Alternet.Common Namespace

AlterNET Studio WinForms Documented Class Library
Alternet.Common Namespace
Classes
 | Class | Description
Public class | AlphaImageList |
Public class | AlphaImageListHelper | Provides additional functionality for ImageList objects.
Public class | AssemblyReferenceResolver | Provides methods for resolving assembly references.
Public class | AsyncLazyT | Provides support for asynchronous lazy initialization. This type is fully threadsafe.
Public class | Check | Provides assertion functions to check parameters meeting certain requirements.
Public class | ChildProcessTracker | Allows processes to be automatically killed if this parent process unexpectedly quits. This feature requires Windows 8 or greater. On Windows 7, nothing is done.
Public class | ColorCursorHelper | Provides additional functionality for System.Windows.Forms.Cursor objects.
Public class | ColorHelper | Provides additional functionality for System.Drawing.Color objects.
Public class | CommandLinePathResolver |
Public class | Consts | Contains default constants for common requirements.
Public class | ControlUtilities | An utility class to work with controls..
Public class | CueTextBox |
Public class | DesignerCategoryNames | Contains constants for names of Property Grid categories.
Public class | DisplayScaledImage | Chooses between regular and high-DPI image and/or scales images depending on current DPI setting. This class is for single image. See also DisplayScaledImages, DisplayScaledImagesByKey.
Public class | DisplayScaledImages | Chooses between regular and high-DPI image and/or scales images depending on current DPI setting. This class is for image list. See also DisplayScaledImagesByKey, DisplayScaledImage.
Public class | DisplayScaledImagesByKeyTKey | Chooses between regular and high-DPI image and/or scales images depending on current DPI setting. This class is for images indexed by key. See also DisplayScaledImages, DisplayScaledImage.
Public class | DisplayScaledImagesEx | Chooses between regular and high-DPI image and/or scales images depending on current DPI setting. This class is for image list. See also DisplayScaledImagesByKey, DisplayScaledImage.
Public class | EnumerableExtensions | Contains extended functionality for enumerable objects.
Public class | ErrorHandler | Represents class that can react various ways for erroneous situations. This class is used internally for exceptions handling.
Public class | FileRange | Represents a location in source code.
Public class | FileSystemUtility |
Public class | FlickerFreeListBox | Provides flicker free ListBox.
Public class | FontInfo | Represents information about a particular font.
Public class | FontInfos | Represents collection of FontInfo elements.
Public class | GdiFontInfo | Represents information about a particular Gdi font.
Public class | GdiFontInfos | Represents collection of GdiFontInfo elements.
Public class | GdiPainter | Encapsulates a Gdi drawing surface, providing properties and methods used to draw text and graphic primitives.
Public class | GraphicsExtensions | Contains extended functionality for drawing surface.
Public class | ImageListHelper | Provides additional functionality for ImageList objects.
Public class | KeysExtensions | Contains extension methods for Keys object.
Public class | ListComparer |
Public class | MathUtilities | Contains extended functionality for mathematic operations.
Public class | MouseUtilities | An utility class to handle mouse events.
Public class | OSUtils | Represents native Win32 API methods.
Public class | Painter | Encapsulates a drawing surface, providing properties and methods used to draw text and graphic primitives.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType | Represents a base class holds various resources used in drawing surfaces. This class is abstract.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription | Provides a base class for brush resource description. This class is abstract.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType | Represents a base class contains embedded resource description.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription | Provides an embedded resource description for image objects.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription | Provides an embedded resource description for image list objects.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription | Provides a base class for pen resource description. This class is abstract.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescriptionTType | Represents a base class contains resource description. This class is abstract.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription | Provides a resource description for brush objects.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription | Provides a resource description for pen objects.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle | Represents a particular text style.
Public class | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription | Provides an embedded resource description for text style objects.
Public class | PathUtilities | An utility class for computing relative paths.
Public class | ProcessUtilities |
Public class | ProductInformation | Represent information about AlterNET product.
Public class | ProgressDialog |
Public class | PropertyChangedEventArgsT | Provides data for the ISyntaxEdit.SourceChanged event.
Public class | Range | Represents an pair of two points that defines a scope in a two-dimensional plane.
Public class | RangeList | Represents sorted list of ranges.
Public class | RectangleExtensions | Contains extended functionality for System.Drawing.Rectangle objects.
Public class | Result | Represents information about the success or failure of particular action.
Public class | ResultT | Provides generic version of Alternet.Common.Result.
Public class | SortListT | Represents sorted list of objects.
Public class | SortRange | Represents a container for a sorted collection of IRange objects.
Public class | SpeedButton | Represents a Windows button - like control.
Public class | StreamExtensions | Contains extension methods for Stream object.
Public class | StringConsts | Contains localizable string constants.
Public class | StringExtensions | Contains extended methods for string objects.
Public class | SymbolLocation | Represents information about location of the code symbol.
Public class | ThreadStaticListT | This item supports the framework infrastructure and is not intended to be used directly from your code.
Public class | TreeViewHelper |
Public class | Utilities | An utility class to dispose object and resources.
Public class | WaitHandleExtensions |
Public class | XPThemes | This class provides functionality to draw control's background with various visual styles.
Structures
 | Structure | Description
Public structure | ChildProcessTrackerIO_COUNTERS |
Public structure | ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION |
Public structure | ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION |
Public structure | OSUtilsCWPSTRUCT | Defines the message parameters passed to a WH_CALLWNDPROC hook procedure, CallWndProc.
Interfaces
 | Interface | Description
Public interface | IControl | Represents standard control properties and methods.
Public interface | IFileRange | Represents a location in source code.
Public interface | INotifier | Represents method that informs object about changes in linked objects.
Public interface | INotify | Represents properties and methods to manage notification between objects.
Public interface | IPainter | Encapsulates a drawing surface, providing properties and methods used to draw text and graphic primitives.
Public interface | IRange | Represents an pair of two points that defines a scope in a two-dimensional plane.
Public interface | IRangeList | Represents a sorted collection of IRange objects that can be individually accessed by index.
Public interface | ISerializationInfo | Represents methods to serialize objects.
Public interface | ISortListT | Represents a sorted collection of objects that can be individually accessed by index.
Public interface | ISortRange | Represents an container for a collection of IRangeobjects.
Public interface | IUpdate | Represents properties and methods of updateable objects.
Delegates
 | Delegate | Description
Public delegate | DisplayScaledImagesByKeyTKeyGetImageFunc | Get image delegate.
Public delegate | EnumChildProc | Represents a method that will handle application-defined function used with the EnumWindows or EnumDesktopWindows functions.
Public delegate | HookHandler | Represents a method that will handle application-defined or library-defined callback function the system calls.
Enumerations
 | Enumeration | Description
Public enumeration | ControlState | Defines control state. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | EditBorderStyle | Specifies the border style for Edit control.
Public enumeration | ErrorBehavior | Defines types of reaction on error.
Public enumeration | JobObjectInfoType |
Public enumeration | JOBOBJECTLIMIT |
Public enumeration | TargetNETFrameworkVersion | Specifies version of the .NET Framework to be used for locating Framework assemblies.
Public enumeration | TechnologyEnvironment | Specifies platform to be used for code completion.
Public enumeration | XPThemeName | Represents color theme names.


AlphaImageList Class

AlphaImageList Class
Inheritance Hierarchy
SystemObject
Alternet.CommonAlphaImageList

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AlphaImageList : IDisposable
Public Class AlphaImageList
    Implements IDisposable
public ref class AlphaImageList : IDisposable
type AlphaImageList =
    class
        interface IDisposable
    end

The AlphaImageList type exposes the following members.

Constructors
 | Name | Description
Public method | AlphaImageList(IEnumerableImage) | Initializes a new instance of the AlphaImageList class
Public method | AlphaImageList(Image) | Initializes a new instance of the AlphaImageList class
Public method | AlphaImageList(IEnumerableImage, Size) | Initializes a new instance of the AlphaImageList class
Public method | AlphaImageList(Image, Int32) | Initializes a new instance of the AlphaImageList class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AlphaImageList
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Images |
Public property | ImageSize |
Top
See Also

Reference

Alternet.Common Namespace


AlphaImageList Constructor

AlphaImageList Constructor
Overload List
 | Name | Description
Public method | AlphaImageList(IEnumerableImage) | Initializes a new instance of the AlphaImageList class
Public method | AlphaImageList(Image) | Initializes a new instance of the AlphaImageList class
Public method | AlphaImageList(IEnumerableImage, Size) | Initializes a new instance of the AlphaImageList class
Public method | AlphaImageList(Image, Int32) | Initializes a new instance of the AlphaImageList class
Top
See Also

Reference

AlphaImageList Class
Alternet.Common Namespace


AlphaImageList Constructor (IEnumerable(Image))

AlphaImageList Constructor (IEnumerableImage)
Initializes a new instance of the AlphaImageList class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphaImageList(
    IEnumerable<Image> images
)
Public Sub New (
    images As IEnumerable(Of Image)
)
public:
AlphaImageList(
    IEnumerable<Image^>^ images
)
new :
        images : IEnumerable<Image> -> AlphaImageList

Parameters

images
Type: System.Collections.GenericIEnumerable Image
See Also

Reference

AlphaImageList Class
AlphaImageList Overload
Alternet.Common Namespace


AlphaImageList Constructor (Image)

AlphaImageList Constructor (Image)
Initializes a new instance of the AlphaImageList class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphaImageList(
    Image stripImage
)
Public Sub New (
    stripImage As Image
)
public:
AlphaImageList(
    Image^ stripImage
)
new :
        stripImage : Image -> AlphaImageList

Parameters

stripImage
Type: System.DrawingImage
See Also

Reference

AlphaImageList Class
AlphaImageList Overload
Alternet.Common Namespace


AlphaImageList Constructor (IEnumerable(Image), Size)

AlphaImageList Constructor (IEnumerableImage, Size)
Initializes a new instance of the AlphaImageList class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphaImageList(
    IEnumerable<Image> images,
    Size size
)
Public Sub New (
    images As IEnumerable(Of Image),
    size As Size
)
public:
AlphaImageList(
    IEnumerable<Image^>^ images,
    Size size
)
new :
        images : IEnumerable<Image> *
        size : Size -> AlphaImageList

Parameters

images
Type: System.Collections.GenericIEnumerable Image
size
Type: System.DrawingSize
See Also

Reference

AlphaImageList Class
AlphaImageList Overload
Alternet.Common Namespace


AlphaImageList Constructor (Image, Int32)

AlphaImageList Constructor (Image, Int32)
Initializes a new instance of the AlphaImageList class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphaImageList(
    Image stripImage,
    int imageWidth
)
Public Sub New (
    stripImage As Image,
    imageWidth As Integer
)
public:
AlphaImageList(
    Image^ stripImage,
    int imageWidth
)
new :
        stripImage : Image *
        imageWidth : int -> AlphaImageList

Parameters

stripImage
Type: System.DrawingImage
imageWidth
Type: SystemInt32
See Also

Reference

AlphaImageList Class
AlphaImageList Overload
Alternet.Common Namespace


AlphaImageList Methods

AlphaImageList Methods

The AlphaImageList type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AlphaImageList Class
Alternet.Common Namespace


AlphaImageList.Dispose Method

AlphaImageListDispose Method
Releases all resources used by the AlphaImageList

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AlphaImageList Class
Alternet.Common Namespace


AlphaImageList Properties

AlphaImageList Properties

The AlphaImageList type exposes the following members.

Properties
 | Name | Description
Public property | Images |
Public property | ImageSize |
Top
See Also

Reference

AlphaImageList Class
Alternet.Common Namespace


AlphaImageList.Images Property

AlphaImageListImages Property

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyList<Image> Images { get; }
Public ReadOnly Property Images As IReadOnlyList(Of Image)
    Get
public:
property IReadOnlyList<Image^>^ Images {
    IReadOnlyList<Image^>^ get ();
}
member Images : IReadOnlyList<Image> with get

Property Value

Type: IReadOnlyList Image
See Also

Reference

AlphaImageList Class
Alternet.Common Namespace


AlphaImageList.ImageSize Property

AlphaImageListImageSize Property

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Size ImageSize { get; }
Public ReadOnly Property ImageSize As Size
    Get
public:
property Size ImageSize {
    Size get ();
}
member ImageSize : Size with get

Property Value

Type: Size
See Also

Reference

AlphaImageList Class
Alternet.Common Namespace


AlphaImageListHelper Class

AlphaImageListHelper Class
Provides additional functionality for ImageList objects.
Inheritance Hierarchy
SystemObject
Alternet.CommonAlphaImageListHelper

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AlphaImageListHelper
Public NotInheritable Class AlphaImageListHelper
public ref class AlphaImageListHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AlphaImageListHelper =  class end

The AlphaImageListHelper type exposes the following members.

Methods
Name | Description
LoadImageListFromStrip | Creates an ImageList from specified resource.
TryLoadImageListFromStrip | Tries to create an ImageList from specified resource.
Top
See Also

Reference

Alternet.Common Namespace


AlphaImageListHelper Methods

AlphaImageListHelper Methods

The AlphaImageListHelper type exposes the following members.

Methods
Name | Description
LoadImageListFromStrip | Creates an ImageList from specified resource.
TryLoadImageListFromStrip | Tries to create an ImageList from specified resource.
Top
See Also

Reference

AlphaImageListHelper Class
Alternet.Common Namespace


AlphaImageListHelper.LoadImageListFromStrip Method

AlphaImageListHelperLoadImageListFromStrip Method
Creates an ImageList from specified resource.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AlphaImageList LoadImageListFromStrip(
    Assembly assembly,
    string resourceName
)
Public Shared Function LoadImageListFromStrip (
    assembly As Assembly,
    resourceName As String
) As AlphaImageList
public:
static AlphaImageList^ LoadImageListFromStrip(
    Assembly^ assembly,
    String^ resourceName
)
static member LoadImageListFromStrip :
        assembly : Assembly *
        resourceName : string -> AlphaImageList

Parameters

assembly
Type: System.ReflectionAssembly
Assembly contains specified resource.
resourceName
Type: SystemString
Name of resource stores stripped image list.

Return Value

Type: AlphaImageList
System.Windows.Forms.ImageList contains images from resource.
See Also

Reference

AlphaImageListHelper Class
Alternet.Common Namespace


AlphaImageListHelper.TryLoadImageListFromStrip Method

AlphaImageListHelperTryLoadImageListFromStrip Method
Tries to create an ImageList from specified resource.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AlphaImageList TryLoadImageListFromStrip(
    Assembly assembly,
    string resourceName
)
Public Shared Function TryLoadImageListFromStrip (
    assembly As Assembly,
    resourceName As String
) As AlphaImageList
public:
static AlphaImageList^ TryLoadImageListFromStrip(
    Assembly^ assembly,
    String^ resourceName
)
static member TryLoadImageListFromStrip :
        assembly : Assembly *
        resourceName : string -> AlphaImageList

Parameters

assembly
Type: System.ReflectionAssembly
Assembly contains specified resource.
resourceName
Type: SystemString
Name of resource stores stripped image list.

Return Value

Type: AlphaImageList
System.Windows.Forms.ImageList contains images from resource.
See Also

Reference

AlphaImageListHelper Class
Alternet.Common Namespace


AssemblyReferenceResolver Class

AssemblyReferenceResolver Class
Provides methods for resolving assembly references.
Inheritance Hierarchy
SystemObject
Alternet.CommonAssemblyReferenceResolver
Alternet.FormDesigner.WinFormsFormDesignerAssemblyReferenceResolver

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyReferenceResolver
Public Class AssemblyReferenceResolver
public ref class AssemblyReferenceResolver
type AssemblyReferenceResolver =  class end

The AssemblyReferenceResolver type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyReferenceResolver | Initializes a new instance of the AssemblyReferenceResolver class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPathToDotNetFrameworkReferenceAssemblies | Returns path to the .NET Framework clr.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResolveAssemblyName | Try to find real assembly name matches the given name.
Public method | ResolveReference | Returns assembly reference accordingly to specified parameters.
Public method | ResolveReferenceAssemblyName | Returns assembly reference name accordingly to specified parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseDirectory | Gets the base directory that the assembly resolver uses to look for assemblies.
Public property | FrameworkPath | Gets location of .NET Framework assemblies.
Public property | SearchPaths | Gets list of search directories to look for source files and referenced assemblies.
Top
See Also

Reference

Alternet.Common Namespace


AssemblyReferenceResolver Constructor

AssemblyReferenceResolver Constructor
Initializes a new instance of the AssemblyReferenceResolver class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AssemblyReferenceResolver(
    IEnumerable<string> searchPaths,
    string frameworkPath,
    string baseDirectory
)
Public Sub New (
    searchPaths As IEnumerable(Of String),
    frameworkPath As String,
    baseDirectory As String
)
public:
AssemblyReferenceResolver(
    IEnumerable<String^>^ searchPaths,
    String^ frameworkPath,
    String^ baseDirectory
)
new :
        searchPaths : IEnumerable<string> *
        frameworkPath : string *
        baseDirectory : string -> AssemblyReferenceResolver

Parameters

searchPaths
Type: System.Collections.GenericIEnumerable String
List of search directories to look for source files and referenced assemblies.
frameworkPath
Type: SystemString
Location of .NET Framework assemblies.
baseDirectory
Type: SystemString
The base directory that the assembly resolver uses to probe for assemblies.
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AssemblyReferenceResolver Methods

AssemblyReferenceResolver Methods

The AssemblyReferenceResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPathToDotNetFrameworkReferenceAssemblies | Returns path to the .NET Framework clr.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResolveAssemblyName | Try to find real assembly name matches the given name.
Public method | ResolveReference | Returns assembly reference accordingly to specified parameters.
Public method | ResolveReferenceAssemblyName | Returns assembly reference name accordingly to specified parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AssemblyReferenceResolver.GetPathToDotNetFrameworkReferenceAssemblies Method

AssemblyReferenceResolverGetPathToDotNetFrameworkReferenceAssemblies Method
Returns path to the .NET Framework clr.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetPathToDotNetFrameworkReferenceAssemblies(
    TargetNETFrameworkVersion version
)
Public Shared Function GetPathToDotNetFrameworkReferenceAssemblies (
    version As TargetNETFrameworkVersion
) As String
public:
static String^ GetPathToDotNetFrameworkReferenceAssemblies(
    TargetNETFrameworkVersion version
)
static member GetPathToDotNetFrameworkReferenceAssemblies :
        version : TargetNETFrameworkVersion -> string

Parameters

version
Type: Alternet.CommonTargetNETFrameworkVersion
.NET Framework version

Return Value

Type: String
path to the .NET framework
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AssemblyReferenceResolver.ResolveAssemblyName Method

AssemblyReferenceResolverResolveAssemblyName Method
Try to find real assembly name matches the given name.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ResolveAssemblyName(
    string name,
    IDefaultAssembliesProvider defaultAssembliesProvider
)
Public Overridable Function ResolveAssemblyName (
    name As String,
    defaultAssembliesProvider As IDefaultAssembliesProvider
) As String
public:
virtual String^ ResolveAssemblyName(
    String^ name,
    IDefaultAssembliesProvider^ defaultAssembliesProvider
)
abstract ResolveAssemblyName :
        name : string *
        defaultAssembliesProvider : IDefaultAssembliesProvider -> string
override ResolveAssemblyName :
        name : string *
        defaultAssembliesProvider : IDefaultAssembliesProvider -> string

Parameters

name
Type: SystemString
Short assembly name.
defaultAssembliesProvider
Type: Alternet.Common.DotNet.DefaultAssembliesIDefaultAssembliesProvider
Default assembly provider.

Return Value

Type: String
Full assembly name if succeed; otherwise empty string.
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AssemblyReferenceResolver.ResolveReference Method

AssemblyReferenceResolverResolveReference Method
Returns assembly reference accordingly to specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ResolveReference(
    string reference,
    string baseFilePath,
    bool searchInGAC,
    TargetFramework targetFramework = null
)
Public Function ResolveReference (
    reference As String,
    baseFilePath As String,
    searchInGAC As Boolean,
    Optional targetFramework As TargetFramework = Nothing
) As String
public:
String^ ResolveReference(
    String^ reference,
    String^ baseFilePath,
    bool searchInGAC,
    TargetFramework^ targetFramework = nullptr
)
member ResolveReference :
        reference : string *
        baseFilePath : string *
        searchInGAC : bool *
        ?targetFramework : TargetFramework
(* Defaults:
        let _targetFramework = defaultArg targetFramework null
*)
-> string

Parameters

reference
Type: SystemString
Default assembly reference.
baseFilePath
Type: SystemString
The base directory used to probe for assembly.
searchInGAC
Type: SystemBoolean
Specifies if assembly can be located in GAC.
targetFramework (Optional)
Type: Alternet.Common.DotNet.ProjectsTargetFramework
Specifies Target framework.

Return Value

Type: String
Fully qualified name of found assembly.
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AssemblyReferenceResolver.ResolveReferenceAssemblyName Method

AssemblyReferenceResolverResolveReferenceAssemblyName Method
Returns assembly reference name accordingly to specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AssemblyName ResolveReferenceAssemblyName(
    string reference,
    string baseFilePath,
    bool searchInGAC,
    TargetFramework targetFramework = null
)
Public Function ResolveReferenceAssemblyName (
    reference As String,
    baseFilePath As String,
    searchInGAC As Boolean,
    Optional targetFramework As TargetFramework = Nothing
) As AssemblyName
public:
AssemblyName^ ResolveReferenceAssemblyName(
    String^ reference,
    String^ baseFilePath,
    bool searchInGAC,
    TargetFramework^ targetFramework = nullptr
)
member ResolveReferenceAssemblyName :
        reference : string *
        baseFilePath : string *
        searchInGAC : bool *
        ?targetFramework : TargetFramework
(* Defaults:
        let _targetFramework = defaultArg targetFramework null
*)
-> AssemblyName

Parameters

reference
Type: SystemString
Default assembly reference.
baseFilePath
Type: SystemString
The base directory used to probe for assembly.
searchInGAC
Type: SystemBoolean
Specifies if assembly can be located in GAC.
targetFramework (Optional)
Type: Alternet.Common.DotNet.ProjectsTargetFramework
Specifies Target framework.

Return Value

Type: AssemblyName
AssemblyName of found assembly.
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AssemblyReferenceResolver Properties

AssemblyReferenceResolver Properties

The AssemblyReferenceResolver type exposes the following members.

Properties
 | Name | Description
Public property | BaseDirectory | Gets the base directory that the assembly resolver uses to look for assemblies.
Public property | FrameworkPath | Gets location of .NET Framework assemblies.
Public property | SearchPaths | Gets list of search directories to look for source files and referenced assemblies.
Top
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AssemblyReferenceResolver.BaseDirectory Property

AssemblyReferenceResolverBaseDirectory Property
Gets the base directory that the assembly resolver uses to look for assemblies.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BaseDirectory { get; }
Public ReadOnly Property BaseDirectory As String
    Get
public:
property String^ BaseDirectory {
    String^ get ();
}
member BaseDirectory : string with get

Property Value

Type: String
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AssemblyReferenceResolver.FrameworkPath Property

AssemblyReferenceResolverFrameworkPath Property
Gets location of .NET Framework assemblies.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FrameworkPath { get; }
Public ReadOnly Property FrameworkPath As String
    Get
public:
property String^ FrameworkPath {
    String^ get ();
}
member FrameworkPath : string with get

Property Value

Type: String
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AssemblyReferenceResolver.SearchPaths Property

AssemblyReferenceResolverSearchPaths Property
Gets list of search directories to look for source files and referenced assemblies.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> SearchPaths { get; }
Public ReadOnly Property SearchPaths As IList(Of String)
    Get
public:
property IList<String^>^ SearchPaths {
    IList<String^>^ get ();
}
member SearchPaths : IList<string> with get

Property Value

Type: IList String
See Also

Reference

AssemblyReferenceResolver Class
Alternet.Common Namespace


AsyncLazy(T) Class

AsyncLazyT Class
Provides support for asynchronous lazy initialization. This type is fully threadsafe.
Inheritance Hierarchy
SystemObject
Alternet.CommonAsyncLazyT

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class AsyncLazy<T>

Public NotInheritable Class AsyncLazy(Of T)
generic<typename T>
public ref class AsyncLazy sealed
[<SealedAttribute>]
type AsyncLazy<'T> =  class end

Type Parameters

T
The type of object that is being asynchronously initialized.

The AsyncLazyT type exposes the following members.

Constructors
 | Name | Description
Public method | AsyncLazyT(FuncTaskT) | Initializes a new instance of the AsyncLazyT class.
Public method | AsyncLazyT(FuncT) | Initializes a new instance of the AsyncLazyT class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAwaiter | Asynchronous infrastructure support. This method permits instances of AsyncLazyT to be await'ed.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Start | Starts the asynchronous initialization, if it has not already started.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common Namespace


AsyncLazy(T) Constructor

AsyncLazyT Constructor
Overload List
 | Name | Description
Public method | AsyncLazyT(FuncTaskT) | Initializes a new instance of the AsyncLazyT class.
Public method | AsyncLazyT(FuncT) | Initializes a new instance of the AsyncLazyT class.
Top
See Also

Reference

AsyncLazyT Class
Alternet.Common Namespace


AsyncLazy(T) Constructor (Func(Task(T)))

AsyncLazyT Constructor (FuncTaskT)
Initializes a new instance of the AsyncLazyT class.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AsyncLazy(
    Func<Task<T>> factory
)
Public Sub New (
    factory As Func(Of Task(Of T))
)
public:
AsyncLazy(
    Func<Task<T>^>^ factory
)
new :
        factory : Func<Task<'T>> -> AsyncLazy

Parameters

factory
Type: SystemFunc Task T
The asynchronous delegate that is invoked on a background thread to produce the value when it is needed.
See Also

Reference

AsyncLazyT Class
AsyncLazyT Overload
Alternet.Common Namespace


AsyncLazy(T) Constructor (Func(T))

AsyncLazyT Constructor (FuncT)
Initializes a new instance of the AsyncLazyT class.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AsyncLazy(
    Func<T> factory
)
Public Sub New (
    factory As Func(Of T)
)
public:
AsyncLazy(
    Func<T>^ factory
)
new :
        factory : Func<'T> -> AsyncLazy

Parameters

factory
Type: SystemFunc T
The delegate that is invoked on a background thread to produce the value when it is needed.
See Also

Reference

AsyncLazyT Class
AsyncLazyT Overload
Alternet.Common Namespace


AsyncLazy(T) Methods

AsyncLazyT Methods

The AsyncLazyT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAwaiter | Asynchronous infrastructure support. This method permits instances of AsyncLazyT to be await'ed.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Start | Starts the asynchronous initialization, if it has not already started.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AsyncLazyT Class
Alternet.Common Namespace


AsyncLazy(T).GetAwaiter Method

AsyncLazyTGetAwaiter Method
Asynchronous infrastructure support. This method permits instances of AsyncLazyT to be await'ed.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TaskAwaiter<T> GetAwaiter()
Public Function GetAwaiter As TaskAwaiter(Of T)
public:
TaskAwaiter<T> GetAwaiter()
member GetAwaiter : unit -> TaskAwaiter<'T>

Return Value

Type: TaskAwaiterT
See Also

Reference

AsyncLazyT Class
Alternet.Common Namespace


AsyncLazy(T).Start Method

AsyncLazyTStart Method
Starts the asynchronous initialization, if it has not already started.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Start()
Public Sub Start
public:
void Start()
member Start : unit -> unit
See Also

Reference

AsyncLazyT Class
Alternet.Common Namespace


Check Class

Check Class
Provides assertion functions to check parameters meeting certain requirements.
Inheritance Hierarchy
SystemObject
Alternet.CommonCheck

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Check
Public NotInheritable Class Check
public ref class Check abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Check =  class end

The Check type exposes the following members.

Methods
Name | Description
Assert | Checks for the condition. If the condition is false throws an exception.
GetEnumValueNotSupportedExceptionT | Raises an exception informs that specified enumeration value is not supported.
NonNull | Checks whether specified object is not null. If object is null throws an exception.
NonNullOrEmpty(IEnumerable, String) | Checks whether specified value is not null or an empty value. If value is null or empty throws an exception.
NonNullOrEmpty(String, String) | Checks whether specified string is not null or an empty string. If string is null or empty throws an exception.
Verify | Verifies the condition. If the condition is false throws an exception.
Top
See Also

Reference

Alternet.Common Namespace


Check Methods

Check Methods

The Check type exposes the following members.

Methods
Name | Description
Assert | Checks for the condition. If the condition is false throws an exception.
GetEnumValueNotSupportedExceptionT | Raises an exception informs that specified enumeration value is not supported.
NonNull | Checks whether specified object is not null. If object is null throws an exception.
NonNullOrEmpty(IEnumerable, String) | Checks whether specified value is not null or an empty value. If value is null or empty throws an exception.
NonNullOrEmpty(String, String) | Checks whether specified string is not null or an empty string. If string is null or empty throws an exception.
Verify | Verifies the condition. If the condition is false throws an exception.
Top
See Also

Reference

Check Class
Alternet.Common Namespace


Check.Assert Method

CheckAssert Method
Checks for the condition. If the condition is false throws an exception.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Assert(
    bool condition
)
Public Shared Sub Assert (
    condition As Boolean
)
public:
static void Assert(
    bool condition
)
static member Assert :
        condition : bool -> unit

Parameters

condition
Type: SystemBoolean
Condition to check.
See Also

Reference

Check Class
Alternet.Common Namespace


Check.GetEnumValueNotSupportedException(T) Method

CheckGetEnumValueNotSupportedExceptionT Method
Raises an exception informs that specified enumeration value is not supported.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Exception GetEnumValueNotSupportedException<T>(
    T value
)
where T : struct, new()

Public Shared Function GetEnumValueNotSupportedException(Of T As {Structure, New}) (
    value As T
) As Exception
public:
generic<typename T>
where T : value class, gcnew()
static Exception^ GetEnumValueNotSupportedException(
    T value
)
static member GetEnumValueNotSupportedException :
        value : 'T -> Exception  when 'T : struct, new()

Parameters

value
Type: T
The enumerated value.

Type Parameters

T
The type of the value.

Return Value

Type: Exception
Exception contains information about value.
See Also

Reference

Check Class
Alternet.Common Namespace


Check.NonNull Method

CheckNonNull Method
Checks whether specified object is not null. If object is null throws an exception.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void NonNull(
    Object obj,
    string parameterName
)
Public Shared Sub NonNull (
    obj As Object,
    parameterName As String
)
public:
static void NonNull(
    Object^ obj,
    String^ parameterName
)
static member NonNull :
        obj : Object *
        parameterName : string -> unit

Parameters

obj
Type: SystemObject
Object to examine.
parameterName
Type: SystemString
The name of the parameter that caused the exception.
See Also

Reference

Check Class
Alternet.Common Namespace


Check.NonNullOrEmpty Method

CheckNonNullOrEmpty Method
Overload List
Name | Description
NonNullOrEmpty(IEnumerable, String) | Checks whether specified value is not null or an empty value. If value is null or empty throws an exception.
NonNullOrEmpty(String, String) | Checks whether specified string is not null or an empty string. If string is null or empty throws an exception.
Top
See Also

Reference

Check Class
Alternet.Common Namespace


Check.NonNullOrEmpty Method (IEnumerable, String)

CheckNonNullOrEmpty Method (IEnumerable, String)
Checks whether specified value is not null or an empty value. If value is null or empty throws an exception.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void NonNullOrEmpty(
    IEnumerable value,
    string parameterName
)
Public Shared Sub NonNullOrEmpty (
    value As IEnumerable,
    parameterName As String
)
public:
static void NonNullOrEmpty(
    IEnumerable^ value,
    String^ parameterName
)
static member NonNullOrEmpty :
        value : IEnumerable *
        parameterName : string -> unit

Parameters

value
Type: System.CollectionsIEnumerable
IEnumerable to examine.
parameterName
Type: SystemString
The name of the parameter that caused the exception.
See Also

Reference

Check Class
NonNullOrEmpty Overload
Alternet.Common Namespace


Check.NonNullOrEmpty Method (String, String)

CheckNonNullOrEmpty Method (String, String)
Checks whether specified string is not null or an empty string. If string is null or empty throws an exception.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void NonNullOrEmpty(
    string str,
    string parameterName
)
Public Shared Sub NonNullOrEmpty (
    str As String,
    parameterName As String
)
public:
static void NonNullOrEmpty(
    String^ str,
    String^ parameterName
)
static member NonNullOrEmpty :
        str : string *
        parameterName : string -> unit

Parameters

str
Type: SystemString
String to examine.
parameterName
Type: SystemString
The name of the parameter that caused the exception.
See Also

Reference

Check Class
NonNullOrEmpty Overload
Alternet.Common Namespace


Check.Verify Method

CheckVerify Method
Verifies the condition. If the condition is false throws an exception.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Verify(
    bool condition
)
Public Shared Sub Verify (
    condition As Boolean
)
public:
static void Verify(
    bool condition
)
static member Verify :
        condition : bool -> unit

Parameters

condition
Type: SystemBoolean
Condition to check.
See Also

Reference

Check Class
Alternet.Common Namespace


ChildProcessTracker Class

ChildProcessTracker Class
Allows processes to be automatically killed if this parent process unexpectedly quits. This feature requires Windows 8 or greater. On Windows 7, nothing is done.
Inheritance Hierarchy
SystemObject
Alternet.CommonChildProcessTracker

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ChildProcessTracker
Public NotInheritable Class ChildProcessTracker
public ref class ChildProcessTracker abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ChildProcessTracker =  class end

The ChildProcessTracker type exposes the following members.

Methods
Name | Description
AddProcess | Add the process to be tracked. If our current process is killed, the child processes that we are tracking will be automatically killed, too. If the child process terminates first, that's fine, too.
Top
Remarks
References: https://stackoverflow.com/a/4657392/386091 https://stackoverflow.com/a/9164742/386091
See Also

Reference

Alternet.Common Namespace


ChildProcessTracker Methods

ChildProcessTracker Methods

The ChildProcessTracker type exposes the following members.

Methods
Name | Description
AddProcess | Add the process to be tracked. If our current process is killed, the child processes that we are tracking will be automatically killed, too. If the child process terminates first, that's fine, too.
Top
See Also

Reference

ChildProcessTracker Class
Alternet.Common Namespace


ChildProcessTracker.AddProcess Method

ChildProcessTrackerAddProcess Method
Add the process to be tracked. If our current process is killed, the child processes that we are tracking will be automatically killed, too. If the child process terminates first, that's fine, too.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddProcess(
    Process process
)
Public Shared Sub AddProcess (
    process As Process
)
public:
static void AddProcess(
    Process^ process
)
static member AddProcess :
        process : Process -> unit

Parameters

process
Type: System.DiagnosticsProcess
See Also

Reference

ChildProcessTracker Class
Alternet.Common Namespace


ChildProcessTracker.IO_COUNTERS Structure

ChildProcessTrackerIO_COUNTERS Structure

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct IO_COUNTERS
Public Structure IO_COUNTERS
public value class IO_COUNTERS
[<SealedAttribute>]
type IO_COUNTERS =  struct end

The ChildProcessTrackerIO_COUNTERS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | OtherOperationCount |
Public field | OtherTransferCount |
Public field | ReadOperationCount |
Public field | ReadTransferCount |
Public field | WriteOperationCount |
Public field | WriteTransferCount |
Top
See Also

Reference

Alternet.Common Namespace


IO_COUNTERS Fields

IO_COUNTERS Fields

The ChildProcessTrackerIO_COUNTERS type exposes the following members.

Fields
 | Name | Description
Public field | OtherOperationCount |
Public field | OtherTransferCount |
Public field | ReadOperationCount |
Public field | ReadTransferCount |
Public field | WriteOperationCount |
Public field | WriteTransferCount |
Top
See Also

Reference

ChildProcessTrackerIO_COUNTERS Structure
Alternet.Common Namespace


ChildProcessTracker.IO_COUNTERS.OtherOperationCount Field

ChildProcessTrackerIO_COUNTERSOtherOperationCount Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong OtherOperationCount
Public OtherOperationCount As ULong
public:
unsigned long long OtherOperationCount
val mutable OtherOperationCount: uint64

Field Value

Type: UInt64
See Also

Reference

ChildProcessTrackerIO_COUNTERS Structure
Alternet.Common Namespace


ChildProcessTracker.IO_COUNTERS.OtherTransferCount Field

ChildProcessTrackerIO_COUNTERSOtherTransferCount Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong OtherTransferCount
Public OtherTransferCount As ULong
public:
unsigned long long OtherTransferCount
val mutable OtherTransferCount: uint64

Field Value

Type: UInt64
See Also

Reference

ChildProcessTrackerIO_COUNTERS Structure
Alternet.Common Namespace


ChildProcessTracker.IO_COUNTERS.ReadOperationCount Field

ChildProcessTrackerIO_COUNTERSReadOperationCount Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong ReadOperationCount
Public ReadOperationCount As ULong
public:
unsigned long long ReadOperationCount
val mutable ReadOperationCount: uint64

Field Value

Type: UInt64
See Also

Reference

ChildProcessTrackerIO_COUNTERS Structure
Alternet.Common Namespace


ChildProcessTracker.IO_COUNTERS.ReadTransferCount Field

ChildProcessTrackerIO_COUNTERSReadTransferCount Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong ReadTransferCount
Public ReadTransferCount As ULong
public:
unsigned long long ReadTransferCount
val mutable ReadTransferCount: uint64

Field Value

Type: UInt64
See Also

Reference

ChildProcessTrackerIO_COUNTERS Structure
Alternet.Common Namespace


ChildProcessTracker.IO_COUNTERS.WriteOperationCount Field

ChildProcessTrackerIO_COUNTERSWriteOperationCount Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong WriteOperationCount
Public WriteOperationCount As ULong
public:
unsigned long long WriteOperationCount
val mutable WriteOperationCount: uint64

Field Value

Type: UInt64
See Also

Reference

ChildProcessTrackerIO_COUNTERS Structure
Alternet.Common Namespace


ChildProcessTracker.IO_COUNTERS.WriteTransferCount Field

ChildProcessTrackerIO_COUNTERSWriteTransferCount Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong WriteTransferCount
Public WriteTransferCount As ULong
public:
unsigned long long WriteTransferCount
val mutable WriteTransferCount: uint64

Field Value

Type: UInt64
See Also

Reference

ChildProcessTrackerIO_COUNTERS Structure
Alternet.Common Namespace


IO_COUNTERS Methods

IO_COUNTERS Methods

The ChildProcessTrackerIO_COUNTERS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ChildProcessTrackerIO_COUNTERS Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION Structure

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct JOBOBJECT_BASIC_LIMIT_INFORMATION
Public Structure JOBOBJECT_BASIC_LIMIT_INFORMATION
public value class JOBOBJECT_BASIC_LIMIT_INFORMATION
[<SealedAttribute>]
type JOBOBJECT_BASIC_LIMIT_INFORMATION =  struct end

The ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | ActiveProcessLimit |
Public field | Affinity |
Public field | LimitFlags |
Public field | MaximumWorkingSetSize |
Public field | MinimumWorkingSetSize |
Public field | PerJobUserTimeLimit |
Public field | PerProcessUserTimeLimit |
Public field | PriorityClass |
Public field | SchedulingClass |
Top
See Also

Reference

Alternet.Common Namespace


JOBOBJECT_BASIC_LIMIT_INFORMATION Fields

JOBOBJECT_BASIC_LIMIT_INFORMATION Fields

The ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION type exposes the following members.

Fields
 | Name | Description
Public field | ActiveProcessLimit |
Public field | Affinity |
Public field | LimitFlags |
Public field | MaximumWorkingSetSize |
Public field | MinimumWorkingSetSize |
Public field | PerJobUserTimeLimit |
Public field | PerProcessUserTimeLimit |
Public field | PriorityClass |
Public field | SchedulingClass |
Top
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION.ActiveProcessLimit Field

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATIONActiveProcessLimit Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint ActiveProcessLimit
Public ActiveProcessLimit As UInteger
public:
unsigned int ActiveProcessLimit
val mutable ActiveProcessLimit: uint32

Field Value

Type: UInt32
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION.Affinity Field

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATIONAffinity Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Affinity
Public Affinity As Long
public:
long long Affinity
val mutable Affinity: int64

Field Value

Type: Int64
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION.LimitFlags Field

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATIONLimitFlags Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JOBOBJECTLIMIT LimitFlags
Public LimitFlags As JOBOBJECTLIMIT
public:
JOBOBJECTLIMIT LimitFlags
val mutable LimitFlags: JOBOBJECTLIMIT

Field Value

Type: JOBOBJECTLIMIT
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION.MaximumWorkingSetSize Field

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATIONMaximumWorkingSetSize Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UIntPtr MaximumWorkingSetSize
Public MaximumWorkingSetSize As UIntPtr
public:
UIntPtr MaximumWorkingSetSize
val mutable MaximumWorkingSetSize: UIntPtr

Field Value

Type: UIntPtr
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION.MinimumWorkingSetSize Field

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATIONMinimumWorkingSetSize Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UIntPtr MinimumWorkingSetSize
Public MinimumWorkingSetSize As UIntPtr
public:
UIntPtr MinimumWorkingSetSize
val mutable MinimumWorkingSetSize: UIntPtr

Field Value

Type: UIntPtr
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION.PerJobUserTimeLimit Field

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATIONPerJobUserTimeLimit Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public long PerJobUserTimeLimit
Public PerJobUserTimeLimit As Long
public:
long long PerJobUserTimeLimit
val mutable PerJobUserTimeLimit: int64

Field Value

Type: Int64
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION.PerProcessUserTimeLimit Field

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATIONPerProcessUserTimeLimit Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public long PerProcessUserTimeLimit
Public PerProcessUserTimeLimit As Long
public:
long long PerProcessUserTimeLimit
val mutable PerProcessUserTimeLimit: int64

Field Value

Type: Int64
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION.PriorityClass Field

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATIONPriorityClass Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint PriorityClass
Public PriorityClass As UInteger
public:
unsigned int PriorityClass
val mutable PriorityClass: uint32

Field Value

Type: UInt32
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_BASIC_LIMIT_INFORMATION.SchedulingClass Field

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATIONSchedulingClass Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint SchedulingClass
Public SchedulingClass As UInteger
public:
unsigned int SchedulingClass
val mutable SchedulingClass: uint32

Field Value

Type: UInt32
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


JOBOBJECT_BASIC_LIMIT_INFORMATION Methods

JOBOBJECT_BASIC_LIMIT_INFORMATION Methods

The ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct JOBOBJECT_EXTENDED_LIMIT_INFORMATION
Public Structure JOBOBJECT_EXTENDED_LIMIT_INFORMATION
public value class JOBOBJECT_EXTENDED_LIMIT_INFORMATION
[<SealedAttribute>]
type JOBOBJECT_EXTENDED_LIMIT_INFORMATION =  struct end

The ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | BasicLimitInformation |
Public field | IoInfo |
Public field | JobMemoryLimit |
Public field | PeakJobMemoryUsed |
Public field | PeakProcessMemoryUsed |
Public field | ProcessMemoryLimit |
Top
See Also

Reference

Alternet.Common Namespace


JOBOBJECT_EXTENDED_LIMIT_INFORMATION Fields

JOBOBJECT_EXTENDED_LIMIT_INFORMATION Fields

The ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION type exposes the following members.

Fields
 | Name | Description
Public field | BasicLimitInformation |
Public field | IoInfo |
Public field | JobMemoryLimit |
Public field | PeakJobMemoryUsed |
Public field | PeakProcessMemoryUsed |
Public field | ProcessMemoryLimit |
Top
See Also

Reference

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_EXTENDED_LIMIT_INFORMATION.BasicLimitInformation Field

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATIONBasicLimitInformation Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION BasicLimitInformation
Public BasicLimitInformation As ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION
public:
ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION BasicLimitInformation
val mutable BasicLimitInformation: ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION

Field Value

Type: ChildProcessTrackerJOBOBJECT_BASIC_LIMIT_INFORMATION
See Also

Reference

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_EXTENDED_LIMIT_INFORMATION.IoInfo Field

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATIONIoInfo Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ChildProcessTrackerIO_COUNTERS IoInfo
Public IoInfo As ChildProcessTrackerIO_COUNTERS
public:
ChildProcessTrackerIO_COUNTERS IoInfo
val mutable IoInfo: ChildProcessTrackerIO_COUNTERS

Field Value

Type: ChildProcessTrackerIO_COUNTERS
See Also

Reference

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_EXTENDED_LIMIT_INFORMATION.JobMemoryLimit Field

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATIONJobMemoryLimit Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UIntPtr JobMemoryLimit
Public JobMemoryLimit As UIntPtr
public:
UIntPtr JobMemoryLimit
val mutable JobMemoryLimit: UIntPtr

Field Value

Type: UIntPtr
See Also

Reference

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_EXTENDED_LIMIT_INFORMATION.PeakJobMemoryUsed Field

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATIONPeakJobMemoryUsed Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UIntPtr PeakJobMemoryUsed
Public PeakJobMemoryUsed As UIntPtr
public:
UIntPtr PeakJobMemoryUsed
val mutable PeakJobMemoryUsed: UIntPtr

Field Value

Type: UIntPtr
See Also

Reference

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_EXTENDED_LIMIT_INFORMATION.PeakProcessMemoryUsed Field

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATIONPeakProcessMemoryUsed Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UIntPtr PeakProcessMemoryUsed
Public PeakProcessMemoryUsed As UIntPtr
public:
UIntPtr PeakProcessMemoryUsed
val mutable PeakProcessMemoryUsed: UIntPtr

Field Value

Type: UIntPtr
See Also

Reference

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ChildProcessTracker.JOBOBJECT_EXTENDED_LIMIT_INFORMATION.ProcessMemoryLimit Field

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATIONProcessMemoryLimit Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UIntPtr ProcessMemoryLimit
Public ProcessMemoryLimit As UIntPtr
public:
UIntPtr ProcessMemoryLimit
val mutable ProcessMemoryLimit: UIntPtr

Field Value

Type: UIntPtr
See Also

Reference

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure
Alternet.Common Namespace


JOBOBJECT_EXTENDED_LIMIT_INFORMATION Methods

JOBOBJECT_EXTENDED_LIMIT_INFORMATION Methods

The ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ChildProcessTrackerJOBOBJECT_EXTENDED_LIMIT_INFORMATION Structure
Alternet.Common Namespace


ColorCursorHelper Class

ColorCursorHelper Class
Provides additional functionality for System.Windows.Forms.Cursor objects.
Inheritance Hierarchy
SystemObject
Alternet.CommonColorCursorHelper

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ColorCursorHelper
Public NotInheritable Class ColorCursorHelper
public ref class ColorCursorHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ColorCursorHelper =  class end

The ColorCursorHelper type exposes the following members.

Methods
Name | Description
LoadFromResource | Locates the Cursor using specified parameters.
LoadFromStream | Locates the Cursor from specified Stream.
Top
See Also

Reference

Alternet.Common Namespace


ColorCursorHelper Methods

ColorCursorHelper Methods

The ColorCursorHelper type exposes the following members.

Methods
Name | Description
LoadFromResource | Locates the Cursor using specified parameters.
LoadFromStream | Locates the Cursor from specified Stream.
Top
See Also

Reference

ColorCursorHelper Class
Alternet.Common Namespace


ColorCursorHelper.LoadFromResource Method

ColorCursorHelperLoadFromResource Method
Locates the Cursor using specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Cursor LoadFromResource(
    Type type,
    string resource
)
Public Shared Function LoadFromResource (
    type As Type,
    resource As String
) As Cursor
public:
static Cursor^ LoadFromResource(
    Type^ type,
    String^ resource
)
static member LoadFromResource :
        type : Type *
        resource : string -> Cursor

Parameters

type
Type: SystemType
The Type to look for the Cursor.
resource
Type: SystemString
Cursor's resource name.

Return Value

Type: Cursor
The Cursor if succeed.
See Also

Reference

ColorCursorHelper Class
Alternet.Common Namespace


ColorCursorHelper.LoadFromStream Method

ColorCursorHelperLoadFromStream Method
Locates the Cursor from specified Stream.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Cursor LoadFromStream(
    Stream cursorStream
)
Public Shared Function LoadFromStream (
    cursorStream As Stream
) As Cursor
public:
static Cursor^ LoadFromStream(
    Stream^ cursorStream
)
static member LoadFromStream :
        cursorStream : Stream -> Cursor

Parameters

cursorStream
Type: System.IOStream
The Stream to look for the Cursor.

Return Value

Type: Cursor
The Cursor if succeed.
See Also

Reference

ColorCursorHelper Class
Alternet.Common Namespace


ColorHelper Class

ColorHelper Class
Provides additional functionality for System.Drawing.Color objects.
Inheritance Hierarchy
SystemObject
Alternet.CommonColorHelper

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ColorHelper
Public NotInheritable Class ColorHelper
public ref class ColorHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ColorHelper =  class end

The ColorHelper type exposes the following members.

Methods
Name | Description
Blend | Blends the specified colors together.
ColorToHtml | Converts specified color into the HTML format.
FromRgb | Creates a System.Drawing.Color structure from a 32-bit RGB value. The alpha value is 255.
Top
See Also

Reference

Alternet.Common Namespace


ColorHelper Methods

ColorHelper Methods

The ColorHelper type exposes the following members.

Methods
Name | Description
Blend | Blends the specified colors together.
ColorToHtml | Converts specified color into the HTML format.
FromRgb | Creates a System.Drawing.Color structure from a 32-bit RGB value. The alpha value is 255.
Top
See Also

Reference

ColorHelper Class
Alternet.Common Namespace


ColorHelper.Blend Method

ColorHelperBlend Method
Blends the specified colors together.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color Blend(
    Color color,
    Color backColor,
    double amount
)
Public Shared Function Blend (
    color As Color,
    backColor As Color,
    amount As Double
) As Color
public:
static Color Blend(
    Color color,
    Color backColor,
    double amount
)
static member Blend :
        color : Color *
        backColor : Color *
        amount : float -> Color

Parameters

color
Type: System.DrawingColor
Color to blend onto the background color.
backColor
Type: System.DrawingColor
Color to blend the other color onto.
amount
Type: SystemDouble
How much of color to keep, “on top of” backColor.

Return Value

Type: Color
The blended color.
See Also

Reference

ColorHelper Class
Alternet.Common Namespace


ColorHelper.ColorToHtml Method

ColorHelperColorToHtml Method
Converts specified color into the HTML format.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColorToHtml(
    Color color
)
Public Shared Function ColorToHtml (
    color As Color
) As String
public:
static String^ ColorToHtml(
    Color color
)
static member ColorToHtml :
        color : Color -> string

Parameters

color
Type: System.DrawingColor
Color to convert.

Return Value

Type: String
String contains HTML representation of given color.
See Also

Reference

ColorHelper Class
Alternet.Common Namespace


ColorHelper.FromRgb Method

ColorHelperFromRgb Method
Creates a System.Drawing.Color structure from a 32-bit RGB value. The alpha value is 255.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color FromRgb(
    int rgb
)
Public Shared Function FromRgb (
    rgb As Integer
) As Color
public:
static Color FromRgb(
    int rgb
)
static member FromRgb :
        rgb : int -> Color

Parameters

rgb
Type: SystemInt32
A value specifying the 32-bit RGB value.

Return Value

Type: Color
The System.Drawing.Color structure that this method creates.
See Also

Reference

ColorHelper Class
Alternet.Common Namespace


CommandLinePathResolver Class

CommandLinePathResolver Class
Inheritance Hierarchy
SystemObject
Alternet.CommonCommandLinePathResolver

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CommandLinePathResolver
Public NotInheritable Class CommandLinePathResolver
public ref class CommandLinePathResolver abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CommandLinePathResolver =  class end

The CommandLinePathResolver type exposes the following members.

Methods
Name | Description
TryGetFullPathForCommand |
Top
See Also

Reference

Alternet.Common Namespace


CommandLinePathResolver Methods

CommandLinePathResolver Methods

The CommandLinePathResolver type exposes the following members.

Methods
Name | Description
TryGetFullPathForCommand |
Top
See Also

Reference

CommandLinePathResolver Class
Alternet.Common Namespace


CommandLinePathResolver.TryGetFullPathForCommand Method

CommandLinePathResolverTryGetFullPathForCommand Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TryGetFullPathForCommand(
    string command
)
Public Shared Function TryGetFullPathForCommand (
    command As String
) As String
public:
static String^ TryGetFullPathForCommand(
    String^ command
)
static member TryGetFullPathForCommand :
        command : string -> string

Parameters

command
Type: SystemString

Return Value

Type: String
See Also

Reference

CommandLinePathResolver Class
Alternet.Common Namespace


Consts Class

Consts Class
Contains default constants for common requirements.
Inheritance Hierarchy
SystemObject
Alternet.CommonConsts

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Consts
Public Class Consts
public ref class Consts
type Consts =  class end

The Consts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AveChar |
BlueItemsAreaColor |
CR |
CRLF |
CrlfArray |
DefaultControlBackColor |
DefaultControlForeColor |
DefaultHotTrackBackColor |
DefaultHotTrackColor |
DefaultPopupBackColor |
DefaultPopupBorderColor |
DefaultPressedBackColor |
DefaultWindowFrameColor |
DefaultXPHeaderForeColor |
DefaultXPItemsForeColor |
DisregardInternationalSymbols |
Escape |
HiddenStr |
HomeSteadItemsAreaColor |
LF |
LongSpace |
MaxWordLength |
MetallicItemsAreaColor |
Space |
Tab |
TabStr |
Top
See Also

Reference

Alternet.Common Namespace


Consts Fields

Consts Fields

The Consts type exposes the following members.

Fields
Name | Description
AveChar |
BlueItemsAreaColor |
CR |
CRLF |
CrlfArray |
DefaultControlBackColor |
DefaultControlForeColor |
DefaultHotTrackBackColor |
DefaultHotTrackColor |
DefaultPopupBackColor |
DefaultPopupBorderColor |
DefaultPressedBackColor |
DefaultWindowFrameColor |
DefaultXPHeaderForeColor |
DefaultXPItemsForeColor |
DisregardInternationalSymbols |
Escape |
HiddenStr |
HomeSteadItemsAreaColor |
LF |
LongSpace |
MaxWordLength |
MetallicItemsAreaColor |
Space |
Tab |
TabStr |
Top
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.AveChar Field

ConstsAveChar Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const char AveChar
Public Const AveChar As Char
public:
literal wchar_t AveChar
static val mutable AveChar: char

Field Value

Type: Char
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.BlueItemsAreaColor Field

ConstsBlueItemsAreaColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color BlueItemsAreaColor
Public Shared BlueItemsAreaColor As Color
public:
static Color BlueItemsAreaColor
static val mutable BlueItemsAreaColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.CR Field

ConstsCR Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const char CR
Public Const CR As Char
public:
literal wchar_t CR
static val mutable CR: char

Field Value

Type: Char
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.CRLF Field

ConstsCRLF Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string CRLF
Public Const CRLF As String
public:
literal String^ CRLF
static val mutable CRLF: string

Field Value

Type: String
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.CrlfArray Field

ConstsCrlfArray Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char[] CrlfArray
Public Shared CrlfArray As Char()
public:
static array<wchar_t>^ CrlfArray
static val mutable CrlfArray: char[]

Field Value

Type: Char
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultControlBackColor Field

ConstsDefaultControlBackColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultControlBackColor
Public Shared DefaultControlBackColor As Color
public:
static Color DefaultControlBackColor
static val mutable DefaultControlBackColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultControlForeColor Field

ConstsDefaultControlForeColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultControlForeColor
Public Shared DefaultControlForeColor As Color
public:
static Color DefaultControlForeColor
static val mutable DefaultControlForeColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultHotTrackBackColor Field

ConstsDefaultHotTrackBackColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultHotTrackBackColor
Public Shared DefaultHotTrackBackColor As Color
public:
static Color DefaultHotTrackBackColor
static val mutable DefaultHotTrackBackColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultHotTrackColor Field

ConstsDefaultHotTrackColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultHotTrackColor
Public Shared DefaultHotTrackColor As Color
public:
static Color DefaultHotTrackColor
static val mutable DefaultHotTrackColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultPopupBackColor Field

ConstsDefaultPopupBackColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultPopupBackColor
Public Shared DefaultPopupBackColor As Color
public:
static Color DefaultPopupBackColor
static val mutable DefaultPopupBackColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultPopupBorderColor Field

ConstsDefaultPopupBorderColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultPopupBorderColor
Public Shared DefaultPopupBorderColor As Color
public:
static Color DefaultPopupBorderColor
static val mutable DefaultPopupBorderColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultPressedBackColor Field

ConstsDefaultPressedBackColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultPressedBackColor
Public Shared DefaultPressedBackColor As Color
public:
static Color DefaultPressedBackColor
static val mutable DefaultPressedBackColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultWindowFrameColor Field

ConstsDefaultWindowFrameColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultWindowFrameColor
Public Shared DefaultWindowFrameColor As Color
public:
static Color DefaultWindowFrameColor
static val mutable DefaultWindowFrameColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultXPHeaderForeColor Field

ConstsDefaultXPHeaderForeColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultXPHeaderForeColor
Public Shared DefaultXPHeaderForeColor As Color
public:
static Color DefaultXPHeaderForeColor
static val mutable DefaultXPHeaderForeColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DefaultXPItemsForeColor Field

ConstsDefaultXPItemsForeColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultXPItemsForeColor
Public Shared DefaultXPItemsForeColor As Color
public:
static Color DefaultXPItemsForeColor
static val mutable DefaultXPItemsForeColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.DisregardInternationalSymbols Field

ConstsDisregardInternationalSymbols Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool DisregardInternationalSymbols
Public Shared DisregardInternationalSymbols As Boolean
public:
static bool DisregardInternationalSymbols
static val mutable DisregardInternationalSymbols: bool

Field Value

Type: Boolean
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.Escape Field

ConstsEscape Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const char Escape
Public Const Escape As Char
public:
literal wchar_t Escape
static val mutable Escape: char

Field Value

Type: Char
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.HiddenStr Field

ConstsHiddenStr Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string HiddenStr
Public Const HiddenStr As String
public:
literal String^ HiddenStr
static val mutable HiddenStr: string

Field Value

Type: String
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.HomeSteadItemsAreaColor Field

ConstsHomeSteadItemsAreaColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color HomeSteadItemsAreaColor
Public Shared HomeSteadItemsAreaColor As Color
public:
static Color HomeSteadItemsAreaColor
static val mutable HomeSteadItemsAreaColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.LF Field

ConstsLF Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const char LF
Public Const LF As Char
public:
literal wchar_t LF
static val mutable LF: char

Field Value

Type: Char
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.LongSpace Field

ConstsLongSpace Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const char LongSpace
Public Const LongSpace As Char
public:
literal wchar_t LongSpace
static val mutable LongSpace: char

Field Value

Type: Char
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.MaxWordLength Field

ConstsMaxWordLength Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MaxWordLength
Public Shared MaxWordLength As Integer
public:
static int MaxWordLength
static val mutable MaxWordLength: int

Field Value

Type: Int32
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.MetallicItemsAreaColor Field

ConstsMetallicItemsAreaColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color MetallicItemsAreaColor
Public Shared MetallicItemsAreaColor As Color
public:
static Color MetallicItemsAreaColor
static val mutable MetallicItemsAreaColor: Color

Field Value

Type: Color
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.Space Field

ConstsSpace Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const char Space
Public Const Space As Char
public:
literal wchar_t Space
static val mutable Space: char

Field Value

Type: Char
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.Tab Field

ConstsTab Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const char Tab
Public Const Tab As Char
public:
literal wchar_t Tab
static val mutable Tab: char

Field Value

Type: Char
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts.TabStr Field

ConstsTabStr Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TabStr
Public Const TabStr As String
public:
literal String^ TabStr
static val mutable TabStr: string

Field Value

Type: String
See Also

Reference

Consts Class
Alternet.Common Namespace


Consts Methods

Consts Methods

The Consts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Consts Class
Alternet.Common Namespace


ControlState Enumeration

ControlState Enumeration
Defines control state. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ControlState
<FlagsAttribute>
Public Enumeration ControlState
[FlagsAttribute]
public enum class ControlState
[<FlagsAttribute>]
type ControlState
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Normal | 1 | Specifies that control is in the normal state.
Disabled | 2 | Specifies that control is in the disabled state.
Pressed | 4 | Specifies that control is in the pressed state.
Hovered | 8 | Specifies that control is in the hovered state.
Focused | 16 | Specifies that control is in the focused state.
Default | 32 | Specifies that control is in the default state.
See Also

Reference

Alternet.Common Namespace


ControlUtilities Class

ControlUtilities Class
An utility class to work with controls..
Inheritance Hierarchy
SystemObject
Alternet.CommonControlUtilities

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ControlUtilities
Public NotInheritable Class ControlUtilities
public ref class ControlUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ControlUtilities =  class end

The ControlUtilities type exposes the following members.

Methods
Name | Description
IsChildHandle | Determines whether a control is a child control or descendant control of a specified parent control.
IsMouseOverControl | Indicates if mouse pointer is hovered over specified control.
ResumeDrawing | Allow changes in the control to be redrawn.
SendMessage | Sends the specified message to a control.
SuspendDrawing | Prevent changes in the control from being redrawn.
Top
See Also

Reference

Alternet.Common Namespace


ControlUtilities Methods

ControlUtilities Methods

The ControlUtilities type exposes the following members.

Methods
Name | Description
IsChildHandle | Determines whether a control is a child control or descendant control of a specified parent control.
IsMouseOverControl | Indicates if mouse pointer is hovered over specified control.
ResumeDrawing | Allow changes in the control to be redrawn.
SendMessage | Sends the specified message to a control.
SuspendDrawing | Prevent changes in the control from being redrawn.
Top
See Also

Reference

ControlUtilities Class
Alternet.Common Namespace


ControlUtilities.IsChildHandle Method

ControlUtilitiesIsChildHandle Method
Determines whether a control is a child control or descendant control of a specified parent control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsChildHandle(
    Control control,
    IntPtr handle
)
Public Shared Function IsChildHandle (
    control As Control,
    handle As IntPtr
) As Boolean
public:
static bool IsChildHandle(
    Control^ control,
    IntPtr handle
)
static member IsChildHandle :
        control : Control *
        handle : IntPtr -> bool

Parameters

control
Type: System.Windows.FormsControl
A parent control.
handle
Type: SystemIntPtr
A handle to the control to be tested.

Return Value

Type: Boolean
True if the control is a child or descendant control; otherwise false.
See Also

Reference

ControlUtilities Class
Alternet.Common Namespace


ControlUtilities.IsMouseOverControl Method

ControlUtilitiesIsMouseOverControl Method
Indicates if mouse pointer is hovered over specified control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsMouseOverControl(
    Control control
)
Public Shared Function IsMouseOverControl (
    control As Control
) As Boolean
public:
static bool IsMouseOverControl(
    Control^ control
)
static member IsMouseOverControl :
        control : Control -> bool

Parameters

control
Type: System.Windows.FormsControl
Given control.

Return Value

Type: Boolean
True if mouse inside control client area; otherwise false.
See Also

Reference

ControlUtilities Class
Alternet.Common Namespace


ControlUtilities.ResumeDrawing Method

ControlUtilitiesResumeDrawing Method
Allow changes in the control to be redrawn.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ResumeDrawing(
    Control parent
)
Public Shared Sub ResumeDrawing (
    parent As Control
)
public:
static void ResumeDrawing(
    Control^ parent
)
static member ResumeDrawing :
        parent : Control -> unit

Parameters

parent
Type: System.Windows.FormsControl
A control to be redrawn.
See Also

Reference

ControlUtilities Class
Alternet.Common Namespace


ControlUtilities.SendMessage Method

ControlUtilitiesSendMessage Method
Sends the specified message to a control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SendMessage(
    Control control,
    int message,
    IntPtr wParam,
    IntPtr lParam
)
Public Shared Sub SendMessage (
    control As Control,
    message As Integer,
    wParam As IntPtr,
    lParam As IntPtr
)
public:
static void SendMessage(
    Control^ control,
    int message,
    IntPtr wParam,
    IntPtr lParam
)
static member SendMessage :
        control : Control *
        message : int *
        wParam : IntPtr *
        lParam : IntPtr -> unit

Parameters

control
Type: System.Windows.FormsControl
A control whose window procedure will receive the message.
message
Type: SystemInt32
The message to be sent.
wParam
Type: SystemIntPtr
Additional message-specific information.
lParam
Type: SystemIntPtr
Additional message-specific information.
See Also

Reference

ControlUtilities Class
Alternet.Common Namespace


ControlUtilities.SuspendDrawing Method

ControlUtilitiesSuspendDrawing Method
Prevent changes in the control from being redrawn.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SuspendDrawing(
    Control parent
)
Public Shared Sub SuspendDrawing (
    parent As Control
)
public:
static void SuspendDrawing(
    Control^ parent
)
static member SuspendDrawing :
        parent : Control -> unit

Parameters

parent
Type: System.Windows.FormsControl
A control to be redrawn.
See Also

Reference

ControlUtilities Class
Alternet.Common Namespace


CueTextBox Class

CueTextBox Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Alternet.CommonCueTextBox
Alternet.FormDesigner.WinForms.ToolboxToolboxSearchTextBox

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CueTextBox : TextBox
Public Class CueTextBox
    Inherits TextBox
public ref class CueTextBox : public TextBox
type CueTextBox =
    class
        inherit TextBox
    end

The CueTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | CueTextBox | Initializes a new instance of the CueTextBox class
Top
Methods
 | Name | Description
Public method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from TextBoxBase.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from TextBoxBase.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from TextBoxBase.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Public method | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from TextBox.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Public method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Public method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox.)
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from TextBox.)
Public property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from TextBox.)
Public property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from TextBox.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. (Inherited from TextBoxBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
Public property | BackgroundImage | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | BackgroundImageLayout | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from TextBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cue |
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from TextBoxBase.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from TextBoxBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Public property | Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from TextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from TextBox.)
Public property | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox.)
Public property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the current text in the TextBox. (Inherited from TextBox.)
Public property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox.)
Public property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from TextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Top
Events
 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
Public event | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from TextBox.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Common Namespace


CueTextBox Constructor

CueTextBox Constructor
Initializes a new instance of the CueTextBox class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CueTextBox()
Public Sub New
public:
CueTextBox()
new : unit -> CueTextBox
See Also

Reference

CueTextBox Class
Alternet.Common Namespace


CueTextBox Methods

CueTextBox Methods

The CueTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from TextBoxBase.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from TextBoxBase.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from TextBoxBase.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Public method | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from TextBox.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Public method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Public method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

CueTextBox Class
Alternet.Common Namespace


CueTextBox Properties

CueTextBox Properties

The CueTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox.)
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from TextBox.)
Public property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from TextBox.)
Public property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from TextBox.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. (Inherited from TextBoxBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
Public property | BackgroundImage | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | BackgroundImageLayout | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from TextBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cue |
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from TextBoxBase.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from TextBoxBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Public property | Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from TextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from TextBox.)
Public property | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox.)
Public property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the current text in the TextBox. (Inherited from TextBox.)
Public property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox.)
Public property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from TextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Top
See Also

Reference

CueTextBox Class
Alternet.Common Namespace


CueTextBox.Cue Property

CueTextBoxCue Property

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Cue { get; set; }
Public Property Cue As String
    Get
    Set
public:
property String^ Cue {
    String^ get ();
    void set (String^ value);
}
member Cue : string with get, set

Property Value

Type: String
See Also

Reference

CueTextBox Class
Alternet.Common Namespace


CueTextBox Events

CueTextBox Events

The CueTextBox type exposes the following members.

Events
 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
Public event | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from TextBox.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CueTextBox Class
Alternet.Common Namespace


DesignerCategoryNames Class

DesignerCategoryNames Class
Contains constants for names of Property Grid categories.
Inheritance Hierarchy
SystemObject
Alternet.CommonDesignerCategoryNames

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DesignerCategoryNames
Public NotInheritable Class DesignerCategoryNames
public ref class DesignerCategoryNames abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DesignerCategoryNames =  class end

The DesignerCategoryNames type exposes the following members.

Fields
Name | Description
Appearance | Name of the Appearance category.
Behavior | Name of the Behavior category.
Top
See Also

Reference

Alternet.Common Namespace


DesignerCategoryNames Fields

DesignerCategoryNames Fields

The DesignerCategoryNames type exposes the following members.

Fields
Name | Description
Appearance | Name of the Appearance category.
Behavior | Name of the Behavior category.
Top
See Also

Reference

DesignerCategoryNames Class
Alternet.Common Namespace


DesignerCategoryNames.Appearance Field

DesignerCategoryNamesAppearance Field
Name of the Appearance category.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Appearance
Public Const Appearance As String
public:
literal String^ Appearance
static val mutable Appearance: string

Field Value

Type: String
See Also

Reference

DesignerCategoryNames Class
Alternet.Common Namespace


DesignerCategoryNames.Behavior Field

DesignerCategoryNamesBehavior Field
Name of the Behavior category.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Behavior
Public Const Behavior As String
public:
literal String^ Behavior
static val mutable Behavior: string

Field Value

Type: String
See Also

Reference

DesignerCategoryNames Class
Alternet.Common Namespace


DisplayScaledImage Class

DisplayScaledImage Class
Chooses between regular and high-DPI image and/or scales images depending on current DPI setting. This class is for single image. See also DisplayScaledImages, DisplayScaledImagesByKey.
Inheritance Hierarchy
SystemObject
Alternet.CommonDisplayScaledImage

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DisplayScaledImage : IDisposable
Public Class DisplayScaledImage
    Implements IDisposable
public ref class DisplayScaledImage : IDisposable
type DisplayScaledImage =
    class
        interface IDisposable
    end

The DisplayScaledImage type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayScaledImage | Initializes a new instance of DisplayScaledImage class.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes this DisplayScaledImage and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Image | Gets output image, with scaling applied, if required.
Public property | ImageNotScaled | Gets output image, but without any scaling applied.
Top
See Also

Reference

Alternet.Common Namespace


DisplayScaledImage Constructor

DisplayScaledImage Constructor
Initializes a new instance of DisplayScaledImage class.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplayScaledImage(
    Func<Image> getImageFunc,
    Func<Image> getImageHighDpiFunc
)
Public Sub New (
    getImageFunc As Func(Of Image),
    getImageHighDpiFunc As Func(Of Image)
)
public:
DisplayScaledImage(
    Func<Image^>^ getImageFunc,
    Func<Image^>^ getImageHighDpiFunc
)
new :
        getImageFunc : Func<Image> *
        getImageHighDpiFunc : Func<Image> -> DisplayScaledImage

Parameters

getImageFunc
Type: SystemFuncImage
A function to provide a 100% DPI image.
getImageHighDpiFunc
Type: SystemFuncImage
A function to provide a 200% DPI image.
See Also

Reference

DisplayScaledImage Class
Alternet.Common Namespace


DisplayScaledImage Methods

DisplayScaledImage Methods

The DisplayScaledImage type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this DisplayScaledImage and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisplayScaledImage Class
Alternet.Common Namespace


DisplayScaledImage.Dispose Method

DisplayScaledImageDispose Method
Disposes this DisplayScaledImage and frees resources associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DisplayScaledImage Class
Alternet.Common Namespace


DisplayScaledImage Properties

DisplayScaledImage Properties

The DisplayScaledImage type exposes the following members.

Properties
 | Name | Description
Public property | Image | Gets output image, with scaling applied, if required.
Public property | ImageNotScaled | Gets output image, but without any scaling applied.
Top
See Also

Reference

DisplayScaledImage Class
Alternet.Common Namespace


DisplayScaledImage.Image Property

DisplayScaledImageImage Property
Gets output image, with scaling applied, if required.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Image Image { get; }
Public Overridable ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get ();
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image
See Also

Reference

DisplayScaledImage Class
Alternet.Common Namespace


DisplayScaledImage.ImageNotScaled Property

DisplayScaledImageImageNotScaled Property
Gets output image, but without any scaling applied.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image ImageNotScaled { get; }
Public ReadOnly Property ImageNotScaled As Image
    Get
public:
property Image^ ImageNotScaled {
    Image^ get ();
}
member ImageNotScaled : Image with get

Property Value

Type: Image
See Also

Reference

DisplayScaledImage Class
Alternet.Common Namespace


DisplayScaledImages Class

DisplayScaledImages Class
Chooses between regular and high-DPI image and/or scales images depending on current DPI setting. This class is for image list. See also DisplayScaledImagesByKey, DisplayScaledImage.
Inheritance Hierarchy
SystemObject
Alternet.CommonDisplayScaledImages

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DisplayScaledImages : IDisposable
Public Class DisplayScaledImages
    Implements IDisposable
public ref class DisplayScaledImages : IDisposable
type DisplayScaledImages =
    class
        interface IDisposable
    end

The DisplayScaledImages type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayScaledImages | Initializes a new instance of DisplayScaledImages class.
Top
Methods
 | Name | Description
Public method | ClearCache | Clears the scaled images cache.
Public method | Dispose | Disposes this DisplayScaledImages and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Images | Gets output images, with scaling applied, if required.
Public property | ImagesNotScaled | Gets output images, but without any scaling applied.
Top
See Also

Reference

Alternet.Common Namespace


DisplayScaledImages Constructor

DisplayScaledImages Constructor
Initializes a new instance of DisplayScaledImages class.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplayScaledImages(
    Func<ImageList> getImagesFunc,
    Func<ImageList> getImagesHighDpiFunc
)
Public Sub New (
    getImagesFunc As Func(Of ImageList),
    getImagesHighDpiFunc As Func(Of ImageList)
)
public:
DisplayScaledImages(
    Func<ImageList^>^ getImagesFunc,
    Func<ImageList^>^ getImagesHighDpiFunc
)
new :
        getImagesFunc : Func<ImageList> *
        getImagesHighDpiFunc : Func<ImageList> -> DisplayScaledImages

Parameters

getImagesFunc
Type: SystemFuncImageList
A function to provide a 100% DPI image.
getImagesHighDpiFunc
Type: SystemFuncImageList
A function to provide a 200% DPI image.
See Also

Reference

DisplayScaledImages Class
Alternet.Common Namespace


DisplayScaledImages Methods

DisplayScaledImages Methods

The DisplayScaledImages type exposes the following members.

Methods
 | Name | Description
Public method | ClearCache | Clears the scaled images cache.
Public method | Dispose | Disposes this DisplayScaledImages and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisplayScaledImages Class
Alternet.Common Namespace


DisplayScaledImages.ClearCache Method

DisplayScaledImagesClearCache Method
Clears the scaled images cache.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearCache()
Public Sub ClearCache
public:
void ClearCache()
member ClearCache : unit -> unit
See Also

Reference

DisplayScaledImages Class
Alternet.Common Namespace


DisplayScaledImages.Dispose Method

DisplayScaledImagesDispose Method
Disposes this DisplayScaledImages and frees resources associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DisplayScaledImages Class
Alternet.Common Namespace


DisplayScaledImages Properties

DisplayScaledImages Properties

The DisplayScaledImages type exposes the following members.

Properties
 | Name | Description
Public property | Images | Gets output images, with scaling applied, if required.
Public property | ImagesNotScaled | Gets output images, but without any scaling applied.
Top
See Also

Reference

DisplayScaledImages Class
Alternet.Common Namespace


DisplayScaledImages.Images Property

DisplayScaledImagesImages Property
Gets output images, with scaling applied, if required.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList Images { get; }
Public Overridable ReadOnly Property Images As ImageList
    Get
public:
virtual property ImageList^ Images {
    ImageList^ get ();
}
abstract Images : ImageList with get
override Images : ImageList with get

Property Value

Type: ImageList
See Also

Reference

DisplayScaledImages Class
Alternet.Common Namespace


DisplayScaledImages.ImagesNotScaled Property

DisplayScaledImagesImagesNotScaled Property
Gets output images, but without any scaling applied.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageList ImagesNotScaled { get; }
Public ReadOnly Property ImagesNotScaled As ImageList
    Get
public:
property ImageList^ ImagesNotScaled {
    ImageList^ get ();
}
member ImagesNotScaled : ImageList with get

Property Value

Type: ImageList
See Also

Reference

DisplayScaledImages Class
Alternet.Common Namespace


DisplayScaledImagesByKey(TKey) Class

DisplayScaledImagesByKeyTKey Class
Chooses between regular and high-DPI image and/or scales images depending on current DPI setting. This class is for images indexed by key. See also DisplayScaledImages, DisplayScaledImage.
Inheritance Hierarchy
SystemObject
Alternet.CommonDisplayScaledImagesByKeyTKey

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DisplayScaledImagesByKey<TKey> : IDisposable

Public Class DisplayScaledImagesByKey(Of TKey)
    Implements IDisposable
generic<typename TKey>
public ref class DisplayScaledImagesByKey : IDisposable
type DisplayScaledImagesByKey<'TKey> =
    class
        interface IDisposable
    end

Type Parameters

TKey

The DisplayScaledImagesByKeyTKey type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayScaledImagesByKeyTKey | Initializes a new instance of DisplayScaledImagesByKey class.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes this DisplayScaledImagesByKey and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Gets output image, with scaling applied, if required. A key to index the image by.
Public method | GetImageNotScaled | Gets output image, but without any scaling applied. A key to index the image by.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common Namespace


DisplayScaledImagesByKey(TKey) Constructor

DisplayScaledImagesByKeyTKey Constructor
Initializes a new instance of DisplayScaledImagesByKey class.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplayScaledImagesByKey(
    DisplayScaledImagesByKeyTKeyGetImageFunc getImageFunc,
    DisplayScaledImagesByKeyTKeyGetImageFunc getImageHighDpiFunc
)
Public Sub New (
    getImageFunc As DisplayScaledImagesByKeyTKeyGetImageFunc,
    getImageHighDpiFunc As DisplayScaledImagesByKeyTKeyGetImageFunc
)
public:
DisplayScaledImagesByKey(
    DisplayScaledImagesByKeyTKeyGetImageFunc^ getImageFunc,
    DisplayScaledImagesByKeyTKeyGetImageFunc^ getImageHighDpiFunc
)
new :
        getImageFunc : DisplayScaledImagesByKeyTKeyGetImageFunc *
        getImageHighDpiFunc : DisplayScaledImagesByKeyTKeyGetImageFunc -> DisplayScaledImagesByKey

Parameters

getImageFunc
Type: Alternet.CommonDisplayScaledImagesByKeyTKeyGetImageFunc
A function to provide a 100% DPI image.
getImageHighDpiFunc
Type: Alternet.CommonDisplayScaledImagesByKeyTKeyGetImageFunc
A function to provide a 200% DPI image.
See Also

Reference

DisplayScaledImagesByKeyTKey Class
Alternet.Common Namespace


DisplayScaledImagesByKey(TKey) Methods

DisplayScaledImagesByKeyTKey Methods

The DisplayScaledImagesByKeyTKey generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this DisplayScaledImagesByKey and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Gets output image, with scaling applied, if required. A key to index the image by.
Public method | GetImageNotScaled | Gets output image, but without any scaling applied. A key to index the image by.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisplayScaledImagesByKeyTKey Class
Alternet.Common Namespace


DisplayScaledImagesByKey(TKey).Dispose Method

DisplayScaledImagesByKeyTKeyDispose Method
Disposes this DisplayScaledImagesByKey and frees resources associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DisplayScaledImagesByKeyTKey Class
Alternet.Common Namespace


DisplayScaledImagesByKey(TKey).GetImage Method

DisplayScaledImagesByKeyTKeyGetImage Method
Gets output image, with scaling applied, if required. A key to index the image by.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Image GetImage(
    TKey key
)
Public Overridable Function GetImage (
    key As TKey
) As Image
public:
virtual Image^ GetImage(
    TKey key
)
abstract GetImage :
        key : 'TKey -> Image
override GetImage :
        key : 'TKey -> Image

Parameters

key
Type: TKey

Return Value

Type: Image
See Also

Reference

DisplayScaledImagesByKeyTKey Class
Alternet.Common Namespace


DisplayScaledImagesByKey(TKey).GetImageNotScaled Method

DisplayScaledImagesByKeyTKeyGetImageNotScaled Method
Gets output image, but without any scaling applied. A key to index the image by.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image GetImageNotScaled(
    TKey key
)
Public Function GetImageNotScaled (
    key As TKey
) As Image
public:
Image^ GetImageNotScaled(
    TKey key
)
member GetImageNotScaled :
        key : 'TKey -> Image

Parameters

key
Type: TKey

Return Value

Type: Image
See Also

Reference

DisplayScaledImagesByKeyTKey Class
Alternet.Common Namespace


DisplayScaledImagesByKey(TKey).GetImageFunc Delegate

DisplayScaledImagesByKeyTKeyGetImageFunc Delegate
Get image delegate.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate Image GetImageFunc(
    TKey key
)
Public Delegate Function GetImageFunc (
    key As TKey
) As Image
public delegate Image^ GetImageFunc(
    TKey key
)
type GetImageFunc =
    delegate of
        key : 'TKey -> Image

Parameters

key
Type: TKey
A key to index the image by.

Return Value

Type: Image
The provided image.
See Also

Reference

Alternet.Common Namespace


DisplayScaledImagesEx Class

DisplayScaledImagesEx Class
Chooses between regular and high-DPI image and/or scales images depending on current DPI setting. This class is for image list. See also DisplayScaledImagesByKey, DisplayScaledImage.
Inheritance Hierarchy
SystemObject
Alternet.CommonDisplayScaledImagesEx

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DisplayScaledImagesEx : IDisposable
Public Class DisplayScaledImagesEx
    Implements IDisposable
public ref class DisplayScaledImagesEx : IDisposable
type DisplayScaledImagesEx =
    class
        interface IDisposable
    end

The DisplayScaledImagesEx type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayScaledImagesEx | Initializes a new instance of DisplayScaledImages class.
Top
Methods
 | Name | Description
Public method | ClearCache | Clears the scaled images cache.
Public method | Dispose | Disposes this DisplayScaledImages and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Images | Gets output images, with scaling applied, if required.
Public property | ImagesNotScaled | Gets output images, but without any scaling applied.
Top
See Also

Reference

Alternet.Common Namespace


DisplayScaledImagesEx Constructor

DisplayScaledImagesEx Constructor
Initializes a new instance of DisplayScaledImages class.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplayScaledImagesEx(
    Func<AlphaImageList> getImagesFunc,
    Func<AlphaImageList> getImagesHighDpiFunc
)
Public Sub New (
    getImagesFunc As Func(Of AlphaImageList),
    getImagesHighDpiFunc As Func(Of AlphaImageList)
)
public:
DisplayScaledImagesEx(
    Func<AlphaImageList^>^ getImagesFunc,
    Func<AlphaImageList^>^ getImagesHighDpiFunc
)
new :
        getImagesFunc : Func<AlphaImageList> *
        getImagesHighDpiFunc : Func<AlphaImageList> -> DisplayScaledImagesEx

Parameters

getImagesFunc
Type: SystemFuncAlphaImageList
A function to provide a 100% DPI image.
getImagesHighDpiFunc
Type: SystemFuncAlphaImageList
A function to provide a 200% DPI image.
See Also

Reference

DisplayScaledImagesEx Class
Alternet.Common Namespace


DisplayScaledImagesEx Methods

DisplayScaledImagesEx Methods

The DisplayScaledImagesEx type exposes the following members.

Methods
 | Name | Description
Public method | ClearCache | Clears the scaled images cache.
Public method | Dispose | Disposes this DisplayScaledImages and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisplayScaledImagesEx Class
Alternet.Common Namespace


DisplayScaledImagesEx.ClearCache Method

DisplayScaledImagesExClearCache Method
Clears the scaled images cache.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearCache()
Public Sub ClearCache
public:
void ClearCache()
member ClearCache : unit -> unit
See Also

Reference

DisplayScaledImagesEx Class
Alternet.Common Namespace


DisplayScaledImagesEx.Dispose Method

DisplayScaledImagesExDispose Method
Disposes this DisplayScaledImages and frees resources associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DisplayScaledImagesEx Class
Alternet.Common Namespace


DisplayScaledImagesEx Properties

DisplayScaledImagesEx Properties

The DisplayScaledImagesEx type exposes the following members.

Properties
 | Name | Description
Public property | Images | Gets output images, with scaling applied, if required.
Public property | ImagesNotScaled | Gets output images, but without any scaling applied.
Top
See Also

Reference

DisplayScaledImagesEx Class
Alternet.Common Namespace


DisplayScaledImagesEx.Images Property

DisplayScaledImagesExImages Property
Gets output images, with scaling applied, if required.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual AlphaImageList Images { get; }
Public Overridable ReadOnly Property Images As AlphaImageList
    Get
public:
virtual property AlphaImageList^ Images {
    AlphaImageList^ get ();
}
abstract Images : AlphaImageList with get
override Images : AlphaImageList with get

Property Value

Type: AlphaImageList
See Also

Reference

DisplayScaledImagesEx Class
Alternet.Common Namespace


DisplayScaledImagesEx.ImagesNotScaled Property

DisplayScaledImagesExImagesNotScaled Property
Gets output images, but without any scaling applied.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphaImageList ImagesNotScaled { get; }
Public ReadOnly Property ImagesNotScaled As AlphaImageList
    Get
public:
property AlphaImageList^ ImagesNotScaled {
    AlphaImageList^ get ();
}
member ImagesNotScaled : AlphaImageList with get

Property Value

Type: AlphaImageList
See Also

Reference

DisplayScaledImagesEx Class
Alternet.Common Namespace


EditBorderStyle Enumeration

EditBorderStyle Enumeration
Specifies the border style for Edit control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EditBorderStyle
Public Enumeration EditBorderStyle
public enum class EditBorderStyle
type EditBorderStyle
Members
Member name | Value | Description
None | 0 | No border.
Fixed3D | 1 | A three-dimensional border.
FixedSingle | 2 | A single-line border.
System | 3 | A system border.
See Also

Reference

Alternet.Common Namespace


EnumChildProc Delegate

EnumChildProc Delegate
Represents a method that will handle application-defined function used with the EnumWindows or EnumDesktopWindows functions.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate bool EnumChildProc(
    IntPtr hwnd,
    IntPtr lparam
)
Public Delegate Function EnumChildProc (
    hwnd As IntPtr,
    lparam As IntPtr
) As Boolean
public delegate bool EnumChildProc(
    IntPtr hwnd,
    IntPtr lparam
)
type EnumChildProc =
    delegate of
        hwnd : IntPtr *
        lparam : IntPtr -> bool

Parameters

hwnd
Type: SystemIntPtr
Handle to a top-level window.
lparam
Type: SystemIntPtr
Specifies the application-defined value given in EnumWindows or EnumDesktopWindows.

Return Value

Type: Boolean
See Also

Reference

Alternet.Common Namespace


EnumerableExtensions Class

EnumerableExtensions Class
Contains extended functionality for enumerable objects.
Inheritance Hierarchy
SystemObject
Alternet.CommonEnumerableExtensions

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class EnumerableExtensions
<ExtensionAttribute>
Public NotInheritable Class EnumerableExtensions
[ExtensionAttribute]
public ref class EnumerableExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type EnumerableExtensions =  class end

The EnumerableExtensions type exposes the following members.

Methods
Name | Description
ConcatT | Concatenates two sequences.
GetItemsHashCodeT(IEnumerableT) | Serves as the default hash function for the items in the sequence.
GetItemsHashCodeT(IEnumerableT, FuncT, Int32) | Serves as the default hash function for the items in the sequence.
IndexOfT | Finds the index of the first occurrence of an item in an enumerable.
IndexOfFirstT | Finds the index of the first item matching an expression in an enumerable.
MaxElementT, TKey | Finds out element with maximum value in the container.
Top
See Also

Reference

Alternet.Common Namespace


EnumerableExtensions Methods

EnumerableExtensions Methods

The EnumerableExtensions type exposes the following members.

Methods
Name | Description
ConcatT | Concatenates two sequences.
GetItemsHashCodeT(IEnumerableT) | Serves as the default hash function for the items in the sequence.
GetItemsHashCodeT(IEnumerableT, FuncT, Int32) | Serves as the default hash function for the items in the sequence.
IndexOfT | Finds the index of the first occurrence of an item in an enumerable.
IndexOfFirstT | Finds the index of the first item matching an expression in an enumerable.
MaxElementT, TKey | Finds out element with maximum value in the container.
Top
See Also

Reference

EnumerableExtensions Class
Alternet.Common Namespace


EnumerableExtensions.Concat(T) Method

EnumerableExtensionsConcatT Method
Concatenates two sequences.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<T> Concat<T>(
    IEnumerable<T> a,
    IEnumerable<T> b
)

Public Shared Function Concat(Of T) (
    a As IEnumerable(Of T),
    b As IEnumerable(Of T)
) As IEnumerable(Of T)
public:
generic<typename T>
static IEnumerable<T>^ Concat(
    IEnumerable<T>^ a,
    IEnumerable<T>^ b
)
static member Concat :
        a : IEnumerable<'T> *
        b : IEnumerable<'T> -> IEnumerable<'T>

Parameters

a
Type: System.Collections.GenericIEnumerableT
The first sequence to concatenate.
b
Type: System.Collections.GenericIEnumerableT
The sequence to concatenate to the first sequence.

Type Parameters

T
The type of the elements of the input sequences.

Return Value

Type: IEnumerableT
An IEnumerable that contains the concatenated elements of the two input sequences.
See Also

Reference

EnumerableExtensions Class
Alternet.Common Namespace


EnumerableExtensions.GetItemsHashCode Method

EnumerableExtensionsGetItemsHashCode Method
Overload List
Name | Description
GetItemsHashCodeT(IEnumerableT) | Serves as the default hash function for the items in the sequence.
GetItemsHashCodeT(IEnumerableT, FuncT, Int32) | Serves as the default hash function for the items in the sequence.
Top
See Also

Reference

EnumerableExtensions Class
Alternet.Common Namespace


EnumerableExtensions.GetItemsHashCode(T) Method (IEnumerable(T))

EnumerableExtensionsGetItemsHashCodeT Method (IEnumerableT)
Serves as the default hash function for the items in the sequence.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetItemsHashCode<T>(
    IEnumerable<T> items
)

Public Shared Function GetItemsHashCode(Of T) (
    items As IEnumerable(Of T)
) As Integer
public:
generic<typename T>
static int GetItemsHashCode(
    IEnumerable<T>^ items
)
static member GetItemsHashCode :
        items : IEnumerable<'T> -> int

Parameters

items
Type: System.Collections.GenericIEnumerableT
The sequence to get hash code.

Type Parameters

T
The type of the elements of the sequences.

Return Value

Type: Int32
A hash code for the sequence.
See Also

Reference

EnumerableExtensions Class
GetItemsHashCode Overload
Alternet.Common Namespace


EnumerableExtensions.GetItemsHashCode(T) Method (IEnumerable(T), Func(T, Int32))

EnumerableExtensionsGetItemsHashCodeT Method (IEnumerableT, FuncT, Int32)
Serves as the default hash function for the items in the sequence.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetItemsHashCode<T>(
    IEnumerable<T> items,
    Func<T, int> getItemHashCodeFunc
)

Public Shared Function GetItemsHashCode(Of T) (
    items As IEnumerable(Of T),
    getItemHashCodeFunc As Func(Of T, Integer)
) As Integer
public:
generic<typename T>
static int GetItemsHashCode(
    IEnumerable<T>^ items,
    Func<T, int>^ getItemHashCodeFunc
)
static member GetItemsHashCode :
        items : IEnumerable<'T> *
        getItemHashCodeFunc : Func<'T, int> -> int

Parameters

items
Type: System.Collections.GenericIEnumerableT
The sequence to get hash code.
getItemHashCodeFunc
Type: SystemFuncT, Int32
Method calculates hash code for particular item.

Type Parameters

T
The type of the elements of the sequences.

Return Value

Type: Int32
A hash code for the sequence.
See Also

Reference

EnumerableExtensions Class
GetItemsHashCode Overload
Alternet.Common Namespace


EnumerableExtensions.IndexOf(T) Method

EnumerableExtensionsIndexOfT Method
Finds the index of the first occurrence of an item in an enumerable.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int IndexOf<T>(
    this IEnumerable<T> items,
    T item
)

<ExtensionAttribute>
Public Shared Function IndexOf(Of T) (
    items As IEnumerable(Of T),
    item As T
) As Integer
public:
[ExtensionAttribute]
generic<typename T>
static int IndexOf(
    IEnumerable<T>^ items,
    T item
)
[<ExtensionAttribute>]
static member IndexOf :
        items : IEnumerable<'T> *
        item : 'T -> int

Parameters

items
Type: System.Collections.GenericIEnumerableT
The enumerable to search.
item
Type: T
The item to find.

Type Parameters

T

Return Value

Type: Int32
The index of the first matching item, or -1 if the item was not found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerableT. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumerableExtensions Class
Alternet.Common Namespace


EnumerableExtensions.IndexOfFirst(T) Method

EnumerableExtensionsIndexOfFirstT Method
Finds the index of the first item matching an expression in an enumerable.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int IndexOfFirst<T>(
    this IEnumerable<T> items,
    Func<T, bool> predicate
)

<ExtensionAttribute>
Public Shared Function IndexOfFirst(Of T) (
    items As IEnumerable(Of T),
    predicate As Func(Of T, Boolean)
) As Integer
public:
[ExtensionAttribute]
generic<typename T>
static int IndexOfFirst(
    IEnumerable<T>^ items,
    Func<T, bool>^ predicate
)
[<ExtensionAttribute>]
static member IndexOfFirst :
        items : IEnumerable<'T> *
        predicate : Func<'T, bool> -> int

Parameters

items
Type: System.Collections.GenericIEnumerableT
The enumerable to search.
predicate
Type: SystemFuncT, Boolean
The expression to test the items against.

Type Parameters

T

Return Value

Type: Int32
The index of the first matching item, or -1 if no items match.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerableT. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumerableExtensions Class
Alternet.Common Namespace


EnumerableExtensions.MaxElement(T, TKey) Method

EnumerableExtensionsMaxElementT, TKey Method
Finds out element with maximum value in the container.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static T MaxElement<T, TKey>(
    this IEnumerable<T> container,
    Func<T, TKey> valuingFoo
)
where TKey : IComparable

<ExtensionAttribute>
Public Shared Function MaxElement(Of T, TKey As IComparable) (
    container As IEnumerable(Of T),
    valuingFoo As Func(Of T, TKey)
) As T
public:
[ExtensionAttribute]
generic<typename T, typename TKey>
where TKey : IComparable
static T MaxElement(
    IEnumerable<T>^ container,
    Func<T, TKey>^ valuingFoo
)
[<ExtensionAttribute>]
static member MaxElement :
        container : IEnumerable<'T> *
        valuingFoo : Func<'T, 'TKey> -> 'T  when 'TKey : IComparable

Parameters

container
Type: System.Collections.GenericIEnumerableT
The container to probe.
valuingFoo
Type: SystemFuncT, TKey
Method calculates max value.

Type Parameters

T
The type of the elements of the container.
TKey
The type of key value to calculate maximum.

Return Value

Type: T
Maximal element in the container.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerableT. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumerableExtensions Class
Alternet.Common Namespace


ErrorBehavior Enumeration

ErrorBehavior Enumeration
Defines types of reaction on error.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ErrorBehavior
Public Enumeration ErrorBehavior
public enum class ErrorBehavior
type ErrorBehavior
Members
Member name | Value | Description
Message | 0 | Message dialog displayed when error occurs.
Exception | 1 | Exception is thrown when error occurs.
None | 2 | No reaction.
See Also

Reference

Alternet.Common Namespace


ErrorHandler Class

ErrorHandler Class
Represents class that can react various ways for erroneous situations. This class is used internally for exceptions handling.
Inheritance Hierarchy
SystemObject
Alternet.CommonErrorHandler

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ErrorHandler
Public NotInheritable Class ErrorHandler
public ref class ErrorHandler sealed
[<SealedAttribute>]
type ErrorHandler =  class end

The ErrorHandler type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Error | Processes given exception with defined way.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name | Description
ErrorBehavior | Gets or sets a value indicating reaction on any error.
Top
See Also

Reference

Alternet.Common Namespace


ErrorHandler Methods

ErrorHandler Methods

The ErrorHandler type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Error | Processes given exception with defined way.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorHandler Class
Alternet.Common Namespace


ErrorHandler.Error Method

ErrorHandlerError Method
Processes given exception with defined way.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Error(
    Exception exception
)
Public Shared Sub Error (
    exception As Exception
)
public:
static void Error(
    Exception^ exception
)
static member Error :
        exception : Exception -> unit

Parameters

exception
Type: SystemException
The Exception to process.
See Also

Reference

ErrorHandler Class
Alternet.Common Namespace


ErrorHandler Properties

ErrorHandler Properties

The ErrorHandler type exposes the following members.

Properties
Name | Description
ErrorBehavior | Gets or sets a value indicating reaction on any error.
Top
See Also

Reference

ErrorHandler Class
Alternet.Common Namespace


ErrorHandler.ErrorBehavior Property

ErrorHandlerErrorBehavior Property
Gets or sets a value indicating reaction on any error.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ErrorBehavior ErrorBehavior { get; set; }
Public Shared Property ErrorBehavior As ErrorBehavior
    Get
    Set
public:
static property ErrorBehavior ErrorBehavior {
    ErrorBehavior get ();
    void set (ErrorBehavior value);
}
static member ErrorBehavior : ErrorBehavior with get, set

Property Value

Type: ErrorBehavior
See Also

Reference

ErrorHandler Class
Alternet.Common Namespace


FileRange Class

FileRange Class
Represents a location in source code.
Inheritance Hierarchy
SystemObject
Alternet.CommonRange
Alternet.CommonFileRange

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FileRange : Range, IFileRange,
    IRange, ICloneable
Public Class FileRange
    Inherits Range
    Implements IFileRange, IRange, ICloneable
public ref class FileRange : public Range,
    IFileRange, IRange, ICloneable
type FileRange =
    class
        inherit Range
        interface IFileRange
        interface IRange
        interface ICloneable
    end

The FileRange type exposes the following members.

Constructors
 | Name | Description
Public method | FileRange | Initializes a new instance of the FileRange class with specified parameters.
Top
Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from Range.)
Public method | Clone | Creates a new object that is a copy of the current IRange object. (Inherited from Range.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted. (Inherited from Range.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EndPoint | Gets or sets end of IRange area. (Inherited from Range.)
Public property | FileName | Gets the text line inside the file.
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size. (Inherited from Range.)
Public property | Size | Gets or sets size of IRange area. (Inherited from Range.)
Public property | SourceText | Gets string inside this location.
Public property | StartPoint | Gets or sets begin of IRange area. (Inherited from Range.)
Top
See Also

Reference

Alternet.Common Namespace


FileRange Constructor

FileRange Constructor
Initializes a new instance of the FileRange class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FileRange(
    Point startPoint,
    Point endPoint,
    string fileName,
    string sourceText
)
Public Sub New (
    startPoint As Point,
    endPoint As Point,
    fileName As String,
    sourceText As String
)
public:
FileRange(
    Point startPoint,
    Point endPoint,
    String^ fileName,
    String^ sourceText
)
new :
        startPoint : Point *
        endPoint : Point *
        fileName : string *
        sourceText : string -> FileRange

Parameters

startPoint
Type: System.DrawingPoint
Start of IRange area.
endPoint
Type: System.DrawingPoint
End of IRange area.
fileName
Type: SystemString
Specifies the full name of the source document file.
sourceText
Type: SystemString
Specifies string inside this location.
See Also

Reference

FileRange Class
Alternet.Common Namespace


FileRange Methods

FileRange Methods

The FileRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from Range.)
Public method | Clone | Creates a new object that is a copy of the current IRange object. (Inherited from Range.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted. (Inherited from Range.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileRange Class
Alternet.Common Namespace


FileRange Properties

FileRange Properties

The FileRange type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets end of IRange area. (Inherited from Range.)
Public property | FileName | Gets the text line inside the file.
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size. (Inherited from Range.)
Public property | Size | Gets or sets size of IRange area. (Inherited from Range.)
Public property | SourceText | Gets string inside this location.
Public property | StartPoint | Gets or sets begin of IRange area. (Inherited from Range.)
Top
See Also

Reference

FileRange Class
Alternet.Common Namespace


FileRange.FileName Property

FileRangeFileName Property
Gets the text line inside the file.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
virtual property String^ FileName {
    String^ get () sealed;
}
abstract FileName : string with get
override FileName : string with get

Property Value

Type: String

Implements

IFileRangeFileName
See Also

Reference

FileRange Class
Alternet.Common Namespace


FileRange.SourceText Property

FileRangeSourceText Property
Gets string inside this location.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceText { get; }
Public ReadOnly Property SourceText As String
    Get
public:
virtual property String^ SourceText {
    String^ get () sealed;
}
abstract SourceText : string with get
override SourceText : string with get

Property Value

Type: String

Implements

IFileRangeSourceText
See Also

Reference

FileRange Class
Alternet.Common Namespace


FileSystemUtility Class

FileSystemUtility Class
Inheritance Hierarchy
SystemObject
Alternet.CommonFileSystemUtility

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FileSystemUtility
Public NotInheritable Class FileSystemUtility
public ref class FileSystemUtility abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FileSystemUtility =  class end

The FileSystemUtility type exposes the following members.

Methods
Name | Description
CopyDirectory |
EnsureDirectoryExists |
Top
See Also

Reference

Alternet.Common Namespace


FileSystemUtility Methods

FileSystemUtility Methods

The FileSystemUtility type exposes the following members.

Methods
Name | Description
CopyDirectory |
EnsureDirectoryExists |
Top
See Also

Reference

FileSystemUtility Class
Alternet.Common Namespace


FileSystemUtility.CopyDirectory Method

FileSystemUtilityCopyDirectory Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CopyDirectory(
    string sourceDirectoryPath,
    string targetDirectoryPath
)
Public Shared Sub CopyDirectory (
    sourceDirectoryPath As String,
    targetDirectoryPath As String
)
public:
static void CopyDirectory(
    String^ sourceDirectoryPath,
    String^ targetDirectoryPath
)
static member CopyDirectory :
        sourceDirectoryPath : string *
        targetDirectoryPath : string -> unit

Parameters

sourceDirectoryPath
Type: SystemString
targetDirectoryPath
Type: SystemString
See Also

Reference

FileSystemUtility Class
Alternet.Common Namespace


FileSystemUtility.EnsureDirectoryExists Method

FileSystemUtilityEnsureDirectoryExists Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void EnsureDirectoryExists(
    string path
)
Public Shared Sub EnsureDirectoryExists (
    path As String
)
public:
static void EnsureDirectoryExists(
    String^ path
)
static member EnsureDirectoryExists :
        path : string -> unit

Parameters

path
Type: SystemString
See Also

Reference

FileSystemUtility Class
Alternet.Common Namespace


FlickerFreeListBox Class

FlickerFreeListBox Class
Provides flicker free ListBox.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsListBox
Alternet.CommonFlickerFreeListBox
Alternet.FormDesigner.WinForms.ToolboxToolboxCategoryItemsListBox

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FlickerFreeListBox : ListBox
Public Class FlickerFreeListBox
    Inherits ListBox
public ref class FlickerFreeListBox : public ListBox
type FlickerFreeListBox =
    class
        inherit ListBox
    end

The FlickerFreeListBox type exposes the following members.

Constructors
 | Name | Description
Public method | FlickerFreeListBox | Initializes a new instance of the FlickerFreeListBox class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | Items | Gets the items of the ListBox. (Inherited from ListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Common Namespace


FlickerFreeListBox Constructor

FlickerFreeListBox Constructor
Initializes a new instance of the FlickerFreeListBox class with default settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlickerFreeListBox()
Public Sub New
public:
FlickerFreeListBox()
new : unit -> FlickerFreeListBox
See Also

Reference

FlickerFreeListBox Class
Alternet.Common Namespace


FlickerFreeListBox Methods

FlickerFreeListBox Methods

The FlickerFreeListBox type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

FlickerFreeListBox Class
Alternet.Common Namespace


FlickerFreeListBox Properties

FlickerFreeListBox Properties

The FlickerFreeListBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | Items | Gets the items of the ListBox. (Inherited from ListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

FlickerFreeListBox Class
Alternet.Common Namespace


FlickerFreeListBox Events

FlickerFreeListBox Events

The FlickerFreeListBox type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

FlickerFreeListBox Class
Alternet.Common Namespace


FontInfo Class

FontInfo Class
Represents information about a particular font.
Inheritance Hierarchy
SystemObject
Alternet.CommonFontInfo
Alternet.CommonGdiFontInfo

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FontInfo
Public Class FontInfo
public ref class FontInfo
type FontInfo =  class end

The FontInfo type exposes the following members.

Constructors
 | Name | Description
Public method | FontInfo(Font, IntPtr) | Initializes a new instance of the FontInfo class with specified parameters.
Public method | FontInfo(IntPtr, IntPtr, String) | Initializes a new instance of the FontInfo class with specified parameters.
Top
Methods
 | Name | Description
Public method | Clear | Frees all resources associated with this FontInfo.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Font | Gets or sets font of this FontInfo.
Public property | FontHeight | Represents height of the font.
Public property | FontName | Represents name of the font.
Public property | FontWidth | Represents width of the font.
Public property | HFont | Represents handle to the Font.
Public property | IsMonoSpaced | Represents a value indicating whether font is monospaced, meaning that all characters drawn with this font have the same width.
Top
See Also

Reference

Alternet.Common Namespace


FontInfo Constructor

FontInfo Constructor
Overload List
 | Name | Description
Public method | FontInfo(Font, IntPtr) | Initializes a new instance of the FontInfo class with specified parameters.
Public method | FontInfo(IntPtr, IntPtr, String) | Initializes a new instance of the FontInfo class with specified parameters.
Top
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfo Constructor (Font, IntPtr)

FontInfo Constructor (Font, IntPtr)
Initializes a new instance of the FontInfo class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontInfo(
    Font font,
    IntPtr dc
)
Public Sub New (
    font As Font,
    dc As IntPtr
)
public:
FontInfo(
    Font^ font,
    IntPtr dc
)
new :
        font : Font *
        dc : IntPtr -> FontInfo

Parameters

font
Type: System.DrawingFont
Specifies Font for this new instance.
dc
Type: SystemIntPtr
Handle to the device context.
See Also

Reference

FontInfo Class
FontInfo Overload
Alternet.Common Namespace


FontInfo Constructor (IntPtr, IntPtr, String)

FontInfo Constructor (IntPtr, IntPtr, String)
Initializes a new instance of the FontInfo class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontInfo(
    IntPtr fontHandle,
    IntPtr dc,
    string fontName
)
Public Sub New (
    fontHandle As IntPtr,
    dc As IntPtr,
    fontName As String
)
public:
FontInfo(
    IntPtr fontHandle,
    IntPtr dc,
    String^ fontName
)
new :
        fontHandle : IntPtr *
        dc : IntPtr *
        fontName : string -> FontInfo

Parameters

fontHandle
Type: SystemIntPtr
Font handle.
dc
Type: SystemIntPtr
Handle to the device context.
fontName
Type: SystemString
Name of the font.
See Also

Reference

FontInfo Class
FontInfo Overload
Alternet.Common Namespace


FontInfo Methods

FontInfo Methods

The FontInfo type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Frees all resources associated with this FontInfo.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfo.Clear Method

FontInfoClear Method
Frees all resources associated with this FontInfo.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfo Properties

FontInfo Properties

The FontInfo type exposes the following members.

Properties
 | Name | Description
Public property | Font | Gets or sets font of this FontInfo.
Public property | FontHeight | Represents height of the font.
Public property | FontName | Represents name of the font.
Public property | FontWidth | Represents width of the font.
Public property | HFont | Represents handle to the Font.
Public property | IsMonoSpaced | Represents a value indicating whether font is monospaced, meaning that all characters drawn with this font have the same width.
Top
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfo.Font Property

FontInfoFont Property
Gets or sets font of this FontInfo.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Font Font { get; }
Public ReadOnly Property Font As Font
    Get
public:
property Font^ Font {
    Font^ get ();
}
member Font : Font with get

Property Value

Type: Font
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfo.FontHeight Property

FontInfoFontHeight Property
Represents height of the font.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FontHeight { get; }
Public ReadOnly Property FontHeight As Integer
    Get
public:
property int FontHeight {
    int get ();
}
member FontHeight : int with get

Property Value

Type: Int32
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfo.FontName Property

FontInfoFontName Property
Represents name of the font.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FontName { get; }
Public ReadOnly Property FontName As String
    Get
public:
property String^ FontName {
    String^ get ();
}
member FontName : string with get

Property Value

Type: String
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfo.FontWidth Property

FontInfoFontWidth Property
Represents width of the font.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FontWidth { get; }
Public ReadOnly Property FontWidth As Integer
    Get
public:
property int FontWidth {
    int get ();
}
member FontWidth : int with get

Property Value

Type: Int32
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfo.HFont Property

FontInfoHFont Property
Represents handle to the Font.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntPtr HFont { get; }
Public ReadOnly Property HFont As IntPtr
    Get
public:
property IntPtr HFont {
    IntPtr get ();
}
member HFont : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfo.IsMonoSpaced Property

FontInfoIsMonoSpaced Property
Represents a value indicating whether font is monospaced, meaning that all characters drawn with this font have the same width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMonoSpaced { get; }
Public ReadOnly Property IsMonoSpaced As Boolean
    Get
public:
property bool IsMonoSpaced {
    bool get ();
}
member IsMonoSpaced : bool with get

Property Value

Type: Boolean
See Also

Reference

FontInfo Class
Alternet.Common Namespace


FontInfos Class

FontInfos Class
Represents collection of FontInfo elements.
Inheritance Hierarchy
SystemObject
Alternet.CommonFontInfos
Alternet.CommonGdiFontInfos

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FontInfos
Public Class FontInfos
public ref class FontInfos
type FontInfos =  class end

The FontInfos type exposes the following members.

Constructors
 | Name | Description
Public method | FontInfos(Font, IntPtr) | Initializes a new instance of the FontInfos class with specified parameters.
Public method | FontInfos(IntPtr, IntPtr) | Initializes a new instance of the FontInfos class with specified parameters.
Top
Methods
 | Name | Description
Public method | Clear | Frees all resources associated with this FontInfos.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetAvailableFontStyle | Indicates whether the specified System.Drawing.FontStyle enumeration is available.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitStyle(FontStyle) | Adds specified style to the style collection.
Public method | InitStyle(String, FontStyle, Int32) | Adds specified style to the style collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CurrentInfo | Represents current FontInfo object.
Public property | FontHeight | Represents height of the current font.
Public property | IsMonoSpaced | Represents a value indicating whether current font is monospaced.
Top
See Also

Reference

Alternet.Common Namespace


FontInfos Constructor

FontInfos Constructor
Overload List
 | Name | Description
Public method | FontInfos(Font, IntPtr) | Initializes a new instance of the FontInfos class with specified parameters.
Public method | FontInfos(IntPtr, IntPtr) | Initializes a new instance of the FontInfos class with specified parameters.
Top
See Also

Reference

FontInfos Class
Alternet.Common Namespace


FontInfos Constructor (Font, IntPtr)

FontInfos Constructor (Font, IntPtr)
Initializes a new instance of the FontInfos class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontInfos(
    Font font,
    IntPtr dc
)
Public Sub New (
    font As Font,
    dc As IntPtr
)
public:
FontInfos(
    Font^ font,
    IntPtr dc
)
new :
        font : Font *
        dc : IntPtr -> FontInfos

Parameters

font
Type: System.DrawingFont
Specifies Font for this new instance.
dc
Type: SystemIntPtr
Handle to the device context.
See Also

Reference

FontInfos Class
FontInfos Overload
Alternet.Common Namespace


FontInfos Constructor (IntPtr, IntPtr)

FontInfos Constructor (IntPtr, IntPtr)
Initializes a new instance of the FontInfos class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontInfos(
    IntPtr fontHandle,
    IntPtr dc
)
Public Sub New (
    fontHandle As IntPtr,
    dc As IntPtr
)
public:
FontInfos(
    IntPtr fontHandle,
    IntPtr dc
)
new :
        fontHandle : IntPtr *
        dc : IntPtr -> FontInfos

Parameters

fontHandle
Type: SystemIntPtr
Specifies Font for this new instance.
dc
Type: SystemIntPtr
Handle to the device context.
See Also

Reference

FontInfos Class
FontInfos Overload
Alternet.Common Namespace


FontInfos Methods

FontInfos Methods

The FontInfos type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Frees all resources associated with this FontInfos.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetAvailableFontStyle | Indicates whether the specified System.Drawing.FontStyle enumeration is available.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitStyle(FontStyle) | Adds specified style to the style collection.
Public method | InitStyle(String, FontStyle, Int32) | Adds specified style to the style collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FontInfos Class
Alternet.Common Namespace


FontInfos.Clear Method

FontInfosClear Method
Frees all resources associated with this FontInfos.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FontInfos Class
Alternet.Common Namespace


FontInfos.GetAvailableFontStyle Method

FontInfosGetAvailableFontStyle Method
Indicates whether the specified System.Drawing.FontStyle enumeration is available.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FontStyle GetAvailableFontStyle(
    FontFamily fontFamily,
    FontStyle desiredStyle
)
Public Shared Function GetAvailableFontStyle (
    fontFamily As FontFamily,
    desiredStyle As FontStyle
) As FontStyle
public:
static FontStyle GetAvailableFontStyle(
    FontFamily^ fontFamily,
    FontStyle desiredStyle
)
static member GetAvailableFontStyle :
        fontFamily : FontFamily *
        desiredStyle : FontStyle -> FontStyle

Parameters

fontFamily
Type: System.DrawingFontFamily
FontFamily to test.
desiredStyle
Type: System.DrawingFontStyle
The System.Drawing.FontStyle to test.

Return Value

Type: FontStyle
The FontStyle available for specified FontFamily object.
See Also

Reference

FontInfos Class
Alternet.Common Namespace


FontInfos.InitStyle Method

FontInfosInitStyle Method
Overload List
 | Name | Description
Public method | InitStyle(FontStyle) | Adds specified style to the style collection.
Public method | InitStyle(String, FontStyle, Int32) | Adds specified style to the style collection.
Top
See Also

Reference

FontInfos Class
Alternet.Common Namespace


FontInfos.InitStyle Method (FontStyle)

FontInfosInitStyle Method (FontStyle)
Adds specified style to the style collection.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontInfo InitStyle(
    FontStyle style
)
Public Function InitStyle (
    style As FontStyle
) As FontInfo
public:
FontInfo^ InitStyle(
    FontStyle style
)
member InitStyle :
        style : FontStyle -> FontInfo

Parameters

style
Type: System.DrawingFontStyle
Style to add.

Return Value

Type: FontInfo
FontInfo that corresponds to the specified style.
See Also

Reference

FontInfos Class
InitStyle Overload
Alternet.Common Namespace


FontInfos.InitStyle Method (String, FontStyle, Int32)

FontInfosInitStyle Method (String, FontStyle, Int32)
Adds specified style to the style collection.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontInfo InitStyle(
    string fontName,
    FontStyle style,
    int fontHeight
)
Public Function InitStyle (
    fontName As String,
    style As FontStyle,
    fontHeight As Integer
) As FontInfo
public:
FontInfo^ InitStyle(
    String^ fontName,
    FontStyle style,
    int fontHeight
)
member InitStyle :
        fontName : string *
        style : FontStyle *
        fontHeight : int -> FontInfo

Parameters

fontName
Type: SystemString
Specifies Font Name.
style
Type: System.DrawingFontStyle
Style to add.
fontHeight
Type: SystemInt32
Specifies Font Height.

Return Value

Type: FontInfo
FontInfo that corresponds to the specified style.
See Also

Reference

FontInfos Class
InitStyle Overload
Alternet.Common Namespace


FontInfos Properties

FontInfos Properties

The FontInfos type exposes the following members.

Properties
 | Name | Description
Public property | CurrentInfo | Represents current FontInfo object.
Public property | FontHeight | Represents height of the current font.
Public property | IsMonoSpaced | Represents a value indicating whether current font is monospaced.
Top
See Also

Reference

FontInfos Class
Alternet.Common Namespace


FontInfos.CurrentInfo Property

FontInfosCurrentInfo Property
Represents current FontInfo object.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontInfo CurrentInfo { get; }
Public ReadOnly Property CurrentInfo As FontInfo
    Get
public:
property FontInfo^ CurrentInfo {
    FontInfo^ get ();
}
member CurrentInfo : FontInfo with get

Property Value

Type: FontInfo
See Also

Reference

FontInfos Class
Alternet.Common Namespace


FontInfos.FontHeight Property

FontInfosFontHeight Property
Represents height of the current font.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FontHeight { get; }
Public ReadOnly Property FontHeight As Integer
    Get
public:
property int FontHeight {
    int get ();
}
member FontHeight : int with get

Property Value

Type: Int32
See Also

Reference

FontInfos Class
Alternet.Common Namespace


FontInfos.IsMonoSpaced Property

FontInfosIsMonoSpaced Property
Represents a value indicating whether current font is monospaced.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMonoSpaced { get; }
Public ReadOnly Property IsMonoSpaced As Boolean
    Get
public:
property bool IsMonoSpaced {
    bool get ();
}
member IsMonoSpaced : bool with get

Property Value

Type: Boolean
See Also

Reference

FontInfos Class
Alternet.Common Namespace


GdiFontInfo Class

GdiFontInfo Class
Represents information about a particular Gdi font.
Inheritance Hierarchy
SystemObject
Alternet.CommonFontInfo
Alternet.CommonGdiFontInfo

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GdiFontInfo : FontInfo
Public Class GdiFontInfo
    Inherits FontInfo
public ref class GdiFontInfo : public FontInfo
type GdiFontInfo =
    class
        inherit FontInfo
    end

The GdiFontInfo type exposes the following members.

Constructors
 | Name | Description
Public method | GdiFontInfo(Font, IntPtr) | Initializes a new instance of the GdiFontInfo class with specified parameters.
Public method | GdiFontInfo(IntPtr, IntPtr, String) | Initializes a new instance of the GdiFontInfo class with specified parameters.
Top
Methods
 | Name | Description
Public method | CharWidth | Calculates width of specified character using current Font.
Public method | Clear | Frees all resources associated with this FontInfo. (Inherited from FontInfo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StringWidth | Calculates width of specified string using current Font.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Font | Gets or sets font of this FontInfo. (Inherited from FontInfo.)
Public property | FontHeight | Represents height of the font. (Inherited from FontInfo.)
Public property | FontName | Represents name of the font. (Inherited from FontInfo.)
Public property | FontWidth | Represents width of the font. (Inherited from FontInfo.)
Public property | HFont | Represents handle to the Font. (Inherited from FontInfo.)
Public property | IsMonoSpaced | Represents a value indicating whether font is monospaced, meaning that all characters drawn with this font have the same width. (Inherited from FontInfo.)
Public property | UseDrawText | Indicates whether string width should be calculated using DrawText method rather then CharWidth.
Top
See Also

Reference

Alternet.Common Namespace


GdiFontInfo Constructor

GdiFontInfo Constructor
Overload List
 | Name | Description
Public method | GdiFontInfo(Font, IntPtr) | Initializes a new instance of the GdiFontInfo class with specified parameters.
Public method | GdiFontInfo(IntPtr, IntPtr, String) | Initializes a new instance of the GdiFontInfo class with specified parameters.
Top
See Also

Reference

GdiFontInfo Class
Alternet.Common Namespace


GdiFontInfo Constructor (Font, IntPtr)

GdiFontInfo Constructor (Font, IntPtr)
Initializes a new instance of the GdiFontInfo class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public GdiFontInfo(
    Font font,
    IntPtr dc
)
Public Sub New (
    font As Font,
    dc As IntPtr
)
public:
GdiFontInfo(
    Font^ font,
    IntPtr dc
)
new :
        font : Font *
        dc : IntPtr -> GdiFontInfo

Parameters

font
Type: System.DrawingFont
Specifies Font for this new instance.
dc
Type: SystemIntPtr
Handle to the device context.
See Also

Reference

GdiFontInfo Class
GdiFontInfo Overload
Alternet.Common Namespace


GdiFontInfo Constructor (IntPtr, IntPtr, String)

GdiFontInfo Constructor (IntPtr, IntPtr, String)
Initializes a new instance of the GdiFontInfo class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public GdiFontInfo(
    IntPtr fontHandle,
    IntPtr dc,
    string fontName
)
Public Sub New (
    fontHandle As IntPtr,
    dc As IntPtr,
    fontName As String
)
public:
GdiFontInfo(
    IntPtr fontHandle,
    IntPtr dc,
    String^ fontName
)
new :
        fontHandle : IntPtr *
        dc : IntPtr *
        fontName : string -> GdiFontInfo

Parameters

fontHandle
Type: SystemIntPtr
Font handle.
dc
Type: SystemIntPtr
Handle to the device context.
fontName
Type: SystemString
Name of the font.
See Also

Reference

GdiFontInfo Class
GdiFontInfo Overload
Alternet.Common Namespace


GdiFontInfo Methods

GdiFontInfo Methods

The GdiFontInfo type exposes the following members.

Methods
 | Name | Description
Public method | CharWidth | Calculates width of specified character using current Font.
Public method | Clear | Frees all resources associated with this FontInfo. (Inherited from FontInfo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StringWidth | Calculates width of specified string using current Font.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GdiFontInfo Class
Alternet.Common Namespace


GdiFontInfo.CharWidth Method

GdiFontInfoCharWidth Method
Calculates width of specified character using current Font.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CharWidth(
    char ch
)
Public Function CharWidth (
    ch As Char
) As Integer
public:
int CharWidth(
    wchar_t ch
)
member CharWidth :
        ch : char -> int

Parameters

ch
Type: SystemChar
Character to measure.

Return Value

Type: Int32
Width of the character.
See Also

Reference

GdiFontInfo Class
Alternet.Common Namespace


GdiFontInfo.StringWidth Method

GdiFontInfoStringWidth Method
Calculates width of specified string using current Font.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int StringWidth(
    string s
)
Public Function StringWidth (
    s As String
) As Integer
public:
int StringWidth(
    String^ s
)
member StringWidth :
        s : string -> int

Parameters

s
Type: SystemString
String to measure.

Return Value

Type: Int32
Width of the text.
See Also

Reference

GdiFontInfo Class
Alternet.Common Namespace


GdiFontInfo Properties

GdiFontInfo Properties

The GdiFontInfo type exposes the following members.

Properties
 | Name | Description
Public property | Font | Gets or sets font of this FontInfo. (Inherited from FontInfo.)
Public property | FontHeight | Represents height of the font. (Inherited from FontInfo.)
Public property | FontName | Represents name of the font. (Inherited from FontInfo.)
Public property | FontWidth | Represents width of the font. (Inherited from FontInfo.)
Public property | HFont | Represents handle to the Font. (Inherited from FontInfo.)
Public property | IsMonoSpaced | Represents a value indicating whether font is monospaced, meaning that all characters drawn with this font have the same width. (Inherited from FontInfo.)
Public property | UseDrawText | Indicates whether string width should be calculated using DrawText method rather then CharWidth.
Top
See Also

Reference

GdiFontInfo Class
Alternet.Common Namespace


GdiFontInfo.UseDrawText Property

GdiFontInfoUseDrawText Property
Indicates whether string width should be calculated using DrawText method rather then CharWidth.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseDrawText { get; set; }
Public Property UseDrawText As Boolean
    Get
    Set
public:
property bool UseDrawText {
    bool get ();
    void set (bool value);
}
member UseDrawText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GdiFontInfo Class
Alternet.Common Namespace


GdiFontInfos Class

GdiFontInfos Class
Represents collection of GdiFontInfo elements.
Inheritance Hierarchy
SystemObject
Alternet.CommonFontInfos
Alternet.CommonGdiFontInfos

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GdiFontInfos : FontInfos
Public Class GdiFontInfos
    Inherits FontInfos
public ref class GdiFontInfos : public FontInfos
type GdiFontInfos =
    class
        inherit FontInfos
    end

The GdiFontInfos type exposes the following members.

Constructors
 | Name | Description
Public method | GdiFontInfos(Font, IntPtr) | Initializes a new instance of the GdiFontInfos class with specified parameters.
Public method | GdiFontInfos(IntPtr, IntPtr) | Initializes a new instance of the GdiFontInfos class with specified parameters.
Top
Methods
 | Name | Description
Public method | Clear | Frees all resources associated with this FontInfos. (Inherited from FontInfos.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitStyle(FontStyle) | Adds specified style to the style collection. (Inherited from FontInfos.)
Public method | InitStyle(String, FontStyle, Int32) | Adds specified style to the style collection. (Inherited from FontInfos.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CurrentInfo | Represents current FontInfo object. (Inherited from FontInfos.)
Public property | FontHeight | Represents height of the current font. (Inherited from FontInfos.)
Public property | IsMonoSpaced | Represents a value indicating whether current font is monospaced. (Inherited from FontInfos.)
Top
See Also

Reference

Alternet.Common Namespace


GdiFontInfos Constructor

GdiFontInfos Constructor
Overload List
 | Name | Description
Public method | GdiFontInfos(Font, IntPtr) | Initializes a new instance of the GdiFontInfos class with specified parameters.
Public method | GdiFontInfos(IntPtr, IntPtr) | Initializes a new instance of the GdiFontInfos class with specified parameters.
Top
See Also

Reference

GdiFontInfos Class
Alternet.Common Namespace


GdiFontInfos Constructor (Font, IntPtr)

GdiFontInfos Constructor (Font, IntPtr)
Initializes a new instance of the GdiFontInfos class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public GdiFontInfos(
    Font font,
    IntPtr dc
)
Public Sub New (
    font As Font,
    dc As IntPtr
)
public:
GdiFontInfos(
    Font^ font,
    IntPtr dc
)
new :
        font : Font *
        dc : IntPtr -> GdiFontInfos

Parameters

font
Type: System.DrawingFont
Specifies Font for this new instance.
dc
Type: SystemIntPtr
Handle to the device context.
See Also

Reference

GdiFontInfos Class
GdiFontInfos Overload
Alternet.Common Namespace


GdiFontInfos Constructor (IntPtr, IntPtr)

GdiFontInfos Constructor (IntPtr, IntPtr)
Initializes a new instance of the GdiFontInfos class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public GdiFontInfos(
    IntPtr fontHandle,
    IntPtr dc
)
Public Sub New (
    fontHandle As IntPtr,
    dc As IntPtr
)
public:
GdiFontInfos(
    IntPtr fontHandle,
    IntPtr dc
)
new :
        fontHandle : IntPtr *
        dc : IntPtr -> GdiFontInfos

Parameters

fontHandle
Type: SystemIntPtr
Font handle.
dc
Type: SystemIntPtr
Handle to the device context.
See Also

Reference

GdiFontInfos Class
GdiFontInfos Overload
Alternet.Common Namespace


GdiFontInfos Methods

GdiFontInfos Methods

The GdiFontInfos type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Frees all resources associated with this FontInfos. (Inherited from FontInfos.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitStyle(FontStyle) | Adds specified style to the style collection. (Inherited from FontInfos.)
Public method | InitStyle(String, FontStyle, Int32) | Adds specified style to the style collection. (Inherited from FontInfos.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GdiFontInfos Class
Alternet.Common Namespace


GdiFontInfos Properties

GdiFontInfos Properties

The GdiFontInfos type exposes the following members.

Properties
 | Name | Description
Public property | CurrentInfo | Represents current FontInfo object. (Inherited from FontInfos.)
Public property | FontHeight | Represents height of the current font. (Inherited from FontInfos.)
Public property | IsMonoSpaced | Represents a value indicating whether current font is monospaced. (Inherited from FontInfos.)
Top
See Also

Reference

GdiFontInfos Class
Alternet.Common Namespace


GdiPainter Class

GdiPainter Class
Encapsulates a Gdi drawing surface, providing properties and methods used to draw text and graphic primitives.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainter
Alternet.CommonGdiPainter

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GdiPainter : Painter, IPainter,
    IDisposable
Public Class GdiPainter
    Inherits Painter
    Implements IPainter, IDisposable
public ref class GdiPainter : public Painter,
    IPainter, IDisposable
type GdiPainter =
    class
        inherit Painter
        interface IPainter
        interface IDisposable
    end

The GdiPainter type exposes the following members.

Constructors
 | Name | Description
Public method | GdiPainter | Initializes a new instance of the GdiPainter class
Top
Methods
 | Name | Description
Public method | BeginPaint | Prepares the GdiPainter to paint. Associates new device context from given Graphics object to GdiPainter and preserves GdiPainter properties.
Public method | CharWidth(Char, Int32) | Returns width of the given number of specified character.
Public method | CharWidth(Char, Int32, Int32, Boolean) | Returns width of the such number of the specified characters fitting into the given Width.
Public method | Clear | Resets all GdiPainter properties to the initial state. (Overrides PainterClear.)
Public method | Dispose | Disposes this Painter and frees resources associated with it. (Inherited from Painter.)
Public method | DrawDotLine | Draws a dotted line from the given start position up to the specified end point.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide) | Draws one or more edges of rectangle.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide, Int32) | Draws one or more edges of rectangle.
Public method | DrawFocusRect(Rectangle, Color) | Draws a border around the specified rectangle using current BackColor.
Public method | DrawFocusRect(Int32, Int32, Int32, Int32, Color) | Draws a border around the specified rectangle using dot pattern.
Public method | DrawImage(ImageList, Int32, Rectangle) | Draws specified image in the specified rectangular area.
Public method | DrawImage(ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | Draws specified image in the specified rectangular area.
Public method | DrawLine(Int32, Int32, Int32, Int32) | Draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawLine(Int32, Int32, Int32, Int32, Color, Int32, DashStyle) | Draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawPolygon | Draws a polygon defined by an array of Point structures.
Public method | DrawRectangle(Rectangle) | Draws a border around the specified rectangle using current BackColor.
Public method | DrawRectangle(Int32, Int32, Int32, Int32) | Draws a border around the specified rectangle using current BackColor.
Public method | DrawRoundRectangle | Draws a rectangle with rounded corners. The rectangle is outlined by using the current pen.
Public method | DrawText | Draws text in the specified rectangle using current values of TextColor and BackColor.
Public method | DrawThemeBackground | Draws the background image defined by the visual style for the specified control part.
Public method | DrawWave | Draws waved line in the specified rectangular area.
Public method | EndPaint | Marks the end of painting. Releases device context associated with this GdiPainter and restores saved GdiPainter properties.
Public method | EndTransform | Sets default two-dimensional linear transformation for the specified device context.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExcludeClipRect(Rectangle) | Creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | ExcludeClipRect(Int32, Int32, Int32, Int32) | Creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | FillGradient(Rectangle, Color, Color, Point, Point) | Fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillGradient(Int32, Int32, Int32, Int32, Color, Color, Point, Point) | Fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillPolygon | Fills the interior of a polygon defined by an array of points specified by Point structures.
Public method | FillRectangle(Rectangle) | Fills the given rectangle by using the current brush.
Public method | FillRectangle(Color, Rectangle) | Fills the given rectangle by using specified color.
Public method | FillRectangle(Int32, Int32, Int32, Int32) | Fills the given rectangular area by using the current brush.
Public method | FillRectangle(Color, Int32, Int32, Int32, Int32) | Fills the given rectangle by using specified color.
Public method | FillRoundRectangle | Fills a rectangle with rounded corners. The rectangle is outlined by using the current pen and filled by using the current brush.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectClipRect(Rectangle) | Creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | IntersectClipRect(Int32, Int32, Int32, Int32) | Creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | RestoreClip | Restores current clipping region from previously saved region.
Public method | SaveClip | Retrieves handle to clipping region saved from specified rectangle.
Public method | SelectNativeFont | Selects font with specified parameters. (Inherited from Painter.)
Public method | StretchDrawImage | Draws stretched image in the specified rectangular area.
Public method | StringWidth(String) | Returns width of the given string.
Public method | StringWidth(String, Int32, Int32) | Returns width of the specified part of the given string.
Public method | StringWidth(String, Int32, Int32, Boolean) | Returns width of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32) | Returns width of the specified part of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32, Boolean) | Returns width of the specified part of the given string fitting into the given Width.
Public method | TextOut(String, Int32, Rectangle) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32) | Draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Boolean, Boolean) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Rectangle, Boolean, Boolean, Int32) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32, Boolean, Boolean) | Draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32) | Draws text within the specified rectangle.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Sets a two-dimensional linear transformation for the specified device context.
Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets background color of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | Font | Gets or sets font of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | FontHeight | Represents height of the font of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | FontStyle | Gets or sets font style of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | FontWidth | Represents width of the font of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | ForeColor | Gets or sets foreground color of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | Graphics | Represents Graphics object used to paint text and graphic primitives.
Public property | Handle | Gets handle to device context currently associated with the IPainter.
Public property | IsMonoSpaced | Represents a value indicating whether font of the device context currently associated with this Painter is monospaced, meaning that all characters drawn with this font have the same width. (Inherited from Painter.)
Public property | LineHeight | When implemented by a class, represents height of the individual lines. (Inherited from Painter.)
Public property | LineSpace | Represents additional height added to the height of the font. (Inherited from Painter.)
Public property | Opaque | Gets or sets a boolean value indicating that background is filled with the current background color before the text is drawn. (Inherited from Painter.)
Public property | StringFormat | Encapsulates text layout information and display manipulations for this Painter. (Inherited from Painter.)
Public property | TextColor | Gets or sets text color of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | Transformation | Gets the world transformation for Graphics property.
Public property | UseDrawText | Indicates whether painter should use DrawText method rather then ExtTextOut to paint text.
Top
See Also

Reference

Alternet.Common Namespace


GdiPainter Constructor

GdiPainter Constructor
Initializes a new instance of the GdiPainter class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public GdiPainter()
Public Sub New
public:
GdiPainter()
new : unit -> GdiPainter
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter Methods

GdiPainter Methods

The GdiPainter type exposes the following members.

Methods
 | Name | Description
Public method | BeginPaint | Prepares the GdiPainter to paint. Associates new device context from given Graphics object to GdiPainter and preserves GdiPainter properties.
Public method | CharWidth(Char, Int32) | Returns width of the given number of specified character.
Public method | CharWidth(Char, Int32, Int32, Boolean) | Returns width of the such number of the specified characters fitting into the given Width.
Public method | Clear | Resets all GdiPainter properties to the initial state. (Overrides PainterClear.)
Public method | Dispose | Disposes this Painter and frees resources associated with it. (Inherited from Painter.)
Public method | DrawDotLine | Draws a dotted line from the given start position up to the specified end point.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide) | Draws one or more edges of rectangle.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide, Int32) | Draws one or more edges of rectangle.
Public method | DrawFocusRect(Rectangle, Color) | Draws a border around the specified rectangle using current BackColor.
Public method | DrawFocusRect(Int32, Int32, Int32, Int32, Color) | Draws a border around the specified rectangle using dot pattern.
Public method | DrawImage(ImageList, Int32, Rectangle) | Draws specified image in the specified rectangular area.
Public method | DrawImage(ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | Draws specified image in the specified rectangular area.
Public method | DrawLine(Int32, Int32, Int32, Int32) | Draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawLine(Int32, Int32, Int32, Int32, Color, Int32, DashStyle) | Draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawPolygon | Draws a polygon defined by an array of Point structures.
Public method | DrawRectangle(Rectangle) | Draws a border around the specified rectangle using current BackColor.
Public method | DrawRectangle(Int32, Int32, Int32, Int32) | Draws a border around the specified rectangle using current BackColor.
Public method | DrawRoundRectangle | Draws a rectangle with rounded corners. The rectangle is outlined by using the current pen.
Public method | DrawText | Draws text in the specified rectangle using current values of TextColor and BackColor.
Public method | DrawThemeBackground | Draws the background image defined by the visual style for the specified control part.
Public method | DrawWave | Draws waved line in the specified rectangular area.
Public method | EndPaint | Marks the end of painting. Releases device context associated with this GdiPainter and restores saved GdiPainter properties.
Public method | EndTransform | Sets default two-dimensional linear transformation for the specified device context.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExcludeClipRect(Rectangle) | Creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | ExcludeClipRect(Int32, Int32, Int32, Int32) | Creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | FillGradient(Rectangle, Color, Color, Point, Point) | Fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillGradient(Int32, Int32, Int32, Int32, Color, Color, Point, Point) | Fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillPolygon | Fills the interior of a polygon defined by an array of points specified by Point structures.
Public method | FillRectangle(Rectangle) | Fills the given rectangle by using the current brush.
Public method | FillRectangle(Color, Rectangle) | Fills the given rectangle by using specified color.
Public method | FillRectangle(Int32, Int32, Int32, Int32) | Fills the given rectangular area by using the current brush.
Public method | FillRectangle(Color, Int32, Int32, Int32, Int32) | Fills the given rectangle by using specified color.
Public method | FillRoundRectangle | Fills a rectangle with rounded corners. The rectangle is outlined by using the current pen and filled by using the current brush.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectClipRect(Rectangle) | Creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | IntersectClipRect(Int32, Int32, Int32, Int32) | Creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | RestoreClip | Restores current clipping region from previously saved region.
Public method | SaveClip | Retrieves handle to clipping region saved from specified rectangle.
Public method | SelectNativeFont | Selects font with specified parameters. (Inherited from Painter.)
Public method | StretchDrawImage | Draws stretched image in the specified rectangular area.
Public method | StringWidth(String) | Returns width of the given string.
Public method | StringWidth(String, Int32, Int32) | Returns width of the specified part of the given string.
Public method | StringWidth(String, Int32, Int32, Boolean) | Returns width of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32) | Returns width of the specified part of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32, Boolean) | Returns width of the specified part of the given string fitting into the given Width.
Public method | TextOut(String, Int32, Rectangle) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32) | Draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Boolean, Boolean) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Rectangle, Boolean, Boolean, Int32) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32, Boolean, Boolean) | Draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32) | Draws text within the specified rectangle.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Sets a two-dimensional linear transformation for the specified device context.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.BeginPaint Method

GdiPainterBeginPaint Method
Prepares the GdiPainter to paint. Associates new device context from given Graphics object to GdiPainter and preserves GdiPainter properties.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void BeginPaint(
    Graphics graphics
)
Public Overridable Sub BeginPaint (
    graphics As Graphics
)
public:
virtual void BeginPaint(
    Graphics^ graphics
)
abstract BeginPaint :
        graphics : Graphics -> unit
override BeginPaint :
        graphics : Graphics -> unit

Parameters

graphics
Type: System.DrawingGraphics
The Graphics object to draw on.

Implements

IPainterBeginPaint(Graphics)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace
GdiPainterEndPaint


GdiPainter.CharWidth Method

GdiPainterCharWidth Method
Overload List
 | Name | Description
Public method | CharWidth(Char, Int32) | Returns width of the given number of specified character.
Public method | CharWidth(Char, Int32, Int32, Boolean) | Returns width of the such number of the specified characters fitting into the given Width.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.CharWidth Method (Char, Int32)

GdiPainterCharWidth Method (Char, Int32)
Returns width of the given number of specified character.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CharWidth(
    char ch,
    int count
)
Public Overridable Function CharWidth (
    ch As Char,
    count As Integer
) As Integer
public:
virtual int CharWidth(
    wchar_t ch,
    int count
)
abstract CharWidth :
        ch : char *
        count : int -> int
override CharWidth :
        ch : char *
        count : int -> int

Parameters

ch
Type: SystemChar
Character to calculate width.
count
Type: SystemInt32
Number of characters.

Return Value

Type: Int32
Width of specified characters.

Implements

IPainterCharWidth(Char, Int32)
See Also

Reference

GdiPainter Class
CharWidth Overload
Alternet.Common Namespace


GdiPainter.CharWidth Method (Char, Int32, Int32, Boolean)

GdiPainterCharWidth Method (Char, Int32, Int32, Boolean)
Returns width of the such number of the specified characters fitting into the given Width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CharWidth(
    char ch,
    int width,
    out int count,
    bool exact
)
Public Overridable Function CharWidth (
    ch As Char,
    width As Integer,
    <OutAttribute> ByRef count As Integer,
    exact As Boolean
) As Integer
public:
virtual int CharWidth(
    wchar_t ch,
    int width,
    [OutAttribute] int% count,
    bool exact
)
abstract CharWidth :
        ch : char *
        width : int *
        count : int byref *
        exact : bool -> int
override CharWidth :
        ch : char *
        width : int *
        count : int byref *
        exact : bool -> int

Parameters

ch
Type: SystemChar
Character to calculate width.
width
Type: SystemInt32
The width that should hold a number of the specified character.
count
Type: SystemInt32
Receive number of character that can fit into specified width.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of specified characters.

Implements

IPainterCharWidth(Char, Int32, Int32, Boolean)
See Also

Reference

GdiPainter Class
CharWidth Overload
Alternet.Common Namespace


GdiPainter.Clear Method

GdiPainterClear Method
Resets all GdiPainter properties to the initial state.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IPainterClear
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawDotLine Method

GdiPainterDrawDotLine Method
Draws a dotted line from the given start position up to the specified end point.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawDotLine(
    int x1,
    int y1,
    int x2,
    int y2,
    Color color1,
    Color color2,
    int size = 1
)
Public Overridable Sub DrawDotLine (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer,
    color1 As Color,
    color2 As Color,
    Optional size As Integer = 1
)
public:
virtual void DrawDotLine(
    int x1,
    int y1,
    int x2,
    int y2,
    Color color1,
    Color color2,
    int size = 1
)
abstract DrawDotLine :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int *
        color1 : Color *
        color2 : Color *
        ?size : int
(* Defaults:
        let _size = defaultArg size 1
*)
-> unit
override DrawDotLine :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int *
        color1 : Color *
        color2 : Color *
        ?size : int
(* Defaults:
        let _size = defaultArg size 1
*)
-> unit

Parameters

x1
Type: SystemInt32
X-coordinate of the line's start point.
y1
Type: SystemInt32
Y-coordinate of the line's start point.
x2
Type: SystemInt32
X-coordinate of the line's ending point.
y2
Type: SystemInt32
Y-coordinate of the line's ending point.
color1
Type: System.DrawingColor
Specifies line color.
color2
Type: System.DrawingColor
Specifies background color.
size (Optional)
Type: SystemInt32
Specifies dot size

Implements

IPainterDrawDotLine(Int32, Int32, Int32, Int32, Color, Color, Int32)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawEdge Method

GdiPainterDrawEdge Method
Overload List
 | Name | Description
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide) | Draws one or more edges of rectangle.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide, Int32) | Draws one or more edges of rectangle.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawEdge Method (Rectangle, Border3DStyle, Border3DSide)

GdiPainterDrawEdge Method (Rectangle, Border3DStyle, Border3DSide)
Draws one or more edges of rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawEdge(
    ref Rectangle rect,
    Border3DStyle border,
    Border3DSide sides
)
Public Overridable Sub DrawEdge (
    ByRef rect As Rectangle,
    border As Border3DStyle,
    sides As Border3DSide
)
public:
virtual void DrawEdge(
    Rectangle% rect,
    Border3DStyle border,
    Border3DSide sides
)
abstract DrawEdge :
        rect : Rectangle byref *
        border : Border3DStyle *
        sides : Border3DSide -> unit
override DrawEdge :
        rect : Rectangle byref *
        border : Border3DStyle *
        sides : Border3DSide -> unit

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle which edges should be drawn.
border
Type: System.Windows.FormsBorder3DStyle
Specifies the style of a three-dimensional border.
sides
Type: System.Windows.FormsBorder3DSide
Specifies the sides of a rectangle to draw.

Implements

IPainterDrawEdge(Rectangle, Border3DStyle, Border3DSide)
See Also

Reference

GdiPainter Class
DrawEdge Overload
Alternet.Common Namespace


GdiPainter.DrawEdge Method (Rectangle, Border3DStyle, Border3DSide, Int32)

GdiPainterDrawEdge Method (Rectangle, Border3DStyle, Border3DSide, Int32)
Draws one or more edges of rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawEdge(
    ref Rectangle rect,
    Border3DStyle border,
    Border3DSide sides,
    int flags
)
Public Overridable Sub DrawEdge (
    ByRef rect As Rectangle,
    border As Border3DStyle,
    sides As Border3DSide,
    flags As Integer
)
public:
virtual void DrawEdge(
    Rectangle% rect,
    Border3DStyle border,
    Border3DSide sides,
    int flags
)
abstract DrawEdge :
        rect : Rectangle byref *
        border : Border3DStyle *
        sides : Border3DSide *
        flags : int -> unit
override DrawEdge :
        rect : Rectangle byref *
        border : Border3DStyle *
        sides : Border3DSide *
        flags : int -> unit

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle which edges should be drawn.
border
Type: System.Windows.FormsBorder3DStyle
Specifies the style of a three-dimensional border.
sides
Type: System.Windows.FormsBorder3DSide
Specifies the sides of a rectangle to draw.
flags
Type: SystemInt32
Additional flags (used for internal purposes).

Implements

IPainterDrawEdge(Rectangle, Border3DStyle, Border3DSide, Int32)
See Also

Reference

GdiPainter Class
DrawEdge Overload
Alternet.Common Namespace


GdiPainter.DrawFocusRect Method

GdiPainterDrawFocusRect Method
Overload List
 | Name | Description
Public method | DrawFocusRect(Rectangle, Color) | Draws a border around the specified rectangle using current BackColor.
Public method | DrawFocusRect(Int32, Int32, Int32, Int32, Color) | Draws a border around the specified rectangle using dot pattern.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawFocusRect Method (Rectangle, Color)

GdiPainterDrawFocusRect Method (Rectangle, Color)
Draws a border around the specified rectangle using current BackColor.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawFocusRect(
    Rectangle rect,
    Color color
)
Public Overridable Sub DrawFocusRect (
    rect As Rectangle,
    color As Color
)
public:
virtual void DrawFocusRect(
    Rectangle rect,
    Color color
)
abstract DrawFocusRect :
        rect : Rectangle *
        color : Color -> unit
override DrawFocusRect :
        rect : Rectangle *
        color : Color -> unit

Parameters

rect
Type: System.DrawingRectangle
The rectangle object to draw border.
color
Type: System.DrawingColor
Color of the frame.

Implements

IPainterDrawFocusRect(Rectangle, Color)
See Also

Reference

GdiPainter Class
DrawFocusRect Overload
Alternet.Common Namespace


GdiPainter.DrawFocusRect Method (Int32, Int32, Int32, Int32, Color)

GdiPainterDrawFocusRect Method (Int32, Int32, Int32, Int32, Color)
Draws a border around the specified rectangle using dot pattern.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawFocusRect(
    int x,
    int y,
    int width,
    int height,
    Color color
)
Public Overridable Sub DrawFocusRect (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer,
    color As Color
)
public:
virtual void DrawFocusRect(
    int x,
    int y,
    int width,
    int height,
    Color color
)
abstract DrawFocusRect :
        x : int *
        y : int *
        width : int *
        height : int *
        color : Color -> unit
override DrawFocusRect :
        x : int *
        y : int *
        width : int *
        height : int *
        color : Color -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.
color
Type: System.DrawingColor
Color of the frame.

Implements

IPainterDrawFocusRect(Int32, Int32, Int32, Int32, Color)
See Also

Reference

GdiPainter Class
DrawFocusRect Overload
Alternet.Common Namespace


GdiPainter.DrawImage Method

GdiPainterDrawImage Method
Overload List
 | Name | Description
Public method | DrawImage(ImageList, Int32, Rectangle) | Draws specified image in the specified rectangular area.
Public method | DrawImage(ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | Draws specified image in the specified rectangular area.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawImage Method (ImageList, Int32, Rectangle)

GdiPainterDrawImage Method (ImageList, Int32, Rectangle)
Draws specified image in the specified rectangular area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawImage(
    ImageList images,
    int index,
    Rectangle rect
)
Public Overridable Sub DrawImage (
    images As ImageList,
    index As Integer,
    rect As Rectangle
)
public:
virtual void DrawImage(
    ImageList^ images,
    int index,
    Rectangle rect
)
abstract DrawImage :
        images : ImageList *
        index : int *
        rect : Rectangle -> unit
override DrawImage :
        images : ImageList *
        index : int *
        rect : Rectangle -> unit

Parameters

images
Type: System.Windows.FormsImageList
Image list that contains image to draw.
index
Type: SystemInt32
Index of image to draw within image list.
rect
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the image.

Implements

IPainterDrawImage(ImageList, Int32, Rectangle)
See Also

Reference

GdiPainter Class
DrawImage Overload
Alternet.Common Namespace


GdiPainter.DrawImage Method (ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)

GdiPainterDrawImage Method (ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)
Draws specified image in the specified rectangular area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawImage(
    ImageList images,
    int index,
    Rectangle rect,
    int srcX,
    int srcY,
    int srcWidth,
    int srcHeight,
    GraphicsUnit srcUnit,
    ImageAttributes imageAttr
)
Public Overridable Sub DrawImage (
    images As ImageList,
    index As Integer,
    rect As Rectangle,
    srcX As Integer,
    srcY As Integer,
    srcWidth As Integer,
    srcHeight As Integer,
    srcUnit As GraphicsUnit,
    imageAttr As ImageAttributes
)
public:
virtual void DrawImage(
    ImageList^ images,
    int index,
    Rectangle rect,
    int srcX,
    int srcY,
    int srcWidth,
    int srcHeight,
    GraphicsUnit srcUnit,
    ImageAttributes^ imageAttr
)
abstract DrawImage :
        images : ImageList *
        index : int *
        rect : Rectangle *
        srcX : int *
        srcY : int *
        srcWidth : int *
        srcHeight : int *
        srcUnit : GraphicsUnit *
        imageAttr : ImageAttributes -> unit
override DrawImage :
        images : ImageList *
        index : int *
        rect : Rectangle *
        srcX : int *
        srcY : int *
        srcWidth : int *
        srcHeight : int *
        srcUnit : GraphicsUnit *
        imageAttr : ImageAttributes -> unit

Parameters

images
Type: System.Windows.FormsImageList
Image list that contains image to draw.
index
Type: SystemInt32
Index of image to draw within image list.
rect
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the image.
srcX
Type: SystemInt32
X-coordinate of the upper-left corner of the portion of the source image to be drawn.
srcY
Type: SystemInt32
Y-coordinate of the upper-left corner of the portion of the source image to be drawn.
srcWidth
Type: SystemInt32
Width of the portion of the source image to be drawn.
srcHeight
Type: SystemInt32
Height of the portion of the source image to be drawn.
srcUnit
Type: System.DrawingGraphicsUnit
Specifies the unit of measure for the image.
imageAttr
Type: System.Drawing.ImagingImageAttributes
Specifies the color and size attributes of the image to be drawn.

Implements

IPainterDrawImage(ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)
See Also

Reference

GdiPainter Class
DrawImage Overload
Alternet.Common Namespace


GdiPainter.DrawLine Method

GdiPainterDrawLine Method
Overload List
 | Name | Description
Public method | DrawLine(Int32, Int32, Int32, Int32) | Draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawLine(Int32, Int32, Int32, Int32, Color, Int32, DashStyle) | Draws a line from the given start position up to, but not including, the specified end point.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawLine Method (Int32, Int32, Int32, Int32)

GdiPainterDrawLine Method (Int32, Int32, Int32, Int32)
Draws a line from the given start position up to, but not including, the specified end point.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawLine(
    int x1,
    int y1,
    int x2,
    int y2
)
Public Overridable Sub DrawLine (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer
)
public:
virtual void DrawLine(
    int x1,
    int y1,
    int x2,
    int y2
)
abstract DrawLine :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int -> unit
override DrawLine :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int -> unit

Parameters

x1
Type: SystemInt32
X-coordinate of the line's start point.
y1
Type: SystemInt32
Y-coordinate of the line's start point.
x2
Type: SystemInt32
X-coordinate of the line's ending point.
y2
Type: SystemInt32
Y-coordinate of the line's ending point.

Implements

IPainterDrawLine(Int32, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
DrawLine Overload
Alternet.Common Namespace


GdiPainter.DrawLine Method (Int32, Int32, Int32, Int32, Color, Int32, DashStyle)

GdiPainterDrawLine Method (Int32, Int32, Int32, Int32, Color, Int32, DashStyle)
Draws a line from the given start position up to, but not including, the specified end point.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawLine(
    int x1,
    int y1,
    int x2,
    int y2,
    Color color,
    int width,
    DashStyle penStyle
)
Public Overridable Sub DrawLine (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer,
    color As Color,
    width As Integer,
    penStyle As DashStyle
)
public:
virtual void DrawLine(
    int x1,
    int y1,
    int x2,
    int y2,
    Color color,
    int width,
    DashStyle penStyle
)
abstract DrawLine :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int *
        color : Color *
        width : int *
        penStyle : DashStyle -> unit
override DrawLine :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int *
        color : Color *
        width : int *
        penStyle : DashStyle -> unit

Parameters

x1
Type: SystemInt32
X-coordinate of the line's start point.
y1
Type: SystemInt32
Y-coordinate of the line's start point.
x2
Type: SystemInt32
X-coordinate of the line's ending point.
y2
Type: SystemInt32
Y-coordinate of the line's ending point.
color
Type: System.DrawingColor
Specifies color of the Pen object to draw line.
width
Type: SystemInt32
Specifies width of the Pen object to draw line.
penStyle
Type: System.Drawing.Drawing2DDashStyle
Specifies style of the Pen object to draw line.

Implements

IPainterDrawLine(Int32, Int32, Int32, Int32, Color, Int32, DashStyle)
See Also

Reference

GdiPainter Class
DrawLine Overload
Alternet.Common Namespace


GdiPainter.DrawPolygon Method

GdiPainterDrawPolygon Method
Draws a polygon defined by an array of Point structures.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawPolygon(
    Point[] points,
    Color color
)
Public Overridable Sub DrawPolygon (
    points As Point(),
    color As Color
)
public:
virtual void DrawPolygon(
    array<Point>^ points,
    Color color
)
abstract DrawPolygon :
        points : Point[] *
        color : Color -> unit
override DrawPolygon :
        points : Point[] *
        color : Color -> unit

Parameters

points
Type: System.DrawingPoint
Array of Point structures that represent the vertices of the polygon.
color
Type: System.DrawingColor
Specifies color of the polygon.

Implements

IPainterDrawPolygon(Point, Color)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawRectangle Method

GdiPainterDrawRectangle Method
Overload List
 | Name | Description
Public method | DrawRectangle(Rectangle) | Draws a border around the specified rectangle using current BackColor.
Public method | DrawRectangle(Int32, Int32, Int32, Int32) | Draws a border around the specified rectangle using current BackColor.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawRectangle Method (Rectangle)

GdiPainterDrawRectangle Method (Rectangle)
Draws a border around the specified rectangle using current BackColor.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawRectangle(
    Rectangle rect
)
Public Overridable Sub DrawRectangle (
    rect As Rectangle
)
public:
virtual void DrawRectangle(
    Rectangle rect
)
abstract DrawRectangle :
        rect : Rectangle -> unit
override DrawRectangle :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
The rectangle object to draw border.

Implements

IPainterDrawRectangle(Rectangle)
See Also

Reference

GdiPainter Class
DrawRectangle Overload
Alternet.Common Namespace


GdiPainter.DrawRectangle Method (Int32, Int32, Int32, Int32)

GdiPainterDrawRectangle Method (Int32, Int32, Int32, Int32)
Draws a border around the specified rectangle using current BackColor.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawRectangle(
    int x,
    int y,
    int width,
    int height
)
Public Overridable Sub DrawRectangle (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
virtual void DrawRectangle(
    int x,
    int y,
    int width,
    int height
)
abstract DrawRectangle :
        x : int *
        y : int *
        width : int *
        height : int -> unit
override DrawRectangle :
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.

Implements

IPainterDrawRectangle(Int32, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
DrawRectangle Overload
Alternet.Common Namespace


GdiPainter.DrawRoundRectangle Method

GdiPainterDrawRoundRectangle Method
Draws a rectangle with rounded corners. The rectangle is outlined by using the current pen.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawRoundRectangle(
    int left,
    int top,
    int right,
    int bottom,
    int width,
    int height
)
Public Overridable Sub DrawRoundRectangle (
    left As Integer,
    top As Integer,
    right As Integer,
    bottom As Integer,
    width As Integer,
    height As Integer
)
public:
virtual void DrawRoundRectangle(
    int left,
    int top,
    int right,
    int bottom,
    int width,
    int height
)
abstract DrawRoundRectangle :
        left : int *
        top : int *
        right : int *
        bottom : int *
        width : int *
        height : int -> unit
override DrawRoundRectangle :
        left : int *
        top : int *
        right : int *
        bottom : int *
        width : int *
        height : int -> unit

Parameters

left
Type: SystemInt32
Specifies the x-coordinate, in logical coordinates, of the upper-left corner of the rectangle.
top
Type: SystemInt32
Specifies the y-coordinate, in logical coordinates, of the upper-left corner of the rectangle.
right
Type: SystemInt32
Specifies the x-coordinate, in logical coordinates, of the lower-right corner of the rectangle.
bottom
Type: SystemInt32
Specifies the y-coordinate, in logical coordinates, of the lower-right corner of the rectangle.
width
Type: SystemInt32
Specifies the width, in logical coordinates, of the ellipse used to draw the rounded corners.
height
Type: SystemInt32
Specifies the height, in logical coordinates, of the ellipse used to draw the rounded corners.

Implements

IPainterDrawRoundRectangle(Int32, Int32, Int32, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawText Method

GdiPainterDrawText Method
Draws text in the specified rectangle using current values of TextColor and BackColor.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawText(
    string text,
    int len,
    Rectangle rect
)
Public Overridable Sub DrawText (
    text As String,
    len As Integer,
    rect As Rectangle
)
public:
virtual void DrawText(
    String^ text,
    int len,
    Rectangle rect
)
abstract DrawText :
        text : string *
        len : int *
        rect : Rectangle -> unit
override DrawText :
        text : string *
        len : int *
        rect : Rectangle -> unit

Parameters

text
Type: SystemString
The text to be draw.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
The layout area for drawing text.

Implements

IPainterDrawText(String, Int32, Rectangle)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawThemeBackground Method

GdiPainterDrawThemeBackground Method
Draws the background image defined by the visual style for the specified control part.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawThemeBackground(
    IntPtr handle,
    int partID,
    int stateID,
    Rectangle rect
)
Public Overridable Sub DrawThemeBackground (
    handle As IntPtr,
    partID As Integer,
    stateID As Integer,
    rect As Rectangle
)
public:
virtual void DrawThemeBackground(
    IntPtr handle,
    int partID,
    int stateID,
    Rectangle rect
)
abstract DrawThemeBackground :
        handle : IntPtr *
        partID : int *
        stateID : int *
        rect : Rectangle -> unit
override DrawThemeBackground :
        handle : IntPtr *
        partID : int *
        stateID : int *
        rect : Rectangle -> unit

Parameters

handle
Type: SystemIntPtr
Handle to a window's specified theme data.
partID
Type: SystemInt32
Specifies the part to draw.
stateID
Type: SystemInt32
Specifies the state of the part to draw.
rect
Type: System.DrawingRectangle
Specifies the rectangle, in logical coordinates, in which the background image is drawn.

Implements

IPainterDrawThemeBackground(IntPtr, Int32, Int32, Rectangle)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.DrawWave Method

GdiPainterDrawWave Method
Draws waved line in the specified rectangular area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawWave(
    Rectangle rect,
    Color color
)
Public Overridable Sub DrawWave (
    rect As Rectangle,
    color As Color
)
public:
virtual void DrawWave(
    Rectangle rect,
    Color color
)
abstract DrawWave :
        rect : Rectangle *
        color : Color -> unit
override DrawWave :
        rect : Rectangle *
        color : Color -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the wave.
color
Type: System.DrawingColor
Color used to draw wave.

Implements

IPainterDrawWave(Rectangle, Color)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.EndPaint Method

GdiPainterEndPaint Method
Marks the end of painting. Releases device context associated with this GdiPainter and restores saved GdiPainter properties.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EndPaint()
Public Overridable Sub EndPaint
public:
virtual void EndPaint()
abstract EndPaint : unit -> unit
override EndPaint : unit -> unit

Implements

IPainterEndPaint
See Also

Reference

GdiPainter Class
Alternet.Common Namespace
GdiPainterBeginPaint(Graphics)


GdiPainter.EndTransform Method

GdiPainterEndTransform Method
Sets default two-dimensional linear transformation for the specified device context.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EndTransform()
Public Overridable Sub EndTransform
public:
virtual void EndTransform()
abstract EndTransform : unit -> unit
override EndTransform : unit -> unit

Implements

IPainterEndTransform
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.ExcludeClipRect Method

GdiPainterExcludeClipRect Method
Overload List
 | Name | Description
Public method | ExcludeClipRect(Rectangle) | Creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | ExcludeClipRect(Int32, Int32, Int32, Int32) | Creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.ExcludeClipRect Method (Rectangle)

GdiPainterExcludeClipRect Method (Rectangle)
Creates a new clipping region that consists of the existing clipping region minus the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ExcludeClipRect(
    Rectangle rect
)
Public Overridable Sub ExcludeClipRect (
    rect As Rectangle
)
public:
virtual void ExcludeClipRect(
    Rectangle rect
)
abstract ExcludeClipRect :
        rect : Rectangle -> unit
override ExcludeClipRect :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangle to exclude.

Implements

IPainterExcludeClipRect(Rectangle)
See Also

Reference

GdiPainter Class
ExcludeClipRect Overload
Alternet.Common Namespace


GdiPainter.ExcludeClipRect Method (Int32, Int32, Int32, Int32)

GdiPainterExcludeClipRect Method (Int32, Int32, Int32, Int32)
Creates a new clipping region that consists of the existing clipping region minus the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ExcludeClipRect(
    int x,
    int y,
    int width,
    int height
)
Public Overridable Sub ExcludeClipRect (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
virtual void ExcludeClipRect(
    int x,
    int y,
    int width,
    int height
)
abstract ExcludeClipRect :
        x : int *
        y : int *
        width : int *
        height : int -> unit
override ExcludeClipRect :
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate, of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate, of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.

Implements

IPainterExcludeClipRect(Int32, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
ExcludeClipRect Overload
Alternet.Common Namespace


GdiPainter.FillGradient Method

GdiPainterFillGradient Method
Overload List
 | Name | Description
Public method | FillGradient(Rectangle, Color, Color, Point, Point) | Fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillGradient(Int32, Int32, Int32, Int32, Color, Color, Point, Point) | Fills the given rectangle with color that smoothly fades from one side to the other.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.FillGradient Method (Rectangle, Color, Color, Point, Point)

GdiPainterFillGradient Method (Rectangle, Color, Color, Point, Point)
Fills the given rectangle with color that smoothly fades from one side to the other.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillGradient(
    Rectangle rect,
    Color beginColor,
    Color endColor,
    Point point1,
    Point point2
)
Public Overridable Sub FillGradient (
    rect As Rectangle,
    beginColor As Color,
    endColor As Color,
    point1 As Point,
    point2 As Point
)
public:
virtual void FillGradient(
    Rectangle rect,
    Color beginColor,
    Color endColor,
    Point point1,
    Point point2
)
abstract FillGradient :
        rect : Rectangle *
        beginColor : Color *
        endColor : Color *
        point1 : Point *
        point2 : Point -> unit
override FillGradient :
        rect : Rectangle *
        beginColor : Color *
        endColor : Color *
        point1 : Point *
        point2 : Point -> unit

Parameters

rect
Type: System.DrawingRectangle
The rectangle object to fill.
beginColor
Type: System.DrawingColor
A Color structure that represents the starting color of the linear gradient.
endColor
Type: System.DrawingColor
A Color structure that represents the ending color of the linear gradient.
point1
Type: System.DrawingPoint
A Point structure that represents the start point of the linear gradient.
point2
Type: System.DrawingPoint
A Point structure that represents the end point of the linear gradient.

Implements

IPainterFillGradient(Rectangle, Color, Color, Point, Point)
See Also

Reference

GdiPainter Class
FillGradient Overload
Alternet.Common Namespace


GdiPainter.FillGradient Method (Int32, Int32, Int32, Int32, Color, Color, Point, Point)

GdiPainterFillGradient Method (Int32, Int32, Int32, Int32, Color, Color, Point, Point)
Fills the given rectangle with color that smoothly fades from one side to the other.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillGradient(
    int x,
    int y,
    int width,
    int height,
    Color beginColor,
    Color endColor,
    Point point1,
    Point point2
)
Public Overridable Sub FillGradient (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer,
    beginColor As Color,
    endColor As Color,
    point1 As Point,
    point2 As Point
)
public:
virtual void FillGradient(
    int x,
    int y,
    int width,
    int height,
    Color beginColor,
    Color endColor,
    Point point1,
    Point point2
)
abstract FillGradient :
        x : int *
        y : int *
        width : int *
        height : int *
        beginColor : Color *
        endColor : Color *
        point1 : Point *
        point2 : Point -> unit
override FillGradient :
        x : int *
        y : int *
        width : int *
        height : int *
        beginColor : Color *
        endColor : Color *
        point1 : Point *
        point2 : Point -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.
beginColor
Type: System.DrawingColor
A Color structure that represents the starting color of the linear gradient.
endColor
Type: System.DrawingColor
A Color structure that represents the ending color of the linear gradient.
point1
Type: System.DrawingPoint
A Point structure that represents the start point of the linear gradient.
point2
Type: System.DrawingPoint
A Point structure that represents the end point of the linear gradient.

Implements

IPainterFillGradient(Int32, Int32, Int32, Int32, Color, Color, Point, Point)
See Also

Reference

GdiPainter Class
FillGradient Overload
Alternet.Common Namespace


GdiPainter.FillPolygon Method

GdiPainterFillPolygon Method
Fills the interior of a polygon defined by an array of points specified by Point structures.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillPolygon(
    Color color,
    Point[] points
)
Public Overridable Sub FillPolygon (
    color As Color,
    points As Point()
)
public:
virtual void FillPolygon(
    Color color,
    array<Point>^ points
)
abstract FillPolygon :
        color : Color *
        points : Point[] -> unit
override FillPolygon :
        color : Color *
        points : Point[] -> unit

Parameters

color
Type: System.DrawingColor
Specifies color to fill polygon.
points
Type: System.DrawingPoint
Array of Point structures that represent the vertices of the polygon to fill.

Implements

IPainterFillPolygon(Color, Point)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.FillRectangle Method

GdiPainterFillRectangle Method
Overload List
 | Name | Description
Public method | FillRectangle(Rectangle) | Fills the given rectangle by using the current brush.
Public method | FillRectangle(Color, Rectangle) | Fills the given rectangle by using specified color.
Public method | FillRectangle(Int32, Int32, Int32, Int32) | Fills the given rectangular area by using the current brush.
Public method | FillRectangle(Color, Int32, Int32, Int32, Int32) | Fills the given rectangle by using specified color.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.FillRectangle Method (Rectangle)

GdiPainterFillRectangle Method (Rectangle)
Fills the given rectangle by using the current brush.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillRectangle(
    Rectangle rect
)
Public Overridable Sub FillRectangle (
    rect As Rectangle
)
public:
virtual void FillRectangle(
    Rectangle rect
)
abstract FillRectangle :
        rect : Rectangle -> unit
override FillRectangle :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
The rectangle object to fill.

Implements

IPainterFillRectangle(Rectangle)
See Also

Reference

GdiPainter Class
FillRectangle Overload
Alternet.Common Namespace


GdiPainter.FillRectangle Method (Color, Rectangle)

GdiPainterFillRectangle Method (Color, Rectangle)
Fills the given rectangle by using specified color.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillRectangle(
    Color color,
    Rectangle rect
)
Public Overridable Sub FillRectangle (
    color As Color,
    rect As Rectangle
)
public:
virtual void FillRectangle(
    Color color,
    Rectangle rect
)
abstract FillRectangle :
        color : Color *
        rect : Rectangle -> unit
override FillRectangle :
        color : Color *
        rect : Rectangle -> unit

Parameters

color
Type: System.DrawingColor
Specified color to fill rectangle.
rect
Type: System.DrawingRectangle
The rectangle object to fill.

Implements

IPainterFillRectangle(Color, Rectangle)
See Also

Reference

GdiPainter Class
FillRectangle Overload
Alternet.Common Namespace


GdiPainter.FillRectangle Method (Int32, Int32, Int32, Int32)

GdiPainterFillRectangle Method (Int32, Int32, Int32, Int32)
Fills the given rectangular area by using the current brush.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillRectangle(
    int x,
    int y,
    int width,
    int height
)
Public Overridable Sub FillRectangle (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
virtual void FillRectangle(
    int x,
    int y,
    int width,
    int height
)
abstract FillRectangle :
        x : int *
        y : int *
        width : int *
        height : int -> unit
override FillRectangle :
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.

Implements

IPainterFillRectangle(Int32, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
FillRectangle Overload
Alternet.Common Namespace


GdiPainter.FillRectangle Method (Color, Int32, Int32, Int32, Int32)

GdiPainterFillRectangle Method (Color, Int32, Int32, Int32, Int32)
Fills the given rectangle by using specified color.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillRectangle(
    Color color,
    int x,
    int y,
    int width,
    int height
)
Public Overridable Sub FillRectangle (
    color As Color,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
virtual void FillRectangle(
    Color color,
    int x,
    int y,
    int width,
    int height
)
abstract FillRectangle :
        color : Color *
        x : int *
        y : int *
        width : int *
        height : int -> unit
override FillRectangle :
        color : Color *
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

color
Type: System.DrawingColor
Specified color to fill rectangle.
x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.

Implements

IPainterFillRectangle(Color, Int32, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
FillRectangle Overload
Alternet.Common Namespace


GdiPainter.FillRoundRectangle Method

GdiPainterFillRoundRectangle Method
Fills a rectangle with rounded corners. The rectangle is outlined by using the current pen and filled by using the current brush.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillRoundRectangle(
    int left,
    int top,
    int right,
    int bottom,
    int width,
    int height
)
Public Overridable Sub FillRoundRectangle (
    left As Integer,
    top As Integer,
    right As Integer,
    bottom As Integer,
    width As Integer,
    height As Integer
)
public:
virtual void FillRoundRectangle(
    int left,
    int top,
    int right,
    int bottom,
    int width,
    int height
)
abstract FillRoundRectangle :
        left : int *
        top : int *
        right : int *
        bottom : int *
        width : int *
        height : int -> unit
override FillRoundRectangle :
        left : int *
        top : int *
        right : int *
        bottom : int *
        width : int *
        height : int -> unit

Parameters

left
Type: SystemInt32
Specifies the x-coordinate, in logical coordinates, of the upper-left corner of the rectangle.
top
Type: SystemInt32
Specifies the y-coordinate, in logical coordinates, of the upper-left corner of the rectangle.
right
Type: SystemInt32
Specifies the x-coordinate, in logical coordinates, of the lower-right corner of the rectangle.
bottom
Type: SystemInt32
Specifies the y-coordinate, in logical coordinates, of the lower-right corner of the rectangle.
width
Type: SystemInt32
Specifies the width, in logical coordinates, of the ellipse used to draw the rounded corners.
height
Type: SystemInt32
Specifies the height, in logical coordinates, of the ellipse used to draw the rounded corners.

Implements

IPainterFillRoundRectangle(Int32, Int32, Int32, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.IntersectClipRect Method

GdiPainterIntersectClipRect Method
Overload List
 | Name | Description
Public method | IntersectClipRect(Rectangle) | Creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | IntersectClipRect(Int32, Int32, Int32, Int32) | Creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.IntersectClipRect Method (Rectangle)

GdiPainterIntersectClipRect Method (Rectangle)
Creates a new clipping region from the intersection of the current clipping region and the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void IntersectClipRect(
    Rectangle rect
)
Public Overridable Sub IntersectClipRect (
    rect As Rectangle
)
public:
virtual void IntersectClipRect(
    Rectangle rect
)
abstract IntersectClipRect :
        rect : Rectangle -> unit
override IntersectClipRect :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangle to intersect.

Implements

IPainterIntersectClipRect(Rectangle)
See Also

Reference

GdiPainter Class
IntersectClipRect Overload
Alternet.Common Namespace


GdiPainter.IntersectClipRect Method (Int32, Int32, Int32, Int32)

GdiPainterIntersectClipRect Method (Int32, Int32, Int32, Int32)
Creates a new clipping region from the intersection of the current clipping region and the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void IntersectClipRect(
    int x,
    int y,
    int width,
    int height
)
Public Overridable Sub IntersectClipRect (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
virtual void IntersectClipRect(
    int x,
    int y,
    int width,
    int height
)
abstract IntersectClipRect :
        x : int *
        y : int *
        width : int *
        height : int -> unit
override IntersectClipRect :
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.

Implements

IPainterIntersectClipRect(Int32, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
IntersectClipRect Overload
Alternet.Common Namespace


GdiPainter.RestoreClip Method

GdiPainterRestoreClip Method
Restores current clipping region from previously saved region.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RestoreClip(
    IntPtr rgn
)
Public Overridable Sub RestoreClip (
    rgn As IntPtr
)
public:
virtual void RestoreClip(
    IntPtr rgn
)
abstract RestoreClip :
        rgn : IntPtr -> unit
override RestoreClip :
        rgn : IntPtr -> unit

Parameters

rgn
Type: SystemIntPtr
Specifies handle to the previously saved clipping region.

Implements

IPainterRestoreClip(IntPtr)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.SaveClip Method

GdiPainterSaveClip Method
Retrieves handle to clipping region saved from specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IntPtr SaveClip(
    Rectangle rect
)
Public Overridable Function SaveClip (
    rect As Rectangle
) As IntPtr
public:
virtual IntPtr SaveClip(
    Rectangle rect
)
abstract SaveClip :
        rect : Rectangle -> IntPtr
override SaveClip :
        rect : Rectangle -> IntPtr

Parameters

rect
Type: System.DrawingRectangle
Rectangle to process.

Return Value

Type: IntPtr
Handle to clipping region.

Implements

IPainterSaveClip(Rectangle)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.StretchDrawImage Method

GdiPainterStretchDrawImage Method
Draws stretched image in the specified rectangular area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StretchDrawImage(
    Rectangle rect,
    Rectangle stretchRect,
    Rectangle imageRect,
    Bitmap image
)
Public Overridable Sub StretchDrawImage (
    rect As Rectangle,
    stretchRect As Rectangle,
    imageRect As Rectangle,
    image As Bitmap
)
public:
virtual void StretchDrawImage(
    Rectangle rect,
    Rectangle stretchRect,
    Rectangle imageRect,
    Bitmap^ image
)
abstract StretchDrawImage :
        rect : Rectangle *
        stretchRect : Rectangle *
        imageRect : Rectangle *
        image : Bitmap -> unit
override StretchDrawImage :
        rect : Rectangle *
        stretchRect : Rectangle *
        imageRect : Rectangle *
        image : Bitmap -> unit

Parameters

rect
Type: System.DrawingRectangle
Base rect
stretchRect
Type: System.DrawingRectangle
Stretch rect
imageRect
Type: System.DrawingRectangle
Image rect
image
Type: System.DrawingBitmap
Specifies image to draw.

Implements

IPainterStretchDrawImage(Rectangle, Rectangle, Rectangle, Bitmap)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.StringWidth Method

GdiPainterStringWidth Method
Overload List
 | Name | Description
Public method | StringWidth(String) | Returns width of the given string.
Public method | StringWidth(String, Int32, Int32) | Returns width of the specified part of the given string.
Public method | StringWidth(String, Int32, Int32, Boolean) | Returns width of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32) | Returns width of the specified part of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32, Boolean) | Returns width of the specified part of the given string fitting into the given Width.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.StringWidth Method (String)

GdiPainterStringWidth Method (String)
Returns width of the given string.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StringWidth(
    string text
)
Public Overridable Function StringWidth (
    text As String
) As Integer
public:
virtual int StringWidth(
    String^ text
)
abstract StringWidth :
        text : string -> int
override StringWidth :
        text : string -> int

Parameters

text
Type: SystemString
The text to calculate width.

Return Value

Type: Int32
Width of specified string.

Implements

IPainterStringWidth(String)
See Also

Reference

GdiPainter Class
StringWidth Overload
Alternet.Common Namespace


GdiPainter.StringWidth Method (String, Int32, Int32)

GdiPainterStringWidth Method (String, Int32, Int32)
Returns width of the specified part of the given string.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StringWidth(
    string text,
    int pos,
    int len
)
Public Overridable Function StringWidth (
    text As String,
    pos As Integer,
    len As Integer
) As Integer
public:
virtual int StringWidth(
    String^ text,
    int pos,
    int len
)
abstract StringWidth :
        text : string *
        pos : int *
        len : int -> int
override StringWidth :
        text : string *
        pos : int *
        len : int -> int

Parameters

text
Type: SystemString
The text to calculate width.
pos
Type: SystemInt32
Position of the first character to start calculating.
len
Type: SystemInt32
Length of the part of string to calculate width.

Return Value

Type: Int32
Width of the part of string.

Implements

IPainterStringWidth(String, Int32, Int32)
See Also

Reference

GdiPainter Class
StringWidth Overload
Alternet.Common Namespace


GdiPainter.StringWidth Method (String, Int32, Int32, Boolean)

GdiPainterStringWidth Method (String, Int32, Int32, Boolean)
Returns width of the given string fitting into the given Width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StringWidth(
    string text,
    int width,
    out int count,
    bool exact
)
Public Overridable Function StringWidth (
    text As String,
    width As Integer,
    <OutAttribute> ByRef count As Integer,
    exact As Boolean
) As Integer
public:
virtual int StringWidth(
    String^ text,
    int width,
    [OutAttribute] int% count,
    bool exact
)
abstract StringWidth :
        text : string *
        width : int *
        count : int byref *
        exact : bool -> int
override StringWidth :
        text : string *
        width : int *
        count : int byref *
        exact : bool -> int

Parameters

text
Type: SystemString
The text to calculate width.
width
Type: SystemInt32
Maximum layout area for the string.
count
Type: SystemInt32
Receives number of character fitting into specified Width.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the part of string.

Implements

IPainterStringWidth(String, Int32, Int32, Boolean)
See Also

Reference

GdiPainter Class
StringWidth Overload
Alternet.Common Namespace


GdiPainter.StringWidth Method (String, Int32, Int32, Int32, Int32)

GdiPainterStringWidth Method (String, Int32, Int32, Int32, Int32)
Returns width of the specified part of the given string fitting into the given Width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StringWidth(
    string text,
    int pos,
    int len,
    int width,
    out int count
)
Public Overridable Function StringWidth (
    text As String,
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef count As Integer
) As Integer
public:
virtual int StringWidth(
    String^ text,
    int pos,
    int len,
    int width,
    [OutAttribute] int% count
)
abstract StringWidth :
        text : string *
        pos : int *
        len : int *
        width : int *
        count : int byref -> int
override StringWidth :
        text : string *
        pos : int *
        len : int *
        width : int *
        count : int byref -> int

Parameters

text
Type: SystemString
The text to calculate width.
pos
Type: SystemInt32
Position of the first character to start calculating.
len
Type: SystemInt32
Length of the part of string to calculate width.
width
Type: SystemInt32
Maximum layout area for the string.
count
Type: SystemInt32
Receives number of characters fitting into specified Width.

Return Value

Type: Int32
Width of the part of string.

Implements

IPainterStringWidth(String, Int32, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
StringWidth Overload
Alternet.Common Namespace


GdiPainter.StringWidth Method (String, Int32, Int32, Int32, Int32, Boolean)

GdiPainterStringWidth Method (String, Int32, Int32, Int32, Int32, Boolean)
Returns width of the specified part of the given string fitting into the given Width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StringWidth(
    string text,
    int pos,
    int len,
    int width,
    out int count,
    bool exact
)
Public Overridable Function StringWidth (
    text As String,
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef count As Integer,
    exact As Boolean
) As Integer
public:
virtual int StringWidth(
    String^ text,
    int pos,
    int len,
    int width,
    [OutAttribute] int% count,
    bool exact
)
abstract StringWidth :
        text : string *
        pos : int *
        len : int *
        width : int *
        count : int byref *
        exact : bool -> int
override StringWidth :
        text : string *
        pos : int *
        len : int *
        width : int *
        count : int byref *
        exact : bool -> int

Parameters

text
Type: SystemString
The text to calculate width.
pos
Type: SystemInt32
Position of the first character to start calculating.
len
Type: SystemInt32
Length of the part of string to calculate width.
width
Type: SystemInt32
Maximum layout area for the string.
count
Type: SystemInt32
Receives number of characters fitting into the into the specified Width.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the part of string.

Implements

IPainterStringWidth(String, Int32, Int32, Int32, Int32, Boolean)
See Also

Reference

GdiPainter Class
StringWidth Overload
Alternet.Common Namespace


GdiPainter.TextOut Method

GdiPainterTextOut Method
Overload List
 | Name | Description
Public method | TextOut(String, Int32, Rectangle) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32) | Draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Boolean, Boolean) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Rectangle, Boolean, Boolean, Int32) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32, Boolean, Boolean) | Draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean) | Draws text within the specified rectangle.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32) | Draws text within the specified rectangle.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.TextOut Method (String, Int32, Rectangle)

GdiPainterTextOut Method (String, Int32, Rectangle)
Draws text within the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TextOut(
    string text,
    int len,
    Rectangle rect
)
Public Overridable Sub TextOut (
    text As String,
    len As Integer,
    rect As Rectangle
)
public:
virtual void TextOut(
    String^ text,
    int len,
    Rectangle rect
)
abstract TextOut :
        text : string *
        len : int *
        rect : Rectangle -> unit
override TextOut :
        text : string *
        len : int *
        rect : Rectangle -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.

Implements

IPainterTextOut(String, Int32, Rectangle)
See Also

Reference

GdiPainter Class
TextOut Overload
Alternet.Common Namespace


GdiPainter.TextOut Method (String, Int32, Int32, Int32)

GdiPainterTextOut Method (String, Int32, Int32, Int32)
Draws text in the specified location.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TextOut(
    string text,
    int len,
    int x,
    int y
)
Public Overridable Sub TextOut (
    text As String,
    len As Integer,
    x As Integer,
    y As Integer
)
public:
virtual void TextOut(
    String^ text,
    int len,
    int x,
    int y
)
abstract TextOut :
        text : string *
        len : int *
        x : int *
        y : int -> unit
override TextOut :
        text : string *
        len : int *
        x : int *
        y : int -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
x
Type: SystemInt32
X-coordinate of the start text point.
y
Type: SystemInt32
Y-coordinate of the start text point.

Implements

IPainterTextOut(String, Int32, Int32, Int32)
See Also

Reference

GdiPainter Class
TextOut Overload
Alternet.Common Namespace


GdiPainter.TextOut Method (String, Int32, Rectangle, Boolean, Boolean)

GdiPainterTextOut Method (String, Int32, Rectangle, Boolean, Boolean)
Draws text within the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TextOut(
    string text,
    int len,
    Rectangle rect,
    bool clipped,
    bool opaque
)
Public Overridable Sub TextOut (
    text As String,
    len As Integer,
    rect As Rectangle,
    clipped As Boolean,
    opaque As Boolean
)
public:
virtual void TextOut(
    String^ text,
    int len,
    Rectangle rect,
    bool clipped,
    bool opaque
)
abstract TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        clipped : bool *
        opaque : bool -> unit
override TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        clipped : bool *
        opaque : bool -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.
clipped
Type: SystemBoolean
Specifies that text will be clipped to the rectangle.
opaque
Type: SystemBoolean
Specifies that current background color should be used to fill the rectangle.

Implements

IPainterTextOut(String, Int32, Rectangle, Boolean, Boolean)
See Also

Reference

GdiPainter Class
TextOut Overload
Alternet.Common Namespace


GdiPainter.TextOut Method (String, Int32, Rectangle, Boolean, Boolean, Int32)

GdiPainterTextOut Method (String, Int32, Rectangle, Boolean, Boolean, Int32)
Draws text within the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TextOut(
    string text,
    int len,
    Rectangle rect,
    bool clipped,
    bool opaque,
    int space
)
Public Overridable Sub TextOut (
    text As String,
    len As Integer,
    rect As Rectangle,
    clipped As Boolean,
    opaque As Boolean,
    space As Integer
)
public:
virtual void TextOut(
    String^ text,
    int len,
    Rectangle rect,
    bool clipped,
    bool opaque,
    int space
)
abstract TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        clipped : bool *
        opaque : bool *
        space : int -> unit
override TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        clipped : bool *
        opaque : bool *
        space : int -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.
clipped
Type: SystemBoolean
Specifies that text will be clipped to the rectangle.
opaque
Type: SystemBoolean
Specifies that current background color should be used to fill the rectangle.
space
Type: SystemInt32
Specifies distance between origins of adjacent character cells.
See Also

Reference

GdiPainter Class
TextOut Overload
Alternet.Common Namespace


GdiPainter.TextOut Method (String, Int32, Int32, Int32, Boolean, Boolean)

GdiPainterTextOut Method (String, Int32, Int32, Int32, Boolean, Boolean)
Draws text in the specified location.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TextOut(
    string text,
    int len,
    int x,
    int y,
    bool clipped,
    bool opaque
)
Public Overridable Sub TextOut (
    text As String,
    len As Integer,
    x As Integer,
    y As Integer,
    clipped As Boolean,
    opaque As Boolean
)
public:
virtual void TextOut(
    String^ text,
    int len,
    int x,
    int y,
    bool clipped,
    bool opaque
)
abstract TextOut :
        text : string *
        len : int *
        x : int *
        y : int *
        clipped : bool *
        opaque : bool -> unit
override TextOut :
        text : string *
        len : int *
        x : int *
        y : int *
        clipped : bool *
        opaque : bool -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
x
Type: SystemInt32
X-coordinate of the start text point.
y
Type: SystemInt32
Y-coordinate of the start text point.
clipped
Type: SystemBoolean
Specifies that text will be clipped to the rectangle.
opaque
Type: SystemBoolean
Specifies that current background color should be used to fill the rectangle.

Implements

IPainterTextOut(String, Int32, Int32, Int32, Boolean, Boolean)
See Also

Reference

GdiPainter Class
TextOut Overload
Alternet.Common Namespace


GdiPainter.TextOut Method (String, Int32, Rectangle, Int32, Int32, Boolean, Boolean)

GdiPainterTextOut Method (String, Int32, Rectangle, Int32, Int32, Boolean, Boolean)
Draws text within the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TextOut(
    string text,
    int len,
    Rectangle rect,
    int x,
    int y,
    bool clipped,
    bool opaque
)
Public Overridable Sub TextOut (
    text As String,
    len As Integer,
    rect As Rectangle,
    x As Integer,
    y As Integer,
    clipped As Boolean,
    opaque As Boolean
)
public:
virtual void TextOut(
    String^ text,
    int len,
    Rectangle rect,
    int x,
    int y,
    bool clipped,
    bool opaque
)
abstract TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        x : int *
        y : int *
        clipped : bool *
        opaque : bool -> unit
override TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        x : int *
        y : int *
        clipped : bool *
        opaque : bool -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.
x
Type: SystemInt32
X-coordinate of the start text point.
y
Type: SystemInt32
Y-coordinate of the start text point.
clipped
Type: SystemBoolean
Specifies that text will be clipped to the rectangle.
opaque
Type: SystemBoolean
Specifies that current background color should be used to fill the rectangle.

Implements

IPainterTextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean)
See Also

Reference

GdiPainter Class
TextOut Overload
Alternet.Common Namespace


GdiPainter.TextOut Method (String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32)

GdiPainterTextOut Method (String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32)
Draws text within the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TextOut(
    string text,
    int len,
    Rectangle rect,
    int x,
    int y,
    bool clipped,
    bool opaque,
    int space
)
Public Overridable Sub TextOut (
    text As String,
    len As Integer,
    rect As Rectangle,
    x As Integer,
    y As Integer,
    clipped As Boolean,
    opaque As Boolean,
    space As Integer
)
public:
virtual void TextOut(
    String^ text,
    int len,
    Rectangle rect,
    int x,
    int y,
    bool clipped,
    bool opaque,
    int space
)
abstract TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        x : int *
        y : int *
        clipped : bool *
        opaque : bool *
        space : int -> unit
override TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        x : int *
        y : int *
        clipped : bool *
        opaque : bool *
        space : int -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.
x
Type: SystemInt32
X-coordinate of the start text point.
y
Type: SystemInt32
Y-coordinate of the start text point.
clipped
Type: SystemBoolean
Specifies that text will be clipped to the rectangle.
opaque
Type: SystemBoolean
Specifies that current background color should be used to fill the rectangle.
space
Type: SystemInt32
Specifies distance between origins of adjacent character cells.

Implements

IPainterTextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32)
See Also

Reference

GdiPainter Class
TextOut Overload
Alternet.Common Namespace


GdiPainter.Transform Method

GdiPainterTransform Method
Sets a two-dimensional linear transformation for the specified device context.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Transform(
    int x,
    int y,
    float scaleX,
    float scaleY
)
Public Overridable Sub Transform (
    x As Integer,
    y As Integer,
    scaleX As Single,
    scaleY As Single
)
public:
virtual void Transform(
    int x,
    int y,
    float scaleX,
    float scaleY
)
abstract Transform :
        x : int *
        y : int *
        scaleX : float32 *
        scaleY : float32 -> unit
override Transform :
        x : int *
        y : int *
        scaleX : float32 *
        scaleY : float32 -> unit

Parameters

x
Type: SystemInt32
Horizontal offset of the transformation.
y
Type: SystemInt32
Vertical offset of the transformation.
scaleX
Type: SystemSingle
Horizontal scale of the transformation.
scaleY
Type: SystemSingle
Vertical scale of the transformation.

Implements

IPainterTransform(Int32, Int32, Single, Single)
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter Properties

GdiPainter Properties

The GdiPainter type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets background color of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | Font | Gets or sets font of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | FontHeight | Represents height of the font of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | FontStyle | Gets or sets font style of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | FontWidth | Represents width of the font of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | ForeColor | Gets or sets foreground color of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | Graphics | Represents Graphics object used to paint text and graphic primitives.
Public property | Handle | Gets handle to device context currently associated with the IPainter.
Public property | IsMonoSpaced | Represents a value indicating whether font of the device context currently associated with this Painter is monospaced, meaning that all characters drawn with this font have the same width. (Inherited from Painter.)
Public property | LineHeight | When implemented by a class, represents height of the individual lines. (Inherited from Painter.)
Public property | LineSpace | Represents additional height added to the height of the font. (Inherited from Painter.)
Public property | Opaque | Gets or sets a boolean value indicating that background is filled with the current background color before the text is drawn. (Inherited from Painter.)
Public property | StringFormat | Encapsulates text layout information and display manipulations for this Painter. (Inherited from Painter.)
Public property | TextColor | Gets or sets text color of the device context currently associated with the Painter. (Inherited from Painter.)
Public property | Transformation | Gets the world transformation for Graphics property.
Public property | UseDrawText | Indicates whether painter should use DrawText method rather then ExtTextOut to paint text.
Top
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.Graphics Property

GdiPainterGraphics Property
Represents Graphics object used to paint text and graphic primitives.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Graphics Graphics { get; }
Public Overridable ReadOnly Property Graphics As Graphics
    Get
public:
virtual property Graphics^ Graphics {
    Graphics^ get ();
}
abstract Graphics : Graphics with get
override Graphics : Graphics with get

Property Value

Type: Graphics

Implements

IPainterGraphics
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.Handle Property

GdiPainterHandle Property
Gets handle to device context currently associated with the IPainter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntPtr Handle { get; }
Public ReadOnly Property Handle As IntPtr
    Get
public:
property IntPtr Handle {
    IntPtr get ();
}
member Handle : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.Transformation Property

GdiPainterTransformation Property
Gets the world transformation for Graphics property.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Matrix Transformation { get; }
Public Overridable ReadOnly Property Transformation As Matrix
    Get
public:
virtual property Matrix^ Transformation {
    Matrix^ get ();
}
abstract Transformation : Matrix with get
override Transformation : Matrix with get

Property Value

Type: Matrix

Implements

IPainterTransformation
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GdiPainter.UseDrawText Property

GdiPainterUseDrawText Property
Indicates whether painter should use DrawText method rather then ExtTextOut to paint text.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UseDrawText { get; set; }
Public Overridable Property UseDrawText As Boolean
    Get
    Set
public:
virtual property bool UseDrawText {
    bool get ();
    void set (bool value);
}
abstract UseDrawText : bool with get, set
override UseDrawText : bool with get, set

Property Value

Type: Boolean

Implements

IPainterUseDrawText
See Also

Reference

GdiPainter Class
Alternet.Common Namespace


GraphicsExtensions Class

GraphicsExtensions Class
Contains extended functionality for drawing surface.
Inheritance Hierarchy
SystemObject
Alternet.CommonGraphicsExtensions

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GraphicsExtensions
<ExtensionAttribute>
Public NotInheritable Class GraphicsExtensions
[ExtensionAttribute]
public ref class GraphicsExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type GraphicsExtensions =  class end

The GraphicsExtensions type exposes the following members.

Methods
Name | Description
DrawAlignedImage | Draws the specified System.Drawing.Image, using its original physical size, with specified alignment.
DrawRectangleAlignedInside | Draws a rectangle aligned accordingly to the pen width.
Top
See Also

Reference

Alternet.Common Namespace


GraphicsExtensions Methods

GraphicsExtensions Methods

The GraphicsExtensions type exposes the following members.

Methods
Name | Description
DrawAlignedImage | Draws the specified System.Drawing.Image, using its original physical size, with specified alignment.
DrawRectangleAlignedInside | Draws a rectangle aligned accordingly to the pen width.
Top
See Also

Reference

GraphicsExtensions Class
Alternet.Common Namespace


GraphicsExtensions.DrawAlignedImage Method

GraphicsExtensionsDrawAlignedImage Method
Draws the specified System.Drawing.Image, using its original physical size, with specified alignment.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawAlignedImage(
    this Graphics graphics,
    Image image,
    Rectangle bounds,
    ContentAlignment alignment = ContentAlignment.MiddleCenter
)
<ExtensionAttribute>
Public Shared Sub DrawAlignedImage (
    graphics As Graphics,
    image As Image,
    bounds As Rectangle,
    Optional alignment As ContentAlignment = ContentAlignment.MiddleCenter
)
public:
[ExtensionAttribute]
static void DrawAlignedImage(
    Graphics^ graphics,
    Image^ image,
    Rectangle bounds,
    ContentAlignment alignment = ContentAlignment::MiddleCenter
)
[<ExtensionAttribute>]
static member DrawAlignedImage :
        graphics : Graphics *
        image : Image *
        bounds : Rectangle *
        ?alignment : ContentAlignment
(* Defaults:
        let _alignment = defaultArg alignment ContentAlignment.MiddleCenter
*)
-> unit

Parameters

graphics
Type: System.DrawingGraphics
Surface to draw image on.
image
Type: System.DrawingImage
System.Drawing.Image to draw.
bounds
Type: System.DrawingRectangle
System.Drawing.Rectangle structure that specifies the location of the drawn image.
alignment (Optional)
Type: System.DrawingContentAlignment
Image alignment.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Graphics. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GraphicsExtensions Class
Alternet.Common Namespace


GraphicsExtensions.DrawRectangleAlignedInside Method

GraphicsExtensionsDrawRectangleAlignedInside Method
Draws a rectangle aligned accordingly to the pen width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawRectangleAlignedInside(
    this Graphics graphics,
    Pen pen,
    Rectangle rect
)
<ExtensionAttribute>
Public Shared Sub DrawRectangleAlignedInside (
    graphics As Graphics,
    pen As Pen,
    rect As Rectangle
)
public:
[ExtensionAttribute]
static void DrawRectangleAlignedInside(
    Graphics^ graphics,
    Pen^ pen,
    Rectangle rect
)
[<ExtensionAttribute>]
static member DrawRectangleAlignedInside :
        graphics : Graphics *
        pen : Pen *
        rect : Rectangle -> unit

Parameters

graphics
Type: System.DrawingGraphics
A System.Drawing.Graphics to be drawn on.
pen
Type: System.DrawingPen
A System.Drawing.Pen that determines the color, width, and style of the rectangle.
rect
Type: System.DrawingRectangle
A System.Drawing.Rectangle structure that represents the rectangle to draw.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Graphics. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GraphicsExtensions Class
Alternet.Common Namespace


HookHandler Delegate

HookHandler Delegate
Represents a method that will handle application-defined or library-defined callback function the system calls.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate IntPtr HookHandler(
    int ncode,
    IntPtr wparam,
    IntPtr lparam
)
Public Delegate Function HookHandler (
    ncode As Integer,
    wparam As IntPtr,
    lparam As IntPtr
) As IntPtr
public delegate IntPtr HookHandler(
    int ncode,
    IntPtr wparam,
    IntPtr lparam
)
type HookHandler =
    delegate of
        ncode : int *
        wparam : IntPtr *
        lparam : IntPtr -> IntPtr

Parameters

ncode
Type: SystemInt32
Hook code.
wparam
Type: SystemIntPtr
Message identifier or current-process flag.
lparam
Type: SystemIntPtr
Address of structure with message data.

Return Value

Type: IntPtr
See Also

Reference

Alternet.Common Namespace


IControl Interface

IControl Interface
Represents standard control properties and methods.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IControl
Public Interface IControl
public interface class IControl
type IControl =  interface end

The IControl type exposes the following members.

Methods
 | Name | Description
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order.
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control.
Public method | FindForm | When implemented by a class, retrieves the form that the control is on.
Public method | Focus | When implemented by a class, sets input focus to the control.
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control.
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control.
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control.
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control.
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle.
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates.
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates.
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area.
Top
Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets the background color for the control.
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control.
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements.
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus.
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control.
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control.
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created.
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction.
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus.
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control.
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control.
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to.
Public property | Height | When implemented by a class, gets or sets the height of the control.
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it.
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed.
Public property | Width | When implemented by a class, gets or sets the width of the control.
Top
Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked.
Top
See Also

Reference

Alternet.Common Namespace


IControl Methods

IControl Methods

The IControl type exposes the following members.

Methods
 | Name | Description
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order.
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control.
Public method | FindForm | When implemented by a class, retrieves the form that the control is on.
Public method | Focus | When implemented by a class, sets input focus to the control.
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control.
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control.
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control.
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control.
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle.
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates.
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates.
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area.
Top
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.BringToFront Method

IControlBringToFront Method
When implemented by a class, brings the control to the front of the z-order.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BringToFront()
Sub BringToFront
void BringToFront()
abstract BringToFront : unit -> unit
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.CreateGraphics Method

IControlCreateGraphics Method
When implemented by a class, creates the Graphics for the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Graphics CreateGraphics()
Function CreateGraphics As Graphics
Graphics^ CreateGraphics()
abstract CreateGraphics : unit -> Graphics

Return Value

Type: Graphics
The Graphics for the control.
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.FindForm Method

IControlFindForm Method
When implemented by a class, retrieves the form that the control is on.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Form FindForm()
Function FindForm As Form
Form^ FindForm()
abstract FindForm : unit -> Form

Return Value

Type: Form
The Form that the control is on.
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Focus Method

IControlFocus Method
When implemented by a class, sets input focus to the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Focus()
Function Focus As Boolean
bool Focus()
abstract Focus : unit -> bool

Return Value

Type: Boolean
true if the input focus request was successful; otherwise, false.
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Invalidate Method

IControlInvalidate Method
Overload List
 | Name | Description
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control.
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control.
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control.
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control.
Top
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Invalidate Method

IControlInvalidate Method
When implemented by a class, invalidates the entire client area of the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Invalidate()
Sub Invalidate
void Invalidate()
abstract Invalidate : unit -> unit
See Also

Reference

IControl Interface
Invalidate Overload
Alternet.Common Namespace


IControl.Invalidate Method (Rectangle)

IControlInvalidate Method (Rectangle)
When implemented by a class, invalidates a specific region of the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Invalidate(
    Rectangle rect
)
Sub Invalidate (
    rect As Rectangle
)
void Invalidate(
    Rectangle rect
)
abstract Invalidate :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
A Rectangle object that represents the region to invalidate.
See Also

Reference

IControl Interface
Invalidate Overload
Alternet.Common Namespace


IControl.Invalidate Method (Region)

IControlInvalidate Method (Region)
When implemented by a class, invalidates a specific region of the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Invalidate(
    Region region
)
Sub Invalidate (
    region As Region
)
void Invalidate(
    Region^ region
)
abstract Invalidate :
        region : Region -> unit

Parameters

region
Type: System.DrawingRegion
The Region to invalidate.
See Also

Reference

IControl Interface
Invalidate Overload
Alternet.Common Namespace


IControl.Invalidate Method (Region, Boolean)

IControlInvalidate Method (Region, Boolean)
When implemented by a class, invalidates a specific region of the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Invalidate(
    Region region,
    bool invalidateChildren
)
Sub Invalidate (
    region As Region,
    invalidateChildren As Boolean
)
void Invalidate(
    Region^ region,
    bool invalidateChildren
)
abstract Invalidate :
        region : Region *
        invalidateChildren : bool -> unit

Parameters

region
Type: System.DrawingRegion
The Region to invalidate.
invalidateChildren
Type: SystemBoolean
True to invalidate the control's child controls; otherwise, false.
See Also

Reference

IControl Interface
Invalidate Overload
Alternet.Common Namespace


IControl.Invoke Method

IControlInvoke Method
When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Invoke(
    Delegate method
)
Function Invoke (
    method As Delegate
) As Object
Object^ Invoke(
    Delegate^ method
)
abstract Invoke :
        method : Delegate -> Object

Parameters

method
Type: SystemDelegate

Return Value

Type: Object
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.PointToClient Method

IControlPointToClient Method
When implemented by a class, computes the location of the specified screen point into client coordinates.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point PointToClient(
    Point p
)
Function PointToClient (
    p As Point
) As Point
Point PointToClient(
    Point p
)
abstract PointToClient :
        p : Point -> Point

Parameters

p
Type: System.DrawingPoint
The screen coordinate Point to convert.

Return Value

Type: Point
A Point that represents the converted Point, in client coordinates.
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.PointToScreen Method

IControlPointToScreen Method
When implemented by a class, computes the location of the specified client point into screen coordinates.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point PointToScreen(
    Point p
)
Function PointToScreen (
    p As Point
) As Point
Point PointToScreen(
    Point p
)
abstract PointToScreen :
        p : Point -> Point

Parameters

p
Type: System.DrawingPoint
The client coordinate Point to convert.

Return Value

Type: Point
A Point that represents the converted Point, in screen coordinates.
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Refresh Method

IControlRefresh Method
When implemented by a class, causes the control to redraw the invalidated regions within its client area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Refresh()
Sub Refresh
void Refresh()
abstract Refresh : unit -> unit
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl Properties

IControl Properties

The IControl type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets the background color for the control.
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control.
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements.
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus.
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control.
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control.
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created.
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction.
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus.
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control.
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control.
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to.
Public property | Height | When implemented by a class, gets or sets the height of the control.
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it.
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed.
Public property | Width | When implemented by a class, gets or sets the width of the control.
Top
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.BackColor Property

IControlBackColor Property
When implemented by a class, gets or sets the background color for the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; set; }
Property BackColor As Color
    Get
    Set
property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.BackgroundImage Property

IControlBackgroundImage Property
When implemented by a class, gets or sets the background image displayed in the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Image BackgroundImage { get; set; }
Property BackgroundImage As Image
    Get
    Set
property Image^ BackgroundImage {
    Image^ get ();
    void set (Image^ value);
}
abstract BackgroundImage : Image with get, set

Property Value

Type: Image
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Bounds Property

IControlBounds Property
When implemented by a class, gets or sets the size and location of the control including its non-client elements.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle Bounds { get; set; }
Property Bounds As Rectangle
    Get
    Set
property Rectangle Bounds {
    Rectangle get ();
    void set (Rectangle value);
}
abstract Bounds : Rectangle with get, set

Property Value

Type: Rectangle
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.CanFocus Property

IControlCanFocus Property
When implemented by a class, returns boolean value indicating whether the control can receive input focus.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanFocus { get; }
ReadOnly Property CanFocus As Boolean
    Get
property bool CanFocus {
    bool get ();
}
abstract CanFocus : bool with get

Property Value

Type: Boolean
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.ClientRectangle Property

IControlClientRectangle Property
When implemented by a class, gets the rectangle that represents the client area of the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle ClientRectangle { get; }
ReadOnly Property ClientRectangle As Rectangle
    Get
property Rectangle ClientRectangle {
    Rectangle get ();
}
abstract ClientRectangle : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.ContextMenuStrip Property

IControlContextMenuStrip Property
When implemented by a class, gets or sets the ContextMenuStrip associated with this control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ContextMenuStrip ContextMenuStrip { get; set; }
Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get ();
    void set (ContextMenuStrip^ value);
}
abstract ContextMenuStrip : ContextMenuStrip with get, set

Property Value

Type: ContextMenuStrip
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Created Property

IControlCreated Property
When implemented by a class, gets a value indicating whether the control has been created.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Created { get; }
ReadOnly Property Created As Boolean
    Get
property bool Created {
    bool get ();
}
abstract Created : bool with get

Property Value

Type: Boolean
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Dock Property

IControlDock Property
When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DockStyle Dock { get; set; }
Property Dock As DockStyle
    Get
    Set
property DockStyle Dock {
    DockStyle get ();
    void set (DockStyle value);
}
abstract Dock : DockStyle with get, set

Property Value

Type: DockStyle
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Enabled Property

IControlEnabled Property
When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Focused Property

IControlFocused Property
When implemented by a class, gets a value indicating whether the control has input focus.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Focused { get; }
ReadOnly Property Focused As Boolean
    Get
property bool Focused {
    bool get ();
}
abstract Focused : bool with get

Property Value

Type: Boolean
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Font Property

IControlFont Property
When implemented by a class, gets or sets the font of the text displayed by the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Font Font { get; set; }
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

Property Value

Type: Font
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.ForeColor Property

IControlForeColor Property
When implemented by a class, gets or sets the foreground color of the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; set; }
Property ForeColor As Color
    Get
    Set
property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Handle Property

IControlHandle Property
When implemented by a class, gets the window handle that the control is bound to.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IntPtr Handle { get; }
ReadOnly Property Handle As IntPtr
    Get
property IntPtr Handle {
    IntPtr get ();
}
abstract Handle : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Height Property

IControlHeight Property
When implemented by a class, gets or sets the height of the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Height { get; set; }
Property Height As Integer
    Get
    Set
property int Height {
    int get ();
    void set (int value);
}
abstract Height : int with get, set

Property Value

Type: Int32
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.IsHandleCreated Property

IControlIsHandleCreated Property
When implemented by a class, gets a value indicating whether the control has a handle associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsHandleCreated { get; }
ReadOnly Property IsHandleCreated As Boolean
    Get
property bool IsHandleCreated {
    bool get ();
}
abstract IsHandleCreated : bool with get

Property Value

Type: Boolean
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Left Property

IControlLeft Property
When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Left { get; set; }
Property Left As Integer
    Get
    Set
property int Left {
    int get ();
    void set (int value);
}
abstract Left : int with get, set

Property Value

Type: Int32
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Location Property

IControlLocation Property
When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Location { get; set; }
Property Location As Point
    Get
    Set
property Point Location {
    Point get ();
    void set (Point value);
}
abstract Location : Point with get, set

Property Value

Type: Point
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Parent Property

IControlParent Property
When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Control Parent { get; set; }
Property Parent As Control
    Get
    Set
property Control^ Parent {
    Control^ get ();
    void set (Control^ value);
}
abstract Parent : Control with get, set

Property Value

Type: Control
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Top Property

IControlTop Property
When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Top { get; set; }
Property Top As Integer
    Get
    Set
property int Top {
    int get ();
    void set (int value);
}
abstract Top : int with get, set

Property Value

Type: Int32
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Visible Property

IControlVisible Property
When implemented by a class, gets or sets a value indicating whether the control is displayed.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Width Property

IControlWidth Property
When implemented by a class, gets or sets the width of the control.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Width { get; set; }
Property Width As Integer
    Get
    Set
property int Width {
    int get ();
    void set (int value);
}
abstract Width : int with get, set

Property Value

Type: Int32
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl Events

IControl Events

The IControl type exposes the following members.

Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked.
Top
See Also

Reference

IControl Interface
Alternet.Common Namespace


IControl.Click Event

IControlClick Event
When implemented by a class, occurs when the control is clicked.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler Click
Event Click As EventHandler
 event EventHandler^ Click {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Click : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IControl Interface
Alternet.Common Namespace


IFileRange Interface

IFileRange Interface
Represents a location in source code.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFileRange : IRange,
    ICloneable
Public Interface IFileRange
    Inherits IRange, ICloneable
public interface class IFileRange : IRange,
    ICloneable
type IFileRange =
    interface
        interface IRange
        interface ICloneable
    end

The IFileRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from IRange.)
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
Properties
 | Name | Description
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area. (Inherited from IRange.)
Public property | FileName | When implemented by a class, gets the full name of the source file.
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size. (Inherited from IRange.)
Public property | Size | When implemented by a class, gets or sets size of IRange area. (Inherited from IRange.)
Public property | SourceText | When implemented by a class, gets the text line inside the file.
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area. (Inherited from IRange.)
Top
See Also

Reference

Alternet.Common Namespace


IFileRange Methods

IFileRange Methods

The IFileRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from IRange.)
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

IFileRange Interface
Alternet.Common Namespace


IFileRange Properties

IFileRange Properties

The IFileRange type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area. (Inherited from IRange.)
Public property | FileName | When implemented by a class, gets the full name of the source file.
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size. (Inherited from IRange.)
Public property | Size | When implemented by a class, gets or sets size of IRange area. (Inherited from IRange.)
Public property | SourceText | When implemented by a class, gets the text line inside the file.
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area. (Inherited from IRange.)
Top
See Also

Reference

IFileRange Interface
Alternet.Common Namespace


IFileRange.FileName Property

IFileRangeFileName Property
When implemented by a class, gets the full name of the source file.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; }
ReadOnly Property FileName As String
    Get
property String^ FileName {
    String^ get ();
}
abstract FileName : string with get

Property Value

Type: String
See Also

Reference

IFileRange Interface
Alternet.Common Namespace


IFileRange.SourceText Property

IFileRangeSourceText Property
When implemented by a class, gets the text line inside the file.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string SourceText { get; }
ReadOnly Property SourceText As String
    Get
property String^ SourceText {
    String^ get ();
}
abstract SourceText : string with get

Property Value

Type: String
See Also

Reference

IFileRange Interface
Alternet.Common Namespace


ImageListHelper Class

ImageListHelper Class
Provides additional functionality for ImageList objects.
Inheritance Hierarchy
SystemObject
Alternet.CommonImageListHelper

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ImageListHelper
Public NotInheritable Class ImageListHelper
public ref class ImageListHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ImageListHelper =  class end

The ImageListHelper type exposes the following members.

Methods
Name | Description
LoadImageListFromStrip(Assembly, String) | Creates an ImageList from specified resource.
LoadImageListFromStrip(Type, String) | Creates an ImageList from specified resource.
SaveImageListAsStrip | Joins content of given image list into a single stripped image an saves in into a specified file.
TryLoadImageListFromStrip | Tries to create an ImageList from specified resource.
Top
See Also

Reference

Alternet.Common Namespace


ImageListHelper Methods

ImageListHelper Methods

The ImageListHelper type exposes the following members.

Methods
Name | Description
LoadImageListFromStrip(Assembly, String) | Creates an ImageList from specified resource.
LoadImageListFromStrip(Type, String) | Creates an ImageList from specified resource.
SaveImageListAsStrip | Joins content of given image list into a single stripped image an saves in into a specified file.
TryLoadImageListFromStrip | Tries to create an ImageList from specified resource.
Top
See Also

Reference

ImageListHelper Class
Alternet.Common Namespace


ImageListHelper.LoadImageListFromStrip Method

ImageListHelperLoadImageListFromStrip Method
Overload List
Name | Description
LoadImageListFromStrip(Assembly, String) | Creates an ImageList from specified resource.
LoadImageListFromStrip(Type, String) | Creates an ImageList from specified resource.
Top
See Also

Reference

ImageListHelper Class
Alternet.Common Namespace


ImageListHelper.LoadImageListFromStrip Method (Assembly, String)

ImageListHelperLoadImageListFromStrip Method (Assembly, String)
Creates an ImageList from specified resource.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImageList LoadImageListFromStrip(
    Assembly assembly,
    string resourceName
)
Public Shared Function LoadImageListFromStrip (
    assembly As Assembly,
    resourceName As String
) As ImageList
public:
static ImageList^ LoadImageListFromStrip(
    Assembly^ assembly,
    String^ resourceName
)
static member LoadImageListFromStrip :
        assembly : Assembly *
        resourceName : string -> ImageList

Parameters

assembly
Type: System.ReflectionAssembly
Assembly contains specified resource.
resourceName
Type: SystemString
Name of resource stores stripped image list.

Return Value

Type: ImageList
System.Windows.Forms.ImageList contains images from resource.
See Also

Reference

ImageListHelper Class
LoadImageListFromStrip Overload
Alternet.Common Namespace


ImageListHelper.LoadImageListFromStrip Method (Type, String)

ImageListHelperLoadImageListFromStrip Method (Type, String)
Creates an ImageList from specified resource.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImageList LoadImageListFromStrip(
    Type resourceType,
    string resourceName
)
Public Shared Function LoadImageListFromStrip (
    resourceType As Type,
    resourceName As String
) As ImageList
public:
static ImageList^ LoadImageListFromStrip(
    Type^ resourceType,
    String^ resourceName
)
static member LoadImageListFromStrip :
        resourceType : Type *
        resourceName : string -> ImageList

Parameters

resourceType
Type: SystemType
Type contains specified resource.
resourceName
Type: SystemString
Name of resource stores stripped image list.

Return Value

Type: ImageList
System.Windows.Forms.ImageList contains images from resource.
See Also

Reference

ImageListHelper Class
LoadImageListFromStrip Overload
Alternet.Common Namespace


ImageListHelper.SaveImageListAsStrip Method

ImageListHelperSaveImageListAsStrip Method
Joins content of given image list into a single stripped image an saves in into a specified file.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SaveImageListAsStrip(
    ImageList imageList,
    string fileName
)
Public Shared Sub SaveImageListAsStrip (
    imageList As ImageList,
    fileName As String
)
public:
static void SaveImageListAsStrip(
    ImageList^ imageList,
    String^ fileName
)
static member SaveImageListAsStrip :
        imageList : ImageList *
        fileName : string -> unit

Parameters

imageList
Type: System.Windows.FormsImageList
ImageList to process.
fileName
Type: SystemString
Name of file to save result.
See Also

Reference

ImageListHelper Class
Alternet.Common Namespace


ImageListHelper.TryLoadImageListFromStrip Method

ImageListHelperTryLoadImageListFromStrip Method
Tries to create an ImageList from specified resource.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImageList TryLoadImageListFromStrip(
    Assembly assembly,
    string resourceName
)
Public Shared Function TryLoadImageListFromStrip (
    assembly As Assembly,
    resourceName As String
) As ImageList
public:
static ImageList^ TryLoadImageListFromStrip(
    Assembly^ assembly,
    String^ resourceName
)
static member TryLoadImageListFromStrip :
        assembly : Assembly *
        resourceName : string -> ImageList

Parameters

assembly
Type: System.ReflectionAssembly
Assembly contains specified resource.
resourceName
Type: SystemString
Name of resource stores stripped image list.

Return Value

Type: ImageList
System.Windows.Forms.ImageList contains images from resource.
See Also

Reference

ImageListHelper Class
Alternet.Common Namespace


INotifier Interface

INotifier Interface
Represents method that informs object about changes in linked objects.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INotifier
Public Interface INotifier
public interface class INotifier
type INotifier =  interface end

The INotifier type exposes the following members.

Methods
 | Name | Description
Public method | Notification | When implemented by a class, updates control's content according to the parameters of notification.
Top
See Also

Reference

Alternet.Common Namespace


INotifier Methods

INotifier Methods

The INotifier type exposes the following members.

Methods
 | Name | Description
Public method | Notification | When implemented by a class, updates control's content according to the parameters of notification.
Top
See Also

Reference

INotifier Interface
Alternet.Common Namespace


INotifier.Notification Method

INotifierNotification Method
When implemented by a class, updates control's content according to the parameters of notification.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Notification(
    Object sender,
    EventArgs e
)
Sub Notification (
    sender As Object,
    e As EventArgs
)
void Notification(
    Object^ sender,
    EventArgs^ e
)
abstract Notification :
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the notification.
e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

INotifier Interface
Alternet.Common Namespace


INotify Interface

INotify Interface
Represents properties and methods to manage notification between objects.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INotify : IUpdate
Public Interface INotify
    Inherits IUpdate
public interface class INotify : IUpdate
type INotify =
    interface
        interface IUpdate
    end

The INotify type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state.
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

Alternet.Common Namespace


INotify Methods

INotify Methods

The INotify type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state.
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

INotify Interface
Alternet.Common Namespace


INotify.AddNotifier Method

INotifyAddNotifier Method
When implemented by a class, adds new handler to respond a notification.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddNotifier(
    INotifier sender
)
Sub AddNotifier (
    sender As INotifier
)
void AddNotifier(
    INotifier^ sender
)
abstract AddNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.
See Also

Reference

INotify Interface
Alternet.Common Namespace


INotify.Notify Method

INotifyNotify Method
When implemented by a class, notifies all notifiers about updating object state.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Notify(
    EventArgs e
)
Sub Notify (
    e As EventArgs
)
void Notify(
    EventArgs^ e
)
abstract Notify :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
See Also

Reference

INotify Interface
Alternet.Common Namespace


INotify.RemoveNotifier Method

INotifyRemoveNotifier Method
When implemented by a class, exclude specified handler from notification handlers list.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveNotifier(
    INotifier sender
)
Sub RemoveNotifier (
    sender As INotifier
)
void RemoveNotifier(
    INotifier^ sender
)
abstract RemoveNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.
See Also

Reference

INotify Interface
Alternet.Common Namespace


INotify Properties

INotify Properties

The INotify type exposes the following members.

Properties
 | Name | Description
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

INotify Interface
Alternet.Common Namespace


IPainter Interface

IPainter Interface
Encapsulates a drawing surface, providing properties and methods used to draw text and graphic primitives.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPainter : IDisposable
Public Interface IPainter
    Inherits IDisposable
public interface class IPainter : IDisposable
type IPainter =
    interface
        interface IDisposable
    end

The IPainter type exposes the following members.

Methods
 | Name | Description
Public method | BeginPaint | When implemented by a class, prepares the IPainter to paint. Associates new device context from given Graphics object to IPainter and preserves IPainter properties.
Public method | CharWidth(Char, Int32) | When implemented by a class, returns width of the given number of specified character.
Public method | CharWidth(Char, Int32, Int32, Boolean) | When implemented by a class, returns width of the such number of the specified characters fitting into the given Width.
Public method | Clear | When implemented by a class, resets all IPainter properties to the initial state.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | DrawDotLine | When implemented by a class, draws a dotted line from the given start position up to the specified end point.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide) | When implemented by a class, draws one or more edges of rectangle.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide, Int32) | When implemented by a class, draws one or more edges of rectangle.
Public method | DrawFocusRect(Rectangle, Color) | When implemented by a class, draws a border around the specified rectangle using current BackColor.
Public method | DrawFocusRect(Int32, Int32, Int32, Int32, Color) | When implemented by a class, draws a border around the specified rectangle using dot pattern.
Public method | DrawImage(ImageList, Int32, Rectangle) | When implemented by a class, draws specified image in the specified rectangular area.
Public method | DrawImage(ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | When implemented by a class, draws specified image in the specified rectangular area.
Public method | DrawLine(Int32, Int32, Int32, Int32) | When implemented by a class, draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawLine(Int32, Int32, Int32, Int32, Color, Int32, DashStyle) | When implemented by a class, draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawPolygon | When implemented by a class, draws a polygon defined by an array of Point structures.
Public method | DrawRectangle(Rectangle) | When implemented by a class, draws a border around the specified rectangle using current BackColor.
Public method | DrawRectangle(Int32, Int32, Int32, Int32) | When implemented by a class, draws a border around the specified rectangle using dot pattern.
Public method | DrawRoundRectangle | When implemented by a class, draws a rectangle with rounded corners. The rectangle is outlined by using the current pen.
Public method | DrawText | When implemented by a class, draws text in the specified rectangle using current values of TextColor and BackColor.
Public method | DrawThemeBackground | When implemented by a class, draws the background image defined by the visual style for the specified control part.
Public method | DrawWave | When implemented by a class, draws waved line in the specified rectangular area.
Public method | EndPaint | When implemented by a class, marks the end of painting. Releases device context associated with this IPainter and restores saved IPainter properties.
Public method | EndTransform | When implemented by a class, sets default two-dimensional linear transformation for the specified device context.
Public method | ExcludeClipRect(Rectangle) | When implemented by a class, creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | ExcludeClipRect(Int32, Int32, Int32, Int32) | When implemented by a class, creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | FillGradient(Rectangle, Color, Color, Point, Point) | When implemented by a class, fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillGradient(Int32, Int32, Int32, Int32, Color, Color, Point, Point) | When implemented by a class, fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillPolygon | When implemented by a class, fills the interior of a polygon defined by an array of points specified by Point structures.
Public method | FillRectangle(Rectangle) | When implemented by a class, fills the given rectangle by using the current brush.
Public method | FillRectangle(Color, Rectangle) | When implemented by a class, fills the given rectangle by using specified color.
Public method | FillRectangle(Int32, Int32, Int32, Int32) | When implemented by a class, fills the given rectangular area by using the current brush.
Public method | FillRectangle(Color, Int32, Int32, Int32, Int32) | When implemented by a class, fills the given rectangle by using specified color.
Public method | FillRoundRectangle | When implemented by a class, fills a rectangle with rounded corners. The rectangle is outlined by using the current pen and filled by using the current brush.
Public method | IntersectClipRect(Rectangle) | When implemented by a class, creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | IntersectClipRect(Int32, Int32, Int32, Int32) | When implemented by a class, creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | RestoreClip | When implemented by a class, restores current clipping region from previously saved region.
Public method | SaveClip | When implemented by a class, retrieves handle to clipping region saved from specified rectangle.
Public method | StretchDrawImage | When implemented by a class, draws stretched image in the specified rectangular area.
Public method | StringWidth(String) | When implemented by a class, returns width of the given string.
Public method | StringWidth(String, Int32, Int32) | When implemented by a class, returns width of the specified part of the given string.
Public method | StringWidth(String, Int32, Int32, Boolean) | When implemented by a class, returns width of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32) | When implemented by a class, returns width of the specified part of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, returns width of the specified part of the given string fitting into the given Width.
Public method | TextOut(String, Int32, Rectangle) | When implemented by a class, draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32) | When implemented by a class, draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Boolean, Boolean) | When implemented by a class, draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32, Boolean, Boolean) | When implemented by a class, draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean) | When implemented by a class, draws text within the specified rectangle.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32) | When implemented by a class, draws text within the specified rectangle.
Public method | Transform | When implemented by a class, sets a two-dimensional linear transformation for the specified device context.
Top
Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets background color of the device context currently associated with the IPainter.
Public property | Font | When implemented by a class, gets or sets font of the device context currently associated with the IPainter.
Public property | FontHeight | When implemented by a class, represents height of the font of the device context currently associated with the IPainter.
Public property | FontStyle | When implemented by a class, gets or sets font style of the device context currently associated with the IPainter.
Public property | FontWidth | When implemented by a class, represents width of the font of the device context currently associated with the IPainter.
Public property | ForeColor | When implemented by a class, gets or sets foreground color of the device context currently associated with the IPainter.
Public property | Graphics | When implemented by a class, represents Graphics object used to paint.
Public property | IsMonoSpaced | When implemented by a class, represents a value indicating whether font of the device context currently associated with this IPainter is monospaced, meaning that all characters drawn with this font have the same width.
Public property | LineHeight | When implemented by a class, represents height of the individual lines.
Public property | LineSpace | When implemented by a class, Represents additional height added to the height of the font.
Public property | Opaque | When implemented by a class, gets or sets a boolean value indicating that background is filled with the current background color before the text is drawn.
Public property | StringFormat | When implemented by a class, encapsulates text layout information and display manipulations for this IPainter.
Public property | TextColor | When implemented by a class, gets or sets text color of the device context currently associated with the IPainter.
Public property | Transformation | When implemented by a class gets the world transformation for Graphics property.
Public property | UseDrawText | When implemented by a class, indicates whether painter should use DrawText method rather then ExtTextOut to paint text.
Top
See Also

Reference

Alternet.Common Namespace


IPainter Methods

IPainter Methods

The IPainter type exposes the following members.

Methods
 | Name | Description
Public method | BeginPaint | When implemented by a class, prepares the IPainter to paint. Associates new device context from given Graphics object to IPainter and preserves IPainter properties.
Public method | CharWidth(Char, Int32) | When implemented by a class, returns width of the given number of specified character.
Public method | CharWidth(Char, Int32, Int32, Boolean) | When implemented by a class, returns width of the such number of the specified characters fitting into the given Width.
Public method | Clear | When implemented by a class, resets all IPainter properties to the initial state.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | DrawDotLine | When implemented by a class, draws a dotted line from the given start position up to the specified end point.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide) | When implemented by a class, draws one or more edges of rectangle.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide, Int32) | When implemented by a class, draws one or more edges of rectangle.
Public method | DrawFocusRect(Rectangle, Color) | When implemented by a class, draws a border around the specified rectangle using current BackColor.
Public method | DrawFocusRect(Int32, Int32, Int32, Int32, Color) | When implemented by a class, draws a border around the specified rectangle using dot pattern.
Public method | DrawImage(ImageList, Int32, Rectangle) | When implemented by a class, draws specified image in the specified rectangular area.
Public method | DrawImage(ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | When implemented by a class, draws specified image in the specified rectangular area.
Public method | DrawLine(Int32, Int32, Int32, Int32) | When implemented by a class, draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawLine(Int32, Int32, Int32, Int32, Color, Int32, DashStyle) | When implemented by a class, draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawPolygon | When implemented by a class, draws a polygon defined by an array of Point structures.
Public method | DrawRectangle(Rectangle) | When implemented by a class, draws a border around the specified rectangle using current BackColor.
Public method | DrawRectangle(Int32, Int32, Int32, Int32) | When implemented by a class, draws a border around the specified rectangle using dot pattern.
Public method | DrawRoundRectangle | When implemented by a class, draws a rectangle with rounded corners. The rectangle is outlined by using the current pen.
Public method | DrawText | When implemented by a class, draws text in the specified rectangle using current values of TextColor and BackColor.
Public method | DrawThemeBackground | When implemented by a class, draws the background image defined by the visual style for the specified control part.
Public method | DrawWave | When implemented by a class, draws waved line in the specified rectangular area.
Public method | EndPaint | When implemented by a class, marks the end of painting. Releases device context associated with this IPainter and restores saved IPainter properties.
Public method | EndTransform | When implemented by a class, sets default two-dimensional linear transformation for the specified device context.
Public method | ExcludeClipRect(Rectangle) | When implemented by a class, creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | ExcludeClipRect(Int32, Int32, Int32, Int32) | When implemented by a class, creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | FillGradient(Rectangle, Color, Color, Point, Point) | When implemented by a class, fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillGradient(Int32, Int32, Int32, Int32, Color, Color, Point, Point) | When implemented by a class, fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillPolygon | When implemented by a class, fills the interior of a polygon defined by an array of points specified by Point structures.
Public method | FillRectangle(Rectangle) | When implemented by a class, fills the given rectangle by using the current brush.
Public method | FillRectangle(Color, Rectangle) | When implemented by a class, fills the given rectangle by using specified color.
Public method | FillRectangle(Int32, Int32, Int32, Int32) | When implemented by a class, fills the given rectangular area by using the current brush.
Public method | FillRectangle(Color, Int32, Int32, Int32, Int32) | When implemented by a class, fills the given rectangle by using specified color.
Public method | FillRoundRectangle | When implemented by a class, fills a rectangle with rounded corners. The rectangle is outlined by using the current pen and filled by using the current brush.
Public method | IntersectClipRect(Rectangle) | When implemented by a class, creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | IntersectClipRect(Int32, Int32, Int32, Int32) | When implemented by a class, creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | RestoreClip | When implemented by a class, restores current clipping region from previously saved region.
Public method | SaveClip | When implemented by a class, retrieves handle to clipping region saved from specified rectangle.
Public method | StretchDrawImage | When implemented by a class, draws stretched image in the specified rectangular area.
Public method | StringWidth(String) | When implemented by a class, returns width of the given string.
Public method | StringWidth(String, Int32, Int32) | When implemented by a class, returns width of the specified part of the given string.
Public method | StringWidth(String, Int32, Int32, Boolean) | When implemented by a class, returns width of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32) | When implemented by a class, returns width of the specified part of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, returns width of the specified part of the given string fitting into the given Width.
Public method | TextOut(String, Int32, Rectangle) | When implemented by a class, draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32) | When implemented by a class, draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Boolean, Boolean) | When implemented by a class, draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32, Boolean, Boolean) | When implemented by a class, draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean) | When implemented by a class, draws text within the specified rectangle.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32) | When implemented by a class, draws text within the specified rectangle.
Public method | Transform | When implemented by a class, sets a two-dimensional linear transformation for the specified device context.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.BeginPaint Method

IPainterBeginPaint Method
When implemented by a class, prepares the IPainter to paint. Associates new device context from given Graphics object to IPainter and preserves IPainter properties.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BeginPaint(
    Graphics graphics
)
Sub BeginPaint (
    graphics As Graphics
)
void BeginPaint(
    Graphics^ graphics
)
abstract BeginPaint :
        graphics : Graphics -> unit

Parameters

graphics
Type: System.DrawingGraphics
The Graphics object to draw on.
See Also

Reference

IPainter Interface
Alternet.Common Namespace
IPainterEndPaint


IPainter.CharWidth Method

IPainterCharWidth Method
Overload List
 | Name | Description
Public method | CharWidth(Char, Int32) | When implemented by a class, returns width of the given number of specified character.
Public method | CharWidth(Char, Int32, Int32, Boolean) | When implemented by a class, returns width of the such number of the specified characters fitting into the given Width.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.CharWidth Method (Char, Int32)

IPainterCharWidth Method (Char, Int32)
When implemented by a class, returns width of the given number of specified character.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int CharWidth(
    char ch,
    int count
)
Function CharWidth (
    ch As Char,
    count As Integer
) As Integer
int CharWidth(
    wchar_t ch,
    int count
)
abstract CharWidth :
        ch : char *
        count : int -> int

Parameters

ch
Type: SystemChar
Character to calculate width.
count
Type: SystemInt32
Number of characters.

Return Value

Type: Int32
Width of specified characters.
See Also

Reference

IPainter Interface
CharWidth Overload
Alternet.Common Namespace


IPainter.CharWidth Method (Char, Int32, Int32, Boolean)

IPainterCharWidth Method (Char, Int32, Int32, Boolean)
When implemented by a class, returns width of the such number of the specified characters fitting into the given Width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int CharWidth(
    char ch,
    int width,
    out int count,
    bool exact
)
Function CharWidth (
    ch As Char,
    width As Integer,
    <OutAttribute> ByRef count As Integer,
    exact As Boolean
) As Integer
int CharWidth(
    wchar_t ch,
    int width,
    [OutAttribute] int% count,
    bool exact
)
abstract CharWidth :
        ch : char *
        width : int *
        count : int byref *
        exact : bool -> int

Parameters

ch
Type: SystemChar
Character to calculate width.
width
Type: SystemInt32
The width that should hold a number of the specified character.
count
Type: SystemInt32
Receive number of character that can fit into specified width.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of specified characters.
See Also

Reference

IPainter Interface
CharWidth Overload
Alternet.Common Namespace


IPainter.Clear Method

IPainterClear Method
When implemented by a class, resets all IPainter properties to the initial state.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawDotLine Method

IPainterDrawDotLine Method
When implemented by a class, draws a dotted line from the given start position up to the specified end point.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawDotLine(
    int x1,
    int y1,
    int x2,
    int y2,
    Color color1,
    Color color2,
    int size = 1
)
Sub DrawDotLine (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer,
    color1 As Color,
    color2 As Color,
    Optional size As Integer = 1
)
void DrawDotLine(
    int x1,
    int y1,
    int x2,
    int y2,
    Color color1,
    Color color2,
    int size = 1
)
abstract DrawDotLine :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int *
        color1 : Color *
        color2 : Color *
        ?size : int
(* Defaults:
        let _size = defaultArg size 1
*)
-> unit

Parameters

x1
Type: SystemInt32
X-coordinate of the line's start point.
y1
Type: SystemInt32
Y-coordinate of the line's start point.
x2
Type: SystemInt32
X-coordinate of the line's ending point.
y2
Type: SystemInt32
Y-coordinate of the line's ending point.
color1
Type: System.DrawingColor
Specifies line color.
color2
Type: System.DrawingColor
Specifies background color.
size (Optional)
Type: SystemInt32
Specifies dot size
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawEdge Method

IPainterDrawEdge Method
Overload List
 | Name | Description
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide) | When implemented by a class, draws one or more edges of rectangle.
Public method | DrawEdge(Rectangle, Border3DStyle, Border3DSide, Int32) | When implemented by a class, draws one or more edges of rectangle.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawEdge Method (Rectangle, Border3DStyle, Border3DSide)

IPainterDrawEdge Method (Rectangle, Border3DStyle, Border3DSide)
When implemented by a class, draws one or more edges of rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawEdge(
    ref Rectangle rect,
    Border3DStyle border,
    Border3DSide sides
)
Sub DrawEdge (
    ByRef rect As Rectangle,
    border As Border3DStyle,
    sides As Border3DSide
)
void DrawEdge(
    Rectangle% rect,
    Border3DStyle border,
    Border3DSide sides
)
abstract DrawEdge :
        rect : Rectangle byref *
        border : Border3DStyle *
        sides : Border3DSide -> unit

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle which edges should be drawn.
border
Type: System.Windows.FormsBorder3DStyle
Specifies the style of a three-dimensional border.
sides
Type: System.Windows.FormsBorder3DSide
Specifies the sides of a rectangle to draw.
See Also

Reference

IPainter Interface
DrawEdge Overload
Alternet.Common Namespace


IPainter.DrawEdge Method (Rectangle, Border3DStyle, Border3DSide, Int32)

IPainterDrawEdge Method (Rectangle, Border3DStyle, Border3DSide, Int32)
When implemented by a class, draws one or more edges of rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawEdge(
    ref Rectangle rect,
    Border3DStyle border,
    Border3DSide sides,
    int flags
)
Sub DrawEdge (
    ByRef rect As Rectangle,
    border As Border3DStyle,
    sides As Border3DSide,
    flags As Integer
)
void DrawEdge(
    Rectangle% rect,
    Border3DStyle border,
    Border3DSide sides,
    int flags
)
abstract DrawEdge :
        rect : Rectangle byref *
        border : Border3DStyle *
        sides : Border3DSide *
        flags : int -> unit

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle which edges should be drawn.
border
Type: System.Windows.FormsBorder3DStyle
Specifies the style of a three-dimensional border.
sides
Type: System.Windows.FormsBorder3DSide
Specifies the sides of a rectangle to draw.
flags
Type: SystemInt32
Additional flags (used for internal purposes).
See Also

Reference

IPainter Interface
DrawEdge Overload
Alternet.Common Namespace


IPainter.DrawFocusRect Method

IPainterDrawFocusRect Method
Overload List
 | Name | Description
Public method | DrawFocusRect(Rectangle, Color) | When implemented by a class, draws a border around the specified rectangle using current BackColor.
Public method | DrawFocusRect(Int32, Int32, Int32, Int32, Color) | When implemented by a class, draws a border around the specified rectangle using dot pattern.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawFocusRect Method (Rectangle, Color)

IPainterDrawFocusRect Method (Rectangle, Color)
When implemented by a class, draws a border around the specified rectangle using current BackColor.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawFocusRect(
    Rectangle rect,
    Color color
)
Sub DrawFocusRect (
    rect As Rectangle,
    color As Color
)
void DrawFocusRect(
    Rectangle rect,
    Color color
)
abstract DrawFocusRect :
        rect : Rectangle *
        color : Color -> unit

Parameters

rect
Type: System.DrawingRectangle
The rectangle object to draw border.
color
Type: System.DrawingColor
Color of the frame.
See Also

Reference

IPainter Interface
DrawFocusRect Overload
Alternet.Common Namespace


IPainter.DrawFocusRect Method (Int32, Int32, Int32, Int32, Color)

IPainterDrawFocusRect Method (Int32, Int32, Int32, Int32, Color)
When implemented by a class, draws a border around the specified rectangle using dot pattern.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawFocusRect(
    int x,
    int y,
    int width,
    int height,
    Color color
)
Sub DrawFocusRect (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer,
    color As Color
)
void DrawFocusRect(
    int x,
    int y,
    int width,
    int height,
    Color color
)
abstract DrawFocusRect :
        x : int *
        y : int *
        width : int *
        height : int *
        color : Color -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.
color
Type: System.DrawingColor
Color of the frame.
See Also

Reference

IPainter Interface
DrawFocusRect Overload
Alternet.Common Namespace


IPainter.DrawImage Method

IPainterDrawImage Method
Overload List
 | Name | Description
Public method | DrawImage(ImageList, Int32, Rectangle) | When implemented by a class, draws specified image in the specified rectangular area.
Public method | DrawImage(ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes) | When implemented by a class, draws specified image in the specified rectangular area.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawImage Method (ImageList, Int32, Rectangle)

IPainterDrawImage Method (ImageList, Int32, Rectangle)
When implemented by a class, draws specified image in the specified rectangular area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawImage(
    ImageList images,
    int index,
    Rectangle rect
)
Sub DrawImage (
    images As ImageList,
    index As Integer,
    rect As Rectangle
)
void DrawImage(
    ImageList^ images,
    int index,
    Rectangle rect
)
abstract DrawImage :
        images : ImageList *
        index : int *
        rect : Rectangle -> unit

Parameters

images
Type: System.Windows.FormsImageList
Image list that contains image to draw.
index
Type: SystemInt32
Index of image to draw within image list.
rect
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the image.
See Also

Reference

IPainter Interface
DrawImage Overload
Alternet.Common Namespace


IPainter.DrawImage Method (ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)

IPainterDrawImage Method (ImageList, Int32, Rectangle, Int32, Int32, Int32, Int32, GraphicsUnit, ImageAttributes)
When implemented by a class, draws specified image in the specified rectangular area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawImage(
    ImageList images,
    int index,
    Rectangle rect,
    int srcX,
    int srcY,
    int srcWidth,
    int srcHeight,
    GraphicsUnit srcUnit,
    ImageAttributes imageAttr
)
Sub DrawImage (
    images As ImageList,
    index As Integer,
    rect As Rectangle,
    srcX As Integer,
    srcY As Integer,
    srcWidth As Integer,
    srcHeight As Integer,
    srcUnit As GraphicsUnit,
    imageAttr As ImageAttributes
)
void DrawImage(
    ImageList^ images,
    int index,
    Rectangle rect,
    int srcX,
    int srcY,
    int srcWidth,
    int srcHeight,
    GraphicsUnit srcUnit,
    ImageAttributes^ imageAttr
)
abstract DrawImage :
        images : ImageList *
        index : int *
        rect : Rectangle *
        srcX : int *
        srcY : int *
        srcWidth : int *
        srcHeight : int *
        srcUnit : GraphicsUnit *
        imageAttr : ImageAttributes -> unit

Parameters

images
Type: System.Windows.FormsImageList
Image list that contains image to draw.
index
Type: SystemInt32
Index of image to draw within image list.
rect
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the image.
srcX
Type: SystemInt32
X-coordinate of the upper-left corner of the portion of the source image to be drawn.
srcY
Type: SystemInt32
Y-coordinate of the upper-left corner of the portion of the source image to be drawn.
srcWidth
Type: SystemInt32
Width of the portion of the source image to be drawn.
srcHeight
Type: SystemInt32
Width of the portion of the source image to be drawn.
srcUnit
Type: System.DrawingGraphicsUnit
Specifies the unit of measure for the image.
imageAttr
Type: System.Drawing.ImagingImageAttributes
Specifies the color and size attributes of the image to be drawn.
See Also

Reference

IPainter Interface
DrawImage Overload
Alternet.Common Namespace


IPainter.DrawLine Method

IPainterDrawLine Method
Overload List
 | Name | Description
Public method | DrawLine(Int32, Int32, Int32, Int32) | When implemented by a class, draws a line from the given start position up to, but not including, the specified end point.
Public method | DrawLine(Int32, Int32, Int32, Int32, Color, Int32, DashStyle) | When implemented by a class, draws a line from the given start position up to, but not including, the specified end point.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawLine Method (Int32, Int32, Int32, Int32)

IPainterDrawLine Method (Int32, Int32, Int32, Int32)
When implemented by a class, draws a line from the given start position up to, but not including, the specified end point.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawLine(
    int x1,
    int y1,
    int x2,
    int y2
)
Sub DrawLine (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer
)
void DrawLine(
    int x1,
    int y1,
    int x2,
    int y2
)
abstract DrawLine :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int -> unit

Parameters

x1
Type: SystemInt32
X-coordinate of the line's start point.
y1
Type: SystemInt32
Y-coordinate of the line's start point.
x2
Type: SystemInt32
X-coordinate of the line's ending point.
y2
Type: SystemInt32
Y-coordinate of the line's ending point.
See Also

Reference

IPainter Interface
DrawLine Overload
Alternet.Common Namespace


IPainter.DrawLine Method (Int32, Int32, Int32, Int32, Color, Int32, DashStyle)

IPainterDrawLine Method (Int32, Int32, Int32, Int32, Color, Int32, DashStyle)
When implemented by a class, draws a line from the given start position up to, but not including, the specified end point.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawLine(
    int x1,
    int y1,
    int x2,
    int y2,
    Color color,
    int width,
    DashStyle penStyle
)
Sub DrawLine (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer,
    color As Color,
    width As Integer,
    penStyle As DashStyle
)
void DrawLine(
    int x1,
    int y1,
    int x2,
    int y2,
    Color color,
    int width,
    DashStyle penStyle
)
abstract DrawLine :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int *
        color : Color *
        width : int *
        penStyle : DashStyle -> unit

Parameters

x1
Type: SystemInt32
X-coordinate of the line's start point.
y1
Type: SystemInt32
Y-coordinate of the line's start point.
x2
Type: SystemInt32
X-coordinate of the line's ending point.
y2
Type: SystemInt32
Y-coordinate of the line's ending point.
color
Type: System.DrawingColor
Specifies color of the Pen object to draw line.
width
Type: SystemInt32
Specifies width of the Pen object to draw line.
penStyle
Type: System.Drawing.Drawing2DDashStyle
Specifies style of the Pen object to draw line.
See Also

Reference

IPainter Interface
DrawLine Overload
Alternet.Common Namespace


IPainter.DrawPolygon Method

IPainterDrawPolygon Method
When implemented by a class, draws a polygon defined by an array of Point structures.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawPolygon(
    Point[] points,
    Color color
)
Sub DrawPolygon (
    points As Point(),
    color As Color
)
void DrawPolygon(
    array<Point>^ points,
    Color color
)
abstract DrawPolygon :
        points : Point[] *
        color : Color -> unit

Parameters

points
Type: System.DrawingPoint
Array of Point structures that represent the vertices of the polygon.
color
Type: System.DrawingColor
Specifies color of the polygon.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawRectangle Method

IPainterDrawRectangle Method
Overload List
 | Name | Description
Public method | DrawRectangle(Rectangle) | When implemented by a class, draws a border around the specified rectangle using current BackColor.
Public method | DrawRectangle(Int32, Int32, Int32, Int32) | When implemented by a class, draws a border around the specified rectangle using dot pattern.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawRectangle Method (Rectangle)

IPainterDrawRectangle Method (Rectangle)
When implemented by a class, draws a border around the specified rectangle using current BackColor.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawRectangle(
    Rectangle rect
)
Sub DrawRectangle (
    rect As Rectangle
)
void DrawRectangle(
    Rectangle rect
)
abstract DrawRectangle :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
The rectangle object to draw border.
See Also

Reference

IPainter Interface
DrawRectangle Overload
Alternet.Common Namespace


IPainter.DrawRectangle Method (Int32, Int32, Int32, Int32)

IPainterDrawRectangle Method (Int32, Int32, Int32, Int32)
When implemented by a class, draws a border around the specified rectangle using dot pattern.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawRectangle(
    int x,
    int y,
    int width,
    int height
)
Sub DrawRectangle (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
void DrawRectangle(
    int x,
    int y,
    int width,
    int height
)
abstract DrawRectangle :
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.
See Also

Reference

IPainter Interface
DrawRectangle Overload
Alternet.Common Namespace


IPainter.DrawRoundRectangle Method

IPainterDrawRoundRectangle Method
When implemented by a class, draws a rectangle with rounded corners. The rectangle is outlined by using the current pen.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawRoundRectangle(
    int left,
    int top,
    int right,
    int bottom,
    int width,
    int height
)
Sub DrawRoundRectangle (
    left As Integer,
    top As Integer,
    right As Integer,
    bottom As Integer,
    width As Integer,
    height As Integer
)
void DrawRoundRectangle(
    int left,
    int top,
    int right,
    int bottom,
    int width,
    int height
)
abstract DrawRoundRectangle :
        left : int *
        top : int *
        right : int *
        bottom : int *
        width : int *
        height : int -> unit

Parameters

left
Type: SystemInt32
Specifies the x-coordinate, in logical coordinates, of the upper-left corner of the rectangle.
top
Type: SystemInt32
Specifies the y-coordinate, in logical coordinates, of the upper-left corner of the rectangle.
right
Type: SystemInt32
Specifies the x-coordinate, in logical coordinates, of the lower-right corner of the rectangle.
bottom
Type: SystemInt32
Specifies the y-coordinate, in logical coordinates, of the lower-right corner of the rectangle.
width
Type: SystemInt32
Specifies the width, in logical coordinates, of the ellipse used to draw the rounded corners.
height
Type: SystemInt32
Specifies the height, in logical coordinates, of the ellipse used to draw the rounded corners.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawText Method

IPainterDrawText Method
When implemented by a class, draws text in the specified rectangle using current values of TextColor and BackColor.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawText(
    string text,
    int len,
    Rectangle rect
)
Sub DrawText (
    text As String,
    len As Integer,
    rect As Rectangle
)
void DrawText(
    String^ text,
    int len,
    Rectangle rect
)
abstract DrawText :
        text : string *
        len : int *
        rect : Rectangle -> unit

Parameters

text
Type: SystemString
The text to be draw.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
The layout area for drawing text.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawThemeBackground Method

IPainterDrawThemeBackground Method
When implemented by a class, draws the background image defined by the visual style for the specified control part.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawThemeBackground(
    IntPtr handle,
    int partID,
    int stateID,
    Rectangle rect
)
Sub DrawThemeBackground (
    handle As IntPtr,
    partID As Integer,
    stateID As Integer,
    rect As Rectangle
)
void DrawThemeBackground(
    IntPtr handle,
    int partID,
    int stateID,
    Rectangle rect
)
abstract DrawThemeBackground :
        handle : IntPtr *
        partID : int *
        stateID : int *
        rect : Rectangle -> unit

Parameters

handle
Type: SystemIntPtr
Handle to a window's specified theme data.
partID
Type: SystemInt32
Specifies the part to draw.
stateID
Type: SystemInt32
Specifies the state of the part to draw.
rect
Type: System.DrawingRectangle
Specifies the rectangle, in logical coordinates, in which the background image is drawn.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.DrawWave Method

IPainterDrawWave Method
When implemented by a class, draws waved line in the specified rectangular area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawWave(
    Rectangle rect,
    Color color
)
Sub DrawWave (
    rect As Rectangle,
    color As Color
)
void DrawWave(
    Rectangle rect,
    Color color
)
abstract DrawWave :
        rect : Rectangle *
        color : Color -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the wave.
color
Type: System.DrawingColor
Color used to draw wave.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.EndPaint Method

IPainterEndPaint Method
When implemented by a class, marks the end of painting. Releases device context associated with this IPainter and restores saved IPainter properties.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EndPaint()
Sub EndPaint
void EndPaint()
abstract EndPaint : unit -> unit
See Also

Reference

IPainter Interface
Alternet.Common Namespace
IPainterBeginPaint(Graphics)


IPainter.EndTransform Method

IPainterEndTransform Method
When implemented by a class, sets default two-dimensional linear transformation for the specified device context.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EndTransform()
Sub EndTransform
void EndTransform()
abstract EndTransform : unit -> unit
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.ExcludeClipRect Method

IPainterExcludeClipRect Method
Overload List
 | Name | Description
Public method | ExcludeClipRect(Rectangle) | When implemented by a class, creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Public method | ExcludeClipRect(Int32, Int32, Int32, Int32) | When implemented by a class, creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.ExcludeClipRect Method (Rectangle)

IPainterExcludeClipRect Method (Rectangle)
When implemented by a class, creates a new clipping region that consists of the existing clipping region minus the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ExcludeClipRect(
    Rectangle rect
)
Sub ExcludeClipRect (
    rect As Rectangle
)
void ExcludeClipRect(
    Rectangle rect
)
abstract ExcludeClipRect :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangle to exclude.
See Also

Reference

IPainter Interface
ExcludeClipRect Overload
Alternet.Common Namespace


IPainter.ExcludeClipRect Method (Int32, Int32, Int32, Int32)

IPainterExcludeClipRect Method (Int32, Int32, Int32, Int32)
When implemented by a class, creates a new clipping region that consists of the existing clipping region minus the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ExcludeClipRect(
    int x,
    int y,
    int width,
    int height
)
Sub ExcludeClipRect (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
void ExcludeClipRect(
    int x,
    int y,
    int width,
    int height
)
abstract ExcludeClipRect :
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate, of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate, of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.
See Also

Reference

IPainter Interface
ExcludeClipRect Overload
Alternet.Common Namespace


IPainter.FillGradient Method

IPainterFillGradient Method
Overload List
 | Name | Description
Public method | FillGradient(Rectangle, Color, Color, Point, Point) | When implemented by a class, fills the given rectangle with color that smoothly fades from one side to the other.
Public method | FillGradient(Int32, Int32, Int32, Int32, Color, Color, Point, Point) | When implemented by a class, fills the given rectangle with color that smoothly fades from one side to the other.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.FillGradient Method (Rectangle, Color, Color, Point, Point)

IPainterFillGradient Method (Rectangle, Color, Color, Point, Point)
When implemented by a class, fills the given rectangle with color that smoothly fades from one side to the other.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillGradient(
    Rectangle rect,
    Color beginColor,
    Color endColor,
    Point point1,
    Point point2
)
Sub FillGradient (
    rect As Rectangle,
    beginColor As Color,
    endColor As Color,
    point1 As Point,
    point2 As Point
)
void FillGradient(
    Rectangle rect,
    Color beginColor,
    Color endColor,
    Point point1,
    Point point2
)
abstract FillGradient :
        rect : Rectangle *
        beginColor : Color *
        endColor : Color *
        point1 : Point *
        point2 : Point -> unit

Parameters

rect
Type: System.DrawingRectangle
The rectangle object to fill.
beginColor
Type: System.DrawingColor
A Color structure that represents the starting color of the linear gradient.
endColor
Type: System.DrawingColor
A Color structure that represents the ending color of the linear gradient.
point1
Type: System.DrawingPoint
A Point structure that represents the start point of the linear gradient.
point2
Type: System.DrawingPoint
A Point structure that represents the end point of the linear gradient.
See Also

Reference

IPainter Interface
FillGradient Overload
Alternet.Common Namespace


IPainter.FillGradient Method (Int32, Int32, Int32, Int32, Color, Color, Point, Point)

IPainterFillGradient Method (Int32, Int32, Int32, Int32, Color, Color, Point, Point)
When implemented by a class, fills the given rectangle with color that smoothly fades from one side to the other.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillGradient(
    int x,
    int y,
    int width,
    int height,
    Color beginColor,
    Color endColor,
    Point point1,
    Point point2
)
Sub FillGradient (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer,
    beginColor As Color,
    endColor As Color,
    point1 As Point,
    point2 As Point
)
void FillGradient(
    int x,
    int y,
    int width,
    int height,
    Color beginColor,
    Color endColor,
    Point point1,
    Point point2
)
abstract FillGradient :
        x : int *
        y : int *
        width : int *
        height : int *
        beginColor : Color *
        endColor : Color *
        point1 : Point *
        point2 : Point -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.
beginColor
Type: System.DrawingColor
A Color structure that represents the starting color of the linear gradient.
endColor
Type: System.DrawingColor
A Color structure that represents the ending color of the linear gradient.
point1
Type: System.DrawingPoint
A Point structure that represents the start point of the linear gradient.
point2
Type: System.DrawingPoint
A Point structure that represents the end point of the linear gradient.
See Also

Reference

IPainter Interface
FillGradient Overload
Alternet.Common Namespace


IPainter.FillPolygon Method

IPainterFillPolygon Method
When implemented by a class, fills the interior of a polygon defined by an array of points specified by Point structures.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillPolygon(
    Color color,
    Point[] points
)
Sub FillPolygon (
    color As Color,
    points As Point()
)
void FillPolygon(
    Color color,
    array<Point>^ points
)
abstract FillPolygon :
        color : Color *
        points : Point[] -> unit

Parameters

color
Type: System.DrawingColor
Specifies color to fill polygon.
points
Type: System.DrawingPoint
Array of Point structures that represent the vertices of the polygon to fill.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.FillRectangle Method

IPainterFillRectangle Method
Overload List
 | Name | Description
Public method | FillRectangle(Rectangle) | When implemented by a class, fills the given rectangle by using the current brush.
Public method | FillRectangle(Color, Rectangle) | When implemented by a class, fills the given rectangle by using specified color.
Public method | FillRectangle(Int32, Int32, Int32, Int32) | When implemented by a class, fills the given rectangular area by using the current brush.
Public method | FillRectangle(Color, Int32, Int32, Int32, Int32) | When implemented by a class, fills the given rectangle by using specified color.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.FillRectangle Method (Rectangle)

IPainterFillRectangle Method (Rectangle)
When implemented by a class, fills the given rectangle by using the current brush.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillRectangle(
    Rectangle rect
)
Sub FillRectangle (
    rect As Rectangle
)
void FillRectangle(
    Rectangle rect
)
abstract FillRectangle :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
The rectangle object to fill.
See Also

Reference

IPainter Interface
FillRectangle Overload
Alternet.Common Namespace


IPainter.FillRectangle Method (Color, Rectangle)

IPainterFillRectangle Method (Color, Rectangle)
When implemented by a class, fills the given rectangle by using specified color.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillRectangle(
    Color color,
    Rectangle rect
)
Sub FillRectangle (
    color As Color,
    rect As Rectangle
)
void FillRectangle(
    Color color,
    Rectangle rect
)
abstract FillRectangle :
        color : Color *
        rect : Rectangle -> unit

Parameters

color
Type: System.DrawingColor
Specified color to fill rectangle.
rect
Type: System.DrawingRectangle
The rectangle object to fill.
See Also

Reference

IPainter Interface
FillRectangle Overload
Alternet.Common Namespace


IPainter.FillRectangle Method (Int32, Int32, Int32, Int32)

IPainterFillRectangle Method (Int32, Int32, Int32, Int32)
When implemented by a class, fills the given rectangular area by using the current brush.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillRectangle(
    int x,
    int y,
    int width,
    int height
)
Sub FillRectangle (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
void FillRectangle(
    int x,
    int y,
    int width,
    int height
)
abstract FillRectangle :
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.
See Also

Reference

IPainter Interface
FillRectangle Overload
Alternet.Common Namespace


IPainter.FillRectangle Method (Color, Int32, Int32, Int32, Int32)

IPainterFillRectangle Method (Color, Int32, Int32, Int32, Int32)
When implemented by a class, fills the given rectangle by using specified color.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillRectangle(
    Color color,
    int x,
    int y,
    int width,
    int height
)
Sub FillRectangle (
    color As Color,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
void FillRectangle(
    Color color,
    int x,
    int y,
    int width,
    int height
)
abstract FillRectangle :
        color : Color *
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

color
Type: System.DrawingColor
Specified color to fill rectangle.
x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.
See Also

Reference

IPainter Interface
FillRectangle Overload
Alternet.Common Namespace


IPainter.FillRoundRectangle Method

IPainterFillRoundRectangle Method
When implemented by a class, fills a rectangle with rounded corners. The rectangle is outlined by using the current pen and filled by using the current brush.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillRoundRectangle(
    int left,
    int top,
    int right,
    int bottom,
    int width,
    int height
)
Sub FillRoundRectangle (
    left As Integer,
    top As Integer,
    right As Integer,
    bottom As Integer,
    width As Integer,
    height As Integer
)
void FillRoundRectangle(
    int left,
    int top,
    int right,
    int bottom,
    int width,
    int height
)
abstract FillRoundRectangle :
        left : int *
        top : int *
        right : int *
        bottom : int *
        width : int *
        height : int -> unit

Parameters

left
Type: SystemInt32
Specifies the x-coordinate, in logical coordinates, of the upper-left corner of the rectangle.
top
Type: SystemInt32
Specifies the y-coordinate, in logical coordinates, of the upper-left corner of the rectangle.
right
Type: SystemInt32
Specifies the x-coordinate, in logical coordinates, of the lower-right corner of the rectangle.
bottom
Type: SystemInt32
Specifies the y-coordinate, in logical coordinates, of the lower-right corner of the rectangle.
width
Type: SystemInt32
Specifies the width, in logical coordinates, of the ellipse used to draw the rounded corners.
height
Type: SystemInt32
Specifies the height, in logical coordinates, of the ellipse used to draw the rounded corners.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.IntersectClipRect Method

IPainterIntersectClipRect Method
Overload List
 | Name | Description
Public method | IntersectClipRect(Rectangle) | When implemented by a class, creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Public method | IntersectClipRect(Int32, Int32, Int32, Int32) | When implemented by a class, creates a new clipping region from the intersection of the current clipping region and the specified rectangle.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.IntersectClipRect Method (Rectangle)

IPainterIntersectClipRect Method (Rectangle)
When implemented by a class, creates a new clipping region from the intersection of the current clipping region and the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void IntersectClipRect(
    Rectangle rect
)
Sub IntersectClipRect (
    rect As Rectangle
)
void IntersectClipRect(
    Rectangle rect
)
abstract IntersectClipRect :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangle to intersect.
See Also

Reference

IPainter Interface
IntersectClipRect Overload
Alternet.Common Namespace


IPainter.IntersectClipRect Method (Int32, Int32, Int32, Int32)

IPainterIntersectClipRect Method (Int32, Int32, Int32, Int32)
When implemented by a class, creates a new clipping region from the intersection of the current clipping region and the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void IntersectClipRect(
    int x,
    int y,
    int width,
    int height
)
Sub IntersectClipRect (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
void IntersectClipRect(
    int x,
    int y,
    int width,
    int height
)
abstract IntersectClipRect :
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate of the upper-left corner of the rectangle.
y
Type: SystemInt32
Y-coordinate of the upper-left corner of the rectangle.
width
Type: SystemInt32
Width of the rectangle.
height
Type: SystemInt32
Height of the rectangle.
See Also

Reference

IPainter Interface
IntersectClipRect Overload
Alternet.Common Namespace


IPainter.RestoreClip Method

IPainterRestoreClip Method
When implemented by a class, restores current clipping region from previously saved region.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RestoreClip(
    IntPtr rgn
)
Sub RestoreClip (
    rgn As IntPtr
)
void RestoreClip(
    IntPtr rgn
)
abstract RestoreClip :
        rgn : IntPtr -> unit

Parameters

rgn
Type: SystemIntPtr
Specifies handle to the previously saved clipping region.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.SaveClip Method

IPainterSaveClip Method
When implemented by a class, retrieves handle to clipping region saved from specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IntPtr SaveClip(
    Rectangle rect
)
Function SaveClip (
    rect As Rectangle
) As IntPtr
IntPtr SaveClip(
    Rectangle rect
)
abstract SaveClip :
        rect : Rectangle -> IntPtr

Parameters

rect
Type: System.DrawingRectangle
Rectangle to process.

Return Value

Type: IntPtr
Handle to clipping region.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.StretchDrawImage Method

IPainterStretchDrawImage Method
When implemented by a class, draws stretched image in the specified rectangular area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StretchDrawImage(
    Rectangle rect,
    Rectangle stretchRect,
    Rectangle imageRect,
    Bitmap image
)
Sub StretchDrawImage (
    rect As Rectangle,
    stretchRect As Rectangle,
    imageRect As Rectangle,
    image As Bitmap
)
void StretchDrawImage(
    Rectangle rect,
    Rectangle stretchRect,
    Rectangle imageRect,
    Bitmap^ image
)
abstract StretchDrawImage :
        rect : Rectangle *
        stretchRect : Rectangle *
        imageRect : Rectangle *
        image : Bitmap -> unit

Parameters

rect
Type: System.DrawingRectangle
Base rect
stretchRect
Type: System.DrawingRectangle
Stretch rect
imageRect
Type: System.DrawingRectangle
Image rect
image
Type: System.DrawingBitmap
Specifies image to draw.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.StringWidth Method

IPainterStringWidth Method
Overload List
 | Name | Description
Public method | StringWidth(String) | When implemented by a class, returns width of the given string.
Public method | StringWidth(String, Int32, Int32) | When implemented by a class, returns width of the specified part of the given string.
Public method | StringWidth(String, Int32, Int32, Boolean) | When implemented by a class, returns width of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32) | When implemented by a class, returns width of the specified part of the given string fitting into the given Width.
Public method | StringWidth(String, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, returns width of the specified part of the given string fitting into the given Width.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.StringWidth Method (String)

IPainterStringWidth Method (String)
When implemented by a class, returns width of the given string.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int StringWidth(
    string text
)
Function StringWidth (
    text As String
) As Integer
int StringWidth(
    String^ text
)
abstract StringWidth :
        text : string -> int

Parameters

text
Type: SystemString
The text to calculate width.

Return Value

Type: Int32
Width of specified string.
See Also

Reference

IPainter Interface
StringWidth Overload
Alternet.Common Namespace


IPainter.StringWidth Method (String, Int32, Int32)

IPainterStringWidth Method (String, Int32, Int32)
When implemented by a class, returns width of the specified part of the given string.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int StringWidth(
    string text,
    int pos,
    int len
)
Function StringWidth (
    text As String,
    pos As Integer,
    len As Integer
) As Integer
int StringWidth(
    String^ text,
    int pos,
    int len
)
abstract StringWidth :
        text : string *
        pos : int *
        len : int -> int

Parameters

text
Type: SystemString
The text to calculate width.
pos
Type: SystemInt32
Position of the first character to start calculating.
len
Type: SystemInt32
Length of the part of string to calculate width.

Return Value

Type: Int32
Width of the part of string.
See Also

Reference

IPainter Interface
StringWidth Overload
Alternet.Common Namespace


IPainter.StringWidth Method (String, Int32, Int32, Boolean)

IPainterStringWidth Method (String, Int32, Int32, Boolean)
When implemented by a class, returns width of the given string fitting into the given Width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int StringWidth(
    string text,
    int width,
    out int count,
    bool exact
)
Function StringWidth (
    text As String,
    width As Integer,
    <OutAttribute> ByRef count As Integer,
    exact As Boolean
) As Integer
int StringWidth(
    String^ text,
    int width,
    [OutAttribute] int% count,
    bool exact
)
abstract StringWidth :
        text : string *
        width : int *
        count : int byref *
        exact : bool -> int

Parameters

text
Type: SystemString
The text to calculate width.
width
Type: SystemInt32
Maximum layout area for the string.
count
Type: SystemInt32
Receives number of character fitting into specified Width.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the part of string.
See Also

Reference

IPainter Interface
StringWidth Overload
Alternet.Common Namespace


IPainter.StringWidth Method (String, Int32, Int32, Int32, Int32)

IPainterStringWidth Method (String, Int32, Int32, Int32, Int32)
When implemented by a class, returns width of the specified part of the given string fitting into the given Width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int StringWidth(
    string text,
    int pos,
    int len,
    int width,
    out int count
)
Function StringWidth (
    text As String,
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef count As Integer
) As Integer
int StringWidth(
    String^ text,
    int pos,
    int len,
    int width,
    [OutAttribute] int% count
)
abstract StringWidth :
        text : string *
        pos : int *
        len : int *
        width : int *
        count : int byref -> int

Parameters

text
Type: SystemString
The text to calculate width.
pos
Type: SystemInt32
Position of the first character to start calculating.
len
Type: SystemInt32
Length of the part of string to calculate width.
width
Type: SystemInt32
Maximum layout area for the string.
count
Type: SystemInt32
Receives number of characters fitting into specified Width.

Return Value

Type: Int32
Width of the part of string.
See Also

Reference

IPainter Interface
StringWidth Overload
Alternet.Common Namespace


IPainter.StringWidth Method (String, Int32, Int32, Int32, Int32, Boolean)

IPainterStringWidth Method (String, Int32, Int32, Int32, Int32, Boolean)
When implemented by a class, returns width of the specified part of the given string fitting into the given Width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int StringWidth(
    string text,
    int pos,
    int len,
    int width,
    out int count,
    bool exact
)
Function StringWidth (
    text As String,
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef count As Integer,
    exact As Boolean
) As Integer
int StringWidth(
    String^ text,
    int pos,
    int len,
    int width,
    [OutAttribute] int% count,
    bool exact
)
abstract StringWidth :
        text : string *
        pos : int *
        len : int *
        width : int *
        count : int byref *
        exact : bool -> int

Parameters

text
Type: SystemString
The text to calculate width.
pos
Type: SystemInt32
Position of the first character to start calculating.
len
Type: SystemInt32
Length of the part of string to calculate width.
width
Type: SystemInt32
Maximum layout area for the string.
count
Type: SystemInt32
Receives number of characters fitting into the into the specified Width.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the part of string.
See Also

Reference

IPainter Interface
StringWidth Overload
Alternet.Common Namespace


IPainter.TextOut Method

IPainterTextOut Method
Overload List
 | Name | Description
Public method | TextOut(String, Int32, Rectangle) | When implemented by a class, draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32) | When implemented by a class, draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Boolean, Boolean) | When implemented by a class, draws text within the specified rectangle.
Public method | TextOut(String, Int32, Int32, Int32, Boolean, Boolean) | When implemented by a class, draws text in the specified location.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean) | When implemented by a class, draws text within the specified rectangle.
Public method | TextOut(String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32) | When implemented by a class, draws text within the specified rectangle.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.TextOut Method (String, Int32, Rectangle)

IPainterTextOut Method (String, Int32, Rectangle)
When implemented by a class, draws text within the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TextOut(
    string text,
    int len,
    Rectangle rect
)
Sub TextOut (
    text As String,
    len As Integer,
    rect As Rectangle
)
void TextOut(
    String^ text,
    int len,
    Rectangle rect
)
abstract TextOut :
        text : string *
        len : int *
        rect : Rectangle -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.
See Also

Reference

IPainter Interface
TextOut Overload
Alternet.Common Namespace


IPainter.TextOut Method (String, Int32, Int32, Int32)

IPainterTextOut Method (String, Int32, Int32, Int32)
When implemented by a class, draws text in the specified location.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TextOut(
    string text,
    int len,
    int x,
    int y
)
Sub TextOut (
    text As String,
    len As Integer,
    x As Integer,
    y As Integer
)
void TextOut(
    String^ text,
    int len,
    int x,
    int y
)
abstract TextOut :
        text : string *
        len : int *
        x : int *
        y : int -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
x
Type: SystemInt32
X-coordinate of the start text point.
y
Type: SystemInt32
Y-coordinate of the start text point.
See Also

Reference

IPainter Interface
TextOut Overload
Alternet.Common Namespace


IPainter.TextOut Method (String, Int32, Rectangle, Boolean, Boolean)

IPainterTextOut Method (String, Int32, Rectangle, Boolean, Boolean)
When implemented by a class, draws text within the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TextOut(
    string text,
    int len,
    Rectangle rect,
    bool clipped,
    bool opaque
)
Sub TextOut (
    text As String,
    len As Integer,
    rect As Rectangle,
    clipped As Boolean,
    opaque As Boolean
)
void TextOut(
    String^ text,
    int len,
    Rectangle rect,
    bool clipped,
    bool opaque
)
abstract TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        clipped : bool *
        opaque : bool -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.
clipped
Type: SystemBoolean
Specifies that text will be clipped to the rectangle.
opaque
Type: SystemBoolean
Specifies that current background color should be used to fill the rectangle.
See Also

Reference

IPainter Interface
TextOut Overload
Alternet.Common Namespace


IPainter.TextOut Method (String, Int32, Int32, Int32, Boolean, Boolean)

IPainterTextOut Method (String, Int32, Int32, Int32, Boolean, Boolean)
When implemented by a class, draws text in the specified location.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TextOut(
    string text,
    int len,
    int x,
    int y,
    bool clipped,
    bool opaque
)
Sub TextOut (
    text As String,
    len As Integer,
    x As Integer,
    y As Integer,
    clipped As Boolean,
    opaque As Boolean
)
void TextOut(
    String^ text,
    int len,
    int x,
    int y,
    bool clipped,
    bool opaque
)
abstract TextOut :
        text : string *
        len : int *
        x : int *
        y : int *
        clipped : bool *
        opaque : bool -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
x
Type: SystemInt32
X-coordinate of the start text point.
y
Type: SystemInt32
Y-coordinate of the start text point.
clipped
Type: SystemBoolean
Specifies that text will be clipped to the rectangle.
opaque
Type: SystemBoolean
Specifies that current background color should be used to fill the rectangle.
See Also

Reference

IPainter Interface
TextOut Overload
Alternet.Common Namespace


IPainter.TextOut Method (String, Int32, Rectangle, Int32, Int32, Boolean, Boolean)

IPainterTextOut Method (String, Int32, Rectangle, Int32, Int32, Boolean, Boolean)
When implemented by a class, draws text within the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TextOut(
    string text,
    int len,
    Rectangle rect,
    int x,
    int y,
    bool clipped,
    bool opaque
)
Sub TextOut (
    text As String,
    len As Integer,
    rect As Rectangle,
    x As Integer,
    y As Integer,
    clipped As Boolean,
    opaque As Boolean
)
void TextOut(
    String^ text,
    int len,
    Rectangle rect,
    int x,
    int y,
    bool clipped,
    bool opaque
)
abstract TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        x : int *
        y : int *
        clipped : bool *
        opaque : bool -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.
x
Type: SystemInt32
X-coordinate of the start text point.
y
Type: SystemInt32
Y-coordinate of the start text point.
clipped
Type: SystemBoolean
Specifies that text will be clipped to the rectangle.
opaque
Type: SystemBoolean
Specifies that current background color should be used to fill the rectangle.
See Also

Reference

IPainter Interface
TextOut Overload
Alternet.Common Namespace


IPainter.TextOut Method (String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32)

IPainterTextOut Method (String, Int32, Rectangle, Int32, Int32, Boolean, Boolean, Int32)
When implemented by a class, draws text within the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TextOut(
    string text,
    int len,
    Rectangle rect,
    int x,
    int y,
    bool clipped,
    bool opaque,
    int space
)
Sub TextOut (
    text As String,
    len As Integer,
    rect As Rectangle,
    x As Integer,
    y As Integer,
    clipped As Boolean,
    opaque As Boolean,
    space As Integer
)
void TextOut(
    String^ text,
    int len,
    Rectangle rect,
    int x,
    int y,
    bool clipped,
    bool opaque,
    int space
)
abstract TextOut :
        text : string *
        len : int *
        rect : Rectangle *
        x : int *
        y : int *
        clipped : bool *
        opaque : bool *
        space : int -> unit

Parameters

text
Type: SystemString
The text to be drawn.
len
Type: SystemInt32
Specifies the length of the string.
rect
Type: System.DrawingRectangle
Specifies the dimensions, in logical coordinates, of a rectangle that is used for clipping, opaquing, or both.
x
Type: SystemInt32
X-coordinate of the start text point.
y
Type: SystemInt32
Y-coordinate of the start text point.
clipped
Type: SystemBoolean
Specifies that text will be clipped to the rectangle.
opaque
Type: SystemBoolean
Specifies that current background color should be used to fill the rectangle.
space
Type: SystemInt32
Specifies distance between origins of adjacent character cells.
See Also

Reference

IPainter Interface
TextOut Overload
Alternet.Common Namespace


IPainter.Transform Method

IPainterTransform Method
When implemented by a class, sets a two-dimensional linear transformation for the specified device context.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Transform(
    int x,
    int y,
    float scaleX,
    float scaleY
)
Sub Transform (
    x As Integer,
    y As Integer,
    scaleX As Single,
    scaleY As Single
)
void Transform(
    int x,
    int y,
    float scaleX,
    float scaleY
)
abstract Transform :
        x : int *
        y : int *
        scaleX : float32 *
        scaleY : float32 -> unit

Parameters

x
Type: SystemInt32
Horizontal offset of the transformation.
y
Type: SystemInt32
Vertical offset of the transformation.
scaleX
Type: SystemSingle
Horizontal scale of the transformation.
scaleY
Type: SystemSingle
Vertical scale of the transformation.
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter Properties

IPainter Properties

The IPainter type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets background color of the device context currently associated with the IPainter.
Public property | Font | When implemented by a class, gets or sets font of the device context currently associated with the IPainter.
Public property | FontHeight | When implemented by a class, represents height of the font of the device context currently associated with the IPainter.
Public property | FontStyle | When implemented by a class, gets or sets font style of the device context currently associated with the IPainter.
Public property | FontWidth | When implemented by a class, represents width of the font of the device context currently associated with the IPainter.
Public property | ForeColor | When implemented by a class, gets or sets foreground color of the device context currently associated with the IPainter.
Public property | Graphics | When implemented by a class, represents Graphics object used to paint.
Public property | IsMonoSpaced | When implemented by a class, represents a value indicating whether font of the device context currently associated with this IPainter is monospaced, meaning that all characters drawn with this font have the same width.
Public property | LineHeight | When implemented by a class, represents height of the individual lines.
Public property | LineSpace | When implemented by a class, Represents additional height added to the height of the font.
Public property | Opaque | When implemented by a class, gets or sets a boolean value indicating that background is filled with the current background color before the text is drawn.
Public property | StringFormat | When implemented by a class, encapsulates text layout information and display manipulations for this IPainter.
Public property | TextColor | When implemented by a class, gets or sets text color of the device context currently associated with the IPainter.
Public property | Transformation | When implemented by a class gets the world transformation for Graphics property.
Public property | UseDrawText | When implemented by a class, indicates whether painter should use DrawText method rather then ExtTextOut to paint text.
Top
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.BackColor Property

IPainterBackColor Property
When implemented by a class, gets or sets background color of the device context currently associated with the IPainter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; set; }
Property BackColor As Color
    Get
    Set
property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.Font Property

IPainterFont Property
When implemented by a class, gets or sets font of the device context currently associated with the IPainter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Font Font { get; set; }
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

Property Value

Type: Font
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.FontHeight Property

IPainterFontHeight Property
When implemented by a class, represents height of the font of the device context currently associated with the IPainter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FontHeight { get; }
ReadOnly Property FontHeight As Integer
    Get
property int FontHeight {
    int get ();
}
abstract FontHeight : int with get

Property Value

Type: Int32
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.FontStyle Property

IPainterFontStyle Property
When implemented by a class, gets or sets font style of the device context currently associated with the IPainter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
FontStyle FontStyle { get; set; }
Property FontStyle As FontStyle
    Get
    Set
property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract FontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.FontWidth Property

IPainterFontWidth Property
When implemented by a class, represents width of the font of the device context currently associated with the IPainter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FontWidth { get; }
ReadOnly Property FontWidth As Integer
    Get
property int FontWidth {
    int get ();
}
abstract FontWidth : int with get

Property Value

Type: Int32
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.ForeColor Property

IPainterForeColor Property
When implemented by a class, gets or sets foreground color of the device context currently associated with the IPainter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; set; }
Property ForeColor As Color
    Get
    Set
property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.Graphics Property

IPainterGraphics Property
When implemented by a class, represents Graphics object used to paint.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Graphics Graphics { get; }
ReadOnly Property Graphics As Graphics
    Get
property Graphics^ Graphics {
    Graphics^ get ();
}
abstract Graphics : Graphics with get

Property Value

Type: Graphics
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.IsMonoSpaced Property

IPainterIsMonoSpaced Property
When implemented by a class, represents a value indicating whether font of the device context currently associated with this IPainter is monospaced, meaning that all characters drawn with this font have the same width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsMonoSpaced { get; set; }
Property IsMonoSpaced As Boolean
    Get
    Set
property bool IsMonoSpaced {
    bool get ();
    void set (bool value);
}
abstract IsMonoSpaced : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.LineHeight Property

IPainterLineHeight Property
When implemented by a class, represents height of the individual lines.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LineHeight { get; }
ReadOnly Property LineHeight As Integer
    Get
property int LineHeight {
    int get ();
}
abstract LineHeight : int with get

Property Value

Type: Int32
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.LineSpace Property

IPainterLineSpace Property
When implemented by a class, Represents additional height added to the height of the font.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LineSpace { get; set; }
Property LineSpace As Integer
    Get
    Set
property int LineSpace {
    int get ();
    void set (int value);
}
abstract LineSpace : int with get, set

Property Value

Type: Int32
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.Opaque Property

IPainterOpaque Property
When implemented by a class, gets or sets a boolean value indicating that background is filled with the current background color before the text is drawn.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Opaque { get; set; }
Property Opaque As Boolean
    Get
    Set
property bool Opaque {
    bool get ();
    void set (bool value);
}
abstract Opaque : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.StringFormat Property

IPainterStringFormat Property
When implemented by a class, encapsulates text layout information and display manipulations for this IPainter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
StringFormat StringFormat { get; set; }
Property StringFormat As StringFormat
    Get
    Set
property StringFormat^ StringFormat {
    StringFormat^ get ();
    void set (StringFormat^ value);
}
abstract StringFormat : StringFormat with get, set

Property Value

Type: StringFormat
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.TextColor Property

IPainterTextColor Property
When implemented by a class, gets or sets text color of the device context currently associated with the IPainter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color TextColor { get; set; }
Property TextColor As Color
    Get
    Set
property Color TextColor {
    Color get ();
    void set (Color value);
}
abstract TextColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.Transformation Property

IPainterTransformation Property
When implemented by a class gets the world transformation for Graphics property.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Matrix Transformation { get; }
ReadOnly Property Transformation As Matrix
    Get
property Matrix^ Transformation {
    Matrix^ get ();
}
abstract Transformation : Matrix with get

Property Value

Type: Matrix
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IPainter.UseDrawText Property

IPainterUseDrawText Property
When implemented by a class, indicates whether painter should use DrawText method rather then ExtTextOut to paint text.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseDrawText { get; set; }
Property UseDrawText As Boolean
    Get
    Set
property bool UseDrawText {
    bool get ();
    void set (bool value);
}
abstract UseDrawText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPainter Interface
Alternet.Common Namespace


IRange Interface

IRange Interface
Represents an pair of two points that defines a scope in a two-dimensional plane.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRange : ICloneable
Public Interface IRange
    Inherits ICloneable
public interface class IRange : ICloneable
type IRange =
    interface
        interface ICloneable
    end

The IRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object.
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
Properties
 | Name | Description
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area.
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size.
Public property | Size | When implemented by a class, gets or sets size of IRange area.
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area.
Top
See Also

Reference

Alternet.Common Namespace


IRange Methods

IRange Methods

The IRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object.
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

IRange Interface
Alternet.Common Namespace


IRange.Assign Method

IRangeAssign Method
Copies contents from another IRange object.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IRange source
)
Sub Assign (
    source As IRange
)
void Assign(
    IRange^ source
)
abstract Assign :
        source : IRange -> unit

Parameters

source
Type: Alternet.CommonIRange
See Also

Reference

IRange Interface
Alternet.Common Namespace


IRange Properties

IRange Properties

The IRange type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area.
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size.
Public property | Size | When implemented by a class, gets or sets size of IRange area.
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area.
Top
See Also

Reference

IRange Interface
Alternet.Common Namespace


IRange.EndPoint Property

IRangeEndPoint Property
When implemented by a class, gets or sets end of IRange area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point EndPoint { get; set; }
Property EndPoint As Point
    Get
    Set
property Point EndPoint {
    Point get ();
    void set (Point value);
}
abstract EndPoint : Point with get, set

Property Value

Type: Point
See Also

Reference

IRange Interface
Alternet.Common Namespace


IRange.IsEmpty Property

IRangeIsEmpty Property
When implemented by a class, gets boolean value indicating whether IRange has zero size.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsEmpty { get; }
ReadOnly Property IsEmpty As Boolean
    Get
property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

IRange Interface
Alternet.Common Namespace


IRange.Size Property

IRangeSize Property
When implemented by a class, gets or sets size of IRange area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Size Size { get; set; }
Property Size As Size
    Get
    Set
property Size Size {
    Size get ();
    void set (Size value);
}
abstract Size : Size with get, set

Property Value

Type: Size
See Also

Reference

IRange Interface
Alternet.Common Namespace


IRange.StartPoint Property

IRangeStartPoint Property
When implemented by a class, gets or sets begin of IRange area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point StartPoint { get; set; }
Property StartPoint As Point
    Get
    Set
property Point StartPoint {
    Point get ();
    void set (Point value);
}
abstract StartPoint : Point with get, set

Property Value

Type: Point
See Also

Reference

IRange Interface
Alternet.Common Namespace


IRangeList Interface

IRangeList Interface
Represents a sorted collection of IRange objects that can be individually accessed by index.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRangeList : ISortList<IRange>,
    IList<IRange>, ICollection<IRange>, IEnumerable<IRange>,
    IEnumerable
Public Interface IRangeList
    Inherits ISortList(Of IRange), IList(Of IRange),
    ICollection(Of IRange), IEnumerable(Of IRange), IEnumerable
public interface class IRangeList : ISortList<IRange^>,
    IList<IRange^>, ICollection<IRange^>, IEnumerable<IRange^>,
    IEnumerable
type IRangeList =
    interface
        interface ISortList<IRange>
        interface IList<IRange>
        interface ICollection<IRange>
        interface IEnumerable<IRange>
        interface IEnumerable
    end

The IRangeList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIRange .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIRange .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIRange .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIRange .)
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIRange .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIRange .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIRange .)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria. (Inherited from ISortListT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIRange .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIRange .)
Public method | Sort | When implemented by a class, sorts the elements in the entire sort list using the specified comparer. (Inherited from ISortListT.)
Public method | UpdatePosition | When implemented by a class, updates specified position by DeltaX and DeltaY values for specific IRange.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIRange | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIRange | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIRange, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIRange .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIRange .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIRange .)
Top
See Also

Reference

Alternet.Common Namespace


IRangeList Methods

IRangeList Methods

The IRangeList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIRange .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIRange .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIRange .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIRange .)
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIRange .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIRange .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIRange .)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria. (Inherited from ISortListT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIRange .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIRange .)
Public method | Sort | When implemented by a class, sorts the elements in the entire sort list using the specified comparer. (Inherited from ISortListT.)
Public method | UpdatePosition | When implemented by a class, updates specified position by DeltaX and DeltaY values for specific IRange.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIRange | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIRange | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIRange, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IRangeList Interface
Alternet.Common Namespace


IRangeList.UpdatePosition Method

IRangeListUpdatePosition Method
When implemented by a class, updates specified position by DeltaX and DeltaY values for specific IRange.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UpdatePosition(
    IRange range,
    int x,
    int y,
    int deltaX,
    int deltaY
)
Function UpdatePosition (
    range As IRange,
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
bool UpdatePosition(
    IRange^ range,
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract UpdatePosition :
        range : IRange *
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

range
Type: Alternet.CommonIRange
IRange to update.
x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IRangeList Interface
Alternet.Common Namespace


IRangeList Properties

IRangeList Properties

The IRangeList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIRange .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIRange .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIRange .)
Top
See Also

Reference

IRangeList Interface
Alternet.Common Namespace


ISerializationInfo Interface

ISerializationInfo Interface
Represents methods to serialize objects.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISerializationInfo
Public Interface ISerializationInfo
public interface class ISerializationInfo
type ISerializationInfo =  interface end

The ISerializationInfo type exposes the following members.

Methods
 | Name | Description
Public method | FixupReferences | When implemented by a class, updates properties of external object with ones previously stored.
Public method | Load | When implemented by a class, reads property values from external object. Reserved for internal use.
Top
See Also

Reference

Alternet.Common Namespace


ISerializationInfo Methods

ISerializationInfo Methods

The ISerializationInfo type exposes the following members.

Methods
 | Name | Description
Public method | FixupReferences | When implemented by a class, updates properties of external object with ones previously stored.
Public method | Load | When implemented by a class, reads property values from external object. Reserved for internal use.
Top
See Also

Reference

ISerializationInfo Interface
Alternet.Common Namespace


ISerializationInfo.FixupReferences Method

ISerializationInfoFixupReferences Method
When implemented by a class, updates properties of external object with ones previously stored.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FixupReferences(
    Object owner
)
Sub FixupReferences (
    owner As Object
)
void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.
See Also

Reference

ISerializationInfo Interface
Alternet.Common Namespace


ISerializationInfo.Load Method

ISerializationInfoLoad Method
When implemented by a class, reads property values from external object. Reserved for internal use.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Load()
Sub Load
void Load()
abstract Load : unit -> unit
See Also

Reference

ISerializationInfo Interface
Alternet.Common Namespace


ISortList(T) Interface

ISortListT Interface
Represents a sorted collection of objects that can be individually accessed by index.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISortList<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

Public Interface ISortList(Of T)
    Inherits IList(Of T), ICollection(Of T), IEnumerable(Of T),
    IEnumerable
generic<typename T>
public interface class ISortList : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable
type ISortList<'T> =
    interface
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T

The ISortListT type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionT.)
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria.
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableT.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListT.)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListT.)
Public method | Sort | When implemented by a class, sorts the elements in the entire sort list using the specified comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfT | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstT | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementT, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionT.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListT.)
Top
See Also

Reference

Alternet.Common Namespace


ISortList(T) Methods

ISortListT Methods

The ISortListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionT .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionT .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionT .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionT .)
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria.
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableT .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListT .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListT .)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionT .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListT .)
Public method | Sort | When implemented by a class, sorts the elements in the entire sort list using the specified comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfT | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstT | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementT, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ISortListT Interface
Alternet.Common Namespace


ISortList(T).FindExact Method

ISortListTFindExact Method
Overload List
 | Name | Description
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Top
See Also

Reference

ISortListT Interface
Alternet.Common Namespace


ISortList(T).FindExact Method (Object, Int32, IComparer)

ISortListTFindExact Method (Object, Int32, IComparer)
When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindExact(
    Object obj,
    out int index,
    IComparer comparer
)
Function FindExact (
    obj As Object,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer
) As Boolean
bool FindExact(
    Object^ obj,
    [OutAttribute] int% index,
    IComparer^ comparer
)
abstract FindExact :
        obj : Object *
        index : int byref *
        comparer : IComparer -> bool

Parameters

obj
Type: SystemObject
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.CollectionsIComparer
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.
See Also

Reference

ISortListT Interface
FindExact Overload
Alternet.Common Namespace


ISortList(T).FindExact Method (T, Int32, IComparer(T))

ISortListTFindExact Method (T, Int32, IComparerT)
When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindExact(
    T obj,
    out int index,
    IComparer<T> comparer
)
Function FindExact (
    obj As T,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer(Of T)
) As Boolean
bool FindExact(
    T obj,
    [OutAttribute] int% index,
    IComparer<T>^ comparer
)
abstract FindExact :
        obj : 'T *
        index : int byref *
        comparer : IComparer<'T> -> bool

Parameters

obj
Type: T
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.Collections.GenericIComparerT
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.
See Also

Reference

ISortListT Interface
FindExact Overload
Alternet.Common Namespace


ISortList(T).FindFirst Method

ISortListTFindFirst Method
Overload List
 | Name | Description
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria.
Top
See Also

Reference

ISortListT Interface
Alternet.Common Namespace


ISortList(T).FindFirst Method (Object, Int32, IComparer)

ISortListTFindFirst Method (Object, Int32, IComparer)
When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindFirst(
    Object obj,
    out int index,
    IComparer comparer
)
Function FindFirst (
    obj As Object,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer
) As Boolean
bool FindFirst(
    Object^ obj,
    [OutAttribute] int% index,
    IComparer^ comparer
)
abstract FindFirst :
        obj : Object *
        index : int byref *
        comparer : IComparer -> bool

Parameters

obj
Type: SystemObject
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.CollectionsIComparer
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.
See Also

Reference

ISortListT Interface
FindFirst Overload
Alternet.Common Namespace


ISortList(T).FindFirst Method (T, Int32, IComparer(T))

ISortListTFindFirst Method (T, Int32, IComparerT)
When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindFirst(
    T obj,
    out int index,
    IComparer<T> comparer
)
Function FindFirst (
    obj As T,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer(Of T)
) As Boolean
bool FindFirst(
    T obj,
    [OutAttribute] int% index,
    IComparer<T>^ comparer
)
abstract FindFirst :
        obj : 'T *
        index : int byref *
        comparer : IComparer<'T> -> bool

Parameters

obj
Type: T
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.Collections.GenericIComparerT
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.
See Also

Reference

ISortListT Interface
FindFirst Overload
Alternet.Common Namespace


ISortList(T).FindLast Method

ISortListTFindLast Method
Overload List
 | Name | Description
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria.
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria.
Top
See Also

Reference

ISortListT Interface
Alternet.Common Namespace


ISortList(T).FindLast Method (Object, Int32, IComparer)

ISortListTFindLast Method (Object, Int32, IComparer)
When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindLast(
    Object obj,
    out int index,
    IComparer comparer
)
Function FindLast (
    obj As Object,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer
) As Boolean
bool FindLast(
    Object^ obj,
    [OutAttribute] int% index,
    IComparer^ comparer
)
abstract FindLast :
        obj : Object *
        index : int byref *
        comparer : IComparer -> bool

Parameters

obj
Type: SystemObject
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.CollectionsIComparer
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.
See Also

Reference

ISortListT Interface
FindLast Overload
Alternet.Common Namespace


ISortList(T).FindLast Method (T, Int32, IComparer(T))

ISortListTFindLast Method (T, Int32, IComparerT)
When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindLast(
    T obj,
    out int index,
    IComparer<T> comparer
)
Function FindLast (
    obj As T,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer(Of T)
) As Boolean
bool FindLast(
    T obj,
    [OutAttribute] int% index,
    IComparer<T>^ comparer
)
abstract FindLast :
        obj : 'T *
        index : int byref *
        comparer : IComparer<'T> -> bool

Parameters

obj
Type: T
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.Collections.GenericIComparerT
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.
See Also

Reference

ISortListT Interface
FindLast Overload
Alternet.Common Namespace


ISortList(T).NeedSort Method

ISortListTNeedSort Method
When implemented by a class, determines if the list needs sorting based on given criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedSort(
    IComparer<T> comparer
)
Function NeedSort (
    comparer As IComparer(Of T)
) As Boolean
bool NeedSort(
    IComparer<T>^ comparer
)
abstract NeedSort :
        comparer : IComparer<'T> -> bool

Parameters

comparer
Type: System.Collections.GenericIComparerT
Comparer object to perform comparison between items in the list.

Return Value

Type: Boolean
True if list has to be sorted; otherwise false.
See Also

Reference

ISortListT Interface
Alternet.Common Namespace


ISortList(T).Sort Method

ISortListTSort Method
When implemented by a class, sorts the elements in the entire sort list using the specified comparer.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Sort(
    IComparer<T> comparer
)
Sub Sort (
    comparer As IComparer(Of T)
)
void Sort(
    IComparer<T>^ comparer
)
abstract Sort :
        comparer : IComparer<'T> -> unit

Parameters

comparer
Type: System.Collections.GenericIComparerT
The IComparer implementation to use when comparing elements.
See Also

Reference

ISortListT Interface
Alternet.Common Namespace


ISortList(T) Properties

ISortListT Properties

The ISortListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionT .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionT .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListT .)
Top
See Also

Reference

ISortListT Interface
Alternet.Common Namespace


ISortRange Interface

ISortRange Interface
Represents an container for a collection of IRangeobjects.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISortRange : IRange,
    ICloneable
Public Interface ISortRange
    Inherits IRange, ICloneable
public interface class ISortRange : IRange,
    ICloneable
type ISortRange =
    interface
        interface IRange
        interface ICloneable
    end

The ISortRange type exposes the following members.

Methods
 | Name | Description
Public method | Add | When implemented by a class, adds specific ISortRange to range list.
Public method | Assign | Copies contents from another IRange object. (Inherited from IRange.)
Public method | BlockDeleting | When implemented by a class, removes all ranges from specified region.
Public method | Clear | When implemented by a class, clears IRange collection.
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | Contains | When implemented by a class, indicates whether the range container contains a specific IRange entry.
Public method | GetRanges | When implemented by a class, fills list specified by Ranges parameter with this ISortRange.
Public method | PositionChanged | When implemented by a class, updates specified position by DeltaX and DeltaY values for any ranges in the collection.
Top
Properties
 | Name | Description
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area. (Inherited from IRange.)
Public property | Index | When implemented by a class, represents index of this ISortRange within the top level ranges collection.
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size. (Inherited from IRange.)
Public property | Range | When implemented by a class, represents current IRange object in the ranges list.
Public property | Ranges | When implemented by a class, represents collection of IRange objects stored in this range list.
Public property | Size | When implemented by a class, gets or sets size of IRange area. (Inherited from IRange.)
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area. (Inherited from IRange.)
Top
See Also

Reference

Alternet.Common Namespace


ISortRange Methods

ISortRange Methods

The ISortRange type exposes the following members.

Methods
 | Name | Description
Public method | Add | When implemented by a class, adds specific ISortRange to range list.
Public method | Assign | Copies contents from another IRange object. (Inherited from IRange.)
Public method | BlockDeleting | When implemented by a class, removes all ranges from specified region.
Public method | Clear | When implemented by a class, clears IRange collection.
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | Contains | When implemented by a class, indicates whether the range container contains a specific IRange entry.
Public method | GetRanges | When implemented by a class, fills list specified by Ranges parameter with this ISortRange.
Public method | PositionChanged | When implemented by a class, updates specified position by DeltaX and DeltaY values for any ranges in the collection.
Top
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange.Add Method

ISortRangeAdd Method
When implemented by a class, adds specific ISortRange to range list.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Add(
    ISortRange range
)
Function Add (
    range As ISortRange
) As Integer
int Add(
    ISortRange^ range
)
abstract Add :
        range : ISortRange -> int

Parameters

range
Type: Alternet.CommonISortRange
ISortRange to add.

Return Value

Type: Int32
The position into which the new range was added.
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange.BlockDeleting Method

ISortRangeBlockDeleting Method
When implemented by a class, removes all ranges from specified region.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BlockDeleting(
    Rectangle rect,
    IRangeList list,
    IComparer<IRange> comparer
)
Function BlockDeleting (
    rect As Rectangle,
    list As IRangeList,
    comparer As IComparer(Of IRange)
) As Boolean
bool BlockDeleting(
    Rectangle rect,
    IRangeList^ list,
    IComparer<IRange^>^ comparer
)
abstract BlockDeleting :
        rect : Rectangle *
        list : IRangeList *
        comparer : IComparer<IRange> -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to remove ranges from.
list
Type: Alternet.CommonIRangeList
List to update.
comparer
Type: System.Collections.GenericIComparerIRange
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange.Clear Method

ISortRangeClear Method
When implemented by a class, clears IRange collection.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange.Contains Method

ISortRangeContains Method
When implemented by a class, indicates whether the range container contains a specific IRange entry.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Contains(
    IRange range
)
Function Contains (
    range As IRange
) As Boolean
bool Contains(
    IRange^ range
)
abstract Contains :
        range : IRange -> bool

Parameters

range
Type: Alternet.CommonIRange
The IRange to locate in the range list.

Return Value

Type: Boolean
True if IRange entry is found; otherwise false.
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange.GetRanges Method

ISortRangeGetRanges Method
When implemented by a class, fills list specified by Ranges parameter with this ISortRange.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetRanges(
    IList<IRange> ranges
)
Sub GetRanges (
    ranges As IList(Of IRange)
)
void GetRanges(
    IList<IRange^>^ ranges
)
abstract GetRanges :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange.PositionChanged Method

ISortRangePositionChanged Method
When implemented by a class, updates specified position by DeltaX and DeltaY values for any ranges in the collection.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IRangeList list,
    IComparer<IRange> comparer
)
Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    list As IRangeList,
    comparer As IComparer(Of IRange)
) As Boolean
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IRangeList^ list,
    IComparer<IRange^>^ comparer
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        list : IRangeList *
        comparer : IComparer<IRange> -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
list
Type: Alternet.CommonIRangeList
List to update.
comparer
Type: System.Collections.GenericIComparerIRange
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange Properties

ISortRange Properties

The ISortRange type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area. (Inherited from IRange.)
Public property | Index | When implemented by a class, represents index of this ISortRange within the top level ranges collection.
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size. (Inherited from IRange.)
Public property | Range | When implemented by a class, represents current IRange object in the ranges list.
Public property | Ranges | When implemented by a class, represents collection of IRange objects stored in this range list.
Public property | Size | When implemented by a class, gets or sets size of IRange area. (Inherited from IRange.)
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area. (Inherited from IRange.)
Top
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange.Index Property

ISortRangeIndex Property
When implemented by a class, represents index of this ISortRange within the top level ranges collection.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange.Range Property

ISortRangeRange Property
When implemented by a class, represents current IRange object in the ranges list.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange Range { get; }
ReadOnly Property Range As IRange
    Get
property IRange^ Range {
    IRange^ get ();
}
abstract Range : IRange with get

Property Value

Type: IRange
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


ISortRange.Ranges Property

ISortRangeRanges Property
When implemented by a class, represents collection of IRange objects stored in this range list.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISortList<IRange> Ranges { get; }
ReadOnly Property Ranges As ISortList(Of IRange)
    Get
property ISortList<IRange^>^ Ranges {
    ISortList<IRange^>^ get ();
}
abstract Ranges : ISortList<IRange> with get

Property Value

Type: ISortList IRange
See Also

Reference

ISortRange Interface
Alternet.Common Namespace


IUpdate Interface

IUpdate Interface
Represents properties and methods of updateable objects.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUpdate
Public Interface IUpdate
public interface class IUpdate
type IUpdate =  interface end

The IUpdate type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method.
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Update | When implemented by a class, updates an object state.
Top
Properties
 | Name | Description
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

Alternet.Common Namespace


IUpdate Methods

IUpdate Methods

The IUpdate type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method.
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Update | When implemented by a class, updates an object state.
Top
See Also

Reference

IUpdate Interface
Alternet.Common Namespace


IUpdate.BeginUpdate Method

IUpdateBeginUpdate Method
When implemented by a class, prevents object state updating until calling EndUpdate method.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int BeginUpdate()
Function BeginUpdate As Integer
int BeginUpdate()
abstract BeginUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.
See Also

Reference

IUpdate Interface
Alternet.Common Namespace


IUpdate.DisableUpdate Method

IUpdateDisableUpdate Method
When implemented by a class, prevents object state updating until calling EnableUpdate method.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int DisableUpdate()
Function DisableUpdate As Integer
int DisableUpdate()
abstract DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.
See Also

Reference

IUpdate Interface
Alternet.Common Namespace


IUpdate.EnableUpdate Method

IUpdateEnableUpdate Method
When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int EnableUpdate()
Function EnableUpdate As Integer
int EnableUpdate()
abstract EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.
See Also

Reference

IUpdate Interface
Alternet.Common Namespace


IUpdate.EndUpdate Method

IUpdateEndUpdate Method
When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int EndUpdate()
Function EndUpdate As Integer
int EndUpdate()
abstract EndUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.
See Also

Reference

IUpdate Interface
Alternet.Common Namespace


IUpdate.Update Method

IUpdateUpdate Method
When implemented by a class, updates an object state.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Update()
Sub Update
void Update()
abstract Update : unit -> unit
See Also

Reference

IUpdate Interface
Alternet.Common Namespace


IUpdate Properties

IUpdate Properties

The IUpdate type exposes the following members.

Properties
 | Name | Description
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

IUpdate Interface
Alternet.Common Namespace


IUpdate.UpdateCount Property

IUpdateUpdateCount Property
When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int UpdateCount { get; }
ReadOnly Property UpdateCount As Integer
    Get
property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get

Property Value

Type: Int32
See Also

Reference

IUpdate Interface
Alternet.Common Namespace


JobObjectInfoType Enumeration

JobObjectInfoType Enumeration

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum JobObjectInfoType
Public Enumeration JobObjectInfoType
public enum class JobObjectInfoType
type JobObjectInfoType
Members
Member name | Value | Description
AssociateCompletionPortInformation | 7 |
BasicLimitInformation | 2 |
BasicUIRestrictions | 4 |
EndOfJobTimeInformation | 6 |
ExtendedLimitInformation | 9 |
SecurityLimitInformation | 5 |
GroupInformation | 11 |
See Also

Reference

Alternet.Common Namespace


JOBOBJECTLIMIT Enumeration

JOBOBJECTLIMIT Enumeration

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum JOBOBJECTLIMIT
<FlagsAttribute>
Public Enumeration JOBOBJECTLIMIT
[FlagsAttribute]
public enum class JOBOBJECTLIMIT
[<FlagsAttribute>]
type JOBOBJECTLIMIT
Members
Member name | Value | Description
JOB_OBJECT_LIMIT_KILL_ON_JOB_CLOSE | 8192 |
See Also

Reference

Alternet.Common Namespace


KeysExtensions Class

KeysExtensions Class
Contains extension methods for Keys object.
Inheritance Hierarchy
SystemObject
Alternet.CommonKeysExtensions

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class KeysExtensions
<ExtensionAttribute>
Public NotInheritable Class KeysExtensions
[ExtensionAttribute]
public ref class KeysExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type KeysExtensions =  class end

The KeysExtensions type exposes the following members.

Methods
Name | Description
IsNavigationOrSystemKey | Determines if key is a navigation or system key
Top
See Also

Reference

Alternet.Common Namespace


KeysExtensions Methods

KeysExtensions Methods

The KeysExtensions type exposes the following members.

Methods
Name | Description
IsNavigationOrSystemKey | Determines if key is a navigation or system key
Top
See Also

Reference

KeysExtensions Class
Alternet.Common Namespace


KeysExtensions.IsNavigationOrSystemKey Method

KeysExtensionsIsNavigationOrSystemKey Method
Determines if key is a navigation or system key

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNavigationOrSystemKey(
    this Keys key
)
<ExtensionAttribute>
Public Shared Function IsNavigationOrSystemKey (
    key As Keys
) As Boolean
public:
[ExtensionAttribute]
static bool IsNavigationOrSystemKey(
    Keys key
)
[<ExtensionAttribute>]
static member IsNavigationOrSystemKey :
        key : Keys -> bool

Parameters

key
Type: System.Windows.FormsKeys

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Keys. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

KeysExtensions Class
Alternet.Common Namespace


ListComparer Class

ListComparer Class
Inheritance Hierarchy
SystemObject
Alternet.CommonListComparer

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ListComparer
Public Class ListComparer
public ref class ListComparer
type ListComparer =  class end

The ListComparer type exposes the following members.

Constructors
 | Name | Description
Public method | ListComparer | Initializes a new instance of the ListComparer class
Top
Methods
 | Name | Description
 | CompareT |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common Namespace


ListComparer Constructor

ListComparer Constructor
Initializes a new instance of the ListComparer class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListComparer()
Public Sub New
public:
ListComparer()
new : unit -> ListComparer
See Also

Reference

ListComparer Class
Alternet.Common Namespace


ListComparer Methods

ListComparer Methods

The ListComparer type exposes the following members.

Methods
 | Name | Description
 | CompareT |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ListComparer Class
Alternet.Common Namespace


ListComparer.Compare(T) Method

ListComparerCompareT Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int Compare<T>(
    IList<T> a,
    IList<T> b,
    IComparer<T> comparer
)

Public Shared Function Compare(Of T) (
    a As IList(Of T),
    b As IList(Of T),
    comparer As IComparer(Of T)
) As Integer
public:
generic<typename T>
static int Compare(
    IList<T>^ a,
    IList<T>^ b,
    IComparer<T>^ comparer
)
static member Compare :
        a : IList<'T> *
        b : IList<'T> *
        comparer : IComparer<'T> -> int

Parameters

a
Type: System.Collections.GenericIListT
b
Type: System.Collections.GenericIListT
comparer
Type: System.Collections.GenericIComparerT

Type Parameters

T

Return Value

Type: Int32
See Also

Reference

ListComparer Class
Alternet.Common Namespace


MathUtilities Class

MathUtilities Class
Contains extended functionality for mathematic operations.
Inheritance Hierarchy
SystemObject
Alternet.CommonMathUtilities

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MathUtilities
<ExtensionAttribute>
Public NotInheritable Class MathUtilities
[ExtensionAttribute]
public ref class MathUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type MathUtilities =  class end

The MathUtilities type exposes the following members.

Methods
Name | Description
Clamp(Double, Double, Double) | Clamps given value between specified dimensions.
Clamp(Int32, Int32, Int32) | Clamps given value between specified dimensions.
IndexOfMax | Searches for the largest value and returns the index of its occurrence in a one-dimensional array.
IndexOfMin | Searches for the smallest value and returns the index of its occurrence in a one-dimensional array.
IsCloseTo | Indicates whether two given values are close to each other.
Max(Double) | Returns the largest of double values in a one-dimensional array.
Max(Int32) | Returns the largest of integer values in a one-dimensional array.
Min(Double) | Returns the smaller of double values in a one-dimensional array.
Min(Int32) | Returns the smaller of integer values in a one-dimensional array.
Wrap | Wraps given value into specified interval.
Top
See Also

Reference

Alternet.Common Namespace


MathUtilities Methods

MathUtilities Methods

The MathUtilities type exposes the following members.

Methods
Name | Description
Clamp(Double, Double, Double) | Clamps given value between specified dimensions.
Clamp(Int32, Int32, Int32) | Clamps given value between specified dimensions.
IndexOfMax | Searches for the largest value and returns the index of its occurrence in a one-dimensional array.
IndexOfMin | Searches for the smallest value and returns the index of its occurrence in a one-dimensional array.
IsCloseTo | Indicates whether two given values are close to each other.
Max(Double) | Returns the largest of double values in a one-dimensional array.
Max(Int32) | Returns the largest of integer values in a one-dimensional array.
Min(Double) | Returns the smaller of double values in a one-dimensional array.
Min(Int32) | Returns the smaller of integer values in a one-dimensional array.
Wrap | Wraps given value into specified interval.
Top
See Also

Reference

MathUtilities Class
Alternet.Common Namespace


MathUtilities.Clamp Method

MathUtilitiesClamp Method
Overload List
Name | Description
Clamp(Double, Double, Double) | Clamps given value between specified dimensions.
Clamp(Int32, Int32, Int32) | Clamps given value between specified dimensions.
Top
See Also

Reference

MathUtilities Class
Alternet.Common Namespace


MathUtilities.Clamp Method (Double, Double, Double)

MathUtilitiesClamp Method (Double, Double, Double)
Clamps given value between specified dimensions.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double Clamp(
    double value,
    double min,
    double max
)
Public Shared Function Clamp (
    value As Double,
    min As Double,
    max As Double
) As Double
public:
static double Clamp(
    double value,
    double min,
    double max
)
static member Clamp :
        value : float *
        min : float *
        max : float -> float

Parameters

value
Type: SystemDouble
Value to probe.
min
Type: SystemDouble
Minimum possible value.
max
Type: SystemDouble
Maximum possible value.

Return Value

Type: Double
Double value that does not exceed specified dimensions.
See Also

Reference

MathUtilities Class
Clamp Overload
Alternet.Common Namespace


MathUtilities.Clamp Method (Int32, Int32, Int32)

MathUtilitiesClamp Method (Int32, Int32, Int32)
Clamps given value between specified dimensions.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int Clamp(
    int value,
    int min,
    int max
)
Public Shared Function Clamp (
    value As Integer,
    min As Integer,
    max As Integer
) As Integer
public:
static int Clamp(
    int value,
    int min,
    int max
)
static member Clamp :
        value : int *
        min : int *
        max : int -> int

Parameters

value
Type: SystemInt32
Value to probe.
min
Type: SystemInt32
Minimum possible value.
max
Type: SystemInt32
Maximum possible value.

Return Value

Type: Int32
Integer value that does not exceed specified dimensions.
See Also

Reference

MathUtilities Class
Clamp Overload
Alternet.Common Namespace


MathUtilities.IndexOfMax Method

MathUtilitiesIndexOfMax Method
Searches for the largest value and returns the index of its occurrence in a one-dimensional array.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int IndexOfMax(
    params double[] values
)
Public Shared Function IndexOfMax (
    ParamArray values As Double()
) As Integer
public:
static int IndexOfMax(
    ... array<double>^ values
)
static member IndexOfMax :
        values : float[] -> int

Parameters

values
Type: SystemDouble
The one-dimensional array to search.

Return Value

Type: Int32
The index of the largest value the in array, if found; otherwise -1.
See Also

Reference

MathUtilities Class
Alternet.Common Namespace


MathUtilities.IndexOfMin Method

MathUtilitiesIndexOfMin Method
Searches for the smallest value and returns the index of its occurrence in a one-dimensional array.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int IndexOfMin(
    params double[] values
)
Public Shared Function IndexOfMin (
    ParamArray values As Double()
) As Integer
public:
static int IndexOfMin(
    ... array<double>^ values
)
static member IndexOfMin :
        values : float[] -> int

Parameters

values
Type: SystemDouble
The one-dimensional array to search.

Return Value

Type: Int32
The index of the smallest value the in array, if found; otherwise -1.
See Also

Reference

MathUtilities Class
Alternet.Common Namespace


MathUtilities.IsCloseTo Method

MathUtilitiesIsCloseTo Method
Indicates whether two given values are close to each other.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsCloseTo(
    this double a,
    double b,
    double epsilon = 1E-05
)
<ExtensionAttribute>
Public Shared Function IsCloseTo (
    a As Double,
    b As Double,
    Optional epsilon As Double = 1E-05
) As Boolean
public:
[ExtensionAttribute]
static bool IsCloseTo(
    double a,
    double b,
    double epsilon = 1E-05
)
[<ExtensionAttribute>]
static member IsCloseTo :
        a : float *
        b : float *
        ?epsilon : float
(* Defaults:
        let _epsilon = defaultArg epsilon 1E-05
*)
-> bool

Parameters

a
Type: SystemDouble
First value to probe.
b
Type: SystemDouble
Second value to probe.
epsilon (Optional)
Type: SystemDouble
Value that limits difference.

Return Value

Type: Boolean
True if difference between two values less then epsilon; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Double. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathUtilities Class
Alternet.Common Namespace


MathUtilities.Max Method

MathUtilitiesMax Method
Overload List
Name | Description
Max(Double) | Returns the largest of double values in a one-dimensional array.
Max(Int32) | Returns the largest of integer values in a one-dimensional array.
Top
See Also

Reference

MathUtilities Class
Alternet.Common Namespace


MathUtilities.Max Method (Double[])

MathUtilitiesMax Method (Double)
Returns the largest of double values in a one-dimensional array.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double Max(
    params double[] values
)
Public Shared Function Max (
    ParamArray values As Double()
) As Double
public:
static double Max(
    ... array<double>^ values
)
static member Max :
        values : float[] -> float

Parameters

values
Type: SystemDouble
The one-dimensional array to compare.

Return Value

Type: Double
The largest double value.
See Also

Reference

MathUtilities Class
Max Overload
Alternet.Common Namespace


MathUtilities.Max Method (Int32[])

MathUtilitiesMax Method (Int32)
Returns the largest of integer values in a one-dimensional array.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int Max(
    params int[] values
)
Public Shared Function Max (
    ParamArray values As Integer()
) As Integer
public:
static int Max(
    ... array<int>^ values
)
static member Max :
        values : int[] -> int

Parameters

values
Type: SystemInt32
The one-dimensional array to compare.

Return Value

Type: Int32
The largest integer value.
See Also

Reference

MathUtilities Class
Max Overload
Alternet.Common Namespace


MathUtilities.Min Method

MathUtilitiesMin Method
Overload List
Name | Description
Min(Double) | Returns the smaller of double values in a one-dimensional array.
Min(Int32) | Returns the smaller of integer values in a one-dimensional array.
Top
See Also

Reference

MathUtilities Class
Alternet.Common Namespace


MathUtilities.Min Method (Double[])

MathUtilitiesMin Method (Double)
Returns the smaller of double values in a one-dimensional array.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double Min(
    params double[] values
)
Public Shared Function Min (
    ParamArray values As Double()
) As Double
public:
static double Min(
    ... array<double>^ values
)
static member Min :
        values : float[] -> float

Parameters

values
Type: SystemDouble
The one-dimensional array to compare.

Return Value

Type: Double
The smallest double value.
See Also

Reference

MathUtilities Class
Min Overload
Alternet.Common Namespace


MathUtilities.Min Method (Int32[])

MathUtilitiesMin Method (Int32)
Returns the smaller of integer values in a one-dimensional array.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int Min(
    params int[] values
)
Public Shared Function Min (
    ParamArray values As Integer()
) As Integer
public:
static int Min(
    ... array<int>^ values
)
static member Min :
        values : int[] -> int

Parameters

values
Type: SystemInt32
The one-dimensional array to compare.

Return Value

Type: Int32
The smallest integer value.
See Also

Reference

MathUtilities Class
Min Overload
Alternet.Common Namespace


MathUtilities.Wrap Method

MathUtilitiesWrap Method
Wraps given value into specified interval.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int Wrap(
    int value,
    int min,
    int max
)
Public Shared Function Wrap (
    value As Integer,
    min As Integer,
    max As Integer
) As Integer
public:
static int Wrap(
    int value,
    int min,
    int max
)
static member Wrap :
        value : int *
        min : int *
        max : int -> int

Parameters

value
Type: SystemInt32
Value to probe.
min
Type: SystemInt32
Minimum possible value.
max
Type: SystemInt32
Maximum possible value.

Return Value

Type: Int32
Maximum if value less then minimum, minimum if value more then maximum; otherwise original value.
See Also

Reference

MathUtilities Class
Alternet.Common Namespace


MouseUtilities Class

MouseUtilities Class
An utility class to handle mouse events.
Inheritance Hierarchy
SystemObject
Alternet.CommonMouseUtilities

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MouseUtilities
Public NotInheritable Class MouseUtilities
public ref class MouseUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MouseUtilities =  class end

The MouseUtilities type exposes the following members.

Methods
Name | Description
SimulateMouseLeftButtonClick | Simulates mouse left button click.
Top
See Also

Reference

Alternet.Common Namespace


MouseUtilities Methods

MouseUtilities Methods

The MouseUtilities type exposes the following members.

Methods
Name | Description
SimulateMouseLeftButtonClick | Simulates mouse left button click.
Top
See Also

Reference

MouseUtilities Class
Alternet.Common Namespace


MouseUtilities.SimulateMouseLeftButtonClick Method

MouseUtilitiesSimulateMouseLeftButtonClick Method
Simulates mouse left button click.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SimulateMouseLeftButtonClick()
Public Shared Sub SimulateMouseLeftButtonClick
public:
static void SimulateMouseLeftButtonClick()
static member SimulateMouseLeftButtonClick : unit -> unit
See Also

Reference

MouseUtilities Class
Alternet.Common Namespace


OSUtils Class

OSUtils Class
Represents native Win32 API methods.
Inheritance Hierarchy
SystemObject
Alternet.CommonOSUtils

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OSUtils
Public Class OSUtils
public ref class OSUtils
type OSUtils =  class end

The OSUtils type exposes the following members.

Constructors
 | Name | Description
Public method | OSUtils | Initializes a new instance of the OSUtils class
Top
Methods
 | Name | Description
 | AdjustNonClientAreaSize |
 | Beep | Generates simple tones on the speaker.
 | CallNextHook | Passes the hook information to the next hook procedure in the current hook chain. A hook procedure can call this function either before or after processing the hook information.
 | CreateCaret | Creates a new shape for the system caret and assigns ownership of the caret to the specified window.
 | DeleteObject | The DeleteObject function deletes a logical pen, brush, font, bitmap, region, or palette, freeing all system resources associated with the object. After the object is deleted, the specified handle is no longer valid.
 | DestroyCaret | Destroys the caret's current shape, frees the caret from the window, and removes the caret from the screen.
 | DisableCloseButton |
 | EnumChildWindows | The EnumChildWindows function enumerates the child windows that belong to the specified parent window by passing the handle of each child window, in turn, to an application-defined callback function. EnumChildWindows continues until the last child window is enumerated or the callback function returns false.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExcludeClipRect | The ExcludeClipRect function creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
 | GetCharFromKey |
 | GetClassName | The GetClassName function retrieves the name of the class to which the specified window belongs.
 | GetDoubleClickTime | Retrieves the current double-click time for the mouse.
 | GetForegroundWindow |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMouseHookHandle | Get structure associated with mouse hook.
 | GetScreenCaps | Retrieves size in pixels per logical inch of entire screen.
 | GetScrollPos | Retrieves the current position of the scroll box (thumb) in the specified scroll bar.
 | GetScrollSize(Boolean) | Retrieves dimension of the arrow bitmap of a scroll bar, in pixels.
 | GetScrollSize(IntPtr, Boolean, Boolean) | Retrieves the page size of the scroll box (thumb) in the specified scroll bar.
 | GetScrollType | Converts given code to the type of scroll event action.
 | GetText | Retrieves text that corresponds to a window.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWindowDC | Retrieves the device context (DC) for the entire window.
 | HideMinimizeAndMaximizeButtons |
 | HiWord | Retrieves the high-order word from the given value.
 | ImeComposition | Retrieves information about the composition.
 | ImmSetCompositionFont | Sets the logical font to use to display characters in the composition window.
 | ImmSetCompositionWindow | Sets the position of the composition window.
 | InitCommonControls | Registers and initializes the common control window classes.
 | InitializeFlatSB | Initializes flat scroll bars for a particular window.
 | IsFontMonospace | Determines if font family represents mono-space font;
 | IsMouseMsg | Indicates whether specified message is mouse message.
 | LoWord | Retrieves the low-order word from the specified value.
 | MessageBeep | Plays default waveform sound.
 | PostMessage | Places a message in the message queue associated with the thread that created the specified window and returns without waiting for the thread to process the message.
 | ReleaseDC | Releases a device context (DC), freeing it for use by other applications.
 | ReleaseHook | Removes a hook procedure installed in a hook chain.
 | RemoveIcon |
 | ScrollWindow | Scrolls the contents of the specified window's client area.
 | SendMessage | The SendMessage function sends the specified message to a window or windows. The function calls the window procedure for the specified window and does not return until the window procedure has processed the message.
 | SetCaretPos | Moves the caret to the specified coordinates.
 | SetCursor | The SetCursor function establishes the cursor shape.
 | SetForegroundWindow |
 | SetMouseHook | Installs hook procedure that monitors mouse messages into a hook chain.
 | SetScrollBar | Sets the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (thumb).
 | SetScrollPos | Sets the position of the scroll box (thumb) in the specified scroll bar.
 | SetText | Sets the text of a window.
 | SetWndProcHook | Installs hook procedure that monitors messages before the system sends them to the destination window procedure into a hook chain.
 | ShowCaret | Makes the caret visible on the screen at the caret's current position.
 | ShowWindowTopMost | Places the window above all non-topmost windows.
 | Sleep | Suspends the execution of the current thread for a specified interval.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UninitializeFlatSB | Uninitializes flat scroll bars for a particular window.
 | UpdateCompositionWindow | Updates position information for a composition window.
 | UpdateNonClientArea |
Top
Fields
Name | Description
BorderFlags_Adjust |
BorderFlags_Flat |
BorderFlags_Mono |
BorderFlags_Soft |
GCS_RESULTSTR |
IMC_GETCOMPOSITIONWINDOW |
IMN_SETCOMPOSITIONWINDOW |
IMN_SETOPENSTATUS |
Message_CanUndo |
Message_CAPTURECHANGED |
Message_Char |
Message_Clear |
Message_CloseDropped |
Message_ContextMenu |
Message_Copy |
Message_Cut |
Message_HScroll |
Message_IME_COMPOSITION |
Message_IME_CONTROL |
Message_IME_NOTIFY |
Message_IME_STARTCOMPOSITION |
Message_InitDialog |
Message_KeyDown |
Message_KeyUp |
Message_LButtonDown |
Message_LButtonUp |
Message_MouseMove |
Message_NCActivate |
Message_NCCalcsize |
Message_NCPaint |
Message_Paste |
Message_SetCursor |
Message_SysKeyDown |
Message_THEMECHANGED |
Message_Undo |
Message_VScroll |
WindowStyle_Border |
WindowStyle_ClientEdge |
Top
See Also

Reference

Alternet.Common Namespace


OSUtils Constructor

OSUtils Constructor
Initializes a new instance of the OSUtils class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public OSUtils()
Public Sub New
public:
OSUtils()
new : unit -> OSUtils
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils Fields

OSUtils Fields

The OSUtils type exposes the following members.

Fields
Name | Description
BorderFlags_Adjust |
BorderFlags_Flat |
BorderFlags_Mono |
BorderFlags_Soft |
GCS_RESULTSTR |
IMC_GETCOMPOSITIONWINDOW |
IMN_SETCOMPOSITIONWINDOW |
IMN_SETOPENSTATUS |
Message_CanUndo |
Message_CAPTURECHANGED |
Message_Char |
Message_Clear |
Message_CloseDropped |
Message_ContextMenu |
Message_Copy |
Message_Cut |
Message_HScroll |
Message_IME_COMPOSITION |
Message_IME_CONTROL |
Message_IME_NOTIFY |
Message_IME_STARTCOMPOSITION |
Message_InitDialog |
Message_KeyDown |
Message_KeyUp |
Message_LButtonDown |
Message_LButtonUp |
Message_MouseMove |
Message_NCActivate |
Message_NCCalcsize |
Message_NCPaint |
Message_Paste |
Message_SetCursor |
Message_SysKeyDown |
Message_THEMECHANGED |
Message_Undo |
Message_VScroll |
WindowStyle_Border |
WindowStyle_ClientEdge |
Top
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.BorderFlags_Adjust Field

OSUtilsBorderFlags_Adjust Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int BorderFlags_Adjust
Public Const BorderFlags_Adjust As Integer
public:
literal int BorderFlags_Adjust
static val mutable BorderFlags_Adjust: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.BorderFlags_Flat Field

OSUtilsBorderFlags_Flat Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int BorderFlags_Flat
Public Const BorderFlags_Flat As Integer
public:
literal int BorderFlags_Flat
static val mutable BorderFlags_Flat: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.BorderFlags_Mono Field

OSUtilsBorderFlags_Mono Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int BorderFlags_Mono
Public Const BorderFlags_Mono As Integer
public:
literal int BorderFlags_Mono
static val mutable BorderFlags_Mono: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.BorderFlags_Soft Field

OSUtilsBorderFlags_Soft Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int BorderFlags_Soft
Public Const BorderFlags_Soft As Integer
public:
literal int BorderFlags_Soft
static val mutable BorderFlags_Soft: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GCS_RESULTSTR Field

OSUtilsGCS_RESULTSTR Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int GCS_RESULTSTR
Public Const GCS_RESULTSTR As Integer
public:
literal int GCS_RESULTSTR
static val mutable GCS_RESULTSTR: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.IMC_GETCOMPOSITIONWINDOW Field

OSUtilsIMC_GETCOMPOSITIONWINDOW Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int IMC_GETCOMPOSITIONWINDOW
Public Const IMC_GETCOMPOSITIONWINDOW As Integer
public:
literal int IMC_GETCOMPOSITIONWINDOW
static val mutable IMC_GETCOMPOSITIONWINDOW: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.IMN_SETCOMPOSITIONWINDOW Field

OSUtilsIMN_SETCOMPOSITIONWINDOW Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int IMN_SETCOMPOSITIONWINDOW
Public Const IMN_SETCOMPOSITIONWINDOW As Integer
public:
literal int IMN_SETCOMPOSITIONWINDOW
static val mutable IMN_SETCOMPOSITIONWINDOW: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.IMN_SETOPENSTATUS Field

OSUtilsIMN_SETOPENSTATUS Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int IMN_SETOPENSTATUS
Public Const IMN_SETOPENSTATUS As Integer
public:
literal int IMN_SETOPENSTATUS
static val mutable IMN_SETOPENSTATUS: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_CanUndo Field

OSUtilsMessage_CanUndo Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_CanUndo
Public Const Message_CanUndo As Integer
public:
literal int Message_CanUndo
static val mutable Message_CanUndo: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_CAPTURECHANGED Field

OSUtilsMessage_CAPTURECHANGED Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_CAPTURECHANGED
Public Const Message_CAPTURECHANGED As Integer
public:
literal int Message_CAPTURECHANGED
static val mutable Message_CAPTURECHANGED: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_Char Field

OSUtilsMessage_Char Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_Char
Public Const Message_Char As Integer
public:
literal int Message_Char
static val mutable Message_Char: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_Clear Field

OSUtilsMessage_Clear Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_Clear
Public Const Message_Clear As Integer
public:
literal int Message_Clear
static val mutable Message_Clear: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_CloseDropped Field

OSUtilsMessage_CloseDropped Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_CloseDropped
Public Const Message_CloseDropped As Integer
public:
literal int Message_CloseDropped
static val mutable Message_CloseDropped: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_ContextMenu Field

OSUtilsMessage_ContextMenu Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_ContextMenu
Public Const Message_ContextMenu As Integer
public:
literal int Message_ContextMenu
static val mutable Message_ContextMenu: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_Copy Field

OSUtilsMessage_Copy Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_Copy
Public Const Message_Copy As Integer
public:
literal int Message_Copy
static val mutable Message_Copy: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_Cut Field

OSUtilsMessage_Cut Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_Cut
Public Const Message_Cut As Integer
public:
literal int Message_Cut
static val mutable Message_Cut: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_HScroll Field

OSUtilsMessage_HScroll Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_HScroll
Public Const Message_HScroll As Integer
public:
literal int Message_HScroll
static val mutable Message_HScroll: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_IME_COMPOSITION Field

OSUtilsMessage_IME_COMPOSITION Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_IME_COMPOSITION
Public Const Message_IME_COMPOSITION As Integer
public:
literal int Message_IME_COMPOSITION
static val mutable Message_IME_COMPOSITION: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_IME_CONTROL Field

OSUtilsMessage_IME_CONTROL Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_IME_CONTROL
Public Const Message_IME_CONTROL As Integer
public:
literal int Message_IME_CONTROL
static val mutable Message_IME_CONTROL: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_IME_NOTIFY Field

OSUtilsMessage_IME_NOTIFY Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_IME_NOTIFY
Public Const Message_IME_NOTIFY As Integer
public:
literal int Message_IME_NOTIFY
static val mutable Message_IME_NOTIFY: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_IME_STARTCOMPOSITION Field

OSUtilsMessage_IME_STARTCOMPOSITION Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_IME_STARTCOMPOSITION
Public Const Message_IME_STARTCOMPOSITION As Integer
public:
literal int Message_IME_STARTCOMPOSITION
static val mutable Message_IME_STARTCOMPOSITION: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_InitDialog Field

OSUtilsMessage_InitDialog Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_InitDialog
Public Const Message_InitDialog As Integer
public:
literal int Message_InitDialog
static val mutable Message_InitDialog: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_KeyDown Field

OSUtilsMessage_KeyDown Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_KeyDown
Public Const Message_KeyDown As Integer
public:
literal int Message_KeyDown
static val mutable Message_KeyDown: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_KeyUp Field

OSUtilsMessage_KeyUp Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_KeyUp
Public Const Message_KeyUp As Integer
public:
literal int Message_KeyUp
static val mutable Message_KeyUp: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_LButtonDown Field

OSUtilsMessage_LButtonDown Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_LButtonDown
Public Const Message_LButtonDown As Integer
public:
literal int Message_LButtonDown
static val mutable Message_LButtonDown: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_LButtonUp Field

OSUtilsMessage_LButtonUp Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_LButtonUp
Public Const Message_LButtonUp As Integer
public:
literal int Message_LButtonUp
static val mutable Message_LButtonUp: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_MouseMove Field

OSUtilsMessage_MouseMove Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_MouseMove
Public Const Message_MouseMove As Integer
public:
literal int Message_MouseMove
static val mutable Message_MouseMove: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_NCActivate Field

OSUtilsMessage_NCActivate Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_NCActivate
Public Const Message_NCActivate As Integer
public:
literal int Message_NCActivate
static val mutable Message_NCActivate: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_NCCalcsize Field

OSUtilsMessage_NCCalcsize Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_NCCalcsize
Public Const Message_NCCalcsize As Integer
public:
literal int Message_NCCalcsize
static val mutable Message_NCCalcsize: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_NCPaint Field

OSUtilsMessage_NCPaint Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_NCPaint
Public Const Message_NCPaint As Integer
public:
literal int Message_NCPaint
static val mutable Message_NCPaint: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_Paste Field

OSUtilsMessage_Paste Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_Paste
Public Const Message_Paste As Integer
public:
literal int Message_Paste
static val mutable Message_Paste: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_SetCursor Field

OSUtilsMessage_SetCursor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_SetCursor
Public Const Message_SetCursor As Integer
public:
literal int Message_SetCursor
static val mutable Message_SetCursor: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_SysKeyDown Field

OSUtilsMessage_SysKeyDown Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_SysKeyDown
Public Const Message_SysKeyDown As Integer
public:
literal int Message_SysKeyDown
static val mutable Message_SysKeyDown: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_THEMECHANGED Field

OSUtilsMessage_THEMECHANGED Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_THEMECHANGED
Public Const Message_THEMECHANGED As Integer
public:
literal int Message_THEMECHANGED
static val mutable Message_THEMECHANGED: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_Undo Field

OSUtilsMessage_Undo Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_Undo
Public Const Message_Undo As Integer
public:
literal int Message_Undo
static val mutable Message_Undo: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Message_VScroll Field

OSUtilsMessage_VScroll Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int Message_VScroll
Public Const Message_VScroll As Integer
public:
literal int Message_VScroll
static val mutable Message_VScroll: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.WindowStyle_Border Field

OSUtilsWindowStyle_Border Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int WindowStyle_Border
Public Const WindowStyle_Border As Integer
public:
literal int WindowStyle_Border
static val mutable WindowStyle_Border: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.WindowStyle_ClientEdge Field

OSUtilsWindowStyle_ClientEdge Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int WindowStyle_ClientEdge
Public Const WindowStyle_ClientEdge As Integer
public:
literal int WindowStyle_ClientEdge
static val mutable WindowStyle_ClientEdge: int

Field Value

Type: Int32
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils Methods

OSUtils Methods

The OSUtils type exposes the following members.

Methods
 | Name | Description
 | AdjustNonClientAreaSize |
 | Beep | Generates simple tones on the speaker.
 | CallNextHook | Passes the hook information to the next hook procedure in the current hook chain. A hook procedure can call this function either before or after processing the hook information.
 | CreateCaret | Creates a new shape for the system caret and assigns ownership of the caret to the specified window.
 | DeleteObject | The DeleteObject function deletes a logical pen, brush, font, bitmap, region, or palette, freeing all system resources associated with the object. After the object is deleted, the specified handle is no longer valid.
 | DestroyCaret | Destroys the caret's current shape, frees the caret from the window, and removes the caret from the screen.
 | DisableCloseButton |
 | EnumChildWindows | The EnumChildWindows function enumerates the child windows that belong to the specified parent window by passing the handle of each child window, in turn, to an application-defined callback function. EnumChildWindows continues until the last child window is enumerated or the callback function returns false.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExcludeClipRect | The ExcludeClipRect function creates a new clipping region that consists of the existing clipping region minus the specified rectangle.
 | GetCharFromKey |
 | GetClassName | The GetClassName function retrieves the name of the class to which the specified window belongs.
 | GetDoubleClickTime | Retrieves the current double-click time for the mouse.
 | GetForegroundWindow |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMouseHookHandle | Get structure associated with mouse hook.
 | GetScreenCaps | Retrieves size in pixels per logical inch of entire screen.
 | GetScrollPos | Retrieves the current position of the scroll box (thumb) in the specified scroll bar.
 | GetScrollSize(Boolean) | Retrieves dimension of the arrow bitmap of a scroll bar, in pixels.
 | GetScrollSize(IntPtr, Boolean, Boolean) | Retrieves the page size of the scroll box (thumb) in the specified scroll bar.
 | GetScrollType | Converts given code to the type of scroll event action.
 | GetText | Retrieves text that corresponds to a window.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWindowDC | Retrieves the device context (DC) for the entire window.
 | HideMinimizeAndMaximizeButtons |
 | HiWord | Retrieves the high-order word from the given value.
 | ImeComposition | Retrieves information about the composition.
 | ImmSetCompositionFont | Sets the logical font to use to display characters in the composition window.
 | ImmSetCompositionWindow | Sets the position of the composition window.
 | InitCommonControls | Registers and initializes the common control window classes.
 | InitializeFlatSB | Initializes flat scroll bars for a particular window.
 | IsFontMonospace | Determines if font family represents mono-space font;
 | IsMouseMsg | Indicates whether specified message is mouse message.
 | LoWord | Retrieves the low-order word from the specified value.
 | MessageBeep | Plays default waveform sound.
 | PostMessage | Places a message in the message queue associated with the thread that created the specified window and returns without waiting for the thread to process the message.
 | ReleaseDC | Releases a device context (DC), freeing it for use by other applications.
 | ReleaseHook | Removes a hook procedure installed in a hook chain.
 | RemoveIcon |
 | ScrollWindow | Scrolls the contents of the specified window's client area.
 | SendMessage | The SendMessage function sends the specified message to a window or windows. The function calls the window procedure for the specified window and does not return until the window procedure has processed the message.
 | SetCaretPos | Moves the caret to the specified coordinates.
 | SetCursor | The SetCursor function establishes the cursor shape.
 | SetForegroundWindow |
 | SetMouseHook | Installs hook procedure that monitors mouse messages into a hook chain.
 | SetScrollBar | Sets the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (thumb).
 | SetScrollPos | Sets the position of the scroll box (thumb) in the specified scroll bar.
 | SetText | Sets the text of a window.
 | SetWndProcHook | Installs hook procedure that monitors messages before the system sends them to the destination window procedure into a hook chain.
 | ShowCaret | Makes the caret visible on the screen at the caret's current position.
 | ShowWindowTopMost | Places the window above all non-topmost windows.
 | Sleep | Suspends the execution of the current thread for a specified interval.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UninitializeFlatSB | Uninitializes flat scroll bars for a particular window.
 | UpdateCompositionWindow | Updates position information for a composition window.
 | UpdateNonClientArea |
Top
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.AdjustNonClientAreaSize Method

OSUtilsAdjustNonClientAreaSize Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AdjustNonClientAreaSize(
    Message message,
    Padding adjustmentInward
)
Public Shared Sub AdjustNonClientAreaSize (
    message As Message,
    adjustmentInward As Padding
)
public:
static void AdjustNonClientAreaSize(
    Message message,
    Padding adjustmentInward
)
static member AdjustNonClientAreaSize :
        message : Message *
        adjustmentInward : Padding -> unit

Parameters

message
Type: System.Windows.FormsMessage
adjustmentInward
Type: System.Windows.FormsPadding
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Beep Method

OSUtilsBeep Method
Generates simple tones on the speaker.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Beep(
    int freq,
    int duration
)
Public Shared Sub Beep (
    freq As Integer,
    duration As Integer
)
public:
static void Beep(
    int freq,
    int duration
)
static member Beep :
        freq : int *
        duration : int -> unit

Parameters

freq
Type: SystemInt32
Frequency of the sound, in hertz.
duration
Type: SystemInt32
Duration of the sound, in milliseconds.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.CallNextHook Method

OSUtilsCallNextHook Method
Passes the hook information to the next hook procedure in the current hook chain. A hook procedure can call this function either before or after processing the hook information.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CallNextHook(
    IntPtr hhk,
    int code,
    IntPtr wparam,
    IntPtr lparam
)
Public Shared Function CallNextHook (
    hhk As IntPtr,
    code As Integer,
    wparam As IntPtr,
    lparam As IntPtr
) As IntPtr
public:
static IntPtr CallNextHook(
    IntPtr hhk,
    int code,
    IntPtr wparam,
    IntPtr lparam
)
static member CallNextHook :
        hhk : IntPtr *
        code : int *
        wparam : IntPtr *
        lparam : IntPtr -> IntPtr

Parameters

hhk
Type: SystemIntPtr
Handle to the current hook.
code
Type: SystemInt32
Hook code passed to the current hook procedure.
wparam
Type: SystemIntPtr
Specifies the wparam value passed to the current hook procedure.
lparam
Type: SystemIntPtr
Specifies the lparam value passed to the current hook procedure.

Return Value

Type: IntPtr
This value is returned by the next hook procedure in the chain.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.CreateCaret Method

OSUtilsCreateCaret Method
Creates a new shape for the system caret and assigns ownership of the caret to the specified window.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CreateCaret(
    IntPtr handle,
    int width,
    int height
)
Public Shared Function CreateCaret (
    handle As IntPtr,
    width As Integer,
    height As Integer
) As Boolean
public:
static bool CreateCaret(
    IntPtr handle,
    int width,
    int height
)
static member CreateCaret :
        handle : IntPtr *
        width : int *
        height : int -> bool

Parameters

handle
Type: SystemIntPtr
Handle to the window that owns the caret.
width
Type: SystemInt32
Specifies the width of the caret in logical units.
height
Type: SystemInt32
Specifies the height of the caret in logical units.

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero; otherwise zero.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.DeleteObject Method

OSUtilsDeleteObject Method
The DeleteObject function deletes a logical pen, brush, font, bitmap, region, or palette, freeing all system resources associated with the object. After the object is deleted, the specified handle is no longer valid.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool DeleteObject(
    IntPtr handle
)
Public Shared Function DeleteObject (
    handle As IntPtr
) As Boolean
public:
static bool DeleteObject(
    IntPtr handle
)
static member DeleteObject :
        handle : IntPtr -> bool

Parameters

handle
Type: SystemIntPtr
A handle to a logical pen, brush, font, bitmap, region, or palette.

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero. If the specified handle is not valid or is currently selected into a DC, the return value is zero.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.DestroyCaret Method

OSUtilsDestroyCaret Method
Destroys the caret's current shape, frees the caret from the window, and removes the caret from the screen.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool DestroyCaret()
Public Shared Function DestroyCaret As Boolean
public:
static bool DestroyCaret()
static member DestroyCaret : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.DisableCloseButton Method

OSUtilsDisableCloseButton Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DisableCloseButton(
    IntPtr handle
)
Public Shared Sub DisableCloseButton (
    handle As IntPtr
)
public:
static void DisableCloseButton(
    IntPtr handle
)
static member DisableCloseButton :
        handle : IntPtr -> unit

Parameters

handle
Type: SystemIntPtr
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.EnumChildWindows Method

OSUtilsEnumChildWindows Method
The EnumChildWindows function enumerates the child windows that belong to the specified parent window by passing the handle of each child window, in turn, to an application-defined callback function. EnumChildWindows continues until the last child window is enumerated or the callback function returns false.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool EnumChildWindows(
    IntPtr hwndParent,
    EnumChildProc lpEnumFunc,
    IntPtr lparam
)
Public Shared Function EnumChildWindows (
    hwndParent As IntPtr,
    lpEnumFunc As EnumChildProc,
    lparam As IntPtr
) As Boolean
public:
static bool EnumChildWindows(
    IntPtr hwndParent,
    EnumChildProc^ lpEnumFunc,
    IntPtr lparam
)
static member EnumChildWindows :
        hwndParent : IntPtr *
        lpEnumFunc : EnumChildProc *
        lparam : IntPtr -> bool

Parameters

hwndParent
Type: SystemIntPtr
Identifies the parent window whose child windows are to be enumerated.
lpEnumFunc
Type: Alternet.CommonEnumChildProc
Points to an application-defined callback function.
lparam
Type: SystemIntPtr
Specifies a 32-bit, application-defined value to be passed to the callback function.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.ExcludeClipRect Method

OSUtilsExcludeClipRect Method
The ExcludeClipRect function creates a new clipping region that consists of the existing clipping region minus the specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int ExcludeClipRect(
    IntPtr hdc,
    int l,
    int t,
    int r,
    int b
)
Public Shared Function ExcludeClipRect (
    hdc As IntPtr,
    l As Integer,
    t As Integer,
    r As Integer,
    b As Integer
) As Integer
public:
static int ExcludeClipRect(
    IntPtr hdc,
    int l,
    int t,
    int r,
    int b
)
static member ExcludeClipRect :
        hdc : IntPtr *
        l : int *
        t : int *
        r : int *
        b : int -> int

Parameters

hdc
Type: SystemIntPtr
Identifies the device context.
l
Type: SystemInt32
Specifies the logical x-coordinate of the upper-left corner of the rectangle.
t
Type: SystemInt32
Specifies the logical y-coordinate of the upper-left corner of the rectangle.
r
Type: SystemInt32
Specifies the logical x-coordinate of the lower-right corner of the rectangle.
b
Type: SystemInt32
Specifies the logical y-coordinate of the lower-right corner of the rectangle.

Return Value

Type: Int32
Specifies type of new clipping region.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetCharFromKey Method

OSUtilsGetCharFromKey Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char GetCharFromKey(
    int virtualKey,
    ref char formatKey
)
Public Shared Function GetCharFromKey (
    virtualKey As Integer,
    ByRef formatKey As Char
) As Char
public:
static wchar_t GetCharFromKey(
    int virtualKey,
    wchar_t% formatKey
)
static member GetCharFromKey :
        virtualKey : int *
        formatKey : char byref -> char

Parameters

virtualKey
Type: SystemInt32
formatKey
Type: SystemChar

Return Value

Type: Char
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetClassName Method

OSUtilsGetClassName Method
The GetClassName function retrieves the name of the class to which the specified window belongs.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetClassName(
    IntPtr hwnd
)
Public Shared Function GetClassName (
    hwnd As IntPtr
) As String
public:
static String^ GetClassName(
    IntPtr hwnd
)
static member GetClassName :
        hwnd : IntPtr -> string

Parameters

hwnd
Type: SystemIntPtr
Identifies the window and, indirectly, the class to which the window belongs.

Return Value

Type: String
Name of the class.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetDoubleClickTime Method

OSUtilsGetDoubleClickTime Method
Retrieves the current double-click time for the mouse.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetDoubleClickTime()
Public Shared Function GetDoubleClickTime As Integer
public:
static int GetDoubleClickTime()
static member GetDoubleClickTime : unit -> int

Return Value

Type: Int32
Returns the current double-click time, in milliseconds.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetForegroundWindow Method

OSUtilsGetForegroundWindow Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetForegroundWindow()
Public Shared Function GetForegroundWindow As IntPtr
public:
static IntPtr GetForegroundWindow()
static member GetForegroundWindow : unit -> IntPtr

Return Value

Type: IntPtr
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetMouseHookHandle Method

OSUtilsGetMouseHookHandle Method
Get structure associated with mouse hook.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetMouseHookHandle(
    IntPtr lparam,
    out Point pt
)
Public Shared Function GetMouseHookHandle (
    lparam As IntPtr,
    <OutAttribute> ByRef pt As Point
) As IntPtr
public:
static IntPtr GetMouseHookHandle(
    IntPtr lparam,
    [OutAttribute] Point% pt
)
static member GetMouseHookHandle :
        lparam : IntPtr *
        pt : Point byref -> IntPtr

Parameters

lparam
Type: SystemIntPtr
Mouse hook data.
pt
Type: System.DrawingPoint
Mouse point.

Return Value

Type: IntPtr
Window handle sending mouse message.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetScreenCaps Method

OSUtilsGetScreenCaps Method
Retrieves size in pixels per logical inch of entire screen.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Size GetScreenCaps()
Public Shared Function GetScreenCaps As Size
public:
static Size GetScreenCaps()
static member GetScreenCaps : unit -> Size

Return Value

Type: Size
Size of entire screen.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetScrollPos Method

OSUtilsGetScrollPos Method
Retrieves the current position of the scroll box (thumb) in the specified scroll bar.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetScrollPos(
    IntPtr handle,
    bool flat,
    bool isVertical
)
Public Shared Function GetScrollPos (
    handle As IntPtr,
    flat As Boolean,
    isVertical As Boolean
) As Integer
public:
static int GetScrollPos(
    IntPtr handle,
    bool flat,
    bool isVertical
)
static member GetScrollPos :
        handle : IntPtr *
        flat : bool *
        isVertical : bool -> int

Parameters

handle
Type: SystemIntPtr
Handle to a scroll bar control or a window with a standard scroll bar.
flat
Type: SystemBoolean
Indicates whether scroll bar is flat.
isVertical
Type: SystemBoolean
Indicates whether scroll bar is vertical or horizontal.

Return Value

Type: Int32
If the function succeeds, the return value is the current position of the scroll box; otherwise zero.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetScrollSize Method

OSUtilsGetScrollSize Method
Overload List
Name | Description
GetScrollSize(Boolean) | Retrieves dimension of the arrow bitmap of a scroll bar, in pixels.
GetScrollSize(IntPtr, Boolean, Boolean) | Retrieves the page size of the scroll box (thumb) in the specified scroll bar.
Top
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetScrollSize Method (Boolean)

OSUtilsGetScrollSize Method (Boolean)
Retrieves dimension of the arrow bitmap of a scroll bar, in pixels.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetScrollSize(
    bool isVertical
)
Public Shared Function GetScrollSize (
    isVertical As Boolean
) As Integer
public:
static int GetScrollSize(
    bool isVertical
)
static member GetScrollSize :
        isVertical : bool -> int

Parameters

isVertical
Type: SystemBoolean
Indicates whether scroll bar is vertical.

Return Value

Type: Int32
Dimension of the arrow bitmap.
See Also

Reference

OSUtils Class
GetScrollSize Overload
Alternet.Common Namespace


OSUtils.GetScrollSize Method (IntPtr, Boolean, Boolean)

OSUtilsGetScrollSize Method (IntPtr, Boolean, Boolean)
Retrieves the page size of the scroll box (thumb) in the specified scroll bar.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetScrollSize(
    IntPtr handle,
    bool flat,
    bool isVertical
)
Public Shared Function GetScrollSize (
    handle As IntPtr,
    flat As Boolean,
    isVertical As Boolean
) As Integer
public:
static int GetScrollSize(
    IntPtr handle,
    bool flat,
    bool isVertical
)
static member GetScrollSize :
        handle : IntPtr *
        flat : bool *
        isVertical : bool -> int

Parameters

handle
Type: SystemIntPtr
Handle to a scroll bar control or a window with a standard scroll bar.
flat
Type: SystemBoolean
Indicates whether scroll bar is flat.
isVertical
Type: SystemBoolean
Indicates whether scroll bar is vertical or horizontal.

Return Value

Type: Int32
If the function succeeds, the return value is the page size of the scroll box; otherwise zero.
See Also

Reference

OSUtils Class
GetScrollSize Overload
Alternet.Common Namespace


OSUtils.GetScrollType Method

OSUtilsGetScrollType Method
Converts given code to the type of scroll event action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ScrollEventType GetScrollType(
    int code
)
Public Shared Function GetScrollType (
    code As Integer
) As ScrollEventType
public:
static ScrollEventType GetScrollType(
    int code
)
static member GetScrollType :
        code : int -> ScrollEventType

Parameters

code
Type: SystemInt32
Code to convert.

Return Value

Type: ScrollEventType
ScrollEventType of scroll event action.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetText Method

OSUtilsGetText Method
Retrieves text that corresponds to a window.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetText(
    IntPtr hwnd
)
Public Shared Function GetText (
    hwnd As IntPtr
) As String
public:
static String^ GetText(
    IntPtr hwnd
)
static member GetText :
        hwnd : IntPtr -> string

Parameters

hwnd
Type: SystemIntPtr
Handle of window.

Return Value

Type: String
Text that corresponds to a window.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.GetWindowDC Method

OSUtilsGetWindowDC Method
Retrieves the device context (DC) for the entire window.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetWindowDC(
    IntPtr hwnd
)
Public Shared Function GetWindowDC (
    hwnd As IntPtr
) As IntPtr
public:
static IntPtr GetWindowDC(
    IntPtr hwnd
)
static member GetWindowDC :
        hwnd : IntPtr -> IntPtr

Parameters

hwnd
Type: SystemIntPtr
Handle to the window with a device context that is to be retrieved.

Return Value

Type: IntPtr
If the function succeeds, the return value is a handle to a device context for the specified window; otherwise return value is null.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.HideMinimizeAndMaximizeButtons Method

OSUtilsHideMinimizeAndMaximizeButtons Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void HideMinimizeAndMaximizeButtons(
    IntPtr handle
)
Public Shared Sub HideMinimizeAndMaximizeButtons (
    handle As IntPtr
)
public:
static void HideMinimizeAndMaximizeButtons(
    IntPtr handle
)
static member HideMinimizeAndMaximizeButtons :
        handle : IntPtr -> unit

Parameters

handle
Type: SystemIntPtr
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.HiWord Method

OSUtilsHiWord Method
Retrieves the high-order word from the given value.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static short HiWord(
    IntPtr value
)
Public Shared Function HiWord (
    value As IntPtr
) As Short
public:
static short HiWord(
    IntPtr value
)
static member HiWord :
        value : IntPtr -> int16

Parameters

value
Type: SystemIntPtr
Specifies the value to be converted.

Return Value

Type: Int16
The return value is the high-order word of the specified value.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.ImeComposition Method

OSUtilsImeComposition Method
Retrieves information about the composition.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ImeComposition(
    IntPtr wnd
)
Public Shared Sub ImeComposition (
    wnd As IntPtr
)
public:
static void ImeComposition(
    IntPtr wnd
)
static member ImeComposition :
        wnd : IntPtr -> unit

Parameters

wnd
Type: SystemIntPtr
Handle to the input context.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.ImmSetCompositionFont Method

OSUtilsImmSetCompositionFont Method
Sets the logical font to use to display characters in the composition window.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ImmSetCompositionFont(
    IntPtr wnd,
    Font font
)
Public Shared Sub ImmSetCompositionFont (
    wnd As IntPtr,
    font As Font
)
public:
static void ImmSetCompositionFont(
    IntPtr wnd,
    Font^ font
)
static member ImmSetCompositionFont :
        wnd : IntPtr *
        font : Font -> unit

Parameters

wnd
Type: SystemIntPtr
Handle to the input context.
font
Type: System.DrawingFont
Font information to set.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.ImmSetCompositionWindow Method

OSUtilsImmSetCompositionWindow Method
Sets the position of the composition window.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ImmSetCompositionWindow(
    IntPtr wnd,
    Point pos
)
Public Shared Sub ImmSetCompositionWindow (
    wnd As IntPtr,
    pos As Point
)
public:
static void ImmSetCompositionWindow(
    IntPtr wnd,
    Point pos
)
static member ImmSetCompositionWindow :
        wnd : IntPtr *
        pos : Point -> unit

Parameters

wnd
Type: SystemIntPtr
Handle to the input context.
pos
Type: System.DrawingPoint
A Point containing the coordinates of the upper left corner of the composition window.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.InitCommonControls Method

OSUtilsInitCommonControls Method
Registers and initializes the common control window classes.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InitCommonControls()
Public Shared Function InitCommonControls As Boolean
public:
static bool InitCommonControls()
static member InitCommonControls : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.InitializeFlatSB Method

OSUtilsInitializeFlatSB Method
Initializes flat scroll bars for a particular window.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InitializeFlatSB(
    IntPtr handle
)
Public Shared Function InitializeFlatSB (
    handle As IntPtr
) As Boolean
public:
static bool InitializeFlatSB(
    IntPtr handle
)
static member InitializeFlatSB :
        handle : IntPtr -> bool

Parameters

handle
Type: SystemIntPtr
Handle to the window that will receive flat scroll bars.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.IsFontMonospace Method

OSUtilsIsFontMonospace Method
Determines if font family represents mono-space font;

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsFontMonospace(
    string fontFamily,
    FontStyle fontStyle,
    int fontHeight
)
Public Shared Function IsFontMonospace (
    fontFamily As String,
    fontStyle As FontStyle,
    fontHeight As Integer
) As Boolean
public:
static bool IsFontMonospace(
    String^ fontFamily,
    FontStyle fontStyle,
    int fontHeight
)
static member IsFontMonospace :
        fontFamily : string *
        fontStyle : FontStyle *
        fontHeight : int -> bool

Parameters

fontFamily
Type: SystemString
Font family.
fontStyle
Type: System.DrawingFontStyle
Font style
fontHeight
Type: SystemInt32
Font height

Return Value

Type: Boolean
True if font is mono-space, otherwise False.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.IsMouseMsg Method

OSUtilsIsMouseMsg Method
Indicates whether specified message is mouse message.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsMouseMsg(
    int msg
)
Public Shared Function IsMouseMsg (
    msg As Integer
) As Boolean
public:
static bool IsMouseMsg(
    int msg
)
static member IsMouseMsg :
        msg : int -> bool

Parameters

msg
Type: SystemInt32
Message to check-up.

Return Value

Type: Boolean
True if it is mouse message; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.LoWord Method

OSUtilsLoWord Method
Retrieves the low-order word from the specified value.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static short LoWord(
    IntPtr value
)
Public Shared Function LoWord (
    value As IntPtr
) As Short
public:
static short LoWord(
    IntPtr value
)
static member LoWord :
        value : IntPtr -> int16

Parameters

value
Type: SystemIntPtr
Specifies the value to be converted.

Return Value

Type: Int16
The return value is the low-order word of the specified value.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.MessageBeep Method

OSUtilsMessageBeep Method
Plays default waveform sound.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void MessageBeep()
Public Shared Sub MessageBeep
public:
static void MessageBeep()
static member MessageBeep : unit -> unit
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.PostMessage Method

OSUtilsPostMessage Method
Places a message in the message queue associated with the thread that created the specified window and returns without waiting for the thread to process the message.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool PostMessage(
    IntPtr hwnd,
    int msg,
    IntPtr wparam,
    IntPtr lparam
)
Public Shared Function PostMessage (
    hwnd As IntPtr,
    msg As Integer,
    wparam As IntPtr,
    lparam As IntPtr
) As Boolean
public:
static bool PostMessage(
    IntPtr hwnd,
    int msg,
    IntPtr wparam,
    IntPtr lparam
)
static member PostMessage :
        hwnd : IntPtr *
        msg : int *
        wparam : IntPtr *
        lparam : IntPtr -> bool

Parameters

hwnd
Type: SystemIntPtr
Handle to the window whose window procedure is to receive the message.
msg
Type: SystemInt32
Specifies the message to be posted.
wparam
Type: SystemIntPtr
Specifies additional message-specific information.
lparam
Type: SystemIntPtr
Specifies additional message-specific information.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.ReleaseDC Method

OSUtilsReleaseDC Method
Releases a device context (DC), freeing it for use by other applications.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int ReleaseDC(
    IntPtr hwnd,
    IntPtr hdc
)
Public Shared Function ReleaseDC (
    hwnd As IntPtr,
    hdc As IntPtr
) As Integer
public:
static int ReleaseDC(
    IntPtr hwnd,
    IntPtr hdc
)
static member ReleaseDC :
        hwnd : IntPtr *
        hdc : IntPtr -> int

Parameters

hwnd
Type: SystemIntPtr
Handle to the window whose DC is to be released.
hdc
Type: SystemIntPtr
Handle to the DC to be released.

Return Value

Type: Int32
The return value indicates whether the DC was released. If the DC was released, the return value is 1; otherwise the return value is zero.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.ReleaseHook Method

OSUtilsReleaseHook Method
Removes a hook procedure installed in a hook chain.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ReleaseHook(
    IntPtr hhk
)
Public Shared Function ReleaseHook (
    hhk As IntPtr
) As Boolean
public:
static bool ReleaseHook(
    IntPtr hhk
)
static member ReleaseHook :
        hhk : IntPtr -> bool

Parameters

hhk
Type: SystemIntPtr
Handle to the hook to be removed.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.RemoveIcon Method

OSUtilsRemoveIcon Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveIcon(
    IntPtr handle
)
Public Shared Sub RemoveIcon (
    handle As IntPtr
)
public:
static void RemoveIcon(
    IntPtr handle
)
static member RemoveIcon :
        handle : IntPtr -> unit

Parameters

handle
Type: SystemIntPtr
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.ScrollWindow Method

OSUtilsScrollWindow Method
Scrolls the contents of the specified window's client area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ScrollWindow(
    IntPtr handle,
    int x,
    int y,
    Rectangle rect
)
Public Shared Sub ScrollWindow (
    handle As IntPtr,
    x As Integer,
    y As Integer,
    rect As Rectangle
)
public:
static void ScrollWindow(
    IntPtr handle,
    int x,
    int y,
    Rectangle rect
)
static member ScrollWindow :
        handle : IntPtr *
        x : int *
        y : int *
        rect : Rectangle -> unit

Parameters

handle
Type: SystemIntPtr
Handle to the window where the client area is to be scrolled.
x
Type: SystemInt32
Specifies the amount of horizontal scrolling.
y
Type: SystemInt32
Specifies the amount of vertical scrolling.
rect
Type: System.DrawingRectangle
Rectangle that specifies the portion of the client area to be scrolled.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.SendMessage Method

OSUtilsSendMessage Method
The SendMessage function sends the specified message to a window or windows. The function calls the window procedure for the specified window and does not return until the window procedure has processed the message.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr SendMessage(
    IntPtr hwnd,
    int msg,
    IntPtr wparam,
    IntPtr lparam
)
Public Shared Function SendMessage (
    hwnd As IntPtr,
    msg As Integer,
    wparam As IntPtr,
    lparam As IntPtr
) As IntPtr
public:
static IntPtr SendMessage(
    IntPtr hwnd,
    int msg,
    IntPtr wparam,
    IntPtr lparam
)
static member SendMessage :
        hwnd : IntPtr *
        msg : int *
        wparam : IntPtr *
        lparam : IntPtr -> IntPtr

Parameters

hwnd
Type: SystemIntPtr
Identifies the window whose window procedure will receive the message.
msg
Type: SystemInt32
Specifies the message to be sent.
wparam
Type: SystemIntPtr
Specifies additional message-specific information.
lparam
Type: SystemIntPtr
Specifies additional message-specific information.

Return Value

Type: IntPtr
Result of the message processing and depends on the message sent.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.SetCaretPos Method

OSUtilsSetCaretPos Method
Moves the caret to the specified coordinates.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool SetCaretPos(
    int x,
    int y
)
Public Shared Function SetCaretPos (
    x As Integer,
    y As Integer
) As Boolean
public:
static bool SetCaretPos(
    int x,
    int y
)
static member SetCaretPos :
        x : int *
        y : int -> bool

Parameters

x
Type: SystemInt32
Specifies the new x-coordinate of the caret.
y
Type: SystemInt32
Specifies the new y-coordinate of the caret.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.SetCursor Method

OSUtilsSetCursor Method
The SetCursor function establishes the cursor shape.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr SetCursor(
    IntPtr handle
)
Public Shared Function SetCursor (
    handle As IntPtr
) As IntPtr
public:
static IntPtr SetCursor(
    IntPtr handle
)
static member SetCursor :
        handle : IntPtr -> IntPtr

Parameters

handle
Type: SystemIntPtr
Identifies the cursor.

Return Value

Type: IntPtr
The handle to the previous cursor if success; otherwise null.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.SetForegroundWindow Method

OSUtilsSetForegroundWindow Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool SetForegroundWindow(
    IntPtr wnd
)
Public Shared Function SetForegroundWindow (
    wnd As IntPtr
) As Boolean
public:
static bool SetForegroundWindow(
    IntPtr wnd
)
static member SetForegroundWindow :
        wnd : IntPtr -> bool

Parameters

wnd
Type: SystemIntPtr

Return Value

Type: Boolean
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.SetMouseHook Method

OSUtilsSetMouseHook Method
Installs hook procedure that monitors mouse messages into a hook chain.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr SetMouseHook(
    HookHandler lpfn
)
Public Shared Function SetMouseHook (
    lpfn As HookHandler
) As IntPtr
public:
static IntPtr SetMouseHook(
    HookHandler^ lpfn
)
static member SetMouseHook :
        lpfn : HookHandler -> IntPtr

Parameters

lpfn
Type: Alternet.CommonHookHandler
Hook procedure.

Return Value

Type: IntPtr
If the function succeeds, the return value is the handle to the hook procedure; otherwise return value is null.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.SetScrollBar Method

OSUtilsSetScrollBar Method
Sets the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (thumb).

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetScrollBar(
    IntPtr handle,
    bool flat,
    int size,
    int pageSize,
    bool isVertical
)
Public Shared Sub SetScrollBar (
    handle As IntPtr,
    flat As Boolean,
    size As Integer,
    pageSize As Integer,
    isVertical As Boolean
)
public:
static void SetScrollBar(
    IntPtr handle,
    bool flat,
    int size,
    int pageSize,
    bool isVertical
)
static member SetScrollBar :
        handle : IntPtr *
        flat : bool *
        size : int *
        pageSize : int *
        isVertical : bool -> unit

Parameters

handle
Type: SystemIntPtr
Handle to a scroll bar control or a window with a standard scroll bar.
flat
Type: SystemBoolean
Indicates whether scroll bar is flat.
size
Type: SystemInt32
Specifies the maximum scrolling position.
pageSize
Type: SystemInt32
Specifies the page size.
isVertical
Type: SystemBoolean
Indicates whether scroll bar is vertical or horizontal.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.SetScrollPos Method

OSUtilsSetScrollPos Method
Sets the position of the scroll box (thumb) in the specified scroll bar.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetScrollPos(
    IntPtr handle,
    bool flat,
    int pos,
    bool isVertical
)
Public Shared Sub SetScrollPos (
    handle As IntPtr,
    flat As Boolean,
    pos As Integer,
    isVertical As Boolean
)
public:
static void SetScrollPos(
    IntPtr handle,
    bool flat,
    int pos,
    bool isVertical
)
static member SetScrollPos :
        handle : IntPtr *
        flat : bool *
        pos : int *
        isVertical : bool -> unit

Parameters

handle
Type: SystemIntPtr
Handle to a scroll bar control or a window with a standard scroll bar.
flat
Type: SystemBoolean
Indicates whether scroll bar is flat.
pos
Type: SystemInt32
Specifies the position of the scroll box.
isVertical
Type: SystemBoolean
Indicates whether scroll bar is vertical or horizontal.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.SetText Method

OSUtilsSetText Method
Sets the text of a window.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetText(
    IntPtr hwnd,
    string text
)
Public Shared Sub SetText (
    hwnd As IntPtr,
    text As String
)
public:
static void SetText(
    IntPtr hwnd,
    String^ text
)
static member SetText :
        hwnd : IntPtr *
        text : string -> unit

Parameters

hwnd
Type: SystemIntPtr
Handle of the window.
text
Type: SystemString
New text of the window.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.SetWndProcHook Method

OSUtilsSetWndProcHook Method
Installs hook procedure that monitors messages before the system sends them to the destination window procedure into a hook chain.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IntPtr SetWndProcHook(
    HookHandler lpfn
)
Public Shared Function SetWndProcHook (
    lpfn As HookHandler
) As IntPtr
public:
static IntPtr SetWndProcHook(
    HookHandler^ lpfn
)
static member SetWndProcHook :
        lpfn : HookHandler -> IntPtr

Parameters

lpfn
Type: Alternet.CommonHookHandler
Hook procedure.

Return Value

Type: IntPtr
If the function succeeds, the return value is the handle to the hook procedure; otherwise return value is null.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.ShowCaret Method

OSUtilsShowCaret Method
Makes the caret visible on the screen at the caret's current position.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ShowCaret(
    IntPtr handle
)
Public Shared Function ShowCaret (
    handle As IntPtr
) As Boolean
public:
static bool ShowCaret(
    IntPtr handle
)
static member ShowCaret :
        handle : IntPtr -> bool

Parameters

handle
Type: SystemIntPtr
Handle to the window that owns the caret.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.ShowWindowTopMost Method

OSUtilsShowWindowTopMost Method
Places the window above all non-topmost windows.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ShowWindowTopMost(
    IntPtr hwnd,
    int x,
    int y,
    int cx,
    int cy
)
Public Shared Function ShowWindowTopMost (
    hwnd As IntPtr,
    x As Integer,
    y As Integer,
    cx As Integer,
    cy As Integer
) As Boolean
public:
static bool ShowWindowTopMost(
    IntPtr hwnd,
    int x,
    int y,
    int cx,
    int cy
)
static member ShowWindowTopMost :
        hwnd : IntPtr *
        x : int *
        y : int *
        cx : int *
        cy : int -> bool

Parameters

hwnd
Type: SystemIntPtr
Handle to the window.
x
Type: SystemInt32
Specifies the new position of the left side of the window, in client coordinates.
y
Type: SystemInt32
Specifies the new position of the top of the window, in client coordinates.
cx
Type: SystemInt32
Specifies the new width of the window, in pixels.
cy
Type: SystemInt32
Specifies the new height of the window, in pixels.

Return Value

Type: Boolean
True if success; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.Sleep Method

OSUtilsSleep Method
Suspends the execution of the current thread for a specified interval.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Sleep(
    int milliSeconds
)
Public Shared Sub Sleep (
    milliSeconds As Integer
)
public:
static void Sleep(
    int milliSeconds
)
static member Sleep :
        milliSeconds : int -> unit

Parameters

milliSeconds
Type: SystemInt32
Specifies time, in milliseconds, for which to suspend execution.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.UninitializeFlatSB Method

OSUtilsUninitializeFlatSB Method
Uninitializes flat scroll bars for a particular window.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool UninitializeFlatSB(
    IntPtr handle
)
Public Shared Function UninitializeFlatSB (
    handle As IntPtr
) As Boolean
public:
static bool UninitializeFlatSB(
    IntPtr handle
)
static member UninitializeFlatSB :
        handle : IntPtr -> bool

Parameters

handle
Type: SystemIntPtr
Handle to the window with the flat scroll bars that will be uninitialized.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.UpdateCompositionWindow Method

OSUtilsUpdateCompositionWindow Method
Updates position information for a composition window.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UpdateCompositionWindow(
    IntPtr wnd,
    Point pos,
    IntPtr wndPos
)
Public Shared Sub UpdateCompositionWindow (
    wnd As IntPtr,
    pos As Point,
    wndPos As IntPtr
)
public:
static void UpdateCompositionWindow(
    IntPtr wnd,
    Point pos,
    IntPtr wndPos
)
static member UpdateCompositionWindow :
        wnd : IntPtr *
        pos : Point *
        wndPos : IntPtr -> unit

Parameters

wnd
Type: SystemIntPtr
Handle to the input context.
pos
Type: System.DrawingPoint
A Point containing the coordinates of the upper left corner of the composition window.
wndPos
Type: SystemIntPtr
Pointer to the composition window.
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.UpdateNonClientArea Method

OSUtilsUpdateNonClientArea Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UpdateNonClientArea(
    IntPtr windowHandle
)
Public Shared Sub UpdateNonClientArea (
    windowHandle As IntPtr
)
public:
static void UpdateNonClientArea(
    IntPtr windowHandle
)
static member UpdateNonClientArea :
        windowHandle : IntPtr -> unit

Parameters

windowHandle
Type: SystemIntPtr
See Also

Reference

OSUtils Class
Alternet.Common Namespace


OSUtils.CWPSTRUCT Structure

OSUtilsCWPSTRUCT Structure
Defines the message parameters passed to a WH_CALLWNDPROC hook procedure, CallWndProc.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct CWPSTRUCT
Public Structure CWPSTRUCT
public value class CWPSTRUCT
[<SealedAttribute>]
type CWPSTRUCT =  struct end

The OSUtilsCWPSTRUCT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | hwnd |
Public field | lParam |
Public field | message |
Public field | wParam |
Top
See Also

Reference

Alternet.Common Namespace


CWPSTRUCT Fields

CWPSTRUCT Fields

The OSUtilsCWPSTRUCT type exposes the following members.

Fields
 | Name | Description
Public field | hwnd |
Public field | lParam |
Public field | message |
Public field | wParam |
Top
See Also

Reference

OSUtilsCWPSTRUCT Structure
Alternet.Common Namespace


OSUtils.CWPSTRUCT.hwnd Field

OSUtilsCWPSTRUCThwnd Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntPtr hwnd
Public hwnd As IntPtr
public:
IntPtr hwnd
val mutable hwnd: IntPtr

Field Value

Type: IntPtr
See Also

Reference

OSUtilsCWPSTRUCT Structure
Alternet.Common Namespace


OSUtils.CWPSTRUCT.lParam Field

OSUtilsCWPSTRUCTlParam Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntPtr lParam
Public lParam As IntPtr
public:
IntPtr lParam
val mutable lParam: IntPtr

Field Value

Type: IntPtr
See Also

Reference

OSUtilsCWPSTRUCT Structure
Alternet.Common Namespace


OSUtils.CWPSTRUCT.message Field

OSUtilsCWPSTRUCTmessage Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int message
Public message As Integer
public:
int message
val mutable message: int

Field Value

Type: Int32
See Also

Reference

OSUtilsCWPSTRUCT Structure
Alternet.Common Namespace


OSUtils.CWPSTRUCT.wParam Field

OSUtilsCWPSTRUCTwParam Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntPtr wParam
Public wParam As IntPtr
public:
IntPtr wParam
val mutable wParam: IntPtr

Field Value

Type: IntPtr
See Also

Reference

OSUtilsCWPSTRUCT Structure
Alternet.Common Namespace


CWPSTRUCT Methods

CWPSTRUCT Methods

The OSUtilsCWPSTRUCT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

OSUtilsCWPSTRUCT Structure
Alternet.Common Namespace


Painter Class

Painter Class
Encapsulates a drawing surface, providing properties and methods used to draw text and graphic primitives.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainter
Alternet.CommonGdiPainter

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Painter : IDisposable
Public Class Painter
    Implements IDisposable
public ref class Painter : IDisposable
type Painter =
    class
        interface IDisposable
    end

The Painter type exposes the following members.

Constructors
 | Name | Description
Public method | Painter | Initializes a new instance of the Painter class with default settings.
Top
Methods
 | Name | Description
Public method | Clear | Resets all Painter properties to the initial state.
Public method | Dispose | Disposes this Painter and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectNativeFont | Selects font with specified parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets background color of the device context currently associated with the Painter.
Public property | Font | Gets or sets font of the device context currently associated with the Painter.
Public property | FontHeight | Represents height of the font of the device context currently associated with the Painter.
Public property | FontStyle | Gets or sets font style of the device context currently associated with the Painter.
Public property | FontWidth | Represents width of the font of the device context currently associated with the Painter.
Public property | ForeColor | Gets or sets foreground color of the device context currently associated with the Painter.
Public property | IsMonoSpaced | Represents a value indicating whether font of the device context currently associated with this Painter is monospaced, meaning that all characters drawn with this font have the same width.
Public property | LineHeight | When implemented by a class, represents height of the individual lines.
Public property | LineSpace | Represents additional height added to the height of the font.
Public property | Opaque | Gets or sets a boolean value indicating that background is filled with the current background color before the text is drawn.
Public property | StringFormat | Encapsulates text layout information and display manipulations for this Painter.
Public property | TextColor | Gets or sets text color of the device context currently associated with the Painter.
Top
See Also

Reference

Alternet.Common Namespace


Painter Constructor

Painter Constructor
Initializes a new instance of the Painter class with default settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Painter()
Public Sub New
public:
Painter()
new : unit -> Painter
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter Methods

Painter Methods

The Painter type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Resets all Painter properties to the initial state.
Public method | Dispose | Disposes this Painter and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectNativeFont | Selects font with specified parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.Clear Method

PainterClear Method
Resets all Painter properties to the initial state.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.Dispose Method

PainterDispose Method
Disposes this Painter and frees resources associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.SelectNativeFont Method

PainterSelectNativeFont Method
Selects font with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectNativeFont(
    string fontName,
    FontStyle fontStyle,
    int fontHeight
)
Public Overridable Sub SelectNativeFont (
    fontName As String,
    fontStyle As FontStyle,
    fontHeight As Integer
)
public:
virtual void SelectNativeFont(
    String^ fontName,
    FontStyle fontStyle,
    int fontHeight
)
abstract SelectNativeFont :
        fontName : string *
        fontStyle : FontStyle *
        fontHeight : int -> unit
override SelectNativeFont :
        fontName : string *
        fontStyle : FontStyle *
        fontHeight : int -> unit

Parameters

fontName
Type: SystemString
The name of Font to select.
fontStyle
Type: System.DrawingFontStyle
The FontStyle of Font to select.
fontHeight
Type: SystemInt32
The height of Font to select.
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter Properties

Painter Properties

The Painter type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets background color of the device context currently associated with the Painter.
Public property | Font | Gets or sets font of the device context currently associated with the Painter.
Public property | FontHeight | Represents height of the font of the device context currently associated with the Painter.
Public property | FontStyle | Gets or sets font style of the device context currently associated with the Painter.
Public property | FontWidth | Represents width of the font of the device context currently associated with the Painter.
Public property | ForeColor | Gets or sets foreground color of the device context currently associated with the Painter.
Public property | IsMonoSpaced | Represents a value indicating whether font of the device context currently associated with this Painter is monospaced, meaning that all characters drawn with this font have the same width.
Public property | LineHeight | When implemented by a class, represents height of the individual lines.
Public property | LineSpace | Represents additional height added to the height of the font.
Public property | Opaque | Gets or sets a boolean value indicating that background is filled with the current background color before the text is drawn.
Public property | StringFormat | Encapsulates text layout information and display manipulations for this Painter.
Public property | TextColor | Gets or sets text color of the device context currently associated with the Painter.
Top
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.BackColor Property

PainterBackColor Property
Gets or sets background color of the device context currently associated with the Painter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BackColor { get; set; }
Public Overridable Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.Font Property

PainterFont Property
Gets or sets font of the device context currently associated with the Painter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Font Font { get; set; }
Public Overridable Property Font As Font
    Get
    Set
public:
virtual property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set
override Font : Font with get, set

Property Value

Type: Font
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.FontHeight Property

PainterFontHeight Property
Represents height of the font of the device context currently associated with the Painter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FontHeight { get; }
Public Overridable ReadOnly Property FontHeight As Integer
    Get
public:
virtual property int FontHeight {
    int get ();
}
abstract FontHeight : int with get
override FontHeight : int with get

Property Value

Type: Int32
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.FontStyle Property

PainterFontStyle Property
Gets or sets font style of the device context currently associated with the Painter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FontStyle FontStyle { get; set; }
Public Overridable Property FontStyle As FontStyle
    Get
    Set
public:
virtual property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract FontStyle : FontStyle with get, set
override FontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.FontWidth Property

PainterFontWidth Property
Represents width of the font of the device context currently associated with the Painter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FontWidth { get; }
Public Overridable ReadOnly Property FontWidth As Integer
    Get
public:
virtual property int FontWidth {
    int get ();
}
abstract FontWidth : int with get
override FontWidth : int with get

Property Value

Type: Int32
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.ForeColor Property

PainterForeColor Property
Gets or sets foreground color of the device context currently associated with the Painter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ForeColor { get; set; }
Public Overridable Property ForeColor As Color
    Get
    Set
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set
override ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.IsMonoSpaced Property

PainterIsMonoSpaced Property
Represents a value indicating whether font of the device context currently associated with this Painter is monospaced, meaning that all characters drawn with this font have the same width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsMonoSpaced { get; set; }
Public Overridable Property IsMonoSpaced As Boolean
    Get
    Set
public:
virtual property bool IsMonoSpaced {
    bool get ();
    void set (bool value);
}
abstract IsMonoSpaced : bool with get, set
override IsMonoSpaced : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.LineHeight Property

PainterLineHeight Property
When implemented by a class, represents height of the individual lines.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LineHeight { get; }
Public Overridable ReadOnly Property LineHeight As Integer
    Get
public:
virtual property int LineHeight {
    int get ();
}
abstract LineHeight : int with get
override LineHeight : int with get

Property Value

Type: Int32
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.LineSpace Property

PainterLineSpace Property
Represents additional height added to the height of the font.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LineSpace { get; set; }
Public Overridable Property LineSpace As Integer
    Get
    Set
public:
virtual property int LineSpace {
    int get ();
    void set (int value);
}
abstract LineSpace : int with get, set
override LineSpace : int with get, set

Property Value

Type: Int32
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.Opaque Property

PainterOpaque Property
Gets or sets a boolean value indicating that background is filled with the current background color before the text is drawn.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Opaque { get; set; }
Public Overridable Property Opaque As Boolean
    Get
    Set
public:
virtual property bool Opaque {
    bool get ();
    void set (bool value);
}
abstract Opaque : bool with get, set
override Opaque : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.StringFormat Property

PainterStringFormat Property
Encapsulates text layout information and display manipulations for this Painter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual StringFormat StringFormat { get; set; }
Public Overridable Property StringFormat As StringFormat
    Get
    Set
public:
virtual property StringFormat^ StringFormat {
    StringFormat^ get ();
    void set (StringFormat^ value);
}
abstract StringFormat : StringFormat with get, set
override StringFormat : StringFormat with get, set

Property Value

Type: StringFormat
See Also

Reference

Painter Class
Alternet.Common Namespace


Painter.TextColor Property

PainterTextColor Property
Gets or sets text color of the device context currently associated with the Painter.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color TextColor { get; set; }
Public Overridable Property TextColor As Color
    Get
    Set
public:
virtual property Color TextColor {
    Color get ();
    void set (Color value);
}
abstract TextColor : Color with get, set
override TextColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Painter Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType) Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType Class
Represents a base class holds various resources used in drawing surfaces. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType
Alternet.Scripter.Debugger.UI.DataTips.PaintingDataTipPainter

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PainterResources<TBrushType, TPenType, TImageType, TImageListType, TTextStyleType> : IDisposable

Public MustInherit Class PainterResources(Of TBrushType, TPenType, TImageType, TImageListType, TTextStyleType)
    Implements IDisposable
generic<typename TBrushType, typename TPenType, typename TImageType, typename TImageListType, typename TTextStyleType>
public ref class PainterResources abstract : IDisposable
[<AbstractClassAttribute>]
type PainterResources<'TBrushType, 'TPenType, 'TImageType, 'TImageListType, 'TTextStyleType> =
    class
        interface IDisposable
    end

Type Parameters

TBrushType
Type of System.Drawing.Brush resources stored in this class.
TPenType
Type of System.Drawing.Pen resources stored in this class.
TImageType
Type of System.Drawing.Image resources stored in this class.
TImageListType
Type of ImageListEx resources stored in this class.
TTextStyleType
Type of TextStyle resources stored in this class.

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this PainterResources and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrush | Finds stored Brush object accordingly to the specified type or creates a new one if necessary.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Finds stored Image object accordingly to the specified type or creates a new one if necessary.
Public method | GetImageList | Finds stored ImageList object accordingly to the specified type or creates a new one if necessary.
Public method | GetPen | Finds stored Pen object accordingly to the specified type or creates a new one if necessary.
Public method | GetTextStyle | Finds stored text style object accordingly to the specified type or creates a new one if necessary.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType) Methods

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType Methods

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this PainterResources and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrush | Finds stored Brush object accordingly to the specified type or creates a new one if necessary.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Finds stored Image object accordingly to the specified type or creates a new one if necessary.
Public method | GetImageList | Finds stored ImageList object accordingly to the specified type or creates a new one if necessary.
Public method | GetPen | Finds stored Pen object accordingly to the specified type or creates a new one if necessary.
Public method | GetTextStyle | Finds stored text style object accordingly to the specified type or creates a new one if necessary.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).Dispose Method

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeDispose Method
Disposes this PainterResources and frees resources associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).GetBrush Method

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeGetBrush Method
Finds stored Brush object accordingly to the specified type or creates a new one if necessary.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Brush GetBrush(
    TBrushType type
)
Public Function GetBrush (
    type As TBrushType
) As Brush
public:
Brush^ GetBrush(
    TBrushType type
)
member GetBrush :
        type : 'TBrushType -> Brush

Parameters

type
Type: TBrushType
Type of Brush to probe.

Return Value

Type: Brush
Stored Brush object.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).GetImage Method

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeGetImage Method
Finds stored Image object accordingly to the specified type or creates a new one if necessary.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image GetImage(
    TImageType type
)
Public Function GetImage (
    type As TImageType
) As Image
public:
Image^ GetImage(
    TImageType type
)
member GetImage :
        type : 'TImageType -> Image

Parameters

type
Type: TImageType
Type of Image to probe.

Return Value

Type: Image
Stored Image object.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).GetImageList Method

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeGetImageList Method
Finds stored ImageList object accordingly to the specified type or creates a new one if necessary.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphaImageList GetImageList(
    TImageListType type
)
Public Function GetImageList (
    type As TImageListType
) As AlphaImageList
public:
AlphaImageList^ GetImageList(
    TImageListType type
)
member GetImageList :
        type : 'TImageListType -> AlphaImageList

Parameters

type
Type: TImageListType
Type of ImageList to probe.

Return Value

Type: AlphaImageList
Stored ImageList object.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).GetPen Method

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeGetPen Method
Finds stored Pen object accordingly to the specified type or creates a new one if necessary.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Pen GetPen(
    TPenType type
)
Public Function GetPen (
    type As TPenType
) As Pen
public:
Pen^ GetPen(
    TPenType type
)
member GetPen :
        type : 'TPenType -> Pen

Parameters

type
Type: TPenType
Type of Pen to probe.

Return Value

Type: Pen
Stored Pen object.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).GetTextStyle Method

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeGetTextStyle Method
Finds stored text style object accordingly to the specified type or creates a new one if necessary.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle GetTextStyle(
    TTextStyleType type
)
Public Function GetTextStyle (
    type As TTextStyleType
) As PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle
public:
PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle^ GetTextStyle(
    TTextStyleType type
)
member GetTextStyle :
        type : 'TTextStyleType -> PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle

Parameters

type
Type: TTextStyleType
Type of text style to probe.

Return Value

Type: PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle
Stored text style object.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).BrushDescription Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription Class
Provides a base class for brush resource description. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription TBrushType
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class BrushDescription : PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<TBrushType>
Public MustInherit Class BrushDescription
    Inherits PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription(Of TBrushType)
public ref class BrushDescription abstract : public PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<TBrushType>
[<AbstractClassAttribute>]
type BrushDescription =
    class
        inherit PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<'TBrushType>
    end

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common Namespace


BrushDescription Methods

BrushDescription Methods

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).EmbeddedResourceDescription(TType) Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType Class
Represents a base class contains embedded resource description.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription TType
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EmbeddedResourceDescription<TType> : PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<TType>

Public Class EmbeddedResourceDescription(Of TType)
    Inherits PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription(Of TType)
generic<typename TType>
public ref class EmbeddedResourceDescription : public PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<TType>
type EmbeddedResourceDescription<'TType> =
    class
        inherit PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<'TType>
    end

Type Parameters

TType
Type of object used as resource.

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType generic type exposes the following members.

Constructors
 | Name | Description
Public method | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType | Initializes a new instance of the EmbeddedResourceDescription class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Assembly | Gets an assembly where this resource stored.
Public property | ResourceName | Gets a name of the resource.
Top
See Also

Reference

Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).EmbeddedResourceDescription(TType) Constructor

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType Constructor
Initializes a new instance of the EmbeddedResourceDescription class with specified settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmbeddedResourceDescription(
    Assembly assembly,
    string resourceName
)
Public Sub New (
    assembly As Assembly,
    resourceName As String
)
public:
EmbeddedResourceDescription(
    Assembly^ assembly,
    String^ resourceName
)
new :
        assembly : Assembly *
        resourceName : string -> EmbeddedResourceDescription

Parameters

assembly
Type: System.ReflectionAssembly
An assembly where this resource stored.
resourceName
Type: SystemString
Name of the resource.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType Class
Alternet.Common Namespace


EmbeddedResourceDescription(TType) Methods

EmbeddedResourceDescriptionTType Methods

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType Class
Alternet.Common Namespace


EmbeddedResourceDescription(TType) Properties

EmbeddedResourceDescriptionTType Properties

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType generic type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets an assembly where this resource stored.
Public property | ResourceName | Gets a name of the resource.
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).EmbeddedResourceDescription(TType).Assembly Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTTypeAssembly Property
Gets an assembly where this resource stored.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Assembly Assembly { get; }
Public ReadOnly Property Assembly As Assembly
    Get
public:
property Assembly^ Assembly {
    Assembly^ get ();
}
member Assembly : Assembly with get

Property Value

Type: Assembly
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).EmbeddedResourceDescription(TType).ResourceName Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTTypeResourceName Property
Gets a name of the resource.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ResourceName { get; }
Public ReadOnly Property ResourceName As String
    Get
public:
property String^ ResourceName {
    String^ get ();
}
member ResourceName : string with get

Property Value

Type: String
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).ImageDescription Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription Class
Provides an embedded resource description for image objects.
Inheritance Hierarchy
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageType
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageDescription : PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription<TImageType>
Public Class ImageDescription
    Inherits PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription(Of TImageType)
public ref class ImageDescription : public PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription<TImageType>
type ImageDescription =
    class
        inherit PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription<'TImageType>
    end

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription generic type exposes the following members.

Constructors
 | Name | Description
Public method | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription | Initializes a new instance of the ImageDescription class with specified settings.
Top
Properties
 | Name | Description
Public property | Assembly | Gets an assembly where this resource stored. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageType .)
Public property | ResourceName | Gets a name of the resource. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageType .)
Top
See Also

Reference

Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).ImageDescription Constructor

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription Constructor
Initializes a new instance of the ImageDescription class with specified settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageDescription(
    Assembly assembly,
    string resourceName
)
Public Sub New (
    assembly As Assembly,
    resourceName As String
)
public:
ImageDescription(
    Assembly^ assembly,
    String^ resourceName
)
new :
        assembly : Assembly *
        resourceName : string -> ImageDescription

Parameters

assembly
Type: System.ReflectionAssembly
An assembly where this resource stored.
resourceName
Type: SystemString
Name of the resource.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription Class
Alternet.Common Namespace


ImageDescription Properties

ImageDescription Properties

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets an assembly where this resource stored. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageType .)
Public property | ResourceName | Gets a name of the resource. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageType .)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).ImageListDescription Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription Class
Provides an embedded resource description for image list objects.
Inheritance Hierarchy
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageListType
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageListDescription : PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription<TImageListType>
Public Class ImageListDescription
    Inherits PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription(Of TImageListType)
public ref class ImageListDescription : public PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription<TImageListType>
type ImageListDescription =
    class
        inherit PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription<'TImageListType>
    end

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription generic type exposes the following members.

Constructors
 | Name | Description
Public method | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription | Initializes a new instance of the ImageListDescription class with specified settings.
Top
Properties
 | Name | Description
Public property | Assembly | Gets an assembly where this resource stored. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageListType .)
Public property | ResourceName | Gets a name of the resource. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageListType .)
Top
See Also

Reference

Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).ImageListDescription Constructor

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription Constructor
Initializes a new instance of the ImageListDescription class with specified settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageListDescription(
    Assembly assembly,
    string resourceName
)
Public Sub New (
    assembly As Assembly,
    resourceName As String
)
public:
ImageListDescription(
    Assembly^ assembly,
    String^ resourceName
)
new :
        assembly : Assembly *
        resourceName : string -> ImageListDescription

Parameters

assembly
Type: System.ReflectionAssembly
An assembly where this resource stored.
resourceName
Type: SystemString
Name of the resource.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription Class
Alternet.Common Namespace


ImageListDescription Properties

ImageListDescription Properties

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets an assembly where this resource stored. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageListType .)
Public property | ResourceName | Gets a name of the resource. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescription TImageListType .)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeImageListDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).PenDescription Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription Class
Provides a base class for pen resource description. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription TPenType
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PenDescription : PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<TPenType>
Public MustInherit Class PenDescription
    Inherits PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription(Of TPenType)
public ref class PenDescription abstract : public PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<TPenType>
[<AbstractClassAttribute>]
type PenDescription =
    class
        inherit PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<'TPenType>
    end

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Width | Gets the width of this pen object, in units of the System.Drawing.Graphics object used for drawing.
Top
See Also

Reference

Alternet.Common Namespace


PenDescription Methods

PenDescription Methods

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription Class
Alternet.Common Namespace


PenDescription Properties

PenDescription Properties

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription type exposes the following members.

Properties
 | Name | Description
Public property | Width | Gets the width of this pen object, in units of the System.Drawing.Graphics object used for drawing.
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).PenDescription.Width Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescriptionWidth Property
Gets the width of this pen object, in units of the System.Drawing.Graphics object used for drawing.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
public:
property int Width {
    int get ();
}
member Width : int with get

Property Value

Type: Int32
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).ResourceDescription(TType) Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescriptionTType Class
Represents a base class contains resource description. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescriptionTType
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeEmbeddedResourceDescriptionTType
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ResourceDescription<TType>

Public MustInherit Class ResourceDescription(Of TType)
generic<typename TType>
public ref class ResourceDescription abstract
[<AbstractClassAttribute>]
type ResourceDescription<'TType> =  class end

Type Parameters

TType
Type of object used as resource.

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescriptionTType generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common Namespace


ResourceDescription(TType) Methods

ResourceDescriptionTType Methods

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescriptionTType generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescriptionTType Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).SolidBrushDescription Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription Class
Provides a resource description for brush objects.
Inheritance Hierarchy
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SolidBrushDescription : PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription
Public Class SolidBrushDescription
    Inherits PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription
public ref class SolidBrushDescription : public PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription
type SolidBrushDescription =
    class
        inherit PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeBrushDescription
    end

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription generic type exposes the following members.

Constructors
 | Name | Description
Public method | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription | Initializes a new instance of the SolidBrushDescription class with specified settings.
Top
Properties
 | Name | Description
Public property | Color | Gets the color of this brush object.
Top
See Also

Reference

Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).SolidBrushDescription Constructor

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription Constructor
Initializes a new instance of the SolidBrushDescription class with specified settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidBrushDescription(
    Color color
)
Public Sub New (
    color As Color
)
public:
SolidBrushDescription(
    Color color
)
new :
        color : Color -> SolidBrushDescription

Parameters

color
Type: System.DrawingColor
The color of this brush object.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription Class
Alternet.Common Namespace


SolidBrushDescription Properties

SolidBrushDescription Properties

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription type exposes the following members.

Properties
 | Name | Description
Public property | Color | Gets the color of this brush object.
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).SolidBrushDescription.Color Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescriptionColor Property
Gets the color of this brush object.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color Color {
    Color get ();
}
member Color : Color with get

Property Value

Type: Color
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidBrushDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).SolidPenDescription Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription Class
Provides a resource description for pen objects.
Inheritance Hierarchy
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SolidPenDescription : PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription
Public Class SolidPenDescription
    Inherits PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription
public ref class SolidPenDescription : public PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription
type SolidPenDescription =
    class
        inherit PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription
    end

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription generic type exposes the following members.

Constructors
 | Name | Description
Public method | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription | Initializes a new instance of the SolidPenDescription class with specified settings.
Top
Properties
 | Name | Description
Public property | Color | Gets the color of this pen object.
Public property | Width | Gets the width of this pen object, in units of the System.Drawing.Graphics object used for drawing. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription.)
Top
See Also

Reference

Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).SolidPenDescription Constructor

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription Constructor
Initializes a new instance of the SolidPenDescription class with specified settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidPenDescription(
    Color color,
    int width
)
Public Sub New (
    color As Color,
    width As Integer
)
public:
SolidPenDescription(
    Color color,
    int width
)
new :
        color : Color *
        width : int -> SolidPenDescription

Parameters

color
Type: System.DrawingColor
The color of this pen object.
width
Type: SystemInt32
The width of this pen object, in units of the System.Drawing.Graphics object used for drawing.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription Class
Alternet.Common Namespace


SolidPenDescription Properties

SolidPenDescription Properties

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription type exposes the following members.

Properties
 | Name | Description
Public property | Color | Gets the color of this pen object.
Public property | Width | Gets the width of this pen object, in units of the System.Drawing.Graphics object used for drawing. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypePenDescription.)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).SolidPenDescription.Color Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescriptionColor Property
Gets the color of this pen object.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color Color {
    Color get ();
}
member Color : Color with get

Property Value

Type: Color
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeSolidPenDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyle Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle Class
Represents a particular text style.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TextStyle
Public NotInheritable Class TextStyle
public ref class TextStyle sealed
[<SealedAttribute>]
type TextStyle =  class end

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle generic type exposes the following members.

Constructors
 | Name | Description
Public method | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle | Initializes a new instance of the TextStyle class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Font | Gets System.Drawing.Font associated with this TextStyle.
Public property | ForeColor | Gets System.Drawing.Color associated with this TextStyle.
Top
See Also

Reference

Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyle Constructor

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle Constructor
Initializes a new instance of the TextStyle class with specified settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextStyle(
    Font font,
    Color foreColor
)
Public Sub New (
    font As Font,
    foreColor As Color
)
public:
TextStyle(
    Font^ font,
    Color foreColor
)
new :
        font : Font *
        foreColor : Color -> TextStyle

Parameters

font
Type: System.DrawingFont
Font associated with this new object.
foreColor
Type: System.DrawingColor
Fore color associated with this new object.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle Class
Alternet.Common Namespace


TextStyle Methods

TextStyle Methods

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle Class
Alternet.Common Namespace


TextStyle Properties

TextStyle Properties

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle type exposes the following members.

Properties
 | Name | Description
Public property | Font | Gets System.Drawing.Font associated with this TextStyle.
Public property | ForeColor | Gets System.Drawing.Color associated with this TextStyle.
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyle.Font Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleFont Property
Gets System.Drawing.Font associated with this TextStyle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Font Font { get; }
Public ReadOnly Property Font As Font
    Get
public:
property Font^ Font {
    Font^ get ();
}
member Font : Font with get

Property Value

Type: Font
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyle.ForeColor Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleForeColor Property
Gets System.Drawing.Color associated with this TextStyle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ForeColor { get; }
Public ReadOnly Property ForeColor As Color
    Get
public:
property Color ForeColor {
    Color get ();
}
member ForeColor : Color with get

Property Value

Type: Color
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyle Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyleDescription Class

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription Class
Provides an embedded resource description for text style objects.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription TTextStyleType
Alternet.CommonPainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextStyleDescription : PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<TTextStyleType>
Public Class TextStyleDescription
    Inherits PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription(Of TTextStyleType)
public ref class TextStyleDescription : public PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<TTextStyleType>
type TextStyleDescription =
    class
        inherit PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeResourceDescription<'TTextStyleType>
    end

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription generic type exposes the following members.

Constructors
 | Name | Description
Public method | PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription | Initializes a new instance of the TextStyleDescription class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EmSize | Gets the em-size of the font associated with this text style.
Public property | FamilyName | Gets the FontFamily name associated with this text style.
Public property | ForeColor | Gets the Color associated with this text style.
Public property | Style | Gets the FontStyle associated with this text style.
Top
See Also

Reference

Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyleDescription Constructor

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription Constructor
Initializes a new instance of the TextStyleDescription class with specified settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextStyleDescription(
    FontFamily familyName,
    float emSize,
    FontStyle style,
    Color foreColor
)
Public Sub New (
    familyName As FontFamily,
    emSize As Single,
    style As FontStyle,
    foreColor As Color
)
public:
TextStyleDescription(
    FontFamily^ familyName,
    float emSize,
    FontStyle style,
    Color foreColor
)
new :
        familyName : FontFamily *
        emSize : float32 *
        style : FontStyle *
        foreColor : Color -> TextStyleDescription

Parameters

familyName
Type: System.DrawingFontFamily
The FontFamily name associated with this text style.
emSize
Type: SystemSingle
The em-size of the font associated with this text style.
style
Type: System.DrawingFontStyle
The FontStyle associated with this text style.
foreColor
Type: System.DrawingColor
The fore color associated with this text style.
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription Class
Alternet.Common Namespace


TextStyleDescription Methods

TextStyleDescription Methods

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription Class
Alternet.Common Namespace


TextStyleDescription Properties

TextStyleDescription Properties

The PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription type exposes the following members.

Properties
 | Name | Description
Public property | EmSize | Gets the em-size of the font associated with this text style.
Public property | FamilyName | Gets the FontFamily name associated with this text style.
Public property | ForeColor | Gets the Color associated with this text style.
Public property | Style | Gets the FontStyle associated with this text style.
Top
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyleDescription.EmSize Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescriptionEmSize Property
Gets the em-size of the font associated with this text style.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public float EmSize { get; }
Public ReadOnly Property EmSize As Single
    Get
public:
property float EmSize {
    float get ();
}
member EmSize : float32 with get

Property Value

Type: Single
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyleDescription.FamilyName Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescriptionFamilyName Property
Gets the FontFamily name associated with this text style.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontFamily FamilyName { get; }
Public ReadOnly Property FamilyName As FontFamily
    Get
public:
property FontFamily^ FamilyName {
    FontFamily^ get ();
}
member FamilyName : FontFamily with get

Property Value

Type: FontFamily
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyleDescription.ForeColor Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescriptionForeColor Property
Gets the Color associated with this text style.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ForeColor { get; }
Public ReadOnly Property ForeColor As Color
    Get
public:
property Color ForeColor {
    Color get ();
}
member ForeColor : Color with get

Property Value

Type: Color
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription Class
Alternet.Common Namespace


PainterResources(TBrushType, TPenType, TImageType, TImageListType, TTextStyleType).TextStyleDescription.Style Property

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescriptionStyle Property
Gets the FontStyle associated with this text style.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontStyle Style { get; }
Public ReadOnly Property Style As FontStyle
    Get
public:
property FontStyle Style {
    FontStyle get ();
}
member Style : FontStyle with get

Property Value

Type: FontStyle
See Also

Reference

PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleTypeTextStyleDescription Class
Alternet.Common Namespace


PathUtilities Class

PathUtilities Class
An utility class for computing relative paths.
Inheritance Hierarchy
SystemObject
Alternet.CommonPathUtilities

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PathUtilities
Public NotInheritable Class PathUtilities
public ref class PathUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PathUtilities =  class end

The PathUtilities type exposes the following members.

Methods
Name | Description
GetExactPath |
GetFileNameWithoutAllExtensions | Removes all extensions from the path, i.e "aaa.png.zip" -> "aaa"
IsPathFullyQualified |
IsPathPartiallyQualified |
MakeRelativePath | Creates a relative path from one file or folder to another.
NormalizePathSeparators | Replaces alternative separators by regular ones in given path.
TryGetExactPath | Gets the exact case used on the file system for an existing file or directory.
Top
See Also

Reference

Alternet.Common Namespace


PathUtilities Methods

PathUtilities Methods

The PathUtilities type exposes the following members.

Methods
Name | Description
GetExactPath |
GetFileNameWithoutAllExtensions | Removes all extensions from the path, i.e "aaa.png.zip" -> "aaa"
IsPathFullyQualified |
IsPathPartiallyQualified |
MakeRelativePath | Creates a relative path from one file or folder to another.
NormalizePathSeparators | Replaces alternative separators by regular ones in given path.
TryGetExactPath | Gets the exact case used on the file system for an existing file or directory.
Top
See Also

Reference

PathUtilities Class
Alternet.Common Namespace


PathUtilities.GetExactPath Method

PathUtilitiesGetExactPath Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetExactPath(
    string path
)
Public Shared Function GetExactPath (
    path As String
) As String
public:
static String^ GetExactPath(
    String^ path
)
static member GetExactPath :
        path : string -> string

Parameters

path
Type: SystemString

Return Value

Type: String
See Also

Reference

PathUtilities Class
Alternet.Common Namespace


PathUtilities.GetFileNameWithoutAllExtensions Method

PathUtilitiesGetFileNameWithoutAllExtensions Method
Removes all extensions from the path, i.e "aaa.png.zip" -> "aaa"

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFileNameWithoutAllExtensions(
    string path
)
Public Shared Function GetFileNameWithoutAllExtensions (
    path As String
) As String
public:
static String^ GetFileNameWithoutAllExtensions(
    String^ path
)
static member GetFileNameWithoutAllExtensions :
        path : string -> string

Parameters

path
Type: SystemString

Return Value

Type: String
See Also

Reference

PathUtilities Class
Alternet.Common Namespace


PathUtilities.IsPathFullyQualified Method

PathUtilitiesIsPathFullyQualified Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsPathFullyQualified(
    string path
)
Public Shared Function IsPathFullyQualified (
    path As String
) As Boolean
public:
static bool IsPathFullyQualified(
    String^ path
)
static member IsPathFullyQualified :
        path : string -> bool

Parameters

path
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

PathUtilities Class
Alternet.Common Namespace


PathUtilities.IsPathPartiallyQualified Method

PathUtilitiesIsPathPartiallyQualified Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsPathPartiallyQualified(
    string path
)
Public Shared Function IsPathPartiallyQualified (
    path As String
) As Boolean
public:
static bool IsPathPartiallyQualified(
    String^ path
)
static member IsPathPartiallyQualified :
        path : string -> bool

Parameters

path
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

PathUtilities Class
Alternet.Common Namespace


PathUtilities.MakeRelativePath Method

PathUtilitiesMakeRelativePath Method
Creates a relative path from one file or folder to another.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MakeRelativePath(
    string fromPath,
    string toPath
)
Public Shared Function MakeRelativePath (
    fromPath As String,
    toPath As String
) As String
public:
static String^ MakeRelativePath(
    String^ fromPath,
    String^ toPath
)
static member MakeRelativePath :
        fromPath : string *
        toPath : string -> string

Parameters

fromPath
Type: SystemString
Contains the directory that defines the start of the relative path.
toPath
Type: SystemString
Contains the path that defines the endpoint of the relative path.

Return Value

Type: String
The relative path from the start directory to the end path or toPath if the paths are not related.
Exceptions
Exception | Condition
ArgumentNullException | fromPath or toPath is null.
UriFormatException | The URI is incorrectly formed.
InvalidOperationException | This instance represents a relative URI, and this property is valid only for absolute URIs.
See Also

Reference

PathUtilities Class
Alternet.Common Namespace


PathUtilities.NormalizePathSeparators Method

PathUtilitiesNormalizePathSeparators Method
Replaces alternative separators by regular ones in given path.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NormalizePathSeparators(
    string inputPath
)
Public Shared Function NormalizePathSeparators (
    inputPath As String
) As String
public:
static String^ NormalizePathSeparators(
    String^ inputPath
)
static member NormalizePathSeparators :
        inputPath : string -> string

Parameters

inputPath
Type: SystemString
Source path to probe.

Return Value

Type: String
Normalized path.
See Also

Reference

PathUtilities Class
Alternet.Common Namespace


PathUtilities.TryGetExactPath Method

PathUtilitiesTryGetExactPath Method
Gets the exact case used on the file system for an existing file or directory.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool TryGetExactPath(
    string path,
    out string exactPath
)
Public Shared Function TryGetExactPath (
    path As String,
    <OutAttribute> ByRef exactPath As String
) As Boolean
public:
static bool TryGetExactPath(
    String^ path,
    [OutAttribute] String^% exactPath
)
static member TryGetExactPath :
        path : string *
        exactPath : string byref -> bool

Parameters

path
Type: SystemString
A relative or absolute path.
exactPath
Type: SystemString
The full path using the correct case if the path exists. Otherwise, null.

Return Value

Type: Boolean
True if the exact path was found. False otherwise.
Remarks
This supports drive-lettered paths and UNC paths, but a UNC root will be returned in title case (e.g., \\Server\Share).
See Also

Reference

PathUtilities Class
Alternet.Common Namespace


ProcessUtilities Class

ProcessUtilities Class
Inheritance Hierarchy
SystemObject
Alternet.CommonProcessUtilities

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ProcessUtilities
<ExtensionAttribute>
Public NotInheritable Class ProcessUtilities
[ExtensionAttribute]
public ref class ProcessUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type ProcessUtilities =  class end

The ProcessUtilities type exposes the following members.

Methods
Name | Description
Is64BitProcess |
IsProcessManaged |
Top
See Also

Reference

Alternet.Common Namespace


ProcessUtilities Methods

ProcessUtilities Methods

The ProcessUtilities type exposes the following members.

Methods
Name | Description
Is64BitProcess |
IsProcessManaged |
Top
See Also

Reference

ProcessUtilities Class
Alternet.Common Namespace


ProcessUtilities.Is64BitProcess Method

ProcessUtilitiesIs64BitProcess Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Is64BitProcess(
    this Process process
)
<ExtensionAttribute>
Public Shared Function Is64BitProcess (
    process As Process
) As Boolean
public:
[ExtensionAttribute]
static bool Is64BitProcess(
    Process^ process
)
[<ExtensionAttribute>]
static member Is64BitProcess :
        process : Process -> bool

Parameters

process
Type: System.DiagnosticsProcess

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Process. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProcessUtilities Class
Alternet.Common Namespace


ProcessUtilities.IsProcessManaged Method

ProcessUtilitiesIsProcessManaged Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsProcessManaged(
    Process process
)
Public Shared Function IsProcessManaged (
    process As Process
) As Boolean
public:
static bool IsProcessManaged(
    Process^ process
)
static member IsProcessManaged :
        process : Process -> bool

Parameters

process
Type: System.DiagnosticsProcess

Return Value

Type: Boolean
See Also

Reference

ProcessUtilities Class
Alternet.Common Namespace


ProductInformation Class

ProductInformation Class
Represent information about AlterNET product.
Inheritance Hierarchy
SystemObject
Alternet.CommonProductInformation

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ProductInformation
Public NotInheritable Class ProductInformation
public ref class ProductInformation abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ProductInformation =  class end

The ProductInformation type exposes the following members.

Properties
Name | Description
ProductVersion | Gets System.Version info of the product.
Top
See Also

Reference

Alternet.Common Namespace


ProductInformation Properties

ProductInformation Properties

The ProductInformation type exposes the following members.

Properties
Name | Description
ProductVersion | Gets System.Version info of the product.
Top
See Also

Reference

ProductInformation Class
Alternet.Common Namespace


ProductInformation.ProductVersion Property

ProductInformationProductVersion Property
Gets System.Version info of the product.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Version ProductVersion { get; }
Public Shared ReadOnly Property ProductVersion As Version
    Get
public:
static property Version^ ProductVersion {
    Version^ get ();
}
static member ProductVersion : Version with get

Property Value

Type: Version
See Also

Reference

ProductInformation Class
Alternet.Common Namespace


ProgressDialog Class

ProgressDialog Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.CommonProgressDialog

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProgressDialog : Form
Public Class ProgressDialog
    Inherits Form
public ref class ProgressDialog : public Form
type ProgressDialog =
    class
        inherit Form
    end

The ProgressDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressDialog | Initializes a new instance of the ProgressDialog class
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ReportProgress |
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | Message |
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Progress |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Common Namespace


ProgressDialog Constructor

ProgressDialog Constructor
Initializes a new instance of the ProgressDialog class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProgressDialog()
Public Sub New
public:
ProgressDialog()
new : unit -> ProgressDialog
See Also

Reference

ProgressDialog Class
Alternet.Common Namespace


ProgressDialog Methods

ProgressDialog Methods

The ProgressDialog type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ReportProgress |
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

ProgressDialog Class
Alternet.Common Namespace


ProgressDialog.ReportProgress Method

ProgressDialogReportProgress Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReportProgress(
    double value
)
Public Sub ReportProgress (
    value As Double
)
public:
void ReportProgress(
    double value
)
member ReportProgress :
        value : float -> unit

Parameters

value
Type: SystemDouble
See Also

Reference

ProgressDialog Class
Alternet.Common Namespace


ProgressDialog Properties

ProgressDialog Properties

The ProgressDialog type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | Message |
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Progress |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ProgressDialog Class
Alternet.Common Namespace


ProgressDialog.Message Property

ProgressDialogMessage Property

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

ProgressDialog Class
Alternet.Common Namespace


ProgressDialog.Progress Property

ProgressDialogProgress Property

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IProgress<double> Progress { get; }
Public ReadOnly Property Progress As IProgress(Of Double)
    Get
public:
property IProgress<double>^ Progress {
    IProgress<double>^ get ();
}
member Progress : IProgress<float> with get

Property Value

Type: IProgressDouble
See Also

Reference

ProgressDialog Class
Alternet.Common Namespace


ProgressDialog Events

ProgressDialog Events

The ProgressDialog type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ProgressDialog Class
Alternet.Common Namespace


PropertyChangedEventArgs(T) Class

PropertyChangedEventArgsT Class
Provides data for the ISyntaxEdit.SourceChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.CommonPropertyChangedEventArgsT

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PropertyChangedEventArgs<T> : EventArgs

Public Class PropertyChangedEventArgs(Of T)
    Inherits EventArgs
generic<typename T>
public ref class PropertyChangedEventArgs : public EventArgs
type PropertyChangedEventArgs<'T> =
    class
        inherit EventArgs
    end

Type Parameters

T

The PropertyChangedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyChangedEventArgsT | Initializes a new instance of the PropertyChangedEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | NewValue | Gets new property value.
Public property | OldValue | Gets old property value.
Top
See Also

Reference

Alternet.Common Namespace


PropertyChangedEventArgs(T) Constructor

PropertyChangedEventArgsT Constructor
Initializes a new instance of the PropertyChangedEventArgs class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyChangedEventArgs(
    T oldValue,
    T newValue
)
Public Sub New (
    oldValue As T,
    newValue As T
)
public:
PropertyChangedEventArgs(
    T oldValue,
    T newValue
)
new :
        oldValue : 'T *
        newValue : 'T -> PropertyChangedEventArgs

Parameters

oldValue
Type: T
Old property value.
newValue
Type: T
New property value.
See Also

Reference

PropertyChangedEventArgsT Class
Alternet.Common Namespace


PropertyChangedEventArgs(T) Methods

PropertyChangedEventArgsT Methods

The PropertyChangedEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyChangedEventArgsT Class
Alternet.Common Namespace


PropertyChangedEventArgs(T) Properties

PropertyChangedEventArgsT Properties

The PropertyChangedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets new property value.
Public property | OldValue | Gets old property value.
Top
See Also

Reference

PropertyChangedEventArgsT Class
Alternet.Common Namespace


PropertyChangedEventArgs(T).NewValue Property

PropertyChangedEventArgsTNewValue Property
Gets new property value.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public T NewValue { get; }
Public ReadOnly Property NewValue As T
    Get
public:
property T NewValue {
    T get ();
}
member NewValue : 'T with get

Property Value

Type: T
See Also

Reference

PropertyChangedEventArgsT Class
Alternet.Common Namespace


PropertyChangedEventArgs(T).OldValue Property

PropertyChangedEventArgsTOldValue Property
Gets old property value.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public T OldValue { get; }
Public ReadOnly Property OldValue As T
    Get
public:
property T OldValue {
    T get ();
}
member OldValue : 'T with get

Property Value

Type: T
See Also

Reference

PropertyChangedEventArgsT Class
Alternet.Common Namespace


Range Class

Range Class
Represents an pair of two points that defines a scope in a two-dimensional plane.
Inheritance Hierarchy
SystemObject
Alternet.CommonRange
Alternet.CommonFileRange
Alternet.CommonSortRange
Alternet.Editor.TextSourceCodeSnippetRange
Alternet.SyntaxOutlineRange

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Range : IRange, ICloneable
<SerializableAttribute>
Public Class Range
    Implements IRange, ICloneable
[SerializableAttribute]
public ref class Range : IRange, ICloneable
[<SerializableAttribute>]
type Range =
    class
        interface IRange
        interface ICloneable
    end

The Range type exposes the following members.

Constructors
 | Name | Description
Public method | Range | Initializes a new instance of the Range class with default settings.
Public method | Range(Point, Point) | Initializes a new instance of the Range class with specified parameters.
Public method | Range(Int32, Int32, Int32, Int32) | Initializes a new instance of the Range class with specified parameters.
Top
Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object.
Public method | Clone | Creates a new object that is a copy of the current IRange object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InsideRange(Point, Rectangle) | Indicates whether specified rectangle contains given position.
 | InsideRange(Point, Rectangle, Boolean) | Indicates whether specified rectangle contains given position.
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UpdatePos(Int32, Int32, Int32, Int32, Point, Boolean) | Updates specified position by DeltaX and DeltaY values.
 | UpdatePos(Int32, Int32, Int32, Int32, Int32, Int32, Boolean) | Updates specified position by DeltaX and DeltaY values.
Top
Properties
 | Name | Description
Public property | EndPoint | Gets or sets end of IRange area.
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size.
Public property | Size | Gets or sets size of IRange area.
Public property | StartPoint | Gets or sets begin of IRange area.
Top
See Also

Reference

Alternet.Common Namespace


Range Constructor

Range Constructor
Overload List
 | Name | Description
Public method | Range | Initializes a new instance of the Range class with default settings.
Public method | Range(Point, Point) | Initializes a new instance of the Range class with specified parameters.
Public method | Range(Int32, Int32, Int32, Int32) | Initializes a new instance of the Range class with specified parameters.
Top
See Also

Reference

Range Class
Alternet.Common Namespace


Range Constructor

Range Constructor
Initializes a new instance of the Range class with default settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Range()
Public Sub New
public:
Range()
new : unit -> Range
See Also

Reference

Range Class
Range Overload
Alternet.Common Namespace


Range Constructor (Point, Point)

Range Constructor (Point, Point)
Initializes a new instance of the Range class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Range(
    Point startPoint,
    Point endPoint
)
Public Sub New (
    startPoint As Point,
    endPoint As Point
)
public:
Range(
    Point startPoint,
    Point endPoint
)
new :
        startPoint : Point *
        endPoint : Point -> Range

Parameters

startPoint
Type: System.DrawingPoint
Start of Range area.
endPoint
Type: System.DrawingPoint
End of Range area.
See Also

Reference

Range Class
Range Overload
Alternet.Common Namespace


Range Constructor (Int32, Int32, Int32, Int32)

Range Constructor (Int32, Int32, Int32, Int32)
Initializes a new instance of the Range class with specified parameters.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Range(
    int x1,
    int y1,
    int x2,
    int y2
)
Public Sub New (
    x1 As Integer,
    y1 As Integer,
    x2 As Integer,
    y2 As Integer
)
public:
Range(
    int x1,
    int y1,
    int x2,
    int y2
)
new :
        x1 : int *
        y1 : int *
        x2 : int *
        y2 : int -> Range

Parameters

x1
Type: SystemInt32
X-coordinate of the start of Range area.
y1
Type: SystemInt32
Y-coordinate of the start of Range area.
x2
Type: SystemInt32
X-coordinate of the end of Range area.
y2
Type: SystemInt32
Y-coordinate of the end of Range area.
See Also

Reference

Range Class
Range Overload
Alternet.Common Namespace


Range Methods

Range Methods

The Range type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object.
Public method | Clone | Creates a new object that is a copy of the current IRange object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InsideRange(Point, Rectangle) | Indicates whether specified rectangle contains given position.
 | InsideRange(Point, Rectangle, Boolean) | Indicates whether specified rectangle contains given position.
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UpdatePos(Int32, Int32, Int32, Int32, Point, Boolean) | Updates specified position by DeltaX and DeltaY values.
 | UpdatePos(Int32, Int32, Int32, Int32, Int32, Int32, Boolean) | Updates specified position by DeltaX and DeltaY values.
Top
See Also

Reference

Range Class
Alternet.Common Namespace


Range.Assign Method

RangeAssign Method
Copies contents from another IRange object.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IRange source
)
Public Overridable Sub Assign (
    source As IRange
)
public:
virtual void Assign(
    IRange^ source
)
abstract Assign :
        source : IRange -> unit
override Assign :
        source : IRange -> unit

Parameters

source
Type: Alternet.CommonIRange

Implements

IRangeAssign(IRange)
See Also

Reference

Range Class
Alternet.Common Namespace


Range.Clone Method

RangeClone Method
Creates a new object that is a copy of the current IRange object.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of System.Object that is the memberwise clone of the current SortRange object.

Implements

ICloneableClone
See Also

Reference

Range Class
Alternet.Common Namespace


Range.InsideRange Method

RangeInsideRange Method
Overload List
Name | Description
InsideRange(Point, Rectangle) | Indicates whether specified rectangle contains given position.
InsideRange(Point, Rectangle, Boolean) | Indicates whether specified rectangle contains given position.
Top
See Also

Reference

Range Class
Alternet.Common Namespace


Range.InsideRange Method (Point, Rectangle)

RangeInsideRange Method (Point, Rectangle)
Indicates whether specified rectangle contains given position.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsideRange(
    Point pt,
    Rectangle rect
)
Public Shared Function InsideRange (
    pt As Point,
    rect As Rectangle
) As Boolean
public:
static bool InsideRange(
    Point pt,
    Rectangle rect
)
static member InsideRange :
        pt : Point *
        rect : Rectangle -> bool

Parameters

pt
Type: System.DrawingPoint
Position to check-up.
rect
Type: System.DrawingRectangle
Rectangular area to check-up.

Return Value

Type: Boolean
True if specified rect contains given Point; otherwise false.
See Also

Reference

Range Class
InsideRange Overload
Alternet.Common Namespace


Range.InsideRange Method (Point, Rectangle, Boolean)

RangeInsideRange Method (Point, Rectangle, Boolean)
Indicates whether specified rectangle contains given position.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsideRange(
    Point pt,
    Rectangle rect,
    bool checkMaxInt
)
Public Shared Function InsideRange (
    pt As Point,
    rect As Rectangle,
    checkMaxInt As Boolean
) As Boolean
public:
static bool InsideRange(
    Point pt,
    Rectangle rect,
    bool checkMaxInt
)
static member InsideRange :
        pt : Point *
        rect : Rectangle *
        checkMaxInt : bool -> bool

Parameters

pt
Type: System.DrawingPoint
Position to check-up.
rect
Type: System.DrawingRectangle
Rectangular area to check-up.
checkMaxInt
Type: SystemBoolean
Indicates that rectangle may contain Max Integer coordinates.

Return Value

Type: Boolean
True if specified rect contains given Point; otherwise false.
See Also

Reference

Range Class
InsideRange Overload
Alternet.Common Namespace


Range.ShouldSerializeSize Method

RangeShouldSerializeSize Method
Indicates whether the Size property should be persisted.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeSize()
Public Function ShouldSerializeSize As Boolean
public:
bool ShouldSerializeSize()
member ShouldSerializeSize : unit -> bool

Return Value

Type: Boolean
Always returns false.
See Also

Reference

Range Class
Alternet.Common Namespace


Range.UpdatePos Method

RangeUpdatePos Method
Overload List
Name | Description
UpdatePos(Int32, Int32, Int32, Int32, Point, Boolean) | Updates specified position by DeltaX and DeltaY values.
UpdatePos(Int32, Int32, Int32, Int32, Int32, Int32, Boolean) | Updates specified position by DeltaX and DeltaY values.
Top
See Also

Reference

Range Class
Alternet.Common Namespace


Range.UpdatePos Method (Int32, Int32, Int32, Int32, Point, Boolean)

RangeUpdatePos Method (Int32, Int32, Int32, Int32, Point, Boolean)
Updates specified position by DeltaX and DeltaY values.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool UpdatePos(
    int x,
    int y,
    int deltaX,
    int deltaY,
    ref Point pt,
    bool endPos
)
Public Shared Function UpdatePos (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ByRef pt As Point,
    endPos As Boolean
) As Boolean
public:
static bool UpdatePos(
    int x,
    int y,
    int deltaX,
    int deltaY,
    Point% pt,
    bool endPos
)
static member UpdatePos :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        pt : Point byref *
        endPos : bool -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
pt
Type: System.DrawingPoint
Position to update.
endPos
Type: SystemBoolean
Specifies whether position represents end of range.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

Range Class
UpdatePos Overload
Alternet.Common Namespace


Range.UpdatePos Method (Int32, Int32, Int32, Int32, Int32, Int32, Boolean)

RangeUpdatePos Method (Int32, Int32, Int32, Int32, Int32, Int32, Boolean)
Updates specified position by DeltaX and DeltaY values.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool UpdatePos(
    int x,
    int y,
    int deltaX,
    int deltaY,
    ref int ch,
    ref int ln,
    bool endPos
)
Public Shared Function UpdatePos (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ByRef ch As Integer,
    ByRef ln As Integer,
    endPos As Boolean
) As Boolean
public:
static bool UpdatePos(
    int x,
    int y,
    int deltaX,
    int deltaY,
    int% ch,
    int% ln,
    bool endPos
)
static member UpdatePos :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : int byref *
        ln : int byref *
        endPos : bool -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
ch
Type: SystemInt32
Horizontal constituent of the position to update.
ln
Type: SystemInt32
Vertical constituent of the position to update.
endPos
Type: SystemBoolean
Specifies whether position represents end of range.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

Range Class
UpdatePos Overload
Alternet.Common Namespace


Range Properties

Range Properties

The Range type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets end of IRange area.
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size.
Public property | Size | Gets or sets size of IRange area.
Public property | StartPoint | Gets or sets begin of IRange area.
Top
See Also

Reference

Range Class
Alternet.Common Namespace


Range.EndPoint Property

RangeEndPoint Property
Gets or sets end of IRange area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point EndPoint { get; set; }
Public Overridable Property EndPoint As Point
    Get
    Set
public:
virtual property Point EndPoint {
    Point get ();
    void set (Point value);
}
abstract EndPoint : Point with get, set
override EndPoint : Point with get, set

Property Value

Type: Point

Implements

IRangeEndPoint
See Also

Reference

Range Class
Alternet.Common Namespace


Range.IsEmpty Property

RangeIsEmpty Property
Gets boolean value indicating whether IRange has zero size.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Type: Boolean

Implements

IRangeIsEmpty
See Also

Reference

Range Class
Alternet.Common Namespace


Range.Size Property

RangeSize Property
Gets or sets size of IRange area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size Size { get; set; }
Public Overridable Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get ();
    void set (Size value);
}
abstract Size : Size with get, set
override Size : Size with get, set

Property Value

Type: Size

Implements

IRangeSize
See Also

Reference

Range Class
Alternet.Common Namespace


Range.StartPoint Property

RangeStartPoint Property
Gets or sets begin of IRange area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point StartPoint { get; set; }
Public Overridable Property StartPoint As Point
    Get
    Set
public:
virtual property Point StartPoint {
    Point get ();
    void set (Point value);
}
abstract StartPoint : Point with get, set
override StartPoint : Point with get, set

Property Value

Type: Point

Implements

IRangeStartPoint
See Also

Reference

Range Class
Alternet.Common Namespace


RangeList Class

RangeList Class
Represents sorted list of ranges.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIRange
Alternet.CommonSortList IRange
Alternet.CommonRangeList

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RangeList : SortList<IRange>,
    IRangeList, ISortList<IRange>, IList<IRange>,
    ICollection<IRange>, IEnumerable<IRange>, IEnumerable
Public Class RangeList
    Inherits SortList(Of IRange)
    Implements IRangeList, ISortList(Of IRange),
    IList(Of IRange), ICollection(Of IRange), IEnumerable(Of IRange),
    IEnumerable
public ref class RangeList : public SortList<IRange^>,
    IRangeList, ISortList<IRange^>, IList<IRange^>,
    ICollection<IRange^>, IEnumerable<IRange^>, IEnumerable
type RangeList =
    class
        inherit SortList<IRange>
        interface IRangeList
        interface ISortList<IRange>
        interface IList<IRange>
        interface ICollection<IRange>
        interface IEnumerable<IRange>
        interface IEnumerable
    end

The RangeList type exposes the following members.

Constructors
 | Name | Description
Public method | RangeList | Initializes a new instance of the RangeList class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the range list.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIRange .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIRange .)
Public method | BeginUpdate | Prevents range list updating until calling EndUpdate method.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIRange .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIRange .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIRange .)
Public method | BlockDeleting | Removes all ranges from specified region.
Public method | Clear | Removes all ranges from RangeList.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIRange .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIRange .)
Public method | CopyFrom | Copies specified ranges to this RangeList.
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIRange .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIRange .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIRange .)
Public method | EndUpdate | Re-enables range list updating, that was turn of by calling BeginUpdate method.
Public method | EndUpdate(Boolean) | Re-enables range list updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified RangeList is equal to the current RangeList. (Overrides ObjectEquals(Object).)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIRange .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIRange .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExactRange(Point) | Locates range at specified position and verifies whether it starts at the given position.
Public method | FindExactRange(Int32) | Locates range at specified line and verifies whether it starts at the given line.
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindInclusiveRange | Locates range containing specific line.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIRange .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIRange .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIRange .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIRange .)
Public method | FindRange(Point) | Locates range at specified position.
Public method | FindRange(Int32) | Locates range at specified line.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIRange .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIRange .)
Public method | GetExactRanges | Fills list specified by Ranges parameter with all ranges that starts at the specified line.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIRange .)
Public method | GetRanges | Returns ranges collection in the from of IList.
Public method | GetRanges(IListIRange) | Fills list specified by Ranges parameter with all existing ranges.
Public method | GetRanges(IListIRange, Point) | Fills list specified by Ranges parameter with all ranges containing specific position.
Public method | GetRanges(IListIRange, Int32) |
Public method | GetRanges(IListIRange, Point, Point) | Fills list specified by Ranges parameter with all ranges within specified range.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIRange .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIRange .)
Public method | Insert | Inserts a range into the range list at the specified index.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIRange .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIRange .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIRange .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Updates specified position by DeltaX and DeltaY values for any ranges in the collection.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIRange .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIRange .)
Public method | RemoveAt | Removes the range at the specified index of the RangeList.
Public method | RemoveRange(Point) | Removes all ranges containing specified position.
Public method | RemoveRange(Int32) | Removes all containing specified line.
Public method | RemoveRange(Int32, Int32) | Removes a range of elements from the ListT. (Inherited from ListIRange .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIRange .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIRange .)
Public method | Sort | Sorts RangeList content.
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIRange .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIRange .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIRange .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIRange .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIRange .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIRange .)
Public method | Update | Updates RangeList content.
Public method | UpdatePosition | Updates specified position by DeltaX and DeltaY values for specific IRange.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIRange | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIRange | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIRange, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIRange .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIRange .)
Public property | TopRange | Represents top level range for this list.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

Alternet.Common Namespace


RangeList Constructor

RangeList Constructor
Initializes a new instance of the RangeList class with default settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RangeList()
Public Sub New
public:
RangeList()
new : unit -> RangeList
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList Methods

RangeList Methods

The RangeList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the range list.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIRange .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIRange .)
Public method | BeginUpdate | Prevents range list updating until calling EndUpdate method.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIRange .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIRange .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIRange .)
Public method | BlockDeleting | Removes all ranges from specified region.
Public method | Clear | Removes all ranges from RangeList.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIRange .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIRange .)
Public method | CopyFrom | Copies specified ranges to this RangeList.
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIRange .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIRange .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIRange .)
Public method | EndUpdate | Re-enables range list updating, that was turn of by calling BeginUpdate method.
Public method | EndUpdate(Boolean) | Re-enables range list updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified RangeList is equal to the current RangeList. (Overrides ObjectEquals(Object).)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIRange .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIRange .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExactRange(Point) | Locates range at specified position and verifies whether it starts at the given position.
Public method | FindExactRange(Int32) | Locates range at specified line and verifies whether it starts at the given line.
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindInclusiveRange | Locates range containing specific line.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIRange .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIRange .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIRange .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIRange .)
Public method | FindRange(Point) | Locates range at specified position.
Public method | FindRange(Int32) | Locates range at specified line.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIRange .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIRange .)
Public method | GetExactRanges | Fills list specified by Ranges parameter with all ranges that starts at the specified line.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIRange .)
Public method | GetRanges | Returns ranges collection in the from of IList.
Public method | GetRanges(IListIRange) | Fills list specified by Ranges parameter with all existing ranges.
Public method | GetRanges(IListIRange, Point) | Fills list specified by Ranges parameter with all ranges containing specific position.
Public method | GetRanges(IListIRange, Int32) |
Public method | GetRanges(IListIRange, Point, Point) | Fills list specified by Ranges parameter with all ranges within specified range.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIRange .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIRange .)
Public method | Insert | Inserts a range into the range list at the specified index.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIRange .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIRange .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIRange .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIRange .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Updates specified position by DeltaX and DeltaY values for any ranges in the collection.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIRange .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIRange .)
Public method | RemoveAt | Removes the range at the specified index of the RangeList.
Public method | RemoveRange(Point) | Removes all ranges containing specified position.
Public method | RemoveRange(Int32) | Removes all containing specified line.
Public method | RemoveRange(Int32, Int32) | Removes a range of elements from the ListT. (Inherited from ListIRange .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIRange .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIRange .)
Public method | Sort | Sorts RangeList content.
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIRange .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIRange .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIRange .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIRange .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIRange .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIRange .)
Public method | Update | Updates RangeList content.
Public method | UpdatePosition | Updates specified position by DeltaX and DeltaY values for specific IRange.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIRange | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIRange | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIRange, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.Add Method

RangeListAdd Method
Adds an object to the end of the range list.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Add(
    IRange item
)
Public Function Add (
    item As IRange
) As Integer
public:
int Add(
    IRange^ item
)
member Add :
        item : IRange -> int

Parameters

item
Type: Alternet.CommonIRange
The range to be added to the end of range list.

Return Value

Type: Int32
Index of object that is added.
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.BeginUpdate Method

RangeListBeginUpdate Method
Prevents range list updating until calling EndUpdate method.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BeginUpdate()
Public Function BeginUpdate As Integer
public:
int BeginUpdate()
member BeginUpdate : unit -> int

Return Value

Type: Int32
Number of range list updating locks.
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.BlockDeleting Method

RangeListBlockDeleting Method
Removes all ranges from specified region.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect
)
Public Overridable Function BlockDeleting (
    rect As Rectangle
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool
override BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to remove ranges from.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.Clear Method

RangeListClear Method
Removes all ranges from RangeList.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.CopyFrom Method

RangeListCopyFrom Method
Copies specified ranges to this RangeList.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CopyFrom(
    IList<IRange> ranges
)
Public Sub CopyFrom (
    ranges As IList(Of IRange)
)
public:
void CopyFrom(
    IList<IRange^>^ ranges
)
member CopyFrom :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Source collection of ranges to copy from.
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.EndUpdate Method

RangeListEndUpdate Method
Overload List
 | Name | Description
Public method | EndUpdate | Re-enables range list updating, that was turn of by calling BeginUpdate method.
Public method | EndUpdate(Boolean) | Re-enables range list updating, that was turn of by calling BeginUpdate method.
Top
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.EndUpdate Method

RangeListEndUpdate Method
Re-enables range list updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndUpdate()
Public Function EndUpdate As Integer
public:
int EndUpdate()
member EndUpdate : unit -> int

Return Value

Type: Int32
Number of range list updating locks.
See Also

Reference

RangeList Class
EndUpdate Overload
Alternet.Common Namespace


RangeList.EndUpdate Method (Boolean)

RangeListEndUpdate Method (Boolean)
Re-enables range list updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndUpdate(
    bool update
)
Public Function EndUpdate (
    update As Boolean
) As Integer
public:
int EndUpdate(
    bool update
)
member EndUpdate :
        update : bool -> int

Parameters

update
Type: SystemBoolean
If true, forces list updating.

Return Value

Type: Int32
Number of range list updating locks.
See Also

Reference

RangeList Class
EndUpdate Overload
Alternet.Common Namespace


RangeList.Equals Method

RangeListEquals Method
Determines whether the specified RangeList is equal to the current RangeList.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The RangeList to compare with the current RangeList.

Return Value

Type: Boolean
True if the specified RangeList is equal to the current RangeList; otherwise, false.
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.FindExactRange Method

RangeListFindExactRange Method
Overload List
 | Name | Description
Public method | FindExactRange(Point) | Locates range at specified position and verifies whether it starts at the given position.
Public method | FindExactRange(Int32) | Locates range at specified line and verifies whether it starts at the given line.
Top
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.FindExactRange Method (Point)

RangeListFindExactRange Method (Point)
Locates range at specified position and verifies whether it starts at the given position.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRange FindExactRange(
    Point point
)
Public Function FindExactRange (
    point As Point
) As IRange
public:
IRange^ FindExactRange(
    Point point
)
member FindExactRange :
        point : Point -> IRange

Parameters

point
Type: System.DrawingPoint
Position to locate range.

Return Value

Type: IRange
IRange if it starts at specified position; otherwise null.
See Also

Reference

RangeList Class
FindExactRange Overload
Alternet.Common Namespace


RangeList.FindExactRange Method (Int32)

RangeListFindExactRange Method (Int32)
Locates range at specified line and verifies whether it starts at the given line.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRange FindExactRange(
    int index
)
Public Function FindExactRange (
    index As Integer
) As IRange
public:
IRange^ FindExactRange(
    int index
)
member FindExactRange :
        index : int -> IRange

Parameters

index
Type: SystemInt32
Index of line to locate range.

Return Value

Type: IRange
IRange if it starts at specified line; otherwise null.
See Also

Reference

RangeList Class
FindExactRange Overload
Alternet.Common Namespace


RangeList.FindInclusiveRange Method

RangeListFindInclusiveRange Method
Locates range containing specific line.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRange FindInclusiveRange(
    int index,
    bool extended = false
)
Public Function FindInclusiveRange (
    index As Integer,
    Optional extended As Boolean = false
) As IRange
public:
IRange^ FindInclusiveRange(
    int index,
    bool extended = false
)
member FindInclusiveRange :
        index : int *
        ?extended : bool
(* Defaults:
        let _extended = defaultArg extended false
*)
-> IRange

Parameters

index
Type: SystemInt32
Position to locate range.
extended (Optional)
Type: SystemBoolean

Return Value

Type: IRange
IRange containing given line.
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.FindRange Method

RangeListFindRange Method
Overload List
 | Name | Description
Public method | FindRange(Point) | Locates range at specified position.
Public method | FindRange(Int32) | Locates range at specified line.
Top
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.FindRange Method (Point)

RangeListFindRange Method (Point)
Locates range at specified position.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRange FindRange(
    Point point
)
Public Function FindRange (
    point As Point
) As IRange
public:
IRange^ FindRange(
    Point point
)
member FindRange :
        point : Point -> IRange

Parameters

point
Type: System.DrawingPoint
Position to locate range.

Return Value

Type: IRange
IRange at the specified position.
See Also

Reference

RangeList Class
FindRange Overload
Alternet.Common Namespace


RangeList.FindRange Method (Int32)

RangeListFindRange Method (Int32)
Locates range at specified line.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRange FindRange(
    int index
)
Public Function FindRange (
    index As Integer
) As IRange
public:
IRange^ FindRange(
    int index
)
member FindRange :
        index : int -> IRange

Parameters

index
Type: SystemInt32
Index of line to locate range.

Return Value

Type: IRange
IRange at specified line.
See Also

Reference

RangeList Class
FindRange Overload
Alternet.Common Namespace


RangeList.GetExactRanges Method

RangeListGetExactRanges Method
Fills list specified by Ranges parameter with all ranges that starts at the specified line.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetExactRanges(
    IList<IRange> ranges,
    int index
)
Public Function GetExactRanges (
    ranges As IList(Of IRange),
    index As Integer
) As Integer
public:
int GetExactRanges(
    IList<IRange^>^ ranges,
    int index
)
member GetExactRanges :
        ranges : IList<IRange> *
        index : int -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
index
Type: SystemInt32
Specifies index of line.

Return Value

Type: Int32
Number of elements in the ranges collection.
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.GetHashCode Method

RangeListGetHashCode Method
Serves as a hash function for a particular type.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current RangeList.
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.GetRanges Method

RangeListGetRanges Method
Overload List
 | Name | Description
Public method | GetRanges | Returns ranges collection in the from of IList.
Public method | GetRanges(IListIRange) | Fills list specified by Ranges parameter with all existing ranges.
Public method | GetRanges(IListIRange, Point) | Fills list specified by Ranges parameter with all ranges containing specific position.
Public method | GetRanges(IListIRange, Int32) |
Public method | GetRanges(IListIRange, Point, Point) | Fills list specified by Ranges parameter with all ranges within specified range.
Top
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.GetRanges Method

RangeListGetRanges Method
Returns ranges collection in the from of IList.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IRange> GetRanges()
Public Function GetRanges As IList(Of IRange)
public:
IList<IRange^>^ GetRanges()
member GetRanges : unit -> IList<IRange>

Return Value

Type: IListIRange
IList representation of ranges collection.
See Also

Reference

RangeList Class
GetRanges Overload
Alternet.Common Namespace


RangeList.GetRanges Method (IList(IRange))

RangeListGetRanges Method (IListIRange)
Fills list specified by Ranges parameter with all existing ranges.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetRanges(
    IList<IRange> ranges
)
Public Function GetRanges (
    ranges As IList(Of IRange)
) As Integer
public:
int GetRanges(
    IList<IRange^>^ ranges
)
member GetRanges :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.

Return Value

Type: Int32
Number of elements in the ranges collection.
See Also

Reference

RangeList Class
GetRanges Overload
Alternet.Common Namespace


RangeList.GetRanges Method (IList(IRange), Point)

RangeListGetRanges Method (IListIRange, Point)
Fills list specified by Ranges parameter with all ranges containing specific position.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetRanges(
    IList<IRange> ranges,
    Point point
)
Public Function GetRanges (
    ranges As IList(Of IRange),
    point As Point
) As Integer
public:
int GetRanges(
    IList<IRange^>^ ranges,
    Point point
)
member GetRanges :
        ranges : IList<IRange> *
        point : Point -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
point
Type: System.DrawingPoint
Specifies position in text coordinates.

Return Value

Type: Int32
Number of elements in the ranges collection.
See Also

Reference

RangeList Class
GetRanges Overload
Alternet.Common Namespace


RangeList.GetRanges Method (IList(IRange), Int32)

RangeListGetRanges Method (IListIRange, Int32)

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetRanges(
    IList<IRange> ranges,
    int index
)
Public Function GetRanges (
    ranges As IList(Of IRange),
    index As Integer
) As Integer
public:
int GetRanges(
    IList<IRange^>^ ranges,
    int index
)
member GetRanges :
        ranges : IList<IRange> *
        index : int -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
index
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

RangeList Class
GetRanges Overload
Alternet.Common Namespace


RangeList.GetRanges Method (IList(IRange), Point, Point)

RangeListGetRanges Method (IListIRange, Point, Point)
Fills list specified by Ranges parameter with all ranges within specified range.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetRanges(
    IList<IRange> ranges,
    Point startpoint,
    Point endpoint
)
Public Function GetRanges (
    ranges As IList(Of IRange),
    startpoint As Point,
    endpoint As Point
) As Integer
public:
int GetRanges(
    IList<IRange^>^ ranges,
    Point startpoint,
    Point endpoint
)
member GetRanges :
        ranges : IList<IRange> *
        startpoint : Point *
        endpoint : Point -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
startpoint
Type: System.DrawingPoint
Specifies start position in text coordinates.
endpoint
Type: System.DrawingPoint
Specifies end position in text coordinates.

Return Value

Type: Int32
Number of elements in the ranges collection.
See Also

Reference

RangeList Class
GetRanges Overload
Alternet.Common Namespace


RangeList.Insert Method

RangeListInsert Method
Inserts a range into the range list at the specified index.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    int index,
    IRange item
)
Public Sub Insert (
    index As Integer,
    item As IRange
)
public:
virtual void Insert(
    int index,
    IRange^ item
) sealed
abstract Insert :
        index : int *
        item : IRange -> unit
override Insert :
        index : int *
        item : IRange -> unit

Parameters

index
Type: SystemInt32
The zero-based index at which range should be inserted.
item
Type: Alternet.CommonIRange
Specifies range to insert.

Implements

IListTInsert(Int32, T)
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.PositionChanged Method

RangeListPositionChanged Method
Updates specified position by DeltaX and DeltaY values for any ranges in the collection.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.RemoveAt Method

RangeListRemoveAt Method
Removes the range at the specified index of the RangeList.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
) sealed
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
The zero-based index of the range to remove.

Implements

IListTRemoveAt(Int32)
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.RemoveRange Method

RangeListRemoveRange Method
Overload List
 | Name | Description
Public method | RemoveRange(Point) | Removes all ranges containing specified position.
Public method | RemoveRange(Int32) | Removes all containing specified line.
Public method | RemoveRange(Int32, Int32) | Removes a range of elements from the ListT. (Inherited from ListIRange .)
Top
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.RemoveRange Method (Point)

RangeListRemoveRange Method (Point)
Removes all ranges containing specified position.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveRange(
    Point point
)
Public Sub RemoveRange (
    point As Point
)
public:
void RemoveRange(
    Point point
)
member RemoveRange :
        point : Point -> unit

Parameters

point
Type: System.DrawingPoint
Position to remove ranges.
See Also

Reference

RangeList Class
RemoveRange Overload
Alternet.Common Namespace


RangeList.RemoveRange Method (Int32)

RangeListRemoveRange Method (Int32)
Removes all containing specified line.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveRange(
    int index
)
Public Sub RemoveRange (
    index As Integer
)
public:
void RemoveRange(
    int index
)
member RemoveRange :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of line to remove ranges.
See Also

Reference

RangeList Class
RemoveRange Overload
Alternet.Common Namespace


RangeList.Sort Method

RangeListSort Method
Overload List
 | Name | Description
Public method | Sort | Sorts RangeList content.
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIRange .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIRange .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIRange .)
Top
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.Sort Method

RangeListSort Method
Sorts RangeList content.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Sort()
Public Sub Sort
public:
void Sort()
member Sort : unit -> unit
See Also

Reference

RangeList Class
Sort Overload
Alternet.Common Namespace


RangeList.Update Method

RangeListUpdate Method
Updates RangeList content.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.UpdatePosition Method

RangeListUpdatePosition Method
Updates specified position by DeltaX and DeltaY values for specific IRange.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdatePosition(
    IRange range,
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Function UpdatePosition (
    range As IRange,
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
public:
virtual bool UpdatePosition(
    IRange^ range,
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract UpdatePosition :
        range : IRange *
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool
override UpdatePosition :
        range : IRange *
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

range
Type: Alternet.CommonIRange
IRange to update.
x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IRangeListUpdatePosition(IRange, Int32, Int32, Int32, Int32)
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList Properties

RangeList Properties

The RangeList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIRange .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIRange .)
Public property | TopRange | Represents top level range for this list.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.TopRange Property

RangeListTopRange Property
Represents top level range for this list.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISortRange TopRange { get; }
Public ReadOnly Property TopRange As ISortRange
    Get
public:
property ISortRange^ TopRange {
    ISortRange^ get ();
}
member TopRange : ISortRange with get

Property Value

Type: ISortRange
See Also

Reference

RangeList Class
Alternet.Common Namespace


RangeList.UpdateCount Property

RangeListUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UpdateCount { get; }
Public ReadOnly Property UpdateCount As Integer
    Get
public:
property int UpdateCount {
    int get ();
}
member UpdateCount : int with get

Property Value

Type: Int32
See Also

Reference

RangeList Class
Alternet.Common Namespace


RectangleExtensions Class

RectangleExtensions Class
Contains extended functionality for System.Drawing.Rectangle objects.
Inheritance Hierarchy
SystemObject
Alternet.CommonRectangleExtensions

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RectangleExtensions
<ExtensionAttribute>
Public NotInheritable Class RectangleExtensions
[ExtensionAttribute]
public ref class RectangleExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type RectangleExtensions =  class end

The RectangleExtensions type exposes the following members.

Methods
Name | Description
DeflatedWithPadding | Deflates given rectangle by the specified padding.
Inflated(Rectangle, Size) | Inflates given rectangle by the specified size.
Inflated(Rectangle, Int32) | Inflates given rectangle by the specified amount.
InflatedWithPadding | Inflates given rectangle by the specified padding.
LeftBottom | Returns location of the bottom-left corner of specified rectangle.
LeftTop | Returns location of the upper-left corner of specified rectangle.
RightBottom | Returns location of the bottom-right corner of specified rectangle.
RightTop | Returns location of the upper-right corner of specified rectangle.
WithHeight | Adjusts a given rectangle with the new height.
WithLocation | Moves the location of given rectangle to the specified coordinates.
WithOffset(Rectangle, Size) | Offsets the location of given rectangle by the specified offset.
WithOffset(Rectangle, Int32, Int32) | Offsets the location of given rectangle by the specified offset.
WithSize | Adjusts a given rectangle with the new size.
WithWidth | Adjusts a given rectangle with the new width.
WithX | Moves the location of given rectangle to the specified x-coordinate.
WithY | Moves the location of given rectangle to the specified y-coordinate.
Top
See Also

Reference

Alternet.Common Namespace


RectangleExtensions Methods

RectangleExtensions Methods

The RectangleExtensions type exposes the following members.

Methods
Name | Description
DeflatedWithPadding | Deflates given rectangle by the specified padding.
Inflated(Rectangle, Size) | Inflates given rectangle by the specified size.
Inflated(Rectangle, Int32) | Inflates given rectangle by the specified amount.
InflatedWithPadding | Inflates given rectangle by the specified padding.
LeftBottom | Returns location of the bottom-left corner of specified rectangle.
LeftTop | Returns location of the upper-left corner of specified rectangle.
RightBottom | Returns location of the bottom-right corner of specified rectangle.
RightTop | Returns location of the upper-right corner of specified rectangle.
WithHeight | Adjusts a given rectangle with the new height.
WithLocation | Moves the location of given rectangle to the specified coordinates.
WithOffset(Rectangle, Size) | Offsets the location of given rectangle by the specified offset.
WithOffset(Rectangle, Int32, Int32) | Offsets the location of given rectangle by the specified offset.
WithSize | Adjusts a given rectangle with the new size.
WithWidth | Adjusts a given rectangle with the new width.
WithX | Moves the location of given rectangle to the specified x-coordinate.
WithY | Moves the location of given rectangle to the specified y-coordinate.
Top
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.DeflatedWithPadding Method

RectangleExtensionsDeflatedWithPadding Method
Deflates given rectangle by the specified padding.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle DeflatedWithPadding(
    this Rectangle r,
    Padding p
)
<ExtensionAttribute>
Public Shared Function DeflatedWithPadding (
    r As Rectangle,
    p As Padding
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle DeflatedWithPadding(
    Rectangle r,
    Padding p
)
[<ExtensionAttribute>]
static member DeflatedWithPadding :
        r : Rectangle *
        p : Padding -> Rectangle

Parameters

r
Type: System.DrawingRectangle
Given rectangle.
p
Type: System.Windows.FormsPadding
System.Windows.Forms.Padding specifying amount to decrease this rectangle.

Return Value

Type: Rectangle
Rectangle object with new size.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.Inflated Method

RectangleExtensionsInflated Method
Overload List
Name | Description
Inflated(Rectangle, Size) | Inflates given rectangle by the specified size.
Inflated(Rectangle, Int32) | Inflates given rectangle by the specified amount.
Top
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.Inflated Method (Rectangle, Size)

RectangleExtensionsInflated Method (Rectangle, Size)
Inflates given rectangle by the specified size.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle Inflated(
    this Rectangle rectangle,
    Size size
)
<ExtensionAttribute>
Public Shared Function Inflated (
    rectangle As Rectangle,
    size As Size
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle Inflated(
    Rectangle rectangle,
    Size size
)
[<ExtensionAttribute>]
static member Inflated :
        rectangle : Rectangle *
        size : Size -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Given rectangle.
size
Type: System.DrawingSize
The amount to inflate this rectangle.

Return Value

Type: Rectangle
Rectangle object with new size.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Inflated Overload
Alternet.Common Namespace


RectangleExtensions.Inflated Method (Rectangle, Int32)

RectangleExtensionsInflated Method (Rectangle, Int32)
Inflates given rectangle by the specified amount.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle Inflated(
    this Rectangle rectangle,
    int amount
)
<ExtensionAttribute>
Public Shared Function Inflated (
    rectangle As Rectangle,
    amount As Integer
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle Inflated(
    Rectangle rectangle,
    int amount
)
[<ExtensionAttribute>]
static member Inflated :
        rectangle : Rectangle *
        amount : int -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Given rectangle.
amount
Type: SystemInt32
The amount to inflate this rectangle in vertical and horizontal direction.

Return Value

Type: Rectangle
Rectangle object with new size.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Inflated Overload
Alternet.Common Namespace


RectangleExtensions.InflatedWithPadding Method

RectangleExtensionsInflatedWithPadding Method
Inflates given rectangle by the specified padding.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle InflatedWithPadding(
    this Rectangle r,
    Padding p
)
<ExtensionAttribute>
Public Shared Function InflatedWithPadding (
    r As Rectangle,
    p As Padding
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle InflatedWithPadding(
    Rectangle r,
    Padding p
)
[<ExtensionAttribute>]
static member InflatedWithPadding :
        r : Rectangle *
        p : Padding -> Rectangle

Parameters

r
Type: System.DrawingRectangle
Given rectangle.
p
Type: System.Windows.FormsPadding
System.Windows.Forms.Padding specifying amount to increase this rectangle.

Return Value

Type: Rectangle
Rectangle object with new size.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.LeftBottom Method

RectangleExtensionsLeftBottom Method
Returns location of the bottom-left corner of specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point LeftBottom(
    this Rectangle r
)
<ExtensionAttribute>
Public Shared Function LeftBottom (
    r As Rectangle
) As Point
public:
[ExtensionAttribute]
static Point LeftBottom(
    Rectangle r
)
[<ExtensionAttribute>]
static member LeftBottom :
        r : Rectangle -> Point

Parameters

r
Type: System.DrawingRectangle
Given rectangle.

Return Value

Type: Point
Point that contains location of the bottom-left rectangle corner.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.LeftTop Method

RectangleExtensionsLeftTop Method
Returns location of the upper-left corner of specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point LeftTop(
    this Rectangle r
)
<ExtensionAttribute>
Public Shared Function LeftTop (
    r As Rectangle
) As Point
public:
[ExtensionAttribute]
static Point LeftTop(
    Rectangle r
)
[<ExtensionAttribute>]
static member LeftTop :
        r : Rectangle -> Point

Parameters

r
Type: System.DrawingRectangle
Given rectangle.

Return Value

Type: Point
Point that contains location of the upper-left rectangle corner.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.RightBottom Method

RectangleExtensionsRightBottom Method
Returns location of the bottom-right corner of specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point RightBottom(
    this Rectangle r
)
<ExtensionAttribute>
Public Shared Function RightBottom (
    r As Rectangle
) As Point
public:
[ExtensionAttribute]
static Point RightBottom(
    Rectangle r
)
[<ExtensionAttribute>]
static member RightBottom :
        r : Rectangle -> Point

Parameters

r
Type: System.DrawingRectangle
Given rectangle.

Return Value

Type: Point
Point that contains location of the bottom-right rectangle corner.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.RightTop Method

RectangleExtensionsRightTop Method
Returns location of the upper-right corner of specified rectangle.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point RightTop(
    this Rectangle r
)
<ExtensionAttribute>
Public Shared Function RightTop (
    r As Rectangle
) As Point
public:
[ExtensionAttribute]
static Point RightTop(
    Rectangle r
)
[<ExtensionAttribute>]
static member RightTop :
        r : Rectangle -> Point

Parameters

r
Type: System.DrawingRectangle
Given rectangle.

Return Value

Type: Point
Point that contains location of the upper-right rectangle corner.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.WithHeight Method

RectangleExtensionsWithHeight Method
Adjusts a given rectangle with the new height.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle WithHeight(
    this Rectangle rectangle,
    int height
)
<ExtensionAttribute>
Public Shared Function WithHeight (
    rectangle As Rectangle,
    height As Integer
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle WithHeight(
    Rectangle rectangle,
    int height
)
[<ExtensionAttribute>]
static member WithHeight :
        rectangle : Rectangle *
        height : int -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Rectangle to process.
height
Type: SystemInt32
New rectangle height.

Return Value

Type: Rectangle
Rectangle object with new height.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.WithLocation Method

RectangleExtensionsWithLocation Method
Moves the location of given rectangle to the specified coordinates.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle WithLocation(
    this Rectangle rectangle,
    Point location
)
<ExtensionAttribute>
Public Shared Function WithLocation (
    rectangle As Rectangle,
    location As Point
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle WithLocation(
    Rectangle rectangle,
    Point location
)
[<ExtensionAttribute>]
static member WithLocation :
        rectangle : Rectangle *
        location : Point -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Rectangle to process.
location
Type: System.DrawingPoint
New rectangle location.

Return Value

Type: Rectangle
Rectangle object with new location.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.WithOffset Method

RectangleExtensionsWithOffset Method
Overload List
Name | Description
WithOffset(Rectangle, Size) | Offsets the location of given rectangle by the specified offset.
WithOffset(Rectangle, Int32, Int32) | Offsets the location of given rectangle by the specified offset.
Top
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.WithOffset Method (Rectangle, Size)

RectangleExtensionsWithOffset Method (Rectangle, Size)
Offsets the location of given rectangle by the specified offset.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle WithOffset(
    this Rectangle rectangle,
    Size offset
)
<ExtensionAttribute>
Public Shared Function WithOffset (
    rectangle As Rectangle,
    offset As Size
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle WithOffset(
    Rectangle rectangle,
    Size offset
)
[<ExtensionAttribute>]
static member WithOffset :
        rectangle : Rectangle *
        offset : Size -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Rectangle to process.
offset
Type: System.DrawingSize
Horizontal and vertical offset.

Return Value

Type: Rectangle
Rectangle object with new location.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
WithOffset Overload
Alternet.Common Namespace


RectangleExtensions.WithOffset Method (Rectangle, Int32, Int32)

RectangleExtensionsWithOffset Method (Rectangle, Int32, Int32)
Offsets the location of given rectangle by the specified offset.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle WithOffset(
    this Rectangle rectangle,
    int offsetX,
    int offsetY
)
<ExtensionAttribute>
Public Shared Function WithOffset (
    rectangle As Rectangle,
    offsetX As Integer,
    offsetY As Integer
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle WithOffset(
    Rectangle rectangle,
    int offsetX,
    int offsetY
)
[<ExtensionAttribute>]
static member WithOffset :
        rectangle : Rectangle *
        offsetX : int *
        offsetY : int -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Rectangle to process.
offsetX
Type: SystemInt32
Horizontal offset.
offsetY
Type: SystemInt32
Vertical offset.

Return Value

Type: Rectangle
Rectangle object with new location.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
WithOffset Overload
Alternet.Common Namespace


RectangleExtensions.WithSize Method

RectangleExtensionsWithSize Method
Adjusts a given rectangle with the new size.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle WithSize(
    this Rectangle rectangle,
    Size size
)
<ExtensionAttribute>
Public Shared Function WithSize (
    rectangle As Rectangle,
    size As Size
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle WithSize(
    Rectangle rectangle,
    Size size
)
[<ExtensionAttribute>]
static member WithSize :
        rectangle : Rectangle *
        size : Size -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Rectangle to process.
size
Type: System.DrawingSize
New rectangle size.

Return Value

Type: Rectangle
Rectangle object with new size.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.WithWidth Method

RectangleExtensionsWithWidth Method
Adjusts a given rectangle with the new width.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle WithWidth(
    this Rectangle rectangle,
    int width
)
<ExtensionAttribute>
Public Shared Function WithWidth (
    rectangle As Rectangle,
    width As Integer
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle WithWidth(
    Rectangle rectangle,
    int width
)
[<ExtensionAttribute>]
static member WithWidth :
        rectangle : Rectangle *
        width : int -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Rectangle to process.
width
Type: SystemInt32
New rectangle width.

Return Value

Type: Rectangle
Rectangle object with new width.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.WithX Method

RectangleExtensionsWithX Method
Moves the location of given rectangle to the specified x-coordinate.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle WithX(
    this Rectangle rectangle,
    int x
)
<ExtensionAttribute>
Public Shared Function WithX (
    rectangle As Rectangle,
    x As Integer
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle WithX(
    Rectangle rectangle,
    int x
)
[<ExtensionAttribute>]
static member WithX :
        rectangle : Rectangle *
        x : int -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Rectangle to process.
x
Type: SystemInt32
New rectangle X position.

Return Value

Type: Rectangle
Rectangle object with new location.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


RectangleExtensions.WithY Method

RectangleExtensionsWithY Method
Moves the location of given rectangle to the specified y-coordinate.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle WithY(
    this Rectangle rectangle,
    int y
)
<ExtensionAttribute>
Public Shared Function WithY (
    rectangle As Rectangle,
    y As Integer
) As Rectangle
public:
[ExtensionAttribute]
static Rectangle WithY(
    Rectangle rectangle,
    int y
)
[<ExtensionAttribute>]
static member WithY :
        rectangle : Rectangle *
        y : int -> Rectangle

Parameters

rectangle
Type: System.DrawingRectangle
Rectangle to process.
y
Type: SystemInt32
New rectangle Y position.

Return Value

Type: Rectangle
Rectangle object with new location.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectangleExtensions Class
Alternet.Common Namespace


Result Class

Result Class
Represents information about the success or failure of particular action.
Inheritance Hierarchy
SystemObject
Alternet.CommonResult
Alternet.CommonResultT

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Result
Public Class Result
public ref class Result
type Result =  class end

The Result type exposes the following members.

Methods
 | Name | Description
 | Combine | Examines specified collection for the unsuccessful result.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Fail(String) | Creates a new Alternet.Common.Result for unsuccessful action.
 | FailT(String) | Creates a new generic Alternet.Common.Result for unsuccessful action.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Ok | Creates a new Alternet.Common.Result for successful action.
 | OkT(T) | Creates a new Alternet.Common.Result for successful action.
Public method | OnBoth | Executes specified function to update result of the executed action.
Public method | OnFailure(Action) | Executes specified function if result represents unsuccessful action.
Public method | OnFailure(ActionResult) | Executes specified function to update result of the executed action if result represents unsuccessful action.
Public method | OnSuccess(Action) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncResult) | Executes specified function if result represents successful action.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorMessage | Gets a message contains error information.
Public property | IsFailure | Gets a value indicating whether action was failed.
Public property | IsSuccess | Gets a value indicating whether action was succeed.
Top
See Also

Reference

Alternet.Common Namespace


Result Methods

Result Methods

The Result type exposes the following members.

Methods
 | Name | Description
 | Combine | Examines specified collection for the unsuccessful result.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Fail(String) | Creates a new Alternet.Common.Result for unsuccessful action.
 | FailT(String) | Creates a new generic Alternet.Common.Result for unsuccessful action.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Ok | Creates a new Alternet.Common.Result for successful action.
 | OkT(T) | Creates a new Alternet.Common.Result for successful action.
Public method | OnBoth | Executes specified function to update result of the executed action.
Public method | OnFailure(Action) | Executes specified function if result represents unsuccessful action.
Public method | OnFailure(ActionResult) | Executes specified function to update result of the executed action if result represents unsuccessful action.
Public method | OnSuccess(Action) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncResult) | Executes specified function if result represents successful action.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Result Class
Alternet.Common Namespace


Result.Combine Method

ResultCombine Method
Examines specified collection for the unsuccessful result.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Result Combine(
    params Result[] results
)
Public Shared Function Combine (
    ParamArray results As Result()
) As Result
public:
static Result^ Combine(
    ... array<Result^>^ results
)
static member Combine :
        results : Result[] -> Result

Parameters

results
Type: Alternet.CommonResult
Array to probe.

Return Value

Type: Result
First occurrence of the unsuccessful result if ones present in the array; otherwise OK result.
See Also

Reference

Result Class
Alternet.Common Namespace


Result.Fail Method

ResultFail Method
Overload List
Name | Description
Fail(String) | Creates a new Alternet.Common.Result for unsuccessful action.
FailT(String) | Creates a new generic Alternet.Common.Result for unsuccessful action.
Top
See Also

Reference

Result Class
Alternet.Common Namespace


Result.Fail Method (String)

ResultFail Method (String)
Creates a new Alternet.Common.Result for unsuccessful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Result Fail(
    string message
)
Public Shared Function Fail (
    message As String
) As Result
public:
static Result^ Fail(
    String^ message
)
static member Fail :
        message : string -> Result

Parameters

message
Type: SystemString
Message describes reason of failure.

Return Value

Type: Result
New Alternet.Common.Result object contains information about error.
See Also

Reference

Result Class
Fail Overload
Alternet.Common Namespace


Result.Fail(T) Method (String)

ResultFailT Method (String)
Creates a new generic Alternet.Common.Result for unsuccessful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Result<T> Fail<T>(
    string message
)

Public Shared Function Fail(Of T) (
    message As String
) As Result(Of T)
public:
generic<typename T>
static Result<T>^ Fail(
    String^ message
)
static member Fail :
        message : string -> Result<'T>

Parameters

message
Type: SystemString
Message describes reason of failure.

Type Parameters

T
Type of object related to the action.

Return Value

Type: Result T
New Alternet.Common.Result object contains information about error.
See Also

Reference

Result Class
Fail Overload
Alternet.Common Namespace


Result.Ok Method

ResultOk Method
Overload List
Name | Description
Ok | Creates a new Alternet.Common.Result for successful action.
OkT(T) | Creates a new Alternet.Common.Result for successful action.
Top
See Also

Reference

Result Class
Alternet.Common Namespace


Result.Ok Method

ResultOk Method
Creates a new Alternet.Common.Result for successful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Result Ok()
Public Shared Function Ok As Result
public:
static Result^ Ok()
static member Ok : unit -> Result

Return Value

Type: Result
New Alternet.Common.Result object.
See Also

Reference

Result Class
Ok Overload
Alternet.Common Namespace


Result.Ok(T) Method (T)

ResultOkT Method (T)
Creates a new Alternet.Common.Result for successful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Result<T> Ok<T>(
    T value
)

Public Shared Function Ok(Of T) (
    value As T
) As Result(Of T)
public:
generic<typename T>
static Result<T>^ Ok(
    T value
)
static member Ok :
        value : 'T -> Result<'T>

Parameters

value
Type: T
An object that is result of the executed action.

Type Parameters

T
Type of object related to the action.

Return Value

Type: Result T
New Alternet.Common.Result object.
See Also

Reference

Result Class
Ok Overload
Alternet.Common Namespace


Result.OnBoth Method

ResultOnBoth Method
Executes specified function to update result of the executed action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result OnBoth(
    Action<Result> action
)
Public Function OnBoth (
    action As Action(Of Result)
) As Result
public:
Result^ OnBoth(
    Action<Result^>^ action
)
member OnBoth :
        action : Action<Result> -> Result

Parameters

action
Type: SystemActionResult
Function to execute.

Return Value

Type: Result
Updated result.
See Also

Reference

Result Class
Alternet.Common Namespace


Result.OnFailure Method

ResultOnFailure Method
Overload List
 | Name | Description
Public method | OnFailure(Action) | Executes specified function if result represents unsuccessful action.
Public method | OnFailure(ActionResult) | Executes specified function to update result of the executed action if result represents unsuccessful action.
Top
See Also

Reference

Result Class
Alternet.Common Namespace


Result.OnFailure Method (Action)

ResultOnFailure Method (Action)
Executes specified function if result represents unsuccessful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result OnFailure(
    Action action
)
Public Function OnFailure (
    action As Action
) As Result
public:
Result^ OnFailure(
    Action^ action
)
member OnFailure :
        action : Action -> Result

Parameters

action
Type: SystemAction
Function to execute.

Return Value

Type: Result
Current result.
See Also

Reference

Result Class
OnFailure Overload
Alternet.Common Namespace


Result.OnFailure Method (Action(Result))

ResultOnFailure Method (ActionResult)
Executes specified function to update result of the executed action if result represents unsuccessful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result OnFailure(
    Action<Result> action
)
Public Function OnFailure (
    action As Action(Of Result)
) As Result
public:
Result^ OnFailure(
    Action<Result^>^ action
)
member OnFailure :
        action : Action<Result> -> Result

Parameters

action
Type: SystemActionResult
Function to execute.

Return Value

Type: Result
Updated result.
See Also

Reference

Result Class
OnFailure Overload
Alternet.Common Namespace


Result.OnSuccess Method

ResultOnSuccess Method
Overload List
 | Name | Description
Public method | OnSuccess(Action) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncResult) | Executes specified function if result represents successful action.
Top
See Also

Reference

Result Class
Alternet.Common Namespace


Result.OnSuccess Method (Action)

ResultOnSuccess Method (Action)
Executes specified function if result represents successful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result OnSuccess(
    Action action
)
Public Function OnSuccess (
    action As Action
) As Result
public:
Result^ OnSuccess(
    Action^ action
)
member OnSuccess :
        action : Action -> Result

Parameters

action
Type: SystemAction
Function to execute.

Return Value

Type: Result
Current result if action was not succeed; otherwise executes specified action and returns OK result.
See Also

Reference

Result Class
OnSuccess Overload
Alternet.Common Namespace


Result.OnSuccess Method (Func(Result))

ResultOnSuccess Method (FuncResult)
Executes specified function if result represents successful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result OnSuccess(
    Func<Result> func
)
Public Function OnSuccess (
    func As Func(Of Result)
) As Result
public:
Result^ OnSuccess(
    Func<Result^>^ func
)
member OnSuccess :
        func : Func<Result> -> Result

Parameters

func
Type: SystemFuncResult
Function to execute.

Return Value

Type: Result
Current result if action was not succeed; otherwise result of executing specified function.
See Also

Reference

Result Class
OnSuccess Overload
Alternet.Common Namespace


Result Properties

Result Properties

The Result type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Gets a message contains error information.
Public property | IsFailure | Gets a value indicating whether action was failed.
Public property | IsSuccess | Gets a value indicating whether action was succeed.
Top
See Also

Reference

Result Class
Alternet.Common Namespace


Result.ErrorMessage Property

ResultErrorMessage Property
Gets a message contains error information.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
public:
property String^ ErrorMessage {
    String^ get ();
}
member ErrorMessage : string with get

Property Value

Type: String
See Also

Reference

Result Class
Alternet.Common Namespace


Result.IsFailure Property

ResultIsFailure Property
Gets a value indicating whether action was failed.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFailure { get; }
Public ReadOnly Property IsFailure As Boolean
    Get
public:
property bool IsFailure {
    bool get ();
}
member IsFailure : bool with get

Property Value

Type: Boolean
See Also

Reference

Result Class
Alternet.Common Namespace


Result.IsSuccess Property

ResultIsSuccess Property
Gets a value indicating whether action was succeed.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSuccess { get; }
Public ReadOnly Property IsSuccess As Boolean
    Get
public:
property bool IsSuccess {
    bool get ();
}
member IsSuccess : bool with get

Property Value

Type: Boolean
See Also

Reference

Result Class
Alternet.Common Namespace


Result(T) Class

ResultT Class
Provides generic version of Alternet.Common.Result.
Inheritance Hierarchy
SystemObject
Alternet.CommonResult
Alternet.CommonResultT

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Result<T> : Result

Public Class Result(Of T)
    Inherits Result
generic<typename T>
public ref class Result : public Result
type Result<'T> =
    class
        inherit Result
    end

Type Parameters

T
Type of object related to the action.

The ResultT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnBoth(ActionResult) | Executes specified function to update result of the executed action. (Inherited from Result.)
Public method | OnBoth(FuncResult, T) | Executes specified function to update result of the executed action.
Public method | OnFailure(Action) | Executes specified function if result represents unsuccessful action. (Inherited from Result.)
Public method | OnFailure(ActionResult) | Executes specified function to update result of the executed action if result represents unsuccessful action. (Inherited from Result.)
Public method | OnFailure(ActionResultT) | Executes specified function to update result of the executed action if result represents unsuccessful action.
Public method | OnSuccess(Action) | Executes specified function if result represents successful action. (Inherited from Result.)
Public method | OnSuccess(ActionT) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncT) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncResult) | Executes specified function if result represents successful action. (Inherited from Result.)
Public method | OnSuccess(FuncResultT) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncT, Result) | Executes specified function if result represents successful action.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorMessage | Gets a message contains error information. (Inherited from Result.)
Public property | IsFailure | Gets a value indicating whether action was failed. (Inherited from Result.)
Public property | IsSuccess | Gets a value indicating whether action was succeed. (Inherited from Result.)
Public property | Value | Gets an object that is result of the executed action.
Top
See Also

Reference

Alternet.Common Namespace


Result(T) Methods

ResultT Methods

The ResultT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnBoth(ActionResult) | Executes specified function to update result of the executed action. (Inherited from Result.)
Public method | OnBoth(FuncResult, T) | Executes specified function to update result of the executed action.
Public method | OnFailure(Action) | Executes specified function if result represents unsuccessful action. (Inherited from Result.)
Public method | OnFailure(ActionResult) | Executes specified function to update result of the executed action if result represents unsuccessful action. (Inherited from Result.)
Public method | OnFailure(ActionResultT) | Executes specified function to update result of the executed action if result represents unsuccessful action.
Public method | OnSuccess(Action) | Executes specified function if result represents successful action. (Inherited from Result.)
Public method | OnSuccess(ActionT) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncT) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncResult) | Executes specified function if result represents successful action. (Inherited from Result.)
Public method | OnSuccess(FuncResultT) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncT, Result) | Executes specified function if result represents successful action.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResultT Class
Alternet.Common Namespace


Result(T).OnBoth Method

ResultTOnBoth Method
Overload List
 | Name | Description
Public method | OnBoth(ActionResult) | Executes specified function to update result of the executed action. (Inherited from Result.)
Public method | OnBoth(FuncResult, T) | Executes specified function to update result of the executed action.
Top
See Also

Reference

ResultT Class
Alternet.Common Namespace


Result(T).OnBoth Method (Func(Result, T))

ResultTOnBoth Method (FuncResult, T)
Executes specified function to update result of the executed action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public T OnBoth(
    Func<Result, T> func
)
Public Function OnBoth (
    func As Func(Of Result, T)
) As T
public:
T OnBoth(
    Func<Result^, T>^ func
)
member OnBoth :
        func : Func<Result, 'T> -> 'T

Parameters

func
Type: SystemFuncResult, T
Function to execute.

Return Value

Type: T
Updated result.
See Also

Reference

ResultT Class
OnBoth Overload
Alternet.Common Namespace


Result(T).OnFailure Method

ResultTOnFailure Method
Overload List
 | Name | Description
Public method | OnFailure(Action) | Executes specified function if result represents unsuccessful action. (Inherited from Result.)
Public method | OnFailure(ActionResult) | Executes specified function to update result of the executed action if result represents unsuccessful action. (Inherited from Result.)
Public method | OnFailure(ActionResultT) | Executes specified function to update result of the executed action if result represents unsuccessful action.
Top
See Also

Reference

ResultT Class
Alternet.Common Namespace


Result(T).OnFailure Method (Action(Result(T)))

ResultTOnFailure Method (ActionResultT)
Executes specified function to update result of the executed action if result represents unsuccessful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result<T> OnFailure(
    Action<Result<T>> action
)
Public Function OnFailure (
    action As Action(Of Result(Of T))
) As Result(Of T)
public:
Result<T>^ OnFailure(
    Action<Result<T>^>^ action
)
member OnFailure :
        action : Action<Result<'T>> -> Result<'T>

Parameters

action
Type: SystemActionResult T
Function to execute.

Return Value

Type: Result T
Current result.
See Also

Reference

ResultT Class
OnFailure Overload
Alternet.Common Namespace


Result(T).OnSuccess Method

ResultTOnSuccess Method
Overload List
 | Name | Description
Public method | OnSuccess(Action) | Executes specified function if result represents successful action. (Inherited from Result.)
Public method | OnSuccess(ActionT) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncT) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncResult) | Executes specified function if result represents successful action. (Inherited from Result.)
Public method | OnSuccess(FuncResultT) | Executes specified function if result represents successful action.
Public method | OnSuccess(FuncT, Result) | Executes specified function if result represents successful action.
Top
See Also

Reference

ResultT Class
Alternet.Common Namespace


Result(T).OnSuccess Method (Action(T))

ResultTOnSuccess Method (ActionT)
Executes specified function if result represents successful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result OnSuccess(
    Action<T> action
)
Public Function OnSuccess (
    action As Action(Of T)
) As Result
public:
Result^ OnSuccess(
    Action<T>^ action
)
member OnSuccess :
        action : Action<'T> -> Result

Parameters

action
Type: SystemActionT
Function to execute.

Return Value

Type: Result
Current result if action was not succeed; otherwise executes specified action and returns OK result.
See Also

Reference

ResultT Class
OnSuccess Overload
Alternet.Common Namespace


Result(T).OnSuccess Method (Func(T))

ResultTOnSuccess Method (FuncT)
Executes specified function if result represents successful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result<T> OnSuccess(
    Func<T> func
)
Public Function OnSuccess (
    func As Func(Of T)
) As Result(Of T)
public:
Result<T>^ OnSuccess(
    Func<T>^ func
)
member OnSuccess :
        func : Func<'T> -> Result<'T>

Parameters

func
Type: SystemFuncT
Function to execute.

Return Value

Type: Result T
Current result if action was not succeed; otherwise result of executing specified function.
See Also

Reference

ResultT Class
OnSuccess Overload
Alternet.Common Namespace


Result(T).OnSuccess Method (Func(Result(T)))

ResultTOnSuccess Method (FuncResultT)
Executes specified function if result represents successful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result<T> OnSuccess(
    Func<Result<T>> func
)
Public Function OnSuccess (
    func As Func(Of Result(Of T))
) As Result(Of T)
public:
Result<T>^ OnSuccess(
    Func<Result<T>^>^ func
)
member OnSuccess :
        func : Func<Result<'T>> -> Result<'T>

Parameters

func
Type: SystemFuncResult T
Function to execute.

Return Value

Type: Result T
Current result if action was not succeed; otherwise result of executing specified function.
See Also

Reference

ResultT Class
OnSuccess Overload
Alternet.Common Namespace


Result(T).OnSuccess Method (Func(T, Result))

ResultTOnSuccess Method (FuncT, Result)
Executes specified function if result represents successful action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Result OnSuccess(
    Func<T, Result> func
)
Public Function OnSuccess (
    func As Func(Of T, Result)
) As Result
public:
Result^ OnSuccess(
    Func<T, Result^>^ func
)
member OnSuccess :
        func : Func<'T, Result> -> Result

Parameters

func
Type: SystemFuncT, Result
Function to execute.

Return Value

Type: Result
Current result if action was not succeed; otherwise result of executing specified function.
See Also

Reference

ResultT Class
OnSuccess Overload
Alternet.Common Namespace


Result(T) Properties

ResultT Properties

The ResultT generic type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Gets a message contains error information. (Inherited from Result.)
Public property | IsFailure | Gets a value indicating whether action was failed. (Inherited from Result.)
Public property | IsSuccess | Gets a value indicating whether action was succeed. (Inherited from Result.)
Public property | Value | Gets an object that is result of the executed action.
Top
See Also

Reference

ResultT Class
Alternet.Common Namespace


Result(T).Value Property

ResultTValue Property
Gets an object that is result of the executed action.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Value { get; }
Public ReadOnly Property Value As T
    Get
public:
property T Value {
    T get ();
}
member Value : 'T with get

Property Value

Type: T
See Also

Reference

ResultT Class
Alternet.Common Namespace


SortList(T) Class

SortListT Class
Represents sorted list of objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListT
Alternet.CommonSortListT
More...

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SortList<T> : List<T>,
    ISortList<T>, IList<T>, ICollection<T>, IEnumerable<T>,
    IEnumerable

<SerializableAttribute>
Public Class SortList(Of T)
    Inherits List(Of T)
    Implements ISortList(Of T), IList(Of T),
    ICollection(Of T), IEnumerable(Of T), IEnumerable
[SerializableAttribute]
generic<typename T>
public ref class SortList : public List<T>,
    ISortList<T>, IList<T>, ICollection<T>, IEnumerable<T>,
    IEnumerable
[<SerializableAttribute>]
type SortList<'T> =
    class
        inherit List<'T>
        interface ISortList<'T>
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T

The SortListT type exposes the following members.

Constructors
 | Name | Description
Public method | SortListT | Initializes a new instance of the SortListT class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListT.)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListT.)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListT.)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListT.)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListT.)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListT.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListT.)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListT.)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListT.)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListT.)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListT.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListT.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListT.)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListT.)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListT.)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListT.)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListT.)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria.
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria.
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListT.)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListT.)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListT.)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListT.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListT.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListT.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListT.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListT.)
 | InsideRange(Point, Rectangle) | Indicates whether specified rectangle contains given position.
 | InsideRange(Point, Rectangle, Boolean) | Indicates whether specified rectangle contains given position.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListT.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListT.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListT.)
Public method | NeedSort | Determines if the list needs sorting based on given criteria.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListT.)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListT.)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListT.)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListT.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListT.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListT.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListT.)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListT.)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListT.)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListT.)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListT.)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListT.)
 | UpdatePos(Int32, Int32, Int32, Int32, Point, Boolean) | Updates specified position by DeltaX and DeltaY values.
 | UpdatePos(Int32, Int32, Int32, Int32, Int32, Int32, Boolean) | Updates specified position by DeltaX and DeltaY values.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfT | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstT | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementT, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListT.)
Public property | CompareIndex | Represents index of element that currently comparing.
Public property | Count | Gets the number of elements actually contained in the SortList.
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListT.)
Top
See Also

Reference

Alternet.Common Namespace
Inheritance Hierarchy
SystemObject
System.Collections.GenericListT
Alternet.CommonSortListT
Alternet.CommonRangeList
Alternet.Editor.TextSourceBookMarks
Alternet.Editor.TextSourceCodeSnippetRanges
Alternet.Editor.TextSourceLineStyles
Alternet.Editor.TextSourceTextSourceContentDividers
Alternet.SyntaxSyntaxAttributes
Alternet.SyntaxSyntaxErrors
Alternet.SyntaxSyntaxNodes


SortList(T) Constructor

SortListT Constructor
Initializes a new instance of the SortListT class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SortList()
Public Sub New
public:
SortList()
new : unit -> SortList
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T) Methods

SortListT Methods

The SortListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListT .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListT .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListT .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListT .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListT .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListT .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListT .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListT .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListT .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListT .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListT .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListT .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListT .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListT .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListT .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListT .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListT .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListT .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListT .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria.
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria.
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListT .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListT .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListT .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListT .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListT .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListT .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListT .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListT .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListT .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListT .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListT .)
 | InsideRange(Point, Rectangle) | Indicates whether specified rectangle contains given position.
 | InsideRange(Point, Rectangle, Boolean) | Indicates whether specified rectangle contains given position.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListT .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListT .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListT .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListT .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListT .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListT .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListT .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListT .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListT .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListT .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListT .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListT .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListT .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListT .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListT .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListT .)
 | UpdatePos(Int32, Int32, Int32, Int32, Point, Boolean) | Updates specified position by DeltaX and DeltaY values.
 | UpdatePos(Int32, Int32, Int32, Int32, Int32, Int32, Boolean) | Updates specified position by DeltaX and DeltaY values.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfT | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstT | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementT, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T).FindExact Method

SortListTFindExact Method
Overload List
 | Name | Description
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates.
Top
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T).FindExact Method (Object, Int32, IComparer)

SortListTFindExact Method (Object, Int32, IComparer)
Finds the given object in the sorted list with assumption that sorted list do not have any duplicates.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FindExact(
    Object obj,
    out int index,
    IComparer comparer
)
Public Function FindExact (
    obj As Object,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer
) As Boolean
public:
virtual bool FindExact(
    Object^ obj,
    [OutAttribute] int% index,
    IComparer^ comparer
) sealed
abstract FindExact :
        obj : Object *
        index : int byref *
        comparer : IComparer -> bool
override FindExact :
        obj : Object *
        index : int byref *
        comparer : IComparer -> bool

Parameters

obj
Type: SystemObject
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.CollectionsIComparer
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.

Implements

ISortListTFindExact(Object, Int32, IComparer)
See Also

Reference

SortListT Class
FindExact Overload
Alternet.Common Namespace


SortList(T).FindExact Method (T, Int32, IComparer(T))

SortListTFindExact Method (T, Int32, IComparerT)
Finds the given object in the sorted list with assumption that sorted list do not have any duplicates.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FindExact(
    T obj,
    out int index,
    IComparer<T> comparer
)
Public Function FindExact (
    obj As T,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer(Of T)
) As Boolean
public:
virtual bool FindExact(
    T obj,
    [OutAttribute] int% index,
    IComparer<T>^ comparer
) sealed
abstract FindExact :
        obj : 'T *
        index : int byref *
        comparer : IComparer<'T> -> bool
override FindExact :
        obj : 'T *
        index : int byref *
        comparer : IComparer<'T> -> bool

Parameters

obj
Type: T
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.Collections.GenericIComparerT
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.

Implements

ISortListTFindExact(T, Int32, IComparerT)
See Also

Reference

SortListT Class
FindExact Overload
Alternet.Common Namespace


SortList(T).FindFirst Method

SortListTFindFirst Method
Overload List
 | Name | Description
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria.
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria.
Top
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T).FindFirst Method (Object, Int32, IComparer)

SortListTFindFirst Method (Object, Int32, IComparer)
Finds the first occurrence of the given object that satisfies searching criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FindFirst(
    Object obj,
    out int index,
    IComparer comparer
)
Public Function FindFirst (
    obj As Object,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer
) As Boolean
public:
virtual bool FindFirst(
    Object^ obj,
    [OutAttribute] int% index,
    IComparer^ comparer
) sealed
abstract FindFirst :
        obj : Object *
        index : int byref *
        comparer : IComparer -> bool
override FindFirst :
        obj : Object *
        index : int byref *
        comparer : IComparer -> bool

Parameters

obj
Type: SystemObject
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.CollectionsIComparer
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.

Implements

ISortListTFindFirst(Object, Int32, IComparer)
See Also

Reference

SortListT Class
FindFirst Overload
Alternet.Common Namespace


SortList(T).FindFirst Method (T, Int32, IComparer(T))

SortListTFindFirst Method (T, Int32, IComparerT)
Finds the first occurrence of the given object that satisfies searching criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FindFirst(
    T obj,
    out int index,
    IComparer<T> comparer
)
Public Function FindFirst (
    obj As T,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer(Of T)
) As Boolean
public:
virtual bool FindFirst(
    T obj,
    [OutAttribute] int% index,
    IComparer<T>^ comparer
) sealed
abstract FindFirst :
        obj : 'T *
        index : int byref *
        comparer : IComparer<'T> -> bool
override FindFirst :
        obj : 'T *
        index : int byref *
        comparer : IComparer<'T> -> bool

Parameters

obj
Type: T
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.Collections.GenericIComparerT
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.

Implements

ISortListTFindFirst(T, Int32, IComparerT)
See Also

Reference

SortListT Class
FindFirst Overload
Alternet.Common Namespace


SortList(T).FindLast Method

SortListTFindLast Method
Overload List
 | Name | Description
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListT .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria.
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria.
Top
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T).FindLast Method (Object, Int32, IComparer)

SortListTFindLast Method (Object, Int32, IComparer)
Finds the last occurrence of the given object that satisfies searching criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FindLast(
    Object obj,
    out int index,
    IComparer comparer
)
Public Function FindLast (
    obj As Object,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer
) As Boolean
public:
virtual bool FindLast(
    Object^ obj,
    [OutAttribute] int% index,
    IComparer^ comparer
) sealed
abstract FindLast :
        obj : Object *
        index : int byref *
        comparer : IComparer -> bool
override FindLast :
        obj : Object *
        index : int byref *
        comparer : IComparer -> bool

Parameters

obj
Type: SystemObject
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.CollectionsIComparer
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.

Implements

ISortListTFindLast(Object, Int32, IComparer)
See Also

Reference

SortListT Class
FindLast Overload
Alternet.Common Namespace


SortList(T).FindLast Method (T, Int32, IComparer(T))

SortListTFindLast Method (T, Int32, IComparerT)
Finds the last occurrence of the given object that satisfies searching criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FindLast(
    T obj,
    out int index,
    IComparer<T> comparer
)
Public Function FindLast (
    obj As T,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer(Of T)
) As Boolean
public:
virtual bool FindLast(
    T obj,
    [OutAttribute] int% index,
    IComparer<T>^ comparer
) sealed
abstract FindLast :
        obj : 'T *
        index : int byref *
        comparer : IComparer<'T> -> bool
override FindLast :
        obj : 'T *
        index : int byref *
        comparer : IComparer<'T> -> bool

Parameters

obj
Type: T
Object to find.
index
Type: SystemInt32
Receive index of the found object in the sorted list.
comparer
Type: System.Collections.GenericIComparerT
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if the find succeed; otherwise false.

Implements

ISortListTFindLast(T, Int32, IComparerT)
See Also

Reference

SortListT Class
FindLast Overload
Alternet.Common Namespace


SortList(T).InsideRange Method

SortListTInsideRange Method
Overload List
Name | Description
InsideRange(Point, Rectangle) | Indicates whether specified rectangle contains given position.
InsideRange(Point, Rectangle, Boolean) | Indicates whether specified rectangle contains given position.
Top
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T).InsideRange Method (Point, Rectangle)

SortListTInsideRange Method (Point, Rectangle)
Indicates whether specified rectangle contains given position.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsideRange(
    Point pt,
    Rectangle rect
)
Public Shared Function InsideRange (
    pt As Point,
    rect As Rectangle
) As Boolean
public:
static bool InsideRange(
    Point pt,
    Rectangle rect
)
static member InsideRange :
        pt : Point *
        rect : Rectangle -> bool

Parameters

pt
Type: System.DrawingPoint
Position to check-up.
rect
Type: System.DrawingRectangle
Rectangular area to check-up.

Return Value

Type: Boolean
True if specified rect contains given Point; otherwise false.
See Also

Reference

SortListT Class
InsideRange Overload
Alternet.Common Namespace


SortList(T).InsideRange Method (Point, Rectangle, Boolean)

SortListTInsideRange Method (Point, Rectangle, Boolean)
Indicates whether specified rectangle contains given position.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InsideRange(
    Point pt,
    Rectangle rect,
    bool checkMaxInt
)
Public Shared Function InsideRange (
    pt As Point,
    rect As Rectangle,
    checkMaxInt As Boolean
) As Boolean
public:
static bool InsideRange(
    Point pt,
    Rectangle rect,
    bool checkMaxInt
)
static member InsideRange :
        pt : Point *
        rect : Rectangle *
        checkMaxInt : bool -> bool

Parameters

pt
Type: System.DrawingPoint
Position to check-up.
rect
Type: System.DrawingRectangle
Rectangular area to check-up.
checkMaxInt
Type: SystemBoolean
Indicates that rectangle may contain Max Integer coordinates.

Return Value

Type: Boolean
True if specified rect contains given Point; otherwise false.
See Also

Reference

SortListT Class
InsideRange Overload
Alternet.Common Namespace


SortList(T).NeedSort Method

SortListTNeedSort Method
Determines if the list needs sorting based on given criteria.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedSort(
    IComparer<T> comparer
)
Public Function NeedSort (
    comparer As IComparer(Of T)
) As Boolean
public:
virtual bool NeedSort(
    IComparer<T>^ comparer
) sealed
abstract NeedSort :
        comparer : IComparer<'T> -> bool
override NeedSort :
        comparer : IComparer<'T> -> bool

Parameters

comparer
Type: System.Collections.GenericIComparerT
Comparer object to perform comparison between items in the list.

Return Value

Type: Boolean
True if list has to be sorted; otherwise false.

Implements

ISortListTNeedSort(IComparerT)
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T).UpdatePos Method

SortListTUpdatePos Method
Overload List
Name | Description
UpdatePos(Int32, Int32, Int32, Int32, Point, Boolean) | Updates specified position by DeltaX and DeltaY values.
UpdatePos(Int32, Int32, Int32, Int32, Int32, Int32, Boolean) | Updates specified position by DeltaX and DeltaY values.
Top
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T).UpdatePos Method (Int32, Int32, Int32, Int32, Point, Boolean)

SortListTUpdatePos Method (Int32, Int32, Int32, Int32, Point, Boolean)
Updates specified position by DeltaX and DeltaY values.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool UpdatePos(
    int x,
    int y,
    int deltaX,
    int deltaY,
    ref Point pt,
    bool endPos
)
Public Shared Function UpdatePos (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ByRef pt As Point,
    endPos As Boolean
) As Boolean
public:
static bool UpdatePos(
    int x,
    int y,
    int deltaX,
    int deltaY,
    Point% pt,
    bool endPos
)
static member UpdatePos :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        pt : Point byref *
        endPos : bool -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
pt
Type: System.DrawingPoint
Position to update.
endPos
Type: SystemBoolean
Specifies whether position represents end of range.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

SortListT Class
UpdatePos Overload
Alternet.Common Namespace


SortList(T).UpdatePos Method (Int32, Int32, Int32, Int32, Int32, Int32, Boolean)

SortListTUpdatePos Method (Int32, Int32, Int32, Int32, Int32, Int32, Boolean)
Updates specified position by DeltaX and DeltaY values.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool UpdatePos(
    int x,
    int y,
    int deltaX,
    int deltaY,
    ref int ch,
    ref int ln,
    bool endPos
)
Public Shared Function UpdatePos (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ByRef ch As Integer,
    ByRef ln As Integer,
    endPos As Boolean
) As Boolean
public:
static bool UpdatePos(
    int x,
    int y,
    int deltaX,
    int deltaY,
    int% ch,
    int% ln,
    bool endPos
)
static member UpdatePos :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : int byref *
        ln : int byref *
        endPos : bool -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
ch
Type: SystemInt32
Horizontal constituent of the position to update.
ln
Type: SystemInt32
Vertical constituent of the position to update.
endPos
Type: SystemBoolean
Specifies whether position represents end of range.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

SortListT Class
UpdatePos Overload
Alternet.Common Namespace


SortList(T) Properties

SortListT Properties

The SortListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListT .)
Public property | CompareIndex | Represents index of element that currently comparing.
Public property | Count | Gets the number of elements actually contained in the SortList.
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListT .)
Top
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T).CompareIndex Property

SortListTCompareIndex Property
Represents index of element that currently comparing.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CompareIndex { get; }
Public ReadOnly Property CompareIndex As Integer
    Get
public:
property int CompareIndex {
    int get ();
}
member CompareIndex : int with get

Property Value

Type: Int32
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortList(T).Count Property

SortListTCount Property
Gets the number of elements actually contained in the SortList.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

SortListT Class
Alternet.Common Namespace


SortRange Class

SortRange Class
Represents a container for a sorted collection of IRange objects.
Inheritance Hierarchy
SystemObject
Alternet.CommonRange
Alternet.CommonSortRange

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SortRange : Range, ISortRange,
    IRange, ICloneable
Public Class SortRange
    Inherits Range
    Implements ISortRange, IRange, ICloneable
public ref class SortRange : public Range,
    ISortRange, IRange, ICloneable
type SortRange =
    class
        inherit Range
        interface ISortRange
        interface IRange
        interface ICloneable
    end

The SortRange type exposes the following members.

Constructors
 | Name | Description
Public method | SortRange(Int32) | Initializes a new instance of the SortRange class with specified index.
Public method | SortRange(IRange, Int32) | Initializes a new instance of the SortRange class with specified settings.
Top
Methods
 | Name | Description
Public method | Add | Adds specific ISortRange to range list.
Public method | Assign | Copies contents from another IRange object. (Overrides RangeAssign(IRange).)
Public method | BlockDeleting | Removes all ranges from specified region.
Public method | Clear | Clears IRange collection.
Public method | Clone | Creates a new object that is a copy of the current ISortRange object. (Overrides RangeClone.)
Public method | Contains | Indicates whether the range container contains a specific IRange entry.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRanges | Fills list specified by Ranges parameter with this ISortRange.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PositionChanged | Updates specified position by DeltaX and DeltaY values for any ranges in the collection.
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted. (Inherited from Range.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EndPoint | Gets or sets end of ISortRange area. (Overrides RangeEndPoint.)
Public property | Index | Represents index of this ISortRange within the top level ranges collection.
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size. (Inherited from Range.)
Public property | Range | Represents current IRange object in the ranges list.
Public property | Ranges | Represents collection of IRange objects stored in this range list.
Public property | Size | Gets or sets size of IRange area. (Inherited from Range.)
Public property | StartPoint | Gets or sets begin of ISortRange area. (Overrides RangeStartPoint.)
Top
See Also

Reference

Alternet.Common Namespace


SortRange Constructor

SortRange Constructor
Overload List
 | Name | Description
Public method | SortRange(Int32) | Initializes a new instance of the SortRange class with specified index.
Public method | SortRange(IRange, Int32) | Initializes a new instance of the SortRange class with specified settings.
Top
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange Constructor (Int32)

SortRange Constructor (Int32)
Initializes a new instance of the SortRange class with specified index.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SortRange(
    int index
)
Public Sub New (
    index As Integer
)
public:
SortRange(
    int index
)
new :
        index : int -> SortRange

Parameters

index
Type: SystemInt32
Index of this new instance within the top level ranges collection.
See Also

Reference

SortRange Class
SortRange Overload
Alternet.Common Namespace


SortRange Constructor (IRange, Int32)

SortRange Constructor (IRange, Int32)
Initializes a new instance of the SortRange class with specified settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SortRange(
    IRange range,
    int index
)
Public Sub New (
    range As IRange,
    index As Integer
)
public:
SortRange(
    IRange^ range,
    int index
)
new :
        range : IRange *
        index : int -> SortRange

Parameters

range
Type: Alternet.CommonIRange
Current IRange object.
index
Type: SystemInt32
Index of this new instance within the top level ranges collection.
See Also

Reference

SortRange Class
SortRange Overload
Alternet.Common Namespace


SortRange Methods

SortRange Methods

The SortRange type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds specific ISortRange to range list.
Public method | Assign | Copies contents from another IRange object. (Overrides RangeAssign(IRange).)
Public method | BlockDeleting | Removes all ranges from specified region.
Public method | Clear | Clears IRange collection.
Public method | Clone | Creates a new object that is a copy of the current ISortRange object. (Overrides RangeClone.)
Public method | Contains | Indicates whether the range container contains a specific IRange entry.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRanges | Fills list specified by Ranges parameter with this ISortRange.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PositionChanged | Updates specified position by DeltaX and DeltaY values for any ranges in the collection.
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted. (Inherited from Range.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.Add Method

SortRangeAdd Method
Adds specific ISortRange to range list.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Add(
    ISortRange range
)
Public Overridable Function Add (
    range As ISortRange
) As Integer
public:
virtual int Add(
    ISortRange^ range
)
abstract Add :
        range : ISortRange -> int
override Add :
        range : ISortRange -> int

Parameters

range
Type: Alternet.CommonISortRange
ISortRange to add.

Return Value

Type: Int32
The position into which the new range was added.

Implements

ISortRangeAdd(ISortRange)
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.Assign Method

SortRangeAssign Method
Copies contents from another IRange object.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Assign(
    IRange source
)
Public Overrides Sub Assign (
    source As IRange
)
public:
virtual void Assign(
    IRange^ source
) override
abstract Assign :
        source : IRange -> unit
override Assign :
        source : IRange -> unit

Parameters

source
Type: Alternet.CommonIRange

Implements

IRangeAssign(IRange)
IRangeAssign(IRange)
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.BlockDeleting Method

SortRangeBlockDeleting Method
Removes all ranges from specified region.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect,
    IRangeList list,
    IComparer<IRange> comparer
)
Public Overridable Function BlockDeleting (
    rect As Rectangle,
    list As IRangeList,
    comparer As IComparer(Of IRange)
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect,
    IRangeList^ list,
    IComparer<IRange^>^ comparer
)
abstract BlockDeleting :
        rect : Rectangle *
        list : IRangeList *
        comparer : IComparer<IRange> -> bool
override BlockDeleting :
        rect : Rectangle *
        list : IRangeList *
        comparer : IComparer<IRange> -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to remove ranges from.
list
Type: Alternet.CommonIRangeList
List to update.
comparer
Type: System.Collections.GenericIComparerIRange
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISortRangeBlockDeleting(Rectangle, IRangeList, IComparerIRange)
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.Clear Method

SortRangeClear Method
Clears IRange collection.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ISortRangeClear
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.Clone Method

SortRangeClone Method
Creates a new object that is a copy of the current ISortRange object.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object Clone()
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of System.Object that is the memberwise clone of the current SortRange object.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.Contains Method

SortRangeContains Method
Indicates whether the range container contains a specific IRange entry.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    IRange range
)
Public Overridable Function Contains (
    range As IRange
) As Boolean
public:
virtual bool Contains(
    IRange^ range
)
abstract Contains :
        range : IRange -> bool
override Contains :
        range : IRange -> bool

Parameters

range
Type: Alternet.CommonIRange
The IRange to locate in the range list.

Return Value

Type: Boolean
True if IRange entry is found; otherwise false.

Implements

ISortRangeContains(IRange)
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.GetRanges Method

SortRangeGetRanges Method
Fills list specified by Ranges parameter with this ISortRange.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GetRanges(
    IList<IRange> ranges
)
Public Sub GetRanges (
    ranges As IList(Of IRange)
)
public:
virtual void GetRanges(
    IList<IRange^>^ ranges
) sealed
abstract GetRanges :
        ranges : IList<IRange> -> unit
override GetRanges :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.

Implements

ISortRangeGetRanges(IListIRange)
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.PositionChanged Method

SortRangePositionChanged Method
Updates specified position by DeltaX and DeltaY values for any ranges in the collection.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IRangeList list,
    IComparer<IRange> comparer
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    list As IRangeList,
    comparer As IComparer(Of IRange)
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IRangeList^ list,
    IComparer<IRange^>^ comparer
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        list : IRangeList *
        comparer : IComparer<IRange> -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        list : IRangeList *
        comparer : IComparer<IRange> -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
list
Type: Alternet.CommonIRangeList
List to update.
comparer
Type: System.Collections.GenericIComparerIRange
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISortRangePositionChanged(Int32, Int32, Int32, Int32, IRangeList, IComparerIRange)
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange Properties

SortRange Properties

The SortRange type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets end of ISortRange area. (Overrides RangeEndPoint.)
Public property | Index | Represents index of this ISortRange within the top level ranges collection.
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size. (Inherited from Range.)
Public property | Range | Represents current IRange object in the ranges list.
Public property | Ranges | Represents collection of IRange objects stored in this range list.
Public property | Size | Gets or sets size of IRange area. (Inherited from Range.)
Public property | StartPoint | Gets or sets begin of ISortRange area. (Overrides RangeStartPoint.)
Top
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.EndPoint Property

SortRangeEndPoint Property
Gets or sets end of ISortRange area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Point EndPoint { get; set; }
Public Overrides Property EndPoint As Point
    Get
    Set
public:
virtual property Point EndPoint {
    Point get () override;
    void set (Point value) override;
}
abstract EndPoint : Point with get, set
override EndPoint : Point with get, set

Property Value

Type: Point

Implements

IRangeEndPoint
IRangeEndPoint
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.Index Property

SortRangeIndex Property
Represents index of this ISortRange within the top level ranges collection.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Index { get; }
Public Overridable ReadOnly Property Index As Integer
    Get
public:
virtual property int Index {
    int get ();
}
abstract Index : int with get
override Index : int with get

Property Value

Type: Int32

Implements

ISortRangeIndex
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.Range Property

SortRangeRange Property
Represents current IRange object in the ranges list.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRange Range { get; }
Public ReadOnly Property Range As IRange
    Get
public:
virtual property IRange^ Range {
    IRange^ get () sealed;
}
abstract Range : IRange with get
override Range : IRange with get

Property Value

Type: IRange

Implements

ISortRangeRange
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.Ranges Property

SortRangeRanges Property
Represents collection of IRange objects stored in this range list.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISortList<IRange> Ranges { get; }
Public Overridable ReadOnly Property Ranges As ISortList(Of IRange)
    Get
public:
virtual property ISortList<IRange^>^ Ranges {
    ISortList<IRange^>^ get ();
}
abstract Ranges : ISortList<IRange> with get
override Ranges : ISortList<IRange> with get

Property Value

Type: ISortList IRange

Implements

ISortRangeRanges
See Also

Reference

SortRange Class
Alternet.Common Namespace


SortRange.StartPoint Property

SortRangeStartPoint Property
Gets or sets begin of ISortRange area.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Point StartPoint { get; set; }
Public Overrides Property StartPoint As Point
    Get
    Set
public:
virtual property Point StartPoint {
    Point get () override;
    void set (Point value) override;
}
abstract StartPoint : Point with get, set
override StartPoint : Point with get, set

Property Value

Type: Point

Implements

IRangeStartPoint
IRangeStartPoint
See Also

Reference

SortRange Class
Alternet.Common Namespace


SpeedButton Class

SpeedButton Class
Represents a Windows button - like control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.CommonSpeedButton

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpeedButton : Control
Public Class SpeedButton
    Inherits Control
public ref class SpeedButton : public Control
type SpeedButton =
    class
        inherit Control
    end

The SpeedButton type exposes the following members.

Constructors
 | Name | Description
Public method | SpeedButton | Initializes a new instance of the SpeedButton class with default settings.
Public method | SpeedButton(IContainer) | Initializes a new instance of the SpeedButton class with specified container.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | OnCheckedChanged | Raises the CheckedChaged event.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowCheck | Gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets border color of this SpeedButton.
Public property | BorderStyle | Gets or sets border style of this SpeedButton.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Checked | Gets or sets a value indicating whether button appears pressed.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageIndex | Gets or sets the index value of the image displayed on this SpeedButton.
Public property | ImageList | Gets or sets the ImageList that contains the images to display in this SpeedButton.
Public property | ImageListHighDpi | Gets or sets the ImageList that contains the images to display in this SpeedButton for high DPI.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes.
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Common Namespace


SpeedButton Constructor

SpeedButton Constructor
Overload List
 | Name | Description
Public method | SpeedButton | Initializes a new instance of the SpeedButton class with default settings.
Public method | SpeedButton(IContainer) | Initializes a new instance of the SpeedButton class with specified container.
Top
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton Constructor

SpeedButton Constructor
Initializes a new instance of the SpeedButton class with default settings.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpeedButton()
Public Sub New
public:
SpeedButton()
new : unit -> SpeedButton
See Also

Reference

SpeedButton Class
SpeedButton Overload
Alternet.Common Namespace


SpeedButton Constructor (IContainer)

SpeedButton Constructor (IContainer)
Initializes a new instance of the SpeedButton class with specified container.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpeedButton(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
SpeedButton(
    IContainer^ container
)
new :
        container : IContainer -> SpeedButton

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

SpeedButton Class
SpeedButton Overload
Alternet.Common Namespace


SpeedButton Methods

SpeedButton Methods

The SpeedButton type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | OnCheckedChanged | Raises the CheckedChaged event.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton.OnCheckedChanged Method

SpeedButtonOnCheckedChanged Method
Raises the CheckedChaged event.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnCheckedChanged(
    EventArgs args
)
Public Overridable Sub OnCheckedChanged (
    args As EventArgs
)
public:
virtual void OnCheckedChanged(
    EventArgs^ args
)
abstract OnCheckedChanged :
        args : EventArgs -> unit
override OnCheckedChanged :
        args : EventArgs -> unit

Parameters

args
Type: SystemEventArgs
The EventArgs that contains data to this event.
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton Properties

SpeedButton Properties

The SpeedButton type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowCheck | Gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets border color of this SpeedButton.
Public property | BorderStyle | Gets or sets border style of this SpeedButton.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | Checked | Gets or sets a value indicating whether button appears pressed.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImageIndex | Gets or sets the index value of the image displayed on this SpeedButton.
Public property | ImageList | Gets or sets the ImageList that contains the images to display in this SpeedButton.
Public property | ImageListHighDpi | Gets or sets the ImageList that contains the images to display in this SpeedButton for high DPI.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton.AllowCheck Property

SpeedButtonAllowCheck Property
Gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowCheck { get; set; }
Public Property AllowCheck As Boolean
    Get
    Set
public:
property bool AllowCheck {
    bool get ();
    void set (bool value);
}
member AllowCheck : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton.BorderColor Property

SpeedButtonBorderColor Property
Gets or sets border color of this SpeedButton.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
member BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton.BorderStyle Property

SpeedButtonBorderStyle Property
Gets or sets border style of this SpeedButton.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditBorderStyle BorderStyle { get; set; }
Public Property BorderStyle As EditBorderStyle
    Get
    Set
public:
property EditBorderStyle BorderStyle {
    EditBorderStyle get ();
    void set (EditBorderStyle value);
}
member BorderStyle : EditBorderStyle with get, set

Property Value

Type: EditBorderStyle
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton.Checked Property

SpeedButtonChecked Property
Gets or sets a value indicating whether button appears pressed.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set
public:
property bool Checked {
    bool get ();
    void set (bool value);
}
member Checked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton.ImageIndex Property

SpeedButtonImageIndex Property
Gets or sets the index value of the image displayed on this SpeedButton.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ImageIndex { get; set; }
Public Property ImageIndex As Integer
    Get
    Set
public:
property int ImageIndex {
    int get ();
    void set (int value);
}
member ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton.ImageList Property

SpeedButtonImageList Property
Gets or sets the ImageList that contains the images to display in this SpeedButton.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageList ImageList { get; set; }
Public Property ImageList As ImageList
    Get
    Set
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}
member ImageList : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton.ImageListHighDpi Property

SpeedButtonImageListHighDpi Property
Gets or sets the ImageList that contains the images to display in this SpeedButton for high DPI.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageList ImageListHighDpi { get; set; }
Public Property ImageListHighDpi As ImageList
    Get
    Set
public:
property ImageList^ ImageListHighDpi {
    ImageList^ get ();
    void set (ImageList^ value);
}
member ImageListHighDpi : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton Events

SpeedButton Events

The SpeedButton type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes.
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


SpeedButton.CheckedChanged Event

SpeedButtonCheckedChanged Event
Occurs when the value of the Checked property changes.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler CheckedChanged
Public Event CheckedChanged As EventHandler
public:
 event EventHandler^ CheckedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CheckedChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SpeedButton Class
Alternet.Common Namespace


StreamExtensions Class

StreamExtensions Class
Contains extension methods for Stream object.
Inheritance Hierarchy
SystemObject
Alternet.CommonStreamExtensions

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StreamExtensions
<ExtensionAttribute>
Public NotInheritable Class StreamExtensions
[ExtensionAttribute]
public ref class StreamExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type StreamExtensions =  class end

The StreamExtensions type exposes the following members.

Methods
Name | Description
CreateStreamFromString | Creates a Stream object that holds specified string.
GetAllBytes | Receives content of the specified input.
GetAllText | Receives content of the specified input.
Top
See Also

Reference

Alternet.Common Namespace


StreamExtensions Methods

StreamExtensions Methods

The StreamExtensions type exposes the following members.

Methods
Name | Description
CreateStreamFromString | Creates a Stream object that holds specified string.
GetAllBytes | Receives content of the specified input.
GetAllText | Receives content of the specified input.
Top
See Also

Reference

StreamExtensions Class
Alternet.Common Namespace


StreamExtensions.CreateStreamFromString Method

StreamExtensionsCreateStreamFromString Method
Creates a Stream object that holds specified string.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Stream CreateStreamFromString(
    string s
)
Public Shared Function CreateStreamFromString (
    s As String
) As Stream
public:
static Stream^ CreateStreamFromString(
    String^ s
)
static member CreateStreamFromString :
        s : string -> Stream

Parameters

s
Type: SystemString
String to process.

Return Value

Type: Stream
Stream containing given string data.
See Also

Reference

StreamExtensions Class
Alternet.Common Namespace


StreamExtensions.GetAllBytes Method

StreamExtensionsGetAllBytes Method
Receives content of the specified input.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static byte[] GetAllBytes(
    this Stream input
)
<ExtensionAttribute>
Public Shared Function GetAllBytes (
    input As Stream
) As Byte()
public:
[ExtensionAttribute]
static array<unsigned char>^ GetAllBytes(
    Stream^ input
)
[<ExtensionAttribute>]
static member GetAllBytes :
        input : Stream -> byte[]

Parameters

input
Type: System.IOStream
Stream object to process.

Return Value

Type: Byte
Array of bytes representing content of the stream.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StreamExtensions Class
Alternet.Common Namespace


StreamExtensions.GetAllText Method

StreamExtensionsGetAllText Method
Receives content of the specified input.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetAllText(
    this Stream input
)
<ExtensionAttribute>
Public Shared Function GetAllText (
    input As Stream
) As String
public:
[ExtensionAttribute]
static String^ GetAllText(
    Stream^ input
)
[<ExtensionAttribute>]
static member GetAllText :
        input : Stream -> string

Parameters

input
Type: System.IOStream
Stream object to process.

Return Value

Type: String
String representing content of the stream.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StreamExtensions Class
Alternet.Common Namespace


StringConsts Class

StringConsts Class
Contains localizable string constants.
Inheritance Hierarchy
SystemObject
Alternet.CommonStringConsts

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StringConsts
Public Class StringConsts
public ref class StringConsts
type StringConsts =  class end

The StringConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Localize |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AddToWatchCaption |
AddWatchCaption |
AddWatchCaptionEvaluateDlg |
AllOpenDocumentsScope |
AssertionFailed |
BackwardDirection |
BeginLineCaption |
CancelCaptionGotoDlg |
CancelCaptionPrintOptionsDlg |
CancelCaptionSearchModalDlg |
CancelCaptionWatchDlg |
CaseSensitiveCaption |
CategoryAssemblies |
CategoryClasses |
CategoryConstants |
CategoryDelegates |
CategoryEnums |
CategoryEvents |
CategoryExtensionMethods |
CategoryFields |
CategoryInterfaces |
CategoryKeywords |
CategoryLocals |
CategoryMethods |
CategoryModules |
CategoryNamespaces |
CategoryOperators |
CategoryParameters |
CategoryProperties |
CategoryReferences |
CategorySnippets |
CategoryStructs |
ClearAllCaption |
CloseAllTabs |
CloseCaption |
CloseCaptionEvaluateDlg |
CloseTab |
CodeSnippetsEditField |
CodeSnippetsInternalName |
CodeSnippetTooltipHeader |
ColumnHeaderCode |
ColumnHeaderDescription |
ColumnHeaderFile |
ColumnHeaderID |
ColumnHeaderLine |
ColumnHeaderName |
ColumnHeaderScope |
ColumnHeaderSource |
CommentsInternalName |
ConfirmAll |
ConfirmCancel |
ConfirmNo |
ConfirmReplace |
ConfirmReplaceText |
ConfirmYes |
CopyCaption |
CopyValueCaption |
CurrentDocumentCaption |
CurrentDocumentScope |
CurrentProjectScope |
DebugCaption |
DebuggerBreak |
DebuggerCompile |
DebuggerContinue |
DebuggerEvaluate |
DebuggerStart |
DebuggerStepInto |
DebuggerStepOver |
DebuggerStop |
DefaultDragMarginHint |
DefaultHyperTextHint |
DeleteBreakpointCaption |
DeleteWatchCaption |
DirectionModalCaption |
DirectivesInternalName |
DisableBreakpointCaption |
DisplayProgressCaption |
DlgGotoCaption |
DlgPrintOptionsCaption |
DlgReplaceCaption |
DlgSearchCaption |
DlgSearchReplaceCaption |
EditWatchCaption |
EmptyColor |
EmptyOption |
EnableBreakpointCaption |
EndLineCaption |
EnterNewLineCaption |
EntireScopeCaption |
EnumValueNotSupported |
ErrArglistParameter |
ErrArrayParamSpecifier |
ErrCantFindDeclaration |
ErrCatchOrFinallyExpected |
ErrDefaultParamNotPermitted |
ErrEndOfFileFound |
ErrExpected |
ErrFieldInitializerExpected |
ErrFixedPointerDeclaration |
ErrIdentifierExpected |
ErrInExpected |
ErrInterfaceDeclaration |
ErrInterfaceMemberDeclaration |
ErrNamespaceDeclaration |
ErrNamespaceModifier |
ErrNamespaceModifiers |
ErrNewExpression |
ErrorCaption |
ErrorCode |
ErrorsCaption |
ErrorsText |
ErrorText |
ErrStackallocExpression |
ErrSyntax |
ErrTypeExpected |
ErrWhileExpected |
EscapeCaption |
EvaluateCaptionEvaluateDlg |
EvaluateDlgCaption |
ExpressionCaptionWatchDlg |
FileNameCaption |
FileToPrintCaption |
FindAllCaption |
FindImplementations |
FindNextCaption |
FindOptionsCaption |
FindOptionsModalCaption |
FindPreviousCaption |
FindReferences |
FindWhatCaption |
FindWhatModalCaption |
FindWhatTextCaption |
FolderNode |
ForwardDirection |
FromCursorCaption |
GeneralCaption |
GenericTypesOverloads |
GotoDefinition |
GotoLocationCaption |
GoToSourceCodeCaption |
HelpCaption |
HTMLParamsInternalName |
HyperTextColorStr |
IdentsInternalName |
InsertDelegateExtendedHint |
InsertDelegateHint |
InvalidMarginColumn |
InvalidPropName |
InvalidRange |
InvalidReference |
InvalidTabStop |
InvalidTypeName |
LineBreakCaption |
LineNofMstr |
LineNumberCaption |
LineNumbersCaptionPrintOptionsDlg |
LineStr |
LookInCaption |
MarkAllCaption |
MatchCaseCaption |
MatchWholeWordCaption |
MenuAddLibraryCaption |
MenuAddTabCaption |
MenuAlignBottomsCaption |
MenuAlignCentersCaption |
MenuAlignLeftsCaption |
MenuAlignmentCaption |
MenuAlignMiddlesCaption |
MenuAlignRightsCaption |
MenuAlignTopsCaption |
MenuArrangeBottomCaption |
MenuArrangeHorizontalMiddleCaption |
MenuArrangeLeftCaption |
MenuArrangeRightCaption |
MenuArrangeTopCaption |
MenuArrangeVerticalMiddleCaption |
MenuBindingCaption |
MenuBringToFrontCaption |
MenuCenterHorzCaption |
MenuCenterVertCaption |
MenuCopyCaption |
MenuCutCaption |
MenuDeleteCaption |
MenuDisplayCustomEditorCaption |
MenuEditStyleCaption |
MenuFormattedTextEditorCaption |
MenuMakeHorzSpacingEqualCaption |
MenuMakeSameHeightCaption |
MenuMakeSameSizeCaption |
MenuMakeSameWidthCaption |
MenuMakeVertSpacingEqualCaption |
MenuMoveDownCaption |
MenuMoveUpCaption |
MenuPasteCaption |
MenuPropertiesCaption |
MenuRasterPlacementCaption |
MenuRedoCaption |
MenuRemoveHorzSpacingCaption |
MenuRemoveVertSpacingCaption |
MenuRenameCaption |
MenuRenameItemCaption |
MenuRenameTabCaption |
MenuResetCaption |
MenuResetToolboxCaption |
MenuSelectAllCaption |
MenuSendToBackCaption |
MenuSnaplinePlacementCaption |
MenuUndoCaption |
MenuViewCodeCaption |
MenuWrapInBorderCaption |
MenuWrapInCanvasCaption |
MenuWrapInGridCaption |
MenuWrapInViewboxCaption |
MenuZoomInCaption |
MenuZoomOutCaption |
MenuZoomToActualCaption |
MenuZoomToFitCaption |
MethodOverloads |
NextErrorCaption |
NoCodeCompletionSuggestions |
NofMstr |
NumbersInternalName |
OccurrencesReplaced |
OKCaptionGotoDlg |
OkCaptionPrintOptionsDlg |
OKCaptionSsearchModalDlg |
OKCaptionWatchDlg |
OneCharInSetCaption |
OneCharNotInSetCaption |
OneOrMoreCaption |
OptionsCaption |
OrCaption |
OriginModalCatpion |
PageNofMstr |
PageNumbersCaption |
PageStr |
ParameterCannotBeEmptyIEnumerable |
ParameterCannotBeEmptyString |
PreviousErrorCaption |
PrintOptions |
PrintOptionsButtonText |
PrintSelectionCaption |
PromptOnReplaceCaption |
RasterWidthText |
ReferenceInternalName |
RegularExpressionsCaption |
ReplaceAllCaption |
ReplaceCaption |
ReplaceWithCaption |
ReswordsInternalName |
ScopeModalCaption |
SearchCaption |
SearchHiddenTextCaption |
SearchReachedStartPos |
SearchResultInternalName |
SearchUpCaption |
SelectedTextScope |
SelectionOnlyCaption |
SetNextStatement |
ShowLineNumbersCaption |
ShowParameterNamesCaption |
ShowParameterTypesCaption |
ShowPotentialFixesCaption |
ShowPotentialFixesShortCuts |
SingleCharCaption |
StatusModified |
StatusOverwrite |
StatusReadOnly |
StatusText |
StringNotFound |
StringsInternalName |
SwitchToFrameCaption |
SymbolsInternalName |
SyntaxErrorsInternalName |
TabAllText |
TabCommonText |
TagCaption |
TagExpressionCaption |
ThreadCode |
ToggleBreakpoint |
ToggleReplaceCaption |
UseColorsCaption |
UseFooterCaption |
UseHeaderCaption |
UseRegularExpressionsCaption |
UseSyntaxCaption |
WarningsCaption |
WarningsText |
WarningText |
WatchDlgCaption |
WhiteSpaceInternalName |
WholeWordsOnlyCaption |
WordWrapCaptionPrintOptionsDlg |
XMLCommentsInternalName |
ZeroOrMoreCaption |
Top
See Also

Reference

Alternet.Common Namespace


StringConsts Fields

StringConsts Fields

The StringConsts type exposes the following members.

Fields
Name | Description
AddToWatchCaption |
AddWatchCaption |
AddWatchCaptionEvaluateDlg |
AllOpenDocumentsScope |
AssertionFailed |
BackwardDirection |
BeginLineCaption |
CancelCaptionGotoDlg |
CancelCaptionPrintOptionsDlg |
CancelCaptionSearchModalDlg |
CancelCaptionWatchDlg |
CaseSensitiveCaption |
CategoryAssemblies |
CategoryClasses |
CategoryConstants |
CategoryDelegates |
CategoryEnums |
CategoryEvents |
CategoryExtensionMethods |
CategoryFields |
CategoryInterfaces |
CategoryKeywords |
CategoryLocals |
CategoryMethods |
CategoryModules |
CategoryNamespaces |
CategoryOperators |
CategoryParameters |
CategoryProperties |
CategoryReferences |
CategorySnippets |
CategoryStructs |
ClearAllCaption |
CloseAllTabs |
CloseCaption |
CloseCaptionEvaluateDlg |
CloseTab |
CodeSnippetsEditField |
CodeSnippetsInternalName |
CodeSnippetTooltipHeader |
ColumnHeaderCode |
ColumnHeaderDescription |
ColumnHeaderFile |
ColumnHeaderID |
ColumnHeaderLine |
ColumnHeaderName |
ColumnHeaderScope |
ColumnHeaderSource |
CommentsInternalName |
ConfirmAll |
ConfirmCancel |
ConfirmNo |
ConfirmReplace |
ConfirmReplaceText |
ConfirmYes |
CopyCaption |
CopyValueCaption |
CurrentDocumentCaption |
CurrentDocumentScope |
CurrentProjectScope |
DebugCaption |
DebuggerBreak |
DebuggerCompile |
DebuggerContinue |
DebuggerEvaluate |
DebuggerStart |
DebuggerStepInto |
DebuggerStepOver |
DebuggerStop |
DefaultDragMarginHint |
DefaultHyperTextHint |
DeleteBreakpointCaption |
DeleteWatchCaption |
DirectionModalCaption |
DirectivesInternalName |
DisableBreakpointCaption |
DisplayProgressCaption |
DlgGotoCaption |
DlgPrintOptionsCaption |
DlgReplaceCaption |
DlgSearchCaption |
DlgSearchReplaceCaption |
EditWatchCaption |
EmptyColor |
EmptyOption |
EnableBreakpointCaption |
EndLineCaption |
EnterNewLineCaption |
EntireScopeCaption |
EnumValueNotSupported |
ErrArglistParameter |
ErrArrayParamSpecifier |
ErrCantFindDeclaration |
ErrCatchOrFinallyExpected |
ErrDefaultParamNotPermitted |
ErrEndOfFileFound |
ErrExpected |
ErrFieldInitializerExpected |
ErrFixedPointerDeclaration |
ErrIdentifierExpected |
ErrInExpected |
ErrInterfaceDeclaration |
ErrInterfaceMemberDeclaration |
ErrNamespaceDeclaration |
ErrNamespaceModifier |
ErrNamespaceModifiers |
ErrNewExpression |
ErrorCaption |
ErrorCode |
ErrorsCaption |
ErrorsText |
ErrorText |
ErrStackallocExpression |
ErrSyntax |
ErrTypeExpected |
ErrWhileExpected |
EscapeCaption |
EvaluateCaptionEvaluateDlg |
EvaluateDlgCaption |
ExpressionCaptionWatchDlg |
FileNameCaption |
FileToPrintCaption |
FindAllCaption |
FindImplementations |
FindNextCaption |
FindOptionsCaption |
FindOptionsModalCaption |
FindPreviousCaption |
FindReferences |
FindWhatCaption |
FindWhatModalCaption |
FindWhatTextCaption |
FolderNode |
ForwardDirection |
FromCursorCaption |
GeneralCaption |
GenericTypesOverloads |
GotoDefinition |
GotoLocationCaption |
GoToSourceCodeCaption |
HelpCaption |
HTMLParamsInternalName |
HyperTextColorStr |
IdentsInternalName |
InsertDelegateExtendedHint |
InsertDelegateHint |
InvalidMarginColumn |
InvalidPropName |
InvalidRange |
InvalidReference |
InvalidTabStop |
InvalidTypeName |
LineBreakCaption |
LineNofMstr |
LineNumberCaption |
LineNumbersCaptionPrintOptionsDlg |
LineStr |
LookInCaption |
MarkAllCaption |
MatchCaseCaption |
MatchWholeWordCaption |
MenuAddLibraryCaption |
MenuAddTabCaption |
MenuAlignBottomsCaption |
MenuAlignCentersCaption |
MenuAlignLeftsCaption |
MenuAlignmentCaption |
MenuAlignMiddlesCaption |
MenuAlignRightsCaption |
MenuAlignTopsCaption |
MenuArrangeBottomCaption |
MenuArrangeHorizontalMiddleCaption |
MenuArrangeLeftCaption |
MenuArrangeRightCaption |
MenuArrangeTopCaption |
MenuArrangeVerticalMiddleCaption |
MenuBindingCaption |
MenuBringToFrontCaption |
MenuCenterHorzCaption |
MenuCenterVertCaption |
MenuCopyCaption |
MenuCutCaption |
MenuDeleteCaption |
MenuDisplayCustomEditorCaption |
MenuEditStyleCaption |
MenuFormattedTextEditorCaption |
MenuMakeHorzSpacingEqualCaption |
MenuMakeSameHeightCaption |
MenuMakeSameSizeCaption |
MenuMakeSameWidthCaption |
MenuMakeVertSpacingEqualCaption |
MenuMoveDownCaption |
MenuMoveUpCaption |
MenuPasteCaption |
MenuPropertiesCaption |
MenuRasterPlacementCaption |
MenuRedoCaption |
MenuRemoveHorzSpacingCaption |
MenuRemoveVertSpacingCaption |
MenuRenameCaption |
MenuRenameItemCaption |
MenuRenameTabCaption |
MenuResetCaption |
MenuResetToolboxCaption |
MenuSelectAllCaption |
MenuSendToBackCaption |
MenuSnaplinePlacementCaption |
MenuUndoCaption |
MenuViewCodeCaption |
MenuWrapInBorderCaption |
MenuWrapInCanvasCaption |
MenuWrapInGridCaption |
MenuWrapInViewboxCaption |
MenuZoomInCaption |
MenuZoomOutCaption |
MenuZoomToActualCaption |
MenuZoomToFitCaption |
MethodOverloads |
NextErrorCaption |
NoCodeCompletionSuggestions |
NofMstr |
NumbersInternalName |
OccurrencesReplaced |
OKCaptionGotoDlg |
OkCaptionPrintOptionsDlg |
OKCaptionSsearchModalDlg |
OKCaptionWatchDlg |
OneCharInSetCaption |
OneCharNotInSetCaption |
OneOrMoreCaption |
OptionsCaption |
OrCaption |
OriginModalCatpion |
PageNofMstr |
PageNumbersCaption |
PageStr |
ParameterCannotBeEmptyIEnumerable |
ParameterCannotBeEmptyString |
PreviousErrorCaption |
PrintOptions |
PrintOptionsButtonText |
PrintSelectionCaption |
PromptOnReplaceCaption |
RasterWidthText |
ReferenceInternalName |
RegularExpressionsCaption |
ReplaceAllCaption |
ReplaceCaption |
ReplaceWithCaption |
ReswordsInternalName |
ScopeModalCaption |
SearchCaption |
SearchHiddenTextCaption |
SearchReachedStartPos |
SearchResultInternalName |
SearchUpCaption |
SelectedTextScope |
SelectionOnlyCaption |
SetNextStatement |
ShowLineNumbersCaption |
ShowParameterNamesCaption |
ShowParameterTypesCaption |
ShowPotentialFixesCaption |
ShowPotentialFixesShortCuts |
SingleCharCaption |
StatusModified |
StatusOverwrite |
StatusReadOnly |
StatusText |
StringNotFound |
StringsInternalName |
SwitchToFrameCaption |
SymbolsInternalName |
SyntaxErrorsInternalName |
TabAllText |
TabCommonText |
TagCaption |
TagExpressionCaption |
ThreadCode |
ToggleBreakpoint |
ToggleReplaceCaption |
UseColorsCaption |
UseFooterCaption |
UseHeaderCaption |
UseRegularExpressionsCaption |
UseSyntaxCaption |
WarningsCaption |
WarningsText |
WarningText |
WatchDlgCaption |
WhiteSpaceInternalName |
WholeWordsOnlyCaption |
WordWrapCaptionPrintOptionsDlg |
XMLCommentsInternalName |
ZeroOrMoreCaption |
Top
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.AddToWatchCaption Field

StringConstsAddToWatchCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string AddToWatchCaption
Public Shared AddToWatchCaption As String
public:
static String^ AddToWatchCaption
static val mutable AddToWatchCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.AddWatchCaption Field

StringConstsAddWatchCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string AddWatchCaption
Public Shared AddWatchCaption As String
public:
static String^ AddWatchCaption
static val mutable AddWatchCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.AddWatchCaptionEvaluateDlg Field

StringConstsAddWatchCaptionEvaluateDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string AddWatchCaptionEvaluateDlg
Public Shared AddWatchCaptionEvaluateDlg As String
public:
static String^ AddWatchCaptionEvaluateDlg
static val mutable AddWatchCaptionEvaluateDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.AllOpenDocumentsScope Field

StringConstsAllOpenDocumentsScope Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string AllOpenDocumentsScope
Public Shared AllOpenDocumentsScope As String
public:
static String^ AllOpenDocumentsScope
static val mutable AllOpenDocumentsScope: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.AssertionFailed Field

StringConstsAssertionFailed Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string AssertionFailed
Public Shared AssertionFailed As String
public:
static String^ AssertionFailed
static val mutable AssertionFailed: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.BackwardDirection Field

StringConstsBackwardDirection Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string BackwardDirection
Public Shared BackwardDirection As String
public:
static String^ BackwardDirection
static val mutable BackwardDirection: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.BeginLineCaption Field

StringConstsBeginLineCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string BeginLineCaption
Public Shared BeginLineCaption As String
public:
static String^ BeginLineCaption
static val mutable BeginLineCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CancelCaptionGotoDlg Field

StringConstsCancelCaptionGotoDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CancelCaptionGotoDlg
Public Shared CancelCaptionGotoDlg As String
public:
static String^ CancelCaptionGotoDlg
static val mutable CancelCaptionGotoDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CancelCaptionPrintOptionsDlg Field

StringConstsCancelCaptionPrintOptionsDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CancelCaptionPrintOptionsDlg
Public Shared CancelCaptionPrintOptionsDlg As String
public:
static String^ CancelCaptionPrintOptionsDlg
static val mutable CancelCaptionPrintOptionsDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CancelCaptionSearchModalDlg Field

StringConstsCancelCaptionSearchModalDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CancelCaptionSearchModalDlg
Public Shared CancelCaptionSearchModalDlg As String
public:
static String^ CancelCaptionSearchModalDlg
static val mutable CancelCaptionSearchModalDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CancelCaptionWatchDlg Field

StringConstsCancelCaptionWatchDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CancelCaptionWatchDlg
Public Shared CancelCaptionWatchDlg As String
public:
static String^ CancelCaptionWatchDlg
static val mutable CancelCaptionWatchDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CaseSensitiveCaption Field

StringConstsCaseSensitiveCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CaseSensitiveCaption
Public Shared CaseSensitiveCaption As String
public:
static String^ CaseSensitiveCaption
static val mutable CaseSensitiveCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryAssemblies Field

StringConstsCategoryAssemblies Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryAssemblies
Public Shared CategoryAssemblies As String
public:
static String^ CategoryAssemblies
static val mutable CategoryAssemblies: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryClasses Field

StringConstsCategoryClasses Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryClasses
Public Shared CategoryClasses As String
public:
static String^ CategoryClasses
static val mutable CategoryClasses: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryConstants Field

StringConstsCategoryConstants Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryConstants
Public Shared CategoryConstants As String
public:
static String^ CategoryConstants
static val mutable CategoryConstants: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryDelegates Field

StringConstsCategoryDelegates Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryDelegates
Public Shared CategoryDelegates As String
public:
static String^ CategoryDelegates
static val mutable CategoryDelegates: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryEnums Field

StringConstsCategoryEnums Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryEnums
Public Shared CategoryEnums As String
public:
static String^ CategoryEnums
static val mutable CategoryEnums: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryEvents Field

StringConstsCategoryEvents Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryEvents
Public Shared CategoryEvents As String
public:
static String^ CategoryEvents
static val mutable CategoryEvents: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryExtensionMethods Field

StringConstsCategoryExtensionMethods Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryExtensionMethods
Public Shared CategoryExtensionMethods As String
public:
static String^ CategoryExtensionMethods
static val mutable CategoryExtensionMethods: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryFields Field

StringConstsCategoryFields Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryFields
Public Shared CategoryFields As String
public:
static String^ CategoryFields
static val mutable CategoryFields: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryInterfaces Field

StringConstsCategoryInterfaces Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryInterfaces
Public Shared CategoryInterfaces As String
public:
static String^ CategoryInterfaces
static val mutable CategoryInterfaces: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryKeywords Field

StringConstsCategoryKeywords Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryKeywords
Public Shared CategoryKeywords As String
public:
static String^ CategoryKeywords
static val mutable CategoryKeywords: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryLocals Field

StringConstsCategoryLocals Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryLocals
Public Shared CategoryLocals As String
public:
static String^ CategoryLocals
static val mutable CategoryLocals: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryMethods Field

StringConstsCategoryMethods Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryMethods
Public Shared CategoryMethods As String
public:
static String^ CategoryMethods
static val mutable CategoryMethods: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryModules Field

StringConstsCategoryModules Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryModules
Public Shared CategoryModules As String
public:
static String^ CategoryModules
static val mutable CategoryModules: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryNamespaces Field

StringConstsCategoryNamespaces Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryNamespaces
Public Shared CategoryNamespaces As String
public:
static String^ CategoryNamespaces
static val mutable CategoryNamespaces: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryOperators Field

StringConstsCategoryOperators Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryOperators
Public Shared CategoryOperators As String
public:
static String^ CategoryOperators
static val mutable CategoryOperators: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryParameters Field

StringConstsCategoryParameters Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryParameters
Public Shared CategoryParameters As String
public:
static String^ CategoryParameters
static val mutable CategoryParameters: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryProperties Field

StringConstsCategoryProperties Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryProperties
Public Shared CategoryProperties As String
public:
static String^ CategoryProperties
static val mutable CategoryProperties: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryReferences Field

StringConstsCategoryReferences Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryReferences
Public Shared CategoryReferences As String
public:
static String^ CategoryReferences
static val mutable CategoryReferences: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategorySnippets Field

StringConstsCategorySnippets Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategorySnippets
Public Shared CategorySnippets As String
public:
static String^ CategorySnippets
static val mutable CategorySnippets: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CategoryStructs Field

StringConstsCategoryStructs Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryStructs
Public Shared CategoryStructs As String
public:
static String^ CategoryStructs
static val mutable CategoryStructs: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ClearAllCaption Field

StringConstsClearAllCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ClearAllCaption
Public Shared ClearAllCaption As String
public:
static String^ ClearAllCaption
static val mutable ClearAllCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CloseAllTabs Field

StringConstsCloseAllTabs Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CloseAllTabs
Public Shared CloseAllTabs As String
public:
static String^ CloseAllTabs
static val mutable CloseAllTabs: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CloseCaption Field

StringConstsCloseCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CloseCaption
Public Shared CloseCaption As String
public:
static String^ CloseCaption
static val mutable CloseCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CloseCaptionEvaluateDlg Field

StringConstsCloseCaptionEvaluateDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CloseCaptionEvaluateDlg
Public Shared CloseCaptionEvaluateDlg As String
public:
static String^ CloseCaptionEvaluateDlg
static val mutable CloseCaptionEvaluateDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CloseTab Field

StringConstsCloseTab Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CloseTab
Public Shared CloseTab As String
public:
static String^ CloseTab
static val mutable CloseTab: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CodeSnippetsEditField Field

StringConstsCodeSnippetsEditField Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeSnippetsEditField
Public Shared CodeSnippetsEditField As String
public:
static String^ CodeSnippetsEditField
static val mutable CodeSnippetsEditField: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CodeSnippetsInternalName Field

StringConstsCodeSnippetsInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeSnippetsInternalName
Public Shared CodeSnippetsInternalName As String
public:
static String^ CodeSnippetsInternalName
static val mutable CodeSnippetsInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CodeSnippetTooltipHeader Field

StringConstsCodeSnippetTooltipHeader Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeSnippetTooltipHeader
Public Shared CodeSnippetTooltipHeader As String
public:
static String^ CodeSnippetTooltipHeader
static val mutable CodeSnippetTooltipHeader: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ColumnHeaderCode Field

StringConstsColumnHeaderCode Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColumnHeaderCode
Public Shared ColumnHeaderCode As String
public:
static String^ ColumnHeaderCode
static val mutable ColumnHeaderCode: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ColumnHeaderDescription Field

StringConstsColumnHeaderDescription Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColumnHeaderDescription
Public Shared ColumnHeaderDescription As String
public:
static String^ ColumnHeaderDescription
static val mutable ColumnHeaderDescription: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ColumnHeaderFile Field

StringConstsColumnHeaderFile Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColumnHeaderFile
Public Shared ColumnHeaderFile As String
public:
static String^ ColumnHeaderFile
static val mutable ColumnHeaderFile: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ColumnHeaderID Field

StringConstsColumnHeaderID Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColumnHeaderID
Public Shared ColumnHeaderID As String
public:
static String^ ColumnHeaderID
static val mutable ColumnHeaderID: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ColumnHeaderLine Field

StringConstsColumnHeaderLine Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColumnHeaderLine
Public Shared ColumnHeaderLine As String
public:
static String^ ColumnHeaderLine
static val mutable ColumnHeaderLine: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ColumnHeaderName Field

StringConstsColumnHeaderName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColumnHeaderName
Public Shared ColumnHeaderName As String
public:
static String^ ColumnHeaderName
static val mutable ColumnHeaderName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ColumnHeaderScope Field

StringConstsColumnHeaderScope Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColumnHeaderScope
Public Shared ColumnHeaderScope As String
public:
static String^ ColumnHeaderScope
static val mutable ColumnHeaderScope: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ColumnHeaderSource Field

StringConstsColumnHeaderSource Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColumnHeaderSource
Public Shared ColumnHeaderSource As String
public:
static String^ ColumnHeaderSource
static val mutable ColumnHeaderSource: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CommentsInternalName Field

StringConstsCommentsInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CommentsInternalName
Public Shared CommentsInternalName As String
public:
static String^ CommentsInternalName
static val mutable CommentsInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ConfirmAll Field

StringConstsConfirmAll Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConfirmAll
Public Shared ConfirmAll As String
public:
static String^ ConfirmAll
static val mutable ConfirmAll: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ConfirmCancel Field

StringConstsConfirmCancel Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConfirmCancel
Public Shared ConfirmCancel As String
public:
static String^ ConfirmCancel
static val mutable ConfirmCancel: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ConfirmNo Field

StringConstsConfirmNo Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConfirmNo
Public Shared ConfirmNo As String
public:
static String^ ConfirmNo
static val mutable ConfirmNo: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ConfirmReplace Field

StringConstsConfirmReplace Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConfirmReplace
Public Shared ConfirmReplace As String
public:
static String^ ConfirmReplace
static val mutable ConfirmReplace: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ConfirmReplaceText Field

StringConstsConfirmReplaceText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConfirmReplaceText
Public Shared ConfirmReplaceText As String
public:
static String^ ConfirmReplaceText
static val mutable ConfirmReplaceText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ConfirmYes Field

StringConstsConfirmYes Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConfirmYes
Public Shared ConfirmYes As String
public:
static String^ ConfirmYes
static val mutable ConfirmYes: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CopyCaption Field

StringConstsCopyCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CopyCaption
Public Shared CopyCaption As String
public:
static String^ CopyCaption
static val mutable CopyCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CopyValueCaption Field

StringConstsCopyValueCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CopyValueCaption
Public Shared CopyValueCaption As String
public:
static String^ CopyValueCaption
static val mutable CopyValueCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CurrentDocumentCaption Field

StringConstsCurrentDocumentCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CurrentDocumentCaption
Public Shared CurrentDocumentCaption As String
public:
static String^ CurrentDocumentCaption
static val mutable CurrentDocumentCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CurrentDocumentScope Field

StringConstsCurrentDocumentScope Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CurrentDocumentScope
Public Shared CurrentDocumentScope As String
public:
static String^ CurrentDocumentScope
static val mutable CurrentDocumentScope: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.CurrentProjectScope Field

StringConstsCurrentProjectScope Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CurrentProjectScope
Public Shared CurrentProjectScope As String
public:
static String^ CurrentProjectScope
static val mutable CurrentProjectScope: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DebugCaption Field

StringConstsDebugCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DebugCaption
Public Shared DebugCaption As String
public:
static String^ DebugCaption
static val mutable DebugCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DebuggerBreak Field

StringConstsDebuggerBreak Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DebuggerBreak
Public Shared DebuggerBreak As String
public:
static String^ DebuggerBreak
static val mutable DebuggerBreak: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DebuggerCompile Field

StringConstsDebuggerCompile Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DebuggerCompile
Public Shared DebuggerCompile As String
public:
static String^ DebuggerCompile
static val mutable DebuggerCompile: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DebuggerContinue Field

StringConstsDebuggerContinue Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DebuggerContinue
Public Shared DebuggerContinue As String
public:
static String^ DebuggerContinue
static val mutable DebuggerContinue: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DebuggerEvaluate Field

StringConstsDebuggerEvaluate Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DebuggerEvaluate
Public Shared DebuggerEvaluate As String
public:
static String^ DebuggerEvaluate
static val mutable DebuggerEvaluate: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DebuggerStart Field

StringConstsDebuggerStart Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DebuggerStart
Public Shared DebuggerStart As String
public:
static String^ DebuggerStart
static val mutable DebuggerStart: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DebuggerStepInto Field

StringConstsDebuggerStepInto Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DebuggerStepInto
Public Shared DebuggerStepInto As String
public:
static String^ DebuggerStepInto
static val mutable DebuggerStepInto: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DebuggerStepOver Field

StringConstsDebuggerStepOver Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DebuggerStepOver
Public Shared DebuggerStepOver As String
public:
static String^ DebuggerStepOver
static val mutable DebuggerStepOver: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DebuggerStop Field

StringConstsDebuggerStop Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DebuggerStop
Public Shared DebuggerStop As String
public:
static String^ DebuggerStop
static val mutable DebuggerStop: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DefaultDragMarginHint Field

StringConstsDefaultDragMarginHint Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultDragMarginHint
Public Shared DefaultDragMarginHint As String
public:
static String^ DefaultDragMarginHint
static val mutable DefaultDragMarginHint: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DefaultHyperTextHint Field

StringConstsDefaultHyperTextHint Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultHyperTextHint
Public Shared DefaultHyperTextHint As String
public:
static String^ DefaultHyperTextHint
static val mutable DefaultHyperTextHint: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DeleteBreakpointCaption Field

StringConstsDeleteBreakpointCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DeleteBreakpointCaption
Public Shared DeleteBreakpointCaption As String
public:
static String^ DeleteBreakpointCaption
static val mutable DeleteBreakpointCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DeleteWatchCaption Field

StringConstsDeleteWatchCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DeleteWatchCaption
Public Shared DeleteWatchCaption As String
public:
static String^ DeleteWatchCaption
static val mutable DeleteWatchCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DirectionModalCaption Field

StringConstsDirectionModalCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DirectionModalCaption
Public Shared DirectionModalCaption As String
public:
static String^ DirectionModalCaption
static val mutable DirectionModalCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DirectivesInternalName Field

StringConstsDirectivesInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DirectivesInternalName
Public Shared DirectivesInternalName As String
public:
static String^ DirectivesInternalName
static val mutable DirectivesInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DisableBreakpointCaption Field

StringConstsDisableBreakpointCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DisableBreakpointCaption
Public Shared DisableBreakpointCaption As String
public:
static String^ DisableBreakpointCaption
static val mutable DisableBreakpointCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DisplayProgressCaption Field

StringConstsDisplayProgressCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DisplayProgressCaption
Public Shared DisplayProgressCaption As String
public:
static String^ DisplayProgressCaption
static val mutable DisplayProgressCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DlgGotoCaption Field

StringConstsDlgGotoCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DlgGotoCaption
Public Shared DlgGotoCaption As String
public:
static String^ DlgGotoCaption
static val mutable DlgGotoCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DlgPrintOptionsCaption Field

StringConstsDlgPrintOptionsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DlgPrintOptionsCaption
Public Shared DlgPrintOptionsCaption As String
public:
static String^ DlgPrintOptionsCaption
static val mutable DlgPrintOptionsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DlgReplaceCaption Field

StringConstsDlgReplaceCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DlgReplaceCaption
Public Shared DlgReplaceCaption As String
public:
static String^ DlgReplaceCaption
static val mutable DlgReplaceCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DlgSearchCaption Field

StringConstsDlgSearchCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DlgSearchCaption
Public Shared DlgSearchCaption As String
public:
static String^ DlgSearchCaption
static val mutable DlgSearchCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.DlgSearchReplaceCaption Field

StringConstsDlgSearchReplaceCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DlgSearchReplaceCaption
Public Shared DlgSearchReplaceCaption As String
public:
static String^ DlgSearchReplaceCaption
static val mutable DlgSearchReplaceCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EditWatchCaption Field

StringConstsEditWatchCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EditWatchCaption
Public Shared EditWatchCaption As String
public:
static String^ EditWatchCaption
static val mutable EditWatchCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EmptyColor Field

StringConstsEmptyColor Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EmptyColor
Public Shared EmptyColor As String
public:
static String^ EmptyColor
static val mutable EmptyColor: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EmptyOption Field

StringConstsEmptyOption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EmptyOption
Public Shared EmptyOption As String
public:
static String^ EmptyOption
static val mutable EmptyOption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EnableBreakpointCaption Field

StringConstsEnableBreakpointCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EnableBreakpointCaption
Public Shared EnableBreakpointCaption As String
public:
static String^ EnableBreakpointCaption
static val mutable EnableBreakpointCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EndLineCaption Field

StringConstsEndLineCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EndLineCaption
Public Shared EndLineCaption As String
public:
static String^ EndLineCaption
static val mutable EndLineCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EnterNewLineCaption Field

StringConstsEnterNewLineCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EnterNewLineCaption
Public Shared EnterNewLineCaption As String
public:
static String^ EnterNewLineCaption
static val mutable EnterNewLineCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EntireScopeCaption Field

StringConstsEntireScopeCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EntireScopeCaption
Public Shared EntireScopeCaption As String
public:
static String^ EntireScopeCaption
static val mutable EntireScopeCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EnumValueNotSupported Field

StringConstsEnumValueNotSupported Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EnumValueNotSupported
Public Shared EnumValueNotSupported As String
public:
static String^ EnumValueNotSupported
static val mutable EnumValueNotSupported: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrArglistParameter Field

StringConstsErrArglistParameter Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrArglistParameter
Public Shared ErrArglistParameter As String
public:
static String^ ErrArglistParameter
static val mutable ErrArglistParameter: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrArrayParamSpecifier Field

StringConstsErrArrayParamSpecifier Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrArrayParamSpecifier
Public Shared ErrArrayParamSpecifier As String
public:
static String^ ErrArrayParamSpecifier
static val mutable ErrArrayParamSpecifier: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrCantFindDeclaration Field

StringConstsErrCantFindDeclaration Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrCantFindDeclaration
Public Shared ErrCantFindDeclaration As String
public:
static String^ ErrCantFindDeclaration
static val mutable ErrCantFindDeclaration: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrCatchOrFinallyExpected Field

StringConstsErrCatchOrFinallyExpected Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrCatchOrFinallyExpected
Public Shared ErrCatchOrFinallyExpected As String
public:
static String^ ErrCatchOrFinallyExpected
static val mutable ErrCatchOrFinallyExpected: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrDefaultParamNotPermitted Field

StringConstsErrDefaultParamNotPermitted Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrDefaultParamNotPermitted
Public Shared ErrDefaultParamNotPermitted As String
public:
static String^ ErrDefaultParamNotPermitted
static val mutable ErrDefaultParamNotPermitted: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrEndOfFileFound Field

StringConstsErrEndOfFileFound Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrEndOfFileFound
Public Shared ErrEndOfFileFound As String
public:
static String^ ErrEndOfFileFound
static val mutable ErrEndOfFileFound: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrExpected Field

StringConstsErrExpected Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrExpected
Public Shared ErrExpected As String
public:
static String^ ErrExpected
static val mutable ErrExpected: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrFieldInitializerExpected Field

StringConstsErrFieldInitializerExpected Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrFieldInitializerExpected
Public Shared ErrFieldInitializerExpected As String
public:
static String^ ErrFieldInitializerExpected
static val mutable ErrFieldInitializerExpected: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrFixedPointerDeclaration Field

StringConstsErrFixedPointerDeclaration Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrFixedPointerDeclaration
Public Shared ErrFixedPointerDeclaration As String
public:
static String^ ErrFixedPointerDeclaration
static val mutable ErrFixedPointerDeclaration: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrIdentifierExpected Field

StringConstsErrIdentifierExpected Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrIdentifierExpected
Public Shared ErrIdentifierExpected As String
public:
static String^ ErrIdentifierExpected
static val mutable ErrIdentifierExpected: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrInExpected Field

StringConstsErrInExpected Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrInExpected
Public Shared ErrInExpected As String
public:
static String^ ErrInExpected
static val mutable ErrInExpected: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrInterfaceDeclaration Field

StringConstsErrInterfaceDeclaration Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrInterfaceDeclaration
Public Shared ErrInterfaceDeclaration As String
public:
static String^ ErrInterfaceDeclaration
static val mutable ErrInterfaceDeclaration: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrInterfaceMemberDeclaration Field

StringConstsErrInterfaceMemberDeclaration Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrInterfaceMemberDeclaration
Public Shared ErrInterfaceMemberDeclaration As String
public:
static String^ ErrInterfaceMemberDeclaration
static val mutable ErrInterfaceMemberDeclaration: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrNamespaceDeclaration Field

StringConstsErrNamespaceDeclaration Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrNamespaceDeclaration
Public Shared ErrNamespaceDeclaration As String
public:
static String^ ErrNamespaceDeclaration
static val mutable ErrNamespaceDeclaration: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrNamespaceModifier Field

StringConstsErrNamespaceModifier Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrNamespaceModifier
Public Shared ErrNamespaceModifier As String
public:
static String^ ErrNamespaceModifier
static val mutable ErrNamespaceModifier: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrNamespaceModifiers Field

StringConstsErrNamespaceModifiers Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrNamespaceModifiers
Public Shared ErrNamespaceModifiers As String
public:
static String^ ErrNamespaceModifiers
static val mutable ErrNamespaceModifiers: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrNewExpression Field

StringConstsErrNewExpression Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrNewExpression
Public Shared ErrNewExpression As String
public:
static String^ ErrNewExpression
static val mutable ErrNewExpression: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrorCaption Field

StringConstsErrorCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrorCaption
Public Shared ErrorCaption As String
public:
static String^ ErrorCaption
static val mutable ErrorCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrorCode Field

StringConstsErrorCode Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrorCode
Public Shared ErrorCode As String
public:
static String^ ErrorCode
static val mutable ErrorCode: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrorsCaption Field

StringConstsErrorsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrorsCaption
Public Shared ErrorsCaption As String
public:
static String^ ErrorsCaption
static val mutable ErrorsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrorsText Field

StringConstsErrorsText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrorsText
Public Shared ErrorsText As String
public:
static String^ ErrorsText
static val mutable ErrorsText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrorText Field

StringConstsErrorText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrorText
Public Shared ErrorText As String
public:
static String^ ErrorText
static val mutable ErrorText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrStackallocExpression Field

StringConstsErrStackallocExpression Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrStackallocExpression
Public Shared ErrStackallocExpression As String
public:
static String^ ErrStackallocExpression
static val mutable ErrStackallocExpression: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrSyntax Field

StringConstsErrSyntax Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrSyntax
Public Shared ErrSyntax As String
public:
static String^ ErrSyntax
static val mutable ErrSyntax: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrTypeExpected Field

StringConstsErrTypeExpected Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrTypeExpected
Public Shared ErrTypeExpected As String
public:
static String^ ErrTypeExpected
static val mutable ErrTypeExpected: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ErrWhileExpected Field

StringConstsErrWhileExpected Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ErrWhileExpected
Public Shared ErrWhileExpected As String
public:
static String^ ErrWhileExpected
static val mutable ErrWhileExpected: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EscapeCaption Field

StringConstsEscapeCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EscapeCaption
Public Shared EscapeCaption As String
public:
static String^ EscapeCaption
static val mutable EscapeCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EvaluateCaptionEvaluateDlg Field

StringConstsEvaluateCaptionEvaluateDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EvaluateCaptionEvaluateDlg
Public Shared EvaluateCaptionEvaluateDlg As String
public:
static String^ EvaluateCaptionEvaluateDlg
static val mutable EvaluateCaptionEvaluateDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.EvaluateDlgCaption Field

StringConstsEvaluateDlgCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EvaluateDlgCaption
Public Shared EvaluateDlgCaption As String
public:
static String^ EvaluateDlgCaption
static val mutable EvaluateDlgCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ExpressionCaptionWatchDlg Field

StringConstsExpressionCaptionWatchDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ExpressionCaptionWatchDlg
Public Shared ExpressionCaptionWatchDlg As String
public:
static String^ ExpressionCaptionWatchDlg
static val mutable ExpressionCaptionWatchDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FileNameCaption Field

StringConstsFileNameCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FileNameCaption
Public Shared FileNameCaption As String
public:
static String^ FileNameCaption
static val mutable FileNameCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FileToPrintCaption Field

StringConstsFileToPrintCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FileToPrintCaption
Public Shared FileToPrintCaption As String
public:
static String^ FileToPrintCaption
static val mutable FileToPrintCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindAllCaption Field

StringConstsFindAllCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindAllCaption
Public Shared FindAllCaption As String
public:
static String^ FindAllCaption
static val mutable FindAllCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindImplementations Field

StringConstsFindImplementations Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindImplementations
Public Shared FindImplementations As String
public:
static String^ FindImplementations
static val mutable FindImplementations: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindNextCaption Field

StringConstsFindNextCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindNextCaption
Public Shared FindNextCaption As String
public:
static String^ FindNextCaption
static val mutable FindNextCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindOptionsCaption Field

StringConstsFindOptionsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindOptionsCaption
Public Shared FindOptionsCaption As String
public:
static String^ FindOptionsCaption
static val mutable FindOptionsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindOptionsModalCaption Field

StringConstsFindOptionsModalCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindOptionsModalCaption
Public Shared FindOptionsModalCaption As String
public:
static String^ FindOptionsModalCaption
static val mutable FindOptionsModalCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindPreviousCaption Field

StringConstsFindPreviousCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindPreviousCaption
Public Shared FindPreviousCaption As String
public:
static String^ FindPreviousCaption
static val mutable FindPreviousCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindReferences Field

StringConstsFindReferences Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindReferences
Public Shared FindReferences As String
public:
static String^ FindReferences
static val mutable FindReferences: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindWhatCaption Field

StringConstsFindWhatCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindWhatCaption
Public Shared FindWhatCaption As String
public:
static String^ FindWhatCaption
static val mutable FindWhatCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindWhatModalCaption Field

StringConstsFindWhatModalCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindWhatModalCaption
Public Shared FindWhatModalCaption As String
public:
static String^ FindWhatModalCaption
static val mutable FindWhatModalCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FindWhatTextCaption Field

StringConstsFindWhatTextCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FindWhatTextCaption
Public Shared FindWhatTextCaption As String
public:
static String^ FindWhatTextCaption
static val mutable FindWhatTextCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FolderNode Field

StringConstsFolderNode Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FolderNode
Public Shared FolderNode As String
public:
static String^ FolderNode
static val mutable FolderNode: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ForwardDirection Field

StringConstsForwardDirection Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ForwardDirection
Public Shared ForwardDirection As String
public:
static String^ ForwardDirection
static val mutable ForwardDirection: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.FromCursorCaption Field

StringConstsFromCursorCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FromCursorCaption
Public Shared FromCursorCaption As String
public:
static String^ FromCursorCaption
static val mutable FromCursorCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.GeneralCaption Field

StringConstsGeneralCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GeneralCaption
Public Shared GeneralCaption As String
public:
static String^ GeneralCaption
static val mutable GeneralCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.GenericTypesOverloads Field

StringConstsGenericTypesOverloads Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GenericTypesOverloads
Public Shared GenericTypesOverloads As String
public:
static String^ GenericTypesOverloads
static val mutable GenericTypesOverloads: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.GotoDefinition Field

StringConstsGotoDefinition Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GotoDefinition
Public Shared GotoDefinition As String
public:
static String^ GotoDefinition
static val mutable GotoDefinition: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.GotoLocationCaption Field

StringConstsGotoLocationCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GotoLocationCaption
Public Shared GotoLocationCaption As String
public:
static String^ GotoLocationCaption
static val mutable GotoLocationCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.GoToSourceCodeCaption Field

StringConstsGoToSourceCodeCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GoToSourceCodeCaption
Public Shared GoToSourceCodeCaption As String
public:
static String^ GoToSourceCodeCaption
static val mutable GoToSourceCodeCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.HelpCaption Field

StringConstsHelpCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HelpCaption
Public Shared HelpCaption As String
public:
static String^ HelpCaption
static val mutable HelpCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.HTMLParamsInternalName Field

StringConstsHTMLParamsInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HTMLParamsInternalName
Public Shared HTMLParamsInternalName As String
public:
static String^ HTMLParamsInternalName
static val mutable HTMLParamsInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.HyperTextColorStr Field

StringConstsHyperTextColorStr Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HyperTextColorStr
Public Shared HyperTextColorStr As String
public:
static String^ HyperTextColorStr
static val mutable HyperTextColorStr: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.IdentsInternalName Field

StringConstsIdentsInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string IdentsInternalName
Public Shared IdentsInternalName As String
public:
static String^ IdentsInternalName
static val mutable IdentsInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.InsertDelegateExtendedHint Field

StringConstsInsertDelegateExtendedHint Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InsertDelegateExtendedHint
Public Shared InsertDelegateExtendedHint As String
public:
static String^ InsertDelegateExtendedHint
static val mutable InsertDelegateExtendedHint: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.InsertDelegateHint Field

StringConstsInsertDelegateHint Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InsertDelegateHint
Public Shared InsertDelegateHint As String
public:
static String^ InsertDelegateHint
static val mutable InsertDelegateHint: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.InvalidMarginColumn Field

StringConstsInvalidMarginColumn Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InvalidMarginColumn
Public Shared InvalidMarginColumn As String
public:
static String^ InvalidMarginColumn
static val mutable InvalidMarginColumn: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.InvalidPropName Field

StringConstsInvalidPropName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InvalidPropName
Public Shared InvalidPropName As String
public:
static String^ InvalidPropName
static val mutable InvalidPropName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.InvalidRange Field

StringConstsInvalidRange Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InvalidRange
Public Shared InvalidRange As String
public:
static String^ InvalidRange
static val mutable InvalidRange: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.InvalidReference Field

StringConstsInvalidReference Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InvalidReference
Public Shared InvalidReference As String
public:
static String^ InvalidReference
static val mutable InvalidReference: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.InvalidTabStop Field

StringConstsInvalidTabStop Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InvalidTabStop
Public Shared InvalidTabStop As String
public:
static String^ InvalidTabStop
static val mutable InvalidTabStop: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.InvalidTypeName Field

StringConstsInvalidTypeName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InvalidTypeName
Public Shared InvalidTypeName As String
public:
static String^ InvalidTypeName
static val mutable InvalidTypeName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.LineBreakCaption Field

StringConstsLineBreakCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineBreakCaption
Public Shared LineBreakCaption As String
public:
static String^ LineBreakCaption
static val mutable LineBreakCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.LineNofMstr Field

StringConstsLineNofMstr Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineNofMstr
Public Shared LineNofMstr As String
public:
static String^ LineNofMstr
static val mutable LineNofMstr: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.LineNumberCaption Field

StringConstsLineNumberCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineNumberCaption
Public Shared LineNumberCaption As String
public:
static String^ LineNumberCaption
static val mutable LineNumberCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.LineNumbersCaptionPrintOptionsDlg Field

StringConstsLineNumbersCaptionPrintOptionsDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineNumbersCaptionPrintOptionsDlg
Public Shared LineNumbersCaptionPrintOptionsDlg As String
public:
static String^ LineNumbersCaptionPrintOptionsDlg
static val mutable LineNumbersCaptionPrintOptionsDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.LineStr Field

StringConstsLineStr Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineStr
Public Shared LineStr As String
public:
static String^ LineStr
static val mutable LineStr: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.LookInCaption Field

StringConstsLookInCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LookInCaption
Public Shared LookInCaption As String
public:
static String^ LookInCaption
static val mutable LookInCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MarkAllCaption Field

StringConstsMarkAllCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MarkAllCaption
Public Shared MarkAllCaption As String
public:
static String^ MarkAllCaption
static val mutable MarkAllCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MatchCaseCaption Field

StringConstsMatchCaseCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MatchCaseCaption
Public Shared MatchCaseCaption As String
public:
static String^ MatchCaseCaption
static val mutable MatchCaseCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MatchWholeWordCaption Field

StringConstsMatchWholeWordCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MatchWholeWordCaption
Public Shared MatchWholeWordCaption As String
public:
static String^ MatchWholeWordCaption
static val mutable MatchWholeWordCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuAddLibraryCaption Field

StringConstsMenuAddLibraryCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuAddLibraryCaption
Public Shared MenuAddLibraryCaption As String
public:
static String^ MenuAddLibraryCaption
static val mutable MenuAddLibraryCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuAddTabCaption Field

StringConstsMenuAddTabCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuAddTabCaption
Public Shared MenuAddTabCaption As String
public:
static String^ MenuAddTabCaption
static val mutable MenuAddTabCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuAlignBottomsCaption Field

StringConstsMenuAlignBottomsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuAlignBottomsCaption
Public Shared MenuAlignBottomsCaption As String
public:
static String^ MenuAlignBottomsCaption
static val mutable MenuAlignBottomsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuAlignCentersCaption Field

StringConstsMenuAlignCentersCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuAlignCentersCaption
Public Shared MenuAlignCentersCaption As String
public:
static String^ MenuAlignCentersCaption
static val mutable MenuAlignCentersCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuAlignLeftsCaption Field

StringConstsMenuAlignLeftsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuAlignLeftsCaption
Public Shared MenuAlignLeftsCaption As String
public:
static String^ MenuAlignLeftsCaption
static val mutable MenuAlignLeftsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuAlignmentCaption Field

StringConstsMenuAlignmentCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuAlignmentCaption
Public Shared MenuAlignmentCaption As String
public:
static String^ MenuAlignmentCaption
static val mutable MenuAlignmentCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuAlignMiddlesCaption Field

StringConstsMenuAlignMiddlesCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuAlignMiddlesCaption
Public Shared MenuAlignMiddlesCaption As String
public:
static String^ MenuAlignMiddlesCaption
static val mutable MenuAlignMiddlesCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuAlignRightsCaption Field

StringConstsMenuAlignRightsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuAlignRightsCaption
Public Shared MenuAlignRightsCaption As String
public:
static String^ MenuAlignRightsCaption
static val mutable MenuAlignRightsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuAlignTopsCaption Field

StringConstsMenuAlignTopsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuAlignTopsCaption
Public Shared MenuAlignTopsCaption As String
public:
static String^ MenuAlignTopsCaption
static val mutable MenuAlignTopsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuArrangeBottomCaption Field

StringConstsMenuArrangeBottomCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuArrangeBottomCaption
Public Shared MenuArrangeBottomCaption As String
public:
static String^ MenuArrangeBottomCaption
static val mutable MenuArrangeBottomCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuArrangeHorizontalMiddleCaption Field

StringConstsMenuArrangeHorizontalMiddleCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuArrangeHorizontalMiddleCaption
Public Shared MenuArrangeHorizontalMiddleCaption As String
public:
static String^ MenuArrangeHorizontalMiddleCaption
static val mutable MenuArrangeHorizontalMiddleCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuArrangeLeftCaption Field

StringConstsMenuArrangeLeftCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuArrangeLeftCaption
Public Shared MenuArrangeLeftCaption As String
public:
static String^ MenuArrangeLeftCaption
static val mutable MenuArrangeLeftCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuArrangeRightCaption Field

StringConstsMenuArrangeRightCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuArrangeRightCaption
Public Shared MenuArrangeRightCaption As String
public:
static String^ MenuArrangeRightCaption
static val mutable MenuArrangeRightCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuArrangeTopCaption Field

StringConstsMenuArrangeTopCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuArrangeTopCaption
Public Shared MenuArrangeTopCaption As String
public:
static String^ MenuArrangeTopCaption
static val mutable MenuArrangeTopCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuArrangeVerticalMiddleCaption Field

StringConstsMenuArrangeVerticalMiddleCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuArrangeVerticalMiddleCaption
Public Shared MenuArrangeVerticalMiddleCaption As String
public:
static String^ MenuArrangeVerticalMiddleCaption
static val mutable MenuArrangeVerticalMiddleCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuBindingCaption Field

StringConstsMenuBindingCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuBindingCaption
Public Shared MenuBindingCaption As String
public:
static String^ MenuBindingCaption
static val mutable MenuBindingCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuBringToFrontCaption Field

StringConstsMenuBringToFrontCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuBringToFrontCaption
Public Shared MenuBringToFrontCaption As String
public:
static String^ MenuBringToFrontCaption
static val mutable MenuBringToFrontCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuCenterHorzCaption Field

StringConstsMenuCenterHorzCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuCenterHorzCaption
Public Shared MenuCenterHorzCaption As String
public:
static String^ MenuCenterHorzCaption
static val mutable MenuCenterHorzCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuCenterVertCaption Field

StringConstsMenuCenterVertCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuCenterVertCaption
Public Shared MenuCenterVertCaption As String
public:
static String^ MenuCenterVertCaption
static val mutable MenuCenterVertCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuCopyCaption Field

StringConstsMenuCopyCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuCopyCaption
Public Shared MenuCopyCaption As String
public:
static String^ MenuCopyCaption
static val mutable MenuCopyCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuCutCaption Field

StringConstsMenuCutCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuCutCaption
Public Shared MenuCutCaption As String
public:
static String^ MenuCutCaption
static val mutable MenuCutCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuDeleteCaption Field

StringConstsMenuDeleteCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuDeleteCaption
Public Shared MenuDeleteCaption As String
public:
static String^ MenuDeleteCaption
static val mutable MenuDeleteCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuDisplayCustomEditorCaption Field

StringConstsMenuDisplayCustomEditorCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuDisplayCustomEditorCaption
Public Shared MenuDisplayCustomEditorCaption As String
public:
static String^ MenuDisplayCustomEditorCaption
static val mutable MenuDisplayCustomEditorCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuEditStyleCaption Field

StringConstsMenuEditStyleCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuEditStyleCaption
Public Shared MenuEditStyleCaption As String
public:
static String^ MenuEditStyleCaption
static val mutable MenuEditStyleCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuFormattedTextEditorCaption Field

StringConstsMenuFormattedTextEditorCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuFormattedTextEditorCaption
Public Shared MenuFormattedTextEditorCaption As String
public:
static String^ MenuFormattedTextEditorCaption
static val mutable MenuFormattedTextEditorCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuMakeHorzSpacingEqualCaption Field

StringConstsMenuMakeHorzSpacingEqualCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuMakeHorzSpacingEqualCaption
Public Shared MenuMakeHorzSpacingEqualCaption As String
public:
static String^ MenuMakeHorzSpacingEqualCaption
static val mutable MenuMakeHorzSpacingEqualCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuMakeSameHeightCaption Field

StringConstsMenuMakeSameHeightCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuMakeSameHeightCaption
Public Shared MenuMakeSameHeightCaption As String
public:
static String^ MenuMakeSameHeightCaption
static val mutable MenuMakeSameHeightCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuMakeSameSizeCaption Field

StringConstsMenuMakeSameSizeCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuMakeSameSizeCaption
Public Shared MenuMakeSameSizeCaption As String
public:
static String^ MenuMakeSameSizeCaption
static val mutable MenuMakeSameSizeCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuMakeSameWidthCaption Field

StringConstsMenuMakeSameWidthCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuMakeSameWidthCaption
Public Shared MenuMakeSameWidthCaption As String
public:
static String^ MenuMakeSameWidthCaption
static val mutable MenuMakeSameWidthCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuMakeVertSpacingEqualCaption Field

StringConstsMenuMakeVertSpacingEqualCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuMakeVertSpacingEqualCaption
Public Shared MenuMakeVertSpacingEqualCaption As String
public:
static String^ MenuMakeVertSpacingEqualCaption
static val mutable MenuMakeVertSpacingEqualCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuMoveDownCaption Field

StringConstsMenuMoveDownCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuMoveDownCaption
Public Shared MenuMoveDownCaption As String
public:
static String^ MenuMoveDownCaption
static val mutable MenuMoveDownCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuMoveUpCaption Field

StringConstsMenuMoveUpCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuMoveUpCaption
Public Shared MenuMoveUpCaption As String
public:
static String^ MenuMoveUpCaption
static val mutable MenuMoveUpCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuPasteCaption Field

StringConstsMenuPasteCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuPasteCaption
Public Shared MenuPasteCaption As String
public:
static String^ MenuPasteCaption
static val mutable MenuPasteCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuPropertiesCaption Field

StringConstsMenuPropertiesCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuPropertiesCaption
Public Shared MenuPropertiesCaption As String
public:
static String^ MenuPropertiesCaption
static val mutable MenuPropertiesCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuRasterPlacementCaption Field

StringConstsMenuRasterPlacementCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuRasterPlacementCaption
Public Shared MenuRasterPlacementCaption As String
public:
static String^ MenuRasterPlacementCaption
static val mutable MenuRasterPlacementCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuRedoCaption Field

StringConstsMenuRedoCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuRedoCaption
Public Shared MenuRedoCaption As String
public:
static String^ MenuRedoCaption
static val mutable MenuRedoCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuRemoveHorzSpacingCaption Field

StringConstsMenuRemoveHorzSpacingCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuRemoveHorzSpacingCaption
Public Shared MenuRemoveHorzSpacingCaption As String
public:
static String^ MenuRemoveHorzSpacingCaption
static val mutable MenuRemoveHorzSpacingCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuRemoveVertSpacingCaption Field

StringConstsMenuRemoveVertSpacingCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuRemoveVertSpacingCaption
Public Shared MenuRemoveVertSpacingCaption As String
public:
static String^ MenuRemoveVertSpacingCaption
static val mutable MenuRemoveVertSpacingCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuRenameCaption Field

StringConstsMenuRenameCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuRenameCaption
Public Shared MenuRenameCaption As String
public:
static String^ MenuRenameCaption
static val mutable MenuRenameCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuRenameItemCaption Field

StringConstsMenuRenameItemCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuRenameItemCaption
Public Shared MenuRenameItemCaption As String
public:
static String^ MenuRenameItemCaption
static val mutable MenuRenameItemCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuRenameTabCaption Field

StringConstsMenuRenameTabCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuRenameTabCaption
Public Shared MenuRenameTabCaption As String
public:
static String^ MenuRenameTabCaption
static val mutable MenuRenameTabCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuResetCaption Field

StringConstsMenuResetCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuResetCaption
Public Shared MenuResetCaption As String
public:
static String^ MenuResetCaption
static val mutable MenuResetCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuResetToolboxCaption Field

StringConstsMenuResetToolboxCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuResetToolboxCaption
Public Shared MenuResetToolboxCaption As String
public:
static String^ MenuResetToolboxCaption
static val mutable MenuResetToolboxCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuSelectAllCaption Field

StringConstsMenuSelectAllCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuSelectAllCaption
Public Shared MenuSelectAllCaption As String
public:
static String^ MenuSelectAllCaption
static val mutable MenuSelectAllCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuSendToBackCaption Field

StringConstsMenuSendToBackCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuSendToBackCaption
Public Shared MenuSendToBackCaption As String
public:
static String^ MenuSendToBackCaption
static val mutable MenuSendToBackCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuSnaplinePlacementCaption Field

StringConstsMenuSnaplinePlacementCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuSnaplinePlacementCaption
Public Shared MenuSnaplinePlacementCaption As String
public:
static String^ MenuSnaplinePlacementCaption
static val mutable MenuSnaplinePlacementCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuUndoCaption Field

StringConstsMenuUndoCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuUndoCaption
Public Shared MenuUndoCaption As String
public:
static String^ MenuUndoCaption
static val mutable MenuUndoCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuViewCodeCaption Field

StringConstsMenuViewCodeCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuViewCodeCaption
Public Shared MenuViewCodeCaption As String
public:
static String^ MenuViewCodeCaption
static val mutable MenuViewCodeCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuWrapInBorderCaption Field

StringConstsMenuWrapInBorderCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuWrapInBorderCaption
Public Shared MenuWrapInBorderCaption As String
public:
static String^ MenuWrapInBorderCaption
static val mutable MenuWrapInBorderCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuWrapInCanvasCaption Field

StringConstsMenuWrapInCanvasCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuWrapInCanvasCaption
Public Shared MenuWrapInCanvasCaption As String
public:
static String^ MenuWrapInCanvasCaption
static val mutable MenuWrapInCanvasCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuWrapInGridCaption Field

StringConstsMenuWrapInGridCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuWrapInGridCaption
Public Shared MenuWrapInGridCaption As String
public:
static String^ MenuWrapInGridCaption
static val mutable MenuWrapInGridCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuWrapInViewboxCaption Field

StringConstsMenuWrapInViewboxCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuWrapInViewboxCaption
Public Shared MenuWrapInViewboxCaption As String
public:
static String^ MenuWrapInViewboxCaption
static val mutable MenuWrapInViewboxCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuZoomInCaption Field

StringConstsMenuZoomInCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuZoomInCaption
Public Shared MenuZoomInCaption As String
public:
static String^ MenuZoomInCaption
static val mutable MenuZoomInCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuZoomOutCaption Field

StringConstsMenuZoomOutCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuZoomOutCaption
Public Shared MenuZoomOutCaption As String
public:
static String^ MenuZoomOutCaption
static val mutable MenuZoomOutCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuZoomToActualCaption Field

StringConstsMenuZoomToActualCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuZoomToActualCaption
Public Shared MenuZoomToActualCaption As String
public:
static String^ MenuZoomToActualCaption
static val mutable MenuZoomToActualCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MenuZoomToFitCaption Field

StringConstsMenuZoomToFitCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MenuZoomToFitCaption
Public Shared MenuZoomToFitCaption As String
public:
static String^ MenuZoomToFitCaption
static val mutable MenuZoomToFitCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.MethodOverloads Field

StringConstsMethodOverloads Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MethodOverloads
Public Shared MethodOverloads As String
public:
static String^ MethodOverloads
static val mutable MethodOverloads: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.NextErrorCaption Field

StringConstsNextErrorCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NextErrorCaption
Public Shared NextErrorCaption As String
public:
static String^ NextErrorCaption
static val mutable NextErrorCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.NoCodeCompletionSuggestions Field

StringConstsNoCodeCompletionSuggestions Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NoCodeCompletionSuggestions
Public Shared NoCodeCompletionSuggestions As String
public:
static String^ NoCodeCompletionSuggestions
static val mutable NoCodeCompletionSuggestions: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.NofMstr Field

StringConstsNofMstr Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NofMstr
Public Shared NofMstr As String
public:
static String^ NofMstr
static val mutable NofMstr: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.NumbersInternalName Field

StringConstsNumbersInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NumbersInternalName
Public Shared NumbersInternalName As String
public:
static String^ NumbersInternalName
static val mutable NumbersInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OccurrencesReplaced Field

StringConstsOccurrencesReplaced Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OccurrencesReplaced
Public Shared OccurrencesReplaced As String
public:
static String^ OccurrencesReplaced
static val mutable OccurrencesReplaced: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OKCaptionGotoDlg Field

StringConstsOKCaptionGotoDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OKCaptionGotoDlg
Public Shared OKCaptionGotoDlg As String
public:
static String^ OKCaptionGotoDlg
static val mutable OKCaptionGotoDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OkCaptionPrintOptionsDlg Field

StringConstsOkCaptionPrintOptionsDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OkCaptionPrintOptionsDlg
Public Shared OkCaptionPrintOptionsDlg As String
public:
static String^ OkCaptionPrintOptionsDlg
static val mutable OkCaptionPrintOptionsDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OKCaptionSsearchModalDlg Field

StringConstsOKCaptionSsearchModalDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OKCaptionSsearchModalDlg
Public Shared OKCaptionSsearchModalDlg As String
public:
static String^ OKCaptionSsearchModalDlg
static val mutable OKCaptionSsearchModalDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OKCaptionWatchDlg Field

StringConstsOKCaptionWatchDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OKCaptionWatchDlg
Public Shared OKCaptionWatchDlg As String
public:
static String^ OKCaptionWatchDlg
static val mutable OKCaptionWatchDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OneCharInSetCaption Field

StringConstsOneCharInSetCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OneCharInSetCaption
Public Shared OneCharInSetCaption As String
public:
static String^ OneCharInSetCaption
static val mutable OneCharInSetCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OneCharNotInSetCaption Field

StringConstsOneCharNotInSetCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OneCharNotInSetCaption
Public Shared OneCharNotInSetCaption As String
public:
static String^ OneCharNotInSetCaption
static val mutable OneCharNotInSetCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OneOrMoreCaption Field

StringConstsOneOrMoreCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OneOrMoreCaption
Public Shared OneOrMoreCaption As String
public:
static String^ OneOrMoreCaption
static val mutable OneOrMoreCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OptionsCaption Field

StringConstsOptionsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OptionsCaption
Public Shared OptionsCaption As String
public:
static String^ OptionsCaption
static val mutable OptionsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OrCaption Field

StringConstsOrCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OrCaption
Public Shared OrCaption As String
public:
static String^ OrCaption
static val mutable OrCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.OriginModalCatpion Field

StringConstsOriginModalCatpion Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OriginModalCatpion
Public Shared OriginModalCatpion As String
public:
static String^ OriginModalCatpion
static val mutable OriginModalCatpion: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.PageNofMstr Field

StringConstsPageNofMstr Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PageNofMstr
Public Shared PageNofMstr As String
public:
static String^ PageNofMstr
static val mutable PageNofMstr: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.PageNumbersCaption Field

StringConstsPageNumbersCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PageNumbersCaption
Public Shared PageNumbersCaption As String
public:
static String^ PageNumbersCaption
static val mutable PageNumbersCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.PageStr Field

StringConstsPageStr Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PageStr
Public Shared PageStr As String
public:
static String^ PageStr
static val mutable PageStr: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ParameterCannotBeEmptyIEnumerable Field

StringConstsParameterCannotBeEmptyIEnumerable Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ParameterCannotBeEmptyIEnumerable
Public Shared ParameterCannotBeEmptyIEnumerable As String
public:
static String^ ParameterCannotBeEmptyIEnumerable
static val mutable ParameterCannotBeEmptyIEnumerable: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ParameterCannotBeEmptyString Field

StringConstsParameterCannotBeEmptyString Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ParameterCannotBeEmptyString
Public Shared ParameterCannotBeEmptyString As String
public:
static String^ ParameterCannotBeEmptyString
static val mutable ParameterCannotBeEmptyString: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.PreviousErrorCaption Field

StringConstsPreviousErrorCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PreviousErrorCaption
Public Shared PreviousErrorCaption As String
public:
static String^ PreviousErrorCaption
static val mutable PreviousErrorCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.PrintOptions Field

StringConstsPrintOptions Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PrintOptions
Public Shared PrintOptions As String
public:
static String^ PrintOptions
static val mutable PrintOptions: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.PrintOptionsButtonText Field

StringConstsPrintOptionsButtonText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PrintOptionsButtonText
Public Shared PrintOptionsButtonText As String
public:
static String^ PrintOptionsButtonText
static val mutable PrintOptionsButtonText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.PrintSelectionCaption Field

StringConstsPrintSelectionCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PrintSelectionCaption
Public Shared PrintSelectionCaption As String
public:
static String^ PrintSelectionCaption
static val mutable PrintSelectionCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.PromptOnReplaceCaption Field

StringConstsPromptOnReplaceCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PromptOnReplaceCaption
Public Shared PromptOnReplaceCaption As String
public:
static String^ PromptOnReplaceCaption
static val mutable PromptOnReplaceCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.RasterWidthText Field

StringConstsRasterWidthText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string RasterWidthText
Public Shared RasterWidthText As String
public:
static String^ RasterWidthText
static val mutable RasterWidthText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ReferenceInternalName Field

StringConstsReferenceInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReferenceInternalName
Public Shared ReferenceInternalName As String
public:
static String^ ReferenceInternalName
static val mutable ReferenceInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.RegularExpressionsCaption Field

StringConstsRegularExpressionsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string RegularExpressionsCaption
Public Shared RegularExpressionsCaption As String
public:
static String^ RegularExpressionsCaption
static val mutable RegularExpressionsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ReplaceAllCaption Field

StringConstsReplaceAllCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReplaceAllCaption
Public Shared ReplaceAllCaption As String
public:
static String^ ReplaceAllCaption
static val mutable ReplaceAllCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ReplaceCaption Field

StringConstsReplaceCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReplaceCaption
Public Shared ReplaceCaption As String
public:
static String^ ReplaceCaption
static val mutable ReplaceCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ReplaceWithCaption Field

StringConstsReplaceWithCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReplaceWithCaption
Public Shared ReplaceWithCaption As String
public:
static String^ ReplaceWithCaption
static val mutable ReplaceWithCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ReswordsInternalName Field

StringConstsReswordsInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReswordsInternalName
Public Shared ReswordsInternalName As String
public:
static String^ ReswordsInternalName
static val mutable ReswordsInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ScopeModalCaption Field

StringConstsScopeModalCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ScopeModalCaption
Public Shared ScopeModalCaption As String
public:
static String^ ScopeModalCaption
static val mutable ScopeModalCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SearchCaption Field

StringConstsSearchCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SearchCaption
Public Shared SearchCaption As String
public:
static String^ SearchCaption
static val mutable SearchCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SearchHiddenTextCaption Field

StringConstsSearchHiddenTextCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SearchHiddenTextCaption
Public Shared SearchHiddenTextCaption As String
public:
static String^ SearchHiddenTextCaption
static val mutable SearchHiddenTextCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SearchReachedStartPos Field

StringConstsSearchReachedStartPos Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SearchReachedStartPos
Public Shared SearchReachedStartPos As String
public:
static String^ SearchReachedStartPos
static val mutable SearchReachedStartPos: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SearchResultInternalName Field

StringConstsSearchResultInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SearchResultInternalName
Public Shared SearchResultInternalName As String
public:
static String^ SearchResultInternalName
static val mutable SearchResultInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SearchUpCaption Field

StringConstsSearchUpCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SearchUpCaption
Public Shared SearchUpCaption As String
public:
static String^ SearchUpCaption
static val mutable SearchUpCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SelectedTextScope Field

StringConstsSelectedTextScope Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SelectedTextScope
Public Shared SelectedTextScope As String
public:
static String^ SelectedTextScope
static val mutable SelectedTextScope: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SelectionOnlyCaption Field

StringConstsSelectionOnlyCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SelectionOnlyCaption
Public Shared SelectionOnlyCaption As String
public:
static String^ SelectionOnlyCaption
static val mutable SelectionOnlyCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SetNextStatement Field

StringConstsSetNextStatement Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SetNextStatement
Public Shared SetNextStatement As String
public:
static String^ SetNextStatement
static val mutable SetNextStatement: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ShowLineNumbersCaption Field

StringConstsShowLineNumbersCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ShowLineNumbersCaption
Public Shared ShowLineNumbersCaption As String
public:
static String^ ShowLineNumbersCaption
static val mutable ShowLineNumbersCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ShowParameterNamesCaption Field

StringConstsShowParameterNamesCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ShowParameterNamesCaption
Public Shared ShowParameterNamesCaption As String
public:
static String^ ShowParameterNamesCaption
static val mutable ShowParameterNamesCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ShowParameterTypesCaption Field

StringConstsShowParameterTypesCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ShowParameterTypesCaption
Public Shared ShowParameterTypesCaption As String
public:
static String^ ShowParameterTypesCaption
static val mutable ShowParameterTypesCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ShowPotentialFixesCaption Field

StringConstsShowPotentialFixesCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ShowPotentialFixesCaption
Public Shared ShowPotentialFixesCaption As String
public:
static String^ ShowPotentialFixesCaption
static val mutable ShowPotentialFixesCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ShowPotentialFixesShortCuts Field

StringConstsShowPotentialFixesShortCuts Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ShowPotentialFixesShortCuts
Public Shared ShowPotentialFixesShortCuts As String
public:
static String^ ShowPotentialFixesShortCuts
static val mutable ShowPotentialFixesShortCuts: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SingleCharCaption Field

StringConstsSingleCharCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SingleCharCaption
Public Shared SingleCharCaption As String
public:
static String^ SingleCharCaption
static val mutable SingleCharCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.StatusModified Field

StringConstsStatusModified Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StatusModified
Public Shared StatusModified As String
public:
static String^ StatusModified
static val mutable StatusModified: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.StatusOverwrite Field

StringConstsStatusOverwrite Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StatusOverwrite
Public Shared StatusOverwrite As String
public:
static String^ StatusOverwrite
static val mutable StatusOverwrite: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.StatusReadOnly Field

StringConstsStatusReadOnly Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StatusReadOnly
Public Shared StatusReadOnly As String
public:
static String^ StatusReadOnly
static val mutable StatusReadOnly: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.StatusText Field

StringConstsStatusText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StatusText
Public Shared StatusText As String
public:
static String^ StatusText
static val mutable StatusText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.StringNotFound Field

StringConstsStringNotFound Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StringNotFound
Public Shared StringNotFound As String
public:
static String^ StringNotFound
static val mutable StringNotFound: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.StringsInternalName Field

StringConstsStringsInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StringsInternalName
Public Shared StringsInternalName As String
public:
static String^ StringsInternalName
static val mutable StringsInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SwitchToFrameCaption Field

StringConstsSwitchToFrameCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SwitchToFrameCaption
Public Shared SwitchToFrameCaption As String
public:
static String^ SwitchToFrameCaption
static val mutable SwitchToFrameCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SymbolsInternalName Field

StringConstsSymbolsInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SymbolsInternalName
Public Shared SymbolsInternalName As String
public:
static String^ SymbolsInternalName
static val mutable SymbolsInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.SyntaxErrorsInternalName Field

StringConstsSyntaxErrorsInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SyntaxErrorsInternalName
Public Shared SyntaxErrorsInternalName As String
public:
static String^ SyntaxErrorsInternalName
static val mutable SyntaxErrorsInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.TabAllText Field

StringConstsTabAllText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TabAllText
Public Shared TabAllText As String
public:
static String^ TabAllText
static val mutable TabAllText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.TabCommonText Field

StringConstsTabCommonText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TabCommonText
Public Shared TabCommonText As String
public:
static String^ TabCommonText
static val mutable TabCommonText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.TagCaption Field

StringConstsTagCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TagCaption
Public Shared TagCaption As String
public:
static String^ TagCaption
static val mutable TagCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.TagExpressionCaption Field

StringConstsTagExpressionCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TagExpressionCaption
Public Shared TagExpressionCaption As String
public:
static String^ TagExpressionCaption
static val mutable TagExpressionCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ThreadCode Field

StringConstsThreadCode Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ThreadCode
Public Shared ThreadCode As String
public:
static String^ ThreadCode
static val mutable ThreadCode: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ToggleBreakpoint Field

StringConstsToggleBreakpoint Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ToggleBreakpoint
Public Shared ToggleBreakpoint As String
public:
static String^ ToggleBreakpoint
static val mutable ToggleBreakpoint: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ToggleReplaceCaption Field

StringConstsToggleReplaceCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ToggleReplaceCaption
Public Shared ToggleReplaceCaption As String
public:
static String^ ToggleReplaceCaption
static val mutable ToggleReplaceCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.UseColorsCaption Field

StringConstsUseColorsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string UseColorsCaption
Public Shared UseColorsCaption As String
public:
static String^ UseColorsCaption
static val mutable UseColorsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.UseFooterCaption Field

StringConstsUseFooterCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string UseFooterCaption
Public Shared UseFooterCaption As String
public:
static String^ UseFooterCaption
static val mutable UseFooterCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.UseHeaderCaption Field

StringConstsUseHeaderCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string UseHeaderCaption
Public Shared UseHeaderCaption As String
public:
static String^ UseHeaderCaption
static val mutable UseHeaderCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.UseRegularExpressionsCaption Field

StringConstsUseRegularExpressionsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string UseRegularExpressionsCaption
Public Shared UseRegularExpressionsCaption As String
public:
static String^ UseRegularExpressionsCaption
static val mutable UseRegularExpressionsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.UseSyntaxCaption Field

StringConstsUseSyntaxCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string UseSyntaxCaption
Public Shared UseSyntaxCaption As String
public:
static String^ UseSyntaxCaption
static val mutable UseSyntaxCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.WarningsCaption Field

StringConstsWarningsCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WarningsCaption
Public Shared WarningsCaption As String
public:
static String^ WarningsCaption
static val mutable WarningsCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.WarningsText Field

StringConstsWarningsText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WarningsText
Public Shared WarningsText As String
public:
static String^ WarningsText
static val mutable WarningsText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.WarningText Field

StringConstsWarningText Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WarningText
Public Shared WarningText As String
public:
static String^ WarningText
static val mutable WarningText: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.WatchDlgCaption Field

StringConstsWatchDlgCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WatchDlgCaption
Public Shared WatchDlgCaption As String
public:
static String^ WatchDlgCaption
static val mutable WatchDlgCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.WhiteSpaceInternalName Field

StringConstsWhiteSpaceInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WhiteSpaceInternalName
Public Shared WhiteSpaceInternalName As String
public:
static String^ WhiteSpaceInternalName
static val mutable WhiteSpaceInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.WholeWordsOnlyCaption Field

StringConstsWholeWordsOnlyCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WholeWordsOnlyCaption
Public Shared WholeWordsOnlyCaption As String
public:
static String^ WholeWordsOnlyCaption
static val mutable WholeWordsOnlyCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.WordWrapCaptionPrintOptionsDlg Field

StringConstsWordWrapCaptionPrintOptionsDlg Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WordWrapCaptionPrintOptionsDlg
Public Shared WordWrapCaptionPrintOptionsDlg As String
public:
static String^ WordWrapCaptionPrintOptionsDlg
static val mutable WordWrapCaptionPrintOptionsDlg: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.XMLCommentsInternalName Field

StringConstsXMLCommentsInternalName Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XMLCommentsInternalName
Public Shared XMLCommentsInternalName As String
public:
static String^ XMLCommentsInternalName
static val mutable XMLCommentsInternalName: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.ZeroOrMoreCaption Field

StringConstsZeroOrMoreCaption Field

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ZeroOrMoreCaption
Public Shared ZeroOrMoreCaption As String
public:
static String^ ZeroOrMoreCaption
static val mutable ZeroOrMoreCaption: string

Field Value

Type: String
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts Methods

StringConsts Methods

The StringConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Localize |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringConsts.Localize Method

StringConstsLocalize Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Localize()
Public Shared Sub Localize
public:
static void Localize()
static member Localize : unit -> unit
See Also

Reference

StringConsts Class
Alternet.Common Namespace


StringExtensions Class

StringExtensions Class
Contains extended methods for string objects.
Inheritance Hierarchy
SystemObject
Alternet.CommonStringExtensions

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StringExtensions
<ExtensionAttribute>
Public NotInheritable Class StringExtensions
[ExtensionAttribute]
public ref class StringExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type StringExtensions =  class end

The StringExtensions type exposes the following members.

Methods
Name | Description
Contains | Checks whether source string contains toCheck string.
IndexOfOccurence |
Replace | Returns a new string in which all occurrences of a specified string in the source string are replaced with another specified string.
SplitToLines |
ToHtml | Converts plain string to the HTML-formatted text.
ToPlainText | Converts HTML-formatted string to the plain text.
Top
See Also

Reference

Alternet.Common Namespace


StringExtensions Methods

StringExtensions Methods

The StringExtensions type exposes the following members.

Methods
Name | Description
Contains | Checks whether source string contains toCheck string.
IndexOfOccurence |
Replace | Returns a new string in which all occurrences of a specified string in the source string are replaced with another specified string.
SplitToLines |
ToHtml | Converts plain string to the HTML-formatted text.
ToPlainText | Converts HTML-formatted string to the plain text.
Top
See Also

Reference

StringExtensions Class
Alternet.Common Namespace


StringExtensions.Contains Method

StringExtensionsContains Method
Checks whether source string contains toCheck string.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Contains(
    this string source,
    string toCheck,
    StringComparison comp
)
<ExtensionAttribute>
Public Shared Function Contains (
    source As String,
    toCheck As String,
    comp As StringComparison
) As Boolean
public:
[ExtensionAttribute]
static bool Contains(
    String^ source,
    String^ toCheck,
    StringComparison comp
)
[<ExtensionAttribute>]
static member Contains :
        source : string *
        toCheck : string *
        comp : StringComparison -> bool

Parameters

source
Type: SystemString
Source string to process.
toCheck
Type: SystemString
The string to seek.
comp
Type: SystemStringComparison
One of the enumeration values that specifies the rules for the search.

Return Value

Type: Boolean
A value indicating whether specified string is a part of source string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
Alternet.Common Namespace


StringExtensions.IndexOfOccurence Method

StringExtensionsIndexOfOccurence Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int IndexOfOccurence(
    this string s,
    char toLookFor,
    int startIndex,
    int occurenceCount
)
<ExtensionAttribute>
Public Shared Function IndexOfOccurence (
    s As String,
    toLookFor As Char,
    startIndex As Integer,
    occurenceCount As Integer
) As Integer
public:
[ExtensionAttribute]
static int IndexOfOccurence(
    String^ s,
    wchar_t toLookFor,
    int startIndex,
    int occurenceCount
)
[<ExtensionAttribute>]
static member IndexOfOccurence :
        s : string *
        toLookFor : char *
        startIndex : int *
        occurenceCount : int -> int

Parameters

s
Type: SystemString
toLookFor
Type: SystemChar
startIndex
Type: SystemInt32
occurenceCount
Type: SystemInt32

Return Value

Type: Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
Alternet.Common Namespace


StringExtensions.Replace Method

StringExtensionsReplace Method
Returns a new string in which all occurrences of a specified string in the source string are replaced with another specified string.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Replace(
    this string source,
    string oldString,
    string newString,
    StringComparison comparison
)
<ExtensionAttribute>
Public Shared Function Replace (
    source As String,
    oldString As String,
    newString As String,
    comparison As StringComparison
) As String
public:
[ExtensionAttribute]
static String^ Replace(
    String^ source,
    String^ oldString,
    String^ newString,
    StringComparison comparison
)
[<ExtensionAttribute>]
static member Replace :
        source : string *
        oldString : string *
        newString : string *
        comparison : StringComparison -> string

Parameters

source
Type: SystemString
Source string to process.
oldString
Type: SystemString
The string to be replaced.
newString
Type: SystemString
The string to replace all occurrences of oldString.
comparison
Type: SystemStringComparison
One of the enumeration values that specifies the rules for the replacement.

Return Value

Type: String
A string that is equivalent to the source string except that all instances of oldString are replaced with newString.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
Alternet.Common Namespace


StringExtensions.SplitToLines Method

StringExtensionsSplitToLines Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] SplitToLines(
    this string s
)
<ExtensionAttribute>
Public Shared Function SplitToLines (
    s As String
) As String()
public:
[ExtensionAttribute]
static array<String^>^ SplitToLines(
    String^ s
)
[<ExtensionAttribute>]
static member SplitToLines :
        s : string -> string[]

Parameters

s
Type: SystemString

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
Alternet.Common Namespace


StringExtensions.ToHtml Method

StringExtensionsToHtml Method
Converts plain string to the HTML-formatted text.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ToHtml(
    this string s
)
<ExtensionAttribute>
Public Shared Function ToHtml (
    s As String
) As String
public:
[ExtensionAttribute]
static String^ ToHtml(
    String^ s
)
[<ExtensionAttribute>]
static member ToHtml :
        s : string -> string

Parameters

s
Type: SystemString
String to convert.

Return Value

Type: String
String with HTML tags.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
Alternet.Common Namespace


StringExtensions.ToPlainText Method

StringExtensionsToPlainText Method
Converts HTML-formatted string to the plain text.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ToPlainText(
    this string s
)
<ExtensionAttribute>
Public Shared Function ToPlainText (
    s As String
) As String
public:
[ExtensionAttribute]
static String^ ToPlainText(
    String^ s
)
[<ExtensionAttribute>]
static member ToPlainText :
        s : string -> string

Parameters

s
Type: SystemString
String to convert.

Return Value

Type: String
String without HTML tags.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
Alternet.Common Namespace


SymbolLocation Class

SymbolLocation Class
Represents information about location of the code symbol.
Inheritance Hierarchy
SystemObject
Alternet.CommonSymbolLocation

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SymbolLocation
Public Class SymbolLocation
public ref class SymbolLocation
type SymbolLocation =  class end

The SymbolLocation type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolLocation | Initializes a new instance of the SymbolLocation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualsTo | Returns true if symbol location is equal to the given object
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Column | Gets or sets column number of symbol.
Public property | FileName | Gets or sets name of file where symbol is located.
Public property | InSource | Gets boolean value, indicating if symbol is located within source file.
Public property | Line | Gets or sets line number of symbol.
Public property | Symbol | Gets or sets a code symbol which location is represented by this SymbolLocation.
Top
See Also

Reference

Alternet.Common Namespace


SymbolLocation Constructor

SymbolLocation Constructor
Initializes a new instance of the SymbolLocation class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolLocation()
Public Sub New
public:
SymbolLocation()
new : unit -> SymbolLocation
See Also

Reference

SymbolLocation Class
Alternet.Common Namespace


SymbolLocation Methods

SymbolLocation Methods

The SymbolLocation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualsTo | Returns true if symbol location is equal to the given object
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SymbolLocation Class
Alternet.Common Namespace


SymbolLocation.EqualsTo Method

SymbolLocationEqualsTo Method
Returns true if symbol location is equal to the given object

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EqualsTo(
    SymbolLocation location
)
Public Function EqualsTo (
    location As SymbolLocation
) As Boolean
public:
bool EqualsTo(
    SymbolLocation^ location
)
member EqualsTo :
        location : SymbolLocation -> bool

Parameters

location
Type: Alternet.CommonSymbolLocation
given symbol location

Return Value

Type: Boolean
True if location is equal to the given object; otherwise false.
See Also

Reference

SymbolLocation Class
Alternet.Common Namespace


SymbolLocation Properties

SymbolLocation Properties

The SymbolLocation type exposes the following members.

Properties
 | Name | Description
Public property | Column | Gets or sets column number of symbol.
Public property | FileName | Gets or sets name of file where symbol is located.
Public property | InSource | Gets boolean value, indicating if symbol is located within source file.
Public property | Line | Gets or sets line number of symbol.
Public property | Symbol | Gets or sets a code symbol which location is represented by this SymbolLocation.
Top
See Also

Reference

SymbolLocation Class
Alternet.Common Namespace


SymbolLocation.Column Property

SymbolLocationColumn Property
Gets or sets column number of symbol.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Column { get; set; }
Public Property Column As Integer
    Get
    Set
public:
property int Column {
    int get ();
    void set (int value);
}
member Column : int with get, set

Property Value

Type: Int32
See Also

Reference

SymbolLocation Class
Alternet.Common Namespace


SymbolLocation.FileName Property

SymbolLocationFileName Property
Gets or sets name of file where symbol is located.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

SymbolLocation Class
Alternet.Common Namespace


SymbolLocation.InSource Property

SymbolLocationInSource Property
Gets boolean value, indicating if symbol is located within source file.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool InSource { get; }
Public ReadOnly Property InSource As Boolean
    Get
public:
property bool InSource {
    bool get ();
}
member InSource : bool with get

Property Value

Type: Boolean
See Also

Reference

SymbolLocation Class
Alternet.Common Namespace


SymbolLocation.Line Property

SymbolLocationLine Property
Gets or sets line number of symbol.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

SymbolLocation Class
Alternet.Common Namespace


SymbolLocation.Symbol Property

SymbolLocationSymbol Property
Gets or sets a code symbol which location is represented by this SymbolLocation.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Symbol { get; set; }
Public Property Symbol As Object
    Get
    Set
public:
property Object^ Symbol {
    Object^ get ();
    void set (Object^ value);
}
member Symbol : Object with get, set

Property Value

Type: Object
See Also

Reference

SymbolLocation Class
Alternet.Common Namespace


TargetNETFrameworkVersion Enumeration

TargetNETFrameworkVersion Enumeration
Specifies version of the .NET Framework to be used for locating Framework assemblies.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TargetNETFrameworkVersion
Public Enumeration TargetNETFrameworkVersion
public enum class TargetNETFrameworkVersion
type TargetNETFrameworkVersion
Members
Member name | Value | Description
Version45 | 5 | Framework 4.5
VersionLatest | 5 | Framework 4.5
VersionAuto | 100 | Location of mscorlib
See Also

Reference

Alternet.Common Namespace


TechnologyEnvironment Enumeration

TechnologyEnvironment Enumeration
Specifies platform to be used for code completion.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TechnologyEnvironment
Public Enumeration TechnologyEnvironment
public enum class TechnologyEnvironment
type TechnologyEnvironment
Members
Member name | Value | Description
System | 0 | No UI Platform is used.
WindowsForms | 1 | Specifies Windows Forms platform.
Wpf | 2 | Specifies WPF platform.
WindowsFormsAndWpf | 3 | Specifies Windows Forms and WPF platforms.
See Also

Reference

Alternet.Common Namespace


ThreadStaticList(T) Class

ThreadStaticListT Class
This item supports the framework infrastructure and is not intended to be used directly from your code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListT
Alternet.CommonThreadStaticListT

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ThreadStaticList<T> : List<T>,
    IDisposable

Public Class ThreadStaticList(Of T)
    Inherits List(Of T)
    Implements IDisposable
generic<typename T>
public ref class ThreadStaticList : public List<T>,
    IDisposable
type ThreadStaticList<'T> =
    class
        inherit List<'T>
        interface IDisposable
    end

Type Parameters

T

The ThreadStaticListT type exposes the following members.

Constructors
 | Name | Description
Public method | ThreadStaticListT | This item supports the framework infrastructure and is not intended to be used directly from your code.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListT.)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListT.)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListT.)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListT.)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListT.)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListT.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListT.)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListT.)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListT.)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListT.)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListT.)
Public method | Dispose | Disposes this ThreadStaticList and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListT.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListT.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListT.)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListT.)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListT.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListT.)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListT.)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListT.)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListT.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListT.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListT.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListT.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListT.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListT.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListT.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListT.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListT.)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListT.)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListT.)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListT.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListT.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListT.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListT.)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListT.)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListT.)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListT.)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListT.)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListT.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListT.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListT.)
Public property | IsDisposed | This item supports the framework infrastructure and is not intended to be used directly from your code.
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListT.)
Top
See Also

Reference

Alternet.Common Namespace


ThreadStaticList(T) Constructor

ThreadStaticListT Constructor
This item supports the framework infrastructure and is not intended to be used directly from your code.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadStaticList(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
ThreadStaticList(
    int capacity
)
new :
        capacity : int -> ThreadStaticList

Parameters

capacity
Type: SystemInt32
See Also

Reference

ThreadStaticListT Class
Alternet.Common Namespace


ThreadStaticList(T) Methods

ThreadStaticListT Methods

The ThreadStaticListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListT .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListT .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListT .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListT .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListT .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListT .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListT .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListT .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListT .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListT .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListT .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListT .)
Public method | Dispose | Disposes this ThreadStaticList and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListT .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListT .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListT .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListT .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListT .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListT .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListT .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListT .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListT .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListT .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListT .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListT .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListT .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListT .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListT .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListT .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListT .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListT .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListT .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListT .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListT .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListT .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListT .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListT .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListT .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListT .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListT .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListT .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListT .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListT .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListT .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListT .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListT .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListT .)
Top
See Also

Reference

ThreadStaticListT Class
Alternet.Common Namespace


ThreadStaticList(T).Dispose Method

ThreadStaticListTDispose Method
Disposes this ThreadStaticList and frees resources associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ThreadStaticListT Class
Alternet.Common Namespace


ThreadStaticList(T) Properties

ThreadStaticListT Properties

The ThreadStaticListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListT .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListT .)
Public property | IsDisposed | This item supports the framework infrastructure and is not intended to be used directly from your code.
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListT .)
Top
See Also

Reference

ThreadStaticListT Class
Alternet.Common Namespace


ThreadStaticList(T).IsDisposed Property

ThreadStaticListTIsDisposed Property
This item supports the framework infrastructure and is not intended to be used directly from your code.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

Property Value

Type: Boolean
See Also

Reference

ThreadStaticListT Class
Alternet.Common Namespace


TreeViewHelper Class

TreeViewHelper Class
Inheritance Hierarchy
SystemObject
Alternet.CommonTreeViewHelper

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class TreeViewHelper
Public NotInheritable Class TreeViewHelper
public ref class TreeViewHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TreeViewHelper =  class end

The TreeViewHelper type exposes the following members.

Methods
Name | Description
GetNodeAtMouseCursor |
Top
See Also

Reference

Alternet.Common Namespace


TreeViewHelper Methods

TreeViewHelper Methods

The TreeViewHelper type exposes the following members.

Methods
Name | Description
GetNodeAtMouseCursor |
Top
See Also

Reference

TreeViewHelper Class
Alternet.Common Namespace


TreeViewHelper.GetNodeAtMouseCursor Method

TreeViewHelperGetNodeAtMouseCursor Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TreeNode GetNodeAtMouseCursor(
    TreeView treeView
)
Public Shared Function GetNodeAtMouseCursor (
    treeView As TreeView
) As TreeNode
public:
static TreeNode^ GetNodeAtMouseCursor(
    TreeView^ treeView
)
static member GetNodeAtMouseCursor :
        treeView : TreeView -> TreeNode

Parameters

treeView
Type: System.Windows.FormsTreeView

Return Value

Type: TreeNode
See Also

Reference

TreeViewHelper Class
Alternet.Common Namespace


Utilities Class

Utilities Class
An utility class to dispose object and resources.
Inheritance Hierarchy
SystemObject
Alternet.CommonUtilities

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Utilities
Public NotInheritable Class Utilities
public ref class Utilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Utilities =  class end
Methods
Name | Description
Dispose(IDisposable) | Disposes specified value and frees resources associated with it.
DisposeT(T) | Disposes specified value and frees resources associated with it.
Top
See Also

Reference

Alternet.Common Namespace


Utilities Methods

Utilities Methods
Methods
Name | Description
Dispose(IDisposable) | Disposes specified value and frees resources associated with it.
DisposeT(T) | Disposes specified value and frees resources associated with it.
Top
See Also

Reference

Utilities Class
Alternet.Common Namespace


Utilities.Dispose Method

UtilitiesDispose Method
Overload List
Name | Description
Dispose(IDisposable) | Disposes specified value and frees resources associated with it.
DisposeT(T) | Disposes specified value and frees resources associated with it.
Top
See Also

Reference

Utilities Class
Alternet.Common Namespace


Utilities.Dispose Method (IDisposable)

UtilitiesDispose Method (IDisposable)
Disposes specified value and frees resources associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Dispose(
    IDisposable value
)
Public Shared Sub Dispose (
    value As IDisposable
)
public:
static void Dispose(
    IDisposable^ value
)
static member Dispose :
        value : IDisposable -> unit

Parameters

value
Type: SystemIDisposable
IDisposable object to be disposed.
See Also

Reference

Utilities Class
Dispose Overload
Alternet.Common Namespace


Utilities.Dispose(T) Method (T)

UtilitiesDisposeT Method (T)
Disposes specified value and frees resources associated with it.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Dispose<T>(
    ref T value
)
where T : class, IDisposable

Public Shared Sub Dispose(Of T As {Class, IDisposable}) (
    ByRef value As T
)
public:
generic<typename T>
where T : ref class, IDisposable
static void Dispose(
    T% value
)
static member Dispose :
        value : 'T byref -> unit  when 'T : not struct and IDisposable

Parameters

value
Type: T
A value to be disposed.

Type Parameters

T
Type of object to dispose.
See Also

Reference

Utilities Class
Dispose Overload
Alternet.Common Namespace


WaitHandleExtensions Class

WaitHandleExtensions Class
Inheritance Hierarchy
SystemObject
Alternet.CommonWaitHandleExtensions

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class WaitHandleExtensions
<ExtensionAttribute>
Public NotInheritable Class WaitHandleExtensions
[ExtensionAttribute]
public ref class WaitHandleExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type WaitHandleExtensions =  class end

The WaitHandleExtensions type exposes the following members.

Methods
Name | Description
WaitOneAsync |
Top
See Also

Reference

Alternet.Common Namespace


WaitHandleExtensions Methods

WaitHandleExtensions Methods

The WaitHandleExtensions type exposes the following members.

Methods
Name | Description
WaitOneAsync |
Top
See Also

Reference

WaitHandleExtensions Class
Alternet.Common Namespace


WaitHandleExtensions.WaitOneAsync Method

WaitHandleExtensionsWaitOneAsync Method

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Task WaitOneAsync(
    this WaitHandle waitHandle
)
<ExtensionAttribute>
Public Shared Function WaitOneAsync (
    waitHandle As WaitHandle
) As Task
public:
[ExtensionAttribute]
static Task^ WaitOneAsync(
    WaitHandle^ waitHandle
)
[<ExtensionAttribute>]
static member WaitOneAsync :
        waitHandle : WaitHandle -> Task

Parameters

waitHandle
Type: System.ThreadingWaitHandle

Return Value

Type: Task

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WaitHandle. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

WaitHandleExtensions Class
Alternet.Common Namespace


XPThemeName Enumeration

XPThemeName Enumeration
Represents color theme names.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum XPThemeName
Public Enumeration XPThemeName
public enum class XPThemeName
type XPThemeName
Members
Member name | Value | Description
None | 0 | Defines that no color theme is available.
Blue | 1 | Defines blue color theme.
HomeStead | 2 | Defines HomeStead color theme.
Metallic | 3 | Defines metallic color theme.
Custom | 4 | Defines custom color theme.
See Also

Reference

Alternet.Common Namespace


XPThemes Class

XPThemes Class
This class provides functionality to draw control's background with various visual styles.
Inheritance Hierarchy
SystemObject
Alternet.CommonXPThemes

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XPThemes
Public Class XPThemes
public ref class XPThemes
type XPThemes =  class end

The XPThemes type exposes the following members.

Constructors
 | Name | Description
Public method | XPThemes | Initializes a new instance of the XPThemes class
Top
Methods
 | Name | Description
 | DoneTheme | Destroys current theme before initialization new theme.
 | DrawBackground | Draws the control background within the specified rectangle with current theme.
 | DrawCheckBox | Draws check box within the specified rectangle with current theme.
 | DrawEditBorder(IntPtr, Rectangle) | Draws border of edit control within the specified rectangle with current theme.
 | DrawEditBorder(IPainter, Rectangle) | Draws border of edit control within the specified rectangle with current theme.
 | DrawGroupBackground | Draws the group background within the specified rectangle with current theme.
 | DrawPushButton | Draws button within the specified rectangle with current theme.
 | DrawRect | Returns the rectangle object displaced relatively specified rectangle object by Offset value.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetGroupCaptionColor | Returns color of the group caption with current color theme.
 | GetGroupItemCaptionColor | Returns color of the group item caption with current color theme.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitTheme | Initializes a new theme.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name | Description
CurrentTheme | Represents name of current color theme.
Offset | Sets the value that specifies two-dimensional shift matrix.
Top
See Also

Reference

Alternet.Common Namespace


XPThemes Constructor

XPThemes Constructor
Initializes a new instance of the XPThemes class

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XPThemes()
Public Sub New
public:
XPThemes()
new : unit -> XPThemes
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes Methods

XPThemes Methods

The XPThemes type exposes the following members.

Methods
 | Name | Description
 | DoneTheme | Destroys current theme before initialization new theme.
 | DrawBackground | Draws the control background within the specified rectangle with current theme.
 | DrawCheckBox | Draws check box within the specified rectangle with current theme.
 | DrawEditBorder(IntPtr, Rectangle) | Draws border of edit control within the specified rectangle with current theme.
 | DrawEditBorder(IPainter, Rectangle) | Draws border of edit control within the specified rectangle with current theme.
 | DrawGroupBackground | Draws the group background within the specified rectangle with current theme.
 | DrawPushButton | Draws button within the specified rectangle with current theme.
 | DrawRect | Returns the rectangle object displaced relatively specified rectangle object by Offset value.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetGroupCaptionColor | Returns color of the group caption with current color theme.
 | GetGroupItemCaptionColor | Returns color of the group item caption with current color theme.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitTheme | Initializes a new theme.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.DoneTheme Method

XPThemesDoneTheme Method
Destroys current theme before initialization new theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DoneTheme()
Public Shared Sub DoneTheme
public:
static void DoneTheme()
static member DoneTheme : unit -> unit
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.DrawBackground Method

XPThemesDrawBackground Method
Draws the control background within the specified rectangle with current theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawBackground(
    IPainter painter,
    Rectangle rect,
    Color startColor,
    Color endColor
)
Public Shared Sub DrawBackground (
    painter As IPainter,
    rect As Rectangle,
    startColor As Color,
    endColor As Color
)
public:
static void DrawBackground(
    IPainter^ painter,
    Rectangle rect,
    Color startColor,
    Color endColor
)
static member DrawBackground :
        painter : IPainter *
        rect : Rectangle *
        startColor : Color *
        endColor : Color -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
rect
Type: System.DrawingRectangle
The Rectangle that represents the dimensions of the control.
startColor
Type: System.DrawingColor
Specifies start background color for gradient background painting when no theme is available.
endColor
Type: System.DrawingColor
Specifies end background color for gradient background painting when no theme is available.
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.DrawCheckBox Method

XPThemesDrawCheckBox Method
Draws check box within the specified rectangle with current theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawCheckBox(
    IPainter painter,
    Rectangle rect,
    bool pressed,
    bool hot
)
Public Shared Sub DrawCheckBox (
    painter As IPainter,
    rect As Rectangle,
    pressed As Boolean,
    hot As Boolean
)
public:
static void DrawCheckBox(
    IPainter^ painter,
    Rectangle rect,
    bool pressed,
    bool hot
)
static member DrawCheckBox :
        painter : IPainter *
        rect : Rectangle *
        pressed : bool *
        hot : bool -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
rect
Type: System.DrawingRectangle
The Rectangle that represents the dimensions of the control.
pressed
Type: SystemBoolean
Specifies if the button is pressed.
hot
Type: SystemBoolean
Specifies if the button is hot.
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.DrawEditBorder Method

XPThemesDrawEditBorder Method
Overload List
Name | Description
DrawEditBorder(IntPtr, Rectangle) | Draws border of edit control within the specified rectangle with current theme.
DrawEditBorder(IPainter, Rectangle) | Draws border of edit control within the specified rectangle with current theme.
Top
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.DrawEditBorder Method (IntPtr, Rectangle)

XPThemesDrawEditBorder Method (IntPtr, Rectangle)
Draws border of edit control within the specified rectangle with current theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawEditBorder(
    IntPtr dc,
    Rectangle rect
)
Public Shared Sub DrawEditBorder (
    dc As IntPtr,
    rect As Rectangle
)
public:
static void DrawEditBorder(
    IntPtr dc,
    Rectangle rect
)
static member DrawEditBorder :
        dc : IntPtr *
        rect : Rectangle -> unit

Parameters

dc
Type: SystemIntPtr
Handle to a device context used for drawing the theme-defined background image.
rect
Type: System.DrawingRectangle
The Rectangle that represents the dimensions of the control.
See Also

Reference

XPThemes Class
DrawEditBorder Overload
Alternet.Common Namespace


XPThemes.DrawEditBorder Method (IPainter, Rectangle)

XPThemesDrawEditBorder Method (IPainter, Rectangle)
Draws border of edit control within the specified rectangle with current theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawEditBorder(
    IPainter painter,
    Rectangle rect
)
Public Shared Sub DrawEditBorder (
    painter As IPainter,
    rect As Rectangle
)
public:
static void DrawEditBorder(
    IPainter^ painter,
    Rectangle rect
)
static member DrawEditBorder :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
rect
Type: System.DrawingRectangle
The Rectangle that represents the dimensions of the control.
See Also

Reference

XPThemes Class
DrawEditBorder Overload
Alternet.Common Namespace


XPThemes.DrawGroupBackground Method

XPThemesDrawGroupBackground Method
Draws the group background within the specified rectangle with current theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawGroupBackground(
    IPainter painter,
    Rectangle rect
)
Public Shared Sub DrawGroupBackground (
    painter As IPainter,
    rect As Rectangle
)
public:
static void DrawGroupBackground(
    IPainter^ painter,
    Rectangle rect
)
static member DrawGroupBackground :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
rect
Type: System.DrawingRectangle
The Rectangle that represents the dimensions of the group.
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.DrawPushButton Method

XPThemesDrawPushButton Method
Draws button within the specified rectangle with current theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawPushButton(
    IPainter painter,
    Rectangle rect,
    bool pressed,
    bool hot
)
Public Shared Sub DrawPushButton (
    painter As IPainter,
    rect As Rectangle,
    pressed As Boolean,
    hot As Boolean
)
public:
static void DrawPushButton(
    IPainter^ painter,
    Rectangle rect,
    bool pressed,
    bool hot
)
static member DrawPushButton :
        painter : IPainter *
        rect : Rectangle *
        pressed : bool *
        hot : bool -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
rect
Type: System.DrawingRectangle
The Rectangle that represents the dimensions of the control.
pressed
Type: SystemBoolean
Specifies if the button is pressed.
hot
Type: SystemBoolean
Specifies if the button is hot.
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.DrawRect Method

XPThemesDrawRect Method
Returns the rectangle object displaced relatively specified rectangle object by Offset value.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Rectangle DrawRect(
    Rectangle sourceRect
)
Public Shared Function DrawRect (
    sourceRect As Rectangle
) As Rectangle
public:
static Rectangle DrawRect(
    Rectangle sourceRect
)
static member DrawRect :
        sourceRect : Rectangle -> Rectangle

Parameters

sourceRect
Type: System.DrawingRectangle
The source Rectangle object.

Return Value

Type: Rectangle
Offset rectangle.
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.GetGroupCaptionColor Method

XPThemesGetGroupCaptionColor Method
Returns color of the group caption with current color theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color GetGroupCaptionColor(
    bool hot
)
Public Shared Function GetGroupCaptionColor (
    hot As Boolean
) As Color
public:
static Color GetGroupCaptionColor(
    bool hot
)
static member GetGroupCaptionColor :
        hot : bool -> Color

Parameters

hot
Type: SystemBoolean
Specifies if the group is hot.

Return Value

Type: Color
The Color structure that specifies color of the group caption.
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.GetGroupItemCaptionColor Method

XPThemesGetGroupItemCaptionColor Method
Returns color of the group item caption with current color theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color GetGroupItemCaptionColor(
    bool hot
)
Public Shared Function GetGroupItemCaptionColor (
    hot As Boolean
) As Color
public:
static Color GetGroupItemCaptionColor(
    bool hot
)
static member GetGroupItemCaptionColor :
        hot : bool -> Color

Parameters

hot
Type: SystemBoolean
Specifies if the item is hot.

Return Value

Type: Color
The Color structure that specifies color of the group item caption.
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.InitTheme Method

XPThemesInitTheme Method
Initializes a new theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void InitTheme()
Public Shared Sub InitTheme
public:
static void InitTheme()
static member InitTheme : unit -> unit
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes Properties

XPThemes Properties

The XPThemes type exposes the following members.

Properties
Name | Description
CurrentTheme | Represents name of current color theme.
Offset | Sets the value that specifies two-dimensional shift matrix.
Top
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.CurrentTheme Property

XPThemesCurrentTheme Property
Represents name of current color theme.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XPThemeName CurrentTheme { get; }
Public Shared ReadOnly Property CurrentTheme As XPThemeName
    Get
public:
static property XPThemeName CurrentTheme {
    XPThemeName get ();
}
static member CurrentTheme : XPThemeName with get

Property Value

Type: XPThemeName
See Also

Reference

XPThemes Class
Alternet.Common Namespace


XPThemes.Offset Property

XPThemesOffset Property
Sets the value that specifies two-dimensional shift matrix.

Namespace: Alternet.Common
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point Offset { get; set; }
Public Shared Property Offset As Point
    Get
    Set
public:
static property Point Offset {
    Point get ();
    void set (Point value);
}
static member Offset : Point with get, set

Property Value

Type: Point
See Also

Reference

XPThemes Class
Alternet.Common Namespace


Alternet.Common.Controls.TreeView Namespace

Alternet.Common.Controls.TreeView Namespace
Classes
 | Class | Description
Public class | CustomDrawnTreeView | Provides node expand button hit test functionality for custom drawn tree views.
Public class | FlickerFreeTreeView | Specifies extended TreeView control suppresses flickering while TreeView content is changing.
Public class | NodePartHitTestEventArgs | Provides data for the NodePartHitTest event handler.
Public class | TreeViewDragAndDropManager |
Public class | TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs |
Public class | TreeViewDropMarker |
Interfaces
 | Interface | Description
Public interface | TreeViewDragAndDropManagerIDragAndDropListener |
Enumerations
 | Enumeration | Description
Public enumeration | NodePart | Specifies types of node parts.


CustomDrawnTreeView Class

CustomDrawnTreeView Class
Provides node expand button hit test functionality for custom drawn tree views.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTreeView
Alternet.Common.Controls.TreeViewFlickerFreeTreeView
Alternet.Common.Controls.TreeViewCustomDrawnTreeView

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CustomDrawnTreeView : FlickerFreeTreeView
Public Class CustomDrawnTreeView
    Inherits FlickerFreeTreeView
public ref class CustomDrawnTreeView : public FlickerFreeTreeView
type CustomDrawnTreeView =
    class
        inherit FlickerFreeTreeView
    end

The CustomDrawnTreeView type exposes the following members.

Constructors
 | Name | Description
Public method | CustomDrawnTreeView | Initializes a new instance of the CustomDrawnTreeView class
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNodeAt(Point) | Retrieves the tree node that is at the specified point. (Inherited from TreeView.)
Public method | GetNodeAt(Int32, Int32) | Retrieves the tree node at the point with the specified coordinates. (Inherited from TreeView.)
Public method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest(Point) | Provides node information, given a point. (Inherited from TreeView.)
Public method | HitTest(Int32, Int32) | Provides node information, given x- and y-coordinates. (Inherited from TreeView.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Sort | Sorts the items in TreeView control. (Inherited from TreeView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Overrides ToString. (Inherited from TreeView.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | (Inherited from TreeView.)
Public property | BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
Public property | BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from TreeView.)
Public property | FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
Public property | HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
Public property | ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
Public property | ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
Public property | ImageList | Gets or sets the ImageList that contains the Image objects that are used by the tree nodes. (Inherited from TreeView.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | Indent | Gets or sets the distance to indent each child tree node level. (Inherited from TreeView.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
Public property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NodePartHitTestEnabled | Gets or sets a value indicating whether hit test for the part of node is enabled.
Public property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Public property | Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value that indicates whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
Public property | Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
Public property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
Public property | SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
Public property | SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
Public property | ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
Public property | ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
Public property | ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
Public property | StateImageList | Gets or sets the image list that is used to indicate the state of the TreeView and its nodes. (Inherited from TreeView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
Public property | TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AfterCheck | Occurs after the tree node check box is checked. (Inherited from TreeView.)
Public event | AfterCollapse | Occurs after the tree node is collapsed. (Inherited from TreeView.)
Public event | AfterExpand | Occurs after the tree node is expanded. (Inherited from TreeView.)
Public event | AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from TreeView.)
Public event | AfterSelect | Occurs after the tree node is selected. (Inherited from TreeView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from TreeView.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from TreeView.)
Public event | BeforeCheck | Occurs before the tree node check box is checked. (Inherited from TreeView.)
Public event | BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from TreeView.)
Public event | BeforeExpand | Occurs before the tree node is expanded. (Inherited from TreeView.)
Public event | BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from TreeView.)
Public event | BeforeSelect | Occurs before the tree node is selected. (Inherited from TreeView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawNode | Occurs when a TreeView is drawn and the DrawMode property is set to a TreeViewDrawMode value other than Normal. (Inherited from TreeView.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging a node. (Inherited from TreeView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseHover | Occurs when the mouse hovers over a TreeNode. (Inherited from TreeView.)
Public event | NodePartHitTest | Occurs when part of TreeView node is clicked by left mouse button.
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from TreeView.)
Public event | Paint | Occurs when the TreeView is drawn. (Inherited from TreeView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TreeView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property changes. (Inherited from TreeView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Common.Controls.TreeView Namespace


CustomDrawnTreeView Constructor

CustomDrawnTreeView Constructor
Initializes a new instance of the CustomDrawnTreeView class

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CustomDrawnTreeView()
Public Sub New
public:
CustomDrawnTreeView()
new : unit -> CustomDrawnTreeView
See Also

Reference

CustomDrawnTreeView Class
Alternet.Common.Controls.TreeView Namespace


CustomDrawnTreeView Methods

CustomDrawnTreeView Methods

The CustomDrawnTreeView type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNodeAt(Point) | Retrieves the tree node that is at the specified point. (Inherited from TreeView.)
Public method | GetNodeAt(Int32, Int32) | Retrieves the tree node at the point with the specified coordinates. (Inherited from TreeView.)
Public method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest(Point) | Provides node information, given a point. (Inherited from TreeView.)
Public method | HitTest(Int32, Int32) | Provides node information, given x- and y-coordinates. (Inherited from TreeView.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Sort | Sorts the items in TreeView control. (Inherited from TreeView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Overrides ToString. (Inherited from TreeView.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

CustomDrawnTreeView Class
Alternet.Common.Controls.TreeView Namespace


CustomDrawnTreeView Properties

CustomDrawnTreeView Properties

The CustomDrawnTreeView type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | (Inherited from TreeView.)
Public property | BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
Public property | BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from TreeView.)
Public property | FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
Public property | HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
Public property | ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
Public property | ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
Public property | ImageList | Gets or sets the ImageList that contains the Image objects that are used by the tree nodes. (Inherited from TreeView.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | Indent | Gets or sets the distance to indent each child tree node level. (Inherited from TreeView.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
Public property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NodePartHitTestEnabled | Gets or sets a value indicating whether hit test for the part of node is enabled.
Public property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Public property | Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value that indicates whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
Public property | Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
Public property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
Public property | SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
Public property | SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
Public property | ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
Public property | ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
Public property | ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
Public property | StateImageList | Gets or sets the image list that is used to indicate the state of the TreeView and its nodes. (Inherited from TreeView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
Public property | TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CustomDrawnTreeView Class
Alternet.Common.Controls.TreeView Namespace


CustomDrawnTreeView.NodePartHitTestEnabled Property

CustomDrawnTreeViewNodePartHitTestEnabled Property
Gets or sets a value indicating whether hit test for the part of node is enabled.

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NodePartHitTestEnabled { get; set; }
Public Property NodePartHitTestEnabled As Boolean
    Get
    Set
public:
property bool NodePartHitTestEnabled {
    bool get ();
    void set (bool value);
}
member NodePartHitTestEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomDrawnTreeView Class
Alternet.Common.Controls.TreeView Namespace


CustomDrawnTreeView Events

CustomDrawnTreeView Events

The CustomDrawnTreeView type exposes the following members.

Events
 | Name | Description
Public event | AfterCheck | Occurs after the tree node check box is checked. (Inherited from TreeView.)
Public event | AfterCollapse | Occurs after the tree node is collapsed. (Inherited from TreeView.)
Public event | AfterExpand | Occurs after the tree node is expanded. (Inherited from TreeView.)
Public event | AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from TreeView.)
Public event | AfterSelect | Occurs after the tree node is selected. (Inherited from TreeView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from TreeView.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from TreeView.)
Public event | BeforeCheck | Occurs before the tree node check box is checked. (Inherited from TreeView.)
Public event | BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from TreeView.)
Public event | BeforeExpand | Occurs before the tree node is expanded. (Inherited from TreeView.)
Public event | BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from TreeView.)
Public event | BeforeSelect | Occurs before the tree node is selected. (Inherited from TreeView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawNode | Occurs when a TreeView is drawn and the DrawMode property is set to a TreeViewDrawMode value other than Normal. (Inherited from TreeView.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging a node. (Inherited from TreeView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseHover | Occurs when the mouse hovers over a TreeNode. (Inherited from TreeView.)
Public event | NodePartHitTest | Occurs when part of TreeView node is clicked by left mouse button.
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from TreeView.)
Public event | Paint | Occurs when the TreeView is drawn. (Inherited from TreeView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TreeView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property changes. (Inherited from TreeView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CustomDrawnTreeView Class
Alternet.Common.Controls.TreeView Namespace


CustomDrawnTreeView.NodePartHitTest Event

CustomDrawnTreeViewNodePartHitTest Event
Occurs when part of TreeView node is clicked by left mouse button.

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<NodePartHitTestEventArgs> NodePartHitTest
Public Event NodePartHitTest As EventHandler(Of NodePartHitTestEventArgs)
public:
 event EventHandler<NodePartHitTestEventArgs^>^ NodePartHitTest {
    void add (EventHandler<NodePartHitTestEventArgs^>^ value);
    void remove (EventHandler<NodePartHitTestEventArgs^>^ value);
}
member NodePartHitTest : IEvent<EventHandler<NodePartHitTestEventArgs>,
    NodePartHitTestEventArgs>

Value

Type: SystemEventHandlerNodePartHitTestEventArgs
See Also

Reference

CustomDrawnTreeView Class
Alternet.Common.Controls.TreeView Namespace


FlickerFreeTreeView Class

FlickerFreeTreeView Class
Specifies extended TreeView control suppresses flickering while TreeView content is changing.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTreeView
Alternet.Common.Controls.TreeViewFlickerFreeTreeView
Alternet.Common.Controls.TreeViewCustomDrawnTreeView

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FlickerFreeTreeView : TreeView
Public Class FlickerFreeTreeView
    Inherits TreeView
public ref class FlickerFreeTreeView : public TreeView
type FlickerFreeTreeView =
    class
        inherit TreeView
    end

The FlickerFreeTreeView type exposes the following members.

Constructors
 | Name | Description
Public method | FlickerFreeTreeView | Initializes a new instance of the FlickerFreeTreeView class
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNodeAt(Point) | Retrieves the tree node that is at the specified point. (Inherited from TreeView.)
Public method | GetNodeAt(Int32, Int32) | Retrieves the tree node at the point with the specified coordinates. (Inherited from TreeView.)
Public method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest(Point) | Provides node information, given a point. (Inherited from TreeView.)
Public method | HitTest(Int32, Int32) | Provides node information, given x- and y-coordinates. (Inherited from TreeView.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Sort | Sorts the items in TreeView control. (Inherited from TreeView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Overrides ToString. (Inherited from TreeView.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | (Inherited from TreeView.)
Public property | BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
Public property | BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from TreeView.)
Public property | FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
Public property | HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
Public property | ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
Public property | ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
Public property | ImageList | Gets or sets the ImageList that contains the Image objects that are used by the tree nodes. (Inherited from TreeView.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | Indent | Gets or sets the distance to indent each child tree node level. (Inherited from TreeView.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
Public property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Public property | Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value that indicates whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
Public property | Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
Public property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
Public property | SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
Public property | SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
Public property | ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
Public property | ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
Public property | ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
Public property | StateImageList | Gets or sets the image list that is used to indicate the state of the TreeView and its nodes. (Inherited from TreeView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
Public property | TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AfterCheck | Occurs after the tree node check box is checked. (Inherited from TreeView.)
Public event | AfterCollapse | Occurs after the tree node is collapsed. (Inherited from TreeView.)
Public event | AfterExpand | Occurs after the tree node is expanded. (Inherited from TreeView.)
Public event | AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from TreeView.)
Public event | AfterSelect | Occurs after the tree node is selected. (Inherited from TreeView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from TreeView.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from TreeView.)
Public event | BeforeCheck | Occurs before the tree node check box is checked. (Inherited from TreeView.)
Public event | BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from TreeView.)
Public event | BeforeExpand | Occurs before the tree node is expanded. (Inherited from TreeView.)
Public event | BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from TreeView.)
Public event | BeforeSelect | Occurs before the tree node is selected. (Inherited from TreeView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawNode | Occurs when a TreeView is drawn and the DrawMode property is set to a TreeViewDrawMode value other than Normal. (Inherited from TreeView.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging a node. (Inherited from TreeView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseHover | Occurs when the mouse hovers over a TreeNode. (Inherited from TreeView.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from TreeView.)
Public event | Paint | Occurs when the TreeView is drawn. (Inherited from TreeView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TreeView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property changes. (Inherited from TreeView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Common.Controls.TreeView Namespace


FlickerFreeTreeView Constructor

FlickerFreeTreeView Constructor
Initializes a new instance of the FlickerFreeTreeView class

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlickerFreeTreeView()
Public Sub New
public:
FlickerFreeTreeView()
new : unit -> FlickerFreeTreeView
See Also

Reference

FlickerFreeTreeView Class
Alternet.Common.Controls.TreeView Namespace


FlickerFreeTreeView Methods

FlickerFreeTreeView Methods

The FlickerFreeTreeView type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNodeAt(Point) | Retrieves the tree node that is at the specified point. (Inherited from TreeView.)
Public method | GetNodeAt(Int32, Int32) | Retrieves the tree node at the point with the specified coordinates. (Inherited from TreeView.)
Public method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest(Point) | Provides node information, given a point. (Inherited from TreeView.)
Public method | HitTest(Int32, Int32) | Provides node information, given x- and y-coordinates. (Inherited from TreeView.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Sort | Sorts the items in TreeView control. (Inherited from TreeView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Overrides ToString. (Inherited from TreeView.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

FlickerFreeTreeView Class
Alternet.Common.Controls.TreeView Namespace


FlickerFreeTreeView Properties

FlickerFreeTreeView Properties

The FlickerFreeTreeView type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | (Inherited from TreeView.)
Public property | BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
Public property | BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | The current foreground color for this control, which is the color the control uses to draw its text. (Inherited from TreeView.)
Public property | FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
Public property | HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
Public property | ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
Public property | ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
Public property | ImageList | Gets or sets the ImageList that contains the Image objects that are used by the tree nodes. (Inherited from TreeView.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | Indent | Gets or sets the distance to indent each child tree node level. (Inherited from TreeView.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
Public property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Public property | Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value that indicates whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
Public property | Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
Public property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
Public property | SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
Public property | SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
Public property | ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
Public property | ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
Public property | ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
Public property | StateImageList | Gets or sets the image list that is used to indicate the state of the TreeView and its nodes. (Inherited from TreeView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
Public property | TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

FlickerFreeTreeView Class
Alternet.Common.Controls.TreeView Namespace


FlickerFreeTreeView Events

FlickerFreeTreeView Events

The FlickerFreeTreeView type exposes the following members.

Events
 | Name | Description
Public event | AfterCheck | Occurs after the tree node check box is checked. (Inherited from TreeView.)
Public event | AfterCollapse | Occurs after the tree node is collapsed. (Inherited from TreeView.)
Public event | AfterExpand | Occurs after the tree node is expanded. (Inherited from TreeView.)
Public event | AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from TreeView.)
Public event | AfterSelect | Occurs after the tree node is selected. (Inherited from TreeView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from TreeView.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from TreeView.)
Public event | BeforeCheck | Occurs before the tree node check box is checked. (Inherited from TreeView.)
Public event | BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from TreeView.)
Public event | BeforeExpand | Occurs before the tree node is expanded. (Inherited from TreeView.)
Public event | BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from TreeView.)
Public event | BeforeSelect | Occurs before the tree node is selected. (Inherited from TreeView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawNode | Occurs when a TreeView is drawn and the DrawMode property is set to a TreeViewDrawMode value other than Normal. (Inherited from TreeView.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging a node. (Inherited from TreeView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseHover | Occurs when the mouse hovers over a TreeNode. (Inherited from TreeView.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from TreeView.)
Public event | Paint | Occurs when the TreeView is drawn. (Inherited from TreeView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TreeView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property changes. (Inherited from TreeView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

FlickerFreeTreeView Class
Alternet.Common.Controls.TreeView Namespace


NodePart Enumeration

NodePart Enumeration
Specifies types of node parts.

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum NodePart
Public Enumeration NodePart
public enum class NodePart
type NodePart
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
ExpandButton | 1 | Specifies expand button.
See Also

Reference

Alternet.Common.Controls.TreeView Namespace


NodePartHitTestEventArgs Class

NodePartHitTestEventArgs Class
Provides data for the NodePartHitTest event handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Common.Controls.TreeViewNodePartHitTestEventArgs

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NodePartHitTestEventArgs : EventArgs
Public Class NodePartHitTestEventArgs
    Inherits EventArgs
public ref class NodePartHitTestEventArgs : public EventArgs
type NodePartHitTestEventArgs =
    class
        inherit EventArgs
    end

The NodePartHitTestEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodePartHitTestEventArgs | Initializes a new instance of the NodePartHitTestEventArgs class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | LocationInNode | Gets the location of the mouse during the mouse event.
Public property | Node | Gets TreeNode to check.
Public property | NodePart | Gets or sets kind of node part.
Top
See Also

Reference

Alternet.Common.Controls.TreeView Namespace


NodePartHitTestEventArgs Constructor

NodePartHitTestEventArgs Constructor
Initializes a new instance of the NodePartHitTestEventArgs class with specified settings.

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NodePartHitTestEventArgs(
    TreeNode node,
    Point locationInNode
)
Public Sub New (
    node As TreeNode,
    locationInNode As Point
)
public:
NodePartHitTestEventArgs(
    TreeNode^ node,
    Point locationInNode
)
new :
        node : TreeNode *
        locationInNode : Point -> NodePartHitTestEventArgs

Parameters

node
Type: System.Windows.FormsTreeNode
TreeNode to check.
locationInNode
Type: System.DrawingPoint
Specifies the location of the mouse during the mouse event.
See Also

Reference

NodePartHitTestEventArgs Class
Alternet.Common.Controls.TreeView Namespace


NodePartHitTestEventArgs Methods

NodePartHitTestEventArgs Methods

The NodePartHitTestEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NodePartHitTestEventArgs Class
Alternet.Common.Controls.TreeView Namespace


NodePartHitTestEventArgs Properties

NodePartHitTestEventArgs Properties

The NodePartHitTestEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | LocationInNode | Gets the location of the mouse during the mouse event.
Public property | Node | Gets TreeNode to check.
Public property | NodePart | Gets or sets kind of node part.
Top
See Also

Reference

NodePartHitTestEventArgs Class
Alternet.Common.Controls.TreeView Namespace


NodePartHitTestEventArgs.LocationInNode Property

NodePartHitTestEventArgsLocationInNode Property
Gets the location of the mouse during the mouse event.

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point LocationInNode { get; }
Public ReadOnly Property LocationInNode As Point
    Get
public:
property Point LocationInNode {
    Point get ();
}
member LocationInNode : Point with get

Property Value

Type: Point
See Also

Reference

NodePartHitTestEventArgs Class
Alternet.Common.Controls.TreeView Namespace


NodePartHitTestEventArgs.Node Property

NodePartHitTestEventArgsNode Property
Gets TreeNode to check.

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeNode Node { get; }
Public ReadOnly Property Node As TreeNode
    Get
public:
property TreeNode^ Node {
    TreeNode^ get ();
}
member Node : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

NodePartHitTestEventArgs Class
Alternet.Common.Controls.TreeView Namespace


NodePartHitTestEventArgs.NodePart Property

NodePartHitTestEventArgsNodePart Property
Gets or sets kind of node part.

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NodePart NodePart { get; set; }
Public Property NodePart As NodePart
    Get
    Set
public:
property NodePart NodePart {
    NodePart get ();
    void set (NodePart value);
}
member NodePart : NodePart with get, set

Property Value

Type: NodePart
See Also

Reference

NodePartHitTestEventArgs Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager Class

TreeViewDragAndDropManager Class
Inheritance Hierarchy
SystemObject
Alternet.Common.Controls.TreeViewTreeViewDragAndDropManager

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TreeViewDragAndDropManager : IDisposable
Public Class TreeViewDragAndDropManager
    Implements IDisposable
public ref class TreeViewDragAndDropManager : IDisposable
type TreeViewDragAndDropManager =
    class
        interface IDisposable
    end

The TreeViewDragAndDropManager type exposes the following members.

Constructors
 | Name | Description
Public method | TreeViewDragAndDropManager | Initializes a new instance of the TreeViewDragAndDropManager class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TreeViewDragAndDropManager
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DragAndDropEnabled |
Top
Events
 | Name | Description
Public event | CustomDropMarkerNodeBoundsRequired |
Top
See Also

Reference

Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager Constructor

TreeViewDragAndDropManager Constructor
Initializes a new instance of the TreeViewDragAndDropManager class

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeViewDragAndDropManager(
    TreeView treeView,
    TreeViewDragAndDropManagerIDragAndDropListener listener
)
Public Sub New (
    treeView As TreeView,
    listener As TreeViewDragAndDropManagerIDragAndDropListener
)
public:
TreeViewDragAndDropManager(
    TreeView^ treeView,
    TreeViewDragAndDropManagerIDragAndDropListener^ listener
)
new :
        treeView : TreeView *
        listener : TreeViewDragAndDropManagerIDragAndDropListener -> TreeViewDragAndDropManager

Parameters

treeView
Type: System.Windows.FormsTreeView
listener
Type: Alternet.Common.Controls.TreeViewTreeViewDragAndDropManagerIDragAndDropListener
See Also

Reference

TreeViewDragAndDropManager Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager Methods

TreeViewDragAndDropManager Methods

The TreeViewDragAndDropManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TreeViewDragAndDropManager Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.Dispose Method

TreeViewDragAndDropManagerDispose Method
Releases all resources used by the TreeViewDragAndDropManager

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TreeViewDragAndDropManager Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager Properties

TreeViewDragAndDropManager Properties

The TreeViewDragAndDropManager type exposes the following members.

Properties
 | Name | Description
Public property | DragAndDropEnabled |
Top
See Also

Reference

TreeViewDragAndDropManager Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.DragAndDropEnabled Property

TreeViewDragAndDropManagerDragAndDropEnabled Property

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DragAndDropEnabled { get; set; }
Public Property DragAndDropEnabled As Boolean
    Get
    Set
public:
property bool DragAndDropEnabled {
    bool get ();
    void set (bool value);
}
member DragAndDropEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TreeViewDragAndDropManager Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager Events

TreeViewDragAndDropManager Events

The TreeViewDragAndDropManager type exposes the following members.

Events
 | Name | Description
Public event | CustomDropMarkerNodeBoundsRequired |
Top
See Also

Reference

TreeViewDragAndDropManager Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.CustomDropMarkerNodeBoundsRequired Event

TreeViewDragAndDropManagerCustomDropMarkerNodeBoundsRequired Event

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs> CustomDropMarkerNodeBoundsRequired
Public Event CustomDropMarkerNodeBoundsRequired As EventHandler(Of TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs)
public:
 event EventHandler<TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs^>^ CustomDropMarkerNodeBoundsRequired {
    void add (EventHandler<TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs^>^ value);
    void remove (EventHandler<TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs^>^ value);
}
member CustomDropMarkerNodeBoundsRequired : IEvent<EventHandler<TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs>,
    TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs>

Value

Type: SystemEventHandlerTreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs
See Also

Reference

TreeViewDragAndDropManager Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.DropMarkerNodeBoundsRequiredEventArgs Class

TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs Class
Inheritance Hierarchy
SystemObject
Alternet.Common.Controls.TreeViewTreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DropMarkerNodeBoundsRequiredEventArgs
Public Class DropMarkerNodeBoundsRequiredEventArgs
public ref class DropMarkerNodeBoundsRequiredEventArgs
type DropMarkerNodeBoundsRequiredEventArgs =  class end

The TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs | Initializes a new instance of the TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Node |
Public property | NodeBounds |
Top
See Also

Reference

Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.DropMarkerNodeBoundsRequiredEventArgs Constructor

TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs Constructor
Initializes a new instance of the TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs class

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DropMarkerNodeBoundsRequiredEventArgs(
    TreeNode node
)
Public Sub New (
    node As TreeNode
)
public:
DropMarkerNodeBoundsRequiredEventArgs(
    TreeNode^ node
)
new :
        node : TreeNode -> DropMarkerNodeBoundsRequiredEventArgs

Parameters

node
Type: System.Windows.FormsTreeNode
See Also

Reference

TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs Class
Alternet.Common.Controls.TreeView Namespace


DropMarkerNodeBoundsRequiredEventArgs Methods

DropMarkerNodeBoundsRequiredEventArgs Methods

The TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs Class
Alternet.Common.Controls.TreeView Namespace


DropMarkerNodeBoundsRequiredEventArgs Properties

DropMarkerNodeBoundsRequiredEventArgs Properties

The TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node |
Public property | NodeBounds |
Top
See Also

Reference

TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.DropMarkerNodeBoundsRequiredEventArgs.Node Property

TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgsNode Property

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeNode Node { get; }
Public ReadOnly Property Node As TreeNode
    Get
public:
property TreeNode^ Node {
    TreeNode^ get ();
}
member Node : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.DropMarkerNodeBoundsRequiredEventArgs.NodeBounds Property

TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgsNodeBounds Property

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<Rectangle> NodeBounds { get; set; }
Public Property NodeBounds As Nullable(Of Rectangle)
    Get
    Set
public:
property Nullable<Rectangle> NodeBounds {
    Nullable<Rectangle> get ();
    void set (Nullable<Rectangle> value);
}
member NodeBounds : Nullable<Rectangle> with get, set

Property Value

Type: NullableRectangle
See Also

Reference

TreeViewDragAndDropManagerDropMarkerNodeBoundsRequiredEventArgs Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.IDragAndDropListener Interface

TreeViewDragAndDropManagerIDragAndDropListener Interface

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDragAndDropListener
Public Interface IDragAndDropListener
public interface class IDragAndDropListener
type IDragAndDropListener =  interface end

The TreeViewDragAndDropManagerIDragAndDropListener type exposes the following members.

Methods
 | Name | Description
Public method | CanDropNodeOnNode |
Public method | DropNodeOnNode |
Top
See Also

Reference

Alternet.Common.Controls.TreeView Namespace


IDragAndDropListener Methods

IDragAndDropListener Methods

The TreeViewDragAndDropManagerIDragAndDropListener type exposes the following members.

Methods
 | Name | Description
Public method | CanDropNodeOnNode |
Public method | DropNodeOnNode |
Top
See Also

Reference

TreeViewDragAndDropManagerIDragAndDropListener Interface
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.IDragAndDropListener.CanDropNodeOnNode Method

TreeViewDragAndDropManagerIDragAndDropListenerCanDropNodeOnNode Method

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanDropNodeOnNode(
    TreeNode draggedNode,
    TreeNode nodeToDropOn
)
Function CanDropNodeOnNode (
    draggedNode As TreeNode,
    nodeToDropOn As TreeNode
) As Boolean
bool CanDropNodeOnNode(
    TreeNode^ draggedNode,
    TreeNode^ nodeToDropOn
)
abstract CanDropNodeOnNode :
        draggedNode : TreeNode *
        nodeToDropOn : TreeNode -> bool

Parameters

draggedNode
Type: System.Windows.FormsTreeNode
nodeToDropOn
Type: System.Windows.FormsTreeNode

Return Value

Type: Boolean
See Also

Reference

TreeViewDragAndDropManagerIDragAndDropListener Interface
Alternet.Common.Controls.TreeView Namespace


TreeViewDragAndDropManager.IDragAndDropListener.DropNodeOnNode Method

TreeViewDragAndDropManagerIDragAndDropListenerDropNodeOnNode Method

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DropNodeOnNode(
    TreeNode draggedNode,
    TreeNode nodeToDropOn
)
Sub DropNodeOnNode (
    draggedNode As TreeNode,
    nodeToDropOn As TreeNode
)
void DropNodeOnNode(
    TreeNode^ draggedNode,
    TreeNode^ nodeToDropOn
)
abstract DropNodeOnNode :
        draggedNode : TreeNode *
        nodeToDropOn : TreeNode -> unit

Parameters

draggedNode
Type: System.Windows.FormsTreeNode
nodeToDropOn
Type: System.Windows.FormsTreeNode
See Also

Reference

TreeViewDragAndDropManagerIDragAndDropListener Interface
Alternet.Common.Controls.TreeView Namespace


TreeViewDropMarker Class

TreeViewDropMarker Class
Inheritance Hierarchy
SystemObject
Alternet.Common.Controls.TreeViewTreeViewDropMarker

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TreeViewDropMarker : IDisposable
Public Class TreeViewDropMarker
    Implements IDisposable
public ref class TreeViewDropMarker : IDisposable
type TreeViewDropMarker =
    class
        interface IDisposable
    end

The TreeViewDropMarker type exposes the following members.

Constructors
 | Name | Description
Public method | TreeViewDropMarker | Initializes a new instance of the TreeViewDropMarker class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TreeViewDropMarker
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | Show |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common.Controls.TreeView Namespace


TreeViewDropMarker Constructor

TreeViewDropMarker Constructor
Initializes a new instance of the TreeViewDropMarker class

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeViewDropMarker()
Public Sub New
public:
TreeViewDropMarker()
new : unit -> TreeViewDropMarker
See Also

Reference

TreeViewDropMarker Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDropMarker Methods

TreeViewDropMarker Methods

The TreeViewDropMarker type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | Show |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TreeViewDropMarker Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDropMarker.Dispose Method

TreeViewDropMarkerDispose Method
Releases all resources used by the TreeViewDropMarker

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TreeViewDropMarker Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDropMarker.Hide Method

TreeViewDropMarkerHide Method

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Hide()
Public Sub Hide
public:
void Hide()
member Hide : unit -> unit
See Also

Reference

TreeViewDropMarker Class
Alternet.Common.Controls.TreeView Namespace


TreeViewDropMarker.Show Method

TreeViewDropMarkerShow Method

Namespace: Alternet.Common.Controls.TreeView
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Show(
    Point markerScreenLocation,
    int width
)
Public Sub Show (
    markerScreenLocation As Point,
    width As Integer
)
public:
void Show(
    Point markerScreenLocation,
    int width
)
member Show :
        markerScreenLocation : Point *
        width : int -> unit

Parameters

markerScreenLocation
Type: System.DrawingPoint
width
Type: SystemInt32
See Also

Reference

TreeViewDropMarker Class
Alternet.Common.Controls.TreeView Namespace


Alternet.Common.DotNet.DefaultAssemblies Namespace

Alternet.Common.DotNet.DefaultAssemblies Namespace
Classes
 | Class | Description
Public class | DefaultAssembliesProviderFactory |
Public class | DotNetCoreReferencesDetector |
Public class | DotNetFrameworkDefaultAssembliesProvider |
Interfaces
 | Interface | Description
Public interface | IDefaultAssembliesProvider |


DefaultAssembliesProviderFactory Class

DefaultAssembliesProviderFactory Class
Inheritance Hierarchy
SystemObject
Alternet.Common.DotNet.DefaultAssembliesDefaultAssembliesProviderFactory

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DefaultAssembliesProviderFactory
Public NotInheritable Class DefaultAssembliesProviderFactory
public ref class DefaultAssembliesProviderFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DefaultAssembliesProviderFactory =  class end

The DefaultAssembliesProviderFactory type exposes the following members.

Methods
Name | Description
CreateDefaultAssembliesProvider |
Top
See Also

Reference

Alternet.Common.DotNet.DefaultAssemblies Namespace


DefaultAssembliesProviderFactory Methods

DefaultAssembliesProviderFactory Methods

The DefaultAssembliesProviderFactory type exposes the following members.

Methods
Name | Description
CreateDefaultAssembliesProvider |
Top
See Also

Reference

DefaultAssembliesProviderFactory Class
Alternet.Common.DotNet.DefaultAssemblies Namespace


DefaultAssembliesProviderFactory.CreateDefaultAssembliesProvider Method

DefaultAssembliesProviderFactoryCreateDefaultAssembliesProvider Method

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDefaultAssembliesProvider CreateDefaultAssembliesProvider()
Public Shared Function CreateDefaultAssembliesProvider As IDefaultAssembliesProvider
public:
static IDefaultAssembliesProvider^ CreateDefaultAssembliesProvider()
static member CreateDefaultAssembliesProvider : unit -> IDefaultAssembliesProvider

Return Value

Type: IDefaultAssembliesProvider
See Also

Reference

DefaultAssembliesProviderFactory Class
Alternet.Common.DotNet.DefaultAssemblies Namespace


DotNetCoreReferencesDetector Class

DotNetCoreReferencesDetector Class
Inheritance Hierarchy
SystemObject
Alternet.Common.DotNet.DefaultAssembliesDotNetCoreReferencesDetector

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DotNetCoreReferencesDetector
Public NotInheritable Class DotNetCoreReferencesDetector
public ref class DotNetCoreReferencesDetector abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DotNetCoreReferencesDetector =  class end

The DotNetCoreReferencesDetector type exposes the following members.

Methods
Name | Description
IsDotNetCoreReference |
ReferencesDotNetCoreRuntime |
Top
See Also

Reference

Alternet.Common.DotNet.DefaultAssemblies Namespace


DotNetCoreReferencesDetector Methods

DotNetCoreReferencesDetector Methods

The DotNetCoreReferencesDetector type exposes the following members.

Methods
Name | Description
IsDotNetCoreReference |
ReferencesDotNetCoreRuntime |
Top
See Also

Reference

DotNetCoreReferencesDetector Class
Alternet.Common.DotNet.DefaultAssemblies Namespace


DotNetCoreReferencesDetector.IsDotNetCoreReference Method

DotNetCoreReferencesDetectorIsDotNetCoreReference Method

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDotNetCoreReference(
    string reference,
    out Version version
)
Public Shared Function IsDotNetCoreReference (
    reference As String,
    <OutAttribute> ByRef version As Version
) As Boolean
public:
static bool IsDotNetCoreReference(
    String^ reference,
    [OutAttribute] Version^% version
)
static member IsDotNetCoreReference :
        reference : string *
        version : Version byref -> bool

Parameters

reference
Type: SystemString
version
Type: SystemVersion

Return Value

Type: Boolean
See Also

Reference

DotNetCoreReferencesDetector Class
Alternet.Common.DotNet.DefaultAssemblies Namespace


DotNetCoreReferencesDetector.ReferencesDotNetCoreRuntime Method

DotNetCoreReferencesDetectorReferencesDotNetCoreRuntime Method

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ReferencesDotNetCoreRuntime(
    IEnumerable<string> references,
    out Version dotNetCoreVersion
)
Public Shared Function ReferencesDotNetCoreRuntime (
    references As IEnumerable(Of String),
    <OutAttribute> ByRef dotNetCoreVersion As Version
) As Boolean
public:
static bool ReferencesDotNetCoreRuntime(
    IEnumerable<String^>^ references,
    [OutAttribute] Version^% dotNetCoreVersion
)
static member ReferencesDotNetCoreRuntime :
        references : IEnumerable<string> *
        dotNetCoreVersion : Version byref -> bool

Parameters

references
Type: System.Collections.GenericIEnumerableString
dotNetCoreVersion
Type: SystemVersion

Return Value

Type: Boolean
See Also

Reference

DotNetCoreReferencesDetector Class
Alternet.Common.DotNet.DefaultAssemblies Namespace


DotNetFrameworkDefaultAssembliesProvider Class

DotNetFrameworkDefaultAssembliesProvider Class
Inheritance Hierarchy
SystemObject
Alternet.Common.DotNet.DefaultAssembliesDotNetFrameworkDefaultAssembliesProvider

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DotNetFrameworkDefaultAssembliesProvider : IDefaultAssembliesProvider
Public Class DotNetFrameworkDefaultAssembliesProvider
    Implements IDefaultAssembliesProvider
public ref class DotNetFrameworkDefaultAssembliesProvider : IDefaultAssembliesProvider
type DotNetFrameworkDefaultAssembliesProvider =
    class
        interface IDefaultAssembliesProvider
    end

The DotNetFrameworkDefaultAssembliesProvider type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetFrameworkDefaultAssembliesProvider | Initializes a new instance of the DotNetFrameworkDefaultAssembliesProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDefaultAssemblies |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common.DotNet.DefaultAssemblies Namespace


DotNetFrameworkDefaultAssembliesProvider Constructor

DotNetFrameworkDefaultAssembliesProvider Constructor
Initializes a new instance of the DotNetFrameworkDefaultAssembliesProvider class

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DotNetFrameworkDefaultAssembliesProvider()
Public Sub New
public:
DotNetFrameworkDefaultAssembliesProvider()
new : unit -> DotNetFrameworkDefaultAssembliesProvider
See Also

Reference

DotNetFrameworkDefaultAssembliesProvider Class
Alternet.Common.DotNet.DefaultAssemblies Namespace


DotNetFrameworkDefaultAssembliesProvider Methods

DotNetFrameworkDefaultAssembliesProvider Methods

The DotNetFrameworkDefaultAssembliesProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDefaultAssemblies |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DotNetFrameworkDefaultAssembliesProvider Class
Alternet.Common.DotNet.DefaultAssemblies Namespace


DotNetFrameworkDefaultAssembliesProvider.GetDefaultAssemblies Method

DotNetFrameworkDefaultAssembliesProviderGetDefaultAssemblies Method

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] GetDefaultAssemblies(
    TechnologyEnvironment technology,
    TargetFramework targetFramework = null,
    bool useRuntimeAssemblies = false
)
Public Function GetDefaultAssemblies (
    technology As TechnologyEnvironment,
    Optional targetFramework As TargetFramework = Nothing,
    Optional useRuntimeAssemblies As Boolean = false
) As String()
public:
virtual array<String^>^ GetDefaultAssemblies(
    TechnologyEnvironment technology,
    TargetFramework^ targetFramework = nullptr,
    bool useRuntimeAssemblies = false
) sealed
abstract GetDefaultAssemblies :
        technology : TechnologyEnvironment *
        ?targetFramework : TargetFramework *
        ?useRuntimeAssemblies : bool
(* Defaults:
        let _targetFramework = defaultArg targetFramework null
        let _useRuntimeAssemblies = defaultArg useRuntimeAssemblies false
*)
-> string[]
override GetDefaultAssemblies :
        technology : TechnologyEnvironment *
        ?targetFramework : TargetFramework *
        ?useRuntimeAssemblies : bool
(* Defaults:
        let _targetFramework = defaultArg targetFramework null
        let _useRuntimeAssemblies = defaultArg useRuntimeAssemblies false
*)
-> string[]

Parameters

technology
Type: Alternet.CommonTechnologyEnvironment
targetFramework (Optional)
Type: Alternet.Common.DotNet.ProjectsTargetFramework
useRuntimeAssemblies (Optional)
Type: SystemBoolean

Return Value

Type: String

Implements

IDefaultAssembliesProviderGetDefaultAssemblies(TechnologyEnvironment, TargetFramework, Boolean)
See Also

Reference

DotNetFrameworkDefaultAssembliesProvider Class
Alternet.Common.DotNet.DefaultAssemblies Namespace


IDefaultAssembliesProvider Interface

IDefaultAssembliesProvider Interface

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDefaultAssembliesProvider
Public Interface IDefaultAssembliesProvider
public interface class IDefaultAssembliesProvider
type IDefaultAssembliesProvider =  interface end

The IDefaultAssembliesProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetDefaultAssemblies |
Top
See Also

Reference

Alternet.Common.DotNet.DefaultAssemblies Namespace


IDefaultAssembliesProvider Methods

IDefaultAssembliesProvider Methods

The IDefaultAssembliesProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetDefaultAssemblies |
Top
See Also

Reference

IDefaultAssembliesProvider Interface
Alternet.Common.DotNet.DefaultAssemblies Namespace


IDefaultAssembliesProvider.GetDefaultAssemblies Method

IDefaultAssembliesProviderGetDefaultAssemblies Method

Namespace: Alternet.Common.DotNet.DefaultAssemblies
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] GetDefaultAssemblies(
    TechnologyEnvironment environment,
    TargetFramework targetFramework = null,
    bool useRuntimeAssemblies = false
)
Function GetDefaultAssemblies (
    environment As TechnologyEnvironment,
    Optional targetFramework As TargetFramework = Nothing,
    Optional useRuntimeAssemblies As Boolean = false
) As String()
array<String^>^ GetDefaultAssemblies(
    TechnologyEnvironment environment,
    TargetFramework^ targetFramework = nullptr,
    bool useRuntimeAssemblies = false
)
abstract GetDefaultAssemblies :
        environment : TechnologyEnvironment *
        ?targetFramework : TargetFramework *
        ?useRuntimeAssemblies : bool
(* Defaults:
        let _targetFramework = defaultArg targetFramework null
        let _useRuntimeAssemblies = defaultArg useRuntimeAssemblies false
*)
-> string[]

Parameters

environment
Type: Alternet.CommonTechnologyEnvironment
targetFramework (Optional)
Type: Alternet.Common.DotNet.ProjectsTargetFramework
useRuntimeAssemblies (Optional)
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

IDefaultAssembliesProvider Interface
Alternet.Common.DotNet.DefaultAssemblies Namespace


Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace

Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace
Classes
 | Class | Description
Public class | DotNetCoreDefaultAssembliesProvider |
Public class | FrameworkReferencedAssembliesService |


DotNetCoreDefaultAssembliesProvider Class

DotNetCoreDefaultAssembliesProvider Class
Inheritance Hierarchy
SystemObject
Alternet.Common.DotNet.DefaultAssemblies.DotNetCoreDotNetCoreDefaultAssembliesProvider

Namespace: Alternet.Common.DotNet.DefaultAssemblies.DotNetCore
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DotNetCoreDefaultAssembliesProvider : IDefaultAssembliesProvider
Public Class DotNetCoreDefaultAssembliesProvider
    Implements IDefaultAssembliesProvider
public ref class DotNetCoreDefaultAssembliesProvider : IDefaultAssembliesProvider
type DotNetCoreDefaultAssembliesProvider =
    class
        interface IDefaultAssembliesProvider
    end

The DotNetCoreDefaultAssembliesProvider type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetCoreDefaultAssembliesProvider | Initializes a new instance of the DotNetCoreDefaultAssembliesProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDefaultAssemblies |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace


DotNetCoreDefaultAssembliesProvider Constructor

DotNetCoreDefaultAssembliesProvider Constructor
Initializes a new instance of the DotNetCoreDefaultAssembliesProvider class

Namespace: Alternet.Common.DotNet.DefaultAssemblies.DotNetCore
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DotNetCoreDefaultAssembliesProvider()
Public Sub New
public:
DotNetCoreDefaultAssembliesProvider()
new : unit -> DotNetCoreDefaultAssembliesProvider
See Also

Reference

DotNetCoreDefaultAssembliesProvider Class
Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace


DotNetCoreDefaultAssembliesProvider Methods

DotNetCoreDefaultAssembliesProvider Methods

The DotNetCoreDefaultAssembliesProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDefaultAssemblies |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DotNetCoreDefaultAssembliesProvider Class
Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace


DotNetCoreDefaultAssembliesProvider.GetDefaultAssemblies Method

DotNetCoreDefaultAssembliesProviderGetDefaultAssemblies Method

Namespace: Alternet.Common.DotNet.DefaultAssemblies.DotNetCore
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] GetDefaultAssemblies(
    TechnologyEnvironment technology,
    TargetFramework targetFramework = null,
    bool useRuntimeAssemblies = false
)
Public Function GetDefaultAssemblies (
    technology As TechnologyEnvironment,
    Optional targetFramework As TargetFramework = Nothing,
    Optional useRuntimeAssemblies As Boolean = false
) As String()
public:
virtual array<String^>^ GetDefaultAssemblies(
    TechnologyEnvironment technology,
    TargetFramework^ targetFramework = nullptr,
    bool useRuntimeAssemblies = false
) sealed
abstract GetDefaultAssemblies :
        technology : TechnologyEnvironment *
        ?targetFramework : TargetFramework *
        ?useRuntimeAssemblies : bool
(* Defaults:
        let _targetFramework = defaultArg targetFramework null
        let _useRuntimeAssemblies = defaultArg useRuntimeAssemblies false
*)
-> string[]
override GetDefaultAssemblies :
        technology : TechnologyEnvironment *
        ?targetFramework : TargetFramework *
        ?useRuntimeAssemblies : bool
(* Defaults:
        let _targetFramework = defaultArg targetFramework null
        let _useRuntimeAssemblies = defaultArg useRuntimeAssemblies false
*)
-> string[]

Parameters

technology
Type: Alternet.CommonTechnologyEnvironment
targetFramework (Optional)
Type: Alternet.Common.DotNet.ProjectsTargetFramework
useRuntimeAssemblies (Optional)
Type: SystemBoolean

Return Value

Type: String

Implements

IDefaultAssembliesProviderGetDefaultAssemblies(TechnologyEnvironment, TargetFramework, Boolean)
See Also

Reference

DotNetCoreDefaultAssembliesProvider Class
Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace


FrameworkReferencedAssembliesService Class

FrameworkReferencedAssembliesService Class
Inheritance Hierarchy
SystemObject
Alternet.Common.DotNet.DefaultAssemblies.DotNetCoreFrameworkReferencedAssembliesService

Namespace: Alternet.Common.DotNet.DefaultAssemblies.DotNetCore
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FrameworkReferencedAssembliesService
Public Class FrameworkReferencedAssembliesService
public ref class FrameworkReferencedAssembliesService
type FrameworkReferencedAssembliesService =  class end

The FrameworkReferencedAssembliesService type exposes the following members.

Constructors
 | Name | Description
Public method | FrameworkReferencedAssembliesService | Initializes a new instance of the FrameworkReferencedAssembliesService class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFrameworkAssemblies |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace


FrameworkReferencedAssembliesService Constructor

FrameworkReferencedAssembliesService Constructor
Initializes a new instance of the FrameworkReferencedAssembliesService class

Namespace: Alternet.Common.DotNet.DefaultAssemblies.DotNetCore
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FrameworkReferencedAssembliesService(
    Version dotNetCoreVersion
)
Public Sub New (
    dotNetCoreVersion As Version
)
public:
FrameworkReferencedAssembliesService(
    Version^ dotNetCoreVersion
)
new :
        dotNetCoreVersion : Version -> FrameworkReferencedAssembliesService

Parameters

dotNetCoreVersion
Type: SystemVersion
See Also

Reference

FrameworkReferencedAssembliesService Class
Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace


FrameworkReferencedAssembliesService Methods

FrameworkReferencedAssembliesService Methods

The FrameworkReferencedAssembliesService type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFrameworkAssemblies |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FrameworkReferencedAssembliesService Class
Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace


FrameworkReferencedAssembliesService.GetFrameworkAssemblies Method

FrameworkReferencedAssembliesServiceGetFrameworkAssemblies Method

Namespace: Alternet.Common.DotNet.DefaultAssemblies.DotNetCore
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyList<AssemblyReference> GetFrameworkAssemblies(
    FrameworkReference frameworkReference
)
Public Function GetFrameworkAssemblies (
    frameworkReference As FrameworkReference
) As IReadOnlyList(Of AssemblyReference)
public:
IReadOnlyList<AssemblyReference^>^ GetFrameworkAssemblies(
    FrameworkReference^ frameworkReference
)
member GetFrameworkAssemblies :
        frameworkReference : FrameworkReference -> IReadOnlyList<AssemblyReference>

Parameters

frameworkReference
Type: Alternet.Common.DotNet.Projects.SdkStyleReferencesFrameworkReference

Return Value

Type: IReadOnlyListAssemblyReference
See Also

Reference

FrameworkReferencedAssembliesService Class
Alternet.Common.DotNet.DefaultAssemblies.DotNetCore Namespace


Alternet.Common.DotNet.Projects Namespace

Alternet.Common.DotNet.Projects Namespace
Classes
 | Class | Description
Public class | TargetFramework |


TargetFramework Class

TargetFramework Class
Inheritance Hierarchy
SystemObject
ValueObjectTargetFramework
Alternet.Common.DotNet.ProjectsTargetFramework

Namespace: Alternet.Common.DotNet.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TargetFramework : ValueObject<TargetFramework>
Public Class TargetFramework
    Inherits ValueObject(Of TargetFramework)
public ref class TargetFramework : public ValueObject<TargetFramework^>
type TargetFramework =
    class
        inherit ValueObject<TargetFramework>
    end

The TargetFramework type exposes the following members.

Constructors
 | Name | Description
Public method | TargetFramework(String) | Initializes a new instance of the TargetFramework class
Public method | TargetFramework(Version, Boolean, String) | Initializes a new instance of the TargetFramework class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
 | CurrentRuntimeFramework |
Public property | IsDotNetCore |
Public property | Moniker |
Public property | OS |
Public property | Version |
Top
See Also

Reference

Alternet.Common.DotNet.Projects Namespace


TargetFramework Constructor

TargetFramework Constructor
Overload List
 | Name | Description
Public method | TargetFramework(String) | Initializes a new instance of the TargetFramework class
Public method | TargetFramework(Version, Boolean, String) | Initializes a new instance of the TargetFramework class
Top
See Also

Reference

TargetFramework Class
Alternet.Common.DotNet.Projects Namespace


TargetFramework Constructor (String)

TargetFramework Constructor (String)
Initializes a new instance of the TargetFramework class

Namespace: Alternet.Common.DotNet.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetFramework(
    string moniker
)
Public Sub New (
    moniker As String
)
public:
TargetFramework(
    String^ moniker
)
new :
        moniker : string -> TargetFramework

Parameters

moniker
Type: SystemString
See Also

Reference

TargetFramework Class
TargetFramework Overload
Alternet.Common.DotNet.Projects Namespace


TargetFramework Constructor (Version, Boolean, String)

TargetFramework Constructor (Version, Boolean, String)
Initializes a new instance of the TargetFramework class

Namespace: Alternet.Common.DotNet.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetFramework(
    Version version,
    bool isDotNetCore,
    string os = null
)
Public Sub New (
    version As Version,
    isDotNetCore As Boolean,
    Optional os As String = Nothing
)
public:
TargetFramework(
    Version^ version,
    bool isDotNetCore,
    String^ os = nullptr
)
new :
        version : Version *
        isDotNetCore : bool *
        ?os : string
(* Defaults:
        let _os = defaultArg os null
*)
-> TargetFramework

Parameters

version
Type: SystemVersion
isDotNetCore
Type: SystemBoolean
os (Optional)
Type: SystemString
See Also

Reference

TargetFramework Class
TargetFramework Overload
Alternet.Common.DotNet.Projects Namespace


TargetFramework Methods

TargetFramework Methods

The TargetFramework type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TargetFramework Class
Alternet.Common.DotNet.Projects Namespace


TargetFramework Properties

TargetFramework Properties

The TargetFramework type exposes the following members.

Properties
 | Name | Description
 | CurrentRuntimeFramework |
Public property | IsDotNetCore |
Public property | Moniker |
Public property | OS |
Public property | Version |
Top
See Also

Reference

TargetFramework Class
Alternet.Common.DotNet.Projects Namespace


TargetFramework.CurrentRuntimeFramework Property

TargetFrameworkCurrentRuntimeFramework Property

Namespace: Alternet.Common.DotNet.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TargetFramework CurrentRuntimeFramework { get; }
Public Shared ReadOnly Property CurrentRuntimeFramework As TargetFramework
    Get
public:
static property TargetFramework^ CurrentRuntimeFramework {
    TargetFramework^ get ();
}
static member CurrentRuntimeFramework : TargetFramework with get

Property Value

Type: TargetFramework
See Also

Reference

TargetFramework Class
Alternet.Common.DotNet.Projects Namespace


TargetFramework.IsDotNetCore Property

TargetFrameworkIsDotNetCore Property

Namespace: Alternet.Common.DotNet.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDotNetCore { get; }
Public ReadOnly Property IsDotNetCore As Boolean
    Get
public:
property bool IsDotNetCore {
    bool get ();
}
member IsDotNetCore : bool with get

Property Value

Type: Boolean
See Also

Reference

TargetFramework Class
Alternet.Common.DotNet.Projects Namespace


TargetFramework.Moniker Property

TargetFrameworkMoniker Property

Namespace: Alternet.Common.DotNet.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Moniker { get; }
Public ReadOnly Property Moniker As String
    Get
public:
property String^ Moniker {
    String^ get ();
}
member Moniker : string with get

Property Value

Type: String
See Also

Reference

TargetFramework Class
Alternet.Common.DotNet.Projects Namespace


TargetFramework.OS Property

TargetFrameworkOS Property

Namespace: Alternet.Common.DotNet.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OS { get; }
Public ReadOnly Property OS As String
    Get
public:
property String^ OS {
    String^ get ();
}
member OS : string with get

Property Value

Type: String
See Also

Reference

TargetFramework Class
Alternet.Common.DotNet.Projects Namespace


TargetFramework.Version Property

TargetFrameworkVersion Property

Namespace: Alternet.Common.DotNet.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Version Version { get; }
Public ReadOnly Property Version As Version
    Get
public:
property Version^ Version {
    Version^ get ();
}
member Version : Version with get

Property Value

Type: Version
See Also

Reference

TargetFramework Class
Alternet.Common.DotNet.Projects Namespace


Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace

Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace
Classes
 | Class | Description
Public class | AssemblyReference |
Public class | FrameworkReference |
Public class | Project |
Public class | ProjectLoader |
Public class | SdkStyleReferencesService |


AssemblyReference Class

AssemblyReference Class
Inheritance Hierarchy
SystemObject
Alternet.Common.DotNet.Projects.SdkStyleReferencesAssemblyReference

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyReference
Public Class AssemblyReference
public ref class AssemblyReference
type AssemblyReference =  class end

The AssemblyReference type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyReference | Initializes a new instance of the AssemblyReference class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FullPath |
Public property | Name |
Top
See Also

Reference

Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


AssemblyReference Constructor

AssemblyReference Constructor
Initializes a new instance of the AssemblyReference class

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AssemblyReference(
    string name,
    string fullPath = null
)
Public Sub New (
    name As String,
    Optional fullPath As String = Nothing
)
public:
AssemblyReference(
    String^ name,
    String^ fullPath = nullptr
)
new :
        name : string *
        ?fullPath : string
(* Defaults:
        let _fullPath = defaultArg fullPath null
*)
-> AssemblyReference

Parameters

name
Type: SystemString
fullPath (Optional)
Type: SystemString
See Also

Reference

AssemblyReference Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


AssemblyReference Methods

AssemblyReference Methods

The AssemblyReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AssemblyReference Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


AssemblyReference Properties

AssemblyReference Properties

The AssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | FullPath |
Public property | Name |
Top
See Also

Reference

AssemblyReference Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


AssemblyReference.FullPath Property

AssemblyReferenceFullPath Property

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get
public:
property String^ FullPath {
    String^ get ();
}
member FullPath : string with get

Property Value

Type: String
See Also

Reference

AssemblyReference Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


AssemblyReference.Name Property

AssemblyReferenceName Property

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

AssemblyReference Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


FrameworkReference Class

FrameworkReference Class
Inheritance Hierarchy
SystemObject
ValueObjectFrameworkReference
Alternet.Common.DotNet.Projects.SdkStyleReferencesFrameworkReference

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FrameworkReference : ValueObject<FrameworkReference>
Public Class FrameworkReference
    Inherits ValueObject(Of FrameworkReference)
public ref class FrameworkReference : public ValueObject<FrameworkReference^>
type FrameworkReference =
    class
        inherit ValueObject<FrameworkReference>
    end

The FrameworkReference type exposes the following members.

Constructors
 | Name | Description
Public method | FrameworkReference | Initializes a new instance of the FrameworkReference class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


FrameworkReference Constructor

FrameworkReference Constructor
Initializes a new instance of the FrameworkReference class

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FrameworkReference(
    string name
)
Public Sub New (
    name As String
)
public:
FrameworkReference(
    String^ name
)
new :
        name : string -> FrameworkReference

Parameters

name
Type: SystemString
See Also

Reference

FrameworkReference Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


FrameworkReference Methods

FrameworkReference Methods

The FrameworkReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FrameworkReference Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


FrameworkReference Properties

FrameworkReference Properties

The FrameworkReference type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

FrameworkReference Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


FrameworkReference.Name Property

FrameworkReferenceName Property

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

FrameworkReference Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Project Class

Project Class
Inheritance Hierarchy
SystemObject
Alternet.Common.DotNet.Projects.SdkStyleReferencesProject

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Project
Public Class Project
public ref class Project
type Project =  class end

The Project type exposes the following members.

Constructors
 | Name | Description
Public method | Project | Initializes a new instance of the Project class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FrameworkReferences |
Public property | Sdk |
Public property | TargetFramework |
Public property | UseWindowsForms |
Public property | UseWpf |
Top
See Also

Reference

Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Project Constructor

Project Constructor
Initializes a new instance of the Project class

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Project(
    string sdk,
    TargetFramework targetFramework,
    bool useWindowsForms,
    bool useWpf,
    IReadOnlyList<string> frameworkReferences
)
Public Sub New (
    sdk As String,
    targetFramework As TargetFramework,
    useWindowsForms As Boolean,
    useWpf As Boolean,
    frameworkReferences As IReadOnlyList(Of String)
)
public:
Project(
    String^ sdk,
    TargetFramework^ targetFramework,
    bool useWindowsForms,
    bool useWpf,
    IReadOnlyList<String^>^ frameworkReferences
)
new :
        sdk : string *
        targetFramework : TargetFramework *
        useWindowsForms : bool *
        useWpf : bool *
        frameworkReferences : IReadOnlyList<string> -> Project

Parameters

sdk
Type: SystemString
targetFramework
Type: Alternet.Common.DotNet.ProjectsTargetFramework
useWindowsForms
Type: SystemBoolean
useWpf
Type: SystemBoolean
frameworkReferences
Type: System.Collections.GenericIReadOnlyListString
See Also

Reference

Project Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Project Methods

Project Methods

The Project type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Project Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Project Properties

Project Properties

The Project type exposes the following members.

Properties
 | Name | Description
Public property | FrameworkReferences |
Public property | Sdk |
Public property | TargetFramework |
Public property | UseWindowsForms |
Public property | UseWpf |
Top
See Also

Reference

Project Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Project.FrameworkReferences Property

ProjectFrameworkReferences Property

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyList<string> FrameworkReferences { get; }
Public ReadOnly Property FrameworkReferences As IReadOnlyList(Of String)
    Get
public:
property IReadOnlyList<String^>^ FrameworkReferences {
    IReadOnlyList<String^>^ get ();
}
member FrameworkReferences : IReadOnlyList<string> with get

Property Value

Type: IReadOnlyListString
See Also

Reference

Project Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Project.Sdk Property

ProjectSdk Property

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Sdk { get; }
Public ReadOnly Property Sdk As String
    Get
public:
property String^ Sdk {
    String^ get ();
}
member Sdk : string with get

Property Value

Type: String
See Also

Reference

Project Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Project.TargetFramework Property

ProjectTargetFramework Property

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetFramework TargetFramework { get; }
Public ReadOnly Property TargetFramework As TargetFramework
    Get
public:
property TargetFramework^ TargetFramework {
    TargetFramework^ get ();
}
member TargetFramework : TargetFramework with get

Property Value

Type: TargetFramework
See Also

Reference

Project Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Project.UseWindowsForms Property

ProjectUseWindowsForms Property

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseWindowsForms { get; }
Public ReadOnly Property UseWindowsForms As Boolean
    Get
public:
property bool UseWindowsForms {
    bool get ();
}
member UseWindowsForms : bool with get

Property Value

Type: Boolean
See Also

Reference

Project Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Project.UseWpf Property

ProjectUseWpf Property

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseWpf { get; }
Public ReadOnly Property UseWpf As Boolean
    Get
public:
property bool UseWpf {
    bool get ();
}
member UseWpf : bool with get

Property Value

Type: Boolean
See Also

Reference

Project Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


ProjectLoader Class

ProjectLoader Class
Inheritance Hierarchy
SystemObject
Alternet.Common.DotNet.Projects.SdkStyleReferencesProjectLoader

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ProjectLoader
Public NotInheritable Class ProjectLoader
public ref class ProjectLoader abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ProjectLoader =  class end

The ProjectLoader type exposes the following members.

Methods
Name | Description
IsSdkStyle |
Load |
Top
See Also

Reference

Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


ProjectLoader Methods

ProjectLoader Methods

The ProjectLoader type exposes the following members.

Methods
Name | Description
IsSdkStyle |
Load |
Top
See Also

Reference

ProjectLoader Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


ProjectLoader.IsSdkStyle Method

ProjectLoaderIsSdkStyle Method

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSdkStyle(
    string projectFileContents
)
Public Shared Function IsSdkStyle (
    projectFileContents As String
) As Boolean
public:
static bool IsSdkStyle(
    String^ projectFileContents
)
static member IsSdkStyle :
        projectFileContents : string -> bool

Parameters

projectFileContents
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ProjectLoader Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


ProjectLoader.Load Method

ProjectLoaderLoad Method

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Project Load(
    string projectFileContents
)
Public Shared Function Load (
    projectFileContents As String
) As Project
public:
static Project^ Load(
    String^ projectFileContents
)
static member Load :
        projectFileContents : string -> Project

Parameters

projectFileContents
Type: SystemString

Return Value

Type: Project
See Also

Reference

ProjectLoader Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


SdkStyleReferencesService Class

SdkStyleReferencesService Class
Inheritance Hierarchy
SystemObject
Alternet.Common.DotNet.Projects.SdkStyleReferencesSdkStyleReferencesService

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SdkStyleReferencesService
Public NotInheritable Class SdkStyleReferencesService
public ref class SdkStyleReferencesService abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SdkStyleReferencesService =  class end

The SdkStyleReferencesService type exposes the following members.

Methods
Name | Description
GetAutoReferences |
GetReferencedFrameworks |
Top
See Also

Reference

Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


SdkStyleReferencesService Methods

SdkStyleReferencesService Methods

The SdkStyleReferencesService type exposes the following members.

Methods
Name | Description
GetAutoReferences |
GetReferencedFrameworks |
Top
See Also

Reference

SdkStyleReferencesService Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


SdkStyleReferencesService.GetAutoReferences Method

SdkStyleReferencesServiceGetAutoReferences Method

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IReadOnlyList<AssemblyReference> GetAutoReferences(
    Project project
)
Public Shared Function GetAutoReferences (
    project As Project
) As IReadOnlyList(Of AssemblyReference)
public:
static IReadOnlyList<AssemblyReference^>^ GetAutoReferences(
    Project^ project
)
static member GetAutoReferences :
        project : Project -> IReadOnlyList<AssemblyReference>

Parameters

project
Type: Alternet.Common.DotNet.Projects.SdkStyleReferencesProject

Return Value

Type: IReadOnlyListAssemblyReference
See Also

Reference

SdkStyleReferencesService Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


SdkStyleReferencesService.GetReferencedFrameworks Method

SdkStyleReferencesServiceGetReferencedFrameworks Method

Namespace: Alternet.Common.DotNet.Projects.SdkStyleReferences
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IReadOnlyList<FrameworkReference> GetReferencedFrameworks(
    Project project
)
Public Shared Function GetReferencedFrameworks (
    project As Project
) As IReadOnlyList(Of FrameworkReference)
public:
static IReadOnlyList<FrameworkReference^>^ GetReferencedFrameworks(
    Project^ project
)
static member GetReferencedFrameworks :
        project : Project -> IReadOnlyList<FrameworkReference>

Parameters

project
Type: Alternet.Common.DotNet.Projects.SdkStyleReferencesProject

Return Value

Type: IReadOnlyListFrameworkReference
See Also

Reference

SdkStyleReferencesService Class
Alternet.Common.DotNet.Projects.SdkStyleReferences Namespace


Alternet.Common.Projects Namespace

Alternet.Common.Projects Namespace
Classes
 | Class | Description
Public class | Project |
Public class | ProjectProjectUserSettings | This class is designed to hold user settings for the project.
Structures
 | Structure | Description
Public structure | ProjectCreationData |


Project Class

Project Class
Inheritance Hierarchy
SystemObject
Alternet.Common.ProjectsProject
Alternet.Common.Projects.DotNetDotNetProject
Alternet.Editor.TypeScriptTSProject

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Project
Public Class Project
public ref class Project
type Project =  class end

The Project type exposes the following members.

Constructors
 | Name | Description
Public method | Project | Initializes a new instance of the Project class
Top
Methods
 | Name | Description
Public method | AddFile | Adds specified code or resource file to the project.
Public method | AllFiles | Gets list of files included in the project.
Public method | BeginUpdate | Prevents project updating until calling EndUpdate method.
Public method | EndUpdate | Re-enables project updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveFile | Removes specified file from the project.
Public method | Reset | Resets Project to the default state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DefaultExtension | Gets a default extension of the project's code files.
Public property | Files | Gets list of files included in the project.
Public property | HasProject | Gets a value indicating whether project contains some data.
Public property | IsFolder | Gets or sets a boolean value indicates whether this Project represents a folder within project collection.
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save.
Public property | ProjectFileName | Gets fully qualified name of the project file.
Public property | ProjectName | Gets or sets project's name.
Public property | Resources | Gets the list of the resources embedded into the project.
Public property | UserSettings | Gets user defined settings for this project.
Top
Events
 | Name | Description
Public event | ProjectModified | Occurs when project content was modified.
Top
See Also

Reference

Alternet.Common.Projects Namespace


Project Constructor

Project Constructor
Initializes a new instance of the Project class

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Project()
Public Sub New
public:
Project()
new : unit -> Project
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project Methods

Project Methods

The Project type exposes the following members.

Methods
 | Name | Description
Public method | AddFile | Adds specified code or resource file to the project.
Public method | AllFiles | Gets list of files included in the project.
Public method | BeginUpdate | Prevents project updating until calling EndUpdate method.
Public method | EndUpdate | Re-enables project updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveFile | Removes specified file from the project.
Public method | Reset | Resets Project to the default state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.AddFile Method

ProjectAddFile Method
Adds specified code or resource file to the project.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddFile(
    string fileName
)
Public Overridable Sub AddFile (
    fileName As String
)
public:
virtual void AddFile(
    String^ fileName
)
abstract AddFile :
        fileName : string -> unit
override AddFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
File to add.
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.AllFiles Method

ProjectAllFiles Method
Gets list of files included in the project.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<string> AllFiles(
    bool includeProject
)
Public Overridable Function AllFiles (
    includeProject As Boolean
) As IList(Of String)
public:
virtual IList<String^>^ AllFiles(
    bool includeProject
)
abstract AllFiles :
        includeProject : bool -> IList<string>
override AllFiles :
        includeProject : bool -> IList<string>

Parameters

includeProject
Type: SystemBoolean
Specifies that result will include project file.

Return Value

Type: IListString
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.BeginUpdate Method

ProjectBeginUpdate Method
Prevents project updating until calling EndUpdate method.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BeginUpdate()
Public Function BeginUpdate As Integer
public:
int BeginUpdate()
member BeginUpdate : unit -> int

Return Value

Type: Int32
Number of project updating locks.
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.EndUpdate Method

ProjectEndUpdate Method
Re-enables project updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndUpdate()
Public Function EndUpdate As Integer
public:
int EndUpdate()
member EndUpdate : unit -> int

Return Value

Type: Int32
Number of project updating locks.
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.RemoveFile Method

ProjectRemoveFile Method
Removes specified file from the project.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveFile(
    string fileName
)
Public Overridable Sub RemoveFile (
    fileName As String
)
public:
virtual void RemoveFile(
    String^ fileName
)
abstract RemoveFile :
        fileName : string -> unit
override RemoveFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
File to remove.
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.Reset Method

ProjectReset Method
Resets Project to the default state.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project Properties

Project Properties

The Project type exposes the following members.

Properties
 | Name | Description
Public property | DefaultExtension | Gets a default extension of the project's code files.
Public property | Files | Gets list of files included in the project.
Public property | HasProject | Gets a value indicating whether project contains some data.
Public property | IsFolder | Gets or sets a boolean value indicates whether this Project represents a folder within project collection.
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save.
Public property | ProjectFileName | Gets fully qualified name of the project file.
Public property | ProjectName | Gets or sets project's name.
Public property | Resources | Gets the list of the resources embedded into the project.
Public property | UserSettings | Gets user defined settings for this project.
Top
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.DefaultExtension Property

ProjectDefaultExtension Property
Gets a default extension of the project's code files.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DefaultExtension { get; }
Public Overridable ReadOnly Property DefaultExtension As String
    Get
public:
virtual property String^ DefaultExtension {
    String^ get ();
}
abstract DefaultExtension : string with get
override DefaultExtension : string with get

Property Value

Type: String
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.Files Property

ProjectFiles Property
Gets list of files included in the project.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Files { get; }
Public ReadOnly Property Files As IList(Of String)
    Get
public:
property IList<String^>^ Files {
    IList<String^>^ get ();
}
member Files : IList<string> with get

Property Value

Type: IListString
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.HasProject Property

ProjectHasProject Property
Gets a value indicating whether project contains some data.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasProject { get; }
Public ReadOnly Property HasProject As Boolean
    Get
public:
property bool HasProject {
    bool get ();
}
member HasProject : bool with get

Property Value

Type: Boolean
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.IsFolder Property

ProjectIsFolder Property
Gets or sets a boolean value indicates whether this Project represents a folder within project collection.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFolder { get; set; }
Public Property IsFolder As Boolean
    Get
    Set
public:
property bool IsFolder {
    bool get ();
    void set (bool value);
}
member IsFolder : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.IsModified Property

ProjectIsModified Property
Gets or sets a value indicating whether project content has been modified since last save.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModified { get; set; }
Public Property IsModified As Boolean
    Get
    Set
public:
property bool IsModified {
    bool get ();
    void set (bool value);
}
member IsModified : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.ProjectFileName Property

ProjectProjectFileName Property
Gets fully qualified name of the project file.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectFileName { get; set; }
Public Property ProjectFileName As String
    Get
    Set
public:
property String^ ProjectFileName {
    String^ get ();
    void set (String^ value);
}
member ProjectFileName : string with get, set

Property Value

Type: String
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.ProjectName Property

ProjectProjectName Property
Gets or sets project's name.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectName { get; set; }
Public Property ProjectName As String
    Get
    Set
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}
member ProjectName : string with get, set

Property Value

Type: String
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.Resources Property

ProjectResources Property
Gets the list of the resources embedded into the project.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Resources { get; }
Public ReadOnly Property Resources As IList(Of String)
    Get
public:
property IList<String^>^ Resources {
    IList<String^>^ get ();
}
member Resources : IList<string> with get

Property Value

Type: IListString
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.UserSettings Property

ProjectUserSettings Property
Gets user defined settings for this project.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectProjectUserSettings UserSettings { get; }
Public ReadOnly Property UserSettings As ProjectProjectUserSettings
    Get
public:
property ProjectProjectUserSettings^ UserSettings {
    ProjectProjectUserSettings^ get ();
}
member UserSettings : ProjectProjectUserSettings with get

Property Value

Type: ProjectProjectUserSettings
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project Events

Project Events

The Project type exposes the following members.

Events
 | Name | Description
Public event | ProjectModified | Occurs when project content was modified.
Top
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.ProjectModified Event

ProjectProjectModified Event
Occurs when project content was modified.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ProjectModified
Public Event ProjectModified As EventHandler
public:
 event EventHandler^ ProjectModified {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ProjectModified : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Project Class
Alternet.Common.Projects Namespace


Project.ProjectUserSettings Class

ProjectProjectUserSettings Class
This class is designed to hold user settings for the project.
Inheritance Hierarchy
SystemObject
Alternet.Common.ProjectsProjectProjectUserSettings

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProjectUserSettings
Public Class ProjectUserSettings
public ref class ProjectUserSettings
type ProjectUserSettings =  class end

The ProjectProjectUserSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ProjectProjectUserSettings | Initializes a new instance of the ProjectProjectUserSettings class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets ProjectUserSettings to the default state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Load | Loads project's settings from specified file. (Defined by DotNetProjectExtension.)
Public Extension Method | Save | Saves project's settings to the file system, if modified. (Defined by DotNetProjectExtension.)
Top
Properties
 | Name | Description
Public property | CommandLineArgs | Gets or sets an array of strings contained the command-line arguments for the project.
Public property | SettingsFileName | Gets name of the file on the disk contained project's settings.
Public property | StartExternalProgram | Gets or sets a value indicating whether some external program should run the project.
Public property | StartProgram | Gets or sets a name of external program used to run project.
Top
See Also

Reference

Alternet.Common.Projects Namespace


Project.ProjectUserSettings Constructor

ProjectProjectUserSettings Constructor
Initializes a new instance of the ProjectProjectUserSettings class

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectUserSettings()
Public Sub New
public:
ProjectUserSettings()
new : unit -> ProjectUserSettings
See Also

Reference

ProjectProjectUserSettings Class
Alternet.Common.Projects Namespace


ProjectUserSettings Methods

ProjectUserSettings Methods

The ProjectProjectUserSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets ProjectUserSettings to the default state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Load | Loads project's settings from specified file. (Defined by DotNetProjectExtension.)
Public Extension Method | Save | Saves project's settings to the file system, if modified. (Defined by DotNetProjectExtension.)
Top
See Also

Reference

ProjectProjectUserSettings Class
Alternet.Common.Projects Namespace


Project.ProjectUserSettings.Reset Method

ProjectProjectUserSettingsReset Method
Resets ProjectUserSettings to the default state.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

ProjectProjectUserSettings Class
Alternet.Common.Projects Namespace


ProjectUserSettings Properties

ProjectUserSettings Properties

The ProjectProjectUserSettings type exposes the following members.

Properties
 | Name | Description
Public property | CommandLineArgs | Gets or sets an array of strings contained the command-line arguments for the project.
Public property | SettingsFileName | Gets name of the file on the disk contained project's settings.
Public property | StartExternalProgram | Gets or sets a value indicating whether some external program should run the project.
Public property | StartProgram | Gets or sets a name of external program used to run project.
Top
See Also

Reference

ProjectProjectUserSettings Class
Alternet.Common.Projects Namespace


Project.ProjectUserSettings.CommandLineArgs Property

ProjectProjectUserSettingsCommandLineArgs Property
Gets or sets an array of strings contained the command-line arguments for the project.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] CommandLineArgs { get; set; }
Public Property CommandLineArgs As String()
    Get
    Set
public:
property array<String^>^ CommandLineArgs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member CommandLineArgs : string[] with get, set

Property Value

Type: String
See Also

Reference

ProjectProjectUserSettings Class
Alternet.Common.Projects Namespace


Project.ProjectUserSettings.SettingsFileName Property

ProjectProjectUserSettingsSettingsFileName Property
Gets name of the file on the disk contained project's settings.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SettingsFileName { get; set; }
Public Property SettingsFileName As String
    Get
    Set
public:
property String^ SettingsFileName {
    String^ get ();
    void set (String^ value);
}
member SettingsFileName : string with get, set

Property Value

Type: String
See Also

Reference

ProjectProjectUserSettings Class
Alternet.Common.Projects Namespace


Project.ProjectUserSettings.StartExternalProgram Property

ProjectProjectUserSettingsStartExternalProgram Property
Gets or sets a value indicating whether some external program should run the project.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StartExternalProgram { get; set; }
Public Property StartExternalProgram As Boolean
    Get
    Set
public:
property bool StartExternalProgram {
    bool get ();
    void set (bool value);
}
member StartExternalProgram : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProjectProjectUserSettings Class
Alternet.Common.Projects Namespace


Project.ProjectUserSettings.StartProgram Property

ProjectProjectUserSettingsStartProgram Property
Gets or sets a name of external program used to run project.

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StartProgram { get; set; }
Public Property StartProgram As String
    Get
    Set
public:
property String^ StartProgram {
    String^ get ();
    void set (String^ value);
}
member StartProgram : string with get, set

Property Value

Type: String
See Also

Reference

ProjectProjectUserSettings Class
Alternet.Common.Projects Namespace


ProjectCreationData Structure

ProjectCreationData Structure

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct ProjectCreationData
Public Structure ProjectCreationData
public value class ProjectCreationData
[<SealedAttribute>]
type ProjectCreationData =  struct end

The ProjectCreationData type exposes the following members.

Constructors
 | Name | Description
Public method | ProjectCreationData | Initializes a new instance of the ProjectCreationData class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Description |
Public field | Language |
Public field | ProjectLocation |
Public field | ProjectName |
Public field | ProjectType |
Public field | TemplatePath |
Top
See Also

Reference

Alternet.Common.Projects Namespace


ProjectCreationData Constructor

ProjectCreationData Constructor
Initializes a new instance of the ProjectCreationData class

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectCreationData(
    string language,
    string projectType,
    string projectName,
    string projectLocation,
    string description,
    string path
)
Public Sub New (
    language As String,
    projectType As String,
    projectName As String,
    projectLocation As String,
    description As String,
    path As String
)
public:
ProjectCreationData(
    String^ language,
    String^ projectType,
    String^ projectName,
    String^ projectLocation,
    String^ description,
    String^ path
)
new :
        language : string *
        projectType : string *
        projectName : string *
        projectLocation : string *
        description : string *
        path : string -> ProjectCreationData

Parameters

language
Type: SystemString
projectType
Type: SystemString
projectName
Type: SystemString
projectLocation
Type: SystemString
description
Type: SystemString
path
Type: SystemString
See Also

Reference

ProjectCreationData Structure
Alternet.Common.Projects Namespace


ProjectCreationData Fields

ProjectCreationData Fields

The ProjectCreationData type exposes the following members.

Fields
 | Name | Description
Public field | Description |
Public field | Language |
Public field | ProjectLocation |
Public field | ProjectName |
Public field | ProjectType |
Public field | TemplatePath |
Top
See Also

Reference

ProjectCreationData Structure
Alternet.Common.Projects Namespace


ProjectCreationData.Description Field

ProjectCreationDataDescription Field

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description
Public Description As String
public:
String^ Description
val mutable Description: string

Field Value

Type: String
See Also

Reference

ProjectCreationData Structure
Alternet.Common.Projects Namespace


ProjectCreationData.Language Field

ProjectCreationDataLanguage Field

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Language
Public Language As String
public:
String^ Language
val mutable Language: string

Field Value

Type: String
See Also

Reference

ProjectCreationData Structure
Alternet.Common.Projects Namespace


ProjectCreationData.ProjectLocation Field

ProjectCreationDataProjectLocation Field

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectLocation
Public ProjectLocation As String
public:
String^ ProjectLocation
val mutable ProjectLocation: string

Field Value

Type: String
See Also

Reference

ProjectCreationData Structure
Alternet.Common.Projects Namespace


ProjectCreationData.ProjectName Field

ProjectCreationDataProjectName Field

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectName
Public ProjectName As String
public:
String^ ProjectName
val mutable ProjectName: string

Field Value

Type: String
See Also

Reference

ProjectCreationData Structure
Alternet.Common.Projects Namespace


ProjectCreationData.ProjectType Field

ProjectCreationDataProjectType Field

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectType
Public ProjectType As String
public:
String^ ProjectType
val mutable ProjectType: string

Field Value

Type: String
See Also

Reference

ProjectCreationData Structure
Alternet.Common.Projects Namespace


ProjectCreationData.TemplatePath Field

ProjectCreationDataTemplatePath Field

Namespace: Alternet.Common.Projects
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TemplatePath
Public TemplatePath As String
public:
String^ TemplatePath
val mutable TemplatePath: string

Field Value

Type: String
See Also

Reference

ProjectCreationData Structure
Alternet.Common.Projects Namespace


ProjectCreationData Methods

ProjectCreationData Methods

The ProjectCreationData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ProjectCreationData Structure
Alternet.Common.Projects Namespace


Alternet.Common.Projects.DotNet Namespace

Alternet.Common.Projects.DotNet Namespace
Classes
 | Class | Description
Public class | DotNetProject | Represents properties and methods used to store and manipulate Visual Studio project content.
Public class | DotNetProjectAssemblyReference | Represents an assembly reference stored in the assembly references list.
Public class | DotNetProjectFileAttribute |
Public class | DotNetProjectFrameworkReference |
Public class | DotNetProjectProjectReference | Represents a project reference stored in the project references list.
Public class | DotNetProjectProjectSolutionSettings | Specifies solution settings related to the project.
Public class | DotNetProjectExtension | Contains extended methods for Alternet.Editor.Common.Project class.
Public class | DotNetSolution | Represents properties and methods used to store and manipulate Visual Studio solution content.
Public class | SolutionExtension | Contains extended methods for Alternet.Editor.Common.Project class.
Enumerations
 | Enumeration | Description
Public enumeration | BuildAction |
Public enumeration | CopyLocal |


BuildAction Enumeration

BuildAction Enumeration

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BuildAction
Public Enumeration BuildAction
public enum class BuildAction
type BuildAction
Members
Member name | Value | Description
None | 0 |
Compile | 1 |
Content | 2 |
ApplicationDefinition | 3 |
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


CopyLocal Enumeration

CopyLocal Enumeration

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CopyLocal
Public Enumeration CopyLocal
public enum class CopyLocal
type CopyLocal
Members
Member name | Value | Description
DoNotCopy | 0 |
CopyAlways | 1 |
CopyIfNewer | 2 |
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


DotNetProject Class

DotNetProject Class
Represents properties and methods used to store and manipulate Visual Studio project content.
Inheritance Hierarchy
SystemObject
Alternet.Common.ProjectsProject
Alternet.Common.Projects.DotNetDotNetProject
Alternet.Editor.IronPythonIronPythonProject

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DotNetProject : Project
Public Class DotNetProject
    Inherits Project
public ref class DotNetProject : public Project
type DotNetProject =
    class
        inherit Project
    end

The DotNetProject type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetProject | Initializes a new instance of the DotNetProject class
Top
Methods
 | Name | Description
Public method | AddFile(String) | Adds specified code or resource file to the project. (Overrides ProjectAddFile(String).)
Public method | AddFile(String, BuildAction, CopyLocal) |
Public method | AddReference | Adds specified reference to the project.
Public method | AllFiles | Gets list of files included in the project. (Overrides ProjectAllFiles(Boolean).)
Public method | BeginUpdate | Prevents project updating until calling EndUpdate method. (Inherited from Project.)
Public method | EndUpdate | Re-enables project updating, that was turn of by calling BeginUpdate method. (Inherited from Project.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFileAttribute |
Public method | GetFileBuildAction |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads project from specified source.
Public method | RemoveFile | Removes specified file from the project. (Overrides ProjectRemoveFile(String).)
Public method | RemoveReference | Removes specified reference from the project.
Public method | Reset | Resets Project to the default state. (Overrides ProjectReset.)
Public method | SetFileAttribute(String, BuildAction) |
Public method | SetFileAttribute(String, CopyLocal) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryResolveAbsolutePath | Try to find real reference name matches the given name.
Public method | TryResolveAbsolutePaths | Try to find real references name matches the given names.
Top
Extension Methods
 | Name | Description
Public Extension Method | Create | Creates new template project and saves it to the file system. (Defined by DotNetProjectExtension.)
Public Extension Method | Load | Loads project from specified source. (Defined by DotNetProjectExtension.)
Public Extension Method | LoadXML(String) | Overloaded. Loads project from specified xml string. (Defined by DotNetProjectExtension.)
Public Extension Method | LoadXML(XmlDocument) | Overloaded. Loads project from specified xml document. (Defined by DotNetProjectExtension.)
Public Extension Method | Save | Saves the project to the file system, if modified. (Defined by DotNetProjectExtension.)
Top
Properties
 | Name | Description
Public property | AssemblyResources | Gets the list of the assembly (with Generator option) resources embedded into the project.
Public property | AutoReferences |
Public property | DefaultExtension | Gets a default extension of the project's code files. (Overrides ProjectDefaultExtension.)
Public property | Files | Gets list of files included in the project. (Inherited from Project.)
Public property | FrameworkReferences |
Public property | HasProject | Gets a value indicating whether project contains some data. (Inherited from Project.)
Public property | ImportedNamespaces | Gets list of imported namespaces used in the project.
Public property | IsFolder | Gets or sets a boolean value indicates whether this Project represents a folder within project collection. (Inherited from Project.)
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save. (Inherited from Project.)
Public property | IsSdkStyle | Gets a value indicating whether this is SDK-style.
Public property | IsWpf | Gets a value indicating whether this is WPF project or not.
Public property | Parent | Gets or sets a Project that is a parent of this project.
Public property | ProjectDependencies | Gets or sets list of project's dependencies.
Public property | ProjectExtension | Gets an extension of the this project.
Public property | ProjectFileName | Gets fully qualified name of the project file. (Inherited from Project.)
Public property | ProjectGuid | Gets or sets's project's GUID.
Public property | ProjectHostGuid | Gets or sets's project's host GUID.
Public property | ProjectName | Gets or sets project's name. (Inherited from Project.)
Public property | ProjectReferences | Gets list of assemblies used in the project.
Public property | References | Gets list of assemblies used in the project.
Public property | RelativePath | Gets or sets a relative file path of this project.
Public property | Resources | Gets the list of the resources embedded into the project. (Inherited from Project.)
Public property | RootNamespace | Gets project's root namespace.
Public property | SolutionSettings | Gets a ProjectSolutionSettings for this project.
Public property | TargetFramework |
Public property | UserSettings | Gets user defined settings for this project. (Inherited from Project.)
Top
Events
 | Name | Description
Public event | ProjectModified | Occurs when project content was modified. (Inherited from Project.)
Top
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


DotNetProject Constructor

DotNetProject Constructor
Initializes a new instance of the DotNetProject class

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DotNetProject()
Public Sub New
public:
DotNetProject()
new : unit -> DotNetProject
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject Methods

DotNetProject Methods

The DotNetProject type exposes the following members.

Methods
 | Name | Description
Public method | AddFile(String) | Adds specified code or resource file to the project. (Overrides ProjectAddFile(String).)
Public method | AddFile(String, BuildAction, CopyLocal) |
Public method | AddReference | Adds specified reference to the project.
Public method | AllFiles | Gets list of files included in the project. (Overrides ProjectAllFiles(Boolean).)
Public method | BeginUpdate | Prevents project updating until calling EndUpdate method. (Inherited from Project.)
Public method | EndUpdate | Re-enables project updating, that was turn of by calling BeginUpdate method. (Inherited from Project.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFileAttribute |
Public method | GetFileBuildAction |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads project from specified source.
Public method | RemoveFile | Removes specified file from the project. (Overrides ProjectRemoveFile(String).)
Public method | RemoveReference | Removes specified reference from the project.
Public method | Reset | Resets Project to the default state. (Overrides ProjectReset.)
Public method | SetFileAttribute(String, BuildAction) |
Public method | SetFileAttribute(String, CopyLocal) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryResolveAbsolutePath | Try to find real reference name matches the given name.
Public method | TryResolveAbsolutePaths | Try to find real references name matches the given names.
Top
Extension Methods
 | Name | Description
Public Extension Method | Create | Creates new template project and saves it to the file system. (Defined by DotNetProjectExtension.)
Public Extension Method | Load | Loads project from specified source. (Defined by DotNetProjectExtension.)
Public Extension Method | LoadXML(String) | Overloaded. Loads project from specified xml string. (Defined by DotNetProjectExtension.)
Public Extension Method | LoadXML(XmlDocument) | Overloaded. Loads project from specified xml document. (Defined by DotNetProjectExtension.)
Public Extension Method | Save | Saves the project to the file system, if modified. (Defined by DotNetProjectExtension.)
Top
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AddFile Method

DotNetProjectAddFile Method
Overload List
 | Name | Description
Public method | AddFile(String) | Adds specified code or resource file to the project. (Overrides ProjectAddFile(String).)
Public method | AddFile(String, BuildAction, CopyLocal) |
Top
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AddFile Method (String)

DotNetProjectAddFile Method (String)
Adds specified code or resource file to the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AddFile(
    string fileName
)
Public Overrides Sub AddFile (
    fileName As String
)
public:
virtual void AddFile(
    String^ fileName
) override
abstract AddFile :
        fileName : string -> unit
override AddFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
File to add.
See Also

Reference

DotNetProject Class
AddFile Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AddFile Method (String, BuildAction, CopyLocal)

DotNetProjectAddFile Method (String, BuildAction, CopyLocal)

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddFile(
    string fileName,
    BuildAction buildAction,
    CopyLocal copyLocal = CopyLocal.DoNotCopy
)
Public Overridable Sub AddFile (
    fileName As String,
    buildAction As BuildAction,
    Optional copyLocal As CopyLocal = CopyLocal.DoNotCopy
)
public:
virtual void AddFile(
    String^ fileName,
    BuildAction buildAction,
    CopyLocal copyLocal = CopyLocal::DoNotCopy
)
abstract AddFile :
        fileName : string *
        buildAction : BuildAction *
        ?copyLocal : CopyLocal
(* Defaults:
        let _copyLocal = defaultArg copyLocal CopyLocal.DoNotCopy
*)
-> unit
override AddFile :
        fileName : string *
        buildAction : BuildAction *
        ?copyLocal : CopyLocal
(* Defaults:
        let _copyLocal = defaultArg copyLocal CopyLocal.DoNotCopy
*)
-> unit

Parameters

fileName
Type: SystemString
buildAction
Type: Alternet.Common.Projects.DotNetBuildAction
copyLocal (Optional)
Type: Alternet.Common.Projects.DotNetCopyLocal
See Also

Reference

DotNetProject Class
AddFile Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AddReference Method

DotNetProjectAddReference Method
Adds specified reference to the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AddReference(
    string reference,
    string hintPath = null
)
Public Function AddReference (
    reference As String,
    Optional hintPath As String = Nothing
) As Boolean
public:
bool AddReference(
    String^ reference,
    String^ hintPath = nullptr
)
member AddReference :
        reference : string *
        ?hintPath : string
(* Defaults:
        let _hintPath = defaultArg hintPath null
*)
-> bool

Parameters

reference
Type: SystemString
Reference to add.
hintPath (Optional)
Type: SystemString
HintPath to add.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AllFiles Method

DotNetProjectAllFiles Method
Gets list of files included in the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IList<string> AllFiles(
    bool includeProject
)
Public Overrides Function AllFiles (
    includeProject As Boolean
) As IList(Of String)
public:
virtual IList<String^>^ AllFiles(
    bool includeProject
) override
abstract AllFiles :
        includeProject : bool -> IList<string>
override AllFiles :
        includeProject : bool -> IList<string>

Parameters

includeProject
Type: SystemBoolean
Specifies that result will include project file.

Return Value

Type: IListString
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.GetFileAttribute Method

DotNetProjectGetFileAttribute Method

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DotNetProjectFileAttribute GetFileAttribute(
    string fileName
)
Public Overridable Function GetFileAttribute (
    fileName As String
) As DotNetProjectFileAttribute
public:
virtual DotNetProjectFileAttribute^ GetFileAttribute(
    String^ fileName
)
abstract GetFileAttribute :
        fileName : string -> DotNetProjectFileAttribute
override GetFileAttribute :
        fileName : string -> DotNetProjectFileAttribute

Parameters

fileName
Type: SystemString

Return Value

Type: DotNetProjectFileAttribute
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.GetFileBuildAction Method

DotNetProjectGetFileBuildAction Method

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetFileBuildAction(
    string fileName
)
Public Overridable Function GetFileBuildAction (
    fileName As String
) As String
public:
virtual String^ GetFileBuildAction(
    String^ fileName
)
abstract GetFileBuildAction :
        fileName : string -> string
override GetFileBuildAction :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.Load Method

DotNetProjectLoad Method
Loads project from specified source.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load(
    string projectFileName
)
Public Overridable Sub Load (
    projectFileName As String
)
public:
virtual void Load(
    String^ projectFileName
)
abstract Load :
        projectFileName : string -> unit
override Load :
        projectFileName : string -> unit

Parameters

projectFileName
Type: SystemString
Path to the project file.
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.RemoveFile Method

DotNetProjectRemoveFile Method
Removes specified file from the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void RemoveFile(
    string fileName
)
Public Overrides Sub RemoveFile (
    fileName As String
)
public:
virtual void RemoveFile(
    String^ fileName
) override
abstract RemoveFile :
        fileName : string -> unit
override RemoveFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
File to remove.
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.RemoveReference Method

DotNetProjectRemoveReference Method
Removes specified reference from the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveReference(
    string reference
)
Public Function RemoveReference (
    reference As String
) As Boolean
public:
bool RemoveReference(
    String^ reference
)
member RemoveReference :
        reference : string -> bool

Parameters

reference
Type: SystemString
Reference to remove.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.Reset Method

DotNetProjectReset Method
Resets Project to the default state.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.SetFileAttribute Method

DotNetProjectSetFileAttribute Method
Overload List
 | Name | Description
Public method | SetFileAttribute(String, BuildAction) |
Public method | SetFileAttribute(String, CopyLocal) |
Top
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.SetFileAttribute Method (String, BuildAction)

DotNetProjectSetFileAttribute Method (String, BuildAction)

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetFileAttribute(
    string fileName,
    BuildAction buildAction
)
Public Overridable Sub SetFileAttribute (
    fileName As String,
    buildAction As BuildAction
)
public:
virtual void SetFileAttribute(
    String^ fileName,
    BuildAction buildAction
)
abstract SetFileAttribute :
        fileName : string *
        buildAction : BuildAction -> unit
override SetFileAttribute :
        fileName : string *
        buildAction : BuildAction -> unit

Parameters

fileName
Type: SystemString
buildAction
Type: Alternet.Common.Projects.DotNetBuildAction
See Also

Reference

DotNetProject Class
SetFileAttribute Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProject.SetFileAttribute Method (String, CopyLocal)

DotNetProjectSetFileAttribute Method (String, CopyLocal)

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetFileAttribute(
    string fileName,
    CopyLocal copyLocal
)
Public Overridable Sub SetFileAttribute (
    fileName As String,
    copyLocal As CopyLocal
)
public:
virtual void SetFileAttribute(
    String^ fileName,
    CopyLocal copyLocal
)
abstract SetFileAttribute :
        fileName : string *
        copyLocal : CopyLocal -> unit
override SetFileAttribute :
        fileName : string *
        copyLocal : CopyLocal -> unit

Parameters

fileName
Type: SystemString
copyLocal
Type: Alternet.Common.Projects.DotNetCopyLocal
See Also

Reference

DotNetProject Class
SetFileAttribute Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProject.TryResolveAbsolutePath Method

DotNetProjectTryResolveAbsolutePath Method
Try to find real reference name matches the given name.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TryResolveAbsolutePath(
    string reference
)
Public Function TryResolveAbsolutePath (
    reference As String
) As String
public:
String^ TryResolveAbsolutePath(
    String^ reference
)
member TryResolveAbsolutePath :
        reference : string -> string

Parameters

reference
Type: SystemString
Short reference name.

Return Value

Type: String
Absolute reference name.
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.TryResolveAbsolutePaths Method

DotNetProjectTryResolveAbsolutePaths Method
Try to find real references name matches the given names.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> TryResolveAbsolutePaths(
    IList<string> references
)
Public Function TryResolveAbsolutePaths (
    references As IList(Of String)
) As IList(Of String)
public:
IList<String^>^ TryResolveAbsolutePaths(
    IList<String^>^ references
)
member TryResolveAbsolutePaths :
        references : IList<string> -> IList<string>

Parameters

references
Type: System.Collections.GenericIListString
Lust of short reference name.

Return Value

Type: IListString
List of absolute reference names.
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject Properties

DotNetProject Properties

The DotNetProject type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyResources | Gets the list of the assembly (with Generator option) resources embedded into the project.
Public property | AutoReferences |
Public property | DefaultExtension | Gets a default extension of the project's code files. (Overrides ProjectDefaultExtension.)
Public property | Files | Gets list of files included in the project. (Inherited from Project.)
Public property | FrameworkReferences |
Public property | HasProject | Gets a value indicating whether project contains some data. (Inherited from Project.)
Public property | ImportedNamespaces | Gets list of imported namespaces used in the project.
Public property | IsFolder | Gets or sets a boolean value indicates whether this Project represents a folder within project collection. (Inherited from Project.)
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save. (Inherited from Project.)
Public property | IsSdkStyle | Gets a value indicating whether this is SDK-style.
Public property | IsWpf | Gets a value indicating whether this is WPF project or not.
Public property | Parent | Gets or sets a Project that is a parent of this project.
Public property | ProjectDependencies | Gets or sets list of project's dependencies.
Public property | ProjectExtension | Gets an extension of the this project.
Public property | ProjectFileName | Gets fully qualified name of the project file. (Inherited from Project.)
Public property | ProjectGuid | Gets or sets's project's GUID.
Public property | ProjectHostGuid | Gets or sets's project's host GUID.
Public property | ProjectName | Gets or sets project's name. (Inherited from Project.)
Public property | ProjectReferences | Gets list of assemblies used in the project.
Public property | References | Gets list of assemblies used in the project.
Public property | RelativePath | Gets or sets a relative file path of this project.
Public property | Resources | Gets the list of the resources embedded into the project. (Inherited from Project.)
Public property | RootNamespace | Gets project's root namespace.
Public property | SolutionSettings | Gets a ProjectSolutionSettings for this project.
Public property | TargetFramework |
Public property | UserSettings | Gets user defined settings for this project. (Inherited from Project.)
Top
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AssemblyResources Property

DotNetProjectAssemblyResources Property
Gets the list of the assembly (with Generator option) resources embedded into the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> AssemblyResources { get; }
Public ReadOnly Property AssemblyResources As IList(Of String)
    Get
public:
property IList<String^>^ AssemblyResources {
    IList<String^>^ get ();
}
member AssemblyResources : IList<string> with get

Property Value

Type: IListString
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AutoReferences Property

DotNetProjectAutoReferences Property

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<DotNetProjectAssemblyReference> AutoReferences { get; }
Public ReadOnly Property AutoReferences As IList(Of DotNetProjectAssemblyReference)
    Get
public:
property IList<DotNetProjectAssemblyReference^>^ AutoReferences {
    IList<DotNetProjectAssemblyReference^>^ get ();
}
member AutoReferences : IList<DotNetProjectAssemblyReference> with get

Property Value

Type: IListDotNetProjectAssemblyReference
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.DefaultExtension Property

DotNetProjectDefaultExtension Property
Gets a default extension of the project's code files.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string DefaultExtension { get; }
Public Overrides ReadOnly Property DefaultExtension As String
    Get
public:
virtual property String^ DefaultExtension {
    String^ get () override;
}
abstract DefaultExtension : string with get
override DefaultExtension : string with get

Property Value

Type: String
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FrameworkReferences Property

DotNetProjectFrameworkReferences Property

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<DotNetProjectFrameworkReference> FrameworkReferences { get; }
Public ReadOnly Property FrameworkReferences As IList(Of DotNetProjectFrameworkReference)
    Get
public:
property IList<DotNetProjectFrameworkReference^>^ FrameworkReferences {
    IList<DotNetProjectFrameworkReference^>^ get ();
}
member FrameworkReferences : IList<DotNetProjectFrameworkReference> with get

Property Value

Type: IListDotNetProjectFrameworkReference
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ImportedNamespaces Property

DotNetProjectImportedNamespaces Property
Gets list of imported namespaces used in the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> ImportedNamespaces { get; }
Public ReadOnly Property ImportedNamespaces As IList(Of String)
    Get
public:
property IList<String^>^ ImportedNamespaces {
    IList<String^>^ get ();
}
member ImportedNamespaces : IList<string> with get

Property Value

Type: IListString
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.IsSdkStyle Property

DotNetProjectIsSdkStyle Property
Gets a value indicating whether this is SDK-style.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSdkStyle { get; set; }
Public Property IsSdkStyle As Boolean
    Get
    Set
public:
property bool IsSdkStyle {
    bool get ();
    void set (bool value);
}
member IsSdkStyle : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.IsWpf Property

DotNetProjectIsWpf Property
Gets a value indicating whether this is WPF project or not.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWpf { get; set; }
Public Property IsWpf As Boolean
    Get
    Set
public:
property bool IsWpf {
    bool get ();
    void set (bool value);
}
member IsWpf : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.Parent Property

DotNetProjectParent Property
Gets or sets a Project that is a parent of this project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DotNetProject Parent { get; set; }
Public Property Parent As DotNetProject
    Get
    Set
public:
property DotNetProject^ Parent {
    DotNetProject^ get ();
    void set (DotNetProject^ value);
}
member Parent : DotNetProject with get, set

Property Value

Type: DotNetProject
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectDependencies Property

DotNetProjectProjectDependencies Property
Gets or sets list of project's dependencies.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<string> ProjectDependencies { get; set; }
Public Property ProjectDependencies As List(Of String)
    Get
    Set
public:
property List<String^>^ ProjectDependencies {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member ProjectDependencies : List<string> with get, set

Property Value

Type: ListString
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectExtension Property

DotNetProjectProjectExtension Property
Gets an extension of the this project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectExtension { get; }
Public ReadOnly Property ProjectExtension As String
    Get
public:
property String^ ProjectExtension {
    String^ get ();
}
member ProjectExtension : string with get

Property Value

Type: String
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectGuid Property

DotNetProjectProjectGuid Property
Gets or sets's project's GUID.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectGuid { get; set; }
Public Property ProjectGuid As String
    Get
    Set
public:
property String^ ProjectGuid {
    String^ get ();
    void set (String^ value);
}
member ProjectGuid : string with get, set

Property Value

Type: String
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectHostGuid Property

DotNetProjectProjectHostGuid Property
Gets or sets's project's host GUID.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectHostGuid { get; }
Public ReadOnly Property ProjectHostGuid As String
    Get
public:
property String^ ProjectHostGuid {
    String^ get ();
}
member ProjectHostGuid : string with get

Property Value

Type: String
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectReferences Property

DotNetProjectProjectReferences Property
Gets list of assemblies used in the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<DotNetProjectProjectReference> ProjectReferences { get; }
Public ReadOnly Property ProjectReferences As IList(Of DotNetProjectProjectReference)
    Get
public:
property IList<DotNetProjectProjectReference^>^ ProjectReferences {
    IList<DotNetProjectProjectReference^>^ get ();
}
member ProjectReferences : IList<DotNetProjectProjectReference> with get

Property Value

Type: IListDotNetProjectProjectReference
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.References Property

DotNetProjectReferences Property
Gets list of assemblies used in the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<DotNetProjectAssemblyReference> References { get; }
Public ReadOnly Property References As IList(Of DotNetProjectAssemblyReference)
    Get
public:
property IList<DotNetProjectAssemblyReference^>^ References {
    IList<DotNetProjectAssemblyReference^>^ get ();
}
member References : IList<DotNetProjectAssemblyReference> with get

Property Value

Type: IListDotNetProjectAssemblyReference
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.RelativePath Property

DotNetProjectRelativePath Property
Gets or sets a relative file path of this project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RelativePath { get; set; }
Public Property RelativePath As String
    Get
    Set
public:
property String^ RelativePath {
    String^ get ();
    void set (String^ value);
}
member RelativePath : string with get, set

Property Value

Type: String
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.RootNamespace Property

DotNetProjectRootNamespace Property
Gets project's root namespace.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RootNamespace { get; set; }
Public Property RootNamespace As String
    Get
    Set
public:
property String^ RootNamespace {
    String^ get ();
    void set (String^ value);
}
member RootNamespace : string with get, set

Property Value

Type: String
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.SolutionSettings Property

DotNetProjectSolutionSettings Property
Gets a ProjectSolutionSettings for this project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DotNetProjectProjectSolutionSettings SolutionSettings { get; }
Public ReadOnly Property SolutionSettings As DotNetProjectProjectSolutionSettings
    Get
public:
property DotNetProjectProjectSolutionSettings^ SolutionSettings {
    DotNetProjectProjectSolutionSettings^ get ();
}
member SolutionSettings : DotNetProjectProjectSolutionSettings with get

Property Value

Type: DotNetProjectProjectSolutionSettings
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.TargetFramework Property

DotNetProjectTargetFramework Property

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetFramework TargetFramework { get; set; }
Public Property TargetFramework As TargetFramework
    Get
    Set
public:
property TargetFramework^ TargetFramework {
    TargetFramework^ get ();
    void set (TargetFramework^ value);
}
member TargetFramework : TargetFramework with get, set

Property Value

Type: TargetFramework
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject Events

DotNetProject Events

The DotNetProject type exposes the following members.

Events
 | Name | Description
Public event | ProjectModified | Occurs when project content was modified. (Inherited from Project.)
Top
See Also

Reference

DotNetProject Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AssemblyReference Class

DotNetProjectAssemblyReference Class
Represents an assembly reference stored in the assembly references list.
Inheritance Hierarchy
SystemObject
Alternet.Common.Projects.DotNetDotNetProjectAssemblyReference

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyReference
Public Class AssemblyReference
public ref class AssemblyReference
type AssemblyReference =  class end

The DotNetProjectAssemblyReference type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetProjectAssemblyReference | Initializes a new instance of the DotNetProjectAssemblyReference class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FullName | Gets or sets a full name of the assembly reference.
Public property | HintPath | Gets or sets a Hint path of the assembly reference.
Public property | Name | Gets or sets a name of the assembly reference.
Top
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


DotNetProject.AssemblyReference Constructor

DotNetProjectAssemblyReference Constructor
Initializes a new instance of the DotNetProjectAssemblyReference class

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AssemblyReference()
Public Sub New
public:
AssemblyReference()
new : unit -> AssemblyReference
See Also

Reference

DotNetProjectAssemblyReference Class
Alternet.Common.Projects.DotNet Namespace


AssemblyReference Methods

AssemblyReference Methods

The DotNetProjectAssemblyReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DotNetProjectAssemblyReference Class
Alternet.Common.Projects.DotNet Namespace


AssemblyReference Properties

AssemblyReference Properties

The DotNetProjectAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets or sets a full name of the assembly reference.
Public property | HintPath | Gets or sets a Hint path of the assembly reference.
Public property | Name | Gets or sets a name of the assembly reference.
Top
See Also

Reference

DotNetProjectAssemblyReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AssemblyReference.FullName Property

DotNetProjectAssemblyReferenceFullName Property
Gets or sets a full name of the assembly reference.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}
member FullName : string with get, set

Property Value

Type: String
See Also

Reference

DotNetProjectAssemblyReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AssemblyReference.HintPath Property

DotNetProjectAssemblyReferenceHintPath Property
Gets or sets a Hint path of the assembly reference.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string HintPath { get; set; }
Public Property HintPath As String
    Get
    Set
public:
property String^ HintPath {
    String^ get ();
    void set (String^ value);
}
member HintPath : string with get, set

Property Value

Type: String
See Also

Reference

DotNetProjectAssemblyReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.AssemblyReference.Name Property

DotNetProjectAssemblyReferenceName Property
Gets or sets a name of the assembly reference.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

DotNetProjectAssemblyReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FileAttribute Class

DotNetProjectFileAttribute Class
Inheritance Hierarchy
SystemObject
Alternet.Common.Projects.DotNetDotNetProjectFileAttribute

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FileAttribute
Public Class FileAttribute
public ref class FileAttribute
type FileAttribute =  class end

The DotNetProjectFileAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetProjectFileAttribute | Initializes a new instance of the DotNetProjectFileAttribute class
Public method | DotNetProjectFileAttribute(BuildAction, CopyLocal) | Initializes a new instance of the DotNetProjectFileAttribute class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnChanged | Raises the Changed event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BuildAction |
Public property | CopyLocal |
Top
Events
 | Name | Description
Public event | Changed |
Top
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


FileAttribute Constructor

FileAttribute Constructor
Overload List
 | Name | Description
Public method | DotNetProjectFileAttribute | Initializes a new instance of the DotNetProjectFileAttribute class
Public method | DotNetProjectFileAttribute(BuildAction, CopyLocal) | Initializes a new instance of the DotNetProjectFileAttribute class
Top
See Also

Reference

DotNetProjectFileAttribute Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FileAttribute Constructor

DotNetProjectFileAttribute Constructor
Initializes a new instance of the DotNetProjectFileAttribute class

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FileAttribute()
Public Sub New
public:
FileAttribute()
new : unit -> FileAttribute
See Also

Reference

DotNetProjectFileAttribute Class
DotNetProjectFileAttribute Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FileAttribute Constructor (BuildAction, CopyLocal)

DotNetProjectFileAttribute Constructor (BuildAction, CopyLocal)
Initializes a new instance of the DotNetProjectFileAttribute class

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FileAttribute(
    BuildAction buildAction,
    CopyLocal copyLocal
)
Public Sub New (
    buildAction As BuildAction,
    copyLocal As CopyLocal
)
public:
FileAttribute(
    BuildAction buildAction,
    CopyLocal copyLocal
)
new :
        buildAction : BuildAction *
        copyLocal : CopyLocal -> FileAttribute

Parameters

buildAction
Type: Alternet.Common.Projects.DotNetBuildAction
copyLocal
Type: Alternet.Common.Projects.DotNetCopyLocal
See Also

Reference

DotNetProjectFileAttribute Class
DotNetProjectFileAttribute Overload
Alternet.Common.Projects.DotNet Namespace


FileAttribute Methods

FileAttribute Methods

The DotNetProjectFileAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnChanged | Raises the Changed event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DotNetProjectFileAttribute Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FileAttribute.OnChanged Method

DotNetProjectFileAttributeOnChanged Method
Raises the Changed event.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnChanged(
    EventArgs args
)
Public Overridable Sub OnChanged (
    args As EventArgs
)
public:
virtual void OnChanged(
    EventArgs^ args
)
abstract OnChanged :
        args : EventArgs -> unit
override OnChanged :
        args : EventArgs -> unit

Parameters

args
Type: SystemEventArgs
The EventArgs that contains data to this event.
See Also

Reference

DotNetProjectFileAttribute Class
Alternet.Common.Projects.DotNet Namespace


FileAttribute Properties

FileAttribute Properties

The DotNetProjectFileAttribute type exposes the following members.

Properties
 | Name | Description
Public property | BuildAction |
Public property | CopyLocal |
Top
See Also

Reference

DotNetProjectFileAttribute Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FileAttribute.BuildAction Property

DotNetProjectFileAttributeBuildAction Property

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BuildAction BuildAction { get; set; }
Public Property BuildAction As BuildAction
    Get
    Set
public:
property BuildAction BuildAction {
    BuildAction get ();
    void set (BuildAction value);
}
member BuildAction : BuildAction with get, set

Property Value

Type: BuildAction
See Also

Reference

DotNetProjectFileAttribute Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FileAttribute.CopyLocal Property

DotNetProjectFileAttributeCopyLocal Property

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CopyLocal CopyLocal { get; set; }
Public Property CopyLocal As CopyLocal
    Get
    Set
public:
property CopyLocal CopyLocal {
    CopyLocal get ();
    void set (CopyLocal value);
}
member CopyLocal : CopyLocal with get, set

Property Value

Type: CopyLocal
See Also

Reference

DotNetProjectFileAttribute Class
Alternet.Common.Projects.DotNet Namespace


FileAttribute Events

FileAttribute Events

The DotNetProjectFileAttribute type exposes the following members.

Events
 | Name | Description
Public event | Changed |
Top
See Also

Reference

DotNetProjectFileAttribute Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FileAttribute.Changed Event

DotNetProjectFileAttributeChanged Event

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Changed
Public Event Changed As EventHandler
public:
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Changed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

DotNetProjectFileAttribute Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FrameworkReference Class

DotNetProjectFrameworkReference Class
Inheritance Hierarchy
SystemObject
Alternet.Common.Projects.DotNetDotNetProjectFrameworkReference

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FrameworkReference
Public Class FrameworkReference
public ref class FrameworkReference
type FrameworkReference =  class end

The DotNetProjectFrameworkReference type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetProjectFrameworkReference | Initializes a new instance of the DotNetProjectFrameworkReference class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Assemblies |
Public property | Name |
Top
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


DotNetProject.FrameworkReference Constructor

DotNetProjectFrameworkReference Constructor
Initializes a new instance of the DotNetProjectFrameworkReference class

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FrameworkReference(
    string name,
    IEnumerable<DotNetProjectAssemblyReference> assemblies
)
Public Sub New (
    name As String,
    assemblies As IEnumerable(Of DotNetProjectAssemblyReference)
)
public:
FrameworkReference(
    String^ name,
    IEnumerable<DotNetProjectAssemblyReference^>^ assemblies
)
new :
        name : string *
        assemblies : IEnumerable<DotNetProjectAssemblyReference> -> FrameworkReference

Parameters

name
Type: SystemString
assemblies
Type: System.Collections.GenericIEnumerableDotNetProjectAssemblyReference
See Also

Reference

DotNetProjectFrameworkReference Class
Alternet.Common.Projects.DotNet Namespace


FrameworkReference Methods

FrameworkReference Methods

The DotNetProjectFrameworkReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DotNetProjectFrameworkReference Class
Alternet.Common.Projects.DotNet Namespace


FrameworkReference Properties

FrameworkReference Properties

The DotNetProjectFrameworkReference type exposes the following members.

Properties
 | Name | Description
Public property | Assemblies |
Public property | Name |
Top
See Also

Reference

DotNetProjectFrameworkReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FrameworkReference.Assemblies Property

DotNetProjectFrameworkReferenceAssemblies Property

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyList<DotNetProjectAssemblyReference> Assemblies { get; }
Public ReadOnly Property Assemblies As IReadOnlyList(Of DotNetProjectAssemblyReference)
    Get
public:
property IReadOnlyList<DotNetProjectAssemblyReference^>^ Assemblies {
    IReadOnlyList<DotNetProjectAssemblyReference^>^ get ();
}
member Assemblies : IReadOnlyList<DotNetProjectAssemblyReference> with get

Property Value

Type: IReadOnlyListDotNetProjectAssemblyReference
See Also

Reference

DotNetProjectFrameworkReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.FrameworkReference.Name Property

DotNetProjectFrameworkReferenceName Property

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

DotNetProjectFrameworkReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectReference Class

DotNetProjectProjectReference Class
Represents a project reference stored in the project references list.
Inheritance Hierarchy
SystemObject
Alternet.Common.Projects.DotNetDotNetProjectProjectReference

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProjectReference
Public Class ProjectReference
public ref class ProjectReference
type ProjectReference =  class end

The DotNetProjectProjectReference type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetProjectProjectReference(String) | Initializes a new instance of the ProjectReference class with specified name.
Public method | DotNetProjectProjectReference(String, String, String) | Initializes a new instance of the ProjectReference class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ProjectName | Gets or sets name of the project.
Top
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


ProjectReference Constructor

ProjectReference Constructor
Overload List
 | Name | Description
Public method | DotNetProjectProjectReference(String) | Initializes a new instance of the ProjectReference class with specified name.
Public method | DotNetProjectProjectReference(String, String, String) | Initializes a new instance of the ProjectReference class with specified parameters.
Top
See Also

Reference

DotNetProjectProjectReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectReference Constructor (String)

DotNetProjectProjectReference Constructor (String)
Initializes a new instance of the ProjectReference class with specified name.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectReference(
    string name
)
Public Sub New (
    name As String
)
public:
ProjectReference(
    String^ name
)
new :
        name : string -> ProjectReference

Parameters

name
Type: SystemString
Name of the project.
See Also

Reference

DotNetProjectProjectReference Class
DotNetProjectProjectReference Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectReference Constructor (String, String, String)

DotNetProjectProjectReference Constructor (String, String, String)
Initializes a new instance of the ProjectReference class with specified parameters.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectReference(
    string name,
    string path,
    string guid
)
Public Sub New (
    name As String,
    path As String,
    guid As String
)
public:
ProjectReference(
    String^ name,
    String^ path,
    String^ guid
)
new :
        name : string *
        path : string *
        guid : string -> ProjectReference

Parameters

name
Type: SystemString
Name of the project.
path
Type: SystemString
Path of the project.
guid
Type: SystemString
GUID of the project.
See Also

Reference

DotNetProjectProjectReference Class
DotNetProjectProjectReference Overload
Alternet.Common.Projects.DotNet Namespace


ProjectReference Methods

ProjectReference Methods

The DotNetProjectProjectReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DotNetProjectProjectReference Class
Alternet.Common.Projects.DotNet Namespace


ProjectReference Properties

ProjectReference Properties

The DotNetProjectProjectReference type exposes the following members.

Properties
 | Name | Description
Public property | ProjectName | Gets or sets name of the project.
Top
See Also

Reference

DotNetProjectProjectReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectReference.ProjectName Property

DotNetProjectProjectReferenceProjectName Property
Gets or sets name of the project.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectName { get; set; }
Public Property ProjectName As String
    Get
    Set
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}
member ProjectName : string with get, set

Property Value

Type: String
See Also

Reference

DotNetProjectProjectReference Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectSolutionSettings Class

DotNetProjectProjectSolutionSettings Class
Specifies solution settings related to the project.
Inheritance Hierarchy
SystemObject
Alternet.Common.Projects.DotNetDotNetProjectProjectSolutionSettings

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProjectSolutionSettings
Public Class ProjectSolutionSettings
public ref class ProjectSolutionSettings
type ProjectSolutionSettings =  class end

The DotNetProjectProjectSolutionSettings type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetProjectProjectSolutionSettings | Initializes a new instance of the DotNetProjectProjectSolutionSettings class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Nodes | Gets or sets list of nested projects.
Public property | SolutionBuildProject | Gets or sets list of boolean values indicates whether the project should be built.
Public property | SolutionConfigurations | Gets or sets list of solution configurations.
Top
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectSolutionSettings Constructor

DotNetProjectProjectSolutionSettings Constructor
Initializes a new instance of the DotNetProjectProjectSolutionSettings class

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectSolutionSettings()
Public Sub New
public:
ProjectSolutionSettings()
new : unit -> ProjectSolutionSettings
See Also

Reference

DotNetProjectProjectSolutionSettings Class
Alternet.Common.Projects.DotNet Namespace


ProjectSolutionSettings Methods

ProjectSolutionSettings Methods

The DotNetProjectProjectSolutionSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DotNetProjectProjectSolutionSettings Class
Alternet.Common.Projects.DotNet Namespace


ProjectSolutionSettings Properties

ProjectSolutionSettings Properties

The DotNetProjectProjectSolutionSettings type exposes the following members.

Properties
 | Name | Description
Public property | Nodes | Gets or sets list of nested projects.
Public property | SolutionBuildProject | Gets or sets list of boolean values indicates whether the project should be built.
Public property | SolutionConfigurations | Gets or sets list of solution configurations.
Top
See Also

Reference

DotNetProjectProjectSolutionSettings Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectSolutionSettings.Nodes Property

DotNetProjectProjectSolutionSettingsNodes Property
Gets or sets list of nested projects.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<DotNetProject> Nodes { get; set; }
Public Property Nodes As List(Of DotNetProject)
    Get
    Set
public:
property List<DotNetProject^>^ Nodes {
    List<DotNetProject^>^ get ();
    void set (List<DotNetProject^>^ value);
}
member Nodes : List<DotNetProject> with get, set

Property Value

Type: ListDotNetProject
See Also

Reference

DotNetProjectProjectSolutionSettings Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectSolutionSettings.SolutionBuildProject Property

DotNetProjectProjectSolutionSettingsSolutionBuildProject Property
Gets or sets list of boolean values indicates whether the project should be built.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<bool> SolutionBuildProject { get; set; }
Public Property SolutionBuildProject As List(Of Boolean)
    Get
    Set
public:
property List<bool>^ SolutionBuildProject {
    List<bool>^ get ();
    void set (List<bool>^ value);
}
member SolutionBuildProject : List<bool> with get, set

Property Value

Type: ListBoolean
See Also

Reference

DotNetProjectProjectSolutionSettings Class
Alternet.Common.Projects.DotNet Namespace


DotNetProject.ProjectSolutionSettings.SolutionConfigurations Property

DotNetProjectProjectSolutionSettingsSolutionConfigurations Property
Gets or sets list of solution configurations.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<string> SolutionConfigurations { get; set; }
Public Property SolutionConfigurations As List(Of String)
    Get
    Set
public:
property List<String^>^ SolutionConfigurations {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member SolutionConfigurations : List<string> with get, set

Property Value

Type: ListString
See Also

Reference

DotNetProjectProjectSolutionSettings Class
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension Class

DotNetProjectExtension Class
Contains extended methods for Alternet.Editor.Common.Project class.
Inheritance Hierarchy
SystemObject
Alternet.Common.Projects.DotNetDotNetProjectExtension

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DotNetProjectExtension
<ExtensionAttribute>
Public NotInheritable Class DotNetProjectExtension
[ExtensionAttribute]
public ref class DotNetProjectExtension abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type DotNetProjectExtension =  class end

The DotNetProjectExtension type exposes the following members.

Methods
Name | Description
Create | Creates new template project and saves it to the file system.
Load(ProjectProjectUserSettings, String) | Loads project's settings from specified file.
Load(DotNetProject, String, String) | Loads project from specified source.
LoadXML(DotNetProject, String) | Loads project from specified xml string.
LoadXML(DotNetProject, XmlDocument) | Loads project from specified xml document.
ResolvePath |
Save(DotNetProject) | Saves the project to the file system, if modified.
Save(ProjectProjectUserSettings) | Saves project's settings to the file system, if modified.
Top
Properties
Name | Description
TargetFramework |
Top
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension Methods

DotNetProjectExtension Methods

The DotNetProjectExtension type exposes the following members.

Methods
Name | Description
Create | Creates new template project and saves it to the file system.
Load(ProjectProjectUserSettings, String) | Loads project's settings from specified file.
Load(DotNetProject, String, String) | Loads project from specified source.
LoadXML(DotNetProject, String) | Loads project from specified xml string.
LoadXML(DotNetProject, XmlDocument) | Loads project from specified xml document.
ResolvePath |
Save(DotNetProject) | Saves the project to the file system, if modified.
Save(ProjectProjectUserSettings) | Saves project's settings to the file system, if modified.
Top
See Also

Reference

DotNetProjectExtension Class
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.Create Method

DotNetProjectExtensionCreate Method
Creates new template project and saves it to the file system.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Create(
    this DotNetProject project,
    ProjectCreationData projectData,
    string basePath
)
<ExtensionAttribute>
Public Shared Function Create (
    project As DotNetProject,
    projectData As ProjectCreationData,
    basePath As String
) As String
public:
[ExtensionAttribute]
static String^ Create(
    DotNetProject^ project,
    ProjectCreationData projectData,
    String^ basePath
)
[<ExtensionAttribute>]
static member Create :
        project : DotNetProject *
        projectData : ProjectCreationData *
        basePath : string -> string

Parameters

project
Type: Alternet.Common.Projects.DotNetDotNetProject
Project to load.
projectData
Type: Alternet.Common.ProjectsProjectCreationData
Data of the project.
basePath
Type: SystemString
Relative path to the template project file.

Return Value

Type: String
Full project name.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DotNetProject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetProjectExtension Class
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.Load Method

DotNetProjectExtensionLoad Method
Overload List
Name | Description
Load(ProjectProjectUserSettings, String) | Loads project's settings from specified file.
Load(DotNetProject, String, String) | Loads project from specified source.
Top
See Also

Reference

DotNetProjectExtension Class
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.Load Method (Project.ProjectUserSettings, String)

DotNetProjectExtensionLoad Method (ProjectProjectUserSettings, String)
Loads project's settings from specified file.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Load(
    this ProjectProjectUserSettings settings,
    string settingsFileName
)
<ExtensionAttribute>
Public Shared Sub Load (
    settings As ProjectProjectUserSettings,
    settingsFileName As String
)
public:
[ExtensionAttribute]
static void Load(
    ProjectProjectUserSettings^ settings,
    String^ settingsFileName
)
[<ExtensionAttribute>]
static member Load :
        settings : ProjectProjectUserSettings *
        settingsFileName : string -> unit

Parameters

settings
Type: Alternet.Common.ProjectsProjectProjectUserSettings
Project settings to load.
settingsFileName
Type: SystemString
Name of file contained project settings.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProjectProjectUserSettings. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetProjectExtension Class
Load Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.Load Method (DotNetProject, String, String)

DotNetProjectExtensionLoad Method (DotNetProject, String, String)
Loads project from specified source.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Load(
    this DotNetProject project,
    string projectFileName,
    string projectName
)
<ExtensionAttribute>
Public Shared Sub Load (
    project As DotNetProject,
    projectFileName As String,
    projectName As String
)
public:
[ExtensionAttribute]
static void Load(
    DotNetProject^ project,
    String^ projectFileName,
    String^ projectName
)
[<ExtensionAttribute>]
static member Load :
        project : DotNetProject *
        projectFileName : string *
        projectName : string -> unit

Parameters

project
Type: Alternet.Common.Projects.DotNetDotNetProject
Project to load.
projectFileName
Type: SystemString
Path to the project file.
projectName
Type: SystemString
Project name.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DotNetProject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetProjectExtension Class
Load Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.LoadXML Method

DotNetProjectExtensionLoadXML Method
Overload List
Name | Description
LoadXML(DotNetProject, String) | Loads project from specified xml string.
LoadXML(DotNetProject, XmlDocument) | Loads project from specified xml document.
Top
See Also

Reference

DotNetProjectExtension Class
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.LoadXML Method (DotNetProject, String)

DotNetProjectExtensionLoadXML Method (DotNetProject, String)
Loads project from specified xml string.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void LoadXML(
    this DotNetProject project,
    string xml
)
<ExtensionAttribute>
Public Shared Sub LoadXML (
    project As DotNetProject,
    xml As String
)
public:
[ExtensionAttribute]
static void LoadXML(
    DotNetProject^ project,
    String^ xml
)
[<ExtensionAttribute>]
static member LoadXML :
        project : DotNetProject *
        xml : string -> unit

Parameters

project
Type: Alternet.Common.Projects.DotNetDotNetProject
Project to load.
xml
Type: SystemString
Xml string with project content.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DotNetProject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetProjectExtension Class
LoadXML Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.LoadXML Method (DotNetProject, XmlDocument)

DotNetProjectExtensionLoadXML Method (DotNetProject, XmlDocument)
Loads project from specified xml document.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void LoadXML(
    this DotNetProject project,
    XmlDocument document
)
<ExtensionAttribute>
Public Shared Sub LoadXML (
    project As DotNetProject,
    document As XmlDocument
)
public:
[ExtensionAttribute]
static void LoadXML(
    DotNetProject^ project,
    XmlDocument^ document
)
[<ExtensionAttribute>]
static member LoadXML :
        project : DotNetProject *
        document : XmlDocument -> unit

Parameters

project
Type: Alternet.Common.Projects.DotNetDotNetProject
Project to load.
document
Type: System.XmlXmlDocument
Xml document with project content.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DotNetProject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetProjectExtension Class
LoadXML Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.ResolvePath Method

DotNetProjectExtensionResolvePath Method

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ResolvePath(
    DotNetProject project,
    string reference,
    out string path
)
Public Shared Function ResolvePath (
    project As DotNetProject,
    reference As String,
    <OutAttribute> ByRef path As String
) As Boolean
public:
static bool ResolvePath(
    DotNetProject^ project,
    String^ reference,
    [OutAttribute] String^% path
)
static member ResolvePath :
        project : DotNetProject *
        reference : string *
        path : string byref -> bool

Parameters

project
Type: Alternet.Common.Projects.DotNetDotNetProject
reference
Type: SystemString
path
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

DotNetProjectExtension Class
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.Save Method

DotNetProjectExtensionSave Method
Overload List
Name | Description
Save(DotNetProject) | Saves the project to the file system, if modified.
Save(ProjectProjectUserSettings) | Saves project's settings to the file system, if modified.
Top
See Also

Reference

DotNetProjectExtension Class
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.Save Method (DotNetProject)

DotNetProjectExtensionSave Method (DotNetProject)
Saves the project to the file system, if modified.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Save(
    this DotNetProject project
)
<ExtensionAttribute>
Public Shared Sub Save (
    project As DotNetProject
)
public:
[ExtensionAttribute]
static void Save(
    DotNetProject^ project
)
[<ExtensionAttribute>]
static member Save :
        project : DotNetProject -> unit

Parameters

project
Type: Alternet.Common.Projects.DotNetDotNetProject
Project to save.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DotNetProject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetProjectExtension Class
Save Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.Save Method (Project.ProjectUserSettings)

DotNetProjectExtensionSave Method (ProjectProjectUserSettings)
Saves project's settings to the file system, if modified.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Save(
    this ProjectProjectUserSettings settings
)
<ExtensionAttribute>
Public Shared Sub Save (
    settings As ProjectProjectUserSettings
)
public:
[ExtensionAttribute]
static void Save(
    ProjectProjectUserSettings^ settings
)
[<ExtensionAttribute>]
static member Save :
        settings : ProjectProjectUserSettings -> unit

Parameters

settings
Type: Alternet.Common.ProjectsProjectProjectUserSettings

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ProjectProjectUserSettings. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetProjectExtension Class
Save Overload
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension Properties

DotNetProjectExtension Properties

The DotNetProjectExtension type exposes the following members.

Properties
Name | Description
TargetFramework |
Top
See Also

Reference

DotNetProjectExtension Class
Alternet.Common.Projects.DotNet Namespace


DotNetProjectExtension.TargetFramework Property

DotNetProjectExtensionTargetFramework Property

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TargetFramework { get; }
Public Shared ReadOnly Property TargetFramework As String
    Get
public:
static property String^ TargetFramework {
    String^ get ();
}
static member TargetFramework : string with get

Property Value

Type: String
See Also

Reference

DotNetProjectExtension Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution Class

DotNetSolution Class
Represents properties and methods used to store and manipulate Visual Studio solution content.
Inheritance Hierarchy
SystemObject
Alternet.Common.Projects.DotNetDotNetSolution

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DotNetSolution
Public Class DotNetSolution
public ref class DotNetSolution
type DotNetSolution =  class end

The DotNetSolution type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetSolution | Initializes a new instance of the DotNetSolution class
Top
Methods
 | Name | Description
Public method | AddProject | Adds project to the solution.
Public method | AllFiles | Gets list of files included in the solution.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveProject | Removes project from the solution.
Public method | Reset | Resets Project to the default state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Load | Loads solution from specified source. (Defined by SolutionExtension.)
Public Extension Method | Save | Saves solution to the file system, if modified. (Defined by SolutionExtension.)
Top
Properties
 | Name | Description
Public property | Configurations | List of solution's configurations.
Public property | DefaultProject | Gets or sets main project in the solution.
Public property | FileFormatVersion | Gets or sets solution's file format version.
Public property | Files | Gets list of files included in the all projects within the solution.
Public property | HasProjects | Gets a value indicating whether solution contains some project or folder.
Public property | IsEmpty | Gets a value indicating whether solution contains some data.
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save.
Public property | MinimumVisualStudioVersion | Gets or sets solution's minimum version.
Public property | Projects | Gets list of projects included in the solution.
Public property | SolutionFileName | Gets fully qualified name of the solution file.
Public property | SolutionGuid | Solution GUID. Mandatory starting from Visual studio 2017.
Public property | SolutionName | Gets or sets solution's name.
Public property | Version | Gets solution version.
Public property | VisualStudioVersion | Gets or sets solution's version.
Top
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


DotNetSolution Constructor

DotNetSolution Constructor
Initializes a new instance of the DotNetSolution class

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DotNetSolution()
Public Sub New
public:
DotNetSolution()
new : unit -> DotNetSolution
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution Methods

DotNetSolution Methods

The DotNetSolution type exposes the following members.

Methods
 | Name | Description
Public method | AddProject | Adds project to the solution.
Public method | AllFiles | Gets list of files included in the solution.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveProject | Removes project from the solution.
Public method | Reset | Resets Project to the default state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Load | Loads solution from specified source. (Defined by SolutionExtension.)
Public Extension Method | Save | Saves solution to the file system, if modified. (Defined by SolutionExtension.)
Top
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.AddProject Method

DotNetSolutionAddProject Method
Adds project to the solution.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddProject(
    DotNetProject project
)
Public Sub AddProject (
    project As DotNetProject
)
public:
void AddProject(
    DotNetProject^ project
)
member AddProject :
        project : DotNetProject -> unit

Parameters

project
Type: Alternet.Common.Projects.DotNetDotNetProject
Project to add.
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.AllFiles Method

DotNetSolutionAllFiles Method
Gets list of files included in the solution.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> AllFiles(
    bool includeProjects
)
Public Function AllFiles (
    includeProjects As Boolean
) As IList(Of String)
public:
IList<String^>^ AllFiles(
    bool includeProjects
)
member AllFiles :
        includeProjects : bool -> IList<string>

Parameters

includeProjects
Type: SystemBoolean
Specifies that result will include project files.

Return Value

Type: IListString
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.RemoveProject Method

DotNetSolutionRemoveProject Method
Removes project from the solution.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveProject(
    DotNetProject project
)
Public Sub RemoveProject (
    project As DotNetProject
)
public:
void RemoveProject(
    DotNetProject^ project
)
member RemoveProject :
        project : DotNetProject -> unit

Parameters

project
Type: Alternet.Common.Projects.DotNetDotNetProject
Project to remove.
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.Reset Method

DotNetSolutionReset Method
Resets Project to the default state.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution Properties

DotNetSolution Properties

The DotNetSolution type exposes the following members.

Properties
 | Name | Description
Public property | Configurations | List of solution's configurations.
Public property | DefaultProject | Gets or sets main project in the solution.
Public property | FileFormatVersion | Gets or sets solution's file format version.
Public property | Files | Gets list of files included in the all projects within the solution.
Public property | HasProjects | Gets a value indicating whether solution contains some project or folder.
Public property | IsEmpty | Gets a value indicating whether solution contains some data.
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save.
Public property | MinimumVisualStudioVersion | Gets or sets solution's minimum version.
Public property | Projects | Gets list of projects included in the solution.
Public property | SolutionFileName | Gets fully qualified name of the solution file.
Public property | SolutionGuid | Solution GUID. Mandatory starting from Visual studio 2017.
Public property | SolutionName | Gets or sets solution's name.
Public property | Version | Gets solution version.
Public property | VisualStudioVersion | Gets or sets solution's version.
Top
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.Configurations Property

DotNetSolutionConfigurations Property
List of solution's configurations.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> Configurations { get; set; }
Public Property Configurations As IDictionary(Of String, String)
    Get
    Set
public:
property IDictionary<String^, String^>^ Configurations {
    IDictionary<String^, String^>^ get ();
    void set (IDictionary<String^, String^>^ value);
}
member Configurations : IDictionary<string, string> with get, set

Property Value

Type: IDictionaryString, String
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.DefaultProject Property

DotNetSolutionDefaultProject Property
Gets or sets main project in the solution.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DotNetProject DefaultProject { get; set; }
Public Property DefaultProject As DotNetProject
    Get
    Set
public:
property DotNetProject^ DefaultProject {
    DotNetProject^ get ();
    void set (DotNetProject^ value);
}
member DefaultProject : DotNetProject with get, set

Property Value

Type: DotNetProject
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.FileFormatVersion Property

DotNetSolutionFileFormatVersion Property
Gets or sets solution's file format version.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FileFormatVersion { get; set; }
Public Property FileFormatVersion As Integer
    Get
    Set
public:
property int FileFormatVersion {
    int get ();
    void set (int value);
}
member FileFormatVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.Files Property

DotNetSolutionFiles Property
Gets list of files included in the all projects within the solution.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Files { get; }
Public ReadOnly Property Files As IList(Of String)
    Get
public:
property IList<String^>^ Files {
    IList<String^>^ get ();
}
member Files : IList<string> with get

Property Value

Type: IListString
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.HasProjects Property

DotNetSolutionHasProjects Property
Gets a value indicating whether solution contains some project or folder.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasProjects { get; }
Public ReadOnly Property HasProjects As Boolean
    Get
public:
property bool HasProjects {
    bool get ();
}
member HasProjects : bool with get

Property Value

Type: Boolean
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.IsEmpty Property

DotNetSolutionIsEmpty Property
Gets a value indicating whether solution contains some data.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.IsModified Property

DotNetSolutionIsModified Property
Gets or sets a value indicating whether project content has been modified since last save.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModified { get; set; }
Public Property IsModified As Boolean
    Get
    Set
public:
property bool IsModified {
    bool get ();
    void set (bool value);
}
member IsModified : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.MinimumVisualStudioVersion Property

DotNetSolutionMinimumVisualStudioVersion Property
Gets or sets solution's minimum version.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MinimumVisualStudioVersion { get; set; }
Public Property MinimumVisualStudioVersion As String
    Get
    Set
public:
property String^ MinimumVisualStudioVersion {
    String^ get ();
    void set (String^ value);
}
member MinimumVisualStudioVersion : string with get, set

Property Value

Type: String
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.Projects Property

DotNetSolutionProjects Property
Gets list of projects included in the solution.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<DotNetProject> Projects { get; }
Public ReadOnly Property Projects As IList(Of DotNetProject)
    Get
public:
property IList<DotNetProject^>^ Projects {
    IList<DotNetProject^>^ get ();
}
member Projects : IList<DotNetProject> with get

Property Value

Type: IListDotNetProject
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.SolutionFileName Property

DotNetSolutionSolutionFileName Property
Gets fully qualified name of the solution file.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SolutionFileName { get; set; }
Public Property SolutionFileName As String
    Get
    Set
public:
property String^ SolutionFileName {
    String^ get ();
    void set (String^ value);
}
member SolutionFileName : string with get, set

Property Value

Type: String
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.SolutionGuid Property

DotNetSolutionSolutionGuid Property
Solution GUID. Mandatory starting from Visual studio 2017.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SolutionGuid { get; set; }
Public Property SolutionGuid As String
    Get
    Set
public:
property String^ SolutionGuid {
    String^ get ();
    void set (String^ value);
}
member SolutionGuid : string with get, set

Property Value

Type: String
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.SolutionName Property

DotNetSolutionSolutionName Property
Gets or sets solution's name.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SolutionName { get; }
Public ReadOnly Property SolutionName As String
    Get
public:
property String^ SolutionName {
    String^ get ();
}
member SolutionName : string with get

Property Value

Type: String
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.Version Property

DotNetSolutionVersion Property
Gets solution version.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Version { get; set; }
Public Property Version As Double
    Get
    Set
public:
property double Version {
    double get ();
    void set (double value);
}
member Version : float with get, set

Property Value

Type: Double
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


DotNetSolution.VisualStudioVersion Property

DotNetSolutionVisualStudioVersion Property
Gets or sets solution's version.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VisualStudioVersion { get; set; }
Public Property VisualStudioVersion As String
    Get
    Set
public:
property String^ VisualStudioVersion {
    String^ get ();
    void set (String^ value);
}
member VisualStudioVersion : string with get, set

Property Value

Type: String
See Also

Reference

DotNetSolution Class
Alternet.Common.Projects.DotNet Namespace


SolutionExtension Class

SolutionExtension Class
Contains extended methods for Alternet.Editor.Common.Project class.
Inheritance Hierarchy
SystemObject
Alternet.Common.Projects.DotNetSolutionExtension

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SolutionExtension
<ExtensionAttribute>
Public NotInheritable Class SolutionExtension
[ExtensionAttribute]
public ref class SolutionExtension abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type SolutionExtension =  class end

The SolutionExtension type exposes the following members.

Methods
Name | Description
Load | Loads solution from specified source.
Save | Saves solution to the file system, if modified.
Top
See Also

Reference

Alternet.Common.Projects.DotNet Namespace


SolutionExtension Methods

SolutionExtension Methods

The SolutionExtension type exposes the following members.

Methods
Name | Description
Load | Loads solution from specified source.
Save | Saves solution to the file system, if modified.
Top
See Also

Reference

SolutionExtension Class
Alternet.Common.Projects.DotNet Namespace


SolutionExtension.Load Method

SolutionExtensionLoad Method
Loads solution from specified source.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Load(
    this DotNetSolution solution,
    string solutionFileName
)
<ExtensionAttribute>
Public Shared Sub Load (
    solution As DotNetSolution,
    solutionFileName As String
)
public:
[ExtensionAttribute]
static void Load(
    DotNetSolution^ solution,
    String^ solutionFileName
)
[<ExtensionAttribute>]
static member Load :
        solution : DotNetSolution *
        solutionFileName : string -> unit

Parameters

solution
Type: Alternet.Common.Projects.DotNetDotNetSolution
Solution to load.
solutionFileName
Type: SystemString
Path to the solution file.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DotNetSolution. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SolutionExtension Class
Alternet.Common.Projects.DotNet Namespace


SolutionExtension.Save Method

SolutionExtensionSave Method
Saves solution to the file system, if modified.

Namespace: Alternet.Common.Projects.DotNet
Assembly: Alternet.Common.v7 (in Alternet.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Save(
    this DotNetSolution solution
)
<ExtensionAttribute>
Public Shared Sub Save (
    solution As DotNetSolution
)
public:
[ExtensionAttribute]
static void Save(
    DotNetSolution^ solution
)
[<ExtensionAttribute>]
static member Save :
        solution : DotNetSolution -> unit

Parameters

solution
Type: Alternet.Common.Projects.DotNetDotNetSolution

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DotNetSolution. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SolutionExtension Class
Alternet.Common.Projects.DotNet Namespace


Alternet.Editor Namespace

Alternet.Editor Namespace
Classes
 | Class | Description
Public class | AutoCorrectEventArgs | Provides data for the AutoCorrectEvent handler.
Public class | CreatePrintEditEventArgs | Provides data for the CreatePrintEdit handler.
Public class | CustomDrawEventArgs | Provides data for the CustomDrawEvent handler.
Public class | DarkVisualTheme |
Public class | DisplayStrings | Represents a collection of visible strings in the text Edit control.
Public class | DrawHeaderEventArgs | Provides data for the DrawHeaderEvent handler.
Public class | DrawInfo | Contains full information about text fragment to be drawn.
Public class | DrawUserMarginEventArgs | Provides data for the DrawUserMarginEvent handler.
Public class | EditConsts | Contains default constants related to Edit control.
Public class | EditHyperText | Represents properties and methods to operate with hypertext within Edit control's content.
Public class | EditLineStyle | Represents a particular style of the line in Edit control.
Public class | EditLineStyles | Represents a collection of the ILineStyle objects for Edit control.
Public class | EditorPrintDocument | Defines a reusable object that sends output to a printer.
Public class | EditPage | Represents a particular page within Edit control content.
Public class | EditPages | Represents a collection of pages in the Edit control.
Public class | EditRuler | Represents Edit control's ruler.
Public class | EditSpelling | Represents properties and methods allowing to visually highlight misspelled words in the control.
Public class | EditSyntaxPaint | Represents properties and methods, used to draw text and graphic primitives.
Public class | EventHandlers | Represents key events for default keymapping.
Public class | GetSearchEventArgs | Provides data for the GetSearchEvent handler.
Public class | Gutter | Represents gutter at the left side of the Edit control.
Public class | HitTestInfo | Contains information about an area of an Edit control.
Public class | InitSearchEventArgs | Provides data for the InitSearchEvent handler.
Public class | KeyData | Represents data for a particular record in the Hashtable that contains keys with attached actions.
Public class | KeyList | Represents list of key or its combinations with attached actions.
Public class | KeyPreviewEventArgs | Provides data for the ICodeCompletionWindow.KeyPreviewEvent handler.
Public class | LightVisualTheme |
Public class | LineSeparator | Represents properties and methods used to separate lines and highlight current line within the Edit control.
Public class | MacroKeyData | Represents macro key or its combinations with attached actions.
Public class | MacroKeyList | Represents list of macro key or its combinations with attached actions.
Public class | Margin | Represents an appearance of the margin in Edit control.
Public class | NotifyEventArgs | Provides data for the NotifyEvent handler.
Public class | OutlineEventArgs | Provides data for the AutoCorrectEvent handler.
Public class | Outlining | Represents properties and methods that affects appearance and behaviour of outline sections within Edit control.
Public class | PageHeader | Represents header/footer parts of the Editor page.
Public class | PositionChangedEventArgs | Provides data for the event that occurs when the position within the text part of the ITextSource is changed.
Public class | Printing | Represents class designed to print, preview and execute print setup dialog for Edit control.
Public class | PromptReplaceEventArgs | Provides data for the PromptOnReplaceEvent handler.
Public class | Resources | Represents container of various resources used by Edit control.
Public class | RulerEventArgs | Provides data for the EditRuler.Change handler.
Public class | RulerIndent | Represents an indentation part of ruler.
Public class | ScrollBar | A custom scrollbar control.
Public class | Scrolling | Represents properties and methods that describe scrolling behaviour of Edit control.
Public class | ScrollingButton | Represents button displayed at the scroll bar area of Edit control.
Public class | ScrollingButtons | Represents collection of IScrollingButton objects.
Public class | ScrollingSplitter | Represents scrolling button that appears as splitter.
Public class | Selection | Represents class used to manage selected part of the Edit control's text content.
Public class | StandardVisualTheme |
Public class | SyntaxEdit | Represents advanced multi-line Edit control.
Public class | SyntaxPaint | Represents properties and methods, used to draw text and graphic primitives.
Public class | TextFoundEventArgs | Provides data for the TextFoundEvent handler.
Public class | UrlJumpEventArgs | Provides data for the UrlJumpEvent handler.
Public class | VisualTheme | Represents a single color theme.
Public class | VisualThemeThemedCodeCompletionBoxPainter |
Public class | VisualThemeThemedVsControlsPainter |
Public class | VisualThemeColors |
Public class | VisualThemeConsts | Contains default string constants for common requirements.
Public class | WhiteSpace | Represents properties of "invisible" characters, such as spaces and tabs, in the control's text content.
Interfaces
 | Interface | Description
Public interface | IAutoCorrect | Represents properties and methods allowing to auto correct words when typing.
Public interface | ICaret | Represents properties and methods to handle caret within the Edit control.
Public interface | ICollapsable | Represents properties and methods to affects appearance and behaviour of outline sections within Edit control.
Public interface | IDisplayStrings | Represents properties and methods for a collection of visible strings in the Edit control.
Public interface | IDrawInfo | Contains full information about text fragment to be drawn.
Public interface | IEditBraceMatching | Represents extended properties and methods to handle matching braces within the Edit control.
Public interface | IEditHyperText | Represents extended properties and methods to operate hypertext section within the text.
Public interface | IEditLineStyle | Represents properties and methods for a particular style of the line in Edit control.
Public interface | IEditLineStyles | Represents properties and methods for a collection of the ILineStyle objects each one specifying a particular style of the line in Edit control.
Public interface | IEditNavigate | Represents additional methods to navigate within the Edit control's text content.
Public interface | IEditNotifier | Represents method that informs editor object about changes in linked objects.
Public interface | IEditNotify | Represents extended properties and methods to manage notification between objects.
Public interface | IEditPage | Represents properties and methods to describe and manipulate with a particular page within Edit control content.
Public interface | IEditPageHeader | Represents properties and methods for header/footer parts of edit page.
Public interface | IEditPages | Represents a collection of pages in the Edit control.
Public interface | IEditRuler | Represents properties and methods of Edit control's ruler.
Public interface | IEditSpelling | Represents properties and methods to allowing to visually highlight misspelled words in the control.
Public interface | IEditSyntaxPaint | Represents properties and methods to paint editor's content.
Public interface | IEventHandlers | Represents key events for default keymapping.
Public interface | IFmtExport | Provides methods to save IStringItem elements.
Public interface | IFmtImport | Provides methods to load text content.
Public interface | IGutter | Represents properties and methods to operate with gutter at the left side of the Edit control.
Public interface | IHitTestInfo | Contains information about an area of an Edit control.
Public interface | IKeyData | Represents properties and methods describing some data attached to the particular key.
Public interface | IKeyList | Represents list of key or its combinations with attached actions.
Public interface | ILineSeparator | Represents properties and methods used to separate lines and highlight current line within the Edit control.
Public interface | IMacroKeyData | Represents macro key or its combinations with attached actions.
Public interface | IMacroKeyList | Represents list of macro key or its combinations with attached actions.
Public interface | IMargin | Represents properties and methods specifying appearance of the margin in Edit control.
Public interface | IOutlining | Represents additional properties and methods that affects appearance and behaviour of outline sections within Edit control.
Public interface | IPrinting | Represents properties and methods for printing and print previewing of Edit control.
Public interface | IRecordPlayBack | Represents properties and methods that allows recording sequences of keyboard commands and play back them later.
Public interface | IRulerIndent | Represents properties and methods defines a ruler indentation.
Public interface | IScrollBarThemeRenderer | Represents properties used to paint scrollbar elements in Visual Studio style.
Public interface | IScrolling | Represents properties and methods that describe scrolling behaviour of Edit control.
Public interface | IScrollingButton | Represents properties specifying appearance and behaviour of button displayed on the scroll bar.
Public interface | IScrollingButtons | Represents properties and methods to provide an indexed access to individual IScrollingButton object.
Public interface | ISearch | Represents properties and methods used to search and replace control's text content.
Public interface | ISelection | Contains properties and methods used to manage selected part of the Edit control's text content.
Public interface | ISplitView | Represents properties and methods allowing Edit control to visually split its content.
Public interface | ISyntaxEdit | Represents properties and methods for an advanced multi-line Edit control.
Public interface | ISyntaxPaint | Represents properties and methods, used to draw text and graphic primitives.
Public interface | IVisualTheme | Properties and methods for representing a single visual theme.
Public interface | IWhiteSpace | Represents properties of "invisible" characters, such as spaces and tabs, in the control's text content.
Public interface | IWordWrap | Represents properties and methods to wrap Edit control's text content.
Delegates
 | Delegate | Description
Public delegate | AutoCorrectEvent | Represents a method that will handle the SyntaxEdit.AutoCorrect event.
Public delegate | CreatePrintEditEvent | Represents a method that will handle the Printing.CreatePrintEdit event.
Public delegate | CreateSearchManagerEvent | Represents a method that will handle the SearchManager.CreateSharedSearch event.
Public delegate | CustomDrawEvent | Represents a method that will handle the SyntaxPaint.CustomDraw, SyntaxEdit.CustomDraw or CodeCompletionHint.CustomDraw events.
Public delegate | DrawHeaderEvent | Represents a method that will handle the SyntaxEdit.DrawHeader, EditPages.DrawHeader or CodeCompletionHint.CustomDraw events.
Public delegate | DrawUserMarginEvent | Represents a method that will handle the SyntaxEdit.DrawUserMargin, EditPages.DrawHeader event.
Public delegate | GetSearchEvent | Represents a method that will handle the SearchManager.GetSearch event.
Public delegate | InitSearchEvent | Represents a method that will handle the SearchManager.InitSearch event.
Public delegate | KeyEvent | Represents a method that will handle the key event.
Public delegate | KeyEventEx | Represents a method that will handle extended key event.
Public delegate | KeyPreviewEvent | Represents a method that will handle the ICodeCompletionWindow.KeyPreview event.
Public delegate | NotifyEvent | Represents a method that will handle the SyntaxEdit.SourceStateChanged event.
Public delegate | OutlineEvent | Represents a method that will handle the IOutlining.Expanding and IOutlining.Collapsing event.
Public delegate | PromptOnReplaceEvent | Represents a method that will handle the SyntaxEdit.PromptOnReplace event.
Public delegate | StringEvent | Represents a method that will handle string replacement event inside Selection
Public delegate | TextFoundEvent | Represents a method that will handle the SearchManager.TextFound event.
Public delegate | TextUndoEvent | Represents a method that will handle string replacement event inside Selection.
Public delegate | TextUndoEventEx | Represents a method that will handle string replacement event inside Selection
Public delegate | UrlJumpEvent | Represents a method that will handle the SyntaxEdit.JumpToUrl or HyperTextEx.JumpToUrl events.
Enumerations
 | Enumeration | Description
Public enumeration | AllowedSelectionMode | Defines which types of selection is allowed. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | DrawStage | DrawState is used to specify a stage in the custom drawing process.
Public enumeration | DrawState | DrawState is used to specify a custom drawing state, including information about elements of the control currently drawn. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | EditRulers | Specifies appearance of Edit control rulers. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | ExtendedSelectionScope | Specifies text selection scope in case of null-selection blocks
Public enumeration | GutterOptions | Defines gutter appearance and behaviour displayed at the left size of the Edit control. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | HitTest | Contains information about a part of the Edit control at a specified coordinate. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | IndentOrientation | Specifies alignment of an indentation part of ruler.
Public enumeration | KeyEventType | Represents type of key event.
Public enumeration | LineStyleOptions | Defines appearance of lines with some line style. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | OutlineOptions | Defines appearance and behaviour of the outline text sections. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | PageType | Specifies the way of viewing Edit control's content.
Public enumeration | PrintOptions | Defines appearance of the printed page when sending Editor's content to the printer. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | RulerOptions | Defines Edit ruler behaviour. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | RulerUnits | Defines units for the ruler.
Public enumeration | ScrollBarOrientation | Enum for the scrollbar orientation.
Public enumeration | ScrollingOptions | Defines scrolling behaviour. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | SelectionOptions | Defines appearance and behaviour of selected text. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | SelectionState | Defines state of the selected text.
Public enumeration | SelectionType | Defines type of the selection.
Public enumeration | SeparatorOptions | Specifies options for highlighting and separating lines within Edit control. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | VisualThemeImagesColor |
Public enumeration | VisualThemeType | Specifies Visual Theme type


AllowedSelectionMode Enumeration

AllowedSelectionMode Enumeration
Defines which types of selection is allowed. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum AllowedSelectionMode
<FlagsAttribute>
Public Enumeration AllowedSelectionMode
[FlagsAttribute]
public enum class AllowedSelectionMode
[<FlagsAttribute>]
type AllowedSelectionMode
Members
Member name | Value | Description
None | 0 | Specifies that no selection type is allowed.
Stream | 1 | Specifies that only stream selection type is allowed.
Block | 2 | Specifies that only block selection type is allowed.
See Also

Reference

Alternet.Editor Namespace
Alternet.EditorSelectionType


AutoCorrectEvent Delegate

AutoCorrectEvent Delegate
Represents a method that will handle the SyntaxEdit.AutoCorrect event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void AutoCorrectEvent(
    Object sender,
    AutoCorrectEventArgs e
)
Public Delegate Sub AutoCorrectEvent (
    sender As Object,
    e As AutoCorrectEventArgs
)
public delegate void AutoCorrectEvent(
    Object^ sender,
    AutoCorrectEventArgs^ e
)
type AutoCorrectEvent =
    delegate of
        sender : Object *
        e : AutoCorrectEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorAutoCorrectEventArgs
A AutoCorrectEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


AutoCorrectEventArgs Class

AutoCorrectEventArgs Class
Provides data for the AutoCorrectEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorAutoCorrectEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AutoCorrectEventArgs : EventArgs
Public Class AutoCorrectEventArgs
    Inherits EventArgs
public ref class AutoCorrectEventArgs : public EventArgs
type AutoCorrectEventArgs =
    class
        inherit EventArgs
    end

The AutoCorrectEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AutoCorrectEventArgs | Initializes a new instance of the AutoCorrectEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CorrectWord | Represents corrected word.
Public property | HasCorrection | Represents a value indicating whether specified word is corrected.
Public property | Word | Represents words to correct.
Top
See Also

Reference

Alternet.Editor Namespace


AutoCorrectEventArgs Constructor

AutoCorrectEventArgs Constructor
Initializes a new instance of the AutoCorrectEventArgs class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AutoCorrectEventArgs()
Public Sub New
public:
AutoCorrectEventArgs()
new : unit -> AutoCorrectEventArgs
See Also

Reference

AutoCorrectEventArgs Class
Alternet.Editor Namespace


AutoCorrectEventArgs Methods

AutoCorrectEventArgs Methods

The AutoCorrectEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AutoCorrectEventArgs Class
Alternet.Editor Namespace


AutoCorrectEventArgs Properties

AutoCorrectEventArgs Properties

The AutoCorrectEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CorrectWord | Represents corrected word.
Public property | HasCorrection | Represents a value indicating whether specified word is corrected.
Public property | Word | Represents words to correct.
Top
See Also

Reference

AutoCorrectEventArgs Class
Alternet.Editor Namespace


AutoCorrectEventArgs.CorrectWord Property

AutoCorrectEventArgsCorrectWord Property
Represents corrected word.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CorrectWord { get; set; }
Public Property CorrectWord As String
    Get
    Set
public:
property String^ CorrectWord {
    String^ get ();
    void set (String^ value);
}
member CorrectWord : string with get, set

Property Value

Type: String
See Also

Reference

AutoCorrectEventArgs Class
Alternet.Editor Namespace


AutoCorrectEventArgs.HasCorrection Property

AutoCorrectEventArgsHasCorrection Property
Represents a value indicating whether specified word is corrected.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasCorrection { get; set; }
Public Property HasCorrection As Boolean
    Get
    Set
public:
property bool HasCorrection {
    bool get ();
    void set (bool value);
}
member HasCorrection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AutoCorrectEventArgs Class
Alternet.Editor Namespace


AutoCorrectEventArgs.Word Property

AutoCorrectEventArgsWord Property
Represents words to correct.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Word { get; set; }
Public Property Word As String
    Get
    Set
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
member Word : string with get, set

Property Value

Type: String
See Also

Reference

AutoCorrectEventArgs Class
Alternet.Editor Namespace


CreatePrintEditEvent Delegate

CreatePrintEditEvent Delegate
Represents a method that will handle the Printing.CreatePrintEdit event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void CreatePrintEditEvent(
    Object sender,
    CreatePrintEditEventArgs e
)
Public Delegate Sub CreatePrintEditEvent (
    sender As Object,
    e As CreatePrintEditEventArgs
)
public delegate void CreatePrintEditEvent(
    Object^ sender,
    CreatePrintEditEventArgs^ e
)
type CreatePrintEditEvent =
    delegate of
        sender : Object *
        e : CreatePrintEditEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorCreatePrintEditEventArgs
A CreatePrintEditEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


CreatePrintEditEventArgs Class

CreatePrintEditEventArgs Class
Provides data for the CreatePrintEdit handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorCreatePrintEditEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CreatePrintEditEventArgs : EventArgs
Public Class CreatePrintEditEventArgs
    Inherits EventArgs
public ref class CreatePrintEditEventArgs : public EventArgs
type CreatePrintEditEventArgs =
    class
        inherit EventArgs
    end

The CreatePrintEditEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CreatePrintEditEventArgs | Initializes a new instance of the CreatePrintEditEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PrintEdit | Edit control that is created to be printed.
Top
See Also

Reference

Alternet.Editor Namespace


CreatePrintEditEventArgs Constructor

CreatePrintEditEventArgs Constructor
Initializes a new instance of the CreatePrintEditEventArgs class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CreatePrintEditEventArgs()
Public Sub New
public:
CreatePrintEditEventArgs()
new : unit -> CreatePrintEditEventArgs
See Also

Reference

CreatePrintEditEventArgs Class
Alternet.Editor Namespace


CreatePrintEditEventArgs Methods

CreatePrintEditEventArgs Methods

The CreatePrintEditEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreatePrintEditEventArgs Class
Alternet.Editor Namespace


CreatePrintEditEventArgs Properties

CreatePrintEditEventArgs Properties

The CreatePrintEditEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PrintEdit | Edit control that is created to be printed.
Top
See Also

Reference

CreatePrintEditEventArgs Class
Alternet.Editor Namespace


CreatePrintEditEventArgs.PrintEdit Property

CreatePrintEditEventArgsPrintEdit Property
Edit control that is created to be printed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISyntaxEdit PrintEdit { get; set; }
Public Property PrintEdit As ISyntaxEdit
    Get
    Set
public:
property ISyntaxEdit^ PrintEdit {
    ISyntaxEdit^ get ();
    void set (ISyntaxEdit^ value);
}
member PrintEdit : ISyntaxEdit with get, set

Property Value

Type: ISyntaxEdit
See Also

Reference

CreatePrintEditEventArgs Class
Alternet.Editor Namespace


CreateSearchManagerEvent Delegate

CreateSearchManagerEvent Delegate
Represents a method that will handle the SearchManager.CreateSharedSearch event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void CreateSearchManagerEvent(
    Object sender,
    CreateSearchManagerEventArgs e
)
Public Delegate Sub CreateSearchManagerEvent (
    sender As Object,
    e As CreateSearchManagerEventArgs
)
public delegate void CreateSearchManagerEvent(
    Object^ sender,
    CreateSearchManagerEventArgs^ e
)
type CreateSearchManagerEvent =
    delegate of
        sender : Object *
        e : CreateSearchManagerEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.Editor.TextSourceCreateSearchManagerEventArgs
A CreateSearchManagerEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


CustomDrawEvent Delegate

CustomDrawEvent Delegate
Represents a method that will handle the SyntaxPaint.CustomDraw, SyntaxEdit.CustomDraw or CodeCompletionHint.CustomDraw events.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void CustomDrawEvent(
    Object sender,
    CustomDrawEventArgs e
)
Public Delegate Sub CustomDrawEvent (
    sender As Object,
    e As CustomDrawEventArgs
)
public delegate void CustomDrawEvent(
    Object^ sender,
    CustomDrawEventArgs^ e
)
type CustomDrawEvent =
    delegate of
        sender : Object *
        e : CustomDrawEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorCustomDrawEventArgs
A CustomDrawEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


CustomDrawEventArgs Class

CustomDrawEventArgs Class
Provides data for the CustomDrawEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorCustomDrawEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CustomDrawEventArgs : EventArgs
Public Class CustomDrawEventArgs
    Inherits EventArgs
public ref class CustomDrawEventArgs : public EventArgs
type CustomDrawEventArgs =
    class
        inherit EventArgs
    end

The CustomDrawEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CustomDrawEventArgs | Initializes a new instance of the CustomDrawEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DrawInfo | Represents information about drawing text.
Public property | DrawStage | Specify a stage in the custom drawing process.
Public property | DrawState | Specify a custom drawing state, including information about elements of the control currently drawn.
Public property | Handled | Specifies whether painting is handled by an event, preventing control from default painting. This parameter is only used when DrawStage is DrawStage.Before.
Public property | Painter | Represents Painter surface to draw on.
Public property | Rect | Specifying rectangular area where Editor's content is drawn.
Top
See Also

Reference

Alternet.Editor Namespace


CustomDrawEventArgs Constructor

CustomDrawEventArgs Constructor
Initializes a new instance of the CustomDrawEventArgs class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CustomDrawEventArgs()
Public Sub New
public:
CustomDrawEventArgs()
new : unit -> CustomDrawEventArgs
See Also

Reference

CustomDrawEventArgs Class
Alternet.Editor Namespace


CustomDrawEventArgs Methods

CustomDrawEventArgs Methods

The CustomDrawEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomDrawEventArgs Class
Alternet.Editor Namespace


CustomDrawEventArgs Properties

CustomDrawEventArgs Properties

The CustomDrawEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DrawInfo | Represents information about drawing text.
Public property | DrawStage | Specify a stage in the custom drawing process.
Public property | DrawState | Specify a custom drawing state, including information about elements of the control currently drawn.
Public property | Handled | Specifies whether painting is handled by an event, preventing control from default painting. This parameter is only used when DrawStage is DrawStage.Before.
Public property | Painter | Represents Painter surface to draw on.
Public property | Rect | Specifying rectangular area where Editor's content is drawn.
Top
See Also

Reference

CustomDrawEventArgs Class
Alternet.Editor Namespace


CustomDrawEventArgs.DrawInfo Property

CustomDrawEventArgsDrawInfo Property
Represents information about drawing text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDrawInfo DrawInfo { get; set; }
Public Property DrawInfo As IDrawInfo
    Get
    Set
public:
property IDrawInfo^ DrawInfo {
    IDrawInfo^ get ();
    void set (IDrawInfo^ value);
}
member DrawInfo : IDrawInfo with get, set

Property Value

Type: IDrawInfo
See Also

Reference

CustomDrawEventArgs Class
Alternet.Editor Namespace


CustomDrawEventArgs.DrawStage Property

CustomDrawEventArgsDrawStage Property
Specify a stage in the custom drawing process.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DrawStage DrawStage { get; set; }
Public Property DrawStage As DrawStage
    Get
    Set
public:
property DrawStage DrawStage {
    DrawStage get ();
    void set (DrawStage value);
}
member DrawStage : DrawStage with get, set

Property Value

Type: DrawStage
See Also

Reference

CustomDrawEventArgs Class
Alternet.Editor Namespace


CustomDrawEventArgs.DrawState Property

CustomDrawEventArgsDrawState Property
Specify a custom drawing state, including information about elements of the control currently drawn.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DrawState DrawState { get; set; }
Public Property DrawState As DrawState
    Get
    Set
public:
property DrawState DrawState {
    DrawState get ();
    void set (DrawState value);
}
member DrawState : DrawState with get, set

Property Value

Type: DrawState
See Also

Reference

CustomDrawEventArgs Class
Alternet.Editor Namespace


CustomDrawEventArgs.Handled Property

CustomDrawEventArgsHandled Property
Specifies whether painting is handled by an event, preventing control from default painting. This parameter is only used when DrawStage is DrawStage.Before.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomDrawEventArgs Class
Alternet.Editor Namespace


CustomDrawEventArgs.Painter Property

CustomDrawEventArgsPainter Property
Represents Painter surface to draw on.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPainter Painter { get; set; }
Public Property Painter As IPainter
    Get
    Set
public:
property IPainter^ Painter {
    IPainter^ get ();
    void set (IPainter^ value);
}
member Painter : IPainter with get, set

Property Value

Type: IPainter
See Also

Reference

CustomDrawEventArgs Class
Alternet.Editor Namespace


CustomDrawEventArgs.Rect Property

CustomDrawEventArgsRect Property
Specifying rectangular area where Editor's content is drawn.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle Rect { get; set; }
Public Property Rect As Rectangle
    Get
    Set
public:
property Rectangle Rect {
    Rectangle get ();
    void set (Rectangle value);
}
member Rect : Rectangle with get, set

Property Value

Type: Rectangle
See Also

Reference

CustomDrawEventArgs Class
Alternet.Editor Namespace


DarkVisualTheme Class

DarkVisualTheme Class
Inheritance Hierarchy
SystemObject
Alternet.EditorVisualTheme
Alternet.EditorStandardVisualTheme
Alternet.EditorDarkVisualTheme

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DarkVisualTheme : StandardVisualTheme
Public Class DarkVisualTheme
    Inherits StandardVisualTheme
public ref class DarkVisualTheme : public StandardVisualTheme
type DarkVisualTheme =
    class
        inherit StandardVisualTheme
    end

The DarkVisualTheme type exposes the following members.

Constructors
 | Name | Description
Public method | DarkVisualTheme | Initializes a new instance of the DarkVisualTheme class
Top
Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox | (Inherited from VisualTheme.)
Public method | ApplyToCodeCompletionHint | (Inherited from VisualTheme.)
Public method | ApplyToEdit | (Inherited from VisualTheme.)
Public method | ApplyToScrollBar | (Inherited from VisualTheme.)
Public method | ApplyToScrollingButton | (Inherited from VisualTheme.)
Public method | ApplyToSplitButton | (Inherited from VisualTheme.)
Public method | Assign | (Inherited from VisualTheme.)
Public method | Dispose | (Inherited from VisualTheme.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromEdit | (Inherited from VisualTheme.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Instance |
Top
Properties
 | Name | Description
Public property | Colors | (Inherited from StandardVisualTheme.)
Public property | Font | Gets or sets the font used for the color theme. (Inherited from VisualTheme.)
Public property | ImagesColor | (Inherited from VisualTheme.)
Public property | Item | Specifies an Item indexer that uses the name of the LexStyle as an index. (Inherited from VisualTheme.)
Public property | LexStyles | Gets or sets the LexStyle array used for the color theme. (Inherited from VisualTheme.)
Public property | Name | Gets or sets the name of the color theme. (Inherited from VisualTheme.)
Public property | ReadOnly | Gets or sets a bool value that indicates whether or not the color theme should be modified. (Inherited from VisualTheme.)
Top
See Also

Reference

Alternet.Editor Namespace


DarkVisualTheme Constructor

DarkVisualTheme Constructor
Initializes a new instance of the DarkVisualTheme class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DarkVisualTheme()
Public Sub New
public:
DarkVisualTheme()
new : unit -> DarkVisualTheme
See Also

Reference

DarkVisualTheme Class
Alternet.Editor Namespace


DarkVisualTheme Fields

DarkVisualTheme Fields

The DarkVisualTheme type exposes the following members.

Fields
Name | Description
Instance |
Top
See Also

Reference

DarkVisualTheme Class
Alternet.Editor Namespace


DarkVisualTheme.Instance Field

DarkVisualThemeInstance Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly DarkVisualTheme Instance
Public Shared ReadOnly Instance As DarkVisualTheme
public:
static initonly DarkVisualTheme^ Instance
static val Instance: DarkVisualTheme

Field Value

Type: DarkVisualTheme
See Also

Reference

DarkVisualTheme Class
Alternet.Editor Namespace


DarkVisualTheme Methods

DarkVisualTheme Methods

The DarkVisualTheme type exposes the following members.

Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox | (Inherited from VisualTheme.)
Public method | ApplyToCodeCompletionHint | (Inherited from VisualTheme.)
Public method | ApplyToEdit | (Inherited from VisualTheme.)
Public method | ApplyToScrollBar | (Inherited from VisualTheme.)
Public method | ApplyToScrollingButton | (Inherited from VisualTheme.)
Public method | ApplyToSplitButton | (Inherited from VisualTheme.)
Public method | Assign | (Inherited from VisualTheme.)
Public method | Dispose | (Inherited from VisualTheme.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromEdit | (Inherited from VisualTheme.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DarkVisualTheme Class
Alternet.Editor Namespace


DarkVisualTheme Properties

DarkVisualTheme Properties

The DarkVisualTheme type exposes the following members.

Properties
 | Name | Description
Public property | Colors | (Inherited from StandardVisualTheme.)
Public property | Font | Gets or sets the font used for the color theme. (Inherited from VisualTheme.)
Public property | ImagesColor | (Inherited from VisualTheme.)
Public property | Item | Specifies an Item indexer that uses the name of the LexStyle as an index. (Inherited from VisualTheme.)
Public property | LexStyles | Gets or sets the LexStyle array used for the color theme. (Inherited from VisualTheme.)
Public property | Name | Gets or sets the name of the color theme. (Inherited from VisualTheme.)
Public property | ReadOnly | Gets or sets a bool value that indicates whether or not the color theme should be modified. (Inherited from VisualTheme.)
Top
See Also

Reference

DarkVisualTheme Class
Alternet.Editor Namespace


DisplayStrings Class

DisplayStrings Class
Represents a collection of visible strings in the text Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorDisplayStrings

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DisplayStrings : IDisplayStrings,
    IStringList, IList<string>, ICollection<string>,
    IEnumerable<string>, IEnumerable, IImport, IExport,
    ITabulation, IWordWrap, ITextSearch, IUpdate, IWordBreak,
    ICollapsable, ITextExport, ITextImport
Public Class DisplayStrings
    Implements IDisplayStrings, IStringList, IList(Of String),
    ICollection(Of String), IEnumerable(Of String), IEnumerable,
    IImport, IExport, ITabulation, IWordWrap, ITextSearch,
    IUpdate, IWordBreak, ICollapsable, ITextExport, ITextImport
public ref class DisplayStrings : IDisplayStrings,
    IStringList, IList<String^>, ICollection<String^>,
    IEnumerable<String^>, IEnumerable, IImport, IExport,
    ITabulation, IWordWrap, ITextSearch, IUpdate, IWordBreak,
    ICollapsable, ITextExport, ITextImport
type DisplayStrings =
    class
        interface IDisplayStrings
        interface IStringList
        interface IList<string>
        interface ICollection<string>
        interface IEnumerable<string>
        interface IEnumerable
        interface IImport
        interface IExport
        interface ITabulation
        interface IWordWrap
        interface ITextSearch
        interface IUpdate
        interface IWordBreak
        interface ICollapsable
        interface ITextExport
        interface ITextImport
    end

The DisplayStrings type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayStrings | Initializes a new instance of the DisplayStrings class with specified parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds a new item to the end of string collection.
Public method | BeginUpdate | Prevents outline list updating until calling ICollapsable.EndUpdate method.
Public method | BlockDeleting | Responds on deleting some block of lines within the editor control.
Public method | CanCollapse | Returns boolean value indicating that outline section at given line can be collapsed.
Public method | CanExpand(Int32) | Returns boolean value indicating that outline section at given line can be expanded.
Public method | CanExpand(IOutlineRange) | Returns boolean value indicating that given outline section can be expanded.
Public method | Clear | Removes all items from string collection.
Public method | Collapse | Collapses the specified line.
Public method | CollapseToDefinitions | Collapses and expands some outline section to get a quick overall view of the content.
Public method | Contains | Indicates whether string collection contains specified string.
Public method | CopyTo | Copies the entire string collection to a another array, starting at the specified index of the target array.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | DisplayPointToPoint(Point) | Converts the specified display coordinates to text coordinates.
Public method | DisplayPointToPoint(Int32, Int32) | Converts the specified display coordinates to text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean) | Converts the specified display coordinates to the text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean, Boolean, Boolean) | Converts the specified display coordinates to the text coordinates.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables outline list updating, that was turn of by calling ICollapsable.BeginUpdate method.
Public method | EnsureExpanded(Point) | Makes all outline sections containing specified position expanded.
Public method | EnsureExpanded(Int32) | Makes all outline sections containing specified line expanded.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Expand | Expands outline section at the given line.
Public method | Find | Searches for given text within the DisplayStrings contents.
Public method | FullCollapse | Collapses all outline sections objects within DisplayStrings.
Public method | FullCollapse(IListIRange) | Collapses all sections objects specified by Ranges parameter.
Public method | FullExpand | Expands all outline sections objects within DisplayStrings.
Public method | FullExpand(IListIRange) | Expands all outline sections specified by Ranges parameter.
Public method | GetColorData | Returns color information related to the specified line.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString(Int32, Int32) | Returns indentation string which consist of tabs and spaces.
Public method | GetIndentString(Int32, Int32, Boolean) | Returns indentation string which consist of tabs and spaces.
Public method | GetLexStyle | Returns lexical style related to the specified position.
Public method | GetOutlineHint | Returns the string that appears in the hint window when mouse pointer over the outline button.
Public method | GetOutlineRange(Point) | Returns outline section representing text substituting outline section and level of outline nesting at the specific position.
Public method | GetOutlineRange(Int32) | Returns outline section, which represents text substring outline section and level of outline nesting at the specific line.
Public method | GetOutlineRanges(IListIRange) | Fills list specified by Ranges parameter with all existing outline sections.
Public method | GetOutlineRanges(IListIRange, Point) | Fills list specified by Ranges parameter with all outline sections containing specific position.
Public method | GetOutlineRanges(IListIRange, Int32) | Fills list specified by Ranges parameter with all outline sections containing specific line.
Public method | GetOutlineRanges(IListIRange, Point, Point) | Fills list specified by Ranges parameter with all outline sections containing specific range.
Public method | GetPrevTabStop | Returns number of spaces to the previous TabStop.
Public method | GetStringAndColorData | Returns text and color information related to the specified line.
Public method | GetTabStop | Returns number of spaces to the next TabStop at the specified position.
Public method | GetTabString(String) | Converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTabString(String, ITextUndoList) | Converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTextAt(Point) | Returns word at the specific text position.
Public method | GetTextAt(Int32, Int32) | Returns word at the specific text position.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisibleLines | Gets max range containing visible lines
Public method | GetWord(Int32, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Char) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | Returns word start and end, if there is word at the specified position.
Public method | GetWrapMargin | Returns position of the wrap margin.
Public method | IndexOf | Returns the index of the first occurrence of given string in the string collection.
Public method | Insert | Inserts value at the specified position.
Public method | IsCollapsed | Indicates whether the outline section at the specified line is collapsed.
Public method | IsDelimiter(Char) | Indicates whether the specified character is delimiter character.
Public method | IsDelimiter(Int32, Int32) | Indicates whether the character at the specific position of the string collection is word delimiter character.
Public method | IsDelimiter(String, Int32) | Indicates whether the character at the specific position of string is word delimiter character.
Public method | IsExpanded | Indicates whether the outlined section at the specified line is expanded.
Public method | IsPointCollapsed | Indicates whether given position is in visible area of the editor control.
Public method | IsPointVisible | Indicates whether given position is in visible area of the editor control.
Public method | IsVisible(Point) | Indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.
Public method | IsVisible(Int32) | Indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.
Public method | IsWhitespace | Indicates whether the character at the specific position of the string collection is a whitespace character.
Public method | LoadFile(String) | Loads the contents of a text file into string collection.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | Loads the contents of a file into string collection.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Public method | LoadStream(Stream) | Loads the contents of a stream into string collection.
Public method | LoadStream(TextReader) | Loads the contents of a stream into string collection.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Public method | Notify | Notifies editor about updating IDisplayStrings state.
Public method | Outline(Point, Point) | This method creates an outlining section based on specific scope.
Public method | Outline(Int32, Int32) | This method creates an outlining section based on specific scope.
Public method | Outline(Point, Point, Int32) | This method creates an outlining section based on specific scope with the specific level of outline nesting.
Public method | Outline(Point, Point, String) | This method creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed section.
Public method | Outline(Int32, Int32, Int32) | This method creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Int32, Int32, String) | This method creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed section.
Public method | Outline(Point, Point, Int32, String) | This method creates an outlining section based on specific scope with specific level of outline nesting and specific text substituting collapsed section.
Public method | Outline(Int32, Int32, Int32, String) | This method creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed section.
Public method | PointToDisplayPoint(Point) | Converts the specified text coordinates into display coordinates.
Public method | PointToDisplayPoint(Int32, Int32) | Converts the specified text coordinates into display coordinates.
Public method | PointToDisplayPoint(Int32, Int32, Boolean) | Converts the specified text coordinates to display coordinates.
Public method | PositionChanged | Responds on changing position in the editor.
Public method | PosToTabPos(String, Int32) | Returns specified position within given string as tabbed position.
Public method | PosToTabPos(String, Int32, Boolean) | Returns specified position within given string as tabbed position.
Public method | Remove | Removes the first occurrence of given string from the string collection.
Public method | RemoveAt | Removes string item at specified position.
Public method | ResetAllowOutlining | Resets the AllowOutlining to its default value.
Public method | ResetDelimiters | Resets the Delimiters to the default value.
Public method | ResetOutlineOptions | Resets the OutlineOptions to its default value.
Public method | ResetTabStops | Resets the TabStops to the default value.
Public method | ResetUseSpaces | Resets the UseSpaces to the default value.
Public method | ResetWordWrap | Resets the WordWrap to its default value.
Public method | ResetWrapAtMargin | Resets the WrapAtMargin to its default value.
Public method | SaveFile(String) | Saves content to the specific file in the text format.
Public method | SaveFile(String, IStringExport) | Saves content to the specific file in the specific format.
Public method | SaveFile(String, Encoding) | Saves content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves content to the specific file in the specific format with specific encoding.
Public method | SaveStream(Stream) | Saves content to the specific stream in the text format.
Public method | SaveStream(TextWriter) | Saves content to the specific stream in the text format.
Public method | SaveStream(Stream, IStringExport) | Saves content to the specific stream in the specific format.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves content to the specific stream in the specific format and specific encoding.
Public method | SetOutlineRanges(IListIRange) | Updates IOutlineRange collection from given list of ranges.
Public method | SetOutlineRanges(IListIRange, Boolean) | Updates IOutlineRange collection from given list of ranges.
Public method | TabPosToPos | Returns specified position within given string as untabbed position.
Public method | ToggleOutlining | Toggles expanded state for current outline sections.
Public method | ToggleOutlining(IListIRange, IOutlineRange) | Toggles expanded state for given IOutlineRange collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnOutline | This method removes all outlined section within the DisplayStrings collection.
Public method | UnOutline(Point) | This method removes outlined section at the specific position.
Public method | UnOutline(Int32) | This method removes all outlined section containing the given line.
Public method | Update | When implemented by a class, updates an object state.
Public method | UpdateHiddenLines | Updates outline ranges for the hidden lines
Public method | UpdateNeeded | Forces IDisplayStrings to recalculate its content.
Public method | UpdateWordWrap | Re-wraps all lines in DisplayStrings collection.
Public method | UpdateWordWrap(Int32, Int32) | Updates wrapped lines within specific scope in DisplayStrings object.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | AllowHiddenLines | Gets or sets a value indicating whether hidden lines are enabled.
Public property | AllowOutlining | Gets or sets a value indicating whether outlining is enabled.
Public property | CollapsedCount | Returns number of collapsed sections.
Public property | Count | Returns number of visible lines.
Public property | Delimiters | Gets or sets an array of chars used to separate words in a text.
Public property | DelimiterString | Gets or sets Delimiters as a single string.
Public property | DisplayCount | Returns number of visible lines.
Public property | IgnoreWhiteSpace | Gets or sets boolean value indicating if white space styles are suppressed.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | Item | Provides an indexed access to individual string stored in the collection.
Public property | LineEnd | When implemented by a class, gets or sets boolean value indicating if the text position can be set to the end of the wrapped line.
Public property | Lines | Gets or sets the collection of underlying "real" collection of text lines.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | Loaded | Gets or sets boolean value indicating if the display strings was fully formatted.
Public property | MaxLineWidth | Gets width of the largest line in the DisplayString object.
Public property | OutlineOptions | Gets or sets options representing outlining appearance and behaviour.
Public property | SuppressTabs | Gets or sets boolean value indicating if conversion from tabs to spaces is suppressed.
Public property | TabStops | Gets or sets the character columns that the cursor will move to each time you press Tab.
Public property | Text | Gets or sets the strings in the IDisplayStrings as a single string with the individual strings delimited by carriage returns.
Public property | UpdateCount | Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested.
Public property | UseSpaces | Gets or sets a value indicating whether indent operations insert space characters rather than TAB characters.
Public property | WordWrap | Gets or sets a value indicating whether a DisplayStrings object automatically wraps words to the beginning of the next line when necessary.
Public property | WrapAtMargin | Gets or sets a value indicating whether a DisplayStrings object automatically wraps words at margin position.
Public property | WrapMargin | Gets position of the wrap margin.
Top
Events
 | Name | Description
Public event | Collapsing | Occurs when user attempts expand outline section.
Public event | Expanding | Occurs when user attempts expand outline section.
Top
Remarks
Use SyntaxStrings to access "real" lines stored in the TextSource. DisplayStrings provides an access to lines as they are displayed in the Edit control, assuming tabulation, wordwrap and outlining.
See Also

Reference

Alternet.Editor Namespace


DisplayStrings Constructor

DisplayStrings Constructor
Initializes a new instance of the DisplayStrings class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplayStrings(
    ISyntaxEdit owner,
    ITextStrings strings
)
Public Sub New (
    owner As ISyntaxEdit,
    strings As ITextStrings
)
public:
DisplayStrings(
    ISyntaxEdit^ owner,
    ITextStrings^ strings
)
new :
        owner : ISyntaxEdit *
        strings : ITextStrings -> DisplayStrings

Parameters

owner
Type: Alternet.EditorISyntaxEdit
Specifies owner of this new instance.
strings
Type: Alternet.Editor.TextSourceITextStrings
Specifies collection of underlying lines.
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings Methods

DisplayStrings Methods

The DisplayStrings type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new item to the end of string collection.
Public method | BeginUpdate | Prevents outline list updating until calling ICollapsable.EndUpdate method.
Public method | BlockDeleting | Responds on deleting some block of lines within the editor control.
Public method | CanCollapse | Returns boolean value indicating that outline section at given line can be collapsed.
Public method | CanExpand(Int32) | Returns boolean value indicating that outline section at given line can be expanded.
Public method | CanExpand(IOutlineRange) | Returns boolean value indicating that given outline section can be expanded.
Public method | Clear | Removes all items from string collection.
Public method | Collapse | Collapses the specified line.
Public method | CollapseToDefinitions | Collapses and expands some outline section to get a quick overall view of the content.
Public method | Contains | Indicates whether string collection contains specified string.
Public method | CopyTo | Copies the entire string collection to a another array, starting at the specified index of the target array.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | DisplayPointToPoint(Point) | Converts the specified display coordinates to text coordinates.
Public method | DisplayPointToPoint(Int32, Int32) | Converts the specified display coordinates to text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean) | Converts the specified display coordinates to the text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean, Boolean, Boolean) | Converts the specified display coordinates to the text coordinates.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables outline list updating, that was turn of by calling ICollapsable.BeginUpdate method.
Public method | EnsureExpanded(Point) | Makes all outline sections containing specified position expanded.
Public method | EnsureExpanded(Int32) | Makes all outline sections containing specified line expanded.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Expand | Expands outline section at the given line.
Public method | Find | Searches for given text within the DisplayStrings contents.
Public method | FullCollapse | Collapses all outline sections objects within DisplayStrings.
Public method | FullCollapse(IListIRange) | Collapses all sections objects specified by Ranges parameter.
Public method | FullExpand | Expands all outline sections objects within DisplayStrings.
Public method | FullExpand(IListIRange) | Expands all outline sections specified by Ranges parameter.
Public method | GetColorData | Returns color information related to the specified line.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString(Int32, Int32) | Returns indentation string which consist of tabs and spaces.
Public method | GetIndentString(Int32, Int32, Boolean) | Returns indentation string which consist of tabs and spaces.
Public method | GetLexStyle | Returns lexical style related to the specified position.
Public method | GetOutlineHint | Returns the string that appears in the hint window when mouse pointer over the outline button.
Public method | GetOutlineRange(Point) | Returns outline section representing text substituting outline section and level of outline nesting at the specific position.
Public method | GetOutlineRange(Int32) | Returns outline section, which represents text substring outline section and level of outline nesting at the specific line.
Public method | GetOutlineRanges(IListIRange) | Fills list specified by Ranges parameter with all existing outline sections.
Public method | GetOutlineRanges(IListIRange, Point) | Fills list specified by Ranges parameter with all outline sections containing specific position.
Public method | GetOutlineRanges(IListIRange, Int32) | Fills list specified by Ranges parameter with all outline sections containing specific line.
Public method | GetOutlineRanges(IListIRange, Point, Point) | Fills list specified by Ranges parameter with all outline sections containing specific range.
Public method | GetPrevTabStop | Returns number of spaces to the previous TabStop.
Public method | GetStringAndColorData | Returns text and color information related to the specified line.
Public method | GetTabStop | Returns number of spaces to the next TabStop at the specified position.
Public method | GetTabString(String) | Converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTabString(String, ITextUndoList) | Converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTextAt(Point) | Returns word at the specific text position.
Public method | GetTextAt(Int32, Int32) | Returns word at the specific text position.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVisibleLines | Gets max range containing visible lines
Public method | GetWord(Int32, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Char) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | Returns word start and end, if there is word at the specified position.
Public method | GetWrapMargin | Returns position of the wrap margin.
Public method | IndexOf | Returns the index of the first occurrence of given string in the string collection.
Public method | Insert | Inserts value at the specified position.
Public method | IsCollapsed | Indicates whether the outline section at the specified line is collapsed.
Public method | IsDelimiter(Char) | Indicates whether the specified character is delimiter character.
Public method | IsDelimiter(Int32, Int32) | Indicates whether the character at the specific position of the string collection is word delimiter character.
Public method | IsDelimiter(String, Int32) | Indicates whether the character at the specific position of string is word delimiter character.
Public method | IsExpanded | Indicates whether the outlined section at the specified line is expanded.
Public method | IsPointCollapsed | Indicates whether given position is in visible area of the editor control.
Public method | IsPointVisible | Indicates whether given position is in visible area of the editor control.
Public method | IsVisible(Point) | Indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.
Public method | IsVisible(Int32) | Indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.
Public method | IsWhitespace | Indicates whether the character at the specific position of the string collection is a whitespace character.
Public method | LoadFile(String) | Loads the contents of a text file into string collection.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | Loads the contents of a file into string collection.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Public method | LoadStream(Stream) | Loads the contents of a stream into string collection.
Public method | LoadStream(TextReader) | Loads the contents of a stream into string collection.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Public method | Notify | Notifies editor about updating IDisplayStrings state.
Public method | Outline(Point, Point) | This method creates an outlining section based on specific scope.
Public method | Outline(Int32, Int32) | This method creates an outlining section based on specific scope.
Public method | Outline(Point, Point, Int32) | This method creates an outlining section based on specific scope with the specific level of outline nesting.
Public method | Outline(Point, Point, String) | This method creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed section.
Public method | Outline(Int32, Int32, Int32) | This method creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Int32, Int32, String) | This method creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed section.
Public method | Outline(Point, Point, Int32, String) | This method creates an outlining section based on specific scope with specific level of outline nesting and specific text substituting collapsed section.
Public method | Outline(Int32, Int32, Int32, String) | This method creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed section.
Public method | PointToDisplayPoint(Point) | Converts the specified text coordinates into display coordinates.
Public method | PointToDisplayPoint(Int32, Int32) | Converts the specified text coordinates into display coordinates.
Public method | PointToDisplayPoint(Int32, Int32, Boolean) | Converts the specified text coordinates to display coordinates.
Public method | PositionChanged | Responds on changing position in the editor.
Public method | PosToTabPos(String, Int32) | Returns specified position within given string as tabbed position.
Public method | PosToTabPos(String, Int32, Boolean) | Returns specified position within given string as tabbed position.
Public method | Remove | Removes the first occurrence of given string from the string collection.
Public method | RemoveAt | Removes string item at specified position.
Public method | ResetAllowOutlining | Resets the AllowOutlining to its default value.
Public method | ResetDelimiters | Resets the Delimiters to the default value.
Public method | ResetOutlineOptions | Resets the OutlineOptions to its default value.
Public method | ResetTabStops | Resets the TabStops to the default value.
Public method | ResetUseSpaces | Resets the UseSpaces to the default value.
Public method | ResetWordWrap | Resets the WordWrap to its default value.
Public method | ResetWrapAtMargin | Resets the WrapAtMargin to its default value.
Public method | SaveFile(String) | Saves content to the specific file in the text format.
Public method | SaveFile(String, IStringExport) | Saves content to the specific file in the specific format.
Public method | SaveFile(String, Encoding) | Saves content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves content to the specific file in the specific format with specific encoding.
Public method | SaveStream(Stream) | Saves content to the specific stream in the text format.
Public method | SaveStream(TextWriter) | Saves content to the specific stream in the text format.
Public method | SaveStream(Stream, IStringExport) | Saves content to the specific stream in the specific format.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves content to the specific stream in the specific format and specific encoding.
Public method | SetOutlineRanges(IListIRange) | Updates IOutlineRange collection from given list of ranges.
Public method | SetOutlineRanges(IListIRange, Boolean) | Updates IOutlineRange collection from given list of ranges.
Public method | TabPosToPos | Returns specified position within given string as untabbed position.
Public method | ToggleOutlining | Toggles expanded state for current outline sections.
Public method | ToggleOutlining(IListIRange, IOutlineRange) | Toggles expanded state for given IOutlineRange collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnOutline | This method removes all outlined section within the DisplayStrings collection.
Public method | UnOutline(Point) | This method removes outlined section at the specific position.
Public method | UnOutline(Int32) | This method removes all outlined section containing the given line.
Public method | Update | When implemented by a class, updates an object state.
Public method | UpdateHiddenLines | Updates outline ranges for the hidden lines
Public method | UpdateNeeded | Forces IDisplayStrings to recalculate its content.
Public method | UpdateWordWrap | Re-wraps all lines in DisplayStrings collection.
Public method | UpdateWordWrap(Int32, Int32) | Updates wrapped lines within specific scope in DisplayStrings object.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Add Method

DisplayStringsAdd Method
Adds a new item to the end of string collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    string item
)
Public Overridable Sub Add (
    item As String
)
public:
virtual void Add(
    String^ item
)
abstract Add :
        item : string -> unit
override Add :
        item : string -> unit

Parameters

item
Type: SystemString
String to be added to the end of the collection.

Implements

ICollectionTAdd(T)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.BeginUpdate Method

DisplayStringsBeginUpdate Method
Prevents outline list updating until calling ICollapsable.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of header updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.BlockDeleting Method

DisplayStringsBlockDeleting Method
Responds on deleting some block of lines within the editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void BlockDeleting(
    Rectangle rect
)
Public Overridable Sub BlockDeleting (
    rect As Rectangle
)
public:
virtual void BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> unit
override BlockDeleting :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangle area of block being deleted.

Implements

IDisplayStringsBlockDeleting(Rectangle)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.CanCollapse Method

DisplayStringsCanCollapse Method
Returns boolean value indicating that outline section at given line can be collapsed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanCollapse(
    int line
)
Public Overridable Function CanCollapse (
    line As Integer
) As Boolean
public:
virtual bool CanCollapse(
    int line
)
abstract CanCollapse :
        line : int -> bool
override CanCollapse :
        line : int -> bool

Parameters

line
Type: SystemInt32

Return Value

Type: Boolean
True if section can be collapsed; otherwise false.

Implements

ICollapsableCanCollapse(Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.CanExpand Method

DisplayStringsCanExpand Method
Overload List
 | Name | Description
Public method | CanExpand(Int32) | Returns boolean value indicating that outline section at given line can be expanded.
Public method | CanExpand(IOutlineRange) | Returns boolean value indicating that given outline section can be expanded.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.CanExpand Method (Int32)

DisplayStringsCanExpand Method (Int32)
Returns boolean value indicating that outline section at given line can be expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanExpand(
    int line
)
Public Overridable Function CanExpand (
    line As Integer
) As Boolean
public:
virtual bool CanExpand(
    int line
)
abstract CanExpand :
        line : int -> bool
override CanExpand :
        line : int -> bool

Parameters

line
Type: SystemInt32

Return Value

Type: Boolean
True if section can be expanded; otherwise false.

Implements

ICollapsableCanExpand(Int32)
See Also

Reference

DisplayStrings Class
CanExpand Overload
Alternet.Editor Namespace


DisplayStrings.CanExpand Method (IOutlineRange)

DisplayStringsCanExpand Method (IOutlineRange)
Returns boolean value indicating that given outline section can be expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanExpand(
    IOutlineRange range
)
Public Overridable Function CanExpand (
    range As IOutlineRange
) As Boolean
public:
virtual bool CanExpand(
    IOutlineRange^ range
)
abstract CanExpand :
        range : IOutlineRange -> bool
override CanExpand :
        range : IOutlineRange -> bool

Parameters

range
Type: Alternet.SyntaxIOutlineRange

Return Value

Type: Boolean
True if section can be expanded; otherwise false.

Implements

ICollapsableCanExpand(IOutlineRange)
See Also

Reference

DisplayStrings Class
CanExpand Overload
Alternet.Editor Namespace


DisplayStrings.Clear Method

DisplayStringsClear Method
Removes all items from string collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Collapse Method

DisplayStringsCollapse Method
Collapses the specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Collapse(
    int index
)
Public Overridable Sub Collapse (
    index As Integer
)
public:
virtual void Collapse(
    int index
)
abstract Collapse :
        index : int -> unit
override Collapse :
        index : int -> unit

Parameters

index
Type: SystemInt32
The index of the line to collapse.

Implements

ICollapsableCollapse(Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.CollapseToDefinitions Method

DisplayStringsCollapseToDefinitions Method
Collapses and expands some outline section to get a quick overall view of the content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CollapseToDefinitions()
Public Overridable Sub CollapseToDefinitions
public:
virtual void CollapseToDefinitions()
abstract CollapseToDefinitions : unit -> unit
override CollapseToDefinitions : unit -> unit

Implements

ICollapsableCollapseToDefinitions
Remarks
Use this command to ensure that only more important for your outline sections starts to be expanded. For Example owner Edit control may expand only bodies of namespaces and classes and collapse all other sections.
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Contains Method

DisplayStringsContains Method
Indicates whether string collection contains specified string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    string item
)
Public Overridable Function Contains (
    item As String
) As Boolean
public:
virtual bool Contains(
    String^ item
)
abstract Contains :
        item : string -> bool
override Contains :
        item : string -> bool

Parameters

item
Type: SystemString
String to check.

Return Value

Type: Boolean
True if contains; otherwise false.

Implements

ICollectionTContains(T)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.CopyTo Method

DisplayStringsCopyTo Method
Copies the entire string collection to a another array, starting at the specified index of the target array.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CopyTo(
    string[] array,
    int arrayIndex
)
Public Overridable Sub CopyTo (
    array As String(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<String^>^ array,
    int arrayIndex
)
abstract CopyTo :
        array : string[] *
        arrayIndex : int -> unit
override CopyTo :
        array : string[] *
        arrayIndex : int -> unit

Parameters

array
Type: SystemString
The Array that is the destination of the elements copied from string collection.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.DisableUpdate Method

DisplayStringsDisableUpdate Method
Prevents object state updating until calling EnableUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.DisplayPointToPoint Method

DisplayStringsDisplayPointToPoint Method
Overload List
 | Name | Description
Public method | DisplayPointToPoint(Point) | Converts the specified display coordinates to text coordinates.
Public method | DisplayPointToPoint(Int32, Int32) | Converts the specified display coordinates to text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean) | Converts the specified display coordinates to the text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean, Boolean, Boolean) | Converts the specified display coordinates to the text coordinates.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.DisplayPointToPoint Method (Point)

DisplayStringsDisplayPointToPoint Method (Point)
Converts the specified display coordinates to text coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point DisplayPointToPoint(
    Point position
)
Public Overridable Function DisplayPointToPoint (
    position As Point
) As Point
public:
virtual Point DisplayPointToPoint(
    Point position
)
abstract DisplayPointToPoint :
        position : Point -> Point
override DisplayPointToPoint :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The Point value that specifies the display coordinates to be converted.

Return Value

Type: Point
Text coordinates of specified display point.

Implements

IDisplayStringsDisplayPointToPoint(Point)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

DisplayStrings Class
DisplayPointToPoint Overload
Alternet.Editor Namespace


DisplayStrings.DisplayPointToPoint Method (Int32, Int32)

DisplayStringsDisplayPointToPoint Method (Int32, Int32)
Converts the specified display coordinates to text coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point DisplayPointToPoint(
    int x,
    int y
)
Public Overridable Function DisplayPointToPoint (
    x As Integer,
    y As Integer
) As Point
public:
virtual Point DisplayPointToPoint(
    int x,
    int y
)
abstract DisplayPointToPoint :
        x : int *
        y : int -> Point
override DisplayPointToPoint :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies display coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies display coordinates to be converted.

Return Value

Type: Point
Text coordinates of specified display point.

Implements

IDisplayStringsDisplayPointToPoint(Int32, Int32)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

DisplayStrings Class
DisplayPointToPoint Overload
Alternet.Editor Namespace


DisplayStrings.DisplayPointToPoint Method (Int32, Int32, Boolean)

DisplayStringsDisplayPointToPoint Method (Int32, Int32, Boolean)
Converts the specified display coordinates to the text coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point DisplayPointToPoint(
    int x,
    int y,
    ref bool lineEnd
)
Public Overridable Function DisplayPointToPoint (
    x As Integer,
    y As Integer,
    ByRef lineEnd As Boolean
) As Point
public:
virtual Point DisplayPointToPoint(
    int x,
    int y,
    bool% lineEnd
)
abstract DisplayPointToPoint :
        x : int *
        y : int *
        lineEnd : bool byref -> Point
override DisplayPointToPoint :
        x : int *
        y : int *
        lineEnd : bool byref -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies display coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies display coordinates to be converted.
lineEnd
Type: SystemBoolean
Receives boolean value indicating if the caret is at the line end of the wrapped line.

Return Value

Type: Point
Text coordinates of specified display point.

Implements

IDisplayStringsDisplayPointToPoint(Int32, Int32, Boolean)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

DisplayStrings Class
DisplayPointToPoint Overload
Alternet.Editor Namespace


DisplayStrings.DisplayPointToPoint Method (Int32, Int32, Boolean, Boolean, Boolean)

DisplayStringsDisplayPointToPoint Method (Int32, Int32, Boolean, Boolean, Boolean)
Converts the specified display coordinates to the text coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point DisplayPointToPoint(
    int x,
    int y,
    bool wrapEnd,
    bool rangeStart,
    bool tabEnd
)
Public Overridable Function DisplayPointToPoint (
    x As Integer,
    y As Integer,
    wrapEnd As Boolean,
    rangeStart As Boolean,
    tabEnd As Boolean
) As Point
public:
virtual Point DisplayPointToPoint(
    int x,
    int y,
    bool wrapEnd,
    bool rangeStart,
    bool tabEnd
)
abstract DisplayPointToPoint :
        x : int *
        y : int *
        wrapEnd : bool *
        rangeStart : bool *
        tabEnd : bool -> Point
override DisplayPointToPoint :
        x : int *
        y : int *
        wrapEnd : bool *
        rangeStart : bool *
        tabEnd : bool -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies display coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies display coordinates to be converted.
wrapEnd
Type: SystemBoolean
Reserved for internal use.
rangeStart
Type: SystemBoolean
Reserved for internal use.
tabEnd
Type: SystemBoolean
Reserved for internal use.

Return Value

Type: Point
Text coordinates of specified display point.

Implements

IDisplayStringsDisplayPointToPoint(Int32, Int32, Boolean, Boolean, Boolean)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

DisplayStrings Class
DisplayPointToPoint Overload
Alternet.Editor Namespace


DisplayStrings.EnableUpdate Method

DisplayStringsEnableUpdate Method
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.EndUpdate Method

DisplayStringsEndUpdate Method
Re-enables outline list updating, that was turn of by calling ICollapsable.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of outline list updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.EnsureExpanded Method

DisplayStringsEnsureExpanded Method
Overload List
 | Name | Description
Public method | EnsureExpanded(Point) | Makes all outline sections containing specified position expanded.
Public method | EnsureExpanded(Int32) | Makes all outline sections containing specified line expanded.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.EnsureExpanded Method (Point)

DisplayStringsEnsureExpanded Method (Point)
Makes all outline sections containing specified position expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EnsureExpanded(
    Point position
)
Public Overridable Sub EnsureExpanded (
    position As Point
)
public:
virtual void EnsureExpanded(
    Point position
)
abstract EnsureExpanded :
        position : Point -> unit
override EnsureExpanded :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position in text coordinates.

Implements

ICollapsableEnsureExpanded(Point)
See Also

Reference

DisplayStrings Class
EnsureExpanded Overload
Alternet.Editor Namespace


DisplayStrings.EnsureExpanded Method (Int32)

DisplayStringsEnsureExpanded Method (Int32)
Makes all outline sections containing specified line expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EnsureExpanded(
    int index
)
Public Overridable Sub EnsureExpanded (
    index As Integer
)
public:
virtual void EnsureExpanded(
    int index
)
abstract EnsureExpanded :
        index : int -> unit
override EnsureExpanded :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies index of the line in text coordinates.

Implements

ICollapsableEnsureExpanded(Int32)
See Also

Reference

DisplayStrings Class
EnsureExpanded Overload
Alternet.Editor Namespace


DisplayStrings.Expand Method

DisplayStringsExpand Method
Expands outline section at the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Expand(
    int index
)
Public Overridable Sub Expand (
    index As Integer
)
public:
virtual void Expand(
    int index
)
abstract Expand :
        index : int -> unit
override Expand :
        index : int -> unit

Parameters

index
Type: SystemInt32
The index of the line to expand.

Implements

ICollapsableExpand(Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Find Method

DisplayStringsFind Method
Searches for given text within the DisplayStrings contents.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Find(
    string s,
    SearchOptions options,
    Regex expression,
    ref Point position,
    out int len,
    out Match match
)
Public Overridable Function Find (
    s As String,
    options As SearchOptions,
    expression As Regex,
    ByRef position As Point,
    <OutAttribute> ByRef len As Integer,
    <OutAttribute> ByRef match As Match
) As Boolean
public:
virtual bool Find(
    String^ s,
    SearchOptions options,
    Regex^ expression,
    Point% position,
    [OutAttribute] int% len,
    [OutAttribute] Match^% match
)
abstract Find :
        s : string *
        options : SearchOptions *
        expression : Regex *
        position : Point byref *
        len : int byref *
        match : Match byref -> bool
override Find :
        s : string *
        options : SearchOptions *
        expression : Regex *
        position : Point byref *
        len : int byref *
        match : Match byref -> bool

Parameters

s
Type: SystemString
The text to locate in the strings.
options
Type: Alternet.Editor.TextSourceSearchOptions
Search parameters.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
position
Type: System.DrawingPoint
Position in strings collection to start search.
len
Type: SystemInt32
Receives length of the found text.
match
Type: System.Text.RegularExpressionsMatch
Receives match if regular expression search successful.

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ITextSearchFind(String, SearchOptions, Regex, Point, Int32, Match)
Remarks
If search succeed Position parameter receive location of the found text.
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.FullCollapse Method

DisplayStringsFullCollapse Method
Overload List
 | Name | Description
Public method | FullCollapse | Collapses all outline sections objects within DisplayStrings.
Public method | FullCollapse(IListIRange) | Collapses all sections objects specified by Ranges parameter.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.FullCollapse Method

DisplayStringsFullCollapse Method
Collapses all outline sections objects within DisplayStrings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FullCollapse()
Public Overridable Sub FullCollapse
public:
virtual void FullCollapse()
abstract FullCollapse : unit -> unit
override FullCollapse : unit -> unit

Implements

ICollapsableFullCollapse
See Also

Reference

DisplayStrings Class
FullCollapse Overload
Alternet.Editor Namespace


DisplayStrings.FullCollapse Method (IList(IRange))

DisplayStringsFullCollapse Method (IListIRange)
Collapses all sections objects specified by Ranges parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FullCollapse(
    IList<IRange> ranges
)
Public Overridable Sub FullCollapse (
    ranges As IList(Of IRange)
)
public:
virtual void FullCollapse(
    IList<IRange^>^ ranges
)
abstract FullCollapse :
        ranges : IList<IRange> -> unit
override FullCollapse :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies IOutlineRange collection to collapse.

Implements

ICollapsableFullCollapse(IListIRange)
See Also

Reference

DisplayStrings Class
FullCollapse Overload
Alternet.Editor Namespace


DisplayStrings.FullExpand Method

DisplayStringsFullExpand Method
Overload List
 | Name | Description
Public method | FullExpand | Expands all outline sections objects within DisplayStrings.
Public method | FullExpand(IListIRange) | Expands all outline sections specified by Ranges parameter.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.FullExpand Method

DisplayStringsFullExpand Method
Expands all outline sections objects within DisplayStrings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FullExpand()
Public Overridable Sub FullExpand
public:
virtual void FullExpand()
abstract FullExpand : unit -> unit
override FullExpand : unit -> unit

Implements

ICollapsableFullExpand
See Also

Reference

DisplayStrings Class
FullExpand Overload
Alternet.Editor Namespace


DisplayStrings.FullExpand Method (IList(IRange))

DisplayStringsFullExpand Method (IListIRange)
Expands all outline sections specified by Ranges parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FullExpand(
    IList<IRange> ranges
)
Public Overridable Sub FullExpand (
    ranges As IList(Of IRange)
)
public:
virtual void FullExpand(
    IList<IRange^>^ ranges
)
abstract FullExpand :
        ranges : IList<IRange> -> unit
override FullExpand :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies IOutlineRange collection to expand.

Implements

ICollapsableFullExpand(IListIRange)
See Also

Reference

DisplayStrings Class
FullExpand Overload
Alternet.Editor Namespace


DisplayStrings.GetColorData Method

DisplayStringsGetColorData Method
Returns color information related to the specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual StringItemInfo[] GetColorData(
    int index
)
Public Overridable Function GetColorData (
    index As Integer
) As StringItemInfo()
public:
virtual array<StringItemInfo>^ GetColorData(
    int index
)
abstract GetColorData :
        index : int -> StringItemInfo[]
override GetColorData :
        index : int -> StringItemInfo[]

Parameters

index
Type: SystemInt32
The index of line in strings array.

Return Value

Type: StringItemInfo

Implements

IDisplayStringsGetColorData(Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetEnumerator Method

DisplayStringsGetEnumerator Method
Returns an enumerator that iterates through a collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<string> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of String)
public:
virtual IEnumerator<String^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<string>
override GetEnumerator : unit -> IEnumerator<string>

Return Value

Type: IEnumeratorString
A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetIndentString Method

DisplayStringsGetIndentString Method
Overload List
 | Name | Description
Public method | GetIndentString(Int32, Int32) | Returns indentation string which consist of tabs and spaces.
Public method | GetIndentString(Int32, Int32, Boolean) | Returns indentation string which consist of tabs and spaces.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetIndentString Method (Int32, Int32)

DisplayStringsGetIndentString Method (Int32, Int32)
Returns indentation string which consist of tabs and spaces.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetIndentString(
    int count,
    int pos
)
Public Overridable Function GetIndentString (
    count As Integer,
    pos As Integer
) As String
public:
virtual String^ GetIndentString(
    int count,
    int pos
)
abstract GetIndentString :
        count : int *
        pos : int -> string
override GetIndentString :
        count : int *
        pos : int -> string

Parameters

count
Type: SystemInt32
Specifies number of characters in the string.
pos
Type: SystemInt32
Specifies start position of the string.

Return Value

Type: String
Indented string that containing tabs and spaces.

Implements

ITabulationGetIndentString(Int32, Int32)
See Also

Reference

DisplayStrings Class
GetIndentString Overload
Alternet.Editor Namespace


DisplayStrings.GetIndentString Method (Int32, Int32, Boolean)

DisplayStringsGetIndentString Method (Int32, Int32, Boolean)
Returns indentation string which consist of tabs and spaces.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetIndentString(
    int count,
    int p,
    bool useSpaces
)
Public Overridable Function GetIndentString (
    count As Integer,
    p As Integer,
    useSpaces As Boolean
) As String
public:
virtual String^ GetIndentString(
    int count,
    int p,
    bool useSpaces
)
abstract GetIndentString :
        count : int *
        p : int *
        useSpaces : bool -> string
override GetIndentString :
        count : int *
        p : int *
        useSpaces : bool -> string

Parameters

count
Type: SystemInt32
Specifies number of characters in the string.
p
Type: SystemInt32
Specifies start position of the string.
useSpaces
Type: SystemBoolean
Specifies that spaces should be used instead of tab characters.

Return Value

Type: String
Indented string that containing tabs and spaces.

Implements

ITabulationGetIndentString(Int32, Int32, Boolean)
See Also

Reference

DisplayStrings Class
GetIndentString Overload
Alternet.Editor Namespace


DisplayStrings.GetLexStyle Method

DisplayStringsGetLexStyle Method
Returns lexical style related to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual StringItemInfo GetLexStyle(
    Point position
)
Public Overridable Function GetLexStyle (
    position As Point
) As StringItemInfo
public:
virtual StringItemInfo GetLexStyle(
    Point position
)
abstract GetLexStyle :
        position : Point -> StringItemInfo
override GetLexStyle :
        position : Point -> StringItemInfo

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position to receive lexical style.

Return Value

Type: StringItemInfo

Implements

IDisplayStringsGetLexStyle(Point)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetOutlineHint Method

DisplayStringsGetOutlineHint Method
Returns the string that appears in the hint window when mouse pointer over the outline button.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetOutlineHint(
    IOutlineRange range
)
Public Overridable Function GetOutlineHint (
    range As IOutlineRange
) As String
public:
virtual String^ GetOutlineHint(
    IOutlineRange^ range
)
abstract GetOutlineHint :
        range : IOutlineRange -> string
override GetOutlineHint :
        range : IOutlineRange -> string

Parameters

range
Type: Alternet.SyntaxIOutlineRange
Specifies the IOutlineRange object holding the hint.

Return Value

Type: String
Hint string for given IOutlineRange object.

Implements

ICollapsableGetOutlineHint(IOutlineRange)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetOutlineRange Method

DisplayStringsGetOutlineRange Method
Overload List
 | Name | Description
Public method | GetOutlineRange(Point) | Returns outline section representing text substituting outline section and level of outline nesting at the specific position.
Public method | GetOutlineRange(Int32) | Returns outline section, which represents text substring outline section and level of outline nesting at the specific line.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetOutlineRange Method (Point)

DisplayStringsGetOutlineRange Method (Point)
Returns outline section representing text substituting outline section and level of outline nesting at the specific position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange GetOutlineRange(
    Point position
)
Public Overridable Function GetOutlineRange (
    position As Point
) As IOutlineRange
public:
virtual IOutlineRange^ GetOutlineRange(
    Point position
)
abstract GetOutlineRange :
        position : Point -> IOutlineRange
override GetOutlineRange :
        position : Point -> IOutlineRange

Parameters

position
Type: System.DrawingPoint
Specifies position in text coordinates.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, if AllowOutlining property is true; otherwise return null.

Implements

ICollapsableGetOutlineRange(Point)
See Also

Reference

DisplayStrings Class
GetOutlineRange Overload
Alternet.Editor Namespace
Alternet.SyntaxIOutlineRange


DisplayStrings.GetOutlineRange Method (Int32)

DisplayStringsGetOutlineRange Method (Int32)
Returns outline section, which represents text substring outline section and level of outline nesting at the specific line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange GetOutlineRange(
    int index
)
Public Overridable Function GetOutlineRange (
    index As Integer
) As IOutlineRange
public:
virtual IOutlineRange^ GetOutlineRange(
    int index
)
abstract GetOutlineRange :
        index : int -> IOutlineRange
override GetOutlineRange :
        index : int -> IOutlineRange

Parameters

index
Type: SystemInt32
Index of the line in text coordinates.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, if AllowOutlining property is true; otherwise return null.

Implements

ICollapsableGetOutlineRange(Int32)
See Also

Reference

DisplayStrings Class
GetOutlineRange Overload
Alternet.Editor Namespace
Alternet.SyntaxIOutlineRange


DisplayStrings.GetOutlineRanges Method

DisplayStringsGetOutlineRanges Method
Overload List
 | Name | Description
Public method | GetOutlineRanges(IListIRange) | Fills list specified by Ranges parameter with all existing outline sections.
Public method | GetOutlineRanges(IListIRange, Point) | Fills list specified by Ranges parameter with all outline sections containing specific position.
Public method | GetOutlineRanges(IListIRange, Int32) | Fills list specified by Ranges parameter with all outline sections containing specific line.
Public method | GetOutlineRanges(IListIRange, Point, Point) | Fills list specified by Ranges parameter with all outline sections containing specific range.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetOutlineRanges Method (IList(IRange))

DisplayStringsGetOutlineRanges Method (IListIRange)
Fills list specified by Ranges parameter with all existing outline sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetOutlineRanges(
    IList<IRange> ranges
)
Public Overridable Function GetOutlineRanges (
    ranges As IList(Of IRange)
) As Integer
public:
virtual int GetOutlineRanges(
    IList<IRange^>^ ranges
)
abstract GetOutlineRanges :
        ranges : IList<IRange> -> int
override GetOutlineRanges :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.

Return Value

Type: Int32
Count of outline sections in Ranges.

Implements

ICollapsableGetOutlineRanges(IListIRange)
Remarks
If AllowOutlining property is false the method clears the Ranges collection and returns zero.
See Also

Reference

DisplayStrings Class
GetOutlineRanges Overload
Alternet.Editor Namespace


DisplayStrings.GetOutlineRanges Method (IList(IRange), Point)

DisplayStringsGetOutlineRanges Method (IListIRange, Point)
Fills list specified by Ranges parameter with all outline sections containing specific position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetOutlineRanges(
    IList<IRange> ranges,
    Point position
)
Public Overridable Function GetOutlineRanges (
    ranges As IList(Of IRange),
    position As Point
) As Integer
public:
virtual int GetOutlineRanges(
    IList<IRange^>^ ranges,
    Point position
)
abstract GetOutlineRanges :
        ranges : IList<IRange> *
        position : Point -> int
override GetOutlineRanges :
        ranges : IList<IRange> *
        position : Point -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
position
Type: System.DrawingPoint
Specifies position in text coordinates.

Return Value

Type: Int32
Count of outline sections in Ranges.

Implements

ICollapsableGetOutlineRanges(IListIRange, Point)
Remarks
If AllowOutlining property is false the method clears the Ranges collection and returns zero.
See Also

Reference

DisplayStrings Class
GetOutlineRanges Overload
Alternet.Editor Namespace


DisplayStrings.GetOutlineRanges Method (IList(IRange), Int32)

DisplayStringsGetOutlineRanges Method (IListIRange, Int32)
Fills list specified by Ranges parameter with all outline sections containing specific line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetOutlineRanges(
    IList<IRange> ranges,
    int index
)
Public Overridable Function GetOutlineRanges (
    ranges As IList(Of IRange),
    index As Integer
) As Integer
public:
virtual int GetOutlineRanges(
    IList<IRange^>^ ranges,
    int index
)
abstract GetOutlineRanges :
        ranges : IList<IRange> *
        index : int -> int
override GetOutlineRanges :
        ranges : IList<IRange> *
        index : int -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
index
Type: SystemInt32
Specifies line in text coordinates.

Return Value

Type: Int32
Count of outline sections in Ranges.

Implements

ICollapsableGetOutlineRanges(IListIRange, Int32)
Remarks
If AllowOutlining property is false the method clears the Ranges collection and returns zero.
See Also

Reference

DisplayStrings Class
GetOutlineRanges Overload
Alternet.Editor Namespace


DisplayStrings.GetOutlineRanges Method (IList(IRange), Point, Point)

DisplayStringsGetOutlineRanges Method (IListIRange, Point, Point)
Fills list specified by Ranges parameter with all outline sections containing specific range.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetOutlineRanges(
    IList<IRange> ranges,
    Point startPoint,
    Point endPoint
)
Public Overridable Function GetOutlineRanges (
    ranges As IList(Of IRange),
    startPoint As Point,
    endPoint As Point
) As Integer
public:
virtual int GetOutlineRanges(
    IList<IRange^>^ ranges,
    Point startPoint,
    Point endPoint
)
abstract GetOutlineRanges :
        ranges : IList<IRange> *
        startPoint : Point *
        endPoint : Point -> int
override GetOutlineRanges :
        ranges : IList<IRange> *
        startPoint : Point *
        endPoint : Point -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
startPoint
Type: System.DrawingPoint
Start position in text coordinates.
endPoint
Type: System.DrawingPoint
End position in text coordinates.

Return Value

Type: Int32
Count of outline sections in Ranges.

Implements

ICollapsableGetOutlineRanges(IListIRange, Point, Point)
Remarks
If AllowOutlining property is false the method clears the Ranges collection and returns zero.
See Also

Reference

DisplayStrings Class
GetOutlineRanges Overload
Alternet.Editor Namespace


DisplayStrings.GetPrevTabStop Method

DisplayStringsGetPrevTabStop Method
Returns number of spaces to the previous TabStop.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPrevTabStop(
    int pos
)
Public Overridable Function GetPrevTabStop (
    pos As Integer
) As Integer
public:
virtual int GetPrevTabStop(
    int pos
)
abstract GetPrevTabStop :
        pos : int -> int
override GetPrevTabStop :
        pos : int -> int

Parameters

pos
Type: SystemInt32
Position to check.

Return Value

Type: Int32
Number of spaces.

Implements

ITabulationGetPrevTabStop(Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetStringAndColorData Method

DisplayStringsGetStringAndColorData Method
Returns text and color information related to the specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetStringAndColorData(
    int index,
    ref string text,
    ref StringItemInfo[] data
)
Public Overridable Function GetStringAndColorData (
    index As Integer,
    ByRef text As String,
    ByRef data As StringItemInfo()
) As Integer
public:
virtual int GetStringAndColorData(
    int index,
    String^% text,
    array<StringItemInfo>^% data
)
abstract GetStringAndColorData :
        index : int *
        text : string byref *
        data : StringItemInfo[] byref -> int
override GetStringAndColorData :
        index : int *
        text : string byref *
        data : StringItemInfo[] byref -> int

Parameters

index
Type: SystemInt32
The index of line in strings array.
text
Type: SystemString
Returns text of the given line.
data
Type: Alternet.SyntaxStringItemInfo
Returns color information of specified line.

Return Value

Type: Int32
Corresponding index within ISyntaxStringscollection.

Implements

IDisplayStringsGetStringAndColorData(Int32, String, StringItemInfo)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetTabStop Method

DisplayStringsGetTabStop Method
Returns number of spaces to the next TabStop at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetTabStop(
    int pos
)
Public Overridable Function GetTabStop (
    pos As Integer
) As Integer
public:
virtual int GetTabStop(
    int pos
)
abstract GetTabStop :
        pos : int -> int
override GetTabStop :
        pos : int -> int

Parameters

pos
Type: SystemInt32
Position to check.

Return Value

Type: Int32
Number of spaces.

Implements

ITabulationGetTabStop(Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetTabString Method

DisplayStringsGetTabString Method
Overload List
 | Name | Description
Public method | GetTabString(String) | Converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTabString(String, ITextUndoList) | Converts all tab character to spaces depending on ITabulation.TabStops property.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetTabString Method (String)

DisplayStringsGetTabString Method (String)
Converts all tab character to spaces depending on ITabulation.TabStops property.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTabString(
    string s
)
Public Overridable Function GetTabString (
    s As String
) As String
public:
virtual String^ GetTabString(
    String^ s
)
abstract GetTabString :
        s : string -> string
override GetTabString :
        s : string -> string

Parameters

s
Type: SystemString
Text to convert.

Return Value

Type: String
Tabbed string.

Implements

ITabulationGetTabString(String)
See Also

Reference

DisplayStrings Class
GetTabString Overload
Alternet.Editor Namespace


DisplayStrings.GetTabString Method (String, ITextUndoList)

DisplayStringsGetTabString Method (String, ITextUndoList)
Converts all tab character to spaces depending on ITabulation.TabStops property.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GetTabString(
    string s,
    ITextUndoList operations
)
Public Overridable Sub GetTabString (
    s As String,
    operations As ITextUndoList
)
public:
virtual void GetTabString(
    String^ s,
    ITextUndoList^ operations
)
abstract GetTabString :
        s : string *
        operations : ITextUndoList -> unit
override GetTabString :
        s : string *
        operations : ITextUndoList -> unit

Parameters

s
Type: SystemString
Text to convert.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments(spaces or tabs).

Implements

ITabulationGetTabString(String, ITextUndoList)
See Also

Reference

DisplayStrings Class
GetTabString Overload
Alternet.Editor Namespace


DisplayStrings.GetTextAt Method

DisplayStringsGetTextAt Method
Overload List
 | Name | Description
Public method | GetTextAt(Point) | Returns word at the specific text position.
Public method | GetTextAt(Int32, Int32) | Returns word at the specific text position.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetTextAt Method (Point)

DisplayStringsGetTextAt Method (Point)
Returns word at the specific text position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTextAt(
    Point position
)
Public Overridable Function GetTextAt (
    position As Point
) As String
public:
virtual String^ GetTextAt(
    Point position
)
abstract GetTextAt :
        position : Point -> string
override GetTextAt :
        position : Point -> string

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position in the text.

Return Value

Type: String

Implements

IWordBreakGetTextAt(Point)
Remarks
If there is no word under specified position, method returns empty string.
See Also

Reference

DisplayStrings Class
GetTextAt Overload
Alternet.Editor Namespace


DisplayStrings.GetTextAt Method (Int32, Int32)

DisplayStringsGetTextAt Method (Int32, Int32)
Returns word at the specific text position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTextAt(
    int pos,
    int line
)
Public Overridable Function GetTextAt (
    pos As Integer,
    line As Integer
) As String
public:
virtual String^ GetTextAt(
    int pos,
    int line
)
abstract GetTextAt :
        pos : int *
        line : int -> string
override GetTextAt :
        pos : int *
        line : int -> string

Parameters

pos
Type: SystemInt32
Specifies index of character in the text string.
line
Type: SystemInt32
Specifies index of visible string.

Return Value

Type: String

Implements

IWordBreakGetTextAt(Int32, Int32)
Remarks
If there is no word under specified position, method returns empty string.
See Also

Reference

DisplayStrings Class
GetTextAt Overload
Alternet.Editor Namespace


DisplayStrings.GetVisibleLines Method

DisplayStringsGetVisibleLines Method
Gets max range containing visible lines

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetVisibleLines(
    out int first,
    out int last
)
Public Overridable Function GetVisibleLines (
    <OutAttribute> ByRef first As Integer,
    <OutAttribute> ByRef last As Integer
) As Boolean
public:
virtual bool GetVisibleLines(
    [OutAttribute] int% first,
    [OutAttribute] int% last
)
abstract GetVisibleLines :
        first : int byref *
        last : int byref -> bool
override GetVisibleLines :
        first : int byref *
        last : int byref -> bool

Parameters

first
Type: SystemInt32
First visible line
last
Type: SystemInt32
Last visible line

Return Value

Type: Boolean
True if there's any visible lines in the editor; otherwise false

Implements

IDisplayStringsGetVisibleLines(Int32, Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetWord Method

DisplayStringsGetWord Method
Overload List
 | Name | Description
Public method | GetWord(Int32, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Char) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | Returns word start and end, if there is word at the specified position.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.GetWord Method (Int32, Int32, Int32, Int32)

DisplayStringsGetWord Method (Int32, Int32, Int32, Int32)
Returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetWord(
    int index,
    int pos,
    out int left,
    out int right
)
Public Overridable Function GetWord (
    index As Integer,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer
) As Boolean
public:
virtual bool GetWord(
    int index,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right
)
abstract GetWord :
        index : int *
        pos : int *
        left : int byref *
        right : int byref -> bool
override GetWord :
        index : int *
        pos : int *
        left : int byref *
        right : int byref -> bool

Parameters

index
Type: SystemInt32
The index of line in the text.
pos
Type: SystemInt32
The index of character in the within the string.
left
Type: SystemInt32
Represents integer variable to receive start position of the word.
right
Type: SystemInt32
Represents integer variable to receive end position of the word.

Return Value

Type: Boolean
True if any word found; otherwise false.

Implements

IWordBreakGetWord(Int32, Int32, Int32, Int32)
See Also

Reference

DisplayStrings Class
GetWord Overload
Alternet.Editor Namespace


DisplayStrings.GetWord Method (String, Int32, Int32, Int32)

DisplayStringsGetWord Method (String, Int32, Int32, Int32)
Returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetWord(
    string s,
    int pos,
    out int left,
    out int right
)
Public Overridable Function GetWord (
    s As String,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer
) As Boolean
public:
virtual bool GetWord(
    String^ s,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right
)
abstract GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref -> bool
override GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref -> bool

Parameters

s
Type: SystemString
The given string.
pos
Type: SystemInt32
The index of character within the string.
left
Type: SystemInt32
Represents integer variable to receive start position of the word.
right
Type: SystemInt32
Represents integer variable to receive end position of the word.

Return Value

Type: Boolean
True if any word found; otherwise false.

Implements

IWordBreakGetWord(String, Int32, Int32, Int32)
See Also

Reference

DisplayStrings Class
GetWord Overload
Alternet.Editor Namespace


DisplayStrings.GetWord Method (String, Int32, Int32, Int32, Char[])

DisplayStringsGetWord Method (String, Int32, Int32, Int32, Char)
Returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetWord(
    string s,
    int pos,
    out int left,
    out int right,
    char[] delims
)
Public Overridable Function GetWord (
    s As String,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer,
    delims As Char()
) As Boolean
public:
virtual bool GetWord(
    String^ s,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right,
    array<wchar_t>^ delims
)
abstract GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : char[] -> bool
override GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : char[] -> bool

Parameters

s
Type: SystemString
The given string.
pos
Type: SystemInt32
The index of character within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.
delims
Type: SystemChar
Collection of delimiters.

Return Value

Type: Boolean
True if any word found; otherwise false.

Implements

IWordBreakGetWord(String, Int32, Int32, Int32, Char)
See Also

Reference

DisplayStrings Class
GetWord Overload
Alternet.Editor Namespace


DisplayStrings.GetWord Method (String, Int32, Int32, Int32, Hashtable)

DisplayStringsGetWord Method (String, Int32, Int32, Int32, Hashtable)
Returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetWord(
    string s,
    int pos,
    out int left,
    out int right,
    Hashtable delims
)
Public Overridable Function GetWord (
    s As String,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer,
    delims As Hashtable
) As Boolean
public:
virtual bool GetWord(
    String^ s,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right,
    Hashtable^ delims
)
abstract GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : Hashtable -> bool
override GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : Hashtable -> bool

Parameters

s
Type: SystemString
The given string.
pos
Type: SystemInt32
The index of character within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.
delims
Type: System.CollectionsHashtable
Collection of delimiters.

Return Value

Type: Boolean
True if any word found; otherwise false.

Implements

IWordBreakGetWord(String, Int32, Int32, Int32, Hashtable)
See Also

Reference

DisplayStrings Class
GetWord Overload
Alternet.Editor Namespace


DisplayStrings.GetWrapMargin Method

DisplayStringsGetWrapMargin Method
Returns position of the wrap margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetWrapMargin()
Public Overridable Function GetWrapMargin As Integer
public:
virtual int GetWrapMargin()
abstract GetWrapMargin : unit -> int
override GetWrapMargin : unit -> int

Return Value

Type: Int32
Return width of client rectangle or position of margin depending of WrapAtMargin property.

Implements

IWordWrapGetWrapMargin
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.IndexOf Method

DisplayStringsIndexOf Method
Returns the index of the first occurrence of given string in the string collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int IndexOf(
    string item
)
Public Overridable Function IndexOf (
    item As String
) As Integer
public:
virtual int IndexOf(
    String^ item
)
abstract IndexOf :
        item : string -> int
override IndexOf :
        item : string -> int

Parameters

item
Type: SystemString
The string to locate in string collection.

Return Value

Type: Int32
The index of the first occurrence of string within the string collection, if found; otherwise -1.

Implements

IListTIndexOf(T)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Insert Method

DisplayStringsInsert Method
Inserts value at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    int index,
    string item
)
Public Overridable Sub Insert (
    index As Integer,
    item As String
)
public:
virtual void Insert(
    int index,
    String^ item
)
abstract Insert :
        index : int *
        item : string -> unit
override Insert :
        index : int *
        item : string -> unit

Parameters

index
Type: SystemInt32
Specifies position to insert.
item
Type: SystemString
Specifies string to insert.

Implements

IListTInsert(Int32, T)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.IsCollapsed Method

DisplayStringsIsCollapsed Method
Indicates whether the outline section at the specified line is collapsed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsCollapsed(
    int index
)
Public Overridable Function IsCollapsed (
    index As Integer
) As Boolean
public:
virtual bool IsCollapsed(
    int index
)
abstract IsCollapsed :
        index : int -> bool
override IsCollapsed :
        index : int -> bool

Parameters

index
Type: SystemInt32
The index of the line.

Return Value

Type: Boolean
True if outlined section is collapsed; otherwise false.

Implements

ICollapsableIsCollapsed(Int32)
Remarks
If there is no outline section at the specified line text, method return false.
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace
DisplayStringsIsExpanded(Int32)


DisplayStrings.IsDelimiter Method

DisplayStringsIsDelimiter Method
Overload List
 | Name | Description
Public method | IsDelimiter(Char) | Indicates whether the specified character is delimiter character.
Public method | IsDelimiter(Int32, Int32) | Indicates whether the character at the specific position of the string collection is word delimiter character.
Public method | IsDelimiter(String, Int32) | Indicates whether the character at the specific position of string is word delimiter character.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.IsDelimiter Method (Char)

DisplayStringsIsDelimiter Method (Char)
Indicates whether the specified character is delimiter character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDelimiter(
    char ch
)
Public Overridable Function IsDelimiter (
    ch As Char
) As Boolean
public:
virtual bool IsDelimiter(
    wchar_t ch
)
abstract IsDelimiter :
        ch : char -> bool
override IsDelimiter :
        ch : char -> bool

Parameters

ch
Type: SystemChar
The char value that should be tested.

Return Value

Type: Boolean
True if specified character is delimiter; otherwise false.

Implements

IWordBreakIsDelimiter(Char)
See Also

Reference

DisplayStrings Class
IsDelimiter Overload
Alternet.Editor Namespace


DisplayStrings.IsDelimiter Method (Int32, Int32)

DisplayStringsIsDelimiter Method (Int32, Int32)
Indicates whether the character at the specific position of the string collection is word delimiter character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDelimiter(
    int index,
    int pos
)
Public Overridable Function IsDelimiter (
    index As Integer,
    pos As Integer
) As Boolean
public:
virtual bool IsDelimiter(
    int index,
    int pos
)
abstract IsDelimiter :
        index : int *
        pos : int -> bool
override IsDelimiter :
        index : int *
        pos : int -> bool

Parameters

index
Type: SystemInt32
The index of line in which character should be tested.
pos
Type: SystemInt32
The index of character in the specific string.

Return Value

Type: Boolean
True if specified character is delimiter character; otherwise false.

Implements

IWordBreakIsDelimiter(Int32, Int32)
See Also

Reference

DisplayStrings Class
IsDelimiter Overload
Alternet.Editor Namespace


DisplayStrings.IsDelimiter Method (String, Int32)

DisplayStringsIsDelimiter Method (String, Int32)
Indicates whether the character at the specific position of string is word delimiter character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDelimiter(
    string s,
    int pos
)
Public Overridable Function IsDelimiter (
    s As String,
    pos As Integer
) As Boolean
public:
virtual bool IsDelimiter(
    String^ s,
    int pos
)
abstract IsDelimiter :
        s : string *
        pos : int -> bool
override IsDelimiter :
        s : string *
        pos : int -> bool

Parameters

s
Type: SystemString
The string in which character should be tested.
pos
Type: SystemInt32
The index of character in the string.

Return Value

Type: Boolean
True if specified character is delimiter character; otherwise false.

Implements

IWordBreakIsDelimiter(String, Int32)
See Also

Reference

DisplayStrings Class
IsDelimiter Overload
Alternet.Editor Namespace


DisplayStrings.IsExpanded Method

DisplayStringsIsExpanded Method
Indicates whether the outlined section at the specified line is expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsExpanded(
    int index
)
Public Overridable Function IsExpanded (
    index As Integer
) As Boolean
public:
virtual bool IsExpanded(
    int index
)
abstract IsExpanded :
        index : int -> bool
override IsExpanded :
        index : int -> bool

Parameters

index
Type: SystemInt32
The index of the line.

Return Value

Type: Boolean
True if outlined section is expanded; otherwise false.

Implements

ICollapsableIsExpanded(Int32)
Remarks
If there is no outline section at the specified line text, method return false.
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace
DisplayStringsIsCollapsed(Int32)


DisplayStrings.IsPointCollapsed Method

DisplayStringsIsPointCollapsed Method
Indicates whether given position is in visible area of the editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsPointCollapsed(
    Point position,
    out IRange range
)
Public Overridable Function IsPointCollapsed (
    position As Point,
    <OutAttribute> ByRef range As IRange
) As Boolean
public:
virtual bool IsPointCollapsed(
    Point position,
    [OutAttribute] IRange^% range
)
abstract IsPointCollapsed :
        position : Point *
        range : IRange byref -> bool
override IsPointCollapsed :
        position : Point *
        range : IRange byref -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.
range
Type: Alternet.CommonIRange
Receives range contains the point. Null if specified position is visible.

Return Value

Type: Boolean
True if position is invisible due to outlining; otherwise false.

Implements

IDisplayStringsIsPointCollapsed(Point, IRange)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.IsPointVisible Method

DisplayStringsIsPointVisible Method
Indicates whether given position is in visible area of the editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPointVisible(
    Point position
)
Public Function IsPointVisible (
    position As Point
) As Boolean
public:
virtual bool IsPointVisible(
    Point position
) sealed
abstract IsPointVisible :
        position : Point -> bool
override IsPointVisible :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.

Return Value

Type: Boolean
True if position is invisible; otherwise false.

Implements

IDisplayStringsIsPointVisible(Point)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.IsVisible Method

DisplayStringsIsVisible Method
Overload List
 | Name | Description
Public method | IsVisible(Point) | Indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.
Public method | IsVisible(Int32) | Indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.IsVisible Method (Point)

DisplayStringsIsVisible Method (Point)
Indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsVisible(
    Point position
)
Public Overridable Function IsVisible (
    position As Point
) As Boolean
public:
virtual bool IsVisible(
    Point position
)
abstract IsVisible :
        position : Point -> bool
override IsVisible :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position in text coordinates.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICollapsableIsVisible(Point)
See Also

Reference

DisplayStrings Class
IsVisible Overload
Alternet.Editor Namespace


DisplayStrings.IsVisible Method (Int32)

DisplayStringsIsVisible Method (Int32)
Indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsVisible(
    int index
)
Public Overridable Function IsVisible (
    index As Integer
) As Boolean
public:
virtual bool IsVisible(
    int index
)
abstract IsVisible :
        index : int -> bool
override IsVisible :
        index : int -> bool

Parameters

index
Type: SystemInt32
Specifies index of the line in text coordinates.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICollapsableIsVisible(Int32)
See Also

Reference

DisplayStrings Class
IsVisible Overload
Alternet.Editor Namespace


DisplayStrings.IsWhitespace Method

DisplayStringsIsWhitespace Method
Indicates whether the character at the specific position of the string collection is a whitespace character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsWhitespace(
    string s,
    int pos
)
Public Overridable Function IsWhitespace (
    s As String,
    pos As Integer
) As Boolean
public:
virtual bool IsWhitespace(
    String^ s,
    int pos
)
abstract IsWhitespace :
        s : string *
        pos : int -> bool
override IsWhitespace :
        s : string *
        pos : int -> bool

Parameters

s
Type: SystemString
The string in which character should be tested.
pos
Type: SystemInt32
The index of character in the specific string.

Return Value

Type: Boolean
True if specified character is whitespace; otherwise false.

Implements

IWordBreakIsWhitespace(String, Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.LoadFile Method

DisplayStringsLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of a text file into string collection.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | Loads the contents of a file into string collection.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.LoadFile Method (String)

DisplayStringsLoadFile Method (String)
Loads the contents of a text file into string collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName
)
Public Overridable Function LoadFile (
    fileName As String
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool
override LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Represents name of file on disk.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IImportLoadFile(String)
See Also

Reference

DisplayStrings Class
LoadFile Overload
Alternet.Editor Namespace


DisplayStrings.LoadFile Method (String, IStringImport)

DisplayStringsLoadFile Method (String, IStringImport)
Loads content from the given file with specified importer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    IStringImport importer
)
Public Overridable Function LoadFile (
    fileName As String,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    IStringImport^ importer
)
abstract LoadFile :
        fileName : string *
        importer : IStringImport -> bool
override LoadFile :
        fileName : string *
        importer : IStringImport -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadFile(String, IStringImport)
See Also

Reference

DisplayStrings Class
LoadFile Overload
Alternet.Editor Namespace


DisplayStrings.LoadFile Method (String, Encoding)

DisplayStringsLoadFile Method (String, Encoding)
Loads the contents of a file into string collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Represents name of file on disk.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

DisplayStrings Class
LoadFile Overload
Alternet.Editor Namespace


DisplayStrings.LoadFile Method (String, IStringImport, Encoding)

DisplayStringsLoadFile Method (String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    IStringImport importer,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    IStringImport^ importer,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        importer : IStringImport *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadFile(String, IStringImport, Encoding)
See Also

Reference

DisplayStrings Class
LoadFile Overload
Alternet.Editor Namespace


DisplayStrings.LoadStream Method

DisplayStringsLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | Loads the contents of a stream into string collection.
Public method | LoadStream(TextReader) | Loads the contents of a stream into string collection.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.LoadStream Method (Stream)

DisplayStringsLoadStream Method (Stream)
Loads the contents of a stream into string collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream
)
Public Overridable Function LoadStream (
    stream As Stream
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream
)
abstract LoadStream :
        stream : Stream -> bool
override LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IImportLoadStream(Stream)
See Also

Reference

DisplayStrings Class
LoadStream Overload
Alternet.Editor Namespace


DisplayStrings.LoadStream Method (TextReader)

DisplayStringsLoadStream Method (TextReader)
Loads the contents of a stream into string collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader
)
Public Overridable Function LoadStream (
    reader As TextReader
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool
override LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IImportLoadStream(TextReader)
See Also

Reference

DisplayStrings Class
LoadStream Overload
Alternet.Editor Namespace


DisplayStrings.LoadStream Method (Stream, IStringImport)

DisplayStringsLoadStream Method (Stream, IStringImport)
Loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    IStringImport importer
)
Public Overridable Function LoadStream (
    stream As Stream,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    IStringImport^ importer
)
abstract LoadStream :
        stream : Stream *
        importer : IStringImport -> bool
override LoadStream :
        stream : Stream *
        importer : IStringImport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(Stream, IStringImport)
See Also

Reference

DisplayStrings Class
LoadStream Overload
Alternet.Editor Namespace


DisplayStrings.LoadStream Method (Stream, Encoding)

DisplayStringsLoadStream Method (Stream, Encoding)
Loads the contents of the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream, Encoding)
See Also

Reference

DisplayStrings Class
LoadStream Overload
Alternet.Editor Namespace


DisplayStrings.LoadStream Method (TextReader, IStringImport)

DisplayStringsLoadStream Method (TextReader, IStringImport)
Loads the contents of the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader,
    IStringImport importer
)
Public Overridable Function LoadStream (
    reader As TextReader,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader,
    IStringImport^ importer
)
abstract LoadStream :
        reader : TextReader *
        importer : IStringImport -> bool
override LoadStream :
        reader : TextReader *
        importer : IStringImport -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(TextReader, IStringImport)
See Also

Reference

DisplayStrings Class
LoadStream Overload
Alternet.Editor Namespace


DisplayStrings.LoadStream Method (Stream, IStringImport, Encoding)

DisplayStringsLoadStream Method (Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    IStringImport importer,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    IStringImport^ importer,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        importer : IStringImport *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(Stream, IStringImport, Encoding)
See Also

Reference

DisplayStrings Class
LoadStream Overload
Alternet.Editor Namespace


DisplayStrings.Notify Method

DisplayStringsNotify Method
Notifies editor about updating IDisplayStrings state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Notify(
    NotifyState state,
    int first,
    int last
)
Public Sub Notify (
    state As NotifyState,
    first As Integer,
    last As Integer
)
public:
virtual void Notify(
    NotifyState state,
    int first,
    int last
) sealed
abstract Notify :
        state : NotifyState *
        first : int *
        last : int -> unit
override Notify :
        state : NotifyState *
        first : int *
        last : int -> unit

Parameters

state
Type: Alternet.Editor.TextSourceNotifyState
Changes reason.
first
Type: SystemInt32
First changed line.
last
Type: SystemInt32
Last changed line.

Implements

IDisplayStringsNotify(NotifyState, Int32, Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Outline Method

DisplayStringsOutline Method
Overload List
 | Name | Description
Public method | Outline(Point, Point) | This method creates an outlining section based on specific scope.
Public method | Outline(Int32, Int32) | This method creates an outlining section based on specific scope.
Public method | Outline(Point, Point, Int32) | This method creates an outlining section based on specific scope with the specific level of outline nesting.
Public method | Outline(Point, Point, String) | This method creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed section.
Public method | Outline(Int32, Int32, Int32) | This method creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Int32, Int32, String) | This method creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed section.
Public method | Outline(Point, Point, Int32, String) | This method creates an outlining section based on specific scope with specific level of outline nesting and specific text substituting collapsed section.
Public method | Outline(Int32, Int32, Int32, String) | This method creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed section.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Outline Method (Point, Point)

DisplayStringsOutline Method (Point, Point)
This method creates an outlining section based on specific scope.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    Point startPoint,
    Point endPoint
)
Public Overridable Function Outline (
    startPoint As Point,
    endPoint As Point
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint
)
abstract Outline :
        startPoint : Point *
        endPoint : Point -> IOutlineRange
override Outline :
        startPoint : Point *
        endPoint : Point -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, if AllowOutlining property is true ; otherwise return null.

Implements

ICollapsableOutline(Point, Point)
Remarks
This method is applicable only when property AllowOutlining is true.
See Also

Reference

DisplayStrings Class
Outline Overload
Alternet.Editor Namespace


DisplayStrings.Outline Method (Int32, Int32)

DisplayStringsOutline Method (Int32, Int32)
This method creates an outlining section based on specific scope.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    int first,
    int last
)
Public Overridable Function Outline (
    first As Integer,
    last As Integer
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    int first,
    int last
)
abstract Outline :
        first : int *
        last : int -> IOutlineRange
override Outline :
        first : int *
        last : int -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, if AllowOutlining property is true ; otherwise return null.

Implements

ICollapsableOutline(Int32, Int32)
Remarks
This method is applicable only when property AllowOutlining is true.
See Also

Reference

DisplayStrings Class
Outline Overload
Alternet.Editor Namespace


DisplayStrings.Outline Method (Point, Point, Int32)

DisplayStringsOutline Method (Point, Point, Int32)
This method creates an outlining section based on specific scope with the specific level of outline nesting.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    Point startPoint,
    Point endPoint,
    int level
)
Public Overridable Function Outline (
    startPoint As Point,
    endPoint As Point,
    level As Integer
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint,
    int level
)
abstract Outline :
        startPoint : Point *
        endPoint : Point *
        level : int -> IOutlineRange
override Outline :
        startPoint : Point *
        endPoint : Point *
        level : int -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, if AllowOutlining property is true ; otherwise return null.

Implements

ICollapsableOutline(Point, Point, Int32)
Remarks
This method is applicable only when property AllowOutlining is true.
See Also

Reference

DisplayStrings Class
Outline Overload
Alternet.Editor Namespace


DisplayStrings.Outline Method (Point, Point, String)

DisplayStringsOutline Method (Point, Point, String)
This method creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    Point startPoint,
    Point endPoint,
    string outlineText
)
Public Overridable Function Outline (
    startPoint As Point,
    endPoint As Point,
    outlineText As String
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint,
    String^ outlineText
)
abstract Outline :
        startPoint : Point *
        endPoint : Point *
        outlineText : string -> IOutlineRange
override Outline :
        startPoint : Point *
        endPoint : Point *
        outlineText : string -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.
outlineText
Type: SystemString
Specifies text displayed when outlined section is collapsed.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, if AllowOutlining property is true; otherwise return null.

Implements

ICollapsableOutline(Point, Point, String)
Remarks
This method is applicable only when property AllowOutlining is true.
See Also

Reference

DisplayStrings Class
Outline Overload
Alternet.Editor Namespace


DisplayStrings.Outline Method (Int32, Int32, Int32)

DisplayStringsOutline Method (Int32, Int32, Int32)
This method creates an outlining section based on specific scope at the specific level of outline nesting.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    int first,
    int last,
    int level
)
Public Overridable Function Outline (
    first As Integer,
    last As Integer,
    level As Integer
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    int first,
    int last,
    int level
)
abstract Outline :
        first : int *
        last : int *
        level : int -> IOutlineRange
override Outline :
        first : int *
        last : int *
        level : int -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, If AllowOutlining property is true; otherwise return null.

Implements

ICollapsableOutline(Int32, Int32, Int32)
Remarks
This method is applicable only when property AllowOutlining is true.
See Also

Reference

DisplayStrings Class
Outline Overload
Alternet.Editor Namespace


DisplayStrings.Outline Method (Int32, Int32, String)

DisplayStringsOutline Method (Int32, Int32, String)
This method creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    int first,
    int last,
    string outlineText
)
Public Overridable Function Outline (
    first As Integer,
    last As Integer,
    outlineText As String
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    int first,
    int last,
    String^ outlineText
)
abstract Outline :
        first : int *
        last : int *
        outlineText : string -> IOutlineRange
override Outline :
        first : int *
        last : int *
        outlineText : string -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.
outlineText
Type: SystemString
Specifies text displayed when outline section is collapsed.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, if AllowOutlining property is true; otherwise return null.

Implements

ICollapsableOutline(Int32, Int32, String)
Remarks
This method is applicable only when property AllowOutlining is true.
See Also

Reference

DisplayStrings Class
Outline Overload
Alternet.Editor Namespace


DisplayStrings.Outline Method (Point, Point, Int32, String)

DisplayStringsOutline Method (Point, Point, Int32, String)
This method creates an outlining section based on specific scope with specific level of outline nesting and specific text substituting collapsed section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    Point startPoint,
    Point endPoint,
    int level,
    string outlineText
)
Public Overridable Function Outline (
    startPoint As Point,
    endPoint As Point,
    level As Integer,
    outlineText As String
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint,
    int level,
    String^ outlineText
)
abstract Outline :
        startPoint : Point *
        endPoint : Point *
        level : int *
        outlineText : string -> IOutlineRange
override Outline :
        startPoint : Point *
        endPoint : Point *
        level : int *
        outlineText : string -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.
outlineText
Type: SystemString
Specifies text displayed when outline section is collapsed.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, if AllowOutlining property is true; otherwise return null.

Implements

ICollapsableOutline(Point, Point, Int32, String)
Remarks
This method is applicable only when property AllowOutlining is true.
See Also

Reference

DisplayStrings Class
Outline Overload
Alternet.Editor Namespace


DisplayStrings.Outline Method (Int32, Int32, Int32, String)

DisplayStringsOutline Method (Int32, Int32, Int32, String)
This method creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    int first,
    int last,
    int level,
    string outlineText
)
Public Overridable Function Outline (
    first As Integer,
    last As Integer,
    level As Integer,
    outlineText As String
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    int first,
    int last,
    int level,
    String^ outlineText
)
abstract Outline :
        first : int *
        last : int *
        level : int *
        outlineText : string -> IOutlineRange
override Outline :
        first : int *
        last : int *
        level : int *
        outlineText : string -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.
outlineText
Type: SystemString
Specifies text displayed when outline section is collapsed.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section, if AllowOutlining property is true; otherwise return null.

Implements

ICollapsableOutline(Int32, Int32, Int32, String)
Remarks
This method is applicable only when property AllowOutlining is true.
See Also

Reference

DisplayStrings Class
Outline Overload
Alternet.Editor Namespace


DisplayStrings.PointToDisplayPoint Method

DisplayStringsPointToDisplayPoint Method
Overload List
 | Name | Description
Public method | PointToDisplayPoint(Point) | Converts the specified text coordinates into display coordinates.
Public method | PointToDisplayPoint(Int32, Int32) | Converts the specified text coordinates into display coordinates.
Public method | PointToDisplayPoint(Int32, Int32, Boolean) | Converts the specified text coordinates to display coordinates.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.PointToDisplayPoint Method (Point)

DisplayStringsPointToDisplayPoint Method (Point)
Converts the specified text coordinates into display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point PointToDisplayPoint(
    Point position
)
Public Overridable Function PointToDisplayPoint (
    position As Point
) As Point
public:
virtual Point PointToDisplayPoint(
    Point position
)
abstract PointToDisplayPoint :
        position : Point -> Point
override PointToDisplayPoint :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The Point value that specifies text coordinates to convert.

Return Value

Type: Point
Display coordinates of the specified point.

Implements

IDisplayStringsPointToDisplayPoint(Point)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

DisplayStrings Class
PointToDisplayPoint Overload
Alternet.Editor Namespace


DisplayStrings.PointToDisplayPoint Method (Int32, Int32)

DisplayStringsPointToDisplayPoint Method (Int32, Int32)
Converts the specified text coordinates into display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point PointToDisplayPoint(
    int x,
    int y
)
Public Overridable Function PointToDisplayPoint (
    x As Integer,
    y As Integer
) As Point
public:
virtual Point PointToDisplayPoint(
    int x,
    int y
)
abstract PointToDisplayPoint :
        x : int *
        y : int -> Point
override PointToDisplayPoint :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies the text coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies the text coordinates to be converted.

Return Value

Type: Point
Display coordinates of the specified point.

Implements

IDisplayStringsPointToDisplayPoint(Int32, Int32)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

DisplayStrings Class
PointToDisplayPoint Overload
Alternet.Editor Namespace


DisplayStrings.PointToDisplayPoint Method (Int32, Int32, Boolean)

DisplayStringsPointToDisplayPoint Method (Int32, Int32, Boolean)
Converts the specified text coordinates to display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point PointToDisplayPoint(
    int x,
    int y,
    bool lineEnd
)
Public Overridable Function PointToDisplayPoint (
    x As Integer,
    y As Integer,
    lineEnd As Boolean
) As Point
public:
virtual Point PointToDisplayPoint(
    int x,
    int y,
    bool lineEnd
)
abstract PointToDisplayPoint :
        x : int *
        y : int *
        lineEnd : bool -> Point
override PointToDisplayPoint :
        x : int *
        y : int *
        lineEnd : bool -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies the text coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies the text coordinates to be converted.
lineEnd
Type: SystemBoolean
Boolean value indicating if the text position can be set to the end of the wrapped line.

Return Value

Type: Point
Display coordinates of the specified text point.

Implements

IDisplayStringsPointToDisplayPoint(Int32, Int32, Boolean)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

DisplayStrings Class
PointToDisplayPoint Overload
Alternet.Editor Namespace


DisplayStrings.PositionChanged Method

DisplayStringsPositionChanged Method
Responds on changing position in the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PositionChanged(
    UpdateReason reason,
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Sub PositionChanged (
    reason As UpdateReason,
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    UpdateReason reason,
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        reason : UpdateReason *
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        reason : UpdateReason *
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

reason
Type: Alternet.Editor.TextSourceUpdateReason
Reason of changing position.
x
Type: SystemInt32
X-coordinate of current position.
y
Type: SystemInt32
Y-coordinate of current position.
deltaX
Type: SystemInt32
Horizontal offset.
deltaY
Type: SystemInt32
Vertical offset.

Implements

IDisplayStringsPositionChanged(UpdateReason, Int32, Int32, Int32, Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.PosToTabPos Method

DisplayStringsPosToTabPos Method
Overload List
 | Name | Description
Public method | PosToTabPos(String, Int32) | Returns specified position within given string as tabbed position.
Public method | PosToTabPos(String, Int32, Boolean) | Returns specified position within given string as tabbed position.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.PosToTabPos Method (String, Int32)

DisplayStringsPosToTabPos Method (String, Int32)
Returns specified position within given string as tabbed position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PosToTabPos(
    string s,
    int pos
)
Public Overridable Function PosToTabPos (
    s As String,
    pos As Integer
) As Integer
public:
virtual int PosToTabPos(
    String^ s,
    int pos
)
abstract PosToTabPos :
        s : string *
        pos : int -> int
override PosToTabPos :
        s : string *
        pos : int -> int

Parameters

s
Type: SystemString
Specifies string to check.
pos
Type: SystemInt32
Position of the character in the string.

Return Value

Type: Int32
Tabbed position.

Implements

ITabulationPosToTabPos(String, Int32)
See Also

Reference

DisplayStrings Class
PosToTabPos Overload
Alternet.Editor Namespace


DisplayStrings.PosToTabPos Method (String, Int32, Boolean)

DisplayStringsPosToTabPos Method (String, Int32, Boolean)
Returns specified position within given string as tabbed position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PosToTabPos(
    string s,
    int pos,
    bool tabEnd
)
Public Overridable Function PosToTabPos (
    s As String,
    pos As Integer,
    tabEnd As Boolean
) As Integer
public:
virtual int PosToTabPos(
    String^ s,
    int pos,
    bool tabEnd
)
abstract PosToTabPos :
        s : string *
        pos : int *
        tabEnd : bool -> int
override PosToTabPos :
        s : string *
        pos : int *
        tabEnd : bool -> int

Parameters

s
Type: SystemString
Specifies string to check.
pos
Type: SystemInt32
Position of the character in the string.
tabEnd
Type: SystemBoolean
Reserved for internal use.

Return Value

Type: Int32
Tabbed position.

Implements

ITabulationPosToTabPos(String, Int32, Boolean)
See Also

Reference

DisplayStrings Class
PosToTabPos Overload
Alternet.Editor Namespace


DisplayStrings.Remove Method

DisplayStringsRemove Method
Removes the first occurrence of given string from the string collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Remove(
    string item
)
Public Overridable Function Remove (
    item As String
) As Boolean
public:
virtual bool Remove(
    String^ item
)
abstract Remove :
        item : string -> bool
override Remove :
        item : string -> bool

Parameters

item
Type: SystemString
String to remove.

Return Value

Type: Boolean
True if item was successfully removed from the ICollection; otherwise, false. This method also returns false if item is not found in the original ICollection.

Implements

ICollectionTRemove(T)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.RemoveAt Method

DisplayStringsRemoveAt Method
Removes string item at specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
)
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies index of item in the string collection to remove.

Implements

IListTRemoveAt(Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.ResetAllowOutlining Method

DisplayStringsResetAllowOutlining Method
Resets the AllowOutlining to its default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAllowOutlining()
Public Overridable Sub ResetAllowOutlining
public:
virtual void ResetAllowOutlining()
abstract ResetAllowOutlining : unit -> unit
override ResetAllowOutlining : unit -> unit

Implements

ICollapsableResetAllowOutlining
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.ResetDelimiters Method

DisplayStringsResetDelimiters Method
Resets the Delimiters to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDelimiters()
Public Overridable Sub ResetDelimiters
public:
virtual void ResetDelimiters()
abstract ResetDelimiters : unit -> unit
override ResetDelimiters : unit -> unit

Implements

IWordBreakResetDelimiters
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.ResetOutlineOptions Method

DisplayStringsResetOutlineOptions Method
Resets the OutlineOptions to its default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOutlineOptions()
Public Overridable Sub ResetOutlineOptions
public:
virtual void ResetOutlineOptions()
abstract ResetOutlineOptions : unit -> unit
override ResetOutlineOptions : unit -> unit

Implements

ICollapsableResetOutlineOptions
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.ResetTabStops Method

DisplayStringsResetTabStops Method
Resets the TabStops to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetTabStops()
Public Overridable Sub ResetTabStops
public:
virtual void ResetTabStops()
abstract ResetTabStops : unit -> unit
override ResetTabStops : unit -> unit

Implements

ITabulationResetTabStops
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.ResetUseSpaces Method

DisplayStringsResetUseSpaces Method
Resets the UseSpaces to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUseSpaces()
Public Overridable Sub ResetUseSpaces
public:
virtual void ResetUseSpaces()
abstract ResetUseSpaces : unit -> unit
override ResetUseSpaces : unit -> unit

Implements

ITabulationResetUseSpaces
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.ResetWordWrap Method

DisplayStringsResetWordWrap Method
Resets the WordWrap to its default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetWordWrap()
Public Overridable Sub ResetWordWrap
public:
virtual void ResetWordWrap()
abstract ResetWordWrap : unit -> unit
override ResetWordWrap : unit -> unit

Implements

IWordWrapResetWordWrap
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.ResetWrapAtMargin Method

DisplayStringsResetWrapAtMargin Method
Resets the WrapAtMargin to its default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetWrapAtMargin()
Public Overridable Sub ResetWrapAtMargin
public:
virtual void ResetWrapAtMargin()
abstract ResetWrapAtMargin : unit -> unit
override ResetWrapAtMargin : unit -> unit

Implements

IWordWrapResetWrapAtMargin
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.SaveFile Method

DisplayStringsSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | Saves content to the specific file in the text format.
Public method | SaveFile(String, IStringExport) | Saves content to the specific file in the specific format.
Public method | SaveFile(String, Encoding) | Saves content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves content to the specific file in the specific format with specific encoding.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.SaveFile Method (String)

DisplayStringsSaveFile Method (String)
Saves content to the specific file in the text format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName
)
Public Overridable Function SaveFile (
    fileName As String
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> bool
override SaveFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of the file to save content.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IExportSaveFile(String)
See Also

Reference

DisplayStrings Class
SaveFile Overload
Alternet.Editor Namespace


DisplayStrings.SaveFile Method (String, IStringExport)

DisplayStringsSaveFile Method (String, IStringExport)
Saves content to the specific file in the specific format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    IStringExport exporter
)
Public Overridable Function SaveFile (
    fileName As String,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    IStringExport^ exporter
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport -> bool
override SaveFile :
        fileName : string *
        exporter : IStringExport -> bool

Parameters

fileName
Type: SystemString
Name of the file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ITextExportSaveFile(String, IStringExport)
See Also

Reference

DisplayStrings Class
SaveFile Overload
Alternet.Editor Namespace


DisplayStrings.SaveFile Method (String, Encoding)

DisplayStringsSaveFile Method (String, Encoding)
Saves content to the specific file with specific encoding.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of the file to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IExportSaveFile(String, Encoding)
See Also

Reference

DisplayStrings Class
SaveFile Overload
Alternet.Editor Namespace


DisplayStrings.SaveFile Method (String, IStringExport, Encoding)

DisplayStringsSaveFile Method (String, IStringExport, Encoding)
Saves content to the specific file in the specific format with specific encoding.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    IStringExport exporter,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of the file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ITextExportSaveFile(String, IStringExport, Encoding)
See Also

Reference

DisplayStrings Class
SaveFile Overload
Alternet.Editor Namespace


DisplayStrings.SaveStream Method

DisplayStringsSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | Saves content to the specific stream in the text format.
Public method | SaveStream(TextWriter) | Saves content to the specific stream in the text format.
Public method | SaveStream(Stream, IStringExport) | Saves content to the specific stream in the specific format.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves content to the specific stream in the specific format and specific encoding.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.SaveStream Method (Stream)

DisplayStringsSaveStream Method (Stream)
Saves content to the specific stream in the text format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream
)
Public Overridable Function SaveStream (
    stream As Stream
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream
)
abstract SaveStream :
        stream : Stream -> bool
override SaveStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IExportSaveStream(Stream)
See Also

Reference

DisplayStrings Class
SaveStream Overload
Alternet.Editor Namespace


DisplayStrings.SaveStream Method (TextWriter)

DisplayStringsSaveStream Method (TextWriter)
Saves content to the specific stream in the text format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer
)
Public Overridable Function SaveStream (
    writer As TextWriter
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer
)
abstract SaveStream :
        writer : TextWriter -> bool
override SaveStream :
        writer : TextWriter -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IExportSaveStream(TextWriter)
See Also

Reference

DisplayStrings Class
SaveStream Overload
Alternet.Editor Namespace


DisplayStrings.SaveStream Method (Stream, IStringExport)

DisplayStringsSaveStream Method (Stream, IStringExport)
Saves content to the specific stream in the specific format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    IStringExport exporter
)
Public Overridable Function SaveStream (
    stream As Stream,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport -> bool
override SaveStream :
        stream : Stream *
        exporter : IStringExport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ITextExportSaveStream(Stream, IStringExport)
See Also

Reference

DisplayStrings Class
SaveStream Overload
Alternet.Editor Namespace


DisplayStrings.SaveStream Method (Stream, Encoding)

DisplayStringsSaveStream Method (Stream, Encoding)
Saves the text content to the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream, Encoding)
See Also

Reference

DisplayStrings Class
SaveStream Overload
Alternet.Editor Namespace


DisplayStrings.SaveStream Method (TextWriter, IStringExport)

DisplayStringsSaveStream Method (TextWriter, IStringExport)
Saves the text content to the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer,
    IStringExport exporter
)
Public Overridable Function SaveStream (
    writer As TextWriter,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer,
    IStringExport^ exporter
)
abstract SaveStream :
        writer : TextWriter *
        exporter : IStringExport -> bool
override SaveStream :
        writer : TextWriter *
        exporter : IStringExport -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveStream(TextWriter, IStringExport)
See Also

Reference

DisplayStrings Class
SaveStream Overload
Alternet.Editor Namespace


DisplayStrings.SaveStream Method (Stream, IStringExport, Encoding)

DisplayStringsSaveStream Method (Stream, IStringExport, Encoding)
Saves content to the specific stream in the specific format and specific encoding.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    IStringExport exporter,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ITextExportSaveStream(Stream, IStringExport, Encoding)
See Also

Reference

DisplayStrings Class
SaveStream Overload
Alternet.Editor Namespace


DisplayStrings.SetOutlineRanges Method

DisplayStringsSetOutlineRanges Method
Overload List
 | Name | Description
Public method | SetOutlineRanges(IListIRange) | Updates IOutlineRange collection from given list of ranges.
Public method | SetOutlineRanges(IListIRange, Boolean) | Updates IOutlineRange collection from given list of ranges.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.SetOutlineRanges Method (IList(IRange))

DisplayStringsSetOutlineRanges Method (IListIRange)
Updates IOutlineRange collection from given list of ranges.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetOutlineRanges(
    IList<IRange> ranges
)
Public Overridable Sub SetOutlineRanges (
    ranges As IList(Of IRange)
)
public:
virtual void SetOutlineRanges(
    IList<IRange^>^ ranges
)
abstract SetOutlineRanges :
        ranges : IList<IRange> -> unit
override SetOutlineRanges :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies new IOutlineRange collection to set.

Implements

ICollapsableSetOutlineRanges(IListIRange)
See Also

Reference

DisplayStrings Class
SetOutlineRanges Overload
Alternet.Editor Namespace


DisplayStrings.SetOutlineRanges Method (IList(IRange), Boolean)

DisplayStringsSetOutlineRanges Method (IListIRange, Boolean)
Updates IOutlineRange collection from given list of ranges.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetOutlineRanges(
    IList<IRange> ranges,
    bool preserveVisible
)
Public Overridable Sub SetOutlineRanges (
    ranges As IList(Of IRange),
    preserveVisible As Boolean
)
public:
virtual void SetOutlineRanges(
    IList<IRange^>^ ranges,
    bool preserveVisible
)
abstract SetOutlineRanges :
        ranges : IList<IRange> *
        preserveVisible : bool -> unit
override SetOutlineRanges :
        ranges : IList<IRange> *
        preserveVisible : bool -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies new IOutlineRange collection to set.
preserveVisible
Type: SystemBoolean
Indicates whether new ranges should preserve collapsed state of existing outline sections.

Implements

ICollapsableSetOutlineRanges(IListIRange, Boolean)
See Also

Reference

DisplayStrings Class
SetOutlineRanges Overload
Alternet.Editor Namespace


DisplayStrings.TabPosToPos Method

DisplayStringsTabPosToPos Method
Returns specified position within given string as untabbed position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int TabPosToPos(
    string s,
    int pos
)
Public Overridable Function TabPosToPos (
    s As String,
    pos As Integer
) As Integer
public:
virtual int TabPosToPos(
    String^ s,
    int pos
)
abstract TabPosToPos :
        s : string *
        pos : int -> int
override TabPosToPos :
        s : string *
        pos : int -> int

Parameters

s
Type: SystemString
Specifies string to convert.
pos
Type: SystemInt32
Specifies index of character which position should be converted.

Return Value

Type: Int32
Untabbed position.

Implements

ITabulationTabPosToPos(String, Int32)
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.ToggleOutlining Method

DisplayStringsToggleOutlining Method
Overload List
 | Name | Description
Public method | ToggleOutlining | Toggles expanded state for current outline sections.
Public method | ToggleOutlining(IListIRange, IOutlineRange) | Toggles expanded state for given IOutlineRange collection.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.ToggleOutlining Method

DisplayStringsToggleOutlining Method
Toggles expanded state for current outline sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleOutlining()
Public Overridable Sub ToggleOutlining
public:
virtual void ToggleOutlining()
abstract ToggleOutlining : unit -> unit
override ToggleOutlining : unit -> unit

Implements

ICollapsableToggleOutlining
Remarks
If there is no outline section at the current point, method does nothing, otherwise it changes collapsed state of the section to the expanded and vice versa.
See Also

Reference

DisplayStrings Class
ToggleOutlining Overload
Alternet.Editor Namespace


DisplayStrings.ToggleOutlining Method (IList(IRange), IOutlineRange)

DisplayStringsToggleOutlining Method (IListIRange, IOutlineRange)
Toggles expanded state for given IOutlineRange collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleOutlining(
    IList<IRange> ranges,
    IOutlineRange range
)
Public Overridable Sub ToggleOutlining (
    ranges As IList(Of IRange),
    range As IOutlineRange
)
public:
virtual void ToggleOutlining(
    IList<IRange^>^ ranges,
    IOutlineRange^ range
)
abstract ToggleOutlining :
        ranges : IList<IRange> *
        range : IOutlineRange -> unit
override ToggleOutlining :
        ranges : IList<IRange> *
        range : IOutlineRange -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies IOutlineRange collection to toggle.
range
Type: Alternet.SyntaxIOutlineRange
IOutlineRange object representing current outline section. The method expands or collapses ranges depending on collapsed state of the Range.

Implements

ICollapsableToggleOutlining(IListIRange, IOutlineRange)
See Also

Reference

DisplayStrings Class
ToggleOutlining Overload
Alternet.Editor Namespace


DisplayStrings.UnOutline Method

DisplayStringsUnOutline Method
Overload List
 | Name | Description
Public method | UnOutline | This method removes all outlined section within the DisplayStrings collection.
Public method | UnOutline(Point) | This method removes outlined section at the specific position.
Public method | UnOutline(Int32) | This method removes all outlined section containing the given line.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.UnOutline Method

DisplayStringsUnOutline Method
This method removes all outlined section within the DisplayStrings collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnOutline()
Public Sub UnOutline
public:
virtual void UnOutline() sealed
abstract UnOutline : unit -> unit
override UnOutline : unit -> unit

Implements

ICollapsableUnOutline
See Also

Reference

DisplayStrings Class
UnOutline Overload
Alternet.Editor Namespace


DisplayStrings.UnOutline Method (Point)

DisplayStringsUnOutline Method (Point)
This method removes outlined section at the specific position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnOutline(
    Point position
)
Public Overridable Sub UnOutline (
    position As Point
)
public:
virtual void UnOutline(
    Point position
)
abstract UnOutline :
        position : Point -> unit
override UnOutline :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position in text coordinates.

Implements

ICollapsableUnOutline(Point)
See Also

Reference

DisplayStrings Class
UnOutline Overload
Alternet.Editor Namespace


DisplayStrings.UnOutline Method (Int32)

DisplayStringsUnOutline Method (Int32)
This method removes all outlined section containing the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnOutline(
    int index
)
Public Overridable Sub UnOutline (
    index As Integer
)
public:
virtual void UnOutline(
    int index
)
abstract UnOutline :
        index : int -> unit
override UnOutline :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies line in text coordinates.

Implements

ICollapsableUnOutline(Int32)
See Also

Reference

DisplayStrings Class
UnOutline Overload
Alternet.Editor Namespace


DisplayStrings.Update Method

DisplayStringsUpdate Method
When implemented by a class, updates an object state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.UpdateHiddenLines Method

DisplayStringsUpdateHiddenLines Method
Updates outline ranges for the hidden lines

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateHiddenLines()
Public Overridable Sub UpdateHiddenLines
public:
virtual void UpdateHiddenLines()
abstract UpdateHiddenLines : unit -> unit
override UpdateHiddenLines : unit -> unit

Implements

IDisplayStringsUpdateHiddenLines
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.UpdateNeeded Method

DisplayStringsUpdateNeeded Method
Forces IDisplayStrings to recalculate its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateNeeded()
Public Overridable Sub UpdateNeeded
public:
virtual void UpdateNeeded()
abstract UpdateNeeded : unit -> unit
override UpdateNeeded : unit -> unit

Implements

IDisplayStringsUpdateNeeded
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.UpdateWordWrap Method

DisplayStringsUpdateWordWrap Method
Overload List
 | Name | Description
Public method | UpdateWordWrap | Re-wraps all lines in DisplayStrings collection.
Public method | UpdateWordWrap(Int32, Int32) | Updates wrapped lines within specific scope in DisplayStrings object.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.UpdateWordWrap Method

DisplayStringsUpdateWordWrap Method
Re-wraps all lines in DisplayStrings collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateWordWrap()
Public Overridable Function UpdateWordWrap As Boolean
public:
virtual bool UpdateWordWrap()
abstract UpdateWordWrap : unit -> bool
override UpdateWordWrap : unit -> bool

Return Value

Type: Boolean
True if succeed otherwise false.

Implements

IWordWrapUpdateWordWrap
See Also

Reference

DisplayStrings Class
UpdateWordWrap Overload
Alternet.Editor Namespace


DisplayStrings.UpdateWordWrap Method (Int32, Int32)

DisplayStringsUpdateWordWrap Method (Int32, Int32)
Updates wrapped lines within specific scope in DisplayStrings object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateWordWrap(
    int first,
    int last
)
Public Overridable Function UpdateWordWrap (
    first As Integer,
    last As Integer
) As Boolean
public:
virtual bool UpdateWordWrap(
    int first,
    int last
)
abstract UpdateWordWrap :
        first : int *
        last : int -> bool
override UpdateWordWrap :
        first : int *
        last : int -> bool

Parameters

first
Type: SystemInt32
Specifies first line to wrap.
last
Type: SystemInt32
Specifies first line to wrap.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IWordWrapUpdateWordWrap(Int32, Int32)
See Also

Reference

DisplayStrings Class
UpdateWordWrap Overload
Alternet.Editor Namespace


DisplayStrings Properties

DisplayStrings Properties

The DisplayStrings type exposes the following members.

Properties
 | Name | Description
Public property | AllowHiddenLines | Gets or sets a value indicating whether hidden lines are enabled.
Public property | AllowOutlining | Gets or sets a value indicating whether outlining is enabled.
Public property | CollapsedCount | Returns number of collapsed sections.
Public property | Count | Returns number of visible lines.
Public property | Delimiters | Gets or sets an array of chars used to separate words in a text.
Public property | DelimiterString | Gets or sets Delimiters as a single string.
Public property | DisplayCount | Returns number of visible lines.
Public property | IgnoreWhiteSpace | Gets or sets boolean value indicating if white space styles are suppressed.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | Item | Provides an indexed access to individual string stored in the collection.
Public property | LineEnd | When implemented by a class, gets or sets boolean value indicating if the text position can be set to the end of the wrapped line.
Public property | Lines | Gets or sets the collection of underlying "real" collection of text lines.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | Loaded | Gets or sets boolean value indicating if the display strings was fully formatted.
Public property | MaxLineWidth | Gets width of the largest line in the DisplayString object.
Public property | OutlineOptions | Gets or sets options representing outlining appearance and behaviour.
Public property | SuppressTabs | Gets or sets boolean value indicating if conversion from tabs to spaces is suppressed.
Public property | TabStops | Gets or sets the character columns that the cursor will move to each time you press Tab.
Public property | Text | Gets or sets the strings in the IDisplayStrings as a single string with the individual strings delimited by carriage returns.
Public property | UpdateCount | Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested.
Public property | UseSpaces | Gets or sets a value indicating whether indent operations insert space characters rather than TAB characters.
Public property | WordWrap | Gets or sets a value indicating whether a DisplayStrings object automatically wraps words to the beginning of the next line when necessary.
Public property | WrapAtMargin | Gets or sets a value indicating whether a DisplayStrings object automatically wraps words at margin position.
Public property | WrapMargin | Gets position of the wrap margin.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.AllowHiddenLines Property

DisplayStringsAllowHiddenLines Property
Gets or sets a value indicating whether hidden lines are enabled.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AllowHiddenLines { get; set; }
Public Overridable Property AllowHiddenLines As Boolean
    Get
    Set
public:
virtual property bool AllowHiddenLines {
    bool get ();
    void set (bool value);
}
abstract AllowHiddenLines : bool with get, set
override AllowHiddenLines : bool with get, set

Property Value

Type: Boolean

Implements

IDisplayStringsAllowHiddenLines
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.AllowOutlining Property

DisplayStringsAllowOutlining Property
Gets or sets a value indicating whether outlining is enabled.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AllowOutlining { get; set; }
Public Overridable Property AllowOutlining As Boolean
    Get
    Set
public:
virtual property bool AllowOutlining {
    bool get ();
    void set (bool value);
}
abstract AllowOutlining : bool with get, set
override AllowOutlining : bool with get, set

Property Value

Type: Boolean

Implements

ICollapsableAllowOutlining
Remarks
Setting this property to false causes removing all outline sections.
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.CollapsedCount Property

DisplayStringsCollapsedCount Property
Returns number of collapsed sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CollapsedCount { get; }
Public Overridable ReadOnly Property CollapsedCount As Integer
    Get
public:
virtual property int CollapsedCount {
    int get ();
}
abstract CollapsedCount : int with get
override CollapsedCount : int with get

Property Value

Type: Int32

Implements

ICollapsableCollapsedCount
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Count Property

DisplayStringsCount Property
Returns number of visible lines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Delimiters Property

DisplayStringsDelimiters Property
Gets or sets an array of chars used to separate words in a text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] Delimiters { get; set; }
Public Overridable Property Delimiters As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ Delimiters {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract Delimiters : char[] with get, set
override Delimiters : char[] with get, set

Property Value

Type: Char

Implements

IWordBreakDelimiters
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.DelimiterString Property

DisplayStringsDelimiterString Property
Gets or sets Delimiters as a single string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DelimiterString { get; set; }
Public Overridable Property DelimiterString As String
    Get
    Set
public:
virtual property String^ DelimiterString {
    String^ get ();
    void set (String^ value);
}
abstract DelimiterString : string with get, set
override DelimiterString : string with get, set

Property Value

Type: String

Implements

IWordBreakDelimiterString
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.DisplayCount Property

DisplayStringsDisplayCount Property
Returns number of visible lines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisplayCount { get; }
Public Overridable ReadOnly Property DisplayCount As Integer
    Get
public:
virtual property int DisplayCount {
    int get ();
}
abstract DisplayCount : int with get
override DisplayCount : int with get

Property Value

Type: Int32

Implements

IDisplayStringsDisplayCount
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.IgnoreWhiteSpace Property

DisplayStringsIgnoreWhiteSpace Property
Gets or sets boolean value indicating if white space styles are suppressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IgnoreWhiteSpace { get; set; }
Public Overridable Property IgnoreWhiteSpace As Boolean
    Get
    Set
public:
virtual property bool IgnoreWhiteSpace {
    bool get ();
    void set (bool value);
}
abstract IgnoreWhiteSpace : bool with get, set
override IgnoreWhiteSpace : bool with get, set

Property Value

Type: Boolean

Implements

IDisplayStringsIgnoreWhiteSpace
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.IsReadOnly Property

DisplayStringsIsReadOnly Property
Gets a value indicating whether the collection is read-only.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Item Property

DisplayStringsItem Property
Provides an indexed access to individual string stored in the collection.
Provides an indexed access to individual strings stored in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As String
    Get
    Set
public:
virtual property String^ default[int index] {
    String^ get (int index);
    void set (int index, String^ value);
}
abstract Item : string with get, set
override Item : string with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: String

Implements

IDisplayStringsItemInt32
IListTItemInt32
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.LineEnd Property

DisplayStringsLineEnd Property
When implemented by a class, gets or sets boolean value indicating if the text position can be set to the end of the wrapped line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LineEnd { get; set; }
Public Overridable Property LineEnd As Boolean
    Get
    Set
public:
virtual property bool LineEnd {
    bool get ();
    void set (bool value);
}
abstract LineEnd : bool with get, set
override LineEnd : bool with get, set

Property Value

Type: Boolean

Implements

IDisplayStringsLineEnd
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Lines Property

DisplayStringsLines Property
Gets or sets the collection of underlying "real" collection of text lines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ITextStrings Lines { get; set; }
Public Overridable Property Lines As ITextStrings
    Get
    Set
public:
virtual property ITextStrings^ Lines {
    ITextStrings^ get ();
    void set (ITextStrings^ value);
}
abstract Lines : ITextStrings with get, set
override Lines : ITextStrings with get, set

Property Value

Type: ITextStrings

Implements

IDisplayStringsLines
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.LineTerminator Property

DisplayStringsLineTerminator Property
Gets or sets a string value that terminates line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string LineTerminator { get; set; }
Public Overridable Property LineTerminator As String
    Get
    Set
public:
virtual property String^ LineTerminator {
    String^ get ();
    void set (String^ value);
}
abstract LineTerminator : string with get, set
override LineTerminator : string with get, set

Property Value

Type: String

Implements

ITextExportLineTerminator
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Loaded Property

DisplayStringsLoaded Property
Gets or sets boolean value indicating if the display strings was fully formatted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Loaded { get; set; }
Public Overridable Property Loaded As Boolean
    Get
    Set
public:
virtual property bool Loaded {
    bool get ();
    void set (bool value);
}
abstract Loaded : bool with get, set
override Loaded : bool with get, set

Property Value

Type: Boolean

Implements

IDisplayStringsLoaded
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.MaxLineWidth Property

DisplayStringsMaxLineWidth Property
Gets width of the largest line in the DisplayString object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MaxLineWidth { get; }
Public Overridable ReadOnly Property MaxLineWidth As Integer
    Get
public:
virtual property int MaxLineWidth {
    int get ();
}
abstract MaxLineWidth : int with get
override MaxLineWidth : int with get

Property Value

Type: Int32

Implements

IDisplayStringsMaxLineWidth
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.OutlineOptions Property

DisplayStringsOutlineOptions Property
Gets or sets options representing outlining appearance and behaviour.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual OutlineOptions OutlineOptions { get; set; }
Public Overridable Property OutlineOptions As OutlineOptions
    Get
    Set
public:
virtual property OutlineOptions OutlineOptions {
    OutlineOptions get ();
    void set (OutlineOptions value);
}
abstract OutlineOptions : OutlineOptions with get, set
override OutlineOptions : OutlineOptions with get, set

Property Value

Type: OutlineOptions

Implements

ICollapsableOutlineOptions
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace
Alternet.EditorOutlineOptions


DisplayStrings.SuppressTabs Property

DisplayStringsSuppressTabs Property
Gets or sets boolean value indicating if conversion from tabs to spaces is suppressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SuppressTabs { get; set; }
Public Overridable Property SuppressTabs As Boolean
    Get
    Set
public:
virtual property bool SuppressTabs {
    bool get ();
    void set (bool value);
}
abstract SuppressTabs : bool with get, set
override SuppressTabs : bool with get, set

Property Value

Type: Boolean

Implements

IDisplayStringsSuppressTabs
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.TabStops Property

DisplayStringsTabStops Property
Gets or sets the character columns that the cursor will move to each time you press Tab.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int[] TabStops { get; set; }
Public Overridable Property TabStops As Integer()
    Get
    Set
public:
virtual property array<int>^ TabStops {
    array<int>^ get ();
    void set (array<int>^ value);
}
abstract TabStops : int[] with get, set
override TabStops : int[] with get, set

Property Value

Type: Int32

Implements

ITabulationTabStops
Remarks
If each successive tab stop is not larger than its predecessor, you will receive an error.
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Text Property

DisplayStringsText Property
Gets or sets the strings in the IDisplayStrings as a single string with the individual strings delimited by carriage returns.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

IStringListText
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.UpdateCount Property

DisplayStringsUpdateCount Property
Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.UseSpaces Property

DisplayStringsUseSpaces Property
Gets or sets a value indicating whether indent operations insert space characters rather than TAB characters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UseSpaces { get; set; }
Public Overridable Property UseSpaces As Boolean
    Get
    Set
public:
virtual property bool UseSpaces {
    bool get ();
    void set (bool value);
}
abstract UseSpaces : bool with get, set
override UseSpaces : bool with get, set

Property Value

Type: Boolean

Implements

ITabulationUseSpaces
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.WordWrap Property

DisplayStringsWordWrap Property
Gets or sets a value indicating whether a DisplayStrings object automatically wraps words to the beginning of the next line when necessary.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool WordWrap { get; set; }
Public Overridable Property WordWrap As Boolean
    Get
    Set
public:
virtual property bool WordWrap {
    bool get ();
    void set (bool value);
}
abstract WordWrap : bool with get, set
override WordWrap : bool with get, set

Property Value

Type: Boolean

Implements

IWordWrapWordWrap
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.WrapAtMargin Property

DisplayStringsWrapAtMargin Property
Gets or sets a value indicating whether a DisplayStrings object automatically wraps words at margin position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool WrapAtMargin { get; set; }
Public Overridable Property WrapAtMargin As Boolean
    Get
    Set
public:
virtual property bool WrapAtMargin {
    bool get ();
    void set (bool value);
}
abstract WrapAtMargin : bool with get, set
override WrapAtMargin : bool with get, set

Property Value

Type: Boolean

Implements

IWordWrapWrapAtMargin
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.WrapMargin Property

DisplayStringsWrapMargin Property
Gets position of the wrap margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int WrapMargin { get; }
Public Overridable ReadOnly Property WrapMargin As Integer
    Get
public:
virtual property int WrapMargin {
    int get ();
}
abstract WrapMargin : int with get
override WrapMargin : int with get

Property Value

Type: Int32

Implements

IWordWrapWrapMargin
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings Events

DisplayStrings Events

The DisplayStrings type exposes the following members.

Events
 | Name | Description
Public event | Collapsing | Occurs when user attempts expand outline section.
Public event | Expanding | Occurs when user attempts expand outline section.
Top
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Collapsing Event

DisplayStringsCollapsing Event
Occurs when user attempts expand outline section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event OutlineEvent Collapsing
Public Event Collapsing As OutlineEvent
public:
virtual  event OutlineEvent^ Collapsing {
    void add (OutlineEvent^ value);
    void remove (OutlineEvent^ value);
}
abstract Collapsing : IEvent<OutlineEvent,
    OutlineEventArgs>
override Collapsing : IEvent<OutlineEvent,
    OutlineEventArgs>

Value

Type: Alternet.EditorOutlineEvent

Implements

ICollapsableCollapsing
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DisplayStrings.Expanding Event

DisplayStringsExpanding Event
Occurs when user attempts expand outline section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event OutlineEvent Expanding
Public Event Expanding As OutlineEvent
public:
virtual  event OutlineEvent^ Expanding {
    void add (OutlineEvent^ value);
    void remove (OutlineEvent^ value);
}
abstract Expanding : IEvent<OutlineEvent,
    OutlineEventArgs>
override Expanding : IEvent<OutlineEvent,
    OutlineEventArgs>

Value

Type: Alternet.EditorOutlineEvent

Implements

ICollapsableExpanding
See Also

Reference

DisplayStrings Class
Alternet.Editor Namespace


DrawHeaderEvent Delegate

DrawHeaderEvent Delegate
Represents a method that will handle the SyntaxEdit.DrawHeader, EditPages.DrawHeader or CodeCompletionHint.CustomDraw events.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void DrawHeaderEvent(
    Object sender,
    DrawHeaderEventArgs e
)
Public Delegate Sub DrawHeaderEvent (
    sender As Object,
    e As DrawHeaderEventArgs
)
public delegate void DrawHeaderEvent(
    Object^ sender,
    DrawHeaderEventArgs^ e
)
type DrawHeaderEvent =
    delegate of
        sender : Object *
        e : DrawHeaderEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorDrawHeaderEventArgs
A DrawHeaderEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


DrawHeaderEventArgs Class

DrawHeaderEventArgs Class
Provides data for the DrawHeaderEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorDrawHeaderEventArgs
Alternet.EditorDrawUserMarginEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DrawHeaderEventArgs : EventArgs
Public Class DrawHeaderEventArgs
    Inherits EventArgs
public ref class DrawHeaderEventArgs : public EventArgs
type DrawHeaderEventArgs =
    class
        inherit EventArgs
    end

The DrawHeaderEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DrawHeaderEventArgs | Initializes a new instance of the DrawHeaderEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Handled | Represents a value indicating whether draw header event is handled.
Public property | Tag | String containing formatting elements used to format DrawHeaderEventArgs.Text.
Public property | Text | String to replace formatting tag.
Top
See Also

Reference

Alternet.Editor Namespace


DrawHeaderEventArgs Constructor

DrawHeaderEventArgs Constructor
Initializes a new instance of the DrawHeaderEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DrawHeaderEventArgs(
    string tag
)
Public Sub New (
    tag As String
)
public:
DrawHeaderEventArgs(
    String^ tag
)
new :
        tag : string -> DrawHeaderEventArgs

Parameters

tag
Type: SystemString
String containing formatting element.
See Also

Reference

DrawHeaderEventArgs Class
Alternet.Editor Namespace


DrawHeaderEventArgs Methods

DrawHeaderEventArgs Methods

The DrawHeaderEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DrawHeaderEventArgs Class
Alternet.Editor Namespace


DrawHeaderEventArgs Properties

DrawHeaderEventArgs Properties

The DrawHeaderEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Represents a value indicating whether draw header event is handled.
Public property | Tag | String containing formatting elements used to format DrawHeaderEventArgs.Text.
Public property | Text | String to replace formatting tag.
Top
See Also

Reference

DrawHeaderEventArgs Class
Alternet.Editor Namespace


DrawHeaderEventArgs.Handled Property

DrawHeaderEventArgsHandled Property
Represents a value indicating whether draw header event is handled.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DrawHeaderEventArgs Class
Alternet.Editor Namespace


DrawHeaderEventArgs.Tag Property

DrawHeaderEventArgsTag Property
String containing formatting elements used to format DrawHeaderEventArgs.Text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Tag { get; set; }
Public Property Tag As String
    Get
    Set
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}
member Tag : string with get, set

Property Value

Type: String
See Also

Reference

DrawHeaderEventArgs Class
Alternet.Editor Namespace


DrawHeaderEventArgs.Text Property

DrawHeaderEventArgsText Property
String to replace formatting tag.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

DrawHeaderEventArgs Class
Alternet.Editor Namespace


DrawInfo Class

DrawInfo Class
Contains full information about text fragment to be drawn.
Inheritance Hierarchy
SystemObject
Alternet.EditorDrawInfo

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DrawInfo : IDrawInfo
Public Class DrawInfo
    Implements IDrawInfo
public ref class DrawInfo : IDrawInfo
type DrawInfo =
    class
        interface IDrawInfo
    end

The DrawInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DrawInfo | Initializes a new instance of the DrawInfo class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets DrawInfo members to their default values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Char | The starting character of the text fragment.
Public property | GutterImage | Specifies index of the image drawn on the gutter.
Public property | Line | The index of line in the text.
Public property | Page | Specifies index of page containing the text to be drawn.
Public property | Selection | Specifies whether text fragment is selected.
Public property | Style | Represents index of lexical style used to draw this text fragment.
Public property | Text | String to draw.
Public property | TextStyle | Contains TextStyle information for this text fragment.
Top
See Also

Reference

Alternet.Editor Namespace


DrawInfo Constructor

DrawInfo Constructor
Initializes a new instance of the DrawInfo class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DrawInfo()
Public Sub New
public:
DrawInfo()
new : unit -> DrawInfo
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo Methods

DrawInfo Methods

The DrawInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets DrawInfo members to their default values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo.Reset Method

DrawInfoReset Method
Resets DrawInfo members to their default values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IDrawInfoReset
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo Properties

DrawInfo Properties

The DrawInfo type exposes the following members.

Properties
 | Name | Description
Public property | Char | The starting character of the text fragment.
Public property | GutterImage | Specifies index of the image drawn on the gutter.
Public property | Line | The index of line in the text.
Public property | Page | Specifies index of page containing the text to be drawn.
Public property | Selection | Specifies whether text fragment is selected.
Public property | Style | Represents index of lexical style used to draw this text fragment.
Public property | Text | String to draw.
Public property | TextStyle | Contains TextStyle information for this text fragment.
Top
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo.Char Property

DrawInfoChar Property
The starting character of the text fragment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Char { get; set; }
Public Property Char As Integer
    Get
    Set
public:
virtual property int Char {
    int get () sealed;
    void set (int value) sealed;
}
abstract Char : int with get, set
override Char : int with get, set

Property Value

Type: Int32

Implements

IDrawInfoChar
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo.GutterImage Property

DrawInfoGutterImage Property
Specifies index of the image drawn on the gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GutterImage { get; set; }
Public Property GutterImage As Integer
    Get
    Set
public:
virtual property int GutterImage {
    int get () sealed;
    void set (int value) sealed;
}
abstract GutterImage : int with get, set
override GutterImage : int with get, set

Property Value

Type: Int32

Implements

IDrawInfoGutterImage
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo.Line Property

DrawInfoLine Property
The index of line in the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
virtual property int Line {
    int get () sealed;
    void set (int value) sealed;
}
abstract Line : int with get, set
override Line : int with get, set

Property Value

Type: Int32

Implements

IDrawInfoLine
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo.Page Property

DrawInfoPage Property
Specifies index of page containing the text to be drawn.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Page { get; set; }
Public Property Page As Integer
    Get
    Set
public:
virtual property int Page {
    int get () sealed;
    void set (int value) sealed;
}
abstract Page : int with get, set
override Page : int with get, set

Property Value

Type: Int32

Implements

IDrawInfoPage
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo.Selection Property

DrawInfoSelection Property
Specifies whether text fragment is selected.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Selection { get; set; }
Public Property Selection As Boolean
    Get
    Set
public:
virtual property bool Selection {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Selection : bool with get, set
override Selection : bool with get, set

Property Value

Type: Boolean

Implements

IDrawInfoSelection
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo.Style Property

DrawInfoStyle Property
Represents index of lexical style used to draw this text fragment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringItemInfo Style { get; set; }
Public Property Style As StringItemInfo
    Get
    Set
public:
virtual property StringItemInfo Style {
    StringItemInfo get () sealed;
    void set (StringItemInfo value) sealed;
}
abstract Style : StringItemInfo with get, set
override Style : StringItemInfo with get, set

Property Value

Type: StringItemInfo

Implements

IDrawInfoStyle
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo.Text Property

DrawInfoText Property
String to draw.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

IDrawInfoText
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawInfo.TextStyle Property

DrawInfoTextStyle Property
Contains TextStyle information for this text fragment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextStyle TextStyle { get; set; }
Public Property TextStyle As TextStyle
    Get
    Set
public:
virtual property TextStyle TextStyle {
    TextStyle get () sealed;
    void set (TextStyle value) sealed;
}
abstract TextStyle : TextStyle with get, set
override TextStyle : TextStyle with get, set

Property Value

Type: TextStyle

Implements

IDrawInfoTextStyle
See Also

Reference

DrawInfo Class
Alternet.Editor Namespace


DrawStage Enumeration

DrawStage Enumeration
DrawState is used to specify a stage in the custom drawing process.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DrawStage
Public Enumeration DrawStage
public enum class DrawStage
type DrawStage
Members
Member name | Value | Description
Before | 0 | After painting.
After | 1 | Before painting.
See Also

Reference

Alternet.Editor Namespace


DrawState Enumeration

DrawState Enumeration
DrawState is used to specify a custom drawing state, including information about elements of the control currently drawn. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum DrawState
<FlagsAttribute>
Public Enumeration DrawState
[FlagsAttribute]
public enum class DrawState
[<FlagsAttribute>]
type DrawState
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Control | 1 | Entire control is currently drawing.
Text | 2 | Text fragment is currently drawing.
Selection | 4 | Text currently drawn is selected.
WhiteSpace | 8 | WhiteSpace is currently drawing.
LineHighlight | 16 | Line highlighter is currently drawing.
LineSeparator | 32 | Line separator is currently drawing.
LineBookMark | 64 | Line bookmark is currently drawing.
Brace | 128 | Brace is currently drawing.
BeyondEol | 256 | Space after end of line is currently drawing.
BeyondEof | 512 | Space after end of file is currently drawing.
Gutter | 1024 | Gutter area is currently drawing.
GutterImage | 2048 | Gutter bookmark or other gutter image is currently drawing.
BookMark | 4096 | Bookmark is currently drawing.
LineNumber | 8192 | Line number are currently drawing.
OutlineArea | 16384 | Outline area is currently drawing.
OutlineImage | 32768 | Outline image (plus/minus button) is currently drawing.
OutlineButton | 65536 | Outline button is currently drawing.
LineModificator | 131072 | Line modificator is currently drawing.
Spelling | 262144 | Misspelled wavy line is currently drawing.
SyntaxError | 524288 | Syntax error wavy line is currently drawing.
Page | 1048576 | Edit page is currently drawing.
PageHeader | 2097152 | Page header is currently drawing.
PageBorder | 4194304 | Page border is currently drawing.
LineStyle | 8388608 | Line Style is currently drawing.
CodeSnippet | 16777216 | Code snippet is currently drawing.
UserMargin | 33554432 | User margin is currently drawing.
Warning | 67108864 | Warning wavy line is currently drawing.
Info | 134217728 | Info wavy line is currently drawing.
Reference | 268435456 | Symbol reference is currently drawing.
SearchResult | 536870912 | Search result is currently drawing.
See Also

Reference

Alternet.Editor Namespace


DrawUserMarginEvent Delegate

DrawUserMarginEvent Delegate
Represents a method that will handle the SyntaxEdit.DrawUserMargin, EditPages.DrawHeader event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void DrawUserMarginEvent(
    Object sender,
    DrawUserMarginEventArgs e
)
Public Delegate Sub DrawUserMarginEvent (
    sender As Object,
    e As DrawUserMarginEventArgs
)
public delegate void DrawUserMarginEvent(
    Object^ sender,
    DrawUserMarginEventArgs^ e
)
type DrawUserMarginEvent =
    delegate of
        sender : Object *
        e : DrawUserMarginEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorDrawUserMarginEventArgs
A DrawUserMarginArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


DrawUserMarginEventArgs Class

DrawUserMarginEventArgs Class
Provides data for the DrawUserMarginEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorDrawHeaderEventArgs
Alternet.EditorDrawUserMarginEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DrawUserMarginEventArgs : DrawHeaderEventArgs
Public Class DrawUserMarginEventArgs
    Inherits DrawHeaderEventArgs
public ref class DrawUserMarginEventArgs : public DrawHeaderEventArgs
type DrawUserMarginEventArgs =
    class
        inherit DrawHeaderEventArgs
    end

The DrawUserMarginEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DrawUserMarginEventArgs | Initializes a new instance of the DrawUserMarginEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Handled | Represents a value indicating whether draw header event is handled. (Inherited from DrawHeaderEventArgs.)
Public property | Line | Line number being drawn.
Public property | Tag | String containing formatting elements used to format DrawHeaderEventArgs.Text. (Inherited from DrawHeaderEventArgs.)
Public property | Text | String to replace formatting tag. (Inherited from DrawHeaderEventArgs.)
Top
See Also

Reference

Alternet.Editor Namespace


DrawUserMarginEventArgs Constructor

DrawUserMarginEventArgs Constructor
Initializes a new instance of the DrawUserMarginEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DrawUserMarginEventArgs(
    string tag,
    int line
)
Public Sub New (
    tag As String,
    line As Integer
)
public:
DrawUserMarginEventArgs(
    String^ tag,
    int line
)
new :
        tag : string *
        line : int -> DrawUserMarginEventArgs

Parameters

tag
Type: SystemString
String containing formatting element.
line
Type: SystemInt32
Line number being drawn.
See Also

Reference

DrawUserMarginEventArgs Class
Alternet.Editor Namespace


DrawUserMarginEventArgs Methods

DrawUserMarginEventArgs Methods

The DrawUserMarginEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DrawUserMarginEventArgs Class
Alternet.Editor Namespace


DrawUserMarginEventArgs Properties

DrawUserMarginEventArgs Properties

The DrawUserMarginEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Represents a value indicating whether draw header event is handled. (Inherited from DrawHeaderEventArgs.)
Public property | Line | Line number being drawn.
Public property | Tag | String containing formatting elements used to format DrawHeaderEventArgs.Text. (Inherited from DrawHeaderEventArgs.)
Public property | Text | String to replace formatting tag. (Inherited from DrawHeaderEventArgs.)
Top
See Also

Reference

DrawUserMarginEventArgs Class
Alternet.Editor Namespace


DrawUserMarginEventArgs.Line Property

DrawUserMarginEventArgsLine Property
Line number being drawn.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

DrawUserMarginEventArgs Class
Alternet.Editor Namespace


EditConsts Class

EditConsts Class
Contains default constants related to Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorEditConsts

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditConsts
Public Class EditConsts
public ref class EditConsts
type EditConsts =  class end

The EditConsts type exposes the following members.

Constructors
 | Name | Description
Public method | EditConsts | Initializes a new instance of the EditConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AnyBookMarkGroup |
CharsTag |
CodeCompletionModeDefaultValue |
ColumnSeparator |
DateTag |
DefaultAnnotationBookmarkColor |
DefaultAnnotationCursorPositionColor |
DefaultAnnotationCustomColor |
DefaultAnnotationSearchResultColor |
DefaultArrowBackColor |
DefaultArrowForeColor |
DefaultAutoCorrectDelimiters |
DefaultBookMarkImageIndex |
DefaultBorderStyle |
DefaultBracesBackColor |
DefaultBracesDelay |
DefaultBracesFontStyle |
DefaultBracesForeColor |
DefaultBulbImageIndex |
DefaultCaretWidth |
DefaultClosingBraces |
DefaultCodeCompletionBorderColor |
DefaultCodeCompletionBorderThickness |
DefaultCodeCompletionButtonHeight |
DefaultCodeCompletionButtonWidth |
DefaultCodeCompletionChars |
DefaultCodeCompletionFlags |
DefaultCodeCompletionFont |
DefaultCodeCompletionFontSize |
DefaultCollasedImageWidth |
DefaultColumnMarginPosition |
DefaultColumnSeparator |
DefaultColumnsIndentForeColor |
DefaultCommentsFontStyle |
DefaultCompletionStartDelay |
DefaultContentDividerColor |
DefaultDelimiters |
DefaultDisabledForeColor |
DefaultDragDelay |
DefaultDrawColumnsIndent |
DefaultDrawStructureGuideLines |
DefaultDropDownCount |
DefaultFont |
DefaultGuideLinesForeColor |
DefaultGutterBackColor |
DefaultGutterForeColor |
DefaultGutterOffset |
DefaultGutterOptions |
DefaultGutterWidth |
DefaultHeaderFontColor |
DefaultHeaderFontStyle |
DefaultHideHintDelay |
DefaultHighlightBackColor |
DefaultHighlightBlockAreaColor |
DefaultHighlightForeColor |
DefaultHighlightOutlineAreaColor |
DefaultHighlightRefDelay |
DefaultHintDelay |
DefaultHintOffsetX |
DefaultHintOffsetY |
DefaultHorzScrollDelta |
DefaultHorzScrollSize |
DefaultHyperTextForeColor |
DefaultInactiveHighlightBackColor |
DefaultInactiveHighlightForeColor |
DefaultIndentOptions |
DefaultInfoBackColor |
DefaultLineBookmarksColor |
DefaultLineModificatorChangedColor |
DefaultLineModificatorSavedColor |
DefaultLineModificatorWidth |
DefaultLineNumbersBackColor |
DefaultLineNumbersForeColor |
DefaultLineNumbersIndent |
DefaultLineNumbersStart |
DefaultLineSeparatorColor |
DefaultLineSeparatorLineColor |
DefaultLineStyleBackColor |
DefaultLineStyleForeColor |
DefaultLineStyleOptions |
DefaultMarginColumnForeColor |
DefaultMarginForeColor |
DefaultMarginHitWidth |
DefaultMarginPosition |
DefaultMinListBoxHeight |
DefaultMinListBoxWidth |
DefaultNavigateOptions |
DefaultOpenBraces |
DefaultOutlineDelay |
DefaultOutlineForeColor |
DefaultOutlineImageBackColor |
DefaultOutlineOptions |
DefaultOutlineText |
DefaultOutliningIndent |
DefaultPageBackColor |
DefaultPageBorderColor |
DefaultPageHorzOffset |
DefaultPageMargin |
DefaultPageMarginSize |
DefaultPageVertOffset |
DefaultParserDelta |
DefaultPrintHeaderForeColor |
DefaultPrintHeaderOffsetX |
DefaultPrintHeaderOffsetY |
DefaultPrintOptions |
DefaultReferencesDelay |
DefaultRowSeparator |
DefaultRulerBackColor |
DefaultRulerFontName |
DefaultRulerFontSize |
DefaultRulerHeight |
DefaultRulerHitWidth |
DefaultRulerIndentBackColor |
DefaultRulerIndentSize |
DefaultRulerMinWidth |
DefaultRulerOptions |
DefaultRulerUnits |
DefaultScrollBackgroundColor |
DefaultScrollDeltaRatio |
DefaultScrollingOptions |
DefaultScrollSplitterSize |
DefaultScrollThumbHoveredColor |
DefaultScrollThumbNormalColor |
DefaultScrollThumbPressedColor |
DefaultSearchOptions |
DefaultSearchResultLimit |
DefaultSelDelay |
DefaultSelectionBorderColor |
DefaultSelectionDragColor |
DefaultSelectionMode |
DefaultSelectionOptions |
DefaultSmoothScrollDelay |
DefaultSmoothScrollPause |
DefaultSmoothScrollSteps |
DefaultSnippetBackColor |
DefaultSnippetEndPattern |
DefaultSnippetPattern |
DefaultSnippetSelectedPattern |
DefaultSpacesInTab |
DefaultSpellDelimiters |
DefaultSpellForeColor |
DefaultTabStop |
DefaultThreadWaitTimeout |
DefaultTransparentColor |
DefaultUndoOptions |
DefaultUrlChars |
DefaultUrlFontStyle |
DefaultUrlForeColor |
DefaultUserMarginBackColor |
DefaultUserMarginForeColor |
DefaultUserMarginText |
DefaultUserMarginWidth |
DefaultWhiteSpaceForeColor |
DefaultWrapDelta |
DefaultWrapImageIndex |
DottedText |
EofSymbol |
EolSymbol |
FileProtocol |
FTPProtocol |
GopherProtocol |
HeaderFontName |
HTTPProtocol |
HTTPSProtocol |
LineTag |
LongSpaceSymbol |
MailTo |
MaxDropDownCount |
MaxFontSize |
MaxHintWindowCount |
MaxHintWindowWidth |
MaxPaintChar |
MaxScrollBarAnnotationsErrorsCount |
MinPageIndent |
NavKeys |
PagesTag |
PageTag |
SearchDialogAppearanceDefaultValue |
SpaceSymbol |
TabSymbol |
TimeTag |
UserTag |
WheelDelta |
WordWrapSymbol |
WWW |
Top
See Also

Reference

Alternet.Editor Namespace


EditConsts Constructor

EditConsts Constructor
Initializes a new instance of the EditConsts class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditConsts()
Public Sub New
public:
EditConsts()
new : unit -> EditConsts
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts Fields

EditConsts Fields

The EditConsts type exposes the following members.

Fields
Name | Description
AnyBookMarkGroup |
CharsTag |
CodeCompletionModeDefaultValue |
ColumnSeparator |
DateTag |
DefaultAnnotationBookmarkColor |
DefaultAnnotationCursorPositionColor |
DefaultAnnotationCustomColor |
DefaultAnnotationSearchResultColor |
DefaultArrowBackColor |
DefaultArrowForeColor |
DefaultAutoCorrectDelimiters |
DefaultBookMarkImageIndex |
DefaultBorderStyle |
DefaultBracesBackColor |
DefaultBracesDelay |
DefaultBracesFontStyle |
DefaultBracesForeColor |
DefaultBulbImageIndex |
DefaultCaretWidth |
DefaultClosingBraces |
DefaultCodeCompletionBorderColor |
DefaultCodeCompletionBorderThickness |
DefaultCodeCompletionButtonHeight |
DefaultCodeCompletionButtonWidth |
DefaultCodeCompletionChars |
DefaultCodeCompletionFlags |
DefaultCodeCompletionFont |
DefaultCodeCompletionFontSize |
DefaultCollasedImageWidth |
DefaultColumnMarginPosition |
DefaultColumnSeparator |
DefaultColumnsIndentForeColor |
DefaultCommentsFontStyle |
DefaultCompletionStartDelay |
DefaultContentDividerColor |
DefaultDelimiters |
DefaultDisabledForeColor |
DefaultDragDelay |
DefaultDrawColumnsIndent |
DefaultDrawStructureGuideLines |
DefaultDropDownCount |
DefaultFont |
DefaultGuideLinesForeColor |
DefaultGutterBackColor |
DefaultGutterForeColor |
DefaultGutterOffset |
DefaultGutterOptions |
DefaultGutterWidth |
DefaultHeaderFontColor |
DefaultHeaderFontStyle |
DefaultHideHintDelay |
DefaultHighlightBackColor |
DefaultHighlightBlockAreaColor |
DefaultHighlightForeColor |
DefaultHighlightOutlineAreaColor |
DefaultHighlightRefDelay |
DefaultHintDelay |
DefaultHintOffsetX |
DefaultHintOffsetY |
DefaultHorzScrollDelta |
DefaultHorzScrollSize |
DefaultHyperTextForeColor |
DefaultInactiveHighlightBackColor |
DefaultInactiveHighlightForeColor |
DefaultIndentOptions |
DefaultInfoBackColor |
DefaultLineBookmarksColor |
DefaultLineModificatorChangedColor |
DefaultLineModificatorSavedColor |
DefaultLineModificatorWidth |
DefaultLineNumbersBackColor |
DefaultLineNumbersForeColor |
DefaultLineNumbersIndent |
DefaultLineNumbersStart |
DefaultLineSeparatorColor |
DefaultLineSeparatorLineColor |
DefaultLineStyleBackColor |
DefaultLineStyleForeColor |
DefaultLineStyleOptions |
DefaultMarginColumnForeColor |
DefaultMarginForeColor |
DefaultMarginHitWidth |
DefaultMarginPosition |
DefaultMinListBoxHeight |
DefaultMinListBoxWidth |
DefaultNavigateOptions |
DefaultOpenBraces |
DefaultOutlineDelay |
DefaultOutlineForeColor |
DefaultOutlineImageBackColor |
DefaultOutlineOptions |
DefaultOutlineText |
DefaultOutliningIndent |
DefaultPageBackColor |
DefaultPageBorderColor |
DefaultPageHorzOffset |
DefaultPageMargin |
DefaultPageMarginSize |
DefaultPageVertOffset |
DefaultParserDelta |
DefaultPrintHeaderForeColor |
DefaultPrintHeaderOffsetX |
DefaultPrintHeaderOffsetY |
DefaultPrintOptions |
DefaultReferencesDelay |
DefaultRowSeparator |
DefaultRulerBackColor |
DefaultRulerFontName |
DefaultRulerFontSize |
DefaultRulerHeight |
DefaultRulerHitWidth |
DefaultRulerIndentBackColor |
DefaultRulerIndentSize |
DefaultRulerMinWidth |
DefaultRulerOptions |
DefaultRulerUnits |
DefaultScrollBackgroundColor |
DefaultScrollDeltaRatio |
DefaultScrollingOptions |
DefaultScrollSplitterSize |
DefaultScrollThumbHoveredColor |
DefaultScrollThumbNormalColor |
DefaultScrollThumbPressedColor |
DefaultSearchOptions |
DefaultSearchResultLimit |
DefaultSelDelay |
DefaultSelectionBorderColor |
DefaultSelectionDragColor |
DefaultSelectionMode |
DefaultSelectionOptions |
DefaultSmoothScrollDelay |
DefaultSmoothScrollPause |
DefaultSmoothScrollSteps |
DefaultSnippetBackColor |
DefaultSnippetEndPattern |
DefaultSnippetPattern |
DefaultSnippetSelectedPattern |
DefaultSpacesInTab |
DefaultSpellDelimiters |
DefaultSpellForeColor |
DefaultTabStop |
DefaultThreadWaitTimeout |
DefaultTransparentColor |
DefaultUndoOptions |
DefaultUrlChars |
DefaultUrlFontStyle |
DefaultUrlForeColor |
DefaultUserMarginBackColor |
DefaultUserMarginForeColor |
DefaultUserMarginText |
DefaultUserMarginWidth |
DefaultWhiteSpaceForeColor |
DefaultWrapDelta |
DefaultWrapImageIndex |
DottedText |
EofSymbol |
EolSymbol |
FileProtocol |
FTPProtocol |
GopherProtocol |
HeaderFontName |
HTTPProtocol |
HTTPSProtocol |
LineTag |
LongSpaceSymbol |
MailTo |
MaxDropDownCount |
MaxFontSize |
MaxHintWindowCount |
MaxHintWindowWidth |
MaxPaintChar |
MaxScrollBarAnnotationsErrorsCount |
MinPageIndent |
NavKeys |
PagesTag |
PageTag |
SearchDialogAppearanceDefaultValue |
SpaceSymbol |
TabSymbol |
TimeTag |
UserTag |
WheelDelta |
WordWrapSymbol |
WWW |
Top
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.AnyBookMarkGroup Field

EditConstsAnyBookMarkGroup Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int AnyBookMarkGroup
Public Const AnyBookMarkGroup As Integer
public:
literal int AnyBookMarkGroup
static val mutable AnyBookMarkGroup: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.CharsTag Field

EditConstsCharsTag Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CharsTag
Public Shared CharsTag As String
public:
static String^ CharsTag
static val mutable CharsTag: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.CodeCompletionModeDefaultValue Field

EditConstsCodeCompletionModeDefaultValue Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const CodeCompletionMode CodeCompletionModeDefaultValue
Public Const CodeCompletionModeDefaultValue As CodeCompletionMode
public:
literal CodeCompletionMode CodeCompletionModeDefaultValue
static val mutable CodeCompletionModeDefaultValue: CodeCompletionMode

Field Value

Type: CodeCompletionMode
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.ColumnSeparator Field

EditConstsColumnSeparator Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ColumnSeparator
Public Shared ColumnSeparator As String
public:
static String^ ColumnSeparator
static val mutable ColumnSeparator: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DateTag Field

EditConstsDateTag Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DateTag
Public Shared DateTag As String
public:
static String^ DateTag
static val mutable DateTag: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultAnnotationBookmarkColor Field

EditConstsDefaultAnnotationBookmarkColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultAnnotationBookmarkColor
Public Shared DefaultAnnotationBookmarkColor As Color
public:
static Color DefaultAnnotationBookmarkColor
static val mutable DefaultAnnotationBookmarkColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultAnnotationCursorPositionColor Field

EditConstsDefaultAnnotationCursorPositionColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultAnnotationCursorPositionColor
Public Shared DefaultAnnotationCursorPositionColor As Color
public:
static Color DefaultAnnotationCursorPositionColor
static val mutable DefaultAnnotationCursorPositionColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultAnnotationCustomColor Field

EditConstsDefaultAnnotationCustomColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultAnnotationCustomColor
Public Shared DefaultAnnotationCustomColor As Color
public:
static Color DefaultAnnotationCustomColor
static val mutable DefaultAnnotationCustomColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultAnnotationSearchResultColor Field

EditConstsDefaultAnnotationSearchResultColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultAnnotationSearchResultColor
Public Shared DefaultAnnotationSearchResultColor As Color
public:
static Color DefaultAnnotationSearchResultColor
static val mutable DefaultAnnotationSearchResultColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultArrowBackColor Field

EditConstsDefaultArrowBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultArrowBackColor
Public Shared DefaultArrowBackColor As Color
public:
static Color DefaultArrowBackColor
static val mutable DefaultArrowBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultArrowForeColor Field

EditConstsDefaultArrowForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultArrowForeColor
Public Shared DefaultArrowForeColor As Color
public:
static Color DefaultArrowForeColor
static val mutable DefaultArrowForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultAutoCorrectDelimiters Field

EditConstsDefaultAutoCorrectDelimiters Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultAutoCorrectDelimiters
Public Shared DefaultAutoCorrectDelimiters As String
public:
static String^ DefaultAutoCorrectDelimiters
static val mutable DefaultAutoCorrectDelimiters: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultBookMarkImageIndex Field

EditConstsDefaultBookMarkImageIndex Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultBookMarkImageIndex
Public Shared DefaultBookMarkImageIndex As Integer
public:
static int DefaultBookMarkImageIndex
static val mutable DefaultBookMarkImageIndex: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultBorderStyle Field

EditConstsDefaultBorderStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const EditBorderStyle DefaultBorderStyle
Public Const DefaultBorderStyle As EditBorderStyle
public:
literal EditBorderStyle DefaultBorderStyle
static val mutable DefaultBorderStyle: EditBorderStyle

Field Value

Type: EditBorderStyle
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultBracesBackColor Field

EditConstsDefaultBracesBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultBracesBackColor
Public Shared DefaultBracesBackColor As Color
public:
static Color DefaultBracesBackColor
static val mutable DefaultBracesBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultBracesDelay Field

EditConstsDefaultBracesDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultBracesDelay
Public Shared DefaultBracesDelay As Integer
public:
static int DefaultBracesDelay
static val mutable DefaultBracesDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultBracesFontStyle Field

EditConstsDefaultBracesFontStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FontStyle DefaultBracesFontStyle
Public Shared DefaultBracesFontStyle As FontStyle
public:
static FontStyle DefaultBracesFontStyle
static val mutable DefaultBracesFontStyle: FontStyle

Field Value

Type: FontStyle
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultBracesForeColor Field

EditConstsDefaultBracesForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultBracesForeColor
Public Shared DefaultBracesForeColor As Color
public:
static Color DefaultBracesForeColor
static val mutable DefaultBracesForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultBulbImageIndex Field

EditConstsDefaultBulbImageIndex Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultBulbImageIndex
Public Shared DefaultBulbImageIndex As Integer
public:
static int DefaultBulbImageIndex
static val mutable DefaultBulbImageIndex: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCaretWidth Field

EditConstsDefaultCaretWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultCaretWidth
Public Shared DefaultCaretWidth As Integer
public:
static int DefaultCaretWidth
static val mutable DefaultCaretWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultClosingBraces Field

EditConstsDefaultClosingBraces Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char[] DefaultClosingBraces
Public Shared DefaultClosingBraces As Char()
public:
static array<wchar_t>^ DefaultClosingBraces
static val mutable DefaultClosingBraces: char[]

Field Value

Type: Char
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCodeCompletionBorderColor Field

EditConstsDefaultCodeCompletionBorderColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultCodeCompletionBorderColor
Public Shared DefaultCodeCompletionBorderColor As Color
public:
static Color DefaultCodeCompletionBorderColor
static val mutable DefaultCodeCompletionBorderColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCodeCompletionBorderThickness Field

EditConstsDefaultCodeCompletionBorderThickness Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultCodeCompletionBorderThickness
Public Shared DefaultCodeCompletionBorderThickness As Integer
public:
static int DefaultCodeCompletionBorderThickness
static val mutable DefaultCodeCompletionBorderThickness: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCodeCompletionButtonHeight Field

EditConstsDefaultCodeCompletionButtonHeight Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultCodeCompletionButtonHeight
Public Shared DefaultCodeCompletionButtonHeight As Integer
public:
static int DefaultCodeCompletionButtonHeight
static val mutable DefaultCodeCompletionButtonHeight: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCodeCompletionButtonWidth Field

EditConstsDefaultCodeCompletionButtonWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultCodeCompletionButtonWidth
Public Shared DefaultCodeCompletionButtonWidth As Integer
public:
static int DefaultCodeCompletionButtonWidth
static val mutable DefaultCodeCompletionButtonWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCodeCompletionChars Field

EditConstsDefaultCodeCompletionChars Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCodeCompletionChars
Public Shared DefaultCodeCompletionChars As String
public:
static String^ DefaultCodeCompletionChars
static val mutable DefaultCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCodeCompletionFlags Field

EditConstsDefaultCodeCompletionFlags Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CodeCompletionFlags DefaultCodeCompletionFlags
Public Shared DefaultCodeCompletionFlags As CodeCompletionFlags
public:
static CodeCompletionFlags DefaultCodeCompletionFlags
static val mutable DefaultCodeCompletionFlags: CodeCompletionFlags

Field Value

Type: CodeCompletionFlags
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCodeCompletionFont Field

EditConstsDefaultCodeCompletionFont Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCodeCompletionFont
Public Shared DefaultCodeCompletionFont As String
public:
static String^ DefaultCodeCompletionFont
static val mutable DefaultCodeCompletionFont: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCodeCompletionFontSize Field

EditConstsDefaultCodeCompletionFontSize Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static float DefaultCodeCompletionFontSize
Public Shared DefaultCodeCompletionFontSize As Single
public:
static float DefaultCodeCompletionFontSize
static val mutable DefaultCodeCompletionFontSize: float32

Field Value

Type: Single
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCollasedImageWidth Field

EditConstsDefaultCollasedImageWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultCollasedImageWidth
Public Shared DefaultCollasedImageWidth As Integer
public:
static int DefaultCollasedImageWidth
static val mutable DefaultCollasedImageWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultColumnMarginPosition Field

EditConstsDefaultColumnMarginPosition Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultColumnMarginPosition
Public Shared DefaultColumnMarginPosition As Integer
public:
static int DefaultColumnMarginPosition
static val mutable DefaultColumnMarginPosition: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultColumnSeparator Field

EditConstsDefaultColumnSeparator Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultColumnSeparator
Public Shared DefaultColumnSeparator As Integer
public:
static int DefaultColumnSeparator
static val mutable DefaultColumnSeparator: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultColumnsIndentForeColor Field

EditConstsDefaultColumnsIndentForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultColumnsIndentForeColor
Public Shared DefaultColumnsIndentForeColor As Color
public:
static Color DefaultColumnsIndentForeColor
static val mutable DefaultColumnsIndentForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCommentsFontStyle Field

EditConstsDefaultCommentsFontStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FontStyle DefaultCommentsFontStyle
Public Shared DefaultCommentsFontStyle As FontStyle
public:
static FontStyle DefaultCommentsFontStyle
static val mutable DefaultCommentsFontStyle: FontStyle

Field Value

Type: FontStyle
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultCompletionStartDelay Field

EditConstsDefaultCompletionStartDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultCompletionStartDelay
Public Shared DefaultCompletionStartDelay As Integer
public:
static int DefaultCompletionStartDelay
static val mutable DefaultCompletionStartDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultContentDividerColor Field

EditConstsDefaultContentDividerColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultContentDividerColor
Public Shared DefaultContentDividerColor As Color
public:
static Color DefaultContentDividerColor
static val mutable DefaultContentDividerColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultDelimiters Field

EditConstsDefaultDelimiters Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultDelimiters
Public Shared DefaultDelimiters As String
public:
static String^ DefaultDelimiters
static val mutable DefaultDelimiters: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultDisabledForeColor Field

EditConstsDefaultDisabledForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultDisabledForeColor
Public Shared DefaultDisabledForeColor As Color
public:
static Color DefaultDisabledForeColor
static val mutable DefaultDisabledForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultDragDelay Field

EditConstsDefaultDragDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultDragDelay
Public Shared DefaultDragDelay As Integer
public:
static int DefaultDragDelay
static val mutable DefaultDragDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultDrawColumnsIndent Field

EditConstsDefaultDrawColumnsIndent Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool DefaultDrawColumnsIndent
Public Shared DefaultDrawColumnsIndent As Boolean
public:
static bool DefaultDrawColumnsIndent
static val mutable DefaultDrawColumnsIndent: bool

Field Value

Type: Boolean
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultDrawStructureGuideLines Field

EditConstsDefaultDrawStructureGuideLines Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool DefaultDrawStructureGuideLines
Public Shared DefaultDrawStructureGuideLines As Boolean
public:
static bool DefaultDrawStructureGuideLines
static val mutable DefaultDrawStructureGuideLines: bool

Field Value

Type: Boolean
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultDropDownCount Field

EditConstsDefaultDropDownCount Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultDropDownCount
Public Shared DefaultDropDownCount As Integer
public:
static int DefaultDropDownCount
static val mutable DefaultDropDownCount: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultFont Field

EditConstsDefaultFont Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Font DefaultFont
Public Shared DefaultFont As Font
public:
static Font^ DefaultFont
static val mutable DefaultFont: Font

Field Value

Type: Font
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultGuideLinesForeColor Field

EditConstsDefaultGuideLinesForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultGuideLinesForeColor
Public Shared DefaultGuideLinesForeColor As Color
public:
static Color DefaultGuideLinesForeColor
static val mutable DefaultGuideLinesForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultGutterBackColor Field

EditConstsDefaultGutterBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultGutterBackColor
Public Shared DefaultGutterBackColor As Color
public:
static Color DefaultGutterBackColor
static val mutable DefaultGutterBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultGutterForeColor Field

EditConstsDefaultGutterForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultGutterForeColor
Public Shared DefaultGutterForeColor As Color
public:
static Color DefaultGutterForeColor
static val mutable DefaultGutterForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultGutterOffset Field

EditConstsDefaultGutterOffset Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultGutterOffset
Public Shared DefaultGutterOffset As Integer
public:
static int DefaultGutterOffset
static val mutable DefaultGutterOffset: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultGutterOptions Field

EditConstsDefaultGutterOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GutterOptions DefaultGutterOptions
Public Shared DefaultGutterOptions As GutterOptions
public:
static GutterOptions DefaultGutterOptions
static val mutable DefaultGutterOptions: GutterOptions

Field Value

Type: GutterOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultGutterWidth Field

EditConstsDefaultGutterWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultGutterWidth
Public Shared DefaultGutterWidth As Integer
public:
static int DefaultGutterWidth
static val mutable DefaultGutterWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHeaderFontColor Field

EditConstsDefaultHeaderFontColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultHeaderFontColor
Public Shared DefaultHeaderFontColor As Color
public:
static Color DefaultHeaderFontColor
static val mutable DefaultHeaderFontColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHeaderFontStyle Field

EditConstsDefaultHeaderFontStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FontStyle DefaultHeaderFontStyle
Public Shared DefaultHeaderFontStyle As FontStyle
public:
static FontStyle DefaultHeaderFontStyle
static val mutable DefaultHeaderFontStyle: FontStyle

Field Value

Type: FontStyle
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHideHintDelay Field

EditConstsDefaultHideHintDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultHideHintDelay
Public Shared DefaultHideHintDelay As Integer
public:
static int DefaultHideHintDelay
static val mutable DefaultHideHintDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHighlightBackColor Field

EditConstsDefaultHighlightBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultHighlightBackColor
Public Shared DefaultHighlightBackColor As Color
public:
static Color DefaultHighlightBackColor
static val mutable DefaultHighlightBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHighlightBlockAreaColor Field

EditConstsDefaultHighlightBlockAreaColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultHighlightBlockAreaColor
Public Shared DefaultHighlightBlockAreaColor As Color
public:
static Color DefaultHighlightBlockAreaColor
static val mutable DefaultHighlightBlockAreaColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHighlightForeColor Field

EditConstsDefaultHighlightForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultHighlightForeColor
Public Shared DefaultHighlightForeColor As Color
public:
static Color DefaultHighlightForeColor
static val mutable DefaultHighlightForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHighlightOutlineAreaColor Field

EditConstsDefaultHighlightOutlineAreaColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultHighlightOutlineAreaColor
Public Shared DefaultHighlightOutlineAreaColor As Color
public:
static Color DefaultHighlightOutlineAreaColor
static val mutable DefaultHighlightOutlineAreaColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHighlightRefDelay Field

EditConstsDefaultHighlightRefDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultHighlightRefDelay
Public Shared DefaultHighlightRefDelay As Integer
public:
static int DefaultHighlightRefDelay
static val mutable DefaultHighlightRefDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHintDelay Field

EditConstsDefaultHintDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultHintDelay
Public Shared DefaultHintDelay As Integer
public:
static int DefaultHintDelay
static val mutable DefaultHintDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHintOffsetX Field

EditConstsDefaultHintOffsetX Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultHintOffsetX
Public Shared DefaultHintOffsetX As Integer
public:
static int DefaultHintOffsetX
static val mutable DefaultHintOffsetX: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHintOffsetY Field

EditConstsDefaultHintOffsetY Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultHintOffsetY
Public Shared DefaultHintOffsetY As Integer
public:
static int DefaultHintOffsetY
static val mutable DefaultHintOffsetY: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHorzScrollDelta Field

EditConstsDefaultHorzScrollDelta Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultHorzScrollDelta
Public Shared DefaultHorzScrollDelta As Integer
public:
static int DefaultHorzScrollDelta
static val mutable DefaultHorzScrollDelta: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHorzScrollSize Field

EditConstsDefaultHorzScrollSize Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultHorzScrollSize
Public Shared DefaultHorzScrollSize As Integer
public:
static int DefaultHorzScrollSize
static val mutable DefaultHorzScrollSize: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultHyperTextForeColor Field

EditConstsDefaultHyperTextForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultHyperTextForeColor
Public Shared DefaultHyperTextForeColor As Color
public:
static Color DefaultHyperTextForeColor
static val mutable DefaultHyperTextForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultInactiveHighlightBackColor Field

EditConstsDefaultInactiveHighlightBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultInactiveHighlightBackColor
Public Shared DefaultInactiveHighlightBackColor As Color
public:
static Color DefaultInactiveHighlightBackColor
static val mutable DefaultInactiveHighlightBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultInactiveHighlightForeColor Field

EditConstsDefaultInactiveHighlightForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultInactiveHighlightForeColor
Public Shared DefaultInactiveHighlightForeColor As Color
public:
static Color DefaultInactiveHighlightForeColor
static val mutable DefaultInactiveHighlightForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultIndentOptions Field

EditConstsDefaultIndentOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IndentOptions DefaultIndentOptions
Public Shared DefaultIndentOptions As IndentOptions
public:
static IndentOptions DefaultIndentOptions
static val mutable DefaultIndentOptions: IndentOptions

Field Value

Type: IndentOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultInfoBackColor Field

EditConstsDefaultInfoBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultInfoBackColor
Public Shared DefaultInfoBackColor As Color
public:
static Color DefaultInfoBackColor
static val mutable DefaultInfoBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineBookmarksColor Field

EditConstsDefaultLineBookmarksColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultLineBookmarksColor
Public Shared DefaultLineBookmarksColor As Color
public:
static Color DefaultLineBookmarksColor
static val mutable DefaultLineBookmarksColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineModificatorChangedColor Field

EditConstsDefaultLineModificatorChangedColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultLineModificatorChangedColor
Public Shared DefaultLineModificatorChangedColor As Color
public:
static Color DefaultLineModificatorChangedColor
static val mutable DefaultLineModificatorChangedColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineModificatorSavedColor Field

EditConstsDefaultLineModificatorSavedColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultLineModificatorSavedColor
Public Shared DefaultLineModificatorSavedColor As Color
public:
static Color DefaultLineModificatorSavedColor
static val mutable DefaultLineModificatorSavedColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineModificatorWidth Field

EditConstsDefaultLineModificatorWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultLineModificatorWidth
Public Shared DefaultLineModificatorWidth As Integer
public:
static int DefaultLineModificatorWidth
static val mutable DefaultLineModificatorWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineNumbersBackColor Field

EditConstsDefaultLineNumbersBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultLineNumbersBackColor
Public Shared DefaultLineNumbersBackColor As Color
public:
static Color DefaultLineNumbersBackColor
static val mutable DefaultLineNumbersBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineNumbersForeColor Field

EditConstsDefaultLineNumbersForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultLineNumbersForeColor
Public Shared DefaultLineNumbersForeColor As Color
public:
static Color DefaultLineNumbersForeColor
static val mutable DefaultLineNumbersForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineNumbersIndent Field

EditConstsDefaultLineNumbersIndent Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultLineNumbersIndent
Public Shared DefaultLineNumbersIndent As Integer
public:
static int DefaultLineNumbersIndent
static val mutable DefaultLineNumbersIndent: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineNumbersStart Field

EditConstsDefaultLineNumbersStart Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultLineNumbersStart
Public Shared DefaultLineNumbersStart As Integer
public:
static int DefaultLineNumbersStart
static val mutable DefaultLineNumbersStart: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineSeparatorColor Field

EditConstsDefaultLineSeparatorColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultLineSeparatorColor
Public Shared DefaultLineSeparatorColor As Color
public:
static Color DefaultLineSeparatorColor
static val mutable DefaultLineSeparatorColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineSeparatorLineColor Field

EditConstsDefaultLineSeparatorLineColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultLineSeparatorLineColor
Public Shared DefaultLineSeparatorLineColor As Color
public:
static Color DefaultLineSeparatorLineColor
static val mutable DefaultLineSeparatorLineColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineStyleBackColor Field

EditConstsDefaultLineStyleBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultLineStyleBackColor
Public Shared DefaultLineStyleBackColor As Color
public:
static Color DefaultLineStyleBackColor
static val mutable DefaultLineStyleBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineStyleForeColor Field

EditConstsDefaultLineStyleForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultLineStyleForeColor
Public Shared DefaultLineStyleForeColor As Color
public:
static Color DefaultLineStyleForeColor
static val mutable DefaultLineStyleForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultLineStyleOptions Field

EditConstsDefaultLineStyleOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LineStyleOptions DefaultLineStyleOptions
Public Shared DefaultLineStyleOptions As LineStyleOptions
public:
static LineStyleOptions DefaultLineStyleOptions
static val mutable DefaultLineStyleOptions: LineStyleOptions

Field Value

Type: LineStyleOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultMarginColumnForeColor Field

EditConstsDefaultMarginColumnForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultMarginColumnForeColor
Public Shared DefaultMarginColumnForeColor As Color
public:
static Color DefaultMarginColumnForeColor
static val mutable DefaultMarginColumnForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultMarginForeColor Field

EditConstsDefaultMarginForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultMarginForeColor
Public Shared DefaultMarginForeColor As Color
public:
static Color DefaultMarginForeColor
static val mutable DefaultMarginForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultMarginHitWidth Field

EditConstsDefaultMarginHitWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultMarginHitWidth
Public Shared DefaultMarginHitWidth As Integer
public:
static int DefaultMarginHitWidth
static val mutable DefaultMarginHitWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultMarginPosition Field

EditConstsDefaultMarginPosition Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultMarginPosition
Public Shared DefaultMarginPosition As Integer
public:
static int DefaultMarginPosition
static val mutable DefaultMarginPosition: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultMinListBoxHeight Field

EditConstsDefaultMinListBoxHeight Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultMinListBoxHeight
Public Shared DefaultMinListBoxHeight As Integer
public:
static int DefaultMinListBoxHeight
static val mutable DefaultMinListBoxHeight: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultMinListBoxWidth Field

EditConstsDefaultMinListBoxWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultMinListBoxWidth
Public Shared DefaultMinListBoxWidth As Integer
public:
static int DefaultMinListBoxWidth
static val mutable DefaultMinListBoxWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultNavigateOptions Field

EditConstsDefaultNavigateOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NavigateOptions DefaultNavigateOptions
Public Shared DefaultNavigateOptions As NavigateOptions
public:
static NavigateOptions DefaultNavigateOptions
static val mutable DefaultNavigateOptions: NavigateOptions

Field Value

Type: NavigateOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultOpenBraces Field

EditConstsDefaultOpenBraces Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char[] DefaultOpenBraces
Public Shared DefaultOpenBraces As Char()
public:
static array<wchar_t>^ DefaultOpenBraces
static val mutable DefaultOpenBraces: char[]

Field Value

Type: Char
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultOutlineDelay Field

EditConstsDefaultOutlineDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultOutlineDelay
Public Shared DefaultOutlineDelay As Integer
public:
static int DefaultOutlineDelay
static val mutable DefaultOutlineDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultOutlineForeColor Field

EditConstsDefaultOutlineForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultOutlineForeColor
Public Shared DefaultOutlineForeColor As Color
public:
static Color DefaultOutlineForeColor
static val mutable DefaultOutlineForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultOutlineImageBackColor Field

EditConstsDefaultOutlineImageBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultOutlineImageBackColor
Public Shared DefaultOutlineImageBackColor As Color
public:
static Color DefaultOutlineImageBackColor
static val mutable DefaultOutlineImageBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultOutlineOptions Field

EditConstsDefaultOutlineOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static OutlineOptions DefaultOutlineOptions
Public Shared DefaultOutlineOptions As OutlineOptions
public:
static OutlineOptions DefaultOutlineOptions
static val mutable DefaultOutlineOptions: OutlineOptions

Field Value

Type: OutlineOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultOutlineText Field

EditConstsDefaultOutlineText Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultOutlineText
Public Shared DefaultOutlineText As String
public:
static String^ DefaultOutlineText
static val mutable DefaultOutlineText: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultOutliningIndent Field

EditConstsDefaultOutliningIndent Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultOutliningIndent
Public Shared DefaultOutliningIndent As Integer
public:
static int DefaultOutliningIndent
static val mutable DefaultOutliningIndent: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPageBackColor Field

EditConstsDefaultPageBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultPageBackColor
Public Shared DefaultPageBackColor As Color
public:
static Color DefaultPageBackColor
static val mutable DefaultPageBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPageBorderColor Field

EditConstsDefaultPageBorderColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultPageBorderColor
Public Shared DefaultPageBorderColor As Color
public:
static Color DefaultPageBorderColor
static val mutable DefaultPageBorderColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPageHorzOffset Field

EditConstsDefaultPageHorzOffset Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultPageHorzOffset
Public Shared DefaultPageHorzOffset As Integer
public:
static int DefaultPageHorzOffset
static val mutable DefaultPageHorzOffset: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPageMargin Field

EditConstsDefaultPageMargin Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultPageMargin
Public Shared DefaultPageMargin As Integer
public:
static int DefaultPageMargin
static val mutable DefaultPageMargin: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPageMarginSize Field

EditConstsDefaultPageMarginSize Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultPageMarginSize
Public Shared DefaultPageMarginSize As Integer
public:
static int DefaultPageMarginSize
static val mutable DefaultPageMarginSize: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPageVertOffset Field

EditConstsDefaultPageVertOffset Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultPageVertOffset
Public Shared DefaultPageVertOffset As Integer
public:
static int DefaultPageVertOffset
static val mutable DefaultPageVertOffset: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultParserDelta Field

EditConstsDefaultParserDelta Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultParserDelta
Public Shared DefaultParserDelta As Integer
public:
static int DefaultParserDelta
static val mutable DefaultParserDelta: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPrintHeaderForeColor Field

EditConstsDefaultPrintHeaderForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultPrintHeaderForeColor
Public Shared DefaultPrintHeaderForeColor As Color
public:
static Color DefaultPrintHeaderForeColor
static val mutable DefaultPrintHeaderForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPrintHeaderOffsetX Field

EditConstsDefaultPrintHeaderOffsetX Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DefaultPrintHeaderOffsetX
Public Const DefaultPrintHeaderOffsetX As Integer
public:
literal int DefaultPrintHeaderOffsetX
static val mutable DefaultPrintHeaderOffsetX: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPrintHeaderOffsetY Field

EditConstsDefaultPrintHeaderOffsetY Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DefaultPrintHeaderOffsetY
Public Const DefaultPrintHeaderOffsetY As Integer
public:
literal int DefaultPrintHeaderOffsetY
static val mutable DefaultPrintHeaderOffsetY: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultPrintOptions Field

EditConstsDefaultPrintOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PrintOptions DefaultPrintOptions
Public Shared DefaultPrintOptions As PrintOptions
public:
static PrintOptions DefaultPrintOptions
static val mutable DefaultPrintOptions: PrintOptions

Field Value

Type: PrintOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultReferencesDelay Field

EditConstsDefaultReferencesDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultReferencesDelay
Public Shared DefaultReferencesDelay As Integer
public:
static int DefaultReferencesDelay
static val mutable DefaultReferencesDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRowSeparator Field

EditConstsDefaultRowSeparator Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultRowSeparator
Public Shared DefaultRowSeparator As Integer
public:
static int DefaultRowSeparator
static val mutable DefaultRowSeparator: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerBackColor Field

EditConstsDefaultRulerBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultRulerBackColor
Public Shared DefaultRulerBackColor As Color
public:
static Color DefaultRulerBackColor
static val mutable DefaultRulerBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerFontName Field

EditConstsDefaultRulerFontName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultRulerFontName
Public Shared DefaultRulerFontName As String
public:
static String^ DefaultRulerFontName
static val mutable DefaultRulerFontName: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerFontSize Field

EditConstsDefaultRulerFontSize Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static float DefaultRulerFontSize
Public Shared DefaultRulerFontSize As Single
public:
static float DefaultRulerFontSize
static val mutable DefaultRulerFontSize: float32

Field Value

Type: Single
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerHeight Field

EditConstsDefaultRulerHeight Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultRulerHeight
Public Shared DefaultRulerHeight As Integer
public:
static int DefaultRulerHeight
static val mutable DefaultRulerHeight: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerHitWidth Field

EditConstsDefaultRulerHitWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultRulerHitWidth
Public Shared DefaultRulerHitWidth As Integer
public:
static int DefaultRulerHitWidth
static val mutable DefaultRulerHitWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerIndentBackColor Field

EditConstsDefaultRulerIndentBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultRulerIndentBackColor
Public Shared DefaultRulerIndentBackColor As Color
public:
static Color DefaultRulerIndentBackColor
static val mutable DefaultRulerIndentBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerIndentSize Field

EditConstsDefaultRulerIndentSize Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultRulerIndentSize
Public Shared DefaultRulerIndentSize As Integer
public:
static int DefaultRulerIndentSize
static val mutable DefaultRulerIndentSize: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerMinWidth Field

EditConstsDefaultRulerMinWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultRulerMinWidth
Public Shared DefaultRulerMinWidth As Integer
public:
static int DefaultRulerMinWidth
static val mutable DefaultRulerMinWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerOptions Field

EditConstsDefaultRulerOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RulerOptions DefaultRulerOptions
Public Shared DefaultRulerOptions As RulerOptions
public:
static RulerOptions DefaultRulerOptions
static val mutable DefaultRulerOptions: RulerOptions

Field Value

Type: RulerOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultRulerUnits Field

EditConstsDefaultRulerUnits Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RulerUnits DefaultRulerUnits
Public Shared DefaultRulerUnits As RulerUnits
public:
static RulerUnits DefaultRulerUnits
static val mutable DefaultRulerUnits: RulerUnits

Field Value

Type: RulerUnits
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultScrollBackgroundColor Field

EditConstsDefaultScrollBackgroundColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultScrollBackgroundColor
Public Shared DefaultScrollBackgroundColor As Color
public:
static Color DefaultScrollBackgroundColor
static val mutable DefaultScrollBackgroundColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultScrollDeltaRatio Field

EditConstsDefaultScrollDeltaRatio Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultScrollDeltaRatio
Public Shared DefaultScrollDeltaRatio As Integer
public:
static int DefaultScrollDeltaRatio
static val mutable DefaultScrollDeltaRatio: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultScrollingOptions Field

EditConstsDefaultScrollingOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ScrollingOptions DefaultScrollingOptions
Public Shared DefaultScrollingOptions As ScrollingOptions
public:
static ScrollingOptions DefaultScrollingOptions
static val mutable DefaultScrollingOptions: ScrollingOptions

Field Value

Type: ScrollingOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultScrollSplitterSize Field

EditConstsDefaultScrollSplitterSize Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultScrollSplitterSize
Public Shared DefaultScrollSplitterSize As Integer
public:
static int DefaultScrollSplitterSize
static val mutable DefaultScrollSplitterSize: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultScrollThumbHoveredColor Field

EditConstsDefaultScrollThumbHoveredColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultScrollThumbHoveredColor
Public Shared DefaultScrollThumbHoveredColor As Color
public:
static Color DefaultScrollThumbHoveredColor
static val mutable DefaultScrollThumbHoveredColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultScrollThumbNormalColor Field

EditConstsDefaultScrollThumbNormalColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultScrollThumbNormalColor
Public Shared DefaultScrollThumbNormalColor As Color
public:
static Color DefaultScrollThumbNormalColor
static val mutable DefaultScrollThumbNormalColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultScrollThumbPressedColor Field

EditConstsDefaultScrollThumbPressedColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultScrollThumbPressedColor
Public Shared DefaultScrollThumbPressedColor As Color
public:
static Color DefaultScrollThumbPressedColor
static val mutable DefaultScrollThumbPressedColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSearchOptions Field

EditConstsDefaultSearchOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SearchOptions DefaultSearchOptions
Public Shared DefaultSearchOptions As SearchOptions
public:
static SearchOptions DefaultSearchOptions
static val mutable DefaultSearchOptions: SearchOptions

Field Value

Type: SearchOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSearchResultLimit Field

EditConstsDefaultSearchResultLimit Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultSearchResultLimit
Public Shared DefaultSearchResultLimit As Integer
public:
static int DefaultSearchResultLimit
static val mutable DefaultSearchResultLimit: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSelDelay Field

EditConstsDefaultSelDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultSelDelay
Public Shared DefaultSelDelay As Integer
public:
static int DefaultSelDelay
static val mutable DefaultSelDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSelectionBorderColor Field

EditConstsDefaultSelectionBorderColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultSelectionBorderColor
Public Shared DefaultSelectionBorderColor As Color
public:
static Color DefaultSelectionBorderColor
static val mutable DefaultSelectionBorderColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSelectionDragColor Field

EditConstsDefaultSelectionDragColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultSelectionDragColor
Public Shared DefaultSelectionDragColor As Color
public:
static Color DefaultSelectionDragColor
static val mutable DefaultSelectionDragColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSelectionMode Field

EditConstsDefaultSelectionMode Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AllowedSelectionMode DefaultSelectionMode
Public Shared DefaultSelectionMode As AllowedSelectionMode
public:
static AllowedSelectionMode DefaultSelectionMode
static val mutable DefaultSelectionMode: AllowedSelectionMode

Field Value

Type: AllowedSelectionMode
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSelectionOptions Field

EditConstsDefaultSelectionOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SelectionOptions DefaultSelectionOptions
Public Shared DefaultSelectionOptions As SelectionOptions
public:
static SelectionOptions DefaultSelectionOptions
static val mutable DefaultSelectionOptions: SelectionOptions

Field Value

Type: SelectionOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSmoothScrollDelay Field

EditConstsDefaultSmoothScrollDelay Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultSmoothScrollDelay
Public Shared DefaultSmoothScrollDelay As Integer
public:
static int DefaultSmoothScrollDelay
static val mutable DefaultSmoothScrollDelay: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSmoothScrollPause Field

EditConstsDefaultSmoothScrollPause Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultSmoothScrollPause
Public Shared DefaultSmoothScrollPause As Integer
public:
static int DefaultSmoothScrollPause
static val mutable DefaultSmoothScrollPause: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSmoothScrollSteps Field

EditConstsDefaultSmoothScrollSteps Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultSmoothScrollSteps
Public Shared DefaultSmoothScrollSteps As Integer
public:
static int DefaultSmoothScrollSteps
static val mutable DefaultSmoothScrollSteps: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSnippetBackColor Field

EditConstsDefaultSnippetBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultSnippetBackColor
Public Shared DefaultSnippetBackColor As Color
public:
static Color DefaultSnippetBackColor
static val mutable DefaultSnippetBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSnippetEndPattern Field

EditConstsDefaultSnippetEndPattern Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultSnippetEndPattern
Public Shared DefaultSnippetEndPattern As String
public:
static String^ DefaultSnippetEndPattern
static val mutable DefaultSnippetEndPattern: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSnippetPattern Field

EditConstsDefaultSnippetPattern Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultSnippetPattern
Public Shared DefaultSnippetPattern As String
public:
static String^ DefaultSnippetPattern
static val mutable DefaultSnippetPattern: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSnippetSelectedPattern Field

EditConstsDefaultSnippetSelectedPattern Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultSnippetSelectedPattern
Public Shared DefaultSnippetSelectedPattern As String
public:
static String^ DefaultSnippetSelectedPattern
static val mutable DefaultSnippetSelectedPattern: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSpacesInTab Field

EditConstsDefaultSpacesInTab Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultSpacesInTab
Public Shared DefaultSpacesInTab As Integer
public:
static int DefaultSpacesInTab
static val mutable DefaultSpacesInTab: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSpellDelimiters Field

EditConstsDefaultSpellDelimiters Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultSpellDelimiters
Public Shared DefaultSpellDelimiters As String
public:
static String^ DefaultSpellDelimiters
static val mutable DefaultSpellDelimiters: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultSpellForeColor Field

EditConstsDefaultSpellForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultSpellForeColor
Public Shared DefaultSpellForeColor As Color
public:
static Color DefaultSpellForeColor
static val mutable DefaultSpellForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultTabStop Field

EditConstsDefaultTabStop Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultTabStop
Public Shared DefaultTabStop As Integer
public:
static int DefaultTabStop
static val mutable DefaultTabStop: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultThreadWaitTimeout Field

EditConstsDefaultThreadWaitTimeout Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultThreadWaitTimeout
Public Shared DefaultThreadWaitTimeout As Integer
public:
static int DefaultThreadWaitTimeout
static val mutable DefaultThreadWaitTimeout: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultTransparentColor Field

EditConstsDefaultTransparentColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultTransparentColor
Public Shared DefaultTransparentColor As Color
public:
static Color DefaultTransparentColor
static val mutable DefaultTransparentColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultUndoOptions Field

EditConstsDefaultUndoOptions Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UndoOptions DefaultUndoOptions
Public Shared DefaultUndoOptions As UndoOptions
public:
static UndoOptions DefaultUndoOptions
static val mutable DefaultUndoOptions: UndoOptions

Field Value

Type: UndoOptions
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultUrlChars Field

EditConstsDefaultUrlChars Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultUrlChars
Public Shared DefaultUrlChars As String
public:
static String^ DefaultUrlChars
static val mutable DefaultUrlChars: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultUrlFontStyle Field

EditConstsDefaultUrlFontStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FontStyle DefaultUrlFontStyle
Public Shared DefaultUrlFontStyle As FontStyle
public:
static FontStyle DefaultUrlFontStyle
static val mutable DefaultUrlFontStyle: FontStyle

Field Value

Type: FontStyle
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultUrlForeColor Field

EditConstsDefaultUrlForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultUrlForeColor
Public Shared DefaultUrlForeColor As Color
public:
static Color DefaultUrlForeColor
static val mutable DefaultUrlForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultUserMarginBackColor Field

EditConstsDefaultUserMarginBackColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultUserMarginBackColor
Public Shared DefaultUserMarginBackColor As Color
public:
static Color DefaultUserMarginBackColor
static val mutable DefaultUserMarginBackColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultUserMarginForeColor Field

EditConstsDefaultUserMarginForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultUserMarginForeColor
Public Shared DefaultUserMarginForeColor As Color
public:
static Color DefaultUserMarginForeColor
static val mutable DefaultUserMarginForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultUserMarginText Field

EditConstsDefaultUserMarginText Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultUserMarginText
Public Shared DefaultUserMarginText As String
public:
static String^ DefaultUserMarginText
static val mutable DefaultUserMarginText: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultUserMarginWidth Field

EditConstsDefaultUserMarginWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultUserMarginWidth
Public Shared DefaultUserMarginWidth As Integer
public:
static int DefaultUserMarginWidth
static val mutable DefaultUserMarginWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultWhiteSpaceForeColor Field

EditConstsDefaultWhiteSpaceForeColor Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultWhiteSpaceForeColor
Public Shared DefaultWhiteSpaceForeColor As Color
public:
static Color DefaultWhiteSpaceForeColor
static val mutable DefaultWhiteSpaceForeColor: Color

Field Value

Type: Color
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultWrapDelta Field

EditConstsDefaultWrapDelta Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultWrapDelta
Public Shared DefaultWrapDelta As Integer
public:
static int DefaultWrapDelta
static val mutable DefaultWrapDelta: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DefaultWrapImageIndex Field

EditConstsDefaultWrapImageIndex Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultWrapImageIndex
Public Shared DefaultWrapImageIndex As Integer
public:
static int DefaultWrapImageIndex
static val mutable DefaultWrapImageIndex: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.DottedText Field

EditConstsDottedText Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DottedText
Public Shared DottedText As String
public:
static String^ DottedText
static val mutable DottedText: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.EofSymbol Field

EditConstsEofSymbol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char EofSymbol
Public Shared EofSymbol As Char
public:
static wchar_t EofSymbol
static val mutable EofSymbol: char

Field Value

Type: Char
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.EolSymbol Field

EditConstsEolSymbol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char EolSymbol
Public Shared EolSymbol As Char
public:
static wchar_t EolSymbol
static val mutable EolSymbol: char

Field Value

Type: Char
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.FileProtocol Field

EditConstsFileProtocol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FileProtocol
Public Shared FileProtocol As String
public:
static String^ FileProtocol
static val mutable FileProtocol: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.FTPProtocol Field

EditConstsFTPProtocol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FTPProtocol
Public Shared FTPProtocol As String
public:
static String^ FTPProtocol
static val mutable FTPProtocol: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.GopherProtocol Field

EditConstsGopherProtocol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GopherProtocol
Public Shared GopherProtocol As String
public:
static String^ GopherProtocol
static val mutable GopherProtocol: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.HeaderFontName Field

EditConstsHeaderFontName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HeaderFontName
Public Shared HeaderFontName As String
public:
static String^ HeaderFontName
static val mutable HeaderFontName: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.HTTPProtocol Field

EditConstsHTTPProtocol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HTTPProtocol
Public Shared HTTPProtocol As String
public:
static String^ HTTPProtocol
static val mutable HTTPProtocol: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.HTTPSProtocol Field

EditConstsHTTPSProtocol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HTTPSProtocol
Public Shared HTTPSProtocol As String
public:
static String^ HTTPSProtocol
static val mutable HTTPSProtocol: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.LineTag Field

EditConstsLineTag Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineTag
Public Shared LineTag As String
public:
static String^ LineTag
static val mutable LineTag: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.LongSpaceSymbol Field

EditConstsLongSpaceSymbol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char LongSpaceSymbol
Public Shared LongSpaceSymbol As Char
public:
static wchar_t LongSpaceSymbol
static val mutable LongSpaceSymbol: char

Field Value

Type: Char
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.MailTo Field

EditConstsMailTo Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MailTo
Public Shared MailTo As String
public:
static String^ MailTo
static val mutable MailTo: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.MaxDropDownCount Field

EditConstsMaxDropDownCount Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MaxDropDownCount
Public Shared MaxDropDownCount As Integer
public:
static int MaxDropDownCount
static val mutable MaxDropDownCount: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.MaxFontSize Field

EditConstsMaxFontSize Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MaxFontSize
Public Shared MaxFontSize As Integer
public:
static int MaxFontSize
static val mutable MaxFontSize: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.MaxHintWindowCount Field

EditConstsMaxHintWindowCount Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MaxHintWindowCount
Public Shared MaxHintWindowCount As Integer
public:
static int MaxHintWindowCount
static val mutable MaxHintWindowCount: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.MaxHintWindowWidth Field

EditConstsMaxHintWindowWidth Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MaxHintWindowWidth
Public Shared MaxHintWindowWidth As Integer
public:
static int MaxHintWindowWidth
static val mutable MaxHintWindowWidth: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.MaxPaintChar Field

EditConstsMaxPaintChar Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MaxPaintChar
Public Shared MaxPaintChar As Integer
public:
static int MaxPaintChar
static val mutable MaxPaintChar: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.MaxScrollBarAnnotationsErrorsCount Field

EditConstsMaxScrollBarAnnotationsErrorsCount Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MaxScrollBarAnnotationsErrorsCount
Public Shared MaxScrollBarAnnotationsErrorsCount As Integer
public:
static int MaxScrollBarAnnotationsErrorsCount
static val mutable MaxScrollBarAnnotationsErrorsCount: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.MinPageIndent Field

EditConstsMinPageIndent Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int MinPageIndent
Public Const MinPageIndent As Integer
public:
literal int MinPageIndent
static val mutable MinPageIndent: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.NavKeys Field

EditConstsNavKeys Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Keys[] NavKeys
Public Shared NavKeys As Keys()
public:
static array<Keys>^ NavKeys
static val mutable NavKeys: Keys[]

Field Value

Type: Keys
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.PagesTag Field

EditConstsPagesTag Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PagesTag
Public Shared PagesTag As String
public:
static String^ PagesTag
static val mutable PagesTag: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.PageTag Field

EditConstsPageTag Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PageTag
Public Shared PageTag As String
public:
static String^ PageTag
static val mutable PageTag: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.SearchDialogAppearanceDefaultValue Field

EditConstsSearchDialogAppearanceDefaultValue Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const SearchDialogAppearance SearchDialogAppearanceDefaultValue
Public Const SearchDialogAppearanceDefaultValue As SearchDialogAppearance
public:
literal SearchDialogAppearance SearchDialogAppearanceDefaultValue
static val mutable SearchDialogAppearanceDefaultValue: SearchDialogAppearance

Field Value

Type: SearchDialogAppearance
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.SpaceSymbol Field

EditConstsSpaceSymbol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char SpaceSymbol
Public Shared SpaceSymbol As Char
public:
static wchar_t SpaceSymbol
static val mutable SpaceSymbol: char

Field Value

Type: Char
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.TabSymbol Field

EditConstsTabSymbol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char TabSymbol
Public Shared TabSymbol As Char
public:
static wchar_t TabSymbol
static val mutable TabSymbol: char

Field Value

Type: Char
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.TimeTag Field

EditConstsTimeTag Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TimeTag
Public Shared TimeTag As String
public:
static String^ TimeTag
static val mutable TimeTag: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.UserTag Field

EditConstsUserTag Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string UserTag
Public Shared UserTag As String
public:
static String^ UserTag
static val mutable UserTag: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.WheelDelta Field

EditConstsWheelDelta Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int WheelDelta
Public Const WheelDelta As Integer
public:
literal int WheelDelta
static val mutable WheelDelta: int

Field Value

Type: Int32
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.WordWrapSymbol Field

EditConstsWordWrapSymbol Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char WordWrapSymbol
Public Shared WordWrapSymbol As Char
public:
static wchar_t WordWrapSymbol
static val mutable WordWrapSymbol: char

Field Value

Type: Char
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts.WWW Field

EditConstsWWW Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WWW
Public Shared WWW As String
public:
static String^ WWW
static val mutable WWW: string

Field Value

Type: String
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditConsts Methods

EditConsts Methods

The EditConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EditConsts Class
Alternet.Editor Namespace


EditHyperText Class

EditHyperText Class
Represents properties and methods to operate with hypertext within Edit control's content.
Inheritance Hierarchy
SystemObject
Alternet.EditorEditHyperText

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditHyperText : IEditHyperText,
    IHyperText
Public Class EditHyperText
    Implements IEditHyperText, IHyperText
public ref class EditHyperText : IEditHyperText,
    IHyperText
type EditHyperText =
    class
        interface IEditHyperText
        interface IHyperText
    end

The EditHyperText type exposes the following members.

Constructors
 | Name | Description
Public method | EditHyperText | Initializes a new instance of the HyperTextEx class with default settings.
Public method | EditHyperText(ISyntaxEdit) | Initializes a new instance of the HyperTextEx class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents from another IEditHyperText object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsHyperText | Indicates whether given text is hypertext.
Public method | IsUrlAtPoint(Int32, Int32) | Indicates whether text at specified position is hypertext.
Public method | IsUrlAtPoint(Int32, Int32, String) | Indicates whether text at specified position is hypertext.
Public method | IsUrlAtPoint(Int32, Int32, String, Boolean) | Indicates whether text at specified position contains a hyperlink.
Public method | IsUrlAtTextPoint | Indicates whether text at specified position is hypertext.
Public method | ResetHighlightHyperText | Resets HighlightHyperText to the default value.
Public method | ResetShowHints | Resets the ShowHints to the default value.
Public method | ResetUrlColor | Resets the UrlColor to the default value.
Public method | ResetUrlStyle | Resets the UrlStyle to the default value.
Public method | ShouldSerializeUrlColor | Indicates whether the UrlColor property should be persisted.
Public method | ShouldSerializeUrlStyle | Indicates whether the UrlStyle property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UrlJump | Tries to launch default browser to process specified url.
Top
Properties
 | Name | Description
Public property | HighlightHyperText | Gets or sets a value indicating whether hypertext urls in the text should be highlighted.
Public property | ShowHints | Gets or sets value indicating whether default hint for hypertext section needs displaying when user moves mouse over the hypertext.
Public property | UrlColor | Gets or sets a value that represents color of highlighted urls.
Public property | UrlStyle | Gets or sets font style of highlighted urls.
Public property | UrlTable | Represents hash table containing hyper-text characters.
Top
Events
 | Name | Description
Public event | HyperText | Occurs when a control needs checking whether some string represents hypertext.
Public event | JumpToUrl | Occurs when user attempts to jump to url by clicking on it in the Edit control.
Top
See Also

Reference

Alternet.Editor Namespace


EditHyperText Constructor

EditHyperText Constructor
Overload List
 | Name | Description
Public method | EditHyperText | Initializes a new instance of the HyperTextEx class with default settings.
Public method | EditHyperText(ISyntaxEdit) | Initializes a new instance of the HyperTextEx class with specified owner.
Top
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText Constructor

EditHyperText Constructor
Initializes a new instance of the HyperTextEx class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditHyperText()
Public Sub New
public:
EditHyperText()
new : unit -> EditHyperText
See Also

Reference

EditHyperText Class
EditHyperText Overload
Alternet.Editor Namespace


EditHyperText Constructor (ISyntaxEdit)

EditHyperText Constructor (ISyntaxEdit)
Initializes a new instance of the HyperTextEx class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditHyperText(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
EditHyperText(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> EditHyperText

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

EditHyperText Class
EditHyperText Overload
Alternet.Editor Namespace


EditHyperText Methods

EditHyperText Methods

The EditHyperText type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents from another IEditHyperText object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsHyperText | Indicates whether given text is hypertext.
Public method | IsUrlAtPoint(Int32, Int32) | Indicates whether text at specified position is hypertext.
Public method | IsUrlAtPoint(Int32, Int32, String) | Indicates whether text at specified position is hypertext.
Public method | IsUrlAtPoint(Int32, Int32, String, Boolean) | Indicates whether text at specified position contains a hyperlink.
Public method | IsUrlAtTextPoint | Indicates whether text at specified position is hypertext.
Public method | ResetHighlightHyperText | Resets HighlightHyperText to the default value.
Public method | ResetShowHints | Resets the ShowHints to the default value.
Public method | ResetUrlColor | Resets the UrlColor to the default value.
Public method | ResetUrlStyle | Resets the UrlStyle to the default value.
Public method | ShouldSerializeUrlColor | Indicates whether the UrlColor property should be persisted.
Public method | ShouldSerializeUrlStyle | Indicates whether the UrlStyle property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UrlJump | Tries to launch default browser to process specified url.
Top
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.Assign Method

EditHyperTextAssign Method
Copies the contents from another IEditHyperText object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IEditHyperText source
)
Public Overridable Sub Assign (
    source As IEditHyperText
)
public:
virtual void Assign(
    IEditHyperText^ source
)
abstract Assign :
        source : IEditHyperText -> unit
override Assign :
        source : IEditHyperText -> unit

Parameters

source
Type: Alternet.EditorIEditHyperText
Specifies IEditHyperText to assign.

Implements

IEditHyperTextAssign(IEditHyperText)
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.IsHyperText Method

EditHyperTextIsHyperText Method
Indicates whether given text is hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsHyperText(
    string text
)
Public Overridable Function IsHyperText (
    text As String
) As Boolean
public:
virtual bool IsHyperText(
    String^ text
)
abstract IsHyperText :
        text : string -> bool
override IsHyperText :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies string to check.

Return Value

Type: Boolean
True if given text is hypertext; otherwise false.

Implements

IHyperTextIsHyperText(String)
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.IsUrlAtPoint Method

EditHyperTextIsUrlAtPoint Method
Overload List
 | Name | Description
Public method | IsUrlAtPoint(Int32, Int32) | Indicates whether text at specified position is hypertext.
Public method | IsUrlAtPoint(Int32, Int32, String) | Indicates whether text at specified position is hypertext.
Public method | IsUrlAtPoint(Int32, Int32, String, Boolean) | Indicates whether text at specified position contains a hyperlink.
Top
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.IsUrlAtPoint Method (Int32, Int32)

EditHyperTextIsUrlAtPoint Method (Int32, Int32)
Indicates whether text at specified position is hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsUrlAtPoint(
    int x,
    int y
)
Public Overridable Function IsUrlAtPoint (
    x As Integer,
    y As Integer
) As Boolean
public:
virtual bool IsUrlAtPoint(
    int x,
    int y
)
abstract IsUrlAtPoint :
        x : int *
        y : int -> bool
override IsUrlAtPoint :
        x : int *
        y : int -> bool

Parameters

x
Type: SystemInt32
The X-constituent of Point value to check.
y
Type: SystemInt32
The Y-constituent of Point value to check.

Return Value

Type: Boolean
True if text at given position is hypertext; otherwise false.

Implements

IEditHyperTextIsUrlAtPoint(Int32, Int32)
See Also

Reference

EditHyperText Class
IsUrlAtPoint Overload
Alternet.Editor Namespace


EditHyperText.IsUrlAtPoint Method (Int32, Int32, String)

EditHyperTextIsUrlAtPoint Method (Int32, Int32, String)
Indicates whether text at specified position is hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsUrlAtPoint(
    int x,
    int y,
    out string url
)
Public Overridable Function IsUrlAtPoint (
    x As Integer,
    y As Integer,
    <OutAttribute> ByRef url As String
) As Boolean
public:
virtual bool IsUrlAtPoint(
    int x,
    int y,
    [OutAttribute] String^% url
)
abstract IsUrlAtPoint :
        x : int *
        y : int *
        url : string byref -> bool
override IsUrlAtPoint :
        x : int *
        y : int *
        url : string byref -> bool

Parameters

x
Type: SystemInt32
The X-constituent of Point value to check.
y
Type: SystemInt32
The Y-constituent of Point value to check.
url
Type: SystemString
Receives text representation of url under text point.

Return Value

Type: Boolean
True if text at given position is hypertext; otherwise false.

Implements

IEditHyperTextIsUrlAtPoint(Int32, Int32, String)
See Also

Reference

EditHyperText Class
IsUrlAtPoint Overload
Alternet.Editor Namespace


EditHyperText.IsUrlAtPoint Method (Int32, Int32, String, Boolean)

EditHyperTextIsUrlAtPoint Method (Int32, Int32, String, Boolean)
Indicates whether text at specified position contains a hyperlink.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsUrlAtPoint(
    int x,
    int y,
    out string url,
    bool needUrl
)
Public Overridable Function IsUrlAtPoint (
    x As Integer,
    y As Integer,
    <OutAttribute> ByRef url As String,
    needUrl As Boolean
) As Boolean
public:
virtual bool IsUrlAtPoint(
    int x,
    int y,
    [OutAttribute] String^% url,
    bool needUrl
)
abstract IsUrlAtPoint :
        x : int *
        y : int *
        url : string byref *
        needUrl : bool -> bool
override IsUrlAtPoint :
        x : int *
        y : int *
        url : string byref *
        needUrl : bool -> bool

Parameters

x
Type: SystemInt32
The X-constituent of Point value to check.
y
Type: SystemInt32
The Y-constituent of Point value to check.
url
Type: SystemString
Receives text representation of hyperlink under text point.
needUrl
Type: SystemBoolean
Specifies whether method should return hypertext.

Return Value

Type: Boolean
True if text at given position is hyperlink; otherwise false.
See Also

Reference

EditHyperText Class
IsUrlAtPoint Overload
Alternet.Editor Namespace


EditHyperText.IsUrlAtTextPoint Method

EditHyperTextIsUrlAtTextPoint Method
Indicates whether text at specified position is hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsUrlAtTextPoint(
    int x,
    int y,
    out string url
)
Public Overridable Function IsUrlAtTextPoint (
    x As Integer,
    y As Integer,
    <OutAttribute> ByRef url As String
) As Boolean
public:
virtual bool IsUrlAtTextPoint(
    int x,
    int y,
    [OutAttribute] String^% url
)
abstract IsUrlAtTextPoint :
        x : int *
        y : int *
        url : string byref -> bool
override IsUrlAtTextPoint :
        x : int *
        y : int *
        url : string byref -> bool

Parameters

x
Type: SystemInt32
The X-constituent of Point value to check in text coordinates.
y
Type: SystemInt32
The Y-constituent of Point value to check in text coordinates.
url
Type: SystemString
Receives text representation of url under text point.

Return Value

Type: Boolean
True if text at given position is hypertext; otherwise false.

Implements

IEditHyperTextIsUrlAtTextPoint(Int32, Int32, String)
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.ResetHighlightHyperText Method

EditHyperTextResetHighlightHyperText Method
Resets HighlightHyperText to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetHighlightHyperText()
Public Overridable Sub ResetHighlightHyperText
public:
virtual void ResetHighlightHyperText()
abstract ResetHighlightHyperText : unit -> unit
override ResetHighlightHyperText : unit -> unit

Implements

IHyperTextResetHighlightHyperText
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.ResetShowHints Method

EditHyperTextResetShowHints Method
Resets the ShowHints to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetShowHints()
Public Overridable Sub ResetShowHints
public:
virtual void ResetShowHints()
abstract ResetShowHints : unit -> unit
override ResetShowHints : unit -> unit

Implements

IEditHyperTextResetShowHints
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.ResetUrlColor Method

EditHyperTextResetUrlColor Method
Resets the UrlColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUrlColor()
Public Overridable Sub ResetUrlColor
public:
virtual void ResetUrlColor()
abstract ResetUrlColor : unit -> unit
override ResetUrlColor : unit -> unit

Implements

IEditHyperTextResetUrlColor
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.ResetUrlStyle Method

EditHyperTextResetUrlStyle Method
Resets the UrlStyle to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUrlStyle()
Public Overridable Sub ResetUrlStyle
public:
virtual void ResetUrlStyle()
abstract ResetUrlStyle : unit -> unit
override ResetUrlStyle : unit -> unit

Implements

IEditHyperTextResetUrlStyle
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.ShouldSerializeUrlColor Method

EditHyperTextShouldSerializeUrlColor Method
Indicates whether the UrlColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeUrlColor()
Public Function ShouldSerializeUrlColor As Boolean
public:
bool ShouldSerializeUrlColor()
member ShouldSerializeUrlColor : unit -> bool

Return Value

Type: Boolean
True if UrlColor differs from its default value; otherwise false.
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.ShouldSerializeUrlStyle Method

EditHyperTextShouldSerializeUrlStyle Method
Indicates whether the UrlStyle property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeUrlStyle()
Public Function ShouldSerializeUrlStyle As Boolean
public:
bool ShouldSerializeUrlStyle()
member ShouldSerializeUrlStyle : unit -> bool

Return Value

Type: Boolean
True if UrlStyle differs from its default value; otherwise false.
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.UrlJump Method

EditHyperTextUrlJump Method
Tries to launch default browser to process specified url.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UrlJump(
    string text
)
Public Overridable Sub UrlJump (
    text As String
)
public:
virtual void UrlJump(
    String^ text
)
abstract UrlJump :
        text : string -> unit
override UrlJump :
        text : string -> unit

Parameters

text
Type: SystemString
Specifies name of a document or application file to jump to.

Implements

IEditHyperTextUrlJump(String)
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText Properties

EditHyperText Properties

The EditHyperText type exposes the following members.

Properties
 | Name | Description
Public property | HighlightHyperText | Gets or sets a value indicating whether hypertext urls in the text should be highlighted.
Public property | ShowHints | Gets or sets value indicating whether default hint for hypertext section needs displaying when user moves mouse over the hypertext.
Public property | UrlColor | Gets or sets a value that represents color of highlighted urls.
Public property | UrlStyle | Gets or sets font style of highlighted urls.
Public property | UrlTable | Represents hash table containing hyper-text characters.
Top
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.HighlightHyperText Property

EditHyperTextHighlightHyperText Property
Gets or sets a value indicating whether hypertext urls in the text should be highlighted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HighlightHyperText { get; set; }
Public Overridable Property HighlightHyperText As Boolean
    Get
    Set
public:
virtual property bool HighlightHyperText {
    bool get ();
    void set (bool value);
}
abstract HighlightHyperText : bool with get, set
override HighlightHyperText : bool with get, set

Property Value

Type: Boolean

Implements

IEditHyperTextHighlightHyperText
IHyperTextHighlightHyperText
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.ShowHints Property

EditHyperTextShowHints Property
Gets or sets value indicating whether default hint for hypertext section needs displaying when user moves mouse over the hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowHints { get; set; }
Public Overridable Property ShowHints As Boolean
    Get
    Set
public:
virtual property bool ShowHints {
    bool get ();
    void set (bool value);
}
abstract ShowHints : bool with get, set
override ShowHints : bool with get, set

Property Value

Type: Boolean

Implements

IEditHyperTextShowHints
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.UrlColor Property

EditHyperTextUrlColor Property
Gets or sets a value that represents color of highlighted urls.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color UrlColor { get; set; }
Public Overridable Property UrlColor As Color
    Get
    Set
public:
virtual property Color UrlColor {
    Color get ();
    void set (Color value);
}
abstract UrlColor : Color with get, set
override UrlColor : Color with get, set

Property Value

Type: Color

Implements

IEditHyperTextUrlColor
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.UrlStyle Property

EditHyperTextUrlStyle Property
Gets or sets font style of highlighted urls.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FontStyle UrlStyle { get; set; }
Public Overridable Property UrlStyle As FontStyle
    Get
    Set
public:
virtual property FontStyle UrlStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract UrlStyle : FontStyle with get, set
override UrlStyle : FontStyle with get, set

Property Value

Type: FontStyle

Implements

IEditHyperTextUrlStyle
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.UrlTable Property

EditHyperTextUrlTable Property
Represents hash table containing hyper-text characters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hashtable UrlTable { get; }
Public ReadOnly Property UrlTable As Hashtable
    Get
public:
virtual property Hashtable^ UrlTable {
    Hashtable^ get () sealed;
}
abstract UrlTable : Hashtable with get
override UrlTable : Hashtable with get

Property Value

Type: Hashtable

Implements

IHyperTextUrlTable
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText Events

EditHyperText Events

The EditHyperText type exposes the following members.

Events
 | Name | Description
Public event | HyperText | Occurs when a control needs checking whether some string represents hypertext.
Public event | JumpToUrl | Occurs when user attempts to jump to url by clicking on it in the Edit control.
Top
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.HyperText Event

EditHyperTextHyperText Event
Occurs when a control needs checking whether some string represents hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event HyperTextEvent HyperText
Public Event HyperText As HyperTextEvent
public:
virtual  event HyperTextEvent^ HyperText {
    void add (HyperTextEvent^ value);
    void remove (HyperTextEvent^ value);
}
abstract HyperText : IEvent<HyperTextEvent,
    HyperTextEventArgs>
override HyperText : IEvent<HyperTextEvent,
    HyperTextEventArgs>

Value

Type: Alternet.Editor.TextSourceHyperTextEvent

Implements

IHyperTextHyperText
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditHyperText.JumpToUrl Event

EditHyperTextJumpToUrl Event
Occurs when user attempts to jump to url by clicking on it in the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event UrlJumpEvent JumpToUrl
Public Event JumpToUrl As UrlJumpEvent
public:
virtual  event UrlJumpEvent^ JumpToUrl {
    void add (UrlJumpEvent^ value);
    void remove (UrlJumpEvent^ value);
}
abstract JumpToUrl : IEvent<UrlJumpEvent,
    UrlJumpEventArgs>
override JumpToUrl : IEvent<UrlJumpEvent,
    UrlJumpEventArgs>

Value

Type: Alternet.EditorUrlJumpEvent

Implements

IEditHyperTextJumpToUrl
See Also

Reference

EditHyperText Class
Alternet.Editor Namespace


EditLineStyle Class

EditLineStyle Class
Represents a particular style of the line in Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorEditLineStyle

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
[TypeConverterAttribute("Alternet.Design.LineStyleConverter, Alternet.Editor.Design.v7")]
public class EditLineStyle : IEditLineStyle
<SerializableAttribute>
<TypeConverterAttribute("Alternet.Design.LineStyleConverter, Alternet.Editor.Design.v7")>
Public Class EditLineStyle
    Implements IEditLineStyle
[SerializableAttribute]
[TypeConverterAttribute(L"Alternet.Design.LineStyleConverter, Alternet.Editor.Design.v7")]
public ref class EditLineStyle : IEditLineStyle
[<SerializableAttribute>]
[<TypeConverterAttribute("Alternet.Design.LineStyleConverter, Alternet.Editor.Design.v7")>]
type EditLineStyle =
    class
        interface IEditLineStyle
    end

The EditLineStyle type exposes the following members.

Constructors
 | Name | Description
Public method | EditLineStyle | Initializes a new instance of the LineStyle class with default settings.
Public method | EditLineStyle(ISyntaxEdit) | Initializes a new instance of the LineStyle class with specified owner.
Public method | EditLineStyle(ISyntaxEdit, String, Color, Color, Color, Int32, LineStyleOptions) | Initializes a new instance of the LineStyle class with specified parameters.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents from another IEditLineStyle object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBackColor | Returns BackColor or ForeColor depending on Options.
Public method | GetForeColor | Returns ForeColor or BackColor depending on Options.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetBackColor | Resets the BackColor to the default value.
Public method | ResetForeColor | Resets the ForeColor to the default value.
Public method | ResetImageIndex | Resets the ImageIndex to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetPenColor | Resets the PenColor to the default value.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor property should be persisted.
Public method | ShouldSerializeForeColor | Indicates whether the ForeColor property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | ShouldSerializePenColor | Indicates whether the PenColor property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets background color of the EditLineStyle.
Public property | ForeColor | Gets or sets foreground color of the EditLineStyle.
Public property | ImageIndex | Gets or sets the index of the image displayed for the EditLineStyle.
Public property | Name | Gets or sets name of the EditLineStyle.
Public property | Options | Gets or sets display options for the EditLineStyle.
Public property | PenColor | Gets or sets background color of the EditLineStyle.
Top
See Also

Reference

Alternet.Editor Namespace


EditLineStyle Constructor

EditLineStyle Constructor
Overload List
 | Name | Description
Public method | EditLineStyle | Initializes a new instance of the LineStyle class with default settings.
Public method | EditLineStyle(ISyntaxEdit) | Initializes a new instance of the LineStyle class with specified owner.
Public method | EditLineStyle(ISyntaxEdit, String, Color, Color, Color, Int32, LineStyleOptions) | Initializes a new instance of the LineStyle class with specified parameters.
Top
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle Constructor

EditLineStyle Constructor
Initializes a new instance of the LineStyle class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditLineStyle()
Public Sub New
public:
EditLineStyle()
new : unit -> EditLineStyle
See Also

Reference

EditLineStyle Class
EditLineStyle Overload
Alternet.Editor Namespace


EditLineStyle Constructor (ISyntaxEdit)

EditLineStyle Constructor (ISyntaxEdit)
Initializes a new instance of the LineStyle class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditLineStyle(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
EditLineStyle(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> EditLineStyle

Parameters

owner
Type: Alternet.EditorISyntaxEdit
SyntaxEdit that owns this new instance.
See Also

Reference

EditLineStyle Class
EditLineStyle Overload
Alternet.Editor Namespace


EditLineStyle Constructor (ISyntaxEdit, String, Color, Color, Color, Int32, LineStyleOptions)

EditLineStyle Constructor (ISyntaxEdit, String, Color, Color, Color, Int32, LineStyleOptions)
Initializes a new instance of the LineStyle class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditLineStyle(
    ISyntaxEdit owner,
    string name,
    Color foreColor,
    Color backColor,
    Color penColor,
    int imageIndex,
    LineStyleOptions options
)
Public Sub New (
    owner As ISyntaxEdit,
    name As String,
    foreColor As Color,
    backColor As Color,
    penColor As Color,
    imageIndex As Integer,
    options As LineStyleOptions
)
public:
EditLineStyle(
    ISyntaxEdit^ owner,
    String^ name,
    Color foreColor,
    Color backColor,
    Color penColor,
    int imageIndex,
    LineStyleOptions options
)
new :
        owner : ISyntaxEdit *
        name : string *
        foreColor : Color *
        backColor : Color *
        penColor : Color *
        imageIndex : int *
        options : LineStyleOptions -> EditLineStyle

Parameters

owner
Type: Alternet.EditorISyntaxEdit
SyntaxEdit that owns this new instance.
name
Type: SystemString
Name of the new instance.
foreColor
Type: System.DrawingColor
Foreground color of the new instance.
backColor
Type: System.DrawingColor
Background color of the new instance.
penColor
Type: System.DrawingColor
Pen color of the new instance.
imageIndex
Type: SystemInt32
Image index of the new instance.
options
Type: Alternet.EditorLineStyleOptions
Options of the new instance.
See Also

Reference

EditLineStyle Class
EditLineStyle Overload
Alternet.Editor Namespace


EditLineStyle Methods

EditLineStyle Methods

The EditLineStyle type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents from another IEditLineStyle object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBackColor | Returns BackColor or ForeColor depending on Options.
Public method | GetForeColor | Returns ForeColor or BackColor depending on Options.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetBackColor | Resets the BackColor to the default value.
Public method | ResetForeColor | Resets the ForeColor to the default value.
Public method | ResetImageIndex | Resets the ImageIndex to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetPenColor | Resets the PenColor to the default value.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor property should be persisted.
Public method | ShouldSerializeForeColor | Indicates whether the ForeColor property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | ShouldSerializePenColor | Indicates whether the PenColor property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.Assign Method

EditLineStyleAssign Method
Copies the contents from another IEditLineStyle object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IEditLineStyle source
)
Public Overridable Sub Assign (
    source As IEditLineStyle
)
public:
virtual void Assign(
    IEditLineStyle^ source
)
abstract Assign :
        source : IEditLineStyle -> unit
override Assign :
        source : IEditLineStyle -> unit

Parameters

source
Type: Alternet.EditorIEditLineStyle
Specifies IEditLineStyle to assign.

Implements

IEditLineStyleAssign(IEditLineStyle)
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.GetBackColor Method

EditLineStyleGetBackColor Method
Returns BackColor or ForeColor depending on Options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color GetBackColor(
    Color color
)
Public Overridable Function GetBackColor (
    color As Color
) As Color
public:
virtual Color GetBackColor(
    Color color
)
abstract GetBackColor :
        color : Color -> Color
override GetBackColor :
        color : Color -> Color

Parameters

color
Type: System.DrawingColor
Specifies default color to return if BackColor or ForeColor represent empty color.

Return Value

Type: Color
ForeColor if LineStyleOptions.InvertColors is on; otherwise BackColor.

Implements

IEditLineStyleGetBackColor(Color)
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.GetForeColor Method

EditLineStyleGetForeColor Method
Returns ForeColor or BackColor depending on Options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color GetForeColor(
    Color color
)
Public Overridable Function GetForeColor (
    color As Color
) As Color
public:
virtual Color GetForeColor(
    Color color
)
abstract GetForeColor :
        color : Color -> Color
override GetForeColor :
        color : Color -> Color

Parameters

color
Type: System.DrawingColor
Specifies default color to return if BackColor or ForeColor represent empty color.

Return Value

Type: Color
BackColor if LineStyleOptions.InvertColors is on; otherwise ForeColor.

Implements

IEditLineStyleGetForeColor(Color)
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ResetBackColor Method

EditLineStyleResetBackColor Method
Resets the BackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBackColor()
Public Overridable Sub ResetBackColor
public:
virtual void ResetBackColor()
abstract ResetBackColor : unit -> unit
override ResetBackColor : unit -> unit

Implements

IEditLineStyleResetBackColor
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ResetForeColor Method

EditLineStyleResetForeColor Method
Resets the ForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetForeColor()
Public Overridable Sub ResetForeColor
public:
virtual void ResetForeColor()
abstract ResetForeColor : unit -> unit
override ResetForeColor : unit -> unit

Implements

IEditLineStyleResetForeColor
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ResetImageIndex Method

EditLineStyleResetImageIndex Method
Resets the ImageIndex to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetImageIndex()
Public Overridable Sub ResetImageIndex
public:
virtual void ResetImageIndex()
abstract ResetImageIndex : unit -> unit
override ResetImageIndex : unit -> unit

Implements

IEditLineStyleResetImageIndex
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ResetOptions Method

EditLineStyleResetOptions Method
Resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOptions()
Public Overridable Sub ResetOptions
public:
virtual void ResetOptions()
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

IEditLineStyleResetOptions
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ResetPenColor Method

EditLineStyleResetPenColor Method
Resets the PenColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetPenColor()
Public Overridable Sub ResetPenColor
public:
virtual void ResetPenColor()
abstract ResetPenColor : unit -> unit
override ResetPenColor : unit -> unit

Implements

IEditLineStyleResetPenColor
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ShouldSerializeBackColor Method

EditLineStyleShouldSerializeBackColor Method
Indicates whether the BackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBackColor()
Public Function ShouldSerializeBackColor As Boolean
public:
bool ShouldSerializeBackColor()
member ShouldSerializeBackColor : unit -> bool

Return Value

Type: Boolean
True if BackColor differs from its default value; otherwise false.
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ShouldSerializeForeColor Method

EditLineStyleShouldSerializeForeColor Method
Indicates whether the ForeColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeForeColor()
Public Function ShouldSerializeForeColor As Boolean
public:
bool ShouldSerializeForeColor()
member ShouldSerializeForeColor : unit -> bool

Return Value

Type: Boolean
True if ForeColor differs from its default value; otherwise false.
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ShouldSerializeOptions Method

EditLineStyleShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOptions()
Public Function ShouldSerializeOptions As Boolean
public:
bool ShouldSerializeOptions()
member ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ShouldSerializePenColor Method

EditLineStyleShouldSerializePenColor Method
Indicates whether the PenColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePenColor()
Public Function ShouldSerializePenColor As Boolean
public:
bool ShouldSerializePenColor()
member ShouldSerializePenColor : unit -> bool

Return Value

Type: Boolean
True if PenColor differs from its default value; otherwise false.
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle Properties

EditLineStyle Properties

The EditLineStyle type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets background color of the EditLineStyle.
Public property | ForeColor | Gets or sets foreground color of the EditLineStyle.
Public property | ImageIndex | Gets or sets the index of the image displayed for the EditLineStyle.
Public property | Name | Gets or sets name of the EditLineStyle.
Public property | Options | Gets or sets display options for the EditLineStyle.
Public property | PenColor | Gets or sets background color of the EditLineStyle.
Top
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.BackColor Property

EditLineStyleBackColor Property
Gets or sets background color of the EditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BackColor { get; set; }
Public Overridable Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color

Implements

IEditLineStyleBackColor
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ForeColor Property

EditLineStyleForeColor Property
Gets or sets foreground color of the EditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ForeColor { get; set; }
Public Overridable Property ForeColor As Color
    Get
    Set
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set
override ForeColor : Color with get, set

Property Value

Type: Color

Implements

IEditLineStyleForeColor
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.ImageIndex Property

EditLineStyleImageIndex Property
Gets or sets the index of the image displayed for the EditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ImageIndex { get; set; }
Public Overridable Property ImageIndex As Integer
    Get
    Set
public:
virtual property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set
override ImageIndex : int with get, set

Property Value

Type: Int32

Implements

IEditLineStyleImageIndex
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.Name Property

EditLineStyleName Property
Gets or sets name of the EditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IEditLineStyleName
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.Options Property

EditLineStyleOptions Property
Gets or sets display options for the EditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual LineStyleOptions Options { get; set; }
Public Overridable Property Options As LineStyleOptions
    Get
    Set
public:
virtual property LineStyleOptions Options {
    LineStyleOptions get ();
    void set (LineStyleOptions value);
}
abstract Options : LineStyleOptions with get, set
override Options : LineStyleOptions with get, set

Property Value

Type: LineStyleOptions

Implements

IEditLineStyleOptions
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyle.PenColor Property

EditLineStylePenColor Property
Gets or sets background color of the EditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color PenColor { get; set; }
Public Overridable Property PenColor As Color
    Get
    Set
public:
virtual property Color PenColor {
    Color get ();
    void set (Color value);
}
abstract PenColor : Color with get, set
override PenColor : Color with get, set

Property Value

Type: Color

Implements

IEditLineStylePenColor
See Also

Reference

EditLineStyle Class
Alternet.Editor Namespace


EditLineStyles Class

EditLineStyles Class
Represents a collection of the ILineStyle objects for Edit control.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIEditLineStyle
Alternet.EditorEditLineStyles

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class EditLineStyles : List<IEditLineStyle>,
    IEditLineStyles, IList<IEditLineStyle>, ICollection<IEditLineStyle>,
    IEnumerable<IEditLineStyle>, IEnumerable
<SerializableAttribute>
Public Class EditLineStyles
    Inherits List(Of IEditLineStyle)
    Implements IEditLineStyles, IList(Of IEditLineStyle),
    ICollection(Of IEditLineStyle), IEnumerable(Of IEditLineStyle), IEnumerable
[SerializableAttribute]
public ref class EditLineStyles : public List<IEditLineStyle^>,
    IEditLineStyles, IList<IEditLineStyle^>, ICollection<IEditLineStyle^>,
    IEnumerable<IEditLineStyle^>, IEnumerable
[<SerializableAttribute>]
type EditLineStyles =
    class
        inherit List<IEditLineStyle>
        interface IEditLineStyles
        interface IList<IEditLineStyle>
        interface ICollection<IEditLineStyle>
        interface IEnumerable<IEditLineStyle>
        interface IEnumerable
    end

The EditLineStyles type exposes the following members.

Constructors
 | Name | Description
Public method | EditLineStyles | Initializes a new instance of the EditLineStyles class with default settings.
Public method | EditLineStyles(ISyntaxEdit) | Initializes a new instance of the EditLineStyles class with specified owner.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIEditLineStyle .)
Public method | AddLineStyle | Adds a new LineStyle to the collection.
Public method | AddLineStyle(String, Color, Color, Color, Int32, LineStyleOptions) | Adds a new LineStyle with specified parameters to the collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIEditLineStyle .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIEditLineStyle .)
Public method | Assign | Copies the contents from another IEditLineStyles object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIEditLineStyle .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIEditLineStyle .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIEditLineStyle .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIEditLineStyle .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIEditLineStyle .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIEditLineStyle .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIEditLineStyle .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIEditLineStyle .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIEditLineStyle .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIEditLineStyle .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIEditLineStyle .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIEditLineStyle .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIEditLineStyle .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIEditLineStyle .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIEditLineStyle .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIEditLineStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIEditLineStyle .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIEditLineStyle .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIEditLineStyle .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIEditLineStyle .)
Public method | IndexOfName | Returns the zero-based index of the first occurrence of the specified Name in the line style collection.
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIEditLineStyle .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIEditLineStyle .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIEditLineStyle .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIEditLineStyle .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIEditLineStyle .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIEditLineStyle .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIEditLineStyle .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIEditLineStyle .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIEditLineStyle .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIEditLineStyle .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIEditLineStyle .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIEditLineStyle .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIEditLineStyle .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIEditLineStyle .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIEditLineStyle .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIEditLineStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIEditLineStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIEditLineStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIEditLineStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIEditLineStyle .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIEditLineStyle .)
Public property | Item |
Top
See Also

Reference

Alternet.Editor Namespace


EditLineStyles Constructor

EditLineStyles Constructor
Overload List
 | Name | Description
Public method | EditLineStyles | Initializes a new instance of the EditLineStyles class with default settings.
Public method | EditLineStyles(ISyntaxEdit) | Initializes a new instance of the EditLineStyles class with specified owner.
Top
See Also

Reference

EditLineStyles Class
Alternet.Editor Namespace


EditLineStyles Constructor

EditLineStyles Constructor
Initializes a new instance of the EditLineStyles class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditLineStyles()
Public Sub New
public:
EditLineStyles()
new : unit -> EditLineStyles
See Also

Reference

EditLineStyles Class
EditLineStyles Overload
Alternet.Editor Namespace


EditLineStyles Constructor (ISyntaxEdit)

EditLineStyles Constructor (ISyntaxEdit)
Initializes a new instance of the EditLineStyles class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditLineStyles(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
EditLineStyles(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> EditLineStyles

Parameters

owner
Type: Alternet.EditorISyntaxEdit
SyntaxEdit that owns this new instance.
See Also

Reference

EditLineStyles Class
EditLineStyles Overload
Alternet.Editor Namespace


EditLineStyles Methods

EditLineStyles Methods

The EditLineStyles type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIEditLineStyle .)
Public method | AddLineStyle | Adds a new LineStyle to the collection.
Public method | AddLineStyle(String, Color, Color, Color, Int32, LineStyleOptions) | Adds a new LineStyle with specified parameters to the collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIEditLineStyle .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIEditLineStyle .)
Public method | Assign | Copies the contents from another IEditLineStyles object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIEditLineStyle .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIEditLineStyle .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIEditLineStyle .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIEditLineStyle .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIEditLineStyle .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIEditLineStyle .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIEditLineStyle .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIEditLineStyle .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIEditLineStyle .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIEditLineStyle .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIEditLineStyle .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIEditLineStyle .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIEditLineStyle .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIEditLineStyle .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIEditLineStyle .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIEditLineStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIEditLineStyle .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIEditLineStyle .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIEditLineStyle .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIEditLineStyle .)
Public method | IndexOfName | Returns the zero-based index of the first occurrence of the specified Name in the line style collection.
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIEditLineStyle .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIEditLineStyle .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIEditLineStyle .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIEditLineStyle .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIEditLineStyle .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIEditLineStyle .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIEditLineStyle .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIEditLineStyle .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIEditLineStyle .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIEditLineStyle .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIEditLineStyle .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIEditLineStyle .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIEditLineStyle .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIEditLineStyle .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIEditLineStyle .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIEditLineStyle .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIEditLineStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIEditLineStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIEditLineStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIEditLineStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

EditLineStyles Class
Alternet.Editor Namespace


EditLineStyles.AddLineStyle Method

EditLineStylesAddLineStyle Method
Overload List
 | Name | Description
Public method | AddLineStyle | Adds a new LineStyle to the collection.
Public method | AddLineStyle(String, Color, Color, Color, Int32, LineStyleOptions) | Adds a new LineStyle with specified parameters to the collection.
Top
See Also

Reference

EditLineStyles Class
Alternet.Editor Namespace


EditLineStyles.AddLineStyle Method

EditLineStylesAddLineStyle Method
Adds a new LineStyle to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AddLineStyle()
Public Overridable Function AddLineStyle As Integer
public:
virtual int AddLineStyle()
abstract AddLineStyle : unit -> int
override AddLineStyle : unit -> int

Return Value

Type: Int32
Index of the added element.

Implements

IEditLineStylesAddLineStyle
See Also

Reference

EditLineStyles Class
AddLineStyle Overload
Alternet.Editor Namespace


EditLineStyles.AddLineStyle Method (String, Color, Color, Color, Int32, LineStyleOptions)

EditLineStylesAddLineStyle Method (String, Color, Color, Color, Int32, LineStyleOptions)
Adds a new LineStyle with specified parameters to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AddLineStyle(
    string name,
    Color foreColor,
    Color backColor,
    Color penColor,
    int imageIndex,
    LineStyleOptions options
)
Public Overridable Function AddLineStyle (
    name As String,
    foreColor As Color,
    backColor As Color,
    penColor As Color,
    imageIndex As Integer,
    options As LineStyleOptions
) As Integer
public:
virtual int AddLineStyle(
    String^ name,
    Color foreColor,
    Color backColor,
    Color penColor,
    int imageIndex,
    LineStyleOptions options
)
abstract AddLineStyle :
        name : string *
        foreColor : Color *
        backColor : Color *
        penColor : Color *
        imageIndex : int *
        options : LineStyleOptions -> int
override AddLineStyle :
        name : string *
        foreColor : Color *
        backColor : Color *
        penColor : Color *
        imageIndex : int *
        options : LineStyleOptions -> int

Parameters

name
Type: SystemString
Name of new LineStyle.
foreColor
Type: System.DrawingColor
Foreground color of new LineStyle.
backColor
Type: System.DrawingColor
Background color of new LineStyle.
penColor
Type: System.DrawingColor
Pen color of new LineStyle.
imageIndex
Type: SystemInt32
Image index of new LineStyle.
options
Type: Alternet.EditorLineStyleOptions
Options of new LineStyle.

Return Value

Type: Int32
Index of the added element in the LineStyle collection.

Implements

IEditLineStylesAddLineStyle(String, Color, Color, Color, Int32, LineStyleOptions)
See Also

Reference

EditLineStyles Class
AddLineStyle Overload
Alternet.Editor Namespace


EditLineStyles.Assign Method

EditLineStylesAssign Method
Copies the contents from another IEditLineStyles object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IEditLineStyles source
)
Public Overridable Sub Assign (
    source As IEditLineStyles
)
public:
virtual void Assign(
    IEditLineStyles^ source
)
abstract Assign :
        source : IEditLineStyles -> unit
override Assign :
        source : IEditLineStyles -> unit

Parameters

source
Type: Alternet.EditorIEditLineStyles
Specifies IEditLineStyles to assign.

Implements

IEditLineStylesAssign(IEditLineStyles)
See Also

Reference

EditLineStyles Class
Alternet.Editor Namespace


EditLineStyles.IndexOfName Method

EditLineStylesIndexOfName Method
Returns the zero-based index of the first occurrence of the specified Name in the line style collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int IndexOfName(
    string name
)
Public Overridable Function IndexOfName (
    name As String
) As Integer
public:
virtual int IndexOfName(
    String^ name
)
abstract IndexOfName :
        name : string -> int
override IndexOfName :
        name : string -> int

Parameters

name
Type: SystemString
Name of line style to locate.

Return Value

Type: Int32
Index of the style found.

Implements

IEditLineStylesIndexOfName(String)
See Also

Reference

EditLineStyles Class
Alternet.Editor Namespace


EditLineStyles Properties

EditLineStyles Properties

The EditLineStyles type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIEditLineStyle .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIEditLineStyle .)
Public property | Item |
Top
See Also

Reference

EditLineStyles Class
Alternet.Editor Namespace


EditLineStyles.Item Property

EditLineStylesItem Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEditLineStyle this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As IEditLineStyle
    Get
    Set
public:
virtual property IEditLineStyle^ default[int index] {
    IEditLineStyle^ get (int index) sealed;
    void set (int index, IEditLineStyle^ value) sealed;
}
abstract Item : IEditLineStyle with get, set
override Item : IEditLineStyle with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: IEditLineStyle

Implements

IListTItemInt32
See Also

Reference

EditLineStyles Class
Alternet.Editor Namespace


EditorPrintDocument Class

EditorPrintDocument Class
Defines a reusable object that sends output to a printer.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Drawing.PrintingPrintDocument
Alternet.EditorEditorPrintDocument

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditorPrintDocument : PrintDocument
Public Class EditorPrintDocument
    Inherits PrintDocument
public ref class EditorPrintDocument : public PrintDocument
type EditorPrintDocument =
    class
        inherit PrintDocument
    end

The EditorPrintDocument type exposes the following members.

Constructors
 | Name | Description
Public method | EditorPrintDocument | Initializes a new instance of the EditorPrintDocument class with specified parameters.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init(ISyntaxEdit) | Initializes EditorPrintDocument content with content of Edit control.
Public method | Init(ISyntaxEdit, Boolean) | Initializes EditorPrintDocument content with content of Edit control.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Print | Starts the document's printing process. (Inherited from PrintDocument.)
Public method | ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)
Top
Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
Public property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Public property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
Public property | PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
Public property | PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
Public event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
Public event | QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)
Top
Remarks
Normally you do not need to use this class. It's used internally by Edit control.
See Also

Reference

Alternet.Editor Namespace


EditorPrintDocument Constructor

EditorPrintDocument Constructor
Initializes a new instance of the EditorPrintDocument class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditorPrintDocument(
    IPrinting printing,
    PrinterSettings settings
)
Public Sub New (
    printing As IPrinting,
    settings As PrinterSettings
)
public:
EditorPrintDocument(
    IPrinting^ printing,
    PrinterSettings^ settings
)
new :
        printing : IPrinting *
        settings : PrinterSettings -> EditorPrintDocument

Parameters

printing
Type: Alternet.EditorIPrinting
Specifies IPrinting object for print document.
settings
Type: System.Drawing.PrintingPrinterSettings
Specifies PrinterSettings for print document.
See Also

Reference

EditorPrintDocument Class
Alternet.Editor Namespace


EditorPrintDocument Methods

EditorPrintDocument Methods

The EditorPrintDocument type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init(ISyntaxEdit) | Initializes EditorPrintDocument content with content of Edit control.
Public method | Init(ISyntaxEdit, Boolean) | Initializes EditorPrintDocument content with content of Edit control.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Print | Starts the document's printing process. (Inherited from PrintDocument.)
Public method | ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)
Top
See Also

Reference

EditorPrintDocument Class
Alternet.Editor Namespace


EditorPrintDocument.Init Method

EditorPrintDocumentInit Method
Overload List
 | Name | Description
Public method | Init(ISyntaxEdit) | Initializes EditorPrintDocument content with content of Edit control.
Public method | Init(ISyntaxEdit, Boolean) | Initializes EditorPrintDocument content with content of Edit control.
Top
See Also

Reference

EditorPrintDocument Class
Alternet.Editor Namespace


EditorPrintDocument.Init Method (ISyntaxEdit)

EditorPrintDocumentInit Method (ISyntaxEdit)
Initializes EditorPrintDocument content with content of Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Init(
    ISyntaxEdit edit
)
Public Sub Init (
    edit As ISyntaxEdit
)
public:
void Init(
    ISyntaxEdit^ edit
)
member Init :
        edit : ISyntaxEdit -> unit

Parameters

edit
Type: Alternet.EditorISyntaxEdit
Represents an ISyntaxEdit object owning EditorPrintDocument.
See Also

Reference

EditorPrintDocument Class
Init Overload
Alternet.Editor Namespace


EditorPrintDocument.Init Method (ISyntaxEdit, Boolean)

EditorPrintDocumentInit Method (ISyntaxEdit, Boolean)
Initializes EditorPrintDocument content with content of Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Init(
    ISyntaxEdit edit,
    bool calcPages
)
Public Overridable Sub Init (
    edit As ISyntaxEdit,
    calcPages As Boolean
)
public:
virtual void Init(
    ISyntaxEdit^ edit,
    bool calcPages
)
abstract Init :
        edit : ISyntaxEdit *
        calcPages : bool -> unit
override Init :
        edit : ISyntaxEdit *
        calcPages : bool -> unit

Parameters

edit
Type: Alternet.EditorISyntaxEdit
Represents an ISyntaxEdit object owning EditorPrintDocument.
calcPages
Type: SystemBoolean
Indicates whether EditorPrintDocument should calculate count of pages to print.
See Also

Reference

EditorPrintDocument Class
Init Overload
Alternet.Editor Namespace


EditorPrintDocument Properties

EditorPrintDocument Properties

The EditorPrintDocument type exposes the following members.

Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
Public property | DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Public property | OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
Public property | PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
Public property | PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
See Also

Reference

EditorPrintDocument Class
Alternet.Editor Namespace


EditorPrintDocument Events

EditorPrintDocument Events

The EditorPrintDocument type exposes the following members.

Events
 | Name | Description
Public event | BeginPrint | Occurs when the Print method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
Public event | PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
Public event | QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)
Top
See Also

Reference

EditorPrintDocument Class
Alternet.Editor Namespace


EditPage Class

EditPage Class
Represents a particular page within Edit control content.
Inheritance Hierarchy
SystemObject
Alternet.EditorEditPage

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditPage : IEditPage, IUpdate,
    IDisposable
Public Class EditPage
    Implements IEditPage, IUpdate, IDisposable
public ref class EditPage : IEditPage,
    IUpdate, IDisposable
type EditPage =
    class
        interface IEditPage
        interface IUpdate
        interface IDisposable
    end

The EditPage type exposes the following members.

Constructors
 | Name | Description
Public method | EditPage | Initializes a new instance of the EditPage with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another IEditPage object.
Public method | BeginUpdate | Prevents page updating until calling EditPage.EndUpdate method.
Public method | DisableUpdate | Prevents page updating until calling EditPage.EndUpdate method.
Public method | Dispose | Disposes this EditPage and frees resources associated with it.
Public method | EnableUpdate | Re-enables page updating, that was turn of by calling EditPage.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling EditPage.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBounds | Retrieves a bounds of the EditPage.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invalidate | Invalidates the page.
Public method | Paint | Draws EditPage object on specified graphic surface.
Public method | ShouldSerializeHorzOffset | Indicates whether the HorzOffset property should be persisted.
Public method | ShouldSerializeLandscape | Indicates whether the Landscape property should be persisted.
Public method | ShouldSerializeMargins | Indicates whether the Margins property should be persisted.
Public method | ShouldSerializePageKind | Indicates whether the PageKind property should be persisted.
Public method | ShouldSerializePageSize | Indicates whether the PageSize property should be persisted.
Public method | ShouldSerializeVertOffset | Indicates whether the VertOffset property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Recalculates page bounds.
Public method | Update(Boolean) | Recalculates page bounds and content.
Public method | Update(Int32, Int32, Point) | When implemented by a class, updates IEditPage state in accordance with specified parameters.
Top
Properties
 | Name | Description
Public property | BottomIndent | Gets or sets page's bottom indentation.
Public property | BoundsRect | Represents a bounding area of the page within Edit control.
Public property | ClientRect | Represents a client(editing) area of the page within Edit control.
Public property | DisplayWidth | Returns displayed page width.
Public property | EndLine | Represents ending line of the page within Edit control content in display coordinates.
Public property | Footer | Represents IEditPageHeader specifying page footer.
Public property | Header | Represents IEditPageHeader specifying page header.
Public property | HorzOffset | Gets or sets a horizontal indentation between pages.
Public property | Index | Represents ordinal number of page within the Edit control pages collection.
Public property | IsFirstPage | Indicates whether this page is the first page within the Edit control pages collection.
Public property | IsLastPage | Indicates whether this page is the last page within the Edit control pages collection.
Public property | Landscape | Gets or sets boolean value that indicates the page orientation (landscape or portrait).
Public property | LeftIndent | Gets or sets page's left indentation.
Public property | Margins | Gets or sets margins specifying offsets of editing area of this EditPage.
Public property | NextPage | Represents a next EditPage within the Edit control pages collection.
Public property | Origin | Represents page's absolute screen coordinate of the page within Edit control.
Public property | PageKind | Gets or sets kind of the page specifying standard paper size.
Public property | PageRect | Gets page's rectangle.
Public property | Pages | When implemented by a class, gets or sets pages collection that owns this page.
Public property | PageSize | Gets or sets size (width and height) of this EditPage.
Public property | PaintNumber | Get or sets a boolean value that indicates whether control should paint it's number at the bottom of page.
Public property | PaintRect | Represents a bounding area excluding whitespace area of the page within Edit control.
Public property | PrevPage | Represents a previous EditPage within the Edit control pages collection.
Public property | RightIndent | Gets or sets page's right indentation.
Public property | StartLine | Represents starting line of the page within Edit control content in display coordinates.
Public property | TopIndent | Gets or sets page's top indentation.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UsePrinterSettings | Get or sets a boolean value that indicates whether control should use printer settings for calculating page size, margin and orientation.
Public property | VertOffset | Gets or sets a vertical indentation between pages.
Public property | WhiteSpaceBottomRect | Represents a whitespace area of the page within Edit control.
Public property | WhiteSpaceTopRect | Represents a whitespace area of the page within Edit control.
Top
See Also

Reference

Alternet.Editor Namespace


EditPage Constructor

EditPage Constructor
Initializes a new instance of the EditPage with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditPage(
    IEditPages pages,
    ISyntaxEdit owner
)
Public Sub New (
    pages As IEditPages,
    owner As ISyntaxEdit
)
public:
EditPage(
    IEditPages^ pages,
    ISyntaxEdit^ owner
)
new :
        pages : IEditPages *
        owner : ISyntaxEdit -> EditPage

Parameters

pages
Type: Alternet.EditorIEditPages
The IEditPages that contains this new instance.
owner
Type: Alternet.EditorISyntaxEdit
The ISyntaxEdit owner of the pages.
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage Methods

EditPage Methods

The EditPage type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another IEditPage object.
Public method | BeginUpdate | Prevents page updating until calling EditPage.EndUpdate method.
Public method | DisableUpdate | Prevents page updating until calling EditPage.EndUpdate method.
Public method | Dispose | Disposes this EditPage and frees resources associated with it.
Public method | EnableUpdate | Re-enables page updating, that was turn of by calling EditPage.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling EditPage.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBounds | Retrieves a bounds of the EditPage.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invalidate | Invalidates the page.
Public method | Paint | Draws EditPage object on specified graphic surface.
Public method | ShouldSerializeHorzOffset | Indicates whether the HorzOffset property should be persisted.
Public method | ShouldSerializeLandscape | Indicates whether the Landscape property should be persisted.
Public method | ShouldSerializeMargins | Indicates whether the Margins property should be persisted.
Public method | ShouldSerializePageKind | Indicates whether the PageKind property should be persisted.
Public method | ShouldSerializePageSize | Indicates whether the PageSize property should be persisted.
Public method | ShouldSerializeVertOffset | Indicates whether the VertOffset property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Recalculates page bounds.
Public method | Update(Boolean) | Recalculates page bounds and content.
Public method | Update(Int32, Int32, Point) | When implemented by a class, updates IEditPage state in accordance with specified parameters.
Top
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Assign Method

EditPageAssign Method
Copies the contents of another IEditPage object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IEditPage source
)
Public Overridable Sub Assign (
    source As IEditPage
)
public:
virtual void Assign(
    IEditPage^ source
)
abstract Assign :
        source : IEditPage -> unit
override Assign :
        source : IEditPage -> unit

Parameters

source
Type: Alternet.EditorIEditPage
Specifies IEditPage to assign.

Implements

IEditPageAssign(IEditPage)
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.BeginUpdate Method

EditPageBeginUpdate Method
Prevents page updating until calling EditPage.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.DisableUpdate Method

EditPageDisableUpdate Method
Prevents page updating until calling EditPage.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Dispose Method

EditPageDispose Method
Disposes this EditPage and frees resources associated with it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.EnableUpdate Method

EditPageEnableUpdate Method
Re-enables page updating, that was turn of by calling EditPage.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.EndUpdate Method

EditPageEndUpdate Method
Re-enables page updating, that was turn of by calling EditPage.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.GetBounds Method

EditPageGetBounds Method
Retrieves a bounds of the EditPage.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle GetBounds(
    bool includeSpace
)
Public Overridable Function GetBounds (
    includeSpace As Boolean
) As Rectangle
public:
virtual Rectangle GetBounds(
    bool includeSpace
)
abstract GetBounds :
        includeSpace : bool -> Rectangle
override GetBounds :
        includeSpace : bool -> Rectangle

Parameters

includeSpace
Type: SystemBoolean
Specifies whether to include whitespace area.

Return Value

Type: Rectangle
Rectangle that bounded this EditPage.

Implements

IEditPageGetBounds(Boolean)
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Invalidate Method

EditPageInvalidate Method
Invalidates the page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Invalidate()
Public Overridable Sub Invalidate
public:
virtual void Invalidate()
abstract Invalidate : unit -> unit
override Invalidate : unit -> unit

Implements

IEditPageInvalidate
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Paint Method

EditPagePaint Method
Draws EditPage object on specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Paint(
    IPainter painter
)
Public Overridable Sub Paint (
    painter As IPainter
)
public:
virtual void Paint(
    IPainter^ painter
)
abstract Paint :
        painter : IPainter -> unit
override Paint :
        painter : IPainter -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.

Implements

IEditPagePaint(IPainter)
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.ShouldSerializeHorzOffset Method

EditPageShouldSerializeHorzOffset Method
Indicates whether the HorzOffset property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeHorzOffset()
Public Function ShouldSerializeHorzOffset As Boolean
public:
bool ShouldSerializeHorzOffset()
member ShouldSerializeHorzOffset : unit -> bool

Return Value

Type: Boolean
True if HorzOffset differs from its default value; otherwise false.
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.ShouldSerializeLandscape Method

EditPageShouldSerializeLandscape Method
Indicates whether the Landscape property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLandscape()
Public Function ShouldSerializeLandscape As Boolean
public:
bool ShouldSerializeLandscape()
member ShouldSerializeLandscape : unit -> bool

Return Value

Type: Boolean
True if Landscape differs from its default value; otherwise false.
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.ShouldSerializeMargins Method

EditPageShouldSerializeMargins Method
Indicates whether the Margins property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeMargins()
Public Function ShouldSerializeMargins As Boolean
public:
bool ShouldSerializeMargins()
member ShouldSerializeMargins : unit -> bool

Return Value

Type: Boolean
True if Margins differs from its default value; otherwise false.
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.ShouldSerializePageKind Method

EditPageShouldSerializePageKind Method
Indicates whether the PageKind property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePageKind()
Public Function ShouldSerializePageKind As Boolean
public:
bool ShouldSerializePageKind()
member ShouldSerializePageKind : unit -> bool

Return Value

Type: Boolean
True if PageKind differs from its default value; otherwise false.
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.ShouldSerializePageSize Method

EditPageShouldSerializePageSize Method
Indicates whether the PageSize property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePageSize()
Public Function ShouldSerializePageSize As Boolean
public:
bool ShouldSerializePageSize()
member ShouldSerializePageSize : unit -> bool

Return Value

Type: Boolean
True if PageSize differs from its default value; otherwise false.
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.ShouldSerializeVertOffset Method

EditPageShouldSerializeVertOffset Method
Indicates whether the VertOffset property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeVertOffset()
Public Function ShouldSerializeVertOffset As Boolean
public:
bool ShouldSerializeVertOffset()
member ShouldSerializeVertOffset : unit -> bool

Return Value

Type: Boolean
True if VertOffset differs from its default value; otherwise false.
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Update Method

EditPageUpdate Method
Overload List
 | Name | Description
Public method | Update | Recalculates page bounds.
Public method | Update(Boolean) | Recalculates page bounds and content.
Public method | Update(Int32, Int32, Point) | When implemented by a class, updates IEditPage state in accordance with specified parameters.
Top
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Update Method

EditPageUpdate Method
Recalculates page bounds.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

EditPage Class
Update Overload
Alternet.Editor Namespace


EditPage.Update Method (Boolean)

EditPageUpdate Method (Boolean)
Recalculates page bounds and content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    bool changed
)
Public Overridable Sub Update (
    changed As Boolean
)
public:
virtual void Update(
    bool changed
)
abstract Update :
        changed : bool -> unit
override Update :
        changed : bool -> unit

Parameters

changed
Type: SystemBoolean
Indicates that page should recalculate it's content.
See Also

Reference

EditPage Class
Update Overload
Alternet.Editor Namespace


EditPage.Update Method (Int32, Int32, Point)

EditPageUpdate Method (Int32, Int32, Point)
When implemented by a class, updates IEditPage state in accordance with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    int startLine,
    int endLine,
    Point origin
)
Public Overridable Sub Update (
    startLine As Integer,
    endLine As Integer,
    origin As Point
)
public:
virtual void Update(
    int startLine,
    int endLine,
    Point origin
)
abstract Update :
        startLine : int *
        endLine : int *
        origin : Point -> unit
override Update :
        startLine : int *
        endLine : int *
        origin : Point -> unit

Parameters

startLine
Type: SystemInt32
New page's start line.
endLine
Type: SystemInt32
New page's end line.
origin
Type: System.DrawingPoint
New page's origin.

Implements

IEditPageUpdate(Int32, Int32, Point)
See Also

Reference

EditPage Class
Update Overload
Alternet.Editor Namespace


EditPage Properties

EditPage Properties

The EditPage type exposes the following members.

Properties
 | Name | Description
Public property | BottomIndent | Gets or sets page's bottom indentation.
Public property | BoundsRect | Represents a bounding area of the page within Edit control.
Public property | ClientRect | Represents a client(editing) area of the page within Edit control.
Public property | DisplayWidth | Returns displayed page width.
Public property | EndLine | Represents ending line of the page within Edit control content in display coordinates.
Public property | Footer | Represents IEditPageHeader specifying page footer.
Public property | Header | Represents IEditPageHeader specifying page header.
Public property | HorzOffset | Gets or sets a horizontal indentation between pages.
Public property | Index | Represents ordinal number of page within the Edit control pages collection.
Public property | IsFirstPage | Indicates whether this page is the first page within the Edit control pages collection.
Public property | IsLastPage | Indicates whether this page is the last page within the Edit control pages collection.
Public property | Landscape | Gets or sets boolean value that indicates the page orientation (landscape or portrait).
Public property | LeftIndent | Gets or sets page's left indentation.
Public property | Margins | Gets or sets margins specifying offsets of editing area of this EditPage.
Public property | NextPage | Represents a next EditPage within the Edit control pages collection.
Public property | Origin | Represents page's absolute screen coordinate of the page within Edit control.
Public property | PageKind | Gets or sets kind of the page specifying standard paper size.
Public property | PageRect | Gets page's rectangle.
Public property | Pages | When implemented by a class, gets or sets pages collection that owns this page.
Public property | PageSize | Gets or sets size (width and height) of this EditPage.
Public property | PaintNumber | Get or sets a boolean value that indicates whether control should paint it's number at the bottom of page.
Public property | PaintRect | Represents a bounding area excluding whitespace area of the page within Edit control.
Public property | PrevPage | Represents a previous EditPage within the Edit control pages collection.
Public property | RightIndent | Gets or sets page's right indentation.
Public property | StartLine | Represents starting line of the page within Edit control content in display coordinates.
Public property | TopIndent | Gets or sets page's top indentation.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UsePrinterSettings | Get or sets a boolean value that indicates whether control should use printer settings for calculating page size, margin and orientation.
Public property | VertOffset | Gets or sets a vertical indentation between pages.
Public property | WhiteSpaceBottomRect | Represents a whitespace area of the page within Edit control.
Public property | WhiteSpaceTopRect | Represents a whitespace area of the page within Edit control.
Top
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.BottomIndent Property

EditPageBottomIndent Property
Gets or sets page's bottom indentation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BottomIndent { get; set; }
Public Overridable Property BottomIndent As Integer
    Get
    Set
public:
virtual property int BottomIndent {
    int get ();
    void set (int value);
}
abstract BottomIndent : int with get, set
override BottomIndent : int with get, set

Property Value

Type: Int32

Implements

IEditPageBottomIndent
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.BoundsRect Property

EditPageBoundsRect Property
Represents a bounding area of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle BoundsRect { get; }
Public Overridable ReadOnly Property BoundsRect As Rectangle
    Get
public:
virtual property Rectangle BoundsRect {
    Rectangle get ();
}
abstract BoundsRect : Rectangle with get
override BoundsRect : Rectangle with get

Property Value

Type: Rectangle

Implements

IEditPageBoundsRect
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.ClientRect Property

EditPageClientRect Property
Represents a client(editing) area of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle ClientRect { get; }
Public Overridable ReadOnly Property ClientRect As Rectangle
    Get
public:
virtual property Rectangle ClientRect {
    Rectangle get ();
}
abstract ClientRect : Rectangle with get
override ClientRect : Rectangle with get

Property Value

Type: Rectangle

Implements

IEditPageClientRect
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.DisplayWidth Property

EditPageDisplayWidth Property
Returns displayed page width.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisplayWidth { get; }
Public Overridable ReadOnly Property DisplayWidth As Integer
    Get
public:
virtual property int DisplayWidth {
    int get ();
}
abstract DisplayWidth : int with get
override DisplayWidth : int with get

Property Value

Type: Int32

Implements

IEditPageDisplayWidth
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.EndLine Property

EditPageEndLine Property
Represents ending line of the page within Edit control content in display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndLine { get; }
Public Overridable ReadOnly Property EndLine As Integer
    Get
public:
virtual property int EndLine {
    int get ();
}
abstract EndLine : int with get
override EndLine : int with get

Property Value

Type: Int32

Implements

IEditPageEndLine
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Footer Property

EditPageFooter Property
Represents IEditPageHeader specifying page footer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IEditPageHeader Footer { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Footer As IEditPageHeader
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IEditPageHeader^ Footer {
    IEditPageHeader^ get ();
    void set (IEditPageHeader^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Footer : IEditPageHeader with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Footer : IEditPageHeader with get, set

Property Value

Type: IEditPageHeader

Implements

IEditPageFooter
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Header Property

EditPageHeader Property
Represents IEditPageHeader specifying page header.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IEditPageHeader Header { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Header As IEditPageHeader
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IEditPageHeader^ Header {
    IEditPageHeader^ get ();
    void set (IEditPageHeader^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Header : IEditPageHeader with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Header : IEditPageHeader with get, set

Property Value

Type: IEditPageHeader

Implements

IEditPageHeader
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.HorzOffset Property

EditPageHorzOffset Property
Gets or sets a horizontal indentation between pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int HorzOffset { get; set; }
Public Overridable Property HorzOffset As Integer
    Get
    Set
public:
virtual property int HorzOffset {
    int get ();
    void set (int value);
}
abstract HorzOffset : int with get, set
override HorzOffset : int with get, set

Property Value

Type: Int32

Implements

IEditPageHorzOffset
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Index Property

EditPageIndex Property
Represents ordinal number of page within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Index { get; }
Public Overridable ReadOnly Property Index As Integer
    Get
public:
virtual property int Index {
    int get ();
}
abstract Index : int with get
override Index : int with get

Property Value

Type: Int32

Implements

IEditPageIndex
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.IsFirstPage Property

EditPageIsFirstPage Property
Indicates whether this page is the first page within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsFirstPage { get; }
Public Overridable ReadOnly Property IsFirstPage As Boolean
    Get
public:
virtual property bool IsFirstPage {
    bool get ();
}
abstract IsFirstPage : bool with get
override IsFirstPage : bool with get

Property Value

Type: Boolean

Implements

IEditPageIsFirstPage
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.IsLastPage Property

EditPageIsLastPage Property
Indicates whether this page is the last page within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsLastPage { get; }
Public Overridable ReadOnly Property IsLastPage As Boolean
    Get
public:
virtual property bool IsLastPage {
    bool get ();
}
abstract IsLastPage : bool with get
override IsLastPage : bool with get

Property Value

Type: Boolean

Implements

IEditPageIsLastPage
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Landscape Property

EditPageLandscape Property
Gets or sets boolean value that indicates the page orientation (landscape or portrait).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Landscape { get; set; }
Public Overridable Property Landscape As Boolean
    Get
    Set
public:
virtual property bool Landscape {
    bool get ();
    void set (bool value);
}
abstract Landscape : bool with get, set
override Landscape : bool with get, set

Property Value

Type: Boolean

Implements

IEditPageLandscape
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.LeftIndent Property

EditPageLeftIndent Property
Gets or sets page's left indentation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LeftIndent { get; set; }
Public Overridable Property LeftIndent As Integer
    Get
    Set
public:
virtual property int LeftIndent {
    int get ();
    void set (int value);
}
abstract LeftIndent : int with get, set
override LeftIndent : int with get, set

Property Value

Type: Int32

Implements

IEditPageLeftIndent
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Margins Property

EditPageMargins Property
Gets or sets margins specifying offsets of editing area of this EditPage.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Margins Margins { get; set; }
Public Overridable Property Margins As Margins
    Get
    Set
public:
virtual property Margins^ Margins {
    Margins^ get ();
    void set (Margins^ value);
}
abstract Margins : Margins with get, set
override Margins : Margins with get, set

Property Value

Type: Margins

Implements

IEditPageMargins
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.NextPage Property

EditPageNextPage Property
Represents a next EditPage within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPage NextPage { get; }
Public Overridable ReadOnly Property NextPage As IEditPage
    Get
public:
virtual property IEditPage^ NextPage {
    IEditPage^ get ();
}
abstract NextPage : IEditPage with get
override NextPage : IEditPage with get

Property Value

Type: IEditPage

Implements

IEditPageNextPage
Remarks
Returns null if the page represents the last page.
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Origin Property

EditPageOrigin Property
Represents page's absolute screen coordinate of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Origin { get; set; }
Public Overridable Property Origin As Point
    Get
    Set
public:
virtual property Point Origin {
    Point get ();
    void set (Point value);
}
abstract Origin : Point with get, set
override Origin : Point with get, set

Property Value

Type: Point

Implements

IEditPageOrigin
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.PageKind Property

EditPagePageKind Property
Gets or sets kind of the page specifying standard paper size.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PaperKind PageKind { get; set; }
Public Overridable Property PageKind As PaperKind
    Get
    Set
public:
virtual property PaperKind PageKind {
    PaperKind get ();
    void set (PaperKind value);
}
abstract PageKind : PaperKind with get, set
override PageKind : PaperKind with get, set

Property Value

Type: PaperKind

Implements

IEditPagePageKind
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.PageRect Property

EditPagePageRect Property
Gets page's rectangle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle PageRect { get; }
Public Overridable ReadOnly Property PageRect As Rectangle
    Get
public:
virtual property Rectangle PageRect {
    Rectangle get ();
}
abstract PageRect : Rectangle with get
override PageRect : Rectangle with get

Property Value

Type: Rectangle

Implements

IEditPagePageRect
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.Pages Property

EditPagePages Property
When implemented by a class, gets or sets pages collection that owns this page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPages Pages { get; set; }
Public Overridable Property Pages As IEditPages
    Get
    Set
public:
virtual property IEditPages^ Pages {
    IEditPages^ get ();
    void set (IEditPages^ value);
}
abstract Pages : IEditPages with get, set
override Pages : IEditPages with get, set

Property Value

Type: IEditPages

Implements

IEditPagePages
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.PageSize Property

EditPagePageSize Property
Gets or sets size (width and height) of this EditPage.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size PageSize { get; set; }
Public Overridable Property PageSize As Size
    Get
    Set
public:
virtual property Size PageSize {
    Size get ();
    void set (Size value);
}
abstract PageSize : Size with get, set
override PageSize : Size with get, set

Property Value

Type: Size

Implements

IEditPagePageSize
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.PaintNumber Property

EditPagePaintNumber Property
Get or sets a boolean value that indicates whether control should paint it's number at the bottom of page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PaintNumber { get; set; }
Public Overridable Property PaintNumber As Boolean
    Get
    Set
public:
virtual property bool PaintNumber {
    bool get ();
    void set (bool value);
}
abstract PaintNumber : bool with get, set
override PaintNumber : bool with get, set

Property Value

Type: Boolean

Implements

IEditPagePaintNumber
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.PaintRect Property

EditPagePaintRect Property
Represents a bounding area excluding whitespace area of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle PaintRect { get; }
Public ReadOnly Property PaintRect As Rectangle
    Get
public:
property Rectangle PaintRect {
    Rectangle get ();
}
member PaintRect : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.PrevPage Property

EditPagePrevPage Property
Represents a previous EditPage within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPage PrevPage { get; }
Public Overridable ReadOnly Property PrevPage As IEditPage
    Get
public:
virtual property IEditPage^ PrevPage {
    IEditPage^ get ();
}
abstract PrevPage : IEditPage with get
override PrevPage : IEditPage with get

Property Value

Type: IEditPage

Implements

IEditPagePrevPage
Remarks
Returns null if the page represents the first page.
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.RightIndent Property

EditPageRightIndent Property
Gets or sets page's right indentation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int RightIndent { get; set; }
Public Overridable Property RightIndent As Integer
    Get
    Set
public:
virtual property int RightIndent {
    int get ();
    void set (int value);
}
abstract RightIndent : int with get, set
override RightIndent : int with get, set

Property Value

Type: Int32

Implements

IEditPageRightIndent
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.StartLine Property

EditPageStartLine Property
Represents starting line of the page within Edit control content in display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StartLine { get; }
Public Overridable ReadOnly Property StartLine As Integer
    Get
public:
virtual property int StartLine {
    int get ();
}
abstract StartLine : int with get
override StartLine : int with get

Property Value

Type: Int32

Implements

IEditPageStartLine
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.TopIndent Property

EditPageTopIndent Property
Gets or sets page's top indentation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int TopIndent { get; set; }
Public Overridable Property TopIndent As Integer
    Get
    Set
public:
virtual property int TopIndent {
    int get ();
    void set (int value);
}
abstract TopIndent : int with get, set
override TopIndent : int with get, set

Property Value

Type: Int32

Implements

IEditPageTopIndent
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.UpdateCount Property

EditPageUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.UsePrinterSettings Property

EditPageUsePrinterSettings Property
Get or sets a boolean value that indicates whether control should use printer settings for calculating page size, margin and orientation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UsePrinterSettings { get; set; }
Public Overridable Property UsePrinterSettings As Boolean
    Get
    Set
public:
virtual property bool UsePrinterSettings {
    bool get ();
    void set (bool value);
}
abstract UsePrinterSettings : bool with get, set
override UsePrinterSettings : bool with get, set

Property Value

Type: Boolean

Implements

IEditPageUsePrinterSettings
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.VertOffset Property

EditPageVertOffset Property
Gets or sets a vertical indentation between pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int VertOffset { get; set; }
Public Overridable Property VertOffset As Integer
    Get
    Set
public:
virtual property int VertOffset {
    int get ();
    void set (int value);
}
abstract VertOffset : int with get, set
override VertOffset : int with get, set

Property Value

Type: Int32

Implements

IEditPageVertOffset
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.WhiteSpaceBottomRect Property

EditPageWhiteSpaceBottomRect Property
Represents a whitespace area of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle WhiteSpaceBottomRect { get; }
Public Overridable ReadOnly Property WhiteSpaceBottomRect As Rectangle
    Get
public:
virtual property Rectangle WhiteSpaceBottomRect {
    Rectangle get ();
}
abstract WhiteSpaceBottomRect : Rectangle with get
override WhiteSpaceBottomRect : Rectangle with get

Property Value

Type: Rectangle

Implements

IEditPageWhiteSpaceBottomRect
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPage.WhiteSpaceTopRect Property

EditPageWhiteSpaceTopRect Property
Represents a whitespace area of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle WhiteSpaceTopRect { get; }
Public Overridable ReadOnly Property WhiteSpaceTopRect As Rectangle
    Get
public:
virtual property Rectangle WhiteSpaceTopRect {
    Rectangle get ();
}
abstract WhiteSpaceTopRect : Rectangle with get
override WhiteSpaceTopRect : Rectangle with get

Property Value

Type: Rectangle

Implements

IEditPageWhiteSpaceTopRect
See Also

Reference

EditPage Class
Alternet.Editor Namespace


EditPages Class

EditPages Class
Represents a collection of pages in the Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorEditPages

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditPages : IEditPages, IUpdate,
    IDisposable, IEnumerable<IEditPage>, IEnumerable
Public Class EditPages
    Implements IEditPages, IUpdate, IDisposable, IEnumerable(Of IEditPage),
    IEnumerable
public ref class EditPages : IEditPages,
    IUpdate, IDisposable, IEnumerable<IEditPage^>, IEnumerable
type EditPages =
    class
        interface IEditPages
        interface IUpdate
        interface IDisposable
        interface IEnumerable<IEditPage>
        interface IEnumerable
    end

The EditPages type exposes the following members.

Constructors
 | Name | Description
Public method | EditPages | Initializes a new instance of the EditPages class with default settings.
Public method | EditPages(ISyntaxEdit) | Initializes a new instance of the EditPages class with the specified owner.
Top
Methods
 | Name | Description
Public method | Add | Adds a new IEditPage to the collection.
Public method | Assign | Assigns most relevant properties from another IEditPages object.
Public method | BeginUpdate | Prevents pages updating until calling EditPages.EndUpdate method.
Public method | CancelDragging | Cancels dragging operation of the page ruler.
Public method | Clear | Removes all items from the pages collection.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | DisplayRulers | Displays rulers if needed.
Public method | Dispose | Disposes this EditPages and frees resources associated with it.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables pages updating, that was turn of by calling EditPages.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPageAt(Point) | Finds page at specified display position.
Public method | GetPageAt(Int32, Int32) | Finds page at specified display position.
Public method | GetPageAtCursor | Finds page at caret position.
Public method | GetPageAtPoint(Point) | Finds page at specified screen position.
Public method | GetPageAtPoint(Int32, Int32) | Finds page at specified screen position.
Public method | GetPageIndexAt(Point) | Finds page at specified display position.
Public method | GetPageIndexAt(Int32, Int32) | Finds page at specified display position.
Public method | GetPageIndexAtCursor | Finds page at caret position.
Public method | GetPageIndexAtPoint(Point) | Finds page at specified screen position.
Public method | GetPageIndexAtPoint(Int32, Int32) | Finds page at specified screen position.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns index of page within page collection.
Public method | InitDefaultPageSettings | Initializes page setting with default values.
Public method | Invalidate | Invalidates specified page.
Public method | IsTransparent | Indicates whether pages are transparent.
Public method | OnDrawHeader | Raises DrawHeader event.
Public method | Paint | Draws pages collection on the graphic surface.
Public method | ResetBackColor | Resets BackColor to the default value.
Public method | ResetBorderColor | Resets BorderColor to the default value.
Public method | ResetDisplayWhiteSpace | Resets DisplayWhiteSpace to the default value.
Public method | ResetPageType | Resets PageType to the default value.
Public method | ResetRulerBackColor | Resets RulerBackColor to the default value.
Public method | ResetRulerIndentBackColor | Resets RulerIndentBackColor to the default value.
Public method | ResetRulerOptions | Resets RulerOptions to the default value.
Public method | ResetRulers | Resets Rulers to the default value.
Public method | ResetRulerUnits | Resets RulerUnits to the default value.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor property should be persisted.
Public method | ShouldSerializeBorderColor | Indicates whether the BorderColor property should be persisted.
Public method | ShouldSerializePageKind | Indicates whether the PageKind property should be persisted.
Public method | ShouldSerializeRulerBackColor | Indicates whether the RulerBackColor property should be persisted.
Public method | ShouldSerializeRulerIndentBackColor | Indicates whether the RulerIndentBackColor property should be persisted.
Public method | ShouldSerializeRulerOptions | Indicates whether the RulerOptions property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Recalculates bounds of all pages in the collection.
Public method | Update(IEditPage) | Recalculates bounds of the specified page.
Public method | Update(IEditPage, Boolean) | Recalculates bounds and updates content of specified page.
Public method | UpdatePages | Recalculates bounds and updates content of specified page.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIEditPage | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIEditPage | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIEditPage, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ApplyRulerToAllPages | Gets or sets a boolean value that indicates that changing of rulers indentation applies to all pages rather than to current page.
Public property | BackColor | Gets or sets a background color of each page in the collection.
Public property | BorderColor | Gets or sets a border color of each page in the collection.
Public property | Caps | Gets size in pixels per logical inch of entire screen.
Public property | Count | Represents a number of pages in the collection.
Public property | DefaultLandscape | Represents default page landscape.
Public property | DefaultMargins | Represents default page margins.
Public property | DefaultPage | Gets or sets properties for default IEditPage object in the pages collection.
Public property | DefaultPageKind | Represents default page kind.
Public property | DefaultPageSize | Represents default page size.
Public property | DisplayWhiteSpace | Gets or sets a boolean value that indicates whether Edit control should draw whitespace area between pages.
Public property | Height | Represents total height of all pages in the collection.
Public property | HorzRuler | Represents IEditRuler object used as a horizontal page ruler.
Public property | Item | Provides an indexed access to individual IEditPage stored in the collection.
Public property | List | Provides an indexed access to individual pages within IEditPages collection.
Public property | Owner | Gets Edit control owns this pages.
Public property | PageKind | Gets or sets kind of the pages specifying standard paper size.
Public property | PageType | Gets or sets value specifying the way of viewing Edit control's content.
Public property | RulerBackColor | Gets or sets background color of the pages rulers.
Public property | RulerIndentBackColor | Gets or sets background color of the indentations parts of the pages rulers.
Public property | RulerOptions | Gets or sets options of the pages rulers.
Public property | Rulers | Gets or sets the rulers displayed within Edit control.
Public property | RulerUnits | Gets or sets measurement units of the pages rulers.
Public property | Transparent | Gets or sets a boolean value that indicates whether Edit control should draw background around the pages.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | VertRuler | Represents IEditRuler object used as a vertical page ruler.
Public property | Width | Represents pages width.
Top
Events
 | Name | Description
Public event | DrawHeader | Occurs when header or footer part of each page is drawing.
Top
See Also

Reference

Alternet.Editor Namespace


EditPages Constructor

EditPages Constructor
Overload List
 | Name | Description
Public method | EditPages | Initializes a new instance of the EditPages class with default settings.
Public method | EditPages(ISyntaxEdit) | Initializes a new instance of the EditPages class with the specified owner.
Top
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages Constructor

EditPages Constructor
Initializes a new instance of the EditPages class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditPages()
Public Sub New
public:
EditPages()
new : unit -> EditPages
See Also

Reference

EditPages Class
EditPages Overload
Alternet.Editor Namespace


EditPages Constructor (ISyntaxEdit)

EditPages Constructor (ISyntaxEdit)
Initializes a new instance of the EditPages class with the specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditPages(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
EditPages(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> EditPages

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

EditPages Class
EditPages Overload
Alternet.Editor Namespace


EditPages Methods

EditPages Methods

The EditPages type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new IEditPage to the collection.
Public method | Assign | Assigns most relevant properties from another IEditPages object.
Public method | BeginUpdate | Prevents pages updating until calling EditPages.EndUpdate method.
Public method | CancelDragging | Cancels dragging operation of the page ruler.
Public method | Clear | Removes all items from the pages collection.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | DisplayRulers | Displays rulers if needed.
Public method | Dispose | Disposes this EditPages and frees resources associated with it.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables pages updating, that was turn of by calling EditPages.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPageAt(Point) | Finds page at specified display position.
Public method | GetPageAt(Int32, Int32) | Finds page at specified display position.
Public method | GetPageAtCursor | Finds page at caret position.
Public method | GetPageAtPoint(Point) | Finds page at specified screen position.
Public method | GetPageAtPoint(Int32, Int32) | Finds page at specified screen position.
Public method | GetPageIndexAt(Point) | Finds page at specified display position.
Public method | GetPageIndexAt(Int32, Int32) | Finds page at specified display position.
Public method | GetPageIndexAtCursor | Finds page at caret position.
Public method | GetPageIndexAtPoint(Point) | Finds page at specified screen position.
Public method | GetPageIndexAtPoint(Int32, Int32) | Finds page at specified screen position.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns index of page within page collection.
Public method | InitDefaultPageSettings | Initializes page setting with default values.
Public method | Invalidate | Invalidates specified page.
Public method | IsTransparent | Indicates whether pages are transparent.
Public method | OnDrawHeader | Raises DrawHeader event.
Public method | Paint | Draws pages collection on the graphic surface.
Public method | ResetBackColor | Resets BackColor to the default value.
Public method | ResetBorderColor | Resets BorderColor to the default value.
Public method | ResetDisplayWhiteSpace | Resets DisplayWhiteSpace to the default value.
Public method | ResetPageType | Resets PageType to the default value.
Public method | ResetRulerBackColor | Resets RulerBackColor to the default value.
Public method | ResetRulerIndentBackColor | Resets RulerIndentBackColor to the default value.
Public method | ResetRulerOptions | Resets RulerOptions to the default value.
Public method | ResetRulers | Resets Rulers to the default value.
Public method | ResetRulerUnits | Resets RulerUnits to the default value.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor property should be persisted.
Public method | ShouldSerializeBorderColor | Indicates whether the BorderColor property should be persisted.
Public method | ShouldSerializePageKind | Indicates whether the PageKind property should be persisted.
Public method | ShouldSerializeRulerBackColor | Indicates whether the RulerBackColor property should be persisted.
Public method | ShouldSerializeRulerIndentBackColor | Indicates whether the RulerIndentBackColor property should be persisted.
Public method | ShouldSerializeRulerOptions | Indicates whether the RulerOptions property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Recalculates bounds of all pages in the collection.
Public method | Update(IEditPage) | Recalculates bounds of the specified page.
Public method | Update(IEditPage, Boolean) | Recalculates bounds and updates content of specified page.
Public method | UpdatePages | Recalculates bounds and updates content of specified page.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIEditPage | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIEditPage | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIEditPage, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Add Method

EditPagesAdd Method
Adds a new IEditPage to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPage Add()
Public Overridable Function Add As IEditPage
public:
virtual IEditPage^ Add()
abstract Add : unit -> IEditPage
override Add : unit -> IEditPage

Return Value

Type: IEditPage
IEditPage that is added.

Implements

IEditPagesAdd
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Assign Method

EditPagesAssign Method
Assigns most relevant properties from another IEditPages object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IEditPages source
)
Public Overridable Sub Assign (
    source As IEditPages
)
public:
virtual void Assign(
    IEditPages^ source
)
abstract Assign :
        source : IEditPages -> unit
override Assign :
        source : IEditPages -> unit

Parameters

source
Type: Alternet.EditorIEditPages
Specifies source object.

Implements

IEditPagesAssign(IEditPages)
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.BeginUpdate Method

EditPagesBeginUpdate Method
Prevents pages updating until calling EditPages.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of pages updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.CancelDragging Method

EditPagesCancelDragging Method
Cancels dragging operation of the page ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CancelDragging()
Public Overridable Sub CancelDragging
public:
virtual void CancelDragging()
abstract CancelDragging : unit -> unit
override CancelDragging : unit -> unit

Implements

IEditPagesCancelDragging
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Clear Method

EditPagesClear Method
Removes all items from the pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IEditPagesClear
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.DisableUpdate Method

EditPagesDisableUpdate Method
Prevents object state updating until calling EnableUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.DisplayRulers Method

EditPagesDisplayRulers Method
Displays rulers if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DisplayRulers()
Public Overridable Sub DisplayRulers
public:
virtual void DisplayRulers()
abstract DisplayRulers : unit -> unit
override DisplayRulers : unit -> unit

Implements

IEditPagesDisplayRulers
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Dispose Method

EditPagesDispose Method
Disposes this EditPages and frees resources associated with it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.EnableUpdate Method

EditPagesEnableUpdate Method
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.EndUpdate Method

EditPagesEndUpdate Method
Re-enables pages updating, that was turn of by calling EditPages.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of pages updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.GetPageAt Method

EditPagesGetPageAt Method
Overload List
 | Name | Description
Public method | GetPageAt(Point) | Finds page at specified display position.
Public method | GetPageAt(Int32, Int32) | Finds page at specified display position.
Top
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.GetPageAt Method (Point)

EditPagesGetPageAt Method (Point)
Finds page at specified display position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPage GetPageAt(
    Point position
)
Public Overridable Function GetPageAt (
    position As Point
) As IEditPage
public:
virtual IEditPage^ GetPageAt(
    Point position
)
abstract GetPageAt :
        position : Point -> IEditPage
override GetPageAt :
        position : Point -> IEditPage

Parameters

position
Type: System.DrawingPoint
Position in display coordinates to obtain the page.

Return Value

Type: IEditPage
IEditPage found.

Implements

IEditPagesGetPageAt(Point)
See Also

Reference

EditPages Class
GetPageAt Overload
Alternet.Editor Namespace


EditPages.GetPageAt Method (Int32, Int32)

EditPagesGetPageAt Method (Int32, Int32)
Finds page at specified display position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPage GetPageAt(
    int x,
    int y
)
Public Overridable Function GetPageAt (
    x As Integer,
    y As Integer
) As IEditPage
public:
virtual IEditPage^ GetPageAt(
    int x,
    int y
)
abstract GetPageAt :
        x : int *
        y : int -> IEditPage
override GetPageAt :
        x : int *
        y : int -> IEditPage

Parameters

x
Type: SystemInt32
X-coordinate of the position (in display coordinates) to find the page.
y
Type: SystemInt32
Y-coordinate of the position (in display coordinates) to find the page.

Return Value

Type: IEditPage
IEditPage containing specified position.

Implements

IEditPagesGetPageAt(Int32, Int32)
See Also

Reference

EditPages Class
GetPageAt Overload
Alternet.Editor Namespace


EditPages.GetPageAtCursor Method

EditPagesGetPageAtCursor Method
Finds page at caret position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPage GetPageAtCursor()
Public Overridable Function GetPageAtCursor As IEditPage
public:
virtual IEditPage^ GetPageAtCursor()
abstract GetPageAtCursor : unit -> IEditPage
override GetPageAtCursor : unit -> IEditPage

Return Value

Type: IEditPage
IEditPage containing caret.

Implements

IEditPagesGetPageAtCursor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.GetPageAtPoint Method

EditPagesGetPageAtPoint Method
Overload List
 | Name | Description
Public method | GetPageAtPoint(Point) | Finds page at specified screen position.
Public method | GetPageAtPoint(Int32, Int32) | Finds page at specified screen position.
Top
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.GetPageAtPoint Method (Point)

EditPagesGetPageAtPoint Method (Point)
Finds page at specified screen position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPage GetPageAtPoint(
    Point position
)
Public Overridable Function GetPageAtPoint (
    position As Point
) As IEditPage
public:
virtual IEditPage^ GetPageAtPoint(
    Point position
)
abstract GetPageAtPoint :
        position : Point -> IEditPage
override GetPageAtPoint :
        position : Point -> IEditPage

Parameters

position
Type: System.DrawingPoint
Position in screen coordinates to obtain the page.

Return Value

Type: IEditPage
IEditPage containing specified position.

Implements

IEditPagesGetPageAtPoint(Point)
See Also

Reference

EditPages Class
GetPageAtPoint Overload
Alternet.Editor Namespace


EditPages.GetPageAtPoint Method (Int32, Int32)

EditPagesGetPageAtPoint Method (Int32, Int32)
Finds page at specified screen position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPage GetPageAtPoint(
    int x,
    int y
)
Public Overridable Function GetPageAtPoint (
    x As Integer,
    y As Integer
) As IEditPage
public:
virtual IEditPage^ GetPageAtPoint(
    int x,
    int y
)
abstract GetPageAtPoint :
        x : int *
        y : int -> IEditPage
override GetPageAtPoint :
        x : int *
        y : int -> IEditPage

Parameters

x
Type: SystemInt32
X-coordinate of the position (in screen coordinates) to find the page.
y
Type: SystemInt32
Y-coordinate of the position (in screen coordinates) to find the page.

Return Value

Type: IEditPage
IEditPage containing specified position.

Implements

IEditPagesGetPageAtPoint(Int32, Int32)
See Also

Reference

EditPages Class
GetPageAtPoint Overload
Alternet.Editor Namespace


EditPages.GetPageIndexAt Method

EditPagesGetPageIndexAt Method
Overload List
 | Name | Description
Public method | GetPageIndexAt(Point) | Finds page at specified display position.
Public method | GetPageIndexAt(Int32, Int32) | Finds page at specified display position.
Top
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.GetPageIndexAt Method (Point)

EditPagesGetPageIndexAt Method (Point)
Finds page at specified display position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPageIndexAt(
    Point position
)
Public Overridable Function GetPageIndexAt (
    position As Point
) As Integer
public:
virtual int GetPageIndexAt(
    Point position
)
abstract GetPageIndexAt :
        position : Point -> int
override GetPageIndexAt :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position in display coordinates to obtain the page.

Return Value

Type: Int32
Ordinal number of found page within the collection.

Implements

IEditPagesGetPageIndexAt(Point)
See Also

Reference

EditPages Class
GetPageIndexAt Overload
Alternet.Editor Namespace


EditPages.GetPageIndexAt Method (Int32, Int32)

EditPagesGetPageIndexAt Method (Int32, Int32)
Finds page at specified display position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPageIndexAt(
    int x,
    int y
)
Public Overridable Function GetPageIndexAt (
    x As Integer,
    y As Integer
) As Integer
public:
virtual int GetPageIndexAt(
    int x,
    int y
)
abstract GetPageIndexAt :
        x : int *
        y : int -> int
override GetPageIndexAt :
        x : int *
        y : int -> int

Parameters

x
Type: SystemInt32
X-coordinate of the position (in display coordinates) to find the page.
y
Type: SystemInt32
Y-coordinate of the position (in display coordinates) to find the page.

Return Value

Type: Int32
Ordinal number of found page within the collection.

Implements

IEditPagesGetPageIndexAt(Int32, Int32)
See Also

Reference

EditPages Class
GetPageIndexAt Overload
Alternet.Editor Namespace


EditPages.GetPageIndexAtCursor Method

EditPagesGetPageIndexAtCursor Method
Finds page at caret position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPageIndexAtCursor()
Public Overridable Function GetPageIndexAtCursor As Integer
public:
virtual int GetPageIndexAtCursor()
abstract GetPageIndexAtCursor : unit -> int
override GetPageIndexAtCursor : unit -> int

Return Value

Type: Int32
Ordinal number of found page within the collection.

Implements

IEditPagesGetPageIndexAtCursor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.GetPageIndexAtPoint Method

EditPagesGetPageIndexAtPoint Method
Overload List
 | Name | Description
Public method | GetPageIndexAtPoint(Point) | Finds page at specified screen position.
Public method | GetPageIndexAtPoint(Int32, Int32) | Finds page at specified screen position.
Top
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.GetPageIndexAtPoint Method (Point)

EditPagesGetPageIndexAtPoint Method (Point)
Finds page at specified screen position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPageIndexAtPoint(
    Point position
)
Public Overridable Function GetPageIndexAtPoint (
    position As Point
) As Integer
public:
virtual int GetPageIndexAtPoint(
    Point position
)
abstract GetPageIndexAtPoint :
        position : Point -> int
override GetPageIndexAtPoint :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position in screen coordinates to obtain the page.

Return Value

Type: Int32
Ordinal number of found page within the collection.

Implements

IEditPagesGetPageIndexAtPoint(Point)
See Also

Reference

EditPages Class
GetPageIndexAtPoint Overload
Alternet.Editor Namespace


EditPages.GetPageIndexAtPoint Method (Int32, Int32)

EditPagesGetPageIndexAtPoint Method (Int32, Int32)
Finds page at specified screen position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPageIndexAtPoint(
    int x,
    int y
)
Public Overridable Function GetPageIndexAtPoint (
    x As Integer,
    y As Integer
) As Integer
public:
virtual int GetPageIndexAtPoint(
    int x,
    int y
)
abstract GetPageIndexAtPoint :
        x : int *
        y : int -> int
override GetPageIndexAtPoint :
        x : int *
        y : int -> int

Parameters

x
Type: SystemInt32
X-coordinate of the position (in screen coordinates) to find the page.
y
Type: SystemInt32
Y-coordinate of the position (in screen coordinates) to find the page.

Return Value

Type: Int32
Ordinal number of found page within the collection.

Implements

IEditPagesGetPageIndexAtPoint(Int32, Int32)
See Also

Reference

EditPages Class
GetPageIndexAtPoint Overload
Alternet.Editor Namespace


EditPages.IndexOf Method

EditPagesIndexOf Method
Returns index of page within page collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int IndexOf(
    IEditPage page
)
Public Overridable Function IndexOf (
    page As IEditPage
) As Integer
public:
virtual int IndexOf(
    IEditPage^ page
)
abstract IndexOf :
        page : IEditPage -> int
override IndexOf :
        page : IEditPage -> int

Parameters

page
Type: Alternet.EditorIEditPage

Return Value

Type: Int32

Implements

IEditPagesIndexOf(IEditPage)
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.InitDefaultPageSettings Method

EditPagesInitDefaultPageSettings Method
Initializes page setting with default values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void InitDefaultPageSettings(
    PageSettings pageSettings
)
Public Overridable Sub InitDefaultPageSettings (
    pageSettings As PageSettings
)
public:
virtual void InitDefaultPageSettings(
    PageSettings^ pageSettings
)
abstract InitDefaultPageSettings :
        pageSettings : PageSettings -> unit
override InitDefaultPageSettings :
        pageSettings : PageSettings -> unit

Parameters

pageSettings
Type: System.Drawing.PrintingPageSettings
Specifies page settings to initialize.

Implements

IEditPagesInitDefaultPageSettings(PageSettings)
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Invalidate Method

EditPagesInvalidate Method
Invalidates specified page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Invalidate(
    IEditPage page
)
Public Overridable Sub Invalidate (
    page As IEditPage
)
public:
virtual void Invalidate(
    IEditPage^ page
)
abstract Invalidate :
        page : IEditPage -> unit
override Invalidate :
        page : IEditPage -> unit

Parameters

page
Type: Alternet.EditorIEditPage
Page to invalidate.

Implements

IEditPagesInvalidate(IEditPage)
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.IsTransparent Method

EditPagesIsTransparent Method
Indicates whether pages are transparent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsTransparent(
    bool nonClient
)
Public Overridable Function IsTransparent (
    nonClient As Boolean
) As Boolean
public:
virtual bool IsTransparent(
    bool nonClient
)
abstract IsTransparent :
        nonClient : bool -> bool
override IsTransparent :
        nonClient : bool -> bool

Parameters

nonClient
Type: SystemBoolean
True if non client editor area should be included to check-up.

Return Value

Type: Boolean
True if pages are transparent; otherwise false.
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.OnDrawHeader Method

EditPagesOnDrawHeader Method
Raises DrawHeader event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnDrawHeader(
    ref string text
)
Public Overridable Sub OnDrawHeader (
    ByRef text As String
)
public:
virtual void OnDrawHeader(
    String^% text
)
abstract OnDrawHeader :
        text : string byref -> unit
override OnDrawHeader :
        text : string byref -> unit

Parameters

text
Type: SystemString
Specifies text to draw.

Implements

IEditPagesOnDrawHeader(String)
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Paint Method

EditPagesPaint Method
Draws pages collection on the graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Paint(
    IPainter painter,
    Rectangle rect
)
Public Overridable Sub Paint (
    painter As IPainter,
    rect As Rectangle
)
public:
virtual void Paint(
    IPainter^ painter,
    Rectangle rect
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle -> unit
override Paint :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
rect
Type: System.DrawingRectangle
Rectangular area of pages collection to draw on.

Implements

IEditPagesPaint(IPainter, Rectangle)
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ResetBackColor Method

EditPagesResetBackColor Method
Resets BackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBackColor()
Public Overridable Sub ResetBackColor
public:
virtual void ResetBackColor()
abstract ResetBackColor : unit -> unit
override ResetBackColor : unit -> unit

Implements

IEditPagesResetBackColor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ResetBorderColor Method

EditPagesResetBorderColor Method
Resets BorderColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBorderColor()
Public Overridable Sub ResetBorderColor
public:
virtual void ResetBorderColor()
abstract ResetBorderColor : unit -> unit
override ResetBorderColor : unit -> unit

Implements

IEditPagesResetBorderColor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ResetDisplayWhiteSpace Method

EditPagesResetDisplayWhiteSpace Method
Resets DisplayWhiteSpace to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDisplayWhiteSpace()
Public Overridable Sub ResetDisplayWhiteSpace
public:
virtual void ResetDisplayWhiteSpace()
abstract ResetDisplayWhiteSpace : unit -> unit
override ResetDisplayWhiteSpace : unit -> unit

Implements

IEditPagesResetDisplayWhiteSpace
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ResetPageType Method

EditPagesResetPageType Method
Resets PageType to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetPageType()
Public Overridable Sub ResetPageType
public:
virtual void ResetPageType()
abstract ResetPageType : unit -> unit
override ResetPageType : unit -> unit

Implements

IEditPagesResetPageType
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ResetRulerBackColor Method

EditPagesResetRulerBackColor Method
Resets RulerBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetRulerBackColor()
Public Overridable Sub ResetRulerBackColor
public:
virtual void ResetRulerBackColor()
abstract ResetRulerBackColor : unit -> unit
override ResetRulerBackColor : unit -> unit

Implements

IEditPagesResetRulerBackColor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ResetRulerIndentBackColor Method

EditPagesResetRulerIndentBackColor Method
Resets RulerIndentBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetRulerIndentBackColor()
Public Overridable Sub ResetRulerIndentBackColor
public:
virtual void ResetRulerIndentBackColor()
abstract ResetRulerIndentBackColor : unit -> unit
override ResetRulerIndentBackColor : unit -> unit

Implements

IEditPagesResetRulerIndentBackColor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ResetRulerOptions Method

EditPagesResetRulerOptions Method
Resets RulerOptions to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetRulerOptions()
Public Overridable Sub ResetRulerOptions
public:
virtual void ResetRulerOptions()
abstract ResetRulerOptions : unit -> unit
override ResetRulerOptions : unit -> unit

Implements

IEditPagesResetRulerOptions
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ResetRulers Method

EditPagesResetRulers Method
Resets Rulers to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetRulers()
Public Overridable Sub ResetRulers
public:
virtual void ResetRulers()
abstract ResetRulers : unit -> unit
override ResetRulers : unit -> unit

Implements

IEditPagesResetRulers
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ResetRulerUnits Method

EditPagesResetRulerUnits Method
Resets RulerUnits to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetRulerUnits()
Public Overridable Sub ResetRulerUnits
public:
virtual void ResetRulerUnits()
abstract ResetRulerUnits : unit -> unit
override ResetRulerUnits : unit -> unit

Implements

IEditPagesResetRulerUnits
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ShouldSerializeBackColor Method

EditPagesShouldSerializeBackColor Method
Indicates whether the BackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBackColor()
Public Function ShouldSerializeBackColor As Boolean
public:
bool ShouldSerializeBackColor()
member ShouldSerializeBackColor : unit -> bool

Return Value

Type: Boolean
True if BackColor differs from its default value; otherwise false.
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ShouldSerializeBorderColor Method

EditPagesShouldSerializeBorderColor Method
Indicates whether the BorderColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBorderColor()
Public Function ShouldSerializeBorderColor As Boolean
public:
bool ShouldSerializeBorderColor()
member ShouldSerializeBorderColor : unit -> bool

Return Value

Type: Boolean
True if BorderColor differs from its default value; otherwise false.
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ShouldSerializePageKind Method

EditPagesShouldSerializePageKind Method
Indicates whether the PageKind property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePageKind()
Public Function ShouldSerializePageKind As Boolean
public:
bool ShouldSerializePageKind()
member ShouldSerializePageKind : unit -> bool

Return Value

Type: Boolean
True if PageKind differs from its default value; otherwise false.
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ShouldSerializeRulerBackColor Method

EditPagesShouldSerializeRulerBackColor Method
Indicates whether the RulerBackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeRulerBackColor()
Public Function ShouldSerializeRulerBackColor As Boolean
public:
bool ShouldSerializeRulerBackColor()
member ShouldSerializeRulerBackColor : unit -> bool

Return Value

Type: Boolean
True if RulerBackColor differs from its default value; otherwise false.
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ShouldSerializeRulerIndentBackColor Method

EditPagesShouldSerializeRulerIndentBackColor Method
Indicates whether the RulerIndentBackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeRulerIndentBackColor()
Public Function ShouldSerializeRulerIndentBackColor As Boolean
public:
bool ShouldSerializeRulerIndentBackColor()
member ShouldSerializeRulerIndentBackColor : unit -> bool

Return Value

Type: Boolean
True if RulerIndentBackColor differs from its default value; otherwise false.
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ShouldSerializeRulerOptions Method

EditPagesShouldSerializeRulerOptions Method
Indicates whether the RulerOptions property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeRulerOptions()
Public Function ShouldSerializeRulerOptions As Boolean
public:
bool ShouldSerializeRulerOptions()
member ShouldSerializeRulerOptions : unit -> bool

Return Value

Type: Boolean
True if RulerOptions differs from its default value; otherwise false.
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Update Method

EditPagesUpdate Method
Overload List
 | Name | Description
Public method | Update | Recalculates bounds of all pages in the collection.
Public method | Update(IEditPage) | Recalculates bounds of the specified page.
Public method | Update(IEditPage, Boolean) | Recalculates bounds and updates content of specified page.
Top
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Update Method

EditPagesUpdate Method
Recalculates bounds of all pages in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

EditPages Class
Update Overload
Alternet.Editor Namespace


EditPages.Update Method (IEditPage)

EditPagesUpdate Method (IEditPage)
Recalculates bounds of the specified page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    IEditPage page
)
Public Overridable Sub Update (
    page As IEditPage
)
public:
virtual void Update(
    IEditPage^ page
)
abstract Update :
        page : IEditPage -> unit
override Update :
        page : IEditPage -> unit

Parameters

page
Type: Alternet.EditorIEditPage
Page to update.

Implements

IEditPagesUpdate(IEditPage)
See Also

Reference

EditPages Class
Update Overload
Alternet.Editor Namespace


EditPages.Update Method (IEditPage, Boolean)

EditPagesUpdate Method (IEditPage, Boolean)
Recalculates bounds and updates content of specified page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update(
    IEditPage page,
    bool changed
)
Public Overridable Sub Update (
    page As IEditPage,
    changed As Boolean
)
public:
virtual void Update(
    IEditPage^ page,
    bool changed
)
abstract Update :
        page : IEditPage *
        changed : bool -> unit
override Update :
        page : IEditPage *
        changed : bool -> unit

Parameters

page
Type: Alternet.EditorIEditPage
Page to update.
changed
Type: SystemBoolean
Indicates that page should recalculate it's content.

Implements

IEditPagesUpdate(IEditPage, Boolean)
See Also

Reference

EditPages Class
Update Overload
Alternet.Editor Namespace


EditPages.UpdatePages Method

EditPagesUpdatePages Method
Recalculates bounds and updates content of specified page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdatePages(
    int index
)
Public Overridable Sub UpdatePages (
    index As Integer
)
public:
virtual void UpdatePages(
    int index
)
abstract UpdatePages :
        index : int -> unit
override UpdatePages :
        index : int -> unit

Parameters

index
Type: SystemInt32
Page index to update.

Implements

IEditPagesUpdatePages(Int32)
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages Properties

EditPages Properties

The EditPages type exposes the following members.

Properties
 | Name | Description
Public property | ApplyRulerToAllPages | Gets or sets a boolean value that indicates that changing of rulers indentation applies to all pages rather than to current page.
Public property | BackColor | Gets or sets a background color of each page in the collection.
Public property | BorderColor | Gets or sets a border color of each page in the collection.
Public property | Caps | Gets size in pixels per logical inch of entire screen.
Public property | Count | Represents a number of pages in the collection.
Public property | DefaultLandscape | Represents default page landscape.
Public property | DefaultMargins | Represents default page margins.
Public property | DefaultPage | Gets or sets properties for default IEditPage object in the pages collection.
Public property | DefaultPageKind | Represents default page kind.
Public property | DefaultPageSize | Represents default page size.
Public property | DisplayWhiteSpace | Gets or sets a boolean value that indicates whether Edit control should draw whitespace area between pages.
Public property | Height | Represents total height of all pages in the collection.
Public property | HorzRuler | Represents IEditRuler object used as a horizontal page ruler.
Public property | Item | Provides an indexed access to individual IEditPage stored in the collection.
Public property | List | Provides an indexed access to individual pages within IEditPages collection.
Public property | Owner | Gets Edit control owns this pages.
Public property | PageKind | Gets or sets kind of the pages specifying standard paper size.
Public property | PageType | Gets or sets value specifying the way of viewing Edit control's content.
Public property | RulerBackColor | Gets or sets background color of the pages rulers.
Public property | RulerIndentBackColor | Gets or sets background color of the indentations parts of the pages rulers.
Public property | RulerOptions | Gets or sets options of the pages rulers.
Public property | Rulers | Gets or sets the rulers displayed within Edit control.
Public property | RulerUnits | Gets or sets measurement units of the pages rulers.
Public property | Transparent | Gets or sets a boolean value that indicates whether Edit control should draw background around the pages.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | VertRuler | Represents IEditRuler object used as a vertical page ruler.
Public property | Width | Represents pages width.
Top
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.ApplyRulerToAllPages Property

EditPagesApplyRulerToAllPages Property
Gets or sets a boolean value that indicates that changing of rulers indentation applies to all pages rather than to current page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ApplyRulerToAllPages { get; set; }
Public Overridable Property ApplyRulerToAllPages As Boolean
    Get
    Set
public:
virtual property bool ApplyRulerToAllPages {
    bool get ();
    void set (bool value);
}
abstract ApplyRulerToAllPages : bool with get, set
override ApplyRulerToAllPages : bool with get, set

Property Value

Type: Boolean

Implements

IEditPagesApplyRulerToAllPages
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.BackColor Property

EditPagesBackColor Property
Gets or sets a background color of each page in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BackColor { get; set; }
Public Overridable Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color

Implements

IEditPagesBackColor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.BorderColor Property

EditPagesBorderColor Property
Gets or sets a border color of each page in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BorderColor { get; set; }
Public Overridable Property BorderColor As Color
    Get
    Set
public:
virtual property Color BorderColor {
    Color get ();
    void set (Color value);
}
abstract BorderColor : Color with get, set
override BorderColor : Color with get, set

Property Value

Type: Color

Implements

IEditPagesBorderColor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Caps Property

EditPagesCaps Property
Gets size in pixels per logical inch of entire screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size Caps { get; }
Public Overridable ReadOnly Property Caps As Size
    Get
public:
virtual property Size Caps {
    Size get ();
}
abstract Caps : Size with get
override Caps : Size with get

Property Value

Type: Size

Implements

IEditPagesCaps
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Count Property

EditPagesCount Property
Represents a number of pages in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

IEditPagesCount
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.DefaultLandscape Property

EditPagesDefaultLandscape Property
Represents default page landscape.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DefaultLandscape { get; }
Public Overridable ReadOnly Property DefaultLandscape As Boolean
    Get
public:
virtual property bool DefaultLandscape {
    bool get ();
}
abstract DefaultLandscape : bool with get
override DefaultLandscape : bool with get

Property Value

Type: Boolean

Implements

IEditPagesDefaultLandscape
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.DefaultMargins Property

EditPagesDefaultMargins Property
Represents default page margins.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Margins DefaultMargins { get; }
Public Overridable ReadOnly Property DefaultMargins As Margins
    Get
public:
virtual property Margins^ DefaultMargins {
    Margins^ get ();
}
abstract DefaultMargins : Margins with get
override DefaultMargins : Margins with get

Property Value

Type: Margins

Implements

IEditPagesDefaultMargins
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.DefaultPage Property

EditPagesDefaultPage Property
Gets or sets properties for default IEditPage object in the pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IEditPage DefaultPage { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property DefaultPage As IEditPage
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IEditPage^ DefaultPage {
    IEditPage^ get ();
    void set (IEditPage^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract DefaultPage : IEditPage with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override DefaultPage : IEditPage with get, set

Property Value

Type: IEditPage

Implements

IEditPagesDefaultPage
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.DefaultPageKind Property

EditPagesDefaultPageKind Property
Represents default page kind.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PaperKind DefaultPageKind { get; }
Public Overridable ReadOnly Property DefaultPageKind As PaperKind
    Get
public:
virtual property PaperKind DefaultPageKind {
    PaperKind get ();
}
abstract DefaultPageKind : PaperKind with get
override DefaultPageKind : PaperKind with get

Property Value

Type: PaperKind

Implements

IEditPagesDefaultPageKind
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.DefaultPageSize Property

EditPagesDefaultPageSize Property
Represents default page size.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size DefaultPageSize { get; }
Public Overridable ReadOnly Property DefaultPageSize As Size
    Get
public:
virtual property Size DefaultPageSize {
    Size get ();
}
abstract DefaultPageSize : Size with get
override DefaultPageSize : Size with get

Property Value

Type: Size

Implements

IEditPagesDefaultPageSize
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.DisplayWhiteSpace Property

EditPagesDisplayWhiteSpace Property
Gets or sets a boolean value that indicates whether Edit control should draw whitespace area between pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DisplayWhiteSpace { get; set; }
Public Overridable Property DisplayWhiteSpace As Boolean
    Get
    Set
public:
virtual property bool DisplayWhiteSpace {
    bool get ();
    void set (bool value);
}
abstract DisplayWhiteSpace : bool with get, set
override DisplayWhiteSpace : bool with get, set

Property Value

Type: Boolean

Implements

IEditPagesDisplayWhiteSpace
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Height Property

EditPagesHeight Property
Represents total height of all pages in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Height { get; }
Public Overridable ReadOnly Property Height As Integer
    Get
public:
virtual property int Height {
    int get ();
}
abstract Height : int with get
override Height : int with get

Property Value

Type: Int32

Implements

IEditPagesHeight
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.HorzRuler Property

EditPagesHorzRuler Property
Represents IEditRuler object used as a horizontal page ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditRuler HorzRuler { get; }
Public Overridable ReadOnly Property HorzRuler As IEditRuler
    Get
public:
virtual property IEditRuler^ HorzRuler {
    IEditRuler^ get ();
}
abstract HorzRuler : IEditRuler with get
override HorzRuler : IEditRuler with get

Property Value

Type: IEditRuler

Implements

IEditPagesHorzRuler
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Item Property

EditPagesItem Property
Provides an indexed access to individual IEditPage stored in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPage this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As IEditPage
    Get
    Set
public:
virtual property IEditPage^ default[int index] {
    IEditPage^ get (int index);
    void set (int index, IEditPage^ value);
}
abstract Item : IEditPage with get, set
override Item : IEditPage with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: IEditPage

Implements

IEditPagesItemInt32
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.List Property

EditPagesList Property
Provides an indexed access to individual pages within IEditPages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<IEditPage> List { get; }
Public Overridable ReadOnly Property List As IList(Of IEditPage)
    Get
public:
virtual property IList<IEditPage^>^ List {
    IList<IEditPage^>^ get ();
}
abstract List : IList<IEditPage> with get
override List : IList<IEditPage> with get

Property Value

Type: IListIEditPage

Implements

IEditPagesList
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Owner Property

EditPagesOwner Property
Gets Edit control owns this pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxEdit Owner { get; }
Public Overridable ReadOnly Property Owner As ISyntaxEdit
    Get
public:
virtual property ISyntaxEdit^ Owner {
    ISyntaxEdit^ get ();
}
abstract Owner : ISyntaxEdit with get
override Owner : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.PageKind Property

EditPagesPageKind Property
Gets or sets kind of the pages specifying standard paper size.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PaperKind PageKind { get; set; }
Public Overridable Property PageKind As PaperKind
    Get
    Set
public:
virtual property PaperKind PageKind {
    PaperKind get ();
    void set (PaperKind value);
}
abstract PageKind : PaperKind with get, set
override PageKind : PaperKind with get, set

Property Value

Type: PaperKind

Implements

IEditPagesPageKind
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.PageType Property

EditPagesPageType Property
Gets or sets value specifying the way of viewing Edit control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PageType PageType { get; set; }
Public Overridable Property PageType As PageType
    Get
    Set
public:
virtual property PageType PageType {
    PageType get ();
    void set (PageType value);
}
abstract PageType : PageType with get, set
override PageType : PageType with get, set

Property Value

Type: PageType

Implements

IEditPagesPageType
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.RulerBackColor Property

EditPagesRulerBackColor Property
Gets or sets background color of the pages rulers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color RulerBackColor { get; set; }
Public Overridable Property RulerBackColor As Color
    Get
    Set
public:
virtual property Color RulerBackColor {
    Color get ();
    void set (Color value);
}
abstract RulerBackColor : Color with get, set
override RulerBackColor : Color with get, set

Property Value

Type: Color

Implements

IEditPagesRulerBackColor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.RulerIndentBackColor Property

EditPagesRulerIndentBackColor Property
Gets or sets background color of the indentations parts of the pages rulers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color RulerIndentBackColor { get; set; }
Public Property RulerIndentBackColor As Color
    Get
    Set
public:
virtual property Color RulerIndentBackColor {
    Color get () sealed;
    void set (Color value) sealed;
}
abstract RulerIndentBackColor : Color with get, set
override RulerIndentBackColor : Color with get, set

Property Value

Type: Color

Implements

IEditPagesRulerIndentBackColor
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.RulerOptions Property

EditPagesRulerOptions Property
Gets or sets options of the pages rulers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual RulerOptions RulerOptions { get; set; }
Public Overridable Property RulerOptions As RulerOptions
    Get
    Set
public:
virtual property RulerOptions RulerOptions {
    RulerOptions get ();
    void set (RulerOptions value);
}
abstract RulerOptions : RulerOptions with get, set
override RulerOptions : RulerOptions with get, set

Property Value

Type: RulerOptions

Implements

IEditPagesRulerOptions
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Rulers Property

EditPagesRulers Property
Gets or sets the rulers displayed within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual EditRulers Rulers { get; set; }
Public Overridable Property Rulers As EditRulers
    Get
    Set
public:
virtual property EditRulers Rulers {
    EditRulers get ();
    void set (EditRulers value);
}
abstract Rulers : EditRulers with get, set
override Rulers : EditRulers with get, set

Property Value

Type: EditRulers

Implements

IEditPagesRulers
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.RulerUnits Property

EditPagesRulerUnits Property
Gets or sets measurement units of the pages rulers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual RulerUnits RulerUnits { get; set; }
Public Overridable Property RulerUnits As RulerUnits
    Get
    Set
public:
virtual property RulerUnits RulerUnits {
    RulerUnits get ();
    void set (RulerUnits value);
}
abstract RulerUnits : RulerUnits with get, set
override RulerUnits : RulerUnits with get, set

Property Value

Type: RulerUnits

Implements

IEditPagesRulerUnits
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Transparent Property

EditPagesTransparent Property
Gets or sets a boolean value that indicates whether Edit control should draw background around the pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Transparent { get; set; }
Public Overridable Property Transparent As Boolean
    Get
    Set
public:
virtual property bool Transparent {
    bool get ();
    void set (bool value);
}
abstract Transparent : bool with get, set
override Transparent : bool with get, set

Property Value

Type: Boolean

Implements

IEditPagesTransparent
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.UpdateCount Property

EditPagesUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.VertRuler Property

EditPagesVertRuler Property
Represents IEditRuler object used as a vertical page ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditRuler VertRuler { get; }
Public Overridable ReadOnly Property VertRuler As IEditRuler
    Get
public:
virtual property IEditRuler^ VertRuler {
    IEditRuler^ get ();
}
abstract VertRuler : IEditRuler with get
override VertRuler : IEditRuler with get

Property Value

Type: IEditRuler

Implements

IEditPagesVertRuler
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.Width Property

EditPagesWidth Property
Represents pages width.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Width { get; }
Public Overridable ReadOnly Property Width As Integer
    Get
public:
virtual property int Width {
    int get ();
}
abstract Width : int with get
override Width : int with get

Property Value

Type: Int32

Implements

IEditPagesWidth
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages Events

EditPages Events

The EditPages type exposes the following members.

Events
 | Name | Description
Public event | DrawHeader | Occurs when header or footer part of each page is drawing.
Top
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditPages.DrawHeader Event

EditPagesDrawHeader Event
Occurs when header or footer part of each page is drawing.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event DrawHeaderEvent DrawHeader
Public Event DrawHeader As DrawHeaderEvent
public:
virtual  event DrawHeaderEvent^ DrawHeader {
    void add (DrawHeaderEvent^ value);
    void remove (DrawHeaderEvent^ value);
}
abstract DrawHeader : IEvent<DrawHeaderEvent,
    DrawHeaderEventArgs>
override DrawHeader : IEvent<DrawHeaderEvent,
    DrawHeaderEventArgs>

Value

Type: Alternet.EditorDrawHeaderEvent

Implements

IEditPagesDrawHeader
See Also

Reference

EditPages Class
Alternet.Editor Namespace


EditRuler Class

EditRuler Class
Represents Edit control's ruler.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.EditorEditRuler

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditRuler : Control, IEditRuler,
    IControl
Public Class EditRuler
    Inherits Control
    Implements IEditRuler, IControl
public ref class EditRuler : public Control,
    IEditRuler, IControl
type EditRuler =
    class
        inherit Control
        interface IEditRuler
        interface IControl
    end

The EditRuler type exposes the following members.

Constructors
 | Name | Description
Public method | EditRuler | Initializes a new instance of the EditRuler with default settings.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another IEditRuler object.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CancelDragging | Cancels dragging operation.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetIndentBackColor | Resets the IndentBackColor to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResetUnits | Resets the Units to the default value.
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IndentBackColor | Gets or sets background color of indentation parts of the ruler.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDragging | Indicates whether some of ruler indentation is in dragging state.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MarkWidth | Gets or sets default distance between adjacent marks.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Options | Gets or sets RulerOptions determining ruler behaviour.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageStart | Gets or sets beginning of the page part of the ruler.
Public property | PageWidth | Gets or sets width, in pixels between left and right indentations indicating width of the page.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RulerStart | Gets or sets position, in pixels, of left indentation specifying start of the page.
Public property | RulerWidth | Gets or sets ruler width.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Units | Gets or sets ruler measurement units.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Vertical | Gets or sets a boolean value indicating whether ruler has vertical or horizontal direction.
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | Change | Occurs when some of ruler indentations has changed its position due to the dragging operation.
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor Namespace


EditRuler Constructor

EditRuler Constructor
Initializes a new instance of the EditRuler with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditRuler()
Public Sub New
public:
EditRuler()
new : unit -> EditRuler
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler Methods

EditRuler Methods

The EditRuler type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another IEditRuler object.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CancelDragging | Cancels dragging operation.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetIndentBackColor | Resets the IndentBackColor to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResetUnits | Resets the Units to the default value.
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.Assign Method

EditRulerAssign Method
Copies the contents of another IEditRuler object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IEditRuler source
)
Public Overridable Sub Assign (
    source As IEditRuler
)
public:
virtual void Assign(
    IEditRuler^ source
)
abstract Assign :
        source : IEditRuler -> unit
override Assign :
        source : IEditRuler -> unit

Parameters

source
Type: Alternet.EditorIEditRuler
Specifies IEditRuler to assign.

Implements

IEditRulerAssign(IEditRuler)
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.CancelDragging Method

EditRulerCancelDragging Method
Cancels dragging operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CancelDragging()
Public Overridable Sub CancelDragging
public:
virtual void CancelDragging()
abstract CancelDragging : unit -> unit
override CancelDragging : unit -> unit

Implements

IEditRulerCancelDragging
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.ResetIndentBackColor Method

EditRulerResetIndentBackColor Method
Resets the IndentBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetIndentBackColor()
Public Overridable Sub ResetIndentBackColor
public:
virtual void ResetIndentBackColor()
abstract ResetIndentBackColor : unit -> unit
override ResetIndentBackColor : unit -> unit

Implements

IEditRulerResetIndentBackColor
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.ResetOptions Method

EditRulerResetOptions Method
Resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOptions()
Public Overridable Sub ResetOptions
public:
virtual void ResetOptions()
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

IEditRulerResetOptions
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.ResetUnits Method

EditRulerResetUnits Method
Resets the Units to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUnits()
Public Overridable Sub ResetUnits
public:
virtual void ResetUnits()
abstract ResetUnits : unit -> unit
override ResetUnits : unit -> unit

Implements

IEditRulerResetUnits
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler Properties

EditRuler Properties

The EditRuler type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IndentBackColor | Gets or sets background color of indentation parts of the ruler.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDragging | Indicates whether some of ruler indentation is in dragging state.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MarkWidth | Gets or sets default distance between adjacent marks.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Options | Gets or sets RulerOptions determining ruler behaviour.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | PageStart | Gets or sets beginning of the page part of the ruler.
Public property | PageWidth | Gets or sets width, in pixels between left and right indentations indicating width of the page.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RulerStart | Gets or sets position, in pixels, of left indentation specifying start of the page.
Public property | RulerWidth | Gets or sets ruler width.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Units | Gets or sets ruler measurement units.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Vertical | Gets or sets a boolean value indicating whether ruler has vertical or horizontal direction.
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.IndentBackColor Property

EditRulerIndentBackColor Property
Gets or sets background color of indentation parts of the ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color IndentBackColor { get; set; }
Public Overridable Property IndentBackColor As Color
    Get
    Set
public:
virtual property Color IndentBackColor {
    Color get ();
    void set (Color value);
}
abstract IndentBackColor : Color with get, set
override IndentBackColor : Color with get, set

Property Value

Type: Color

Implements

IEditRulerIndentBackColor
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.IsDragging Property

EditRulerIsDragging Property
Indicates whether some of ruler indentation is in dragging state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDragging { get; }
Public Overridable ReadOnly Property IsDragging As Boolean
    Get
public:
virtual property bool IsDragging {
    bool get ();
}
abstract IsDragging : bool with get
override IsDragging : bool with get

Property Value

Type: Boolean

Implements

IEditRulerIsDragging
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.MarkWidth Property

EditRulerMarkWidth Property
Gets or sets default distance between adjacent marks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MarkWidth { get; set; }
Public Overridable Property MarkWidth As Integer
    Get
    Set
public:
virtual property int MarkWidth {
    int get ();
    void set (int value);
}
abstract MarkWidth : int with get, set
override MarkWidth : int with get, set

Property Value

Type: Int32

Implements

IEditRulerMarkWidth
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.Options Property

EditRulerOptions Property
Gets or sets RulerOptions determining ruler behaviour.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual RulerOptions Options { get; set; }
Public Overridable Property Options As RulerOptions
    Get
    Set
public:
virtual property RulerOptions Options {
    RulerOptions get ();
    void set (RulerOptions value);
}
abstract Options : RulerOptions with get, set
override Options : RulerOptions with get, set

Property Value

Type: RulerOptions

Implements

IEditRulerOptions
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.PageStart Property

EditRulerPageStart Property
Gets or sets beginning of the page part of the ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PageStart { get; set; }
Public Overridable Property PageStart As Integer
    Get
    Set
public:
virtual property int PageStart {
    int get ();
    void set (int value);
}
abstract PageStart : int with get, set
override PageStart : int with get, set

Property Value

Type: Int32

Implements

IEditRulerPageStart
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.PageWidth Property

EditRulerPageWidth Property
Gets or sets width, in pixels between left and right indentations indicating width of the page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PageWidth { get; set; }
Public Overridable Property PageWidth As Integer
    Get
    Set
public:
virtual property int PageWidth {
    int get ();
    void set (int value);
}
abstract PageWidth : int with get, set
override PageWidth : int with get, set

Property Value

Type: Int32

Implements

IEditRulerPageWidth
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.RulerStart Property

EditRulerRulerStart Property
Gets or sets position, in pixels, of left indentation specifying start of the page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RulerStart { get; set; }
Public Property RulerStart As Integer
    Get
    Set
public:
virtual property int RulerStart {
    int get () sealed;
    void set (int value) sealed;
}
abstract RulerStart : int with get, set
override RulerStart : int with get, set

Property Value

Type: Int32

Implements

IEditRulerRulerStart
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.RulerWidth Property

EditRulerRulerWidth Property
Gets or sets ruler width.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int RulerWidth { get; set; }
Public Overridable Property RulerWidth As Integer
    Get
    Set
public:
virtual property int RulerWidth {
    int get ();
    void set (int value);
}
abstract RulerWidth : int with get, set
override RulerWidth : int with get, set

Property Value

Type: Int32

Implements

IEditRulerRulerWidth
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.Units Property

EditRulerUnits Property
Gets or sets ruler measurement units.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual RulerUnits Units { get; set; }
Public Overridable Property Units As RulerUnits
    Get
    Set
public:
virtual property RulerUnits Units {
    RulerUnits get ();
    void set (RulerUnits value);
}
abstract Units : RulerUnits with get, set
override Units : RulerUnits with get, set

Property Value

Type: RulerUnits

Implements

IEditRulerUnits
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.Vertical Property

EditRulerVertical Property
Gets or sets a boolean value indicating whether ruler has vertical or horizontal direction.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Vertical { get; set; }
Public Overridable Property Vertical As Boolean
    Get
    Set
public:
virtual property bool Vertical {
    bool get ();
    void set (bool value);
}
abstract Vertical : bool with get, set
override Vertical : bool with get, set

Property Value

Type: Boolean

Implements

IEditRulerVertical
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler Events

EditRuler Events

The EditRuler type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | Change | Occurs when some of ruler indentations has changed its position due to the dragging operation.
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRuler.Change Event

EditRulerChange Event
Occurs when some of ruler indentations has changed its position due to the dragging operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Change
Public Event Change As EventHandler
public:
virtual  event EventHandler^ Change {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Change : IEvent<EventHandler,
    EventArgs>
override Change : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IEditRulerChange
See Also

Reference

EditRuler Class
Alternet.Editor Namespace


EditRulers Enumeration

EditRulers Enumeration
Specifies appearance of Edit control rulers. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum EditRulers
<FlagsAttribute>
Public Enumeration EditRulers
[FlagsAttribute]
public enum class EditRulers
[<FlagsAttribute>]
type EditRulers
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Horizonal | 1 | Display a horizontal ruler.
Vertical | 2 | Display a vertical ruler.
See Also

Reference

Alternet.Editor Namespace


EditSpelling Class

EditSpelling Class
Represents properties and methods allowing to visually highlight misspelled words in the control.
Inheritance Hierarchy
SystemObject
Alternet.EditorEditSpelling

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditSpelling : IEditSpelling,
    ISpelling
Public Class EditSpelling
    Implements IEditSpelling, ISpelling
public ref class EditSpelling : IEditSpelling,
    ISpelling
type EditSpelling =
    class
        interface IEditSpelling
        interface ISpelling
    end

The EditSpelling type exposes the following members.

Constructors
 | Name | Description
Public method | EditSpelling | Initializes a new instance of the Spelling class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents from another IEditSpelling object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct.
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct.
Public method | ResetCheckSpelling | Resets the CheckSpelling to the default value.
Public method | ResetSpellColor | Resets the SpellColor to the default value.
Public method | ResetSpellDelimiters | Resets the SpellDelimiters to the default value.
Public method | ShouldSerializeSpellColor | Indicates whether the SpellColor property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CheckSpelling | Gets or sets a value indicating whether the document can check spelling for its content.
Public property | HasSpelling | Gets boolean value indicating that editor has external spell checker assigned.
Public property | SpellColor | Gets or sets a value representing color to draw wavy underlines under misspelled words.
Public property | SpellDelimiters | Gets or sets an array of chars used to separate words in a text.
Public property | SpellDelimiterString | Gets or sets Delimiters as a single string.
Public property | SpellTable | Represents a hash table containing delimiters.
Top
Events
 | Name | Description
Public event | WordSpell | Occurs when spelling of some word within the text needs checking.
Top
See Also

Reference

Alternet.Editor Namespace


EditSpelling Constructor

EditSpelling Constructor
Initializes a new instance of the Spelling class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditSpelling(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
EditSpelling(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> EditSpelling

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling Methods

EditSpelling Methods

The EditSpelling type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents from another IEditSpelling object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct.
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct.
Public method | ResetCheckSpelling | Resets the CheckSpelling to the default value.
Public method | ResetSpellColor | Resets the SpellColor to the default value.
Public method | ResetSpellDelimiters | Resets the SpellDelimiters to the default value.
Public method | ShouldSerializeSpellColor | Indicates whether the SpellColor property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.Assign Method

EditSpellingAssign Method
Copies the contents from another IEditSpelling object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IEditSpelling source
)
Public Overridable Sub Assign (
    source As IEditSpelling
)
public:
virtual void Assign(
    IEditSpelling^ source
)
abstract Assign :
        source : IEditSpelling -> unit
override Assign :
        source : IEditSpelling -> unit

Parameters

source
Type: Alternet.EditorIEditSpelling
Specifies IEditSpelling to assign.

Implements

IEditSpellingAssign(IEditSpelling)
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.IsWordCorrect Method

EditSpellingIsWordCorrect Method
Overload List
 | Name | Description
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct.
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct.
Top
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.IsWordCorrect Method (String)

EditSpellingIsWordCorrect Method (String)
Checks whether spelling for the given word is correct.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsWordCorrect(
    string text
)
Public Overridable Function IsWordCorrect (
    text As String
) As Boolean
public:
virtual bool IsWordCorrect(
    String^ text
)
abstract IsWordCorrect :
        text : string -> bool
override IsWordCorrect :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies text to check-up.

Return Value

Type: Boolean
True if correct; otherwise false.

Implements

ISpellingIsWordCorrect(String)
See Also

Reference

EditSpelling Class
IsWordCorrect Overload
Alternet.Editor Namespace


EditSpelling.IsWordCorrect Method (String, Point)

EditSpellingIsWordCorrect Method (String, Point)
Checks whether spelling for the given word is correct.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsWordCorrect(
    string text,
    Point position
)
Public Overridable Function IsWordCorrect (
    text As String,
    position As Point
) As Boolean
public:
virtual bool IsWordCorrect(
    String^ text,
    Point position
)
abstract IsWordCorrect :
        text : string *
        position : Point -> bool
override IsWordCorrect :
        text : string *
        position : Point -> bool

Parameters

text
Type: SystemString
Specifies text to check-up.
position
Type: System.DrawingPoint
Specifies position of the word within the text.

Return Value

Type: Boolean
True if correct; otherwise false.

Implements

ISpellingIsWordCorrect(String, Point)
See Also

Reference

EditSpelling Class
IsWordCorrect Overload
Alternet.Editor Namespace


EditSpelling.ResetCheckSpelling Method

EditSpellingResetCheckSpelling Method
Resets the CheckSpelling to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetCheckSpelling()
Public Overridable Sub ResetCheckSpelling
public:
virtual void ResetCheckSpelling()
abstract ResetCheckSpelling : unit -> unit
override ResetCheckSpelling : unit -> unit

Implements

ISpellingResetCheckSpelling
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.ResetSpellColor Method

EditSpellingResetSpellColor Method
Resets the SpellColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSpellColor()
Public Overridable Sub ResetSpellColor
public:
virtual void ResetSpellColor()
abstract ResetSpellColor : unit -> unit
override ResetSpellColor : unit -> unit

Implements

IEditSpellingResetSpellColor
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.ResetSpellDelimiters Method

EditSpellingResetSpellDelimiters Method
Resets the SpellDelimiters to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSpellDelimiters()
Public Overridable Sub ResetSpellDelimiters
public:
virtual void ResetSpellDelimiters()
abstract ResetSpellDelimiters : unit -> unit
override ResetSpellDelimiters : unit -> unit

Implements

ISpellingResetSpellDelimiters
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.ShouldSerializeSpellColor Method

EditSpellingShouldSerializeSpellColor Method
Indicates whether the SpellColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeSpellColor()
Public Function ShouldSerializeSpellColor As Boolean
public:
bool ShouldSerializeSpellColor()
member ShouldSerializeSpellColor : unit -> bool

Return Value

Type: Boolean
True if SpellColor differs from its default value; otherwise false.
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling Properties

EditSpelling Properties

The EditSpelling type exposes the following members.

Properties
 | Name | Description
Public property | CheckSpelling | Gets or sets a value indicating whether the document can check spelling for its content.
Public property | HasSpelling | Gets boolean value indicating that editor has external spell checker assigned.
Public property | SpellColor | Gets or sets a value representing color to draw wavy underlines under misspelled words.
Public property | SpellDelimiters | Gets or sets an array of chars used to separate words in a text.
Public property | SpellDelimiterString | Gets or sets Delimiters as a single string.
Public property | SpellTable | Represents a hash table containing delimiters.
Top
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.CheckSpelling Property

EditSpellingCheckSpelling Property
Gets or sets a value indicating whether the document can check spelling for its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CheckSpelling { get; set; }
Public Overridable Property CheckSpelling As Boolean
    Get
    Set
public:
virtual property bool CheckSpelling {
    bool get ();
    void set (bool value);
}
abstract CheckSpelling : bool with get, set
override CheckSpelling : bool with get, set

Property Value

Type: Boolean

Implements

IEditSpellingCheckSpelling
ISpellingCheckSpelling
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.HasSpelling Property

EditSpellingHasSpelling Property
Gets boolean value indicating that editor has external spell checker assigned.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasSpelling { get; }
Public Overridable ReadOnly Property HasSpelling As Boolean
    Get
public:
virtual property bool HasSpelling {
    bool get ();
}
abstract HasSpelling : bool with get
override HasSpelling : bool with get

Property Value

Type: Boolean

Implements

ISpellingHasSpelling
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.SpellColor Property

EditSpellingSpellColor Property
Gets or sets a value representing color to draw wavy underlines under misspelled words.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color SpellColor { get; set; }
Public Overridable Property SpellColor As Color
    Get
    Set
public:
virtual property Color SpellColor {
    Color get ();
    void set (Color value);
}
abstract SpellColor : Color with get, set
override SpellColor : Color with get, set

Property Value

Type: Color

Implements

IEditSpellingSpellColor
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.SpellDelimiters Property

EditSpellingSpellDelimiters Property
Gets or sets an array of chars used to separate words in a text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] SpellDelimiters { get; set; }
Public Overridable Property SpellDelimiters As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ SpellDelimiters {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract SpellDelimiters : char[] with get, set
override SpellDelimiters : char[] with get, set

Property Value

Type: Char

Implements

ISpellingSpellDelimiters
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.SpellDelimiterString Property

EditSpellingSpellDelimiterString Property
Gets or sets Delimiters as a single string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string SpellDelimiterString { get; set; }
Public Overridable Property SpellDelimiterString As String
    Get
    Set
public:
virtual property String^ SpellDelimiterString {
    String^ get ();
    void set (String^ value);
}
abstract SpellDelimiterString : string with get, set
override SpellDelimiterString : string with get, set

Property Value

Type: String

Implements

ISpellingSpellDelimiterString
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.SpellTable Property

EditSpellingSpellTable Property
Represents a hash table containing delimiters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Hashtable SpellTable { get; }
Public Overridable ReadOnly Property SpellTable As Hashtable
    Get
public:
virtual property Hashtable^ SpellTable {
    Hashtable^ get ();
}
abstract SpellTable : Hashtable with get
override SpellTable : Hashtable with get

Property Value

Type: Hashtable

Implements

ISpellingSpellTable
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling Events

EditSpelling Events

The EditSpelling type exposes the following members.

Events
 | Name | Description
Public event | WordSpell | Occurs when spelling of some word within the text needs checking.
Top
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSpelling.WordSpell Event

EditSpellingWordSpell Event
Occurs when spelling of some word within the text needs checking.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event WordSpellEvent WordSpell
Public Event WordSpell As WordSpellEvent
public:
virtual  event WordSpellEvent^ WordSpell {
    void add (WordSpellEvent^ value);
    void remove (WordSpellEvent^ value);
}
abstract WordSpell : IEvent<WordSpellEvent,
    WordSpellEventArgs>
override WordSpell : IEvent<WordSpellEvent,
    WordSpellEventArgs>

Value

Type: Alternet.Editor.TextSourceWordSpellEvent

Implements

ISpellingWordSpell
See Also

Reference

EditSpelling Class
Alternet.Editor Namespace


EditSyntaxPaint Class

EditSyntaxPaint Class
Represents properties and methods, used to draw text and graphic primitives.
Inheritance Hierarchy
SystemObject
Alternet.EditorSyntaxPaint
Alternet.EditorEditSyntaxPaint

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditSyntaxPaint : SyntaxPaint,
    IEditSyntaxPaint, ISyntaxPaint
Public Class EditSyntaxPaint
    Inherits SyntaxPaint
    Implements IEditSyntaxPaint, ISyntaxPaint
public ref class EditSyntaxPaint : public SyntaxPaint,
    IEditSyntaxPaint, ISyntaxPaint
type EditSyntaxPaint =
    class
        inherit SyntaxPaint
        interface IEditSyntaxPaint
        interface ISyntaxPaint
    end

The EditSyntaxPaint type exposes the following members.

Constructors
 | Name | Description
Public method | EditSyntaxPaint | Initializes a new instance of the EditSyntaxPaint class with specified parameters.
Top
Methods
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position. (Overrides SyntaxPaintDrawLine(Int32, Point, Rectangle).)
Public method | DrawLine(Int32, Point, Rectangle, Int32) | Draws line given by its index at the specified position.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal. (Inherited from SyntaxPaint.)
Public method | GetBackColor(Boolean) | Retrieves background color in accordance with specified parameter and editor settings.
Public method | GetBackColor(Color, TextStyle) | Retrieves background color corresponding to given state. (Overrides SyntaxPaintGetBackColor(Color, TextStyle).)
Public method | GetFontColor | Retrieves font color corresponding to given state. (Overrides SyntaxPaintGetFontColor(Color, TextStyle).)
Public method | GetFontStyle | Retrieves font style corresponding to given state. (Overrides SyntaxPaintGetFontStyle(FontStyle, TextStyle).)
Public method | GetForeColor | Retrieves foreground color in accordance with specified parameter and editor settings.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style. (Inherited from SyntaxPaint.)
Public method | GetRectRegion(Rectangle) | Returns region corresponding to given rectangle.
Public method | GetRectRegion(SelectionType, Rectangle, Boolean, Boolean) | Returns region corresponding to given rectangle.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given at by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | OnCustomDraw | Raises an CustomDraw event. (Inherited from SyntaxPaint.)
Public method | PaintLineBookMark | Paint specified line bookmark.
Public method | PaintLineBookMarks | Paints collection of line bookmark. (Overrides SyntaxPaintPaintLineBookMarks(Rectangle).)
Public method | PaintSyntax | Paints a specified part of the control. (Overrides SyntaxPaintPaintSyntax(Int32, Int32, Point, Rectangle, Point, Boolean).)
Public method | PaintWindow | When implemented by a class, paints editor's content.
Public method | ResetColumnsIndentForeColor | Resets the ColumnsIndentForeColor to the default value.
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ResetDisabledBackColor | Resets the DisabledBackColor to the default value.
Public method | ResetDisabledForeColor | Resets the DisabledForeColor to the default value.
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ResetDrawColumnsIndent | Resets the DrawColumnsIndent to the default value.
Public method | ResetDrawStructureGuideLines | Resets the DrawColumnsIndent to the default value.
Public method | ResetGuideLinesForeColor | Resets the GuideLinesForeColor to the default value.
Public method | ResetReadonlyBackColor | Resets the ReadonlyBackColor to the default value.
Public method | ResetReadonlyForeColor | Resets the ReadonlyForeColor to the default value.
Public method | ResetSyntaxErrorsHints | When implemented by a class, resets the SyntaxErrorsHints to the default value.
Public method | ShouldSerializeColumnsIndentForeColor | Indicates whether the ColumnsIndentForeColor property should be persisted.
Public method | ShouldSerializeDisabledBackColor | Indicates whether the DisabledBackColor property should be persisted.
Public method | ShouldSerializeDisabledForeColor | Indicates whether the DisabledForeColor property should be persisted.
Public method | ShouldSerializeDrawColumnsIndent | Indicates whether the DrawColumnsIndent property should be persisted.
Public method | ShouldSerializeDrawStructureGuideLines | Indicates whether the DrawStructureGuideLines property should be persisted.
Public method | ShouldSerializeGuideLinesForeColor | Indicates whether the GuideLinesForeColor property should be persisted.
Public method | ShouldSerializeReadonlyBackColor | Indicates whether the ReadonlyBackColor property should be persisted.
Public method | ShouldSerializeReadonlyForeColor | Indicates whether the ReadonlyForeColor property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ColumnsIndentForeColor | Specifies columns indentation color.
Public property | DisableColorPaint | Gets or sets a value indicating whether control uses colors to paint its content. (Inherited from SyntaxPaint.)
Public property | DisabledBackColor | Gets or sets background color used in the disabled state.
Public property | DisabledForeColor | Gets or sets foreground color used in the disabled state.
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from SyntaxPaint.)
Public property | DrawColumnsIndent | Indicates whether edit control should draw columns indentation marks.
Public property | DrawStructureGuideLines | Indicates whether edit control should draw columns indentation marks.
Public property | GuideLinesForeColor | Specifies guide lines color.
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content. (Overrides SyntaxPaintLexer.)
Public property | NeedPaint | Gets or sets a boolean value that indicates whether Edit control should be repainted now.
Public property | Owner | Represents SyntaxEdit object that owns this EditSyntaxPaint.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from SyntaxPaint.)
Public property | ReadonlyBackColor | Gets or sets background color used in the readonly state.
Public property | ReadonlyForeColor | Gets or sets foreground color used in the readonly state.
Public property | SyntaxErrorsHints | Gets or sets a boolean value that indicates whether Edit control should display hint over each syntax error in it's content.
Top
Events
 | Name | Description
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxPaint.)
Top
See Also

Reference

Alternet.Editor Namespace


EditSyntaxPaint Constructor

EditSyntaxPaint Constructor
Initializes a new instance of the EditSyntaxPaint class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditSyntaxPaint(
    IPainter painter,
    ISyntaxEdit owner
)
Public Sub New (
    painter As IPainter,
    owner As ISyntaxEdit
)
public:
EditSyntaxPaint(
    IPainter^ painter,
    ISyntaxEdit^ owner
)
new :
        painter : IPainter *
        owner : ISyntaxEdit -> EditSyntaxPaint

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
owner
Type: Alternet.EditorISyntaxEdit
Specifies control being painted.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint Methods

EditSyntaxPaint Methods

The EditSyntaxPaint type exposes the following members.

Methods
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position. (Overrides SyntaxPaintDrawLine(Int32, Point, Rectangle).)
Public method | DrawLine(Int32, Point, Rectangle, Int32) | Draws line given by its index at the specified position.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal. (Inherited from SyntaxPaint.)
Public method | GetBackColor(Boolean) | Retrieves background color in accordance with specified parameter and editor settings.
Public method | GetBackColor(Color, TextStyle) | Retrieves background color corresponding to given state. (Overrides SyntaxPaintGetBackColor(Color, TextStyle).)
Public method | GetFontColor | Retrieves font color corresponding to given state. (Overrides SyntaxPaintGetFontColor(Color, TextStyle).)
Public method | GetFontStyle | Retrieves font style corresponding to given state. (Overrides SyntaxPaintGetFontStyle(FontStyle, TextStyle).)
Public method | GetForeColor | Retrieves foreground color in accordance with specified parameter and editor settings.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style. (Inherited from SyntaxPaint.)
Public method | GetRectRegion(Rectangle) | Returns region corresponding to given rectangle.
Public method | GetRectRegion(SelectionType, Rectangle, Boolean, Boolean) | Returns region corresponding to given rectangle.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given at by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | OnCustomDraw | Raises an CustomDraw event. (Inherited from SyntaxPaint.)
Public method | PaintLineBookMark | Paint specified line bookmark.
Public method | PaintLineBookMarks | Paints collection of line bookmark. (Overrides SyntaxPaintPaintLineBookMarks(Rectangle).)
Public method | PaintSyntax | Paints a specified part of the control. (Overrides SyntaxPaintPaintSyntax(Int32, Int32, Point, Rectangle, Point, Boolean).)
Public method | PaintWindow | When implemented by a class, paints editor's content.
Public method | ResetColumnsIndentForeColor | Resets the ColumnsIndentForeColor to the default value.
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ResetDisabledBackColor | Resets the DisabledBackColor to the default value.
Public method | ResetDisabledForeColor | Resets the DisabledForeColor to the default value.
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ResetDrawColumnsIndent | Resets the DrawColumnsIndent to the default value.
Public method | ResetDrawStructureGuideLines | Resets the DrawColumnsIndent to the default value.
Public method | ResetGuideLinesForeColor | Resets the GuideLinesForeColor to the default value.
Public method | ResetReadonlyBackColor | Resets the ReadonlyBackColor to the default value.
Public method | ResetReadonlyForeColor | Resets the ReadonlyForeColor to the default value.
Public method | ResetSyntaxErrorsHints | When implemented by a class, resets the SyntaxErrorsHints to the default value.
Public method | ShouldSerializeColumnsIndentForeColor | Indicates whether the ColumnsIndentForeColor property should be persisted.
Public method | ShouldSerializeDisabledBackColor | Indicates whether the DisabledBackColor property should be persisted.
Public method | ShouldSerializeDisabledForeColor | Indicates whether the DisabledForeColor property should be persisted.
Public method | ShouldSerializeDrawColumnsIndent | Indicates whether the DrawColumnsIndent property should be persisted.
Public method | ShouldSerializeDrawStructureGuideLines | Indicates whether the DrawStructureGuideLines property should be persisted.
Public method | ShouldSerializeGuideLinesForeColor | Indicates whether the GuideLinesForeColor property should be persisted.
Public method | ShouldSerializeReadonlyBackColor | Indicates whether the ReadonlyBackColor property should be persisted.
Public method | ShouldSerializeReadonlyForeColor | Indicates whether the ReadonlyForeColor property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.DrawLine Method

EditSyntaxPaintDrawLine Method
Overload List
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position. (Overrides SyntaxPaintDrawLine(Int32, Point, Rectangle).)
Public method | DrawLine(Int32, Point, Rectangle, Int32) | Draws line given by its index at the specified position.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Top
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.DrawLine Method (Int32, Point, Rectangle)

EditSyntaxPaintDrawLine Method (Int32, Point, Rectangle)
Draws line given by its index at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void DrawLine(
    int index,
    Point position,
    Rectangle clipRect
)
Public Overrides Sub DrawLine (
    index As Integer,
    position As Point,
    clipRect As Rectangle
)
public:
virtual void DrawLine(
    int index,
    Point position,
    Rectangle clipRect
) override
abstract DrawLine :
        index : int *
        position : Point *
        clipRect : Rectangle -> unit
override DrawLine :
        index : int *
        position : Point *
        clipRect : Rectangle -> unit

Parameters

index
Type: SystemInt32
Index of line to draw.
position
Type: System.DrawingPoint
Position to start drawing.
clipRect
Type: System.DrawingRectangle
Rectangular area of the control to draw line in.

Implements

ISyntaxPaintDrawLine(Int32, Point, Rectangle)
ISyntaxPaintDrawLine(Int32, Point, Rectangle)
See Also

Reference

EditSyntaxPaint Class
DrawLine Overload
Alternet.Editor Namespace


EditSyntaxPaint.DrawLine Method (Int32, Point, Rectangle, Int32)

EditSyntaxPaintDrawLine Method (Int32, Point, Rectangle, Int32)
Draws line given by its index at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawLine(
    int index,
    Point position,
    Rectangle clipRect,
    out int realLine
)
Public Overridable Sub DrawLine (
    index As Integer,
    position As Point,
    clipRect As Rectangle,
    <OutAttribute> ByRef realLine As Integer
)
public:
virtual void DrawLine(
    int index,
    Point position,
    Rectangle clipRect,
    [OutAttribute] int% realLine
)
abstract DrawLine :
        index : int *
        position : Point *
        clipRect : Rectangle *
        realLine : int byref -> unit
override DrawLine :
        index : int *
        position : Point *
        clipRect : Rectangle *
        realLine : int byref -> unit

Parameters

index
Type: SystemInt32
Index of line to draw.
position
Type: System.DrawingPoint
Position to start drawing.
clipRect
Type: System.DrawingRectangle
Rectangular area of the control to draw line in.
realLine
Type: SystemInt32
Real line index.
See Also

Reference

EditSyntaxPaint Class
DrawLine Overload
Alternet.Editor Namespace


EditSyntaxPaint.GetBackColor Method

EditSyntaxPaintGetBackColor Method
Overload List
 | Name | Description
Public method | GetBackColor(Boolean) | Retrieves background color in accordance with specified parameter and editor settings.
Public method | GetBackColor(Color, TextStyle) | Retrieves background color corresponding to given state. (Overrides SyntaxPaintGetBackColor(Color, TextStyle).)
Top
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.GetBackColor Method (Boolean)

EditSyntaxPaintGetBackColor Method (Boolean)
Retrieves background color in accordance with specified parameter and editor settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color GetBackColor(
    bool readOnly
)
Public Overridable Function GetBackColor (
    readOnly As Boolean
) As Color
public:
virtual Color GetBackColor(
    bool readOnly
)
abstract GetBackColor :
        readOnly : bool -> Color
override GetBackColor :
        readOnly : bool -> Color

Parameters

readOnly
Type: SystemBoolean
Specifies whether method should return background color for readonly state.

Return Value

Type: Color
Appropriate background color.

Implements

IEditSyntaxPaintGetBackColor(Boolean)
See Also

Reference

EditSyntaxPaint Class
GetBackColor Overload
Alternet.Editor Namespace


EditSyntaxPaint.GetBackColor Method (Color, TextStyle)

EditSyntaxPaintGetBackColor Method (Color, TextStyle)
Retrieves background color corresponding to given state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Color GetBackColor(
    Color color,
    TextStyle state
)
Public Overrides Function GetBackColor (
    color As Color,
    state As TextStyle
) As Color
public:
virtual Color GetBackColor(
    Color color,
    TextStyle state
) override
abstract GetBackColor :
        color : Color *
        state : TextStyle -> Color
override GetBackColor :
        color : Color *
        state : TextStyle -> Color

Parameters

color
Type: System.DrawingColor
Default color.
state
Type: Alternet.SyntaxTextStyle
Additional color flags.

Return Value

Type: Color
New value of background color.
See Also

Reference

EditSyntaxPaint Class
GetBackColor Overload
Alternet.Editor Namespace


EditSyntaxPaint.GetFontColor Method

EditSyntaxPaintGetFontColor Method
Retrieves font color corresponding to given state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Color GetFontColor(
    Color color,
    TextStyle textStyle
)
Public Overrides Function GetFontColor (
    color As Color,
    textStyle As TextStyle
) As Color
public:
virtual Color GetFontColor(
    Color color,
    TextStyle textStyle
) override
abstract GetFontColor :
        color : Color *
        textStyle : TextStyle -> Color
override GetFontColor :
        color : Color *
        textStyle : TextStyle -> Color

Parameters

color
Type: System.DrawingColor
Default color.
textStyle
Type: Alternet.SyntaxTextStyle
Additional color flags.

Return Value

Type: Color
New value of font color.

Implements

ISyntaxPaintGetFontColor(Color, TextStyle)
ISyntaxPaintGetFontColor(Color, TextStyle)
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.GetFontStyle Method

EditSyntaxPaintGetFontStyle Method
Retrieves font style corresponding to given state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override FontStyle GetFontStyle(
    FontStyle fontStyle,
    TextStyle textStyle
)
Public Overrides Function GetFontStyle (
    fontStyle As FontStyle,
    textStyle As TextStyle
) As FontStyle
public:
virtual FontStyle GetFontStyle(
    FontStyle fontStyle,
    TextStyle textStyle
) override
abstract GetFontStyle :
        fontStyle : FontStyle *
        textStyle : TextStyle -> FontStyle
override GetFontStyle :
        fontStyle : FontStyle *
        textStyle : TextStyle -> FontStyle

Parameters

fontStyle
Type: System.DrawingFontStyle
Default style.
textStyle
Type: Alternet.SyntaxTextStyle
Additional color flags.

Return Value

Type: FontStyle
New value of font style.

Implements

ISyntaxPaintGetFontStyle(FontStyle, TextStyle)
ISyntaxPaintGetFontStyle(FontStyle, TextStyle)
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.GetForeColor Method

EditSyntaxPaintGetForeColor Method
Retrieves foreground color in accordance with specified parameter and editor settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color GetForeColor(
    bool readOnly
)
Public Overridable Function GetForeColor (
    readOnly As Boolean
) As Color
public:
virtual Color GetForeColor(
    bool readOnly
)
abstract GetForeColor :
        readOnly : bool -> Color
override GetForeColor :
        readOnly : bool -> Color

Parameters

readOnly
Type: SystemBoolean
Specifies whether method should return foreground color for readonly state.

Return Value

Type: Color
Appropriate foreground color.

Implements

IEditSyntaxPaintGetForeColor(Boolean)
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.GetRectRegion Method

EditSyntaxPaintGetRectRegion Method
Overload List
 | Name | Description
Public method | GetRectRegion(Rectangle) | Returns region corresponding to given rectangle.
Public method | GetRectRegion(SelectionType, Rectangle, Boolean, Boolean) | Returns region corresponding to given rectangle.
Top
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.GetRectRegion Method (Rectangle)

EditSyntaxPaintGetRectRegion Method (Rectangle)
Returns region corresponding to given rectangle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Region GetRectRegion(
    Rectangle rect
)
Public Overridable Function GetRectRegion (
    rect As Rectangle
) As Region
public:
virtual Region^ GetRectRegion(
    Rectangle rect
)
abstract GetRectRegion :
        rect : Rectangle -> Region
override GetRectRegion :
        rect : Rectangle -> Region

Parameters

rect
Type: System.DrawingRectangle
Rectangle to check.

Return Value

Type: Region
Region corresponding to given rectangle.

Implements

IEditSyntaxPaintGetRectRegion(Rectangle)
See Also

Reference

EditSyntaxPaint Class
GetRectRegion Overload
Alternet.Editor Namespace


EditSyntaxPaint.GetRectRegion Method (SelectionType, Rectangle, Boolean, Boolean)

EditSyntaxPaintGetRectRegion Method (SelectionType, Rectangle, Boolean, Boolean)
Returns region corresponding to given rectangle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Region GetRectRegion(
    SelectionType selectionType,
    Rectangle rect,
    bool topLeftEnd,
    bool bottomRightEnd
)
Public Overridable Function GetRectRegion (
    selectionType As SelectionType,
    rect As Rectangle,
    topLeftEnd As Boolean,
    bottomRightEnd As Boolean
) As Region
public:
virtual Region^ GetRectRegion(
    SelectionType selectionType,
    Rectangle rect,
    bool topLeftEnd,
    bool bottomRightEnd
)
abstract GetRectRegion :
        selectionType : SelectionType *
        rect : Rectangle *
        topLeftEnd : bool *
        bottomRightEnd : bool -> Region
override GetRectRegion :
        selectionType : SelectionType *
        rect : Rectangle *
        topLeftEnd : bool *
        bottomRightEnd : bool -> Region

Parameters

selectionType
Type: Alternet.EditorSelectionType
Specifies selection type.
rect
Type: System.DrawingRectangle
Rectangle to check.
topLeftEnd
Type: SystemBoolean
Boolean value indicating if the region's topleft corner should be calculated taking into account end of the wrapped line.
bottomRightEnd
Type: SystemBoolean
Boolean value indicating if the region's bottomright corner should be calculated taking into account end of the wrapped line.

Return Value

Type: Region
Region corresponding to given rectangle.

Implements

IEditSyntaxPaintGetRectRegion(SelectionType, Rectangle, Boolean, Boolean)
See Also

Reference

EditSyntaxPaint Class
GetRectRegion Overload
Alternet.Editor Namespace


EditSyntaxPaint.PaintLineBookMark Method

EditSyntaxPaintPaintLineBookMark Method
Paint specified line bookmark.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintLineBookMark(
    IBookMark bookMark,
    Rectangle rect
)
Public Overridable Sub PaintLineBookMark (
    bookMark As IBookMark,
    rect As Rectangle
)
public:
virtual void PaintLineBookMark(
    IBookMark^ bookMark,
    Rectangle rect
)
abstract PaintLineBookMark :
        bookMark : IBookMark *
        rect : Rectangle -> unit
override PaintLineBookMark :
        bookMark : IBookMark *
        rect : Rectangle -> unit

Parameters

bookMark
Type: Alternet.Editor.TextSourceIBookMark
IBookMark to draw.
rect
Type: System.DrawingRectangle
Rectangular area of control to draw line bookmark.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.PaintLineBookMarks Method

EditSyntaxPaintPaintLineBookMarks Method
Paints collection of line bookmark.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PaintLineBookMarks(
    Rectangle rect
)
Public Overrides Sub PaintLineBookMarks (
    rect As Rectangle
)
public:
virtual void PaintLineBookMarks(
    Rectangle rect
) override
abstract PaintLineBookMarks :
        rect : Rectangle -> unit
override PaintLineBookMarks :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangular area of control to draw line bookmarks.

Implements

IEditSyntaxPaintPaintLineBookMarks(Rectangle)
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.PaintSyntax Method

EditSyntaxPaintPaintSyntax Method
Paints a specified part of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
)
Public Overrides Sub PaintSyntax (
    startLine As Integer,
    endLine As Integer,
    position As Point,
    rect As Rectangle,
    location As Point,
    specialPaint As Boolean
)
public:
virtual void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
) override
abstract PaintSyntax :
        startLine : int *
        endLine : int *
        position : Point *
        rect : Rectangle *
        location : Point *
        specialPaint : bool -> unit
override PaintSyntax :
        startLine : int *
        endLine : int *
        position : Point *
        rect : Rectangle *
        location : Point *
        specialPaint : bool -> unit

Parameters

startLine
Type: SystemInt32
Specifies first line of content to paint.
endLine
Type: SystemInt32
Specifies last line of content to paint.
position
Type: System.DrawingPoint
The Point value that specifies start position to draw content from.
rect
Type: System.DrawingRectangle
Rectangular area of control to draw.
location
Type: System.DrawingPoint
The Point value that specifies start position to draw page from.
specialPaint
Type: SystemBoolean
Reserved for internal use. Used for Print and Print preview.

Implements

ISyntaxPaintPaintSyntax(Int32, Int32, Point, Rectangle, Point, Boolean)
ISyntaxPaintPaintSyntax(Int32, Int32, Point, Rectangle, Point, Boolean)
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.PaintWindow Method

EditSyntaxPaintPaintWindow Method
When implemented by a class, paints editor's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintWindow(
    int startLine,
    Rectangle rect,
    Point location,
    float scaleX,
    float scaleY,
    bool specialPaint,
    bool inPrinting
)
Public Overridable Sub PaintWindow (
    startLine As Integer,
    rect As Rectangle,
    location As Point,
    scaleX As Single,
    scaleY As Single,
    specialPaint As Boolean,
    inPrinting As Boolean
)
public:
virtual void PaintWindow(
    int startLine,
    Rectangle rect,
    Point location,
    float scaleX,
    float scaleY,
    bool specialPaint,
    bool inPrinting
)
abstract PaintWindow :
        startLine : int *
        rect : Rectangle *
        location : Point *
        scaleX : float32 *
        scaleY : float32 *
        specialPaint : bool *
        inPrinting : bool -> unit
override PaintWindow :
        startLine : int *
        rect : Rectangle *
        location : Point *
        scaleX : float32 *
        scaleY : float32 *
        specialPaint : bool *
        inPrinting : bool -> unit

Parameters

startLine
Type: SystemInt32
Specifies first line of content to paint.
rect
Type: System.DrawingRectangle
Rectangular area of control to draw.
location
Type: System.DrawingPoint
The Point value that specifies start position to draw content from.
scaleX
Type: SystemSingle
Horizontal scale of the transformation.
scaleY
Type: SystemSingle
Vertical scale of the transformation.
specialPaint
Type: SystemBoolean
Reserved for internal use. Used for Print and Print preview.
inPrinting
Type: SystemBoolean
Reserved for internal use. Used for Print and Print preview.

Implements

IEditSyntaxPaintPaintWindow(Int32, Rectangle, Point, Single, Single, Boolean, Boolean)
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ResetColumnsIndentForeColor Method

EditSyntaxPaintResetColumnsIndentForeColor Method
Resets the ColumnsIndentForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetColumnsIndentForeColor()
Public Overridable Sub ResetColumnsIndentForeColor
public:
virtual void ResetColumnsIndentForeColor()
abstract ResetColumnsIndentForeColor : unit -> unit
override ResetColumnsIndentForeColor : unit -> unit

Implements

IEditSyntaxPaintResetColumnsIndentForeColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ResetDisabledBackColor Method

EditSyntaxPaintResetDisabledBackColor Method
Resets the DisabledBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDisabledBackColor()
Public Overridable Sub ResetDisabledBackColor
public:
virtual void ResetDisabledBackColor()
abstract ResetDisabledBackColor : unit -> unit
override ResetDisabledBackColor : unit -> unit

Implements

IEditSyntaxPaintResetDisabledBackColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ResetDisabledForeColor Method

EditSyntaxPaintResetDisabledForeColor Method
Resets the DisabledForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDisabledForeColor()
Public Overridable Sub ResetDisabledForeColor
public:
virtual void ResetDisabledForeColor()
abstract ResetDisabledForeColor : unit -> unit
override ResetDisabledForeColor : unit -> unit

Implements

IEditSyntaxPaintResetDisabledForeColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ResetDrawColumnsIndent Method

EditSyntaxPaintResetDrawColumnsIndent Method
Resets the DrawColumnsIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDrawColumnsIndent()
Public Overridable Sub ResetDrawColumnsIndent
public:
virtual void ResetDrawColumnsIndent()
abstract ResetDrawColumnsIndent : unit -> unit
override ResetDrawColumnsIndent : unit -> unit

Implements

IEditSyntaxPaintResetDrawColumnsIndent
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ResetDrawStructureGuideLines Method

EditSyntaxPaintResetDrawStructureGuideLines Method
Resets the DrawColumnsIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDrawStructureGuideLines()
Public Overridable Sub ResetDrawStructureGuideLines
public:
virtual void ResetDrawStructureGuideLines()
abstract ResetDrawStructureGuideLines : unit -> unit
override ResetDrawStructureGuideLines : unit -> unit
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ResetGuideLinesForeColor Method

EditSyntaxPaintResetGuideLinesForeColor Method
Resets the GuideLinesForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetGuideLinesForeColor()
Public Overridable Sub ResetGuideLinesForeColor
public:
virtual void ResetGuideLinesForeColor()
abstract ResetGuideLinesForeColor : unit -> unit
override ResetGuideLinesForeColor : unit -> unit
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ResetReadonlyBackColor Method

EditSyntaxPaintResetReadonlyBackColor Method
Resets the ReadonlyBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetReadonlyBackColor()
Public Overridable Sub ResetReadonlyBackColor
public:
virtual void ResetReadonlyBackColor()
abstract ResetReadonlyBackColor : unit -> unit
override ResetReadonlyBackColor : unit -> unit

Implements

IEditSyntaxPaintResetReadonlyBackColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ResetReadonlyForeColor Method

EditSyntaxPaintResetReadonlyForeColor Method
Resets the ReadonlyForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetReadonlyForeColor()
Public Overridable Sub ResetReadonlyForeColor
public:
virtual void ResetReadonlyForeColor()
abstract ResetReadonlyForeColor : unit -> unit
override ResetReadonlyForeColor : unit -> unit

Implements

IEditSyntaxPaintResetReadonlyForeColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ResetSyntaxErrorsHints Method

EditSyntaxPaintResetSyntaxErrorsHints Method
When implemented by a class, resets the SyntaxErrorsHints to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSyntaxErrorsHints()
Public Overridable Sub ResetSyntaxErrorsHints
public:
virtual void ResetSyntaxErrorsHints()
abstract ResetSyntaxErrorsHints : unit -> unit
override ResetSyntaxErrorsHints : unit -> unit

Implements

IEditSyntaxPaintResetSyntaxErrorsHints
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ShouldSerializeColumnsIndentForeColor Method

EditSyntaxPaintShouldSerializeColumnsIndentForeColor Method
Indicates whether the ColumnsIndentForeColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeColumnsIndentForeColor()
Public Function ShouldSerializeColumnsIndentForeColor As Boolean
public:
bool ShouldSerializeColumnsIndentForeColor()
member ShouldSerializeColumnsIndentForeColor : unit -> bool

Return Value

Type: Boolean
True if ColumnsIndentForeColor differs from its default value; otherwise false.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ShouldSerializeDisabledBackColor Method

EditSyntaxPaintShouldSerializeDisabledBackColor Method
Indicates whether the DisabledBackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeDisabledBackColor()
Public Function ShouldSerializeDisabledBackColor As Boolean
public:
bool ShouldSerializeDisabledBackColor()
member ShouldSerializeDisabledBackColor : unit -> bool

Return Value

Type: Boolean
True if DisabledBackColor differs from its default value; otherwise false.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ShouldSerializeDisabledForeColor Method

EditSyntaxPaintShouldSerializeDisabledForeColor Method
Indicates whether the DisabledForeColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeDisabledForeColor()
Public Function ShouldSerializeDisabledForeColor As Boolean
public:
bool ShouldSerializeDisabledForeColor()
member ShouldSerializeDisabledForeColor : unit -> bool

Return Value

Type: Boolean
True if DisabledForeColor differs from its default value; otherwise false.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ShouldSerializeDrawColumnsIndent Method

EditSyntaxPaintShouldSerializeDrawColumnsIndent Method
Indicates whether the DrawColumnsIndent property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeDrawColumnsIndent()
Public Overridable Function ShouldSerializeDrawColumnsIndent As Boolean
public:
virtual bool ShouldSerializeDrawColumnsIndent()
abstract ShouldSerializeDrawColumnsIndent : unit -> bool
override ShouldSerializeDrawColumnsIndent : unit -> bool

Return Value

Type: Boolean
True if DrawColumnsIndent differs from its default value; otherwise false.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ShouldSerializeDrawStructureGuideLines Method

EditSyntaxPaintShouldSerializeDrawStructureGuideLines Method
Indicates whether the DrawStructureGuideLines property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeDrawStructureGuideLines()
Public Function ShouldSerializeDrawStructureGuideLines As Boolean
public:
bool ShouldSerializeDrawStructureGuideLines()
member ShouldSerializeDrawStructureGuideLines : unit -> bool

Return Value

Type: Boolean
True if DrawStructureGuideLines differs from its default value; otherwise false.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ShouldSerializeGuideLinesForeColor Method

EditSyntaxPaintShouldSerializeGuideLinesForeColor Method
Indicates whether the GuideLinesForeColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeGuideLinesForeColor()
Public Function ShouldSerializeGuideLinesForeColor As Boolean
public:
bool ShouldSerializeGuideLinesForeColor()
member ShouldSerializeGuideLinesForeColor : unit -> bool

Return Value

Type: Boolean
True if GuideLinesForeColor differs from its default value; otherwise false.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ShouldSerializeReadonlyBackColor Method

EditSyntaxPaintShouldSerializeReadonlyBackColor Method
Indicates whether the ReadonlyBackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeReadonlyBackColor()
Public Function ShouldSerializeReadonlyBackColor As Boolean
public:
bool ShouldSerializeReadonlyBackColor()
member ShouldSerializeReadonlyBackColor : unit -> bool

Return Value

Type: Boolean
True if ReadonlyBackColor differs from its default value; otherwise false.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ShouldSerializeReadonlyForeColor Method

EditSyntaxPaintShouldSerializeReadonlyForeColor Method
Indicates whether the ReadonlyForeColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeReadonlyForeColor()
Public Function ShouldSerializeReadonlyForeColor As Boolean
public:
bool ShouldSerializeReadonlyForeColor()
member ShouldSerializeReadonlyForeColor : unit -> bool

Return Value

Type: Boolean
True if ReadonlyForeColor differs from its default value; otherwise false.
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint Properties

EditSyntaxPaint Properties

The EditSyntaxPaint type exposes the following members.

Properties
 | Name | Description
Public property | ColumnsIndentForeColor | Specifies columns indentation color.
Public property | DisableColorPaint | Gets or sets a value indicating whether control uses colors to paint its content. (Inherited from SyntaxPaint.)
Public property | DisabledBackColor | Gets or sets background color used in the disabled state.
Public property | DisabledForeColor | Gets or sets foreground color used in the disabled state.
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from SyntaxPaint.)
Public property | DrawColumnsIndent | Indicates whether edit control should draw columns indentation marks.
Public property | DrawStructureGuideLines | Indicates whether edit control should draw columns indentation marks.
Public property | GuideLinesForeColor | Specifies guide lines color.
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content. (Overrides SyntaxPaintLexer.)
Public property | NeedPaint | Gets or sets a boolean value that indicates whether Edit control should be repainted now.
Public property | Owner | Represents SyntaxEdit object that owns this EditSyntaxPaint.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from SyntaxPaint.)
Public property | ReadonlyBackColor | Gets or sets background color used in the readonly state.
Public property | ReadonlyForeColor | Gets or sets foreground color used in the readonly state.
Public property | SyntaxErrorsHints | Gets or sets a boolean value that indicates whether Edit control should display hint over each syntax error in it's content.
Top
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ColumnsIndentForeColor Property

EditSyntaxPaintColumnsIndentForeColor Property
Specifies columns indentation color.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ColumnsIndentForeColor { get; set; }
Public Overridable Property ColumnsIndentForeColor As Color
    Get
    Set
public:
virtual property Color ColumnsIndentForeColor {
    Color get ();
    void set (Color value);
}
abstract ColumnsIndentForeColor : Color with get, set
override ColumnsIndentForeColor : Color with get, set

Property Value

Type: Color

Implements

IEditSyntaxPaintColumnsIndentForeColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.DisabledBackColor Property

EditSyntaxPaintDisabledBackColor Property
Gets or sets background color used in the disabled state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color DisabledBackColor { get; set; }
Public Overridable Property DisabledBackColor As Color
    Get
    Set
public:
virtual property Color DisabledBackColor {
    Color get ();
    void set (Color value);
}
abstract DisabledBackColor : Color with get, set
override DisabledBackColor : Color with get, set

Property Value

Type: Color

Implements

IEditSyntaxPaintDisabledBackColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.DisabledForeColor Property

EditSyntaxPaintDisabledForeColor Property
Gets or sets foreground color used in the disabled state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color DisabledForeColor { get; set; }
Public Overridable Property DisabledForeColor As Color
    Get
    Set
public:
virtual property Color DisabledForeColor {
    Color get ();
    void set (Color value);
}
abstract DisabledForeColor : Color with get, set
override DisabledForeColor : Color with get, set

Property Value

Type: Color

Implements

IEditSyntaxPaintDisabledForeColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.DrawColumnsIndent Property

EditSyntaxPaintDrawColumnsIndent Property
Indicates whether edit control should draw columns indentation marks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DrawColumnsIndent { get; set; }
Public Overridable Property DrawColumnsIndent As Boolean
    Get
    Set
public:
virtual property bool DrawColumnsIndent {
    bool get ();
    void set (bool value);
}
abstract DrawColumnsIndent : bool with get, set
override DrawColumnsIndent : bool with get, set

Property Value

Type: Boolean

Implements

IEditSyntaxPaintDrawColumnsIndent
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.DrawStructureGuideLines Property

EditSyntaxPaintDrawStructureGuideLines Property
Indicates whether edit control should draw columns indentation marks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DrawStructureGuideLines { get; set; }
Public Overridable Property DrawStructureGuideLines As Boolean
    Get
    Set
public:
virtual property bool DrawStructureGuideLines {
    bool get ();
    void set (bool value);
}
abstract DrawStructureGuideLines : bool with get, set
override DrawStructureGuideLines : bool with get, set

Property Value

Type: Boolean

Implements

IEditSyntaxPaintDrawStructureGuideLines
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.GuideLinesForeColor Property

EditSyntaxPaintGuideLinesForeColor Property
Specifies guide lines color.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color GuideLinesForeColor { get; set; }
Public Overridable Property GuideLinesForeColor As Color
    Get
    Set
public:
virtual property Color GuideLinesForeColor {
    Color get ();
    void set (Color value);
}
abstract GuideLinesForeColor : Color with get, set
override GuideLinesForeColor : Color with get, set

Property Value

Type: Color

Implements

IEditSyntaxPaintGuideLinesForeColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.Lexer Property

EditSyntaxPaintLexer Property
Gets or sets object that can make lexical analysis for the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ILexer Lexer { get; }
Public Overrides ReadOnly Property Lexer As ILexer
    Get
public:
virtual property ILexer^ Lexer {
    ILexer^ get () override;
}
abstract Lexer : ILexer with get
override Lexer : ILexer with get

Property Value

Type: ILexer

Implements

ISyntaxPaintLexer
ISyntaxPaintLexer
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.NeedPaint Property

EditSyntaxPaintNeedPaint Property
Gets or sets a boolean value that indicates whether Edit control should be repainted now.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedPaint { get; set; }
Public Overridable Property NeedPaint As Boolean
    Get
    Set
public:
virtual property bool NeedPaint {
    bool get ();
    void set (bool value);
}
abstract NeedPaint : bool with get, set
override NeedPaint : bool with get, set

Property Value

Type: Boolean

Implements

IEditSyntaxPaintNeedPaint
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.Owner Property

EditSyntaxPaintOwner Property
Represents SyntaxEdit object that owns this EditSyntaxPaint.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxEdit Owner { get; }
Public Overridable ReadOnly Property Owner As ISyntaxEdit
    Get
public:
virtual property ISyntaxEdit^ Owner {
    ISyntaxEdit^ get ();
}
abstract Owner : ISyntaxEdit with get
override Owner : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ReadonlyBackColor Property

EditSyntaxPaintReadonlyBackColor Property
Gets or sets background color used in the readonly state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ReadonlyBackColor { get; set; }
Public Overridable Property ReadonlyBackColor As Color
    Get
    Set
public:
virtual property Color ReadonlyBackColor {
    Color get ();
    void set (Color value);
}
abstract ReadonlyBackColor : Color with get, set
override ReadonlyBackColor : Color with get, set

Property Value

Type: Color

Implements

IEditSyntaxPaintReadonlyBackColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.ReadonlyForeColor Property

EditSyntaxPaintReadonlyForeColor Property
Gets or sets foreground color used in the readonly state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ReadonlyForeColor { get; set; }
Public Overridable Property ReadonlyForeColor As Color
    Get
    Set
public:
virtual property Color ReadonlyForeColor {
    Color get ();
    void set (Color value);
}
abstract ReadonlyForeColor : Color with get, set
override ReadonlyForeColor : Color with get, set

Property Value

Type: Color

Implements

IEditSyntaxPaintReadonlyForeColor
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint.SyntaxErrorsHints Property

EditSyntaxPaintSyntaxErrorsHints Property
Gets or sets a boolean value that indicates whether Edit control should display hint over each syntax error in it's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SyntaxErrorsHints { get; set; }
Public Overridable Property SyntaxErrorsHints As Boolean
    Get
    Set
public:
virtual property bool SyntaxErrorsHints {
    bool get ();
    void set (bool value);
}
abstract SyntaxErrorsHints : bool with get, set
override SyntaxErrorsHints : bool with get, set

Property Value

Type: Boolean

Implements

IEditSyntaxPaintSyntaxErrorsHints
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EditSyntaxPaint Events

EditSyntaxPaint Events

The EditSyntaxPaint type exposes the following members.

Events
 | Name | Description
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxPaint.)
Top
See Also

Reference

EditSyntaxPaint Class
Alternet.Editor Namespace


EventHandlers Class

EventHandlers Class
Represents key events for default keymapping.
Inheritance Hierarchy
SystemObject
Alternet.EditorEventHandlers

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EventHandlers : IEventHandlers
Public Class EventHandlers
    Implements IEventHandlers
public ref class EventHandlers : IEventHandlers
type EventHandlers =
    class
        interface IEventHandlers
    end

The EventHandlers type exposes the following members.

Constructors
 | Name | Description
Public method | EventHandlers | Initializes a new instance of the EventHandlers class with specified owner.
Top
Methods
 | Name | Description
Public method | ClearAllBookMarks |
Public method | DeleteLeft |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Find |
Public method | FindNext |
Public method | FindNextSelected |
Public method | FindPrevious |
Public method | FindPreviousSelected |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoBookMark |
Public method | GotoLine |
Public method | GotoNextBookMark |
Public method | GotoPrevBookMark |
Public method | PressKey |
Public method | ProcessEscape |
Public method | Redo |
Public method | Replace |
Public method | SelectAll |
Public method | SelectCharLeft |
Public method | SelectCharRight |
Public method | SelectFileBegin |
Public method | SelectFileEnd |
Public method | SelectLineBegin |
Public method | SelectLineDown |
Public method | SelectLineEnd |
Public method | SelectLineUp |
Public method | SelectPageDown |
Public method | SelectPageUp |
Public method | SelectScreenBottom |
Public method | SelectScreenTop |
Public method | SelectWordLeft |
Public method | SelectWordRight |
Public method | StartReverseIncrementalSearch |
Public method | ToggleBookMark |
Public method | ToggleBookMark(Object) |
Public method | ToggleHiddenText |
Public method | ToggleMatchCase |
Public method | ToggleRegularExpressions |
Public method | ToggleSearchUp |
Public method | ToggleWholeWord |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo |
Top
Fields
 | Name | Description
Public field | CapitalizeEvent | Raises the key event that calls ISelection.Capitalize method.
Public field | CharTransposeEvent | Raises the key event that calls ISelection.CharTransponse method.
Public field | ClearBookMarkEvent | Raises the key event that calls IBookMarks.ClearAllBookMarks method.
Public field | CodeSnippetsEvent | Raises the key event that calls ISyntaxEdit.QuickInfo method.
Public field | CollapseToDefinitionsEvent | Raises the key event that calls IOutlining.CollapseToDefinitions method.
Public field | CommentSelectionEvent | Raises the key event that calls ISelection.CommentSelection method.
Public field | CompleteCodeFixesOrRefactors | Raises the key event that calls ISyntaxEdit.CompleteCodeFixesOrRefactors method.
Public field | CompleteWordEvent | Raises the key event that calls ISyntaxEdit.CompleteWord method.
Public field | CopyEvent | Raises the key event that calls ISelection.Copy method.
Public field | CutEvent | Raises the key event that calls ISelection.Cut method.
Public field | DeleteLeftEvent | Raises the key event that calls ISelection.DeleteLeft method.
Public field | DeleteRightEvent | Raises the key event that calls ISelection.DeleteRight method.
Public field | DeleteWhiteSpaceEvent | Raises the key event that calls ISelection.DeleteWhiteSpace method.
Public field | DeleteWordLeftEvent | Raises the key event that calls ISelection.DeleteWordLeft method.
Public field | DeleteWordRightEvent | Raises the key event that calls ISelection.DeleteWordRight method.
Public field | FindEvent | Raises the key event that calls ISyntaxEdit.DisplaySearchDialog method.
Public field | FindNextEvent | Raises the key event that calls FindNext method.
Public field | FindNextSelectedEvent | Raises the key event that calls FindNextSelected method.
Public field | FindPreviousEvent | Raises the key event that calls FindPrevious method.
Public field | FindPreviousSelectedEvent | Raises the key event that calls FindPreviousSelected method.
Public field | FormatDocumentEvent | Raises the key event that calls ISelection.SmartFormatDocument method.
Public field | FormatSelectionEvent | Raises the key event that calls ISelection.SmartFormat method.
Public field | GotolineEvent | Raises the key event that calls ISyntaxEdit.DisplayGotoLineDialog method.
Public field | InitIncrementalSearchEvent | Raises the key event that calls ISyntaxEdit.StartIncrementalSearch method.
Public field | InitReverseIncrementalSearchEvent | Raises the key event that calls StartReverseIncrementalSearch method.
Public field | LineCutEvent | Raises the key event that calls ISelection.CutLine method.
Public field | LineDeleteEvent | Raises the key event that calls ISelection.DeleteLine method.
Public field | LineTransposeEvent | Raises the key event that calls ISelection.LineTransponse method.
Public field | ListMembersEvent | Raises the key event that calls ISyntaxEdit.ListMembers method.
Public field | LowerCaseEvent | Raises the key event that calls ISelection.LowerCase method.
Public field | MoveBookMarkEvent | Raises the key event that calls IBookMarks.GotoBookMark method.
Public field | MoveCharLeftEvent | Raises the key event that calls ISyntaxEdit.MoveCharLeft method.
Public field | MoveCharRightEvent | Raises the key event that calls ISyntaxEdit.MoveCharRight method.
Public field | MoveFileBeginEvent | Raises the key event that calls ISyntaxEdit.MoveFileBegin method.
Public field | MoveFileEndEvent | Raises the key event that calls ISyntaxEdit.MoveFileEnd method.
Public field | MoveLineBeginEvent | Raises the key event that calls ISyntaxEdit.MoveLineBeginCycled method.
Public field | MoveLineDownEvent | Raises the key event that calls ISyntaxEdit.MoveLineDown method.
Public field | MoveLineEndEvent | Raises the key event that calls ISyntaxEdit.MoveLineEnd method.
Public field | MoveLineUpEvent | Raises the key event that calls ISyntaxEdit.MoveLineUp method.
Public field | MovePageDownEvent | Raises the key event that calls ISyntaxEdit.MovePageDown method.
Public field | MovePageUpEvent | Raises the key event that calls ISyntaxEdit.MovePageUp method.
Public field | MoveScreenBottomEvent | Raises the key event that calls ISyntaxEdit.MoveScreenBottom method.
Public field | MoveScreenTopEvent | Raises the key event that calls ISyntaxEdit.MoveScreenTop method.
Public field | MoveToBraceEvent | Raises the key event that calls ISelection.SelectToBrace method.
Public field | MoveToBraceExtendEvent | Raises the key event that calls ISelection.SelectToBrace method.
Public field | MoveToCloseBraceEvent | Raises the key event that calls ISelection.SelectToCloseBrace method.
Public field | MoveToCloseBraceExtendEvent | Raises the key event that calls ISelection.SelectToCloseBrace method.
Public field | MoveToOpenBraceEvent | Raises the key event that calls ISelection.SelectToOpenBrace method.
Public field | MoveToOpenBraceExtendEvent | Raises the key event that calls ISelection.SelectToOpenBrace method.
Public field | MoveWordLeftEvent | Raises the key event that calls ISyntaxEdit.MoveWordLeft method.
Public field | MoveWordRightEvent | Raises the key event that calls ISyntaxEdit.MoveWordRight method.
Public field | NewLineAboveEvent | Raises the key event that calls ISelection.NewLineAbove method.
Public field | NewLineBelowEvent | Raises the key event that calls ISelection.NewLineBelow method.
Public field | NewLineEvent | Raises the key event that calls ISelection.NewLine method.
Public field | NextBookMarkEvent | Raises the key event that calls IBookMarks.GotoNextBookMark method.
Public field | ParameterInfoEvent | Raises the key event that calls ISyntaxEdit.ParameterInfo method.
Public field | PasteEvent | Raises the key event that calls ISelection.Paste method.
Public field | PlayBackMacro | Raises the key event that calls ISyntaxEdit.PlayBackMacro method.
Public field | PrevBookMarkEvent | Raises the key event that calls IBookMarks.GotoPrevBookMark method.
Public field | ProcessEscapeEvent | Raises the key event that calls ISelection.ProcessEscape method.
Public field | ProcessKey | Raises the key event that calls PressKey method.
Public field | ProcessShiftTabEvent | Raises the key event that calls ISelection.ProcessShiftTab method.
Public field | ProcessTabEvent | Raises the key event that calls ISelection.ProcessTab method.
Public field | QuickInfoEvent | Raises the key event that calls ISyntaxEdit.ListMembers method.
Public field | RedoEvent | Raises the key event that calls ITextSource.Redo method.
Public field | ReplaceEvent | Raises the key event that calls ISyntaxEdit.DisplayReplaceDialog method.
Public field | ScrollLineDownEvent | Raises the key event that calls ISyntaxEdit.ScrollLineDown method.
Public field | ScrollLineUpEvent | Raises the key event that calls ISyntaxEdit.ScrollLineUp method.
Public field | SelectAllEvent | Raises the key event that calls ISelection.SelectAll method.
Public field | SelectCharLeftEvent | Raises the key event that calls ISelection.SelectCharLeft method.
Public field | SelectCharRightEvent | Raises the key event that calls ISelection.SelectCharRight method.
Public field | SelectFileBeginEvent | Raises the key event that calls ISelection.SelectFileBegin method.
Public field | SelectFileEndEvent | Raises the key event that calls ISelection.SelectFileEnd method.
Public field | SelectLineBeginEvent | Raises the key event that calls ISelection.SelectLineBegin method.
Public field | SelectLineDownEvent | Raises the key event that calls ISelection.SelectLineDown method.
Public field | SelectLineEndEvent | Raises the key event that calls ISelection.SelectLineEnd method.
Public field | SelectLineUpEvent | Raises the key event that calls ISelection.SelectLineUp method.
Public field | SelectPageDownEvent | Raises the key event that calls ISelection.SelectPageDown method.
Public field | SelectPageUpEvent | Raises the key event that calls ISelection.SelectPageUp method.
Public field | SelectScreenBottomEvent | Raises the key event that calls ISelection.SelectScreenBottom method.
Public field | SelectScreenTopEvent | Raises the key event that calls ISelection.SelectScreenTop method.
Public field | SelectWordEvent | Raises the key event that calls ISelection.SelectWord method.
Public field | SelectWordLeftEvent | Raises the key event that calls ISelection.SelectWordLeft method.
Public field | SelectWordRightEvent | Raises the key event that calls ISelection.SelectWordRight method.
Public field | SwapAnchorEvent | Raises the key event that calls ISelection.SwapAnchor method.
Public field | TabifyEvent | Raises the key event that calls ISelection.Tabify method.
Public field | ToggleBookMarkEvent | Raises the key event that calls IBookMarks.ToggleBookMark method.
Public field | ToggleBookMarkEventEx | Raises the key event that calls IBookMarks.ToggleBookMark method with parameter.
Public field | ToggleHiddenTextEvent | Raises the key event that calls ToggleHiddenText method.
Public field | ToggleMacroRecording | Raises the key event that calls ISyntaxEdit.ToggleMacroRecording method.
Public field | ToggleMatchCaseEvent | Raises the key event that calls ToggleMatchCase method.
Public field | ToggleOutliningEvent | Raises the key event that calls IOutlining.ToggleOutlining method.
Public field | ToggleOutliningSelectionEvent | Raises the key event that calls ISelection.ToggleOutlining method.
Public field | ToggleOverwriteEvent | Raises the key event that calls ISelection.ToggleOverWrite method.
Public field | ToggleRegularExpressionsEvent | Raises the key event that calls ToggleRegularExpressions method.
Public field | ToggleSearchUpEvent | Raises the key event that calls ToggleSearchUp method.
Public field | ToggleWholeWordEvent | Raises the key event that calls ToggleWholeWord method.
Public field | UncommentSelectionEvent | Raises the key event that calls ISelection.UncommentSelection method.
Public field | UndoEvent | Raises the key event that calls ITextSource.Undo method.
Public field | UnTabifyEvent | Raises the key event that calls ISelection.UnTabify method.
Public field | UpperCaseEvent | Raises the key event that calls ISelection.UpperCase method.
Public field | WordTransposeEvent | Raises the key event that calls ISelection.WordTransponse method.
Top
Properties
 | Name | Description
Public property | EventNames | Represents names of all available event handlers.
Public property | MacroRecordEvent | Represents an event to process macro recording.
Top
Remarks
Normally you do not need to use this class directly, it's used internally by edit control.
See Also

Reference

Alternet.Editor Namespace


EventHandlers Constructor

EventHandlers Constructor
Initializes a new instance of the EventHandlers class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventHandlers(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
EventHandlers(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> EventHandlers

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers Fields

EventHandlers Fields

The EventHandlers type exposes the following members.

Fields
 | Name | Description
Public field | CapitalizeEvent | Raises the key event that calls ISelection.Capitalize method.
Public field | CharTransposeEvent | Raises the key event that calls ISelection.CharTransponse method.
Public field | ClearBookMarkEvent | Raises the key event that calls IBookMarks.ClearAllBookMarks method.
Public field | CodeSnippetsEvent | Raises the key event that calls ISyntaxEdit.QuickInfo method.
Public field | CollapseToDefinitionsEvent | Raises the key event that calls IOutlining.CollapseToDefinitions method.
Public field | CommentSelectionEvent | Raises the key event that calls ISelection.CommentSelection method.
Public field | CompleteCodeFixesOrRefactors | Raises the key event that calls ISyntaxEdit.CompleteCodeFixesOrRefactors method.
Public field | CompleteWordEvent | Raises the key event that calls ISyntaxEdit.CompleteWord method.
Public field | CopyEvent | Raises the key event that calls ISelection.Copy method.
Public field | CutEvent | Raises the key event that calls ISelection.Cut method.
Public field | DeleteLeftEvent | Raises the key event that calls ISelection.DeleteLeft method.
Public field | DeleteRightEvent | Raises the key event that calls ISelection.DeleteRight method.
Public field | DeleteWhiteSpaceEvent | Raises the key event that calls ISelection.DeleteWhiteSpace method.
Public field | DeleteWordLeftEvent | Raises the key event that calls ISelection.DeleteWordLeft method.
Public field | DeleteWordRightEvent | Raises the key event that calls ISelection.DeleteWordRight method.
Public field | FindEvent | Raises the key event that calls ISyntaxEdit.DisplaySearchDialog method.
Public field | FindNextEvent | Raises the key event that calls FindNext method.
Public field | FindNextSelectedEvent | Raises the key event that calls FindNextSelected method.
Public field | FindPreviousEvent | Raises the key event that calls FindPrevious method.
Public field | FindPreviousSelectedEvent | Raises the key event that calls FindPreviousSelected method.
Public field | FormatDocumentEvent | Raises the key event that calls ISelection.SmartFormatDocument method.
Public field | FormatSelectionEvent | Raises the key event that calls ISelection.SmartFormat method.
Public field | GotolineEvent | Raises the key event that calls ISyntaxEdit.DisplayGotoLineDialog method.
Public field | InitIncrementalSearchEvent | Raises the key event that calls ISyntaxEdit.StartIncrementalSearch method.
Public field | InitReverseIncrementalSearchEvent | Raises the key event that calls StartReverseIncrementalSearch method.
Public field | LineCutEvent | Raises the key event that calls ISelection.CutLine method.
Public field | LineDeleteEvent | Raises the key event that calls ISelection.DeleteLine method.
Public field | LineTransposeEvent | Raises the key event that calls ISelection.LineTransponse method.
Public field | ListMembersEvent | Raises the key event that calls ISyntaxEdit.ListMembers method.
Public field | LowerCaseEvent | Raises the key event that calls ISelection.LowerCase method.
Public field | MoveBookMarkEvent | Raises the key event that calls IBookMarks.GotoBookMark method.
Public field | MoveCharLeftEvent | Raises the key event that calls ISyntaxEdit.MoveCharLeft method.
Public field | MoveCharRightEvent | Raises the key event that calls ISyntaxEdit.MoveCharRight method.
Public field | MoveFileBeginEvent | Raises the key event that calls ISyntaxEdit.MoveFileBegin method.
Public field | MoveFileEndEvent | Raises the key event that calls ISyntaxEdit.MoveFileEnd method.
Public field | MoveLineBeginEvent | Raises the key event that calls ISyntaxEdit.MoveLineBeginCycled method.
Public field | MoveLineDownEvent | Raises the key event that calls ISyntaxEdit.MoveLineDown method.
Public field | MoveLineEndEvent | Raises the key event that calls ISyntaxEdit.MoveLineEnd method.
Public field | MoveLineUpEvent | Raises the key event that calls ISyntaxEdit.MoveLineUp method.
Public field | MovePageDownEvent | Raises the key event that calls ISyntaxEdit.MovePageDown method.
Public field | MovePageUpEvent | Raises the key event that calls ISyntaxEdit.MovePageUp method.
Public field | MoveScreenBottomEvent | Raises the key event that calls ISyntaxEdit.MoveScreenBottom method.
Public field | MoveScreenTopEvent | Raises the key event that calls ISyntaxEdit.MoveScreenTop method.
Public field | MoveToBraceEvent | Raises the key event that calls ISelection.SelectToBrace method.
Public field | MoveToBraceExtendEvent | Raises the key event that calls ISelection.SelectToBrace method.
Public field | MoveToCloseBraceEvent | Raises the key event that calls ISelection.SelectToCloseBrace method.
Public field | MoveToCloseBraceExtendEvent | Raises the key event that calls ISelection.SelectToCloseBrace method.
Public field | MoveToOpenBraceEvent | Raises the key event that calls ISelection.SelectToOpenBrace method.
Public field | MoveToOpenBraceExtendEvent | Raises the key event that calls ISelection.SelectToOpenBrace method.
Public field | MoveWordLeftEvent | Raises the key event that calls ISyntaxEdit.MoveWordLeft method.
Public field | MoveWordRightEvent | Raises the key event that calls ISyntaxEdit.MoveWordRight method.
Public field | NewLineAboveEvent | Raises the key event that calls ISelection.NewLineAbove method.
Public field | NewLineBelowEvent | Raises the key event that calls ISelection.NewLineBelow method.
Public field | NewLineEvent | Raises the key event that calls ISelection.NewLine method.
Public field | NextBookMarkEvent | Raises the key event that calls IBookMarks.GotoNextBookMark method.
Public field | ParameterInfoEvent | Raises the key event that calls ISyntaxEdit.ParameterInfo method.
Public field | PasteEvent | Raises the key event that calls ISelection.Paste method.
Public field | PlayBackMacro | Raises the key event that calls ISyntaxEdit.PlayBackMacro method.
Public field | PrevBookMarkEvent | Raises the key event that calls IBookMarks.GotoPrevBookMark method.
Public field | ProcessEscapeEvent | Raises the key event that calls ISelection.ProcessEscape method.
Public field | ProcessKey | Raises the key event that calls PressKey method.
Public field | ProcessShiftTabEvent | Raises the key event that calls ISelection.ProcessShiftTab method.
Public field | ProcessTabEvent | Raises the key event that calls ISelection.ProcessTab method.
Public field | QuickInfoEvent | Raises the key event that calls ISyntaxEdit.ListMembers method.
Public field | RedoEvent | Raises the key event that calls ITextSource.Redo method.
Public field | ReplaceEvent | Raises the key event that calls ISyntaxEdit.DisplayReplaceDialog method.
Public field | ScrollLineDownEvent | Raises the key event that calls ISyntaxEdit.ScrollLineDown method.
Public field | ScrollLineUpEvent | Raises the key event that calls ISyntaxEdit.ScrollLineUp method.
Public field | SelectAllEvent | Raises the key event that calls ISelection.SelectAll method.
Public field | SelectCharLeftEvent | Raises the key event that calls ISelection.SelectCharLeft method.
Public field | SelectCharRightEvent | Raises the key event that calls ISelection.SelectCharRight method.
Public field | SelectFileBeginEvent | Raises the key event that calls ISelection.SelectFileBegin method.
Public field | SelectFileEndEvent | Raises the key event that calls ISelection.SelectFileEnd method.
Public field | SelectLineBeginEvent | Raises the key event that calls ISelection.SelectLineBegin method.
Public field | SelectLineDownEvent | Raises the key event that calls ISelection.SelectLineDown method.
Public field | SelectLineEndEvent | Raises the key event that calls ISelection.SelectLineEnd method.
Public field | SelectLineUpEvent | Raises the key event that calls ISelection.SelectLineUp method.
Public field | SelectPageDownEvent | Raises the key event that calls ISelection.SelectPageDown method.
Public field | SelectPageUpEvent | Raises the key event that calls ISelection.SelectPageUp method.
Public field | SelectScreenBottomEvent | Raises the key event that calls ISelection.SelectScreenBottom method.
Public field | SelectScreenTopEvent | Raises the key event that calls ISelection.SelectScreenTop method.
Public field | SelectWordEvent | Raises the key event that calls ISelection.SelectWord method.
Public field | SelectWordLeftEvent | Raises the key event that calls ISelection.SelectWordLeft method.
Public field | SelectWordRightEvent | Raises the key event that calls ISelection.SelectWordRight method.
Public field | SwapAnchorEvent | Raises the key event that calls ISelection.SwapAnchor method.
Public field | TabifyEvent | Raises the key event that calls ISelection.Tabify method.
Public field | ToggleBookMarkEvent | Raises the key event that calls IBookMarks.ToggleBookMark method.
Public field | ToggleBookMarkEventEx | Raises the key event that calls IBookMarks.ToggleBookMark method with parameter.
Public field | ToggleHiddenTextEvent | Raises the key event that calls ToggleHiddenText method.
Public field | ToggleMacroRecording | Raises the key event that calls ISyntaxEdit.ToggleMacroRecording method.
Public field | ToggleMatchCaseEvent | Raises the key event that calls ToggleMatchCase method.
Public field | ToggleOutliningEvent | Raises the key event that calls IOutlining.ToggleOutlining method.
Public field | ToggleOutliningSelectionEvent | Raises the key event that calls ISelection.ToggleOutlining method.
Public field | ToggleOverwriteEvent | Raises the key event that calls ISelection.ToggleOverWrite method.
Public field | ToggleRegularExpressionsEvent | Raises the key event that calls ToggleRegularExpressions method.
Public field | ToggleSearchUpEvent | Raises the key event that calls ToggleSearchUp method.
Public field | ToggleWholeWordEvent | Raises the key event that calls ToggleWholeWord method.
Public field | UncommentSelectionEvent | Raises the key event that calls ISelection.UncommentSelection method.
Public field | UndoEvent | Raises the key event that calls ITextSource.Undo method.
Public field | UnTabifyEvent | Raises the key event that calls ISelection.UnTabify method.
Public field | UpperCaseEvent | Raises the key event that calls ISelection.UpperCase method.
Public field | WordTransposeEvent | Raises the key event that calls ISelection.WordTransponse method.
Top
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.CapitalizeEvent Field

EventHandlersCapitalizeEvent Field
Raises the key event that calls ISelection.Capitalize method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent CapitalizeEvent
Public CapitalizeEvent As KeyEvent
public:
KeyEvent^ CapitalizeEvent
val mutable CapitalizeEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.CharTransposeEvent Field

EventHandlersCharTransposeEvent Field
Raises the key event that calls ISelection.CharTransponse method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent CharTransposeEvent
Public CharTransposeEvent As KeyEvent
public:
KeyEvent^ CharTransposeEvent
val mutable CharTransposeEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ClearBookMarkEvent Field

EventHandlersClearBookMarkEvent Field
Raises the key event that calls IBookMarks.ClearAllBookMarks method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ClearBookMarkEvent
Public ClearBookMarkEvent As KeyEvent
public:
KeyEvent^ ClearBookMarkEvent
val mutable ClearBookMarkEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.CodeSnippetsEvent Field

EventHandlersCodeSnippetsEvent Field
Raises the key event that calls ISyntaxEdit.QuickInfo method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent CodeSnippetsEvent
Public CodeSnippetsEvent As KeyEvent
public:
KeyEvent^ CodeSnippetsEvent
val mutable CodeSnippetsEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.CollapseToDefinitionsEvent Field

EventHandlersCollapseToDefinitionsEvent Field
Raises the key event that calls IOutlining.CollapseToDefinitions method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent CollapseToDefinitionsEvent
Public CollapseToDefinitionsEvent As KeyEvent
public:
KeyEvent^ CollapseToDefinitionsEvent
val mutable CollapseToDefinitionsEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.CommentSelectionEvent Field

EventHandlersCommentSelectionEvent Field
Raises the key event that calls ISelection.CommentSelection method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent CommentSelectionEvent
Public CommentSelectionEvent As KeyEvent
public:
KeyEvent^ CommentSelectionEvent
val mutable CommentSelectionEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.CompleteCodeFixesOrRefactors Field

EventHandlersCompleteCodeFixesOrRefactors Field
Raises the key event that calls ISyntaxEdit.CompleteCodeFixesOrRefactors method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent CompleteCodeFixesOrRefactors
Public CompleteCodeFixesOrRefactors As KeyEvent
public:
KeyEvent^ CompleteCodeFixesOrRefactors
val mutable CompleteCodeFixesOrRefactors: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.CompleteWordEvent Field

EventHandlersCompleteWordEvent Field
Raises the key event that calls ISyntaxEdit.CompleteWord method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent CompleteWordEvent
Public CompleteWordEvent As KeyEvent
public:
KeyEvent^ CompleteWordEvent
val mutable CompleteWordEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.CopyEvent Field

EventHandlersCopyEvent Field
Raises the key event that calls ISelection.Copy method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent CopyEvent
Public CopyEvent As KeyEvent
public:
KeyEvent^ CopyEvent
val mutable CopyEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.CutEvent Field

EventHandlersCutEvent Field
Raises the key event that calls ISelection.Cut method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent CutEvent
Public CutEvent As KeyEvent
public:
KeyEvent^ CutEvent
val mutable CutEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.DeleteLeftEvent Field

EventHandlersDeleteLeftEvent Field
Raises the key event that calls ISelection.DeleteLeft method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent DeleteLeftEvent
Public DeleteLeftEvent As KeyEvent
public:
KeyEvent^ DeleteLeftEvent
val mutable DeleteLeftEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.DeleteRightEvent Field

EventHandlersDeleteRightEvent Field
Raises the key event that calls ISelection.DeleteRight method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent DeleteRightEvent
Public DeleteRightEvent As KeyEvent
public:
KeyEvent^ DeleteRightEvent
val mutable DeleteRightEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.DeleteWhiteSpaceEvent Field

EventHandlersDeleteWhiteSpaceEvent Field
Raises the key event that calls ISelection.DeleteWhiteSpace method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent DeleteWhiteSpaceEvent
Public DeleteWhiteSpaceEvent As KeyEvent
public:
KeyEvent^ DeleteWhiteSpaceEvent
val mutable DeleteWhiteSpaceEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.DeleteWordLeftEvent Field

EventHandlersDeleteWordLeftEvent Field
Raises the key event that calls ISelection.DeleteWordLeft method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent DeleteWordLeftEvent
Public DeleteWordLeftEvent As KeyEvent
public:
KeyEvent^ DeleteWordLeftEvent
val mutable DeleteWordLeftEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.DeleteWordRightEvent Field

EventHandlersDeleteWordRightEvent Field
Raises the key event that calls ISelection.DeleteWordRight method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent DeleteWordRightEvent
Public DeleteWordRightEvent As KeyEvent
public:
KeyEvent^ DeleteWordRightEvent
val mutable DeleteWordRightEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FindEvent Field

EventHandlersFindEvent Field
Raises the key event that calls ISyntaxEdit.DisplaySearchDialog method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent FindEvent
Public FindEvent As KeyEvent
public:
KeyEvent^ FindEvent
val mutable FindEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FindNextEvent Field

EventHandlersFindNextEvent Field
Raises the key event that calls FindNext method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent FindNextEvent
Public FindNextEvent As KeyEvent
public:
KeyEvent^ FindNextEvent
val mutable FindNextEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FindNextSelectedEvent Field

EventHandlersFindNextSelectedEvent Field
Raises the key event that calls FindNextSelected method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent FindNextSelectedEvent
Public FindNextSelectedEvent As KeyEvent
public:
KeyEvent^ FindNextSelectedEvent
val mutable FindNextSelectedEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FindPreviousEvent Field

EventHandlersFindPreviousEvent Field
Raises the key event that calls FindPrevious method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent FindPreviousEvent
Public FindPreviousEvent As KeyEvent
public:
KeyEvent^ FindPreviousEvent
val mutable FindPreviousEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FindPreviousSelectedEvent Field

EventHandlersFindPreviousSelectedEvent Field
Raises the key event that calls FindPreviousSelected method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent FindPreviousSelectedEvent
Public FindPreviousSelectedEvent As KeyEvent
public:
KeyEvent^ FindPreviousSelectedEvent
val mutable FindPreviousSelectedEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FormatDocumentEvent Field

EventHandlersFormatDocumentEvent Field
Raises the key event that calls ISelection.SmartFormatDocument method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent FormatDocumentEvent
Public FormatDocumentEvent As KeyEvent
public:
KeyEvent^ FormatDocumentEvent
val mutable FormatDocumentEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FormatSelectionEvent Field

EventHandlersFormatSelectionEvent Field
Raises the key event that calls ISelection.SmartFormat method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent FormatSelectionEvent
Public FormatSelectionEvent As KeyEvent
public:
KeyEvent^ FormatSelectionEvent
val mutable FormatSelectionEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.GotolineEvent Field

EventHandlersGotolineEvent Field
Raises the key event that calls ISyntaxEdit.DisplayGotoLineDialog method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent GotolineEvent
Public GotolineEvent As KeyEvent
public:
KeyEvent^ GotolineEvent
val mutable GotolineEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.InitIncrementalSearchEvent Field

EventHandlersInitIncrementalSearchEvent Field
Raises the key event that calls ISyntaxEdit.StartIncrementalSearch method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent InitIncrementalSearchEvent
Public InitIncrementalSearchEvent As KeyEvent
public:
KeyEvent^ InitIncrementalSearchEvent
val mutable InitIncrementalSearchEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.InitReverseIncrementalSearchEvent Field

EventHandlersInitReverseIncrementalSearchEvent Field
Raises the key event that calls StartReverseIncrementalSearch method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent InitReverseIncrementalSearchEvent
Public InitReverseIncrementalSearchEvent As KeyEvent
public:
KeyEvent^ InitReverseIncrementalSearchEvent
val mutable InitReverseIncrementalSearchEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.LineCutEvent Field

EventHandlersLineCutEvent Field
Raises the key event that calls ISelection.CutLine method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent LineCutEvent
Public LineCutEvent As KeyEvent
public:
KeyEvent^ LineCutEvent
val mutable LineCutEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.LineDeleteEvent Field

EventHandlersLineDeleteEvent Field
Raises the key event that calls ISelection.DeleteLine method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent LineDeleteEvent
Public LineDeleteEvent As KeyEvent
public:
KeyEvent^ LineDeleteEvent
val mutable LineDeleteEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.LineTransposeEvent Field

EventHandlersLineTransposeEvent Field
Raises the key event that calls ISelection.LineTransponse method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent LineTransposeEvent
Public LineTransposeEvent As KeyEvent
public:
KeyEvent^ LineTransposeEvent
val mutable LineTransposeEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ListMembersEvent Field

EventHandlersListMembersEvent Field
Raises the key event that calls ISyntaxEdit.ListMembers method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ListMembersEvent
Public ListMembersEvent As KeyEvent
public:
KeyEvent^ ListMembersEvent
val mutable ListMembersEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.LowerCaseEvent Field

EventHandlersLowerCaseEvent Field
Raises the key event that calls ISelection.LowerCase method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent LowerCaseEvent
Public LowerCaseEvent As KeyEvent
public:
KeyEvent^ LowerCaseEvent
val mutable LowerCaseEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveBookMarkEvent Field

EventHandlersMoveBookMarkEvent Field
Raises the key event that calls IBookMarks.GotoBookMark method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx MoveBookMarkEvent
Public MoveBookMarkEvent As KeyEventEx
public:
KeyEventEx^ MoveBookMarkEvent
val mutable MoveBookMarkEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveCharLeftEvent Field

EventHandlersMoveCharLeftEvent Field
Raises the key event that calls ISyntaxEdit.MoveCharLeft method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveCharLeftEvent
Public MoveCharLeftEvent As KeyEvent
public:
KeyEvent^ MoveCharLeftEvent
val mutable MoveCharLeftEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveCharRightEvent Field

EventHandlersMoveCharRightEvent Field
Raises the key event that calls ISyntaxEdit.MoveCharRight method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveCharRightEvent
Public MoveCharRightEvent As KeyEvent
public:
KeyEvent^ MoveCharRightEvent
val mutable MoveCharRightEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveFileBeginEvent Field

EventHandlersMoveFileBeginEvent Field
Raises the key event that calls ISyntaxEdit.MoveFileBegin method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveFileBeginEvent
Public MoveFileBeginEvent As KeyEvent
public:
KeyEvent^ MoveFileBeginEvent
val mutable MoveFileBeginEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveFileEndEvent Field

EventHandlersMoveFileEndEvent Field
Raises the key event that calls ISyntaxEdit.MoveFileEnd method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveFileEndEvent
Public MoveFileEndEvent As KeyEvent
public:
KeyEvent^ MoveFileEndEvent
val mutable MoveFileEndEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveLineBeginEvent Field

EventHandlersMoveLineBeginEvent Field
Raises the key event that calls ISyntaxEdit.MoveLineBeginCycled method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveLineBeginEvent
Public MoveLineBeginEvent As KeyEvent
public:
KeyEvent^ MoveLineBeginEvent
val mutable MoveLineBeginEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveLineDownEvent Field

EventHandlersMoveLineDownEvent Field
Raises the key event that calls ISyntaxEdit.MoveLineDown method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveLineDownEvent
Public MoveLineDownEvent As KeyEvent
public:
KeyEvent^ MoveLineDownEvent
val mutable MoveLineDownEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveLineEndEvent Field

EventHandlersMoveLineEndEvent Field
Raises the key event that calls ISyntaxEdit.MoveLineEnd method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveLineEndEvent
Public MoveLineEndEvent As KeyEvent
public:
KeyEvent^ MoveLineEndEvent
val mutable MoveLineEndEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveLineUpEvent Field

EventHandlersMoveLineUpEvent Field
Raises the key event that calls ISyntaxEdit.MoveLineUp method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveLineUpEvent
Public MoveLineUpEvent As KeyEvent
public:
KeyEvent^ MoveLineUpEvent
val mutable MoveLineUpEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MovePageDownEvent Field

EventHandlersMovePageDownEvent Field
Raises the key event that calls ISyntaxEdit.MovePageDown method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MovePageDownEvent
Public MovePageDownEvent As KeyEvent
public:
KeyEvent^ MovePageDownEvent
val mutable MovePageDownEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MovePageUpEvent Field

EventHandlersMovePageUpEvent Field
Raises the key event that calls ISyntaxEdit.MovePageUp method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MovePageUpEvent
Public MovePageUpEvent As KeyEvent
public:
KeyEvent^ MovePageUpEvent
val mutable MovePageUpEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveScreenBottomEvent Field

EventHandlersMoveScreenBottomEvent Field
Raises the key event that calls ISyntaxEdit.MoveScreenBottom method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveScreenBottomEvent
Public MoveScreenBottomEvent As KeyEvent
public:
KeyEvent^ MoveScreenBottomEvent
val mutable MoveScreenBottomEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveScreenTopEvent Field

EventHandlersMoveScreenTopEvent Field
Raises the key event that calls ISyntaxEdit.MoveScreenTop method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveScreenTopEvent
Public MoveScreenTopEvent As KeyEvent
public:
KeyEvent^ MoveScreenTopEvent
val mutable MoveScreenTopEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveToBraceEvent Field

EventHandlersMoveToBraceEvent Field
Raises the key event that calls ISelection.SelectToBrace method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveToBraceEvent
Public MoveToBraceEvent As KeyEvent
public:
KeyEvent^ MoveToBraceEvent
val mutable MoveToBraceEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveToBraceExtendEvent Field

EventHandlersMoveToBraceExtendEvent Field
Raises the key event that calls ISelection.SelectToBrace method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveToBraceExtendEvent
Public MoveToBraceExtendEvent As KeyEvent
public:
KeyEvent^ MoveToBraceExtendEvent
val mutable MoveToBraceExtendEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveToCloseBraceEvent Field

EventHandlersMoveToCloseBraceEvent Field
Raises the key event that calls ISelection.SelectToCloseBrace method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveToCloseBraceEvent
Public MoveToCloseBraceEvent As KeyEvent
public:
KeyEvent^ MoveToCloseBraceEvent
val mutable MoveToCloseBraceEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveToCloseBraceExtendEvent Field

EventHandlersMoveToCloseBraceExtendEvent Field
Raises the key event that calls ISelection.SelectToCloseBrace method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveToCloseBraceExtendEvent
Public MoveToCloseBraceExtendEvent As KeyEvent
public:
KeyEvent^ MoveToCloseBraceExtendEvent
val mutable MoveToCloseBraceExtendEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveToOpenBraceEvent Field

EventHandlersMoveToOpenBraceEvent Field
Raises the key event that calls ISelection.SelectToOpenBrace method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveToOpenBraceEvent
Public MoveToOpenBraceEvent As KeyEvent
public:
KeyEvent^ MoveToOpenBraceEvent
val mutable MoveToOpenBraceEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveToOpenBraceExtendEvent Field

EventHandlersMoveToOpenBraceExtendEvent Field
Raises the key event that calls ISelection.SelectToOpenBrace method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveToOpenBraceExtendEvent
Public MoveToOpenBraceExtendEvent As KeyEvent
public:
KeyEvent^ MoveToOpenBraceExtendEvent
val mutable MoveToOpenBraceExtendEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveWordLeftEvent Field

EventHandlersMoveWordLeftEvent Field
Raises the key event that calls ISyntaxEdit.MoveWordLeft method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveWordLeftEvent
Public MoveWordLeftEvent As KeyEvent
public:
KeyEvent^ MoveWordLeftEvent
val mutable MoveWordLeftEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MoveWordRightEvent Field

EventHandlersMoveWordRightEvent Field
Raises the key event that calls ISyntaxEdit.MoveWordRight method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent MoveWordRightEvent
Public MoveWordRightEvent As KeyEvent
public:
KeyEvent^ MoveWordRightEvent
val mutable MoveWordRightEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.NewLineAboveEvent Field

EventHandlersNewLineAboveEvent Field
Raises the key event that calls ISelection.NewLineAbove method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent NewLineAboveEvent
Public NewLineAboveEvent As KeyEvent
public:
KeyEvent^ NewLineAboveEvent
val mutable NewLineAboveEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.NewLineBelowEvent Field

EventHandlersNewLineBelowEvent Field
Raises the key event that calls ISelection.NewLineBelow method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent NewLineBelowEvent
Public NewLineBelowEvent As KeyEvent
public:
KeyEvent^ NewLineBelowEvent
val mutable NewLineBelowEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.NewLineEvent Field

EventHandlersNewLineEvent Field
Raises the key event that calls ISelection.NewLine method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent NewLineEvent
Public NewLineEvent As KeyEvent
public:
KeyEvent^ NewLineEvent
val mutable NewLineEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.NextBookMarkEvent Field

EventHandlersNextBookMarkEvent Field
Raises the key event that calls IBookMarks.GotoNextBookMark method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent NextBookMarkEvent
Public NextBookMarkEvent As KeyEvent
public:
KeyEvent^ NextBookMarkEvent
val mutable NextBookMarkEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ParameterInfoEvent Field

EventHandlersParameterInfoEvent Field
Raises the key event that calls ISyntaxEdit.ParameterInfo method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ParameterInfoEvent
Public ParameterInfoEvent As KeyEvent
public:
KeyEvent^ ParameterInfoEvent
val mutable ParameterInfoEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.PasteEvent Field

EventHandlersPasteEvent Field
Raises the key event that calls ISelection.Paste method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent PasteEvent
Public PasteEvent As KeyEvent
public:
KeyEvent^ PasteEvent
val mutable PasteEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.PlayBackMacro Field

EventHandlersPlayBackMacro Field
Raises the key event that calls ISyntaxEdit.PlayBackMacro method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent PlayBackMacro
Public PlayBackMacro As KeyEvent
public:
KeyEvent^ PlayBackMacro
val mutable PlayBackMacro: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.PrevBookMarkEvent Field

EventHandlersPrevBookMarkEvent Field
Raises the key event that calls IBookMarks.GotoPrevBookMark method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent PrevBookMarkEvent
Public PrevBookMarkEvent As KeyEvent
public:
KeyEvent^ PrevBookMarkEvent
val mutable PrevBookMarkEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ProcessEscapeEvent Field

EventHandlersProcessEscapeEvent Field
Raises the key event that calls ISelection.ProcessEscape method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ProcessEscapeEvent
Public ProcessEscapeEvent As KeyEvent
public:
KeyEvent^ ProcessEscapeEvent
val mutable ProcessEscapeEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ProcessKey Field

EventHandlersProcessKey Field
Raises the key event that calls PressKey method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx ProcessKey
Public ProcessKey As KeyEventEx
public:
KeyEventEx^ ProcessKey
val mutable ProcessKey: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ProcessShiftTabEvent Field

EventHandlersProcessShiftTabEvent Field
Raises the key event that calls ISelection.ProcessShiftTab method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ProcessShiftTabEvent
Public ProcessShiftTabEvent As KeyEvent
public:
KeyEvent^ ProcessShiftTabEvent
val mutable ProcessShiftTabEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ProcessTabEvent Field

EventHandlersProcessTabEvent Field
Raises the key event that calls ISelection.ProcessTab method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ProcessTabEvent
Public ProcessTabEvent As KeyEvent
public:
KeyEvent^ ProcessTabEvent
val mutable ProcessTabEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.QuickInfoEvent Field

EventHandlersQuickInfoEvent Field
Raises the key event that calls ISyntaxEdit.ListMembers method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent QuickInfoEvent
Public QuickInfoEvent As KeyEvent
public:
KeyEvent^ QuickInfoEvent
val mutable QuickInfoEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.RedoEvent Field

EventHandlersRedoEvent Field
Raises the key event that calls ITextSource.Redo method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent RedoEvent
Public RedoEvent As KeyEvent
public:
KeyEvent^ RedoEvent
val mutable RedoEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ReplaceEvent Field

EventHandlersReplaceEvent Field
Raises the key event that calls ISyntaxEdit.DisplayReplaceDialog method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ReplaceEvent
Public ReplaceEvent As KeyEvent
public:
KeyEvent^ ReplaceEvent
val mutable ReplaceEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ScrollLineDownEvent Field

EventHandlersScrollLineDownEvent Field
Raises the key event that calls ISyntaxEdit.ScrollLineDown method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ScrollLineDownEvent
Public ScrollLineDownEvent As KeyEvent
public:
KeyEvent^ ScrollLineDownEvent
val mutable ScrollLineDownEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ScrollLineUpEvent Field

EventHandlersScrollLineUpEvent Field
Raises the key event that calls ISyntaxEdit.ScrollLineUp method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ScrollLineUpEvent
Public ScrollLineUpEvent As KeyEvent
public:
KeyEvent^ ScrollLineUpEvent
val mutable ScrollLineUpEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectAllEvent Field

EventHandlersSelectAllEvent Field
Raises the key event that calls ISelection.SelectAll method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent SelectAllEvent
Public SelectAllEvent As KeyEvent
public:
KeyEvent^ SelectAllEvent
val mutable SelectAllEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectCharLeftEvent Field

EventHandlersSelectCharLeftEvent Field
Raises the key event that calls ISelection.SelectCharLeft method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectCharLeftEvent
Public SelectCharLeftEvent As KeyEventEx
public:
KeyEventEx^ SelectCharLeftEvent
val mutable SelectCharLeftEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectCharRightEvent Field

EventHandlersSelectCharRightEvent Field
Raises the key event that calls ISelection.SelectCharRight method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectCharRightEvent
Public SelectCharRightEvent As KeyEventEx
public:
KeyEventEx^ SelectCharRightEvent
val mutable SelectCharRightEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectFileBeginEvent Field

EventHandlersSelectFileBeginEvent Field
Raises the key event that calls ISelection.SelectFileBegin method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectFileBeginEvent
Public SelectFileBeginEvent As KeyEventEx
public:
KeyEventEx^ SelectFileBeginEvent
val mutable SelectFileBeginEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectFileEndEvent Field

EventHandlersSelectFileEndEvent Field
Raises the key event that calls ISelection.SelectFileEnd method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectFileEndEvent
Public SelectFileEndEvent As KeyEventEx
public:
KeyEventEx^ SelectFileEndEvent
val mutable SelectFileEndEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectLineBeginEvent Field

EventHandlersSelectLineBeginEvent Field
Raises the key event that calls ISelection.SelectLineBegin method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectLineBeginEvent
Public SelectLineBeginEvent As KeyEventEx
public:
KeyEventEx^ SelectLineBeginEvent
val mutable SelectLineBeginEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectLineDownEvent Field

EventHandlersSelectLineDownEvent Field
Raises the key event that calls ISelection.SelectLineDown method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectLineDownEvent
Public SelectLineDownEvent As KeyEventEx
public:
KeyEventEx^ SelectLineDownEvent
val mutable SelectLineDownEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectLineEndEvent Field

EventHandlersSelectLineEndEvent Field
Raises the key event that calls ISelection.SelectLineEnd method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectLineEndEvent
Public SelectLineEndEvent As KeyEventEx
public:
KeyEventEx^ SelectLineEndEvent
val mutable SelectLineEndEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectLineUpEvent Field

EventHandlersSelectLineUpEvent Field
Raises the key event that calls ISelection.SelectLineUp method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectLineUpEvent
Public SelectLineUpEvent As KeyEventEx
public:
KeyEventEx^ SelectLineUpEvent
val mutable SelectLineUpEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectPageDownEvent Field

EventHandlersSelectPageDownEvent Field
Raises the key event that calls ISelection.SelectPageDown method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectPageDownEvent
Public SelectPageDownEvent As KeyEventEx
public:
KeyEventEx^ SelectPageDownEvent
val mutable SelectPageDownEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectPageUpEvent Field

EventHandlersSelectPageUpEvent Field
Raises the key event that calls ISelection.SelectPageUp method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectPageUpEvent
Public SelectPageUpEvent As KeyEventEx
public:
KeyEventEx^ SelectPageUpEvent
val mutable SelectPageUpEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectScreenBottomEvent Field

EventHandlersSelectScreenBottomEvent Field
Raises the key event that calls ISelection.SelectScreenBottom method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectScreenBottomEvent
Public SelectScreenBottomEvent As KeyEventEx
public:
KeyEventEx^ SelectScreenBottomEvent
val mutable SelectScreenBottomEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectScreenTopEvent Field

EventHandlersSelectScreenTopEvent Field
Raises the key event that calls ISelection.SelectScreenTop method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectScreenTopEvent
Public SelectScreenTopEvent As KeyEventEx
public:
KeyEventEx^ SelectScreenTopEvent
val mutable SelectScreenTopEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectWordEvent Field

EventHandlersSelectWordEvent Field
Raises the key event that calls ISelection.SelectWord method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent SelectWordEvent
Public SelectWordEvent As KeyEvent
public:
KeyEvent^ SelectWordEvent
val mutable SelectWordEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectWordLeftEvent Field

EventHandlersSelectWordLeftEvent Field
Raises the key event that calls ISelection.SelectWordLeft method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectWordLeftEvent
Public SelectWordLeftEvent As KeyEventEx
public:
KeyEventEx^ SelectWordLeftEvent
val mutable SelectWordLeftEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectWordRightEvent Field

EventHandlersSelectWordRightEvent Field
Raises the key event that calls ISelection.SelectWordRight method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx SelectWordRightEvent
Public SelectWordRightEvent As KeyEventEx
public:
KeyEventEx^ SelectWordRightEvent
val mutable SelectWordRightEvent: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SwapAnchorEvent Field

EventHandlersSwapAnchorEvent Field
Raises the key event that calls ISelection.SwapAnchor method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent SwapAnchorEvent
Public SwapAnchorEvent As KeyEvent
public:
KeyEvent^ SwapAnchorEvent
val mutable SwapAnchorEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.TabifyEvent Field

EventHandlersTabifyEvent Field
Raises the key event that calls ISelection.Tabify method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent TabifyEvent
Public TabifyEvent As KeyEvent
public:
KeyEvent^ TabifyEvent
val mutable TabifyEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleBookMarkEvent Field

EventHandlersToggleBookMarkEvent Field
Raises the key event that calls IBookMarks.ToggleBookMark method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleBookMarkEvent
Public ToggleBookMarkEvent As KeyEvent
public:
KeyEvent^ ToggleBookMarkEvent
val mutable ToggleBookMarkEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleBookMarkEventEx Field

EventHandlersToggleBookMarkEventEx Field
Raises the key event that calls IBookMarks.ToggleBookMark method with parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx ToggleBookMarkEventEx
Public ToggleBookMarkEventEx As KeyEventEx
public:
KeyEventEx^ ToggleBookMarkEventEx
val mutable ToggleBookMarkEventEx: KeyEventEx

Field Value

Type: KeyEventEx
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleHiddenTextEvent Field

EventHandlersToggleHiddenTextEvent Field
Raises the key event that calls ToggleHiddenText method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleHiddenTextEvent
Public ToggleHiddenTextEvent As KeyEvent
public:
KeyEvent^ ToggleHiddenTextEvent
val mutable ToggleHiddenTextEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleMacroRecording Field

EventHandlersToggleMacroRecording Field
Raises the key event that calls ISyntaxEdit.ToggleMacroRecording method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleMacroRecording
Public ToggleMacroRecording As KeyEvent
public:
KeyEvent^ ToggleMacroRecording
val mutable ToggleMacroRecording: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleMatchCaseEvent Field

EventHandlersToggleMatchCaseEvent Field
Raises the key event that calls ToggleMatchCase method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleMatchCaseEvent
Public ToggleMatchCaseEvent As KeyEvent
public:
KeyEvent^ ToggleMatchCaseEvent
val mutable ToggleMatchCaseEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleOutliningEvent Field

EventHandlersToggleOutliningEvent Field
Raises the key event that calls IOutlining.ToggleOutlining method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleOutliningEvent
Public ToggleOutliningEvent As KeyEvent
public:
KeyEvent^ ToggleOutliningEvent
val mutable ToggleOutliningEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleOutliningSelectionEvent Field

EventHandlersToggleOutliningSelectionEvent Field
Raises the key event that calls ISelection.ToggleOutlining method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleOutliningSelectionEvent
Public ToggleOutliningSelectionEvent As KeyEvent
public:
KeyEvent^ ToggleOutliningSelectionEvent
val mutable ToggleOutliningSelectionEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleOverwriteEvent Field

EventHandlersToggleOverwriteEvent Field
Raises the key event that calls ISelection.ToggleOverWrite method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleOverwriteEvent
Public ToggleOverwriteEvent As KeyEvent
public:
KeyEvent^ ToggleOverwriteEvent
val mutable ToggleOverwriteEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleRegularExpressionsEvent Field

EventHandlersToggleRegularExpressionsEvent Field
Raises the key event that calls ToggleRegularExpressions method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleRegularExpressionsEvent
Public ToggleRegularExpressionsEvent As KeyEvent
public:
KeyEvent^ ToggleRegularExpressionsEvent
val mutable ToggleRegularExpressionsEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleSearchUpEvent Field

EventHandlersToggleSearchUpEvent Field
Raises the key event that calls ToggleSearchUp method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleSearchUpEvent
Public ToggleSearchUpEvent As KeyEvent
public:
KeyEvent^ ToggleSearchUpEvent
val mutable ToggleSearchUpEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleWholeWordEvent Field

EventHandlersToggleWholeWordEvent Field
Raises the key event that calls ToggleWholeWord method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent ToggleWholeWordEvent
Public ToggleWholeWordEvent As KeyEvent
public:
KeyEvent^ ToggleWholeWordEvent
val mutable ToggleWholeWordEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.UncommentSelectionEvent Field

EventHandlersUncommentSelectionEvent Field
Raises the key event that calls ISelection.UncommentSelection method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent UncommentSelectionEvent
Public UncommentSelectionEvent As KeyEvent
public:
KeyEvent^ UncommentSelectionEvent
val mutable UncommentSelectionEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.UndoEvent Field

EventHandlersUndoEvent Field
Raises the key event that calls ITextSource.Undo method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent UndoEvent
Public UndoEvent As KeyEvent
public:
KeyEvent^ UndoEvent
val mutable UndoEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.UnTabifyEvent Field

EventHandlersUnTabifyEvent Field
Raises the key event that calls ISelection.UnTabify method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent UnTabifyEvent
Public UnTabifyEvent As KeyEvent
public:
KeyEvent^ UnTabifyEvent
val mutable UnTabifyEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.UpperCaseEvent Field

EventHandlersUpperCaseEvent Field
Raises the key event that calls ISelection.UpperCase method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent UpperCaseEvent
Public UpperCaseEvent As KeyEvent
public:
KeyEvent^ UpperCaseEvent
val mutable UpperCaseEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.WordTransposeEvent Field

EventHandlersWordTransposeEvent Field
Raises the key event that calls ISelection.WordTransponse method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent WordTransposeEvent
Public WordTransposeEvent As KeyEvent
public:
KeyEvent^ WordTransposeEvent
val mutable WordTransposeEvent: KeyEvent

Field Value

Type: KeyEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers Methods

EventHandlers Methods

The EventHandlers type exposes the following members.

Methods
 | Name | Description
Public method | ClearAllBookMarks |
Public method | DeleteLeft |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Find |
Public method | FindNext |
Public method | FindNextSelected |
Public method | FindPrevious |
Public method | FindPreviousSelected |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoBookMark |
Public method | GotoLine |
Public method | GotoNextBookMark |
Public method | GotoPrevBookMark |
Public method | PressKey |
Public method | ProcessEscape |
Public method | Redo |
Public method | Replace |
Public method | SelectAll |
Public method | SelectCharLeft |
Public method | SelectCharRight |
Public method | SelectFileBegin |
Public method | SelectFileEnd |
Public method | SelectLineBegin |
Public method | SelectLineDown |
Public method | SelectLineEnd |
Public method | SelectLineUp |
Public method | SelectPageDown |
Public method | SelectPageUp |
Public method | SelectScreenBottom |
Public method | SelectScreenTop |
Public method | SelectWordLeft |
Public method | SelectWordRight |
Public method | StartReverseIncrementalSearch |
Public method | ToggleBookMark |
Public method | ToggleBookMark(Object) |
Public method | ToggleHiddenText |
Public method | ToggleMatchCase |
Public method | ToggleRegularExpressions |
Public method | ToggleSearchUp |
Public method | ToggleWholeWord |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo |
Top
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ClearAllBookMarks Method

EventHandlersClearAllBookMarks Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearAllBookMarks()
Public Sub ClearAllBookMarks
public:
void ClearAllBookMarks()
member ClearAllBookMarks : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.DeleteLeft Method

EventHandlersDeleteLeft Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteLeft()
Public Sub DeleteLeft
public:
void DeleteLeft()
member DeleteLeft : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.Find Method

EventHandlersFind Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Find()
Public Sub Find
public:
void Find()
member Find : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FindNext Method

EventHandlersFindNext Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FindNext()
Public Sub FindNext
public:
void FindNext()
member FindNext : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FindNextSelected Method

EventHandlersFindNextSelected Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FindNextSelected()
Public Sub FindNextSelected
public:
void FindNextSelected()
member FindNextSelected : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FindPrevious Method

EventHandlersFindPrevious Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FindPrevious()
Public Sub FindPrevious
public:
void FindPrevious()
member FindPrevious : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.FindPreviousSelected Method

EventHandlersFindPreviousSelected Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FindPreviousSelected()
Public Sub FindPreviousSelected
public:
void FindPreviousSelected()
member FindPreviousSelected : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.GotoBookMark Method

EventHandlersGotoBookMark Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GotoBookMark(
    Object param
)
Public Sub GotoBookMark (
    param As Object
)
public:
void GotoBookMark(
    Object^ param
)
member GotoBookMark :
        param : Object -> unit

Parameters

param
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.GotoLine Method

EventHandlersGotoLine Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GotoLine()
Public Sub GotoLine
public:
void GotoLine()
member GotoLine : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.GotoNextBookMark Method

EventHandlersGotoNextBookMark Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GotoNextBookMark()
Public Sub GotoNextBookMark
public:
void GotoNextBookMark()
member GotoNextBookMark : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.GotoPrevBookMark Method

EventHandlersGotoPrevBookMark Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GotoPrevBookMark()
Public Sub GotoPrevBookMark
public:
void GotoPrevBookMark()
member GotoPrevBookMark : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.PressKey Method

EventHandlersPressKey Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PressKey(
    Object param
)
Public Sub PressKey (
    param As Object
)
public:
void PressKey(
    Object^ param
)
member PressKey :
        param : Object -> unit

Parameters

param
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ProcessEscape Method

EventHandlersProcessEscape Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ProcessEscape()
Public Sub ProcessEscape
public:
void ProcessEscape()
member ProcessEscape : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.Redo Method

EventHandlersRedo Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Redo()
Public Sub Redo
public:
void Redo()
member Redo : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.Replace Method

EventHandlersReplace Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Replace()
Public Sub Replace
public:
void Replace()
member Replace : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectAll Method

EventHandlersSelectAll Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectAll()
Public Sub SelectAll
public:
void SelectAll()
member SelectAll : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectCharLeft Method

EventHandlersSelectCharLeft Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectCharLeft(
    Object selectionType
)
Public Sub SelectCharLeft (
    selectionType As Object
)
public:
void SelectCharLeft(
    Object^ selectionType
)
member SelectCharLeft :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectCharRight Method

EventHandlersSelectCharRight Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectCharRight(
    Object selectionType
)
Public Sub SelectCharRight (
    selectionType As Object
)
public:
void SelectCharRight(
    Object^ selectionType
)
member SelectCharRight :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectFileBegin Method

EventHandlersSelectFileBegin Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectFileBegin(
    Object selectionType
)
Public Sub SelectFileBegin (
    selectionType As Object
)
public:
void SelectFileBegin(
    Object^ selectionType
)
member SelectFileBegin :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectFileEnd Method

EventHandlersSelectFileEnd Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectFileEnd(
    Object selectionType
)
Public Sub SelectFileEnd (
    selectionType As Object
)
public:
void SelectFileEnd(
    Object^ selectionType
)
member SelectFileEnd :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectLineBegin Method

EventHandlersSelectLineBegin Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectLineBegin(
    Object selectionType
)
Public Sub SelectLineBegin (
    selectionType As Object
)
public:
void SelectLineBegin(
    Object^ selectionType
)
member SelectLineBegin :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectLineDown Method

EventHandlersSelectLineDown Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectLineDown(
    Object selectionType
)
Public Sub SelectLineDown (
    selectionType As Object
)
public:
void SelectLineDown(
    Object^ selectionType
)
member SelectLineDown :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectLineEnd Method

EventHandlersSelectLineEnd Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectLineEnd(
    Object selectionType
)
Public Sub SelectLineEnd (
    selectionType As Object
)
public:
void SelectLineEnd(
    Object^ selectionType
)
member SelectLineEnd :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectLineUp Method

EventHandlersSelectLineUp Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectLineUp(
    Object selectionType
)
Public Sub SelectLineUp (
    selectionType As Object
)
public:
void SelectLineUp(
    Object^ selectionType
)
member SelectLineUp :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectPageDown Method

EventHandlersSelectPageDown Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectPageDown(
    Object selectionType
)
Public Sub SelectPageDown (
    selectionType As Object
)
public:
void SelectPageDown(
    Object^ selectionType
)
member SelectPageDown :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectPageUp Method

EventHandlersSelectPageUp Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectPageUp(
    Object selectionType
)
Public Sub SelectPageUp (
    selectionType As Object
)
public:
void SelectPageUp(
    Object^ selectionType
)
member SelectPageUp :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectScreenBottom Method

EventHandlersSelectScreenBottom Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectScreenBottom(
    Object selectionType
)
Public Sub SelectScreenBottom (
    selectionType As Object
)
public:
void SelectScreenBottom(
    Object^ selectionType
)
member SelectScreenBottom :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectScreenTop Method

EventHandlersSelectScreenTop Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectScreenTop(
    Object selectionType
)
Public Sub SelectScreenTop (
    selectionType As Object
)
public:
void SelectScreenTop(
    Object^ selectionType
)
member SelectScreenTop :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectWordLeft Method

EventHandlersSelectWordLeft Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectWordLeft(
    Object selectionType
)
Public Sub SelectWordLeft (
    selectionType As Object
)
public:
void SelectWordLeft(
    Object^ selectionType
)
member SelectWordLeft :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.SelectWordRight Method

EventHandlersSelectWordRight Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectWordRight(
    Object selectionType
)
Public Sub SelectWordRight (
    selectionType As Object
)
public:
void SelectWordRight(
    Object^ selectionType
)
member SelectWordRight :
        selectionType : Object -> unit

Parameters

selectionType
Type: SystemObject
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.StartReverseIncrementalSearch Method

EventHandlersStartReverseIncrementalSearch Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartReverseIncrementalSearch()
Public Sub StartReverseIncrementalSearch
public:
void StartReverseIncrementalSearch()
member StartReverseIncrementalSearch : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleBookMark Method

EventHandlersToggleBookMark Method
Overload List
 | Name | Description
Public method | ToggleBookMark |
Public method | ToggleBookMark(Object) |
Top
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleBookMark Method

EventHandlersToggleBookMark Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToggleBookMark()
Public Sub ToggleBookMark
public:
void ToggleBookMark()
member ToggleBookMark : unit -> unit
See Also

Reference

EventHandlers Class
ToggleBookMark Overload
Alternet.Editor Namespace


EventHandlers.ToggleBookMark Method (Object)

EventHandlersToggleBookMark Method (Object)

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToggleBookMark(
    Object param
)
Public Sub ToggleBookMark (
    param As Object
)
public:
void ToggleBookMark(
    Object^ param
)
member ToggleBookMark :
        param : Object -> unit

Parameters

param
Type: SystemObject
See Also

Reference

EventHandlers Class
ToggleBookMark Overload
Alternet.Editor Namespace


EventHandlers.ToggleHiddenText Method

EventHandlersToggleHiddenText Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToggleHiddenText()
Public Sub ToggleHiddenText
public:
void ToggleHiddenText()
member ToggleHiddenText : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleMatchCase Method

EventHandlersToggleMatchCase Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToggleMatchCase()
Public Sub ToggleMatchCase
public:
void ToggleMatchCase()
member ToggleMatchCase : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleRegularExpressions Method

EventHandlersToggleRegularExpressions Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToggleRegularExpressions()
Public Sub ToggleRegularExpressions
public:
void ToggleRegularExpressions()
member ToggleRegularExpressions : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleSearchUp Method

EventHandlersToggleSearchUp Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToggleSearchUp()
Public Sub ToggleSearchUp
public:
void ToggleSearchUp()
member ToggleSearchUp : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.ToggleWholeWord Method

EventHandlersToggleWholeWord Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToggleWholeWord()
Public Sub ToggleWholeWord
public:
void ToggleWholeWord()
member ToggleWholeWord : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.Undo Method

EventHandlersUndo Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Undo()
Public Sub Undo
public:
void Undo()
member Undo : unit -> unit
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers Properties

EventHandlers Properties

The EventHandlers type exposes the following members.

Properties
 | Name | Description
Public property | EventNames | Represents names of all available event handlers.
Public property | MacroRecordEvent | Represents an event to process macro recording.
Top
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.EventNames Property

EventHandlersEventNames Property
Represents names of all available event handlers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] EventNames { get; }
Public ReadOnly Property EventNames As String()
    Get
public:
virtual property array<String^>^ EventNames {
    array<String^>^ get () sealed;
}
abstract EventNames : string[] with get
override EventNames : string[] with get

Property Value

Type: String

Implements

IEventHandlersEventNames
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


EventHandlers.MacroRecordEvent Property

EventHandlersMacroRecordEvent Property
Represents an event to process macro recording.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual KeyEventEx MacroRecordEvent { get; }
Public Overridable ReadOnly Property MacroRecordEvent As KeyEventEx
    Get
public:
virtual property KeyEventEx^ MacroRecordEvent {
    KeyEventEx^ get ();
}
abstract MacroRecordEvent : KeyEventEx with get
override MacroRecordEvent : KeyEventEx with get

Property Value

Type: KeyEventEx

Implements

IEventHandlersMacroRecordEvent
See Also

Reference

EventHandlers Class
Alternet.Editor Namespace


ExtendedSelectionScope Enumeration

ExtendedSelectionScope Enumeration
Specifies text selection scope in case of null-selection blocks

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExtendedSelectionScope
Public Enumeration ExtendedSelectionScope
public enum class ExtendedSelectionScope
type ExtendedSelectionScope
Members
Member name | Value | Description
None | 0 | Only text being selected
Left | 1 | In case of null-selection block includes character to the left.
Right | 2 | In case of null-selection block includes character to the right.
See Also

Reference

Alternet.Editor Namespace


GetSearchEvent Delegate

GetSearchEvent Delegate
Represents a method that will handle the SearchManager.GetSearch event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void GetSearchEvent(
    Object sender,
    GetSearchEventArgs e
)
Public Delegate Sub GetSearchEvent (
    sender As Object,
    e As GetSearchEventArgs
)
public delegate void GetSearchEvent(
    Object^ sender,
    GetSearchEventArgs^ e
)
type GetSearchEvent =
    delegate of
        sender : Object *
        e : GetSearchEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorGetSearchEventArgs
A GetSearchEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


GetSearchEventArgs Class

GetSearchEventArgs Class
Provides data for the GetSearchEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorGetSearchEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GetSearchEventArgs : EventArgs
Public Class GetSearchEventArgs
    Inherits EventArgs
public ref class GetSearchEventArgs : public EventArgs
type GetSearchEventArgs =
    class
        inherit EventArgs
    end

The GetSearchEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | GetSearchEventArgs | Initializes a new instance of the GetSearchEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FileName | Name of file where search processed.
Public property | Search | Search engine where search processed.
Top
See Also

Reference

Alternet.Editor Namespace


GetSearchEventArgs Constructor

GetSearchEventArgs Constructor
Initializes a new instance of the GetSearchEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public GetSearchEventArgs(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
GetSearchEventArgs(
    String^ fileName
)
new :
        fileName : string -> GetSearchEventArgs

Parameters

fileName
Type: SystemString
Name of file where search processed.
See Also

Reference

GetSearchEventArgs Class
Alternet.Editor Namespace


GetSearchEventArgs Methods

GetSearchEventArgs Methods

The GetSearchEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetSearchEventArgs Class
Alternet.Editor Namespace


GetSearchEventArgs Properties

GetSearchEventArgs Properties

The GetSearchEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Name of file where search processed.
Public property | Search | Search engine where search processed.
Top
See Also

Reference

GetSearchEventArgs Class
Alternet.Editor Namespace


GetSearchEventArgs.FileName Property

GetSearchEventArgsFileName Property
Name of file where search processed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

GetSearchEventArgs Class
Alternet.Editor Namespace


GetSearchEventArgs.Search Property

GetSearchEventArgsSearch Property
Search engine where search processed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISearch Search { get; set; }
Public Property Search As ISearch
    Get
    Set
public:
property ISearch^ Search {
    ISearch^ get ();
    void set (ISearch^ value);
}
member Search : ISearch with get, set

Property Value

Type: ISearch
See Also

Reference

GetSearchEventArgs Class
Alternet.Editor Namespace


Gutter Class

Gutter Class
Represents gutter at the left side of the Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorGutter

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Gutter : IGutter, IUpdate,
    IDisposable
Public Class Gutter
    Implements IGutter, IUpdate, IDisposable
public ref class Gutter : IGutter, IUpdate,
    IDisposable
type Gutter =
    class
        interface IGutter
        interface IUpdate
        interface IDisposable
    end

The Gutter type exposes the following members.

Constructors
 | Name | Description
Public method | Gutter | Initializes a new instance of the Gutter class with default settings.
Public method | Gutter(ISyntaxEdit) | Initializes a new instance of the Gutter class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents from another IGutter object.
Public method | BeginUpdate | Prevents gutter updating until calling Gutter.EndUpdate method.
Public method | DisableUpdate | Prevents gutter updating until calling Gutter.EndUpdate method.
Public method | Dispose | Disposes this Gutter and frees resources associated with it.
Public method | EnableUpdate | Re-enables gutter updating, that was turn of by calling Gutter.BeginUpdate method.
Public method | EndUpdate | Re-enables gutter updating, that was turn of by calling Gutter.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHitTest | Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method | GetImage | When implemented by a class, gets image from the images collection
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvalidateLineNumberArea | Invalidates line number area if it needs to be altered. Specifies whether line number width needs to be recalculated.
Public method | IsMouseOnOutlineButton | Indicates whether mouse point is within the outline button area.
Public method | OnClick | Raises the Click event.
Public method | OnDoubleClick | Raises the DoubleClick event.
Public method | Paint(IPainter, Rectangle) | Draws gutter on the specified graphic surface.
Public method | Paint(IPainter, Rectangle, Int32) | Draws gutter on the specified graphic surface.
Public method | ResetBookMarkImageIndex | Resets the BookMarkImageIndex to the default value.
Public method | ResetBrushColor | Resets the BrushColor to the default value.
Public method | ResetBulbImageIndex | Resets the BulbImageIndex to the default value.
Public method | ResetDrawLineBookmarks | Resets the DrawLineBookmarks to the default value.
Public method | ResetHighlightBlockAreaColor | Resets the HighlightBlockAreaColor to the default value.
Public method | ResetHighlightOutlineAreaColor | Resets the HighlightOutlineAreaColor to the default value.
Public method | ResetLineBookmarksColor | Resets the LineBookmarksColor to the default value.
Public method | ResetLineModificatorChangedColor | Resets the LineModificatorChangedColor to the default value.
Public method | ResetLineModificatorSavedColor | Resets the LineModificatorSavedColor to the default value.
Public method | ResetLineNumbersAlignment | Resets the LineNumbersAlignment to the default value.
Public method | ResetLineNumbersBackColor | Resets the LineNumbersBackColor to the default value.
Public method | ResetLineNumbersForeColor | Resets the LineNumbersForeColor to the default value.
Public method | ResetLineNumbersLeftIndent | Resets the LineNumbersLeftIndent to the default value.
Public method | ResetLineNumbersRightIndent | Resets the LineNumbersRightIndent to the default value.
Public method | ResetLineNumbersStart | Resets the LineNumbersStart to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetOutlineImageBackColor | Resets the OutlineImageBackColor to the default value.
Public method | ResetOutliningLeftIndent | Resets the OutliningLeftIndent to the default value.
Public method | ResetOutliningRightIndent | Resets the OutliningRightIndent to the default value.
Public method | ResetPenColor | Resets the PenColor to the default value.
Public method | ResetShowBookmarkHints | Resets the ShowBookmarkHints to the default value.
Public method | ResetUserMarginBackColor | Resets the UserMarginBackColor to the default value.
Public method | ResetUserMarginForeColor | Resets the UserMarginForeColor to the default value.
Public method | ResetUserMarginText | Resets the UserMarginText to the default value.
Public method | ResetUserMarginWidth | Resets the UserMarginWidth to the default value.
Public method | ResetVisible | Resets the Visible to the default value.
Public method | ResetWidth | Resets the Width to the default value.
Public method | ResetWrapImageIndex | Resets the WrapImageIndex to the default value.
Public method | ShouldSerializeBookMarkImageIndex | Indicates whether the BookMarkImageIndex property should be persisted.
Public method | ShouldSerializeBrushColor | Indicates whether the BrushColor property should be persisted.
Public method | ShouldSerializeBulbImageIndex | Indicates whether the BulbImageIndex property should be persisted.
Public method | ShouldSerializeHighlightBlockAreaColor | Indicates whether the HighlightBlockAreaColor property should be persisted.
Public method | ShouldSerializeHighlightOutlineAreaColor | Indicates whether the HighlightOutlineAreaColor property should be persisted.
Public method | ShouldSerializeLineBookmarksColor | Indicates whether the LineBookmarksColor property should be persisted.
Public method | ShouldSerializeLineModificatorChangedColor | Indicates whether the LineModificatorChangedColor property should be persisted.
Public method | ShouldSerializeLineModificatorSavedColor | Indicates whether the LineModificatorSavedColor property should be persisted.
Public method | ShouldSerializeLineNumbersBackColor | Indicates whether the LineNumbersBackColor property should be persisted.
Public method | ShouldSerializeLineNumbersForeColor | Indicates whether the LineNumbersForeColor property should be persisted.
Public method | ShouldSerializeLineNumbersLeftIndent | Indicates whether the LineNumbersLeftIndent property should be persisted.
Public method | ShouldSerializeLineNumbersRightIndent | Indicates whether the LineNumbersRightIndent property should be persisted.
Public method | ShouldSerializeLineNumbersStart | Indicates whether the LineNumbersStart property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | ShouldSerializeOutlineImageBackColor | Indicates whether the OutlineImageBackColor property should be persisted.
Public method | ShouldSerializeOutliningLeftIndent | Indicates whether the OutliningLeftIndent property should be persisted.
Public method | ShouldSerializeOutliningRightIndent | Indicates whether the OutliningRightIndent property should be persisted.
Public method | ShouldSerializePenColor | Indicates whether the PenColor property should be persisted.
Public method | ShouldSerializeUserMarginBackColor | Indicates whether the UserMarginBackColor property should be persisted.
Public method | ShouldSerializeUserMarginForeColor | Indicates whether the UserMarginForeColor property should be persisted.
Public method | ShouldSerializeUserMarginText | Indicates whether the UserMarginText property should be persisted.
Public method | ShouldSerializeUserMarginWidth | Indicates whether the UserMarginWidth property should be persisted.
Public method | ShouldSerializeWidth | Indicates whether the Width property should be persisted.
Public method | ShouldSerializeWrapImageIndex | Indicates whether the WrapImageIndex property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Causes the edit control to invalidate it's content.
Public method | Update(Boolean) | Causes the edit control to invalidate it's content.
Top
Properties
 | Name | Description
Public property | BookMarkImageIndex | Gets or sets a value that specifies index of item in the image collection used to paint bookmark.
Public property | Brush | Gets or sets a Brush object used to paint gutter.
Public property | BrushColor | Gets or sets background color of the gutter.
Public property | BulbImageIndex | Gets or sets a value that specifies index of item in the image collection used to paint light bulb.
Public property | DisplayArea | Gets display width of the gutter, including line numbers and outlining area, but not including line modificators if they're painted outside gutter.
Public property | DisplayWidth | Gets display width of the gutter, including line numbers and outlining area.
Public property | DrawLineBookmarks | Gets or sets a value indicating whether Edit control should draw triangle at bookmark position inside line.
Public property | HighlightBlockAreaColor | Gets or sets a background color of the highlighted block area.
Public property | HighlightOutlineAreaColor | Gets or sets a background color of the highlighted outline area.
Public property | Images | Gets or sets an ImageList object that contains collection of images for gutter.
Public property | ImagesHighDpi | Gets or sets an ImageList object that contains collection of images for gutter for high DPI.
Public property | ImagesResourceNameSuffix |
Public property | LineBookmarksColor | Gets or sets a color of the line bookmarks.
Public property | LineModificatorChangedColor | Gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the modified state.
Public property | LineModificatorSavedColor | Gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the saved state.
Public property | LineNumbersAlignment | Gets or sets line numbers alignment information.
Public property | LineNumbersBackColor | Gets or sets background color for the line numbers.
Public property | LineNumbersForeColor | Gets or sets foreground color for the line numbers.
Public property | LineNumbersLeftIndent | Gets or sets line numbers indentation from the left gutter border. When auto scaling enabled, measured in DIP.
Public property | LineNumbersLeftIndentInPixels | Gets line numbers indentation from the left gutter border in pixels.
Public property | LineNumbersRightIndent | Gets or sets line numbers indentation from the right gutter border. When auto scaling enabled, measured in DIP.
Public property | LineNumbersRightIndentInPixels | Gets line numbers indentation from the right gutter border in pixels.
Public property | LineNumbersStart | Gets or sets number of the first line being painted on the gutter.
Public property | MaxLineNumberLength | Gets or sets maximum count of numbers in the line number.
Public property | Options | Gets or sets a GutterOptions that determine gutter appearance and behaviour.
Public property | OutlineImageBackColor | Gets or sets an outline image back color.
Public property | OutliningLeftIndent | Gets or sets outlining indentation from the left gutter border. When auto scaling enabled, measured in DIP.
Public property | OutliningLeftIndentInPixels | Gets outlining indentation from the left gutter border in pixels.
Public property | OutliningRightIndent | Gets or sets outlining indentation from the right gutter border. When auto scaling enabled, measured in DIP.
Public property | OutliningRightIndentInPixels | Gets outlining indentation from the right gutter border in pixels.
Public property | Pen | Gets or sets a Pen object used to paint gutter line.
Public property | PenColor | Gets or sets color of the gutter line.
Public property | Rect | Gets the rectangle that represents gutter area.
Public property | ShowBookmarkHints | Gets or sets a value indicating whether Edit control should display text describing bookmark in form of tooltip window when mouse pointer is over the gutter bookmark.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UserMarginBackColor | Gets or sets background color of the user margin.
Public property | UserMarginForeColor | Gets or sets foreground color of the line numbers.
Public property | UserMarginText | Gets or sets text of the user margin.
Public property | UserMarginWidth | Gets or sets the width of the user margin area. When auto scaling enabled, measured in DIP.
Public property | UserMarginWidthInPixels | Gets the width of the user margin area in pixels.
Public property | Visible | Gets or sets a value indicating whether the gutter area is visible.
Public property | Width | Gets or sets the width of the gutter. When auto scaling enabled, measured in DIP.
Public property | WidthInPixels | Gets the width of the gutter in pixels.
Public property | WrapImageIndex | Gets or sets a value that specifies index of item in the image collection used to paint special mark indicating the wrapped line.
Top
Events
 | Name | Description
Public event | Click | Occurs when the Gutter clicked.
Public event | DoubleClick | Occurs when the Gutter double-clicked.
Public event | DrawUserMargin | Occurs when user margin part of each line is drawing.
Top
See Also

Reference

Alternet.Editor Namespace


Gutter Constructor

Gutter Constructor
Overload List
 | Name | Description
Public method | Gutter | Initializes a new instance of the Gutter class with default settings.
Public method | Gutter(ISyntaxEdit) | Initializes a new instance of the Gutter class with specified owner.
Top
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter Constructor

Gutter Constructor
Initializes a new instance of the Gutter class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Gutter()
Public Sub New
public:
Gutter()
new : unit -> Gutter
See Also

Reference

Gutter Class
Gutter Overload
Alternet.Editor Namespace


Gutter Constructor (ISyntaxEdit)

Gutter Constructor (ISyntaxEdit)
Initializes a new instance of the Gutter class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Gutter(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
Gutter(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> Gutter

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

Gutter Class
Gutter Overload
Alternet.Editor Namespace


Gutter Methods

Gutter Methods

The Gutter type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents from another IGutter object.
Public method | BeginUpdate | Prevents gutter updating until calling Gutter.EndUpdate method.
Public method | DisableUpdate | Prevents gutter updating until calling Gutter.EndUpdate method.
Public method | Dispose | Disposes this Gutter and frees resources associated with it.
Public method | EnableUpdate | Re-enables gutter updating, that was turn of by calling Gutter.BeginUpdate method.
Public method | EndUpdate | Re-enables gutter updating, that was turn of by calling Gutter.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHitTest | Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method | GetImage | When implemented by a class, gets image from the images collection
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvalidateLineNumberArea | Invalidates line number area if it needs to be altered. Specifies whether line number width needs to be recalculated.
Public method | IsMouseOnOutlineButton | Indicates whether mouse point is within the outline button area.
Public method | OnClick | Raises the Click event.
Public method | OnDoubleClick | Raises the DoubleClick event.
Public method | Paint(IPainter, Rectangle) | Draws gutter on the specified graphic surface.
Public method | Paint(IPainter, Rectangle, Int32) | Draws gutter on the specified graphic surface.
Public method | ResetBookMarkImageIndex | Resets the BookMarkImageIndex to the default value.
Public method | ResetBrushColor | Resets the BrushColor to the default value.
Public method | ResetBulbImageIndex | Resets the BulbImageIndex to the default value.
Public method | ResetDrawLineBookmarks | Resets the DrawLineBookmarks to the default value.
Public method | ResetHighlightBlockAreaColor | Resets the HighlightBlockAreaColor to the default value.
Public method | ResetHighlightOutlineAreaColor | Resets the HighlightOutlineAreaColor to the default value.
Public method | ResetLineBookmarksColor | Resets the LineBookmarksColor to the default value.
Public method | ResetLineModificatorChangedColor | Resets the LineModificatorChangedColor to the default value.
Public method | ResetLineModificatorSavedColor | Resets the LineModificatorSavedColor to the default value.
Public method | ResetLineNumbersAlignment | Resets the LineNumbersAlignment to the default value.
Public method | ResetLineNumbersBackColor | Resets the LineNumbersBackColor to the default value.
Public method | ResetLineNumbersForeColor | Resets the LineNumbersForeColor to the default value.
Public method | ResetLineNumbersLeftIndent | Resets the LineNumbersLeftIndent to the default value.
Public method | ResetLineNumbersRightIndent | Resets the LineNumbersRightIndent to the default value.
Public method | ResetLineNumbersStart | Resets the LineNumbersStart to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetOutlineImageBackColor | Resets the OutlineImageBackColor to the default value.
Public method | ResetOutliningLeftIndent | Resets the OutliningLeftIndent to the default value.
Public method | ResetOutliningRightIndent | Resets the OutliningRightIndent to the default value.
Public method | ResetPenColor | Resets the PenColor to the default value.
Public method | ResetShowBookmarkHints | Resets the ShowBookmarkHints to the default value.
Public method | ResetUserMarginBackColor | Resets the UserMarginBackColor to the default value.
Public method | ResetUserMarginForeColor | Resets the UserMarginForeColor to the default value.
Public method | ResetUserMarginText | Resets the UserMarginText to the default value.
Public method | ResetUserMarginWidth | Resets the UserMarginWidth to the default value.
Public method | ResetVisible | Resets the Visible to the default value.
Public method | ResetWidth | Resets the Width to the default value.
Public method | ResetWrapImageIndex | Resets the WrapImageIndex to the default value.
Public method | ShouldSerializeBookMarkImageIndex | Indicates whether the BookMarkImageIndex property should be persisted.
Public method | ShouldSerializeBrushColor | Indicates whether the BrushColor property should be persisted.
Public method | ShouldSerializeBulbImageIndex | Indicates whether the BulbImageIndex property should be persisted.
Public method | ShouldSerializeHighlightBlockAreaColor | Indicates whether the HighlightBlockAreaColor property should be persisted.
Public method | ShouldSerializeHighlightOutlineAreaColor | Indicates whether the HighlightOutlineAreaColor property should be persisted.
Public method | ShouldSerializeLineBookmarksColor | Indicates whether the LineBookmarksColor property should be persisted.
Public method | ShouldSerializeLineModificatorChangedColor | Indicates whether the LineModificatorChangedColor property should be persisted.
Public method | ShouldSerializeLineModificatorSavedColor | Indicates whether the LineModificatorSavedColor property should be persisted.
Public method | ShouldSerializeLineNumbersBackColor | Indicates whether the LineNumbersBackColor property should be persisted.
Public method | ShouldSerializeLineNumbersForeColor | Indicates whether the LineNumbersForeColor property should be persisted.
Public method | ShouldSerializeLineNumbersLeftIndent | Indicates whether the LineNumbersLeftIndent property should be persisted.
Public method | ShouldSerializeLineNumbersRightIndent | Indicates whether the LineNumbersRightIndent property should be persisted.
Public method | ShouldSerializeLineNumbersStart | Indicates whether the LineNumbersStart property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | ShouldSerializeOutlineImageBackColor | Indicates whether the OutlineImageBackColor property should be persisted.
Public method | ShouldSerializeOutliningLeftIndent | Indicates whether the OutliningLeftIndent property should be persisted.
Public method | ShouldSerializeOutliningRightIndent | Indicates whether the OutliningRightIndent property should be persisted.
Public method | ShouldSerializePenColor | Indicates whether the PenColor property should be persisted.
Public method | ShouldSerializeUserMarginBackColor | Indicates whether the UserMarginBackColor property should be persisted.
Public method | ShouldSerializeUserMarginForeColor | Indicates whether the UserMarginForeColor property should be persisted.
Public method | ShouldSerializeUserMarginText | Indicates whether the UserMarginText property should be persisted.
Public method | ShouldSerializeUserMarginWidth | Indicates whether the UserMarginWidth property should be persisted.
Public method | ShouldSerializeWidth | Indicates whether the Width property should be persisted.
Public method | ShouldSerializeWrapImageIndex | Indicates whether the WrapImageIndex property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Causes the edit control to invalidate it's content.
Public method | Update(Boolean) | Causes the edit control to invalidate it's content.
Top
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Assign Method

GutterAssign Method
Copies the contents from another IGutter object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IGutter source
)
Public Overridable Sub Assign (
    source As IGutter
)
public:
virtual void Assign(
    IGutter^ source
)
abstract Assign :
        source : IGutter -> unit
override Assign :
        source : IGutter -> unit

Parameters

source
Type: Alternet.EditorIGutter
Specifies IGutter to assign.

Implements

IGutterAssign(IGutter)
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.BeginUpdate Method

GutterBeginUpdate Method
Prevents gutter updating until calling Gutter.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of gutter updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.DisableUpdate Method

GutterDisableUpdate Method
Prevents gutter updating until calling Gutter.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Dispose Method

GutterDispose Method
Disposes this Gutter and frees resources associated with it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.EnableUpdate Method

GutterEnableUpdate Method
Re-enables gutter updating, that was turn of by calling Gutter.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of gutter updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.EndUpdate Method

GutterEndUpdate Method
Re-enables gutter updating, that was turn of by calling Gutter.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of gutter updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.GetHitTest Method

GutterGetHitTest Method
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GetHitTest(
    int x,
    int y,
    IHitTestInfo hitTestInfo
)
Public Overridable Sub GetHitTest (
    x As Integer,
    y As Integer,
    hitTestInfo As IHitTestInfo
)
public:
virtual void GetHitTest(
    int x,
    int y,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTest :
        x : int *
        y : int *
        hitTestInfo : IHitTestInfo -> unit
override GetHitTest :
        x : int *
        y : int *
        hitTestInfo : IHitTestInfo -> unit

Parameters

x
Type: SystemInt32
Specifies horizontal coordinate of position to check.
y
Type: SystemInt32
Specifies vertical coordinate of position to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.

Implements

IGutterGetHitTest(Int32, Int32, IHitTestInfo)
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.GetImage Method

GutterGetImage Method
When implemented by a class, gets image from the images collection

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Image GetImage(
    int index
)
Public Overridable Function GetImage (
    index As Integer
) As Image
public:
virtual Image^ GetImage(
    int index
)
abstract GetImage :
        index : int -> Image
override GetImage :
        index : int -> Image

Parameters

index
Type: SystemInt32
Image index

Return Value

Type: Image
Image at given index.

Implements

IGutterGetImage(Int32)
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.InvalidateLineNumberArea Method

GutterInvalidateLineNumberArea Method
Invalidates line number area if it needs to be altered. Specifies whether line number width needs to be recalculated.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InvalidateLineNumberArea(
    bool updateWidth
)
Public Overridable Function InvalidateLineNumberArea (
    updateWidth As Boolean
) As Boolean
public:
virtual bool InvalidateLineNumberArea(
    bool updateWidth
)
abstract InvalidateLineNumberArea :
        updateWidth : bool -> bool
override InvalidateLineNumberArea :
        updateWidth : bool -> bool

Parameters

updateWidth
Type: SystemBoolean

Return Value

Type: Boolean

Implements

IGutterInvalidateLineNumberArea(Boolean)
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.IsMouseOnOutlineButton Method

GutterIsMouseOnOutlineButton Method
Indicates whether mouse point is within the outline button area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsMouseOnOutlineButton(
    int x,
    int y,
    out IOutlineRange range
)
Public Overridable Function IsMouseOnOutlineButton (
    x As Integer,
    y As Integer,
    <OutAttribute> ByRef range As IOutlineRange
) As Boolean
public:
virtual bool IsMouseOnOutlineButton(
    int x,
    int y,
    [OutAttribute] IOutlineRange^% range
)
abstract IsMouseOnOutlineButton :
        x : int *
        y : int *
        range : IOutlineRange byref -> bool
override IsMouseOnOutlineButton :
        x : int *
        y : int *
        range : IOutlineRange byref -> bool

Parameters

x
Type: SystemInt32
X-coordinate of the mouse pointer.
y
Type: SystemInt32
Y-coordinate of the mouse pointer.
range
Type: Alternet.SyntaxIOutlineRange
Retrieves IOutlineRange under mouse pointer.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.OnClick Method

GutterOnClick Method
Raises the Click event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnClick(
    EventArgs e
)
Public Overridable Sub OnClick (
    e As EventArgs
)
public:
virtual void OnClick(
    EventArgs^ e
)
abstract OnClick :
        e : EventArgs -> unit
override OnClick :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
The EventArgs that contains data to this event.

Implements

IGutterOnClick(EventArgs)
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.OnDoubleClick Method

GutterOnDoubleClick Method
Raises the DoubleClick event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnDoubleClick(
    EventArgs e
)
Public Overridable Sub OnDoubleClick (
    e As EventArgs
)
public:
virtual void OnDoubleClick(
    EventArgs^ e
)
abstract OnDoubleClick :
        e : EventArgs -> unit
override OnDoubleClick :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
The EventArgs that contains data to this event.

Implements

IGutterOnDoubleClick(EventArgs)
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Paint Method

GutterPaint Method
Overload List
 | Name | Description
Public method | Paint(IPainter, Rectangle) | Draws gutter on the specified graphic surface.
Public method | Paint(IPainter, Rectangle, Int32) | Draws gutter on the specified graphic surface.
Top
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Paint Method (IPainter, Rectangle)

GutterPaint Method (IPainter, Rectangle)
Draws gutter on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Paint(
    IPainter painter,
    Rectangle rect
)
Public Overridable Sub Paint (
    painter As IPainter,
    rect As Rectangle
)
public:
virtual void Paint(
    IPainter^ painter,
    Rectangle rect
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle -> unit
override Paint :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of gutter to draw.

Implements

IGutterPaint(IPainter, Rectangle)
See Also

Reference

Gutter Class
Paint Overload
Alternet.Editor Namespace


Gutter.Paint Method (IPainter, Rectangle, Int32)

GutterPaint Method (IPainter, Rectangle, Int32)
Draws gutter on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Paint(
    IPainter painter,
    Rectangle rect,
    int startLine
)
Public Overridable Sub Paint (
    painter As IPainter,
    rect As Rectangle,
    startLine As Integer
)
public:
virtual void Paint(
    IPainter^ painter,
    Rectangle rect,
    int startLine
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle *
        startLine : int -> unit
override Paint :
        painter : IPainter *
        rect : Rectangle *
        startLine : int -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of gutter to draw.
startLine
Type: SystemInt32
The first display line to draw.

Implements

IGutterPaint(IPainter, Rectangle, Int32)
See Also

Reference

Gutter Class
Paint Overload
Alternet.Editor Namespace


Gutter.ResetBookMarkImageIndex Method

GutterResetBookMarkImageIndex Method
Resets the BookMarkImageIndex to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBookMarkImageIndex()
Public Overridable Sub ResetBookMarkImageIndex
public:
virtual void ResetBookMarkImageIndex()
abstract ResetBookMarkImageIndex : unit -> unit
override ResetBookMarkImageIndex : unit -> unit

Implements

IGutterResetBookMarkImageIndex
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetBrushColor Method

GutterResetBrushColor Method
Resets the BrushColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBrushColor()
Public Overridable Sub ResetBrushColor
public:
virtual void ResetBrushColor()
abstract ResetBrushColor : unit -> unit
override ResetBrushColor : unit -> unit

Implements

IGutterResetBrushColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetBulbImageIndex Method

GutterResetBulbImageIndex Method
Resets the BulbImageIndex to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBulbImageIndex()
Public Overridable Sub ResetBulbImageIndex
public:
virtual void ResetBulbImageIndex()
abstract ResetBulbImageIndex : unit -> unit
override ResetBulbImageIndex : unit -> unit
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetDrawLineBookmarks Method

GutterResetDrawLineBookmarks Method
Resets the DrawLineBookmarks to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDrawLineBookmarks()
Public Overridable Sub ResetDrawLineBookmarks
public:
virtual void ResetDrawLineBookmarks()
abstract ResetDrawLineBookmarks : unit -> unit
override ResetDrawLineBookmarks : unit -> unit

Implements

IGutterResetDrawLineBookmarks
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetHighlightBlockAreaColor Method

GutterResetHighlightBlockAreaColor Method
Resets the HighlightBlockAreaColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetHighlightBlockAreaColor()
Public Overridable Sub ResetHighlightBlockAreaColor
public:
virtual void ResetHighlightBlockAreaColor()
abstract ResetHighlightBlockAreaColor : unit -> unit
override ResetHighlightBlockAreaColor : unit -> unit
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetHighlightOutlineAreaColor Method

GutterResetHighlightOutlineAreaColor Method
Resets the HighlightOutlineAreaColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetHighlightOutlineAreaColor()
Public Overridable Sub ResetHighlightOutlineAreaColor
public:
virtual void ResetHighlightOutlineAreaColor()
abstract ResetHighlightOutlineAreaColor : unit -> unit
override ResetHighlightOutlineAreaColor : unit -> unit

Implements

IGutterResetHighlightOutlineAreaColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetLineBookmarksColor Method

GutterResetLineBookmarksColor Method
Resets the LineBookmarksColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineBookmarksColor()
Public Overridable Sub ResetLineBookmarksColor
public:
virtual void ResetLineBookmarksColor()
abstract ResetLineBookmarksColor : unit -> unit
override ResetLineBookmarksColor : unit -> unit

Implements

IGutterResetLineBookmarksColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetLineModificatorChangedColor Method

GutterResetLineModificatorChangedColor Method
Resets the LineModificatorChangedColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineModificatorChangedColor()
Public Overridable Sub ResetLineModificatorChangedColor
public:
virtual void ResetLineModificatorChangedColor()
abstract ResetLineModificatorChangedColor : unit -> unit
override ResetLineModificatorChangedColor : unit -> unit

Implements

IGutterResetLineModificatorChangedColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetLineModificatorSavedColor Method

GutterResetLineModificatorSavedColor Method
Resets the LineModificatorSavedColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineModificatorSavedColor()
Public Overridable Sub ResetLineModificatorSavedColor
public:
virtual void ResetLineModificatorSavedColor()
abstract ResetLineModificatorSavedColor : unit -> unit
override ResetLineModificatorSavedColor : unit -> unit

Implements

IGutterResetLineModificatorSavedColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetLineNumbersAlignment Method

GutterResetLineNumbersAlignment Method
Resets the LineNumbersAlignment to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineNumbersAlignment()
Public Overridable Sub ResetLineNumbersAlignment
public:
virtual void ResetLineNumbersAlignment()
abstract ResetLineNumbersAlignment : unit -> unit
override ResetLineNumbersAlignment : unit -> unit

Implements

IGutterResetLineNumbersAlignment
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetLineNumbersBackColor Method

GutterResetLineNumbersBackColor Method
Resets the LineNumbersBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineNumbersBackColor()
Public Overridable Sub ResetLineNumbersBackColor
public:
virtual void ResetLineNumbersBackColor()
abstract ResetLineNumbersBackColor : unit -> unit
override ResetLineNumbersBackColor : unit -> unit

Implements

IGutterResetLineNumbersBackColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetLineNumbersForeColor Method

GutterResetLineNumbersForeColor Method
Resets the LineNumbersForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineNumbersForeColor()
Public Overridable Sub ResetLineNumbersForeColor
public:
virtual void ResetLineNumbersForeColor()
abstract ResetLineNumbersForeColor : unit -> unit
override ResetLineNumbersForeColor : unit -> unit

Implements

IGutterResetLineNumbersForeColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetLineNumbersLeftIndent Method

GutterResetLineNumbersLeftIndent Method
Resets the LineNumbersLeftIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineNumbersLeftIndent()
Public Overridable Sub ResetLineNumbersLeftIndent
public:
virtual void ResetLineNumbersLeftIndent()
abstract ResetLineNumbersLeftIndent : unit -> unit
override ResetLineNumbersLeftIndent : unit -> unit

Implements

IGutterResetLineNumbersLeftIndent
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetLineNumbersRightIndent Method

GutterResetLineNumbersRightIndent Method
Resets the LineNumbersRightIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineNumbersRightIndent()
Public Overridable Sub ResetLineNumbersRightIndent
public:
virtual void ResetLineNumbersRightIndent()
abstract ResetLineNumbersRightIndent : unit -> unit
override ResetLineNumbersRightIndent : unit -> unit

Implements

IGutterResetLineNumbersRightIndent
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetLineNumbersStart Method

GutterResetLineNumbersStart Method
Resets the LineNumbersStart to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineNumbersStart()
Public Overridable Sub ResetLineNumbersStart
public:
virtual void ResetLineNumbersStart()
abstract ResetLineNumbersStart : unit -> unit
override ResetLineNumbersStart : unit -> unit

Implements

IGutterResetLineNumbersStart
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetOptions Method

GutterResetOptions Method
Resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOptions()
Public Overridable Sub ResetOptions
public:
virtual void ResetOptions()
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

IGutterResetOptions
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetOutlineImageBackColor Method

GutterResetOutlineImageBackColor Method
Resets the OutlineImageBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOutlineImageBackColor()
Public Overridable Sub ResetOutlineImageBackColor
public:
virtual void ResetOutlineImageBackColor()
abstract ResetOutlineImageBackColor : unit -> unit
override ResetOutlineImageBackColor : unit -> unit

Implements

IGutterResetOutlineImageBackColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetOutliningLeftIndent Method

GutterResetOutliningLeftIndent Method
Resets the OutliningLeftIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOutliningLeftIndent()
Public Overridable Sub ResetOutliningLeftIndent
public:
virtual void ResetOutliningLeftIndent()
abstract ResetOutliningLeftIndent : unit -> unit
override ResetOutliningLeftIndent : unit -> unit

Implements

IGutterResetOutliningLeftIndent
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetOutliningRightIndent Method

GutterResetOutliningRightIndent Method
Resets the OutliningRightIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOutliningRightIndent()
Public Overridable Sub ResetOutliningRightIndent
public:
virtual void ResetOutliningRightIndent()
abstract ResetOutliningRightIndent : unit -> unit
override ResetOutliningRightIndent : unit -> unit

Implements

IGutterResetOutliningRightIndent
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetPenColor Method

GutterResetPenColor Method
Resets the PenColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetPenColor()
Public Overridable Sub ResetPenColor
public:
virtual void ResetPenColor()
abstract ResetPenColor : unit -> unit
override ResetPenColor : unit -> unit

Implements

IGutterResetPenColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetShowBookmarkHints Method

GutterResetShowBookmarkHints Method
Resets the ShowBookmarkHints to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetShowBookmarkHints()
Public Overridable Sub ResetShowBookmarkHints
public:
virtual void ResetShowBookmarkHints()
abstract ResetShowBookmarkHints : unit -> unit
override ResetShowBookmarkHints : unit -> unit

Implements

IGutterResetShowBookmarkHints
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetUserMarginBackColor Method

GutterResetUserMarginBackColor Method
Resets the UserMarginBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUserMarginBackColor()
Public Overridable Sub ResetUserMarginBackColor
public:
virtual void ResetUserMarginBackColor()
abstract ResetUserMarginBackColor : unit -> unit
override ResetUserMarginBackColor : unit -> unit

Implements

IGutterResetUserMarginBackColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetUserMarginForeColor Method

GutterResetUserMarginForeColor Method
Resets the UserMarginForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUserMarginForeColor()
Public Overridable Sub ResetUserMarginForeColor
public:
virtual void ResetUserMarginForeColor()
abstract ResetUserMarginForeColor : unit -> unit
override ResetUserMarginForeColor : unit -> unit

Implements

IGutterResetUserMarginForeColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetUserMarginText Method

GutterResetUserMarginText Method
Resets the UserMarginText to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUserMarginText()
Public Overridable Sub ResetUserMarginText
public:
virtual void ResetUserMarginText()
abstract ResetUserMarginText : unit -> unit
override ResetUserMarginText : unit -> unit

Implements

IGutterResetUserMarginText
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetUserMarginWidth Method

GutterResetUserMarginWidth Method
Resets the UserMarginWidth to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUserMarginWidth()
Public Overridable Sub ResetUserMarginWidth
public:
virtual void ResetUserMarginWidth()
abstract ResetUserMarginWidth : unit -> unit
override ResetUserMarginWidth : unit -> unit

Implements

IGutterResetUserMarginWidth
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetVisible Method

GutterResetVisible Method
Resets the Visible to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetVisible()
Public Overridable Sub ResetVisible
public:
virtual void ResetVisible()
abstract ResetVisible : unit -> unit
override ResetVisible : unit -> unit

Implements

IGutterResetVisible
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetWidth Method

GutterResetWidth Method
Resets the Width to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetWidth()
Public Overridable Sub ResetWidth
public:
virtual void ResetWidth()
abstract ResetWidth : unit -> unit
override ResetWidth : unit -> unit

Implements

IGutterResetWidth
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ResetWrapImageIndex Method

GutterResetWrapImageIndex Method
Resets the WrapImageIndex to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetWrapImageIndex()
Public Overridable Sub ResetWrapImageIndex
public:
virtual void ResetWrapImageIndex()
abstract ResetWrapImageIndex : unit -> unit
override ResetWrapImageIndex : unit -> unit

Implements

IGutterResetWrapImageIndex
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeBookMarkImageIndex Method

GutterShouldSerializeBookMarkImageIndex Method
Indicates whether the BookMarkImageIndex property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBookMarkImageIndex()
Public Function ShouldSerializeBookMarkImageIndex As Boolean
public:
bool ShouldSerializeBookMarkImageIndex()
member ShouldSerializeBookMarkImageIndex : unit -> bool

Return Value

Type: Boolean
True if BookMarkImageIndex differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeBrushColor Method

GutterShouldSerializeBrushColor Method
Indicates whether the BrushColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBrushColor()
Public Function ShouldSerializeBrushColor As Boolean
public:
bool ShouldSerializeBrushColor()
member ShouldSerializeBrushColor : unit -> bool

Return Value

Type: Boolean
True if BrushColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeBulbImageIndex Method

GutterShouldSerializeBulbImageIndex Method
Indicates whether the BulbImageIndex property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBulbImageIndex()
Public Function ShouldSerializeBulbImageIndex As Boolean
public:
bool ShouldSerializeBulbImageIndex()
member ShouldSerializeBulbImageIndex : unit -> bool

Return Value

Type: Boolean
True if BulbImageIndex differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeHighlightBlockAreaColor Method

GutterShouldSerializeHighlightBlockAreaColor Method
Indicates whether the HighlightBlockAreaColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeHighlightBlockAreaColor()
Public Overridable Function ShouldSerializeHighlightBlockAreaColor As Boolean
public:
virtual bool ShouldSerializeHighlightBlockAreaColor()
abstract ShouldSerializeHighlightBlockAreaColor : unit -> bool
override ShouldSerializeHighlightBlockAreaColor : unit -> bool

Return Value

Type: Boolean
True if HighlightBlockAreaColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeHighlightOutlineAreaColor Method

GutterShouldSerializeHighlightOutlineAreaColor Method
Indicates whether the HighlightOutlineAreaColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeHighlightOutlineAreaColor()
Public Overridable Function ShouldSerializeHighlightOutlineAreaColor As Boolean
public:
virtual bool ShouldSerializeHighlightOutlineAreaColor()
abstract ShouldSerializeHighlightOutlineAreaColor : unit -> bool
override ShouldSerializeHighlightOutlineAreaColor : unit -> bool

Return Value

Type: Boolean
True if HighlightOutlineAreaColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeLineBookmarksColor Method

GutterShouldSerializeLineBookmarksColor Method
Indicates whether the LineBookmarksColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLineBookmarksColor()
Public Function ShouldSerializeLineBookmarksColor As Boolean
public:
bool ShouldSerializeLineBookmarksColor()
member ShouldSerializeLineBookmarksColor : unit -> bool

Return Value

Type: Boolean
True if LineBookmarksColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeLineModificatorChangedColor Method

GutterShouldSerializeLineModificatorChangedColor Method
Indicates whether the LineModificatorChangedColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLineModificatorChangedColor()
Public Function ShouldSerializeLineModificatorChangedColor As Boolean
public:
bool ShouldSerializeLineModificatorChangedColor()
member ShouldSerializeLineModificatorChangedColor : unit -> bool

Return Value

Type: Boolean
True if LineModificatorChangedColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeLineModificatorSavedColor Method

GutterShouldSerializeLineModificatorSavedColor Method
Indicates whether the LineModificatorSavedColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeLineModificatorSavedColor()
Public Overridable Function ShouldSerializeLineModificatorSavedColor As Boolean
public:
virtual bool ShouldSerializeLineModificatorSavedColor()
abstract ShouldSerializeLineModificatorSavedColor : unit -> bool
override ShouldSerializeLineModificatorSavedColor : unit -> bool

Return Value

Type: Boolean
True if LineModificatorSavedColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeLineNumbersBackColor Method

GutterShouldSerializeLineNumbersBackColor Method
Indicates whether the LineNumbersBackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLineNumbersBackColor()
Public Function ShouldSerializeLineNumbersBackColor As Boolean
public:
bool ShouldSerializeLineNumbersBackColor()
member ShouldSerializeLineNumbersBackColor : unit -> bool

Return Value

Type: Boolean
True if LineNumbersBackColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeLineNumbersForeColor Method

GutterShouldSerializeLineNumbersForeColor Method
Indicates whether the LineNumbersForeColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLineNumbersForeColor()
Public Function ShouldSerializeLineNumbersForeColor As Boolean
public:
bool ShouldSerializeLineNumbersForeColor()
member ShouldSerializeLineNumbersForeColor : unit -> bool

Return Value

Type: Boolean
True if LineNumbersForeColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeLineNumbersLeftIndent Method

GutterShouldSerializeLineNumbersLeftIndent Method
Indicates whether the LineNumbersLeftIndent property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLineNumbersLeftIndent()
Public Function ShouldSerializeLineNumbersLeftIndent As Boolean
public:
bool ShouldSerializeLineNumbersLeftIndent()
member ShouldSerializeLineNumbersLeftIndent : unit -> bool

Return Value

Type: Boolean
True if LineNumbersLeftIndent differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeLineNumbersRightIndent Method

GutterShouldSerializeLineNumbersRightIndent Method
Indicates whether the LineNumbersRightIndent property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLineNumbersRightIndent()
Public Function ShouldSerializeLineNumbersRightIndent As Boolean
public:
bool ShouldSerializeLineNumbersRightIndent()
member ShouldSerializeLineNumbersRightIndent : unit -> bool

Return Value

Type: Boolean
True if LineNumbersRightIndent differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeLineNumbersStart Method

GutterShouldSerializeLineNumbersStart Method
Indicates whether the LineNumbersStart property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLineNumbersStart()
Public Function ShouldSerializeLineNumbersStart As Boolean
public:
bool ShouldSerializeLineNumbersStart()
member ShouldSerializeLineNumbersStart : unit -> bool

Return Value

Type: Boolean
True if LineNumbersStart differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeOptions Method

GutterShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOptions()
Public Function ShouldSerializeOptions As Boolean
public:
bool ShouldSerializeOptions()
member ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeOutlineImageBackColor Method

GutterShouldSerializeOutlineImageBackColor Method
Indicates whether the OutlineImageBackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeOutlineImageBackColor()
Public Overridable Function ShouldSerializeOutlineImageBackColor As Boolean
public:
virtual bool ShouldSerializeOutlineImageBackColor()
abstract ShouldSerializeOutlineImageBackColor : unit -> bool
override ShouldSerializeOutlineImageBackColor : unit -> bool

Return Value

Type: Boolean
True if OutlineImageBackColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeOutliningLeftIndent Method

GutterShouldSerializeOutliningLeftIndent Method
Indicates whether the OutliningLeftIndent property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOutliningLeftIndent()
Public Function ShouldSerializeOutliningLeftIndent As Boolean
public:
bool ShouldSerializeOutliningLeftIndent()
member ShouldSerializeOutliningLeftIndent : unit -> bool

Return Value

Type: Boolean
True if OutliningLeftIndent differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeOutliningRightIndent Method

GutterShouldSerializeOutliningRightIndent Method
Indicates whether the OutliningRightIndent property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOutliningRightIndent()
Public Function ShouldSerializeOutliningRightIndent As Boolean
public:
bool ShouldSerializeOutliningRightIndent()
member ShouldSerializeOutliningRightIndent : unit -> bool

Return Value

Type: Boolean
True if OutliningRightIndent differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializePenColor Method

GutterShouldSerializePenColor Method
Indicates whether the PenColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePenColor()
Public Function ShouldSerializePenColor As Boolean
public:
bool ShouldSerializePenColor()
member ShouldSerializePenColor : unit -> bool

Return Value

Type: Boolean
True if PenColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeUserMarginBackColor Method

GutterShouldSerializeUserMarginBackColor Method
Indicates whether the UserMarginBackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeUserMarginBackColor()
Public Function ShouldSerializeUserMarginBackColor As Boolean
public:
bool ShouldSerializeUserMarginBackColor()
member ShouldSerializeUserMarginBackColor : unit -> bool

Return Value

Type: Boolean
True if UserMarginBackColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeUserMarginForeColor Method

GutterShouldSerializeUserMarginForeColor Method
Indicates whether the UserMarginForeColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeUserMarginForeColor()
Public Function ShouldSerializeUserMarginForeColor As Boolean
public:
bool ShouldSerializeUserMarginForeColor()
member ShouldSerializeUserMarginForeColor : unit -> bool

Return Value

Type: Boolean
True if UserMarginBackColor differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeUserMarginText Method

GutterShouldSerializeUserMarginText Method
Indicates whether the UserMarginText property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeUserMarginText()
Public Function ShouldSerializeUserMarginText As Boolean
public:
bool ShouldSerializeUserMarginText()
member ShouldSerializeUserMarginText : unit -> bool

Return Value

Type: Boolean
True if UserMarginText differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeUserMarginWidth Method

GutterShouldSerializeUserMarginWidth Method
Indicates whether the UserMarginWidth property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeUserMarginWidth()
Public Function ShouldSerializeUserMarginWidth As Boolean
public:
bool ShouldSerializeUserMarginWidth()
member ShouldSerializeUserMarginWidth : unit -> bool

Return Value

Type: Boolean
True if UserMarginWidth differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeWidth Method

GutterShouldSerializeWidth Method
Indicates whether the Width property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeWidth()
Public Function ShouldSerializeWidth As Boolean
public:
bool ShouldSerializeWidth()
member ShouldSerializeWidth : unit -> bool

Return Value

Type: Boolean
True if Width differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShouldSerializeWrapImageIndex Method

GutterShouldSerializeWrapImageIndex Method
Indicates whether the WrapImageIndex property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeWrapImageIndex()
Public Function ShouldSerializeWrapImageIndex As Boolean
public:
bool ShouldSerializeWrapImageIndex()
member ShouldSerializeWrapImageIndex : unit -> bool

Return Value

Type: Boolean
True if WrapImageIndex differs from its default value; otherwise false.
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Update Method

GutterUpdate Method
Overload List
 | Name | Description
Public method | Update | Causes the edit control to invalidate it's content.
Public method | Update(Boolean) | Causes the edit control to invalidate it's content.
Top
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Update Method

GutterUpdate Method
Causes the edit control to invalidate it's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
virtual void Update() sealed
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

Gutter Class
Update Overload
Alternet.Editor Namespace


Gutter.Update Method (Boolean)

GutterUpdate Method (Boolean)
Causes the edit control to invalidate it's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update(
    bool needChange
)
Public Sub Update (
    needChange As Boolean
)
public:
void Update(
    bool needChange
)
member Update :
        needChange : bool -> unit

Parameters

needChange
Type: SystemBoolean
Specifies whether ISyntaxEdit control should invalidate it's content.
See Also

Reference

Gutter Class
Update Overload
Alternet.Editor Namespace


Gutter Properties

Gutter Properties

The Gutter type exposes the following members.

Properties
 | Name | Description
Public property | BookMarkImageIndex | Gets or sets a value that specifies index of item in the image collection used to paint bookmark.
Public property | Brush | Gets or sets a Brush object used to paint gutter.
Public property | BrushColor | Gets or sets background color of the gutter.
Public property | BulbImageIndex | Gets or sets a value that specifies index of item in the image collection used to paint light bulb.
Public property | DisplayArea | Gets display width of the gutter, including line numbers and outlining area, but not including line modificators if they're painted outside gutter.
Public property | DisplayWidth | Gets display width of the gutter, including line numbers and outlining area.
Public property | DrawLineBookmarks | Gets or sets a value indicating whether Edit control should draw triangle at bookmark position inside line.
Public property | HighlightBlockAreaColor | Gets or sets a background color of the highlighted block area.
Public property | HighlightOutlineAreaColor | Gets or sets a background color of the highlighted outline area.
Public property | Images | Gets or sets an ImageList object that contains collection of images for gutter.
Public property | ImagesHighDpi | Gets or sets an ImageList object that contains collection of images for gutter for high DPI.
Public property | ImagesResourceNameSuffix |
Public property | LineBookmarksColor | Gets or sets a color of the line bookmarks.
Public property | LineModificatorChangedColor | Gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the modified state.
Public property | LineModificatorSavedColor | Gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the saved state.
Public property | LineNumbersAlignment | Gets or sets line numbers alignment information.
Public property | LineNumbersBackColor | Gets or sets background color for the line numbers.
Public property | LineNumbersForeColor | Gets or sets foreground color for the line numbers.
Public property | LineNumbersLeftIndent | Gets or sets line numbers indentation from the left gutter border. When auto scaling enabled, measured in DIP.
Public property | LineNumbersLeftIndentInPixels | Gets line numbers indentation from the left gutter border in pixels.
Public property | LineNumbersRightIndent | Gets or sets line numbers indentation from the right gutter border. When auto scaling enabled, measured in DIP.
Public property | LineNumbersRightIndentInPixels | Gets line numbers indentation from the right gutter border in pixels.
Public property | LineNumbersStart | Gets or sets number of the first line being painted on the gutter.
Public property | MaxLineNumberLength | Gets or sets maximum count of numbers in the line number.
Public property | Options | Gets or sets a GutterOptions that determine gutter appearance and behaviour.
Public property | OutlineImageBackColor | Gets or sets an outline image back color.
Public property | OutliningLeftIndent | Gets or sets outlining indentation from the left gutter border. When auto scaling enabled, measured in DIP.
Public property | OutliningLeftIndentInPixels | Gets outlining indentation from the left gutter border in pixels.
Public property | OutliningRightIndent | Gets or sets outlining indentation from the right gutter border. When auto scaling enabled, measured in DIP.
Public property | OutliningRightIndentInPixels | Gets outlining indentation from the right gutter border in pixels.
Public property | Pen | Gets or sets a Pen object used to paint gutter line.
Public property | PenColor | Gets or sets color of the gutter line.
Public property | Rect | Gets the rectangle that represents gutter area.
Public property | ShowBookmarkHints | Gets or sets a value indicating whether Edit control should display text describing bookmark in form of tooltip window when mouse pointer is over the gutter bookmark.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UserMarginBackColor | Gets or sets background color of the user margin.
Public property | UserMarginForeColor | Gets or sets foreground color of the line numbers.
Public property | UserMarginText | Gets or sets text of the user margin.
Public property | UserMarginWidth | Gets or sets the width of the user margin area. When auto scaling enabled, measured in DIP.
Public property | UserMarginWidthInPixels | Gets the width of the user margin area in pixels.
Public property | Visible | Gets or sets a value indicating whether the gutter area is visible.
Public property | Width | Gets or sets the width of the gutter. When auto scaling enabled, measured in DIP.
Public property | WidthInPixels | Gets the width of the gutter in pixels.
Public property | WrapImageIndex | Gets or sets a value that specifies index of item in the image collection used to paint special mark indicating the wrapped line.
Top
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.BookMarkImageIndex Property

GutterBookMarkImageIndex Property
Gets or sets a value that specifies index of item in the image collection used to paint bookmark.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BookMarkImageIndex { get; set; }
Public Overridable Property BookMarkImageIndex As Integer
    Get
    Set
public:
virtual property int BookMarkImageIndex {
    int get ();
    void set (int value);
}
abstract BookMarkImageIndex : int with get, set
override BookMarkImageIndex : int with get, set

Property Value

Type: Int32

Implements

IGutterBookMarkImageIndex
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Brush Property

GutterBrush Property
Gets or sets a Brush object used to paint gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Brush Brush { get; set; }
Public Overridable Property Brush As Brush
    Get
    Set
public:
virtual property Brush^ Brush {
    Brush^ get ();
    void set (Brush^ value);
}
abstract Brush : Brush with get, set
override Brush : Brush with get, set

Property Value

Type: Brush

Implements

IGutterBrush
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.BrushColor Property

GutterBrushColor Property
Gets or sets background color of the gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BrushColor { get; set; }
Public Overridable Property BrushColor As Color
    Get
    Set
public:
virtual property Color BrushColor {
    Color get ();
    void set (Color value);
}
abstract BrushColor : Color with get, set
override BrushColor : Color with get, set

Property Value

Type: Color

Implements

IGutterBrushColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.BulbImageIndex Property

GutterBulbImageIndex Property
Gets or sets a value that specifies index of item in the image collection used to paint light bulb.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BulbImageIndex { get; set; }
Public Overridable Property BulbImageIndex As Integer
    Get
    Set
public:
virtual property int BulbImageIndex {
    int get ();
    void set (int value);
}
abstract BulbImageIndex : int with get, set
override BulbImageIndex : int with get, set

Property Value

Type: Int32

Implements

IGutterBulbImageIndex
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.DisplayArea Property

GutterDisplayArea Property
Gets display width of the gutter, including line numbers and outlining area, but not including line modificators if they're painted outside gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisplayArea { get; }
Public Overridable ReadOnly Property DisplayArea As Integer
    Get
public:
virtual property int DisplayArea {
    int get ();
}
abstract DisplayArea : int with get
override DisplayArea : int with get

Property Value

Type: Int32

Implements

IGutterDisplayArea
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.DisplayWidth Property

GutterDisplayWidth Property
Gets display width of the gutter, including line numbers and outlining area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisplayWidth { get; }
Public Overridable ReadOnly Property DisplayWidth As Integer
    Get
public:
virtual property int DisplayWidth {
    int get ();
}
abstract DisplayWidth : int with get
override DisplayWidth : int with get

Property Value

Type: Int32

Implements

IGutterDisplayWidth
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.DrawLineBookmarks Property

GutterDrawLineBookmarks Property
Gets or sets a value indicating whether Edit control should draw triangle at bookmark position inside line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DrawLineBookmarks { get; set; }
Public Overridable Property DrawLineBookmarks As Boolean
    Get
    Set
public:
virtual property bool DrawLineBookmarks {
    bool get ();
    void set (bool value);
}
abstract DrawLineBookmarks : bool with get, set
override DrawLineBookmarks : bool with get, set

Property Value

Type: Boolean

Implements

IGutterDrawLineBookmarks
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.HighlightBlockAreaColor Property

GutterHighlightBlockAreaColor Property
Gets or sets a background color of the highlighted block area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color HighlightBlockAreaColor { get; set; }
Public Overridable Property HighlightBlockAreaColor As Color
    Get
    Set
public:
virtual property Color HighlightBlockAreaColor {
    Color get ();
    void set (Color value);
}
abstract HighlightBlockAreaColor : Color with get, set
override HighlightBlockAreaColor : Color with get, set

Property Value

Type: Color

Implements

IGutterHighlightBlockAreaColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.HighlightOutlineAreaColor Property

GutterHighlightOutlineAreaColor Property
Gets or sets a background color of the highlighted outline area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color HighlightOutlineAreaColor { get; set; }
Public Overridable Property HighlightOutlineAreaColor As Color
    Get
    Set
public:
virtual property Color HighlightOutlineAreaColor {
    Color get ();
    void set (Color value);
}
abstract HighlightOutlineAreaColor : Color with get, set
override HighlightOutlineAreaColor : Color with get, set

Property Value

Type: Color

Implements

IGutterHighlightOutlineAreaColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Images Property

GutterImages Property
Gets or sets an ImageList object that contains collection of images for gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList Images { get; set; }
Public Overridable Property Images As ImageList
    Get
    Set
public:
virtual property ImageList^ Images {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract Images : ImageList with get, set
override Images : ImageList with get, set

Property Value

Type: ImageList

Implements

IGutterImages
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ImagesHighDpi Property

GutterImagesHighDpi Property
Gets or sets an ImageList object that contains collection of images for gutter for high DPI.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList ImagesHighDpi { get; set; }
Public Overridable Property ImagesHighDpi As ImageList
    Get
    Set
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract ImagesHighDpi : ImageList with get, set
override ImagesHighDpi : ImageList with get, set

Property Value

Type: ImageList

Implements

IGutterImagesHighDpi
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ImagesResourceNameSuffix Property

GutterImagesResourceNameSuffix Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ImagesResourceNameSuffix { get; set; }
Public Property ImagesResourceNameSuffix As String
    Get
    Set
public:
virtual property String^ ImagesResourceNameSuffix {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ImagesResourceNameSuffix : string with get, set
override ImagesResourceNameSuffix : string with get, set

Property Value

Type: String

Implements

IGutterImagesResourceNameSuffix
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineBookmarksColor Property

GutterLineBookmarksColor Property
Gets or sets a color of the line bookmarks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color LineBookmarksColor { get; set; }
Public Overridable Property LineBookmarksColor As Color
    Get
    Set
public:
virtual property Color LineBookmarksColor {
    Color get ();
    void set (Color value);
}
abstract LineBookmarksColor : Color with get, set
override LineBookmarksColor : Color with get, set

Property Value

Type: Color

Implements

IGutterLineBookmarksColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineModificatorChangedColor Property

GutterLineModificatorChangedColor Property
Gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the modified state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color LineModificatorChangedColor { get; set; }
Public Overridable Property LineModificatorChangedColor As Color
    Get
    Set
public:
virtual property Color LineModificatorChangedColor {
    Color get ();
    void set (Color value);
}
abstract LineModificatorChangedColor : Color with get, set
override LineModificatorChangedColor : Color with get, set

Property Value

Type: Color

Implements

IGutterLineModificatorChangedColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineModificatorSavedColor Property

GutterLineModificatorSavedColor Property
Gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the saved state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color LineModificatorSavedColor { get; set; }
Public Overridable Property LineModificatorSavedColor As Color
    Get
    Set
public:
virtual property Color LineModificatorSavedColor {
    Color get ();
    void set (Color value);
}
abstract LineModificatorSavedColor : Color with get, set
override LineModificatorSavedColor : Color with get, set

Property Value

Type: Color

Implements

IGutterLineModificatorSavedColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineNumbersAlignment Property

GutterLineNumbersAlignment Property
Gets or sets line numbers alignment information.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual StringAlignment LineNumbersAlignment { get; set; }
Public Overridable Property LineNumbersAlignment As StringAlignment
    Get
    Set
public:
virtual property StringAlignment LineNumbersAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
abstract LineNumbersAlignment : StringAlignment with get, set
override LineNumbersAlignment : StringAlignment with get, set

Property Value

Type: StringAlignment

Implements

IGutterLineNumbersAlignment
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineNumbersBackColor Property

GutterLineNumbersBackColor Property
Gets or sets background color for the line numbers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color LineNumbersBackColor { get; set; }
Public Overridable Property LineNumbersBackColor As Color
    Get
    Set
public:
virtual property Color LineNumbersBackColor {
    Color get ();
    void set (Color value);
}
abstract LineNumbersBackColor : Color with get, set
override LineNumbersBackColor : Color with get, set

Property Value

Type: Color

Implements

IGutterLineNumbersBackColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineNumbersForeColor Property

GutterLineNumbersForeColor Property
Gets or sets foreground color for the line numbers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color LineNumbersForeColor { get; set; }
Public Overridable Property LineNumbersForeColor As Color
    Get
    Set
public:
virtual property Color LineNumbersForeColor {
    Color get ();
    void set (Color value);
}
abstract LineNumbersForeColor : Color with get, set
override LineNumbersForeColor : Color with get, set

Property Value

Type: Color

Implements

IGutterLineNumbersForeColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineNumbersLeftIndent Property

GutterLineNumbersLeftIndent Property
Gets or sets line numbers indentation from the left gutter border. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LineNumbersLeftIndent { get; set; }
Public Overridable Property LineNumbersLeftIndent As Integer
    Get
    Set
public:
virtual property int LineNumbersLeftIndent {
    int get ();
    void set (int value);
}
abstract LineNumbersLeftIndent : int with get, set
override LineNumbersLeftIndent : int with get, set

Property Value

Type: Int32

Implements

IGutterLineNumbersLeftIndent
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineNumbersLeftIndentInPixels Property

GutterLineNumbersLeftIndentInPixels Property
Gets line numbers indentation from the left gutter border in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LineNumbersLeftIndentInPixels { get; }
Public Overridable ReadOnly Property LineNumbersLeftIndentInPixels As Integer
    Get
public:
virtual property int LineNumbersLeftIndentInPixels {
    int get ();
}
abstract LineNumbersLeftIndentInPixels : int with get
override LineNumbersLeftIndentInPixels : int with get

Property Value

Type: Int32

Implements

IGutterLineNumbersLeftIndentInPixels
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineNumbersRightIndent Property

GutterLineNumbersRightIndent Property
Gets or sets line numbers indentation from the right gutter border. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LineNumbersRightIndent { get; set; }
Public Overridable Property LineNumbersRightIndent As Integer
    Get
    Set
public:
virtual property int LineNumbersRightIndent {
    int get ();
    void set (int value);
}
abstract LineNumbersRightIndent : int with get, set
override LineNumbersRightIndent : int with get, set

Property Value

Type: Int32

Implements

IGutterLineNumbersRightIndent
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineNumbersRightIndentInPixels Property

GutterLineNumbersRightIndentInPixels Property
Gets line numbers indentation from the right gutter border in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LineNumbersRightIndentInPixels { get; }
Public Overridable ReadOnly Property LineNumbersRightIndentInPixels As Integer
    Get
public:
virtual property int LineNumbersRightIndentInPixels {
    int get ();
}
abstract LineNumbersRightIndentInPixels : int with get
override LineNumbersRightIndentInPixels : int with get

Property Value

Type: Int32

Implements

IGutterLineNumbersRightIndentInPixels
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.LineNumbersStart Property

GutterLineNumbersStart Property
Gets or sets number of the first line being painted on the gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LineNumbersStart { get; set; }
Public Overridable Property LineNumbersStart As Integer
    Get
    Set
public:
virtual property int LineNumbersStart {
    int get ();
    void set (int value);
}
abstract LineNumbersStart : int with get, set
override LineNumbersStart : int with get, set

Property Value

Type: Int32

Implements

IGutterLineNumbersStart
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.MaxLineNumberLength Property

GutterMaxLineNumberLength Property
Gets or sets maximum count of numbers in the line number.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MaxLineNumberLength { get; set; }
Public Overridable Property MaxLineNumberLength As Integer
    Get
    Set
public:
virtual property int MaxLineNumberLength {
    int get ();
    void set (int value);
}
abstract MaxLineNumberLength : int with get, set
override MaxLineNumberLength : int with get, set

Property Value

Type: Int32

Implements

IGutterMaxLineNumberLength
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Options Property

GutterOptions Property
Gets or sets a GutterOptions that determine gutter appearance and behaviour.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GutterOptions Options { get; set; }
Public Overridable Property Options As GutterOptions
    Get
    Set
public:
virtual property GutterOptions Options {
    GutterOptions get ();
    void set (GutterOptions value);
}
abstract Options : GutterOptions with get, set
override Options : GutterOptions with get, set

Property Value

Type: GutterOptions

Implements

IGutterOptions
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.OutlineImageBackColor Property

GutterOutlineImageBackColor Property
Gets or sets an outline image back color.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color OutlineImageBackColor { get; set; }
Public Overridable Property OutlineImageBackColor As Color
    Get
    Set
public:
virtual property Color OutlineImageBackColor {
    Color get ();
    void set (Color value);
}
abstract OutlineImageBackColor : Color with get, set
override OutlineImageBackColor : Color with get, set

Property Value

Type: Color

Implements

IGutterOutlineImageBackColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.OutliningLeftIndent Property

GutterOutliningLeftIndent Property
Gets or sets outlining indentation from the left gutter border. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int OutliningLeftIndent { get; set; }
Public Overridable Property OutliningLeftIndent As Integer
    Get
    Set
public:
virtual property int OutliningLeftIndent {
    int get ();
    void set (int value);
}
abstract OutliningLeftIndent : int with get, set
override OutliningLeftIndent : int with get, set

Property Value

Type: Int32

Implements

IGutterOutliningLeftIndent
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.OutliningLeftIndentInPixels Property

GutterOutliningLeftIndentInPixels Property
Gets outlining indentation from the left gutter border in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int OutliningLeftIndentInPixels { get; }
Public Overridable ReadOnly Property OutliningLeftIndentInPixels As Integer
    Get
public:
virtual property int OutliningLeftIndentInPixels {
    int get ();
}
abstract OutliningLeftIndentInPixels : int with get
override OutliningLeftIndentInPixels : int with get

Property Value

Type: Int32

Implements

IGutterOutliningLeftIndentInPixels
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.OutliningRightIndent Property

GutterOutliningRightIndent Property
Gets or sets outlining indentation from the right gutter border. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int OutliningRightIndent { get; set; }
Public Overridable Property OutliningRightIndent As Integer
    Get
    Set
public:
virtual property int OutliningRightIndent {
    int get ();
    void set (int value);
}
abstract OutliningRightIndent : int with get, set
override OutliningRightIndent : int with get, set

Property Value

Type: Int32

Implements

IGutterOutliningRightIndent
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.OutliningRightIndentInPixels Property

GutterOutliningRightIndentInPixels Property
Gets outlining indentation from the right gutter border in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int OutliningRightIndentInPixels { get; }
Public Overridable ReadOnly Property OutliningRightIndentInPixels As Integer
    Get
public:
virtual property int OutliningRightIndentInPixels {
    int get ();
}
abstract OutliningRightIndentInPixels : int with get
override OutliningRightIndentInPixels : int with get

Property Value

Type: Int32

Implements

IGutterOutliningRightIndentInPixels
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Pen Property

GutterPen Property
Gets or sets a Pen object used to paint gutter line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Pen Pen { get; set; }
Public Overridable Property Pen As Pen
    Get
    Set
public:
virtual property Pen^ Pen {
    Pen^ get ();
    void set (Pen^ value);
}
abstract Pen : Pen with get, set
override Pen : Pen with get, set

Property Value

Type: Pen

Implements

IGutterPen
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.PenColor Property

GutterPenColor Property
Gets or sets color of the gutter line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color PenColor { get; set; }
Public Overridable Property PenColor As Color
    Get
    Set
public:
virtual property Color PenColor {
    Color get ();
    void set (Color value);
}
abstract PenColor : Color with get, set
override PenColor : Color with get, set

Property Value

Type: Color

Implements

IGutterPenColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Rect Property

GutterRect Property
Gets the rectangle that represents gutter area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle Rect { get; }
Public Overridable ReadOnly Property Rect As Rectangle
    Get
public:
virtual property Rectangle Rect {
    Rectangle get ();
}
abstract Rect : Rectangle with get
override Rect : Rectangle with get

Property Value

Type: Rectangle

Implements

IGutterRect
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.ShowBookmarkHints Property

GutterShowBookmarkHints Property
Gets or sets a value indicating whether Edit control should display text describing bookmark in form of tooltip window when mouse pointer is over the gutter bookmark.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowBookmarkHints { get; set; }
Public Overridable Property ShowBookmarkHints As Boolean
    Get
    Set
public:
virtual property bool ShowBookmarkHints {
    bool get ();
    void set (bool value);
}
abstract ShowBookmarkHints : bool with get, set
override ShowBookmarkHints : bool with get, set

Property Value

Type: Boolean

Implements

IGutterShowBookmarkHints
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.UpdateCount Property

GutterUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.UserMarginBackColor Property

GutterUserMarginBackColor Property
Gets or sets background color of the user margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color UserMarginBackColor { get; set; }
Public Overridable Property UserMarginBackColor As Color
    Get
    Set
public:
virtual property Color UserMarginBackColor {
    Color get ();
    void set (Color value);
}
abstract UserMarginBackColor : Color with get, set
override UserMarginBackColor : Color with get, set

Property Value

Type: Color

Implements

IGutterUserMarginBackColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.UserMarginForeColor Property

GutterUserMarginForeColor Property
Gets or sets foreground color of the line numbers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color UserMarginForeColor { get; set; }
Public Overridable Property UserMarginForeColor As Color
    Get
    Set
public:
virtual property Color UserMarginForeColor {
    Color get ();
    void set (Color value);
}
abstract UserMarginForeColor : Color with get, set
override UserMarginForeColor : Color with get, set

Property Value

Type: Color

Implements

IGutterUserMarginForeColor
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.UserMarginText Property

GutterUserMarginText Property
Gets or sets text of the user margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string UserMarginText { get; set; }
Public Overridable Property UserMarginText As String
    Get
    Set
public:
virtual property String^ UserMarginText {
    String^ get ();
    void set (String^ value);
}
abstract UserMarginText : string with get, set
override UserMarginText : string with get, set

Property Value

Type: String

Implements

IGutterUserMarginText
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.UserMarginWidth Property

GutterUserMarginWidth Property
Gets or sets the width of the user margin area. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UserMarginWidth { get; set; }
Public Overridable Property UserMarginWidth As Integer
    Get
    Set
public:
virtual property int UserMarginWidth {
    int get ();
    void set (int value);
}
abstract UserMarginWidth : int with get, set
override UserMarginWidth : int with get, set

Property Value

Type: Int32

Implements

IGutterUserMarginWidth
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.UserMarginWidthInPixels Property

GutterUserMarginWidthInPixels Property
Gets the width of the user margin area in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UserMarginWidthInPixels { get; }
Public Overridable ReadOnly Property UserMarginWidthInPixels As Integer
    Get
public:
virtual property int UserMarginWidthInPixels {
    int get ();
}
abstract UserMarginWidthInPixels : int with get
override UserMarginWidthInPixels : int with get

Property Value

Type: Int32

Implements

IGutterUserMarginWidthInPixels
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Visible Property

GutterVisible Property
Gets or sets a value indicating whether the gutter area is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Visible { get; set; }
Public Overridable Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

IGutterVisible
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Width Property

GutterWidth Property
Gets or sets the width of the gutter. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Width { get; set; }
Public Overridable Property Width As Integer
    Get
    Set
public:
virtual property int Width {
    int get ();
    void set (int value);
}
abstract Width : int with get, set
override Width : int with get, set

Property Value

Type: Int32

Implements

IGutterWidth
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.WidthInPixels Property

GutterWidthInPixels Property
Gets the width of the gutter in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int WidthInPixels { get; }
Public Overridable ReadOnly Property WidthInPixels As Integer
    Get
public:
virtual property int WidthInPixels {
    int get ();
}
abstract WidthInPixels : int with get
override WidthInPixels : int with get

Property Value

Type: Int32

Implements

IGutterWidthInPixels
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.WrapImageIndex Property

GutterWrapImageIndex Property
Gets or sets a value that specifies index of item in the image collection used to paint special mark indicating the wrapped line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int WrapImageIndex { get; set; }
Public Overridable Property WrapImageIndex As Integer
    Get
    Set
public:
virtual property int WrapImageIndex {
    int get ();
    void set (int value);
}
abstract WrapImageIndex : int with get, set
override WrapImageIndex : int with get, set

Property Value

Type: Int32

Implements

IGutterWrapImageIndex
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter Events

Gutter Events

The Gutter type exposes the following members.

Events
 | Name | Description
Public event | Click | Occurs when the Gutter clicked.
Public event | DoubleClick | Occurs when the Gutter double-clicked.
Public event | DrawUserMargin | Occurs when user margin part of each line is drawing.
Top
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.Click Event

GutterClick Event
Occurs when the Gutter clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Click
Public Event Click As EventHandler
public:
virtual  event EventHandler^ Click {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Click : IEvent<EventHandler,
    EventArgs>
override Click : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IGutterClick
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.DoubleClick Event

GutterDoubleClick Event
Occurs when the Gutter double-clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DoubleClick
Public Event DoubleClick As EventHandler
public:
virtual  event EventHandler^ DoubleClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DoubleClick : IEvent<EventHandler,
    EventArgs>
override DoubleClick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IGutterDoubleClick
See Also

Reference

Gutter Class
Alternet.Editor Namespace


Gutter.DrawUserMargin Event

GutterDrawUserMargin Event
Occurs when user margin part of each line is drawing.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event DrawUserMarginEvent DrawUserMargin
Public Event DrawUserMargin As DrawUserMarginEvent
public:
virtual  event DrawUserMarginEvent^ DrawUserMargin {
    void add (DrawUserMarginEvent^ value);
    void remove (DrawUserMarginEvent^ value);
}
abstract DrawUserMargin : IEvent<DrawUserMarginEvent,
    DrawUserMarginEventArgs>
override DrawUserMargin : IEvent<DrawUserMarginEvent,
    DrawUserMarginEventArgs>

Value

Type: Alternet.EditorDrawUserMarginEvent

Implements

IGutterDrawUserMargin
See Also

Reference

Gutter Class
Alternet.Editor Namespace


GutterOptions Enumeration

GutterOptions Enumeration
Defines gutter appearance and behaviour displayed at the left size of the Edit control. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum GutterOptions
<FlagsAttribute>
Public Enumeration GutterOptions
[FlagsAttribute]
public enum class GutterOptions
[<FlagsAttribute>]
type GutterOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
PaintLineNumbers | 1 | Specifies that numbers of lines should be drawn.
PaintLinesOnGutter | 2 | Specifies that numbers of lines should be drawn at the gutter area rather than beyond the gutter.
PaintLinesBeyondEof | 4 | Specifies that numbers of lines should be drawn beyond end of file.
PaintBookMarks | 8 | Specifies that bookmarks should be drawn.
PaintLineModificators | 16 | Specifies that line modificators (color stitch that indicates that the line content is modified, unmodified or saved) should be drawn.
PaintUserMargin | 32 | Specifies that user margin (allowing to draw additional information) should be drawn.
SelectLineOnClick | 64 | Specifies that entire line should be selected while user holds "Shift" key and left clicks mouse on gutter.
See Also

Reference

Alternet.Editor Namespace


HitTest Enumeration

HitTest Enumeration
Contains information about a part of the Edit control at a specified coordinate. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum HitTest
<FlagsAttribute>
Public Enumeration HitTest
[FlagsAttribute]
public enum class HitTest
[<FlagsAttribute>]
type HitTest
Members
Member name | Value | Description
None | 0 | No part.
Above | 1 | Above the Edit control client area.
Below | 2 | Below the Edit control client area.
Left | 4 | Left to the Edit control client area.
Right | 8 | Right to the Edit control client area.
Text | 16 | On the text.
Selection | 32 | On the selected text.
BeyondEol | 64 | Beyond line end.
BeyondEof | 128 | Beyond file end.
Gutter | 256 | On the gutter area.
Margin | 512 | On the margin area.
GutterImage | 1024 | On the gutter image.
BookMark | 2048 | On the bookmark.
OutlineArea | 4096 | On the outline area.
OutlineImage | 8192 | On the outline image(plus/minus) button.
OutlineButton | 16384 | On the outline button.
LineModificator | 32768 | On the line modificator area.
LineNumber | 65536 | On the line numbers area.
HyperText | 131072 | On the hypertext.
Page | 262144 | On the page.
PageWhiteSpace | 524288 | On the interval between pages.
See Also

Reference

Alternet.Editor Namespace


HitTestInfo Class

HitTestInfo Class
Contains information about an area of an Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorHitTestInfo

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HitTestInfo : IHitTestInfo
Public Class HitTestInfo
    Implements IHitTestInfo
public ref class HitTestInfo : IHitTestInfo
type HitTestInfo =
    class
        interface IHitTestInfo
    end

The HitTestInfo type exposes the following members.

Constructors
 | Name | Description
Public method | HitTestInfo | Initializes a new instance of the HitTestInfo class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets HitTestInfo members to their default values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Bookmark | Gets or sets the IBookmark index, evaluated by the hit-test operation. Contains index of the bookmark if mouse is over the gutter image; - 1 otherwise.
Public property | Group | Gets or sets the IBookmark group, evaluated by the hit-test operation.
Public property | GutterImage | Gets or sets the Gutter ImageIndex, evaluated by the hit-test operation. Contains index of image if mouse is over the gutter image; - 1 otherwise.
Public property | GutterImageRect | Gets or sets the area of gutter image, evaluated by the hit-test operation. Contains area of the image if mouse is over the gutter image; - 1 otherwise.
Public property | HitTest | Gets or sets the HitTest that represents the area of the Edit control evaluated by the hit-test operation.
Public property | Item | Gets or sets the IStrItem object evaluated by the hit-test operation. Contains instance of IStrItem object if mouse is over text line in Edit control; null otherwise.
Public property | Line | Gets or sets the index of line evaluated by the hit-test operation. Contains index of line if mouse is over text line in Edit control; -1 otherwise.
Public property | OutlineIndex | Gets or sets the index of line where outline image is displayed, evaluated by the hit-test operation. Contains index of line if mouse is over the outline button; - 1 otherwise.
Public property | OutlineRange | Gets or sets the IOutlineRange object evaluated by the hit-test operation. Contains instance of IOutlineRange object if mouse is over outline button; null otherwise.
Public property | Page | Gets or sets the index of page evaluated by the hit-test operation. Contains index of page if mouse is over text page in Edit control; null otherwise.
Public property | Pos | Gets or sets the index of character within the line evaluated by the hit-test operation. Contains index of line if mouse is over some text in Edit control; -1 otherwise.
Public property | String | Gets or sets the text string evaluated by the hit-test operation. Contains string if mouse is over text line in Edit control; null otherwise.
Public property | Style | Gets or sets the index of lexical style evaluated by the hit-test operation. Contains index of lexical style if mouse is over the text; - 1 otherwise.
Public property | TextStyle | Gets or sets the set of additional flags for the text fragment evaluated by the hit-test operation.
Public property | Url | Gets or sets the hypertext string evaluated by the hit-test operation. Contains string if mouse is over hypertext section in Edit control; null otherwise.
Public property | Word | Gets or sets the word evaluated by the hit-test operation. Contains string if mouse is over some word in Edit control; null otherwise.
Top
See Also

Reference

Alternet.Editor Namespace


HitTestInfo Constructor

HitTestInfo Constructor
Initializes a new instance of the HitTestInfo class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HitTestInfo()
Public Sub New
public:
HitTestInfo()
new : unit -> HitTestInfo
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo Methods

HitTestInfo Methods

The HitTestInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets HitTestInfo members to their default values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Reset Method

HitTestInfoReset Method
Resets HitTestInfo members to their default values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IHitTestInfoReset
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo Properties

HitTestInfo Properties

The HitTestInfo type exposes the following members.

Properties
 | Name | Description
Public property | Bookmark | Gets or sets the IBookmark index, evaluated by the hit-test operation. Contains index of the bookmark if mouse is over the gutter image; - 1 otherwise.
Public property | Group | Gets or sets the IBookmark group, evaluated by the hit-test operation.
Public property | GutterImage | Gets or sets the Gutter ImageIndex, evaluated by the hit-test operation. Contains index of image if mouse is over the gutter image; - 1 otherwise.
Public property | GutterImageRect | Gets or sets the area of gutter image, evaluated by the hit-test operation. Contains area of the image if mouse is over the gutter image; - 1 otherwise.
Public property | HitTest | Gets or sets the HitTest that represents the area of the Edit control evaluated by the hit-test operation.
Public property | Item | Gets or sets the IStrItem object evaluated by the hit-test operation. Contains instance of IStrItem object if mouse is over text line in Edit control; null otherwise.
Public property | Line | Gets or sets the index of line evaluated by the hit-test operation. Contains index of line if mouse is over text line in Edit control; -1 otherwise.
Public property | OutlineIndex | Gets or sets the index of line where outline image is displayed, evaluated by the hit-test operation. Contains index of line if mouse is over the outline button; - 1 otherwise.
Public property | OutlineRange | Gets or sets the IOutlineRange object evaluated by the hit-test operation. Contains instance of IOutlineRange object if mouse is over outline button; null otherwise.
Public property | Page | Gets or sets the index of page evaluated by the hit-test operation. Contains index of page if mouse is over text page in Edit control; null otherwise.
Public property | Pos | Gets or sets the index of character within the line evaluated by the hit-test operation. Contains index of line if mouse is over some text in Edit control; -1 otherwise.
Public property | String | Gets or sets the text string evaluated by the hit-test operation. Contains string if mouse is over text line in Edit control; null otherwise.
Public property | Style | Gets or sets the index of lexical style evaluated by the hit-test operation. Contains index of lexical style if mouse is over the text; - 1 otherwise.
Public property | TextStyle | Gets or sets the set of additional flags for the text fragment evaluated by the hit-test operation.
Public property | Url | Gets or sets the hypertext string evaluated by the hit-test operation. Contains string if mouse is over hypertext section in Edit control; null otherwise.
Public property | Word | Gets or sets the word evaluated by the hit-test operation. Contains string if mouse is over some word in Edit control; null otherwise.
Top
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Bookmark Property

HitTestInfoBookmark Property
Gets or sets the IBookmark index, evaluated by the hit-test operation. Contains index of the bookmark if mouse is over the gutter image; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Bookmark { get; set; }
Public Overridable Property Bookmark As Integer
    Get
    Set
public:
virtual property int Bookmark {
    int get ();
    void set (int value);
}
abstract Bookmark : int with get, set
override Bookmark : int with get, set

Property Value

Type: Int32

Implements

IHitTestInfoBookmark
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Group Property

HitTestInfoGroup Property
Gets or sets the IBookmark group, evaluated by the hit-test operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Group { get; set; }
Public Overridable Property Group As Integer
    Get
    Set
public:
virtual property int Group {
    int get ();
    void set (int value);
}
abstract Group : int with get, set
override Group : int with get, set

Property Value

Type: Int32

Implements

IHitTestInfoGroup
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.GutterImage Property

HitTestInfoGutterImage Property
Gets or sets the Gutter ImageIndex, evaluated by the hit-test operation. Contains index of image if mouse is over the gutter image; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GutterImage { get; set; }
Public Overridable Property GutterImage As Integer
    Get
    Set
public:
virtual property int GutterImage {
    int get ();
    void set (int value);
}
abstract GutterImage : int with get, set
override GutterImage : int with get, set

Property Value

Type: Int32

Implements

IHitTestInfoGutterImage
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.GutterImageRect Property

HitTestInfoGutterImageRect Property
Gets or sets the area of gutter image, evaluated by the hit-test operation. Contains area of the image if mouse is over the gutter image; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle GutterImageRect { get; set; }
Public Overridable Property GutterImageRect As Rectangle
    Get
    Set
public:
virtual property Rectangle GutterImageRect {
    Rectangle get ();
    void set (Rectangle value);
}
abstract GutterImageRect : Rectangle with get, set
override GutterImageRect : Rectangle with get, set

Property Value

Type: Rectangle

Implements

IHitTestInfoGutterImageRect
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.HitTest Property

HitTestInfoHitTest Property
Gets or sets the HitTest that represents the area of the Edit control evaluated by the hit-test operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual HitTest HitTest { get; set; }
Public Overridable Property HitTest As HitTest
    Get
    Set
public:
virtual property HitTest HitTest {
    HitTest get ();
    void set (HitTest value);
}
abstract HitTest : HitTest with get, set
override HitTest : HitTest with get, set

Property Value

Type: HitTest

Implements

IHitTestInfoHitTest
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Item Property

HitTestInfoItem Property
Gets or sets the IStrItem object evaluated by the hit-test operation. Contains instance of IStrItem object if mouse is over text line in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IStringItem Item { get; set; }
Public Overridable Property Item As IStringItem
    Get
    Set
public:
virtual property IStringItem^ Item {
    IStringItem^ get ();
    void set (IStringItem^ value);
}
abstract Item : IStringItem with get, set
override Item : IStringItem with get, set

Property Value

Type: IStringItem

Implements

IHitTestInfoItem
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Line Property

HitTestInfoLine Property
Gets or sets the index of line evaluated by the hit-test operation. Contains index of line if mouse is over text line in Edit control; -1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Line { get; set; }
Public Overridable Property Line As Integer
    Get
    Set
public:
virtual property int Line {
    int get ();
    void set (int value);
}
abstract Line : int with get, set
override Line : int with get, set

Property Value

Type: Int32

Implements

IHitTestInfoLine
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.OutlineIndex Property

HitTestInfoOutlineIndex Property
Gets or sets the index of line where outline image is displayed, evaluated by the hit-test operation. Contains index of line if mouse is over the outline button; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int OutlineIndex { get; set; }
Public Overridable Property OutlineIndex As Integer
    Get
    Set
public:
virtual property int OutlineIndex {
    int get ();
    void set (int value);
}
abstract OutlineIndex : int with get, set
override OutlineIndex : int with get, set

Property Value

Type: Int32

Implements

IHitTestInfoOutlineIndex
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.OutlineRange Property

HitTestInfoOutlineRange Property
Gets or sets the IOutlineRange object evaluated by the hit-test operation. Contains instance of IOutlineRange object if mouse is over outline button; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange OutlineRange { get; set; }
Public Overridable Property OutlineRange As IOutlineRange
    Get
    Set
public:
virtual property IOutlineRange^ OutlineRange {
    IOutlineRange^ get ();
    void set (IOutlineRange^ value);
}
abstract OutlineRange : IOutlineRange with get, set
override OutlineRange : IOutlineRange with get, set

Property Value

Type: IOutlineRange

Implements

IHitTestInfoOutlineRange
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Page Property

HitTestInfoPage Property
Gets or sets the index of page evaluated by the hit-test operation. Contains index of page if mouse is over text page in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Page { get; set; }
Public Overridable Property Page As Integer
    Get
    Set
public:
virtual property int Page {
    int get ();
    void set (int value);
}
abstract Page : int with get, set
override Page : int with get, set

Property Value

Type: Int32

Implements

IHitTestInfoPage
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Pos Property

HitTestInfoPos Property
Gets or sets the index of character within the line evaluated by the hit-test operation. Contains index of line if mouse is over some text in Edit control; -1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Pos { get; set; }
Public Overridable Property Pos As Integer
    Get
    Set
public:
virtual property int Pos {
    int get ();
    void set (int value);
}
abstract Pos : int with get, set
override Pos : int with get, set

Property Value

Type: Int32

Implements

IHitTestInfoPos
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.String Property

HitTestInfoString Property
Gets or sets the text string evaluated by the hit-test operation. Contains string if mouse is over text line in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string String { get; set; }
Public Overridable Property String As String
    Get
    Set
public:
virtual property String^ String {
    String^ get ();
    void set (String^ value);
}
abstract String : string with get, set
override String : string with get, set

Property Value

Type: String

Implements

IHitTestInfoString
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Style Property

HitTestInfoStyle Property
Gets or sets the index of lexical style evaluated by the hit-test operation. Contains index of lexical style if mouse is over the text; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Style { get; set; }
Public Overridable Property Style As Integer
    Get
    Set
public:
virtual property int Style {
    int get ();
    void set (int value);
}
abstract Style : int with get, set
override Style : int with get, set

Property Value

Type: Int32

Implements

IHitTestInfoStyle
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.TextStyle Property

HitTestInfoTextStyle Property
Gets or sets the set of additional flags for the text fragment evaluated by the hit-test operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual TextStyle TextStyle { get; set; }
Public Overridable Property TextStyle As TextStyle
    Get
    Set
public:
virtual property TextStyle TextStyle {
    TextStyle get ();
    void set (TextStyle value);
}
abstract TextStyle : TextStyle with get, set
override TextStyle : TextStyle with get, set

Property Value

Type: TextStyle

Implements

IHitTestInfoTextStyle
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Url Property

HitTestInfoUrl Property
Gets or sets the hypertext string evaluated by the hit-test operation. Contains string if mouse is over hypertext section in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Url { get; set; }
Public Overridable Property Url As String
    Get
    Set
public:
virtual property String^ Url {
    String^ get ();
    void set (String^ value);
}
abstract Url : string with get, set
override Url : string with get, set

Property Value

Type: String

Implements

IHitTestInfoUrl
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


HitTestInfo.Word Property

HitTestInfoWord Property
Gets or sets the word evaluated by the hit-test operation. Contains string if mouse is over some word in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Word { get; set; }
Public Overridable Property Word As String
    Get
    Set
public:
virtual property String^ Word {
    String^ get ();
    void set (String^ value);
}
abstract Word : string with get, set
override Word : string with get, set

Property Value

Type: String

Implements

IHitTestInfoWord
See Also

Reference

HitTestInfo Class
Alternet.Editor Namespace


IAutoCorrect Interface

IAutoCorrect Interface
Represents properties and methods allowing to auto correct words when typing.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IAutoCorrect
Public Interface IAutoCorrect
public interface class IAutoCorrect
type IAutoCorrect =  interface end

The IAutoCorrect type exposes the following members.

Methods
 | Name | Description
Public method | HasAutoCorrection | When implemented by a class, checks whether specified word has correction.
Top
Properties
 | Name | Description
Public property | AutoCorrectDelimiters | When implemented by a class, gets or sets an array of chars that used as word delimiters.
Public property | AutoCorrection | When implemented by a class, gets or sets a boolean value indicating whether to auto correct words being typed.
Top
Events
 | Name | Description
Public event | AutoCorrect | When implemented by a class, occurs when control tries to auto correct word being typed.
Top
See Also

Reference

Alternet.Editor Namespace


IAutoCorrect Methods

IAutoCorrect Methods

The IAutoCorrect type exposes the following members.

Methods
 | Name | Description
Public method | HasAutoCorrection | When implemented by a class, checks whether specified word has correction.
Top
See Also

Reference

IAutoCorrect Interface
Alternet.Editor Namespace


IAutoCorrect.HasAutoCorrection Method

IAutoCorrectHasAutoCorrection Method
When implemented by a class, checks whether specified word has correction.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasAutoCorrection(
    string word,
    out string correctWord
)
Function HasAutoCorrection (
    word As String,
    <OutAttribute> ByRef correctWord As String
) As Boolean
bool HasAutoCorrection(
    String^ word,
    [OutAttribute] String^% correctWord
)
abstract HasAutoCorrection :
        word : string *
        correctWord : string byref -> bool

Parameters

word
Type: SystemString
Word that should be corrected.
correctWord
Type: SystemString
Receives a corrected word.

Return Value

Type: Boolean
True if word has correction; otherwise false.
See Also

Reference

IAutoCorrect Interface
Alternet.Editor Namespace


IAutoCorrect Properties

IAutoCorrect Properties

The IAutoCorrect type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectDelimiters | When implemented by a class, gets or sets an array of chars that used as word delimiters.
Public property | AutoCorrection | When implemented by a class, gets or sets a boolean value indicating whether to auto correct words being typed.
Top
See Also

Reference

IAutoCorrect Interface
Alternet.Editor Namespace


IAutoCorrect.AutoCorrectDelimiters Property

IAutoCorrectAutoCorrectDelimiters Property
When implemented by a class, gets or sets an array of chars that used as word delimiters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] AutoCorrectDelimiters { get; set; }
Property AutoCorrectDelimiters As Char()
    Get
    Set
property array<wchar_t>^ AutoCorrectDelimiters {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract AutoCorrectDelimiters : char[] with get, set

Property Value

Type: Char
See Also

Reference

IAutoCorrect Interface
Alternet.Editor Namespace


IAutoCorrect.AutoCorrection Property

IAutoCorrectAutoCorrection Property
When implemented by a class, gets or sets a boolean value indicating whether to auto correct words being typed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AutoCorrection { get; set; }
Property AutoCorrection As Boolean
    Get
    Set
property bool AutoCorrection {
    bool get ();
    void set (bool value);
}
abstract AutoCorrection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IAutoCorrect Interface
Alternet.Editor Namespace


IAutoCorrect Events

IAutoCorrect Events

The IAutoCorrect type exposes the following members.

Events
 | Name | Description
Public event | AutoCorrect | When implemented by a class, occurs when control tries to auto correct word being typed.
Top
See Also

Reference

IAutoCorrect Interface
Alternet.Editor Namespace


IAutoCorrect.AutoCorrect Event

IAutoCorrectAutoCorrect Event
When implemented by a class, occurs when control tries to auto correct word being typed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event AutoCorrectEvent AutoCorrect
Event AutoCorrect As AutoCorrectEvent
 event AutoCorrectEvent^ AutoCorrect {
    void add (AutoCorrectEvent^ value);
    void remove (AutoCorrectEvent^ value);
}
abstract AutoCorrect : IEvent<AutoCorrectEvent,
    AutoCorrectEventArgs>

Value

Type: Alternet.EditorAutoCorrectEvent
See Also

Reference

IAutoCorrect Interface
Alternet.Editor Namespace


ICaret Interface

ICaret Interface
Represents properties and methods to handle caret within the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICaret
Public Interface ICaret
public interface class ICaret
type ICaret =  interface end

The ICaret type exposes the following members.

Methods
 | Name | Description
Public method | CreateCaret | When implemented by a class, creates a new shape for the system caret and gets ownership of the caret.
Public method | DestroyCaret | When implemented by a class, destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
Public method | DisplayDragCaret | When implemented by a class, displays dragging caret rather than regular caret.
Public method | GetCaretSize | When implemented by a class, returns size of the caret's current shape at given position.
Public method | HideDragCaret | When implemented by a class, hides dragging caret.
Public method | KillFocus | When implemented by a class, ensure the caret is not visible.
Public method | ResetHideCaret | When implemented by a class, resets the HideCaret to the default value.
Public method | ResetKeepCaretOnLostFocus | When implemented by a class, resets the KeepCaretOnLostFocus to the default value.
Public method | ShowCaret | When implemented by a class, moves the caret to the specified coordinates.
Public method | UpdateCaret | When implemented by a class, ensures the caret is displayed in the current position.
Top
Properties
 | Name | Description
Public property | CurrentBlockRange | When implemented by a class, gets currently highlighted block range.
Public property | HideCaret | When implemented by a class, gets or sets a value indicating whether the control should display caret when it has input focus.
Public property | HighlightCurrentBlock | When implemented by a class, specifies that edit control should highlight current block.
Public property | KeepCaretOnLostFocus | When implemented by a class, keeps caret in visible state even Edit control lost focus.
Top
See Also

Reference

Alternet.Editor Namespace


ICaret Methods

ICaret Methods

The ICaret type exposes the following members.

Methods
 | Name | Description
Public method | CreateCaret | When implemented by a class, creates a new shape for the system caret and gets ownership of the caret.
Public method | DestroyCaret | When implemented by a class, destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
Public method | DisplayDragCaret | When implemented by a class, displays dragging caret rather than regular caret.
Public method | GetCaretSize | When implemented by a class, returns size of the caret's current shape at given position.
Public method | HideDragCaret | When implemented by a class, hides dragging caret.
Public method | KillFocus | When implemented by a class, ensure the caret is not visible.
Public method | ResetHideCaret | When implemented by a class, resets the HideCaret to the default value.
Public method | ResetKeepCaretOnLostFocus | When implemented by a class, resets the KeepCaretOnLostFocus to the default value.
Public method | ShowCaret | When implemented by a class, moves the caret to the specified coordinates.
Public method | UpdateCaret | When implemented by a class, ensures the caret is displayed in the current position.
Top
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.CreateCaret Method

ICaretCreateCaret Method
When implemented by a class, creates a new shape for the system caret and gets ownership of the caret.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CreateCaret()
Sub CreateCaret
void CreateCaret()
abstract CreateCaret : unit -> unit
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.DestroyCaret Method

ICaretDestroyCaret Method
When implemented by a class, destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DestroyCaret()
Sub DestroyCaret
void DestroyCaret()
abstract DestroyCaret : unit -> unit
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.DisplayDragCaret Method

ICaretDisplayDragCaret Method
When implemented by a class, displays dragging caret rather than regular caret.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DisplayDragCaret()
Sub DisplayDragCaret
void DisplayDragCaret()
abstract DisplayDragCaret : unit -> unit
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.GetCaretSize Method

ICaretGetCaretSize Method
When implemented by a class, returns size of the caret's current shape at given position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Size GetCaretSize(
    Point position
)
Function GetCaretSize (
    position As Point
) As Size
Size GetCaretSize(
    Point position
)
abstract GetCaretSize :
        position : Point -> Size

Parameters

position
Type: System.DrawingPoint
Point at which caret size should be calculated.

Return Value

Type: Size
Size of the caret.
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.HideDragCaret Method

ICaretHideDragCaret Method
When implemented by a class, hides dragging caret.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HideDragCaret()
Sub HideDragCaret
void HideDragCaret()
abstract HideDragCaret : unit -> unit
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.KillFocus Method

ICaretKillFocus Method
When implemented by a class, ensure the caret is not visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KillFocus()
Sub KillFocus
void KillFocus()
abstract KillFocus : unit -> unit
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.ResetHideCaret Method

ICaretResetHideCaret Method
When implemented by a class, resets the HideCaret to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetHideCaret()
Sub ResetHideCaret
void ResetHideCaret()
abstract ResetHideCaret : unit -> unit
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.ResetKeepCaretOnLostFocus Method

ICaretResetKeepCaretOnLostFocus Method
When implemented by a class, resets the KeepCaretOnLostFocus to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetKeepCaretOnLostFocus()
Sub ResetKeepCaretOnLostFocus
void ResetKeepCaretOnLostFocus()
abstract ResetKeepCaretOnLostFocus : unit -> unit
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.ShowCaret Method

ICaretShowCaret Method
When implemented by a class, moves the caret to the specified coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowCaret(
    int x,
    int y
)
Sub ShowCaret (
    x As Integer,
    y As Integer
)
void ShowCaret(
    int x,
    int y
)
abstract ShowCaret :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
Specifies the new x-coordinate of the caret.
y
Type: SystemInt32
Specifies the new y-coordinate of the caret.
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.UpdateCaret Method

ICaretUpdateCaret Method
When implemented by a class, ensures the caret is displayed in the current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateCaret()
Sub UpdateCaret
void UpdateCaret()
abstract UpdateCaret : unit -> unit
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret Properties

ICaret Properties

The ICaret type exposes the following members.

Properties
 | Name | Description
Public property | CurrentBlockRange | When implemented by a class, gets currently highlighted block range.
Public property | HideCaret | When implemented by a class, gets or sets a value indicating whether the control should display caret when it has input focus.
Public property | HighlightCurrentBlock | When implemented by a class, specifies that edit control should highlight current block.
Public property | KeepCaretOnLostFocus | When implemented by a class, keeps caret in visible state even Edit control lost focus.
Top
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.CurrentBlockRange Property

ICaretCurrentBlockRange Property
When implemented by a class, gets currently highlighted block range.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange CurrentBlockRange { get; }
ReadOnly Property CurrentBlockRange As IRange
    Get
property IRange^ CurrentBlockRange {
    IRange^ get ();
}
abstract CurrentBlockRange : IRange with get

Property Value

Type: IRange
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.HideCaret Property

ICaretHideCaret Property
When implemented by a class, gets or sets a value indicating whether the control should display caret when it has input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HideCaret { get; set; }
Property HideCaret As Boolean
    Get
    Set
property bool HideCaret {
    bool get ();
    void set (bool value);
}
abstract HideCaret : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.HighlightCurrentBlock Property

ICaretHighlightCurrentBlock Property
When implemented by a class, specifies that edit control should highlight current block.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HighlightCurrentBlock { get; set; }
Property HighlightCurrentBlock As Boolean
    Get
    Set
property bool HighlightCurrentBlock {
    bool get ();
    void set (bool value);
}
abstract HighlightCurrentBlock : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICaret.KeepCaretOnLostFocus Property

ICaretKeepCaretOnLostFocus Property
When implemented by a class, keeps caret in visible state even Edit control lost focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool KeepCaretOnLostFocus { get; set; }
Property KeepCaretOnLostFocus As Boolean
    Get
    Set
property bool KeepCaretOnLostFocus {
    bool get ();
    void set (bool value);
}
abstract KeepCaretOnLostFocus : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICaret Interface
Alternet.Editor Namespace


ICollapsable Interface

ICollapsable Interface
Represents properties and methods to affects appearance and behaviour of outline sections within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICollapsable
Public Interface ICollapsable
public interface class ICollapsable
type ICollapsable =  interface end

The ICollapsable type exposes the following members.

Methods
 | Name | Description
Public method | CanCollapse | When implemented in a class, returns boolean value indicating that outline section at given line can be collapsed.
Public method | CanExpand(Int32) | When implemented in a class, returns boolean value indicating that outline section at given line can be expanded.
Public method | CanExpand(IOutlineRange) | When implemented in a class, returns boolean value indicating that given outline section can be expanded.
Public method | Collapse | When implemented by a class, collapses the specified line.
Public method | CollapseToDefinitions | When implemented by a class, collapses and expands some outline section to get a quick overall view of the content.
Public method | EnsureExpanded(Point) | When implemented by a class, makes all outline sections containing specified position expanded.
Public method | EnsureExpanded(Int32) | When implemented by a class, makes all outline sections containing specified line expanded.
Public method | Expand | When implemented by a class, expands outline section at the given line.
Public method | FullCollapse | When implemented by a class, collapses all outlining sections.
Public method | FullCollapse(IListIRange) | When implemented by a class, collapses all sections objects specified by Ranges parameter.
Public method | FullExpand | When implemented by a class, expands all outlining sections.
Public method | FullExpand(IListIRange) | When implemented by a class, expands all outline sections specified by Ranges parameter.
Public method | GetOutlineHint | When implemented by a class, returns string that appears in the hint window when mouse pointer is over the outline button.
Public method | GetOutlineRange(Point) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position.
Public method | GetOutlineRange(Int32) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line.
Public method | GetOutlineRanges(IListIRange) | When implemented by a class, fills list specified by ranges parameter with all existing outline sections.
Public method | GetOutlineRanges(IListIRange, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific position.
Public method | GetOutlineRanges(IListIRange, Int32) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific line.
Public method | GetOutlineRanges(IListIRange, Point, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific range.
Public method | IsCollapsed | When implemented by a class, indicates whether the outlined text at the specified line is collapsed.
Public method | IsExpanded | When implemented by a class, indicates whether the outlined text at the specified line is expanded.
Public method | IsVisible(Point) | When implemented by a class, indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.
Public method | IsVisible(Int32) | When implemented by a class, indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.
Public method | Outline(Point, Point) | When implemented by a class, creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Point, Point, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Point, Point, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Point, Point, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | ResetAllowOutlining | When implemented by a class, resets AllowOutlining to the default value.
Public method | ResetOutlineOptions | When implemented by a class, resets OutlineOptions to the default value.
Public method | SetOutlineRanges(IListIRange) | When implemented by a class, updates IOutlineRange collection from given list of ranges.
Public method | SetOutlineRanges(IListIRange, Boolean) | When implemented by a class, updates IOutlineRange collection from given list of ranges.
Public method | ToggleOutlining | When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOutlining(IListIRange, IOutlineRange) | When implemented by a class, toggles expanded state for given IOutlineRange collection.
Public method | UnOutline | When implemented by a class, removes all outlined sections from outline collection.
Public method | UnOutline(Point) | When implemented by a class, removes outlined section at the specific position.
Public method | UnOutline(Int32) | When implemented by a class, removes all outline sections containing the given line.
Top
Properties
 | Name | Description
Public property | AllowOutlining | When implemented by a class, gets or sets a value indicating whether outlining enabled.
Public property | CollapsedCount | When implemented by a class, returns number of collapsed sections.
Public property | OutlineOptions | When implemented by a class, gets or sets outlining options.
Top
Events
 | Name | Description
Public event | Collapsing | When implemented by a class, occurs when user attempts collapse outline section.
Public event | Expanding | When implemented by a class, occurs when user attempts expand outline section.
Top
See Also

Reference

Alternet.Editor Namespace


ICollapsable Methods

ICollapsable Methods

The ICollapsable type exposes the following members.

Methods
 | Name | Description
Public method | CanCollapse | When implemented in a class, returns boolean value indicating that outline section at given line can be collapsed.
Public method | CanExpand(Int32) | When implemented in a class, returns boolean value indicating that outline section at given line can be expanded.
Public method | CanExpand(IOutlineRange) | When implemented in a class, returns boolean value indicating that given outline section can be expanded.
Public method | Collapse | When implemented by a class, collapses the specified line.
Public method | CollapseToDefinitions | When implemented by a class, collapses and expands some outline section to get a quick overall view of the content.
Public method | EnsureExpanded(Point) | When implemented by a class, makes all outline sections containing specified position expanded.
Public method | EnsureExpanded(Int32) | When implemented by a class, makes all outline sections containing specified line expanded.
Public method | Expand | When implemented by a class, expands outline section at the given line.
Public method | FullCollapse | When implemented by a class, collapses all outlining sections.
Public method | FullCollapse(IListIRange) | When implemented by a class, collapses all sections objects specified by Ranges parameter.
Public method | FullExpand | When implemented by a class, expands all outlining sections.
Public method | FullExpand(IListIRange) | When implemented by a class, expands all outline sections specified by Ranges parameter.
Public method | GetOutlineHint | When implemented by a class, returns string that appears in the hint window when mouse pointer is over the outline button.
Public method | GetOutlineRange(Point) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position.
Public method | GetOutlineRange(Int32) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line.
Public method | GetOutlineRanges(IListIRange) | When implemented by a class, fills list specified by ranges parameter with all existing outline sections.
Public method | GetOutlineRanges(IListIRange, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific position.
Public method | GetOutlineRanges(IListIRange, Int32) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific line.
Public method | GetOutlineRanges(IListIRange, Point, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific range.
Public method | IsCollapsed | When implemented by a class, indicates whether the outlined text at the specified line is collapsed.
Public method | IsExpanded | When implemented by a class, indicates whether the outlined text at the specified line is expanded.
Public method | IsVisible(Point) | When implemented by a class, indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.
Public method | IsVisible(Int32) | When implemented by a class, indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.
Public method | Outline(Point, Point) | When implemented by a class, creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Point, Point, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Point, Point, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Point, Point, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | ResetAllowOutlining | When implemented by a class, resets AllowOutlining to the default value.
Public method | ResetOutlineOptions | When implemented by a class, resets OutlineOptions to the default value.
Public method | SetOutlineRanges(IListIRange) | When implemented by a class, updates IOutlineRange collection from given list of ranges.
Public method | SetOutlineRanges(IListIRange, Boolean) | When implemented by a class, updates IOutlineRange collection from given list of ranges.
Public method | ToggleOutlining | When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOutlining(IListIRange, IOutlineRange) | When implemented by a class, toggles expanded state for given IOutlineRange collection.
Public method | UnOutline | When implemented by a class, removes all outlined sections from outline collection.
Public method | UnOutline(Point) | When implemented by a class, removes outlined section at the specific position.
Public method | UnOutline(Int32) | When implemented by a class, removes all outline sections containing the given line.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.CanCollapse Method

ICollapsableCanCollapse Method
When implemented in a class, returns boolean value indicating that outline section at given line can be collapsed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCollapse(
    int line
)
Function CanCollapse (
    line As Integer
) As Boolean
bool CanCollapse(
    int line
)
abstract CanCollapse :
        line : int -> bool

Parameters

line
Type: SystemInt32

Return Value

Type: Boolean
True if section can be collapsed; otherwise false.
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.CanExpand Method

ICollapsableCanExpand Method
Overload List
 | Name | Description
Public method | CanExpand(Int32) | When implemented in a class, returns boolean value indicating that outline section at given line can be expanded.
Public method | CanExpand(IOutlineRange) | When implemented in a class, returns boolean value indicating that given outline section can be expanded.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.CanExpand Method (Int32)

ICollapsableCanExpand Method (Int32)
When implemented in a class, returns boolean value indicating that outline section at given line can be expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanExpand(
    int line
)
Function CanExpand (
    line As Integer
) As Boolean
bool CanExpand(
    int line
)
abstract CanExpand :
        line : int -> bool

Parameters

line
Type: SystemInt32
Line index.

Return Value

Type: Boolean
True if section can be expanded; otherwise false.
See Also

Reference

ICollapsable Interface
CanExpand Overload
Alternet.Editor Namespace


ICollapsable.CanExpand Method (IOutlineRange)

ICollapsableCanExpand Method (IOutlineRange)
When implemented in a class, returns boolean value indicating that given outline section can be expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanExpand(
    IOutlineRange range
)
Function CanExpand (
    range As IOutlineRange
) As Boolean
bool CanExpand(
    IOutlineRange^ range
)
abstract CanExpand :
        range : IOutlineRange -> bool

Parameters

range
Type: Alternet.SyntaxIOutlineRange
Specifies outline range.

Return Value

Type: Boolean
True if section can be expanded; otherwise false.
See Also

Reference

ICollapsable Interface
CanExpand Overload
Alternet.Editor Namespace


ICollapsable.Collapse Method

ICollapsableCollapse Method
When implemented by a class, collapses the specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Collapse(
    int index
)
Sub Collapse (
    index As Integer
)
void Collapse(
    int index
)
abstract Collapse :
        index : int -> unit

Parameters

index
Type: SystemInt32
The index of the line to collapse.
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.CollapseToDefinitions Method

ICollapsableCollapseToDefinitions Method
When implemented by a class, collapses and expands some outline section to get a quick overall view of the content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CollapseToDefinitions()
Sub CollapseToDefinitions
void CollapseToDefinitions()
abstract CollapseToDefinitions : unit -> unit
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.EnsureExpanded Method

ICollapsableEnsureExpanded Method
Overload List
 | Name | Description
Public method | EnsureExpanded(Point) | When implemented by a class, makes all outline sections containing specified position expanded.
Public method | EnsureExpanded(Int32) | When implemented by a class, makes all outline sections containing specified line expanded.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.EnsureExpanded Method (Point)

ICollapsableEnsureExpanded Method (Point)
When implemented by a class, makes all outline sections containing specified position expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EnsureExpanded(
    Point position
)
Sub EnsureExpanded (
    position As Point
)
void EnsureExpanded(
    Point position
)
abstract EnsureExpanded :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position in the text.
See Also

Reference

ICollapsable Interface
EnsureExpanded Overload
Alternet.Editor Namespace


ICollapsable.EnsureExpanded Method (Int32)

ICollapsableEnsureExpanded Method (Int32)
When implemented by a class, makes all outline sections containing specified line expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EnsureExpanded(
    int index
)
Sub EnsureExpanded (
    index As Integer
)
void EnsureExpanded(
    int index
)
abstract EnsureExpanded :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies position of the line in the text.
See Also

Reference

ICollapsable Interface
EnsureExpanded Overload
Alternet.Editor Namespace


ICollapsable.Expand Method

ICollapsableExpand Method
When implemented by a class, expands outline section at the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Expand(
    int index
)
Sub Expand (
    index As Integer
)
void Expand(
    int index
)
abstract Expand :
        index : int -> unit

Parameters

index
Type: SystemInt32
The index of the line to expand.
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.FullCollapse Method

ICollapsableFullCollapse Method
Overload List
 | Name | Description
Public method | FullCollapse | When implemented by a class, collapses all outlining sections.
Public method | FullCollapse(IListIRange) | When implemented by a class, collapses all sections objects specified by Ranges parameter.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.FullCollapse Method

ICollapsableFullCollapse Method
When implemented by a class, collapses all outlining sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FullCollapse()
Sub FullCollapse
void FullCollapse()
abstract FullCollapse : unit -> unit
See Also

Reference

ICollapsable Interface
FullCollapse Overload
Alternet.Editor Namespace


ICollapsable.FullCollapse Method (IList(IRange))

ICollapsableFullCollapse Method (IListIRange)
When implemented by a class, collapses all sections objects specified by Ranges parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FullCollapse(
    IList<IRange> ranges
)
Sub FullCollapse (
    ranges As IList(Of IRange)
)
void FullCollapse(
    IList<IRange^>^ ranges
)
abstract FullCollapse :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies IOutlineRange collection to collapse.
See Also

Reference

ICollapsable Interface
FullCollapse Overload
Alternet.Editor Namespace


ICollapsable.FullExpand Method

ICollapsableFullExpand Method
Overload List
 | Name | Description
Public method | FullExpand | When implemented by a class, expands all outlining sections.
Public method | FullExpand(IListIRange) | When implemented by a class, expands all outline sections specified by Ranges parameter.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.FullExpand Method

ICollapsableFullExpand Method
When implemented by a class, expands all outlining sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FullExpand()
Sub FullExpand
void FullExpand()
abstract FullExpand : unit -> unit
See Also

Reference

ICollapsable Interface
FullExpand Overload
Alternet.Editor Namespace


ICollapsable.FullExpand Method (IList(IRange))

ICollapsableFullExpand Method (IListIRange)
When implemented by a class, expands all outline sections specified by Ranges parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FullExpand(
    IList<IRange> ranges
)
Sub FullExpand (
    ranges As IList(Of IRange)
)
void FullExpand(
    IList<IRange^>^ ranges
)
abstract FullExpand :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies IOutlineRange collection to expand.
See Also

Reference

ICollapsable Interface
FullExpand Overload
Alternet.Editor Namespace


ICollapsable.GetOutlineHint Method

ICollapsableGetOutlineHint Method
When implemented by a class, returns string that appears in the hint window when mouse pointer is over the outline button.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetOutlineHint(
    IOutlineRange range
)
Function GetOutlineHint (
    range As IOutlineRange
) As String
String^ GetOutlineHint(
    IOutlineRange^ range
)
abstract GetOutlineHint :
        range : IOutlineRange -> string

Parameters

range
Type: Alternet.SyntaxIOutlineRange
Specifies the IOutlineRange object holding the hint.

Return Value

Type: String
Hint string.
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.GetOutlineRange Method

ICollapsableGetOutlineRange Method
Overload List
 | Name | Description
Public method | GetOutlineRange(Point) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position.
Public method | GetOutlineRange(Int32) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.GetOutlineRange Method (Point)

ICollapsableGetOutlineRange Method (Point)
When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange GetOutlineRange(
    Point position
)
Function GetOutlineRange (
    position As Point
) As IOutlineRange
IOutlineRange^ GetOutlineRange(
    Point position
)
abstract GetOutlineRange :
        position : Point -> IOutlineRange

Parameters

position
Type: System.DrawingPoint
Specifies position in the text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
GetOutlineRange Overload
Alternet.Editor Namespace


ICollapsable.GetOutlineRange Method (Int32)

ICollapsableGetOutlineRange Method (Int32)
When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange GetOutlineRange(
    int index
)
Function GetOutlineRange (
    index As Integer
) As IOutlineRange
IOutlineRange^ GetOutlineRange(
    int index
)
abstract GetOutlineRange :
        index : int -> IOutlineRange

Parameters

index
Type: SystemInt32
Index of line in the text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
GetOutlineRange Overload
Alternet.Editor Namespace


ICollapsable.GetOutlineRanges Method

ICollapsableGetOutlineRanges Method
Overload List
 | Name | Description
Public method | GetOutlineRanges(IListIRange) | When implemented by a class, fills list specified by ranges parameter with all existing outline sections.
Public method | GetOutlineRanges(IListIRange, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific position.
Public method | GetOutlineRanges(IListIRange, Int32) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific line.
Public method | GetOutlineRanges(IListIRange, Point, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific range.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.GetOutlineRanges Method (IList(IRange))

ICollapsableGetOutlineRanges Method (IListIRange)
When implemented by a class, fills list specified by ranges parameter with all existing outline sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetOutlineRanges(
    IList<IRange> ranges
)
Function GetOutlineRanges (
    ranges As IList(Of IRange)
) As Integer
int GetOutlineRanges(
    IList<IRange^>^ ranges
)
abstract GetOutlineRanges :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.

Return Value

Type: Int32
Number of elements in the ranges collection.
See Also

Reference

ICollapsable Interface
GetOutlineRanges Overload
Alternet.Editor Namespace


ICollapsable.GetOutlineRanges Method (IList(IRange), Point)

ICollapsableGetOutlineRanges Method (IListIRange, Point)
When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetOutlineRanges(
    IList<IRange> ranges,
    Point position
)
Function GetOutlineRanges (
    ranges As IList(Of IRange),
    position As Point
) As Integer
int GetOutlineRanges(
    IList<IRange^>^ ranges,
    Point position
)
abstract GetOutlineRanges :
        ranges : IList<IRange> *
        position : Point -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
position
Type: System.DrawingPoint
Specifies position in the text.

Return Value

Type: Int32
Number of elements in the ranges collection.
See Also

Reference

ICollapsable Interface
GetOutlineRanges Overload
Alternet.Editor Namespace


ICollapsable.GetOutlineRanges Method (IList(IRange), Int32)

ICollapsableGetOutlineRanges Method (IListIRange, Int32)
When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetOutlineRanges(
    IList<IRange> ranges,
    int index
)
Function GetOutlineRanges (
    ranges As IList(Of IRange),
    index As Integer
) As Integer
int GetOutlineRanges(
    IList<IRange^>^ ranges,
    int index
)
abstract GetOutlineRanges :
        ranges : IList<IRange> *
        index : int -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
index
Type: SystemInt32
Specifies index of line in text coordinates.

Return Value

Type: Int32
Number of elements in the ranges collection.
See Also

Reference

ICollapsable Interface
GetOutlineRanges Overload
Alternet.Editor Namespace


ICollapsable.GetOutlineRanges Method (IList(IRange), Point, Point)

ICollapsableGetOutlineRanges Method (IListIRange, Point, Point)
When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific range.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetOutlineRanges(
    IList<IRange> ranges,
    Point startPoint,
    Point endPoint
)
Function GetOutlineRanges (
    ranges As IList(Of IRange),
    startPoint As Point,
    endPoint As Point
) As Integer
int GetOutlineRanges(
    IList<IRange^>^ ranges,
    Point startPoint,
    Point endPoint
)
abstract GetOutlineRanges :
        ranges : IList<IRange> *
        startPoint : Point *
        endPoint : Point -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
startPoint
Type: System.DrawingPoint
Specifies start position in the text.
endPoint
Type: System.DrawingPoint
Specifies end position in the text.

Return Value

Type: Int32
Number of elements in the ranges collection.
See Also

Reference

ICollapsable Interface
GetOutlineRanges Overload
Alternet.Editor Namespace


ICollapsable.IsCollapsed Method

ICollapsableIsCollapsed Method
When implemented by a class, indicates whether the outlined text at the specified line is collapsed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCollapsed(
    int index
)
Function IsCollapsed (
    index As Integer
) As Boolean
bool IsCollapsed(
    int index
)
abstract IsCollapsed :
        index : int -> bool

Parameters

index
Type: SystemInt32
Index of the line to test.

Return Value

Type: Boolean
True if collapsed; otherwise false.
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.IsExpanded Method

ICollapsableIsExpanded Method
When implemented by a class, indicates whether the outlined text at the specified line is expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsExpanded(
    int index
)
Function IsExpanded (
    index As Integer
) As Boolean
bool IsExpanded(
    int index
)
abstract IsExpanded :
        index : int -> bool

Parameters

index
Type: SystemInt32
Index of the line to test.

Return Value

Type: Boolean
True if expanded; otherwise false.
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.IsVisible Method

ICollapsableIsVisible Method
Overload List
 | Name | Description
Public method | IsVisible(Point) | When implemented by a class, indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.
Public method | IsVisible(Int32) | When implemented by a class, indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.IsVisible Method (Point)

ICollapsableIsVisible Method (Point)
When implemented by a class, indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsVisible(
    Point position
)
Function IsVisible (
    position As Point
) As Boolean
bool IsVisible(
    Point position
)
abstract IsVisible :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position in the text.

Return Value

Type: Boolean
True if visible; otherwise false.
See Also

Reference

ICollapsable Interface
IsVisible Overload
Alternet.Editor Namespace


ICollapsable.IsVisible Method (Int32)

ICollapsableIsVisible Method (Int32)
When implemented by a class, indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsVisible(
    int index
)
Function IsVisible (
    index As Integer
) As Boolean
bool IsVisible(
    int index
)
abstract IsVisible :
        index : int -> bool

Parameters

index
Type: SystemInt32
Specifies index of line in the text.

Return Value

Type: Boolean
True if visible; otherwise false.
See Also

Reference

ICollapsable Interface
IsVisible Overload
Alternet.Editor Namespace


ICollapsable.Outline Method

ICollapsableOutline Method
Overload List
 | Name | Description
Public method | Outline(Point, Point) | When implemented by a class, creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Point, Point, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Point, Point, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Point, Point, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.Outline Method (Point, Point)

ICollapsableOutline Method (Point, Point)
When implemented by a class, creates an outlining section based on specific scope within current outlined section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange Outline(
    Point startPoint,
    Point endPoint
)
Function Outline (
    startPoint As Point,
    endPoint As Point
) As IOutlineRange
IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint
)
abstract Outline :
        startPoint : Point *
        endPoint : Point -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
Outline Overload
Alternet.Editor Namespace


ICollapsable.Outline Method (Int32, Int32)

ICollapsableOutline Method (Int32, Int32)
When implemented by a class, creates an outlining section based on specific scope within current outlined section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange Outline(
    int first,
    int last
)
Function Outline (
    first As Integer,
    last As Integer
) As IOutlineRange
IOutlineRange^ Outline(
    int first,
    int last
)
abstract Outline :
        first : int *
        last : int -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
Outline Overload
Alternet.Editor Namespace


ICollapsable.Outline Method (Point, Point, Int32)

ICollapsableOutline Method (Point, Point, Int32)
When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange Outline(
    Point startPoint,
    Point endPoint,
    int level
)
Function Outline (
    startPoint As Point,
    endPoint As Point,
    level As Integer
) As IOutlineRange
IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint,
    int level
)
abstract Outline :
        startPoint : Point *
        endPoint : Point *
        level : int -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
Outline Overload
Alternet.Editor Namespace


ICollapsable.Outline Method (Point, Point, String)

ICollapsableOutline Method (Point, Point, String)
When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange Outline(
    Point startPoint,
    Point endPoint,
    string outlineText
)
Function Outline (
    startPoint As Point,
    endPoint As Point,
    outlineText As String
) As IOutlineRange
IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint,
    String^ outlineText
)
abstract Outline :
        startPoint : Point *
        endPoint : Point *
        outlineText : string -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.
outlineText
Type: SystemString
Specifies text to substitute collapsed text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
Outline Overload
Alternet.Editor Namespace


ICollapsable.Outline Method (Int32, Int32, Int32)

ICollapsableOutline Method (Int32, Int32, Int32)
When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange Outline(
    int first,
    int last,
    int level
)
Function Outline (
    first As Integer,
    last As Integer,
    level As Integer
) As IOutlineRange
IOutlineRange^ Outline(
    int first,
    int last,
    int level
)
abstract Outline :
        first : int *
        last : int *
        level : int -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
Outline Overload
Alternet.Editor Namespace


ICollapsable.Outline Method (Int32, Int32, String)

ICollapsableOutline Method (Int32, Int32, String)
When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange Outline(
    int first,
    int last,
    string outlineText
)
Function Outline (
    first As Integer,
    last As Integer,
    outlineText As String
) As IOutlineRange
IOutlineRange^ Outline(
    int first,
    int last,
    String^ outlineText
)
abstract Outline :
        first : int *
        last : int *
        outlineText : string -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.
outlineText
Type: SystemString
Specifies first line of section to outline.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
Outline Overload
Alternet.Editor Namespace


ICollapsable.Outline Method (Point, Point, Int32, String)

ICollapsableOutline Method (Point, Point, Int32, String)
When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange Outline(
    Point startPoint,
    Point endPoint,
    int level,
    string outlineText
)
Function Outline (
    startPoint As Point,
    endPoint As Point,
    level As Integer,
    outlineText As String
) As IOutlineRange
IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint,
    int level,
    String^ outlineText
)
abstract Outline :
        startPoint : Point *
        endPoint : Point *
        level : int *
        outlineText : string -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.
outlineText
Type: SystemString
Specifies text to substitute collapsed text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
Outline Overload
Alternet.Editor Namespace


ICollapsable.Outline Method (Int32, Int32, Int32, String)

ICollapsableOutline Method (Int32, Int32, Int32, String)
When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange Outline(
    int first,
    int last,
    int level,
    string outlineText
)
Function Outline (
    first As Integer,
    last As Integer,
    level As Integer,
    outlineText As String
) As IOutlineRange
IOutlineRange^ Outline(
    int first,
    int last,
    int level,
    String^ outlineText
)
abstract Outline :
        first : int *
        last : int *
        level : int *
        outlineText : string -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.
outlineText
Type: SystemString
Specifies text substituting collapsed text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.
See Also

Reference

ICollapsable Interface
Outline Overload
Alternet.Editor Namespace


ICollapsable.ResetAllowOutlining Method

ICollapsableResetAllowOutlining Method
When implemented by a class, resets AllowOutlining to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAllowOutlining()
Sub ResetAllowOutlining
void ResetAllowOutlining()
abstract ResetAllowOutlining : unit -> unit
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.ResetOutlineOptions Method

ICollapsableResetOutlineOptions Method
When implemented by a class, resets OutlineOptions to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOutlineOptions()
Sub ResetOutlineOptions
void ResetOutlineOptions()
abstract ResetOutlineOptions : unit -> unit
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.SetOutlineRanges Method

ICollapsableSetOutlineRanges Method
Overload List
 | Name | Description
Public method | SetOutlineRanges(IListIRange) | When implemented by a class, updates IOutlineRange collection from given list of ranges.
Public method | SetOutlineRanges(IListIRange, Boolean) | When implemented by a class, updates IOutlineRange collection from given list of ranges.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.SetOutlineRanges Method (IList(IRange))

ICollapsableSetOutlineRanges Method (IListIRange)
When implemented by a class, updates IOutlineRange collection from given list of ranges.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetOutlineRanges(
    IList<IRange> ranges
)
Sub SetOutlineRanges (
    ranges As IList(Of IRange)
)
void SetOutlineRanges(
    IList<IRange^>^ ranges
)
abstract SetOutlineRanges :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies new IOutlineRange collection to set.
See Also

Reference

ICollapsable Interface
SetOutlineRanges Overload
Alternet.Editor Namespace


ICollapsable.SetOutlineRanges Method (IList(IRange), Boolean)

ICollapsableSetOutlineRanges Method (IListIRange, Boolean)
When implemented by a class, updates IOutlineRange collection from given list of ranges.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetOutlineRanges(
    IList<IRange> ranges,
    bool preserveVisible
)
Sub SetOutlineRanges (
    ranges As IList(Of IRange),
    preserveVisible As Boolean
)
void SetOutlineRanges(
    IList<IRange^>^ ranges,
    bool preserveVisible
)
abstract SetOutlineRanges :
        ranges : IList<IRange> *
        preserveVisible : bool -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies new IOutlineRange collection to set.
preserveVisible
Type: SystemBoolean
Indicates whether new ranges should preserve collapsed state of existing outline sections.
See Also

Reference

ICollapsable Interface
SetOutlineRanges Overload
Alternet.Editor Namespace


ICollapsable.ToggleOutlining Method

ICollapsableToggleOutlining Method
Overload List
 | Name | Description
Public method | ToggleOutlining | When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOutlining(IListIRange, IOutlineRange) | When implemented by a class, toggles expanded state for given IOutlineRange collection.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.ToggleOutlining Method

ICollapsableToggleOutlining Method
When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleOutlining()
Sub ToggleOutlining
void ToggleOutlining()
abstract ToggleOutlining : unit -> unit
See Also

Reference

ICollapsable Interface
ToggleOutlining Overload
Alternet.Editor Namespace


ICollapsable.ToggleOutlining Method (IList(IRange), IOutlineRange)

ICollapsableToggleOutlining Method (IListIRange, IOutlineRange)
When implemented by a class, toggles expanded state for given IOutlineRange collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleOutlining(
    IList<IRange> ranges,
    IOutlineRange range
)
Sub ToggleOutlining (
    ranges As IList(Of IRange),
    range As IOutlineRange
)
void ToggleOutlining(
    IList<IRange^>^ ranges,
    IOutlineRange^ range
)
abstract ToggleOutlining :
        ranges : IList<IRange> *
        range : IOutlineRange -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies IOutlineRange collection to toggle.
range
Type: Alternet.SyntaxIOutlineRange
IOutlineRange object representing current outline section. The method expands or collapses ranges depending on collapsed state of the Range.
See Also

Reference

ICollapsable Interface
ToggleOutlining Overload
Alternet.Editor Namespace


ICollapsable.UnOutline Method

ICollapsableUnOutline Method
Overload List
 | Name | Description
Public method | UnOutline | When implemented by a class, removes all outlined sections from outline collection.
Public method | UnOutline(Point) | When implemented by a class, removes outlined section at the specific position.
Public method | UnOutline(Int32) | When implemented by a class, removes all outline sections containing the given line.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.UnOutline Method

ICollapsableUnOutline Method
When implemented by a class, removes all outlined sections from outline collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnOutline()
Sub UnOutline
void UnOutline()
abstract UnOutline : unit -> unit
See Also

Reference

ICollapsable Interface
UnOutline Overload
Alternet.Editor Namespace


ICollapsable.UnOutline Method (Point)

ICollapsableUnOutline Method (Point)
When implemented by a class, removes outlined section at the specific position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnOutline(
    Point position
)
Sub UnOutline (
    position As Point
)
void UnOutline(
    Point position
)
abstract UnOutline :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position in the text.
See Also

Reference

ICollapsable Interface
UnOutline Overload
Alternet.Editor Namespace


ICollapsable.UnOutline Method (Int32)

ICollapsableUnOutline Method (Int32)
When implemented by a class, removes all outline sections containing the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnOutline(
    int index
)
Sub UnOutline (
    index As Integer
)
void UnOutline(
    int index
)
abstract UnOutline :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies line in the text.
See Also

Reference

ICollapsable Interface
UnOutline Overload
Alternet.Editor Namespace


ICollapsable Properties

ICollapsable Properties

The ICollapsable type exposes the following members.

Properties
 | Name | Description
Public property | AllowOutlining | When implemented by a class, gets or sets a value indicating whether outlining enabled.
Public property | CollapsedCount | When implemented by a class, returns number of collapsed sections.
Public property | OutlineOptions | When implemented by a class, gets or sets outlining options.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.AllowOutlining Property

ICollapsableAllowOutlining Property
When implemented by a class, gets or sets a value indicating whether outlining enabled.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AllowOutlining { get; set; }
Property AllowOutlining As Boolean
    Get
    Set
property bool AllowOutlining {
    bool get ();
    void set (bool value);
}
abstract AllowOutlining : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.CollapsedCount Property

ICollapsableCollapsedCount Property
When implemented by a class, returns number of collapsed sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int CollapsedCount { get; }
ReadOnly Property CollapsedCount As Integer
    Get
property int CollapsedCount {
    int get ();
}
abstract CollapsedCount : int with get

Property Value

Type: Int32
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.OutlineOptions Property

ICollapsableOutlineOptions Property
When implemented by a class, gets or sets outlining options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
OutlineOptions OutlineOptions { get; set; }
Property OutlineOptions As OutlineOptions
    Get
    Set
property OutlineOptions OutlineOptions {
    OutlineOptions get ();
    void set (OutlineOptions value);
}
abstract OutlineOptions : OutlineOptions with get, set

Property Value

Type: OutlineOptions
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable Events

ICollapsable Events

The ICollapsable type exposes the following members.

Events
 | Name | Description
Public event | Collapsing | When implemented by a class, occurs when user attempts collapse outline section.
Public event | Expanding | When implemented by a class, occurs when user attempts expand outline section.
Top
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.Collapsing Event

ICollapsableCollapsing Event
When implemented by a class, occurs when user attempts collapse outline section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event OutlineEvent Collapsing
Event Collapsing As OutlineEvent
 event OutlineEvent^ Collapsing {
    void add (OutlineEvent^ value);
    void remove (OutlineEvent^ value);
}
abstract Collapsing : IEvent<OutlineEvent,
    OutlineEventArgs>

Value

Type: Alternet.EditorOutlineEvent
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


ICollapsable.Expanding Event

ICollapsableExpanding Event
When implemented by a class, occurs when user attempts expand outline section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event OutlineEvent Expanding
Event Expanding As OutlineEvent
 event OutlineEvent^ Expanding {
    void add (OutlineEvent^ value);
    void remove (OutlineEvent^ value);
}
abstract Expanding : IEvent<OutlineEvent,
    OutlineEventArgs>

Value

Type: Alternet.EditorOutlineEvent
See Also

Reference

ICollapsable Interface
Alternet.Editor Namespace


IDisplayStrings Interface

IDisplayStrings Interface
Represents properties and methods for a collection of visible strings in the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDisplayStrings : IStringList,
    IList<string>, ICollection<string>, IEnumerable<string>,
    IEnumerable, IImport, IExport, ITabulation, IWordWrap,
    ITextSearch, IUpdate, IWordBreak, ICollapsable, ITextExport,
    ITextImport
Public Interface IDisplayStrings
    Inherits IStringList, IList(Of String), ICollection(Of String),
    IEnumerable(Of String), IEnumerable, IImport, IExport,
    ITabulation, IWordWrap, ITextSearch, IUpdate, IWordBreak,
    ICollapsable, ITextExport, ITextImport
public interface class IDisplayStrings : IStringList,
    IList<String^>, ICollection<String^>, IEnumerable<String^>,
    IEnumerable, IImport, IExport, ITabulation, IWordWrap,
    ITextSearch, IUpdate, IWordBreak, ICollapsable, ITextExport,
    ITextImport
type IDisplayStrings =
    interface
        interface IStringList
        interface IList<string>
        interface ICollection<string>
        interface IEnumerable<string>
        interface IEnumerable
        interface IImport
        interface IExport
        interface ITabulation
        interface IWordWrap
        interface ITextSearch
        interface IUpdate
        interface IWordBreak
        interface ICollapsable
        interface ITextExport
        interface ITextImport
    end

The IDisplayStrings type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionString.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BlockDeleting | When implemented by a class, responds on deleting some block of lines within the editor control.
Public method | CanCollapse | When implemented in a class, returns boolean value indicating that outline section at given line can be collapsed. (Inherited from ICollapsable.)
Public method | CanExpand(Int32) | When implemented in a class, returns boolean value indicating that outline section at given line can be expanded. (Inherited from ICollapsable.)
Public method | CanExpand(IOutlineRange) | When implemented in a class, returns boolean value indicating that given outline section can be expanded. (Inherited from ICollapsable.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionString.)
Public method | Collapse | When implemented by a class, collapses the specified line. (Inherited from ICollapsable.)
Public method | CollapseToDefinitions | When implemented by a class, collapses and expands some outline section to get a quick overall view of the content. (Inherited from ICollapsable.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionString.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionString.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | DisplayPointToPoint(Point) | When implemented by a class, converts the specified display coordinates to the text coordinates.
Public method | DisplayPointToPoint(Int32, Int32) | When implemented by a class, converts the specified display coordinates to text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean) | When implemented by a class, converts the specified display coordinates to the text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean, Boolean, Boolean) | When implemented by a class, converts the specified display coordinates to the text coordinates.
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | EnsureExpanded(Point) | When implemented by a class, makes all outline sections containing specified position expanded. (Inherited from ICollapsable.)
Public method | EnsureExpanded(Int32) | When implemented by a class, makes all outline sections containing specified line expanded. (Inherited from ICollapsable.)
Public method | Expand | When implemented by a class, expands outline section at the given line. (Inherited from ICollapsable.)
Public method | Find | When implemented by a class, searches for given text within the control's text content. (Inherited from ITextSearch.)
Public method | FullCollapse | When implemented by a class, collapses all outlining sections. (Inherited from ICollapsable.)
Public method | FullCollapse(IListIRange) | When implemented by a class, collapses all sections objects specified by Ranges parameter. (Inherited from ICollapsable.)
Public method | FullExpand | When implemented by a class, expands all outlining sections. (Inherited from ICollapsable.)
Public method | FullExpand(IListIRange) | When implemented by a class, expands all outline sections specified by Ranges parameter. (Inherited from ICollapsable.)
Public method | GetColorData | When implemented by a class, returns color information related to the specified line.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableString.)
Public method | GetIndentString(Int32, Int32) | When implemented by a class, returns indentation string which consist of tabs and spaces. (Inherited from ITabulation.)
Public method | GetIndentString(Int32, Int32, Boolean) | When implemented by a class, returns indentation string which consist of tabs and spaces. (Inherited from ITabulation.)
Public method | GetLexStyle | When implemented by a class, returns lexical style related to the specified position.
Public method | GetOutlineHint | When implemented by a class, returns string that appears in the hint window when mouse pointer is over the outline button. (Inherited from ICollapsable.)
Public method | GetOutlineRange(Point) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position. (Inherited from ICollapsable.)
Public method | GetOutlineRange(Int32) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange) | When implemented by a class, fills list specified by ranges parameter with all existing outline sections. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific position. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Int32) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific line. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Point, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific range. (Inherited from ICollapsable.)
Public method | GetPrevTabStop | When implemented by a class, returns number of spaces to the previous TabStop. (Inherited from ITabulation.)
Public method | GetStringAndColorData | When implemented by a class, returns text and color information related to the specified line.
Public method | GetTabStop | When implemented by a class, returns number of spaces to the next TabStop at the specified position. (Inherited from ITabulation.)
Public method | GetTabString(String) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTabString(String, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTextAt(Point) | When implemented by a class, returns word at the specific text position. (Inherited from IWordBreak.)
Public method | GetTextAt(Int32, Int32) | When implemented by a class, returns word at the specific text position. (Inherited from IWordBreak.)
Public method | GetVisibleLines | When implemented by a class, gets max range containing visible lines
Public method | GetWord(Int32, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32, Char) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWrapMargin | When implemented by a class, returns position of the wrapping margin. (Inherited from IWordWrap.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListString.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListString.)
Public method | IsCollapsed | When implemented by a class, indicates whether the outlined text at the specified line is collapsed. (Inherited from ICollapsable.)
Public method | IsDelimiter(Char) | When implemented by a class, indicates whether the specified character is delimiter character. (Inherited from IWordBreak.)
Public method | IsDelimiter(Int32, Int32) | When implemented by a class, indicates whether the character at the specific position of the string collection is delimiter character. (Inherited from IWordBreak.)
Public method | IsDelimiter(String, Int32) | When implemented by a class, indicates whether the character at the specific position of given string is a delimiter character. (Inherited from IWordBreak.)
Public method | IsExpanded | When implemented by a class, indicates whether the outlined text at the specified line is expanded. (Inherited from ICollapsable.)
Public method | IsPointCollapsed | When implemented by a class, indicates whether given position is in invisible area of the editor control.
Public method | IsPointVisible | When implemented by a class, indicates whether given position is in visible area of the editor control.
Public method | IsVisible(Point) | When implemented by a class, indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position. (Inherited from ICollapsable.)
Public method | IsVisible(Int32) | When implemented by a class, indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line. (Inherited from ICollapsable.)
Public method | IsWhitespace | When implemented by a class, indicates whether the character at the specific position of given string is a whitespace character. (Inherited from IWordBreak.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer. (Inherited from ITextImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding. (Inherited from ITextImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | Notify | When implemented by a class, notifies editor about updating IDisplayStrings state.
Public method | Outline(Point, Point) | When implemented by a class, creates an outlining section based on specific scope within current outlined section. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope within current outlined section. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | PointToDisplayPoint(Point) | When implemented by a class, converts the specified text coordinates to display coordinates.
Public method | PointToDisplayPoint(Int32, Int32) | When implemented by a class, converts the specified text coordinates to display coordinates.
Public method | PointToDisplayPoint(Int32, Int32, Boolean) | When implemented by a class, converts the specified text coordinates to display coordinates.
Public method | PositionChanged | When implemented by a class, responds on changing position in the editor.
Public method | PosToTabPos(String, Int32) | When implemented by a class, returns specified position within given string as tabbed position. (Inherited from ITabulation.)
Public method | PosToTabPos(String, Int32, Boolean) | When implemented by a class, returns specified position within given string as tabbed position. (Inherited from ITabulation.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionString.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListString.)
Public method | ResetAllowOutlining | When implemented by a class, resets AllowOutlining to the default value. (Inherited from ICollapsable.)
Public method | ResetDelimiters | When implemented by a class, resets the Delimiters to the default value. (Inherited from IWordBreak.)
Public method | ResetOutlineOptions | When implemented by a class, resets OutlineOptions to the default value. (Inherited from ICollapsable.)
Public method | ResetTabStops | When implemented by a class, resets the ITabulation.TabStops to the default value. (Inherited from ITabulation.)
Public method | ResetUseSpaces | When implemented by a class, resets the ITabulation.UseSpaces to the default value. (Inherited from ITabulation.)
Public method | ResetWordWrap | When implemented by a class, resets the WordWrap to the default value. (Inherited from IWordWrap.)
Public method | ResetWrapAtMargin | When implemented by a class, resets the WrapAtMargin to the default value. (Inherited from IWordWrap.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter. (Inherited from ITextExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding. (Inherited from ITextExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SetOutlineRanges(IListIRange) | When implemented by a class, updates IOutlineRange collection from given list of ranges. (Inherited from ICollapsable.)
Public method | SetOutlineRanges(IListIRange, Boolean) | When implemented by a class, updates IOutlineRange collection from given list of ranges. (Inherited from ICollapsable.)
Public method | TabPosToPos | When implemented by a class, returns specified position within given string as untabbed position. (Inherited from ITabulation.)
Public method | ToggleOutlining | When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection. (Inherited from ICollapsable.)
Public method | ToggleOutlining(IListIRange, IOutlineRange) | When implemented by a class, toggles expanded state for given IOutlineRange collection. (Inherited from ICollapsable.)
Public method | UnOutline | When implemented by a class, removes all outlined sections from outline collection. (Inherited from ICollapsable.)
Public method | UnOutline(Point) | When implemented by a class, removes outlined section at the specific position. (Inherited from ICollapsable.)
Public method | UnOutline(Int32) | When implemented by a class, removes all outline sections containing the given line. (Inherited from ICollapsable.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | UpdateHiddenLines | When implemented by a class, updates outline ranges for the hidden lines
Public method | UpdateNeeded | When implemented by a class, forces IDisplayStrings to recalculate its content.
Public method | UpdateWordWrap | When implemented by a class, re-wraps all lines in the text. (Inherited from IWordWrap.)
Public method | UpdateWordWrap(Int32, Int32) | When implemented by a class, re-wraps lines in the text within specific scope. (Inherited from IWordWrap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | AllowHiddenLines | Gets or sets a value indicating whether hidden lines are enabled.
Public property | AllowOutlining | When implemented by a class, gets or sets a value indicating whether outlining enabled. (Inherited from ICollapsable.)
Public property | CollapsedCount | When implemented by a class, returns number of collapsed sections. (Inherited from ICollapsable.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionString.)
Public property | Delimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text. (Inherited from IWordBreak.)
Public property | DelimiterString | When implemented by a class, gets or sets Delimiters as a single string. (Inherited from IWordBreak.)
Public property | DisplayCount | When implemented by a class, returns number of visible lines.
Public property | IgnoreWhiteSpace | When implemented by a class, gets or sets boolean value indicating if white space styles are ignored.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionString.)
Public property | Item | When implemented by a class, provides an indexed access to individual strings stored in the collection.
Public property | LineEnd | When implemented by a class, gets or sets boolean value indicating if the text position can be set to the end of the wrapped line.
Public property | Lines | When implemented by a class, gets or sets the collection of underlying "real" collection of text lines.
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | Loaded | When implemented by a class, gets or sets boolean value indicating if the display strings was fully formatted.
Public property | MaxLineWidth | When implemented by a class, gets width of the largest line in the control's text.
Public property | OutlineOptions | When implemented by a class, gets or sets outlining options. (Inherited from ICollapsable.)
Public property | SuppressTabs | When implemented by a class, gets or sets boolean value indicating if conversion from tabs to spaces is suppressed.
Public property | TabStops | When implemented by a class, gets or sets the character columns that the cursor will move to each time you press Tab. (Inherited from ITabulation.)
Public property | Text | When implemented by a class, gets or sets the strings in the IStringList as a single string with the individual strings delimited by carriage returns. (Inherited from IStringList.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UseSpaces | When implemented by a class, gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters. (Inherited from ITabulation.)
Public property | WordWrap | When implemented by a class, gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary. (Inherited from IWordWrap.)
Public property | WrapAtMargin | When implemented by a class, gets or sets a value indicating whether control automatically wraps words at margin position. (Inherited from IWordWrap.)
Public property | WrapMargin | When implemented by a class, gets position of the wrapping margin. (Inherited from IWordWrap.)
Top
Events
 | Name | Description
Public event | Collapsing | When implemented by a class, occurs when user attempts collapse outline section. (Inherited from ICollapsable.)
Public event | Expanding | When implemented by a class, occurs when user attempts expand outline section. (Inherited from ICollapsable.)
Top
See Also

Reference

Alternet.Editor Namespace


IDisplayStrings Methods

IDisplayStrings Methods

The IDisplayStrings type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionString.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BlockDeleting | When implemented by a class, responds on deleting some block of lines within the editor control.
Public method | CanCollapse | When implemented in a class, returns boolean value indicating that outline section at given line can be collapsed. (Inherited from ICollapsable.)
Public method | CanExpand(Int32) | When implemented in a class, returns boolean value indicating that outline section at given line can be expanded. (Inherited from ICollapsable.)
Public method | CanExpand(IOutlineRange) | When implemented in a class, returns boolean value indicating that given outline section can be expanded. (Inherited from ICollapsable.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionString.)
Public method | Collapse | When implemented by a class, collapses the specified line. (Inherited from ICollapsable.)
Public method | CollapseToDefinitions | When implemented by a class, collapses and expands some outline section to get a quick overall view of the content. (Inherited from ICollapsable.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionString.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionString.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | DisplayPointToPoint(Point) | When implemented by a class, converts the specified display coordinates to the text coordinates.
Public method | DisplayPointToPoint(Int32, Int32) | When implemented by a class, converts the specified display coordinates to text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean) | When implemented by a class, converts the specified display coordinates to the text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean, Boolean, Boolean) | When implemented by a class, converts the specified display coordinates to the text coordinates.
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | EnsureExpanded(Point) | When implemented by a class, makes all outline sections containing specified position expanded. (Inherited from ICollapsable.)
Public method | EnsureExpanded(Int32) | When implemented by a class, makes all outline sections containing specified line expanded. (Inherited from ICollapsable.)
Public method | Expand | When implemented by a class, expands outline section at the given line. (Inherited from ICollapsable.)
Public method | Find | When implemented by a class, searches for given text within the control's text content. (Inherited from ITextSearch.)
Public method | FullCollapse | When implemented by a class, collapses all outlining sections. (Inherited from ICollapsable.)
Public method | FullCollapse(IListIRange) | When implemented by a class, collapses all sections objects specified by Ranges parameter. (Inherited from ICollapsable.)
Public method | FullExpand | When implemented by a class, expands all outlining sections. (Inherited from ICollapsable.)
Public method | FullExpand(IListIRange) | When implemented by a class, expands all outline sections specified by Ranges parameter. (Inherited from ICollapsable.)
Public method | GetColorData | When implemented by a class, returns color information related to the specified line.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableString.)
Public method | GetIndentString(Int32, Int32) | When implemented by a class, returns indentation string which consist of tabs and spaces. (Inherited from ITabulation.)
Public method | GetIndentString(Int32, Int32, Boolean) | When implemented by a class, returns indentation string which consist of tabs and spaces. (Inherited from ITabulation.)
Public method | GetLexStyle | When implemented by a class, returns lexical style related to the specified position.
Public method | GetOutlineHint | When implemented by a class, returns string that appears in the hint window when mouse pointer is over the outline button. (Inherited from ICollapsable.)
Public method | GetOutlineRange(Point) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position. (Inherited from ICollapsable.)
Public method | GetOutlineRange(Int32) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange) | When implemented by a class, fills list specified by ranges parameter with all existing outline sections. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific position. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Int32) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific line. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Point, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific range. (Inherited from ICollapsable.)
Public method | GetPrevTabStop | When implemented by a class, returns number of spaces to the previous TabStop. (Inherited from ITabulation.)
Public method | GetStringAndColorData | When implemented by a class, returns text and color information related to the specified line.
Public method | GetTabStop | When implemented by a class, returns number of spaces to the next TabStop at the specified position. (Inherited from ITabulation.)
Public method | GetTabString(String) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTabString(String, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTextAt(Point) | When implemented by a class, returns word at the specific text position. (Inherited from IWordBreak.)
Public method | GetTextAt(Int32, Int32) | When implemented by a class, returns word at the specific text position. (Inherited from IWordBreak.)
Public method | GetVisibleLines | When implemented by a class, gets max range containing visible lines
Public method | GetWord(Int32, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32, Char) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWrapMargin | When implemented by a class, returns position of the wrapping margin. (Inherited from IWordWrap.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListString.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListString.)
Public method | IsCollapsed | When implemented by a class, indicates whether the outlined text at the specified line is collapsed. (Inherited from ICollapsable.)
Public method | IsDelimiter(Char) | When implemented by a class, indicates whether the specified character is delimiter character. (Inherited from IWordBreak.)
Public method | IsDelimiter(Int32, Int32) | When implemented by a class, indicates whether the character at the specific position of the string collection is delimiter character. (Inherited from IWordBreak.)
Public method | IsDelimiter(String, Int32) | When implemented by a class, indicates whether the character at the specific position of given string is a delimiter character. (Inherited from IWordBreak.)
Public method | IsExpanded | When implemented by a class, indicates whether the outlined text at the specified line is expanded. (Inherited from ICollapsable.)
Public method | IsPointCollapsed | When implemented by a class, indicates whether given position is in invisible area of the editor control.
Public method | IsPointVisible | When implemented by a class, indicates whether given position is in visible area of the editor control.
Public method | IsVisible(Point) | When implemented by a class, indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position. (Inherited from ICollapsable.)
Public method | IsVisible(Int32) | When implemented by a class, indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line. (Inherited from ICollapsable.)
Public method | IsWhitespace | When implemented by a class, indicates whether the character at the specific position of given string is a whitespace character. (Inherited from IWordBreak.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer. (Inherited from ITextImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding. (Inherited from ITextImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | Notify | When implemented by a class, notifies editor about updating IDisplayStrings state.
Public method | Outline(Point, Point) | When implemented by a class, creates an outlining section based on specific scope within current outlined section. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope within current outlined section. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | PointToDisplayPoint(Point) | When implemented by a class, converts the specified text coordinates to display coordinates.
Public method | PointToDisplayPoint(Int32, Int32) | When implemented by a class, converts the specified text coordinates to display coordinates.
Public method | PointToDisplayPoint(Int32, Int32, Boolean) | When implemented by a class, converts the specified text coordinates to display coordinates.
Public method | PositionChanged | When implemented by a class, responds on changing position in the editor.
Public method | PosToTabPos(String, Int32) | When implemented by a class, returns specified position within given string as tabbed position. (Inherited from ITabulation.)
Public method | PosToTabPos(String, Int32, Boolean) | When implemented by a class, returns specified position within given string as tabbed position. (Inherited from ITabulation.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionString.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListString.)
Public method | ResetAllowOutlining | When implemented by a class, resets AllowOutlining to the default value. (Inherited from ICollapsable.)
Public method | ResetDelimiters | When implemented by a class, resets the Delimiters to the default value. (Inherited from IWordBreak.)
Public method | ResetOutlineOptions | When implemented by a class, resets OutlineOptions to the default value. (Inherited from ICollapsable.)
Public method | ResetTabStops | When implemented by a class, resets the ITabulation.TabStops to the default value. (Inherited from ITabulation.)
Public method | ResetUseSpaces | When implemented by a class, resets the ITabulation.UseSpaces to the default value. (Inherited from ITabulation.)
Public method | ResetWordWrap | When implemented by a class, resets the WordWrap to the default value. (Inherited from IWordWrap.)
Public method | ResetWrapAtMargin | When implemented by a class, resets the WrapAtMargin to the default value. (Inherited from IWordWrap.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter. (Inherited from ITextExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding. (Inherited from ITextExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SetOutlineRanges(IListIRange) | When implemented by a class, updates IOutlineRange collection from given list of ranges. (Inherited from ICollapsable.)
Public method | SetOutlineRanges(IListIRange, Boolean) | When implemented by a class, updates IOutlineRange collection from given list of ranges. (Inherited from ICollapsable.)
Public method | TabPosToPos | When implemented by a class, returns specified position within given string as untabbed position. (Inherited from ITabulation.)
Public method | ToggleOutlining | When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection. (Inherited from ICollapsable.)
Public method | ToggleOutlining(IListIRange, IOutlineRange) | When implemented by a class, toggles expanded state for given IOutlineRange collection. (Inherited from ICollapsable.)
Public method | UnOutline | When implemented by a class, removes all outlined sections from outline collection. (Inherited from ICollapsable.)
Public method | UnOutline(Point) | When implemented by a class, removes outlined section at the specific position. (Inherited from ICollapsable.)
Public method | UnOutline(Int32) | When implemented by a class, removes all outline sections containing the given line. (Inherited from ICollapsable.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | UpdateHiddenLines | When implemented by a class, updates outline ranges for the hidden lines
Public method | UpdateNeeded | When implemented by a class, forces IDisplayStrings to recalculate its content.
Public method | UpdateWordWrap | When implemented by a class, re-wraps all lines in the text. (Inherited from IWordWrap.)
Public method | UpdateWordWrap(Int32, Int32) | When implemented by a class, re-wraps lines in the text within specific scope. (Inherited from IWordWrap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.BlockDeleting Method

IDisplayStringsBlockDeleting Method
When implemented by a class, responds on deleting some block of lines within the editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BlockDeleting(
    Rectangle rect
)
Sub BlockDeleting (
    rect As Rectangle
)
void BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangle area of block being deleted.
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.DisplayPointToPoint Method

IDisplayStringsDisplayPointToPoint Method
Overload List
 | Name | Description
Public method | DisplayPointToPoint(Point) | When implemented by a class, converts the specified display coordinates to the text coordinates.
Public method | DisplayPointToPoint(Int32, Int32) | When implemented by a class, converts the specified display coordinates to text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean) | When implemented by a class, converts the specified display coordinates to the text coordinates.
Public method | DisplayPointToPoint(Int32, Int32, Boolean, Boolean, Boolean) | When implemented by a class, converts the specified display coordinates to the text coordinates.
Top
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.DisplayPointToPoint Method (Point)

IDisplayStringsDisplayPointToPoint Method (Point)
When implemented by a class, converts the specified display coordinates to the text coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point DisplayPointToPoint(
    Point position
)
Function DisplayPointToPoint (
    position As Point
) As Point
Point DisplayPointToPoint(
    Point position
)
abstract DisplayPointToPoint :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The Point value that specifies the display coordinates to be converted.

Return Value

Type: Point
Text coordinates of specified display point.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

IDisplayStrings Interface
DisplayPointToPoint Overload
Alternet.Editor Namespace


IDisplayStrings.DisplayPointToPoint Method (Int32, Int32)

IDisplayStringsDisplayPointToPoint Method (Int32, Int32)
When implemented by a class, converts the specified display coordinates to text coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point DisplayPointToPoint(
    int x,
    int y
)
Function DisplayPointToPoint (
    x As Integer,
    y As Integer
) As Point
Point DisplayPointToPoint(
    int x,
    int y
)
abstract DisplayPointToPoint :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies the display coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies the display coordinates to be converted.

Return Value

Type: Point
Text coordinates of specified display point.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

IDisplayStrings Interface
DisplayPointToPoint Overload
Alternet.Editor Namespace


IDisplayStrings.DisplayPointToPoint Method (Int32, Int32, Boolean)

IDisplayStringsDisplayPointToPoint Method (Int32, Int32, Boolean)
When implemented by a class, converts the specified display coordinates to the text coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point DisplayPointToPoint(
    int x,
    int y,
    ref bool lineEnd
)
Function DisplayPointToPoint (
    x As Integer,
    y As Integer,
    ByRef lineEnd As Boolean
) As Point
Point DisplayPointToPoint(
    int x,
    int y,
    bool% lineEnd
)
abstract DisplayPointToPoint :
        x : int *
        y : int *
        lineEnd : bool byref -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies display coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies display coordinates to be converted.
lineEnd
Type: SystemBoolean
Receives boolean value indicating if the caret is at the line end of the wrapped line.

Return Value

Type: Point
Text coordinates of specified display point.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

IDisplayStrings Interface
DisplayPointToPoint Overload
Alternet.Editor Namespace


IDisplayStrings.DisplayPointToPoint Method (Int32, Int32, Boolean, Boolean, Boolean)

IDisplayStringsDisplayPointToPoint Method (Int32, Int32, Boolean, Boolean, Boolean)
When implemented by a class, converts the specified display coordinates to the text coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point DisplayPointToPoint(
    int x,
    int y,
    bool wrapEnd,
    bool rangeStart,
    bool tabEnd
)
Function DisplayPointToPoint (
    x As Integer,
    y As Integer,
    wrapEnd As Boolean,
    rangeStart As Boolean,
    tabEnd As Boolean
) As Point
Point DisplayPointToPoint(
    int x,
    int y,
    bool wrapEnd,
    bool rangeStart,
    bool tabEnd
)
abstract DisplayPointToPoint :
        x : int *
        y : int *
        wrapEnd : bool *
        rangeStart : bool *
        tabEnd : bool -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies display coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies display coordinates to be converted.
wrapEnd
Type: SystemBoolean
Reserved for internal use.
rangeStart
Type: SystemBoolean
Reserved for internal use.
tabEnd
Type: SystemBoolean
Reserved for internal use.

Return Value

Type: Point
Text coordinates of specified display point.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

IDisplayStrings Interface
DisplayPointToPoint Overload
Alternet.Editor Namespace


IDisplayStrings.GetColorData Method

IDisplayStringsGetColorData Method
When implemented by a class, returns color information related to the specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
StringItemInfo[] GetColorData(
    int index
)
Function GetColorData (
    index As Integer
) As StringItemInfo()
array<StringItemInfo>^ GetColorData(
    int index
)
abstract GetColorData :
        index : int -> StringItemInfo[]

Parameters

index
Type: SystemInt32
The index of line in strings array.

Return Value

Type: StringItemInfo
Color information of specified line.
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.GetLexStyle Method

IDisplayStringsGetLexStyle Method
When implemented by a class, returns lexical style related to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
StringItemInfo GetLexStyle(
    Point position
)
Function GetLexStyle (
    position As Point
) As StringItemInfo
StringItemInfo GetLexStyle(
    Point position
)
abstract GetLexStyle :
        position : Point -> StringItemInfo

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position to receive lexical style.

Return Value

Type: StringItemInfo
Lexical style at specified position.
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.GetStringAndColorData Method

IDisplayStringsGetStringAndColorData Method
When implemented by a class, returns text and color information related to the specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetStringAndColorData(
    int index,
    ref string text,
    ref StringItemInfo[] data
)
Function GetStringAndColorData (
    index As Integer,
    ByRef text As String,
    ByRef data As StringItemInfo()
) As Integer
int GetStringAndColorData(
    int index,
    String^% text,
    array<StringItemInfo>^% data
)
abstract GetStringAndColorData :
        index : int *
        text : string byref *
        data : StringItemInfo[] byref -> int

Parameters

index
Type: SystemInt32
The index of line in strings array.
text
Type: SystemString
Returns text of the given line.
data
Type: Alternet.SyntaxStringItemInfo
Returns color information of specified line.

Return Value

Type: Int32
Corresponding index within ISyntaxStringscollection.
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.GetVisibleLines Method

IDisplayStringsGetVisibleLines Method
When implemented by a class, gets max range containing visible lines

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetVisibleLines(
    out int first,
    out int last
)
Function GetVisibleLines (
    <OutAttribute> ByRef first As Integer,
    <OutAttribute> ByRef last As Integer
) As Boolean
bool GetVisibleLines(
    [OutAttribute] int% first,
    [OutAttribute] int% last
)
abstract GetVisibleLines :
        first : int byref *
        last : int byref -> bool

Parameters

first
Type: SystemInt32
First visible line
last
Type: SystemInt32
Last visible line

Return Value

Type: Boolean
True if there's any visible lines in the editor; otherwise false
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.IsPointCollapsed Method

IDisplayStringsIsPointCollapsed Method
When implemented by a class, indicates whether given position is in invisible area of the editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPointCollapsed(
    Point position,
    out IRange range
)
Function IsPointCollapsed (
    position As Point,
    <OutAttribute> ByRef range As IRange
) As Boolean
bool IsPointCollapsed(
    Point position,
    [OutAttribute] IRange^% range
)
abstract IsPointCollapsed :
        position : Point *
        range : IRange byref -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.
range
Type: Alternet.CommonIRange
Receives range contains the point. Null if specified position is visible.

Return Value

Type: Boolean
True if position is invisible due to outlining; otherwise false.
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.IsPointVisible Method

IDisplayStringsIsPointVisible Method
When implemented by a class, indicates whether given position is in visible area of the editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPointVisible(
    Point position
)
Function IsPointVisible (
    position As Point
) As Boolean
bool IsPointVisible(
    Point position
)
abstract IsPointVisible :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.

Return Value

Type: Boolean
True if position is invisible; otherwise false.
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.Notify Method

IDisplayStringsNotify Method
When implemented by a class, notifies editor about updating IDisplayStrings state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Notify(
    NotifyState state,
    int first,
    int last
)
Sub Notify (
    state As NotifyState,
    first As Integer,
    last As Integer
)
void Notify(
    NotifyState state,
    int first,
    int last
)
abstract Notify :
        state : NotifyState *
        first : int *
        last : int -> unit

Parameters

state
Type: Alternet.Editor.TextSourceNotifyState
Changes reason.
first
Type: SystemInt32
First changed line.
last
Type: SystemInt32
Last changed line.
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.PointToDisplayPoint Method

IDisplayStringsPointToDisplayPoint Method
Overload List
 | Name | Description
Public method | PointToDisplayPoint(Point) | When implemented by a class, converts the specified text coordinates to display coordinates.
Public method | PointToDisplayPoint(Int32, Int32) | When implemented by a class, converts the specified text coordinates to display coordinates.
Public method | PointToDisplayPoint(Int32, Int32, Boolean) | When implemented by a class, converts the specified text coordinates to display coordinates.
Top
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.PointToDisplayPoint Method (Point)

IDisplayStringsPointToDisplayPoint Method (Point)
When implemented by a class, converts the specified text coordinates to display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point PointToDisplayPoint(
    Point position
)
Function PointToDisplayPoint (
    position As Point
) As Point
Point PointToDisplayPoint(
    Point position
)
abstract PointToDisplayPoint :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The Point value that specifies the text coordinates to be converted.

Return Value

Type: Point
Display coordinates of the specified text point.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

IDisplayStrings Interface
PointToDisplayPoint Overload
Alternet.Editor Namespace


IDisplayStrings.PointToDisplayPoint Method (Int32, Int32)

IDisplayStringsPointToDisplayPoint Method (Int32, Int32)
When implemented by a class, converts the specified text coordinates to display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point PointToDisplayPoint(
    int x,
    int y
)
Function PointToDisplayPoint (
    x As Integer,
    y As Integer
) As Point
Point PointToDisplayPoint(
    int x,
    int y
)
abstract PointToDisplayPoint :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies the text coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies the text coordinates to be converted.

Return Value

Type: Point
Display coordinates of the specified text point.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

IDisplayStrings Interface
PointToDisplayPoint Overload
Alternet.Editor Namespace


IDisplayStrings.PointToDisplayPoint Method (Int32, Int32, Boolean)

IDisplayStringsPointToDisplayPoint Method (Int32, Int32, Boolean)
When implemented by a class, converts the specified text coordinates to display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point PointToDisplayPoint(
    int x,
    int y,
    bool lineEnd
)
Function PointToDisplayPoint (
    x As Integer,
    y As Integer,
    lineEnd As Boolean
) As Point
Point PointToDisplayPoint(
    int x,
    int y,
    bool lineEnd
)
abstract PointToDisplayPoint :
        x : int *
        y : int *
        lineEnd : bool -> Point

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies the text coordinates to be converted.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies the text coordinates to be converted.
lineEnd
Type: SystemBoolean
Boolean value indicating if the text position can be set to the end of the wrapped line.

Return Value

Type: Point
Display coordinates of the specified text point.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

IDisplayStrings Interface
PointToDisplayPoint Overload
Alternet.Editor Namespace


IDisplayStrings.PositionChanged Method

IDisplayStringsPositionChanged Method
When implemented by a class, responds on changing position in the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PositionChanged(
    UpdateReason reason,
    int x,
    int y,
    int deltaX,
    int deltaY
)
Sub PositionChanged (
    reason As UpdateReason,
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
void PositionChanged(
    UpdateReason reason,
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        reason : UpdateReason *
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

reason
Type: Alternet.Editor.TextSourceUpdateReason
Reason of changing position.
x
Type: SystemInt32
X-coordinate of current position.
y
Type: SystemInt32
Y-coordinate of current position.
deltaX
Type: SystemInt32
Horizontal offset.
deltaY
Type: SystemInt32
Vertical offset.
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.UpdateHiddenLines Method

IDisplayStringsUpdateHiddenLines Method
When implemented by a class, updates outline ranges for the hidden lines

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateHiddenLines()
Sub UpdateHiddenLines
void UpdateHiddenLines()
abstract UpdateHiddenLines : unit -> unit
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.UpdateNeeded Method

IDisplayStringsUpdateNeeded Method
When implemented by a class, forces IDisplayStrings to recalculate its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateNeeded()
Sub UpdateNeeded
void UpdateNeeded()
abstract UpdateNeeded : unit -> unit
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings Properties

IDisplayStrings Properties

The IDisplayStrings type exposes the following members.

Properties
 | Name | Description
Public property | AllowHiddenLines | Gets or sets a value indicating whether hidden lines are enabled.
Public property | AllowOutlining | When implemented by a class, gets or sets a value indicating whether outlining enabled. (Inherited from ICollapsable.)
Public property | CollapsedCount | When implemented by a class, returns number of collapsed sections. (Inherited from ICollapsable.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionString.)
Public property | Delimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text. (Inherited from IWordBreak.)
Public property | DelimiterString | When implemented by a class, gets or sets Delimiters as a single string. (Inherited from IWordBreak.)
Public property | DisplayCount | When implemented by a class, returns number of visible lines.
Public property | IgnoreWhiteSpace | When implemented by a class, gets or sets boolean value indicating if white space styles are ignored.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionString.)
Public property | Item | When implemented by a class, provides an indexed access to individual strings stored in the collection.
Public property | LineEnd | When implemented by a class, gets or sets boolean value indicating if the text position can be set to the end of the wrapped line.
Public property | Lines | When implemented by a class, gets or sets the collection of underlying "real" collection of text lines.
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | Loaded | When implemented by a class, gets or sets boolean value indicating if the display strings was fully formatted.
Public property | MaxLineWidth | When implemented by a class, gets width of the largest line in the control's text.
Public property | OutlineOptions | When implemented by a class, gets or sets outlining options. (Inherited from ICollapsable.)
Public property | SuppressTabs | When implemented by a class, gets or sets boolean value indicating if conversion from tabs to spaces is suppressed.
Public property | TabStops | When implemented by a class, gets or sets the character columns that the cursor will move to each time you press Tab. (Inherited from ITabulation.)
Public property | Text | When implemented by a class, gets or sets the strings in the IStringList as a single string with the individual strings delimited by carriage returns. (Inherited from IStringList.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UseSpaces | When implemented by a class, gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters. (Inherited from ITabulation.)
Public property | WordWrap | When implemented by a class, gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary. (Inherited from IWordWrap.)
Public property | WrapAtMargin | When implemented by a class, gets or sets a value indicating whether control automatically wraps words at margin position. (Inherited from IWordWrap.)
Public property | WrapMargin | When implemented by a class, gets position of the wrapping margin. (Inherited from IWordWrap.)
Top
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.AllowHiddenLines Property

IDisplayStringsAllowHiddenLines Property
Gets or sets a value indicating whether hidden lines are enabled.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AllowHiddenLines { get; set; }
Property AllowHiddenLines As Boolean
    Get
    Set
property bool AllowHiddenLines {
    bool get ();
    void set (bool value);
}
abstract AllowHiddenLines : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.DisplayCount Property

IDisplayStringsDisplayCount Property
When implemented by a class, returns number of visible lines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int DisplayCount { get; }
ReadOnly Property DisplayCount As Integer
    Get
property int DisplayCount {
    int get ();
}
abstract DisplayCount : int with get

Property Value

Type: Int32
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.IgnoreWhiteSpace Property

IDisplayStringsIgnoreWhiteSpace Property
When implemented by a class, gets or sets boolean value indicating if white space styles are ignored.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IgnoreWhiteSpace { get; set; }
Property IgnoreWhiteSpace As Boolean
    Get
    Set
property bool IgnoreWhiteSpace {
    bool get ();
    void set (bool value);
}
abstract IgnoreWhiteSpace : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.Item Property

IDisplayStringsItem Property
When implemented by a class, provides an indexed access to individual strings stored in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As String
    Get
property String^ default[int index] {
    String^ get (int index);
}
abstract Item : string with get

Parameters

index
Type: SystemInt32

Property Value

Type: String

Implements

IListTItemInt32
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.LineEnd Property

IDisplayStringsLineEnd Property
When implemented by a class, gets or sets boolean value indicating if the text position can be set to the end of the wrapped line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LineEnd { get; set; }
Property LineEnd As Boolean
    Get
    Set
property bool LineEnd {
    bool get ();
    void set (bool value);
}
abstract LineEnd : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.Lines Property

IDisplayStringsLines Property
When implemented by a class, gets or sets the collection of underlying "real" collection of text lines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ITextStrings Lines { get; set; }
Property Lines As ITextStrings
    Get
    Set
property ITextStrings^ Lines {
    ITextStrings^ get ();
    void set (ITextStrings^ value);
}
abstract Lines : ITextStrings with get, set

Property Value

Type: ITextStrings
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.Loaded Property

IDisplayStringsLoaded Property
When implemented by a class, gets or sets boolean value indicating if the display strings was fully formatted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Loaded { get; set; }
Property Loaded As Boolean
    Get
    Set
property bool Loaded {
    bool get ();
    void set (bool value);
}
abstract Loaded : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.MaxLineWidth Property

IDisplayStringsMaxLineWidth Property
When implemented by a class, gets width of the largest line in the control's text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxLineWidth { get; }
ReadOnly Property MaxLineWidth As Integer
    Get
property int MaxLineWidth {
    int get ();
}
abstract MaxLineWidth : int with get

Property Value

Type: Int32
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings.SuppressTabs Property

IDisplayStringsSuppressTabs Property
When implemented by a class, gets or sets boolean value indicating if conversion from tabs to spaces is suppressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SuppressTabs { get; set; }
Property SuppressTabs As Boolean
    Get
    Set
property bool SuppressTabs {
    bool get ();
    void set (bool value);
}
abstract SuppressTabs : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDisplayStrings Events

IDisplayStrings Events

The IDisplayStrings type exposes the following members.

Events
 | Name | Description
Public event | Collapsing | When implemented by a class, occurs when user attempts collapse outline section. (Inherited from ICollapsable.)
Public event | Expanding | When implemented by a class, occurs when user attempts expand outline section. (Inherited from ICollapsable.)
Top
See Also

Reference

IDisplayStrings Interface
Alternet.Editor Namespace


IDrawInfo Interface

IDrawInfo Interface
Contains full information about text fragment to be drawn.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDrawInfo
Public Interface IDrawInfo
public interface class IDrawInfo
type IDrawInfo =  interface end

The IDrawInfo type exposes the following members.

Methods
 | Name | Description
Public method | Reset | When implemented by a class, resets DrawInfo members to their default values.
Top
Properties
 | Name | Description
Public property | Char | When implemented by a class, specifies a starting character of the text fragment.
Public property | GutterImage | When implemented by a class, specifies an index of the image drawn on the gutter.
Public property | Line | When implemented by a class, specifies an index of line in the text.
Public property | Page | When implemented by a class, specifies index of page containing the text to be drawn.
Public property | Selection | When implemented by a class, specifies whether text fragment is selected.
Public property | Style | When implemented by a class, represents an index of lexical style used to draw this text fragment.
Public property | Text | When implemented by a class, represents a string to draw.
Public property | TextStyle | When implemented by a class, represents a TextStyle information for this text fragment.
Top
See Also

Reference

Alternet.Editor Namespace


IDrawInfo Methods

IDrawInfo Methods

The IDrawInfo type exposes the following members.

Methods
 | Name | Description
Public method | Reset | When implemented by a class, resets DrawInfo members to their default values.
Top
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo.Reset Method

IDrawInfoReset Method
When implemented by a class, resets DrawInfo members to their default values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo Properties

IDrawInfo Properties

The IDrawInfo type exposes the following members.

Properties
 | Name | Description
Public property | Char | When implemented by a class, specifies a starting character of the text fragment.
Public property | GutterImage | When implemented by a class, specifies an index of the image drawn on the gutter.
Public property | Line | When implemented by a class, specifies an index of line in the text.
Public property | Page | When implemented by a class, specifies index of page containing the text to be drawn.
Public property | Selection | When implemented by a class, specifies whether text fragment is selected.
Public property | Style | When implemented by a class, represents an index of lexical style used to draw this text fragment.
Public property | Text | When implemented by a class, represents a string to draw.
Public property | TextStyle | When implemented by a class, represents a TextStyle information for this text fragment.
Top
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo.Char Property

IDrawInfoChar Property
When implemented by a class, specifies a starting character of the text fragment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Char { get; set; }
Property Char As Integer
    Get
    Set
property int Char {
    int get ();
    void set (int value);
}
abstract Char : int with get, set

Property Value

Type: Int32
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo.GutterImage Property

IDrawInfoGutterImage Property
When implemented by a class, specifies an index of the image drawn on the gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GutterImage { get; set; }
Property GutterImage As Integer
    Get
    Set
property int GutterImage {
    int get ();
    void set (int value);
}
abstract GutterImage : int with get, set

Property Value

Type: Int32
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo.Line Property

IDrawInfoLine Property
When implemented by a class, specifies an index of line in the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Line { get; set; }
Property Line As Integer
    Get
    Set
property int Line {
    int get ();
    void set (int value);
}
abstract Line : int with get, set

Property Value

Type: Int32
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo.Page Property

IDrawInfoPage Property
When implemented by a class, specifies index of page containing the text to be drawn.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Page { get; set; }
Property Page As Integer
    Get
    Set
property int Page {
    int get ();
    void set (int value);
}
abstract Page : int with get, set

Property Value

Type: Int32
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo.Selection Property

IDrawInfoSelection Property
When implemented by a class, specifies whether text fragment is selected.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Selection { get; set; }
Property Selection As Boolean
    Get
    Set
property bool Selection {
    bool get ();
    void set (bool value);
}
abstract Selection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo.Style Property

IDrawInfoStyle Property
When implemented by a class, represents an index of lexical style used to draw this text fragment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
StringItemInfo Style { get; set; }
Property Style As StringItemInfo
    Get
    Set
property StringItemInfo Style {
    StringItemInfo get ();
    void set (StringItemInfo value);
}
abstract Style : StringItemInfo with get, set

Property Value

Type: StringItemInfo
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo.Text Property

IDrawInfoText Property
When implemented by a class, represents a string to draw.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IDrawInfo.TextStyle Property

IDrawInfoTextStyle Property
When implemented by a class, represents a TextStyle information for this text fragment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TextStyle TextStyle { get; set; }
Property TextStyle As TextStyle
    Get
    Set
property TextStyle TextStyle {
    TextStyle get ();
    void set (TextStyle value);
}
abstract TextStyle : TextStyle with get, set

Property Value

Type: TextStyle
See Also

Reference

IDrawInfo Interface
Alternet.Editor Namespace


IEditBraceMatching Interface

IEditBraceMatching Interface
Represents extended properties and methods to handle matching braces within the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditBraceMatching : IBraceMatching
Public Interface IEditBraceMatching
    Inherits IBraceMatching
public interface class IEditBraceMatching : IBraceMatching
type IEditBraceMatching =
    interface
        interface IBraceMatching
    end

The IEditBraceMatching type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IEditBraceMatching object.
Public method | FindClosingBrace(Point) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindClosingBrace(Int32, Int32) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Point) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Int32, Int32) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | HighlightBraces | When implemented by a class, highlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | ResetBackColor | When implemented by a class, resets the BackColor to the default value.
Public method | ResetBracesOptions | When implemented by a class, resets the BracesOptions to its default value. (Inherited from IBraceMatching.)
Public method | ResetClosingBraces | When implemented by a class, resets the ClosingBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetFontStyle | When implemented by a class, resets the FontStyle to the default value.
Public method | ResetForeColor | When implemented by a class, resets the ForeColor to the default value.
Public method | ResetOpenBraces | When implemented by a class, resets the OpenBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetUseRoundRect | When implemented by a class, resets the UseRoundRect to the default value.
Public method | TempHighlightBraces | When implemented by a class, temporary highlights all text within the area specified by rects. (Inherited from IBraceMatching.)
Public method | TempUnhighlightBraces | When implemented by a class, cancels text highlighting turned on using TempHighlightBraces (Inherited from IBraceMatching.)
Public method | UnhighlightBraces | When implemented by a class, unhighlights braces containing caret position. (Inherited from IBraceMatching.)
Top
Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets a value that represents background color to draw matching braces.
Public property | BracesOptions | When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control.
Public property | ClosingBraces | When implemented by a class, gets or sets an array of characters each one representing a closing brace.
Public property | FontStyle | When implemented by a class, gets or sets a FontStyle value that is used to draw matching braces.
Public property | ForeColor | When implemented by a class, gets or sets a value that represents foreground color to draw matching braces.
Public property | OpenBraces | When implemented by a class, gets or sets an array of characters each one representing an open brace.
Public property | UseRoundRect | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw rectangle around matching braces.
Top
See Also

Reference

Alternet.Editor Namespace


IEditBraceMatching Methods

IEditBraceMatching Methods

The IEditBraceMatching type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IEditBraceMatching object.
Public method | FindClosingBrace(Point) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindClosingBrace(Int32, Int32) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Point) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Int32, Int32) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | HighlightBraces | When implemented by a class, highlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | ResetBackColor | When implemented by a class, resets the BackColor to the default value.
Public method | ResetBracesOptions | When implemented by a class, resets the BracesOptions to its default value. (Inherited from IBraceMatching.)
Public method | ResetClosingBraces | When implemented by a class, resets the ClosingBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetFontStyle | When implemented by a class, resets the FontStyle to the default value.
Public method | ResetForeColor | When implemented by a class, resets the ForeColor to the default value.
Public method | ResetOpenBraces | When implemented by a class, resets the OpenBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetUseRoundRect | When implemented by a class, resets the UseRoundRect to the default value.
Public method | TempHighlightBraces | When implemented by a class, temporary highlights all text within the area specified by rects. (Inherited from IBraceMatching.)
Public method | TempUnhighlightBraces | When implemented by a class, cancels text highlighting turned on using TempHighlightBraces (Inherited from IBraceMatching.)
Public method | UnhighlightBraces | When implemented by a class, unhighlights braces containing caret position. (Inherited from IBraceMatching.)
Top
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.Assign Method

IEditBraceMatchingAssign Method
When implemented by a class, copies the contents from another IEditBraceMatching object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IEditBraceMatching source
)
Sub Assign (
    source As IEditBraceMatching
)
void Assign(
    IEditBraceMatching^ source
)
abstract Assign :
        source : IEditBraceMatching -> unit

Parameters

source
Type: Alternet.EditorIEditBraceMatching
Specifies IEditBraceMatching to assign.
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.ResetBackColor Method

IEditBraceMatchingResetBackColor Method
When implemented by a class, resets the BackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBackColor()
Sub ResetBackColor
void ResetBackColor()
abstract ResetBackColor : unit -> unit
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.ResetFontStyle Method

IEditBraceMatchingResetFontStyle Method
When implemented by a class, resets the FontStyle to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetFontStyle()
Sub ResetFontStyle
void ResetFontStyle()
abstract ResetFontStyle : unit -> unit
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.ResetForeColor Method

IEditBraceMatchingResetForeColor Method
When implemented by a class, resets the ForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetForeColor()
Sub ResetForeColor
void ResetForeColor()
abstract ResetForeColor : unit -> unit
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.ResetUseRoundRect Method

IEditBraceMatchingResetUseRoundRect Method
When implemented by a class, resets the UseRoundRect to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUseRoundRect()
Sub ResetUseRoundRect
void ResetUseRoundRect()
abstract ResetUseRoundRect : unit -> unit
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching Properties

IEditBraceMatching Properties

The IEditBraceMatching type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets a value that represents background color to draw matching braces.
Public property | BracesOptions | When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control.
Public property | ClosingBraces | When implemented by a class, gets or sets an array of characters each one representing a closing brace.
Public property | FontStyle | When implemented by a class, gets or sets a FontStyle value that is used to draw matching braces.
Public property | ForeColor | When implemented by a class, gets or sets a value that represents foreground color to draw matching braces.
Public property | OpenBraces | When implemented by a class, gets or sets an array of characters each one representing an open brace.
Public property | UseRoundRect | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw rectangle around matching braces.
Top
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.BackColor Property

IEditBraceMatchingBackColor Property
When implemented by a class, gets or sets a value that represents background color to draw matching braces.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; set; }
Property BackColor As Color
    Get
    Set
property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.BracesOptions Property

IEditBraceMatchingBracesOptions Property
When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
BracesOptions BracesOptions { get; set; }
Property BracesOptions As BracesOptions
    Get
    Set
property BracesOptions BracesOptions {
    BracesOptions get ();
    void set (BracesOptions value);
}
abstract BracesOptions : BracesOptions with get, set

Property Value

Type: BracesOptions

Implements

IBraceMatchingBracesOptions
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.ClosingBraces Property

IEditBraceMatchingClosingBraces Property
When implemented by a class, gets or sets an array of characters each one representing a closing brace.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] ClosingBraces { get; set; }
Property ClosingBraces As Char()
    Get
    Set
property array<wchar_t>^ ClosingBraces {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract ClosingBraces : char[] with get, set

Property Value

Type: Char

Implements

IBraceMatchingClosingBraces
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.FontStyle Property

IEditBraceMatchingFontStyle Property
When implemented by a class, gets or sets a FontStyle value that is used to draw matching braces.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
FontStyle FontStyle { get; set; }
Property FontStyle As FontStyle
    Get
    Set
property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract FontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.ForeColor Property

IEditBraceMatchingForeColor Property
When implemented by a class, gets or sets a value that represents foreground color to draw matching braces.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; set; }
Property ForeColor As Color
    Get
    Set
property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.OpenBraces Property

IEditBraceMatchingOpenBraces Property
When implemented by a class, gets or sets an array of characters each one representing an open brace.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] OpenBraces { get; set; }
Property OpenBraces As Char()
    Get
    Set
property array<wchar_t>^ OpenBraces {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract OpenBraces : char[] with get, set

Property Value

Type: Char

Implements

IBraceMatchingOpenBraces
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditBraceMatching.UseRoundRect Property

IEditBraceMatchingUseRoundRect Property
When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw rectangle around matching braces.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseRoundRect { get; set; }
Property UseRoundRect As Boolean
    Get
    Set
property bool UseRoundRect {
    bool get ();
    void set (bool value);
}
abstract UseRoundRect : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditBraceMatching Interface
Alternet.Editor Namespace


IEditHyperText Interface

IEditHyperText Interface
Represents extended properties and methods to operate hypertext section within the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditHyperText : IHyperText
Public Interface IEditHyperText
    Inherits IHyperText
public interface class IEditHyperText : IHyperText
type IEditHyperText =
    interface
        interface IHyperText
    end

The IEditHyperText type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IEditHyperText object.
Public method | IsHyperText | When implemented by a class, indicates whether given text represents hypertext. (Inherited from IHyperText.)
Public method | IsUrlAtPoint(Int32, Int32) | When implemented by a class, indicates whether text at specified position is hypertext.
Public method | IsUrlAtPoint(Int32, Int32, String) | When implemented by a class, indicates whether text at specified position is hypertext.
Public method | IsUrlAtTextPoint | When implemented by a class, indicates whether text at specified position is hypertext.
Public method | ResetHighlightHyperText | When implemented by a class, resets HighlightUrls to the default value. (Inherited from IHyperText.)
Public method | ResetShowHints | When implemented by a class, resets the ShowHints to the default value.
Public method | ResetUrlColor | When implemented by a class, resets the UrlColor to the default value.
Public method | ResetUrlStyle | When implemented by a class, resets the UrlStyle to the default value.
Public method | UrlJump | When implemented by a class, tries to launch default browser to process specified url.
Top
Properties
 | Name | Description
Public property | HighlightHyperText | When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted.
Public property | ShowHints | When implementing by a class, gets or sets value indicating whether default hint for hypertext section needs displaying when user moves mouse over the hypertext.
Public property | UrlColor | When implemented by a class, gets or sets a value that represents color of highlighted urls.
Public property | UrlStyle | When implemented by a class, gets or sets font style of highlighted urls.
Public property | UrlTable | When implemented by a class, represents hash table containing hyper-text characters. (Inherited from IHyperText.)
Top
Events
 | Name | Description
Public event | HyperText | When implemented by a class, occurs when a control needs checking whether some string represents hypertext. (Inherited from IHyperText.)
Public event | JumpToUrl | When implemented by a class, occurs when user attempts to jump to url.
Top
See Also

Reference

Alternet.Editor Namespace
Alternet.Editor.TextSourceIHyperText


IEditHyperText Methods

IEditHyperText Methods

The IEditHyperText type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IEditHyperText object.
Public method | IsHyperText | When implemented by a class, indicates whether given text represents hypertext. (Inherited from IHyperText.)
Public method | IsUrlAtPoint(Int32, Int32) | When implemented by a class, indicates whether text at specified position is hypertext.
Public method | IsUrlAtPoint(Int32, Int32, String) | When implemented by a class, indicates whether text at specified position is hypertext.
Public method | IsUrlAtTextPoint | When implemented by a class, indicates whether text at specified position is hypertext.
Public method | ResetHighlightHyperText | When implemented by a class, resets HighlightUrls to the default value. (Inherited from IHyperText.)
Public method | ResetShowHints | When implemented by a class, resets the ShowHints to the default value.
Public method | ResetUrlColor | When implemented by a class, resets the UrlColor to the default value.
Public method | ResetUrlStyle | When implemented by a class, resets the UrlStyle to the default value.
Public method | UrlJump | When implemented by a class, tries to launch default browser to process specified url.
Top
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.Assign Method

IEditHyperTextAssign Method
When implemented by a class, copies the contents from another IEditHyperText object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IEditHyperText source
)
Sub Assign (
    source As IEditHyperText
)
void Assign(
    IEditHyperText^ source
)
abstract Assign :
        source : IEditHyperText -> unit

Parameters

source
Type: Alternet.EditorIEditHyperText
Specifies IEditHyperText to assign.
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.IsUrlAtPoint Method

IEditHyperTextIsUrlAtPoint Method
Overload List
 | Name | Description
Public method | IsUrlAtPoint(Int32, Int32) | When implemented by a class, indicates whether text at specified position is hypertext.
Public method | IsUrlAtPoint(Int32, Int32, String) | When implemented by a class, indicates whether text at specified position is hypertext.
Top
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.IsUrlAtPoint Method (Int32, Int32)

IEditHyperTextIsUrlAtPoint Method (Int32, Int32)
When implemented by a class, indicates whether text at specified position is hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsUrlAtPoint(
    int x,
    int y
)
Function IsUrlAtPoint (
    x As Integer,
    y As Integer
) As Boolean
bool IsUrlAtPoint(
    int x,
    int y
)
abstract IsUrlAtPoint :
        x : int *
        y : int -> bool

Parameters

x
Type: SystemInt32
The X-constituent of Point value to check.
y
Type: SystemInt32
The Y-constituent of Point value to check.

Return Value

Type: Boolean
True if text at given position is hypertext; otherwise false.
See Also

Reference

IEditHyperText Interface
IsUrlAtPoint Overload
Alternet.Editor Namespace


IEditHyperText.IsUrlAtPoint Method (Int32, Int32, String)

IEditHyperTextIsUrlAtPoint Method (Int32, Int32, String)
When implemented by a class, indicates whether text at specified position is hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsUrlAtPoint(
    int x,
    int y,
    out string url
)
Function IsUrlAtPoint (
    x As Integer,
    y As Integer,
    <OutAttribute> ByRef url As String
) As Boolean
bool IsUrlAtPoint(
    int x,
    int y,
    [OutAttribute] String^% url
)
abstract IsUrlAtPoint :
        x : int *
        y : int *
        url : string byref -> bool

Parameters

x
Type: SystemInt32
The X-constituent of Point value to check.
y
Type: SystemInt32
The Y-constituent of Point value to check.
url
Type: SystemString
Receives text representation of url under text point.

Return Value

Type: Boolean
True if text at given position is hypertext; otherwise false.
See Also

Reference

IEditHyperText Interface
IsUrlAtPoint Overload
Alternet.Editor Namespace


IEditHyperText.IsUrlAtTextPoint Method

IEditHyperTextIsUrlAtTextPoint Method
When implemented by a class, indicates whether text at specified position is hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsUrlAtTextPoint(
    int x,
    int y,
    out string url
)
Function IsUrlAtTextPoint (
    x As Integer,
    y As Integer,
    <OutAttribute> ByRef url As String
) As Boolean
bool IsUrlAtTextPoint(
    int x,
    int y,
    [OutAttribute] String^% url
)
abstract IsUrlAtTextPoint :
        x : int *
        y : int *
        url : string byref -> bool

Parameters

x
Type: SystemInt32
The X-constituent of Point value to check in text coordinates.
y
Type: SystemInt32
The Y-constituent of Point value to check in text coordinates.
url
Type: SystemString
Receives text representation of url under text point.

Return Value

Type: Boolean
True if text at given position is hypertext; otherwise false.
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.ResetShowHints Method

IEditHyperTextResetShowHints Method
When implemented by a class, resets the ShowHints to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetShowHints()
Sub ResetShowHints
void ResetShowHints()
abstract ResetShowHints : unit -> unit
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.ResetUrlColor Method

IEditHyperTextResetUrlColor Method
When implemented by a class, resets the UrlColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUrlColor()
Sub ResetUrlColor
void ResetUrlColor()
abstract ResetUrlColor : unit -> unit
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.ResetUrlStyle Method

IEditHyperTextResetUrlStyle Method
When implemented by a class, resets the UrlStyle to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUrlStyle()
Sub ResetUrlStyle
void ResetUrlStyle()
abstract ResetUrlStyle : unit -> unit
Remarks
Use JumpToUrl to suppress launching default browser.
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.UrlJump Method

IEditHyperTextUrlJump Method
When implemented by a class, tries to launch default browser to process specified url.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UrlJump(
    string text
)
Sub UrlJump (
    text As String
)
void UrlJump(
    String^ text
)
abstract UrlJump :
        text : string -> unit

Parameters

text
Type: SystemString
Specifies name of a document or application file to jump to.
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText Properties

IEditHyperText Properties

The IEditHyperText type exposes the following members.

Properties
 | Name | Description
Public property | HighlightHyperText | When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted.
Public property | ShowHints | When implementing by a class, gets or sets value indicating whether default hint for hypertext section needs displaying when user moves mouse over the hypertext.
Public property | UrlColor | When implemented by a class, gets or sets a value that represents color of highlighted urls.
Public property | UrlStyle | When implemented by a class, gets or sets font style of highlighted urls.
Public property | UrlTable | When implemented by a class, represents hash table containing hyper-text characters. (Inherited from IHyperText.)
Top
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.HighlightHyperText Property

IEditHyperTextHighlightHyperText Property
When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HighlightHyperText { get; set; }
Property HighlightHyperText As Boolean
    Get
    Set
property bool HighlightHyperText {
    bool get ();
    void set (bool value);
}
abstract HighlightHyperText : bool with get, set

Property Value

Type: Boolean

Implements

IHyperTextHighlightHyperText
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.ShowHints Property

IEditHyperTextShowHints Property
When implementing by a class, gets or sets value indicating whether default hint for hypertext section needs displaying when user moves mouse over the hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowHints { get; set; }
Property ShowHints As Boolean
    Get
    Set
property bool ShowHints {
    bool get ();
    void set (bool value);
}
abstract ShowHints : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.UrlColor Property

IEditHyperTextUrlColor Property
When implemented by a class, gets or sets a value that represents color of highlighted urls.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color UrlColor { get; set; }
Property UrlColor As Color
    Get
    Set
property Color UrlColor {
    Color get ();
    void set (Color value);
}
abstract UrlColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.UrlStyle Property

IEditHyperTextUrlStyle Property
When implemented by a class, gets or sets font style of highlighted urls.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
FontStyle UrlStyle { get; set; }
Property UrlStyle As FontStyle
    Get
    Set
property FontStyle UrlStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract UrlStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText Events

IEditHyperText Events

The IEditHyperText type exposes the following members.

Events
 | Name | Description
Public event | HyperText | When implemented by a class, occurs when a control needs checking whether some string represents hypertext. (Inherited from IHyperText.)
Public event | JumpToUrl | When implemented by a class, occurs when user attempts to jump to url.
Top
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditHyperText.JumpToUrl Event

IEditHyperTextJumpToUrl Event
When implemented by a class, occurs when user attempts to jump to url.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event UrlJumpEvent JumpToUrl
Event JumpToUrl As UrlJumpEvent
 event UrlJumpEvent^ JumpToUrl {
    void add (UrlJumpEvent^ value);
    void remove (UrlJumpEvent^ value);
}
abstract JumpToUrl : IEvent<UrlJumpEvent,
    UrlJumpEventArgs>

Value

Type: Alternet.EditorUrlJumpEvent
See Also

Reference

IEditHyperText Interface
Alternet.Editor Namespace


IEditLineStyle Interface

IEditLineStyle Interface
Represents properties and methods for a particular style of the line in Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditLineStyle
Public Interface IEditLineStyle
public interface class IEditLineStyle
type IEditLineStyle =  interface end

The IEditLineStyle type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another ILineStyle object.
Public method | GetBackColor | When implemented by a class, returns BackColor or ForeColor depending on Options.
Public method | GetForeColor | Returns ForeColor or BackColor depending on Options.
Public method | ResetBackColor | When implemented by a class, resets the BackColor to the default value.
Public method | ResetForeColor | When implemented by a class, resets the ForeColor to the default value.
Public method | ResetImageIndex | When implemented by a class, resets the ImageIndex to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ResetPenColor | When implemented by a class, resets the PenColor to the default value.
Top
Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets background color of the IEditLineStyle.
Public property | ForeColor | When implemented by a class, gets or sets foreground color of the IEditLineStyle.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the IEditLineStyle.
Public property | Name | When implemented by a class, gets or sets name of the ILineStyle.
Public property | Options | When implemented by a class, gets or sets display options for the IEditLineStyle.
Public property | PenColor | When implemented by a class, gets or sets pen color of the IEditLineStyle.
Top
See Also

Reference

Alternet.Editor Namespace


IEditLineStyle Methods

IEditLineStyle Methods

The IEditLineStyle type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another ILineStyle object.
Public method | GetBackColor | When implemented by a class, returns BackColor or ForeColor depending on Options.
Public method | GetForeColor | Returns ForeColor or BackColor depending on Options.
Public method | ResetBackColor | When implemented by a class, resets the BackColor to the default value.
Public method | ResetForeColor | When implemented by a class, resets the ForeColor to the default value.
Public method | ResetImageIndex | When implemented by a class, resets the ImageIndex to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ResetPenColor | When implemented by a class, resets the PenColor to the default value.
Top
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.Assign Method

IEditLineStyleAssign Method
When implemented by a class, copies the contents from another ILineStyle object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IEditLineStyle source
)
Sub Assign (
    source As IEditLineStyle
)
void Assign(
    IEditLineStyle^ source
)
abstract Assign :
        source : IEditLineStyle -> unit

Parameters

source
Type: Alternet.EditorIEditLineStyle
Specifies IEditLineStyle to assign.
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.GetBackColor Method

IEditLineStyleGetBackColor Method
When implemented by a class, returns BackColor or ForeColor depending on Options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color GetBackColor(
    Color color
)
Function GetBackColor (
    color As Color
) As Color
Color GetBackColor(
    Color color
)
abstract GetBackColor :
        color : Color -> Color

Parameters

color
Type: System.DrawingColor
Specifies default color to return if BackColor or ForeColor represent empty color.

Return Value

Type: Color
ForeColor if LineStyleOptions.InvertColors is on; otherwise BackColor.
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.GetForeColor Method

IEditLineStyleGetForeColor Method
Returns ForeColor or BackColor depending on Options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color GetForeColor(
    Color color
)
Function GetForeColor (
    color As Color
) As Color
Color GetForeColor(
    Color color
)
abstract GetForeColor :
        color : Color -> Color

Parameters

color
Type: System.DrawingColor
Specifies default color to return if BackColor or ForeColor represent empty color.

Return Value

Type: Color
BackColor if LineStyleOptions.InvertColors is on; otherwise ForeColor.
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.ResetBackColor Method

IEditLineStyleResetBackColor Method
When implemented by a class, resets the BackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBackColor()
Sub ResetBackColor
void ResetBackColor()
abstract ResetBackColor : unit -> unit
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.ResetForeColor Method

IEditLineStyleResetForeColor Method
When implemented by a class, resets the ForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetForeColor()
Sub ResetForeColor
void ResetForeColor()
abstract ResetForeColor : unit -> unit
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.ResetImageIndex Method

IEditLineStyleResetImageIndex Method
When implemented by a class, resets the ImageIndex to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetImageIndex()
Sub ResetImageIndex
void ResetImageIndex()
abstract ResetImageIndex : unit -> unit
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.ResetOptions Method

IEditLineStyleResetOptions Method
When implemented by a class, resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOptions()
Sub ResetOptions
void ResetOptions()
abstract ResetOptions : unit -> unit
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.ResetPenColor Method

IEditLineStyleResetPenColor Method
When implemented by a class, resets the PenColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetPenColor()
Sub ResetPenColor
void ResetPenColor()
abstract ResetPenColor : unit -> unit
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle Properties

IEditLineStyle Properties

The IEditLineStyle type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets background color of the IEditLineStyle.
Public property | ForeColor | When implemented by a class, gets or sets foreground color of the IEditLineStyle.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the IEditLineStyle.
Public property | Name | When implemented by a class, gets or sets name of the ILineStyle.
Public property | Options | When implemented by a class, gets or sets display options for the IEditLineStyle.
Public property | PenColor | When implemented by a class, gets or sets pen color of the IEditLineStyle.
Top
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.BackColor Property

IEditLineStyleBackColor Property
When implemented by a class, gets or sets background color of the IEditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; set; }
Property BackColor As Color
    Get
    Set
property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.ForeColor Property

IEditLineStyleForeColor Property
When implemented by a class, gets or sets foreground color of the IEditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; set; }
Property ForeColor As Color
    Get
    Set
property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.ImageIndex Property

IEditLineStyleImageIndex Property
When implemented by a class, gets or sets the index of the image displayed for the IEditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ImageIndex { get; set; }
Property ImageIndex As Integer
    Get
    Set
property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.Name Property

IEditLineStyleName Property
When implemented by a class, gets or sets name of the ILineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.Options Property

IEditLineStyleOptions Property
When implemented by a class, gets or sets display options for the IEditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
LineStyleOptions Options { get; set; }
Property Options As LineStyleOptions
    Get
    Set
property LineStyleOptions Options {
    LineStyleOptions get ();
    void set (LineStyleOptions value);
}
abstract Options : LineStyleOptions with get, set

Property Value

Type: LineStyleOptions
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyle.PenColor Property

IEditLineStylePenColor Property
When implemented by a class, gets or sets pen color of the IEditLineStyle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color PenColor { get; set; }
Property PenColor As Color
    Get
    Set
property Color PenColor {
    Color get ();
    void set (Color value);
}
abstract PenColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditLineStyle Interface
Alternet.Editor Namespace


IEditLineStyles Interface

IEditLineStyles Interface
Represents properties and methods for a collection of the ILineStyle objects each one specifying a particular style of the line in Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditLineStyles : IList<IEditLineStyle>,
    ICollection<IEditLineStyle>, IEnumerable<IEditLineStyle>, IEnumerable
Public Interface IEditLineStyles
    Inherits IList(Of IEditLineStyle), ICollection(Of IEditLineStyle),
    IEnumerable(Of IEditLineStyle), IEnumerable
public interface class IEditLineStyles : IList<IEditLineStyle^>,
    ICollection<IEditLineStyle^>, IEnumerable<IEditLineStyle^>, IEnumerable
type IEditLineStyles =
    interface
        interface IList<IEditLineStyle>
        interface ICollection<IEditLineStyle>
        interface IEnumerable<IEditLineStyle>
        interface IEnumerable
    end

The IEditLineStyles type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIEditLineStyle .)
Public method | AddLineStyle | When implemented by a class, adds a new ILineStyle to the collection.
Public method | AddLineStyle(String, Color, Color, Color, Int32, LineStyleOptions) | When implemented by a class, adds a new ILineStyle with specified parameters to the collection.
Public method | Assign | When implemented by a class, copies the contents from another IEditLineStyles object.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIEditLineStyle .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIEditLineStyle .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIEditLineStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIEditLineStyle .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIEditLineStyle .)
Public method | IndexOfName | When implemented by a class, returns the zero-based index of the first occurrence of the specified Name in the line style collection.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIEditLineStyle .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIEditLineStyle .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIEditLineStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIEditLineStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIEditLineStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIEditLineStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIEditLineStyle .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIEditLineStyle .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIEditLineStyle .)
Top
See Also

Reference

Alternet.Editor Namespace


IEditLineStyles Methods

IEditLineStyles Methods

The IEditLineStyles type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIEditLineStyle .)
Public method | AddLineStyle | When implemented by a class, adds a new ILineStyle to the collection.
Public method | AddLineStyle(String, Color, Color, Color, Int32, LineStyleOptions) | When implemented by a class, adds a new ILineStyle with specified parameters to the collection.
Public method | Assign | When implemented by a class, copies the contents from another IEditLineStyles object.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIEditLineStyle .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIEditLineStyle .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIEditLineStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIEditLineStyle .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIEditLineStyle .)
Public method | IndexOfName | When implemented by a class, returns the zero-based index of the first occurrence of the specified Name in the line style collection.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIEditLineStyle .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIEditLineStyle .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIEditLineStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIEditLineStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIEditLineStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIEditLineStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IEditLineStyles Interface
Alternet.Editor Namespace


IEditLineStyles.AddLineStyle Method

IEditLineStylesAddLineStyle Method
Overload List
 | Name | Description
Public method | AddLineStyle | When implemented by a class, adds a new ILineStyle to the collection.
Public method | AddLineStyle(String, Color, Color, Color, Int32, LineStyleOptions) | When implemented by a class, adds a new ILineStyle with specified parameters to the collection.
Top
See Also

Reference

IEditLineStyles Interface
Alternet.Editor Namespace


IEditLineStyles.AddLineStyle Method

IEditLineStylesAddLineStyle Method
When implemented by a class, adds a new ILineStyle to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AddLineStyle()
Function AddLineStyle As Integer
int AddLineStyle()
abstract AddLineStyle : unit -> int

Return Value

Type: Int32
Index of the added element.
See Also

Reference

IEditLineStyles Interface
AddLineStyle Overload
Alternet.Editor Namespace


IEditLineStyles.AddLineStyle Method (String, Color, Color, Color, Int32, LineStyleOptions)

IEditLineStylesAddLineStyle Method (String, Color, Color, Color, Int32, LineStyleOptions)
When implemented by a class, adds a new ILineStyle with specified parameters to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AddLineStyle(
    string name,
    Color foreColor,
    Color backColor,
    Color penColor,
    int imageIndex,
    LineStyleOptions options
)
Function AddLineStyle (
    name As String,
    foreColor As Color,
    backColor As Color,
    penColor As Color,
    imageIndex As Integer,
    options As LineStyleOptions
) As Integer
int AddLineStyle(
    String^ name,
    Color foreColor,
    Color backColor,
    Color penColor,
    int imageIndex,
    LineStyleOptions options
)
abstract AddLineStyle :
        name : string *
        foreColor : Color *
        backColor : Color *
        penColor : Color *
        imageIndex : int *
        options : LineStyleOptions -> int

Parameters

name
Type: SystemString
Name of new ILineStyle.
foreColor
Type: System.DrawingColor
Foreground color of new ILineStyle.
backColor
Type: System.DrawingColor
Background color of new ILineStyle.
penColor
Type: System.DrawingColor
Pen color of new ILineStyle.
imageIndex
Type: SystemInt32
Image index of new ILineStyle.
options
Type: Alternet.EditorLineStyleOptions
Options of new ILineStyle.

Return Value

Type: Int32
Index of the added element in the ILineStyle collection.
See Also

Reference

IEditLineStyles Interface
AddLineStyle Overload
Alternet.Editor Namespace


IEditLineStyles.Assign Method

IEditLineStylesAssign Method
When implemented by a class, copies the contents from another IEditLineStyles object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IEditLineStyles source
)
Sub Assign (
    source As IEditLineStyles
)
void Assign(
    IEditLineStyles^ source
)
abstract Assign :
        source : IEditLineStyles -> unit

Parameters

source
Type: Alternet.EditorIEditLineStyles
Specifies IEditLineStyles to assign.
See Also

Reference

IEditLineStyles Interface
Alternet.Editor Namespace


IEditLineStyles.IndexOfName Method

IEditLineStylesIndexOfName Method
When implemented by a class, returns the zero-based index of the first occurrence of the specified Name in the line style collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int IndexOfName(
    string name
)
Function IndexOfName (
    name As String
) As Integer
int IndexOfName(
    String^ name
)
abstract IndexOfName :
        name : string -> int

Parameters

name
Type: SystemString
Name of line style to locate.

Return Value

Type: Int32
Index of the style found.
See Also

Reference

IEditLineStyles Interface
Alternet.Editor Namespace


IEditLineStyles Properties

IEditLineStyles Properties

The IEditLineStyles type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIEditLineStyle .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIEditLineStyle .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIEditLineStyle .)
Top
See Also

Reference

IEditLineStyles Interface
Alternet.Editor Namespace


IEditNavigate Interface

IEditNavigate Interface
Represents additional methods to navigate within the Edit control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditNavigate : INavigate
Public Interface IEditNavigate
    Inherits INavigate
public interface class IEditNavigate : INavigate
type IEditNavigate =
    interface
        interface INavigate
    end

The IEditNavigate type exposes the following members.

Methods
Name Description
Public method DisablePositionUpdate
When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method.
(Inherited from INavigate.)
Public method EnablePositionUpdate
When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
(Inherited from INavigate.)
Public method MoveCharLeft
When implemented by a class, moves the current position one character to the left.
Public method MoveCharRight
When implemented by a class, moves the current position one character to the right.
Public method MoveFileBegin
When implemented by a class, moves the current position to the first character of the first line.
Public method MoveFileEnd
When implemented by a class, moves the current position to the last character of the last line.
Public method MoveLineBegin
When implemented by a class, moves the current position to the first character of current line.
Public method MoveLineBeginCycled
When implemented by a class, moves the current position to the first not whitespace character/first character of current line.
Public method MoveLineDown
When implemented by a class, moves the current position to the next line.
Public method MoveLineEnd
When implemented by a class, moves the current position to the last character of current line.
Public method MoveLineEndCycled
When implemented by a class, moves the current position to the last not whitespace character/last character of current line.
Public method MoveLineUp
When implemented by a class, moves the current position to the previous line.
Public method MovePageDown
When implemented by a class, moves current position to the next page.
Public method MovePageUp
When implemented by a class, moves current position to the previous page.
Public method MoveScreenBottom
When implemented by a class, moves the current position to the bottom of the screen.
Public method MoveScreenTop
When implemented by a class, moves the current position to the top of the screen.
Public method MoveTo(Point)
When implemented by a class, moves the current position to the given position.
(Inherited from INavigate.)
Public method MoveTo(Int32, Int32)
When implemented by a class, moves the current position to the given position.
(Inherited from INavigate.)
Public method MoveToBrace
When implemented by a class, moves the current position to the next open or close brace in the text content.
Public method MoveToChar
When implemented by a class, moves the current position to the specified character in the current line.
(Inherited from INavigate.)
Public method MoveToCloseBrace
When implemented by a class, moves the current position to the next close brace in the text content.
Public method MoveToLine(Int32)
When implemented by a class, moves the current position to the specified line.
(Inherited from INavigate.)
Public method MoveToLine(Int32, Int32)
When implemented by a class, moves the current position to the specified line.
(Inherited from INavigate.)
Public method MoveToOpenBrace
When implemented by a class, moves the current position to the prev open brace in the text content.
Public method MoveWordLeft
When implemented by a class, moves the current position one word to the left.
Public method MoveWordRight
When implemented by a class, moves the current position one word to the right.
Public method Navigate
When implemented by a class, moves current position by the given offset value.
(Inherited from INavigate.)
Public method ProcessEnter
When implemented by a class, performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ProcessShiftTab
When implemented by a class, performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ProcessTab
When implemented by a class, performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ResetNavigateOptions
When implemented by a class, resets the NavigateOptions to the default value.
(Inherited from INavigate.)
Public method RestorePosition
When implemented by a class, restores position from stored position list by given index.
(Inherited from INavigate.)
Public method RestorePositionWithUndo
When implemented by a class, restores position from stored position list by given index.
(Inherited from INavigate.)
Public method ScrollLineDown
When implemented by a class, scrolls text content one line down.
Public method ScrollLineUp
When implemented by a class, scrolls text content one line up.
Public method SetNavigateOptions
When implemented by a class, sets navigating options without validating position.
(Inherited from INavigate.)
Public method StorePosition(Point)
When implemented by a class, stores given position to stored position list.
(Inherited from INavigate.)
Public method StorePosition(Point, Boolean)
When implemented by a class, stores given position to stored position list.
(Inherited from INavigate.)
Public method StorePositionWithUndo
When implemented by a class, stores given position to stored position list preserving it for undo.
(Inherited from INavigate.)
Public method ValidatePosition
When implemented by a class, validates given position within control's text content.
(Inherited from INavigate.)
Top
Properties
 | Name | Description
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options. (Inherited from INavigate.)
Public property | Position | When implemented by a class, gets or sets current position within the control's text content. (Inherited from INavigate.)
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content. (Inherited from INavigate.)
Top
See Also

Reference

Alternet.Editor Namespace


IEditNavigate Methods

IEditNavigate Methods

The IEditNavigate type exposes the following members.

Methods
Name Description
Public method DisablePositionUpdate
When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method.
(Inherited from INavigate.)
Public method EnablePositionUpdate
When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
(Inherited from INavigate.)
Public method MoveCharLeft
When implemented by a class, moves the current position one character to the left.
Public method MoveCharRight
When implemented by a class, moves the current position one character to the right.
Public method MoveFileBegin
When implemented by a class, moves the current position to the first character of the first line.
Public method MoveFileEnd
When implemented by a class, moves the current position to the last character of the last line.
Public method MoveLineBegin
When implemented by a class, moves the current position to the first character of current line.
Public method MoveLineBeginCycled
When implemented by a class, moves the current position to the first not whitespace character/first character of current line.
Public method MoveLineDown
When implemented by a class, moves the current position to the next line.
Public method MoveLineEnd
When implemented by a class, moves the current position to the last character of current line.
Public method MoveLineEndCycled
When implemented by a class, moves the current position to the last not whitespace character/last character of current line.
Public method MoveLineUp
When implemented by a class, moves the current position to the previous line.
Public method MovePageDown
When implemented by a class, moves current position to the next page.
Public method MovePageUp
When implemented by a class, moves current position to the previous page.
Public method MoveScreenBottom
When implemented by a class, moves the current position to the bottom of the screen.
Public method MoveScreenTop
When implemented by a class, moves the current position to the top of the screen.
Public method MoveTo(Point)
When implemented by a class, moves the current position to the given position.
(Inherited from INavigate.)
Public method MoveTo(Int32, Int32)
When implemented by a class, moves the current position to the given position.
(Inherited from INavigate.)
Public method MoveToBrace
When implemented by a class, moves the current position to the next open or close brace in the text content.
Public method MoveToChar
When implemented by a class, moves the current position to the specified character in the current line.
(Inherited from INavigate.)
Public method MoveToCloseBrace
When implemented by a class, moves the current position to the next close brace in the text content.
Public method MoveToLine(Int32)
When implemented by a class, moves the current position to the specified line.
(Inherited from INavigate.)
Public method MoveToLine(Int32, Int32)
When implemented by a class, moves the current position to the specified line.
(Inherited from INavigate.)
Public method MoveToOpenBrace
When implemented by a class, moves the current position to the prev open brace in the text content.
Public method MoveWordLeft
When implemented by a class, moves the current position one word to the left.
Public method MoveWordRight
When implemented by a class, moves the current position one word to the right.
Public method Navigate
When implemented by a class, moves current position by the given offset value.
(Inherited from INavigate.)
Public method ProcessEnter
When implemented by a class, performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ProcessShiftTab
When implemented by a class, performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ProcessTab
When implemented by a class, performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ResetNavigateOptions
When implemented by a class, resets the NavigateOptions to the default value.
(Inherited from INavigate.)
Public method RestorePosition
When implemented by a class, restores position from stored position list by given index.
(Inherited from INavigate.)
Public method RestorePositionWithUndo
When implemented by a class, restores position from stored position list by given index.
(Inherited from INavigate.)
Public method ScrollLineDown
When implemented by a class, scrolls text content one line down.
Public method ScrollLineUp
When implemented by a class, scrolls text content one line up.
Public method SetNavigateOptions
When implemented by a class, sets navigating options without validating position.
(Inherited from INavigate.)
Public method StorePosition(Point)
When implemented by a class, stores given position to stored position list.
(Inherited from INavigate.)
Public method StorePosition(Point, Boolean)
When implemented by a class, stores given position to stored position list.
(Inherited from INavigate.)
Public method StorePositionWithUndo
When implemented by a class, stores given position to stored position list preserving it for undo.
(Inherited from INavigate.)
Public method ValidatePosition
When implemented by a class, validates given position within control's text content.
(Inherited from INavigate.)
Top
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveCharLeft Method

IEditNavigateMoveCharLeft Method
When implemented by a class, moves the current position one character to the left.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveCharLeft()
Sub MoveCharLeft
void MoveCharLeft()
abstract MoveCharLeft : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveCharRight Method

IEditNavigateMoveCharRight Method
When implemented by a class, moves the current position one character to the right.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveCharRight()
Sub MoveCharRight
void MoveCharRight()
abstract MoveCharRight : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveFileBegin Method

IEditNavigateMoveFileBegin Method
When implemented by a class, moves the current position to the first character of the first line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveFileBegin()
Sub MoveFileBegin
void MoveFileBegin()
abstract MoveFileBegin : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveFileEnd Method

IEditNavigateMoveFileEnd Method
When implemented by a class, moves the current position to the last character of the last line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveFileEnd()
Sub MoveFileEnd
void MoveFileEnd()
abstract MoveFileEnd : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveLineBegin Method

IEditNavigateMoveLineBegin Method
When implemented by a class, moves the current position to the first character of current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveLineBegin()
Sub MoveLineBegin
void MoveLineBegin()
abstract MoveLineBegin : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveLineBeginCycled Method

IEditNavigateMoveLineBeginCycled Method
When implemented by a class, moves the current position to the first not whitespace character/first character of current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveLineBeginCycled()
Sub MoveLineBeginCycled
void MoveLineBeginCycled()
abstract MoveLineBeginCycled : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveLineDown Method

IEditNavigateMoveLineDown Method
When implemented by a class, moves the current position to the next line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveLineDown()
Sub MoveLineDown
void MoveLineDown()
abstract MoveLineDown : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveLineEnd Method

IEditNavigateMoveLineEnd Method
When implemented by a class, moves the current position to the last character of current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveLineEnd()
Sub MoveLineEnd
void MoveLineEnd()
abstract MoveLineEnd : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveLineEndCycled Method

IEditNavigateMoveLineEndCycled Method
When implemented by a class, moves the current position to the last not whitespace character/last character of current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveLineEndCycled()
Sub MoveLineEndCycled
void MoveLineEndCycled()
abstract MoveLineEndCycled : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveLineUp Method

IEditNavigateMoveLineUp Method
When implemented by a class, moves the current position to the previous line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveLineUp()
Sub MoveLineUp
void MoveLineUp()
abstract MoveLineUp : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MovePageDown Method

IEditNavigateMovePageDown Method
When implemented by a class, moves current position to the next page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MovePageDown()
Sub MovePageDown
void MovePageDown()
abstract MovePageDown : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MovePageUp Method

IEditNavigateMovePageUp Method
When implemented by a class, moves current position to the previous page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MovePageUp()
Sub MovePageUp
void MovePageUp()
abstract MovePageUp : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveScreenBottom Method

IEditNavigateMoveScreenBottom Method
When implemented by a class, moves the current position to the bottom of the screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveScreenBottom()
Sub MoveScreenBottom
void MoveScreenBottom()
abstract MoveScreenBottom : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveScreenTop Method

IEditNavigateMoveScreenTop Method
When implemented by a class, moves the current position to the top of the screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveScreenTop()
Sub MoveScreenTop
void MoveScreenTop()
abstract MoveScreenTop : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveToBrace Method

IEditNavigateMoveToBrace Method
When implemented by a class, moves the current position to the next open or close brace in the text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveToBrace()
Sub MoveToBrace
void MoveToBrace()
abstract MoveToBrace : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveToCloseBrace Method

IEditNavigateMoveToCloseBrace Method
When implemented by a class, moves the current position to the next close brace in the text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveToCloseBrace()
Sub MoveToCloseBrace
void MoveToCloseBrace()
abstract MoveToCloseBrace : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveToOpenBrace Method

IEditNavigateMoveToOpenBrace Method
When implemented by a class, moves the current position to the prev open brace in the text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveToOpenBrace()
Sub MoveToOpenBrace
void MoveToOpenBrace()
abstract MoveToOpenBrace : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveWordLeft Method

IEditNavigateMoveWordLeft Method
When implemented by a class, moves the current position one word to the left.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveWordLeft()
Sub MoveWordLeft
void MoveWordLeft()
abstract MoveWordLeft : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.MoveWordRight Method

IEditNavigateMoveWordRight Method
When implemented by a class, moves the current position one word to the right.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveWordRight()
Sub MoveWordRight
void MoveWordRight()
abstract MoveWordRight : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.ProcessEnter Method

IEditNavigateProcessEnter Method
When implemented by a class, performs specific actions when Enter key is pressed.

Return Value

Type: Boolean
True if key was processed; otherwise false.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessEnter()
Function ProcessEnter As Boolean
bool ProcessEnter()
abstract ProcessEnter : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.ProcessShiftTab Method

IEditNavigateProcessShiftTab Method
When implemented by a class, performs specific actions when Shift + Tab key is pressed.

Return Value

Type: Boolean
True if key was processed; otherwise false.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessShiftTab(
    Point position
)
Function ProcessShiftTab (
    position As Point
) As Boolean
bool ProcessShiftTab(
    Point position
)
abstract ProcessShiftTab :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.ProcessTab Method

IEditNavigateProcessTab Method
When implemented by a class, performs specific actions when Tab key is pressed.

Return Value

Type: Boolean
True if key was processed; otherwise false.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessTab(
    Point position
)
Function ProcessTab (
    position As Point
) As Boolean
bool ProcessTab(
    Point position
)
abstract ProcessTab :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.ScrollLineDown Method

IEditNavigateScrollLineDown Method
When implemented by a class, scrolls text content one line down.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollLineDown()
Sub ScrollLineDown
void ScrollLineDown()
abstract ScrollLineDown : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate.ScrollLineUp Method

IEditNavigateScrollLineUp Method
When implemented by a class, scrolls text content one line up.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollLineUp()
Sub ScrollLineUp
void ScrollLineUp()
abstract ScrollLineUp : unit -> unit
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNavigate Properties

IEditNavigate Properties

The IEditNavigate type exposes the following members.

Properties
 | Name | Description
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options. (Inherited from INavigate.)
Public property | Position | When implemented by a class, gets or sets current position within the control's text content. (Inherited from INavigate.)
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content. (Inherited from INavigate.)
Top
See Also

Reference

IEditNavigate Interface
Alternet.Editor Namespace


IEditNotifier Interface

IEditNotifier Interface
Represents method that informs editor object about changes in linked objects.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditNotifier : INotifier
Public Interface IEditNotifier
    Inherits INotifier
public interface class IEditNotifier : INotifier
type IEditNotifier =
    interface
        interface INotifier
    end

The IEditNotifier type exposes the following members.

Methods
 | Name | Description
Public method | Notification | When implemented by a class, updates control's content according to the parameters of notification. (Inherited from INotifier.)
Public method | OnStateChanged | When implemented by a class, updates editor control's content according to the parameters of notification.
Top
See Also

Reference

Alternet.Editor Namespace


IEditNotifier Methods

IEditNotifier Methods

The IEditNotifier type exposes the following members.

Methods
 | Name | Description
Public method | Notification | When implemented by a class, updates control's content according to the parameters of notification. (Inherited from INotifier.)
Public method | OnStateChanged | When implemented by a class, updates editor control's content according to the parameters of notification.
Top
See Also

Reference

IEditNotifier Interface
Alternet.Editor Namespace


IEditNotifier.OnStateChanged Method

IEditNotifierOnStateChanged Method
When implemented by a class, updates editor control's content according to the parameters of notification.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnStateChanged(
    Object sender,
    NotifyState state
)
Sub OnStateChanged (
    sender As Object,
    state As NotifyState
)
void OnStateChanged(
    Object^ sender,
    NotifyState state
)
abstract OnStateChanged :
        sender : Object *
        state : NotifyState -> unit

Parameters

sender
Type: SystemObject
The source of the notification.
state
Type: Alternet.Editor.TextSourceNotifyState
Reason of changes.
See Also

Reference

IEditNotifier Interface
Alternet.Editor Namespace


IEditNotify Interface

IEditNotify Interface
Represents extended properties and methods to manage notification between objects.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditNotify : INotify,
    IUpdate
Public Interface IEditNotify
    Inherits INotify, IUpdate
public interface class IEditNotify : INotify,
    IUpdate
type IEditNotify =
    interface
        interface INotify
        interface IUpdate
    end

The IEditNotify type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | FirstChanged | When implemented by a class, represents index of the first changed line.
Public property | LastChanged | When implemented by a class, represents index of the last changed line.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

Alternet.Editor Namespace


IEditNotify Methods

IEditNotify Methods

The IEditNotify type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

IEditNotify Interface
Alternet.Editor Namespace


IEditNotify Properties

IEditNotify Properties

The IEditNotify type exposes the following members.

Properties
 | Name | Description
Public property | FirstChanged | When implemented by a class, represents index of the first changed line.
Public property | LastChanged | When implemented by a class, represents index of the last changed line.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

IEditNotify Interface
Alternet.Editor Namespace


IEditNotify.FirstChanged Property

IEditNotifyFirstChanged Property
When implemented by a class, represents index of the first changed line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FirstChanged { get; }
ReadOnly Property FirstChanged As Integer
    Get
property int FirstChanged {
    int get ();
}
abstract FirstChanged : int with get

Property Value

Type: Int32
See Also

Reference

IEditNotify Interface
Alternet.Editor Namespace


IEditNotify.LastChanged Property

IEditNotifyLastChanged Property
When implemented by a class, represents index of the last changed line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LastChanged { get; }
ReadOnly Property LastChanged As Integer
    Get
property int LastChanged {
    int get ();
}
abstract LastChanged : int with get

Property Value

Type: Int32
See Also

Reference

IEditNotify Interface
Alternet.Editor Namespace


IEditPage Interface

IEditPage Interface
Represents properties and methods to describe and manipulate with a particular page within Edit control content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditPage : IUpdate,
    IDisposable
Public Interface IEditPage
    Inherits IUpdate, IDisposable
public interface class IEditPage : IUpdate,
    IDisposable
type IEditPage =
    interface
        interface IUpdate
        interface IDisposable
    end

The IEditPage type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IEditPage object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | GetBounds | When implemented by a class, retrieves a bounds of the IEditPage.
Public method | Invalidate | When implemented by a class, invalidates the page.
Public method | Paint | When implemented by a class, draws IEditPage object on specified graphic surface.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | Update(Int32, Int32, Point) | When implemented by a class, updates IEditPage state in accordance with specified parameters.
Top
Properties
 | Name | Description
Public property | BottomIndent | When implemented by a class, gets or sets page's bottom indentation.
Public property | BoundsRect | When implemented by a class, represents a bounding area of the page within the Edit control.
Public property | ClientRect | When implemented by a class, represents a client(editing) area of the page within Edit control.
Public property | DisplayWidth | When implemented by a class, returns displayed page width.
Public property | EndLine | When implemented by a class, represents ending line of the page within Edit control content in display coordinates.
Public property | Footer | When implemented by a class, represents IPageHeader specifying page footer.
Public property | Header | When implemented by a class, represents IPageHeader specifying page header.
Public property | HorzOffset | When implemented by a class, gets or sets a horizontal indentation between pages.
Public property | Index | When implemented by a class, represents ordinal number of page within the Edit control pages collection.
Public property | IsFirstPage | When implemented by a class, indicates whether this page is the first page within the Edit control pages collection.
Public property | IsLastPage | When implemented by a class, indicates whether this page is the last page within the Edit control pages collection.
Public property | Landscape | When implemented by a class, gets or sets boolean value that indicates the page orientation (landscape or portrait).
Public property | LeftIndent | When implemented by a class, gets or sets page's left indentation.
Public property | Margins | When implemented by a class, gets or sets margins specifying offsets of editing area of this IEditPage.
Public property | NextPage | When implemented by a class, represents a next IEditPage within the Edit control pages collection.
Public property | Origin | When implemented by a class, represents page's absolute screen coordinate of the page within Edit control.
Public property | PageKind | When implemented by a class, gets or sets kind of the page specifying standard paper size.
Public property | PageRect | When implemented by a class, gets page's rectangle.
Public property | Pages | When implemented by a class, gets or sets pages collection that owns this page.
Public property | PageSize | When implemented by a class, gets or sets size (width and height) of this IEditPage.
Public property | PaintNumber | When implemented by a class, get or sets a boolean value that indicates whether control should paint it's number at the bottom of page.
Public property | PrevPage | When implemented by a class, represents a previous IEditPage within the Edit control pages collection.
Public property | RightIndent | When implemented by a class, gets or sets page's right indentation.
Public property | StartLine | When implemented by a class, represents starting line of the page within Edit control content in display coordinates.
Public property | TopIndent | When implemented by a class, gets or sets page's top indentation.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UsePrinterSettings | When implemented by a class, get or sets a boolean value that indicates whether control should use printer settings for calculating page size, margin and orientation.
Public property | VertOffset | When implemented by a class, gets or sets a vertical indentation between pages.
Public property | WhiteSpaceBottomRect | When implemented by a class, represents a whitespace area of the page within Edit control.
Public property | WhiteSpaceTopRect | When implemented by a class, represents a whitespace area of the page within Edit control.
Top
See Also

Reference

Alternet.Editor Namespace


IEditPage Methods

IEditPage Methods

The IEditPage type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IEditPage object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | GetBounds | When implemented by a class, retrieves a bounds of the IEditPage.
Public method | Invalidate | When implemented by a class, invalidates the page.
Public method | Paint | When implemented by a class, draws IEditPage object on specified graphic surface.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | Update(Int32, Int32, Point) | When implemented by a class, updates IEditPage state in accordance with specified parameters.
Top
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Assign Method

IEditPageAssign Method
When implemented by a class, copies the contents of another IEditPage object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IEditPage source
)
Sub Assign (
    source As IEditPage
)
void Assign(
    IEditPage^ source
)
abstract Assign :
        source : IEditPage -> unit

Parameters

source
Type: Alternet.EditorIEditPage
Specifies IEditPage to assign.
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.GetBounds Method

IEditPageGetBounds Method
When implemented by a class, retrieves a bounds of the IEditPage.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle GetBounds(
    bool includeSpace
)
Function GetBounds (
    includeSpace As Boolean
) As Rectangle
Rectangle GetBounds(
    bool includeSpace
)
abstract GetBounds :
        includeSpace : bool -> Rectangle

Parameters

includeSpace
Type: SystemBoolean
Specifies whether to include whitespace area.

Return Value

Type: Rectangle
Rectangle that bounded this IEditPage.
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Invalidate Method

IEditPageInvalidate Method
When implemented by a class, invalidates the page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Invalidate()
Sub Invalidate
void Invalidate()
abstract Invalidate : unit -> unit
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Paint Method

IEditPagePaint Method
When implemented by a class, draws IEditPage object on specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Paint(
    IPainter painter
)
Sub Paint (
    painter As IPainter
)
void Paint(
    IPainter^ painter
)
abstract Paint :
        painter : IPainter -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Update Method

IEditPageUpdate Method
Overload List
 | Name | Description
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | Update(Int32, Int32, Point) | When implemented by a class, updates IEditPage state in accordance with specified parameters.
Top
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Update Method (Int32, Int32, Point)

IEditPageUpdate Method (Int32, Int32, Point)
When implemented by a class, updates IEditPage state in accordance with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Update(
    int startLine,
    int endLine,
    Point origin
)
Sub Update (
    startLine As Integer,
    endLine As Integer,
    origin As Point
)
void Update(
    int startLine,
    int endLine,
    Point origin
)
abstract Update :
        startLine : int *
        endLine : int *
        origin : Point -> unit

Parameters

startLine
Type: SystemInt32
New page's start line.
endLine
Type: SystemInt32
New page's end line.
origin
Type: System.DrawingPoint
New page's origin.
See Also

Reference

IEditPage Interface
Update Overload
Alternet.Editor Namespace


IEditPage Properties

IEditPage Properties

The IEditPage type exposes the following members.

Properties
 | Name | Description
Public property | BottomIndent | When implemented by a class, gets or sets page's bottom indentation.
Public property | BoundsRect | When implemented by a class, represents a bounding area of the page within the Edit control.
Public property | ClientRect | When implemented by a class, represents a client(editing) area of the page within Edit control.
Public property | DisplayWidth | When implemented by a class, returns displayed page width.
Public property | EndLine | When implemented by a class, represents ending line of the page within Edit control content in display coordinates.
Public property | Footer | When implemented by a class, represents IPageHeader specifying page footer.
Public property | Header | When implemented by a class, represents IPageHeader specifying page header.
Public property | HorzOffset | When implemented by a class, gets or sets a horizontal indentation between pages.
Public property | Index | When implemented by a class, represents ordinal number of page within the Edit control pages collection.
Public property | IsFirstPage | When implemented by a class, indicates whether this page is the first page within the Edit control pages collection.
Public property | IsLastPage | When implemented by a class, indicates whether this page is the last page within the Edit control pages collection.
Public property | Landscape | When implemented by a class, gets or sets boolean value that indicates the page orientation (landscape or portrait).
Public property | LeftIndent | When implemented by a class, gets or sets page's left indentation.
Public property | Margins | When implemented by a class, gets or sets margins specifying offsets of editing area of this IEditPage.
Public property | NextPage | When implemented by a class, represents a next IEditPage within the Edit control pages collection.
Public property | Origin | When implemented by a class, represents page's absolute screen coordinate of the page within Edit control.
Public property | PageKind | When implemented by a class, gets or sets kind of the page specifying standard paper size.
Public property | PageRect | When implemented by a class, gets page's rectangle.
Public property | Pages | When implemented by a class, gets or sets pages collection that owns this page.
Public property | PageSize | When implemented by a class, gets or sets size (width and height) of this IEditPage.
Public property | PaintNumber | When implemented by a class, get or sets a boolean value that indicates whether control should paint it's number at the bottom of page.
Public property | PrevPage | When implemented by a class, represents a previous IEditPage within the Edit control pages collection.
Public property | RightIndent | When implemented by a class, gets or sets page's right indentation.
Public property | StartLine | When implemented by a class, represents starting line of the page within Edit control content in display coordinates.
Public property | TopIndent | When implemented by a class, gets or sets page's top indentation.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UsePrinterSettings | When implemented by a class, get or sets a boolean value that indicates whether control should use printer settings for calculating page size, margin and orientation.
Public property | VertOffset | When implemented by a class, gets or sets a vertical indentation between pages.
Public property | WhiteSpaceBottomRect | When implemented by a class, represents a whitespace area of the page within Edit control.
Public property | WhiteSpaceTopRect | When implemented by a class, represents a whitespace area of the page within Edit control.
Top
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.BottomIndent Property

IEditPageBottomIndent Property
When implemented by a class, gets or sets page's bottom indentation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int BottomIndent { get; set; }
Property BottomIndent As Integer
    Get
    Set
property int BottomIndent {
    int get ();
    void set (int value);
}
abstract BottomIndent : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.BoundsRect Property

IEditPageBoundsRect Property
When implemented by a class, represents a bounding area of the page within the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle BoundsRect { get; }
ReadOnly Property BoundsRect As Rectangle
    Get
property Rectangle BoundsRect {
    Rectangle get ();
}
abstract BoundsRect : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.ClientRect Property

IEditPageClientRect Property
When implemented by a class, represents a client(editing) area of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle ClientRect { get; }
ReadOnly Property ClientRect As Rectangle
    Get
property Rectangle ClientRect {
    Rectangle get ();
}
abstract ClientRect : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.DisplayWidth Property

IEditPageDisplayWidth Property
When implemented by a class, returns displayed page width.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int DisplayWidth { get; }
ReadOnly Property DisplayWidth As Integer
    Get
property int DisplayWidth {
    int get ();
}
abstract DisplayWidth : int with get

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.EndLine Property

IEditPageEndLine Property
When implemented by a class, represents ending line of the page within Edit control content in display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int EndLine { get; }
ReadOnly Property EndLine As Integer
    Get
property int EndLine {
    int get ();
}
abstract EndLine : int with get

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Footer Property

IEditPageFooter Property
When implemented by a class, represents IPageHeader specifying page footer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPageHeader Footer { get; set; }
Property Footer As IEditPageHeader
    Get
    Set
property IEditPageHeader^ Footer {
    IEditPageHeader^ get ();
    void set (IEditPageHeader^ value);
}
abstract Footer : IEditPageHeader with get, set

Property Value

Type: IEditPageHeader
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Header Property

IEditPageHeader Property
When implemented by a class, represents IPageHeader specifying page header.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPageHeader Header { get; set; }
Property Header As IEditPageHeader
    Get
    Set
property IEditPageHeader^ Header {
    IEditPageHeader^ get ();
    void set (IEditPageHeader^ value);
}
abstract Header : IEditPageHeader with get, set

Property Value

Type: IEditPageHeader
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.HorzOffset Property

IEditPageHorzOffset Property
When implemented by a class, gets or sets a horizontal indentation between pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int HorzOffset { get; set; }
Property HorzOffset As Integer
    Get
    Set
property int HorzOffset {
    int get ();
    void set (int value);
}
abstract HorzOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Index Property

IEditPageIndex Property
When implemented by a class, represents ordinal number of page within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.IsFirstPage Property

IEditPageIsFirstPage Property
When implemented by a class, indicates whether this page is the first page within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsFirstPage { get; }
ReadOnly Property IsFirstPage As Boolean
    Get
property bool IsFirstPage {
    bool get ();
}
abstract IsFirstPage : bool with get

Property Value

Type: Boolean
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.IsLastPage Property

IEditPageIsLastPage Property
When implemented by a class, indicates whether this page is the last page within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsLastPage { get; }
ReadOnly Property IsLastPage As Boolean
    Get
property bool IsLastPage {
    bool get ();
}
abstract IsLastPage : bool with get

Property Value

Type: Boolean
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Landscape Property

IEditPageLandscape Property
When implemented by a class, gets or sets boolean value that indicates the page orientation (landscape or portrait).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Landscape { get; set; }
Property Landscape As Boolean
    Get
    Set
property bool Landscape {
    bool get ();
    void set (bool value);
}
abstract Landscape : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.LeftIndent Property

IEditPageLeftIndent Property
When implemented by a class, gets or sets page's left indentation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LeftIndent { get; set; }
Property LeftIndent As Integer
    Get
    Set
property int LeftIndent {
    int get ();
    void set (int value);
}
abstract LeftIndent : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Margins Property

IEditPageMargins Property
When implemented by a class, gets or sets margins specifying offsets of editing area of this IEditPage.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Margins Margins { get; set; }
Property Margins As Margins
    Get
    Set
property Margins^ Margins {
    Margins^ get ();
    void set (Margins^ value);
}
abstract Margins : Margins with get, set

Property Value

Type: Margins
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.NextPage Property

IEditPageNextPage Property
When implemented by a class, represents a next IEditPage within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage NextPage { get; }
ReadOnly Property NextPage As IEditPage
    Get
property IEditPage^ NextPage {
    IEditPage^ get ();
}
abstract NextPage : IEditPage with get

Property Value

Type: IEditPage
Remarks
Returns null if the page represents the last page.
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Origin Property

IEditPageOrigin Property
When implemented by a class, represents page's absolute screen coordinate of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Origin { get; }
ReadOnly Property Origin As Point
    Get
property Point Origin {
    Point get ();
}
abstract Origin : Point with get

Property Value

Type: Point
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.PageKind Property

IEditPagePageKind Property
When implemented by a class, gets or sets kind of the page specifying standard paper size.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PaperKind PageKind { get; set; }
Property PageKind As PaperKind
    Get
    Set
property PaperKind PageKind {
    PaperKind get ();
    void set (PaperKind value);
}
abstract PageKind : PaperKind with get, set

Property Value

Type: PaperKind
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.PageRect Property

IEditPagePageRect Property
When implemented by a class, gets page's rectangle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle PageRect { get; }
ReadOnly Property PageRect As Rectangle
    Get
property Rectangle PageRect {
    Rectangle get ();
}
abstract PageRect : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.Pages Property

IEditPagePages Property
When implemented by a class, gets or sets pages collection that owns this page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPages Pages { get; set; }
Property Pages As IEditPages
    Get
    Set
property IEditPages^ Pages {
    IEditPages^ get ();
    void set (IEditPages^ value);
}
abstract Pages : IEditPages with get, set

Property Value

Type: IEditPages
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.PageSize Property

IEditPagePageSize Property
When implemented by a class, gets or sets size (width and height) of this IEditPage.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Size PageSize { get; set; }
Property PageSize As Size
    Get
    Set
property Size PageSize {
    Size get ();
    void set (Size value);
}
abstract PageSize : Size with get, set

Property Value

Type: Size
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.PaintNumber Property

IEditPagePaintNumber Property
When implemented by a class, get or sets a boolean value that indicates whether control should paint it's number at the bottom of page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PaintNumber { get; set; }
Property PaintNumber As Boolean
    Get
    Set
property bool PaintNumber {
    bool get ();
    void set (bool value);
}
abstract PaintNumber : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.PrevPage Property

IEditPagePrevPage Property
When implemented by a class, represents a previous IEditPage within the Edit control pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage PrevPage { get; }
ReadOnly Property PrevPage As IEditPage
    Get
property IEditPage^ PrevPage {
    IEditPage^ get ();
}
abstract PrevPage : IEditPage with get

Property Value

Type: IEditPage
Remarks
Returns null if the page represents the first page.
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.RightIndent Property

IEditPageRightIndent Property
When implemented by a class, gets or sets page's right indentation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int RightIndent { get; set; }
Property RightIndent As Integer
    Get
    Set
property int RightIndent {
    int get ();
    void set (int value);
}
abstract RightIndent : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.StartLine Property

IEditPageStartLine Property
When implemented by a class, represents starting line of the page within Edit control content in display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int StartLine { get; }
ReadOnly Property StartLine As Integer
    Get
property int StartLine {
    int get ();
}
abstract StartLine : int with get

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.TopIndent Property

IEditPageTopIndent Property
When implemented by a class, gets or sets page's top indentation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int TopIndent { get; set; }
Property TopIndent As Integer
    Get
    Set
property int TopIndent {
    int get ();
    void set (int value);
}
abstract TopIndent : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.UsePrinterSettings Property

IEditPageUsePrinterSettings Property
When implemented by a class, get or sets a boolean value that indicates whether control should use printer settings for calculating page size, margin and orientation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UsePrinterSettings { get; set; }
Property UsePrinterSettings As Boolean
    Get
    Set
property bool UsePrinterSettings {
    bool get ();
    void set (bool value);
}
abstract UsePrinterSettings : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.VertOffset Property

IEditPageVertOffset Property
When implemented by a class, gets or sets a vertical indentation between pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int VertOffset { get; set; }
Property VertOffset As Integer
    Get
    Set
property int VertOffset {
    int get ();
    void set (int value);
}
abstract VertOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.WhiteSpaceBottomRect Property

IEditPageWhiteSpaceBottomRect Property
When implemented by a class, represents a whitespace area of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle WhiteSpaceBottomRect { get; }
ReadOnly Property WhiteSpaceBottomRect As Rectangle
    Get
property Rectangle WhiteSpaceBottomRect {
    Rectangle get ();
}
abstract WhiteSpaceBottomRect : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPage.WhiteSpaceTopRect Property

IEditPageWhiteSpaceTopRect Property
When implemented by a class, represents a whitespace area of the page within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle WhiteSpaceTopRect { get; }
ReadOnly Property WhiteSpaceTopRect As Rectangle
    Get
property Rectangle WhiteSpaceTopRect {
    Rectangle get ();
}
abstract WhiteSpaceTopRect : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

IEditPage Interface
Alternet.Editor Namespace


IEditPageHeader Interface

IEditPageHeader Interface
Represents properties and methods for header/footer parts of edit page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditPageHeader : IUpdate,
    IDisposable
Public Interface IEditPageHeader
    Inherits IUpdate, IDisposable
public interface class IEditPageHeader : IUpdate,
    IDisposable
type IEditPageHeader =
    interface
        interface IUpdate
        interface IDisposable
    end

The IEditPageHeader type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IPageHeader object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Paint | When implemented by a class, draws page header/footer on the specified graphic surface.
Public method | ResetFont | When implemented by a class, resets the IPageHeader.Font to the default value.
Public method | ResetFontColor | When implemented by a class, resets the IPageHeader.FontColor to the default value.
Public method | ResetOffset | When implemented by a class, resets the IPageHeader.Offset to the default value.
Public method | ResetReverseOnEvenPages | When implemented by a class, resets the IPageHeader.ReverseOnEvenPages to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | CenterText | When implemented by a class, gets or sets a string that appears at the center of the header/footer area.
Public property | Font | When implemented by a class, gets or sets font used to draw header/footer text.
Public property | FontColor | When implemented by a class, gets or sets font color used to draw header/footer text.
Public property | LeftText | When implemented by a class, gets or sets a string that appears at the left part of the header/footer area.
Public property | Offset | When implemented by a class, gets or sets indentation of the primary text edge.
Public property | ReverseOnEvenPages | When implemented by a class, gets or sets a value indicating whether the LeftText and RightText interchanging on even page.
Public property | RightText | When implemented by a class, gets or sets a string that appears at the right part of the header/footer area.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the IPageHeader is visible.
Top
Events
 | Name | Description
Public event | DrawHeader | When implemented by a class, occurs when header or footer part of each page is drawing.
Top
See Also

Reference

Alternet.Editor Namespace


IEditPageHeader Methods

IEditPageHeader Methods

The IEditPageHeader type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IPageHeader object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Paint | When implemented by a class, draws page header/footer on the specified graphic surface.
Public method | ResetFont | When implemented by a class, resets the IPageHeader.Font to the default value.
Public method | ResetFontColor | When implemented by a class, resets the IPageHeader.FontColor to the default value.
Public method | ResetOffset | When implemented by a class, resets the IPageHeader.Offset to the default value.
Public method | ResetReverseOnEvenPages | When implemented by a class, resets the IPageHeader.ReverseOnEvenPages to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.Assign Method

IEditPageHeaderAssign Method
When implemented by a class, copies the contents of another IPageHeader object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IEditPageHeader source
)
Sub Assign (
    source As IEditPageHeader
)
void Assign(
    IEditPageHeader^ source
)
abstract Assign :
        source : IEditPageHeader -> unit

Parameters

source
Type: Alternet.EditorIEditPageHeader
Specifies IPageHeader to assign.
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.Paint Method

IEditPageHeaderPaint Method
When implemented by a class, draws page header/footer on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Paint(
    IPainter painter,
    Rectangle rect,
    int pageIndex,
    int pageCount,
    bool pageNumbers
)
Sub Paint (
    painter As IPainter,
    rect As Rectangle,
    pageIndex As Integer,
    pageCount As Integer,
    pageNumbers As Boolean
)
void Paint(
    IPainter^ painter,
    Rectangle rect,
    int pageIndex,
    int pageCount,
    bool pageNumbers
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle *
        pageIndex : int *
        pageCount : int *
        pageNumbers : bool -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of header/footer to draw on.
pageIndex
Type: SystemInt32
Index of page which header/footer is drawing.
pageCount
Type: SystemInt32
Total number of pages.
pageNumbers
Type: SystemBoolean
Specifies whether header/footer should draw page number.
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.ResetFont Method

IEditPageHeaderResetFont Method
When implemented by a class, resets the IPageHeader.Font to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetFont()
Sub ResetFont
void ResetFont()
abstract ResetFont : unit -> unit
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.ResetFontColor Method

IEditPageHeaderResetFontColor Method
When implemented by a class, resets the IPageHeader.FontColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetFontColor()
Sub ResetFontColor
void ResetFontColor()
abstract ResetFontColor : unit -> unit
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.ResetOffset Method

IEditPageHeaderResetOffset Method
When implemented by a class, resets the IPageHeader.Offset to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOffset()
Sub ResetOffset
void ResetOffset()
abstract ResetOffset : unit -> unit
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.ResetReverseOnEvenPages Method

IEditPageHeaderResetReverseOnEvenPages Method
When implemented by a class, resets the IPageHeader.ReverseOnEvenPages to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetReverseOnEvenPages()
Sub ResetReverseOnEvenPages
void ResetReverseOnEvenPages()
abstract ResetReverseOnEvenPages : unit -> unit
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader Properties

IEditPageHeader Properties

The IEditPageHeader type exposes the following members.

Properties
 | Name | Description
Public property | CenterText | When implemented by a class, gets or sets a string that appears at the center of the header/footer area.
Public property | Font | When implemented by a class, gets or sets font used to draw header/footer text.
Public property | FontColor | When implemented by a class, gets or sets font color used to draw header/footer text.
Public property | LeftText | When implemented by a class, gets or sets a string that appears at the left part of the header/footer area.
Public property | Offset | When implemented by a class, gets or sets indentation of the primary text edge.
Public property | ReverseOnEvenPages | When implemented by a class, gets or sets a value indicating whether the LeftText and RightText interchanging on even page.
Public property | RightText | When implemented by a class, gets or sets a string that appears at the right part of the header/footer area.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the IPageHeader is visible.
Top
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.CenterText Property

IEditPageHeaderCenterText Property
When implemented by a class, gets or sets a string that appears at the center of the header/footer area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string CenterText { get; set; }
Property CenterText As String
    Get
    Set
property String^ CenterText {
    String^ get ();
    void set (String^ value);
}
abstract CenterText : string with get, set

Property Value

Type: String
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.Font Property

IEditPageHeaderFont Property
When implemented by a class, gets or sets font used to draw header/footer text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Font Font { get; set; }
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

Property Value

Type: Font
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.FontColor Property

IEditPageHeaderFontColor Property
When implemented by a class, gets or sets font color used to draw header/footer text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color FontColor { get; set; }
Property FontColor As Color
    Get
    Set
property Color FontColor {
    Color get ();
    void set (Color value);
}
abstract FontColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.LeftText Property

IEditPageHeaderLeftText Property
When implemented by a class, gets or sets a string that appears at the left part of the header/footer area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string LeftText { get; set; }
Property LeftText As String
    Get
    Set
property String^ LeftText {
    String^ get ();
    void set (String^ value);
}
abstract LeftText : string with get, set

Property Value

Type: String
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.Offset Property

IEditPageHeaderOffset Property
When implemented by a class, gets or sets indentation of the primary text edge.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Offset { get; set; }
Property Offset As Point
    Get
    Set
property Point Offset {
    Point get ();
    void set (Point value);
}
abstract Offset : Point with get, set

Property Value

Type: Point
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.ReverseOnEvenPages Property

IEditPageHeaderReverseOnEvenPages Property
When implemented by a class, gets or sets a value indicating whether the LeftText and RightText interchanging on even page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReverseOnEvenPages { get; set; }
Property ReverseOnEvenPages As Boolean
    Get
    Set
property bool ReverseOnEvenPages {
    bool get ();
    void set (bool value);
}
abstract ReverseOnEvenPages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.RightText Property

IEditPageHeaderRightText Property
When implemented by a class, gets or sets a string that appears at the right part of the header/footer area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string RightText { get; set; }
Property RightText As String
    Get
    Set
property String^ RightText {
    String^ get ();
    void set (String^ value);
}
abstract RightText : string with get, set

Property Value

Type: String
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.Visible Property

IEditPageHeaderVisible Property
When implemented by a class, gets or sets a value indicating whether the IPageHeader is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader Events

IEditPageHeader Events

The IEditPageHeader type exposes the following members.

Events
 | Name | Description
Public event | DrawHeader | When implemented by a class, occurs when header or footer part of each page is drawing.
Top
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPageHeader.DrawHeader Event

IEditPageHeaderDrawHeader Event
When implemented by a class, occurs when header or footer part of each page is drawing.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event DrawHeaderEvent DrawHeader
Event DrawHeader As DrawHeaderEvent
 event DrawHeaderEvent^ DrawHeader {
    void add (DrawHeaderEvent^ value);
    void remove (DrawHeaderEvent^ value);
}
abstract DrawHeader : IEvent<DrawHeaderEvent,
    DrawHeaderEventArgs>

Value

Type: Alternet.EditorDrawHeaderEvent
See Also

Reference

IEditPageHeader Interface
Alternet.Editor Namespace


IEditPages Interface

IEditPages Interface
Represents a collection of pages in the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditPages : IUpdate,
    IDisposable, IEnumerable<IEditPage>, IEnumerable
Public Interface IEditPages
    Inherits IUpdate, IDisposable, IEnumerable(Of IEditPage),
    IEnumerable
public interface class IEditPages : IUpdate,
    IDisposable, IEnumerable<IEditPage^>, IEnumerable
type IEditPages =
    interface
        interface IUpdate
        interface IDisposable
        interface IEnumerable<IEditPage>
        interface IEnumerable
    end

The IEditPages type exposes the following members.

Methods
 | Name | Description
Public method | Add | When implemented by a class, adds a new IEditPage to the collection.
Public method | Assign | When implemented by a class, assigns most relevant properties from another IEditPages object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | CancelDragging | When implemented by a class, cancels dragging operation of the page ruler.
Public method | Clear | When implemented by a class, removes all items from the pages collection.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | DisplayRulers | When implemented by a class, displays rulers if needed.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIEditPage .)
Public method | GetPageAt(Point) | When implemented by a class, finds page at specified display position.
Public method | GetPageAt(Int32, Int32) | When implemented by a class, finds page at specified display position.
Public method | GetPageAtCursor | When implemented by a class, finds page at caret position.
Public method | GetPageAtPoint(Point) | When implemented by a class, finds page at specified screen position.
Public method | GetPageAtPoint(Int32, Int32) | When implemented by a class, finds page at specified screen position.
Public method | GetPageIndexAt(Point) | When implemented by a class, finds page at specified display position.
Public method | GetPageIndexAt(Int32, Int32) | When implemented by a class, finds page at specified display position.
Public method | GetPageIndexAtCursor | When implemented by a class, finds page at caret position.
Public method | GetPageIndexAtPoint(Point) | When implemented by a class, finds page at specified screen position.
Public method | GetPageIndexAtPoint(Int32, Int32) | When implemented by a class, finds page at specified screen position.
Public method | IndexOf | When implemented by a class, returns index of page within page collection.
Public method | InitDefaultPageSettings | When implemented by a class, initializes page settings with default values.
Public method | Invalidate | When implemented by a class, invalidates specified page.
Public method | OnDrawHeader | When implemented by a class, raises DrawHeader event.
Public method | Paint | When implemented by a class, draws pages collection on the graphic surface.
Public method | ResetBackColor | When implemented by a class, resets BackColor to the default value.
Public method | ResetBorderColor | When implemented by a class, resets BorderColor to the default value.
Public method | ResetDisplayWhiteSpace | When implemented by a class, resets DisplayWhiteSpace to the default value.
Public method | ResetPageType | When implemented by a class, resets PageType to the default value.
Public method | ResetRulerBackColor | When implemented by a class, resets RulerBackColor to the default value.
Public method | ResetRulerIndentBackColor | When implemented by a class, resets RulerIndentBackColor to the default value.
Public method | ResetRulerOptions | When implemented by a class, resets RulerOptions to the default value.
Public method | ResetRulers | When implemented by a class, resets Rulers to the default value.
Public method | ResetRulerUnits | When implemented by a class, resets RulerUnits to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | Update(IEditPage) | When implemented by a class, recalculates bounds of the specified page.
Public method | Update(IEditPage, Boolean) | When implemented by a class, recalculates bounds and updates content of specified page.
Public method | UpdatePages | When implemented by a class, recalculates bounds and updates content of specified page.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIEditPage | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIEditPage | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIEditPage, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ApplyRulerToAllPages | When implemented by a class, gets or sets a boolean value that indicates that changing of rulers indentation applies to all pages rather than to current page.
Public property | BackColor | When implemented by a class, gets or sets a background color of each page in the collection.
Public property | BorderColor | When implemented by a class, gets or sets a border color of each page in the collection.
Public property | Caps | When implemented by a class, gets size in pixels per logical inch of entire screen.
Public property | Count | When implemented by a class, represents a number of pages in the collection.
Public property | DefaultLandscape | When implemented by a class, represents default page landscape.
Public property | DefaultMargins | When implemented by a class, represents default page margins.
Public property | DefaultPage | When implemented by a class, gets or sets properties for default IEditPage object in the pages collection.
Public property | DefaultPageKind | When implemented by a class, represents default page kind.
Public property | DefaultPageSize | When implemented by a class, represents default page size.
Public property | DisplayWhiteSpace | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw whitespace area between pages.
Public property | Height | When implemented by a class, represents total height of all pages in the collection.
Public property | HorzRuler | When implemented by a class, represents IEditRuler object used as a horizontal page ruler.
Public property | Item | When implemented by a class, provides an indexed access to individual IEditPage stored in the collection.
Public property | List | When implemented by a class, provides an indexed access to individual pages within IEditPages collection.
Public property | PageKind | Gets or sets kind of the pages specifying standard paper size.
Public property | PageType | When implemented by a class, gets or sets value specifying the way of viewing Edit control's content.
Public property | RulerBackColor | When implemented by a class, gets or sets background color of the pages rulers.
Public property | RulerIndentBackColor | When implemented by a class, gets or sets background color of the indentations parts of the pages rulers.
Public property | RulerOptions | When implemented by a class, gets or sets options of the pages rulers.
Public property | Rulers | When implemented by a class, gets or sets the rulers displayed within Edit control.
Public property | RulerUnits | When implemented by a class, gets or sets measurement units of the pages rulers.
Public property | Transparent | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw background around the pages.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | VertRuler | When implemented by a class, represents IEditRuler object used as a vertical page ruler.
Public property | Width | When implemented by a class, represents pages width.
Top
Events
 | Name | Description
Public event | DrawHeader | When implemented by a class, occurs when header or footer part of each page is drawing.
Top
See Also

Reference

Alternet.Editor Namespace


IEditPages Methods

IEditPages Methods

The IEditPages type exposes the following members.

Methods
 | Name | Description
Public method | Add | When implemented by a class, adds a new IEditPage to the collection.
Public method | Assign | When implemented by a class, assigns most relevant properties from another IEditPages object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | CancelDragging | When implemented by a class, cancels dragging operation of the page ruler.
Public method | Clear | When implemented by a class, removes all items from the pages collection.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | DisplayRulers | When implemented by a class, displays rulers if needed.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIEditPage .)
Public method | GetPageAt(Point) | When implemented by a class, finds page at specified display position.
Public method | GetPageAt(Int32, Int32) | When implemented by a class, finds page at specified display position.
Public method | GetPageAtCursor | When implemented by a class, finds page at caret position.
Public method | GetPageAtPoint(Point) | When implemented by a class, finds page at specified screen position.
Public method | GetPageAtPoint(Int32, Int32) | When implemented by a class, finds page at specified screen position.
Public method | GetPageIndexAt(Point) | When implemented by a class, finds page at specified display position.
Public method | GetPageIndexAt(Int32, Int32) | When implemented by a class, finds page at specified display position.
Public method | GetPageIndexAtCursor | When implemented by a class, finds page at caret position.
Public method | GetPageIndexAtPoint(Point) | When implemented by a class, finds page at specified screen position.
Public method | GetPageIndexAtPoint(Int32, Int32) | When implemented by a class, finds page at specified screen position.
Public method | IndexOf | When implemented by a class, returns index of page within page collection.
Public method | InitDefaultPageSettings | When implemented by a class, initializes page settings with default values.
Public method | Invalidate | When implemented by a class, invalidates specified page.
Public method | OnDrawHeader | When implemented by a class, raises DrawHeader event.
Public method | Paint | When implemented by a class, draws pages collection on the graphic surface.
Public method | ResetBackColor | When implemented by a class, resets BackColor to the default value.
Public method | ResetBorderColor | When implemented by a class, resets BorderColor to the default value.
Public method | ResetDisplayWhiteSpace | When implemented by a class, resets DisplayWhiteSpace to the default value.
Public method | ResetPageType | When implemented by a class, resets PageType to the default value.
Public method | ResetRulerBackColor | When implemented by a class, resets RulerBackColor to the default value.
Public method | ResetRulerIndentBackColor | When implemented by a class, resets RulerIndentBackColor to the default value.
Public method | ResetRulerOptions | When implemented by a class, resets RulerOptions to the default value.
Public method | ResetRulers | When implemented by a class, resets Rulers to the default value.
Public method | ResetRulerUnits | When implemented by a class, resets RulerUnits to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | Update(IEditPage) | When implemented by a class, recalculates bounds of the specified page.
Public method | Update(IEditPage, Boolean) | When implemented by a class, recalculates bounds and updates content of specified page.
Public method | UpdatePages | When implemented by a class, recalculates bounds and updates content of specified page.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIEditPage | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIEditPage | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIEditPage, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Add Method

IEditPagesAdd Method
When implemented by a class, adds a new IEditPage to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage Add()
Function Add As IEditPage
IEditPage^ Add()
abstract Add : unit -> IEditPage

Return Value

Type: IEditPage
IEditPage that is added.
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Assign Method

IEditPagesAssign Method
When implemented by a class, assigns most relevant properties from another IEditPages object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IEditPages source
)
Sub Assign (
    source As IEditPages
)
void Assign(
    IEditPages^ source
)
abstract Assign :
        source : IEditPages -> unit

Parameters

source
Type: Alternet.EditorIEditPages
Specifies source object.
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.CancelDragging Method

IEditPagesCancelDragging Method
When implemented by a class, cancels dragging operation of the page ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CancelDragging()
Sub CancelDragging
void CancelDragging()
abstract CancelDragging : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Clear Method

IEditPagesClear Method
When implemented by a class, removes all items from the pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.DisplayRulers Method

IEditPagesDisplayRulers Method
When implemented by a class, displays rulers if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DisplayRulers()
Sub DisplayRulers
void DisplayRulers()
abstract DisplayRulers : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.GetPageAt Method

IEditPagesGetPageAt Method
Overload List
 | Name | Description
Public method | GetPageAt(Point) | When implemented by a class, finds page at specified display position.
Public method | GetPageAt(Int32, Int32) | When implemented by a class, finds page at specified display position.
Top
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.GetPageAt Method (Point)

IEditPagesGetPageAt Method (Point)
When implemented by a class, finds page at specified display position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage GetPageAt(
    Point position
)
Function GetPageAt (
    position As Point
) As IEditPage
IEditPage^ GetPageAt(
    Point position
)
abstract GetPageAt :
        position : Point -> IEditPage

Parameters

position
Type: System.DrawingPoint
Position in display coordinates to obtain the page.

Return Value

Type: IEditPage
IEditPage found.
See Also

Reference

IEditPages Interface
GetPageAt Overload
Alternet.Editor Namespace


IEditPages.GetPageAt Method (Int32, Int32)

IEditPagesGetPageAt Method (Int32, Int32)
When implemented by a class, finds page at specified display position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage GetPageAt(
    int x,
    int y
)
Function GetPageAt (
    x As Integer,
    y As Integer
) As IEditPage
IEditPage^ GetPageAt(
    int x,
    int y
)
abstract GetPageAt :
        x : int *
        y : int -> IEditPage

Parameters

x
Type: SystemInt32
X-coordinate of the position (in display coordinates) to find the page.
y
Type: SystemInt32
Y-coordinate of the position (in display coordinates) to find the page.

Return Value

Type: IEditPage
IEditPage containing specified position.
See Also

Reference

IEditPages Interface
GetPageAt Overload
Alternet.Editor Namespace


IEditPages.GetPageAtCursor Method

IEditPagesGetPageAtCursor Method
When implemented by a class, finds page at caret position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage GetPageAtCursor()
Function GetPageAtCursor As IEditPage
IEditPage^ GetPageAtCursor()
abstract GetPageAtCursor : unit -> IEditPage

Return Value

Type: IEditPage
IEditPage containing caret.
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.GetPageAtPoint Method

IEditPagesGetPageAtPoint Method
Overload List
 | Name | Description
Public method | GetPageAtPoint(Point) | When implemented by a class, finds page at specified screen position.
Public method | GetPageAtPoint(Int32, Int32) | When implemented by a class, finds page at specified screen position.
Top
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.GetPageAtPoint Method (Point)

IEditPagesGetPageAtPoint Method (Point)
When implemented by a class, finds page at specified screen position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage GetPageAtPoint(
    Point position
)
Function GetPageAtPoint (
    position As Point
) As IEditPage
IEditPage^ GetPageAtPoint(
    Point position
)
abstract GetPageAtPoint :
        position : Point -> IEditPage

Parameters

position
Type: System.DrawingPoint
Position in screen coordinates to obtain the page.

Return Value

Type: IEditPage
IEditPage containing specified position.
See Also

Reference

IEditPages Interface
GetPageAtPoint Overload
Alternet.Editor Namespace


IEditPages.GetPageAtPoint Method (Int32, Int32)

IEditPagesGetPageAtPoint Method (Int32, Int32)
When implemented by a class, finds page at specified screen position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage GetPageAtPoint(
    int x,
    int y
)
Function GetPageAtPoint (
    x As Integer,
    y As Integer
) As IEditPage
IEditPage^ GetPageAtPoint(
    int x,
    int y
)
abstract GetPageAtPoint :
        x : int *
        y : int -> IEditPage

Parameters

x
Type: SystemInt32
X-coordinate of the position (in screen coordinates) to find the page.
y
Type: SystemInt32
Y-coordinate of the position (in screen coordinates) to find the page.

Return Value

Type: IEditPage
IEditPage containing specified position.
See Also

Reference

IEditPages Interface
GetPageAtPoint Overload
Alternet.Editor Namespace


IEditPages.GetPageIndexAt Method

IEditPagesGetPageIndexAt Method
Overload List
 | Name | Description
Public method | GetPageIndexAt(Point) | When implemented by a class, finds page at specified display position.
Public method | GetPageIndexAt(Int32, Int32) | When implemented by a class, finds page at specified display position.
Top
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.GetPageIndexAt Method (Point)

IEditPagesGetPageIndexAt Method (Point)
When implemented by a class, finds page at specified display position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPageIndexAt(
    Point position
)
Function GetPageIndexAt (
    position As Point
) As Integer
int GetPageIndexAt(
    Point position
)
abstract GetPageIndexAt :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position in display coordinates to obtain the page.

Return Value

Type: Int32
Ordinal number of found page within the collection.
See Also

Reference

IEditPages Interface
GetPageIndexAt Overload
Alternet.Editor Namespace


IEditPages.GetPageIndexAt Method (Int32, Int32)

IEditPagesGetPageIndexAt Method (Int32, Int32)
When implemented by a class, finds page at specified display position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPageIndexAt(
    int x,
    int y
)
Function GetPageIndexAt (
    x As Integer,
    y As Integer
) As Integer
int GetPageIndexAt(
    int x,
    int y
)
abstract GetPageIndexAt :
        x : int *
        y : int -> int

Parameters

x
Type: SystemInt32
X-coordinate of the position (in display coordinates) to find the page.
y
Type: SystemInt32
Y-coordinate of the position (in display coordinates) to find the page.

Return Value

Type: Int32
Ordinal number of found page within the collection.
See Also

Reference

IEditPages Interface
GetPageIndexAt Overload
Alternet.Editor Namespace


IEditPages.GetPageIndexAtCursor Method

IEditPagesGetPageIndexAtCursor Method
When implemented by a class, finds page at caret position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPageIndexAtCursor()
Function GetPageIndexAtCursor As Integer
int GetPageIndexAtCursor()
abstract GetPageIndexAtCursor : unit -> int

Return Value

Type: Int32
Ordinal number of found page within the collection.
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.GetPageIndexAtPoint Method

IEditPagesGetPageIndexAtPoint Method
Overload List
 | Name | Description
Public method | GetPageIndexAtPoint(Point) | When implemented by a class, finds page at specified screen position.
Public method | GetPageIndexAtPoint(Int32, Int32) | When implemented by a class, finds page at specified screen position.
Top
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.GetPageIndexAtPoint Method (Point)

IEditPagesGetPageIndexAtPoint Method (Point)
When implemented by a class, finds page at specified screen position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPageIndexAtPoint(
    Point position
)
Function GetPageIndexAtPoint (
    position As Point
) As Integer
int GetPageIndexAtPoint(
    Point position
)
abstract GetPageIndexAtPoint :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position in screen coordinates to obtain the page.

Return Value

Type: Int32
Ordinal number of found page within the collection.
See Also

Reference

IEditPages Interface
GetPageIndexAtPoint Overload
Alternet.Editor Namespace


IEditPages.GetPageIndexAtPoint Method (Int32, Int32)

IEditPagesGetPageIndexAtPoint Method (Int32, Int32)
When implemented by a class, finds page at specified screen position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPageIndexAtPoint(
    int x,
    int y
)
Function GetPageIndexAtPoint (
    x As Integer,
    y As Integer
) As Integer
int GetPageIndexAtPoint(
    int x,
    int y
)
abstract GetPageIndexAtPoint :
        x : int *
        y : int -> int

Parameters

x
Type: SystemInt32
X-coordinate of the position (in screen coordinates) to find the page.
y
Type: SystemInt32
Y-coordinate of the position (in screen coordinates) to find the page.

Return Value

Type: Int32
Ordinal number of found page within the collection.
See Also

Reference

IEditPages Interface
GetPageIndexAtPoint Overload
Alternet.Editor Namespace


IEditPages.IndexOf Method

IEditPagesIndexOf Method
When implemented by a class, returns index of page within page collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int IndexOf(
    IEditPage page
)
Function IndexOf (
    page As IEditPage
) As Integer
int IndexOf(
    IEditPage^ page
)
abstract IndexOf :
        page : IEditPage -> int

Parameters

page
Type: Alternet.EditorIEditPage

Return Value

Type: Int32
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.InitDefaultPageSettings Method

IEditPagesInitDefaultPageSettings Method
When implemented by a class, initializes page settings with default values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void InitDefaultPageSettings(
    PageSettings settings
)
Sub InitDefaultPageSettings (
    settings As PageSettings
)
void InitDefaultPageSettings(
    PageSettings^ settings
)
abstract InitDefaultPageSettings :
        settings : PageSettings -> unit

Parameters

settings
Type: System.Drawing.PrintingPageSettings
Specifies page settings to initialize.
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Invalidate Method

IEditPagesInvalidate Method
When implemented by a class, invalidates specified page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Invalidate(
    IEditPage page
)
Sub Invalidate (
    page As IEditPage
)
void Invalidate(
    IEditPage^ page
)
abstract Invalidate :
        page : IEditPage -> unit

Parameters

page
Type: Alternet.EditorIEditPage
Page to invalidate.
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.OnDrawHeader Method

IEditPagesOnDrawHeader Method
When implemented by a class, raises DrawHeader event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnDrawHeader(
    ref string text
)
Sub OnDrawHeader (
    ByRef text As String
)
void OnDrawHeader(
    String^% text
)
abstract OnDrawHeader :
        text : string byref -> unit

Parameters

text
Type: SystemString
Specifies text to draw.
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Paint Method

IEditPagesPaint Method
When implemented by a class, draws pages collection on the graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Paint(
    IPainter painter,
    Rectangle rect
)
Sub Paint (
    painter As IPainter,
    rect As Rectangle
)
void Paint(
    IPainter^ painter,
    Rectangle rect
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
rect
Type: System.DrawingRectangle
Rectangular area of pages collection to draw on.
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ResetBackColor Method

IEditPagesResetBackColor Method
When implemented by a class, resets BackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBackColor()
Sub ResetBackColor
void ResetBackColor()
abstract ResetBackColor : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ResetBorderColor Method

IEditPagesResetBorderColor Method
When implemented by a class, resets BorderColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBorderColor()
Sub ResetBorderColor
void ResetBorderColor()
abstract ResetBorderColor : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ResetDisplayWhiteSpace Method

IEditPagesResetDisplayWhiteSpace Method
When implemented by a class, resets DisplayWhiteSpace to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDisplayWhiteSpace()
Sub ResetDisplayWhiteSpace
void ResetDisplayWhiteSpace()
abstract ResetDisplayWhiteSpace : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ResetPageType Method

IEditPagesResetPageType Method
When implemented by a class, resets PageType to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetPageType()
Sub ResetPageType
void ResetPageType()
abstract ResetPageType : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ResetRulerBackColor Method

IEditPagesResetRulerBackColor Method
When implemented by a class, resets RulerBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetRulerBackColor()
Sub ResetRulerBackColor
void ResetRulerBackColor()
abstract ResetRulerBackColor : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ResetRulerIndentBackColor Method

IEditPagesResetRulerIndentBackColor Method
When implemented by a class, resets RulerIndentBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetRulerIndentBackColor()
Sub ResetRulerIndentBackColor
void ResetRulerIndentBackColor()
abstract ResetRulerIndentBackColor : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ResetRulerOptions Method

IEditPagesResetRulerOptions Method
When implemented by a class, resets RulerOptions to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetRulerOptions()
Sub ResetRulerOptions
void ResetRulerOptions()
abstract ResetRulerOptions : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ResetRulers Method

IEditPagesResetRulers Method
When implemented by a class, resets Rulers to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetRulers()
Sub ResetRulers
void ResetRulers()
abstract ResetRulers : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ResetRulerUnits Method

IEditPagesResetRulerUnits Method
When implemented by a class, resets RulerUnits to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetRulerUnits()
Sub ResetRulerUnits
void ResetRulerUnits()
abstract ResetRulerUnits : unit -> unit
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Update Method

IEditPagesUpdate Method
Overload List
 | Name | Description
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | Update(IEditPage) | When implemented by a class, recalculates bounds of the specified page.
Public method | Update(IEditPage, Boolean) | When implemented by a class, recalculates bounds and updates content of specified page.
Top
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Update Method (IEditPage)

IEditPagesUpdate Method (IEditPage)
When implemented by a class, recalculates bounds of the specified page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Update(
    IEditPage page
)
Sub Update (
    page As IEditPage
)
void Update(
    IEditPage^ page
)
abstract Update :
        page : IEditPage -> unit

Parameters

page
Type: Alternet.EditorIEditPage
Page to update.
See Also

Reference

IEditPages Interface
Update Overload
Alternet.Editor Namespace


IEditPages.Update Method (IEditPage, Boolean)

IEditPagesUpdate Method (IEditPage, Boolean)
When implemented by a class, recalculates bounds and updates content of specified page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Update(
    IEditPage page,
    bool changed
)
Sub Update (
    page As IEditPage,
    changed As Boolean
)
void Update(
    IEditPage^ page,
    bool changed
)
abstract Update :
        page : IEditPage *
        changed : bool -> unit

Parameters

page
Type: Alternet.EditorIEditPage
Page to update.
changed
Type: SystemBoolean
Indicates that page should recalculate it's content.
See Also

Reference

IEditPages Interface
Update Overload
Alternet.Editor Namespace


IEditPages.UpdatePages Method

IEditPagesUpdatePages Method
When implemented by a class, recalculates bounds and updates content of specified page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdatePages(
    int index
)
Sub UpdatePages (
    index As Integer
)
void UpdatePages(
    int index
)
abstract UpdatePages :
        index : int -> unit

Parameters

index
Type: SystemInt32
Page index to update.
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages Properties

IEditPages Properties

The IEditPages type exposes the following members.

Properties
 | Name | Description
Public property | ApplyRulerToAllPages | When implemented by a class, gets or sets a boolean value that indicates that changing of rulers indentation applies to all pages rather than to current page.
Public property | BackColor | When implemented by a class, gets or sets a background color of each page in the collection.
Public property | BorderColor | When implemented by a class, gets or sets a border color of each page in the collection.
Public property | Caps | When implemented by a class, gets size in pixels per logical inch of entire screen.
Public property | Count | When implemented by a class, represents a number of pages in the collection.
Public property | DefaultLandscape | When implemented by a class, represents default page landscape.
Public property | DefaultMargins | When implemented by a class, represents default page margins.
Public property | DefaultPage | When implemented by a class, gets or sets properties for default IEditPage object in the pages collection.
Public property | DefaultPageKind | When implemented by a class, represents default page kind.
Public property | DefaultPageSize | When implemented by a class, represents default page size.
Public property | DisplayWhiteSpace | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw whitespace area between pages.
Public property | Height | When implemented by a class, represents total height of all pages in the collection.
Public property | HorzRuler | When implemented by a class, represents IEditRuler object used as a horizontal page ruler.
Public property | Item | When implemented by a class, provides an indexed access to individual IEditPage stored in the collection.
Public property | List | When implemented by a class, provides an indexed access to individual pages within IEditPages collection.
Public property | PageKind | Gets or sets kind of the pages specifying standard paper size.
Public property | PageType | When implemented by a class, gets or sets value specifying the way of viewing Edit control's content.
Public property | RulerBackColor | When implemented by a class, gets or sets background color of the pages rulers.
Public property | RulerIndentBackColor | When implemented by a class, gets or sets background color of the indentations parts of the pages rulers.
Public property | RulerOptions | When implemented by a class, gets or sets options of the pages rulers.
Public property | Rulers | When implemented by a class, gets or sets the rulers displayed within Edit control.
Public property | RulerUnits | When implemented by a class, gets or sets measurement units of the pages rulers.
Public property | Transparent | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw background around the pages.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | VertRuler | When implemented by a class, represents IEditRuler object used as a vertical page ruler.
Public property | Width | When implemented by a class, represents pages width.
Top
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.ApplyRulerToAllPages Property

IEditPagesApplyRulerToAllPages Property
When implemented by a class, gets or sets a boolean value that indicates that changing of rulers indentation applies to all pages rather than to current page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ApplyRulerToAllPages { get; set; }
Property ApplyRulerToAllPages As Boolean
    Get
    Set
property bool ApplyRulerToAllPages {
    bool get ();
    void set (bool value);
}
abstract ApplyRulerToAllPages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.BackColor Property

IEditPagesBackColor Property
When implemented by a class, gets or sets a background color of each page in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; set; }
Property BackColor As Color
    Get
    Set
property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.BorderColor Property

IEditPagesBorderColor Property
When implemented by a class, gets or sets a border color of each page in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BorderColor { get; set; }
Property BorderColor As Color
    Get
    Set
property Color BorderColor {
    Color get ();
    void set (Color value);
}
abstract BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Caps Property

IEditPagesCaps Property
When implemented by a class, gets size in pixels per logical inch of entire screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Size Caps { get; }
ReadOnly Property Caps As Size
    Get
property Size Caps {
    Size get ();
}
abstract Caps : Size with get

Property Value

Type: Size
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Count Property

IEditPagesCount Property
When implemented by a class, represents a number of pages in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.DefaultLandscape Property

IEditPagesDefaultLandscape Property
When implemented by a class, represents default page landscape.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DefaultLandscape { get; }
ReadOnly Property DefaultLandscape As Boolean
    Get
property bool DefaultLandscape {
    bool get ();
}
abstract DefaultLandscape : bool with get

Property Value

Type: Boolean
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.DefaultMargins Property

IEditPagesDefaultMargins Property
When implemented by a class, represents default page margins.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Margins DefaultMargins { get; }
ReadOnly Property DefaultMargins As Margins
    Get
property Margins^ DefaultMargins {
    Margins^ get ();
}
abstract DefaultMargins : Margins with get

Property Value

Type: Margins
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.DefaultPage Property

IEditPagesDefaultPage Property
When implemented by a class, gets or sets properties for default IEditPage object in the pages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage DefaultPage { get; set; }
Property DefaultPage As IEditPage
    Get
    Set
property IEditPage^ DefaultPage {
    IEditPage^ get ();
    void set (IEditPage^ value);
}
abstract DefaultPage : IEditPage with get, set

Property Value

Type: IEditPage
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.DefaultPageKind Property

IEditPagesDefaultPageKind Property
When implemented by a class, represents default page kind.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PaperKind DefaultPageKind { get; }
ReadOnly Property DefaultPageKind As PaperKind
    Get
property PaperKind DefaultPageKind {
    PaperKind get ();
}
abstract DefaultPageKind : PaperKind with get

Property Value

Type: PaperKind
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.DefaultPageSize Property

IEditPagesDefaultPageSize Property
When implemented by a class, represents default page size.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Size DefaultPageSize { get; }
ReadOnly Property DefaultPageSize As Size
    Get
property Size DefaultPageSize {
    Size get ();
}
abstract DefaultPageSize : Size with get

Property Value

Type: Size
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.DisplayWhiteSpace Property

IEditPagesDisplayWhiteSpace Property
When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw whitespace area between pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DisplayWhiteSpace { get; set; }
Property DisplayWhiteSpace As Boolean
    Get
    Set
property bool DisplayWhiteSpace {
    bool get ();
    void set (bool value);
}
abstract DisplayWhiteSpace : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Height Property

IEditPagesHeight Property
When implemented by a class, represents total height of all pages in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Height { get; }
ReadOnly Property Height As Integer
    Get
property int Height {
    int get ();
}
abstract Height : int with get

Property Value

Type: Int32
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.HorzRuler Property

IEditPagesHorzRuler Property
When implemented by a class, represents IEditRuler object used as a horizontal page ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditRuler HorzRuler { get; }
ReadOnly Property HorzRuler As IEditRuler
    Get
property IEditRuler^ HorzRuler {
    IEditRuler^ get ();
}
abstract HorzRuler : IEditRuler with get

Property Value

Type: IEditRuler
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Item Property

IEditPagesItem Property
When implemented by a class, provides an indexed access to individual IEditPage stored in the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPage this[
    int index
] { get; set; }
Default Property Item (
    index As Integer
) As IEditPage
    Get
    Set
property IEditPage^ default[int index] {
    IEditPage^ get (int index);
    void set (int index, IEditPage^ value);
}
abstract Item : IEditPage with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: IEditPage
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.List Property

IEditPagesList Property
When implemented by a class, provides an indexed access to individual pages within IEditPages collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<IEditPage> List { get; }
ReadOnly Property List As IList(Of IEditPage)
    Get
property IList<IEditPage^>^ List {
    IList<IEditPage^>^ get ();
}
abstract List : IList<IEditPage> with get

Property Value

Type: IListIEditPage
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.PageKind Property

IEditPagesPageKind Property
Gets or sets kind of the pages specifying standard paper size.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PaperKind PageKind { get; set; }
Property PageKind As PaperKind
    Get
    Set
property PaperKind PageKind {
    PaperKind get ();
    void set (PaperKind value);
}
abstract PageKind : PaperKind with get, set

Property Value

Type: PaperKind
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.PageType Property

IEditPagesPageType Property
When implemented by a class, gets or sets value specifying the way of viewing Edit control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PageType PageType { get; set; }
Property PageType As PageType
    Get
    Set
property PageType PageType {
    PageType get ();
    void set (PageType value);
}
abstract PageType : PageType with get, set

Property Value

Type: PageType
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.RulerBackColor Property

IEditPagesRulerBackColor Property
When implemented by a class, gets or sets background color of the pages rulers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color RulerBackColor { get; set; }
Property RulerBackColor As Color
    Get
    Set
property Color RulerBackColor {
    Color get ();
    void set (Color value);
}
abstract RulerBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.RulerIndentBackColor Property

IEditPagesRulerIndentBackColor Property
When implemented by a class, gets or sets background color of the indentations parts of the pages rulers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color RulerIndentBackColor { get; set; }
Property RulerIndentBackColor As Color
    Get
    Set
property Color RulerIndentBackColor {
    Color get ();
    void set (Color value);
}
abstract RulerIndentBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.RulerOptions Property

IEditPagesRulerOptions Property
When implemented by a class, gets or sets options of the pages rulers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
RulerOptions RulerOptions { get; set; }
Property RulerOptions As RulerOptions
    Get
    Set
property RulerOptions RulerOptions {
    RulerOptions get ();
    void set (RulerOptions value);
}
abstract RulerOptions : RulerOptions with get, set

Property Value

Type: RulerOptions
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Rulers Property

IEditPagesRulers Property
When implemented by a class, gets or sets the rulers displayed within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
EditRulers Rulers { get; set; }
Property Rulers As EditRulers
    Get
    Set
property EditRulers Rulers {
    EditRulers get ();
    void set (EditRulers value);
}
abstract Rulers : EditRulers with get, set

Property Value

Type: EditRulers
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.RulerUnits Property

IEditPagesRulerUnits Property
When implemented by a class, gets or sets measurement units of the pages rulers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
RulerUnits RulerUnits { get; set; }
Property RulerUnits As RulerUnits
    Get
    Set
property RulerUnits RulerUnits {
    RulerUnits get ();
    void set (RulerUnits value);
}
abstract RulerUnits : RulerUnits with get, set

Property Value

Type: RulerUnits
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Transparent Property

IEditPagesTransparent Property
When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw background around the pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Transparent { get; set; }
Property Transparent As Boolean
    Get
    Set
property bool Transparent {
    bool get ();
    void set (bool value);
}
abstract Transparent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.VertRuler Property

IEditPagesVertRuler Property
When implemented by a class, represents IEditRuler object used as a vertical page ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditRuler VertRuler { get; }
ReadOnly Property VertRuler As IEditRuler
    Get
property IEditRuler^ VertRuler {
    IEditRuler^ get ();
}
abstract VertRuler : IEditRuler with get

Property Value

Type: IEditRuler
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.Width Property

IEditPagesWidth Property
When implemented by a class, represents pages width.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Width { get; }
ReadOnly Property Width As Integer
    Get
property int Width {
    int get ();
}
abstract Width : int with get

Property Value

Type: Int32
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages Events

IEditPages Events

The IEditPages type exposes the following members.

Events
 | Name | Description
Public event | DrawHeader | When implemented by a class, occurs when header or footer part of each page is drawing.
Top
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditPages.DrawHeader Event

IEditPagesDrawHeader Event
When implemented by a class, occurs when header or footer part of each page is drawing.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event DrawHeaderEvent DrawHeader
Event DrawHeader As DrawHeaderEvent
 event DrawHeaderEvent^ DrawHeader {
    void add (DrawHeaderEvent^ value);
    void remove (DrawHeaderEvent^ value);
}
abstract DrawHeader : IEvent<DrawHeaderEvent,
    DrawHeaderEventArgs>

Value

Type: Alternet.EditorDrawHeaderEvent
See Also

Reference

IEditPages Interface
Alternet.Editor Namespace


IEditRuler Interface

IEditRuler Interface
Represents properties and methods of Edit control's ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditRuler : IControl
Public Interface IEditRuler
    Inherits IControl
public interface class IEditRuler : IControl
type IEditRuler =
    interface
        interface IControl
    end

The IEditRuler type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IEditRuler object.
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | CancelDragging | When implemented by a class, cancels dragging operation.
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | ResetIndentBackColor | When implemented by a class, resets the IndentBackColor to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ResetUnits | When implemented by a class, resets the Units to the default value.
Public method | SendToBack | When implemented by a class, sends the control to the back of the z-order.
Top
Properties
 | Name | Description
Public property | Anchor | When implemented by a class, gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IndentBackColor | When implemented by a class, gets or sets background color of indentation parts of the ruler.
Public property | IsDragging | When implemented by a class, indicates whether some of ruler indentation is in dragging state.
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | MarkWidth | When implemented by a class, gets or sets default distance between adjacent marks.
Public property | Options | When implemented by a class, gets or sets RulerOptions determining ruler behaviour.
Public property | PageStart | When implemented by a class, gets or sets beginning of the page part of the ruler.
Public property | PageWidth | When implemented by a class, gets or sets width, in pixels between left and right indentations indicating width of the page.
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | RulerStart | When implemented by a class, gets or sets position, in pixels, of left indentation specifying start of the page.
Public property | RulerWidth | When implemented by a class, gets or sets ruler width.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Units | When implemented by a class, gets or sets ruler measurement units.
Public property | Vertical | When implemented by a class, gets or sets a boolean value indicating whether ruler has vertical or horizontal direction.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
Events
 | Name | Description
Public event | Change | When implemented by a class, occurs when some of ruler indentations has changed its position due to the dragging operation.
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Top
See Also

Reference

Alternet.Editor Namespace


IEditRuler Methods

IEditRuler Methods

The IEditRuler type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IEditRuler object.
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | CancelDragging | When implemented by a class, cancels dragging operation.
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | ResetIndentBackColor | When implemented by a class, resets the IndentBackColor to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ResetUnits | When implemented by a class, resets the Units to the default value.
Public method | SendToBack | When implemented by a class, sends the control to the back of the z-order.
Top
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.Assign Method

IEditRulerAssign Method
When implemented by a class, copies the contents of another IEditRuler object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IEditRuler source
)
Sub Assign (
    source As IEditRuler
)
void Assign(
    IEditRuler^ source
)
abstract Assign :
        source : IEditRuler -> unit

Parameters

source
Type: Alternet.EditorIEditRuler
Specifies IEditRuler to assign.
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.CancelDragging Method

IEditRulerCancelDragging Method
When implemented by a class, cancels dragging operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CancelDragging()
Sub CancelDragging
void CancelDragging()
abstract CancelDragging : unit -> unit
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.ResetIndentBackColor Method

IEditRulerResetIndentBackColor Method
When implemented by a class, resets the IndentBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetIndentBackColor()
Sub ResetIndentBackColor
void ResetIndentBackColor()
abstract ResetIndentBackColor : unit -> unit
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.ResetOptions Method

IEditRulerResetOptions Method
When implemented by a class, resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOptions()
Sub ResetOptions
void ResetOptions()
abstract ResetOptions : unit -> unit
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.ResetUnits Method

IEditRulerResetUnits Method
When implemented by a class, resets the Units to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUnits()
Sub ResetUnits
void ResetUnits()
abstract ResetUnits : unit -> unit
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.SendToBack Method

IEditRulerSendToBack Method
When implemented by a class, sends the control to the back of the z-order.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendToBack()
Sub SendToBack
void SendToBack()
abstract SendToBack : unit -> unit
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler Properties

IEditRuler Properties

The IEditRuler type exposes the following members.

Properties
 | Name | Description
Public property | Anchor | When implemented by a class, gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IndentBackColor | When implemented by a class, gets or sets background color of indentation parts of the ruler.
Public property | IsDragging | When implemented by a class, indicates whether some of ruler indentation is in dragging state.
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | MarkWidth | When implemented by a class, gets or sets default distance between adjacent marks.
Public property | Options | When implemented by a class, gets or sets RulerOptions determining ruler behaviour.
Public property | PageStart | When implemented by a class, gets or sets beginning of the page part of the ruler.
Public property | PageWidth | When implemented by a class, gets or sets width, in pixels between left and right indentations indicating width of the page.
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | RulerStart | When implemented by a class, gets or sets position, in pixels, of left indentation specifying start of the page.
Public property | RulerWidth | When implemented by a class, gets or sets ruler width.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Units | When implemented by a class, gets or sets ruler measurement units.
Public property | Vertical | When implemented by a class, gets or sets a boolean value indicating whether ruler has vertical or horizontal direction.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.Anchor Property

IEditRulerAnchor Property
When implemented by a class, gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
AnchorStyles Anchor { get; set; }
Property Anchor As AnchorStyles
    Get
    Set
property AnchorStyles Anchor {
    AnchorStyles get ();
    void set (AnchorStyles value);
}
abstract Anchor : AnchorStyles with get, set

Property Value

Type: AnchorStyles
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.IndentBackColor Property

IEditRulerIndentBackColor Property
When implemented by a class, gets or sets background color of indentation parts of the ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color IndentBackColor { get; set; }
Property IndentBackColor As Color
    Get
    Set
property Color IndentBackColor {
    Color get ();
    void set (Color value);
}
abstract IndentBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.IsDragging Property

IEditRulerIsDragging Property
When implemented by a class, indicates whether some of ruler indentation is in dragging state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsDragging { get; }
ReadOnly Property IsDragging As Boolean
    Get
property bool IsDragging {
    bool get ();
}
abstract IsDragging : bool with get

Property Value

Type: Boolean
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.MarkWidth Property

IEditRulerMarkWidth Property
When implemented by a class, gets or sets default distance between adjacent marks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MarkWidth { get; set; }
Property MarkWidth As Integer
    Get
    Set
property int MarkWidth {
    int get ();
    void set (int value);
}
abstract MarkWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.Options Property

IEditRulerOptions Property
When implemented by a class, gets or sets RulerOptions determining ruler behaviour.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
RulerOptions Options { get; set; }
Property Options As RulerOptions
    Get
    Set
property RulerOptions Options {
    RulerOptions get ();
    void set (RulerOptions value);
}
abstract Options : RulerOptions with get, set

Property Value

Type: RulerOptions
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.PageStart Property

IEditRulerPageStart Property
When implemented by a class, gets or sets beginning of the page part of the ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int PageStart { get; set; }
Property PageStart As Integer
    Get
    Set
property int PageStart {
    int get ();
    void set (int value);
}
abstract PageStart : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.PageWidth Property

IEditRulerPageWidth Property
When implemented by a class, gets or sets width, in pixels between left and right indentations indicating width of the page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int PageWidth { get; set; }
Property PageWidth As Integer
    Get
    Set
property int PageWidth {
    int get ();
    void set (int value);
}
abstract PageWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.RulerStart Property

IEditRulerRulerStart Property
When implemented by a class, gets or sets position, in pixels, of left indentation specifying start of the page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int RulerStart { get; set; }
Property RulerStart As Integer
    Get
    Set
property int RulerStart {
    int get ();
    void set (int value);
}
abstract RulerStart : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.RulerWidth Property

IEditRulerRulerWidth Property
When implemented by a class, gets or sets ruler width.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int RulerWidth { get; set; }
Property RulerWidth As Integer
    Get
    Set
property int RulerWidth {
    int get ();
    void set (int value);
}
abstract RulerWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.Units Property

IEditRulerUnits Property
When implemented by a class, gets or sets ruler measurement units.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
RulerUnits Units { get; set; }
Property Units As RulerUnits
    Get
    Set
property RulerUnits Units {
    RulerUnits get ();
    void set (RulerUnits value);
}
abstract Units : RulerUnits with get, set

Property Value

Type: RulerUnits
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.Vertical Property

IEditRulerVertical Property
When implemented by a class, gets or sets a boolean value indicating whether ruler has vertical or horizontal direction.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Vertical { get; set; }
Property Vertical As Boolean
    Get
    Set
property bool Vertical {
    bool get ();
    void set (bool value);
}
abstract Vertical : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler Events

IEditRuler Events

The IEditRuler type exposes the following members.

Events
 | Name | Description
Public event | Change | When implemented by a class, occurs when some of ruler indentations has changed its position due to the dragging operation.
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Top
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditRuler.Change Event

IEditRulerChange Event
When implemented by a class, occurs when some of ruler indentations has changed its position due to the dragging operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler Change
Event Change As EventHandler
 event EventHandler^ Change {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Change : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IEditRuler Interface
Alternet.Editor Namespace


IEditSpelling Interface

IEditSpelling Interface
Represents properties and methods to allowing to visually highlight misspelled words in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditSpelling : ISpelling
Public Interface IEditSpelling
    Inherits ISpelling
public interface class IEditSpelling : ISpelling
type IEditSpelling =
    interface
        interface ISpelling
    end

The IEditSpelling type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IEditSpelling object.
Public method | IsWordCorrect(String) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | IsWordCorrect(String, Point) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | ResetCheckSpelling | When implemented by a class, resets the CheckSpelling to the default value. (Inherited from ISpelling.)
Public method | ResetSpellColor | When implemented by a class, resets the SpellColor to the default value.
Public method | ResetSpellDelimiters | When implemented by a class, resets the SpellDelimiters to the default value. (Inherited from ISpelling.)
Top
Properties
 | Name | Description
Public property | CheckSpelling | When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content.
Public property | HasSpelling | When implemented by a class, gets boolean value indicating that editor has external spell checker assigned. (Inherited from ISpelling.)
Public property | SpellColor | When implemented by a class, gets or sets a value representing color to draw wavy underlines under misspelled words.
Public property | SpellDelimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text when performing spelling check. (Inherited from ISpelling.)
Public property | SpellDelimiterString | When implemented by a class, gets or sets SpellDelimiters as a single string. (Inherited from ISpelling.)
Public property | SpellTable | When implemented by a class, represents a hash table containing delimiters. (Inherited from ISpelling.)
Top
Events
 | Name | Description
Public event | WordSpell | When implemented by a class, occurs when spelling of some word within the text needs checking. (Inherited from ISpelling.)
Top
See Also

Reference

Alternet.Editor Namespace


IEditSpelling Methods

IEditSpelling Methods

The IEditSpelling type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IEditSpelling object.
Public method | IsWordCorrect(String) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | IsWordCorrect(String, Point) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | ResetCheckSpelling | When implemented by a class, resets the CheckSpelling to the default value. (Inherited from ISpelling.)
Public method | ResetSpellColor | When implemented by a class, resets the SpellColor to the default value.
Public method | ResetSpellDelimiters | When implemented by a class, resets the SpellDelimiters to the default value. (Inherited from ISpelling.)
Top
See Also

Reference

IEditSpelling Interface
Alternet.Editor Namespace


IEditSpelling.Assign Method

IEditSpellingAssign Method
When implemented by a class, copies the contents from another IEditSpelling object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IEditSpelling source
)
Sub Assign (
    source As IEditSpelling
)
void Assign(
    IEditSpelling^ source
)
abstract Assign :
        source : IEditSpelling -> unit

Parameters

source
Type: Alternet.EditorIEditSpelling
Specifies IEditSpelling to assign.
See Also

Reference

IEditSpelling Interface
Alternet.Editor Namespace


IEditSpelling.ResetSpellColor Method

IEditSpellingResetSpellColor Method
When implemented by a class, resets the SpellColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetSpellColor()
Sub ResetSpellColor
void ResetSpellColor()
abstract ResetSpellColor : unit -> unit
See Also

Reference

IEditSpelling Interface
Alternet.Editor Namespace


IEditSpelling Properties

IEditSpelling Properties

The IEditSpelling type exposes the following members.

Properties
 | Name | Description
Public property | CheckSpelling | When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content.
Public property | HasSpelling | When implemented by a class, gets boolean value indicating that editor has external spell checker assigned. (Inherited from ISpelling.)
Public property | SpellColor | When implemented by a class, gets or sets a value representing color to draw wavy underlines under misspelled words.
Public property | SpellDelimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text when performing spelling check. (Inherited from ISpelling.)
Public property | SpellDelimiterString | When implemented by a class, gets or sets SpellDelimiters as a single string. (Inherited from ISpelling.)
Public property | SpellTable | When implemented by a class, represents a hash table containing delimiters. (Inherited from ISpelling.)
Top
See Also

Reference

IEditSpelling Interface
Alternet.Editor Namespace


IEditSpelling.CheckSpelling Property

IEditSpellingCheckSpelling Property
When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CheckSpelling { get; set; }
Property CheckSpelling As Boolean
    Get
    Set
property bool CheckSpelling {
    bool get ();
    void set (bool value);
}
abstract CheckSpelling : bool with get, set

Property Value

Type: Boolean

Implements

ISpellingCheckSpelling
See Also

Reference

IEditSpelling Interface
Alternet.Editor Namespace


IEditSpelling.SpellColor Property

IEditSpellingSpellColor Property
When implemented by a class, gets or sets a value representing color to draw wavy underlines under misspelled words.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color SpellColor { get; set; }
Property SpellColor As Color
    Get
    Set
property Color SpellColor {
    Color get ();
    void set (Color value);
}
abstract SpellColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditSpelling Interface
Alternet.Editor Namespace


IEditSpelling Events

IEditSpelling Events

The IEditSpelling type exposes the following members.

Events
 | Name | Description
Public event | WordSpell | When implemented by a class, occurs when spelling of some word within the text needs checking. (Inherited from ISpelling.)
Top
See Also

Reference

IEditSpelling Interface
Alternet.Editor Namespace


IEditSyntaxPaint Interface

IEditSyntaxPaint Interface
Represents properties and methods to paint editor's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEditSyntaxPaint : ISyntaxPaint
Public Interface IEditSyntaxPaint
    Inherits ISyntaxPaint
public interface class IEditSyntaxPaint : ISyntaxPaint
type IEditSyntaxPaint =
    interface
        interface ISyntaxPaint
    end

The IEditSyntaxPaint type exposes the following members.

Methods
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position. (Inherited from ISyntaxPaint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position. (Inherited from ISyntaxPaint.)
Public method | EqualStyles | When implemented by a class, indicates whether given styles are equal. (Inherited from ISyntaxPaint.)
Public method | GetBackColor | When implemented by a class, retrieves background color in accordance with specified parameter and editor settings.
Public method | GetFontColor | When implemented by a class, retrieves font color corresponding to given state. (Inherited from ISyntaxPaint.)
Public method | GetFontStyle | When implemented by a class, retrieves font style corresponding to given state. (Inherited from ISyntaxPaint.)
Public method | GetForeColor | When implemented by a class, retrieves foreground color in accordance with specified parameter and editor settings.
Public method | GetLexStyle | When implemented by a class, retrieves lex state corresponding to given parser style. (Inherited from ISyntaxPaint.)
Public method | GetRectRegion(Rectangle) | When implemented by a class, returns region corresponding to given rectangle.
Public method | GetRectRegion(SelectionType, Rectangle, Boolean, Boolean) | When implemented by a class, returns region corresponding to given rectangle.
Public method | MeasureLine(Int32, Int32, Int32) | When implemented by a class, measures part of the string given at by its Index. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | When implemented by a class, measures part of given string. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of the string given by its index. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of given string. (Inherited from ISyntaxPaint.)
Public method | OnCustomDraw | When implemented by a class, raises an CustomDraw event. (Inherited from ISyntaxPaint.)
Public method | PaintLineBookMarks | When implemented by a class, paints collection of line bookmark.
Public method | PaintSyntax | When implemented by a class, perform syntax painting of the control on the graphic surface. (Inherited from ISyntaxPaint.)
Public method | PaintWindow | When implemented by a class, paints editor's content.
Public method | ResetColumnsIndentForeColor | When implemented by a class, resets the ColumnsIndentForeColor to the default value.
Public method | ResetDisableColorPaint | When implemented by a class, resets the DisableColorPaint to the default value. (Inherited from ISyntaxPaint.)
Public method | ResetDisabledBackColor | When implemented by a class, resets the DisabledBackColor to the default value.
Public method | ResetDisabledForeColor | When implemented by a class, resets the DisabledForeColor to the default value.
Public method | ResetDisableSyntaxPaint | When implemented by a class, resets the DisableSyntaxPaint to the default value. (Inherited from ISyntaxPaint.)
Public method | ResetDrawColumnsIndent | When implemented by a class, resets the DrawColumnsIndent to the default value.
Public method | ResetReadonlyBackColor | When implemented by a class, resets the ReadonlyBackColor to the default value.
Public method | ResetReadonlyForeColor | When implemented by a class, resets the ReadonlyForeColor to the default value.
Public method | ResetSyntaxErrorsHints | When implemented by a class, resets the SyntaxErrorsHints to the default value.
Top
Properties
 | Name | Description
Public property | ColumnsIndentForeColor | When implemented by a class, specifies columns indentation color.
Public property | DisableColorPaint | When implemented by a class, gets or sets a value indicating whether control uses colors to paint its content. (Inherited from ISyntaxPaint.)
Public property | DisabledBackColor | When implemented by a class, gets or sets background color used in the disabled state.
Public property | DisabledForeColor | When implemented by a class, gets or sets foreground color used in the disabled state.
Public property | DisableSyntaxPaint | When implemented by a class, gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from ISyntaxPaint.)
Public property | DrawColumnsIndent | When implemented by a class, indicates whether edit control should draw columns indentation marks.
Public property | DrawStructureGuideLines | When implemented by a class, indicates whether edit control should draw guide lines.
Public property | GuideLinesForeColor | When implemented by a class, specifies guide lines color.
Public property | Lexer | When implemented by a class, gets or sets object that can make lexical analysis for the control's content. (Inherited from ISyntaxPaint.)
Public property | NeedPaint | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should be repainted now.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from ISyntaxPaint.)
Public property | ReadonlyBackColor | When implemented by a class, gets or sets background color used in the readonly state.
Public property | ReadonlyForeColor | When implemented by a class, gets or sets foreground color used in the readonly state.
Public property | SyntaxErrorsHints | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should display hint over each syntax error in it's content.
Top
Events
 | Name | Description
Public event | CustomDraw | When implemented by a class, occurs when control draws its content. (Inherited from ISyntaxPaint.)
Top
See Also

Reference

Alternet.Editor Namespace


IEditSyntaxPaint Methods

IEditSyntaxPaint Methods

The IEditSyntaxPaint type exposes the following members.

Methods
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position. (Inherited from ISyntaxPaint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position. (Inherited from ISyntaxPaint.)
Public method | EqualStyles | When implemented by a class, indicates whether given styles are equal. (Inherited from ISyntaxPaint.)
Public method | GetBackColor | When implemented by a class, retrieves background color in accordance with specified parameter and editor settings.
Public method | GetFontColor | When implemented by a class, retrieves font color corresponding to given state. (Inherited from ISyntaxPaint.)
Public method | GetFontStyle | When implemented by a class, retrieves font style corresponding to given state. (Inherited from ISyntaxPaint.)
Public method | GetForeColor | When implemented by a class, retrieves foreground color in accordance with specified parameter and editor settings.
Public method | GetLexStyle | When implemented by a class, retrieves lex state corresponding to given parser style. (Inherited from ISyntaxPaint.)
Public method | GetRectRegion(Rectangle) | When implemented by a class, returns region corresponding to given rectangle.
Public method | GetRectRegion(SelectionType, Rectangle, Boolean, Boolean) | When implemented by a class, returns region corresponding to given rectangle.
Public method | MeasureLine(Int32, Int32, Int32) | When implemented by a class, measures part of the string given at by its Index. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | When implemented by a class, measures part of given string. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of the string given by its index. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of given string. (Inherited from ISyntaxPaint.)
Public method | OnCustomDraw | When implemented by a class, raises an CustomDraw event. (Inherited from ISyntaxPaint.)
Public method | PaintLineBookMarks | When implemented by a class, paints collection of line bookmark.
Public method | PaintSyntax | When implemented by a class, perform syntax painting of the control on the graphic surface. (Inherited from ISyntaxPaint.)
Public method | PaintWindow | When implemented by a class, paints editor's content.
Public method | ResetColumnsIndentForeColor | When implemented by a class, resets the ColumnsIndentForeColor to the default value.
Public method | ResetDisableColorPaint | When implemented by a class, resets the DisableColorPaint to the default value. (Inherited from ISyntaxPaint.)
Public method | ResetDisabledBackColor | When implemented by a class, resets the DisabledBackColor to the default value.
Public method | ResetDisabledForeColor | When implemented by a class, resets the DisabledForeColor to the default value.
Public method | ResetDisableSyntaxPaint | When implemented by a class, resets the DisableSyntaxPaint to the default value. (Inherited from ISyntaxPaint.)
Public method | ResetDrawColumnsIndent | When implemented by a class, resets the DrawColumnsIndent to the default value.
Public method | ResetReadonlyBackColor | When implemented by a class, resets the ReadonlyBackColor to the default value.
Public method | ResetReadonlyForeColor | When implemented by a class, resets the ReadonlyForeColor to the default value.
Public method | ResetSyntaxErrorsHints | When implemented by a class, resets the SyntaxErrorsHints to the default value.
Top
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.GetBackColor Method

IEditSyntaxPaintGetBackColor Method
When implemented by a class, retrieves background color in accordance with specified parameter and editor settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color GetBackColor(
    bool readOnly
)
Function GetBackColor (
    readOnly As Boolean
) As Color
Color GetBackColor(
    bool readOnly
)
abstract GetBackColor :
        readOnly : bool -> Color

Parameters

readOnly
Type: SystemBoolean
Specifies whether method should return background color for readonly state.

Return Value

Type: Color
Appropriate background color.
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.GetForeColor Method

IEditSyntaxPaintGetForeColor Method
When implemented by a class, retrieves foreground color in accordance with specified parameter and editor settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color GetForeColor(
    bool readOnly
)
Function GetForeColor (
    readOnly As Boolean
) As Color
Color GetForeColor(
    bool readOnly
)
abstract GetForeColor :
        readOnly : bool -> Color

Parameters

readOnly
Type: SystemBoolean
Specifies whether method should return foreground color for readonly state.

Return Value

Type: Color
Appropriate foreground color.
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.GetRectRegion Method

IEditSyntaxPaintGetRectRegion Method
Overload List
 | Name | Description
Public method | GetRectRegion(Rectangle) | When implemented by a class, returns region corresponding to given rectangle.
Public method | GetRectRegion(SelectionType, Rectangle, Boolean, Boolean) | When implemented by a class, returns region corresponding to given rectangle.
Top
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.GetRectRegion Method (Rectangle)

IEditSyntaxPaintGetRectRegion Method (Rectangle)
When implemented by a class, returns region corresponding to given rectangle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Region GetRectRegion(
    Rectangle rect
)
Function GetRectRegion (
    rect As Rectangle
) As Region
Region^ GetRectRegion(
    Rectangle rect
)
abstract GetRectRegion :
        rect : Rectangle -> Region

Parameters

rect
Type: System.DrawingRectangle
Rectangle to check.

Return Value

Type: Region
Region corresponding to given rectangle.
See Also

Reference

IEditSyntaxPaint Interface
GetRectRegion Overload
Alternet.Editor Namespace


IEditSyntaxPaint.GetRectRegion Method (SelectionType, Rectangle, Boolean, Boolean)

IEditSyntaxPaintGetRectRegion Method (SelectionType, Rectangle, Boolean, Boolean)
When implemented by a class, returns region corresponding to given rectangle.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Region GetRectRegion(
    SelectionType selectionType,
    Rectangle rect,
    bool topLeftEnd,
    bool bottomRightEnd
)
Function GetRectRegion (
    selectionType As SelectionType,
    rect As Rectangle,
    topLeftEnd As Boolean,
    bottomRightEnd As Boolean
) As Region
Region^ GetRectRegion(
    SelectionType selectionType,
    Rectangle rect,
    bool topLeftEnd,
    bool bottomRightEnd
)
abstract GetRectRegion :
        selectionType : SelectionType *
        rect : Rectangle *
        topLeftEnd : bool *
        bottomRightEnd : bool -> Region

Parameters

selectionType
Type: Alternet.EditorSelectionType
Specifies selection type.
rect
Type: System.DrawingRectangle
Rectangle to check.
topLeftEnd
Type: SystemBoolean
Boolean value indicating if the region's topleft corner should be calculated taking into account end of the wrapped line.
bottomRightEnd
Type: SystemBoolean
Boolean value indicating if the region's bottomright corner should be calculated taking into account end of the wrapped line.

Return Value

Type: Region
Region corresponding to given rectangle.
See Also

Reference

IEditSyntaxPaint Interface
GetRectRegion Overload
Alternet.Editor Namespace


IEditSyntaxPaint.PaintLineBookMarks Method

IEditSyntaxPaintPaintLineBookMarks Method
When implemented by a class, paints collection of line bookmark.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintLineBookMarks(
    Rectangle rect
)
Sub PaintLineBookMarks (
    rect As Rectangle
)
void PaintLineBookMarks(
    Rectangle rect
)
abstract PaintLineBookMarks :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangular area of control to draw line bookmarks.
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.PaintWindow Method

IEditSyntaxPaintPaintWindow Method
When implemented by a class, paints editor's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintWindow(
    int startLine,
    Rectangle rect,
    Point location,
    float scaleX,
    float scaleY,
    bool specialPaint,
    bool inPrinting
)
Sub PaintWindow (
    startLine As Integer,
    rect As Rectangle,
    location As Point,
    scaleX As Single,
    scaleY As Single,
    specialPaint As Boolean,
    inPrinting As Boolean
)
void PaintWindow(
    int startLine,
    Rectangle rect,
    Point location,
    float scaleX,
    float scaleY,
    bool specialPaint,
    bool inPrinting
)
abstract PaintWindow :
        startLine : int *
        rect : Rectangle *
        location : Point *
        scaleX : float32 *
        scaleY : float32 *
        specialPaint : bool *
        inPrinting : bool -> unit

Parameters

startLine
Type: SystemInt32
Specifies first line of content to paint.
rect
Type: System.DrawingRectangle
Rectangular area of control to draw.
location
Type: System.DrawingPoint
The Point value that specifies start position to draw content from.
scaleX
Type: SystemSingle
Horizontal scale of the transformation.
scaleY
Type: SystemSingle
Vertical scale of the transformation.
specialPaint
Type: SystemBoolean
Reserved for internal use. Used for Print and Print preview.
inPrinting
Type: SystemBoolean
Reserved for internal use. Used for Print and Print preview.
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ResetColumnsIndentForeColor Method

IEditSyntaxPaintResetColumnsIndentForeColor Method
When implemented by a class, resets the ColumnsIndentForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetColumnsIndentForeColor()
Sub ResetColumnsIndentForeColor
void ResetColumnsIndentForeColor()
abstract ResetColumnsIndentForeColor : unit -> unit
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ResetDisabledBackColor Method

IEditSyntaxPaintResetDisabledBackColor Method
When implemented by a class, resets the DisabledBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDisabledBackColor()
Sub ResetDisabledBackColor
void ResetDisabledBackColor()
abstract ResetDisabledBackColor : unit -> unit
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ResetDisabledForeColor Method

IEditSyntaxPaintResetDisabledForeColor Method
When implemented by a class, resets the DisabledForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDisabledForeColor()
Sub ResetDisabledForeColor
void ResetDisabledForeColor()
abstract ResetDisabledForeColor : unit -> unit
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ResetDrawColumnsIndent Method

IEditSyntaxPaintResetDrawColumnsIndent Method
When implemented by a class, resets the DrawColumnsIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDrawColumnsIndent()
Sub ResetDrawColumnsIndent
void ResetDrawColumnsIndent()
abstract ResetDrawColumnsIndent : unit -> unit
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ResetReadonlyBackColor Method

IEditSyntaxPaintResetReadonlyBackColor Method
When implemented by a class, resets the ReadonlyBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetReadonlyBackColor()
Sub ResetReadonlyBackColor
void ResetReadonlyBackColor()
abstract ResetReadonlyBackColor : unit -> unit
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ResetReadonlyForeColor Method

IEditSyntaxPaintResetReadonlyForeColor Method
When implemented by a class, resets the ReadonlyForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetReadonlyForeColor()
Sub ResetReadonlyForeColor
void ResetReadonlyForeColor()
abstract ResetReadonlyForeColor : unit -> unit
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ResetSyntaxErrorsHints Method

IEditSyntaxPaintResetSyntaxErrorsHints Method
When implemented by a class, resets the SyntaxErrorsHints to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetSyntaxErrorsHints()
Sub ResetSyntaxErrorsHints
void ResetSyntaxErrorsHints()
abstract ResetSyntaxErrorsHints : unit -> unit
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint Properties

IEditSyntaxPaint Properties

The IEditSyntaxPaint type exposes the following members.

Properties
 | Name | Description
Public property | ColumnsIndentForeColor | When implemented by a class, specifies columns indentation color.
Public property | DisableColorPaint | When implemented by a class, gets or sets a value indicating whether control uses colors to paint its content. (Inherited from ISyntaxPaint.)
Public property | DisabledBackColor | When implemented by a class, gets or sets background color used in the disabled state.
Public property | DisabledForeColor | When implemented by a class, gets or sets foreground color used in the disabled state.
Public property | DisableSyntaxPaint | When implemented by a class, gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from ISyntaxPaint.)
Public property | DrawColumnsIndent | When implemented by a class, indicates whether edit control should draw columns indentation marks.
Public property | DrawStructureGuideLines | When implemented by a class, indicates whether edit control should draw guide lines.
Public property | GuideLinesForeColor | When implemented by a class, specifies guide lines color.
Public property | Lexer | When implemented by a class, gets or sets object that can make lexical analysis for the control's content. (Inherited from ISyntaxPaint.)
Public property | NeedPaint | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should be repainted now.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from ISyntaxPaint.)
Public property | ReadonlyBackColor | When implemented by a class, gets or sets background color used in the readonly state.
Public property | ReadonlyForeColor | When implemented by a class, gets or sets foreground color used in the readonly state.
Public property | SyntaxErrorsHints | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should display hint over each syntax error in it's content.
Top
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ColumnsIndentForeColor Property

IEditSyntaxPaintColumnsIndentForeColor Property
When implemented by a class, specifies columns indentation color.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ColumnsIndentForeColor { get; set; }
Property ColumnsIndentForeColor As Color
    Get
    Set
property Color ColumnsIndentForeColor {
    Color get ();
    void set (Color value);
}
abstract ColumnsIndentForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.DisabledBackColor Property

IEditSyntaxPaintDisabledBackColor Property
When implemented by a class, gets or sets background color used in the disabled state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color DisabledBackColor { get; set; }
Property DisabledBackColor As Color
    Get
    Set
property Color DisabledBackColor {
    Color get ();
    void set (Color value);
}
abstract DisabledBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.DisabledForeColor Property

IEditSyntaxPaintDisabledForeColor Property
When implemented by a class, gets or sets foreground color used in the disabled state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color DisabledForeColor { get; set; }
Property DisabledForeColor As Color
    Get
    Set
property Color DisabledForeColor {
    Color get ();
    void set (Color value);
}
abstract DisabledForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.DrawColumnsIndent Property

IEditSyntaxPaintDrawColumnsIndent Property
When implemented by a class, indicates whether edit control should draw columns indentation marks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DrawColumnsIndent { get; set; }
Property DrawColumnsIndent As Boolean
    Get
    Set
property bool DrawColumnsIndent {
    bool get ();
    void set (bool value);
}
abstract DrawColumnsIndent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.DrawStructureGuideLines Property

IEditSyntaxPaintDrawStructureGuideLines Property
When implemented by a class, indicates whether edit control should draw guide lines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DrawStructureGuideLines { get; set; }
Property DrawStructureGuideLines As Boolean
    Get
    Set
property bool DrawStructureGuideLines {
    bool get ();
    void set (bool value);
}
abstract DrawStructureGuideLines : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.GuideLinesForeColor Property

IEditSyntaxPaintGuideLinesForeColor Property
When implemented by a class, specifies guide lines color.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color GuideLinesForeColor { get; set; }
Property GuideLinesForeColor As Color
    Get
    Set
property Color GuideLinesForeColor {
    Color get ();
    void set (Color value);
}
abstract GuideLinesForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.NeedPaint Property

IEditSyntaxPaintNeedPaint Property
When implemented by a class, gets or sets a boolean value that indicates whether Edit control should be repainted now.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedPaint { get; set; }
Property NeedPaint As Boolean
    Get
    Set
property bool NeedPaint {
    bool get ();
    void set (bool value);
}
abstract NeedPaint : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ReadonlyBackColor Property

IEditSyntaxPaintReadonlyBackColor Property
When implemented by a class, gets or sets background color used in the readonly state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ReadonlyBackColor { get; set; }
Property ReadonlyBackColor As Color
    Get
    Set
property Color ReadonlyBackColor {
    Color get ();
    void set (Color value);
}
abstract ReadonlyBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.ReadonlyForeColor Property

IEditSyntaxPaintReadonlyForeColor Property
When implemented by a class, gets or sets foreground color used in the readonly state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ReadonlyForeColor { get; set; }
Property ReadonlyForeColor As Color
    Get
    Set
property Color ReadonlyForeColor {
    Color get ();
    void set (Color value);
}
abstract ReadonlyForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint.SyntaxErrorsHints Property

IEditSyntaxPaintSyntaxErrorsHints Property
When implemented by a class, gets or sets a boolean value that indicates whether Edit control should display hint over each syntax error in it's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SyntaxErrorsHints { get; set; }
Property SyntaxErrorsHints As Boolean
    Get
    Set
property bool SyntaxErrorsHints {
    bool get ();
    void set (bool value);
}
abstract SyntaxErrorsHints : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEditSyntaxPaint Events

IEditSyntaxPaint Events

The IEditSyntaxPaint type exposes the following members.

Events
 | Name | Description
Public event | CustomDraw | When implemented by a class, occurs when control draws its content. (Inherited from ISyntaxPaint.)
Top
See Also

Reference

IEditSyntaxPaint Interface
Alternet.Editor Namespace


IEventHandlers Interface

IEventHandlers Interface
Represents key events for default keymapping.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEventHandlers
Public Interface IEventHandlers
public interface class IEventHandlers
type IEventHandlers =  interface end

The IEventHandlers type exposes the following members.

Properties
 | Name | Description
Public property | EventNames | When implemented by a class, represents names of all available event handlers.
Public property | MacroRecordEvent | When implemented by a class, represents an event to process macro recording.
Top
See Also

Reference

Alternet.Editor Namespace


IEventHandlers Properties

IEventHandlers Properties

The IEventHandlers type exposes the following members.

Properties
 | Name | Description
Public property | EventNames | When implemented by a class, represents names of all available event handlers.
Public property | MacroRecordEvent | When implemented by a class, represents an event to process macro recording.
Top
See Also

Reference

IEventHandlers Interface
Alternet.Editor Namespace


IEventHandlers.EventNames Property

IEventHandlersEventNames Property
When implemented by a class, represents names of all available event handlers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] EventNames { get; }
ReadOnly Property EventNames As String()
    Get
property array<String^>^ EventNames {
    array<String^>^ get ();
}
abstract EventNames : string[] with get

Property Value

Type: String
See Also

Reference

IEventHandlers Interface
Alternet.Editor Namespace


IEventHandlers.MacroRecordEvent Property

IEventHandlersMacroRecordEvent Property
When implemented by a class, represents an event to process macro recording.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
KeyEventEx MacroRecordEvent { get; }
ReadOnly Property MacroRecordEvent As KeyEventEx
    Get
property KeyEventEx^ MacroRecordEvent {
    KeyEventEx^ get ();
}
abstract MacroRecordEvent : KeyEventEx with get

Property Value

Type: KeyEventEx
See Also

Reference

IEventHandlers Interface
Alternet.Editor Namespace


IFmtExport Interface

IFmtExport Interface
Provides methods to save IStringItem elements.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFmtExport : IStringExport
Public Interface IFmtExport
    Inherits IStringExport
public interface class IFmtExport : IStringExport
type IFmtExport =
    interface
        interface IStringExport
    end

The IFmtExport type exposes the following members.

Methods
 | Name | Description
Public method | BeginWrite | When implemented by a class, starts writing routine. (Inherited from IStringExport.)
Public method | EndWrite | When implemented by a class, finalizes writing routine. (Inherited from IStringExport.)
Public method | Write | When implemented by a class, saves entire content. (Inherited from IStringExport.)
Public method | WriteLine | When implemented by a class, saves a particular IStringItem object. (Inherited from IStringExport.)
Top
See Also

Reference

Alternet.Editor Namespace


IFmtExport Methods

IFmtExport Methods

The IFmtExport type exposes the following members.

Methods
 | Name | Description
Public method | BeginWrite | When implemented by a class, starts writing routine. (Inherited from IStringExport.)
Public method | EndWrite | When implemented by a class, finalizes writing routine. (Inherited from IStringExport.)
Public method | Write | When implemented by a class, saves entire content. (Inherited from IStringExport.)
Public method | WriteLine | When implemented by a class, saves a particular IStringItem object. (Inherited from IStringExport.)
Top
See Also

Reference

IFmtExport Interface
Alternet.Editor Namespace


IFmtImport Interface

IFmtImport Interface
Provides methods to load text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFmtImport : IStringImport,
    IDisposable
Public Interface IFmtImport
    Inherits IStringImport, IDisposable
public interface class IFmtImport : IStringImport,
    IDisposable
type IFmtImport =
    interface
        interface IStringImport
        interface IDisposable
    end

The IFmtImport type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | When implemented by a class, starts reading routine. (Inherited from IStringImport.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndRead | When implemented by a class, finalizes reading routine. (Inherited from IStringImport.)
Public method | Read | When implemented by a class, loads entire content. (Inherited from IStringImport.)
Top
Properties
 | Name | Description
Public property | DefaultBackColor | When implemented by a class, defines default back color of the text.
Public property | DefaultForeColor | When implemented by a class, defines default fore color of the text.
Public property | DefaultStyle | When implemented by a class, gets or sets default font style of the text.
Top
Events
 | Name | Description
Public event | ReadFormattedText | When implemented by a class, occurs when formatted text is read.
Top
See Also

Reference

Alternet.Editor Namespace


IFmtImport Methods

IFmtImport Methods

The IFmtImport type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | When implemented by a class, starts reading routine. (Inherited from IStringImport.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndRead | When implemented by a class, finalizes reading routine. (Inherited from IStringImport.)
Public method | Read | When implemented by a class, loads entire content. (Inherited from IStringImport.)
Top
See Also

Reference

IFmtImport Interface
Alternet.Editor Namespace


IFmtImport Properties

IFmtImport Properties

The IFmtImport type exposes the following members.

Properties
 | Name | Description
Public property | DefaultBackColor | When implemented by a class, defines default back color of the text.
Public property | DefaultForeColor | When implemented by a class, defines default fore color of the text.
Public property | DefaultStyle | When implemented by a class, gets or sets default font style of the text.
Top
See Also

Reference

IFmtImport Interface
Alternet.Editor Namespace


IFmtImport.DefaultBackColor Property

IFmtImportDefaultBackColor Property
When implemented by a class, defines default back color of the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color DefaultBackColor { get; set; }
Property DefaultBackColor As Color
    Get
    Set
property Color DefaultBackColor {
    Color get ();
    void set (Color value);
}
abstract DefaultBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IFmtImport Interface
Alternet.Editor Namespace


IFmtImport.DefaultForeColor Property

IFmtImportDefaultForeColor Property
When implemented by a class, defines default fore color of the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color DefaultForeColor { get; set; }
Property DefaultForeColor As Color
    Get
    Set
property Color DefaultForeColor {
    Color get ();
    void set (Color value);
}
abstract DefaultForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IFmtImport Interface
Alternet.Editor Namespace


IFmtImport.DefaultStyle Property

IFmtImportDefaultStyle Property
When implemented by a class, gets or sets default font style of the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
FontStyle DefaultStyle { get; set; }
Property DefaultStyle As FontStyle
    Get
    Set
property FontStyle DefaultStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract DefaultStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

IFmtImport Interface
Alternet.Editor Namespace


IFmtImport Events

IFmtImport Events

The IFmtImport type exposes the following members.

Events
 | Name | Description
Public event | ReadFormattedText | When implemented by a class, occurs when formatted text is read.
Top
See Also

Reference

IFmtImport Interface
Alternet.Editor Namespace


IFmtImport.ReadFormattedText Event

IFmtImportReadFormattedText Event
When implemented by a class, occurs when formatted text is read.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event ReadFormattedTextEvent ReadFormattedText
Event ReadFormattedText As ReadFormattedTextEvent
 event ReadFormattedTextEvent^ ReadFormattedText {
    void add (ReadFormattedTextEvent^ value);
    void remove (ReadFormattedTextEvent^ value);
}
abstract ReadFormattedText : IEvent<ReadFormattedTextEvent,
    ReadFormattedTextEventArgs>

Value

Type: Alternet.SyntaxReadFormattedTextEvent
Remarks
The event handler receives an argument of type EventArgs containing data related to this event.
See Also

Reference

IFmtImport Interface
Alternet.Editor Namespace


IGutter Interface

IGutter Interface
Represents properties and methods to operate with gutter at the left side of the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IGutter : IUpdate,
    IDisposable
Public Interface IGutter
    Inherits IUpdate, IDisposable
public interface class IGutter : IUpdate,
    IDisposable
type IGutter =
    interface
        interface IUpdate
        interface IDisposable
    end

The IGutter type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IGutter object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | GetHitTest | When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method | GetImage | When implemented by a class, gets image from the images collection
Public method | InvalidateLineNumberArea | When implemented by a class, invalidates line number area if it needs to be altered. Specifies whether line number width needs to be recalculated.
Public method | OnClick | When implemented by a class, raises the Click event.
Public method | OnDoubleClick | When implemented by a class, raises the DoubleClick event.
Public method | Paint(IPainter, Rectangle) | When implemented by a class, draws gutter on the specified graphic surface.
Public method | Paint(IPainter, Rectangle, Int32) | When implemented by a class, draws gutter on the specified graphic surface.
Public method | ResetBookMarkImageIndex | When implemented by a class, resets the BookMarkImageIndex to the default value.
Public method | ResetBrushColor | When implemented by a class, resets the Width to the default value.
Public method | ResetDrawLineBookmarks | When implemented by a class, resets the DrawLineBookmarks to the default value.
Public method | ResetHighlightOutlineAreaColor | When implemented by a class, resets the HighlightOutlineAreaColor to the default value.
Public method | ResetLineBookmarksColor | When implemented by a class, resets the LineBookmarksColor to the default value.
Public method | ResetLineModificatorChangedColor | When implemented by a class, resets the LineModificatorChangedColor to the default value.
Public method | ResetLineModificatorSavedColor | When implemented by a class, resets the LineModificatorSavedColor to the default value.
Public method | ResetLineNumbersAlignment | When implemented by a class, resets the LineNumbersAlignment to the default value.
Public method | ResetLineNumbersBackColor | When implemented by a class, resets the LineNumbersBackColor to the default value.
Public method | ResetLineNumbersForeColor | When implemented by a class, resets the LineNumbersForeColor to the default value.
Public method | ResetLineNumbersLeftIndent | When implemented by a class, resets the LineNumbersLeftIndent to the default value.
Public method | ResetLineNumbersRightIndent | When implemented by a class, resets the LineNumbersRightIndent to the default value.
Public method | ResetLineNumbersStart | When implemented by a class, resets the LineNumbersStart to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ResetOutlineImageBackColor | When implemented by a class, resets the OutlineImageBackColor to the default value.
Public method | ResetOutliningLeftIndent | When implemented by a class, resets the OutliningLeftIndentt to the default value.
Public method | ResetOutliningRightIndent | When implemented by a class, resets the OutliningRightIndent to the default value.
Public method | ResetPenColor | When implemented by a class, resets the PenColor to the default value.
Public method | ResetShowBookmarkHints | When implemented by a class, resets the ShowBookmarkHints to the default value.
Public method | ResetUserMarginBackColor | When implemented by a class, resets the UserMarginBackColor to the default value.
Public method | ResetUserMarginForeColor | When implemented by a class, resets the UserMarginForeColor to the default value.
Public method | ResetUserMarginText | When implemented by a class, resets the UserMarginText to the default value.
Public method | ResetUserMarginWidth | When implemented by a class, resets the UserMarginWidth to the default value.
Public method | ResetVisible | When implemented by a class, resets the Visible to the default value.
Public method | ResetWidth | When implemented by a class, resets the Width to the default value.
Public method | ResetWrapImageIndex | When implemented by a class, resets the WrapImageIndex to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | BookMarkImageIndex | When implemented by a class, gets or sets a value that specifies index of item in the image collection used to paint bookmark.
Public property | Brush | When implemented by a class, gets or sets a Brush object used to paint gutter.
Public property | BrushColor | When implemented by a class, gets or sets background color of the gutter.
Public property | BulbImageIndex | When implemented by a class, gets or sets a value that specifies index of item in the image collection used to paint light bulb.
Public property | DisplayArea | When implemented by a class, gets display area of the gutter, including line numbers and outlining area, but not including line modificators if they're painted outside gutter.
Public property | DisplayWidth | When implemented by a class, gets display width of the gutter, including line numbers and outlining area.
Public property | DrawLineBookmarks | When implemented by a class, gets or sets a value indicating whether Edit control should draw triangle at bookmark position inside line.
Public property | HighlightBlockAreaColor | When implemented by a class, gets or sets a background color of the highlighted block area.
Public property | HighlightOutlineAreaColor | When implemented by a class, gets or sets a background color of the highlighted outline area.
Public property | Images | When implemented by a class, gets or sets an ImageList object that contains collection of images for gutter.
Public property | ImagesHighDpi | When implemented by a class, gets or sets an ImageList object that contains collection of images for gutter for high DPI.
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix.
Public property | LineBookmarksColor | When implemented by a class, gets or sets a color of the line bookmarks.
Public property | LineModificatorChangedColor | When implemented by a class, gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the modified state.
Public property | LineModificatorSavedColor | When implemented by a class, gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the saved state.
Public property | LineNumbersAlignment | When implemented by a class, gets or sets line numbers alignment information.
Public property | LineNumbersBackColor | When implemented by a class, gets or sets background color of the line numbers.
Public property | LineNumbersForeColor | When implemented by a class, gets or sets foreground color of the line numbers.
Public property | LineNumbersLeftIndent | When implemented by a class, gets or sets line numbers indentation from the left gutter border. When auto scaling enabled, measured in DIP.
Public property | LineNumbersLeftIndentInPixels | When implemented by a class, gets line numbers indentation from the left gutter border in pixels.
Public property | LineNumbersRightIndent | When implemented by a class, gets or sets line numbers indentation from the right gutter border. When auto scaling enabled, measured in DIP.
Public property | LineNumbersRightIndentInPixels | When implemented by a class, gets line numbers indentation from the right gutter border in pixels.
Public property | LineNumbersStart | When implemented by a class, gets or sets index of the first line being painted on the gutter.
Public property | MaxLineNumberLength | When implemented by a class, gets or sets maximum count of numbers in the line number.
Public property | Options | When implemented by a class, gets or sets a GutterOptions that determine gutter appearance and behaviour.
Public property | OutlineImageBackColor | When implemented by a class, gets or sets an outline image back color..
Public property | OutliningLeftIndent | When implemented by a class, gets or sets outlining indentation from the left gutter border. When auto scaling enabled, measured in DIP.
Public property | OutliningLeftIndentInPixels | When implemented by a class, gets outlining indentation from the left gutter border in pixels.
Public property | OutliningRightIndent | When implemented by a class, gets or sets outlining indentation from the right gutter border. When auto scaling enabled, measured in DIP.
Public property | OutliningRightIndentInPixels | When implemented by a class, gets outlining indentation from the right gutter border in pixels.
Public property | Pen | When implemented by a class, gets or sets a Pen object used to paint gutter line.
Public property | PenColor | When implemented by a class, gets or sets color of the gutter line.
Public property | Rect | When implemented by a class, gets the rectangle that represents gutter area.
Public property | ShowBookmarkHints | When implemented by a class, gets or sets a value indicating whether Edit control should display text describing bookmark in form of tooltip window when mouse pointer is over the gutter bookmark.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UserMarginBackColor | When implemented by a class, gets or sets background color of the user margin.
Public property | UserMarginForeColor | When implemented by a class, gets or sets foreground color for the user margin.
Public property | UserMarginText | When implemented by a class, gets or sets text of the user margin.
Public property | UserMarginWidth | When implemented by a class, gets or sets the width of the user margin area. When auto scaling enabled, measured in DIP.
Public property | UserMarginWidthInPixels | When implemented by a class, gets the width of the user margin area in pixels.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the gutter area is visible.
Public property | Width | When implemented by a class, gets or sets the width of the gutter. When auto scaling enabled, measured in DIP.
Public property | WidthInPixels | When implemented by a class, gets the width of the gutter in pixels.
Public property | WrapImageIndex | When implemented by a class, gets or sets a value that specifies index of item in the image collection used to paint special mark indicating the wrapped line.
Top
Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the IGutter clicked.
Public event | DoubleClick | When implemented by a class, occurs when the IGutter double-clicked.
Public event | DrawUserMargin | When implemented by a class, occurs when user margin part of each line is drawing.
Top
See Also

Reference

Alternet.Editor Namespace


IGutter Methods

IGutter Methods

The IGutter type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IGutter object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | GetHitTest | When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method | GetImage | When implemented by a class, gets image from the images collection
Public method | InvalidateLineNumberArea | When implemented by a class, invalidates line number area if it needs to be altered. Specifies whether line number width needs to be recalculated.
Public method | OnClick | When implemented by a class, raises the Click event.
Public method | OnDoubleClick | When implemented by a class, raises the DoubleClick event.
Public method | Paint(IPainter, Rectangle) | When implemented by a class, draws gutter on the specified graphic surface.
Public method | Paint(IPainter, Rectangle, Int32) | When implemented by a class, draws gutter on the specified graphic surface.
Public method | ResetBookMarkImageIndex | When implemented by a class, resets the BookMarkImageIndex to the default value.
Public method | ResetBrushColor | When implemented by a class, resets the Width to the default value.
Public method | ResetDrawLineBookmarks | When implemented by a class, resets the DrawLineBookmarks to the default value.
Public method | ResetHighlightOutlineAreaColor | When implemented by a class, resets the HighlightOutlineAreaColor to the default value.
Public method | ResetLineBookmarksColor | When implemented by a class, resets the LineBookmarksColor to the default value.
Public method | ResetLineModificatorChangedColor | When implemented by a class, resets the LineModificatorChangedColor to the default value.
Public method | ResetLineModificatorSavedColor | When implemented by a class, resets the LineModificatorSavedColor to the default value.
Public method | ResetLineNumbersAlignment | When implemented by a class, resets the LineNumbersAlignment to the default value.
Public method | ResetLineNumbersBackColor | When implemented by a class, resets the LineNumbersBackColor to the default value.
Public method | ResetLineNumbersForeColor | When implemented by a class, resets the LineNumbersForeColor to the default value.
Public method | ResetLineNumbersLeftIndent | When implemented by a class, resets the LineNumbersLeftIndent to the default value.
Public method | ResetLineNumbersRightIndent | When implemented by a class, resets the LineNumbersRightIndent to the default value.
Public method | ResetLineNumbersStart | When implemented by a class, resets the LineNumbersStart to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ResetOutlineImageBackColor | When implemented by a class, resets the OutlineImageBackColor to the default value.
Public method | ResetOutliningLeftIndent | When implemented by a class, resets the OutliningLeftIndentt to the default value.
Public method | ResetOutliningRightIndent | When implemented by a class, resets the OutliningRightIndent to the default value.
Public method | ResetPenColor | When implemented by a class, resets the PenColor to the default value.
Public method | ResetShowBookmarkHints | When implemented by a class, resets the ShowBookmarkHints to the default value.
Public method | ResetUserMarginBackColor | When implemented by a class, resets the UserMarginBackColor to the default value.
Public method | ResetUserMarginForeColor | When implemented by a class, resets the UserMarginForeColor to the default value.
Public method | ResetUserMarginText | When implemented by a class, resets the UserMarginText to the default value.
Public method | ResetUserMarginWidth | When implemented by a class, resets the UserMarginWidth to the default value.
Public method | ResetVisible | When implemented by a class, resets the Visible to the default value.
Public method | ResetWidth | When implemented by a class, resets the Width to the default value.
Public method | ResetWrapImageIndex | When implemented by a class, resets the WrapImageIndex to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Assign Method

IGutterAssign Method
When implemented by a class, copies the contents from another IGutter object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IGutter source
)
Sub Assign (
    source As IGutter
)
void Assign(
    IGutter^ source
)
abstract Assign :
        source : IGutter -> unit

Parameters

source
Type: Alternet.EditorIGutter
Specifies IGutter to assign.
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.GetHitTest Method

IGutterGetHitTest Method
When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetHitTest(
    int x,
    int y,
    IHitTestInfo hitTestInfo
)
Sub GetHitTest (
    x As Integer,
    y As Integer,
    hitTestInfo As IHitTestInfo
)
void GetHitTest(
    int x,
    int y,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTest :
        x : int *
        y : int *
        hitTestInfo : IHitTestInfo -> unit

Parameters

x
Type: SystemInt32
Specifies horizontal coordinate of position to check.
y
Type: SystemInt32
Specifies vertical coordinate of position to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.GetImage Method

IGutterGetImage Method
When implemented by a class, gets image from the images collection

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Image GetImage(
    int index
)
Function GetImage (
    index As Integer
) As Image
Image^ GetImage(
    int index
)
abstract GetImage :
        index : int -> Image

Parameters

index
Type: SystemInt32
Image index

Return Value

Type: Image
Image at given index.
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.InvalidateLineNumberArea Method

IGutterInvalidateLineNumberArea Method
When implemented by a class, invalidates line number area if it needs to be altered. Specifies whether line number width needs to be recalculated.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool InvalidateLineNumberArea(
    bool updateWidth
)
Function InvalidateLineNumberArea (
    updateWidth As Boolean
) As Boolean
bool InvalidateLineNumberArea(
    bool updateWidth
)
abstract InvalidateLineNumberArea :
        updateWidth : bool -> bool

Parameters

updateWidth
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.OnClick Method

IGutterOnClick Method
When implemented by a class, raises the Click event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnClick(
    EventArgs e
)
Sub OnClick (
    e As EventArgs
)
void OnClick(
    EventArgs^ e
)
abstract OnClick :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
The EventArgs that contains data to this event.
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.OnDoubleClick Method

IGutterOnDoubleClick Method
When implemented by a class, raises the DoubleClick event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnDoubleClick(
    EventArgs e
)
Sub OnDoubleClick (
    e As EventArgs
)
void OnDoubleClick(
    EventArgs^ e
)
abstract OnDoubleClick :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
The EventArgs that contains data to this event.
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Paint Method

IGutterPaint Method
Overload List
 | Name | Description
Public method | Paint(IPainter, Rectangle) | When implemented by a class, draws gutter on the specified graphic surface.
Public method | Paint(IPainter, Rectangle, Int32) | When implemented by a class, draws gutter on the specified graphic surface.
Top
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Paint Method (IPainter, Rectangle)

IGutterPaint Method (IPainter, Rectangle)
When implemented by a class, draws gutter on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Paint(
    IPainter painter,
    Rectangle rect
)
Sub Paint (
    painter As IPainter,
    rect As Rectangle
)
void Paint(
    IPainter^ painter,
    Rectangle rect
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of gutter to draw.
See Also

Reference

IGutter Interface
Paint Overload
Alternet.Editor Namespace


IGutter.Paint Method (IPainter, Rectangle, Int32)

IGutterPaint Method (IPainter, Rectangle, Int32)
When implemented by a class, draws gutter on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Paint(
    IPainter painter,
    Rectangle rect,
    int startLine
)
Sub Paint (
    painter As IPainter,
    rect As Rectangle,
    startLine As Integer
)
void Paint(
    IPainter^ painter,
    Rectangle rect,
    int startLine
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle *
        startLine : int -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of gutter to draw.
startLine
Type: SystemInt32
The first display line to draw.
See Also

Reference

IGutter Interface
Paint Overload
Alternet.Editor Namespace


IGutter.ResetBookMarkImageIndex Method

IGutterResetBookMarkImageIndex Method
When implemented by a class, resets the BookMarkImageIndex to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBookMarkImageIndex()
Sub ResetBookMarkImageIndex
void ResetBookMarkImageIndex()
abstract ResetBookMarkImageIndex : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetBrushColor Method

IGutterResetBrushColor Method
When implemented by a class, resets the Width to the default value.
When implemented by a class, resets the BrushColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBrushColor()
Sub ResetBrushColor
void ResetBrushColor()
abstract ResetBrushColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetDrawLineBookmarks Method

IGutterResetDrawLineBookmarks Method
When implemented by a class, resets the DrawLineBookmarks to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDrawLineBookmarks()
Sub ResetDrawLineBookmarks
void ResetDrawLineBookmarks()
abstract ResetDrawLineBookmarks : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetHighlightOutlineAreaColor Method

IGutterResetHighlightOutlineAreaColor Method
When implemented by a class, resets the HighlightOutlineAreaColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetHighlightOutlineAreaColor()
Sub ResetHighlightOutlineAreaColor
void ResetHighlightOutlineAreaColor()
abstract ResetHighlightOutlineAreaColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetLineBookmarksColor Method

IGutterResetLineBookmarksColor Method
When implemented by a class, resets the LineBookmarksColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineBookmarksColor()
Sub ResetLineBookmarksColor
void ResetLineBookmarksColor()
abstract ResetLineBookmarksColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetLineModificatorChangedColor Method

IGutterResetLineModificatorChangedColor Method
When implemented by a class, resets the LineModificatorChangedColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineModificatorChangedColor()
Sub ResetLineModificatorChangedColor
void ResetLineModificatorChangedColor()
abstract ResetLineModificatorChangedColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetLineModificatorSavedColor Method

IGutterResetLineModificatorSavedColor Method
When implemented by a class, resets the LineModificatorSavedColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineModificatorSavedColor()
Sub ResetLineModificatorSavedColor
void ResetLineModificatorSavedColor()
abstract ResetLineModificatorSavedColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetLineNumbersAlignment Method

IGutterResetLineNumbersAlignment Method
When implemented by a class, resets the LineNumbersAlignment to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineNumbersAlignment()
Sub ResetLineNumbersAlignment
void ResetLineNumbersAlignment()
abstract ResetLineNumbersAlignment : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetLineNumbersBackColor Method

IGutterResetLineNumbersBackColor Method
When implemented by a class, resets the LineNumbersBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineNumbersBackColor()
Sub ResetLineNumbersBackColor
void ResetLineNumbersBackColor()
abstract ResetLineNumbersBackColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetLineNumbersForeColor Method

IGutterResetLineNumbersForeColor Method
When implemented by a class, resets the LineNumbersForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineNumbersForeColor()
Sub ResetLineNumbersForeColor
void ResetLineNumbersForeColor()
abstract ResetLineNumbersForeColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetLineNumbersLeftIndent Method

IGutterResetLineNumbersLeftIndent Method
When implemented by a class, resets the LineNumbersLeftIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineNumbersLeftIndent()
Sub ResetLineNumbersLeftIndent
void ResetLineNumbersLeftIndent()
abstract ResetLineNumbersLeftIndent : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetLineNumbersRightIndent Method

IGutterResetLineNumbersRightIndent Method
When implemented by a class, resets the LineNumbersRightIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineNumbersRightIndent()
Sub ResetLineNumbersRightIndent
void ResetLineNumbersRightIndent()
abstract ResetLineNumbersRightIndent : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetLineNumbersStart Method

IGutterResetLineNumbersStart Method
When implemented by a class, resets the LineNumbersStart to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineNumbersStart()
Sub ResetLineNumbersStart
void ResetLineNumbersStart()
abstract ResetLineNumbersStart : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetOptions Method

IGutterResetOptions Method
When implemented by a class, resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOptions()
Sub ResetOptions
void ResetOptions()
abstract ResetOptions : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetOutlineImageBackColor Method

IGutterResetOutlineImageBackColor Method
When implemented by a class, resets the OutlineImageBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOutlineImageBackColor()
Sub ResetOutlineImageBackColor
void ResetOutlineImageBackColor()
abstract ResetOutlineImageBackColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetOutliningLeftIndent Method

IGutterResetOutliningLeftIndent Method
When implemented by a class, resets the OutliningLeftIndentt to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOutliningLeftIndent()
Sub ResetOutliningLeftIndent
void ResetOutliningLeftIndent()
abstract ResetOutliningLeftIndent : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetOutliningRightIndent Method

IGutterResetOutliningRightIndent Method
When implemented by a class, resets the OutliningRightIndent to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOutliningRightIndent()
Sub ResetOutliningRightIndent
void ResetOutliningRightIndent()
abstract ResetOutliningRightIndent : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetPenColor Method

IGutterResetPenColor Method
When implemented by a class, resets the PenColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetPenColor()
Sub ResetPenColor
void ResetPenColor()
abstract ResetPenColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetShowBookmarkHints Method

IGutterResetShowBookmarkHints Method
When implemented by a class, resets the ShowBookmarkHints to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetShowBookmarkHints()
Sub ResetShowBookmarkHints
void ResetShowBookmarkHints()
abstract ResetShowBookmarkHints : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetUserMarginBackColor Method

IGutterResetUserMarginBackColor Method
When implemented by a class, resets the UserMarginBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUserMarginBackColor()
Sub ResetUserMarginBackColor
void ResetUserMarginBackColor()
abstract ResetUserMarginBackColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetUserMarginForeColor Method

IGutterResetUserMarginForeColor Method
When implemented by a class, resets the UserMarginForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUserMarginForeColor()
Sub ResetUserMarginForeColor
void ResetUserMarginForeColor()
abstract ResetUserMarginForeColor : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetUserMarginText Method

IGutterResetUserMarginText Method
When implemented by a class, resets the UserMarginText to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUserMarginText()
Sub ResetUserMarginText
void ResetUserMarginText()
abstract ResetUserMarginText : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetUserMarginWidth Method

IGutterResetUserMarginWidth Method
When implemented by a class, resets the UserMarginWidth to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUserMarginWidth()
Sub ResetUserMarginWidth
void ResetUserMarginWidth()
abstract ResetUserMarginWidth : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetVisible Method

IGutterResetVisible Method
When implemented by a class, resets the Visible to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetVisible()
Sub ResetVisible
void ResetVisible()
abstract ResetVisible : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetWidth Method

IGutterResetWidth Method
When implemented by a class, resets the Width to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetWidth()
Sub ResetWidth
void ResetWidth()
abstract ResetWidth : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ResetWrapImageIndex Method

IGutterResetWrapImageIndex Method
When implemented by a class, resets the WrapImageIndex to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetWrapImageIndex()
Sub ResetWrapImageIndex
void ResetWrapImageIndex()
abstract ResetWrapImageIndex : unit -> unit
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter Properties

IGutter Properties

The IGutter type exposes the following members.

Properties
 | Name | Description
Public property | BookMarkImageIndex | When implemented by a class, gets or sets a value that specifies index of item in the image collection used to paint bookmark.
Public property | Brush | When implemented by a class, gets or sets a Brush object used to paint gutter.
Public property | BrushColor | When implemented by a class, gets or sets background color of the gutter.
Public property | BulbImageIndex | When implemented by a class, gets or sets a value that specifies index of item in the image collection used to paint light bulb.
Public property | DisplayArea | When implemented by a class, gets display area of the gutter, including line numbers and outlining area, but not including line modificators if they're painted outside gutter.
Public property | DisplayWidth | When implemented by a class, gets display width of the gutter, including line numbers and outlining area.
Public property | DrawLineBookmarks | When implemented by a class, gets or sets a value indicating whether Edit control should draw triangle at bookmark position inside line.
Public property | HighlightBlockAreaColor | When implemented by a class, gets or sets a background color of the highlighted block area.
Public property | HighlightOutlineAreaColor | When implemented by a class, gets or sets a background color of the highlighted outline area.
Public property | Images | When implemented by a class, gets or sets an ImageList object that contains collection of images for gutter.
Public property | ImagesHighDpi | When implemented by a class, gets or sets an ImageList object that contains collection of images for gutter for high DPI.
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix.
Public property | LineBookmarksColor | When implemented by a class, gets or sets a color of the line bookmarks.
Public property | LineModificatorChangedColor | When implemented by a class, gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the modified state.
Public property | LineModificatorSavedColor | When implemented by a class, gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the saved state.
Public property | LineNumbersAlignment | When implemented by a class, gets or sets line numbers alignment information.
Public property | LineNumbersBackColor | When implemented by a class, gets or sets background color of the line numbers.
Public property | LineNumbersForeColor | When implemented by a class, gets or sets foreground color of the line numbers.
Public property | LineNumbersLeftIndent | When implemented by a class, gets or sets line numbers indentation from the left gutter border. When auto scaling enabled, measured in DIP.
Public property | LineNumbersLeftIndentInPixels | When implemented by a class, gets line numbers indentation from the left gutter border in pixels.
Public property | LineNumbersRightIndent | When implemented by a class, gets or sets line numbers indentation from the right gutter border. When auto scaling enabled, measured in DIP.
Public property | LineNumbersRightIndentInPixels | When implemented by a class, gets line numbers indentation from the right gutter border in pixels.
Public property | LineNumbersStart | When implemented by a class, gets or sets index of the first line being painted on the gutter.
Public property | MaxLineNumberLength | When implemented by a class, gets or sets maximum count of numbers in the line number.
Public property | Options | When implemented by a class, gets or sets a GutterOptions that determine gutter appearance and behaviour.
Public property | OutlineImageBackColor | When implemented by a class, gets or sets an outline image back color..
Public property | OutliningLeftIndent | When implemented by a class, gets or sets outlining indentation from the left gutter border. When auto scaling enabled, measured in DIP.
Public property | OutliningLeftIndentInPixels | When implemented by a class, gets outlining indentation from the left gutter border in pixels.
Public property | OutliningRightIndent | When implemented by a class, gets or sets outlining indentation from the right gutter border. When auto scaling enabled, measured in DIP.
Public property | OutliningRightIndentInPixels | When implemented by a class, gets outlining indentation from the right gutter border in pixels.
Public property | Pen | When implemented by a class, gets or sets a Pen object used to paint gutter line.
Public property | PenColor | When implemented by a class, gets or sets color of the gutter line.
Public property | Rect | When implemented by a class, gets the rectangle that represents gutter area.
Public property | ShowBookmarkHints | When implemented by a class, gets or sets a value indicating whether Edit control should display text describing bookmark in form of tooltip window when mouse pointer is over the gutter bookmark.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UserMarginBackColor | When implemented by a class, gets or sets background color of the user margin.
Public property | UserMarginForeColor | When implemented by a class, gets or sets foreground color for the user margin.
Public property | UserMarginText | When implemented by a class, gets or sets text of the user margin.
Public property | UserMarginWidth | When implemented by a class, gets or sets the width of the user margin area. When auto scaling enabled, measured in DIP.
Public property | UserMarginWidthInPixels | When implemented by a class, gets the width of the user margin area in pixels.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the gutter area is visible.
Public property | Width | When implemented by a class, gets or sets the width of the gutter. When auto scaling enabled, measured in DIP.
Public property | WidthInPixels | When implemented by a class, gets the width of the gutter in pixels.
Public property | WrapImageIndex | When implemented by a class, gets or sets a value that specifies index of item in the image collection used to paint special mark indicating the wrapped line.
Top
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.BookMarkImageIndex Property

IGutterBookMarkImageIndex Property
When implemented by a class, gets or sets a value that specifies index of item in the image collection used to paint bookmark.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int BookMarkImageIndex { get; set; }
Property BookMarkImageIndex As Integer
    Get
    Set
property int BookMarkImageIndex {
    int get ();
    void set (int value);
}
abstract BookMarkImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Brush Property

IGutterBrush Property
When implemented by a class, gets or sets a Brush object used to paint gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Brush Brush { get; set; }
Property Brush As Brush
    Get
    Set
property Brush^ Brush {
    Brush^ get ();
    void set (Brush^ value);
}
abstract Brush : Brush with get, set

Property Value

Type: Brush
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.BrushColor Property

IGutterBrushColor Property
When implemented by a class, gets or sets background color of the gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BrushColor { get; set; }
Property BrushColor As Color
    Get
    Set
property Color BrushColor {
    Color get ();
    void set (Color value);
}
abstract BrushColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.BulbImageIndex Property

IGutterBulbImageIndex Property
When implemented by a class, gets or sets a value that specifies index of item in the image collection used to paint light bulb.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int BulbImageIndex { get; set; }
Property BulbImageIndex As Integer
    Get
    Set
property int BulbImageIndex {
    int get ();
    void set (int value);
}
abstract BulbImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.DisplayArea Property

IGutterDisplayArea Property
When implemented by a class, gets display area of the gutter, including line numbers and outlining area, but not including line modificators if they're painted outside gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int DisplayArea { get; }
ReadOnly Property DisplayArea As Integer
    Get
property int DisplayArea {
    int get ();
}
abstract DisplayArea : int with get

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.DisplayWidth Property

IGutterDisplayWidth Property
When implemented by a class, gets display width of the gutter, including line numbers and outlining area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int DisplayWidth { get; }
ReadOnly Property DisplayWidth As Integer
    Get
property int DisplayWidth {
    int get ();
}
abstract DisplayWidth : int with get

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.DrawLineBookmarks Property

IGutterDrawLineBookmarks Property
When implemented by a class, gets or sets a value indicating whether Edit control should draw triangle at bookmark position inside line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DrawLineBookmarks { get; set; }
Property DrawLineBookmarks As Boolean
    Get
    Set
property bool DrawLineBookmarks {
    bool get ();
    void set (bool value);
}
abstract DrawLineBookmarks : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.HighlightBlockAreaColor Property

IGutterHighlightBlockAreaColor Property
When implemented by a class, gets or sets a background color of the highlighted block area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color HighlightBlockAreaColor { get; set; }
Property HighlightBlockAreaColor As Color
    Get
    Set
property Color HighlightBlockAreaColor {
    Color get ();
    void set (Color value);
}
abstract HighlightBlockAreaColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.HighlightOutlineAreaColor Property

IGutterHighlightOutlineAreaColor Property
When implemented by a class, gets or sets a background color of the highlighted outline area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color HighlightOutlineAreaColor { get; set; }
Property HighlightOutlineAreaColor As Color
    Get
    Set
property Color HighlightOutlineAreaColor {
    Color get ();
    void set (Color value);
}
abstract HighlightOutlineAreaColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Images Property

IGutterImages Property
When implemented by a class, gets or sets an ImageList object that contains collection of images for gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList Images { get; set; }
Property Images As ImageList
    Get
    Set
property ImageList^ Images {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract Images : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ImagesHighDpi Property

IGutterImagesHighDpi Property
When implemented by a class, gets or sets an ImageList object that contains collection of images for gutter for high DPI.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList ImagesHighDpi { get; set; }
Property ImagesHighDpi As ImageList
    Get
    Set
property ImageList^ ImagesHighDpi {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract ImagesHighDpi : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ImagesResourceNameSuffix Property

IGutterImagesResourceNameSuffix Property
When implemented by a class, gets or sets the images resource name suffix.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ImagesResourceNameSuffix { get; set; }
Property ImagesResourceNameSuffix As String
    Get
    Set
property String^ ImagesResourceNameSuffix {
    String^ get ();
    void set (String^ value);
}
abstract ImagesResourceNameSuffix : string with get, set

Property Value

Type: String
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineBookmarksColor Property

IGutterLineBookmarksColor Property
When implemented by a class, gets or sets a color of the line bookmarks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color LineBookmarksColor { get; set; }
Property LineBookmarksColor As Color
    Get
    Set
property Color LineBookmarksColor {
    Color get ();
    void set (Color value);
}
abstract LineBookmarksColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineModificatorChangedColor Property

IGutterLineModificatorChangedColor Property
When implemented by a class, gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the modified state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color LineModificatorChangedColor { get; set; }
Property LineModificatorChangedColor As Color
    Get
    Set
property Color LineModificatorChangedColor {
    Color get ();
    void set (Color value);
}
abstract LineModificatorChangedColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineModificatorSavedColor Property

IGutterLineModificatorSavedColor Property
When implemented by a class, gets or sets a color of the line modificators(color stitch that indicates that the line content is unmodified, modified or saved) in the saved state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color LineModificatorSavedColor { get; set; }
Property LineModificatorSavedColor As Color
    Get
    Set
property Color LineModificatorSavedColor {
    Color get ();
    void set (Color value);
}
abstract LineModificatorSavedColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineNumbersAlignment Property

IGutterLineNumbersAlignment Property
When implemented by a class, gets or sets line numbers alignment information.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
StringAlignment LineNumbersAlignment { get; set; }
Property LineNumbersAlignment As StringAlignment
    Get
    Set
property StringAlignment LineNumbersAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
abstract LineNumbersAlignment : StringAlignment with get, set

Property Value

Type: StringAlignment
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineNumbersBackColor Property

IGutterLineNumbersBackColor Property
When implemented by a class, gets or sets background color of the line numbers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color LineNumbersBackColor { get; set; }
Property LineNumbersBackColor As Color
    Get
    Set
property Color LineNumbersBackColor {
    Color get ();
    void set (Color value);
}
abstract LineNumbersBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineNumbersForeColor Property

IGutterLineNumbersForeColor Property
When implemented by a class, gets or sets foreground color of the line numbers.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color LineNumbersForeColor { get; set; }
Property LineNumbersForeColor As Color
    Get
    Set
property Color LineNumbersForeColor {
    Color get ();
    void set (Color value);
}
abstract LineNumbersForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineNumbersLeftIndent Property

IGutterLineNumbersLeftIndent Property
When implemented by a class, gets or sets line numbers indentation from the left gutter border. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LineNumbersLeftIndent { get; set; }
Property LineNumbersLeftIndent As Integer
    Get
    Set
property int LineNumbersLeftIndent {
    int get ();
    void set (int value);
}
abstract LineNumbersLeftIndent : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineNumbersLeftIndentInPixels Property

IGutterLineNumbersLeftIndentInPixels Property
When implemented by a class, gets line numbers indentation from the left gutter border in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LineNumbersLeftIndentInPixels { get; }
ReadOnly Property LineNumbersLeftIndentInPixels As Integer
    Get
property int LineNumbersLeftIndentInPixels {
    int get ();
}
abstract LineNumbersLeftIndentInPixels : int with get

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineNumbersRightIndent Property

IGutterLineNumbersRightIndent Property
When implemented by a class, gets or sets line numbers indentation from the right gutter border. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LineNumbersRightIndent { get; set; }
Property LineNumbersRightIndent As Integer
    Get
    Set
property int LineNumbersRightIndent {
    int get ();
    void set (int value);
}
abstract LineNumbersRightIndent : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineNumbersRightIndentInPixels Property

IGutterLineNumbersRightIndentInPixels Property
When implemented by a class, gets line numbers indentation from the right gutter border in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LineNumbersRightIndentInPixels { get; }
ReadOnly Property LineNumbersRightIndentInPixels As Integer
    Get
property int LineNumbersRightIndentInPixels {
    int get ();
}
abstract LineNumbersRightIndentInPixels : int with get

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.LineNumbersStart Property

IGutterLineNumbersStart Property
When implemented by a class, gets or sets index of the first line being painted on the gutter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LineNumbersStart { get; set; }
Property LineNumbersStart As Integer
    Get
    Set
property int LineNumbersStart {
    int get ();
    void set (int value);
}
abstract LineNumbersStart : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.MaxLineNumberLength Property

IGutterMaxLineNumberLength Property
When implemented by a class, gets or sets maximum count of numbers in the line number.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxLineNumberLength { get; set; }
Property MaxLineNumberLength As Integer
    Get
    Set
property int MaxLineNumberLength {
    int get ();
    void set (int value);
}
abstract MaxLineNumberLength : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Options Property

IGutterOptions Property
When implemented by a class, gets or sets a GutterOptions that determine gutter appearance and behaviour.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
GutterOptions Options { get; set; }
Property Options As GutterOptions
    Get
    Set
property GutterOptions Options {
    GutterOptions get ();
    void set (GutterOptions value);
}
abstract Options : GutterOptions with get, set

Property Value

Type: GutterOptions
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.OutlineImageBackColor Property

IGutterOutlineImageBackColor Property
When implemented by a class, gets or sets an outline image back color..

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color OutlineImageBackColor { get; set; }
Property OutlineImageBackColor As Color
    Get
    Set
property Color OutlineImageBackColor {
    Color get ();
    void set (Color value);
}
abstract OutlineImageBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.OutliningLeftIndent Property

IGutterOutliningLeftIndent Property
When implemented by a class, gets or sets outlining indentation from the left gutter border. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int OutliningLeftIndent { get; set; }
Property OutliningLeftIndent As Integer
    Get
    Set
property int OutliningLeftIndent {
    int get ();
    void set (int value);
}
abstract OutliningLeftIndent : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.OutliningLeftIndentInPixels Property

IGutterOutliningLeftIndentInPixels Property
When implemented by a class, gets outlining indentation from the left gutter border in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int OutliningLeftIndentInPixels { get; }
ReadOnly Property OutliningLeftIndentInPixels As Integer
    Get
property int OutliningLeftIndentInPixels {
    int get ();
}
abstract OutliningLeftIndentInPixels : int with get

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.OutliningRightIndent Property

IGutterOutliningRightIndent Property
When implemented by a class, gets or sets outlining indentation from the right gutter border. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int OutliningRightIndent { get; set; }
Property OutliningRightIndent As Integer
    Get
    Set
property int OutliningRightIndent {
    int get ();
    void set (int value);
}
abstract OutliningRightIndent : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.OutliningRightIndentInPixels Property

IGutterOutliningRightIndentInPixels Property
When implemented by a class, gets outlining indentation from the right gutter border in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int OutliningRightIndentInPixels { get; }
ReadOnly Property OutliningRightIndentInPixels As Integer
    Get
property int OutliningRightIndentInPixels {
    int get ();
}
abstract OutliningRightIndentInPixels : int with get

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Pen Property

IGutterPen Property
When implemented by a class, gets or sets a Pen object used to paint gutter line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Pen Pen { get; set; }
Property Pen As Pen
    Get
    Set
property Pen^ Pen {
    Pen^ get ();
    void set (Pen^ value);
}
abstract Pen : Pen with get, set

Property Value

Type: Pen
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.PenColor Property

IGutterPenColor Property
When implemented by a class, gets or sets color of the gutter line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color PenColor { get; set; }
Property PenColor As Color
    Get
    Set
property Color PenColor {
    Color get ();
    void set (Color value);
}
abstract PenColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Rect Property

IGutterRect Property
When implemented by a class, gets the rectangle that represents gutter area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle Rect { get; }
ReadOnly Property Rect As Rectangle
    Get
property Rectangle Rect {
    Rectangle get ();
}
abstract Rect : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.ShowBookmarkHints Property

IGutterShowBookmarkHints Property
When implemented by a class, gets or sets a value indicating whether Edit control should display text describing bookmark in form of tooltip window when mouse pointer is over the gutter bookmark.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowBookmarkHints { get; set; }
Property ShowBookmarkHints As Boolean
    Get
    Set
property bool ShowBookmarkHints {
    bool get ();
    void set (bool value);
}
abstract ShowBookmarkHints : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.UserMarginBackColor Property

IGutterUserMarginBackColor Property
When implemented by a class, gets or sets background color of the user margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color UserMarginBackColor { get; set; }
Property UserMarginBackColor As Color
    Get
    Set
property Color UserMarginBackColor {
    Color get ();
    void set (Color value);
}
abstract UserMarginBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.UserMarginForeColor Property

IGutterUserMarginForeColor Property
When implemented by a class, gets or sets foreground color for the user margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color UserMarginForeColor { get; set; }
Property UserMarginForeColor As Color
    Get
    Set
property Color UserMarginForeColor {
    Color get ();
    void set (Color value);
}
abstract UserMarginForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.UserMarginText Property

IGutterUserMarginText Property
When implemented by a class, gets or sets text of the user margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string UserMarginText { get; set; }
Property UserMarginText As String
    Get
    Set
property String^ UserMarginText {
    String^ get ();
    void set (String^ value);
}
abstract UserMarginText : string with get, set

Property Value

Type: String
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.UserMarginWidth Property

IGutterUserMarginWidth Property
When implemented by a class, gets or sets the width of the user margin area. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int UserMarginWidth { get; set; }
Property UserMarginWidth As Integer
    Get
    Set
property int UserMarginWidth {
    int get ();
    void set (int value);
}
abstract UserMarginWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.UserMarginWidthInPixels Property

IGutterUserMarginWidthInPixels Property
When implemented by a class, gets the width of the user margin area in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int UserMarginWidthInPixels { get; }
ReadOnly Property UserMarginWidthInPixels As Integer
    Get
property int UserMarginWidthInPixels {
    int get ();
}
abstract UserMarginWidthInPixels : int with get

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Visible Property

IGutterVisible Property
When implemented by a class, gets or sets a value indicating whether the gutter area is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Width Property

IGutterWidth Property
When implemented by a class, gets or sets the width of the gutter. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Width { get; set; }
Property Width As Integer
    Get
    Set
property int Width {
    int get ();
    void set (int value);
}
abstract Width : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.WidthInPixels Property

IGutterWidthInPixels Property
When implemented by a class, gets the width of the gutter in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int WidthInPixels { get; }
ReadOnly Property WidthInPixels As Integer
    Get
property int WidthInPixels {
    int get ();
}
abstract WidthInPixels : int with get

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.WrapImageIndex Property

IGutterWrapImageIndex Property
When implemented by a class, gets or sets a value that specifies index of item in the image collection used to paint special mark indicating the wrapped line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int WrapImageIndex { get; set; }
Property WrapImageIndex As Integer
    Get
    Set
property int WrapImageIndex {
    int get ();
    void set (int value);
}
abstract WrapImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter Events

IGutter Events

The IGutter type exposes the following members.

Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the IGutter clicked.
Public event | DoubleClick | When implemented by a class, occurs when the IGutter double-clicked.
Public event | DrawUserMargin | When implemented by a class, occurs when user margin part of each line is drawing.
Top
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.Click Event

IGutterClick Event
When implemented by a class, occurs when the IGutter clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler Click
Event Click As EventHandler
 event EventHandler^ Click {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Click : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.DoubleClick Event

IGutterDoubleClick Event
When implemented by a class, occurs when the IGutter double-clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler DoubleClick
Event DoubleClick As EventHandler
 event EventHandler^ DoubleClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DoubleClick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IGutter.DrawUserMargin Event

IGutterDrawUserMargin Event
When implemented by a class, occurs when user margin part of each line is drawing.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event DrawUserMarginEvent DrawUserMargin
Event DrawUserMargin As DrawUserMarginEvent
 event DrawUserMarginEvent^ DrawUserMargin {
    void add (DrawUserMarginEvent^ value);
    void remove (DrawUserMarginEvent^ value);
}
abstract DrawUserMargin : IEvent<DrawUserMarginEvent,
    DrawUserMarginEventArgs>

Value

Type: Alternet.EditorDrawUserMarginEvent
See Also

Reference

IGutter Interface
Alternet.Editor Namespace


IHitTestInfo Interface

IHitTestInfo Interface
Contains information about an area of an Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IHitTestInfo
Public Interface IHitTestInfo
public interface class IHitTestInfo
type IHitTestInfo =  interface end

The IHitTestInfo type exposes the following members.

Methods
 | Name | Description
Public method | Reset | When implemented by a class, resets HitTestInfo members to their default values.
Top
Properties
 | Name | Description
Public property | Bookmark | When implemented by a class, gets or sets the IBookmark index, evaluated by the hit-test operation. Contains index of the bookmark if mouse is over the gutter image; - 1 otherwise.
Public property | Group | When implemented by a class, gets or sets the IBookmark group, evaluated by the hit-test operation.
Public property | GutterImage | When implemented by a class, gets or sets the Gutter ImageIndex, evaluated by the hit-test operation. Contains index of image if mouse is over the gutter image; - 1 otherwise.
Public property | GutterImageRect | Gets or sets the area of gutter image, evaluated by the hit-test operation. Contains area of the image if mouse is over the gutter image; - 1 otherwise.
Public property | HitTest | When implemented by a class, gets or sets the HitTest that represents the area of the Edit control evaluated by the hit-test operation.
Public property | Item | When implemented by a class, gets or sets the IStrItem object evaluated by the hit-test operation. Contains instance of IStrItem object if mouse is over text line in Edit control; null otherwise.
Public property | Line | When implemented by a class, gets or sets the index of line evaluated by the hit-test operation. Contains index of line if mouse is over text line in Edit control; -1 otherwise.
Public property | OutlineIndex | When implemented by a class, gets or sets the index of line where outline image is displayed, evaluated by the hit-test operation. Contains index of line if mouse is over the outline button; - 1 otherwise.
Public property | OutlineRange | When implemented by a class, gets or sets the IOutlineRange object evaluated by the hit-test operation. Contains instance of IOutlineRange object if mouse is over outline button; null otherwise.
Public property | Page | When implemented by a class, gets or sets the index of page evaluated by the hit-test operation. Contains index of page if mouse is over text page in Edit control; null otherwise.
Public property | Pos | When implemented by a class, gets or sets the index of character within the line evaluated by the hit-test operation. Contains index of line if mouse is over some text in Edit control; -1 otherwise.
Public property | String | When implemented by a class, gets or sets the text string evaluated by the hit-test operation. Contains string if mouse is over text line in Edit control; null otherwise.
Public property | Style | When implemented by a class, gets or sets the index of lexical style evaluated by the hit-test operation. Contains index of lexical style if mouse is over the text; - 1 otherwise.
Public property | TextStyle | When implemented by a class, gets or sets the set of additional flags for the text fragment evaluated by the hit-test operation.
Public property | Url | Gets the hypertext string evaluated by the hit-test operation. Contains string if mouse is over hypertext section in Edit control; null otherwise.
Public property | Word | When implemented by a class, gets or sets the word evaluated by the hit-test operation. Contains string if mouse is over some word in Edit control; null otherwise.
Top
See Also

Reference

Alternet.Editor Namespace


IHitTestInfo Methods

IHitTestInfo Methods

The IHitTestInfo type exposes the following members.

Methods
 | Name | Description
Public method | Reset | When implemented by a class, resets HitTestInfo members to their default values.
Top
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Reset Method

IHitTestInfoReset Method
When implemented by a class, resets HitTestInfo members to their default values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo Properties

IHitTestInfo Properties

The IHitTestInfo type exposes the following members.

Properties
 | Name | Description
Public property | Bookmark | When implemented by a class, gets or sets the IBookmark index, evaluated by the hit-test operation. Contains index of the bookmark if mouse is over the gutter image; - 1 otherwise.
Public property | Group | When implemented by a class, gets or sets the IBookmark group, evaluated by the hit-test operation.
Public property | GutterImage | When implemented by a class, gets or sets the Gutter ImageIndex, evaluated by the hit-test operation. Contains index of image if mouse is over the gutter image; - 1 otherwise.
Public property | GutterImageRect | Gets or sets the area of gutter image, evaluated by the hit-test operation. Contains area of the image if mouse is over the gutter image; - 1 otherwise.
Public property | HitTest | When implemented by a class, gets or sets the HitTest that represents the area of the Edit control evaluated by the hit-test operation.
Public property | Item | When implemented by a class, gets or sets the IStrItem object evaluated by the hit-test operation. Contains instance of IStrItem object if mouse is over text line in Edit control; null otherwise.
Public property | Line | When implemented by a class, gets or sets the index of line evaluated by the hit-test operation. Contains index of line if mouse is over text line in Edit control; -1 otherwise.
Public property | OutlineIndex | When implemented by a class, gets or sets the index of line where outline image is displayed, evaluated by the hit-test operation. Contains index of line if mouse is over the outline button; - 1 otherwise.
Public property | OutlineRange | When implemented by a class, gets or sets the IOutlineRange object evaluated by the hit-test operation. Contains instance of IOutlineRange object if mouse is over outline button; null otherwise.
Public property | Page | When implemented by a class, gets or sets the index of page evaluated by the hit-test operation. Contains index of page if mouse is over text page in Edit control; null otherwise.
Public property | Pos | When implemented by a class, gets or sets the index of character within the line evaluated by the hit-test operation. Contains index of line if mouse is over some text in Edit control; -1 otherwise.
Public property | String | When implemented by a class, gets or sets the text string evaluated by the hit-test operation. Contains string if mouse is over text line in Edit control; null otherwise.
Public property | Style | When implemented by a class, gets or sets the index of lexical style evaluated by the hit-test operation. Contains index of lexical style if mouse is over the text; - 1 otherwise.
Public property | TextStyle | When implemented by a class, gets or sets the set of additional flags for the text fragment evaluated by the hit-test operation.
Public property | Url | Gets the hypertext string evaluated by the hit-test operation. Contains string if mouse is over hypertext section in Edit control; null otherwise.
Public property | Word | When implemented by a class, gets or sets the word evaluated by the hit-test operation. Contains string if mouse is over some word in Edit control; null otherwise.
Top
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Bookmark Property

IHitTestInfoBookmark Property
When implemented by a class, gets or sets the IBookmark index, evaluated by the hit-test operation. Contains index of the bookmark if mouse is over the gutter image; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Bookmark { get; set; }
Property Bookmark As Integer
    Get
    Set
property int Bookmark {
    int get ();
    void set (int value);
}
abstract Bookmark : int with get, set

Property Value

Type: Int32
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Group Property

IHitTestInfoGroup Property
When implemented by a class, gets or sets the IBookmark group, evaluated by the hit-test operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Group { get; set; }
Property Group As Integer
    Get
    Set
property int Group {
    int get ();
    void set (int value);
}
abstract Group : int with get, set

Property Value

Type: Int32
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.GutterImage Property

IHitTestInfoGutterImage Property
When implemented by a class, gets or sets the Gutter ImageIndex, evaluated by the hit-test operation. Contains index of image if mouse is over the gutter image; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GutterImage { get; set; }
Property GutterImage As Integer
    Get
    Set
property int GutterImage {
    int get ();
    void set (int value);
}
abstract GutterImage : int with get, set

Property Value

Type: Int32
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.GutterImageRect Property

IHitTestInfoGutterImageRect Property
Gets or sets the area of gutter image, evaluated by the hit-test operation. Contains area of the image if mouse is over the gutter image; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle GutterImageRect { get; set; }
Property GutterImageRect As Rectangle
    Get
    Set
property Rectangle GutterImageRect {
    Rectangle get ();
    void set (Rectangle value);
}
abstract GutterImageRect : Rectangle with get, set

Property Value

Type: Rectangle
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.HitTest Property

IHitTestInfoHitTest Property
When implemented by a class, gets or sets the HitTest that represents the area of the Edit control evaluated by the hit-test operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
HitTest HitTest { get; set; }
Property HitTest As HitTest
    Get
    Set
property HitTest HitTest {
    HitTest get ();
    void set (HitTest value);
}
abstract HitTest : HitTest with get, set

Property Value

Type: HitTest
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Item Property

IHitTestInfoItem Property
When implemented by a class, gets or sets the IStrItem object evaluated by the hit-test operation. Contains instance of IStrItem object if mouse is over text line in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IStringItem Item { get; set; }
Property Item As IStringItem
    Get
    Set
property IStringItem^ Item {
    IStringItem^ get ();
    void set (IStringItem^ value);
}
abstract Item : IStringItem with get, set

Property Value

Type: IStringItem
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Line Property

IHitTestInfoLine Property
When implemented by a class, gets or sets the index of line evaluated by the hit-test operation. Contains index of line if mouse is over text line in Edit control; -1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Line { get; set; }
Property Line As Integer
    Get
    Set
property int Line {
    int get ();
    void set (int value);
}
abstract Line : int with get, set

Property Value

Type: Int32
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.OutlineIndex Property

IHitTestInfoOutlineIndex Property
When implemented by a class, gets or sets the index of line where outline image is displayed, evaluated by the hit-test operation. Contains index of line if mouse is over the outline button; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int OutlineIndex { get; set; }
Property OutlineIndex As Integer
    Get
    Set
property int OutlineIndex {
    int get ();
    void set (int value);
}
abstract OutlineIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.OutlineRange Property

IHitTestInfoOutlineRange Property
When implemented by a class, gets or sets the IOutlineRange object evaluated by the hit-test operation. Contains instance of IOutlineRange object if mouse is over outline button; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange OutlineRange { get; set; }
Property OutlineRange As IOutlineRange
    Get
    Set
property IOutlineRange^ OutlineRange {
    IOutlineRange^ get ();
    void set (IOutlineRange^ value);
}
abstract OutlineRange : IOutlineRange with get, set

Property Value

Type: IOutlineRange
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Page Property

IHitTestInfoPage Property
When implemented by a class, gets or sets the index of page evaluated by the hit-test operation. Contains index of page if mouse is over text page in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Page { get; set; }
Property Page As Integer
    Get
    Set
property int Page {
    int get ();
    void set (int value);
}
abstract Page : int with get, set

Property Value

Type: Int32
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Pos Property

IHitTestInfoPos Property
When implemented by a class, gets or sets the index of character within the line evaluated by the hit-test operation. Contains index of line if mouse is over some text in Edit control; -1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Pos { get; set; }
Property Pos As Integer
    Get
    Set
property int Pos {
    int get ();
    void set (int value);
}
abstract Pos : int with get, set

Property Value

Type: Int32
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.String Property

IHitTestInfoString Property
When implemented by a class, gets or sets the text string evaluated by the hit-test operation. Contains string if mouse is over text line in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string String { get; set; }
Property String As String
    Get
    Set
property String^ String {
    String^ get ();
    void set (String^ value);
}
abstract String : string with get, set

Property Value

Type: String
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Style Property

IHitTestInfoStyle Property
When implemented by a class, gets or sets the index of lexical style evaluated by the hit-test operation. Contains index of lexical style if mouse is over the text; - 1 otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Style { get; set; }
Property Style As Integer
    Get
    Set
property int Style {
    int get ();
    void set (int value);
}
abstract Style : int with get, set

Property Value

Type: Int32
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.TextStyle Property

IHitTestInfoTextStyle Property
When implemented by a class, gets or sets the set of additional flags for the text fragment evaluated by the hit-test operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TextStyle TextStyle { get; set; }
Property TextStyle As TextStyle
    Get
    Set
property TextStyle TextStyle {
    TextStyle get ();
    void set (TextStyle value);
}
abstract TextStyle : TextStyle with get, set

Property Value

Type: TextStyle
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Url Property

IHitTestInfoUrl Property
Gets the hypertext string evaluated by the hit-test operation. Contains string if mouse is over hypertext section in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Url { get; set; }
Property Url As String
    Get
    Set
property String^ Url {
    String^ get ();
    void set (String^ value);
}
abstract Url : string with get, set

Property Value

Type: String
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IHitTestInfo.Word Property

IHitTestInfoWord Property
When implemented by a class, gets or sets the word evaluated by the hit-test operation. Contains string if mouse is over some word in Edit control; null otherwise.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Word { get; set; }
Property Word As String
    Get
    Set
property String^ Word {
    String^ get ();
    void set (String^ value);
}
abstract Word : string with get, set

Property Value

Type: String
See Also

Reference

IHitTestInfo Interface
Alternet.Editor Namespace


IKeyData Interface

IKeyData Interface
Represents properties and methods describing some data attached to the particular key.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IKeyData
Public Interface IKeyData
public interface class IKeyData
type IKeyData =  interface end

The IKeyData type exposes the following members.

Properties
 | Name | Description
Public property | Action | When implemented by a class, represents an action that executes when the key is pressed.
Public property | ActionEx | When implemented by a class, represents extended action that executes when the key is pressed.
Public property | EventName | When implemented by a class, represents a name of the action.
Public property | Keys | When implemented by a class, represents a key to which some action is attached.
Public property | LeaveState | When implemented by a class, represents a state of the Edit control after key is pressed.
Public property | Param | When implemented by a class, represents an object passed as a parameter to the extended action.
Public property | State | When implemented by a class, represents a state of the Edit control before key is pressed.
Top
See Also

Reference

Alternet.Editor Namespace


IKeyData Properties

IKeyData Properties

The IKeyData type exposes the following members.

Properties
 | Name | Description
Public property | Action | When implemented by a class, represents an action that executes when the key is pressed.
Public property | ActionEx | When implemented by a class, represents extended action that executes when the key is pressed.
Public property | EventName | When implemented by a class, represents a name of the action.
Public property | Keys | When implemented by a class, represents a key to which some action is attached.
Public property | LeaveState | When implemented by a class, represents a state of the Edit control after key is pressed.
Public property | Param | When implemented by a class, represents an object passed as a parameter to the extended action.
Public property | State | When implemented by a class, represents a state of the Edit control before key is pressed.
Top
See Also

Reference

IKeyData Interface
Alternet.Editor Namespace


IKeyData.Action Property

IKeyDataAction Property
When implemented by a class, represents an action that executes when the key is pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
KeyEvent Action { get; set; }
Property Action As KeyEvent
    Get
    Set
property KeyEvent^ Action {
    KeyEvent^ get ();
    void set (KeyEvent^ value);
}
abstract Action : KeyEvent with get, set

Property Value

Type: KeyEvent
See Also

Reference

IKeyData Interface
Alternet.Editor Namespace


IKeyData.ActionEx Property

IKeyDataActionEx Property
When implemented by a class, represents extended action that executes when the key is pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
KeyEventEx ActionEx { get; set; }
Property ActionEx As KeyEventEx
    Get
    Set
property KeyEventEx^ ActionEx {
    KeyEventEx^ get ();
    void set (KeyEventEx^ value);
}
abstract ActionEx : KeyEventEx with get, set

Property Value

Type: KeyEventEx
See Also

Reference

IKeyData Interface
Alternet.Editor Namespace


IKeyData.EventName Property

IKeyDataEventName Property
When implemented by a class, represents a name of the action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string EventName { get; set; }
Property EventName As String
    Get
    Set
property String^ EventName {
    String^ get ();
    void set (String^ value);
}
abstract EventName : string with get, set

Property Value

Type: String
See Also

Reference

IKeyData Interface
Alternet.Editor Namespace


IKeyData.Keys Property

IKeyDataKeys Property
When implemented by a class, represents a key to which some action is attached.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Keys Keys { get; set; }
Property Keys As Keys
    Get
    Set
property Keys Keys {
    Keys get ();
    void set (Keys value);
}
abstract Keys : Keys with get, set

Property Value

Type: Keys
See Also

Reference

IKeyData Interface
Alternet.Editor Namespace


IKeyData.LeaveState Property

IKeyDataLeaveState Property
When implemented by a class, represents a state of the Edit control after key is pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LeaveState { get; set; }
Property LeaveState As Integer
    Get
    Set
property int LeaveState {
    int get ();
    void set (int value);
}
abstract LeaveState : int with get, set

Property Value

Type: Int32
See Also

Reference

IKeyData Interface
Alternet.Editor Namespace


IKeyData.Param Property

IKeyDataParam Property
When implemented by a class, represents an object passed as a parameter to the extended action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Param { get; set; }
Property Param As Object
    Get
    Set
property Object^ Param {
    Object^ get ();
    void set (Object^ value);
}
abstract Param : Object with get, set

Property Value

Type: Object
See Also

Reference

IKeyData Interface
Alternet.Editor Namespace


IKeyData.State Property

IKeyDataState Property
When implemented by a class, represents a state of the Edit control before key is pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int State { get; set; }
Property State As Integer
    Get
    Set
property int State {
    int get ();
    void set (int value);
}
abstract State : int with get, set

Property Value

Type: Int32
See Also

Reference

IKeyData Interface
Alternet.Editor Namespace


IKeyList Interface

IKeyList Interface
Represents list of key or its combinations with attached actions.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IKeyList
Public Interface IKeyList
public interface class IKeyList
type IKeyList =  interface end

The IKeyList type exposes the following members.

Methods
 | Name | Description
Public method | Add(Keys, KeyEvent) | When implemented by a class, adds a new key to key collection with specified action.
Public method | Add(Keys, KeyEventEx, Object) | When implemented by a class, adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEvent, Int32, Int32) | When implemented by a class, adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEventEx, Object, Int32, Int32) | When implemented by a class, adds a new key to key collection with specified parameters.
Public method | AddNormal(Keys, KeyEvent) | When implemented by a class, adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | AddNormal(Keys, KeyEventEx, Object) | When implemented by a class, adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | Clear | When implemented by a class, removes all elements from the key list.
Public method | ExecuteKey | When implemented by a class, executes action or extended action attached to the specified key.
Public method | FindKey | When implemented by a class, indicates whether given key locates within the collection.
Public method | Remove(Keys) | When implemented by a class, removes given key from the key collection.
Public method | Remove(Keys, Int32) | When implemented by a class, removes given key from the key collection.
Top
Properties
 | Name | Description
Public property | EventData | When implemented by a class, represents array of event handlers associated with keys.
Public property | Handlers | When implemented by a class, represents an event handlers collection which contains elements that can be used as a particular action attached to key or key combination from the IKeyList.
Top
See Also

Reference

Alternet.Editor Namespace


IKeyList Methods

IKeyList Methods

The IKeyList type exposes the following members.

Methods
 | Name | Description
Public method | Add(Keys, KeyEvent) | When implemented by a class, adds a new key to key collection with specified action.
Public method | Add(Keys, KeyEventEx, Object) | When implemented by a class, adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEvent, Int32, Int32) | When implemented by a class, adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEventEx, Object, Int32, Int32) | When implemented by a class, adds a new key to key collection with specified parameters.
Public method | AddNormal(Keys, KeyEvent) | When implemented by a class, adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | AddNormal(Keys, KeyEventEx, Object) | When implemented by a class, adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | Clear | When implemented by a class, removes all elements from the key list.
Public method | ExecuteKey | When implemented by a class, executes action or extended action attached to the specified key.
Public method | FindKey | When implemented by a class, indicates whether given key locates within the collection.
Public method | Remove(Keys) | When implemented by a class, removes given key from the key collection.
Public method | Remove(Keys, Int32) | When implemented by a class, removes given key from the key collection.
Top
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


IKeyList.Add Method

IKeyListAdd Method
Overload List
 | Name | Description
Public method | Add(Keys, KeyEvent) | When implemented by a class, adds a new key to key collection with specified action.
Public method | Add(Keys, KeyEventEx, Object) | When implemented by a class, adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEvent, Int32, Int32) | When implemented by a class, adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEventEx, Object, Int32, Int32) | When implemented by a class, adds a new key to key collection with specified parameters.
Top
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


IKeyList.Add Method (Keys, KeyEvent)

IKeyListAdd Method (Keys, KeyEvent)
When implemented by a class, adds a new key to key collection with specified action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Add(
    Keys keys,
    KeyEvent action
)
Sub Add (
    keys As Keys,
    action As KeyEvent
)
void Add(
    Keys keys,
    KeyEvent^ action
)
abstract Add :
        keys : Keys *
        action : KeyEvent -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEvent
Action that executes when the key is pressed.
See Also

Reference

IKeyList Interface
Add Overload
Alternet.Editor Namespace


IKeyList.Add Method (Keys, KeyEventEx, Object)

IKeyListAdd Method (Keys, KeyEventEx, Object)
When implemented by a class, adds a new key to key collection with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Add(
    Keys keys,
    KeyEventEx action,
    Object param
)
Sub Add (
    keys As Keys,
    action As KeyEventEx,
    param As Object
)
void Add(
    Keys keys,
    KeyEventEx^ action,
    Object^ param
)
abstract Add :
        keys : Keys *
        action : KeyEventEx *
        param : Object -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEventEx
Extended action that executes when the key is pressed.
param
Type: SystemObject
Object passed as a parameter to the extended action.
See Also

Reference

IKeyList Interface
Add Overload
Alternet.Editor Namespace


IKeyList.Add Method (Keys, KeyEvent, Int32, Int32)

IKeyListAdd Method (Keys, KeyEvent, Int32, Int32)
When implemented by a class, adds a new key to key collection with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Add(
    Keys keys,
    KeyEvent action,
    int state,
    int leaveState
)
Sub Add (
    keys As Keys,
    action As KeyEvent,
    state As Integer,
    leaveState As Integer
)
void Add(
    Keys keys,
    KeyEvent^ action,
    int state,
    int leaveState
)
abstract Add :
        keys : Keys *
        action : KeyEvent *
        state : int *
        leaveState : int -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEvent
Action that executes when the key is pressed.
state
Type: SystemInt32
State of the Edit control before key is pressed.
leaveState
Type: SystemInt32
State of the Edit control after key is pressed.
See Also

Reference

IKeyList Interface
Add Overload
Alternet.Editor Namespace


IKeyList.Add Method (Keys, KeyEventEx, Object, Int32, Int32)

IKeyListAdd Method (Keys, KeyEventEx, Object, Int32, Int32)
When implemented by a class, adds a new key to key collection with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Add(
    Keys keys,
    KeyEventEx action,
    Object param,
    int state,
    int leaveState
)
Sub Add (
    keys As Keys,
    action As KeyEventEx,
    param As Object,
    state As Integer,
    leaveState As Integer
)
void Add(
    Keys keys,
    KeyEventEx^ action,
    Object^ param,
    int state,
    int leaveState
)
abstract Add :
        keys : Keys *
        action : KeyEventEx *
        param : Object *
        state : int *
        leaveState : int -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEventEx
Extended action that executes when the key is pressed.
param
Type: SystemObject
Object passed as a parameter to the extended action.
state
Type: SystemInt32
State of the Edit control when key is pressed.
leaveState
Type: SystemInt32
State of the Edit control after key is pressed.
See Also

Reference

IKeyList Interface
Add Overload
Alternet.Editor Namespace


IKeyList.AddNormal Method

IKeyListAddNormal Method
Overload List
 | Name | Description
Public method | AddNormal(Keys, KeyEvent) | When implemented by a class, adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | AddNormal(Keys, KeyEventEx, Object) | When implemented by a class, adds a new key to key collection with specified parameters and default (normal) state and leave state.
Top
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


IKeyList.AddNormal Method (Keys, KeyEvent)

IKeyListAddNormal Method (Keys, KeyEvent)
When implemented by a class, adds a new key to key collection with specified parameters and default (normal) state and leave state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddNormal(
    Keys keys,
    KeyEvent action
)
Sub AddNormal (
    keys As Keys,
    action As KeyEvent
)
void AddNormal(
    Keys keys,
    KeyEvent^ action
)
abstract AddNormal :
        keys : Keys *
        action : KeyEvent -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key that added to the collection.
action
Type: Alternet.EditorKeyEvent
Action that executes when the key is pressed.
See Also

Reference

IKeyList Interface
AddNormal Overload
Alternet.Editor Namespace


IKeyList.AddNormal Method (Keys, KeyEventEx, Object)

IKeyListAddNormal Method (Keys, KeyEventEx, Object)
When implemented by a class, adds a new key to key collection with specified parameters and default (normal) state and leave state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddNormal(
    Keys keys,
    KeyEventEx action,
    Object param
)
Sub AddNormal (
    keys As Keys,
    action As KeyEventEx,
    param As Object
)
void AddNormal(
    Keys keys,
    KeyEventEx^ action,
    Object^ param
)
abstract AddNormal :
        keys : Keys *
        action : KeyEventEx *
        param : Object -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEventEx
Extended action that executes when the key is pressed.
param
Type: SystemObject
Object passed as a parameter to the extended action.
See Also

Reference

IKeyList Interface
AddNormal Overload
Alternet.Editor Namespace


IKeyList.Clear Method

IKeyListClear Method
When implemented by a class, removes all elements from the key list.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


IKeyList.ExecuteKey Method

IKeyListExecuteKey Method
When implemented by a class, executes action or extended action attached to the specified key.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ExecuteKey(
    Keys keys,
    ref int state
)
Function ExecuteKey (
    keys As Keys,
    ByRef state As Integer
) As Boolean
bool ExecuteKey(
    Keys keys,
    int% state
)
abstract ExecuteKey :
        keys : Keys *
        state : int byref -> bool

Parameters

keys
Type: System.Windows.FormsKeys
Key for which action should be executed.
state
Type: SystemInt32
Receive leave state of specified action.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


IKeyList.FindKey Method

IKeyListFindKey Method
When implemented by a class, indicates whether given key locates within the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindKey(
    Keys keys,
    int state
)
Function FindKey (
    keys As Keys,
    state As Integer
) As Boolean
bool FindKey(
    Keys keys,
    int state
)
abstract FindKey :
        keys : Keys *
        state : int -> bool

Parameters

keys
Type: System.Windows.FormsKeys
Key to find.
state
Type: SystemInt32
State of the Edit control before the key is pressed.

Return Value

Type: Boolean
True if the specified key exists; otherwise false.
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


IKeyList.Remove Method

IKeyListRemove Method
Overload List
 | Name | Description
Public method | Remove(Keys) | When implemented by a class, removes given key from the key collection.
Public method | Remove(Keys, Int32) | When implemented by a class, removes given key from the key collection.
Top
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


IKeyList.Remove Method (Keys)

IKeyListRemove Method (Keys)
When implemented by a class, removes given key from the key collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Remove(
    Keys keys
)
Sub Remove (
    keys As Keys
)
void Remove(
    Keys keys
)
abstract Remove :
        keys : Keys -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key to remove.
See Also

Reference

IKeyList Interface
Remove Overload
Alternet.Editor Namespace


IKeyList.Remove Method (Keys, Int32)

IKeyListRemove Method (Keys, Int32)
When implemented by a class, removes given key from the key collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Remove(
    Keys keys,
    int state
)
Sub Remove (
    keys As Keys,
    state As Integer
)
void Remove(
    Keys keys,
    int state
)
abstract Remove :
        keys : Keys *
        state : int -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key to remove.
state
Type: SystemInt32
State of the Edit control when the key is pressed.
See Also

Reference

IKeyList Interface
Remove Overload
Alternet.Editor Namespace


IKeyList Properties

IKeyList Properties

The IKeyList type exposes the following members.

Properties
 | Name | Description
Public property | EventData | When implemented by a class, represents array of event handlers associated with keys.
Public property | Handlers | When implemented by a class, represents an event handlers collection which contains elements that can be used as a particular action attached to key or key combination from the IKeyList.
Top
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


IKeyList.EventData Property

IKeyListEventData Property
When implemented by a class, represents array of event handlers associated with keys.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IKeyData[] EventData { get; }
ReadOnly Property EventData As IKeyData()
    Get
property array<IKeyData^>^ EventData {
    array<IKeyData^>^ get ();
}
abstract EventData : IKeyData[] with get

Property Value

Type: IKeyData
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


IKeyList.Handlers Property

IKeyListHandlers Property
When implemented by a class, represents an event handlers collection which contains elements that can be used as a particular action attached to key or key combination from the IKeyList.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEventHandlers Handlers { get; }
ReadOnly Property Handlers As IEventHandlers
    Get
property IEventHandlers^ Handlers {
    IEventHandlers^ get ();
}
abstract Handlers : IEventHandlers with get

Property Value

Type: IEventHandlers
See Also

Reference

IKeyList Interface
Alternet.Editor Namespace


ILineSeparator Interface

ILineSeparator Interface
Represents properties and methods used to separate lines and highlight current line within the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILineSeparator : IUpdate
Public Interface ILineSeparator
    Inherits IUpdate
public interface class ILineSeparator : IUpdate
type ILineSeparator =
    interface
        interface IUpdate
    end

The ILineSeparator type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another ILineSeparator object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | NeedHide | When implemented by a class, indicates whether Edit control owning the ILineSeparator needs to hide highlighting of the current line when loosing input focus.
Public method | NeedHighlight | When implemented by a class, indicates whether Edit control owning the ILineSeparator need to highlight the current line.
Public method | NeedHighlightDisplayLine | Gets boolean value indicating that given line should be highlighted. Specifies line index in display coordinates.
Public method | NeedHighlightLine | When implemented by a class, gets boolean value indicating that given line should be highlighted. Specifies line index.
Public method | ResetContentDividerColor | When implemented by a class, resets the ContentDividerColor to the default value.
Public method | ResetHighlightBackColor | When implemented by a class, resets the HighlightBackColor to the default value.
Public method | ResetHighlightForeColor | When implemented by a class, resets the HighlightForeColor to the default value.
Public method | ResetLineColor | When implemented by a class, resets the LineColor to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | TempHighlightLine | When implemented by a class, temporary highlights specifies line until Edit control state changed.
Public method | TempUnhighlightLine | Removes highlighting from temporary highlighted line.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | ContentDividerColor | When implemented by a class, gets or sets color of horizontal lines between text sections in the Edit control.
Public property | HighlightBackColor | When implemented by a class, gets or sets a background color of highlighted line.
Public property | HighlightForeColor | When implemented by a class, gets or sets a foreground color of highlighted line.
Public property | LineColor | When implemented by a class, gets or sets color of horizontal lines between particular lines in the Edit control.
Public property | Options | When implemented by a class, gets or sets a set of flags customizing appearance and behaviour of the ILineSeparator.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

Alternet.Editor Namespace


ILineSeparator Methods

ILineSeparator Methods

The ILineSeparator type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another ILineSeparator object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | NeedHide | When implemented by a class, indicates whether Edit control owning the ILineSeparator needs to hide highlighting of the current line when loosing input focus.
Public method | NeedHighlight | When implemented by a class, indicates whether Edit control owning the ILineSeparator need to highlight the current line.
Public method | NeedHighlightDisplayLine | Gets boolean value indicating that given line should be highlighted. Specifies line index in display coordinates.
Public method | NeedHighlightLine | When implemented by a class, gets boolean value indicating that given line should be highlighted. Specifies line index.
Public method | ResetContentDividerColor | When implemented by a class, resets the ContentDividerColor to the default value.
Public method | ResetHighlightBackColor | When implemented by a class, resets the HighlightBackColor to the default value.
Public method | ResetHighlightForeColor | When implemented by a class, resets the HighlightForeColor to the default value.
Public method | ResetLineColor | When implemented by a class, resets the LineColor to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | TempHighlightLine | When implemented by a class, temporary highlights specifies line until Edit control state changed.
Public method | TempUnhighlightLine | Removes highlighting from temporary highlighted line.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.Assign Method

ILineSeparatorAssign Method
When implemented by a class, copies the contents from another ILineSeparator object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ILineSeparator source
)
Sub Assign (
    source As ILineSeparator
)
void Assign(
    ILineSeparator^ source
)
abstract Assign :
        source : ILineSeparator -> unit

Parameters

source
Type: Alternet.EditorILineSeparator
Specifies ILineSeparator to assign.
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.NeedHide Method

ILineSeparatorNeedHide Method
When implemented by a class, indicates whether Edit control owning the ILineSeparator needs to hide highlighting of the current line when loosing input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedHide()
Function NeedHide As Boolean
bool NeedHide()
abstract NeedHide : unit -> bool

Return Value

Type: Boolean
True if need; otherwise false.
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.NeedHighlight Method

ILineSeparatorNeedHighlight Method
When implemented by a class, indicates whether Edit control owning the ILineSeparator need to highlight the current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedHighlight()
Function NeedHighlight As Boolean
bool NeedHighlight()
abstract NeedHighlight : unit -> bool

Return Value

Type: Boolean
True if need; otherwise false.
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.NeedHighlightDisplayLine Method

ILineSeparatorNeedHighlightDisplayLine Method
Gets boolean value indicating that given line should be highlighted. Specifies line index in display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedHighlightDisplayLine(
    int index
)
Function NeedHighlightDisplayLine (
    index As Integer
) As Boolean
bool NeedHighlightDisplayLine(
    int index
)
abstract NeedHighlightDisplayLine :
        index : int -> bool

Parameters

index
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.NeedHighlightLine Method

ILineSeparatorNeedHighlightLine Method
When implemented by a class, gets boolean value indicating that given line should be highlighted. Specifies line index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedHighlightLine(
    int index
)
Function NeedHighlightLine (
    index As Integer
) As Boolean
bool NeedHighlightLine(
    int index
)
abstract NeedHighlightLine :
        index : int -> bool

Parameters

index
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.ResetContentDividerColor Method

ILineSeparatorResetContentDividerColor Method
When implemented by a class, resets the ContentDividerColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetContentDividerColor()
Sub ResetContentDividerColor
void ResetContentDividerColor()
abstract ResetContentDividerColor : unit -> unit
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.ResetHighlightBackColor Method

ILineSeparatorResetHighlightBackColor Method
When implemented by a class, resets the HighlightBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetHighlightBackColor()
Sub ResetHighlightBackColor
void ResetHighlightBackColor()
abstract ResetHighlightBackColor : unit -> unit
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.ResetHighlightForeColor Method

ILineSeparatorResetHighlightForeColor Method
When implemented by a class, resets the HighlightForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetHighlightForeColor()
Sub ResetHighlightForeColor
void ResetHighlightForeColor()
abstract ResetHighlightForeColor : unit -> unit
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.ResetLineColor Method

ILineSeparatorResetLineColor Method
When implemented by a class, resets the LineColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineColor()
Sub ResetLineColor
void ResetLineColor()
abstract ResetLineColor : unit -> unit
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.ResetOptions Method

ILineSeparatorResetOptions Method
When implemented by a class, resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOptions()
Sub ResetOptions
void ResetOptions()
abstract ResetOptions : unit -> unit
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.TempHighlightLine Method

ILineSeparatorTempHighlightLine Method
When implemented by a class, temporary highlights specifies line until Edit control state changed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TempHighlightLine(
    int index
)
Sub TempHighlightLine (
    index As Integer
)
void TempHighlightLine(
    int index
)
abstract TempHighlightLine :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of line to highlight.
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.TempUnhighlightLine Method

ILineSeparatorTempUnhighlightLine Method
Removes highlighting from temporary highlighted line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TempUnhighlightLine()
Sub TempUnhighlightLine
void TempUnhighlightLine()
abstract TempUnhighlightLine : unit -> unit
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator Properties

ILineSeparator Properties

The ILineSeparator type exposes the following members.

Properties
 | Name | Description
Public property | ContentDividerColor | When implemented by a class, gets or sets color of horizontal lines between text sections in the Edit control.
Public property | HighlightBackColor | When implemented by a class, gets or sets a background color of highlighted line.
Public property | HighlightForeColor | When implemented by a class, gets or sets a foreground color of highlighted line.
Public property | LineColor | When implemented by a class, gets or sets color of horizontal lines between particular lines in the Edit control.
Public property | Options | When implemented by a class, gets or sets a set of flags customizing appearance and behaviour of the ILineSeparator.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.ContentDividerColor Property

ILineSeparatorContentDividerColor Property
When implemented by a class, gets or sets color of horizontal lines between text sections in the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ContentDividerColor { get; set; }
Property ContentDividerColor As Color
    Get
    Set
property Color ContentDividerColor {
    Color get ();
    void set (Color value);
}
abstract ContentDividerColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.HighlightBackColor Property

ILineSeparatorHighlightBackColor Property
When implemented by a class, gets or sets a background color of highlighted line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color HighlightBackColor { get; set; }
Property HighlightBackColor As Color
    Get
    Set
property Color HighlightBackColor {
    Color get ();
    void set (Color value);
}
abstract HighlightBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.HighlightForeColor Property

ILineSeparatorHighlightForeColor Property
When implemented by a class, gets or sets a foreground color of highlighted line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color HighlightForeColor { get; set; }
Property HighlightForeColor As Color
    Get
    Set
property Color HighlightForeColor {
    Color get ();
    void set (Color value);
}
abstract HighlightForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.LineColor Property

ILineSeparatorLineColor Property
When implemented by a class, gets or sets color of horizontal lines between particular lines in the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color LineColor { get; set; }
Property LineColor As Color
    Get
    Set
property Color LineColor {
    Color get ();
    void set (Color value);
}
abstract LineColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


ILineSeparator.Options Property

ILineSeparatorOptions Property
When implemented by a class, gets or sets a set of flags customizing appearance and behaviour of the ILineSeparator.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SeparatorOptions Options { get; set; }
Property Options As SeparatorOptions
    Get
    Set
property SeparatorOptions Options {
    SeparatorOptions get ();
    void set (SeparatorOptions value);
}
abstract Options : SeparatorOptions with get, set

Property Value

Type: SeparatorOptions
See Also

Reference

ILineSeparator Interface
Alternet.Editor Namespace


IMacroKeyData Interface

IMacroKeyData Interface
Represents macro key or its combinations with attached actions.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMacroKeyData : IKeyData
Public Interface IMacroKeyData
    Inherits IKeyData
public interface class IMacroKeyData : IKeyData
type IMacroKeyData =
    interface
        interface IKeyData
    end

The IMacroKeyData type exposes the following members.

Properties
 | Name | Description
Public property | Action | When implemented by a class, represents an action that executes when the key is pressed. (Inherited from IKeyData.)
Public property | ActionEx | When implemented by a class, represents extended action that executes when the key is pressed. (Inherited from IKeyData.)
Public property | EventName | When implemented by a class, represents a name of the action. (Inherited from IKeyData.)
Public property | FullName | When implemented by a class, gives a string representation of the action.
Public property | Keys | When implemented by a class, represents a key to which some action is attached. (Inherited from IKeyData.)
Public property | LeaveState | When implemented by a class, represents a state of the Edit control after key is pressed. (Inherited from IKeyData.)
Public property | Param | When implemented by a class, represents an object passed as a parameter to the extended action. (Inherited from IKeyData.)
Public property | ParamStr | When implemented by a class, represents parameter text.
Public property | ParamType | When implemented by a class, gets or sets type of the parameter.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this MacroKeyData object.
Public property | State | When implemented by a class, represents a state of the Edit control before key is pressed. (Inherited from IKeyData.)
Top
See Also

Reference

Alternet.Editor Namespace


IMacroKeyData Properties

IMacroKeyData Properties

The IMacroKeyData type exposes the following members.

Properties
 | Name | Description
Public property | Action | When implemented by a class, represents an action that executes when the key is pressed. (Inherited from IKeyData.)
Public property | ActionEx | When implemented by a class, represents extended action that executes when the key is pressed. (Inherited from IKeyData.)
Public property | EventName | When implemented by a class, represents a name of the action. (Inherited from IKeyData.)
Public property | FullName | When implemented by a class, gives a string representation of the action.
Public property | Keys | When implemented by a class, represents a key to which some action is attached. (Inherited from IKeyData.)
Public property | LeaveState | When implemented by a class, represents a state of the Edit control after key is pressed. (Inherited from IKeyData.)
Public property | Param | When implemented by a class, represents an object passed as a parameter to the extended action. (Inherited from IKeyData.)
Public property | ParamStr | When implemented by a class, represents parameter text.
Public property | ParamType | When implemented by a class, gets or sets type of the parameter.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this MacroKeyData object.
Public property | State | When implemented by a class, represents a state of the Edit control before key is pressed. (Inherited from IKeyData.)
Top
See Also

Reference

IMacroKeyData Interface
Alternet.Editor Namespace


IMacroKeyData.FullName Property

IMacroKeyDataFullName Property
When implemented by a class, gives a string representation of the action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FullName { get; set; }
Property FullName As String
    Get
    Set
property String^ FullName {
    String^ get ();
    void set (String^ value);
}
abstract FullName : string with get, set

Property Value

Type: String
See Also

Reference

IMacroKeyData Interface
Alternet.Editor Namespace


IMacroKeyData.ParamStr Property

IMacroKeyDataParamStr Property
When implemented by a class, represents parameter text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ParamStr { get; set; }
Property ParamStr As String
    Get
    Set
property String^ ParamStr {
    String^ get ();
    void set (String^ value);
}
abstract ParamStr : string with get, set

Property Value

Type: String
See Also

Reference

IMacroKeyData Interface
Alternet.Editor Namespace


IMacroKeyData.ParamType Property

IMacroKeyDataParamType Property
When implemented by a class, gets or sets type of the parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
KeyEventType ParamType { get; set; }
Property ParamType As KeyEventType
    Get
    Set
property KeyEventType ParamType {
    KeyEventType get ();
    void set (KeyEventType value);
}
abstract ParamType : KeyEventType with get, set

Property Value

Type: KeyEventType
See Also

Reference

IMacroKeyData Interface
Alternet.Editor Namespace


IMacroKeyData.SerializationInfo Property

IMacroKeyDataSerializationInfo Property
When implemented by a class, gets or sets an xml representation of this MacroKeyData object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISerializationInfo SerializationInfo { get; set; }
Property SerializationInfo As ISerializationInfo
    Get
    Set
property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

IMacroKeyData Interface
Alternet.Editor Namespace


IMacroKeyList Interface

IMacroKeyList Interface
Represents list of macro key or its combinations with attached actions.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMacroKeyList : IList<IMacroKeyData>,
    ICollection<IMacroKeyData>, IEnumerable<IMacroKeyData>, IEnumerable
Public Interface IMacroKeyList
    Inherits IList(Of IMacroKeyData), ICollection(Of IMacroKeyData),
    IEnumerable(Of IMacroKeyData), IEnumerable
public interface class IMacroKeyList : IList<IMacroKeyData^>,
    ICollection<IMacroKeyData^>, IEnumerable<IMacroKeyData^>, IEnumerable
type IMacroKeyList =
    interface
        interface IList<IMacroKeyData>
        interface ICollection<IMacroKeyData>
        interface IEnumerable<IMacroKeyData>
        interface IEnumerable
    end

The IMacroKeyList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIMacroKeyData .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIMacroKeyData .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIMacroKeyData .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIMacroKeyData .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIMacroKeyData .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIMacroKeyData .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIMacroKeyData .)
Public method | LinkMacros | When implemented by a class, links macro actions to the editor events.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIMacroKeyData .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIMacroKeyData .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIMacroKeyData | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIMacroKeyData | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIMacroKeyData, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIMacroKeyData .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIMacroKeyData .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIMacroKeyData .)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this MacroKeyList object.
Top
See Also

Reference

Alternet.Editor Namespace


IMacroKeyList Methods

IMacroKeyList Methods

The IMacroKeyList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIMacroKeyData .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIMacroKeyData .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIMacroKeyData .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIMacroKeyData .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIMacroKeyData .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIMacroKeyData .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIMacroKeyData .)
Public method | LinkMacros | When implemented by a class, links macro actions to the editor events.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIMacroKeyData .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIMacroKeyData .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIMacroKeyData | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIMacroKeyData | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIMacroKeyData, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IMacroKeyList Interface
Alternet.Editor Namespace


IMacroKeyList.LinkMacros Method

IMacroKeyListLinkMacros Method
When implemented by a class, links macro actions to the editor events.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LinkMacros(
    Object owner,
    IEventHandlers keyHandlers
)
Sub LinkMacros (
    owner As Object,
    keyHandlers As IEventHandlers
)
void LinkMacros(
    Object^ owner,
    IEventHandlers^ keyHandlers
)
abstract LinkMacros :
        owner : Object *
        keyHandlers : IEventHandlers -> unit

Parameters

owner
Type: SystemObject
Editor control contains macros.
keyHandlers
Type: Alternet.EditorIEventHandlers
Collection of events.
See Also

Reference

IMacroKeyList Interface
Alternet.Editor Namespace


IMacroKeyList Properties

IMacroKeyList Properties

The IMacroKeyList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIMacroKeyData .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIMacroKeyData .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIMacroKeyData .)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this MacroKeyList object.
Top
See Also

Reference

IMacroKeyList Interface
Alternet.Editor Namespace


IMacroKeyList.SerializationInfo Property

IMacroKeyListSerializationInfo Property
When implemented by a class, gets or sets an xml representation of this MacroKeyList object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISerializationInfo SerializationInfo { get; set; }
Property SerializationInfo As ISerializationInfo
    Get
    Set
property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

IMacroKeyList Interface
Alternet.Editor Namespace


IMargin Interface

IMargin Interface
Represents properties and methods specifying appearance of the margin in Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMargin : IUpdate,
    IDisposable
Public Interface IMargin
    Inherits IUpdate, IDisposable
public interface class IMargin : IUpdate,
    IDisposable
type IMargin =
    interface
        interface IUpdate
        interface IDisposable
    end

The IMargin type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IMargin object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | CancelDragging | When implemented by a class, cancels dragging the margin.
Public method | Contains | When implemented by a class, indicates whether IMargin area contains given position.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | DragTo | When implemented by a class, moves IMargin to specified position.
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Paint | When implemented by a class, draws IMargin object on the specified graphic surface.
Public method | PaintColumn | Draws margin column on the specified graphic surface.
Public method | ResetAllowDrag | When implemented by a class, resets the AllowDrag to the default value.
Public method | ResetColumnPositions | When implemented by a class, resets the ColumnPositions to the default value.
Public method | ResetColumnsPenColor | When implemented by a class, resets the ColumnPenColor to the default value.
Public method | ResetColumnsVisible | When implemented by a class, resets the ColumnsVisible to the default value.
Public method | ResetPenColor | When implemented by a class, resets the PenColor to the default value.
Public method | ResetPosition | When implemented by a class, resets the Position to the default value.
Public method | ResetShowHints | When implemented by a class, resets the ShowHints to the default value.
Public method | ResetVisible | When implemented by a class, resets the Visible to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | AllowDrag | When implemented by a class, indicates whether drag operation can performed to IMargin.
Public property | ColumnPen | When implemented by a class, gets or sets Pen object that describes the color and pattern of column margin lines.
Public property | ColumnPenColor | When implemented by a class, gets or sets a color of the column margin line.
Public property | ColumnPositions | When implemented by a class, gets or sets the character columns where additional column margin will be drawn.
Public property | ColumnsVisible | When implemented by a class, gets or sets a value indicating whether column margins should be painted.
Public property | IsDragging | When implemented by a class, indicates whether IMargin is in dragging state.
Public property | Pen | When implemented by a class, gets or sets Pen object that describes the color and pattern of IMargin line.
Public property | PenColor | When implemented by a class, gets or sets a color of the margin line.
Public property | Position | When implemented by a class, gets or sets value indicating position, in characters, of the vertical line within the text portion of the control.
Public property | ShowHints | When implemented by a class, gets or sets a value indicating whether IMargin should display some hint when mouse pointer is over the margin area.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether vertical line should be painted.
Top
See Also

Reference

Alternet.Editor Namespace


IMargin Methods

IMargin Methods

The IMargin type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IMargin object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | CancelDragging | When implemented by a class, cancels dragging the margin.
Public method | Contains | When implemented by a class, indicates whether IMargin area contains given position.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | DragTo | When implemented by a class, moves IMargin to specified position.
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Paint | When implemented by a class, draws IMargin object on the specified graphic surface.
Public method | PaintColumn | Draws margin column on the specified graphic surface.
Public method | ResetAllowDrag | When implemented by a class, resets the AllowDrag to the default value.
Public method | ResetColumnPositions | When implemented by a class, resets the ColumnPositions to the default value.
Public method | ResetColumnsPenColor | When implemented by a class, resets the ColumnPenColor to the default value.
Public method | ResetColumnsVisible | When implemented by a class, resets the ColumnsVisible to the default value.
Public method | ResetPenColor | When implemented by a class, resets the PenColor to the default value.
Public method | ResetPosition | When implemented by a class, resets the Position to the default value.
Public method | ResetShowHints | When implemented by a class, resets the ShowHints to the default value.
Public method | ResetVisible | When implemented by a class, resets the Visible to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.Assign Method

IMarginAssign Method
When implemented by a class, copies the contents from another IMargin object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IMargin source
)
Sub Assign (
    source As IMargin
)
void Assign(
    IMargin^ source
)
abstract Assign :
        source : IMargin -> unit

Parameters

source
Type: Alternet.EditorIMargin
Specifies IMargin to assign.
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.CancelDragging Method

IMarginCancelDragging Method
When implemented by a class, cancels dragging the margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CancelDragging()
Sub CancelDragging
void CancelDragging()
abstract CancelDragging : unit -> unit
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.Contains Method

IMarginContains Method
When implemented by a class, indicates whether IMargin area contains given position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Contains(
    int x,
    int y
)
Function Contains (
    x As Integer,
    y As Integer
) As Boolean
bool Contains(
    int x,
    int y
)
abstract Contains :
        x : int *
        y : int -> bool

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies the point to check-up.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies the point to check-up.

Return Value

Type: Boolean
True if contains; otherwise false.
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.DragTo Method

IMarginDragTo Method
When implemented by a class, moves IMargin to specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DragTo(
    int x,
    int y
)
Sub DragTo (
    x As Integer,
    y As Integer
)
void DragTo(
    int x,
    int y
)
abstract DragTo :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies position to drag.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies position to drag.
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.Paint Method

IMarginPaint Method
When implemented by a class, draws IMargin object on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Paint(
    IPainter painter,
    Rectangle rect
)
Sub Paint (
    painter As IPainter,
    rect As Rectangle
)
void Paint(
    IPainter^ painter,
    Rectangle rect
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of IMargin to draw.
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.PaintColumn Method

IMarginPaintColumn Method
Draws margin column on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintColumn(
    IPainter painter,
    Rectangle rect
)
Sub PaintColumn (
    painter As IPainter,
    rect As Rectangle
)
void PaintColumn(
    IPainter^ painter,
    Rectangle rect
)
abstract PaintColumn :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of Margin to draw.
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ResetAllowDrag Method

IMarginResetAllowDrag Method
When implemented by a class, resets the AllowDrag to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAllowDrag()
Sub ResetAllowDrag
void ResetAllowDrag()
abstract ResetAllowDrag : unit -> unit
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ResetColumnPositions Method

IMarginResetColumnPositions Method
When implemented by a class, resets the ColumnPositions to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetColumnPositions()
Sub ResetColumnPositions
void ResetColumnPositions()
abstract ResetColumnPositions : unit -> unit
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ResetColumnsPenColor Method

IMarginResetColumnsPenColor Method
When implemented by a class, resets the ColumnPenColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetColumnsPenColor()
Sub ResetColumnsPenColor
void ResetColumnsPenColor()
abstract ResetColumnsPenColor : unit -> unit
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ResetColumnsVisible Method

IMarginResetColumnsVisible Method
When implemented by a class, resets the ColumnsVisible to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetColumnsVisible()
Sub ResetColumnsVisible
void ResetColumnsVisible()
abstract ResetColumnsVisible : unit -> unit
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ResetPenColor Method

IMarginResetPenColor Method
When implemented by a class, resets the PenColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetPenColor()
Sub ResetPenColor
void ResetPenColor()
abstract ResetPenColor : unit -> unit
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ResetPosition Method

IMarginResetPosition Method
When implemented by a class, resets the Position to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetPosition()
Sub ResetPosition
void ResetPosition()
abstract ResetPosition : unit -> unit
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ResetShowHints Method

IMarginResetShowHints Method
When implemented by a class, resets the ShowHints to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetShowHints()
Sub ResetShowHints
void ResetShowHints()
abstract ResetShowHints : unit -> unit
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ResetVisible Method

IMarginResetVisible Method
When implemented by a class, resets the Visible to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetVisible()
Sub ResetVisible
void ResetVisible()
abstract ResetVisible : unit -> unit
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin Properties

IMargin Properties

The IMargin type exposes the following members.

Properties
 | Name | Description
Public property | AllowDrag | When implemented by a class, indicates whether drag operation can performed to IMargin.
Public property | ColumnPen | When implemented by a class, gets or sets Pen object that describes the color and pattern of column margin lines.
Public property | ColumnPenColor | When implemented by a class, gets or sets a color of the column margin line.
Public property | ColumnPositions | When implemented by a class, gets or sets the character columns where additional column margin will be drawn.
Public property | ColumnsVisible | When implemented by a class, gets or sets a value indicating whether column margins should be painted.
Public property | IsDragging | When implemented by a class, indicates whether IMargin is in dragging state.
Public property | Pen | When implemented by a class, gets or sets Pen object that describes the color and pattern of IMargin line.
Public property | PenColor | When implemented by a class, gets or sets a color of the margin line.
Public property | Position | When implemented by a class, gets or sets value indicating position, in characters, of the vertical line within the text portion of the control.
Public property | ShowHints | When implemented by a class, gets or sets a value indicating whether IMargin should display some hint when mouse pointer is over the margin area.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether vertical line should be painted.
Top
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.AllowDrag Property

IMarginAllowDrag Property
When implemented by a class, indicates whether drag operation can performed to IMargin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AllowDrag { get; set; }
Property AllowDrag As Boolean
    Get
    Set
property bool AllowDrag {
    bool get ();
    void set (bool value);
}
abstract AllowDrag : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ColumnPen Property

IMarginColumnPen Property
When implemented by a class, gets or sets Pen object that describes the color and pattern of column margin lines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Pen ColumnPen { get; set; }
Property ColumnPen As Pen
    Get
    Set
property Pen^ ColumnPen {
    Pen^ get ();
    void set (Pen^ value);
}
abstract ColumnPen : Pen with get, set

Property Value

Type: Pen
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ColumnPenColor Property

IMarginColumnPenColor Property
When implemented by a class, gets or sets a color of the column margin line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ColumnPenColor { get; set; }
Property ColumnPenColor As Color
    Get
    Set
property Color ColumnPenColor {
    Color get ();
    void set (Color value);
}
abstract ColumnPenColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ColumnPositions Property

IMarginColumnPositions Property
When implemented by a class, gets or sets the character columns where additional column margin will be drawn.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int[] ColumnPositions { get; set; }
Property ColumnPositions As Integer()
    Get
    Set
property array<int>^ ColumnPositions {
    array<int>^ get ();
    void set (array<int>^ value);
}
abstract ColumnPositions : int[] with get, set

Property Value

Type: Int32
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ColumnsVisible Property

IMarginColumnsVisible Property
When implemented by a class, gets or sets a value indicating whether column margins should be painted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ColumnsVisible { get; set; }
Property ColumnsVisible As Boolean
    Get
    Set
property bool ColumnsVisible {
    bool get ();
    void set (bool value);
}
abstract ColumnsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.IsDragging Property

IMarginIsDragging Property
When implemented by a class, indicates whether IMargin is in dragging state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsDragging { get; set; }
Property IsDragging As Boolean
    Get
    Set
property bool IsDragging {
    bool get ();
    void set (bool value);
}
abstract IsDragging : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.Pen Property

IMarginPen Property
When implemented by a class, gets or sets Pen object that describes the color and pattern of IMargin line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Pen Pen { get; set; }
Property Pen As Pen
    Get
    Set
property Pen^ Pen {
    Pen^ get ();
    void set (Pen^ value);
}
abstract Pen : Pen with get, set

Property Value

Type: Pen
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.PenColor Property

IMarginPenColor Property
When implemented by a class, gets or sets a color of the margin line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color PenColor { get; set; }
Property PenColor As Color
    Get
    Set
property Color PenColor {
    Color get ();
    void set (Color value);
}
abstract PenColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.Position Property

IMarginPosition Property
When implemented by a class, gets or sets value indicating position, in characters, of the vertical line within the text portion of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Position { get; set; }
Property Position As Integer
    Get
    Set
property int Position {
    int get ();
    void set (int value);
}
abstract Position : int with get, set

Property Value

Type: Int32
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.ShowHints Property

IMarginShowHints Property
When implemented by a class, gets or sets a value indicating whether IMargin should display some hint when mouse pointer is over the margin area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowHints { get; set; }
Property ShowHints As Boolean
    Get
    Set
property bool ShowHints {
    bool get ();
    void set (bool value);
}
abstract ShowHints : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IMargin.Visible Property

IMarginVisible Property
When implemented by a class, gets or sets a value indicating whether vertical line should be painted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IMargin Interface
Alternet.Editor Namespace


IndentOrientation Enumeration

IndentOrientation Enumeration
Specifies alignment of an indentation part of ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum IndentOrientation
Public Enumeration IndentOrientation
public enum class IndentOrientation
type IndentOrientation
Members
Member name | Value | Description
Near | 0 | Specifies that indentation is positioned at the begin of the ruler.
Far | 1 | Specifies that indentation is positioned at the end of the ruler.
See Also

Reference

Alternet.Editor Namespace


InitSearchEvent Delegate

InitSearchEvent Delegate
Represents a method that will handle the SearchManager.InitSearch event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void InitSearchEvent(
    Object sender,
    InitSearchEventArgs e
)
Public Delegate Sub InitSearchEvent (
    sender As Object,
    e As InitSearchEventArgs
)
public delegate void InitSearchEvent(
    Object^ sender,
    InitSearchEventArgs^ e
)
type InitSearchEvent =
    delegate of
        sender : Object *
        e : InitSearchEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorInitSearchEventArgs
A InitSearchEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


InitSearchEventArgs Class

InitSearchEventArgs Class
Provides data for the InitSearchEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorInitSearchEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InitSearchEventArgs : EventArgs
Public Class InitSearchEventArgs
    Inherits EventArgs
public ref class InitSearchEventArgs : public EventArgs
type InitSearchEventArgs =
    class
        inherit EventArgs
    end

The InitSearchEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | InitSearchEventArgs | Initializes a new instance of the InitSearchEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Options | Defines search behavior.
Public property | Search | Search engine where search should be processed.
Public property | SearchList | List of search engines.
Top
See Also

Reference

Alternet.Editor Namespace


InitSearchEventArgs Constructor

InitSearchEventArgs Constructor
Initializes a new instance of the InitSearchEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public InitSearchEventArgs(
    ISearch search,
    IList<string> searchList,
    SearchOptions options
)
Public Sub New (
    search As ISearch,
    searchList As IList(Of String),
    options As SearchOptions
)
public:
InitSearchEventArgs(
    ISearch^ search,
    IList<String^>^ searchList,
    SearchOptions options
)
new :
        search : ISearch *
        searchList : IList<string> *
        options : SearchOptions -> InitSearchEventArgs

Parameters

search
Type: Alternet.EditorISearch
ISearch engine where search should be processed.
searchList
Type: System.Collections.GenericIListString
Receives list of search engines.
options
Type: Alternet.Editor.TextSourceSearchOptions
SearchOptions defines search behavior.
See Also

Reference

InitSearchEventArgs Class
Alternet.Editor Namespace


InitSearchEventArgs Methods

InitSearchEventArgs Methods

The InitSearchEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InitSearchEventArgs Class
Alternet.Editor Namespace


InitSearchEventArgs Properties

InitSearchEventArgs Properties

The InitSearchEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Options | Defines search behavior.
Public property | Search | Search engine where search should be processed.
Public property | SearchList | List of search engines.
Top
See Also

Reference

InitSearchEventArgs Class
Alternet.Editor Namespace


InitSearchEventArgs.Options Property

InitSearchEventArgsOptions Property
Defines search behavior.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchOptions Options { get; set; }
Public Property Options As SearchOptions
    Get
    Set
public:
property SearchOptions Options {
    SearchOptions get ();
    void set (SearchOptions value);
}
member Options : SearchOptions with get, set

Property Value

Type: SearchOptions
See Also

Reference

InitSearchEventArgs Class
Alternet.Editor Namespace


InitSearchEventArgs.Search Property

InitSearchEventArgsSearch Property
Search engine where search should be processed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISearch Search { get; set; }
Public Property Search As ISearch
    Get
    Set
public:
property ISearch^ Search {
    ISearch^ get ();
    void set (ISearch^ value);
}
member Search : ISearch with get, set

Property Value

Type: ISearch
See Also

Reference

InitSearchEventArgs Class
Alternet.Editor Namespace


InitSearchEventArgs.SearchList Property

InitSearchEventArgsSearchList Property
List of search engines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> SearchList { get; set; }
Public Property SearchList As IList(Of String)
    Get
    Set
public:
property IList<String^>^ SearchList {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
member SearchList : IList<string> with get, set

Property Value

Type: IListString
See Also

Reference

InitSearchEventArgs Class
Alternet.Editor Namespace


IOutlining Interface

IOutlining Interface
Represents additional properties and methods that affects appearance and behaviour of outline sections within Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IOutlining : ICollapsable
Public Interface IOutlining
    Inherits ICollapsable
public interface class IOutlining : ICollapsable
type IOutlining =
    interface
        interface ICollapsable
    end

The IOutlining type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IOutlining object.
Public method | CanCollapse | When implemented in a class, returns boolean value indicating that outline section at given line can be collapsed. (Inherited from ICollapsable.)
Public method | CanExpand(Int32) | When implemented in a class, returns boolean value indicating that outline section at given line can be expanded. (Inherited from ICollapsable.)
Public method | CanExpand(IOutlineRange) | When implemented in a class, returns boolean value indicating that given outline section can be expanded. (Inherited from ICollapsable.)
Public method | Collapse | When implemented by a class, collapses the specified line. (Inherited from ICollapsable.)
Public method | CollapseToDefinitions | When implemented by a class, collapses and expands some outline section to get a quick overall view of the content. (Inherited from ICollapsable.)
Public method | EnsureExpanded(Point) | When implemented by a class, makes all outline sections containing specified position expanded. (Inherited from ICollapsable.)
Public method | EnsureExpanded(Int32) | When implemented by a class, makes all outline sections containing specified line expanded. (Inherited from ICollapsable.)
Public method | Expand | When implemented by a class, expands outline section at the given line. (Inherited from ICollapsable.)
Public method | FullCollapse | When implemented by a class, collapses all outlining sections. (Inherited from ICollapsable.)
Public method | FullCollapse(IListIRange) | When implemented by a class, collapses all sections objects specified by Ranges parameter. (Inherited from ICollapsable.)
Public method | FullExpand | When implemented by a class, expands all outlining sections. (Inherited from ICollapsable.)
Public method | FullExpand(IListIRange) | When implemented by a class, expands all outline sections specified by Ranges parameter. (Inherited from ICollapsable.)
Public method | GetOutlineHint | When implemented by a class, returns string that appears in the hint window when mouse pointer is over the outline button. (Inherited from ICollapsable.)
Public method | GetOutlineRange(Point) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position. (Inherited from ICollapsable.)
Public method | GetOutlineRange(Int32) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange) | When implemented by a class, fills list specified by ranges parameter with all existing outline sections. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific position. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Int32) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific line. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Point, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific range. (Inherited from ICollapsable.)
Public method | IsCollapsed | When implemented by a class, indicates whether the outlined text at the specified line is collapsed. (Inherited from ICollapsable.)
Public method | IsExpanded | When implemented by a class, indicates whether the outlined text at the specified line is expanded. (Inherited from ICollapsable.)
Public method | IsVisible(Point) | When implemented by a class, indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position. (Inherited from ICollapsable.)
Public method | IsVisible(Int32) | When implemented by a class, indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line. (Inherited from ICollapsable.)
Public method | Outline(Point, Point) | When implemented by a class, creates an outlining section based on specific scope within current outlined section. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope within current outlined section. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | OutlineText | When implemented by a class, tries to perform lexical analysis of entire text to create outline sections based on results of this analysis.
Public method | ResetAllowOutlining | When implemented by a class, resets AllowOutlining to the default value. (Inherited from ICollapsable.)
Public method | ResetOutlineColor | When implemented by a class, resets the OutlineColor to the default value.
Public method | ResetOutlineOptions | When implemented by a class, resets OutlineOptions to the default value. (Inherited from ICollapsable.)
Public method | SetOutlineRanges(IListIRange) | When implemented by a class, updates IOutlineRange collection from given list of ranges. (Inherited from ICollapsable.)
Public method | SetOutlineRanges(IListIRange, Boolean) | When implemented by a class, updates IOutlineRange collection from given list of ranges. (Inherited from ICollapsable.)
Public method | ToggleOutlining | When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection. (Inherited from ICollapsable.)
Public method | ToggleOutlining(IListIRange, IOutlineRange) | When implemented by a class, toggles expanded state for given IOutlineRange collection. (Inherited from ICollapsable.)
Public method | UnOutline | When implemented by a class, removes all outlined sections from outline collection. (Inherited from ICollapsable.)
Public method | UnOutline(Point) | When implemented by a class, removes outlined section at the specific position. (Inherited from ICollapsable.)
Public method | UnOutline(Int32) | When implemented by a class, removes all outline sections containing the given line. (Inherited from ICollapsable.)
Public method | UnOutlineText | When implemented by a class, removes all outline section from outline collection.
Top
Properties
 | Name | Description
Public property | AllowOutlining | When implemented by a class, gets or sets a value indicating whether outlining enabled. Added to provide a workaround for C++ CodeDOM parser.
Public property | CollapsedCount | When implemented by a class, returns number of collapsed sections. (Inherited from ICollapsable.)
Public property | ImageSize | When implemented by a class, gets or sets size of outlining image. When auto scaling enabled, measured in DIP.
Public property | ImageSizeInPixels | When implemented by a class, gets size of outlining image in pixels.
Public property | OutlineColor | When implemented by a class, gets or sets color that is used to draw outline button.
Public property | OutlineOptions | When implemented by a class, gets or sets outlining options. Added to provide a workaround for C++ CodeDOM parser.
Public property | UseRoundRect | When implemented by a class, gets or sets a boolean value indicating whether outlining buttons should be drawn with rounded corners.
Top
Events
 | Name | Description
Public event | Collapsing | When implemented by a class, occurs when user attempts collapse outline section. (Inherited from ICollapsable.)
Public event | Expanding | When implemented by a class, occurs when user attempts expand outline section. (Inherited from ICollapsable.)
Top
See Also

Reference

Alternet.Editor Namespace


IOutlining Methods

IOutlining Methods

The IOutlining type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IOutlining object.
Public method | CanCollapse | When implemented in a class, returns boolean value indicating that outline section at given line can be collapsed. (Inherited from ICollapsable.)
Public method | CanExpand(Int32) | When implemented in a class, returns boolean value indicating that outline section at given line can be expanded. (Inherited from ICollapsable.)
Public method | CanExpand(IOutlineRange) | When implemented in a class, returns boolean value indicating that given outline section can be expanded. (Inherited from ICollapsable.)
Public method | Collapse | When implemented by a class, collapses the specified line. (Inherited from ICollapsable.)
Public method | CollapseToDefinitions | When implemented by a class, collapses and expands some outline section to get a quick overall view of the content. (Inherited from ICollapsable.)
Public method | EnsureExpanded(Point) | When implemented by a class, makes all outline sections containing specified position expanded. (Inherited from ICollapsable.)
Public method | EnsureExpanded(Int32) | When implemented by a class, makes all outline sections containing specified line expanded. (Inherited from ICollapsable.)
Public method | Expand | When implemented by a class, expands outline section at the given line. (Inherited from ICollapsable.)
Public method | FullCollapse | When implemented by a class, collapses all outlining sections. (Inherited from ICollapsable.)
Public method | FullCollapse(IListIRange) | When implemented by a class, collapses all sections objects specified by Ranges parameter. (Inherited from ICollapsable.)
Public method | FullExpand | When implemented by a class, expands all outlining sections. (Inherited from ICollapsable.)
Public method | FullExpand(IListIRange) | When implemented by a class, expands all outline sections specified by Ranges parameter. (Inherited from ICollapsable.)
Public method | GetOutlineHint | When implemented by a class, returns string that appears in the hint window when mouse pointer is over the outline button. (Inherited from ICollapsable.)
Public method | GetOutlineRange(Point) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position. (Inherited from ICollapsable.)
Public method | GetOutlineRange(Int32) | When implemented by a class, returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange) | When implemented by a class, fills list specified by ranges parameter with all existing outline sections. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific position. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Int32) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific line. (Inherited from ICollapsable.)
Public method | GetOutlineRanges(IListIRange, Point, Point) | When implemented by a class, fills list specified by ranges parameter with all outline sections containing specific range. (Inherited from ICollapsable.)
Public method | IsCollapsed | When implemented by a class, indicates whether the outlined text at the specified line is collapsed. (Inherited from ICollapsable.)
Public method | IsExpanded | When implemented by a class, indicates whether the outlined text at the specified line is expanded. (Inherited from ICollapsable.)
Public method | IsVisible(Point) | When implemented by a class, indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position. (Inherited from ICollapsable.)
Public method | IsVisible(Int32) | When implemented by a class, indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line. (Inherited from ICollapsable.)
Public method | Outline(Point, Point) | When implemented by a class, creates an outlining section based on specific scope within current outlined section. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope within current outlined section. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, Int32) | When implemented by a class, creates an outlining section based on specific scope at the specific level of outline nesting. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Point, Point, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | Outline(Int32, Int32, Int32, String) | When implemented by a class, creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text. (Inherited from ICollapsable.)
Public method | OutlineText | When implemented by a class, tries to perform lexical analysis of entire text to create outline sections based on results of this analysis.
Public method | ResetAllowOutlining | When implemented by a class, resets AllowOutlining to the default value. (Inherited from ICollapsable.)
Public method | ResetOutlineColor | When implemented by a class, resets the OutlineColor to the default value.
Public method | ResetOutlineOptions | When implemented by a class, resets OutlineOptions to the default value. (Inherited from ICollapsable.)
Public method | SetOutlineRanges(IListIRange) | When implemented by a class, updates IOutlineRange collection from given list of ranges. (Inherited from ICollapsable.)
Public method | SetOutlineRanges(IListIRange, Boolean) | When implemented by a class, updates IOutlineRange collection from given list of ranges. (Inherited from ICollapsable.)
Public method | ToggleOutlining | When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection. (Inherited from ICollapsable.)
Public method | ToggleOutlining(IListIRange, IOutlineRange) | When implemented by a class, toggles expanded state for given IOutlineRange collection. (Inherited from ICollapsable.)
Public method | UnOutline | When implemented by a class, removes all outlined sections from outline collection. (Inherited from ICollapsable.)
Public method | UnOutline(Point) | When implemented by a class, removes outlined section at the specific position. (Inherited from ICollapsable.)
Public method | UnOutline(Int32) | When implemented by a class, removes all outline sections containing the given line. (Inherited from ICollapsable.)
Public method | UnOutlineText | When implemented by a class, removes all outline section from outline collection.
Top
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.Assign Method

IOutliningAssign Method
When implemented by a class, copies the contents from another IOutlining object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IOutlining source
)
Sub Assign (
    source As IOutlining
)
void Assign(
    IOutlining^ source
)
abstract Assign :
        source : IOutlining -> unit

Parameters

source
Type: Alternet.EditorIOutlining
Specifies IOutlining to assign.
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.OutlineText Method

IOutliningOutlineText Method
When implemented by a class, tries to perform lexical analysis of entire text to create outline sections based on results of this analysis.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OutlineText()
Sub OutlineText
void OutlineText()
abstract OutlineText : unit -> unit
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.ResetOutlineColor Method

IOutliningResetOutlineColor Method
When implemented by a class, resets the OutlineColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOutlineColor()
Sub ResetOutlineColor
void ResetOutlineColor()
abstract ResetOutlineColor : unit -> unit
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.UnOutlineText Method

IOutliningUnOutlineText Method
When implemented by a class, removes all outline section from outline collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnOutlineText()
Sub UnOutlineText
void UnOutlineText()
abstract UnOutlineText : unit -> unit
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining Properties

IOutlining Properties

The IOutlining type exposes the following members.

Properties
 | Name | Description
Public property | AllowOutlining | When implemented by a class, gets or sets a value indicating whether outlining enabled. Added to provide a workaround for C++ CodeDOM parser.
Public property | CollapsedCount | When implemented by a class, returns number of collapsed sections. (Inherited from ICollapsable.)
Public property | ImageSize | When implemented by a class, gets or sets size of outlining image. When auto scaling enabled, measured in DIP.
Public property | ImageSizeInPixels | When implemented by a class, gets size of outlining image in pixels.
Public property | OutlineColor | When implemented by a class, gets or sets color that is used to draw outline button.
Public property | OutlineOptions | When implemented by a class, gets or sets outlining options. Added to provide a workaround for C++ CodeDOM parser.
Public property | UseRoundRect | When implemented by a class, gets or sets a boolean value indicating whether outlining buttons should be drawn with rounded corners.
Top
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.AllowOutlining Property

IOutliningAllowOutlining Property
When implemented by a class, gets or sets a value indicating whether outlining enabled. Added to provide a workaround for C++ CodeDOM parser.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AllowOutlining { get; set; }
Property AllowOutlining As Boolean
    Get
    Set
property bool AllowOutlining {
    bool get ();
    void set (bool value);
}
abstract AllowOutlining : bool with get, set

Property Value

Type: Boolean

Implements

ICollapsableAllowOutlining
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.ImageSize Property

IOutliningImageSize Property
When implemented by a class, gets or sets size of outlining image. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ImageSize { get; set; }
Property ImageSize As Integer
    Get
    Set
property int ImageSize {
    int get ();
    void set (int value);
}
abstract ImageSize : int with get, set

Property Value

Type: Int32
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.ImageSizeInPixels Property

IOutliningImageSizeInPixels Property
When implemented by a class, gets size of outlining image in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ImageSizeInPixels { get; }
ReadOnly Property ImageSizeInPixels As Integer
    Get
property int ImageSizeInPixels {
    int get ();
}
abstract ImageSizeInPixels : int with get

Property Value

Type: Int32
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.OutlineColor Property

IOutliningOutlineColor Property
When implemented by a class, gets or sets color that is used to draw outline button.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color OutlineColor { get; set; }
Property OutlineColor As Color
    Get
    Set
property Color OutlineColor {
    Color get ();
    void set (Color value);
}
abstract OutlineColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.OutlineOptions Property

IOutliningOutlineOptions Property
When implemented by a class, gets or sets outlining options. Added to provide a workaround for C++ CodeDOM parser.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
OutlineOptions OutlineOptions { get; set; }
Property OutlineOptions As OutlineOptions
    Get
    Set
property OutlineOptions OutlineOptions {
    OutlineOptions get ();
    void set (OutlineOptions value);
}
abstract OutlineOptions : OutlineOptions with get, set

Property Value

Type: OutlineOptions

Implements

ICollapsableOutlineOptions
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining.UseRoundRect Property

IOutliningUseRoundRect Property
When implemented by a class, gets or sets a boolean value indicating whether outlining buttons should be drawn with rounded corners.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseRoundRect { get; set; }
Property UseRoundRect As Boolean
    Get
    Set
property bool UseRoundRect {
    bool get ();
    void set (bool value);
}
abstract UseRoundRect : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IOutlining Events

IOutlining Events

The IOutlining type exposes the following members.

Events
 | Name | Description
Public event | Collapsing | When implemented by a class, occurs when user attempts collapse outline section. (Inherited from ICollapsable.)
Public event | Expanding | When implemented by a class, occurs when user attempts expand outline section. (Inherited from ICollapsable.)
Top
See Also

Reference

IOutlining Interface
Alternet.Editor Namespace


IPrinting Interface

IPrinting Interface
Represents properties and methods for printing and print previewing of Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPrinting : IDisposable
Public Interface IPrinting
    Inherits IDisposable
public interface class IPrinting : IDisposable
type IPrinting =
    interface
        interface IDisposable
    end

The IPrinting type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IPrinting object.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExecutePageSetupDialog | When implemented by a class, initializes and runs page setup dialog.
Public method | ExecutePageSetupDialog(IWin32Window) | When implemented by a class, initializes and runs page setup dialog.
Public method | ExecutePrintDialog | When implemented by a class, initializes and runs print dialog.
Public method | ExecutePrintDialog(IWin32Window) | When implemented by a class, initializes and runs print dialog.
Public method | ExecutePrintOptionsDialog | When implemented by a class, initializes and runs print options dialog.
Public method | ExecutePrintOptionsDialog(IWin32Window) | When implemented by a class, initializes and runs print options dialog.
Public method | ExecutePrintPreviewDialog | When implemented by a class, initializes and runs print preview dialog.
Public method | ExecutePrintPreviewDialog(IWin32Window) | When implemented by a class, initializes and runs print preview dialog.
Public method | OnCreatePrintEdit | When implemented by a class, raises the CreatePrintEdit event.
Public method | OnFinalized | When implemented by a class, raises the Finalized event.
Public method | OnInitialized | When implemented by a class, raises the Initialized event.
Public method | Print | When implemented by a class, sends IPrinting.PrintDocument content to the printer.
Public method | ResetAllowedOptions | When implemented by a class, resets IPrinting.AllowedOptions to the default value.
Public method | ResetOptions | When implemented by a class, resets IPrinting.Options to the default value.
Top
Properties
 | Name | Description
Public property | AllowedOptions | When implemented by a class, gets or sets Print Options dialog options, that can be changed by user.
Public property | Footer | When implemented by a class, represents IEditPageHeader object to draw footer of printing document.
Public property | Header | When implemented by a class, represents IEditPageHeader object to draw header of printing document.
Public property | Options | When implemented by a class, gets or sets PrintOptions that determines printing behaviour.
Public property | PageSetupDialog | When implemented by a class, represents a dialog box that allows users to manipulate page settings, including margins and paper orientation.
Public property | PrintDialog | When implemented by a class, represents a dialog box that allows users to select a printer and choose which portions of the document to print.
Public property | PrintDocument | When implemented by a class, represents document to print, print preview or setup.
Public property | PrintEdit | When implemented by a class, provides an access to internal ISyntaxEdit object being printed.
Public property | PrinterSettings | When implemented by a class, represents settings for print document.
Public property | PrintOptionsDialog | When implemented by a class, provides a dialog box that allows users to manipulate print settings.
Public property | PrintPreviewDialog | When implemented by a class, represents a dialog box that allows user to preview print document.
Public property | ShowPrintOptionsDialog | When implemented by a class, gets or sets a value indicating whether Print Options Dialog can be opened.
Top
Events
 | Name | Description
Public event | CreatePrintEdit | When implemented by a class, occurs when Edit control to print is about to be created.
Public event | Finalized | When implemented by a class, occurs when printing is done.
Public event | Initialized | When implemented by a class, occurs when document to print is initialized.
Top
See Also

Reference

Alternet.Editor Namespace


IPrinting Methods

IPrinting Methods

The IPrinting type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IPrinting object.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExecutePageSetupDialog | When implemented by a class, initializes and runs page setup dialog.
Public method | ExecutePageSetupDialog(IWin32Window) | When implemented by a class, initializes and runs page setup dialog.
Public method | ExecutePrintDialog | When implemented by a class, initializes and runs print dialog.
Public method | ExecutePrintDialog(IWin32Window) | When implemented by a class, initializes and runs print dialog.
Public method | ExecutePrintOptionsDialog | When implemented by a class, initializes and runs print options dialog.
Public method | ExecutePrintOptionsDialog(IWin32Window) | When implemented by a class, initializes and runs print options dialog.
Public method | ExecutePrintPreviewDialog | When implemented by a class, initializes and runs print preview dialog.
Public method | ExecutePrintPreviewDialog(IWin32Window) | When implemented by a class, initializes and runs print preview dialog.
Public method | OnCreatePrintEdit | When implemented by a class, raises the CreatePrintEdit event.
Public method | OnFinalized | When implemented by a class, raises the Finalized event.
Public method | OnInitialized | When implemented by a class, raises the Initialized event.
Public method | Print | When implemented by a class, sends IPrinting.PrintDocument content to the printer.
Public method | ResetAllowedOptions | When implemented by a class, resets IPrinting.AllowedOptions to the default value.
Public method | ResetOptions | When implemented by a class, resets IPrinting.Options to the default value.
Top
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.Assign Method

IPrintingAssign Method
When implemented by a class, copies the contents of another IPrinting object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IPrinting source
)
Sub Assign (
    source As IPrinting
)
void Assign(
    IPrinting^ source
)
abstract Assign :
        source : IPrinting -> unit

Parameters

source
Type: Alternet.EditorIPrinting
Specifies IPrinting to assign.
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.ExecutePageSetupDialog Method

IPrintingExecutePageSetupDialog Method
Overload List
 | Name | Description
Public method | ExecutePageSetupDialog | When implemented by a class, initializes and runs page setup dialog.
Public method | ExecutePageSetupDialog(IWin32Window) | When implemented by a class, initializes and runs page setup dialog.
Top
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.ExecutePageSetupDialog Method

IPrintingExecutePageSetupDialog Method
When implemented by a class, initializes and runs page setup dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ExecutePageSetupDialog()
Function ExecutePageSetupDialog As DialogResult
DialogResult ExecutePageSetupDialog()
abstract ExecutePageSetupDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrinting Interface
ExecutePageSetupDialog Overload
Alternet.Editor Namespace


IPrinting.ExecutePageSetupDialog Method (IWin32Window)

IPrintingExecutePageSetupDialog Method (IWin32Window)
When implemented by a class, initializes and runs page setup dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ExecutePageSetupDialog(
    IWin32Window ownerwnd
)
Function ExecutePageSetupDialog (
    ownerwnd As IWin32Window
) As DialogResult
DialogResult ExecutePageSetupDialog(
    IWin32Window^ ownerwnd
)
abstract ExecutePageSetupDialog :
        ownerwnd : IWin32Window -> DialogResult

Parameters

ownerwnd
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrinting Interface
ExecutePageSetupDialog Overload
Alternet.Editor Namespace


IPrinting.ExecutePrintDialog Method

IPrintingExecutePrintDialog Method
Overload List
 | Name | Description
Public method | ExecutePrintDialog | When implemented by a class, initializes and runs print dialog.
Public method | ExecutePrintDialog(IWin32Window) | When implemented by a class, initializes and runs print dialog.
Top
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.ExecutePrintDialog Method

IPrintingExecutePrintDialog Method
When implemented by a class, initializes and runs print dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ExecutePrintDialog()
Function ExecutePrintDialog As DialogResult
DialogResult ExecutePrintDialog()
abstract ExecutePrintDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrinting Interface
ExecutePrintDialog Overload
Alternet.Editor Namespace


IPrinting.ExecutePrintDialog Method (IWin32Window)

IPrintingExecutePrintDialog Method (IWin32Window)
When implemented by a class, initializes and runs print dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ExecutePrintDialog(
    IWin32Window ownerwnd
)
Function ExecutePrintDialog (
    ownerwnd As IWin32Window
) As DialogResult
DialogResult ExecutePrintDialog(
    IWin32Window^ ownerwnd
)
abstract ExecutePrintDialog :
        ownerwnd : IWin32Window -> DialogResult

Parameters

ownerwnd
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrinting Interface
ExecutePrintDialog Overload
Alternet.Editor Namespace


IPrinting.ExecutePrintOptionsDialog Method

IPrintingExecutePrintOptionsDialog Method
Overload List
 | Name | Description
Public method | ExecutePrintOptionsDialog | When implemented by a class, initializes and runs print options dialog.
Public method | ExecutePrintOptionsDialog(IWin32Window) | When implemented by a class, initializes and runs print options dialog.
Top
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.ExecutePrintOptionsDialog Method

IPrintingExecutePrintOptionsDialog Method
When implemented by a class, initializes and runs print options dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ExecutePrintOptionsDialog()
Function ExecutePrintOptionsDialog As DialogResult
DialogResult ExecutePrintOptionsDialog()
abstract ExecutePrintOptionsDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrinting Interface
ExecutePrintOptionsDialog Overload
Alternet.Editor Namespace


IPrinting.ExecutePrintOptionsDialog Method (IWin32Window)

IPrintingExecutePrintOptionsDialog Method (IWin32Window)
When implemented by a class, initializes and runs print options dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ExecutePrintOptionsDialog(
    IWin32Window ownerwnd
)
Function ExecutePrintOptionsDialog (
    ownerwnd As IWin32Window
) As DialogResult
DialogResult ExecutePrintOptionsDialog(
    IWin32Window^ ownerwnd
)
abstract ExecutePrintOptionsDialog :
        ownerwnd : IWin32Window -> DialogResult

Parameters

ownerwnd
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrinting Interface
ExecutePrintOptionsDialog Overload
Alternet.Editor Namespace


IPrinting.ExecutePrintPreviewDialog Method

IPrintingExecutePrintPreviewDialog Method
Overload List
 | Name | Description
Public method | ExecutePrintPreviewDialog | When implemented by a class, initializes and runs print preview dialog.
Public method | ExecutePrintPreviewDialog(IWin32Window) | When implemented by a class, initializes and runs print preview dialog.
Top
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.ExecutePrintPreviewDialog Method

IPrintingExecutePrintPreviewDialog Method
When implemented by a class, initializes and runs print preview dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ExecutePrintPreviewDialog()
Function ExecutePrintPreviewDialog As DialogResult
DialogResult ExecutePrintPreviewDialog()
abstract ExecutePrintPreviewDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrinting Interface
ExecutePrintPreviewDialog Overload
Alternet.Editor Namespace


IPrinting.ExecutePrintPreviewDialog Method (IWin32Window)

IPrintingExecutePrintPreviewDialog Method (IWin32Window)
When implemented by a class, initializes and runs print preview dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ExecutePrintPreviewDialog(
    IWin32Window ownerwnd
)
Function ExecutePrintPreviewDialog (
    ownerwnd As IWin32Window
) As DialogResult
DialogResult ExecutePrintPreviewDialog(
    IWin32Window^ ownerwnd
)
abstract ExecutePrintPreviewDialog :
        ownerwnd : IWin32Window -> DialogResult

Parameters

ownerwnd
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrinting Interface
ExecutePrintPreviewDialog Overload
Alternet.Editor Namespace


IPrinting.OnCreatePrintEdit Method

IPrintingOnCreatePrintEdit Method
When implemented by a class, raises the CreatePrintEdit event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxEdit OnCreatePrintEdit()
Function OnCreatePrintEdit As ISyntaxEdit
ISyntaxEdit^ OnCreatePrintEdit()
abstract OnCreatePrintEdit : unit -> ISyntaxEdit

Return Value

Type: ISyntaxEdit
SyntaxEdit that is created to print.
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.OnFinalized Method

IPrintingOnFinalized Method
When implemented by a class, raises the Finalized event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnFinalized()
Sub OnFinalized
void OnFinalized()
abstract OnFinalized : unit -> unit
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.OnInitialized Method

IPrintingOnInitialized Method
When implemented by a class, raises the Initialized event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnInitialized()
Sub OnInitialized
void OnInitialized()
abstract OnInitialized : unit -> unit
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.Print Method

IPrintingPrint Method
When implemented by a class, sends IPrinting.PrintDocument content to the printer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Print()
Sub Print
void Print()
abstract Print : unit -> unit
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.ResetAllowedOptions Method

IPrintingResetAllowedOptions Method
When implemented by a class, resets IPrinting.AllowedOptions to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAllowedOptions()
Sub ResetAllowedOptions
void ResetAllowedOptions()
abstract ResetAllowedOptions : unit -> unit
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.ResetOptions Method

IPrintingResetOptions Method
When implemented by a class, resets IPrinting.Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOptions()
Sub ResetOptions
void ResetOptions()
abstract ResetOptions : unit -> unit
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting Properties

IPrinting Properties

The IPrinting type exposes the following members.

Properties
 | Name | Description
Public property | AllowedOptions | When implemented by a class, gets or sets Print Options dialog options, that can be changed by user.
Public property | Footer | When implemented by a class, represents IEditPageHeader object to draw footer of printing document.
Public property | Header | When implemented by a class, represents IEditPageHeader object to draw header of printing document.
Public property | Options | When implemented by a class, gets or sets PrintOptions that determines printing behaviour.
Public property | PageSetupDialog | When implemented by a class, represents a dialog box that allows users to manipulate page settings, including margins and paper orientation.
Public property | PrintDialog | When implemented by a class, represents a dialog box that allows users to select a printer and choose which portions of the document to print.
Public property | PrintDocument | When implemented by a class, represents document to print, print preview or setup.
Public property | PrintEdit | When implemented by a class, provides an access to internal ISyntaxEdit object being printed.
Public property | PrinterSettings | When implemented by a class, represents settings for print document.
Public property | PrintOptionsDialog | When implemented by a class, provides a dialog box that allows users to manipulate print settings.
Public property | PrintPreviewDialog | When implemented by a class, represents a dialog box that allows user to preview print document.
Public property | ShowPrintOptionsDialog | When implemented by a class, gets or sets a value indicating whether Print Options Dialog can be opened.
Top
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.AllowedOptions Property

IPrintingAllowedOptions Property
When implemented by a class, gets or sets Print Options dialog options, that can be changed by user.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PrintOptions AllowedOptions { get; set; }
Property AllowedOptions As PrintOptions
    Get
    Set
property PrintOptions AllowedOptions {
    PrintOptions get ();
    void set (PrintOptions value);
}
abstract AllowedOptions : PrintOptions with get, set

Property Value

Type: PrintOptions
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.Footer Property

IPrintingFooter Property
When implemented by a class, represents IEditPageHeader object to draw footer of printing document.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPageHeader Footer { get; set; }
Property Footer As IEditPageHeader
    Get
    Set
property IEditPageHeader^ Footer {
    IEditPageHeader^ get ();
    void set (IEditPageHeader^ value);
}
abstract Footer : IEditPageHeader with get, set

Property Value

Type: IEditPageHeader
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.Header Property

IPrintingHeader Property
When implemented by a class, represents IEditPageHeader object to draw header of printing document.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPageHeader Header { get; set; }
Property Header As IEditPageHeader
    Get
    Set
property IEditPageHeader^ Header {
    IEditPageHeader^ get ();
    void set (IEditPageHeader^ value);
}
abstract Header : IEditPageHeader with get, set

Property Value

Type: IEditPageHeader
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.Options Property

IPrintingOptions Property
When implemented by a class, gets or sets PrintOptions that determines printing behaviour.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PrintOptions Options { get; set; }
Property Options As PrintOptions
    Get
    Set
property PrintOptions Options {
    PrintOptions get ();
    void set (PrintOptions value);
}
abstract Options : PrintOptions with get, set

Property Value

Type: PrintOptions
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.PageSetupDialog Property

IPrintingPageSetupDialog Property
When implemented by a class, represents a dialog box that allows users to manipulate page settings, including margins and paper orientation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PageSetupDialog PageSetupDialog { get; }
ReadOnly Property PageSetupDialog As PageSetupDialog
    Get
property PageSetupDialog^ PageSetupDialog {
    PageSetupDialog^ get ();
}
abstract PageSetupDialog : PageSetupDialog with get

Property Value

Type: PageSetupDialog
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.PrintDialog Property

IPrintingPrintDialog Property
When implemented by a class, represents a dialog box that allows users to select a printer and choose which portions of the document to print.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PrintDialog PrintDialog { get; }
ReadOnly Property PrintDialog As PrintDialog
    Get
property PrintDialog^ PrintDialog {
    PrintDialog^ get ();
}
abstract PrintDialog : PrintDialog with get

Property Value

Type: PrintDialog
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.PrintDocument Property

IPrintingPrintDocument Property
When implemented by a class, represents document to print, print preview or setup.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PrintDocument PrintDocument { get; }
ReadOnly Property PrintDocument As PrintDocument
    Get
property PrintDocument^ PrintDocument {
    PrintDocument^ get ();
}
abstract PrintDocument : PrintDocument with get

Property Value

Type: PrintDocument
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.PrintEdit Property

IPrintingPrintEdit Property
When implemented by a class, provides an access to internal ISyntaxEdit object being printed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxEdit PrintEdit { get; }
ReadOnly Property PrintEdit As ISyntaxEdit
    Get
property ISyntaxEdit^ PrintEdit {
    ISyntaxEdit^ get ();
}
abstract PrintEdit : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.PrinterSettings Property

IPrintingPrinterSettings Property
When implemented by a class, represents settings for print document.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PrinterSettings PrinterSettings { get; }
ReadOnly Property PrinterSettings As PrinterSettings
    Get
property PrinterSettings^ PrinterSettings {
    PrinterSettings^ get ();
}
abstract PrinterSettings : PrinterSettings with get

Property Value

Type: PrinterSettings
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.PrintOptionsDialog Property

IPrintingPrintOptionsDialog Property
When implemented by a class, provides a dialog box that allows users to manipulate print settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPrintOptionsDialog PrintOptionsDialog { get; set; }
Property PrintOptionsDialog As IPrintOptionsDialog
    Get
    Set
property IPrintOptionsDialog^ PrintOptionsDialog {
    IPrintOptionsDialog^ get ();
    void set (IPrintOptionsDialog^ value);
}
abstract PrintOptionsDialog : IPrintOptionsDialog with get, set

Property Value

Type: IPrintOptionsDialog
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.PrintPreviewDialog Property

IPrintingPrintPreviewDialog Property
When implemented by a class, represents a dialog box that allows user to preview print document.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PrintPreviewDialog PrintPreviewDialog { get; }
ReadOnly Property PrintPreviewDialog As PrintPreviewDialog
    Get
property PrintPreviewDialog^ PrintPreviewDialog {
    PrintPreviewDialog^ get ();
}
abstract PrintPreviewDialog : PrintPreviewDialog with get

Property Value

Type: PrintPreviewDialog
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.ShowPrintOptionsDialog Property

IPrintingShowPrintOptionsDialog Property
When implemented by a class, gets or sets a value indicating whether Print Options Dialog can be opened.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowPrintOptionsDialog { get; set; }
Property ShowPrintOptionsDialog As Boolean
    Get
    Set
property bool ShowPrintOptionsDialog {
    bool get ();
    void set (bool value);
}
abstract ShowPrintOptionsDialog : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting Events

IPrinting Events

The IPrinting type exposes the following members.

Events
 | Name | Description
Public event | CreatePrintEdit | When implemented by a class, occurs when Edit control to print is about to be created.
Public event | Finalized | When implemented by a class, occurs when printing is done.
Public event | Initialized | When implemented by a class, occurs when document to print is initialized.
Top
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.CreatePrintEdit Event

IPrintingCreatePrintEdit Event
When implemented by a class, occurs when Edit control to print is about to be created.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event CreatePrintEditEvent CreatePrintEdit
Event CreatePrintEdit As CreatePrintEditEvent
 event CreatePrintEditEvent^ CreatePrintEdit {
    void add (CreatePrintEditEvent^ value);
    void remove (CreatePrintEditEvent^ value);
}
abstract CreatePrintEdit : IEvent<CreatePrintEditEvent,
    CreatePrintEditEventArgs>

Value

Type: Alternet.EditorCreatePrintEditEvent
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.Finalized Event

IPrintingFinalized Event
When implemented by a class, occurs when printing is done.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler Finalized
Event Finalized As EventHandler
 event EventHandler^ Finalized {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Finalized : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IPrinting.Initialized Event

IPrintingInitialized Event
When implemented by a class, occurs when document to print is initialized.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler Initialized
Event Initialized As EventHandler
 event EventHandler^ Initialized {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Initialized : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IPrinting Interface
Alternet.Editor Namespace


IRecordPlayBack Interface

IRecordPlayBack Interface
Represents properties and methods that allows recording sequences of keyboard commands and play back them later.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRecordPlayBack
Public Interface IRecordPlayBack
public interface class IRecordPlayBack
type IRecordPlayBack =  interface end

The IRecordPlayBack type exposes the following members.

Methods
 | Name | Description
Public method | LoadMacros(Stream) | When implemented by a class, loads the macro records from the given stream.
Public method | LoadMacros(TextReader) | When implemented by a class, loads the macro records from the given stream.
Public method | LoadMacros(String) | When implemented by a class, loads the macro records from the given file.
Public method | PauseMacroRecording | When implemented by a class, suspends recording the command sequence.
Public method | PlayBackMacro | When implemented by a class, repeats the stored command sequence.
Public method | RecordKeyData | When implemented by a class, adds keyData to the MacroRecords array.
Public method | ResumeMacroRecording | When implemented by a class, resumes recording the command sequence.
Public method | SaveMacros(Stream) | When implemented by a class, saves the macro records to the given stream in xml format.
Public method | SaveMacros(TextWriter) | When implemented by a class, saves the macro records to the given stream in xml format.
Public method | SaveMacros(String) | When implemented by a class, saves the macro records to the given file in xml format.
Public method | StartMacroRecording | When implemented by a class, starts recording the command sequence.
Public method | StopMacroRecording | When implemented by a class, stops recording the command sequence.
Public method | ToggleMacroRecording | When implemented by a class, toggles recording the command sequence.
Top
Properties
 | Name | Description
Public property | MacroRecording | When implemented by a class, gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands.
Public property | MacroRecords | When implemented by a class, represents an array containing keyboard commands.
Public property | MacroSuspendend | When implemented by a class, gets or sets a boolean value indicating whether recording is suspended.
Top
See Also

Reference

Alternet.Editor Namespace


IRecordPlayBack Methods

IRecordPlayBack Methods

The IRecordPlayBack type exposes the following members.

Methods
 | Name | Description
Public method | LoadMacros(Stream) | When implemented by a class, loads the macro records from the given stream.
Public method | LoadMacros(TextReader) | When implemented by a class, loads the macro records from the given stream.
Public method | LoadMacros(String) | When implemented by a class, loads the macro records from the given file.
Public method | PauseMacroRecording | When implemented by a class, suspends recording the command sequence.
Public method | PlayBackMacro | When implemented by a class, repeats the stored command sequence.
Public method | RecordKeyData | When implemented by a class, adds keyData to the MacroRecords array.
Public method | ResumeMacroRecording | When implemented by a class, resumes recording the command sequence.
Public method | SaveMacros(Stream) | When implemented by a class, saves the macro records to the given stream in xml format.
Public method | SaveMacros(TextWriter) | When implemented by a class, saves the macro records to the given stream in xml format.
Public method | SaveMacros(String) | When implemented by a class, saves the macro records to the given file in xml format.
Public method | StartMacroRecording | When implemented by a class, starts recording the command sequence.
Public method | StopMacroRecording | When implemented by a class, stops recording the command sequence.
Public method | ToggleMacroRecording | When implemented by a class, toggles recording the command sequence.
Top
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.LoadMacros Method

IRecordPlayBackLoadMacros Method
Overload List
 | Name | Description
Public method | LoadMacros(Stream) | When implemented by a class, loads the macro records from the given stream.
Public method | LoadMacros(TextReader) | When implemented by a class, loads the macro records from the given stream.
Public method | LoadMacros(String) | When implemented by a class, loads the macro records from the given file.
Top
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.LoadMacros Method (Stream)

IRecordPlayBackLoadMacros Method (Stream)
When implemented by a class, loads the macro records from the given stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadMacros(
    Stream stream
)
Sub LoadMacros (
    stream As Stream
)
void LoadMacros(
    Stream^ stream
)
abstract LoadMacros :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
See Also

Reference

IRecordPlayBack Interface
LoadMacros Overload
Alternet.Editor Namespace


IRecordPlayBack.LoadMacros Method (TextReader)

IRecordPlayBackLoadMacros Method (TextReader)
When implemented by a class, loads the macro records from the given stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadMacros(
    TextReader reader
)
Sub LoadMacros (
    reader As TextReader
)
void LoadMacros(
    TextReader^ reader
)
abstract LoadMacros :
        reader : TextReader -> unit

Parameters

reader
Type: System.IOTextReader
The TextReader object to read macros from stream.
See Also

Reference

IRecordPlayBack Interface
LoadMacros Overload
Alternet.Editor Namespace


IRecordPlayBack.LoadMacros Method (String)

IRecordPlayBackLoadMacros Method (String)
When implemented by a class, loads the macro records from the given file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadMacros(
    string fileName
)
Sub LoadMacros (
    fileName As String
)
void LoadMacros(
    String^ fileName
)
abstract LoadMacros :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
Name of file to load macros.
See Also

Reference

IRecordPlayBack Interface
LoadMacros Overload
Alternet.Editor Namespace


IRecordPlayBack.PauseMacroRecording Method

IRecordPlayBackPauseMacroRecording Method
When implemented by a class, suspends recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PauseMacroRecording()
Sub PauseMacroRecording
void PauseMacroRecording()
abstract PauseMacroRecording : unit -> unit
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.PlayBackMacro Method

IRecordPlayBackPlayBackMacro Method
When implemented by a class, repeats the stored command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PlayBackMacro()
Sub PlayBackMacro
void PlayBackMacro()
abstract PlayBackMacro : unit -> unit
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.RecordKeyData Method

IRecordPlayBackRecordKeyData Method
When implemented by a class, adds keyData to the MacroRecords array.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RecordKeyData(
    IMacroKeyData keyData
)
Sub RecordKeyData (
    keyData As IMacroKeyData
)
void RecordKeyData(
    IMacroKeyData^ keyData
)
abstract RecordKeyData :
        keyData : IMacroKeyData -> unit

Parameters

keyData
Type: Alternet.EditorIMacroKeyData
Specifies a keyboard command.
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.ResumeMacroRecording Method

IRecordPlayBackResumeMacroRecording Method
When implemented by a class, resumes recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResumeMacroRecording()
Sub ResumeMacroRecording
void ResumeMacroRecording()
abstract ResumeMacroRecording : unit -> unit
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.SaveMacros Method

IRecordPlayBackSaveMacros Method
Overload List
 | Name | Description
Public method | SaveMacros(Stream) | When implemented by a class, saves the macro records to the given stream in xml format.
Public method | SaveMacros(TextWriter) | When implemented by a class, saves the macro records to the given stream in xml format.
Public method | SaveMacros(String) | When implemented by a class, saves the macro records to the given file in xml format.
Top
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.SaveMacros Method (Stream)

IRecordPlayBackSaveMacros Method (Stream)
When implemented by a class, saves the macro records to the given stream in xml format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SaveMacros(
    Stream stream
)
Sub SaveMacros (
    stream As Stream
)
void SaveMacros(
    Stream^ stream
)
abstract SaveMacros :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
See Also

Reference

IRecordPlayBack Interface
SaveMacros Overload
Alternet.Editor Namespace


IRecordPlayBack.SaveMacros Method (TextWriter)

IRecordPlayBackSaveMacros Method (TextWriter)
When implemented by a class, saves the macro records to the given stream in xml format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SaveMacros(
    TextWriter writer
)
Sub SaveMacros (
    writer As TextWriter
)
void SaveMacros(
    TextWriter^ writer
)
abstract SaveMacros :
        writer : TextWriter -> unit

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write macros to stream.
See Also

Reference

IRecordPlayBack Interface
SaveMacros Overload
Alternet.Editor Namespace


IRecordPlayBack.SaveMacros Method (String)

IRecordPlayBackSaveMacros Method (String)
When implemented by a class, saves the macro records to the given file in xml format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SaveMacros(
    string fileName
)
Sub SaveMacros (
    fileName As String
)
void SaveMacros(
    String^ fileName
)
abstract SaveMacros :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
Name of file to save macros.
See Also

Reference

IRecordPlayBack Interface
SaveMacros Overload
Alternet.Editor Namespace


IRecordPlayBack.StartMacroRecording Method

IRecordPlayBackStartMacroRecording Method
When implemented by a class, starts recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartMacroRecording()
Sub StartMacroRecording
void StartMacroRecording()
abstract StartMacroRecording : unit -> unit
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.StopMacroRecording Method

IRecordPlayBackStopMacroRecording Method
When implemented by a class, stops recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StopMacroRecording()
Sub StopMacroRecording
void StopMacroRecording()
abstract StopMacroRecording : unit -> unit
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.ToggleMacroRecording Method

IRecordPlayBackToggleMacroRecording Method
When implemented by a class, toggles recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleMacroRecording()
Sub ToggleMacroRecording
void ToggleMacroRecording()
abstract ToggleMacroRecording : unit -> unit
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack Properties

IRecordPlayBack Properties

The IRecordPlayBack type exposes the following members.

Properties
 | Name | Description
Public property | MacroRecording | When implemented by a class, gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands.
Public property | MacroRecords | When implemented by a class, represents an array containing keyboard commands.
Public property | MacroSuspendend | When implemented by a class, gets or sets a boolean value indicating whether recording is suspended.
Top
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.MacroRecording Property

IRecordPlayBackMacroRecording Property
When implemented by a class, gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool MacroRecording { get; set; }
Property MacroRecording As Boolean
    Get
    Set
property bool MacroRecording {
    bool get ();
    void set (bool value);
}
abstract MacroRecording : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.MacroRecords Property

IRecordPlayBackMacroRecords Property
When implemented by a class, represents an array containing keyboard commands.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IMacroKeyList MacroRecords { get; }
ReadOnly Property MacroRecords As IMacroKeyList
    Get
property IMacroKeyList^ MacroRecords {
    IMacroKeyList^ get ();
}
abstract MacroRecords : IMacroKeyList with get

Property Value

Type: IMacroKeyList
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRecordPlayBack.MacroSuspendend Property

IRecordPlayBackMacroSuspendend Property
When implemented by a class, gets or sets a boolean value indicating whether recording is suspended.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool MacroSuspendend { get; set; }
Property MacroSuspendend As Boolean
    Get
    Set
property bool MacroSuspendend {
    bool get ();
    void set (bool value);
}
abstract MacroSuspendend : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRecordPlayBack Interface
Alternet.Editor Namespace


IRulerIndent Interface

IRulerIndent Interface
Represents properties and methods defines a ruler indentation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRulerIndent
Public Interface IRulerIndent
public interface class IRulerIndent
type IRulerIndent =  interface end

The IRulerIndent type exposes the following members.

Methods
 | Name | Description
Public method | CancelDragging | When implemented by a class, cancels dragging operation.
Public method | DrawIndent | When implemented by a class, draws indentation part of ruler on the specified graphic surface.
Top
Properties
 | Name | Description
Public property | Dragging | When implemented by a class, indicates whether RulerIndent is in dragging state.
Public property | Indent | When implemented by a class, gets or sets size of this RulerIndent.
Public property | Orientation | When implemented by a class, gets or sets RulerIndent alignment.
Top
See Also

Reference

Alternet.Editor Namespace


IRulerIndent Methods

IRulerIndent Methods

The IRulerIndent type exposes the following members.

Methods
 | Name | Description
Public method | CancelDragging | When implemented by a class, cancels dragging operation.
Public method | DrawIndent | When implemented by a class, draws indentation part of ruler on the specified graphic surface.
Top
See Also

Reference

IRulerIndent Interface
Alternet.Editor Namespace


IRulerIndent.CancelDragging Method

IRulerIndentCancelDragging Method
When implemented by a class, cancels dragging operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CancelDragging()
Sub CancelDragging
void CancelDragging()
abstract CancelDragging : unit -> unit
See Also

Reference

IRulerIndent Interface
Alternet.Editor Namespace


IRulerIndent.DrawIndent Method

IRulerIndentDrawIndent Method
When implemented by a class, draws indentation part of ruler on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawIndent(
    Graphics graph,
    Rectangle rect,
    bool vertical,
    Color indentBackColor,
    Color backColor
)
Sub DrawIndent (
    graph As Graphics,
    rect As Rectangle,
    vertical As Boolean,
    indentBackColor As Color,
    backColor As Color
)
void DrawIndent(
    Graphics^ graph,
    Rectangle rect,
    bool vertical,
    Color indentBackColor,
    Color backColor
)
abstract DrawIndent :
        graph : Graphics *
        rect : Rectangle *
        vertical : bool *
        indentBackColor : Color *
        backColor : Color -> unit

Parameters

graph
Type: System.DrawingGraphics
The Graphics object to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of ruler indentation to draw on.
vertical
Type: SystemBoolean
Indicates whether indentation has vertical or horizontal direction.
indentBackColor
Type: System.DrawingColor
Specifies background color of this RulerIndent.
backColor
Type: System.DrawingColor
Specifies background color of RulerIndent slider.
See Also

Reference

IRulerIndent Interface
Alternet.Editor Namespace


IRulerIndent Properties

IRulerIndent Properties

The IRulerIndent type exposes the following members.

Properties
 | Name | Description
Public property | Dragging | When implemented by a class, indicates whether RulerIndent is in dragging state.
Public property | Indent | When implemented by a class, gets or sets size of this RulerIndent.
Public property | Orientation | When implemented by a class, gets or sets RulerIndent alignment.
Top
See Also

Reference

IRulerIndent Interface
Alternet.Editor Namespace


IRulerIndent.Dragging Property

IRulerIndentDragging Property
When implemented by a class, indicates whether RulerIndent is in dragging state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Dragging { get; set; }
Property Dragging As Boolean
    Get
    Set
property bool Dragging {
    bool get ();
    void set (bool value);
}
abstract Dragging : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRulerIndent Interface
Alternet.Editor Namespace


IRulerIndent.Indent Property

IRulerIndentIndent Property
When implemented by a class, gets or sets size of this RulerIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Indent { get; set; }
Property Indent As Integer
    Get
    Set
property int Indent {
    int get ();
    void set (int value);
}
abstract Indent : int with get, set

Property Value

Type: Int32
See Also

Reference

IRulerIndent Interface
Alternet.Editor Namespace


IRulerIndent.Orientation Property

IRulerIndentOrientation Property
When implemented by a class, gets or sets RulerIndent alignment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IndentOrientation Orientation { get; set; }
Property Orientation As IndentOrientation
    Get
    Set
property IndentOrientation Orientation {
    IndentOrientation get ();
    void set (IndentOrientation value);
}
abstract Orientation : IndentOrientation with get, set

Property Value

Type: IndentOrientation
See Also

Reference

IRulerIndent Interface
Alternet.Editor Namespace


IScrollBarThemeRenderer Interface

IScrollBarThemeRenderer Interface
Represents properties used to paint scrollbar elements in Visual Studio style.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScrollBarThemeRenderer
Public Interface IScrollBarThemeRenderer
public interface class IScrollBarThemeRenderer
type IScrollBarThemeRenderer =  interface end

The IScrollBarThemeRenderer type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | When implemented by a class, gets or sets a color to draw scrollbar elements background.
Public property | ThumbHoveredColor | When implemented by a class, gets or sets a color of the thumb element in the hovered state.
Public property | ThumbNormalColor | When implemented by a class, gets or sets a color of the thumb element in the normal state.
Public property | ThumbPressedColor | When implemented by a class, gets or sets a color of the thumb element in the pressed state.
Top
See Also

Reference

Alternet.Editor Namespace


IScrollBarThemeRenderer Properties

IScrollBarThemeRenderer Properties

The IScrollBarThemeRenderer type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | When implemented by a class, gets or sets a color to draw scrollbar elements background.
Public property | ThumbHoveredColor | When implemented by a class, gets or sets a color of the thumb element in the hovered state.
Public property | ThumbNormalColor | When implemented by a class, gets or sets a color of the thumb element in the normal state.
Public property | ThumbPressedColor | When implemented by a class, gets or sets a color of the thumb element in the pressed state.
Top
See Also

Reference

IScrollBarThemeRenderer Interface
Alternet.Editor Namespace


IScrollBarThemeRenderer.BackgroundColor Property

IScrollBarThemeRendererBackgroundColor Property
When implemented by a class, gets or sets a color to draw scrollbar elements background.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackgroundColor { get; set; }
Property BackgroundColor As Color
    Get
    Set
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
abstract BackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IScrollBarThemeRenderer Interface
Alternet.Editor Namespace


IScrollBarThemeRenderer.ThumbHoveredColor Property

IScrollBarThemeRendererThumbHoveredColor Property
When implemented by a class, gets or sets a color of the thumb element in the hovered state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ThumbHoveredColor { get; set; }
Property ThumbHoveredColor As Color
    Get
    Set
property Color ThumbHoveredColor {
    Color get ();
    void set (Color value);
}
abstract ThumbHoveredColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IScrollBarThemeRenderer Interface
Alternet.Editor Namespace


IScrollBarThemeRenderer.ThumbNormalColor Property

IScrollBarThemeRendererThumbNormalColor Property
When implemented by a class, gets or sets a color of the thumb element in the normal state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ThumbNormalColor { get; set; }
Property ThumbNormalColor As Color
    Get
    Set
property Color ThumbNormalColor {
    Color get ();
    void set (Color value);
}
abstract ThumbNormalColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IScrollBarThemeRenderer Interface
Alternet.Editor Namespace


IScrollBarThemeRenderer.ThumbPressedColor Property

IScrollBarThemeRendererThumbPressedColor Property
When implemented by a class, gets or sets a color of the thumb element in the pressed state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ThumbPressedColor { get; set; }
Property ThumbPressedColor As Color
    Get
    Set
property Color ThumbPressedColor {
    Color get ();
    void set (Color value);
}
abstract ThumbPressedColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IScrollBarThemeRenderer Interface
Alternet.Editor Namespace


IScrolling Interface

IScrolling Interface
Represents properties and methods that describe scrolling behaviour of Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScrolling : IUpdate,
    IDisposable
Public Interface IScrolling
    Inherits IUpdate, IDisposable
public interface class IScrolling : IUpdate,
    IDisposable
type IScrolling =
    interface
        interface IUpdate
        interface IDisposable
    end

The IScrolling type exposes the following members.

Methods
 | Name | Description
Public method | ApplyTheme |
Public method | Assign | When implemented by a class, copies the contents of another IScrolling object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | MouseScroll | When implemented by a class, scrolls editor control vertically.
Public method | OnScrollButtonClick | When implemented by a class, raises ScrollButtonClick event.
Public method | ResetDefaultHorzScrollSize | When implemented by a class, resets the DefaultHorzScrollSize to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ResetScrollBars | When implemented by a class, resets the ScrollBars to the default value.
Public method | SystemScroll | When implemented by a class, performs a system scrolls by calling Windows API.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | UpdateFlat | When implemented by a class, initializes flat scroll bars for editor control.
Public method | UpdateScroll | When implemented by a class, updates scrolling control.
Public method | UpdateScroll(Boolean) | When implemented by a class, updates scrolling control.
Top
Properties
 | Name | Description
Public property | Annotations | When implemented by a class, gets the scroll bars annotations control interface.
Public property | DefaultHorzScrollSize | When implemented by a class, gets or sets a default size of horizontal scrollbar.
Public property | FixedScrollSize | When implemented by a class, indicates whether horz scrollbar has fixed size.
Public property | HasHScrollBar | When implemented by a class, gets boolean value indicating whether control has a horizontal scroll bar control.
Public property | HasVScrollBar | When implemented by a class, gets boolean value indicating whether control has a vertical scroll bar control.
Public property | HorzButtons | When implemented by a class, represents a collection of additional buttons displayed on the horizontal scroll bar.
Public property | HorzScrollbarVisible | When implemented by a class, indicates whether horizontal scrollbar is visible.
Public property | HorzSplitButton |
Public property | HScrollBar | When implemented by a class, gets horizontal scroll bar control.
Public property | Options | When implemented by a class, gets or sets a ScrollingOptions that determine scrolling behaviour.
Public property | Owner | When implemented by a class, represents owner of this IScrolling object.
Public property | ScrollBars | When implemented by a class, gets or sets the type of scroll bars displayed in the control.
Public property | ScrollBarsCornerColor | When implemented by a class, indicates color of the corner between scroll bars for the current visual style.
Public property | ScrollBarsVisualStyle | When implemented by a class, gets or sets the scroll bars visual style displayed in the control.
Public property | ScrollByPixels | When implemented by a class, indicates whether scrollbars should use pixels rather than characters.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | VertButtons | When implemented by a class, represents a collection of additional buttons displayed on the vertical scroll bar.
Public property | VertScrollbarVisible | When implemented by a class, indicates whether vertical scrollbar is visible.
Public property | VertSplitButton |
Public property | VScrollBar | When implemented by a class, gets vertical scroll bar control.
Public property | WindowOriginX | When implemented by a class, gets or sets a index of the first visible character within the control.
Public property | WindowOriginY | When implemented by a class, gets or sets a value that represents first visible line within the control.
Top
Events
 | Name | Description
Public event | HorizontalScroll | When implemented by a class, occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving.
Public event | ScrollButtonClick | When implemented by a class, occurs when some scrolling button is clicked.
Public event | VerticalScroll | When implemented by a class, occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving.
Top
See Also

Reference

Alternet.Editor Namespace


IScrolling Methods

IScrolling Methods

The IScrolling type exposes the following members.

Methods
 | Name | Description
Public method | ApplyTheme |
Public method | Assign | When implemented by a class, copies the contents of another IScrolling object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | MouseScroll | When implemented by a class, scrolls editor control vertically.
Public method | OnScrollButtonClick | When implemented by a class, raises ScrollButtonClick event.
Public method | ResetDefaultHorzScrollSize | When implemented by a class, resets the DefaultHorzScrollSize to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ResetScrollBars | When implemented by a class, resets the ScrollBars to the default value.
Public method | SystemScroll | When implemented by a class, performs a system scrolls by calling Windows API.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | UpdateFlat | When implemented by a class, initializes flat scroll bars for editor control.
Public method | UpdateScroll | When implemented by a class, updates scrolling control.
Public method | UpdateScroll(Boolean) | When implemented by a class, updates scrolling control.
Top
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.ApplyTheme Method

IScrollingApplyTheme Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyTheme(
    IVisualTheme theme
)
Sub ApplyTheme (
    theme As IVisualTheme
)
void ApplyTheme(
    IVisualTheme^ theme
)
abstract ApplyTheme :
        theme : IVisualTheme -> unit

Parameters

theme
Type: Alternet.EditorIVisualTheme
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.Assign Method

IScrollingAssign Method
When implemented by a class, copies the contents of another IScrolling object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IScrolling source
)
Sub Assign (
    source As IScrolling
)
void Assign(
    IScrolling^ source
)
abstract Assign :
        source : IScrolling -> unit

Parameters

source
Type: Alternet.EditorIScrolling
Specifies IScrolling to assign.
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.MouseScroll Method

IScrollingMouseScroll Method
When implemented by a class, scrolls editor control vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MouseScroll(
    int delta
)
Sub MouseScroll (
    delta As Integer
)
void MouseScroll(
    int delta
)
abstract MouseScroll :
        delta : int -> unit

Parameters

delta
Type: SystemInt32
Specifies mouse wheel delta.
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.OnScrollButtonClick Method

IScrollingOnScrollButtonClick Method
When implemented by a class, raises ScrollButtonClick event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnScrollButtonClick(
    Object sender,
    EventArgs e
)
Sub OnScrollButtonClick (
    sender As Object,
    e As EventArgs
)
void OnScrollButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract OnScrollButtonClick :
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.ResetDefaultHorzScrollSize Method

IScrollingResetDefaultHorzScrollSize Method
When implemented by a class, resets the DefaultHorzScrollSize to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDefaultHorzScrollSize()
Sub ResetDefaultHorzScrollSize
void ResetDefaultHorzScrollSize()
abstract ResetDefaultHorzScrollSize : unit -> unit
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.ResetOptions Method

IScrollingResetOptions Method
When implemented by a class, resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOptions()
Sub ResetOptions
void ResetOptions()
abstract ResetOptions : unit -> unit
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.ResetScrollBars Method

IScrollingResetScrollBars Method
When implemented by a class, resets the ScrollBars to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetScrollBars()
Sub ResetScrollBars
void ResetScrollBars()
abstract ResetScrollBars : unit -> unit
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.SystemScroll Method

IScrollingSystemScroll Method
When implemented by a class, performs a system scrolls by calling Windows API.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SystemScroll(
    int code,
    bool vert
)
Sub SystemScroll (
    code As Integer,
    vert As Boolean
)
void SystemScroll(
    int code,
    bool vert
)
abstract SystemScroll :
        code : int *
        vert : bool -> unit

Parameters

code
Type: SystemInt32
Specifies scrolling request.
vert
Type: SystemBoolean
True if vertical scroll bar should be scrolled; otherwise false.
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.UpdateFlat Method

IScrollingUpdateFlat Method
When implemented by a class, initializes flat scroll bars for editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateFlat()
Sub UpdateFlat
void UpdateFlat()
abstract UpdateFlat : unit -> unit
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.UpdateScroll Method

IScrollingUpdateScroll Method
Overload List
 | Name | Description
Public method | UpdateScroll | When implemented by a class, updates scrolling control.
Public method | UpdateScroll(Boolean) | When implemented by a class, updates scrolling control.
Top
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.UpdateScroll Method

IScrollingUpdateScroll Method
When implemented by a class, updates scrolling control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateScroll()
Sub UpdateScroll
void UpdateScroll()
abstract UpdateScroll : unit -> unit
See Also

Reference

IScrolling Interface
UpdateScroll Overload
Alternet.Editor Namespace


IScrolling.UpdateScroll Method (Boolean)

IScrollingUpdateScroll Method (Boolean)
When implemented by a class, updates scrolling control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateScroll(
    bool updateSize
)
Sub UpdateScroll (
    updateSize As Boolean
)
void UpdateScroll(
    bool updateSize
)
abstract UpdateScroll :
        updateSize : bool -> unit

Parameters

updateSize
Type: SystemBoolean
True if scrolling control should be resized; otherwise false.
See Also

Reference

IScrolling Interface
UpdateScroll Overload
Alternet.Editor Namespace


IScrolling Properties

IScrolling Properties

The IScrolling type exposes the following members.

Properties
 | Name | Description
Public property | Annotations | When implemented by a class, gets the scroll bars annotations control interface.
Public property | DefaultHorzScrollSize | When implemented by a class, gets or sets a default size of horizontal scrollbar.
Public property | FixedScrollSize | When implemented by a class, indicates whether horz scrollbar has fixed size.
Public property | HasHScrollBar | When implemented by a class, gets boolean value indicating whether control has a horizontal scroll bar control.
Public property | HasVScrollBar | When implemented by a class, gets boolean value indicating whether control has a vertical scroll bar control.
Public property | HorzButtons | When implemented by a class, represents a collection of additional buttons displayed on the horizontal scroll bar.
Public property | HorzScrollbarVisible | When implemented by a class, indicates whether horizontal scrollbar is visible.
Public property | HorzSplitButton |
Public property | HScrollBar | When implemented by a class, gets horizontal scroll bar control.
Public property | Options | When implemented by a class, gets or sets a ScrollingOptions that determine scrolling behaviour.
Public property | Owner | When implemented by a class, represents owner of this IScrolling object.
Public property | ScrollBars | When implemented by a class, gets or sets the type of scroll bars displayed in the control.
Public property | ScrollBarsCornerColor | When implemented by a class, indicates color of the corner between scroll bars for the current visual style.
Public property | ScrollBarsVisualStyle | When implemented by a class, gets or sets the scroll bars visual style displayed in the control.
Public property | ScrollByPixels | When implemented by a class, indicates whether scrollbars should use pixels rather than characters.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | VertButtons | When implemented by a class, represents a collection of additional buttons displayed on the vertical scroll bar.
Public property | VertScrollbarVisible | When implemented by a class, indicates whether vertical scrollbar is visible.
Public property | VertSplitButton |
Public property | VScrollBar | When implemented by a class, gets vertical scroll bar control.
Public property | WindowOriginX | When implemented by a class, gets or sets a index of the first visible character within the control.
Public property | WindowOriginY | When implemented by a class, gets or sets a value that represents first visible line within the control.
Top
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.Annotations Property

IScrollingAnnotations Property
When implemented by a class, gets the scroll bars annotations control interface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScrollBarAnnotations Annotations { get; }
ReadOnly Property Annotations As IScrollBarAnnotations
    Get
property IScrollBarAnnotations^ Annotations {
    IScrollBarAnnotations^ get ();
}
abstract Annotations : IScrollBarAnnotations with get

Property Value

Type: IScrollBarAnnotations
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.DefaultHorzScrollSize Property

IScrollingDefaultHorzScrollSize Property
When implemented by a class, gets or sets a default size of horizontal scrollbar.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int DefaultHorzScrollSize { get; set; }
Property DefaultHorzScrollSize As Integer
    Get
    Set
property int DefaultHorzScrollSize {
    int get ();
    void set (int value);
}
abstract DefaultHorzScrollSize : int with get, set

Property Value

Type: Int32
Remarks
This property is applicable when control forces showing of the horizontal scroll bar.
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.FixedScrollSize Property

IScrollingFixedScrollSize Property
When implemented by a class, indicates whether horz scrollbar has fixed size.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FixedScrollSize { get; }
ReadOnly Property FixedScrollSize As Boolean
    Get
property bool FixedScrollSize {
    bool get ();
}
abstract FixedScrollSize : bool with get

Property Value

Type: Boolean
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.HasHScrollBar Property

IScrollingHasHScrollBar Property
When implemented by a class, gets boolean value indicating whether control has a horizontal scroll bar control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasHScrollBar { get; }
ReadOnly Property HasHScrollBar As Boolean
    Get
property bool HasHScrollBar {
    bool get ();
}
abstract HasHScrollBar : bool with get

Property Value

Type: Boolean
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.HasVScrollBar Property

IScrollingHasVScrollBar Property
When implemented by a class, gets boolean value indicating whether control has a vertical scroll bar control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasVScrollBar { get; }
ReadOnly Property HasVScrollBar As Boolean
    Get
property bool HasVScrollBar {
    bool get ();
}
abstract HasVScrollBar : bool with get

Property Value

Type: Boolean
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.HorzButtons Property

IScrollingHorzButtons Property
When implemented by a class, represents a collection of additional buttons displayed on the horizontal scroll bar.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScrollingButtons HorzButtons { get; }
ReadOnly Property HorzButtons As IScrollingButtons
    Get
property IScrollingButtons^ HorzButtons {
    IScrollingButtons^ get ();
}
abstract HorzButtons : IScrollingButtons with get

Property Value

Type: IScrollingButtons
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.HorzScrollbarVisible Property

IScrollingHorzScrollbarVisible Property
When implemented by a class, indicates whether horizontal scrollbar is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HorzScrollbarVisible { get; }
ReadOnly Property HorzScrollbarVisible As Boolean
    Get
property bool HorzScrollbarVisible {
    bool get ();
}
abstract HorzScrollbarVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.HorzSplitButton Property

IScrollingHorzSplitButton Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScrollingButton HorzSplitButton { get; }
ReadOnly Property HorzSplitButton As IScrollingButton
    Get
property IScrollingButton^ HorzSplitButton {
    IScrollingButton^ get ();
}
abstract HorzSplitButton : IScrollingButton with get

Property Value

Type: IScrollingButton
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.HScrollBar Property

IScrollingHScrollBar Property
When implemented by a class, gets horizontal scroll bar control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScrollBar HScrollBar { get; }
ReadOnly Property HScrollBar As ScrollBar
    Get
property ScrollBar^ HScrollBar {
    ScrollBar^ get ();
}
abstract HScrollBar : ScrollBar with get

Property Value

Type: ScrollBar
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.Options Property

IScrollingOptions Property
When implemented by a class, gets or sets a ScrollingOptions that determine scrolling behaviour.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScrollingOptions Options { get; set; }
Property Options As ScrollingOptions
    Get
    Set
property ScrollingOptions Options {
    ScrollingOptions get ();
    void set (ScrollingOptions value);
}
abstract Options : ScrollingOptions with get, set

Property Value

Type: ScrollingOptions
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.Owner Property

IScrollingOwner Property
When implemented by a class, represents owner of this IScrolling object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxEdit Owner { get; }
ReadOnly Property Owner As ISyntaxEdit
    Get
property ISyntaxEdit^ Owner {
    ISyntaxEdit^ get ();
}
abstract Owner : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.ScrollBars Property

IScrollingScrollBars Property
When implemented by a class, gets or sets the type of scroll bars displayed in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
RichTextBoxScrollBars ScrollBars { get; set; }
Property ScrollBars As RichTextBoxScrollBars
    Get
    Set
property RichTextBoxScrollBars ScrollBars {
    RichTextBoxScrollBars get ();
    void set (RichTextBoxScrollBars value);
}
abstract ScrollBars : RichTextBoxScrollBars with get, set

Property Value

Type: RichTextBoxScrollBars
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.ScrollBarsCornerColor Property

IScrollingScrollBarsCornerColor Property
When implemented by a class, indicates color of the corner between scroll bars for the current visual style.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ScrollBarsCornerColor { get; }
ReadOnly Property ScrollBarsCornerColor As Color
    Get
property Color ScrollBarsCornerColor {
    Color get ();
}
abstract ScrollBarsCornerColor : Color with get

Property Value

Type: Color
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.ScrollBarsVisualStyle Property

IScrollingScrollBarsVisualStyle Property
When implemented by a class, gets or sets the scroll bars visual style displayed in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScrollBarVisualStyle ScrollBarsVisualStyle { get; set; }
Property ScrollBarsVisualStyle As ScrollBarVisualStyle
    Get
    Set
property ScrollBarVisualStyle ScrollBarsVisualStyle {
    ScrollBarVisualStyle get ();
    void set (ScrollBarVisualStyle value);
}
abstract ScrollBarsVisualStyle : ScrollBarVisualStyle with get, set

Property Value

Type: ScrollBarVisualStyle
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.ScrollByPixels Property

IScrollingScrollByPixels Property
When implemented by a class, indicates whether scrollbars should use pixels rather than characters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ScrollByPixels { get; }
ReadOnly Property ScrollByPixels As Boolean
    Get
property bool ScrollByPixels {
    bool get ();
}
abstract ScrollByPixels : bool with get

Property Value

Type: Boolean
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.VertButtons Property

IScrollingVertButtons Property
When implemented by a class, represents a collection of additional buttons displayed on the vertical scroll bar.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScrollingButtons VertButtons { get; }
ReadOnly Property VertButtons As IScrollingButtons
    Get
property IScrollingButtons^ VertButtons {
    IScrollingButtons^ get ();
}
abstract VertButtons : IScrollingButtons with get

Property Value

Type: IScrollingButtons
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.VertScrollbarVisible Property

IScrollingVertScrollbarVisible Property
When implemented by a class, indicates whether vertical scrollbar is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool VertScrollbarVisible { get; }
ReadOnly Property VertScrollbarVisible As Boolean
    Get
property bool VertScrollbarVisible {
    bool get ();
}
abstract VertScrollbarVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.VertSplitButton Property

IScrollingVertSplitButton Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScrollingButton VertSplitButton { get; }
ReadOnly Property VertSplitButton As IScrollingButton
    Get
property IScrollingButton^ VertSplitButton {
    IScrollingButton^ get ();
}
abstract VertSplitButton : IScrollingButton with get

Property Value

Type: IScrollingButton
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.VScrollBar Property

IScrollingVScrollBar Property
When implemented by a class, gets vertical scroll bar control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScrollBar VScrollBar { get; }
ReadOnly Property VScrollBar As ScrollBar
    Get
property ScrollBar^ VScrollBar {
    ScrollBar^ get ();
}
abstract VScrollBar : ScrollBar with get

Property Value

Type: ScrollBar
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.WindowOriginX Property

IScrollingWindowOriginX Property
When implemented by a class, gets or sets a index of the first visible character within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int WindowOriginX { get; set; }
Property WindowOriginX As Integer
    Get
    Set
property int WindowOriginX {
    int get ();
    void set (int value);
}
abstract WindowOriginX : int with get, set

Property Value

Type: Int32
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.WindowOriginY Property

IScrollingWindowOriginY Property
When implemented by a class, gets or sets a value that represents first visible line within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int WindowOriginY { get; set; }
Property WindowOriginY As Integer
    Get
    Set
property int WindowOriginY {
    int get ();
    void set (int value);
}
abstract WindowOriginY : int with get, set

Property Value

Type: Int32
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling Events

IScrolling Events

The IScrolling type exposes the following members.

Events
 | Name | Description
Public event | HorizontalScroll | When implemented by a class, occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving.
Public event | ScrollButtonClick | When implemented by a class, occurs when some scrolling button is clicked.
Public event | VerticalScroll | When implemented by a class, occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving.
Top
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.HorizontalScroll Event

IScrollingHorizontalScroll Event
When implemented by a class, occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler HorizontalScroll
Event HorizontalScroll As EventHandler
 event EventHandler^ HorizontalScroll {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HorizontalScroll : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.ScrollButtonClick Event

IScrollingScrollButtonClick Event
When implemented by a class, occurs when some scrolling button is clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ScrollButtonClick
Event ScrollButtonClick As EventHandler
 event EventHandler^ ScrollButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScrollButtonClick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrolling.VerticalScroll Event

IScrollingVerticalScroll Event
When implemented by a class, occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler VerticalScroll
Event VerticalScroll As EventHandler
 event EventHandler^ VerticalScroll {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VerticalScroll : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScrolling Interface
Alternet.Editor Namespace


IScrollingButton Interface

IScrollingButton Interface
Represents properties specifying appearance and behaviour of button displayed on the scroll bar.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScrollingButton : IDisposable
Public Interface IScrollingButton
    Inherits IDisposable
public interface class IScrollingButton : IDisposable
type IScrollingButton =
    interface
        interface IDisposable
    end

The IScrollingButton type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IScrollingButton object.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
Properties
 | Name | Description
Public property | AllowCheck | When implemented by a class, gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked.
Public property | BorderStyle | When implemented by a class, gets or sets the border style for this IScrollingButton.
Public property | Button | When implemented by a class, represents windowed control that appears as a button.
Public property | Checked | When implemented by a class, gets or sets a boolean value indicating whether button appears pressed.
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of this IScrollingButton.
Public property | GroupIndex | When implemented by a class, gets or sets a value allows buttons to work together as a group.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for this IScrollingButton.
Public property | Images | When implemented by a class, gets or sets the ImageList for this IScrollingButton.
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for high DPI for this IScrollingButton.
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of this IScrollingButton.
Public property | Scrolling | When implemented by a class, gets or sets IScrolling contains this button.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether this IScrollingButton is visible.
Top
See Also

Reference

Alternet.Editor Namespace


IScrollingButton Methods

IScrollingButton Methods

The IScrollingButton type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IScrollingButton object.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.Assign Method

IScrollingButtonAssign Method
When implemented by a class, copies the contents of another IScrollingButton object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IScrollingButton source
)
Sub Assign (
    source As IScrollingButton
)
void Assign(
    IScrollingButton^ source
)
abstract Assign :
        source : IScrollingButton -> unit

Parameters

source
Type: Alternet.EditorIScrollingButton
Specifies IScrollingButton to assign.
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton Properties

IScrollingButton Properties

The IScrollingButton type exposes the following members.

Properties
 | Name | Description
Public property | AllowCheck | When implemented by a class, gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked.
Public property | BorderStyle | When implemented by a class, gets or sets the border style for this IScrollingButton.
Public property | Button | When implemented by a class, represents windowed control that appears as a button.
Public property | Checked | When implemented by a class, gets or sets a boolean value indicating whether button appears pressed.
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of this IScrollingButton.
Public property | GroupIndex | When implemented by a class, gets or sets a value allows buttons to work together as a group.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for this IScrollingButton.
Public property | Images | When implemented by a class, gets or sets the ImageList for this IScrollingButton.
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for high DPI for this IScrollingButton.
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of this IScrollingButton.
Public property | Scrolling | When implemented by a class, gets or sets IScrolling contains this button.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether this IScrollingButton is visible.
Top
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.AllowCheck Property

IScrollingButtonAllowCheck Property
When implemented by a class, gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AllowCheck { get; set; }
Property AllowCheck As Boolean
    Get
    Set
property bool AllowCheck {
    bool get ();
    void set (bool value);
}
abstract AllowCheck : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.BorderStyle Property

IScrollingButtonBorderStyle Property
When implemented by a class, gets or sets the border style for this IScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
EditBorderStyle BorderStyle { get; set; }
Property BorderStyle As EditBorderStyle
    Get
    Set
property EditBorderStyle BorderStyle {
    EditBorderStyle get ();
    void set (EditBorderStyle value);
}
abstract BorderStyle : EditBorderStyle with get, set

Property Value

Type: EditBorderStyle
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.Button Property

IScrollingButtonButton Property
When implemented by a class, represents windowed control that appears as a button.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SpeedButton Button { get; }
ReadOnly Property Button As SpeedButton
    Get
property SpeedButton^ Button {
    SpeedButton^ get ();
}
abstract Button : SpeedButton with get

Property Value

Type: SpeedButton
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.Checked Property

IScrollingButtonChecked Property
When implemented by a class, gets or sets a boolean value indicating whether button appears pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Checked { get; set; }
Property Checked As Boolean
    Get
    Set
property bool Checked {
    bool get ();
    void set (bool value);
}
abstract Checked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.Description Property

IScrollingButtonDescription Property
When implemented by a class, gets or sets a string value that specifies short description of this IScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.GroupIndex Property

IScrollingButtonGroupIndex Property
When implemented by a class, gets or sets a value allows buttons to work together as a group.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GroupIndex { get; set; }
Property GroupIndex As Integer
    Get
    Set
property int GroupIndex {
    int get ();
    void set (int value);
}
abstract GroupIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.ImageIndex Property

IScrollingButtonImageIndex Property
When implemented by a class, gets or sets the index of the image displayed for this IScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ImageIndex { get; set; }
Property ImageIndex As Integer
    Get
    Set
property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.Images Property

IScrollingButtonImages Property
When implemented by a class, gets or sets the ImageList for this IScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList Images { get; set; }
Property Images As ImageList
    Get
    Set
property ImageList^ Images {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract Images : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.ImagesHighDpi Property

IScrollingButtonImagesHighDpi Property
When implemented by a class, gets or sets the ImageList for high DPI for this IScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList ImagesHighDpi { get; set; }
Property ImagesHighDpi As ImageList
    Get
    Set
property ImageList^ ImagesHighDpi {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract ImagesHighDpi : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.Name Property

IScrollingButtonName Property
When implemented by a class, gets or sets a string value that specifies the name of this IScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.Scrolling Property

IScrollingButtonScrolling Property
When implemented by a class, gets or sets IScrolling contains this button.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScrolling Scrolling { get; set; }
Property Scrolling As IScrolling
    Get
    Set
property IScrolling^ Scrolling {
    IScrolling^ get ();
    void set (IScrolling^ value);
}
abstract Scrolling : IScrolling with get, set

Property Value

Type: IScrolling
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButton.Visible Property

IScrollingButtonVisible Property
When implemented by a class, gets or sets a value indicating whether this IScrollingButton is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScrollingButton Interface
Alternet.Editor Namespace


IScrollingButtons Interface

IScrollingButtons Interface
Represents properties and methods to provide an indexed access to individual IScrollingButton object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScrollingButtons : IList<IScrollingButton>,
    ICollection<IScrollingButton>, IEnumerable<IScrollingButton>, IEnumerable
Public Interface IScrollingButtons
    Inherits IList(Of IScrollingButton), ICollection(Of IScrollingButton),
    IEnumerable(Of IScrollingButton), IEnumerable
public interface class IScrollingButtons : IList<IScrollingButton^>,
    ICollection<IScrollingButton^>, IEnumerable<IScrollingButton^>, IEnumerable
type IScrollingButtons =
    interface
        interface IList<IScrollingButton>
        interface ICollection<IScrollingButton>
        interface IEnumerable<IScrollingButton>
        interface IEnumerable
    end

The IScrollingButtons type exposes the following members.

Methods
 | Name | Description
Public method | Add | When implemented by a class, adds an IScrollingButton to the list.
Public method | AddScrollingButton | When implemented by a class, creates and adds a new IScrollingButton to the collection.
Public method | AddScrollingButton(String, String, Int32) | When implemented by a class, creates new IScrollingButton with specified parameters and adds it to the collection.
Public method | Assign | When implemented by a class, copies the contents of another IScrollingButtons object.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIScrollingButton .)
Public method | ClearButtons | When implemented by a class, clears entire collection.
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIScrollingButton .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIScrollingButton .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIScrollingButton .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIScrollingButton .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIScrollingButton .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIScrollingButton .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIScrollingButton .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIScrollingButton | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIScrollingButton | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIScrollingButton, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIScrollingButton .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIScrollingButton .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIScrollingButton .)
Top
See Also

Reference

Alternet.Editor Namespace


IScrollingButtons Methods

IScrollingButtons Methods

The IScrollingButtons type exposes the following members.

Methods
 | Name | Description
Public method | Add | When implemented by a class, adds an IScrollingButton to the list.
Public method | AddScrollingButton | When implemented by a class, creates and adds a new IScrollingButton to the collection.
Public method | AddScrollingButton(String, String, Int32) | When implemented by a class, creates new IScrollingButton with specified parameters and adds it to the collection.
Public method | Assign | When implemented by a class, copies the contents of another IScrollingButtons object.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIScrollingButton .)
Public method | ClearButtons | When implemented by a class, clears entire collection.
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIScrollingButton .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIScrollingButton .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIScrollingButton .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIScrollingButton .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIScrollingButton .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIScrollingButton .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIScrollingButton .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIScrollingButton | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIScrollingButton | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIScrollingButton, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IScrollingButtons Interface
Alternet.Editor Namespace


IScrollingButtons.Add Method

IScrollingButtonsAdd Method
When implemented by a class, adds an IScrollingButton to the list.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Add(
    IScrollingButton item
)
Sub Add (
    item As IScrollingButton
)
void Add(
    IScrollingButton^ item
)
abstract Add :
        item : IScrollingButton -> unit

Parameters

item
Type: Alternet.EditorIScrollingButton
IScrollingButton to be added.

Implements

ICollectionTAdd(T)
See Also

Reference

IScrollingButtons Interface
Alternet.Editor Namespace


IScrollingButtons.AddScrollingButton Method

IScrollingButtonsAddScrollingButton Method
Overload List
 | Name | Description
Public method | AddScrollingButton | When implemented by a class, creates and adds a new IScrollingButton to the collection.
Public method | AddScrollingButton(String, String, Int32) | When implemented by a class, creates new IScrollingButton with specified parameters and adds it to the collection.
Top
See Also

Reference

IScrollingButtons Interface
Alternet.Editor Namespace


IScrollingButtons.AddScrollingButton Method

IScrollingButtonsAddScrollingButton Method
When implemented by a class, creates and adds a new IScrollingButton to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AddScrollingButton()
Function AddScrollingButton As Integer
int AddScrollingButton()
abstract AddScrollingButton : unit -> int

Return Value

Type: Int32
Index of this new IScrollingButton in the collection.
See Also

Reference

IScrollingButtons Interface
AddScrollingButton Overload
Alternet.Editor Namespace


IScrollingButtons.AddScrollingButton Method (String, String, Int32)

IScrollingButtonsAddScrollingButton Method (String, String, Int32)
When implemented by a class, creates new IScrollingButton with specified parameters and adds it to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AddScrollingButton(
    string name,
    string description,
    int imageIndex
)
Function AddScrollingButton (
    name As String,
    description As String,
    imageIndex As Integer
) As Integer
int AddScrollingButton(
    String^ name,
    String^ description,
    int imageIndex
)
abstract AddScrollingButton :
        name : string *
        description : string *
        imageIndex : int -> int

Parameters

name
Type: SystemString
Name of this new IScrollingButton.
description
Type: SystemString
Description of this new IScrollingButton.
imageIndex
Type: SystemInt32
ImageIndex of this new IScrollingButton.

Return Value

Type: Int32
Index of this new IScrollingButton in the collection.
See Also

Reference

IScrollingButtons Interface
AddScrollingButton Overload
Alternet.Editor Namespace


IScrollingButtons.Assign Method

IScrollingButtonsAssign Method
When implemented by a class, copies the contents of another IScrollingButtons object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IScrollingButtons source
)
Sub Assign (
    source As IScrollingButtons
)
void Assign(
    IScrollingButtons^ source
)
abstract Assign :
        source : IScrollingButtons -> unit

Parameters

source
Type: Alternet.EditorIScrollingButtons
Specifies IScrollingButtons to assign.
See Also

Reference

IScrollingButtons Interface
Alternet.Editor Namespace


IScrollingButtons.ClearButtons Method

IScrollingButtonsClearButtons Method
When implemented by a class, clears entire collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearButtons()
Sub ClearButtons
void ClearButtons()
abstract ClearButtons : unit -> unit
See Also

Reference

IScrollingButtons Interface
Alternet.Editor Namespace


IScrollingButtons Properties

IScrollingButtons Properties

The IScrollingButtons type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIScrollingButton .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIScrollingButton .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIScrollingButton .)
Top
See Also

Reference

IScrollingButtons Interface
Alternet.Editor Namespace


ISearch Interface

ISearch Interface
Represents properties and methods used to search and replace control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISearch : ITextSearch
Public Interface ISearch
    Inherits ITextSearch
public interface class ISearch : ITextSearch
type ISearch =
    interface
        interface ITextSearch
    end

The ISearch type exposes the following members.

Methods
 | Name | Description
Public method | CanFindNext | When implemented by a class, indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
Public method | CanFindNextSelected | When implemented by a class, indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
Public method | CanFindPrevious | When implemented by a class, indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
Public method | CanFindPreviousSelected | When implemented by a class, indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
Public method | CanSearchSelection | When implemented by a class, returns whether search can be performed inside selection.
Public method | CycledSearch | When implemented by a class, performs cycled search.
Public method | Find(String) | When implemented by a class, searches for given text within the control's contents.
Public method | Find(String, SearchOptions) | When implemented by a class, searches for given text within the control's contents with specified options.
Public method | Find(String, SearchOptions, Regex) | When implemented by a class, searches for given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, IListIRange) | When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, Boolean, Boolean) | When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, Point, Int32, Match) | When implemented by a class, searches for given text within the control's text content. (Inherited from ITextSearch.)
Public method | FindNext | When implemented by a class, searches for the next occurrence of the text specified by previous search.
Public method | FindNextSelected | When implemented by a class, searches for the next occurrence of the selected text.
Public method | FindPrevious | When implemented by a class, searches for the previous occurrence of the text specified by previous search.
Public method | FindPreviousSelected | When implemented by a class, searches for the previous occurrence of the selected text.
Public method | FinishIncrementalSearch | When implemented by a class, leaves control from the incremental search state.
Public method | GetTextToSearchAtCursor | When implemented by a class, returns word at the cursor position.
Public method | HighlightAll | When implemented by a class, highlights all occurrences of specified string in the class text content.
Public method | IncrementalSearch | When implemented by a class, finds given text incrementally.
Public method | MarkAll(String, Boolean) | When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | MarkAll(String, SearchOptions, Boolean) | When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | MarkAll(String, SearchOptions, Regex, Boolean) | When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | NeedReplaceCurrent | When implemented by a class, indicates whether search engine need to replace successfully found and selected text.
Public method | OnTextFound | When implemented by a class, occurs when search text is found.
Public method | Replace(String, String) | When implemented by a class, searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
Public method | Replace(String, String, SearchOptions) | When implemented by a class, searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
Public method | Replace(String, String, SearchOptions, Regex) | When implemented by a class, searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
Public method | ReplaceAll(String, String, Int32) | When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Int32) | When implemented by a class, replaces all occurrences of given text within text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Regex, Int32) | When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean) | When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceCurrent | When implemented by a class, replaces currently selected text.
Public method | ShowNotFound | When implemented by a class, displays "searched text not found" message box.
Public method | StartIncrementalSearch | When implemented by a class, enters control to the incremental search state.
Public method | StartIncrementalSearch(Boolean) | When implemented by a class, enters control to the incremental search state.
Public method | UnhighlightAll | When implemented by a class, unhighlights search results previously highlighted by HighlightAll.
Top
Properties
 | Name | Description
Public property | FirstSearch | When implemented by a class, gets or sets a value indicating whether control launches text search at first.
Public property | GotoLineDialog | When implemented by a class, gets or sets a dialog prompting for index of the line you need to locate.
Public property | HighlightSearchResults | When implemented by a class, indicates whether search results are highlighted while the search dialog is open.
Public property | IncrementalSearchString | When implemented by a class, return text to search if class is in incremental search state; otherwise return empty string.
Public property | InIncrementalSearch | When implemented by a class, indicates whether control is in incremental search state.
Public property | SearchDialog | When implemented by a class, gets or sets a dialog box allowing to search for the text or replace it.
Public property | SearchGlobal | When implemented by a class, gets or sets a value indicating whether search should be global.
Public property | SearchLen | When implemented by a class, represents length of the last found text.
Public property | SearchOptions | When implemented by a class, gets or sets a value that defines search and replace options.
Public property | SearchPos | When implemented by a class, gets or sets a value that represents position of the last found text.
Top
Events
 | Name | Description
Public event | TextChanged | When implemented by a class, occurs when the TextEditor text changes.
Top
See Also

Reference

Alternet.Editor Namespace


ISearch Methods

ISearch Methods

The ISearch type exposes the following members.

Methods
 | Name | Description
Public method | CanFindNext | When implemented by a class, indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
Public method | CanFindNextSelected | When implemented by a class, indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
Public method | CanFindPrevious | When implemented by a class, indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
Public method | CanFindPreviousSelected | When implemented by a class, indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
Public method | CanSearchSelection | When implemented by a class, returns whether search can be performed inside selection.
Public method | CycledSearch | When implemented by a class, performs cycled search.
Public method | Find(String) | When implemented by a class, searches for given text within the control's contents.
Public method | Find(String, SearchOptions) | When implemented by a class, searches for given text within the control's contents with specified options.
Public method | Find(String, SearchOptions, Regex) | When implemented by a class, searches for given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, IListIRange) | When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, Boolean, Boolean) | When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, Point, Int32, Match) | When implemented by a class, searches for given text within the control's text content. (Inherited from ITextSearch.)
Public method | FindNext | When implemented by a class, searches for the next occurrence of the text specified by previous search.
Public method | FindNextSelected | When implemented by a class, searches for the next occurrence of the selected text.
Public method | FindPrevious | When implemented by a class, searches for the previous occurrence of the text specified by previous search.
Public method | FindPreviousSelected | When implemented by a class, searches for the previous occurrence of the selected text.
Public method | FinishIncrementalSearch | When implemented by a class, leaves control from the incremental search state.
Public method | GetTextToSearchAtCursor | When implemented by a class, returns word at the cursor position.
Public method | HighlightAll | When implemented by a class, highlights all occurrences of specified string in the class text content.
Public method | IncrementalSearch | When implemented by a class, finds given text incrementally.
Public method | MarkAll(String, Boolean) | When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | MarkAll(String, SearchOptions, Boolean) | When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | MarkAll(String, SearchOptions, Regex, Boolean) | When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | NeedReplaceCurrent | When implemented by a class, indicates whether search engine need to replace successfully found and selected text.
Public method | OnTextFound | When implemented by a class, occurs when search text is found.
Public method | Replace(String, String) | When implemented by a class, searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
Public method | Replace(String, String, SearchOptions) | When implemented by a class, searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
Public method | Replace(String, String, SearchOptions, Regex) | When implemented by a class, searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
Public method | ReplaceAll(String, String, Int32) | When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Int32) | When implemented by a class, replaces all occurrences of given text within text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Regex, Int32) | When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean) | When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceCurrent | When implemented by a class, replaces currently selected text.
Public method | ShowNotFound | When implemented by a class, displays "searched text not found" message box.
Public method | StartIncrementalSearch | When implemented by a class, enters control to the incremental search state.
Public method | StartIncrementalSearch(Boolean) | When implemented by a class, enters control to the incremental search state.
Public method | UnhighlightAll | When implemented by a class, unhighlights search results previously highlighted by HighlightAll.
Top
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.CanFindNext Method

ISearchCanFindNext Method
When implemented by a class, indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanFindNext()
Function CanFindNext As Boolean
bool CanFindNext()
abstract CanFindNext : unit -> bool

Return Value

Type: Boolean
False if it is the first attempt to search; otherwise true.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.CanFindNextSelected Method

ISearchCanFindNextSelected Method
When implemented by a class, indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanFindNextSelected()
Function CanFindNextSelected As Boolean
bool CanFindNextSelected()
abstract CanFindNextSelected : unit -> bool

Return Value

Type: Boolean
False if it is the first attempt to search or no text selected; otherwise true.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.CanFindPrevious Method

ISearchCanFindPrevious Method
When implemented by a class, indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanFindPrevious()
Function CanFindPrevious As Boolean
bool CanFindPrevious()
abstract CanFindPrevious : unit -> bool

Return Value

Type: Boolean
False if it is the first attempt to search; otherwise true.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.CanFindPreviousSelected Method

ISearchCanFindPreviousSelected Method
When implemented by a class, indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanFindPreviousSelected()
Function CanFindPreviousSelected As Boolean
bool CanFindPreviousSelected()
abstract CanFindPreviousSelected : unit -> bool

Return Value

Type: Boolean
False if it is the first attempt to search or no text selected; otherwise true.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.CanSearchSelection Method

ISearchCanSearchSelection Method
When implemented by a class, returns whether search can be performed inside selection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSearchSelection(
    out string selectedText
)
Function CanSearchSelection (
    <OutAttribute> ByRef selectedText As String
) As Boolean
bool CanSearchSelection(
    [OutAttribute] String^% selectedText
)
abstract CanSearchSelection :
        selectedText : string byref -> bool

Parameters

selectedText
Type: SystemString
Specifies the text being selected.

Return Value

Type: Boolean
True if selection is not empty; otherwise false.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.CycledSearch Method

ISearchCycledSearch Method
When implemented by a class, performs cycled search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CycledSearch(
    string text,
    SearchOptions options,
    Regex expression,
    bool silent
)
Function CycledSearch (
    text As String,
    options As SearchOptions,
    expression As Regex,
    silent As Boolean
) As Boolean
bool CycledSearch(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    bool silent
)
abstract CycledSearch :
        text : string *
        options : SearchOptions *
        expression : Regex *
        silent : bool -> bool

Parameters

text
Type: SystemString
Text being found.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
silent
Type: SystemBoolean
Determines if no visual feedback is required.

Return Value

Type: Boolean
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.Find Method

ISearchFind Method
Overload List
 | Name | Description
Public method | Find(String) | When implemented by a class, searches for given text within the control's contents.
Public method | Find(String, SearchOptions) | When implemented by a class, searches for given text within the control's contents with specified options.
Public method | Find(String, SearchOptions, Regex) | When implemented by a class, searches for given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, IListIRange) | When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, Boolean, Boolean) | When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, Point, Int32, Match) | When implemented by a class, searches for given text within the control's text content. (Inherited from ITextSearch.)
Top
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.Find Method (String)

ISearchFind Method (String)
When implemented by a class, searches for given text within the control's contents.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Find(
    string text
)
Function Find (
    text As String
) As Boolean
bool Find(
    String^ text
)
abstract Find :
        text : string -> bool

Parameters

text
Type: SystemString
Text to find.

Return Value

Type: Boolean
True if search succeed; otherwise false.
See Also

Reference

ISearch Interface
Find Overload
Alternet.Editor Namespace


ISearch.Find Method (String, SearchOptions)

ISearchFind Method (String, SearchOptions)
When implemented by a class, searches for given text within the control's contents with specified options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Find(
    string text,
    SearchOptions options
)
Function Find (
    text As String,
    options As SearchOptions
) As Boolean
bool Find(
    String^ text,
    SearchOptions options
)
abstract Find :
        text : string *
        options : SearchOptions -> bool

Parameters

text
Type: SystemString
Text to find.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.

Return Value

Type: Boolean
True if search succeed; otherwise false.
See Also

Reference

ISearch Interface
Find Overload
Alternet.Editor Namespace


ISearch.Find Method (String, SearchOptions, Regex)

ISearchFind Method (String, SearchOptions, Regex)
When implemented by a class, searches for given text within the control's contents with specified options using specified regular expression.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Find(
    string text,
    SearchOptions options,
    Regex expression
)
Function Find (
    text As String,
    options As SearchOptions,
    expression As Regex
) As Boolean
bool Find(
    String^ text,
    SearchOptions options,
    Regex^ expression
)
abstract Find :
        text : string *
        options : SearchOptions *
        expression : Regex -> bool

Parameters

text
Type: SystemString
Text to find.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.

Return Value

Type: Boolean
True if search succeed; otherwise false.
See Also

Reference

ISearch Interface
Find Overload
Alternet.Editor Namespace


ISearch.Find Method (String, SearchOptions, Regex, IList(IRange))

ISearchFind Method (String, SearchOptions, Regex, IListIRange)
When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Find(
    string text,
    SearchOptions options,
    Regex expression,
    IList<IRange> ranges
)
Function Find (
    text As String,
    options As SearchOptions,
    expression As Regex,
    ranges As IList(Of IRange)
) As Boolean
bool Find(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    IList<IRange^>^ ranges
)
abstract Find :
        text : string *
        options : SearchOptions *
        expression : Regex *
        ranges : IList<IRange> -> bool

Parameters

text
Type: SystemString
Text to find.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
ranges
Type: System.Collections.GenericIListIRange
Represents list of ranges determining search results.

Return Value

Type: Boolean
True if search succeed; otherwise false.
See Also

Reference

ISearch Interface
Find Overload
Alternet.Editor Namespace


ISearch.Find Method (String, SearchOptions, Regex, Boolean, Boolean)

ISearchFind Method (String, SearchOptions, Regex, Boolean, Boolean)
When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Find(
    string text,
    SearchOptions options,
    Regex expression,
    bool firstSearch,
    bool silent
)
Function Find (
    text As String,
    options As SearchOptions,
    expression As Regex,
    firstSearch As Boolean,
    silent As Boolean
) As Boolean
bool Find(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    bool firstSearch,
    bool silent
)
abstract Find :
        text : string *
        options : SearchOptions *
        expression : Regex *
        firstSearch : bool *
        silent : bool -> bool

Parameters

text
Type: SystemString
Text to find.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
firstSearch
Type: SystemBoolean
Specifies if search is performed the first time.
silent
Type: SystemBoolean
Determines if no visual feedback is required.

Return Value

Type: Boolean
True if search succeed; otherwise false.
See Also

Reference

ISearch Interface
Find Overload
Alternet.Editor Namespace


ISearch.FindNext Method

ISearchFindNext Method
When implemented by a class, searches for the next occurrence of the text specified by previous search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindNext()
Function FindNext As Boolean
bool FindNext()
abstract FindNext : unit -> bool

Return Value

Type: Boolean
True if search succeed; otherwise false.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.FindNextSelected Method

ISearchFindNextSelected Method
When implemented by a class, searches for the next occurrence of the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindNextSelected()
Function FindNextSelected As Boolean
bool FindNextSelected()
abstract FindNextSelected : unit -> bool

Return Value

Type: Boolean
True if search succeed; otherwise false.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.FindPrevious Method

ISearchFindPrevious Method
When implemented by a class, searches for the previous occurrence of the text specified by previous search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindPrevious()
Function FindPrevious As Boolean
bool FindPrevious()
abstract FindPrevious : unit -> bool

Return Value

Type: Boolean
True if search succeed; otherwise false.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.FindPreviousSelected Method

ISearchFindPreviousSelected Method
When implemented by a class, searches for the previous occurrence of the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindPreviousSelected()
Function FindPreviousSelected As Boolean
bool FindPreviousSelected()
abstract FindPreviousSelected : unit -> bool

Return Value

Type: Boolean
True if search succeed; otherwise false.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.FinishIncrementalSearch Method

ISearchFinishIncrementalSearch Method
When implemented by a class, leaves control from the incremental search state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FinishIncrementalSearch()
Sub FinishIncrementalSearch
void FinishIncrementalSearch()
abstract FinishIncrementalSearch : unit -> unit
See Also

Reference

ISearch Interface
Alternet.Editor Namespace
ISearchStartIncrementalSearch


ISearch.GetTextToSearchAtCursor Method

ISearchGetTextToSearchAtCursor Method
When implemented by a class, returns word at the cursor position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetTextToSearchAtCursor()
Function GetTextToSearchAtCursor As String
String^ GetTextToSearchAtCursor()
abstract GetTextToSearchAtCursor : unit -> string

Return Value

Type: String
Word at the cursor position.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.HighlightAll Method

ISearchHighlightAll Method
When implemented by a class, highlights all occurrences of specified string in the class text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int HighlightAll(
    string text,
    SearchOptions options,
    Regex expression
)
Function HighlightAll (
    text As String,
    options As SearchOptions,
    expression As Regex
) As Integer
int HighlightAll(
    String^ text,
    SearchOptions options,
    Regex^ expression
)
abstract HighlightAll :
        text : string *
        options : SearchOptions *
        expression : Regex -> int

Parameters

text
Type: SystemString
Specifies text to mark.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.

Return Value

Type: Int32
Number of found occurrences.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.IncrementalSearch Method

ISearchIncrementalSearch Method
When implemented by a class, finds given text incrementally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IncrementalSearch(
    string key,
    bool deleteLast
)
Function IncrementalSearch (
    key As String,
    deleteLast As Boolean
) As Boolean
bool IncrementalSearch(
    String^ key,
    bool deleteLast
)
abstract IncrementalSearch :
        key : string *
        deleteLast : bool -> bool

Parameters

key
Type: SystemString
Additional value to search text.
deleteLast
Type: SystemBoolean
Specifies whether search text should be altered by adding Key string.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.MarkAll Method

ISearchMarkAll Method
Overload List
 | Name | Description
Public method | MarkAll(String, Boolean) | When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | MarkAll(String, SearchOptions, Boolean) | When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | MarkAll(String, SearchOptions, Regex, Boolean) | When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Top
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.MarkAll Method (String, Boolean)

ISearchMarkAll Method (String, Boolean)
When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MarkAll(
    string text,
    bool clearPrevious
)
Function MarkAll (
    text As String,
    clearPrevious As Boolean
) As Integer
int MarkAll(
    String^ text,
    bool clearPrevious
)
abstract MarkAll :
        text : string *
        clearPrevious : bool -> int

Parameters

text
Type: SystemString
Specifies text to mark.
clearPrevious
Type: SystemBoolean
Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Return Value

Type: Int32
Number of found occurrences.
See Also

Reference

ISearch Interface
MarkAll Overload
Alternet.Editor Namespace


ISearch.MarkAll Method (String, SearchOptions, Boolean)

ISearchMarkAll Method (String, SearchOptions, Boolean)
When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MarkAll(
    string text,
    SearchOptions options,
    bool clearPrevious
)
Function MarkAll (
    text As String,
    options As SearchOptions,
    clearPrevious As Boolean
) As Integer
int MarkAll(
    String^ text,
    SearchOptions options,
    bool clearPrevious
)
abstract MarkAll :
        text : string *
        options : SearchOptions *
        clearPrevious : bool -> int

Parameters

text
Type: SystemString
Specifies text to mark.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
clearPrevious
Type: SystemBoolean
Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Return Value

Type: Int32
Number of found occurrences.
See Also

Reference

ISearch Interface
MarkAll Overload
Alternet.Editor Namespace


ISearch.MarkAll Method (String, SearchOptions, Regex, Boolean)

ISearchMarkAll Method (String, SearchOptions, Regex, Boolean)
When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MarkAll(
    string text,
    SearchOptions options,
    Regex expression,
    bool clearPrevious
)
Function MarkAll (
    text As String,
    options As SearchOptions,
    expression As Regex,
    clearPrevious As Boolean
) As Integer
int MarkAll(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    bool clearPrevious
)
abstract MarkAll :
        text : string *
        options : SearchOptions *
        expression : Regex *
        clearPrevious : bool -> int

Parameters

text
Type: SystemString
Specifies text to mark.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
clearPrevious
Type: SystemBoolean
Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Return Value

Type: Int32
Number of found occurrences.
See Also

Reference

ISearch Interface
MarkAll Overload
Alternet.Editor Namespace


ISearch.NeedReplaceCurrent Method

ISearchNeedReplaceCurrent Method
When implemented by a class, indicates whether search engine need to replace successfully found and selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedReplaceCurrent(
    out Match match
)
Function NeedReplaceCurrent (
    <OutAttribute> ByRef match As Match
) As Boolean
bool NeedReplaceCurrent(
    [OutAttribute] Match^% match
)
abstract NeedReplaceCurrent :
        match : Match byref -> bool

Parameters

match
Type: System.Text.RegularExpressionsMatch
Receives match if regular expression search successful.

Return Value

Type: Boolean
True if selected text matches search text; otherwise false.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.OnTextFound Method

ISearchOnTextFound Method
When implemented by a class, occurs when search text is found.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnTextFound(
    string text,
    SearchOptions options,
    Regex expression,
    Match match,
    Point position,
    int len,
    bool silent,
    bool multiline
)
Sub OnTextFound (
    text As String,
    options As SearchOptions,
    expression As Regex,
    match As Match,
    position As Point,
    len As Integer,
    silent As Boolean,
    multiline As Boolean
)
void OnTextFound(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    Match^ match,
    Point position,
    int len,
    bool silent,
    bool multiline
)
abstract OnTextFound :
        text : string *
        options : SearchOptions *
        expression : Regex *
        match : Match *
        position : Point *
        len : int *
        silent : bool *
        multiline : bool -> unit

Parameters

text
Type: SystemString
Text being found.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
match
Type: System.Text.RegularExpressionsMatch
Specifies match if regular expression search successful.
position
Type: System.DrawingPoint
Specifies position of found text.
len
Type: SystemInt32
Specifies length of found text.
silent
Type: SystemBoolean
Determines if no visual feedback is required.
multiline
Type: SystemBoolean
Determines if search text is found on multiple lines.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.Replace Method

ISearchReplace Method
Overload List
 | Name | Description
Public method | Replace(String, String) | When implemented by a class, searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
Public method | Replace(String, String, SearchOptions) | When implemented by a class, searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
Public method | Replace(String, String, SearchOptions, Regex) | When implemented by a class, searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
Top
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.Replace Method (String, String)

ISearchReplace Method (String, String)
When implemented by a class, searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Replace(
    string text,
    string replaceWith
)
Function Replace (
    text As String,
    replaceWith As String
) As Boolean
bool Replace(
    String^ text,
    String^ replaceWith
)
abstract Replace :
        text : string *
        replaceWith : string -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISearch Interface
Replace Overload
Alternet.Editor Namespace


ISearch.Replace Method (String, String, SearchOptions)

ISearchReplace Method (String, String, SearchOptions)
When implemented by a class, searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Replace(
    string text,
    string replaceWith,
    SearchOptions options
)
Function Replace (
    text As String,
    replaceWith As String,
    options As SearchOptions
) As Boolean
bool Replace(
    String^ text,
    String^ replaceWith,
    SearchOptions options
)
abstract Replace :
        text : string *
        replaceWith : string *
        options : SearchOptions -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISearch Interface
Replace Overload
Alternet.Editor Namespace


ISearch.Replace Method (String, String, SearchOptions, Regex)

ISearchReplace Method (String, String, SearchOptions, Regex)
When implemented by a class, searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Replace(
    string text,
    string replaceWith,
    SearchOptions options,
    Regex expression
)
Function Replace (
    text As String,
    replaceWith As String,
    options As SearchOptions,
    expression As Regex
) As Boolean
bool Replace(
    String^ text,
    String^ replaceWith,
    SearchOptions options,
    Regex^ expression
)
abstract Replace :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        expression : Regex -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISearch Interface
Replace Overload
Alternet.Editor Namespace


ISearch.ReplaceAll Method

ISearchReplaceAll Method
Overload List
 | Name | Description
Public method | ReplaceAll(String, String, Int32) | When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Int32) | When implemented by a class, replaces all occurrences of given text within text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Regex, Int32) | When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean) | When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
Top
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.ReplaceAll Method (String, String, Int32)

ISearchReplaceAll Method (String, String, Int32)
When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReplaceAll(
    string text,
    string replaceWith,
    out int count
)
Function ReplaceAll (
    text As String,
    replaceWith As String,
    <OutAttribute> ByRef count As Integer
) As Boolean
bool ReplaceAll(
    String^ text,
    String^ replaceWith,
    [OutAttribute] int% count
)
abstract ReplaceAll :
        text : string *
        replaceWith : string *
        count : int byref -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
count
Type: SystemInt32
Number of replaced occurrences.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISearch Interface
ReplaceAll Overload
Alternet.Editor Namespace


ISearch.ReplaceAll Method (String, String, SearchOptions, Int32)

ISearchReplaceAll Method (String, String, SearchOptions, Int32)
When implemented by a class, replaces all occurrences of given text within text content by specified replaceWith string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReplaceAll(
    string text,
    string replaceWith,
    SearchOptions options,
    out int count
)
Function ReplaceAll (
    text As String,
    replaceWith As String,
    options As SearchOptions,
    <OutAttribute> ByRef count As Integer
) As Boolean
bool ReplaceAll(
    String^ text,
    String^ replaceWith,
    SearchOptions options,
    [OutAttribute] int% count
)
abstract ReplaceAll :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        count : int byref -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
count
Type: SystemInt32
Number of replaced occurrences.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISearch Interface
ReplaceAll Overload
Alternet.Editor Namespace


ISearch.ReplaceAll Method (String, String, SearchOptions, Regex, Int32)

ISearchReplaceAll Method (String, String, SearchOptions, Regex, Int32)
When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReplaceAll(
    string text,
    string replaceWith,
    SearchOptions options,
    Regex expression,
    out int count
)
Function ReplaceAll (
    text As String,
    replaceWith As String,
    options As SearchOptions,
    expression As Regex,
    <OutAttribute> ByRef count As Integer
) As Boolean
bool ReplaceAll(
    String^ text,
    String^ replaceWith,
    SearchOptions options,
    Regex^ expression,
    [OutAttribute] int% count
)
abstract ReplaceAll :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        expression : Regex *
        count : int byref -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
count
Type: SystemInt32
Number of replaced occurrences.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISearch Interface
ReplaceAll Overload
Alternet.Editor Namespace


ISearch.ReplaceAll Method (String, String, SearchOptions, Regex, Int32, Boolean)

ISearchReplaceAll Method (String, String, SearchOptions, Regex, Int32, Boolean)
When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReplaceAll(
    string text,
    string replaceWith,
    SearchOptions options,
    Regex expression,
    out int count,
    out bool abort
)
Function ReplaceAll (
    text As String,
    replaceWith As String,
    options As SearchOptions,
    expression As Regex,
    <OutAttribute> ByRef count As Integer,
    <OutAttribute> ByRef abort As Boolean
) As Boolean
bool ReplaceAll(
    String^ text,
    String^ replaceWith,
    SearchOptions options,
    Regex^ expression,
    [OutAttribute] int% count,
    [OutAttribute] bool% abort
)
abstract ReplaceAll :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        expression : Regex *
        count : int byref *
        abort : bool byref -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
count
Type: SystemInt32
Number of replaced occurrences.
abort
Type: SystemBoolean
Indicates whether replace action aborted.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISearch Interface
ReplaceAll Overload
Alternet.Editor Namespace


ISearch.ReplaceCurrent Method

ISearchReplaceCurrent Method
When implemented by a class, replaces currently selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReplaceCurrent(
    string replaceWith,
    SearchOptions options,
    Match match
)
Function ReplaceCurrent (
    replaceWith As String,
    options As SearchOptions,
    match As Match
) As Boolean
bool ReplaceCurrent(
    String^ replaceWith,
    SearchOptions options,
    Match^ match
)
abstract ReplaceCurrent :
        replaceWith : string *
        options : SearchOptions *
        match : Match -> bool

Parameters

replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search and replace.
match
Type: System.Text.RegularExpressionsMatch
Represents Match object if regular expression search successful.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.ShowNotFound Method

ISearchShowNotFound Method
When implemented by a class, displays "searched text not found" message box.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowNotFound(
    string caption
)
Sub ShowNotFound (
    caption As String
)
void ShowNotFound(
    String^ caption
)
abstract ShowNotFound :
        caption : string -> unit

Parameters

caption
Type: SystemString
Specifies caption of the message dialog.
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.StartIncrementalSearch Method

ISearchStartIncrementalSearch Method
Overload List
 | Name | Description
Public method | StartIncrementalSearch | When implemented by a class, enters control to the incremental search state.
Public method | StartIncrementalSearch(Boolean) | When implemented by a class, enters control to the incremental search state.
Top
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.StartIncrementalSearch Method

ISearchStartIncrementalSearch Method
When implemented by a class, enters control to the incremental search state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartIncrementalSearch()
Sub StartIncrementalSearch
void StartIncrementalSearch()
abstract StartIncrementalSearch : unit -> unit
See Also

Reference

ISearch Interface
StartIncrementalSearch Overload
Alternet.Editor Namespace
ISearchFinishIncrementalSearch


ISearch.StartIncrementalSearch Method (Boolean)

ISearchStartIncrementalSearch Method (Boolean)
When implemented by a class, enters control to the incremental search state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartIncrementalSearch(
    bool backwardSearch
)
Sub StartIncrementalSearch (
    backwardSearch As Boolean
)
void StartIncrementalSearch(
    bool backwardSearch
)
abstract StartIncrementalSearch :
        backwardSearch : bool -> unit

Parameters

backwardSearch
Type: SystemBoolean
Indicates that search should be executed towards the beginning of text.
See Also

Reference

ISearch Interface
StartIncrementalSearch Overload
Alternet.Editor Namespace
ISearchFinishIncrementalSearch


ISearch.UnhighlightAll Method

ISearchUnhighlightAll Method
When implemented by a class, unhighlights search results previously highlighted by HighlightAll.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnhighlightAll()
Sub UnhighlightAll
void UnhighlightAll()
abstract UnhighlightAll : unit -> unit
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch Properties

ISearch Properties

The ISearch type exposes the following members.

Properties
 | Name | Description
Public property | FirstSearch | When implemented by a class, gets or sets a value indicating whether control launches text search at first.
Public property | GotoLineDialog | When implemented by a class, gets or sets a dialog prompting for index of the line you need to locate.
Public property | HighlightSearchResults | When implemented by a class, indicates whether search results are highlighted while the search dialog is open.
Public property | IncrementalSearchString | When implemented by a class, return text to search if class is in incremental search state; otherwise return empty string.
Public property | InIncrementalSearch | When implemented by a class, indicates whether control is in incremental search state.
Public property | SearchDialog | When implemented by a class, gets or sets a dialog box allowing to search for the text or replace it.
Public property | SearchGlobal | When implemented by a class, gets or sets a value indicating whether search should be global.
Public property | SearchLen | When implemented by a class, represents length of the last found text.
Public property | SearchOptions | When implemented by a class, gets or sets a value that defines search and replace options.
Public property | SearchPos | When implemented by a class, gets or sets a value that represents position of the last found text.
Top
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.FirstSearch Property

ISearchFirstSearch Property
When implemented by a class, gets or sets a value indicating whether control launches text search at first.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FirstSearch { get; set; }
Property FirstSearch As Boolean
    Get
    Set
property bool FirstSearch {
    bool get ();
    void set (bool value);
}
abstract FirstSearch : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.GotoLineDialog Property

ISearchGotoLineDialog Property
When implemented by a class, gets or sets a dialog prompting for index of the line you need to locate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IGotoLineDialog GotoLineDialog { get; set; }
Property GotoLineDialog As IGotoLineDialog
    Get
    Set
property IGotoLineDialog^ GotoLineDialog {
    IGotoLineDialog^ get ();
    void set (IGotoLineDialog^ value);
}
abstract GotoLineDialog : IGotoLineDialog with get, set

Property Value

Type: IGotoLineDialog
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.HighlightSearchResults Property

ISearchHighlightSearchResults Property
When implemented by a class, indicates whether search results are highlighted while the search dialog is open.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HighlightSearchResults { get; set; }
Property HighlightSearchResults As Boolean
    Get
    Set
property bool HighlightSearchResults {
    bool get ();
    void set (bool value);
}
abstract HighlightSearchResults : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.IncrementalSearchString Property

ISearchIncrementalSearchString Property
When implemented by a class, return text to search if class is in incremental search state; otherwise return empty string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string IncrementalSearchString { get; }
ReadOnly Property IncrementalSearchString As String
    Get
property String^ IncrementalSearchString {
    String^ get ();
}
abstract IncrementalSearchString : string with get

Property Value

Type: String
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.InIncrementalSearch Property

ISearchInIncrementalSearch Property
When implemented by a class, indicates whether control is in incremental search state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool InIncrementalSearch { get; }
ReadOnly Property InIncrementalSearch As Boolean
    Get
property bool InIncrementalSearch {
    bool get ();
}
abstract InIncrementalSearch : bool with get

Property Value

Type: Boolean
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.SearchDialog Property

ISearchSearchDialog Property
When implemented by a class, gets or sets a dialog box allowing to search for the text or replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISearchDialog SearchDialog { get; set; }
Property SearchDialog As ISearchDialog
    Get
    Set
property ISearchDialog^ SearchDialog {
    ISearchDialog^ get ();
    void set (ISearchDialog^ value);
}
abstract SearchDialog : ISearchDialog with get, set

Property Value

Type: ISearchDialog
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.SearchGlobal Property

ISearchSearchGlobal Property
When implemented by a class, gets or sets a value indicating whether search should be global.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SearchGlobal { get; set; }
Property SearchGlobal As Boolean
    Get
    Set
property bool SearchGlobal {
    bool get ();
    void set (bool value);
}
abstract SearchGlobal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.SearchLen Property

ISearchSearchLen Property
When implemented by a class, represents length of the last found text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SearchLen { get; }
ReadOnly Property SearchLen As Integer
    Get
property int SearchLen {
    int get ();
}
abstract SearchLen : int with get

Property Value

Type: Int32
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.SearchOptions Property

ISearchSearchOptions Property
When implemented by a class, gets or sets a value that defines search and replace options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SearchOptions SearchOptions { get; set; }
Property SearchOptions As SearchOptions
    Get
    Set
property SearchOptions SearchOptions {
    SearchOptions get ();
    void set (SearchOptions value);
}
abstract SearchOptions : SearchOptions with get, set

Property Value

Type: SearchOptions
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.SearchPos Property

ISearchSearchPos Property
When implemented by a class, gets or sets a value that represents position of the last found text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point SearchPos { get; set; }
Property SearchPos As Point
    Get
    Set
property Point SearchPos {
    Point get ();
    void set (Point value);
}
abstract SearchPos : Point with get, set

Property Value

Type: Point
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch Events

ISearch Events

The ISearch type exposes the following members.

Events
 | Name | Description
Public event | TextChanged | When implemented by a class, occurs when the TextEditor text changes.
Top
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISearch.TextChanged Event

ISearchTextChanged Event
When implemented by a class, occurs when the TextEditor text changes.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler TextChanged
Event TextChanged As EventHandler
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISearch Interface
Alternet.Editor Namespace


ISelection Interface

ISelection Interface
Contains properties and methods used to manage selected part of the Edit control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISelection : IDisposable
Public Interface ISelection
    Inherits IDisposable
public interface class ISelection : IDisposable
type ISelection =
    interface
        interface IDisposable
    end

The ISelection type exposes the following members.

Methods
 | Name | Description
Public method | ApplyTextChanges | When implemented by a class, applies text changes to the text.
Public method | Assign | When implemented by a class, copies the contents from another ISelection object.
Public method | BeginUpdate | When implemented by a class, prevents the ISelection updating until the EndUpdate method is called.
Public method | CanCopy | When implemented by a class, indicates whether selected text can be copied to clipboard.
Public method | CanCut | When implemented by a class, indicates whether selected text can be cut to the clipboard.
Public method | CanDelete | When implemented by a class, indicates whether selected text can be deleted.
Public method | CanDrag | When implemented by a class, indicates whether control can drag selected text.
Public method | CanPaste | When implemented by a class, indicates whether control can paste some text from the clipboard.
Public method | Capitalize | When implemented by a class, changes first character of all words in selected text to upper-case and all another characters to lower-case.
Public method | ChangeBlock(StringEvent) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(StringEvent, Boolean, Boolean) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent, Boolean, Boolean) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | CharTransponse | When implemented by a class, transposes character under the caret with the next character.
Public method | Clear | When implemented by a class, makes selection empty, without deleting its content.
Public method | CollapseToDefinitions | When implemented by a class, collapses and expands some outline section to get a quick overall view of the Edit content.
Public method | CommentSelection | When implemented by a class, marks the selected text as a comment, using the correct comment syntax for the programming language.
Public method | Copy | When implemented by a class, copies SelectedText to the Clipboard.
Public method | Cut | When implemented by a class, cuts SelectedText to the Clipboard.
Public method | CutLine | When implemented by a class, cuts current line to the clipboard if no text is selected; otherwise cuts selected text.
Public method | Delete | When implemented by a class, deletes selected text from the control.
Public method | Delete(ExtendedSelectionScope) | When implemented by a class, deletes selected text from the control.
Public method | DeleteLeft | When implemented by a class, deletes one character left to the cursor.
Public method | DeleteLine | When implemented by a class, deletes current line if no text selected; otherwise deletes selected text.
Public method | DeleteRight | When implemented by a class, deletes one character right to the cursor.
Public method | DeleteWhiteSpace | When implemented by a class, removes all space and tab characters from selected text. If no text selected - removes space and tab characters from current line.
Public method | DeleteWordLeft | When implemented by a class, deletes one word left to the cursor.
Public method | DeleteWordRight | When implemented by a class, deletes one word right to the cursor.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | DragTo | When implemented by a class, moves or copies selected text to the specified position.
Public method | EndSelection | When implemented by a class, stops selection.
Public method | EndUpdate | When implemented by a class, re-enables selection updating turned off by calling BeginUpdate method.
Public method | GetSelectionForLine | When implemented by a class, sets left and right parameter to the first and last selected characters within specified line.
Public method | Indent | When implemented by a class, indents the selected text by one indentation level, inserting Tab or spaces to the beginning of the line.
Public method | InsertString | When implemented by a class, inserts given text to the control's content deleting selected text if needed.
Public method | Invalidate | When implemented by a class, invalidates a selection region of the editor control and causes a paint message to be sent to the editor control.
Public method | IsPosInSelection(Point) | When implemented by a class, indicates whether given position located within the selected region.
Public method | IsPosInSelection(Int32, Int32) | When implemented by a class, indicates whether given position located within the selected region.
Public method | IsValidSelectionPoint | When implemented by a class, indicates whether specified position located at the top-left or right-bottom corners of selection area.
Public method | LineTransponse | When implemented by a class, transposes line under the caret with the next line.
Public method | LowerCase | When implemented by a class, converts all selected characters to the lower-case.
Public method | Modified | When implemented by a class, responds on any modifications in the editor.
Public method | Move | When implemented by a class, moves or copies selected text to the specified position.
Public method | NewLine | When implemented by a class, inserts a line break at the current position of the control.
Public method | NewLineAbove | When implemented by a class, inserts a line break above the current position of the control.
Public method | NewLineBelow | When implemented by a class, inserts a line break below the current position of the control.
Public method | OnSelect | When implemented by a class, selects part of text source settings. Reserved for internal use.
Public method | OnSelectionChanged | When implemented by a class, raises SelectionChanged event.
Public method | Paste | When implemented by a class, pastes content of the Clipboard to the Edit control, replacing selected text if needed.
Public method | PositionChanged | When implemented by a class, responds on changing position in the editor.
Public method | ProcessEscape | When implemented by a class, processes escape pressure: method deselects selected text.
Public method | ProcessShiftTab | When implemented by a class, moves current position to the previous tab stop if the selected text is empty; otherwise unindents selected text.
Public method | ProcessTab | When implemented by a class, inserts new tab character or spaces if the selected text is empty; otherwise indents selected text.
Public method | ResetAllowedSelectionMode | When implemented by a class, resets the AllowedSelectionMode to the default value.
Public method | ResetBackColor | When implemented by a class, resets the BackColor to the default value.
Public method | ResetBorderColor | When implemented by a class, resets the BorderColor to the default value.
Public method | ResetForeColor | When implemented by a class, resets the ForeColor to the default value.
Public method | ResetInActiveBackColor | When implemented by a class, resets the InActiveBackColor to the default value.
Public method | ResetInActiveForeColor | When implemented by a class, resets the InActiveForeColor to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ScrollIfNeeded | When implemented by a class, scrolls to specified position if needed.
Public method | SelectAll | When implemented by a class, selects all lines in the control's content.
Public method | SelectCharLeft | When implemented by a class, increases selected text to one character at the left side of the selection region.
Public method | SelectCharLeft(SelectionType) | When implemented by a class, increases selected text to one character at the left side of the selection region and sets a given selection type.
Public method | SelectCharRight | When implemented by a class, increases selected text to one character at the right side of the selection region.
Public method | SelectCharRight(SelectionType) | When implemented by a class, increases selected text to one character at the right side of the selection region and sets a given selection type.
Public method | SelectedCount | When implemented by a class, returns amount of the lines being selected.
Public method | SelectedString | When implemented by a class, returns selected part of string at specified position.
Public method | SelectFileBegin | When implemented by a class, increases selected text to beginning of the control's content.
Public method | SelectFileBegin(SelectionType) | When implemented by a class, increases selected text to beginning of the control's content and sets a given selection type.
Public method | SelectFileEnd | When implemented by a class, increases selected text to end of the control's content.
Public method | SelectFileEnd(SelectionType) | When implemented by a class, increases selected text to end of the control's content and sets a given selection type.
Public method | SelectionToScreen | When implemented by a class, represents selection region in a screen coordinates.
Public method | SelectionToTextPoint | When implemented by a class, converts given selection coordinate to the text coordinate.
Public method | SelectLine | When implemented by a class, selects entire line at the current position in the control.
Public method | SelectLineBegin | When implemented by a class, selects from current position to the beginning of current line in the control.
Public method | SelectLineBegin(SelectionType) | When implemented by a class, selects from current position to the beginning of current line in the control and sets a given selection type.
Public method | SelectLineDown | When implemented by a class, increases selected text to the following line in the control.
Public method | SelectLineDown(SelectionType) | When implemented by a class, increases selected text to the following line in the control and sets a given selection type.
Public method | SelectLineEnd | When implemented by a class, selects from current position to the end of current line in the control.
Public method | SelectLineEnd(SelectionType) | When implemented by a class, selects from current position to the end of current line in the control and sets a given selection type.
Public method | SelectLineOnTrippleClick | When implemented by a class, selects entire line at the current position in the control as a result of triple click.
Public method | SelectLineUp | When implemented by a class, increases selected text to the preceding line in the control.
Public method | SelectLineUp(SelectionType) | When implemented by a class, increases selected text to the preceding line in the control and sets a given selection type.
Public method | SelectPageDown | When implemented by a class, increases selected text to the one page down in the control.
Public method | SelectPageDown(SelectionType) | When implemented by a class, increases selected text to the one page down in the control and sets a given selection type.
Public method | SelectPageUp | When implemented by a class, increases selected text to the one page up in the control.
Public method | SelectPageUp(SelectionType) | When implemented by a class, increases selected text to the one page up in the control and sets a given selection type.
Public method | SelectScreenBottom | When implemented by a class, increases selected text to the end of screen.
Public method | SelectScreenBottom(SelectionType) | When implemented by a class, increases selected text to the end of the screen and sets a given selection type.
Public method | SelectScreenTop | When implemented by a class, increases selected text to the begin of screen.
Public method | SelectScreenTop(SelectionType) | When implemented by a class, increases selected text to the begin of the screen and sets a given selection type.
Public method | SelectToBrace | When implemented by a class, increases selected text to the next open or closing brace.
Public method | SelectToCloseBrace | When implemented by a class, increases selected text to the next closing brace.
Public method | SelectToOpenBrace | When implemented by a class, increases selected text to the prev open brace.
Public method | SelectWord | When implemented by a class, selects word at the current position in the control.
Public method | SelectWordLeft | When implemented by a class, increases selected text to the word located at the left side of the current position in the control.
Public method | SelectWordLeft(SelectionType) | When implemented by a class, increases selected text to the word located at the left side of the current position in the control and sets a given selection type.
Public method | SelectWordRight | When implemented by a class, increases selected text to the word located at the right side of the current position in the control.
Public method | SelectWordRight(SelectionType) | When implemented by a class, increases selected text to the word located at the right side of the current position in the control and sets a given selection type.
Public method | SetSelection(SelectionType, Rectangle) | When implemented by a class, sets new selection region with specified selection type.
Public method | SetSelection(SelectionType, Point, Point) | When implemented by a class, sets new selection region with specified selection type.
Public method | SmartFormat | When implemented by a class, formats selected text using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormat(Char) | When implemented by a class, formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies Character being typed
Public method | SmartFormat(Int32) | When implemented by a class, formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormatBlock | When implemented by a class, formats current syntax block using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormatDocument | When implemented by a class, formats entire document using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartIndent | When implemented by a class, positions the cursor to the line indentation level, obtained from parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent option when user presses Enter.
Public method | SmartIndent(Char) | When implemented by a class, formats given current line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies character being typed
Public method | StartSelection | When implemented by a class, forces selection start.
Public method | SwapAnchor | When implemented by a class, change current position from beginning of selection rectangle to the end of selection rectangle or vice versa.
Public method | Tabify | When implemented by a class, converts spaces to tabs in the current string within the selected area according to tab settings.
Public method | TextToSelectionPoint | When implemented by a class, converts given text coordinate to the selection coordinate.
Public method | ToggleOutlining | When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOverWrite | When implemented by a class, toggles the control's overwrite mode.
Public method | UncommentSelection | When implemented by a class, removes the comment syntax from the selected text.
Public method | UnIndent | When implemented by a class, unindents the selected text by one indentation level, deleting Tab or spaces from the beginning of the line.
Public method | UnTabify | When implemented by a class, converts tabs to spaces in the current string within the selected area according to tab settings.
Public method | UpdateSelection | When implemented by a class, invalidates selected region.
Public method | UpdateSelRange | When implemented by a class, updates selection start and end to the specified position.
Public method | UpdateSelStart(Boolean) | When implemented by a class, updates selection start to the specified position.
Public method | UpdateSelStart(Point) | When implemented by a class, updates selection start to the specified position.
Public method | UpperCase | When implemented by a class, converts all selected characters to the upper-case.
Public method | WordTransponse | When implemented by a class, transposes word under the caret with the next word.
Top
Properties
 | Name | Description
Public property | AllowedSelectionMode | When implemented by a class, gets or sets types of selection allowed to Edit control content.
Public property | BackColor | When implemented by a class, gets or sets a background color of the SelectedText when owner control has input focus.
Public property | BorderColor | When implemented by a class, gets or sets a color of the selection border.
Public property | ForeColor | When implemented by a class, gets or sets a foreground color of the SelectedText when owner control has input focus.
Public property | InActiveBackColor | When implemented by a class, gets or sets a background color of the SelectedText when owner control does not have input focus.
Public property | InActiveForeColor | When implemented by a class, gets or sets a foreground color of the SelectedText when owner control does not have input focus.
Public property | IsEmpty | When implemented by a class, indicates whether nothing is selected.
Public property | Options | When implemented by a class, gets or sets options determining behaviour or the ISelection.
Public property | SelectedColorData | When implemented by a class, gets strings that corresponds to selected part of the control's text content.
Public property | SelectedText | When implemented by a class, gets or sets strings that corresponds to selected part of the control's text content.
Public property | SelectionLength | When implemented by a class, gets or sets length of the SelectedText.
Public property | SelectionRect | When implemented by a class, gets or sets rectangular area indicating selected text of the control.
Public property | SelectionStart | When implemented by a class, gets or sets the position of the first selected character while text considered as a single string.
Public property | SelectionState | When implemented by a class, gets or sets a value indicates state of the selected text.
Public property | SelectionType | When implemented by a class, gets or sets type of current selection.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
Events
 | Name | Description
Public event | SelectionChanged | When implemented by a class, occurs when selection bounds are changed.
Top
See Also

Reference

Alternet.Editor Namespace


ISelection Methods

ISelection Methods

The ISelection type exposes the following members.

Methods
 | Name | Description
Public method | ApplyTextChanges | When implemented by a class, applies text changes to the text.
Public method | Assign | When implemented by a class, copies the contents from another ISelection object.
Public method | BeginUpdate | When implemented by a class, prevents the ISelection updating until the EndUpdate method is called.
Public method | CanCopy | When implemented by a class, indicates whether selected text can be copied to clipboard.
Public method | CanCut | When implemented by a class, indicates whether selected text can be cut to the clipboard.
Public method | CanDelete | When implemented by a class, indicates whether selected text can be deleted.
Public method | CanDrag | When implemented by a class, indicates whether control can drag selected text.
Public method | CanPaste | When implemented by a class, indicates whether control can paste some text from the clipboard.
Public method | Capitalize | When implemented by a class, changes first character of all words in selected text to upper-case and all another characters to lower-case.
Public method | ChangeBlock(StringEvent) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(StringEvent, Boolean, Boolean) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent, Boolean, Boolean) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | CharTransponse | When implemented by a class, transposes character under the caret with the next character.
Public method | Clear | When implemented by a class, makes selection empty, without deleting its content.
Public method | CollapseToDefinitions | When implemented by a class, collapses and expands some outline section to get a quick overall view of the Edit content.
Public method | CommentSelection | When implemented by a class, marks the selected text as a comment, using the correct comment syntax for the programming language.
Public method | Copy | When implemented by a class, copies SelectedText to the Clipboard.
Public method | Cut | When implemented by a class, cuts SelectedText to the Clipboard.
Public method | CutLine | When implemented by a class, cuts current line to the clipboard if no text is selected; otherwise cuts selected text.
Public method | Delete | When implemented by a class, deletes selected text from the control.
Public method | Delete(ExtendedSelectionScope) | When implemented by a class, deletes selected text from the control.
Public method | DeleteLeft | When implemented by a class, deletes one character left to the cursor.
Public method | DeleteLine | When implemented by a class, deletes current line if no text selected; otherwise deletes selected text.
Public method | DeleteRight | When implemented by a class, deletes one character right to the cursor.
Public method | DeleteWhiteSpace | When implemented by a class, removes all space and tab characters from selected text. If no text selected - removes space and tab characters from current line.
Public method | DeleteWordLeft | When implemented by a class, deletes one word left to the cursor.
Public method | DeleteWordRight | When implemented by a class, deletes one word right to the cursor.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | DragTo | When implemented by a class, moves or copies selected text to the specified position.
Public method | EndSelection | When implemented by a class, stops selection.
Public method | EndUpdate | When implemented by a class, re-enables selection updating turned off by calling BeginUpdate method.
Public method | GetSelectionForLine | When implemented by a class, sets left and right parameter to the first and last selected characters within specified line.
Public method | Indent | When implemented by a class, indents the selected text by one indentation level, inserting Tab or spaces to the beginning of the line.
Public method | InsertString | When implemented by a class, inserts given text to the control's content deleting selected text if needed.
Public method | Invalidate | When implemented by a class, invalidates a selection region of the editor control and causes a paint message to be sent to the editor control.
Public method | IsPosInSelection(Point) | When implemented by a class, indicates whether given position located within the selected region.
Public method | IsPosInSelection(Int32, Int32) | When implemented by a class, indicates whether given position located within the selected region.
Public method | IsValidSelectionPoint | When implemented by a class, indicates whether specified position located at the top-left or right-bottom corners of selection area.
Public method | LineTransponse | When implemented by a class, transposes line under the caret with the next line.
Public method | LowerCase | When implemented by a class, converts all selected characters to the lower-case.
Public method | Modified | When implemented by a class, responds on any modifications in the editor.
Public method | Move | When implemented by a class, moves or copies selected text to the specified position.
Public method | NewLine | When implemented by a class, inserts a line break at the current position of the control.
Public method | NewLineAbove | When implemented by a class, inserts a line break above the current position of the control.
Public method | NewLineBelow | When implemented by a class, inserts a line break below the current position of the control.
Public method | OnSelect | When implemented by a class, selects part of text source settings. Reserved for internal use.
Public method | OnSelectionChanged | When implemented by a class, raises SelectionChanged event.
Public method | Paste | When implemented by a class, pastes content of the Clipboard to the Edit control, replacing selected text if needed.
Public method | PositionChanged | When implemented by a class, responds on changing position in the editor.
Public method | ProcessEscape | When implemented by a class, processes escape pressure: method deselects selected text.
Public method | ProcessShiftTab | When implemented by a class, moves current position to the previous tab stop if the selected text is empty; otherwise unindents selected text.
Public method | ProcessTab | When implemented by a class, inserts new tab character or spaces if the selected text is empty; otherwise indents selected text.
Public method | ResetAllowedSelectionMode | When implemented by a class, resets the AllowedSelectionMode to the default value.
Public method | ResetBackColor | When implemented by a class, resets the BackColor to the default value.
Public method | ResetBorderColor | When implemented by a class, resets the BorderColor to the default value.
Public method | ResetForeColor | When implemented by a class, resets the ForeColor to the default value.
Public method | ResetInActiveBackColor | When implemented by a class, resets the InActiveBackColor to the default value.
Public method | ResetInActiveForeColor | When implemented by a class, resets the InActiveForeColor to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ScrollIfNeeded | When implemented by a class, scrolls to specified position if needed.
Public method | SelectAll | When implemented by a class, selects all lines in the control's content.
Public method | SelectCharLeft | When implemented by a class, increases selected text to one character at the left side of the selection region.
Public method | SelectCharLeft(SelectionType) | When implemented by a class, increases selected text to one character at the left side of the selection region and sets a given selection type.
Public method | SelectCharRight | When implemented by a class, increases selected text to one character at the right side of the selection region.
Public method | SelectCharRight(SelectionType) | When implemented by a class, increases selected text to one character at the right side of the selection region and sets a given selection type.
Public method | SelectedCount | When implemented by a class, returns amount of the lines being selected.
Public method | SelectedString | When implemented by a class, returns selected part of string at specified position.
Public method | SelectFileBegin | When implemented by a class, increases selected text to beginning of the control's content.
Public method | SelectFileBegin(SelectionType) | When implemented by a class, increases selected text to beginning of the control's content and sets a given selection type.
Public method | SelectFileEnd | When implemented by a class, increases selected text to end of the control's content.
Public method | SelectFileEnd(SelectionType) | When implemented by a class, increases selected text to end of the control's content and sets a given selection type.
Public method | SelectionToScreen | When implemented by a class, represents selection region in a screen coordinates.
Public method | SelectionToTextPoint | When implemented by a class, converts given selection coordinate to the text coordinate.
Public method | SelectLine | When implemented by a class, selects entire line at the current position in the control.
Public method | SelectLineBegin | When implemented by a class, selects from current position to the beginning of current line in the control.
Public method | SelectLineBegin(SelectionType) | When implemented by a class, selects from current position to the beginning of current line in the control and sets a given selection type.
Public method | SelectLineDown | When implemented by a class, increases selected text to the following line in the control.
Public method | SelectLineDown(SelectionType) | When implemented by a class, increases selected text to the following line in the control and sets a given selection type.
Public method | SelectLineEnd | When implemented by a class, selects from current position to the end of current line in the control.
Public method | SelectLineEnd(SelectionType) | When implemented by a class, selects from current position to the end of current line in the control and sets a given selection type.
Public method | SelectLineOnTrippleClick | When implemented by a class, selects entire line at the current position in the control as a result of triple click.
Public method | SelectLineUp | When implemented by a class, increases selected text to the preceding line in the control.
Public method | SelectLineUp(SelectionType) | When implemented by a class, increases selected text to the preceding line in the control and sets a given selection type.
Public method | SelectPageDown | When implemented by a class, increases selected text to the one page down in the control.
Public method | SelectPageDown(SelectionType) | When implemented by a class, increases selected text to the one page down in the control and sets a given selection type.
Public method | SelectPageUp | When implemented by a class, increases selected text to the one page up in the control.
Public method | SelectPageUp(SelectionType) | When implemented by a class, increases selected text to the one page up in the control and sets a given selection type.
Public method | SelectScreenBottom | When implemented by a class, increases selected text to the end of screen.
Public method | SelectScreenBottom(SelectionType) | When implemented by a class, increases selected text to the end of the screen and sets a given selection type.
Public method | SelectScreenTop | When implemented by a class, increases selected text to the begin of screen.
Public method | SelectScreenTop(SelectionType) | When implemented by a class, increases selected text to the begin of the screen and sets a given selection type.
Public method | SelectToBrace | When implemented by a class, increases selected text to the next open or closing brace.
Public method | SelectToCloseBrace | When implemented by a class, increases selected text to the next closing brace.
Public method | SelectToOpenBrace | When implemented by a class, increases selected text to the prev open brace.
Public method | SelectWord | When implemented by a class, selects word at the current position in the control.
Public method | SelectWordLeft | When implemented by a class, increases selected text to the word located at the left side of the current position in the control.
Public method | SelectWordLeft(SelectionType) | When implemented by a class, increases selected text to the word located at the left side of the current position in the control and sets a given selection type.
Public method | SelectWordRight | When implemented by a class, increases selected text to the word located at the right side of the current position in the control.
Public method | SelectWordRight(SelectionType) | When implemented by a class, increases selected text to the word located at the right side of the current position in the control and sets a given selection type.
Public method | SetSelection(SelectionType, Rectangle) | When implemented by a class, sets new selection region with specified selection type.
Public method | SetSelection(SelectionType, Point, Point) | When implemented by a class, sets new selection region with specified selection type.
Public method | SmartFormat | When implemented by a class, formats selected text using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormat(Char) | When implemented by a class, formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies Character being typed
Public method | SmartFormat(Int32) | When implemented by a class, formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormatBlock | When implemented by a class, formats current syntax block using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormatDocument | When implemented by a class, formats entire document using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartIndent | When implemented by a class, positions the cursor to the line indentation level, obtained from parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent option when user presses Enter.
Public method | SmartIndent(Char) | When implemented by a class, formats given current line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies character being typed
Public method | StartSelection | When implemented by a class, forces selection start.
Public method | SwapAnchor | When implemented by a class, change current position from beginning of selection rectangle to the end of selection rectangle or vice versa.
Public method | Tabify | When implemented by a class, converts spaces to tabs in the current string within the selected area according to tab settings.
Public method | TextToSelectionPoint | When implemented by a class, converts given text coordinate to the selection coordinate.
Public method | ToggleOutlining | When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOverWrite | When implemented by a class, toggles the control's overwrite mode.
Public method | UncommentSelection | When implemented by a class, removes the comment syntax from the selected text.
Public method | UnIndent | When implemented by a class, unindents the selected text by one indentation level, deleting Tab or spaces from the beginning of the line.
Public method | UnTabify | When implemented by a class, converts tabs to spaces in the current string within the selected area according to tab settings.
Public method | UpdateSelection | When implemented by a class, invalidates selected region.
Public method | UpdateSelRange | When implemented by a class, updates selection start and end to the specified position.
Public method | UpdateSelStart(Boolean) | When implemented by a class, updates selection start to the specified position.
Public method | UpdateSelStart(Point) | When implemented by a class, updates selection start to the specified position.
Public method | UpperCase | When implemented by a class, converts all selected characters to the upper-case.
Public method | WordTransponse | When implemented by a class, transposes word under the caret with the next word.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ApplyTextChanges Method

ISelectionApplyTextChanges Method
When implemented by a class, applies text changes to the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyTextChanges(
    IList<ITextUndo> textChanges,
    bool format
)
Sub ApplyTextChanges (
    textChanges As IList(Of ITextUndo),
    format As Boolean
)
void ApplyTextChanges(
    IList<ITextUndo^>^ textChanges,
    bool format
)
abstract ApplyTextChanges :
        textChanges : IList<ITextUndo> *
        format : bool -> unit

Parameters

textChanges
Type: System.Collections.GenericIListITextUndo
List of text changes
format
Type: SystemBoolean
Specifies if inserted block needs to be formatted.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Assign Method

ISelectionAssign Method
When implemented by a class, copies the contents from another ISelection object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ISelection source
)
Sub Assign (
    source As ISelection
)
void Assign(
    ISelection^ source
)
abstract Assign :
        source : ISelection -> unit

Parameters

source
Type: Alternet.EditorISelection
Specifies ISelection to assign.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.BeginUpdate Method

ISelectionBeginUpdate Method
When implemented by a class, prevents the ISelection updating until the EndUpdate method is called.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int BeginUpdate()
Function BeginUpdate As Integer
int BeginUpdate()
abstract BeginUpdate : unit -> int

Return Value

Type: Int32
Number of update locks.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace
SelectionEndUpdate


ISelection.CanCopy Method

ISelectionCanCopy Method
When implemented by a class, indicates whether selected text can be copied to clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCopy()
Function CanCopy As Boolean
bool CanCopy()
abstract CanCopy : unit -> bool

Return Value

Type: Boolean
True if the selection is not empty; otherwise false.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.CanCut Method

ISelectionCanCut Method
When implemented by a class, indicates whether selected text can be cut to the clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCut()
Function CanCut As Boolean
bool CanCut()
abstract CanCut : unit -> bool

Return Value

Type: Boolean
True if the selection can be cut; otherwise false.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.CanDelete Method

ISelectionCanDelete Method
When implemented by a class, indicates whether selected text can be deleted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanDelete()
Function CanDelete As Boolean
bool CanDelete()
abstract CanDelete : unit -> bool

Return Value

Type: Boolean
True if the selection can be deleted; otherwise false.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.CanDrag Method

ISelectionCanDrag Method
When implemented by a class, indicates whether control can drag selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanDrag(
    Point position
)
Function CanDrag (
    position As Point
) As Boolean
bool CanDrag(
    Point position
)
abstract CanDrag :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies destination position of drag operation.

Return Value

Type: Boolean
True if the control can drag selected text; otherwise false.
Remarks
Control must not be in the read-only state to allow dragging selected text.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.CanPaste Method

ISelectionCanPaste Method
When implemented by a class, indicates whether control can paste some text from the clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanPaste()
Function CanPaste As Boolean
bool CanPaste()
abstract CanPaste : unit -> bool

Return Value

Type: Boolean
True if the Clipboard has some text or unicode text.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Capitalize Method

ISelectionCapitalize Method
When implemented by a class, changes first character of all words in selected text to upper-case and all another characters to lower-case.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Capitalize()
Sub Capitalize
void Capitalize()
abstract Capitalize : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ChangeBlock Method

ISelectionChangeBlock Method
Overload List
 | Name | Description
Public method | ChangeBlock(StringEvent) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(StringEvent, Boolean, Boolean) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent, Boolean, Boolean) | When implemented by a class, changes selected text by applying specified event to every line in the selected text.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ChangeBlock Method (StringEvent)

ISelectionChangeBlock Method (StringEvent)
When implemented by a class, changes selected text by applying specified event to every line in the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ChangeBlock(
    StringEvent action
)
Sub ChangeBlock (
    action As StringEvent
)
void ChangeBlock(
    StringEvent^ action
)
abstract ChangeBlock :
        action : StringEvent -> unit

Parameters

action
Type: Alternet.EditorStringEvent
Specifies action to execute.
See Also

Reference

ISelection Interface
ChangeBlock Overload
Alternet.Editor Namespace


ISelection.ChangeBlock Method (TextUndoEvent)

ISelectionChangeBlock Method (TextUndoEvent)
When implemented by a class, changes selected text by applying specified event to every line in the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ChangeBlock(
    TextUndoEvent action
)
Sub ChangeBlock (
    action As TextUndoEvent
)
void ChangeBlock(
    TextUndoEvent^ action
)
abstract ChangeBlock :
        action : TextUndoEvent -> unit

Parameters

action
Type: Alternet.EditorTextUndoEvent
Specifies action to execute.
See Also

Reference

ISelection Interface
ChangeBlock Overload
Alternet.Editor Namespace


ISelection.ChangeBlock Method (StringEvent, Boolean, Boolean)

ISelectionChangeBlock Method (StringEvent, Boolean, Boolean)
When implemented by a class, changes selected text by applying specified event to every line in the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ChangeBlock(
    StringEvent action,
    bool changeIfEmpty,
    bool extendFirstLine
)
Sub ChangeBlock (
    action As StringEvent,
    changeIfEmpty As Boolean,
    extendFirstLine As Boolean
)
void ChangeBlock(
    StringEvent^ action,
    bool changeIfEmpty,
    bool extendFirstLine
)
abstract ChangeBlock :
        action : StringEvent *
        changeIfEmpty : bool *
        extendFirstLine : bool -> unit

Parameters

action
Type: Alternet.EditorStringEvent
Specifies action to execute.
changeIfEmpty
Type: SystemBoolean
Indicates that action should be performed for current line if selection is empty.
extendFirstLine
Type: SystemBoolean
Specifies that action should applied to whole lines in the selected region rather than to the selected portion of the line.
See Also

Reference

ISelection Interface
ChangeBlock Overload
Alternet.Editor Namespace


ISelection.ChangeBlock Method (TextUndoEvent, Boolean, Boolean)

ISelectionChangeBlock Method (TextUndoEvent, Boolean, Boolean)
When implemented by a class, changes selected text by applying specified event to every line in the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ChangeBlock(
    TextUndoEvent action,
    bool changeIfEmpty,
    bool extendFirstLine
)
Sub ChangeBlock (
    action As TextUndoEvent,
    changeIfEmpty As Boolean,
    extendFirstLine As Boolean
)
void ChangeBlock(
    TextUndoEvent^ action,
    bool changeIfEmpty,
    bool extendFirstLine
)
abstract ChangeBlock :
        action : TextUndoEvent *
        changeIfEmpty : bool *
        extendFirstLine : bool -> unit

Parameters

action
Type: Alternet.EditorTextUndoEvent
Specifies action to execute.
changeIfEmpty
Type: SystemBoolean
Indicates that action should be performed for current line if selection is empty.
extendFirstLine
Type: SystemBoolean
Specifies that action should applied to whole lines in the selected region rather than to the selected portion of the line.
See Also

Reference

ISelection Interface
ChangeBlock Overload
Alternet.Editor Namespace


ISelection.CharTransponse Method

ISelectionCharTransponse Method
When implemented by a class, transposes character under the caret with the next character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CharTransponse()
Sub CharTransponse
void CharTransponse()
abstract CharTransponse : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Clear Method

ISelectionClear Method
When implemented by a class, makes selection empty, without deleting its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.CollapseToDefinitions Method

ISelectionCollapseToDefinitions Method
When implemented by a class, collapses and expands some outline section to get a quick overall view of the Edit content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CollapseToDefinitions()
Sub CollapseToDefinitions
void CollapseToDefinitions()
abstract CollapseToDefinitions : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.CommentSelection Method

ISelectionCommentSelection Method
When implemented by a class, marks the selected text as a comment, using the correct comment syntax for the programming language.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CommentSelection()
Sub CommentSelection
void CommentSelection()
abstract CommentSelection : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Copy Method

ISelectionCopy Method
When implemented by a class, copies SelectedText to the Clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Copy()
Sub Copy
void Copy()
abstract Copy : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Cut Method

ISelectionCut Method
When implemented by a class, cuts SelectedText to the Clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Cut()
Sub Cut
void Cut()
abstract Cut : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.CutLine Method

ISelectionCutLine Method
When implemented by a class, cuts current line to the clipboard if no text is selected; otherwise cuts selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CutLine()
Sub CutLine
void CutLine()
abstract CutLine : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Delete Method

ISelectionDelete Method
Overload List
 | Name | Description
Public method | Delete | When implemented by a class, deletes selected text from the control.
Public method | Delete(ExtendedSelectionScope) | When implemented by a class, deletes selected text from the control.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Delete Method

ISelectionDelete Method
When implemented by a class, deletes selected text from the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Delete()
Function Delete As Boolean
bool Delete()
abstract Delete : unit -> bool

Return Value

Type: Boolean
True if successful.
See Also

Reference

ISelection Interface
Delete Overload
Alternet.Editor Namespace


ISelection.Delete Method (ExtendedSelectionScope)

ISelectionDelete Method (ExtendedSelectionScope)
When implemented by a class, deletes selected text from the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Delete(
    ExtendedSelectionScope scope
)
Function Delete (
    scope As ExtendedSelectionScope
) As Boolean
bool Delete(
    ExtendedSelectionScope scope
)
abstract Delete :
        scope : ExtendedSelectionScope -> bool

Parameters

scope
Type: Alternet.EditorExtendedSelectionScope
Specifies extended selection scope for null-width blocks

Return Value

Type: Boolean
True if successful.
See Also

Reference

ISelection Interface
Delete Overload
Alternet.Editor Namespace


ISelection.DeleteLeft Method

ISelectionDeleteLeft Method
When implemented by a class, deletes one character left to the cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteLeft()
Sub DeleteLeft
void DeleteLeft()
abstract DeleteLeft : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.DeleteLine Method

ISelectionDeleteLine Method
When implemented by a class, deletes current line if no text selected; otherwise deletes selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteLine()
Sub DeleteLine
void DeleteLine()
abstract DeleteLine : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.DeleteRight Method

ISelectionDeleteRight Method
When implemented by a class, deletes one character right to the cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteRight()
Sub DeleteRight
void DeleteRight()
abstract DeleteRight : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.DeleteWhiteSpace Method

ISelectionDeleteWhiteSpace Method
When implemented by a class, removes all space and tab characters from selected text. If no text selected - removes space and tab characters from current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteWhiteSpace()
Sub DeleteWhiteSpace
void DeleteWhiteSpace()
abstract DeleteWhiteSpace : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.DeleteWordLeft Method

ISelectionDeleteWordLeft Method
When implemented by a class, deletes one word left to the cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteWordLeft()
Sub DeleteWordLeft
void DeleteWordLeft()
abstract DeleteWordLeft : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.DeleteWordRight Method

ISelectionDeleteWordRight Method
When implemented by a class, deletes one word right to the cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeleteWordRight()
Sub DeleteWordRight
void DeleteWordRight()
abstract DeleteWordRight : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.DragTo Method

ISelectionDragTo Method
When implemented by a class, moves or copies selected text to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DragTo(
    Point position,
    bool deleteOrigin
)
Sub DragTo (
    position As Point,
    deleteOrigin As Boolean
)
void DragTo(
    Point position,
    bool deleteOrigin
)
abstract DragTo :
        position : Point *
        deleteOrigin : bool -> unit

Parameters

position
Type: System.DrawingPoint
Position to move or copy.
deleteOrigin
Type: SystemBoolean
Indicates whether method should move or copy selected text.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.EndSelection Method

ISelectionEndSelection Method
When implemented by a class, stops selection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EndSelection()
Sub EndSelection
void EndSelection()
abstract EndSelection : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.EndUpdate Method

ISelectionEndUpdate Method
When implemented by a class, re-enables selection updating turned off by calling BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int EndUpdate()
Function EndUpdate As Integer
int EndUpdate()
abstract EndUpdate : unit -> int

Return Value

Type: Int32
Number of update locks.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace
SelectionBeginUpdate


ISelection.GetSelectionForLine Method

ISelectionGetSelectionForLine Method
When implemented by a class, sets left and right parameter to the first and last selected characters within specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetSelectionForLine(
    int index,
    out int left,
    out int right
)
Function GetSelectionForLine (
    index As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer
) As Boolean
bool GetSelectionForLine(
    int index,
    [OutAttribute] int% left,
    [OutAttribute] int% right
)
abstract GetSelectionForLine :
        index : int *
        left : int byref *
        right : int byref -> bool

Parameters

index
Type: SystemInt32
Index of line within Edit control content.
left
Type: SystemInt32
Receives index of the first selected character.
right
Type: SystemInt32
Receives index of the last selected character.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Indent Method

ISelectionIndent Method
When implemented by a class, indents the selected text by one indentation level, inserting Tab or spaces to the beginning of the line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Indent()
Sub Indent
void Indent()
abstract Indent : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.InsertString Method

ISelectionInsertString Method
When implemented by a class, inserts given text to the control's content deleting selected text if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertString(
    string s
)
Sub InsertString (
    s As String
)
void InsertString(
    String^ s
)
abstract InsertString :
        s : string -> unit

Parameters

s
Type: SystemString
Text to insert.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Invalidate Method

ISelectionInvalidate Method
When implemented by a class, invalidates a selection region of the editor control and causes a paint message to be sent to the editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Invalidate()
Sub Invalidate
void Invalidate()
abstract Invalidate : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.IsPosInSelection Method

ISelectionIsPosInSelection Method
Overload List
 | Name | Description
Public method | IsPosInSelection(Point) | When implemented by a class, indicates whether given position located within the selected region.
Public method | IsPosInSelection(Int32, Int32) | When implemented by a class, indicates whether given position located within the selected region.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.IsPosInSelection Method (Point)

ISelectionIsPosInSelection Method (Point)
When implemented by a class, indicates whether given position located within the selected region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPosInSelection(
    Point position
)
Function IsPosInSelection (
    position As Point
) As Boolean
bool IsPosInSelection(
    Point position
)
abstract IsPosInSelection :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.

Return Value

Type: Boolean
True if position in selected region; otherwise false.
See Also

Reference

ISelection Interface
IsPosInSelection Overload
Alternet.Editor Namespace


ISelection.IsPosInSelection Method (Int32, Int32)

ISelectionIsPosInSelection Method (Int32, Int32)
When implemented by a class, indicates whether given position located within the selected region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPosInSelection(
    int x,
    int y
)
Function IsPosInSelection (
    x As Integer,
    y As Integer
) As Boolean
bool IsPosInSelection(
    int x,
    int y
)
abstract IsPosInSelection :
        x : int *
        y : int -> bool

Parameters

x
Type: SystemInt32
Horizontal coordinate of the position to check.
y
Type: SystemInt32
Vertical coordinate of the position to check.

Return Value

Type: Boolean
True if position in selected region; otherwise false.
See Also

Reference

ISelection Interface
IsPosInSelection Overload
Alternet.Editor Namespace


ISelection.IsValidSelectionPoint Method

ISelectionIsValidSelectionPoint Method
When implemented by a class, indicates whether specified position located at the top-left or right-bottom corners of selection area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsValidSelectionPoint(
    Point position
)
Function IsValidSelectionPoint (
    position As Point
) As Boolean
bool IsValidSelectionPoint(
    Point position
)
abstract IsValidSelectionPoint :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.

Return Value

Type: Boolean
True if specified position valid; otherwise false.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.LineTransponse Method

ISelectionLineTransponse Method
When implemented by a class, transposes line under the caret with the next line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LineTransponse()
Sub LineTransponse
void LineTransponse()
abstract LineTransponse : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.LowerCase Method

ISelectionLowerCase Method
When implemented by a class, converts all selected characters to the lower-case.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LowerCase()
Sub LowerCase
void LowerCase()
abstract LowerCase : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Modified Method

ISelectionModified Method
When implemented by a class, responds on any modifications in the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Modified()
Sub Modified
void Modified()
abstract Modified : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Move Method

ISelectionMove Method
When implemented by a class, moves or copies selected text to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Move(
    Point position,
    bool deleteOrigin
)
Function Move (
    position As Point,
    deleteOrigin As Boolean
) As Boolean
bool Move(
    Point position,
    bool deleteOrigin
)
abstract Move :
        position : Point *
        deleteOrigin : bool -> bool

Parameters

position
Type: System.DrawingPoint
Position to move or copy.
deleteOrigin
Type: SystemBoolean
Indicates whether method should move or copy selected text.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.NewLine Method

ISelectionNewLine Method
When implemented by a class, inserts a line break at the current position of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void NewLine()
Sub NewLine
void NewLine()
abstract NewLine : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.NewLineAbove Method

ISelectionNewLineAbove Method
When implemented by a class, inserts a line break above the current position of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void NewLineAbove()
Sub NewLineAbove
void NewLineAbove()
abstract NewLineAbove : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.NewLineBelow Method

ISelectionNewLineBelow Method
When implemented by a class, inserts a line break below the current position of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void NewLineBelow()
Sub NewLineBelow
void NewLineBelow()
abstract NewLineBelow : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.OnSelect Method

ISelectionOnSelect Method
When implemented by a class, selects part of text source settings. Reserved for internal use.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnSelect(
    Object source,
    EventArgs e
)
Sub OnSelect (
    source As Object,
    e As EventArgs
)
void OnSelect(
    Object^ source,
    EventArgs^ e
)
abstract OnSelect :
        source : Object *
        e : EventArgs -> unit

Parameters

source
Type: SystemObject
The source of the selection.
e
Type: SystemEventArgs
An EventArgs that contains the data.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.OnSelectionChanged Method

ISelectionOnSelectionChanged Method
When implemented by a class, raises SelectionChanged event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnSelectionChanged()
Sub OnSelectionChanged
void OnSelectionChanged()
abstract OnSelectionChanged : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Paste Method

ISelectionPaste Method
When implemented by a class, pastes content of the Clipboard to the Edit control, replacing selected text if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Paste()
Sub Paste
void Paste()
abstract Paste : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.PositionChanged Method

ISelectionPositionChanged Method
When implemented by a class, responds on changing position in the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
X-part of position to change.
y
Type: SystemInt32
Y-part of position to change.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ProcessEscape Method

ISelectionProcessEscape Method
When implemented by a class, processes escape pressure: method deselects selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ProcessEscape()
Sub ProcessEscape
void ProcessEscape()
abstract ProcessEscape : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ProcessShiftTab Method

ISelectionProcessShiftTab Method
When implemented by a class, moves current position to the previous tab stop if the selected text is empty; otherwise unindents selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ProcessShiftTab()
Sub ProcessShiftTab
void ProcessShiftTab()
abstract ProcessShiftTab : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ProcessTab Method

ISelectionProcessTab Method
When implemented by a class, inserts new tab character or spaces if the selected text is empty; otherwise indents selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ProcessTab()
Sub ProcessTab
void ProcessTab()
abstract ProcessTab : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ResetAllowedSelectionMode Method

ISelectionResetAllowedSelectionMode Method
When implemented by a class, resets the AllowedSelectionMode to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAllowedSelectionMode()
Sub ResetAllowedSelectionMode
void ResetAllowedSelectionMode()
abstract ResetAllowedSelectionMode : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ResetBackColor Method

ISelectionResetBackColor Method
When implemented by a class, resets the BackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBackColor()
Sub ResetBackColor
void ResetBackColor()
abstract ResetBackColor : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ResetBorderColor Method

ISelectionResetBorderColor Method
When implemented by a class, resets the BorderColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBorderColor()
Sub ResetBorderColor
void ResetBorderColor()
abstract ResetBorderColor : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ResetForeColor Method

ISelectionResetForeColor Method
When implemented by a class, resets the ForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetForeColor()
Sub ResetForeColor
void ResetForeColor()
abstract ResetForeColor : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ResetInActiveBackColor Method

ISelectionResetInActiveBackColor Method
When implemented by a class, resets the InActiveBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetInActiveBackColor()
Sub ResetInActiveBackColor
void ResetInActiveBackColor()
abstract ResetInActiveBackColor : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ResetInActiveForeColor Method

ISelectionResetInActiveForeColor Method
When implemented by a class, resets the InActiveForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetInActiveForeColor()
Sub ResetInActiveForeColor
void ResetInActiveForeColor()
abstract ResetInActiveForeColor : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ResetOptions Method

ISelectionResetOptions Method
When implemented by a class, resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOptions()
Sub ResetOptions
void ResetOptions()
abstract ResetOptions : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ScrollIfNeeded Method

ISelectionScrollIfNeeded Method
When implemented by a class, scrolls to specified position if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ScrollIfNeeded(
    Point pt
)
Function ScrollIfNeeded (
    pt As Point
) As Boolean
bool ScrollIfNeeded(
    Point pt
)
abstract ScrollIfNeeded :
        pt : Point -> bool

Parameters

pt
Type: System.DrawingPoint
Position to scroll.

Return Value

Type: Boolean
True if scroll needed; otherwise false.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectAll Method

ISelectionSelectAll Method
When implemented by a class, selects all lines in the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectAll()
Sub SelectAll
void SelectAll()
abstract SelectAll : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectCharLeft Method

ISelectionSelectCharLeft Method
Overload List
 | Name | Description
Public method | SelectCharLeft | When implemented by a class, increases selected text to one character at the left side of the selection region.
Public method | SelectCharLeft(SelectionType) | When implemented by a class, increases selected text to one character at the left side of the selection region and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectCharLeft Method

ISelectionSelectCharLeft Method
When implemented by a class, increases selected text to one character at the left side of the selection region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectCharLeft()
Sub SelectCharLeft
void SelectCharLeft()
abstract SelectCharLeft : unit -> unit
See Also

Reference

ISelection Interface
SelectCharLeft Overload
Alternet.Editor Namespace


ISelection.SelectCharLeft Method (SelectionType)

ISelectionSelectCharLeft Method (SelectionType)
When implemented by a class, increases selected text to one character at the left side of the selection region and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectCharLeft(
    SelectionType selectionType
)
Sub SelectCharLeft (
    selectionType As SelectionType
)
void SelectCharLeft(
    SelectionType selectionType
)
abstract SelectCharLeft :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectCharLeft Overload
Alternet.Editor Namespace


ISelection.SelectCharRight Method

ISelectionSelectCharRight Method
Overload List
 | Name | Description
Public method | SelectCharRight | When implemented by a class, increases selected text to one character at the right side of the selection region.
Public method | SelectCharRight(SelectionType) | When implemented by a class, increases selected text to one character at the right side of the selection region and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectCharRight Method

ISelectionSelectCharRight Method
When implemented by a class, increases selected text to one character at the right side of the selection region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectCharRight()
Sub SelectCharRight
void SelectCharRight()
abstract SelectCharRight : unit -> unit
See Also

Reference

ISelection Interface
SelectCharRight Overload
Alternet.Editor Namespace


ISelection.SelectCharRight Method (SelectionType)

ISelectionSelectCharRight Method (SelectionType)
When implemented by a class, increases selected text to one character at the right side of the selection region and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectCharRight(
    SelectionType selectionType
)
Sub SelectCharRight (
    selectionType As SelectionType
)
void SelectCharRight(
    SelectionType selectionType
)
abstract SelectCharRight :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectCharRight Overload
Alternet.Editor Namespace


ISelection.SelectedCount Method

ISelectionSelectedCount Method
When implemented by a class, returns amount of the lines being selected.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SelectedCount()
Function SelectedCount As Integer
int SelectedCount()
abstract SelectedCount : unit -> int

Return Value

Type: Int32
Number of selected lines.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectedString Method

ISelectionSelectedString Method
When implemented by a class, returns selected part of string at specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string SelectedString(
    int index
)
Function SelectedString (
    index As Integer
) As String
String^ SelectedString(
    int index
)
abstract SelectedString :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the line.

Return Value

Type: String
Selected part of specified string.
Remarks
If selection is empty method returns null.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectFileBegin Method

ISelectionSelectFileBegin Method
Overload List
 | Name | Description
Public method | SelectFileBegin | When implemented by a class, increases selected text to beginning of the control's content.
Public method | SelectFileBegin(SelectionType) | When implemented by a class, increases selected text to beginning of the control's content and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectFileBegin Method

ISelectionSelectFileBegin Method
When implemented by a class, increases selected text to beginning of the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectFileBegin()
Sub SelectFileBegin
void SelectFileBegin()
abstract SelectFileBegin : unit -> unit
See Also

Reference

ISelection Interface
SelectFileBegin Overload
Alternet.Editor Namespace


ISelection.SelectFileBegin Method (SelectionType)

ISelectionSelectFileBegin Method (SelectionType)
When implemented by a class, increases selected text to beginning of the control's content and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectFileBegin(
    SelectionType selectionType
)
Sub SelectFileBegin (
    selectionType As SelectionType
)
void SelectFileBegin(
    SelectionType selectionType
)
abstract SelectFileBegin :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectFileBegin Overload
Alternet.Editor Namespace


ISelection.SelectFileEnd Method

ISelectionSelectFileEnd Method
Overload List
 | Name | Description
Public method | SelectFileEnd | When implemented by a class, increases selected text to end of the control's content.
Public method | SelectFileEnd(SelectionType) | When implemented by a class, increases selected text to end of the control's content and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectFileEnd Method

ISelectionSelectFileEnd Method
When implemented by a class, increases selected text to end of the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectFileEnd()
Sub SelectFileEnd
void SelectFileEnd()
abstract SelectFileEnd : unit -> unit
See Also

Reference

ISelection Interface
SelectFileEnd Overload
Alternet.Editor Namespace


ISelection.SelectFileEnd Method (SelectionType)

ISelectionSelectFileEnd Method (SelectionType)
When implemented by a class, increases selected text to end of the control's content and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectFileEnd(
    SelectionType selectionType
)
Sub SelectFileEnd (
    selectionType As SelectionType
)
void SelectFileEnd(
    SelectionType selectionType
)
abstract SelectFileEnd :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectFileEnd Overload
Alternet.Editor Namespace


ISelection.SelectionToScreen Method

ISelectionSelectionToScreen Method
When implemented by a class, represents selection region in a screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle SelectionToScreen()
Function SelectionToScreen As Rectangle
Rectangle SelectionToScreen()
abstract SelectionToScreen : unit -> Rectangle

Return Value

Type: Rectangle
Screen coordinate rectangle corresponding to selection region.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectionToTextPoint Method

ISelectionSelectionToTextPoint Method
When implemented by a class, converts given selection coordinate to the text coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point SelectionToTextPoint(
    Point position
)
Function SelectionToTextPoint (
    position As Point
) As Point
Point SelectionToTextPoint(
    Point position
)
abstract SelectionToTextPoint :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The selection coordinate Point to convert.

Return Value

Type: Point
Point that represents the converted position, in text coordinates.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectLine Method

ISelectionSelectLine Method
When implemented by a class, selects entire line at the current position in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLine()
Sub SelectLine
void SelectLine()
abstract SelectLine : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectLineBegin Method

ISelectionSelectLineBegin Method
Overload List
 | Name | Description
Public method | SelectLineBegin | When implemented by a class, selects from current position to the beginning of current line in the control.
Public method | SelectLineBegin(SelectionType) | When implemented by a class, selects from current position to the beginning of current line in the control and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectLineBegin Method

ISelectionSelectLineBegin Method
When implemented by a class, selects from current position to the beginning of current line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLineBegin()
Sub SelectLineBegin
void SelectLineBegin()
abstract SelectLineBegin : unit -> unit
See Also

Reference

ISelection Interface
SelectLineBegin Overload
Alternet.Editor Namespace


ISelection.SelectLineBegin Method (SelectionType)

ISelectionSelectLineBegin Method (SelectionType)
When implemented by a class, selects from current position to the beginning of current line in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLineBegin(
    SelectionType selectionType
)
Sub SelectLineBegin (
    selectionType As SelectionType
)
void SelectLineBegin(
    SelectionType selectionType
)
abstract SelectLineBegin :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectLineBegin Overload
Alternet.Editor Namespace


ISelection.SelectLineDown Method

ISelectionSelectLineDown Method
Overload List
 | Name | Description
Public method | SelectLineDown | When implemented by a class, increases selected text to the following line in the control.
Public method | SelectLineDown(SelectionType) | When implemented by a class, increases selected text to the following line in the control and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectLineDown Method

ISelectionSelectLineDown Method
When implemented by a class, increases selected text to the following line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLineDown()
Sub SelectLineDown
void SelectLineDown()
abstract SelectLineDown : unit -> unit
See Also

Reference

ISelection Interface
SelectLineDown Overload
Alternet.Editor Namespace


ISelection.SelectLineDown Method (SelectionType)

ISelectionSelectLineDown Method (SelectionType)
When implemented by a class, increases selected text to the following line in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLineDown(
    SelectionType selectionType
)
Sub SelectLineDown (
    selectionType As SelectionType
)
void SelectLineDown(
    SelectionType selectionType
)
abstract SelectLineDown :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectLineDown Overload
Alternet.Editor Namespace


ISelection.SelectLineEnd Method

ISelectionSelectLineEnd Method
Overload List
 | Name | Description
Public method | SelectLineEnd | When implemented by a class, selects from current position to the end of current line in the control.
Public method | SelectLineEnd(SelectionType) | When implemented by a class, selects from current position to the end of current line in the control and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectLineEnd Method

ISelectionSelectLineEnd Method
When implemented by a class, selects from current position to the end of current line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLineEnd()
Sub SelectLineEnd
void SelectLineEnd()
abstract SelectLineEnd : unit -> unit
See Also

Reference

ISelection Interface
SelectLineEnd Overload
Alternet.Editor Namespace


ISelection.SelectLineEnd Method (SelectionType)

ISelectionSelectLineEnd Method (SelectionType)
When implemented by a class, selects from current position to the end of current line in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLineEnd(
    SelectionType selectionType
)
Sub SelectLineEnd (
    selectionType As SelectionType
)
void SelectLineEnd(
    SelectionType selectionType
)
abstract SelectLineEnd :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectLineEnd Overload
Alternet.Editor Namespace


ISelection.SelectLineOnTrippleClick Method

ISelectionSelectLineOnTrippleClick Method
When implemented by a class, selects entire line at the current position in the control as a result of triple click.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLineOnTrippleClick()
Sub SelectLineOnTrippleClick
void SelectLineOnTrippleClick()
abstract SelectLineOnTrippleClick : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectLineUp Method

ISelectionSelectLineUp Method
Overload List
 | Name | Description
Public method | SelectLineUp | When implemented by a class, increases selected text to the preceding line in the control.
Public method | SelectLineUp(SelectionType) | When implemented by a class, increases selected text to the preceding line in the control and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectLineUp Method

ISelectionSelectLineUp Method
When implemented by a class, increases selected text to the preceding line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLineUp()
Sub SelectLineUp
void SelectLineUp()
abstract SelectLineUp : unit -> unit
See Also

Reference

ISelection Interface
SelectLineUp Overload
Alternet.Editor Namespace


ISelection.SelectLineUp Method (SelectionType)

ISelectionSelectLineUp Method (SelectionType)
When implemented by a class, increases selected text to the preceding line in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectLineUp(
    SelectionType selectionType
)
Sub SelectLineUp (
    selectionType As SelectionType
)
void SelectLineUp(
    SelectionType selectionType
)
abstract SelectLineUp :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectLineUp Overload
Alternet.Editor Namespace


ISelection.SelectPageDown Method

ISelectionSelectPageDown Method
Overload List
 | Name | Description
Public method | SelectPageDown | When implemented by a class, increases selected text to the one page down in the control.
Public method | SelectPageDown(SelectionType) | When implemented by a class, increases selected text to the one page down in the control and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectPageDown Method

ISelectionSelectPageDown Method
When implemented by a class, increases selected text to the one page down in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectPageDown()
Sub SelectPageDown
void SelectPageDown()
abstract SelectPageDown : unit -> unit
See Also

Reference

ISelection Interface
SelectPageDown Overload
Alternet.Editor Namespace


ISelection.SelectPageDown Method (SelectionType)

ISelectionSelectPageDown Method (SelectionType)
When implemented by a class, increases selected text to the one page down in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectPageDown(
    SelectionType selectionType
)
Sub SelectPageDown (
    selectionType As SelectionType
)
void SelectPageDown(
    SelectionType selectionType
)
abstract SelectPageDown :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectPageDown Overload
Alternet.Editor Namespace


ISelection.SelectPageUp Method

ISelectionSelectPageUp Method
Overload List
 | Name | Description
Public method | SelectPageUp | When implemented by a class, increases selected text to the one page up in the control.
Public method | SelectPageUp(SelectionType) | When implemented by a class, increases selected text to the one page up in the control and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectPageUp Method

ISelectionSelectPageUp Method
When implemented by a class, increases selected text to the one page up in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectPageUp()
Sub SelectPageUp
void SelectPageUp()
abstract SelectPageUp : unit -> unit
See Also

Reference

ISelection Interface
SelectPageUp Overload
Alternet.Editor Namespace


ISelection.SelectPageUp Method (SelectionType)

ISelectionSelectPageUp Method (SelectionType)
When implemented by a class, increases selected text to the one page up in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectPageUp(
    SelectionType selectionType
)
Sub SelectPageUp (
    selectionType As SelectionType
)
void SelectPageUp(
    SelectionType selectionType
)
abstract SelectPageUp :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectPageUp Overload
Alternet.Editor Namespace


ISelection.SelectScreenBottom Method

ISelectionSelectScreenBottom Method
Overload List
 | Name | Description
Public method | SelectScreenBottom | When implemented by a class, increases selected text to the end of screen.
Public method | SelectScreenBottom(SelectionType) | When implemented by a class, increases selected text to the end of the screen and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectScreenBottom Method

ISelectionSelectScreenBottom Method
When implemented by a class, increases selected text to the end of screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectScreenBottom()
Sub SelectScreenBottom
void SelectScreenBottom()
abstract SelectScreenBottom : unit -> unit
See Also

Reference

ISelection Interface
SelectScreenBottom Overload
Alternet.Editor Namespace


ISelection.SelectScreenBottom Method (SelectionType)

ISelectionSelectScreenBottom Method (SelectionType)
When implemented by a class, increases selected text to the end of the screen and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectScreenBottom(
    SelectionType selectionType
)
Sub SelectScreenBottom (
    selectionType As SelectionType
)
void SelectScreenBottom(
    SelectionType selectionType
)
abstract SelectScreenBottom :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectScreenBottom Overload
Alternet.Editor Namespace


ISelection.SelectScreenTop Method

ISelectionSelectScreenTop Method
Overload List
 | Name | Description
Public method | SelectScreenTop | When implemented by a class, increases selected text to the begin of screen.
Public method | SelectScreenTop(SelectionType) | When implemented by a class, increases selected text to the begin of the screen and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectScreenTop Method

ISelectionSelectScreenTop Method
When implemented by a class, increases selected text to the begin of screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectScreenTop()
Sub SelectScreenTop
void SelectScreenTop()
abstract SelectScreenTop : unit -> unit
See Also

Reference

ISelection Interface
SelectScreenTop Overload
Alternet.Editor Namespace


ISelection.SelectScreenTop Method (SelectionType)

ISelectionSelectScreenTop Method (SelectionType)
When implemented by a class, increases selected text to the begin of the screen and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectScreenTop(
    SelectionType selectionType
)
Sub SelectScreenTop (
    selectionType As SelectionType
)
void SelectScreenTop(
    SelectionType selectionType
)
abstract SelectScreenTop :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectScreenTop Overload
Alternet.Editor Namespace


ISelection.SelectToBrace Method

ISelectionSelectToBrace Method
When implemented by a class, increases selected text to the next open or closing brace.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectToBrace()
Sub SelectToBrace
void SelectToBrace()
abstract SelectToBrace : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectToCloseBrace Method

ISelectionSelectToCloseBrace Method
When implemented by a class, increases selected text to the next closing brace.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectToCloseBrace()
Sub SelectToCloseBrace
void SelectToCloseBrace()
abstract SelectToCloseBrace : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectToOpenBrace Method

ISelectionSelectToOpenBrace Method
When implemented by a class, increases selected text to the prev open brace.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectToOpenBrace()
Sub SelectToOpenBrace
void SelectToOpenBrace()
abstract SelectToOpenBrace : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectWord Method

ISelectionSelectWord Method
When implemented by a class, selects word at the current position in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectWord()
Sub SelectWord
void SelectWord()
abstract SelectWord : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectWordLeft Method

ISelectionSelectWordLeft Method
Overload List
 | Name | Description
Public method | SelectWordLeft | When implemented by a class, increases selected text to the word located at the left side of the current position in the control.
Public method | SelectWordLeft(SelectionType) | When implemented by a class, increases selected text to the word located at the left side of the current position in the control and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectWordLeft Method

ISelectionSelectWordLeft Method
When implemented by a class, increases selected text to the word located at the left side of the current position in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectWordLeft()
Sub SelectWordLeft
void SelectWordLeft()
abstract SelectWordLeft : unit -> unit
See Also

Reference

ISelection Interface
SelectWordLeft Overload
Alternet.Editor Namespace


ISelection.SelectWordLeft Method (SelectionType)

ISelectionSelectWordLeft Method (SelectionType)
When implemented by a class, increases selected text to the word located at the left side of the current position in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectWordLeft(
    SelectionType selectionType
)
Sub SelectWordLeft (
    selectionType As SelectionType
)
void SelectWordLeft(
    SelectionType selectionType
)
abstract SelectWordLeft :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectWordLeft Overload
Alternet.Editor Namespace


ISelection.SelectWordRight Method

ISelectionSelectWordRight Method
Overload List
 | Name | Description
Public method | SelectWordRight | When implemented by a class, increases selected text to the word located at the right side of the current position in the control.
Public method | SelectWordRight(SelectionType) | When implemented by a class, increases selected text to the word located at the right side of the current position in the control and sets a given selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectWordRight Method

ISelectionSelectWordRight Method
When implemented by a class, increases selected text to the word located at the right side of the current position in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectWordRight()
Sub SelectWordRight
void SelectWordRight()
abstract SelectWordRight : unit -> unit
See Also

Reference

ISelection Interface
SelectWordRight Overload
Alternet.Editor Namespace


ISelection.SelectWordRight Method (SelectionType)

ISelectionSelectWordRight Method (SelectionType)
When implemented by a class, increases selected text to the word located at the right side of the current position in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectWordRight(
    SelectionType selectionType
)
Sub SelectWordRight (
    selectionType As SelectionType
)
void SelectWordRight(
    SelectionType selectionType
)
abstract SelectWordRight :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.
See Also

Reference

ISelection Interface
SelectWordRight Overload
Alternet.Editor Namespace


ISelection.SetSelection Method

ISelectionSetSelection Method
Overload List
 | Name | Description
Public method | SetSelection(SelectionType, Rectangle) | When implemented by a class, sets new selection region with specified selection type.
Public method | SetSelection(SelectionType, Point, Point) | When implemented by a class, sets new selection region with specified selection type.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SetSelection Method (SelectionType, Rectangle)

ISelectionSetSelection Method (SelectionType, Rectangle)
When implemented by a class, sets new selection region with specified selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetSelection(
    SelectionType selectionType,
    Rectangle selectionRect
)
Sub SetSelection (
    selectionType As SelectionType,
    selectionRect As Rectangle
)
void SetSelection(
    SelectionType selectionType,
    Rectangle selectionRect
)
abstract SetSelection :
        selectionType : SelectionType *
        selectionRect : Rectangle -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New selection type.
selectionRect
Type: System.DrawingRectangle
New selected rectangle.
See Also

Reference

ISelection Interface
SetSelection Overload
Alternet.Editor Namespace


ISelection.SetSelection Method (SelectionType, Point, Point)

ISelectionSetSelection Method (SelectionType, Point, Point)
When implemented by a class, sets new selection region with specified selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetSelection(
    SelectionType selectionType,
    Point selectionStart,
    Point selectionEnd
)
Sub SetSelection (
    selectionType As SelectionType,
    selectionStart As Point,
    selectionEnd As Point
)
void SetSelection(
    SelectionType selectionType,
    Point selectionStart,
    Point selectionEnd
)
abstract SetSelection :
        selectionType : SelectionType *
        selectionStart : Point *
        selectionEnd : Point -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New selection type.
selectionStart
Type: System.DrawingPoint
Left-top corner of the selected rectangle.
selectionEnd
Type: System.DrawingPoint
Right-bottom corner of the selected rectangle.
See Also

Reference

ISelection Interface
SetSelection Overload
Alternet.Editor Namespace


ISelection.SmartFormat Method

ISelectionSmartFormat Method
Overload List
 | Name | Description
Public method | SmartFormat | When implemented by a class, formats selected text using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormat(Char) | When implemented by a class, formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies Character being typed
Public method | SmartFormat(Int32) | When implemented by a class, formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SmartFormat Method

ISelectionSmartFormat Method
When implemented by a class, formats selected text using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SmartFormat()
Sub SmartFormat
void SmartFormat()
abstract SmartFormat : unit -> unit
See Also

Reference

ISelection Interface
SmartFormat Overload
Alternet.Editor Namespace


ISelection.SmartFormat Method (Char)

ISelectionSmartFormat Method (Char)
When implemented by a class, formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies Character being typed

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SmartFormat(
    char ch
)
Function SmartFormat (
    ch As Char
) As Boolean
bool SmartFormat(
    wchar_t ch
)
abstract SmartFormat :
        ch : char -> bool

Parameters

ch
Type: SystemChar

Return Value

Type: Boolean
See Also

Reference

ISelection Interface
SmartFormat Overload
Alternet.Editor Namespace


ISelection.SmartFormat Method (Int32)

ISelectionSmartFormat Method (Int32)
When implemented by a class, formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SmartFormat(
    int line
)
Sub SmartFormat (
    line As Integer
)
void SmartFormat(
    int line
)
abstract SmartFormat :
        line : int -> unit

Parameters

line
Type: SystemInt32
See Also

Reference

ISelection Interface
SmartFormat Overload
Alternet.Editor Namespace


ISelection.SmartFormatBlock Method

ISelectionSmartFormatBlock Method
When implemented by a class, formats current syntax block using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SmartFormatBlock(
    bool extended,
    char ch
)
Sub SmartFormatBlock (
    extended As Boolean,
    ch As Char
)
void SmartFormatBlock(
    bool extended,
    wchar_t ch
)
abstract SmartFormatBlock :
        extended : bool *
        ch : char -> unit

Parameters

extended
Type: SystemBoolean
Specifies that search should be extended outside current scope
ch
Type: SystemChar
Specifies character being typed
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SmartFormatDocument Method

ISelectionSmartFormatDocument Method
When implemented by a class, formats entire document using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SmartFormatDocument()
Sub SmartFormatDocument
void SmartFormatDocument()
abstract SmartFormatDocument : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SmartIndent Method

ISelectionSmartIndent Method
Overload List
 | Name | Description
Public method | SmartIndent | When implemented by a class, positions the cursor to the line indentation level, obtained from parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent option when user presses Enter.
Public method | SmartIndent(Char) | When implemented by a class, formats given current line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies character being typed
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SmartIndent Method

ISelectionSmartIndent Method
When implemented by a class, positions the cursor to the line indentation level, obtained from parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent option when user presses Enter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SmartIndent()
Sub SmartIndent
void SmartIndent()
abstract SmartIndent : unit -> unit
See Also

Reference

ISelection Interface
SmartIndent Overload
Alternet.Editor Namespace


ISelection.SmartIndent Method (Char)

ISelectionSmartIndent Method (Char)
When implemented by a class, formats given current line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies character being typed

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SmartIndent(
    char ch
)
Function SmartIndent (
    ch As Char
) As Boolean
bool SmartIndent(
    wchar_t ch
)
abstract SmartIndent :
        ch : char -> bool

Parameters

ch
Type: SystemChar

Return Value

Type: Boolean
See Also

Reference

ISelection Interface
SmartIndent Overload
Alternet.Editor Namespace


ISelection.StartSelection Method

ISelectionStartSelection Method
When implemented by a class, forces selection start.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartSelection()
Sub StartSelection
void StartSelection()
abstract StartSelection : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SwapAnchor Method

ISelectionSwapAnchor Method
When implemented by a class, change current position from beginning of selection rectangle to the end of selection rectangle or vice versa.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SwapAnchor()
Sub SwapAnchor
void SwapAnchor()
abstract SwapAnchor : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Tabify Method

ISelectionTabify Method
When implemented by a class, converts spaces to tabs in the current string within the selected area according to tab settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Tabify()
Sub Tabify
void Tabify()
abstract Tabify : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.TextToSelectionPoint Method

ISelectionTextToSelectionPoint Method
When implemented by a class, converts given text coordinate to the selection coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point TextToSelectionPoint(
    Point position
)
Function TextToSelectionPoint (
    position As Point
) As Point
Point TextToSelectionPoint(
    Point position
)
abstract TextToSelectionPoint :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The text coordinate Point to convert.

Return Value

Type: Point
Point that represents the converted position, in selection coordinates.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ToggleOutlining Method

ISelectionToggleOutlining Method
When implemented by a class, toggles expanded state for all IOutlineRange objects in outline collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleOutlining()
Sub ToggleOutlining
void ToggleOutlining()
abstract ToggleOutlining : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ToggleOverWrite Method

ISelectionToggleOverWrite Method
When implemented by a class, toggles the control's overwrite mode.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleOverWrite()
Sub ToggleOverWrite
void ToggleOverWrite()
abstract ToggleOverWrite : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.UncommentSelection Method

ISelectionUncommentSelection Method
When implemented by a class, removes the comment syntax from the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UncommentSelection()
Sub UncommentSelection
void UncommentSelection()
abstract UncommentSelection : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.UnIndent Method

ISelectionUnIndent Method
When implemented by a class, unindents the selected text by one indentation level, deleting Tab or spaces from the beginning of the line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnIndent()
Sub UnIndent
void UnIndent()
abstract UnIndent : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.UnTabify Method

ISelectionUnTabify Method
When implemented by a class, converts tabs to spaces in the current string within the selected area according to tab settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnTabify()
Sub UnTabify
void UnTabify()
abstract UnTabify : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.UpdateSelection Method

ISelectionUpdateSelection Method
When implemented by a class, invalidates selected region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateSelection()
Sub UpdateSelection
void UpdateSelection()
abstract UpdateSelection : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.UpdateSelRange Method

ISelectionUpdateSelRange Method
When implemented by a class, updates selection start and end to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateSelRange(
    Point start,
    Point end
)
Sub UpdateSelRange (
    start As Point,
    end As Point
)
void UpdateSelRange(
    Point start,
    Point end
)
abstract UpdateSelRange :
        start : Point *
        end : Point -> unit

Parameters

start
Type: System.DrawingPoint
New selection start.
end
Type: System.DrawingPoint
New selection end.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.UpdateSelStart Method

ISelectionUpdateSelStart Method
Overload List
 | Name | Description
Public method | UpdateSelStart(Boolean) | When implemented by a class, updates selection start to the specified position.
Public method | UpdateSelStart(Point) | When implemented by a class, updates selection start to the specified position.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.UpdateSelStart Method (Boolean)

ISelectionUpdateSelStart Method (Boolean)
When implemented by a class, updates selection start to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateSelStart(
    bool checkIfEmpty
)
Sub UpdateSelStart (
    checkIfEmpty As Boolean
)
void UpdateSelStart(
    bool checkIfEmpty
)
abstract UpdateSelStart :
        checkIfEmpty : bool -> unit

Parameters

checkIfEmpty
Type: SystemBoolean
Checks whether selection is empty.
See Also

Reference

ISelection Interface
UpdateSelStart Overload
Alternet.Editor Namespace


ISelection.UpdateSelStart Method (Point)

ISelectionUpdateSelStart Method (Point)
When implemented by a class, updates selection start to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateSelStart(
    Point position
)
Sub UpdateSelStart (
    position As Point
)
void UpdateSelStart(
    Point position
)
abstract UpdateSelStart :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
New selection start.
See Also

Reference

ISelection Interface
UpdateSelStart Overload
Alternet.Editor Namespace


ISelection.UpperCase Method

ISelectionUpperCase Method
When implemented by a class, converts all selected characters to the upper-case.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpperCase()
Sub UpperCase
void UpperCase()
abstract UpperCase : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.WordTransponse Method

ISelectionWordTransponse Method
When implemented by a class, transposes word under the caret with the next word.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void WordTransponse()
Sub WordTransponse
void WordTransponse()
abstract WordTransponse : unit -> unit
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection Properties

ISelection Properties

The ISelection type exposes the following members.

Properties
 | Name | Description
Public property | AllowedSelectionMode | When implemented by a class, gets or sets types of selection allowed to Edit control content.
Public property | BackColor | When implemented by a class, gets or sets a background color of the SelectedText when owner control has input focus.
Public property | BorderColor | When implemented by a class, gets or sets a color of the selection border.
Public property | ForeColor | When implemented by a class, gets or sets a foreground color of the SelectedText when owner control has input focus.
Public property | InActiveBackColor | When implemented by a class, gets or sets a background color of the SelectedText when owner control does not have input focus.
Public property | InActiveForeColor | When implemented by a class, gets or sets a foreground color of the SelectedText when owner control does not have input focus.
Public property | IsEmpty | When implemented by a class, indicates whether nothing is selected.
Public property | Options | When implemented by a class, gets or sets options determining behaviour or the ISelection.
Public property | SelectedColorData | When implemented by a class, gets strings that corresponds to selected part of the control's text content.
Public property | SelectedText | When implemented by a class, gets or sets strings that corresponds to selected part of the control's text content.
Public property | SelectionLength | When implemented by a class, gets or sets length of the SelectedText.
Public property | SelectionRect | When implemented by a class, gets or sets rectangular area indicating selected text of the control.
Public property | SelectionStart | When implemented by a class, gets or sets the position of the first selected character while text considered as a single string.
Public property | SelectionState | When implemented by a class, gets or sets a value indicates state of the selected text.
Public property | SelectionType | When implemented by a class, gets or sets type of current selection.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.AllowedSelectionMode Property

ISelectionAllowedSelectionMode Property
When implemented by a class, gets or sets types of selection allowed to Edit control content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
AllowedSelectionMode AllowedSelectionMode { get; set; }
Property AllowedSelectionMode As AllowedSelectionMode
    Get
    Set
property AllowedSelectionMode AllowedSelectionMode {
    AllowedSelectionMode get ();
    void set (AllowedSelectionMode value);
}
abstract AllowedSelectionMode : AllowedSelectionMode with get, set

Property Value

Type: AllowedSelectionMode
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.BackColor Property

ISelectionBackColor Property
When implemented by a class, gets or sets a background color of the SelectedText when owner control has input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; set; }
Property BackColor As Color
    Get
    Set
property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.BorderColor Property

ISelectionBorderColor Property
When implemented by a class, gets or sets a color of the selection border.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BorderColor { get; set; }
Property BorderColor As Color
    Get
    Set
property Color BorderColor {
    Color get ();
    void set (Color value);
}
abstract BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.ForeColor Property

ISelectionForeColor Property
When implemented by a class, gets or sets a foreground color of the SelectedText when owner control has input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; set; }
Property ForeColor As Color
    Get
    Set
property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.InActiveBackColor Property

ISelectionInActiveBackColor Property
When implemented by a class, gets or sets a background color of the SelectedText when owner control does not have input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color InActiveBackColor { get; set; }
Property InActiveBackColor As Color
    Get
    Set
property Color InActiveBackColor {
    Color get ();
    void set (Color value);
}
abstract InActiveBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.InActiveForeColor Property

ISelectionInActiveForeColor Property
When implemented by a class, gets or sets a foreground color of the SelectedText when owner control does not have input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color InActiveForeColor { get; set; }
Property InActiveForeColor As Color
    Get
    Set
property Color InActiveForeColor {
    Color get ();
    void set (Color value);
}
abstract InActiveForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.IsEmpty Property

ISelectionIsEmpty Property
When implemented by a class, indicates whether nothing is selected.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsEmpty { get; }
ReadOnly Property IsEmpty As Boolean
    Get
property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get

Return Value

Type: Boolean
True if empty; otherwise false.
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.Options Property

ISelectionOptions Property
When implemented by a class, gets or sets options determining behaviour or the ISelection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SelectionOptions Options { get; set; }
Property Options As SelectionOptions
    Get
    Set
property SelectionOptions Options {
    SelectionOptions get ();
    void set (SelectionOptions value);
}
abstract Options : SelectionOptions with get, set

Property Value

Type: SelectionOptions
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectedColorData Property

ISelectionSelectedColorData Property
When implemented by a class, gets strings that corresponds to selected part of the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string SelectedColorData { get; }
ReadOnly Property SelectedColorData As String
    Get
property String^ SelectedColorData {
    String^ get ();
}
abstract SelectedColorData : string with get

Property Value

Type: String
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectedText Property

ISelectionSelectedText Property
When implemented by a class, gets or sets strings that corresponds to selected part of the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string SelectedText { get; set; }
Property SelectedText As String
    Get
    Set
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
abstract SelectedText : string with get, set

Property Value

Type: String
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectionLength Property

ISelectionSelectionLength Property
When implemented by a class, gets or sets length of the SelectedText.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SelectionLength { get; set; }
Property SelectionLength As Integer
    Get
    Set
property int SelectionLength {
    int get ();
    void set (int value);
}
abstract SelectionLength : int with get, set

Property Value

Type: Int32
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectionRect Property

ISelectionSelectionRect Property
When implemented by a class, gets or sets rectangular area indicating selected text of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle SelectionRect { get; set; }
Property SelectionRect As Rectangle
    Get
    Set
property Rectangle SelectionRect {
    Rectangle get ();
    void set (Rectangle value);
}
abstract SelectionRect : Rectangle with get, set

Property Value

Type: Rectangle
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectionStart Property

ISelectionSelectionStart Property
When implemented by a class, gets or sets the position of the first selected character while text considered as a single string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SelectionStart { get; set; }
Property SelectionStart As Integer
    Get
    Set
property int SelectionStart {
    int get ();
    void set (int value);
}
abstract SelectionStart : int with get, set

Property Value

Type: Int32
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectionState Property

ISelectionSelectionState Property
When implemented by a class, gets or sets a value indicates state of the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SelectionState SelectionState { get; set; }
Property SelectionState As SelectionState
    Get
    Set
property SelectionState SelectionState {
    SelectionState get ();
    void set (SelectionState value);
}
abstract SelectionState : SelectionState with get, set

Property Value

Type: SelectionState
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectionType Property

ISelectionSelectionType Property
When implemented by a class, gets or sets type of current selection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SelectionType SelectionType { get; set; }
Property SelectionType As SelectionType
    Get
    Set
property SelectionType SelectionType {
    SelectionType get ();
    void set (SelectionType value);
}
abstract SelectionType : SelectionType with get, set

Property Value

Type: SelectionType
See Also

Reference

ISelection Interface
Alternet.Editor Namespace
Alternet.EditorSelectionType


ISelection.UpdateCount Property

ISelectionUpdateCount Property
When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int UpdateCount { get; }
ReadOnly Property UpdateCount As Integer
    Get
property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get

Property Value

Type: Int32
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection Events

ISelection Events

The ISelection type exposes the following members.

Events
 | Name | Description
Public event | SelectionChanged | When implemented by a class, occurs when selection bounds are changed.
Top
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISelection.SelectionChanged Event

ISelectionSelectionChanged Event
When implemented by a class, occurs when selection bounds are changed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SelectionChanged
Event SelectionChanged As EventHandler
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISelection Interface
Alternet.Editor Namespace


ISplitView Interface

ISplitView Interface
Represents properties and methods allowing Edit control to visually split its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISplitView
Public Interface ISplitView
public interface class ISplitView
type ISplitView =  interface end

The ISplitView type exposes the following members.

Methods
 | Name | Description
Public method | CanSplitHorz | When implemented by a class, indicates whether control can split its content horizontally.
Public method | CanSplitVert | When implemented by a class, indicates whether control can split its content vertically.
Public method | CanUnsplitHorz | When implemented by a class, indicates whether control has horizontal split view.
Public method | CanUnsplitVert | When implemented by a class, indicates whether control has vertical split view.
Public method | SplitViewHorz | When implemented by a class, splits its content horizontally.
Public method | SplitViewVert | When implemented by a class, splits its content vertically.
Public method | UnsplitViewHorz | When implemented by a class, removes horizontal split view.
Public method | UnsplitViewVert | When implemented by a class, removes vertical split view.
Top
Properties
 | Name | Description
Public property | HorzSplitEdit | When implemented by a class, represents horizontal split view control.
Public property | HorzSplitter | When implemented by a class, represents a horizontal Splitter control allowing to split Edit content horizontally.
Public property | VertSplitEdit | When implemented by a class, represents an vertical split view control.
Public property | VertSplitter | When implemented by a class, represents a vertical Splitter control allowing to split Edit content vertically.
Top
Events
 | Name | Description
Public event | SplitHorz | When implemented by a class, occurs when user splits Edit control horizontally.
Public event | SplitVert | When implemented by a class, occurs when user splits Edit control vertically.
Public event | UnsplitHorz | When implemented by a class, occurs when horizontal split view is removed.
Public event | UnsplitVert | When implemented by a class, occurs when vertical split view is removed.
Top
See Also

Reference

Alternet.Editor Namespace


ISplitView Methods

ISplitView Methods

The ISplitView type exposes the following members.

Methods
 | Name | Description
Public method | CanSplitHorz | When implemented by a class, indicates whether control can split its content horizontally.
Public method | CanSplitVert | When implemented by a class, indicates whether control can split its content vertically.
Public method | CanUnsplitHorz | When implemented by a class, indicates whether control has horizontal split view.
Public method | CanUnsplitVert | When implemented by a class, indicates whether control has vertical split view.
Public method | SplitViewHorz | When implemented by a class, splits its content horizontally.
Public method | SplitViewVert | When implemented by a class, splits its content vertically.
Public method | UnsplitViewHorz | When implemented by a class, removes horizontal split view.
Public method | UnsplitViewVert | When implemented by a class, removes vertical split view.
Top
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.CanSplitHorz Method

ISplitViewCanSplitHorz Method
When implemented by a class, indicates whether control can split its content horizontally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSplitHorz()
Function CanSplitHorz As Boolean
bool CanSplitHorz()
abstract CanSplitHorz : unit -> bool

Return Value

Type: Boolean
True if can split horizontally; otherwise false.
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.CanSplitVert Method

ISplitViewCanSplitVert Method
When implemented by a class, indicates whether control can split its content vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSplitVert()
Function CanSplitVert As Boolean
bool CanSplitVert()
abstract CanSplitVert : unit -> bool

Return Value

Type: Boolean
True if can split vertically; otherwise false.
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.CanUnsplitHorz Method

ISplitViewCanUnsplitHorz Method
When implemented by a class, indicates whether control has horizontal split view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanUnsplitHorz()
Function CanUnsplitHorz As Boolean
bool CanUnsplitHorz()
abstract CanUnsplitHorz : unit -> bool

Return Value

Type: Boolean
True if horizontal split view is visible; otherwise false.
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.CanUnsplitVert Method

ISplitViewCanUnsplitVert Method
When implemented by a class, indicates whether control has vertical split view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanUnsplitVert()
Function CanUnsplitVert As Boolean
bool CanUnsplitVert()
abstract CanUnsplitVert : unit -> bool

Return Value

Type: Boolean
True if vertical split view is visible; otherwise false.
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.SplitViewHorz Method

ISplitViewSplitViewHorz Method
When implemented by a class, splits its content horizontally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SplitViewHorz()
Sub SplitViewHorz
void SplitViewHorz()
abstract SplitViewHorz : unit -> unit
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.SplitViewVert Method

ISplitViewSplitViewVert Method
When implemented by a class, splits its content vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SplitViewVert()
Sub SplitViewVert
void SplitViewVert()
abstract SplitViewVert : unit -> unit
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.UnsplitViewHorz Method

ISplitViewUnsplitViewHorz Method
When implemented by a class, removes horizontal split view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnsplitViewHorz()
Sub UnsplitViewHorz
void UnsplitViewHorz()
abstract UnsplitViewHorz : unit -> unit
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.UnsplitViewVert Method

ISplitViewUnsplitViewVert Method
When implemented by a class, removes vertical split view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnsplitViewVert()
Sub UnsplitViewVert
void UnsplitViewVert()
abstract UnsplitViewVert : unit -> unit
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView Properties

ISplitView Properties

The ISplitView type exposes the following members.

Properties
 | Name | Description
Public property | HorzSplitEdit | When implemented by a class, represents horizontal split view control.
Public property | HorzSplitter | When implemented by a class, represents a horizontal Splitter control allowing to split Edit content horizontally.
Public property | VertSplitEdit | When implemented by a class, represents an vertical split view control.
Public property | VertSplitter | When implemented by a class, represents a vertical Splitter control allowing to split Edit content vertically.
Top
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.HorzSplitEdit Property

ISplitViewHorzSplitEdit Property
When implemented by a class, represents horizontal split view control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxEdit HorzSplitEdit { get; }
ReadOnly Property HorzSplitEdit As ISyntaxEdit
    Get
property ISyntaxEdit^ HorzSplitEdit {
    ISyntaxEdit^ get ();
}
abstract HorzSplitEdit : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.HorzSplitter Property

ISplitViewHorzSplitter Property
When implemented by a class, represents a horizontal Splitter control allowing to split Edit content horizontally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Splitter HorzSplitter { get; }
ReadOnly Property HorzSplitter As Splitter
    Get
property Splitter^ HorzSplitter {
    Splitter^ get ();
}
abstract HorzSplitter : Splitter with get

Property Value

Type: Splitter
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.VertSplitEdit Property

ISplitViewVertSplitEdit Property
When implemented by a class, represents an vertical split view control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxEdit VertSplitEdit { get; }
ReadOnly Property VertSplitEdit As ISyntaxEdit
    Get
property ISyntaxEdit^ VertSplitEdit {
    ISyntaxEdit^ get ();
}
abstract VertSplitEdit : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.VertSplitter Property

ISplitViewVertSplitter Property
When implemented by a class, represents a vertical Splitter control allowing to split Edit content vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Splitter VertSplitter { get; }
ReadOnly Property VertSplitter As Splitter
    Get
property Splitter^ VertSplitter {
    Splitter^ get ();
}
abstract VertSplitter : Splitter with get

Property Value

Type: Splitter
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView Events

ISplitView Events

The ISplitView type exposes the following members.

Events
 | Name | Description
Public event | SplitHorz | When implemented by a class, occurs when user splits Edit control horizontally.
Public event | SplitVert | When implemented by a class, occurs when user splits Edit control vertically.
Public event | UnsplitHorz | When implemented by a class, occurs when horizontal split view is removed.
Public event | UnsplitVert | When implemented by a class, occurs when vertical split view is removed.
Top
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.SplitHorz Event

ISplitViewSplitHorz Event
When implemented by a class, occurs when user splits Edit control horizontally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SplitHorz
Event SplitHorz As EventHandler
 event EventHandler^ SplitHorz {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SplitHorz : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.SplitVert Event

ISplitViewSplitVert Event
When implemented by a class, occurs when user splits Edit control vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SplitVert
Event SplitVert As EventHandler
 event EventHandler^ SplitVert {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SplitVert : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.UnsplitHorz Event

ISplitViewUnsplitHorz Event
When implemented by a class, occurs when horizontal split view is removed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler UnsplitHorz
Event UnsplitHorz As EventHandler
 event EventHandler^ UnsplitHorz {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UnsplitHorz : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISplitView.UnsplitVert Event

ISplitViewUnsplitVert Event
When implemented by a class, occurs when vertical split view is removed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler UnsplitVert
Event UnsplitVert As EventHandler
 event EventHandler^ UnsplitVert {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UnsplitVert : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISplitView Interface
Alternet.Editor Namespace


ISyntaxEdit Interface

ISyntaxEdit Interface
Represents properties and methods for an advanced multi-line Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxEdit : ISearch,
    ITextSearch, IEditNotifier, INotifier, ICaret, IEditNavigate,
    INavigate, IEdit, IUpdate, IWordWrap, ITextExport,
    IExport, ITextImport, IImport, ICodeCompletion, IRecordPlayBack,
    ISplitView, IAutoCorrect, IControl
Public Interface ISyntaxEdit
    Inherits ISearch, ITextSearch, IEditNotifier, INotifier,
    ICaret, IEditNavigate, INavigate, IEdit, IUpdate,
    IWordWrap, ITextExport, IExport, ITextImport, IImport,
    ICodeCompletion, IRecordPlayBack, ISplitView, IAutoCorrect, IControl
public interface class ISyntaxEdit : ISearch,
    ITextSearch, IEditNotifier, INotifier, ICaret, IEditNavigate,
    INavigate, IEdit, IUpdate, IWordWrap, ITextExport,
    IExport, ITextImport, IImport, ICodeCompletion, IRecordPlayBack,
    ISplitView, IAutoCorrect, IControl
type ISyntaxEdit =
    interface
        interface ISearch
        interface ITextSearch
        interface IEditNotifier
        interface INotifier
        interface ICaret
        interface IEditNavigate
        interface INavigate
        interface IEdit
        interface IUpdate
        interface IWordWrap
        interface ITextExport
        interface IExport
        interface ITextImport
        interface IImport
        interface ICodeCompletion
        interface IRecordPlayBack
        interface ISplitView
        interface IAutoCorrect
        interface IControl
    end

The ISyntaxEdit type exposes the following members.

Methods
Name Description
Public method ApplyTheme
Whem implemented by a class, applies visual theme to the SyntaxEdit control.
Public method Assign
When implemented by a class, assigns most relevant properties from another ISyntaxEdit object.
Public method BeginUpdate
When implemented by a class, prevents object state updating until calling EndUpdate method.
(Inherited from IUpdate.)
Public method BreakLine
When implemented by a class, breaks current line into two lines.
(Inherited from IEdit.)
Public method BringToFront
When implemented by a class, brings the control to the front of the z-order.
(Inherited from IControl.)
Public method CanFindNext
When implemented by a class, indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
(Inherited from ISearch.)
Public method CanFindNextSelected
When implemented by a class, indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
(Inherited from ISearch.)
Public method CanFindPrevious
When implemented by a class, indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
(Inherited from ISearch.)
Public method CanFindPreviousSelected
When implemented by a class, indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
(Inherited from ISearch.)
Public method CanSearchSelection
When implemented by a class, returns whether search can be performed inside selection.
(Inherited from ISearch.)
Public method CanSplitHorz
When implemented by a class, indicates whether control can split its content horizontally.
(Inherited from ISplitView.)
Public method CanSplitVert
When implemented by a class, indicates whether control can split its content vertically.
(Inherited from ISplitView.)
Public method CanUnsplitHorz
When implemented by a class, indicates whether control has horizontal split view.
(Inherited from ISplitView.)
Public method CanUnsplitVert
When implemented by a class, indicates whether control has vertical split view.
(Inherited from ISplitView.)
Public method CodeCompletion
When implemented by a class, performs code completion for the specified text representing language element.
(Inherited from ICodeCompletion.)
Public method CodeCompletionWindowFocused
When implemented by a class, indicates whether ICodeCompletionWindow has focus.
(Inherited from ICodeCompletion.)
Public method CodeSnippets
When implemented by a class, displays a code completion window with list of available code snippets.
(Inherited from ICodeCompletion.)
Public method CompleteCodeFixes
When implemented by a class, displays a code completion window with list of available code fixes.
(Inherited from ICodeCompletion.)
Public method CompleteCodeFixesOrRefactors
When implemented by a class, displays a code completion window with list of available code fixes or code refactors.
(Inherited from ICodeCompletion.)
Public method CompleteCodeRefactors
When implemented by a class, displays a code completion window with list of available code refactors.
(Inherited from ICodeCompletion.)
Public method CompleteWord
When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content and locates single member, if possible.
(Inherited from ICodeCompletion.)
Public method CreateCaret
When implemented by a class, creates a new shape for the system caret and gets ownership of the caret.
(Inherited from ICaret.)
Public method CreateGraphics
When implemented by a class, creates the Graphics for the control.
(Inherited from IControl.)
Public method CycledSearch
When implemented by a class, performs cycled search.
(Inherited from ISearch.)
Public method DeleteBlock
When implemented by a class, deletes a specified block of characters.
(Inherited from IEdit.)
Public method DeleteLeft
When implemented by a class, deletes a specified number of characters to the left of the active point.
(Inherited from IEdit.)
Public method DeleteRight
When implemented by a class, deletes a specified number of characters to the right of the active point.
(Inherited from IEdit.)
Public method DestroyCaret
When implemented by a class, destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
(Inherited from ICaret.)
Public method DisablePositionUpdate
When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method.
(Inherited from INavigate.)
Public method DisableUpdate
When implemented by a class, prevents object state updating until calling EnableUpdate method.
(Inherited from IUpdate.)
Public method DisplayDragCaret
When implemented by a class, displays dragging caret rather than regular caret.
(Inherited from ICaret.)
Public method DisplayGotoLineDialog
When implemented by a class, initializes and runs a dialog prompting you for index of the line you need to locate.
Public method DisplayGotoLineDialog(IWin32Window)
When implemented by a class, initializes and runs a dialog prompting you for index of the line you need to locate.
Public method DisplayModalReplaceDialog
When implemented by a class, initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method DisplayModalReplaceDialog(IWin32Window)
When implemented by a class, initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method DisplayModalSearchDialog
When implemented by a class, initializes and runs a modal dialog box allowing you to search for some text.
Public method DisplayModalSearchDialog(IWin32Window)
When implemented by a class, initializes and runs a modal dialog box allowing you to search for some text.
Public method DisplayReplaceDialog
When implemented by a class, initializes and runs a dialog box allowing you to search for text and replace it.
Public method DisplayReplaceDialog(IWin32Window)
When implemented by a class, initializes and runs a dialog box allowing you to search for text and replace it.
Public method DisplaySearchDialog
When implemented by a class, initializes and runs a dialog box allowing you to search for some text.
Public method DisplaySearchDialog(IWin32Window)
When implemented by a class, initializes and runs a dialog box allowing you to search for some text.
Public method DisplayToScreen(Int32, Int32)
When implemented by a class, converts given display coordinates, index of line and character, to screen coordinates.
Public method DisplayToScreen(Int32, Int32, Boolean)
When implemented by a class, converts given display coordinates, index of line and character, to screen coordinates.
Public method EnablePositionUpdate
When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
(Inherited from INavigate.)
Public method EnableUpdate
When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from IUpdate.)
Public method EndUpdate
When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method.
(Inherited from IUpdate.)
Public method Find(String)
When implemented by a class, searches for given text within the control's contents.
(Inherited from ISearch.)
Public method Find(String, SearchOptions)
When implemented by a class, searches for given text within the control's contents with specified options.
(Inherited from ISearch.)
Public method Find(String, SearchOptions, Regex)
When implemented by a class, searches for given text within the control's contents with specified options using specified regular expression.
(Inherited from ISearch.)
Public method Find(String, SearchOptions, Regex, IListIRange)
When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from ISearch.)
Public method Find(String, SearchOptions, Regex, Boolean, Boolean)
When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from ISearch.)
Public method Find(String, SearchOptions, Regex, Point, Int32, Match)
When implemented by a class, searches for given text within the control's text content.
(Inherited from ITextSearch.)
Public method FindForm
When implemented by a class, retrieves the form that the control is on.
(Inherited from IControl.)
Public method FindNext
When implemented by a class, searches for the next occurrence of the text specified by previous search.
(Inherited from ISearch.)
Public method FindNextSelected
When implemented by a class, searches for the next occurrence of the selected text.
(Inherited from ISearch.)
Public method FindPrevious
When implemented by a class, searches for the previous occurrence of the text specified by previous search.
(Inherited from ISearch.)
Public method FindPreviousSelected
When implemented by a class, searches for the previous occurrence of the selected text.
(Inherited from ISearch.)
Public method FinishIncrementalSearch
When implemented by a class, leaves control from the incremental search state.
(Inherited from ISearch.)
Public method Focus
When implemented by a class, sets input focus to the control.
(Inherited from IControl.)
Public method GetCaretSize
When implemented by a class, returns size of the caret's current shape at given position.
(Inherited from ICaret.)
Public method GetCharsInWidth
When implemented by a class, returns number of characters painted with current font that will fit into specified Width.
Public method GetHitTest(Point, IHitTestInfo)
When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method GetHitTest(Int32, Int32, IHitTestInfo)
When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method GetHitTestAtTextPoint(Point, IHitTestInfo)
When implemented by a class, fills hitTestInfo parameter by information about a part of control at specified text coordinate.
Public method GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo)
When implemented by a class, retrieves information about part of control at specified text coordinate.
Public method GetIndentString
When implemented by a class, gets indentation string at current position.
(Inherited from IEdit.)
Public method GetLinesInHeight
When implemented by a class, determines how many lines can fit into given Height.
Public method GetTextAtCursor
When implemented by a class, returns word at the cursor position.
Public method GetTextToSearchAtCursor
When implemented by a class, returns word at the cursor position.
(Inherited from ISearch.)
Public method GetWrapMargin
When implemented by a class, returns position of the wrapping margin.
(Inherited from IWordWrap.)
Public method HasAutoCorrection
When implemented by a class, checks whether specified word has correction.
(Inherited from IAutoCorrect.)
Public method HideDragCaret
When implemented by a class, hides dragging caret.
(Inherited from ICaret.)
Public method HideScrollHint
When implemented by a class, hides scroll hint window if necessary.
Public method HighlightAll
When implemented by a class, highlights all occurrences of specified string in the class text content.
(Inherited from ISearch.)
Public method IncrementalSearch
When implemented by a class, finds given text incrementally.
(Inherited from ISearch.)
Public method IndentLine
When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
(Inherited from IEdit.)
Public method IndentLine(String, Boolean)
When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
(Inherited from IEdit.)
Public method Insert
When implemented by a class, inserts the given string at the specified location.
(Inherited from IEdit.)
Public method InsertBlock(String, Boolean)
When implemented by a class, inserts the given string at the specified location.
(Inherited from IEdit.)
Public method InsertBlock(String, Boolean)
When implemented by a class, inserts the given string array at the specified location.
(Inherited from IEdit.)
Public method InsertBlock(ITextStrings, Boolean)
When implemented by a class, inserts the given string collection at the specified location.
(Inherited from IEdit.)
Public method InsertBlock(String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.
(Inherited from IEdit.)
Public method InsertFromFile
When implemented by a class, inserts the file text content at the specified location.
(Inherited from IEdit.)
Public method Invalidate
When implemented by a class, invalidates the entire client area of the control.
(Inherited from IControl.)
Public method Invalidate(Rectangle)
When implemented by a class, invalidates a specific region of the control.
(Inherited from IControl.)
Public method Invalidate(Region)
When implemented by a class, invalidates a specific region of the control.
(Inherited from IControl.)
Public method Invalidate(Region, Boolean)
When implemented by a class, invalidates a specific region of the control.
(Inherited from IControl.)
Public method Invoke
When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle.
(Inherited from IControl.)
Public method IsValidText
When implemented by a class, indicates whether text at the specified position is valid (that is does not contain comments or string constants).
(Inherited from ICodeCompletion.)
Public method KillFocus
When implemented by a class, ensure the caret is not visible.
(Inherited from ICaret.)
Public method LineIsHidden
When implemented by a class, determines whether the given line is hidden.
(Inherited from IEdit.)
Public method LineIsReadonly
When implemented by a class, determines whether the given line is readonly.
(Inherited from IEdit.)
Public method ListMembers
When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content.
(Inherited from ICodeCompletion.)
Public method LoadFile(String)
When implemented by a class, loads the contents of the specified file.
(Inherited from IImport.)
Public method LoadFile(String, IStringImport)
When implemented by a class, loads content from the given file with specified importer.
(Inherited from ITextImport.)
Public method LoadFile(String, Encoding)
When implemented by a class, loads the contents of the specified file with specified encoding.
(Inherited from IImport.)
Public method LoadFile(String, IStringImport, Encoding)
When implemented by a class, loads content from the given file with specified importer and specific encoding.
(Inherited from ITextImport.)
Public method LoadMacros(Stream)
When implemented by a class, loads the macro records from the given stream.
(Inherited from IRecordPlayBack.)
Public method LoadMacros(TextReader)
When implemented by a class, loads the macro records from the given stream.
(Inherited from IRecordPlayBack.)
Public method LoadMacros(String)
When implemented by a class, loads the macro records from the given file.
(Inherited from IRecordPlayBack.)
Public method LoadStream(Stream)
When implemented by a class, loads the contents of the specified stream.
(Inherited from IImport.)
Public method LoadStream(TextReader)
When implemented by a class, loads the contents of the specified stream.
(Inherited from IImport.)
Public method LoadStream(Stream, IStringImport)
When implemented by a class, loads the text content from the given stream with specified importer.
(Inherited from ITextImport.)
Public method LoadStream(TextReader, IStringImport)
When implemented by a class, loads the text content from the given stream with specified importer.
(Inherited from ITextImport.)
Public method LoadStream(Stream, Encoding)
When implemented by a class, loads the contents of the specified stream.
(Inherited from IImport.)
Public method LoadStream(Stream, IStringImport, Encoding)
When implemented by a class, loads the text content from the given stream with specified importer.
(Inherited from ITextImport.)
Public method MakeVisible(Point)
When implemented by a class, scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method MakeVisible(Point, Boolean)
When implemented by a class, scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method MarkAll(String, Boolean)
When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from ISearch.)
Public method MarkAll(String, SearchOptions, Boolean)
When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from ISearch.)
Public method MarkAll(String, SearchOptions, Regex, Boolean)
When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from ISearch.)
Public method MoveCaretOnDrag
When implemented by a class, moves caret to the position of drag cursor.
Public method MoveCharLeft
When implemented by a class, moves the current position one character to the left.
(Inherited from IEditNavigate.)
Public method MoveCharRight
When implemented by a class, moves the current position one character to the right.
(Inherited from IEditNavigate.)
Public method MoveFileBegin
When implemented by a class, moves the current position to the first character of the first line.
(Inherited from IEditNavigate.)
Public method MoveFileEnd
When implemented by a class, moves the current position to the last character of the last line.
(Inherited from IEditNavigate.)
Public method MoveLineBegin
When implemented by a class, moves the current position to the first character of current line.
(Inherited from IEditNavigate.)
Public method MoveLineBeginCycled
When implemented by a class, moves the current position to the first not whitespace character/first character of current line.
(Inherited from IEditNavigate.)
Public method MoveLineDown
When implemented by a class, moves the current position to the next line.
(Inherited from IEditNavigate.)
Public method MoveLineEnd
When implemented by a class, moves the current position to the last character of current line.
(Inherited from IEditNavigate.)
Public method MoveLineEndCycled
When implemented by a class, moves the current position to the last not whitespace character/last character of current line.
(Inherited from IEditNavigate.)
Public method MoveLineUp
When implemented by a class, moves the current position to the previous line.
(Inherited from IEditNavigate.)
Public method MovePageDown
When implemented by a class, moves current position to the next page.
(Inherited from IEditNavigate.)
Public method MovePageUp
When implemented by a class, moves current position to the previous page.
(Inherited from IEditNavigate.)
Public method MoveScreenBottom
When implemented by a class, moves the current position to the bottom of the screen.
(Inherited from IEditNavigate.)
Public method MoveScreenTop
When implemented by a class, moves the current position to the top of the screen.
(Inherited from IEditNavigate.)
Public method MoveTo(Point)
When implemented by a class, moves the current position to the given position.
(Inherited from INavigate.)
Public method MoveTo(Int32, Int32)
When implemented by a class, moves the current position to the given position.
(Inherited from INavigate.)
Public method MoveToBrace
When implemented by a class, moves the current position to the next open or close brace in the text content.
(Inherited from IEditNavigate.)
Public method MoveToChar
When implemented by a class, moves the current position to the specified character in the current line.
(Inherited from INavigate.)
Public method MoveToCloseBrace
When implemented by a class, moves the current position to the next close brace in the text content.
(Inherited from IEditNavigate.)
Public method MoveToLine(Int32)
When implemented by a class, moves the current position to the specified line.
(Inherited from INavigate.)
Public method MoveToLine(Int32, Int32)
When implemented by a class, moves the current position to the specified line.
(Inherited from INavigate.)
Public method MoveToOpenBrace
When implemented by a class, moves the current position to the prev open brace in the text content.
(Inherited from IEditNavigate.)
Public method MoveWordLeft
When implemented by a class, moves the current position one word to the left.
(Inherited from IEditNavigate.)
Public method MoveWordRight
When implemented by a class, moves the current position one word to the right.
(Inherited from IEditNavigate.)
Public method Navigate
When implemented by a class, moves current position by the given offset value.
(Inherited from INavigate.)
Public method NeedReplaceCurrent
When implemented by a class, indicates whether search engine need to replace successfully found and selected text.
(Inherited from ISearch.)
Public method NewLine
When implemented by a class, inserts a line break at the current position.
(Inherited from IEdit.)
Public method NewLine(String, Boolean)
When implemented by a class, inserts a line break at the current position with indentation.
(Inherited from IEdit.)
Public method NewLineAbove
When implemented by a class, inserts a line break above the current position.
(Inherited from IEdit.)
Public method NewLineBelow
When implemented by a class, inserts a line break below the current position.
(Inherited from IEdit.)
Public method Notification
When implemented by a class, updates control's content according to the parameters of notification.
(Inherited from INotifier.)
Public method OnStateChanged
When implemented by a class, updates editor control's content according to the parameters of notification.
(Inherited from IEditNotifier.)
Public method OnTextFound
When implemented by a class, occurs when search text is found.
(Inherited from ISearch.)
Public method ParameterInfo
When implemented by a class, displays a code completion window containing information for the current method or parameter in the Editor's content.
(Inherited from ICodeCompletion.)
Public method PauseMacroRecording
When implemented by a class, suspends recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method PlayBackMacro
When implemented by a class, repeats the stored command sequence.
(Inherited from IRecordPlayBack.)
Public method PointToClient
When implemented by a class, computes the location of the specified screen point into client coordinates.
(Inherited from IControl.)
Public method PointToScreen
When implemented by a class, computes the location of the specified client point into screen coordinates.
(Inherited from IControl.)
Public method PositionIsReadonly
When implemented by a class, determines whether the text at given position is readonly.
(Inherited from IEdit.)
Public method ProcessEnter
When implemented by a class, performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from IEditNavigate.)
Public method ProcessKeyMsg
When implemented by a class, processes a keyboard message.
Public method ProcessKeyPress
When implemented by a class, processes key press.
Public method ProcessShiftTab
When implemented by a class, performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from IEditNavigate.)
Public method ProcessTab
When implemented by a class, performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from IEditNavigate.)
Public method QuickInfo
When implemented by a class, displays a code completion window with simple tooltip information.
(Inherited from ICodeCompletion.)
Public method RecordKeyData
When implemented by a class, adds keyData to the MacroRecords array.
(Inherited from IRecordPlayBack.)
Public method Refresh
When implemented by a class, causes the control to redraw the invalidated regions within its client area.
(Inherited from IControl.)
Public method Replace(String, String)
When implemented by a class, searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
(Inherited from ISearch.)
Public method Replace(String, String, SearchOptions)
When implemented by a class, searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
(Inherited from ISearch.)
Public method Replace(String, String, SearchOptions, Regex)
When implemented by a class, searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
(Inherited from ISearch.)
Public method ReplaceAll(String, String, Int32)
When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from ISearch.)
Public method ReplaceAll(String, String, SearchOptions, Int32)
When implemented by a class, replaces all occurrences of given text within text content by specified replaceWith string.
(Inherited from ISearch.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32)
When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from ISearch.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean)
When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from ISearch.)
Public method ReplaceCurrent
When implemented by a class, replaces currently selected text.
(Inherited from ISearch.)
Public method ResetAcceptReturns
When implemented by a class, resets the AcceptReturns to the default value.
Public method ResetAcceptTabs
When implemented by a class, resets the AcceptTabs to the default value.
Public method ResetBorderColor
When implemented by a class, resets the BorderColor to the default value.
Public method ResetBorderStyle
When implemented by a class, resets the BorderStyle to the default value.
Public method ResetHideCaret
When implemented by a class, resets the HideCaret to the default value.
(Inherited from ICaret.)
Public method ResetIndentOptions
When implemented by a class, resets the IndentOptions to the default value.
(Inherited from IEdit.)
Public method ResetKeepCaretOnLostFocus
When implemented by a class, resets the KeepCaretOnLostFocus to the default value.
(Inherited from ICaret.)
Public method ResetLineSpace
When implemented by a class, resets the LineSpace to the default value.
Public method ResetMaxLength
When implemented by a class, resets the MaxLength to the default value.
(Inherited from IEdit.)
Public method ResetModified
When implemented by a class, resets the Modified to the default value.
(Inherited from IEdit.)
Public method ResetNavigateOptions
When implemented by a class, resets the NavigateOptions to the default value.
(Inherited from INavigate.)
Public method ResetOverWrite
When implemented by a class, resets the OverWrite to the default value.
(Inherited from IEdit.)
Public method ResetReadOnly
When implemented by a class, resets the Readonly to the default value.
(Inherited from IEdit.)
Public method ResetSingleLineMode
When implemented by a class, resets the SingleLineMode to the default value.
(Inherited from IEdit.)
Public method ResetWordWrap
When implemented by a class, resets the WordWrap to the default value.
(Inherited from IWordWrap.)
Public method ResetWrapAtMargin
When implemented by a class, resets the WrapAtMargin to the default value.
(Inherited from IWordWrap.)
Public method RestorePosition
When implemented by a class, restores position from stored position list by given index.
(Inherited from INavigate.)
Public method RestorePositionWithUndo
When implemented by a class, restores position from stored position list by given index.
(Inherited from INavigate.)
Public method ResumeMacroRecording
When implemented by a class, resumes recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method SaveFile(String)
When implemented by a class, saves text content to the specific file.
(Inherited from IExport.)
Public method SaveFile(String, IStringExport)
When implemented by a class, saves content to the given file with specified exporter.
(Inherited from ITextExport.)
Public method SaveFile(String, Encoding)
When implemented by a class, saves text content to the specific file with specific encoding.
(Inherited from IExport.)
Public method SaveFile(String, IStringExport, Encoding)
When implemented by a class, saves content to the given file with specified exported and specific encoding.
(Inherited from ITextExport.)
Public method SaveMacros(Stream)
When implemented by a class, saves the macro records to the given stream in xml format.
(Inherited from IRecordPlayBack.)
Public method SaveMacros(TextWriter)
When implemented by a class, saves the macro records to the given stream in xml format.
(Inherited from IRecordPlayBack.)
Public method SaveMacros(String)
When implemented by a class, saves the macro records to the given file in xml format.
(Inherited from IRecordPlayBack.)
Public method SaveStream(Stream)
When implemented by a class, saves the text content to the specified stream.
(Inherited from IExport.)
Public method SaveStream(TextWriter)
When implemented by a class, saves the text content to the specified stream.
(Inherited from IExport.)
Public method SaveStream(Stream, IStringExport)
When implemented by a class, saves the text content to the given stream with specified exporter.
(Inherited from ITextExport.)
Public method SaveStream(TextWriter, IStringExport)
When implemented by a class, saves the text content to the given stream with specified exporter.
(Inherited from ITextExport.)
Public method SaveStream(Stream, Encoding)
When implemented by a class, saves the text content to the specified stream.
(Inherited from IExport.)
Public method SaveStream(Stream, IStringExport, Encoding)
When implemented by a class, saves the text content to the given stream with specified exporter.
(Inherited from ITextExport.)
Public method ScreenToDisplay
When implemented by a class, converts given screen coordinates to display coordinates(index of line and character).
Public method ScreenToDisplayX
When implemented by a class, converts given screen coordinates to display coordinate of a character.
Public method ScreenToText(Point)
When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).
Public method ScreenToText(Int32, Int32)
When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).
Public method ScreenToText(Int32, Int32, Boolean)
When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).
Public method ScrollLineDown
When implemented by a class, scrolls text content one line down.
(Inherited from IEditNavigate.)
Public method ScrollLineUp
When implemented by a class, scrolls text content one line up.
(Inherited from IEditNavigate.)
Public method SetLineHidden(Int32, Boolean)
When implemented by a class, sets hidden state for the given line.
(Inherited from IEdit.)
Public method SetLineHidden(Int32, Boolean)
When implemented by a class, sets hidden state for the given line.
(Inherited from IEdit.)
Public method SetLineReadonly(Int32, Boolean)
When implemented by a class, sets readonly state for the given line.
(Inherited from IEdit.)
Public method SetLineReadonly(Int32, Boolean)
When implemented by a class, sets readonly state for the given line.
(Inherited from IEdit.)
Public method SetNavigateOptions
When implemented by a class, sets navigating options without validating position.
(Inherited from INavigate.)
Public method ShowCaret
When implemented by a class, moves the caret to the specified coordinates.
(Inherited from ICaret.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType)
When implemented by a class, shows code completion popup window with given provider at the current position.
(Inherited from ICodeCompletion.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point)
When implemented by a class, shows code completion popup window with given Provider at the specified position.
(Inherited from ICodeCompletion.)
Public method ShowCodeCompletionButton
When implemented by a class, shows code completion popup window with given Provider at the specified position.
(Inherited from ICodeCompletion.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, ILexer)
When implemented by a class, displays ICodeCompletionHint with given provider at the current position.
(Inherited from ICodeCompletion.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer)
When implemented by a class, displays ICodeCompletionHint with given provider at the specified position.
(Inherited from ICodeCompletion.)
Public method ShowNotFound
When implemented by a class, displays "searched text not found" message box.
(Inherited from ISearch.)
Public method ShowScrollHint
When implemented by a class, displays tooltip indicating destination line when scrolling.
Public method SplitViewHorz
When implemented by a class, splits its content horizontally.
(Inherited from ISplitView.)
Public method SplitViewVert
When implemented by a class, splits its content vertically.
(Inherited from ISplitView.)
Public method StartIncrementalSearch
When implemented by a class, enters control to the incremental search state.
(Inherited from ISearch.)
Public method StartIncrementalSearch(Boolean)
When implemented by a class, enters control to the incremental search state.
(Inherited from ISearch.)
Public method StartMacroRecording
When implemented by a class, starts recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method StopMacroRecording
When implemented by a class, stops recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method StorePosition(Point)
When implemented by a class, stores given position to stored position list.
(Inherited from INavigate.)
Public method StorePosition(Point, Boolean)
When implemented by a class, stores given position to stored position list.
(Inherited from INavigate.)
Public method StorePositionWithUndo
When implemented by a class, stores given position to stored position list preserving it for undo.
(Inherited from INavigate.)
Public method TextToScreen(Point)
When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.
Public method TextToScreen(Point, Boolean)
When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.
Public method TextToScreen(Int32, Int32)
When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.
Public method ToggleMacroRecording
When implemented by a class, toggles recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method UnBreakLine
When implemented by a class, concatenates lines at current position.
(Inherited from IEdit.)
Public method UnhighlightAll
When implemented by a class, unhighlights search results previously highlighted by HighlightAll.
(Inherited from ISearch.)
Public method UnsplitViewHorz
When implemented by a class, removes horizontal split view.
(Inherited from ISplitView.)
Public method UnsplitViewVert
When implemented by a class, removes vertical split view.
(Inherited from ISplitView.)
Public method Update
When implemented by a class, updates an object state.
(Inherited from IUpdate.)
Public method UpdateCaret
When implemented by a class, ensures the caret is displayed in the current position.
(Inherited from ICaret.)
Public method UpdateView
When implemented by a class, updates editor content, caret and pages area.
Public method UpdateWordWrap
When implemented by a class, re-wraps all lines in the text.
(Inherited from IWordWrap.)
Public method UpdateWordWrap(Int32, Int32)
When implemented by a class, re-wraps lines in the text within specific scope.
(Inherited from IWordWrap.)
Public method ValidatePosition
When implemented by a class, validates given position within control's text content.
(Inherited from INavigate.)
Top
Properties
 | Name | Description
Public property | AcceptReturns | When implemented by a class, gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key.
Public property | AcceptTabs | When implemented by a class, gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key.
Public property | ActiveOutlineRange | When implemented by a class, gets currently highlighted outlined range.
Public property | AutoCorrectDelimiters | When implemented by a class, gets or sets an array of chars that used as word delimiters. (Inherited from IAutoCorrect.)
Public property | AutoCorrection | When implemented by a class, gets or sets a boolean value indicating whether to auto correct words being typed. (Inherited from IAutoCorrect.)
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | BorderColor | When implemented by a class, gets or sets the border color for the Edit control.
Public property | BorderStyle | When implemented by a class, gets or sets the border style for the Edit control.
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | Braces | When implemented by a class, represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control.
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | CharsInWidth | When implemented by a class, returns number of characters painted with current font that will fit into control's client area.
Public property | ClientArea | When implemented by a class, gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded.
Public property | ClientHeight | When implemented by a class, gets the width of the client area of the Edit control.
Public property | ClientRect | When implemented by a class, gets the rectangle that represents the client area of the Edit control.
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ClientWidth | When implemented by a class, gets the height of the client area of the Edit control.
Public property | CodeCompletionBox | When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of list. (Inherited from ICodeCompletion.)
Public property | CodeCompletionChars | When implemented by a class, represents a collection of characters that initializes a code completion procedure when typing in the editor. (Inherited from ICodeCompletion.)
Public property | CodeCompletionHint | When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of the tooltip. (Inherited from ICodeCompletion.)
Public property | CodeCompletionMode | When implemented by a class, gets or sets code completion box mode. (Inherited from ICodeCompletion.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | CurrentBlockRange | When implemented by a class, gets currently highlighted block range. (Inherited from ICaret.)
Public property | DisplayLines | When implemented by a class, represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control.
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | EditMargin | When implemented by a class, represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed.
Public property | EffectiveVisualTheme | Whem implemented by a class, gets current visual theme.
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | EventHandlers | When implemented by a class, represents object that holds EventHandlers containing list of keys with attached actions.
Public property | FirstSearch | When implemented by a class, gets or sets a value indicating whether control launches text search at first. (Inherited from ISearch.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | GotoLineDialog | When implemented by a class, gets or sets a dialog prompting for index of the line you need to locate. (Inherited from ISearch.)
Public property | Gutter | When implemented by a class, represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control.
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | HideCaret | When implemented by a class, gets or sets a value indicating whether the control should display caret when it has input focus. (Inherited from ICaret.)
Public property | HighlightCurrentBlock | When implemented by a class, specifies that edit control should highlight current block. (Inherited from ICaret.)
Public property | HighlightMatchingBlocks | When implemented by a class, specifies that edit control should highlight begin/end blocks.
Public property | HighlightReferences | When implemented by a class, specifies that edit control should highlight found references.
Public property | HighlightSearchResults | When implemented by a class, indicates whether search results are highlighted while the search dialog is open. (Inherited from ISearch.)
Public property | HorzSplitEdit | When implemented by a class, represents horizontal split view control. (Inherited from ISplitView.)
Public property | HorzSplitter | When implemented by a class, represents a horizontal Splitter control allowing to split Edit content horizontally. (Inherited from ISplitView.)
Public property | HyperText | When implemented by a class, represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control.
Public property | IncrementalSearchString | When implemented by a class, return text to search if class is in incremental search state; otherwise return empty string. (Inherited from ISearch.)
Public property | IndentOptions | When implemented by a class, gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from IEdit.)
Public property | InIncrementalSearch | When implemented by a class, indicates whether control is in incremental search state. (Inherited from ISearch.)
Public property | IsCodeCompletionWindowFocused | When implemented by a class, indicates whether ICodeCompletionWindow has focus. (Inherited from ICodeCompletion.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | IsSearchFocused | When implemented by a class, gets a boolean value indicating whether search dialog box has input focus.
Public property | KeepCaretOnLostFocus | When implemented by a class, keeps caret in visible state even Edit control lost focus. (Inherited from ICaret.)
Public property | KeyList | When implemented by a class, represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure.
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Lexer | When implemented by a class, gets or sets object that can make lexical analysis for the control's content.
Public property | Lines | When implemented by a class, represents object that implements ITextStrings interface containing collection of strings determining control's content.
Public property | LineSeparator | When implemented by a class, represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control.
Public property | LinesInHeight | When implemented by a class, determines how many lines can fit into control's client area.
Public property | LineSpace | When implemented by a class, gets or sets line space between individual lines in the Edit control.
Public property | LineStyles | When implemented by a class, represents an object that implements IEditLineStyles interface holding collection of ILineStyle objects each of them determines particular style of the line in the control.
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | MacroRecording | When implemented by a class, gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands. (Inherited from IRecordPlayBack.)
Public property | MacroRecords | When implemented by a class, represents an array containing keyboard commands. (Inherited from IRecordPlayBack.)
Public property | MacroSuspendend | When implemented by a class, gets or sets a boolean value indicating whether recording is suspended. (Inherited from IRecordPlayBack.)
Public property | MaxLength | When implemented by a class, specifies the maximum number of characters that can be entered into the edit control. (Inherited from IEdit.)
Public property | Modified | When implemented by a class, gets or sets a value indicating whether the control's text content is modified. (Inherited from IEdit.)
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options. (Inherited from INavigate.)
Public property | OpenSharedEditorFunc | When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment.
Public property | Outlining | When implementing by a class, represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control.
Public property | Overwrite | When implemented by a class, gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from IEdit.)
Public property | Pages | When implemented by a class, represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages.
Public property | Painter | When implemented by a class, represents an object that implements IPainter interface used to draw control's text.
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | Position | When implemented by a class, gets or sets current position within the control's text content. (Inherited from INavigate.)
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content. (Inherited from INavigate.)
Public property | Printing | When implemented by a class, represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options.
Public property | ReadOnly | When implemented by a class, gets or sets a value indicating whether the control's content is read-only. (Inherited from IEdit.)
Public property | Scrolling | When implemented by a class, represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control.
Public property | SearchDialog | When implemented by a class, gets or sets a dialog box allowing to search for the text or replace it. (Inherited from ISearch.)
Public property | SearchDialogAppearance | When implemented by a class, gets or sets search dialog appearance.
Public property | SearchGlobal | When implemented by a class, gets or sets a value indicating whether search should be global. (Inherited from ISearch.)
Public property | SearchLen | When implemented by a class, represents length of the last found text. (Inherited from ISearch.)
Public property | SearchOptions | When implemented by a class, gets or sets a value that defines search and replace options. (Inherited from ISearch.)
Public property | SearchPos | When implemented by a class, gets or sets a value that represents position of the last found text. (Inherited from ISearch.)
Public property | Selection | When implemented by a class, represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text.
Public property | SingleLineMode | When implemented by a class, gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from IEdit.)
Public property | Source | When implemented by a class, gets or sets an object that implements ITextSource interface containing an actual string data displayed by the control.
Public property | Spelling | When implemented by a class, represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words.
Public property | Strings | When implemented by a class, represents Lines property in the form of array of strings.
Public property | SyntaxPaint | When implemented by a class, represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Transparent | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw its background.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UseDefaultMenu | When implemented by a class, indicates whether edit control should use built in popup menu.
Public property | VertSplitEdit | When implemented by a class, represents an vertical split view control. (Inherited from ISplitView.)
Public property | VertSplitter | When implemented by a class, represents a vertical Splitter control allowing to split Edit content vertically. (Inherited from ISplitView.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | VisualTheme | When implemented by a class, gets or sets visual theme for the editor.
Public property | VisualThemeType | When implemented by a class, gets or sets visual theme type for the editor.
Public property | WhiteSpace | When implemented by a class, represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks.
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Public property | WordWrap | When implemented by a class, gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary. (Inherited from IWordWrap.)
Public property | WrapAtMargin | When implemented by a class, gets or sets a value indicating whether control automatically wraps words at margin position. (Inherited from IWordWrap.)
Public property | WrapMargin | When implemented by a class, gets position of the wrapping margin. (Inherited from IWordWrap.)
Top
Events
 | Name | Description
Public event | AutoCorrect | When implemented by a class, occurs when control tries to auto correct word being typed. (Inherited from IAutoCorrect.)
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Public event | ModifiedChanged | When implemented by a class, occurs when modified state is changed.
Public event | NeedCodeCompletion | When implemented by a class, occurs when code completion window is to be displayed. (Inherited from ICodeCompletion.)
Public event | PaintBackground | When implemented by a class, occurs when Edit control should paint its background in transparent mode.
Public event | PromptOnReplace | When implemented by a class, occurs when replace dialog prompts on replace action.
Public event | SourceChanged | When implemented by a class, occurs when source changes.
Public event | SourceStateChanged | When implemented by a class, occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc.
Public event | SplitHorz | When implemented by a class, occurs when user splits Edit control horizontally. (Inherited from ISplitView.)
Public event | SplitVert | When implemented by a class, occurs when user splits Edit control vertically. (Inherited from ISplitView.)
Public event | TextChanged | When implemented by a class, occurs when the TextEditor text changes. (Inherited from ISearch.)
Public event | UnsplitHorz | When implemented by a class, occurs when horizontal split view is removed. (Inherited from ISplitView.)
Public event | UnsplitVert | When implemented by a class, occurs when vertical split view is removed. (Inherited from ISplitView.)
Top
See Also

Reference

Alternet.Editor Namespace


ISyntaxEdit Methods

ISyntaxEdit Methods

The ISyntaxEdit type exposes the following members.

Methods
Name Description
Public method ApplyTheme
Whem implemented by a class, applies visual theme to the SyntaxEdit control.
Public method Assign
When implemented by a class, assigns most relevant properties from another ISyntaxEdit object.
Public method BeginUpdate
When implemented by a class, prevents object state updating until calling EndUpdate method.
(Inherited from IUpdate.)
Public method BreakLine
When implemented by a class, breaks current line into two lines.
(Inherited from IEdit.)
Public method BringToFront
When implemented by a class, brings the control to the front of the z-order.
(Inherited from IControl.)
Public method CanFindNext
When implemented by a class, indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
(Inherited from ISearch.)
Public method CanFindNextSelected
When implemented by a class, indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
(Inherited from ISearch.)
Public method CanFindPrevious
When implemented by a class, indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
(Inherited from ISearch.)
Public method CanFindPreviousSelected
When implemented by a class, indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
(Inherited from ISearch.)
Public method CanSearchSelection
When implemented by a class, returns whether search can be performed inside selection.
(Inherited from ISearch.)
Public method CanSplitHorz
When implemented by a class, indicates whether control can split its content horizontally.
(Inherited from ISplitView.)
Public method CanSplitVert
When implemented by a class, indicates whether control can split its content vertically.
(Inherited from ISplitView.)
Public method CanUnsplitHorz
When implemented by a class, indicates whether control has horizontal split view.
(Inherited from ISplitView.)
Public method CanUnsplitVert
When implemented by a class, indicates whether control has vertical split view.
(Inherited from ISplitView.)
Public method CodeCompletion
When implemented by a class, performs code completion for the specified text representing language element.
(Inherited from ICodeCompletion.)
Public method CodeCompletionWindowFocused
When implemented by a class, indicates whether ICodeCompletionWindow has focus.
(Inherited from ICodeCompletion.)
Public method CodeSnippets
When implemented by a class, displays a code completion window with list of available code snippets.
(Inherited from ICodeCompletion.)
Public method CompleteCodeFixes
When implemented by a class, displays a code completion window with list of available code fixes.
(Inherited from ICodeCompletion.)
Public method CompleteCodeFixesOrRefactors
When implemented by a class, displays a code completion window with list of available code fixes or code refactors.
(Inherited from ICodeCompletion.)
Public method CompleteCodeRefactors
When implemented by a class, displays a code completion window with list of available code refactors.
(Inherited from ICodeCompletion.)
Public method CompleteWord
When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content and locates single member, if possible.
(Inherited from ICodeCompletion.)
Public method CreateCaret
When implemented by a class, creates a new shape for the system caret and gets ownership of the caret.
(Inherited from ICaret.)
Public method CreateGraphics
When implemented by a class, creates the Graphics for the control.
(Inherited from IControl.)
Public method CycledSearch
When implemented by a class, performs cycled search.
(Inherited from ISearch.)
Public method DeleteBlock
When implemented by a class, deletes a specified block of characters.
(Inherited from IEdit.)
Public method DeleteLeft
When implemented by a class, deletes a specified number of characters to the left of the active point.
(Inherited from IEdit.)
Public method DeleteRight
When implemented by a class, deletes a specified number of characters to the right of the active point.
(Inherited from IEdit.)
Public method DestroyCaret
When implemented by a class, destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
(Inherited from ICaret.)
Public method DisablePositionUpdate
When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method.
(Inherited from INavigate.)
Public method DisableUpdate
When implemented by a class, prevents object state updating until calling EnableUpdate method.
(Inherited from IUpdate.)
Public method DisplayDragCaret
When implemented by a class, displays dragging caret rather than regular caret.
(Inherited from ICaret.)
Public method DisplayGotoLineDialog
When implemented by a class, initializes and runs a dialog prompting you for index of the line you need to locate.
Public method DisplayGotoLineDialog(IWin32Window)
When implemented by a class, initializes and runs a dialog prompting you for index of the line you need to locate.
Public method DisplayModalReplaceDialog
When implemented by a class, initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method DisplayModalReplaceDialog(IWin32Window)
When implemented by a class, initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method DisplayModalSearchDialog
When implemented by a class, initializes and runs a modal dialog box allowing you to search for some text.
Public method DisplayModalSearchDialog(IWin32Window)
When implemented by a class, initializes and runs a modal dialog box allowing you to search for some text.
Public method DisplayReplaceDialog
When implemented by a class, initializes and runs a dialog box allowing you to search for text and replace it.
Public method DisplayReplaceDialog(IWin32Window)
When implemented by a class, initializes and runs a dialog box allowing you to search for text and replace it.
Public method DisplaySearchDialog
When implemented by a class, initializes and runs a dialog box allowing you to search for some text.
Public method DisplaySearchDialog(IWin32Window)
When implemented by a class, initializes and runs a dialog box allowing you to search for some text.
Public method DisplayToScreen(Int32, Int32)
When implemented by a class, converts given display coordinates, index of line and character, to screen coordinates.
Public method DisplayToScreen(Int32, Int32, Boolean)
When implemented by a class, converts given display coordinates, index of line and character, to screen coordinates.
Public method EnablePositionUpdate
When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
(Inherited from INavigate.)
Public method EnableUpdate
When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from IUpdate.)
Public method EndUpdate
When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method.
(Inherited from IUpdate.)
Public method Find(String)
When implemented by a class, searches for given text within the control's contents.
(Inherited from ISearch.)
Public method Find(String, SearchOptions)
When implemented by a class, searches for given text within the control's contents with specified options.
(Inherited from ISearch.)
Public method Find(String, SearchOptions, Regex)
When implemented by a class, searches for given text within the control's contents with specified options using specified regular expression.
(Inherited from ISearch.)
Public method Find(String, SearchOptions, Regex, IListIRange)
When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from ISearch.)
Public method Find(String, SearchOptions, Regex, Boolean, Boolean)
When implemented by a class, searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from ISearch.)
Public method Find(String, SearchOptions, Regex, Point, Int32, Match)
When implemented by a class, searches for given text within the control's text content.
(Inherited from ITextSearch.)
Public method FindForm
When implemented by a class, retrieves the form that the control is on.
(Inherited from IControl.)
Public method FindNext
When implemented by a class, searches for the next occurrence of the text specified by previous search.
(Inherited from ISearch.)
Public method FindNextSelected
When implemented by a class, searches for the next occurrence of the selected text.
(Inherited from ISearch.)
Public method FindPrevious
When implemented by a class, searches for the previous occurrence of the text specified by previous search.
(Inherited from ISearch.)
Public method FindPreviousSelected
When implemented by a class, searches for the previous occurrence of the selected text.
(Inherited from ISearch.)
Public method FinishIncrementalSearch
When implemented by a class, leaves control from the incremental search state.
(Inherited from ISearch.)
Public method Focus
When implemented by a class, sets input focus to the control.
(Inherited from IControl.)
Public method GetCaretSize
When implemented by a class, returns size of the caret's current shape at given position.
(Inherited from ICaret.)
Public method GetCharsInWidth
When implemented by a class, returns number of characters painted with current font that will fit into specified Width.
Public method GetHitTest(Point, IHitTestInfo)
When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method GetHitTest(Int32, Int32, IHitTestInfo)
When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method GetHitTestAtTextPoint(Point, IHitTestInfo)
When implemented by a class, fills hitTestInfo parameter by information about a part of control at specified text coordinate.
Public method GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo)
When implemented by a class, retrieves information about part of control at specified text coordinate.
Public method GetIndentString
When implemented by a class, gets indentation string at current position.
(Inherited from IEdit.)
Public method GetLinesInHeight
When implemented by a class, determines how many lines can fit into given Height.
Public method GetTextAtCursor
When implemented by a class, returns word at the cursor position.
Public method GetTextToSearchAtCursor
When implemented by a class, returns word at the cursor position.
(Inherited from ISearch.)
Public method GetWrapMargin
When implemented by a class, returns position of the wrapping margin.
(Inherited from IWordWrap.)
Public method HasAutoCorrection
When implemented by a class, checks whether specified word has correction.
(Inherited from IAutoCorrect.)
Public method HideDragCaret
When implemented by a class, hides dragging caret.
(Inherited from ICaret.)
Public method HideScrollHint
When implemented by a class, hides scroll hint window if necessary.
Public method HighlightAll
When implemented by a class, highlights all occurrences of specified string in the class text content.
(Inherited from ISearch.)
Public method IncrementalSearch
When implemented by a class, finds given text incrementally.
(Inherited from ISearch.)
Public method IndentLine
When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
(Inherited from IEdit.)
Public method IndentLine(String, Boolean)
When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
(Inherited from IEdit.)
Public method Insert
When implemented by a class, inserts the given string at the specified location.
(Inherited from IEdit.)
Public method InsertBlock(String, Boolean)
When implemented by a class, inserts the given string at the specified location.
(Inherited from IEdit.)
Public method InsertBlock(String, Boolean)
When implemented by a class, inserts the given string array at the specified location.
(Inherited from IEdit.)
Public method InsertBlock(ITextStrings, Boolean)
When implemented by a class, inserts the given string collection at the specified location.
(Inherited from IEdit.)
Public method InsertBlock(String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.
(Inherited from IEdit.)
Public method InsertFromFile
When implemented by a class, inserts the file text content at the specified location.
(Inherited from IEdit.)
Public method Invalidate
When implemented by a class, invalidates the entire client area of the control.
(Inherited from IControl.)
Public method Invalidate(Rectangle)
When implemented by a class, invalidates a specific region of the control.
(Inherited from IControl.)
Public method Invalidate(Region)
When implemented by a class, invalidates a specific region of the control.
(Inherited from IControl.)
Public method Invalidate(Region, Boolean)
When implemented by a class, invalidates a specific region of the control.
(Inherited from IControl.)
Public method Invoke
When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle.
(Inherited from IControl.)
Public method IsValidText
When implemented by a class, indicates whether text at the specified position is valid (that is does not contain comments or string constants).
(Inherited from ICodeCompletion.)
Public method KillFocus
When implemented by a class, ensure the caret is not visible.
(Inherited from ICaret.)
Public method LineIsHidden
When implemented by a class, determines whether the given line is hidden.
(Inherited from IEdit.)
Public method LineIsReadonly
When implemented by a class, determines whether the given line is readonly.
(Inherited from IEdit.)
Public method ListMembers
When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content.
(Inherited from ICodeCompletion.)
Public method LoadFile(String)
When implemented by a class, loads the contents of the specified file.
(Inherited from IImport.)
Public method LoadFile(String, IStringImport)
When implemented by a class, loads content from the given file with specified importer.
(Inherited from ITextImport.)
Public method LoadFile(String, Encoding)
When implemented by a class, loads the contents of the specified file with specified encoding.
(Inherited from IImport.)
Public method LoadFile(String, IStringImport, Encoding)
When implemented by a class, loads content from the given file with specified importer and specific encoding.
(Inherited from ITextImport.)
Public method LoadMacros(Stream)
When implemented by a class, loads the macro records from the given stream.
(Inherited from IRecordPlayBack.)
Public method LoadMacros(TextReader)
When implemented by a class, loads the macro records from the given stream.
(Inherited from IRecordPlayBack.)
Public method LoadMacros(String)
When implemented by a class, loads the macro records from the given file.
(Inherited from IRecordPlayBack.)
Public method LoadStream(Stream)
When implemented by a class, loads the contents of the specified stream.
(Inherited from IImport.)
Public method LoadStream(TextReader)
When implemented by a class, loads the contents of the specified stream.
(Inherited from IImport.)
Public method LoadStream(Stream, IStringImport)
When implemented by a class, loads the text content from the given stream with specified importer.
(Inherited from ITextImport.)
Public method LoadStream(TextReader, IStringImport)
When implemented by a class, loads the text content from the given stream with specified importer.
(Inherited from ITextImport.)
Public method LoadStream(Stream, Encoding)
When implemented by a class, loads the contents of the specified stream.
(Inherited from IImport.)
Public method LoadStream(Stream, IStringImport, Encoding)
When implemented by a class, loads the text content from the given stream with specified importer.
(Inherited from ITextImport.)
Public method MakeVisible(Point)
When implemented by a class, scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method MakeVisible(Point, Boolean)
When implemented by a class, scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method MarkAll(String, Boolean)
When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from ISearch.)
Public method MarkAll(String, SearchOptions, Boolean)
When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from ISearch.)
Public method MarkAll(String, SearchOptions, Regex, Boolean)
When implemented by a class, marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from ISearch.)
Public method MoveCaretOnDrag
When implemented by a class, moves caret to the position of drag cursor.
Public method MoveCharLeft
When implemented by a class, moves the current position one character to the left.
(Inherited from IEditNavigate.)
Public method MoveCharRight
When implemented by a class, moves the current position one character to the right.
(Inherited from IEditNavigate.)
Public method MoveFileBegin
When implemented by a class, moves the current position to the first character of the first line.
(Inherited from IEditNavigate.)
Public method MoveFileEnd
When implemented by a class, moves the current position to the last character of the last line.
(Inherited from IEditNavigate.)
Public method MoveLineBegin
When implemented by a class, moves the current position to the first character of current line.
(Inherited from IEditNavigate.)
Public method MoveLineBeginCycled
When implemented by a class, moves the current position to the first not whitespace character/first character of current line.
(Inherited from IEditNavigate.)
Public method MoveLineDown
When implemented by a class, moves the current position to the next line.
(Inherited from IEditNavigate.)
Public method MoveLineEnd
When implemented by a class, moves the current position to the last character of current line.
(Inherited from IEditNavigate.)
Public method MoveLineEndCycled
When implemented by a class, moves the current position to the last not whitespace character/last character of current line.
(Inherited from IEditNavigate.)
Public method MoveLineUp
When implemented by a class, moves the current position to the previous line.
(Inherited from IEditNavigate.)
Public method MovePageDown
When implemented by a class, moves current position to the next page.
(Inherited from IEditNavigate.)
Public method MovePageUp
When implemented by a class, moves current position to the previous page.
(Inherited from IEditNavigate.)
Public method MoveScreenBottom
When implemented by a class, moves the current position to the bottom of the screen.
(Inherited from IEditNavigate.)
Public method MoveScreenTop
When implemented by a class, moves the current position to the top of the screen.
(Inherited from IEditNavigate.)
Public method MoveTo(Point)
When implemented by a class, moves the current position to the given position.
(Inherited from INavigate.)
Public method MoveTo(Int32, Int32)
When implemented by a class, moves the current position to the given position.
(Inherited from INavigate.)
Public method MoveToBrace
When implemented by a class, moves the current position to the next open or close brace in the text content.
(Inherited from IEditNavigate.)
Public method MoveToChar
When implemented by a class, moves the current position to the specified character in the current line.
(Inherited from INavigate.)
Public method MoveToCloseBrace
When implemented by a class, moves the current position to the next close brace in the text content.
(Inherited from IEditNavigate.)
Public method MoveToLine(Int32)
When implemented by a class, moves the current position to the specified line.
(Inherited from INavigate.)
Public method MoveToLine(Int32, Int32)
When implemented by a class, moves the current position to the specified line.
(Inherited from INavigate.)
Public method MoveToOpenBrace
When implemented by a class, moves the current position to the prev open brace in the text content.
(Inherited from IEditNavigate.)
Public method MoveWordLeft
When implemented by a class, moves the current position one word to the left.
(Inherited from IEditNavigate.)
Public method MoveWordRight
When implemented by a class, moves the current position one word to the right.
(Inherited from IEditNavigate.)
Public method Navigate
When implemented by a class, moves current position by the given offset value.
(Inherited from INavigate.)
Public method NeedReplaceCurrent
When implemented by a class, indicates whether search engine need to replace successfully found and selected text.
(Inherited from ISearch.)
Public method NewLine
When implemented by a class, inserts a line break at the current position.
(Inherited from IEdit.)
Public method NewLine(String, Boolean)
When implemented by a class, inserts a line break at the current position with indentation.
(Inherited from IEdit.)
Public method NewLineAbove
When implemented by a class, inserts a line break above the current position.
(Inherited from IEdit.)
Public method NewLineBelow
When implemented by a class, inserts a line break below the current position.
(Inherited from IEdit.)
Public method Notification
When implemented by a class, updates control's content according to the parameters of notification.
(Inherited from INotifier.)
Public method OnStateChanged
When implemented by a class, updates editor control's content according to the parameters of notification.
(Inherited from IEditNotifier.)
Public method OnTextFound
When implemented by a class, occurs when search text is found.
(Inherited from ISearch.)
Public method ParameterInfo
When implemented by a class, displays a code completion window containing information for the current method or parameter in the Editor's content.
(Inherited from ICodeCompletion.)
Public method PauseMacroRecording
When implemented by a class, suspends recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method PlayBackMacro
When implemented by a class, repeats the stored command sequence.
(Inherited from IRecordPlayBack.)
Public method PointToClient
When implemented by a class, computes the location of the specified screen point into client coordinates.
(Inherited from IControl.)
Public method PointToScreen
When implemented by a class, computes the location of the specified client point into screen coordinates.
(Inherited from IControl.)
Public method PositionIsReadonly
When implemented by a class, determines whether the text at given position is readonly.
(Inherited from IEdit.)
Public method ProcessEnter
When implemented by a class, performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from IEditNavigate.)
Public method ProcessKeyMsg
When implemented by a class, processes a keyboard message.
Public method ProcessKeyPress
When implemented by a class, processes key press.
Public method ProcessShiftTab
When implemented by a class, performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from IEditNavigate.)
Public method ProcessTab
When implemented by a class, performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from IEditNavigate.)
Public method QuickInfo
When implemented by a class, displays a code completion window with simple tooltip information.
(Inherited from ICodeCompletion.)
Public method RecordKeyData
When implemented by a class, adds keyData to the MacroRecords array.
(Inherited from IRecordPlayBack.)
Public method Refresh
When implemented by a class, causes the control to redraw the invalidated regions within its client area.
(Inherited from IControl.)
Public method Replace(String, String)
When implemented by a class, searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
(Inherited from ISearch.)
Public method Replace(String, String, SearchOptions)
When implemented by a class, searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
(Inherited from ISearch.)
Public method Replace(String, String, SearchOptions, Regex)
When implemented by a class, searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
(Inherited from ISearch.)
Public method ReplaceAll(String, String, Int32)
When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from ISearch.)
Public method ReplaceAll(String, String, SearchOptions, Int32)
When implemented by a class, replaces all occurrences of given text within text content by specified replaceWith string.
(Inherited from ISearch.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32)
When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from ISearch.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean)
When implemented by a class, replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from ISearch.)
Public method ReplaceCurrent
When implemented by a class, replaces currently selected text.
(Inherited from ISearch.)
Public method ResetAcceptReturns
When implemented by a class, resets the AcceptReturns to the default value.
Public method ResetAcceptTabs
When implemented by a class, resets the AcceptTabs to the default value.
Public method ResetBorderColor
When implemented by a class, resets the BorderColor to the default value.
Public method ResetBorderStyle
When implemented by a class, resets the BorderStyle to the default value.
Public method ResetHideCaret
When implemented by a class, resets the HideCaret to the default value.
(Inherited from ICaret.)
Public method ResetIndentOptions
When implemented by a class, resets the IndentOptions to the default value.
(Inherited from IEdit.)
Public method ResetKeepCaretOnLostFocus
When implemented by a class, resets the KeepCaretOnLostFocus to the default value.
(Inherited from ICaret.)
Public method ResetLineSpace
When implemented by a class, resets the LineSpace to the default value.
Public method ResetMaxLength
When implemented by a class, resets the MaxLength to the default value.
(Inherited from IEdit.)
Public method ResetModified
When implemented by a class, resets the Modified to the default value.
(Inherited from IEdit.)
Public method ResetNavigateOptions
When implemented by a class, resets the NavigateOptions to the default value.
(Inherited from INavigate.)
Public method ResetOverWrite
When implemented by a class, resets the OverWrite to the default value.
(Inherited from IEdit.)
Public method ResetReadOnly
When implemented by a class, resets the Readonly to the default value.
(Inherited from IEdit.)
Public method ResetSingleLineMode
When implemented by a class, resets the SingleLineMode to the default value.
(Inherited from IEdit.)
Public method ResetWordWrap
When implemented by a class, resets the WordWrap to the default value.
(Inherited from IWordWrap.)
Public method ResetWrapAtMargin
When implemented by a class, resets the WrapAtMargin to the default value.
(Inherited from IWordWrap.)
Public method RestorePosition
When implemented by a class, restores position from stored position list by given index.
(Inherited from INavigate.)
Public method RestorePositionWithUndo
When implemented by a class, restores position from stored position list by given index.
(Inherited from INavigate.)
Public method ResumeMacroRecording
When implemented by a class, resumes recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method SaveFile(String)
When implemented by a class, saves text content to the specific file.
(Inherited from IExport.)
Public method SaveFile(String, IStringExport)
When implemented by a class, saves content to the given file with specified exporter.
(Inherited from ITextExport.)
Public method SaveFile(String, Encoding)
When implemented by a class, saves text content to the specific file with specific encoding.
(Inherited from IExport.)
Public method SaveFile(String, IStringExport, Encoding)
When implemented by a class, saves content to the given file with specified exported and specific encoding.
(Inherited from ITextExport.)
Public method SaveMacros(Stream)
When implemented by a class, saves the macro records to the given stream in xml format.
(Inherited from IRecordPlayBack.)
Public method SaveMacros(TextWriter)
When implemented by a class, saves the macro records to the given stream in xml format.
(Inherited from IRecordPlayBack.)
Public method SaveMacros(String)
When implemented by a class, saves the macro records to the given file in xml format.
(Inherited from IRecordPlayBack.)
Public method SaveStream(Stream)
When implemented by a class, saves the text content to the specified stream.
(Inherited from IExport.)
Public method SaveStream(TextWriter)
When implemented by a class, saves the text content to the specified stream.
(Inherited from IExport.)
Public method SaveStream(Stream, IStringExport)
When implemented by a class, saves the text content to the given stream with specified exporter.
(Inherited from ITextExport.)
Public method SaveStream(TextWriter, IStringExport)
When implemented by a class, saves the text content to the given stream with specified exporter.
(Inherited from ITextExport.)
Public method SaveStream(Stream, Encoding)
When implemented by a class, saves the text content to the specified stream.
(Inherited from IExport.)
Public method SaveStream(Stream, IStringExport, Encoding)
When implemented by a class, saves the text content to the given stream with specified exporter.
(Inherited from ITextExport.)
Public method ScreenToDisplay
When implemented by a class, converts given screen coordinates to display coordinates(index of line and character).
Public method ScreenToDisplayX
When implemented by a class, converts given screen coordinates to display coordinate of a character.
Public method ScreenToText(Point)
When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).
Public method ScreenToText(Int32, Int32)
When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).
Public method ScreenToText(Int32, Int32, Boolean)
When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).
Public method ScrollLineDown
When implemented by a class, scrolls text content one line down.
(Inherited from IEditNavigate.)
Public method ScrollLineUp
When implemented by a class, scrolls text content one line up.
(Inherited from IEditNavigate.)
Public method SetLineHidden(Int32, Boolean)
When implemented by a class, sets hidden state for the given line.
(Inherited from IEdit.)
Public method SetLineHidden(Int32, Boolean)
When implemented by a class, sets hidden state for the given line.
(Inherited from IEdit.)
Public method SetLineReadonly(Int32, Boolean)
When implemented by a class, sets readonly state for the given line.
(Inherited from IEdit.)
Public method SetLineReadonly(Int32, Boolean)
When implemented by a class, sets readonly state for the given line.
(Inherited from IEdit.)
Public method SetNavigateOptions
When implemented by a class, sets navigating options without validating position.
(Inherited from INavigate.)
Public method ShowCaret
When implemented by a class, moves the caret to the specified coordinates.
(Inherited from ICaret.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType)
When implemented by a class, shows code completion popup window with given provider at the current position.
(Inherited from ICodeCompletion.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point)
When implemented by a class, shows code completion popup window with given Provider at the specified position.
(Inherited from ICodeCompletion.)
Public method ShowCodeCompletionButton
When implemented by a class, shows code completion popup window with given Provider at the specified position.
(Inherited from ICodeCompletion.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, ILexer)
When implemented by a class, displays ICodeCompletionHint with given provider at the current position.
(Inherited from ICodeCompletion.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer)
When implemented by a class, displays ICodeCompletionHint with given provider at the specified position.
(Inherited from ICodeCompletion.)
Public method ShowNotFound
When implemented by a class, displays "searched text not found" message box.
(Inherited from ISearch.)
Public method ShowScrollHint
When implemented by a class, displays tooltip indicating destination line when scrolling.
Public method SplitViewHorz
When implemented by a class, splits its content horizontally.
(Inherited from ISplitView.)
Public method SplitViewVert
When implemented by a class, splits its content vertically.
(Inherited from ISplitView.)
Public method StartIncrementalSearch
When implemented by a class, enters control to the incremental search state.
(Inherited from ISearch.)
Public method StartIncrementalSearch(Boolean)
When implemented by a class, enters control to the incremental search state.
(Inherited from ISearch.)
Public method StartMacroRecording
When implemented by a class, starts recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method StopMacroRecording
When implemented by a class, stops recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method StorePosition(Point)
When implemented by a class, stores given position to stored position list.
(Inherited from INavigate.)
Public method StorePosition(Point, Boolean)
When implemented by a class, stores given position to stored position list.
(Inherited from INavigate.)
Public method StorePositionWithUndo
When implemented by a class, stores given position to stored position list preserving it for undo.
(Inherited from INavigate.)
Public method TextToScreen(Point)
When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.
Public method TextToScreen(Point, Boolean)
When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.
Public method TextToScreen(Int32, Int32)
When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.
Public method ToggleMacroRecording
When implemented by a class, toggles recording the command sequence.
(Inherited from IRecordPlayBack.)
Public method UnBreakLine
When implemented by a class, concatenates lines at current position.
(Inherited from IEdit.)
Public method UnhighlightAll
When implemented by a class, unhighlights search results previously highlighted by HighlightAll.
(Inherited from ISearch.)
Public method UnsplitViewHorz
When implemented by a class, removes horizontal split view.
(Inherited from ISplitView.)
Public method UnsplitViewVert
When implemented by a class, removes vertical split view.
(Inherited from ISplitView.)
Public method Update
When implemented by a class, updates an object state.
(Inherited from IUpdate.)
Public method UpdateCaret
When implemented by a class, ensures the caret is displayed in the current position.
(Inherited from ICaret.)
Public method UpdateView
When implemented by a class, updates editor content, caret and pages area.
Public method UpdateWordWrap
When implemented by a class, re-wraps all lines in the text.
(Inherited from IWordWrap.)
Public method UpdateWordWrap(Int32, Int32)
When implemented by a class, re-wraps lines in the text within specific scope.
(Inherited from IWordWrap.)
Public method ValidatePosition
When implemented by a class, validates given position within control's text content.
(Inherited from INavigate.)
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ApplyTheme Method

ISyntaxEditApplyTheme Method
Whem implemented by a class, applies visual theme to the SyntaxEdit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyTheme(
    IVisualTheme theme
)
Sub ApplyTheme (
    theme As IVisualTheme
)
void ApplyTheme(
    IVisualTheme^ theme
)
abstract ApplyTheme :
        theme : IVisualTheme -> unit

Parameters

theme
Type: Alternet.EditorIVisualTheme
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Assign Method

ISyntaxEditAssign Method
When implemented by a class, assigns most relevant properties from another ISyntaxEdit object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ISyntaxEdit source
)
Sub Assign (
    source As ISyntaxEdit
)
void Assign(
    ISyntaxEdit^ source
)
abstract Assign :
        source : ISyntaxEdit -> unit

Parameters

source
Type: Alternet.EditorISyntaxEdit
Specifies source object.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.DisplayGotoLineDialog Method

ISyntaxEditDisplayGotoLineDialog Method
Overload List
 | Name | Description
Public method | DisplayGotoLineDialog | When implemented by a class, initializes and runs a dialog prompting you for index of the line you need to locate.
Public method | DisplayGotoLineDialog(IWin32Window) | When implemented by a class, initializes and runs a dialog prompting you for index of the line you need to locate.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.DisplayGotoLineDialog Method

ISyntaxEditDisplayGotoLineDialog Method
When implemented by a class, initializes and runs a dialog prompting you for index of the line you need to locate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplayGotoLineDialog()
Function DisplayGotoLineDialog As DialogResult
DialogResult DisplayGotoLineDialog()
abstract DisplayGotoLineDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplayGotoLineDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplayGotoLineDialog Method (IWin32Window)

ISyntaxEditDisplayGotoLineDialog Method (IWin32Window)
When implemented by a class, initializes and runs a dialog prompting you for index of the line you need to locate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplayGotoLineDialog(
    IWin32Window owner
)
Function DisplayGotoLineDialog (
    owner As IWin32Window
) As DialogResult
DialogResult DisplayGotoLineDialog(
    IWin32Window^ owner
)
abstract DisplayGotoLineDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplayGotoLineDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplayModalReplaceDialog Method

ISyntaxEditDisplayModalReplaceDialog Method
Overload List
 | Name | Description
Public method | DisplayModalReplaceDialog | When implemented by a class, initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method | DisplayModalReplaceDialog(IWin32Window) | When implemented by a class, initializes and runs a modal dialog box allowing you to search for text and replace it.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.DisplayModalReplaceDialog Method

ISyntaxEditDisplayModalReplaceDialog Method
When implemented by a class, initializes and runs a modal dialog box allowing you to search for text and replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplayModalReplaceDialog()
Function DisplayModalReplaceDialog As DialogResult
DialogResult DisplayModalReplaceDialog()
abstract DisplayModalReplaceDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplayModalReplaceDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplayModalReplaceDialog Method (IWin32Window)

ISyntaxEditDisplayModalReplaceDialog Method (IWin32Window)
When implemented by a class, initializes and runs a modal dialog box allowing you to search for text and replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplayModalReplaceDialog(
    IWin32Window owner
)
Function DisplayModalReplaceDialog (
    owner As IWin32Window
) As DialogResult
DialogResult DisplayModalReplaceDialog(
    IWin32Window^ owner
)
abstract DisplayModalReplaceDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplayModalReplaceDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplayModalSearchDialog Method

ISyntaxEditDisplayModalSearchDialog Method
Overload List
 | Name | Description
Public method | DisplayModalSearchDialog | When implemented by a class, initializes and runs a modal dialog box allowing you to search for some text.
Public method | DisplayModalSearchDialog(IWin32Window) | When implemented by a class, initializes and runs a modal dialog box allowing you to search for some text.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.DisplayModalSearchDialog Method

ISyntaxEditDisplayModalSearchDialog Method
When implemented by a class, initializes and runs a modal dialog box allowing you to search for some text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplayModalSearchDialog()
Function DisplayModalSearchDialog As DialogResult
DialogResult DisplayModalSearchDialog()
abstract DisplayModalSearchDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplayModalSearchDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplayModalSearchDialog Method (IWin32Window)

ISyntaxEditDisplayModalSearchDialog Method (IWin32Window)
When implemented by a class, initializes and runs a modal dialog box allowing you to search for some text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplayModalSearchDialog(
    IWin32Window owner
)
Function DisplayModalSearchDialog (
    owner As IWin32Window
) As DialogResult
DialogResult DisplayModalSearchDialog(
    IWin32Window^ owner
)
abstract DisplayModalSearchDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplayModalSearchDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplayReplaceDialog Method

ISyntaxEditDisplayReplaceDialog Method
Overload List
 | Name | Description
Public method | DisplayReplaceDialog | When implemented by a class, initializes and runs a dialog box allowing you to search for text and replace it.
Public method | DisplayReplaceDialog(IWin32Window) | When implemented by a class, initializes and runs a dialog box allowing you to search for text and replace it.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.DisplayReplaceDialog Method

ISyntaxEditDisplayReplaceDialog Method
When implemented by a class, initializes and runs a dialog box allowing you to search for text and replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplayReplaceDialog()
Function DisplayReplaceDialog As DialogResult
DialogResult DisplayReplaceDialog()
abstract DisplayReplaceDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplayReplaceDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplayReplaceDialog Method (IWin32Window)

ISyntaxEditDisplayReplaceDialog Method (IWin32Window)
When implemented by a class, initializes and runs a dialog box allowing you to search for text and replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplayReplaceDialog(
    IWin32Window owner
)
Function DisplayReplaceDialog (
    owner As IWin32Window
) As DialogResult
DialogResult DisplayReplaceDialog(
    IWin32Window^ owner
)
abstract DisplayReplaceDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplayReplaceDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplaySearchDialog Method

ISyntaxEditDisplaySearchDialog Method
Overload List
 | Name | Description
Public method | DisplaySearchDialog | When implemented by a class, initializes and runs a dialog box allowing you to search for some text.
Public method | DisplaySearchDialog(IWin32Window) | When implemented by a class, initializes and runs a dialog box allowing you to search for some text.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.DisplaySearchDialog Method

ISyntaxEditDisplaySearchDialog Method
When implemented by a class, initializes and runs a dialog box allowing you to search for some text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplaySearchDialog()
Function DisplaySearchDialog As DialogResult
DialogResult DisplaySearchDialog()
abstract DisplaySearchDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplaySearchDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplaySearchDialog Method (IWin32Window)

ISyntaxEditDisplaySearchDialog Method (IWin32Window)
When implemented by a class, initializes and runs a dialog box allowing you to search for some text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult DisplaySearchDialog(
    IWin32Window owner
)
Function DisplaySearchDialog (
    owner As IWin32Window
) As DialogResult
DialogResult DisplaySearchDialog(
    IWin32Window^ owner
)
abstract DisplaySearchDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISyntaxEdit Interface
DisplaySearchDialog Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplayToScreen Method

ISyntaxEditDisplayToScreen Method
Overload List
 | Name | Description
Public method | DisplayToScreen(Int32, Int32) | When implemented by a class, converts given display coordinates, index of line and character, to screen coordinates.
Public method | DisplayToScreen(Int32, Int32, Boolean) | When implemented by a class, converts given display coordinates, index of line and character, to screen coordinates.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.DisplayToScreen Method (Int32, Int32)

ISyntaxEditDisplayToScreen Method (Int32, Int32)
When implemented by a class, converts given display coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point DisplayToScreen(
    int x,
    int y
)
Function DisplayToScreen (
    x As Integer,
    y As Integer
) As Point
Point DisplayToScreen(
    int x,
    int y
)
abstract DisplayToScreen :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
Index of character in the line.
y
Type: SystemInt32
Index of line.

Return Value

Type: Point
The Point representing screen coordinate.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

ISyntaxEdit Interface
DisplayToScreen Overload
Alternet.Editor Namespace


ISyntaxEdit.DisplayToScreen Method (Int32, Int32, Boolean)

ISyntaxEditDisplayToScreen Method (Int32, Int32, Boolean)
When implemented by a class, converts given display coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point DisplayToScreen(
    int x,
    int y,
    bool average
)
Function DisplayToScreen (
    x As Integer,
    y As Integer,
    average As Boolean
) As Point
Point DisplayToScreen(
    int x,
    int y,
    bool average
)
abstract DisplayToScreen :
        x : int *
        y : int *
        average : bool -> Point

Parameters

x
Type: SystemInt32
Index of character in the line.
y
Type: SystemInt32
Index of line.
average
Type: SystemBoolean

Return Value

Type: Point
The Point representing screen coordinate.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

ISyntaxEdit Interface
DisplayToScreen Overload
Alternet.Editor Namespace


ISyntaxEdit.GetCharsInWidth Method

ISyntaxEditGetCharsInWidth Method
When implemented by a class, returns number of characters painted with current font that will fit into specified Width.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetCharsInWidth(
    int width
)
Function GetCharsInWidth (
    width As Integer
) As Integer
int GetCharsInWidth(
    int width
)
abstract GetCharsInWidth :
        width : int -> int

Parameters

width
Type: SystemInt32
Width to fit characters.

Return Value

Type: Int32
Number of characters that can fit in.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.GetHitTest Method

ISyntaxEditGetHitTest Method
Overload List
 | Name | Description
Public method | GetHitTest(Point, IHitTestInfo) | When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method | GetHitTest(Int32, Int32, IHitTestInfo) | When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.GetHitTest Method (Point, IHitTestInfo)

ISyntaxEditGetHitTest Method (Point, IHitTestInfo)
When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetHitTest(
    Point position,
    IHitTestInfo hitTestInfo
)
Sub GetHitTest (
    position As Point,
    hitTestInfo As IHitTestInfo
)
void GetHitTest(
    Point position,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTest :
        position : Point *
        hitTestInfo : IHitTestInfo -> unit

Parameters

position
Type: System.DrawingPoint
Specifies coordinate to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.
See Also

Reference

ISyntaxEdit Interface
GetHitTest Overload
Alternet.Editor Namespace


ISyntaxEdit.GetHitTest Method (Int32, Int32, IHitTestInfo)

ISyntaxEditGetHitTest Method (Int32, Int32, IHitTestInfo)
When implemented by a class, fills hitTestInfo parameter by information about a part of the control at specified coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetHitTest(
    int x,
    int y,
    IHitTestInfo hitTestInfo
)
Sub GetHitTest (
    x As Integer,
    y As Integer,
    hitTestInfo As IHitTestInfo
)
void GetHitTest(
    int x,
    int y,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTest :
        x : int *
        y : int *
        hitTestInfo : IHitTestInfo -> unit

Parameters

x
Type: SystemInt32
Specifies horizontal coordinate of position to check.
y
Type: SystemInt32
Specifies vertical coordinate of position to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.
See Also

Reference

ISyntaxEdit Interface
GetHitTest Overload
Alternet.Editor Namespace


ISyntaxEdit.GetHitTestAtTextPoint Method

ISyntaxEditGetHitTestAtTextPoint Method
Overload List
 | Name | Description
Public method | GetHitTestAtTextPoint(Point, IHitTestInfo) | When implemented by a class, fills hitTestInfo parameter by information about a part of control at specified text coordinate.
Public method | GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo) | When implemented by a class, retrieves information about part of control at specified text coordinate.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.GetHitTestAtTextPoint Method (Point, IHitTestInfo)

ISyntaxEditGetHitTestAtTextPoint Method (Point, IHitTestInfo)
When implemented by a class, fills hitTestInfo parameter by information about a part of control at specified text coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetHitTestAtTextPoint(
    Point position,
    IHitTestInfo hitTestInfo
)
Sub GetHitTestAtTextPoint (
    position As Point,
    hitTestInfo As IHitTestInfo
)
void GetHitTestAtTextPoint(
    Point position,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTestAtTextPoint :
        position : Point *
        hitTestInfo : IHitTestInfo -> unit

Parameters

position
Type: System.DrawingPoint
Specifies coordinate to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.
See Also

Reference

ISyntaxEdit Interface
GetHitTestAtTextPoint Overload
Alternet.Editor Namespace


ISyntaxEdit.GetHitTestAtTextPoint Method (Int32, Int32, IHitTestInfo)

ISyntaxEditGetHitTestAtTextPoint Method (Int32, Int32, IHitTestInfo)
When implemented by a class, retrieves information about part of control at specified text coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetHitTestAtTextPoint(
    int x,
    int y,
    IHitTestInfo hitTestInfo
)
Sub GetHitTestAtTextPoint (
    x As Integer,
    y As Integer,
    hitTestInfo As IHitTestInfo
)
void GetHitTestAtTextPoint(
    int x,
    int y,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTestAtTextPoint :
        x : int *
        y : int *
        hitTestInfo : IHitTestInfo -> unit

Parameters

x
Type: SystemInt32
Specifies horizontal coordinate of text position to check.
y
Type: SystemInt32
Specifies vertical coordinate of text position to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.
See Also

Reference

ISyntaxEdit Interface
GetHitTestAtTextPoint Overload
Alternet.Editor Namespace


ISyntaxEdit.GetLinesInHeight Method

ISyntaxEditGetLinesInHeight Method
When implemented by a class, determines how many lines can fit into given Height.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetLinesInHeight(
    int height
)
Function GetLinesInHeight (
    height As Integer
) As Integer
int GetLinesInHeight(
    int height
)
abstract GetLinesInHeight :
        height : int -> int

Parameters

height
Type: SystemInt32
Height to fit lines.

Return Value

Type: Int32
Number of lines that can fit in.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.GetTextAtCursor Method

ISyntaxEditGetTextAtCursor Method
When implemented by a class, returns word at the cursor position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetTextAtCursor()
Function GetTextAtCursor As String
String^ GetTextAtCursor()
abstract GetTextAtCursor : unit -> string

Return Value

Type: String
Word at the cursor position.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.HideScrollHint Method

ISyntaxEditHideScrollHint Method
When implemented by a class, hides scroll hint window if necessary.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HideScrollHint()
Sub HideScrollHint
void HideScrollHint()
abstract HideScrollHint : unit -> unit
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.MakeVisible Method

ISyntaxEditMakeVisible Method
Overload List
 | Name | Description
Public method | MakeVisible(Point) | When implemented by a class, scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method | MakeVisible(Point, Boolean) | When implemented by a class, scrolls the control's content, if necessary, to ensure a specified text position is in view.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.MakeVisible Method (Point)

ISyntaxEditMakeVisible Method (Point)
When implemented by a class, scrolls the control's content, if necessary, to ensure a specified text position is in view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MakeVisible(
    Point position
)
Sub MakeVisible (
    position As Point
)
void MakeVisible(
    Point position
)
abstract MakeVisible :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Position in the text to make visible.
See Also

Reference

ISyntaxEdit Interface
MakeVisible Overload
Alternet.Editor Namespace


ISyntaxEdit.MakeVisible Method (Point, Boolean)

ISyntaxEditMakeVisible Method (Point, Boolean)
When implemented by a class, scrolls the control's content, if necessary, to ensure a specified text position is in view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MakeVisible(
    Point position,
    bool centerLine
)
Sub MakeVisible (
    position As Point,
    centerLine As Boolean
)
void MakeVisible(
    Point position,
    bool centerLine
)
abstract MakeVisible :
        position : Point *
        centerLine : bool -> unit

Parameters

position
Type: System.DrawingPoint
Position in the text to make visible.
centerLine
Type: SystemBoolean
Specifies whether given line must be centered within control's client area.
See Also

Reference

ISyntaxEdit Interface
MakeVisible Overload
Alternet.Editor Namespace


ISyntaxEdit.MoveCaretOnDrag Method

ISyntaxEditMoveCaretOnDrag Method
When implemented by a class, moves caret to the position of drag cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveCaretOnDrag()
Sub MoveCaretOnDrag
void MoveCaretOnDrag()
abstract MoveCaretOnDrag : unit -> unit
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ProcessKeyMsg Method

ISyntaxEditProcessKeyMsg Method
When implemented by a class, processes a keyboard message.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessKeyMsg(
    ref Message msg
)
Function ProcessKeyMsg (
    ByRef msg As Message
) As Boolean
bool ProcessKeyMsg(
    Message% msg
)
abstract ProcessKeyMsg :
        msg : Message byref -> bool

Parameters

msg
Type: System.Windows.FormsMessage
A Message, passed by reference, that represents the window message to process.

Return Value

Type: Boolean
True if the message was processed by the control; otherwise, false.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ProcessKeyPress Method

ISyntaxEditProcessKeyPress Method
When implemented by a class, processes key press.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ProcessKeyPress(
    char keyChar
)
Sub ProcessKeyPress (
    keyChar As Char
)
void ProcessKeyPress(
    wchar_t keyChar
)
abstract ProcessKeyPress :
        keyChar : char -> unit

Parameters

keyChar
Type: SystemChar
Represents key character to process.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ResetAcceptReturns Method

ISyntaxEditResetAcceptReturns Method
When implemented by a class, resets the AcceptReturns to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAcceptReturns()
Sub ResetAcceptReturns
void ResetAcceptReturns()
abstract ResetAcceptReturns : unit -> unit
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ResetAcceptTabs Method

ISyntaxEditResetAcceptTabs Method
When implemented by a class, resets the AcceptTabs to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAcceptTabs()
Sub ResetAcceptTabs
void ResetAcceptTabs()
abstract ResetAcceptTabs : unit -> unit
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ResetBorderColor Method

ISyntaxEditResetBorderColor Method
When implemented by a class, resets the BorderColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBorderColor()
Sub ResetBorderColor
void ResetBorderColor()
abstract ResetBorderColor : unit -> unit
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ResetBorderStyle Method

ISyntaxEditResetBorderStyle Method
When implemented by a class, resets the BorderStyle to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBorderStyle()
Sub ResetBorderStyle
void ResetBorderStyle()
abstract ResetBorderStyle : unit -> unit
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ResetLineSpace Method

ISyntaxEditResetLineSpace Method
When implemented by a class, resets the LineSpace to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetLineSpace()
Sub ResetLineSpace
void ResetLineSpace()
abstract ResetLineSpace : unit -> unit
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ScreenToDisplay Method

ISyntaxEditScreenToDisplay Method
When implemented by a class, converts given screen coordinates to display coordinates(index of line and character).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point ScreenToDisplay(
    int x,
    int y
)
Function ScreenToDisplay (
    x As Integer,
    y As Integer
) As Point
Point ScreenToDisplay(
    int x,
    int y
)
abstract ScreenToDisplay :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
Horizontal screen coordinate to convert.
y
Type: SystemInt32
Vertical screen coordinate to convert.

Return Value

Type: Point
The Point representing display coordinate.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ScreenToDisplayX Method

ISyntaxEditScreenToDisplayX Method
When implemented by a class, converts given screen coordinates to display coordinate of a character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ScreenToDisplayX(
    int x,
    int line
)
Function ScreenToDisplayX (
    x As Integer,
    line As Integer
) As Integer
int ScreenToDisplayX(
    int x,
    int line
)
abstract ScreenToDisplayX :
        x : int *
        line : int -> int

Parameters

x
Type: SystemInt32
Horizontal screen coordinate to convert.
line
Type: SystemInt32
Vertical display coordinate of a text line.

Return Value

Type: Int32
The integer representing display coordinate.
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ScreenToText Method

ISyntaxEditScreenToText Method
Overload List
 | Name | Description
Public method | ScreenToText(Point) | When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).
Public method | ScreenToText(Int32, Int32) | When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).
Public method | ScreenToText(Int32, Int32, Boolean) | When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ScreenToText Method (Point)

ISyntaxEditScreenToText Method (Point)
When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point ScreenToText(
    Point position
)
Function ScreenToText (
    position As Point
) As Point
Point ScreenToText(
    Point position
)
abstract ScreenToText :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The screen coordinate Point to convert.

Return Value

Type: Point
The Point representing text coordinate.
See Also

Reference

ISyntaxEdit Interface
ScreenToText Overload
Alternet.Editor Namespace


ISyntaxEdit.ScreenToText Method (Int32, Int32)

ISyntaxEditScreenToText Method (Int32, Int32)
When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point ScreenToText(
    int x,
    int y
)
Function ScreenToText (
    x As Integer,
    y As Integer
) As Point
Point ScreenToText(
    int x,
    int y
)
abstract ScreenToText :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
Horizontal screen coordinate to convert.
y
Type: SystemInt32
Vertical screen coordinate to convert.

Return Value

Type: Point
The Point representing text coordinate.
See Also

Reference

ISyntaxEdit Interface
ScreenToText Overload
Alternet.Editor Namespace


ISyntaxEdit.ScreenToText Method (Int32, Int32, Boolean)

ISyntaxEditScreenToText Method (Int32, Int32, Boolean)
When implemented by a class, converts given screen coordinates to text coordinates (index of line and character).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point ScreenToText(
    int x,
    int y,
    ref bool lineEnd
)
Function ScreenToText (
    x As Integer,
    y As Integer,
    ByRef lineEnd As Boolean
) As Point
Point ScreenToText(
    int x,
    int y,
    bool% lineEnd
)
abstract ScreenToText :
        x : int *
        y : int *
        lineEnd : bool byref -> Point

Parameters

x
Type: SystemInt32
Horizontal screen coordinate to convert.
y
Type: SystemInt32
Vertical screen coordinate to convert.
lineEnd
Type: SystemBoolean
Receives boolean value indicating if the caret is at the line end of the wrapped line.

Return Value

Type: Point
The Point representing text coordinate.
See Also

Reference

ISyntaxEdit Interface
ScreenToText Overload
Alternet.Editor Namespace


ISyntaxEdit.ShowScrollHint Method

ISyntaxEditShowScrollHint Method
When implemented by a class, displays tooltip indicating destination line when scrolling.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowScrollHint(
    int pos
)
Sub ShowScrollHint (
    pos As Integer
)
void ShowScrollHint(
    int pos
)
abstract ShowScrollHint :
        pos : int -> unit

Parameters

pos
Type: SystemInt32
Specifies vertical position (in display coordinates) to obtain hint info.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.TextToScreen Method

ISyntaxEditTextToScreen Method
Overload List
 | Name | Description
Public method | TextToScreen(Point) | When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.
Public method | TextToScreen(Point, Boolean) | When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.
Public method | TextToScreen(Int32, Int32) | When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.TextToScreen Method (Point)

ISyntaxEditTextToScreen Method (Point)
When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point TextToScreen(
    Point position
)
Function TextToScreen (
    position As Point
) As Point
Point TextToScreen(
    Point position
)
abstract TextToScreen :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The text coordinate Point to convert.

Return Value

Type: Point
The Point representing screen coordinate.
See Also

Reference

ISyntaxEdit Interface
TextToScreen Overload
Alternet.Editor Namespace


ISyntaxEdit.TextToScreen Method (Point, Boolean)

ISyntaxEditTextToScreen Method (Point, Boolean)
When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point TextToScreen(
    Point position,
    bool lineEnd
)
Function TextToScreen (
    position As Point,
    lineEnd As Boolean
) As Point
Point TextToScreen(
    Point position,
    bool lineEnd
)
abstract TextToScreen :
        position : Point *
        lineEnd : bool -> Point

Parameters

position
Type: System.DrawingPoint
Point coordinate to convert.
lineEnd
Type: SystemBoolean
Boolean value indicating if the text position can be set to the end of the wrapped line.

Return Value

Type: Point
The Point representing screen coordinate.
See Also

Reference

ISyntaxEdit Interface
TextToScreen Overload
Alternet.Editor Namespace


ISyntaxEdit.TextToScreen Method (Int32, Int32)

ISyntaxEditTextToScreen Method (Int32, Int32)
When implemented by a class, converts given text coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point TextToScreen(
    int x,
    int y
)
Function TextToScreen (
    x As Integer,
    y As Integer
) As Point
Point TextToScreen(
    int x,
    int y
)
abstract TextToScreen :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
Horizontal text coordinate to convert.
y
Type: SystemInt32
Vertical text coordinate to convert.

Return Value

Type: Point
The Point representing screen coordinate.
See Also

Reference

ISyntaxEdit Interface
TextToScreen Overload
Alternet.Editor Namespace


ISyntaxEdit.UpdateView Method

ISyntaxEditUpdateView Method
When implemented by a class, updates editor content, caret and pages area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateView()
Sub UpdateView
void UpdateView()
abstract UpdateView : unit -> unit
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit Properties

ISyntaxEdit Properties

The ISyntaxEdit type exposes the following members.

Properties
 | Name | Description
Public property | AcceptReturns | When implemented by a class, gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key.
Public property | AcceptTabs | When implemented by a class, gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key.
Public property | ActiveOutlineRange | When implemented by a class, gets currently highlighted outlined range.
Public property | AutoCorrectDelimiters | When implemented by a class, gets or sets an array of chars that used as word delimiters. (Inherited from IAutoCorrect.)
Public property | AutoCorrection | When implemented by a class, gets or sets a boolean value indicating whether to auto correct words being typed. (Inherited from IAutoCorrect.)
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | BorderColor | When implemented by a class, gets or sets the border color for the Edit control.
Public property | BorderStyle | When implemented by a class, gets or sets the border style for the Edit control.
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | Braces | When implemented by a class, represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control.
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | CharsInWidth | When implemented by a class, returns number of characters painted with current font that will fit into control's client area.
Public property | ClientArea | When implemented by a class, gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded.
Public property | ClientHeight | When implemented by a class, gets the width of the client area of the Edit control.
Public property | ClientRect | When implemented by a class, gets the rectangle that represents the client area of the Edit control.
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ClientWidth | When implemented by a class, gets the height of the client area of the Edit control.
Public property | CodeCompletionBox | When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of list. (Inherited from ICodeCompletion.)
Public property | CodeCompletionChars | When implemented by a class, represents a collection of characters that initializes a code completion procedure when typing in the editor. (Inherited from ICodeCompletion.)
Public property | CodeCompletionHint | When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of the tooltip. (Inherited from ICodeCompletion.)
Public property | CodeCompletionMode | When implemented by a class, gets or sets code completion box mode. (Inherited from ICodeCompletion.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | CurrentBlockRange | When implemented by a class, gets currently highlighted block range. (Inherited from ICaret.)
Public property | DisplayLines | When implemented by a class, represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control.
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | EditMargin | When implemented by a class, represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed.
Public property | EffectiveVisualTheme | Whem implemented by a class, gets current visual theme.
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | EventHandlers | When implemented by a class, represents object that holds EventHandlers containing list of keys with attached actions.
Public property | FirstSearch | When implemented by a class, gets or sets a value indicating whether control launches text search at first. (Inherited from ISearch.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | GotoLineDialog | When implemented by a class, gets or sets a dialog prompting for index of the line you need to locate. (Inherited from ISearch.)
Public property | Gutter | When implemented by a class, represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control.
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | HideCaret | When implemented by a class, gets or sets a value indicating whether the control should display caret when it has input focus. (Inherited from ICaret.)
Public property | HighlightCurrentBlock | When implemented by a class, specifies that edit control should highlight current block. (Inherited from ICaret.)
Public property | HighlightMatchingBlocks | When implemented by a class, specifies that edit control should highlight begin/end blocks.
Public property | HighlightReferences | When implemented by a class, specifies that edit control should highlight found references.
Public property | HighlightSearchResults | When implemented by a class, indicates whether search results are highlighted while the search dialog is open. (Inherited from ISearch.)
Public property | HorzSplitEdit | When implemented by a class, represents horizontal split view control. (Inherited from ISplitView.)
Public property | HorzSplitter | When implemented by a class, represents a horizontal Splitter control allowing to split Edit content horizontally. (Inherited from ISplitView.)
Public property | HyperText | When implemented by a class, represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control.
Public property | IncrementalSearchString | When implemented by a class, return text to search if class is in incremental search state; otherwise return empty string. (Inherited from ISearch.)
Public property | IndentOptions | When implemented by a class, gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from IEdit.)
Public property | InIncrementalSearch | When implemented by a class, indicates whether control is in incremental search state. (Inherited from ISearch.)
Public property | IsCodeCompletionWindowFocused | When implemented by a class, indicates whether ICodeCompletionWindow has focus. (Inherited from ICodeCompletion.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | IsSearchFocused | When implemented by a class, gets a boolean value indicating whether search dialog box has input focus.
Public property | KeepCaretOnLostFocus | When implemented by a class, keeps caret in visible state even Edit control lost focus. (Inherited from ICaret.)
Public property | KeyList | When implemented by a class, represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure.
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Lexer | When implemented by a class, gets or sets object that can make lexical analysis for the control's content.
Public property | Lines | When implemented by a class, represents object that implements ITextStrings interface containing collection of strings determining control's content.
Public property | LineSeparator | When implemented by a class, represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control.
Public property | LinesInHeight | When implemented by a class, determines how many lines can fit into control's client area.
Public property | LineSpace | When implemented by a class, gets or sets line space between individual lines in the Edit control.
Public property | LineStyles | When implemented by a class, represents an object that implements IEditLineStyles interface holding collection of ILineStyle objects each of them determines particular style of the line in the control.
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | MacroRecording | When implemented by a class, gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands. (Inherited from IRecordPlayBack.)
Public property | MacroRecords | When implemented by a class, represents an array containing keyboard commands. (Inherited from IRecordPlayBack.)
Public property | MacroSuspendend | When implemented by a class, gets or sets a boolean value indicating whether recording is suspended. (Inherited from IRecordPlayBack.)
Public property | MaxLength | When implemented by a class, specifies the maximum number of characters that can be entered into the edit control. (Inherited from IEdit.)
Public property | Modified | When implemented by a class, gets or sets a value indicating whether the control's text content is modified. (Inherited from IEdit.)
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options. (Inherited from INavigate.)
Public property | OpenSharedEditorFunc | When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment.
Public property | Outlining | When implementing by a class, represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control.
Public property | Overwrite | When implemented by a class, gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from IEdit.)
Public property | Pages | When implemented by a class, represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages.
Public property | Painter | When implemented by a class, represents an object that implements IPainter interface used to draw control's text.
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | Position | When implemented by a class, gets or sets current position within the control's text content. (Inherited from INavigate.)
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content. (Inherited from INavigate.)
Public property | Printing | When implemented by a class, represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options.
Public property | ReadOnly | When implemented by a class, gets or sets a value indicating whether the control's content is read-only. (Inherited from IEdit.)
Public property | Scrolling | When implemented by a class, represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control.
Public property | SearchDialog | When implemented by a class, gets or sets a dialog box allowing to search for the text or replace it. (Inherited from ISearch.)
Public property | SearchDialogAppearance | When implemented by a class, gets or sets search dialog appearance.
Public property | SearchGlobal | When implemented by a class, gets or sets a value indicating whether search should be global. (Inherited from ISearch.)
Public property | SearchLen | When implemented by a class, represents length of the last found text. (Inherited from ISearch.)
Public property | SearchOptions | When implemented by a class, gets or sets a value that defines search and replace options. (Inherited from ISearch.)
Public property | SearchPos | When implemented by a class, gets or sets a value that represents position of the last found text. (Inherited from ISearch.)
Public property | Selection | When implemented by a class, represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text.
Public property | SingleLineMode | When implemented by a class, gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from IEdit.)
Public property | Source | When implemented by a class, gets or sets an object that implements ITextSource interface containing an actual string data displayed by the control.
Public property | Spelling | When implemented by a class, represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words.
Public property | Strings | When implemented by a class, represents Lines property in the form of array of strings.
Public property | SyntaxPaint | When implemented by a class, represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Transparent | When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw its background.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UseDefaultMenu | When implemented by a class, indicates whether edit control should use built in popup menu.
Public property | VertSplitEdit | When implemented by a class, represents an vertical split view control. (Inherited from ISplitView.)
Public property | VertSplitter | When implemented by a class, represents a vertical Splitter control allowing to split Edit content vertically. (Inherited from ISplitView.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | VisualTheme | When implemented by a class, gets or sets visual theme for the editor.
Public property | VisualThemeType | When implemented by a class, gets or sets visual theme type for the editor.
Public property | WhiteSpace | When implemented by a class, represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks.
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Public property | WordWrap | When implemented by a class, gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary. (Inherited from IWordWrap.)
Public property | WrapAtMargin | When implemented by a class, gets or sets a value indicating whether control automatically wraps words at margin position. (Inherited from IWordWrap.)
Public property | WrapMargin | When implemented by a class, gets position of the wrapping margin. (Inherited from IWordWrap.)
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.AcceptReturns Property

ISyntaxEditAcceptReturns Property
When implemented by a class, gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AcceptReturns { get; set; }
Property AcceptReturns As Boolean
    Get
    Set
property bool AcceptReturns {
    bool get ();
    void set (bool value);
}
abstract AcceptReturns : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.AcceptTabs Property

ISyntaxEditAcceptTabs Property
When implemented by a class, gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AcceptTabs { get; set; }
Property AcceptTabs As Boolean
    Get
    Set
property bool AcceptTabs {
    bool get ();
    void set (bool value);
}
abstract AcceptTabs : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ActiveOutlineRange Property

ISyntaxEditActiveOutlineRange Property
When implemented by a class, gets currently highlighted outlined range.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlineRange ActiveOutlineRange { get; }
ReadOnly Property ActiveOutlineRange As IOutlineRange
    Get
property IOutlineRange^ ActiveOutlineRange {
    IOutlineRange^ get ();
}
abstract ActiveOutlineRange : IOutlineRange with get

Property Value

Type: IOutlineRange
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.BorderColor Property

ISyntaxEditBorderColor Property
When implemented by a class, gets or sets the border color for the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BorderColor { get; set; }
Property BorderColor As Color
    Get
    Set
property Color BorderColor {
    Color get ();
    void set (Color value);
}
abstract BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.BorderStyle Property

ISyntaxEditBorderStyle Property
When implemented by a class, gets or sets the border style for the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
EditBorderStyle BorderStyle { get; set; }
Property BorderStyle As EditBorderStyle
    Get
    Set
property EditBorderStyle BorderStyle {
    EditBorderStyle get ();
    void set (EditBorderStyle value);
}
abstract BorderStyle : EditBorderStyle with get, set

Property Value

Type: EditBorderStyle
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Braces Property

ISyntaxEditBraces Property
When implemented by a class, represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditBraceMatching Braces { get; set; }
Property Braces As IEditBraceMatching
    Get
    Set
property IEditBraceMatching^ Braces {
    IEditBraceMatching^ get ();
    void set (IEditBraceMatching^ value);
}
abstract Braces : IEditBraceMatching with get, set

Property Value

Type: IEditBraceMatching
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.CharsInWidth Property

ISyntaxEditCharsInWidth Property
When implemented by a class, returns number of characters painted with current font that will fit into control's client area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int CharsInWidth { get; }
ReadOnly Property CharsInWidth As Integer
    Get
property int CharsInWidth {
    int get ();
}
abstract CharsInWidth : int with get

Return Value

Type: Int32
Number of characters that can fit in.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ClientArea Property

ISyntaxEditClientArea Property
When implemented by a class, gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle ClientArea { get; }
ReadOnly Property ClientArea As Rectangle
    Get
property Rectangle ClientArea {
    Rectangle get ();
}
abstract ClientArea : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ClientHeight Property

ISyntaxEditClientHeight Property
When implemented by a class, gets the width of the client area of the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ClientHeight { get; }
ReadOnly Property ClientHeight As Integer
    Get
property int ClientHeight {
    int get ();
}
abstract ClientHeight : int with get

Property Value

Type: Int32
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ClientRect Property

ISyntaxEditClientRect Property
When implemented by a class, gets the rectangle that represents the client area of the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle ClientRect { get; }
ReadOnly Property ClientRect As Rectangle
    Get
property Rectangle ClientRect {
    Rectangle get ();
}
abstract ClientRect : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ClientWidth Property

ISyntaxEditClientWidth Property
When implemented by a class, gets the height of the client area of the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ClientWidth { get; }
ReadOnly Property ClientWidth As Integer
    Get
property int ClientWidth {
    int get ();
}
abstract ClientWidth : int with get

Property Value

Type: Int32
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.DisplayLines Property

ISyntaxEditDisplayLines Property
When implemented by a class, represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDisplayStrings DisplayLines { get; }
ReadOnly Property DisplayLines As IDisplayStrings
    Get
property IDisplayStrings^ DisplayLines {
    IDisplayStrings^ get ();
}
abstract DisplayLines : IDisplayStrings with get

Property Value

Type: IDisplayStrings
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.EditMargin Property

ISyntaxEditEditMargin Property
When implemented by a class, represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IMargin EditMargin { get; set; }
Property EditMargin As IMargin
    Get
    Set
property IMargin^ EditMargin {
    IMargin^ get ();
    void set (IMargin^ value);
}
abstract EditMargin : IMargin with get, set

Property Value

Type: IMargin
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.EffectiveVisualTheme Property

ISyntaxEditEffectiveVisualTheme Property
Whem implemented by a class, gets current visual theme.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IVisualTheme EffectiveVisualTheme { get; }
ReadOnly Property EffectiveVisualTheme As IVisualTheme
    Get
property IVisualTheme^ EffectiveVisualTheme {
    IVisualTheme^ get ();
}
abstract EffectiveVisualTheme : IVisualTheme with get

Property Value

Type: IVisualTheme
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.EventHandlers Property

ISyntaxEditEventHandlers Property
When implemented by a class, represents object that holds EventHandlers containing list of keys with attached actions.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEventHandlers EventHandlers { get; }
ReadOnly Property EventHandlers As IEventHandlers
    Get
property IEventHandlers^ EventHandlers {
    IEventHandlers^ get ();
}
abstract EventHandlers : IEventHandlers with get

Property Value

Type: IEventHandlers
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Gutter Property

ISyntaxEditGutter Property
When implemented by a class, represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IGutter Gutter { get; set; }
Property Gutter As IGutter
    Get
    Set
property IGutter^ Gutter {
    IGutter^ get ();
    void set (IGutter^ value);
}
abstract Gutter : IGutter with get, set

Property Value

Type: IGutter
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.HighlightMatchingBlocks Property

ISyntaxEditHighlightMatchingBlocks Property
When implemented by a class, specifies that edit control should highlight begin/end blocks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HighlightMatchingBlocks { get; set; }
Property HighlightMatchingBlocks As Boolean
    Get
    Set
property bool HighlightMatchingBlocks {
    bool get ();
    void set (bool value);
}
abstract HighlightMatchingBlocks : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.HighlightReferences Property

ISyntaxEditHighlightReferences Property
When implemented by a class, specifies that edit control should highlight found references.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HighlightReferences { get; set; }
Property HighlightReferences As Boolean
    Get
    Set
property bool HighlightReferences {
    bool get ();
    void set (bool value);
}
abstract HighlightReferences : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.HyperText Property

ISyntaxEditHyperText Property
When implemented by a class, represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditHyperText HyperText { get; set; }
Property HyperText As IEditHyperText
    Get
    Set
property IEditHyperText^ HyperText {
    IEditHyperText^ get ();
    void set (IEditHyperText^ value);
}
abstract HyperText : IEditHyperText with get, set

Property Value

Type: IEditHyperText
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.IsSearchFocused Property

ISyntaxEditIsSearchFocused Property
When implemented by a class, gets a boolean value indicating whether search dialog box has input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsSearchFocused { get; }
ReadOnly Property IsSearchFocused As Boolean
    Get
property bool IsSearchFocused {
    bool get ();
}
abstract IsSearchFocused : bool with get

Property Value

Type: Boolean
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.KeyList Property

ISyntaxEditKeyList Property
When implemented by a class, represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IKeyList KeyList { get; }
ReadOnly Property KeyList As IKeyList
    Get
property IKeyList^ KeyList {
    IKeyList^ get ();
}
abstract KeyList : IKeyList with get

Property Value

Type: IKeyList
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Lexer Property

ISyntaxEditLexer Property
When implemented by a class, gets or sets object that can make lexical analysis for the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexer Lexer { get; set; }
Property Lexer As ILexer
    Get
    Set
property ILexer^ Lexer {
    ILexer^ get ();
    void set (ILexer^ value);
}
abstract Lexer : ILexer with get, set

Property Value

Type: ILexer
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Lines Property

ISyntaxEditLines Property
When implemented by a class, represents object that implements ITextStrings interface containing collection of strings determining control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ITextStrings Lines { get; set; }
Property Lines As ITextStrings
    Get
    Set
property ITextStrings^ Lines {
    ITextStrings^ get ();
    void set (ITextStrings^ value);
}
abstract Lines : ITextStrings with get, set

Property Value

Type: ITextStrings
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.LineSeparator Property

ISyntaxEditLineSeparator Property
When implemented by a class, represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILineSeparator LineSeparator { get; set; }
Property LineSeparator As ILineSeparator
    Get
    Set
property ILineSeparator^ LineSeparator {
    ILineSeparator^ get ();
    void set (ILineSeparator^ value);
}
abstract LineSeparator : ILineSeparator with get, set

Property Value

Type: ILineSeparator
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.LinesInHeight Property

ISyntaxEditLinesInHeight Property
When implemented by a class, determines how many lines can fit into control's client area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LinesInHeight { get; }
ReadOnly Property LinesInHeight As Integer
    Get
property int LinesInHeight {
    int get ();
}
abstract LinesInHeight : int with get

Return Value

Type: Int32
Number of lines that can fit in.
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.LineSpace Property

ISyntaxEditLineSpace Property
When implemented by a class, gets or sets line space between individual lines in the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LineSpace { get; set; }
Property LineSpace As Integer
    Get
    Set
property int LineSpace {
    int get ();
    void set (int value);
}
abstract LineSpace : int with get, set

Property Value

Type: Int32
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.LineStyles Property

ISyntaxEditLineStyles Property
When implemented by a class, represents an object that implements IEditLineStyles interface holding collection of ILineStyle objects each of them determines particular style of the line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditLineStyles LineStyles { get; set; }
Property LineStyles As IEditLineStyles
    Get
    Set
property IEditLineStyles^ LineStyles {
    IEditLineStyles^ get ();
    void set (IEditLineStyles^ value);
}
abstract LineStyles : IEditLineStyles with get, set

Property Value

Type: IEditLineStyles
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.OpenSharedEditorFunc Property

ISyntaxEditOpenSharedEditorFunc Property
When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Func<string, ISyntaxEdit> OpenSharedEditorFunc { get; set; }
Property OpenSharedEditorFunc As Func(Of String, ISyntaxEdit)
    Get
    Set
property Func<String^, ISyntaxEdit^>^ OpenSharedEditorFunc {
    Func<String^, ISyntaxEdit^>^ get ();
    void set (Func<String^, ISyntaxEdit^>^ value);
}
abstract OpenSharedEditorFunc : Func<string, ISyntaxEdit> with get, set

Property Value

Type: FuncString, ISyntaxEdit
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Outlining Property

ISyntaxEditOutlining Property
When implementing by a class, represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IOutlining Outlining { get; set; }
Property Outlining As IOutlining
    Get
    Set
property IOutlining^ Outlining {
    IOutlining^ get ();
    void set (IOutlining^ value);
}
abstract Outlining : IOutlining with get, set

Property Value

Type: IOutlining
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Pages Property

ISyntaxEditPages Property
When implemented by a class, represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditPages Pages { get; set; }
Property Pages As IEditPages
    Get
    Set
property IEditPages^ Pages {
    IEditPages^ get ();
    void set (IEditPages^ value);
}
abstract Pages : IEditPages with get, set

Property Value

Type: IEditPages
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Painter Property

ISyntaxEditPainter Property
When implemented by a class, represents an object that implements IPainter interface used to draw control's text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPainter Painter { get; }
ReadOnly Property Painter As IPainter
    Get
property IPainter^ Painter {
    IPainter^ get ();
}
abstract Painter : IPainter with get

Property Value

Type: IPainter
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Printing Property

ISyntaxEditPrinting Property
When implemented by a class, represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPrinting Printing { get; set; }
Property Printing As IPrinting
    Get
    Set
property IPrinting^ Printing {
    IPrinting^ get ();
    void set (IPrinting^ value);
}
abstract Printing : IPrinting with get, set

Property Value

Type: IPrinting
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Scrolling Property

ISyntaxEditScrolling Property
When implemented by a class, represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScrolling Scrolling { get; set; }
Property Scrolling As IScrolling
    Get
    Set
property IScrolling^ Scrolling {
    IScrolling^ get ();
    void set (IScrolling^ value);
}
abstract Scrolling : IScrolling with get, set

Property Value

Type: IScrolling
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.SearchDialogAppearance Property

ISyntaxEditSearchDialogAppearance Property
When implemented by a class, gets or sets search dialog appearance.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SearchDialogAppearance SearchDialogAppearance { get; set; }
Property SearchDialogAppearance As SearchDialogAppearance
    Get
    Set
property SearchDialogAppearance SearchDialogAppearance {
    SearchDialogAppearance get ();
    void set (SearchDialogAppearance value);
}
abstract SearchDialogAppearance : SearchDialogAppearance with get, set

Property Value

Type: SearchDialogAppearance
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Selection Property

ISyntaxEditSelection Property
When implemented by a class, represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISelection Selection { get; set; }
Property Selection As ISelection
    Get
    Set
property ISelection^ Selection {
    ISelection^ get ();
    void set (ISelection^ value);
}
abstract Selection : ISelection with get, set

Property Value

Type: ISelection
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Source Property

ISyntaxEditSource Property
When implemented by a class, gets or sets an object that implements ITextSource interface containing an actual string data displayed by the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ITextSource Source { get; set; }
Property Source As ITextSource
    Get
    Set
property ITextSource^ Source {
    ITextSource^ get ();
    void set (ITextSource^ value);
}
abstract Source : ITextSource with get, set

Property Value

Type: ITextSource
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Spelling Property

ISyntaxEditSpelling Property
When implemented by a class, represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditSpelling Spelling { get; set; }
Property Spelling As IEditSpelling
    Get
    Set
property IEditSpelling^ Spelling {
    IEditSpelling^ get ();
    void set (IEditSpelling^ value);
}
abstract Spelling : IEditSpelling with get, set

Property Value

Type: IEditSpelling
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Strings Property

ISyntaxEditStrings Property
When implemented by a class, represents Lines property in the form of array of strings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] Strings { get; }
ReadOnly Property Strings As String()
    Get
property array<String^>^ Strings {
    array<String^>^ get ();
}
abstract Strings : string[] with get

Property Value

Type: String
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.SyntaxPaint Property

ISyntaxEditSyntaxPaint Property
When implemented by a class, represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEditSyntaxPaint SyntaxPaint { get; set; }
Property SyntaxPaint As IEditSyntaxPaint
    Get
    Set
property IEditSyntaxPaint^ SyntaxPaint {
    IEditSyntaxPaint^ get ();
    void set (IEditSyntaxPaint^ value);
}
abstract SyntaxPaint : IEditSyntaxPaint with get, set

Property Value

Type: IEditSyntaxPaint
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.Transparent Property

ISyntaxEditTransparent Property
When implemented by a class, gets or sets a boolean value that indicates whether Edit control should draw its background.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Transparent { get; set; }
Property Transparent As Boolean
    Get
    Set
property bool Transparent {
    bool get ();
    void set (bool value);
}
abstract Transparent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.UseDefaultMenu Property

ISyntaxEditUseDefaultMenu Property
When implemented by a class, indicates whether edit control should use built in popup menu.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseDefaultMenu { get; set; }
Property UseDefaultMenu As Boolean
    Get
    Set
property bool UseDefaultMenu {
    bool get ();
    void set (bool value);
}
abstract UseDefaultMenu : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.VisualTheme Property

ISyntaxEditVisualTheme Property
When implemented by a class, gets or sets visual theme for the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IVisualTheme VisualTheme { get; set; }
Property VisualTheme As IVisualTheme
    Get
    Set
property IVisualTheme^ VisualTheme {
    IVisualTheme^ get ();
    void set (IVisualTheme^ value);
}
abstract VisualTheme : IVisualTheme with get, set

Property Value

Type: IVisualTheme
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.VisualThemeType Property

ISyntaxEditVisualThemeType Property
When implemented by a class, gets or sets visual theme type for the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
VisualThemeType VisualThemeType { get; set; }
Property VisualThemeType As VisualThemeType
    Get
    Set
property VisualThemeType VisualThemeType {
    VisualThemeType get ();
    void set (VisualThemeType value);
}
abstract VisualThemeType : VisualThemeType with get, set

Property Value

Type: VisualThemeType
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.WhiteSpace Property

ISyntaxEditWhiteSpace Property
When implemented by a class, represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IWhiteSpace WhiteSpace { get; set; }
Property WhiteSpace As IWhiteSpace
    Get
    Set
property IWhiteSpace^ WhiteSpace {
    IWhiteSpace^ get ();
    void set (IWhiteSpace^ value);
}
abstract WhiteSpace : IWhiteSpace with get, set

Property Value

Type: IWhiteSpace
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit Events

ISyntaxEdit Events

The ISyntaxEdit type exposes the following members.

Events
 | Name | Description
Public event | AutoCorrect | When implemented by a class, occurs when control tries to auto correct word being typed. (Inherited from IAutoCorrect.)
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Public event | ModifiedChanged | When implemented by a class, occurs when modified state is changed.
Public event | NeedCodeCompletion | When implemented by a class, occurs when code completion window is to be displayed. (Inherited from ICodeCompletion.)
Public event | PaintBackground | When implemented by a class, occurs when Edit control should paint its background in transparent mode.
Public event | PromptOnReplace | When implemented by a class, occurs when replace dialog prompts on replace action.
Public event | SourceChanged | When implemented by a class, occurs when source changes.
Public event | SourceStateChanged | When implemented by a class, occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc.
Public event | SplitHorz | When implemented by a class, occurs when user splits Edit control horizontally. (Inherited from ISplitView.)
Public event | SplitVert | When implemented by a class, occurs when user splits Edit control vertically. (Inherited from ISplitView.)
Public event | TextChanged | When implemented by a class, occurs when the TextEditor text changes. (Inherited from ISearch.)
Public event | UnsplitHorz | When implemented by a class, occurs when horizontal split view is removed. (Inherited from ISplitView.)
Public event | UnsplitVert | When implemented by a class, occurs when vertical split view is removed. (Inherited from ISplitView.)
Top
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.ModifiedChanged Event

ISyntaxEditModifiedChanged Event
When implemented by a class, occurs when modified state is changed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ModifiedChanged
Event ModifiedChanged As EventHandler
 event EventHandler^ ModifiedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ModifiedChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.PaintBackground Event

ISyntaxEditPaintBackground Event
When implemented by a class, occurs when Edit control should paint its background in transparent mode.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event PaintEventHandler PaintBackground
Event PaintBackground As PaintEventHandler
 event PaintEventHandler^ PaintBackground {
    void add (PaintEventHandler^ value);
    void remove (PaintEventHandler^ value);
}
abstract PaintBackground : IEvent<PaintEventHandler,
    PaintEventArgs>

Value

Type: System.Windows.FormsPaintEventHandler
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.PromptOnReplace Event

ISyntaxEditPromptOnReplace Event
When implemented by a class, occurs when replace dialog prompts on replace action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event PromptOnReplaceEvent PromptOnReplace
Event PromptOnReplace As PromptOnReplaceEvent
 event PromptOnReplaceEvent^ PromptOnReplace {
    void add (PromptOnReplaceEvent^ value);
    void remove (PromptOnReplaceEvent^ value);
}
abstract PromptOnReplace : IEvent<PromptOnReplaceEvent,
    PromptReplaceEventArgs>

Value

Type: Alternet.EditorPromptOnReplaceEvent
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.SourceChanged Event

ISyntaxEditSourceChanged Event
When implemented by a class, occurs when source changes.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PropertyChangedEventArgs<ITextSource>> SourceChanged
Event SourceChanged As EventHandler(Of PropertyChangedEventArgs(Of ITextSource))
 event EventHandler<PropertyChangedEventArgs<ITextSource^>^>^ SourceChanged {
    void add (EventHandler<PropertyChangedEventArgs<ITextSource^>^>^ value);
    void remove (EventHandler<PropertyChangedEventArgs<ITextSource^>^>^ value);
}
abstract SourceChanged : IEvent<EventHandler<PropertyChangedEventArgs<ITextSource>>,
    PropertyChangedEventArgs<ITextSource>>

Value

Type: SystemEventHandlerPropertyChangedEventArgs ITextSource
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxEdit.SourceStateChanged Event

ISyntaxEditSourceStateChanged Event
When implemented by a class, occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event NotifyEvent SourceStateChanged
Event SourceStateChanged As NotifyEvent
 event NotifyEvent^ SourceStateChanged {
    void add (NotifyEvent^ value);
    void remove (NotifyEvent^ value);
}
abstract SourceStateChanged : IEvent<NotifyEvent,
    NotifyEventArgs>

Value

Type: Alternet.EditorNotifyEvent
See Also

Reference

ISyntaxEdit Interface
Alternet.Editor Namespace


ISyntaxPaint Interface

ISyntaxPaint Interface
Represents properties and methods, used to draw text and graphic primitives.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxPaint
Public Interface ISyntaxPaint
public interface class ISyntaxPaint
type ISyntaxPaint =  interface end

The ISyntaxPaint type exposes the following members.

Methods
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position.
Public method | EqualStyles | When implemented by a class, indicates whether given styles are equal.
Public method | GetFontColor | When implemented by a class, retrieves font color corresponding to given state.
Public method | GetFontStyle | When implemented by a class, retrieves font style corresponding to given state.
Public method | GetLexStyle | When implemented by a class, retrieves lex state corresponding to given parser style.
Public method | MeasureLine(Int32, Int32, Int32) | When implemented by a class, measures part of the string given at by its Index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | When implemented by a class, measures part of given string.
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of given string.
Public method | OnCustomDraw | When implemented by a class, raises an CustomDraw event.
Public method | PaintSyntax | When implemented by a class, perform syntax painting of the control on the graphic surface.
Public method | ResetDisableColorPaint | When implemented by a class, resets the DisableColorPaint to the default value.
Public method | ResetDisableSyntaxPaint | When implemented by a class, resets the DisableSyntaxPaint to the default value.
Top
Properties
 | Name | Description
Public property | DisableColorPaint | When implemented by a class, gets or sets a value indicating whether control uses colors to paint its content.
Public property | DisableSyntaxPaint | When implemented by a class, gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content.
Public property | Lexer | When implemented by a class, gets or sets object that can make lexical analysis for the control's content.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives.
Top
Events
 | Name | Description
Public event | CustomDraw | When implemented by a class, occurs when control draws its content.
Top
See Also

Reference

Alternet.Editor Namespace


ISyntaxPaint Methods

ISyntaxPaint Methods

The ISyntaxPaint type exposes the following members.

Methods
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position.
Public method | EqualStyles | When implemented by a class, indicates whether given styles are equal.
Public method | GetFontColor | When implemented by a class, retrieves font color corresponding to given state.
Public method | GetFontStyle | When implemented by a class, retrieves font style corresponding to given state.
Public method | GetLexStyle | When implemented by a class, retrieves lex state corresponding to given parser style.
Public method | MeasureLine(Int32, Int32, Int32) | When implemented by a class, measures part of the string given at by its Index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | When implemented by a class, measures part of given string.
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of given string.
Public method | OnCustomDraw | When implemented by a class, raises an CustomDraw event.
Public method | PaintSyntax | When implemented by a class, perform syntax painting of the control on the graphic surface.
Public method | ResetDisableColorPaint | When implemented by a class, resets the DisableColorPaint to the default value.
Public method | ResetDisableSyntaxPaint | When implemented by a class, resets the DisableSyntaxPaint to the default value.
Top
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.DrawLine Method

ISyntaxPaintDrawLine Method
Overload List
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position.
Top
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.DrawLine Method (Int32, Point, Rectangle)

ISyntaxPaintDrawLine Method (Int32, Point, Rectangle)
When implemented by a class, draws line given by its index at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawLine(
    int index,
    Point position,
    Rectangle clipRect
)
Sub DrawLine (
    index As Integer,
    position As Point,
    clipRect As Rectangle
)
void DrawLine(
    int index,
    Point position,
    Rectangle clipRect
)
abstract DrawLine :
        index : int *
        position : Point *
        clipRect : Rectangle -> unit

Parameters

index
Type: SystemInt32
Index of line to draw.
position
Type: System.DrawingPoint
Position to start drawing.
clipRect
Type: System.DrawingRectangle
Rectangular area of the control to draw line in.
See Also

Reference

ISyntaxPaint Interface
DrawLine Overload
Alternet.Editor Namespace


ISyntaxPaint.DrawLine Method (Int32, String, StringItemInfo[], Point, Rectangle)

ISyntaxPaintDrawLine Method (Int32, String, StringItemInfo, Point, Rectangle)
When implemented by a class, draws line given by its index at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DrawLine(
    int index,
    string line,
    StringItemInfo[] colorData,
    Point position,
    Rectangle clipRect
)
Sub DrawLine (
    index As Integer,
    line As String,
    colorData As StringItemInfo(),
    position As Point,
    clipRect As Rectangle
)
void DrawLine(
    int index,
    String^ line,
    array<StringItemInfo>^ colorData,
    Point position,
    Rectangle clipRect
)
abstract DrawLine :
        index : int *
        line : string *
        colorData : StringItemInfo[] *
        position : Point *
        clipRect : Rectangle -> unit

Parameters

index
Type: SystemInt32
Index of line to draw.
line
Type: SystemString
Specifies text to draw.
colorData
Type: Alternet.SyntaxStringItemInfo
Specifies array containing color data for given string.
position
Type: System.DrawingPoint
Position to start drawing.
clipRect
Type: System.DrawingRectangle
Rectangular area of the control to draw line in.
See Also

Reference

ISyntaxPaint Interface
DrawLine Overload
Alternet.Editor Namespace


ISyntaxPaint.EqualStyles Method

ISyntaxPaintEqualStyles Method
When implemented by a class, indicates whether given styles are equal.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool EqualStyles(
    StringItemInfo style1,
    StringItemInfo style2,
    bool useColors
)
Function EqualStyles (
    style1 As StringItemInfo,
    style2 As StringItemInfo,
    useColors As Boolean
) As Boolean
bool EqualStyles(
    StringItemInfo style1,
    StringItemInfo style2,
    bool useColors
)
abstract EqualStyles :
        style1 : StringItemInfo *
        style2 : StringItemInfo *
        useColors : bool -> bool

Parameters

style1
Type: Alternet.SyntaxStringItemInfo
First style to compare.
style2
Type: Alternet.SyntaxStringItemInfo
Second style to compare.
useColors
Type: SystemBoolean
Indicate whether colors of the styles are assumed.

Return Value

Type: Boolean
True if styles are equal; otherwise false.
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.GetFontColor Method

ISyntaxPaintGetFontColor Method
When implemented by a class, retrieves font color corresponding to given state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color GetFontColor(
    Color color,
    TextStyle textStyle
)
Function GetFontColor (
    color As Color,
    textStyle As TextStyle
) As Color
Color GetFontColor(
    Color color,
    TextStyle textStyle
)
abstract GetFontColor :
        color : Color *
        textStyle : TextStyle -> Color

Parameters

color
Type: System.DrawingColor
Default color.
textStyle
Type: Alternet.SyntaxTextStyle
Additional text styles.

Return Value

Type: Color
New value of font color.
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.GetFontStyle Method

ISyntaxPaintGetFontStyle Method
When implemented by a class, retrieves font style corresponding to given state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
FontStyle GetFontStyle(
    FontStyle fontStyle,
    TextStyle textStyle
)
Function GetFontStyle (
    fontStyle As FontStyle,
    textStyle As TextStyle
) As FontStyle
FontStyle GetFontStyle(
    FontStyle fontStyle,
    TextStyle textStyle
)
abstract GetFontStyle :
        fontStyle : FontStyle *
        textStyle : TextStyle -> FontStyle

Parameters

fontStyle
Type: System.DrawingFontStyle
Default style.
textStyle
Type: Alternet.SyntaxTextStyle
Additional text styles.

Return Value

Type: FontStyle
New value of font style.
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.GetLexStyle Method

ISyntaxPaintGetLexStyle Method
When implemented by a class, retrieves lex state corresponding to given parser style.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStyle GetLexStyle(
    StringItemInfo style,
    ref TextStyle textStyle
)
Function GetLexStyle (
    style As StringItemInfo,
    ByRef textStyle As TextStyle
) As ILexStyle
ILexStyle^ GetLexStyle(
    StringItemInfo style,
    TextStyle% textStyle
)
abstract GetLexStyle :
        style : StringItemInfo *
        textStyle : TextStyle byref -> ILexStyle

Parameters

style
Type: Alternet.SyntaxStringItemInfo
Index of parser style.
textStyle
Type: Alternet.SyntaxTextStyle
Additional text styles.

Return Value

Type: ILexStyle
LexStyle by its index.
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.MeasureLine Method

ISyntaxPaintMeasureLine Method
Overload List
 | Name | Description
Public method | MeasureLine(Int32, Int32, Int32) | When implemented by a class, measures part of the string given at by its Index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | When implemented by a class, measures part of given string.
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of given string.
Top
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.MeasureLine Method (Int32, Int32, Int32)

ISyntaxPaintMeasureLine Method (Int32, Int32, Int32)
When implemented by a class, measures part of the string given at by its Index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MeasureLine(
    int index,
    int pos,
    int len
)
Function MeasureLine (
    index As Integer,
    pos As Integer,
    len As Integer
) As Integer
int MeasureLine(
    int index,
    int pos,
    int len
)
abstract MeasureLine :
        index : int *
        pos : int *
        len : int -> int

Parameters

index
Type: SystemInt32
Index of line to measure.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.

Return Value

Type: Int32
Width of the measured part of the string.
See Also

Reference

ISyntaxPaint Interface
MeasureLine Overload
Alternet.Editor Namespace


ISyntaxPaint.MeasureLine Method (String, StringItemInfo[], Int32, Int32)

ISyntaxPaintMeasureLine Method (String, StringItemInfo, Int32, Int32)
When implemented by a class, measures part of given string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MeasureLine(
    string line,
    StringItemInfo[] colorData,
    int pos,
    int len
)
Function MeasureLine (
    line As String,
    colorData As StringItemInfo(),
    pos As Integer,
    len As Integer
) As Integer
int MeasureLine(
    String^ line,
    array<StringItemInfo>^ colorData,
    int pos,
    int len
)
abstract MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int -> int

Parameters

line
Type: SystemString
Text to measure.
colorData
Type: Alternet.SyntaxStringItemInfo
Color data attached to the given string.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.

Return Value

Type: Int32
Width of the measured part of the string.
See Also

Reference

ISyntaxPaint Interface
MeasureLine Overload
Alternet.Editor Namespace


ISyntaxPaint.MeasureLine Method (Int32, Int32, Int32, Int32, Int32, Boolean)

ISyntaxPaintMeasureLine Method (Int32, Int32, Int32, Int32, Int32, Boolean)
When implemented by a class, measures part of the string given by its index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MeasureLine(
    int index,
    int pos,
    int len,
    int width,
    out int chars,
    bool exact
)
Function MeasureLine (
    index As Integer,
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef chars As Integer,
    exact As Boolean
) As Integer
int MeasureLine(
    int index,
    int pos,
    int len,
    int width,
    [OutAttribute] int% chars,
    bool exact
)
abstract MeasureLine :
        index : int *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int

Parameters

index
Type: SystemInt32
Index of line to measure.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.
width
Type: SystemInt32
Maximum length of the string.
chars
Type: SystemInt32
Receive real number of measured chars.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the measured part of the string.
See Also

Reference

ISyntaxPaint Interface
MeasureLine Overload
Alternet.Editor Namespace


ISyntaxPaint.MeasureLine Method (String, StringItemInfo[], Int32, Int32, Int32, Int32, Boolean)

ISyntaxPaintMeasureLine Method (String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean)
When implemented by a class, measures part of given string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MeasureLine(
    string line,
    StringItemInfo[] colorData,
    int pos,
    int len,
    int width,
    out int chars,
    bool exact
)
Function MeasureLine (
    line As String,
    colorData As StringItemInfo(),
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef chars As Integer,
    exact As Boolean
) As Integer
int MeasureLine(
    String^ line,
    array<StringItemInfo>^ colorData,
    int pos,
    int len,
    int width,
    [OutAttribute] int% chars,
    bool exact
)
abstract MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int

Parameters

line
Type: SystemString
Text to measure.
colorData
Type: Alternet.SyntaxStringItemInfo
Color data attached to the given string.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.
width
Type: SystemInt32
Maximum length of the string.
chars
Type: SystemInt32
Receive real number of measured chars.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the measured part of the string.
See Also

Reference

ISyntaxPaint Interface
MeasureLine Overload
Alternet.Editor Namespace


ISyntaxPaint.OnCustomDraw Method

ISyntaxPaintOnCustomDraw Method
When implemented by a class, raises an CustomDraw event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OnCustomDraw(
    Rectangle rect,
    DrawStage stage,
    DrawState state,
    IDrawInfo info
)
Function OnCustomDraw (
    rect As Rectangle,
    stage As DrawStage,
    state As DrawState,
    info As IDrawInfo
) As Boolean
bool OnCustomDraw(
    Rectangle rect,
    DrawStage stage,
    DrawState state,
    IDrawInfo^ info
)
abstract OnCustomDraw :
        rect : Rectangle *
        stage : DrawStage *
        state : DrawState *
        info : IDrawInfo -> bool

Parameters

rect
Type: System.DrawingRectangle
Rectangular area of control to draw.
stage
Type: Alternet.EditorDrawStage
Specifies whether this method called before or after painting.
state
Type: Alternet.EditorDrawState
Specifies part of control to draw.
info
Type: Alternet.EditorIDrawInfo
Full information about drawing text fragment.

Return Value

Type: Boolean
True if user handles this event; otherwise false.
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.PaintSyntax Method

ISyntaxPaintPaintSyntax Method
When implemented by a class, perform syntax painting of the control on the graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
)
Sub PaintSyntax (
    startLine As Integer,
    endLine As Integer,
    position As Point,
    rect As Rectangle,
    location As Point,
    specialPaint As Boolean
)
void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
)
abstract PaintSyntax :
        startLine : int *
        endLine : int *
        position : Point *
        rect : Rectangle *
        location : Point *
        specialPaint : bool -> unit

Parameters

startLine
Type: SystemInt32
Specifies the first line of content to paint.
endLine
Type: SystemInt32
Specifies the last line of content to paint.
position
Type: System.DrawingPoint
The Point value that specifies start position to draw content from.
rect
Type: System.DrawingRectangle
Rectangular area of control to draw.
location
Type: System.DrawingPoint
The Point value that specifies start position to draw page from.
specialPaint
Type: SystemBoolean
Reserved for internal use. Used for Print and Print preview.
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.ResetDisableColorPaint Method

ISyntaxPaintResetDisableColorPaint Method
When implemented by a class, resets the DisableColorPaint to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDisableColorPaint()
Sub ResetDisableColorPaint
void ResetDisableColorPaint()
abstract ResetDisableColorPaint : unit -> unit
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.ResetDisableSyntaxPaint Method

ISyntaxPaintResetDisableSyntaxPaint Method
When implemented by a class, resets the DisableSyntaxPaint to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDisableSyntaxPaint()
Sub ResetDisableSyntaxPaint
void ResetDisableSyntaxPaint()
abstract ResetDisableSyntaxPaint : unit -> unit
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint Properties

ISyntaxPaint Properties

The ISyntaxPaint type exposes the following members.

Properties
 | Name | Description
Public property | DisableColorPaint | When implemented by a class, gets or sets a value indicating whether control uses colors to paint its content.
Public property | DisableSyntaxPaint | When implemented by a class, gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content.
Public property | Lexer | When implemented by a class, gets or sets object that can make lexical analysis for the control's content.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives.
Top
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.DisableColorPaint Property

ISyntaxPaintDisableColorPaint Property
When implemented by a class, gets or sets a value indicating whether control uses colors to paint its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DisableColorPaint { get; set; }
Property DisableColorPaint As Boolean
    Get
    Set
property bool DisableColorPaint {
    bool get ();
    void set (bool value);
}
abstract DisableColorPaint : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.DisableSyntaxPaint Property

ISyntaxPaintDisableSyntaxPaint Property
When implemented by a class, gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DisableSyntaxPaint { get; set; }
Property DisableSyntaxPaint As Boolean
    Get
    Set
property bool DisableSyntaxPaint {
    bool get ();
    void set (bool value);
}
abstract DisableSyntaxPaint : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.Lexer Property

ISyntaxPaintLexer Property
When implemented by a class, gets or sets object that can make lexical analysis for the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexer Lexer { get; set; }
Property Lexer As ILexer
    Get
    Set
property ILexer^ Lexer {
    ILexer^ get ();
    void set (ILexer^ value);
}
abstract Lexer : ILexer with get, set

Property Value

Type: ILexer
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.Painter Property

ISyntaxPaintPainter Property
Specifies IPainter object used to draw text and graphic primitives.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPainter Painter { get; set; }
Property Painter As IPainter
    Get
    Set
property IPainter^ Painter {
    IPainter^ get ();
    void set (IPainter^ value);
}
abstract Painter : IPainter with get, set

Property Value

Type: IPainter
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint Events

ISyntaxPaint Events

The ISyntaxPaint type exposes the following members.

Events
 | Name | Description
Public event | CustomDraw | When implemented by a class, occurs when control draws its content.
Top
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


ISyntaxPaint.CustomDraw Event

ISyntaxPaintCustomDraw Event
When implemented by a class, occurs when control draws its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event CustomDrawEvent CustomDraw
Event CustomDraw As CustomDrawEvent
 event CustomDrawEvent^ CustomDraw {
    void add (CustomDrawEvent^ value);
    void remove (CustomDrawEvent^ value);
}
abstract CustomDraw : IEvent<CustomDrawEvent,
    CustomDrawEventArgs>

Value

Type: Alternet.EditorCustomDrawEvent
See Also

Reference

ISyntaxPaint Interface
Alternet.Editor Namespace


IVisualTheme Interface

IVisualTheme Interface
Properties and methods for representing a single visual theme.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IVisualTheme : IDisposable
Public Interface IVisualTheme
    Inherits IDisposable
public interface class IVisualTheme : IDisposable
type IVisualTheme =
    interface
        interface IDisposable
    end

The IVisualTheme type exposes the following members.

Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox |
Public method | ApplyToCodeCompletionHint |
Public method | ApplyToEdit |
Public method | ApplyToScrollBar |
Public method | ApplyToScrollingButton |
Public method | ApplyToSplitButton |
Public method | Assign |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | LoadFromEdit |
Top
Properties
 | Name | Description
Public property | Font | When implemented by a class, gets or sets the font used for the color theme.
Public property | ImagesColor |
Public property | Item | When implemented by a class, specifies an Item indexer that uses the name of the LexStyle as an index.
Public property | LexStyles | When implemented by a class, gets or sets the LexStyle array used for the color theme.
Public property | Name | When implemented by a class, gets or sets the name of the color theme.
Public property | ReadOnly | When implemented by a class, gets or sets a bool value that indicates whether or not the color theme should be modified.
Top
See Also

Reference

Alternet.Editor Namespace


IVisualTheme Methods

IVisualTheme Methods

The IVisualTheme type exposes the following members.

Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox |
Public method | ApplyToCodeCompletionHint |
Public method | ApplyToEdit |
Public method | ApplyToScrollBar |
Public method | ApplyToScrollingButton |
Public method | ApplyToSplitButton |
Public method | Assign |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | LoadFromEdit |
Top
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.ApplyToCodeCompletionBox Method

IVisualThemeApplyToCodeCompletionBox Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyToCodeCompletionBox(
    ICodeCompletionBox codeCompletionBox
)
Sub ApplyToCodeCompletionBox (
    codeCompletionBox As ICodeCompletionBox
)
void ApplyToCodeCompletionBox(
    ICodeCompletionBox^ codeCompletionBox
)
abstract ApplyToCodeCompletionBox :
        codeCompletionBox : ICodeCompletionBox -> unit

Parameters

codeCompletionBox
Type: Alternet.Editor.CodeCompletionICodeCompletionBox
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.ApplyToCodeCompletionHint Method

IVisualThemeApplyToCodeCompletionHint Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyToCodeCompletionHint(
    ICodeCompletionHint codeCompletionHint
)
Sub ApplyToCodeCompletionHint (
    codeCompletionHint As ICodeCompletionHint
)
void ApplyToCodeCompletionHint(
    ICodeCompletionHint^ codeCompletionHint
)
abstract ApplyToCodeCompletionHint :
        codeCompletionHint : ICodeCompletionHint -> unit

Parameters

codeCompletionHint
Type: Alternet.Editor.CodeCompletionICodeCompletionHint
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.ApplyToEdit Method

IVisualThemeApplyToEdit Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyToEdit(
    ISyntaxEdit edit
)
Sub ApplyToEdit (
    edit As ISyntaxEdit
)
void ApplyToEdit(
    ISyntaxEdit^ edit
)
abstract ApplyToEdit :
        edit : ISyntaxEdit -> unit

Parameters

edit
Type: Alternet.EditorISyntaxEdit
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.ApplyToScrollBar Method

IVisualThemeApplyToScrollBar Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyToScrollBar(
    ScrollBar scrollBar
)
Sub ApplyToScrollBar (
    scrollBar As ScrollBar
)
void ApplyToScrollBar(
    ScrollBar^ scrollBar
)
abstract ApplyToScrollBar :
        scrollBar : ScrollBar -> unit

Parameters

scrollBar
Type: Alternet.EditorScrollBar
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.ApplyToScrollingButton Method

IVisualThemeApplyToScrollingButton Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyToScrollingButton(
    IScrollingButton button
)
Sub ApplyToScrollingButton (
    button As IScrollingButton
)
void ApplyToScrollingButton(
    IScrollingButton^ button
)
abstract ApplyToScrollingButton :
        button : IScrollingButton -> unit

Parameters

button
Type: Alternet.EditorIScrollingButton
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.ApplyToSplitButton Method

IVisualThemeApplyToSplitButton Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ApplyToSplitButton(
    IScrollingButton button
)
Sub ApplyToSplitButton (
    button As IScrollingButton
)
void ApplyToSplitButton(
    IScrollingButton^ button
)
abstract ApplyToSplitButton :
        button : IScrollingButton -> unit

Parameters

button
Type: Alternet.EditorIScrollingButton
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.Assign Method

IVisualThemeAssign Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IVisualTheme source
)
Sub Assign (
    source As IVisualTheme
)
void Assign(
    IVisualTheme^ source
)
abstract Assign :
        source : IVisualTheme -> unit

Parameters

source
Type: Alternet.EditorIVisualTheme
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.LoadFromEdit Method

IVisualThemeLoadFromEdit Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadFromEdit(
    ISyntaxEdit edit
)
Sub LoadFromEdit (
    edit As ISyntaxEdit
)
void LoadFromEdit(
    ISyntaxEdit^ edit
)
abstract LoadFromEdit :
        edit : ISyntaxEdit -> unit

Parameters

edit
Type: Alternet.EditorISyntaxEdit
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme Properties

IVisualTheme Properties

The IVisualTheme type exposes the following members.

Properties
 | Name | Description
Public property | Font | When implemented by a class, gets or sets the font used for the color theme.
Public property | ImagesColor |
Public property | Item | When implemented by a class, specifies an Item indexer that uses the name of the LexStyle as an index.
Public property | LexStyles | When implemented by a class, gets or sets the LexStyle array used for the color theme.
Public property | Name | When implemented by a class, gets or sets the name of the color theme.
Public property | ReadOnly | When implemented by a class, gets or sets a bool value that indicates whether or not the color theme should be modified.
Top
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.Font Property

IVisualThemeFont Property
When implemented by a class, gets or sets the font used for the color theme.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Font Font { get; set; }
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

Property Value

Type: Font
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.ImagesColor Property

IVisualThemeImagesColor Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
VisualThemeImagesColor ImagesColor { get; set; }
Property ImagesColor As VisualThemeImagesColor
    Get
    Set
property VisualThemeImagesColor ImagesColor {
    VisualThemeImagesColor get ();
    void set (VisualThemeImagesColor value);
}
abstract ImagesColor : VisualThemeImagesColor with get, set

Property Value

Type: VisualThemeImagesColor
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.Item Property

IVisualThemeItem Property
When implemented by a class, specifies an Item indexer that uses the name of the LexStyle as an index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStyle this[
    string name
] { get; }
ReadOnly Default Property Item (
    name As String
) As ILexStyle
    Get
property ILexStyle^ default[String^ name] {
    ILexStyle^ get (String^ name);
}
abstract Item : ILexStyle with get

Parameters

name
Type: SystemString
Name of the LexStyle such as "ident".

Return Value

Type: ILexStyle
LexStyle object that corresponds to the name parameter, or null for an invalid name.
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.LexStyles Property

IVisualThemeLexStyles Property
When implemented by a class, gets or sets the LexStyle array used for the color theme.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStyles LexStyles { get; set; }
Property LexStyles As ILexStyles
    Get
    Set
property ILexStyles^ LexStyles {
    ILexStyles^ get ();
    void set (ILexStyles^ value);
}
abstract LexStyles : ILexStyles with get, set

Property Value

Type: ILexStyles
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.Name Property

IVisualThemeName Property
When implemented by a class, gets or sets the name of the color theme.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IVisualTheme.ReadOnly Property

IVisualThemeReadOnly Property
When implemented by a class, gets or sets a bool value that indicates whether or not the color theme should be modified.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReadOnly { get; set; }
Property ReadOnly As Boolean
    Get
    Set
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
abstract ReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IVisualTheme Interface
Alternet.Editor Namespace


IWhiteSpace Interface

IWhiteSpace Interface
Represents properties of "invisible" characters, such as spaces and tabs, in the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWhiteSpace : IUpdate
Public Interface IWhiteSpace
    Inherits IUpdate
public interface class IWhiteSpace : IUpdate
type IWhiteSpace =
    interface
        interface IUpdate
    end

The IWhiteSpace type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IWhiteSpace object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | ResetEofSymbol | When implemented by a class, resets the EofSymbol to the default value.
Public method | ResetEolSymbol | When implemented by a class, resets the EolSymbol to the default value.
Public method | ResetSpaceSymbol | When implemented by a class, resets the SpaceSymbol to the default value.
Public method | ResetSymbolColor | When implemented by a class, resets the SymbolColor to the default value.
Public method | ResetTabSymbol | When implemented by a class, resets the TabSymbol to the default value.
Public method | ResetVisible | When implemented by a class, resets the Visible to the default value.
Public method | ResetWordWrapSymbol | When implemented by a class, resets the WordWrapSymbol to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | EofString | When implemented by a class, represents one character string that specifies end of file.
Public property | EofSymbol | When implemented by a class, gets or sets character that specifies end of file.
Public property | EolString | When implemented by a class, represents one character string that specifies end of line.
Public property | EolSymbol | When implemented by a class, gets or sets character that specifies end of line.
Public property | LongSpaceSymbol | When implemented by a class, gets or sets character that introduces special symbol to paint instead of the long space character.
Public property | SpaceString | When implemented by a class, represents one character string that introduces special symbol to paint instead of the space character.
Public property | SpaceSymbol | When implemented by a class, gets or sets character that introduces special symbol to paint instead of the space character.
Public property | SymbolColor | When implemented by a class, gets or sets color used to paint special symbols.
Public property | TabString | When implemented by a class, represents one character string that introduces special symbol to paint instead of the tab character.
Public property | TabSymbol | When implemented by a class, gets or sets character that introduces special symbol to paint instead of the tab character.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether white space symbols are visible in the control's text content.
Public property | WordWrapString | When implemented by a class, represents one character string that specifies wrapped file.
Public property | WordWrapSymbol | When implemented by a class, gets or sets character that specifies wrapped line.
Top
See Also

Reference

Alternet.Editor Namespace


IWhiteSpace Methods

IWhiteSpace Methods

The IWhiteSpace type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents from another IWhiteSpace object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | ResetEofSymbol | When implemented by a class, resets the EofSymbol to the default value.
Public method | ResetEolSymbol | When implemented by a class, resets the EolSymbol to the default value.
Public method | ResetSpaceSymbol | When implemented by a class, resets the SpaceSymbol to the default value.
Public method | ResetSymbolColor | When implemented by a class, resets the SymbolColor to the default value.
Public method | ResetTabSymbol | When implemented by a class, resets the TabSymbol to the default value.
Public method | ResetVisible | When implemented by a class, resets the Visible to the default value.
Public method | ResetWordWrapSymbol | When implemented by a class, resets the WordWrapSymbol to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.Assign Method

IWhiteSpaceAssign Method
When implemented by a class, copies the contents from another IWhiteSpace object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IWhiteSpace source
)
Sub Assign (
    source As IWhiteSpace
)
void Assign(
    IWhiteSpace^ source
)
abstract Assign :
        source : IWhiteSpace -> unit

Parameters

source
Type: Alternet.EditorIWhiteSpace
Specifies IWhiteSpace to assign.
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.ResetEofSymbol Method

IWhiteSpaceResetEofSymbol Method
When implemented by a class, resets the EofSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetEofSymbol()
Sub ResetEofSymbol
void ResetEofSymbol()
abstract ResetEofSymbol : unit -> unit
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.ResetEolSymbol Method

IWhiteSpaceResetEolSymbol Method
When implemented by a class, resets the EolSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetEolSymbol()
Sub ResetEolSymbol
void ResetEolSymbol()
abstract ResetEolSymbol : unit -> unit
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.ResetSpaceSymbol Method

IWhiteSpaceResetSpaceSymbol Method
When implemented by a class, resets the SpaceSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetSpaceSymbol()
Sub ResetSpaceSymbol
void ResetSpaceSymbol()
abstract ResetSpaceSymbol : unit -> unit
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.ResetSymbolColor Method

IWhiteSpaceResetSymbolColor Method
When implemented by a class, resets the SymbolColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetSymbolColor()
Sub ResetSymbolColor
void ResetSymbolColor()
abstract ResetSymbolColor : unit -> unit
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.ResetTabSymbol Method

IWhiteSpaceResetTabSymbol Method
When implemented by a class, resets the TabSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetTabSymbol()
Sub ResetTabSymbol
void ResetTabSymbol()
abstract ResetTabSymbol : unit -> unit
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.ResetVisible Method

IWhiteSpaceResetVisible Method
When implemented by a class, resets the Visible to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetVisible()
Sub ResetVisible
void ResetVisible()
abstract ResetVisible : unit -> unit
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.ResetWordWrapSymbol Method

IWhiteSpaceResetWordWrapSymbol Method
When implemented by a class, resets the WordWrapSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetWordWrapSymbol()
Sub ResetWordWrapSymbol
void ResetWordWrapSymbol()
abstract ResetWordWrapSymbol : unit -> unit
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace Properties

IWhiteSpace Properties

The IWhiteSpace type exposes the following members.

Properties
 | Name | Description
Public property | EofString | When implemented by a class, represents one character string that specifies end of file.
Public property | EofSymbol | When implemented by a class, gets or sets character that specifies end of file.
Public property | EolString | When implemented by a class, represents one character string that specifies end of line.
Public property | EolSymbol | When implemented by a class, gets or sets character that specifies end of line.
Public property | LongSpaceSymbol | When implemented by a class, gets or sets character that introduces special symbol to paint instead of the long space character.
Public property | SpaceString | When implemented by a class, represents one character string that introduces special symbol to paint instead of the space character.
Public property | SpaceSymbol | When implemented by a class, gets or sets character that introduces special symbol to paint instead of the space character.
Public property | SymbolColor | When implemented by a class, gets or sets color used to paint special symbols.
Public property | TabString | When implemented by a class, represents one character string that introduces special symbol to paint instead of the tab character.
Public property | TabSymbol | When implemented by a class, gets or sets character that introduces special symbol to paint instead of the tab character.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether white space symbols are visible in the control's text content.
Public property | WordWrapString | When implemented by a class, represents one character string that specifies wrapped file.
Public property | WordWrapSymbol | When implemented by a class, gets or sets character that specifies wrapped line.
Top
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.EofString Property

IWhiteSpaceEofString Property
When implemented by a class, represents one character string that specifies end of file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string EofString { get; }
ReadOnly Property EofString As String
    Get
property String^ EofString {
    String^ get ();
}
abstract EofString : string with get

Property Value

Type: String
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.EofSymbol Property

IWhiteSpaceEofSymbol Property
When implemented by a class, gets or sets character that specifies end of file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char EofSymbol { get; set; }
Property EofSymbol As Char
    Get
    Set
property wchar_t EofSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract EofSymbol : char with get, set

Property Value

Type: Char
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.EolString Property

IWhiteSpaceEolString Property
When implemented by a class, represents one character string that specifies end of line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string EolString { get; }
ReadOnly Property EolString As String
    Get
property String^ EolString {
    String^ get ();
}
abstract EolString : string with get

Property Value

Type: String
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.EolSymbol Property

IWhiteSpaceEolSymbol Property
When implemented by a class, gets or sets character that specifies end of line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char EolSymbol { get; set; }
Property EolSymbol As Char
    Get
    Set
property wchar_t EolSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract EolSymbol : char with get, set

Property Value

Type: Char
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.LongSpaceSymbol Property

IWhiteSpaceLongSpaceSymbol Property
When implemented by a class, gets or sets character that introduces special symbol to paint instead of the long space character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char LongSpaceSymbol { get; set; }
Property LongSpaceSymbol As Char
    Get
    Set
property wchar_t LongSpaceSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract LongSpaceSymbol : char with get, set

Property Value

Type: Char
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.SpaceString Property

IWhiteSpaceSpaceString Property
When implemented by a class, represents one character string that introduces special symbol to paint instead of the space character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string SpaceString { get; }
ReadOnly Property SpaceString As String
    Get
property String^ SpaceString {
    String^ get ();
}
abstract SpaceString : string with get

Property Value

Type: String
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.SpaceSymbol Property

IWhiteSpaceSpaceSymbol Property
When implemented by a class, gets or sets character that introduces special symbol to paint instead of the space character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char SpaceSymbol { get; set; }
Property SpaceSymbol As Char
    Get
    Set
property wchar_t SpaceSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract SpaceSymbol : char with get, set

Property Value

Type: Char
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.SymbolColor Property

IWhiteSpaceSymbolColor Property
When implemented by a class, gets or sets color used to paint special symbols.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color SymbolColor { get; set; }
Property SymbolColor As Color
    Get
    Set
property Color SymbolColor {
    Color get ();
    void set (Color value);
}
abstract SymbolColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.TabString Property

IWhiteSpaceTabString Property
When implemented by a class, represents one character string that introduces special symbol to paint instead of the tab character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string TabString { get; }
ReadOnly Property TabString As String
    Get
property String^ TabString {
    String^ get ();
}
abstract TabString : string with get

Property Value

Type: String
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.TabSymbol Property

IWhiteSpaceTabSymbol Property
When implemented by a class, gets or sets character that introduces special symbol to paint instead of the tab character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char TabSymbol { get; set; }
Property TabSymbol As Char
    Get
    Set
property wchar_t TabSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract TabSymbol : char with get, set

Property Value

Type: Char
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.Visible Property

IWhiteSpaceVisible Property
When implemented by a class, gets or sets a value indicating whether white space symbols are visible in the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.WordWrapString Property

IWhiteSpaceWordWrapString Property
When implemented by a class, represents one character string that specifies wrapped file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string WordWrapString { get; }
ReadOnly Property WordWrapString As String
    Get
property String^ WordWrapString {
    String^ get ();
}
abstract WordWrapString : string with get

Property Value

Type: String
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWhiteSpace.WordWrapSymbol Property

IWhiteSpaceWordWrapSymbol Property
When implemented by a class, gets or sets character that specifies wrapped line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char WordWrapSymbol { get; set; }
Property WordWrapSymbol As Char
    Get
    Set
property wchar_t WordWrapSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract WordWrapSymbol : char with get, set

Property Value

Type: Char
See Also

Reference

IWhiteSpace Interface
Alternet.Editor Namespace


IWordWrap Interface

IWordWrap Interface
Represents properties and methods to wrap Edit control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWordWrap
Public Interface IWordWrap
public interface class IWordWrap
type IWordWrap =  interface end

The IWordWrap type exposes the following members.

Methods
 | Name | Description
Public method | GetWrapMargin | When implemented by a class, returns position of the wrapping margin.
Public method | ResetWordWrap | When implemented by a class, resets the WordWrap to the default value.
Public method | ResetWrapAtMargin | When implemented by a class, resets the WrapAtMargin to the default value.
Public method | UpdateWordWrap | When implemented by a class, re-wraps all lines in the text.
Public method | UpdateWordWrap(Int32, Int32) | When implemented by a class, re-wraps lines in the text within specific scope.
Top
Properties
 | Name | Description
Public property | WordWrap | When implemented by a class, gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary.
Public property | WrapAtMargin | When implemented by a class, gets or sets a value indicating whether control automatically wraps words at margin position.
Public property | WrapMargin | When implemented by a class, gets position of the wrapping margin.
Top
See Also

Reference

Alternet.Editor Namespace


IWordWrap Methods

IWordWrap Methods

The IWordWrap type exposes the following members.

Methods
 | Name | Description
Public method | GetWrapMargin | When implemented by a class, returns position of the wrapping margin.
Public method | ResetWordWrap | When implemented by a class, resets the WordWrap to the default value.
Public method | ResetWrapAtMargin | When implemented by a class, resets the WrapAtMargin to the default value.
Public method | UpdateWordWrap | When implemented by a class, re-wraps all lines in the text.
Public method | UpdateWordWrap(Int32, Int32) | When implemented by a class, re-wraps lines in the text within specific scope.
Top
See Also

Reference

IWordWrap Interface
Alternet.Editor Namespace


IWordWrap.GetWrapMargin Method

IWordWrapGetWrapMargin Method
When implemented by a class, returns position of the wrapping margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetWrapMargin()
Function GetWrapMargin As Integer
int GetWrapMargin()
abstract GetWrapMargin : unit -> int

Return Value

Type: Int32
See Also

Reference

IWordWrap Interface
Alternet.Editor Namespace


IWordWrap.ResetWordWrap Method

IWordWrapResetWordWrap Method
When implemented by a class, resets the WordWrap to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetWordWrap()
Sub ResetWordWrap
void ResetWordWrap()
abstract ResetWordWrap : unit -> unit
See Also

Reference

IWordWrap Interface
Alternet.Editor Namespace


IWordWrap.ResetWrapAtMargin Method

IWordWrapResetWrapAtMargin Method
When implemented by a class, resets the WrapAtMargin to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetWrapAtMargin()
Sub ResetWrapAtMargin
void ResetWrapAtMargin()
abstract ResetWrapAtMargin : unit -> unit
See Also

Reference

IWordWrap Interface
Alternet.Editor Namespace


IWordWrap.UpdateWordWrap Method

IWordWrapUpdateWordWrap Method
Overload List
 | Name | Description
Public method | UpdateWordWrap | When implemented by a class, re-wraps all lines in the text.
Public method | UpdateWordWrap(Int32, Int32) | When implemented by a class, re-wraps lines in the text within specific scope.
Top
See Also

Reference

IWordWrap Interface
Alternet.Editor Namespace


IWordWrap.UpdateWordWrap Method

IWordWrapUpdateWordWrap Method
When implemented by a class, re-wraps all lines in the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UpdateWordWrap()
Function UpdateWordWrap As Boolean
bool UpdateWordWrap()
abstract UpdateWordWrap : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IWordWrap Interface
UpdateWordWrap Overload
Alternet.Editor Namespace


IWordWrap.UpdateWordWrap Method (Int32, Int32)

IWordWrapUpdateWordWrap Method (Int32, Int32)
When implemented by a class, re-wraps lines in the text within specific scope.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UpdateWordWrap(
    int first,
    int last
)
Function UpdateWordWrap (
    first As Integer,
    last As Integer
) As Boolean
bool UpdateWordWrap(
    int first,
    int last
)
abstract UpdateWordWrap :
        first : int *
        last : int -> bool

Parameters

first
Type: SystemInt32
Specifies first line to wrap.
last
Type: SystemInt32
Specifies last line to wrap.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IWordWrap Interface
UpdateWordWrap Overload
Alternet.Editor Namespace


IWordWrap Properties

IWordWrap Properties

The IWordWrap type exposes the following members.

Properties
 | Name | Description
Public property | WordWrap | When implemented by a class, gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary.
Public property | WrapAtMargin | When implemented by a class, gets or sets a value indicating whether control automatically wraps words at margin position.
Public property | WrapMargin | When implemented by a class, gets position of the wrapping margin.
Top
See Also

Reference

IWordWrap Interface
Alternet.Editor Namespace


IWordWrap.WordWrap Property

IWordWrapWordWrap Property
When implemented by a class, gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WordWrap { get; set; }
Property WordWrap As Boolean
    Get
    Set
property bool WordWrap {
    bool get ();
    void set (bool value);
}
abstract WordWrap : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IWordWrap Interface
Alternet.Editor Namespace


IWordWrap.WrapAtMargin Property

IWordWrapWrapAtMargin Property
When implemented by a class, gets or sets a value indicating whether control automatically wraps words at margin position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WrapAtMargin { get; set; }
Property WrapAtMargin As Boolean
    Get
    Set
property bool WrapAtMargin {
    bool get ();
    void set (bool value);
}
abstract WrapAtMargin : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IWordWrap Interface
Alternet.Editor Namespace


IWordWrap.WrapMargin Property

IWordWrapWrapMargin Property
When implemented by a class, gets position of the wrapping margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int WrapMargin { get; }
ReadOnly Property WrapMargin As Integer
    Get
property int WrapMargin {
    int get ();
}
abstract WrapMargin : int with get

Property Value

Type: Int32
See Also

Reference

IWordWrap Interface
Alternet.Editor Namespace


KeyData Class

KeyData Class
Represents data for a particular record in the Hashtable that contains keys with attached actions.
Inheritance Hierarchy
SystemObject
Alternet.EditorKeyData
Alternet.EditorMacroKeyData

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyData : IKeyData
Public Class KeyData
    Implements IKeyData
public ref class KeyData : IKeyData
type KeyData =
    class
        interface IKeyData
    end

The KeyData type exposes the following members.

Constructors
 | Name | Description
Public method | KeyData | Initializes a new instance of the KeyListData class with default settings.
Public method | KeyData(Keys, KeyEvent, KeyEventEx, Object, Int32, Int32) | Initializes a new instance of the KeyListData class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts KeyListData content to string. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Action | Action that executes when the key is pressed.
Public property | ActionEx | Extended action that executes when the key is pressed.
Public property | EventName | String representation of the action.
Public property | Keys | Key to which some action is attached.
Public property | LeaveState | State of the Edit control after key is pressed.
Public property | Param | Object passed as a parameter to the extended action.
Public property | State | State of the Edit control before key is pressed.
Top
See Also

Reference

Alternet.Editor Namespace


KeyData Constructor

KeyData Constructor
Overload List
 | Name | Description
Public method | KeyData | Initializes a new instance of the KeyListData class with default settings.
Public method | KeyData(Keys, KeyEvent, KeyEventEx, Object, Int32, Int32) | Initializes a new instance of the KeyListData class with specified parameters.
Top
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData Constructor

KeyData Constructor
Initializes a new instance of the KeyListData class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyData()
Public Sub New
public:
KeyData()
new : unit -> KeyData
See Also

Reference

KeyData Class
KeyData Overload
Alternet.Editor Namespace


KeyData Constructor (Keys, KeyEvent, KeyEventEx, Object, Int32, Int32)

KeyData Constructor (Keys, KeyEvent, KeyEventEx, Object, Int32, Int32)
Initializes a new instance of the KeyListData class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyData(
    Keys keys,
    KeyEvent action,
    KeyEventEx actionEx,
    Object param,
    int state,
    int leaveState
)
Public Sub New (
    keys As Keys,
    action As KeyEvent,
    actionEx As KeyEventEx,
    param As Object,
    state As Integer,
    leaveState As Integer
)
public:
KeyData(
    Keys keys,
    KeyEvent^ action,
    KeyEventEx^ actionEx,
    Object^ param,
    int state,
    int leaveState
)
new :
        keys : Keys *
        action : KeyEvent *
        actionEx : KeyEventEx *
        param : Object *
        state : int *
        leaveState : int -> KeyData

Parameters

keys
Type: System.Windows.FormsKeys
Specifies key data of this new instance.
action
Type: Alternet.EditorKeyEvent
Action that executes when the key is pressed.
actionEx
Type: Alternet.EditorKeyEventEx
Extended action that executes when the key is pressed.
param
Type: SystemObject
Object passed as a parameter to the extended action.
state
Type: SystemInt32
State of the Edit control before key is pressed.
leaveState
Type: SystemInt32
State of the Edit control after key is pressed.
See Also

Reference

KeyData Class
KeyData Overload
Alternet.Editor Namespace


KeyData Methods

KeyData Methods

The KeyData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts KeyListData content to string. (Overrides ObjectToString.)
Top
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData.ToString Method

KeyDataToString Method
Converts KeyListData content to string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
String that represents this KeyListData.
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData Properties

KeyData Properties

The KeyData type exposes the following members.

Properties
 | Name | Description
Public property | Action | Action that executes when the key is pressed.
Public property | ActionEx | Extended action that executes when the key is pressed.
Public property | EventName | String representation of the action.
Public property | Keys | Key to which some action is attached.
Public property | LeaveState | State of the Edit control after key is pressed.
Public property | Param | Object passed as a parameter to the extended action.
Public property | State | State of the Edit control before key is pressed.
Top
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData.Action Property

KeyDataAction Property
Action that executes when the key is pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEvent Action { get; set; }
Public Property Action As KeyEvent
    Get
    Set
public:
virtual property KeyEvent^ Action {
    KeyEvent^ get () sealed;
    void set (KeyEvent^ value) sealed;
}
abstract Action : KeyEvent with get, set
override Action : KeyEvent with get, set

Property Value

Type: KeyEvent

Implements

IKeyDataAction
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData.ActionEx Property

KeyDataActionEx Property
Extended action that executes when the key is pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventEx ActionEx { get; set; }
Public Property ActionEx As KeyEventEx
    Get
    Set
public:
virtual property KeyEventEx^ ActionEx {
    KeyEventEx^ get () sealed;
    void set (KeyEventEx^ value) sealed;
}
abstract ActionEx : KeyEventEx with get, set
override ActionEx : KeyEventEx with get, set

Property Value

Type: KeyEventEx

Implements

IKeyDataActionEx
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData.EventName Property

KeyDataEventName Property
String representation of the action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EventName { get; set; }
Public Property EventName As String
    Get
    Set
public:
virtual property String^ EventName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract EventName : string with get, set
override EventName : string with get, set

Property Value

Type: String

Implements

IKeyDataEventName
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData.Keys Property

KeyDataKeys Property
Key to which some action is attached.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Keys Keys { get; set; }
Public Property Keys As Keys
    Get
    Set
public:
virtual property Keys Keys {
    Keys get () sealed;
    void set (Keys value) sealed;
}
abstract Keys : Keys with get, set
override Keys : Keys with get, set

Property Value

Type: Keys

Implements

IKeyDataKeys
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData.LeaveState Property

KeyDataLeaveState Property
State of the Edit control after key is pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LeaveState { get; set; }
Public Property LeaveState As Integer
    Get
    Set
public:
virtual property int LeaveState {
    int get () sealed;
    void set (int value) sealed;
}
abstract LeaveState : int with get, set
override LeaveState : int with get, set

Property Value

Type: Int32

Implements

IKeyDataLeaveState
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData.Param Property

KeyDataParam Property
Object passed as a parameter to the extended action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Param { get; set; }
Public Property Param As Object
    Get
    Set
public:
virtual property Object^ Param {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
abstract Param : Object with get, set
override Param : Object with get, set

Property Value

Type: Object

Implements

IKeyDataParam
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyData.State Property

KeyDataState Property
State of the Edit control before key is pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int State { get; set; }
Public Property State As Integer
    Get
    Set
public:
virtual property int State {
    int get () sealed;
    void set (int value) sealed;
}
abstract State : int with get, set
override State : int with get, set

Property Value

Type: Int32

Implements

IKeyDataState
See Also

Reference

KeyData Class
Alternet.Editor Namespace


KeyEvent Delegate

KeyEvent Delegate
Represents a method that will handle the key event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void KeyEvent()
Public Delegate Sub KeyEvent
public delegate void KeyEvent()
type KeyEvent =
    delegate of unit -> unit
See Also

Reference

Alternet.Editor Namespace


KeyEventEx Delegate

KeyEventEx Delegate
Represents a method that will handle extended key event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void KeyEventEx(
    Object param
)
Public Delegate Sub KeyEventEx (
    param As Object
)
public delegate void KeyEventEx(
    Object^ param
)
type KeyEventEx =
    delegate of
        param : Object -> unit

Parameters

param
Type: SystemObject
Object containing additional event data.
See Also

Reference

Alternet.Editor Namespace


KeyEventType Enumeration

KeyEventType Enumeration
Represents type of key event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum KeyEventType
Public Enumeration KeyEventType
public enum class KeyEventType
type KeyEventType
Members
Member name | Value | Description
None | 0 | No key event.
IntParam | 1 | Key event for integer parameter.
CharParam | 2 | Key event for char parameter.
SelectionParam | 3 | Key event for SelectionType parameter.
See Also

Reference

Alternet.Editor Namespace


KeyList Class

KeyList Class
Represents list of key or its combinations with attached actions.
Inheritance Hierarchy
SystemObject
Alternet.EditorKeyList

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyList : IKeyList
Public Class KeyList
    Implements IKeyList
public ref class KeyList : IKeyList
type KeyList =
    class
        interface IKeyList
    end

The KeyList type exposes the following members.

Constructors
 | Name | Description
Public method | KeyList | Initializes a new instance of the KeyList class with specified owner.
Top
Methods
 | Name | Description
Public method | Add(Keys, KeyEvent) | Adds a new key to key collection with specified action.
Public method | Add(Keys, KeyEventEx, Object) | Adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEvent, Int32, Int32) | Adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEventEx, Object, Int32, Int32) | Adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEvent, KeyEventEx, Object, Int32, Int32) | Adds a new key to key collection with specified parameters.
Public method | AddNormal(Keys, KeyEvent) | Adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | AddNormal(Keys, KeyEventEx, Object) | Adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | Clear | Removes all elements from the key list.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecuteKey | Executes action or extended action attached to the specified key.
Public method | FindKey | Indicates whether given key locates within the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Remove(Keys) | Removes given key from the key collection.
Public method | Remove(Keys, Int32) | Removes given key from the key collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EventData | Represents array of event handlers associated with keys.
Public property | Handlers | Represents an event handlers collection which contains elements that can be used as a particular action attached to key or key combination from the KeyList.
Top
Remarks
KeyList class is used to dynamically link key sequences with executing some actions within Edit control. You can use this class to customize reaction on pressing certain keys sequences in the Edit control.
See Also

Reference

Alternet.Editor Namespace


KeyList Constructor

KeyList Constructor
Initializes a new instance of the KeyList class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyList(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
KeyList(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> KeyList

Parameters

owner
Type: Alternet.EditorISyntaxEdit
SyntaxEdit that owns this new instance.
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList Methods

KeyList Methods

The KeyList type exposes the following members.

Methods
 | Name | Description
Public method | Add(Keys, KeyEvent) | Adds a new key to key collection with specified action.
Public method | Add(Keys, KeyEventEx, Object) | Adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEvent, Int32, Int32) | Adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEventEx, Object, Int32, Int32) | Adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEvent, KeyEventEx, Object, Int32, Int32) | Adds a new key to key collection with specified parameters.
Public method | AddNormal(Keys, KeyEvent) | Adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | AddNormal(Keys, KeyEventEx, Object) | Adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | Clear | Removes all elements from the key list.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecuteKey | Executes action or extended action attached to the specified key.
Public method | FindKey | Indicates whether given key locates within the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Remove(Keys) | Removes given key from the key collection.
Public method | Remove(Keys, Int32) | Removes given key from the key collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList.Add Method

KeyListAdd Method
Overload List
 | Name | Description
Public method | Add(Keys, KeyEvent) | Adds a new key to key collection with specified action.
Public method | Add(Keys, KeyEventEx, Object) | Adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEvent, Int32, Int32) | Adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEventEx, Object, Int32, Int32) | Adds a new key to key collection with specified parameters.
Public method | Add(Keys, KeyEvent, KeyEventEx, Object, Int32, Int32) | Adds a new key to key collection with specified parameters.
Top
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList.Add Method (Keys, KeyEvent)

KeyListAdd Method (Keys, KeyEvent)
Adds a new key to key collection with specified action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    Keys keys,
    KeyEvent action
)
Public Overridable Sub Add (
    keys As Keys,
    action As KeyEvent
)
public:
virtual void Add(
    Keys keys,
    KeyEvent^ action
)
abstract Add :
        keys : Keys *
        action : KeyEvent -> unit
override Add :
        keys : Keys *
        action : KeyEvent -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEvent
Action that executes when the key is pressed.

Implements

IKeyListAdd(Keys, KeyEvent)
See Also

Reference

KeyList Class
Add Overload
Alternet.Editor Namespace


KeyList.Add Method (Keys, KeyEventEx, Object)

KeyListAdd Method (Keys, KeyEventEx, Object)
Adds a new key to key collection with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    Keys keys,
    KeyEventEx action,
    Object param
)
Public Overridable Sub Add (
    keys As Keys,
    action As KeyEventEx,
    param As Object
)
public:
virtual void Add(
    Keys keys,
    KeyEventEx^ action,
    Object^ param
)
abstract Add :
        keys : Keys *
        action : KeyEventEx *
        param : Object -> unit
override Add :
        keys : Keys *
        action : KeyEventEx *
        param : Object -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEventEx
Extended action that executes when the key is pressed.
param
Type: SystemObject
Object passed as a parameter to the extended action.

Implements

IKeyListAdd(Keys, KeyEventEx, Object)
See Also

Reference

KeyList Class
Add Overload
Alternet.Editor Namespace


KeyList.Add Method (Keys, KeyEvent, Int32, Int32)

KeyListAdd Method (Keys, KeyEvent, Int32, Int32)
Adds a new key to key collection with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    Keys keys,
    KeyEvent action,
    int state,
    int leaveState
)
Public Overridable Sub Add (
    keys As Keys,
    action As KeyEvent,
    state As Integer,
    leaveState As Integer
)
public:
virtual void Add(
    Keys keys,
    KeyEvent^ action,
    int state,
    int leaveState
)
abstract Add :
        keys : Keys *
        action : KeyEvent *
        state : int *
        leaveState : int -> unit
override Add :
        keys : Keys *
        action : KeyEvent *
        state : int *
        leaveState : int -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEvent
Action that executes when the key is pressed.
state
Type: SystemInt32
State of the Edit control before key is pressed.
leaveState
Type: SystemInt32
State of the Edit control after key is pressed.

Implements

IKeyListAdd(Keys, KeyEvent, Int32, Int32)
See Also

Reference

KeyList Class
Add Overload
Alternet.Editor Namespace


KeyList.Add Method (Keys, KeyEventEx, Object, Int32, Int32)

KeyListAdd Method (Keys, KeyEventEx, Object, Int32, Int32)
Adds a new key to key collection with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    Keys keys,
    KeyEventEx action,
    Object param,
    int state,
    int leaveState
)
Public Overridable Sub Add (
    keys As Keys,
    action As KeyEventEx,
    param As Object,
    state As Integer,
    leaveState As Integer
)
public:
virtual void Add(
    Keys keys,
    KeyEventEx^ action,
    Object^ param,
    int state,
    int leaveState
)
abstract Add :
        keys : Keys *
        action : KeyEventEx *
        param : Object *
        state : int *
        leaveState : int -> unit
override Add :
        keys : Keys *
        action : KeyEventEx *
        param : Object *
        state : int *
        leaveState : int -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEventEx
Extended action that executes when the key is pressed.
param
Type: SystemObject
Object passed as a parameter to the extended action.
state
Type: SystemInt32
State of the Edit control when key is pressed.
leaveState
Type: SystemInt32
State of the Edit control after key is pressed.

Implements

IKeyListAdd(Keys, KeyEventEx, Object, Int32, Int32)
See Also

Reference

KeyList Class
Add Overload
Alternet.Editor Namespace


KeyList.Add Method (Keys, KeyEvent, KeyEventEx, Object, Int32, Int32)

KeyListAdd Method (Keys, KeyEvent, KeyEventEx, Object, Int32, Int32)
Adds a new key to key collection with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    Keys keys,
    KeyEvent action,
    KeyEventEx actionEx,
    Object param,
    int state,
    int leaveState
)
Public Overridable Sub Add (
    keys As Keys,
    action As KeyEvent,
    actionEx As KeyEventEx,
    param As Object,
    state As Integer,
    leaveState As Integer
)
public:
virtual void Add(
    Keys keys,
    KeyEvent^ action,
    KeyEventEx^ actionEx,
    Object^ param,
    int state,
    int leaveState
)
abstract Add :
        keys : Keys *
        action : KeyEvent *
        actionEx : KeyEventEx *
        param : Object *
        state : int *
        leaveState : int -> unit
override Add :
        keys : Keys *
        action : KeyEvent *
        actionEx : KeyEventEx *
        param : Object *
        state : int *
        leaveState : int -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEvent
Action that executes when the key is pressed.
actionEx
Type: Alternet.EditorKeyEventEx
Extended action that executes when the key is pressed.
param
Type: SystemObject
Object passed as a parameter to the extended action.
state
Type: SystemInt32
State of the Edit control when key is pressed.
leaveState
Type: SystemInt32
State of the Edit control after key is pressed.
See Also

Reference

KeyList Class
Add Overload
Alternet.Editor Namespace


KeyList.AddNormal Method

KeyListAddNormal Method
Overload List
 | Name | Description
Public method | AddNormal(Keys, KeyEvent) | Adds a new key to key collection with specified parameters and default (normal) state and leave state.
Public method | AddNormal(Keys, KeyEventEx, Object) | Adds a new key to key collection with specified parameters and default (normal) state and leave state.
Top
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList.AddNormal Method (Keys, KeyEvent)

KeyListAddNormal Method (Keys, KeyEvent)
Adds a new key to key collection with specified parameters and default (normal) state and leave state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddNormal(
    Keys keys,
    KeyEvent action
)
Public Overridable Sub AddNormal (
    keys As Keys,
    action As KeyEvent
)
public:
virtual void AddNormal(
    Keys keys,
    KeyEvent^ action
)
abstract AddNormal :
        keys : Keys *
        action : KeyEvent -> unit
override AddNormal :
        keys : Keys *
        action : KeyEvent -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key that added to the collection.
action
Type: Alternet.EditorKeyEvent
Action that executes when the key is pressed.

Implements

IKeyListAddNormal(Keys, KeyEvent)
See Also

Reference

KeyList Class
AddNormal Overload
Alternet.Editor Namespace


KeyList.AddNormal Method (Keys, KeyEventEx, Object)

KeyListAddNormal Method (Keys, KeyEventEx, Object)
Adds a new key to key collection with specified parameters and default (normal) state and leave state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddNormal(
    Keys keys,
    KeyEventEx action,
    Object param
)
Public Overridable Sub AddNormal (
    keys As Keys,
    action As KeyEventEx,
    param As Object
)
public:
virtual void AddNormal(
    Keys keys,
    KeyEventEx^ action,
    Object^ param
)
abstract AddNormal :
        keys : Keys *
        action : KeyEventEx *
        param : Object -> unit
override AddNormal :
        keys : Keys *
        action : KeyEventEx *
        param : Object -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key added to the collection.
action
Type: Alternet.EditorKeyEventEx
Extended action that executes when the key is pressed.
param
Type: SystemObject
Object passed as a parameter to the extended action.

Implements

IKeyListAddNormal(Keys, KeyEventEx, Object)
See Also

Reference

KeyList Class
AddNormal Overload
Alternet.Editor Namespace


KeyList.Clear Method

KeyListClear Method
Removes all elements from the key list.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IKeyListClear
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList.ExecuteKey Method

KeyListExecuteKey Method
Executes action or extended action attached to the specified key.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ExecuteKey(
    Keys keys,
    ref int state
)
Public Overridable Function ExecuteKey (
    keys As Keys,
    ByRef state As Integer
) As Boolean
public:
virtual bool ExecuteKey(
    Keys keys,
    int% state
)
abstract ExecuteKey :
        keys : Keys *
        state : int byref -> bool
override ExecuteKey :
        keys : Keys *
        state : int byref -> bool

Parameters

keys
Type: System.Windows.FormsKeys
Key for which action should be executed.
state
Type: SystemInt32
Receive leave state of specified action.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IKeyListExecuteKey(Keys, Int32)
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList.FindKey Method

KeyListFindKey Method
Indicates whether given key locates within the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindKey(
    Keys keys,
    int state
)
Public Overridable Function FindKey (
    keys As Keys,
    state As Integer
) As Boolean
public:
virtual bool FindKey(
    Keys keys,
    int state
)
abstract FindKey :
        keys : Keys *
        state : int -> bool
override FindKey :
        keys : Keys *
        state : int -> bool

Parameters

keys
Type: System.Windows.FormsKeys
Key to find.
state
Type: SystemInt32
State of the Edit control before the key is pressed.

Return Value

Type: Boolean
True if the specified key exists; otherwise false.

Implements

IKeyListFindKey(Keys, Int32)
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList.Remove Method

KeyListRemove Method
Overload List
 | Name | Description
Public method | Remove(Keys) | Removes given key from the key collection.
Public method | Remove(Keys, Int32) | Removes given key from the key collection.
Top
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList.Remove Method (Keys)

KeyListRemove Method (Keys)
Removes given key from the key collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Remove(
    Keys keys
)
Public Overridable Sub Remove (
    keys As Keys
)
public:
virtual void Remove(
    Keys keys
)
abstract Remove :
        keys : Keys -> unit
override Remove :
        keys : Keys -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key to remove.

Implements

IKeyListRemove(Keys)
See Also

Reference

KeyList Class
Remove Overload
Alternet.Editor Namespace


KeyList.Remove Method (Keys, Int32)

KeyListRemove Method (Keys, Int32)
Removes given key from the key collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Remove(
    Keys keys,
    int state
)
Public Overridable Sub Remove (
    keys As Keys,
    state As Integer
)
public:
virtual void Remove(
    Keys keys,
    int state
)
abstract Remove :
        keys : Keys *
        state : int -> unit
override Remove :
        keys : Keys *
        state : int -> unit

Parameters

keys
Type: System.Windows.FormsKeys
Key to remove.
state
Type: SystemInt32
State of the Edit control when the key is pressed.

Implements

IKeyListRemove(Keys, Int32)
See Also

Reference

KeyList Class
Remove Overload
Alternet.Editor Namespace


KeyList Properties

KeyList Properties

The KeyList type exposes the following members.

Properties
 | Name | Description
Public property | EventData | Represents array of event handlers associated with keys.
Public property | Handlers | Represents an event handlers collection which contains elements that can be used as a particular action attached to key or key combination from the KeyList.
Top
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList.EventData Property

KeyListEventData Property
Represents array of event handlers associated with keys.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IKeyData[] EventData { get; }
Public ReadOnly Property EventData As IKeyData()
    Get
public:
virtual property array<IKeyData^>^ EventData {
    array<IKeyData^>^ get () sealed;
}
abstract EventData : IKeyData[] with get
override EventData : IKeyData[] with get

Property Value

Type: IKeyData

Implements

IKeyListEventData
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyList.Handlers Property

KeyListHandlers Property
Represents an event handlers collection which contains elements that can be used as a particular action attached to key or key combination from the KeyList.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEventHandlers Handlers { get; }
Public ReadOnly Property Handlers As IEventHandlers
    Get
public:
virtual property IEventHandlers^ Handlers {
    IEventHandlers^ get () sealed;
}
abstract Handlers : IEventHandlers with get
override Handlers : IEventHandlers with get

Property Value

Type: IEventHandlers

Implements

IKeyListHandlers
See Also

Reference

KeyList Class
Alternet.Editor Namespace


KeyPreviewEvent Delegate

KeyPreviewEvent Delegate
Represents a method that will handle the ICodeCompletionWindow.KeyPreview event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void KeyPreviewEvent(
    Object sender,
    KeyPreviewEventArgs e
)
Public Delegate Sub KeyPreviewEvent (
    sender As Object,
    e As KeyPreviewEventArgs
)
public delegate void KeyPreviewEvent(
    Object^ sender,
    KeyPreviewEventArgs^ e
)
type KeyPreviewEvent =
    delegate of
        sender : Object *
        e : KeyPreviewEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorKeyPreviewEventArgs
A KeyPreviewEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


KeyPreviewEventArgs Class

KeyPreviewEventArgs Class
Provides data for the ICodeCompletionWindow.KeyPreviewEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorKeyPreviewEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyPreviewEventArgs : EventArgs
Public Class KeyPreviewEventArgs
    Inherits EventArgs
public ref class KeyPreviewEventArgs : public EventArgs
type KeyPreviewEventArgs =
    class
        inherit EventArgs
    end

The KeyPreviewEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | KeyPreviewEventArgs | Initializes a new instance of the KeyPreviewEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Handled | Specifies whether painting is handled by an event, preventing further processing of the key message.
Public property | Message | Key message.
Top
See Also

Reference

Alternet.Editor Namespace


KeyPreviewEventArgs Constructor

KeyPreviewEventArgs Constructor
Initializes a new instance of the KeyPreviewEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyPreviewEventArgs(
    Message m
)
Public Sub New (
    m As Message
)
public:
KeyPreviewEventArgs(
    Message m
)
new :
        m : Message -> KeyPreviewEventArgs

Parameters

m
Type: System.Windows.FormsMessage
Represents key message.
See Also

Reference

KeyPreviewEventArgs Class
Alternet.Editor Namespace


KeyPreviewEventArgs Methods

KeyPreviewEventArgs Methods

The KeyPreviewEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KeyPreviewEventArgs Class
Alternet.Editor Namespace


KeyPreviewEventArgs Properties

KeyPreviewEventArgs Properties

The KeyPreviewEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Specifies whether painting is handled by an event, preventing further processing of the key message.
Public property | Message | Key message.
Top
See Also

Reference

KeyPreviewEventArgs Class
Alternet.Editor Namespace


KeyPreviewEventArgs.Handled Property

KeyPreviewEventArgsHandled Property
Specifies whether painting is handled by an event, preventing further processing of the key message.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

KeyPreviewEventArgs Class
Alternet.Editor Namespace


KeyPreviewEventArgs.Message Property

KeyPreviewEventArgsMessage Property
Key message.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Message Message { get; set; }
Public Property Message As Message
    Get
    Set
public:
property Message Message {
    Message get ();
    void set (Message value);
}
member Message : Message with get, set

Property Value

Type: Message
See Also

Reference

KeyPreviewEventArgs Class
Alternet.Editor Namespace


LightVisualTheme Class

LightVisualTheme Class
Inheritance Hierarchy
SystemObject
Alternet.EditorVisualTheme
Alternet.EditorStandardVisualTheme
Alternet.EditorLightVisualTheme

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LightVisualTheme : StandardVisualTheme
Public Class LightVisualTheme
    Inherits StandardVisualTheme
public ref class LightVisualTheme : public StandardVisualTheme
type LightVisualTheme =
    class
        inherit StandardVisualTheme
    end

The LightVisualTheme type exposes the following members.

Constructors
 | Name | Description
Public method | LightVisualTheme | Initializes a new instance of the LightVisualTheme class
Top
Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox | (Inherited from VisualTheme.)
Public method | ApplyToCodeCompletionHint | (Inherited from VisualTheme.)
Public method | ApplyToEdit | (Inherited from VisualTheme.)
Public method | ApplyToScrollBar | (Inherited from VisualTheme.)
Public method | ApplyToScrollingButton | (Inherited from VisualTheme.)
Public method | ApplyToSplitButton | (Inherited from VisualTheme.)
Public method | Assign | (Inherited from VisualTheme.)
Public method | Dispose | (Inherited from VisualTheme.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromEdit | (Inherited from VisualTheme.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Instance |
Top
Properties
 | Name | Description
Public property | Colors | (Inherited from StandardVisualTheme.)
Public property | Font | Gets or sets the font used for the color theme. (Inherited from VisualTheme.)
Public property | ImagesColor | (Inherited from VisualTheme.)
Public property | Item | Specifies an Item indexer that uses the name of the LexStyle as an index. (Inherited from VisualTheme.)
Public property | LexStyles | Gets or sets the LexStyle array used for the color theme. (Inherited from VisualTheme.)
Public property | Name | Gets or sets the name of the color theme. (Inherited from VisualTheme.)
Public property | ReadOnly | Gets or sets a bool value that indicates whether or not the color theme should be modified. (Inherited from VisualTheme.)
Top
See Also

Reference

Alternet.Editor Namespace


LightVisualTheme Constructor

LightVisualTheme Constructor
Initializes a new instance of the LightVisualTheme class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LightVisualTheme()
Public Sub New
public:
LightVisualTheme()
new : unit -> LightVisualTheme
See Also

Reference

LightVisualTheme Class
Alternet.Editor Namespace


LightVisualTheme Fields

LightVisualTheme Fields

The LightVisualTheme type exposes the following members.

Fields
Name | Description
Instance |
Top
See Also

Reference

LightVisualTheme Class
Alternet.Editor Namespace


LightVisualTheme.Instance Field

LightVisualThemeInstance Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly LightVisualTheme Instance
Public Shared ReadOnly Instance As LightVisualTheme
public:
static initonly LightVisualTheme^ Instance
static val Instance: LightVisualTheme

Field Value

Type: LightVisualTheme
See Also

Reference

LightVisualTheme Class
Alternet.Editor Namespace


LightVisualTheme Methods

LightVisualTheme Methods

The LightVisualTheme type exposes the following members.

Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox | (Inherited from VisualTheme.)
Public method | ApplyToCodeCompletionHint | (Inherited from VisualTheme.)
Public method | ApplyToEdit | (Inherited from VisualTheme.)
Public method | ApplyToScrollBar | (Inherited from VisualTheme.)
Public method | ApplyToScrollingButton | (Inherited from VisualTheme.)
Public method | ApplyToSplitButton | (Inherited from VisualTheme.)
Public method | Assign | (Inherited from VisualTheme.)
Public method | Dispose | (Inherited from VisualTheme.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromEdit | (Inherited from VisualTheme.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LightVisualTheme Class
Alternet.Editor Namespace


LightVisualTheme Properties

LightVisualTheme Properties

The LightVisualTheme type exposes the following members.

Properties
 | Name | Description
Public property | Colors | (Inherited from StandardVisualTheme.)
Public property | Font | Gets or sets the font used for the color theme. (Inherited from VisualTheme.)
Public property | ImagesColor | (Inherited from VisualTheme.)
Public property | Item | Specifies an Item indexer that uses the name of the LexStyle as an index. (Inherited from VisualTheme.)
Public property | LexStyles | Gets or sets the LexStyle array used for the color theme. (Inherited from VisualTheme.)
Public property | Name | Gets or sets the name of the color theme. (Inherited from VisualTheme.)
Public property | ReadOnly | Gets or sets a bool value that indicates whether or not the color theme should be modified. (Inherited from VisualTheme.)
Top
See Also

Reference

LightVisualTheme Class
Alternet.Editor Namespace


LineSeparator Class

LineSeparator Class
Represents properties and methods used to separate lines and highlight current line within the Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorLineSeparator

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineSeparator : ILineSeparator,
    IUpdate
Public Class LineSeparator
    Implements ILineSeparator, IUpdate
public ref class LineSeparator : ILineSeparator,
    IUpdate
type LineSeparator =
    class
        interface ILineSeparator
        interface IUpdate
    end

The LineSeparator type exposes the following members.

Constructors
 | Name | Description
Public method | LineSeparator | Initializes a new instance of the LineSeparator class with default settings.
Public method | LineSeparator(ISyntaxEdit) | Initializes a new instance of the LineSeparator class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents from another ILineSeparator object.
Public method | BeginUpdate | Prevents LineSeparator updating until calling LineSeparator.EndUpdate method.
Public method | DisableUpdate | Prevents LineSeparator updating until calling LineSeparator.EndUpdate method.
Public method | EnableUpdate | Re-enables LineSeparator updating, that was turn of by calling LineSeparator.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling LineSeparator.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NeedHide | Indicates whether Edit control owning the LineSeparator needs to hide highlighting of the current line when loosing input focus.
Public method | NeedHighlight | Indicates whether Edit control owning the LineSeparator need to highlight the current line.
Public method | NeedHighlightDisplayLine | Gets boolean value indicating that given line should be highlighted. Specifies line index in display coordinates.
Public method | NeedHighlightLine | Gets boolean value indicating that given line should be highlighted. Specifies line index.
Public method | ResetContentDividerColor | Resets the ContentDividerColor to the default value.
Public method | ResetHighlightBackColor | Resets the HighlightBackColor to the default value.
Public method | ResetHighlightForeColor | Resets the HighlightForeColor to the default value.
Public method | ResetLineColor | Resets the LineColor to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ShouldSerializeContentDividerColor | Indicates whether the ContentDividerColor property should be persisted.
Public method | ShouldSerializeHighlightBackColor | Indicates whether the HighlightBackColor property should be persisted.
Public method | ShouldSerializeHighlightForeColor | Indicates whether the HighlightForeColor property should be persisted.
Public method | ShouldSerializeLineColor | Indicates whether the LineColor property should be persisted.
Public method | TempHighlightLine | Temporary highlights specifies line until Edit control state changed.
Public method | TempUnhighlightLine | Removes highlighting from temporary highlighted line.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Invalidates editor if needed.
Top
Properties
 | Name | Description
Public property | ContentDividerColor | Gets or sets color of horizontal lines between particular sections (for example, methods) in the Edit control.
Public property | HighlightBackColor | Gets or sets a background color of highlighted line.
Public property | HighlightForeColor | Gets or sets a foreground color of highlighted line.
Public property | LineColor | Gets or sets color of horizontal lines between particular lines in the Edit control.
Public property | Options | Gets or sets a set of flags customizing appearance and behaviour of the LineSeparator.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

Alternet.Editor Namespace


LineSeparator Constructor

LineSeparator Constructor
Overload List
 | Name | Description
Public method | LineSeparator | Initializes a new instance of the LineSeparator class with default settings.
Public method | LineSeparator(ISyntaxEdit) | Initializes a new instance of the LineSeparator class with specified owner.
Top
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator Constructor

LineSeparator Constructor
Initializes a new instance of the LineSeparator class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineSeparator()
Public Sub New
public:
LineSeparator()
new : unit -> LineSeparator
See Also

Reference

LineSeparator Class
LineSeparator Overload
Alternet.Editor Namespace


LineSeparator Constructor (ISyntaxEdit)

LineSeparator Constructor (ISyntaxEdit)
Initializes a new instance of the LineSeparator class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineSeparator(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
LineSeparator(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> LineSeparator

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

LineSeparator Class
LineSeparator Overload
Alternet.Editor Namespace


LineSeparator Methods

LineSeparator Methods

The LineSeparator type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents from another ILineSeparator object.
Public method | BeginUpdate | Prevents LineSeparator updating until calling LineSeparator.EndUpdate method.
Public method | DisableUpdate | Prevents LineSeparator updating until calling LineSeparator.EndUpdate method.
Public method | EnableUpdate | Re-enables LineSeparator updating, that was turn of by calling LineSeparator.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling LineSeparator.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NeedHide | Indicates whether Edit control owning the LineSeparator needs to hide highlighting of the current line when loosing input focus.
Public method | NeedHighlight | Indicates whether Edit control owning the LineSeparator need to highlight the current line.
Public method | NeedHighlightDisplayLine | Gets boolean value indicating that given line should be highlighted. Specifies line index in display coordinates.
Public method | NeedHighlightLine | Gets boolean value indicating that given line should be highlighted. Specifies line index.
Public method | ResetContentDividerColor | Resets the ContentDividerColor to the default value.
Public method | ResetHighlightBackColor | Resets the HighlightBackColor to the default value.
Public method | ResetHighlightForeColor | Resets the HighlightForeColor to the default value.
Public method | ResetLineColor | Resets the LineColor to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ShouldSerializeContentDividerColor | Indicates whether the ContentDividerColor property should be persisted.
Public method | ShouldSerializeHighlightBackColor | Indicates whether the HighlightBackColor property should be persisted.
Public method | ShouldSerializeHighlightForeColor | Indicates whether the HighlightForeColor property should be persisted.
Public method | ShouldSerializeLineColor | Indicates whether the LineColor property should be persisted.
Public method | TempHighlightLine | Temporary highlights specifies line until Edit control state changed.
Public method | TempUnhighlightLine | Removes highlighting from temporary highlighted line.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Invalidates editor if needed.
Top
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.Assign Method

LineSeparatorAssign Method
Copies the contents from another ILineSeparator object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ILineSeparator source
)
Public Overridable Sub Assign (
    source As ILineSeparator
)
public:
virtual void Assign(
    ILineSeparator^ source
)
abstract Assign :
        source : ILineSeparator -> unit
override Assign :
        source : ILineSeparator -> unit

Parameters

source
Type: Alternet.EditorILineSeparator
Specifies ILineSeparator to assign.

Implements

ILineSeparatorAssign(ILineSeparator)
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.BeginUpdate Method

LineSeparatorBeginUpdate Method
Prevents LineSeparator updating until calling LineSeparator.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of LineSeparator updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.DisableUpdate Method

LineSeparatorDisableUpdate Method
Prevents LineSeparator updating until calling LineSeparator.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.EnableUpdate Method

LineSeparatorEnableUpdate Method
Re-enables LineSeparator updating, that was turn of by calling LineSeparator.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of LineSeparator updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.EndUpdate Method

LineSeparatorEndUpdate Method
Re-enables page updating, that was turn of by calling LineSeparator.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of LineSeparator updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.NeedHide Method

LineSeparatorNeedHide Method
Indicates whether Edit control owning the LineSeparator needs to hide highlighting of the current line when loosing input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedHide()
Public Overridable Function NeedHide As Boolean
public:
virtual bool NeedHide()
abstract NeedHide : unit -> bool
override NeedHide : unit -> bool

Return Value

Type: Boolean
True if need; otherwise false.

Implements

ILineSeparatorNeedHide
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.NeedHighlight Method

LineSeparatorNeedHighlight Method
Indicates whether Edit control owning the LineSeparator need to highlight the current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedHighlight()
Public Overridable Function NeedHighlight As Boolean
public:
virtual bool NeedHighlight()
abstract NeedHighlight : unit -> bool
override NeedHighlight : unit -> bool

Return Value

Type: Boolean
True if need; otherwise false.

Implements

ILineSeparatorNeedHighlight
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.NeedHighlightDisplayLine Method

LineSeparatorNeedHighlightDisplayLine Method
Gets boolean value indicating that given line should be highlighted. Specifies line index in display coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedHighlightDisplayLine(
    int index
)
Public Overridable Function NeedHighlightDisplayLine (
    index As Integer
) As Boolean
public:
virtual bool NeedHighlightDisplayLine(
    int index
)
abstract NeedHighlightDisplayLine :
        index : int -> bool
override NeedHighlightDisplayLine :
        index : int -> bool

Parameters

index
Type: SystemInt32

Return Value

Type: Boolean

Implements

ILineSeparatorNeedHighlightDisplayLine(Int32)
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.NeedHighlightLine Method

LineSeparatorNeedHighlightLine Method
Gets boolean value indicating that given line should be highlighted. Specifies line index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedHighlightLine(
    int index
)
Public Overridable Function NeedHighlightLine (
    index As Integer
) As Boolean
public:
virtual bool NeedHighlightLine(
    int index
)
abstract NeedHighlightLine :
        index : int -> bool
override NeedHighlightLine :
        index : int -> bool

Parameters

index
Type: SystemInt32

Return Value

Type: Boolean

Implements

ILineSeparatorNeedHighlightLine(Int32)
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ResetContentDividerColor Method

LineSeparatorResetContentDividerColor Method
Resets the ContentDividerColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetContentDividerColor()
Public Overridable Sub ResetContentDividerColor
public:
virtual void ResetContentDividerColor()
abstract ResetContentDividerColor : unit -> unit
override ResetContentDividerColor : unit -> unit

Implements

ILineSeparatorResetContentDividerColor
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ResetHighlightBackColor Method

LineSeparatorResetHighlightBackColor Method
Resets the HighlightBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetHighlightBackColor()
Public Overridable Sub ResetHighlightBackColor
public:
virtual void ResetHighlightBackColor()
abstract ResetHighlightBackColor : unit -> unit
override ResetHighlightBackColor : unit -> unit

Implements

ILineSeparatorResetHighlightBackColor
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ResetHighlightForeColor Method

LineSeparatorResetHighlightForeColor Method
Resets the HighlightForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetHighlightForeColor()
Public Overridable Sub ResetHighlightForeColor
public:
virtual void ResetHighlightForeColor()
abstract ResetHighlightForeColor : unit -> unit
override ResetHighlightForeColor : unit -> unit

Implements

ILineSeparatorResetHighlightForeColor
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ResetLineColor Method

LineSeparatorResetLineColor Method
Resets the LineColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineColor()
Public Overridable Sub ResetLineColor
public:
virtual void ResetLineColor()
abstract ResetLineColor : unit -> unit
override ResetLineColor : unit -> unit

Implements

ILineSeparatorResetLineColor
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ResetOptions Method

LineSeparatorResetOptions Method
Resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOptions()
Public Overridable Sub ResetOptions
public:
virtual void ResetOptions()
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ILineSeparatorResetOptions
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ShouldSerializeContentDividerColor Method

LineSeparatorShouldSerializeContentDividerColor Method
Indicates whether the ContentDividerColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeContentDividerColor()
Public Function ShouldSerializeContentDividerColor As Boolean
public:
bool ShouldSerializeContentDividerColor()
member ShouldSerializeContentDividerColor : unit -> bool

Return Value

Type: Boolean
True if ContentDividerColor differs from its default value; otherwise false.
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ShouldSerializeHighlightBackColor Method

LineSeparatorShouldSerializeHighlightBackColor Method
Indicates whether the HighlightBackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeHighlightBackColor()
Public Function ShouldSerializeHighlightBackColor As Boolean
public:
bool ShouldSerializeHighlightBackColor()
member ShouldSerializeHighlightBackColor : unit -> bool

Return Value

Type: Boolean
True if HighlightBackColor differs from its default value; otherwise false.
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ShouldSerializeHighlightForeColor Method

LineSeparatorShouldSerializeHighlightForeColor Method
Indicates whether the HighlightForeColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeHighlightForeColor()
Public Function ShouldSerializeHighlightForeColor As Boolean
public:
bool ShouldSerializeHighlightForeColor()
member ShouldSerializeHighlightForeColor : unit -> bool

Return Value

Type: Boolean
True if HighlightForeColor differs from its default value; otherwise false.
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ShouldSerializeLineColor Method

LineSeparatorShouldSerializeLineColor Method
Indicates whether the LineColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLineColor()
Public Function ShouldSerializeLineColor As Boolean
public:
bool ShouldSerializeLineColor()
member ShouldSerializeLineColor : unit -> bool

Return Value

Type: Boolean
True if LineColor differs from its default value; otherwise false.
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.TempHighlightLine Method

LineSeparatorTempHighlightLine Method
Temporary highlights specifies line until Edit control state changed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempHighlightLine(
    int index
)
Public Overridable Sub TempHighlightLine (
    index As Integer
)
public:
virtual void TempHighlightLine(
    int index
)
abstract TempHighlightLine :
        index : int -> unit
override TempHighlightLine :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of line to highlight.

Implements

ILineSeparatorTempHighlightLine(Int32)
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.TempUnhighlightLine Method

LineSeparatorTempUnhighlightLine Method
Removes highlighting from temporary highlighted line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempUnhighlightLine()
Public Overridable Sub TempUnhighlightLine
public:
virtual void TempUnhighlightLine()
abstract TempUnhighlightLine : unit -> unit
override TempUnhighlightLine : unit -> unit

Implements

ILineSeparatorTempUnhighlightLine
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.Update Method

LineSeparatorUpdate Method
Invalidates editor if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
virtual void Update() sealed
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator Properties

LineSeparator Properties

The LineSeparator type exposes the following members.

Properties
 | Name | Description
Public property | ContentDividerColor | Gets or sets color of horizontal lines between particular sections (for example, methods) in the Edit control.
Public property | HighlightBackColor | Gets or sets a background color of highlighted line.
Public property | HighlightForeColor | Gets or sets a foreground color of highlighted line.
Public property | LineColor | Gets or sets color of horizontal lines between particular lines in the Edit control.
Public property | Options | Gets or sets a set of flags customizing appearance and behaviour of the LineSeparator.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.ContentDividerColor Property

LineSeparatorContentDividerColor Property
Gets or sets color of horizontal lines between particular sections (for example, methods) in the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ContentDividerColor { get; set; }
Public Overridable Property ContentDividerColor As Color
    Get
    Set
public:
virtual property Color ContentDividerColor {
    Color get ();
    void set (Color value);
}
abstract ContentDividerColor : Color with get, set
override ContentDividerColor : Color with get, set

Property Value

Type: Color

Implements

ILineSeparatorContentDividerColor
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.HighlightBackColor Property

LineSeparatorHighlightBackColor Property
Gets or sets a background color of highlighted line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color HighlightBackColor { get; set; }
Public Overridable Property HighlightBackColor As Color
    Get
    Set
public:
virtual property Color HighlightBackColor {
    Color get ();
    void set (Color value);
}
abstract HighlightBackColor : Color with get, set
override HighlightBackColor : Color with get, set

Property Value

Type: Color

Implements

ILineSeparatorHighlightBackColor
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.HighlightForeColor Property

LineSeparatorHighlightForeColor Property
Gets or sets a foreground color of highlighted line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color HighlightForeColor { get; set; }
Public Overridable Property HighlightForeColor As Color
    Get
    Set
public:
virtual property Color HighlightForeColor {
    Color get ();
    void set (Color value);
}
abstract HighlightForeColor : Color with get, set
override HighlightForeColor : Color with get, set

Property Value

Type: Color

Implements

ILineSeparatorHighlightForeColor
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.LineColor Property

LineSeparatorLineColor Property
Gets or sets color of horizontal lines between particular lines in the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color LineColor { get; set; }
Public Overridable Property LineColor As Color
    Get
    Set
public:
virtual property Color LineColor {
    Color get ();
    void set (Color value);
}
abstract LineColor : Color with get, set
override LineColor : Color with get, set

Property Value

Type: Color

Implements

ILineSeparatorLineColor
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.Options Property

LineSeparatorOptions Property
Gets or sets a set of flags customizing appearance and behaviour of the LineSeparator.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SeparatorOptions Options { get; set; }
Public Overridable Property Options As SeparatorOptions
    Get
    Set
public:
virtual property SeparatorOptions Options {
    SeparatorOptions get ();
    void set (SeparatorOptions value);
}
abstract Options : SeparatorOptions with get, set
override Options : SeparatorOptions with get, set

Property Value

Type: SeparatorOptions

Implements

ILineSeparatorOptions
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineSeparator.UpdateCount Property

LineSeparatorUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

LineSeparator Class
Alternet.Editor Namespace


LineStyleOptions Enumeration

LineStyleOptions Enumeration
Defines appearance of lines with some line style. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum LineStyleOptions
<FlagsAttribute>
Public Enumeration LineStyleOptions
[FlagsAttribute]
public enum class LineStyleOptions
[<FlagsAttribute>]
type LineStyleOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
BeyondEol | 1 | Specifies that line style applicable beyond end of line.
InvertColors | 2 | Specifies that background and foreground colors should be interchanged.
DisplayImageOnMultipleLines | 4 | Specifies that gutter images should be displayed on multiple lines.
See Also

Reference

Alternet.Editor Namespace


MacroKeyData Class

MacroKeyData Class
Represents macro key or its combinations with attached actions.
Inheritance Hierarchy
SystemObject
Alternet.EditorKeyData
Alternet.EditorMacroKeyData

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MacroKeyData : KeyData,
    IMacroKeyData, IKeyData
Public Class MacroKeyData
    Inherits KeyData
    Implements IMacroKeyData, IKeyData
public ref class MacroKeyData : public KeyData,
    IMacroKeyData, IKeyData
type MacroKeyData =
    class
        inherit KeyData
        interface IMacroKeyData
        interface IKeyData
    end

The MacroKeyData type exposes the following members.

Constructors
 | Name | Description
Public method | MacroKeyData | Initializes a new instance of the MacroKeyListData class with default settings.
Public method | MacroKeyData(Keys, KeyEvent, KeyEventEx, Object, Int32, Int32) | Initializes a new instance of the MacroKeyListData class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts KeyListData content to string. (Inherited from KeyData.)
Top
Properties
 | Name | Description
Public property | Action | Action that executes when the key is pressed. (Inherited from KeyData.)
Public property | ActionEx | Extended action that executes when the key is pressed. (Inherited from KeyData.)
Public property | EventName | String representation of the action. (Inherited from KeyData.)
Public property | FullName | String representation of the action.
Public property | Keys | Key to which some action is attached. (Inherited from KeyData.)
Public property | LeaveState | State of the Edit control after key is pressed. (Inherited from KeyData.)
Public property | Param | Object passed as a parameter to the extended action. (Inherited from KeyData.)
Public property | ParamStr | String representation of the parameter.
Public property | ParamType | Gets or sets type of the parameter.
Public property | SerializationInfo | Gets or sets an xml representation of this ColorTheme object.
Public property | State | State of the Edit control before key is pressed. (Inherited from KeyData.)
Top
See Also

Reference

Alternet.Editor Namespace


MacroKeyData Constructor

MacroKeyData Constructor
Overload List
 | Name | Description
Public method | MacroKeyData | Initializes a new instance of the MacroKeyListData class with default settings.
Public method | MacroKeyData(Keys, KeyEvent, KeyEventEx, Object, Int32, Int32) | Initializes a new instance of the MacroKeyListData class with specified settings.
Top
See Also

Reference

MacroKeyData Class
Alternet.Editor Namespace


MacroKeyData Constructor

MacroKeyData Constructor
Initializes a new instance of the MacroKeyListData class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MacroKeyData()
Public Sub New
public:
MacroKeyData()
new : unit -> MacroKeyData
See Also

Reference

MacroKeyData Class
MacroKeyData Overload
Alternet.Editor Namespace


MacroKeyData Constructor (Keys, KeyEvent, KeyEventEx, Object, Int32, Int32)

MacroKeyData Constructor (Keys, KeyEvent, KeyEventEx, Object, Int32, Int32)
Initializes a new instance of the MacroKeyListData class with specified settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MacroKeyData(
    Keys keyData,
    KeyEvent action,
    KeyEventEx actionEx,
    Object param,
    int state,
    int leaveState
)
Public Sub New (
    keyData As Keys,
    action As KeyEvent,
    actionEx As KeyEventEx,
    param As Object,
    state As Integer,
    leaveState As Integer
)
public:
MacroKeyData(
    Keys keyData,
    KeyEvent^ action,
    KeyEventEx^ actionEx,
    Object^ param,
    int state,
    int leaveState
)
new :
        keyData : Keys *
        action : KeyEvent *
        actionEx : KeyEventEx *
        param : Object *
        state : int *
        leaveState : int -> MacroKeyData

Parameters

keyData
Type: System.Windows.FormsKeys
Specifies key data of this new instance.
action
Type: Alternet.EditorKeyEvent
Action that executes when the key is pressed.
actionEx
Type: Alternet.EditorKeyEventEx
Extended action that executes when the key is pressed.
param
Type: SystemObject
Object passed as a parameter to the extended action.
state
Type: SystemInt32
Current state of the Edit control.
leaveState
Type: SystemInt32
State of the Edit control after key is pressed.
See Also

Reference

MacroKeyData Class
MacroKeyData Overload
Alternet.Editor Namespace


MacroKeyData Methods

MacroKeyData Methods

The MacroKeyData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts KeyListData content to string. (Inherited from KeyData.)
Top
See Also

Reference

MacroKeyData Class
Alternet.Editor Namespace


MacroKeyData Properties

MacroKeyData Properties

The MacroKeyData type exposes the following members.

Properties
 | Name | Description
Public property | Action | Action that executes when the key is pressed. (Inherited from KeyData.)
Public property | ActionEx | Extended action that executes when the key is pressed. (Inherited from KeyData.)
Public property | EventName | String representation of the action. (Inherited from KeyData.)
Public property | FullName | String representation of the action.
Public property | Keys | Key to which some action is attached. (Inherited from KeyData.)
Public property | LeaveState | State of the Edit control after key is pressed. (Inherited from KeyData.)
Public property | Param | Object passed as a parameter to the extended action. (Inherited from KeyData.)
Public property | ParamStr | String representation of the parameter.
Public property | ParamType | Gets or sets type of the parameter.
Public property | SerializationInfo | Gets or sets an xml representation of this ColorTheme object.
Public property | State | State of the Edit control before key is pressed. (Inherited from KeyData.)
Top
See Also

Reference

MacroKeyData Class
Alternet.Editor Namespace


MacroKeyData.FullName Property

MacroKeyDataFullName Property
String representation of the action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set
public:
virtual property String^ FullName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FullName : string with get, set
override FullName : string with get, set

Property Value

Type: String

Implements

IMacroKeyDataFullName
See Also

Reference

MacroKeyData Class
Alternet.Editor Namespace


MacroKeyData.ParamStr Property

MacroKeyDataParamStr Property
String representation of the parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ParamStr { get; set; }
Public Property ParamStr As String
    Get
    Set
public:
virtual property String^ ParamStr {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ParamStr : string with get, set
override ParamStr : string with get, set

Property Value

Type: String

Implements

IMacroKeyDataParamStr
See Also

Reference

MacroKeyData Class
Alternet.Editor Namespace


MacroKeyData.ParamType Property

MacroKeyDataParamType Property
Gets or sets type of the parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventType ParamType { get; set; }
Public Property ParamType As KeyEventType
    Get
    Set
public:
virtual property KeyEventType ParamType {
    KeyEventType get () sealed;
    void set (KeyEventType value) sealed;
}
abstract ParamType : KeyEventType with get, set
override ParamType : KeyEventType with get, set

Property Value

Type: KeyEventType

Implements

IMacroKeyDataParamType
See Also

Reference

MacroKeyData Class
Alternet.Editor Namespace


MacroKeyData.SerializationInfo Property

MacroKeyDataSerializationInfo Property
Gets or sets an xml representation of this ColorTheme object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

IMacroKeyDataSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

MacroKeyData Class
Alternet.Editor Namespace


MacroKeyList Class

MacroKeyList Class
Represents list of macro key or its combinations with attached actions.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIMacroKeyData
Alternet.EditorMacroKeyList

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MacroKeyList : List<IMacroKeyData>,
    IMacroKeyList, IList<IMacroKeyData>, ICollection<IMacroKeyData>,
    IEnumerable<IMacroKeyData>, IEnumerable
Public Class MacroKeyList
    Inherits List(Of IMacroKeyData)
    Implements IMacroKeyList, IList(Of IMacroKeyData),
    ICollection(Of IMacroKeyData), IEnumerable(Of IMacroKeyData), IEnumerable
public ref class MacroKeyList : public List<IMacroKeyData^>,
    IMacroKeyList, IList<IMacroKeyData^>, ICollection<IMacroKeyData^>,
    IEnumerable<IMacroKeyData^>, IEnumerable
type MacroKeyList =
    class
        inherit List<IMacroKeyData>
        interface IMacroKeyList
        interface IList<IMacroKeyData>
        interface ICollection<IMacroKeyData>
        interface IEnumerable<IMacroKeyData>
        interface IEnumerable
    end

The MacroKeyList type exposes the following members.

Constructors
 | Name | Description
Public method | MacroKeyList | Initializes a new instance of the MacroKeyList class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIMacroKeyData .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIMacroKeyData .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIMacroKeyData .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIMacroKeyData .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIMacroKeyData .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIMacroKeyData .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIMacroKeyData .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIMacroKeyData .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIMacroKeyData .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIMacroKeyData .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIMacroKeyData .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIMacroKeyData .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIMacroKeyData .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIMacroKeyData .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIMacroKeyData .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIMacroKeyData .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIMacroKeyData .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIMacroKeyData .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIMacroKeyData .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIMacroKeyData .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIMacroKeyData .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIMacroKeyData .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIMacroKeyData .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIMacroKeyData .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIMacroKeyData .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIMacroKeyData .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIMacroKeyData .)
Public method | LinkMacros | Links macro actions to the editor events.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIMacroKeyData .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIMacroKeyData .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIMacroKeyData .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIMacroKeyData .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIMacroKeyData .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIMacroKeyData .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIMacroKeyData .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIMacroKeyData .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIMacroKeyData .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIMacroKeyData .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIMacroKeyData .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIMacroKeyData .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIMacroKeyData | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIMacroKeyData | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIMacroKeyData, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIMacroKeyData .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIMacroKeyData .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIMacroKeyData .)
Public property | SerializationInfo | Gets or sets an xml representation of this ColorTheme object.
Top
See Also

Reference

Alternet.Editor Namespace


MacroKeyList Constructor

MacroKeyList Constructor
Initializes a new instance of the MacroKeyList class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MacroKeyList()
Public Sub New
public:
MacroKeyList()
new : unit -> MacroKeyList
See Also

Reference

MacroKeyList Class
Alternet.Editor Namespace


MacroKeyList Methods

MacroKeyList Methods

The MacroKeyList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIMacroKeyData .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIMacroKeyData .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIMacroKeyData .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIMacroKeyData .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIMacroKeyData .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIMacroKeyData .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIMacroKeyData .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIMacroKeyData .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIMacroKeyData .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIMacroKeyData .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIMacroKeyData .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIMacroKeyData .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIMacroKeyData .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIMacroKeyData .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIMacroKeyData .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIMacroKeyData .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIMacroKeyData .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIMacroKeyData .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIMacroKeyData .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIMacroKeyData .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIMacroKeyData .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIMacroKeyData .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIMacroKeyData .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIMacroKeyData .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIMacroKeyData .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIMacroKeyData .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIMacroKeyData .)
Public method | LinkMacros | Links macro actions to the editor events.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIMacroKeyData .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIMacroKeyData .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIMacroKeyData .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIMacroKeyData .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIMacroKeyData .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIMacroKeyData .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIMacroKeyData .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIMacroKeyData .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIMacroKeyData .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIMacroKeyData .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIMacroKeyData .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIMacroKeyData .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIMacroKeyData .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIMacroKeyData | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIMacroKeyData | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIMacroKeyData, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

MacroKeyList Class
Alternet.Editor Namespace


MacroKeyList.LinkMacros Method

MacroKeyListLinkMacros Method
Links macro actions to the editor events.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LinkMacros(
    Object owner,
    IEventHandlers keyHandlers
)
Public Sub LinkMacros (
    owner As Object,
    keyHandlers As IEventHandlers
)
public:
virtual void LinkMacros(
    Object^ owner,
    IEventHandlers^ keyHandlers
) sealed
abstract LinkMacros :
        owner : Object *
        keyHandlers : IEventHandlers -> unit
override LinkMacros :
        owner : Object *
        keyHandlers : IEventHandlers -> unit

Parameters

owner
Type: SystemObject
Editor control containing macros.
keyHandlers
Type: Alternet.EditorIEventHandlers
Collection of events.

Implements

IMacroKeyListLinkMacros(Object, IEventHandlers)
See Also

Reference

MacroKeyList Class
Alternet.Editor Namespace


MacroKeyList Properties

MacroKeyList Properties

The MacroKeyList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIMacroKeyData .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIMacroKeyData .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIMacroKeyData .)
Public property | SerializationInfo | Gets or sets an xml representation of this ColorTheme object.
Top
See Also

Reference

MacroKeyList Class
Alternet.Editor Namespace


MacroKeyList.SerializationInfo Property

MacroKeyListSerializationInfo Property
Gets or sets an xml representation of this ColorTheme object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

IMacroKeyListSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

MacroKeyList Class
Alternet.Editor Namespace


Margin Class

Margin Class
Represents an appearance of the margin in Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorMargin

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Margin : IMargin, IUpdate,
    IDisposable
Public Class Margin
    Implements IMargin, IUpdate, IDisposable
public ref class Margin : IMargin, IUpdate,
    IDisposable
type Margin =
    class
        interface IMargin
        interface IUpdate
        interface IDisposable
    end

The Margin type exposes the following members.

Constructors
 | Name | Description
Public method | Margin | Initializes a new instance of the Margin with default settings.
Public method | Margin(ISyntaxEdit) | Initializes a new instance of the Margin with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents from another IMargin object.
Public method | BeginUpdate | Prevents Margin updating until calling Margin.EndUpdate method.
Public method | CancelDragging | Cancels dragging the margin.
Public method | Contains | Indicates whether Margin area contains given position.
Public method | DisableUpdate | Prevents Margin updating until calling Margin.EndUpdate method.
Public method | Dispose | Disposes this Margin and frees resources associated with it.
Public method | DragTo | Moves Margin to specified position.
Public method | EnableUpdate | Re-enables Margin updating, that was turn of by calling Margin.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling Margin.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Paint | Draws Margin object on the specified graphic surface.
Public method | PaintColumn | Draws margin column on the specified graphic surface.
Public method | ResetAllowDrag | Resets the AllowDrag to the default value.
Public method | ResetColumnPositions | Resets the Position to the default value.
Public method | ResetColumnsPenColor | Resets the ColumnPenColor to the default value.
Public method | ResetColumnsVisible | Resets the ColumnsVisible to the default value.
Public method | ResetPenColor | Resets the PenColor to the default value.
Public method | ResetPosition | Resets the Position to the default value.
Public method | ResetShowHints | Resets the ShowHints to the default value.
Public method | ResetVisible | Resets the Visible to the default value.
Public method | ShouldSerializeColumnPenColor | Indicates whether the ColumnPenColor property should be persisted.
Public method | ShouldSerializeColumnPositions | Indicates whether the ColumnPositions property should be persisted.
Public method | ShouldSerializePenColor | Indicates whether the PenColor property should be persisted.
Public method | ShouldSerializePosition | Indicates whether the Position property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Forces editor control to invalidate it's area.
Public method | Update(Boolean) | Invalidates editor if needed.
Top
Properties
 | Name | Description
Public property | AllowDrag | Indicates whether drag operation can performed to Margin.
Public property | ColumnPen | Gets or sets Pen object that describes the color and pattern of Margin line.
Public property | ColumnPenColor | Gets or sets a color of the column margin line.
Public property | ColumnPositions | Gets or sets the character columns where additional column margin will be drawn.
Public property | ColumnsVisible | Gets or sets a value indicating whether column margins should be painted.
Public property | IsDragging | Indicates whether Margin is in dragging state.
Public property | Pen | Gets or sets Pen object that describes the color and pattern of Margin line.
Public property | PenColor | Gets or sets a color of the margin line.
Public property | Position | Gets or sets value indicating position, in characters, of the vertical line within the text portion of the control.
Public property | ShowHints | Gets or sets a value indicating whether Margin should display some hint when mouse pointer is over the margin area.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | Visible | Gets or sets a value indicating whether vertical line should be painted.
Top
See Also

Reference

Alternet.Editor Namespace


Margin Constructor

Margin Constructor
Overload List
 | Name | Description
Public method | Margin | Initializes a new instance of the Margin with default settings.
Public method | Margin(ISyntaxEdit) | Initializes a new instance of the Margin with specified owner.
Top
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin Constructor

Margin Constructor
Initializes a new instance of the Margin with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Margin()
Public Sub New
public:
Margin()
new : unit -> Margin
See Also

Reference

Margin Class
Margin Overload
Alternet.Editor Namespace


Margin Constructor (ISyntaxEdit)

Margin Constructor (ISyntaxEdit)
Initializes a new instance of the Margin with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Margin(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
Margin(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> Margin

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

Margin Class
Margin Overload
Alternet.Editor Namespace


Margin Methods

Margin Methods

The Margin type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents from another IMargin object.
Public method | BeginUpdate | Prevents Margin updating until calling Margin.EndUpdate method.
Public method | CancelDragging | Cancels dragging the margin.
Public method | Contains | Indicates whether Margin area contains given position.
Public method | DisableUpdate | Prevents Margin updating until calling Margin.EndUpdate method.
Public method | Dispose | Disposes this Margin and frees resources associated with it.
Public method | DragTo | Moves Margin to specified position.
Public method | EnableUpdate | Re-enables Margin updating, that was turn of by calling Margin.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling Margin.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Paint | Draws Margin object on the specified graphic surface.
Public method | PaintColumn | Draws margin column on the specified graphic surface.
Public method | ResetAllowDrag | Resets the AllowDrag to the default value.
Public method | ResetColumnPositions | Resets the Position to the default value.
Public method | ResetColumnsPenColor | Resets the ColumnPenColor to the default value.
Public method | ResetColumnsVisible | Resets the ColumnsVisible to the default value.
Public method | ResetPenColor | Resets the PenColor to the default value.
Public method | ResetPosition | Resets the Position to the default value.
Public method | ResetShowHints | Resets the ShowHints to the default value.
Public method | ResetVisible | Resets the Visible to the default value.
Public method | ShouldSerializeColumnPenColor | Indicates whether the ColumnPenColor property should be persisted.
Public method | ShouldSerializeColumnPositions | Indicates whether the ColumnPositions property should be persisted.
Public method | ShouldSerializePenColor | Indicates whether the PenColor property should be persisted.
Public method | ShouldSerializePosition | Indicates whether the Position property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Forces editor control to invalidate it's area.
Public method | Update(Boolean) | Invalidates editor if needed.
Top
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.Assign Method

MarginAssign Method
Copies the contents from another IMargin object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IMargin source
)
Public Overridable Sub Assign (
    source As IMargin
)
public:
virtual void Assign(
    IMargin^ source
)
abstract Assign :
        source : IMargin -> unit
override Assign :
        source : IMargin -> unit

Parameters

source
Type: Alternet.EditorIMargin
Specifies IMargin to assign.

Implements

IMarginAssign(IMargin)
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.BeginUpdate Method

MarginBeginUpdate Method
Prevents Margin updating until calling Margin.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of Margin updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.CancelDragging Method

MarginCancelDragging Method
Cancels dragging the margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CancelDragging()
Public Overridable Sub CancelDragging
public:
virtual void CancelDragging()
abstract CancelDragging : unit -> unit
override CancelDragging : unit -> unit

Implements

IMarginCancelDragging
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.Contains Method

MarginContains Method
Indicates whether Margin area contains given position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    int x,
    int y
)
Public Overridable Function Contains (
    x As Integer,
    y As Integer
) As Boolean
public:
virtual bool Contains(
    int x,
    int y
)
abstract Contains :
        x : int *
        y : int -> bool
override Contains :
        x : int *
        y : int -> bool

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies the point to check-up.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies the point to check-up.

Return Value

Type: Boolean
True if contains; otherwise false.

Implements

IMarginContains(Int32, Int32)
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.DisableUpdate Method

MarginDisableUpdate Method
Prevents Margin updating until calling Margin.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.Dispose Method

MarginDispose Method
Disposes this Margin and frees resources associated with it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.DragTo Method

MarginDragTo Method
Moves Margin to specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DragTo(
    int x,
    int y
)
Public Overridable Sub DragTo (
    x As Integer,
    y As Integer
)
public:
virtual void DragTo(
    int x,
    int y
)
abstract DragTo :
        x : int *
        y : int -> unit
override DragTo :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies position to drag.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies position to drag.

Implements

IMarginDragTo(Int32, Int32)
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.EnableUpdate Method

MarginEnableUpdate Method
Re-enables Margin updating, that was turn of by calling Margin.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of Margin updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.EndUpdate Method

MarginEndUpdate Method
Re-enables page updating, that was turn of by calling Margin.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of Margin updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.Paint Method

MarginPaint Method
Draws Margin object on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Paint(
    IPainter painter,
    Rectangle rect
)
Public Overridable Sub Paint (
    painter As IPainter,
    rect As Rectangle
)
public:
virtual void Paint(
    IPainter^ painter,
    Rectangle rect
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle -> unit
override Paint :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of Margin to draw.

Implements

IMarginPaint(IPainter, Rectangle)
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.PaintColumn Method

MarginPaintColumn Method
Draws margin column on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintColumn(
    IPainter painter,
    Rectangle rect
)
Public Overridable Sub PaintColumn (
    painter As IPainter,
    rect As Rectangle
)
public:
virtual void PaintColumn(
    IPainter^ painter,
    Rectangle rect
)
abstract PaintColumn :
        painter : IPainter *
        rect : Rectangle -> unit
override PaintColumn :
        painter : IPainter *
        rect : Rectangle -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of Margin to draw.

Implements

IMarginPaintColumn(IPainter, Rectangle)
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ResetAllowDrag Method

MarginResetAllowDrag Method
Resets the AllowDrag to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAllowDrag()
Public Overridable Sub ResetAllowDrag
public:
virtual void ResetAllowDrag()
abstract ResetAllowDrag : unit -> unit
override ResetAllowDrag : unit -> unit

Implements

IMarginResetAllowDrag
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ResetColumnPositions Method

MarginResetColumnPositions Method
Resets the Position to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetColumnPositions()
Public Overridable Sub ResetColumnPositions
public:
virtual void ResetColumnPositions()
abstract ResetColumnPositions : unit -> unit
override ResetColumnPositions : unit -> unit

Implements

IMarginResetColumnPositions
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ResetColumnsPenColor Method

MarginResetColumnsPenColor Method
Resets the ColumnPenColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetColumnsPenColor()
Public Overridable Sub ResetColumnsPenColor
public:
virtual void ResetColumnsPenColor()
abstract ResetColumnsPenColor : unit -> unit
override ResetColumnsPenColor : unit -> unit

Implements

IMarginResetColumnsPenColor
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ResetColumnsVisible Method

MarginResetColumnsVisible Method
Resets the ColumnsVisible to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetColumnsVisible()
Public Overridable Sub ResetColumnsVisible
public:
virtual void ResetColumnsVisible()
abstract ResetColumnsVisible : unit -> unit
override ResetColumnsVisible : unit -> unit

Implements

IMarginResetColumnsVisible
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ResetPenColor Method

MarginResetPenColor Method
Resets the PenColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetPenColor()
Public Overridable Sub ResetPenColor
public:
virtual void ResetPenColor()
abstract ResetPenColor : unit -> unit
override ResetPenColor : unit -> unit

Implements

IMarginResetPenColor
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ResetPosition Method

MarginResetPosition Method
Resets the Position to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetPosition()
Public Overridable Sub ResetPosition
public:
virtual void ResetPosition()
abstract ResetPosition : unit -> unit
override ResetPosition : unit -> unit

Implements

IMarginResetPosition
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ResetShowHints Method

MarginResetShowHints Method
Resets the ShowHints to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetShowHints()
Public Overridable Sub ResetShowHints
public:
virtual void ResetShowHints()
abstract ResetShowHints : unit -> unit
override ResetShowHints : unit -> unit

Implements

IMarginResetShowHints
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ResetVisible Method

MarginResetVisible Method
Resets the Visible to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetVisible()
Public Overridable Sub ResetVisible
public:
virtual void ResetVisible()
abstract ResetVisible : unit -> unit
override ResetVisible : unit -> unit

Implements

IMarginResetVisible
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ShouldSerializeColumnPenColor Method

MarginShouldSerializeColumnPenColor Method
Indicates whether the ColumnPenColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeColumnPenColor()
Public Function ShouldSerializeColumnPenColor As Boolean
public:
bool ShouldSerializeColumnPenColor()
member ShouldSerializeColumnPenColor : unit -> bool

Return Value

Type: Boolean
True if ColumnPenColor differs from its default value; otherwise false.
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ShouldSerializeColumnPositions Method

MarginShouldSerializeColumnPositions Method
Indicates whether the ColumnPositions property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeColumnPositions()
Public Function ShouldSerializeColumnPositions As Boolean
public:
bool ShouldSerializeColumnPositions()
member ShouldSerializeColumnPositions : unit -> bool

Return Value

Type: Boolean
True if ColumnPositions differs from its default value; otherwise false.
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ShouldSerializePenColor Method

MarginShouldSerializePenColor Method
Indicates whether the PenColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePenColor()
Public Function ShouldSerializePenColor As Boolean
public:
bool ShouldSerializePenColor()
member ShouldSerializePenColor : unit -> bool

Return Value

Type: Boolean
True if PenColor differs from its default value; otherwise false.
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ShouldSerializePosition Method

MarginShouldSerializePosition Method
Indicates whether the Position property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePosition()
Public Function ShouldSerializePosition As Boolean
public:
bool ShouldSerializePosition()
member ShouldSerializePosition : unit -> bool

Return Value

Type: Boolean
True if Position differs from its default value; otherwise false.
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.Update Method

MarginUpdate Method
Overload List
 | Name | Description
Public method | Update | Forces editor control to invalidate it's area.
Public method | Update(Boolean) | Invalidates editor if needed.
Top
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.Update Method

MarginUpdate Method
Forces editor control to invalidate it's area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
virtual void Update() sealed
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

Margin Class
Update Overload
Alternet.Editor Namespace


Margin.Update Method (Boolean)

MarginUpdate Method (Boolean)
Invalidates editor if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update(
    bool needUpdate
)
Public Sub Update (
    needUpdate As Boolean
)
public:
void Update(
    bool needUpdate
)
member Update :
        needUpdate : bool -> unit

Parameters

needUpdate
Type: SystemBoolean
See Also

Reference

Margin Class
Update Overload
Alternet.Editor Namespace


Margin Properties

Margin Properties

The Margin type exposes the following members.

Properties
 | Name | Description
Public property | AllowDrag | Indicates whether drag operation can performed to Margin.
Public property | ColumnPen | Gets or sets Pen object that describes the color and pattern of Margin line.
Public property | ColumnPenColor | Gets or sets a color of the column margin line.
Public property | ColumnPositions | Gets or sets the character columns where additional column margin will be drawn.
Public property | ColumnsVisible | Gets or sets a value indicating whether column margins should be painted.
Public property | IsDragging | Indicates whether Margin is in dragging state.
Public property | Pen | Gets or sets Pen object that describes the color and pattern of Margin line.
Public property | PenColor | Gets or sets a color of the margin line.
Public property | Position | Gets or sets value indicating position, in characters, of the vertical line within the text portion of the control.
Public property | ShowHints | Gets or sets a value indicating whether Margin should display some hint when mouse pointer is over the margin area.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | Visible | Gets or sets a value indicating whether vertical line should be painted.
Top
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.AllowDrag Property

MarginAllowDrag Property
Indicates whether drag operation can performed to Margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AllowDrag { get; set; }
Public Overridable Property AllowDrag As Boolean
    Get
    Set
public:
virtual property bool AllowDrag {
    bool get ();
    void set (bool value);
}
abstract AllowDrag : bool with get, set
override AllowDrag : bool with get, set

Property Value

Type: Boolean

Implements

IMarginAllowDrag
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ColumnPen Property

MarginColumnPen Property
Gets or sets Pen object that describes the color and pattern of Margin line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Pen ColumnPen { get; set; }
Public Overridable Property ColumnPen As Pen
    Get
    Set
public:
virtual property Pen^ ColumnPen {
    Pen^ get ();
    void set (Pen^ value);
}
abstract ColumnPen : Pen with get, set
override ColumnPen : Pen with get, set

Property Value

Type: Pen

Implements

IMarginColumnPen
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ColumnPenColor Property

MarginColumnPenColor Property
Gets or sets a color of the column margin line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ColumnPenColor { get; set; }
Public Overridable Property ColumnPenColor As Color
    Get
    Set
public:
virtual property Color ColumnPenColor {
    Color get ();
    void set (Color value);
}
abstract ColumnPenColor : Color with get, set
override ColumnPenColor : Color with get, set

Property Value

Type: Color

Implements

IMarginColumnPenColor
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ColumnPositions Property

MarginColumnPositions Property
Gets or sets the character columns where additional column margin will be drawn.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int[] ColumnPositions { get; set; }
Public Overridable Property ColumnPositions As Integer()
    Get
    Set
public:
virtual property array<int>^ ColumnPositions {
    array<int>^ get ();
    void set (array<int>^ value);
}
abstract ColumnPositions : int[] with get, set
override ColumnPositions : int[] with get, set

Property Value

Type: Int32

Implements

IMarginColumnPositions
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ColumnsVisible Property

MarginColumnsVisible Property
Gets or sets a value indicating whether column margins should be painted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ColumnsVisible { get; set; }
Public Overridable Property ColumnsVisible As Boolean
    Get
    Set
public:
virtual property bool ColumnsVisible {
    bool get ();
    void set (bool value);
}
abstract ColumnsVisible : bool with get, set
override ColumnsVisible : bool with get, set

Property Value

Type: Boolean

Implements

IMarginColumnsVisible
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.IsDragging Property

MarginIsDragging Property
Indicates whether Margin is in dragging state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDragging { get; set; }
Public Overridable Property IsDragging As Boolean
    Get
    Set
public:
virtual property bool IsDragging {
    bool get ();
    void set (bool value);
}
abstract IsDragging : bool with get, set
override IsDragging : bool with get, set

Property Value

Type: Boolean

Implements

IMarginIsDragging
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.Pen Property

MarginPen Property
Gets or sets Pen object that describes the color and pattern of Margin line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Pen Pen { get; set; }
Public Overridable Property Pen As Pen
    Get
    Set
public:
virtual property Pen^ Pen {
    Pen^ get ();
    void set (Pen^ value);
}
abstract Pen : Pen with get, set
override Pen : Pen with get, set

Property Value

Type: Pen

Implements

IMarginPen
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.PenColor Property

MarginPenColor Property
Gets or sets a color of the margin line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color PenColor { get; set; }
Public Overridable Property PenColor As Color
    Get
    Set
public:
virtual property Color PenColor {
    Color get ();
    void set (Color value);
}
abstract PenColor : Color with get, set
override PenColor : Color with get, set

Property Value

Type: Color

Implements

IMarginPenColor
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.Position Property

MarginPosition Property
Gets or sets value indicating position, in characters, of the vertical line within the text portion of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Position { get; set; }
Public Overridable Property Position As Integer
    Get
    Set
public:
virtual property int Position {
    int get ();
    void set (int value);
}
abstract Position : int with get, set
override Position : int with get, set

Property Value

Type: Int32

Implements

IMarginPosition
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.ShowHints Property

MarginShowHints Property
Gets or sets a value indicating whether Margin should display some hint when mouse pointer is over the margin area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowHints { get; set; }
Public Overridable Property ShowHints As Boolean
    Get
    Set
public:
virtual property bool ShowHints {
    bool get ();
    void set (bool value);
}
abstract ShowHints : bool with get, set
override ShowHints : bool with get, set

Property Value

Type: Boolean

Implements

IMarginShowHints
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.UpdateCount Property

MarginUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

Margin Class
Alternet.Editor Namespace


Margin.Visible Property

MarginVisible Property
Gets or sets a value indicating whether vertical line should be painted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Visible { get; set; }
Public Overridable Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

IMarginVisible
See Also

Reference

Margin Class
Alternet.Editor Namespace


NotifyEvent Delegate

NotifyEvent Delegate
Represents a method that will handle the SyntaxEdit.SourceStateChanged event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void NotifyEvent(
    Object sender,
    NotifyEventArgs e
)
Public Delegate Sub NotifyEvent (
    sender As Object,
    e As NotifyEventArgs
)
public delegate void NotifyEvent(
    Object^ sender,
    NotifyEventArgs^ e
)
type NotifyEvent =
    delegate of
        sender : Object *
        e : NotifyEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorNotifyEventArgs
A NotifyEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


NotifyEventArgs Class

NotifyEventArgs Class
Provides data for the NotifyEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorNotifyEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NotifyEventArgs : EventArgs
Public Class NotifyEventArgs
    Inherits EventArgs
public ref class NotifyEventArgs : public EventArgs
type NotifyEventArgs =
    class
        inherit EventArgs
    end

The NotifyEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NotifyEventArgs | Initializes a new instance of the NotifyEventArgs class with default settings.
Public method | NotifyEventArgs(NotifyState, Int32, Int32, Boolean) | Initializes a new instance of the NotifyEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FirstChanged | Represents index of the first changed line in the text portion of the control.
Public property | LastChanged | Represents index of the last changed line in the text portion of the control.
Public property | State | Represents the reason of change.
Public property | Update | Indicates whether ISyntaxEdit control should update its scroll bars and caret position.
Top
See Also

Reference

Alternet.Editor Namespace


NotifyEventArgs Constructor

NotifyEventArgs Constructor
Overload List
 | Name | Description
Public method | NotifyEventArgs | Initializes a new instance of the NotifyEventArgs class with default settings.
Public method | NotifyEventArgs(NotifyState, Int32, Int32, Boolean) | Initializes a new instance of the NotifyEventArgs class with specified parameters.
Top
See Also

Reference

NotifyEventArgs Class
Alternet.Editor Namespace


NotifyEventArgs Constructor

NotifyEventArgs Constructor
Initializes a new instance of the NotifyEventArgs class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyEventArgs()
Public Sub New
public:
NotifyEventArgs()
new : unit -> NotifyEventArgs
See Also

Reference

NotifyEventArgs Class
NotifyEventArgs Overload
Alternet.Editor Namespace


NotifyEventArgs Constructor (NotifyState, Int32, Int32, Boolean)

NotifyEventArgs Constructor (NotifyState, Int32, Int32, Boolean)
Initializes a new instance of the NotifyEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyEventArgs(
    NotifyState state,
    int first,
    int last,
    bool update
)
Public Sub New (
    state As NotifyState,
    first As Integer,
    last As Integer,
    update As Boolean
)
public:
NotifyEventArgs(
    NotifyState state,
    int first,
    int last,
    bool update
)
new :
        state : NotifyState *
        first : int *
        last : int *
        update : bool -> NotifyEventArgs

Parameters

state
Type: Alternet.Editor.TextSourceNotifyState
State of the new instance.
first
Type: SystemInt32
First changed line of new instance.
last
Type: SystemInt32
Last changed line of new instance.
update
Type: SystemBoolean
Specifies Update field of the instance.
See Also

Reference

NotifyEventArgs Class
NotifyEventArgs Overload
Alternet.Editor Namespace


NotifyEventArgs Methods

NotifyEventArgs Methods

The NotifyEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NotifyEventArgs Class
Alternet.Editor Namespace


NotifyEventArgs Properties

NotifyEventArgs Properties

The NotifyEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FirstChanged | Represents index of the first changed line in the text portion of the control.
Public property | LastChanged | Represents index of the last changed line in the text portion of the control.
Public property | State | Represents the reason of change.
Public property | Update | Indicates whether ISyntaxEdit control should update its scroll bars and caret position.
Top
See Also

Reference

NotifyEventArgs Class
Alternet.Editor Namespace


NotifyEventArgs.FirstChanged Property

NotifyEventArgsFirstChanged Property
Represents index of the first changed line in the text portion of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FirstChanged { get; set; }
Public Property FirstChanged As Integer
    Get
    Set
public:
property int FirstChanged {
    int get ();
    void set (int value);
}
member FirstChanged : int with get, set

Property Value

Type: Int32
See Also

Reference

NotifyEventArgs Class
Alternet.Editor Namespace


NotifyEventArgs.LastChanged Property

NotifyEventArgsLastChanged Property
Represents index of the last changed line in the text portion of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LastChanged { get; set; }
Public Property LastChanged As Integer
    Get
    Set
public:
property int LastChanged {
    int get ();
    void set (int value);
}
member LastChanged : int with get, set

Property Value

Type: Int32
See Also

Reference

NotifyEventArgs Class
Alternet.Editor Namespace


NotifyEventArgs.State Property

NotifyEventArgsState Property
Represents the reason of change.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NotifyState State { get; set; }
Public Property State As NotifyState
    Get
    Set
public:
property NotifyState State {
    NotifyState get ();
    void set (NotifyState value);
}
member State : NotifyState with get, set

Property Value

Type: NotifyState
See Also

Reference

NotifyEventArgs Class
Alternet.Editor Namespace


NotifyEventArgs.Update Property

NotifyEventArgsUpdate Property
Indicates whether ISyntaxEdit control should update its scroll bars and caret position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Update { get; set; }
Public Property Update As Boolean
    Get
    Set
public:
property bool Update {
    bool get ();
    void set (bool value);
}
member Update : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NotifyEventArgs Class
Alternet.Editor Namespace


OutlineEvent Delegate

OutlineEvent Delegate
Represents a method that will handle the IOutlining.Expanding and IOutlining.Collapsing event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void OutlineEvent(
    Object sender,
    OutlineEventArgs e
)
Public Delegate Sub OutlineEvent (
    sender As Object,
    e As OutlineEventArgs
)
public delegate void OutlineEvent(
    Object^ sender,
    OutlineEventArgs^ e
)
type OutlineEvent =
    delegate of
        sender : Object *
        e : OutlineEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorOutlineEventArgs
A AutoCorrectEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


OutlineEventArgs Class

OutlineEventArgs Class
Provides data for the AutoCorrectEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorOutlineEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OutlineEventArgs : EventArgs
Public Class OutlineEventArgs
    Inherits EventArgs
public ref class OutlineEventArgs : public EventArgs
type OutlineEventArgs =
    class
        inherit EventArgs
    end

The OutlineEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OutlineEventArgs | Initialized OutlineEventArgs class with specified line index.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CanCollapse | Indicates that outline section at given line can be collapsed.
Public property | CanExpand | Indicates that outline section at given line can be expanded.
Public property | Line | Represents line to be collapsed or expanded.
Top
See Also

Reference

Alternet.Editor Namespace


OutlineEventArgs Constructor

OutlineEventArgs Constructor
Initialized OutlineEventArgs class with specified line index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public OutlineEventArgs(
    int line
)
Public Sub New (
    line As Integer
)
public:
OutlineEventArgs(
    int line
)
new :
        line : int -> OutlineEventArgs

Parameters

line
Type: SystemInt32
See Also

Reference

OutlineEventArgs Class
Alternet.Editor Namespace


OutlineEventArgs Methods

OutlineEventArgs Methods

The OutlineEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OutlineEventArgs Class
Alternet.Editor Namespace


OutlineEventArgs Properties

OutlineEventArgs Properties

The OutlineEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CanCollapse | Indicates that outline section at given line can be collapsed.
Public property | CanExpand | Indicates that outline section at given line can be expanded.
Public property | Line | Represents line to be collapsed or expanded.
Top
See Also

Reference

OutlineEventArgs Class
Alternet.Editor Namespace


OutlineEventArgs.CanCollapse Property

OutlineEventArgsCanCollapse Property
Indicates that outline section at given line can be collapsed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCollapse { get; set; }
Public Property CanCollapse As Boolean
    Get
    Set
public:
property bool CanCollapse {
    bool get ();
    void set (bool value);
}
member CanCollapse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

OutlineEventArgs Class
Alternet.Editor Namespace


OutlineEventArgs.CanExpand Property

OutlineEventArgsCanExpand Property
Indicates that outline section at given line can be expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanExpand { get; set; }
Public Property CanExpand As Boolean
    Get
    Set
public:
property bool CanExpand {
    bool get ();
    void set (bool value);
}
member CanExpand : bool with get, set

Property Value

Type: Boolean
See Also

Reference

OutlineEventArgs Class
Alternet.Editor Namespace


OutlineEventArgs.Line Property

OutlineEventArgsLine Property
Represents line to be collapsed or expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

OutlineEventArgs Class
Alternet.Editor Namespace


OutlineOptions Enumeration

OutlineOptions Enumeration
Defines appearance and behaviour of the outline text sections. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum OutlineOptions
<FlagsAttribute>
Public Enumeration OutlineOptions
[FlagsAttribute]
public enum class OutlineOptions
[<FlagsAttribute>]
type OutlineOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
DrawOnGutter | 1 | Specifies that control should paint outline images and lines on gutter.
DrawLines | 2 | Specifies that control should paint lines for expanded outline section.
DrawButtons | 4 | Specifies that control should paint the outline buttons substituting content of the collapsed section.
ShowHints | 8 | Specifies that control should display text of the collapsed outline section in the popup window when mouse pointer is over the outline button.
HighlightOnMove | 16 | Specifies that control should highlight outlined section when mouse pointer is over the outline area.
See Also

Reference

Alternet.Editor Namespace


Outlining Class

Outlining Class
Represents properties and methods that affects appearance and behaviour of outline sections within Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorOutlining

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Outlining : IOutlining, ICollapsable
Public Class Outlining
    Implements IOutlining, ICollapsable
public ref class Outlining : IOutlining,
    ICollapsable
type Outlining =
    class
        interface IOutlining
        interface ICollapsable
    end

The Outlining type exposes the following members.

Constructors
 | Name | Description
Public method | Outlining | Initializes a new instance of the Outlining class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents from another IOutlining object.
Public method | BeginUpdate | Prevents outline list updating until calling EndUpdate method.
Public method | CanCollapse | Returns boolean value indicating that outline section at given line can be collapsed.
Public method | CanExpand(Int32) | Returns boolean value indicating that outline section at given line can be expanded.
Public method | CanExpand(IOutlineRange) | Returns boolean value indicating that given outline section can be expanded.
Public method | Collapse | Collapses the specified line.
Public method | CollapseToDefinitions | Collapses and expands some outline section to get a quick overall view of the content.
Public method | EndUpdate | Re-enables outline list updating, that was turn of by calling BeginUpdate method.
Public method | EnsureExpanded(Point) | Makes all outline sections containing specified position expanded.
Public method | EnsureExpanded(Int32) | Makes all outline sections containing specified line expanded.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Expand | Expands outline section at the given line.
Public method | FullCollapse | When implemented by a class, collapses all outlining sections.
Public method | FullCollapse(IListIRange) | Collapses all sections objects specified by Ranges parameter.
Public method | FullExpand | Expands all outlining sections.
Public method | FullExpand(IListIRange) | Expands all outline sections specified by Ranges parameter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetOutlineHint | Returns string that appears in the hint window when mouse pointer is over the outline button.
Public method | GetOutlineRange(Point) | Returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position.
Public method | GetOutlineRange(Int32) | Returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line.
Public method | GetOutlineRanges(IListIRange) | Fills list specified by ranges parameter with all existing outline sections.
Public method | GetOutlineRanges(IListIRange, Point) | Fills list specified by ranges parameter with all outline sections containing specific position.
Public method | GetOutlineRanges(IListIRange, Int32) | Fills list specified by ranges parameter with all outline sections containing specific line.
Public method | GetOutlineRanges(IListIRange, Point, Point) | Fills list specified by ranges parameter with all outline sections containing specific range.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCollapsed | Indicates whether the outlined text at the specified line is collapsed.
Public method | IsExpanded | Indicates whether the outlined text at the specified line is expanded.
Public method | IsVisible(Point) | Indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.
Public method | IsVisible(Int32) | Indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.
Public method | Outline(Point, Point) | Creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Int32, Int32) | Creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Point, Point, Int32) | Creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Point, Point, String) | Creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32) | Creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Int32, Int32, String) | Creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Point, Point, Int32, String) | Creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32, String) | Creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | OutlineText | Tries to perform lexical analysis of entire text to create outline sections based on results of this analysis.
Public method | ResetAllowOutlining | Resets AllowOutlining to the default value.
Public method | ResetOutlineColor | Resets OutlineColor to the default value.
Public method | ResetOutlineOptions | Resets OutlineOptions to the default value.
Public method | SetOutlineRanges(IListIRange) | Updates IOutlineRange collection from given list of ranges.
Public method | SetOutlineRanges(IListIRange, Boolean) | Updates IOutlineRange collection from given list of ranges.
Public method | ShouldSerializeImageSize | Indicates whether the ImageSize property should be persisted.
Public method | ShouldSerializeOutlineColor | Indicates whether the OutlineColor property should be persisted.
Public method | ShouldSerializeOutlineOptions | Indicates whether the OutlineOptions property should be persisted.
Public method | ToggleOutlining | Toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOutlining(IListIRange, IOutlineRange) | Toggles expanded state for given IOutlineRange collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnOutline | Removes all outlined sections from outline collection.
Public method | UnOutline(Point) | Removes outlined section at the specific position.
Public method | UnOutline(Int32) | Removes all outline sections containing the given line.
Public method | UnOutlineText | Removes all outline section from outline collection.
Top
Properties
 | Name | Description
Public property | AllowOutlining | Gets or sets a value indicating whether outlining enabled.
Public property | CollapsedCount | Returns number of collapsed sections.
Public property | ImageSize | Gets or sets size of outlining image. When auto scaling enabled, measured in DIP.
Public property | ImageSizeInPixels | When implemented by a class, gets size of outlining image in pixels.
Public property | OutlineColor | Gets or sets color that is used to draw outline button.
Public property | OutlineOptions | Gets or sets outlining options.
Public property | UseRoundRect | Gets or sets a boolean value indicating whether outlining buttons should be drawn with rounded corners.
Top
Events
 | Name | Description
Public event | Collapsing | Occurs when user attempts expand outline section.
Public event | Expanding | Occurs when user attempts expand outline section.
Top
See Also

Reference

Alternet.Editor Namespace


Outlining Constructor

Outlining Constructor
Initializes a new instance of the Outlining class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outlining(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
Outlining(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> Outlining

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining Methods

Outlining Methods

The Outlining type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents from another IOutlining object.
Public method | BeginUpdate | Prevents outline list updating until calling EndUpdate method.
Public method | CanCollapse | Returns boolean value indicating that outline section at given line can be collapsed.
Public method | CanExpand(Int32) | Returns boolean value indicating that outline section at given line can be expanded.
Public method | CanExpand(IOutlineRange) | Returns boolean value indicating that given outline section can be expanded.
Public method | Collapse | Collapses the specified line.
Public method | CollapseToDefinitions | Collapses and expands some outline section to get a quick overall view of the content.
Public method | EndUpdate | Re-enables outline list updating, that was turn of by calling BeginUpdate method.
Public method | EnsureExpanded(Point) | Makes all outline sections containing specified position expanded.
Public method | EnsureExpanded(Int32) | Makes all outline sections containing specified line expanded.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Expand | Expands outline section at the given line.
Public method | FullCollapse | When implemented by a class, collapses all outlining sections.
Public method | FullCollapse(IListIRange) | Collapses all sections objects specified by Ranges parameter.
Public method | FullExpand | Expands all outlining sections.
Public method | FullExpand(IListIRange) | Expands all outline sections specified by Ranges parameter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetOutlineHint | Returns string that appears in the hint window when mouse pointer is over the outline button.
Public method | GetOutlineRange(Point) | Returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position.
Public method | GetOutlineRange(Int32) | Returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line.
Public method | GetOutlineRanges(IListIRange) | Fills list specified by ranges parameter with all existing outline sections.
Public method | GetOutlineRanges(IListIRange, Point) | Fills list specified by ranges parameter with all outline sections containing specific position.
Public method | GetOutlineRanges(IListIRange, Int32) | Fills list specified by ranges parameter with all outline sections containing specific line.
Public method | GetOutlineRanges(IListIRange, Point, Point) | Fills list specified by ranges parameter with all outline sections containing specific range.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCollapsed | Indicates whether the outlined text at the specified line is collapsed.
Public method | IsExpanded | Indicates whether the outlined text at the specified line is expanded.
Public method | IsVisible(Point) | Indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.
Public method | IsVisible(Int32) | Indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.
Public method | Outline(Point, Point) | Creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Int32, Int32) | Creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Point, Point, Int32) | Creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Point, Point, String) | Creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32) | Creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Int32, Int32, String) | Creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Point, Point, Int32, String) | Creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32, String) | Creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | OutlineText | Tries to perform lexical analysis of entire text to create outline sections based on results of this analysis.
Public method | ResetAllowOutlining | Resets AllowOutlining to the default value.
Public method | ResetOutlineColor | Resets OutlineColor to the default value.
Public method | ResetOutlineOptions | Resets OutlineOptions to the default value.
Public method | SetOutlineRanges(IListIRange) | Updates IOutlineRange collection from given list of ranges.
Public method | SetOutlineRanges(IListIRange, Boolean) | Updates IOutlineRange collection from given list of ranges.
Public method | ShouldSerializeImageSize | Indicates whether the ImageSize property should be persisted.
Public method | ShouldSerializeOutlineColor | Indicates whether the OutlineColor property should be persisted.
Public method | ShouldSerializeOutlineOptions | Indicates whether the OutlineOptions property should be persisted.
Public method | ToggleOutlining | Toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOutlining(IListIRange, IOutlineRange) | Toggles expanded state for given IOutlineRange collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnOutline | Removes all outlined sections from outline collection.
Public method | UnOutline(Point) | Removes outlined section at the specific position.
Public method | UnOutline(Int32) | Removes all outline sections containing the given line.
Public method | UnOutlineText | Removes all outline section from outline collection.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.Assign Method

OutliningAssign Method
Copies the contents from another IOutlining object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IOutlining source
)
Public Overridable Sub Assign (
    source As IOutlining
)
public:
virtual void Assign(
    IOutlining^ source
)
abstract Assign :
        source : IOutlining -> unit
override Assign :
        source : IOutlining -> unit

Parameters

source
Type: Alternet.EditorIOutlining
Specifies IOutlining to assign.

Implements

IOutliningAssign(IOutlining)
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.BeginUpdate Method

OutliningBeginUpdate Method
Prevents outline list updating until calling EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of outline list updating locks.
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.CanCollapse Method

OutliningCanCollapse Method
Returns boolean value indicating that outline section at given line can be collapsed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanCollapse(
    int line
)
Public Overridable Function CanCollapse (
    line As Integer
) As Boolean
public:
virtual bool CanCollapse(
    int line
)
abstract CanCollapse :
        line : int -> bool
override CanCollapse :
        line : int -> bool

Parameters

line
Type: SystemInt32

Return Value

Type: Boolean
True if section can be collapsed; otherwise false.

Implements

ICollapsableCanCollapse(Int32)
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.CanExpand Method

OutliningCanExpand Method
Overload List
 | Name | Description
Public method | CanExpand(Int32) | Returns boolean value indicating that outline section at given line can be expanded.
Public method | CanExpand(IOutlineRange) | Returns boolean value indicating that given outline section can be expanded.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.CanExpand Method (Int32)

OutliningCanExpand Method (Int32)
Returns boolean value indicating that outline section at given line can be expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanExpand(
    int line
)
Public Overridable Function CanExpand (
    line As Integer
) As Boolean
public:
virtual bool CanExpand(
    int line
)
abstract CanExpand :
        line : int -> bool
override CanExpand :
        line : int -> bool

Parameters

line
Type: SystemInt32

Return Value

Type: Boolean
True if section can be expanded; otherwise false.

Implements

ICollapsableCanExpand(Int32)
See Also

Reference

Outlining Class
CanExpand Overload
Alternet.Editor Namespace


Outlining.CanExpand Method (IOutlineRange)

OutliningCanExpand Method (IOutlineRange)
Returns boolean value indicating that given outline section can be expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanExpand(
    IOutlineRange range
)
Public Overridable Function CanExpand (
    range As IOutlineRange
) As Boolean
public:
virtual bool CanExpand(
    IOutlineRange^ range
)
abstract CanExpand :
        range : IOutlineRange -> bool
override CanExpand :
        range : IOutlineRange -> bool

Parameters

range
Type: Alternet.SyntaxIOutlineRange
Specifies outline range.

Return Value

Type: Boolean
True if section can be expanded; otherwise false.

Implements

ICollapsableCanExpand(IOutlineRange)
See Also

Reference

Outlining Class
CanExpand Overload
Alternet.Editor Namespace


Outlining.Collapse Method

OutliningCollapse Method
Collapses the specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Collapse(
    int index
)
Public Overridable Sub Collapse (
    index As Integer
)
public:
virtual void Collapse(
    int index
)
abstract Collapse :
        index : int -> unit
override Collapse :
        index : int -> unit

Parameters

index
Type: SystemInt32
The index of the line to collapse.

Implements

ICollapsableCollapse(Int32)
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.CollapseToDefinitions Method

OutliningCollapseToDefinitions Method
Collapses and expands some outline section to get a quick overall view of the content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CollapseToDefinitions()
Public Overridable Sub CollapseToDefinitions
public:
virtual void CollapseToDefinitions()
abstract CollapseToDefinitions : unit -> unit
override CollapseToDefinitions : unit -> unit

Implements

ICollapsableCollapseToDefinitions
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.EndUpdate Method

OutliningEndUpdate Method
Re-enables outline list updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of outline list updating locks.
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.EnsureExpanded Method

OutliningEnsureExpanded Method
Overload List
 | Name | Description
Public method | EnsureExpanded(Point) | Makes all outline sections containing specified position expanded.
Public method | EnsureExpanded(Int32) | Makes all outline sections containing specified line expanded.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.EnsureExpanded Method (Point)

OutliningEnsureExpanded Method (Point)
Makes all outline sections containing specified position expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EnsureExpanded(
    Point position
)
Public Overridable Sub EnsureExpanded (
    position As Point
)
public:
virtual void EnsureExpanded(
    Point position
)
abstract EnsureExpanded :
        position : Point -> unit
override EnsureExpanded :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position in the text.

Implements

ICollapsableEnsureExpanded(Point)
See Also

Reference

Outlining Class
EnsureExpanded Overload
Alternet.Editor Namespace


Outlining.EnsureExpanded Method (Int32)

OutliningEnsureExpanded Method (Int32)
Makes all outline sections containing specified line expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EnsureExpanded(
    int index
)
Public Overridable Sub EnsureExpanded (
    index As Integer
)
public:
virtual void EnsureExpanded(
    int index
)
abstract EnsureExpanded :
        index : int -> unit
override EnsureExpanded :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies position of the line in the text.

Implements

ICollapsableEnsureExpanded(Int32)
See Also

Reference

Outlining Class
EnsureExpanded Overload
Alternet.Editor Namespace


Outlining.Expand Method

OutliningExpand Method
Expands outline section at the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Expand(
    int index
)
Public Overridable Sub Expand (
    index As Integer
)
public:
virtual void Expand(
    int index
)
abstract Expand :
        index : int -> unit
override Expand :
        index : int -> unit

Parameters

index
Type: SystemInt32
The index of the line to expand.

Implements

ICollapsableExpand(Int32)
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.FullCollapse Method

OutliningFullCollapse Method
Overload List
 | Name | Description
Public method | FullCollapse | When implemented by a class, collapses all outlining sections.
Public method | FullCollapse(IListIRange) | Collapses all sections objects specified by Ranges parameter.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.FullCollapse Method

OutliningFullCollapse Method
When implemented by a class, collapses all outlining sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FullCollapse()
Public Overridable Sub FullCollapse
public:
virtual void FullCollapse()
abstract FullCollapse : unit -> unit
override FullCollapse : unit -> unit

Implements

ICollapsableFullCollapse
See Also

Reference

Outlining Class
FullCollapse Overload
Alternet.Editor Namespace


Outlining.FullCollapse Method (IList(IRange))

OutliningFullCollapse Method (IListIRange)
Collapses all sections objects specified by Ranges parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FullCollapse(
    IList<IRange> ranges
)
Public Overridable Sub FullCollapse (
    ranges As IList(Of IRange)
)
public:
virtual void FullCollapse(
    IList<IRange^>^ ranges
)
abstract FullCollapse :
        ranges : IList<IRange> -> unit
override FullCollapse :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies IOutlineRange collection to collapse.

Implements

ICollapsableFullCollapse(IListIRange)
See Also

Reference

Outlining Class
FullCollapse Overload
Alternet.Editor Namespace


Outlining.FullExpand Method

OutliningFullExpand Method
Overload List
 | Name | Description
Public method | FullExpand | Expands all outlining sections.
Public method | FullExpand(IListIRange) | Expands all outline sections specified by Ranges parameter.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.FullExpand Method

OutliningFullExpand Method
Expands all outlining sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FullExpand()
Public Overridable Sub FullExpand
public:
virtual void FullExpand()
abstract FullExpand : unit -> unit
override FullExpand : unit -> unit

Implements

ICollapsableFullExpand
See Also

Reference

Outlining Class
FullExpand Overload
Alternet.Editor Namespace


Outlining.FullExpand Method (IList(IRange))

OutliningFullExpand Method (IListIRange)
Expands all outline sections specified by Ranges parameter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FullExpand(
    IList<IRange> ranges
)
Public Overridable Sub FullExpand (
    ranges As IList(Of IRange)
)
public:
virtual void FullExpand(
    IList<IRange^>^ ranges
)
abstract FullExpand :
        ranges : IList<IRange> -> unit
override FullExpand :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies IOutlineRange collection to expand.

Implements

ICollapsableFullExpand(IListIRange)
See Also

Reference

Outlining Class
FullExpand Overload
Alternet.Editor Namespace


Outlining.GetOutlineHint Method

OutliningGetOutlineHint Method
Returns string that appears in the hint window when mouse pointer is over the outline button.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetOutlineHint(
    IOutlineRange range
)
Public Overridable Function GetOutlineHint (
    range As IOutlineRange
) As String
public:
virtual String^ GetOutlineHint(
    IOutlineRange^ range
)
abstract GetOutlineHint :
        range : IOutlineRange -> string
override GetOutlineHint :
        range : IOutlineRange -> string

Parameters

range
Type: Alternet.SyntaxIOutlineRange
Specifies the IOutlineRange object holding the hint.

Return Value

Type: String
Hint string.

Implements

ICollapsableGetOutlineHint(IOutlineRange)
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.GetOutlineRange Method

OutliningGetOutlineRange Method
Overload List
 | Name | Description
Public method | GetOutlineRange(Point) | Returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position.
Public method | GetOutlineRange(Int32) | Returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.GetOutlineRange Method (Point)

OutliningGetOutlineRange Method (Point)
Returns outline section, which represents text substituting outlined section and level of outline nesting at the specific position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange GetOutlineRange(
    Point position
)
Public Overridable Function GetOutlineRange (
    position As Point
) As IOutlineRange
public:
virtual IOutlineRange^ GetOutlineRange(
    Point position
)
abstract GetOutlineRange :
        position : Point -> IOutlineRange
override GetOutlineRange :
        position : Point -> IOutlineRange

Parameters

position
Type: System.DrawingPoint
Specifies position in the text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableGetOutlineRange(Point)
See Also

Reference

Outlining Class
GetOutlineRange Overload
Alternet.Editor Namespace


Outlining.GetOutlineRange Method (Int32)

OutliningGetOutlineRange Method (Int32)
Returns outline section, which represents text substituting outlined section and level of outline nesting at the specific line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange GetOutlineRange(
    int index
)
Public Overridable Function GetOutlineRange (
    index As Integer
) As IOutlineRange
public:
virtual IOutlineRange^ GetOutlineRange(
    int index
)
abstract GetOutlineRange :
        index : int -> IOutlineRange
override GetOutlineRange :
        index : int -> IOutlineRange

Parameters

index
Type: SystemInt32
Index of line in the text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableGetOutlineRange(Int32)
See Also

Reference

Outlining Class
GetOutlineRange Overload
Alternet.Editor Namespace


Outlining.GetOutlineRanges Method

OutliningGetOutlineRanges Method
Overload List
 | Name | Description
Public method | GetOutlineRanges(IListIRange) | Fills list specified by ranges parameter with all existing outline sections.
Public method | GetOutlineRanges(IListIRange, Point) | Fills list specified by ranges parameter with all outline sections containing specific position.
Public method | GetOutlineRanges(IListIRange, Int32) | Fills list specified by ranges parameter with all outline sections containing specific line.
Public method | GetOutlineRanges(IListIRange, Point, Point) | Fills list specified by ranges parameter with all outline sections containing specific range.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.GetOutlineRanges Method (IList(IRange))

OutliningGetOutlineRanges Method (IListIRange)
Fills list specified by ranges parameter with all existing outline sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetOutlineRanges(
    IList<IRange> ranges
)
Public Overridable Function GetOutlineRanges (
    ranges As IList(Of IRange)
) As Integer
public:
virtual int GetOutlineRanges(
    IList<IRange^>^ ranges
)
abstract GetOutlineRanges :
        ranges : IList<IRange> -> int
override GetOutlineRanges :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.

Return Value

Type: Int32
Number of elements in the ranges collection.

Implements

ICollapsableGetOutlineRanges(IListIRange)
See Also

Reference

Outlining Class
GetOutlineRanges Overload
Alternet.Editor Namespace


Outlining.GetOutlineRanges Method (IList(IRange), Point)

OutliningGetOutlineRanges Method (IListIRange, Point)
Fills list specified by ranges parameter with all outline sections containing specific position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetOutlineRanges(
    IList<IRange> ranges,
    Point position
)
Public Overridable Function GetOutlineRanges (
    ranges As IList(Of IRange),
    position As Point
) As Integer
public:
virtual int GetOutlineRanges(
    IList<IRange^>^ ranges,
    Point position
)
abstract GetOutlineRanges :
        ranges : IList<IRange> *
        position : Point -> int
override GetOutlineRanges :
        ranges : IList<IRange> *
        position : Point -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
position
Type: System.DrawingPoint
Specifies position in the text.

Return Value

Type: Int32
Number of elements in the ranges collection.

Implements

ICollapsableGetOutlineRanges(IListIRange, Point)
See Also

Reference

Outlining Class
GetOutlineRanges Overload
Alternet.Editor Namespace


Outlining.GetOutlineRanges Method (IList(IRange), Int32)

OutliningGetOutlineRanges Method (IListIRange, Int32)
Fills list specified by ranges parameter with all outline sections containing specific line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetOutlineRanges(
    IList<IRange> ranges,
    int index
)
Public Overridable Function GetOutlineRanges (
    ranges As IList(Of IRange),
    index As Integer
) As Integer
public:
virtual int GetOutlineRanges(
    IList<IRange^>^ ranges,
    int index
)
abstract GetOutlineRanges :
        ranges : IList<IRange> *
        index : int -> int
override GetOutlineRanges :
        ranges : IList<IRange> *
        index : int -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
index
Type: SystemInt32
Specifies index of line in text coordinates.

Return Value

Type: Int32
Number of elements in the ranges collection.

Implements

ICollapsableGetOutlineRanges(IListIRange, Int32)
See Also

Reference

Outlining Class
GetOutlineRanges Overload
Alternet.Editor Namespace


Outlining.GetOutlineRanges Method (IList(IRange), Point, Point)

OutliningGetOutlineRanges Method (IListIRange, Point, Point)
Fills list specified by ranges parameter with all outline sections containing specific range.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetOutlineRanges(
    IList<IRange> ranges,
    Point startPoint,
    Point endPoint
)
Public Overridable Function GetOutlineRanges (
    ranges As IList(Of IRange),
    startPoint As Point,
    endPoint As Point
) As Integer
public:
virtual int GetOutlineRanges(
    IList<IRange^>^ ranges,
    Point startPoint,
    Point endPoint
)
abstract GetOutlineRanges :
        ranges : IList<IRange> *
        startPoint : Point *
        endPoint : Point -> int
override GetOutlineRanges :
        ranges : IList<IRange> *
        startPoint : Point *
        endPoint : Point -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies list to fill.
startPoint
Type: System.DrawingPoint
Specifies start position in the text.
endPoint
Type: System.DrawingPoint
Specifies end position in the text.

Return Value

Type: Int32
Number of elements in the ranges collection.

Implements

ICollapsableGetOutlineRanges(IListIRange, Point, Point)
See Also

Reference

Outlining Class
GetOutlineRanges Overload
Alternet.Editor Namespace


Outlining.IsCollapsed Method

OutliningIsCollapsed Method
Indicates whether the outlined text at the specified line is collapsed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsCollapsed(
    int index
)
Public Overridable Function IsCollapsed (
    index As Integer
) As Boolean
public:
virtual bool IsCollapsed(
    int index
)
abstract IsCollapsed :
        index : int -> bool
override IsCollapsed :
        index : int -> bool

Parameters

index
Type: SystemInt32
The index of the line to test.

Return Value

Type: Boolean
True if collapsed; otherwise false.

Implements

ICollapsableIsCollapsed(Int32)
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.IsExpanded Method

OutliningIsExpanded Method
Indicates whether the outlined text at the specified line is expanded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsExpanded(
    int index
)
Public Overridable Function IsExpanded (
    index As Integer
) As Boolean
public:
virtual bool IsExpanded(
    int index
)
abstract IsExpanded :
        index : int -> bool
override IsExpanded :
        index : int -> bool

Parameters

index
Type: SystemInt32
The index of the line to test.

Return Value

Type: Boolean
True if expanded; otherwise false.

Implements

ICollapsableIsExpanded(Int32)
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.IsVisible Method

OutliningIsVisible Method
Overload List
 | Name | Description
Public method | IsVisible(Point) | Indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.
Public method | IsVisible(Int32) | Indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.IsVisible Method (Point)

OutliningIsVisible Method (Point)
Indicates whether the text at the specified position is visible, that is there is no collapsed outline section containing given position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsVisible(
    Point position
)
Public Overridable Function IsVisible (
    position As Point
) As Boolean
public:
virtual bool IsVisible(
    Point position
)
abstract IsVisible :
        position : Point -> bool
override IsVisible :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position in the text.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICollapsableIsVisible(Point)
See Also

Reference

Outlining Class
IsVisible Overload
Alternet.Editor Namespace


Outlining.IsVisible Method (Int32)

OutliningIsVisible Method (Int32)
Indicates whether the text at the specified line is visible, that is there is no collapsed outline section containing given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsVisible(
    int index
)
Public Overridable Function IsVisible (
    index As Integer
) As Boolean
public:
virtual bool IsVisible(
    int index
)
abstract IsVisible :
        index : int -> bool
override IsVisible :
        index : int -> bool

Parameters

index
Type: SystemInt32
Specifies index of line in the text.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICollapsableIsVisible(Int32)
See Also

Reference

Outlining Class
IsVisible Overload
Alternet.Editor Namespace


Outlining.Outline Method

OutliningOutline Method
Overload List
 | Name | Description
Public method | Outline(Point, Point) | Creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Int32, Int32) | Creates an outlining section based on specific scope within current outlined section.
Public method | Outline(Point, Point, Int32) | Creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Point, Point, String) | Creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32) | Creates an outlining section based on specific scope at the specific level of outline nesting.
Public method | Outline(Int32, Int32, String) | Creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.
Public method | Outline(Point, Point, Int32, String) | Creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Public method | Outline(Int32, Int32, Int32, String) | Creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.Outline Method (Point, Point)

OutliningOutline Method (Point, Point)
Creates an outlining section based on specific scope within current outlined section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    Point startPoint,
    Point endPoint
)
Public Overridable Function Outline (
    startPoint As Point,
    endPoint As Point
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint
)
abstract Outline :
        startPoint : Point *
        endPoint : Point -> IOutlineRange
override Outline :
        startPoint : Point *
        endPoint : Point -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableOutline(Point, Point)
See Also

Reference

Outlining Class
Outline Overload
Alternet.Editor Namespace


Outlining.Outline Method (Int32, Int32)

OutliningOutline Method (Int32, Int32)
Creates an outlining section based on specific scope within current outlined section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    int first,
    int last
)
Public Overridable Function Outline (
    first As Integer,
    last As Integer
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    int first,
    int last
)
abstract Outline :
        first : int *
        last : int -> IOutlineRange
override Outline :
        first : int *
        last : int -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableOutline(Int32, Int32)
See Also

Reference

Outlining Class
Outline Overload
Alternet.Editor Namespace


Outlining.Outline Method (Point, Point, Int32)

OutliningOutline Method (Point, Point, Int32)
Creates an outlining section based on specific scope at the specific level of outline nesting.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    Point startPoint,
    Point endPoint,
    int level
)
Public Overridable Function Outline (
    startPoint As Point,
    endPoint As Point,
    level As Integer
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint,
    int level
)
abstract Outline :
        startPoint : Point *
        endPoint : Point *
        level : int -> IOutlineRange
override Outline :
        startPoint : Point *
        endPoint : Point *
        level : int -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableOutline(Point, Point, Int32)
See Also

Reference

Outlining Class
Outline Overload
Alternet.Editor Namespace


Outlining.Outline Method (Point, Point, String)

OutliningOutline Method (Point, Point, String)
Creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    Point startPoint,
    Point endPoint,
    string outlineText
)
Public Overridable Function Outline (
    startPoint As Point,
    endPoint As Point,
    outlineText As String
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint,
    String^ outlineText
)
abstract Outline :
        startPoint : Point *
        endPoint : Point *
        outlineText : string -> IOutlineRange
override Outline :
        startPoint : Point *
        endPoint : Point *
        outlineText : string -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.
outlineText
Type: SystemString
Specifies text to substitute collapsed text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableOutline(Point, Point, String)
See Also

Reference

Outlining Class
Outline Overload
Alternet.Editor Namespace


Outlining.Outline Method (Int32, Int32, Int32)

OutliningOutline Method (Int32, Int32, Int32)
Creates an outlining section based on specific scope at the specific level of outline nesting.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    int first,
    int last,
    int level
)
Public Overridable Function Outline (
    first As Integer,
    last As Integer,
    level As Integer
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    int first,
    int last,
    int level
)
abstract Outline :
        first : int *
        last : int *
        level : int -> IOutlineRange
override Outline :
        first : int *
        last : int *
        level : int -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableOutline(Int32, Int32, Int32)
See Also

Reference

Outlining Class
Outline Overload
Alternet.Editor Namespace


Outlining.Outline Method (Int32, Int32, String)

OutliningOutline Method (Int32, Int32, String)
Creates an outlining section based on specific scope within current outlined section and with specific text substituting collapsed text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    int first,
    int last,
    string outlineText
)
Public Overridable Function Outline (
    first As Integer,
    last As Integer,
    outlineText As String
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    int first,
    int last,
    String^ outlineText
)
abstract Outline :
        first : int *
        last : int *
        outlineText : string -> IOutlineRange
override Outline :
        first : int *
        last : int *
        outlineText : string -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.
outlineText
Type: SystemString
Specifies first line of section to outline.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableOutline(Int32, Int32, String)
See Also

Reference

Outlining Class
Outline Overload
Alternet.Editor Namespace


Outlining.Outline Method (Point, Point, Int32, String)

OutliningOutline Method (Point, Point, Int32, String)
Creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    Point startPoint,
    Point endPoint,
    int level,
    string outlineText
)
Public Overridable Function Outline (
    startPoint As Point,
    endPoint As Point,
    level As Integer,
    outlineText As String
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    Point startPoint,
    Point endPoint,
    int level,
    String^ outlineText
)
abstract Outline :
        startPoint : Point *
        endPoint : Point *
        level : int *
        outlineText : string -> IOutlineRange
override Outline :
        startPoint : Point *
        endPoint : Point *
        level : int *
        outlineText : string -> IOutlineRange

Parameters

startPoint
Type: System.DrawingPoint
Specifies begin of section to outline.
endPoint
Type: System.DrawingPoint
Specifies end of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.
outlineText
Type: SystemString
Specifies text to substitute collapsed text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableOutline(Point, Point, Int32, String)
See Also

Reference

Outlining Class
Outline Overload
Alternet.Editor Namespace


Outlining.Outline Method (Int32, Int32, Int32, String)

OutliningOutline Method (Int32, Int32, Int32, String)
Creates an outlining section based on specific scope at specific level of outline nesting and with specific text substituting collapsed text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IOutlineRange Outline(
    int first,
    int last,
    int level,
    string outlineText
)
Public Overridable Function Outline (
    first As Integer,
    last As Integer,
    level As Integer,
    outlineText As String
) As IOutlineRange
public:
virtual IOutlineRange^ Outline(
    int first,
    int last,
    int level,
    String^ outlineText
)
abstract Outline :
        first : int *
        last : int *
        level : int *
        outlineText : string -> IOutlineRange
override Outline :
        first : int *
        last : int *
        level : int *
        outlineText : string -> IOutlineRange

Parameters

first
Type: SystemInt32
Specifies first line of section to outline.
last
Type: SystemInt32
Specifies last line of section to outline.
level
Type: SystemInt32
Specifies level of outline nesting for this section.
outlineText
Type: SystemString
Specifies text substituting collapsed text.

Return Value

Type: IOutlineRange
IOutlineRange object that represents outline section.

Implements

ICollapsableOutline(Int32, Int32, Int32, String)
See Also

Reference

Outlining Class
Outline Overload
Alternet.Editor Namespace


Outlining.OutlineText Method

OutliningOutlineText Method
Tries to perform lexical analysis of entire text to create outline sections based on results of this analysis.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OutlineText()
Public Overridable Sub OutlineText
public:
virtual void OutlineText()
abstract OutlineText : unit -> unit
override OutlineText : unit -> unit

Implements

IOutliningOutlineText
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.ResetAllowOutlining Method

OutliningResetAllowOutlining Method
Resets AllowOutlining to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAllowOutlining()
Public Overridable Sub ResetAllowOutlining
public:
virtual void ResetAllowOutlining()
abstract ResetAllowOutlining : unit -> unit
override ResetAllowOutlining : unit -> unit

Implements

ICollapsableResetAllowOutlining
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.ResetOutlineColor Method

OutliningResetOutlineColor Method
Resets OutlineColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOutlineColor()
Public Overridable Sub ResetOutlineColor
public:
virtual void ResetOutlineColor()
abstract ResetOutlineColor : unit -> unit
override ResetOutlineColor : unit -> unit

Implements

IOutliningResetOutlineColor
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.ResetOutlineOptions Method

OutliningResetOutlineOptions Method
Resets OutlineOptions to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOutlineOptions()
Public Overridable Sub ResetOutlineOptions
public:
virtual void ResetOutlineOptions()
abstract ResetOutlineOptions : unit -> unit
override ResetOutlineOptions : unit -> unit

Implements

ICollapsableResetOutlineOptions
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.SetOutlineRanges Method

OutliningSetOutlineRanges Method
Overload List
 | Name | Description
Public method | SetOutlineRanges(IListIRange) | Updates IOutlineRange collection from given list of ranges.
Public method | SetOutlineRanges(IListIRange, Boolean) | Updates IOutlineRange collection from given list of ranges.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.SetOutlineRanges Method (IList(IRange))

OutliningSetOutlineRanges Method (IListIRange)
Updates IOutlineRange collection from given list of ranges.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetOutlineRanges(
    IList<IRange> ranges
)
Public Overridable Sub SetOutlineRanges (
    ranges As IList(Of IRange)
)
public:
virtual void SetOutlineRanges(
    IList<IRange^>^ ranges
)
abstract SetOutlineRanges :
        ranges : IList<IRange> -> unit
override SetOutlineRanges :
        ranges : IList<IRange> -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies new IOutlineRange collection to set.

Implements

ICollapsableSetOutlineRanges(IListIRange)
See Also

Reference

Outlining Class
SetOutlineRanges Overload
Alternet.Editor Namespace


Outlining.SetOutlineRanges Method (IList(IRange), Boolean)

OutliningSetOutlineRanges Method (IListIRange, Boolean)
Updates IOutlineRange collection from given list of ranges.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetOutlineRanges(
    IList<IRange> ranges,
    bool preserveVisible
)
Public Overridable Sub SetOutlineRanges (
    ranges As IList(Of IRange),
    preserveVisible As Boolean
)
public:
virtual void SetOutlineRanges(
    IList<IRange^>^ ranges,
    bool preserveVisible
)
abstract SetOutlineRanges :
        ranges : IList<IRange> *
        preserveVisible : bool -> unit
override SetOutlineRanges :
        ranges : IList<IRange> *
        preserveVisible : bool -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies new IOutlineRange collection to set.
preserveVisible
Type: SystemBoolean
Indicates whether new ranges should preserve collapsed state of existing outline sections.

Implements

ICollapsableSetOutlineRanges(IListIRange, Boolean)
See Also

Reference

Outlining Class
SetOutlineRanges Overload
Alternet.Editor Namespace


Outlining.ShouldSerializeImageSize Method

OutliningShouldSerializeImageSize Method
Indicates whether the ImageSize property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeImageSize()
Public Function ShouldSerializeImageSize As Boolean
public:
bool ShouldSerializeImageSize()
member ShouldSerializeImageSize : unit -> bool

Return Value

Type: Boolean
True if ImageSize differs from its default value; otherwise false.
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.ShouldSerializeOutlineColor Method

OutliningShouldSerializeOutlineColor Method
Indicates whether the OutlineColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOutlineColor()
Public Function ShouldSerializeOutlineColor As Boolean
public:
bool ShouldSerializeOutlineColor()
member ShouldSerializeOutlineColor : unit -> bool

Return Value

Type: Boolean
True if OutlineColor differs from its default value; otherwise false.
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.ShouldSerializeOutlineOptions Method

OutliningShouldSerializeOutlineOptions Method
Indicates whether the OutlineOptions property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOutlineOptions()
Public Function ShouldSerializeOutlineOptions As Boolean
public:
bool ShouldSerializeOutlineOptions()
member ShouldSerializeOutlineOptions : unit -> bool

Return Value

Type: Boolean
True if OutlineOptions differs from its default value; otherwise false.
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.ToggleOutlining Method

OutliningToggleOutlining Method
Overload List
 | Name | Description
Public method | ToggleOutlining | Toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOutlining(IListIRange, IOutlineRange) | Toggles expanded state for given IOutlineRange collection.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.ToggleOutlining Method

OutliningToggleOutlining Method
Toggles expanded state for all IOutlineRange objects in outline collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleOutlining()
Public Overridable Sub ToggleOutlining
public:
virtual void ToggleOutlining()
abstract ToggleOutlining : unit -> unit
override ToggleOutlining : unit -> unit

Implements

ICollapsableToggleOutlining
See Also

Reference

Outlining Class
ToggleOutlining Overload
Alternet.Editor Namespace


Outlining.ToggleOutlining Method (IList(IRange), IOutlineRange)

OutliningToggleOutlining Method (IListIRange, IOutlineRange)
Toggles expanded state for given IOutlineRange collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleOutlining(
    IList<IRange> ranges,
    IOutlineRange range
)
Public Overridable Sub ToggleOutlining (
    ranges As IList(Of IRange),
    range As IOutlineRange
)
public:
virtual void ToggleOutlining(
    IList<IRange^>^ ranges,
    IOutlineRange^ range
)
abstract ToggleOutlining :
        ranges : IList<IRange> *
        range : IOutlineRange -> unit
override ToggleOutlining :
        ranges : IList<IRange> *
        range : IOutlineRange -> unit

Parameters

ranges
Type: System.Collections.GenericIListIRange
Specifies IOutlineRange collection to toggle.
range
Type: Alternet.SyntaxIOutlineRange
IOutlineRange object representing current outline section. The method expands or collapses ranges depending on collapsed state of the Range.

Implements

ICollapsableToggleOutlining(IListIRange, IOutlineRange)
See Also

Reference

Outlining Class
ToggleOutlining Overload
Alternet.Editor Namespace


Outlining.UnOutline Method

OutliningUnOutline Method
Overload List
 | Name | Description
Public method | UnOutline | Removes all outlined sections from outline collection.
Public method | UnOutline(Point) | Removes outlined section at the specific position.
Public method | UnOutline(Int32) | Removes all outline sections containing the given line.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.UnOutline Method

OutliningUnOutline Method
Removes all outlined sections from outline collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnOutline()
Public Overridable Sub UnOutline
public:
virtual void UnOutline()
abstract UnOutline : unit -> unit
override UnOutline : unit -> unit

Implements

ICollapsableUnOutline
See Also

Reference

Outlining Class
UnOutline Overload
Alternet.Editor Namespace


Outlining.UnOutline Method (Point)

OutliningUnOutline Method (Point)
Removes outlined section at the specific position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnOutline(
    Point position
)
Public Overridable Sub UnOutline (
    position As Point
)
public:
virtual void UnOutline(
    Point position
)
abstract UnOutline :
        position : Point -> unit
override UnOutline :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position in the text.

Implements

ICollapsableUnOutline(Point)
See Also

Reference

Outlining Class
UnOutline Overload
Alternet.Editor Namespace


Outlining.UnOutline Method (Int32)

OutliningUnOutline Method (Int32)
Removes all outline sections containing the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnOutline(
    int index
)
Public Overridable Sub UnOutline (
    index As Integer
)
public:
virtual void UnOutline(
    int index
)
abstract UnOutline :
        index : int -> unit
override UnOutline :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies line in the text.

Implements

ICollapsableUnOutline(Int32)
See Also

Reference

Outlining Class
UnOutline Overload
Alternet.Editor Namespace


Outlining.UnOutlineText Method

OutliningUnOutlineText Method
Removes all outline section from outline collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnOutlineText()
Public Overridable Sub UnOutlineText
public:
virtual void UnOutlineText()
abstract UnOutlineText : unit -> unit
override UnOutlineText : unit -> unit

Implements

IOutliningUnOutlineText
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining Properties

Outlining Properties

The Outlining type exposes the following members.

Properties
 | Name | Description
Public property | AllowOutlining | Gets or sets a value indicating whether outlining enabled.
Public property | CollapsedCount | Returns number of collapsed sections.
Public property | ImageSize | Gets or sets size of outlining image. When auto scaling enabled, measured in DIP.
Public property | ImageSizeInPixels | When implemented by a class, gets size of outlining image in pixels.
Public property | OutlineColor | Gets or sets color that is used to draw outline button.
Public property | OutlineOptions | Gets or sets outlining options.
Public property | UseRoundRect | Gets or sets a boolean value indicating whether outlining buttons should be drawn with rounded corners.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.AllowOutlining Property

OutliningAllowOutlining Property
Gets or sets a value indicating whether outlining enabled.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AllowOutlining { get; set; }
Public Overridable Property AllowOutlining As Boolean
    Get
    Set
public:
virtual property bool AllowOutlining {
    bool get ();
    void set (bool value);
}
abstract AllowOutlining : bool with get, set
override AllowOutlining : bool with get, set

Property Value

Type: Boolean

Implements

IOutliningAllowOutlining
ICollapsableAllowOutlining
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.CollapsedCount Property

OutliningCollapsedCount Property
Returns number of collapsed sections.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CollapsedCount { get; }
Public Overridable ReadOnly Property CollapsedCount As Integer
    Get
public:
virtual property int CollapsedCount {
    int get ();
}
abstract CollapsedCount : int with get
override CollapsedCount : int with get

Property Value

Type: Int32

Implements

ICollapsableCollapsedCount
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.ImageSize Property

OutliningImageSize Property
Gets or sets size of outlining image. When auto scaling enabled, measured in DIP.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ImageSize { get; set; }
Public Property ImageSize As Integer
    Get
    Set
public:
virtual property int ImageSize {
    int get () sealed;
    void set (int value) sealed;
}
abstract ImageSize : int with get, set
override ImageSize : int with get, set

Property Value

Type: Int32

Implements

IOutliningImageSize
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.ImageSizeInPixels Property

OutliningImageSizeInPixels Property
When implemented by a class, gets size of outlining image in pixels.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ImageSizeInPixels { get; }
Public ReadOnly Property ImageSizeInPixels As Integer
    Get
public:
virtual property int ImageSizeInPixels {
    int get () sealed;
}
abstract ImageSizeInPixels : int with get
override ImageSizeInPixels : int with get

Property Value

Type: Int32

Implements

IOutliningImageSizeInPixels
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.OutlineColor Property

OutliningOutlineColor Property
Gets or sets color that is used to draw outline button.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color OutlineColor { get; set; }
Public Overridable Property OutlineColor As Color
    Get
    Set
public:
virtual property Color OutlineColor {
    Color get ();
    void set (Color value);
}
abstract OutlineColor : Color with get, set
override OutlineColor : Color with get, set

Property Value

Type: Color

Implements

IOutliningOutlineColor
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.OutlineOptions Property

OutliningOutlineOptions Property
Gets or sets outlining options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual OutlineOptions OutlineOptions { get; set; }
Public Overridable Property OutlineOptions As OutlineOptions
    Get
    Set
public:
virtual property OutlineOptions OutlineOptions {
    OutlineOptions get ();
    void set (OutlineOptions value);
}
abstract OutlineOptions : OutlineOptions with get, set
override OutlineOptions : OutlineOptions with get, set

Property Value

Type: OutlineOptions

Implements

IOutliningOutlineOptions
ICollapsableOutlineOptions
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.UseRoundRect Property

OutliningUseRoundRect Property
Gets or sets a boolean value indicating whether outlining buttons should be drawn with rounded corners.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseRoundRect { get; set; }
Public Property UseRoundRect As Boolean
    Get
    Set
public:
virtual property bool UseRoundRect {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract UseRoundRect : bool with get, set
override UseRoundRect : bool with get, set

Property Value

Type: Boolean

Implements

IOutliningUseRoundRect
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining Events

Outlining Events

The Outlining type exposes the following members.

Events
 | Name | Description
Public event | Collapsing | Occurs when user attempts expand outline section.
Public event | Expanding | Occurs when user attempts expand outline section.
Top
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.Collapsing Event

OutliningCollapsing Event
Occurs when user attempts expand outline section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event OutlineEvent Collapsing
Public Event Collapsing As OutlineEvent
public:
virtual  event OutlineEvent^ Collapsing {
    void add (OutlineEvent^ value);
    void remove (OutlineEvent^ value);
}
abstract Collapsing : IEvent<OutlineEvent,
    OutlineEventArgs>
override Collapsing : IEvent<OutlineEvent,
    OutlineEventArgs>

Value

Type: Alternet.EditorOutlineEvent

Implements

ICollapsableCollapsing
See Also

Reference

Outlining Class
Alternet.Editor Namespace


Outlining.Expanding Event

OutliningExpanding Event
Occurs when user attempts expand outline section.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event OutlineEvent Expanding
Public Event Expanding As OutlineEvent
public:
virtual  event OutlineEvent^ Expanding {
    void add (OutlineEvent^ value);
    void remove (OutlineEvent^ value);
}
abstract Expanding : IEvent<OutlineEvent,
    OutlineEventArgs>
override Expanding : IEvent<OutlineEvent,
    OutlineEventArgs>

Value

Type: Alternet.EditorOutlineEvent

Implements

ICollapsableExpanding
See Also

Reference

Outlining Class
Alternet.Editor Namespace


PageHeader Class

PageHeader Class
Represents header/footer parts of the Editor page.
Inheritance Hierarchy
SystemObject
Alternet.EditorPageHeader

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PageHeader : IEditPageHeader, IUpdate,
    IDisposable
Public Class PageHeader
    Implements IEditPageHeader, IUpdate, IDisposable
public ref class PageHeader : IEditPageHeader,
    IUpdate, IDisposable
type PageHeader =
    class
        interface IEditPageHeader
        interface IUpdate
        interface IDisposable
    end

The PageHeader type exposes the following members.

Constructors
 | Name | Description
Public method | PageHeader | Initializes a new instance of PageHeader class with default settings.
Public method | PageHeader(IEditPage, ISyntaxEdit) | Initializes a new instance of PageHeader class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another IEditPageHeader object.
Public method | BeginUpdate | Prevents PageHeader updating until calling PageHeader.EndUpdate method.
Public method | DisableUpdate | Prevents PageHeader updating until calling PageHeader.EndUpdate method.
Public method | Dispose | Disposes this PageHeader and frees resources associated with it.
Public method | EnableUpdate | Re-enables PageHeader updating, that was turn of by calling PageHeader.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling PageHeader.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextToPaint | Replaces all tags in the given text by their values.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Paint | Draws page header/footer on the specified graphic surface.
Public method | ResetFont | Resets the PageHeader.Font to the default value.
Public method | ResetFontColor | Resets the PageHeader.FontColor to the default value.
Public method | ResetOffset | Resets the PageHeader.Offset to the default value.
Public method | ResetReverseOnEvenPages | Resets the PageHeader.ReverseOnEvenPages to the default value.
Public method | ShouldSerializeFont | Indicates whether the Font property should be persisted.
Public method | ShouldSerializeFontColor | Indicates whether the FontColor property should be persisted.
Public method | ShouldSerializeOffset | Indicates whether the Offset property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Invalidates the header.
Top
Properties
 | Name | Description
Public property | CenterText | Gets or sets a string that appears at the center of the header/footer area.
Public property | Font | Gets or sets font used to draw header/footer text.
Public property | FontColor | Gets or sets font color used to draw header/footer text.
Public property | LeftText | Gets or sets a string that appears at the left part of the header/footer area.
Public property | Offset | Gets or sets indentation of the primary text edge.
Public property | ReverseOnEvenPages | Gets or sets a value indicating whether the LeftText and RightText interchanging on even page.
Public property | RightText | Gets or sets a string that appears at the right part of the header/footer area.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | Visible | Gets or sets a value indicating whether the PageHeader is visible.
Top
Events
 | Name | Description
Public event | DrawHeader | Occurs when header or footer part of each page is drawing.
Top
See Also

Reference

Alternet.Editor Namespace


PageHeader Constructor

PageHeader Constructor
Overload List
 | Name | Description
Public method | PageHeader | Initializes a new instance of PageHeader class with default settings.
Public method | PageHeader(IEditPage, ISyntaxEdit) | Initializes a new instance of PageHeader class with specified owner.
Top
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader Constructor

PageHeader Constructor
Initializes a new instance of PageHeader class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageHeader()
Public Sub New
public:
PageHeader()
new : unit -> PageHeader
See Also

Reference

PageHeader Class
PageHeader Overload
Alternet.Editor Namespace


PageHeader Constructor (IEditPage, ISyntaxEdit)

PageHeader Constructor (IEditPage, ISyntaxEdit)
Initializes a new instance of PageHeader class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageHeader(
    IEditPage page,
    ISyntaxEdit owner
)
Public Sub New (
    page As IEditPage,
    owner As ISyntaxEdit
)
public:
PageHeader(
    IEditPage^ page,
    ISyntaxEdit^ owner
)
new :
        page : IEditPage *
        owner : ISyntaxEdit -> PageHeader

Parameters

page
Type: Alternet.EditorIEditPage
Specifies IEditPage that owns this new instance.
owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit container of page.
See Also

Reference

PageHeader Class
PageHeader Overload
Alternet.Editor Namespace


PageHeader Methods

PageHeader Methods

The PageHeader type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another IEditPageHeader object.
Public method | BeginUpdate | Prevents PageHeader updating until calling PageHeader.EndUpdate method.
Public method | DisableUpdate | Prevents PageHeader updating until calling PageHeader.EndUpdate method.
Public method | Dispose | Disposes this PageHeader and frees resources associated with it.
Public method | EnableUpdate | Re-enables PageHeader updating, that was turn of by calling PageHeader.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling PageHeader.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextToPaint | Replaces all tags in the given text by their values.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Paint | Draws page header/footer on the specified graphic surface.
Public method | ResetFont | Resets the PageHeader.Font to the default value.
Public method | ResetFontColor | Resets the PageHeader.FontColor to the default value.
Public method | ResetOffset | Resets the PageHeader.Offset to the default value.
Public method | ResetReverseOnEvenPages | Resets the PageHeader.ReverseOnEvenPages to the default value.
Public method | ShouldSerializeFont | Indicates whether the Font property should be persisted.
Public method | ShouldSerializeFontColor | Indicates whether the FontColor property should be persisted.
Public method | ShouldSerializeOffset | Indicates whether the Offset property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Invalidates the header.
Top
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.Assign Method

PageHeaderAssign Method
Copies the contents of another IEditPageHeader object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IEditPageHeader source
)
Public Overridable Sub Assign (
    source As IEditPageHeader
)
public:
virtual void Assign(
    IEditPageHeader^ source
)
abstract Assign :
        source : IEditPageHeader -> unit
override Assign :
        source : IEditPageHeader -> unit

Parameters

source
Type: Alternet.EditorIEditPageHeader
Specifies IEditPageHeader to assign.

Implements

IEditPageHeaderAssign(IEditPageHeader)
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.BeginUpdate Method

PageHeaderBeginUpdate Method
Prevents PageHeader updating until calling PageHeader.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of PageHeader updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.DisableUpdate Method

PageHeaderDisableUpdate Method
Prevents PageHeader updating until calling PageHeader.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.Dispose Method

PageHeaderDispose Method
Disposes this PageHeader and frees resources associated with it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.EnableUpdate Method

PageHeaderEnableUpdate Method
Re-enables PageHeader updating, that was turn of by calling PageHeader.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of PageHeader updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.EndUpdate Method

PageHeaderEndUpdate Method
Re-enables page updating, that was turn of by calling PageHeader.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of PageHeader updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.GetTextToPaint Method

PageHeaderGetTextToPaint Method
Replaces all tags in the given text by their values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTextToPaint(
    string text,
    int pageIndex,
    int pageCount
)
Public Overridable Function GetTextToPaint (
    text As String,
    pageIndex As Integer,
    pageCount As Integer
) As String
public:
virtual String^ GetTextToPaint(
    String^ text,
    int pageIndex,
    int pageCount
)
abstract GetTextToPaint :
        text : string *
        pageIndex : int *
        pageCount : int -> string
override GetTextToPaint :
        text : string *
        pageIndex : int *
        pageCount : int -> string

Parameters

text
Type: SystemString
Specifies text to format.
pageIndex
Type: SystemInt32
Specifies index of page.
pageCount
Type: SystemInt32
Specifies page count.

Return Value

Type: String
Formatted text.
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.Paint Method

PageHeaderPaint Method
Draws page header/footer on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Paint(
    IPainter painter,
    Rectangle rect,
    int pageIndex,
    int pageCount,
    bool pageNumbers
)
Public Overridable Sub Paint (
    painter As IPainter,
    rect As Rectangle,
    pageIndex As Integer,
    pageCount As Integer,
    pageNumbers As Boolean
)
public:
virtual void Paint(
    IPainter^ painter,
    Rectangle rect,
    int pageIndex,
    int pageCount,
    bool pageNumbers
)
abstract Paint :
        painter : IPainter *
        rect : Rectangle *
        pageIndex : int *
        pageCount : int *
        pageNumbers : bool -> unit
override Paint :
        painter : IPainter *
        rect : Rectangle *
        pageIndex : int *
        pageCount : int *
        pageNumbers : bool -> unit

Parameters

painter
Type: Alternet.CommonIPainter
Represents IPainter surface to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of header/footer to draw on.
pageIndex
Type: SystemInt32
Index of page which header/footer is drawing.
pageCount
Type: SystemInt32
Total number of pages.
pageNumbers
Type: SystemBoolean
Specifies whether header/footer should draw page number.

Implements

IEditPageHeaderPaint(IPainter, Rectangle, Int32, Int32, Boolean)
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.ResetFont Method

PageHeaderResetFont Method
Resets the PageHeader.Font to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetFont()
Public Overridable Sub ResetFont
public:
virtual void ResetFont()
abstract ResetFont : unit -> unit
override ResetFont : unit -> unit

Implements

IEditPageHeaderResetFont
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.ResetFontColor Method

PageHeaderResetFontColor Method
Resets the PageHeader.FontColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetFontColor()
Public Overridable Sub ResetFontColor
public:
virtual void ResetFontColor()
abstract ResetFontColor : unit -> unit
override ResetFontColor : unit -> unit

Implements

IEditPageHeaderResetFontColor
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.ResetOffset Method

PageHeaderResetOffset Method
Resets the PageHeader.Offset to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOffset()
Public Overridable Sub ResetOffset
public:
virtual void ResetOffset()
abstract ResetOffset : unit -> unit
override ResetOffset : unit -> unit

Implements

IEditPageHeaderResetOffset
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.ResetReverseOnEvenPages Method

PageHeaderResetReverseOnEvenPages Method
Resets the PageHeader.ReverseOnEvenPages to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetReverseOnEvenPages()
Public Overridable Sub ResetReverseOnEvenPages
public:
virtual void ResetReverseOnEvenPages()
abstract ResetReverseOnEvenPages : unit -> unit
override ResetReverseOnEvenPages : unit -> unit

Implements

IEditPageHeaderResetReverseOnEvenPages
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.ShouldSerializeFont Method

PageHeaderShouldSerializeFont Method
Indicates whether the Font property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeFont()
Public Function ShouldSerializeFont As Boolean
public:
bool ShouldSerializeFont()
member ShouldSerializeFont : unit -> bool

Return Value

Type: Boolean
True if Font differs from its default value; otherwise false.
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.ShouldSerializeFontColor Method

PageHeaderShouldSerializeFontColor Method
Indicates whether the FontColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeFontColor()
Public Function ShouldSerializeFontColor As Boolean
public:
bool ShouldSerializeFontColor()
member ShouldSerializeFontColor : unit -> bool

Return Value

Type: Boolean
True if FontColor differs from its default value; otherwise false.
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.ShouldSerializeOffset Method

PageHeaderShouldSerializeOffset Method
Indicates whether the Offset property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOffset()
Public Function ShouldSerializeOffset As Boolean
public:
bool ShouldSerializeOffset()
member ShouldSerializeOffset : unit -> bool

Return Value

Type: Boolean
True if Offset differs from its default value; otherwise false.
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.Update Method

PageHeaderUpdate Method
Invalidates the header.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader Properties

PageHeader Properties

The PageHeader type exposes the following members.

Properties
 | Name | Description
Public property | CenterText | Gets or sets a string that appears at the center of the header/footer area.
Public property | Font | Gets or sets font used to draw header/footer text.
Public property | FontColor | Gets or sets font color used to draw header/footer text.
Public property | LeftText | Gets or sets a string that appears at the left part of the header/footer area.
Public property | Offset | Gets or sets indentation of the primary text edge.
Public property | ReverseOnEvenPages | Gets or sets a value indicating whether the LeftText and RightText interchanging on even page.
Public property | RightText | Gets or sets a string that appears at the right part of the header/footer area.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | Visible | Gets or sets a value indicating whether the PageHeader is visible.
Top
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.CenterText Property

PageHeaderCenterText Property
Gets or sets a string that appears at the center of the header/footer area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string CenterText { get; set; }
Public Overridable Property CenterText As String
    Get
    Set
public:
virtual property String^ CenterText {
    String^ get ();
    void set (String^ value);
}
abstract CenterText : string with get, set
override CenterText : string with get, set

Property Value

Type: String

Implements

IEditPageHeaderCenterText
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.Font Property

PageHeaderFont Property
Gets or sets font used to draw header/footer text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Font Font { get; set; }
Public Overridable Property Font As Font
    Get
    Set
public:
virtual property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set
override Font : Font with get, set

Property Value

Type: Font

Implements

IEditPageHeaderFont
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.FontColor Property

PageHeaderFontColor Property
Gets or sets font color used to draw header/footer text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color FontColor { get; set; }
Public Overridable Property FontColor As Color
    Get
    Set
public:
virtual property Color FontColor {
    Color get ();
    void set (Color value);
}
abstract FontColor : Color with get, set
override FontColor : Color with get, set

Property Value

Type: Color

Implements

IEditPageHeaderFontColor
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.LeftText Property

PageHeaderLeftText Property
Gets or sets a string that appears at the left part of the header/footer area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string LeftText { get; set; }
Public Overridable Property LeftText As String
    Get
    Set
public:
virtual property String^ LeftText {
    String^ get ();
    void set (String^ value);
}
abstract LeftText : string with get, set
override LeftText : string with get, set

Property Value

Type: String

Implements

IEditPageHeaderLeftText
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.Offset Property

PageHeaderOffset Property
Gets or sets indentation of the primary text edge.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Offset { get; set; }
Public Overridable Property Offset As Point
    Get
    Set
public:
virtual property Point Offset {
    Point get ();
    void set (Point value);
}
abstract Offset : Point with get, set
override Offset : Point with get, set

Property Value

Type: Point

Implements

IEditPageHeaderOffset
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.ReverseOnEvenPages Property

PageHeaderReverseOnEvenPages Property
Gets or sets a value indicating whether the LeftText and RightText interchanging on even page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReverseOnEvenPages { get; set; }
Public Overridable Property ReverseOnEvenPages As Boolean
    Get
    Set
public:
virtual property bool ReverseOnEvenPages {
    bool get ();
    void set (bool value);
}
abstract ReverseOnEvenPages : bool with get, set
override ReverseOnEvenPages : bool with get, set

Property Value

Type: Boolean

Implements

IEditPageHeaderReverseOnEvenPages
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.RightText Property

PageHeaderRightText Property
Gets or sets a string that appears at the right part of the header/footer area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string RightText { get; set; }
Public Overridable Property RightText As String
    Get
    Set
public:
virtual property String^ RightText {
    String^ get ();
    void set (String^ value);
}
abstract RightText : string with get, set
override RightText : string with get, set

Property Value

Type: String

Implements

IEditPageHeaderRightText
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.UpdateCount Property

PageHeaderUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.Visible Property

PageHeaderVisible Property
Gets or sets a value indicating whether the PageHeader is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Visible { get; set; }
Public Overridable Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

IEditPageHeaderVisible
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader Events

PageHeader Events

The PageHeader type exposes the following members.

Events
 | Name | Description
Public event | DrawHeader | Occurs when header or footer part of each page is drawing.
Top
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageHeader.DrawHeader Event

PageHeaderDrawHeader Event
Occurs when header or footer part of each page is drawing.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event DrawHeaderEvent DrawHeader
Public Event DrawHeader As DrawHeaderEvent
public:
virtual  event DrawHeaderEvent^ DrawHeader {
    void add (DrawHeaderEvent^ value);
    void remove (DrawHeaderEvent^ value);
}
abstract DrawHeader : IEvent<DrawHeaderEvent,
    DrawHeaderEventArgs>
override DrawHeader : IEvent<DrawHeaderEvent,
    DrawHeaderEventArgs>

Value

Type: Alternet.EditorDrawHeaderEvent

Implements

IEditPageHeaderDrawHeader
See Also

Reference

PageHeader Class
Alternet.Editor Namespace


PageType Enumeration

PageType Enumeration
Specifies the way of viewing Edit control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PageType
Public Enumeration PageType
public enum class PageType
type PageType
Members
Member name | Value | Description
Normal | 0 | Specifies normal view.
PageBreaks | 1 | Specifies dotted line to be displayed between separate pages.
PageLayout | 2 | Specifies page layout mode, allowing to see how text will be positioned on the printed page.
See Also

Reference

Alternet.Editor Namespace


PositionChangedEventArgs Class

PositionChangedEventArgs Class
Provides data for the event that occurs when the position within the text part of the ITextSource is changed.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorPositionChangedEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PositionChangedEventArgs : EventArgs
Public Class PositionChangedEventArgs
    Inherits EventArgs
public ref class PositionChangedEventArgs : public EventArgs
type PositionChangedEventArgs =
    class
        inherit EventArgs
    end

The PositionChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PositionChangedEventArgs | Initializes a new instance of the PositionChangedEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DeltaX | Represents the horizontal displacement of the current position within the text of the ITextSource.
Public property | DeltaY | Represents the vertical displacement of the current position within the text of the ITextSource control.
Public property | Reason | Represents the reason of the position change, such as insert new symbol, delete symbol, navigate and so on.
Top
See Also

Reference

Alternet.Editor Namespace


PositionChangedEventArgs Constructor

PositionChangedEventArgs Constructor
Initializes a new instance of the PositionChangedEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PositionChangedEventArgs(
    UpdateReason reason,
    int deltaX,
    int deltaY
)
Public Sub New (
    reason As UpdateReason,
    deltaX As Integer,
    deltaY As Integer
)
public:
PositionChangedEventArgs(
    UpdateReason reason,
    int deltaX,
    int deltaY
)
new :
        reason : UpdateReason *
        deltaX : int *
        deltaY : int -> PositionChangedEventArgs

Parameters

reason
Type: Alternet.Editor.TextSourceUpdateReason
Reason of the position change.
deltaX
Type: SystemInt32
Horizontal displacement of the current position.
deltaY
Type: SystemInt32
Vertical displacement of the current position.
See Also

Reference

PositionChangedEventArgs Class
Alternet.Editor Namespace


PositionChangedEventArgs Methods

PositionChangedEventArgs Methods

The PositionChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PositionChangedEventArgs Class
Alternet.Editor Namespace


PositionChangedEventArgs Properties

PositionChangedEventArgs Properties

The PositionChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DeltaX | Represents the horizontal displacement of the current position within the text of the ITextSource.
Public property | DeltaY | Represents the vertical displacement of the current position within the text of the ITextSource control.
Public property | Reason | Represents the reason of the position change, such as insert new symbol, delete symbol, navigate and so on.
Top
See Also

Reference

PositionChangedEventArgs Class
Alternet.Editor Namespace


PositionChangedEventArgs.DeltaX Property

PositionChangedEventArgsDeltaX Property
Represents the horizontal displacement of the current position within the text of the ITextSource.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DeltaX { get; set; }
Public Property DeltaX As Integer
    Get
    Set
public:
property int DeltaX {
    int get ();
    void set (int value);
}
member DeltaX : int with get, set

Property Value

Type: Int32
See Also

Reference

PositionChangedEventArgs Class
Alternet.Editor Namespace


PositionChangedEventArgs.DeltaY Property

PositionChangedEventArgsDeltaY Property
Represents the vertical displacement of the current position within the text of the ITextSource control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DeltaY { get; set; }
Public Property DeltaY As Integer
    Get
    Set
public:
property int DeltaY {
    int get ();
    void set (int value);
}
member DeltaY : int with get, set

Property Value

Type: Int32
See Also

Reference

PositionChangedEventArgs Class
Alternet.Editor Namespace


PositionChangedEventArgs.Reason Property

PositionChangedEventArgsReason Property
Represents the reason of the position change, such as insert new symbol, delete symbol, navigate and so on.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UpdateReason Reason { get; set; }
Public Property Reason As UpdateReason
    Get
    Set
public:
property UpdateReason Reason {
    UpdateReason get ();
    void set (UpdateReason value);
}
member Reason : UpdateReason with get, set

Property Value

Type: UpdateReason
See Also

Reference

PositionChangedEventArgs Class
Alternet.Editor Namespace


Printing Class

Printing Class
Represents class designed to print, preview and execute print setup dialog for Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorPrinting

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Printing : IPrinting, IDisposable
Public Class Printing
    Implements IPrinting, IDisposable
public ref class Printing : IPrinting,
    IDisposable
type Printing =
    class
        interface IPrinting
        interface IDisposable
    end

The Printing type exposes the following members.

Constructors
 | Name | Description
Public method | Printing | Initializes a new instance of the Printing class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another IPrinting object.
Public method | Dispose | Disposes this Printing and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecutePageSetupDialog | Initializes and runs page setup dialog.
Public method | ExecutePageSetupDialog(IWin32Window) | Initializes and runs page setup dialog.
Public method | ExecutePrintDialog | Initializes and runs print dialog.
Public method | ExecutePrintDialog(IWin32Window) | Initializes and runs print dialog.
Public method | ExecutePrintOptionsDialog | Initializes and runs print options dialog.
Public method | ExecutePrintOptionsDialog(IWin32Window) | Initializes and runs print options dialog.
Public method | ExecutePrintPreviewDialog | Initializes and runs print preview dialog.
Public method | ExecutePrintPreviewDialog(IWin32Window) | Initializes and runs print preview dialog.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnCreatePrintEdit | Raises the CreatePrintEdit event.
Public method | OnFinalized | Raises the Finalized event.
Public method | OnInitialized | Raises the Initialized event.
Public method | Print | Sends Printing.PrintDocument content to the printer.
Public method | ResetAllowedOptions | Resets AllowedOptions to the default value.
Public method | ResetOptions | Resets Options to the default value.
Public method | ShouldSerializeAllowedOptions | Indicates whether the AllowedOptions property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AllowedOptions | Gets or sets Print Options dialog options, that can be changed by user.
Public property | Footer | Represents IEditPageHeader object to draw footer of printing document.
Public property | Header | Represents IEditPageHeader object to draw header of printing document.
Public property | Options | Gets or sets PrintOptions that determines printing behaviour.
Public property | PageSetupDialog | Represents a dialog box that allows users to manipulate page settings, including margins and paper orientation.
Public property | PrintDialog | Represents a dialog box that allows users to select a printer and choose which portions of the document to print.
Public property | PrintDocument | Represents document to print, print preview or setup.
Public property | PrintEdit | Provides an access to internal ISyntaxEdit object being printed.
Public property | PrinterSettings | Represents settings for print document.
Public property | PrintOptionsDialog | Provides a dialog box that allows users to manipulate print settings.
Public property | PrintPreviewDialog | Represents a dialog box that allows user to preview print document.
Public property | ShowPrintOptionsDialog | Gets or sets a value indicating whether Print Options Dialog can be opened.
Top
Events
 | Name | Description
Public event | CreatePrintEdit | Occurs when Edit control to print is about to be created.
Public event | Finalized | Occurs when printing is done.
Public event | Initialized | Occurs when document to print is initialized.
Top
See Also

Reference

Alternet.Editor Namespace


Printing Constructor

Printing Constructor
Initializes a new instance of the Printing class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Printing(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
Printing(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> Printing

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing Methods

Printing Methods

The Printing type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another IPrinting object.
Public method | Dispose | Disposes this Printing and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecutePageSetupDialog | Initializes and runs page setup dialog.
Public method | ExecutePageSetupDialog(IWin32Window) | Initializes and runs page setup dialog.
Public method | ExecutePrintDialog | Initializes and runs print dialog.
Public method | ExecutePrintDialog(IWin32Window) | Initializes and runs print dialog.
Public method | ExecutePrintOptionsDialog | Initializes and runs print options dialog.
Public method | ExecutePrintOptionsDialog(IWin32Window) | Initializes and runs print options dialog.
Public method | ExecutePrintPreviewDialog | Initializes and runs print preview dialog.
Public method | ExecutePrintPreviewDialog(IWin32Window) | Initializes and runs print preview dialog.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnCreatePrintEdit | Raises the CreatePrintEdit event.
Public method | OnFinalized | Raises the Finalized event.
Public method | OnInitialized | Raises the Initialized event.
Public method | Print | Sends Printing.PrintDocument content to the printer.
Public method | ResetAllowedOptions | Resets AllowedOptions to the default value.
Public method | ResetOptions | Resets Options to the default value.
Public method | ShouldSerializeAllowedOptions | Indicates whether the AllowedOptions property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.Assign Method

PrintingAssign Method
Copies the contents of another IPrinting object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IPrinting source
)
Public Overridable Sub Assign (
    source As IPrinting
)
public:
virtual void Assign(
    IPrinting^ source
)
abstract Assign :
        source : IPrinting -> unit
override Assign :
        source : IPrinting -> unit

Parameters

source
Type: Alternet.EditorIPrinting
Specifies IPrinting to assign.

Implements

IPrintingAssign(IPrinting)
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.Dispose Method

PrintingDispose Method
Disposes this Printing and frees resources associated with it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ExecutePageSetupDialog Method

PrintingExecutePageSetupDialog Method
Overload List
 | Name | Description
Public method | ExecutePageSetupDialog | Initializes and runs page setup dialog.
Public method | ExecutePageSetupDialog(IWin32Window) | Initializes and runs page setup dialog.
Top
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ExecutePageSetupDialog Method

PrintingExecutePageSetupDialog Method
Initializes and runs page setup dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult ExecutePageSetupDialog()
Public Overridable Function ExecutePageSetupDialog As DialogResult
public:
virtual DialogResult ExecutePageSetupDialog()
abstract ExecutePageSetupDialog : unit -> DialogResult
override ExecutePageSetupDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IPrintingExecutePageSetupDialog
See Also

Reference

Printing Class
ExecutePageSetupDialog Overload
Alternet.Editor Namespace


Printing.ExecutePageSetupDialog Method (IWin32Window)

PrintingExecutePageSetupDialog Method (IWin32Window)
Initializes and runs page setup dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult ExecutePageSetupDialog(
    IWin32Window ownerwnd
)
Public Overridable Function ExecutePageSetupDialog (
    ownerwnd As IWin32Window
) As DialogResult
public:
virtual DialogResult ExecutePageSetupDialog(
    IWin32Window^ ownerwnd
)
abstract ExecutePageSetupDialog :
        ownerwnd : IWin32Window -> DialogResult
override ExecutePageSetupDialog :
        ownerwnd : IWin32Window -> DialogResult

Parameters

ownerwnd
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IPrintingExecutePageSetupDialog(IWin32Window)
See Also

Reference

Printing Class
ExecutePageSetupDialog Overload
Alternet.Editor Namespace


Printing.ExecutePrintDialog Method

PrintingExecutePrintDialog Method
Overload List
 | Name | Description
Public method | ExecutePrintDialog | Initializes and runs print dialog.
Public method | ExecutePrintDialog(IWin32Window) | Initializes and runs print dialog.
Top
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ExecutePrintDialog Method

PrintingExecutePrintDialog Method
Initializes and runs print dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult ExecutePrintDialog()
Public Overridable Function ExecutePrintDialog As DialogResult
public:
virtual DialogResult ExecutePrintDialog()
abstract ExecutePrintDialog : unit -> DialogResult
override ExecutePrintDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IPrintingExecutePrintDialog
See Also

Reference

Printing Class
ExecutePrintDialog Overload
Alternet.Editor Namespace


Printing.ExecutePrintDialog Method (IWin32Window)

PrintingExecutePrintDialog Method (IWin32Window)
Initializes and runs print dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult ExecutePrintDialog(
    IWin32Window ownerwnd
)
Public Overridable Function ExecutePrintDialog (
    ownerwnd As IWin32Window
) As DialogResult
public:
virtual DialogResult ExecutePrintDialog(
    IWin32Window^ ownerwnd
)
abstract ExecutePrintDialog :
        ownerwnd : IWin32Window -> DialogResult
override ExecutePrintDialog :
        ownerwnd : IWin32Window -> DialogResult

Parameters

ownerwnd
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IPrintingExecutePrintDialog(IWin32Window)
See Also

Reference

Printing Class
ExecutePrintDialog Overload
Alternet.Editor Namespace


Printing.ExecutePrintOptionsDialog Method

PrintingExecutePrintOptionsDialog Method
Overload List
 | Name | Description
Public method | ExecutePrintOptionsDialog | Initializes and runs print options dialog.
Public method | ExecutePrintOptionsDialog(IWin32Window) | Initializes and runs print options dialog.
Top
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ExecutePrintOptionsDialog Method

PrintingExecutePrintOptionsDialog Method
Initializes and runs print options dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult ExecutePrintOptionsDialog()
Public Overridable Function ExecutePrintOptionsDialog As DialogResult
public:
virtual DialogResult ExecutePrintOptionsDialog()
abstract ExecutePrintOptionsDialog : unit -> DialogResult
override ExecutePrintOptionsDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IPrintingExecutePrintOptionsDialog
See Also

Reference

Printing Class
ExecutePrintOptionsDialog Overload
Alternet.Editor Namespace


Printing.ExecutePrintOptionsDialog Method (IWin32Window)

PrintingExecutePrintOptionsDialog Method (IWin32Window)
Initializes and runs print options dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult ExecutePrintOptionsDialog(
    IWin32Window ownerwnd
)
Public Overridable Function ExecutePrintOptionsDialog (
    ownerwnd As IWin32Window
) As DialogResult
public:
virtual DialogResult ExecutePrintOptionsDialog(
    IWin32Window^ ownerwnd
)
abstract ExecutePrintOptionsDialog :
        ownerwnd : IWin32Window -> DialogResult
override ExecutePrintOptionsDialog :
        ownerwnd : IWin32Window -> DialogResult

Parameters

ownerwnd
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IPrintingExecutePrintOptionsDialog(IWin32Window)
See Also

Reference

Printing Class
ExecutePrintOptionsDialog Overload
Alternet.Editor Namespace


Printing.ExecutePrintPreviewDialog Method

PrintingExecutePrintPreviewDialog Method
Overload List
 | Name | Description
Public method | ExecutePrintPreviewDialog | Initializes and runs print preview dialog.
Public method | ExecutePrintPreviewDialog(IWin32Window) | Initializes and runs print preview dialog.
Top
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ExecutePrintPreviewDialog Method

PrintingExecutePrintPreviewDialog Method
Initializes and runs print preview dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult ExecutePrintPreviewDialog()
Public Overridable Function ExecutePrintPreviewDialog As DialogResult
public:
virtual DialogResult ExecutePrintPreviewDialog()
abstract ExecutePrintPreviewDialog : unit -> DialogResult
override ExecutePrintPreviewDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IPrintingExecutePrintPreviewDialog
See Also

Reference

Printing Class
ExecutePrintPreviewDialog Overload
Alternet.Editor Namespace


Printing.ExecutePrintPreviewDialog Method (IWin32Window)

PrintingExecutePrintPreviewDialog Method (IWin32Window)
Initializes and runs print preview dialog.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult ExecutePrintPreviewDialog(
    IWin32Window ownerwnd
)
Public Overridable Function ExecutePrintPreviewDialog (
    ownerwnd As IWin32Window
) As DialogResult
public:
virtual DialogResult ExecutePrintPreviewDialog(
    IWin32Window^ ownerwnd
)
abstract ExecutePrintPreviewDialog :
        ownerwnd : IWin32Window -> DialogResult
override ExecutePrintPreviewDialog :
        ownerwnd : IWin32Window -> DialogResult

Parameters

ownerwnd
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IPrintingExecutePrintPreviewDialog(IWin32Window)
See Also

Reference

Printing Class
ExecutePrintPreviewDialog Overload
Alternet.Editor Namespace


Printing.OnCreatePrintEdit Method

PrintingOnCreatePrintEdit Method
Raises the CreatePrintEdit event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxEdit OnCreatePrintEdit()
Public Overridable Function OnCreatePrintEdit As ISyntaxEdit
public:
virtual ISyntaxEdit^ OnCreatePrintEdit()
abstract OnCreatePrintEdit : unit -> ISyntaxEdit
override OnCreatePrintEdit : unit -> ISyntaxEdit

Return Value

Type: ISyntaxEdit
SyntaxEdit that is created to print.

Implements

IPrintingOnCreatePrintEdit
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.OnFinalized Method

PrintingOnFinalized Method
Raises the Finalized event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnFinalized()
Public Overridable Sub OnFinalized
public:
virtual void OnFinalized()
abstract OnFinalized : unit -> unit
override OnFinalized : unit -> unit

Implements

IPrintingOnFinalized
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.OnInitialized Method

PrintingOnInitialized Method
Raises the Initialized event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnInitialized()
Public Overridable Sub OnInitialized
public:
virtual void OnInitialized()
abstract OnInitialized : unit -> unit
override OnInitialized : unit -> unit

Implements

IPrintingOnInitialized
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.Print Method

PrintingPrint Method
Sends Printing.PrintDocument content to the printer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Print()
Public Overridable Sub Print
public:
virtual void Print()
abstract Print : unit -> unit
override Print : unit -> unit

Implements

IPrintingPrint
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ResetAllowedOptions Method

PrintingResetAllowedOptions Method
Resets AllowedOptions to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAllowedOptions()
Public Overridable Sub ResetAllowedOptions
public:
virtual void ResetAllowedOptions()
abstract ResetAllowedOptions : unit -> unit
override ResetAllowedOptions : unit -> unit

Implements

IPrintingResetAllowedOptions
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ResetOptions Method

PrintingResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOptions()
Public Overridable Sub ResetOptions
public:
virtual void ResetOptions()
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

IPrintingResetOptions
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ShouldSerializeAllowedOptions Method

PrintingShouldSerializeAllowedOptions Method
Indicates whether the AllowedOptions property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeAllowedOptions()
Public Function ShouldSerializeAllowedOptions As Boolean
public:
bool ShouldSerializeAllowedOptions()
member ShouldSerializeAllowedOptions : unit -> bool

Return Value

Type: Boolean
True if AllowedOptions differs from its default value; otherwise false.
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ShouldSerializeOptions Method

PrintingShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOptions()
Public Function ShouldSerializeOptions As Boolean
public:
bool ShouldSerializeOptions()
member ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing Properties

Printing Properties

The Printing type exposes the following members.

Properties
 | Name | Description
Public property | AllowedOptions | Gets or sets Print Options dialog options, that can be changed by user.
Public property | Footer | Represents IEditPageHeader object to draw footer of printing document.
Public property | Header | Represents IEditPageHeader object to draw header of printing document.
Public property | Options | Gets or sets PrintOptions that determines printing behaviour.
Public property | PageSetupDialog | Represents a dialog box that allows users to manipulate page settings, including margins and paper orientation.
Public property | PrintDialog | Represents a dialog box that allows users to select a printer and choose which portions of the document to print.
Public property | PrintDocument | Represents document to print, print preview or setup.
Public property | PrintEdit | Provides an access to internal ISyntaxEdit object being printed.
Public property | PrinterSettings | Represents settings for print document.
Public property | PrintOptionsDialog | Provides a dialog box that allows users to manipulate print settings.
Public property | PrintPreviewDialog | Represents a dialog box that allows user to preview print document.
Public property | ShowPrintOptionsDialog | Gets or sets a value indicating whether Print Options Dialog can be opened.
Top
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.AllowedOptions Property

PrintingAllowedOptions Property
Gets or sets Print Options dialog options, that can be changed by user.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PrintOptions AllowedOptions { get; set; }
Public Overridable Property AllowedOptions As PrintOptions
    Get
    Set
public:
virtual property PrintOptions AllowedOptions {
    PrintOptions get ();
    void set (PrintOptions value);
}
abstract AllowedOptions : PrintOptions with get, set
override AllowedOptions : PrintOptions with get, set

Property Value

Type: PrintOptions

Implements

IPrintingAllowedOptions
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.Footer Property

PrintingFooter Property
Represents IEditPageHeader object to draw footer of printing document.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPageHeader Footer { get; set; }
Public Overridable Property Footer As IEditPageHeader
    Get
    Set
public:
virtual property IEditPageHeader^ Footer {
    IEditPageHeader^ get ();
    void set (IEditPageHeader^ value);
}
abstract Footer : IEditPageHeader with get, set
override Footer : IEditPageHeader with get, set

Property Value

Type: IEditPageHeader

Implements

IPrintingFooter
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.Header Property

PrintingHeader Property
Represents IEditPageHeader object to draw header of printing document.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEditPageHeader Header { get; set; }
Public Overridable Property Header As IEditPageHeader
    Get
    Set
public:
virtual property IEditPageHeader^ Header {
    IEditPageHeader^ get ();
    void set (IEditPageHeader^ value);
}
abstract Header : IEditPageHeader with get, set
override Header : IEditPageHeader with get, set

Property Value

Type: IEditPageHeader

Implements

IPrintingHeader
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.Options Property

PrintingOptions Property
Gets or sets PrintOptions that determines printing behaviour.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PrintOptions Options { get; set; }
Public Overridable Property Options As PrintOptions
    Get
    Set
public:
virtual property PrintOptions Options {
    PrintOptions get ();
    void set (PrintOptions value);
}
abstract Options : PrintOptions with get, set
override Options : PrintOptions with get, set

Property Value

Type: PrintOptions

Implements

IPrintingOptions
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.PageSetupDialog Property

PrintingPageSetupDialog Property
Represents a dialog box that allows users to manipulate page settings, including margins and paper orientation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PageSetupDialog PageSetupDialog { get; }
Public Overridable ReadOnly Property PageSetupDialog As PageSetupDialog
    Get
public:
virtual property PageSetupDialog^ PageSetupDialog {
    PageSetupDialog^ get ();
}
abstract PageSetupDialog : PageSetupDialog with get
override PageSetupDialog : PageSetupDialog with get

Property Value

Type: PageSetupDialog

Implements

IPrintingPageSetupDialog
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.PrintDialog Property

PrintingPrintDialog Property
Represents a dialog box that allows users to select a printer and choose which portions of the document to print.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PrintDialog PrintDialog { get; }
Public Overridable ReadOnly Property PrintDialog As PrintDialog
    Get
public:
virtual property PrintDialog^ PrintDialog {
    PrintDialog^ get ();
}
abstract PrintDialog : PrintDialog with get
override PrintDialog : PrintDialog with get

Property Value

Type: PrintDialog

Implements

IPrintingPrintDialog
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.PrintDocument Property

PrintingPrintDocument Property
Represents document to print, print preview or setup.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PrintDocument PrintDocument { get; }
Public Overridable ReadOnly Property PrintDocument As PrintDocument
    Get
public:
virtual property PrintDocument^ PrintDocument {
    PrintDocument^ get ();
}
abstract PrintDocument : PrintDocument with get
override PrintDocument : PrintDocument with get

Property Value

Type: PrintDocument

Implements

IPrintingPrintDocument
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.PrintEdit Property

PrintingPrintEdit Property
Provides an access to internal ISyntaxEdit object being printed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISyntaxEdit PrintEdit { get; }
Public ReadOnly Property PrintEdit As ISyntaxEdit
    Get
public:
virtual property ISyntaxEdit^ PrintEdit {
    ISyntaxEdit^ get () sealed;
}
abstract PrintEdit : ISyntaxEdit with get
override PrintEdit : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit

Implements

IPrintingPrintEdit
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.PrinterSettings Property

PrintingPrinterSettings Property
Represents settings for print document.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PrinterSettings PrinterSettings { get; }
Public Overridable ReadOnly Property PrinterSettings As PrinterSettings
    Get
public:
virtual property PrinterSettings^ PrinterSettings {
    PrinterSettings^ get ();
}
abstract PrinterSettings : PrinterSettings with get
override PrinterSettings : PrinterSettings with get

Property Value

Type: PrinterSettings

Implements

IPrintingPrinterSettings
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.PrintOptionsDialog Property

PrintingPrintOptionsDialog Property
Provides a dialog box that allows users to manipulate print settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPrintOptionsDialog PrintOptionsDialog { get; set; }
Public Overridable Property PrintOptionsDialog As IPrintOptionsDialog
    Get
    Set
public:
virtual property IPrintOptionsDialog^ PrintOptionsDialog {
    IPrintOptionsDialog^ get ();
    void set (IPrintOptionsDialog^ value);
}
abstract PrintOptionsDialog : IPrintOptionsDialog with get, set
override PrintOptionsDialog : IPrintOptionsDialog with get, set

Property Value

Type: IPrintOptionsDialog

Implements

IPrintingPrintOptionsDialog
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.PrintPreviewDialog Property

PrintingPrintPreviewDialog Property
Represents a dialog box that allows user to preview print document.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PrintPreviewDialog PrintPreviewDialog { get; }
Public Overridable ReadOnly Property PrintPreviewDialog As PrintPreviewDialog
    Get
public:
virtual property PrintPreviewDialog^ PrintPreviewDialog {
    PrintPreviewDialog^ get ();
}
abstract PrintPreviewDialog : PrintPreviewDialog with get
override PrintPreviewDialog : PrintPreviewDialog with get

Property Value

Type: PrintPreviewDialog

Implements

IPrintingPrintPreviewDialog
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.ShowPrintOptionsDialog Property

PrintingShowPrintOptionsDialog Property
Gets or sets a value indicating whether Print Options Dialog can be opened.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowPrintOptionsDialog { get; set; }
Public Overridable Property ShowPrintOptionsDialog As Boolean
    Get
    Set
public:
virtual property bool ShowPrintOptionsDialog {
    bool get ();
    void set (bool value);
}
abstract ShowPrintOptionsDialog : bool with get, set
override ShowPrintOptionsDialog : bool with get, set

Property Value

Type: Boolean

Implements

IPrintingShowPrintOptionsDialog
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing Events

Printing Events

The Printing type exposes the following members.

Events
 | Name | Description
Public event | CreatePrintEdit | Occurs when Edit control to print is about to be created.
Public event | Finalized | Occurs when printing is done.
Public event | Initialized | Occurs when document to print is initialized.
Top
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.CreatePrintEdit Event

PrintingCreatePrintEdit Event
Occurs when Edit control to print is about to be created.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event CreatePrintEditEvent CreatePrintEdit
Public Event CreatePrintEdit As CreatePrintEditEvent
public:
virtual  event CreatePrintEditEvent^ CreatePrintEdit {
    void add (CreatePrintEditEvent^ value);
    void remove (CreatePrintEditEvent^ value);
}
abstract CreatePrintEdit : IEvent<CreatePrintEditEvent,
    CreatePrintEditEventArgs>
override CreatePrintEdit : IEvent<CreatePrintEditEvent,
    CreatePrintEditEventArgs>

Value

Type: Alternet.EditorCreatePrintEditEvent

Implements

IPrintingCreatePrintEdit
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.Finalized Event

PrintingFinalized Event
Occurs when printing is done.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Finalized
Public Event Finalized As EventHandler
public:
virtual  event EventHandler^ Finalized {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Finalized : IEvent<EventHandler,
    EventArgs>
override Finalized : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IPrintingFinalized
See Also

Reference

Printing Class
Alternet.Editor Namespace


Printing.Initialized Event

PrintingInitialized Event
Occurs when document to print is initialized.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Initialized
Public Event Initialized As EventHandler
public:
virtual  event EventHandler^ Initialized {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Initialized : IEvent<EventHandler,
    EventArgs>
override Initialized : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IPrintingInitialized
See Also

Reference

Printing Class
Alternet.Editor Namespace


PrintOptions Enumeration

PrintOptions Enumeration
Defines appearance of the printed page when sending Editor's content to the printer. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum PrintOptions
<FlagsAttribute>
Public Enumeration PrintOptions
[FlagsAttribute]
public enum class PrintOptions
[<FlagsAttribute>]
type PrintOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
LineNumbers | 1 | Specifies that document should print with line numbers.
PageNumbers | 2 | Specifies that document should print with page numbers.
WordWrap | 4 | Specifies that document should print with wrapping lines if necessary.
PrintSelection | 8 | Specifies that document should print only selected part of the text.
UseColors | 16 | Specifies that document should print using colors.
UseSyntax | 32 | Specifies that lexical analysis should be used for the document being printed.
UseHeader | 64 | Specifies that document should print with header.
UseFooter | 128 | Specifies that document should print with footer.
DisplayProgress | 256 | Specifies that progress of the printing operation should be displayed.
See Also

Reference

Alternet.Editor Namespace


PromptOnReplaceEvent Delegate

PromptOnReplaceEvent Delegate
Represents a method that will handle the SyntaxEdit.PromptOnReplace event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void PromptOnReplaceEvent(
    Object sender,
    PromptReplaceEventArgs e
)
Public Delegate Sub PromptOnReplaceEvent (
    sender As Object,
    e As PromptReplaceEventArgs
)
public delegate void PromptOnReplaceEvent(
    Object^ sender,
    PromptReplaceEventArgs^ e
)
type PromptOnReplaceEvent =
    delegate of
        sender : Object *
        e : PromptReplaceEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorPromptReplaceEventArgs
A PromptReplaceEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


PromptReplaceEventArgs Class

PromptReplaceEventArgs Class
Provides data for the PromptOnReplaceEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorPromptReplaceEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PromptReplaceEventArgs : EventArgs
Public Class PromptReplaceEventArgs
    Inherits EventArgs
public ref class PromptReplaceEventArgs : public EventArgs
type PromptReplaceEventArgs =
    class
        inherit EventArgs
    end

The PromptReplaceEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PromptReplaceEventArgs | Initializes a new instance of the PromptReplaceEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DialogResult | Represents dialog result for the prompt.
Public property | Handled | Represents a value indicating whether prompt on replace event is handled, disabling use default prompt dialog. By default this value is false.
Public property | Text | Represents the text to replace.
Public property | YesToAll | Represent a value indicating "yes" answer to all rest prompts, prevents following prompts.
Top
See Also

Reference

Alternet.Editor Namespace


PromptReplaceEventArgs Constructor

PromptReplaceEventArgs Constructor
Initializes a new instance of the PromptReplaceEventArgs class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PromptReplaceEventArgs(
    string text,
    bool handled,
    DialogResult dialogResult,
    bool yesToAll
)
Public Sub New (
    text As String,
    handled As Boolean,
    dialogResult As DialogResult,
    yesToAll As Boolean
)
public:
PromptReplaceEventArgs(
    String^ text,
    bool handled,
    DialogResult dialogResult,
    bool yesToAll
)
new :
        text : string *
        handled : bool *
        dialogResult : DialogResult *
        yesToAll : bool -> PromptReplaceEventArgs

Parameters

text
Type: SystemString
The text to replace.
handled
Type: SystemBoolean
Specifies whether prompt on replace event already handled.
dialogResult
Type: System.Windows.FormsDialogResult
Specifies dialog result for the prompt.
yesToAll
Type: SystemBoolean
Specifies "yes" answer for all rest prompts.
See Also

Reference

PromptReplaceEventArgs Class
Alternet.Editor Namespace


PromptReplaceEventArgs Methods

PromptReplaceEventArgs Methods

The PromptReplaceEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PromptReplaceEventArgs Class
Alternet.Editor Namespace


PromptReplaceEventArgs Properties

PromptReplaceEventArgs Properties

The PromptReplaceEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DialogResult | Represents dialog result for the prompt.
Public property | Handled | Represents a value indicating whether prompt on replace event is handled, disabling use default prompt dialog. By default this value is false.
Public property | Text | Represents the text to replace.
Public property | YesToAll | Represent a value indicating "yes" answer to all rest prompts, prevents following prompts.
Top
See Also

Reference

PromptReplaceEventArgs Class
Alternet.Editor Namespace


PromptReplaceEventArgs.DialogResult Property

PromptReplaceEventArgsDialogResult Property
Represents dialog result for the prompt.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DialogResult DialogResult { get; set; }
Public Property DialogResult As DialogResult
    Get
    Set
public:
property DialogResult DialogResult {
    DialogResult get ();
    void set (DialogResult value);
}
member DialogResult : DialogResult with get, set

Property Value

Type: DialogResult
See Also

Reference

PromptReplaceEventArgs Class
Alternet.Editor Namespace


PromptReplaceEventArgs.Handled Property

PromptReplaceEventArgsHandled Property
Represents a value indicating whether prompt on replace event is handled, disabling use default prompt dialog. By default this value is false.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PromptReplaceEventArgs Class
Alternet.Editor Namespace


PromptReplaceEventArgs.Text Property

PromptReplaceEventArgsText Property
Represents the text to replace.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

PromptReplaceEventArgs Class
Alternet.Editor Namespace


PromptReplaceEventArgs.YesToAll Property

PromptReplaceEventArgsYesToAll Property
Represent a value indicating "yes" answer to all rest prompts, prevents following prompts.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool YesToAll { get; set; }
Public Property YesToAll As Boolean
    Get
    Set
public:
property bool YesToAll {
    bool get ();
    void set (bool value);
}
member YesToAll : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PromptReplaceEventArgs Class
Alternet.Editor Namespace


Resources Class

Resources Class
Represents container of various resources used by Edit control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.EditorResources

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Resources : Component
Public Class Resources
    Inherits Component
public ref class Resources : public Component
type Resources =
    class
        inherit Component
    end

The Resources type exposes the following members.

Constructors
 | Name | Description
Public method | Resources | Initializes a new instance of the Resources class with default settings.
Public method | Resources(IContainer) | Initializes a new instance of the Resources class with specified container.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Top
See Also

Reference

Alternet.Editor Namespace


Resources Constructor

Resources Constructor
Overload List
 | Name | Description
Public method | Resources | Initializes a new instance of the Resources class with default settings.
Public method | Resources(IContainer) | Initializes a new instance of the Resources class with specified container.
Top
See Also

Reference

Resources Class
Alternet.Editor Namespace


Resources Constructor

Resources Constructor
Initializes a new instance of the Resources class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Resources()
Public Sub New
public:
Resources()
new : unit -> Resources
See Also

Reference

Resources Class
Resources Overload
Alternet.Editor Namespace


Resources Constructor (IContainer)

Resources Constructor (IContainer)
Initializes a new instance of the Resources class with specified container.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Resources(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
Resources(
    IContainer^ container
)
new :
        container : IContainer -> Resources

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

Resources Class
Resources Overload
Alternet.Editor Namespace


Resources Methods

Resources Methods

The Resources type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

Resources Class
Alternet.Editor Namespace


Resources Properties

Resources Properties

The Resources type exposes the following members.

Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
See Also

Reference

Resources Class
Alternet.Editor Namespace


Resources Events

Resources Events

The Resources type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Top
See Also

Reference

Resources Class
Alternet.Editor Namespace


RulerEventArgs Class

RulerEventArgs Class
Provides data for the EditRuler.Change handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorRulerEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RulerEventArgs : EventArgs
Public Class RulerEventArgs
    Inherits EventArgs
public ref class RulerEventArgs : public EventArgs
type RulerEventArgs =
    class
        inherit EventArgs
    end

The RulerEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RulerEventArgs | Initializes a new instance of the RulerEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Object | Source of the ruler event.
Top
See Also

Reference

Alternet.Editor Namespace


RulerEventArgs Constructor

RulerEventArgs Constructor
Initializes a new instance of the RulerEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RulerEventArgs(
    Object obj
)
Public Sub New (
    obj As Object
)
public:
RulerEventArgs(
    Object^ obj
)
new :
        obj : Object -> RulerEventArgs

Parameters

obj
Type: SystemObject
The source of the event.
See Also

Reference

RulerEventArgs Class
Alternet.Editor Namespace


RulerEventArgs Methods

RulerEventArgs Methods

The RulerEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RulerEventArgs Class
Alternet.Editor Namespace


RulerEventArgs Properties

RulerEventArgs Properties

The RulerEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Object | Source of the ruler event.
Top
See Also

Reference

RulerEventArgs Class
Alternet.Editor Namespace


RulerEventArgs.Object Property

RulerEventArgsObject Property
Source of the ruler event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Object { get; set; }
Public Property Object As Object
    Get
    Set
public:
property Object^ Object {
    Object^ get ();
    void set (Object^ value);
}
member Object : Object with get, set

Property Value

Type: Object
See Also

Reference

RulerEventArgs Class
Alternet.Editor Namespace


RulerIndent Class

RulerIndent Class
Represents an indentation part of ruler.
Inheritance Hierarchy
SystemObject
Alternet.EditorRulerIndent

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RulerIndent : IRulerIndent
Public Class RulerIndent
    Implements IRulerIndent
public ref class RulerIndent : IRulerIndent
type RulerIndent =
    class
        interface IRulerIndent
    end

The RulerIndent type exposes the following members.

Constructors
 | Name | Description
Public method | RulerIndent | Initializes a new instance of the RulerIndent class with default settings.
Public method | RulerIndent(IndentOrientation, Int32) | Initializes a new instance of the RulerIndent class with specified parameters.
Top
Methods
 | Name | Description
Public method | CancelDragging | Cancels dragging operation.
Public method | DrawIndent | Draws indentation part of ruler on the specified graphic surface.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Dragging | Indicates whether RulerIndent is in dragging state.
Public property | Indent | Gets or sets size of this RulerIndent.
Public property | Orientation | Gets or sets RulerIndent alignment.
Top
See Also

Reference

Alternet.Editor Namespace


RulerIndent Constructor

RulerIndent Constructor
Overload List
 | Name | Description
Public method | RulerIndent | Initializes a new instance of the RulerIndent class with default settings.
Public method | RulerIndent(IndentOrientation, Int32) | Initializes a new instance of the RulerIndent class with specified parameters.
Top
See Also

Reference

RulerIndent Class
Alternet.Editor Namespace


RulerIndent Constructor

RulerIndent Constructor
Initializes a new instance of the RulerIndent class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RulerIndent()
Public Sub New
public:
RulerIndent()
new : unit -> RulerIndent
See Also

Reference

RulerIndent Class
RulerIndent Overload
Alternet.Editor Namespace


RulerIndent Constructor (IndentOrientation, Int32)

RulerIndent Constructor (IndentOrientation, Int32)
Initializes a new instance of the RulerIndent class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RulerIndent(
    IndentOrientation orientation,
    int indent
)
Public Sub New (
    orientation As IndentOrientation,
    indent As Integer
)
public:
RulerIndent(
    IndentOrientation orientation,
    int indent
)
new :
        orientation : IndentOrientation *
        indent : int -> RulerIndent

Parameters

orientation
Type: Alternet.EditorIndentOrientation
Specifies orientation of this new instance.
indent
Type: SystemInt32
Specifies size of this new instance.
See Also

Reference

RulerIndent Class
RulerIndent Overload
Alternet.Editor Namespace


RulerIndent Methods

RulerIndent Methods

The RulerIndent type exposes the following members.

Methods
 | Name | Description
Public method | CancelDragging | Cancels dragging operation.
Public method | DrawIndent | Draws indentation part of ruler on the specified graphic surface.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RulerIndent Class
Alternet.Editor Namespace


RulerIndent.CancelDragging Method

RulerIndentCancelDragging Method
Cancels dragging operation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CancelDragging()
Public Sub CancelDragging
public:
virtual void CancelDragging() sealed
abstract CancelDragging : unit -> unit
override CancelDragging : unit -> unit

Implements

IRulerIndentCancelDragging
See Also

Reference

RulerIndent Class
Alternet.Editor Namespace


RulerIndent.DrawIndent Method

RulerIndentDrawIndent Method
Draws indentation part of ruler on the specified graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DrawIndent(
    Graphics graph,
    Rectangle rect,
    bool vertical,
    Color indentBackColor,
    Color backColor
)
Public Sub DrawIndent (
    graph As Graphics,
    rect As Rectangle,
    vertical As Boolean,
    indentBackColor As Color,
    backColor As Color
)
public:
virtual void DrawIndent(
    Graphics^ graph,
    Rectangle rect,
    bool vertical,
    Color indentBackColor,
    Color backColor
) sealed
abstract DrawIndent :
        graph : Graphics *
        rect : Rectangle *
        vertical : bool *
        indentBackColor : Color *
        backColor : Color -> unit
override DrawIndent :
        graph : Graphics *
        rect : Rectangle *
        vertical : bool *
        indentBackColor : Color *
        backColor : Color -> unit

Parameters

graph
Type: System.DrawingGraphics
The Graphics object to draw on.
rect
Type: System.DrawingRectangle
Rectangular area of ruler indentation to draw on.
vertical
Type: SystemBoolean
Indicates whether indentation has vertical or horizontal direction.
indentBackColor
Type: System.DrawingColor
Specifies background color of this RulerIndent.
backColor
Type: System.DrawingColor
Specifies background color of RulerIndent slider.

Implements

IRulerIndentDrawIndent(Graphics, Rectangle, Boolean, Color, Color)
See Also

Reference

RulerIndent Class
Alternet.Editor Namespace


RulerIndent Properties

RulerIndent Properties

The RulerIndent type exposes the following members.

Properties
 | Name | Description
Public property | Dragging | Indicates whether RulerIndent is in dragging state.
Public property | Indent | Gets or sets size of this RulerIndent.
Public property | Orientation | Gets or sets RulerIndent alignment.
Top
See Also

Reference

RulerIndent Class
Alternet.Editor Namespace


RulerIndent.Dragging Property

RulerIndentDragging Property
Indicates whether RulerIndent is in dragging state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Dragging { get; set; }
Public Property Dragging As Boolean
    Get
    Set
public:
virtual property bool Dragging {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Dragging : bool with get, set
override Dragging : bool with get, set

Property Value

Type: Boolean

Implements

IRulerIndentDragging
See Also

Reference

RulerIndent Class
Alternet.Editor Namespace


RulerIndent.Indent Property

RulerIndentIndent Property
Gets or sets size of this RulerIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Indent { get; set; }
Public Property Indent As Integer
    Get
    Set
public:
virtual property int Indent {
    int get () sealed;
    void set (int value) sealed;
}
abstract Indent : int with get, set
override Indent : int with get, set

Property Value

Type: Int32

Implements

IRulerIndentIndent
See Also

Reference

RulerIndent Class
Alternet.Editor Namespace


RulerIndent.Orientation Property

RulerIndentOrientation Property
Gets or sets RulerIndent alignment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IndentOrientation Orientation { get; set; }
Public Property Orientation As IndentOrientation
    Get
    Set
public:
virtual property IndentOrientation Orientation {
    IndentOrientation get () sealed;
    void set (IndentOrientation value) sealed;
}
abstract Orientation : IndentOrientation with get, set
override Orientation : IndentOrientation with get, set

Property Value

Type: IndentOrientation

Implements

IRulerIndentOrientation
See Also

Reference

RulerIndent Class
Alternet.Editor Namespace


RulerOptions Enumeration

RulerOptions Enumeration
Defines Edit ruler behaviour. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum RulerOptions
<FlagsAttribute>
Public Enumeration RulerOptions
[FlagsAttribute]
public enum class RulerOptions
[<FlagsAttribute>]
type RulerOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Discrete | 1 | Specifies that ruler indents changes its position in discrete steps.
AllowDrag | 2 | Allows dragging ruler indentations.
DisplayDragLine | 4 | Specifies dotted line to be displayed while ruler indentation being dragged.
See Also

Reference

Alternet.Editor Namespace


RulerUnits Enumeration

RulerUnits Enumeration
Defines units for the ruler.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RulerUnits
Public Enumeration RulerUnits
public enum class RulerUnits
type RulerUnits
Members
Member name | Value | Description
Milimeters | 0 | Specifies that ruler marks are measured in millimeters.
Inches | 1 | Specifies that ruler marks are measured in inches.
Pixels | 2 | Specifies that ruler marks are measured in pixels.
Characters | 3 | Specifies that ruler marks are measured in characters.
See Also

Reference

Alternet.Editor Namespace


ScrollBar Class

ScrollBar Class
A custom scrollbar control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.EditorScrollBar

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ScrollBar : Control
Public MustInherit Class ScrollBar
    Inherits Control
public ref class ScrollBar abstract : public Control
[<AbstractClassAttribute>]
type ScrollBar =
    class
        inherit Control
    end

The ScrollBar type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollBar | Initializes a new instance of the ScrollBar class.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents the drawing of the control until EndUpdate is called.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Ends the updating process and the control can draw itself again.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change amount.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum value.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | The scrollbar Orientation - horizontal / vertical.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Renderer | Gets or sets IScrollBarRenderer for the scrollbar.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change amount.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value.
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualStyle | Gets or sets visual style of the scrollbar.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintOver | Occurs when scrollbar paints its content.
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the scrollbar scrolled.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor Namespace


ScrollBar Constructor

ScrollBar Constructor
Initializes a new instance of the ScrollBar class.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScrollBar()
Public Sub New
public:
ScrollBar()
new : unit -> ScrollBar
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar Methods

ScrollBar Methods

The ScrollBar type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents the drawing of the control until EndUpdate is called.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Ends the updating process and the control can draw itself again.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.BeginUpdate Method

ScrollBarBeginUpdate Method
Prevents the drawing of the control until EndUpdate is called.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BeginUpdate()
Public Sub BeginUpdate
public:
void BeginUpdate()
member BeginUpdate : unit -> unit
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.EndUpdate Method

ScrollBarEndUpdate Method
Ends the updating process and the control can draw itself again.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EndUpdate()
Public Sub EndUpdate
public:
void EndUpdate()
member EndUpdate : unit -> unit
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar Properties

ScrollBar Properties

The ScrollBar type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change amount.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value.
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum value.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | The scrollbar Orientation - horizontal / vertical.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Renderer | Gets or sets IScrollBarRenderer for the scrollbar.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change amount.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value.
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualStyle | Gets or sets visual style of the scrollbar.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.LargeChange Property

ScrollBarLargeChange Property
Gets or sets the large change amount.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LargeChange { get; set; }
Public Property LargeChange As Integer
    Get
    Set
public:
property int LargeChange {
    int get ();
    void set (int value);
}
member LargeChange : int with get, set

Property Value

Type: Int32
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.Maximum Property

ScrollBarMaximum Property
Gets or sets the maximum value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Maximum { get; set; }
Public Property Maximum As Integer
    Get
    Set
public:
property int Maximum {
    int get ();
    void set (int value);
}
member Maximum : int with get, set

Property Value

Type: Int32
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.Minimum Property

ScrollBarMinimum Property
Gets or sets the minimum value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set
public:
property int Minimum {
    int get ();
    void set (int value);
}
member Minimum : int with get, set

Property Value

Type: Int32
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.Orientation Property

ScrollBarOrientation Property
The scrollbar Orientation - horizontal / vertical.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract ScrollBarOrientation Orientation { get; }
Public MustOverride ReadOnly Property Orientation As ScrollBarOrientation
    Get
public:
virtual property ScrollBarOrientation Orientation {
    ScrollBarOrientation get () abstract;
}
abstract Orientation : ScrollBarOrientation with get

Property Value

Type: ScrollBarOrientation
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.Renderer Property

ScrollBarRenderer Property
Gets or sets IScrollBarRenderer for the scrollbar.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScrollBarRenderer Renderer { get; set; }
Public Property Renderer As IScrollBarRenderer
    Get
    Set
public:
property IScrollBarRenderer^ Renderer {
    IScrollBarRenderer^ get ();
    void set (IScrollBarRenderer^ value);
}
member Renderer : IScrollBarRenderer with get, set

Property Value

Type: IScrollBarRenderer
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.SmallChange Property

ScrollBarSmallChange Property
Gets or sets the small change amount.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SmallChange { get; set; }
Public Property SmallChange As Integer
    Get
    Set
public:
property int SmallChange {
    int get ();
    void set (int value);
}
member SmallChange : int with get, set

Property Value

Type: Int32
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.Value Property

ScrollBarValue Property
Gets or sets the value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
public:
property int Value {
    int get ();
    void set (int value);
}
member Value : int with get, set

Property Value

Type: Int32
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.VisualStyle Property

ScrollBarVisualStyle Property
Gets or sets visual style of the scrollbar.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScrollBarVisualStyle VisualStyle { get; set; }
Public Property VisualStyle As ScrollBarVisualStyle
    Get
    Set
public:
property ScrollBarVisualStyle VisualStyle {
    ScrollBarVisualStyle get ();
    void set (ScrollBarVisualStyle value);
}
member VisualStyle : ScrollBarVisualStyle with get, set

Property Value

Type: ScrollBarVisualStyle
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar Events

ScrollBar Events

The ScrollBar type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintOver | Occurs when scrollbar paints its content.
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the scrollbar scrolled.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.PaintOver Event

ScrollBarPaintOver Event
Occurs when scrollbar paints its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ScrollBarPaintEventArgs> PaintOver
Public Event PaintOver As EventHandler(Of ScrollBarPaintEventArgs)
public:
 event EventHandler<ScrollBarPaintEventArgs^>^ PaintOver {
    void add (EventHandler<ScrollBarPaintEventArgs^>^ value);
    void remove (EventHandler<ScrollBarPaintEventArgs^>^ value);
}
member PaintOver : IEvent<EventHandler<ScrollBarPaintEventArgs>,
    ScrollBarPaintEventArgs>

Value

Type: SystemEventHandlerScrollBarPaintEventArgs
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBar.Scroll Event

ScrollBarScroll Event
Occurs when the scrollbar scrolled.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event ScrollEventHandler Scroll
Public Event Scroll As ScrollEventHandler
public:
 event ScrollEventHandler^ Scroll {
    void add (ScrollEventHandler^ value);
    void remove (ScrollEventHandler^ value);
}
member Scroll : IEvent<ScrollEventHandler,
    ScrollEventArgs>

Value

Type: System.Windows.FormsScrollEventHandler
See Also

Reference

ScrollBar Class
Alternet.Editor Namespace


ScrollBarOrientation Enumeration

ScrollBarOrientation Enumeration
Enum for the scrollbar orientation.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScrollBarOrientation
Public Enumeration ScrollBarOrientation
public enum class ScrollBarOrientation
type ScrollBarOrientation
Members
Member name | Value | Description
Horizontal | 0 | Indicates a horizontal scrollbar.
Vertical | 1 | Indicates a vertical scrollbar.
See Also

Reference

Alternet.Editor Namespace


Scrolling Class

Scrolling Class
Represents properties and methods that describe scrolling behaviour of Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorScrolling

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Scrolling : IScrolling, IUpdate,
    IDisposable
Public Class Scrolling
    Implements IScrolling, IUpdate, IDisposable
public ref class Scrolling : IScrolling,
    IUpdate, IDisposable
type Scrolling =
    class
        interface IScrolling
        interface IUpdate
        interface IDisposable
    end

The Scrolling type exposes the following members.

Constructors
 | Name | Description
Public method | Scrolling | Initializes a new instance of the Scrolling class with specified owner.
Top
Methods
 | Name | Description
Public method | ApplyTheme |
Public method | Assign | Copies the contents of another IScrolling object.
Public method | BeginUpdate | Prevents Scrolling updating until the EndUpdate method is called.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | Dispose | Disposes this Scrolling and frees resources associated with it.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables Scrolling updating turned off by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MouseScroll | Scrolls editor control vertically.
Public method | OnScrollButtonClick | Raises ScrollButtonClick event.
Public method | ResetDefaultHorzScrollSize | Resets the DefaultHorzScrollSize to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetScrollBars | Resets the ScrollBars to the default value.
Public method | ShouldSerializeDefaultHorzScrollSize | Indicates whether the DefaultHorzScrollSize property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | SystemScroll | Performs a system scrolls by calling Windows API.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the Scrolling size and position.
Public method | UpdateFlat | Initializes flat scroll bars for editor control.
Public method | UpdateScroll | Updates scrolling control.
Public method | UpdateScroll(Boolean) | Updates scrolling control.
Top
Properties
 | Name | Description
Public property | Annotations | Gets the scroll bars annotations control interface.
Public property | DefaultHorzScrollSize | Gets or sets a default size of horizontal scrollbar.
Public property | FixedScrollSize | Indicates whether horz scrollbar has fixed size.
Public property | HasHScrollBar | Indicates whether control has a horizontal scroll bar control.
Public property | HasVScrollBar | Indicates whether control has a vertical scroll bar control.
Public property | HorzButtons | Represents a collection of additional buttons displayed at the horizontal scroll bar area.
Public property | HorzScrollbarVisible | When implemented by a class, indicates whether horizontal scrollbar is visible.
Public property | HorzSplitButton | Represents a special button on the scroll area used split Edit control horizontally.
Public property | HScrollBar | Gets horizontal scroll bar control.
Public property | Options | Gets or sets a ScrollingOptions that determine scrolling behaviour.
Public property | Owner | Represents owner of this IScrolling object.
Public property | ScrollBars | Gets or sets the type of scroll bars displayed in the control.
Public property | ScrollBarsCornerColor | Indicates color of the corner between scroll bars for the current visual style.
Public property | ScrollBarsVisualStyle | Gets or sets the scroll bars visual style displayed in the control.
Public property | ScrollByPixels | Indicates whether scrollbars should use pixels rather than characters.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | VertButtons | Represents a collection of additional buttons displayed at the vertical scroll bar area.
Public property | VertScrollbarVisible | When implemented by a class, indicates whether vertical scrollbar is visible.
Public property | VertSplitButton | Represents a special button on the scroll area used to split Edit control vertically.
Public property | VScrollBar | Gets vertical scroll bar control.
Public property | WindowOriginX | Gets or sets a index of the first visible character within the control.
Public property | WindowOriginY | Gets or sets a value that represents first visible line within the control.
Top
Events
 | Name | Description
Public event | HorizontalScroll | Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving.
Public event | ScrollButtonClick | Occurs when some scrolling button is clicked.
Public event | VerticalScroll | Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving.
Top
See Also

Reference

Alternet.Editor Namespace


Scrolling Constructor

Scrolling Constructor
Initializes a new instance of the Scrolling class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Scrolling(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
Scrolling(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> Scrolling

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling Methods

Scrolling Methods

The Scrolling type exposes the following members.

Methods
 | Name | Description
Public method | ApplyTheme |
Public method | Assign | Copies the contents of another IScrolling object.
Public method | BeginUpdate | Prevents Scrolling updating until the EndUpdate method is called.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | Dispose | Disposes this Scrolling and frees resources associated with it.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables Scrolling updating turned off by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MouseScroll | Scrolls editor control vertically.
Public method | OnScrollButtonClick | Raises ScrollButtonClick event.
Public method | ResetDefaultHorzScrollSize | Resets the DefaultHorzScrollSize to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetScrollBars | Resets the ScrollBars to the default value.
Public method | ShouldSerializeDefaultHorzScrollSize | Indicates whether the DefaultHorzScrollSize property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | SystemScroll | Performs a system scrolls by calling Windows API.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the Scrolling size and position.
Public method | UpdateFlat | Initializes flat scroll bars for editor control.
Public method | UpdateScroll | Updates scrolling control.
Public method | UpdateScroll(Boolean) | Updates scrolling control.
Top
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ApplyTheme Method

ScrollingApplyTheme Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplyTheme(
    IVisualTheme theme
)
Public Sub ApplyTheme (
    theme As IVisualTheme
)
public:
virtual void ApplyTheme(
    IVisualTheme^ theme
) sealed
abstract ApplyTheme :
        theme : IVisualTheme -> unit
override ApplyTheme :
        theme : IVisualTheme -> unit

Parameters

theme
Type: Alternet.EditorIVisualTheme

Implements

IScrollingApplyTheme(IVisualTheme)
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.Assign Method

ScrollingAssign Method
Copies the contents of another IScrolling object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IScrolling source
)
Public Overridable Sub Assign (
    source As IScrolling
)
public:
virtual void Assign(
    IScrolling^ source
)
abstract Assign :
        source : IScrolling -> unit
override Assign :
        source : IScrolling -> unit

Parameters

source
Type: Alternet.EditorIScrolling
Specifies IScrolling to assign.

Implements

IScrollingAssign(IScrolling)
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.BeginUpdate Method

ScrollingBeginUpdate Method
Prevents Scrolling updating until the EndUpdate method is called.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of Scrolling updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.DisableUpdate Method

ScrollingDisableUpdate Method
Prevents object state updating until calling EnableUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.Dispose Method

ScrollingDispose Method
Disposes this Scrolling and frees resources associated with it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.EnableUpdate Method

ScrollingEnableUpdate Method
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.EndUpdate Method

ScrollingEndUpdate Method
Re-enables Scrolling updating turned off by calling BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of Scrolling updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.MouseScroll Method

ScrollingMouseScroll Method
Scrolls editor control vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MouseScroll(
    int delta
)
Public Overridable Sub MouseScroll (
    delta As Integer
)
public:
virtual void MouseScroll(
    int delta
)
abstract MouseScroll :
        delta : int -> unit
override MouseScroll :
        delta : int -> unit

Parameters

delta
Type: SystemInt32
Specifies mouse wheel delta.

Implements

IScrollingMouseScroll(Int32)
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.OnScrollButtonClick Method

ScrollingOnScrollButtonClick Method
Raises ScrollButtonClick event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScrollButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub OnScrollButtonClick (
    sender As Object,
    e As EventArgs
)
public:
virtual void OnScrollButtonClick(
    Object^ sender,
    EventArgs^ e
)
abstract OnScrollButtonClick :
        sender : Object *
        e : EventArgs -> unit
override OnScrollButtonClick :
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: SystemEventArgs
An EventArgs that contains the event data.

Implements

IScrollingOnScrollButtonClick(Object, EventArgs)
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ResetDefaultHorzScrollSize Method

ScrollingResetDefaultHorzScrollSize Method
Resets the DefaultHorzScrollSize to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDefaultHorzScrollSize()
Public Overridable Sub ResetDefaultHorzScrollSize
public:
virtual void ResetDefaultHorzScrollSize()
abstract ResetDefaultHorzScrollSize : unit -> unit
override ResetDefaultHorzScrollSize : unit -> unit

Implements

IScrollingResetDefaultHorzScrollSize
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ResetOptions Method

ScrollingResetOptions Method
Resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOptions()
Public Overridable Sub ResetOptions
public:
virtual void ResetOptions()
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

IScrollingResetOptions
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ResetScrollBars Method

ScrollingResetScrollBars Method
Resets the ScrollBars to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetScrollBars()
Public Overridable Sub ResetScrollBars
public:
virtual void ResetScrollBars()
abstract ResetScrollBars : unit -> unit
override ResetScrollBars : unit -> unit

Implements

IScrollingResetScrollBars
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ShouldSerializeDefaultHorzScrollSize Method

ScrollingShouldSerializeDefaultHorzScrollSize Method
Indicates whether the DefaultHorzScrollSize property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeDefaultHorzScrollSize()
Public Function ShouldSerializeDefaultHorzScrollSize As Boolean
public:
bool ShouldSerializeDefaultHorzScrollSize()
member ShouldSerializeDefaultHorzScrollSize : unit -> bool

Return Value

Type: Boolean
True if DefaultHorzScrollSize differs from its default value; otherwise false.
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ShouldSerializeOptions Method

ScrollingShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOptions()
Public Function ShouldSerializeOptions As Boolean
public:
bool ShouldSerializeOptions()
member ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.SystemScroll Method

ScrollingSystemScroll Method
Performs a system scrolls by calling Windows API.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SystemScroll(
    int code,
    bool vert
)
Public Overridable Sub SystemScroll (
    code As Integer,
    vert As Boolean
)
public:
virtual void SystemScroll(
    int code,
    bool vert
)
abstract SystemScroll :
        code : int *
        vert : bool -> unit
override SystemScroll :
        code : int *
        vert : bool -> unit

Parameters

code
Type: SystemInt32
Specifies scrolling request.
vert
Type: SystemBoolean
True if vertical scroll bar should be scrolled; otherwise false.

Implements

IScrollingSystemScroll(Int32, Boolean)
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.Update Method

ScrollingUpdate Method
Updates the Scrolling size and position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.UpdateFlat Method

ScrollingUpdateFlat Method
Initializes flat scroll bars for editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateFlat()
Public Overridable Sub UpdateFlat
public:
virtual void UpdateFlat()
abstract UpdateFlat : unit -> unit
override UpdateFlat : unit -> unit

Implements

IScrollingUpdateFlat
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.UpdateScroll Method

ScrollingUpdateScroll Method
Overload List
 | Name | Description
Public method | UpdateScroll | Updates scrolling control.
Public method | UpdateScroll(Boolean) | Updates scrolling control.
Top
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.UpdateScroll Method

ScrollingUpdateScroll Method
Updates scrolling control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateScroll()
Public Overridable Sub UpdateScroll
public:
virtual void UpdateScroll()
abstract UpdateScroll : unit -> unit
override UpdateScroll : unit -> unit

Implements

IScrollingUpdateScroll
See Also

Reference

Scrolling Class
UpdateScroll Overload
Alternet.Editor Namespace


Scrolling.UpdateScroll Method (Boolean)

ScrollingUpdateScroll Method (Boolean)
Updates scrolling control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateScroll(
    bool updateSize
)
Public Overridable Sub UpdateScroll (
    updateSize As Boolean
)
public:
virtual void UpdateScroll(
    bool updateSize
)
abstract UpdateScroll :
        updateSize : bool -> unit
override UpdateScroll :
        updateSize : bool -> unit

Parameters

updateSize
Type: SystemBoolean
True if scrolling control should be resized; otherwise false.

Implements

IScrollingUpdateScroll(Boolean)
See Also

Reference

Scrolling Class
UpdateScroll Overload
Alternet.Editor Namespace


Scrolling Properties

Scrolling Properties

The Scrolling type exposes the following members.

Properties
 | Name | Description
Public property | Annotations | Gets the scroll bars annotations control interface.
Public property | DefaultHorzScrollSize | Gets or sets a default size of horizontal scrollbar.
Public property | FixedScrollSize | Indicates whether horz scrollbar has fixed size.
Public property | HasHScrollBar | Indicates whether control has a horizontal scroll bar control.
Public property | HasVScrollBar | Indicates whether control has a vertical scroll bar control.
Public property | HorzButtons | Represents a collection of additional buttons displayed at the horizontal scroll bar area.
Public property | HorzScrollbarVisible | When implemented by a class, indicates whether horizontal scrollbar is visible.
Public property | HorzSplitButton | Represents a special button on the scroll area used split Edit control horizontally.
Public property | HScrollBar | Gets horizontal scroll bar control.
Public property | Options | Gets or sets a ScrollingOptions that determine scrolling behaviour.
Public property | Owner | Represents owner of this IScrolling object.
Public property | ScrollBars | Gets or sets the type of scroll bars displayed in the control.
Public property | ScrollBarsCornerColor | Indicates color of the corner between scroll bars for the current visual style.
Public property | ScrollBarsVisualStyle | Gets or sets the scroll bars visual style displayed in the control.
Public property | ScrollByPixels | Indicates whether scrollbars should use pixels rather than characters.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | VertButtons | Represents a collection of additional buttons displayed at the vertical scroll bar area.
Public property | VertScrollbarVisible | When implemented by a class, indicates whether vertical scrollbar is visible.
Public property | VertSplitButton | Represents a special button on the scroll area used to split Edit control vertically.
Public property | VScrollBar | Gets vertical scroll bar control.
Public property | WindowOriginX | Gets or sets a index of the first visible character within the control.
Public property | WindowOriginY | Gets or sets a value that represents first visible line within the control.
Top
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.Annotations Property

ScrollingAnnotations Property
Gets the scroll bars annotations control interface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScrollBarAnnotations Annotations { get; }
Public ReadOnly Property Annotations As IScrollBarAnnotations
    Get
public:
virtual property IScrollBarAnnotations^ Annotations {
    IScrollBarAnnotations^ get () sealed;
}
abstract Annotations : IScrollBarAnnotations with get
override Annotations : IScrollBarAnnotations with get

Property Value

Type: IScrollBarAnnotations

Implements

IScrollingAnnotations
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.DefaultHorzScrollSize Property

ScrollingDefaultHorzScrollSize Property
Gets or sets a default size of horizontal scrollbar.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DefaultHorzScrollSize { get; set; }
Public Overridable Property DefaultHorzScrollSize As Integer
    Get
    Set
public:
virtual property int DefaultHorzScrollSize {
    int get ();
    void set (int value);
}
abstract DefaultHorzScrollSize : int with get, set
override DefaultHorzScrollSize : int with get, set

Property Value

Type: Int32

Implements

IScrollingDefaultHorzScrollSize
Remarks
This property is applicable when control forces showing of the horizontal scroll bar.
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.FixedScrollSize Property

ScrollingFixedScrollSize Property
Indicates whether horz scrollbar has fixed size.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FixedScrollSize { get; }
Public Overridable ReadOnly Property FixedScrollSize As Boolean
    Get
public:
virtual property bool FixedScrollSize {
    bool get ();
}
abstract FixedScrollSize : bool with get
override FixedScrollSize : bool with get

Property Value

Type: Boolean

Implements

IScrollingFixedScrollSize
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.HasHScrollBar Property

ScrollingHasHScrollBar Property
Indicates whether control has a horizontal scroll bar control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasHScrollBar { get; }
Public Overridable ReadOnly Property HasHScrollBar As Boolean
    Get
public:
virtual property bool HasHScrollBar {
    bool get ();
}
abstract HasHScrollBar : bool with get
override HasHScrollBar : bool with get

Property Value

Type: Boolean

Implements

IScrollingHasHScrollBar
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.HasVScrollBar Property

ScrollingHasVScrollBar Property
Indicates whether control has a vertical scroll bar control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasVScrollBar { get; }
Public Overridable ReadOnly Property HasVScrollBar As Boolean
    Get
public:
virtual property bool HasVScrollBar {
    bool get ();
}
abstract HasVScrollBar : bool with get
override HasVScrollBar : bool with get

Property Value

Type: Boolean

Implements

IScrollingHasVScrollBar
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.HorzButtons Property

ScrollingHorzButtons Property
Represents a collection of additional buttons displayed at the horizontal scroll bar area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute("Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")]
public virtual IScrollingButtons HorzButtons { get; }
<TypeConverterAttribute("Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")>
Public Overridable ReadOnly Property HorzButtons As IScrollingButtons
    Get
public:
[TypeConverterAttribute(L"Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")]
virtual property IScrollingButtons^ HorzButtons {
    IScrollingButtons^ get ();
}
[<TypeConverterAttribute("Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")>]
abstract HorzButtons : IScrollingButtons with get
[<TypeConverterAttribute("Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")>]
override HorzButtons : IScrollingButtons with get

Property Value

Type: IScrollingButtons

Implements

IScrollingHorzButtons
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.HorzScrollbarVisible Property

ScrollingHorzScrollbarVisible Property
When implemented by a class, indicates whether horizontal scrollbar is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HorzScrollbarVisible { get; }
Public Overridable ReadOnly Property HorzScrollbarVisible As Boolean
    Get
public:
virtual property bool HorzScrollbarVisible {
    bool get ();
}
abstract HorzScrollbarVisible : bool with get
override HorzScrollbarVisible : bool with get

Property Value

Type: Boolean

Implements

IScrollingHorzScrollbarVisible
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.HorzSplitButton Property

ScrollingHorzSplitButton Property
Represents a special button on the scroll area used split Edit control horizontally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScrollingButton HorzSplitButton { get; }
Public ReadOnly Property HorzSplitButton As IScrollingButton
    Get
public:
virtual property IScrollingButton^ HorzSplitButton {
    IScrollingButton^ get () sealed;
}
abstract HorzSplitButton : IScrollingButton with get
override HorzSplitButton : IScrollingButton with get

Property Value

Type: IScrollingButton

Implements

IScrollingHorzSplitButton
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.HScrollBar Property

ScrollingHScrollBar Property
Gets horizontal scroll bar control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ScrollBar HScrollBar { get; }
Public Overridable ReadOnly Property HScrollBar As ScrollBar
    Get
public:
virtual property ScrollBar^ HScrollBar {
    ScrollBar^ get ();
}
abstract HScrollBar : ScrollBar with get
override HScrollBar : ScrollBar with get

Property Value

Type: ScrollBar

Implements

IScrollingHScrollBar
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.Options Property

ScrollingOptions Property
Gets or sets a ScrollingOptions that determine scrolling behaviour.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ScrollingOptions Options { get; set; }
Public Overridable Property Options As ScrollingOptions
    Get
    Set
public:
virtual property ScrollingOptions Options {
    ScrollingOptions get ();
    void set (ScrollingOptions value);
}
abstract Options : ScrollingOptions with get, set
override Options : ScrollingOptions with get, set

Property Value

Type: ScrollingOptions

Implements

IScrollingOptions
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.Owner Property

ScrollingOwner Property
Represents owner of this IScrolling object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISyntaxEdit Owner { get; }
Public ReadOnly Property Owner As ISyntaxEdit
    Get
public:
virtual property ISyntaxEdit^ Owner {
    ISyntaxEdit^ get () sealed;
}
abstract Owner : ISyntaxEdit with get
override Owner : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit

Implements

IScrollingOwner
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ScrollBars Property

ScrollingScrollBars Property
Gets or sets the type of scroll bars displayed in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual RichTextBoxScrollBars ScrollBars { get; set; }
Public Overridable Property ScrollBars As RichTextBoxScrollBars
    Get
    Set
public:
virtual property RichTextBoxScrollBars ScrollBars {
    RichTextBoxScrollBars get ();
    void set (RichTextBoxScrollBars value);
}
abstract ScrollBars : RichTextBoxScrollBars with get, set
override ScrollBars : RichTextBoxScrollBars with get, set

Property Value

Type: RichTextBoxScrollBars

Implements

IScrollingScrollBars
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ScrollBarsCornerColor Property

ScrollingScrollBarsCornerColor Property
Indicates color of the corner between scroll bars for the current visual style.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ScrollBarsCornerColor { get; }
Public Overridable ReadOnly Property ScrollBarsCornerColor As Color
    Get
public:
virtual property Color ScrollBarsCornerColor {
    Color get ();
}
abstract ScrollBarsCornerColor : Color with get
override ScrollBarsCornerColor : Color with get

Property Value

Type: Color

Implements

IScrollingScrollBarsCornerColor
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ScrollBarsVisualStyle Property

ScrollingScrollBarsVisualStyle Property
Gets or sets the scroll bars visual style displayed in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ScrollBarVisualStyle ScrollBarsVisualStyle { get; set; }
Public Overridable Property ScrollBarsVisualStyle As ScrollBarVisualStyle
    Get
    Set
public:
virtual property ScrollBarVisualStyle ScrollBarsVisualStyle {
    ScrollBarVisualStyle get ();
    void set (ScrollBarVisualStyle value);
}
abstract ScrollBarsVisualStyle : ScrollBarVisualStyle with get, set
override ScrollBarsVisualStyle : ScrollBarVisualStyle with get, set

Property Value

Type: ScrollBarVisualStyle

Implements

IScrollingScrollBarsVisualStyle
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ScrollByPixels Property

ScrollingScrollByPixels Property
Indicates whether scrollbars should use pixels rather than characters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ScrollByPixels { get; }
Public Overridable ReadOnly Property ScrollByPixels As Boolean
    Get
public:
virtual property bool ScrollByPixels {
    bool get ();
}
abstract ScrollByPixels : bool with get
override ScrollByPixels : bool with get

Property Value

Type: Boolean

Implements

IScrollingScrollByPixels
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.UpdateCount Property

ScrollingUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.VertButtons Property

ScrollingVertButtons Property
Represents a collection of additional buttons displayed at the vertical scroll bar area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute("Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")]
public virtual IScrollingButtons VertButtons { get; }
<TypeConverterAttribute("Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")>
Public Overridable ReadOnly Property VertButtons As IScrollingButtons
    Get
public:
[TypeConverterAttribute(L"Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")]
virtual property IScrollingButtons^ VertButtons {
    IScrollingButtons^ get ();
}
[<TypeConverterAttribute("Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")>]
abstract VertButtons : IScrollingButtons with get
[<TypeConverterAttribute("Alternet.Design.ScrollingButtonsConverter, Alternet.Editor.Design.v7")>]
override VertButtons : IScrollingButtons with get

Property Value

Type: IScrollingButtons

Implements

IScrollingVertButtons
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.VertScrollbarVisible Property

ScrollingVertScrollbarVisible Property
When implemented by a class, indicates whether vertical scrollbar is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool VertScrollbarVisible { get; }
Public Overridable ReadOnly Property VertScrollbarVisible As Boolean
    Get
public:
virtual property bool VertScrollbarVisible {
    bool get ();
}
abstract VertScrollbarVisible : bool with get
override VertScrollbarVisible : bool with get

Property Value

Type: Boolean

Implements

IScrollingVertScrollbarVisible
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.VertSplitButton Property

ScrollingVertSplitButton Property
Represents a special button on the scroll area used to split Edit control vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScrollingButton VertSplitButton { get; }
Public ReadOnly Property VertSplitButton As IScrollingButton
    Get
public:
virtual property IScrollingButton^ VertSplitButton {
    IScrollingButton^ get () sealed;
}
abstract VertSplitButton : IScrollingButton with get
override VertSplitButton : IScrollingButton with get

Property Value

Type: IScrollingButton

Implements

IScrollingVertSplitButton
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.VScrollBar Property

ScrollingVScrollBar Property
Gets vertical scroll bar control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ScrollBar VScrollBar { get; }
Public Overridable ReadOnly Property VScrollBar As ScrollBar
    Get
public:
virtual property ScrollBar^ VScrollBar {
    ScrollBar^ get ();
}
abstract VScrollBar : ScrollBar with get
override VScrollBar : ScrollBar with get

Property Value

Type: ScrollBar

Implements

IScrollingVScrollBar
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.WindowOriginX Property

ScrollingWindowOriginX Property
Gets or sets a index of the first visible character within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int WindowOriginX { get; set; }
Public Overridable Property WindowOriginX As Integer
    Get
    Set
public:
virtual property int WindowOriginX {
    int get ();
    void set (int value);
}
abstract WindowOriginX : int with get, set
override WindowOriginX : int with get, set

Property Value

Type: Int32

Implements

IScrollingWindowOriginX
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.WindowOriginY Property

ScrollingWindowOriginY Property
Gets or sets a value that represents first visible line within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int WindowOriginY { get; set; }
Public Overridable Property WindowOriginY As Integer
    Get
    Set
public:
virtual property int WindowOriginY {
    int get ();
    void set (int value);
}
abstract WindowOriginY : int with get, set
override WindowOriginY : int with get, set

Property Value

Type: Int32

Implements

IScrollingWindowOriginY
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling Events

Scrolling Events

The Scrolling type exposes the following members.

Events
 | Name | Description
Public event | HorizontalScroll | Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving.
Public event | ScrollButtonClick | Occurs when some scrolling button is clicked.
Public event | VerticalScroll | Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving.
Top
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.HorizontalScroll Event

ScrollingHorizontalScroll Event
Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler HorizontalScroll
Public Event HorizontalScroll As EventHandler
public:
virtual  event EventHandler^ HorizontalScroll {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HorizontalScroll : IEvent<EventHandler,
    EventArgs>
override HorizontalScroll : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScrollingHorizontalScroll
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.ScrollButtonClick Event

ScrollingScrollButtonClick Event
Occurs when some scrolling button is clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScrollButtonClick
Public Event ScrollButtonClick As EventHandler
public:
virtual  event EventHandler^ ScrollButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScrollButtonClick : IEvent<EventHandler,
    EventArgs>
override ScrollButtonClick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScrollingScrollButtonClick
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


Scrolling.VerticalScroll Event

ScrollingVerticalScroll Event
Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler VerticalScroll
Public Event VerticalScroll As EventHandler
public:
virtual  event EventHandler^ VerticalScroll {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VerticalScroll : IEvent<EventHandler,
    EventArgs>
override VerticalScroll : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScrollingVerticalScroll
See Also

Reference

Scrolling Class
Alternet.Editor Namespace


ScrollingButton Class

ScrollingButton Class
Represents button displayed at the scroll bar area of Edit control.
Inheritance Hierarchy
SystemObject
Alternet.EditorScrollingButton
Alternet.EditorScrollingSplitter

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute("Alternet.Design.ScrollingButtonConverter, Alternet.Editor.Design.v7")]
public class ScrollingButton : IScrollingButton,
    IDisposable
<TypeConverterAttribute("Alternet.Design.ScrollingButtonConverter, Alternet.Editor.Design.v7")>
Public Class ScrollingButton
    Implements IScrollingButton, IDisposable
[TypeConverterAttribute(L"Alternet.Design.ScrollingButtonConverter, Alternet.Editor.Design.v7")]
public ref class ScrollingButton : IScrollingButton,
    IDisposable
[<TypeConverterAttribute("Alternet.Design.ScrollingButtonConverter, Alternet.Editor.Design.v7")>]
type ScrollingButton =
    class
        interface IScrollingButton
        interface IDisposable
    end

The ScrollingButton type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollingButton | Initializes a new instance of the ScrollingButton with default settings.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another IScrollingButton object.
Public method | Dispose | Disposes this ScrollingButton and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeDescription | Indicates whether the Description property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AllowCheck | Gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked.
Public property | BorderStyle | Gets or sets the border style for this ScrollingButton.
Public property | Button | Represents windowed control that appears as a button.
Public property | Checked | Gets or sets a boolean value indicating whether button appears pressed.
Public property | Description | Gets or sets a string value that specifies short description of this ScrollingButton.
Public property | GroupIndex | Gets or sets a value allows buttons to work together as a group.
Public property | ImageIndex | Gets or sets the index of the image displayed for this ScrollingButton.
Public property | Images | Gets or sets the ImageList for this ScrollingButton.
Public property | ImagesHighDpi | Gets or sets the ImageList for high DPI for this ScrollingButton.
Public property | Name | Gets or sets a string value that specifies the name of this ScrollingButton.
Public property | Scrolling | Gets or sets IScrolling contains this button.
Public property | Visible | Gets or sets a value indicating whether this ScrollingButton is visible.
Top
Events
 | Name | Description
Public event | CheckedChanged | Occurs when the value of the Checked property changes.
Top
See Also

Reference

Alternet.Editor Namespace


ScrollingButton Constructor

ScrollingButton Constructor
Initializes a new instance of the ScrollingButton with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScrollingButton()
Public Sub New
public:
ScrollingButton()
new : unit -> ScrollingButton
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton Methods

ScrollingButton Methods

The ScrollingButton type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another IScrollingButton object.
Public method | Dispose | Disposes this ScrollingButton and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeDescription | Indicates whether the Description property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.Assign Method

ScrollingButtonAssign Method
Copies the contents of another IScrollingButton object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IScrollingButton source
)
Public Overridable Sub Assign (
    source As IScrollingButton
)
public:
virtual void Assign(
    IScrollingButton^ source
)
abstract Assign :
        source : IScrollingButton -> unit
override Assign :
        source : IScrollingButton -> unit

Parameters

source
Type: Alternet.EditorIScrollingButton
Specifies IScrollingButton to assign.

Implements

IScrollingButtonAssign(IScrollingButton)
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.Dispose Method

ScrollingButtonDispose Method
Disposes this ScrollingButton and frees resources associated with it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.ShouldSerializeDescription Method

ScrollingButtonShouldSerializeDescription Method
Indicates whether the Description property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeDescription()
Public Function ShouldSerializeDescription As Boolean
public:
bool ShouldSerializeDescription()
member ShouldSerializeDescription : unit -> bool

Return Value

Type: Boolean
True if Description differs from its default value; otherwise false.
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton Properties

ScrollingButton Properties

The ScrollingButton type exposes the following members.

Properties
 | Name | Description
Public property | AllowCheck | Gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked.
Public property | BorderStyle | Gets or sets the border style for this ScrollingButton.
Public property | Button | Represents windowed control that appears as a button.
Public property | Checked | Gets or sets a boolean value indicating whether button appears pressed.
Public property | Description | Gets or sets a string value that specifies short description of this ScrollingButton.
Public property | GroupIndex | Gets or sets a value allows buttons to work together as a group.
Public property | ImageIndex | Gets or sets the index of the image displayed for this ScrollingButton.
Public property | Images | Gets or sets the ImageList for this ScrollingButton.
Public property | ImagesHighDpi | Gets or sets the ImageList for high DPI for this ScrollingButton.
Public property | Name | Gets or sets a string value that specifies the name of this ScrollingButton.
Public property | Scrolling | Gets or sets IScrolling contains this button.
Public property | Visible | Gets or sets a value indicating whether this ScrollingButton is visible.
Top
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.AllowCheck Property

ScrollingButtonAllowCheck Property
Gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AllowCheck { get; set; }
Public Overridable Property AllowCheck As Boolean
    Get
    Set
public:
virtual property bool AllowCheck {
    bool get ();
    void set (bool value);
}
abstract AllowCheck : bool with get, set
override AllowCheck : bool with get, set

Property Value

Type: Boolean

Implements

IScrollingButtonAllowCheck
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.BorderStyle Property

ScrollingButtonBorderStyle Property
Gets or sets the border style for this ScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual EditBorderStyle BorderStyle { get; set; }
Public Overridable Property BorderStyle As EditBorderStyle
    Get
    Set
public:
virtual property EditBorderStyle BorderStyle {
    EditBorderStyle get ();
    void set (EditBorderStyle value);
}
abstract BorderStyle : EditBorderStyle with get, set
override BorderStyle : EditBorderStyle with get, set

Property Value

Type: EditBorderStyle

Implements

IScrollingButtonBorderStyle
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.Button Property

ScrollingButtonButton Property
Represents windowed control that appears as a button.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SpeedButton Button { get; }
Public Overridable ReadOnly Property Button As SpeedButton
    Get
public:
virtual property SpeedButton^ Button {
    SpeedButton^ get ();
}
abstract Button : SpeedButton with get
override Button : SpeedButton with get

Property Value

Type: SpeedButton

Implements

IScrollingButtonButton
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.Checked Property

ScrollingButtonChecked Property
Gets or sets a boolean value indicating whether button appears pressed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Checked { get; set; }
Public Overridable Property Checked As Boolean
    Get
    Set
public:
virtual property bool Checked {
    bool get ();
    void set (bool value);
}
abstract Checked : bool with get, set
override Checked : bool with get, set

Property Value

Type: Boolean

Implements

IScrollingButtonChecked
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.Description Property

ScrollingButtonDescription Property
Gets or sets a string value that specifies short description of this ScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

IScrollingButtonDescription
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.GroupIndex Property

ScrollingButtonGroupIndex Property
Gets or sets a value allows buttons to work together as a group.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GroupIndex { get; set; }
Public Overridable Property GroupIndex As Integer
    Get
    Set
public:
virtual property int GroupIndex {
    int get ();
    void set (int value);
}
abstract GroupIndex : int with get, set
override GroupIndex : int with get, set

Property Value

Type: Int32

Implements

IScrollingButtonGroupIndex
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.ImageIndex Property

ScrollingButtonImageIndex Property
Gets or sets the index of the image displayed for this ScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ImageIndex { get; set; }
Public Overridable Property ImageIndex As Integer
    Get
    Set
public:
virtual property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set
override ImageIndex : int with get, set

Property Value

Type: Int32

Implements

IScrollingButtonImageIndex
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.Images Property

ScrollingButtonImages Property
Gets or sets the ImageList for this ScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList Images { get; set; }
Public Overridable Property Images As ImageList
    Get
    Set
public:
virtual property ImageList^ Images {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract Images : ImageList with get, set
override Images : ImageList with get, set

Property Value

Type: ImageList

Implements

IScrollingButtonImages
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.ImagesHighDpi Property

ScrollingButtonImagesHighDpi Property
Gets or sets the ImageList for high DPI for this ScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList ImagesHighDpi { get; set; }
Public Overridable Property ImagesHighDpi As ImageList
    Get
    Set
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract ImagesHighDpi : ImageList with get, set
override ImagesHighDpi : ImageList with get, set

Property Value

Type: ImageList

Implements

IScrollingButtonImagesHighDpi
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.Name Property

ScrollingButtonName Property
Gets or sets a string value that specifies the name of this ScrollingButton.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IScrollingButtonName
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.Scrolling Property

ScrollingButtonScrolling Property
Gets or sets IScrolling contains this button.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScrolling Scrolling { get; set; }
Public Property Scrolling As IScrolling
    Get
    Set
public:
virtual property IScrolling^ Scrolling {
    IScrolling^ get () sealed;
    void set (IScrolling^ value) sealed;
}
abstract Scrolling : IScrolling with get, set
override Scrolling : IScrolling with get, set

Property Value

Type: IScrolling

Implements

IScrollingButtonScrolling
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.Visible Property

ScrollingButtonVisible Property
Gets or sets a value indicating whether this ScrollingButton is visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Visible { get; set; }
Public Overridable Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

IScrollingButtonVisible
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton Events

ScrollingButton Events

The ScrollingButton type exposes the following members.

Events
 | Name | Description
Public event | CheckedChanged | Occurs when the value of the Checked property changes.
Top
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButton.CheckedChanged Event

ScrollingButtonCheckedChanged Event
Occurs when the value of the Checked property changes.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler CheckedChanged
Public Event CheckedChanged As EventHandler
public:
 event EventHandler^ CheckedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CheckedChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ScrollingButton Class
Alternet.Editor Namespace


ScrollingButtons Class

ScrollingButtons Class
Represents collection of IScrollingButton objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIScrollingButton
Alternet.EditorScrollingButtons

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ScrollingButtons : List<IScrollingButton>,
    IScrollingButtons, IList<IScrollingButton>, ICollection<IScrollingButton>,
    IEnumerable<IScrollingButton>, IEnumerable
<SerializableAttribute>
Public Class ScrollingButtons
    Inherits List(Of IScrollingButton)
    Implements IScrollingButtons, IList(Of IScrollingButton),
    ICollection(Of IScrollingButton), IEnumerable(Of IScrollingButton), IEnumerable
[SerializableAttribute]
public ref class ScrollingButtons : public List<IScrollingButton^>,
    IScrollingButtons, IList<IScrollingButton^>, ICollection<IScrollingButton^>,
    IEnumerable<IScrollingButton^>, IEnumerable
[<SerializableAttribute>]
type ScrollingButtons =
    class
        inherit List<IScrollingButton>
        interface IScrollingButtons
        interface IList<IScrollingButton>
        interface ICollection<IScrollingButton>
        interface IEnumerable<IScrollingButton>
        interface IEnumerable
    end

The ScrollingButtons type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollingButtons | Initializes a new instance of the ScrollingButtons class with default settings.
Public method | ScrollingButtons(IScrolling, ISyntaxEdit) | Initializes a new instance of the ScrollingButtons class with specified owner.
Top
Methods
 | Name | Description
Public method | Add | Adds a new button to the collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIScrollingButton .)
Public method | AddScrollingButton | Adds a new button to the collection.
Public method | AddScrollingButton(String, String, Int32) | Adds a new button with specified properties to the collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIScrollingButton .)
Public method | Assign | Copies the contents of another IScrollingButtons object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIScrollingButton .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIScrollingButton .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIScrollingButton .)
Public method | Clear | Removes all buttons from the button collection.
Public method | ClearButtons | Clears entire collection.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIScrollingButton .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIScrollingButton .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIScrollingButton .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIScrollingButton .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIScrollingButton .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIScrollingButton .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIScrollingButton .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIScrollingButton .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIScrollingButton .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIScrollingButton .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIScrollingButton .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIScrollingButton .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIScrollingButton .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIScrollingButton .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIScrollingButton .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIScrollingButton .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIScrollingButton .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIScrollingButton .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIScrollingButton .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIScrollingButton .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIScrollingButton .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIScrollingButton .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIScrollingButton .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIScrollingButton .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIScrollingButton .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIScrollingButton .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIScrollingButton .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIScrollingButton .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIScrollingButton .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIScrollingButton .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIScrollingButton .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIScrollingButton .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIScrollingButton .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIScrollingButton | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIScrollingButton | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIScrollingButton, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIScrollingButton .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIScrollingButton .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIScrollingButton .)
Top
See Also

Reference

Alternet.Editor Namespace


ScrollingButtons Constructor

ScrollingButtons Constructor
Overload List
 | Name | Description
Public method | ScrollingButtons | Initializes a new instance of the ScrollingButtons class with default settings.
Public method | ScrollingButtons(IScrolling, ISyntaxEdit) | Initializes a new instance of the ScrollingButtons class with specified owner.
Top
See Also

Reference

ScrollingButtons Class
Alternet.Editor Namespace


ScrollingButtons Constructor

ScrollingButtons Constructor
Initializes a new instance of the ScrollingButtons class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScrollingButtons()
Public Sub New
public:
ScrollingButtons()
new : unit -> ScrollingButtons
See Also

Reference

ScrollingButtons Class
ScrollingButtons Overload
Alternet.Editor Namespace


ScrollingButtons Constructor (IScrolling, ISyntaxEdit)

ScrollingButtons Constructor (IScrolling, ISyntaxEdit)
Initializes a new instance of the ScrollingButtons class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScrollingButtons(
    IScrolling scrolling,
    ISyntaxEdit owner
)
Public Sub New (
    scrolling As IScrolling,
    owner As ISyntaxEdit
)
public:
ScrollingButtons(
    IScrolling^ scrolling,
    ISyntaxEdit^ owner
)
new :
        scrolling : IScrolling *
        owner : ISyntaxEdit -> ScrollingButtons

Parameters

scrolling
Type: Alternet.EditorIScrolling
IScrolling that owns this new instance.
owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit container of scrolling.
See Also

Reference

ScrollingButtons Class
ScrollingButtons Overload
Alternet.Editor Namespace


ScrollingButtons Methods

ScrollingButtons Methods

The ScrollingButtons type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new button to the collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIScrollingButton .)
Public method | AddScrollingButton | Adds a new button to the collection.
Public method | AddScrollingButton(String, String, Int32) | Adds a new button with specified properties to the collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIScrollingButton .)
Public method | Assign | Copies the contents of another IScrollingButtons object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIScrollingButton .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIScrollingButton .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIScrollingButton .)
Public method | Clear | Removes all buttons from the button collection.
Public method | ClearButtons | Clears entire collection.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIScrollingButton .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIScrollingButton .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIScrollingButton .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIScrollingButton .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIScrollingButton .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIScrollingButton .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIScrollingButton .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIScrollingButton .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIScrollingButton .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIScrollingButton .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIScrollingButton .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIScrollingButton .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIScrollingButton .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIScrollingButton .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIScrollingButton .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIScrollingButton .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIScrollingButton .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIScrollingButton .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIScrollingButton .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIScrollingButton .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIScrollingButton .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIScrollingButton .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIScrollingButton .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIScrollingButton .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIScrollingButton .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIScrollingButton .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIScrollingButton .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIScrollingButton .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIScrollingButton .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIScrollingButton .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIScrollingButton .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIScrollingButton .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIScrollingButton .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIScrollingButton .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIScrollingButton | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIScrollingButton | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIScrollingButton, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ScrollingButtons Class
Alternet.Editor Namespace


ScrollingButtons.Add Method

ScrollingButtonsAdd Method
Adds a new button to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    IScrollingButton item
)
Public Overridable Sub Add (
    item As IScrollingButton
)
public:
virtual void Add(
    IScrollingButton^ item
)
abstract Add :
        item : IScrollingButton -> unit
override Add :
        item : IScrollingButton -> unit

Parameters

item
Type: Alternet.EditorIScrollingButton
Button to add.

Implements

IScrollingButtonsAdd(IScrollingButton)
ICollectionTAdd(T)
See Also

Reference

ScrollingButtons Class
Alternet.Editor Namespace


ScrollingButtons.AddScrollingButton Method

ScrollingButtonsAddScrollingButton Method
Overload List
 | Name | Description
Public method | AddScrollingButton | Adds a new button to the collection.
Public method | AddScrollingButton(String, String, Int32) | Adds a new button with specified properties to the collection.
Top
See Also

Reference

ScrollingButtons Class
Alternet.Editor Namespace


ScrollingButtons.AddScrollingButton Method

ScrollingButtonsAddScrollingButton Method
Adds a new button to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AddScrollingButton()
Public Overridable Function AddScrollingButton As Integer
public:
virtual int AddScrollingButton()
abstract AddScrollingButton : unit -> int
override AddScrollingButton : unit -> int

Return Value

Type: Int32
Index of the added button.

Implements

IScrollingButtonsAddScrollingButton
See Also

Reference

ScrollingButtons Class
AddScrollingButton Overload
Alternet.Editor Namespace


ScrollingButtons.AddScrollingButton Method (String, String, Int32)

ScrollingButtonsAddScrollingButton Method (String, String, Int32)
Adds a new button with specified properties to the collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AddScrollingButton(
    string name,
    string description,
    int imageIndex
)
Public Overridable Function AddScrollingButton (
    name As String,
    description As String,
    imageIndex As Integer
) As Integer
public:
virtual int AddScrollingButton(
    String^ name,
    String^ description,
    int imageIndex
)
abstract AddScrollingButton :
        name : string *
        description : string *
        imageIndex : int -> int
override AddScrollingButton :
        name : string *
        description : string *
        imageIndex : int -> int

Parameters

name
Type: SystemString
Specifies button name.
description
Type: SystemString
Specifies button description.
imageIndex
Type: SystemInt32
Specifies index of button image.

Return Value

Type: Int32
Index of the added button.

Implements

IScrollingButtonsAddScrollingButton(String, String, Int32)
See Also

Reference

ScrollingButtons Class
AddScrollingButton Overload
Alternet.Editor Namespace


ScrollingButtons.Assign Method

ScrollingButtonsAssign Method
Copies the contents of another IScrollingButtons object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IScrollingButtons source
)
Public Overridable Sub Assign (
    source As IScrollingButtons
)
public:
virtual void Assign(
    IScrollingButtons^ source
)
abstract Assign :
        source : IScrollingButtons -> unit
override Assign :
        source : IScrollingButtons -> unit

Parameters

source
Type: Alternet.EditorIScrollingButtons
Specifies IScrollingButtons to assign.

Implements

IScrollingButtonsAssign(IScrollingButtons)
See Also

Reference

ScrollingButtons Class
Alternet.Editor Namespace


ScrollingButtons.Clear Method

ScrollingButtonsClear Method
Removes all buttons from the button collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

ScrollingButtons Class
Alternet.Editor Namespace


ScrollingButtons.ClearButtons Method

ScrollingButtonsClearButtons Method
Clears entire collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearButtons()
Public Sub ClearButtons
public:
virtual void ClearButtons() sealed
abstract ClearButtons : unit -> unit
override ClearButtons : unit -> unit

Implements

IScrollingButtonsClearButtons
See Also

Reference

ScrollingButtons Class
Alternet.Editor Namespace


ScrollingButtons Properties

ScrollingButtons Properties

The ScrollingButtons type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIScrollingButton .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIScrollingButton .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIScrollingButton .)
Top
See Also

Reference

ScrollingButtons Class
Alternet.Editor Namespace


ScrollingOptions Enumeration

ScrollingOptions Enumeration
Defines scrolling behaviour. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ScrollingOptions
<FlagsAttribute>
Public Enumeration ScrollingOptions
[FlagsAttribute]
public enum class ScrollingOptions
[<FlagsAttribute>]
type ScrollingOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
SmoothScroll | 1 | Specifies that Edit control should reposition immediately while user tracking the thumb.
ShowScrollHint | 2 | Specifies that control should display hint text in the popup window when user tracking the thumb.
UseScrollDelta | 4 | Specifies that horizontal scrolling should scroll client area at the several characters rather than one character when caret is at the right border.
SystemScrollbars | 8 | Specifies that Edit control should use system scroll bars rather than scrollbar controls.
FlatScrollbars | 16 | Specifies that scroll bars appears in flat style.
AllowSplitHorz | 32 | Allows user to split Edit control horizontally. This options works only if SystemScrollBars is off and control has Dock property set to DockStyle.Fill.
AllowSplitVert | 64 | Allows user to split Edit control vertically. This options works only if SystemScrollBars is off and control has Dock property set to DockStyle.Fill.
HorzButtons | 128 | Specifies that scroll bars should display a collection of horizontal buttons at the left side of the horizontal scroll bar. This options works only if SystemScrollBars is off.
VertButtons | 256 | Specifies that scroll bars should display a collection of vertical buttons at the bottom side of vertical scroll bar. This options works only if SystemScrollBars is off.
ScrollByPixels | 512 | Specifies that scroll bars should calculate their size using pixels rather than characters.
VerticalScrollBarAnnotations | 1024 | Specifies that annotations should be drawn over vertical scroll bar.
See Also

Reference

Alternet.Editor Namespace


ScrollingSplitter Class

ScrollingSplitter Class
Represents scrolling button that appears as splitter.
Inheritance Hierarchy
SystemObject
Alternet.EditorScrollingButton
Alternet.EditorScrollingSplitter

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScrollingSplitter : ScrollingButton
Public Class ScrollingSplitter
    Inherits ScrollingButton
public ref class ScrollingSplitter : public ScrollingButton
type ScrollingSplitter =
    class
        inherit ScrollingButton
    end

The ScrollingSplitter type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollingSplitter | Initializes a new instance of the ScrollSplitter class with default settings.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another IScrollingButton object. (Inherited from ScrollingButton.)
Public method | Dispose | Disposes this ScrollingButton and frees resources associated with it. (Inherited from ScrollingButton.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeDescription | Indicates whether the Description property should be persisted. (Inherited from ScrollingButton.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AllowCheck | Gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked. (Inherited from ScrollingButton.)
Public property | BorderStyle | Gets or sets the border style for this ScrollingButton. (Inherited from ScrollingButton.)
Public property | Button | Represents windowed control that appears as a button. (Inherited from ScrollingButton.)
Public property | Checked | Gets or sets a boolean value indicating whether button appears pressed. (Inherited from ScrollingButton.)
Public property | Description | Gets or sets a string value that specifies short description of this ScrollingButton. (Inherited from ScrollingButton.)
Public property | GroupIndex | Gets or sets a value allows buttons to work together as a group. (Inherited from ScrollingButton.)
Public property | ImageIndex | Gets or sets the index of the image displayed for this ScrollingButton. (Inherited from ScrollingButton.)
Public property | Images | Gets or sets the ImageList for this ScrollingButton. (Inherited from ScrollingButton.)
Public property | ImagesHighDpi | Gets or sets the ImageList for high DPI for this ScrollingButton. (Inherited from ScrollingButton.)
Public property | Name | Gets or sets a string value that specifies the name of this ScrollingButton. (Inherited from ScrollingButton.)
Public property | Scrolling | Gets or sets IScrolling contains this button. (Inherited from ScrollingButton.)
Public property | Visible | Gets or sets a value indicating whether this ScrollingButton is visible. (Inherited from ScrollingButton.)
Top
Events
 | Name | Description
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from ScrollingButton.)
Top
See Also

Reference

Alternet.Editor Namespace


ScrollingSplitter Constructor

ScrollingSplitter Constructor
Initializes a new instance of the ScrollSplitter class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScrollingSplitter()
Public Sub New
public:
ScrollingSplitter()
new : unit -> ScrollingSplitter
See Also

Reference

ScrollingSplitter Class
Alternet.Editor Namespace


ScrollingSplitter Methods

ScrollingSplitter Methods

The ScrollingSplitter type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another IScrollingButton object. (Inherited from ScrollingButton.)
Public method | Dispose | Disposes this ScrollingButton and frees resources associated with it. (Inherited from ScrollingButton.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeDescription | Indicates whether the Description property should be persisted. (Inherited from ScrollingButton.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScrollingSplitter Class
Alternet.Editor Namespace


ScrollingSplitter Properties

ScrollingSplitter Properties

The ScrollingSplitter type exposes the following members.

Properties
 | Name | Description
Public property | AllowCheck | Gets or sets a value indicating whether button should automatically appear pressed in and not pressed in when clicked. (Inherited from ScrollingButton.)
Public property | BorderStyle | Gets or sets the border style for this ScrollingButton. (Inherited from ScrollingButton.)
Public property | Button | Represents windowed control that appears as a button. (Inherited from ScrollingButton.)
Public property | Checked | Gets or sets a boolean value indicating whether button appears pressed. (Inherited from ScrollingButton.)
Public property | Description | Gets or sets a string value that specifies short description of this ScrollingButton. (Inherited from ScrollingButton.)
Public property | GroupIndex | Gets or sets a value allows buttons to work together as a group. (Inherited from ScrollingButton.)
Public property | ImageIndex | Gets or sets the index of the image displayed for this ScrollingButton. (Inherited from ScrollingButton.)
Public property | Images | Gets or sets the ImageList for this ScrollingButton. (Inherited from ScrollingButton.)
Public property | ImagesHighDpi | Gets or sets the ImageList for high DPI for this ScrollingButton. (Inherited from ScrollingButton.)
Public property | Name | Gets or sets a string value that specifies the name of this ScrollingButton. (Inherited from ScrollingButton.)
Public property | Scrolling | Gets or sets IScrolling contains this button. (Inherited from ScrollingButton.)
Public property | Visible | Gets or sets a value indicating whether this ScrollingButton is visible. (Inherited from ScrollingButton.)
Top
See Also

Reference

ScrollingSplitter Class
Alternet.Editor Namespace


ScrollingSplitter Events

ScrollingSplitter Events

The ScrollingSplitter type exposes the following members.

Events
 | Name | Description
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from ScrollingButton.)
Top
See Also

Reference

ScrollingSplitter Class
Alternet.Editor Namespace


Selection Class

Selection Class
Represents class used to manage selected part of the Edit control's text content.
Inheritance Hierarchy
SystemObject
Alternet.EditorSelection

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Selection : ISelection, IDisposable
Public Class Selection
    Implements ISelection, IDisposable
public ref class Selection : ISelection,
    IDisposable
type Selection =
    class
        interface ISelection
        interface IDisposable
    end

The Selection type exposes the following members.

Constructors
 | Name | Description
Public method | Selection | Initializes a new instance of the Selection class with default settings.
Public method | Selection(ISyntaxEdit) | Initializes a new instance of the Selection class with specified owner.
Top
Methods
 | Name | Description
Public method | ApplyTextChanges | Applies text changes to the text.
Public method | Assign | Copies the contents from another ISelection object.
Public method | BeginUpdate | Prevents the Selection updating until the EndUpdate method is called.
Public method | CanCopy | Indicates whether selected text can be copied to clipboard.
Public method | CanCut | Indicates whether selected text can be cut to the clipboard.
Public method | CanDelete | Indicates whether selected text can be deleted.
Public method | CanDrag | Indicates whether control can drag selected text.
Public method | CanPaste | Indicates whether control can paste some text from the clipboard.
Public method | Capitalize | Changes first character of all words in selected text to upper-case and all another characters to lower-case.
Public method | ChangeBlock(StringEvent) | Changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent) | Changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(StringEvent, Boolean, Boolean) | Changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent, Boolean, Boolean) | Changes selected text by applying specified event to every line in the selected text.
Public method | CharTransponse | Transposes character under the caret with the next character.
Public method | Clear | Makes selection empty, without deleting its content.
Public method | CollapseToDefinitions | Collapses and expands some outline section to get a quick overall view of the Edit content.
Public method | CommentSelection | Marks the selected text as a comment, using the correct comment syntax for the programming language.
Public method | Copy | Copies SelectedText to the Clipboard.
Public method | Cut | Cuts SelectedText to the Clipboard.
Public method | CutLine | Cuts current line to the clipboard if no text selected; otherwise cuts selected text.
Public method | Delete | Deletes selected text from the control.
Public method | Delete(ExtendedSelectionScope) | When implemented by a class, deletes selected text from the control.
Public method | DeleteLeft | Deletes one character left to the cursor.
Public method | DeleteLine | Deletes current line if no text selected; otherwise deletes selected text.
Public method | DeleteRight | Deletes one character right to the cursor.
Public method | DeleteWhiteSpace | Removes all space and tab characters from selected text. If nothing is selected the method removes space and tab characters from the current line.
Public method | DeleteWordLeft | Deletes one word left to the cursor.
Public method | DeleteWordRight | Deletes one word right to the cursor.
Public method | Dispose | Disposes this Selection and frees resources associated with it.
Public method | DragTo | Moves or copies selected text to the specified position.
Public method | EndSelection | Stops selection.
Public method | EndUpdate | Re-enables selection updating turned off by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSelectionForLine | Sets left and right index of the first and last selected characters within specified line.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Indent | Indents the selected text by one indentation level, inserting Tab or spaces to the beginning of the line.
Public method | InsertString | Inserts given text to the control's content deleting selected text if needed.
Public method | Invalidate | Invalidates a selection region of the editor control and causes a paint message to be sent to the editor control.
Public method | IsPosInSelection(Point) | Indicates whether given position located within the selected region.
Public method | IsPosInSelection(Int32, Int32) | Indicates whether given position located within the selected region.
Public method | IsValidSelectionPoint | Indicates whether specified position located at the top-left or right-bottom corners of selection area.
Public method | LineTransponse | Transposes line under the caret with the next line.
Public method | LowerCase | Converts all selected characters to the lower-case.
Public method | Modified | Responds on any modifications in the editor.
Public method | Move | Moves or copies selected text to the specified position.
Public method | NewLine | Inserts a line break at the current position of the control.
Public method | NewLineAbove | Inserts a line break above the current position of the control.
Public method | NewLineBelow | Inserts a line break below the current position of the control.
Public method | OnSelect | Selects part of text source settings. Reserved for internal use.
Public method | OnSelectionChanged | Raises SelectionChanged event.
Public method | Paste | Pastes content of the Clipboard to the Edit control, replacing selected text if needed.
Public method | PositionChanged | Responds on changing position in the editor.
Public method | ProcessEscape | Processes escape pressure: method deselects selected text.
Public method | ProcessShiftTab | Moves current position to the previous tab stop if the selected text is empty; otherwise unindents selected text.
Public method | ProcessTab | Inserts new tab character or spaces if the selected text is empty; otherwise indents selected text.
Public method | ResetAllowedSelectionMode | Resets the AllowedSelectionMode to the default value.
Public method | ResetBackColor | Resets the BackColor to the default value.
Public method | ResetBorderColor | Resets the BorderColor to the default value.
Public method | ResetForeColor | Resets the ForeColor to the default value.
Public method | ResetInActiveBackColor | Resets the InActiveBackColor to the default value.
Public method | ResetInActiveForeColor | Resets the InActiveForeColor to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ScrollIfNeeded | Scrolls to specified position if needed.
Public method | SelectAll | Selects all lines in the control's content.
Public method | SelectCharLeft | Increases selected text to one character at the left side of the selection region.
Public method | SelectCharLeft(SelectionType) | Increases selected text to one character at the left side of the selection region and sets a given selection type.
Public method | SelectCharRight | Increases selected text to one character at the right side of the selection region.
Public method | SelectCharRight(SelectionType) | Increases selected text to one character at the right side of the selection region and sets a given selection type.
Public method | SelectCurrentWord | Tries to select word nearest to the current position in the control.
Public method | SelectedCount | Returns amount of the lines being selected.
Public method | SelectedData | Returns selected part of color information at specified position.
Public method | SelectedString | Returns selected part of string at specified position.
Public method | SelectFileBegin | Increases selected text to beginning of the control's content.
Public method | SelectFileBegin(SelectionType) | Increases selected text to beginning of the control's content and sets a given selection type.
Public method | SelectFileEnd | Increases selected text to end of the control's content.
Public method | SelectFileEnd(SelectionType) | Increases selected text to end of the control's content and sets a given selection type.
Public method | SelectionToScreen | Represents selection region in a screen coordinates.
Public method | SelectionToTextPoint | Converts given selection coordinate to the text coordinate.
Public method | SelectLine | Selects entire line at the current position in the control.
Public method | SelectLineBegin | Selects from current position to the beginning of current line in the control.
Public method | SelectLineBegin(SelectionType) | Selects from current position to the beginning of current line in the control and sets a given selection type.
Public method | SelectLineDown | Increases selected text to the following line in the control.
Public method | SelectLineDown(SelectionType) | Increases selected text to the following line in the control and sets a given selection type.
Public method | SelectLineEnd | Selects from current position to the end of current line in the control.
Public method | SelectLineEnd(SelectionType) | Selects from current position to the end of current line in the control and sets a given selection type.
Public method | SelectLineOnTrippleClick | Selects entire line at the current position in the control as a result of triple click.
Public method | SelectLineUp | Increases selected text to the preceding line in the control.
Public method | SelectLineUp(SelectionType) | Increases selected text to the preceding line in the control and sets a given selection type.
Public method | SelectNextWord | Select word next to the current word.
Public method | SelectPageDown | Increases selected text to the one page down in the control.
Public method | SelectPageDown(SelectionType) | Increases selected text to the one page down in the control and sets a given selection type.
Public method | SelectPageUp | Increases selected text to the one page up in the control.
Public method | SelectPageUp(SelectionType) | Increases selected text to the one page up in the control and sets a given selection type.
Public method | SelectScreenBottom | Increases selected text to the end of screen.
Public method | SelectScreenBottom(SelectionType) | Increases selected text to the end of the screen and sets a given selection type.
Public method | SelectScreenTop | Increases selected text to the begin of screen.
Public method | SelectScreenTop(SelectionType) | Increases selected text to the begin of the screen and sets a given selection type.
Public method | SelectToBrace | Increases selected text to the next open or closing brace.
Public method | SelectToCloseBrace | Increases selected text to the next closing brace.
Public method | SelectToOpenBrace | Increases selected text to the prev open brace.
Public method | SelectWord | Selects word at the current position in the control.
Public method | SelectWordLeft | Increases selected text to the word located at the left side of the current position in the control.
Public method | SelectWordLeft(SelectionType) | Increases selected text to the word located at the left side of the current position in the control and sets a given selection type.
Public method | SelectWordRight | Increases selected text to the word located at the right side of the current position in the control.
Public method | SelectWordRight(SelectionType) | Increases selected text to the word located at the right side of the current position in the control and sets a given selection type.
Public method | SetSelectedText(String, SelectionType) | Replaces SelectedText by specified text.
Public method | SetSelectedText(String, SelectionType, Boolean) | Replaces SelectedText by specified text.
Public method | SetSelection(SelectionType, Rectangle) | Sets new selection region with specified selection type.
Public method | SetSelection(SelectionType, Point, Point) | Sets new selection region with specified selection type.
Public method | ShouldSerializeAllowedSelectionMode | Indicates whether the AllowedSelectionMode property should be persisted.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor property should be persisted.
Public method | ShouldSerializeBorderColor | Indicates whether the BorderColor property should be persisted.
Public method | ShouldSerializeForeColor | Indicates whether the FontColor property should be persisted.
Public method | ShouldSerializeInActiveBackColor | Indicates whether the InActiveBackColor property should be persisted.
Public method | ShouldSerializeInActiveForeColor | Indicates whether the InActiveForeColor property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | SmartFormat | Formats selected text using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormat(Char) | Formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies Character being typed
Public method | SmartFormat(Int32) | Formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormatBlock | Formats current syntax block using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormatDocument | Formats entire document using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartIndent | Positions the cursor to the line indentation level, obtained from parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent option when user presses Enter.
Public method | SmartIndent(Char) | Formats given current line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies character being typed
Public method | StartSelection | Forces selection start.
Public method | SwapAnchor | Change current position from beginning of selection rectangle to the end of selection rectangle or vice versa.
Public method | Tabify | Converts spaces to tabs in the current string within the selected area according to tab settings.
Public method | TextToSelectionPoint | Converts given text coordinate to the selection coordinate.
Public method | ToggleOutlining | Toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOverWrite | Toggles the control's overwrite mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UncommentSelection | Removes the comment syntax from the selected text.
Public method | UnIndent | Unindents the selected text by one indentation level, deleting Tab or spaces from the beginning of the line.
Public method | UnTabify | Converts tabs to spaces in the current string within the selected area according to tab settings.
Public method | UpdateSelection | Invalidates selected region.
Public method | UpdateSelRange | Updates selection start and end to the specified position.
Public method | UpdateSelStart(Boolean) | Updates selection start to the specified position.
Public method | UpdateSelStart(Point) | Updates selection start to the specified position.
Public method | UpperCase | Converts all selected characters to the upper-case.
Public method | WordTransponse | Transposes word under the caret with the next word.
Top
Fields
Name | Description
MaxChangesCount |
Top
Properties
 | Name | Description
Public property | AllowedSelectionMode | Gets or sets type of selection allowed to Edit control content.
Public property | BackColor | Gets or sets a background color of the SelectedText when owner control has input focus.
Public property | BorderColor | Gets or sets a color of the selection border.
Public property | ForeColor | Gets or sets a foreground color of the SelectedText when owner control has input focus.
Public property | InActiveBackColor | Gets or sets a background color of the SelectedText when owner control does not have input focus.
Public property | InActiveForeColor | Gets or sets a foreground color of the SelectedText when owner control does not have input focus.
Public property | IsEmpty | Indicates whether nothing is selected.
Public property | Options | Gets or sets options determining behaviour or the Selection.
Public property | SelectedColorData | Gets or sets strings that corresponds to selected part of the control's text content.
Public property | SelectedText | Gets or sets strings that corresponds to selected part of the control's text content.
Public property | SelectionLength | Gets or sets length of the SelectedText.
Public property | SelectionRect | Gets or sets rectangular area indicating selected text of the control.
Public property | SelectionStart | Gets or sets the position of the first selected character while text considered as a single string.
Public property | SelectionState | Gets or sets a value indicates state of the selected text.
Public property | SelectionType | Gets or sets type of current selection.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
Events
 | Name | Description
Public event | SelectionChanged | Occurs when selection bounds are changed.
Top
See Also

Reference

Alternet.Editor Namespace


Selection Constructor

Selection Constructor
Overload List
 | Name | Description
Public method | Selection | Initializes a new instance of the Selection class with default settings.
Public method | Selection(ISyntaxEdit) | Initializes a new instance of the Selection class with specified owner.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection Constructor

Selection Constructor
Initializes a new instance of the Selection class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Selection()
Public Sub New
public:
Selection()
new : unit -> Selection
See Also

Reference

Selection Class
Selection Overload
Alternet.Editor Namespace


Selection Constructor (ISyntaxEdit)

Selection Constructor (ISyntaxEdit)
Initializes a new instance of the Selection class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Selection(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
Selection(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> Selection

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

Selection Class
Selection Overload
Alternet.Editor Namespace


Selection Fields

Selection Fields

The Selection type exposes the following members.

Fields
Name | Description
MaxChangesCount |
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.MaxChangesCount Field

SelectionMaxChangesCount Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int MaxChangesCount
Public Const MaxChangesCount As Integer
public:
literal int MaxChangesCount
static val mutable MaxChangesCount: int

Field Value

Type: Int32
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection Methods

Selection Methods

The Selection type exposes the following members.

Methods
 | Name | Description
Public method | ApplyTextChanges | Applies text changes to the text.
Public method | Assign | Copies the contents from another ISelection object.
Public method | BeginUpdate | Prevents the Selection updating until the EndUpdate method is called.
Public method | CanCopy | Indicates whether selected text can be copied to clipboard.
Public method | CanCut | Indicates whether selected text can be cut to the clipboard.
Public method | CanDelete | Indicates whether selected text can be deleted.
Public method | CanDrag | Indicates whether control can drag selected text.
Public method | CanPaste | Indicates whether control can paste some text from the clipboard.
Public method | Capitalize | Changes first character of all words in selected text to upper-case and all another characters to lower-case.
Public method | ChangeBlock(StringEvent) | Changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent) | Changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(StringEvent, Boolean, Boolean) | Changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent, Boolean, Boolean) | Changes selected text by applying specified event to every line in the selected text.
Public method | CharTransponse | Transposes character under the caret with the next character.
Public method | Clear | Makes selection empty, without deleting its content.
Public method | CollapseToDefinitions | Collapses and expands some outline section to get a quick overall view of the Edit content.
Public method | CommentSelection | Marks the selected text as a comment, using the correct comment syntax for the programming language.
Public method | Copy | Copies SelectedText to the Clipboard.
Public method | Cut | Cuts SelectedText to the Clipboard.
Public method | CutLine | Cuts current line to the clipboard if no text selected; otherwise cuts selected text.
Public method | Delete | Deletes selected text from the control.
Public method | Delete(ExtendedSelectionScope) | When implemented by a class, deletes selected text from the control.
Public method | DeleteLeft | Deletes one character left to the cursor.
Public method | DeleteLine | Deletes current line if no text selected; otherwise deletes selected text.
Public method | DeleteRight | Deletes one character right to the cursor.
Public method | DeleteWhiteSpace | Removes all space and tab characters from selected text. If nothing is selected the method removes space and tab characters from the current line.
Public method | DeleteWordLeft | Deletes one word left to the cursor.
Public method | DeleteWordRight | Deletes one word right to the cursor.
Public method | Dispose | Disposes this Selection and frees resources associated with it.
Public method | DragTo | Moves or copies selected text to the specified position.
Public method | EndSelection | Stops selection.
Public method | EndUpdate | Re-enables selection updating turned off by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSelectionForLine | Sets left and right index of the first and last selected characters within specified line.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Indent | Indents the selected text by one indentation level, inserting Tab or spaces to the beginning of the line.
Public method | InsertString | Inserts given text to the control's content deleting selected text if needed.
Public method | Invalidate | Invalidates a selection region of the editor control and causes a paint message to be sent to the editor control.
Public method | IsPosInSelection(Point) | Indicates whether given position located within the selected region.
Public method | IsPosInSelection(Int32, Int32) | Indicates whether given position located within the selected region.
Public method | IsValidSelectionPoint | Indicates whether specified position located at the top-left or right-bottom corners of selection area.
Public method | LineTransponse | Transposes line under the caret with the next line.
Public method | LowerCase | Converts all selected characters to the lower-case.
Public method | Modified | Responds on any modifications in the editor.
Public method | Move | Moves or copies selected text to the specified position.
Public method | NewLine | Inserts a line break at the current position of the control.
Public method | NewLineAbove | Inserts a line break above the current position of the control.
Public method | NewLineBelow | Inserts a line break below the current position of the control.
Public method | OnSelect | Selects part of text source settings. Reserved for internal use.
Public method | OnSelectionChanged | Raises SelectionChanged event.
Public method | Paste | Pastes content of the Clipboard to the Edit control, replacing selected text if needed.
Public method | PositionChanged | Responds on changing position in the editor.
Public method | ProcessEscape | Processes escape pressure: method deselects selected text.
Public method | ProcessShiftTab | Moves current position to the previous tab stop if the selected text is empty; otherwise unindents selected text.
Public method | ProcessTab | Inserts new tab character or spaces if the selected text is empty; otherwise indents selected text.
Public method | ResetAllowedSelectionMode | Resets the AllowedSelectionMode to the default value.
Public method | ResetBackColor | Resets the BackColor to the default value.
Public method | ResetBorderColor | Resets the BorderColor to the default value.
Public method | ResetForeColor | Resets the ForeColor to the default value.
Public method | ResetInActiveBackColor | Resets the InActiveBackColor to the default value.
Public method | ResetInActiveForeColor | Resets the InActiveForeColor to the default value.
Public method | ResetOptions | Resets the Options to the default value.
Public method | ScrollIfNeeded | Scrolls to specified position if needed.
Public method | SelectAll | Selects all lines in the control's content.
Public method | SelectCharLeft | Increases selected text to one character at the left side of the selection region.
Public method | SelectCharLeft(SelectionType) | Increases selected text to one character at the left side of the selection region and sets a given selection type.
Public method | SelectCharRight | Increases selected text to one character at the right side of the selection region.
Public method | SelectCharRight(SelectionType) | Increases selected text to one character at the right side of the selection region and sets a given selection type.
Public method | SelectCurrentWord | Tries to select word nearest to the current position in the control.
Public method | SelectedCount | Returns amount of the lines being selected.
Public method | SelectedData | Returns selected part of color information at specified position.
Public method | SelectedString | Returns selected part of string at specified position.
Public method | SelectFileBegin | Increases selected text to beginning of the control's content.
Public method | SelectFileBegin(SelectionType) | Increases selected text to beginning of the control's content and sets a given selection type.
Public method | SelectFileEnd | Increases selected text to end of the control's content.
Public method | SelectFileEnd(SelectionType) | Increases selected text to end of the control's content and sets a given selection type.
Public method | SelectionToScreen | Represents selection region in a screen coordinates.
Public method | SelectionToTextPoint | Converts given selection coordinate to the text coordinate.
Public method | SelectLine | Selects entire line at the current position in the control.
Public method | SelectLineBegin | Selects from current position to the beginning of current line in the control.
Public method | SelectLineBegin(SelectionType) | Selects from current position to the beginning of current line in the control and sets a given selection type.
Public method | SelectLineDown | Increases selected text to the following line in the control.
Public method | SelectLineDown(SelectionType) | Increases selected text to the following line in the control and sets a given selection type.
Public method | SelectLineEnd | Selects from current position to the end of current line in the control.
Public method | SelectLineEnd(SelectionType) | Selects from current position to the end of current line in the control and sets a given selection type.
Public method | SelectLineOnTrippleClick | Selects entire line at the current position in the control as a result of triple click.
Public method | SelectLineUp | Increases selected text to the preceding line in the control.
Public method | SelectLineUp(SelectionType) | Increases selected text to the preceding line in the control and sets a given selection type.
Public method | SelectNextWord | Select word next to the current word.
Public method | SelectPageDown | Increases selected text to the one page down in the control.
Public method | SelectPageDown(SelectionType) | Increases selected text to the one page down in the control and sets a given selection type.
Public method | SelectPageUp | Increases selected text to the one page up in the control.
Public method | SelectPageUp(SelectionType) | Increases selected text to the one page up in the control and sets a given selection type.
Public method | SelectScreenBottom | Increases selected text to the end of screen.
Public method | SelectScreenBottom(SelectionType) | Increases selected text to the end of the screen and sets a given selection type.
Public method | SelectScreenTop | Increases selected text to the begin of screen.
Public method | SelectScreenTop(SelectionType) | Increases selected text to the begin of the screen and sets a given selection type.
Public method | SelectToBrace | Increases selected text to the next open or closing brace.
Public method | SelectToCloseBrace | Increases selected text to the next closing brace.
Public method | SelectToOpenBrace | Increases selected text to the prev open brace.
Public method | SelectWord | Selects word at the current position in the control.
Public method | SelectWordLeft | Increases selected text to the word located at the left side of the current position in the control.
Public method | SelectWordLeft(SelectionType) | Increases selected text to the word located at the left side of the current position in the control and sets a given selection type.
Public method | SelectWordRight | Increases selected text to the word located at the right side of the current position in the control.
Public method | SelectWordRight(SelectionType) | Increases selected text to the word located at the right side of the current position in the control and sets a given selection type.
Public method | SetSelectedText(String, SelectionType) | Replaces SelectedText by specified text.
Public method | SetSelectedText(String, SelectionType, Boolean) | Replaces SelectedText by specified text.
Public method | SetSelection(SelectionType, Rectangle) | Sets new selection region with specified selection type.
Public method | SetSelection(SelectionType, Point, Point) | Sets new selection region with specified selection type.
Public method | ShouldSerializeAllowedSelectionMode | Indicates whether the AllowedSelectionMode property should be persisted.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor property should be persisted.
Public method | ShouldSerializeBorderColor | Indicates whether the BorderColor property should be persisted.
Public method | ShouldSerializeForeColor | Indicates whether the FontColor property should be persisted.
Public method | ShouldSerializeInActiveBackColor | Indicates whether the InActiveBackColor property should be persisted.
Public method | ShouldSerializeInActiveForeColor | Indicates whether the InActiveForeColor property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | SmartFormat | Formats selected text using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormat(Char) | Formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies Character being typed
Public method | SmartFormat(Int32) | Formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormatBlock | Formats current syntax block using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormatDocument | Formats entire document using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartIndent | Positions the cursor to the line indentation level, obtained from parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent option when user presses Enter.
Public method | SmartIndent(Char) | Formats given current line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies character being typed
Public method | StartSelection | Forces selection start.
Public method | SwapAnchor | Change current position from beginning of selection rectangle to the end of selection rectangle or vice versa.
Public method | Tabify | Converts spaces to tabs in the current string within the selected area according to tab settings.
Public method | TextToSelectionPoint | Converts given text coordinate to the selection coordinate.
Public method | ToggleOutlining | Toggles expanded state for all IOutlineRange objects in outline collection.
Public method | ToggleOverWrite | Toggles the control's overwrite mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UncommentSelection | Removes the comment syntax from the selected text.
Public method | UnIndent | Unindents the selected text by one indentation level, deleting Tab or spaces from the beginning of the line.
Public method | UnTabify | Converts tabs to spaces in the current string within the selected area according to tab settings.
Public method | UpdateSelection | Invalidates selected region.
Public method | UpdateSelRange | Updates selection start and end to the specified position.
Public method | UpdateSelStart(Boolean) | Updates selection start to the specified position.
Public method | UpdateSelStart(Point) | Updates selection start to the specified position.
Public method | UpperCase | Converts all selected characters to the upper-case.
Public method | WordTransponse | Transposes word under the caret with the next word.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ApplyTextChanges Method

SelectionApplyTextChanges Method
Applies text changes to the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ApplyTextChanges(
    IList<ITextUndo> textChanges,
    bool format
)
Public Overridable Sub ApplyTextChanges (
    textChanges As IList(Of ITextUndo),
    format As Boolean
)
public:
virtual void ApplyTextChanges(
    IList<ITextUndo^>^ textChanges,
    bool format
)
abstract ApplyTextChanges :
        textChanges : IList<ITextUndo> *
        format : bool -> unit
override ApplyTextChanges :
        textChanges : IList<ITextUndo> *
        format : bool -> unit

Parameters

textChanges
Type: System.Collections.GenericIListITextUndo
List of text changes
format
Type: SystemBoolean
Specifies if inserted block needs to be formatted.

Implements

ISelectionApplyTextChanges(IListITextUndo, Boolean)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Assign Method

SelectionAssign Method
Copies the contents from another ISelection object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ISelection source
)
Public Overridable Sub Assign (
    source As ISelection
)
public:
virtual void Assign(
    ISelection^ source
)
abstract Assign :
        source : ISelection -> unit
override Assign :
        source : ISelection -> unit

Parameters

source
Type: Alternet.EditorISelection
Specifies ISelection to assign.

Implements

ISelectionAssign(ISelection)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.BeginUpdate Method

SelectionBeginUpdate Method
Prevents the Selection updating until the EndUpdate method is called.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of update locks.

Implements

ISelectionBeginUpdate
See Also

Reference

Selection Class
Alternet.Editor Namespace
SelectionEndUpdate


Selection.CanCopy Method

SelectionCanCopy Method
Indicates whether selected text can be copied to clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanCopy()
Public Overridable Function CanCopy As Boolean
public:
virtual bool CanCopy()
abstract CanCopy : unit -> bool
override CanCopy : unit -> bool

Return Value

Type: Boolean
True if the selection is not empty; otherwise false.

Implements

ISelectionCanCopy
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.CanCut Method

SelectionCanCut Method
Indicates whether selected text can be cut to the clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanCut()
Public Overridable Function CanCut As Boolean
public:
virtual bool CanCut()
abstract CanCut : unit -> bool
override CanCut : unit -> bool

Return Value

Type: Boolean
True if the selection can be cut; otherwise false.

Implements

ISelectionCanCut
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.CanDelete Method

SelectionCanDelete Method
Indicates whether selected text can be deleted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanDelete()
Public Overridable Function CanDelete As Boolean
public:
virtual bool CanDelete()
abstract CanDelete : unit -> bool
override CanDelete : unit -> bool

Return Value

Type: Boolean
True if the selection can be deleted; otherwise false.

Implements

ISelectionCanDelete
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.CanDrag Method

SelectionCanDrag Method
Indicates whether control can drag selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanDrag(
    Point position
)
Public Overridable Function CanDrag (
    position As Point
) As Boolean
public:
virtual bool CanDrag(
    Point position
)
abstract CanDrag :
        position : Point -> bool
override CanDrag :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies destination position of drag operation.

Return Value

Type: Boolean
True if the control can drag selected text; otherwise false.

Implements

ISelectionCanDrag(Point)
Remarks
Control must not be in the read-only state to allow dragging selected text.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.CanPaste Method

SelectionCanPaste Method
Indicates whether control can paste some text from the clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanPaste()
Public Overridable Function CanPaste As Boolean
public:
virtual bool CanPaste()
abstract CanPaste : unit -> bool
override CanPaste : unit -> bool

Return Value

Type: Boolean
True if the Clipboard has some text or unicode text.

Implements

ISelectionCanPaste
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Capitalize Method

SelectionCapitalize Method
Changes first character of all words in selected text to upper-case and all another characters to lower-case.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Capitalize()
Public Overridable Sub Capitalize
public:
virtual void Capitalize()
abstract Capitalize : unit -> unit
override Capitalize : unit -> unit

Implements

ISelectionCapitalize
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ChangeBlock Method

SelectionChangeBlock Method
Overload List
 | Name | Description
Public method | ChangeBlock(StringEvent) | Changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent) | Changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(StringEvent, Boolean, Boolean) | Changes selected text by applying specified event to every line in the selected text.
Public method | ChangeBlock(TextUndoEvent, Boolean, Boolean) | Changes selected text by applying specified event to every line in the selected text.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ChangeBlock Method (StringEvent)

SelectionChangeBlock Method (StringEvent)
Changes selected text by applying specified event to every line in the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ChangeBlock(
    StringEvent action
)
Public Overridable Sub ChangeBlock (
    action As StringEvent
)
public:
virtual void ChangeBlock(
    StringEvent^ action
)
abstract ChangeBlock :
        action : StringEvent -> unit
override ChangeBlock :
        action : StringEvent -> unit

Parameters

action
Type: Alternet.EditorStringEvent
Specifies action to execute.

Implements

ISelectionChangeBlock(StringEvent)
See Also

Reference

Selection Class
ChangeBlock Overload
Alternet.Editor Namespace


Selection.ChangeBlock Method (TextUndoEvent)

SelectionChangeBlock Method (TextUndoEvent)
Changes selected text by applying specified event to every line in the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ChangeBlock(
    TextUndoEvent action
)
Public Overridable Sub ChangeBlock (
    action As TextUndoEvent
)
public:
virtual void ChangeBlock(
    TextUndoEvent^ action
)
abstract ChangeBlock :
        action : TextUndoEvent -> unit
override ChangeBlock :
        action : TextUndoEvent -> unit

Parameters

action
Type: Alternet.EditorTextUndoEvent
Specifies action to execute.

Implements

ISelectionChangeBlock(TextUndoEvent)
See Also

Reference

Selection Class
ChangeBlock Overload
Alternet.Editor Namespace


Selection.ChangeBlock Method (StringEvent, Boolean, Boolean)

SelectionChangeBlock Method (StringEvent, Boolean, Boolean)
Changes selected text by applying specified event to every line in the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ChangeBlock(
    StringEvent action,
    bool changeIfEmpty,
    bool extendFirstLine
)
Public Overridable Sub ChangeBlock (
    action As StringEvent,
    changeIfEmpty As Boolean,
    extendFirstLine As Boolean
)
public:
virtual void ChangeBlock(
    StringEvent^ action,
    bool changeIfEmpty,
    bool extendFirstLine
)
abstract ChangeBlock :
        action : StringEvent *
        changeIfEmpty : bool *
        extendFirstLine : bool -> unit
override ChangeBlock :
        action : StringEvent *
        changeIfEmpty : bool *
        extendFirstLine : bool -> unit

Parameters

action
Type: Alternet.EditorStringEvent
Specifies action to execute.
changeIfEmpty
Type: SystemBoolean
Indicates that action should be performed for current line if selection is empty.
extendFirstLine
Type: SystemBoolean
Specifies that action should applied to whole lines in the selected region rather than to the selected portion of the line.

Implements

ISelectionChangeBlock(StringEvent, Boolean, Boolean)
See Also

Reference

Selection Class
ChangeBlock Overload
Alternet.Editor Namespace


Selection.ChangeBlock Method (TextUndoEvent, Boolean, Boolean)

SelectionChangeBlock Method (TextUndoEvent, Boolean, Boolean)
Changes selected text by applying specified event to every line in the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ChangeBlock(
    TextUndoEvent action,
    bool changeIfEmpty,
    bool extendFirstLine
)
Public Overridable Sub ChangeBlock (
    action As TextUndoEvent,
    changeIfEmpty As Boolean,
    extendFirstLine As Boolean
)
public:
virtual void ChangeBlock(
    TextUndoEvent^ action,
    bool changeIfEmpty,
    bool extendFirstLine
)
abstract ChangeBlock :
        action : TextUndoEvent *
        changeIfEmpty : bool *
        extendFirstLine : bool -> unit
override ChangeBlock :
        action : TextUndoEvent *
        changeIfEmpty : bool *
        extendFirstLine : bool -> unit

Parameters

action
Type: Alternet.EditorTextUndoEvent
Specifies action to execute.
changeIfEmpty
Type: SystemBoolean
Indicates that action should be performed for current line if selection is empty.
extendFirstLine
Type: SystemBoolean
Specifies that action should applied to whole lines in the selected region rather than to the selected portion of the line.

Implements

ISelectionChangeBlock(TextUndoEvent, Boolean, Boolean)
See Also

Reference

Selection Class
ChangeBlock Overload
Alternet.Editor Namespace


Selection.CharTransponse Method

SelectionCharTransponse Method
Transposes character under the caret with the next character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CharTransponse()
Public Overridable Sub CharTransponse
public:
virtual void CharTransponse()
abstract CharTransponse : unit -> unit
override CharTransponse : unit -> unit

Implements

ISelectionCharTransponse
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Clear Method

SelectionClear Method
Makes selection empty, without deleting its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ISelectionClear
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.CollapseToDefinitions Method

SelectionCollapseToDefinitions Method
Collapses and expands some outline section to get a quick overall view of the Edit content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CollapseToDefinitions()
Public Overridable Sub CollapseToDefinitions
public:
virtual void CollapseToDefinitions()
abstract CollapseToDefinitions : unit -> unit
override CollapseToDefinitions : unit -> unit

Implements

ISelectionCollapseToDefinitions
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.CommentSelection Method

SelectionCommentSelection Method
Marks the selected text as a comment, using the correct comment syntax for the programming language.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CommentSelection()
Public Overridable Sub CommentSelection
public:
virtual void CommentSelection()
abstract CommentSelection : unit -> unit
override CommentSelection : unit -> unit

Implements

ISelectionCommentSelection
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Copy Method

SelectionCopy Method
Copies SelectedText to the Clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Copy()
Public Overridable Sub Copy
public:
virtual void Copy()
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ISelectionCopy
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Cut Method

SelectionCut Method
Cuts SelectedText to the Clipboard.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Cut()
Public Overridable Sub Cut
public:
virtual void Cut()
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ISelectionCut
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.CutLine Method

SelectionCutLine Method
Cuts current line to the clipboard if no text selected; otherwise cuts selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CutLine()
Public Overridable Sub CutLine
public:
virtual void CutLine()
abstract CutLine : unit -> unit
override CutLine : unit -> unit

Implements

ISelectionCutLine
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Delete Method

SelectionDelete Method
Overload List
 | Name | Description
Public method | Delete | Deletes selected text from the control.
Public method | Delete(ExtendedSelectionScope) | When implemented by a class, deletes selected text from the control.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Delete Method

SelectionDelete Method
Deletes selected text from the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Delete()
Public Overridable Function Delete As Boolean
public:
virtual bool Delete()
abstract Delete : unit -> bool
override Delete : unit -> bool

Return Value

Type: Boolean
True if successful.

Implements

ISelectionDelete
See Also

Reference

Selection Class
Delete Overload
Alternet.Editor Namespace


Selection.Delete Method (ExtendedSelectionScope)

SelectionDelete Method (ExtendedSelectionScope)
When implemented by a class, deletes selected text from the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Delete(
    ExtendedSelectionScope scope
)
Public Overridable Function Delete (
    scope As ExtendedSelectionScope
) As Boolean
public:
virtual bool Delete(
    ExtendedSelectionScope scope
)
abstract Delete :
        scope : ExtendedSelectionScope -> bool
override Delete :
        scope : ExtendedSelectionScope -> bool

Parameters

scope
Type: Alternet.EditorExtendedSelectionScope
Specifies extended selection scope for null-width blocks

Return Value

Type: Boolean
True if successful.

Implements

ISelectionDelete(ExtendedSelectionScope)
See Also

Reference

Selection Class
Delete Overload
Alternet.Editor Namespace


Selection.DeleteLeft Method

SelectionDeleteLeft Method
Deletes one character left to the cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteLeft()
Public Overridable Sub DeleteLeft
public:
virtual void DeleteLeft()
abstract DeleteLeft : unit -> unit
override DeleteLeft : unit -> unit

Implements

ISelectionDeleteLeft
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.DeleteLine Method

SelectionDeleteLine Method
Deletes current line if no text selected; otherwise deletes selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteLine()
Public Overridable Sub DeleteLine
public:
virtual void DeleteLine()
abstract DeleteLine : unit -> unit
override DeleteLine : unit -> unit

Implements

ISelectionDeleteLine
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.DeleteRight Method

SelectionDeleteRight Method
Deletes one character right to the cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteRight()
Public Overridable Sub DeleteRight
public:
virtual void DeleteRight()
abstract DeleteRight : unit -> unit
override DeleteRight : unit -> unit

Implements

ISelectionDeleteRight
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.DeleteWhiteSpace Method

SelectionDeleteWhiteSpace Method
Removes all space and tab characters from selected text. If nothing is selected the method removes space and tab characters from the current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteWhiteSpace()
Public Overridable Sub DeleteWhiteSpace
public:
virtual void DeleteWhiteSpace()
abstract DeleteWhiteSpace : unit -> unit
override DeleteWhiteSpace : unit -> unit

Implements

ISelectionDeleteWhiteSpace
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.DeleteWordLeft Method

SelectionDeleteWordLeft Method
Deletes one word left to the cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteWordLeft()
Public Overridable Sub DeleteWordLeft
public:
virtual void DeleteWordLeft()
abstract DeleteWordLeft : unit -> unit
override DeleteWordLeft : unit -> unit

Implements

ISelectionDeleteWordLeft
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.DeleteWordRight Method

SelectionDeleteWordRight Method
Deletes one word right to the cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteWordRight()
Public Overridable Sub DeleteWordRight
public:
virtual void DeleteWordRight()
abstract DeleteWordRight : unit -> unit
override DeleteWordRight : unit -> unit

Implements

ISelectionDeleteWordRight
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Dispose Method

SelectionDispose Method
Disposes this Selection and frees resources associated with it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.DragTo Method

SelectionDragTo Method
Moves or copies selected text to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DragTo(
    Point position,
    bool deleteOrigin
)
Public Overridable Sub DragTo (
    position As Point,
    deleteOrigin As Boolean
)
public:
virtual void DragTo(
    Point position,
    bool deleteOrigin
)
abstract DragTo :
        position : Point *
        deleteOrigin : bool -> unit
override DragTo :
        position : Point *
        deleteOrigin : bool -> unit

Parameters

position
Type: System.DrawingPoint
Position to move or copy.
deleteOrigin
Type: SystemBoolean
Indicates whether method should move or copy selected text.

Implements

ISelectionDragTo(Point, Boolean)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.EndSelection Method

SelectionEndSelection Method
Stops selection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EndSelection()
Public Sub EndSelection
public:
virtual void EndSelection() sealed
abstract EndSelection : unit -> unit
override EndSelection : unit -> unit

Implements

ISelectionEndSelection
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.EndUpdate Method

SelectionEndUpdate Method
Re-enables selection updating turned off by calling BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of update locks.

Implements

ISelectionEndUpdate
See Also

Reference

Selection Class
Alternet.Editor Namespace
SelectionBeginUpdate


Selection.GetSelectionForLine Method

SelectionGetSelectionForLine Method
Sets left and right index of the first and last selected characters within specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetSelectionForLine(
    int index,
    out int left,
    out int right
)
Public Overridable Function GetSelectionForLine (
    index As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer
) As Boolean
public:
virtual bool GetSelectionForLine(
    int index,
    [OutAttribute] int% left,
    [OutAttribute] int% right
)
abstract GetSelectionForLine :
        index : int *
        left : int byref *
        right : int byref -> bool
override GetSelectionForLine :
        index : int *
        left : int byref *
        right : int byref -> bool

Parameters

index
Type: SystemInt32
Index of line within Edit control content.
left
Type: SystemInt32
Receives index of the first selected character.
right
Type: SystemInt32
Receives index of the last selected character.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISelectionGetSelectionForLine(Int32, Int32, Int32)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Indent Method

SelectionIndent Method
Indents the selected text by one indentation level, inserting Tab or spaces to the beginning of the line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Indent()
Public Sub Indent
public:
virtual void Indent() sealed
abstract Indent : unit -> unit
override Indent : unit -> unit

Implements

ISelectionIndent
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.InsertString Method

SelectionInsertString Method
Inserts given text to the control's content deleting selected text if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void InsertString(
    string s
)
Public Overridable Sub InsertString (
    s As String
)
public:
virtual void InsertString(
    String^ s
)
abstract InsertString :
        s : string -> unit
override InsertString :
        s : string -> unit

Parameters

s
Type: SystemString
Text to insert.

Implements

ISelectionInsertString(String)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Invalidate Method

SelectionInvalidate Method
Invalidates a selection region of the editor control and causes a paint message to be sent to the editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Invalidate()
Public Overridable Sub Invalidate
public:
virtual void Invalidate()
abstract Invalidate : unit -> unit
override Invalidate : unit -> unit

Implements

ISelectionInvalidate
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.IsPosInSelection Method

SelectionIsPosInSelection Method
Overload List
 | Name | Description
Public method | IsPosInSelection(Point) | Indicates whether given position located within the selected region.
Public method | IsPosInSelection(Int32, Int32) | Indicates whether given position located within the selected region.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.IsPosInSelection Method (Point)

SelectionIsPosInSelection Method (Point)
Indicates whether given position located within the selected region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsPosInSelection(
    Point position
)
Public Overridable Function IsPosInSelection (
    position As Point
) As Boolean
public:
virtual bool IsPosInSelection(
    Point position
)
abstract IsPosInSelection :
        position : Point -> bool
override IsPosInSelection :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.

Return Value

Type: Boolean
True if position in selected region; otherwise false.

Implements

ISelectionIsPosInSelection(Point)
See Also

Reference

Selection Class
IsPosInSelection Overload
Alternet.Editor Namespace


Selection.IsPosInSelection Method (Int32, Int32)

SelectionIsPosInSelection Method (Int32, Int32)
Indicates whether given position located within the selected region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsPosInSelection(
    int x,
    int y
)
Public Overridable Function IsPosInSelection (
    x As Integer,
    y As Integer
) As Boolean
public:
virtual bool IsPosInSelection(
    int x,
    int y
)
abstract IsPosInSelection :
        x : int *
        y : int -> bool
override IsPosInSelection :
        x : int *
        y : int -> bool

Parameters

x
Type: SystemInt32
Horizontal coordinate of the position to check.
y
Type: SystemInt32
Vertical coordinate of the position to check.

Return Value

Type: Boolean
True if position in selected region; otherwise false.

Implements

ISelectionIsPosInSelection(Int32, Int32)
See Also

Reference

Selection Class
IsPosInSelection Overload
Alternet.Editor Namespace


Selection.IsValidSelectionPoint Method

SelectionIsValidSelectionPoint Method
Indicates whether specified position located at the top-left or right-bottom corners of selection area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsValidSelectionPoint(
    Point position
)
Public Overridable Function IsValidSelectionPoint (
    position As Point
) As Boolean
public:
virtual bool IsValidSelectionPoint(
    Point position
)
abstract IsValidSelectionPoint :
        position : Point -> bool
override IsValidSelectionPoint :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.

Return Value

Type: Boolean
True if specified position valid; otherwise false.

Implements

ISelectionIsValidSelectionPoint(Point)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.LineTransponse Method

SelectionLineTransponse Method
Transposes line under the caret with the next line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void LineTransponse()
Public Overridable Sub LineTransponse
public:
virtual void LineTransponse()
abstract LineTransponse : unit -> unit
override LineTransponse : unit -> unit

Implements

ISelectionLineTransponse
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.LowerCase Method

SelectionLowerCase Method
Converts all selected characters to the lower-case.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void LowerCase()
Public Overridable Sub LowerCase
public:
virtual void LowerCase()
abstract LowerCase : unit -> unit
override LowerCase : unit -> unit

Implements

ISelectionLowerCase
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Modified Method

SelectionModified Method
Responds on any modifications in the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Modified()
Public Overridable Sub Modified
public:
virtual void Modified()
abstract Modified : unit -> unit
override Modified : unit -> unit

Implements

ISelectionModified
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Move Method

SelectionMove Method
Moves or copies selected text to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Move(
    Point position,
    bool deleteOrigin
)
Public Overridable Function Move (
    position As Point,
    deleteOrigin As Boolean
) As Boolean
public:
virtual bool Move(
    Point position,
    bool deleteOrigin
)
abstract Move :
        position : Point *
        deleteOrigin : bool -> bool
override Move :
        position : Point *
        deleteOrigin : bool -> bool

Parameters

position
Type: System.DrawingPoint
Position to move or copy.
deleteOrigin
Type: SystemBoolean
Indicates whether method should move or copy selected text.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISelectionMove(Point, Boolean)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.NewLine Method

SelectionNewLine Method
Inserts a line break at the current position of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void NewLine()
Public Overridable Sub NewLine
public:
virtual void NewLine()
abstract NewLine : unit -> unit
override NewLine : unit -> unit

Implements

ISelectionNewLine
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.NewLineAbove Method

SelectionNewLineAbove Method
Inserts a line break above the current position of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void NewLineAbove()
Public Overridable Sub NewLineAbove
public:
virtual void NewLineAbove()
abstract NewLineAbove : unit -> unit
override NewLineAbove : unit -> unit

Implements

ISelectionNewLineAbove
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.NewLineBelow Method

SelectionNewLineBelow Method
Inserts a line break below the current position of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void NewLineBelow()
Public Overridable Sub NewLineBelow
public:
virtual void NewLineBelow()
abstract NewLineBelow : unit -> unit
override NewLineBelow : unit -> unit

Implements

ISelectionNewLineBelow
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.OnSelect Method

SelectionOnSelect Method
Selects part of text source settings. Reserved for internal use.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnSelect(
    Object source,
    EventArgs e
)
Public Overridable Sub OnSelect (
    source As Object,
    e As EventArgs
)
public:
virtual void OnSelect(
    Object^ source,
    EventArgs^ e
)
abstract OnSelect :
        source : Object *
        e : EventArgs -> unit
override OnSelect :
        source : Object *
        e : EventArgs -> unit

Parameters

source
Type: SystemObject
The source of the selection.
e
Type: SystemEventArgs
An EventArgs that contains the data.

Implements

ISelectionOnSelect(Object, EventArgs)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.OnSelectionChanged Method

SelectionOnSelectionChanged Method
Raises SelectionChanged event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnSelectionChanged()
Public Overridable Sub OnSelectionChanged
public:
virtual void OnSelectionChanged()
abstract OnSelectionChanged : unit -> unit
override OnSelectionChanged : unit -> unit

Implements

ISelectionOnSelectionChanged
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Paste Method

SelectionPaste Method
Pastes content of the Clipboard to the Edit control, replacing selected text if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Paste()
Public Overridable Sub Paste
public:
virtual void Paste()
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ISelectionPaste
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.PositionChanged Method

SelectionPositionChanged Method
Responds on changing position in the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
X-part of position to change.
y
Type: SystemInt32
Y-part of position to change.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Implements

ISelectionPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ProcessEscape Method

SelectionProcessEscape Method
Processes escape pressure: method deselects selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ProcessEscape()
Public Overridable Sub ProcessEscape
public:
virtual void ProcessEscape()
abstract ProcessEscape : unit -> unit
override ProcessEscape : unit -> unit

Implements

ISelectionProcessEscape
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ProcessShiftTab Method

SelectionProcessShiftTab Method
Moves current position to the previous tab stop if the selected text is empty; otherwise unindents selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ProcessShiftTab()
Public Overridable Sub ProcessShiftTab
public:
virtual void ProcessShiftTab()
abstract ProcessShiftTab : unit -> unit
override ProcessShiftTab : unit -> unit

Implements

ISelectionProcessShiftTab
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ProcessTab Method

SelectionProcessTab Method
Inserts new tab character or spaces if the selected text is empty; otherwise indents selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ProcessTab()
Public Overridable Sub ProcessTab
public:
virtual void ProcessTab()
abstract ProcessTab : unit -> unit
override ProcessTab : unit -> unit

Implements

ISelectionProcessTab
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ResetAllowedSelectionMode Method

SelectionResetAllowedSelectionMode Method
Resets the AllowedSelectionMode to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAllowedSelectionMode()
Public Overridable Sub ResetAllowedSelectionMode
public:
virtual void ResetAllowedSelectionMode()
abstract ResetAllowedSelectionMode : unit -> unit
override ResetAllowedSelectionMode : unit -> unit

Implements

ISelectionResetAllowedSelectionMode
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ResetBackColor Method

SelectionResetBackColor Method
Resets the BackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBackColor()
Public Overridable Sub ResetBackColor
public:
virtual void ResetBackColor()
abstract ResetBackColor : unit -> unit
override ResetBackColor : unit -> unit

Implements

ISelectionResetBackColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ResetBorderColor Method

SelectionResetBorderColor Method
Resets the BorderColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBorderColor()
Public Overridable Sub ResetBorderColor
public:
virtual void ResetBorderColor()
abstract ResetBorderColor : unit -> unit
override ResetBorderColor : unit -> unit

Implements

ISelectionResetBorderColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ResetForeColor Method

SelectionResetForeColor Method
Resets the ForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetForeColor()
Public Overridable Sub ResetForeColor
public:
virtual void ResetForeColor()
abstract ResetForeColor : unit -> unit
override ResetForeColor : unit -> unit

Implements

ISelectionResetForeColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ResetInActiveBackColor Method

SelectionResetInActiveBackColor Method
Resets the InActiveBackColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetInActiveBackColor()
Public Overridable Sub ResetInActiveBackColor
public:
virtual void ResetInActiveBackColor()
abstract ResetInActiveBackColor : unit -> unit
override ResetInActiveBackColor : unit -> unit

Implements

ISelectionResetInActiveBackColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ResetInActiveForeColor Method

SelectionResetInActiveForeColor Method
Resets the InActiveForeColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetInActiveForeColor()
Public Overridable Sub ResetInActiveForeColor
public:
virtual void ResetInActiveForeColor()
abstract ResetInActiveForeColor : unit -> unit
override ResetInActiveForeColor : unit -> unit

Implements

ISelectionResetInActiveForeColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ResetOptions Method

SelectionResetOptions Method
Resets the Options to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOptions()
Public Overridable Sub ResetOptions
public:
virtual void ResetOptions()
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISelectionResetOptions
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ScrollIfNeeded Method

SelectionScrollIfNeeded Method
Scrolls to specified position if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ScrollIfNeeded(
    Point pt
)
Public Overridable Function ScrollIfNeeded (
    pt As Point
) As Boolean
public:
virtual bool ScrollIfNeeded(
    Point pt
)
abstract ScrollIfNeeded :
        pt : Point -> bool
override ScrollIfNeeded :
        pt : Point -> bool

Parameters

pt
Type: System.DrawingPoint
Position to scroll.

Return Value

Type: Boolean
True if scroll needed; otherwise false.

Implements

ISelectionScrollIfNeeded(Point)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectAll Method

SelectionSelectAll Method
Selects all lines in the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectAll()
Public Overridable Sub SelectAll
public:
virtual void SelectAll()
abstract SelectAll : unit -> unit
override SelectAll : unit -> unit

Implements

ISelectionSelectAll
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectCharLeft Method

SelectionSelectCharLeft Method
Overload List
 | Name | Description
Public method | SelectCharLeft | Increases selected text to one character at the left side of the selection region.
Public method | SelectCharLeft(SelectionType) | Increases selected text to one character at the left side of the selection region and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectCharLeft Method

SelectionSelectCharLeft Method
Increases selected text to one character at the left side of the selection region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectCharLeft()
Public Overridable Sub SelectCharLeft
public:
virtual void SelectCharLeft()
abstract SelectCharLeft : unit -> unit
override SelectCharLeft : unit -> unit

Implements

ISelectionSelectCharLeft
See Also

Reference

Selection Class
SelectCharLeft Overload
Alternet.Editor Namespace


Selection.SelectCharLeft Method (SelectionType)

SelectionSelectCharLeft Method (SelectionType)
Increases selected text to one character at the left side of the selection region and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectCharLeft(
    SelectionType selectionType
)
Public Overridable Sub SelectCharLeft (
    selectionType As SelectionType
)
public:
virtual void SelectCharLeft(
    SelectionType selectionType
)
abstract SelectCharLeft :
        selectionType : SelectionType -> unit
override SelectCharLeft :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectCharLeft(SelectionType)
See Also

Reference

Selection Class
SelectCharLeft Overload
Alternet.Editor Namespace


Selection.SelectCharRight Method

SelectionSelectCharRight Method
Overload List
 | Name | Description
Public method | SelectCharRight | Increases selected text to one character at the right side of the selection region.
Public method | SelectCharRight(SelectionType) | Increases selected text to one character at the right side of the selection region and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectCharRight Method

SelectionSelectCharRight Method
Increases selected text to one character at the right side of the selection region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectCharRight()
Public Overridable Sub SelectCharRight
public:
virtual void SelectCharRight()
abstract SelectCharRight : unit -> unit
override SelectCharRight : unit -> unit

Implements

ISelectionSelectCharRight
See Also

Reference

Selection Class
SelectCharRight Overload
Alternet.Editor Namespace


Selection.SelectCharRight Method (SelectionType)

SelectionSelectCharRight Method (SelectionType)
Increases selected text to one character at the right side of the selection region and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectCharRight(
    SelectionType selectionType
)
Public Overridable Sub SelectCharRight (
    selectionType As SelectionType
)
public:
virtual void SelectCharRight(
    SelectionType selectionType
)
abstract SelectCharRight :
        selectionType : SelectionType -> unit
override SelectCharRight :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectCharRight(SelectionType)
See Also

Reference

Selection Class
SelectCharRight Overload
Alternet.Editor Namespace


Selection.SelectCurrentWord Method

SelectionSelectCurrentWord Method
Tries to select word nearest to the current position in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SelectCurrentWord()
Public Function SelectCurrentWord As Boolean
public:
bool SelectCurrentWord()
member SelectCurrentWord : unit -> bool

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectedCount Method

SelectionSelectedCount Method
Returns amount of the lines being selected.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int SelectedCount()
Public Overridable Function SelectedCount As Integer
public:
virtual int SelectedCount()
abstract SelectedCount : unit -> int
override SelectedCount : unit -> int

Return Value

Type: Int32
Number of selected lines.

Implements

ISelectionSelectedCount
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectedData Method

SelectionSelectedData Method
Returns selected part of color information at specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SelectedData(
    int index
)
Public Function SelectedData (
    index As Integer
) As String
public:
String^ SelectedData(
    int index
)
member SelectedData :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies line index.

Return Value

Type: String
Selected part of specified string.
Remarks
If selection is empty method returns null.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectedString Method

SelectionSelectedString Method
Returns selected part of string at specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string SelectedString(
    int index
)
Public Overridable Function SelectedString (
    index As Integer
) As String
public:
virtual String^ SelectedString(
    int index
)
abstract SelectedString :
        index : int -> string
override SelectedString :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies line index.

Return Value

Type: String
Selected part of specified string.

Implements

ISelectionSelectedString(Int32)
Remarks
If selection is empty method returns null.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectFileBegin Method

SelectionSelectFileBegin Method
Overload List
 | Name | Description
Public method | SelectFileBegin | Increases selected text to beginning of the control's content.
Public method | SelectFileBegin(SelectionType) | Increases selected text to beginning of the control's content and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectFileBegin Method

SelectionSelectFileBegin Method
Increases selected text to beginning of the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectFileBegin()
Public Overridable Sub SelectFileBegin
public:
virtual void SelectFileBegin()
abstract SelectFileBegin : unit -> unit
override SelectFileBegin : unit -> unit

Implements

ISelectionSelectFileBegin
See Also

Reference

Selection Class
SelectFileBegin Overload
Alternet.Editor Namespace


Selection.SelectFileBegin Method (SelectionType)

SelectionSelectFileBegin Method (SelectionType)
Increases selected text to beginning of the control's content and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectFileBegin(
    SelectionType selectionType
)
Public Overridable Sub SelectFileBegin (
    selectionType As SelectionType
)
public:
virtual void SelectFileBegin(
    SelectionType selectionType
)
abstract SelectFileBegin :
        selectionType : SelectionType -> unit
override SelectFileBegin :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectFileBegin(SelectionType)
See Also

Reference

Selection Class
SelectFileBegin Overload
Alternet.Editor Namespace


Selection.SelectFileEnd Method

SelectionSelectFileEnd Method
Overload List
 | Name | Description
Public method | SelectFileEnd | Increases selected text to end of the control's content.
Public method | SelectFileEnd(SelectionType) | Increases selected text to end of the control's content and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectFileEnd Method

SelectionSelectFileEnd Method
Increases selected text to end of the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectFileEnd()
Public Overridable Sub SelectFileEnd
public:
virtual void SelectFileEnd()
abstract SelectFileEnd : unit -> unit
override SelectFileEnd : unit -> unit

Implements

ISelectionSelectFileEnd
See Also

Reference

Selection Class
SelectFileEnd Overload
Alternet.Editor Namespace


Selection.SelectFileEnd Method (SelectionType)

SelectionSelectFileEnd Method (SelectionType)
Increases selected text to end of the control's content and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectFileEnd(
    SelectionType selectionType
)
Public Overridable Sub SelectFileEnd (
    selectionType As SelectionType
)
public:
virtual void SelectFileEnd(
    SelectionType selectionType
)
abstract SelectFileEnd :
        selectionType : SelectionType -> unit
override SelectFileEnd :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectFileEnd(SelectionType)
See Also

Reference

Selection Class
SelectFileEnd Overload
Alternet.Editor Namespace


Selection.SelectionToScreen Method

SelectionSelectionToScreen Method
Represents selection region in a screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle SelectionToScreen()
Public Overridable Function SelectionToScreen As Rectangle
public:
virtual Rectangle SelectionToScreen()
abstract SelectionToScreen : unit -> Rectangle
override SelectionToScreen : unit -> Rectangle

Return Value

Type: Rectangle
Screen coordinate rectangle corresponding to selection region.

Implements

ISelectionSelectionToScreen
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectionToTextPoint Method

SelectionSelectionToTextPoint Method
Converts given selection coordinate to the text coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point SelectionToTextPoint(
    Point position
)
Public Overridable Function SelectionToTextPoint (
    position As Point
) As Point
public:
virtual Point SelectionToTextPoint(
    Point position
)
abstract SelectionToTextPoint :
        position : Point -> Point
override SelectionToTextPoint :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The selection coordinate Point to convert.

Return Value

Type: Point
Point that represents the converted position, in text coordinates.

Implements

ISelectionSelectionToTextPoint(Point)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectLine Method

SelectionSelectLine Method
Selects entire line at the current position in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLine()
Public Overridable Sub SelectLine
public:
virtual void SelectLine()
abstract SelectLine : unit -> unit
override SelectLine : unit -> unit

Implements

ISelectionSelectLine
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectLineBegin Method

SelectionSelectLineBegin Method
Overload List
 | Name | Description
Public method | SelectLineBegin | Selects from current position to the beginning of current line in the control.
Public method | SelectLineBegin(SelectionType) | Selects from current position to the beginning of current line in the control and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectLineBegin Method

SelectionSelectLineBegin Method
Selects from current position to the beginning of current line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLineBegin()
Public Overridable Sub SelectLineBegin
public:
virtual void SelectLineBegin()
abstract SelectLineBegin : unit -> unit
override SelectLineBegin : unit -> unit

Implements

ISelectionSelectLineBegin
See Also

Reference

Selection Class
SelectLineBegin Overload
Alternet.Editor Namespace


Selection.SelectLineBegin Method (SelectionType)

SelectionSelectLineBegin Method (SelectionType)
Selects from current position to the beginning of current line in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLineBegin(
    SelectionType selectionType
)
Public Overridable Sub SelectLineBegin (
    selectionType As SelectionType
)
public:
virtual void SelectLineBegin(
    SelectionType selectionType
)
abstract SelectLineBegin :
        selectionType : SelectionType -> unit
override SelectLineBegin :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectLineBegin(SelectionType)
See Also

Reference

Selection Class
SelectLineBegin Overload
Alternet.Editor Namespace


Selection.SelectLineDown Method

SelectionSelectLineDown Method
Overload List
 | Name | Description
Public method | SelectLineDown | Increases selected text to the following line in the control.
Public method | SelectLineDown(SelectionType) | Increases selected text to the following line in the control and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectLineDown Method

SelectionSelectLineDown Method
Increases selected text to the following line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLineDown()
Public Overridable Sub SelectLineDown
public:
virtual void SelectLineDown()
abstract SelectLineDown : unit -> unit
override SelectLineDown : unit -> unit

Implements

ISelectionSelectLineDown
See Also

Reference

Selection Class
SelectLineDown Overload
Alternet.Editor Namespace


Selection.SelectLineDown Method (SelectionType)

SelectionSelectLineDown Method (SelectionType)
Increases selected text to the following line in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLineDown(
    SelectionType selectionType
)
Public Overridable Sub SelectLineDown (
    selectionType As SelectionType
)
public:
virtual void SelectLineDown(
    SelectionType selectionType
)
abstract SelectLineDown :
        selectionType : SelectionType -> unit
override SelectLineDown :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectLineDown(SelectionType)
See Also

Reference

Selection Class
SelectLineDown Overload
Alternet.Editor Namespace


Selection.SelectLineEnd Method

SelectionSelectLineEnd Method
Overload List
 | Name | Description
Public method | SelectLineEnd | Selects from current position to the end of current line in the control.
Public method | SelectLineEnd(SelectionType) | Selects from current position to the end of current line in the control and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectLineEnd Method

SelectionSelectLineEnd Method
Selects from current position to the end of current line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLineEnd()
Public Overridable Sub SelectLineEnd
public:
virtual void SelectLineEnd()
abstract SelectLineEnd : unit -> unit
override SelectLineEnd : unit -> unit

Implements

ISelectionSelectLineEnd
See Also

Reference

Selection Class
SelectLineEnd Overload
Alternet.Editor Namespace


Selection.SelectLineEnd Method (SelectionType)

SelectionSelectLineEnd Method (SelectionType)
Selects from current position to the end of current line in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLineEnd(
    SelectionType selectionType
)
Public Overridable Sub SelectLineEnd (
    selectionType As SelectionType
)
public:
virtual void SelectLineEnd(
    SelectionType selectionType
)
abstract SelectLineEnd :
        selectionType : SelectionType -> unit
override SelectLineEnd :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectLineEnd(SelectionType)
See Also

Reference

Selection Class
SelectLineEnd Overload
Alternet.Editor Namespace


Selection.SelectLineOnTrippleClick Method

SelectionSelectLineOnTrippleClick Method
Selects entire line at the current position in the control as a result of triple click.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLineOnTrippleClick()
Public Overridable Sub SelectLineOnTrippleClick
public:
virtual void SelectLineOnTrippleClick()
abstract SelectLineOnTrippleClick : unit -> unit
override SelectLineOnTrippleClick : unit -> unit

Implements

ISelectionSelectLineOnTrippleClick
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectLineUp Method

SelectionSelectLineUp Method
Overload List
 | Name | Description
Public method | SelectLineUp | Increases selected text to the preceding line in the control.
Public method | SelectLineUp(SelectionType) | Increases selected text to the preceding line in the control and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectLineUp Method

SelectionSelectLineUp Method
Increases selected text to the preceding line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLineUp()
Public Overridable Sub SelectLineUp
public:
virtual void SelectLineUp()
abstract SelectLineUp : unit -> unit
override SelectLineUp : unit -> unit

Implements

ISelectionSelectLineUp
See Also

Reference

Selection Class
SelectLineUp Overload
Alternet.Editor Namespace


Selection.SelectLineUp Method (SelectionType)

SelectionSelectLineUp Method (SelectionType)
Increases selected text to the preceding line in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectLineUp(
    SelectionType selectionType
)
Public Overridable Sub SelectLineUp (
    selectionType As SelectionType
)
public:
virtual void SelectLineUp(
    SelectionType selectionType
)
abstract SelectLineUp :
        selectionType : SelectionType -> unit
override SelectLineUp :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectLineUp(SelectionType)
See Also

Reference

Selection Class
SelectLineUp Overload
Alternet.Editor Namespace


Selection.SelectNextWord Method

SelectionSelectNextWord Method
Select word next to the current word.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SelectNextWord()
Public Function SelectNextWord As Boolean
public:
bool SelectNextWord()
member SelectNextWord : unit -> bool

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectPageDown Method

SelectionSelectPageDown Method
Overload List
 | Name | Description
Public method | SelectPageDown | Increases selected text to the one page down in the control.
Public method | SelectPageDown(SelectionType) | Increases selected text to the one page down in the control and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectPageDown Method

SelectionSelectPageDown Method
Increases selected text to the one page down in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectPageDown()
Public Overridable Sub SelectPageDown
public:
virtual void SelectPageDown()
abstract SelectPageDown : unit -> unit
override SelectPageDown : unit -> unit

Implements

ISelectionSelectPageDown
See Also

Reference

Selection Class
SelectPageDown Overload
Alternet.Editor Namespace


Selection.SelectPageDown Method (SelectionType)

SelectionSelectPageDown Method (SelectionType)
Increases selected text to the one page down in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectPageDown(
    SelectionType selectionType
)
Public Overridable Sub SelectPageDown (
    selectionType As SelectionType
)
public:
virtual void SelectPageDown(
    SelectionType selectionType
)
abstract SelectPageDown :
        selectionType : SelectionType -> unit
override SelectPageDown :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectPageDown(SelectionType)
See Also

Reference

Selection Class
SelectPageDown Overload
Alternet.Editor Namespace


Selection.SelectPageUp Method

SelectionSelectPageUp Method
Overload List
 | Name | Description
Public method | SelectPageUp | Increases selected text to the one page up in the control.
Public method | SelectPageUp(SelectionType) | Increases selected text to the one page up in the control and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectPageUp Method

SelectionSelectPageUp Method
Increases selected text to the one page up in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectPageUp()
Public Overridable Sub SelectPageUp
public:
virtual void SelectPageUp()
abstract SelectPageUp : unit -> unit
override SelectPageUp : unit -> unit

Implements

ISelectionSelectPageUp
See Also

Reference

Selection Class
SelectPageUp Overload
Alternet.Editor Namespace


Selection.SelectPageUp Method (SelectionType)

SelectionSelectPageUp Method (SelectionType)
Increases selected text to the one page up in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectPageUp(
    SelectionType selectionType
)
Public Overridable Sub SelectPageUp (
    selectionType As SelectionType
)
public:
virtual void SelectPageUp(
    SelectionType selectionType
)
abstract SelectPageUp :
        selectionType : SelectionType -> unit
override SelectPageUp :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectPageUp(SelectionType)
See Also

Reference

Selection Class
SelectPageUp Overload
Alternet.Editor Namespace


Selection.SelectScreenBottom Method

SelectionSelectScreenBottom Method
Overload List
 | Name | Description
Public method | SelectScreenBottom | Increases selected text to the end of screen.
Public method | SelectScreenBottom(SelectionType) | Increases selected text to the end of the screen and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectScreenBottom Method

SelectionSelectScreenBottom Method
Increases selected text to the end of screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectScreenBottom()
Public Overridable Sub SelectScreenBottom
public:
virtual void SelectScreenBottom()
abstract SelectScreenBottom : unit -> unit
override SelectScreenBottom : unit -> unit

Implements

ISelectionSelectScreenBottom
See Also

Reference

Selection Class
SelectScreenBottom Overload
Alternet.Editor Namespace


Selection.SelectScreenBottom Method (SelectionType)

SelectionSelectScreenBottom Method (SelectionType)
Increases selected text to the end of the screen and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectScreenBottom(
    SelectionType selectionType
)
Public Overridable Sub SelectScreenBottom (
    selectionType As SelectionType
)
public:
virtual void SelectScreenBottom(
    SelectionType selectionType
)
abstract SelectScreenBottom :
        selectionType : SelectionType -> unit
override SelectScreenBottom :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectScreenBottom(SelectionType)
See Also

Reference

Selection Class
SelectScreenBottom Overload
Alternet.Editor Namespace


Selection.SelectScreenTop Method

SelectionSelectScreenTop Method
Overload List
 | Name | Description
Public method | SelectScreenTop | Increases selected text to the begin of screen.
Public method | SelectScreenTop(SelectionType) | Increases selected text to the begin of the screen and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectScreenTop Method

SelectionSelectScreenTop Method
Increases selected text to the begin of screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectScreenTop()
Public Overridable Sub SelectScreenTop
public:
virtual void SelectScreenTop()
abstract SelectScreenTop : unit -> unit
override SelectScreenTop : unit -> unit

Implements

ISelectionSelectScreenTop
See Also

Reference

Selection Class
SelectScreenTop Overload
Alternet.Editor Namespace


Selection.SelectScreenTop Method (SelectionType)

SelectionSelectScreenTop Method (SelectionType)
Increases selected text to the begin of the screen and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectScreenTop(
    SelectionType selectionType
)
Public Overridable Sub SelectScreenTop (
    selectionType As SelectionType
)
public:
virtual void SelectScreenTop(
    SelectionType selectionType
)
abstract SelectScreenTop :
        selectionType : SelectionType -> unit
override SelectScreenTop :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectScreenTop(SelectionType)
See Also

Reference

Selection Class
SelectScreenTop Overload
Alternet.Editor Namespace


Selection.SelectToBrace Method

SelectionSelectToBrace Method
Increases selected text to the next open or closing brace.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectToBrace()
Public Overridable Sub SelectToBrace
public:
virtual void SelectToBrace()
abstract SelectToBrace : unit -> unit
override SelectToBrace : unit -> unit

Implements

ISelectionSelectToBrace
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectToCloseBrace Method

SelectionSelectToCloseBrace Method
Increases selected text to the next closing brace.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectToCloseBrace()
Public Overridable Sub SelectToCloseBrace
public:
virtual void SelectToCloseBrace()
abstract SelectToCloseBrace : unit -> unit
override SelectToCloseBrace : unit -> unit

Implements

ISelectionSelectToCloseBrace
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectToOpenBrace Method

SelectionSelectToOpenBrace Method
Increases selected text to the prev open brace.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectToOpenBrace()
Public Overridable Sub SelectToOpenBrace
public:
virtual void SelectToOpenBrace()
abstract SelectToOpenBrace : unit -> unit
override SelectToOpenBrace : unit -> unit

Implements

ISelectionSelectToOpenBrace
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectWord Method

SelectionSelectWord Method
Selects word at the current position in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectWord()
Public Overridable Sub SelectWord
public:
virtual void SelectWord()
abstract SelectWord : unit -> unit
override SelectWord : unit -> unit

Implements

ISelectionSelectWord
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectWordLeft Method

SelectionSelectWordLeft Method
Overload List
 | Name | Description
Public method | SelectWordLeft | Increases selected text to the word located at the left side of the current position in the control.
Public method | SelectWordLeft(SelectionType) | Increases selected text to the word located at the left side of the current position in the control and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectWordLeft Method

SelectionSelectWordLeft Method
Increases selected text to the word located at the left side of the current position in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectWordLeft()
Public Overridable Sub SelectWordLeft
public:
virtual void SelectWordLeft()
abstract SelectWordLeft : unit -> unit
override SelectWordLeft : unit -> unit

Implements

ISelectionSelectWordLeft
See Also

Reference

Selection Class
SelectWordLeft Overload
Alternet.Editor Namespace


Selection.SelectWordLeft Method (SelectionType)

SelectionSelectWordLeft Method (SelectionType)
Increases selected text to the word located at the left side of the current position in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectWordLeft(
    SelectionType selectionType
)
Public Overridable Sub SelectWordLeft (
    selectionType As SelectionType
)
public:
virtual void SelectWordLeft(
    SelectionType selectionType
)
abstract SelectWordLeft :
        selectionType : SelectionType -> unit
override SelectWordLeft :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectWordLeft(SelectionType)
See Also

Reference

Selection Class
SelectWordLeft Overload
Alternet.Editor Namespace


Selection.SelectWordRight Method

SelectionSelectWordRight Method
Overload List
 | Name | Description
Public method | SelectWordRight | Increases selected text to the word located at the right side of the current position in the control.
Public method | SelectWordRight(SelectionType) | Increases selected text to the word located at the right side of the current position in the control and sets a given selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectWordRight Method

SelectionSelectWordRight Method
Increases selected text to the word located at the right side of the current position in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectWordRight()
Public Overridable Sub SelectWordRight
public:
virtual void SelectWordRight()
abstract SelectWordRight : unit -> unit
override SelectWordRight : unit -> unit

Implements

ISelectionSelectWordRight
See Also

Reference

Selection Class
SelectWordRight Overload
Alternet.Editor Namespace


Selection.SelectWordRight Method (SelectionType)

SelectionSelectWordRight Method (SelectionType)
Increases selected text to the word located at the right side of the current position in the control and sets a given selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SelectWordRight(
    SelectionType selectionType
)
Public Overridable Sub SelectWordRight (
    selectionType As SelectionType
)
public:
virtual void SelectWordRight(
    SelectionType selectionType
)
abstract SelectWordRight :
        selectionType : SelectionType -> unit
override SelectWordRight :
        selectionType : SelectionType -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New type of the selection.

Implements

ISelectionSelectWordRight(SelectionType)
See Also

Reference

Selection Class
SelectWordRight Overload
Alternet.Editor Namespace


Selection.SetSelectedText Method

SelectionSetSelectedText Method
Overload List
 | Name | Description
Public method | SetSelectedText(String, SelectionType) | Replaces SelectedText by specified text.
Public method | SetSelectedText(String, SelectionType, Boolean) | Replaces SelectedText by specified text.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SetSelectedText Method (String, SelectionType)

SelectionSetSelectedText Method (String, SelectionType)
Replaces SelectedText by specified text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSelectedText(
    string text,
    SelectionType selType
)
Public Sub SetSelectedText (
    text As String,
    selType As SelectionType
)
public:
void SetSelectedText(
    String^ text,
    SelectionType selType
)
member SetSelectedText :
        text : string *
        selType : SelectionType -> unit

Parameters

text
Type: SystemString
New value of SelectedText.
selType
Type: Alternet.EditorSelectionType
New type of selection.
See Also

Reference

Selection Class
SetSelectedText Overload
Alternet.Editor Namespace


Selection.SetSelectedText Method (String, SelectionType, Boolean)

SelectionSetSelectedText Method (String, SelectionType, Boolean)
Replaces SelectedText by specified text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetSelectedText(
    string text,
    SelectionType selType,
    bool moveToEnd
)
Public Overridable Sub SetSelectedText (
    text As String,
    selType As SelectionType,
    moveToEnd As Boolean
)
public:
virtual void SetSelectedText(
    String^ text,
    SelectionType selType,
    bool moveToEnd
)
abstract SetSelectedText :
        text : string *
        selType : SelectionType *
        moveToEnd : bool -> unit
override SetSelectedText :
        text : string *
        selType : SelectionType *
        moveToEnd : bool -> unit

Parameters

text
Type: SystemString
New value of SelectedText.
selType
Type: Alternet.EditorSelectionType
New type of selection.
moveToEnd
Type: SystemBoolean
Specifies whether cursor should move to the end of the selection.
See Also

Reference

Selection Class
SetSelectedText Overload
Alternet.Editor Namespace


Selection.SetSelection Method

SelectionSetSelection Method
Overload List
 | Name | Description
Public method | SetSelection(SelectionType, Rectangle) | Sets new selection region with specified selection type.
Public method | SetSelection(SelectionType, Point, Point) | Sets new selection region with specified selection type.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SetSelection Method (SelectionType, Rectangle)

SelectionSetSelection Method (SelectionType, Rectangle)
Sets new selection region with specified selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetSelection(
    SelectionType selectionType,
    Rectangle selectionRect
)
Public Overridable Sub SetSelection (
    selectionType As SelectionType,
    selectionRect As Rectangle
)
public:
virtual void SetSelection(
    SelectionType selectionType,
    Rectangle selectionRect
)
abstract SetSelection :
        selectionType : SelectionType *
        selectionRect : Rectangle -> unit
override SetSelection :
        selectionType : SelectionType *
        selectionRect : Rectangle -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New selection type.
selectionRect
Type: System.DrawingRectangle
New selected rectangle.

Implements

ISelectionSetSelection(SelectionType, Rectangle)
See Also

Reference

Selection Class
SetSelection Overload
Alternet.Editor Namespace


Selection.SetSelection Method (SelectionType, Point, Point)

SelectionSetSelection Method (SelectionType, Point, Point)
Sets new selection region with specified selection type.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetSelection(
    SelectionType selectionType,
    Point selectionStart,
    Point selectionEnd
)
Public Overridable Sub SetSelection (
    selectionType As SelectionType,
    selectionStart As Point,
    selectionEnd As Point
)
public:
virtual void SetSelection(
    SelectionType selectionType,
    Point selectionStart,
    Point selectionEnd
)
abstract SetSelection :
        selectionType : SelectionType *
        selectionStart : Point *
        selectionEnd : Point -> unit
override SetSelection :
        selectionType : SelectionType *
        selectionStart : Point *
        selectionEnd : Point -> unit

Parameters

selectionType
Type: Alternet.EditorSelectionType
New selection type.
selectionStart
Type: System.DrawingPoint
Left-top corner of the selected rectangle.
selectionEnd
Type: System.DrawingPoint
Right-bottom corner of the selected rectangle.

Implements

ISelectionSetSelection(SelectionType, Point, Point)
See Also

Reference

Selection Class
SetSelection Overload
Alternet.Editor Namespace


Selection.ShouldSerializeAllowedSelectionMode Method

SelectionShouldSerializeAllowedSelectionMode Method
Indicates whether the AllowedSelectionMode property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeAllowedSelectionMode()
Public Function ShouldSerializeAllowedSelectionMode As Boolean
public:
bool ShouldSerializeAllowedSelectionMode()
member ShouldSerializeAllowedSelectionMode : unit -> bool

Return Value

Type: Boolean
True if AllowedSelectionMode differs from its default value; otherwise false.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ShouldSerializeBackColor Method

SelectionShouldSerializeBackColor Method
Indicates whether the BackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBackColor()
Public Function ShouldSerializeBackColor As Boolean
public:
bool ShouldSerializeBackColor()
member ShouldSerializeBackColor : unit -> bool

Return Value

Type: Boolean
True if BackColor differs from its default value; otherwise false.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ShouldSerializeBorderColor Method

SelectionShouldSerializeBorderColor Method
Indicates whether the BorderColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBorderColor()
Public Function ShouldSerializeBorderColor As Boolean
public:
bool ShouldSerializeBorderColor()
member ShouldSerializeBorderColor : unit -> bool

Return Value

Type: Boolean
True if InActiveForeColor differs from its default value; otherwise false.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ShouldSerializeForeColor Method

SelectionShouldSerializeForeColor Method
Indicates whether the FontColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeForeColor()
Public Function ShouldSerializeForeColor As Boolean
public:
bool ShouldSerializeForeColor()
member ShouldSerializeForeColor : unit -> bool

Return Value

Type: Boolean
True if FontColor differs from its default value; otherwise false.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ShouldSerializeInActiveBackColor Method

SelectionShouldSerializeInActiveBackColor Method
Indicates whether the InActiveBackColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeInActiveBackColor()
Public Function ShouldSerializeInActiveBackColor As Boolean
public:
bool ShouldSerializeInActiveBackColor()
member ShouldSerializeInActiveBackColor : unit -> bool

Return Value

Type: Boolean
True if InActiveBackColor differs from its default value; otherwise false.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ShouldSerializeInActiveForeColor Method

SelectionShouldSerializeInActiveForeColor Method
Indicates whether the InActiveForeColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeInActiveForeColor()
Public Function ShouldSerializeInActiveForeColor As Boolean
public:
bool ShouldSerializeInActiveForeColor()
member ShouldSerializeInActiveForeColor : unit -> bool

Return Value

Type: Boolean
True if InActiveForeColor differs from its default value; otherwise false.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ShouldSerializeOptions Method

SelectionShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOptions()
Public Function ShouldSerializeOptions As Boolean
public:
bool ShouldSerializeOptions()
member ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SmartFormat Method

SelectionSmartFormat Method
Overload List
 | Name | Description
Public method | SmartFormat | Formats selected text using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Public method | SmartFormat(Char) | Formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies Character being typed
Public method | SmartFormat(Int32) | Formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SmartFormat Method

SelectionSmartFormat Method
Formats selected text using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SmartFormat()
Public Overridable Sub SmartFormat
public:
virtual void SmartFormat()
abstract SmartFormat : unit -> unit
override SmartFormat : unit -> unit

Implements

ISelectionSmartFormat
See Also

Reference

Selection Class
SmartFormat Overload
Alternet.Editor Namespace


Selection.SmartFormat Method (Char)

SelectionSmartFormat Method (Char)
Formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies Character being typed

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SmartFormat(
    char ch
)
Public Overridable Function SmartFormat (
    ch As Char
) As Boolean
public:
virtual bool SmartFormat(
    wchar_t ch
)
abstract SmartFormat :
        ch : char -> bool
override SmartFormat :
        ch : char -> bool

Parameters

ch
Type: SystemChar

Return Value

Type: Boolean

Implements

ISelectionSmartFormat(Char)
See Also

Reference

Selection Class
SmartFormat Overload
Alternet.Editor Namespace


Selection.SmartFormat Method (Int32)

SelectionSmartFormat Method (Int32)
Formats given line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SmartFormat(
    int line
)
Public Overridable Sub SmartFormat (
    line As Integer
)
public:
virtual void SmartFormat(
    int line
)
abstract SmartFormat :
        line : int -> unit
override SmartFormat :
        line : int -> unit

Parameters

line
Type: SystemInt32

Implements

ISelectionSmartFormat(Int32)
See Also

Reference

Selection Class
SmartFormat Overload
Alternet.Editor Namespace


Selection.SmartFormatBlock Method

SelectionSmartFormatBlock Method
Formats current syntax block using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SmartFormatBlock(
    bool extended,
    char ch
)
Public Overridable Sub SmartFormatBlock (
    extended As Boolean,
    ch As Char
)
public:
virtual void SmartFormatBlock(
    bool extended,
    wchar_t ch
)
abstract SmartFormatBlock :
        extended : bool *
        ch : char -> unit
override SmartFormatBlock :
        extended : bool *
        ch : char -> unit

Parameters

extended
Type: SystemBoolean
Specifies that search should be extended outside current scope
ch
Type: SystemChar
Character being typed.

Implements

ISelectionSmartFormatBlock(Boolean, Char)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SmartFormatDocument Method

SelectionSmartFormatDocument Method
Formats entire document using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SmartFormatDocument()
Public Overridable Sub SmartFormatDocument
public:
virtual void SmartFormatDocument()
abstract SmartFormatDocument : unit -> unit
override SmartFormatDocument : unit -> unit

Implements

ISelectionSmartFormatDocument
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SmartIndent Method

SelectionSmartIndent Method
Overload List
 | Name | Description
Public method | SmartIndent | Positions the cursor to the line indentation level, obtained from parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent option when user presses Enter.
Public method | SmartIndent(Char) | Formats given current line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies character being typed
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SmartIndent Method

SelectionSmartIndent Method
Positions the cursor to the line indentation level, obtained from parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent option when user presses Enter.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SmartIndent()
Public Overridable Sub SmartIndent
public:
virtual void SmartIndent()
abstract SmartIndent : unit -> unit
override SmartIndent : unit -> unit

Implements

ISelectionSmartIndent
See Also

Reference

Selection Class
SmartIndent Overload
Alternet.Editor Namespace


Selection.SmartIndent Method (Char)

SelectionSmartIndent Method (Char)
Formats given current line using indentation obtained from Syntax Parser supporting Alternet.Syntax.SyntaxOptions.SmartIndent. Specifies character being typed

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SmartIndent(
    char ch
)
Public Overridable Function SmartIndent (
    ch As Char
) As Boolean
public:
virtual bool SmartIndent(
    wchar_t ch
)
abstract SmartIndent :
        ch : char -> bool
override SmartIndent :
        ch : char -> bool

Parameters

ch
Type: SystemChar

Return Value

Type: Boolean

Implements

ISelectionSmartIndent(Char)
See Also

Reference

Selection Class
SmartIndent Overload
Alternet.Editor Namespace


Selection.StartSelection Method

SelectionStartSelection Method
Forces selection start.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StartSelection()
Public Overridable Sub StartSelection
public:
virtual void StartSelection()
abstract StartSelection : unit -> unit
override StartSelection : unit -> unit

Implements

ISelectionStartSelection
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SwapAnchor Method

SelectionSwapAnchor Method
Change current position from beginning of selection rectangle to the end of selection rectangle or vice versa.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SwapAnchor()
Public Overridable Sub SwapAnchor
public:
virtual void SwapAnchor()
abstract SwapAnchor : unit -> unit
override SwapAnchor : unit -> unit

Implements

ISelectionSwapAnchor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Tabify Method

SelectionTabify Method
Converts spaces to tabs in the current string within the selected area according to tab settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Tabify()
Public Overridable Sub Tabify
public:
virtual void Tabify()
abstract Tabify : unit -> unit
override Tabify : unit -> unit

Implements

ISelectionTabify
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.TextToSelectionPoint Method

SelectionTextToSelectionPoint Method
Converts given text coordinate to the selection coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point TextToSelectionPoint(
    Point position
)
Public Overridable Function TextToSelectionPoint (
    position As Point
) As Point
public:
virtual Point TextToSelectionPoint(
    Point position
)
abstract TextToSelectionPoint :
        position : Point -> Point
override TextToSelectionPoint :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The text coordinate Point to convert.

Return Value

Type: Point
Point that represents the converted position, in selection coordinates.

Implements

ISelectionTextToSelectionPoint(Point)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ToggleOutlining Method

SelectionToggleOutlining Method
Toggles expanded state for all IOutlineRange objects in outline collection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleOutlining()
Public Overridable Sub ToggleOutlining
public:
virtual void ToggleOutlining()
abstract ToggleOutlining : unit -> unit
override ToggleOutlining : unit -> unit

Implements

ISelectionToggleOutlining
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ToggleOverWrite Method

SelectionToggleOverWrite Method
Toggles the control's overwrite mode.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleOverWrite()
Public Overridable Sub ToggleOverWrite
public:
virtual void ToggleOverWrite()
abstract ToggleOverWrite : unit -> unit
override ToggleOverWrite : unit -> unit

Implements

ISelectionToggleOverWrite
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.UncommentSelection Method

SelectionUncommentSelection Method
Removes the comment syntax from the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UncommentSelection()
Public Overridable Sub UncommentSelection
public:
virtual void UncommentSelection()
abstract UncommentSelection : unit -> unit
override UncommentSelection : unit -> unit

Implements

ISelectionUncommentSelection
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.UnIndent Method

SelectionUnIndent Method
Unindents the selected text by one indentation level, deleting Tab or spaces from the beginning of the line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnIndent()
Public Overridable Sub UnIndent
public:
virtual void UnIndent()
abstract UnIndent : unit -> unit
override UnIndent : unit -> unit

Implements

ISelectionUnIndent
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.UnTabify Method

SelectionUnTabify Method
Converts tabs to spaces in the current string within the selected area according to tab settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnTabify()
Public Overridable Sub UnTabify
public:
virtual void UnTabify()
abstract UnTabify : unit -> unit
override UnTabify : unit -> unit

Implements

ISelectionUnTabify
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.UpdateSelection Method

SelectionUpdateSelection Method
Invalidates selected region.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateSelection()
Public Overridable Sub UpdateSelection
public:
virtual void UpdateSelection()
abstract UpdateSelection : unit -> unit
override UpdateSelection : unit -> unit

Implements

ISelectionUpdateSelection
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.UpdateSelRange Method

SelectionUpdateSelRange Method
Updates selection start and end to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateSelRange(
    Point start,
    Point end
)
Public Overridable Sub UpdateSelRange (
    start As Point,
    end As Point
)
public:
virtual void UpdateSelRange(
    Point start,
    Point end
)
abstract UpdateSelRange :
        start : Point *
        end : Point -> unit
override UpdateSelRange :
        start : Point *
        end : Point -> unit

Parameters

start
Type: System.DrawingPoint
New selection start.
end
Type: System.DrawingPoint
New selection end.

Implements

ISelectionUpdateSelRange(Point, Point)
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.UpdateSelStart Method

SelectionUpdateSelStart Method
Overload List
 | Name | Description
Public method | UpdateSelStart(Boolean) | Updates selection start to the specified position.
Public method | UpdateSelStart(Point) | Updates selection start to the specified position.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.UpdateSelStart Method (Boolean)

SelectionUpdateSelStart Method (Boolean)
Updates selection start to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateSelStart(
    bool checkIfEmpty
)
Public Overridable Sub UpdateSelStart (
    checkIfEmpty As Boolean
)
public:
virtual void UpdateSelStart(
    bool checkIfEmpty
)
abstract UpdateSelStart :
        checkIfEmpty : bool -> unit
override UpdateSelStart :
        checkIfEmpty : bool -> unit

Parameters

checkIfEmpty
Type: SystemBoolean
Checks whether selection is empty.

Implements

ISelectionUpdateSelStart(Boolean)
See Also

Reference

Selection Class
UpdateSelStart Overload
Alternet.Editor Namespace


Selection.UpdateSelStart Method (Point)

SelectionUpdateSelStart Method (Point)
Updates selection start to the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateSelStart(
    Point position
)
Public Overridable Sub UpdateSelStart (
    position As Point
)
public:
virtual void UpdateSelStart(
    Point position
)
abstract UpdateSelStart :
        position : Point -> unit
override UpdateSelStart :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
New selection start.

Implements

ISelectionUpdateSelStart(Point)
See Also

Reference

Selection Class
UpdateSelStart Overload
Alternet.Editor Namespace


Selection.UpperCase Method

SelectionUpperCase Method
Converts all selected characters to the upper-case.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpperCase()
Public Overridable Sub UpperCase
public:
virtual void UpperCase()
abstract UpperCase : unit -> unit
override UpperCase : unit -> unit

Implements

ISelectionUpperCase
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.WordTransponse Method

SelectionWordTransponse Method
Transposes word under the caret with the next word.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void WordTransponse()
Public Overridable Sub WordTransponse
public:
virtual void WordTransponse()
abstract WordTransponse : unit -> unit
override WordTransponse : unit -> unit

Implements

ISelectionWordTransponse
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection Properties

Selection Properties

The Selection type exposes the following members.

Properties
 | Name | Description
Public property | AllowedSelectionMode | Gets or sets type of selection allowed to Edit control content.
Public property | BackColor | Gets or sets a background color of the SelectedText when owner control has input focus.
Public property | BorderColor | Gets or sets a color of the selection border.
Public property | ForeColor | Gets or sets a foreground color of the SelectedText when owner control has input focus.
Public property | InActiveBackColor | Gets or sets a background color of the SelectedText when owner control does not have input focus.
Public property | InActiveForeColor | Gets or sets a foreground color of the SelectedText when owner control does not have input focus.
Public property | IsEmpty | Indicates whether nothing is selected.
Public property | Options | Gets or sets options determining behaviour or the Selection.
Public property | SelectedColorData | Gets or sets strings that corresponds to selected part of the control's text content.
Public property | SelectedText | Gets or sets strings that corresponds to selected part of the control's text content.
Public property | SelectionLength | Gets or sets length of the SelectedText.
Public property | SelectionRect | Gets or sets rectangular area indicating selected text of the control.
Public property | SelectionStart | Gets or sets the position of the first selected character while text considered as a single string.
Public property | SelectionState | Gets or sets a value indicates state of the selected text.
Public property | SelectionType | Gets or sets type of current selection.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.AllowedSelectionMode Property

SelectionAllowedSelectionMode Property
Gets or sets type of selection allowed to Edit control content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual AllowedSelectionMode AllowedSelectionMode { get; set; }
Public Overridable Property AllowedSelectionMode As AllowedSelectionMode
    Get
    Set
public:
virtual property AllowedSelectionMode AllowedSelectionMode {
    AllowedSelectionMode get ();
    void set (AllowedSelectionMode value);
}
abstract AllowedSelectionMode : AllowedSelectionMode with get, set
override AllowedSelectionMode : AllowedSelectionMode with get, set

Property Value

Type: AllowedSelectionMode

Implements

ISelectionAllowedSelectionMode
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.BackColor Property

SelectionBackColor Property
Gets or sets a background color of the SelectedText when owner control has input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BackColor { get; set; }
Public Overridable Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color

Implements

ISelectionBackColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.BorderColor Property

SelectionBorderColor Property
Gets or sets a color of the selection border.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BorderColor { get; set; }
Public Overridable Property BorderColor As Color
    Get
    Set
public:
virtual property Color BorderColor {
    Color get ();
    void set (Color value);
}
abstract BorderColor : Color with get, set
override BorderColor : Color with get, set

Property Value

Type: Color

Implements

ISelectionBorderColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.ForeColor Property

SelectionForeColor Property
Gets or sets a foreground color of the SelectedText when owner control has input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ForeColor { get; set; }
Public Overridable Property ForeColor As Color
    Get
    Set
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set
override ForeColor : Color with get, set

Property Value

Type: Color

Implements

ISelectionForeColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.InActiveBackColor Property

SelectionInActiveBackColor Property
Gets or sets a background color of the SelectedText when owner control does not have input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color InActiveBackColor { get; set; }
Public Overridable Property InActiveBackColor As Color
    Get
    Set
public:
virtual property Color InActiveBackColor {
    Color get ();
    void set (Color value);
}
abstract InActiveBackColor : Color with get, set
override InActiveBackColor : Color with get, set

Property Value

Type: Color

Implements

ISelectionInActiveBackColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.InActiveForeColor Property

SelectionInActiveForeColor Property
Gets or sets a foreground color of the SelectedText when owner control does not have input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color InActiveForeColor { get; set; }
Public Overridable Property InActiveForeColor As Color
    Get
    Set
public:
virtual property Color InActiveForeColor {
    Color get ();
    void set (Color value);
}
abstract InActiveForeColor : Color with get, set
override InActiveForeColor : Color with get, set

Property Value

Type: Color

Implements

ISelectionInActiveForeColor
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.IsEmpty Property

SelectionIsEmpty Property
Indicates whether nothing is selected.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Return Value

Type: Boolean
True if empty; otherwise false.

Implements

ISelectionIsEmpty
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.Options Property

SelectionOptions Property
Gets or sets options determining behaviour or the Selection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SelectionOptions Options { get; set; }
Public Overridable Property Options As SelectionOptions
    Get
    Set
public:
virtual property SelectionOptions Options {
    SelectionOptions get ();
    void set (SelectionOptions value);
}
abstract Options : SelectionOptions with get, set
override Options : SelectionOptions with get, set

Property Value

Type: SelectionOptions

Implements

ISelectionOptions
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectedColorData Property

SelectionSelectedColorData Property
Gets or sets strings that corresponds to selected part of the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string SelectedColorData { get; }
Public Overridable ReadOnly Property SelectedColorData As String
    Get
public:
virtual property String^ SelectedColorData {
    String^ get ();
}
abstract SelectedColorData : string with get
override SelectedColorData : string with get

Property Value

Type: String

Implements

ISelectionSelectedColorData
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectedText Property

SelectionSelectedText Property
Gets or sets strings that corresponds to selected part of the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string SelectedText { get; set; }
Public Overridable Property SelectedText As String
    Get
    Set
public:
virtual property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}
abstract SelectedText : string with get, set
override SelectedText : string with get, set

Property Value

Type: String

Implements

ISelectionSelectedText
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectionLength Property

SelectionSelectionLength Property
Gets or sets length of the SelectedText.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int SelectionLength { get; set; }
Public Overridable Property SelectionLength As Integer
    Get
    Set
public:
virtual property int SelectionLength {
    int get ();
    void set (int value);
}
abstract SelectionLength : int with get, set
override SelectionLength : int with get, set

Property Value

Type: Int32

Implements

ISelectionSelectionLength
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectionRect Property

SelectionSelectionRect Property
Gets or sets rectangular area indicating selected text of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle SelectionRect { get; set; }
Public Overridable Property SelectionRect As Rectangle
    Get
    Set
public:
virtual property Rectangle SelectionRect {
    Rectangle get ();
    void set (Rectangle value);
}
abstract SelectionRect : Rectangle with get, set
override SelectionRect : Rectangle with get, set

Property Value

Type: Rectangle

Implements

ISelectionSelectionRect
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectionStart Property

SelectionSelectionStart Property
Gets or sets the position of the first selected character while text considered as a single string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int SelectionStart { get; set; }
Public Overridable Property SelectionStart As Integer
    Get
    Set
public:
virtual property int SelectionStart {
    int get ();
    void set (int value);
}
abstract SelectionStart : int with get, set
override SelectionStart : int with get, set

Property Value

Type: Int32

Implements

ISelectionSelectionStart
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectionState Property

SelectionSelectionState Property
Gets or sets a value indicates state of the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SelectionState SelectionState { get; set; }
Public Overridable Property SelectionState As SelectionState
    Get
    Set
public:
virtual property SelectionState SelectionState {
    SelectionState get ();
    void set (SelectionState value);
}
abstract SelectionState : SelectionState with get, set
override SelectionState : SelectionState with get, set

Property Value

Type: SelectionState

Implements

ISelectionSelectionState
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectionType Property

SelectionSelectionType Property
Gets or sets type of current selection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SelectionType SelectionType { get; set; }
Public Overridable Property SelectionType As SelectionType
    Get
    Set
public:
virtual property SelectionType SelectionType {
    SelectionType get ();
    void set (SelectionType value);
}
abstract SelectionType : SelectionType with get, set
override SelectionType : SelectionType with get, set

Property Value

Type: SelectionType

Implements

ISelectionSelectionType
See Also

Reference

Selection Class
Alternet.Editor Namespace
Alternet.EditorSelectionType


Selection.UpdateCount Property

SelectionUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

ISelectionUpdateCount
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection Events

Selection Events

The Selection type exposes the following members.

Events
 | Name | Description
Public event | SelectionChanged | Occurs when selection bounds are changed.
Top
See Also

Reference

Selection Class
Alternet.Editor Namespace


Selection.SelectionChanged Event

SelectionSelectionChanged Event
Occurs when selection bounds are changed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
public:
virtual  event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectionChanged : IEvent<EventHandler,
    EventArgs>
override SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISelectionSelectionChanged
See Also

Reference

Selection Class
Alternet.Editor Namespace


SelectionOptions Enumeration

SelectionOptions Enumeration
Defines appearance and behaviour of selected text. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum SelectionOptions
<FlagsAttribute>
Public Enumeration SelectionOptions
[FlagsAttribute]
public enum class SelectionOptions
[<FlagsAttribute>]
type SelectionOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
DisableSelection | 1 | Disables to select any text.
DisableDragging | 2 | Disables dragging the selected text.
SelectBeyondEol | 4 | Specifies that selection is drawn beyond end of line.
UseColors | 8 | Specifies that selection should paint preserving colors of the text fragments.
HideSelection | 16 | Specifies that selected text should be draw as unselected text when control lost focus.
SelectLineOnDblClick | 32 | Specifies that whole line should be selected instead of single word when user double clicks on some text.
DeselectOnCopy | 64 | Specifies that selection should be unselected when selected text copies to the Clipboard.
PersistentBlocks | 128 | Specifies that selected text should be retained even when the cursor is moved, until a new block is selected.
OverwriteBlocks | 256 | Specifies that selected text should be replaced of text with whatever is typed next.
SmartFormat | 512 | Specifies that selected text should be formatted according to syntax rules when pasting.
WordSelect | 1024 | Specifies that Edit control should select words instead of single characters.
DrawBorder | 2048 | Specifies that Edit control should draw border around selection.
SelectLineOnTripleClick | 4096 | Specifies that whole line should be selected when user triple clicks on some text.
DeselectOnDblClick | 8192 | Specifies that selection should be cleared by dblclick.
ConvertToSpacesOnPaste | 16384 | Specifies that selection should convert all tabs to spaces in the text being pasted when Lines.UseSpaces is on.
RtfClipboard | 32768 | Specifies that selection should copy it's content clipboard in rtf format.
ClearOnDrag | 65536 | Specifies that selection should be deleted when dragging from external source.
CopyLineWhenEmpty | 131072 | Specifies that copy and cut operation should process entire line when selection is empty.
DisableCodeSnippetOnTab | 262144 | Specifies that Edit control should not try to find and insert code snippet when tab key is pressed.
ExtendedBlockMode | 524288 | Specifies that text entered in block selection mode affects all selected lines.
SelectWordOnCtrlClick | 1048576 | Specifies that word should be selected when user clicks on some text holding Ctrl Key.
DeselectOnDrag | 2097152 | Specifies that selection should be unselected after text is dragged into the Editor.
See Also

Reference

Alternet.Editor Namespace


SelectionState Enumeration

SelectionState Enumeration
Defines state of the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectionState
Public Enumeration SelectionState
public enum class SelectionState
type SelectionState
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Drag | 1 | Specifies that selected text is dragged.
Select | 2 | Specifies that some text part is selected.
SelectWord | 3 | Specifies that Edit control tries to select words instead of single characters.
SelectLine | 4 | Specifies that Edit control tries to select lines instead of single characters.
See Also

Reference

Alternet.Editor Namespace


SelectionType Enumeration

SelectionType Enumeration
Defines type of the selection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public enum SelectionType
<SerializableAttribute>
Public Enumeration SelectionType
[SerializableAttribute]
public enum class SelectionType
[<SerializableAttribute>]
type SelectionType
Members
Member name | Value | Description
None | 0 | Specifies that no text is selected.
Stream | 1 | Specifies that selected text consists of consecutive characters.
Block | 2 | Specifies that selected text represents square block.
See Also

Reference

Alternet.Editor Namespace
Alternet.EditorAllowedSelectionMode


SeparatorOptions Enumeration

SeparatorOptions Enumeration
Specifies options for highlighting and separating lines within Edit control. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum SeparatorOptions
<FlagsAttribute>
Public Enumeration SeparatorOptions
[FlagsAttribute]
public enum class SeparatorOptions
[<FlagsAttribute>]
type SeparatorOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
HighlightCurrentLine | 1 | Specifies that current line in Edit control should be highlighted.
HideHighlighting | 2 | Specifies that current line in Edit control should not be highlighted when control looses input focus.
SeparateLines | 4 | Specifies that lines are visually separated in Edit control.
SeparateWrapLines | 8 | Specifies that Line separator is drawn between lines that are dropped due to word break procedure.
SeparateContent | 16 | Specifies that Line separator is drawn between separate sections of the text, for example between methods.
SeparateBeyondEof | 32 | Specifies that Line separator is drawn between lines beyond end of file.
See Also

Reference

Alternet.Editor Namespace


StandardVisualTheme Class

StandardVisualTheme Class
Inheritance Hierarchy
SystemObject
Alternet.EditorVisualTheme
Alternet.EditorStandardVisualTheme
Alternet.EditorDarkVisualTheme
Alternet.EditorLightVisualTheme

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class StandardVisualTheme : VisualTheme
Public MustInherit Class StandardVisualTheme
    Inherits VisualTheme
public ref class StandardVisualTheme abstract : public VisualTheme
[<AbstractClassAttribute>]
type StandardVisualTheme =
    class
        inherit VisualTheme
    end

The StandardVisualTheme type exposes the following members.

Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox | (Inherited from VisualTheme.)
Public method | ApplyToCodeCompletionHint | (Inherited from VisualTheme.)
Public method | ApplyToEdit | (Inherited from VisualTheme.)
Public method | ApplyToScrollBar | (Inherited from VisualTheme.)
Public method | ApplyToScrollingButton | (Inherited from VisualTheme.)
Public method | ApplyToSplitButton | (Inherited from VisualTheme.)
Public method | Assign | (Inherited from VisualTheme.)
Public method | Dispose | (Inherited from VisualTheme.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromEdit | (Inherited from VisualTheme.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Colors |
Public property | Font | Gets or sets the font used for the color theme. (Inherited from VisualTheme.)
Public property | ImagesColor | (Inherited from VisualTheme.)
Public property | Item | Specifies an Item indexer that uses the name of the LexStyle as an index. (Inherited from VisualTheme.)
Public property | LexStyles | Gets or sets the LexStyle array used for the color theme. (Inherited from VisualTheme.)
Public property | Name | Gets or sets the name of the color theme. (Inherited from VisualTheme.)
Public property | ReadOnly | Gets or sets a bool value that indicates whether or not the color theme should be modified. (Inherited from VisualTheme.)
Top
See Also

Reference

Alternet.Editor Namespace


StandardVisualTheme Methods

StandardVisualTheme Methods

The StandardVisualTheme type exposes the following members.

Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox | (Inherited from VisualTheme.)
Public method | ApplyToCodeCompletionHint | (Inherited from VisualTheme.)
Public method | ApplyToEdit | (Inherited from VisualTheme.)
Public method | ApplyToScrollBar | (Inherited from VisualTheme.)
Public method | ApplyToScrollingButton | (Inherited from VisualTheme.)
Public method | ApplyToSplitButton | (Inherited from VisualTheme.)
Public method | Assign | (Inherited from VisualTheme.)
Public method | Dispose | (Inherited from VisualTheme.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromEdit | (Inherited from VisualTheme.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StandardVisualTheme Class
Alternet.Editor Namespace


StandardVisualTheme Properties

StandardVisualTheme Properties

The StandardVisualTheme type exposes the following members.

Properties
 | Name | Description
Public property | Colors |
Public property | Font | Gets or sets the font used for the color theme. (Inherited from VisualTheme.)
Public property | ImagesColor | (Inherited from VisualTheme.)
Public property | Item | Specifies an Item indexer that uses the name of the LexStyle as an index. (Inherited from VisualTheme.)
Public property | LexStyles | Gets or sets the LexStyle array used for the color theme. (Inherited from VisualTheme.)
Public property | Name | Gets or sets the name of the color theme. (Inherited from VisualTheme.)
Public property | ReadOnly | Gets or sets a bool value that indicates whether or not the color theme should be modified. (Inherited from VisualTheme.)
Top
See Also

Reference

StandardVisualTheme Class
Alternet.Editor Namespace


StandardVisualTheme.Colors Property

StandardVisualThemeColors Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualThemeColors Colors { get; }
Public ReadOnly Property Colors As VisualThemeColors
    Get
public:
property VisualThemeColors^ Colors {
    VisualThemeColors^ get ();
}
member Colors : VisualThemeColors with get

Property Value

Type: VisualThemeColors
See Also

Reference

StandardVisualTheme Class
Alternet.Editor Namespace


StringEvent Delegate

StringEvent Delegate
Represents a method that will handle string replacement event inside Selection

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate string StringEvent(
    string s
)
Public Delegate Function StringEvent (
    s As String
) As String
public delegate String^ StringEvent(
    String^ s
)
type StringEvent =
    delegate of
        s : string -> string

Parameters

s
Type: SystemString
String to be replaced.

Return Value

Type: String
See Also

Reference

Alternet.Editor Namespace


SyntaxEdit Class

SyntaxEdit Class
Represents advanced multi-line Edit control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.EditorSyntaxEdit
Alternet.Editor.CommonScriptCodeEdit

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxEdit : Control, ISyntaxEdit,
    ISearch, ITextSearch, IEditNotifier, INotifier, ICaret,
    IEditNavigate, INavigate, IEdit, IUpdate, IWordWrap,
    ITextExport, IExport, ITextImport, IImport, ICodeCompletion,
    IRecordPlayBack, ISplitView, IAutoCorrect, IControl
Public Class SyntaxEdit
    Inherits Control
    Implements ISyntaxEdit, ISearch, ITextSearch, IEditNotifier,
    INotifier, ICaret, IEditNavigate, INavigate, IEdit,
    IUpdate, IWordWrap, ITextExport, IExport, ITextImport,
    IImport, ICodeCompletion, IRecordPlayBack, ISplitView, IAutoCorrect,
    IControl
public ref class SyntaxEdit : public Control,
    ISyntaxEdit, ISearch, ITextSearch, IEditNotifier, INotifier,
    ICaret, IEditNavigate, INavigate, IEdit, IUpdate,
    IWordWrap, ITextExport, IExport, ITextImport, IImport,
    ICodeCompletion, IRecordPlayBack, ISplitView, IAutoCorrect, IControl
type SyntaxEdit =
    class
        inherit Control
        interface ISyntaxEdit
        interface ISearch
        interface ITextSearch
        interface IEditNotifier
        interface INotifier
        interface ICaret
        interface IEditNavigate
        interface INavigate
        interface IEdit
        interface IUpdate
        interface IWordWrap
        interface ITextExport
        interface IExport
        interface ITextImport
        interface IImport
        interface ICodeCompletion
        interface IRecordPlayBack
        interface ISplitView
        interface IAutoCorrect
        interface IControl
    end

The SyntaxEdit type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxEdit | Initializes a new instance of the SyntaxEdit class with default settings.
Public method | SyntaxEdit(IContainer) | Initializes a new instance of the SyntaxEdit class with specified container.
Top
Methods
Name | Description
Public method ApplyTheme
Applies visual theme to the SyntaxEdit control.
Public method Assign
Assigns most relevant properties from another ISyntaxEdit object.
Public method BeginInvoke(Delegate)
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginInvoke(Delegate, Object)
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginUpdate
Prevents editor updating until calling EndUpdate method.
Public method BreakLine
Breaks current line into two lines.
Public method BringToFront
Brings the control to the front of the z-order.
(Inherited from Control.)
Public method CanFindNext
Indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
Public method CanFindNextSelected
Indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
Public method CanFindPrevious
Indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
Public method CanFindPreviousSelected
Indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
Public method CanSearchSelection
Returns whether search can be performed inside selection.
Public method CanSplitHorz
Indicates whether control can split its content horizontally.
Public method CanSplitVert
Indicates whether control can split its content vertically.
Public method CanUnsplitHorz
Indicates whether control has horizontal split view.
Public method CanUnsplitVert
Indicates whether control has vertical split view.
Public method CodeCompletion
Performs code completion for the specified text representing language element.
Public method CodeCompletionWindowFocused
Indicates whether ICodeCompletionWindow has focus.
Public method CodeSnippets
Displays a code completion window with list of available code snippets.
Public method CompleteCodeFixes
Displays a code completion window with list of available code fixes.
Public method CompleteCodeFixesOrRefactors
Displays a code completion window with list of available code fixes or code refactors.
Public method CompleteCodeRefactors
Displays a code completion window with list of available code refactors.
Public method CompleteWord
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box and locates single member, if possible.
Public method Contains
Retrieves a value indicating whether the specified control is a child of the control.
(Inherited from Control.)
Public method CreateCaret
Creates a new shape for the system caret and gets ownership of the caret.
Public method CreateControl
Forces the creation of the visible control, including the creation of the handle and any visible child controls.
(Inherited from Control.)
Public method CreateGraphics
Creates the Graphics for the control.
(Inherited from Control.)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CycledSearch
Performs cycled search.
Public method DeleteBlock
Deletes a specified block of characters.
Public method DeleteLeft
Deletes a specified number of characters to the left of the active point.
Public method DeleteRight
Deletes a specified number of characters to the right of the active point.
Public method DestroyCaret
Destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
Public method DisablePositionUpdate
Prevents notification of changing of caret position until calling EnablePositionUpdate method.
Public method DisableUpdate
Prevents editor updating until calling EnableUpdate method.
Public method DisplayDragCaret
Displays dragging caret rather than regular caret.
Public method DisplayGotoLineDialog
Initializes and runs a dialog prompting you for index of the line you need to locate.
Public method DisplayGotoLineDialog(IWin32Window)
Initializes and runs a dialog prompting you for index of the line you need to locate.
Public method DisplayModalReplaceDialog
Initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method DisplayModalReplaceDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method DisplayModalSearchDialog
Initializes and runs a modal dialog box allowing you to search for some text.
Public method DisplayModalSearchDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for some text.
Public method DisplayReplaceDialog
Initializes and runs a dialog box allowing you to search for text and replace it.
Public method DisplayReplaceDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for text and replace it.
Public method DisplaySearchDialog
Initializes and runs a dialog box allowing you to search for some text.
Public method DisplaySearchDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for some text.
Public method DisplayToScreen(Int32, Int32)
Converts given display coordinates, index of line and character, to screen coordinates.
Public method DisplayToScreen(Int32, Int32, Boolean)
Converts given display coordinates, index of line and character, to screen coordinates.
Public method Dispose
Releases all resources used by the Component.
(Inherited from Component.)
Public method DoDragDrop
Begins a drag-and-drop operation.
(Inherited from Control.)
Public method DrawToBitmap
Supports rendering to the specified bitmap.
(Inherited from Control.)
Public method EnablePositionUpdate
Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
Public method EnableUpdate
Re-enables editor updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method EndInvoke
Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
(Inherited from Control.)
Public method EndUpdate
Re-enables outline editor updating, that was turn of by calling BeginUpdate method.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method Find(String)
Searches for given text within the control's contents.
Public method Find(String, SearchOptions)
Searches for given text within the control's contents with specified options.
Public method Find(String, SearchOptions, Regex)
Searches for given text within the control's contents with specified options using specified regular expression.
Public method Find(String, SearchOptions, Regex, IListIRange)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method Find(String, SearchOptions, Regex, Boolean, Boolean)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method Find(String, SearchOptions, Regex, Point, Int32, Match)
Searches for given text within the control's text content.
Public method FindForm
Retrieves the form that the control is on.
(Inherited from Control.)
Public method FindNext
Searches for the next occurrence of the text specified by previous search.
Public method FindNextSelected
Searches for the next occurrence of the selected text.
Public method FindPrevious
Searches for the previous occurrence of the text specified by previous search.
Public method FindPreviousSelected
Searches for the previous occurrence of the selected text.
Public method FinishIncrementalSearch
Leaves control from the incremental search state.
Public method Focus
Sets input focus to the control.
(Inherited from Control.)
Public method GetCaretSize
Returns size of the caret's current shape at given position.
Public method GetCharsInWidth
Returns number of characters painted with current font that will fit into specified Width.
Public method GetChildAtPoint(Point)
Retrieves the child control that is located at the specified coordinates.
(Inherited from Control.)
Public method GetChildAtPoint(Point, GetChildAtPointSkip)
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
(Inherited from Control.)
Public method GetContainerControl
Returns the next ContainerControl up the control's chain of parent controls.
(Inherited from Control.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetHitTest(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method GetHitTest(Int32, Int32, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method GetHitTestAtTextPoint(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of control at specified text coordinate.
Public method GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo)
Retrieves information about part of control at specified text coordinate.
Public method GetIndentString
Gets indentation string at current position.
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetLinesInHeight
Determines how many lines can fit into given Height.
Public method GetNextControl
Retrieves the next control forward or back in the tab order of child controls.
(Inherited from Control.)
Public method GetPreferredSize
Retrieves the size of a rectangular area into which a control can be fitted.
(Inherited from Control.)
Public method GetTextAtCursor
Returns word at the cursor position.
Public method GetTextToSearchAtCursor
Returns word at the cursor position.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetWordAt
Checks word accordingly to specified conditions.
Public method GetWrapMargin
Returns position of the wrapping margin.
Public method HasAutoCorrection
Checks whether specified word has correction.
Public method Hide
Conceals the control from the user.
(Inherited from Control.)
Public method HideDragCaret
Hides dragging caret.
Public method HideScrollHint
Hides scroll hint window if necessary.
Public method HighlightAll
Highlights all occurrences of specified string in the class text content.
Public method IncrementalSearch
Finds given text incrementally.
Public method IndentLine
Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
Public method IndentLine(String, Boolean)
Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method Insert
Inserts the given string at the specified location.
Public method InsertBlock(String, Boolean)
Inserts the given string at the specified location.
Public method InsertBlock(String, Boolean)
Inserts the given string array at the specified location.
Public method InsertBlock(ITextStrings, Boolean)
Inserts the given string collection at the specified location.
Public method InsertBlock(String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.
Public method InsertFromFile
Inserts the file text content at the specified location.
Public method Invalidate
Invalidates the entire surface of the control and causes the control to be redrawn.
(Inherited from Control.)
Public method Invalidate(Region)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Boolean)
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Region, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invoke(Delegate)
Executes the specified delegate on the thread that owns the control's underlying window handle.
(Inherited from Control.)
Public method Invoke(Delegate, Object)
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
(Inherited from Control.)
Public method IsValidText
Indicates whether text at the specified position is valid (that is does not contain comments or string constants).
Public method KillFocus
Ensure the caret is not visible.
Public method LineIsHidden
Determines whether the given line is hidden.
Public method LineIsReadonly
Determines whether the given line is readonly.
Public method ListMembers
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box.
Public method LoadFile(String)
Loads the contents of the specified file.
Public method LoadFile(String, IStringImport)
Loads content from the given file with specified importer.
Public method LoadFile(String, Encoding)
Loads the contents of the specified file with specified encoding.
Public method LoadFile(String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.
Public method LoadMacros(Stream)
Loads the macro records from the given stream.
Public method LoadMacros(TextReader)
Loads the macro records from the given stream.
Public method LoadMacros(String)
Loads the macro records from the given file.
Public method LoadStream(Stream)
Loads the contents of the specified stream.
Public method LoadStream(TextReader)
Loads the contents of the specified stream.
Public method LoadStream(Stream, IStringImport)
Loads the text content from the given stream with specified importer.
Public method LoadStream(Stream, Encoding)
Loads the contents of the specified stream.
Public method LoadStream(TextReader, IStringImport)
Loads the contents of the specified stream.
Public method LoadStream(Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.
Public method MakeVisible(Point)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method MakeVisible(Point, Boolean)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method MarkAll(String, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method MarkAll(String, SearchOptions, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method MarkAll(String, SearchOptions, Regex, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method MoveCaretOnDrag
Moves caret to the position of drag cursor.
Public method MoveCharLeft
Moves the current position one character to the left.
Public method MoveCharRight
Moves the current position one character to the right.
Public method MoveFileBegin
Moves the current position to the first character of the first line.
Public method MoveFileEnd
Moves the current position to the last character of the last line.
Public method MoveLineBegin
Moves the current position to the first character of current line.
Public method MoveLineBeginCycled
Moves the current position to the first not whitespace character/first character of current line.
Public method MoveLineDown
Moves the current position to the next line.
Public method MoveLineEnd
Moves the current position to the last character of current line.
Public method MoveLineEndCycled
Moves the current position to the last not whitespace character/last character of current line.
Public method MoveLineUp
Moves the current position to the previous line.
Public method MovePageDown
Moves current position to the next page.
Public method MovePageUp
Moves current position to the previous page.
Public method MoveScreenBottom
Moves the current position to the bottom of the screen.
Public method MoveScreenTop
Moves the current position to the top of the screen.
Public method MoveTo(Point)
Moves the current position to the given position.
Public method MoveTo(Int32, Int32)
Moves the current position to the given position.
Public method MoveToBrace
Moves the current position to the next open or close brace in the text content.
Public method MoveToChar
Moves the current position to the specified character in current line.
Public method MoveToCloseBrace
Moves the current position to the next close brace in the text content.
Public method MoveToLine(Int32)
Moves the current position to the specified line.
Public method MoveToLine(Int32, Int32)
Moves the current position to the specified line.
Public method MoveToOpenBrace
Moves the current position to the previous open brace in the text content.
Public method MoveWordLeft
Moves the current position one word to the left.
Public method MoveWordRight
Moves the current position one word to the right.
Public method Navigate
Moves current position by the given offset value.
Public method NeedReplaceCurrent
Indicates whether search engine need to replace successfully found and selected text.
Public method NeedReplaceCurrent(Match)
Indicates whether search engine need to replace successfully found and selected text.
Public method NewLine
Inserts a line break at the current position.
Public method NewLine(String, Boolean)
Inserts a line break at the current position with indentation
Public method NewLineAbove
Inserts a line break above the current position.
Public method NewLineBelow
Inserts a line break below the current position.
Public method Notification
Updates control's content according to parameters of notification.
Public method OnStateChanged
Updates control's content according to the state of the source.
Public method OnTextFound
When implemented by a class, occurs when search text is found.
Public method OutlineText
Forces automatic outlining by getting up-to-date information about outline section from the Parser.
Public method ParameterInfo
Displays a code completion window containing information for the current method or parameter in the Editor's content.
Public method PauseMacroRecording
Suspends recording the command sequence.
Public method PerformLayout
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PerformLayout(Control, String)
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PlayBackMacro
Repeats the stored command sequence.
Public method PointToClient
Computes the location of the specified screen point into client coordinates.
(Inherited from Control.)
Public method PointToScreen
Computes the location of the specified client point into screen coordinates.
(Inherited from Control.)
Public method PositionIsReadonly
Determines whether the text at given position is readonly.
Public method PreProcessControlMessage
Preprocesses keyboard or input messages within the message loop before they are dispatched.
(Inherited from Control.)
Public method PreProcessMessage
Preprocesses input messages within the message loop before they are dispatched.
(Overrides ControlPreProcessMessage(Message).)
Public method ProcessEnter
Performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ProcessKeyMsg
Processes a keyboard message.
Public method ProcessKeyPress
Processes key press.
Public method ProcessShiftTab
Performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ProcessTab
Performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method QuickInfo
Displays a code completion window with simple tooltip information.
Public method RecordKeyData
Adds keyData to the MacroRecords array.
Public method RectangleToClient
Computes the size and location of the specified screen rectangle in client coordinates.
(Inherited from Control.)
Public method RectangleToScreen
Computes the size and location of the specified client rectangle in screen coordinates.
(Inherited from Control.)
Public method Refresh
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
(Inherited from Control.)
Public method Replace(String, String)
Searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
Public method Replace(String, String, SearchOptions)
Searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
Public method Replace(String, String, SearchOptions, Regex)
Searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
Public method ReplaceAll(String, String, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
Public method ReplaceAll(String, String, SearchOptions, Int32)
Replaces all occurrences of given text within text content by specified replaceWith string.
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean)
Replaces all occurrences of given text within class text content by specified replaceWith string.
Public method ReplaceCurrent
Replaces currently selected text.
Public method ResetAcceptReturns
Resets the AcceptReturns to the default value.
Public method ResetAcceptTabs
Resets the AcceptTabs to the default value.
Public method ResetBackColor
Resets the BackColor property to its default value.
(Inherited from Control.)
Public method ResetBindings
Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
(Inherited from Control.)
Public method ResetBorderColor
Resets the BorderColor to the default value.
Public method ResetBorderStyle
Resets the BorderStyle to the default value.
Public method ResetCursor
Resets the Cursor property to its default value.
(Overrides ControlResetCursor.)
Public method ResetFont
Resets the Font property to its default value.
(Overrides ControlResetFont.)
Public method ResetForeColor
Resets the ForeColor property to its default value.
(Inherited from Control.)
Public method ResetHideCaret
Resets the HideCaret to the default value.
Public method ResetImeMode
Resets the ImeMode property to its default value.
(Inherited from Control.)
Public method ResetIndentOptions
Resets the IndentOptions to the default value.
Public method ResetKeepCaretOnLostFocus
Resets the KeepCaretOnLostFocus to the default value.
Public method ResetLineSpace
Resets the LineSpace to the default value.
Public method ResetMaxLength
Resets the MaxLength to the default value.
Public method ResetModified
Resets the Modified to the default value.
Public method ResetNavigateOptions
Resets the NavigateOptions to the default value.
Public method ResetOverWrite
Resets the OverWrite to the default value.
Public method ResetReadOnly
Resets the ReadOnly to the default value.
Public method ResetRightToLeft
Resets the RightToLeft property to its default value.
(Inherited from Control.)
Public method ResetSingleLineMode
Resets the SingleLineMode to the default value.
Public method ResetText
Resets the Text property to its default value.
(Inherited from Control.)
Public method ResetWordWrap
Resets the WordWrap to the default value.
Public method ResetWrapAtMargin
Resets the WrapAtMargin to the default value.
Public method RestorePosition
Restores position from stored position list by given index.
Public method RestorePositionWithUndo
Restores position from stored position list by given index.
Public method ResumeLayout
Resumes usual layout logic.
(Inherited from Control.)
Public method ResumeLayout(Boolean)
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.
(Inherited from Control.)
Public method ResumeMacroRecording
Resumes recording the command sequence.
Public method SaveFile(String)
Saves text content to the specific file.
Public method SaveFile(String, IStringExport)
Saves content to the given file in the specific format.
Public method SaveFile(String, Encoding)
Saves text content to the specific file with specific encoding.
Public method SaveFile(String, IStringExport, Encoding)
Saves content to the given file in the specific format with specific encoding.
Public method SaveMacros(Stream)
Saves the macro records to the given stream in xml format.
Public method SaveMacros(TextWriter)
Saves the macro records to the given stream in xml format.
Public method SaveMacros(String)
Saves the macro records to the given file in xml format.
Public method SaveStream(Stream)
Saves content of the snippet to the specified stream.
Public method SaveStream(TextWriter)
Saves the text content to the specified stream.
Public method SaveStream(Stream, IStringExport)
Saves content to the specific stream in the specific format.
Public method SaveStream(Stream, Encoding)
Saves the text content to the specified stream.
Public method SaveStream(TextWriter, IStringExport)
Saves the text content to the specified stream.
Public method SaveStream(Stream, IStringExport, Encoding)
Saves content to the specific stream in the specific format and specific encoding.
Public method Scale(Single) Obsolete.
Scales the control and any child controls.
(Inherited from Control.)
Public method Scale(SizeF)
Scales the control and all child controls by the specified scaling factor.
(Inherited from Control.)
Public method Scale(Single, Single) Obsolete.
Scales the entire control and any child controls.
(Inherited from Control.)
Public method ScreenToDisplay(Int32, Int32)
Converts given screen coordinates to display coordinates (index of line and character).
Public method | ScreenToDisplay(Int32, Int32, Boolean)
Public method ScreenToDisplayX
When implemented by a class, converts given screen coordinates to display coordinate of a character.
Public method ScreenToText(Point)
Converts given screen coordinates to text coordinates (index of line and character).
Public method ScreenToText(Int32, Int32)
Converts given screen coordinates to text coordinates (index of line and character).
Public method ScreenToText(Int32, Int32, Boolean)
Converts given screen coordinates to text coordinates (index of line and character).
Public method ScrollLineDown
Scrolls text content one line down.
Public method ScrollLineUp
Scrolls text content one line up.
Public method Select
Activates the control.
(Inherited from Control.)
Public method SelectNextControl
Activates the next control.
(Inherited from Control.)
Public method SendToBack
Sends the control to the back of the z-order.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32)
Sets the bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified)
Sets the specified bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
Public method SetNavigateOptions
Sets navigating options without validating position.
Public method ShouldSerializeBorderColor
Indicates whether the BorderColor property should be persisted.
Public method ShouldSerializeBorderStyle
Indicates whether the BorderStyle property should be persisted.
Public method ShouldSerializeCodeCompletionChars
Indicates whether the CodeCompletionChars property should be persisted.
Public method ShouldSerializeCursor
Indicates whether the Cursor property should be persisted.
Public method ShouldSerializeFont
Indicates whether the Font property should be persisted.
Public method ShouldSerializeIndentOptions
Indicates whether the IndentOptions property should be persisted.
Public method ShouldSerializeNavigateOptions
Indicates whether the NavigateOptions property should be persisted.
Public method ShouldSerializeReadOnly
Indicates whether the ReadOnly property should be persisted.
Public method ShouldSerializeSearchOptions
Indicates whether the SearchOptions property should be persisted.
Public method ShouldSerializeText
Indicates whether the Text property should be persisted.
Public method Show
Displays the control to the user.
(Inherited from Control.)
Public method ShowCaret
Moves the caret to the specified coordinates.
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType)
Shows code completion popup window with given provider at the current position.
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point)
Shows code completion popup window with given Provider at the specified position.
Public method ShowCodeCompletionButton(ICodeCompletionProvider)
Shows code completion popup window with given provider at the current position.
Public method ShowCodeCompletionButton(ICodeCompletionProvider, Point, Boolean)
Shows code completion popup window with given Provider at the specified position.
Public method ShowCodeCompletionHint(ICodeCompletionProvider, ILexer)
Displays ICodeCompletionHint with given provider at the current position.
Public method ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer)
Displays ICodeCompletionHint with given provider at the specified position.
Public method ShowNotFound
Displays "searched text not found" message box.
Public method ShowScrollHint
Displays tooltip indicating destination line when scrolling.
Public method SplitViewHorz
Splits control content horizontally.
Public method SplitViewVert
Splits control content vertically.
Public method StartIncrementalSearch
Enters control to the incremental search state.
Public method StartIncrementalSearch(Boolean)
Enters control to the incremental search state.
Public method StartMacroRecording
Starts recording the command sequence.
Public method StopMacroRecording
Stops recording the command sequence.
Public method StorePosition(Point)
Stores given position to stored position list.
Public method StorePosition(Point, Boolean)
Stores given position to stored position list.
Public method StorePositionWithUndo
Stores given position to stored position list preserving it for undo.
Public method SuspendLayout
Temporarily suspends the layout logic for the control.
(Inherited from Control.)
Public method | TextStyleAt
Public method TextToScreen(Point)
Converts given text coordinates, index of line and character, to screen coordinates.
Public method TextToScreen(Point, Boolean)
Converts given text coordinates, index of line and character, to screen coordinates.
Public method TextToScreen(Int32, Int32)
Converts given text coordinates, index of line and character, to screen coordinates.
Public method ToggleMacroRecording
Toggles recording the command sequence.
Public method ToString
Returns a String containing the name of the Component, if any. This method should not be overridden.
(Inherited from Component.)
Public method UnBreakLine
Concatenates lines at current position.
Public method UnhighlightAll
Unhighlights search results previously highlighted by HighlightAll.
Public method UnsplitViewHorz
Removes horizontal split view.
Public method UnsplitViewVert
Removes vertical split view.
Public method Update
Causes the control to redraw the invalidated regions within its client area.
(Inherited from Control.)
Public method UpdateCaret
Ensures the caret is displayed in the current position.
Public method UpdateCursor
Causes current mouse cursor to be updated.
Public method UpdateView
Updates editor content, caret and pages area.
Public method UpdateWordWrap
Re-wraps all lines in the text.
Public method UpdateWordWrap(Int32, Int32)
Re-wraps lines in the text within specific scope.
Public method ValidatePosition
Validates given position within control's text content.
Top
Properties
 | Name | Description
Public property | AcceptReturns | Gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key.
Public property | AcceptTabs | Gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key.
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveOutlineRange | Gets currently highlighted outlined range.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Overrides ControlAllowDrop.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCorrectDelimiters | Gets or sets an array of chars that used as word delimiters.
Public property | AutoCorrection | Gets or sets a boolean value indicating whether to auto correct words being typed.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color for the Edit control.
Public property | BorderStyle | Gets or sets the border style for the Edit control.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Braces | Represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control.
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharsInWidth | Returns number of characters painted with current font that will fit into control's client area.
Public property | ClientArea | Gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded.
Public property | ClientHeight | Gets the width of the client area of the Edit control.
Public property | ClientRect | Gets the rectangle that represents the client area of the Edit control.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ClientWidth | Gets the width of the client area of the Edit control.
Public property | CodeCompletionBox | Represents object that specifies a popup window that contains code completion information presented in the form of list.
Public property | CodeCompletionButton | Represents object that specifies a popup window that contains code completion information presented in the form of list.
Public property | CodeCompletionChars | Represents a collection of characters that initializes a code completion procedure when typing in the editor.
Public property | CodeCompletionHint | Represents object that specifies a popup window that contains code completion information presented in the form of the tooltip.
Public property | CodeCompletionMode | Gets or sets code completion box mode.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentBlockRange | Gets currently highlighted block range.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Overrides ControlCursor.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultMenu | Gets or sets default context menu for the editor control.
Public property | DisplayLines | Represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | EditMargin | Represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed.
Public property | EffectiveVisualTheme | Gets current visual theme.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EventHandlers | Represents object that holds EventHandlers containing list of keys with attached actions.
Public property | FirstSearch | Gets or sets a value indicating whether control launches text search at first.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Overrides ControlFont.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GotoLineDialog | Gets or sets a dialog prompting for index of the line you need to locate.
Public property | Gutter | Represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideCaret | Gets or sets a value indicating whether the control should display caret when it has input focus.
Public property | HighlightCurrentBlock | Specifies that edit control should highlight current block.
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight begin/end blocks.
Public property | HighlightReferences | Specifies that edit control should highlight found references.
Public property | HighlightSearchResults | Indicates whether search results are highlighted while the search dialog is open.
Public property | HorzSplitEdit | Represents horizontal split view control.
Public property | HorzSplitter | Represents a horizontal Splitter control allowing to split Edit content horizontally.
Public property | HyperText | Represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IncrementalSearchString | Return text to search if class is in incremental search state; otherwise return empty string.
Public property | InCycledSearch | Indicates whether control is in incremental search state.
Public property | IndentOptions | Gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line.
Public property | InIncrementalSearch | Indicates whether control is in incremental search state.
Public property | InnerTextSource | Gets inner text source
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsCodeCompletionWindowFocused | Indicates whether ICodeCompletionWindow has focus.
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSearchFocused | Gets a boolean value indicating whether search dialog box has input focus.
Public property | KeepCaretOnLostFocus | Keeps caret in visible state even Edit control lost focus.
Public property | KeyList | Represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content.
Public property | Lines | Represents object that implements ITextStrings interface containing collection of strings determining control's content.
Public property | LineSeparator | Represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control.
Public property | LinesInHeight | Determines how many lines can fit into control's client area.
Public property | LineSpace | Gets or sets line space between individual lines in the Edit control.
Public property | LineStyles | Represents an object that implements IEditLineStyles interface holding collection of IEditLineStyle objects each of them determines particular style of the line in the control.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | MacroRecording | Gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands.
Public property | MacroRecords | Represents an array containing keyboard commands.
Public property | MacroSuspendend | Gets or sets a boolean value indicating whether recording is suspended.
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavigateOptions | Gets or sets navigating options.
Public property | OpenSharedEditorFunc | When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment.
Public property | Outlining | Represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control.
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Pages | Represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages.
Public property | Painter | Represents an object that implements IPainter interface used to draw control's text.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | Position | Gets or sets current position within the control's text content.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PrevPosition | Gets previous position within the control's text content.
Public property | Printing | Represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options.
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Scrolling | Represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control.
Public property | SearchDialog | Gets or sets a dialog box allowing to search for the text or replace it.
Public property | SearchDialogAppearance |
Public property | SearchGlobal | Gets or sets a value indicating whether search should be global.
Public property | SearchLen | Represents length of the last found text.
Public property | SearchOptions | Gets or sets a value that defines search and replace options.
Public property | SearchPos | Gets or sets a value that represents position of the last found text.
Public property | Selection | Represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text.
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Source | Gets or sets an object that implements ITextSource interface containing an actual string data displayed by the control.
Public property | Spelling | Represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words.
Public property | Strings | Represents Lines property in the form of array of strings.
Public property | SyntaxPaint | Represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the string collection as a single string with the individual lines delimited by carriage returns. (Overrides ControlText.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Transparent | Gets or sets a boolean value that indicates whether Edit control should draw its background.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UseDefaultMenu | Indicates whether edit control should use built in popup menu.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VertSplitEdit | Represents an vertical split view control.
Public property | VertSplitter | Represents a vertical Splitter control allowing to split Edit content vertically.
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualTheme | Gets or sets visual theme for the editor.
Public property | VisualThemeType | Gets or sets visual theme type for the editor.
Public property | WhiteSpace | Represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary.
Public property | WrapAtMargin | Gets or sets a value indicating whether control automatically wraps words at margin position.
Public property | WrapMargin | Gets position of the wrapping margin.
Top
Events
 | Name | Description
Public event | AutoCorrect | Occurs when control tries to auto correct word being typed.
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckHyperText | Occurs when a control needs checking whether some string represents hypertext.
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when control draws its content.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawHeader | Occurs when header or footer part of each page is drawing.
Public event | DrawUserMargin | Occurs when user margin part of each line is drawing.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | GutterClick | Occurs when the gutter part of Edit control is clicked.
Public event | GutterDblClick | Occurs when the gutter part of Edit control is double-clicked.
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HorizontalScroll | Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | JumpToUrl | Occurs when user attempts to jump to url.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when modified state is changed.
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NeedCodeCompletion | Occurs when code completion window is to be displayed.
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintBackground | Occurs when Edit control should paint its background in transparent mode.
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PromptOnReplace | Occurs when replace dialog prompts on replace action.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollButtonClick | Occurs when some scrolling button is clicked.
Public event | SelectionChanged | Occurs when selection bounds are changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SourceChanged | Occurs when source changes.
Public event | SourceStateChanged | Occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc.
Public event | SplitHorz | Occurs when user splits Edit control horizontally.
Public event | SplitVert | Occurs when user splits Edit control vertically.
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | UndoEvent | Occurs when undo/redo operation performed.
Public event | UnsplitHorz | Occurs when horizontal split view is removed.
Public event | UnsplitVert | Occurs when vertical split view is removed.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VerticalScroll | Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking.
Top
See Also

Reference

Alternet.Editor Namespace


SyntaxEdit Constructor

SyntaxEdit Constructor
Overload List
 | Name | Description
Public method | SyntaxEdit | Initializes a new instance of the SyntaxEdit class with default settings.
Public method | SyntaxEdit(IContainer) | Initializes a new instance of the SyntaxEdit class with specified container.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit Constructor

SyntaxEdit Constructor
Initializes a new instance of the SyntaxEdit class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxEdit()
Public Sub New
public:
SyntaxEdit()
new : unit -> SyntaxEdit
See Also

Reference

SyntaxEdit Class
SyntaxEdit Overload
Alternet.Editor Namespace


SyntaxEdit Constructor (IContainer)

SyntaxEdit Constructor (IContainer)
Initializes a new instance of the SyntaxEdit class with specified container.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxEdit(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
SyntaxEdit(
    IContainer^ container
)
new :
        container : IContainer -> SyntaxEdit

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

SyntaxEdit Class
SyntaxEdit Overload
Alternet.Editor Namespace


SyntaxEdit Methods

SyntaxEdit Methods

The SyntaxEdit type exposes the following members.

Methods
Name | Description
Public method ApplyTheme
Applies visual theme to the SyntaxEdit control.
Public method Assign
Assigns most relevant properties from another ISyntaxEdit object.
Public method BeginInvoke(Delegate)
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginInvoke(Delegate, Object)
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginUpdate
Prevents editor updating until calling EndUpdate method.
Public method BreakLine
Breaks current line into two lines.
Public method BringToFront
Brings the control to the front of the z-order.
(Inherited from Control.)
Public method CanFindNext
Indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
Public method CanFindNextSelected
Indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
Public method CanFindPrevious
Indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
Public method CanFindPreviousSelected
Indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
Public method CanSearchSelection
Returns whether search can be performed inside selection.
Public method CanSplitHorz
Indicates whether control can split its content horizontally.
Public method CanSplitVert
Indicates whether control can split its content vertically.
Public method CanUnsplitHorz
Indicates whether control has horizontal split view.
Public method CanUnsplitVert
Indicates whether control has vertical split view.
Public method CodeCompletion
Performs code completion for the specified text representing language element.
Public method CodeCompletionWindowFocused
Indicates whether ICodeCompletionWindow has focus.
Public method CodeSnippets
Displays a code completion window with list of available code snippets.
Public method CompleteCodeFixes
Displays a code completion window with list of available code fixes.
Public method CompleteCodeFixesOrRefactors
Displays a code completion window with list of available code fixes or code refactors.
Public method CompleteCodeRefactors
Displays a code completion window with list of available code refactors.
Public method CompleteWord
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box and locates single member, if possible.
Public method Contains
Retrieves a value indicating whether the specified control is a child of the control.
(Inherited from Control.)
Public method CreateCaret
Creates a new shape for the system caret and gets ownership of the caret.
Public method CreateControl
Forces the creation of the visible control, including the creation of the handle and any visible child controls.
(Inherited from Control.)
Public method CreateGraphics
Creates the Graphics for the control.
(Inherited from Control.)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method CycledSearch
Performs cycled search.
Public method DeleteBlock
Deletes a specified block of characters.
Public method DeleteLeft
Deletes a specified number of characters to the left of the active point.
Public method DeleteRight
Deletes a specified number of characters to the right of the active point.
Public method DestroyCaret
Destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
Public method DisablePositionUpdate
Prevents notification of changing of caret position until calling EnablePositionUpdate method.
Public method DisableUpdate
Prevents editor updating until calling EnableUpdate method.
Public method DisplayDragCaret
Displays dragging caret rather than regular caret.
Public method DisplayGotoLineDialog
Initializes and runs a dialog prompting you for index of the line you need to locate.
Public method DisplayGotoLineDialog(IWin32Window)
Initializes and runs a dialog prompting you for index of the line you need to locate.
Public method DisplayModalReplaceDialog
Initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method DisplayModalReplaceDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method DisplayModalSearchDialog
Initializes and runs a modal dialog box allowing you to search for some text.
Public method DisplayModalSearchDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for some text.
Public method DisplayReplaceDialog
Initializes and runs a dialog box allowing you to search for text and replace it.
Public method DisplayReplaceDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for text and replace it.
Public method DisplaySearchDialog
Initializes and runs a dialog box allowing you to search for some text.
Public method DisplaySearchDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for some text.
Public method DisplayToScreen(Int32, Int32)
Converts given display coordinates, index of line and character, to screen coordinates.
Public method DisplayToScreen(Int32, Int32, Boolean)
Converts given display coordinates, index of line and character, to screen coordinates.
Public method Dispose
Releases all resources used by the Component.
(Inherited from Component.)
Public method DoDragDrop
Begins a drag-and-drop operation.
(Inherited from Control.)
Public method DrawToBitmap
Supports rendering to the specified bitmap.
(Inherited from Control.)
Public method EnablePositionUpdate
Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
Public method EnableUpdate
Re-enables editor updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method EndInvoke
Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
(Inherited from Control.)
Public method EndUpdate
Re-enables outline editor updating, that was turn of by calling BeginUpdate method.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method Find(String)
Searches for given text within the control's contents.
Public method Find(String, SearchOptions)
Searches for given text within the control's contents with specified options.
Public method Find(String, SearchOptions, Regex)
Searches for given text within the control's contents with specified options using specified regular expression.
Public method Find(String, SearchOptions, Regex, IListIRange)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method Find(String, SearchOptions, Regex, Boolean, Boolean)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method Find(String, SearchOptions, Regex, Point, Int32, Match)
Searches for given text within the control's text content.
Public method FindForm
Retrieves the form that the control is on.
(Inherited from Control.)
Public method FindNext
Searches for the next occurrence of the text specified by previous search.
Public method FindNextSelected
Searches for the next occurrence of the selected text.
Public method FindPrevious
Searches for the previous occurrence of the text specified by previous search.
Public method FindPreviousSelected
Searches for the previous occurrence of the selected text.
Public method FinishIncrementalSearch
Leaves control from the incremental search state.
Public method Focus
Sets input focus to the control.
(Inherited from Control.)
Public method GetCaretSize
Returns size of the caret's current shape at given position.
Public method GetCharsInWidth
Returns number of characters painted with current font that will fit into specified Width.
Public method GetChildAtPoint(Point)
Retrieves the child control that is located at the specified coordinates.
(Inherited from Control.)
Public method GetChildAtPoint(Point, GetChildAtPointSkip)
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
(Inherited from Control.)
Public method GetContainerControl
Returns the next ContainerControl up the control's chain of parent controls.
(Inherited from Control.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetHitTest(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method GetHitTest(Int32, Int32, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method GetHitTestAtTextPoint(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of control at specified text coordinate.
Public method GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo)
Retrieves information about part of control at specified text coordinate.
Public method GetIndentString
Gets indentation string at current position.
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method GetLinesInHeight
Determines how many lines can fit into given Height.
Public method GetNextControl
Retrieves the next control forward or back in the tab order of child controls.
(Inherited from Control.)
Public method GetPreferredSize
Retrieves the size of a rectangular area into which a control can be fitted.
(Inherited from Control.)
Public method GetTextAtCursor
Returns word at the cursor position.
Public method GetTextToSearchAtCursor
Returns word at the cursor position.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetWordAt
Checks word accordingly to specified conditions.
Public method GetWrapMargin
Returns position of the wrapping margin.
Public method HasAutoCorrection
Checks whether specified word has correction.
Public method Hide
Conceals the control from the user.
(Inherited from Control.)
Public method HideDragCaret
Hides dragging caret.
Public method HideScrollHint
Hides scroll hint window if necessary.
Public method HighlightAll
Highlights all occurrences of specified string in the class text content.
Public method IncrementalSearch
Finds given text incrementally.
Public method IndentLine
Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
Public method IndentLine(String, Boolean)
Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method Insert
Inserts the given string at the specified location.
Public method InsertBlock(String, Boolean)
Inserts the given string at the specified location.
Public method InsertBlock(String, Boolean)
Inserts the given string array at the specified location.
Public method InsertBlock(ITextStrings, Boolean)
Inserts the given string collection at the specified location.
Public method InsertBlock(String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.
Public method InsertFromFile
Inserts the file text content at the specified location.
Public method Invalidate
Invalidates the entire surface of the control and causes the control to be redrawn.
(Inherited from Control.)
Public method Invalidate(Region)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Boolean)
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Region, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invoke(Delegate)
Executes the specified delegate on the thread that owns the control's underlying window handle.
(Inherited from Control.)
Public method Invoke(Delegate, Object)
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
(Inherited from Control.)
Public method IsValidText
Indicates whether text at the specified position is valid (that is does not contain comments or string constants).
Public method KillFocus
Ensure the caret is not visible.
Public method LineIsHidden
Determines whether the given line is hidden.
Public method LineIsReadonly
Determines whether the given line is readonly.
Public method ListMembers
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box.
Public method LoadFile(String)
Loads the contents of the specified file.
Public method LoadFile(String, IStringImport)
Loads content from the given file with specified importer.
Public method LoadFile(String, Encoding)
Loads the contents of the specified file with specified encoding.
Public method LoadFile(String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.
Public method LoadMacros(Stream)
Loads the macro records from the given stream.
Public method LoadMacros(TextReader)
Loads the macro records from the given stream.
Public method LoadMacros(String)
Loads the macro records from the given file.
Public method LoadStream(Stream)
Loads the contents of the specified stream.
Public method LoadStream(TextReader)
Loads the contents of the specified stream.
Public method LoadStream(Stream, IStringImport)
Loads the text content from the given stream with specified importer.
Public method LoadStream(Stream, Encoding)
Loads the contents of the specified stream.
Public method LoadStream(TextReader, IStringImport)
Loads the contents of the specified stream.
Public method LoadStream(Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.
Public method MakeVisible(Point)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method MakeVisible(Point, Boolean)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method MarkAll(String, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method MarkAll(String, SearchOptions, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method MarkAll(String, SearchOptions, Regex, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method MoveCaretOnDrag
Moves caret to the position of drag cursor.
Public method MoveCharLeft
Moves the current position one character to the left.
Public method MoveCharRight
Moves the current position one character to the right.
Public method MoveFileBegin
Moves the current position to the first character of the first line.
Public method MoveFileEnd
Moves the current position to the last character of the last line.
Public method MoveLineBegin
Moves the current position to the first character of current line.
Public method MoveLineBeginCycled
Moves the current position to the first not whitespace character/first character of current line.
Public method MoveLineDown
Moves the current position to the next line.
Public method MoveLineEnd
Moves the current position to the last character of current line.
Public method MoveLineEndCycled
Moves the current position to the last not whitespace character/last character of current line.
Public method MoveLineUp
Moves the current position to the previous line.
Public method MovePageDown
Moves current position to the next page.
Public method MovePageUp
Moves current position to the previous page.
Public method MoveScreenBottom
Moves the current position to the bottom of the screen.
Public method MoveScreenTop
Moves the current position to the top of the screen.
Public method MoveTo(Point)
Moves the current position to the given position.
Public method MoveTo(Int32, Int32)
Moves the current position to the given position.
Public method MoveToBrace
Moves the current position to the next open or close brace in the text content.
Public method MoveToChar
Moves the current position to the specified character in current line.
Public method MoveToCloseBrace
Moves the current position to the next close brace in the text content.
Public method MoveToLine(Int32)
Moves the current position to the specified line.
Public method MoveToLine(Int32, Int32)
Moves the current position to the specified line.
Public method MoveToOpenBrace
Moves the current position to the previous open brace in the text content.
Public method MoveWordLeft
Moves the current position one word to the left.
Public method MoveWordRight
Moves the current position one word to the right.
Public method Navigate
Moves current position by the given offset value.
Public method NeedReplaceCurrent
Indicates whether search engine need to replace successfully found and selected text.
Public method NeedReplaceCurrent(Match)
Indicates whether search engine need to replace successfully found and selected text.
Public method NewLine
Inserts a line break at the current position.
Public method NewLine(String, Boolean)
Inserts a line break at the current position with indentation
Public method NewLineAbove
Inserts a line break above the current position.
Public method NewLineBelow
Inserts a line break below the current position.
Public method Notification
Updates control's content according to parameters of notification.
Public method OnStateChanged
Updates control's content according to the state of the source.
Public method OnTextFound
When implemented by a class, occurs when search text is found.
Public method OutlineText
Forces automatic outlining by getting up-to-date information about outline section from the Parser.
Public method ParameterInfo
Displays a code completion window containing information for the current method or parameter in the Editor's content.
Public method PauseMacroRecording
Suspends recording the command sequence.
Public method PerformLayout
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PerformLayout(Control, String)
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PlayBackMacro
Repeats the stored command sequence.
Public method PointToClient
Computes the location of the specified screen point into client coordinates.
(Inherited from Control.)
Public method PointToScreen
Computes the location of the specified client point into screen coordinates.
(Inherited from Control.)
Public method PositionIsReadonly
Determines whether the text at given position is readonly.
Public method PreProcessControlMessage
Preprocesses keyboard or input messages within the message loop before they are dispatched.
(Inherited from Control.)
Public method PreProcessMessage
Preprocesses input messages within the message loop before they are dispatched.
(Overrides ControlPreProcessMessage(Message).)
Public method ProcessEnter
Performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ProcessKeyMsg
Processes a keyboard message.
Public method ProcessKeyPress
Processes key press.
Public method ProcessShiftTab
Performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method ProcessTab
Performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
Public method QuickInfo
Displays a code completion window with simple tooltip information.
Public method RecordKeyData
Adds keyData to the MacroRecords array.
Public method RectangleToClient
Computes the size and location of the specified screen rectangle in client coordinates.
(Inherited from Control.)
Public method RectangleToScreen
Computes the size and location of the specified client rectangle in screen coordinates.
(Inherited from Control.)
Public method Refresh
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
(Inherited from Control.)
Public method Replace(String, String)
Searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
Public method Replace(String, String, SearchOptions)
Searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
Public method Replace(String, String, SearchOptions, Regex)
Searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
Public method ReplaceAll(String, String, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
Public method ReplaceAll(String, String, SearchOptions, Int32)
Replaces all occurrences of given text within text content by specified replaceWith string.
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean)
Replaces all occurrences of given text within class text content by specified replaceWith string.
Public method ReplaceCurrent
Replaces currently selected text.
Public method ResetAcceptReturns
Resets the AcceptReturns to the default value.
Public method ResetAcceptTabs
Resets the AcceptTabs to the default value.
Public method ResetBackColor
Resets the BackColor property to its default value.
(Inherited from Control.)
Public method ResetBindings
Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
(Inherited from Control.)
Public method ResetBorderColor
Resets the BorderColor to the default value.
Public method ResetBorderStyle
Resets the BorderStyle to the default value.
Public method ResetCursor
Resets the Cursor property to its default value.
(Overrides ControlResetCursor.)
Public method ResetFont
Resets the Font property to its default value.
(Overrides ControlResetFont.)
Public method ResetForeColor
Resets the ForeColor property to its default value.
(Inherited from Control.)
Public method ResetHideCaret
Resets the HideCaret to the default value.
Public method ResetImeMode
Resets the ImeMode property to its default value.
(Inherited from Control.)
Public method ResetIndentOptions
Resets the IndentOptions to the default value.
Public method ResetKeepCaretOnLostFocus
Resets the KeepCaretOnLostFocus to the default value.
Public method ResetLineSpace
Resets the LineSpace to the default value.
Public method ResetMaxLength
Resets the MaxLength to the default value.
Public method ResetModified
Resets the Modified to the default value.
Public method ResetNavigateOptions
Resets the NavigateOptions to the default value.
Public method ResetOverWrite
Resets the OverWrite to the default value.
Public method ResetReadOnly
Resets the ReadOnly to the default value.
Public method ResetRightToLeft
Resets the RightToLeft property to its default value.
(Inherited from Control.)
Public method ResetSingleLineMode
Resets the SingleLineMode to the default value.
Public method ResetText
Resets the Text property to its default value.
(Inherited from Control.)
Public method ResetWordWrap
Resets the WordWrap to the default value.
Public method ResetWrapAtMargin
Resets the WrapAtMargin to the default value.
Public method RestorePosition
Restores position from stored position list by given index.
Public method RestorePositionWithUndo
Restores position from stored position list by given index.
Public method ResumeLayout
Resumes usual layout logic.
(Inherited from Control.)
Public method ResumeLayout(Boolean)
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.
(Inherited from Control.)
Public method ResumeMacroRecording
Resumes recording the command sequence.
Public method SaveFile(String)
Saves text content to the specific file.
Public method SaveFile(String, IStringExport)
Saves content to the given file in the specific format.
Public method SaveFile(String, Encoding)
Saves text content to the specific file with specific encoding.
Public method SaveFile(String, IStringExport, Encoding)
Saves content to the given file in the specific format with specific encoding.
Public method SaveMacros(Stream)
Saves the macro records to the given stream in xml format.
Public method SaveMacros(TextWriter)
Saves the macro records to the given stream in xml format.
Public method SaveMacros(String)
Saves the macro records to the given file in xml format.
Public method SaveStream(Stream)
Saves content of the snippet to the specified stream.
Public method SaveStream(TextWriter)
Saves the text content to the specified stream.
Public method SaveStream(Stream, IStringExport)
Saves content to the specific stream in the specific format.
Public method SaveStream(Stream, Encoding)
Saves the text content to the specified stream.
Public method SaveStream(TextWriter, IStringExport)
Saves the text content to the specified stream.
Public method SaveStream(Stream, IStringExport, Encoding)
Saves content to the specific stream in the specific format and specific encoding.
Public method Scale(Single) Obsolete.
Scales the control and any child controls.
(Inherited from Control.)
Public method Scale(SizeF)
Scales the control and all child controls by the specified scaling factor.
(Inherited from Control.)
Public method Scale(Single, Single) Obsolete.
Scales the entire control and any child controls.
(Inherited from Control.)
Public method ScreenToDisplay(Int32, Int32)
Converts given screen coordinates to display coordinates (index of line and character).
Public method | ScreenToDisplay(Int32, Int32, Boolean)
Public method ScreenToDisplayX
When implemented by a class, converts given screen coordinates to display coordinate of a character.
Public method ScreenToText(Point)
Converts given screen coordinates to text coordinates (index of line and character).
Public method ScreenToText(Int32, Int32)
Converts given screen coordinates to text coordinates (index of line and character).
Public method ScreenToText(Int32, Int32, Boolean)
Converts given screen coordinates to text coordinates (index of line and character).
Public method ScrollLineDown
Scrolls text content one line down.
Public method ScrollLineUp
Scrolls text content one line up.
Public method Select
Activates the control.
(Inherited from Control.)
Public method SelectNextControl
Activates the next control.
(Inherited from Control.)
Public method SendToBack
Sends the control to the back of the z-order.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32)
Sets the bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified)
Sets the specified bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
Public method SetNavigateOptions
Sets navigating options without validating position.
Public method ShouldSerializeBorderColor
Indicates whether the BorderColor property should be persisted.
Public method ShouldSerializeBorderStyle
Indicates whether the BorderStyle property should be persisted.
Public method ShouldSerializeCodeCompletionChars
Indicates whether the CodeCompletionChars property should be persisted.
Public method ShouldSerializeCursor
Indicates whether the Cursor property should be persisted.
Public method ShouldSerializeFont
Indicates whether the Font property should be persisted.
Public method ShouldSerializeIndentOptions
Indicates whether the IndentOptions property should be persisted.
Public method ShouldSerializeNavigateOptions
Indicates whether the NavigateOptions property should be persisted.
Public method ShouldSerializeReadOnly
Indicates whether the ReadOnly property should be persisted.
Public method ShouldSerializeSearchOptions
Indicates whether the SearchOptions property should be persisted.
Public method ShouldSerializeText
Indicates whether the Text property should be persisted.
Public method Show
Displays the control to the user.
(Inherited from Control.)
Public method ShowCaret
Moves the caret to the specified coordinates.
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType)
Shows code completion popup window with given provider at the current position.
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point)
Shows code completion popup window with given Provider at the specified position.
Public method ShowCodeCompletionButton(ICodeCompletionProvider)
Shows code completion popup window with given provider at the current position.
Public method ShowCodeCompletionButton(ICodeCompletionProvider, Point, Boolean)
Shows code completion popup window with given Provider at the specified position.
Public method ShowCodeCompletionHint(ICodeCompletionProvider, ILexer)
Displays ICodeCompletionHint with given provider at the current position.
Public method ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer)
Displays ICodeCompletionHint with given provider at the specified position.
Public method ShowNotFound
Displays "searched text not found" message box.
Public method ShowScrollHint
Displays tooltip indicating destination line when scrolling.
Public method SplitViewHorz
Splits control content horizontally.
Public method SplitViewVert
Splits control content vertically.
Public method StartIncrementalSearch
Enters control to the incremental search state.
Public method StartIncrementalSearch(Boolean)
Enters control to the incremental search state.
Public method StartMacroRecording
Starts recording the command sequence.
Public method StopMacroRecording
Stops recording the command sequence.
Public method StorePosition(Point)
Stores given position to stored position list.
Public method StorePosition(Point, Boolean)
Stores given position to stored position list.
Public method StorePositionWithUndo
Stores given position to stored position list preserving it for undo.
Public method SuspendLayout
Temporarily suspends the layout logic for the control.
(Inherited from Control.)
Public method | TextStyleAt
Public method TextToScreen(Point)
Converts given text coordinates, index of line and character, to screen coordinates.
Public method TextToScreen(Point, Boolean)
Converts given text coordinates, index of line and character, to screen coordinates.
Public method TextToScreen(Int32, Int32)
Converts given text coordinates, index of line and character, to screen coordinates.
Public method ToggleMacroRecording
Toggles recording the command sequence.
Public method ToString
Returns a String containing the name of the Component, if any. This method should not be overridden.
(Inherited from Component.)
Public method UnBreakLine
Concatenates lines at current position.
Public method UnhighlightAll
Unhighlights search results previously highlighted by HighlightAll.
Public method UnsplitViewHorz
Removes horizontal split view.
Public method UnsplitViewVert
Removes vertical split view.
Public method Update
Causes the control to redraw the invalidated regions within its client area.
(Inherited from Control.)
Public method UpdateCaret
Ensures the caret is displayed in the current position.
Public method UpdateCursor
Causes current mouse cursor to be updated.
Public method UpdateView
Updates editor content, caret and pages area.
Public method UpdateWordWrap
Re-wraps all lines in the text.
Public method UpdateWordWrap(Int32, Int32)
Re-wraps lines in the text within specific scope.
Public method ValidatePosition
Validates given position within control's text content.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ApplyTheme Method

SyntaxEditApplyTheme Method
Applies visual theme to the SyntaxEdit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ApplyTheme(
    IVisualTheme theme
)
Public Overridable Sub ApplyTheme (
    theme As IVisualTheme
)
public:
virtual void ApplyTheme(
    IVisualTheme^ theme
)
abstract ApplyTheme :
        theme : IVisualTheme -> unit
override ApplyTheme :
        theme : IVisualTheme -> unit

Parameters

theme
Type: Alternet.EditorIVisualTheme

Implements

ISyntaxEditApplyTheme(IVisualTheme)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Assign Method

SyntaxEditAssign Method
Assigns most relevant properties from another ISyntaxEdit object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ISyntaxEdit source
)
Public Overridable Sub Assign (
    source As ISyntaxEdit
)
public:
virtual void Assign(
    ISyntaxEdit^ source
)
abstract Assign :
        source : ISyntaxEdit -> unit
override Assign :
        source : ISyntaxEdit -> unit

Parameters

source
Type: Alternet.EditorISyntaxEdit
Specifies source object.

Implements

ISyntaxEditAssign(ISyntaxEdit)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.BeginUpdate Method

SyntaxEditBeginUpdate Method
Prevents editor updating until calling EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of header updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.BreakLine Method

SyntaxEditBreakLine Method
Breaks current line into two lines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BreakLine(
    bool withChange = false
)
Public Overridable Function BreakLine (
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool BreakLine(
    bool withChange = false
)
abstract BreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override BreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditBreakLine(Boolean)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CanFindNext Method

SyntaxEditCanFindNext Method
Indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanFindNext()
Public Overridable Function CanFindNext As Boolean
public:
virtual bool CanFindNext()
abstract CanFindNext : unit -> bool
override CanFindNext : unit -> bool

Return Value

Type: Boolean
False if it is the first attempt to search; otherwise true.

Implements

ISearchCanFindNext
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CanFindNextSelected Method

SyntaxEditCanFindNextSelected Method
Indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanFindNextSelected()
Public Overridable Function CanFindNextSelected As Boolean
public:
virtual bool CanFindNextSelected()
abstract CanFindNextSelected : unit -> bool
override CanFindNextSelected : unit -> bool

Return Value

Type: Boolean
False if it is the first attempt to search or no text selected; otherwise true.

Implements

ISearchCanFindNextSelected
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CanFindPrevious Method

SyntaxEditCanFindPrevious Method
Indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanFindPrevious()
Public Overridable Function CanFindPrevious As Boolean
public:
virtual bool CanFindPrevious()
abstract CanFindPrevious : unit -> bool
override CanFindPrevious : unit -> bool

Return Value

Type: Boolean
False if it is the first attempt to search; otherwise true.

Implements

ISearchCanFindPrevious
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CanFindPreviousSelected Method

SyntaxEditCanFindPreviousSelected Method
Indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanFindPreviousSelected()
Public Overridable Function CanFindPreviousSelected As Boolean
public:
virtual bool CanFindPreviousSelected()
abstract CanFindPreviousSelected : unit -> bool
override CanFindPreviousSelected : unit -> bool

Return Value

Type: Boolean
False if it is the first attempt to search or no text selected; otherwise true.

Implements

ISearchCanFindPreviousSelected
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CanSearchSelection Method

SyntaxEditCanSearchSelection Method
Returns whether search can be performed inside selection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanSearchSelection(
    out string selectedText
)
Public Overridable Function CanSearchSelection (
    <OutAttribute> ByRef selectedText As String
) As Boolean
public:
virtual bool CanSearchSelection(
    [OutAttribute] String^% selectedText
)
abstract CanSearchSelection :
        selectedText : string byref -> bool
override CanSearchSelection :
        selectedText : string byref -> bool

Parameters

selectedText
Type: SystemString

Return Value

Type: Boolean
True if selection is not empty; otherwise false.

Implements

ISearchCanSearchSelection(String)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CanSplitHorz Method

SyntaxEditCanSplitHorz Method
Indicates whether control can split its content horizontally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanSplitHorz()
Public Overridable Function CanSplitHorz As Boolean
public:
virtual bool CanSplitHorz()
abstract CanSplitHorz : unit -> bool
override CanSplitHorz : unit -> bool

Return Value

Type: Boolean
True if can split horizontally; otherwise false.

Implements

ISplitViewCanSplitHorz
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CanSplitVert Method

SyntaxEditCanSplitVert Method
Indicates whether control can split its content vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanSplitVert()
Public Overridable Function CanSplitVert As Boolean
public:
virtual bool CanSplitVert()
abstract CanSplitVert : unit -> bool
override CanSplitVert : unit -> bool

Return Value

Type: Boolean
True if can split vertically; otherwise false.

Implements

ISplitViewCanSplitVert
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CanUnsplitHorz Method

SyntaxEditCanUnsplitHorz Method
Indicates whether control has horizontal split view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanUnsplitHorz()
Public Overridable Function CanUnsplitHorz As Boolean
public:
virtual bool CanUnsplitHorz()
abstract CanUnsplitHorz : unit -> bool
override CanUnsplitHorz : unit -> bool

Return Value

Type: Boolean
True if horizontal split view is visible; otherwise false.

Implements

ISplitViewCanUnsplitHorz
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CanUnsplitVert Method

SyntaxEditCanUnsplitVert Method
Indicates whether control has vertical split view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanUnsplitVert()
Public Overridable Function CanUnsplitVert As Boolean
public:
virtual bool CanUnsplitVert()
abstract CanUnsplitVert : unit -> bool
override CanUnsplitVert : unit -> bool

Return Value

Type: Boolean
True if vertical split view is visible; otherwise false.

Implements

ISplitViewCanUnsplitVert
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CodeCompletion Method

SyntaxEditCodeCompletion Method
Performs code completion for the specified text representing language element.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CodeCompletion(
    CodeCompletionArgs e
)
Public Overridable Sub CodeCompletion (
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    CodeCompletionArgs^ e
)
abstract CodeCompletion :
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        e : CodeCompletionArgs -> unit

Parameters

e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.

Implements

ICodeCompletionCodeCompletion(CodeCompletionArgs)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CodeCompletionWindowFocused Method

SyntaxEditCodeCompletionWindowFocused Method
Indicates whether ICodeCompletionWindow has focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CodeCompletionWindowFocused(
    out Control control
)
Public Overridable Function CodeCompletionWindowFocused (
    <OutAttribute> ByRef control As Control
) As Boolean
public:
virtual bool CodeCompletionWindowFocused(
    [OutAttribute] Control^% control
)
abstract CodeCompletionWindowFocused :
        control : Control byref -> bool
override CodeCompletionWindowFocused :
        control : Control byref -> bool

Parameters

control
Type: System.Windows.FormsControl
Returns control that has focus.

Return Value

Type: Boolean
True if succeed; otherwise, false.

Implements

ICodeCompletionCodeCompletionWindowFocused(Control)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CodeSnippets Method

SyntaxEditCodeSnippets Method
Displays a code completion window with list of available code snippets.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CodeSnippets()
Public Overridable Sub CodeSnippets
public:
virtual void CodeSnippets()
abstract CodeSnippets : unit -> unit
override CodeSnippets : unit -> unit

Implements

ICodeCompletionCodeSnippets
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CompleteCodeFixes Method

SyntaxEditCompleteCodeFixes Method
Displays a code completion window with list of available code fixes.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CompleteCodeFixes()
Public Overridable Sub CompleteCodeFixes
public:
virtual void CompleteCodeFixes()
abstract CompleteCodeFixes : unit -> unit
override CompleteCodeFixes : unit -> unit

Implements

ICodeCompletionCompleteCodeFixes
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CompleteCodeFixesOrRefactors Method

SyntaxEditCompleteCodeFixesOrRefactors Method
Displays a code completion window with list of available code fixes or code refactors.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CompleteCodeFixesOrRefactors()
Public Overridable Sub CompleteCodeFixesOrRefactors
public:
virtual void CompleteCodeFixesOrRefactors()
abstract CompleteCodeFixesOrRefactors : unit -> unit
override CompleteCodeFixesOrRefactors : unit -> unit

Implements

ICodeCompletionCompleteCodeFixesOrRefactors
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CompleteCodeRefactors Method

SyntaxEditCompleteCodeRefactors Method
Displays a code completion window with list of available code refactors.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CompleteCodeRefactors()
Public Overridable Sub CompleteCodeRefactors
public:
virtual void CompleteCodeRefactors()
abstract CompleteCodeRefactors : unit -> unit
override CompleteCodeRefactors : unit -> unit

Implements

ICodeCompletionCompleteCodeRefactors
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CompleteWord Method

SyntaxEditCompleteWord Method
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box and locates single member, if possible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CompleteWord()
Public Overridable Sub CompleteWord
public:
virtual void CompleteWord()
abstract CompleteWord : unit -> unit
override CompleteWord : unit -> unit

Implements

ICodeCompletionCompleteWord
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CreateCaret Method

SyntaxEditCreateCaret Method
Creates a new shape for the system caret and gets ownership of the caret.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CreateCaret()
Public Overridable Sub CreateCaret
public:
virtual void CreateCaret()
abstract CreateCaret : unit -> unit
override CreateCaret : unit -> unit

Implements

ICaretCreateCaret
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CycledSearch Method

SyntaxEditCycledSearch Method
Performs cycled search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CycledSearch(
    string text,
    SearchOptions options,
    Regex expression,
    bool silent
)
Public Overridable Function CycledSearch (
    text As String,
    options As SearchOptions,
    expression As Regex,
    silent As Boolean
) As Boolean
public:
virtual bool CycledSearch(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    bool silent
)
abstract CycledSearch :
        text : string *
        options : SearchOptions *
        expression : Regex *
        silent : bool -> bool
override CycledSearch :
        text : string *
        options : SearchOptions *
        expression : Regex *
        silent : bool -> bool

Parameters

text
Type: SystemString
Text being found.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
silent
Type: SystemBoolean
Determines if no visual feedback is required.

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchCycledSearch(String, SearchOptions, Regex, Boolean)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DeleteBlock Method

SyntaxEditDeleteBlock Method
Deletes a specified block of characters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DeleteBlock(
    Rectangle rect,
    bool withChange = false
)
Public Overridable Function DeleteBlock (
    rect As Rectangle,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool DeleteBlock(
    Rectangle rect,
    bool withChange = false
)
abstract DeleteBlock :
        rect : Rectangle *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override DeleteBlock :
        rect : Rectangle *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies coordinates of characters block to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if method succeed; otherwise false.

Implements

IEditDeleteBlock(Rectangle, Boolean)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DeleteLeft Method

SyntaxEditDeleteLeft Method
Deletes a specified number of characters to the left of the active point.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DeleteLeft(
    int len,
    bool withChange = false
)
Public Overridable Function DeleteLeft (
    len As Integer,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool DeleteLeft(
    int len,
    bool withChange = false
)
abstract DeleteLeft :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override DeleteLeft :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

len
Type: SystemInt32
Specifies number of characters to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.

Return Value

Type: Boolean
True if method succeed; otherwise false.

Implements

IEditDeleteLeft(Int32, Boolean)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DeleteRight Method

SyntaxEditDeleteRight Method
Deletes a specified number of characters to the right of the active point.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DeleteRight(
    int len,
    bool withChange = false
)
Public Overridable Function DeleteRight (
    len As Integer,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool DeleteRight(
    int len,
    bool withChange = false
)
abstract DeleteRight :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override DeleteRight :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

len
Type: SystemInt32
Specifies number of characters to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.

Return Value

Type: Boolean
True if method succeed; otherwise false.

Implements

IEditDeleteRight(Int32, Boolean)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DestroyCaret Method

SyntaxEditDestroyCaret Method
Destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DestroyCaret()
Public Overridable Sub DestroyCaret
public:
virtual void DestroyCaret()
abstract DestroyCaret : unit -> unit
override DestroyCaret : unit -> unit

Implements

ICaretDestroyCaret
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisablePositionUpdate Method

SyntaxEditDisablePositionUpdate Method
Prevents notification of changing of caret position until calling EnablePositionUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DisablePositionUpdate()
Public Overridable Sub DisablePositionUpdate
public:
virtual void DisablePositionUpdate()
abstract DisablePositionUpdate : unit -> unit
override DisablePositionUpdate : unit -> unit

Return Value

Type:
Number of object state updating locks.

Implements

INavigateDisablePositionUpdate
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisableUpdate Method

SyntaxEditDisableUpdate Method
Prevents editor updating until calling EnableUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisplayDragCaret Method

SyntaxEditDisplayDragCaret Method
Displays dragging caret rather than regular caret.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DisplayDragCaret()
Public Overridable Sub DisplayDragCaret
public:
virtual void DisplayDragCaret()
abstract DisplayDragCaret : unit -> unit
override DisplayDragCaret : unit -> unit

Implements

ICaretDisplayDragCaret
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisplayGotoLineDialog Method

SyntaxEditDisplayGotoLineDialog Method
Overload List
 | Name | Description
Public method | DisplayGotoLineDialog | Initializes and runs a dialog prompting you for index of the line you need to locate.
Public method | DisplayGotoLineDialog(IWin32Window) | Initializes and runs a dialog prompting you for index of the line you need to locate.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisplayGotoLineDialog Method

SyntaxEditDisplayGotoLineDialog Method
Initializes and runs a dialog prompting you for index of the line you need to locate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult DisplayGotoLineDialog()
Public Overridable Function DisplayGotoLineDialog As DialogResult
public:
virtual DialogResult DisplayGotoLineDialog()
abstract DisplayGotoLineDialog : unit -> DialogResult
override DisplayGotoLineDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplayGotoLineDialog
See Also

Reference

SyntaxEdit Class
DisplayGotoLineDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplayGotoLineDialog Method (IWin32Window)

SyntaxEditDisplayGotoLineDialog Method (IWin32Window)
Initializes and runs a dialog prompting you for index of the line you need to locate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult DisplayGotoLineDialog(
    IWin32Window owner
)
Public Overridable Function DisplayGotoLineDialog (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult DisplayGotoLineDialog(
    IWin32Window^ owner
)
abstract DisplayGotoLineDialog :
        owner : IWin32Window -> DialogResult
override DisplayGotoLineDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplayGotoLineDialog(IWin32Window)
See Also

Reference

SyntaxEdit Class
DisplayGotoLineDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplayModalReplaceDialog Method

SyntaxEditDisplayModalReplaceDialog Method
Overload List
 | Name | Description
Public method | DisplayModalReplaceDialog | Initializes and runs a modal dialog box allowing you to search for text and replace it.
Public method | DisplayModalReplaceDialog(IWin32Window) | Initializes and runs a modal dialog box allowing you to search for text and replace it.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisplayModalReplaceDialog Method

SyntaxEditDisplayModalReplaceDialog Method
Initializes and runs a modal dialog box allowing you to search for text and replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DialogResult DisplayModalReplaceDialog()
Public Function DisplayModalReplaceDialog As DialogResult
public:
virtual DialogResult DisplayModalReplaceDialog() sealed
abstract DisplayModalReplaceDialog : unit -> DialogResult
override DisplayModalReplaceDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplayModalReplaceDialog
See Also

Reference

SyntaxEdit Class
DisplayModalReplaceDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplayModalReplaceDialog Method (IWin32Window)

SyntaxEditDisplayModalReplaceDialog Method (IWin32Window)
Initializes and runs a modal dialog box allowing you to search for text and replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DialogResult DisplayModalReplaceDialog(
    IWin32Window owner
)
Public Function DisplayModalReplaceDialog (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult DisplayModalReplaceDialog(
    IWin32Window^ owner
) sealed
abstract DisplayModalReplaceDialog :
        owner : IWin32Window -> DialogResult
override DisplayModalReplaceDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplayModalReplaceDialog(IWin32Window)
See Also

Reference

SyntaxEdit Class
DisplayModalReplaceDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplayModalSearchDialog Method

SyntaxEditDisplayModalSearchDialog Method
Overload List
 | Name | Description
Public method | DisplayModalSearchDialog | Initializes and runs a modal dialog box allowing you to search for some text.
Public method | DisplayModalSearchDialog(IWin32Window) | Initializes and runs a modal dialog box allowing you to search for some text.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisplayModalSearchDialog Method

SyntaxEditDisplayModalSearchDialog Method
Initializes and runs a modal dialog box allowing you to search for some text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DialogResult DisplayModalSearchDialog()
Public Function DisplayModalSearchDialog As DialogResult
public:
virtual DialogResult DisplayModalSearchDialog() sealed
abstract DisplayModalSearchDialog : unit -> DialogResult
override DisplayModalSearchDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplayModalSearchDialog
See Also

Reference

SyntaxEdit Class
DisplayModalSearchDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplayModalSearchDialog Method (IWin32Window)

SyntaxEditDisplayModalSearchDialog Method (IWin32Window)
Initializes and runs a modal dialog box allowing you to search for some text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DialogResult DisplayModalSearchDialog(
    IWin32Window owner
)
Public Function DisplayModalSearchDialog (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult DisplayModalSearchDialog(
    IWin32Window^ owner
) sealed
abstract DisplayModalSearchDialog :
        owner : IWin32Window -> DialogResult
override DisplayModalSearchDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplayModalSearchDialog(IWin32Window)
See Also

Reference

SyntaxEdit Class
DisplayModalSearchDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplayReplaceDialog Method

SyntaxEditDisplayReplaceDialog Method
Overload List
 | Name | Description
Public method | DisplayReplaceDialog | Initializes and runs a dialog box allowing you to search for text and replace it.
Public method | DisplayReplaceDialog(IWin32Window) | Initializes and runs a dialog box allowing you to search for text and replace it.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisplayReplaceDialog Method

SyntaxEditDisplayReplaceDialog Method
Initializes and runs a dialog box allowing you to search for text and replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult DisplayReplaceDialog()
Public Overridable Function DisplayReplaceDialog As DialogResult
public:
virtual DialogResult DisplayReplaceDialog()
abstract DisplayReplaceDialog : unit -> DialogResult
override DisplayReplaceDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplayReplaceDialog
See Also

Reference

SyntaxEdit Class
DisplayReplaceDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplayReplaceDialog Method (IWin32Window)

SyntaxEditDisplayReplaceDialog Method (IWin32Window)
Initializes and runs a dialog box allowing you to search for text and replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult DisplayReplaceDialog(
    IWin32Window owner
)
Public Overridable Function DisplayReplaceDialog (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult DisplayReplaceDialog(
    IWin32Window^ owner
)
abstract DisplayReplaceDialog :
        owner : IWin32Window -> DialogResult
override DisplayReplaceDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplayReplaceDialog(IWin32Window)
See Also

Reference

SyntaxEdit Class
DisplayReplaceDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplaySearchDialog Method

SyntaxEditDisplaySearchDialog Method
Overload List
 | Name | Description
Public method | DisplaySearchDialog | Initializes and runs a dialog box allowing you to search for some text.
Public method | DisplaySearchDialog(IWin32Window) | Initializes and runs a dialog box allowing you to search for some text.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisplaySearchDialog Method

SyntaxEditDisplaySearchDialog Method
Initializes and runs a dialog box allowing you to search for some text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult DisplaySearchDialog()
Public Overridable Function DisplaySearchDialog As DialogResult
public:
virtual DialogResult DisplaySearchDialog()
abstract DisplaySearchDialog : unit -> DialogResult
override DisplaySearchDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplaySearchDialog
See Also

Reference

SyntaxEdit Class
DisplaySearchDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplaySearchDialog Method (IWin32Window)

SyntaxEditDisplaySearchDialog Method (IWin32Window)
Initializes and runs a dialog box allowing you to search for some text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult DisplaySearchDialog(
    IWin32Window owner
)
Public Overridable Function DisplaySearchDialog (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult DisplaySearchDialog(
    IWin32Window^ owner
)
abstract DisplaySearchDialog :
        owner : IWin32Window -> DialogResult
override DisplaySearchDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISyntaxEditDisplaySearchDialog(IWin32Window)
See Also

Reference

SyntaxEdit Class
DisplaySearchDialog Overload
Alternet.Editor Namespace


SyntaxEdit.DisplayToScreen Method

SyntaxEditDisplayToScreen Method
Overload List
 | Name | Description
Public method | DisplayToScreen(Int32, Int32) | Converts given display coordinates, index of line and character, to screen coordinates.
Public method | DisplayToScreen(Int32, Int32, Boolean) | Converts given display coordinates, index of line and character, to screen coordinates.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisplayToScreen Method (Int32, Int32)

SyntaxEditDisplayToScreen Method (Int32, Int32)
Converts given display coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point DisplayToScreen(
    int x,
    int y
)
Public Overridable Function DisplayToScreen (
    x As Integer,
    y As Integer
) As Point
public:
virtual Point DisplayToScreen(
    int x,
    int y
)
abstract DisplayToScreen :
        x : int *
        y : int -> Point
override DisplayToScreen :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
Index of character in the line.
y
Type: SystemInt32
Index of line.

Return Value

Type: Point
The Point representing screen coordinate.

Implements

ISyntaxEditDisplayToScreen(Int32, Int32)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

SyntaxEdit Class
DisplayToScreen Overload
Alternet.Editor Namespace


SyntaxEdit.DisplayToScreen Method (Int32, Int32, Boolean)

SyntaxEditDisplayToScreen Method (Int32, Int32, Boolean)
Converts given display coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point DisplayToScreen(
    int x,
    int y,
    bool average
)
Public Overridable Function DisplayToScreen (
    x As Integer,
    y As Integer,
    average As Boolean
) As Point
public:
virtual Point DisplayToScreen(
    int x,
    int y,
    bool average
)
abstract DisplayToScreen :
        x : int *
        y : int *
        average : bool -> Point
override DisplayToScreen :
        x : int *
        y : int *
        average : bool -> Point

Parameters

x
Type: SystemInt32
Index of character in the line.
y
Type: SystemInt32
Index of line.
average
Type: SystemBoolean

Return Value

Type: Point
The Point representing screen coordinate.

Implements

ISyntaxEditDisplayToScreen(Int32, Int32, Boolean)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

SyntaxEdit Class
DisplayToScreen Overload
Alternet.Editor Namespace


SyntaxEdit.EnablePositionUpdate Method

SyntaxEditEnablePositionUpdate Method
Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EnablePositionUpdate()
Public Overridable Sub EnablePositionUpdate
public:
virtual void EnablePositionUpdate()
abstract EnablePositionUpdate : unit -> unit
override EnablePositionUpdate : unit -> unit

Return Value

Type:
Number of object state updating locks.

Implements

INavigateEnablePositionUpdate
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.EnableUpdate Method

SyntaxEditEnableUpdate Method
Re-enables editor updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.EndUpdate Method

SyntaxEditEndUpdate Method
Re-enables outline editor updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of outline list updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Find Method

SyntaxEditFind Method
Overload List
 | Name | Description
Public method | Find(String) | Searches for given text within the control's contents.
Public method | Find(String, SearchOptions) | Searches for given text within the control's contents with specified options.
Public method | Find(String, SearchOptions, Regex) | Searches for given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, IListIRange) | Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, Boolean, Boolean) | Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
Public method | Find(String, SearchOptions, Regex, Point, Int32, Match) | Searches for given text within the control's text content.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Find Method (String)

SyntaxEditFind Method (String)
Searches for given text within the control's contents.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Find(
    string text
)
Public Overridable Function Find (
    text As String
) As Boolean
public:
virtual bool Find(
    String^ text
)
abstract Find :
        text : string -> bool
override Find :
        text : string -> bool

Parameters

text
Type: SystemString
Text to find.

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchFind(String)
See Also

Reference

SyntaxEdit Class
Find Overload
Alternet.Editor Namespace


SyntaxEdit.Find Method (String, SearchOptions)

SyntaxEditFind Method (String, SearchOptions)
Searches for given text within the control's contents with specified options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Find(
    string text,
    SearchOptions options
)
Public Overridable Function Find (
    text As String,
    options As SearchOptions
) As Boolean
public:
virtual bool Find(
    String^ text,
    SearchOptions options
)
abstract Find :
        text : string *
        options : SearchOptions -> bool
override Find :
        text : string *
        options : SearchOptions -> bool

Parameters

text
Type: SystemString
Text to find.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchFind(String, SearchOptions)
See Also

Reference

SyntaxEdit Class
Find Overload
Alternet.Editor Namespace


SyntaxEdit.Find Method (String, SearchOptions, Regex)

SyntaxEditFind Method (String, SearchOptions, Regex)
Searches for given text within the control's contents with specified options using specified regular expression.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Find(
    string text,
    SearchOptions options,
    Regex expression
)
Public Overridable Function Find (
    text As String,
    options As SearchOptions,
    expression As Regex
) As Boolean
public:
virtual bool Find(
    String^ text,
    SearchOptions options,
    Regex^ expression
)
abstract Find :
        text : string *
        options : SearchOptions *
        expression : Regex -> bool
override Find :
        text : string *
        options : SearchOptions *
        expression : Regex -> bool

Parameters

text
Type: SystemString
Text to find.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchFind(String, SearchOptions, Regex)
See Also

Reference

SyntaxEdit Class
Find Overload
Alternet.Editor Namespace


SyntaxEdit.Find Method (String, SearchOptions, Regex, IList(IRange))

SyntaxEditFind Method (String, SearchOptions, Regex, IListIRange)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Find(
    string text,
    SearchOptions options,
    Regex expression,
    IList<IRange> ranges
)
Public Overridable Function Find (
    text As String,
    options As SearchOptions,
    expression As Regex,
    ranges As IList(Of IRange)
) As Boolean
public:
virtual bool Find(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    IList<IRange^>^ ranges
)
abstract Find :
        text : string *
        options : SearchOptions *
        expression : Regex *
        ranges : IList<IRange> -> bool
override Find :
        text : string *
        options : SearchOptions *
        expression : Regex *
        ranges : IList<IRange> -> bool

Parameters

text
Type: SystemString
Text to find.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
ranges
Type: System.Collections.GenericIListIRange
Represents list of ranges determining search results.

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchFind(String, SearchOptions, Regex, IListIRange)
See Also

Reference

SyntaxEdit Class
Find Overload
Alternet.Editor Namespace


SyntaxEdit.Find Method (String, SearchOptions, Regex, Boolean, Boolean)

SyntaxEditFind Method (String, SearchOptions, Regex, Boolean, Boolean)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Find(
    string text,
    SearchOptions options,
    Regex expression,
    bool firstSearch,
    bool silent
)
Public Overridable Function Find (
    text As String,
    options As SearchOptions,
    expression As Regex,
    firstSearch As Boolean,
    silent As Boolean
) As Boolean
public:
virtual bool Find(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    bool firstSearch,
    bool silent
)
abstract Find :
        text : string *
        options : SearchOptions *
        expression : Regex *
        firstSearch : bool *
        silent : bool -> bool
override Find :
        text : string *
        options : SearchOptions *
        expression : Regex *
        firstSearch : bool *
        silent : bool -> bool

Parameters

text
Type: SystemString
Text to find.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
firstSearch
Type: SystemBoolean
Specifies if search is performed the first time.
silent
Type: SystemBoolean
Determines if no visual feedback is required.

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchFind(String, SearchOptions, Regex, Boolean, Boolean)
See Also

Reference

SyntaxEdit Class
Find Overload
Alternet.Editor Namespace


SyntaxEdit.Find Method (String, SearchOptions, Regex, Point, Int32, Match)

SyntaxEditFind Method (String, SearchOptions, Regex, Point, Int32, Match)
Searches for given text within the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Find(
    string s,
    SearchOptions options,
    Regex expression,
    ref Point position,
    out int len,
    out Match match
)
Public Overridable Function Find (
    s As String,
    options As SearchOptions,
    expression As Regex,
    ByRef position As Point,
    <OutAttribute> ByRef len As Integer,
    <OutAttribute> ByRef match As Match
) As Boolean
public:
virtual bool Find(
    String^ s,
    SearchOptions options,
    Regex^ expression,
    Point% position,
    [OutAttribute] int% len,
    [OutAttribute] Match^% match
)
abstract Find :
        s : string *
        options : SearchOptions *
        expression : Regex *
        position : Point byref *
        len : int byref *
        match : Match byref -> bool
override Find :
        s : string *
        options : SearchOptions *
        expression : Regex *
        position : Point byref *
        len : int byref *
        match : Match byref -> bool

Parameters

s
Type: SystemString
The text to locate in the collection.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
position
Type: System.DrawingPoint
Position in strings collection to start search.
len
Type: SystemInt32
Receives length of the found text.
match
Type: System.Text.RegularExpressionsMatch
Receives match if regular expression search successful.

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ITextSearchFind(String, SearchOptions, Regex, Point, Int32, Match)
Remarks
If search succeed position parameter receive location of the found text.
See Also

Reference

SyntaxEdit Class
Find Overload
Alternet.Editor Namespace


SyntaxEdit.FindNext Method

SyntaxEditFindNext Method
Searches for the next occurrence of the text specified by previous search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindNext()
Public Overridable Function FindNext As Boolean
public:
virtual bool FindNext()
abstract FindNext : unit -> bool
override FindNext : unit -> bool

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchFindNext
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.FindNextSelected Method

SyntaxEditFindNextSelected Method
Searches for the next occurrence of the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindNextSelected()
Public Overridable Function FindNextSelected As Boolean
public:
virtual bool FindNextSelected()
abstract FindNextSelected : unit -> bool
override FindNextSelected : unit -> bool

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchFindNextSelected
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.FindPrevious Method

SyntaxEditFindPrevious Method
Searches for the previous occurrence of the text specified by previous search.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindPrevious()
Public Overridable Function FindPrevious As Boolean
public:
virtual bool FindPrevious()
abstract FindPrevious : unit -> bool
override FindPrevious : unit -> bool

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchFindPrevious
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.FindPreviousSelected Method

SyntaxEditFindPreviousSelected Method
Searches for the previous occurrence of the selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindPreviousSelected()
Public Overridable Function FindPreviousSelected As Boolean
public:
virtual bool FindPreviousSelected()
abstract FindPreviousSelected : unit -> bool
override FindPreviousSelected : unit -> bool

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ISearchFindPreviousSelected
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.FinishIncrementalSearch Method

SyntaxEditFinishIncrementalSearch Method
Leaves control from the incremental search state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FinishIncrementalSearch()
Public Overridable Sub FinishIncrementalSearch
public:
virtual void FinishIncrementalSearch()
abstract FinishIncrementalSearch : unit -> unit
override FinishIncrementalSearch : unit -> unit

Implements

ISearchFinishIncrementalSearch
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace
SyntaxEditStartIncrementalSearch


SyntaxEdit.GetCaretSize Method

SyntaxEditGetCaretSize Method
Returns size of the caret's current shape at given position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size GetCaretSize(
    Point position
)
Public Overridable Function GetCaretSize (
    position As Point
) As Size
public:
virtual Size GetCaretSize(
    Point position
)
abstract GetCaretSize :
        position : Point -> Size
override GetCaretSize :
        position : Point -> Size

Parameters

position
Type: System.DrawingPoint
Point at which caret size should be calculated.

Return Value

Type: Size
Size of the caret.

Implements

ICaretGetCaretSize(Point)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GetCharsInWidth Method

SyntaxEditGetCharsInWidth Method
Returns number of characters painted with current font that will fit into specified Width.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetCharsInWidth(
    int width
)
Public Overridable Function GetCharsInWidth (
    width As Integer
) As Integer
public:
virtual int GetCharsInWidth(
    int width
)
abstract GetCharsInWidth :
        width : int -> int
override GetCharsInWidth :
        width : int -> int

Parameters

width
Type: SystemInt32
Width to fit characters.

Return Value

Type: Int32
Number of characters that can fit in.

Implements

ISyntaxEditGetCharsInWidth(Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GetHitTest Method

SyntaxEditGetHitTest Method
Overload List
 | Name | Description
Public method | GetHitTest(Point, IHitTestInfo) | Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Public method | GetHitTest(Int32, Int32, IHitTestInfo) | Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GetHitTest Method (Point, IHitTestInfo)

SyntaxEditGetHitTest Method (Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GetHitTest(
    Point position,
    IHitTestInfo hitTestInfo
)
Public Overridable Sub GetHitTest (
    position As Point,
    hitTestInfo As IHitTestInfo
)
public:
virtual void GetHitTest(
    Point position,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTest :
        position : Point *
        hitTestInfo : IHitTestInfo -> unit
override GetHitTest :
        position : Point *
        hitTestInfo : IHitTestInfo -> unit

Parameters

position
Type: System.DrawingPoint
Specifies coordinate to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.

Implements

ISyntaxEditGetHitTest(Point, IHitTestInfo)
See Also

Reference

SyntaxEdit Class
GetHitTest Overload
Alternet.Editor Namespace


SyntaxEdit.GetHitTest Method (Int32, Int32, IHitTestInfo)

SyntaxEditGetHitTest Method (Int32, Int32, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GetHitTest(
    int x,
    int y,
    IHitTestInfo hitTestInfo
)
Public Overridable Sub GetHitTest (
    x As Integer,
    y As Integer,
    hitTestInfo As IHitTestInfo
)
public:
virtual void GetHitTest(
    int x,
    int y,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTest :
        x : int *
        y : int *
        hitTestInfo : IHitTestInfo -> unit
override GetHitTest :
        x : int *
        y : int *
        hitTestInfo : IHitTestInfo -> unit

Parameters

x
Type: SystemInt32
Specifies horizontal coordinate of position to check.
y
Type: SystemInt32
Specifies vertical coordinate of position to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.

Implements

ISyntaxEditGetHitTest(Int32, Int32, IHitTestInfo)
See Also

Reference

SyntaxEdit Class
GetHitTest Overload
Alternet.Editor Namespace


SyntaxEdit.GetHitTestAtTextPoint Method

SyntaxEditGetHitTestAtTextPoint Method
Overload List
 | Name | Description
Public method | GetHitTestAtTextPoint(Point, IHitTestInfo) | Fills hitTestInfo parameter by information about a part of control at specified text coordinate.
Public method | GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo) | Retrieves information about part of control at specified text coordinate.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GetHitTestAtTextPoint Method (Point, IHitTestInfo)

SyntaxEditGetHitTestAtTextPoint Method (Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of control at specified text coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GetHitTestAtTextPoint(
    Point position,
    IHitTestInfo hitTestInfo
)
Public Overridable Sub GetHitTestAtTextPoint (
    position As Point,
    hitTestInfo As IHitTestInfo
)
public:
virtual void GetHitTestAtTextPoint(
    Point position,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTestAtTextPoint :
        position : Point *
        hitTestInfo : IHitTestInfo -> unit
override GetHitTestAtTextPoint :
        position : Point *
        hitTestInfo : IHitTestInfo -> unit

Parameters

position
Type: System.DrawingPoint
Specifies coordinate to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.

Implements

ISyntaxEditGetHitTestAtTextPoint(Point, IHitTestInfo)
See Also

Reference

SyntaxEdit Class
GetHitTestAtTextPoint Overload
Alternet.Editor Namespace


SyntaxEdit.GetHitTestAtTextPoint Method (Int32, Int32, IHitTestInfo)

SyntaxEditGetHitTestAtTextPoint Method (Int32, Int32, IHitTestInfo)
Retrieves information about part of control at specified text coordinate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GetHitTestAtTextPoint(
    int x,
    int y,
    IHitTestInfo hitTestInfo
)
Public Overridable Sub GetHitTestAtTextPoint (
    x As Integer,
    y As Integer,
    hitTestInfo As IHitTestInfo
)
public:
virtual void GetHitTestAtTextPoint(
    int x,
    int y,
    IHitTestInfo^ hitTestInfo
)
abstract GetHitTestAtTextPoint :
        x : int *
        y : int *
        hitTestInfo : IHitTestInfo -> unit
override GetHitTestAtTextPoint :
        x : int *
        y : int *
        hitTestInfo : IHitTestInfo -> unit

Parameters

x
Type: SystemInt32
Specifies horizontal coordinate of text position to check.
y
Type: SystemInt32
Specifies vertical coordinate of text position to check.
hitTestInfo
Type: Alternet.EditorIHitTestInfo
Retrieves information about part of control.

Implements

ISyntaxEditGetHitTestAtTextPoint(Int32, Int32, IHitTestInfo)
See Also

Reference

SyntaxEdit Class
GetHitTestAtTextPoint Overload
Alternet.Editor Namespace


SyntaxEdit.GetIndentString Method

SyntaxEditGetIndentString Method
Gets indentation string at current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetIndentString()
Public Overridable Function GetIndentString As String
public:
virtual String^ GetIndentString()
abstract GetIndentString : unit -> string
override GetIndentString : unit -> string

Return Value

Type: String

Implements

IEditGetIndentString
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GetLinesInHeight Method

SyntaxEditGetLinesInHeight Method
Determines how many lines can fit into given Height.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetLinesInHeight(
    int height
)
Public Overridable Function GetLinesInHeight (
    height As Integer
) As Integer
public:
virtual int GetLinesInHeight(
    int height
)
abstract GetLinesInHeight :
        height : int -> int
override GetLinesInHeight :
        height : int -> int

Parameters

height
Type: SystemInt32
Height to fit lines.

Return Value

Type: Int32
Number of lines that can fit in.

Implements

ISyntaxEditGetLinesInHeight(Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GetTextAtCursor Method

SyntaxEditGetTextAtCursor Method
Returns word at the cursor position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTextAtCursor()
Public Overridable Function GetTextAtCursor As String
public:
virtual String^ GetTextAtCursor()
abstract GetTextAtCursor : unit -> string
override GetTextAtCursor : unit -> string

Return Value

Type: String
Word at the cursor position.

Implements

ISyntaxEditGetTextAtCursor
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GetTextToSearchAtCursor Method

SyntaxEditGetTextToSearchAtCursor Method
Returns word at the cursor position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTextToSearchAtCursor()
Public Overridable Function GetTextToSearchAtCursor As String
public:
virtual String^ GetTextToSearchAtCursor()
abstract GetTextToSearchAtCursor : unit -> string
override GetTextToSearchAtCursor : unit -> string

Return Value

Type: String
Word at the cursor position.

Implements

ISearchGetTextToSearchAtCursor
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GetWordAt Method

SyntaxEditGetWordAt Method
Checks word accordingly to specified conditions.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetWordAt(
    IStringItem item,
    int pos,
    out int left,
    out int right
)
Public Overridable Function GetWordAt (
    item As IStringItem,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer
) As Boolean
public:
virtual bool GetWordAt(
    IStringItem^ item,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right
)
abstract GetWordAt :
        item : IStringItem *
        pos : int *
        left : int byref *
        right : int byref -> bool
override GetWordAt :
        item : IStringItem *
        pos : int *
        left : int byref *
        right : int byref -> bool

Parameters

item
Type: Alternet.SyntaxIStringItem
IStringItem where word should be checked.
pos
Type: SystemInt32
Position to check.
left
Type: SystemInt32
Receives start character number of the word.
right
Type: SystemInt32
Receives end character number of the word.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GetWrapMargin Method

SyntaxEditGetWrapMargin Method
Returns position of the wrapping margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetWrapMargin()
Public Overridable Function GetWrapMargin As Integer
public:
virtual int GetWrapMargin()
abstract GetWrapMargin : unit -> int
override GetWrapMargin : unit -> int

Return Value

Type: Int32

Implements

IWordWrapGetWrapMargin
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HasAutoCorrection Method

SyntaxEditHasAutoCorrection Method
Checks whether specified word has correction.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasAutoCorrection(
    string word,
    out string correctWord
)
Public Overridable Function HasAutoCorrection (
    word As String,
    <OutAttribute> ByRef correctWord As String
) As Boolean
public:
virtual bool HasAutoCorrection(
    String^ word,
    [OutAttribute] String^% correctWord
)
abstract HasAutoCorrection :
        word : string *
        correctWord : string byref -> bool
override HasAutoCorrection :
        word : string *
        correctWord : string byref -> bool

Parameters

word
Type: SystemString
Word that should be corrected.
correctWord
Type: SystemString
Receives a corrected word.

Return Value

Type: Boolean
True if word has correction; otherwise false.

Implements

IAutoCorrectHasAutoCorrection(String, String)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HideDragCaret Method

SyntaxEditHideDragCaret Method
Hides dragging caret.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void HideDragCaret()
Public Overridable Sub HideDragCaret
public:
virtual void HideDragCaret()
abstract HideDragCaret : unit -> unit
override HideDragCaret : unit -> unit

Implements

ICaretHideDragCaret
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HideScrollHint Method

SyntaxEditHideScrollHint Method
Hides scroll hint window if necessary.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void HideScrollHint()
Public Overridable Sub HideScrollHint
public:
virtual void HideScrollHint()
abstract HideScrollHint : unit -> unit
override HideScrollHint : unit -> unit

Implements

ISyntaxEditHideScrollHint
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HighlightAll Method

SyntaxEditHighlightAll Method
Highlights all occurrences of specified string in the class text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int HighlightAll(
    string text,
    SearchOptions options,
    Regex expression
)
Public Overridable Function HighlightAll (
    text As String,
    options As SearchOptions,
    expression As Regex
) As Integer
public:
virtual int HighlightAll(
    String^ text,
    SearchOptions options,
    Regex^ expression
)
abstract HighlightAll :
        text : string *
        options : SearchOptions *
        expression : Regex -> int
override HighlightAll :
        text : string *
        options : SearchOptions *
        expression : Regex -> int

Parameters

text
Type: SystemString
Specifies text to mark.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.

Return Value

Type: Int32
Number of found occurrences.

Implements

ISearchHighlightAll(String, SearchOptions, Regex)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.IncrementalSearch Method

SyntaxEditIncrementalSearch Method
Finds given text incrementally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IncrementalSearch(
    string key,
    bool deleteLast
)
Public Overridable Function IncrementalSearch (
    key As String,
    deleteLast As Boolean
) As Boolean
public:
virtual bool IncrementalSearch(
    String^ key,
    bool deleteLast
)
abstract IncrementalSearch :
        key : string *
        deleteLast : bool -> bool
override IncrementalSearch :
        key : string *
        deleteLast : bool -> bool

Parameters

key
Type: SystemString
Additional value to search text.
deleteLast
Type: SystemBoolean
Specifies whether search text should be altered by adding Key string.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISearchIncrementalSearch(String, Boolean)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.IndentLine Method

SyntaxEditIndentLine Method
Overload List
 | Name | Description
Public method | IndentLine | Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
Public method | IndentLine(String, Boolean) | Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.IndentLine Method

SyntaxEditIndentLine Method
Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void IndentLine()
Public Overridable Sub IndentLine
public:
virtual void IndentLine()
abstract IndentLine : unit -> unit
override IndentLine : unit -> unit

Implements

IEditIndentLine
See Also

Reference

SyntaxEdit Class
IndentLine Overload
Alternet.Editor Namespace


SyntaxEdit.IndentLine Method (String, Boolean)

SyntaxEditIndentLine Method (String, Boolean)
Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void IndentLine(
    string indent,
    bool withChange = false
)
Public Overridable Sub IndentLine (
    indent As String,
    Optional withChange As Boolean = false
)
public:
virtual void IndentLine(
    String^ indent,
    bool withChange = false
)
abstract IndentLine :
        indent : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit
override IndentLine :
        indent : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit

Parameters

indent
Type: SystemString
withChange (Optional)
Type: SystemBoolean

Implements

IEditIndentLine(String, Boolean)
See Also

Reference

SyntaxEdit Class
IndentLine Overload
Alternet.Editor Namespace


SyntaxEdit.Insert Method

SyntaxEditInsert Method
Inserts the given string at the specified location.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    string text,
    bool withChange = false
)
Public Overridable Function Insert (
    text As String,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool Insert(
    String^ text,
    bool withChange = false
)
abstract Insert :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override Insert :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

text
Type: SystemString
The text to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsert(String, Boolean)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.InsertBlock Method

SyntaxEditInsertBlock Method
Overload List
 | Name | Description
Public method | InsertBlock(String, Boolean) | Inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | Inserts the given string array at the specified location.
Public method | InsertBlock(ITextStrings, Boolean) | Inserts the given string collection at the specified location.
Public method | InsertBlock(String, Boolean, Boolean) | When implemented by a class, inserts the given string array at the specified location.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.InsertBlock Method (String, Boolean)

SyntaxEditInsertBlock Method (String, Boolean)
Inserts the given string at the specified location.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertBlock(
    string text,
    bool withChange = false
)
Public Overridable Function InsertBlock (
    text As String,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool InsertBlock(
    String^ text,
    bool withChange = false
)
abstract InsertBlock :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override InsertBlock :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

text
Type: SystemString
String to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertBlock(String, Boolean)
See Also

Reference

SyntaxEdit Class
InsertBlock Overload
Alternet.Editor Namespace


SyntaxEdit.InsertBlock Method (String[], Boolean)

SyntaxEditInsertBlock Method (String, Boolean)
Inserts the given string array at the specified location.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertBlock(
    string[] strings,
    bool withChange = false
)
Public Overridable Function InsertBlock (
    strings As String(),
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool InsertBlock(
    array<String^>^ strings,
    bool withChange = false
)
abstract InsertBlock :
        strings : string[] *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override InsertBlock :
        strings : string[] *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

strings
Type: SystemString
String array to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertBlock(String, Boolean)
See Also

Reference

SyntaxEdit Class
InsertBlock Overload
Alternet.Editor Namespace


SyntaxEdit.InsertBlock Method (ITextStrings, Boolean)

SyntaxEditInsertBlock Method (ITextStrings, Boolean)
Inserts the given string collection at the specified location.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertBlock(
    ITextStrings strings,
    bool withChange = false
)
Public Overridable Function InsertBlock (
    strings As ITextStrings,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool InsertBlock(
    ITextStrings^ strings,
    bool withChange = false
)
abstract InsertBlock :
        strings : ITextStrings *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override InsertBlock :
        strings : ITextStrings *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

strings
Type: Alternet.Editor.TextSourceITextStrings
Collection of strings to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertBlock(ITextStrings, Boolean)
See Also

Reference

SyntaxEdit Class
InsertBlock Overload
Alternet.Editor Namespace


SyntaxEdit.InsertBlock Method (String[], Boolean, Boolean)

SyntaxEditInsertBlock Method (String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertBlock(
    string[] strings,
    bool select,
    bool withChange = false
)
Public Overridable Function InsertBlock (
    strings As String(),
    select As Boolean,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool InsertBlock(
    array<String^>^ strings,
    bool select,
    bool withChange = false
)
abstract InsertBlock :
        strings : string[] *
        select : bool *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override InsertBlock :
        strings : string[] *
        select : bool *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

strings
Type: SystemString
String array to insert.
select
Type: SystemBoolean
Specifies whether inserted block should be selected.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertBlock(String, Boolean, Boolean)
See Also

Reference

SyntaxEdit Class
InsertBlock Overload
Alternet.Editor Namespace


SyntaxEdit.InsertFromFile Method

SyntaxEditInsertFromFile Method
Inserts the file text content at the specified location.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertFromFile(
    string fileName
)
Public Overridable Function InsertFromFile (
    fileName As String
) As Boolean
public:
virtual bool InsertFromFile(
    String^ fileName
)
abstract InsertFromFile :
        fileName : string -> bool
override InsertFromFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load text from.

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertFromFile(String)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.IsValidText Method

SyntaxEditIsValidText Method
Indicates whether text at the specified position is valid (that is does not contain comments or string constants).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsValidText(
    Point position
)
Public Overridable Function IsValidText (
    position As Point
) As Boolean
public:
virtual bool IsValidText(
    Point position
)
abstract IsValidText :
        position : Point -> bool
override IsValidText :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.

Return Value

Type: Boolean
True if text is not plain; otherwise false.

Implements

ICodeCompletionIsValidText(Point)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.KillFocus Method

SyntaxEditKillFocus Method
Ensure the caret is not visible.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void KillFocus()
Public Overridable Sub KillFocus
public:
virtual void KillFocus()
abstract KillFocus : unit -> unit
override KillFocus : unit -> unit

Implements

ICaretKillFocus
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LineIsHidden Method

SyntaxEditLineIsHidden Method
Determines whether the given line is hidden.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LineIsHidden(
    int index
)
Public Overridable Function LineIsHidden (
    index As Integer
) As Boolean
public:
virtual bool LineIsHidden(
    int index
)
abstract LineIsHidden :
        index : int -> bool
override LineIsHidden :
        index : int -> bool

Parameters

index
Type: SystemInt32
Line index.

Return Value

Type: Boolean
True if the line at given index is hidden; otherwise false.

Implements

IEditLineIsHidden(Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LineIsReadonly Method

SyntaxEditLineIsReadonly Method
Determines whether the given line is readonly.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LineIsReadonly(
    int index
)
Public Overridable Function LineIsReadonly (
    index As Integer
) As Boolean
public:
virtual bool LineIsReadonly(
    int index
)
abstract LineIsReadonly :
        index : int -> bool
override LineIsReadonly :
        index : int -> bool

Parameters

index
Type: SystemInt32
Line index.

Return Value

Type: Boolean
True if the line at given index is readonly; otherwise false.

Implements

IEditLineIsReadonly(Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ListMembers Method

SyntaxEditListMembers Method
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ListMembers()
Public Overridable Sub ListMembers
public:
virtual void ListMembers()
abstract ListMembers : unit -> unit
override ListMembers : unit -> unit

Implements

ICodeCompletionListMembers
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LoadFile Method

SyntaxEditLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LoadFile Method (String)

SyntaxEditLoadFile Method (String)
Loads the contents of the specified file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName
)
Public Overridable Function LoadFile (
    fileName As String
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool
override LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String)
See Also

Reference

SyntaxEdit Class
LoadFile Overload
Alternet.Editor Namespace


SyntaxEdit.LoadFile Method (String, IStringImport)

SyntaxEditLoadFile Method (String, IStringImport)
Loads content from the given file with specified importer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    IStringImport importer
)
Public Overridable Function LoadFile (
    fileName As String,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    IStringImport^ importer
)
abstract LoadFile :
        fileName : string *
        importer : IStringImport -> bool
override LoadFile :
        fileName : string *
        importer : IStringImport -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadFile(String, IStringImport)
See Also

Reference

SyntaxEdit Class
LoadFile Overload
Alternet.Editor Namespace


SyntaxEdit.LoadFile Method (String, Encoding)

SyntaxEditLoadFile Method (String, Encoding)
Loads the contents of the specified file with specified encoding.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

SyntaxEdit Class
LoadFile Overload
Alternet.Editor Namespace


SyntaxEdit.LoadFile Method (String, IStringImport, Encoding)

SyntaxEditLoadFile Method (String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    IStringImport importer,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    IStringImport^ importer,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        importer : IStringImport *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadFile(String, IStringImport, Encoding)
See Also

Reference

SyntaxEdit Class
LoadFile Overload
Alternet.Editor Namespace


SyntaxEdit.LoadMacros Method

SyntaxEditLoadMacros Method
Overload List
 | Name | Description
Public method | LoadMacros(Stream) | Loads the macro records from the given stream.
Public method | LoadMacros(TextReader) | Loads the macro records from the given stream.
Public method | LoadMacros(String) | Loads the macro records from the given file.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LoadMacros Method (Stream)

SyntaxEditLoadMacros Method (Stream)
Loads the macro records from the given stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void LoadMacros(
    Stream stream
)
Public Overridable Sub LoadMacros (
    stream As Stream
)
public:
virtual void LoadMacros(
    Stream^ stream
)
abstract LoadMacros :
        stream : Stream -> unit
override LoadMacros :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Implements

IRecordPlayBackLoadMacros(Stream)
See Also

Reference

SyntaxEdit Class
LoadMacros Overload
Alternet.Editor Namespace


SyntaxEdit.LoadMacros Method (TextReader)

SyntaxEditLoadMacros Method (TextReader)
Loads the macro records from the given stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void LoadMacros(
    TextReader reader
)
Public Overridable Sub LoadMacros (
    reader As TextReader
)
public:
virtual void LoadMacros(
    TextReader^ reader
)
abstract LoadMacros :
        reader : TextReader -> unit
override LoadMacros :
        reader : TextReader -> unit

Parameters

reader
Type: System.IOTextReader
The TextReader object to read macros from stream.

Implements

IRecordPlayBackLoadMacros(TextReader)
See Also

Reference

SyntaxEdit Class
LoadMacros Overload
Alternet.Editor Namespace


SyntaxEdit.LoadMacros Method (String)

SyntaxEditLoadMacros Method (String)
Loads the macro records from the given file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void LoadMacros(
    string fileName
)
Public Overridable Sub LoadMacros (
    fileName As String
)
public:
virtual void LoadMacros(
    String^ fileName
)
abstract LoadMacros :
        fileName : string -> unit
override LoadMacros :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
Name of file to load macros.

Implements

IRecordPlayBackLoadMacros(String)
See Also

Reference

SyntaxEdit Class
LoadMacros Overload
Alternet.Editor Namespace


SyntaxEdit.LoadStream Method

SyntaxEditLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LoadStream Method (Stream)

SyntaxEditLoadStream Method (Stream)
Loads the contents of the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream
)
Public Overridable Function LoadStream (
    stream As Stream
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream
)
abstract LoadStream :
        stream : Stream -> bool
override LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream)
See Also

Reference

SyntaxEdit Class
LoadStream Overload
Alternet.Editor Namespace


SyntaxEdit.LoadStream Method (TextReader)

SyntaxEditLoadStream Method (TextReader)
Loads the contents of the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader
)
Public Overridable Function LoadStream (
    reader As TextReader
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool
override LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(TextReader)
See Also

Reference

SyntaxEdit Class
LoadStream Overload
Alternet.Editor Namespace


SyntaxEdit.LoadStream Method (Stream, IStringImport)

SyntaxEditLoadStream Method (Stream, IStringImport)
Loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    IStringImport importer
)
Public Overridable Function LoadStream (
    stream As Stream,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    IStringImport^ importer
)
abstract LoadStream :
        stream : Stream *
        importer : IStringImport -> bool
override LoadStream :
        stream : Stream *
        importer : IStringImport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(Stream, IStringImport)
See Also

Reference

SyntaxEdit Class
LoadStream Overload
Alternet.Editor Namespace


SyntaxEdit.LoadStream Method (Stream, Encoding)

SyntaxEditLoadStream Method (Stream, Encoding)
Loads the contents of the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream, Encoding)
See Also

Reference

SyntaxEdit Class
LoadStream Overload
Alternet.Editor Namespace


SyntaxEdit.LoadStream Method (TextReader, IStringImport)

SyntaxEditLoadStream Method (TextReader, IStringImport)
Loads the contents of the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader,
    IStringImport importer
)
Public Overridable Function LoadStream (
    reader As TextReader,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader,
    IStringImport^ importer
)
abstract LoadStream :
        reader : TextReader *
        importer : IStringImport -> bool
override LoadStream :
        reader : TextReader *
        importer : IStringImport -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(TextReader, IStringImport)
See Also

Reference

SyntaxEdit Class
LoadStream Overload
Alternet.Editor Namespace


SyntaxEdit.LoadStream Method (Stream, IStringImport, Encoding)

SyntaxEditLoadStream Method (Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    IStringImport importer,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    IStringImport^ importer,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        importer : IStringImport *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(Stream, IStringImport, Encoding)
See Also

Reference

SyntaxEdit Class
LoadStream Overload
Alternet.Editor Namespace


SyntaxEdit.MakeVisible Method

SyntaxEditMakeVisible Method
Overload List
 | Name | Description
Public method | MakeVisible(Point) | Scrolls the control's content, if necessary, to ensure a specified text position is in view.
Public method | MakeVisible(Point, Boolean) | Scrolls the control's content, if necessary, to ensure a specified text position is in view.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MakeVisible Method (Point)

SyntaxEditMakeVisible Method (Point)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MakeVisible(
    Point position
)
Public Overridable Sub MakeVisible (
    position As Point
)
public:
virtual void MakeVisible(
    Point position
)
abstract MakeVisible :
        position : Point -> unit
override MakeVisible :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Position in the text to make visible.

Implements

ISyntaxEditMakeVisible(Point)
See Also

Reference

SyntaxEdit Class
MakeVisible Overload
Alternet.Editor Namespace


SyntaxEdit.MakeVisible Method (Point, Boolean)

SyntaxEditMakeVisible Method (Point, Boolean)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MakeVisible(
    Point position,
    bool centerLine
)
Public Overridable Sub MakeVisible (
    position As Point,
    centerLine As Boolean
)
public:
virtual void MakeVisible(
    Point position,
    bool centerLine
)
abstract MakeVisible :
        position : Point *
        centerLine : bool -> unit
override MakeVisible :
        position : Point *
        centerLine : bool -> unit

Parameters

position
Type: System.DrawingPoint
Position in the text to make visible.
centerLine
Type: SystemBoolean
Specifies whether given line must be centered within control's client area.

Implements

ISyntaxEditMakeVisible(Point, Boolean)
See Also

Reference

SyntaxEdit Class
MakeVisible Overload
Alternet.Editor Namespace


SyntaxEdit.MarkAll Method

SyntaxEditMarkAll Method
Overload List
 | Name | Description
Public method | MarkAll(String, Boolean) | Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | MarkAll(String, SearchOptions, Boolean) | Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Public method | MarkAll(String, SearchOptions, Regex, Boolean) | Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MarkAll Method (String, Boolean)

SyntaxEditMarkAll Method (String, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MarkAll(
    string text,
    bool clearPrevious
)
Public Overridable Function MarkAll (
    text As String,
    clearPrevious As Boolean
) As Integer
public:
virtual int MarkAll(
    String^ text,
    bool clearPrevious
)
abstract MarkAll :
        text : string *
        clearPrevious : bool -> int
override MarkAll :
        text : string *
        clearPrevious : bool -> int

Parameters

text
Type: SystemString
Specifies text to mark.
clearPrevious
Type: SystemBoolean
Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Return Value

Type: Int32
Number of found occurrences.

Implements

ISearchMarkAll(String, Boolean)
See Also

Reference

SyntaxEdit Class
MarkAll Overload
Alternet.Editor Namespace


SyntaxEdit.MarkAll Method (String, SearchOptions, Boolean)

SyntaxEditMarkAll Method (String, SearchOptions, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MarkAll(
    string text,
    SearchOptions options,
    bool clearPrevious
)
Public Overridable Function MarkAll (
    text As String,
    options As SearchOptions,
    clearPrevious As Boolean
) As Integer
public:
virtual int MarkAll(
    String^ text,
    SearchOptions options,
    bool clearPrevious
)
abstract MarkAll :
        text : string *
        options : SearchOptions *
        clearPrevious : bool -> int
override MarkAll :
        text : string *
        options : SearchOptions *
        clearPrevious : bool -> int

Parameters

text
Type: SystemString
Specifies text to mark.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
clearPrevious
Type: SystemBoolean
Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Return Value

Type: Int32
Number of found occurrences.

Implements

ISearchMarkAll(String, SearchOptions, Boolean)
See Also

Reference

SyntaxEdit Class
MarkAll Overload
Alternet.Editor Namespace


SyntaxEdit.MarkAll Method (String, SearchOptions, Regex, Boolean)

SyntaxEditMarkAll Method (String, SearchOptions, Regex, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MarkAll(
    string text,
    SearchOptions options,
    Regex expression,
    bool clearPrevious
)
Public Overridable Function MarkAll (
    text As String,
    options As SearchOptions,
    expression As Regex,
    clearPrevious As Boolean
) As Integer
public:
virtual int MarkAll(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    bool clearPrevious
)
abstract MarkAll :
        text : string *
        options : SearchOptions *
        expression : Regex *
        clearPrevious : bool -> int
override MarkAll :
        text : string *
        options : SearchOptions *
        expression : Regex *
        clearPrevious : bool -> int

Parameters

text
Type: SystemString
Specifies text to mark.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
clearPrevious
Type: SystemBoolean
Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Return Value

Type: Int32
Number of found occurrences.

Implements

ISearchMarkAll(String, SearchOptions, Regex, Boolean)
See Also

Reference

SyntaxEdit Class
MarkAll Overload
Alternet.Editor Namespace


SyntaxEdit.MoveCaretOnDrag Method

SyntaxEditMoveCaretOnDrag Method
Moves caret to the position of drag cursor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveCaretOnDrag()
Public Overridable Sub MoveCaretOnDrag
public:
virtual void MoveCaretOnDrag()
abstract MoveCaretOnDrag : unit -> unit
override MoveCaretOnDrag : unit -> unit

Implements

ISyntaxEditMoveCaretOnDrag
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveCharLeft Method

SyntaxEditMoveCharLeft Method
Moves the current position one character to the left.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveCharLeft()
Public Overridable Sub MoveCharLeft
public:
virtual void MoveCharLeft()
abstract MoveCharLeft : unit -> unit
override MoveCharLeft : unit -> unit

Implements

IEditNavigateMoveCharLeft
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveCharRight Method

SyntaxEditMoveCharRight Method
Moves the current position one character to the right.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveCharRight()
Public Overridable Sub MoveCharRight
public:
virtual void MoveCharRight()
abstract MoveCharRight : unit -> unit
override MoveCharRight : unit -> unit

Implements

IEditNavigateMoveCharRight
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveFileBegin Method

SyntaxEditMoveFileBegin Method
Moves the current position to the first character of the first line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveFileBegin()
Public Overridable Sub MoveFileBegin
public:
virtual void MoveFileBegin()
abstract MoveFileBegin : unit -> unit
override MoveFileBegin : unit -> unit

Implements

IEditNavigateMoveFileBegin
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveFileEnd Method

SyntaxEditMoveFileEnd Method
Moves the current position to the last character of the last line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveFileEnd()
Public Overridable Sub MoveFileEnd
public:
virtual void MoveFileEnd()
abstract MoveFileEnd : unit -> unit
override MoveFileEnd : unit -> unit

Implements

IEditNavigateMoveFileEnd
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveLineBegin Method

SyntaxEditMoveLineBegin Method
Moves the current position to the first character of current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveLineBegin()
Public Overridable Sub MoveLineBegin
public:
virtual void MoveLineBegin()
abstract MoveLineBegin : unit -> unit
override MoveLineBegin : unit -> unit

Implements

IEditNavigateMoveLineBegin
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveLineBeginCycled Method

SyntaxEditMoveLineBeginCycled Method
Moves the current position to the first not whitespace character/first character of current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveLineBeginCycled()
Public Overridable Sub MoveLineBeginCycled
public:
virtual void MoveLineBeginCycled()
abstract MoveLineBeginCycled : unit -> unit
override MoveLineBeginCycled : unit -> unit

Implements

IEditNavigateMoveLineBeginCycled
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveLineDown Method

SyntaxEditMoveLineDown Method
Moves the current position to the next line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveLineDown()
Public Overridable Sub MoveLineDown
public:
virtual void MoveLineDown()
abstract MoveLineDown : unit -> unit
override MoveLineDown : unit -> unit

Implements

IEditNavigateMoveLineDown
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveLineEnd Method

SyntaxEditMoveLineEnd Method
Moves the current position to the last character of current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveLineEnd()
Public Overridable Sub MoveLineEnd
public:
virtual void MoveLineEnd()
abstract MoveLineEnd : unit -> unit
override MoveLineEnd : unit -> unit

Implements

IEditNavigateMoveLineEnd
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveLineEndCycled Method

SyntaxEditMoveLineEndCycled Method
Moves the current position to the last not whitespace character/last character of current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveLineEndCycled()
Public Overridable Sub MoveLineEndCycled
public:
virtual void MoveLineEndCycled()
abstract MoveLineEndCycled : unit -> unit
override MoveLineEndCycled : unit -> unit

Implements

IEditNavigateMoveLineEndCycled
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveLineUp Method

SyntaxEditMoveLineUp Method
Moves the current position to the previous line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveLineUp()
Public Overridable Sub MoveLineUp
public:
virtual void MoveLineUp()
abstract MoveLineUp : unit -> unit
override MoveLineUp : unit -> unit

Implements

IEditNavigateMoveLineUp
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MovePageDown Method

SyntaxEditMovePageDown Method
Moves current position to the next page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MovePageDown()
Public Overridable Sub MovePageDown
public:
virtual void MovePageDown()
abstract MovePageDown : unit -> unit
override MovePageDown : unit -> unit

Implements

IEditNavigateMovePageDown
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MovePageUp Method

SyntaxEditMovePageUp Method
Moves current position to the previous page.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MovePageUp()
Public Overridable Sub MovePageUp
public:
virtual void MovePageUp()
abstract MovePageUp : unit -> unit
override MovePageUp : unit -> unit

Implements

IEditNavigateMovePageUp
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveScreenBottom Method

SyntaxEditMoveScreenBottom Method
Moves the current position to the bottom of the screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveScreenBottom()
Public Overridable Sub MoveScreenBottom
public:
virtual void MoveScreenBottom()
abstract MoveScreenBottom : unit -> unit
override MoveScreenBottom : unit -> unit

Implements

IEditNavigateMoveScreenBottom
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveScreenTop Method

SyntaxEditMoveScreenTop Method
Moves the current position to the top of the screen.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveScreenTop()
Public Overridable Sub MoveScreenTop
public:
virtual void MoveScreenTop()
abstract MoveScreenTop : unit -> unit
override MoveScreenTop : unit -> unit

Implements

IEditNavigateMoveScreenTop
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveTo Method

SyntaxEditMoveTo Method
Overload List
 | Name | Description
Public method | MoveTo(Point) | Moves the current position to the given position.
Public method | MoveTo(Int32, Int32) | Moves the current position to the given position.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveTo Method (Point)

SyntaxEditMoveTo Method (Point)
Moves the current position to the given position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveTo(
    Point position
)
Public Overridable Sub MoveTo (
    position As Point
)
public:
virtual void MoveTo(
    Point position
)
abstract MoveTo :
        position : Point -> unit
override MoveTo :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
New location of the current position.

Implements

INavigateMoveTo(Point)
See Also

Reference

SyntaxEdit Class
MoveTo Overload
Alternet.Editor Namespace


SyntaxEdit.MoveTo Method (Int32, Int32)

SyntaxEditMoveTo Method (Int32, Int32)
Moves the current position to the given position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveTo(
    int x,
    int y
)
Public Overridable Sub MoveTo (
    x As Integer,
    y As Integer
)
public:
virtual void MoveTo(
    int x,
    int y
)
abstract MoveTo :
        x : int *
        y : int -> unit
override MoveTo :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
Index of character in the line to move to.
y
Type: SystemInt32
Index of line to move to.

Implements

INavigateMoveTo(Int32, Int32)
See Also

Reference

SyntaxEdit Class
MoveTo Overload
Alternet.Editor Namespace


SyntaxEdit.MoveToBrace Method

SyntaxEditMoveToBrace Method
Moves the current position to the next open or close brace in the text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveToBrace()
Public Overridable Sub MoveToBrace
public:
virtual void MoveToBrace()
abstract MoveToBrace : unit -> unit
override MoveToBrace : unit -> unit

Implements

IEditNavigateMoveToBrace
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveToChar Method

SyntaxEditMoveToChar Method
Moves the current position to the specified character in current line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveToChar(
    int x
)
Public Overridable Sub MoveToChar (
    x As Integer
)
public:
virtual void MoveToChar(
    int x
)
abstract MoveToChar :
        x : int -> unit
override MoveToChar :
        x : int -> unit

Parameters

x
Type: SystemInt32
Index of character in current line to move to.

Implements

INavigateMoveToChar(Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveToCloseBrace Method

SyntaxEditMoveToCloseBrace Method
Moves the current position to the next close brace in the text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveToCloseBrace()
Public Overridable Sub MoveToCloseBrace
public:
virtual void MoveToCloseBrace()
abstract MoveToCloseBrace : unit -> unit
override MoveToCloseBrace : unit -> unit

Implements

IEditNavigateMoveToCloseBrace
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveToLine Method

SyntaxEditMoveToLine Method
Overload List
 | Name | Description
Public method | MoveToLine(Int32) | Moves the current position to the specified line.
Public method | MoveToLine(Int32, Int32) | Moves the current position to the specified line.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveToLine Method (Int32)

SyntaxEditMoveToLine Method (Int32)
Moves the current position to the specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveToLine(
    int y
)
Public Overridable Sub MoveToLine (
    y As Integer
)
public:
virtual void MoveToLine(
    int y
)
abstract MoveToLine :
        y : int -> unit
override MoveToLine :
        y : int -> unit

Parameters

y
Type: SystemInt32
Index of line to move to.

Implements

INavigateMoveToLine(Int32)
See Also

Reference

SyntaxEdit Class
MoveToLine Overload
Alternet.Editor Namespace


SyntaxEdit.MoveToLine Method (Int32, Int32)

SyntaxEditMoveToLine Method (Int32, Int32)
Moves the current position to the specified line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveToLine(
    int y,
    int linesAbove
)
Public Overridable Sub MoveToLine (
    y As Integer,
    linesAbove As Integer
)
public:
virtual void MoveToLine(
    int y,
    int linesAbove
)
abstract MoveToLine :
        y : int *
        linesAbove : int -> unit
override MoveToLine :
        y : int *
        linesAbove : int -> unit

Parameters

y
Type: SystemInt32
Index of line to move to.
linesAbove
Type: SystemInt32
Number of lines to leave above cursor.

Implements

INavigateMoveToLine(Int32, Int32)
See Also

Reference

SyntaxEdit Class
MoveToLine Overload
Alternet.Editor Namespace


SyntaxEdit.MoveToOpenBrace Method

SyntaxEditMoveToOpenBrace Method
Moves the current position to the previous open brace in the text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveToOpenBrace()
Public Overridable Sub MoveToOpenBrace
public:
virtual void MoveToOpenBrace()
abstract MoveToOpenBrace : unit -> unit
override MoveToOpenBrace : unit -> unit

Implements

IEditNavigateMoveToOpenBrace
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveWordLeft Method

SyntaxEditMoveWordLeft Method
Moves the current position one word to the left.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveWordLeft()
Public Overridable Sub MoveWordLeft
public:
virtual void MoveWordLeft()
abstract MoveWordLeft : unit -> unit
override MoveWordLeft : unit -> unit

Implements

IEditNavigateMoveWordLeft
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MoveWordRight Method

SyntaxEditMoveWordRight Method
Moves the current position one word to the right.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveWordRight()
Public Overridable Sub MoveWordRight
public:
virtual void MoveWordRight()
abstract MoveWordRight : unit -> unit
override MoveWordRight : unit -> unit

Implements

IEditNavigateMoveWordRight
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Navigate Method

SyntaxEditNavigate Method
Moves current position by the given offset value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Navigate(
    int deltaX,
    int deltaY
)
Public Overridable Sub Navigate (
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void Navigate(
    int deltaX,
    int deltaY
)
abstract Navigate :
        deltaX : int *
        deltaY : int -> unit
override Navigate :
        deltaX : int *
        deltaY : int -> unit

Parameters

deltaX
Type: SystemInt32
Horizontal offset.
deltaY
Type: SystemInt32
Vertical offset.

Implements

INavigateNavigate(Int32, Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.NeedReplaceCurrent Method

SyntaxEditNeedReplaceCurrent Method
Overload List
 | Name | Description
Public method | NeedReplaceCurrent | Indicates whether search engine need to replace successfully found and selected text.
Public method | NeedReplaceCurrent(Match) | Indicates whether search engine need to replace successfully found and selected text.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.NeedReplaceCurrent Method

SyntaxEditNeedReplaceCurrent Method
Indicates whether search engine need to replace successfully found and selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedReplaceCurrent()
Public Function NeedReplaceCurrent As Boolean
public:
bool NeedReplaceCurrent()
member NeedReplaceCurrent : unit -> bool

Return Value

Type: Boolean
True is some text is found; otherwise false.
See Also

Reference

SyntaxEdit Class
NeedReplaceCurrent Overload
Alternet.Editor Namespace


SyntaxEdit.NeedReplaceCurrent Method (Match)

SyntaxEditNeedReplaceCurrent Method (Match)
Indicates whether search engine need to replace successfully found and selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedReplaceCurrent(
    out Match match
)
Public Overridable Function NeedReplaceCurrent (
    <OutAttribute> ByRef match As Match
) As Boolean
public:
virtual bool NeedReplaceCurrent(
    [OutAttribute] Match^% match
)
abstract NeedReplaceCurrent :
        match : Match byref -> bool
override NeedReplaceCurrent :
        match : Match byref -> bool

Parameters

match
Type: System.Text.RegularExpressionsMatch
Receives match if regular expression search successful.

Return Value

Type: Boolean
True is some text is found; otherwise false.

Implements

ISearchNeedReplaceCurrent(Match)
See Also

Reference

SyntaxEdit Class
NeedReplaceCurrent Overload
Alternet.Editor Namespace


SyntaxEdit.NewLine Method

SyntaxEditNewLine Method
Overload List
 | Name | Description
Public method | NewLine | Inserts a line break at the current position.
Public method | NewLine(String, Boolean) | Inserts a line break at the current position with indentation
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.NewLine Method

SyntaxEditNewLine Method
Inserts a line break at the current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NewLine()
Public Overridable Function NewLine As Boolean
public:
virtual bool NewLine()
abstract NewLine : unit -> bool
override NewLine : unit -> bool

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditNewLine
See Also

Reference

SyntaxEdit Class
NewLine Overload
Alternet.Editor Namespace


SyntaxEdit.NewLine Method (String, Boolean)

SyntaxEditNewLine Method (String, Boolean)
Inserts a line break at the current position with indentation

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NewLine(
    ref string indent,
    bool withChange = false
)
Public Overridable Function NewLine (
    ByRef indent As String,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool NewLine(
    String^% indent,
    bool withChange = false
)
abstract NewLine :
        indent : string byref *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override NewLine :
        indent : string byref *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

indent
Type: SystemString
pass desired indentation level, or null for automatic indentation
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditNewLine(String, Boolean)
See Also

Reference

SyntaxEdit Class
NewLine Overload
Alternet.Editor Namespace


SyntaxEdit.NewLineAbove Method

SyntaxEditNewLineAbove Method
Inserts a line break above the current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NewLineAbove()
Public Overridable Function NewLineAbove As Boolean
public:
virtual bool NewLineAbove()
abstract NewLineAbove : unit -> bool
override NewLineAbove : unit -> bool

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditNewLineAbove
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.NewLineBelow Method

SyntaxEditNewLineBelow Method
Inserts a line break below the current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NewLineBelow()
Public Overridable Function NewLineBelow As Boolean
public:
virtual bool NewLineBelow()
abstract NewLineBelow : unit -> bool
override NewLineBelow : unit -> bool

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditNewLineBelow
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Notification Method

SyntaxEditNotification Method
Updates control's content according to parameters of notification.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Notification(
    Object sender,
    EventArgs e
)
Public Overridable Sub Notification (
    sender As Object,
    e As EventArgs
)
public:
virtual void Notification(
    Object^ sender,
    EventArgs^ e
)
abstract Notification :
        sender : Object *
        e : EventArgs -> unit
override Notification :
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the notification.
e
Type: SystemEventArgs
An EventArgs that contains the event data.

Implements

INotifierNotification(Object, EventArgs)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.OnStateChanged Method

SyntaxEditOnStateChanged Method
Updates control's content according to the state of the source.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnStateChanged(
    Object sender,
    NotifyState state
)
Public Overridable Sub OnStateChanged (
    sender As Object,
    state As NotifyState
)
public:
virtual void OnStateChanged(
    Object^ sender,
    NotifyState state
)
abstract OnStateChanged :
        sender : Object *
        state : NotifyState -> unit
override OnStateChanged :
        sender : Object *
        state : NotifyState -> unit

Parameters

sender
Type: SystemObject
The source of the notification.
state
Type: Alternet.Editor.TextSourceNotifyState
Specifies changes of the control's content.

Implements

IEditNotifierOnStateChanged(Object, NotifyState)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.OnTextFound Method

SyntaxEditOnTextFound Method
When implemented by a class, occurs when search text is found.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void OnTextFound(
    string text,
    SearchOptions options,
    Regex expression,
    Match match,
    Point position,
    int len,
    bool silent,
    bool multiline
)
Public Sub OnTextFound (
    text As String,
    options As SearchOptions,
    expression As Regex,
    match As Match,
    position As Point,
    len As Integer,
    silent As Boolean,
    multiline As Boolean
)
public:
virtual void OnTextFound(
    String^ text,
    SearchOptions options,
    Regex^ expression,
    Match^ match,
    Point position,
    int len,
    bool silent,
    bool multiline
) sealed
abstract OnTextFound :
        text : string *
        options : SearchOptions *
        expression : Regex *
        match : Match *
        position : Point *
        len : int *
        silent : bool *
        multiline : bool -> unit
override OnTextFound :
        text : string *
        options : SearchOptions *
        expression : Regex *
        match : Match *
        position : Point *
        len : int *
        silent : bool *
        multiline : bool -> unit

Parameters

text
Type: SystemString
Text being found.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
match
Type: System.Text.RegularExpressionsMatch
Specifies match if regular expression search successful.
position
Type: System.DrawingPoint
Specifies position of found text.
len
Type: SystemInt32
Specifies length of found text.
silent
Type: SystemBoolean
Determines if no visual feedback is required.
multiline
Type: SystemBoolean
Determines if search text is found on multiple lines.

Implements

ISearchOnTextFound(String, SearchOptions, Regex, Match, Point, Int32, Boolean, Boolean)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.OutlineText Method

SyntaxEditOutlineText Method
Forces automatic outlining by getting up-to-date information about outline section from the Parser.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void OutlineText()
Public Sub OutlineText
public:
void OutlineText()
member OutlineText : unit -> unit
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ParameterInfo Method

SyntaxEditParameterInfo Method
Displays a code completion window containing information for the current method or parameter in the Editor's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ParameterInfo()
Public Overridable Sub ParameterInfo
public:
virtual void ParameterInfo()
abstract ParameterInfo : unit -> unit
override ParameterInfo : unit -> unit

Implements

ICodeCompletionParameterInfo
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.PauseMacroRecording Method

SyntaxEditPauseMacroRecording Method
Suspends recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PauseMacroRecording()
Public Overridable Sub PauseMacroRecording
public:
virtual void PauseMacroRecording()
abstract PauseMacroRecording : unit -> unit
override PauseMacroRecording : unit -> unit

Implements

IRecordPlayBackPauseMacroRecording
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.PlayBackMacro Method

SyntaxEditPlayBackMacro Method
Repeats the stored command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PlayBackMacro()
Public Overridable Sub PlayBackMacro
public:
virtual void PlayBackMacro()
abstract PlayBackMacro : unit -> unit
override PlayBackMacro : unit -> unit

Implements

IRecordPlayBackPlayBackMacro
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.PositionIsReadonly Method

SyntaxEditPositionIsReadonly Method
Determines whether the text at given position is readonly.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionIsReadonly(
    Point position
)
Public Overridable Function PositionIsReadonly (
    position As Point
) As Boolean
public:
virtual bool PositionIsReadonly(
    Point position
)
abstract PositionIsReadonly :
        position : Point -> bool
override PositionIsReadonly :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position in text coordinates.

Return Value

Type: Boolean
True if the text can be edited at given position; otherwise false.

Implements

IEditPositionIsReadonly(Point)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.PreProcessMessage Method

SyntaxEditPreProcessMessage Method
Preprocesses input messages within the message loop before they are dispatched.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PreProcessMessage(
    ref Message msg
)
Public Overrides Function PreProcessMessage (
    ByRef msg As Message
) As Boolean
public:
virtual bool PreProcessMessage(
    Message% msg
) override
abstract PreProcessMessage :
        msg : Message byref -> bool
override PreProcessMessage :
        msg : Message byref -> bool

Parameters

msg
Type: System.Windows.FormsMessage
A Message, passed by reference, that represents the message to process.

Return Value

Type: Boolean
True if the message was processed by the Edit control; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ProcessEnter Method

SyntaxEditProcessEnter Method
Performs specific actions when Enter key is pressed.

Return Value

Type: Boolean
True if key was processed; otherwise false.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ProcessEnter()
Public Overridable Function ProcessEnter As Boolean
public:
virtual bool ProcessEnter()
abstract ProcessEnter : unit -> bool
override ProcessEnter : unit -> bool

Return Value

Type: Boolean

Implements

IEditNavigateProcessEnter
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ProcessKeyMsg Method

SyntaxEditProcessKeyMsg Method
Processes a keyboard message.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ProcessKeyMsg(
    ref Message msg
)
Public Overridable Function ProcessKeyMsg (
    ByRef msg As Message
) As Boolean
public:
virtual bool ProcessKeyMsg(
    Message% msg
)
abstract ProcessKeyMsg :
        msg : Message byref -> bool
override ProcessKeyMsg :
        msg : Message byref -> bool

Parameters

msg
Type: System.Windows.FormsMessage
A Message, passed by reference, that represents the window message to process.

Return Value

Type: Boolean
True if the message was processed by the control; otherwise, false.

Implements

ISyntaxEditProcessKeyMsg(Message)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ProcessKeyPress Method

SyntaxEditProcessKeyPress Method
Processes key press.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ProcessKeyPress(
    char keyChar
)
Public Overridable Sub ProcessKeyPress (
    keyChar As Char
)
public:
virtual void ProcessKeyPress(
    wchar_t keyChar
)
abstract ProcessKeyPress :
        keyChar : char -> unit
override ProcessKeyPress :
        keyChar : char -> unit

Parameters

keyChar
Type: SystemChar
Represents key character to process.

Implements

ISyntaxEditProcessKeyPress(Char)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ProcessShiftTab Method

SyntaxEditProcessShiftTab Method
Performs specific actions when Shift + Tab key is pressed.

Return Value

Type: Boolean
True if key was processed; otherwise false.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ProcessShiftTab(
    Point position
)
Public Overridable Function ProcessShiftTab (
    position As Point
) As Boolean
public:
virtual bool ProcessShiftTab(
    Point position
)
abstract ProcessShiftTab :
        position : Point -> bool
override ProcessShiftTab :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint

Return Value

Type: Boolean

Implements

IEditNavigateProcessShiftTab(Point)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ProcessTab Method

SyntaxEditProcessTab Method
Performs specific actions when Tab key is pressed.

Return Value

Type: Boolean
True if key was processed; otherwise false.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ProcessTab(
    Point position
)
Public Overridable Function ProcessTab (
    position As Point
) As Boolean
public:
virtual bool ProcessTab(
    Point position
)
abstract ProcessTab :
        position : Point -> bool
override ProcessTab :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint

Return Value

Type: Boolean

Implements

IEditNavigateProcessTab(Point)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.QuickInfo Method

SyntaxEditQuickInfo Method
Displays a code completion window with simple tooltip information.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void QuickInfo()
Public Overridable Sub QuickInfo
public:
virtual void QuickInfo()
abstract QuickInfo : unit -> unit
override QuickInfo : unit -> unit

Implements

ICodeCompletionQuickInfo
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.RecordKeyData Method

SyntaxEditRecordKeyData Method
Adds keyData to the MacroRecords array.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RecordKeyData(
    IMacroKeyData keyData
)
Public Overridable Sub RecordKeyData (
    keyData As IMacroKeyData
)
public:
virtual void RecordKeyData(
    IMacroKeyData^ keyData
)
abstract RecordKeyData :
        keyData : IMacroKeyData -> unit
override RecordKeyData :
        keyData : IMacroKeyData -> unit

Parameters

keyData
Type: Alternet.EditorIMacroKeyData
Specifies a keyboard command.

Implements

IRecordPlayBackRecordKeyData(IMacroKeyData)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Replace Method

SyntaxEditReplace Method
Overload List
 | Name | Description
Public method | Replace(String, String) | Searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
Public method | Replace(String, String, SearchOptions) | Searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
Public method | Replace(String, String, SearchOptions, Regex) | Searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Replace Method (String, String)

SyntaxEditReplace Method (String, String)
Searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Replace(
    string text,
    string replaceWith
)
Public Overridable Function Replace (
    text As String,
    replaceWith As String
) As Boolean
public:
virtual bool Replace(
    String^ text,
    String^ replaceWith
)
abstract Replace :
        text : string *
        replaceWith : string -> bool
override Replace :
        text : string *
        replaceWith : string -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISearchReplace(String, String)
See Also

Reference

SyntaxEdit Class
Replace Overload
Alternet.Editor Namespace


SyntaxEdit.Replace Method (String, String, SearchOptions)

SyntaxEditReplace Method (String, String, SearchOptions)
Searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Replace(
    string text,
    string replaceWith,
    SearchOptions options
)
Public Overridable Function Replace (
    text As String,
    replaceWith As String,
    options As SearchOptions
) As Boolean
public:
virtual bool Replace(
    String^ text,
    String^ replaceWith,
    SearchOptions options
)
abstract Replace :
        text : string *
        replaceWith : string *
        options : SearchOptions -> bool
override Replace :
        text : string *
        replaceWith : string *
        options : SearchOptions -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISearchReplace(String, String, SearchOptions)
See Also

Reference

SyntaxEdit Class
Replace Overload
Alternet.Editor Namespace


SyntaxEdit.Replace Method (String, String, SearchOptions, Regex)

SyntaxEditReplace Method (String, String, SearchOptions, Regex)
Searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Replace(
    string text,
    string replaceWith,
    SearchOptions options,
    Regex expression
)
Public Overridable Function Replace (
    text As String,
    replaceWith As String,
    options As SearchOptions,
    expression As Regex
) As Boolean
public:
virtual bool Replace(
    String^ text,
    String^ replaceWith,
    SearchOptions options,
    Regex^ expression
)
abstract Replace :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        expression : Regex -> bool
override Replace :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        expression : Regex -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISearchReplace(String, String, SearchOptions, Regex)
See Also

Reference

SyntaxEdit Class
Replace Overload
Alternet.Editor Namespace


SyntaxEdit.ReplaceAll Method

SyntaxEditReplaceAll Method
Overload List
 | Name | Description
Public method | ReplaceAll(String, String, Int32) | Replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Int32) | Replaces all occurrences of given text within text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Regex, Int32) | Replaces all occurrences of given text within class text content by specified replaceWith string.
Public method | ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean) | Replaces all occurrences of given text within class text content by specified replaceWith string.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ReplaceAll Method (String, String, Int32)

SyntaxEditReplaceAll Method (String, String, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReplaceAll(
    string text,
    string replaceWith,
    out int count
)
Public Overridable Function ReplaceAll (
    text As String,
    replaceWith As String,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
virtual bool ReplaceAll(
    String^ text,
    String^ replaceWith,
    [OutAttribute] int% count
)
abstract ReplaceAll :
        text : string *
        replaceWith : string *
        count : int byref -> bool
override ReplaceAll :
        text : string *
        replaceWith : string *
        count : int byref -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
count
Type: SystemInt32
Number of replaced occurrences.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISearchReplaceAll(String, String, Int32)
See Also

Reference

SyntaxEdit Class
ReplaceAll Overload
Alternet.Editor Namespace


SyntaxEdit.ReplaceAll Method (String, String, SearchOptions, Int32)

SyntaxEditReplaceAll Method (String, String, SearchOptions, Int32)
Replaces all occurrences of given text within text content by specified replaceWith string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReplaceAll(
    string text,
    string replaceWith,
    SearchOptions options,
    out int count
)
Public Overridable Function ReplaceAll (
    text As String,
    replaceWith As String,
    options As SearchOptions,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
virtual bool ReplaceAll(
    String^ text,
    String^ replaceWith,
    SearchOptions options,
    [OutAttribute] int% count
)
abstract ReplaceAll :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        count : int byref -> bool
override ReplaceAll :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        count : int byref -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
count
Type: SystemInt32
Number of replaced occurrences.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISearchReplaceAll(String, String, SearchOptions, Int32)
See Also

Reference

SyntaxEdit Class
ReplaceAll Overload
Alternet.Editor Namespace


SyntaxEdit.ReplaceAll Method (String, String, SearchOptions, Regex, Int32)

SyntaxEditReplaceAll Method (String, String, SearchOptions, Regex, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReplaceAll(
    string text,
    string replaceWith,
    SearchOptions options,
    Regex expression,
    out int count
)
Public Overridable Function ReplaceAll (
    text As String,
    replaceWith As String,
    options As SearchOptions,
    expression As Regex,
    <OutAttribute> ByRef count As Integer
) As Boolean
public:
virtual bool ReplaceAll(
    String^ text,
    String^ replaceWith,
    SearchOptions options,
    Regex^ expression,
    [OutAttribute] int% count
)
abstract ReplaceAll :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        expression : Regex *
        count : int byref -> bool
override ReplaceAll :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        expression : Regex *
        count : int byref -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
count
Type: SystemInt32
Number of replaced occurrences.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISearchReplaceAll(String, String, SearchOptions, Regex, Int32)
See Also

Reference

SyntaxEdit Class
ReplaceAll Overload
Alternet.Editor Namespace


SyntaxEdit.ReplaceAll Method (String, String, SearchOptions, Regex, Int32, Boolean)

SyntaxEditReplaceAll Method (String, String, SearchOptions, Regex, Int32, Boolean)
Replaces all occurrences of given text within class text content by specified replaceWith string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReplaceAll(
    string text,
    string replaceWith,
    SearchOptions options,
    Regex expression,
    out int count,
    out bool abort
)
Public Overridable Function ReplaceAll (
    text As String,
    replaceWith As String,
    options As SearchOptions,
    expression As Regex,
    <OutAttribute> ByRef count As Integer,
    <OutAttribute> ByRef abort As Boolean
) As Boolean
public:
virtual bool ReplaceAll(
    String^ text,
    String^ replaceWith,
    SearchOptions options,
    Regex^ expression,
    [OutAttribute] int% count,
    [OutAttribute] bool% abort
)
abstract ReplaceAll :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        expression : Regex *
        count : int byref *
        abort : bool byref -> bool
override ReplaceAll :
        text : string *
        replaceWith : string *
        options : SearchOptions *
        expression : Regex *
        count : int byref *
        abort : bool byref -> bool

Parameters

text
Type: SystemString
Text to find.
replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Represents options to search text.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
count
Type: SystemInt32
Number of replaced occurrences.
abort
Type: SystemBoolean
Indicates whether replace action aborted.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISearchReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean)
See Also

Reference

SyntaxEdit Class
ReplaceAll Overload
Alternet.Editor Namespace


SyntaxEdit.ReplaceCurrent Method

SyntaxEditReplaceCurrent Method
Replaces currently selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReplaceCurrent(
    string replaceWith,
    SearchOptions options,
    Match match
)
Public Overridable Function ReplaceCurrent (
    replaceWith As String,
    options As SearchOptions,
    match As Match
) As Boolean
public:
virtual bool ReplaceCurrent(
    String^ replaceWith,
    SearchOptions options,
    Match^ match
)
abstract ReplaceCurrent :
        replaceWith : string *
        options : SearchOptions *
        match : Match -> bool
override ReplaceCurrent :
        replaceWith : string *
        options : SearchOptions *
        match : Match -> bool

Parameters

replaceWith
Type: SystemString
Text to replace.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search and replace.
match
Type: System.Text.RegularExpressionsMatch
Represents Match object if regular expression search successful.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISearchReplaceCurrent(String, SearchOptions, Match)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetAcceptReturns Method

SyntaxEditResetAcceptReturns Method
Resets the AcceptReturns to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAcceptReturns()
Public Overridable Sub ResetAcceptReturns
public:
virtual void ResetAcceptReturns()
abstract ResetAcceptReturns : unit -> unit
override ResetAcceptReturns : unit -> unit

Implements

ISyntaxEditResetAcceptReturns
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetAcceptTabs Method

SyntaxEditResetAcceptTabs Method
Resets the AcceptTabs to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAcceptTabs()
Public Overridable Sub ResetAcceptTabs
public:
virtual void ResetAcceptTabs()
abstract ResetAcceptTabs : unit -> unit
override ResetAcceptTabs : unit -> unit

Implements

ISyntaxEditResetAcceptTabs
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetBorderColor Method

SyntaxEditResetBorderColor Method
Resets the BorderColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBorderColor()
Public Overridable Sub ResetBorderColor
public:
virtual void ResetBorderColor()
abstract ResetBorderColor : unit -> unit
override ResetBorderColor : unit -> unit

Implements

ISyntaxEditResetBorderColor
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetBorderStyle Method

SyntaxEditResetBorderStyle Method
Resets the BorderStyle to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBorderStyle()
Public Overridable Sub ResetBorderStyle
public:
virtual void ResetBorderStyle()
abstract ResetBorderStyle : unit -> unit
override ResetBorderStyle : unit -> unit

Implements

ISyntaxEditResetBorderStyle
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetCursor Method

SyntaxEditResetCursor Method
Resets the Cursor property to its default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCursor()
Public Overrides Sub ResetCursor
public:
virtual void ResetCursor() override
abstract ResetCursor : unit -> unit
override ResetCursor : unit -> unit
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetFont Method

SyntaxEditResetFont Method
Resets the Font property to its default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetFont()
Public Overrides Sub ResetFont
public:
virtual void ResetFont() override
abstract ResetFont : unit -> unit
override ResetFont : unit -> unit
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetHideCaret Method

SyntaxEditResetHideCaret Method
Resets the HideCaret to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetHideCaret()
Public Overridable Sub ResetHideCaret
public:
virtual void ResetHideCaret()
abstract ResetHideCaret : unit -> unit
override ResetHideCaret : unit -> unit

Implements

ICaretResetHideCaret
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetIndentOptions Method

SyntaxEditResetIndentOptions Method
Resets the IndentOptions to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetIndentOptions()
Public Overridable Sub ResetIndentOptions
public:
virtual void ResetIndentOptions()
abstract ResetIndentOptions : unit -> unit
override ResetIndentOptions : unit -> unit

Implements

IEditResetIndentOptions
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetKeepCaretOnLostFocus Method

SyntaxEditResetKeepCaretOnLostFocus Method
Resets the KeepCaretOnLostFocus to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetKeepCaretOnLostFocus()
Public Overridable Sub ResetKeepCaretOnLostFocus
public:
virtual void ResetKeepCaretOnLostFocus()
abstract ResetKeepCaretOnLostFocus : unit -> unit
override ResetKeepCaretOnLostFocus : unit -> unit

Implements

ICaretResetKeepCaretOnLostFocus
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetLineSpace Method

SyntaxEditResetLineSpace Method
Resets the LineSpace to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLineSpace()
Public Overridable Sub ResetLineSpace
public:
virtual void ResetLineSpace()
abstract ResetLineSpace : unit -> unit
override ResetLineSpace : unit -> unit

Implements

ISyntaxEditResetLineSpace
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetMaxLength Method

SyntaxEditResetMaxLength Method
Resets the MaxLength to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetMaxLength()
Public Overridable Sub ResetMaxLength
public:
virtual void ResetMaxLength()
abstract ResetMaxLength : unit -> unit
override ResetMaxLength : unit -> unit

Implements

IEditResetMaxLength
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetModified Method

SyntaxEditResetModified Method
Resets the Modified to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetModified()
Public Overridable Sub ResetModified
public:
virtual void ResetModified()
abstract ResetModified : unit -> unit
override ResetModified : unit -> unit

Implements

IEditResetModified
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetNavigateOptions Method

SyntaxEditResetNavigateOptions Method
Resets the NavigateOptions to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetNavigateOptions()
Public Overridable Sub ResetNavigateOptions
public:
virtual void ResetNavigateOptions()
abstract ResetNavigateOptions : unit -> unit
override ResetNavigateOptions : unit -> unit

Implements

INavigateResetNavigateOptions
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetOverWrite Method

SyntaxEditResetOverWrite Method
Resets the OverWrite to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOverWrite()
Public Overridable Sub ResetOverWrite
public:
virtual void ResetOverWrite()
abstract ResetOverWrite : unit -> unit
override ResetOverWrite : unit -> unit

Implements

IEditResetOverWrite
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetReadOnly Method

SyntaxEditResetReadOnly Method
Resets the ReadOnly to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetReadOnly()
Public Overridable Sub ResetReadOnly
public:
virtual void ResetReadOnly()
abstract ResetReadOnly : unit -> unit
override ResetReadOnly : unit -> unit

Implements

IEditResetReadOnly
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetSingleLineMode Method

SyntaxEditResetSingleLineMode Method
Resets the SingleLineMode to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSingleLineMode()
Public Overridable Sub ResetSingleLineMode
public:
virtual void ResetSingleLineMode()
abstract ResetSingleLineMode : unit -> unit
override ResetSingleLineMode : unit -> unit

Implements

IEditResetSingleLineMode
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetWordWrap Method

SyntaxEditResetWordWrap Method
Resets the WordWrap to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetWordWrap()
Public Overridable Sub ResetWordWrap
public:
virtual void ResetWordWrap()
abstract ResetWordWrap : unit -> unit
override ResetWordWrap : unit -> unit

Implements

IWordWrapResetWordWrap
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResetWrapAtMargin Method

SyntaxEditResetWrapAtMargin Method
Resets the WrapAtMargin to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetWrapAtMargin()
Public Overridable Sub ResetWrapAtMargin
public:
virtual void ResetWrapAtMargin()
abstract ResetWrapAtMargin : unit -> unit
override ResetWrapAtMargin : unit -> unit

Implements

IWordWrapResetWrapAtMargin
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.RestorePosition Method

SyntaxEditRestorePosition Method
Restores position from stored position list by given index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point RestorePosition(
    int index
)
Public Overridable Function RestorePosition (
    index As Integer
) As Point
public:
virtual Point RestorePosition(
    int index
)
abstract RestorePosition :
        index : int -> Point
override RestorePosition :
        index : int -> Point

Parameters

index
Type: SystemInt32
Index of position to restore.

Return Value

Type: Point
Point value that represents stored position.

Implements

INavigateRestorePosition(Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.RestorePositionWithUndo Method

SyntaxEditRestorePositionWithUndo Method
Restores position from stored position list by given index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RestorePositionWithUndo(
    int index
)
Public Overridable Sub RestorePositionWithUndo (
    index As Integer
)
public:
virtual void RestorePositionWithUndo(
    int index
)
abstract RestorePositionWithUndo :
        index : int -> unit
override RestorePositionWithUndo :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of position to restore.

Implements

INavigateRestorePositionWithUndo(Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ResumeMacroRecording Method

SyntaxEditResumeMacroRecording Method
Resumes recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResumeMacroRecording()
Public Overridable Sub ResumeMacroRecording
public:
virtual void ResumeMacroRecording()
abstract ResumeMacroRecording : unit -> unit
override ResumeMacroRecording : unit -> unit

Implements

IRecordPlayBackResumeMacroRecording
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SaveFile Method

SyntaxEditSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, IStringExport) | Saves content to the given file in the specific format.
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves content to the given file in the specific format with specific encoding.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SaveFile Method (String)

SyntaxEditSaveFile Method (String)
Saves text content to the specific file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName
)
Public Overridable Function SaveFile (
    fileName As String
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> bool
override SaveFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String)
See Also

Reference

SyntaxEdit Class
SaveFile Overload
Alternet.Editor Namespace


SyntaxEdit.SaveFile Method (String, IStringExport)

SyntaxEditSaveFile Method (String, IStringExport)
Saves content to the given file in the specific format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    IStringExport exporter
)
Public Overridable Function SaveFile (
    fileName As String,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    IStringExport^ exporter
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport -> bool
override SaveFile :
        fileName : string *
        exporter : IStringExport -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveFile(String, IStringExport)
See Also

Reference

SyntaxEdit Class
SaveFile Overload
Alternet.Editor Namespace


SyntaxEdit.SaveFile Method (String, Encoding)

SyntaxEditSaveFile Method (String, Encoding)
Saves text content to the specific file with specific encoding.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String, Encoding)
See Also

Reference

SyntaxEdit Class
SaveFile Overload
Alternet.Editor Namespace


SyntaxEdit.SaveFile Method (String, IStringExport, Encoding)

SyntaxEditSaveFile Method (String, IStringExport, Encoding)
Saves content to the given file in the specific format with specific encoding.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    IStringExport exporter,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveFile(String, IStringExport, Encoding)
See Also

Reference

SyntaxEdit Class
SaveFile Overload
Alternet.Editor Namespace


SyntaxEdit.SaveMacros Method

SyntaxEditSaveMacros Method
Overload List
 | Name | Description
Public method | SaveMacros(Stream) | Saves the macro records to the given stream in xml format.
Public method | SaveMacros(TextWriter) | Saves the macro records to the given stream in xml format.
Public method | SaveMacros(String) | Saves the macro records to the given file in xml format.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SaveMacros Method (Stream)

SyntaxEditSaveMacros Method (Stream)
Saves the macro records to the given stream in xml format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveMacros(
    Stream stream
)
Public Overridable Sub SaveMacros (
    stream As Stream
)
public:
virtual void SaveMacros(
    Stream^ stream
)
abstract SaveMacros :
        stream : Stream -> unit
override SaveMacros :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Implements

IRecordPlayBackSaveMacros(Stream)
See Also

Reference

SyntaxEdit Class
SaveMacros Overload
Alternet.Editor Namespace


SyntaxEdit.SaveMacros Method (TextWriter)

SyntaxEditSaveMacros Method (TextWriter)
Saves the macro records to the given stream in xml format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveMacros(
    TextWriter writer
)
Public Overridable Sub SaveMacros (
    writer As TextWriter
)
public:
virtual void SaveMacros(
    TextWriter^ writer
)
abstract SaveMacros :
        writer : TextWriter -> unit
override SaveMacros :
        writer : TextWriter -> unit

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write macros to stream.

Implements

IRecordPlayBackSaveMacros(TextWriter)
See Also

Reference

SyntaxEdit Class
SaveMacros Overload
Alternet.Editor Namespace


SyntaxEdit.SaveMacros Method (String)

SyntaxEditSaveMacros Method (String)
Saves the macro records to the given file in xml format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveMacros(
    string fileName
)
Public Overridable Sub SaveMacros (
    fileName As String
)
public:
virtual void SaveMacros(
    String^ fileName
)
abstract SaveMacros :
        fileName : string -> unit
override SaveMacros :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
Name of file to save macros.

Implements

IRecordPlayBackSaveMacros(String)
See Also

Reference

SyntaxEdit Class
SaveMacros Overload
Alternet.Editor Namespace


SyntaxEdit.SaveStream Method

SyntaxEditSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport) | Saves content to the specific stream in the specific format.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves content to the specific stream in the specific format and specific encoding.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SaveStream Method (Stream)

SyntaxEditSaveStream Method (Stream)
Saves content of the snippet to the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream
)
Public Overridable Function SaveStream (
    stream As Stream
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream
)
abstract SaveStream :
        stream : Stream -> bool
override SaveStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream)
See Also

Reference

SyntaxEdit Class
SaveStream Overload
Alternet.Editor Namespace


SyntaxEdit.SaveStream Method (TextWriter)

SyntaxEditSaveStream Method (TextWriter)
Saves the text content to the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer
)
Public Overridable Function SaveStream (
    writer As TextWriter
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer
)
abstract SaveStream :
        writer : TextWriter -> bool
override SaveStream :
        writer : TextWriter -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(TextWriter)
See Also

Reference

SyntaxEdit Class
SaveStream Overload
Alternet.Editor Namespace


SyntaxEdit.SaveStream Method (Stream, IStringExport)

SyntaxEditSaveStream Method (Stream, IStringExport)
Saves content to the specific stream in the specific format.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    IStringExport exporter
)
Public Overridable Function SaveStream (
    stream As Stream,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport -> bool
override SaveStream :
        stream : Stream *
        exporter : IStringExport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ITextExportSaveStream(Stream, IStringExport)
See Also

Reference

SyntaxEdit Class
SaveStream Overload
Alternet.Editor Namespace


SyntaxEdit.SaveStream Method (Stream, Encoding)

SyntaxEditSaveStream Method (Stream, Encoding)
Saves the text content to the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream, Encoding)
See Also

Reference

SyntaxEdit Class
SaveStream Overload
Alternet.Editor Namespace


SyntaxEdit.SaveStream Method (TextWriter, IStringExport)

SyntaxEditSaveStream Method (TextWriter, IStringExport)
Saves the text content to the specified stream.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer,
    IStringExport exporter
)
Public Overridable Function SaveStream (
    writer As TextWriter,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer,
    IStringExport^ exporter
)
abstract SaveStream :
        writer : TextWriter *
        exporter : IStringExport -> bool
override SaveStream :
        writer : TextWriter *
        exporter : IStringExport -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveStream(TextWriter, IStringExport)
See Also

Reference

SyntaxEdit Class
SaveStream Overload
Alternet.Editor Namespace


SyntaxEdit.SaveStream Method (Stream, IStringExport, Encoding)

SyntaxEditSaveStream Method (Stream, IStringExport, Encoding)
Saves content to the specific stream in the specific format and specific encoding.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    IStringExport exporter,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ITextExportSaveStream(Stream, IStringExport, Encoding)
See Also

Reference

SyntaxEdit Class
SaveStream Overload
Alternet.Editor Namespace


SyntaxEdit.ScreenToDisplay Method

SyntaxEditScreenToDisplay Method
Overload List
 | Name | Description
Public method | ScreenToDisplay(Int32, Int32) | Converts given screen coordinates to display coordinates (index of line and character).
Public method | ScreenToDisplay(Int32, Int32, Boolean) |
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ScreenToDisplay Method (Int32, Int32)

SyntaxEditScreenToDisplay Method (Int32, Int32)
Converts given screen coordinates to display coordinates (index of line and character).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point ScreenToDisplay(
    int x,
    int y
)
Public Overridable Function ScreenToDisplay (
    x As Integer,
    y As Integer
) As Point
public:
virtual Point ScreenToDisplay(
    int x,
    int y
)
abstract ScreenToDisplay :
        x : int *
        y : int -> Point
override ScreenToDisplay :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
Horizontal screen coordinate to convert.
y
Type: SystemInt32
Vertical screen coordinate to convert.

Return Value

Type: Point
The Point representing display coordinate.

Implements

ISyntaxEditScreenToDisplay(Int32, Int32)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

SyntaxEdit Class
ScreenToDisplay Overload
Alternet.Editor Namespace


SyntaxEdit.ScreenToDisplay Method (Int32, Int32, Boolean)

SyntaxEditScreenToDisplay Method (Int32, Int32, Boolean)

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point ScreenToDisplay(
    int x,
    int y,
    bool checkBeyondEof
)
Public Overridable Function ScreenToDisplay (
    x As Integer,
    y As Integer,
    checkBeyondEof As Boolean
) As Point
public:
virtual Point ScreenToDisplay(
    int x,
    int y,
    bool checkBeyondEof
)
abstract ScreenToDisplay :
        x : int *
        y : int *
        checkBeyondEof : bool -> Point
override ScreenToDisplay :
        x : int *
        y : int *
        checkBeyondEof : bool -> Point

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
checkBeyondEof
Type: SystemBoolean

Return Value

Type: Point
See Also

Reference

SyntaxEdit Class
ScreenToDisplay Overload
Alternet.Editor Namespace


SyntaxEdit.ScreenToDisplayX Method

SyntaxEditScreenToDisplayX Method
When implemented by a class, converts given screen coordinates to display coordinate of a character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ScreenToDisplayX(
    int x,
    int line
)
Public Overridable Function ScreenToDisplayX (
    x As Integer,
    line As Integer
) As Integer
public:
virtual int ScreenToDisplayX(
    int x,
    int line
)
abstract ScreenToDisplayX :
        x : int *
        line : int -> int
override ScreenToDisplayX :
        x : int *
        line : int -> int

Parameters

x
Type: SystemInt32
Horizontal screen coordinate to convert.
line
Type: SystemInt32
Vertical display coordinate of a text line.

Return Value

Type: Int32
The integer representing display coordinate.

Implements

ISyntaxEditScreenToDisplayX(Int32, Int32)
Remarks
Display coordinate represents point in Edit control, it may be different from text coordinate due to tabulations, wordwrap and outlining.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ScreenToText Method

SyntaxEditScreenToText Method
Overload List
 | Name | Description
Public method | ScreenToText(Point) | Converts given screen coordinates to text coordinates (index of line and character).
Public method | ScreenToText(Int32, Int32) | Converts given screen coordinates to text coordinates (index of line and character).
Public method | ScreenToText(Int32, Int32, Boolean) | Converts given screen coordinates to text coordinates (index of line and character).
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ScreenToText Method (Point)

SyntaxEditScreenToText Method (Point)
Converts given screen coordinates to text coordinates (index of line and character).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point ScreenToText(
    Point position
)
Public Overridable Function ScreenToText (
    position As Point
) As Point
public:
virtual Point ScreenToText(
    Point position
)
abstract ScreenToText :
        position : Point -> Point
override ScreenToText :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The screen coordinate Point to convert.

Return Value

Type: Point
The Point representing text coordinate.

Implements

ISyntaxEditScreenToText(Point)
See Also

Reference

SyntaxEdit Class
ScreenToText Overload
Alternet.Editor Namespace


SyntaxEdit.ScreenToText Method (Int32, Int32)

SyntaxEditScreenToText Method (Int32, Int32)
Converts given screen coordinates to text coordinates (index of line and character).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point ScreenToText(
    int x,
    int y
)
Public Overridable Function ScreenToText (
    x As Integer,
    y As Integer
) As Point
public:
virtual Point ScreenToText(
    int x,
    int y
)
abstract ScreenToText :
        x : int *
        y : int -> Point
override ScreenToText :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
Horizontal screen coordinate to convert.
y
Type: SystemInt32
Vertical screen coordinate to convert.

Return Value

Type: Point
The Point representing text coordinate.

Implements

ISyntaxEditScreenToText(Int32, Int32)
See Also

Reference

SyntaxEdit Class
ScreenToText Overload
Alternet.Editor Namespace


SyntaxEdit.ScreenToText Method (Int32, Int32, Boolean)

SyntaxEditScreenToText Method (Int32, Int32, Boolean)
Converts given screen coordinates to text coordinates (index of line and character).

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point ScreenToText(
    int x,
    int y,
    ref bool lineEnd
)
Public Overridable Function ScreenToText (
    x As Integer,
    y As Integer,
    ByRef lineEnd As Boolean
) As Point
public:
virtual Point ScreenToText(
    int x,
    int y,
    bool% lineEnd
)
abstract ScreenToText :
        x : int *
        y : int *
        lineEnd : bool byref -> Point
override ScreenToText :
        x : int *
        y : int *
        lineEnd : bool byref -> Point

Parameters

x
Type: SystemInt32
Horizontal screen coordinate to convert.
y
Type: SystemInt32
Vertical screen coordinate to convert.
lineEnd
Type: SystemBoolean
Receives boolean value indicating if the caret is at the line end of the wrapped line.

Return Value

Type: Point
The Point representing text coordinate.

Implements

ISyntaxEditScreenToText(Int32, Int32, Boolean)
See Also

Reference

SyntaxEdit Class
ScreenToText Overload
Alternet.Editor Namespace


SyntaxEdit.ScrollLineDown Method

SyntaxEditScrollLineDown Method
Scrolls text content one line down.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ScrollLineDown()
Public Overridable Sub ScrollLineDown
public:
virtual void ScrollLineDown()
abstract ScrollLineDown : unit -> unit
override ScrollLineDown : unit -> unit

Implements

IEditNavigateScrollLineDown
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ScrollLineUp Method

SyntaxEditScrollLineUp Method
Scrolls text content one line up.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ScrollLineUp()
Public Overridable Sub ScrollLineUp
public:
virtual void ScrollLineUp()
abstract ScrollLineUp : unit -> unit
override ScrollLineUp : unit -> unit

Implements

IEditNavigateScrollLineUp
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SetLineHidden Method

SyntaxEditSetLineHidden Method
Overload List
 | Name | Description
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SetLineHidden Method (Int32, Boolean)

SyntaxEditSetLineHidden Method (Int32, Boolean)
Sets readonly state for the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineHidden(
    int index,
    bool hidden
)
Public Overridable Sub SetLineHidden (
    index As Integer,
    hidden As Boolean
)
public:
virtual void SetLineHidden(
    int index,
    bool hidden
)
abstract SetLineHidden :
        index : int *
        hidden : bool -> unit
override SetLineHidden :
        index : int *
        hidden : bool -> unit

Parameters

index
Type: SystemInt32
Line index.
hidden
Type: SystemBoolean
Indicates hidden flag should be set or cleared.

Implements

IEditSetLineHidden(Int32, Boolean)
See Also

Reference

SyntaxEdit Class
SetLineHidden Overload
Alternet.Editor Namespace


SyntaxEdit.SetLineHidden Method (Int32[], Boolean)

SyntaxEditSetLineHidden Method (Int32, Boolean)
Sets readonly state for the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineHidden(
    int[] indexes,
    bool hidden
)
Public Overridable Sub SetLineHidden (
    indexes As Integer(),
    hidden As Boolean
)
public:
virtual void SetLineHidden(
    array<int>^ indexes,
    bool hidden
)
abstract SetLineHidden :
        indexes : int[] *
        hidden : bool -> unit
override SetLineHidden :
        indexes : int[] *
        hidden : bool -> unit

Parameters

indexes
Type: SystemInt32
Line indexes.
hidden
Type: SystemBoolean
Indicates hidden flag should be set or cleared.

Implements

IEditSetLineHidden(Int32, Boolean)
See Also

Reference

SyntaxEdit Class
SetLineHidden Overload
Alternet.Editor Namespace


SyntaxEdit.SetLineReadonly Method

SyntaxEditSetLineReadonly Method
Overload List
 | Name | Description
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SetLineReadonly Method (Int32, Boolean)

SyntaxEditSetLineReadonly Method (Int32, Boolean)
Sets readonly state for the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineReadonly(
    int index,
    bool readOnly
)
Public Overridable Sub SetLineReadonly (
    index As Integer,
    readOnly As Boolean
)
public:
virtual void SetLineReadonly(
    int index,
    bool readOnly
)
abstract SetLineReadonly :
        index : int *
        readOnly : bool -> unit
override SetLineReadonly :
        index : int *
        readOnly : bool -> unit

Parameters

index
Type: SystemInt32
Line index.
readOnly
Type: SystemBoolean
Indicates readonly flag should be set or cleared.

Implements

IEditSetLineReadonly(Int32, Boolean)
See Also

Reference

SyntaxEdit Class
SetLineReadonly Overload
Alternet.Editor Namespace


SyntaxEdit.SetLineReadonly Method (Int32[], Boolean)

SyntaxEditSetLineReadonly Method (Int32, Boolean)
Sets readonly state for the given line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineReadonly(
    int[] indexes,
    bool readOnly
)
Public Overridable Sub SetLineReadonly (
    indexes As Integer(),
    readOnly As Boolean
)
public:
virtual void SetLineReadonly(
    array<int>^ indexes,
    bool readOnly
)
abstract SetLineReadonly :
        indexes : int[] *
        readOnly : bool -> unit
override SetLineReadonly :
        indexes : int[] *
        readOnly : bool -> unit

Parameters

indexes
Type: SystemInt32
Line indexes.
readOnly
Type: SystemBoolean
Indicates readonly flag should be set or cleared.

Implements

IEditSetLineReadonly(Int32, Boolean)
See Also

Reference

SyntaxEdit Class
SetLineReadonly Overload
Alternet.Editor Namespace


SyntaxEdit.SetNavigateOptions Method

SyntaxEditSetNavigateOptions Method
Sets navigating options without validating position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetNavigateOptions(
    NavigateOptions navigateOptions
)
Public Overridable Sub SetNavigateOptions (
    navigateOptions As NavigateOptions
)
public:
virtual void SetNavigateOptions(
    NavigateOptions navigateOptions
)
abstract SetNavigateOptions :
        navigateOptions : NavigateOptions -> unit
override SetNavigateOptions :
        navigateOptions : NavigateOptions -> unit

Parameters

navigateOptions
Type: Alternet.Editor.TextSourceNavigateOptions

Implements

INavigateSetNavigateOptions(NavigateOptions)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeBorderColor Method

SyntaxEditShouldSerializeBorderColor Method
Indicates whether the BorderColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeBorderColor()
Public Overridable Function ShouldSerializeBorderColor As Boolean
public:
virtual bool ShouldSerializeBorderColor()
abstract ShouldSerializeBorderColor : unit -> bool
override ShouldSerializeBorderColor : unit -> bool

Return Value

Type: Boolean
True if BorderColor differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeBorderStyle Method

SyntaxEditShouldSerializeBorderStyle Method
Indicates whether the BorderStyle property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeBorderStyle()
Public Overridable Function ShouldSerializeBorderStyle As Boolean
public:
virtual bool ShouldSerializeBorderStyle()
abstract ShouldSerializeBorderStyle : unit -> bool
override ShouldSerializeBorderStyle : unit -> bool

Return Value

Type: Boolean
True if BorderStyle differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeCodeCompletionChars Method

SyntaxEditShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeCodeCompletionChars()
Public Function ShouldSerializeCodeCompletionChars As Boolean
public:
bool ShouldSerializeCodeCompletionChars()
member ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeCursor Method

SyntaxEditShouldSerializeCursor Method
Indicates whether the Cursor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeCursor()
Public Function ShouldSerializeCursor As Boolean
public:
bool ShouldSerializeCursor()
member ShouldSerializeCursor : unit -> bool

Return Value

Type: Boolean
True if Cursor differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeFont Method

SyntaxEditShouldSerializeFont Method
Indicates whether the Font property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeFont()
Public Function ShouldSerializeFont As Boolean
public:
bool ShouldSerializeFont()
member ShouldSerializeFont : unit -> bool

Return Value

Type: Boolean
True if Font differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeIndentOptions Method

SyntaxEditShouldSerializeIndentOptions Method
Indicates whether the IndentOptions property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeIndentOptions()
Public Function ShouldSerializeIndentOptions As Boolean
public:
bool ShouldSerializeIndentOptions()
member ShouldSerializeIndentOptions : unit -> bool

Return Value

Type: Boolean
True if IndentOptions differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeNavigateOptions Method

SyntaxEditShouldSerializeNavigateOptions Method
Indicates whether the NavigateOptions property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeNavigateOptions()
Public Function ShouldSerializeNavigateOptions As Boolean
public:
bool ShouldSerializeNavigateOptions()
member ShouldSerializeNavigateOptions : unit -> bool

Return Value

Type: Boolean
True if NavigateOptions differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeReadOnly Method

SyntaxEditShouldSerializeReadOnly Method
Indicates whether the ReadOnly property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeReadOnly()
Public Function ShouldSerializeReadOnly As Boolean
public:
bool ShouldSerializeReadOnly()
member ShouldSerializeReadOnly : unit -> bool

Return Value

Type: Boolean
True if ReadOnly differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeSearchOptions Method

SyntaxEditShouldSerializeSearchOptions Method
Indicates whether the SearchOptions property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeSearchOptions()
Public Function ShouldSerializeSearchOptions As Boolean
public:
bool ShouldSerializeSearchOptions()
member ShouldSerializeSearchOptions : unit -> bool

Return Value

Type: Boolean
True if SearchOptions differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShouldSerializeText Method

SyntaxEditShouldSerializeText Method
Indicates whether the Text property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeText()
Public Function ShouldSerializeText As Boolean
public:
bool ShouldSerializeText()
member ShouldSerializeText : unit -> bool

Return Value

Type: Boolean
True if Text differs from its default value; otherwise false.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShowCaret Method

SyntaxEditShowCaret Method
Moves the caret to the specified coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowCaret(
    int x,
    int y
)
Public Overridable Sub ShowCaret (
    x As Integer,
    y As Integer
)
public:
virtual void ShowCaret(
    int x,
    int y
)
abstract ShowCaret :
        x : int *
        y : int -> unit
override ShowCaret :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
Specifies the new x-coordinate of the caret.
y
Type: SystemInt32
Specifies the new y-coordinate of the caret.

Implements

ICaretShowCaret(Int32, Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShowCodeCompletionBox Method

SyntaxEditShowCodeCompletionBox Method
Overload List
 | Name | Description
Public method | ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType) | Shows code completion popup window with given provider at the current position.
Public method | ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point) | Shows code completion popup window with given Provider at the specified position.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShowCodeCompletionBox Method (ICodeCompletionProvider, CodeCompletionType)

SyntaxEditShowCodeCompletionBox Method (ICodeCompletionProvider, CodeCompletionType)
Shows code completion popup window with given provider at the current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowCodeCompletionBox(
    ICodeCompletionProvider provider,
    CodeCompletionType completionType
)
Public Overridable Sub ShowCodeCompletionBox (
    provider As ICodeCompletionProvider,
    completionType As CodeCompletionType
)
public:
virtual void ShowCodeCompletionBox(
    ICodeCompletionProvider^ provider,
    CodeCompletionType completionType
)
abstract ShowCodeCompletionBox :
        provider : ICodeCompletionProvider *
        completionType : CodeCompletionType -> unit
override ShowCodeCompletionBox :
        provider : ICodeCompletionProvider *
        completionType : CodeCompletionType -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion popup window.
completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion type.

Implements

ICodeCompletionShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType)
See Also

Reference

SyntaxEdit Class
ShowCodeCompletionBox Overload
Alternet.Editor Namespace


SyntaxEdit.ShowCodeCompletionBox Method (ICodeCompletionProvider, CodeCompletionType, Point)

SyntaxEditShowCodeCompletionBox Method (ICodeCompletionProvider, CodeCompletionType, Point)
Shows code completion popup window with given Provider at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowCodeCompletionBox(
    ICodeCompletionProvider provider,
    CodeCompletionType completionType,
    Point position
)
Public Overridable Sub ShowCodeCompletionBox (
    provider As ICodeCompletionProvider,
    completionType As CodeCompletionType,
    position As Point
)
public:
virtual void ShowCodeCompletionBox(
    ICodeCompletionProvider^ provider,
    CodeCompletionType completionType,
    Point position
)
abstract ShowCodeCompletionBox :
        provider : ICodeCompletionProvider *
        completionType : CodeCompletionType *
        position : Point -> unit
override ShowCodeCompletionBox :
        provider : ICodeCompletionProvider *
        completionType : CodeCompletionType *
        position : Point -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion popup window.
completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion type.
position
Type: System.DrawingPoint
Position to show code completion popup window.

Implements

ICodeCompletionShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point)
See Also

Reference

SyntaxEdit Class
ShowCodeCompletionBox Overload
Alternet.Editor Namespace


SyntaxEdit.ShowCodeCompletionButton Method

SyntaxEditShowCodeCompletionButton Method
Overload List
 | Name | Description
Public method | ShowCodeCompletionButton(ICodeCompletionProvider) | Shows code completion popup window with given provider at the current position.
Public method | ShowCodeCompletionButton(ICodeCompletionProvider, Point, Boolean) | Shows code completion popup window with given Provider at the specified position.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShowCodeCompletionButton Method (ICodeCompletionProvider)

SyntaxEditShowCodeCompletionButton Method (ICodeCompletionProvider)
Shows code completion popup window with given provider at the current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowCodeCompletionButton(
    ICodeCompletionProvider provider
)
Public Overridable Sub ShowCodeCompletionButton (
    provider As ICodeCompletionProvider
)
public:
virtual void ShowCodeCompletionButton(
    ICodeCompletionProvider^ provider
)
abstract ShowCodeCompletionButton :
        provider : ICodeCompletionProvider -> unit
override ShowCodeCompletionButton :
        provider : ICodeCompletionProvider -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion popup window.
See Also

Reference

SyntaxEdit Class
ShowCodeCompletionButton Overload
Alternet.Editor Namespace


SyntaxEdit.ShowCodeCompletionButton Method (ICodeCompletionProvider, Point, Boolean)

SyntaxEditShowCodeCompletionButton Method (ICodeCompletionProvider, Point, Boolean)
Shows code completion popup window with given Provider at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowCodeCompletionButton(
    ICodeCompletionProvider provider,
    Point position,
    bool dropDown
)
Public Overridable Sub ShowCodeCompletionButton (
    provider As ICodeCompletionProvider,
    position As Point,
    dropDown As Boolean
)
public:
virtual void ShowCodeCompletionButton(
    ICodeCompletionProvider^ provider,
    Point position,
    bool dropDown
)
abstract ShowCodeCompletionButton :
        provider : ICodeCompletionProvider *
        position : Point *
        dropDown : bool -> unit
override ShowCodeCompletionButton :
        provider : ICodeCompletionProvider *
        position : Point *
        dropDown : bool -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion popup window.
position
Type: System.DrawingPoint
Position to show code completion popup window.
dropDown
Type: SystemBoolean
Specifies if dropdown menu should be displayed.

Implements

ICodeCompletionShowCodeCompletionButton(ICodeCompletionProvider, Point, Boolean)
See Also

Reference

SyntaxEdit Class
ShowCodeCompletionButton Overload
Alternet.Editor Namespace


SyntaxEdit.ShowCodeCompletionHint Method

SyntaxEditShowCodeCompletionHint Method
Overload List
 | Name | Description
Public method | ShowCodeCompletionHint(ICodeCompletionProvider, ILexer) | Displays ICodeCompletionHint with given provider at the current position.
Public method | ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer) | Displays ICodeCompletionHint with given provider at the specified position.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShowCodeCompletionHint Method (ICodeCompletionProvider, ILexer)

SyntaxEditShowCodeCompletionHint Method (ICodeCompletionProvider, ILexer)
Displays ICodeCompletionHint with given provider at the current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowCodeCompletionHint(
    ICodeCompletionProvider provider,
    ILexer lexer
)
Public Overridable Sub ShowCodeCompletionHint (
    provider As ICodeCompletionProvider,
    lexer As ILexer
)
public:
virtual void ShowCodeCompletionHint(
    ICodeCompletionProvider^ provider,
    ILexer^ lexer
)
abstract ShowCodeCompletionHint :
        provider : ICodeCompletionProvider *
        lexer : ILexer -> unit
override ShowCodeCompletionHint :
        provider : ICodeCompletionProvider *
        lexer : ILexer -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion hint.
lexer
Type: Alternet.Syntax.LexerILexer
Specifies lexer used to draw code completion hint.

Implements

ICodeCompletionShowCodeCompletionHint(ICodeCompletionProvider, ILexer)
See Also

Reference

SyntaxEdit Class
ShowCodeCompletionHint Overload
Alternet.Editor Namespace


SyntaxEdit.ShowCodeCompletionHint Method (ICodeCompletionProvider, Point, ILexer)

SyntaxEditShowCodeCompletionHint Method (ICodeCompletionProvider, Point, ILexer)
Displays ICodeCompletionHint with given provider at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowCodeCompletionHint(
    ICodeCompletionProvider provider,
    Point position,
    ILexer lexer
)
Public Overridable Sub ShowCodeCompletionHint (
    provider As ICodeCompletionProvider,
    position As Point,
    lexer As ILexer
)
public:
virtual void ShowCodeCompletionHint(
    ICodeCompletionProvider^ provider,
    Point position,
    ILexer^ lexer
)
abstract ShowCodeCompletionHint :
        provider : ICodeCompletionProvider *
        position : Point *
        lexer : ILexer -> unit
override ShowCodeCompletionHint :
        provider : ICodeCompletionProvider *
        position : Point *
        lexer : ILexer -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion hint.
position
Type: System.DrawingPoint
Position to display the hint.
lexer
Type: Alternet.Syntax.LexerILexer
Specifies lexer used to draw code completion hint.

Implements

ICodeCompletionShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer)
See Also

Reference

SyntaxEdit Class
ShowCodeCompletionHint Overload
Alternet.Editor Namespace


SyntaxEdit.ShowNotFound Method

SyntaxEditShowNotFound Method
Displays "searched text not found" message box.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowNotFound(
    string caption
)
Public Overridable Sub ShowNotFound (
    caption As String
)
public:
virtual void ShowNotFound(
    String^ caption
)
abstract ShowNotFound :
        caption : string -> unit
override ShowNotFound :
        caption : string -> unit

Parameters

caption
Type: SystemString
Specifies caption of the message dialog.

Implements

ISearchShowNotFound(String)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ShowScrollHint Method

SyntaxEditShowScrollHint Method
Displays tooltip indicating destination line when scrolling.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowScrollHint(
    int pos
)
Public Overridable Sub ShowScrollHint (
    pos As Integer
)
public:
virtual void ShowScrollHint(
    int pos
)
abstract ShowScrollHint :
        pos : int -> unit
override ShowScrollHint :
        pos : int -> unit

Parameters

pos
Type: SystemInt32
Specifies vertical position (in display coordinates) to obtain hint info.

Implements

ISyntaxEditShowScrollHint(Int32)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SplitViewHorz Method

SyntaxEditSplitViewHorz Method
Splits control content horizontally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SplitViewHorz()
Public Overridable Sub SplitViewHorz
public:
virtual void SplitViewHorz()
abstract SplitViewHorz : unit -> unit
override SplitViewHorz : unit -> unit

Implements

ISplitViewSplitViewHorz
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SplitViewVert Method

SyntaxEditSplitViewVert Method
Splits control content vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SplitViewVert()
Public Overridable Sub SplitViewVert
public:
virtual void SplitViewVert()
abstract SplitViewVert : unit -> unit
override SplitViewVert : unit -> unit

Implements

ISplitViewSplitViewVert
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.StartIncrementalSearch Method

SyntaxEditStartIncrementalSearch Method
Overload List
 | Name | Description
Public method | StartIncrementalSearch | Enters control to the incremental search state.
Public method | StartIncrementalSearch(Boolean) | Enters control to the incremental search state.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.StartIncrementalSearch Method

SyntaxEditStartIncrementalSearch Method
Enters control to the incremental search state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StartIncrementalSearch()
Public Overridable Sub StartIncrementalSearch
public:
virtual void StartIncrementalSearch()
abstract StartIncrementalSearch : unit -> unit
override StartIncrementalSearch : unit -> unit

Implements

ISearchStartIncrementalSearch
See Also

Reference

SyntaxEdit Class
StartIncrementalSearch Overload
Alternet.Editor Namespace
SyntaxEditFinishIncrementalSearch


SyntaxEdit.StartIncrementalSearch Method (Boolean)

SyntaxEditStartIncrementalSearch Method (Boolean)
Enters control to the incremental search state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StartIncrementalSearch(
    bool backwardSearch
)
Public Overridable Sub StartIncrementalSearch (
    backwardSearch As Boolean
)
public:
virtual void StartIncrementalSearch(
    bool backwardSearch
)
abstract StartIncrementalSearch :
        backwardSearch : bool -> unit
override StartIncrementalSearch :
        backwardSearch : bool -> unit

Parameters

backwardSearch
Type: SystemBoolean
Indicates that search should be executed towards the beginning of text.

Implements

ISearchStartIncrementalSearch(Boolean)
See Also

Reference

SyntaxEdit Class
StartIncrementalSearch Overload
Alternet.Editor Namespace
SyntaxEditFinishIncrementalSearch


SyntaxEdit.StartMacroRecording Method

SyntaxEditStartMacroRecording Method
Starts recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StartMacroRecording()
Public Overridable Sub StartMacroRecording
public:
virtual void StartMacroRecording()
abstract StartMacroRecording : unit -> unit
override StartMacroRecording : unit -> unit

Implements

IRecordPlayBackStartMacroRecording
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.StopMacroRecording Method

SyntaxEditStopMacroRecording Method
Stops recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StopMacroRecording()
Public Overridable Sub StopMacroRecording
public:
virtual void StopMacroRecording()
abstract StopMacroRecording : unit -> unit
override StopMacroRecording : unit -> unit

Implements

IRecordPlayBackStopMacroRecording
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.StorePosition Method

SyntaxEditStorePosition Method
Overload List
 | Name | Description
Public method | StorePosition(Point) | Stores given position to stored position list.
Public method | StorePosition(Point, Boolean) | Stores given position to stored position list.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.StorePosition Method (Point)

SyntaxEditStorePosition Method (Point)
Stores given position to stored position list.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StorePosition(
    Point position
)
Public Overridable Function StorePosition (
    position As Point
) As Integer
public:
virtual int StorePosition(
    Point position
)
abstract StorePosition :
        position : Point -> int
override StorePosition :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position to store.

Return Value

Type: Int32
Index of stored position in list.

Implements

INavigateStorePosition(Point)
See Also

Reference

SyntaxEdit Class
StorePosition Overload
Alternet.Editor Namespace


SyntaxEdit.StorePosition Method (Point, Boolean)

SyntaxEditStorePosition Method (Point, Boolean)
Stores given position to stored position list.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StorePosition(
    Point position,
    bool endPos
)
Public Overridable Function StorePosition (
    position As Point,
    endPos As Boolean
) As Integer
public:
virtual int StorePosition(
    Point position,
    bool endPos
)
abstract StorePosition :
        position : Point *
        endPos : bool -> int
override StorePosition :
        position : Point *
        endPos : bool -> int

Parameters

position
Type: System.DrawingPoint
Position to store.
endPos
Type: SystemBoolean
Specifies whether position represents end of range.

Return Value

Type: Int32
Index of stored position in list.

Implements

INavigateStorePosition(Point, Boolean)
See Also

Reference

SyntaxEdit Class
StorePosition Overload
Alternet.Editor Namespace


SyntaxEdit.StorePositionWithUndo Method

SyntaxEditStorePositionWithUndo Method
Stores given position to stored position list preserving it for undo.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StorePositionWithUndo(
    Point position
)
Public Overridable Function StorePositionWithUndo (
    position As Point
) As Integer
public:
virtual int StorePositionWithUndo(
    Point position
)
abstract StorePositionWithUndo :
        position : Point -> int
override StorePositionWithUndo :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position to store.

Return Value

Type: Int32
Index of stored position in list.

Implements

INavigateStorePositionWithUndo(Point)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.TextStyleAt Method

SyntaxEditTextStyleAt Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual byte TextStyleAt(
    Point position
)
Public Overridable Function TextStyleAt (
    position As Point
) As Byte
public:
virtual unsigned char TextStyleAt(
    Point position
)
abstract TextStyleAt :
        position : Point -> byte
override TextStyleAt :
        position : Point -> byte

Parameters

position
Type: System.DrawingPoint

Return Value

Type: Byte
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.TextToScreen Method

SyntaxEditTextToScreen Method
Overload List
 | Name | Description
Public method | TextToScreen(Point) | Converts given text coordinates, index of line and character, to screen coordinates.
Public method | TextToScreen(Point, Boolean) | Converts given text coordinates, index of line and character, to screen coordinates.
Public method | TextToScreen(Int32, Int32) | Converts given text coordinates, index of line and character, to screen coordinates.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.TextToScreen Method (Point)

SyntaxEditTextToScreen Method (Point)
Converts given text coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point TextToScreen(
    Point position
)
Public Overridable Function TextToScreen (
    position As Point
) As Point
public:
virtual Point TextToScreen(
    Point position
)
abstract TextToScreen :
        position : Point -> Point
override TextToScreen :
        position : Point -> Point

Parameters

position
Type: System.DrawingPoint
The text coordinate Point to convert.

Return Value

Type: Point
The Point representing screen coordinate.

Implements

ISyntaxEditTextToScreen(Point)
See Also

Reference

SyntaxEdit Class
TextToScreen Overload
Alternet.Editor Namespace


SyntaxEdit.TextToScreen Method (Point, Boolean)

SyntaxEditTextToScreen Method (Point, Boolean)
Converts given text coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point TextToScreen(
    Point position,
    bool lineEnd
)
Public Overridable Function TextToScreen (
    position As Point,
    lineEnd As Boolean
) As Point
public:
virtual Point TextToScreen(
    Point position,
    bool lineEnd
)
abstract TextToScreen :
        position : Point *
        lineEnd : bool -> Point
override TextToScreen :
        position : Point *
        lineEnd : bool -> Point

Parameters

position
Type: System.DrawingPoint
Point coordinate to convert.
lineEnd
Type: SystemBoolean
Boolean value indicating if the text position can be set to the end of the wrapped line.

Return Value

Type: Point
The Point representing screen coordinate.

Implements

ISyntaxEditTextToScreen(Point, Boolean)
See Also

Reference

SyntaxEdit Class
TextToScreen Overload
Alternet.Editor Namespace


SyntaxEdit.TextToScreen Method (Int32, Int32)

SyntaxEditTextToScreen Method (Int32, Int32)
Converts given text coordinates, index of line and character, to screen coordinates.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point TextToScreen(
    int x,
    int y
)
Public Overridable Function TextToScreen (
    x As Integer,
    y As Integer
) As Point
public:
virtual Point TextToScreen(
    int x,
    int y
)
abstract TextToScreen :
        x : int *
        y : int -> Point
override TextToScreen :
        x : int *
        y : int -> Point

Parameters

x
Type: SystemInt32
Horizontal text coordinate to convert.
y
Type: SystemInt32
Vertical text coordinate to convert.

Return Value

Type: Point
The Point representing screen coordinate.

Implements

ISyntaxEditTextToScreen(Int32, Int32)
See Also

Reference

SyntaxEdit Class
TextToScreen Overload
Alternet.Editor Namespace


SyntaxEdit.ToggleMacroRecording Method

SyntaxEditToggleMacroRecording Method
Toggles recording the command sequence.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleMacroRecording()
Public Overridable Sub ToggleMacroRecording
public:
virtual void ToggleMacroRecording()
abstract ToggleMacroRecording : unit -> unit
override ToggleMacroRecording : unit -> unit

Implements

IRecordPlayBackToggleMacroRecording
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UnBreakLine Method

SyntaxEditUnBreakLine Method
Concatenates lines at current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnBreakLine(
    bool withChange = false
)
Public Overridable Function UnBreakLine (
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool UnBreakLine(
    bool withChange = false
)
abstract UnBreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override UnBreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditUnBreakLine(Boolean)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UnhighlightAll Method

SyntaxEditUnhighlightAll Method
Unhighlights search results previously highlighted by HighlightAll.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnhighlightAll()
Public Overridable Sub UnhighlightAll
public:
virtual void UnhighlightAll()
abstract UnhighlightAll : unit -> unit
override UnhighlightAll : unit -> unit

Implements

ISearchUnhighlightAll
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UnsplitViewHorz Method

SyntaxEditUnsplitViewHorz Method
Removes horizontal split view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnsplitViewHorz()
Public Overridable Sub UnsplitViewHorz
public:
virtual void UnsplitViewHorz()
abstract UnsplitViewHorz : unit -> unit
override UnsplitViewHorz : unit -> unit

Implements

ISplitViewUnsplitViewHorz
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UnsplitViewVert Method

SyntaxEditUnsplitViewVert Method
Removes vertical split view.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnsplitViewVert()
Public Overridable Sub UnsplitViewVert
public:
virtual void UnsplitViewVert()
abstract UnsplitViewVert : unit -> unit
override UnsplitViewVert : unit -> unit

Implements

ISplitViewUnsplitViewVert
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UpdateCaret Method

SyntaxEditUpdateCaret Method
Ensures the caret is displayed in the current position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateCaret()
Public Overridable Sub UpdateCaret
public:
virtual void UpdateCaret()
abstract UpdateCaret : unit -> unit
override UpdateCaret : unit -> unit

Implements

ICaretUpdateCaret
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UpdateCursor Method

SyntaxEditUpdateCursor Method
Causes current mouse cursor to be updated.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateCursor()
Public Sub UpdateCursor
public:
void UpdateCursor()
member UpdateCursor : unit -> unit
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UpdateView Method

SyntaxEditUpdateView Method
Updates editor content, caret and pages area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateView()
Public Sub UpdateView
public:
virtual void UpdateView() sealed
abstract UpdateView : unit -> unit
override UpdateView : unit -> unit

Implements

ISyntaxEditUpdateView
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UpdateWordWrap Method

SyntaxEditUpdateWordWrap Method
Overload List
 | Name | Description
Public method | UpdateWordWrap | Re-wraps all lines in the text.
Public method | UpdateWordWrap(Int32, Int32) | Re-wraps lines in the text within specific scope.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UpdateWordWrap Method

SyntaxEditUpdateWordWrap Method
Re-wraps all lines in the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateWordWrap()
Public Overridable Function UpdateWordWrap As Boolean
public:
virtual bool UpdateWordWrap()
abstract UpdateWordWrap : unit -> bool
override UpdateWordWrap : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IWordWrapUpdateWordWrap
See Also

Reference

SyntaxEdit Class
UpdateWordWrap Overload
Alternet.Editor Namespace


SyntaxEdit.UpdateWordWrap Method (Int32, Int32)

SyntaxEditUpdateWordWrap Method (Int32, Int32)
Re-wraps lines in the text within specific scope.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateWordWrap(
    int first,
    int last
)
Public Overridable Function UpdateWordWrap (
    first As Integer,
    last As Integer
) As Boolean
public:
virtual bool UpdateWordWrap(
    int first,
    int last
)
abstract UpdateWordWrap :
        first : int *
        last : int -> bool
override UpdateWordWrap :
        first : int *
        last : int -> bool

Parameters

first
Type: SystemInt32
Specifies first line to wrap.
last
Type: SystemInt32
Specifies last line to wrap.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IWordWrapUpdateWordWrap(Int32, Int32)
See Also

Reference

SyntaxEdit Class
UpdateWordWrap Overload
Alternet.Editor Namespace


SyntaxEdit.ValidatePosition Method

SyntaxEditValidatePosition Method
Validates given position within control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ValidatePosition(
    ref Point position
)
Public Overridable Sub ValidatePosition (
    ByRef position As Point
)
public:
virtual void ValidatePosition(
    Point% position
)
abstract ValidatePosition :
        position : Point byref -> unit
override ValidatePosition :
        position : Point byref -> unit

Parameters

position
Type: System.DrawingPoint
Position to validate.

Implements

INavigateValidatePosition(Point)
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit Properties

SyntaxEdit Properties

The SyntaxEdit type exposes the following members.

Properties
 | Name | Description
Public property | AcceptReturns | Gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key.
Public property | AcceptTabs | Gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key.
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveOutlineRange | Gets currently highlighted outlined range.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Overrides ControlAllowDrop.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCorrectDelimiters | Gets or sets an array of chars that used as word delimiters.
Public property | AutoCorrection | Gets or sets a boolean value indicating whether to auto correct words being typed.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color for the Edit control.
Public property | BorderStyle | Gets or sets the border style for the Edit control.
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Braces | Represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control.
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharsInWidth | Returns number of characters painted with current font that will fit into control's client area.
Public property | ClientArea | Gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded.
Public property | ClientHeight | Gets the width of the client area of the Edit control.
Public property | ClientRect | Gets the rectangle that represents the client area of the Edit control.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ClientWidth | Gets the width of the client area of the Edit control.
Public property | CodeCompletionBox | Represents object that specifies a popup window that contains code completion information presented in the form of list.
Public property | CodeCompletionButton | Represents object that specifies a popup window that contains code completion information presented in the form of list.
Public property | CodeCompletionChars | Represents a collection of characters that initializes a code completion procedure when typing in the editor.
Public property | CodeCompletionHint | Represents object that specifies a popup window that contains code completion information presented in the form of the tooltip.
Public property | CodeCompletionMode | Gets or sets code completion box mode.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentBlockRange | Gets currently highlighted block range.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Overrides ControlCursor.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultMenu | Gets or sets default context menu for the editor control.
Public property | DisplayLines | Represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | EditMargin | Represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed.
Public property | EffectiveVisualTheme | Gets current visual theme.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EventHandlers | Represents object that holds EventHandlers containing list of keys with attached actions.
Public property | FirstSearch | Gets or sets a value indicating whether control launches text search at first.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Overrides ControlFont.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GotoLineDialog | Gets or sets a dialog prompting for index of the line you need to locate.
Public property | Gutter | Represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideCaret | Gets or sets a value indicating whether the control should display caret when it has input focus.
Public property | HighlightCurrentBlock | Specifies that edit control should highlight current block.
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight begin/end blocks.
Public property | HighlightReferences | Specifies that edit control should highlight found references.
Public property | HighlightSearchResults | Indicates whether search results are highlighted while the search dialog is open.
Public property | HorzSplitEdit | Represents horizontal split view control.
Public property | HorzSplitter | Represents a horizontal Splitter control allowing to split Edit content horizontally.
Public property | HyperText | Represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IncrementalSearchString | Return text to search if class is in incremental search state; otherwise return empty string.
Public property | InCycledSearch | Indicates whether control is in incremental search state.
Public property | IndentOptions | Gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line.
Public property | InIncrementalSearch | Indicates whether control is in incremental search state.
Public property | InnerTextSource | Gets inner text source
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsCodeCompletionWindowFocused | Indicates whether ICodeCompletionWindow has focus.
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSearchFocused | Gets a boolean value indicating whether search dialog box has input focus.
Public property | KeepCaretOnLostFocus | Keeps caret in visible state even Edit control lost focus.
Public property | KeyList | Represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content.
Public property | Lines | Represents object that implements ITextStrings interface containing collection of strings determining control's content.
Public property | LineSeparator | Represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control.
Public property | LinesInHeight | Determines how many lines can fit into control's client area.
Public property | LineSpace | Gets or sets line space between individual lines in the Edit control.
Public property | LineStyles | Represents an object that implements IEditLineStyles interface holding collection of IEditLineStyle objects each of them determines particular style of the line in the control.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | MacroRecording | Gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands.
Public property | MacroRecords | Represents an array containing keyboard commands.
Public property | MacroSuspendend | Gets or sets a boolean value indicating whether recording is suspended.
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavigateOptions | Gets or sets navigating options.
Public property | OpenSharedEditorFunc | When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment.
Public property | Outlining | Represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control.
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Pages | Represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages.
Public property | Painter | Represents an object that implements IPainter interface used to draw control's text.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | Position | Gets or sets current position within the control's text content.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PrevPosition | Gets previous position within the control's text content.
Public property | Printing | Represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options.
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Scrolling | Represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control.
Public property | SearchDialog | Gets or sets a dialog box allowing to search for the text or replace it.
Public property | SearchDialogAppearance |
Public property | SearchGlobal | Gets or sets a value indicating whether search should be global.
Public property | SearchLen | Represents length of the last found text.
Public property | SearchOptions | Gets or sets a value that defines search and replace options.
Public property | SearchPos | Gets or sets a value that represents position of the last found text.
Public property | Selection | Represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text.
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Source | Gets or sets an object that implements ITextSource interface containing an actual string data displayed by the control.
Public property | Spelling | Represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words.
Public property | Strings | Represents Lines property in the form of array of strings.
Public property | SyntaxPaint | Represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the string collection as a single string with the individual lines delimited by carriage returns. (Overrides ControlText.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Transparent | Gets or sets a boolean value that indicates whether Edit control should draw its background.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UseDefaultMenu | Indicates whether edit control should use built in popup menu.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VertSplitEdit | Represents an vertical split view control.
Public property | VertSplitter | Represents a vertical Splitter control allowing to split Edit content vertically.
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualTheme | Gets or sets visual theme for the editor.
Public property | VisualThemeType | Gets or sets visual theme type for the editor.
Public property | WhiteSpace | Represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks.
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary.
Public property | WrapAtMargin | Gets or sets a value indicating whether control automatically wraps words at margin position.
Public property | WrapMargin | Gets position of the wrapping margin.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.AcceptReturns Property

SyntaxEditAcceptReturns Property
Gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AcceptReturns { get; set; }
Public Overridable Property AcceptReturns As Boolean
    Get
    Set
public:
virtual property bool AcceptReturns {
    bool get ();
    void set (bool value);
}
abstract AcceptReturns : bool with get, set
override AcceptReturns : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxEditAcceptReturns
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.AcceptTabs Property

SyntaxEditAcceptTabs Property
Gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AcceptTabs { get; set; }
Public Overridable Property AcceptTabs As Boolean
    Get
    Set
public:
virtual property bool AcceptTabs {
    bool get ();
    void set (bool value);
}
abstract AcceptTabs : bool with get, set
override AcceptTabs : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxEditAcceptTabs
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ActiveOutlineRange Property

SyntaxEditActiveOutlineRange Property
Gets currently highlighted outlined range.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IOutlineRange ActiveOutlineRange { get; }
Public ReadOnly Property ActiveOutlineRange As IOutlineRange
    Get
public:
virtual property IOutlineRange^ ActiveOutlineRange {
    IOutlineRange^ get () sealed;
}
abstract ActiveOutlineRange : IOutlineRange with get
override ActiveOutlineRange : IOutlineRange with get

Property Value

Type: IOutlineRange

Implements

ISyntaxEditActiveOutlineRange
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.AllowDrop Property

SyntaxEditAllowDrop Property
Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowDrop { get; set; }
Public Overrides Property AllowDrop As Boolean
    Get
    Set
public:
virtual property bool AllowDrop {
    bool get () override;
    void set (bool value) override;
}
abstract AllowDrop : bool with get, set
override AllowDrop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.AutoCorrectDelimiters Property

SyntaxEditAutoCorrectDelimiters Property
Gets or sets an array of chars that used as word delimiters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] AutoCorrectDelimiters { get; set; }
Public Overridable Property AutoCorrectDelimiters As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ AutoCorrectDelimiters {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract AutoCorrectDelimiters : char[] with get, set
override AutoCorrectDelimiters : char[] with get, set

Property Value

Type: Char

Implements

IAutoCorrectAutoCorrectDelimiters
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.AutoCorrection Property

SyntaxEditAutoCorrection Property
Gets or sets a boolean value indicating whether to auto correct words being typed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AutoCorrection { get; set; }
Public Overridable Property AutoCorrection As Boolean
    Get
    Set
public:
virtual property bool AutoCorrection {
    bool get ();
    void set (bool value);
}
abstract AutoCorrection : bool with get, set
override AutoCorrection : bool with get, set

Property Value

Type: Boolean

Implements

IAutoCorrectAutoCorrection
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.BorderColor Property

SyntaxEditBorderColor Property
Gets or sets the border color for the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BorderColor { get; set; }
Public Overridable Property BorderColor As Color
    Get
    Set
public:
virtual property Color BorderColor {
    Color get ();
    void set (Color value);
}
abstract BorderColor : Color with get, set
override BorderColor : Color with get, set

Property Value

Type: Color

Implements

ISyntaxEditBorderColor
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.BorderStyle Property

SyntaxEditBorderStyle Property
Gets or sets the border style for the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual EditBorderStyle BorderStyle { get; set; }
Public Overridable Property BorderStyle As EditBorderStyle
    Get
    Set
public:
virtual property EditBorderStyle BorderStyle {
    EditBorderStyle get ();
    void set (EditBorderStyle value);
}
abstract BorderStyle : EditBorderStyle with get, set
override BorderStyle : EditBorderStyle with get, set

Property Value

Type: EditBorderStyle

Implements

ISyntaxEditBorderStyle
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Braces Property

SyntaxEditBraces Property
Represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IEditBraceMatching Braces { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Braces As IEditBraceMatching
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IEditBraceMatching^ Braces {
    IEditBraceMatching^ get ();
    void set (IEditBraceMatching^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Braces : IEditBraceMatching with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Braces : IEditBraceMatching with get, set

Property Value

Type: IEditBraceMatching

Implements

ISyntaxEditBraces
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CharsInWidth Property

SyntaxEditCharsInWidth Property
Returns number of characters painted with current font that will fit into control's client area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CharsInWidth { get; }
Public Overridable ReadOnly Property CharsInWidth As Integer
    Get
public:
virtual property int CharsInWidth {
    int get ();
}
abstract CharsInWidth : int with get
override CharsInWidth : int with get

Return Value

Type: Int32
Number of characters that can fit in.

Implements

ISyntaxEditCharsInWidth
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ClientArea Property

SyntaxEditClientArea Property
Gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle ClientArea { get; }
Public Overridable ReadOnly Property ClientArea As Rectangle
    Get
public:
virtual property Rectangle ClientArea {
    Rectangle get ();
}
abstract ClientArea : Rectangle with get
override ClientArea : Rectangle with get

Property Value

Type: Rectangle

Implements

ISyntaxEditClientArea
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ClientHeight Property

SyntaxEditClientHeight Property
Gets the width of the client area of the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ClientHeight { get; }
Public Overridable ReadOnly Property ClientHeight As Integer
    Get
public:
virtual property int ClientHeight {
    int get ();
}
abstract ClientHeight : int with get
override ClientHeight : int with get

Property Value

Type: Int32

Implements

ISyntaxEditClientHeight
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ClientRect Property

SyntaxEditClientRect Property
Gets the rectangle that represents the client area of the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle ClientRect { get; }
Public Overridable ReadOnly Property ClientRect As Rectangle
    Get
public:
virtual property Rectangle ClientRect {
    Rectangle get ();
}
abstract ClientRect : Rectangle with get
override ClientRect : Rectangle with get

Property Value

Type: Rectangle

Implements

ISyntaxEditClientRect
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ClientWidth Property

SyntaxEditClientWidth Property
Gets the width of the client area of the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ClientWidth { get; }
Public Overridable ReadOnly Property ClientWidth As Integer
    Get
public:
virtual property int ClientWidth {
    int get ();
}
abstract ClientWidth : int with get
override ClientWidth : int with get

Property Value

Type: Int32

Implements

ISyntaxEditClientWidth
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CodeCompletionBox Property

SyntaxEditCodeCompletionBox Property
Represents object that specifies a popup window that contains code completion information presented in the form of list.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionBox CodeCompletionBox { get; }
Public Overridable ReadOnly Property CodeCompletionBox As ICodeCompletionBox
    Get
public:
virtual property ICodeCompletionBox^ CodeCompletionBox {
    ICodeCompletionBox^ get ();
}
abstract CodeCompletionBox : ICodeCompletionBox with get
override CodeCompletionBox : ICodeCompletionBox with get

Property Value

Type: ICodeCompletionBox

Implements

ICodeCompletionCodeCompletionBox
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CodeCompletionButton Property

SyntaxEditCodeCompletionButton Property
Represents object that specifies a popup window that contains code completion information presented in the form of list.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionButton CodeCompletionButton { get; }
Public Overridable ReadOnly Property CodeCompletionButton As ICodeCompletionButton
    Get
public:
virtual property ICodeCompletionButton^ CodeCompletionButton {
    ICodeCompletionButton^ get ();
}
abstract CodeCompletionButton : ICodeCompletionButton with get
override CodeCompletionButton : ICodeCompletionButton with get

Property Value

Type: ICodeCompletionButton
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CodeCompletionChars Property

SyntaxEditCodeCompletionChars Property
Represents a collection of characters that initializes a code completion procedure when typing in the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] CodeCompletionChars { get; set; }
Public Overridable Property CodeCompletionChars As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ CodeCompletionChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract CodeCompletionChars : char[] with get, set
override CodeCompletionChars : char[] with get, set

Property Value

Type: Char

Implements

ICodeCompletionCodeCompletionChars
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CodeCompletionHint Property

SyntaxEditCodeCompletionHint Property
Represents object that specifies a popup window that contains code completion information presented in the form of the tooltip.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionHint CodeCompletionHint { get; }
Public Overridable ReadOnly Property CodeCompletionHint As ICodeCompletionHint
    Get
public:
virtual property ICodeCompletionHint^ CodeCompletionHint {
    ICodeCompletionHint^ get ();
}
abstract CodeCompletionHint : ICodeCompletionHint with get
override CodeCompletionHint : ICodeCompletionHint with get

Property Value

Type: ICodeCompletionHint

Implements

ICodeCompletionCodeCompletionHint
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CodeCompletionMode Property

SyntaxEditCodeCompletionMode Property
Gets or sets code completion box mode.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionMode CodeCompletionMode { get; set; }
Public Property CodeCompletionMode As CodeCompletionMode
    Get
    Set
public:
virtual property CodeCompletionMode CodeCompletionMode {
    CodeCompletionMode get () sealed;
    void set (CodeCompletionMode value) sealed;
}
abstract CodeCompletionMode : CodeCompletionMode with get, set
override CodeCompletionMode : CodeCompletionMode with get, set

Property Value

Type: CodeCompletionMode

Implements

ICodeCompletionCodeCompletionMode
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CurrentBlockRange Property

SyntaxEditCurrentBlockRange Property
Gets currently highlighted block range.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRange CurrentBlockRange { get; }
Public ReadOnly Property CurrentBlockRange As IRange
    Get
public:
virtual property IRange^ CurrentBlockRange {
    IRange^ get () sealed;
}
abstract CurrentBlockRange : IRange with get
override CurrentBlockRange : IRange with get

Property Value

Type: IRange

Implements

ICaretCurrentBlockRange
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Cursor Property

SyntaxEditCursor Property
Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Cursor Cursor { get; set; }
Public Overrides Property Cursor As Cursor
    Get
    Set
public:
virtual property Cursor^ Cursor {
    Cursor^ get () override;
    void set (Cursor^ value) override;
}
abstract Cursor : Cursor with get, set
override Cursor : Cursor with get, set

Return Value

Type: Cursor
A Cursor that represents the cursor to display when the mouse pointer is over the control.
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DefaultMenu Property

SyntaxEditDefaultMenu Property
Gets or sets default context menu for the editor control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContextMenuStrip DefaultMenu { get; set; }
Public Property DefaultMenu As ContextMenuStrip
    Get
    Set
public:
property ContextMenuStrip^ DefaultMenu {
    ContextMenuStrip^ get ();
    void set (ContextMenuStrip^ value);
}
member DefaultMenu : ContextMenuStrip with get, set

Property Value

Type: ContextMenuStrip
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DisplayLines Property

SyntaxEditDisplayLines Property
Represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IDisplayStrings DisplayLines { get; }
Public Overridable ReadOnly Property DisplayLines As IDisplayStrings
    Get
public:
virtual property IDisplayStrings^ DisplayLines {
    IDisplayStrings^ get ();
}
abstract DisplayLines : IDisplayStrings with get
override DisplayLines : IDisplayStrings with get

Property Value

Type: IDisplayStrings

Implements

ISyntaxEditDisplayLines
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.EditMargin Property

SyntaxEditEditMargin Property
Represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IMargin EditMargin { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property EditMargin As IMargin
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IMargin^ EditMargin {
    IMargin^ get ();
    void set (IMargin^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract EditMargin : IMargin with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override EditMargin : IMargin with get, set

Property Value

Type: IMargin

Implements

ISyntaxEditEditMargin
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.EffectiveVisualTheme Property

SyntaxEditEffectiveVisualTheme Property
Gets current visual theme.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IVisualTheme EffectiveVisualTheme { get; }
Public ReadOnly Property EffectiveVisualTheme As IVisualTheme
    Get
public:
virtual property IVisualTheme^ EffectiveVisualTheme {
    IVisualTheme^ get () sealed;
}
abstract EffectiveVisualTheme : IVisualTheme with get
override EffectiveVisualTheme : IVisualTheme with get

Property Value

Type: IVisualTheme

Implements

ISyntaxEditEffectiveVisualTheme
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.EventHandlers Property

SyntaxEditEventHandlers Property
Represents object that holds EventHandlers containing list of keys with attached actions.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEventHandlers EventHandlers { get; }
Public ReadOnly Property EventHandlers As IEventHandlers
    Get
public:
virtual property IEventHandlers^ EventHandlers {
    IEventHandlers^ get () sealed;
}
abstract EventHandlers : IEventHandlers with get
override EventHandlers : IEventHandlers with get

Property Value

Type: IEventHandlers

Implements

ISyntaxEditEventHandlers
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.FirstSearch Property

SyntaxEditFirstSearch Property
Gets or sets a value indicating whether control launches text search at first.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FirstSearch { get; set; }
Public Overridable Property FirstSearch As Boolean
    Get
    Set
public:
virtual property bool FirstSearch {
    bool get ();
    void set (bool value);
}
abstract FirstSearch : bool with get, set
override FirstSearch : bool with get, set

Property Value

Type: Boolean

Implements

ISearchFirstSearch
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Font Property

SyntaxEditFont Property
Gets or sets the font of the text displayed by the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Font Font { get; set; }
Public Overrides Property Font As Font
    Get
    Set
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
abstract Font : Font with get, set
override Font : Font with get, set

Return Value

Type: Font
The Font to apply to the text displayed by the control. The default is the value of the DefaultFont property.

Implements

IControlFont
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GotoLineDialog Property

SyntaxEditGotoLineDialog Property
Gets or sets a dialog prompting for index of the line you need to locate.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IGotoLineDialog GotoLineDialog { get; set; }
Public Overridable Property GotoLineDialog As IGotoLineDialog
    Get
    Set
public:
virtual property IGotoLineDialog^ GotoLineDialog {
    IGotoLineDialog^ get ();
    void set (IGotoLineDialog^ value);
}
abstract GotoLineDialog : IGotoLineDialog with get, set
override GotoLineDialog : IGotoLineDialog with get, set

Property Value

Type: IGotoLineDialog

Implements

ISearchGotoLineDialog
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Gutter Property

SyntaxEditGutter Property
Represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IGutter Gutter { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Gutter As IGutter
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IGutter^ Gutter {
    IGutter^ get ();
    void set (IGutter^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Gutter : IGutter with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Gutter : IGutter with get, set

Property Value

Type: IGutter

Implements

ISyntaxEditGutter
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HideCaret Property

SyntaxEditHideCaret Property
Gets or sets a value indicating whether the control should display caret when it has input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HideCaret { get; set; }
Public Overridable Property HideCaret As Boolean
    Get
    Set
public:
virtual property bool HideCaret {
    bool get ();
    void set (bool value);
}
abstract HideCaret : bool with get, set
override HideCaret : bool with get, set

Property Value

Type: Boolean

Implements

ICaretHideCaret
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HighlightCurrentBlock Property

SyntaxEditHighlightCurrentBlock Property
Specifies that edit control should highlight current block.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HighlightCurrentBlock { get; set; }
Public Overridable Property HighlightCurrentBlock As Boolean
    Get
    Set
public:
virtual property bool HighlightCurrentBlock {
    bool get ();
    void set (bool value);
}
abstract HighlightCurrentBlock : bool with get, set
override HighlightCurrentBlock : bool with get, set

Property Value

Type: Boolean

Implements

ICaretHighlightCurrentBlock
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HighlightMatchingBlocks Property

SyntaxEditHighlightMatchingBlocks Property
Specifies that edit control should highlight begin/end blocks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HighlightMatchingBlocks { get; set; }
Public Overridable Property HighlightMatchingBlocks As Boolean
    Get
    Set
public:
virtual property bool HighlightMatchingBlocks {
    bool get ();
    void set (bool value);
}
abstract HighlightMatchingBlocks : bool with get, set
override HighlightMatchingBlocks : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxEditHighlightMatchingBlocks
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HighlightReferences Property

SyntaxEditHighlightReferences Property
Specifies that edit control should highlight found references.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HighlightReferences { get; set; }
Public Overridable Property HighlightReferences As Boolean
    Get
    Set
public:
virtual property bool HighlightReferences {
    bool get ();
    void set (bool value);
}
abstract HighlightReferences : bool with get, set
override HighlightReferences : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxEditHighlightReferences
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HighlightSearchResults Property

SyntaxEditHighlightSearchResults Property
Indicates whether search results are highlighted while the search dialog is open.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HighlightSearchResults { get; set; }
Public Property HighlightSearchResults As Boolean
    Get
    Set
public:
virtual property bool HighlightSearchResults {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract HighlightSearchResults : bool with get, set
override HighlightSearchResults : bool with get, set

Property Value

Type: Boolean

Implements

ISearchHighlightSearchResults
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HorzSplitEdit Property

SyntaxEditHorzSplitEdit Property
Represents horizontal split view control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxEdit HorzSplitEdit { get; }
Public Overridable ReadOnly Property HorzSplitEdit As ISyntaxEdit
    Get
public:
virtual property ISyntaxEdit^ HorzSplitEdit {
    ISyntaxEdit^ get ();
}
abstract HorzSplitEdit : ISyntaxEdit with get
override HorzSplitEdit : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit

Implements

ISplitViewHorzSplitEdit
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HorzSplitter Property

SyntaxEditHorzSplitter Property
Represents a horizontal Splitter control allowing to split Edit content horizontally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Splitter HorzSplitter { get; }
Public Overridable ReadOnly Property HorzSplitter As Splitter
    Get
public:
virtual property Splitter^ HorzSplitter {
    Splitter^ get ();
}
abstract HorzSplitter : Splitter with get
override HorzSplitter : Splitter with get

Property Value

Type: Splitter

Implements

ISplitViewHorzSplitter
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HyperText Property

SyntaxEditHyperText Property
Represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IEditHyperText HyperText { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property HyperText As IEditHyperText
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IEditHyperText^ HyperText {
    IEditHyperText^ get ();
    void set (IEditHyperText^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract HyperText : IEditHyperText with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override HyperText : IEditHyperText with get, set

Property Value

Type: IEditHyperText

Implements

ISyntaxEditHyperText
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.IncrementalSearchString Property

SyntaxEditIncrementalSearchString Property
Return text to search if class is in incremental search state; otherwise return empty string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string IncrementalSearchString { get; }
Public Overridable ReadOnly Property IncrementalSearchString As String
    Get
public:
virtual property String^ IncrementalSearchString {
    String^ get ();
}
abstract IncrementalSearchString : string with get
override IncrementalSearchString : string with get

Property Value

Type: String

Implements

ISearchIncrementalSearchString
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.InCycledSearch Property

SyntaxEditInCycledSearch Property
Indicates whether control is in incremental search state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InCycledSearch { get; set; }
Public Overridable Property InCycledSearch As Boolean
    Get
    Set
public:
virtual property bool InCycledSearch {
    bool get ();
    void set (bool value);
}
abstract InCycledSearch : bool with get, set
override InCycledSearch : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.IndentOptions Property

SyntaxEditIndentOptions Property
Gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IndentOptions IndentOptions { get; set; }
Public Overridable Property IndentOptions As IndentOptions
    Get
    Set
public:
virtual property IndentOptions IndentOptions {
    IndentOptions get ();
    void set (IndentOptions value);
}
abstract IndentOptions : IndentOptions with get, set
override IndentOptions : IndentOptions with get, set

Property Value

Type: IndentOptions

Implements

IEditIndentOptions
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.InIncrementalSearch Property

SyntaxEditInIncrementalSearch Property
Indicates whether control is in incremental search state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InIncrementalSearch { get; }
Public Overridable ReadOnly Property InIncrementalSearch As Boolean
    Get
public:
virtual property bool InIncrementalSearch {
    bool get ();
}
abstract InIncrementalSearch : bool with get
override InIncrementalSearch : bool with get

Property Value

Type: Boolean

Implements

ISearchInIncrementalSearch
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.InnerTextSource Property

SyntaxEditInnerTextSource Property
Gets inner text source

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ITextSource InnerTextSource { get; }
Public ReadOnly Property InnerTextSource As ITextSource
    Get
public:
property ITextSource^ InnerTextSource {
    ITextSource^ get ();
}
member InnerTextSource : ITextSource with get

Property Value

Type: ITextSource
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.IsCodeCompletionWindowFocused Property

SyntaxEditIsCodeCompletionWindowFocused Property
Indicates whether ICodeCompletionWindow has focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsCodeCompletionWindowFocused { get; }
Public Overridable ReadOnly Property IsCodeCompletionWindowFocused As Boolean
    Get
public:
virtual property bool IsCodeCompletionWindowFocused {
    bool get ();
}
abstract IsCodeCompletionWindowFocused : bool with get
override IsCodeCompletionWindowFocused : bool with get

Return Value

Type: Boolean
True if succeed; otherwise, false.

Implements

ICodeCompletionIsCodeCompletionWindowFocused
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.IsSearchFocused Property

SyntaxEditIsSearchFocused Property
Gets a boolean value indicating whether search dialog box has input focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsSearchFocused { get; }
Public Overridable ReadOnly Property IsSearchFocused As Boolean
    Get
public:
virtual property bool IsSearchFocused {
    bool get ();
}
abstract IsSearchFocused : bool with get
override IsSearchFocused : bool with get

Property Value

Type: Boolean

Implements

ISyntaxEditIsSearchFocused
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.KeepCaretOnLostFocus Property

SyntaxEditKeepCaretOnLostFocus Property
Keeps caret in visible state even Edit control lost focus.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool KeepCaretOnLostFocus { get; set; }
Public Overridable Property KeepCaretOnLostFocus As Boolean
    Get
    Set
public:
virtual property bool KeepCaretOnLostFocus {
    bool get ();
    void set (bool value);
}
abstract KeepCaretOnLostFocus : bool with get, set
override KeepCaretOnLostFocus : bool with get, set

Property Value

Type: Boolean

Implements

ICaretKeepCaretOnLostFocus
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.KeyList Property

SyntaxEditKeyList Property
Represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IKeyList KeyList { get; }
Public Overridable ReadOnly Property KeyList As IKeyList
    Get
public:
virtual property IKeyList^ KeyList {
    IKeyList^ get ();
}
abstract KeyList : IKeyList with get
override KeyList : IKeyList with get

Property Value

Type: IKeyList

Implements

ISyntaxEditKeyList
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Lexer Property

SyntaxEditLexer Property
Gets or sets object that can make lexical analysis for the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexer Lexer { get; set; }
Public Overridable Property Lexer As ILexer
    Get
    Set
public:
virtual property ILexer^ Lexer {
    ILexer^ get ();
    void set (ILexer^ value);
}
abstract Lexer : ILexer with get, set
override Lexer : ILexer with get, set

Property Value

Type: ILexer

Implements

ISyntaxEditLexer
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Lines Property

SyntaxEditLines Property
Represents object that implements ITextStrings interface containing collection of strings determining control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ITextStrings Lines { get; set; }
Public Overridable Property Lines As ITextStrings
    Get
    Set
public:
virtual property ITextStrings^ Lines {
    ITextStrings^ get ();
    void set (ITextStrings^ value);
}
abstract Lines : ITextStrings with get, set
override Lines : ITextStrings with get, set

Property Value

Type: ITextStrings

Implements

ISyntaxEditLines
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LineSeparator Property

SyntaxEditLineSeparator Property
Represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual ILineSeparator LineSeparator { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property LineSeparator As ILineSeparator
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property ILineSeparator^ LineSeparator {
    ILineSeparator^ get ();
    void set (ILineSeparator^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract LineSeparator : ILineSeparator with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override LineSeparator : ILineSeparator with get, set

Property Value

Type: ILineSeparator

Implements

ISyntaxEditLineSeparator
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LinesInHeight Property

SyntaxEditLinesInHeight Property
Determines how many lines can fit into control's client area.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LinesInHeight { get; }
Public Overridable ReadOnly Property LinesInHeight As Integer
    Get
public:
virtual property int LinesInHeight {
    int get ();
}
abstract LinesInHeight : int with get
override LinesInHeight : int with get

Return Value

Type: Int32
Number of lines that can fit in.

Implements

ISyntaxEditLinesInHeight
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LineSpace Property

SyntaxEditLineSpace Property
Gets or sets line space between individual lines in the Edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LineSpace { get; set; }
Public Overridable Property LineSpace As Integer
    Get
    Set
public:
virtual property int LineSpace {
    int get ();
    void set (int value);
}
abstract LineSpace : int with get, set
override LineSpace : int with get, set

Property Value

Type: Int32

Implements

ISyntaxEditLineSpace
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LineStyles Property

SyntaxEditLineStyles Property
Represents an object that implements IEditLineStyles interface holding collection of IEditLineStyle objects each of them determines particular style of the line in the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute("Alternet.Design.LineStylesConverter, Alternet.Editor.Design.v7")]
public virtual IEditLineStyles LineStyles { get; set; }
<TypeConverterAttribute("Alternet.Design.LineStylesConverter, Alternet.Editor.Design.v7")>
Public Overridable Property LineStyles As IEditLineStyles
    Get
    Set
public:
[TypeConverterAttribute(L"Alternet.Design.LineStylesConverter, Alternet.Editor.Design.v7")]
virtual property IEditLineStyles^ LineStyles {
    IEditLineStyles^ get ();
    void set (IEditLineStyles^ value);
}
[<TypeConverterAttribute("Alternet.Design.LineStylesConverter, Alternet.Editor.Design.v7")>]
abstract LineStyles : IEditLineStyles with get, set
[<TypeConverterAttribute("Alternet.Design.LineStylesConverter, Alternet.Editor.Design.v7")>]
override LineStyles : IEditLineStyles with get, set

Property Value

Type: IEditLineStyles

Implements

ISyntaxEditLineStyles
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.LineTerminator Property

SyntaxEditLineTerminator Property
Gets or sets a string value that terminates line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string LineTerminator { get; set; }
Public Overridable Property LineTerminator As String
    Get
    Set
public:
virtual property String^ LineTerminator {
    String^ get ();
    void set (String^ value);
}
abstract LineTerminator : string with get, set
override LineTerminator : string with get, set

Property Value

Type: String

Implements

ITextExportLineTerminator
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MacroRecording Property

SyntaxEditMacroRecording Property
Gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MacroRecording { get; set; }
Public Overridable Property MacroRecording As Boolean
    Get
    Set
public:
virtual property bool MacroRecording {
    bool get ();
    void set (bool value);
}
abstract MacroRecording : bool with get, set
override MacroRecording : bool with get, set

Property Value

Type: Boolean

Implements

IRecordPlayBackMacroRecording
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MacroRecords Property

SyntaxEditMacroRecords Property
Represents an array containing keyboard commands.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IMacroKeyList MacroRecords { get; set; }
Public Overridable Property MacroRecords As IMacroKeyList
    Get
    Set
public:
virtual property IMacroKeyList^ MacroRecords {
    IMacroKeyList^ get ();
    void set (IMacroKeyList^ value);
}
abstract MacroRecords : IMacroKeyList with get, set
override MacroRecords : IMacroKeyList with get, set

Property Value

Type: IMacroKeyList

Implements

IRecordPlayBackMacroRecords
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MacroSuspendend Property

SyntaxEditMacroSuspendend Property
Gets or sets a boolean value indicating whether recording is suspended.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MacroSuspendend { get; set; }
Public Overridable Property MacroSuspendend As Boolean
    Get
    Set
public:
virtual property bool MacroSuspendend {
    bool get ();
    void set (bool value);
}
abstract MacroSuspendend : bool with get, set
override MacroSuspendend : bool with get, set

Property Value

Type: Boolean

Implements

IRecordPlayBackMacroSuspendend
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.MaxLength Property

SyntaxEditMaxLength Property
Specifies the maximum number of characters that can be entered into the edit control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MaxLength { get; set; }
Public Overridable Property MaxLength As Integer
    Get
    Set
public:
virtual property int MaxLength {
    int get ();
    void set (int value);
}
abstract MaxLength : int with get, set
override MaxLength : int with get, set

Property Value

Type: Int32

Implements

IEditMaxLength
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Modified Property

SyntaxEditModified Property
Gets or sets a value indicating whether the control's text content is modified.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Modified { get; set; }
Public Overridable Property Modified As Boolean
    Get
    Set
public:
virtual property bool Modified {
    bool get ();
    void set (bool value);
}
abstract Modified : bool with get, set
override Modified : bool with get, set

Property Value

Type: Boolean

Implements

IEditModified
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.NavigateOptions Property

SyntaxEditNavigateOptions Property
Gets or sets navigating options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual NavigateOptions NavigateOptions { get; set; }
Public Overridable Property NavigateOptions As NavigateOptions
    Get
    Set
public:
virtual property NavigateOptions NavigateOptions {
    NavigateOptions get ();
    void set (NavigateOptions value);
}
abstract NavigateOptions : NavigateOptions with get, set
override NavigateOptions : NavigateOptions with get, set

Property Value

Type: NavigateOptions

Implements

INavigateNavigateOptions
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.OpenSharedEditorFunc Property

SyntaxEditOpenSharedEditorFunc Property
When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Func<string, ISyntaxEdit> OpenSharedEditorFunc { get; set; }
Public Overridable Property OpenSharedEditorFunc As Func(Of String, ISyntaxEdit)
    Get
    Set
public:
virtual property Func<String^, ISyntaxEdit^>^ OpenSharedEditorFunc {
    Func<String^, ISyntaxEdit^>^ get ();
    void set (Func<String^, ISyntaxEdit^>^ value);
}
abstract OpenSharedEditorFunc : Func<string, ISyntaxEdit> with get, set
override OpenSharedEditorFunc : Func<string, ISyntaxEdit> with get, set

Property Value

Type: FuncString, ISyntaxEdit

Implements

ISyntaxEditOpenSharedEditorFunc
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Outlining Property

SyntaxEditOutlining Property
Represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IOutlining Outlining { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Outlining As IOutlining
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IOutlining^ Outlining {
    IOutlining^ get ();
    void set (IOutlining^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Outlining : IOutlining with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Outlining : IOutlining with get, set

Property Value

Type: IOutlining

Implements

ISyntaxEditOutlining
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Overwrite Property

SyntaxEditOverwrite Property
Gets or sets a value indicating whether the inserted text overwrites existing text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Overwrite { get; set; }
Public Overridable Property Overwrite As Boolean
    Get
    Set
public:
virtual property bool Overwrite {
    bool get ();
    void set (bool value);
}
abstract Overwrite : bool with get, set
override Overwrite : bool with get, set

Property Value

Type: Boolean

Implements

IEditOverwrite
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Pages Property

SyntaxEditPages Property
Represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IEditPages Pages { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Pages As IEditPages
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IEditPages^ Pages {
    IEditPages^ get ();
    void set (IEditPages^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Pages : IEditPages with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Pages : IEditPages with get, set

Property Value

Type: IEditPages

Implements

ISyntaxEditPages
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Painter Property

SyntaxEditPainter Property
Represents an object that implements IPainter interface used to draw control's text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPainter Painter { get; }
Public Overridable ReadOnly Property Painter As IPainter
    Get
public:
virtual property IPainter^ Painter {
    IPainter^ get ();
}
abstract Painter : IPainter with get
override Painter : IPainter with get

Property Value

Type: IPainter

Implements

ISyntaxEditPainter
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Position Property

SyntaxEditPosition Property
Gets or sets current position within the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Position { get; set; }
Public Overridable Property Position As Point
    Get
    Set
public:
virtual property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set
override Position : Point with get, set

Property Value

Type: Point

Implements

INavigatePosition
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.PrevPosition Property

SyntaxEditPrevPosition Property
Gets previous position within the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point PrevPosition { get; }
Public Overridable ReadOnly Property PrevPosition As Point
    Get
public:
virtual property Point PrevPosition {
    Point get ();
}
abstract PrevPosition : Point with get
override PrevPosition : Point with get

Property Value

Type: Point

Implements

INavigatePrevPosition
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Printing Property

SyntaxEditPrinting Property
Represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IPrinting Printing { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Printing As IPrinting
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IPrinting^ Printing {
    IPrinting^ get ();
    void set (IPrinting^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Printing : IPrinting with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Printing : IPrinting with get, set

Property Value

Type: IPrinting

Implements

ISyntaxEditPrinting
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ReadOnly Property

SyntaxEditReadOnly Property
Gets or sets a value indicating whether the control's content is read-only.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReadOnly { get; set; }
Public Overridable Property ReadOnly As Boolean
    Get
    Set
public:
virtual property bool ReadOnly {
    bool get ();
    void set (bool value);
}
abstract ReadOnly : bool with get, set
override ReadOnly : bool with get, set

Property Value

Type: Boolean

Implements

IEditReadOnly
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Scrolling Property

SyntaxEditScrolling Property
Represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IScrolling Scrolling { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Scrolling As IScrolling
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IScrolling^ Scrolling {
    IScrolling^ get ();
    void set (IScrolling^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Scrolling : IScrolling with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Scrolling : IScrolling with get, set

Property Value

Type: IScrolling

Implements

ISyntaxEditScrolling
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SearchDialog Property

SyntaxEditSearchDialog Property
Gets or sets a dialog box allowing to search for the text or replace it.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISearchDialog SearchDialog { get; set; }
Public Overridable Property SearchDialog As ISearchDialog
    Get
    Set
public:
virtual property ISearchDialog^ SearchDialog {
    ISearchDialog^ get ();
    void set (ISearchDialog^ value);
}
abstract SearchDialog : ISearchDialog with get, set
override SearchDialog : ISearchDialog with get, set

Property Value

Type: ISearchDialog

Implements

ISearchSearchDialog
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SearchDialogAppearance Property

SyntaxEditSearchDialogAppearance Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchDialogAppearance SearchDialogAppearance { get; set; }
Public Property SearchDialogAppearance As SearchDialogAppearance
    Get
    Set
public:
virtual property SearchDialogAppearance SearchDialogAppearance {
    SearchDialogAppearance get () sealed;
    void set (SearchDialogAppearance value) sealed;
}
abstract SearchDialogAppearance : SearchDialogAppearance with get, set
override SearchDialogAppearance : SearchDialogAppearance with get, set

Property Value

Type: SearchDialogAppearance

Implements

ISyntaxEditSearchDialogAppearance
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SearchGlobal Property

SyntaxEditSearchGlobal Property
Gets or sets a value indicating whether search should be global.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SearchGlobal { get; set; }
Public Property SearchGlobal As Boolean
    Get
    Set
public:
virtual property bool SearchGlobal {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SearchGlobal : bool with get, set
override SearchGlobal : bool with get, set

Property Value

Type: Boolean

Implements

ISearchSearchGlobal
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SearchLen Property

SyntaxEditSearchLen Property
Represents length of the last found text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int SearchLen { get; }
Public Overridable ReadOnly Property SearchLen As Integer
    Get
public:
virtual property int SearchLen {
    int get ();
}
abstract SearchLen : int with get
override SearchLen : int with get

Property Value

Type: Int32

Implements

ISearchSearchLen
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SearchOptions Property

SyntaxEditSearchOptions Property
Gets or sets a value that defines search and replace options.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SearchOptions SearchOptions { get; set; }
Public Overridable Property SearchOptions As SearchOptions
    Get
    Set
public:
virtual property SearchOptions SearchOptions {
    SearchOptions get ();
    void set (SearchOptions value);
}
abstract SearchOptions : SearchOptions with get, set
override SearchOptions : SearchOptions with get, set

Property Value

Type: SearchOptions

Implements

ISearchSearchOptions
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SearchPos Property

SyntaxEditSearchPos Property
Gets or sets a value that represents position of the last found text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point SearchPos { get; set; }
Public Overridable Property SearchPos As Point
    Get
    Set
public:
virtual property Point SearchPos {
    Point get ();
    void set (Point value);
}
abstract SearchPos : Point with get, set
override SearchPos : Point with get, set

Property Value

Type: Point

Implements

ISearchSearchPos
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Selection Property

SyntaxEditSelection Property
Represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual ISelection Selection { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Selection As ISelection
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property ISelection^ Selection {
    ISelection^ get ();
    void set (ISelection^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Selection : ISelection with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Selection : ISelection with get, set

Property Value

Type: ISelection

Implements

ISyntaxEditSelection
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SingleLineMode Property

SyntaxEditSingleLineMode Property
Gets or sets a value indicating whether the control accepts only one line of the text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SingleLineMode { get; set; }
Public Overridable Property SingleLineMode As Boolean
    Get
    Set
public:
virtual property bool SingleLineMode {
    bool get ();
    void set (bool value);
}
abstract SingleLineMode : bool with get, set
override SingleLineMode : bool with get, set

Property Value

Type: Boolean

Implements

IEditSingleLineMode
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Source Property

SyntaxEditSource Property
Gets or sets an object that implements ITextSource interface containing an actual string data displayed by the control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ITextSource Source { get; set; }
Public Overridable Property Source As ITextSource
    Get
    Set
public:
virtual property ITextSource^ Source {
    ITextSource^ get ();
    void set (ITextSource^ value);
}
abstract Source : ITextSource with get, set
override Source : ITextSource with get, set

Property Value

Type: ITextSource

Implements

ISyntaxEditSource
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Spelling Property

SyntaxEditSpelling Property
Represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IEditSpelling Spelling { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property Spelling As IEditSpelling
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IEditSpelling^ Spelling {
    IEditSpelling^ get ();
    void set (IEditSpelling^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract Spelling : IEditSpelling with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override Spelling : IEditSpelling with get, set

Property Value

Type: IEditSpelling

Implements

ISyntaxEditSpelling
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Strings Property

SyntaxEditStrings Property
Represents Lines property in the form of array of strings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(CollectionConverter))]
public string[] Strings { get; set; }
<TypeConverterAttribute(GetType(CollectionConverter))>
Public Property Strings As String()
    Get
    Set
public:
[TypeConverterAttribute(typeof(CollectionConverter))]
virtual property array<String^>^ Strings {
    array<String^>^ get () sealed;
    void set (array<String^>^ value) sealed;
}
[<TypeConverterAttribute(typeof(CollectionConverter))>]
abstract Strings : string[] with get, set
[<TypeConverterAttribute(typeof(CollectionConverter))>]
override Strings : string[] with get, set

Property Value

Type: String

Implements

ISyntaxEditStrings
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SyntaxPaint Property

SyntaxEditSyntaxPaint Property
Represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IEditSyntaxPaint SyntaxPaint { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property SyntaxPaint As IEditSyntaxPaint
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IEditSyntaxPaint^ SyntaxPaint {
    IEditSyntaxPaint^ get ();
    void set (IEditSyntaxPaint^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract SyntaxPaint : IEditSyntaxPaint with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override SyntaxPaint : IEditSyntaxPaint with get, set

Property Value

Type: IEditSyntaxPaint

Implements

ISyntaxEditSyntaxPaint
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Text Property

SyntaxEditText Property
Gets or sets the string collection as a single string with the individual lines delimited by carriage returns.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.Transparent Property

SyntaxEditTransparent Property
Gets or sets a boolean value that indicates whether Edit control should draw its background.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Transparent { get; set; }
Public Overridable Property Transparent As Boolean
    Get
    Set
public:
virtual property bool Transparent {
    bool get ();
    void set (bool value);
}
abstract Transparent : bool with get, set
override Transparent : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxEditTransparent
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UpdateCount Property

SyntaxEditUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UseDefaultMenu Property

SyntaxEditUseDefaultMenu Property
Indicates whether edit control should use built in popup menu.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UseDefaultMenu { get; set; }
Public Overridable Property UseDefaultMenu As Boolean
    Get
    Set
public:
virtual property bool UseDefaultMenu {
    bool get ();
    void set (bool value);
}
abstract UseDefaultMenu : bool with get, set
override UseDefaultMenu : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxEditUseDefaultMenu
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.VertSplitEdit Property

SyntaxEditVertSplitEdit Property
Represents an vertical split view control.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxEdit VertSplitEdit { get; }
Public Overridable ReadOnly Property VertSplitEdit As ISyntaxEdit
    Get
public:
virtual property ISyntaxEdit^ VertSplitEdit {
    ISyntaxEdit^ get ();
}
abstract VertSplitEdit : ISyntaxEdit with get
override VertSplitEdit : ISyntaxEdit with get

Property Value

Type: ISyntaxEdit

Implements

ISplitViewVertSplitEdit
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.VertSplitter Property

SyntaxEditVertSplitter Property
Represents a vertical Splitter control allowing to split Edit content vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Splitter VertSplitter { get; }
Public Overridable ReadOnly Property VertSplitter As Splitter
    Get
public:
virtual property Splitter^ VertSplitter {
    Splitter^ get ();
}
abstract VertSplitter : Splitter with get
override VertSplitter : Splitter with get

Property Value

Type: Splitter

Implements

ISplitViewVertSplitter
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.VisualTheme Property

SyntaxEditVisualTheme Property
Gets or sets visual theme for the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IVisualTheme VisualTheme { get; set; }
Public Property VisualTheme As IVisualTheme
    Get
    Set
public:
virtual property IVisualTheme^ VisualTheme {
    IVisualTheme^ get () sealed;
    void set (IVisualTheme^ value) sealed;
}
abstract VisualTheme : IVisualTheme with get, set
override VisualTheme : IVisualTheme with get, set

Property Value

Type: IVisualTheme

Implements

ISyntaxEditVisualTheme
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.VisualThemeType Property

SyntaxEditVisualThemeType Property
Gets or sets visual theme type for the editor.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualThemeType VisualThemeType { get; set; }
Public Property VisualThemeType As VisualThemeType
    Get
    Set
public:
virtual property VisualThemeType VisualThemeType {
    VisualThemeType get () sealed;
    void set (VisualThemeType value) sealed;
}
abstract VisualThemeType : VisualThemeType with get, set
override VisualThemeType : VisualThemeType with get, set

Property Value

Type: VisualThemeType

Implements

ISyntaxEditVisualThemeType
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.WhiteSpace Property

SyntaxEditWhiteSpace Property
Represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public virtual IWhiteSpace WhiteSpace { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Overridable Property WhiteSpace As IWhiteSpace
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
virtual property IWhiteSpace^ WhiteSpace {
    IWhiteSpace^ get ();
    void set (IWhiteSpace^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
abstract WhiteSpace : IWhiteSpace with get, set
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
override WhiteSpace : IWhiteSpace with get, set

Property Value

Type: IWhiteSpace

Implements

ISyntaxEditWhiteSpace
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.WordWrap Property

SyntaxEditWordWrap Property
Gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool WordWrap { get; set; }
Public Overridable Property WordWrap As Boolean
    Get
    Set
public:
virtual property bool WordWrap {
    bool get ();
    void set (bool value);
}
abstract WordWrap : bool with get, set
override WordWrap : bool with get, set

Property Value

Type: Boolean

Implements

IWordWrapWordWrap
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.WrapAtMargin Property

SyntaxEditWrapAtMargin Property
Gets or sets a value indicating whether control automatically wraps words at margin position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool WrapAtMargin { get; set; }
Public Overridable Property WrapAtMargin As Boolean
    Get
    Set
public:
virtual property bool WrapAtMargin {
    bool get ();
    void set (bool value);
}
abstract WrapAtMargin : bool with get, set
override WrapAtMargin : bool with get, set

Property Value

Type: Boolean

Implements

IWordWrapWrapAtMargin
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.WrapMargin Property

SyntaxEditWrapMargin Property
Gets position of the wrapping margin.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int WrapMargin { get; }
Public Overridable ReadOnly Property WrapMargin As Integer
    Get
public:
virtual property int WrapMargin {
    int get ();
}
abstract WrapMargin : int with get
override WrapMargin : int with get

Property Value

Type: Int32

Implements

IWordWrapWrapMargin
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit Events

SyntaxEdit Events

The SyntaxEdit type exposes the following members.

Events
 | Name | Description
Public event | AutoCorrect | Occurs when control tries to auto correct word being typed.
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckHyperText | Occurs when a control needs checking whether some string represents hypertext.
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when control draws its content.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawHeader | Occurs when header or footer part of each page is drawing.
Public event | DrawUserMargin | Occurs when user margin part of each line is drawing.
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | GutterClick | Occurs when the gutter part of Edit control is clicked.
Public event | GutterDblClick | Occurs when the gutter part of Edit control is double-clicked.
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HorizontalScroll | Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | JumpToUrl | Occurs when user attempts to jump to url.
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when modified state is changed.
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NeedCodeCompletion | Occurs when code completion window is to be displayed.
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintBackground | Occurs when Edit control should paint its background in transparent mode.
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PromptOnReplace | Occurs when replace dialog prompts on replace action.
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollButtonClick | Occurs when some scrolling button is clicked.
Public event | SelectionChanged | Occurs when selection bounds are changed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SourceChanged | Occurs when source changes.
Public event | SourceStateChanged | Occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc.
Public event | SplitHorz | Occurs when user splits Edit control horizontally.
Public event | SplitVert | Occurs when user splits Edit control vertically.
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | UndoEvent | Occurs when undo/redo operation performed.
Public event | UnsplitHorz | Occurs when horizontal split view is removed.
Public event | UnsplitVert | Occurs when vertical split view is removed.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VerticalScroll | Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking.
Top
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.AutoCorrect Event

SyntaxEditAutoCorrect Event
Occurs when control tries to auto correct word being typed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event AutoCorrectEvent AutoCorrect
Public Event AutoCorrect As AutoCorrectEvent
public:
virtual  event AutoCorrectEvent^ AutoCorrect {
    void add (AutoCorrectEvent^ value);
    void remove (AutoCorrectEvent^ value);
}
abstract AutoCorrect : IEvent<AutoCorrectEvent,
    AutoCorrectEventArgs>
override AutoCorrect : IEvent<AutoCorrectEvent,
    AutoCorrectEventArgs>

Value

Type: Alternet.EditorAutoCorrectEvent

Implements

IAutoCorrectAutoCorrect
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CheckHyperText Event

SyntaxEditCheckHyperText Event
Occurs when a control needs checking whether some string represents hypertext.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event HyperTextEvent CheckHyperText
Public Event CheckHyperText As HyperTextEvent
public:
 event HyperTextEvent^ CheckHyperText {
    void add (HyperTextEvent^ value);
    void remove (HyperTextEvent^ value);
}
member CheckHyperText : IEvent<HyperTextEvent,
    HyperTextEventArgs>

Value

Type: Alternet.Editor.TextSourceHyperTextEvent
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.CustomDraw Event

SyntaxEditCustomDraw Event
Occurs when control draws its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event CustomDrawEvent CustomDraw
Public Event CustomDraw As CustomDrawEvent
public:
 event CustomDrawEvent^ CustomDraw {
    void add (CustomDrawEvent^ value);
    void remove (CustomDrawEvent^ value);
}
member CustomDraw : IEvent<CustomDrawEvent,
    CustomDrawEventArgs>

Value

Type: Alternet.EditorCustomDrawEvent
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DrawHeader Event

SyntaxEditDrawHeader Event
Occurs when header or footer part of each page is drawing.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event DrawHeaderEvent DrawHeader
Public Event DrawHeader As DrawHeaderEvent
public:
 event DrawHeaderEvent^ DrawHeader {
    void add (DrawHeaderEvent^ value);
    void remove (DrawHeaderEvent^ value);
}
member DrawHeader : IEvent<DrawHeaderEvent,
    DrawHeaderEventArgs>

Value

Type: Alternet.EditorDrawHeaderEvent
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.DrawUserMargin Event

SyntaxEditDrawUserMargin Event
Occurs when user margin part of each line is drawing.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event DrawUserMarginEvent DrawUserMargin
Public Event DrawUserMargin As DrawUserMarginEvent
public:
 event DrawUserMarginEvent^ DrawUserMargin {
    void add (DrawUserMarginEvent^ value);
    void remove (DrawUserMarginEvent^ value);
}
member DrawUserMargin : IEvent<DrawUserMarginEvent,
    DrawUserMarginEventArgs>

Value

Type: Alternet.EditorDrawUserMarginEvent
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GutterClick Event

SyntaxEditGutterClick Event
Occurs when the gutter part of Edit control is clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler GutterClick
Public Event GutterClick As EventHandler
public:
 event EventHandler^ GutterClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GutterClick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.GutterDblClick Event

SyntaxEditGutterDblClick Event
Occurs when the gutter part of Edit control is double-clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler GutterDblClick
Public Event GutterDblClick As EventHandler
public:
 event EventHandler^ GutterDblClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GutterDblClick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.HorizontalScroll Event

SyntaxEditHorizontalScroll Event
Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler HorizontalScroll
Public Event HorizontalScroll As EventHandler
public:
 event EventHandler^ HorizontalScroll {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member HorizontalScroll : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.JumpToUrl Event

SyntaxEditJumpToUrl Event
Occurs when user attempts to jump to url.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event UrlJumpEvent JumpToUrl
Public Event JumpToUrl As UrlJumpEvent
public:
 event UrlJumpEvent^ JumpToUrl {
    void add (UrlJumpEvent^ value);
    void remove (UrlJumpEvent^ value);
}
member JumpToUrl : IEvent<UrlJumpEvent,
    UrlJumpEventArgs>

Value

Type: Alternet.EditorUrlJumpEvent
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ModifiedChanged Event

SyntaxEditModifiedChanged Event
Occurs when modified state is changed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ModifiedChanged
Public Event ModifiedChanged As EventHandler
public:
virtual  event EventHandler^ ModifiedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ModifiedChanged : IEvent<EventHandler,
    EventArgs>
override ModifiedChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISyntaxEditModifiedChanged
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.NeedCodeCompletion Event

SyntaxEditNeedCodeCompletion Event
Occurs when code completion window is to be displayed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event CodeCompletionEvent NeedCodeCompletion
Public Event NeedCodeCompletion As CodeCompletionEvent
public:
virtual  event CodeCompletionEvent^ NeedCodeCompletion {
    void add (CodeCompletionEvent^ value);
    void remove (CodeCompletionEvent^ value);
}
abstract NeedCodeCompletion : IEvent<CodeCompletionEvent,
    CodeCompletionArgs>
override NeedCodeCompletion : IEvent<CodeCompletionEvent,
    CodeCompletionArgs>

Value

Type: Alternet.SyntaxCodeCompletionEvent

Implements

ICodeCompletionNeedCodeCompletion
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.PaintBackground Event

SyntaxEditPaintBackground Event
Occurs when Edit control should paint its background in transparent mode.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PaintEventHandler PaintBackground
Public Event PaintBackground As PaintEventHandler
public:
virtual  event PaintEventHandler^ PaintBackground {
    void add (PaintEventHandler^ value);
    void remove (PaintEventHandler^ value);
}
abstract PaintBackground : IEvent<PaintEventHandler,
    PaintEventArgs>
override PaintBackground : IEvent<PaintEventHandler,
    PaintEventArgs>

Value

Type: System.Windows.FormsPaintEventHandler

Implements

ISyntaxEditPaintBackground
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.PromptOnReplace Event

SyntaxEditPromptOnReplace Event
Occurs when replace dialog prompts on replace action.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event PromptOnReplaceEvent PromptOnReplace
Public Event PromptOnReplace As PromptOnReplaceEvent
public:
virtual  event PromptOnReplaceEvent^ PromptOnReplace {
    void add (PromptOnReplaceEvent^ value);
    void remove (PromptOnReplaceEvent^ value);
}
abstract PromptOnReplace : IEvent<PromptOnReplaceEvent,
    PromptReplaceEventArgs>
override PromptOnReplace : IEvent<PromptOnReplaceEvent,
    PromptReplaceEventArgs>

Value

Type: Alternet.EditorPromptOnReplaceEvent

Implements

ISyntaxEditPromptOnReplace
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.ScrollButtonClick Event

SyntaxEditScrollButtonClick Event
Occurs when some scrolling button is clicked.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScrollButtonClick
Public Event ScrollButtonClick As EventHandler
public:
 event EventHandler^ ScrollButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ScrollButtonClick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SelectionChanged Event

SyntaxEditSelectionChanged Event
Occurs when selection bounds are changed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SourceChanged Event

SyntaxEditSourceChanged Event
Occurs when source changes.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PropertyChangedEventArgs<ITextSource>> SourceChanged
Public Event SourceChanged As EventHandler(Of PropertyChangedEventArgs(Of ITextSource))
public:
virtual  event EventHandler<PropertyChangedEventArgs<ITextSource^>^>^ SourceChanged {
    void add (EventHandler<PropertyChangedEventArgs<ITextSource^>^>^ value);
    void remove (EventHandler<PropertyChangedEventArgs<ITextSource^>^>^ value);
}
abstract SourceChanged : IEvent<EventHandler<PropertyChangedEventArgs<ITextSource>>,
    PropertyChangedEventArgs<ITextSource>>
override SourceChanged : IEvent<EventHandler<PropertyChangedEventArgs<ITextSource>>,
    PropertyChangedEventArgs<ITextSource>>

Value

Type: SystemEventHandlerPropertyChangedEventArgs ITextSource

Implements

ISyntaxEditSourceChanged
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SourceStateChanged Event

SyntaxEditSourceStateChanged Event
Occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event NotifyEvent SourceStateChanged
Public Event SourceStateChanged As NotifyEvent
public:
virtual  event NotifyEvent^ SourceStateChanged {
    void add (NotifyEvent^ value);
    void remove (NotifyEvent^ value);
}
abstract SourceStateChanged : IEvent<NotifyEvent,
    NotifyEventArgs>
override SourceStateChanged : IEvent<NotifyEvent,
    NotifyEventArgs>

Value

Type: Alternet.EditorNotifyEvent

Implements

ISyntaxEditSourceStateChanged
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SplitHorz Event

SyntaxEditSplitHorz Event
Occurs when user splits Edit control horizontally.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SplitHorz
Public Event SplitHorz As EventHandler
public:
virtual  event EventHandler^ SplitHorz {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SplitHorz : IEvent<EventHandler,
    EventArgs>
override SplitHorz : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISplitViewSplitHorz
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.SplitVert Event

SyntaxEditSplitVert Event
Occurs when user splits Edit control vertically.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SplitVert
Public Event SplitVert As EventHandler
public:
virtual  event EventHandler^ SplitVert {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SplitVert : IEvent<EventHandler,
    EventArgs>
override SplitVert : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISplitViewSplitVert
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UndoEvent Event

SyntaxEditUndoEvent Event
Occurs when undo/redo operation performed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event UndoEvent UndoEvent
Public Event UndoEvent As UndoEvent
public:
 event UndoEvent^ UndoEvent {
    void add (UndoEvent^ value);
    void remove (UndoEvent^ value);
}
member UndoEvent : IEvent<UndoEvent,
    UndoEventArgs>

Value

Type: Alternet.Editor.TextSourceUndoEvent
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UnsplitHorz Event

SyntaxEditUnsplitHorz Event
Occurs when horizontal split view is removed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UnsplitHorz
Public Event UnsplitHorz As EventHandler
public:
virtual  event EventHandler^ UnsplitHorz {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UnsplitHorz : IEvent<EventHandler,
    EventArgs>
override UnsplitHorz : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISplitViewUnsplitHorz
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.UnsplitVert Event

SyntaxEditUnsplitVert Event
Occurs when vertical split view is removed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UnsplitVert
Public Event UnsplitVert As EventHandler
public:
virtual  event EventHandler^ UnsplitVert {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UnsplitVert : IEvent<EventHandler,
    EventArgs>
override UnsplitVert : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISplitViewUnsplitVert
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.VerticalScroll Event

SyntaxEditVerticalScroll Event
Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler VerticalScroll
Public Event VerticalScroll As EventHandler
public:
 event EventHandler^ VerticalScroll {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member VerticalScroll : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxEdit.WordSpell Event

SyntaxEditWordSpell Event
Occurs when spelling of some word within the text needs checking.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event WordSpellEvent WordSpell
Public Event WordSpell As WordSpellEvent
public:
 event WordSpellEvent^ WordSpell {
    void add (WordSpellEvent^ value);
    void remove (WordSpellEvent^ value);
}
member WordSpell : IEvent<WordSpellEvent,
    WordSpellEventArgs>

Value

Type: Alternet.Editor.TextSourceWordSpellEvent
See Also

Reference

SyntaxEdit Class
Alternet.Editor Namespace


SyntaxPaint Class

SyntaxPaint Class
Represents properties and methods, used to draw text and graphic primitives.
Inheritance Hierarchy
SystemObject
Alternet.EditorSyntaxPaint
Alternet.Editor.CodeCompletionHtmlSyntaxPaint
Alternet.EditorEditSyntaxPaint

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxPaint : ISyntaxPaint
Public Class SyntaxPaint
    Implements ISyntaxPaint
public ref class SyntaxPaint : ISyntaxPaint
type SyntaxPaint =
    class
        interface ISyntaxPaint
    end

The SyntaxPaint type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxPaint | Initializes a new instance of the SyntaxPaint class with specified parameters.
Top
Methods
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal.
Public method | GetBackColor | Retrieves background color corresponding to given state.
Public method | GetFontColor | Retrieves font color corresponding to given state.
Public method | GetFontStyle | Retrieves font style corresponding to given state.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given at by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of given string.
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of given string.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Measures part of given string.
Public method | OnCustomDraw | Raises an CustomDraw event.
Public method | PaintLineBookMarks | Paints collection of line bookmark.
Public method | PaintSyntax | Perform syntax painting of the control on the graphic surface.
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to the default value.
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to the default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisableColorPaint | Gets or sets a value indicating whether control uses colors to paint its content.
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content.
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives.
Top
Events
 | Name | Description
Public event | CustomDraw | Occurs when control draws its content.
Top
See Also

Reference

Alternet.Editor Namespace


SyntaxPaint Constructor

SyntaxPaint Constructor
Initializes a new instance of the SyntaxPaint class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxPaint(
    IPainter painter,
    Control control
)
Public Sub New (
    painter As IPainter,
    control As Control
)
public:
SyntaxPaint(
    IPainter^ painter,
    Control^ control
)
new :
        painter : IPainter *
        control : Control -> SyntaxPaint

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
control
Type: System.Windows.FormsControl
Specifies control begin painted.
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint Methods

SyntaxPaint Methods

The SyntaxPaint type exposes the following members.

Methods
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal.
Public method | GetBackColor | Retrieves background color corresponding to given state.
Public method | GetFontColor | Retrieves font color corresponding to given state.
Public method | GetFontStyle | Retrieves font style corresponding to given state.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given at by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of given string.
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of given string.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Measures part of given string.
Public method | OnCustomDraw | Raises an CustomDraw event.
Public method | PaintLineBookMarks | Paints collection of line bookmark.
Public method | PaintSyntax | Perform syntax painting of the control on the graphic surface.
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to the default value.
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to the default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.DrawLine Method

SyntaxPaintDrawLine Method
Overload List
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position.
Top
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.DrawLine Method (Int32, Point, Rectangle)

SyntaxPaintDrawLine Method (Int32, Point, Rectangle)
Draws line given by its index at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawLine(
    int index,
    Point position,
    Rectangle clipRect
)
Public Overridable Sub DrawLine (
    index As Integer,
    position As Point,
    clipRect As Rectangle
)
public:
virtual void DrawLine(
    int index,
    Point position,
    Rectangle clipRect
)
abstract DrawLine :
        index : int *
        position : Point *
        clipRect : Rectangle -> unit
override DrawLine :
        index : int *
        position : Point *
        clipRect : Rectangle -> unit

Parameters

index
Type: SystemInt32
Index of line to draw.
position
Type: System.DrawingPoint
Position to start drawing.
clipRect
Type: System.DrawingRectangle
Rectangular area of the control to draw line in.

Implements

ISyntaxPaintDrawLine(Int32, Point, Rectangle)
See Also

Reference

SyntaxPaint Class
DrawLine Overload
Alternet.Editor Namespace


SyntaxPaint.DrawLine Method (Int32, String, StringItemInfo[], Point, Rectangle)

SyntaxPaintDrawLine Method (Int32, String, StringItemInfo, Point, Rectangle)
Draws line given by its index at the specified position.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawLine(
    int index,
    string line,
    StringItemInfo[] colorData,
    Point position,
    Rectangle clipRect
)
Public Overridable Sub DrawLine (
    index As Integer,
    line As String,
    colorData As StringItemInfo(),
    position As Point,
    clipRect As Rectangle
)
public:
virtual void DrawLine(
    int index,
    String^ line,
    array<StringItemInfo>^ colorData,
    Point position,
    Rectangle clipRect
)
abstract DrawLine :
        index : int *
        line : string *
        colorData : StringItemInfo[] *
        position : Point *
        clipRect : Rectangle -> unit
override DrawLine :
        index : int *
        line : string *
        colorData : StringItemInfo[] *
        position : Point *
        clipRect : Rectangle -> unit

Parameters

index
Type: SystemInt32
Index of line to draw.
line
Type: SystemString
Specifies text to draw.
colorData
Type: Alternet.SyntaxStringItemInfo
Specifies array containing color data for given string.
position
Type: System.DrawingPoint
Position to start drawing.
clipRect
Type: System.DrawingRectangle
Rectangular area of the control to draw line in.

Implements

ISyntaxPaintDrawLine(Int32, String, StringItemInfo, Point, Rectangle)
See Also

Reference

SyntaxPaint Class
DrawLine Overload
Alternet.Editor Namespace


SyntaxPaint.EqualStyles Method

SyntaxPaintEqualStyles Method
Indicates whether given styles are equal.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EqualStyles(
    StringItemInfo style1,
    StringItemInfo style2,
    bool useColors
)
Public Function EqualStyles (
    style1 As StringItemInfo,
    style2 As StringItemInfo,
    useColors As Boolean
) As Boolean
public:
virtual bool EqualStyles(
    StringItemInfo style1,
    StringItemInfo style2,
    bool useColors
) sealed
abstract EqualStyles :
        style1 : StringItemInfo *
        style2 : StringItemInfo *
        useColors : bool -> bool
override EqualStyles :
        style1 : StringItemInfo *
        style2 : StringItemInfo *
        useColors : bool -> bool

Parameters

style1
Type: Alternet.SyntaxStringItemInfo
First style to compare.
style2
Type: Alternet.SyntaxStringItemInfo
Second style to compare.
useColors
Type: SystemBoolean
Indicate whether colors of the styles are assumed.

Return Value

Type: Boolean
True if styles are equal; otherwise false.

Implements

ISyntaxPaintEqualStyles(StringItemInfo, StringItemInfo, Boolean)
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.GetBackColor Method

SyntaxPaintGetBackColor Method
Retrieves background color corresponding to given state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color GetBackColor(
    Color color,
    TextStyle state
)
Public Overridable Function GetBackColor (
    color As Color,
    state As TextStyle
) As Color
public:
virtual Color GetBackColor(
    Color color,
    TextStyle state
)
abstract GetBackColor :
        color : Color *
        state : TextStyle -> Color
override GetBackColor :
        color : Color *
        state : TextStyle -> Color

Parameters

color
Type: System.DrawingColor
Default color.
state
Type: Alternet.SyntaxTextStyle
Additional color flags.

Return Value

Type: Color
New value of background color.
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.GetFontColor Method

SyntaxPaintGetFontColor Method
Retrieves font color corresponding to given state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color GetFontColor(
    Color color,
    TextStyle textStyle
)
Public Overridable Function GetFontColor (
    color As Color,
    textStyle As TextStyle
) As Color
public:
virtual Color GetFontColor(
    Color color,
    TextStyle textStyle
)
abstract GetFontColor :
        color : Color *
        textStyle : TextStyle -> Color
override GetFontColor :
        color : Color *
        textStyle : TextStyle -> Color

Parameters

color
Type: System.DrawingColor
Default color.
textStyle
Type: Alternet.SyntaxTextStyle
Additional text styles.

Return Value

Type: Color
New value of font color.

Implements

ISyntaxPaintGetFontColor(Color, TextStyle)
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.GetFontStyle Method

SyntaxPaintGetFontStyle Method
Retrieves font style corresponding to given state.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FontStyle GetFontStyle(
    FontStyle fontStyle,
    TextStyle textStyle
)
Public Overridable Function GetFontStyle (
    fontStyle As FontStyle,
    textStyle As TextStyle
) As FontStyle
public:
virtual FontStyle GetFontStyle(
    FontStyle fontStyle,
    TextStyle textStyle
)
abstract GetFontStyle :
        fontStyle : FontStyle *
        textStyle : TextStyle -> FontStyle
override GetFontStyle :
        fontStyle : FontStyle *
        textStyle : TextStyle -> FontStyle

Parameters

fontStyle
Type: System.DrawingFontStyle
Default style.
textStyle
Type: Alternet.SyntaxTextStyle
Additional text styles.

Return Value

Type: FontStyle
New value of font style.

Implements

ISyntaxPaintGetFontStyle(FontStyle, TextStyle)
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.GetLexStyle Method

SyntaxPaintGetLexStyle Method
Retrieves lex state corresponding to given parser style.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStyle GetLexStyle(
    StringItemInfo style,
    ref TextStyle textStyle
)
Public Overridable Function GetLexStyle (
    style As StringItemInfo,
    ByRef textStyle As TextStyle
) As ILexStyle
public:
virtual ILexStyle^ GetLexStyle(
    StringItemInfo style,
    TextStyle% textStyle
)
abstract GetLexStyle :
        style : StringItemInfo *
        textStyle : TextStyle byref -> ILexStyle
override GetLexStyle :
        style : StringItemInfo *
        textStyle : TextStyle byref -> ILexStyle

Parameters

style
Type: Alternet.SyntaxStringItemInfo
Index of parser style.
textStyle
Type: Alternet.SyntaxTextStyle
Additional text styles.

Return Value

Type: ILexStyle
LexStyle by its index.

Implements

ISyntaxPaintGetLexStyle(StringItemInfo, TextStyle)
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.MeasureLine Method

SyntaxPaintMeasureLine Method
Overload List
 | Name | Description
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given at by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of given string.
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of given string.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Measures part of given string.
Top
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.MeasureLine Method (Int32, Int32, Int32)

SyntaxPaintMeasureLine Method (Int32, Int32, Int32)
Measures part of the string given at by its index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MeasureLine(
    int index,
    int pos,
    int len
)
Public Overridable Function MeasureLine (
    index As Integer,
    pos As Integer,
    len As Integer
) As Integer
public:
virtual int MeasureLine(
    int index,
    int pos,
    int len
)
abstract MeasureLine :
        index : int *
        pos : int *
        len : int -> int
override MeasureLine :
        index : int *
        pos : int *
        len : int -> int

Parameters

index
Type: SystemInt32
Index of line to measure.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.

Return Value

Type: Int32
Width of the measured part of the string.

Implements

ISyntaxPaintMeasureLine(Int32, Int32, Int32)
See Also

Reference

SyntaxPaint Class
MeasureLine Overload
Alternet.Editor Namespace


SyntaxPaint.MeasureLine Method (String, StringItemInfo[], Int32, Int32)

SyntaxPaintMeasureLine Method (String, StringItemInfo, Int32, Int32)
Measures part of given string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MeasureLine(
    string line,
    StringItemInfo[] colorData,
    int pos,
    int len
)
Public Overridable Function MeasureLine (
    line As String,
    colorData As StringItemInfo(),
    pos As Integer,
    len As Integer
) As Integer
public:
virtual int MeasureLine(
    String^ line,
    array<StringItemInfo>^ colorData,
    int pos,
    int len
)
abstract MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int -> int
override MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int -> int

Parameters

line
Type: SystemString
Text to measure.
colorData
Type: Alternet.SyntaxStringItemInfo
Color data attached to the given string.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.

Return Value

Type: Int32
Width of the measured part of the string.

Implements

ISyntaxPaintMeasureLine(String, StringItemInfo, Int32, Int32)
See Also

Reference

SyntaxPaint Class
MeasureLine Overload
Alternet.Editor Namespace


SyntaxPaint.MeasureLine Method (Int32, Int32, Int32, Int32, Int32, Boolean)

SyntaxPaintMeasureLine Method (Int32, Int32, Int32, Int32, Int32, Boolean)
Measures part of the string given by its index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MeasureLine(
    int index,
    int pos,
    int len,
    int width,
    out int chars,
    bool exact
)
Public Overridable Function MeasureLine (
    index As Integer,
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef chars As Integer,
    exact As Boolean
) As Integer
public:
virtual int MeasureLine(
    int index,
    int pos,
    int len,
    int width,
    [OutAttribute] int% chars,
    bool exact
)
abstract MeasureLine :
        index : int *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int
override MeasureLine :
        index : int *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int

Parameters

index
Type: SystemInt32
Index of line to measure.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.
width
Type: SystemInt32
Maximum length of the string.
chars
Type: SystemInt32
Receive real number of measured chars.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the measured part of the string.

Implements

ISyntaxPaintMeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean)
See Also

Reference

SyntaxPaint Class
MeasureLine Overload
Alternet.Editor Namespace


SyntaxPaint.MeasureLine Method (String, StringItemInfo[], Int32, Int32, Int32, Int32, Boolean)

SyntaxPaintMeasureLine Method (String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean)
Measures part of given string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MeasureLine(
    string line,
    StringItemInfo[] colorData,
    int pos,
    int len,
    int width,
    out int chars,
    bool exact
)
Public Function MeasureLine (
    line As String,
    colorData As StringItemInfo(),
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef chars As Integer,
    exact As Boolean
) As Integer
public:
virtual int MeasureLine(
    String^ line,
    array<StringItemInfo>^ colorData,
    int pos,
    int len,
    int width,
    [OutAttribute] int% chars,
    bool exact
) sealed
abstract MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int
override MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int

Parameters

line
Type: SystemString
Text to measure.
colorData
Type: Alternet.SyntaxStringItemInfo
Color data attached to the given string.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.
width
Type: SystemInt32
Maximum length of the string.
chars
Type: SystemInt32
Receive real number of measured chars.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the measured part of the string.

Implements

ISyntaxPaintMeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean)
See Also

Reference

SyntaxPaint Class
MeasureLine Overload
Alternet.Editor Namespace


SyntaxPaint.MeasureLine Method (String, StringItemInfo[], Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean)

SyntaxPaintMeasureLine Method (String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean)
Measures part of given string.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MeasureLine(
    string line,
    StringItemInfo[] colorData,
    int pos,
    int len,
    int width,
    out int chars,
    bool measureChars,
    bool addSpace,
    bool exact
)
Public Overridable Function MeasureLine (
    line As String,
    colorData As StringItemInfo(),
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef chars As Integer,
    measureChars As Boolean,
    addSpace As Boolean,
    exact As Boolean
) As Integer
public:
virtual int MeasureLine(
    String^ line,
    array<StringItemInfo>^ colorData,
    int pos,
    int len,
    int width,
    [OutAttribute] int% chars,
    bool measureChars,
    bool addSpace,
    bool exact
)
abstract MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        measureChars : bool *
        addSpace : bool *
        exact : bool -> int
override MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        measureChars : bool *
        addSpace : bool *
        exact : bool -> int

Parameters

line
Type: SystemString
Text to measure.
colorData
Type: Alternet.SyntaxStringItemInfo
Color data attached to the given string.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.
width
Type: SystemInt32
Maximum length of the string.
chars
Type: SystemInt32
Receive real number of measured chars.
measureChars
Type: SystemBoolean
Specifies whether the method should measure how much characters fits to the given width.
addSpace
Type: SystemBoolean
Specifies whether spaces are added to the end of string if needed.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the measured part of the string.
See Also

Reference

SyntaxPaint Class
MeasureLine Overload
Alternet.Editor Namespace


SyntaxPaint.OnCustomDraw Method

SyntaxPaintOnCustomDraw Method
Raises an CustomDraw event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool OnCustomDraw(
    Rectangle rect,
    DrawStage stage,
    DrawState state,
    IDrawInfo info
)
Public Overridable Function OnCustomDraw (
    rect As Rectangle,
    stage As DrawStage,
    state As DrawState,
    info As IDrawInfo
) As Boolean
public:
virtual bool OnCustomDraw(
    Rectangle rect,
    DrawStage stage,
    DrawState state,
    IDrawInfo^ info
)
abstract OnCustomDraw :
        rect : Rectangle *
        stage : DrawStage *
        state : DrawState *
        info : IDrawInfo -> bool
override OnCustomDraw :
        rect : Rectangle *
        stage : DrawStage *
        state : DrawState *
        info : IDrawInfo -> bool

Parameters

rect
Type: System.DrawingRectangle
Rectangular area of control to draw.
stage
Type: Alternet.EditorDrawStage
Specifies whether this method called before or after painting.
state
Type: Alternet.EditorDrawState
Specifies part of control to draw.
info
Type: Alternet.EditorIDrawInfo
Full information about drawing text fragment.

Return Value

Type: Boolean
True if user handles this event; otherwise false.

Implements

ISyntaxPaintOnCustomDraw(Rectangle, DrawStage, DrawState, IDrawInfo)
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.PaintLineBookMarks Method

SyntaxPaintPaintLineBookMarks Method
Paints collection of line bookmark.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintLineBookMarks(
    Rectangle rect
)
Public Overridable Sub PaintLineBookMarks (
    rect As Rectangle
)
public:
virtual void PaintLineBookMarks(
    Rectangle rect
)
abstract PaintLineBookMarks :
        rect : Rectangle -> unit
override PaintLineBookMarks :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Rectangular area of control to draw line bookmarks.
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.PaintSyntax Method

SyntaxPaintPaintSyntax Method
Perform syntax painting of the control on the graphic surface.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
)
Public Overridable Sub PaintSyntax (
    startLine As Integer,
    endLine As Integer,
    position As Point,
    rect As Rectangle,
    location As Point,
    specialPaint As Boolean
)
public:
virtual void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
)
abstract PaintSyntax :
        startLine : int *
        endLine : int *
        position : Point *
        rect : Rectangle *
        location : Point *
        specialPaint : bool -> unit
override PaintSyntax :
        startLine : int *
        endLine : int *
        position : Point *
        rect : Rectangle *
        location : Point *
        specialPaint : bool -> unit

Parameters

startLine
Type: SystemInt32
Specifies the first line of content to paint.
endLine
Type: SystemInt32
Specifies the last line of content to paint.
position
Type: System.DrawingPoint
The Point value that specifies start position to draw content from.
rect
Type: System.DrawingRectangle
Rectangular area of control to draw.
location
Type: System.DrawingPoint
The Point value that specifies start position to draw page from.
specialPaint
Type: SystemBoolean
Reserved for internal use. Used for Print and Print preview.

Implements

ISyntaxPaintPaintSyntax(Int32, Int32, Point, Rectangle, Point, Boolean)
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.ResetDisableColorPaint Method

SyntaxPaintResetDisableColorPaint Method
Resets the DisableColorPaint to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDisableColorPaint()
Public Overridable Sub ResetDisableColorPaint
public:
virtual void ResetDisableColorPaint()
abstract ResetDisableColorPaint : unit -> unit
override ResetDisableColorPaint : unit -> unit

Implements

ISyntaxPaintResetDisableColorPaint
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.ResetDisableSyntaxPaint Method

SyntaxPaintResetDisableSyntaxPaint Method
Resets the DisableSyntaxPaint to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDisableSyntaxPaint()
Public Overridable Sub ResetDisableSyntaxPaint
public:
virtual void ResetDisableSyntaxPaint()
abstract ResetDisableSyntaxPaint : unit -> unit
override ResetDisableSyntaxPaint : unit -> unit

Implements

ISyntaxPaintResetDisableSyntaxPaint
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint Properties

SyntaxPaint Properties

The SyntaxPaint type exposes the following members.

Properties
 | Name | Description
Public property | DisableColorPaint | Gets or sets a value indicating whether control uses colors to paint its content.
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content.
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives.
Top
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.DisableColorPaint Property

SyntaxPaintDisableColorPaint Property
Gets or sets a value indicating whether control uses colors to paint its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DisableColorPaint { get; set; }
Public Overridable Property DisableColorPaint As Boolean
    Get
    Set
public:
virtual property bool DisableColorPaint {
    bool get ();
    void set (bool value);
}
abstract DisableColorPaint : bool with get, set
override DisableColorPaint : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxPaintDisableColorPaint
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.DisableSyntaxPaint Property

SyntaxPaintDisableSyntaxPaint Property
Gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DisableSyntaxPaint { get; set; }
Public Overridable Property DisableSyntaxPaint As Boolean
    Get
    Set
public:
virtual property bool DisableSyntaxPaint {
    bool get ();
    void set (bool value);
}
abstract DisableSyntaxPaint : bool with get, set
override DisableSyntaxPaint : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxPaintDisableSyntaxPaint
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.Lexer Property

SyntaxPaintLexer Property
Gets or sets object that can make lexical analysis for the control's content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexer Lexer { get; set; }
Public Overridable Property Lexer As ILexer
    Get
    Set
public:
virtual property ILexer^ Lexer {
    ILexer^ get ();
    void set (ILexer^ value);
}
abstract Lexer : ILexer with get, set
override Lexer : ILexer with get, set

Property Value

Type: ILexer

Implements

ISyntaxPaintLexer
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.Painter Property

SyntaxPaintPainter Property
Specifies IPainter object used to draw text and graphic primitives.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPainter Painter { get; set; }
Public Property Painter As IPainter
    Get
    Set
public:
virtual property IPainter^ Painter {
    IPainter^ get () sealed;
    void set (IPainter^ value) sealed;
}
abstract Painter : IPainter with get, set
override Painter : IPainter with get, set

Property Value

Type: IPainter

Implements

ISyntaxPaintPainter
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint Events

SyntaxPaint Events

The SyntaxPaint type exposes the following members.

Events
 | Name | Description
Public event | CustomDraw | Occurs when control draws its content.
Top
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


SyntaxPaint.CustomDraw Event

SyntaxPaintCustomDraw Event
Occurs when control draws its content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event CustomDrawEvent CustomDraw
Public Event CustomDraw As CustomDrawEvent
public:
virtual  event CustomDrawEvent^ CustomDraw {
    void add (CustomDrawEvent^ value);
    void remove (CustomDrawEvent^ value);
}
abstract CustomDraw : IEvent<CustomDrawEvent,
    CustomDrawEventArgs>
override CustomDraw : IEvent<CustomDrawEvent,
    CustomDrawEventArgs>

Value

Type: Alternet.EditorCustomDrawEvent

Implements

ISyntaxPaintCustomDraw
See Also

Reference

SyntaxPaint Class
Alternet.Editor Namespace


TextFoundEvent Delegate

TextFoundEvent Delegate
Represents a method that will handle the SearchManager.TextFound event.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void TextFoundEvent(
    Object sender,
    TextFoundEventArgs e
)
Public Delegate Sub TextFoundEvent (
    sender As Object,
    e As TextFoundEventArgs
)
public delegate void TextFoundEvent(
    Object^ sender,
    TextFoundEventArgs^ e
)
type TextFoundEvent =
    delegate of
        sender : Object *
        e : TextFoundEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorTextFoundEventArgs
A TextFoundEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


TextFoundEventArgs Class

TextFoundEventArgs Class
Provides data for the TextFoundEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorTextFoundEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextFoundEventArgs : EventArgs
Public Class TextFoundEventArgs
    Inherits EventArgs
public ref class TextFoundEventArgs : public EventArgs
type TextFoundEventArgs =
    class
        inherit EventArgs
    end

The TextFoundEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextFoundEventArgs(ISearch) | Initializes a new instance of the TextFoundEventArgs class with specified parameters.
Public method | TextFoundEventArgs(String, String, SearchOptions, Regex, Match, Point, Int32, Boolean) | Initializes a new instance of the TextFoundEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Expression | Represents a regular expression to find text.
Public property | FileName | Name of file where text found.
Public property | Len | Length of found text.
Public property | Match | Match if regular expression search successful.
Public property | MultiLine | Determines if search text is found on multiple lines.
Public property | Options | Defines search behavior.
Public property | Position | Position where text was found.
Public property | Search | Search engine where text was found.
Public property | Text | Found text.
Top
See Also

Reference

Alternet.Editor Namespace


TextFoundEventArgs Constructor

TextFoundEventArgs Constructor
Overload List
 | Name | Description
Public method | TextFoundEventArgs(ISearch) | Initializes a new instance of the TextFoundEventArgs class with specified parameters.
Public method | TextFoundEventArgs(String, String, SearchOptions, Regex, Match, Point, Int32, Boolean) | Initializes a new instance of the TextFoundEventArgs class with specified parameters.
Top
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs Constructor (ISearch)

TextFoundEventArgs Constructor (ISearch)
Initializes a new instance of the TextFoundEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextFoundEventArgs(
    ISearch search
)
Public Sub New (
    search As ISearch
)
public:
TextFoundEventArgs(
    ISearch^ search
)
new :
        search : ISearch -> TextFoundEventArgs

Parameters

search
Type: Alternet.EditorISearch
ISearch engine where text was found.
See Also

Reference

TextFoundEventArgs Class
TextFoundEventArgs Overload
Alternet.Editor Namespace


TextFoundEventArgs Constructor (String, String, SearchOptions, Regex, Match, Point, Int32, Boolean)

TextFoundEventArgs Constructor (String, String, SearchOptions, Regex, Match, Point, Int32, Boolean)
Initializes a new instance of the TextFoundEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextFoundEventArgs(
    string fileName,
    string text,
    SearchOptions options,
    Regex expression,
    Match match,
    Point position,
    int len,
    bool multiLine
)
Public Sub New (
    fileName As String,
    text As String,
    options As SearchOptions,
    expression As Regex,
    match As Match,
    position As Point,
    len As Integer,
    multiLine As Boolean
)
public:
TextFoundEventArgs(
    String^ fileName,
    String^ text,
    SearchOptions options,
    Regex^ expression,
    Match^ match,
    Point position,
    int len,
    bool multiLine
)
new :
        fileName : string *
        text : string *
        options : SearchOptions *
        expression : Regex *
        match : Match *
        position : Point *
        len : int *
        multiLine : bool -> TextFoundEventArgs

Parameters

fileName
Type: SystemString
Name of file where text found.
text
Type: SystemString
Founded text.
options
Type: Alternet.Editor.TextSourceSearchOptions
SearchOptions defines search behavior.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
match
Type: System.Text.RegularExpressionsMatch
Match if regular expression search successful.
position
Type: System.DrawingPoint
Position where text was found.
len
Type: SystemInt32
Length of found text.
multiLine
Type: SystemBoolean
Determines if search text is found on multiple lines.
See Also

Reference

TextFoundEventArgs Class
TextFoundEventArgs Overload
Alternet.Editor Namespace


TextFoundEventArgs Methods

TextFoundEventArgs Methods

The TextFoundEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs Properties

TextFoundEventArgs Properties

The TextFoundEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Expression | Represents a regular expression to find text.
Public property | FileName | Name of file where text found.
Public property | Len | Length of found text.
Public property | Match | Match if regular expression search successful.
Public property | MultiLine | Determines if search text is found on multiple lines.
Public property | Options | Defines search behavior.
Public property | Position | Position where text was found.
Public property | Search | Search engine where text was found.
Public property | Text | Found text.
Top
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs.Expression Property

TextFoundEventArgsExpression Property
Represents a regular expression to find text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Regex Expression { get; set; }
Public Property Expression As Regex
    Get
    Set
public:
property Regex^ Expression {
    Regex^ get ();
    void set (Regex^ value);
}
member Expression : Regex with get, set

Property Value

Type: Regex
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs.FileName Property

TextFoundEventArgsFileName Property
Name of file where text found.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs.Len Property

TextFoundEventArgsLen Property
Length of found text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Len { get; set; }
Public Property Len As Integer
    Get
    Set
public:
property int Len {
    int get ();
    void set (int value);
}
member Len : int with get, set

Property Value

Type: Int32
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs.Match Property

TextFoundEventArgsMatch Property
Match if regular expression search successful.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Match Match { get; set; }
Public Property Match As Match
    Get
    Set
public:
property Match^ Match {
    Match^ get ();
    void set (Match^ value);
}
member Match : Match with get, set

Property Value

Type: Match
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs.MultiLine Property

TextFoundEventArgsMultiLine Property
Determines if search text is found on multiple lines.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MultiLine { get; set; }
Public Property MultiLine As Boolean
    Get
    Set
public:
property bool MultiLine {
    bool get ();
    void set (bool value);
}
member MultiLine : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs.Options Property

TextFoundEventArgsOptions Property
Defines search behavior.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchOptions Options { get; set; }
Public Property Options As SearchOptions
    Get
    Set
public:
property SearchOptions Options {
    SearchOptions get ();
    void set (SearchOptions value);
}
member Options : SearchOptions with get, set

Property Value

Type: SearchOptions
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs.Position Property

TextFoundEventArgsPosition Property
Position where text was found.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set
public:
property Point Position {
    Point get ();
    void set (Point value);
}
member Position : Point with get, set

Property Value

Type: Point
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs.Search Property

TextFoundEventArgsSearch Property
Search engine where text was found.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISearch Search { get; set; }
Public Property Search As ISearch
    Get
    Set
public:
property ISearch^ Search {
    ISearch^ get ();
    void set (ISearch^ value);
}
member Search : ISearch with get, set

Property Value

Type: ISearch
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextFoundEventArgs.Text Property

TextFoundEventArgsText Property
Found text.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

TextFoundEventArgs Class
Alternet.Editor Namespace


TextUndoEvent Delegate

TextUndoEvent Delegate
Represents a method that will handle string replacement event inside Selection.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void TextUndoEvent(
    string s,
    ITextUndoList operations
)
Public Delegate Sub TextUndoEvent (
    s As String,
    operations As ITextUndoList
)
public delegate void TextUndoEvent(
    String^ s,
    ITextUndoList^ operations
)
type TextUndoEvent =
    delegate of
        s : string *
        operations : ITextUndoList -> unit

Parameters

s
Type: SystemString
String to be replaced.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
See Also

Reference

Alternet.Editor Namespace


TextUndoEventEx Delegate

TextUndoEventEx Delegate
Represents a method that will handle string replacement event inside Selection

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void TextUndoEventEx(
    IRange range,
    int index,
    string s,
    ITextUndoList operations
)
Public Delegate Sub TextUndoEventEx (
    range As IRange,
    index As Integer,
    s As String,
    operations As ITextUndoList
)
public delegate void TextUndoEventEx(
    IRange^ range,
    int index,
    String^ s,
    ITextUndoList^ operations
)
type TextUndoEventEx =
    delegate of
        range : IRange *
        index : int *
        s : string *
        operations : ITextUndoList -> unit

Parameters

range
Type: Alternet.CommonIRange
Range representing text to change.
index
Type: SystemInt32
Index of line to be changed.
s
Type: SystemString
String to be replaced.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
See Also

Reference

Alternet.Editor Namespace


UrlJumpEvent Delegate

UrlJumpEvent Delegate
Represents a method that will handle the SyntaxEdit.JumpToUrl or HyperTextEx.JumpToUrl events.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UrlJumpEvent(
    Object sender,
    UrlJumpEventArgs e
)
Public Delegate Sub UrlJumpEvent (
    sender As Object,
    e As UrlJumpEventArgs
)
public delegate void UrlJumpEvent(
    Object^ sender,
    UrlJumpEventArgs^ e
)
type UrlJumpEvent =
    delegate of
        sender : Object *
        e : UrlJumpEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.EditorUrlJumpEventArgs
A UrlJumpEventArgs that contains the event data.
See Also

Reference

Alternet.Editor Namespace


UrlJumpEventArgs Class

UrlJumpEventArgs Class
Provides data for the UrlJumpEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.EditorUrlJumpEventArgs

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UrlJumpEventArgs : EventArgs
Public Class UrlJumpEventArgs
    Inherits EventArgs
public ref class UrlJumpEventArgs : public EventArgs
type UrlJumpEventArgs =
    class
        inherit EventArgs
    end

The UrlJumpEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UrlJumpEventArgs | Initializes a new instance of the UrlJumpEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Handled | Represents a value indicating whether jump to url event is handled, disabling opening default browser. By default this value is false.
Public property | Text | Represents the Url address.
Top
See Also

Reference

Alternet.Editor Namespace


UrlJumpEventArgs Constructor

UrlJumpEventArgs Constructor
Initializes a new instance of the UrlJumpEventArgs class with specified parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UrlJumpEventArgs(
    string text,
    bool handled
)
Public Sub New (
    text As String,
    handled As Boolean
)
public:
UrlJumpEventArgs(
    String^ text,
    bool handled
)
new :
        text : string *
        handled : bool -> UrlJumpEventArgs

Parameters

text
Type: SystemString
The Url address.
handled
Type: SystemBoolean
Specifies whether jump to url event already handled.
See Also

Reference

UrlJumpEventArgs Class
Alternet.Editor Namespace


UrlJumpEventArgs Methods

UrlJumpEventArgs Methods

The UrlJumpEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UrlJumpEventArgs Class
Alternet.Editor Namespace


UrlJumpEventArgs Properties

UrlJumpEventArgs Properties

The UrlJumpEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Represents a value indicating whether jump to url event is handled, disabling opening default browser. By default this value is false.
Public property | Text | Represents the Url address.
Top
See Also

Reference

UrlJumpEventArgs Class
Alternet.Editor Namespace


UrlJumpEventArgs.Handled Property

UrlJumpEventArgsHandled Property
Represents a value indicating whether jump to url event is handled, disabling opening default browser. By default this value is false.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UrlJumpEventArgs Class
Alternet.Editor Namespace


UrlJumpEventArgs.Text Property

UrlJumpEventArgsText Property
Represents the Url address.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

UrlJumpEventArgs Class
Alternet.Editor Namespace


VisualTheme Class

VisualTheme Class
Represents a single color theme.
Inheritance Hierarchy
SystemObject
Alternet.EditorVisualTheme
Alternet.EditorStandardVisualTheme

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VisualTheme : IVisualTheme,
    IDisposable
Public Class VisualTheme
    Implements IVisualTheme, IDisposable
public ref class VisualTheme : IVisualTheme,
    IDisposable
type VisualTheme =
    class
        interface IVisualTheme
        interface IDisposable
    end

The VisualTheme type exposes the following members.

Constructors
 | Name | Description
Public method | VisualTheme | Initailizes new instance of ColorTheme with default settings.
Public method | VisualTheme(String, Boolean, Font, ILexStyles) | Initializes new instance of ColorTheme with given parameters.
Top
Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox |
Public method | ApplyToCodeCompletionHint |
Public method | ApplyToEdit |
Public method | ApplyToScrollBar |
Public method | ApplyToScrollingButton |
Public method | ApplyToSplitButton |
Public method | Assign |
Public method | Dispose | Releases all resources used by the VisualTheme
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromEdit |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Font | Gets or sets the font used for the color theme.
Public property | ImagesColor |
Public property | Item | Specifies an Item indexer that uses the name of the LexStyle as an index.
Public property | LexStyles | Gets or sets the LexStyle array used for the color theme.
Public property | Name | Gets or sets the name of the color theme.
Public property | ReadOnly | Gets or sets a bool value that indicates whether or not the color theme should be modified.
Top
See Also

Reference

Alternet.Editor Namespace


VisualTheme Constructor

VisualTheme Constructor
Overload List
 | Name | Description
Public method | VisualTheme | Initailizes new instance of ColorTheme with default settings.
Public method | VisualTheme(String, Boolean, Font, ILexStyles) | Initializes new instance of ColorTheme with given parameters.
Top
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme Constructor

VisualTheme Constructor
Initailizes new instance of ColorTheme with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualTheme()
Public Sub New
public:
VisualTheme()
new : unit -> VisualTheme
See Also

Reference

VisualTheme Class
VisualTheme Overload
Alternet.Editor Namespace


VisualTheme Constructor (String, Boolean, Font, ILexStyles)

VisualTheme Constructor (String, Boolean, Font, ILexStyles)
Initializes new instance of ColorTheme with given parameters.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualTheme(
    string name,
    bool readOnly,
    Font font,
    ILexStyles lexStyles
)
Public Sub New (
    name As String,
    readOnly As Boolean,
    font As Font,
    lexStyles As ILexStyles
)
public:
VisualTheme(
    String^ name,
    bool readOnly,
    Font^ font,
    ILexStyles^ lexStyles
)
new :
        name : string *
        readOnly : bool *
        font : Font *
        lexStyles : ILexStyles -> VisualTheme

Parameters

name
Type: SystemString
Color theme name.
readOnly
Type: SystemBoolean
A flag that indicates whether or not the color theme should be modified.
font
Type: System.DrawingFont
lexStyles
Type: Alternet.Syntax.LexerILexStyles
LexStyle array.
See Also

Reference

VisualTheme Class
VisualTheme Overload
Alternet.Editor Namespace


VisualTheme Methods

VisualTheme Methods

The VisualTheme type exposes the following members.

Methods
 | Name | Description
Public method | ApplyToCodeCompletionBox |
Public method | ApplyToCodeCompletionHint |
Public method | ApplyToEdit |
Public method | ApplyToScrollBar |
Public method | ApplyToScrollingButton |
Public method | ApplyToSplitButton |
Public method | Assign |
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFromEdit |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.ApplyToCodeCompletionBox Method

VisualThemeApplyToCodeCompletionBox Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplyToCodeCompletionBox(
    ICodeCompletionBox codeCompletionBox
)
Public Sub ApplyToCodeCompletionBox (
    codeCompletionBox As ICodeCompletionBox
)
public:
virtual void ApplyToCodeCompletionBox(
    ICodeCompletionBox^ codeCompletionBox
) sealed
abstract ApplyToCodeCompletionBox :
        codeCompletionBox : ICodeCompletionBox -> unit
override ApplyToCodeCompletionBox :
        codeCompletionBox : ICodeCompletionBox -> unit

Parameters

codeCompletionBox
Type: Alternet.Editor.CodeCompletionICodeCompletionBox

Implements

IVisualThemeApplyToCodeCompletionBox(ICodeCompletionBox)
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.ApplyToCodeCompletionHint Method

VisualThemeApplyToCodeCompletionHint Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplyToCodeCompletionHint(
    ICodeCompletionHint codeCompletionHint
)
Public Sub ApplyToCodeCompletionHint (
    codeCompletionHint As ICodeCompletionHint
)
public:
virtual void ApplyToCodeCompletionHint(
    ICodeCompletionHint^ codeCompletionHint
) sealed
abstract ApplyToCodeCompletionHint :
        codeCompletionHint : ICodeCompletionHint -> unit
override ApplyToCodeCompletionHint :
        codeCompletionHint : ICodeCompletionHint -> unit

Parameters

codeCompletionHint
Type: Alternet.Editor.CodeCompletionICodeCompletionHint

Implements

IVisualThemeApplyToCodeCompletionHint(ICodeCompletionHint)
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.ApplyToEdit Method

VisualThemeApplyToEdit Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplyToEdit(
    ISyntaxEdit edit
)
Public Sub ApplyToEdit (
    edit As ISyntaxEdit
)
public:
virtual void ApplyToEdit(
    ISyntaxEdit^ edit
) sealed
abstract ApplyToEdit :
        edit : ISyntaxEdit -> unit
override ApplyToEdit :
        edit : ISyntaxEdit -> unit

Parameters

edit
Type: Alternet.EditorISyntaxEdit

Implements

IVisualThemeApplyToEdit(ISyntaxEdit)
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.ApplyToScrollBar Method

VisualThemeApplyToScrollBar Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplyToScrollBar(
    ScrollBar scrollBar
)
Public Sub ApplyToScrollBar (
    scrollBar As ScrollBar
)
public:
virtual void ApplyToScrollBar(
    ScrollBar^ scrollBar
) sealed
abstract ApplyToScrollBar :
        scrollBar : ScrollBar -> unit
override ApplyToScrollBar :
        scrollBar : ScrollBar -> unit

Parameters

scrollBar
Type: Alternet.EditorScrollBar

Implements

IVisualThemeApplyToScrollBar(ScrollBar)
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.ApplyToScrollingButton Method

VisualThemeApplyToScrollingButton Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplyToScrollingButton(
    IScrollingButton button
)
Public Sub ApplyToScrollingButton (
    button As IScrollingButton
)
public:
virtual void ApplyToScrollingButton(
    IScrollingButton^ button
) sealed
abstract ApplyToScrollingButton :
        button : IScrollingButton -> unit
override ApplyToScrollingButton :
        button : IScrollingButton -> unit

Parameters

button
Type: Alternet.EditorIScrollingButton

Implements

IVisualThemeApplyToScrollingButton(IScrollingButton)
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.ApplyToSplitButton Method

VisualThemeApplyToSplitButton Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplyToSplitButton(
    IScrollingButton button
)
Public Sub ApplyToSplitButton (
    button As IScrollingButton
)
public:
virtual void ApplyToSplitButton(
    IScrollingButton^ button
) sealed
abstract ApplyToSplitButton :
        button : IScrollingButton -> unit
override ApplyToSplitButton :
        button : IScrollingButton -> unit

Parameters

button
Type: Alternet.EditorIScrollingButton

Implements

IVisualThemeApplyToSplitButton(IScrollingButton)
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.Assign Method

VisualThemeAssign Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Assign(
    IVisualTheme source
)
Public Sub Assign (
    source As IVisualTheme
)
public:
virtual void Assign(
    IVisualTheme^ source
) sealed
abstract Assign :
        source : IVisualTheme -> unit
override Assign :
        source : IVisualTheme -> unit

Parameters

source
Type: Alternet.EditorIVisualTheme

Implements

IVisualThemeAssign(IVisualTheme)
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.Dispose Method

VisualThemeDispose Method
Releases all resources used by the VisualTheme

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.LoadFromEdit Method

VisualThemeLoadFromEdit Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LoadFromEdit(
    ISyntaxEdit edit
)
Public Sub LoadFromEdit (
    edit As ISyntaxEdit
)
public:
virtual void LoadFromEdit(
    ISyntaxEdit^ edit
) sealed
abstract LoadFromEdit :
        edit : ISyntaxEdit -> unit
override LoadFromEdit :
        edit : ISyntaxEdit -> unit

Parameters

edit
Type: Alternet.EditorISyntaxEdit

Implements

IVisualThemeLoadFromEdit(ISyntaxEdit)
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme Properties

VisualTheme Properties

The VisualTheme type exposes the following members.

Properties
 | Name | Description
Public property | Font | Gets or sets the font used for the color theme.
Public property | ImagesColor |
Public property | Item | Specifies an Item indexer that uses the name of the LexStyle as an index.
Public property | LexStyles | Gets or sets the LexStyle array used for the color theme.
Public property | Name | Gets or sets the name of the color theme.
Public property | ReadOnly | Gets or sets a bool value that indicates whether or not the color theme should be modified.
Top
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.Font Property

VisualThemeFont Property
Gets or sets the font used for the color theme.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Font Font { get; set; }
Public Overridable Property Font As Font
    Get
    Set
public:
virtual property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set
override Font : Font with get, set

Property Value

Type: Font

Implements

IVisualThemeFont
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.ImagesColor Property

VisualThemeImagesColor Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualThemeImagesColor ImagesColor { get; set; }
Public Property ImagesColor As VisualThemeImagesColor
    Get
    Set
public:
virtual property VisualThemeImagesColor ImagesColor {
    VisualThemeImagesColor get () sealed;
    void set (VisualThemeImagesColor value) sealed;
}
abstract ImagesColor : VisualThemeImagesColor with get, set
override ImagesColor : VisualThemeImagesColor with get, set

Property Value

Type: VisualThemeImagesColor

Implements

IVisualThemeImagesColor
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.Item Property

VisualThemeItem Property
Specifies an Item indexer that uses the name of the LexStyle as an index.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ILexStyle this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As ILexStyle
    Get
public:
virtual property ILexStyle^ default[String^ name] {
    ILexStyle^ get (String^ name) sealed;
}
abstract Item : ILexStyle with get
override Item : ILexStyle with get

Parameters

name
Type: SystemString
Name of the LexStyle such as "ident".

Return Value

Type: ILexStyle
LexStyle object that corresponds to the name parameter, or null for an invalid name.

Implements

IVisualThemeItemString
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.LexStyles Property

VisualThemeLexStyles Property
Gets or sets the LexStyle array used for the color theme.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStyles LexStyles { get; set; }
Public Overridable Property LexStyles As ILexStyles
    Get
    Set
public:
virtual property ILexStyles^ LexStyles {
    ILexStyles^ get ();
    void set (ILexStyles^ value);
}
abstract LexStyles : ILexStyles with get, set
override LexStyles : ILexStyles with get, set

Property Value

Type: ILexStyles

Implements

IVisualThemeLexStyles
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.Name Property

VisualThemeName Property
Gets or sets the name of the color theme.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IVisualThemeName
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.ReadOnly Property

VisualThemeReadOnly Property
Gets or sets a bool value that indicates whether or not the color theme should be modified.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReadOnly { get; set; }
Public Overridable Property ReadOnly As Boolean
    Get
    Set
public:
virtual property bool ReadOnly {
    bool get ();
    void set (bool value);
}
abstract ReadOnly : bool with get, set
override ReadOnly : bool with get, set

Property Value

Type: Boolean

Implements

IVisualThemeReadOnly
See Also

Reference

VisualTheme Class
Alternet.Editor Namespace


VisualTheme.ThemedCodeCompletionBoxPainter Class

VisualThemeThemedCodeCompletionBoxPainter Class
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResources CodeCompletionBoxPainterBrush, CodeCompletionBoxPainterPen, CodeCompletionBoxPainterImage, CodeCompletionBoxPainterImageList, CodeCompletionBoxPainterTextStyle
CodeCompletionBoxPainter
Alternet.EditorVisualThemeThemedCodeCompletionBoxPainter

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ThemedCodeCompletionBoxPainter : CodeCompletionBoxPainter
Public Class ThemedCodeCompletionBoxPainter
    Inherits CodeCompletionBoxPainter
public ref class ThemedCodeCompletionBoxPainter : public CodeCompletionBoxPainter
type ThemedCodeCompletionBoxPainter =
    class
        inherit CodeCompletionBoxPainter
    end

The VisualThemeThemedCodeCompletionBoxPainter type exposes the following members.

Constructors
 | Name | Description
Public method | VisualThemeThemedCodeCompletionBoxPainter | Initializes a new instance of the VisualThemeThemedCodeCompletionBoxPainter class
Top
Methods
 | Name | Description
Public method | Dispose | Disposes this PainterResources and frees resources associated with it. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrush | Finds stored Brush object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Finds stored Image object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetImageList | Finds stored ImageList object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetPen | Finds stored Pen object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetTextStyle | Finds stored text style object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Editor Namespace


VisualTheme.ThemedCodeCompletionBoxPainter Constructor

VisualThemeThemedCodeCompletionBoxPainter Constructor
Initializes a new instance of the VisualThemeThemedCodeCompletionBoxPainter class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThemedCodeCompletionBoxPainter(
    VisualTheme theme
)
Public Sub New (
    theme As VisualTheme
)
public:
ThemedCodeCompletionBoxPainter(
    VisualTheme^ theme
)
new :
        theme : VisualTheme -> ThemedCodeCompletionBoxPainter

Parameters

theme
Type: Alternet.EditorVisualTheme
See Also

Reference

VisualThemeThemedCodeCompletionBoxPainter Class
Alternet.Editor Namespace


ThemedCodeCompletionBoxPainter Methods

ThemedCodeCompletionBoxPainter Methods

The VisualThemeThemedCodeCompletionBoxPainter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this PainterResources and frees resources associated with it. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrush | Finds stored Brush object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Finds stored Image object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetImageList | Finds stored ImageList object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetPen | Finds stored Pen object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetTextStyle | Finds stored text style object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisualThemeThemedCodeCompletionBoxPainter Class
Alternet.Editor Namespace


VisualTheme.ThemedVsControlsPainter Class

VisualThemeThemedVsControlsPainter Class
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResources VsControlsPainterBrush, VsControlsPainterPen, VsControlsPainterImage, VsControlsPainterImageList, VsControlsPainterTextStyle
VsControlsPainter
Alternet.EditorVisualThemeThemedVsControlsPainter

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ThemedVsControlsPainter : VsControlsPainter
Public Class ThemedVsControlsPainter
    Inherits VsControlsPainter
public ref class ThemedVsControlsPainter : public VsControlsPainter
type ThemedVsControlsPainter =
    class
        inherit VsControlsPainter
    end

The VisualThemeThemedVsControlsPainter type exposes the following members.

Constructors
 | Name | Description
Public method | VisualThemeThemedVsControlsPainter | Initializes a new instance of the VisualThemeThemedVsControlsPainter class
Top
Methods
 | Name | Description
Public method | Dispose | Disposes this PainterResources and frees resources associated with it. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrush | Finds stored Brush object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Finds stored Image object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetImageList | Finds stored ImageList object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetPen | Finds stored Pen object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetTextStyle | Finds stored text style object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Editor Namespace


VisualTheme.ThemedVsControlsPainter Constructor

VisualThemeThemedVsControlsPainter Constructor
Initializes a new instance of the VisualThemeThemedVsControlsPainter class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThemedVsControlsPainter(
    VisualTheme theme
)
Public Sub New (
    theme As VisualTheme
)
public:
ThemedVsControlsPainter(
    VisualTheme^ theme
)
new :
        theme : VisualTheme -> ThemedVsControlsPainter

Parameters

theme
Type: Alternet.EditorVisualTheme
See Also

Reference

VisualThemeThemedVsControlsPainter Class
Alternet.Editor Namespace


ThemedVsControlsPainter Methods

ThemedVsControlsPainter Methods

The VisualThemeThemedVsControlsPainter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this PainterResources and frees resources associated with it. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrush | Finds stored Brush object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Finds stored Image object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetImageList | Finds stored ImageList object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetPen | Finds stored Pen object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetTextStyle | Finds stored text style object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisualThemeThemedVsControlsPainter Class
Alternet.Editor Namespace


VisualThemeColors Class

VisualThemeColors Class
Inheritance Hierarchy
SystemObject
Alternet.EditorVisualThemeColors

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VisualThemeColors : ICloneable
Public Class VisualThemeColors
    Implements ICloneable
public ref class VisualThemeColors : ICloneable
type VisualThemeColors =
    class
        interface ICloneable
    end

The VisualThemeColors type exposes the following members.

Constructors
 | Name | Description
Public method | VisualThemeColors | Initializes a new instance of the VisualThemeColors class
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ActiveSelectionBackground |
Public property | ActiveSelectionForeground |
Public property | BracesBackground |
Public property | BracesForeground |
Public property | CodeCompletionBoxBackground |
Public property | CodeCompletionBoxBorder |
Public property | CodeCompletionBoxCategoryFilterButtonHovered |
Public property | CodeCompletionBoxCategoryFilterButtonPressed |
Public property | CodeCompletionBoxCategoryFilterToolbarBackground |
Public property | CodeCompletionBoxItemFocusRectangle |
Public property | CodeCompletionBoxNoSuggestionsText |
Public property | CodeCompletionHintBackground |
Public property | Comments |
Public property | Directives |
Public property | GutterBackground |
Public property | GutterForeground |
Public property | HighlightBlockAreaBackground |
Public property | HighlightOutlineAreaBackground |
Public property | HtmlParams |
Public property | HyperText |
Public property | Identifiers |
Public property | ImagesColor |
Public property | InactiveSelectionBackground |
Public property | InactiveSelectionForeground |
Public property | LineModificatorChanged |
Public property | LineModificatorSaved |
Public property | LineNumbers |
Public property | LineSeparator |
Public property | MisspelledWords |
Public property | Numbers |
Public property | OutlinePen |
Public property | PopupPanelFocusHighlightIndicatorFocused |
Public property | PopupPanelFocusHighlightIndicatorNonFocused |
Public property | PopupPanelResizeGripper |
Public property | ReferenceHighlightBackground |
Public property | Reswords |
Public property | ScrollBarBackground |
Public property | ScrollThumbHovered |
Public property | ScrollThumbNormal |
Public property | ScrollThumbPressed |
Public property | SearchResultsHighlightBackground |
Public property | Strings |
Public property | Symbols |
Public property | VsControlsButtonHovered |
Public property | VsControlsButtonPressed |
Public property | VsControlsControlBackground |
Public property | VsControlsControlTextNormal |
Public property | VsControlsPopupBorder |
Public property | VsControlsToggleButtonHovered |
Public property | VsControlsToggleButtonPressedBorder |
Public property | WhiteSpace |
Public property | WindowBackground |
Public property | XmlComments |
Top
See Also

Reference

Alternet.Editor Namespace


VisualThemeColors Constructor

VisualThemeColors Constructor
Initializes a new instance of the VisualThemeColors class

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualThemeColors()
Public Sub New
public:
VisualThemeColors()
new : unit -> VisualThemeColors
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors Methods

VisualThemeColors Methods

The VisualThemeColors type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.Clone Method

VisualThemeColorsClone Method

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualThemeColors Clone()
Public Function Clone As VisualThemeColors
public:
VisualThemeColors^ Clone()
member Clone : unit -> VisualThemeColors

Return Value

Type: VisualThemeColors
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors Properties

VisualThemeColors Properties

The VisualThemeColors type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSelectionBackground |
Public property | ActiveSelectionForeground |
Public property | BracesBackground |
Public property | BracesForeground |
Public property | CodeCompletionBoxBackground |
Public property | CodeCompletionBoxBorder |
Public property | CodeCompletionBoxCategoryFilterButtonHovered |
Public property | CodeCompletionBoxCategoryFilterButtonPressed |
Public property | CodeCompletionBoxCategoryFilterToolbarBackground |
Public property | CodeCompletionBoxItemFocusRectangle |
Public property | CodeCompletionBoxNoSuggestionsText |
Public property | CodeCompletionHintBackground |
Public property | Comments |
Public property | Directives |
Public property | GutterBackground |
Public property | GutterForeground |
Public property | HighlightBlockAreaBackground |
Public property | HighlightOutlineAreaBackground |
Public property | HtmlParams |
Public property | HyperText |
Public property | Identifiers |
Public property | ImagesColor |
Public property | InactiveSelectionBackground |
Public property | InactiveSelectionForeground |
Public property | LineModificatorChanged |
Public property | LineModificatorSaved |
Public property | LineNumbers |
Public property | LineSeparator |
Public property | MisspelledWords |
Public property | Numbers |
Public property | OutlinePen |
Public property | PopupPanelFocusHighlightIndicatorFocused |
Public property | PopupPanelFocusHighlightIndicatorNonFocused |
Public property | PopupPanelResizeGripper |
Public property | ReferenceHighlightBackground |
Public property | Reswords |
Public property | ScrollBarBackground |
Public property | ScrollThumbHovered |
Public property | ScrollThumbNormal |
Public property | ScrollThumbPressed |
Public property | SearchResultsHighlightBackground |
Public property | Strings |
Public property | Symbols |
Public property | VsControlsButtonHovered |
Public property | VsControlsButtonPressed |
Public property | VsControlsControlBackground |
Public property | VsControlsControlTextNormal |
Public property | VsControlsPopupBorder |
Public property | VsControlsToggleButtonHovered |
Public property | VsControlsToggleButtonPressedBorder |
Public property | WhiteSpace |
Public property | WindowBackground |
Public property | XmlComments |
Top
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.ActiveSelectionBackground Property

VisualThemeColorsActiveSelectionBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ActiveSelectionBackground { get; set; }
Public Property ActiveSelectionBackground As Color
    Get
    Set
public:
property Color ActiveSelectionBackground {
    Color get ();
    void set (Color value);
}
member ActiveSelectionBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.ActiveSelectionForeground Property

VisualThemeColorsActiveSelectionForeground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ActiveSelectionForeground { get; set; }
Public Property ActiveSelectionForeground As Color
    Get
    Set
public:
property Color ActiveSelectionForeground {
    Color get ();
    void set (Color value);
}
member ActiveSelectionForeground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.BracesBackground Property

VisualThemeColorsBracesBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BracesBackground { get; set; }
Public Property BracesBackground As Color
    Get
    Set
public:
property Color BracesBackground {
    Color get ();
    void set (Color value);
}
member BracesBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.BracesForeground Property

VisualThemeColorsBracesForeground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BracesForeground { get; set; }
Public Property BracesForeground As Color
    Get
    Set
public:
property Color BracesForeground {
    Color get ();
    void set (Color value);
}
member BracesForeground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.CodeCompletionBoxBackground Property

VisualThemeColorsCodeCompletionBoxBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CodeCompletionBoxBackground { get; set; }
Public Property CodeCompletionBoxBackground As Color
    Get
    Set
public:
property Color CodeCompletionBoxBackground {
    Color get ();
    void set (Color value);
}
member CodeCompletionBoxBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.CodeCompletionBoxBorder Property

VisualThemeColorsCodeCompletionBoxBorder Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CodeCompletionBoxBorder { get; set; }
Public Property CodeCompletionBoxBorder As Color
    Get
    Set
public:
property Color CodeCompletionBoxBorder {
    Color get ();
    void set (Color value);
}
member CodeCompletionBoxBorder : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.CodeCompletionBoxCategoryFilterButtonHovered Property

VisualThemeColorsCodeCompletionBoxCategoryFilterButtonHovered Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CodeCompletionBoxCategoryFilterButtonHovered { get; set; }
Public Property CodeCompletionBoxCategoryFilterButtonHovered As Color
    Get
    Set
public:
property Color CodeCompletionBoxCategoryFilterButtonHovered {
    Color get ();
    void set (Color value);
}
member CodeCompletionBoxCategoryFilterButtonHovered : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.CodeCompletionBoxCategoryFilterButtonPressed Property

VisualThemeColorsCodeCompletionBoxCategoryFilterButtonPressed Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CodeCompletionBoxCategoryFilterButtonPressed { get; set; }
Public Property CodeCompletionBoxCategoryFilterButtonPressed As Color
    Get
    Set
public:
property Color CodeCompletionBoxCategoryFilterButtonPressed {
    Color get ();
    void set (Color value);
}
member CodeCompletionBoxCategoryFilterButtonPressed : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.CodeCompletionBoxCategoryFilterToolbarBackground Property

VisualThemeColorsCodeCompletionBoxCategoryFilterToolbarBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CodeCompletionBoxCategoryFilterToolbarBackground { get; set; }
Public Property CodeCompletionBoxCategoryFilterToolbarBackground As Color
    Get
    Set
public:
property Color CodeCompletionBoxCategoryFilterToolbarBackground {
    Color get ();
    void set (Color value);
}
member CodeCompletionBoxCategoryFilterToolbarBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.CodeCompletionBoxItemFocusRectangle Property

VisualThemeColorsCodeCompletionBoxItemFocusRectangle Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CodeCompletionBoxItemFocusRectangle { get; set; }
Public Property CodeCompletionBoxItemFocusRectangle As Color
    Get
    Set
public:
property Color CodeCompletionBoxItemFocusRectangle {
    Color get ();
    void set (Color value);
}
member CodeCompletionBoxItemFocusRectangle : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.CodeCompletionBoxNoSuggestionsText Property

VisualThemeColorsCodeCompletionBoxNoSuggestionsText Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CodeCompletionBoxNoSuggestionsText { get; set; }
Public Property CodeCompletionBoxNoSuggestionsText As Color
    Get
    Set
public:
property Color CodeCompletionBoxNoSuggestionsText {
    Color get ();
    void set (Color value);
}
member CodeCompletionBoxNoSuggestionsText : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.CodeCompletionHintBackground Property

VisualThemeColorsCodeCompletionHintBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CodeCompletionHintBackground { get; set; }
Public Property CodeCompletionHintBackground As Color
    Get
    Set
public:
property Color CodeCompletionHintBackground {
    Color get ();
    void set (Color value);
}
member CodeCompletionHintBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.Comments Property

VisualThemeColorsComments Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Comments { get; set; }
Public Property Comments As Color
    Get
    Set
public:
property Color Comments {
    Color get ();
    void set (Color value);
}
member Comments : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.Directives Property

VisualThemeColorsDirectives Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Directives { get; set; }
Public Property Directives As Color
    Get
    Set
public:
property Color Directives {
    Color get ();
    void set (Color value);
}
member Directives : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.GutterBackground Property

VisualThemeColorsGutterBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color GutterBackground { get; set; }
Public Property GutterBackground As Color
    Get
    Set
public:
property Color GutterBackground {
    Color get ();
    void set (Color value);
}
member GutterBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.GutterForeground Property

VisualThemeColorsGutterForeground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color GutterForeground { get; set; }
Public Property GutterForeground As Color
    Get
    Set
public:
property Color GutterForeground {
    Color get ();
    void set (Color value);
}
member GutterForeground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.HighlightBlockAreaBackground Property

VisualThemeColorsHighlightBlockAreaBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color HighlightBlockAreaBackground { get; set; }
Public Property HighlightBlockAreaBackground As Color
    Get
    Set
public:
property Color HighlightBlockAreaBackground {
    Color get ();
    void set (Color value);
}
member HighlightBlockAreaBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.HighlightOutlineAreaBackground Property

VisualThemeColorsHighlightOutlineAreaBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color HighlightOutlineAreaBackground { get; set; }
Public Property HighlightOutlineAreaBackground As Color
    Get
    Set
public:
property Color HighlightOutlineAreaBackground {
    Color get ();
    void set (Color value);
}
member HighlightOutlineAreaBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.HtmlParams Property

VisualThemeColorsHtmlParams Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color HtmlParams { get; set; }
Public Property HtmlParams As Color
    Get
    Set
public:
property Color HtmlParams {
    Color get ();
    void set (Color value);
}
member HtmlParams : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.HyperText Property

VisualThemeColorsHyperText Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color HyperText { get; set; }
Public Property HyperText As Color
    Get
    Set
public:
property Color HyperText {
    Color get ();
    void set (Color value);
}
member HyperText : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.Identifiers Property

VisualThemeColorsIdentifiers Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Identifiers { get; set; }
Public Property Identifiers As Color
    Get
    Set
public:
property Color Identifiers {
    Color get ();
    void set (Color value);
}
member Identifiers : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.ImagesColor Property

VisualThemeColorsImagesColor Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualThemeImagesColor ImagesColor { get; set; }
Public Property ImagesColor As VisualThemeImagesColor
    Get
    Set
public:
property VisualThemeImagesColor ImagesColor {
    VisualThemeImagesColor get ();
    void set (VisualThemeImagesColor value);
}
member ImagesColor : VisualThemeImagesColor with get, set

Property Value

Type: VisualThemeImagesColor
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.InactiveSelectionBackground Property

VisualThemeColorsInactiveSelectionBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color InactiveSelectionBackground { get; set; }
Public Property InactiveSelectionBackground As Color
    Get
    Set
public:
property Color InactiveSelectionBackground {
    Color get ();
    void set (Color value);
}
member InactiveSelectionBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.InactiveSelectionForeground Property

VisualThemeColorsInactiveSelectionForeground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color InactiveSelectionForeground { get; set; }
Public Property InactiveSelectionForeground As Color
    Get
    Set
public:
property Color InactiveSelectionForeground {
    Color get ();
    void set (Color value);
}
member InactiveSelectionForeground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.LineModificatorChanged Property

VisualThemeColorsLineModificatorChanged Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color LineModificatorChanged { get; set; }
Public Property LineModificatorChanged As Color
    Get
    Set
public:
property Color LineModificatorChanged {
    Color get ();
    void set (Color value);
}
member LineModificatorChanged : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.LineModificatorSaved Property

VisualThemeColorsLineModificatorSaved Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color LineModificatorSaved { get; set; }
Public Property LineModificatorSaved As Color
    Get
    Set
public:
property Color LineModificatorSaved {
    Color get ();
    void set (Color value);
}
member LineModificatorSaved : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.LineNumbers Property

VisualThemeColorsLineNumbers Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color LineNumbers { get; set; }
Public Property LineNumbers As Color
    Get
    Set
public:
property Color LineNumbers {
    Color get ();
    void set (Color value);
}
member LineNumbers : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.LineSeparator Property

VisualThemeColorsLineSeparator Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color LineSeparator { get; set; }
Public Property LineSeparator As Color
    Get
    Set
public:
property Color LineSeparator {
    Color get ();
    void set (Color value);
}
member LineSeparator : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.MisspelledWords Property

VisualThemeColorsMisspelledWords Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color MisspelledWords { get; set; }
Public Property MisspelledWords As Color
    Get
    Set
public:
property Color MisspelledWords {
    Color get ();
    void set (Color value);
}
member MisspelledWords : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.Numbers Property

VisualThemeColorsNumbers Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Numbers { get; set; }
Public Property Numbers As Color
    Get
    Set
public:
property Color Numbers {
    Color get ();
    void set (Color value);
}
member Numbers : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.OutlinePen Property

VisualThemeColorsOutlinePen Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color OutlinePen { get; set; }
Public Property OutlinePen As Color
    Get
    Set
public:
property Color OutlinePen {
    Color get ();
    void set (Color value);
}
member OutlinePen : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.PopupPanelFocusHighlightIndicatorFocused Property

VisualThemeColorsPopupPanelFocusHighlightIndicatorFocused Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color PopupPanelFocusHighlightIndicatorFocused { get; set; }
Public Property PopupPanelFocusHighlightIndicatorFocused As Color
    Get
    Set
public:
property Color PopupPanelFocusHighlightIndicatorFocused {
    Color get ();
    void set (Color value);
}
member PopupPanelFocusHighlightIndicatorFocused : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.PopupPanelFocusHighlightIndicatorNonFocused Property

VisualThemeColorsPopupPanelFocusHighlightIndicatorNonFocused Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color PopupPanelFocusHighlightIndicatorNonFocused { get; set; }
Public Property PopupPanelFocusHighlightIndicatorNonFocused As Color
    Get
    Set
public:
property Color PopupPanelFocusHighlightIndicatorNonFocused {
    Color get ();
    void set (Color value);
}
member PopupPanelFocusHighlightIndicatorNonFocused : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.PopupPanelResizeGripper Property

VisualThemeColorsPopupPanelResizeGripper Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color PopupPanelResizeGripper { get; set; }
Public Property PopupPanelResizeGripper As Color
    Get
    Set
public:
property Color PopupPanelResizeGripper {
    Color get ();
    void set (Color value);
}
member PopupPanelResizeGripper : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.ReferenceHighlightBackground Property

VisualThemeColorsReferenceHighlightBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ReferenceHighlightBackground { get; set; }
Public Property ReferenceHighlightBackground As Color
    Get
    Set
public:
property Color ReferenceHighlightBackground {
    Color get ();
    void set (Color value);
}
member ReferenceHighlightBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.Reswords Property

VisualThemeColorsReswords Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Reswords { get; set; }
Public Property Reswords As Color
    Get
    Set
public:
property Color Reswords {
    Color get ();
    void set (Color value);
}
member Reswords : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.ScrollBarBackground Property

VisualThemeColorsScrollBarBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ScrollBarBackground { get; set; }
Public Property ScrollBarBackground As Color
    Get
    Set
public:
property Color ScrollBarBackground {
    Color get ();
    void set (Color value);
}
member ScrollBarBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.ScrollThumbHovered Property

VisualThemeColorsScrollThumbHovered Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ScrollThumbHovered { get; set; }
Public Property ScrollThumbHovered As Color
    Get
    Set
public:
property Color ScrollThumbHovered {
    Color get ();
    void set (Color value);
}
member ScrollThumbHovered : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.ScrollThumbNormal Property

VisualThemeColorsScrollThumbNormal Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ScrollThumbNormal { get; set; }
Public Property ScrollThumbNormal As Color
    Get
    Set
public:
property Color ScrollThumbNormal {
    Color get ();
    void set (Color value);
}
member ScrollThumbNormal : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.ScrollThumbPressed Property

VisualThemeColorsScrollThumbPressed Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ScrollThumbPressed { get; set; }
Public Property ScrollThumbPressed As Color
    Get
    Set
public:
property Color ScrollThumbPressed {
    Color get ();
    void set (Color value);
}
member ScrollThumbPressed : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.SearchResultsHighlightBackground Property

VisualThemeColorsSearchResultsHighlightBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SearchResultsHighlightBackground { get; set; }
Public Property SearchResultsHighlightBackground As Color
    Get
    Set
public:
property Color SearchResultsHighlightBackground {
    Color get ();
    void set (Color value);
}
member SearchResultsHighlightBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.Strings Property

VisualThemeColorsStrings Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Strings { get; set; }
Public Property Strings As Color
    Get
    Set
public:
property Color Strings {
    Color get ();
    void set (Color value);
}
member Strings : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.Symbols Property

VisualThemeColorsSymbols Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Symbols { get; set; }
Public Property Symbols As Color
    Get
    Set
public:
property Color Symbols {
    Color get ();
    void set (Color value);
}
member Symbols : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.VsControlsButtonHovered Property

VisualThemeColorsVsControlsButtonHovered Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color VsControlsButtonHovered { get; set; }
Public Property VsControlsButtonHovered As Color
    Get
    Set
public:
property Color VsControlsButtonHovered {
    Color get ();
    void set (Color value);
}
member VsControlsButtonHovered : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.VsControlsButtonPressed Property

VisualThemeColorsVsControlsButtonPressed Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color VsControlsButtonPressed { get; set; }
Public Property VsControlsButtonPressed As Color
    Get
    Set
public:
property Color VsControlsButtonPressed {
    Color get ();
    void set (Color value);
}
member VsControlsButtonPressed : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.VsControlsControlBackground Property

VisualThemeColorsVsControlsControlBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color VsControlsControlBackground { get; set; }
Public Property VsControlsControlBackground As Color
    Get
    Set
public:
property Color VsControlsControlBackground {
    Color get ();
    void set (Color value);
}
member VsControlsControlBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.VsControlsControlTextNormal Property

VisualThemeColorsVsControlsControlTextNormal Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color VsControlsControlTextNormal { get; set; }
Public Property VsControlsControlTextNormal As Color
    Get
    Set
public:
property Color VsControlsControlTextNormal {
    Color get ();
    void set (Color value);
}
member VsControlsControlTextNormal : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.VsControlsPopupBorder Property

VisualThemeColorsVsControlsPopupBorder Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color VsControlsPopupBorder { get; set; }
Public Property VsControlsPopupBorder As Color
    Get
    Set
public:
property Color VsControlsPopupBorder {
    Color get ();
    void set (Color value);
}
member VsControlsPopupBorder : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.VsControlsToggleButtonHovered Property

VisualThemeColorsVsControlsToggleButtonHovered Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color VsControlsToggleButtonHovered { get; set; }
Public Property VsControlsToggleButtonHovered As Color
    Get
    Set
public:
property Color VsControlsToggleButtonHovered {
    Color get ();
    void set (Color value);
}
member VsControlsToggleButtonHovered : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.VsControlsToggleButtonPressedBorder Property

VisualThemeColorsVsControlsToggleButtonPressedBorder Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color VsControlsToggleButtonPressedBorder { get; set; }
Public Property VsControlsToggleButtonPressedBorder As Color
    Get
    Set
public:
property Color VsControlsToggleButtonPressedBorder {
    Color get ();
    void set (Color value);
}
member VsControlsToggleButtonPressedBorder : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.WhiteSpace Property

VisualThemeColorsWhiteSpace Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color WhiteSpace { get; set; }
Public Property WhiteSpace As Color
    Get
    Set
public:
property Color WhiteSpace {
    Color get ();
    void set (Color value);
}
member WhiteSpace : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.WindowBackground Property

VisualThemeColorsWindowBackground Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color WindowBackground { get; set; }
Public Property WindowBackground As Color
    Get
    Set
public:
property Color WindowBackground {
    Color get ();
    void set (Color value);
}
member WindowBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeColors.XmlComments Property

VisualThemeColorsXmlComments Property

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color XmlComments { get; set; }
Public Property XmlComments As Color
    Get
    Set
public:
property Color XmlComments {
    Color get ();
    void set (Color value);
}
member XmlComments : Color with get, set

Property Value

Type: Color
See Also

Reference

VisualThemeColors Class
Alternet.Editor Namespace


VisualThemeConsts Class

VisualThemeConsts Class
Contains default string constants for common requirements.
Inheritance Hierarchy
SystemObject
Alternet.EditorVisualThemeConsts

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VisualThemeConsts
Public Class VisualThemeConsts
public ref class VisualThemeConsts
type VisualThemeConsts =  class end

The VisualThemeConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ActiveSelectionInternalName |
ActiveSelectionName |
BraceMatchingInternalName |
BraceMatchingName |
BracesName |
CodeCompletionBoxBorderColorInternalName |
CodeCompletionBoxBorderColorName |
CodeCompletionBoxCategoryFilterButtonHoveredColorInternalName |
CodeCompletionBoxCategoryFilterButtonHoveredColorName |
CodeCompletionBoxCategoryFilterButtonPressedColorInternalName |
CodeCompletionBoxCategoryFilterButtonPressedColorName |
CodeCompletionBoxCategoryFilterToolbarBackgroundColorInternalName |
CodeCompletionBoxCategoryFilterToolbarBackgroundColorName |
CodeCompletionBoxColorInternalName |
CodeCompletionBoxColorName |
CodeCompletionBoxItemFocusRectangleColorInternalName |
CodeCompletionBoxItemFocusRectangleColorName |
CodeCompletionBoxNoSuggestionsTextColorInternalName |
CodeCompletionBoxNoSuggestionsTextColorName |
CodeCompletionHintColorInternalName |
CodeCompletionHintColorName |
CodeOutlinePenColorInternalName |
CodeOutlinePenColorName |
CodeSnippetsInternalName |
CodeSnippetsName |
CommentsInternalName |
CommentsName |
CommentStyle |
DirectivesInternalName |
DirectivesName |
DirectiveStyle |
FunctionsName |
GutterPenColorInternalName |
GutterPenColorName |
HighlightBlockAreaColorInternalName |
HighlightBlockAreaColorName |
HighlightOutlineAreaColorInternalName |
HighlightOutlineAreaColorName |
HTMLParamsInternalName |
HTMLParamsName |
HyperTextInternalName |
HyperTextName |
IdentsInternalName |
IdentsName |
IdentStyle |
InactiveSelectionInternalName |
InactiveSelectionName |
IncludeInternalName |
IncludeName |
IncludesName |
LineModificatorChangedInternalName |
LineModificatorChangedName |
LineModificatorSavedInternalName |
LineModificatorSavedName |
LineNumbersInternalName |
LineNumbersName |
LineSeparatorInternalName |
LineSeparatorName |
MisspelledWordsInternalName |
MisspelledWordsName |
NewObjectsName |
NumbersInternalName |
NumbersName |
NumberStyle |
ObjectsName |
OperatorsName |
PopupPanelFocusHighlightIndicatorFocusedColorInternalName |
PopupPanelFocusHighlightIndicatorFocusedColorName |
PopupPanelFocusHighlightIndicatorNonFocusedColorInternalName |
PopupPanelFocusHighlightIndicatorNonFocusedColorName |
PopupPanelResizeGripperColorInternalName |
PopupPanelResizeGripperColorName |
ReferencesColorName |
ReswordsInternalName |
ReswordsName |
ReswordStyle |
ScrollBackgroundColorInternalName |
ScrollBackgroundColorName |
SearchResultsColorName |
StringsInternalName |
StringsName |
StringStyle |
SymbolsInternalName |
SymbolsName |
SymbolStyle |
SyntaxErrorsInternalName |
SyntaxErrorsName |
SyntaxErrorStyle |
ThumbHoveredColorInternalName |
ThumbHoveredColorName |
ThumbNormalColorInternalName |
ThumbNormalColorName |
ThumbPressedColorInternalName |
ThumbPressedColorName |
VsControlsButtonHoveredColorInternalName |
VsControlsButtonHoveredColorName |
VsControlsButtonPressedColorInternalName |
VsControlsButtonPressedColorName |
VsControlsControlBackgroundColorInternalName |
VsControlsControlBackgroundColorName |
VsControlsControlTextNormalColorInternalName |
VsControlsControlTextNormalColorName |
VsControlsPopupBorderColorInternalName |
VsControlsPopupBorderColorName |
VsControlsToggleButtonHoveredColorInternalName |
VsControlsToggleButtonHoveredColorName |
VsControlsToggleButtonPressedBorderColorInternalName |
VsControlsToggleButtonPressedBorderColorName |
WhiteSpaceInternalName |
WhiteSpaceName |
WhitespaceStyle |
WindowColorInternalName |
WindowColorName |
XMLCommentsInternalName |
XMLCommentsName |
XmlCommentStyle |
Top
See Also

Reference

Alternet.Editor Namespace


VisualThemeConsts Fields

VisualThemeConsts Fields

The VisualThemeConsts type exposes the following members.

Fields
Name | Description
ActiveSelectionInternalName |
ActiveSelectionName |
BraceMatchingInternalName |
BraceMatchingName |
BracesName |
CodeCompletionBoxBorderColorInternalName |
CodeCompletionBoxBorderColorName |
CodeCompletionBoxCategoryFilterButtonHoveredColorInternalName |
CodeCompletionBoxCategoryFilterButtonHoveredColorName |
CodeCompletionBoxCategoryFilterButtonPressedColorInternalName |
CodeCompletionBoxCategoryFilterButtonPressedColorName |
CodeCompletionBoxCategoryFilterToolbarBackgroundColorInternalName |
CodeCompletionBoxCategoryFilterToolbarBackgroundColorName |
CodeCompletionBoxColorInternalName |
CodeCompletionBoxColorName |
CodeCompletionBoxItemFocusRectangleColorInternalName |
CodeCompletionBoxItemFocusRectangleColorName |
CodeCompletionBoxNoSuggestionsTextColorInternalName |
CodeCompletionBoxNoSuggestionsTextColorName |
CodeCompletionHintColorInternalName |
CodeCompletionHintColorName |
CodeOutlinePenColorInternalName |
CodeOutlinePenColorName |
CodeSnippetsInternalName |
CodeSnippetsName |
CommentsInternalName |
CommentsName |
CommentStyle |
DirectivesInternalName |
DirectivesName |
DirectiveStyle |
FunctionsName |
GutterPenColorInternalName |
GutterPenColorName |
HighlightBlockAreaColorInternalName |
HighlightBlockAreaColorName |
HighlightOutlineAreaColorInternalName |
HighlightOutlineAreaColorName |
HTMLParamsInternalName |
HTMLParamsName |
HyperTextInternalName |
HyperTextName |
IdentsInternalName |
IdentsName |
IdentStyle |
InactiveSelectionInternalName |
InactiveSelectionName |
IncludeInternalName |
IncludeName |
IncludesName |
LineModificatorChangedInternalName |
LineModificatorChangedName |
LineModificatorSavedInternalName |
LineModificatorSavedName |
LineNumbersInternalName |
LineNumbersName |
LineSeparatorInternalName |
LineSeparatorName |
MisspelledWordsInternalName |
MisspelledWordsName |
NewObjectsName |
NumbersInternalName |
NumbersName |
NumberStyle |
ObjectsName |
OperatorsName |
PopupPanelFocusHighlightIndicatorFocusedColorInternalName |
PopupPanelFocusHighlightIndicatorFocusedColorName |
PopupPanelFocusHighlightIndicatorNonFocusedColorInternalName |
PopupPanelFocusHighlightIndicatorNonFocusedColorName |
PopupPanelResizeGripperColorInternalName |
PopupPanelResizeGripperColorName |
ReferencesColorName |
ReswordsInternalName |
ReswordsName |
ReswordStyle |
ScrollBackgroundColorInternalName |
ScrollBackgroundColorName |
SearchResultsColorName |
StringsInternalName |
StringsName |
StringStyle |
SymbolsInternalName |
SymbolsName |
SymbolStyle |
SyntaxErrorsInternalName |
SyntaxErrorsName |
SyntaxErrorStyle |
ThumbHoveredColorInternalName |
ThumbHoveredColorName |
ThumbNormalColorInternalName |
ThumbNormalColorName |
ThumbPressedColorInternalName |
ThumbPressedColorName |
VsControlsButtonHoveredColorInternalName |
VsControlsButtonHoveredColorName |
VsControlsButtonPressedColorInternalName |
VsControlsButtonPressedColorName |
VsControlsControlBackgroundColorInternalName |
VsControlsControlBackgroundColorName |
VsControlsControlTextNormalColorInternalName |
VsControlsControlTextNormalColorName |
VsControlsPopupBorderColorInternalName |
VsControlsPopupBorderColorName |
VsControlsToggleButtonHoveredColorInternalName |
VsControlsToggleButtonHoveredColorName |
VsControlsToggleButtonPressedBorderColorInternalName |
VsControlsToggleButtonPressedBorderColorName |
WhiteSpaceInternalName |
WhiteSpaceName |
WhitespaceStyle |
WindowColorInternalName |
WindowColorName |
XMLCommentsInternalName |
XMLCommentsName |
XmlCommentStyle |
Top
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ActiveSelectionInternalName Field

VisualThemeConstsActiveSelectionInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ActiveSelectionInternalName
Public Shared ActiveSelectionInternalName As String
public:
static String^ ActiveSelectionInternalName
static val mutable ActiveSelectionInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ActiveSelectionName Field

VisualThemeConstsActiveSelectionName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ActiveSelectionName
Public Shared ActiveSelectionName As String
public:
static String^ ActiveSelectionName
static val mutable ActiveSelectionName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.BraceMatchingInternalName Field

VisualThemeConstsBraceMatchingInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string BraceMatchingInternalName
Public Shared BraceMatchingInternalName As String
public:
static String^ BraceMatchingInternalName
static val mutable BraceMatchingInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.BraceMatchingName Field

VisualThemeConstsBraceMatchingName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string BraceMatchingName
Public Shared BraceMatchingName As String
public:
static String^ BraceMatchingName
static val mutable BraceMatchingName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.BracesName Field

VisualThemeConstsBracesName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string BracesName
Public Shared BracesName As String
public:
static String^ BracesName
static val mutable BracesName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxBorderColorInternalName Field

VisualThemeConstsCodeCompletionBoxBorderColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxBorderColorInternalName
Public Shared CodeCompletionBoxBorderColorInternalName As String
public:
static String^ CodeCompletionBoxBorderColorInternalName
static val mutable CodeCompletionBoxBorderColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxBorderColorName Field

VisualThemeConstsCodeCompletionBoxBorderColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxBorderColorName
Public Shared CodeCompletionBoxBorderColorName As String
public:
static String^ CodeCompletionBoxBorderColorName
static val mutable CodeCompletionBoxBorderColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxCategoryFilterButtonHoveredColorInternalName Field

VisualThemeConstsCodeCompletionBoxCategoryFilterButtonHoveredColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxCategoryFilterButtonHoveredColorInternalName
Public Shared CodeCompletionBoxCategoryFilterButtonHoveredColorInternalName As String
public:
static String^ CodeCompletionBoxCategoryFilterButtonHoveredColorInternalName
static val mutable CodeCompletionBoxCategoryFilterButtonHoveredColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxCategoryFilterButtonHoveredColorName Field

VisualThemeConstsCodeCompletionBoxCategoryFilterButtonHoveredColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxCategoryFilterButtonHoveredColorName
Public Shared CodeCompletionBoxCategoryFilterButtonHoveredColorName As String
public:
static String^ CodeCompletionBoxCategoryFilterButtonHoveredColorName
static val mutable CodeCompletionBoxCategoryFilterButtonHoveredColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxCategoryFilterButtonPressedColorInternalName Field

VisualThemeConstsCodeCompletionBoxCategoryFilterButtonPressedColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxCategoryFilterButtonPressedColorInternalName
Public Shared CodeCompletionBoxCategoryFilterButtonPressedColorInternalName As String
public:
static String^ CodeCompletionBoxCategoryFilterButtonPressedColorInternalName
static val mutable CodeCompletionBoxCategoryFilterButtonPressedColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxCategoryFilterButtonPressedColorName Field

VisualThemeConstsCodeCompletionBoxCategoryFilterButtonPressedColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxCategoryFilterButtonPressedColorName
Public Shared CodeCompletionBoxCategoryFilterButtonPressedColorName As String
public:
static String^ CodeCompletionBoxCategoryFilterButtonPressedColorName
static val mutable CodeCompletionBoxCategoryFilterButtonPressedColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxCategoryFilterToolbarBackgroundColorInternalName Field

VisualThemeConstsCodeCompletionBoxCategoryFilterToolbarBackgroundColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxCategoryFilterToolbarBackgroundColorInternalName
Public Shared CodeCompletionBoxCategoryFilterToolbarBackgroundColorInternalName As String
public:
static String^ CodeCompletionBoxCategoryFilterToolbarBackgroundColorInternalName
static val mutable CodeCompletionBoxCategoryFilterToolbarBackgroundColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxCategoryFilterToolbarBackgroundColorName Field

VisualThemeConstsCodeCompletionBoxCategoryFilterToolbarBackgroundColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxCategoryFilterToolbarBackgroundColorName
Public Shared CodeCompletionBoxCategoryFilterToolbarBackgroundColorName As String
public:
static String^ CodeCompletionBoxCategoryFilterToolbarBackgroundColorName
static val mutable CodeCompletionBoxCategoryFilterToolbarBackgroundColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxColorInternalName Field

VisualThemeConstsCodeCompletionBoxColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxColorInternalName
Public Shared CodeCompletionBoxColorInternalName As String
public:
static String^ CodeCompletionBoxColorInternalName
static val mutable CodeCompletionBoxColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxColorName Field

VisualThemeConstsCodeCompletionBoxColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxColorName
Public Shared CodeCompletionBoxColorName As String
public:
static String^ CodeCompletionBoxColorName
static val mutable CodeCompletionBoxColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxItemFocusRectangleColorInternalName Field

VisualThemeConstsCodeCompletionBoxItemFocusRectangleColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxItemFocusRectangleColorInternalName
Public Shared CodeCompletionBoxItemFocusRectangleColorInternalName As String
public:
static String^ CodeCompletionBoxItemFocusRectangleColorInternalName
static val mutable CodeCompletionBoxItemFocusRectangleColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxItemFocusRectangleColorName Field

VisualThemeConstsCodeCompletionBoxItemFocusRectangleColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxItemFocusRectangleColorName
Public Shared CodeCompletionBoxItemFocusRectangleColorName As String
public:
static String^ CodeCompletionBoxItemFocusRectangleColorName
static val mutable CodeCompletionBoxItemFocusRectangleColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxNoSuggestionsTextColorInternalName Field

VisualThemeConstsCodeCompletionBoxNoSuggestionsTextColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxNoSuggestionsTextColorInternalName
Public Shared CodeCompletionBoxNoSuggestionsTextColorInternalName As String
public:
static String^ CodeCompletionBoxNoSuggestionsTextColorInternalName
static val mutable CodeCompletionBoxNoSuggestionsTextColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionBoxNoSuggestionsTextColorName Field

VisualThemeConstsCodeCompletionBoxNoSuggestionsTextColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionBoxNoSuggestionsTextColorName
Public Shared CodeCompletionBoxNoSuggestionsTextColorName As String
public:
static String^ CodeCompletionBoxNoSuggestionsTextColorName
static val mutable CodeCompletionBoxNoSuggestionsTextColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionHintColorInternalName Field

VisualThemeConstsCodeCompletionHintColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionHintColorInternalName
Public Shared CodeCompletionHintColorInternalName As String
public:
static String^ CodeCompletionHintColorInternalName
static val mutable CodeCompletionHintColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeCompletionHintColorName Field

VisualThemeConstsCodeCompletionHintColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeCompletionHintColorName
Public Shared CodeCompletionHintColorName As String
public:
static String^ CodeCompletionHintColorName
static val mutable CodeCompletionHintColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeOutlinePenColorInternalName Field

VisualThemeConstsCodeOutlinePenColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeOutlinePenColorInternalName
Public Shared CodeOutlinePenColorInternalName As String
public:
static String^ CodeOutlinePenColorInternalName
static val mutable CodeOutlinePenColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeOutlinePenColorName Field

VisualThemeConstsCodeOutlinePenColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeOutlinePenColorName
Public Shared CodeOutlinePenColorName As String
public:
static String^ CodeOutlinePenColorName
static val mutable CodeOutlinePenColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeSnippetsInternalName Field

VisualThemeConstsCodeSnippetsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeSnippetsInternalName
Public Shared CodeSnippetsInternalName As String
public:
static String^ CodeSnippetsInternalName
static val mutable CodeSnippetsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CodeSnippetsName Field

VisualThemeConstsCodeSnippetsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CodeSnippetsName
Public Shared CodeSnippetsName As String
public:
static String^ CodeSnippetsName
static val mutable CodeSnippetsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CommentsInternalName Field

VisualThemeConstsCommentsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CommentsInternalName
Public Shared CommentsInternalName As String
public:
static String^ CommentsInternalName
static val mutable CommentsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CommentsName Field

VisualThemeConstsCommentsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CommentsName
Public Shared CommentsName As String
public:
static String^ CommentsName
static val mutable CommentsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.CommentStyle Field

VisualThemeConstsCommentStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CommentStyle
Public Shared CommentStyle As String
public:
static String^ CommentStyle
static val mutable CommentStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.DirectivesInternalName Field

VisualThemeConstsDirectivesInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DirectivesInternalName
Public Shared DirectivesInternalName As String
public:
static String^ DirectivesInternalName
static val mutable DirectivesInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.DirectivesName Field

VisualThemeConstsDirectivesName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DirectivesName
Public Shared DirectivesName As String
public:
static String^ DirectivesName
static val mutable DirectivesName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.DirectiveStyle Field

VisualThemeConstsDirectiveStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DirectiveStyle
Public Shared DirectiveStyle As String
public:
static String^ DirectiveStyle
static val mutable DirectiveStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.FunctionsName Field

VisualThemeConstsFunctionsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FunctionsName
Public Shared FunctionsName As String
public:
static String^ FunctionsName
static val mutable FunctionsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.GutterPenColorInternalName Field

VisualThemeConstsGutterPenColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GutterPenColorInternalName
Public Shared GutterPenColorInternalName As String
public:
static String^ GutterPenColorInternalName
static val mutable GutterPenColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.GutterPenColorName Field

VisualThemeConstsGutterPenColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GutterPenColorName
Public Shared GutterPenColorName As String
public:
static String^ GutterPenColorName
static val mutable GutterPenColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.HighlightBlockAreaColorInternalName Field

VisualThemeConstsHighlightBlockAreaColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HighlightBlockAreaColorInternalName
Public Shared HighlightBlockAreaColorInternalName As String
public:
static String^ HighlightBlockAreaColorInternalName
static val mutable HighlightBlockAreaColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.HighlightBlockAreaColorName Field

VisualThemeConstsHighlightBlockAreaColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HighlightBlockAreaColorName
Public Shared HighlightBlockAreaColorName As String
public:
static String^ HighlightBlockAreaColorName
static val mutable HighlightBlockAreaColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.HighlightOutlineAreaColorInternalName Field

VisualThemeConstsHighlightOutlineAreaColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HighlightOutlineAreaColorInternalName
Public Shared HighlightOutlineAreaColorInternalName As String
public:
static String^ HighlightOutlineAreaColorInternalName
static val mutable HighlightOutlineAreaColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.HighlightOutlineAreaColorName Field

VisualThemeConstsHighlightOutlineAreaColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HighlightOutlineAreaColorName
Public Shared HighlightOutlineAreaColorName As String
public:
static String^ HighlightOutlineAreaColorName
static val mutable HighlightOutlineAreaColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.HTMLParamsInternalName Field

VisualThemeConstsHTMLParamsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HTMLParamsInternalName
Public Shared HTMLParamsInternalName As String
public:
static String^ HTMLParamsInternalName
static val mutable HTMLParamsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.HTMLParamsName Field

VisualThemeConstsHTMLParamsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HTMLParamsName
Public Shared HTMLParamsName As String
public:
static String^ HTMLParamsName
static val mutable HTMLParamsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.HyperTextInternalName Field

VisualThemeConstsHyperTextInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HyperTextInternalName
Public Shared HyperTextInternalName As String
public:
static String^ HyperTextInternalName
static val mutable HyperTextInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.HyperTextName Field

VisualThemeConstsHyperTextName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string HyperTextName
Public Shared HyperTextName As String
public:
static String^ HyperTextName
static val mutable HyperTextName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.IdentsInternalName Field

VisualThemeConstsIdentsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string IdentsInternalName
Public Shared IdentsInternalName As String
public:
static String^ IdentsInternalName
static val mutable IdentsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.IdentsName Field

VisualThemeConstsIdentsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string IdentsName
Public Shared IdentsName As String
public:
static String^ IdentsName
static val mutable IdentsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.IdentStyle Field

VisualThemeConstsIdentStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string IdentStyle
Public Shared IdentStyle As String
public:
static String^ IdentStyle
static val mutable IdentStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.InactiveSelectionInternalName Field

VisualThemeConstsInactiveSelectionInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InactiveSelectionInternalName
Public Shared InactiveSelectionInternalName As String
public:
static String^ InactiveSelectionInternalName
static val mutable InactiveSelectionInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.InactiveSelectionName Field

VisualThemeConstsInactiveSelectionName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InactiveSelectionName
Public Shared InactiveSelectionName As String
public:
static String^ InactiveSelectionName
static val mutable InactiveSelectionName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.IncludeInternalName Field

VisualThemeConstsIncludeInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string IncludeInternalName
Public Shared IncludeInternalName As String
public:
static String^ IncludeInternalName
static val mutable IncludeInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.IncludeName Field

VisualThemeConstsIncludeName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string IncludeName
Public Shared IncludeName As String
public:
static String^ IncludeName
static val mutable IncludeName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.IncludesName Field

VisualThemeConstsIncludesName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string IncludesName
Public Shared IncludesName As String
public:
static String^ IncludesName
static val mutable IncludesName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.LineModificatorChangedInternalName Field

VisualThemeConstsLineModificatorChangedInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineModificatorChangedInternalName
Public Shared LineModificatorChangedInternalName As String
public:
static String^ LineModificatorChangedInternalName
static val mutable LineModificatorChangedInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.LineModificatorChangedName Field

VisualThemeConstsLineModificatorChangedName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineModificatorChangedName
Public Shared LineModificatorChangedName As String
public:
static String^ LineModificatorChangedName
static val mutable LineModificatorChangedName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.LineModificatorSavedInternalName Field

VisualThemeConstsLineModificatorSavedInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineModificatorSavedInternalName
Public Shared LineModificatorSavedInternalName As String
public:
static String^ LineModificatorSavedInternalName
static val mutable LineModificatorSavedInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.LineModificatorSavedName Field

VisualThemeConstsLineModificatorSavedName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineModificatorSavedName
Public Shared LineModificatorSavedName As String
public:
static String^ LineModificatorSavedName
static val mutable LineModificatorSavedName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.LineNumbersInternalName Field

VisualThemeConstsLineNumbersInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineNumbersInternalName
Public Shared LineNumbersInternalName As String
public:
static String^ LineNumbersInternalName
static val mutable LineNumbersInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.LineNumbersName Field

VisualThemeConstsLineNumbersName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineNumbersName
Public Shared LineNumbersName As String
public:
static String^ LineNumbersName
static val mutable LineNumbersName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.LineSeparatorInternalName Field

VisualThemeConstsLineSeparatorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineSeparatorInternalName
Public Shared LineSeparatorInternalName As String
public:
static String^ LineSeparatorInternalName
static val mutable LineSeparatorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.LineSeparatorName Field

VisualThemeConstsLineSeparatorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LineSeparatorName
Public Shared LineSeparatorName As String
public:
static String^ LineSeparatorName
static val mutable LineSeparatorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.MisspelledWordsInternalName Field

VisualThemeConstsMisspelledWordsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MisspelledWordsInternalName
Public Shared MisspelledWordsInternalName As String
public:
static String^ MisspelledWordsInternalName
static val mutable MisspelledWordsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.MisspelledWordsName Field

VisualThemeConstsMisspelledWordsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MisspelledWordsName
Public Shared MisspelledWordsName As String
public:
static String^ MisspelledWordsName
static val mutable MisspelledWordsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.NewObjectsName Field

VisualThemeConstsNewObjectsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NewObjectsName
Public Shared NewObjectsName As String
public:
static String^ NewObjectsName
static val mutable NewObjectsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.NumbersInternalName Field

VisualThemeConstsNumbersInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NumbersInternalName
Public Shared NumbersInternalName As String
public:
static String^ NumbersInternalName
static val mutable NumbersInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.NumbersName Field

VisualThemeConstsNumbersName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NumbersName
Public Shared NumbersName As String
public:
static String^ NumbersName
static val mutable NumbersName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.NumberStyle Field

VisualThemeConstsNumberStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NumberStyle
Public Shared NumberStyle As String
public:
static String^ NumberStyle
static val mutable NumberStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ObjectsName Field

VisualThemeConstsObjectsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ObjectsName
Public Shared ObjectsName As String
public:
static String^ ObjectsName
static val mutable ObjectsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.OperatorsName Field

VisualThemeConstsOperatorsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OperatorsName
Public Shared OperatorsName As String
public:
static String^ OperatorsName
static val mutable OperatorsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.PopupPanelFocusHighlightIndicatorFocusedColorInternalName Field

VisualThemeConstsPopupPanelFocusHighlightIndicatorFocusedColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PopupPanelFocusHighlightIndicatorFocusedColorInternalName
Public Shared PopupPanelFocusHighlightIndicatorFocusedColorInternalName As String
public:
static String^ PopupPanelFocusHighlightIndicatorFocusedColorInternalName
static val mutable PopupPanelFocusHighlightIndicatorFocusedColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.PopupPanelFocusHighlightIndicatorFocusedColorName Field

VisualThemeConstsPopupPanelFocusHighlightIndicatorFocusedColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PopupPanelFocusHighlightIndicatorFocusedColorName
Public Shared PopupPanelFocusHighlightIndicatorFocusedColorName As String
public:
static String^ PopupPanelFocusHighlightIndicatorFocusedColorName
static val mutable PopupPanelFocusHighlightIndicatorFocusedColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.PopupPanelFocusHighlightIndicatorNonFocusedColorInternalName Field

VisualThemeConstsPopupPanelFocusHighlightIndicatorNonFocusedColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PopupPanelFocusHighlightIndicatorNonFocusedColorInternalName
Public Shared PopupPanelFocusHighlightIndicatorNonFocusedColorInternalName As String
public:
static String^ PopupPanelFocusHighlightIndicatorNonFocusedColorInternalName
static val mutable PopupPanelFocusHighlightIndicatorNonFocusedColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.PopupPanelFocusHighlightIndicatorNonFocusedColorName Field

VisualThemeConstsPopupPanelFocusHighlightIndicatorNonFocusedColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PopupPanelFocusHighlightIndicatorNonFocusedColorName
Public Shared PopupPanelFocusHighlightIndicatorNonFocusedColorName As String
public:
static String^ PopupPanelFocusHighlightIndicatorNonFocusedColorName
static val mutable PopupPanelFocusHighlightIndicatorNonFocusedColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.PopupPanelResizeGripperColorInternalName Field

VisualThemeConstsPopupPanelResizeGripperColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PopupPanelResizeGripperColorInternalName
Public Shared PopupPanelResizeGripperColorInternalName As String
public:
static String^ PopupPanelResizeGripperColorInternalName
static val mutable PopupPanelResizeGripperColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.PopupPanelResizeGripperColorName Field

VisualThemeConstsPopupPanelResizeGripperColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string PopupPanelResizeGripperColorName
Public Shared PopupPanelResizeGripperColorName As String
public:
static String^ PopupPanelResizeGripperColorName
static val mutable PopupPanelResizeGripperColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ReferencesColorName Field

VisualThemeConstsReferencesColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReferencesColorName
Public Shared ReferencesColorName As String
public:
static String^ ReferencesColorName
static val mutable ReferencesColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ReswordsInternalName Field

VisualThemeConstsReswordsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReswordsInternalName
Public Shared ReswordsInternalName As String
public:
static String^ ReswordsInternalName
static val mutable ReswordsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ReswordsName Field

VisualThemeConstsReswordsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReswordsName
Public Shared ReswordsName As String
public:
static String^ ReswordsName
static val mutable ReswordsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ReswordStyle Field

VisualThemeConstsReswordStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ReswordStyle
Public Shared ReswordStyle As String
public:
static String^ ReswordStyle
static val mutable ReswordStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ScrollBackgroundColorInternalName Field

VisualThemeConstsScrollBackgroundColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ScrollBackgroundColorInternalName
Public Shared ScrollBackgroundColorInternalName As String
public:
static String^ ScrollBackgroundColorInternalName
static val mutable ScrollBackgroundColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ScrollBackgroundColorName Field

VisualThemeConstsScrollBackgroundColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ScrollBackgroundColorName
Public Shared ScrollBackgroundColorName As String
public:
static String^ ScrollBackgroundColorName
static val mutable ScrollBackgroundColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.SearchResultsColorName Field

VisualThemeConstsSearchResultsColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SearchResultsColorName
Public Shared SearchResultsColorName As String
public:
static String^ SearchResultsColorName
static val mutable SearchResultsColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.StringsInternalName Field

VisualThemeConstsStringsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StringsInternalName
Public Shared StringsInternalName As String
public:
static String^ StringsInternalName
static val mutable StringsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.StringsName Field

VisualThemeConstsStringsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StringsName
Public Shared StringsName As String
public:
static String^ StringsName
static val mutable StringsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.StringStyle Field

VisualThemeConstsStringStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StringStyle
Public Shared StringStyle As String
public:
static String^ StringStyle
static val mutable StringStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.SymbolsInternalName Field

VisualThemeConstsSymbolsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SymbolsInternalName
Public Shared SymbolsInternalName As String
public:
static String^ SymbolsInternalName
static val mutable SymbolsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.SymbolsName Field

VisualThemeConstsSymbolsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SymbolsName
Public Shared SymbolsName As String
public:
static String^ SymbolsName
static val mutable SymbolsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.SymbolStyle Field

VisualThemeConstsSymbolStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SymbolStyle
Public Shared SymbolStyle As String
public:
static String^ SymbolStyle
static val mutable SymbolStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.SyntaxErrorsInternalName Field

VisualThemeConstsSyntaxErrorsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SyntaxErrorsInternalName
Public Shared SyntaxErrorsInternalName As String
public:
static String^ SyntaxErrorsInternalName
static val mutable SyntaxErrorsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.SyntaxErrorsName Field

VisualThemeConstsSyntaxErrorsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SyntaxErrorsName
Public Shared SyntaxErrorsName As String
public:
static String^ SyntaxErrorsName
static val mutable SyntaxErrorsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.SyntaxErrorStyle Field

VisualThemeConstsSyntaxErrorStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SyntaxErrorStyle
Public Shared SyntaxErrorStyle As String
public:
static String^ SyntaxErrorStyle
static val mutable SyntaxErrorStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ThumbHoveredColorInternalName Field

VisualThemeConstsThumbHoveredColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ThumbHoveredColorInternalName
Public Shared ThumbHoveredColorInternalName As String
public:
static String^ ThumbHoveredColorInternalName
static val mutable ThumbHoveredColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ThumbHoveredColorName Field

VisualThemeConstsThumbHoveredColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ThumbHoveredColorName
Public Shared ThumbHoveredColorName As String
public:
static String^ ThumbHoveredColorName
static val mutable ThumbHoveredColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ThumbNormalColorInternalName Field

VisualThemeConstsThumbNormalColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ThumbNormalColorInternalName
Public Shared ThumbNormalColorInternalName As String
public:
static String^ ThumbNormalColorInternalName
static val mutable ThumbNormalColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ThumbNormalColorName Field

VisualThemeConstsThumbNormalColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ThumbNormalColorName
Public Shared ThumbNormalColorName As String
public:
static String^ ThumbNormalColorName
static val mutable ThumbNormalColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ThumbPressedColorInternalName Field

VisualThemeConstsThumbPressedColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ThumbPressedColorInternalName
Public Shared ThumbPressedColorInternalName As String
public:
static String^ ThumbPressedColorInternalName
static val mutable ThumbPressedColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.ThumbPressedColorName Field

VisualThemeConstsThumbPressedColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ThumbPressedColorName
Public Shared ThumbPressedColorName As String
public:
static String^ ThumbPressedColorName
static val mutable ThumbPressedColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsButtonHoveredColorInternalName Field

VisualThemeConstsVsControlsButtonHoveredColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsButtonHoveredColorInternalName
Public Shared VsControlsButtonHoveredColorInternalName As String
public:
static String^ VsControlsButtonHoveredColorInternalName
static val mutable VsControlsButtonHoveredColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsButtonHoveredColorName Field

VisualThemeConstsVsControlsButtonHoveredColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsButtonHoveredColorName
Public Shared VsControlsButtonHoveredColorName As String
public:
static String^ VsControlsButtonHoveredColorName
static val mutable VsControlsButtonHoveredColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsButtonPressedColorInternalName Field

VisualThemeConstsVsControlsButtonPressedColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsButtonPressedColorInternalName
Public Shared VsControlsButtonPressedColorInternalName As String
public:
static String^ VsControlsButtonPressedColorInternalName
static val mutable VsControlsButtonPressedColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsButtonPressedColorName Field

VisualThemeConstsVsControlsButtonPressedColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsButtonPressedColorName
Public Shared VsControlsButtonPressedColorName As String
public:
static String^ VsControlsButtonPressedColorName
static val mutable VsControlsButtonPressedColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsControlBackgroundColorInternalName Field

VisualThemeConstsVsControlsControlBackgroundColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsControlBackgroundColorInternalName
Public Shared VsControlsControlBackgroundColorInternalName As String
public:
static String^ VsControlsControlBackgroundColorInternalName
static val mutable VsControlsControlBackgroundColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsControlBackgroundColorName Field

VisualThemeConstsVsControlsControlBackgroundColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsControlBackgroundColorName
Public Shared VsControlsControlBackgroundColorName As String
public:
static String^ VsControlsControlBackgroundColorName
static val mutable VsControlsControlBackgroundColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsControlTextNormalColorInternalName Field

VisualThemeConstsVsControlsControlTextNormalColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsControlTextNormalColorInternalName
Public Shared VsControlsControlTextNormalColorInternalName As String
public:
static String^ VsControlsControlTextNormalColorInternalName
static val mutable VsControlsControlTextNormalColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsControlTextNormalColorName Field

VisualThemeConstsVsControlsControlTextNormalColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsControlTextNormalColorName
Public Shared VsControlsControlTextNormalColorName As String
public:
static String^ VsControlsControlTextNormalColorName
static val mutable VsControlsControlTextNormalColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsPopupBorderColorInternalName Field

VisualThemeConstsVsControlsPopupBorderColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsPopupBorderColorInternalName
Public Shared VsControlsPopupBorderColorInternalName As String
public:
static String^ VsControlsPopupBorderColorInternalName
static val mutable VsControlsPopupBorderColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsPopupBorderColorName Field

VisualThemeConstsVsControlsPopupBorderColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsPopupBorderColorName
Public Shared VsControlsPopupBorderColorName As String
public:
static String^ VsControlsPopupBorderColorName
static val mutable VsControlsPopupBorderColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsToggleButtonHoveredColorInternalName Field

VisualThemeConstsVsControlsToggleButtonHoveredColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsToggleButtonHoveredColorInternalName
Public Shared VsControlsToggleButtonHoveredColorInternalName As String
public:
static String^ VsControlsToggleButtonHoveredColorInternalName
static val mutable VsControlsToggleButtonHoveredColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsToggleButtonHoveredColorName Field

VisualThemeConstsVsControlsToggleButtonHoveredColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsToggleButtonHoveredColorName
Public Shared VsControlsToggleButtonHoveredColorName As String
public:
static String^ VsControlsToggleButtonHoveredColorName
static val mutable VsControlsToggleButtonHoveredColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsToggleButtonPressedBorderColorInternalName Field

VisualThemeConstsVsControlsToggleButtonPressedBorderColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsToggleButtonPressedBorderColorInternalName
Public Shared VsControlsToggleButtonPressedBorderColorInternalName As String
public:
static String^ VsControlsToggleButtonPressedBorderColorInternalName
static val mutable VsControlsToggleButtonPressedBorderColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.VsControlsToggleButtonPressedBorderColorName Field

VisualThemeConstsVsControlsToggleButtonPressedBorderColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VsControlsToggleButtonPressedBorderColorName
Public Shared VsControlsToggleButtonPressedBorderColorName As String
public:
static String^ VsControlsToggleButtonPressedBorderColorName
static val mutable VsControlsToggleButtonPressedBorderColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.WhiteSpaceInternalName Field

VisualThemeConstsWhiteSpaceInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WhiteSpaceInternalName
Public Shared WhiteSpaceInternalName As String
public:
static String^ WhiteSpaceInternalName
static val mutable WhiteSpaceInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.WhiteSpaceName Field

VisualThemeConstsWhiteSpaceName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WhiteSpaceName
Public Shared WhiteSpaceName As String
public:
static String^ WhiteSpaceName
static val mutable WhiteSpaceName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.WhitespaceStyle Field

VisualThemeConstsWhitespaceStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WhitespaceStyle
Public Shared WhitespaceStyle As String
public:
static String^ WhitespaceStyle
static val mutable WhitespaceStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.WindowColorInternalName Field

VisualThemeConstsWindowColorInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WindowColorInternalName
Public Shared WindowColorInternalName As String
public:
static String^ WindowColorInternalName
static val mutable WindowColorInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.WindowColorName Field

VisualThemeConstsWindowColorName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string WindowColorName
Public Shared WindowColorName As String
public:
static String^ WindowColorName
static val mutable WindowColorName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.XMLCommentsInternalName Field

VisualThemeConstsXMLCommentsInternalName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XMLCommentsInternalName
Public Shared XMLCommentsInternalName As String
public:
static String^ XMLCommentsInternalName
static val mutable XMLCommentsInternalName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.XMLCommentsName Field

VisualThemeConstsXMLCommentsName Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XMLCommentsName
Public Shared XMLCommentsName As String
public:
static String^ XMLCommentsName
static val mutable XMLCommentsName: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts.XmlCommentStyle Field

VisualThemeConstsXmlCommentStyle Field

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XmlCommentStyle
Public Shared XmlCommentStyle As String
public:
static String^ XmlCommentStyle
static val mutable XmlCommentStyle: string

Field Value

Type: String
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeConsts Methods

VisualThemeConsts Methods

The VisualThemeConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisualThemeConsts Class
Alternet.Editor Namespace


VisualThemeImagesColor Enumeration

VisualThemeImagesColor Enumeration

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VisualThemeImagesColor
Public Enumeration VisualThemeImagesColor
public enum class VisualThemeImagesColor
type VisualThemeImagesColor
Members
Member name | Value | Description
Light | 0 |
Dark | 1 |
See Also

Reference

Alternet.Editor Namespace


VisualThemeType Enumeration

VisualThemeType Enumeration
Specifies Visual Theme type

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VisualThemeType
Public Enumeration VisualThemeType
public enum class VisualThemeType
type VisualThemeType
Members
Member name | Value | Description
None | 0 |
Light | 1 |
Dark | 2 |
Custom | 3 |
See Also

Reference

Alternet.Editor Namespace


WhiteSpace Class

WhiteSpace Class
Represents properties of "invisible" characters, such as spaces and tabs, in the control's text content.
Inheritance Hierarchy
SystemObject
Alternet.EditorWhiteSpace

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WhiteSpace : IWhiteSpace, IUpdate
Public Class WhiteSpace
    Implements IWhiteSpace, IUpdate
public ref class WhiteSpace : IWhiteSpace,
    IUpdate
type WhiteSpace =
    class
        interface IWhiteSpace
        interface IUpdate
    end

The WhiteSpace type exposes the following members.

Constructors
 | Name | Description
Public method | WhiteSpace | Initializes a new instance of the WhiteSpace class with default settings.
Public method | WhiteSpace(ISyntaxEdit) | Initializes a new instance of the WhiteSpace class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents from another IWhiteSpace object.
Public method | BeginUpdate | Prevents WhiteSpace updating until calling WhiteSpace.EndUpdate method.
Public method | DisableUpdate | Prevents WhiteSpace updating until calling WhiteSpace.EndUpdate method.
Public method | EnableUpdate | Re-enables WhiteSpace updating, that was turn of by calling Margin.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling WhiteSpace.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetEofSymbol | Resets the EofSymbol to the default value.
Public method | ResetEolSymbol | Resets the EolSymbol to the default value.
Public method | ResetLongSpaceSymbol | Resets the LongSpaceSymbol to the default value.
Public method | ResetSpaceSymbol | Resets the SpaceSymbol to the default value.
Public method | ResetSymbolColor | Resets the SymbolColor to the default value.
Public method | ResetTabSymbol | Resets the TabSymbol to the default value.
Public method | ResetVisible | Resets the Visible to the default value.
Public method | ResetWordWrapSymbol | Resets the WordWrapSymbol to the default value.
Public method | ShouldSerializeEofSymbol | Indicates whether the EofSymbol property should be persisted.
Public method | ShouldSerializeEolSymbol | Indicates whether the EolSymbol property should be persisted.
Public method | ShouldSerializeLongSpaceSymbol | Indicates whether the LongSpaceSymbol property should be persisted.
Public method | ShouldSerializeSpaceSymbol | Indicates whether the SpaceSymbol property should be persisted.
Public method | ShouldSerializeSymbolColor | Indicates whether the SymbolColor property should be persisted.
Public method | ShouldSerializeTabSymbol | Indicates whether the TabSymbol property should be persisted.
Public method | ShouldSerializeWordWrapSymbol | Indicates whether the WordWrapSymbol property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Invalidates editor if needed.
Top
Properties
 | Name | Description
Public property | EofString | Represents one character string that specifies end of file.
Public property | EofSymbol | Gets or sets character that specifies end of file.
Public property | EolString | Represents one character string that specifies end of line.
Public property | EolSymbol | Gets or sets character that specifies end of line.
Public property | LongSpaceString | Represents one character string that introduces special symbol to paint instead of the long space character.
Public property | LongSpaceSymbol | Gets or sets character that introduces special symbol to paint instead of the long space character.
Public property | SpaceString | Represents one character string that introduces special symbol to paint instead of the space character.
Public property | SpaceSymbol | Gets or sets character that introduces special symbol to paint instead of the space character.
Public property | SymbolColor | Gets or sets color used to paint special symbols.
Public property | TabString | Represents one character string that introduces special symbol to paint instead of the tab character.
Public property | TabSymbol | Gets or sets character that introduces special symbol to paint instead of the tab character.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | Visible | Gets or sets a value indicating whether white space symbols are visible in the control's text content.
Public property | WordWrapString | Represents one character string that specifies wrapped file.
Public property | WordWrapSymbol | Gets or sets character that specifies wrapped line.
Top
See Also

Reference

Alternet.Editor Namespace


WhiteSpace Constructor

WhiteSpace Constructor
Overload List
 | Name | Description
Public method | WhiteSpace | Initializes a new instance of the WhiteSpace class with default settings.
Public method | WhiteSpace(ISyntaxEdit) | Initializes a new instance of the WhiteSpace class with specified owner.
Top
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace Constructor

WhiteSpace Constructor
Initializes a new instance of the WhiteSpace class with default settings.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public WhiteSpace()
Public Sub New
public:
WhiteSpace()
new : unit -> WhiteSpace
See Also

Reference

WhiteSpace Class
WhiteSpace Overload
Alternet.Editor Namespace


WhiteSpace Constructor (ISyntaxEdit)

WhiteSpace Constructor (ISyntaxEdit)
Initializes a new instance of the WhiteSpace class with specified owner.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public WhiteSpace(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
WhiteSpace(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> WhiteSpace

Parameters

owner
Type: Alternet.EditorISyntaxEdit
ISyntaxEdit that owns this new instance.
See Also

Reference

WhiteSpace Class
WhiteSpace Overload
Alternet.Editor Namespace


WhiteSpace Methods

WhiteSpace Methods

The WhiteSpace type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents from another IWhiteSpace object.
Public method | BeginUpdate | Prevents WhiteSpace updating until calling WhiteSpace.EndUpdate method.
Public method | DisableUpdate | Prevents WhiteSpace updating until calling WhiteSpace.EndUpdate method.
Public method | EnableUpdate | Re-enables WhiteSpace updating, that was turn of by calling Margin.BeginUpdate method.
Public method | EndUpdate | Re-enables page updating, that was turn of by calling WhiteSpace.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetEofSymbol | Resets the EofSymbol to the default value.
Public method | ResetEolSymbol | Resets the EolSymbol to the default value.
Public method | ResetLongSpaceSymbol | Resets the LongSpaceSymbol to the default value.
Public method | ResetSpaceSymbol | Resets the SpaceSymbol to the default value.
Public method | ResetSymbolColor | Resets the SymbolColor to the default value.
Public method | ResetTabSymbol | Resets the TabSymbol to the default value.
Public method | ResetVisible | Resets the Visible to the default value.
Public method | ResetWordWrapSymbol | Resets the WordWrapSymbol to the default value.
Public method | ShouldSerializeEofSymbol | Indicates whether the EofSymbol property should be persisted.
Public method | ShouldSerializeEolSymbol | Indicates whether the EolSymbol property should be persisted.
Public method | ShouldSerializeLongSpaceSymbol | Indicates whether the LongSpaceSymbol property should be persisted.
Public method | ShouldSerializeSpaceSymbol | Indicates whether the SpaceSymbol property should be persisted.
Public method | ShouldSerializeSymbolColor | Indicates whether the SymbolColor property should be persisted.
Public method | ShouldSerializeTabSymbol | Indicates whether the TabSymbol property should be persisted.
Public method | ShouldSerializeWordWrapSymbol | Indicates whether the WordWrapSymbol property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Invalidates editor if needed.
Top
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.Assign Method

WhiteSpaceAssign Method
Copies the contents from another IWhiteSpace object.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IWhiteSpace source
)
Public Overridable Sub Assign (
    source As IWhiteSpace
)
public:
virtual void Assign(
    IWhiteSpace^ source
)
abstract Assign :
        source : IWhiteSpace -> unit
override Assign :
        source : IWhiteSpace -> unit

Parameters

source
Type: Alternet.EditorIWhiteSpace
Specifies IWhiteSpace to assign.

Implements

IWhiteSpaceAssign(IWhiteSpace)
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.BeginUpdate Method

WhiteSpaceBeginUpdate Method
Prevents WhiteSpace updating until calling WhiteSpace.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of WhiteSpace updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.DisableUpdate Method

WhiteSpaceDisableUpdate Method
Prevents WhiteSpace updating until calling WhiteSpace.EndUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.EnableUpdate Method

WhiteSpaceEnableUpdate Method
Re-enables WhiteSpace updating, that was turn of by calling Margin.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of Margin updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.EndUpdate Method

WhiteSpaceEndUpdate Method
Re-enables page updating, that was turn of by calling WhiteSpace.BeginUpdate method.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of WhiteSpace updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ResetEofSymbol Method

WhiteSpaceResetEofSymbol Method
Resets the EofSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetEofSymbol()
Public Overridable Sub ResetEofSymbol
public:
virtual void ResetEofSymbol()
abstract ResetEofSymbol : unit -> unit
override ResetEofSymbol : unit -> unit

Implements

IWhiteSpaceResetEofSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ResetEolSymbol Method

WhiteSpaceResetEolSymbol Method
Resets the EolSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetEolSymbol()
Public Overridable Sub ResetEolSymbol
public:
virtual void ResetEolSymbol()
abstract ResetEolSymbol : unit -> unit
override ResetEolSymbol : unit -> unit

Implements

IWhiteSpaceResetEolSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ResetLongSpaceSymbol Method

WhiteSpaceResetLongSpaceSymbol Method
Resets the LongSpaceSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetLongSpaceSymbol()
Public Overridable Sub ResetLongSpaceSymbol
public:
virtual void ResetLongSpaceSymbol()
abstract ResetLongSpaceSymbol : unit -> unit
override ResetLongSpaceSymbol : unit -> unit
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ResetSpaceSymbol Method

WhiteSpaceResetSpaceSymbol Method
Resets the SpaceSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSpaceSymbol()
Public Overridable Sub ResetSpaceSymbol
public:
virtual void ResetSpaceSymbol()
abstract ResetSpaceSymbol : unit -> unit
override ResetSpaceSymbol : unit -> unit

Implements

IWhiteSpaceResetSpaceSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ResetSymbolColor Method

WhiteSpaceResetSymbolColor Method
Resets the SymbolColor to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSymbolColor()
Public Overridable Sub ResetSymbolColor
public:
virtual void ResetSymbolColor()
abstract ResetSymbolColor : unit -> unit
override ResetSymbolColor : unit -> unit

Implements

IWhiteSpaceResetSymbolColor
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ResetTabSymbol Method

WhiteSpaceResetTabSymbol Method
Resets the TabSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetTabSymbol()
Public Overridable Sub ResetTabSymbol
public:
virtual void ResetTabSymbol()
abstract ResetTabSymbol : unit -> unit
override ResetTabSymbol : unit -> unit

Implements

IWhiteSpaceResetTabSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ResetVisible Method

WhiteSpaceResetVisible Method
Resets the Visible to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetVisible()
Public Overridable Sub ResetVisible
public:
virtual void ResetVisible()
abstract ResetVisible : unit -> unit
override ResetVisible : unit -> unit

Implements

IWhiteSpaceResetVisible
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ResetWordWrapSymbol Method

WhiteSpaceResetWordWrapSymbol Method
Resets the WordWrapSymbol to the default value.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetWordWrapSymbol()
Public Overridable Sub ResetWordWrapSymbol
public:
virtual void ResetWordWrapSymbol()
abstract ResetWordWrapSymbol : unit -> unit
override ResetWordWrapSymbol : unit -> unit

Implements

IWhiteSpaceResetWordWrapSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ShouldSerializeEofSymbol Method

WhiteSpaceShouldSerializeEofSymbol Method
Indicates whether the EofSymbol property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeEofSymbol()
Public Function ShouldSerializeEofSymbol As Boolean
public:
bool ShouldSerializeEofSymbol()
member ShouldSerializeEofSymbol : unit -> bool

Return Value

Type: Boolean
True if EofSymbol differs from its default value; otherwise false.
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ShouldSerializeEolSymbol Method

WhiteSpaceShouldSerializeEolSymbol Method
Indicates whether the EolSymbol property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeEolSymbol()
Public Function ShouldSerializeEolSymbol As Boolean
public:
bool ShouldSerializeEolSymbol()
member ShouldSerializeEolSymbol : unit -> bool

Return Value

Type: Boolean
True if EolSymbol differs from its default value; otherwise false.
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ShouldSerializeLongSpaceSymbol Method

WhiteSpaceShouldSerializeLongSpaceSymbol Method
Indicates whether the LongSpaceSymbol property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLongSpaceSymbol()
Public Function ShouldSerializeLongSpaceSymbol As Boolean
public:
bool ShouldSerializeLongSpaceSymbol()
member ShouldSerializeLongSpaceSymbol : unit -> bool

Return Value

Type: Boolean
True if LongSpaceSymbol differs from its default value; otherwise false.
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ShouldSerializeSpaceSymbol Method

WhiteSpaceShouldSerializeSpaceSymbol Method
Indicates whether the SpaceSymbol property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeSpaceSymbol()
Public Function ShouldSerializeSpaceSymbol As Boolean
public:
bool ShouldSerializeSpaceSymbol()
member ShouldSerializeSpaceSymbol : unit -> bool

Return Value

Type: Boolean
True if SpaceSymbol differs from its default value; otherwise false.
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ShouldSerializeSymbolColor Method

WhiteSpaceShouldSerializeSymbolColor Method
Indicates whether the SymbolColor property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeSymbolColor()
Public Function ShouldSerializeSymbolColor As Boolean
public:
bool ShouldSerializeSymbolColor()
member ShouldSerializeSymbolColor : unit -> bool

Return Value

Type: Boolean
True if SymbolColor differs from its default value; otherwise false.
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ShouldSerializeTabSymbol Method

WhiteSpaceShouldSerializeTabSymbol Method
Indicates whether the TabSymbol property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeTabSymbol()
Public Function ShouldSerializeTabSymbol As Boolean
public:
bool ShouldSerializeTabSymbol()
member ShouldSerializeTabSymbol : unit -> bool

Return Value

Type: Boolean
True if TabSymbol differs from its default value; otherwise false.
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.ShouldSerializeWordWrapSymbol Method

WhiteSpaceShouldSerializeWordWrapSymbol Method
Indicates whether the WordWrapSymbol property should be persisted.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeWordWrapSymbol()
Public Function ShouldSerializeWordWrapSymbol As Boolean
public:
bool ShouldSerializeWordWrapSymbol()
member ShouldSerializeWordWrapSymbol : unit -> bool

Return Value

Type: Boolean
True if WordWrapSymbol differs from its default value; otherwise false.
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.Update Method

WhiteSpaceUpdate Method
Invalidates editor if needed.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
virtual void Update() sealed
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace Properties

WhiteSpace Properties

The WhiteSpace type exposes the following members.

Properties
 | Name | Description
Public property | EofString | Represents one character string that specifies end of file.
Public property | EofSymbol | Gets or sets character that specifies end of file.
Public property | EolString | Represents one character string that specifies end of line.
Public property | EolSymbol | Gets or sets character that specifies end of line.
Public property | LongSpaceString | Represents one character string that introduces special symbol to paint instead of the long space character.
Public property | LongSpaceSymbol | Gets or sets character that introduces special symbol to paint instead of the long space character.
Public property | SpaceString | Represents one character string that introduces special symbol to paint instead of the space character.
Public property | SpaceSymbol | Gets or sets character that introduces special symbol to paint instead of the space character.
Public property | SymbolColor | Gets or sets color used to paint special symbols.
Public property | TabString | Represents one character string that introduces special symbol to paint instead of the tab character.
Public property | TabSymbol | Gets or sets character that introduces special symbol to paint instead of the tab character.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | Visible | Gets or sets a value indicating whether white space symbols are visible in the control's text content.
Public property | WordWrapString | Represents one character string that specifies wrapped file.
Public property | WordWrapSymbol | Gets or sets character that specifies wrapped line.
Top
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.EofString Property

WhiteSpaceEofString Property
Represents one character string that specifies end of file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string EofString { get; }
Public Overridable ReadOnly Property EofString As String
    Get
public:
virtual property String^ EofString {
    String^ get ();
}
abstract EofString : string with get
override EofString : string with get

Property Value

Type: String

Implements

IWhiteSpaceEofString
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.EofSymbol Property

WhiteSpaceEofSymbol Property
Gets or sets character that specifies end of file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char EofSymbol { get; set; }
Public Overridable Property EofSymbol As Char
    Get
    Set
public:
virtual property wchar_t EofSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract EofSymbol : char with get, set
override EofSymbol : char with get, set

Property Value

Type: Char

Implements

IWhiteSpaceEofSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.EolString Property

WhiteSpaceEolString Property
Represents one character string that specifies end of line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string EolString { get; }
Public Overridable ReadOnly Property EolString As String
    Get
public:
virtual property String^ EolString {
    String^ get ();
}
abstract EolString : string with get
override EolString : string with get

Property Value

Type: String

Implements

IWhiteSpaceEolString
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.EolSymbol Property

WhiteSpaceEolSymbol Property
Gets or sets character that specifies end of line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char EolSymbol { get; set; }
Public Overridable Property EolSymbol As Char
    Get
    Set
public:
virtual property wchar_t EolSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract EolSymbol : char with get, set
override EolSymbol : char with get, set

Property Value

Type: Char

Implements

IWhiteSpaceEolSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.LongSpaceString Property

WhiteSpaceLongSpaceString Property
Represents one character string that introduces special symbol to paint instead of the long space character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string LongSpaceString { get; }
Public Overridable ReadOnly Property LongSpaceString As String
    Get
public:
virtual property String^ LongSpaceString {
    String^ get ();
}
abstract LongSpaceString : string with get
override LongSpaceString : string with get

Property Value

Type: String
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.LongSpaceSymbol Property

WhiteSpaceLongSpaceSymbol Property
Gets or sets character that introduces special symbol to paint instead of the long space character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char LongSpaceSymbol { get; set; }
Public Overridable Property LongSpaceSymbol As Char
    Get
    Set
public:
virtual property wchar_t LongSpaceSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract LongSpaceSymbol : char with get, set
override LongSpaceSymbol : char with get, set

Property Value

Type: Char

Implements

IWhiteSpaceLongSpaceSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.SpaceString Property

WhiteSpaceSpaceString Property
Represents one character string that introduces special symbol to paint instead of the space character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string SpaceString { get; }
Public Overridable ReadOnly Property SpaceString As String
    Get
public:
virtual property String^ SpaceString {
    String^ get ();
}
abstract SpaceString : string with get
override SpaceString : string with get

Property Value

Type: String

Implements

IWhiteSpaceSpaceString
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.SpaceSymbol Property

WhiteSpaceSpaceSymbol Property
Gets or sets character that introduces special symbol to paint instead of the space character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char SpaceSymbol { get; set; }
Public Overridable Property SpaceSymbol As Char
    Get
    Set
public:
virtual property wchar_t SpaceSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract SpaceSymbol : char with get, set
override SpaceSymbol : char with get, set

Property Value

Type: Char

Implements

IWhiteSpaceSpaceSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.SymbolColor Property

WhiteSpaceSymbolColor Property
Gets or sets color used to paint special symbols.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color SymbolColor { get; set; }
Public Overridable Property SymbolColor As Color
    Get
    Set
public:
virtual property Color SymbolColor {
    Color get ();
    void set (Color value);
}
abstract SymbolColor : Color with get, set
override SymbolColor : Color with get, set

Property Value

Type: Color

Implements

IWhiteSpaceSymbolColor
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.TabString Property

WhiteSpaceTabString Property
Represents one character string that introduces special symbol to paint instead of the tab character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string TabString { get; }
Public Overridable ReadOnly Property TabString As String
    Get
public:
virtual property String^ TabString {
    String^ get ();
}
abstract TabString : string with get
override TabString : string with get

Property Value

Type: String

Implements

IWhiteSpaceTabString
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.TabSymbol Property

WhiteSpaceTabSymbol Property
Gets or sets character that introduces special symbol to paint instead of the tab character.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char TabSymbol { get; set; }
Public Overridable Property TabSymbol As Char
    Get
    Set
public:
virtual property wchar_t TabSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract TabSymbol : char with get, set
override TabSymbol : char with get, set

Property Value

Type: Char

Implements

IWhiteSpaceTabSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.UpdateCount Property

WhiteSpaceUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.Visible Property

WhiteSpaceVisible Property
Gets or sets a value indicating whether white space symbols are visible in the control's text content.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Visible { get; set; }
Public Overridable Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

IWhiteSpaceVisible
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.WordWrapString Property

WhiteSpaceWordWrapString Property
Represents one character string that specifies wrapped file.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string WordWrapString { get; }
Public Overridable ReadOnly Property WordWrapString As String
    Get
public:
virtual property String^ WordWrapString {
    String^ get ();
}
abstract WordWrapString : string with get
override WordWrapString : string with get

Property Value

Type: String

Implements

IWhiteSpaceWordWrapString
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


WhiteSpace.WordWrapSymbol Property

WhiteSpaceWordWrapSymbol Property
Gets or sets character that specifies wrapped line.

Namespace: Alternet.Editor
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char WordWrapSymbol { get; set; }
Public Overridable Property WordWrapSymbol As Char
    Get
    Set
public:
virtual property wchar_t WordWrapSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
abstract WordWrapSymbol : char with get, set
override WordWrapSymbol : char with get, set

Property Value

Type: Char

Implements

IWhiteSpaceWordWrapSymbol
See Also

Reference

WhiteSpace Class
Alternet.Editor Namespace


Alternet.Editor.CodeCompletion Namespace

Alternet.Editor.CodeCompletion Namespace
Classes
 | Class | Description
Public class | CodeCompletionBox | Represents class that implements ICodeCompletionBox interface. This object is used to display a popup window containing Code Completion information presented in the form of list.
Public class | CodeCompletionButton | Represents class that implements ICodeCompletionButton interface. This object is used to display a popup window containing Code Fix information presented in the form of popup menu.
Public class | CodeCompletionColumn | Represents individual column object within a code completion columns collection.
Public class | CodeCompletionColumns | Represents properties and methods to provide indexed access to ICodeCompletionColumnobject.
Public class | CodeCompletionEdit | Represents class that implements ICodeCompletionEdit interface. This object is used to display a popup window containing Code Completion information presented in the form of an edit with a label.
Public class | CodeCompletionHint | Represents class that implements ICodeCompletionHint interface. This object to represent a popup window in a form of tooltip.
Public class | CodeCompletionWindow | Represents a base class for popup controls such as CodeCompletionBox and CodeCompletionHint.
Public class | CompletionButton | Represents a button-like control used to display code completion in a form of drop-down menu.
Public class | CompletionEdit | Represents a completion list box control. This class inherited from ListBox class and provides similar functionality for code completion requirements.
Public class | CompletionHint | Represents a tooltip-like control used in a code completion.
Public class | CompletionListBox | Represents a completion list box control. This class inherited from ListBox class and provides similar functionality for code completion requirements.
Public class | HintSyntaxPaint | Represents class that performs syntax painting for hint control.
Public class | HtmlLexer | Represents class used to highlight hint content with bold style.
Public class | HtmlSyntaxPaint | Represents class that performs syntax painting for hint control.
Public class | ListBoxVScrollBar |
Public class | ListBoxWithAdvancedScrolling |
Public class | ScrollableCodeCompletionBox |
Interfaces
 | Interface | Description
Public interface | ICodeCompletion | Represents properties and methods to provide code completion list box/tooltip for the Editor's content.
Public interface | ICodeCompletionBox | Represents properties and methods of a popup window that displays code completion information presented in the form of a list.
Public interface | ICodeCompletionButton | Represents properties and methods of a popup window that displays code completion information presented in the form of drop-down button.
Public interface | ICodeCompletionColumn | Represents properties and methods to identify individual column object within a code completion columns collection.
Public interface | ICodeCompletionColumns | Represents properties and methods to provide indexed access to ICodeCompletionColumn object.
Public interface | ICodeCompletionEdit | Represents properties and methods of a popup window that displays code completion information presented in the form of an edit with a label.
Public interface | ICodeCompletionHint | Represents properties and methods of a popup window that displays code completion information presented in the form of a tooltip window..
Public interface | ICodeCompletionWindow | Represents properties and methods to display a popup window containing Code Completion information.
Public interface | ICompletionButton | Represents properties and methods of button control that appears in the code completion window.
Public interface | ICompletionEdit | Represents properties for code completion requirements.
Enumerations
 | Enumeration | Description
Public enumeration | CodeCompletionFlags | Defines behaviour of the code completion popup window. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.


CodeCompletionBox Class

CodeCompletionBox Class
Represents class that implements ICodeCompletionBox interface. This object is used to display a popup window containing Code Completion information presented in the form of list.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CodeCompletionCodeCompletionWindow
Alternet.Editor.CodeCompletionCodeCompletionBox
Alternet.Editor.CodeCompletionScrollableCodeCompletionBox
Alternet.Scripter.IntegrationEditorCodeCompletionControllerCodeCompletionBox

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionBox : CodeCompletionWindow,
    ICodeCompletionBox, ICodeCompletionWindow
Public Class CodeCompletionBox
    Inherits CodeCompletionWindow
    Implements ICodeCompletionBox, ICodeCompletionWindow
public ref class CodeCompletionBox : public CodeCompletionWindow,
    ICodeCompletionBox, ICodeCompletionWindow
type CodeCompletionBox =
    class
        inherit CodeCompletionWindow
        interface ICodeCompletionBox
        interface ICodeCompletionWindow
    end

The CodeCompletionBox type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionBox | Initializes a new instance of the CodeCompletionBox class with specified owner.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddColumn | Adds a new column to the CodeCompletionBox column collection.
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CodeCompletionBox column collection.
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Overrides CodeCompletionWindowContainsControl(Control).)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position in the column collection.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Overrides CodeCompletionWindowPerformSearch.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Overrides CodeCompletionWindowPopupAt(Point, ICodeCompletionProvider).)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveColumnAt | Removes the column at the specified index of the column collection.
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionBox content from its Provider. (Overrides CodeCompletionWindowResetContent.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDropDownCount | Resets the DropDownCount to its default value.
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable to its default value. (Overrides CodeCompletionWindowResetSizeable.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CodeCompletionBorderColor | Gets CodeCompletionBox border color.
Public property | CodeCompletionBorderThickness | Gets thickness of the CodeCompletionBox border.
Public property | Columns | Represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionEdit | Represents CodeCompletionEdit object used to display code snippets.
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | CompletionHint | Represents CodeCompletion hint object used to display hints next to completion box.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | DropDownCount | Gets or sets a value that specifies maximum visible amount of the ListBox items within the control.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | Filter | Gets or sets filter string to filter CodeCompletionBox content.
Public property | Filtered | Gets or sets a boolean value that indicates whether CodeCompletionBox should filter its content using Filter property.
Public property | FilterOptions | Gets or sets rules specifying how CodeCompletionBox should filter its content.
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionEdit control has an input focus. (Overrides CodeCompletionWindowIsFocused.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | ShowTabs | Gets or sets boolean value that indicates whether codecompletion window should display additional tabs.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | Sorted | Gets or sets a value indicating whether the items in the CodeCompletionBox are sorted alphabetically.
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectionChanged | Occurs when index specifying the currently selected item is changed.
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox Constructor

CodeCompletionBox Constructor
Initializes a new instance of the CodeCompletionBox class with specified owner.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionBox(
    Control owner
)
Public Sub New (
    owner As Control
)
public:
CodeCompletionBox(
    Control^ owner
)
new :
        owner : Control -> CodeCompletionBox

Parameters

owner
Type: System.Windows.FormsControl
Specifies control owning this new instance.
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox Methods

CodeCompletionBox Methods

The CodeCompletionBox type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddColumn | Adds a new column to the CodeCompletionBox column collection.
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CodeCompletionBox column collection.
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Overrides CodeCompletionWindowContainsControl(Control).)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position in the column collection.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Overrides CodeCompletionWindowPerformSearch.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Overrides CodeCompletionWindowPopupAt(Point, ICodeCompletionProvider).)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveColumnAt | Removes the column at the specified index of the column collection.
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionBox content from its Provider. (Overrides CodeCompletionWindowResetContent.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDropDownCount | Resets the DropDownCount to its default value.
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable to its default value. (Overrides CodeCompletionWindowResetSizeable.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.AddColumn Method

CodeCompletionBoxAddColumn Method
Adds a new column to the CodeCompletionBox column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionColumn AddColumn()
Public Overridable Function AddColumn As ICodeCompletionColumn
public:
virtual ICodeCompletionColumn^ AddColumn()
abstract AddColumn : unit -> ICodeCompletionColumn
override AddColumn : unit -> ICodeCompletionColumn

Return Value

Type: ICodeCompletionColumn

Implements

ICodeCompletionBoxAddColumn
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.ClearColumns Method

CodeCompletionBoxClearColumns Method
Removes all columns from the CodeCompletionBox column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearColumns()
Public Overridable Sub ClearColumns
public:
virtual void ClearColumns()
abstract ClearColumns : unit -> unit
override ClearColumns : unit -> unit

Implements

ICodeCompletionBoxClearColumns
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.ContainsControl Method

CodeCompletionBoxContainsControl Method
Retrieves a value indicating whether the popup window contains the specified control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ContainsControl(
    Control control
)
Public Overrides Function ContainsControl (
    control As Control
) As Boolean
public:
virtual bool ContainsControl(
    Control^ control
) override
abstract ContainsControl :
        control : Control -> bool
override ContainsControl :
        control : Control -> bool

Parameters

control
Type: System.Windows.FormsControl
The Control to evaluate.

Return Value

Type: Boolean
True if the popup window contains the specified control; otherwise, false.

Implements

ICodeCompletionWindowContainsControl(Control)
ICodeCompletionWindowContainsControl(Control)
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.InsertColumn Method

CodeCompletionBoxInsertColumn Method
Inserts a new column to the specified position in the column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionColumn InsertColumn(
    int index
)
Public Overridable Function InsertColumn (
    index As Integer
) As ICodeCompletionColumn
public:
virtual ICodeCompletionColumn^ InsertColumn(
    int index
)
abstract InsertColumn :
        index : int -> ICodeCompletionColumn
override InsertColumn :
        index : int -> ICodeCompletionColumn

Parameters

index
Type: SystemInt32
Index of the column in the collection.

Return Value

Type: ICodeCompletionColumn
New inserted column.

Implements

ICodeCompletionBoxInsertColumn(Int32)
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.PerformSearch Method

CodeCompletionBoxPerformSearch Method
Performs searching operation.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool PerformSearch()
Public Overrides Function PerformSearch As Boolean
public:
virtual bool PerformSearch() override
abstract PerformSearch : unit -> bool
override PerformSearch : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ICodeCompletionWindowPerformSearch
ICodeCompletionWindowPerformSearch
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.PopupAt Method

CodeCompletionBoxPopupAt Method
Overload List
 | Name | Description
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Overrides CodeCompletionWindowPopupAt(Point, ICodeCompletionProvider).)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Top
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.PopupAt Method (Point, ICodeCompletionProvider)

CodeCompletionBoxPopupAt Method (Point, ICodeCompletionProvider)
Displays popup window at the specified position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PopupAt(
    Point position,
    ICodeCompletionProvider provider
)
Public Overrides Sub PopupAt (
    position As Point,
    provider As ICodeCompletionProvider
)
public:
virtual void PopupAt(
    Point position,
    ICodeCompletionProvider^ provider
) override
abstract PopupAt :
        position : Point *
        provider : ICodeCompletionProvider -> unit
override PopupAt :
        position : Point *
        provider : ICodeCompletionProvider -> unit

Parameters

position
Type: System.DrawingPoint
The Point object that specifies the coordinates at which popup window should be displayed.
provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Specifies source of the content for this window

Implements

ICodeCompletionWindowPopupAt(Point, ICodeCompletionProvider)
ICodeCompletionWindowPopupAt(Point, ICodeCompletionProvider)
See Also

Reference

CodeCompletionBox Class
PopupAt Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.RemoveColumnAt Method

CodeCompletionBoxRemoveColumnAt Method
Removes the column at the specified index of the column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveColumnAt(
    int index
)
Public Overridable Sub RemoveColumnAt (
    index As Integer
)
public:
virtual void RemoveColumnAt(
    int index
)
abstract RemoveColumnAt :
        index : int -> unit
override RemoveColumnAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies zero-based index of the column to remove.

Implements

ICodeCompletionBoxRemoveColumnAt(Int32)
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.ResetContent Method

CodeCompletionBoxResetContent Method
Updates CodeCompletionBox content from its Provider.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetContent()
Public Overrides Sub ResetContent
public:
virtual void ResetContent() override
abstract ResetContent : unit -> unit
override ResetContent : unit -> unit

Implements

ICodeCompletionWindowResetContent
ICodeCompletionWindowResetContent
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.ResetDropDownCount Method

CodeCompletionBoxResetDropDownCount Method
Resets the DropDownCount to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDropDownCount()
Public Overridable Sub ResetDropDownCount
public:
virtual void ResetDropDownCount()
abstract ResetDropDownCount : unit -> unit
override ResetDropDownCount : unit -> unit

Implements

ICodeCompletionBoxResetDropDownCount
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.ResetSizeable Method

CodeCompletionBoxResetSizeable Method
Resets the Sizeable to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetSizeable()
Public Overrides Sub ResetSizeable
public:
virtual void ResetSizeable() override
abstract ResetSizeable : unit -> unit
override ResetSizeable : unit -> unit

Implements

ICodeCompletionWindowResetSizeable
ICodeCompletionWindowResetSizeable
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox Properties

CodeCompletionBox Properties

The CodeCompletionBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CodeCompletionBorderColor | Gets CodeCompletionBox border color.
Public property | CodeCompletionBorderThickness | Gets thickness of the CodeCompletionBox border.
Public property | Columns | Represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionEdit | Represents CodeCompletionEdit object used to display code snippets.
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | CompletionHint | Represents CodeCompletion hint object used to display hints next to completion box.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | DropDownCount | Gets or sets a value that specifies maximum visible amount of the ListBox items within the control.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | Filter | Gets or sets filter string to filter CodeCompletionBox content.
Public property | Filtered | Gets or sets a boolean value that indicates whether CodeCompletionBox should filter its content using Filter property.
Public property | FilterOptions | Gets or sets rules specifying how CodeCompletionBox should filter its content.
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionEdit control has an input focus. (Overrides CodeCompletionWindowIsFocused.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | ShowTabs | Gets or sets boolean value that indicates whether codecompletion window should display additional tabs.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | Sorted | Gets or sets a value indicating whether the items in the CodeCompletionBox are sorted alphabetically.
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.CodeCompletionBorderColor Property

CodeCompletionBoxCodeCompletionBorderColor Property
Gets CodeCompletionBox border color.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color CodeCompletionBorderColor { get; }
Public Overridable ReadOnly Property CodeCompletionBorderColor As Color
    Get
public:
virtual property Color CodeCompletionBorderColor {
    Color get ();
}
abstract CodeCompletionBorderColor : Color with get
override CodeCompletionBorderColor : Color with get

Property Value

Type: Color

Implements

ICodeCompletionBoxCodeCompletionBorderColor
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.CodeCompletionBorderThickness Property

CodeCompletionBoxCodeCompletionBorderThickness Property
Gets thickness of the CodeCompletionBox border.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CodeCompletionBorderThickness { get; }
Public Overridable ReadOnly Property CodeCompletionBorderThickness As Integer
    Get
public:
virtual property int CodeCompletionBorderThickness {
    int get ();
}
abstract CodeCompletionBorderThickness : int with get
override CodeCompletionBorderThickness : int with get

Property Value

Type: Int32
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.Columns Property

CodeCompletionBoxColumns Property
Represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionColumn[] Columns { get; }
Public Overridable ReadOnly Property Columns As ICodeCompletionColumn()
    Get
public:
virtual property array<ICodeCompletionColumn^>^ Columns {
    array<ICodeCompletionColumn^>^ get ();
}
abstract Columns : ICodeCompletionColumn[] with get
override Columns : ICodeCompletionColumn[] with get

Property Value

Type: ICodeCompletionColumn

Implements

ICodeCompletionBoxColumns
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.CompletionEdit Property

CodeCompletionBoxCompletionEdit Property
Represents CodeCompletionEdit object used to display code snippets.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionEdit CompletionEdit { get; }
Public Overridable ReadOnly Property CompletionEdit As ICodeCompletionEdit
    Get
public:
virtual property ICodeCompletionEdit^ CompletionEdit {
    ICodeCompletionEdit^ get ();
}
abstract CompletionEdit : ICodeCompletionEdit with get
override CompletionEdit : ICodeCompletionEdit with get

Property Value

Type: ICodeCompletionEdit

Implements

ICodeCompletionBoxCompletionEdit
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.CompletionHint Property

CodeCompletionBoxCompletionHint Property
Represents CodeCompletion hint object used to display hints next to completion box.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionHint CompletionHint { get; }
Public Overridable ReadOnly Property CompletionHint As ICodeCompletionHint
    Get
public:
virtual property ICodeCompletionHint^ CompletionHint {
    ICodeCompletionHint^ get ();
}
abstract CompletionHint : ICodeCompletionHint with get
override CompletionHint : ICodeCompletionHint with get

Property Value

Type: ICodeCompletionHint

Implements

ICodeCompletionBoxCompletionHint
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.DropDownCount Property

CodeCompletionBoxDropDownCount Property
Gets or sets a value that specifies maximum visible amount of the ListBox items within the control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DropDownCount { get; set; }
Public Overridable Property DropDownCount As Integer
    Get
    Set
public:
virtual property int DropDownCount {
    int get ();
    void set (int value);
}
abstract DropDownCount : int with get, set
override DropDownCount : int with get, set

Property Value

Type: Int32

Implements

ICodeCompletionBoxDropDownCount
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.Filter Property

CodeCompletionBoxFilter Property
Gets or sets filter string to filter CodeCompletionBox content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Filter { get; set; }
Public Overridable Property Filter As String
    Get
    Set
public:
virtual property String^ Filter {
    String^ get ();
    void set (String^ value);
}
abstract Filter : string with get, set
override Filter : string with get, set

Property Value

Type: String

Implements

ICodeCompletionBoxFilter
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace
CodeCompletionBoxFiltered


CodeCompletionBox.Filtered Property

CodeCompletionBoxFiltered Property
Gets or sets a boolean value that indicates whether CodeCompletionBox should filter its content using Filter property.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Filtered { get; set; }
Public Overridable Property Filtered As Boolean
    Get
    Set
public:
virtual property bool Filtered {
    bool get ();
    void set (bool value);
}
abstract Filtered : bool with get, set
override Filtered : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionBoxFiltered
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace
CodeCompletionBoxFilter


CodeCompletionBox.FilterOptions Property

CodeCompletionBoxFilterOptions Property
Gets or sets rules specifying how CodeCompletionBox should filter its content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CompletionListFilterOptions FilterOptions { get; set; }
Public Overridable Property FilterOptions As CompletionListFilterOptions
    Get
    Set
public:
virtual property CompletionListFilterOptions FilterOptions {
    CompletionListFilterOptions get ();
    void set (CompletionListFilterOptions value);
}
abstract FilterOptions : CompletionListFilterOptions with get, set
override FilterOptions : CompletionListFilterOptions with get, set

Property Value

Type: CompletionListFilterOptions
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.IsFocused Property

CodeCompletionBoxIsFocused Property
Indicates whether CodeCompletionEdit control has an input focus.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsFocused { get; }
Public Overrides ReadOnly Property IsFocused As Boolean
    Get
public:
virtual property bool IsFocused {
    bool get () override;
}
abstract IsFocused : bool with get
override IsFocused : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionWindowIsFocused
ICodeCompletionWindowIsFocused
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.ShowTabs Property

CodeCompletionBoxShowTabs Property
Gets or sets boolean value that indicates whether codecompletion window should display additional tabs.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowTabs { get; set; }
Public Property ShowTabs As Boolean
    Get
    Set
public:
virtual property bool ShowTabs {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowTabs : bool with get, set
override ShowTabs : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionBoxShowTabs
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.Sorted Property

CodeCompletionBoxSorted Property
Gets or sets a value indicating whether the items in the CodeCompletionBox are sorted alphabetically.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Sorted { get; set; }
Public Overridable Property Sorted As Boolean
    Get
    Set
public:
virtual property bool Sorted {
    bool get ();
    void set (bool value);
}
abstract Sorted : bool with get, set
override Sorted : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionBoxSorted
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox Events

CodeCompletionBox Events

The CodeCompletionBox type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectionChanged | Occurs when index specifying the currently selected item is changed.
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionBox.SelectionChanged Event

CodeCompletionBoxSelectionChanged Event
Occurs when index specifying the currently selected item is changed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual event EventHandler SelectionChanged
Public Overridable Event SelectionChanged As EventHandler
public:
virtual  event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectionChanged : IEvent<EventHandler,
    EventArgs>
override SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ICodeCompletionBoxSelectionChanged
Remarks
The event handler receives an argument of type EventArgs containing data related to this event.
See Also

Reference

CodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionButton Class

CodeCompletionButton Class
Represents class that implements ICodeCompletionButton interface. This object is used to display a popup window containing Code Fix information presented in the form of popup menu.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CodeCompletionCodeCompletionWindow
Alternet.Editor.CodeCompletionCodeCompletionButton

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionButton : CodeCompletionWindow,
    ICodeCompletionButton, ICodeCompletionWindow
Public Class CodeCompletionButton
    Inherits CodeCompletionWindow
    Implements ICodeCompletionButton, ICodeCompletionWindow
public ref class CodeCompletionButton : public CodeCompletionWindow,
    ICodeCompletionButton, ICodeCompletionWindow
type CodeCompletionButton =
    class
        inherit CodeCompletionWindow
        interface ICodeCompletionButton
        interface ICodeCompletionWindow
    end

The CodeCompletionButton type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionButton | Initializes a new instance of the CodeCompletionButton class with specified owner.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Inherited from CodeCompletionWindow.)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | DropDown | Display drop down menu.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionWindow.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Overrides CodeCompletionWindowPopupAt(Point, ICodeCompletionProvider).)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionWindow content from its Provider. (Inherited from CodeCompletionWindow.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionWindow or it's child control has an input focus. (Inherited from CodeCompletionWindow.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CodeCompletionButton Constructor

CodeCompletionButton Constructor
Initializes a new instance of the CodeCompletionButton class with specified owner.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionButton(
    Control owner,
    Image image
)
Public Sub New (
    owner As Control,
    image As Image
)
public:
CodeCompletionButton(
    Control^ owner,
    Image^ image
)
new :
        owner : Control *
        image : Image -> CodeCompletionButton

Parameters

owner
Type: System.Windows.FormsControl
Specifies control owning this new instance.
image
Type: System.DrawingImage
Specifies bulb image for the new instance.
See Also

Reference

CodeCompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionButton Methods

CodeCompletionButton Methods

The CodeCompletionButton type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Inherited from CodeCompletionWindow.)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | DropDown | Display drop down menu.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionWindow.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Overrides CodeCompletionWindowPopupAt(Point, ICodeCompletionProvider).)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionWindow content from its Provider. (Inherited from CodeCompletionWindow.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

CodeCompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionButton.DropDown Method

CodeCompletionButtonDropDown Method
Display drop down menu.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DropDown()
Public Overridable Sub DropDown
public:
virtual void DropDown()
abstract DropDown : unit -> unit
override DropDown : unit -> unit

Implements

ICodeCompletionButtonDropDown
See Also

Reference

CodeCompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionButton.PopupAt Method

CodeCompletionButtonPopupAt Method
Overload List
 | Name | Description
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Overrides CodeCompletionWindowPopupAt(Point, ICodeCompletionProvider).)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Top
See Also

Reference

CodeCompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionButton.PopupAt Method (Point, ICodeCompletionProvider)

CodeCompletionButtonPopupAt Method (Point, ICodeCompletionProvider)
Displays popup window at the specified position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PopupAt(
    Point position,
    ICodeCompletionProvider provider
)
Public Overrides Sub PopupAt (
    position As Point,
    provider As ICodeCompletionProvider
)
public:
virtual void PopupAt(
    Point position,
    ICodeCompletionProvider^ provider
) override
abstract PopupAt :
        position : Point *
        provider : ICodeCompletionProvider -> unit
override PopupAt :
        position : Point *
        provider : ICodeCompletionProvider -> unit

Parameters

position
Type: System.DrawingPoint
Screen coordinates at which popup window should be displayed.
provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Specifies source of the content for this window

Implements

ICodeCompletionWindowPopupAt(Point, ICodeCompletionProvider)
ICodeCompletionWindowPopupAt(Point, ICodeCompletionProvider)
See Also

Reference

CodeCompletionButton Class
PopupAt Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionButton Properties

CodeCompletionButton Properties

The CodeCompletionButton type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionWindow or it's child control has an input focus. (Inherited from CodeCompletionWindow.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionButton Events

CodeCompletionButton Events

The CodeCompletionButton type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn Class

CodeCompletionColumn Class
Represents individual column object within a code completion columns collection.
Inheritance Hierarchy
SystemObject
Alternet.Editor.CodeCompletionCodeCompletionColumn

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionColumn : ICodeCompletionColumn
Public Class CodeCompletionColumn
    Implements ICodeCompletionColumn
public ref class CodeCompletionColumn : ICodeCompletionColumn
type CodeCompletionColumn =
    class
        interface ICodeCompletionColumn
    end

The CodeCompletionColumn type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionColumn | Initializes a new instance of the CodeCompletionColumn class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetFontStyle | Resets the FontStyle to its default value.
Public method | ResetForeColor | Resets the ForeColor to its default value.
Public method | ResetVisible | Resets the Visible to its default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FontStyle | Gets or sets style information for CodeCompletionColumn font.
Public property | ForeColor | Gets or sets Color structure that represents foreground color of the CodeCompletionColumn.
Public property | Name | Gets or sets the name of the CodeCompletionColumn.
Public property | Visible | Gets or sets a value indicating whether a column is visible.
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn Constructor

CodeCompletionColumn Constructor
Initializes a new instance of the CodeCompletionColumn class

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionColumn()
Public Sub New
public:
CodeCompletionColumn()
new : unit -> CodeCompletionColumn
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn Methods

CodeCompletionColumn Methods

The CodeCompletionColumn type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetFontStyle | Resets the FontStyle to its default value.
Public method | ResetForeColor | Resets the ForeColor to its default value.
Public method | ResetVisible | Resets the Visible to its default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn.ResetFontStyle Method

CodeCompletionColumnResetFontStyle Method
Resets the FontStyle to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetFontStyle()
Public Overridable Sub ResetFontStyle
public:
virtual void ResetFontStyle()
abstract ResetFontStyle : unit -> unit
override ResetFontStyle : unit -> unit

Implements

ICodeCompletionColumnResetFontStyle
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn.ResetForeColor Method

CodeCompletionColumnResetForeColor Method
Resets the ForeColor to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetForeColor()
Public Overridable Sub ResetForeColor
public:
virtual void ResetForeColor()
abstract ResetForeColor : unit -> unit
override ResetForeColor : unit -> unit

Implements

ICodeCompletionColumnResetForeColor
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn.ResetVisible Method

CodeCompletionColumnResetVisible Method
Resets the Visible to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetVisible()
Public Overridable Sub ResetVisible
public:
virtual void ResetVisible()
abstract ResetVisible : unit -> unit
override ResetVisible : unit -> unit

Implements

ICodeCompletionColumnResetVisible
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn Properties

CodeCompletionColumn Properties

The CodeCompletionColumn type exposes the following members.

Properties
 | Name | Description
Public property | FontStyle | Gets or sets style information for CodeCompletionColumn font.
Public property | ForeColor | Gets or sets Color structure that represents foreground color of the CodeCompletionColumn.
Public property | Name | Gets or sets the name of the CodeCompletionColumn.
Public property | Visible | Gets or sets a value indicating whether a column is visible.
Top
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn.FontStyle Property

CodeCompletionColumnFontStyle Property
Gets or sets style information for CodeCompletionColumn font.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FontStyle FontStyle { get; set; }
Public Overridable Property FontStyle As FontStyle
    Get
    Set
public:
virtual property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract FontStyle : FontStyle with get, set
override FontStyle : FontStyle with get, set

Property Value

Type: FontStyle

Implements

ICodeCompletionColumnFontStyle
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn.ForeColor Property

CodeCompletionColumnForeColor Property
Gets or sets Color structure that represents foreground color of the CodeCompletionColumn.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ForeColor { get; set; }
Public Overridable Property ForeColor As Color
    Get
    Set
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set
override ForeColor : Color with get, set

Property Value

Type: Color

Implements

ICodeCompletionColumnForeColor
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn.Name Property

CodeCompletionColumnName Property
Gets or sets the name of the CodeCompletionColumn.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ICodeCompletionColumnName
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumn.Visible Property

CodeCompletionColumnVisible Property
Gets or sets a value indicating whether a column is visible.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Visible { get; set; }
Public Overridable Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionColumnVisible
See Also

Reference

CodeCompletionColumn Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumns Class

CodeCompletionColumns Class
Represents properties and methods to provide indexed access to ICodeCompletionColumnobject.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionColumn
Alternet.Editor.CodeCompletionCodeCompletionColumns

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionColumns : List<ICodeCompletionColumn>,
    ICodeCompletionColumns, IList<ICodeCompletionColumn>, ICollection<ICodeCompletionColumn>,
    IEnumerable<ICodeCompletionColumn>, IEnumerable
Public Class CodeCompletionColumns
    Inherits List(Of ICodeCompletionColumn)
    Implements ICodeCompletionColumns, IList(Of ICodeCompletionColumn),
    ICollection(Of ICodeCompletionColumn), IEnumerable(Of ICodeCompletionColumn), IEnumerable
public ref class CodeCompletionColumns : public List<ICodeCompletionColumn^>,
    ICodeCompletionColumns, IList<ICodeCompletionColumn^>, ICollection<ICodeCompletionColumn^>,
    IEnumerable<ICodeCompletionColumn^>, IEnumerable
type CodeCompletionColumns =
    class
        inherit List<ICodeCompletionColumn>
        interface ICodeCompletionColumns
        interface IList<ICodeCompletionColumn>
        interface ICollection<ICodeCompletionColumn>
        interface IEnumerable<ICodeCompletionColumn>
        interface IEnumerable
    end

The CodeCompletionColumns type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionColumns | Initializes a new instance of the CodeCompletionColumns class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionColumn .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionColumn .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionColumn .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionColumn .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionColumn .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionColumn .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionColumn .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionColumn .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionColumn .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionColumn .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionColumn .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionColumn .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionColumn .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionColumn .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionColumn .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionColumn .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionColumn .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionColumn .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionColumn .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionColumn .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionColumn .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionColumn .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionColumn .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionColumn .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionColumn | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionColumn | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionColumn, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionColumn .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionColumn .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionColumn .)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumns Constructor

CodeCompletionColumns Constructor
Initializes a new instance of the CodeCompletionColumns class

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionColumns()
Public Sub New
public:
CodeCompletionColumns()
new : unit -> CodeCompletionColumns
See Also

Reference

CodeCompletionColumns Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumns Methods

CodeCompletionColumns Methods

The CodeCompletionColumns type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionColumn .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionColumn .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionColumn .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionColumn .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionColumn .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionColumn .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionColumn .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionColumn .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionColumn .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionColumn .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionColumn .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionColumn .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionColumn .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionColumn .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionColumn .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionColumn .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionColumn .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionColumn .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionColumn .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionColumn .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionColumn .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionColumn .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionColumn .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionColumn .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionColumn .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionColumn .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionColumn .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionColumn | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionColumn | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionColumn, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeCompletionColumns Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionColumns Properties

CodeCompletionColumns Properties

The CodeCompletionColumns type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionColumn .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionColumn .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionColumn .)
Top
See Also

Reference

CodeCompletionColumns Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit Class

CodeCompletionEdit Class
Represents class that implements ICodeCompletionEdit interface. This object is used to display a popup window containing Code Completion information presented in the form of an edit with a label.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CodeCompletionCodeCompletionWindow
Alternet.Editor.CodeCompletionCodeCompletionEdit

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionEdit : CodeCompletionWindow,
    ICodeCompletionEdit, ICodeCompletionWindow, IControl
Public Class CodeCompletionEdit
    Inherits CodeCompletionWindow
    Implements ICodeCompletionEdit, ICodeCompletionWindow, IControl
public ref class CodeCompletionEdit : public CodeCompletionWindow,
    ICodeCompletionEdit, ICodeCompletionWindow, IControl
type CodeCompletionEdit =
    class
        inherit CodeCompletionWindow
        interface ICodeCompletionEdit
        interface ICodeCompletionWindow
        interface IControl
    end

The CodeCompletionEdit type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionEdit | Initializes a new instance of the CodeCompletionEdit class with specified parameters.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Overrides CodeCompletionWindowContainsControl(Control).)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionWindow.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionWindow content from its Provider. (Inherited from CodeCompletionWindow.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | Edit | Represents a completion list box control.
Public property | EditField | Gets or sets a value that indicates caption of the Edit label.
Public property | EditPath | Gets or sets a value that indicates text of the field being edited.
Public property | EditText | Gets or sets a value that indicates text of the field being edited.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionEdit control has an input focus. (Overrides CodeCompletionWindowIsFocused.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit Constructor

CodeCompletionEdit Constructor
Initializes a new instance of the CodeCompletionEdit class with specified parameters.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionEdit(
    Control owner,
    ICodeCompletionBox parent
)
Public Sub New (
    owner As Control,
    parent As ICodeCompletionBox
)
public:
CodeCompletionEdit(
    Control^ owner,
    ICodeCompletionBox^ parent
)
new :
        owner : Control *
        parent : ICodeCompletionBox -> CodeCompletionEdit

Parameters

owner
Type: System.Windows.FormsControl
The SyntaxEdit control owning this new instance.
parent
Type: Alternet.Editor.CodeCompletionICodeCompletionBox
Specifies parent of this new instance.
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit Methods

CodeCompletionEdit Methods

The CodeCompletionEdit type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Overrides CodeCompletionWindowContainsControl(Control).)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionWindow.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionWindow content from its Provider. (Inherited from CodeCompletionWindow.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit.ContainsControl Method

CodeCompletionEditContainsControl Method
Retrieves a value indicating whether the popup window contains the specified control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ContainsControl(
    Control control
)
Public Overrides Function ContainsControl (
    control As Control
) As Boolean
public:
virtual bool ContainsControl(
    Control^ control
) override
abstract ContainsControl :
        control : Control -> bool
override ContainsControl :
        control : Control -> bool

Parameters

control
Type: System.Windows.FormsControl
The Control to evaluate.

Return Value

Type: Boolean
True if the popup window contains the specified control; otherwise, false.

Implements

ICodeCompletionWindowContainsControl(Control)
ICodeCompletionWindowContainsControl(Control)
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit Properties

CodeCompletionEdit Properties

The CodeCompletionEdit type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | Edit | Represents a completion list box control.
Public property | EditField | Gets or sets a value that indicates caption of the Edit label.
Public property | EditPath | Gets or sets a value that indicates text of the field being edited.
Public property | EditText | Gets or sets a value that indicates text of the field being edited.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionEdit control has an input focus. (Overrides CodeCompletionWindowIsFocused.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit.Edit Property

CodeCompletionEditEdit Property
Represents a completion list box control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICompletionEdit Edit { get; }
Public Overridable ReadOnly Property Edit As ICompletionEdit
    Get
public:
virtual property ICompletionEdit^ Edit {
    ICompletionEdit^ get ();
}
abstract Edit : ICompletionEdit with get
override Edit : ICompletionEdit with get

Property Value

Type: ICompletionEdit

Implements

ICodeCompletionEditEdit
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit.EditField Property

CodeCompletionEditEditField Property
Gets or sets a value that indicates caption of the Edit label.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string EditField { get; set; }
Public Overridable Property EditField As String
    Get
    Set
public:
virtual property String^ EditField {
    String^ get ();
    void set (String^ value);
}
abstract EditField : string with get, set
override EditField : string with get, set

Property Value

Type: String

Implements

ICodeCompletionEditEditField
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit.EditPath Property

CodeCompletionEditEditPath Property
Gets or sets a value that indicates text of the field being edited.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EditPath { get; set; }
Public Property EditPath As String
    Get
    Set
public:
virtual property String^ EditPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract EditPath : string with get, set
override EditPath : string with get, set

Property Value

Type: String

Implements

ICodeCompletionEditEditPath
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit.EditText Property

CodeCompletionEditEditText Property
Gets or sets a value that indicates text of the field being edited.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EditText { get; set; }
Public Property EditText As String
    Get
    Set
public:
virtual property String^ EditText {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract EditText : string with get, set
override EditText : string with get, set

Property Value

Type: String

Implements

ICodeCompletionEditEditText
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit.IsFocused Property

CodeCompletionEditIsFocused Property
Indicates whether CodeCompletionEdit control has an input focus.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsFocused { get; }
Public Overrides ReadOnly Property IsFocused As Boolean
    Get
public:
virtual property bool IsFocused {
    bool get () override;
}
abstract IsFocused : bool with get
override IsFocused : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionWindowIsFocused
ICodeCompletionWindowIsFocused
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionEdit Events

CodeCompletionEdit Events

The CodeCompletionEdit type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionFlags Enumeration

CodeCompletionFlags Enumeration
Defines behaviour of the code completion popup window. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum CodeCompletionFlags
<FlagsAttribute>
Public Enumeration CodeCompletionFlags
[FlagsAttribute]
public enum class CodeCompletionFlags
[<FlagsAttribute>]
type CodeCompletionFlags
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
CloseOnEscape | 1 | Specifies that code completion popup window should be closed when user presses the ESC key.
AcceptOnEnter | 2 | Specifies that code completion popup window should accept its result when user presses the ENTER key.
CloseOnMouseLeave | 4 | Specifies that code completion popup window should be closed when mouse pointer leaves the control.
CloseOnLostFocus | 8 | Specifies that code completion popup window should be closed when popup window lost focus.
AcceptOnClick | 16 | Specifies that code completion popup window should accept its result when user clicks the popup.
AcceptOnDblClick | 32 | Specifies that code completion popup window should accept its result when user double clicks the popup.
FeetToScreen | 64 | Specifies that code completion popup window should be fitted to screen when popups.
KeepActive | 128 | Indicates whether hint window remains visible until closed manually.
AcceptOnDelimiter | 256 | Specifies that code completion popup window should accept its result when user presses delimiter key.
AcceptOnTab | 512 | Specifies that code completion popup window should accept its result when user presses tab.
AcceptOnSpace | 1024 | Specifies that code completion popup window should accept its result and suppress the space key when user presses space.
ForceSelection | 2048 | Specifies that code completion popup window should force selection first item.
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint Class

CodeCompletionHint Class
Represents class that implements ICodeCompletionHint interface. This object to represent a popup window in a form of tooltip.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CodeCompletionCodeCompletionWindow
Alternet.Editor.CodeCompletionCodeCompletionHint
Alternet.Scripter.IntegrationEditorCodeCompletionControllerCodeCompletionHint

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionHint : CodeCompletionWindow,
    ICodeCompletionHint, ICodeCompletionWindow, ISyntaxPaint
Public Class CodeCompletionHint
    Inherits CodeCompletionWindow
    Implements ICodeCompletionHint, ICodeCompletionWindow, ISyntaxPaint
public ref class CodeCompletionHint : public CodeCompletionWindow,
    ICodeCompletionHint, ICodeCompletionWindow, ISyntaxPaint
type CodeCompletionHint =
    class
        inherit CodeCompletionWindow
        interface ICodeCompletionHint
        interface ICodeCompletionWindow
        interface ISyntaxPaint
    end

The CodeCompletionHint type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionHint | Initializes a new instance of the CodeCompletionHint class with specified owner.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Inherited from CodeCompletionWindow.)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawLine(Int32, Point, Rectangle) | Draws specific line in of the hint control to the graphic surface.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFontColor | Retrieves font color corresponding to given state.
Public method | GetFontStyle | Retrieves font style corresponding to given state.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of the given string.
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of the given string.
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | OnCustomDraw | Calls Hint.SyntaxPaint.OnCustomDraw method that raises CustomDraw event.
Public method | PaintSyntax | Paints a specified part of the hint control.
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionWindow.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoHide | Resets the AutoHide to its default value.
Public method | ResetAutoHidePause | Resets the AutoHidePause to its default value.
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionHint content from its Provider. (Overrides CodeCompletionWindowResetContent.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to its default value.
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to its default value.
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoHide | Gets or sets a value indicating whether CodeCompletionHint should be closed after some period of time.
Public property | AutoHidePause | Gets or sets a value that specifies delay, in milliseconds, between displaying and hiding popup hint.
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisableColorPaint | Gets or sets a value indicating whether hint control uses colors to paint its content.
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether hint control uses lexical colors/styles to paint its content.
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionWindow or it's child control has an input focus. (Inherited from CodeCompletionWindow.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | Gets or sets object that can make lexical analysis for the hint control content.
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Painter |
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when hint draws its content.
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HyperTextClick | Occurs when hypertext is clicked.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint Constructor

CodeCompletionHint Constructor
Initializes a new instance of the CodeCompletionHint class with specified owner.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionHint(
    Control owner
)
Public Sub New (
    owner As Control
)
public:
CodeCompletionHint(
    Control^ owner
)
new :
        owner : Control -> CodeCompletionHint

Parameters

owner
Type: System.Windows.FormsControl
The SyntaxEdit object owning this new instance.
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint Methods

CodeCompletionHint Methods

The CodeCompletionHint type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Inherited from CodeCompletionWindow.)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawLine(Int32, Point, Rectangle) | Draws specific line in of the hint control to the graphic surface.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFontColor | Retrieves font color corresponding to given state.
Public method | GetFontStyle | Retrieves font style corresponding to given state.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of the given string.
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of the given string.
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | OnCustomDraw | Calls Hint.SyntaxPaint.OnCustomDraw method that raises CustomDraw event.
Public method | PaintSyntax | Paints a specified part of the hint control.
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionWindow.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoHide | Resets the AutoHide to its default value.
Public method | ResetAutoHidePause | Resets the AutoHidePause to its default value.
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionHint content from its Provider. (Overrides CodeCompletionWindowResetContent.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to its default value.
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to its default value.
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.DrawLine Method

CodeCompletionHintDrawLine Method
Overload List
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | Draws specific line in of the hint control to the graphic surface.
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position.
Top
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.DrawLine Method (Int32, Point, Rectangle)

CodeCompletionHintDrawLine Method (Int32, Point, Rectangle)
Draws specific line in of the hint control to the graphic surface.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawLine(
    int index,
    Point position,
    Rectangle clipRect
)
Public Overridable Sub DrawLine (
    index As Integer,
    position As Point,
    clipRect As Rectangle
)
public:
virtual void DrawLine(
    int index,
    Point position,
    Rectangle clipRect
)
abstract DrawLine :
        index : int *
        position : Point *
        clipRect : Rectangle -> unit
override DrawLine :
        index : int *
        position : Point *
        clipRect : Rectangle -> unit

Parameters

index
Type: SystemInt32
Specifies index of line to draw.
position
Type: System.DrawingPoint
The Point value that specifies start position to draw.
clipRect
Type: System.DrawingRectangle
Rectangular area of hint control to draw in.

Implements

ISyntaxPaintDrawLine(Int32, Point, Rectangle)
See Also

Reference

CodeCompletionHint Class
DrawLine Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.DrawLine Method (Int32, String, StringItemInfo[], Point, Rectangle)

CodeCompletionHintDrawLine Method (Int32, String, StringItemInfo, Point, Rectangle)
Draws line given by its index at the specified position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawLine(
    int index,
    string line,
    StringItemInfo[] colorData,
    Point position,
    Rectangle clipRect
)
Public Overridable Sub DrawLine (
    index As Integer,
    line As String,
    colorData As StringItemInfo(),
    position As Point,
    clipRect As Rectangle
)
public:
virtual void DrawLine(
    int index,
    String^ line,
    array<StringItemInfo>^ colorData,
    Point position,
    Rectangle clipRect
)
abstract DrawLine :
        index : int *
        line : string *
        colorData : StringItemInfo[] *
        position : Point *
        clipRect : Rectangle -> unit
override DrawLine :
        index : int *
        line : string *
        colorData : StringItemInfo[] *
        position : Point *
        clipRect : Rectangle -> unit

Parameters

index
Type: SystemInt32
Index of line to draw.
line
Type: SystemString
Specifies text to draw.
colorData
Type: Alternet.SyntaxStringItemInfo
Specifies array containing color data for given string.
position
Type: System.DrawingPoint
Position to start drawing.
clipRect
Type: System.DrawingRectangle
Rectangular area of the control to draw line in.

Implements

ISyntaxPaintDrawLine(Int32, String, StringItemInfo, Point, Rectangle)
See Also

Reference

CodeCompletionHint Class
DrawLine Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.EqualStyles Method

CodeCompletionHintEqualStyles Method
Indicates whether given styles are equal.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool EqualStyles(
    StringItemInfo style1,
    StringItemInfo style2,
    bool useColors
)
Public Overridable Function EqualStyles (
    style1 As StringItemInfo,
    style2 As StringItemInfo,
    useColors As Boolean
) As Boolean
public:
virtual bool EqualStyles(
    StringItemInfo style1,
    StringItemInfo style2,
    bool useColors
)
abstract EqualStyles :
        style1 : StringItemInfo *
        style2 : StringItemInfo *
        useColors : bool -> bool
override EqualStyles :
        style1 : StringItemInfo *
        style2 : StringItemInfo *
        useColors : bool -> bool

Parameters

style1
Type: Alternet.SyntaxStringItemInfo
First style to compare.
style2
Type: Alternet.SyntaxStringItemInfo
Second style to compare.
useColors
Type: SystemBoolean
Indicate whether colors of the styles are assumed.

Return Value

Type: Boolean
True if styles are equal; otherwise false.

Implements

ISyntaxPaintEqualStyles(StringItemInfo, StringItemInfo, Boolean)
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.GetFontColor Method

CodeCompletionHintGetFontColor Method
Retrieves font color corresponding to given state.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color GetFontColor(
    Color color,
    TextStyle textStyle
)
Public Overridable Function GetFontColor (
    color As Color,
    textStyle As TextStyle
) As Color
public:
virtual Color GetFontColor(
    Color color,
    TextStyle textStyle
)
abstract GetFontColor :
        color : Color *
        textStyle : TextStyle -> Color
override GetFontColor :
        color : Color *
        textStyle : TextStyle -> Color

Parameters

color
Type: System.DrawingColor
Default color.
textStyle
Type: Alternet.SyntaxTextStyle
Additional color flags.

Return Value

Type: Color
New value of font color.

Implements

ISyntaxPaintGetFontColor(Color, TextStyle)
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.GetFontStyle Method

CodeCompletionHintGetFontStyle Method
Retrieves font style corresponding to given state.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FontStyle GetFontStyle(
    FontStyle fontStyle,
    TextStyle textStyle
)
Public Overridable Function GetFontStyle (
    fontStyle As FontStyle,
    textStyle As TextStyle
) As FontStyle
public:
virtual FontStyle GetFontStyle(
    FontStyle fontStyle,
    TextStyle textStyle
)
abstract GetFontStyle :
        fontStyle : FontStyle *
        textStyle : TextStyle -> FontStyle
override GetFontStyle :
        fontStyle : FontStyle *
        textStyle : TextStyle -> FontStyle

Parameters

fontStyle
Type: System.DrawingFontStyle
Default style.
textStyle
Type: Alternet.SyntaxTextStyle
Additional text styles.

Return Value

Type: FontStyle
New value of font style.

Implements

ISyntaxPaintGetFontStyle(FontStyle, TextStyle)
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.GetLexStyle Method

CodeCompletionHintGetLexStyle Method
Retrieves lex state corresponding to given parser style.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStyle GetLexStyle(
    StringItemInfo style,
    ref TextStyle textStyle
)
Public Overridable Function GetLexStyle (
    style As StringItemInfo,
    ByRef textStyle As TextStyle
) As ILexStyle
public:
virtual ILexStyle^ GetLexStyle(
    StringItemInfo style,
    TextStyle% textStyle
)
abstract GetLexStyle :
        style : StringItemInfo *
        textStyle : TextStyle byref -> ILexStyle
override GetLexStyle :
        style : StringItemInfo *
        textStyle : TextStyle byref -> ILexStyle

Parameters

style
Type: Alternet.SyntaxStringItemInfo
Index of parser style.
textStyle
Type: Alternet.SyntaxTextStyle
Additional text styles.

Return Value

Type: ILexStyle
LexStyle by its index.

Implements

ISyntaxPaintGetLexStyle(StringItemInfo, TextStyle)
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.MeasureLine Method

CodeCompletionHintMeasureLine Method
Overload List
 | Name | Description
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of the given string.
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index.
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of the given string.
Top
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.MeasureLine Method (Int32, Int32, Int32)

CodeCompletionHintMeasureLine Method (Int32, Int32, Int32)
Measures part of the string given by its index.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MeasureLine(
    int index,
    int pos,
    int len
)
Public Overridable Function MeasureLine (
    index As Integer,
    pos As Integer,
    len As Integer
) As Integer
public:
virtual int MeasureLine(
    int index,
    int pos,
    int len
)
abstract MeasureLine :
        index : int *
        pos : int *
        len : int -> int
override MeasureLine :
        index : int *
        pos : int *
        len : int -> int

Parameters

index
Type: SystemInt32
Index of line to measure.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.

Return Value

Type: Int32
Width of the measured part of the string.

Implements

ISyntaxPaintMeasureLine(Int32, Int32, Int32)
See Also

Reference

CodeCompletionHint Class
MeasureLine Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.MeasureLine Method (String, StringItemInfo[], Int32, Int32)

CodeCompletionHintMeasureLine Method (String, StringItemInfo, Int32, Int32)
Measures part of the given string.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MeasureLine(
    string line,
    StringItemInfo[] colorData,
    int pos,
    int len
)
Public Overridable Function MeasureLine (
    line As String,
    colorData As StringItemInfo(),
    pos As Integer,
    len As Integer
) As Integer
public:
virtual int MeasureLine(
    String^ line,
    array<StringItemInfo>^ colorData,
    int pos,
    int len
)
abstract MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int -> int
override MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int -> int

Parameters

line
Type: SystemString
Text to measure.
colorData
Type: Alternet.SyntaxStringItemInfo
Color data attached to the given string.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.

Return Value

Type: Int32
Width of the measured part of the string.

Implements

ISyntaxPaintMeasureLine(String, StringItemInfo, Int32, Int32)
See Also

Reference

CodeCompletionHint Class
MeasureLine Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.MeasureLine Method (Int32, Int32, Int32, Int32, Int32, Boolean)

CodeCompletionHintMeasureLine Method (Int32, Int32, Int32, Int32, Int32, Boolean)
Measures part of the string given by its index.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MeasureLine(
    int index,
    int pos,
    int len,
    int width,
    out int chars,
    bool exact
)
Public Overridable Function MeasureLine (
    index As Integer,
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef chars As Integer,
    exact As Boolean
) As Integer
public:
virtual int MeasureLine(
    int index,
    int pos,
    int len,
    int width,
    [OutAttribute] int% chars,
    bool exact
)
abstract MeasureLine :
        index : int *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int
override MeasureLine :
        index : int *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int

Parameters

index
Type: SystemInt32
Index of line to measure.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.
width
Type: SystemInt32
Maximum length of the string.
chars
Type: SystemInt32
Receive real number of measured chars.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the measured part of the string.

Implements

ISyntaxPaintMeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean)
See Also

Reference

CodeCompletionHint Class
MeasureLine Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.MeasureLine Method (String, StringItemInfo[], Int32, Int32, Int32, Int32, Boolean)

CodeCompletionHintMeasureLine Method (String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean)
Measures part of the given string.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MeasureLine(
    string line,
    StringItemInfo[] colorData,
    int pos,
    int len,
    int width,
    out int chars,
    bool exact
)
Public Overridable Function MeasureLine (
    line As String,
    colorData As StringItemInfo(),
    pos As Integer,
    len As Integer,
    width As Integer,
    <OutAttribute> ByRef chars As Integer,
    exact As Boolean
) As Integer
public:
virtual int MeasureLine(
    String^ line,
    array<StringItemInfo>^ colorData,
    int pos,
    int len,
    int width,
    [OutAttribute] int% chars,
    bool exact
)
abstract MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int
override MeasureLine :
        line : string *
        colorData : StringItemInfo[] *
        pos : int *
        len : int *
        width : int *
        chars : int byref *
        exact : bool -> int

Parameters

line
Type: SystemString
Text to measure.
colorData
Type: Alternet.SyntaxStringItemInfo
Color data attached to the given string.
pos
Type: SystemInt32
Start character of string to measure.
len
Type: SystemInt32
Number of characters to measure.
width
Type: SystemInt32
Maximum length of the string.
chars
Type: SystemInt32
Receive real number of measured chars.
exact
Type: SystemBoolean
Specifies whether the calculating should be precise.

Return Value

Type: Int32
Width of the measured part of the string.

Implements

ISyntaxPaintMeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean)
See Also

Reference

CodeCompletionHint Class
MeasureLine Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.OnCustomDraw Method

CodeCompletionHintOnCustomDraw Method
Calls Hint.SyntaxPaint.OnCustomDraw method that raises CustomDraw event.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool OnCustomDraw(
    Rectangle rect,
    DrawStage stage,
    DrawState state,
    IDrawInfo info
)
Public Overridable Function OnCustomDraw (
    rect As Rectangle,
    stage As DrawStage,
    state As DrawState,
    info As IDrawInfo
) As Boolean
public:
virtual bool OnCustomDraw(
    Rectangle rect,
    DrawStage stage,
    DrawState state,
    IDrawInfo^ info
)
abstract OnCustomDraw :
        rect : Rectangle *
        stage : DrawStage *
        state : DrawState *
        info : IDrawInfo -> bool
override OnCustomDraw :
        rect : Rectangle *
        stage : DrawStage *
        state : DrawState *
        info : IDrawInfo -> bool

Parameters

rect
Type: System.DrawingRectangle
Rectangular area of CodeCompletionHint to draw.
stage
Type: Alternet.EditorDrawStage
Specifies whether this method called before or after painting.
state
Type: Alternet.EditorDrawState
Specifies part of control to draw.
info
Type: Alternet.EditorIDrawInfo
Full information about drawing text fragment.

Return Value

Type: Boolean
True if user handles this event; otherwise false.

Implements

ISyntaxPaintOnCustomDraw(Rectangle, DrawStage, DrawState, IDrawInfo)
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.PaintSyntax Method

CodeCompletionHintPaintSyntax Method
Paints a specified part of the hint control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
)
Public Overridable Sub PaintSyntax (
    startLine As Integer,
    endLine As Integer,
    position As Point,
    rect As Rectangle,
    location As Point,
    specialPaint As Boolean
)
public:
virtual void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
)
abstract PaintSyntax :
        startLine : int *
        endLine : int *
        position : Point *
        rect : Rectangle *
        location : Point *
        specialPaint : bool -> unit
override PaintSyntax :
        startLine : int *
        endLine : int *
        position : Point *
        rect : Rectangle *
        location : Point *
        specialPaint : bool -> unit

Parameters

startLine
Type: SystemInt32
Specifies first line to paint.
endLine
Type: SystemInt32
Specifies last line to paint.
position
Type: System.DrawingPoint
The Point value that specifies start position to draw from.
rect
Type: System.DrawingRectangle
Rectangular area of CodeCompletionHint to draw.
location
Type: System.DrawingPoint
The Point value that specifies start position to draw page from.
specialPaint
Type: SystemBoolean
Reserved for internal use.

Implements

ISyntaxPaintPaintSyntax(Int32, Int32, Point, Rectangle, Point, Boolean)
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.ResetAutoHide Method

CodeCompletionHintResetAutoHide Method
Resets the AutoHide to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAutoHide()
Public Overridable Sub ResetAutoHide
public:
virtual void ResetAutoHide()
abstract ResetAutoHide : unit -> unit
override ResetAutoHide : unit -> unit

Implements

ICodeCompletionHintResetAutoHide
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.ResetAutoHidePause Method

CodeCompletionHintResetAutoHidePause Method
Resets the AutoHidePause to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAutoHidePause()
Public Overridable Sub ResetAutoHidePause
public:
virtual void ResetAutoHidePause()
abstract ResetAutoHidePause : unit -> unit
override ResetAutoHidePause : unit -> unit

Implements

ICodeCompletionHintResetAutoHidePause
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.ResetContent Method

CodeCompletionHintResetContent Method
Updates CodeCompletionHint content from its Provider.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetContent()
Public Overrides Sub ResetContent
public:
virtual void ResetContent() override
abstract ResetContent : unit -> unit
override ResetContent : unit -> unit

Implements

ICodeCompletionWindowResetContent
ICodeCompletionWindowResetContent
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.ResetDisableColorPaint Method

CodeCompletionHintResetDisableColorPaint Method
Resets the DisableColorPaint to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDisableColorPaint()
Public Overridable Sub ResetDisableColorPaint
public:
virtual void ResetDisableColorPaint()
abstract ResetDisableColorPaint : unit -> unit
override ResetDisableColorPaint : unit -> unit

Implements

ISyntaxPaintResetDisableColorPaint
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.ResetDisableSyntaxPaint Method

CodeCompletionHintResetDisableSyntaxPaint Method
Resets the DisableSyntaxPaint to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDisableSyntaxPaint()
Public Overridable Sub ResetDisableSyntaxPaint
public:
virtual void ResetDisableSyntaxPaint()
abstract ResetDisableSyntaxPaint : unit -> unit
override ResetDisableSyntaxPaint : unit -> unit

Implements

ISyntaxPaintResetDisableSyntaxPaint
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint Properties

CodeCompletionHint Properties

The CodeCompletionHint type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoHide | Gets or sets a value indicating whether CodeCompletionHint should be closed after some period of time.
Public property | AutoHidePause | Gets or sets a value that specifies delay, in milliseconds, between displaying and hiding popup hint.
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisableColorPaint | Gets or sets a value indicating whether hint control uses colors to paint its content.
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether hint control uses lexical colors/styles to paint its content.
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionWindow or it's child control has an input focus. (Inherited from CodeCompletionWindow.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | Gets or sets object that can make lexical analysis for the hint control content.
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Painter |
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.AutoHide Property

CodeCompletionHintAutoHide Property
Gets or sets a value indicating whether CodeCompletionHint should be closed after some period of time.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AutoHide { get; set; }
Public Overridable Property AutoHide As Boolean
    Get
    Set
public:
virtual property bool AutoHide {
    bool get ();
    void set (bool value);
}
abstract AutoHide : bool with get, set
override AutoHide : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionHintAutoHide
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace
CodeCompletionHintAutoHidePause


CodeCompletionHint.AutoHidePause Property

CodeCompletionHintAutoHidePause Property
Gets or sets a value that specifies delay, in milliseconds, between displaying and hiding popup hint.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AutoHidePause { get; set; }
Public Overridable Property AutoHidePause As Integer
    Get
    Set
public:
virtual property int AutoHidePause {
    int get ();
    void set (int value);
}
abstract AutoHidePause : int with get, set
override AutoHidePause : int with get, set

Property Value

Type: Int32

Implements

ICodeCompletionHintAutoHidePause
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace
CodeCompletionHintAutoHide


CodeCompletionHint.DisableColorPaint Property

CodeCompletionHintDisableColorPaint Property
Gets or sets a value indicating whether hint control uses colors to paint its content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DisableColorPaint { get; set; }
Public Overridable Property DisableColorPaint As Boolean
    Get
    Set
public:
virtual property bool DisableColorPaint {
    bool get ();
    void set (bool value);
}
abstract DisableColorPaint : bool with get, set
override DisableColorPaint : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxPaintDisableColorPaint
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.DisableSyntaxPaint Property

CodeCompletionHintDisableSyntaxPaint Property
Gets or sets a value indicating whether hint control uses lexical colors/styles to paint its content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DisableSyntaxPaint { get; set; }
Public Overridable Property DisableSyntaxPaint As Boolean
    Get
    Set
public:
virtual property bool DisableSyntaxPaint {
    bool get ();
    void set (bool value);
}
abstract DisableSyntaxPaint : bool with get, set
override DisableSyntaxPaint : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxPaintDisableSyntaxPaint
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.Lexer Property

CodeCompletionHintLexer Property
Gets or sets object that can make lexical analysis for the hint control content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexer Lexer { get; set; }
Public Overridable Property Lexer As ILexer
    Get
    Set
public:
virtual property ILexer^ Lexer {
    ILexer^ get ();
    void set (ILexer^ value);
}
abstract Lexer : ILexer with get, set
override Lexer : ILexer with get, set

Property Value

Type: ILexer

Implements

ISyntaxPaintLexer
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.Painter Property

CodeCompletionHintPainter Property

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPainter Painter { get; set; }
Public Property Painter As IPainter
    Get
    Set
public:
virtual property IPainter^ Painter {
    IPainter^ get () sealed;
    void set (IPainter^ value) sealed;
}
abstract Painter : IPainter with get, set
override Painter : IPainter with get, set

Property Value

Type: IPainter

Implements

ISyntaxPaintPainter
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint Events

CodeCompletionHint Events

The CodeCompletionHint type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when hint draws its content.
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HyperTextClick | Occurs when hypertext is clicked.
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.CustomDraw Event

CodeCompletionHintCustomDraw Event
Occurs when hint draws its content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event CustomDrawEvent CustomDraw
Public Event CustomDraw As CustomDrawEvent
public:
virtual  event CustomDrawEvent^ CustomDraw {
    void add (CustomDrawEvent^ value);
    void remove (CustomDrawEvent^ value);
}
abstract CustomDraw : IEvent<CustomDrawEvent,
    CustomDrawEventArgs>
override CustomDraw : IEvent<CustomDrawEvent,
    CustomDrawEventArgs>

Value

Type: Alternet.EditorCustomDrawEvent

Implements

ISyntaxPaintCustomDraw
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionHint.HyperTextClick Event

CodeCompletionHintHyperTextClick Event
Occurs when hypertext is clicked.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler HyperTextClick
Public Event HyperTextClick As EventHandler
public:
virtual  event EventHandler^ HyperTextClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HyperTextClick : IEvent<EventHandler,
    EventArgs>
override HyperTextClick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ICodeCompletionHintHyperTextClick
See Also

Reference

CodeCompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow Class

CodeCompletionWindow Class
Represents a base class for popup controls such as CodeCompletionBox and CodeCompletionHint.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CodeCompletionCodeCompletionWindow
Alternet.Editor.CodeCompletionCodeCompletionBox
Alternet.Editor.CodeCompletionCodeCompletionButton
Alternet.Editor.CodeCompletionCodeCompletionEdit
Alternet.Editor.CodeCompletionCodeCompletionHint

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionWindow : Form,
    ICodeCompletionWindow, IControl
Public Class CodeCompletionWindow
    Inherits Form
    Implements ICodeCompletionWindow, IControl
public ref class CodeCompletionWindow : public Form,
    ICodeCompletionWindow, IControl
type CodeCompletionWindow =
    class
        inherit Form
        interface ICodeCompletionWindow
        interface IControl
    end

The CodeCompletionWindow type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionWindow | Initializes a new instance of the CodeCompletionWindow class with default settings.
Public method | CodeCompletionWindow(Control) | Initializes a new instance of the CodeCompletionWindow class with specified owner.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window.
Public method | Close(Boolean, Boolean) | Closes the popup window.
Public method | Close(Boolean, Char) | Closes the popup window.
Public method | CloseDelayed | Closes the popup window with delay.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control.
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold.
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation.
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position.
Public method | PopupAt(Point) | Displays popup window at the specified screen position.
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position.
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position.
Public method | PositionChanged | Responds on changing position in the popup window.
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value.
Public method | ResetContent | Updates CodeCompletionWindow content from its Provider.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value.
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Overrides FormAutoSize.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultCodeCompletionFont |
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid.
Public property | FocusControl | Returns child control that has an input focus.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionWindow or it's child control has an input focus.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible.
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable.
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid.
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed.
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message.
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Remarks
Do not create instances of this class, use derived classes instead.
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow Constructor

CodeCompletionWindow Constructor
Overload List
 | Name | Description
Public method | CodeCompletionWindow | Initializes a new instance of the CodeCompletionWindow class with default settings.
Public method | CodeCompletionWindow(Control) | Initializes a new instance of the CodeCompletionWindow class with specified owner.
Top
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow Constructor

CodeCompletionWindow Constructor
Initializes a new instance of the CodeCompletionWindow class with default settings.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionWindow()
Public Sub New
public:
CodeCompletionWindow()
new : unit -> CodeCompletionWindow
See Also

Reference

CodeCompletionWindow Class
CodeCompletionWindow Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow Constructor (Control)

CodeCompletionWindow Constructor (Control)
Initializes a new instance of the CodeCompletionWindow class with specified owner.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionWindow(
    Control owner
)
Public Sub New (
    owner As Control
)
public:
CodeCompletionWindow(
    Control^ owner
)
new :
        owner : Control -> CodeCompletionWindow

Parameters

owner
Type: System.Windows.FormsControl
The SyntaxEdit control owning this new instance.
See Also

Reference

CodeCompletionWindow Class
CodeCompletionWindow Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow Methods

CodeCompletionWindow Methods

The CodeCompletionWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window.
Public method | Close(Boolean, Boolean) | Closes the popup window.
Public method | Close(Boolean, Char) | Closes the popup window.
Public method | CloseDelayed | Closes the popup window with delay.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control.
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold.
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation.
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position.
Public method | PopupAt(Point) | Displays popup window at the specified screen position.
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position.
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position.
Public method | PositionChanged | Responds on changing position in the popup window.
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value.
Public method | ResetContent | Updates CodeCompletionWindow content from its Provider.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value.
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.Close Method

CodeCompletionWindowClose Method
Overload List
 | Name | Description
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window.
Public method | Close(Boolean, Boolean) | Closes the popup window.
Public method | Close(Boolean, Char) | Closes the popup window.
Top
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.Close Method (Boolean)

CodeCompletionWindowClose Method (Boolean)
Closes the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Close(
    bool accept
)
Public Overridable Sub Close (
    accept As Boolean
)
public:
virtual void Close(
    bool accept
)
abstract Close :
        accept : bool -> unit
override Close :
        accept : bool -> unit

Parameters

accept
Type: SystemBoolean
Indicates whether the result of the popup should be accepted.

Implements

ICodeCompletionWindowClose(Boolean)
See Also

Reference

CodeCompletionWindow Class
Close Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.Close Method (Boolean, Boolean)

CodeCompletionWindowClose Method (Boolean, Boolean)
Closes the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Close(
    bool accept,
    bool setFocus
)
Public Overridable Sub Close (
    accept As Boolean,
    setFocus As Boolean
)
public:
virtual void Close(
    bool accept,
    bool setFocus
)
abstract Close :
        accept : bool *
        setFocus : bool -> unit
override Close :
        accept : bool *
        setFocus : bool -> unit

Parameters

accept
Type: SystemBoolean
Indicates whether the result of the popup should be accepted.
setFocus
Type: SystemBoolean
Indicates whether the owner control should be focused after closing popup window.

Implements

ICodeCompletionWindowClose(Boolean, Boolean)
See Also

Reference

CodeCompletionWindow Class
Close Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.Close Method (Boolean, Char)

CodeCompletionWindowClose Method (Boolean, Char)
Closes the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Close(
    bool accept,
    char keyChar
)
Public Overridable Sub Close (
    accept As Boolean,
    keyChar As Char
)
public:
virtual void Close(
    bool accept,
    wchar_t keyChar
)
abstract Close :
        accept : bool *
        keyChar : char -> unit
override Close :
        accept : bool *
        keyChar : char -> unit

Parameters

accept
Type: SystemBoolean
Indicates whether the result of the popup should be accepted.
keyChar
Type: SystemChar
Char that closes this window.
See Also

Reference

CodeCompletionWindow Class
Close Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.CloseDelayed Method

CodeCompletionWindowCloseDelayed Method
Closes the popup window with delay.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CloseDelayed(
    bool accept
)
Public Overridable Sub CloseDelayed (
    accept As Boolean
)
public:
virtual void CloseDelayed(
    bool accept
)
abstract CloseDelayed :
        accept : bool -> unit
override CloseDelayed :
        accept : bool -> unit

Parameters

accept
Type: SystemBoolean
Indicates whether the result of the popup should be accepted.

Implements

ICodeCompletionWindowCloseDelayed(Boolean)
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.ContainsControl Method

CodeCompletionWindowContainsControl Method
Retrieves a value indicating whether the popup window contains the specified control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ContainsControl(
    Control control
)
Public Overridable Function ContainsControl (
    control As Control
) As Boolean
public:
virtual bool ContainsControl(
    Control^ control
)
abstract ContainsControl :
        control : Control -> bool
override ContainsControl :
        control : Control -> bool

Parameters

control
Type: System.Windows.FormsControl
The Control to evaluate.

Return Value

Type: Boolean
True if the popup window contains the specified control; otherwise, false.

Implements

ICodeCompletionWindowContainsControl(Control)
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.ContainsMouseCursor Method

CodeCompletionWindowContainsMouseCursor Method
Determines whether control contains mouse position, with specified therehold.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ContainsMouseCursor(
    int therehold
)
Public Overridable Function ContainsMouseCursor (
    therehold As Integer
) As Boolean
public:
virtual bool ContainsMouseCursor(
    int therehold
)
abstract ContainsMouseCursor :
        therehold : int -> bool
override ContainsMouseCursor :
        therehold : int -> bool

Parameters

therehold
Type: SystemInt32
Specifies size, in pixels, of the inflated boundary of the control.

Return Value

Type: Boolean

Implements

ICodeCompletionWindowContainsMouseCursor(Int32)
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.EnsureVisible Method

CodeCompletionWindowEnsureVisible Method
Ensures that the popup window is visible in the screen working area, moving it if necessary.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EnsureVisible(
    ref Point position
)
Public Overridable Sub EnsureVisible (
    ByRef position As Point
)
public:
virtual void EnsureVisible(
    Point% position
)
abstract EnsureVisible :
        position : Point byref -> unit
override EnsureVisible :
        position : Point byref -> unit

Parameters

position
Type: System.DrawingPoint
Position in screen coordinates.

Implements

ICodeCompletionWindowEnsureVisible(Point)
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.MouseOverControl Method

CodeCompletionWindowMouseOverControl Method

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MouseOverControl(
    Point point
)
Public Overridable Function MouseOverControl (
    point As Point
) As Boolean
public:
virtual bool MouseOverControl(
    Point point
)
abstract MouseOverControl :
        point : Point -> bool
override MouseOverControl :
        point : Point -> bool

Parameters

point
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.PerformSearch Method

CodeCompletionWindowPerformSearch Method
Performs searching operation.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PerformSearch()
Public Overridable Function PerformSearch As Boolean
public:
virtual bool PerformSearch()
abstract PerformSearch : unit -> bool
override PerformSearch : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ICodeCompletionWindowPerformSearch
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.Popup Method

CodeCompletionWindowPopup Method
Displays popup window at the current mouse position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Popup()
Public Overridable Sub Popup
public:
virtual void Popup()
abstract Popup : unit -> unit
override Popup : unit -> unit

Implements

ICodeCompletionWindowPopup
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.PopupAt Method

CodeCompletionWindowPopupAt Method
Overload List
 | Name | Description
Public method | PopupAt(Point) | Displays popup window at the specified screen position.
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position.
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position.
Top
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.PopupAt Method (Point)

CodeCompletionWindowPopupAt Method (Point)
Displays popup window at the specified screen position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PopupAt(
    Point position
)
Public Overridable Sub PopupAt (
    position As Point
)
public:
virtual void PopupAt(
    Point position
)
abstract PopupAt :
        position : Point -> unit
override PopupAt :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
The Point object that specifies the coordinates at which popup window should be displayed.

Implements

ICodeCompletionWindowPopupAt(Point)
See Also

Reference

CodeCompletionWindow Class
PopupAt Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.PopupAt Method (Point, ICodeCompletionProvider)

CodeCompletionWindowPopupAt Method (Point, ICodeCompletionProvider)
Displays popup window at the specified position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PopupAt(
    Point position,
    ICodeCompletionProvider provider
)
Public Overridable Sub PopupAt (
    position As Point,
    provider As ICodeCompletionProvider
)
public:
virtual void PopupAt(
    Point position,
    ICodeCompletionProvider^ provider
)
abstract PopupAt :
        position : Point *
        provider : ICodeCompletionProvider -> unit
override PopupAt :
        position : Point *
        provider : ICodeCompletionProvider -> unit

Parameters

position
Type: System.DrawingPoint
The Point object that specifies the coordinates at which popup window should be displayed.
provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Specifies source of the content for this window

Implements

ICodeCompletionWindowPopupAt(Point, ICodeCompletionProvider)
See Also

Reference

CodeCompletionWindow Class
PopupAt Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.PopupAt Method (Int32, Int32)

CodeCompletionWindowPopupAt Method (Int32, Int32)
Displays popup window at the specified position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PopupAt(
    int x,
    int y
)
Public Overridable Sub PopupAt (
    x As Integer,
    y As Integer
)
public:
virtual void PopupAt(
    int x,
    int y
)
abstract PopupAt :
        x : int *
        y : int -> unit
override PopupAt :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
Horizontal coordinate at which popup window should be displayed.
y
Type: SystemInt32
Vertical coordinate at which popup window should be displayed.

Implements

ICodeCompletionWindowPopupAt(Int32, Int32)
See Also

Reference

CodeCompletionWindow Class
PopupAt Overload
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.PositionChanged Method

CodeCompletionWindowPositionChanged Method
Responds on changing position in the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate of current position.
y
Type: SystemInt32
Y-coordinate of current position.
deltaX
Type: SystemInt32
Horizontal offset.
deltaY
Type: SystemInt32
Vertical offset.

Implements

ICodeCompletionWindowPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.ResetAutoSize Method

CodeCompletionWindowResetAutoSize Method
Resets the AutoSize property to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAutoSize()
Public Overridable Sub ResetAutoSize
public:
virtual void ResetAutoSize()
abstract ResetAutoSize : unit -> unit
override ResetAutoSize : unit -> unit

Implements

ICodeCompletionWindowResetAutoSize
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.ResetCodeCompletionFlags Method

CodeCompletionWindowResetCodeCompletionFlags Method
Resets the CompletionFlags property to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetCodeCompletionFlags()
Public Overridable Sub ResetCodeCompletionFlags
public:
virtual void ResetCodeCompletionFlags()
abstract ResetCodeCompletionFlags : unit -> unit
override ResetCodeCompletionFlags : unit -> unit

Implements

ICodeCompletionWindowResetCodeCompletionFlags
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.ResetContent Method

CodeCompletionWindowResetContent Method
Updates CodeCompletionWindow content from its Provider.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetContent()
Public Overridable Sub ResetContent
public:
virtual void ResetContent()
abstract ResetContent : unit -> unit
override ResetContent : unit -> unit

Implements

ICodeCompletionWindowResetContent
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.ResetSizeable Method

CodeCompletionWindowResetSizeable Method
Resets the Sizeable property to its default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSizeable()
Public Overridable Sub ResetSizeable
public:
virtual void ResetSizeable()
abstract ResetSizeable : unit -> unit
override ResetSizeable : unit -> unit

Implements

ICodeCompletionWindowResetSizeable
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow Properties

CodeCompletionWindow Properties

The CodeCompletionWindow type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Overrides FormAutoSize.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultCodeCompletionFont |
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid.
Public property | FocusControl | Returns child control that has an input focus.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionWindow or it's child control has an input focus.
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible.
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable.
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid.
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.AutoSize Property

CodeCompletionWindowAutoSize Property
Gets or sets a value indicating whether a popup window is automatically resized to fit its contents.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool AutoSize { get; set; }
Public Overrides Property AutoSize As Boolean
    Get
    Set
public:
virtual property bool AutoSize {
    bool get () override;
    void set (bool value) override;
}
abstract AutoSize : bool with get, set
override AutoSize : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionWindowAutoSize
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.CompletionFlags Property

CodeCompletionWindowCompletionFlags Property
Gets or sets collection of attributes that specifies behavior of the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CodeCompletionFlags CompletionFlags { get; set; }
Public Overridable Property CompletionFlags As CodeCompletionFlags
    Get
    Set
public:
virtual property CodeCompletionFlags CompletionFlags {
    CodeCompletionFlags get ();
    void set (CodeCompletionFlags value);
}
abstract CompletionFlags : CodeCompletionFlags with get, set
override CompletionFlags : CodeCompletionFlags with get, set

Property Value

Type: CodeCompletionFlags

Implements

ICodeCompletionWindowCompletionFlags
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.DefaultCodeCompletionFont Property

CodeCompletionWindowDefaultCodeCompletionFont Property

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Font DefaultCodeCompletionFont { get; }
Public Shared ReadOnly Property DefaultCodeCompletionFont As Font
    Get
public:
static property Font^ DefaultCodeCompletionFont {
    Font^ get ();
}
static member DefaultCodeCompletionFont : Font with get

Property Value

Type: Font
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.DisplayPos Property

CodeCompletionWindowDisplayPos Property
Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point DisplayPos { get; set; }
Public Overridable Property DisplayPos As Point
    Get
    Set
public:
virtual property Point DisplayPos {
    Point get ();
    void set (Point value);
}
abstract DisplayPos : Point with get, set
override DisplayPos : Point with get, set

Property Value

Type: Point

Implements

ICodeCompletionWindowDisplayPos
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.DoNotFocusPopupControl Property

CodeCompletionWindowDoNotFocusPopupControl Property
Gets or sets a value indicating whether popup control should not be focused.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoNotFocusPopupControl { get; set; }
Public Property DoNotFocusPopupControl As Boolean
    Get
    Set
public:
property bool DoNotFocusPopupControl {
    bool get ();
    void set (bool value);
}
member DoNotFocusPopupControl : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.EndPos Property

CodeCompletionWindowEndPos Property
Specifies position within the text where CodeCompletionWindow is valid.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point EndPos { get; set; }
Public Overridable Property EndPos As Point
    Get
    Set
public:
virtual property Point EndPos {
    Point get ();
    void set (Point value);
}
abstract EndPos : Point with get, set
override EndPos : Point with get, set

Property Value

Type: Point

Implements

ICodeCompletionWindowEndPos
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace
CodeCompletionWindowStartPos


CodeCompletionWindow.FocusControl Property

CodeCompletionWindowFocusControl Property
Returns child control that has an input focus.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Control FocusControl { get; }
Public Overridable ReadOnly Property FocusControl As Control
    Get
public:
virtual property Control^ FocusControl {
    Control^ get ();
}
abstract FocusControl : Control with get
override FocusControl : Control with get

Property Value

Type: Control

Implements

ICodeCompletionWindowFocusControl
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.Images Property

CodeCompletionWindowImages Property
Gets or sets the ImageList for code completion items.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList Images { get; set; }
Public Overridable Property Images As ImageList
    Get
    Set
public:
virtual property ImageList^ Images {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract Images : ImageList with get, set
override Images : ImageList with get, set

Property Value

Type: ImageList

Implements

ICodeCompletionWindowImages
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.IsFocused Property

CodeCompletionWindowIsFocused Property
Indicates whether CodeCompletionWindow or it's child control has an input focus.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsFocused { get; }
Public Overridable ReadOnly Property IsFocused As Boolean
    Get
public:
virtual property bool IsFocused {
    bool get ();
}
abstract IsFocused : bool with get
override IsFocused : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionWindowIsFocused
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.IsVisible Property

CodeCompletionWindowIsVisible Property
Indicates if window is visible.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsVisible { get; }
Public Overridable ReadOnly Property IsVisible As Boolean
    Get
public:
virtual property bool IsVisible {
    bool get ();
}
abstract IsVisible : bool with get
override IsVisible : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionWindowIsVisible
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.OwnerControl Property

CodeCompletionWindowOwnerControl Property
Represents a control owning this CodeCompletionWindow object.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Control OwnerControl { get; set; }
Public Overridable Property OwnerControl As Control
    Get
    Set
public:
virtual property Control^ OwnerControl {
    Control^ get ();
    void set (Control^ value);
}
abstract OwnerControl : Control with get, set
override OwnerControl : Control with get, set

Property Value

Type: Control

Implements

ICodeCompletionWindowOwnerControl
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.PopupControl Property

CodeCompletionWindowPopupControl Property
Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Control PopupControl { get; }
Public Overridable ReadOnly Property PopupControl As Control
    Get
public:
virtual property Control^ PopupControl {
    Control^ get ();
}
abstract PopupControl : Control with get
override PopupControl : Control with get

Property Value

Type: Control

Implements

ICodeCompletionWindowPopupControl
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace
Alternet.Editor.CodeCompletionCodeCompletionHint
Alternet.Editor.CodeCompletionCompletionListBox


CodeCompletionWindow.Provider Property

CodeCompletionWindowProvider Property
Gets or sets the object that contains data related to the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionProvider Provider { get; set; }
Public Overridable Property Provider As ICodeCompletionProvider
    Get
    Set
public:
virtual property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get ();
    void set (ICodeCompletionProvider^ value);
}
abstract Provider : ICodeCompletionProvider with get, set
override Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider

Implements

ICodeCompletionWindowProvider
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.Sizeable Property

CodeCompletionWindowSizeable Property
Gets or sets a value indicating whether the border of the popup window is sizable.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Sizeable { get; set; }
Public Overridable Property Sizeable As Boolean
    Get
    Set
public:
virtual property bool Sizeable {
    bool get ();
    void set (bool value);
}
abstract Sizeable : bool with get, set
override Sizeable : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionWindowSizeable
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.StartPos Property

CodeCompletionWindowStartPos Property
Specifies position within the text where CodeCompletionWindow is valid.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point StartPos { get; set; }
Public Overridable Property StartPos As Point
    Get
    Set
public:
virtual property Point StartPos {
    Point get ();
    void set (Point value);
}
abstract StartPos : Point with get, set
override StartPos : Point with get, set

Property Value

Type: Point

Implements

ICodeCompletionWindowStartPos
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace
CodeCompletionWindowEndPos


CodeCompletionWindow Events

CodeCompletionWindow Events

The CodeCompletionWindow type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed.
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message.
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.ClosePopup Event

CodeCompletionWindowClosePopup Event
Occurs when the popup window is closed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event ClosePopupEvent ClosePopup
Public Event ClosePopup As ClosePopupEvent
public:
virtual  event ClosePopupEvent^ ClosePopup {
    void add (ClosePopupEvent^ value);
    void remove (ClosePopupEvent^ value);
}
abstract ClosePopup : IEvent<ClosePopupEvent,
    ClosingEventArgs>
override ClosePopup : IEvent<ClosePopupEvent,
    ClosingEventArgs>

Value

Type: Alternet.SyntaxClosePopupEvent

Implements

ICodeCompletionWindowClosePopup
Remarks
The event handler receives an argument of type ClosingEventArgs containing data related to this event.
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.KeyPreviewEvent Event

CodeCompletionWindowKeyPreviewEvent Event
Occurs when the popup window receives key message.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event KeyPreviewEvent KeyPreviewEvent
Public Event KeyPreviewEvent As KeyPreviewEvent
public:
virtual  event KeyPreviewEvent^ KeyPreviewEvent {
    void add (KeyPreviewEvent^ value);
    void remove (KeyPreviewEvent^ value);
}
abstract KeyPreviewEvent : IEvent<KeyPreviewEvent,
    KeyPreviewEventArgs>
override KeyPreviewEvent : IEvent<KeyPreviewEvent,
    KeyPreviewEventArgs>

Value

Type: Alternet.EditorKeyPreviewEvent

Implements

ICodeCompletionWindowKeyPreviewEvent
Remarks
The event handler receives an argument of type KeyPreviewEventArgs containing data related to this event.
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CodeCompletionWindow.ShowPopup Event

CodeCompletionWindowShowPopup Event
Occurs when the popup window is displayed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event ShowPopupEvent ShowPopup
Public Event ShowPopup As ShowPopupEvent
public:
virtual  event ShowPopupEvent^ ShowPopup {
    void add (ShowPopupEvent^ value);
    void remove (ShowPopupEvent^ value);
}
abstract ShowPopup : IEvent<ShowPopupEvent,
    ShowingEventArgs>
override ShowPopup : IEvent<ShowPopupEvent,
    ShowingEventArgs>

Value

Type: Alternet.SyntaxShowPopupEvent

Implements

ICodeCompletionWindowShowPopup
Remarks
The event handler receives an argument of type ShowingEventArgs containing data related to this event.
See Also

Reference

CodeCompletionWindow Class
Alternet.Editor.CodeCompletion Namespace


CompletionButton Class

CompletionButton Class
Represents a button-like control used to display code completion in a form of drop-down menu.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Editor.CodeCompletionCompletionButton

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CompletionButton : UserControl,
    ICompletionButton, IControl
Public Class CompletionButton
    Inherits UserControl
    Implements ICompletionButton, IControl
public ref class CompletionButton : public UserControl,
    ICompletionButton, IControl
type CompletionButton =
    class
        inherit UserControl
        interface ICompletionButton
        interface IControl
    end

The CompletionButton type exposes the following members.

Constructors
 | Name | Description
Public method | CompletionButton | Initializes a new instance of the CompletionButton class with specified owner.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | DropDown | Display drop down menu.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndex | Returns current index.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetContent | Updates CompletionButton content from its Provider.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Image | Gets or sets a bulb image displayed in this control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Menu | Gets or sets a ContextMenuStrip associated with this control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Represents the object that provides data for code completion.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CompletionButton Constructor

CompletionButton Constructor
Initializes a new instance of the CompletionButton class with specified owner.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompletionButton(
    ICodeCompletionButton owner
)
Public Sub New (
    owner As ICodeCompletionButton
)
public:
CompletionButton(
    ICodeCompletionButton^ owner
)
new :
        owner : ICodeCompletionButton -> CompletionButton

Parameters

owner
Type: Alternet.Editor.CodeCompletionICodeCompletionButton
ICodeCompletionButton that owns this new instance.
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CompletionButton Methods

CompletionButton Methods

The CompletionButton type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | DropDown | Display drop down menu.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndex | Returns current index.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetContent | Updates CompletionButton content from its Provider.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CompletionButton.DropDown Method

CompletionButtonDropDown Method
Display drop down menu.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DropDown()
Public Sub DropDown
public:
void DropDown()
member DropDown : unit -> unit
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CompletionButton.GetIndex Method

CompletionButtonGetIndex Method
Returns current index.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetIndex(
    bool acceptIfFocused
)
Public Function GetIndex (
    acceptIfFocused As Boolean
) As Integer
public:
virtual int GetIndex(
    bool acceptIfFocused
) sealed
abstract GetIndex :
        acceptIfFocused : bool -> int
override GetIndex :
        acceptIfFocused : bool -> int

Parameters

acceptIfFocused
Type: SystemBoolean
specifies if focused item will be returned

Return Value

Type: Int32
Index of the currently selected item.

Implements

ICompletionButtonGetIndex(Boolean)
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CompletionButton.ResetContent Method

CompletionButtonResetContent Method
Updates CompletionButton content from its Provider.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetContent()
Public Sub ResetContent
public:
virtual void ResetContent() sealed
abstract ResetContent : unit -> unit
override ResetContent : unit -> unit

Implements

ICompletionButtonResetContent
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CompletionButton Properties

CompletionButton Properties

The CompletionButton type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Image | Gets or sets a bulb image displayed in this control.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Menu | Gets or sets a ContextMenuStrip associated with this control.
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Represents the object that provides data for code completion.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CompletionButton.Image Property

CompletionButtonImage Property
Gets or sets a bulb image displayed in this control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Property Value

Type: Image
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CompletionButton.Menu Property

CompletionButtonMenu Property
Gets or sets a ContextMenuStrip associated with this control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContextMenuStrip Menu { get; set; }
Public Property Menu As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ Menu {
    ContextMenuStrip^ get () sealed;
    void set (ContextMenuStrip^ value) sealed;
}
abstract Menu : ContextMenuStrip with get, set
override Menu : ContextMenuStrip with get, set

Property Value

Type: ContextMenuStrip

Implements

ICompletionButtonMenu
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CompletionButton.Provider Property

CompletionButtonProvider Property
Represents the object that provides data for code completion.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionProvider Provider { get; set; }
Public Property Provider As ICodeCompletionProvider
    Get
    Set
public:
virtual property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get () sealed;
    void set (ICodeCompletionProvider^ value) sealed;
}
abstract Provider : ICodeCompletionProvider with get, set
override Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider

Implements

ICompletionButtonProvider
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace
Alternet.Syntax.CodeCompletionICodeCompletionProvider


CompletionButton Events

CompletionButton Events

The CompletionButton type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CompletionButton Class
Alternet.Editor.CodeCompletion Namespace


CompletionEdit Class

CompletionEdit Class
Represents a completion list box control. This class inherited from ListBox class and provides similar functionality for code completion requirements.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Editor.CodeCompletionCompletionEdit

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CompletionEdit : UserControl,
    ICompletionEdit, IControl
Public Class CompletionEdit
    Inherits UserControl
    Implements ICompletionEdit, IControl
public ref class CompletionEdit : public UserControl,
    ICompletionEdit, IControl
type CompletionEdit =
    class
        inherit UserControl
        interface ICompletionEdit
        interface IControl
    end

The CompletionEdit type exposes the following members.

Constructors
 | Name | Description
Public method | CompletionEdit | Initializes a new instance of the CompletionEdit class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | UpdateSize | Updates size of this ICompletionEdit control.
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | EditBox | Represents a text box allowing to edit content of the CompletionEditcontrol.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Label | Represents a label associated with the edit CompletionEditcontrol.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PathLabel | Represents a path label associated with the edit CompletionEditcontrol.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CompletionEdit Constructor

CompletionEdit Constructor
Initializes a new instance of the CompletionEdit class with default settings.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompletionEdit()
Public Sub New
public:
CompletionEdit()
new : unit -> CompletionEdit
See Also

Reference

CompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CompletionEdit Methods

CompletionEdit Methods

The CompletionEdit type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | UpdateSize | Updates size of this ICompletionEdit control.
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

CompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CompletionEdit.UpdateSize Method

CompletionEditUpdateSize Method
Updates size of this ICompletionEdit control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateSize()
Public Sub UpdateSize
public:
virtual void UpdateSize() sealed
abstract UpdateSize : unit -> unit
override UpdateSize : unit -> unit

Implements

ICompletionEditUpdateSize
See Also

Reference

CompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CompletionEdit Properties

CompletionEdit Properties

The CompletionEdit type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | EditBox | Represents a text box allowing to edit content of the CompletionEditcontrol.
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Label | Represents a label associated with the edit CompletionEditcontrol.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PathLabel | Represents a path label associated with the edit CompletionEditcontrol.
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CompletionEdit.EditBox Property

CompletionEditEditBox Property
Represents a text box allowing to edit content of the CompletionEditcontrol.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextBox EditBox { get; }
Public ReadOnly Property EditBox As TextBox
    Get
public:
virtual property TextBox^ EditBox {
    TextBox^ get () sealed;
}
abstract EditBox : TextBox with get
override EditBox : TextBox with get

Property Value

Type: TextBox

Implements

ICompletionEditEditBox
See Also

Reference

CompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CompletionEdit.Label Property

CompletionEditLabel Property
Represents a label associated with the edit CompletionEditcontrol.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Label Label { get; }
Public ReadOnly Property Label As Label
    Get
public:
virtual property Label^ Label {
    Label^ get () sealed;
}
abstract Label : Label with get
override Label : Label with get

Property Value

Type: Label

Implements

ICompletionEditLabel
See Also

Reference

CompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CompletionEdit.PathLabel Property

CompletionEditPathLabel Property
Represents a path label associated with the edit CompletionEditcontrol.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Label PathLabel { get; }
Public ReadOnly Property PathLabel As Label
    Get
public:
virtual property Label^ PathLabel {
    Label^ get () sealed;
}
abstract PathLabel : Label with get
override PathLabel : Label with get

Property Value

Type: Label

Implements

ICompletionEditPathLabel
See Also

Reference

CompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CompletionEdit Events

CompletionEdit Events

The CompletionEdit type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CompletionEdit Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint Class

CompletionHint Class
Represents a tooltip-like control used in a code completion.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.Editor.CodeCompletionCompletionHint

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CompletionHint : Control
Public Class CompletionHint
    Inherits Control
public ref class CompletionHint : public Control
type CompletionHint =
    class
        inherit Control
    end

The CompletionHint type exposes the following members.

Constructors
 | Name | Description
Public method | CompletionHint | Initializes a new instance of the CompletionHint class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ChangeSelection | Increments or decrementsSelectedIndex property.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | IsOnHyperText |
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetContent | Updates CompletionHint content from its Provider.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | UpdateHint | Updates content, position and size of the hint window.
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HintSize | Returns a size of the hint control.
Public property | Images | Represents an image list associated with this CompletionHint.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NeedArrows | Indicates whether hint control have to paint up/down arrows.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets an object that contains data related to this CompletionHint.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index specifying the currently selected hint item.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StartPos | Gets or sets start position of the hint in text coordinates.
Public property | SyntaxPaint | Represents ISyntaxPaint interface used to draw control's content.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpdateSize | Occurs when size of the hint control is changed.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CompletionHint Constructor

CompletionHint Constructor
Initializes a new instance of the CompletionHint class with default settings.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompletionHint()
Public Sub New
public:
CompletionHint()
new : unit -> CompletionHint
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint Methods

CompletionHint Methods

The CompletionHint type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ChangeSelection | Increments or decrementsSelectedIndex property.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | IsOnHyperText |
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetContent | Updates CompletionHint content from its Provider.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | UpdateHint | Updates content, position and size of the hint window.
Top
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.ChangeSelection Method

CompletionHintChangeSelection Method
Increments or decrementsSelectedIndex property.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ChangeSelection(
    bool inc
)
Public Sub ChangeSelection (
    inc As Boolean
)
public:
void ChangeSelection(
    bool inc
)
member ChangeSelection :
        inc : bool -> unit

Parameters

inc
Type: SystemBoolean
Specifies whether SelectedIndex should be incremented.
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.IsOnHyperText Method

CompletionHintIsOnHyperText Method

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsOnHyperText(
    int x,
    int y
)
Public Overridable Function IsOnHyperText (
    x As Integer,
    y As Integer
) As Boolean
public:
virtual bool IsOnHyperText(
    int x,
    int y
)
abstract IsOnHyperText :
        x : int *
        y : int -> bool
override IsOnHyperText :
        x : int *
        y : int -> bool

Parameters

x
Type: SystemInt32
y
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.ResetContent Method

CompletionHintResetContent Method
Updates CompletionHint content from its Provider.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetContent()
Public Sub ResetContent
public:
void ResetContent()
member ResetContent : unit -> unit
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.UpdateHint Method

CompletionHintUpdateHint Method
Updates content, position and size of the hint window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UpdateHint()
Public Function UpdateHint As Boolean
public:
bool UpdateHint()
member UpdateHint : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint Properties

CompletionHint Properties

The CompletionHint type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HintSize | Returns a size of the hint control.
Public property | Images | Represents an image list associated with this CompletionHint.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NeedArrows | Indicates whether hint control have to paint up/down arrows.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets an object that contains data related to this CompletionHint.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedIndex | Gets or sets the index specifying the currently selected hint item.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | StartPos | Gets or sets start position of the hint in text coordinates.
Public property | SyntaxPaint | Represents ISyntaxPaint interface used to draw control's content.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UpdateSize | Occurs when size of the hint control is changed.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.HintSize Property

CompletionHintHintSize Property
Returns a size of the hint control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Size HintSize { get; }
Public ReadOnly Property HintSize As Size
    Get
public:
property Size HintSize {
    Size get ();
}
member HintSize : Size with get

Property Value

Type: Size
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.Images Property

CompletionHintImages Property
Represents an image list associated with this CompletionHint.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageList Images { get; }
Public ReadOnly Property Images As ImageList
    Get
public:
property ImageList^ Images {
    ImageList^ get ();
}
member Images : ImageList with get

Property Value

Type: ImageList
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.NeedArrows Property

CompletionHintNeedArrows Property
Indicates whether hint control have to paint up/down arrows.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedArrows { get; }
Public ReadOnly Property NeedArrows As Boolean
    Get
public:
property bool NeedArrows {
    bool get ();
}
member NeedArrows : bool with get

Property Value

Type: Boolean
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.Provider Property

CompletionHintProvider Property
Gets or sets an object that contains data related to this CompletionHint.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionProvider Provider { get; set; }
Public Property Provider As ICodeCompletionProvider
    Get
    Set
public:
property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get ();
    void set (ICodeCompletionProvider^ value);
}
member Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.SelectedIndex Property

CompletionHintSelectedIndex Property
Gets or sets the index specifying the currently selected hint item.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SelectedIndex { get; set; }
Public Property SelectedIndex As Integer
    Get
    Set
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}
member SelectedIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.StartPos Property

CompletionHintStartPos Property
Gets or sets start position of the hint in text coordinates.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point StartPos { get; set; }
Public Property StartPos As Point
    Get
    Set
public:
property Point StartPos {
    Point get ();
    void set (Point value);
}
member StartPos : Point with get, set

Return Value

Type: Point
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.SyntaxPaint Property

CompletionHintSyntaxPaint Property
Represents ISyntaxPaint interface used to draw control's content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISyntaxPaint SyntaxPaint { get; }
Public ReadOnly Property SyntaxPaint As ISyntaxPaint
    Get
public:
property ISyntaxPaint^ SyntaxPaint {
    ISyntaxPaint^ get ();
}
member SyntaxPaint : ISyntaxPaint with get

Property Value

Type: ISyntaxPaint
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint.UpdateSize Property

CompletionHintUpdateSize Property
Occurs when size of the hint control is changed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventHandler UpdateSize { get; set; }
Public Property UpdateSize As EventHandler
    Get
    Set
public:
property EventHandler^ UpdateSize {
    EventHandler^ get ();
    void set (EventHandler^ value);
}
member UpdateSize : EventHandler with get, set

Property Value

Type: EventHandler
Remarks
The event handler receives an argument of type EventArgs containing data related to this event.
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionHint Events

CompletionHint Events

The CompletionHint type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CompletionHint Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox Class

CompletionListBox Class
Represents a completion list box control. This class inherited from ListBox class and provides similar functionality for code completion requirements.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsListBox
Alternet.Editor.CodeCompletionListBoxWithAdvancedScrolling
Alternet.Editor.CodeCompletionCompletionListBox
Alternet.Scripter.IntegrationEditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CompletionListBox : ListBoxWithAdvancedScrolling,
    ICompletionListBox, IControl
Public Class CompletionListBox
    Inherits ListBoxWithAdvancedScrolling
    Implements ICompletionListBox, IControl
public ref class CompletionListBox : public ListBoxWithAdvancedScrolling,
    ICompletionListBox, IControl
type CompletionListBox =
    class
        inherit ListBoxWithAdvancedScrolling
        interface ICompletionListBox
        interface IControl
    end

The CompletionListBox type exposes the following members.

Constructors
 | Name | Description
Public method | CompletionListBox | Initializes a new instance of the CompletionListBox class with default settings.
Top
Methods
 | Name | Description
Public method | AddColumn | Adds a new column to the end of the CompletionListBox column collection.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CompletionListBox column collection.
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetColumn | Returns a column by specifies index.
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndex | Returns current index.
Public method | GetIndex(Boolean) | Returns current index.
Public method | GetIndex(Int32) | Returns current index.
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position of the CompletionListBox columns collection.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | RemoveColumnAt | Removes column at the specified position from the CompletionListBox column collection.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetContent | Updates CompletionListBox content from its Provider.
Public method | ResetContent(Int32) | Updates CompletionListBox content from its Provider.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnCount | Returns number of the columns in the listbox.
Public property | Columns | Represents ICodeCompletionColumn collection.
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Filter | Gets or sets filter string to filter CompletionListBox content.
Public property | Filtered | Gets or sets a boolean value that indicates whether CompletionListBox should filter its content using Filer property.
Public property | FilterOptions | Gets or sets rules specifying how list box should filter its content.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusMode | Specifies item preselection mode.
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | Images | Represents an image list associated with this CompletionListBox.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | ItemImagePadding | Gets or sets padding of the image part.
Public property | Items | Gets the items appears in the CompletionListBox.
Public property | ItemTextPadding | Gets or sets padding of the text part.
Public property | ItemWidth | Gets width of the widest item.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavKeys | Represents a key collection used to navigate within the CompletionListBox content.
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | Priority | Gets or sets priority filter to filter CompletionListBox content.
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Represents the object that provides data for code completion.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in the CompletionListBox. (Overrides ListBoxSelectedIndex.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | VerticalScrollBarVisible | (Inherited from ListBoxWithAdvancedScrolling.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemsChanged | (Inherited from ListBoxWithAdvancedScrolling.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | UpdateSize | Occurs when size of the control is changed.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VerticalScrollChanged | (Inherited from ListBoxWithAdvancedScrolling.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


CompletionListBox Constructor

CompletionListBox Constructor
Initializes a new instance of the CompletionListBox class with default settings.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompletionListBox()
Public Sub New
public:
CompletionListBox()
new : unit -> CompletionListBox
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox Methods

CompletionListBox Methods

The CompletionListBox type exposes the following members.

Methods
 | Name | Description
Public method | AddColumn | Adds a new column to the end of the CompletionListBox column collection.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CompletionListBox column collection.
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetColumn | Returns a column by specifies index.
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndex | Returns current index.
Public method | GetIndex(Boolean) | Returns current index.
Public method | GetIndex(Int32) | Returns current index.
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position of the CompletionListBox columns collection.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | RemoveColumnAt | Removes column at the specified position from the CompletionListBox column collection.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetContent | Updates CompletionListBox content from its Provider.
Public method | ResetContent(Int32) | Updates CompletionListBox content from its Provider.
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.AddColumn Method

CompletionListBoxAddColumn Method
Adds a new column to the end of the CompletionListBox column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionColumn AddColumn()
Public Function AddColumn As ICodeCompletionColumn
public:
virtual ICodeCompletionColumn^ AddColumn() sealed
abstract AddColumn : unit -> ICodeCompletionColumn
override AddColumn : unit -> ICodeCompletionColumn

Return Value

Type: ICodeCompletionColumn
ICodeCompletionColumn added.
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.ClearColumns Method

CompletionListBoxClearColumns Method
Removes all columns from the CompletionListBox column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearColumns()
Public Sub ClearColumns
public:
virtual void ClearColumns() sealed
abstract ClearColumns : unit -> unit
override ClearColumns : unit -> unit
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.GetColumn Method

CompletionListBoxGetColumn Method
Returns a column by specifies index.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionColumn GetColumn(
    int index
)
Public Function GetColumn (
    index As Integer
) As ICodeCompletionColumn
public:
ICodeCompletionColumn^ GetColumn(
    int index
)
member GetColumn :
        index : int -> ICodeCompletionColumn

Parameters

index
Type: SystemInt32
Specifies index of the column to obtain.

Return Value

Type: ICodeCompletionColumn
ICodeCompletionColumn object at specified position.
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.GetIndex Method

CompletionListBoxGetIndex Method
Overload List
 | Name | Description
Public method | GetIndex | Returns current index.
Public method | GetIndex(Boolean) | Returns current index.
Public method | GetIndex(Int32) | Returns current index.
Top
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.GetIndex Method

CompletionListBoxGetIndex Method
Returns current index.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetIndex()
Public Function GetIndex As Integer
public:
virtual int GetIndex() sealed
abstract GetIndex : unit -> int
override GetIndex : unit -> int

Return Value

Type: Int32
Index of the currently selected item.
See Also

Reference

CompletionListBox Class
GetIndex Overload
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.GetIndex Method (Boolean)

CompletionListBoxGetIndex Method (Boolean)
Returns current index.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetIndex(
    bool acceptIfFocused
)
Public Function GetIndex (
    acceptIfFocused As Boolean
) As Integer
public:
virtual int GetIndex(
    bool acceptIfFocused
) sealed
abstract GetIndex :
        acceptIfFocused : bool -> int
override GetIndex :
        acceptIfFocused : bool -> int

Parameters

acceptIfFocused
Type: SystemBoolean
specifies if focused item will be returned

Return Value

Type: Int32
Index of the currently selected item.
See Also

Reference

CompletionListBox Class
GetIndex Overload
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.GetIndex Method (Int32)

CompletionListBoxGetIndex Method (Int32)
Returns current index.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetIndex(
    int index
)
Public Function GetIndex (
    index As Integer
) As Integer
public:
virtual int GetIndex(
    int index
) sealed
abstract GetIndex :
        index : int -> int
override GetIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Default index value.

Return Value

Type: Int32
Index of the currently selected item.
See Also

Reference

CompletionListBox Class
GetIndex Overload
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.InsertColumn Method

CompletionListBoxInsertColumn Method
Inserts a new column to the specified position of the CompletionListBox columns collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionColumn InsertColumn(
    int index
)
Public Function InsertColumn (
    index As Integer
) As ICodeCompletionColumn
public:
virtual ICodeCompletionColumn^ InsertColumn(
    int index
) sealed
abstract InsertColumn :
        index : int -> ICodeCompletionColumn
override InsertColumn :
        index : int -> ICodeCompletionColumn

Parameters

index
Type: SystemInt32
Position of the column to insert.

Return Value

Type: ICodeCompletionColumn
ICodeCompletionColumn inserted.
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.RemoveColumnAt Method

CompletionListBoxRemoveColumnAt Method
Removes column at the specified position from the CompletionListBox column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveColumnAt(
    int index
)
Public Sub RemoveColumnAt (
    index As Integer
)
public:
virtual void RemoveColumnAt(
    int index
) sealed
abstract RemoveColumnAt :
        index : int -> unit
override RemoveColumnAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies index of the column to remove.
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.ResetContent Method

CompletionListBoxResetContent Method
Overload List
 | Name | Description
Public method | ResetContent | Updates CompletionListBox content from its Provider.
Public method | ResetContent(Int32) | Updates CompletionListBox content from its Provider.
Top
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.ResetContent Method

CompletionListBoxResetContent Method
Updates CompletionListBox content from its Provider.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetContent()
Public Sub ResetContent
public:
virtual void ResetContent() sealed
abstract ResetContent : unit -> unit
override ResetContent : unit -> unit
See Also

Reference

CompletionListBox Class
ResetContent Overload
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.ResetContent Method (Int32)

CompletionListBoxResetContent Method (Int32)
Updates CompletionListBox content from its Provider.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetContent(
    int index
)
Public Sub ResetContent (
    index As Integer
)
public:
virtual void ResetContent(
    int index
) sealed
abstract ResetContent :
        index : int -> unit
override ResetContent :
        index : int -> unit

Parameters

index
Type: SystemInt32
The integer value that specifies SelectedIndex property of the CompletionListBox.
See Also

Reference

CompletionListBox Class
ResetContent Overload
Alternet.Editor.CodeCompletion Namespace


CompletionListBox Properties

CompletionListBox Properties

The CompletionListBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnCount | Returns number of the columns in the listbox.
Public property | Columns | Represents ICodeCompletionColumn collection.
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Filter | Gets or sets filter string to filter CompletionListBox content.
Public property | Filtered | Gets or sets a boolean value that indicates whether CompletionListBox should filter its content using Filer property.
Public property | FilterOptions | Gets or sets rules specifying how list box should filter its content.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusMode | Specifies item preselection mode.
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | Images | Represents an image list associated with this CompletionListBox.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | ItemImagePadding | Gets or sets padding of the image part.
Public property | Items | Gets the items appears in the CompletionListBox.
Public property | ItemTextPadding | Gets or sets padding of the text part.
Public property | ItemWidth | Gets width of the widest item.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavKeys | Represents a key collection used to navigate within the CompletionListBox content.
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | Priority | Gets or sets priority filter to filter CompletionListBox content.
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Represents the object that provides data for code completion.
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in the CompletionListBox. (Overrides ListBoxSelectedIndex.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | VerticalScrollBarVisible | (Inherited from ListBoxWithAdvancedScrolling.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.ColumnCount Property

CompletionListBoxColumnCount Property
Returns number of the columns in the listbox.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ColumnCount { get; }
Public ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () sealed;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.Columns Property

CompletionListBoxColumns Property
Represents ICodeCompletionColumn collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionColumns Columns { get; }
Public ReadOnly Property Columns As ICodeCompletionColumns
    Get
public:
virtual property ICodeCompletionColumns^ Columns {
    ICodeCompletionColumns^ get () sealed;
}
abstract Columns : ICodeCompletionColumns with get
override Columns : ICodeCompletionColumns with get

Property Value

Type: ICodeCompletionColumns
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.Filter Property

CompletionListBoxFilter Property
Gets or sets filter string to filter CompletionListBox content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Filter { get; set; }
Public Property Filter As String
    Get
    Set
public:
virtual property String^ Filter {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Filter : string with get, set
override Filter : string with get, set

Property Value

Type: String
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace
CompletionListBoxFiltered


CompletionListBox.Filtered Property

CompletionListBoxFiltered Property
Gets or sets a boolean value that indicates whether CompletionListBox should filter its content using Filer property.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Filtered { get; set; }
Public Property Filtered As Boolean
    Get
    Set
public:
virtual property bool Filtered {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Filtered : bool with get, set
override Filtered : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace
CompletionListBoxFilter


CompletionListBox.FilterOptions Property

CompletionListBoxFilterOptions Property
Gets or sets rules specifying how list box should filter its content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompletionListFilterOptions FilterOptions { get; set; }
Public Property FilterOptions As CompletionListFilterOptions
    Get
    Set
public:
virtual property CompletionListFilterOptions FilterOptions {
    CompletionListFilterOptions get () sealed;
    void set (CompletionListFilterOptions value) sealed;
}
abstract FilterOptions : CompletionListFilterOptions with get, set
override FilterOptions : CompletionListFilterOptions with get, set

Property Value

Type: CompletionListFilterOptions
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.FocusMode Property

CompletionListBoxFocusMode Property
Specifies item preselection mode.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ItemFocusMode FocusMode { get; set; }
Public Property FocusMode As ItemFocusMode
    Get
    Set
public:
virtual property ItemFocusMode FocusMode {
    ItemFocusMode get () sealed;
    void set (ItemFocusMode value) sealed;
}
abstract FocusMode : ItemFocusMode with get, set
override FocusMode : ItemFocusMode with get, set

Property Value

Type: ItemFocusMode
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.Images Property

CompletionListBoxImages Property
Represents an image list associated with this CompletionListBox.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageList Images { get; set; }
Public Property Images As ImageList
    Get
    Set
public:
virtual property ImageList^ Images {
    ImageList^ get () sealed;
    void set (ImageList^ value) sealed;
}
abstract Images : ImageList with get, set
override Images : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.ItemImagePadding Property

CompletionListBoxItemImagePadding Property
Gets or sets padding of the image part.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Padding ItemImagePadding { get; set; }
Public Overridable Property ItemImagePadding As Padding
    Get
    Set
public:
virtual property Padding ItemImagePadding {
    Padding get ();
    void set (Padding value);
}
abstract ItemImagePadding : Padding with get, set
override ItemImagePadding : Padding with get, set

Property Value

Type: Padding
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.Items Property

CompletionListBoxItems Property
Gets the items appears in the CompletionListBox.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList Items { get; }
Public ReadOnly Property Items As IList
    Get
public:
virtual property IList^ Items {
    IList^ get () sealed;
}
abstract Items : IList with get
override Items : IList with get

Property Value

Type: IList
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.ItemTextPadding Property

CompletionListBoxItemTextPadding Property
Gets or sets padding of the text part.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Padding ItemTextPadding { get; set; }
Public Overridable Property ItemTextPadding As Padding
    Get
    Set
public:
virtual property Padding ItemTextPadding {
    Padding get ();
    void set (Padding value);
}
abstract ItemTextPadding : Padding with get, set
override ItemTextPadding : Padding with get, set

Property Value

Type: Padding
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.ItemWidth Property

CompletionListBoxItemWidth Property
Gets width of the widest item.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ItemWidth { get; }
Public ReadOnly Property ItemWidth As Integer
    Get
public:
virtual property int ItemWidth {
    int get () sealed;
}
abstract ItemWidth : int with get
override ItemWidth : int with get

Property Value

Type: Int32
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.NavKeys Property

CompletionListBoxNavKeys Property
Represents a key collection used to navigate within the CompletionListBox content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Keys[] NavKeys { get; }
Public ReadOnly Property NavKeys As Keys()
    Get
public:
virtual property array<Keys>^ NavKeys {
    array<Keys>^ get () sealed;
}
abstract NavKeys : Keys[] with get
override NavKeys : Keys[] with get

Property Value

Type: Keys
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.Priority Property

CompletionListBoxPriority Property
Gets or sets priority filter to filter CompletionListBox content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Priority { get; set; }
Public Property Priority As Integer
    Get
    Set
public:
virtual property int Priority {
    int get () sealed;
    void set (int value) sealed;
}
abstract Priority : int with get, set
override Priority : int with get, set

Property Value

Type: Int32
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace
CompletionListBoxFilter


CompletionListBox.Provider Property

CompletionListBoxProvider Property
Represents the object that provides data for code completion.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionProvider Provider { get; set; }
Public Property Provider As ICodeCompletionProvider
    Get
    Set
public:
virtual property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get () sealed;
    void set (ICodeCompletionProvider^ value) sealed;
}
abstract Provider : ICodeCompletionProvider with get, set
override Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace
Alternet.Syntax.CodeCompletionICodeCompletionProvider


CompletionListBox.SelectedIndex Property

CompletionListBoxSelectedIndex Property
Gets or sets the zero-based index of the currently selected item in the CompletionListBox.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int SelectedIndex { get; set; }
Public Overrides Property SelectedIndex As Integer
    Get
    Set
public:
virtual property int SelectedIndex {
    int get () override;
    void set (int value) override;
}
abstract SelectedIndex : int with get, set
override SelectedIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox Events

CompletionListBox Events

The CompletionListBox type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemsChanged | (Inherited from ListBoxWithAdvancedScrolling.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | UpdateSize | Occurs when size of the control is changed.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VerticalScrollChanged | (Inherited from ListBoxWithAdvancedScrolling.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


CompletionListBox.UpdateSize Event

CompletionListBoxUpdateSize Event
Occurs when size of the control is changed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UpdateSize
Public Event UpdateSize As EventHandler
public:
virtual  event EventHandler^ UpdateSize {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UpdateSize : IEvent<EventHandler,
    EventArgs>
override UpdateSize : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
Remarks
The event handler receives an argument of type EventArgs containing data related to this event.
See Also

Reference

CompletionListBox Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint Class

HintSyntaxPaint Class
Represents class that performs syntax painting for hint control.
Inheritance Hierarchy
SystemObject
Alternet.EditorSyntaxPaint
Alternet.Editor.CodeCompletionHtmlSyntaxPaint
Alternet.Editor.CodeCompletionHintSyntaxPaint

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HintSyntaxPaint : HtmlSyntaxPaint
Public Class HintSyntaxPaint
    Inherits HtmlSyntaxPaint
public ref class HintSyntaxPaint : public HtmlSyntaxPaint
type HintSyntaxPaint =
    class
        inherit HtmlSyntaxPaint
    end

The HintSyntaxPaint type exposes the following members.

Constructors
 | Name | Description
Public method | HintSyntaxPaint | Initializes a new instance of the HintSyntaxPaint class with specified graphic surface and owner control.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes this HtmlSyntaxPaint and frees resources associated with it. (Inherited from HtmlSyntaxPaint.)
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Overrides SyntaxPaintDrawLine(Int32, String, StringItemInfo, Point, Rectangle).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal. (Inherited from SyntaxPaint.)
Public method | GetBackColor | Retrieves background color corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetFontColor | Retrieves font color corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetFontStyle | Retrieves font style corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style. (Inherited from SyntaxPaint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given at by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | OnCustomDraw | Raises an CustomDraw event. (Inherited from SyntaxPaint.)
Public method | PaintLineBookMarks | Paints collection of line bookmark. (Inherited from SyntaxPaint.)
Public method | PaintSyntax | Paints a specified part of the hint control. (Overrides SyntaxPaintPaintSyntax(Int32, Int32, Point, Rectangle, Point, Boolean).)
Public method | PrepareData | Prepares color data to paint. (Inherited from HtmlSyntaxPaint.)
Public method | ProviderChanged | Updates provider and related properties to this control.
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateHint | Updates content of the hint window.
Public method | UpdateSize | Updates size of this control.
Top
Properties
 | Name | Description
Public property | DisableColorPaint | Gets or sets a value indicating whether control uses colors to paint its content. (Inherited from SyntaxPaint.)
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from SyntaxPaint.)
Public property | LeftArrowArea | Represents rectangular area for left arrow.
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content. (Inherited from SyntaxPaint.)
Public property | NeedArrows | Gets boolean value indicating whether hint control have to paint up/down arrows.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from SyntaxPaint.)
Public property | Provider | Gets or sets an object that contains data related to this CompletionHint. (Inherited from HtmlSyntaxPaint.)
Public property | StartPos | Gets or sets start position of the hint in text coordinates.
Public property | Strings | Represents an array of strings displayed in a hint.
Top
Events
 | Name | Description
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxPaint.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint Constructor

HintSyntaxPaint Constructor
Initializes a new instance of the HintSyntaxPaint class with specified graphic surface and owner control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HintSyntaxPaint(
    IPainter painter,
    Control control
)
Public Sub New (
    painter As IPainter,
    control As Control
)
public:
HintSyntaxPaint(
    IPainter^ painter,
    Control^ control
)
new :
        painter : IPainter *
        control : Control -> HintSyntaxPaint

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
control
Type: System.Windows.FormsControl
Specifies control owning the HintSyntaxPaint.
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint Methods

HintSyntaxPaint Methods

The HintSyntaxPaint type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this HtmlSyntaxPaint and frees resources associated with it. (Inherited from HtmlSyntaxPaint.)
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Overrides SyntaxPaintDrawLine(Int32, String, StringItemInfo, Point, Rectangle).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal. (Inherited from SyntaxPaint.)
Public method | GetBackColor | Retrieves background color corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetFontColor | Retrieves font color corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetFontStyle | Retrieves font style corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style. (Inherited from SyntaxPaint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given at by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | OnCustomDraw | Raises an CustomDraw event. (Inherited from SyntaxPaint.)
Public method | PaintLineBookMarks | Paints collection of line bookmark. (Inherited from SyntaxPaint.)
Public method | PaintSyntax | Paints a specified part of the hint control. (Overrides SyntaxPaintPaintSyntax(Int32, Int32, Point, Rectangle, Point, Boolean).)
Public method | PrepareData | Prepares color data to paint. (Inherited from HtmlSyntaxPaint.)
Public method | ProviderChanged | Updates provider and related properties to this control.
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateHint | Updates content of the hint window.
Public method | UpdateSize | Updates size of this control.
Top
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.DrawLine Method

HintSyntaxPaintDrawLine Method
Overload List
 | Name | Description
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Overrides SyntaxPaintDrawLine(Int32, String, StringItemInfo, Point, Rectangle).)
Top
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.DrawLine Method (Int32, String, StringItemInfo[], Point, Rectangle)

HintSyntaxPaintDrawLine Method (Int32, String, StringItemInfo, Point, Rectangle)
Draws line given by its index at the specified position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void DrawLine(
    int index,
    string line,
    StringItemInfo[] colorData,
    Point position,
    Rectangle clipRect
)
Public Overrides Sub DrawLine (
    index As Integer,
    line As String,
    colorData As StringItemInfo(),
    position As Point,
    clipRect As Rectangle
)
public:
virtual void DrawLine(
    int index,
    String^ line,
    array<StringItemInfo>^ colorData,
    Point position,
    Rectangle clipRect
) override
abstract DrawLine :
        index : int *
        line : string *
        colorData : StringItemInfo[] *
        position : Point *
        clipRect : Rectangle -> unit
override DrawLine :
        index : int *
        line : string *
        colorData : StringItemInfo[] *
        position : Point *
        clipRect : Rectangle -> unit

Parameters

index
Type: SystemInt32
Index of line to draw.
line
Type: SystemString
Specifies text to draw.
colorData
Type: Alternet.SyntaxStringItemInfo
Specifies array containing color data for given string.
position
Type: System.DrawingPoint
Position to start drawing.
clipRect
Type: System.DrawingRectangle
Rectangular area of the control to draw line in.

Implements

ISyntaxPaintDrawLine(Int32, String, StringItemInfo, Point, Rectangle)
See Also

Reference

HintSyntaxPaint Class
DrawLine Overload
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.PaintSyntax Method

HintSyntaxPaintPaintSyntax Method
Paints a specified part of the hint control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
)
Public Overrides Sub PaintSyntax (
    startLine As Integer,
    endLine As Integer,
    position As Point,
    rect As Rectangle,
    location As Point,
    specialPaint As Boolean
)
public:
virtual void PaintSyntax(
    int startLine,
    int endLine,
    Point position,
    Rectangle rect,
    Point location,
    bool specialPaint
) override
abstract PaintSyntax :
        startLine : int *
        endLine : int *
        position : Point *
        rect : Rectangle *
        location : Point *
        specialPaint : bool -> unit
override PaintSyntax :
        startLine : int *
        endLine : int *
        position : Point *
        rect : Rectangle *
        location : Point *
        specialPaint : bool -> unit

Parameters

startLine
Type: SystemInt32
Specifies the first line to paint.
endLine
Type: SystemInt32
Specifies the last line to paint.
position
Type: System.DrawingPoint
The Point value that specifies start position to draw lines from.
rect
Type: System.DrawingRectangle
Rectangular area of HintSyntaxPaint to draw.
location
Type: System.DrawingPoint
The Point value that specifies start position to draw page from.
specialPaint
Type: SystemBoolean
Reserved for internal use.

Implements

ISyntaxPaintPaintSyntax(Int32, Int32, Point, Rectangle, Point, Boolean)
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.ProviderChanged Method

HintSyntaxPaintProviderChanged Method
Updates provider and related properties to this control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ProviderChanged(
    ICodeCompletionProvider provider,
    int index
)
Public Sub ProviderChanged (
    provider As ICodeCompletionProvider,
    index As Integer
)
public:
void ProviderChanged(
    ICodeCompletionProvider^ provider,
    int index
)
member ProviderChanged :
        provider : ICodeCompletionProvider *
        index : int -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
New provider.
index
Type: SystemInt32
New index.
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.UpdateHint Method

HintSyntaxPaintUpdateHint Method
Updates content of the hint window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UpdateHint()
Public Function UpdateHint As Boolean
public:
bool UpdateHint()
member UpdateHint : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.UpdateSize Method

HintSyntaxPaintUpdateSize Method
Updates size of this control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Size UpdateSize()
Public Function UpdateSize As Size
public:
Size UpdateSize()
member UpdateSize : unit -> Size

Return Value

Type: Size
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint Properties

HintSyntaxPaint Properties

The HintSyntaxPaint type exposes the following members.

Properties
 | Name | Description
Public property | DisableColorPaint | Gets or sets a value indicating whether control uses colors to paint its content. (Inherited from SyntaxPaint.)
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from SyntaxPaint.)
Public property | LeftArrowArea | Represents rectangular area for left arrow.
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content. (Inherited from SyntaxPaint.)
Public property | NeedArrows | Gets boolean value indicating whether hint control have to paint up/down arrows.
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from SyntaxPaint.)
Public property | Provider | Gets or sets an object that contains data related to this CompletionHint. (Inherited from HtmlSyntaxPaint.)
Public property | StartPos | Gets or sets start position of the hint in text coordinates.
Public property | Strings | Represents an array of strings displayed in a hint.
Top
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.LeftArrowArea Property

HintSyntaxPaintLeftArrowArea Property
Represents rectangular area for left arrow.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle LeftArrowArea { get; }
Public ReadOnly Property LeftArrowArea As Rectangle
    Get
public:
property Rectangle LeftArrowArea {
    Rectangle get ();
}
member LeftArrowArea : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.NeedArrows Property

HintSyntaxPaintNeedArrows Property
Gets boolean value indicating whether hint control have to paint up/down arrows.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedArrows { get; }
Public ReadOnly Property NeedArrows As Boolean
    Get
public:
property bool NeedArrows {
    bool get ();
}
member NeedArrows : bool with get

Property Value

Type: Boolean
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.StartPos Property

HintSyntaxPaintStartPos Property
Gets or sets start position of the hint in text coordinates.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point StartPos { get; set; }
Public Property StartPos As Point
    Get
    Set
public:
property Point StartPos {
    Point get ();
    void set (Point value);
}
member StartPos : Point with get, set

Return Value

Type: Point
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint.Strings Property

HintSyntaxPaintStrings Property
Represents an array of strings displayed in a hint.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IStringItem> Strings { get; }
Public ReadOnly Property Strings As IList(Of IStringItem)
    Get
public:
property IList<IStringItem^>^ Strings {
    IList<IStringItem^>^ get ();
}
member Strings : IList<IStringItem> with get

Property Value

Type: IListIStringItem
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HintSyntaxPaint Events

HintSyntaxPaint Events

The HintSyntaxPaint type exposes the following members.

Events
 | Name | Description
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxPaint.)
Top
See Also

Reference

HintSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HtmlLexer Class

HtmlLexer Class
Represents class used to highlight hint content with bold style.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.Editor.CodeCompletionHtmlLexer

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HtmlLexer : Lexer
Public Class HtmlLexer
    Inherits Lexer
public ref class HtmlLexer : public Lexer
type HtmlLexer =
    class
        inherit Lexer
    end

The HtmlLexer type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlLexer | Initializes a new instance of the HtmlLexer class with default settings.
Top
Methods
 | Name | Description
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | ParseHtmlText | Performs out lexical analysis of given text.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from Lexer.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from Lexer.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from Lexer.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


HtmlLexer Constructor

HtmlLexer Constructor
Initializes a new instance of the HtmlLexer class with default settings.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HtmlLexer()
Public Sub New
public:
HtmlLexer()
new : unit -> HtmlLexer
See Also

Reference

HtmlLexer Class
Alternet.Editor.CodeCompletion Namespace


HtmlLexer Methods

HtmlLexer Methods

The HtmlLexer type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | ParseHtmlText | Performs out lexical analysis of given text.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from Lexer.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from Lexer.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

HtmlLexer Class
Alternet.Editor.CodeCompletion Namespace


HtmlLexer.ParseHtmlText Method

HtmlLexerParseHtmlText Method
Performs out lexical analysis of given text.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ParseHtmlText(
    int state,
    FontStyle style,
    Color color,
    Color backColor,
    ref string s,
    ref StringItemInfo[] colorData
)
Public Function ParseHtmlText (
    state As Integer,
    style As FontStyle,
    color As Color,
    backColor As Color,
    ByRef s As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
int ParseHtmlText(
    int state,
    FontStyle style,
    Color color,
    Color backColor,
    String^% s,
    array<StringItemInfo>^% colorData
)
member ParseHtmlText :
        state : int *
        style : FontStyle *
        color : Color *
        backColor : Color *
        s : string byref *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
style
Type: System.DrawingFontStyle
Specifies default font style.
color
Type: System.DrawingColor
Specifies default fore core.
backColor
Type: System.DrawingColor
Specifies default background color.
s
Type: SystemString
Text to parse.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data of the given text.

Return Value

Type: Int32
Final lexical state.
See Also

Reference

HtmlLexer Class
Alternet.Editor.CodeCompletion Namespace


HtmlLexer Properties

HtmlLexer Properties

The HtmlLexer type exposes the following members.

Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from Lexer.)
Top
See Also

Reference

HtmlLexer Class
Alternet.Editor.CodeCompletion Namespace


HtmlLexer Events

HtmlLexer Events

The HtmlLexer type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Top
See Also

Reference

HtmlLexer Class
Alternet.Editor.CodeCompletion Namespace


HtmlSyntaxPaint Class

HtmlSyntaxPaint Class
Represents class that performs syntax painting for hint control.
Inheritance Hierarchy
SystemObject
Alternet.EditorSyntaxPaint
Alternet.Editor.CodeCompletionHtmlSyntaxPaint
Alternet.Editor.CodeCompletionHintSyntaxPaint

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HtmlSyntaxPaint : SyntaxPaint,
    IDisposable
Public Class HtmlSyntaxPaint
    Inherits SyntaxPaint
    Implements IDisposable
public ref class HtmlSyntaxPaint : public SyntaxPaint,
    IDisposable
type HtmlSyntaxPaint =
    class
        inherit SyntaxPaint
        interface IDisposable
    end

The HtmlSyntaxPaint type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlSyntaxPaint | Initializes a new instance of the HtmlSyntaxPaint class with specified graphic surface and owner control.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes this HtmlSyntaxPaint and frees resources associated with it.
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal. (Inherited from SyntaxPaint.)
Public method | GetBackColor | Retrieves background color corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetFontColor | Retrieves font color corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetFontStyle | Retrieves font style corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style. (Inherited from SyntaxPaint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given at by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | OnCustomDraw | Raises an CustomDraw event. (Inherited from SyntaxPaint.)
Public method | PaintLineBookMarks | Paints collection of line bookmark. (Inherited from SyntaxPaint.)
Public method | PaintSyntax | Perform syntax painting of the control on the graphic surface. (Inherited from SyntaxPaint.)
Public method | PrepareData | Prepares color data to paint.
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisableColorPaint | Gets or sets a value indicating whether control uses colors to paint its content. (Inherited from SyntaxPaint.)
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from SyntaxPaint.)
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content. (Inherited from SyntaxPaint.)
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from SyntaxPaint.)
Public property | Provider | Gets or sets an object that contains data related to this CompletionHint.
Top
Events
 | Name | Description
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxPaint.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


HtmlSyntaxPaint Constructor

HtmlSyntaxPaint Constructor
Initializes a new instance of the HtmlSyntaxPaint class with specified graphic surface and owner control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HtmlSyntaxPaint(
    IPainter painter,
    Control control
)
Public Sub New (
    painter As IPainter,
    control As Control
)
public:
HtmlSyntaxPaint(
    IPainter^ painter,
    Control^ control
)
new :
        painter : IPainter *
        control : Control -> HtmlSyntaxPaint

Parameters

painter
Type: Alternet.CommonIPainter
Specifies IPainter object used to draw text and graphic primitives.
control
Type: System.Windows.FormsControl
Specifies control owning the HtmlSyntaxPaint.
See Also

Reference

HtmlSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HtmlSyntaxPaint Methods

HtmlSyntaxPaint Methods

The HtmlSyntaxPaint type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this HtmlSyntaxPaint and frees resources associated with it.
Public method | DrawLine(Int32, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from SyntaxPaint.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal. (Inherited from SyntaxPaint.)
Public method | GetBackColor | Retrieves background color corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetFontColor | Retrieves font color corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetFontStyle | Retrieves font style corresponding to given state. (Inherited from SyntaxPaint.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style. (Inherited from SyntaxPaint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given at by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean) | Measures part of given string. (Inherited from SyntaxPaint.)
Public method | OnCustomDraw | Raises an CustomDraw event. (Inherited from SyntaxPaint.)
Public method | PaintLineBookMarks | Paints collection of line bookmark. (Inherited from SyntaxPaint.)
Public method | PaintSyntax | Perform syntax painting of the control on the graphic surface. (Inherited from SyntaxPaint.)
Public method | PrepareData | Prepares color data to paint.
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to the default value. (Inherited from SyntaxPaint.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HtmlSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HtmlSyntaxPaint.Dispose Method

HtmlSyntaxPaintDispose Method
Disposes this HtmlSyntaxPaint and frees resources associated with it.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

HtmlSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HtmlSyntaxPaint.PrepareData Method

HtmlSyntaxPaintPrepareData Method
Prepares color data to paint.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PrepareData(
    int state,
    FontStyle style,
    Color color,
    Color backColor,
    ref string s,
    ref StringItemInfo[] colorData
)
Public Overridable Function PrepareData (
    state As Integer,
    style As FontStyle,
    color As Color,
    backColor As Color,
    ByRef s As String,
    ByRef colorData As StringItemInfo()
) As Boolean
public:
virtual bool PrepareData(
    int state,
    FontStyle style,
    Color color,
    Color backColor,
    String^% s,
    array<StringItemInfo>^% colorData
)
abstract PrepareData :
        state : int *
        style : FontStyle *
        color : Color *
        backColor : Color *
        s : string byref *
        colorData : StringItemInfo[] byref -> bool
override PrepareData :
        state : int *
        style : FontStyle *
        color : Color *
        backColor : Color *
        s : string byref *
        colorData : StringItemInfo[] byref -> bool

Parameters

state
Type: SystemInt32
Specifies start lexical state.
style
Type: System.DrawingFontStyle
Specifies default font style.
color
Type: System.DrawingColor
Specifies default color
backColor
Type: System.DrawingColor
Specifies default background color
s
Type: SystemString
Text to parse.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data of the given text.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

HtmlSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HtmlSyntaxPaint Properties

HtmlSyntaxPaint Properties

The HtmlSyntaxPaint type exposes the following members.

Properties
 | Name | Description
Public property | DisableColorPaint | Gets or sets a value indicating whether control uses colors to paint its content. (Inherited from SyntaxPaint.)
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from SyntaxPaint.)
Public property | Lexer | Gets or sets object that can make lexical analysis for the control's content. (Inherited from SyntaxPaint.)
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from SyntaxPaint.)
Public property | Provider | Gets or sets an object that contains data related to this CompletionHint.
Top
See Also

Reference

HtmlSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HtmlSyntaxPaint.Provider Property

HtmlSyntaxPaintProvider Property
Gets or sets an object that contains data related to this CompletionHint.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionProvider Provider { get; set; }
Public Property Provider As ICodeCompletionProvider
    Get
    Set
public:
property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get ();
    void set (ICodeCompletionProvider^ value);
}
member Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider
See Also

Reference

HtmlSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


HtmlSyntaxPaint Events

HtmlSyntaxPaint Events

The HtmlSyntaxPaint type exposes the following members.

Events
 | Name | Description
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxPaint.)
Top
See Also

Reference

HtmlSyntaxPaint Class
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion Interface

ICodeCompletion Interface
Represents properties and methods to provide code completion list box/tooltip for the Editor's content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletion
Public Interface ICodeCompletion
public interface class ICodeCompletion
type ICodeCompletion =  interface end

The ICodeCompletion type exposes the following members.

Methods
 | Name | Description
Public method | CodeCompletion | When implemented by a class, performs code completion for the specified text representing language element.
Public method | CodeCompletionWindowFocused | When implemented by a class, indicates whether ICodeCompletionWindow has focus.
Public method | CodeSnippets | When implemented by a class, displays a code completion window with list of available code snippets.
Public method | CompleteCodeFixes | When implemented by a class, displays a code completion window with list of available code fixes.
Public method | CompleteCodeFixesOrRefactors | When implemented by a class, displays a code completion window with list of available code fixes or code refactors.
Public method | CompleteCodeRefactors | When implemented by a class, displays a code completion window with list of available code refactors.
Public method | CompleteWord | When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content and locates single member, if possible.
Public method | IsValidText | When implemented by a class, indicates whether text at the specified position is valid (that is does not contain comments or string constants).
Public method | ListMembers | When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content.
Public method | ParameterInfo | When implemented by a class, displays a code completion window containing information for the current method or parameter in the Editor's content.
Public method | QuickInfo | When implemented by a class, displays a code completion window with simple tooltip information.
Public method | ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType) | When implemented by a class, shows code completion popup window with given provider at the current position.
Public method | ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point) | When implemented by a class, shows code completion popup window with given Provider at the specified position.
Public method | ShowCodeCompletionButton | When implemented by a class, shows code completion popup window with given Provider at the specified position.
Public method | ShowCodeCompletionHint(ICodeCompletionProvider, ILexer) | When implemented by a class, displays ICodeCompletionHint with given provider at the current position.
Public method | ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer) | When implemented by a class, displays ICodeCompletionHint with given provider at the specified position.
Top
Properties
 | Name | Description
Public property | CodeCompletionBox | When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of list.
Public property | CodeCompletionChars | When implemented by a class, represents a collection of characters that initializes a code completion procedure when typing in the editor.
Public property | CodeCompletionHint | When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of the tooltip.
Public property | CodeCompletionMode | When implemented by a class, gets or sets code completion box mode.
Public property | IsCodeCompletionWindowFocused | When implemented by a class, indicates whether ICodeCompletionWindow has focus.
Top
Events
 | Name | Description
Public event | NeedCodeCompletion | When implemented by a class, occurs when code completion window is to be displayed.
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICodeCompletion Methods

ICodeCompletion Methods

The ICodeCompletion type exposes the following members.

Methods
 | Name | Description
Public method | CodeCompletion | When implemented by a class, performs code completion for the specified text representing language element.
Public method | CodeCompletionWindowFocused | When implemented by a class, indicates whether ICodeCompletionWindow has focus.
Public method | CodeSnippets | When implemented by a class, displays a code completion window with list of available code snippets.
Public method | CompleteCodeFixes | When implemented by a class, displays a code completion window with list of available code fixes.
Public method | CompleteCodeFixesOrRefactors | When implemented by a class, displays a code completion window with list of available code fixes or code refactors.
Public method | CompleteCodeRefactors | When implemented by a class, displays a code completion window with list of available code refactors.
Public method | CompleteWord | When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content and locates single member, if possible.
Public method | IsValidText | When implemented by a class, indicates whether text at the specified position is valid (that is does not contain comments or string constants).
Public method | ListMembers | When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content.
Public method | ParameterInfo | When implemented by a class, displays a code completion window containing information for the current method or parameter in the Editor's content.
Public method | QuickInfo | When implemented by a class, displays a code completion window with simple tooltip information.
Public method | ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType) | When implemented by a class, shows code completion popup window with given provider at the current position.
Public method | ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point) | When implemented by a class, shows code completion popup window with given Provider at the specified position.
Public method | ShowCodeCompletionButton | When implemented by a class, shows code completion popup window with given Provider at the specified position.
Public method | ShowCodeCompletionHint(ICodeCompletionProvider, ILexer) | When implemented by a class, displays ICodeCompletionHint with given provider at the current position.
Public method | ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer) | When implemented by a class, displays ICodeCompletionHint with given provider at the specified position.
Top
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CodeCompletion Method

ICodeCompletionCodeCompletion Method
When implemented by a class, performs code completion for the specified text representing language element.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CodeCompletion(
    CodeCompletionArgs e
)
Sub CodeCompletion (
    e As CodeCompletionArgs
)
void CodeCompletion(
    CodeCompletionArgs^ e
)
abstract CodeCompletion :
        e : CodeCompletionArgs -> unit

Parameters

e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CodeCompletionWindowFocused Method

ICodeCompletionCodeCompletionWindowFocused Method
When implemented by a class, indicates whether ICodeCompletionWindow has focus.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CodeCompletionWindowFocused(
    out Control control
)
Function CodeCompletionWindowFocused (
    <OutAttribute> ByRef control As Control
) As Boolean
bool CodeCompletionWindowFocused(
    [OutAttribute] Control^% control
)
abstract CodeCompletionWindowFocused :
        control : Control byref -> bool

Parameters

control
Type: System.Windows.FormsControl
Returns control that has focus.

Return Value

Type: Boolean
True if succeed; otherwise, false.
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CodeSnippets Method

ICodeCompletionCodeSnippets Method
When implemented by a class, displays a code completion window with list of available code snippets.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CodeSnippets()
Sub CodeSnippets
void CodeSnippets()
abstract CodeSnippets : unit -> unit
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CompleteCodeFixes Method

ICodeCompletionCompleteCodeFixes Method
When implemented by a class, displays a code completion window with list of available code fixes.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CompleteCodeFixes()
Sub CompleteCodeFixes
void CompleteCodeFixes()
abstract CompleteCodeFixes : unit -> unit
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CompleteCodeFixesOrRefactors Method

ICodeCompletionCompleteCodeFixesOrRefactors Method
When implemented by a class, displays a code completion window with list of available code fixes or code refactors.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CompleteCodeFixesOrRefactors()
Sub CompleteCodeFixesOrRefactors
void CompleteCodeFixesOrRefactors()
abstract CompleteCodeFixesOrRefactors : unit -> unit
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CompleteCodeRefactors Method

ICodeCompletionCompleteCodeRefactors Method
When implemented by a class, displays a code completion window with list of available code refactors.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CompleteCodeRefactors()
Sub CompleteCodeRefactors
void CompleteCodeRefactors()
abstract CompleteCodeRefactors : unit -> unit
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CompleteWord Method

ICodeCompletionCompleteWord Method
When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content and locates single member, if possible.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CompleteWord()
Sub CompleteWord
void CompleteWord()
abstract CompleteWord : unit -> unit
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.IsValidText Method

ICodeCompletionIsValidText Method
When implemented by a class, indicates whether text at the specified position is valid (that is does not contain comments or string constants).

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsValidText(
    Point position
)
Function IsValidText (
    position As Point
) As Boolean
bool IsValidText(
    Point position
)
abstract IsValidText :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position to check.

Return Value

Type: Boolean
True if text is not plain; otherwise false.
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.ListMembers Method

ICodeCompletionListMembers Method
When implemented by a class, displays a code completion window that lists members of the current class in the Editor's content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ListMembers()
Sub ListMembers
void ListMembers()
abstract ListMembers : unit -> unit
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.ParameterInfo Method

ICodeCompletionParameterInfo Method
When implemented by a class, displays a code completion window containing information for the current method or parameter in the Editor's content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ParameterInfo()
Sub ParameterInfo
void ParameterInfo()
abstract ParameterInfo : unit -> unit
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.QuickInfo Method

ICodeCompletionQuickInfo Method
When implemented by a class, displays a code completion window with simple tooltip information.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void QuickInfo()
Sub QuickInfo
void QuickInfo()
abstract QuickInfo : unit -> unit
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.ShowCodeCompletionBox Method

ICodeCompletionShowCodeCompletionBox Method
Overload List
 | Name | Description
Public method | ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType) | When implemented by a class, shows code completion popup window with given provider at the current position.
Public method | ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point) | When implemented by a class, shows code completion popup window with given Provider at the specified position.
Top
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.ShowCodeCompletionBox Method (ICodeCompletionProvider, CodeCompletionType)

ICodeCompletionShowCodeCompletionBox Method (ICodeCompletionProvider, CodeCompletionType)
When implemented by a class, shows code completion popup window with given provider at the current position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowCodeCompletionBox(
    ICodeCompletionProvider provider,
    CodeCompletionType completionType
)
Sub ShowCodeCompletionBox (
    provider As ICodeCompletionProvider,
    completionType As CodeCompletionType
)
void ShowCodeCompletionBox(
    ICodeCompletionProvider^ provider,
    CodeCompletionType completionType
)
abstract ShowCodeCompletionBox :
        provider : ICodeCompletionProvider *
        completionType : CodeCompletionType -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion popup window.
completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion type.
See Also

Reference

ICodeCompletion Interface
ShowCodeCompletionBox Overload
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.ShowCodeCompletionBox Method (ICodeCompletionProvider, CodeCompletionType, Point)

ICodeCompletionShowCodeCompletionBox Method (ICodeCompletionProvider, CodeCompletionType, Point)
When implemented by a class, shows code completion popup window with given Provider at the specified position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowCodeCompletionBox(
    ICodeCompletionProvider provider,
    CodeCompletionType completionType,
    Point position
)
Sub ShowCodeCompletionBox (
    provider As ICodeCompletionProvider,
    completionType As CodeCompletionType,
    position As Point
)
void ShowCodeCompletionBox(
    ICodeCompletionProvider^ provider,
    CodeCompletionType completionType,
    Point position
)
abstract ShowCodeCompletionBox :
        provider : ICodeCompletionProvider *
        completionType : CodeCompletionType *
        position : Point -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion popup window.
completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion type.
position
Type: System.DrawingPoint
Position to show code completion popup window.
See Also

Reference

ICodeCompletion Interface
ShowCodeCompletionBox Overload
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.ShowCodeCompletionButton Method

ICodeCompletionShowCodeCompletionButton Method
When implemented by a class, shows code completion popup window with given Provider at the specified position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowCodeCompletionButton(
    ICodeCompletionProvider provider,
    Point position,
    bool dropDown
)
Sub ShowCodeCompletionButton (
    provider As ICodeCompletionProvider,
    position As Point,
    dropDown As Boolean
)
void ShowCodeCompletionButton(
    ICodeCompletionProvider^ provider,
    Point position,
    bool dropDown
)
abstract ShowCodeCompletionButton :
        provider : ICodeCompletionProvider *
        position : Point *
        dropDown : bool -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion popup window.
position
Type: System.DrawingPoint
Position to show code completion popup window.
dropDown
Type: SystemBoolean
Specifies if dropdown menu should be displayed.
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.ShowCodeCompletionHint Method

ICodeCompletionShowCodeCompletionHint Method
Overload List
 | Name | Description
Public method | ShowCodeCompletionHint(ICodeCompletionProvider, ILexer) | When implemented by a class, displays ICodeCompletionHint with given provider at the current position.
Public method | ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer) | When implemented by a class, displays ICodeCompletionHint with given provider at the specified position.
Top
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.ShowCodeCompletionHint Method (ICodeCompletionProvider, ILexer)

ICodeCompletionShowCodeCompletionHint Method (ICodeCompletionProvider, ILexer)
When implemented by a class, displays ICodeCompletionHint with given provider at the current position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowCodeCompletionHint(
    ICodeCompletionProvider provider,
    ILexer lexer
)
Sub ShowCodeCompletionHint (
    provider As ICodeCompletionProvider,
    lexer As ILexer
)
void ShowCodeCompletionHint(
    ICodeCompletionProvider^ provider,
    ILexer^ lexer
)
abstract ShowCodeCompletionHint :
        provider : ICodeCompletionProvider *
        lexer : ILexer -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion hint.
lexer
Type: Alternet.Syntax.LexerILexer
Specifies lexer used to draw code completion hint.
See Also

Reference

ICodeCompletion Interface
ShowCodeCompletionHint Overload
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.ShowCodeCompletionHint Method (ICodeCompletionProvider, Point, ILexer)

ICodeCompletionShowCodeCompletionHint Method (ICodeCompletionProvider, Point, ILexer)
When implemented by a class, displays ICodeCompletionHint with given provider at the specified position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowCodeCompletionHint(
    ICodeCompletionProvider provider,
    Point position,
    ILexer lexer
)
Sub ShowCodeCompletionHint (
    provider As ICodeCompletionProvider,
    position As Point,
    lexer As ILexer
)
void ShowCodeCompletionHint(
    ICodeCompletionProvider^ provider,
    Point position,
    ILexer^ lexer
)
abstract ShowCodeCompletionHint :
        provider : ICodeCompletionProvider *
        position : Point *
        lexer : ILexer -> unit

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Represents data for code completion hint.
position
Type: System.DrawingPoint
Position to display the hint.
lexer
Type: Alternet.Syntax.LexerILexer
Specifies lexer used to draw code completion hint.
See Also

Reference

ICodeCompletion Interface
ShowCodeCompletionHint Overload
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion Properties

ICodeCompletion Properties

The ICodeCompletion type exposes the following members.

Properties
 | Name | Description
Public property | CodeCompletionBox | When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of list.
Public property | CodeCompletionChars | When implemented by a class, represents a collection of characters that initializes a code completion procedure when typing in the editor.
Public property | CodeCompletionHint | When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of the tooltip.
Public property | CodeCompletionMode | When implemented by a class, gets or sets code completion box mode.
Public property | IsCodeCompletionWindowFocused | When implemented by a class, indicates whether ICodeCompletionWindow has focus.
Top
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CodeCompletionBox Property

ICodeCompletionCodeCompletionBox Property
When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of list.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionBox CodeCompletionBox { get; }
ReadOnly Property CodeCompletionBox As ICodeCompletionBox
    Get
property ICodeCompletionBox^ CodeCompletionBox {
    ICodeCompletionBox^ get ();
}
abstract CodeCompletionBox : ICodeCompletionBox with get

Property Value

Type: ICodeCompletionBox
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CodeCompletionChars Property

ICodeCompletionCodeCompletionChars Property
When implemented by a class, represents a collection of characters that initializes a code completion procedure when typing in the editor.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] CodeCompletionChars { get; set; }
Property CodeCompletionChars As Char()
    Get
    Set
property array<wchar_t>^ CodeCompletionChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract CodeCompletionChars : char[] with get, set

Property Value

Type: Char
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CodeCompletionHint Property

ICodeCompletionCodeCompletionHint Property
When implemented by a class, represents object that specifies a popup window that contains Code completion information presented in the form of the tooltip.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionHint CodeCompletionHint { get; }
ReadOnly Property CodeCompletionHint As ICodeCompletionHint
    Get
property ICodeCompletionHint^ CodeCompletionHint {
    ICodeCompletionHint^ get ();
}
abstract CodeCompletionHint : ICodeCompletionHint with get

Property Value

Type: ICodeCompletionHint
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.CodeCompletionMode Property

ICodeCompletionCodeCompletionMode Property
When implemented by a class, gets or sets code completion box mode.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
CodeCompletionMode CodeCompletionMode { get; set; }
Property CodeCompletionMode As CodeCompletionMode
    Get
    Set
property CodeCompletionMode CodeCompletionMode {
    CodeCompletionMode get ();
    void set (CodeCompletionMode value);
}
abstract CodeCompletionMode : CodeCompletionMode with get, set

Property Value

Type: CodeCompletionMode
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.IsCodeCompletionWindowFocused Property

ICodeCompletionIsCodeCompletionWindowFocused Property
When implemented by a class, indicates whether ICodeCompletionWindow has focus.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCodeCompletionWindowFocused { get; }
ReadOnly Property IsCodeCompletionWindowFocused As Boolean
    Get
property bool IsCodeCompletionWindowFocused {
    bool get ();
}
abstract IsCodeCompletionWindowFocused : bool with get

Return Value

Type: Boolean
True if succeed; otherwise, false.
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion Events

ICodeCompletion Events

The ICodeCompletion type exposes the following members.

Events
 | Name | Description
Public event | NeedCodeCompletion | When implemented by a class, occurs when code completion window is to be displayed.
Top
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletion.NeedCodeCompletion Event

ICodeCompletionNeedCodeCompletion Event
When implemented by a class, occurs when code completion window is to be displayed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event CodeCompletionEvent NeedCodeCompletion
Event NeedCodeCompletion As CodeCompletionEvent
 event CodeCompletionEvent^ NeedCodeCompletion {
    void add (CodeCompletionEvent^ value);
    void remove (CodeCompletionEvent^ value);
}
abstract NeedCodeCompletion : IEvent<CodeCompletionEvent,
    CodeCompletionArgs>

Value

Type: Alternet.SyntaxCodeCompletionEvent
See Also

Reference

ICodeCompletion Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox Interface

ICodeCompletionBox Interface
Represents properties and methods of a popup window that displays code completion information presented in the form of a list.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionBox : ICodeCompletionWindow
Public Interface ICodeCompletionBox
    Inherits ICodeCompletionWindow
public interface class ICodeCompletionBox : ICodeCompletionWindow
type ICodeCompletionBox =
    interface
        interface ICodeCompletionWindow
    end

The ICodeCompletionBox type exposes the following members.

Methods
 | Name | Description
Public method | AddColumn | When implemented by a class, adds a new column to the ICodeCompletionBox column collection.
Public method | ClearColumns | When implemented by a class, removes all columns from the ICodeCompletionBox column collection.
Public method | Close(Boolean) | When implemented by a class, closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay. (Inherited from ICodeCompletionWindow.)
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control. (Inherited from ICodeCompletionWindow.)
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold. (Inherited from ICodeCompletionWindow.)
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from ICodeCompletionWindow.)
Public method | InsertColumn | When implemented by a class, inserts a new column to the specified position in the column collection.
Public method | PerformSearch | When implemented by a class, performs searching operation. (Inherited from ICodeCompletionWindow.)
Public method | Popup | When implemented by a class, displays popup window at the current mouse position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window. (Inherited from ICodeCompletionWindow.)
Public method | RemoveColumnAt | When implemented by a class, removes the column at the specified index of the column collection.
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider. (Inherited from ICodeCompletionWindow.)
Public method | ResetDropDownCount | When implemented by a class, resets the DropDownCount to the default value.
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value. (Inherited from ICodeCompletionWindow.)
Top
Properties
 | Name | Description
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from ICodeCompletionWindow.)
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | CodeCompletionBorderColor | When implemented by a class, gets ICodeCompletionBox border color.
Public property | Columns | When implemented by a class, represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox.
Public property | CompletionEdit | When implemented by a class, represents CodeCompletionEdit object used to display code snippets.
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window. (Inherited from ICodeCompletionWindow.)
Public property | CompletionHint | When implemented by a class, represents CodeCompletion hint object used to display hints next to completion box.
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from ICodeCompletionWindow.)
Public property | DropDownCount | When implemented by a class, gets or sets a value that specifies maximal visible index of the ListBox items within the popup control.
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Filter | When implemented by a class, gets or sets filter string used to filter ICodeCompletionBox content.
Public property | Filtered | When implemented by a class, gets or sets a boolean value that indicates whether ICodeCompletionBox should filter its content using Filer property.
Public property | FocusControl | When implemented by a class, returns child control that has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | Font | When implemented by a class, gets or sets the font for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionWindow.)
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | IsVisible | When implemented by a class, indicates if window is visible. (Inherited from ICodeCompletionWindow.)
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow. (Inherited from ICodeCompletionWindow.)
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from ICodeCompletionWindow.)
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ShowTabs | When implemented by a class, gets or sets boolean value that indicates whether codecompletion window should display additional tabs.
Public property | Size | When implemented by a class, returns size of the window. (Inherited from ICodeCompletionWindow.)
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable. (Inherited from ICodeCompletionWindow.)
Public property | Sorted | When implemented by a class, gets or sets a value indicating whether the items in the ICodeCompletionBox are sorted alphabetically.
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed.
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed. (Inherited from ICodeCompletionWindow.)
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed. (Inherited from ICodeCompletionWindow.)
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control. (Inherited from ICodeCompletionWindow.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from ICodeCompletionWindow.)
Public event | SelectionChanged | When implemented by a class, occurs when index specifying the currently selected item is changed.
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox Methods

ICodeCompletionBox Methods

The ICodeCompletionBox type exposes the following members.

Methods
 | Name | Description
Public method | AddColumn | When implemented by a class, adds a new column to the ICodeCompletionBox column collection.
Public method | ClearColumns | When implemented by a class, removes all columns from the ICodeCompletionBox column collection.
Public method | Close(Boolean) | When implemented by a class, closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay. (Inherited from ICodeCompletionWindow.)
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control. (Inherited from ICodeCompletionWindow.)
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold. (Inherited from ICodeCompletionWindow.)
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from ICodeCompletionWindow.)
Public method | InsertColumn | When implemented by a class, inserts a new column to the specified position in the column collection.
Public method | PerformSearch | When implemented by a class, performs searching operation. (Inherited from ICodeCompletionWindow.)
Public method | Popup | When implemented by a class, displays popup window at the current mouse position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window. (Inherited from ICodeCompletionWindow.)
Public method | RemoveColumnAt | When implemented by a class, removes the column at the specified index of the column collection.
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider. (Inherited from ICodeCompletionWindow.)
Public method | ResetDropDownCount | When implemented by a class, resets the DropDownCount to the default value.
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.AddColumn Method

ICodeCompletionBoxAddColumn Method
When implemented by a class, adds a new column to the ICodeCompletionBox column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionColumn AddColumn()
Function AddColumn As ICodeCompletionColumn
ICodeCompletionColumn^ AddColumn()
abstract AddColumn : unit -> ICodeCompletionColumn

Return Value

Type: ICodeCompletionColumn
New added column.
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.ClearColumns Method

ICodeCompletionBoxClearColumns Method
When implemented by a class, removes all columns from the ICodeCompletionBox column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearColumns()
Sub ClearColumns
void ClearColumns()
abstract ClearColumns : unit -> unit
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.InsertColumn Method

ICodeCompletionBoxInsertColumn Method
When implemented by a class, inserts a new column to the specified position in the column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionColumn InsertColumn(
    int index
)
Function InsertColumn (
    index As Integer
) As ICodeCompletionColumn
ICodeCompletionColumn^ InsertColumn(
    int index
)
abstract InsertColumn :
        index : int -> ICodeCompletionColumn

Parameters

index
Type: SystemInt32
Index of the column in the collection.

Return Value

Type: ICodeCompletionColumn
New inserted column.
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.RemoveColumnAt Method

ICodeCompletionBoxRemoveColumnAt Method
When implemented by a class, removes the column at the specified index of the column collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveColumnAt(
    int index
)
Sub RemoveColumnAt (
    index As Integer
)
void RemoveColumnAt(
    int index
)
abstract RemoveColumnAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies zero-based index of the column to remove.
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.ResetDropDownCount Method

ICodeCompletionBoxResetDropDownCount Method
When implemented by a class, resets the DropDownCount to the default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDropDownCount()
Sub ResetDropDownCount
void ResetDropDownCount()
abstract ResetDropDownCount : unit -> unit
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox Properties

ICodeCompletionBox Properties

The ICodeCompletionBox type exposes the following members.

Properties
 | Name | Description
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from ICodeCompletionWindow.)
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | CodeCompletionBorderColor | When implemented by a class, gets ICodeCompletionBox border color.
Public property | Columns | When implemented by a class, represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox.
Public property | CompletionEdit | When implemented by a class, represents CodeCompletionEdit object used to display code snippets.
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window. (Inherited from ICodeCompletionWindow.)
Public property | CompletionHint | When implemented by a class, represents CodeCompletion hint object used to display hints next to completion box.
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from ICodeCompletionWindow.)
Public property | DropDownCount | When implemented by a class, gets or sets a value that specifies maximal visible index of the ListBox items within the popup control.
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Filter | When implemented by a class, gets or sets filter string used to filter ICodeCompletionBox content.
Public property | Filtered | When implemented by a class, gets or sets a boolean value that indicates whether ICodeCompletionBox should filter its content using Filer property.
Public property | FocusControl | When implemented by a class, returns child control that has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | Font | When implemented by a class, gets or sets the font for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionWindow.)
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | IsVisible | When implemented by a class, indicates if window is visible. (Inherited from ICodeCompletionWindow.)
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow. (Inherited from ICodeCompletionWindow.)
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from ICodeCompletionWindow.)
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ShowTabs | When implemented by a class, gets or sets boolean value that indicates whether codecompletion window should display additional tabs.
Public property | Size | When implemented by a class, returns size of the window. (Inherited from ICodeCompletionWindow.)
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable. (Inherited from ICodeCompletionWindow.)
Public property | Sorted | When implemented by a class, gets or sets a value indicating whether the items in the ICodeCompletionBox are sorted alphabetically.
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed.
Top
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.CodeCompletionBorderColor Property

ICodeCompletionBoxCodeCompletionBorderColor Property
When implemented by a class, gets ICodeCompletionBox border color.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color CodeCompletionBorderColor { get; }
ReadOnly Property CodeCompletionBorderColor As Color
    Get
property Color CodeCompletionBorderColor {
    Color get ();
}
abstract CodeCompletionBorderColor : Color with get

Property Value

Type: Color
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.Columns Property

ICodeCompletionBoxColumns Property
When implemented by a class, represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionColumn[] Columns { get; }
ReadOnly Property Columns As ICodeCompletionColumn()
    Get
property array<ICodeCompletionColumn^>^ Columns {
    array<ICodeCompletionColumn^>^ get ();
}
abstract Columns : ICodeCompletionColumn[] with get

Property Value

Type: ICodeCompletionColumn
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.CompletionEdit Property

ICodeCompletionBoxCompletionEdit Property
When implemented by a class, represents CodeCompletionEdit object used to display code snippets.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionEdit CompletionEdit { get; }
ReadOnly Property CompletionEdit As ICodeCompletionEdit
    Get
property ICodeCompletionEdit^ CompletionEdit {
    ICodeCompletionEdit^ get ();
}
abstract CompletionEdit : ICodeCompletionEdit with get

Property Value

Type: ICodeCompletionEdit
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.CompletionHint Property

ICodeCompletionBoxCompletionHint Property
When implemented by a class, represents CodeCompletion hint object used to display hints next to completion box.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionHint CompletionHint { get; }
ReadOnly Property CompletionHint As ICodeCompletionHint
    Get
property ICodeCompletionHint^ CompletionHint {
    ICodeCompletionHint^ get ();
}
abstract CompletionHint : ICodeCompletionHint with get

Property Value

Type: ICodeCompletionHint
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.DropDownCount Property

ICodeCompletionBoxDropDownCount Property
When implemented by a class, gets or sets a value that specifies maximal visible index of the ListBox items within the popup control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int DropDownCount { get; set; }
Property DropDownCount As Integer
    Get
    Set
property int DropDownCount {
    int get ();
    void set (int value);
}
abstract DropDownCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.Filter Property

ICodeCompletionBoxFilter Property
When implemented by a class, gets or sets filter string used to filter ICodeCompletionBox content.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Filter { get; set; }
Property Filter As String
    Get
    Set
property String^ Filter {
    String^ get ();
    void set (String^ value);
}
abstract Filter : string with get, set

Property Value

Type: String
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.Filtered Property

ICodeCompletionBoxFiltered Property
When implemented by a class, gets or sets a boolean value that indicates whether ICodeCompletionBox should filter its content using Filer property.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Filtered { get; set; }
Property Filtered As Boolean
    Get
    Set
property bool Filtered {
    bool get ();
    void set (bool value);
}
abstract Filtered : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.ShowTabs Property

ICodeCompletionBoxShowTabs Property
When implemented by a class, gets or sets boolean value that indicates whether codecompletion window should display additional tabs.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowTabs { get; set; }
Property ShowTabs As Boolean
    Get
    Set
property bool ShowTabs {
    bool get ();
    void set (bool value);
}
abstract ShowTabs : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.Sorted Property

ICodeCompletionBoxSorted Property
When implemented by a class, gets or sets a value indicating whether the items in the ICodeCompletionBox are sorted alphabetically.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Sorted { get; set; }
Property Sorted As Boolean
    Get
    Set
property bool Sorted {
    bool get ();
    void set (bool value);
}
abstract Sorted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.Visible Property

ICodeCompletionBoxVisible Property
When implemented by a class, gets or sets a value indicating whether the control is displayed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox Events

ICodeCompletionBox Events

The ICodeCompletionBox type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed. (Inherited from ICodeCompletionWindow.)
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed. (Inherited from ICodeCompletionWindow.)
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control. (Inherited from ICodeCompletionWindow.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from ICodeCompletionWindow.)
Public event | SelectionChanged | When implemented by a class, occurs when index specifying the currently selected item is changed.
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionBox.SelectionChanged Event

ICodeCompletionBoxSelectionChanged Event
When implemented by a class, occurs when index specifying the currently selected item is changed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SelectionChanged
Event SelectionChanged As EventHandler
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ICodeCompletionBox Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionButton Interface

ICodeCompletionButton Interface
Represents properties and methods of a popup window that displays code completion information presented in the form of drop-down button.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionButton : ICodeCompletionWindow
Public Interface ICodeCompletionButton
    Inherits ICodeCompletionWindow
public interface class ICodeCompletionButton : ICodeCompletionWindow
type ICodeCompletionButton =
    interface
        interface ICodeCompletionWindow
    end

The ICodeCompletionButton type exposes the following members.

Methods
 | Name | Description
Public method | Close(Boolean) | When implemented by a class, closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay. (Inherited from ICodeCompletionWindow.)
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control. (Inherited from ICodeCompletionWindow.)
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold. (Inherited from ICodeCompletionWindow.)
Public method | DropDown | When implemented by a class, displays button's popup menu.
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from ICodeCompletionWindow.)
Public method | PerformSearch | When implemented by a class, performs searching operation. (Inherited from ICodeCompletionWindow.)
Public method | Popup | When implemented by a class, displays popup window at the current mouse position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window. (Inherited from ICodeCompletionWindow.)
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider. (Inherited from ICodeCompletionWindow.)
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value. (Inherited from ICodeCompletionWindow.)
Top
Properties
 | Name | Description
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from ICodeCompletionWindow.)
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window. (Inherited from ICodeCompletionWindow.)
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from ICodeCompletionWindow.)
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | FocusControl | When implemented by a class, returns child control that has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | Font | When implemented by a class, gets or sets the font for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionWindow.)
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | IsVisible | When implemented by a class, indicates if window is visible. (Inherited from ICodeCompletionWindow.)
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow. (Inherited from ICodeCompletionWindow.)
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from ICodeCompletionWindow.)
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Size | When implemented by a class, returns size of the window. (Inherited from ICodeCompletionWindow.)
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable. (Inherited from ICodeCompletionWindow.)
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed.
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed. (Inherited from ICodeCompletionWindow.)
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed. (Inherited from ICodeCompletionWindow.)
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control. (Inherited from ICodeCompletionWindow.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from ICodeCompletionWindow.)
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICodeCompletionButton Methods

ICodeCompletionButton Methods

The ICodeCompletionButton type exposes the following members.

Methods
 | Name | Description
Public method | Close(Boolean) | When implemented by a class, closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay. (Inherited from ICodeCompletionWindow.)
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control. (Inherited from ICodeCompletionWindow.)
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold. (Inherited from ICodeCompletionWindow.)
Public method | DropDown | When implemented by a class, displays button's popup menu.
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from ICodeCompletionWindow.)
Public method | PerformSearch | When implemented by a class, performs searching operation. (Inherited from ICodeCompletionWindow.)
Public method | Popup | When implemented by a class, displays popup window at the current mouse position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window. (Inherited from ICodeCompletionWindow.)
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider. (Inherited from ICodeCompletionWindow.)
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

ICodeCompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionButton.DropDown Method

ICodeCompletionButtonDropDown Method
When implemented by a class, displays button's popup menu.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DropDown()
Sub DropDown
void DropDown()
abstract DropDown : unit -> unit
See Also

Reference

ICodeCompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionButton Properties

ICodeCompletionButton Properties

The ICodeCompletionButton type exposes the following members.

Properties
 | Name | Description
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from ICodeCompletionWindow.)
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window. (Inherited from ICodeCompletionWindow.)
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from ICodeCompletionWindow.)
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | FocusControl | When implemented by a class, returns child control that has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | Font | When implemented by a class, gets or sets the font for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionWindow.)
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | IsVisible | When implemented by a class, indicates if window is visible. (Inherited from ICodeCompletionWindow.)
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow. (Inherited from ICodeCompletionWindow.)
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from ICodeCompletionWindow.)
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Size | When implemented by a class, returns size of the window. (Inherited from ICodeCompletionWindow.)
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable. (Inherited from ICodeCompletionWindow.)
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed.
Top
See Also

Reference

ICodeCompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionButton.Visible Property

ICodeCompletionButtonVisible Property
When implemented by a class, gets or sets a value indicating whether the control is displayed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionButton Events

ICodeCompletionButton Events

The ICodeCompletionButton type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed. (Inherited from ICodeCompletionWindow.)
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed. (Inherited from ICodeCompletionWindow.)
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control. (Inherited from ICodeCompletionWindow.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from ICodeCompletionWindow.)
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

ICodeCompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn Interface

ICodeCompletionColumn Interface
Represents properties and methods to identify individual column object within a code completion columns collection.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionColumn
Public Interface ICodeCompletionColumn
public interface class ICodeCompletionColumn
type ICodeCompletionColumn =  interface end

The ICodeCompletionColumn type exposes the following members.

Methods
 | Name | Description
Public method | ResetFontStyle | When implemented by a class, resets FontStyle to the default value.
Public method | ResetForeColor | When implemented by a class, resets ForeColor to the default value.
Public method | ResetVisible | When implemented by a class, resets Visible to the default value.
Top
Properties
 | Name | Description
Public property | FontStyle | When implemented by a class, gets or sets font style of the column.
Public property | ForeColor | When implemented by a class, gets or sets foreground color of the column.
Public property | Name | When implemented by a class, gets or sets the name of the column.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether a column is visible.
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn Methods

ICodeCompletionColumn Methods

The ICodeCompletionColumn type exposes the following members.

Methods
 | Name | Description
Public method | ResetFontStyle | When implemented by a class, resets FontStyle to the default value.
Public method | ResetForeColor | When implemented by a class, resets ForeColor to the default value.
Public method | ResetVisible | When implemented by a class, resets Visible to the default value.
Top
See Also

Reference

ICodeCompletionColumn Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn.ResetFontStyle Method

ICodeCompletionColumnResetFontStyle Method
When implemented by a class, resets FontStyle to the default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetFontStyle()
Sub ResetFontStyle
void ResetFontStyle()
abstract ResetFontStyle : unit -> unit
See Also

Reference

ICodeCompletionColumn Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn.ResetForeColor Method

ICodeCompletionColumnResetForeColor Method
When implemented by a class, resets ForeColor to the default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetForeColor()
Sub ResetForeColor
void ResetForeColor()
abstract ResetForeColor : unit -> unit
See Also

Reference

ICodeCompletionColumn Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn.ResetVisible Method

ICodeCompletionColumnResetVisible Method
When implemented by a class, resets Visible to the default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetVisible()
Sub ResetVisible
void ResetVisible()
abstract ResetVisible : unit -> unit
See Also

Reference

ICodeCompletionColumn Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn Properties

ICodeCompletionColumn Properties

The ICodeCompletionColumn type exposes the following members.

Properties
 | Name | Description
Public property | FontStyle | When implemented by a class, gets or sets font style of the column.
Public property | ForeColor | When implemented by a class, gets or sets foreground color of the column.
Public property | Name | When implemented by a class, gets or sets the name of the column.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether a column is visible.
Top
See Also

Reference

ICodeCompletionColumn Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn.FontStyle Property

ICodeCompletionColumnFontStyle Property
When implemented by a class, gets or sets font style of the column.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
FontStyle FontStyle { get; set; }
Property FontStyle As FontStyle
    Get
    Set
property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract FontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

ICodeCompletionColumn Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn.ForeColor Property

ICodeCompletionColumnForeColor Property
When implemented by a class, gets or sets foreground color of the column.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; set; }
Property ForeColor As Color
    Get
    Set
property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ICodeCompletionColumn Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn.Name Property

ICodeCompletionColumnName Property
When implemented by a class, gets or sets the name of the column.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICodeCompletionColumn Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumn.Visible Property

ICodeCompletionColumnVisible Property
When implemented by a class, gets or sets a value indicating whether a column is visible.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionColumn Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumns Interface

ICodeCompletionColumns Interface
Represents properties and methods to provide indexed access to ICodeCompletionColumn object.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionColumns : IList<ICodeCompletionColumn>,
    ICollection<ICodeCompletionColumn>, IEnumerable<ICodeCompletionColumn>, IEnumerable
Public Interface ICodeCompletionColumns
    Inherits IList(Of ICodeCompletionColumn), ICollection(Of ICodeCompletionColumn),
    IEnumerable(Of ICodeCompletionColumn), IEnumerable
public interface class ICodeCompletionColumns : IList<ICodeCompletionColumn^>,
    ICollection<ICodeCompletionColumn^>, IEnumerable<ICodeCompletionColumn^>, IEnumerable
type ICodeCompletionColumns =
    interface
        interface IList<ICodeCompletionColumn>
        interface ICollection<ICodeCompletionColumn>
        interface IEnumerable<ICodeCompletionColumn>
        interface IEnumerable
    end

The ICodeCompletionColumns type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionColumn .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionColumn .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionColumn .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionColumn .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionColumn .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionColumn .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionColumn .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionColumn .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionColumn .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionColumn | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionColumn | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionColumn, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionColumn .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionColumn .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionColumn .)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumns Methods

ICodeCompletionColumns Methods

The ICodeCompletionColumns type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionColumn .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionColumn .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionColumn .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionColumn .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionColumn .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionColumn .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionColumn .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionColumn .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionColumn .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionColumn | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionColumn | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionColumn, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeCompletionColumns Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionColumns Properties

ICodeCompletionColumns Properties

The ICodeCompletionColumns type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionColumn .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionColumn .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionColumn .)
Top
See Also

Reference

ICodeCompletionColumns Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionEdit Interface

ICodeCompletionEdit Interface
Represents properties and methods of a popup window that displays code completion information presented in the form of an edit with a label.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionEdit : ICodeCompletionWindow,
    IControl
Public Interface ICodeCompletionEdit
    Inherits ICodeCompletionWindow, IControl
public interface class ICodeCompletionEdit : ICodeCompletionWindow,
    IControl
type ICodeCompletionEdit =
    interface
        interface ICodeCompletionWindow
        interface IControl
    end

The ICodeCompletionEdit type exposes the following members.

Methods
 | Name | Description
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | Close(Boolean) | When implemented by a class, closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay. (Inherited from ICodeCompletionWindow.)
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control. (Inherited from ICodeCompletionWindow.)
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold. (Inherited from ICodeCompletionWindow.)
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from ICodeCompletionWindow.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | PerformSearch | When implemented by a class, performs searching operation. (Inherited from ICodeCompletionWindow.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Popup | When implemented by a class, displays popup window at the current mouse position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider. (Inherited from ICodeCompletionWindow.)
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value. (Inherited from ICodeCompletionWindow.)
Top
Properties
 | Name | Description
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from ICodeCompletionWindow.)
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from ICodeCompletionWindow.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Edit | When implemented by a class, represents a completion list box control.
Public property | EditField | When implemented by a class, gets or sets a value that indicates caption of the Edit label.
Public property | EditPath | When implemented by a class, gets or sets a value that indicates path to the nested data.
Public property | EditText | When implemented by a class, gets or sets a value that indicates text of the field being edited.
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | FocusControl | When implemented by a class, returns child control that has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionWindow.)
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | IsVisible | When implemented by a class, indicates if window is visible. (Inherited from ICodeCompletionWindow.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow. (Inherited from ICodeCompletionWindow.)
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from ICodeCompletionWindow.)
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Size | When implemented by a class, returns size of the window. (Inherited from ICodeCompletionWindow.)
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable. (Inherited from ICodeCompletionWindow.)
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed. (Inherited from ICodeCompletionWindow.)
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed. (Inherited from ICodeCompletionWindow.)
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control. (Inherited from ICodeCompletionWindow.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from ICodeCompletionWindow.)
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICodeCompletionEdit Methods

ICodeCompletionEdit Methods

The ICodeCompletionEdit type exposes the following members.

Methods
 | Name | Description
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | Close(Boolean) | When implemented by a class, closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay. (Inherited from ICodeCompletionWindow.)
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control. (Inherited from ICodeCompletionWindow.)
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold. (Inherited from ICodeCompletionWindow.)
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from ICodeCompletionWindow.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | PerformSearch | When implemented by a class, performs searching operation. (Inherited from ICodeCompletionWindow.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Popup | When implemented by a class, displays popup window at the current mouse position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider. (Inherited from ICodeCompletionWindow.)
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

ICodeCompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionEdit Properties

ICodeCompletionEdit Properties

The ICodeCompletionEdit type exposes the following members.

Properties
 | Name | Description
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from ICodeCompletionWindow.)
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from ICodeCompletionWindow.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Edit | When implemented by a class, represents a completion list box control.
Public property | EditField | When implemented by a class, gets or sets a value that indicates caption of the Edit label.
Public property | EditPath | When implemented by a class, gets or sets a value that indicates path to the nested data.
Public property | EditText | When implemented by a class, gets or sets a value that indicates text of the field being edited.
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | FocusControl | When implemented by a class, returns child control that has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionWindow.)
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | IsVisible | When implemented by a class, indicates if window is visible. (Inherited from ICodeCompletionWindow.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow. (Inherited from ICodeCompletionWindow.)
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from ICodeCompletionWindow.)
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Size | When implemented by a class, returns size of the window. (Inherited from ICodeCompletionWindow.)
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable. (Inherited from ICodeCompletionWindow.)
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
See Also

Reference

ICodeCompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionEdit.Edit Property

ICodeCompletionEditEdit Property
When implemented by a class, represents a completion list box control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICompletionEdit Edit { get; }
ReadOnly Property Edit As ICompletionEdit
    Get
property ICompletionEdit^ Edit {
    ICompletionEdit^ get ();
}
abstract Edit : ICompletionEdit with get

Property Value

Type: ICompletionEdit
See Also

Reference

ICodeCompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionEdit.EditField Property

ICodeCompletionEditEditField Property
When implemented by a class, gets or sets a value that indicates caption of the Edit label.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string EditField { get; set; }
Property EditField As String
    Get
    Set
property String^ EditField {
    String^ get ();
    void set (String^ value);
}
abstract EditField : string with get, set

Property Value

Type: String
See Also

Reference

ICodeCompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionEdit.EditPath Property

ICodeCompletionEditEditPath Property
When implemented by a class, gets or sets a value that indicates path to the nested data.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string EditPath { get; set; }
Property EditPath As String
    Get
    Set
property String^ EditPath {
    String^ get ();
    void set (String^ value);
}
abstract EditPath : string with get, set

Property Value

Type: String
See Also

Reference

ICodeCompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionEdit.EditText Property

ICodeCompletionEditEditText Property
When implemented by a class, gets or sets a value that indicates text of the field being edited.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string EditText { get; set; }
Property EditText As String
    Get
    Set
property String^ EditText {
    String^ get ();
    void set (String^ value);
}
abstract EditText : string with get, set

Property Value

Type: String
See Also

Reference

ICodeCompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionEdit Events

ICodeCompletionEdit Events

The ICodeCompletionEdit type exposes the following members.

Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed. (Inherited from ICodeCompletionWindow.)
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed. (Inherited from ICodeCompletionWindow.)
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control. (Inherited from ICodeCompletionWindow.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from ICodeCompletionWindow.)
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

ICodeCompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint Interface

ICodeCompletionHint Interface
Represents properties and methods of a popup window that displays code completion information presented in the form of a tooltip window..

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionHint : ICodeCompletionWindow,
    ISyntaxPaint
Public Interface ICodeCompletionHint
    Inherits ICodeCompletionWindow, ISyntaxPaint
public interface class ICodeCompletionHint : ICodeCompletionWindow,
    ISyntaxPaint
type ICodeCompletionHint =
    interface
        interface ICodeCompletionWindow
        interface ISyntaxPaint
    end

The ICodeCompletionHint type exposes the following members.

Methods
 | Name | Description
Public method | Close(Boolean) | When implemented by a class, closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay. (Inherited from ICodeCompletionWindow.)
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control. (Inherited from ICodeCompletionWindow.)
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold. (Inherited from ICodeCompletionWindow.)
Public method | DrawLine(Int32, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position. (Inherited from ISyntaxPaint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position. (Inherited from ISyntaxPaint.)
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from ICodeCompletionWindow.)
Public method | EqualStyles | When implemented by a class, indicates whether given styles are equal. (Inherited from ISyntaxPaint.)
Public method | GetFontColor | When implemented by a class, retrieves font color corresponding to given state. (Inherited from ISyntaxPaint.)
Public method | GetFontStyle | When implemented by a class, retrieves font style corresponding to given state. (Inherited from ISyntaxPaint.)
Public method | GetLexStyle | When implemented by a class, retrieves lex state corresponding to given parser style. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32) | When implemented by a class, measures part of the string given at by its Index. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | When implemented by a class, measures part of given string. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of the string given by its index. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of given string. (Inherited from ISyntaxPaint.)
Public method | OnCustomDraw | When implemented by a class, raises an CustomDraw event. (Inherited from ISyntaxPaint.)
Public method | PaintSyntax | When implemented by a class, perform syntax painting of the control on the graphic surface. (Inherited from ISyntaxPaint.)
Public method | PerformSearch | When implemented by a class, performs searching operation. (Inherited from ICodeCompletionWindow.)
Public method | Popup | When implemented by a class, displays popup window at the current mouse position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window. (Inherited from ICodeCompletionWindow.)
Public method | ResetAutoHide | When implemented by a class, resets the AutoHide to the default value.
Public method | ResetAutoHidePause | When implemented by a class, resets the AutoHidePause to the default value.
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider. (Inherited from ICodeCompletionWindow.)
Public method | ResetDisableColorPaint | When implemented by a class, resets the DisableColorPaint to the default value. (Inherited from ISyntaxPaint.)
Public method | ResetDisableSyntaxPaint | When implemented by a class, resets the DisableSyntaxPaint to the default value. (Inherited from ISyntaxPaint.)
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value. (Inherited from ICodeCompletionWindow.)
Top
Properties
 | Name | Description
Public property | AutoHide | When implemented by a class, gets or sets a value that indicates whether ICodeCompletionHint should be closed after some period of time.
Public property | AutoHidePause | When implemented by a class, gets or sets a value that specifies delay, in milliseconds, between displaying and hiding popup hint.
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from ICodeCompletionWindow.)
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window. (Inherited from ICodeCompletionWindow.)
Public property | DisableColorPaint | When implemented by a class, gets or sets a value indicating whether control uses colors to paint its content. (Inherited from ISyntaxPaint.)
Public property | DisableSyntaxPaint | When implemented by a class, gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from ISyntaxPaint.)
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from ICodeCompletionWindow.)
Public property | Enabled | When implemented by a class, enables or disables the hint
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | FocusControl | When implemented by a class, returns child control that has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | Font | When implemented by a class, gets or sets the font for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionWindow.)
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | IsVisible | When implemented by a class, indicates if window is visible. (Inherited from ICodeCompletionWindow.)
Public property | Lexer | When implemented by a class, gets or sets object that can make lexical analysis for the control's content. (Inherited from ISyntaxPaint.)
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow. (Inherited from ICodeCompletionWindow.)
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from ISyntaxPaint.)
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from ICodeCompletionWindow.)
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Size | When implemented by a class, returns size of the window. (Inherited from ICodeCompletionWindow.)
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable. (Inherited from ICodeCompletionWindow.)
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed.
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed. (Inherited from ICodeCompletionWindow.)
Public event | CustomDraw | When implemented by a class, occurs when control draws its content. (Inherited from ISyntaxPaint.)
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed. (Inherited from ICodeCompletionWindow.)
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control. (Inherited from ICodeCompletionWindow.)
Public event | HyperTextClick | When implemented by a class, occurs when user clicks on hypertext in the hint.
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from ICodeCompletionWindow.)
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint Methods

ICodeCompletionHint Methods

The ICodeCompletionHint type exposes the following members.

Methods
 | Name | Description
Public method | Close(Boolean) | When implemented by a class, closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from ICodeCompletionWindow.)
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay. (Inherited from ICodeCompletionWindow.)
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control. (Inherited from ICodeCompletionWindow.)
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold. (Inherited from ICodeCompletionWindow.)
Public method | DrawLine(Int32, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position. (Inherited from ISyntaxPaint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | When implemented by a class, draws line given by its index at the specified position. (Inherited from ISyntaxPaint.)
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from ICodeCompletionWindow.)
Public method | EqualStyles | When implemented by a class, indicates whether given styles are equal. (Inherited from ISyntaxPaint.)
Public method | GetFontColor | When implemented by a class, retrieves font color corresponding to given state. (Inherited from ISyntaxPaint.)
Public method | GetFontStyle | When implemented by a class, retrieves font style corresponding to given state. (Inherited from ISyntaxPaint.)
Public method | GetLexStyle | When implemented by a class, retrieves lex state corresponding to given parser style. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32) | When implemented by a class, measures part of the string given at by its Index. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | When implemented by a class, measures part of given string. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of the string given by its index. (Inherited from ISyntaxPaint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | When implemented by a class, measures part of given string. (Inherited from ISyntaxPaint.)
Public method | OnCustomDraw | When implemented by a class, raises an CustomDraw event. (Inherited from ISyntaxPaint.)
Public method | PaintSyntax | When implemented by a class, perform syntax painting of the control on the graphic surface. (Inherited from ISyntaxPaint.)
Public method | PerformSearch | When implemented by a class, performs searching operation. (Inherited from ICodeCompletionWindow.)
Public method | Popup | When implemented by a class, displays popup window at the current mouse position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position. (Inherited from ICodeCompletionWindow.)
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window. (Inherited from ICodeCompletionWindow.)
Public method | ResetAutoHide | When implemented by a class, resets the AutoHide to the default value.
Public method | ResetAutoHidePause | When implemented by a class, resets the AutoHidePause to the default value.
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value. (Inherited from ICodeCompletionWindow.)
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider. (Inherited from ICodeCompletionWindow.)
Public method | ResetDisableColorPaint | When implemented by a class, resets the DisableColorPaint to the default value. (Inherited from ISyntaxPaint.)
Public method | ResetDisableSyntaxPaint | When implemented by a class, resets the DisableSyntaxPaint to the default value. (Inherited from ISyntaxPaint.)
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint.ResetAutoHide Method

ICodeCompletionHintResetAutoHide Method
When implemented by a class, resets the AutoHide to the default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAutoHide()
Sub ResetAutoHide
void ResetAutoHide()
abstract ResetAutoHide : unit -> unit
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint.ResetAutoHidePause Method

ICodeCompletionHintResetAutoHidePause Method
When implemented by a class, resets the AutoHidePause to the default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAutoHidePause()
Sub ResetAutoHidePause
void ResetAutoHidePause()
abstract ResetAutoHidePause : unit -> unit
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint Properties

ICodeCompletionHint Properties

The ICodeCompletionHint type exposes the following members.

Properties
 | Name | Description
Public property | AutoHide | When implemented by a class, gets or sets a value that indicates whether ICodeCompletionHint should be closed after some period of time.
Public property | AutoHidePause | When implemented by a class, gets or sets a value that specifies delay, in milliseconds, between displaying and hiding popup hint.
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from ICodeCompletionWindow.)
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window. (Inherited from ICodeCompletionWindow.)
Public property | DisableColorPaint | When implemented by a class, gets or sets a value indicating whether control uses colors to paint its content. (Inherited from ISyntaxPaint.)
Public property | DisableSyntaxPaint | When implemented by a class, gets or sets a value indicating whether Edit control uses lexical colors/styles to paint its content. (Inherited from ISyntaxPaint.)
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from ICodeCompletionWindow.)
Public property | Enabled | When implemented by a class, enables or disables the hint
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | FocusControl | When implemented by a class, returns child control that has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | Font | When implemented by a class, gets or sets the font for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionWindow.)
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus. (Inherited from ICodeCompletionWindow.)
Public property | IsVisible | When implemented by a class, indicates if window is visible. (Inherited from ICodeCompletionWindow.)
Public property | Lexer | When implemented by a class, gets or sets object that can make lexical analysis for the control's content. (Inherited from ISyntaxPaint.)
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow. (Inherited from ICodeCompletionWindow.)
Public property | Painter | Specifies IPainter object used to draw text and graphic primitives. (Inherited from ISyntaxPaint.)
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from ICodeCompletionWindow.)
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window. (Inherited from ICodeCompletionWindow.)
Public property | Size | When implemented by a class, returns size of the window. (Inherited from ICodeCompletionWindow.)
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable. (Inherited from ICodeCompletionWindow.)
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid. (Inherited from ICodeCompletionWindow.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed.
Top
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint.AutoHide Property

ICodeCompletionHintAutoHide Property
When implemented by a class, gets or sets a value that indicates whether ICodeCompletionHint should be closed after some period of time.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AutoHide { get; set; }
Property AutoHide As Boolean
    Get
    Set
property bool AutoHide {
    bool get ();
    void set (bool value);
}
abstract AutoHide : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint.AutoHidePause Property

ICodeCompletionHintAutoHidePause Property
When implemented by a class, gets or sets a value that specifies delay, in milliseconds, between displaying and hiding popup hint.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AutoHidePause { get; set; }
Property AutoHidePause As Integer
    Get
    Set
property int AutoHidePause {
    int get ();
    void set (int value);
}
abstract AutoHidePause : int with get, set

Property Value

Type: Int32
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint.Enabled Property

ICodeCompletionHintEnabled Property
When implemented by a class, enables or disables the hint

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint.Visible Property

ICodeCompletionHintVisible Property
When implemented by a class, gets or sets a value indicating whether the control is displayed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint Events

ICodeCompletionHint Events

The ICodeCompletionHint type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed. (Inherited from ICodeCompletionWindow.)
Public event | CustomDraw | When implemented by a class, occurs when control draws its content. (Inherited from ISyntaxPaint.)
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed. (Inherited from ICodeCompletionWindow.)
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control. (Inherited from ICodeCompletionWindow.)
Public event | HyperTextClick | When implemented by a class, occurs when user clicks on hypertext in the hint.
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from ICodeCompletionWindow.)
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed. (Inherited from ICodeCompletionWindow.)
Top
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionHint.HyperTextClick Event

ICodeCompletionHintHyperTextClick Event
When implemented by a class, occurs when user clicks on hypertext in the hint.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler HyperTextClick
Event HyperTextClick As EventHandler
 event EventHandler^ HyperTextClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract HyperTextClick : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ICodeCompletionHint Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow Interface

ICodeCompletionWindow Interface
Represents properties and methods to display a popup window containing Code Completion information.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionWindow
Public Interface ICodeCompletionWindow
public interface class ICodeCompletionWindow
type ICodeCompletionWindow =  interface end

The ICodeCompletionWindow type exposes the following members.

Methods
 | Name | Description
Public method | Close(Boolean) | When implemented by a class, closes the popup window.
Public method | Close(Boolean, Boolean) | Closes the popup window.
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay.
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control.
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold.
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary.
Public method | PerformSearch | When implemented by a class, performs searching operation.
Public method | Popup | When implemented by a class, displays popup window at the current mouse position.
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position.
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position.
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position.
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window.
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value.
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value.
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider.
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value.
Top
Properties
 | Name | Description
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents.
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window.
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window.
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed.
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid.
Public property | FocusControl | When implemented by a class, returns child control that has an input focus.
Public property | Font | When implemented by a class, gets or sets the font for the popup window.
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window.
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items.
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus.
Public property | IsVisible | When implemented by a class, indicates if window is visible.
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow.
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox.
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window.
Public property | Size | When implemented by a class, returns size of the window.
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable.
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid.
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed.
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed.
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control.
Public event | KeyPreviewEvent | Occurs when the popup window receives key message.
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed.
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow Methods

ICodeCompletionWindow Methods

The ICodeCompletionWindow type exposes the following members.

Methods
 | Name | Description
Public method | Close(Boolean) | When implemented by a class, closes the popup window.
Public method | Close(Boolean, Boolean) | Closes the popup window.
Public method | CloseDelayed | When implemented by a class, closes the popup window with delay.
Public method | ContainsControl | When implemented by a class, retrieves a value indicating whether the popup window contains the specified control.
Public method | ContainsMouseCursor | When implemented by a class, determines whether control contains mouse position, with specified therehold.
Public method | EnsureVisible | When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary.
Public method | PerformSearch | When implemented by a class, performs searching operation.
Public method | Popup | When implemented by a class, displays popup window at the current mouse position.
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position.
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position.
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position.
Public method | PositionChanged | When implemented by a class, responds on changing position in the popup window.
Public method | ResetAutoSize | When implemented by a class, resets the AutoSize to the default value.
Public method | ResetCodeCompletionFlags | When implemented by a class, resets the CodeCompletions to the default value.
Public method | ResetContent | When implemented by a class, updates ICodeCompletionWindow content from its Provider.
Public method | ResetSizeable | When implemented by a class, resets the Sizeable to the default value.
Top
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.Close Method

ICodeCompletionWindowClose Method
Overload List
 | Name | Description
Public method | Close(Boolean) | When implemented by a class, closes the popup window.
Public method | Close(Boolean, Boolean) | Closes the popup window.
Top
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.Close Method (Boolean)

ICodeCompletionWindowClose Method (Boolean)
When implemented by a class, closes the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Close(
    bool accept
)
Sub Close (
    accept As Boolean
)
void Close(
    bool accept
)
abstract Close :
        accept : bool -> unit

Parameters

accept
Type: SystemBoolean
Indicates whether the result of the popup should be accepted.
See Also

Reference

ICodeCompletionWindow Interface
Close Overload
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.Close Method (Boolean, Boolean)

ICodeCompletionWindowClose Method (Boolean, Boolean)
Closes the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Close(
    bool accept,
    bool setFocus
)
Sub Close (
    accept As Boolean,
    setFocus As Boolean
)
void Close(
    bool accept,
    bool setFocus
)
abstract Close :
        accept : bool *
        setFocus : bool -> unit

Parameters

accept
Type: SystemBoolean
Indicates whether the result of the popup should be accepted.
setFocus
Type: SystemBoolean
Indicates whether the owner control should be focused after closing popup window.
See Also

Reference

ICodeCompletionWindow Interface
Close Overload
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.CloseDelayed Method

ICodeCompletionWindowCloseDelayed Method
When implemented by a class, closes the popup window with delay.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CloseDelayed(
    bool accept
)
Sub CloseDelayed (
    accept As Boolean
)
void CloseDelayed(
    bool accept
)
abstract CloseDelayed :
        accept : bool -> unit

Parameters

accept
Type: SystemBoolean
Indicates whether the result of the popup should be accepted.
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.ContainsControl Method

ICodeCompletionWindowContainsControl Method
When implemented by a class, retrieves a value indicating whether the popup window contains the specified control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ContainsControl(
    Control control
)
Function ContainsControl (
    control As Control
) As Boolean
bool ContainsControl(
    Control^ control
)
abstract ContainsControl :
        control : Control -> bool

Parameters

control
Type: System.Windows.FormsControl
The Control to evaluate.

Return Value

Type: Boolean
True if the popup window contains the specified control; otherwise, false.
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.ContainsMouseCursor Method

ICodeCompletionWindowContainsMouseCursor Method
When implemented by a class, determines whether control contains mouse position, with specified therehold.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ContainsMouseCursor(
    int therehold
)
Function ContainsMouseCursor (
    therehold As Integer
) As Boolean
bool ContainsMouseCursor(
    int therehold
)
abstract ContainsMouseCursor :
        therehold : int -> bool

Parameters

therehold
Type: SystemInt32
Specifies size, in pixels, of the inflated boundary of the control.

Return Value

Type: Boolean
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.EnsureVisible Method

ICodeCompletionWindowEnsureVisible Method
When implemented by a class, ensures that the popup window is visible in the screen working area, moving it if necessary.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EnsureVisible(
    ref Point position
)
Sub EnsureVisible (
    ByRef position As Point
)
void EnsureVisible(
    Point% position
)
abstract EnsureVisible :
        position : Point byref -> unit

Parameters

position
Type: System.DrawingPoint
Position to evaluate.
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.PerformSearch Method

ICodeCompletionWindowPerformSearch Method
When implemented by a class, performs searching operation.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PerformSearch()
Function PerformSearch As Boolean
bool PerformSearch()
abstract PerformSearch : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.Popup Method

ICodeCompletionWindowPopup Method
When implemented by a class, displays popup window at the current mouse position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Popup()
Sub Popup
void Popup()
abstract Popup : unit -> unit
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.PopupAt Method

ICodeCompletionWindowPopupAt Method
Overload List
 | Name | Description
Public method | PopupAt(Point) | When implemented by a class, displays popup window at the specified screen position.
Public method | PopupAt(Point, ICodeCompletionProvider) | When implemented by a class, displays popup window at the specified screen position.
Public method | PopupAt(Int32, Int32) | When implemented by a class, displays popup window at the specified screen position.
Top
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.PopupAt Method (Point)

ICodeCompletionWindowPopupAt Method (Point)
When implemented by a class, displays popup window at the specified screen position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PopupAt(
    Point position
)
Sub PopupAt (
    position As Point
)
void PopupAt(
    Point position
)
abstract PopupAt :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
The Point object that specifies the coordinates at which popup window should be displayed.
See Also

Reference

ICodeCompletionWindow Interface
PopupAt Overload
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.PopupAt Method (Point, ICodeCompletionProvider)

ICodeCompletionWindowPopupAt Method (Point, ICodeCompletionProvider)
When implemented by a class, displays popup window at the specified screen position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PopupAt(
    Point position,
    ICodeCompletionProvider provider
)
Sub PopupAt (
    position As Point,
    provider As ICodeCompletionProvider
)
void PopupAt(
    Point position,
    ICodeCompletionProvider^ provider
)
abstract PopupAt :
        position : Point *
        provider : ICodeCompletionProvider -> unit

Parameters

position
Type: System.DrawingPoint
The Point object that specifies the coordinates at which popup window should be displayed.
provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Specifies source of the content for this window
See Also

Reference

ICodeCompletionWindow Interface
PopupAt Overload
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.PopupAt Method (Int32, Int32)

ICodeCompletionWindowPopupAt Method (Int32, Int32)
When implemented by a class, displays popup window at the specified screen position.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PopupAt(
    int x,
    int y
)
Sub PopupAt (
    x As Integer,
    y As Integer
)
void PopupAt(
    int x,
    int y
)
abstract PopupAt :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
Horizontal coordinate at which popup window should be displayed.
y
Type: SystemInt32
Vertical coordinate at which popup window should be displayed.
See Also

Reference

ICodeCompletionWindow Interface
PopupAt Overload
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.PositionChanged Method

ICodeCompletionWindowPositionChanged Method
When implemented by a class, responds on changing position in the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
X-coordinate of current position.
y
Type: SystemInt32
Y-coordinate of current position.
deltaX
Type: SystemInt32
Horizontal offset.
deltaY
Type: SystemInt32
Vertical offset.
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.ResetAutoSize Method

ICodeCompletionWindowResetAutoSize Method
When implemented by a class, resets the AutoSize to the default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAutoSize()
Sub ResetAutoSize
void ResetAutoSize()
abstract ResetAutoSize : unit -> unit
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.ResetCodeCompletionFlags Method

ICodeCompletionWindowResetCodeCompletionFlags Method
When implemented by a class, resets the CodeCompletions to the default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetCodeCompletionFlags()
Sub ResetCodeCompletionFlags
void ResetCodeCompletionFlags()
abstract ResetCodeCompletionFlags : unit -> unit
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.ResetContent Method

ICodeCompletionWindowResetContent Method
When implemented by a class, updates ICodeCompletionWindow content from its Provider.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetContent()
Sub ResetContent
void ResetContent()
abstract ResetContent : unit -> unit
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.ResetSizeable Method

ICodeCompletionWindowResetSizeable Method
When implemented by a class, resets the Sizeable to the default value.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetSizeable()
Sub ResetSizeable
void ResetSizeable()
abstract ResetSizeable : unit -> unit
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow Properties

ICodeCompletionWindow Properties

The ICodeCompletionWindow type exposes the following members.

Properties
 | Name | Description
Public property | AutoSize | When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents.
Public property | BackColor | When implemented by a class, gets or sets the back color for the popup window.
Public property | CompletionFlags | When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window.
Public property | DisplayPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed.
Public property | EndPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid.
Public property | FocusControl | When implemented by a class, returns child control that has an input focus.
Public property | Font | When implemented by a class, gets or sets the font for the popup window.
Public property | ForeColor | When implemented by a class, gets or sets the fore color for the popup window.
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items.
Public property | IsFocused | When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus.
Public property | IsVisible | When implemented by a class, indicates if window is visible.
Public property | OwnerControl | When implemented by a class, represents a control owning the ICodeCompletionWindow.
Public property | PopupControl | When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox.
Public property | Provider | When implemented by a class, gets or sets the object that contains data related to the popup window.
Public property | Size | When implemented by a class, returns size of the window.
Public property | Sizeable | When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable.
Public property | StartPos | When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid.
Top
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.AutoSize Property

ICodeCompletionWindowAutoSize Property
When implemented by a class, gets or sets a value indicating whether a popup window is automatically resized to fit its contents.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AutoSize { get; set; }
Property AutoSize As Boolean
    Get
    Set
property bool AutoSize {
    bool get ();
    void set (bool value);
}
abstract AutoSize : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.BackColor Property

ICodeCompletionWindowBackColor Property
When implemented by a class, gets or sets the back color for the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; set; }
Property BackColor As Color
    Get
    Set
property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.CompletionFlags Property

ICodeCompletionWindowCompletionFlags Property
When implemented by a class, gets or sets collection of attributes that specifies behaviour of the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
CodeCompletionFlags CompletionFlags { get; set; }
Property CompletionFlags As CodeCompletionFlags
    Get
    Set
property CodeCompletionFlags CompletionFlags {
    CodeCompletionFlags get ();
    void set (CodeCompletionFlags value);
}
abstract CompletionFlags : CodeCompletionFlags with get, set

Property Value

Type: CodeCompletionFlags
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.DisplayPos Property

ICodeCompletionWindowDisplayPos Property
When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point DisplayPos { get; set; }
Property DisplayPos As Point
    Get
    Set
property Point DisplayPos {
    Point get ();
    void set (Point value);
}
abstract DisplayPos : Point with get, set

Property Value

Type: Point
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.EndPos Property

ICodeCompletionWindowEndPos Property
When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point EndPos { get; set; }
Property EndPos As Point
    Get
    Set
property Point EndPos {
    Point get ();
    void set (Point value);
}
abstract EndPos : Point with get, set

Property Value

Type: Point
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.FocusControl Property

ICodeCompletionWindowFocusControl Property
When implemented by a class, returns child control that has an input focus.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Control FocusControl { get; }
ReadOnly Property FocusControl As Control
    Get
property Control^ FocusControl {
    Control^ get ();
}
abstract FocusControl : Control with get

Property Value

Type: Control
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.Font Property

ICodeCompletionWindowFont Property
When implemented by a class, gets or sets the font for the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Font Font { get; set; }
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

Property Value

Type: Font
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.ForeColor Property

ICodeCompletionWindowForeColor Property
When implemented by a class, gets or sets the fore color for the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; set; }
Property ForeColor As Color
    Get
    Set
property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.Images Property

ICodeCompletionWindowImages Property
When implemented by a class, gets or sets the ImageList for code completion items.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList Images { get; set; }
Property Images As ImageList
    Get
    Set
property ImageList^ Images {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract Images : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.IsFocused Property

ICodeCompletionWindowIsFocused Property
When implemented by a class, indicates whether ICodeCompletionWindow or it's child control has an input focus.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsFocused { get; }
ReadOnly Property IsFocused As Boolean
    Get
property bool IsFocused {
    bool get ();
}
abstract IsFocused : bool with get

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.IsVisible Property

ICodeCompletionWindowIsVisible Property
When implemented by a class, indicates if window is visible.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsVisible { get; }
ReadOnly Property IsVisible As Boolean
    Get
property bool IsVisible {
    bool get ();
}
abstract IsVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.OwnerControl Property

ICodeCompletionWindowOwnerControl Property
When implemented by a class, represents a control owning the ICodeCompletionWindow.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Control OwnerControl { get; set; }
Property OwnerControl As Control
    Get
    Set
property Control^ OwnerControl {
    Control^ get ();
    void set (Control^ value);
}
abstract OwnerControl : Control with get, set

Property Value

Type: Control
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.PopupControl Property

ICodeCompletionWindowPopupControl Property
When implemented by a class, represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Control PopupControl { get; }
ReadOnly Property PopupControl As Control
    Get
property Control^ PopupControl {
    Control^ get ();
}
abstract PopupControl : Control with get

Property Value

Type: Control
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace
Alternet.Editor.CodeCompletionCodeCompletionHint
Alternet.Editor.CodeCompletionCompletionListBox


ICodeCompletionWindow.Provider Property

ICodeCompletionWindowProvider Property
When implemented by a class, gets or sets the object that contains data related to the popup window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionProvider Provider { get; set; }
Property Provider As ICodeCompletionProvider
    Get
    Set
property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get ();
    void set (ICodeCompletionProvider^ value);
}
abstract Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.Size Property

ICodeCompletionWindowSize Property
When implemented by a class, returns size of the window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Size Size { get; }
ReadOnly Property Size As Size
    Get
property Size Size {
    Size get ();
}
abstract Size : Size with get

Property Value

Type: Size
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.Sizeable Property

ICodeCompletionWindowSizeable Property
When implemented by a class, gets or sets a value indicating whether the border of the popup window is resizable.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Sizeable { get; set; }
Property Sizeable As Boolean
    Get
    Set
property bool Sizeable {
    bool get ();
    void set (bool value);
}
abstract Sizeable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.StartPos Property

ICodeCompletionWindowStartPos Property
When implemented by a class, specifies position within the text (as index of line and character) where ICodeCompletionWindow is valid.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point StartPos { get; set; }
Property StartPos As Point
    Get
    Set
property Point StartPos {
    Point get ();
    void set (Point value);
}
abstract StartPos : Point with get, set

Property Value

Type: Point
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow Events

ICodeCompletionWindow Events

The ICodeCompletionWindow type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when the popup window is closed.
Public event | Disposed | When implemented by a class, occurs when the popup window is disposed.
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control.
Public event | KeyPreviewEvent | Occurs when the popup window receives key message.
Public event | ShowPopup | When implemented by a class, occurs when the popup window is displayed.
Top
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.ClosePopup Event

ICodeCompletionWindowClosePopup Event
When implemented by a class, occurs when the popup window is closed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event ClosePopupEvent ClosePopup
Event ClosePopup As ClosePopupEvent
 event ClosePopupEvent^ ClosePopup {
    void add (ClosePopupEvent^ value);
    void remove (ClosePopupEvent^ value);
}
abstract ClosePopup : IEvent<ClosePopupEvent,
    ClosingEventArgs>

Value

Type: Alternet.SyntaxClosePopupEvent
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.Disposed Event

ICodeCompletionWindowDisposed Event
When implemented by a class, occurs when the popup window is disposed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler Disposed
Event Disposed As EventHandler
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Disposed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.HelpRequested Event

ICodeCompletionWindowHelpRequested Event
When implemented by a class, occurs when user requests help for a control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event HelpEventHandler HelpRequested
Event HelpRequested As HelpEventHandler
 event HelpEventHandler^ HelpRequested {
    void add (HelpEventHandler^ value);
    void remove (HelpEventHandler^ value);
}
abstract HelpRequested : IEvent<HelpEventHandler,
    HelpEventArgs>

Value

Type: System.Windows.FormsHelpEventHandler
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.KeyPreviewEvent Event

ICodeCompletionWindowKeyPreviewEvent Event
Occurs when the popup window receives key message.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event KeyPreviewEvent KeyPreviewEvent
Event KeyPreviewEvent As KeyPreviewEvent
 event KeyPreviewEvent^ KeyPreviewEvent {
    void add (KeyPreviewEvent^ value);
    void remove (KeyPreviewEvent^ value);
}
abstract KeyPreviewEvent : IEvent<KeyPreviewEvent,
    KeyPreviewEventArgs>

Value

Type: Alternet.EditorKeyPreviewEvent
Remarks
The event handler receives an argument of type KeyPreviewEventArgs containing data related to this event.
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICodeCompletionWindow.ShowPopup Event

ICodeCompletionWindowShowPopup Event
When implemented by a class, occurs when the popup window is displayed.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event ShowPopupEvent ShowPopup
Event ShowPopup As ShowPopupEvent
 event ShowPopupEvent^ ShowPopup {
    void add (ShowPopupEvent^ value);
    void remove (ShowPopupEvent^ value);
}
abstract ShowPopup : IEvent<ShowPopupEvent,
    ShowingEventArgs>

Value

Type: Alternet.SyntaxShowPopupEvent
See Also

Reference

ICodeCompletionWindow Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionButton Interface

ICompletionButton Interface
Represents properties and methods of button control that appears in the code completion window.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICompletionButton : IControl
Public Interface ICompletionButton
    Inherits IControl
public interface class ICompletionButton : IControl
type ICompletionButton =
    interface
        interface IControl
    end

The ICompletionButton type exposes the following members.

Methods
 | Name | Description
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | GetIndex | When implemented by a class, returns current index.
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | ResetContent | When implemented by a class, updates ICompletionButton content from its Provider.
Top
Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | Menu | When implemented by a class, gets the menu items of the ICompletionButton.
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | Provider | When implemented by a class, represents the object that provides data for code completion.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICompletionButton Methods

ICompletionButton Methods

The ICompletionButton type exposes the following members.

Methods
 | Name | Description
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | GetIndex | When implemented by a class, returns current index.
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | ResetContent | When implemented by a class, updates ICompletionButton content from its Provider.
Top
See Also

Reference

ICompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionButton.GetIndex Method

ICompletionButtonGetIndex Method
When implemented by a class, returns current index.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetIndex(
    bool acceptIfFocused
)
Function GetIndex (
    acceptIfFocused As Boolean
) As Integer
int GetIndex(
    bool acceptIfFocused
)
abstract GetIndex :
        acceptIfFocused : bool -> int

Parameters

acceptIfFocused
Type: SystemBoolean
specifies if focused item will be returned

Return Value

Type: Int32
Index of the currently selected item.
See Also

Reference

ICompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionButton.ResetContent Method

ICompletionButtonResetContent Method
When implemented by a class, updates ICompletionButton content from its Provider.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetContent()
Sub ResetContent
void ResetContent()
abstract ResetContent : unit -> unit
See Also

Reference

ICompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionButton Properties

ICompletionButton Properties

The ICompletionButton type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | Menu | When implemented by a class, gets the menu items of the ICompletionButton.
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | Provider | When implemented by a class, represents the object that provides data for code completion.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
See Also

Reference

ICompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionButton.Menu Property

ICompletionButtonMenu Property
When implemented by a class, gets the menu items of the ICompletionButton.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ContextMenuStrip Menu { get; }
ReadOnly Property Menu As ContextMenuStrip
    Get
property ContextMenuStrip^ Menu {
    ContextMenuStrip^ get ();
}
abstract Menu : ContextMenuStrip with get

Property Value

Type: ContextMenuStrip
See Also

Reference

ICompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionButton.Provider Property

ICompletionButtonProvider Property
When implemented by a class, represents the object that provides data for code completion.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionProvider Provider { get; set; }
Property Provider As ICodeCompletionProvider
    Get
    Set
property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get ();
    void set (ICodeCompletionProvider^ value);
}
abstract Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider
See Also

Reference

ICompletionButton Interface
Alternet.Editor.CodeCompletion Namespace
Alternet.Syntax.CodeCompletionICodeCompletionProvider


ICompletionButton Events

ICompletionButton Events

The ICompletionButton type exposes the following members.

Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Top
See Also

Reference

ICompletionButton Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionEdit Interface

ICompletionEdit Interface
Represents properties for code completion requirements.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICompletionEdit : IControl
Public Interface ICompletionEdit
    Inherits IControl
public interface class ICompletionEdit : IControl
type ICompletionEdit =
    interface
        interface IControl
    end

The ICompletionEdit type exposes the following members.

Methods
 | Name | Description
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | UpdateSize | When implemented by a class, updates size of this ICompletionEdit control.
Top
Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | EditBox | When implemented by a class, represents a text box allowing to edit content of the ICompletionEditcontrol.
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Label | When implemented by a class, represents a label associated with the edit ICompletionEditcontrol.
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | PathLabel | When implemented by a class, represents a path label associated with the edit ICompletionEditcontrol.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ICompletionEdit Methods

ICompletionEdit Methods

The ICompletionEdit type exposes the following members.

Methods
 | Name | Description
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | UpdateSize | When implemented by a class, updates size of this ICompletionEdit control.
Top
See Also

Reference

ICompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionEdit.UpdateSize Method

ICompletionEditUpdateSize Method
When implemented by a class, updates size of this ICompletionEdit control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateSize()
Sub UpdateSize
void UpdateSize()
abstract UpdateSize : unit -> unit
See Also

Reference

ICompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionEdit Properties

ICompletionEdit Properties

The ICompletionEdit type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | EditBox | When implemented by a class, represents a text box allowing to edit content of the ICompletionEditcontrol.
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Label | When implemented by a class, represents a label associated with the edit ICompletionEditcontrol.
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | PathLabel | When implemented by a class, represents a path label associated with the edit ICompletionEditcontrol.
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
See Also

Reference

ICompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionEdit.EditBox Property

ICompletionEditEditBox Property
When implemented by a class, represents a text box allowing to edit content of the ICompletionEditcontrol.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TextBox EditBox { get; }
ReadOnly Property EditBox As TextBox
    Get
property TextBox^ EditBox {
    TextBox^ get ();
}
abstract EditBox : TextBox with get

Property Value

Type: TextBox
See Also

Reference

ICompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionEdit.Label Property

ICompletionEditLabel Property
When implemented by a class, represents a label associated with the edit ICompletionEditcontrol.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Label Label { get; }
ReadOnly Property Label As Label
    Get
property Label^ Label {
    Label^ get ();
}
abstract Label : Label with get

Property Value

Type: Label
See Also

Reference

ICompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionEdit.PathLabel Property

ICompletionEditPathLabel Property
When implemented by a class, represents a path label associated with the edit ICompletionEditcontrol.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Label PathLabel { get; }
ReadOnly Property PathLabel As Label
    Get
property Label^ PathLabel {
    Label^ get ();
}
abstract PathLabel : Label with get

Property Value

Type: Label
See Also

Reference

ICompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ICompletionEdit Events

ICompletionEdit Events

The ICompletionEdit type exposes the following members.

Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Top
See Also

Reference

ICompletionEdit Interface
Alternet.Editor.CodeCompletion Namespace


ListBoxVScrollBar Class

ListBoxVScrollBar Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.EditorScrollBar
VScrollBar
Alternet.Editor.CodeCompletionListBoxVScrollBar

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ListBoxVScrollBar : VScrollBar
Public Class ListBoxVScrollBar
    Inherits VScrollBar
public ref class ListBoxVScrollBar : public VScrollBar
type ListBoxVScrollBar =
    class
        inherit VScrollBar
    end

The ListBoxVScrollBar type exposes the following members.

Constructors
 | Name | Description
Public method | ListBoxVScrollBar | Initializes a new instance of the ListBoxVScrollBar class
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents the drawing of the control until EndUpdate is called. (Inherited from ScrollBar.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Ends the updating process and the control can draw itself again. (Inherited from ScrollBar.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change amount. (Inherited from ScrollBar.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox |
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value. (Inherited from ScrollBar.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum value. (Inherited from ScrollBar.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | The scrollbar Orientation - horizontal / vertical. (Inherited from ScrollBar.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Renderer | Gets or sets IScrollBarRenderer for the scrollbar. (Inherited from ScrollBar.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change amount. (Inherited from ScrollBar.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value. (Inherited from ScrollBar.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualStyle | Gets or sets visual style of the scrollbar. (Inherited from ScrollBar.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintOver | Occurs when scrollbar paints its content. (Inherited from ScrollBar.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the scrollbar scrolled. (Inherited from ScrollBar.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ListBoxVScrollBar Constructor

ListBoxVScrollBar Constructor
Initializes a new instance of the ListBoxVScrollBar class

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListBoxVScrollBar()
Public Sub New
public:
ListBoxVScrollBar()
new : unit -> ListBoxVScrollBar
See Also

Reference

ListBoxVScrollBar Class
Alternet.Editor.CodeCompletion Namespace


ListBoxVScrollBar Methods

ListBoxVScrollBar Methods

The ListBoxVScrollBar type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents the drawing of the control until EndUpdate is called. (Inherited from ScrollBar.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Ends the updating process and the control can draw itself again. (Inherited from ScrollBar.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ListBoxVScrollBar Class
Alternet.Editor.CodeCompletion Namespace


ListBoxVScrollBar Properties

ListBoxVScrollBar Properties

The ListBoxVScrollBar type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LargeChange | Gets or sets the large change amount. (Inherited from ScrollBar.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox |
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | Maximum | Gets or sets the maximum value. (Inherited from ScrollBar.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Minimum | Gets or sets the minimum value. (Inherited from ScrollBar.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | The scrollbar Orientation - horizontal / vertical. (Inherited from ScrollBar.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Renderer | Gets or sets IScrollBarRenderer for the scrollbar. (Inherited from ScrollBar.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallChange | Gets or sets the small change amount. (Inherited from ScrollBar.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Value | Gets or sets the value. (Inherited from ScrollBar.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualStyle | Gets or sets visual style of the scrollbar. (Inherited from ScrollBar.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ListBoxVScrollBar Class
Alternet.Editor.CodeCompletion Namespace


ListBoxVScrollBar.ListBox Property

ListBoxVScrollBarListBox Property

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListBoxWithAdvancedScrolling ListBox { get; set; }
Public Property ListBox As ListBoxWithAdvancedScrolling
    Get
    Set
public:
property ListBoxWithAdvancedScrolling^ ListBox {
    ListBoxWithAdvancedScrolling^ get ();
    void set (ListBoxWithAdvancedScrolling^ value);
}
member ListBox : ListBoxWithAdvancedScrolling with get, set

Property Value

Type: ListBoxWithAdvancedScrolling
See Also

Reference

ListBoxVScrollBar Class
Alternet.Editor.CodeCompletion Namespace


ListBoxVScrollBar Events

ListBoxVScrollBar Events

The ListBoxVScrollBar type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintOver | Occurs when scrollbar paints its content. (Inherited from ScrollBar.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the scrollbar scrolled. (Inherited from ScrollBar.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ListBoxVScrollBar Class
Alternet.Editor.CodeCompletion Namespace


ListBoxWithAdvancedScrolling Class

ListBoxWithAdvancedScrolling Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsListBox
Alternet.Editor.CodeCompletionListBoxWithAdvancedScrolling
Alternet.Editor.CodeCompletionCompletionListBox

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ListBoxWithAdvancedScrolling : ListBox
Public Class ListBoxWithAdvancedScrolling
    Inherits ListBox
public ref class ListBoxWithAdvancedScrolling : public ListBox
type ListBoxWithAdvancedScrolling =
    class
        inherit ListBox
    end

The ListBoxWithAdvancedScrolling type exposes the following members.

Constructors
 | Name | Description
Public method | ListBoxWithAdvancedScrolling | Initializes a new instance of the ListBoxWithAdvancedScrolling class
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | Items | Gets the items of the ListBox. (Inherited from ListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | VerticalScrollBarVisible |
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemsChanged |
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VerticalScrollChanged |
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ListBoxWithAdvancedScrolling Constructor

ListBoxWithAdvancedScrolling Constructor
Initializes a new instance of the ListBoxWithAdvancedScrolling class

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListBoxWithAdvancedScrolling()
Public Sub New
public:
ListBoxWithAdvancedScrolling()
new : unit -> ListBoxWithAdvancedScrolling
See Also

Reference

ListBoxWithAdvancedScrolling Class
Alternet.Editor.CodeCompletion Namespace


ListBoxWithAdvancedScrolling Methods

ListBoxWithAdvancedScrolling Methods

The ListBoxWithAdvancedScrolling type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ListBoxWithAdvancedScrolling Class
Alternet.Editor.CodeCompletion Namespace


ListBoxWithAdvancedScrolling Properties

ListBoxWithAdvancedScrolling Properties

The ListBoxWithAdvancedScrolling type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | Items | Gets the items of the ListBox. (Inherited from ListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | VerticalScrollBarVisible |
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ListBoxWithAdvancedScrolling Class
Alternet.Editor.CodeCompletion Namespace


ListBoxWithAdvancedScrolling.VerticalScrollBarVisible Property

ListBoxWithAdvancedScrollingVerticalScrollBarVisible Property

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool VerticalScrollBarVisible { get; set; }
Public Property VerticalScrollBarVisible As Boolean
    Get
    Set
public:
property bool VerticalScrollBarVisible {
    bool get ();
    void set (bool value);
}
member VerticalScrollBarVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ListBoxWithAdvancedScrolling Class
Alternet.Editor.CodeCompletion Namespace


ListBoxWithAdvancedScrolling Events

ListBoxWithAdvancedScrolling Events

The ListBoxWithAdvancedScrolling type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemsChanged |
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VerticalScrollChanged |
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ListBoxWithAdvancedScrolling Class
Alternet.Editor.CodeCompletion Namespace


ListBoxWithAdvancedScrolling.ItemsChanged Event

ListBoxWithAdvancedScrollingItemsChanged Event

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ItemsChanged
Public Event ItemsChanged As EventHandler
public:
 event EventHandler^ ItemsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ItemsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ListBoxWithAdvancedScrolling Class
Alternet.Editor.CodeCompletion Namespace


ListBoxWithAdvancedScrolling.VerticalScrollChanged Event

ListBoxWithAdvancedScrollingVerticalScrollChanged Event

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event ScrollEventHandler VerticalScrollChanged
Public Event VerticalScrollChanged As ScrollEventHandler
public:
 event ScrollEventHandler^ VerticalScrollChanged {
    void add (ScrollEventHandler^ value);
    void remove (ScrollEventHandler^ value);
}
member VerticalScrollChanged : IEvent<ScrollEventHandler,
    ScrollEventArgs>

Value

Type: System.Windows.FormsScrollEventHandler
See Also

Reference

ListBoxWithAdvancedScrolling Class
Alternet.Editor.CodeCompletion Namespace


ScrollableCodeCompletionBox Class

ScrollableCodeCompletionBox Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CodeCompletionCodeCompletionWindow
Alternet.Editor.CodeCompletionCodeCompletionBox
Alternet.Editor.CodeCompletionScrollableCodeCompletionBox

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScrollableCodeCompletionBox : CodeCompletionBox
Public Class ScrollableCodeCompletionBox
    Inherits CodeCompletionBox
public ref class ScrollableCodeCompletionBox : public CodeCompletionBox
type ScrollableCodeCompletionBox =
    class
        inherit CodeCompletionBox
    end

The ScrollableCodeCompletionBox type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollableCodeCompletionBox | Initializes a new instance of the ScrollableCodeCompletionBox class
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddColumn | Adds a new column to the CodeCompletionBox column collection. (Inherited from CodeCompletionBox.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CodeCompletionBox column collection. (Inherited from CodeCompletionBox.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Overrides CodeCompletionBoxContainsControl(Control).)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position in the column collection. (Inherited from CodeCompletionBox.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionBox.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionBox.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveColumnAt | Removes the column at the specified index of the column collection. (Inherited from CodeCompletionBox.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionBox content from its Provider. (Inherited from CodeCompletionBox.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDropDownCount | Resets the DropDownCount to its default value. (Inherited from CodeCompletionBox.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable to its default value. (Inherited from CodeCompletionBox.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CodeCompletionBorderColor | Gets CodeCompletionBox border color. (Inherited from CodeCompletionBox.)
Public property | CodeCompletionBorderThickness | Gets thickness of the CodeCompletionBox border. (Inherited from CodeCompletionBox.)
Public property | Columns | Represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox. (Inherited from CodeCompletionBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionEdit | Represents CodeCompletionEdit object used to display code snippets. (Inherited from CodeCompletionBox.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | CompletionHint | Represents CodeCompletion hint object used to display hints next to completion box. (Inherited from CodeCompletionBox.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | DropDownCount | Gets or sets a value that specifies maximum visible amount of the ListBox items within the control. (Inherited from CodeCompletionBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | Filter | Gets or sets filter string to filter CodeCompletionBox content. (Inherited from CodeCompletionBox.)
Public property | Filtered | Gets or sets a boolean value that indicates whether CodeCompletionBox should filter its content using Filter property. (Inherited from CodeCompletionBox.)
Public property | FilterOptions | Gets or sets rules specifying how CodeCompletionBox should filter its content. (Inherited from CodeCompletionBox.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionEdit control has an input focus. (Overrides CodeCompletionBoxIsFocused.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ScrollBar |
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | ShowTabs | Gets or sets boolean value that indicates whether codecompletion window should display additional tabs. (Inherited from CodeCompletionBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | Sorted | Gets or sets a value indicating whether the items in the CodeCompletionBox are sorted alphabetically. (Inherited from CodeCompletionBox.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectionChanged | Occurs when index specifying the currently selected item is changed. (Inherited from CodeCompletionBox.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.CodeCompletion Namespace


ScrollableCodeCompletionBox Constructor

ScrollableCodeCompletionBox Constructor
Initializes a new instance of the ScrollableCodeCompletionBox class

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScrollableCodeCompletionBox(
    Control owner
)
Public Sub New (
    owner As Control
)
public:
ScrollableCodeCompletionBox(
    Control^ owner
)
new :
        owner : Control -> ScrollableCodeCompletionBox

Parameters

owner
Type: System.Windows.FormsControl
See Also

Reference

ScrollableCodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


ScrollableCodeCompletionBox Methods

ScrollableCodeCompletionBox Methods

The ScrollableCodeCompletionBox type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddColumn | Adds a new column to the CodeCompletionBox column collection. (Inherited from CodeCompletionBox.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CodeCompletionBox column collection. (Inherited from CodeCompletionBox.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Overrides CodeCompletionBoxContainsControl(Control).)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position in the column collection. (Inherited from CodeCompletionBox.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionBox.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionBox.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveColumnAt | Removes the column at the specified index of the column collection. (Inherited from CodeCompletionBox.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionBox content from its Provider. (Inherited from CodeCompletionBox.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDropDownCount | Resets the DropDownCount to its default value. (Inherited from CodeCompletionBox.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable to its default value. (Inherited from CodeCompletionBox.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

ScrollableCodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


ScrollableCodeCompletionBox.ContainsControl Method

ScrollableCodeCompletionBoxContainsControl Method
Retrieves a value indicating whether the popup window contains the specified control.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ContainsControl(
    Control control
)
Public Overrides Function ContainsControl (
    control As Control
) As Boolean
public:
virtual bool ContainsControl(
    Control^ control
) override
abstract ContainsControl :
        control : Control -> bool
override ContainsControl :
        control : Control -> bool

Parameters

control
Type: System.Windows.FormsControl
The Control to evaluate.

Return Value

Type: Boolean
True if the popup window contains the specified control; otherwise, false.

Implements

ICodeCompletionWindowContainsControl(Control)
ICodeCompletionWindowContainsControl(Control)
See Also

Reference

ScrollableCodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


ScrollableCodeCompletionBox Properties

ScrollableCodeCompletionBox Properties

The ScrollableCodeCompletionBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CodeCompletionBorderColor | Gets CodeCompletionBox border color. (Inherited from CodeCompletionBox.)
Public property | CodeCompletionBorderThickness | Gets thickness of the CodeCompletionBox border. (Inherited from CodeCompletionBox.)
Public property | Columns | Represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox. (Inherited from CodeCompletionBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionEdit | Represents CodeCompletionEdit object used to display code snippets. (Inherited from CodeCompletionBox.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | CompletionHint | Represents CodeCompletion hint object used to display hints next to completion box. (Inherited from CodeCompletionBox.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | DropDownCount | Gets or sets a value that specifies maximum visible amount of the ListBox items within the control. (Inherited from CodeCompletionBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | Filter | Gets or sets filter string to filter CodeCompletionBox content. (Inherited from CodeCompletionBox.)
Public property | Filtered | Gets or sets a boolean value that indicates whether CodeCompletionBox should filter its content using Filter property. (Inherited from CodeCompletionBox.)
Public property | FilterOptions | Gets or sets rules specifying how CodeCompletionBox should filter its content. (Inherited from CodeCompletionBox.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionEdit control has an input focus. (Overrides CodeCompletionBoxIsFocused.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ScrollBar |
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | ShowTabs | Gets or sets boolean value that indicates whether codecompletion window should display additional tabs. (Inherited from CodeCompletionBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | Sorted | Gets or sets a value indicating whether the items in the CodeCompletionBox are sorted alphabetically. (Inherited from CodeCompletionBox.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ScrollableCodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


ScrollableCodeCompletionBox.IsFocused Property

ScrollableCodeCompletionBoxIsFocused Property
Indicates whether CodeCompletionEdit control has an input focus.

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsFocused { get; }
Public Overrides ReadOnly Property IsFocused As Boolean
    Get
public:
virtual property bool IsFocused {
    bool get () override;
}
abstract IsFocused : bool with get
override IsFocused : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionWindowIsFocused
ICodeCompletionWindowIsFocused
See Also

Reference

ScrollableCodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


ScrollableCodeCompletionBox.ScrollBar Property

ScrollableCodeCompletionBoxScrollBar Property

Namespace: Alternet.Editor.CodeCompletion
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListBoxVScrollBar ScrollBar { get; }
Public ReadOnly Property ScrollBar As ListBoxVScrollBar
    Get
public:
property ListBoxVScrollBar^ ScrollBar {
    ListBoxVScrollBar^ get ();
}
member ScrollBar : ListBoxVScrollBar with get

Property Value

Type: ListBoxVScrollBar
See Also

Reference

ScrollableCodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


ScrollableCodeCompletionBox Events

ScrollableCodeCompletionBox Events

The ScrollableCodeCompletionBox type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectionChanged | Occurs when index specifying the currently selected item is changed. (Inherited from CodeCompletionBox.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ScrollableCodeCompletionBox Class
Alternet.Editor.CodeCompletion Namespace


Alternet.Editor.Common Namespace

Alternet.Editor.Common Namespace
Classes
 | Class | Description
Public class | ColorBox | Represents a combo-box like control used to select color from drop-down list of colors.
Public class | DlgConfirmSave | Represents dialog box used to confirm saving or not source code or design content before it's closing.
Public class | DlgNewProject |
Public class | DotNetProjectExplorer | Represents methods used to explore particular project in the TreeView control.
Public class | FindResultClickEventArgs | Provides data for the FindResultClick event.
Public class | FindResults | Displays list of search results.
Public class | FormNodeData | Represents data contained in the TreeNode for the Alternet.Editor.Common.ProjectExplorer.
Public class | NavigationHistory | Represents methods to store and restore text location for navigation purposes.
Public class | ProjectExplorer | Represents methods used to explore particular project in the TreeView control.
Public class | ProjectTypes |
Public class | ScriptCodeEdit |
Public class | ScriptCodeEditStatus |
Public class | SolutionExplorer | Represents methods used to explore particular solution in the TreeView control.
Interfaces
 | Interface | Description
Public interface | IScriptEdit |
Delegates
 | Delegate | Description
Public delegate | CreateParserFunc |
Enumerations
 | Enumeration | Description
Public enumeration | FormOpenMode | Defines design or code mode for TreeNode data.


ColorBox Class

ColorBox Class
Represents a combo-box like control used to select color from drop-down list of colors.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsComboBox
Alternet.Editor.CommonColorBox

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColorBox : ComboBox, IDisposable
Public Class ColorBox
    Inherits ComboBox
    Implements IDisposable
public ref class ColorBox : public ComboBox,
    IDisposable
type ColorBox =
    class
        inherit ComboBox
        interface IDisposable
    end

The ColorBox type exposes the following members.

Constructors
 | Name | Description
Public method | ColorBox | Initializes a new instance of the ColorBox class with default settings.
Public method | ColorBox(IContainer) | Initializes a new instance of the ColorBox class with specified container.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance when items are added to the ComboBox one at a time. (Inherited from ComboBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ComboBox control after painting is suspended by the BeginUpdate method. (Inherited from ComboBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Returns the index of the first item in the ComboBox that starts with the specified string. (Inherited from ComboBox.)
Public method | FindString(String, Int32) | Returns the index of the first item in the ComboBox beyond the specified index that contains the specified string. The search is not case sensitive. (Inherited from ComboBox.)
Public method | FindStringExact(String) | Finds the first item in the combo box that matches the specified string. (Inherited from ComboBox.)
Public method | FindStringExact(String, Int32) | Finds the first item after the specified index that matches the specified string. (Inherited from ComboBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ComboBox. (Inherited from ComboBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from ComboBox.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the editable portion of the ComboBox. (Inherited from ComboBox.)
Public method | SelectAll | Selects all the text in the editable portion of the ComboBox. (Inherited from ComboBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the ComboBox control. (Inherited from ComboBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from ComboBox.)
Public property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the ComboBox. (Inherited from ComboBox.)
Public property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from ComboBox.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ComboBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ComboBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from ComboBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ComboBox. (Inherited from ComboBox.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list. (Inherited from ComboBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox. (Inherited from ComboBox.)
Public property | DropDownStyle | Gets or sets a value specifying the style of the combo box. (Inherited from ComboBox.)
Public property | DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box. (Inherited from ComboBox.)
Public property | DroppedDown | Gets or sets a value indicating whether the combo box is displaying its drop-down portion. (Inherited from ComboBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | FlatStyle | Gets or sets the appearance of the ComboBox. (Inherited from ComboBox.)
Public property | Focused | Gets a value indicating whether the ComboBox has focus. (Inherited from ComboBox.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ComboBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ComboBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the combo box. (Inherited from ComboBox.)
Public property | Items | Gets an object representing the collection of the colors contained in this ColorBox.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox. (Inherited from ComboBox.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that the GetPreferredSize(Size) method can specify. (Inherited from ComboBox.)
Public property | MaxLength | Gets or sets the number of characters a user can type into the ComboBox. (Inherited from ComboBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that the GetPreferredSize(Size) method can specify. (Inherited from ComboBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from ComboBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the preferred height of the ComboBox. (Inherited from ComboBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedColor | Gets or sets currently selected color in the ColorBox.
Public property | SelectedIndex | Gets or sets the index specifying the currently selected item. (Inherited from ComboBox.)
Public property | SelectedItem | Gets or sets currently selected item in the ComboBox. (Inherited from ComboBox.)
Public property | SelectedText | Gets or sets the text that is selected in the editable portion of a ComboBox. (Inherited from ComboBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionLength | Gets or sets the number of characters selected in the editable portion of the combo box. (Inherited from ComboBox.)
Public property | SelectionStart | Gets or sets the starting index of text selected in the combo box. (Inherited from ComboBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted. (Inherited from ComboBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Represents text associated with this control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ComboBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ComboBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | This event is not relevant for this class. (Inherited from ComboBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ComboBox changes. (Inherited from ComboBox.)
Public event | DropDown | Occurs when the drop-down portion of a ComboBox is shown. (Inherited from ComboBox.)
Public event | DropDownClosed | Occurs when the drop-down portion of the ComboBox is no longer visible. (Inherited from ComboBox.)
Public event | DropDownStyleChanged | Occurs when the DropDownStyle property has changed. (Inherited from ComboBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined. (Inherited from ComboBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | This event is not relevant to this class. (Inherited from ComboBox.)
Public event | Paint | Occurs when the ComboBox control is redrawn. (Inherited from ComboBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from ComboBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SelectionChangeCommitted | Occurs when the user changes the selected item and that change is displayed in the ComboBox. (Inherited from ComboBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TextUpdate | Occurs when the control has formatted the text, but before the text is displayed. (Inherited from ComboBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.Common Namespace


ColorBox Constructor

ColorBox Constructor
Overload List
 | Name | Description
Public method | ColorBox | Initializes a new instance of the ColorBox class with default settings.
Public method | ColorBox(IContainer) | Initializes a new instance of the ColorBox class with specified container.
Top
See Also

Reference

ColorBox Class
Alternet.Editor.Common Namespace


ColorBox Constructor

ColorBox Constructor
Initializes a new instance of the ColorBox class with default settings.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ColorBox()
Public Sub New
public:
ColorBox()
new : unit -> ColorBox
See Also

Reference

ColorBox Class
ColorBox Overload
Alternet.Editor.Common Namespace


ColorBox Constructor (IContainer)

ColorBox Constructor (IContainer)
Initializes a new instance of the ColorBox class with specified container.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ColorBox(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
ColorBox(
    IContainer^ container
)
new :
        container : IContainer -> ColorBox

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

ColorBox Class
ColorBox Overload
Alternet.Editor.Common Namespace


ColorBox Methods

ColorBox Methods

The ColorBox type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance when items are added to the ComboBox one at a time. (Inherited from ComboBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ComboBox control after painting is suspended by the BeginUpdate method. (Inherited from ComboBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Returns the index of the first item in the ComboBox that starts with the specified string. (Inherited from ComboBox.)
Public method | FindString(String, Int32) | Returns the index of the first item in the ComboBox beyond the specified index that contains the specified string. The search is not case sensitive. (Inherited from ComboBox.)
Public method | FindStringExact(String) | Finds the first item in the combo box that matches the specified string. (Inherited from ComboBox.)
Public method | FindStringExact(String, Int32) | Finds the first item after the specified index that matches the specified string. (Inherited from ComboBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ComboBox. (Inherited from ComboBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from ComboBox.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the editable portion of the ComboBox. (Inherited from ComboBox.)
Public method | SelectAll | Selects all the text in the editable portion of the ComboBox. (Inherited from ComboBox.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the ComboBox control. (Inherited from ComboBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ColorBox Class
Alternet.Editor.Common Namespace


ColorBox Properties

ColorBox Properties

The ColorBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from ComboBox.)
Public property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the ComboBox. (Inherited from ComboBox.)
Public property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from ComboBox.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ComboBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ComboBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from ComboBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ComboBox. (Inherited from ComboBox.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list. (Inherited from ComboBox.)
Public property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the ComboBox. (Inherited from ComboBox.)
Public property | DropDownStyle | Gets or sets a value specifying the style of the combo box. (Inherited from ComboBox.)
Public property | DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box. (Inherited from ComboBox.)
Public property | DroppedDown | Gets or sets a value indicating whether the combo box is displaying its drop-down portion. (Inherited from ComboBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | FlatStyle | Gets or sets the appearance of the ComboBox. (Inherited from ComboBox.)
Public property | Focused | Gets a value indicating whether the ComboBox has focus. (Inherited from ComboBox.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ComboBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ComboBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the combo box. (Inherited from ComboBox.)
Public property | Items | Gets an object representing the collection of the colors contained in this ColorBox.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox. (Inherited from ComboBox.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that the GetPreferredSize(Size) method can specify. (Inherited from ComboBox.)
Public property | MaxLength | Gets or sets the number of characters a user can type into the ComboBox. (Inherited from ComboBox.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that the GetPreferredSize(Size) method can specify. (Inherited from ComboBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from ComboBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the preferred height of the ComboBox. (Inherited from ComboBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedColor | Gets or sets currently selected color in the ColorBox.
Public property | SelectedIndex | Gets or sets the index specifying the currently selected item. (Inherited from ComboBox.)
Public property | SelectedItem | Gets or sets currently selected item in the ComboBox. (Inherited from ComboBox.)
Public property | SelectedText | Gets or sets the text that is selected in the editable portion of a ComboBox. (Inherited from ComboBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionLength | Gets or sets the number of characters selected in the editable portion of the combo box. (Inherited from ComboBox.)
Public property | SelectionStart | Gets or sets the starting index of text selected in the combo box. (Inherited from ComboBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted. (Inherited from ComboBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Represents text associated with this control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ColorBox Class
Alternet.Editor.Common Namespace


ColorBox.Items Property

ColorBoxItems Property
Gets an object representing the collection of the colors contained in this ColorBox.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComboBoxObjectCollection Items { get; }
Public ReadOnly Property Items As ComboBoxObjectCollection
    Get
public:
property ComboBoxObjectCollection^ Items {
    ComboBoxObjectCollection^ get ();
}
member Items : ComboBoxObjectCollection with get

Property Value

Type: ComboBoxObjectCollection
See Also

Reference

ColorBox Class
Alternet.Editor.Common Namespace


ColorBox.SelectedColor Property

ColorBoxSelectedColor Property
Gets or sets currently selected color in the ColorBox.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set
public:
property Color SelectedColor {
    Color get ();
    void set (Color value);
}
member SelectedColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ColorBox Class
Alternet.Editor.Common Namespace


ColorBox.Text Property

ColorBoxText Property
Represents text associated with this control.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
member Text : string with get

Property Value

Type: String
See Also

Reference

ColorBox Class
Alternet.Editor.Common Namespace


ColorBox Events

ColorBox Events

The ColorBox type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ComboBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ComboBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | This event is not relevant for this class. (Inherited from ComboBox.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ComboBox changes. (Inherited from ComboBox.)
Public event | DropDown | Occurs when the drop-down portion of a ComboBox is shown. (Inherited from ComboBox.)
Public event | DropDownClosed | Occurs when the drop-down portion of the ComboBox is no longer visible. (Inherited from ComboBox.)
Public event | DropDownStyleChanged | Occurs when the DropDownStyle property has changed. (Inherited from ComboBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs each time an owner-drawn ComboBox item needs to be drawn and when the sizes of the list items are determined. (Inherited from ComboBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | This event is not relevant to this class. (Inherited from ComboBox.)
Public event | Paint | Occurs when the ComboBox control is redrawn. (Inherited from ComboBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from ComboBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SelectionChangeCommitted | Occurs when the user changes the selected item and that change is displayed in the ComboBox. (Inherited from ComboBox.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TextUpdate | Occurs when the control has formatted the text, but before the text is displayed. (Inherited from ComboBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ColorBox Class
Alternet.Editor.Common Namespace


CreateParserFunc Delegate

CreateParserFunc Delegate

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate ILexer CreateParserFunc(
    Type type
)
Public Delegate Function CreateParserFunc (
    type As Type
) As ILexer
public delegate ILexer^ CreateParserFunc(
    Type^ type
)
type CreateParserFunc =
    delegate of
        type : Type -> ILexer

Parameters

type
Type: SystemType

Return Value

Type: ILexer
See Also

Reference

Alternet.Editor.Common Namespace


DlgConfirmSave Class

DlgConfirmSave Class
Represents dialog box used to confirm saving or not source code or design content before it's closing.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CommonDlgConfirmSave

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DlgConfirmSave : Form
Public Class DlgConfirmSave
    Inherits Form
public ref class DlgConfirmSave : public Form
type DlgConfirmSave =
    class
        inherit Form
    end

The DlgConfirmSave type exposes the following members.

Constructors
 | Name | Description
Public method | DlgConfirmSave | Initializes a new instance of the DlgConfirmSave class with default settings.
Public method | DlgConfirmSave(String, IListString) | Initializes a new instance of the DlgConfirmSave class with specified settings.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.Common Namespace


DlgConfirmSave Constructor

DlgConfirmSave Constructor
Overload List
 | Name | Description
Public method | DlgConfirmSave | Initializes a new instance of the DlgConfirmSave class with default settings.
Public method | DlgConfirmSave(String, IListString) | Initializes a new instance of the DlgConfirmSave class with specified settings.
Top
See Also

Reference

DlgConfirmSave Class
Alternet.Editor.Common Namespace


DlgConfirmSave Constructor

DlgConfirmSave Constructor
Initializes a new instance of the DlgConfirmSave class with default settings.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DlgConfirmSave()
Public Sub New
public:
DlgConfirmSave()
new : unit -> DlgConfirmSave
See Also

Reference

DlgConfirmSave Class
DlgConfirmSave Overload
Alternet.Editor.Common Namespace


DlgConfirmSave Constructor (String, IList(String))

DlgConfirmSave Constructor (String, IListString)
Initializes a new instance of the DlgConfirmSave class with specified settings.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DlgConfirmSave(
    string title,
    IList<string> unsavedFiles
)
Public Sub New (
    title As String,
    unsavedFiles As IList(Of String)
)
public:
DlgConfirmSave(
    String^ title,
    IList<String^>^ unsavedFiles
)
new :
        title : string *
        unsavedFiles : IList<string> -> DlgConfirmSave

Parameters

title
Type: SystemString
Text associated with this new instance.
unsavedFiles
Type: System.Collections.GenericIListString
List of modified files to confirm.
See Also

Reference

DlgConfirmSave Class
DlgConfirmSave Overload
Alternet.Editor.Common Namespace


DlgConfirmSave Methods

DlgConfirmSave Methods

The DlgConfirmSave type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

DlgConfirmSave Class
Alternet.Editor.Common Namespace


DlgConfirmSave Properties

DlgConfirmSave Properties

The DlgConfirmSave type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DlgConfirmSave Class
Alternet.Editor.Common Namespace


DlgConfirmSave Events

DlgConfirmSave Events

The DlgConfirmSave type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DlgConfirmSave Class
Alternet.Editor.Common Namespace


DlgNewProject Class

DlgNewProject Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CommonDlgNewProject

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DlgNewProject : Form
Public Class DlgNewProject
    Inherits Form
public ref class DlgNewProject : public Form
type DlgNewProject =
    class
        inherit Form
    end

The DlgNewProject type exposes the following members.

Constructors
 | Name | Description
Public method | DlgNewProject | Initializes a new instance of the DlgNewProject class
Public method | DlgNewProject(ProjectCreationData, String, String) | Initializes a new instance of the DlgNewProject class
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProjectData |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.Common Namespace


DlgNewProject Constructor

DlgNewProject Constructor
Overload List
 | Name | Description
Public method | DlgNewProject | Initializes a new instance of the DlgNewProject class
Public method | DlgNewProject(ProjectCreationData, String, String) | Initializes a new instance of the DlgNewProject class
Top
See Also

Reference

DlgNewProject Class
Alternet.Editor.Common Namespace


DlgNewProject Constructor

DlgNewProject Constructor
Initializes a new instance of the DlgNewProject class

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DlgNewProject()
Public Sub New
public:
DlgNewProject()
new : unit -> DlgNewProject
See Also

Reference

DlgNewProject Class
DlgNewProject Overload
Alternet.Editor.Common Namespace


DlgNewProject Constructor (ProjectCreationData, String[], String[])

DlgNewProject Constructor (ProjectCreationData, String, String)
Initializes a new instance of the DlgNewProject class

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DlgNewProject(
    ProjectCreationData projectData,
    string[] supportedLanguages,
    string[] supportedProjectTypes
)
Public Sub New (
    projectData As ProjectCreationData,
    supportedLanguages As String(),
    supportedProjectTypes As String()
)
public:
DlgNewProject(
    ProjectCreationData projectData,
    array<String^>^ supportedLanguages,
    array<String^>^ supportedProjectTypes
)
new :
        projectData : ProjectCreationData *
        supportedLanguages : string[] *
        supportedProjectTypes : string[] -> DlgNewProject

Parameters

projectData
Type: Alternet.Common.ProjectsProjectCreationData
supportedLanguages
Type: SystemString
supportedProjectTypes
Type: SystemString
See Also

Reference

DlgNewProject Class
DlgNewProject Overload
Alternet.Editor.Common Namespace


DlgNewProject Methods

DlgNewProject Methods

The DlgNewProject type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

DlgNewProject Class
Alternet.Editor.Common Namespace


DlgNewProject Properties

DlgNewProject Properties

The DlgNewProject type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ProjectData |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DlgNewProject Class
Alternet.Editor.Common Namespace


DlgNewProject.ProjectData Property

DlgNewProjectProjectData Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectCreationData ProjectData { get; }
Public ReadOnly Property ProjectData As ProjectCreationData
    Get
public:
property ProjectCreationData ProjectData {
    ProjectCreationData get ();
}
member ProjectData : ProjectCreationData with get

Property Value

Type: ProjectCreationData
See Also

Reference

DlgNewProject Class
Alternet.Editor.Common Namespace


DlgNewProject Events

DlgNewProject Events

The DlgNewProject type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DlgNewProject Class
Alternet.Editor.Common Namespace


DotNetProjectExplorer Class

DotNetProjectExplorer Class
Represents methods used to explore particular project in the TreeView control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.CommonProjectExplorer
Alternet.Editor.CommonDotNetProjectExplorer

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DotNetProjectExplorer : ProjectExplorer
Public Class DotNetProjectExplorer
    Inherits ProjectExplorer
public ref class DotNetProjectExplorer : public ProjectExplorer
type DotNetProjectExplorer =
    class
        inherit ProjectExplorer
    end

The DotNetProjectExplorer type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetProjectExplorer | Initializes a new instance of the ProjectExplorer class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given project. (Inherited from ProjectExplorer.)
Top
Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore project's content. (Inherited from ProjectExplorer.)
Top
See Also

Reference

Alternet.Editor.Common Namespace


DotNetProjectExplorer Constructor

DotNetProjectExplorer Constructor
Initializes a new instance of the ProjectExplorer class with default settings.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DotNetProjectExplorer()
Public Sub New
public:
DotNetProjectExplorer()
new : unit -> DotNetProjectExplorer
See Also

Reference

DotNetProjectExplorer Class
Alternet.Editor.Common Namespace


DotNetProjectExplorer Methods

DotNetProjectExplorer Methods

The DotNetProjectExplorer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given project. (Inherited from ProjectExplorer.)
Top
See Also

Reference

DotNetProjectExplorer Class
Alternet.Editor.Common Namespace


DotNetProjectExplorer Properties

DotNetProjectExplorer Properties

The DotNetProjectExplorer type exposes the following members.

Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore project's content. (Inherited from ProjectExplorer.)
Top
See Also

Reference

DotNetProjectExplorer Class
Alternet.Editor.Common Namespace


FindResultClickEventArgs Class

FindResultClickEventArgs Class
Provides data for the FindResultClick event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.CommonFindResultClickEventArgs

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FindResultClickEventArgs : EventArgs
Public Class FindResultClickEventArgs
    Inherits EventArgs
public ref class FindResultClickEventArgs : public EventArgs
type FindResultClickEventArgs =
    class
        inherit EventArgs
    end

The FindResultClickEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FindResultClickEventArgs | Initializes a new instance of the FindResultClickEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FileRange | Gets or sets file range in the source code related to the current element.
Top
See Also

Reference

Alternet.Editor.Common Namespace


FindResultClickEventArgs Constructor

FindResultClickEventArgs Constructor
Initializes a new instance of the FindResultClickEventArgs class

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FindResultClickEventArgs()
Public Sub New
public:
FindResultClickEventArgs()
new : unit -> FindResultClickEventArgs
See Also

Reference

FindResultClickEventArgs Class
Alternet.Editor.Common Namespace


FindResultClickEventArgs Methods

FindResultClickEventArgs Methods

The FindResultClickEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindResultClickEventArgs Class
Alternet.Editor.Common Namespace


FindResultClickEventArgs Properties

FindResultClickEventArgs Properties

The FindResultClickEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FileRange | Gets or sets file range in the source code related to the current element.
Top
See Also

Reference

FindResultClickEventArgs Class
Alternet.Editor.Common Namespace


FindResultClickEventArgs.FileRange Property

FindResultClickEventArgsFileRange Property
Gets or sets file range in the source code related to the current element.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFileRange FileRange { get; set; }
Public Property FileRange As IFileRange
    Get
    Set
public:
property IFileRange^ FileRange {
    IFileRange^ get ();
    void set (IFileRange^ value);
}
member FileRange : IFileRange with get, set

Property Value

Type: IFileRange
See Also

Reference

FindResultClickEventArgs Class
Alternet.Editor.Common Namespace


FindResults Class

FindResults Class
Displays list of search results.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Editor.CommonFindResults

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FindResults : UserControl
Public Class FindResults
    Inherits UserControl
public ref class FindResults : public UserControl
type FindResults =
    class
        inherit UserControl
    end

The FindResults type exposes the following members.

Constructors
 | Name | Description
Public method | FindResults | Initializes a new instance of the FindResults class with default settings.
Top
Methods
 | Name | Description
Public method | AddFindResult | Adds specified range to the collection of search result.
Public method | AddFindResults | Fills FindResults content from specified range list.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears list of results.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | ResultsAvailable | Gets a boolean value indicates whether the find results available.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedRange | Gets IFileRange related to the selected found result.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FindResultClick | Occurs when particular search result was clicked.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.Common Namespace


FindResults Constructor

FindResults Constructor
Initializes a new instance of the FindResults class with default settings.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FindResults()
Public Sub New
public:
FindResults()
new : unit -> FindResults
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults Methods

FindResults Methods

The FindResults type exposes the following members.

Methods
 | Name | Description
Public method | AddFindResult | Adds specified range to the collection of search result.
Public method | AddFindResults | Fills FindResults content from specified range list.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears list of results.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults.AddFindResult Method

FindResultsAddFindResult Method
Adds specified range to the collection of search result.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddFindResult(
    IFileRange range
)
Public Sub AddFindResult (
    range As IFileRange
)
public:
void AddFindResult(
    IFileRange^ range
)
member AddFindResult :
        range : IFileRange -> unit

Parameters

range
Type: Alternet.CommonIFileRange
IFileRange to add.
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults.AddFindResults Method

FindResultsAddFindResults Method
Fills FindResults content from specified range list.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddFindResults(
    IRangeList references
)
Public Sub AddFindResults (
    references As IRangeList
)
public:
void AddFindResults(
    IRangeList^ references
)
member AddFindResults :
        references : IRangeList -> unit

Parameters

references
Type: Alternet.CommonIRangeList
List of ranges contains search results.
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults.Clear Method

FindResultsClear Method
Clears list of results.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults.Localize Method

FindResultsLocalize Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults Properties

FindResults Properties

The FindResults type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | ResultsAvailable | Gets a boolean value indicates whether the find results available.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedRange | Gets IFileRange related to the selected found result.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults.ResultsAvailable Property

FindResultsResultsAvailable Property
Gets a boolean value indicates whether the find results available.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ResultsAvailable { get; }
Public ReadOnly Property ResultsAvailable As Boolean
    Get
public:
property bool ResultsAvailable {
    bool get ();
}
member ResultsAvailable : bool with get

Property Value

Type: Boolean
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults.SelectedRange Property

FindResultsSelectedRange Property
Gets IFileRange related to the selected found result.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFileRange SelectedRange { get; }
Public ReadOnly Property SelectedRange As IFileRange
    Get
public:
property IFileRange^ SelectedRange {
    IFileRange^ get ();
}
member SelectedRange : IFileRange with get

Property Value

Type: IFileRange
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults Events

FindResults Events

The FindResults type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FindResultClick | Occurs when particular search result was clicked.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FindResults.FindResultClick Event

FindResultsFindResultClick Event
Occurs when particular search result was clicked.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FindResultClickEventArgs> FindResultClick
Public Event FindResultClick As EventHandler(Of FindResultClickEventArgs)
public:
 event EventHandler<FindResultClickEventArgs^>^ FindResultClick {
    void add (EventHandler<FindResultClickEventArgs^>^ value);
    void remove (EventHandler<FindResultClickEventArgs^>^ value);
}
member FindResultClick : IEvent<EventHandler<FindResultClickEventArgs>,
    FindResultClickEventArgs>

Value

Type: SystemEventHandlerFindResultClickEventArgs
See Also

Reference

FindResults Class
Alternet.Editor.Common Namespace


FormNodeData Class

FormNodeData Class
Represents data contained in the TreeNode for the Alternet.Editor.Common.ProjectExplorer.
Inheritance Hierarchy
SystemObject
Alternet.Editor.CommonFormNodeData

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormNodeData
Public Class FormNodeData
public ref class FormNodeData
type FormNodeData =  class end

The FormNodeData type exposes the following members.

Constructors
 | Name | Description
Public method | FormNodeData | Initializes a new instance of the FormNodeData class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FileName | Gets name of the file related to the node.
Public property | FormId | Gets id of the form related to the node.
Public property | OpenMode | Gets openmode of the node.
Top
See Also

Reference

Alternet.Editor.Common Namespace


FormNodeData Constructor

FormNodeData Constructor
Initializes a new instance of the FormNodeData class with specified parameters.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormNodeData(
    string formId,
    string fileName,
    FormOpenMode openMode
)
Public Sub New (
    formId As String,
    fileName As String,
    openMode As FormOpenMode
)
public:
FormNodeData(
    String^ formId,
    String^ fileName,
    FormOpenMode openMode
)
new :
        formId : string *
        fileName : string *
        openMode : FormOpenMode -> FormNodeData

Parameters

formId
Type: SystemString
Id of the form related to the node.
fileName
Type: SystemString
Name of file related to the node.
openMode
Type: Alternet.Editor.CommonFormOpenMode
Mode of the node.
See Also

Reference

FormNodeData Class
Alternet.Editor.Common Namespace


FormNodeData Methods

FormNodeData Methods

The FormNodeData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormNodeData Class
Alternet.Editor.Common Namespace


FormNodeData Properties

FormNodeData Properties

The FormNodeData type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets name of the file related to the node.
Public property | FormId | Gets id of the form related to the node.
Public property | OpenMode | Gets openmode of the node.
Top
See Also

Reference

FormNodeData Class
Alternet.Editor.Common Namespace


FormNodeData.FileName Property

FormNodeDataFileName Property
Gets name of the file related to the node.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

FormNodeData Class
Alternet.Editor.Common Namespace


FormNodeData.FormId Property

FormNodeDataFormId Property
Gets id of the form related to the node.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FormId { get; }
Public ReadOnly Property FormId As String
    Get
public:
property String^ FormId {
    String^ get ();
}
member FormId : string with get

Property Value

Type: String
See Also

Reference

FormNodeData Class
Alternet.Editor.Common Namespace


FormNodeData.OpenMode Property

FormNodeDataOpenMode Property
Gets openmode of the node.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormOpenMode OpenMode { get; }
Public ReadOnly Property OpenMode As FormOpenMode
    Get
public:
property FormOpenMode OpenMode {
    FormOpenMode get ();
}
member OpenMode : FormOpenMode with get

Property Value

Type: FormOpenMode
See Also

Reference

FormNodeData Class
Alternet.Editor.Common Namespace


FormOpenMode Enumeration

FormOpenMode Enumeration
Defines design or code mode for TreeNode data.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FormOpenMode
Public Enumeration FormOpenMode
public enum class FormOpenMode
type FormOpenMode
Members
Member name | Value | Description
Design | 0 | Specifies design mode.
Code | 1 | Specifies code mode.
See Also

Reference

Alternet.Editor.Common Namespace


IScriptEdit Interface

IScriptEdit Interface

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptEdit : IControl
Public Interface IScriptEdit
    Inherits IControl
public interface class IScriptEdit : IControl
type IScriptEdit =
    interface
        interface IControl
    end

The IScriptEdit type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdate |
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | Copy |
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | Cut |
Public method | Delete |
Public method | DeselectAll |
Public method | EndUpdate |
Public method | Find |
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | GetLine |
Public method | GetSymbolAtCursor |
Public method | GotoLine |
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | LoadFile |
Public method | MakeVisible |
Public method | MoveLineEnd |
Public method | MoveToLine |
Public method | Paste |
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Print |
Public method | PrintPreview |
Public method | Redo |
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | Replace |
Public method | SaveFile |
Public method | Search |
Public method | SelectAll |
Public method | Undo |
Public method | UpdateSyntax |
Top
Extension Methods
 | Name | Description
Public Extension Method | CanFindDeclaration | (Defined by CodeEditExtensions.)
Public Extension Method | Document | (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindImplementations | (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterDefaultAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterNamespaces | (Defined by CodeEditExtensions.)
Public Extension Method | SetFileNameAndProject | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Top
Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanCopy |
Public property | CanCut |
Public property | CanDelete |
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | CanPaste |
Public property | CanRedo |
Public property | CanUndo |
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | CurrentChar |
Public property | CurrentLine |
Public property | DefaultMenu |
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | FileName |
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | Modified |
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | Position |
Public property | ReadOnly |
Public property | Status |
Public property | StatusText | Obsolete.
Public property | Text |
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Public event | ModifiedChanged |
Public event | ParserChanged |
Public event | StatusChanged |
Public event | TextChanged |
Top
See Also

Reference

Alternet.Editor.Common Namespace


IScriptEdit Methods

IScriptEdit Methods

The IScriptEdit type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdate |
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | Copy |
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | Cut |
Public method | Delete |
Public method | DeselectAll |
Public method | EndUpdate |
Public method | Find |
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | GetLine |
Public method | GetSymbolAtCursor |
Public method | GotoLine |
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | LoadFile |
Public method | MakeVisible |
Public method | MoveLineEnd |
Public method | MoveToLine |
Public method | Paste |
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Print |
Public method | PrintPreview |
Public method | Redo |
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | Replace |
Public method | SaveFile |
Public method | Search |
Public method | SelectAll |
Public method | Undo |
Public method | UpdateSyntax |
Top
Extension Methods
 | Name | Description
Public Extension Method | CanFindDeclaration | (Defined by CodeEditExtensions.)
Public Extension Method | Document | (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindImplementations | (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterDefaultAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterNamespaces | (Defined by CodeEditExtensions.)
Public Extension Method | SetFileNameAndProject | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Top
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.BeginUpdate Method

IScriptEditBeginUpdate Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int BeginUpdate()
Function BeginUpdate As Integer
int BeginUpdate()
abstract BeginUpdate : unit -> int

Return Value

Type: Int32
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Copy Method

IScriptEditCopy Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Copy()
Sub Copy
void Copy()
abstract Copy : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Cut Method

IScriptEditCut Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Cut()
Sub Cut
void Cut()
abstract Cut : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Delete Method

IScriptEditDelete Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Delete()
Sub Delete
void Delete()
abstract Delete : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.DeselectAll Method

IScriptEditDeselectAll Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DeselectAll()
Sub DeselectAll
void DeselectAll()
abstract DeselectAll : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.EndUpdate Method

IScriptEditEndUpdate Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int EndUpdate()
Function EndUpdate As Integer
int EndUpdate()
abstract EndUpdate : unit -> int

Return Value

Type: Int32
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Find Method

IScriptEditFind Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Find(
    string text
)
Function Find (
    text As String
) As Boolean
bool Find(
    String^ text
)
abstract Find :
        text : string -> bool

Parameters

text
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.GetLine Method

IScriptEditGetLine Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetLine(
    int index
)
Function GetLine (
    index As Integer
) As String
String^ GetLine(
    int index
)
abstract GetLine :
        index : int -> string

Parameters

index
Type: SystemInt32

Return Value

Type: String
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.GetSymbolAtCursor Method

IScriptEditGetSymbolAtCursor Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetSymbolAtCursor()
Function GetSymbolAtCursor As String
String^ GetSymbolAtCursor()
abstract GetSymbolAtCursor : unit -> string

Return Value

Type: String
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.GotoLine Method

IScriptEditGotoLine Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GotoLine()
Sub GotoLine
void GotoLine()
abstract GotoLine : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.LoadFile Method

IScriptEditLoadFile Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadFile(
    string fileName
)
Sub LoadFile (
    fileName As String
)
void LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.MakeVisible Method

IScriptEditMakeVisible Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MakeVisible(
    Point position,
    bool centerLine
)
Sub MakeVisible (
    position As Point,
    centerLine As Boolean
)
void MakeVisible(
    Point position,
    bool centerLine
)
abstract MakeVisible :
        position : Point *
        centerLine : bool -> unit

Parameters

position
Type: System.DrawingPoint
centerLine
Type: SystemBoolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.MoveLineEnd Method

IScriptEditMoveLineEnd Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveLineEnd()
Sub MoveLineEnd
void MoveLineEnd()
abstract MoveLineEnd : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.MoveToLine Method

IScriptEditMoveToLine Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveToLine(
    int y
)
Sub MoveToLine (
    y As Integer
)
void MoveToLine(
    int y
)
abstract MoveToLine :
        y : int -> unit

Parameters

y
Type: SystemInt32
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Paste Method

IScriptEditPaste Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Paste()
Sub Paste
void Paste()
abstract Paste : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Print Method

IScriptEditPrint Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Print()
Sub Print
void Print()
abstract Print : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.PrintPreview Method

IScriptEditPrintPreview Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PrintPreview()
Sub PrintPreview
void PrintPreview()
abstract PrintPreview : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Redo Method

IScriptEditRedo Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Redo()
Sub Redo
void Redo()
abstract Redo : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Replace Method

IScriptEditReplace Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Replace()
Sub Replace
void Replace()
abstract Replace : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.SaveFile Method

IScriptEditSaveFile Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SaveFile(
    string fileName
)
Sub SaveFile (
    fileName As String
)
void SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Search Method

IScriptEditSearch Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Search()
Sub Search
void Search()
abstract Search : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.SelectAll Method

IScriptEditSelectAll Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectAll()
Sub SelectAll
void SelectAll()
abstract SelectAll : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Undo Method

IScriptEditUndo Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Undo()
Sub Undo
void Undo()
abstract Undo : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.UpdateSyntax Method

IScriptEditUpdateSyntax Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UpdateSyntax()
Sub UpdateSyntax
void UpdateSyntax()
abstract UpdateSyntax : unit -> unit
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit Properties

IScriptEdit Properties

The IScriptEdit type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanCopy |
Public property | CanCut |
Public property | CanDelete |
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | CanPaste |
Public property | CanRedo |
Public property | CanUndo |
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | CurrentChar |
Public property | CurrentLine |
Public property | DefaultMenu |
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | FileName |
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | Modified |
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | Position |
Public property | ReadOnly |
Public property | Status |
Public property | StatusText | Obsolete.
Public property | Text |
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.CanCopy Property

IScriptEditCanCopy Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCopy { get; }
ReadOnly Property CanCopy As Boolean
    Get
property bool CanCopy {
    bool get ();
}
abstract CanCopy : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.CanCut Property

IScriptEditCanCut Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCut { get; }
ReadOnly Property CanCut As Boolean
    Get
property bool CanCut {
    bool get ();
}
abstract CanCut : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.CanDelete Property

IScriptEditCanDelete Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanDelete { get; }
ReadOnly Property CanDelete As Boolean
    Get
property bool CanDelete {
    bool get ();
}
abstract CanDelete : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.CanPaste Property

IScriptEditCanPaste Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanPaste { get; }
ReadOnly Property CanPaste As Boolean
    Get
property bool CanPaste {
    bool get ();
}
abstract CanPaste : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.CanRedo Property

IScriptEditCanRedo Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanRedo { get; }
ReadOnly Property CanRedo As Boolean
    Get
property bool CanRedo {
    bool get ();
}
abstract CanRedo : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.CanUndo Property

IScriptEditCanUndo Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanUndo { get; }
ReadOnly Property CanUndo As Boolean
    Get
property bool CanUndo {
    bool get ();
}
abstract CanUndo : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.CurrentChar Property

IScriptEditCurrentChar Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int CurrentChar { get; }
ReadOnly Property CurrentChar As Integer
    Get
property int CurrentChar {
    int get ();
}
abstract CurrentChar : int with get

Property Value

Type: Int32
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.CurrentLine Property

IScriptEditCurrentLine Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int CurrentLine { get; }
ReadOnly Property CurrentLine As Integer
    Get
property int CurrentLine {
    int get ();
}
abstract CurrentLine : int with get

Property Value

Type: Int32
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.DefaultMenu Property

IScriptEditDefaultMenu Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ContextMenuStrip DefaultMenu { get; }
ReadOnly Property DefaultMenu As ContextMenuStrip
    Get
property ContextMenuStrip^ DefaultMenu {
    ContextMenuStrip^ get ();
}
abstract DefaultMenu : ContextMenuStrip with get

Property Value

Type: ContextMenuStrip
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.FileName Property

IScriptEditFileName Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Modified Property

IScriptEditModified Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Modified { get; }
ReadOnly Property Modified As Boolean
    Get
property bool Modified {
    bool get ();
}
abstract Modified : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Position Property

IScriptEditPosition Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Position { get; set; }
Property Position As Point
    Get
    Set
property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set

Property Value

Type: Point
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.ReadOnly Property

IScriptEditReadOnly Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReadOnly { get; set; }
Property ReadOnly As Boolean
    Get
    Set
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
abstract ReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Status Property

IScriptEditStatus Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptCodeEditStatus Status { get; }
ReadOnly Property Status As ScriptCodeEditStatus
    Get
property ScriptCodeEditStatus^ Status {
    ScriptCodeEditStatus^ get ();
}
abstract Status : ScriptCodeEditStatus with get

Property Value

Type: ScriptCodeEditStatus
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.StatusText Property

IScriptEditStatusText Property

Note: This API is now obsolete.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Status instead.")]
string[] StatusText { get; }
<ObsoleteAttribute("Use Status instead.")>
ReadOnly Property StatusText As String()
    Get
[ObsoleteAttribute(L"Use Status instead.")]
property array<String^>^ StatusText {
    array<String^>^ get ();
}
[<ObsoleteAttribute("Use Status instead.")>]
abstract StatusText : string[] with get

Property Value

Type: String
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.Text Property

IScriptEditText Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit Events

IScriptEdit Events

The IScriptEdit type exposes the following members.

Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Public event | ModifiedChanged |
Public event | ParserChanged |
Public event | StatusChanged |
Public event | TextChanged |
Top
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.ModifiedChanged Event

IScriptEditModifiedChanged Event

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ModifiedChanged
Event ModifiedChanged As EventHandler
 event EventHandler^ ModifiedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ModifiedChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.ParserChanged Event

IScriptEditParserChanged Event

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ParserChanged
Event ParserChanged As EventHandler
 event EventHandler^ ParserChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ParserChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.StatusChanged Event

IScriptEditStatusChanged Event

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler StatusChanged
Event StatusChanged As EventHandler
 event EventHandler^ StatusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract StatusChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


IScriptEdit.TextChanged Event

IScriptEditTextChanged Event

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler TextChanged
Event TextChanged As EventHandler
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptEdit Interface
Alternet.Editor.Common Namespace


NavigationHistory Class

NavigationHistory Class
Represents methods to store and restore text location for navigation purposes.
Inheritance Hierarchy
SystemObject
Alternet.Editor.CommonNavigationHistory

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NavigationHistory
Public Class NavigationHistory
public ref class NavigationHistory
type NavigationHistory =  class end

The NavigationHistory type exposes the following members.

Constructors
 | Name | Description
Public method | NavigationHistory | Initializes a new instance of the NavigationHistory class
Top
Methods
 | Name | Description
Public method | AddToHistory | Adds specified location to the history collection.
Public method | BeginUpdate | Prevents navigation history updating until calling EndUpdate method.
Public method | ClearCurrentHistory | Clears only forward part of the navigation history and updates all related visual controls.
Public method | ClearHistory | Clears navigation history and updates all related visual controls.
Public method | EndUpdate | When implemented by a class, re-enables navigation history updating turned off by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNextHistory | Moves to the next location in the stored history collection.
Public method | GetPrevHistory | Moves to the previous location in the stored history collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SaveCurrentLocationToHistory | Adds specified location to the history collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateHistory(ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem) | Updates visual history elements accordingly the new history index.
Public method | UpdateHistory(ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem, Boolean) | Updates visual history elements accordingly the new history index.
Top
See Also

Reference

Alternet.Editor.Common Namespace


NavigationHistory Constructor

NavigationHistory Constructor
Initializes a new instance of the NavigationHistory class

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NavigationHistory()
Public Sub New
public:
NavigationHistory()
new : unit -> NavigationHistory
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory Methods

NavigationHistory Methods

The NavigationHistory type exposes the following members.

Methods
 | Name | Description
Public method | AddToHistory | Adds specified location to the history collection.
Public method | BeginUpdate | Prevents navigation history updating until calling EndUpdate method.
Public method | ClearCurrentHistory | Clears only forward part of the navigation history and updates all related visual controls.
Public method | ClearHistory | Clears navigation history and updates all related visual controls.
Public method | EndUpdate | When implemented by a class, re-enables navigation history updating turned off by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNextHistory | Moves to the next location in the stored history collection.
Public method | GetPrevHistory | Moves to the previous location in the stored history collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SaveCurrentLocationToHistory | Adds specified location to the history collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateHistory(ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem) | Updates visual history elements accordingly the new history index.
Public method | UpdateHistory(ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem, Boolean) | Updates visual history elements accordingly the new history index.
Top
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.AddToHistory Method

NavigationHistoryAddToHistory Method
Adds specified location to the history collection.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddToHistory(
    SymbolLocation location,
    string text
)
Public Sub AddToHistory (
    location As SymbolLocation,
    text As String
)
public:
void AddToHistory(
    SymbolLocation^ location,
    String^ text
)
member AddToHistory :
        location : SymbolLocation *
        text : string -> unit

Parameters

location
Type: Alternet.CommonSymbolLocation
SymbolLocation to add.
text
Type: SystemString
Text in the code at specified location.
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.BeginUpdate Method

NavigationHistoryBeginUpdate Method
Prevents navigation history updating until calling EndUpdate method.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BeginUpdate()
Public Function BeginUpdate As Integer
public:
int BeginUpdate()
member BeginUpdate : unit -> int

Return Value

Type: Int32
Number of history updating locks.
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.ClearCurrentHistory Method

NavigationHistoryClearCurrentHistory Method
Clears only forward part of the navigation history and updates all related visual controls.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearCurrentHistory(
    ToolStripItemCollection items,
    ToolStripItem backward,
    ToolStripItem forward
)
Public Sub ClearCurrentHistory (
    items As ToolStripItemCollection,
    backward As ToolStripItem,
    forward As ToolStripItem
)
public:
void ClearCurrentHistory(
    ToolStripItemCollection^ items,
    ToolStripItem^ backward,
    ToolStripItem^ forward
)
member ClearCurrentHistory :
        items : ToolStripItemCollection *
        backward : ToolStripItem *
        forward : ToolStripItem -> unit

Parameters

items
Type: System.Windows.FormsToolStripItemCollection
List of items to be updated accordingly to the history collection.
backward
Type: System.Windows.FormsToolStripItem
Visual element related to the backward navigation.
forward
Type: System.Windows.FormsToolStripItem
Visual element related to the forward navigation.
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.ClearHistory Method

NavigationHistoryClearHistory Method
Clears navigation history and updates all related visual controls.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearHistory(
    ToolStripItemCollection items,
    ToolStripItem backward,
    ToolStripItem forward
)
Public Sub ClearHistory (
    items As ToolStripItemCollection,
    backward As ToolStripItem,
    forward As ToolStripItem
)
public:
void ClearHistory(
    ToolStripItemCollection^ items,
    ToolStripItem^ backward,
    ToolStripItem^ forward
)
member ClearHistory :
        items : ToolStripItemCollection *
        backward : ToolStripItem *
        forward : ToolStripItem -> unit

Parameters

items
Type: System.Windows.FormsToolStripItemCollection
List of items to be updated accordingly to the history collection.
backward
Type: System.Windows.FormsToolStripItem
Visual element related to the backward navigation.
forward
Type: System.Windows.FormsToolStripItem
Visual element related to the forward navigation.
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.EndUpdate Method

NavigationHistoryEndUpdate Method
When implemented by a class, re-enables navigation history updating turned off by calling BeginUpdate method.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndUpdate()
Public Function EndUpdate As Integer
public:
int EndUpdate()
member EndUpdate : unit -> int

Return Value

Type: Int32
Number of history updating locks.
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.GetNextHistory Method

NavigationHistoryGetNextHistory Method
Moves to the next location in the stored history collection.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNextHistory(
    ref KeyValuePair<string, SymbolLocation> pair
)
Public Function GetNextHistory (
    ByRef pair As KeyValuePair(Of String, SymbolLocation)
) As Integer
public:
int GetNextHistory(
    KeyValuePair<String^, SymbolLocation^>% pair
)
member GetNextHistory :
        pair : KeyValuePair<string, SymbolLocation> byref -> int

Parameters

pair
Type: System.Collections.GenericKeyValuePairString, SymbolLocation
Receives location information.

Return Value

Type: Int32
Index of the current location information in the collection.
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.GetPrevHistory Method

NavigationHistoryGetPrevHistory Method
Moves to the previous location in the stored history collection.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPrevHistory(
    ref KeyValuePair<string, SymbolLocation> pair
)
Public Function GetPrevHistory (
    ByRef pair As KeyValuePair(Of String, SymbolLocation)
) As Integer
public:
int GetPrevHistory(
    KeyValuePair<String^, SymbolLocation^>% pair
)
member GetPrevHistory :
        pair : KeyValuePair<string, SymbolLocation> byref -> int

Parameters

pair
Type: System.Collections.GenericKeyValuePairString, SymbolLocation
Receives location information.

Return Value

Type: Int32
Index of the current location information in the collection.
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.SaveCurrentLocationToHistory Method

NavigationHistorySaveCurrentLocationToHistory Method
Adds specified location to the history collection.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveCurrentLocationToHistory(
    Point position,
    string fileName,
    string code
)
Public Sub SaveCurrentLocationToHistory (
    position As Point,
    fileName As String,
    code As String
)
public:
void SaveCurrentLocationToHistory(
    Point position,
    String^ fileName,
    String^ code
)
member SaveCurrentLocationToHistory :
        position : Point *
        fileName : string *
        code : string -> unit

Parameters

position
Type: System.DrawingPoint
Position in the code to add.
fileName
Type: SystemString
Name of file where code is located.
code
Type: SystemString
Text in the code at specified location.
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.UpdateHistory Method

NavigationHistoryUpdateHistory Method
Overload List
 | Name | Description
Public method | UpdateHistory(ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem) | Updates visual history elements accordingly the new history index.
Public method | UpdateHistory(ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem, Boolean) | Updates visual history elements accordingly the new history index.
Top
See Also

Reference

NavigationHistory Class
Alternet.Editor.Common Namespace


NavigationHistory.UpdateHistory Method (ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem)

NavigationHistoryUpdateHistory Method (ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem)
Updates visual history elements accordingly the new history index.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateHistory(
    ToolStripItemCollection items,
    int newIndex,
    ToolStripItem backward,
    ToolStripItem forward
)
Public Sub UpdateHistory (
    items As ToolStripItemCollection,
    newIndex As Integer,
    backward As ToolStripItem,
    forward As ToolStripItem
)
public:
void UpdateHistory(
    ToolStripItemCollection^ items,
    int newIndex,
    ToolStripItem^ backward,
    ToolStripItem^ forward
)
member UpdateHistory :
        items : ToolStripItemCollection *
        newIndex : int *
        backward : ToolStripItem *
        forward : ToolStripItem -> unit

Parameters

items
Type: System.Windows.FormsToolStripItemCollection
List of items to be updated accordingly to the history collection.
newIndex
Type: SystemInt32
New current history index.
backward
Type: System.Windows.FormsToolStripItem
Visual element related to the backward navigation.
forward
Type: System.Windows.FormsToolStripItem
Visual element related to the forward navigation.
See Also

Reference

NavigationHistory Class
UpdateHistory Overload
Alternet.Editor.Common Namespace


NavigationHistory.UpdateHistory Method (ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem, Boolean)

NavigationHistoryUpdateHistory Method (ToolStripItemCollection, Int32, ToolStripItem, ToolStripItem, Boolean)
Updates visual history elements accordingly the new history index.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateHistory(
    ToolStripItemCollection items,
    int newIndex,
    ToolStripItem backward,
    ToolStripItem forward,
    bool relative
)
Public Sub UpdateHistory (
    items As ToolStripItemCollection,
    newIndex As Integer,
    backward As ToolStripItem,
    forward As ToolStripItem,
    relative As Boolean
)
public:
void UpdateHistory(
    ToolStripItemCollection^ items,
    int newIndex,
    ToolStripItem^ backward,
    ToolStripItem^ forward,
    bool relative
)
member UpdateHistory :
        items : ToolStripItemCollection *
        newIndex : int *
        backward : ToolStripItem *
        forward : ToolStripItem *
        relative : bool -> unit

Parameters

items
Type: System.Windows.FormsToolStripItemCollection
List of items to be updated accordingly to the history collection.
newIndex
Type: SystemInt32
New current history index.
backward
Type: System.Windows.FormsToolStripItem
Visual element related to the backward navigation.
forward
Type: System.Windows.FormsToolStripItem
Visual element related to the forward navigation.
relative
Type: SystemBoolean
True if visual controls should display only part of the history list.
See Also

Reference

NavigationHistory Class
UpdateHistory Overload
Alternet.Editor.Common Namespace


ProjectExplorer Class

ProjectExplorer Class
Represents methods used to explore particular project in the TreeView control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.CommonProjectExplorer
Alternet.Editor.CommonDotNetProjectExplorer
Alternet.Editor.TypeScriptTSProjectExplorer

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProjectExplorer
Public Class ProjectExplorer
public ref class ProjectExplorer
type ProjectExplorer =  class end

The ProjectExplorer type exposes the following members.

Constructors
 | Name | Description
Public method | ProjectExplorer | Initializes a new instance of the ProjectExplorer class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetFileNameFromNode |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsFolderNode |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given project.
Top
Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore project's content.
Top
See Also

Reference

Alternet.Editor.Common Namespace


ProjectExplorer Constructor

ProjectExplorer Constructor
Initializes a new instance of the ProjectExplorer class with default settings.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectExplorer()
Public Sub New
public:
ProjectExplorer()
new : unit -> ProjectExplorer
See Also

Reference

ProjectExplorer Class
Alternet.Editor.Common Namespace


ProjectExplorer Methods

ProjectExplorer Methods

The ProjectExplorer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetFileNameFromNode |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsFolderNode |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given project.
Top
See Also

Reference

ProjectExplorer Class
Alternet.Editor.Common Namespace


ProjectExplorer.GetFileNameFromNode Method

ProjectExplorerGetFileNameFromNode Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFileNameFromNode(
    TreeNode node
)
Public Shared Function GetFileNameFromNode (
    node As TreeNode
) As String
public:
static String^ GetFileNameFromNode(
    TreeNode^ node
)
static member GetFileNameFromNode :
        node : TreeNode -> string

Parameters

node
Type: System.Windows.FormsTreeNode

Return Value

Type: String
See Also

Reference

ProjectExplorer Class
Alternet.Editor.Common Namespace


ProjectExplorer.IsFolderNode Method

ProjectExplorerIsFolderNode Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsFolderNode(
    TreeNode node
)
Public Shared Function IsFolderNode (
    node As TreeNode
) As Boolean
public:
static bool IsFolderNode(
    TreeNode^ node
)
static member IsFolderNode :
        node : TreeNode -> bool

Parameters

node
Type: System.Windows.FormsTreeNode

Return Value

Type: Boolean
See Also

Reference

ProjectExplorer Class
Alternet.Editor.Common Namespace


ProjectExplorer.UpdateExplorer Method

ProjectExplorerUpdateExplorer Method
Updates explorer content from given project.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateExplorer(
    Project project
)
Public Overridable Sub UpdateExplorer (
    project As Project
)
public:
virtual void UpdateExplorer(
    Project^ project
)
abstract UpdateExplorer :
        project : Project -> unit
override UpdateExplorer :
        project : Project -> unit

Parameters

project
Type: Alternet.Common.ProjectsProject
Project to explore.
See Also

Reference

ProjectExplorer Class
Alternet.Editor.Common Namespace


ProjectExplorer Properties

ProjectExplorer Properties

The ProjectExplorer type exposes the following members.

Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore project's content.
Top
See Also

Reference

ProjectExplorer Class
Alternet.Editor.Common Namespace


ProjectExplorer.ExplorerTree Property

ProjectExplorerExplorerTree Property
Gets or sets System.Windows.Forms.TreeView control used to explore project's content.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeView ExplorerTree { get; set; }
Public Property ExplorerTree As TreeView
    Get
    Set
public:
property TreeView^ ExplorerTree {
    TreeView^ get ();
    void set (TreeView^ value);
}
member ExplorerTree : TreeView with get, set

Property Value

Type: TreeView
See Also

Reference

ProjectExplorer Class
Alternet.Editor.Common Namespace


ProjectTypes Class

ProjectTypes Class
Inheritance Hierarchy
SystemObject
Alternet.Editor.CommonProjectTypes

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ProjectTypes
Public NotInheritable Class ProjectTypes
public ref class ProjectTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ProjectTypes =  class end

The ProjectTypes type exposes the following members.

Fields
Name | Description
ProjectItems |
SupportedLanguages |
SupportedProjectTypes |
Top
See Also

Reference

Alternet.Editor.Common Namespace


ProjectTypes Fields

ProjectTypes Fields

The ProjectTypes type exposes the following members.

Fields
Name | Description
ProjectItems |
SupportedLanguages |
SupportedProjectTypes |
Top
See Also

Reference

ProjectTypes Class
Alternet.Editor.Common Namespace


ProjectTypes.ProjectItems Field

ProjectTypesProjectItems Field

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ProjectCreationData[] ProjectItems
Public Shared ProjectItems As ProjectCreationData()
public:
static array<ProjectCreationData>^ ProjectItems
static val mutable ProjectItems: ProjectCreationData[]

Field Value

Type: ProjectCreationData
See Also

Reference

ProjectTypes Class
Alternet.Editor.Common Namespace


ProjectTypes.SupportedLanguages Field

ProjectTypesSupportedLanguages Field

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] SupportedLanguages
Public Shared SupportedLanguages As String()
public:
static array<String^>^ SupportedLanguages
static val mutable SupportedLanguages: string[]

Field Value

Type: String
See Also

Reference

ProjectTypes Class
Alternet.Editor.Common Namespace


ProjectTypes.SupportedProjectTypes Field

ProjectTypesSupportedProjectTypes Field

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] SupportedProjectTypes
Public Shared SupportedProjectTypes As String()
public:
static array<String^>^ SupportedProjectTypes
static val mutable SupportedProjectTypes: string[]

Field Value

Type: String
See Also

Reference

ProjectTypes Class
Alternet.Editor.Common Namespace


ScriptCodeEdit Class

ScriptCodeEdit Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.EditorSyntaxEdit
Alternet.Editor.CommonScriptCodeEdit
Alternet.Scripter.IntegrationDebugCodeEdit

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptCodeEdit : SyntaxEdit,
    IScriptEdit, IControl
Public Class ScriptCodeEdit
    Inherits SyntaxEdit
    Implements IScriptEdit, IControl
public ref class ScriptCodeEdit : public SyntaxEdit,
    IScriptEdit, IControl
type ScriptCodeEdit =
    class
        inherit SyntaxEdit
        interface IScriptEdit
        interface IControl
    end

The ScriptCodeEdit type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptCodeEdit | Initializes a new instance of the ScriptCodeEdit class
Top
Methods
Name | Description
Public method ApplyTheme
Applies visual theme to the SyntaxEdit control.
(Inherited from SyntaxEdit.)
Public method Assign
Assigns most relevant properties from another ISyntaxEdit object.
(Inherited from SyntaxEdit.)
Public method BeginInvoke(Delegate)
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginInvoke(Delegate, Object)
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginUpdate
Prevents editor updating until calling EndUpdate method.
(Inherited from SyntaxEdit.)
Public method BreakLine
Breaks current line into two lines.
(Inherited from SyntaxEdit.)
Public method BringToFront
Brings the control to the front of the z-order.
(Inherited from Control.)
Public method CanFindNext
Indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindNextSelected
Indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindPrevious
Indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindPreviousSelected
Indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanSearchSelection
Returns whether search can be performed inside selection.
(Inherited from SyntaxEdit.)
Public method CanSplitHorz
Indicates whether control can split its content horizontally.
(Inherited from SyntaxEdit.)
Public method CanSplitVert
Indicates whether control can split its content vertically.
(Inherited from SyntaxEdit.)
Public method CanUnsplitHorz
Indicates whether control has horizontal split view.
(Inherited from SyntaxEdit.)
Public method CanUnsplitVert
Indicates whether control has vertical split view.
(Inherited from SyntaxEdit.)
Public method CodeCompletion
Performs code completion for the specified text representing language element.
(Inherited from SyntaxEdit.)
Public method CodeCompletionWindowFocused
Indicates whether ICodeCompletionWindow has focus.
(Inherited from SyntaxEdit.)
Public method CodeSnippets
Displays a code completion window with list of available code snippets.
(Inherited from SyntaxEdit.)
Public method CompleteCodeFixes
Displays a code completion window with list of available code fixes.
(Inherited from SyntaxEdit.)
Public method CompleteCodeFixesOrRefactors
Displays a code completion window with list of available code fixes or code refactors.
(Inherited from SyntaxEdit.)
Public method CompleteCodeRefactors
Displays a code completion window with list of available code refactors.
(Inherited from SyntaxEdit.)
Public method CompleteWord
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box and locates single member, if possible.
(Inherited from SyntaxEdit.)
Public method Contains
Retrieves a value indicating whether the specified control is a child of the control.
(Inherited from Control.)
Public method | Copy
Public method CreateCaret
Creates a new shape for the system caret and gets ownership of the caret.
(Inherited from SyntaxEdit.)
Public method CreateControl
Forces the creation of the visible control, including the creation of the handle and any visible child controls.
(Inherited from Control.)
Public method CreateGraphics
Creates the Graphics for the control.
(Inherited from Control.)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method | Cut
Public method CycledSearch
Performs cycled search.
(Inherited from SyntaxEdit.)
Public method | Delete
Public method DeleteBlock
Deletes a specified block of characters.
(Inherited from SyntaxEdit.)
Public method DeleteLeft
Deletes a specified number of characters to the left of the active point.
(Inherited from SyntaxEdit.)
Public method DeleteRight
Deletes a specified number of characters to the right of the active point.
(Inherited from SyntaxEdit.)
Public method | DeselectAll
Public method DestroyCaret
Destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
(Inherited from SyntaxEdit.)
Public method DisablePositionUpdate
Prevents notification of changing of caret position until calling EnablePositionUpdate method.
(Inherited from SyntaxEdit.)
Public method DisableUpdate
Prevents editor updating until calling EnableUpdate method.
(Inherited from SyntaxEdit.)
Public method DisplayDragCaret
Displays dragging caret rather than regular caret.
(Inherited from SyntaxEdit.)
Public method DisplayGotoLineDialog
Initializes and runs a dialog prompting you for index of the line you need to locate.
(Inherited from SyntaxEdit.)
Public method DisplayGotoLineDialog(IWin32Window)
Initializes and runs a dialog prompting you for index of the line you need to locate.
(Inherited from SyntaxEdit.)
Public method DisplayModalReplaceDialog
Initializes and runs a modal dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayModalReplaceDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayModalSearchDialog
Initializes and runs a modal dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayModalSearchDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayReplaceDialog
Initializes and runs a dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayReplaceDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplaySearchDialog
Initializes and runs a dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplaySearchDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayToScreen(Int32, Int32)
Converts given display coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method DisplayToScreen(Int32, Int32, Boolean)
Converts given display coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method Dispose
Releases all resources used by the Component.
(Inherited from Component.)
Public method DoDragDrop
Begins a drag-and-drop operation.
(Inherited from Control.)
Public method DrawToBitmap
Supports rendering to the specified bitmap.
(Inherited from Control.)
Public method EnablePositionUpdate
Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
(Inherited from SyntaxEdit.)
Public method EnableUpdate
Re-enables editor updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from SyntaxEdit.)
Public method EndInvoke
Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
(Inherited from Control.)
Public method EndUpdate
Re-enables outline editor updating, that was turn of by calling BeginUpdate method.
(Inherited from SyntaxEdit.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method Find(String)
Searches for given text within the control's contents.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions)
Searches for given text within the control's contents with specified options.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex)
Searches for given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, IListIRange)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, Boolean, Boolean)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, Point, Int32, Match)
Searches for given text within the control's text content.
(Inherited from SyntaxEdit.)
Public method FindForm
Retrieves the form that the control is on.
(Inherited from Control.)
Public method FindNext
Searches for the next occurrence of the text specified by previous search.
(Inherited from SyntaxEdit.)
Public method FindNextSelected
Searches for the next occurrence of the selected text.
(Inherited from SyntaxEdit.)
Public method FindPrevious
Searches for the previous occurrence of the text specified by previous search.
(Inherited from SyntaxEdit.)
Public method FindPreviousSelected
Searches for the previous occurrence of the selected text.
(Inherited from SyntaxEdit.)
Public method FinishIncrementalSearch
Leaves control from the incremental search state.
(Inherited from SyntaxEdit.)
Public method Focus
Sets input focus to the control.
(Inherited from Control.)
Public method GetCaretSize
Returns size of the caret's current shape at given position.
(Inherited from SyntaxEdit.)
Public method GetCharsInWidth
Returns number of characters painted with current font that will fit into specified Width.
(Inherited from SyntaxEdit.)
Public method GetChildAtPoint(Point)
Retrieves the child control that is located at the specified coordinates.
(Inherited from Control.)
Public method GetChildAtPoint(Point, GetChildAtPointSkip)
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
(Inherited from Control.)
Public method GetContainerControl
Returns the next ContainerControl up the control's chain of parent controls.
(Inherited from Control.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetHitTest(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTest(Int32, Int32, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTestAtTextPoint(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of control at specified text coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo)
Retrieves information about part of control at specified text coordinate.
(Inherited from SyntaxEdit.)
Public method GetIndentString
Gets indentation string at current position.
(Inherited from SyntaxEdit.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | GetLine
Public method GetLinesInHeight
Determines how many lines can fit into given Height.
(Inherited from SyntaxEdit.)
Public method GetNextControl
Retrieves the next control forward or back in the tab order of child controls.
(Inherited from Control.)
Public method GetPreferredSize
Retrieves the size of a rectangular area into which a control can be fitted.
(Inherited from Control.)
Public method | GetSymbolAtCursor
Public method GetTextAtCursor
Returns word at the cursor position.
(Inherited from SyntaxEdit.)
Public method GetTextToSearchAtCursor
Returns word at the cursor position.
(Inherited from SyntaxEdit.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetWordAt
Checks word accordingly to specified conditions.
(Inherited from SyntaxEdit.)
Public method GetWrapMargin
Returns position of the wrapping margin.
(Inherited from SyntaxEdit.)
Public method | GotoLine
Public method HasAutoCorrection
Checks whether specified word has correction.
(Inherited from SyntaxEdit.)
Public method Hide
Conceals the control from the user.
(Inherited from Control.)
Public method HideDragCaret
Hides dragging caret.
(Inherited from SyntaxEdit.)
Public method HideScrollHint
Hides scroll hint window if necessary.
(Inherited from SyntaxEdit.)
Public method HighlightAll
Highlights all occurrences of specified string in the class text content.
(Inherited from SyntaxEdit.)
Public method IncrementalSearch
Finds given text incrementally.
(Inherited from SyntaxEdit.)
Public method IndentLine
Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
(Inherited from SyntaxEdit.)
Public method IndentLine(String, Boolean)
Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
(Inherited from SyntaxEdit.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method Insert
Inserts the given string at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean)
Inserts the given string at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean)
Inserts the given string array at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(ITextStrings, Boolean)
Inserts the given string collection at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertFromFile
Inserts the file text content at the specified location.
(Inherited from SyntaxEdit.)
Public method Invalidate
Invalidates the entire surface of the control and causes the control to be redrawn.
(Inherited from Control.)
Public method Invalidate(Region)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Boolean)
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Region, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invoke(Delegate)
Executes the specified delegate on the thread that owns the control's underlying window handle.
(Inherited from Control.)
Public method Invoke(Delegate, Object)
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
(Inherited from Control.)
Public method IsValidText
Indicates whether text at the specified position is valid (that is does not contain comments or string constants).
(Inherited from SyntaxEdit.)
Public method KillFocus
Ensure the caret is not visible.
(Inherited from SyntaxEdit.)
Public method LineIsHidden
Determines whether the given line is hidden.
(Inherited from SyntaxEdit.)
Public method LineIsReadonly
Determines whether the given line is readonly.
(Inherited from SyntaxEdit.)
Public method ListMembers
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box.
(Inherited from SyntaxEdit.)
Public method | LoadFile(String)
Public method LoadFile(String, IStringImport)
Loads content from the given file with specified importer.
(Inherited from SyntaxEdit.)
Public method LoadFile(String, Encoding)
Loads the contents of the specified file with specified encoding.
(Inherited from SyntaxEdit.)
Public method LoadFile(String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.
(Inherited from SyntaxEdit.)
Public method LoadMacros(Stream)
Loads the macro records from the given stream.
(Inherited from SyntaxEdit.)
Public method LoadMacros(TextReader)
Loads the macro records from the given stream.
(Inherited from SyntaxEdit.)
Public method LoadMacros(String)
Loads the macro records from the given file.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(TextReader)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, IStringImport)
Loads the text content from the given stream with specified importer.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, Encoding)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(TextReader, IStringImport)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.
(Inherited from SyntaxEdit.)
Public method MakeVisible(Point)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
(Inherited from SyntaxEdit.)
Public method MakeVisible(Point, Boolean)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, SearchOptions, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, SearchOptions, Regex, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MoveCaretOnDrag
Moves caret to the position of drag cursor.
(Inherited from SyntaxEdit.)
Public method MoveCharLeft
Moves the current position one character to the left.
(Inherited from SyntaxEdit.)
Public method MoveCharRight
Moves the current position one character to the right.
(Inherited from SyntaxEdit.)
Public method MoveFileBegin
Moves the current position to the first character of the first line.
(Inherited from SyntaxEdit.)
Public method MoveFileEnd
Moves the current position to the last character of the last line.
(Inherited from SyntaxEdit.)
Public method MoveLineBegin
Moves the current position to the first character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineBeginCycled
Moves the current position to the first not whitespace character/first character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineDown
Moves the current position to the next line.
(Inherited from SyntaxEdit.)
Public method MoveLineEnd
Moves the current position to the last character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineEndCycled
Moves the current position to the last not whitespace character/last character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineUp
Moves the current position to the previous line.
(Inherited from SyntaxEdit.)
Public method MovePageDown
Moves current position to the next page.
(Inherited from SyntaxEdit.)
Public method MovePageUp
Moves current position to the previous page.
(Inherited from SyntaxEdit.)
Public method MoveScreenBottom
Moves the current position to the bottom of the screen.
(Inherited from SyntaxEdit.)
Public method MoveScreenTop
Moves the current position to the top of the screen.
(Inherited from SyntaxEdit.)
Public method MoveTo(Point)
Moves the current position to the given position.
(Inherited from SyntaxEdit.)
Public method MoveTo(Int32, Int32)
Moves the current position to the given position.
(Inherited from SyntaxEdit.)
Public method MoveToBrace
Moves the current position to the next open or close brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveToChar
Moves the current position to the specified character in current line.
(Inherited from SyntaxEdit.)
Public method MoveToCloseBrace
Moves the current position to the next close brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveToLine(Int32)
Moves the current position to the specified line.
(Inherited from SyntaxEdit.)
Public method MoveToLine(Int32, Int32)
Moves the current position to the specified line.
(Inherited from SyntaxEdit.)
Public method MoveToOpenBrace
Moves the current position to the previous open brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveWordLeft
Moves the current position one word to the left.
(Inherited from SyntaxEdit.)
Public method MoveWordRight
Moves the current position one word to the right.
(Inherited from SyntaxEdit.)
Public method Navigate
Moves current position by the given offset value.
(Inherited from SyntaxEdit.)
Public method NeedReplaceCurrent
Indicates whether search engine need to replace successfully found and selected text.
(Inherited from SyntaxEdit.)
Public method NeedReplaceCurrent(Match)
Indicates whether search engine need to replace successfully found and selected text.
(Inherited from SyntaxEdit.)
Public method NewLine
Inserts a line break at the current position.
(Inherited from SyntaxEdit.)
Public method NewLine(String, Boolean)
Inserts a line break at the current position with indentation
(Inherited from SyntaxEdit.)
Public method NewLineAbove
Inserts a line break above the current position.
(Inherited from SyntaxEdit.)
Public method NewLineBelow
Inserts a line break below the current position.
(Inherited from SyntaxEdit.)
Public method Notification
Updates control's content according to parameters of notification.
(Inherited from SyntaxEdit.)
Public method OnStateChanged
Updates control's content according to the state of the source.
(Inherited from SyntaxEdit.)
Public method OnTextFound
When implemented by a class, occurs when search text is found.
(Inherited from SyntaxEdit.)
Public method OutlineText
Forces automatic outlining by getting up-to-date information about outline section from the Parser.
(Inherited from SyntaxEdit.)
Public method ParameterInfo
Displays a code completion window containing information for the current method or parameter in the Editor's content.
(Inherited from SyntaxEdit.)
Public method | Paste
Public method PauseMacroRecording
Suspends recording the command sequence.
(Inherited from SyntaxEdit.)
Public method PerformLayout
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PerformLayout(Control, String)
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PlayBackMacro
Repeats the stored command sequence.
(Inherited from SyntaxEdit.)
Public method PointToClient
Computes the location of the specified screen point into client coordinates.
(Inherited from Control.)
Public method PointToScreen
Computes the location of the specified client point into screen coordinates.
(Inherited from Control.)
Public method PositionIsReadonly
Determines whether the text at given position is readonly.
(Inherited from SyntaxEdit.)
Public method PreProcessControlMessage
Preprocesses keyboard or input messages within the message loop before they are dispatched.
(Inherited from Control.)
Public method PreProcessMessage
Preprocesses input messages within the message loop before they are dispatched.
(Inherited from SyntaxEdit.)
Public method | Print
Public method | PrintPreview
Public method ProcessEnter
Performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method ProcessKeyMsg
Processes a keyboard message.
(Inherited from SyntaxEdit.)
Public method ProcessKeyPress
Processes key press.
(Inherited from SyntaxEdit.)
Public method ProcessShiftTab
Performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method ProcessTab
Performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method QuickInfo
Displays a code completion window with simple tooltip information.
(Inherited from SyntaxEdit.)
Public method RecordKeyData
Adds keyData to the MacroRecords array.
(Inherited from SyntaxEdit.)
Public method RectangleToClient
Computes the size and location of the specified screen rectangle in client coordinates.
(Inherited from Control.)
Public method RectangleToScreen
Computes the size and location of the specified client rectangle in screen coordinates.
(Inherited from Control.)
Public method | Redo
Public method Refresh
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
(Inherited from Control.)
Public method | Replace
Public method Replace(String, String)
Searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method Replace(String, String, SearchOptions)
Searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method Replace(String, String, SearchOptions, Regex)
Searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Int32)
Replaces all occurrences of given text within text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceCurrent
Replaces currently selected text.
(Inherited from SyntaxEdit.)
Public method ResetAcceptReturns
Resets the AcceptReturns to the default value.
(Inherited from SyntaxEdit.)
Public method ResetAcceptTabs
Resets the AcceptTabs to the default value.
(Inherited from SyntaxEdit.)
Public method ResetBackColor
Resets the BackColor property to its default value.
(Inherited from Control.)
Public method ResetBindings
Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
(Inherited from Control.)
Public method ResetBorderColor
Resets the BorderColor to the default value.
(Inherited from SyntaxEdit.)
Public method ResetBorderStyle
Resets the BorderStyle to the default value.
(Inherited from SyntaxEdit.)
Public method ResetCursor
Resets the Cursor property to its default value.
(Inherited from SyntaxEdit.)
Public method ResetFont
Resets the Font property to its default value.
(Inherited from SyntaxEdit.)
Public method ResetForeColor
Resets the ForeColor property to its default value.
(Inherited from Control.)
Public method ResetHideCaret
Resets the HideCaret to the default value.
(Inherited from SyntaxEdit.)
Public method ResetImeMode
Resets the ImeMode property to its default value.
(Inherited from Control.)
Public method ResetIndentOptions
Resets the IndentOptions to the default value.
(Inherited from SyntaxEdit.)
Public method ResetKeepCaretOnLostFocus
Resets the KeepCaretOnLostFocus to the default value.
(Inherited from SyntaxEdit.)
Public method ResetLineSpace
Resets the LineSpace to the default value.
(Inherited from SyntaxEdit.)
Public method ResetMaxLength
Resets the MaxLength to the default value.
(Inherited from SyntaxEdit.)
Public method ResetModified
Resets the Modified to the default value.
(Inherited from SyntaxEdit.)
Public method ResetNavigateOptions
Resets the NavigateOptions to the default value.
(Inherited from SyntaxEdit.)
Public method ResetOverWrite
Resets the OverWrite to the default value.
(Inherited from SyntaxEdit.)
Public method ResetReadOnly
Resets the ReadOnly to the default value.
(Inherited from SyntaxEdit.)
Public method ResetRightToLeft
Resets the RightToLeft property to its default value.
(Inherited from Control.)
Public method ResetSingleLineMode
Resets the SingleLineMode to the default value.
(Inherited from SyntaxEdit.)
Public method ResetText
Resets the Text property to its default value.
(Inherited from Control.)
Public method ResetWordWrap
Resets the WordWrap to the default value.
(Inherited from SyntaxEdit.)
Public method ResetWrapAtMargin
Resets the WrapAtMargin to the default value.
(Inherited from SyntaxEdit.)
Public method RestorePosition
Restores position from stored position list by given index.
(Inherited from SyntaxEdit.)
Public method RestorePositionWithUndo
Restores position from stored position list by given index.
(Inherited from SyntaxEdit.)
Public method ResumeLayout
Resumes usual layout logic.
(Inherited from Control.)
Public method ResumeLayout(Boolean)
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.
(Inherited from Control.)
Public method ResumeMacroRecording
Resumes recording the command sequence.
(Inherited from SyntaxEdit.)
Public method | SaveFile(String)
Public method SaveFile(String, IStringExport)
Saves content to the given file in the specific format.
(Inherited from SyntaxEdit.)
Public method SaveFile(String, Encoding)
Saves text content to the specific file with specific encoding.
(Inherited from SyntaxEdit.)
Public method SaveFile(String, IStringExport, Encoding)
Saves content to the given file in the specific format with specific encoding.
(Inherited from SyntaxEdit.)
Public method SaveMacros(Stream)
Saves the macro records to the given stream in xml format.
(Inherited from SyntaxEdit.)
Public method SaveMacros(TextWriter)
Saves the macro records to the given stream in xml format.
(Inherited from SyntaxEdit.)
Public method SaveMacros(String)
Saves the macro records to the given file in xml format.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream)
Saves content of the snippet to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(TextWriter)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, IStringExport)
Saves content to the specific stream in the specific format.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, Encoding)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(TextWriter, IStringExport)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, IStringExport, Encoding)
Saves content to the specific stream in the specific format and specific encoding.
(Inherited from SyntaxEdit.)
Public method Scale(Single) Obsolete.
Scales the control and any child controls.
(Inherited from Control.)
Public method Scale(SizeF)
Scales the control and all child controls by the specified scaling factor.
(Inherited from Control.)
Public method Scale(Single, Single) Obsolete.
Scales the entire control and any child controls.
(Inherited from Control.)
Public method ScreenToDisplay(Int32, Int32)
Converts given screen coordinates to display coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method | ScreenToDisplay(Int32, Int32, Boolean) | (Inherited from SyntaxEdit.)
Public method ScreenToDisplayX
When implemented by a class, converts given screen coordinates to display coordinate of a character.
(Inherited from SyntaxEdit.)
Public method ScreenToText(Point)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScreenToText(Int32, Int32)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScreenToText(Int32, Int32, Boolean)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScrollLineDown
Scrolls text content one line down.
(Inherited from SyntaxEdit.)
Public method ScrollLineUp
Scrolls text content one line up.
(Inherited from SyntaxEdit.)
Public method | Search
Public method Select
Activates the control.
(Inherited from Control.)
Public method | SelectAll
Public method SelectNextControl
Activates the next control.
(Inherited from Control.)
Public method SendToBack
Sends the control to the back of the z-order.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32)
Sets the bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified)
Sets the specified bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetNavigateOptions
Sets navigating options without validating position.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeBorderColor
Indicates whether the BorderColor property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeBorderStyle
Indicates whether the BorderStyle property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeCodeCompletionChars
Indicates whether the CodeCompletionChars property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeCursor
Indicates whether the Cursor property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeFont
Indicates whether the Font property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeIndentOptions
Indicates whether the IndentOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeNavigateOptions
Indicates whether the NavigateOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeReadOnly
Indicates whether the ReadOnly property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeSearchOptions
Indicates whether the SearchOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeText
Indicates whether the Text property should be persisted.
(Inherited from SyntaxEdit.)
Public method Show
Displays the control to the user.
(Inherited from Control.)
Public method ShowCaret
Moves the caret to the specified coordinates.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType)
Shows code completion popup window with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point)
Shows code completion popup window with given Provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionButton(ICodeCompletionProvider)
Shows code completion popup window with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionButton(ICodeCompletionProvider, Point, Boolean)
Shows code completion popup window with given Provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, ILexer)
Displays ICodeCompletionHint with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer)
Displays ICodeCompletionHint with given provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowNotFound
Displays "searched text not found" message box.
(Inherited from SyntaxEdit.)
Public method ShowScrollHint
Displays tooltip indicating destination line when scrolling.
(Inherited from SyntaxEdit.)
Public method SplitViewHorz
Splits control content horizontally.
(Inherited from SyntaxEdit.)
Public method SplitViewVert
Splits control content vertically.
(Inherited from SyntaxEdit.)
Public method StartIncrementalSearch
Enters control to the incremental search state.
(Inherited from SyntaxEdit.)
Public method StartIncrementalSearch(Boolean)
Enters control to the incremental search state.
(Inherited from SyntaxEdit.)
Public method StartMacroRecording
Starts recording the command sequence.
(Inherited from SyntaxEdit.)
Public method StopMacroRecording
Stops recording the command sequence.
(Inherited from SyntaxEdit.)
Public method StorePosition(Point)
Stores given position to stored position list.
(Inherited from SyntaxEdit.)
Public method StorePosition(Point, Boolean)
Stores given position to stored position list.
(Inherited from SyntaxEdit.)
Public method StorePositionWithUndo
Stores given position to stored position list preserving it for undo.
(Inherited from SyntaxEdit.)
Public method SuspendLayout
Temporarily suspends the layout logic for the control.
(Inherited from Control.)
Public method | TextStyleAt | (Inherited from SyntaxEdit.)
Public method TextToScreen(Point)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method TextToScreen(Point, Boolean)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method TextToScreen(Int32, Int32)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method ToggleMacroRecording
Toggles recording the command sequence.
(Inherited from SyntaxEdit.)
Public method ToString
Returns a String containing the name of the Component, if any. This method should not be overridden.
(Inherited from Component.)
Public method UnBreakLine
Concatenates lines at current position.
(Inherited from SyntaxEdit.)
Public method | Undo
Public method UnhighlightAll
Unhighlights search results previously highlighted by HighlightAll.
(Inherited from SyntaxEdit.)
Public method UnsplitViewHorz
Removes horizontal split view.
(Inherited from SyntaxEdit.)
Public method UnsplitViewVert
Removes vertical split view.
(Inherited from SyntaxEdit.)
Public method Update
Causes the control to redraw the invalidated regions within its client area.
(Inherited from Control.)
Public method UpdateCaret
Ensures the caret is displayed in the current position.
(Inherited from SyntaxEdit.)
Public method UpdateCursor
Causes current mouse cursor to be updated.
(Inherited from SyntaxEdit.)
Public method | UpdateSyntax
Public method UpdateView
Updates editor content, caret and pages area.
(Inherited from SyntaxEdit.)
Public method UpdateWordWrap
Re-wraps all lines in the text.
(Inherited from SyntaxEdit.)
Public method UpdateWordWrap(Int32, Int32)
Re-wraps lines in the text within specific scope.
(Inherited from SyntaxEdit.)
Public method ValidatePosition
Validates given position within control's text content.
(Inherited from SyntaxEdit.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanFindDeclaration | (Defined by CodeEditExtensions.)
Public Extension Method | Document | (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindImplementations | (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterDefaultAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterNamespaces | (Defined by CodeEditExtensions.)
Public Extension Method | SetFileNameAndProject | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Top
Properties
 | Name | Description
Public property | AcceptReturns | Gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key. (Inherited from SyntaxEdit.)
Public property | AcceptTabs | Gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key. (Inherited from SyntaxEdit.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveOutlineRange | Gets currently highlighted outlined range. (Inherited from SyntaxEdit.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from SyntaxEdit.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCorrectDelimiters | Gets or sets an array of chars that used as word delimiters. (Inherited from SyntaxEdit.)
Public property | AutoCorrection | Gets or sets a boolean value indicating whether to auto correct words being typed. (Inherited from SyntaxEdit.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color for the Edit control. (Inherited from SyntaxEdit.)
Public property | BorderStyle | Gets or sets the border style for the Edit control. (Inherited from SyntaxEdit.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Braces | Represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control. (Inherited from SyntaxEdit.)
Public property | CanCopy |
Public property | CanCut |
Public property | CanDelete |
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanPaste |
Public property | CanRedo |
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo |
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharsInWidth | Returns number of characters painted with current font that will fit into control's client area. (Inherited from SyntaxEdit.)
Public property | ClientArea | Gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded. (Inherited from SyntaxEdit.)
Public property | ClientHeight | Gets the width of the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | ClientRect | Gets the rectangle that represents the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ClientWidth | Gets the width of the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | CodeCompletionBox | Represents object that specifies a popup window that contains code completion information presented in the form of list. (Inherited from SyntaxEdit.)
Public property | CodeCompletionButton | Represents object that specifies a popup window that contains code completion information presented in the form of list. (Inherited from SyntaxEdit.)
Public property | CodeCompletionChars | Represents a collection of characters that initializes a code completion procedure when typing in the editor. (Inherited from SyntaxEdit.)
Public property | CodeCompletionHint | Represents object that specifies a popup window that contains code completion information presented in the form of the tooltip. (Inherited from SyntaxEdit.)
Public property | CodeCompletionMode | Gets or sets code completion box mode. (Inherited from SyntaxEdit.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateParserFunc |
Public property | CurrentBlockRange | Gets currently highlighted block range. (Inherited from SyntaxEdit.)
Public property | CurrentChar |
Public property | CurrentLine |
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from SyntaxEdit.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultMenu | Gets or sets default context menu for the editor control. (Inherited from SyntaxEdit.)
Public property | DisplayLines | Represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control. (Inherited from SyntaxEdit.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | EditMargin | Represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed. (Inherited from SyntaxEdit.)
Public property | EffectiveVisualTheme | Gets current visual theme. (Inherited from SyntaxEdit.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EventHandlers | Represents object that holds EventHandlers containing list of keys with attached actions. (Inherited from SyntaxEdit.)
Public property | FileName |
Public property | FirstSearch | Gets or sets a value indicating whether control launches text search at first. (Inherited from SyntaxEdit.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from SyntaxEdit.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GotoLineDialog | Gets or sets a dialog prompting for index of the line you need to locate. (Inherited from SyntaxEdit.)
Public property | Gutter | Represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control. (Inherited from SyntaxEdit.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideCaret | Gets or sets a value indicating whether the control should display caret when it has input focus. (Inherited from SyntaxEdit.)
Public property | HighlightCurrentBlock | Specifies that edit control should highlight current block. (Inherited from SyntaxEdit.)
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight begin/end blocks. (Inherited from SyntaxEdit.)
Public property | HighlightReferences | Specifies that edit control should highlight found references. (Inherited from SyntaxEdit.)
Public property | HighlightSearchResults | Indicates whether search results are highlighted while the search dialog is open. (Inherited from SyntaxEdit.)
Public property | HorzSplitEdit | Represents horizontal split view control. (Inherited from SyntaxEdit.)
Public property | HorzSplitter | Represents a horizontal Splitter control allowing to split Edit content horizontally. (Inherited from SyntaxEdit.)
Public property | HyperText | Represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control. (Inherited from SyntaxEdit.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IncrementalSearchString | Return text to search if class is in incremental search state; otherwise return empty string. (Inherited from SyntaxEdit.)
Public property | InCycledSearch | Indicates whether control is in incremental search state. (Inherited from SyntaxEdit.)
Public property | IndentOptions | Gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from SyntaxEdit.)
Public property | InIncrementalSearch | Indicates whether control is in incremental search state. (Inherited from SyntaxEdit.)
Public property | InnerTextSource | Gets inner text source (Inherited from SyntaxEdit.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsCodeCompletionWindowFocused | Indicates whether ICodeCompletionWindow has focus. (Inherited from SyntaxEdit.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSearchFocused | Gets a boolean value indicating whether search dialog box has input focus. (Inherited from SyntaxEdit.)
Public property | KeepCaretOnLostFocus | Keeps caret in visible state even Edit control lost focus. (Inherited from SyntaxEdit.)
Public property | KeyList | Represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure. (Inherited from SyntaxEdit.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | (Overrides SyntaxEditLexer.)
Public property | Lines | Represents object that implements ITextStrings interface containing collection of strings determining control's content. (Inherited from SyntaxEdit.)
Public property | LineSeparator | Represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control. (Inherited from SyntaxEdit.)
Public property | LinesInHeight | Determines how many lines can fit into control's client area. (Inherited from SyntaxEdit.)
Public property | LineSpace | Gets or sets line space between individual lines in the Edit control. (Inherited from SyntaxEdit.)
Public property | LineStyles | Represents an object that implements IEditLineStyles interface holding collection of IEditLineStyle objects each of them determines particular style of the line in the control. (Inherited from SyntaxEdit.)
Public property | LineTerminator | Gets or sets a string value that terminates line. (Inherited from SyntaxEdit.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | MacroRecording | Gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands. (Inherited from SyntaxEdit.)
Public property | MacroRecords | Represents an array containing keyboard commands. (Inherited from SyntaxEdit.)
Public property | MacroSuspendend | Gets or sets a boolean value indicating whether recording is suspended. (Inherited from SyntaxEdit.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control. (Inherited from SyntaxEdit.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified. (Inherited from SyntaxEdit.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavigateOptions | Gets or sets navigating options. (Inherited from SyntaxEdit.)
Public property | OpenSharedEditorFunc | When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment. (Inherited from SyntaxEdit.)
Public property | Outlining | Represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control. (Inherited from SyntaxEdit.)
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from SyntaxEdit.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Pages | Represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages. (Inherited from SyntaxEdit.)
Public property | Painter | Represents an object that implements IPainter interface used to draw control's text. (Inherited from SyntaxEdit.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | Parsers |
Public property | Position | Gets or sets current position within the control's text content. (Inherited from SyntaxEdit.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PrevPosition | Gets previous position within the control's text content. (Inherited from SyntaxEdit.)
Public property | Printing | Represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options. (Inherited from SyntaxEdit.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only. (Inherited from SyntaxEdit.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Scrolling | Represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control. (Inherited from SyntaxEdit.)
Public property | SearchDialog | Gets or sets a dialog box allowing to search for the text or replace it. (Inherited from SyntaxEdit.)
Public property | SearchDialogAppearance | (Inherited from SyntaxEdit.)
Public property | SearchGlobal | Gets or sets a value indicating whether search should be global. (Inherited from SyntaxEdit.)
Public property | SearchLen | Represents length of the last found text. (Inherited from SyntaxEdit.)
Public property | SearchOptions | Gets or sets a value that defines search and replace options. (Inherited from SyntaxEdit.)
Public property | SearchPos | Gets or sets a value that represents position of the last found text. (Inherited from SyntaxEdit.)
Public property | Selection | Represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text. (Inherited from SyntaxEdit.)
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from SyntaxEdit.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Source | (Overrides SyntaxEditSource.)
Public property | Spelling | Represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words. (Inherited from SyntaxEdit.)
Public property | Status |
Public property | StatusText | Obsolete.
Public property | Strings | Represents Lines property in the form of array of strings. (Inherited from SyntaxEdit.)
Public property | SyntaxPaint | Represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content. (Inherited from SyntaxEdit.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the string collection as a single string with the individual lines delimited by carriage returns. (Inherited from SyntaxEdit.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Transparent | Gets or sets a boolean value that indicates whether Edit control should draw its background. (Inherited from SyntaxEdit.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from SyntaxEdit.)
Public property | UseDefaultMenu | Indicates whether edit control should use built in popup menu. (Inherited from SyntaxEdit.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VertSplitEdit | Represents an vertical split view control. (Inherited from SyntaxEdit.)
Public property | VertSplitter | Represents a vertical Splitter control allowing to split Edit content vertically. (Inherited from SyntaxEdit.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualTheme | Gets or sets visual theme for the editor. (Inherited from SyntaxEdit.)
Public property | VisualThemeType | Gets or sets visual theme type for the editor. (Inherited from SyntaxEdit.)
Public property | WhiteSpace | Represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks. (Inherited from SyntaxEdit.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary. (Inherited from SyntaxEdit.)
Public property | WrapAtMargin | Gets or sets a value indicating whether control automatically wraps words at margin position. (Inherited from SyntaxEdit.)
Public property | WrapMargin | Gets position of the wrapping margin. (Inherited from SyntaxEdit.)
Top
Events
 | Name | Description
Public event | AutoCorrect | Occurs when control tries to auto correct word being typed. (Inherited from SyntaxEdit.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckHyperText | Occurs when a control needs checking whether some string represents hypertext. (Inherited from SyntaxEdit.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxEdit.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawHeader | Occurs when header or footer part of each page is drawing. (Inherited from SyntaxEdit.)
Public event | DrawUserMargin | Occurs when user margin part of each line is drawing. (Inherited from SyntaxEdit.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | GutterClick | Occurs when the gutter part of Edit control is clicked. (Inherited from SyntaxEdit.)
Public event | GutterDblClick | Occurs when the gutter part of Edit control is double-clicked. (Inherited from SyntaxEdit.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HorizontalScroll | Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving. (Inherited from SyntaxEdit.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | JumpToUrl | Occurs when user attempts to jump to url. (Inherited from SyntaxEdit.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when modified state is changed. (Inherited from SyntaxEdit.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NeedCodeCompletion | Occurs when code completion window is to be displayed. (Inherited from SyntaxEdit.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintBackground | Occurs when Edit control should paint its background in transparent mode. (Inherited from SyntaxEdit.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | ParserChanged |
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PromptOnReplace | Occurs when replace dialog prompts on replace action. (Inherited from SyntaxEdit.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollButtonClick | Occurs when some scrolling button is clicked. (Inherited from SyntaxEdit.)
Public event | SelectionChanged | Occurs when selection bounds are changed. (Inherited from SyntaxEdit.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SourceChanged | Occurs when source changes. (Inherited from SyntaxEdit.)
Public event | SourceStateChanged | Occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc. (Inherited from SyntaxEdit.)
Public event | SplitHorz | Occurs when user splits Edit control horizontally. (Inherited from SyntaxEdit.)
Public event | SplitVert | Occurs when user splits Edit control vertically. (Inherited from SyntaxEdit.)
Public event | StatusChanged |
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged |
Public event | UndoEvent | Occurs when undo/redo operation performed. (Inherited from SyntaxEdit.)
Public event | UnsplitHorz | Occurs when horizontal split view is removed. (Inherited from SyntaxEdit.)
Public event | UnsplitVert | Occurs when vertical split view is removed. (Inherited from SyntaxEdit.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VerticalScroll | Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving. (Inherited from SyntaxEdit.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking. (Inherited from SyntaxEdit.)
Top
See Also

Reference

Alternet.Editor.Common Namespace


ScriptCodeEdit Constructor

ScriptCodeEdit Constructor
Initializes a new instance of the ScriptCodeEdit class

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCodeEdit()
Public Sub New
public:
ScriptCodeEdit()
new : unit -> ScriptCodeEdit
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit Methods

ScriptCodeEdit Methods

The ScriptCodeEdit type exposes the following members.

Methods
Name | Description
Public method ApplyTheme
Applies visual theme to the SyntaxEdit control.
(Inherited from SyntaxEdit.)
Public method Assign
Assigns most relevant properties from another ISyntaxEdit object.
(Inherited from SyntaxEdit.)
Public method BeginInvoke(Delegate)
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginInvoke(Delegate, Object)
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginUpdate
Prevents editor updating until calling EndUpdate method.
(Inherited from SyntaxEdit.)
Public method BreakLine
Breaks current line into two lines.
(Inherited from SyntaxEdit.)
Public method BringToFront
Brings the control to the front of the z-order.
(Inherited from Control.)
Public method CanFindNext
Indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindNextSelected
Indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindPrevious
Indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindPreviousSelected
Indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanSearchSelection
Returns whether search can be performed inside selection.
(Inherited from SyntaxEdit.)
Public method CanSplitHorz
Indicates whether control can split its content horizontally.
(Inherited from SyntaxEdit.)
Public method CanSplitVert
Indicates whether control can split its content vertically.
(Inherited from SyntaxEdit.)
Public method CanUnsplitHorz
Indicates whether control has horizontal split view.
(Inherited from SyntaxEdit.)
Public method CanUnsplitVert
Indicates whether control has vertical split view.
(Inherited from SyntaxEdit.)
Public method CodeCompletion
Performs code completion for the specified text representing language element.
(Inherited from SyntaxEdit.)
Public method CodeCompletionWindowFocused
Indicates whether ICodeCompletionWindow has focus.
(Inherited from SyntaxEdit.)
Public method CodeSnippets
Displays a code completion window with list of available code snippets.
(Inherited from SyntaxEdit.)
Public method CompleteCodeFixes
Displays a code completion window with list of available code fixes.
(Inherited from SyntaxEdit.)
Public method CompleteCodeFixesOrRefactors
Displays a code completion window with list of available code fixes or code refactors.
(Inherited from SyntaxEdit.)
Public method CompleteCodeRefactors
Displays a code completion window with list of available code refactors.
(Inherited from SyntaxEdit.)
Public method CompleteWord
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box and locates single member, if possible.
(Inherited from SyntaxEdit.)
Public method Contains
Retrieves a value indicating whether the specified control is a child of the control.
(Inherited from Control.)
Public method | Copy
Public method CreateCaret
Creates a new shape for the system caret and gets ownership of the caret.
(Inherited from SyntaxEdit.)
Public method CreateControl
Forces the creation of the visible control, including the creation of the handle and any visible child controls.
(Inherited from Control.)
Public method CreateGraphics
Creates the Graphics for the control.
(Inherited from Control.)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method | Cut
Public method CycledSearch
Performs cycled search.
(Inherited from SyntaxEdit.)
Public method | Delete
Public method DeleteBlock
Deletes a specified block of characters.
(Inherited from SyntaxEdit.)
Public method DeleteLeft
Deletes a specified number of characters to the left of the active point.
(Inherited from SyntaxEdit.)
Public method DeleteRight
Deletes a specified number of characters to the right of the active point.
(Inherited from SyntaxEdit.)
Public method | DeselectAll
Public method DestroyCaret
Destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
(Inherited from SyntaxEdit.)
Public method DisablePositionUpdate
Prevents notification of changing of caret position until calling EnablePositionUpdate method.
(Inherited from SyntaxEdit.)
Public method DisableUpdate
Prevents editor updating until calling EnableUpdate method.
(Inherited from SyntaxEdit.)
Public method DisplayDragCaret
Displays dragging caret rather than regular caret.
(Inherited from SyntaxEdit.)
Public method DisplayGotoLineDialog
Initializes and runs a dialog prompting you for index of the line you need to locate.
(Inherited from SyntaxEdit.)
Public method DisplayGotoLineDialog(IWin32Window)
Initializes and runs a dialog prompting you for index of the line you need to locate.
(Inherited from SyntaxEdit.)
Public method DisplayModalReplaceDialog
Initializes and runs a modal dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayModalReplaceDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayModalSearchDialog
Initializes and runs a modal dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayModalSearchDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayReplaceDialog
Initializes and runs a dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayReplaceDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplaySearchDialog
Initializes and runs a dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplaySearchDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayToScreen(Int32, Int32)
Converts given display coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method DisplayToScreen(Int32, Int32, Boolean)
Converts given display coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method Dispose
Releases all resources used by the Component.
(Inherited from Component.)
Public method DoDragDrop
Begins a drag-and-drop operation.
(Inherited from Control.)
Public method DrawToBitmap
Supports rendering to the specified bitmap.
(Inherited from Control.)
Public method EnablePositionUpdate
Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
(Inherited from SyntaxEdit.)
Public method EnableUpdate
Re-enables editor updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from SyntaxEdit.)
Public method EndInvoke
Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
(Inherited from Control.)
Public method EndUpdate
Re-enables outline editor updating, that was turn of by calling BeginUpdate method.
(Inherited from SyntaxEdit.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method Find(String)
Searches for given text within the control's contents.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions)
Searches for given text within the control's contents with specified options.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex)
Searches for given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, IListIRange)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, Boolean, Boolean)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, Point, Int32, Match)
Searches for given text within the control's text content.
(Inherited from SyntaxEdit.)
Public method FindForm
Retrieves the form that the control is on.
(Inherited from Control.)
Public method FindNext
Searches for the next occurrence of the text specified by previous search.
(Inherited from SyntaxEdit.)
Public method FindNextSelected
Searches for the next occurrence of the selected text.
(Inherited from SyntaxEdit.)
Public method FindPrevious
Searches for the previous occurrence of the text specified by previous search.
(Inherited from SyntaxEdit.)
Public method FindPreviousSelected
Searches for the previous occurrence of the selected text.
(Inherited from SyntaxEdit.)
Public method FinishIncrementalSearch
Leaves control from the incremental search state.
(Inherited from SyntaxEdit.)
Public method Focus
Sets input focus to the control.
(Inherited from Control.)
Public method GetCaretSize
Returns size of the caret's current shape at given position.
(Inherited from SyntaxEdit.)
Public method GetCharsInWidth
Returns number of characters painted with current font that will fit into specified Width.
(Inherited from SyntaxEdit.)
Public method GetChildAtPoint(Point)
Retrieves the child control that is located at the specified coordinates.
(Inherited from Control.)
Public method GetChildAtPoint(Point, GetChildAtPointSkip)
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
(Inherited from Control.)
Public method GetContainerControl
Returns the next ContainerControl up the control's chain of parent controls.
(Inherited from Control.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetHitTest(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTest(Int32, Int32, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTestAtTextPoint(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of control at specified text coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo)
Retrieves information about part of control at specified text coordinate.
(Inherited from SyntaxEdit.)
Public method GetIndentString
Gets indentation string at current position.
(Inherited from SyntaxEdit.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | GetLine
Public method GetLinesInHeight
Determines how many lines can fit into given Height.
(Inherited from SyntaxEdit.)
Public method GetNextControl
Retrieves the next control forward or back in the tab order of child controls.
(Inherited from Control.)
Public method GetPreferredSize
Retrieves the size of a rectangular area into which a control can be fitted.
(Inherited from Control.)
Public method | GetSymbolAtCursor
Public method GetTextAtCursor
Returns word at the cursor position.
(Inherited from SyntaxEdit.)
Public method GetTextToSearchAtCursor
Returns word at the cursor position.
(Inherited from SyntaxEdit.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetWordAt
Checks word accordingly to specified conditions.
(Inherited from SyntaxEdit.)
Public method GetWrapMargin
Returns position of the wrapping margin.
(Inherited from SyntaxEdit.)
Public method | GotoLine
Public method HasAutoCorrection
Checks whether specified word has correction.
(Inherited from SyntaxEdit.)
Public method Hide
Conceals the control from the user.
(Inherited from Control.)
Public method HideDragCaret
Hides dragging caret.
(Inherited from SyntaxEdit.)
Public method HideScrollHint
Hides scroll hint window if necessary.
(Inherited from SyntaxEdit.)
Public method HighlightAll
Highlights all occurrences of specified string in the class text content.
(Inherited from SyntaxEdit.)
Public method IncrementalSearch
Finds given text incrementally.
(Inherited from SyntaxEdit.)
Public method IndentLine
Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
(Inherited from SyntaxEdit.)
Public method IndentLine(String, Boolean)
Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
(Inherited from SyntaxEdit.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method Insert
Inserts the given string at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean)
Inserts the given string at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean)
Inserts the given string array at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(ITextStrings, Boolean)
Inserts the given string collection at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertFromFile
Inserts the file text content at the specified location.
(Inherited from SyntaxEdit.)
Public method Invalidate
Invalidates the entire surface of the control and causes the control to be redrawn.
(Inherited from Control.)
Public method Invalidate(Region)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Boolean)
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Region, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invoke(Delegate)
Executes the specified delegate on the thread that owns the control's underlying window handle.
(Inherited from Control.)
Public method Invoke(Delegate, Object)
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
(Inherited from Control.)
Public method IsValidText
Indicates whether text at the specified position is valid (that is does not contain comments or string constants).
(Inherited from SyntaxEdit.)
Public method KillFocus
Ensure the caret is not visible.
(Inherited from SyntaxEdit.)
Public method LineIsHidden
Determines whether the given line is hidden.
(Inherited from SyntaxEdit.)
Public method LineIsReadonly
Determines whether the given line is readonly.
(Inherited from SyntaxEdit.)
Public method ListMembers
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box.
(Inherited from SyntaxEdit.)
Public method | LoadFile(String)
Public method LoadFile(String, IStringImport)
Loads content from the given file with specified importer.
(Inherited from SyntaxEdit.)
Public method LoadFile(String, Encoding)
Loads the contents of the specified file with specified encoding.
(Inherited from SyntaxEdit.)
Public method LoadFile(String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.
(Inherited from SyntaxEdit.)
Public method LoadMacros(Stream)
Loads the macro records from the given stream.
(Inherited from SyntaxEdit.)
Public method LoadMacros(TextReader)
Loads the macro records from the given stream.
(Inherited from SyntaxEdit.)
Public method LoadMacros(String)
Loads the macro records from the given file.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(TextReader)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, IStringImport)
Loads the text content from the given stream with specified importer.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, Encoding)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(TextReader, IStringImport)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.
(Inherited from SyntaxEdit.)
Public method MakeVisible(Point)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
(Inherited from SyntaxEdit.)
Public method MakeVisible(Point, Boolean)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, SearchOptions, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, SearchOptions, Regex, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MoveCaretOnDrag
Moves caret to the position of drag cursor.
(Inherited from SyntaxEdit.)
Public method MoveCharLeft
Moves the current position one character to the left.
(Inherited from SyntaxEdit.)
Public method MoveCharRight
Moves the current position one character to the right.
(Inherited from SyntaxEdit.)
Public method MoveFileBegin
Moves the current position to the first character of the first line.
(Inherited from SyntaxEdit.)
Public method MoveFileEnd
Moves the current position to the last character of the last line.
(Inherited from SyntaxEdit.)
Public method MoveLineBegin
Moves the current position to the first character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineBeginCycled
Moves the current position to the first not whitespace character/first character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineDown
Moves the current position to the next line.
(Inherited from SyntaxEdit.)
Public method MoveLineEnd
Moves the current position to the last character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineEndCycled
Moves the current position to the last not whitespace character/last character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineUp
Moves the current position to the previous line.
(Inherited from SyntaxEdit.)
Public method MovePageDown
Moves current position to the next page.
(Inherited from SyntaxEdit.)
Public method MovePageUp
Moves current position to the previous page.
(Inherited from SyntaxEdit.)
Public method MoveScreenBottom
Moves the current position to the bottom of the screen.
(Inherited from SyntaxEdit.)
Public method MoveScreenTop
Moves the current position to the top of the screen.
(Inherited from SyntaxEdit.)
Public method MoveTo(Point)
Moves the current position to the given position.
(Inherited from SyntaxEdit.)
Public method MoveTo(Int32, Int32)
Moves the current position to the given position.
(Inherited from SyntaxEdit.)
Public method MoveToBrace
Moves the current position to the next open or close brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveToChar
Moves the current position to the specified character in current line.
(Inherited from SyntaxEdit.)
Public method MoveToCloseBrace
Moves the current position to the next close brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveToLine(Int32)
Moves the current position to the specified line.
(Inherited from SyntaxEdit.)
Public method MoveToLine(Int32, Int32)
Moves the current position to the specified line.
(Inherited from SyntaxEdit.)
Public method MoveToOpenBrace
Moves the current position to the previous open brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveWordLeft
Moves the current position one word to the left.
(Inherited from SyntaxEdit.)
Public method MoveWordRight
Moves the current position one word to the right.
(Inherited from SyntaxEdit.)
Public method Navigate
Moves current position by the given offset value.
(Inherited from SyntaxEdit.)
Public method NeedReplaceCurrent
Indicates whether search engine need to replace successfully found and selected text.
(Inherited from SyntaxEdit.)
Public method NeedReplaceCurrent(Match)
Indicates whether search engine need to replace successfully found and selected text.
(Inherited from SyntaxEdit.)
Public method NewLine
Inserts a line break at the current position.
(Inherited from SyntaxEdit.)
Public method NewLine(String, Boolean)
Inserts a line break at the current position with indentation
(Inherited from SyntaxEdit.)
Public method NewLineAbove
Inserts a line break above the current position.
(Inherited from SyntaxEdit.)
Public method NewLineBelow
Inserts a line break below the current position.
(Inherited from SyntaxEdit.)
Public method Notification
Updates control's content according to parameters of notification.
(Inherited from SyntaxEdit.)
Public method OnStateChanged
Updates control's content according to the state of the source.
(Inherited from SyntaxEdit.)
Public method OnTextFound
When implemented by a class, occurs when search text is found.
(Inherited from SyntaxEdit.)
Public method OutlineText
Forces automatic outlining by getting up-to-date information about outline section from the Parser.
(Inherited from SyntaxEdit.)
Public method ParameterInfo
Displays a code completion window containing information for the current method or parameter in the Editor's content.
(Inherited from SyntaxEdit.)
Public method | Paste
Public method PauseMacroRecording
Suspends recording the command sequence.
(Inherited from SyntaxEdit.)
Public method PerformLayout
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PerformLayout(Control, String)
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PlayBackMacro
Repeats the stored command sequence.
(Inherited from SyntaxEdit.)
Public method PointToClient
Computes the location of the specified screen point into client coordinates.
(Inherited from Control.)
Public method PointToScreen
Computes the location of the specified client point into screen coordinates.
(Inherited from Control.)
Public method PositionIsReadonly
Determines whether the text at given position is readonly.
(Inherited from SyntaxEdit.)
Public method PreProcessControlMessage
Preprocesses keyboard or input messages within the message loop before they are dispatched.
(Inherited from Control.)
Public method PreProcessMessage
Preprocesses input messages within the message loop before they are dispatched.
(Inherited from SyntaxEdit.)
Public method | Print
Public method | PrintPreview
Public method ProcessEnter
Performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method ProcessKeyMsg
Processes a keyboard message.
(Inherited from SyntaxEdit.)
Public method ProcessKeyPress
Processes key press.
(Inherited from SyntaxEdit.)
Public method ProcessShiftTab
Performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method ProcessTab
Performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method QuickInfo
Displays a code completion window with simple tooltip information.
(Inherited from SyntaxEdit.)
Public method RecordKeyData
Adds keyData to the MacroRecords array.
(Inherited from SyntaxEdit.)
Public method RectangleToClient
Computes the size and location of the specified screen rectangle in client coordinates.
(Inherited from Control.)
Public method RectangleToScreen
Computes the size and location of the specified client rectangle in screen coordinates.
(Inherited from Control.)
Public method | Redo
Public method Refresh
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
(Inherited from Control.)
Public method | Replace
Public method Replace(String, String)
Searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method Replace(String, String, SearchOptions)
Searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method Replace(String, String, SearchOptions, Regex)
Searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Int32)
Replaces all occurrences of given text within text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceCurrent
Replaces currently selected text.
(Inherited from SyntaxEdit.)
Public method ResetAcceptReturns
Resets the AcceptReturns to the default value.
(Inherited from SyntaxEdit.)
Public method ResetAcceptTabs
Resets the AcceptTabs to the default value.
(Inherited from SyntaxEdit.)
Public method ResetBackColor
Resets the BackColor property to its default value.
(Inherited from Control.)
Public method ResetBindings
Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
(Inherited from Control.)
Public method ResetBorderColor
Resets the BorderColor to the default value.
(Inherited from SyntaxEdit.)
Public method ResetBorderStyle
Resets the BorderStyle to the default value.
(Inherited from SyntaxEdit.)
Public method ResetCursor
Resets the Cursor property to its default value.
(Inherited from SyntaxEdit.)
Public method ResetFont
Resets the Font property to its default value.
(Inherited from SyntaxEdit.)
Public method ResetForeColor
Resets the ForeColor property to its default value.
(Inherited from Control.)
Public method ResetHideCaret
Resets the HideCaret to the default value.
(Inherited from SyntaxEdit.)
Public method ResetImeMode
Resets the ImeMode property to its default value.
(Inherited from Control.)
Public method ResetIndentOptions
Resets the IndentOptions to the default value.
(Inherited from SyntaxEdit.)
Public method ResetKeepCaretOnLostFocus
Resets the KeepCaretOnLostFocus to the default value.
(Inherited from SyntaxEdit.)
Public method ResetLineSpace
Resets the LineSpace to the default value.
(Inherited from SyntaxEdit.)
Public method ResetMaxLength
Resets the MaxLength to the default value.
(Inherited from SyntaxEdit.)
Public method ResetModified
Resets the Modified to the default value.
(Inherited from SyntaxEdit.)
Public method ResetNavigateOptions
Resets the NavigateOptions to the default value.
(Inherited from SyntaxEdit.)
Public method ResetOverWrite
Resets the OverWrite to the default value.
(Inherited from SyntaxEdit.)
Public method ResetReadOnly
Resets the ReadOnly to the default value.
(Inherited from SyntaxEdit.)
Public method ResetRightToLeft
Resets the RightToLeft property to its default value.
(Inherited from Control.)
Public method ResetSingleLineMode
Resets the SingleLineMode to the default value.
(Inherited from SyntaxEdit.)
Public method ResetText
Resets the Text property to its default value.
(Inherited from Control.)
Public method ResetWordWrap
Resets the WordWrap to the default value.
(Inherited from SyntaxEdit.)
Public method ResetWrapAtMargin
Resets the WrapAtMargin to the default value.
(Inherited from SyntaxEdit.)
Public method RestorePosition
Restores position from stored position list by given index.
(Inherited from SyntaxEdit.)
Public method RestorePositionWithUndo
Restores position from stored position list by given index.
(Inherited from SyntaxEdit.)
Public method ResumeLayout
Resumes usual layout logic.
(Inherited from Control.)
Public method ResumeLayout(Boolean)
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.
(Inherited from Control.)
Public method ResumeMacroRecording
Resumes recording the command sequence.
(Inherited from SyntaxEdit.)
Public method | SaveFile(String)
Public method SaveFile(String, IStringExport)
Saves content to the given file in the specific format.
(Inherited from SyntaxEdit.)
Public method SaveFile(String, Encoding)
Saves text content to the specific file with specific encoding.
(Inherited from SyntaxEdit.)
Public method SaveFile(String, IStringExport, Encoding)
Saves content to the given file in the specific format with specific encoding.
(Inherited from SyntaxEdit.)
Public method SaveMacros(Stream)
Saves the macro records to the given stream in xml format.
(Inherited from SyntaxEdit.)
Public method SaveMacros(TextWriter)
Saves the macro records to the given stream in xml format.
(Inherited from SyntaxEdit.)
Public method SaveMacros(String)
Saves the macro records to the given file in xml format.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream)
Saves content of the snippet to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(TextWriter)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, IStringExport)
Saves content to the specific stream in the specific format.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, Encoding)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(TextWriter, IStringExport)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, IStringExport, Encoding)
Saves content to the specific stream in the specific format and specific encoding.
(Inherited from SyntaxEdit.)
Public method Scale(Single) Obsolete.
Scales the control and any child controls.
(Inherited from Control.)
Public method Scale(SizeF)
Scales the control and all child controls by the specified scaling factor.
(Inherited from Control.)
Public method Scale(Single, Single) Obsolete.
Scales the entire control and any child controls.
(Inherited from Control.)
Public method ScreenToDisplay(Int32, Int32)
Converts given screen coordinates to display coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method | ScreenToDisplay(Int32, Int32, Boolean) | (Inherited from SyntaxEdit.)
Public method ScreenToDisplayX
When implemented by a class, converts given screen coordinates to display coordinate of a character.
(Inherited from SyntaxEdit.)
Public method ScreenToText(Point)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScreenToText(Int32, Int32)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScreenToText(Int32, Int32, Boolean)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScrollLineDown
Scrolls text content one line down.
(Inherited from SyntaxEdit.)
Public method ScrollLineUp
Scrolls text content one line up.
(Inherited from SyntaxEdit.)
Public method | Search
Public method Select
Activates the control.
(Inherited from Control.)
Public method | SelectAll
Public method SelectNextControl
Activates the next control.
(Inherited from Control.)
Public method SendToBack
Sends the control to the back of the z-order.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32)
Sets the bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified)
Sets the specified bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetNavigateOptions
Sets navigating options without validating position.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeBorderColor
Indicates whether the BorderColor property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeBorderStyle
Indicates whether the BorderStyle property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeCodeCompletionChars
Indicates whether the CodeCompletionChars property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeCursor
Indicates whether the Cursor property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeFont
Indicates whether the Font property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeIndentOptions
Indicates whether the IndentOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeNavigateOptions
Indicates whether the NavigateOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeReadOnly
Indicates whether the ReadOnly property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeSearchOptions
Indicates whether the SearchOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeText
Indicates whether the Text property should be persisted.
(Inherited from SyntaxEdit.)
Public method Show
Displays the control to the user.
(Inherited from Control.)
Public method ShowCaret
Moves the caret to the specified coordinates.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType)
Shows code completion popup window with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point)
Shows code completion popup window with given Provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionButton(ICodeCompletionProvider)
Shows code completion popup window with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionButton(ICodeCompletionProvider, Point, Boolean)
Shows code completion popup window with given Provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, ILexer)
Displays ICodeCompletionHint with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer)
Displays ICodeCompletionHint with given provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowNotFound
Displays "searched text not found" message box.
(Inherited from SyntaxEdit.)
Public method ShowScrollHint
Displays tooltip indicating destination line when scrolling.
(Inherited from SyntaxEdit.)
Public method SplitViewHorz
Splits control content horizontally.
(Inherited from SyntaxEdit.)
Public method SplitViewVert
Splits control content vertically.
(Inherited from SyntaxEdit.)
Public method StartIncrementalSearch
Enters control to the incremental search state.
(Inherited from SyntaxEdit.)
Public method StartIncrementalSearch(Boolean)
Enters control to the incremental search state.
(Inherited from SyntaxEdit.)
Public method StartMacroRecording
Starts recording the command sequence.
(Inherited from SyntaxEdit.)
Public method StopMacroRecording
Stops recording the command sequence.
(Inherited from SyntaxEdit.)
Public method StorePosition(Point)
Stores given position to stored position list.
(Inherited from SyntaxEdit.)
Public method StorePosition(Point, Boolean)
Stores given position to stored position list.
(Inherited from SyntaxEdit.)
Public method StorePositionWithUndo
Stores given position to stored position list preserving it for undo.
(Inherited from SyntaxEdit.)
Public method SuspendLayout
Temporarily suspends the layout logic for the control.
(Inherited from Control.)
Public method | TextStyleAt | (Inherited from SyntaxEdit.)
Public method TextToScreen(Point)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method TextToScreen(Point, Boolean)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method TextToScreen(Int32, Int32)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method ToggleMacroRecording
Toggles recording the command sequence.
(Inherited from SyntaxEdit.)
Public method ToString
Returns a String containing the name of the Component, if any. This method should not be overridden.
(Inherited from Component.)
Public method UnBreakLine
Concatenates lines at current position.
(Inherited from SyntaxEdit.)
Public method | Undo
Public method UnhighlightAll
Unhighlights search results previously highlighted by HighlightAll.
(Inherited from SyntaxEdit.)
Public method UnsplitViewHorz
Removes horizontal split view.
(Inherited from SyntaxEdit.)
Public method UnsplitViewVert
Removes vertical split view.
(Inherited from SyntaxEdit.)
Public method Update
Causes the control to redraw the invalidated regions within its client area.
(Inherited from Control.)
Public method UpdateCaret
Ensures the caret is displayed in the current position.
(Inherited from SyntaxEdit.)
Public method UpdateCursor
Causes current mouse cursor to be updated.
(Inherited from SyntaxEdit.)
Public method | UpdateSyntax
Public method UpdateView
Updates editor content, caret and pages area.
(Inherited from SyntaxEdit.)
Public method UpdateWordWrap
Re-wraps all lines in the text.
(Inherited from SyntaxEdit.)
Public method UpdateWordWrap(Int32, Int32)
Re-wraps lines in the text within specific scope.
(Inherited from SyntaxEdit.)
Public method ValidatePosition
Validates given position within control's text content.
(Inherited from SyntaxEdit.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanFindDeclaration | (Defined by CodeEditExtensions.)
Public Extension Method | Document | (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindImplementations | (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterDefaultAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterNamespaces | (Defined by CodeEditExtensions.)
Public Extension Method | SetFileNameAndProject | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Top
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Copy Method

ScriptCodeEditCopy Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

IScriptEditCopy
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Cut Method

ScriptCodeEditCut Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

IScriptEditCut
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Delete Method

ScriptCodeEditDelete Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Delete()
Public Sub Delete
public:
virtual void Delete() sealed
abstract Delete : unit -> unit
override Delete : unit -> unit

Implements

IScriptEditDelete
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.DeselectAll Method

ScriptCodeEditDeselectAll Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeselectAll()
Public Sub DeselectAll
public:
virtual void DeselectAll() sealed
abstract DeselectAll : unit -> unit
override DeselectAll : unit -> unit

Implements

IScriptEditDeselectAll
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.GetLine Method

ScriptCodeEditGetLine Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetLine(
    int index
)
Public Function GetLine (
    index As Integer
) As String
public:
virtual String^ GetLine(
    int index
) sealed
abstract GetLine :
        index : int -> string
override GetLine :
        index : int -> string

Parameters

index
Type: SystemInt32

Return Value

Type: String

Implements

IScriptEditGetLine(Int32)
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.GetSymbolAtCursor Method

ScriptCodeEditGetSymbolAtCursor Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetSymbolAtCursor()
Public Function GetSymbolAtCursor As String
public:
virtual String^ GetSymbolAtCursor() sealed
abstract GetSymbolAtCursor : unit -> string
override GetSymbolAtCursor : unit -> string

Return Value

Type: String

Implements

IScriptEditGetSymbolAtCursor
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.GotoLine Method

ScriptCodeEditGotoLine Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GotoLine()
Public Sub GotoLine
public:
virtual void GotoLine() sealed
abstract GotoLine : unit -> unit
override GotoLine : unit -> unit

Implements

IScriptEditGotoLine
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.LoadFile Method

ScriptCodeEditLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) |
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer. (Inherited from SyntaxEdit.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxEdit.)
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding. (Inherited from SyntaxEdit.)
Top
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.LoadFile Method (String)

ScriptCodeEditLoadFile Method (String)

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LoadFile(
    string fileName
)
Public Sub LoadFile (
    fileName As String
)
public:
virtual void LoadFile(
    String^ fileName
) sealed
abstract LoadFile :
        fileName : string -> unit
override LoadFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString

Implements

IScriptEditLoadFile(String)
See Also

Reference

ScriptCodeEdit Class
LoadFile Overload
Alternet.Editor.Common Namespace


ScriptCodeEdit.Paste Method

ScriptCodeEditPaste Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

IScriptEditPaste
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Print Method

ScriptCodeEditPrint Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Print()
Public Sub Print
public:
virtual void Print() sealed
abstract Print : unit -> unit
override Print : unit -> unit

Implements

IScriptEditPrint
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.PrintPreview Method

ScriptCodeEditPrintPreview Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PrintPreview()
Public Sub PrintPreview
public:
virtual void PrintPreview() sealed
abstract PrintPreview : unit -> unit
override PrintPreview : unit -> unit

Implements

IScriptEditPrintPreview
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Redo Method

ScriptCodeEditRedo Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Redo()
Public Sub Redo
public:
virtual void Redo() sealed
abstract Redo : unit -> unit
override Redo : unit -> unit

Implements

IScriptEditRedo
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Replace Method

ScriptCodeEditReplace Method
Overload List
 | Name | Description
Public method | Replace |
Public method | Replace(String, String) | Searches for the first occurrence of given text within the text content and if succeed replaces it by specified string. (Inherited from SyntaxEdit.)
Public method | Replace(String, String, SearchOptions) | Searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string. (Inherited from SyntaxEdit.)
Public method | Replace(String, String, SearchOptions, Regex) | Searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string. (Inherited from SyntaxEdit.)
Top
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Replace Method

ScriptCodeEditReplace Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Replace()
Public Sub Replace
public:
virtual void Replace() sealed
abstract Replace : unit -> unit
override Replace : unit -> unit

Implements

IScriptEditReplace
See Also

Reference

ScriptCodeEdit Class
Replace Overload
Alternet.Editor.Common Namespace


ScriptCodeEdit.SaveFile Method

ScriptCodeEditSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) |
Public method | SaveFile(String, IStringExport) | Saves content to the given file in the specific format. (Inherited from SyntaxEdit.)
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding. (Inherited from SyntaxEdit.)
Public method | SaveFile(String, IStringExport, Encoding) | Saves content to the given file in the specific format with specific encoding. (Inherited from SyntaxEdit.)
Top
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.SaveFile Method (String)

ScriptCodeEditSaveFile Method (String)

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveFile(
    string fileName
)
Public Sub SaveFile (
    fileName As String
)
public:
virtual void SaveFile(
    String^ fileName
) sealed
abstract SaveFile :
        fileName : string -> unit
override SaveFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString

Implements

IScriptEditSaveFile(String)
See Also

Reference

ScriptCodeEdit Class
SaveFile Overload
Alternet.Editor.Common Namespace


ScriptCodeEdit.Search Method

ScriptCodeEditSearch Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Search()
Public Sub Search
public:
virtual void Search() sealed
abstract Search : unit -> unit
override Search : unit -> unit

Implements

IScriptEditSearch
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.SelectAll Method

ScriptCodeEditSelectAll Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectAll()
Public Sub SelectAll
public:
virtual void SelectAll() sealed
abstract SelectAll : unit -> unit
override SelectAll : unit -> unit

Implements

IScriptEditSelectAll
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Undo Method

ScriptCodeEditUndo Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Undo()
Public Sub Undo
public:
virtual void Undo() sealed
abstract Undo : unit -> unit
override Undo : unit -> unit

Implements

IScriptEditUndo
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.UpdateSyntax Method

ScriptCodeEditUpdateSyntax Method

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateSyntax()
Public Sub UpdateSyntax
public:
virtual void UpdateSyntax() sealed
abstract UpdateSyntax : unit -> unit
override UpdateSyntax : unit -> unit

Implements

IScriptEditUpdateSyntax
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit Properties

ScriptCodeEdit Properties

The ScriptCodeEdit type exposes the following members.

Properties
 | Name | Description
Public property | AcceptReturns | Gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key. (Inherited from SyntaxEdit.)
Public property | AcceptTabs | Gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key. (Inherited from SyntaxEdit.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveOutlineRange | Gets currently highlighted outlined range. (Inherited from SyntaxEdit.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from SyntaxEdit.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCorrectDelimiters | Gets or sets an array of chars that used as word delimiters. (Inherited from SyntaxEdit.)
Public property | AutoCorrection | Gets or sets a boolean value indicating whether to auto correct words being typed. (Inherited from SyntaxEdit.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color for the Edit control. (Inherited from SyntaxEdit.)
Public property | BorderStyle | Gets or sets the border style for the Edit control. (Inherited from SyntaxEdit.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Braces | Represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control. (Inherited from SyntaxEdit.)
Public property | CanCopy |
Public property | CanCut |
Public property | CanDelete |
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanPaste |
Public property | CanRedo |
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo |
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharsInWidth | Returns number of characters painted with current font that will fit into control's client area. (Inherited from SyntaxEdit.)
Public property | ClientArea | Gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded. (Inherited from SyntaxEdit.)
Public property | ClientHeight | Gets the width of the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | ClientRect | Gets the rectangle that represents the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ClientWidth | Gets the width of the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | CodeCompletionBox | Represents object that specifies a popup window that contains code completion information presented in the form of list. (Inherited from SyntaxEdit.)
Public property | CodeCompletionButton | Represents object that specifies a popup window that contains code completion information presented in the form of list. (Inherited from SyntaxEdit.)
Public property | CodeCompletionChars | Represents a collection of characters that initializes a code completion procedure when typing in the editor. (Inherited from SyntaxEdit.)
Public property | CodeCompletionHint | Represents object that specifies a popup window that contains code completion information presented in the form of the tooltip. (Inherited from SyntaxEdit.)
Public property | CodeCompletionMode | Gets or sets code completion box mode. (Inherited from SyntaxEdit.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateParserFunc |
Public property | CurrentBlockRange | Gets currently highlighted block range. (Inherited from SyntaxEdit.)
Public property | CurrentChar |
Public property | CurrentLine |
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from SyntaxEdit.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultMenu | Gets or sets default context menu for the editor control. (Inherited from SyntaxEdit.)
Public property | DisplayLines | Represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control. (Inherited from SyntaxEdit.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | EditMargin | Represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed. (Inherited from SyntaxEdit.)
Public property | EffectiveVisualTheme | Gets current visual theme. (Inherited from SyntaxEdit.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EventHandlers | Represents object that holds EventHandlers containing list of keys with attached actions. (Inherited from SyntaxEdit.)
Public property | FileName |
Public property | FirstSearch | Gets or sets a value indicating whether control launches text search at first. (Inherited from SyntaxEdit.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from SyntaxEdit.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GotoLineDialog | Gets or sets a dialog prompting for index of the line you need to locate. (Inherited from SyntaxEdit.)
Public property | Gutter | Represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control. (Inherited from SyntaxEdit.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideCaret | Gets or sets a value indicating whether the control should display caret when it has input focus. (Inherited from SyntaxEdit.)
Public property | HighlightCurrentBlock | Specifies that edit control should highlight current block. (Inherited from SyntaxEdit.)
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight begin/end blocks. (Inherited from SyntaxEdit.)
Public property | HighlightReferences | Specifies that edit control should highlight found references. (Inherited from SyntaxEdit.)
Public property | HighlightSearchResults | Indicates whether search results are highlighted while the search dialog is open. (Inherited from SyntaxEdit.)
Public property | HorzSplitEdit | Represents horizontal split view control. (Inherited from SyntaxEdit.)
Public property | HorzSplitter | Represents a horizontal Splitter control allowing to split Edit content horizontally. (Inherited from SyntaxEdit.)
Public property | HyperText | Represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control. (Inherited from SyntaxEdit.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IncrementalSearchString | Return text to search if class is in incremental search state; otherwise return empty string. (Inherited from SyntaxEdit.)
Public property | InCycledSearch | Indicates whether control is in incremental search state. (Inherited from SyntaxEdit.)
Public property | IndentOptions | Gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from SyntaxEdit.)
Public property | InIncrementalSearch | Indicates whether control is in incremental search state. (Inherited from SyntaxEdit.)
Public property | InnerTextSource | Gets inner text source (Inherited from SyntaxEdit.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsCodeCompletionWindowFocused | Indicates whether ICodeCompletionWindow has focus. (Inherited from SyntaxEdit.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSearchFocused | Gets a boolean value indicating whether search dialog box has input focus. (Inherited from SyntaxEdit.)
Public property | KeepCaretOnLostFocus | Keeps caret in visible state even Edit control lost focus. (Inherited from SyntaxEdit.)
Public property | KeyList | Represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure. (Inherited from SyntaxEdit.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | (Overrides SyntaxEditLexer.)
Public property | Lines | Represents object that implements ITextStrings interface containing collection of strings determining control's content. (Inherited from SyntaxEdit.)
Public property | LineSeparator | Represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control. (Inherited from SyntaxEdit.)
Public property | LinesInHeight | Determines how many lines can fit into control's client area. (Inherited from SyntaxEdit.)
Public property | LineSpace | Gets or sets line space between individual lines in the Edit control. (Inherited from SyntaxEdit.)
Public property | LineStyles | Represents an object that implements IEditLineStyles interface holding collection of IEditLineStyle objects each of them determines particular style of the line in the control. (Inherited from SyntaxEdit.)
Public property | LineTerminator | Gets or sets a string value that terminates line. (Inherited from SyntaxEdit.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | MacroRecording | Gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands. (Inherited from SyntaxEdit.)
Public property | MacroRecords | Represents an array containing keyboard commands. (Inherited from SyntaxEdit.)
Public property | MacroSuspendend | Gets or sets a boolean value indicating whether recording is suspended. (Inherited from SyntaxEdit.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control. (Inherited from SyntaxEdit.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified. (Inherited from SyntaxEdit.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavigateOptions | Gets or sets navigating options. (Inherited from SyntaxEdit.)
Public property | OpenSharedEditorFunc | When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment. (Inherited from SyntaxEdit.)
Public property | Outlining | Represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control. (Inherited from SyntaxEdit.)
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from SyntaxEdit.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Pages | Represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages. (Inherited from SyntaxEdit.)
Public property | Painter | Represents an object that implements IPainter interface used to draw control's text. (Inherited from SyntaxEdit.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | Parsers |
Public property | Position | Gets or sets current position within the control's text content. (Inherited from SyntaxEdit.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PrevPosition | Gets previous position within the control's text content. (Inherited from SyntaxEdit.)
Public property | Printing | Represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options. (Inherited from SyntaxEdit.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only. (Inherited from SyntaxEdit.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Scrolling | Represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control. (Inherited from SyntaxEdit.)
Public property | SearchDialog | Gets or sets a dialog box allowing to search for the text or replace it. (Inherited from SyntaxEdit.)
Public property | SearchDialogAppearance | (Inherited from SyntaxEdit.)
Public property | SearchGlobal | Gets or sets a value indicating whether search should be global. (Inherited from SyntaxEdit.)
Public property | SearchLen | Represents length of the last found text. (Inherited from SyntaxEdit.)
Public property | SearchOptions | Gets or sets a value that defines search and replace options. (Inherited from SyntaxEdit.)
Public property | SearchPos | Gets or sets a value that represents position of the last found text. (Inherited from SyntaxEdit.)
Public property | Selection | Represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text. (Inherited from SyntaxEdit.)
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from SyntaxEdit.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Source | (Overrides SyntaxEditSource.)
Public property | Spelling | Represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words. (Inherited from SyntaxEdit.)
Public property | Status |
Public property | StatusText | Obsolete.
Public property | Strings | Represents Lines property in the form of array of strings. (Inherited from SyntaxEdit.)
Public property | SyntaxPaint | Represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content. (Inherited from SyntaxEdit.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the string collection as a single string with the individual lines delimited by carriage returns. (Inherited from SyntaxEdit.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Transparent | Gets or sets a boolean value that indicates whether Edit control should draw its background. (Inherited from SyntaxEdit.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from SyntaxEdit.)
Public property | UseDefaultMenu | Indicates whether edit control should use built in popup menu. (Inherited from SyntaxEdit.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VertSplitEdit | Represents an vertical split view control. (Inherited from SyntaxEdit.)
Public property | VertSplitter | Represents a vertical Splitter control allowing to split Edit content vertically. (Inherited from SyntaxEdit.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualTheme | Gets or sets visual theme for the editor. (Inherited from SyntaxEdit.)
Public property | VisualThemeType | Gets or sets visual theme type for the editor. (Inherited from SyntaxEdit.)
Public property | WhiteSpace | Represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks. (Inherited from SyntaxEdit.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary. (Inherited from SyntaxEdit.)
Public property | WrapAtMargin | Gets or sets a value indicating whether control automatically wraps words at margin position. (Inherited from SyntaxEdit.)
Public property | WrapMargin | Gets position of the wrapping margin. (Inherited from SyntaxEdit.)
Top
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.CanCopy Property

ScriptCodeEditCanCopy Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCopy { get; }
Public ReadOnly Property CanCopy As Boolean
    Get
public:
virtual property bool CanCopy {
    bool get () sealed;
}
abstract CanCopy : bool with get
override CanCopy : bool with get

Property Value

Type: Boolean

Implements

IScriptEditCanCopy
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.CanCut Property

ScriptCodeEditCanCut Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCut { get; }
Public ReadOnly Property CanCut As Boolean
    Get
public:
virtual property bool CanCut {
    bool get () sealed;
}
abstract CanCut : bool with get
override CanCut : bool with get

Property Value

Type: Boolean

Implements

IScriptEditCanCut
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.CanDelete Property

ScriptCodeEditCanDelete Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDelete { get; }
Public ReadOnly Property CanDelete As Boolean
    Get
public:
virtual property bool CanDelete {
    bool get () sealed;
}
abstract CanDelete : bool with get
override CanDelete : bool with get

Property Value

Type: Boolean

Implements

IScriptEditCanDelete
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.CanPaste Property

ScriptCodeEditCanPaste Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPaste { get; }
Public ReadOnly Property CanPaste As Boolean
    Get
public:
virtual property bool CanPaste {
    bool get () sealed;
}
abstract CanPaste : bool with get
override CanPaste : bool with get

Property Value

Type: Boolean

Implements

IScriptEditCanPaste
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.CanRedo Property

ScriptCodeEditCanRedo Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRedo { get; }
Public ReadOnly Property CanRedo As Boolean
    Get
public:
virtual property bool CanRedo {
    bool get () sealed;
}
abstract CanRedo : bool with get
override CanRedo : bool with get

Property Value

Type: Boolean

Implements

IScriptEditCanRedo
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.CanUndo Property

ScriptCodeEditCanUndo Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUndo { get; }
Public ReadOnly Property CanUndo As Boolean
    Get
public:
virtual property bool CanUndo {
    bool get () sealed;
}
abstract CanUndo : bool with get
override CanUndo : bool with get

Property Value

Type: Boolean

Implements

IScriptEditCanUndo
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.CreateParserFunc Property

ScriptCodeEditCreateParserFunc Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CreateParserFunc CreateParserFunc { get; set; }
Public Shared Property CreateParserFunc As CreateParserFunc
    Get
    Set
public:
static property CreateParserFunc^ CreateParserFunc {
    CreateParserFunc^ get ();
    void set (CreateParserFunc^ value);
}
static member CreateParserFunc : CreateParserFunc with get, set

Property Value

Type: CreateParserFunc
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.CurrentChar Property

ScriptCodeEditCurrentChar Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CurrentChar { get; }
Public ReadOnly Property CurrentChar As Integer
    Get
public:
virtual property int CurrentChar {
    int get () sealed;
}
abstract CurrentChar : int with get
override CurrentChar : int with get

Property Value

Type: Int32

Implements

IScriptEditCurrentChar
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.CurrentLine Property

ScriptCodeEditCurrentLine Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CurrentLine { get; }
Public ReadOnly Property CurrentLine As Integer
    Get
public:
virtual property int CurrentLine {
    int get () sealed;
}
abstract CurrentLine : int with get
override CurrentLine : int with get

Property Value

Type: Int32

Implements

IScriptEditCurrentLine
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.FileName Property

ScriptCodeEditFileName Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

IScriptEditFileName
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Lexer Property

ScriptCodeEditLexer Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ILexer Lexer { get; set; }
Public Overrides Property Lexer As ILexer
    Get
    Set
public:
virtual property ILexer^ Lexer {
    ILexer^ get () override;
    void set (ILexer^ value) override;
}
abstract Lexer : ILexer with get, set
override Lexer : ILexer with get, set

Property Value

Type: ILexer

Implements

ISyntaxEditLexer
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Parsers Property

ScriptCodeEditParsers Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDictionary<string, Type> Parsers { get; }
Public Shared ReadOnly Property Parsers As IDictionary(Of String, Type)
    Get
public:
static property IDictionary<String^, Type^>^ Parsers {
    IDictionary<String^, Type^>^ get ();
}
static member Parsers : IDictionary<string, Type> with get

Property Value

Type: IDictionaryString, Type
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Source Property

ScriptCodeEditSource Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ITextSource Source { get; set; }
Public Overrides Property Source As ITextSource
    Get
    Set
public:
virtual property ITextSource^ Source {
    ITextSource^ get () override;
    void set (ITextSource^ value) override;
}
abstract Source : ITextSource with get, set
override Source : ITextSource with get, set

Property Value

Type: ITextSource

Implements

ISyntaxEditSource
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.Status Property

ScriptCodeEditStatus Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCodeEditStatus Status { get; }
Public ReadOnly Property Status As ScriptCodeEditStatus
    Get
public:
virtual property ScriptCodeEditStatus^ Status {
    ScriptCodeEditStatus^ get () sealed;
}
abstract Status : ScriptCodeEditStatus with get
override Status : ScriptCodeEditStatus with get

Property Value

Type: ScriptCodeEditStatus

Implements

IScriptEditStatus
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.StatusText Property

ScriptCodeEditStatusText Property

Note: This API is now obsolete.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Status instead.")]
public string[] StatusText { get; }
<ObsoleteAttribute("Use Status instead.")>
Public ReadOnly Property StatusText As String()
    Get
public:
[ObsoleteAttribute(L"Use Status instead.")]
virtual property array<String^>^ StatusText {
    array<String^>^ get () sealed;
}
[<ObsoleteAttribute("Use Status instead.")>]
abstract StatusText : string[] with get
[<ObsoleteAttribute("Use Status instead.")>]
override StatusText : string[] with get

Property Value

Type: String

Implements

IScriptEditStatusText
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit Events

ScriptCodeEdit Events

The ScriptCodeEdit type exposes the following members.

Events
 | Name | Description
Public event | AutoCorrect | Occurs when control tries to auto correct word being typed. (Inherited from SyntaxEdit.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckHyperText | Occurs when a control needs checking whether some string represents hypertext. (Inherited from SyntaxEdit.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxEdit.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawHeader | Occurs when header or footer part of each page is drawing. (Inherited from SyntaxEdit.)
Public event | DrawUserMargin | Occurs when user margin part of each line is drawing. (Inherited from SyntaxEdit.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | GutterClick | Occurs when the gutter part of Edit control is clicked. (Inherited from SyntaxEdit.)
Public event | GutterDblClick | Occurs when the gutter part of Edit control is double-clicked. (Inherited from SyntaxEdit.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HorizontalScroll | Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving. (Inherited from SyntaxEdit.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | JumpToUrl | Occurs when user attempts to jump to url. (Inherited from SyntaxEdit.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when modified state is changed. (Inherited from SyntaxEdit.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NeedCodeCompletion | Occurs when code completion window is to be displayed. (Inherited from SyntaxEdit.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintBackground | Occurs when Edit control should paint its background in transparent mode. (Inherited from SyntaxEdit.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | ParserChanged |
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PromptOnReplace | Occurs when replace dialog prompts on replace action. (Inherited from SyntaxEdit.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollButtonClick | Occurs when some scrolling button is clicked. (Inherited from SyntaxEdit.)
Public event | SelectionChanged | Occurs when selection bounds are changed. (Inherited from SyntaxEdit.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SourceChanged | Occurs when source changes. (Inherited from SyntaxEdit.)
Public event | SourceStateChanged | Occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc. (Inherited from SyntaxEdit.)
Public event | SplitHorz | Occurs when user splits Edit control horizontally. (Inherited from SyntaxEdit.)
Public event | SplitVert | Occurs when user splits Edit control vertically. (Inherited from SyntaxEdit.)
Public event | StatusChanged |
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged |
Public event | UndoEvent | Occurs when undo/redo operation performed. (Inherited from SyntaxEdit.)
Public event | UnsplitHorz | Occurs when horizontal split view is removed. (Inherited from SyntaxEdit.)
Public event | UnsplitVert | Occurs when vertical split view is removed. (Inherited from SyntaxEdit.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VerticalScroll | Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving. (Inherited from SyntaxEdit.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking. (Inherited from SyntaxEdit.)
Top
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.ParserChanged Event

ScriptCodeEditParserChanged Event

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ParserChanged
Public Event ParserChanged As EventHandler
public:
virtual  event EventHandler^ ParserChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ParserChanged : IEvent<EventHandler,
    EventArgs>
override ParserChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptEditParserChanged
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.StatusChanged Event

ScriptCodeEditStatusChanged Event

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler StatusChanged
Public Event StatusChanged As EventHandler
public:
virtual  event EventHandler^ StatusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract StatusChanged : IEvent<EventHandler,
    EventArgs>
override StatusChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptEditStatusChanged
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEdit.TextChanged Event

ScriptCodeEditTextChanged Event

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler TextChanged
Public Event TextChanged As EventHandler
public:
virtual  event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>
override TextChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptEditTextChanged
See Also

Reference

ScriptCodeEdit Class
Alternet.Editor.Common Namespace


ScriptCodeEditStatus Class

ScriptCodeEditStatus Class
Inheritance Hierarchy
SystemObject
Alternet.Editor.CommonScriptCodeEditStatus

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptCodeEditStatus
Public Class ScriptCodeEditStatus
public ref class ScriptCodeEditStatus
type ScriptCodeEditStatus =  class end

The ScriptCodeEditStatus type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptCodeEditStatus | Initializes a new instance of the ScriptCodeEditStatus class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Modified |
Public property | Overwrite |
Public property | Position |
Top
See Also

Reference

Alternet.Editor.Common Namespace


ScriptCodeEditStatus Constructor

ScriptCodeEditStatus Constructor
Initializes a new instance of the ScriptCodeEditStatus class

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCodeEditStatus(
    string position,
    string modified,
    string overwrite
)
Public Sub New (
    position As String,
    modified As String,
    overwrite As String
)
public:
ScriptCodeEditStatus(
    String^ position,
    String^ modified,
    String^ overwrite
)
new :
        position : string *
        modified : string *
        overwrite : string -> ScriptCodeEditStatus

Parameters

position
Type: SystemString
modified
Type: SystemString
overwrite
Type: SystemString
See Also

Reference

ScriptCodeEditStatus Class
Alternet.Editor.Common Namespace


ScriptCodeEditStatus Methods

ScriptCodeEditStatus Methods

The ScriptCodeEditStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptCodeEditStatus Class
Alternet.Editor.Common Namespace


ScriptCodeEditStatus Properties

ScriptCodeEditStatus Properties

The ScriptCodeEditStatus type exposes the following members.

Properties
 | Name | Description
Public property | Modified |
Public property | Overwrite |
Public property | Position |
Top
See Also

Reference

ScriptCodeEditStatus Class
Alternet.Editor.Common Namespace


ScriptCodeEditStatus.Modified Property

ScriptCodeEditStatusModified Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Modified { get; }
Public ReadOnly Property Modified As String
    Get
public:
property String^ Modified {
    String^ get ();
}
member Modified : string with get

Property Value

Type: String
See Also

Reference

ScriptCodeEditStatus Class
Alternet.Editor.Common Namespace


ScriptCodeEditStatus.Overwrite Property

ScriptCodeEditStatusOverwrite Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Overwrite { get; }
Public ReadOnly Property Overwrite As String
    Get
public:
property String^ Overwrite {
    String^ get ();
}
member Overwrite : string with get

Property Value

Type: String
See Also

Reference

ScriptCodeEditStatus Class
Alternet.Editor.Common Namespace


ScriptCodeEditStatus.Position Property

ScriptCodeEditStatusPosition Property

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Position { get; }
Public ReadOnly Property Position As String
    Get
public:
property String^ Position {
    String^ get ();
}
member Position : string with get

Property Value

Type: String
See Also

Reference

ScriptCodeEditStatus Class
Alternet.Editor.Common Namespace


SolutionExplorer Class

SolutionExplorer Class
Represents methods used to explore particular solution in the TreeView control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.CommonSolutionExplorer

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SolutionExplorer
Public Class SolutionExplorer
public ref class SolutionExplorer
type SolutionExplorer =  class end

The SolutionExplorer type exposes the following members.

Constructors
 | Name | Description
Public method | SolutionExplorer | Initializes a new instance of the SolutionExplorer class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given solution.
Top
Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore solution's content.
Top
See Also

Reference

Alternet.Editor.Common Namespace


SolutionExplorer Constructor

SolutionExplorer Constructor
Initializes a new instance of the SolutionExplorer class with default settings.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolutionExplorer()
Public Sub New
public:
SolutionExplorer()
new : unit -> SolutionExplorer
See Also

Reference

SolutionExplorer Class
Alternet.Editor.Common Namespace


SolutionExplorer Methods

SolutionExplorer Methods

The SolutionExplorer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given solution.
Top
See Also

Reference

SolutionExplorer Class
Alternet.Editor.Common Namespace


SolutionExplorer.UpdateExplorer Method

SolutionExplorerUpdateExplorer Method
Updates explorer content from given solution.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateExplorer(
    DotNetSolution solution
)
Public Sub UpdateExplorer (
    solution As DotNetSolution
)
public:
void UpdateExplorer(
    DotNetSolution^ solution
)
member UpdateExplorer :
        solution : DotNetSolution -> unit

Parameters

solution
Type: Alternet.Common.Projects.DotNetDotNetSolution
Solution to explore.
See Also

Reference

SolutionExplorer Class
Alternet.Editor.Common Namespace


SolutionExplorer Properties

SolutionExplorer Properties

The SolutionExplorer type exposes the following members.

Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore solution's content.
Top
See Also

Reference

SolutionExplorer Class
Alternet.Editor.Common Namespace


SolutionExplorer.ExplorerTree Property

SolutionExplorerExplorerTree Property
Gets or sets System.Windows.Forms.TreeView control used to explore solution's content.

Namespace: Alternet.Editor.Common
Assembly: Alternet.Editor.Common.v7 (in Alternet.Editor.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeView ExplorerTree { get; set; }
Public Property ExplorerTree As TreeView
    Get
    Set
public:
property TreeView^ ExplorerTree {
    TreeView^ get ();
    void set (TreeView^ value);
}
member ExplorerTree : TreeView with get, set

Property Value

Type: TreeView
See Also

Reference

SolutionExplorer Class
Alternet.Editor.Common Namespace


Alternet.Editor.Dialogs Namespace

Alternet.Editor.Dialogs Namespace
Classes
 | Class | Description
Public class | DlgGoto | Represents dialog box that allows moving to a specific line index within Edit control.
Public class | DlgPrintOptions | Represents dialog box to manipulate print settings.
Public class | DlgSearch | Represents a windows form used to provide search and replace dialog.
Public class | PersistentSettings | Represents a base class for classes designed to save/restore key properties of some object.
Public class | PopupPanelDlgSearch | Represents a windows form used to provide search and replace dialog.
Public class | PopupPanelSearchDialog | Represents a dialog box that allows user to search for the text.
Public class | SearchDialog | Represents a dialog box that allows user to search for the text.
Public class | SearchSettings | This class is designed to hold settings for search and replace dialogs.
Interfaces
 | Interface | Description
Public interface | IGotoLineDialog | Represents dialog box that allows moving to a specific line index within Edit control.
Public interface | IPersistentSettings | Represents methods to save/restore key properties of some object.
Public interface | IPrintOptionsDialog | Represents properties and methods to manipulate print settings.
Public interface | ISearchDialog | Represents a dialog box that allows user to search for the text.
Public interface | ISearchSettings | Represents properties and methods to hold settings for search and replace dialogs.


DlgGoto Class

DlgGoto Class
Represents dialog box that allows moving to a specific line index within Edit control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.DialogsDlgGoto

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DlgGoto : Form, IGotoLineDialog
Public Class DlgGoto
    Inherits Form
    Implements IGotoLineDialog
public ref class DlgGoto : public Form,
    IGotoLineDialog
type DlgGoto =
    class
        inherit Form
        interface IGotoLineDialog
    end

The DlgGoto type exposes the following members.

Constructors
 | Name | Description
Public method | DlgGoto | Initializes a new instance of the DlgGoto class with default settings.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(Object, Int32, Int32) | Displays a goto dialog.
Public method | Execute(Object, Int32, Int32, IWin32Window) | Displays a goto dialog.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Line | Gets or sets index of the current line. When dialog executes receives index of the new line.
Public property | Lines | Sets number of lines in the control's text content.
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


DlgGoto Constructor

DlgGoto Constructor
Initializes a new instance of the DlgGoto class with default settings.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DlgGoto()
Public Sub New
public:
DlgGoto()
new : unit -> DlgGoto
See Also

Reference

DlgGoto Class
Alternet.Editor.Dialogs Namespace


DlgGoto Methods

DlgGoto Methods

The DlgGoto type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(Object, Int32, Int32) | Displays a goto dialog.
Public method | Execute(Object, Int32, Int32, IWin32Window) | Displays a goto dialog.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

DlgGoto Class
Alternet.Editor.Dialogs Namespace


DlgGoto.Execute Method

DlgGotoExecute Method
Overload List
 | Name | Description
Public method | Execute(Object, Int32, Int32) | Displays a goto dialog.
Public method | Execute(Object, Int32, Int32, IWin32Window) | Displays a goto dialog.
Top
See Also

Reference

DlgGoto Class
Alternet.Editor.Dialogs Namespace


DlgGoto.Execute Method (Object, Int32, Int32)

DlgGotoExecute Method (Object, Int32, Int32)
Displays a goto dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult Execute(
    Object sender,
    int lines,
    ref int line
)
Public Overridable Function Execute (
    sender As Object,
    lines As Integer,
    ByRef line As Integer
) As DialogResult
public:
virtual DialogResult Execute(
    Object^ sender,
    int lines,
    int% line
)
abstract Execute :
        sender : Object *
        lines : int *
        line : int byref -> DialogResult
override Execute :
        sender : Object *
        lines : int *
        line : int byref -> DialogResult

Parameters

sender
Type: SystemObject
Specifies object owning the dialog.
lines
Type: SystemInt32
Number of lines in the control's text content.
line
Type: SystemInt32
Index of the current line. When dialog executes receives index of the new line.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IGotoLineDialogExecute(Object, Int32, Int32)
See Also

Reference

DlgGoto Class
Execute Overload
Alternet.Editor.Dialogs Namespace


DlgGoto.Execute Method (Object, Int32, Int32, IWin32Window)

DlgGotoExecute Method (Object, Int32, Int32, IWin32Window)
Displays a goto dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult Execute(
    Object sender,
    int lines,
    ref int line,
    IWin32Window owner
)
Public Overridable Function Execute (
    sender As Object,
    lines As Integer,
    ByRef line As Integer,
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Execute(
    Object^ sender,
    int lines,
    int% line,
    IWin32Window^ owner
)
abstract Execute :
        sender : Object *
        lines : int *
        line : int byref *
        owner : IWin32Window -> DialogResult
override Execute :
        sender : Object *
        lines : int *
        line : int byref *
        owner : IWin32Window -> DialogResult

Parameters

sender
Type: SystemObject
Specifies object owning the dialog.
lines
Type: SystemInt32
Number of lines in the control's text content.
line
Type: SystemInt32
Index of the current line. When dialog executes receives index of the new line.
owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

IGotoLineDialogExecute(Object, Int32, Int32, IWin32Window)
See Also

Reference

DlgGoto Class
Execute Overload
Alternet.Editor.Dialogs Namespace


DlgGoto Properties

DlgGoto Properties

The DlgGoto type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Line | Gets or sets index of the current line. When dialog executes receives index of the new line.
Public property | Lines | Sets number of lines in the control's text content.
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DlgGoto Class
Alternet.Editor.Dialogs Namespace


DlgGoto.Line Property

DlgGotoLine Property
Gets or sets index of the current line. When dialog executes receives index of the new line.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

DlgGoto Class
Alternet.Editor.Dialogs Namespace


DlgGoto.Lines Property

DlgGotoLines Property
Sets number of lines in the control's text content.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Lines { set; }
Public WriteOnly Property Lines As Integer
    Set
public:
property int Lines {
    void set (int value);
}
member Lines : int with set

Property Value

Type: Int32
See Also

Reference

DlgGoto Class
Alternet.Editor.Dialogs Namespace


DlgGoto Events

DlgGoto Events

The DlgGoto type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DlgGoto Class
Alternet.Editor.Dialogs Namespace


DlgPrintOptions Class

DlgPrintOptions Class
Represents dialog box to manipulate print settings.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.DialogsDlgPrintOptions

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DlgPrintOptions : Form,
    IPrintOptionsDialog
Public Class DlgPrintOptions
    Inherits Form
    Implements IPrintOptionsDialog
public ref class DlgPrintOptions : public Form,
    IPrintOptionsDialog
type DlgPrintOptions =
    class
        inherit Form
        interface IPrintOptionsDialog
    end

The DlgPrintOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DlgPrintOptions | Initializes a new instance of the DlgPrintOptions class with default settings.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAllowedOptions | Resets the AllowedOptions to the default value.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowedOptions | Gets or sets print options that can be changed by user.
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | FileName | Gets or sets name of file to be printed.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | Options | Gets or sets a collection of flags determining print behavior.
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


DlgPrintOptions Constructor

DlgPrintOptions Constructor
Initializes a new instance of the DlgPrintOptions class with default settings.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DlgPrintOptions()
Public Sub New
public:
DlgPrintOptions()
new : unit -> DlgPrintOptions
See Also

Reference

DlgPrintOptions Class
Alternet.Editor.Dialogs Namespace


DlgPrintOptions Methods

DlgPrintOptions Methods

The DlgPrintOptions type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAllowedOptions | Resets the AllowedOptions to the default value.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetOptions | Resets the Options to the default value.
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

DlgPrintOptions Class
Alternet.Editor.Dialogs Namespace


DlgPrintOptions.ResetAllowedOptions Method

DlgPrintOptionsResetAllowedOptions Method
Resets the AllowedOptions to the default value.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAllowedOptions()
Public Overridable Sub ResetAllowedOptions
public:
virtual void ResetAllowedOptions()
abstract ResetAllowedOptions : unit -> unit
override ResetAllowedOptions : unit -> unit

Implements

IPrintOptionsDialogResetAllowedOptions
See Also

Reference

DlgPrintOptions Class
Alternet.Editor.Dialogs Namespace


DlgPrintOptions.ResetOptions Method

DlgPrintOptionsResetOptions Method
Resets the Options to the default value.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOptions()
Public Overridable Sub ResetOptions
public:
virtual void ResetOptions()
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

IPrintOptionsDialogResetOptions
See Also

Reference

DlgPrintOptions Class
Alternet.Editor.Dialogs Namespace


DlgPrintOptions Properties

DlgPrintOptions Properties

The DlgPrintOptions type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowedOptions | Gets or sets print options that can be changed by user.
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | FileName | Gets or sets name of file to be printed.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | Options | Gets or sets a collection of flags determining print behavior.
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DlgPrintOptions Class
Alternet.Editor.Dialogs Namespace


DlgPrintOptions.AllowedOptions Property

DlgPrintOptionsAllowedOptions Property
Gets or sets print options that can be changed by user.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PrintOptions AllowedOptions { get; set; }
Public Property AllowedOptions As PrintOptions
    Get
    Set
public:
virtual property PrintOptions AllowedOptions {
    PrintOptions get () sealed;
    void set (PrintOptions value) sealed;
}
abstract AllowedOptions : PrintOptions with get, set
override AllowedOptions : PrintOptions with get, set

Property Value

Type: PrintOptions

Implements

IPrintOptionsDialogAllowedOptions
See Also

Reference

DlgPrintOptions Class
Alternet.Editor.Dialogs Namespace


DlgPrintOptions.FileName Property

DlgPrintOptionsFileName Property
Gets or sets name of file to be printed.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

IPrintOptionsDialogFileName
See Also

Reference

DlgPrintOptions Class
Alternet.Editor.Dialogs Namespace


DlgPrintOptions.Options Property

DlgPrintOptionsOptions Property
Gets or sets a collection of flags determining print behavior.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PrintOptions Options { get; set; }
Public Overridable Property Options As PrintOptions
    Get
    Set
public:
virtual property PrintOptions Options {
    PrintOptions get ();
    void set (PrintOptions value);
}
abstract Options : PrintOptions with get, set
override Options : PrintOptions with get, set

Property Value

Type: PrintOptions

Implements

IPrintOptionsDialogOptions
See Also

Reference

DlgPrintOptions Class
Alternet.Editor.Dialogs Namespace


DlgPrintOptions Events

DlgPrintOptions Events

The DlgPrintOptions type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DlgPrintOptions Class
Alternet.Editor.Dialogs Namespace


DlgSearch Class

DlgSearch Class
Represents a windows form used to provide search and replace dialog.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.DialogsDlgSearch

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DlgSearch : Form
Public Class DlgSearch
    Inherits Form
public ref class DlgSearch : public Form
type DlgSearch =
    class
        inherit Form
    end

The DlgSearch type exposes the following members.

Constructors
 | Name | Description
Public method | DlgSearch | Initializes a new instance of the DlgSearch class with default settings.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HighlightAll | Highlights all occurrences of specified string in the text content.
Public method | Init | Resets DlgSearch to the start of search.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Fields
 | Name | Description
Public field | btClose |
Public field | btFindNext |
Public field | btFindOptions |
Public field | btMarkAll |
Public field | btPopup |
Public field | btReplace |
Public field | btReplaceAll |
Public field | btReplacePopup |
Public field | cbFindWhat |
Public field | cbReplaceWith |
Public field | chbMatchCase |
Public field | chbMatchWholeWord |
Public field | chbPromptOnReplace |
Public field | chbSearchHiddenText |
Public field | chbSearchUp |
Public field | chbUseRegularExpressions |
Public field | cmFind |
Public field | laFindWhat |
Public field | laLookIn |
Public field | laReplaceWith |
Public field | menuItem10 |
Public field | menuItem4 |
Public field | miBeginLine |
Public field | miEndLine |
Public field | miEscape |
Public field | miOneCharInSet |
Public field | miOneCharNotInSet |
Public field | miOneOrMore |
Public field | miOr |
Public field | miSingleChar |
Public field | miTag |
Public field | miZeroOrMore |
Public field | tbSearch |
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClearBookmarks | Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsReplace | Gets or sets a boolean value that indicates whether search or replace dialog should be executed.
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | Options | Gets or sets options that defines search and replace behavior.
Public property | OptionsVisible | Indicates whether options group box should be visible.
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | Search | Gets or sets ISearch interface owning the dialog.
Public property | SelectionEnabled | Gets or sets a boolean value that indicates whether search can be executed through selected text.
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


DlgSearch Constructor

DlgSearch Constructor
Initializes a new instance of the DlgSearch class with default settings.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DlgSearch()
Public Sub New
public:
DlgSearch()
new : unit -> DlgSearch
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch Fields

DlgSearch Fields

The DlgSearch type exposes the following members.

Fields
 | Name | Description
Public field | btClose |
Public field | btFindNext |
Public field | btFindOptions |
Public field | btMarkAll |
Public field | btPopup |
Public field | btReplace |
Public field | btReplaceAll |
Public field | btReplacePopup |
Public field | cbFindWhat |
Public field | cbReplaceWith |
Public field | chbMatchCase |
Public field | chbMatchWholeWord |
Public field | chbPromptOnReplace |
Public field | chbSearchHiddenText |
Public field | chbSearchUp |
Public field | chbUseRegularExpressions |
Public field | cmFind |
Public field | laFindWhat |
Public field | laLookIn |
Public field | laReplaceWith |
Public field | menuItem10 |
Public field | menuItem4 |
Public field | miBeginLine |
Public field | miEndLine |
Public field | miEscape |
Public field | miOneCharInSet |
Public field | miOneCharNotInSet |
Public field | miOneOrMore |
Public field | miOr |
Public field | miSingleChar |
Public field | miTag |
Public field | miZeroOrMore |
Public field | tbSearch |
Top
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.btClose Field

DlgSearchbtClose Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Button btClose
Public btClose As Button
public:
Button^ btClose
val mutable btClose: Button

Field Value

Type: Button
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.btFindNext Field

DlgSearchbtFindNext Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Button btFindNext
Public btFindNext As Button
public:
Button^ btFindNext
val mutable btFindNext: Button

Field Value

Type: Button
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.btFindOptions Field

DlgSearchbtFindOptions Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Button btFindOptions
Public btFindOptions As Button
public:
Button^ btFindOptions
val mutable btFindOptions: Button

Field Value

Type: Button
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.btMarkAll Field

DlgSearchbtMarkAll Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Button btMarkAll
Public btMarkAll As Button
public:
Button^ btMarkAll
val mutable btMarkAll: Button

Field Value

Type: Button
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.btPopup Field

DlgSearchbtPopup Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Button btPopup
Public btPopup As Button
public:
Button^ btPopup
val mutable btPopup: Button

Field Value

Type: Button
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.btReplace Field

DlgSearchbtReplace Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Button btReplace
Public btReplace As Button
public:
Button^ btReplace
val mutable btReplace: Button

Field Value

Type: Button
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.btReplaceAll Field

DlgSearchbtReplaceAll Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Button btReplaceAll
Public btReplaceAll As Button
public:
Button^ btReplaceAll
val mutable btReplaceAll: Button

Field Value

Type: Button
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.btReplacePopup Field

DlgSearchbtReplacePopup Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Button btReplacePopup
Public btReplacePopup As Button
public:
Button^ btReplacePopup
val mutable btReplacePopup: Button

Field Value

Type: Button
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.cbFindWhat Field

DlgSearchcbFindWhat Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComboBox cbFindWhat
Public cbFindWhat As ComboBox
public:
ComboBox^ cbFindWhat
val mutable cbFindWhat: ComboBox

Field Value

Type: ComboBox
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.cbReplaceWith Field

DlgSearchcbReplaceWith Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComboBox cbReplaceWith
Public cbReplaceWith As ComboBox
public:
ComboBox^ cbReplaceWith
val mutable cbReplaceWith: ComboBox

Field Value

Type: ComboBox
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.chbMatchCase Field

DlgSearchchbMatchCase Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CheckBox chbMatchCase
Public chbMatchCase As CheckBox
public:
CheckBox^ chbMatchCase
val mutable chbMatchCase: CheckBox

Field Value

Type: CheckBox
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.chbMatchWholeWord Field

DlgSearchchbMatchWholeWord Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CheckBox chbMatchWholeWord
Public chbMatchWholeWord As CheckBox
public:
CheckBox^ chbMatchWholeWord
val mutable chbMatchWholeWord: CheckBox

Field Value

Type: CheckBox
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.chbPromptOnReplace Field

DlgSearchchbPromptOnReplace Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CheckBox chbPromptOnReplace
Public chbPromptOnReplace As CheckBox
public:
CheckBox^ chbPromptOnReplace
val mutable chbPromptOnReplace: CheckBox

Field Value

Type: CheckBox
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.chbSearchHiddenText Field

DlgSearchchbSearchHiddenText Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CheckBox chbSearchHiddenText
Public chbSearchHiddenText As CheckBox
public:
CheckBox^ chbSearchHiddenText
val mutable chbSearchHiddenText: CheckBox

Field Value

Type: CheckBox
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.chbSearchUp Field

DlgSearchchbSearchUp Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CheckBox chbSearchUp
Public chbSearchUp As CheckBox
public:
CheckBox^ chbSearchUp
val mutable chbSearchUp: CheckBox

Field Value

Type: CheckBox
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.chbUseRegularExpressions Field

DlgSearchchbUseRegularExpressions Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CheckBox chbUseRegularExpressions
Public chbUseRegularExpressions As CheckBox
public:
CheckBox^ chbUseRegularExpressions
val mutable chbUseRegularExpressions: CheckBox

Field Value

Type: CheckBox
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.cmFind Field

DlgSearchcmFind Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContextMenuStrip cmFind
Public cmFind As ContextMenuStrip
public:
ContextMenuStrip^ cmFind
val mutable cmFind: ContextMenuStrip

Field Value

Type: ContextMenuStrip
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.laFindWhat Field

DlgSearchlaFindWhat Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Label laFindWhat
Public laFindWhat As Label
public:
Label^ laFindWhat
val mutable laFindWhat: Label

Field Value

Type: Label
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.laLookIn Field

DlgSearchlaLookIn Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Label laLookIn
Public laLookIn As Label
public:
Label^ laLookIn
val mutable laLookIn: Label

Field Value

Type: Label
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.laReplaceWith Field

DlgSearchlaReplaceWith Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Label laReplaceWith
Public laReplaceWith As Label
public:
Label^ laReplaceWith
val mutable laReplaceWith: Label

Field Value

Type: Label
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.menuItem10 Field

DlgSearchmenuItem10 Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripSeparator menuItem10
Public menuItem10 As ToolStripSeparator
public:
ToolStripSeparator^ menuItem10
val mutable menuItem10: ToolStripSeparator

Field Value

Type: ToolStripSeparator
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.menuItem4 Field

DlgSearchmenuItem4 Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripSeparator menuItem4
Public menuItem4 As ToolStripSeparator
public:
ToolStripSeparator^ menuItem4
val mutable menuItem4: ToolStripSeparator

Field Value

Type: ToolStripSeparator
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miBeginLine Field

DlgSearchmiBeginLine Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miBeginLine
Public miBeginLine As ToolStripMenuItem
public:
ToolStripMenuItem^ miBeginLine
val mutable miBeginLine: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miEndLine Field

DlgSearchmiEndLine Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miEndLine
Public miEndLine As ToolStripMenuItem
public:
ToolStripMenuItem^ miEndLine
val mutable miEndLine: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miEscape Field

DlgSearchmiEscape Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miEscape
Public miEscape As ToolStripMenuItem
public:
ToolStripMenuItem^ miEscape
val mutable miEscape: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miOneCharInSet Field

DlgSearchmiOneCharInSet Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miOneCharInSet
Public miOneCharInSet As ToolStripMenuItem
public:
ToolStripMenuItem^ miOneCharInSet
val mutable miOneCharInSet: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miOneCharNotInSet Field

DlgSearchmiOneCharNotInSet Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miOneCharNotInSet
Public miOneCharNotInSet As ToolStripMenuItem
public:
ToolStripMenuItem^ miOneCharNotInSet
val mutable miOneCharNotInSet: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miOneOrMore Field

DlgSearchmiOneOrMore Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miOneOrMore
Public miOneOrMore As ToolStripMenuItem
public:
ToolStripMenuItem^ miOneOrMore
val mutable miOneOrMore: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miOr Field

DlgSearchmiOr Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miOr
Public miOr As ToolStripMenuItem
public:
ToolStripMenuItem^ miOr
val mutable miOr: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miSingleChar Field

DlgSearchmiSingleChar Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miSingleChar
Public miSingleChar As ToolStripMenuItem
public:
ToolStripMenuItem^ miSingleChar
val mutable miSingleChar: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miTag Field

DlgSearchmiTag Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miTag
Public miTag As ToolStripMenuItem
public:
ToolStripMenuItem^ miTag
val mutable miTag: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.miZeroOrMore Field

DlgSearchmiZeroOrMore Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem miZeroOrMore
Public miZeroOrMore As ToolStripMenuItem
public:
ToolStripMenuItem^ miZeroOrMore
val mutable miZeroOrMore: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.tbSearch Field

DlgSearchtbSearch Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TabControl tbSearch
Public tbSearch As TabControl
public:
TabControl^ tbSearch
val mutable tbSearch: TabControl

Field Value

Type: TabControl
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch Methods

DlgSearch Methods

The DlgSearch type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HighlightAll | Highlights all occurrences of specified string in the text content.
Public method | Init | Resets DlgSearch to the start of search.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.HighlightAll Method

DlgSearchHighlightAll Method
Highlights all occurrences of specified string in the text content.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HighlightAll()
Public Sub HighlightAll
public:
void HighlightAll()
member HighlightAll : unit -> unit
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.Init Method

DlgSearchInit Method
Resets DlgSearch to the start of search.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Init()
Public Sub Init
public:
void Init()
member Init : unit -> unit
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch Properties

DlgSearch Properties

The DlgSearch type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClearBookmarks | Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsReplace | Gets or sets a boolean value that indicates whether search or replace dialog should be executed.
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | Options | Gets or sets options that defines search and replace behavior.
Public property | OptionsVisible | Indicates whether options group box should be visible.
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | Search | Gets or sets ISearch interface owning the dialog.
Public property | SelectionEnabled | Gets or sets a boolean value that indicates whether search can be executed through selected text.
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.ClearBookmarks Property

DlgSearchClearBookmarks Property
Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ClearBookmarks { get; set; }
Public Property ClearBookmarks As Boolean
    Get
    Set
public:
property bool ClearBookmarks {
    bool get ();
    void set (bool value);
}
member ClearBookmarks : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.IsReplace Property

DlgSearchIsReplace Property
Gets or sets a boolean value that indicates whether search or replace dialog should be executed.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReplace { get; set; }
Public Property IsReplace As Boolean
    Get
    Set
public:
property bool IsReplace {
    bool get ();
    void set (bool value);
}
member IsReplace : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.Options Property

DlgSearchOptions Property
Gets or sets options that defines search and replace behavior.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchOptions Options { get; set; }
Public Property Options As SearchOptions
    Get
    Set
public:
property SearchOptions Options {
    SearchOptions get ();
    void set (SearchOptions value);
}
member Options : SearchOptions with get, set

Property Value

Type: SearchOptions
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.OptionsVisible Property

DlgSearchOptionsVisible Property
Indicates whether options group box should be visible.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OptionsVisible { get; set; }
Public Property OptionsVisible As Boolean
    Get
    Set
public:
property bool OptionsVisible {
    bool get ();
    void set (bool value);
}
member OptionsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.Search Property

DlgSearchSearch Property
Gets or sets ISearch interface owning the dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISearch Search { get; set; }
Public Property Search As ISearch
    Get
    Set
public:
property ISearch^ Search {
    ISearch^ get ();
    void set (ISearch^ value);
}
member Search : ISearch with get, set

Property Value

Type: ISearch
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch.SelectionEnabled Property

DlgSearchSelectionEnabled Property
Gets or sets a boolean value that indicates whether search can be executed through selected text.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SelectionEnabled { get; set; }
Public Property SelectionEnabled As Boolean
    Get
    Set
public:
property bool SelectionEnabled {
    bool get ();
    void set (bool value);
}
member SelectionEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


DlgSearch Events

DlgSearch Events

The DlgSearch type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DlgSearch Class
Alternet.Editor.Dialogs Namespace


IGotoLineDialog Interface

IGotoLineDialog Interface
Represents dialog box that allows moving to a specific line index within Edit control.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IGotoLineDialog
Public Interface IGotoLineDialog
public interface class IGotoLineDialog
type IGotoLineDialog =  interface end

The IGotoLineDialog type exposes the following members.

Methods
 | Name | Description
Public method | Execute(Object, Int32, Int32) | When implemented by a class, displays a goto dialog.
Public method | Execute(Object, Int32, Int32, IWin32Window) | When implemented by a class, displays a goto dialog.
Top
Properties
 | Name | Description
Public property | Font | When implemented by a class, gets or sets a font for the dialog to use.
Top
Events
 | Name | Description
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control.
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


IGotoLineDialog Methods

IGotoLineDialog Methods
Methods
 | Name | Description
Public method | Execute(Object, Int32, Int32) | When implemented by a class, displays a goto dialog.
Public method | Execute(Object, Int32, Int32, IWin32Window) | When implemented by a class, displays a goto dialog.
Top
See Also

Reference

IGotoLineDialog Interface
Alternet.Editor.Dialogs Namespace


IGotoLineDialog.Execute Method

IGotoLineDialogExecute Method
Overload List
 | Name | Description
Public method | Execute(Object, Int32, Int32) | When implemented by a class, displays a goto dialog.
Public method | Execute(Object, Int32, Int32, IWin32Window) | When implemented by a class, displays a goto dialog.
Top
See Also

Reference

IGotoLineDialog Interface
Alternet.Editor.Dialogs Namespace


IGotoLineDialog.Execute Method (Object, Int32, Int32)

IGotoLineDialogExecute Method (Object, Int32, Int32)
When implemented by a class, displays a goto dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult Execute(
    Object sender,
    int lines,
    ref int line
)
Function Execute (
    sender As Object,
    lines As Integer,
    ByRef line As Integer
) As DialogResult
DialogResult Execute(
    Object^ sender,
    int lines,
    int% line
)
abstract Execute :
        sender : Object *
        lines : int *
        line : int byref -> DialogResult

Parameters

sender
Type: SystemObject
Specifies object owning the dialog.
lines
Type: SystemInt32
Number of lines in the control's text content.
line
Type: SystemInt32
Index of the current line. When dialog executes receives index of the new line.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IGotoLineDialog Interface
Execute Overload
Alternet.Editor.Dialogs Namespace


IGotoLineDialog.Execute Method (Object, Int32, Int32, IWin32Window)

IGotoLineDialogExecute Method (Object, Int32, Int32, IWin32Window)
When implemented by a class, displays a goto dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult Execute(
    Object sender,
    int lines,
    ref int line,
    IWin32Window owner
)
Function Execute (
    sender As Object,
    lines As Integer,
    ByRef line As Integer,
    owner As IWin32Window
) As DialogResult
DialogResult Execute(
    Object^ sender,
    int lines,
    int% line,
    IWin32Window^ owner
)
abstract Execute :
        sender : Object *
        lines : int *
        line : int byref *
        owner : IWin32Window -> DialogResult

Parameters

sender
Type: SystemObject
Specifies object owning the dialog.
lines
Type: SystemInt32
Number of lines in the control's text content.
line
Type: SystemInt32
Index of the current line. When dialog executes receives index of the new line.
owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IGotoLineDialog Interface
Execute Overload
Alternet.Editor.Dialogs Namespace


IGotoLineDialog Properties

IGotoLineDialog Properties

The IGotoLineDialog type exposes the following members.

Properties
 | Name | Description
Public property | Font | When implemented by a class, gets or sets a font for the dialog to use.
Top
See Also

Reference

IGotoLineDialog Interface
Alternet.Editor.Dialogs Namespace


IGotoLineDialog.Font Property

IGotoLineDialogFont Property
When implemented by a class, gets or sets a font for the dialog to use.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Font Font { get; set; }
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

Property Value

Type: Font
See Also

Reference

IGotoLineDialog Interface
Alternet.Editor.Dialogs Namespace


IGotoLineDialog Events

IGotoLineDialog Events

The IGotoLineDialog type exposes the following members.

Events
 | Name | Description
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control.
Top
See Also

Reference

IGotoLineDialog Interface
Alternet.Editor.Dialogs Namespace


IGotoLineDialog.HelpRequested Event

IGotoLineDialogHelpRequested Event
When implemented by a class, occurs when user requests help for a control.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event HelpEventHandler HelpRequested
Event HelpRequested As HelpEventHandler
 event HelpEventHandler^ HelpRequested {
    void add (HelpEventHandler^ value);
    void remove (HelpEventHandler^ value);
}
abstract HelpRequested : IEvent<HelpEventHandler,
    HelpEventArgs>

Value

Type: System.Windows.FormsHelpEventHandler
See Also

Reference

IGotoLineDialog Interface
Alternet.Editor.Dialogs Namespace


IPersistentSettings Interface

IPersistentSettings Interface
Represents methods to save/restore key properties of some object.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPersistentSettings : IImport,
    IExport
Public Interface IPersistentSettings
    Inherits IImport, IExport
public interface class IPersistentSettings : IImport,
    IExport
type IPersistentSettings =
    interface
        interface IImport
        interface IExport
    end

The IPersistentSettings type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the content from another IPersistentSettings object.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


IPersistentSettings Methods

IPersistentSettings Methods

The IPersistentSettings type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the content from another IPersistentSettings object.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Top
See Also

Reference

IPersistentSettings Interface
Alternet.Editor.Dialogs Namespace


IPersistentSettings.Assign Method

IPersistentSettingsAssign Method
When implemented by a class, copies the content from another IPersistentSettings object.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IPersistentSettings source
)
Sub Assign (
    source As IPersistentSettings
)
void Assign(
    IPersistentSettings^ source
)
abstract Assign :
        source : IPersistentSettings -> unit

Parameters

source
Type: Alternet.Editor.DialogsIPersistentSettings
Specifies IPersistentSettings to assign.
See Also

Reference

IPersistentSettings Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog Interface

IPrintOptionsDialog Interface
Represents properties and methods to manipulate print settings.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPrintOptionsDialog
Public Interface IPrintOptionsDialog
public interface class IPrintOptionsDialog
type IPrintOptionsDialog =  interface end

The IPrintOptionsDialog type exposes the following members.

Methods
 | Name | Description
Public method | ResetAllowedOptions | When implemented by a class, resets the AllowedOptions to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ShowDialog | When implemented by a class, runs a print options dialog box.
Public method | ShowDialog(IWin32Window) | When implemented by a class, runs a print options dialog box.
Top
Properties
 | Name | Description
Public property | AllowedOptions | When implemented by a class, gets or sets print options that can be changed by user.
Public property | FileName | When implemented by a class, gets or sets name of file to be printed.
Public property | Font | When implemented by a class, gets or sets a font for the dialog to use.
Public property | Options | When implemented by a class, gets or sets a collection of flags determining print behavior.
Top
Events
 | Name | Description
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control.
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog Methods

IPrintOptionsDialog Methods

The IPrintOptionsDialog type exposes the following members.

Methods
 | Name | Description
Public method | ResetAllowedOptions | When implemented by a class, resets the AllowedOptions to the default value.
Public method | ResetOptions | When implemented by a class, resets the Options to the default value.
Public method | ShowDialog | When implemented by a class, runs a print options dialog box.
Public method | ShowDialog(IWin32Window) | When implemented by a class, runs a print options dialog box.
Top
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.ResetAllowedOptions Method

IPrintOptionsDialogResetAllowedOptions Method
When implemented by a class, resets the AllowedOptions to the default value.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAllowedOptions()
Sub ResetAllowedOptions
void ResetAllowedOptions()
abstract ResetAllowedOptions : unit -> unit
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.ResetOptions Method

IPrintOptionsDialogResetOptions Method
When implemented by a class, resets the Options to the default value.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOptions()
Sub ResetOptions
void ResetOptions()
abstract ResetOptions : unit -> unit
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.ShowDialog Method

IPrintOptionsDialogShowDialog Method
Overload List
 | Name | Description
Public method | ShowDialog | When implemented by a class, runs a print options dialog box.
Public method | ShowDialog(IWin32Window) | When implemented by a class, runs a print options dialog box.
Top
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.ShowDialog Method

IPrintOptionsDialogShowDialog Method
When implemented by a class, runs a print options dialog box.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ShowDialog()
Function ShowDialog As DialogResult
DialogResult ShowDialog()
abstract ShowDialog : unit -> DialogResult

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrintOptionsDialog Interface
ShowDialog Overload
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.ShowDialog Method (IWin32Window)

IPrintOptionsDialogShowDialog Method (IWin32Window)
When implemented by a class, runs a print options dialog box.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult ShowDialog(
    IWin32Window owner
)
Function ShowDialog (
    owner As IWin32Window
) As DialogResult
DialogResult ShowDialog(
    IWin32Window^ owner
)
abstract ShowDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

IPrintOptionsDialog Interface
ShowDialog Overload
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog Properties

IPrintOptionsDialog Properties

The IPrintOptionsDialog type exposes the following members.

Properties
 | Name | Description
Public property | AllowedOptions | When implemented by a class, gets or sets print options that can be changed by user.
Public property | FileName | When implemented by a class, gets or sets name of file to be printed.
Public property | Font | When implemented by a class, gets or sets a font for the dialog to use.
Public property | Options | When implemented by a class, gets or sets a collection of flags determining print behavior.
Top
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.AllowedOptions Property

IPrintOptionsDialogAllowedOptions Property
When implemented by a class, gets or sets print options that can be changed by user.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PrintOptions AllowedOptions { get; set; }
Property AllowedOptions As PrintOptions
    Get
    Set
property PrintOptions AllowedOptions {
    PrintOptions get ();
    void set (PrintOptions value);
}
abstract AllowedOptions : PrintOptions with get, set

Property Value

Type: PrintOptions
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.FileName Property

IPrintOptionsDialogFileName Property
When implemented by a class, gets or sets name of file to be printed.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.Font Property

IPrintOptionsDialogFont Property
When implemented by a class, gets or sets a font for the dialog to use.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Font Font { get; set; }
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

Property Value

Type: Font
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.Options Property

IPrintOptionsDialogOptions Property
When implemented by a class, gets or sets a collection of flags determining print behavior.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PrintOptions Options { get; set; }
Property Options As PrintOptions
    Get
    Set
property PrintOptions Options {
    PrintOptions get ();
    void set (PrintOptions value);
}
abstract Options : PrintOptions with get, set

Property Value

Type: PrintOptions
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog Events

IPrintOptionsDialog Events

The IPrintOptionsDialog type exposes the following members.

Events
 | Name | Description
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control.
Top
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


IPrintOptionsDialog.HelpRequested Event

IPrintOptionsDialogHelpRequested Event
When implemented by a class, occurs when user requests help for a control.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event HelpEventHandler HelpRequested
Event HelpRequested As HelpEventHandler
 event HelpEventHandler^ HelpRequested {
    void add (HelpEventHandler^ value);
    void remove (HelpEventHandler^ value);
}
abstract HelpRequested : IEvent<HelpEventHandler,
    HelpEventArgs>

Value

Type: System.Windows.FormsHelpEventHandler
See Also

Reference

IPrintOptionsDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog Interface

ISearchDialog Interface
Represents a dialog box that allows user to search for the text.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISearchDialog
Public Interface ISearchDialog
public interface class ISearchDialog
type ISearchDialog =  interface end

The ISearchDialog type exposes the following members.

Methods
 | Name | Description
Public method | Close | When implemented by a class, closes the dialog.
Public method | DoneSearch | When implemented by a class, finishes search.
Public method | EnsureVisible | When implemented by a class, ensures that the search dialog box is visible in specified rectangle, moving it if necessary.
Public method | Execute(ISearch, Boolean, Boolean) | When implemented by a class, initializes and runs a search dialog box.
Public method | Execute(ISearch, Boolean, Boolean, IWin32Window) | When implemented by a class, initializes and runs a search dialog box.
Public method | ToggleHiddenText | When implemented by a class, toggles searching through hidden text on/off.
Public method | ToggleMatchCase | When implemented by a class, toggles case sensitive searching on/off.
Public method | ToggleRegularExpressions | When implemented by a class, toggles using regular expressions on/off.
Public method | ToggleSearchUp | When implemented by a class, toggles searching direction towards/backwards.
Public method | ToggleWholeWord | When implemented by a class, toggles searching for whole words on/off.
Top
Properties
 | Name | Description
Public property | Font | When implemented by a class, gets or sets a font for the dialog to use.
Public property | IsFocused | When implemented by a class, gets a boolean value indicating whether dialog box has input focus.
Public property | OwnerForm | When implemented by a class, gets or sets form that owns this dialog.
Public property | SearchSettings | When implemented by a class, gets search settings associated with search dialog.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether dialog box is visible.
Top
Events
 | Name | Description
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control.
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


ISearchDialog Methods

ISearchDialog Methods

The ISearchDialog type exposes the following members.

Methods
 | Name | Description
Public method | Close | When implemented by a class, closes the dialog.
Public method | DoneSearch | When implemented by a class, finishes search.
Public method | EnsureVisible | When implemented by a class, ensures that the search dialog box is visible in specified rectangle, moving it if necessary.
Public method | Execute(ISearch, Boolean, Boolean) | When implemented by a class, initializes and runs a search dialog box.
Public method | Execute(ISearch, Boolean, Boolean, IWin32Window) | When implemented by a class, initializes and runs a search dialog box.
Public method | ToggleHiddenText | When implemented by a class, toggles searching through hidden text on/off.
Public method | ToggleMatchCase | When implemented by a class, toggles case sensitive searching on/off.
Public method | ToggleRegularExpressions | When implemented by a class, toggles using regular expressions on/off.
Public method | ToggleSearchUp | When implemented by a class, toggles searching direction towards/backwards.
Public method | ToggleWholeWord | When implemented by a class, toggles searching for whole words on/off.
Top
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.Close Method

ISearchDialogClose Method
When implemented by a class, closes the dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Close()
Sub Close
void Close()
abstract Close : unit -> unit
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.DoneSearch Method

ISearchDialogDoneSearch Method
When implemented by a class, finishes search.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DoneSearch(
    ISearch search
)
Sub DoneSearch (
    search As ISearch
)
void DoneSearch(
    ISearch^ search
)
abstract DoneSearch :
        search : ISearch -> unit

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch to finish.
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.EnsureVisible Method

ISearchDialogEnsureVisible Method
When implemented by a class, ensures that the search dialog box is visible in specified rectangle, moving it if necessary.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EnsureVisible(
    Rectangle rect
)
Sub EnsureVisible (
    rect As Rectangle
)
void EnsureVisible(
    Rectangle rect
)
abstract EnsureVisible :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
The Rectangle to check.
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.Execute Method

ISearchDialogExecute Method
Overload List
 | Name | Description
Public method | Execute(ISearch, Boolean, Boolean) | When implemented by a class, initializes and runs a search dialog box.
Public method | Execute(ISearch, Boolean, Boolean, IWin32Window) | When implemented by a class, initializes and runs a search dialog box.
Top
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.Execute Method (ISearch, Boolean, Boolean)

ISearchDialogExecute Method (ISearch, Boolean, Boolean)
When implemented by a class, initializes and runs a search dialog box.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult Execute(
    ISearch search,
    bool isModal,
    bool isReplace
)
Function Execute (
    search As ISearch,
    isModal As Boolean,
    isReplace As Boolean
) As DialogResult
DialogResult Execute(
    ISearch^ search,
    bool isModal,
    bool isReplace
)
abstract Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool -> DialogResult

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch interface owning the dialog.
isModal
Type: SystemBoolean
Indicates whether search dialog should appear in modal state.
isReplace
Type: SystemBoolean
Indicates whether search or replace dialog should be executed.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISearchDialog Interface
Execute Overload
Alternet.Editor.Dialogs Namespace


ISearchDialog.Execute Method (ISearch, Boolean, Boolean, IWin32Window)

ISearchDialogExecute Method (ISearch, Boolean, Boolean, IWin32Window)
When implemented by a class, initializes and runs a search dialog box.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DialogResult Execute(
    ISearch search,
    bool isModal,
    bool isReplace,
    IWin32Window owner
)
Function Execute (
    search As ISearch,
    isModal As Boolean,
    isReplace As Boolean,
    owner As IWin32Window
) As DialogResult
DialogResult Execute(
    ISearch^ search,
    bool isModal,
    bool isReplace,
    IWin32Window^ owner
)
abstract Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool *
        owner : IWin32Window -> DialogResult

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch interface owning the dialog.
isModal
Type: SystemBoolean
Indicates whether search dialog should appear in modal state.
isReplace
Type: SystemBoolean
Indicates whether search or replace dialog should be executed.
owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.
See Also

Reference

ISearchDialog Interface
Execute Overload
Alternet.Editor.Dialogs Namespace


ISearchDialog.ToggleHiddenText Method

ISearchDialogToggleHiddenText Method
When implemented by a class, toggles searching through hidden text on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleHiddenText()
Sub ToggleHiddenText
void ToggleHiddenText()
abstract ToggleHiddenText : unit -> unit
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.ToggleMatchCase Method

ISearchDialogToggleMatchCase Method
When implemented by a class, toggles case sensitive searching on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleMatchCase()
Sub ToggleMatchCase
void ToggleMatchCase()
abstract ToggleMatchCase : unit -> unit
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.ToggleRegularExpressions Method

ISearchDialogToggleRegularExpressions Method
When implemented by a class, toggles using regular expressions on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleRegularExpressions()
Sub ToggleRegularExpressions
void ToggleRegularExpressions()
abstract ToggleRegularExpressions : unit -> unit
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.ToggleSearchUp Method

ISearchDialogToggleSearchUp Method
When implemented by a class, toggles searching direction towards/backwards.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleSearchUp()
Sub ToggleSearchUp
void ToggleSearchUp()
abstract ToggleSearchUp : unit -> unit
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.ToggleWholeWord Method

ISearchDialogToggleWholeWord Method
When implemented by a class, toggles searching for whole words on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleWholeWord()
Sub ToggleWholeWord
void ToggleWholeWord()
abstract ToggleWholeWord : unit -> unit
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog Properties

ISearchDialog Properties

The ISearchDialog type exposes the following members.

Properties
 | Name | Description
Public property | Font | When implemented by a class, gets or sets a font for the dialog to use.
Public property | IsFocused | When implemented by a class, gets a boolean value indicating whether dialog box has input focus.
Public property | OwnerForm | When implemented by a class, gets or sets form that owns this dialog.
Public property | SearchSettings | When implemented by a class, gets search settings associated with search dialog.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether dialog box is visible.
Top
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.Font Property

ISearchDialogFont Property
When implemented by a class, gets or sets a font for the dialog to use.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Font Font { get; set; }
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

Property Value

Type: Font
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.IsFocused Property

ISearchDialogIsFocused Property
When implemented by a class, gets a boolean value indicating whether dialog box has input focus.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsFocused { get; }
ReadOnly Property IsFocused As Boolean
    Get
property bool IsFocused {
    bool get ();
}
abstract IsFocused : bool with get

Property Value

Type: Boolean
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.OwnerForm Property

ISearchDialogOwnerForm Property
When implemented by a class, gets or sets form that owns this dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Form OwnerForm { get; set; }
Property OwnerForm As Form
    Get
    Set
property Form^ OwnerForm {
    Form^ get ();
    void set (Form^ value);
}
abstract OwnerForm : Form with get, set

Property Value

Type: Form
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.SearchSettings Property

ISearchDialogSearchSettings Property
When implemented by a class, gets search settings associated with search dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISearchSettings SearchSettings { get; }
ReadOnly Property SearchSettings As ISearchSettings
    Get
property ISearchSettings^ SearchSettings {
    ISearchSettings^ get ();
}
abstract SearchSettings : ISearchSettings with get

Property Value

Type: ISearchSettings
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.Visible Property

ISearchDialogVisible Property
When implemented by a class, gets or sets a value indicating whether dialog box is visible.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog Events

ISearchDialog Events

The ISearchDialog type exposes the following members.

Events
 | Name | Description
Public event | HelpRequested | When implemented by a class, occurs when user requests help for a control.
Top
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchDialog.HelpRequested Event

ISearchDialogHelpRequested Event
When implemented by a class, occurs when user requests help for a control.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event HelpEventHandler HelpRequested
Event HelpRequested As HelpEventHandler
 event HelpEventHandler^ HelpRequested {
    void add (HelpEventHandler^ value);
    void remove (HelpEventHandler^ value);
}
abstract HelpRequested : IEvent<HelpEventHandler,
    HelpEventArgs>

Value

Type: System.Windows.FormsHelpEventHandler
See Also

Reference

ISearchDialog Interface
Alternet.Editor.Dialogs Namespace


ISearchSettings Interface

ISearchSettings Interface
Represents properties and methods to hold settings for search and replace dialogs.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISearchSettings : IPersistentSettings,
    IImport, IExport
Public Interface ISearchSettings
    Inherits IPersistentSettings, IImport, IExport
public interface class ISearchSettings : IPersistentSettings,
    IImport, IExport
type ISearchSettings =
    interface
        interface IPersistentSettings
        interface IImport
        interface IExport
    end

The ISearchSettings type exposes the following members.

Methods
 | Name | Description
Public method | Assign(IPersistentSettings) | When implemented by a class, copies the content from another IPersistentSettings object. (Inherited from IPersistentSettings.)
Public method | Assign(ISearchSettings) | When implemented by a class, copies the content from another ISearchSettings object.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Top
Properties
 | Name | Description
Public property | ClearBookmarks | When implemented by a class, indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.
Public property | GlobalSearch | When implemented by a class, specifies whether search should be global.
Public property | OptionsVisible | When implemented by a class, indicates whether find/replace dialog should display search options.
Public property | ReplaceList | When implemented by a class, represents the replace history for the replace dialog.
Public property | SearchList | When implemented by a class, represents the search history for the search dialog.
Public property | SearchOptions | When implemented by a class, represents options that determine behavior of search or replace dialog.
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


ISearchSettings Methods

ISearchSettings Methods
Methods
 | Name | Description
Public method | Assign(IPersistentSettings) | When implemented by a class, copies the content from another IPersistentSettings object. (Inherited from IPersistentSettings.)
Public method | Assign(ISearchSettings) | When implemented by a class, copies the content from another ISearchSettings object.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Top
See Also

Reference

ISearchSettings Interface
Alternet.Editor.Dialogs Namespace


ISearchSettings.Assign Method

ISearchSettingsAssign Method
Overload List
 | Name | Description
Public method | Assign(IPersistentSettings) | When implemented by a class, copies the content from another IPersistentSettings object. (Inherited from IPersistentSettings.)
Public method | Assign(ISearchSettings) | When implemented by a class, copies the content from another ISearchSettings object.
Top
See Also

Reference

ISearchSettings Interface
Alternet.Editor.Dialogs Namespace


ISearchSettings.Assign Method (ISearchSettings)

ISearchSettingsAssign Method (ISearchSettings)
When implemented by a class, copies the content from another ISearchSettings object.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ISearchSettings source
)
Sub Assign (
    source As ISearchSettings
)
void Assign(
    ISearchSettings^ source
)
abstract Assign :
        source : ISearchSettings -> unit

Parameters

source
Type: Alternet.Editor.DialogsISearchSettings
Specifies ISearchSettings to assign.
See Also

Reference

ISearchSettings Interface
Assign Overload
Alternet.Editor.Dialogs Namespace


ISearchSettings Properties

ISearchSettings Properties

The ISearchSettings type exposes the following members.

Properties
 | Name | Description
Public property | ClearBookmarks | When implemented by a class, indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.
Public property | GlobalSearch | When implemented by a class, specifies whether search should be global.
Public property | OptionsVisible | When implemented by a class, indicates whether find/replace dialog should display search options.
Public property | ReplaceList | When implemented by a class, represents the replace history for the replace dialog.
Public property | SearchList | When implemented by a class, represents the search history for the search dialog.
Public property | SearchOptions | When implemented by a class, represents options that determine behavior of search or replace dialog.
Top
See Also

Reference

ISearchSettings Interface
Alternet.Editor.Dialogs Namespace


ISearchSettings.ClearBookmarks Property

ISearchSettingsClearBookmarks Property
When implemented by a class, indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ClearBookmarks { get; set; }
Property ClearBookmarks As Boolean
    Get
    Set
property bool ClearBookmarks {
    bool get ();
    void set (bool value);
}
abstract ClearBookmarks : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISearchSettings Interface
Alternet.Editor.Dialogs Namespace


ISearchSettings.GlobalSearch Property

ISearchSettingsGlobalSearch Property
When implemented by a class, specifies whether search should be global.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GlobalSearch { get; set; }
Property GlobalSearch As Boolean
    Get
    Set
property bool GlobalSearch {
    bool get ();
    void set (bool value);
}
abstract GlobalSearch : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISearchSettings Interface
Alternet.Editor.Dialogs Namespace


ISearchSettings.OptionsVisible Property

ISearchSettingsOptionsVisible Property
When implemented by a class, indicates whether find/replace dialog should display search options.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OptionsVisible { get; set; }
Property OptionsVisible As Boolean
    Get
    Set
property bool OptionsVisible {
    bool get ();
    void set (bool value);
}
abstract OptionsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISearchSettings Interface
Alternet.Editor.Dialogs Namespace


ISearchSettings.ReplaceList Property

ISearchSettingsReplaceList Property
When implemented by a class, represents the replace history for the replace dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> ReplaceList { get; }
ReadOnly Property ReplaceList As IList(Of String)
    Get
property IList<String^>^ ReplaceList {
    IList<String^>^ get ();
}
abstract ReplaceList : IList<string> with get

Property Value

Type: IListString
See Also

Reference

ISearchSettings Interface
Alternet.Editor.Dialogs Namespace


ISearchSettings.SearchList Property

ISearchSettingsSearchList Property
When implemented by a class, represents the search history for the search dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> SearchList { get; }
ReadOnly Property SearchList As IList(Of String)
    Get
property IList<String^>^ SearchList {
    IList<String^>^ get ();
}
abstract SearchList : IList<string> with get

Property Value

Type: IListString
See Also

Reference

ISearchSettings Interface
Alternet.Editor.Dialogs Namespace


ISearchSettings.SearchOptions Property

ISearchSettingsSearchOptions Property
When implemented by a class, represents options that determine behavior of search or replace dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SearchOptions SearchOptions { get; set; }
Property SearchOptions As SearchOptions
    Get
    Set
property SearchOptions SearchOptions {
    SearchOptions get ();
    void set (SearchOptions value);
}
abstract SearchOptions : SearchOptions with get, set

Property Value

Type: SearchOptions
See Also

Reference

ISearchSettings Interface
Alternet.Editor.Dialogs Namespace


PersistentSettings Class

PersistentSettings Class
Represents a base class for classes designed to save/restore key properties of some object.
Inheritance Hierarchy
SystemObject
Alternet.Editor.DialogsPersistentSettings
Alternet.Editor.DialogsSearchSettings

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PersistentSettings : IPersistentSettings,
    IImport, IExport
Public Class PersistentSettings
    Implements IPersistentSettings, IImport, IExport
public ref class PersistentSettings : IPersistentSettings,
    IImport, IExport
type PersistentSettings =
    class
        interface IPersistentSettings
        interface IImport
        interface IExport
    end

The PersistentSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PersistentSettings | Initializes a new instance of the PersistentSettings class
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents from another IPersistentSettings object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlType | Returns Type object for a class that contain control's settings information. In this class method returns null. Descendant classes can override this method.
Public method | LoadFile(String) | Loads IPersistentSettings content from the specified file.
Public method | LoadFile(String, Encoding) | Loads IPersistentSettings content from the specified file with specified encoding.
Public method | LoadStream(Stream) | Loads IPersistentSettings content from the specified stream with specified encoding.
Public method | LoadStream(TextReader) | Loads IPersistentSettings content from the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads IPersistentSettings content from the specified stream with specified encoding.
Public method | SaveFile(String) | Saves IPersistentSettings content to the specified file.
Public method | SaveFile(String, Encoding) | Saves IPersistentSettings content to the specified file with specific encoding.
Public method | SaveStream(Stream) | Saves IPersistentSettings content to the specified stream.
Public method | SaveStream(TextWriter) | Saves IPersistentSettings content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves IPersistentSettings content to the specified stream with specific encoding.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SerializationInfo | Gets or sets an xml representation of this PersistentSettings object.
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


PersistentSettings Constructor

PersistentSettings Constructor
Initializes a new instance of the PersistentSettings class

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PersistentSettings()
Public Sub New
public:
PersistentSettings()
new : unit -> PersistentSettings
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PersistentSettings Methods

PersistentSettings Methods

The PersistentSettings type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents from another IPersistentSettings object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlType | Returns Type object for a class that contain control's settings information. In this class method returns null. Descendant classes can override this method.
Public method | LoadFile(String) | Loads IPersistentSettings content from the specified file.
Public method | LoadFile(String, Encoding) | Loads IPersistentSettings content from the specified file with specified encoding.
Public method | LoadStream(Stream) | Loads IPersistentSettings content from the specified stream with specified encoding.
Public method | LoadStream(TextReader) | Loads IPersistentSettings content from the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads IPersistentSettings content from the specified stream with specified encoding.
Public method | SaveFile(String) | Saves IPersistentSettings content to the specified file.
Public method | SaveFile(String, Encoding) | Saves IPersistentSettings content to the specified file with specific encoding.
Public method | SaveStream(Stream) | Saves IPersistentSettings content to the specified stream.
Public method | SaveStream(TextWriter) | Saves IPersistentSettings content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves IPersistentSettings content to the specified stream with specific encoding.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PersistentSettings.Assign Method

PersistentSettingsAssign Method
Copies the contents from another IPersistentSettings object.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IPersistentSettings source
)
Public Overridable Sub Assign (
    source As IPersistentSettings
)
public:
virtual void Assign(
    IPersistentSettings^ source
)
abstract Assign :
        source : IPersistentSettings -> unit
override Assign :
        source : IPersistentSettings -> unit

Parameters

source
Type: Alternet.Editor.DialogsIPersistentSettings
Specifies IPersistentSettings to assign.

Implements

IPersistentSettingsAssign(IPersistentSettings)
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PersistentSettings.GetXmlType Method

PersistentSettingsGetXmlType Method
Returns Type object for a class that contain control's settings information. In this class method returns null. Descendant classes can override this method.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Type GetXmlType()
Public Overridable Function GetXmlType As Type
public:
virtual Type^ GetXmlType()
abstract GetXmlType : unit -> Type
override GetXmlType : unit -> Type

Return Value

Type: Type
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PersistentSettings.LoadFile Method

PersistentSettingsLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads IPersistentSettings content from the specified file.
Public method | LoadFile(String, Encoding) | Loads IPersistentSettings content from the specified file with specified encoding.
Top
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PersistentSettings.LoadFile Method (String)

PersistentSettingsLoadFile Method (String)
Loads IPersistentSettings content from the specified file.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName
)
Public Overridable Function LoadFile (
    fileName As String
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool
override LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of the file to load.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String)
See Also

Reference

PersistentSettings Class
LoadFile Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings.LoadFile Method (String, Encoding)

PersistentSettingsLoadFile Method (String, Encoding)
Loads IPersistentSettings content from the specified file with specified encoding.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
) sealed
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of the file to load.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

PersistentSettings Class
LoadFile Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings.LoadStream Method

PersistentSettingsLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | Loads IPersistentSettings content from the specified stream with specified encoding.
Public method | LoadStream(TextReader) | Loads IPersistentSettings content from the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads IPersistentSettings content from the specified stream with specified encoding.
Top
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PersistentSettings.LoadStream Method (Stream)

PersistentSettingsLoadStream Method (Stream)
Loads IPersistentSettings content from the specified stream with specified encoding.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadStream(
    Stream stream
)
Public Function LoadStream (
    stream As Stream
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream
) sealed
abstract LoadStream :
        stream : Stream -> bool
override LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream)
See Also

Reference

PersistentSettings Class
LoadStream Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings.LoadStream Method (TextReader)

PersistentSettingsLoadStream Method (TextReader)
Loads IPersistentSettings content from the specified stream.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader
)
Public Overridable Function LoadStream (
    reader As TextReader
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool
override LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(TextReader)
See Also

Reference

PersistentSettings Class
LoadStream Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings.LoadStream Method (Stream, Encoding)

PersistentSettingsLoadStream Method (Stream, Encoding)
Loads IPersistentSettings content from the specified stream with specified encoding.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadStream(
    Stream stream,
    Encoding encoding
)
Public Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
) sealed
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream, Encoding)
See Also

Reference

PersistentSettings Class
LoadStream Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings.SaveFile Method

PersistentSettingsSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | Saves IPersistentSettings content to the specified file.
Public method | SaveFile(String, Encoding) | Saves IPersistentSettings content to the specified file with specific encoding.
Top
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PersistentSettings.SaveFile Method (String)

PersistentSettingsSaveFile Method (String)
Saves IPersistentSettings content to the specified file.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName
)
Public Overridable Function SaveFile (
    fileName As String
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> bool
override SaveFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of the file to save.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String)
See Also

Reference

PersistentSettings Class
SaveFile Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings.SaveFile Method (String, Encoding)

PersistentSettingsSaveFile Method (String, Encoding)
Saves IPersistentSettings content to the specified file with specific encoding.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveFile(
    string fileName,
    Encoding encoding
)
Public Function SaveFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    Encoding^ encoding
) sealed
abstract SaveFile :
        fileName : string *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Return Value

Type: Boolean

Implements

IExportSaveFile(String, Encoding)
See Also

Reference

PersistentSettings Class
SaveFile Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings.SaveStream Method

PersistentSettingsSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | Saves IPersistentSettings content to the specified stream.
Public method | SaveStream(TextWriter) | Saves IPersistentSettings content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves IPersistentSettings content to the specified stream with specific encoding.
Top
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PersistentSettings.SaveStream Method (Stream)

PersistentSettingsSaveStream Method (Stream)
Saves IPersistentSettings content to the specified stream.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveStream(
    Stream stream
)
Public Function SaveStream (
    stream As Stream
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream
) sealed
abstract SaveStream :
        stream : Stream -> bool
override SaveStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream)
See Also

Reference

PersistentSettings Class
SaveStream Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings.SaveStream Method (TextWriter)

PersistentSettingsSaveStream Method (TextWriter)
Saves IPersistentSettings content to the specified stream.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer
)
Public Overridable Function SaveStream (
    writer As TextWriter
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer
)
abstract SaveStream :
        writer : TextWriter -> bool
override SaveStream :
        writer : TextWriter -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(TextWriter)
See Also

Reference

PersistentSettings Class
SaveStream Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings.SaveStream Method (Stream, Encoding)

PersistentSettingsSaveStream Method (Stream, Encoding)
Saves IPersistentSettings content to the specified stream with specific encoding.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveStream(
    Stream stream,
    Encoding encoding
)
Public Function SaveStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    Encoding^ encoding
) sealed
abstract SaveStream :
        stream : Stream *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream, Encoding)
See Also

Reference

PersistentSettings Class
SaveStream Overload
Alternet.Editor.Dialogs Namespace


PersistentSettings Properties

PersistentSettings Properties

The PersistentSettings type exposes the following members.

Properties
 | Name | Description
Public property | SerializationInfo | Gets or sets an xml representation of this PersistentSettings object.
Top
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PersistentSettings.SerializationInfo Property

PersistentSettingsSerializationInfo Property
Gets or sets an xml representation of this PersistentSettings object.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

PersistentSettings Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch Class

PopupPanelDlgSearch Class
Represents a windows form used to provide search and replace dialog.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Editor.DialogsPopupPanelDlgSearch

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PopupPanelDlgSearch : UserControl,
    IVsControlResourceProvider
Public Class PopupPanelDlgSearch
    Inherits UserControl
    Implements IVsControlResourceProvider
public ref class PopupPanelDlgSearch : public UserControl,
    IVsControlResourceProvider
type PopupPanelDlgSearch =
    class
        inherit UserControl
        interface IVsControlResourceProvider
    end

The PopupPanelDlgSearch type exposes the following members.

Constructors
 | Name | Description
Public method | PopupPanelDlgSearch | Initializes a new instance of the DlgSearch class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the dialog.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HighlightAll | Highlights all occurrences of the search text.
Public method | Init | Resets DlgSearch to the start of search.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IControl) | Displays the dialog with the specified parent control.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Fields
 | Name | Description
Public field | btFindNext |
Public field | btReplace |
Public field | btReplaceAll |
Public field | cbFindWhat |
Public field | cbReplaceWith |
Public field | chbMatchCase |
Public field | chbMatchWholeWord |
Public field | chbUseRegularExpressions |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClearBookmarks | Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsReplace | Gets or sets a boolean value that indicates whether search or replace dialog should be executed.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Options | Gets or sets options that defines search and replace behavior.
Public property | OptionsVisible | Indicates whether options group box should be visible.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Search | Gets or sets ISearch interface owning the dialog.
Public property | SelectionEnabled | Gets or sets a boolean value that indicates whether search can be executed through selected text.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the dialog is closed.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch Constructor

PopupPanelDlgSearch Constructor
Initializes a new instance of the DlgSearch class with default settings.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PopupPanelDlgSearch()
Public Sub New
public:
PopupPanelDlgSearch()
new : unit -> PopupPanelDlgSearch
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch Fields

PopupPanelDlgSearch Fields

The PopupPanelDlgSearch type exposes the following members.

Fields
 | Name | Description
Public field | btFindNext |
Public field | btReplace |
Public field | btReplaceAll |
Public field | cbFindWhat |
Public field | cbReplaceWith |
Public field | chbMatchCase |
Public field | chbMatchWholeWord |
Public field | chbUseRegularExpressions |
Top
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.btFindNext Field

PopupPanelDlgSearchbtFindNext Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VsButton btFindNext
Public btFindNext As VsButton
public:
VsButton^ btFindNext
val mutable btFindNext: VsButton

Field Value

Type: VsButton
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.btReplace Field

PopupPanelDlgSearchbtReplace Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VsButton btReplace
Public btReplace As VsButton
public:
VsButton^ btReplace
val mutable btReplace: VsButton

Field Value

Type: VsButton
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.btReplaceAll Field

PopupPanelDlgSearchbtReplaceAll Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VsButton btReplaceAll
Public btReplaceAll As VsButton
public:
VsButton^ btReplaceAll
val mutable btReplaceAll: VsButton

Field Value

Type: VsButton
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.cbFindWhat Field

PopupPanelDlgSearchcbFindWhat Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComboBox cbFindWhat
Public cbFindWhat As ComboBox
public:
ComboBox^ cbFindWhat
val mutable cbFindWhat: ComboBox

Field Value

Type: ComboBox
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.cbReplaceWith Field

PopupPanelDlgSearchcbReplaceWith Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComboBox cbReplaceWith
Public cbReplaceWith As ComboBox
public:
ComboBox^ cbReplaceWith
val mutable cbReplaceWith: ComboBox

Field Value

Type: ComboBox
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.chbMatchCase Field

PopupPanelDlgSearchchbMatchCase Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VsToggleButton chbMatchCase
Public chbMatchCase As VsToggleButton
public:
VsToggleButton^ chbMatchCase
val mutable chbMatchCase: VsToggleButton

Field Value

Type: VsToggleButton
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.chbMatchWholeWord Field

PopupPanelDlgSearchchbMatchWholeWord Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VsToggleButton chbMatchWholeWord
Public chbMatchWholeWord As VsToggleButton
public:
VsToggleButton^ chbMatchWholeWord
val mutable chbMatchWholeWord: VsToggleButton

Field Value

Type: VsToggleButton
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.chbUseRegularExpressions Field

PopupPanelDlgSearchchbUseRegularExpressions Field

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VsToggleButton chbUseRegularExpressions
Public chbUseRegularExpressions As VsToggleButton
public:
VsToggleButton^ chbUseRegularExpressions
val mutable chbUseRegularExpressions: VsToggleButton

Field Value

Type: VsToggleButton
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch Methods

PopupPanelDlgSearch Methods

The PopupPanelDlgSearch type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the dialog.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HighlightAll | Highlights all occurrences of the search text.
Public method | Init | Resets DlgSearch to the start of search.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IControl) | Displays the dialog with the specified parent control.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.Close Method

PopupPanelDlgSearchClose Method
Closes the dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.HighlightAll Method

PopupPanelDlgSearchHighlightAll Method
Highlights all occurrences of the search text.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HighlightAll()
Public Sub HighlightAll
public:
void HighlightAll()
member HighlightAll : unit -> unit
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.Init Method

PopupPanelDlgSearchInit Method
Resets DlgSearch to the start of search.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Init()
Public Sub Init
public:
void Init()
member Init : unit -> unit
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.Show Method

PopupPanelDlgSearchShow Method
Overload List
 | Name | Description
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IControl) | Displays the dialog with the specified parent control.
Top
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.Show Method (IControl)

PopupPanelDlgSearchShow Method (IControl)
Displays the dialog with the specified parent control.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Show(
    IControl parentControl
)
Public Sub Show (
    parentControl As IControl
)
public:
void Show(
    IControl^ parentControl
)
member Show :
        parentControl : IControl -> unit

Parameters

parentControl
Type: Alternet.CommonIControl
Parent container of the dialog.
See Also

Reference

PopupPanelDlgSearch Class
Show Overload
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch Properties

PopupPanelDlgSearch Properties

The PopupPanelDlgSearch type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClearBookmarks | Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsReplace | Gets or sets a boolean value that indicates whether search or replace dialog should be executed.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Options | Gets or sets options that defines search and replace behavior.
Public property | OptionsVisible | Indicates whether options group box should be visible.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Search | Gets or sets ISearch interface owning the dialog.
Public property | SelectionEnabled | Gets or sets a boolean value that indicates whether search can be executed through selected text.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.ClearBookmarks Property

PopupPanelDlgSearchClearBookmarks Property
Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ClearBookmarks { get; set; }
Public Property ClearBookmarks As Boolean
    Get
    Set
public:
property bool ClearBookmarks {
    bool get ();
    void set (bool value);
}
member ClearBookmarks : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.IsReplace Property

PopupPanelDlgSearchIsReplace Property
Gets or sets a boolean value that indicates whether search or replace dialog should be executed.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReplace { get; set; }
Public Property IsReplace As Boolean
    Get
    Set
public:
property bool IsReplace {
    bool get ();
    void set (bool value);
}
member IsReplace : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.Options Property

PopupPanelDlgSearchOptions Property
Gets or sets options that defines search and replace behavior.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchOptions Options { get; set; }
Public Property Options As SearchOptions
    Get
    Set
public:
property SearchOptions Options {
    SearchOptions get ();
    void set (SearchOptions value);
}
member Options : SearchOptions with get, set

Property Value

Type: SearchOptions
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.OptionsVisible Property

PopupPanelDlgSearchOptionsVisible Property
Indicates whether options group box should be visible.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OptionsVisible { get; set; }
Public Property OptionsVisible As Boolean
    Get
    Set
public:
property bool OptionsVisible {
    bool get ();
    void set (bool value);
}
member OptionsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.Search Property

PopupPanelDlgSearchSearch Property
Gets or sets ISearch interface owning the dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISearch Search { get; set; }
Public Property Search As ISearch
    Get
    Set
public:
property ISearch^ Search {
    ISearch^ get ();
    void set (ISearch^ value);
}
member Search : ISearch with get, set

Property Value

Type: ISearch
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.SelectionEnabled Property

PopupPanelDlgSearchSelectionEnabled Property
Gets or sets a boolean value that indicates whether search can be executed through selected text.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SelectionEnabled { get; set; }
Public Property SelectionEnabled As Boolean
    Get
    Set
public:
property bool SelectionEnabled {
    bool get ();
    void set (bool value);
}
member SelectionEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch Events

PopupPanelDlgSearch Events

The PopupPanelDlgSearch type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the dialog is closed.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelDlgSearch.Closed Event

PopupPanelDlgSearchClosed Event
Occurs when the dialog is closed.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Closed
Public Event Closed As EventHandler
public:
 event EventHandler^ Closed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Closed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PopupPanelDlgSearch Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog Class

PopupPanelSearchDialog Class
Represents a dialog box that allows user to search for the text.
Inheritance Hierarchy
SystemObject
Alternet.Editor.DialogsPopupPanelSearchDialog

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PopupPanelSearchDialog : ISearchDialog
Public Class PopupPanelSearchDialog
    Implements ISearchDialog
public ref class PopupPanelSearchDialog : ISearchDialog
type PopupPanelSearchDialog =
    class
        interface ISearchDialog
    end

The PopupPanelSearchDialog type exposes the following members.

Constructors
 | Name | Description
Public method | PopupPanelSearchDialog | Initializes a new instance of the PopupPanelSearchDialog class
Top
Methods
 | Name | Description
Public method | Close | Closes the dialog.
 | Done | Finishes search.
Public method | DoneSearch | Finishes search.
Public method | EnableRegularExpressions | When implemented by a class, enables/disables regular expressions.
Public method | EnsureVisible | Ensures that the search dialog box is visible in specified rectangle, moving it if necessary.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ISearch, Boolean, Boolean) | Initializes and runs a search dialog box.
Public method | Execute(ISearch, Boolean, Boolean, IWin32Window) | Initializes and runs a search dialog box.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowRegularExpressions | When implemented by a class, shows/hide regular expressions.
Public method | ToggleHiddenText | Toggles searching through hidden text on/off.
Public method | ToggleMatchCase | Toggles case sensitive searching on/off.
Public method | TogglePromptOnReplace | Toggles prompting before replacing on/off.
Public method | ToggleRegularExpressions | Toggles using regular expressions on/off.
Public method | ToggleSearchUp | Toggles searching direction towards/backwards.
Public method | ToggleWholeWord | Toggles searching for whole words on/off.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Font | Gets or sets a font for the dialog to use.
Public property | IsFocused | Gets a boolean value indicating whether dialog box is visible.
Public property | OwnerForm | Gets or sets form that owns this dialog.
Public property | SearchDlg | Gets dialog form associated with search dialog.
Public property | SearchSettings | Gets search settings associated with search dialog.
Public property | Visible | Gets or sets a value indicating whether dialog box is visible.
Top
Events
 | Name | Description
Public event | HelpRequested | Occurs when user requests help for a control.
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog Constructor

PopupPanelSearchDialog Constructor
Initializes a new instance of the PopupPanelSearchDialog class

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PopupPanelSearchDialog()
Public Sub New
public:
PopupPanelSearchDialog()
new : unit -> PopupPanelSearchDialog
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog Methods

PopupPanelSearchDialog Methods

The PopupPanelSearchDialog type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the dialog.
 | Done | Finishes search.
Public method | DoneSearch | Finishes search.
Public method | EnableRegularExpressions | When implemented by a class, enables/disables regular expressions.
Public method | EnsureVisible | Ensures that the search dialog box is visible in specified rectangle, moving it if necessary.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ISearch, Boolean, Boolean) | Initializes and runs a search dialog box.
Public method | Execute(ISearch, Boolean, Boolean, IWin32Window) | Initializes and runs a search dialog box.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowRegularExpressions | When implemented by a class, shows/hide regular expressions.
Public method | ToggleHiddenText | Toggles searching through hidden text on/off.
Public method | ToggleMatchCase | Toggles case sensitive searching on/off.
Public method | TogglePromptOnReplace | Toggles prompting before replacing on/off.
Public method | ToggleRegularExpressions | Toggles using regular expressions on/off.
Public method | ToggleSearchUp | Toggles searching direction towards/backwards.
Public method | ToggleWholeWord | Toggles searching for whole words on/off.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.Close Method

PopupPanelSearchDialogClose Method
Closes the dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Close()
Public Overridable Sub Close
public:
virtual void Close()
abstract Close : unit -> unit
override Close : unit -> unit

Implements

ISearchDialogClose
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.Done Method

PopupPanelSearchDialogDone Method
Finishes search.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Done(
    ISearch search
)
Public Shared Sub Done (
    search As ISearch
)
public:
static void Done(
    ISearch^ search
)
static member Done :
        search : ISearch -> unit

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch to finish.
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.DoneSearch Method

PopupPanelSearchDialogDoneSearch Method
Finishes search.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DoneSearch(
    ISearch search
)
Public Overridable Sub DoneSearch (
    search As ISearch
)
public:
virtual void DoneSearch(
    ISearch^ search
)
abstract DoneSearch :
        search : ISearch -> unit
override DoneSearch :
        search : ISearch -> unit

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch to finish.

Implements

ISearchDialogDoneSearch(ISearch)
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.EnableRegularExpressions Method

PopupPanelSearchDialogEnableRegularExpressions Method
When implemented by a class, enables/disables regular expressions.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableRegularExpressions(
    bool enable
)
Public Sub EnableRegularExpressions (
    enable As Boolean
)
public:
void EnableRegularExpressions(
    bool enable
)
member EnableRegularExpressions :
        enable : bool -> unit

Parameters

enable
Type: SystemBoolean
Specifies whether regular expressions checkbox should be enabled.
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.EnsureVisible Method

PopupPanelSearchDialogEnsureVisible Method
Ensures that the search dialog box is visible in specified rectangle, moving it if necessary.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EnsureVisible(
    Rectangle rect
)
Public Overridable Sub EnsureVisible (
    rect As Rectangle
)
public:
virtual void EnsureVisible(
    Rectangle rect
)
abstract EnsureVisible :
        rect : Rectangle -> unit
override EnsureVisible :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
The Rectangle to check.

Implements

ISearchDialogEnsureVisible(Rectangle)
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.Execute Method

PopupPanelSearchDialogExecute Method
Overload List
 | Name | Description
Public method | Execute(ISearch, Boolean, Boolean) | Initializes and runs a search dialog box.
Public method | Execute(ISearch, Boolean, Boolean, IWin32Window) | Initializes and runs a search dialog box.
Top
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.Execute Method (ISearch, Boolean, Boolean)

PopupPanelSearchDialogExecute Method (ISearch, Boolean, Boolean)
Initializes and runs a search dialog box.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult Execute(
    ISearch search,
    bool isModal,
    bool isReplace
)
Public Overridable Function Execute (
    search As ISearch,
    isModal As Boolean,
    isReplace As Boolean
) As DialogResult
public:
virtual DialogResult Execute(
    ISearch^ search,
    bool isModal,
    bool isReplace
)
abstract Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool -> DialogResult
override Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool -> DialogResult

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch interface owning the dialog.
isModal
Type: SystemBoolean
Indicates whether search dialog should appear in modal state.
isReplace
Type: SystemBoolean
Indicates whether search or replace dialog should be executed.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISearchDialogExecute(ISearch, Boolean, Boolean)
See Also

Reference

PopupPanelSearchDialog Class
Execute Overload
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.Execute Method (ISearch, Boolean, Boolean, IWin32Window)

PopupPanelSearchDialogExecute Method (ISearch, Boolean, Boolean, IWin32Window)
Initializes and runs a search dialog box.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DialogResult Execute(
    ISearch search,
    bool isModal,
    bool isReplace,
    IWin32Window owner
)
Public Function Execute (
    search As ISearch,
    isModal As Boolean,
    isReplace As Boolean,
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Execute(
    ISearch^ search,
    bool isModal,
    bool isReplace,
    IWin32Window^ owner
) sealed
abstract Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool *
        owner : IWin32Window -> DialogResult
override Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool *
        owner : IWin32Window -> DialogResult

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch interface owning the dialog.
isModal
Type: SystemBoolean
Indicates whether search dialog should appear in modal state.
isReplace
Type: SystemBoolean
Indicates whether search or replace dialog should be executed.
owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISearchDialogExecute(ISearch, Boolean, Boolean, IWin32Window)
See Also

Reference

PopupPanelSearchDialog Class
Execute Overload
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.ShowRegularExpressions Method

PopupPanelSearchDialogShowRegularExpressions Method
When implemented by a class, shows/hide regular expressions.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowRegularExpressions(
    bool show
)
Public Sub ShowRegularExpressions (
    show As Boolean
)
public:
void ShowRegularExpressions(
    bool show
)
member ShowRegularExpressions :
        show : bool -> unit

Parameters

show
Type: SystemBoolean
Specifies whether regular expressions checkbox should be visible.
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.ToggleHiddenText Method

PopupPanelSearchDialogToggleHiddenText Method
Toggles searching through hidden text on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleHiddenText()
Public Overridable Sub ToggleHiddenText
public:
virtual void ToggleHiddenText()
abstract ToggleHiddenText : unit -> unit
override ToggleHiddenText : unit -> unit

Implements

ISearchDialogToggleHiddenText
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.ToggleMatchCase Method

PopupPanelSearchDialogToggleMatchCase Method
Toggles case sensitive searching on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleMatchCase()
Public Overridable Sub ToggleMatchCase
public:
virtual void ToggleMatchCase()
abstract ToggleMatchCase : unit -> unit
override ToggleMatchCase : unit -> unit

Implements

ISearchDialogToggleMatchCase
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.TogglePromptOnReplace Method

PopupPanelSearchDialogTogglePromptOnReplace Method
Toggles prompting before replacing on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void TogglePromptOnReplace()
Public Sub TogglePromptOnReplace
public:
void TogglePromptOnReplace()
member TogglePromptOnReplace : unit -> unit
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.ToggleRegularExpressions Method

PopupPanelSearchDialogToggleRegularExpressions Method
Toggles using regular expressions on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleRegularExpressions()
Public Overridable Sub ToggleRegularExpressions
public:
virtual void ToggleRegularExpressions()
abstract ToggleRegularExpressions : unit -> unit
override ToggleRegularExpressions : unit -> unit

Implements

ISearchDialogToggleRegularExpressions
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.ToggleSearchUp Method

PopupPanelSearchDialogToggleSearchUp Method
Toggles searching direction towards/backwards.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleSearchUp()
Public Overridable Sub ToggleSearchUp
public:
virtual void ToggleSearchUp()
abstract ToggleSearchUp : unit -> unit
override ToggleSearchUp : unit -> unit

Implements

ISearchDialogToggleSearchUp
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.ToggleWholeWord Method

PopupPanelSearchDialogToggleWholeWord Method
Toggles searching for whole words on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleWholeWord()
Public Overridable Sub ToggleWholeWord
public:
virtual void ToggleWholeWord()
abstract ToggleWholeWord : unit -> unit
override ToggleWholeWord : unit -> unit

Implements

ISearchDialogToggleWholeWord
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog Properties

PopupPanelSearchDialog Properties

The PopupPanelSearchDialog type exposes the following members.

Properties
 | Name | Description
Public property | Font | Gets or sets a font for the dialog to use.
Public property | IsFocused | Gets a boolean value indicating whether dialog box is visible.
Public property | OwnerForm | Gets or sets form that owns this dialog.
Public property | SearchDlg | Gets dialog form associated with search dialog.
Public property | SearchSettings | Gets search settings associated with search dialog.
Public property | Visible | Gets or sets a value indicating whether dialog box is visible.
Top
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.Font Property

PopupPanelSearchDialogFont Property
Gets or sets a font for the dialog to use.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
public:
virtual property Font^ Font {
    Font^ get () sealed;
    void set (Font^ value) sealed;
}
abstract Font : Font with get, set
override Font : Font with get, set

Property Value

Type: Font

Implements

ISearchDialogFont
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.IsFocused Property

PopupPanelSearchDialogIsFocused Property
Gets a boolean value indicating whether dialog box is visible.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFocused { get; }
Public ReadOnly Property IsFocused As Boolean
    Get
public:
virtual property bool IsFocused {
    bool get () sealed;
}
abstract IsFocused : bool with get
override IsFocused : bool with get

Property Value

Type: Boolean

Implements

ISearchDialogIsFocused
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.OwnerForm Property

PopupPanelSearchDialogOwnerForm Property
Gets or sets form that owns this dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Form OwnerForm { get; set; }
Public Property OwnerForm As Form
    Get
    Set
public:
virtual property Form^ OwnerForm {
    Form^ get () sealed;
    void set (Form^ value) sealed;
}
abstract OwnerForm : Form with get, set
override OwnerForm : Form with get, set

Property Value

Type: Form

Implements

ISearchDialogOwnerForm
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.SearchDlg Property

PopupPanelSearchDialogSearchDlg Property
Gets dialog form associated with search dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PopupPanelDlgSearch SearchDlg { get; }
Public Overridable ReadOnly Property SearchDlg As PopupPanelDlgSearch
    Get
public:
virtual property PopupPanelDlgSearch^ SearchDlg {
    PopupPanelDlgSearch^ get ();
}
abstract SearchDlg : PopupPanelDlgSearch with get
override SearchDlg : PopupPanelDlgSearch with get

Property Value

Type: PopupPanelDlgSearch
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.SearchSettings Property

PopupPanelSearchDialogSearchSettings Property
Gets search settings associated with search dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISearchSettings SearchSettings { get; }
Public Overridable ReadOnly Property SearchSettings As ISearchSettings
    Get
public:
virtual property ISearchSettings^ SearchSettings {
    ISearchSettings^ get ();
}
abstract SearchSettings : ISearchSettings with get
override SearchSettings : ISearchSettings with get

Property Value

Type: ISearchSettings

Implements

ISearchDialogSearchSettings
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.Visible Property

PopupPanelSearchDialogVisible Property
Gets or sets a value indicating whether dialog box is visible.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

ISearchDialogVisible
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog Events

PopupPanelSearchDialog Events

The PopupPanelSearchDialog type exposes the following members.

Events
 | Name | Description
Public event | HelpRequested | Occurs when user requests help for a control.
Top
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


PopupPanelSearchDialog.HelpRequested Event

PopupPanelSearchDialogHelpRequested Event
Occurs when user requests help for a control.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual event HelpEventHandler HelpRequested
Public Overridable Event HelpRequested As HelpEventHandler
public:
virtual  event HelpEventHandler^ HelpRequested {
    void add (HelpEventHandler^ value);
    void remove (HelpEventHandler^ value);
}
abstract HelpRequested : IEvent<HelpEventHandler,
    HelpEventArgs>
override HelpRequested : IEvent<HelpEventHandler,
    HelpEventArgs>

Value

Type: System.Windows.FormsHelpEventHandler

Implements

ISearchDialogHelpRequested
See Also

Reference

PopupPanelSearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog Class

SearchDialog Class
Represents a dialog box that allows user to search for the text.
Inheritance Hierarchy
SystemObject
Alternet.Editor.DialogsSearchDialog

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SearchDialog : ISearchDialog
Public Class SearchDialog
    Implements ISearchDialog
public ref class SearchDialog : ISearchDialog
type SearchDialog =
    class
        interface ISearchDialog
    end

The SearchDialog type exposes the following members.

Constructors
 | Name | Description
Public method | SearchDialog | Initializes a new instance of the SearchDialog class
Top
Methods
 | Name | Description
Public method | Close | Closes the dialog.
 | Done | Finishes search.
Public method | DoneSearch | Finishes search.
Public method | EnableRegularExpressions | When implemented by a class, enables/disables regular expressions.
Public method | EnsureVisible | Ensures that the search dialog box is visible in specified rectangle, moving it if necessary.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ISearch, Boolean, Boolean) | Initializes and runs a search dialog box.
Public method | Execute(ISearch, Boolean, Boolean, IWin32Window) | Initializes and runs a search dialog box.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowRegularExpressions | When implemented by a class, shows/hide regular expressions.
Public method | ToggleHiddenText | Toggles searching through hidden text on/off.
Public method | ToggleMatchCase | Toggles case sensitive searching on/off.
Public method | TogglePromptOnReplace | Toggles prompting before replacing on/off.
Public method | ToggleRegularExpressions | Toggles using regular expressions on/off.
Public method | ToggleSearchUp | Toggles searching direction towards/backwards.
Public method | ToggleWholeWord | Toggles searching for whole words on/off.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Font | Gets or sets a font for the dialog to use.
Public property | IsFocused | Gets a boolean value indicating whether dialog box is visible.
Public property | OwnerForm | Gets or sets form that owns this dialog.
Public property | SearchDlg | Gets dialog form associated with search dialog.
Public property | SearchSettings | Gets search settings associated with search dialog.
Public property | Visible | Gets or sets a value indicating whether dialog box is visible.
Top
Events
 | Name | Description
Public event | HelpRequested | Occurs when user requests help for a control.
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


SearchDialog Constructor

SearchDialog Constructor
Initializes a new instance of the SearchDialog class

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchDialog()
Public Sub New
public:
SearchDialog()
new : unit -> SearchDialog
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog Methods

SearchDialog Methods

The SearchDialog type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the dialog.
 | Done | Finishes search.
Public method | DoneSearch | Finishes search.
Public method | EnableRegularExpressions | When implemented by a class, enables/disables regular expressions.
Public method | EnsureVisible | Ensures that the search dialog box is visible in specified rectangle, moving it if necessary.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ISearch, Boolean, Boolean) | Initializes and runs a search dialog box.
Public method | Execute(ISearch, Boolean, Boolean, IWin32Window) | Initializes and runs a search dialog box.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowRegularExpressions | When implemented by a class, shows/hide regular expressions.
Public method | ToggleHiddenText | Toggles searching through hidden text on/off.
Public method | ToggleMatchCase | Toggles case sensitive searching on/off.
Public method | TogglePromptOnReplace | Toggles prompting before replacing on/off.
Public method | ToggleRegularExpressions | Toggles using regular expressions on/off.
Public method | ToggleSearchUp | Toggles searching direction towards/backwards.
Public method | ToggleWholeWord | Toggles searching for whole words on/off.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.Close Method

SearchDialogClose Method
Closes the dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Close()
Public Overridable Sub Close
public:
virtual void Close()
abstract Close : unit -> unit
override Close : unit -> unit

Implements

ISearchDialogClose
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.Done Method

SearchDialogDone Method
Finishes search.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Done(
    ISearch search
)
Public Shared Sub Done (
    search As ISearch
)
public:
static void Done(
    ISearch^ search
)
static member Done :
        search : ISearch -> unit

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch to finish.
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.DoneSearch Method

SearchDialogDoneSearch Method
Finishes search.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DoneSearch(
    ISearch search
)
Public Overridable Sub DoneSearch (
    search As ISearch
)
public:
virtual void DoneSearch(
    ISearch^ search
)
abstract DoneSearch :
        search : ISearch -> unit
override DoneSearch :
        search : ISearch -> unit

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch to finish.

Implements

ISearchDialogDoneSearch(ISearch)
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.EnableRegularExpressions Method

SearchDialogEnableRegularExpressions Method
When implemented by a class, enables/disables regular expressions.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableRegularExpressions(
    bool enable
)
Public Sub EnableRegularExpressions (
    enable As Boolean
)
public:
void EnableRegularExpressions(
    bool enable
)
member EnableRegularExpressions :
        enable : bool -> unit

Parameters

enable
Type: SystemBoolean
Specifies whether regular expressions checkbox should be enabled.
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.EnsureVisible Method

SearchDialogEnsureVisible Method
Ensures that the search dialog box is visible in specified rectangle, moving it if necessary.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EnsureVisible(
    Rectangle rect
)
Public Overridable Sub EnsureVisible (
    rect As Rectangle
)
public:
virtual void EnsureVisible(
    Rectangle rect
)
abstract EnsureVisible :
        rect : Rectangle -> unit
override EnsureVisible :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
The Rectangle to check.

Implements

ISearchDialogEnsureVisible(Rectangle)
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.Execute Method

SearchDialogExecute Method
Overload List
 | Name | Description
Public method | Execute(ISearch, Boolean, Boolean) | Initializes and runs a search dialog box.
Public method | Execute(ISearch, Boolean, Boolean, IWin32Window) | Initializes and runs a search dialog box.
Top
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.Execute Method (ISearch, Boolean, Boolean)

SearchDialogExecute Method (ISearch, Boolean, Boolean)
Initializes and runs a search dialog box.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult Execute(
    ISearch search,
    bool isModal,
    bool isReplace
)
Public Overridable Function Execute (
    search As ISearch,
    isModal As Boolean,
    isReplace As Boolean
) As DialogResult
public:
virtual DialogResult Execute(
    ISearch^ search,
    bool isModal,
    bool isReplace
)
abstract Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool -> DialogResult
override Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool -> DialogResult

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch interface owning the dialog.
isModal
Type: SystemBoolean
Indicates whether search dialog should appear in modal state.
isReplace
Type: SystemBoolean
Indicates whether search or replace dialog should be executed.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISearchDialogExecute(ISearch, Boolean, Boolean)
See Also

Reference

SearchDialog Class
Execute Overload
Alternet.Editor.Dialogs Namespace


SearchDialog.Execute Method (ISearch, Boolean, Boolean, IWin32Window)

SearchDialogExecute Method (ISearch, Boolean, Boolean, IWin32Window)
Initializes and runs a search dialog box.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult Execute(
    ISearch search,
    bool isModal,
    bool isReplace,
    IWin32Window owner
)
Public Overridable Function Execute (
    search As ISearch,
    isModal As Boolean,
    isReplace As Boolean,
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Execute(
    ISearch^ search,
    bool isModal,
    bool isReplace,
    IWin32Window^ owner
)
abstract Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool *
        owner : IWin32Window -> DialogResult
override Execute :
        search : ISearch *
        isModal : bool *
        isReplace : bool *
        owner : IWin32Window -> DialogResult

Parameters

search
Type: Alternet.EditorISearch
Specifies ISearch interface owning the dialog.
isModal
Type: SystemBoolean
Indicates whether search dialog should appear in modal state.
isReplace
Type: SystemBoolean
Indicates whether search or replace dialog should be executed.
owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

Type: DialogResult
DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Implements

ISearchDialogExecute(ISearch, Boolean, Boolean, IWin32Window)
See Also

Reference

SearchDialog Class
Execute Overload
Alternet.Editor.Dialogs Namespace


SearchDialog.ShowRegularExpressions Method

SearchDialogShowRegularExpressions Method
When implemented by a class, shows/hide regular expressions.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowRegularExpressions(
    bool show
)
Public Sub ShowRegularExpressions (
    show As Boolean
)
public:
void ShowRegularExpressions(
    bool show
)
member ShowRegularExpressions :
        show : bool -> unit

Parameters

show
Type: SystemBoolean
Specifies whether regular expressions checkbox should be visible.
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.ToggleHiddenText Method

SearchDialogToggleHiddenText Method
Toggles searching through hidden text on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleHiddenText()
Public Overridable Sub ToggleHiddenText
public:
virtual void ToggleHiddenText()
abstract ToggleHiddenText : unit -> unit
override ToggleHiddenText : unit -> unit

Implements

ISearchDialogToggleHiddenText
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.ToggleMatchCase Method

SearchDialogToggleMatchCase Method
Toggles case sensitive searching on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleMatchCase()
Public Overridable Sub ToggleMatchCase
public:
virtual void ToggleMatchCase()
abstract ToggleMatchCase : unit -> unit
override ToggleMatchCase : unit -> unit

Implements

ISearchDialogToggleMatchCase
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.TogglePromptOnReplace Method

SearchDialogTogglePromptOnReplace Method
Toggles prompting before replacing on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void TogglePromptOnReplace()
Public Sub TogglePromptOnReplace
public:
void TogglePromptOnReplace()
member TogglePromptOnReplace : unit -> unit
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.ToggleRegularExpressions Method

SearchDialogToggleRegularExpressions Method
Toggles using regular expressions on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleRegularExpressions()
Public Overridable Sub ToggleRegularExpressions
public:
virtual void ToggleRegularExpressions()
abstract ToggleRegularExpressions : unit -> unit
override ToggleRegularExpressions : unit -> unit

Implements

ISearchDialogToggleRegularExpressions
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.ToggleSearchUp Method

SearchDialogToggleSearchUp Method
Toggles searching direction towards/backwards.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleSearchUp()
Public Overridable Sub ToggleSearchUp
public:
virtual void ToggleSearchUp()
abstract ToggleSearchUp : unit -> unit
override ToggleSearchUp : unit -> unit

Implements

ISearchDialogToggleSearchUp
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.ToggleWholeWord Method

SearchDialogToggleWholeWord Method
Toggles searching for whole words on/off.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleWholeWord()
Public Overridable Sub ToggleWholeWord
public:
virtual void ToggleWholeWord()
abstract ToggleWholeWord : unit -> unit
override ToggleWholeWord : unit -> unit

Implements

ISearchDialogToggleWholeWord
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog Properties

SearchDialog Properties

The SearchDialog type exposes the following members.

Properties
 | Name | Description
Public property | Font | Gets or sets a font for the dialog to use.
Public property | IsFocused | Gets a boolean value indicating whether dialog box is visible.
Public property | OwnerForm | Gets or sets form that owns this dialog.
Public property | SearchDlg | Gets dialog form associated with search dialog.
Public property | SearchSettings | Gets search settings associated with search dialog.
Public property | Visible | Gets or sets a value indicating whether dialog box is visible.
Top
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.Font Property

SearchDialogFont Property
Gets or sets a font for the dialog to use.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
public:
virtual property Font^ Font {
    Font^ get () sealed;
    void set (Font^ value) sealed;
}
abstract Font : Font with get, set
override Font : Font with get, set

Property Value

Type: Font

Implements

ISearchDialogFont
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.IsFocused Property

SearchDialogIsFocused Property
Gets a boolean value indicating whether dialog box is visible.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFocused { get; }
Public ReadOnly Property IsFocused As Boolean
    Get
public:
virtual property bool IsFocused {
    bool get () sealed;
}
abstract IsFocused : bool with get
override IsFocused : bool with get

Property Value

Type: Boolean

Implements

ISearchDialogIsFocused
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.OwnerForm Property

SearchDialogOwnerForm Property
Gets or sets form that owns this dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Form OwnerForm { get; set; }
Public Property OwnerForm As Form
    Get
    Set
public:
virtual property Form^ OwnerForm {
    Form^ get () sealed;
    void set (Form^ value) sealed;
}
abstract OwnerForm : Form with get, set
override OwnerForm : Form with get, set

Property Value

Type: Form

Implements

ISearchDialogOwnerForm
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.SearchDlg Property

SearchDialogSearchDlg Property
Gets dialog form associated with search dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DlgSearch SearchDlg { get; }
Public Overridable ReadOnly Property SearchDlg As DlgSearch
    Get
public:
virtual property DlgSearch^ SearchDlg {
    DlgSearch^ get ();
}
abstract SearchDlg : DlgSearch with get
override SearchDlg : DlgSearch with get

Property Value

Type: DlgSearch
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.SearchSettings Property

SearchDialogSearchSettings Property
Gets search settings associated with search dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISearchSettings SearchSettings { get; }
Public Overridable ReadOnly Property SearchSettings As ISearchSettings
    Get
public:
virtual property ISearchSettings^ SearchSettings {
    ISearchSettings^ get ();
}
abstract SearchSettings : ISearchSettings with get
override SearchSettings : ISearchSettings with get

Property Value

Type: ISearchSettings

Implements

ISearchDialogSearchSettings
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.Visible Property

SearchDialogVisible Property
Gets or sets a value indicating whether dialog box is visible.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

ISearchDialogVisible
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog Events

SearchDialog Events

The SearchDialog type exposes the following members.

Events
 | Name | Description
Public event | HelpRequested | Occurs when user requests help for a control.
Top
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchDialog.HelpRequested Event

SearchDialogHelpRequested Event
Occurs when user requests help for a control.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual event HelpEventHandler HelpRequested
Public Overridable Event HelpRequested As HelpEventHandler
public:
virtual  event HelpEventHandler^ HelpRequested {
    void add (HelpEventHandler^ value);
    void remove (HelpEventHandler^ value);
}
abstract HelpRequested : IEvent<HelpEventHandler,
    HelpEventArgs>
override HelpRequested : IEvent<HelpEventHandler,
    HelpEventArgs>

Value

Type: System.Windows.FormsHelpEventHandler

Implements

ISearchDialogHelpRequested
See Also

Reference

SearchDialog Class
Alternet.Editor.Dialogs Namespace


SearchSettings Class

SearchSettings Class
This class is designed to hold settings for search and replace dialogs.
Inheritance Hierarchy
SystemObject
Alternet.Editor.DialogsPersistentSettings
Alternet.Editor.DialogsSearchSettings

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SearchSettings : PersistentSettings,
    ISearchSettings, IPersistentSettings, IImport, IExport
Public Class SearchSettings
    Inherits PersistentSettings
    Implements ISearchSettings, IPersistentSettings, IImport, IExport
public ref class SearchSettings : public PersistentSettings,
    ISearchSettings, IPersistentSettings, IImport, IExport
type SearchSettings =
    class
        inherit PersistentSettings
        interface ISearchSettings
        interface IPersistentSettings
        interface IImport
        interface IExport
    end

The SearchSettings type exposes the following members.

Constructors
 | Name | Description
Public method | SearchSettings | Initializes a new instance of the SearchSettings class with default settings.
Top
Methods
 | Name | Description
Public method | Assign(IPersistentSettings) | Copies the contents from another IPersistentSettings object. (Overrides PersistentSettingsAssign(IPersistentSettings).)
Public method | Assign(ISearchSettings) | When implemented by a class, copies the content from another ISearchSettings object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlType | Returns Type object for a class that contain information about SearchSettings. In this class method returns type of XmlSearchSettingsInfo class. (Overrides PersistentSettingsGetXmlType.)
Public method | LoadFile(String) | Loads IPersistentSettings content from the specified file. (Inherited from PersistentSettings.)
Public method | LoadFile(String, Encoding) | Loads IPersistentSettings content from the specified file with specified encoding. (Inherited from PersistentSettings.)
Public method | LoadStream(Stream) | Loads IPersistentSettings content from the specified stream with specified encoding. (Inherited from PersistentSettings.)
Public method | LoadStream(TextReader) | Loads IPersistentSettings content from the specified stream. (Inherited from PersistentSettings.)
Public method | LoadStream(Stream, Encoding) | Loads IPersistentSettings content from the specified stream with specified encoding. (Inherited from PersistentSettings.)
Public method | SaveFile(String) | Saves IPersistentSettings content to the specified file. (Inherited from PersistentSettings.)
Public method | SaveFile(String, Encoding) | Saves IPersistentSettings content to the specified file with specific encoding. (Inherited from PersistentSettings.)
Public method | SaveStream(Stream) | Saves IPersistentSettings content to the specified stream. (Inherited from PersistentSettings.)
Public method | SaveStream(TextWriter) | Saves IPersistentSettings content to the specified stream. (Inherited from PersistentSettings.)
Public method | SaveStream(Stream, Encoding) | Saves IPersistentSettings content to the specified stream with specific encoding. (Inherited from PersistentSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ClearBookmarks | Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.
Public property | GlobalSearch | Specifies whether search should be global.
Public property | OptionsVisible | Indicates whether find/replace dialog should display search settings.
Public property | ReplaceList | Represents the replace history for the replace dialog.
Public property | SearchList | Represents the search history for the search dialog.
Public property | SearchOptions | Represents options that determine behavior of search or replace dialog.
Public property | SerializationInfo | Gets or sets an xml representation of this SearchSettings object. (Overrides PersistentSettingsSerializationInfo.)
Top
See Also

Reference

Alternet.Editor.Dialogs Namespace


SearchSettings Constructor

SearchSettings Constructor
Initializes a new instance of the SearchSettings class with default settings.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchSettings()
Public Sub New
public:
SearchSettings()
new : unit -> SearchSettings
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings Methods

SearchSettings Methods

The SearchSettings type exposes the following members.

Methods
 | Name | Description
Public method | Assign(IPersistentSettings) | Copies the contents from another IPersistentSettings object. (Overrides PersistentSettingsAssign(IPersistentSettings).)
Public method | Assign(ISearchSettings) | When implemented by a class, copies the content from another ISearchSettings object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlType | Returns Type object for a class that contain information about SearchSettings. In this class method returns type of XmlSearchSettingsInfo class. (Overrides PersistentSettingsGetXmlType.)
Public method | LoadFile(String) | Loads IPersistentSettings content from the specified file. (Inherited from PersistentSettings.)
Public method | LoadFile(String, Encoding) | Loads IPersistentSettings content from the specified file with specified encoding. (Inherited from PersistentSettings.)
Public method | LoadStream(Stream) | Loads IPersistentSettings content from the specified stream with specified encoding. (Inherited from PersistentSettings.)
Public method | LoadStream(TextReader) | Loads IPersistentSettings content from the specified stream. (Inherited from PersistentSettings.)
Public method | LoadStream(Stream, Encoding) | Loads IPersistentSettings content from the specified stream with specified encoding. (Inherited from PersistentSettings.)
Public method | SaveFile(String) | Saves IPersistentSettings content to the specified file. (Inherited from PersistentSettings.)
Public method | SaveFile(String, Encoding) | Saves IPersistentSettings content to the specified file with specific encoding. (Inherited from PersistentSettings.)
Public method | SaveStream(Stream) | Saves IPersistentSettings content to the specified stream. (Inherited from PersistentSettings.)
Public method | SaveStream(TextWriter) | Saves IPersistentSettings content to the specified stream. (Inherited from PersistentSettings.)
Public method | SaveStream(Stream, Encoding) | Saves IPersistentSettings content to the specified stream with specific encoding. (Inherited from PersistentSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings.Assign Method

SearchSettingsAssign Method
Overload List
 | Name | Description
Public method | Assign(IPersistentSettings) | Copies the contents from another IPersistentSettings object. (Overrides PersistentSettingsAssign(IPersistentSettings).)
Public method | Assign(ISearchSettings) | When implemented by a class, copies the content from another ISearchSettings object.
Top
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings.Assign Method (IPersistentSettings)

SearchSettingsAssign Method (IPersistentSettings)
Copies the contents from another IPersistentSettings object.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Assign(
    IPersistentSettings source
)
Public Overrides Sub Assign (
    source As IPersistentSettings
)
public:
virtual void Assign(
    IPersistentSettings^ source
) override
abstract Assign :
        source : IPersistentSettings -> unit
override Assign :
        source : IPersistentSettings -> unit

Parameters

source
Type: Alternet.Editor.DialogsIPersistentSettings
Specifies IPersistentSettings to assign.

Implements

IPersistentSettingsAssign(IPersistentSettings)
IPersistentSettingsAssign(IPersistentSettings)
See Also

Reference

SearchSettings Class
Assign Overload
Alternet.Editor.Dialogs Namespace


SearchSettings.Assign Method (ISearchSettings)

SearchSettingsAssign Method (ISearchSettings)
When implemented by a class, copies the content from another ISearchSettings object.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ISearchSettings source
)
Public Overridable Sub Assign (
    source As ISearchSettings
)
public:
virtual void Assign(
    ISearchSettings^ source
)
abstract Assign :
        source : ISearchSettings -> unit
override Assign :
        source : ISearchSettings -> unit

Parameters

source
Type: Alternet.Editor.DialogsISearchSettings
Specifies ISearchSettings to assign.

Implements

ISearchSettingsAssign(ISearchSettings)
See Also

Reference

SearchSettings Class
Assign Overload
Alternet.Editor.Dialogs Namespace


SearchSettings.GetXmlType Method

SearchSettingsGetXmlType Method
Returns Type object for a class that contain information about SearchSettings. In this class method returns type of XmlSearchSettingsInfo class.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Type GetXmlType()
Public Overrides Function GetXmlType As Type
public:
virtual Type^ GetXmlType() override
abstract GetXmlType : unit -> Type
override GetXmlType : unit -> Type

Return Value

Type: Type
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings Properties

SearchSettings Properties

The SearchSettings type exposes the following members.

Properties
 | Name | Description
Public property | ClearBookmarks | Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.
Public property | GlobalSearch | Specifies whether search should be global.
Public property | OptionsVisible | Indicates whether find/replace dialog should display search settings.
Public property | ReplaceList | Represents the replace history for the replace dialog.
Public property | SearchList | Represents the search history for the search dialog.
Public property | SearchOptions | Represents options that determine behavior of search or replace dialog.
Public property | SerializationInfo | Gets or sets an xml representation of this SearchSettings object. (Overrides PersistentSettingsSerializationInfo.)
Top
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings.ClearBookmarks Property

SearchSettingsClearBookmarks Property
Indicates whether all unnumbered bookmarks should be removed from the bookmarks collection.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ClearBookmarks { get; set; }
Public Overridable Property ClearBookmarks As Boolean
    Get
    Set
public:
virtual property bool ClearBookmarks {
    bool get ();
    void set (bool value);
}
abstract ClearBookmarks : bool with get, set
override ClearBookmarks : bool with get, set

Property Value

Type: Boolean

Implements

ISearchSettingsClearBookmarks
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings.GlobalSearch Property

SearchSettingsGlobalSearch Property
Specifies whether search should be global.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GlobalSearch { get; set; }
Public Property GlobalSearch As Boolean
    Get
    Set
public:
virtual property bool GlobalSearch {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract GlobalSearch : bool with get, set
override GlobalSearch : bool with get, set

Property Value

Type: Boolean

Implements

ISearchSettingsGlobalSearch
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings.OptionsVisible Property

SearchSettingsOptionsVisible Property
Indicates whether find/replace dialog should display search settings.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool OptionsVisible { get; set; }
Public Overridable Property OptionsVisible As Boolean
    Get
    Set
public:
virtual property bool OptionsVisible {
    bool get ();
    void set (bool value);
}
abstract OptionsVisible : bool with get, set
override OptionsVisible : bool with get, set

Property Value

Type: Boolean

Implements

ISearchSettingsOptionsVisible
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings.ReplaceList Property

SearchSettingsReplaceList Property
Represents the replace history for the replace dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<string> ReplaceList { get; }
Public Overridable ReadOnly Property ReplaceList As IList(Of String)
    Get
public:
virtual property IList<String^>^ ReplaceList {
    IList<String^>^ get ();
}
abstract ReplaceList : IList<string> with get
override ReplaceList : IList<string> with get

Property Value

Type: IListString

Implements

ISearchSettingsReplaceList
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings.SearchList Property

SearchSettingsSearchList Property
Represents the search history for the search dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<string> SearchList { get; }
Public Overridable ReadOnly Property SearchList As IList(Of String)
    Get
public:
virtual property IList<String^>^ SearchList {
    IList<String^>^ get ();
}
abstract SearchList : IList<string> with get
override SearchList : IList<string> with get

Property Value

Type: IListString

Implements

ISearchSettingsSearchList
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings.SearchOptions Property

SearchSettingsSearchOptions Property
Represents options that determine behavior of search or replace dialog.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SearchOptions SearchOptions { get; set; }
Public Overridable Property SearchOptions As SearchOptions
    Get
    Set
public:
virtual property SearchOptions SearchOptions {
    SearchOptions get ();
    void set (SearchOptions value);
}
abstract SearchOptions : SearchOptions with get, set
override SearchOptions : SearchOptions with get, set

Property Value

Type: SearchOptions

Implements

ISearchSettingsSearchOptions
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


SearchSettings.SerializationInfo Property

SearchSettingsSerializationInfo Property
Gets or sets an xml representation of this SearchSettings object.

Namespace: Alternet.Editor.Dialogs
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

SearchSettings Class
Alternet.Editor.Dialogs Namespace


Alternet.Editor.IronPython Namespace

Alternet.Editor.IronPython Namespace
Classes
 | Class | Description
Public class | CodeEditExtensions |
Public class | CodeExplorer | Represents methods used to explore parsed representation of the source code in the TreeView control.
Public class | CodeUtils | Represents extended functionality to fill classes and methods lists related to the position inside the text document.
Public class | IronPythonProject | Represents properties and methods used to store and manipulate Visual Studio project content.
Public class | NavigateToNodeRequestedEventArgs |


CodeEditExtensions Class

CodeEditExtensions Class
Inheritance Hierarchy
SystemObject
Alternet.Editor.IronPythonCodeEditExtensions

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CodeEditExtensions
<ExtensionAttribute>
Public NotInheritable Class CodeEditExtensions
[ExtensionAttribute]
public ref class CodeEditExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type CodeEditExtensions =  class end

The CodeEditExtensions type exposes the following members.

Methods
Name | Description
FindDeclaration |
FindReferences |
Top
See Also

Reference

Alternet.Editor.IronPython Namespace


CodeEditExtensions Methods

CodeEditExtensions Methods

The CodeEditExtensions type exposes the following members.

Methods
Name | Description
FindDeclaration |
FindReferences |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.IronPython Namespace


CodeEditExtensions.FindDeclaration Method

CodeEditExtensionsFindDeclaration Method

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SymbolLocation FindDeclaration(
    this IScriptEdit edit,
    Point position
)
<ExtensionAttribute>
Public Shared Function FindDeclaration (
    edit As IScriptEdit,
    position As Point
) As SymbolLocation
public:
[ExtensionAttribute]
static SymbolLocation^ FindDeclaration(
    IScriptEdit^ edit,
    Point position
)
[<ExtensionAttribute>]
static member FindDeclaration :
        edit : IScriptEdit *
        position : Point -> SymbolLocation

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
position
Type: System.DrawingPoint

Return Value

Type: SymbolLocation

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.IronPython Namespace


CodeEditExtensions.FindReferences Method

CodeEditExtensionsFindReferences Method

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int FindReferences(
    this IScriptEdit edit,
    Point position,
    IRangeList references
)
<ExtensionAttribute>
Public Shared Function FindReferences (
    edit As IScriptEdit,
    position As Point,
    references As IRangeList
) As Integer
public:
[ExtensionAttribute]
static int FindReferences(
    IScriptEdit^ edit,
    Point position,
    IRangeList^ references
)
[<ExtensionAttribute>]
static member FindReferences :
        edit : IScriptEdit *
        position : Point *
        references : IRangeList -> int

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
position
Type: System.DrawingPoint
references
Type: Alternet.CommonIRangeList

Return Value

Type: Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.IronPython Namespace


CodeExplorer Class

CodeExplorer Class
Represents methods used to explore parsed representation of the source code in the TreeView control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.IronPythonCodeExplorer

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeExplorer
Public Class CodeExplorer
public ref class CodeExplorer
type CodeExplorer =  class end

The CodeExplorer type exposes the following members.

Constructors
 | Name | Description
Public method | CodeExplorer | Initializes a new instance of the CodeExplorer class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ScopeImageIndex | Calculates offset for the image index accordingly to the visibility scope.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given source document.
Top
Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore source code.
Top
Events
 | Name | Description
Public event | NavigateToNodeRequested |
Top
See Also

Reference

Alternet.Editor.IronPython Namespace


CodeExplorer Constructor

CodeExplorer Constructor
Initializes a new instance of the CodeExplorer class with default settings.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeExplorer()
Public Sub New
public:
CodeExplorer()
new : unit -> CodeExplorer
See Also

Reference

CodeExplorer Class
Alternet.Editor.IronPython Namespace


CodeExplorer Methods

CodeExplorer Methods

The CodeExplorer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ScopeImageIndex | Calculates offset for the image index accordingly to the visibility scope.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given source document.
Top
See Also

Reference

CodeExplorer Class
Alternet.Editor.IronPython Namespace


CodeExplorer.ScopeImageIndex Method

CodeExplorerScopeImageIndex Method
Calculates offset for the image index accordingly to the visibility scope.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int ScopeImageIndex(
    bool isScopedImage
)
Public Shared Function ScopeImageIndex (
    isScopedImage As Boolean
) As Integer
public:
static int ScopeImageIndex(
    bool isScopedImage
)
static member ScopeImageIndex :
        isScopedImage : bool -> int

Parameters

isScopedImage
Type: SystemBoolean
Indicates whether image index needs to be adjusted.

Return Value

Type: Int32
The amount to offset.
See Also

Reference

CodeExplorer Class
Alternet.Editor.IronPython Namespace


CodeExplorer.UpdateExplorer Method

CodeExplorerUpdateExplorer Method
Updates explorer content from given source document.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateExplorer(
    ISyntaxTree tree
)
Public Sub UpdateExplorer (
    tree As ISyntaxTree
)
public:
void UpdateExplorer(
    ISyntaxTree^ tree
)
member UpdateExplorer :
        tree : ISyntaxTree -> unit

Parameters

tree
Type: Alternet.SyntaxISyntaxTree
SyntaxTree Describes syntax structure of code text.
See Also

Reference

CodeExplorer Class
Alternet.Editor.IronPython Namespace


CodeExplorer Properties

CodeExplorer Properties

The CodeExplorer type exposes the following members.

Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore source code.
Top
See Also

Reference

CodeExplorer Class
Alternet.Editor.IronPython Namespace


CodeExplorer.ExplorerTree Property

CodeExplorerExplorerTree Property
Gets or sets System.Windows.Forms.TreeView control used to explore source code.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeView ExplorerTree { get; set; }
Public Property ExplorerTree As TreeView
    Get
    Set
public:
property TreeView^ ExplorerTree {
    TreeView^ get ();
    void set (TreeView^ value);
}
member ExplorerTree : TreeView with get, set

Property Value

Type: TreeView
See Also

Reference

CodeExplorer Class
Alternet.Editor.IronPython Namespace


CodeExplorer Events

CodeExplorer Events

The CodeExplorer type exposes the following members.

Events
 | Name | Description
Public event | NavigateToNodeRequested |
Top
See Also

Reference

CodeExplorer Class
Alternet.Editor.IronPython Namespace


CodeExplorer.NavigateToNodeRequested Event

CodeExplorerNavigateToNodeRequested Event

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<NavigateToNodeRequestedEventArgs> NavigateToNodeRequested
Public Event NavigateToNodeRequested As EventHandler(Of NavigateToNodeRequestedEventArgs)
public:
 event EventHandler<NavigateToNodeRequestedEventArgs^>^ NavigateToNodeRequested {
    void add (EventHandler<NavigateToNodeRequestedEventArgs^>^ value);
    void remove (EventHandler<NavigateToNodeRequestedEventArgs^>^ value);
}
member NavigateToNodeRequested : IEvent<EventHandler<NavigateToNodeRequestedEventArgs>,
    NavigateToNodeRequestedEventArgs>

Value

Type: SystemEventHandlerNavigateToNodeRequestedEventArgs
See Also

Reference

CodeExplorer Class
Alternet.Editor.IronPython Namespace


CodeUtils Class

CodeUtils Class
Represents extended functionality to fill classes and methods lists related to the position inside the text document.
Inheritance Hierarchy
SystemObject
Alternet.Editor.IronPythonCodeUtils

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeUtils
Public Class CodeUtils
public ref class CodeUtils
type CodeUtils =  class end

The CodeUtils type exposes the following members.

Constructors
 | Name | Description
Public method | CodeUtils | Initializes a new instance of the CodeUtils class
Top
Methods
 | Name | Description
 | DrawItem | Provides a custom drawing for a ComboBox item.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FillClasses | Fills given ComboBox with list of classes obtained from specified document at the given position.
 | FillMethods | Fills given ComboBox with list of methods obtained from specified document at the given position.
 | FormatText | Formats content of specified syntax element accordingly to language rules of the document.
 | GetFormattedText | Formats content of specified SyntaxNode accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetNodeByPosition | Finds parent node of given SyntaxNode that is a class or structure node.
 | GetPosition | Finds position in source code related to the specified syntax element.
 | GetSelectedPosition | Finds position in source code related to the currently selected item in the ComboBox control.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidNode |
 | NavigateClasses | Updates content of given class ComboBox accordingly to given position.
 | NavigateMethods | Updates content of given method ComboBox accordingly to given position.
 | SelectItem | Finds position of the syntax element linked to the currently selected item in the ComboBox control.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Editor.IronPython Namespace


CodeUtils Constructor

CodeUtils Constructor
Initializes a new instance of the CodeUtils class

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeUtils()
Public Sub New
public:
CodeUtils()
new : unit -> CodeUtils
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils Methods

CodeUtils Methods

The CodeUtils type exposes the following members.

Methods
 | Name | Description
 | DrawItem | Provides a custom drawing for a ComboBox item.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FillClasses | Fills given ComboBox with list of classes obtained from specified document at the given position.
 | FillMethods | Fills given ComboBox with list of methods obtained from specified document at the given position.
 | FormatText | Formats content of specified syntax element accordingly to language rules of the document.
 | GetFormattedText | Formats content of specified SyntaxNode accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetNodeByPosition | Finds parent node of given SyntaxNode that is a class or structure node.
 | GetPosition | Finds position in source code related to the specified syntax element.
 | GetSelectedPosition | Finds position in source code related to the currently selected item in the ComboBox control.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidNode |
 | NavigateClasses | Updates content of given class ComboBox accordingly to given position.
 | NavigateMethods | Updates content of given method ComboBox accordingly to given position.
 | SelectItem | Finds position of the syntax element linked to the currently selected item in the ComboBox control.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.DrawItem Method

CodeUtilsDrawItem Method
Provides a custom drawing for a ComboBox item.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawItem(
    ComboBox comboBox,
    DrawItemEventArgs e,
    ImageList images
)
Public Shared Sub DrawItem (
    comboBox As ComboBox,
    e As DrawItemEventArgs,
    images As ImageList
)
public:
static void DrawItem(
    ComboBox^ comboBox,
    DrawItemEventArgs^ e,
    ImageList^ images
)
static member DrawItem :
        comboBox : ComboBox *
        e : DrawItemEventArgs *
        images : ImageList -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox which item will be drawn.
e
Type: System.Windows.FormsDrawItemEventArgs
A DrawItemEventArgs that contains the event data.
images
Type: System.Windows.FormsImageList
List of images used to draw with items.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.FillClasses Method

CodeUtilsFillClasses Method
Fills given ComboBox with list of classes obtained from specified document at the given position.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void FillClasses(
    ComboBox comboBox,
    ISyntaxParser parser,
    Point position
)
Public Shared Sub FillClasses (
    comboBox As ComboBox,
    parser As ISyntaxParser,
    position As Point
)
public:
static void FillClasses(
    ComboBox^ comboBox,
    ISyntaxParser^ parser,
    Point position
)
static member FillClasses :
        comboBox : ComboBox *
        parser : ISyntaxParser *
        position : Point -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox control to process.
parser
Type: Alternet.SyntaxISyntaxParser
ISyntaxParser processes source code.
position
Type: System.DrawingPoint
Position in code.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.FillMethods Method

CodeUtilsFillMethods Method
Fills given ComboBox with list of methods obtained from specified document at the given position.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void FillMethods(
    ComboBox comboBox,
    ISyntaxParser parser,
    Point position,
    ComboBox classCombo
)
Public Shared Sub FillMethods (
    comboBox As ComboBox,
    parser As ISyntaxParser,
    position As Point,
    classCombo As ComboBox
)
public:
static void FillMethods(
    ComboBox^ comboBox,
    ISyntaxParser^ parser,
    Point position,
    ComboBox^ classCombo
)
static member FillMethods :
        comboBox : ComboBox *
        parser : ISyntaxParser *
        position : Point *
        classCombo : ComboBox -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox control to process.
parser
Type: Alternet.SyntaxISyntaxParser
ISyntaxParser processes source code.
position
Type: System.DrawingPoint
Position in code.
classCombo
Type: System.Windows.FormsComboBox
Contains list of classes.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.FormatText Method

CodeUtilsFormatText Method
Formats content of specified syntax element accordingly to language rules of the document.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FormatText(
    Object item
)
Public Shared Function FormatText (
    item As Object
) As String
public:
static String^ FormatText(
    Object^ item
)
static member FormatText :
        item : Object -> string

Parameters

item
Type: SystemObject
Syntax element to probe.

Return Value

Type: String
Formatted sting that contains a syntax element.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.GetFormattedText Method

CodeUtilsGetFormattedText Method
Formats content of specified SyntaxNode accordingly to language rules of the document.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFormattedText(
    ISyntaxNode node
)
Public Shared Function GetFormattedText (
    node As ISyntaxNode
) As String
public:
static String^ GetFormattedText(
    ISyntaxNode^ node
)
static member GetFormattedText :
        node : ISyntaxNode -> string

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to format.

Return Value

Type: String
Formatted sting that contains a SyntaxNode.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.GetNodeByPosition Method

CodeUtilsGetNodeByPosition Method
Finds parent node of given SyntaxNode that is a class or structure node.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISyntaxNode GetNodeByPosition(
    ComboBox classComboBox,
    Point position
)
Public Shared Function GetNodeByPosition (
    classComboBox As ComboBox,
    position As Point
) As ISyntaxNode
public:
static ISyntaxNode^ GetNodeByPosition(
    ComboBox^ classComboBox,
    Point position
)
static member GetNodeByPosition :
        classComboBox : ComboBox *
        position : Point -> ISyntaxNode

Parameters

classComboBox
Type: System.Windows.FormsComboBox
position
Type: System.DrawingPoint

Return Value

Type: ISyntaxNode
Class or structure node.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.GetPosition Method

CodeUtilsGetPosition Method
Finds position in source code related to the specified syntax element.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GetPosition(
    Object node,
    out Point point
)
Public Shared Function GetPosition (
    node As Object,
    <OutAttribute> ByRef point As Point
) As Boolean
public:
static bool GetPosition(
    Object^ node,
    [OutAttribute] Point% point
)
static member GetPosition :
        node : Object *
        point : Point byref -> bool

Parameters

node
Type: SystemObject
Syntax element (class or method) to probe.
point
Type: System.DrawingPoint
Receives start point of given syntax element.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.GetSelectedPosition Method

CodeUtilsGetSelectedPosition Method
Finds position in source code related to the currently selected item in the ComboBox control.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point GetSelectedPosition(
    ComboBox comboBox
)
Public Shared Function GetSelectedPosition (
    comboBox As ComboBox
) As Point
public:
static Point GetSelectedPosition(
    ComboBox^ comboBox
)
static member GetSelectedPosition :
        comboBox : ComboBox -> Point

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox contains list of syntax elements (classes or methods).

Return Value

Type: Point
System.Draw.Point represents start point of current syntax element.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.IsValidNode Method

CodeUtilsIsValidNode Method

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidNode(
    int nodeType,
    out int index
)
Public Shared Function IsValidNode (
    nodeType As Integer,
    <OutAttribute> ByRef index As Integer
) As Boolean
public:
static bool IsValidNode(
    int nodeType,
    [OutAttribute] int% index
)
static member IsValidNode :
        nodeType : int *
        index : int byref -> bool

Parameters

nodeType
Type: SystemInt32
index
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.NavigateClasses Method

CodeUtilsNavigateClasses Method
Updates content of given class ComboBox accordingly to given position.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void NavigateClasses(
    ComboBox comboBox,
    ISyntaxParser parser,
    Point position
)
Public Shared Sub NavigateClasses (
    comboBox As ComboBox,
    parser As ISyntaxParser,
    position As Point
)
public:
static void NavigateClasses(
    ComboBox^ comboBox,
    ISyntaxParser^ parser,
    Point position
)
static member NavigateClasses :
        comboBox : ComboBox *
        parser : ISyntaxParser *
        position : Point -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox to process.
parser
Type: Alternet.SyntaxISyntaxParser
ISyntaxParser processes source code.
position
Type: System.DrawingPoint
Position in code.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.NavigateMethods Method

CodeUtilsNavigateMethods Method
Updates content of given method ComboBox accordingly to given position.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void NavigateMethods(
    ComboBox comboBox,
    ISyntaxParser parser,
    Point position,
    ComboBox classComboBox
)
Public Shared Sub NavigateMethods (
    comboBox As ComboBox,
    parser As ISyntaxParser,
    position As Point,
    classComboBox As ComboBox
)
public:
static void NavigateMethods(
    ComboBox^ comboBox,
    ISyntaxParser^ parser,
    Point position,
    ComboBox^ classComboBox
)
static member NavigateMethods :
        comboBox : ComboBox *
        parser : ISyntaxParser *
        position : Point *
        classComboBox : ComboBox -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox to process.
parser
Type: Alternet.SyntaxISyntaxParser
ISyntaxParser processes source code.
position
Type: System.DrawingPoint
Position in code.
classComboBox
Type: System.Windows.FormsComboBox
Contains list of classes.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


CodeUtils.SelectItem Method

CodeUtilsSelectItem Method
Finds position of the syntax element linked to the currently selected item in the ComboBox control.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool SelectItem(
    ComboBox comboBox,
    out Point position
)
Public Shared Function SelectItem (
    comboBox As ComboBox,
    <OutAttribute> ByRef position As Point
) As Boolean
public:
static bool SelectItem(
    ComboBox^ comboBox,
    [OutAttribute] Point% position
)
static member SelectItem :
        comboBox : ComboBox *
        position : Point byref -> bool

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox to process.
position
Type: System.DrawingPoint
Receives start point of currently selected syntax element.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

CodeUtils Class
Alternet.Editor.IronPython Namespace


IronPythonProject Class

IronPythonProject Class
Represents properties and methods used to store and manipulate Visual Studio project content.
Inheritance Hierarchy
SystemObject
Alternet.Common.ProjectsProject
Alternet.Common.Projects.DotNetDotNetProject
Alternet.Editor.IronPythonIronPythonProject

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonProject : DotNetProject
Public Class IronPythonProject
    Inherits DotNetProject
public ref class IronPythonProject : public DotNetProject
type IronPythonProject =
    class
        inherit DotNetProject
    end

The IronPythonProject type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonProject | Initializes a new instance of the IronPythonProject class
Top
Methods
 | Name | Description
Public method | AddFile(String) | Adds specified code or resource file to the project. (Inherited from DotNetProject.)
Public method | AddFile(String, BuildAction, CopyLocal) | (Inherited from DotNetProject.)
Public method | AddReference | Adds specified reference to the project. (Inherited from DotNetProject.)
Public method | AllFiles | Gets list of files included in the project. (Inherited from DotNetProject.)
Public method | BeginUpdate | Prevents project updating until calling EndUpdate method. (Inherited from Project.)
Public method | EndUpdate | Re-enables project updating, that was turn of by calling BeginUpdate method. (Inherited from Project.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFileAttribute | (Inherited from DotNetProject.)
Public method | GetFileBuildAction | (Inherited from DotNetProject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads project from specified source. (Inherited from DotNetProject.)
Public method | RemoveFile | Removes specified file from the project. (Inherited from DotNetProject.)
Public method | RemoveReference | Removes specified reference from the project. (Inherited from DotNetProject.)
Public method | Reset | Resets Project to the default state. (Inherited from DotNetProject.)
Public method | SetFileAttribute(String, BuildAction) | (Inherited from DotNetProject.)
Public method | SetFileAttribute(String, CopyLocal) | (Inherited from DotNetProject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryResolveAbsolutePath | Try to find real reference name matches the given name. (Inherited from DotNetProject.)
Public method | TryResolveAbsolutePaths | Try to find real references name matches the given names. (Inherited from DotNetProject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Create | Creates new template project and saves it to the file system. (Defined by DotNetProjectExtension.)
Public Extension Method | Load | Loads project from specified source. (Defined by DotNetProjectExtension.)
Public Extension Method | LoadXML(String) | Overloaded. Loads project from specified xml string. (Defined by DotNetProjectExtension.)
Public Extension Method | LoadXML(XmlDocument) | Overloaded. Loads project from specified xml document. (Defined by DotNetProjectExtension.)
Public Extension Method | Save | Saves the project to the file system, if modified. (Defined by DotNetProjectExtension.)
Top
Properties
 | Name | Description
Public property | AssemblyResources | Gets the list of the assembly (with Generator option) resources embedded into the project. (Inherited from DotNetProject.)
Public property | AutoReferences | (Inherited from DotNetProject.)
Public property | DefaultExtension | Gets a default extension of the project's code files. (Overrides DotNetProjectDefaultExtension.)
Public property | Files | Gets list of files included in the project. (Inherited from Project.)
Public property | FrameworkReferences | (Inherited from DotNetProject.)
Public property | HasProject | Gets a value indicating whether project contains some data. (Inherited from Project.)
Public property | ImportedNamespaces | Gets list of imported namespaces used in the project. (Inherited from DotNetProject.)
Public property | IsFolder | Gets or sets a boolean value indicates whether this Project represents a folder within project collection. (Inherited from Project.)
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save. (Inherited from Project.)
Public property | IsSdkStyle | Gets a value indicating whether this is SDK-style. (Inherited from DotNetProject.)
Public property | IsWpf | Gets a value indicating whether this is WPF project or not. (Inherited from DotNetProject.)
Public property | Parent | Gets or sets a Project that is a parent of this project. (Inherited from DotNetProject.)
Public property | ProjectDependencies | Gets or sets list of project's dependencies. (Inherited from DotNetProject.)
Public property | ProjectExtension | Gets an extension of the this project. (Inherited from DotNetProject.)
Public property | ProjectFileName | Gets fully qualified name of the project file. (Inherited from Project.)
Public property | ProjectGuid | Gets or sets's project's GUID. (Inherited from DotNetProject.)
Public property | ProjectHostGuid | Gets or sets's project's host GUID. (Inherited from DotNetProject.)
Public property | ProjectName | Gets or sets project's name. (Inherited from Project.)
Public property | ProjectReferences | Gets list of assemblies used in the project. (Inherited from DotNetProject.)
Public property | References | Gets list of assemblies used in the project. (Inherited from DotNetProject.)
Public property | RelativePath | Gets or sets a relative file path of this project. (Inherited from DotNetProject.)
Public property | Resources | Gets the list of the resources embedded into the project. (Inherited from Project.)
Public property | RootNamespace | Gets project's root namespace. (Inherited from DotNetProject.)
Public property | SolutionSettings | Gets a ProjectSolutionSettings for this project. (Inherited from DotNetProject.)
Public property | TargetFramework | (Inherited from DotNetProject.)
Public property | UserSettings | Gets user defined settings for this project. (Inherited from Project.)
Top
Events
 | Name | Description
Public event | ProjectModified | Occurs when project content was modified. (Inherited from Project.)
Top
See Also

Reference

Alternet.Editor.IronPython Namespace


IronPythonProject Constructor

IronPythonProject Constructor
Initializes a new instance of the IronPythonProject class

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonProject()
Public Sub New
public:
IronPythonProject()
new : unit -> IronPythonProject
See Also

Reference

IronPythonProject Class
Alternet.Editor.IronPython Namespace


IronPythonProject Methods

IronPythonProject Methods

The IronPythonProject type exposes the following members.

Methods
 | Name | Description
Public method | AddFile(String) | Adds specified code or resource file to the project. (Inherited from DotNetProject.)
Public method | AddFile(String, BuildAction, CopyLocal) | (Inherited from DotNetProject.)
Public method | AddReference | Adds specified reference to the project. (Inherited from DotNetProject.)
Public method | AllFiles | Gets list of files included in the project. (Inherited from DotNetProject.)
Public method | BeginUpdate | Prevents project updating until calling EndUpdate method. (Inherited from Project.)
Public method | EndUpdate | Re-enables project updating, that was turn of by calling BeginUpdate method. (Inherited from Project.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFileAttribute | (Inherited from DotNetProject.)
Public method | GetFileBuildAction | (Inherited from DotNetProject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads project from specified source. (Inherited from DotNetProject.)
Public method | RemoveFile | Removes specified file from the project. (Inherited from DotNetProject.)
Public method | RemoveReference | Removes specified reference from the project. (Inherited from DotNetProject.)
Public method | Reset | Resets Project to the default state. (Inherited from DotNetProject.)
Public method | SetFileAttribute(String, BuildAction) | (Inherited from DotNetProject.)
Public method | SetFileAttribute(String, CopyLocal) | (Inherited from DotNetProject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryResolveAbsolutePath | Try to find real reference name matches the given name. (Inherited from DotNetProject.)
Public method | TryResolveAbsolutePaths | Try to find real references name matches the given names. (Inherited from DotNetProject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Create | Creates new template project and saves it to the file system. (Defined by DotNetProjectExtension.)
Public Extension Method | Load | Loads project from specified source. (Defined by DotNetProjectExtension.)
Public Extension Method | LoadXML(String) | Overloaded. Loads project from specified xml string. (Defined by DotNetProjectExtension.)
Public Extension Method | LoadXML(XmlDocument) | Overloaded. Loads project from specified xml document. (Defined by DotNetProjectExtension.)
Public Extension Method | Save | Saves the project to the file system, if modified. (Defined by DotNetProjectExtension.)
Top
See Also

Reference

IronPythonProject Class
Alternet.Editor.IronPython Namespace


IronPythonProject Properties

IronPythonProject Properties

The IronPythonProject type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyResources | Gets the list of the assembly (with Generator option) resources embedded into the project. (Inherited from DotNetProject.)
Public property | AutoReferences | (Inherited from DotNetProject.)
Public property | DefaultExtension | Gets a default extension of the project's code files. (Overrides DotNetProjectDefaultExtension.)
Public property | Files | Gets list of files included in the project. (Inherited from Project.)
Public property | FrameworkReferences | (Inherited from DotNetProject.)
Public property | HasProject | Gets a value indicating whether project contains some data. (Inherited from Project.)
Public property | ImportedNamespaces | Gets list of imported namespaces used in the project. (Inherited from DotNetProject.)
Public property | IsFolder | Gets or sets a boolean value indicates whether this Project represents a folder within project collection. (Inherited from Project.)
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save. (Inherited from Project.)
Public property | IsSdkStyle | Gets a value indicating whether this is SDK-style. (Inherited from DotNetProject.)
Public property | IsWpf | Gets a value indicating whether this is WPF project or not. (Inherited from DotNetProject.)
Public property | Parent | Gets or sets a Project that is a parent of this project. (Inherited from DotNetProject.)
Public property | ProjectDependencies | Gets or sets list of project's dependencies. (Inherited from DotNetProject.)
Public property | ProjectExtension | Gets an extension of the this project. (Inherited from DotNetProject.)
Public property | ProjectFileName | Gets fully qualified name of the project file. (Inherited from Project.)
Public property | ProjectGuid | Gets or sets's project's GUID. (Inherited from DotNetProject.)
Public property | ProjectHostGuid | Gets or sets's project's host GUID. (Inherited from DotNetProject.)
Public property | ProjectName | Gets or sets project's name. (Inherited from Project.)
Public property | ProjectReferences | Gets list of assemblies used in the project. (Inherited from DotNetProject.)
Public property | References | Gets list of assemblies used in the project. (Inherited from DotNetProject.)
Public property | RelativePath | Gets or sets a relative file path of this project. (Inherited from DotNetProject.)
Public property | Resources | Gets the list of the resources embedded into the project. (Inherited from Project.)
Public property | RootNamespace | Gets project's root namespace. (Inherited from DotNetProject.)
Public property | SolutionSettings | Gets a ProjectSolutionSettings for this project. (Inherited from DotNetProject.)
Public property | TargetFramework | (Inherited from DotNetProject.)
Public property | UserSettings | Gets user defined settings for this project. (Inherited from Project.)
Top
See Also

Reference

IronPythonProject Class
Alternet.Editor.IronPython Namespace


IronPythonProject.DefaultExtension Property

IronPythonProjectDefaultExtension Property
Gets a default extension of the project's code files.

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string DefaultExtension { get; }
Public Overrides ReadOnly Property DefaultExtension As String
    Get
public:
virtual property String^ DefaultExtension {
    String^ get () override;
}
abstract DefaultExtension : string with get
override DefaultExtension : string with get

Property Value

Type: String
See Also

Reference

IronPythonProject Class
Alternet.Editor.IronPython Namespace


IronPythonProject Events

IronPythonProject Events

The IronPythonProject type exposes the following members.

Events
 | Name | Description
Public event | ProjectModified | Occurs when project content was modified. (Inherited from Project.)
Top
See Also

Reference

IronPythonProject Class
Alternet.Editor.IronPython Namespace


NavigateToNodeRequestedEventArgs Class

NavigateToNodeRequestedEventArgs Class
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.IronPythonNavigateToNodeRequestedEventArgs

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NavigateToNodeRequestedEventArgs : EventArgs
Public Class NavigateToNodeRequestedEventArgs
    Inherits EventArgs
public ref class NavigateToNodeRequestedEventArgs : public EventArgs
type NavigateToNodeRequestedEventArgs =
    class
        inherit EventArgs
    end

The NavigateToNodeRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NavigateToNodeRequestedEventArgs | Initializes a new instance of the NavigateToNodeRequestedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Node |
Top
See Also

Reference

Alternet.Editor.IronPython Namespace


NavigateToNodeRequestedEventArgs Constructor

NavigateToNodeRequestedEventArgs Constructor
Initializes a new instance of the NavigateToNodeRequestedEventArgs class

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NavigateToNodeRequestedEventArgs(
    Object node
)
Public Sub New (
    node As Object
)
public:
NavigateToNodeRequestedEventArgs(
    Object^ node
)
new :
        node : Object -> NavigateToNodeRequestedEventArgs

Parameters

node
Type: SystemObject
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.IronPython Namespace


NavigateToNodeRequestedEventArgs Methods

NavigateToNodeRequestedEventArgs Methods

The NavigateToNodeRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.IronPython Namespace


NavigateToNodeRequestedEventArgs Properties

NavigateToNodeRequestedEventArgs Properties

The NavigateToNodeRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node |
Top
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.IronPython Namespace


NavigateToNodeRequestedEventArgs.Node Property

NavigateToNodeRequestedEventArgsNode Property

Namespace: Alternet.Editor.IronPython
Assembly: Alternet.Editor.IronPython.v7 (in Alternet.Editor.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Node { get; }
Public ReadOnly Property Node As Object
    Get
public:
property Object^ Node {
    Object^ get ();
}
member Node : Object with get

Property Value

Type: Object
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.IronPython Namespace


Alternet.Editor.Roslyn Namespace

Alternet.Editor.Roslyn Namespace
Classes
 | Class | Description
Public class | CodeEditExtensions |
Public class | CodeEditExtensionsCsScriptParser |
Public class | CodeEditExtensionsVbScriptParser |
Public class | CodeExplorer | Represents methods used to explore parsed representation of the source code in the TreeView control.
Public class | CodeUtils | Represents extended functionality to fill classes and methods lists related to the position inside the text document.
Public class | CSUtils | Represents extended functionality to explore code in the project.
Public class | NavigateToNodeRequestedEventArgs |
Public class | ResolveReferenceEventArgs | Provides data for the IScriptRun.ReferenceResolve event.
Public class | VBUtils | Represents extended functionality to explore code in the project.


CodeEditExtensions Class

CodeEditExtensions Class
Inheritance Hierarchy
SystemObject
Alternet.Editor.RoslynCodeEditExtensions

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CodeEditExtensions
<ExtensionAttribute>
Public NotInheritable Class CodeEditExtensions
[ExtensionAttribute]
public ref class CodeEditExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type CodeEditExtensions =  class end

The CodeEditExtensions type exposes the following members.

Methods
Name | Description
CloseProject |
DetectTargetFrameworkFromReferences |
DetectTechnologyEnvironmentFromReferences |
Document |
FindDeclaration |
FindImplementations |
FindReferences |
InitSyntax |
InitSyntax(IScriptEdit) |
OpenProject |
RegisterAssemblies(IScriptEdit, String) |
RegisterAssemblies(String, String, NullableTechnologyEnvironment, Boolean, String, TargetFramework) |
RegisterAssembly |
RegisterCode(String, String, String) |
RegisterCode(IScriptEdit, String, String) |
RegisterDefaultAssemblies |
RegisterNamespaces |
RegisterProjectReferences |
ReplaceCodeFile |
SetFileNameAndProject |
UnregisterAssemblies(IScriptEdit, String) |
UnregisterAssemblies(String, TechnologyEnvironment, String) |
UnregisterAssembly |
UnregisterCode(IScriptEdit, String) |
UnregisterCode(String, String, String) |
UnregisterProjectReferences |
Top
Events
Name | Description
ReferenceResolve |
Top
See Also

Reference

Alternet.Editor.Roslyn Namespace


CodeEditExtensions Methods

CodeEditExtensions Methods

The CodeEditExtensions type exposes the following members.

Methods
Name | Description
CloseProject |
DetectTargetFrameworkFromReferences |
DetectTechnologyEnvironmentFromReferences |
Document |
FindDeclaration |
FindImplementations |
FindReferences |
InitSyntax |
InitSyntax(IScriptEdit) |
OpenProject |
RegisterAssemblies(IScriptEdit, String) |
RegisterAssemblies(String, String, NullableTechnologyEnvironment, Boolean, String, TargetFramework) |
RegisterAssembly |
RegisterCode(String, String, String) |
RegisterCode(IScriptEdit, String, String) |
RegisterDefaultAssemblies |
RegisterNamespaces |
RegisterProjectReferences |
ReplaceCodeFile |
SetFileNameAndProject |
UnregisterAssemblies(IScriptEdit, String) |
UnregisterAssemblies(String, TechnologyEnvironment, String) |
UnregisterAssembly |
UnregisterCode(IScriptEdit, String) |
UnregisterCode(String, String, String) |
UnregisterProjectReferences |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.CloseProject Method

CodeEditExtensionsCloseProject Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CloseProject(
    string extension,
    string projectName
)
Public Shared Function CloseProject (
    extension As String,
    projectName As String
) As Boolean
public:
static bool CloseProject(
    String^ extension,
    String^ projectName
)
static member CloseProject :
        extension : string *
        projectName : string -> bool

Parameters

extension
Type: SystemString
projectName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.DetectTargetFrameworkFromReferences Method

CodeEditExtensionsDetectTargetFrameworkFromReferences Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TargetFramework DetectTargetFrameworkFromReferences(
    string[] references
)
Public Shared Function DetectTargetFrameworkFromReferences (
    references As String()
) As TargetFramework
public:
static TargetFramework^ DetectTargetFrameworkFromReferences(
    array<String^>^ references
)
static member DetectTargetFrameworkFromReferences :
        references : string[] -> TargetFramework

Parameters

references
Type: SystemString

Return Value

Type: TargetFramework
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.DetectTechnologyEnvironmentFromReferences Method

CodeEditExtensionsDetectTechnologyEnvironmentFromReferences Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TechnologyEnvironment DetectTechnologyEnvironmentFromReferences(
    string[] references
)
Public Shared Function DetectTechnologyEnvironmentFromReferences (
    references As String()
) As TechnologyEnvironment
public:
static TechnologyEnvironment DetectTechnologyEnvironmentFromReferences(
    array<String^>^ references
)
static member DetectTechnologyEnvironmentFromReferences :
        references : string[] -> TechnologyEnvironment

Parameters

references
Type: SystemString

Return Value

Type: TechnologyEnvironment
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.Document Method

CodeEditExtensionsDocument Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Document(
    this IScriptEdit edit
)
<ExtensionAttribute>
Public Shared Function Document (
    edit As IScriptEdit
) As Object
public:
[ExtensionAttribute]
static Object^ Document(
    IScriptEdit^ edit
)
[<ExtensionAttribute>]
static member Document :
        edit : IScriptEdit -> Object

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit

Return Value

Type: Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.FindDeclaration Method

CodeEditExtensionsFindDeclaration Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SymbolLocation FindDeclaration(
    this IScriptEdit edit,
    Point position
)
<ExtensionAttribute>
Public Shared Function FindDeclaration (
    edit As IScriptEdit,
    position As Point
) As SymbolLocation
public:
[ExtensionAttribute]
static SymbolLocation^ FindDeclaration(
    IScriptEdit^ edit,
    Point position
)
[<ExtensionAttribute>]
static member FindDeclaration :
        edit : IScriptEdit *
        position : Point -> SymbolLocation

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
position
Type: System.DrawingPoint

Return Value

Type: SymbolLocation

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.FindImplementations Method

CodeEditExtensionsFindImplementations Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int FindImplementations(
    this IScriptEdit edit,
    Point position,
    IRangeList references
)
<ExtensionAttribute>
Public Shared Function FindImplementations (
    edit As IScriptEdit,
    position As Point,
    references As IRangeList
) As Integer
public:
[ExtensionAttribute]
static int FindImplementations(
    IScriptEdit^ edit,
    Point position,
    IRangeList^ references
)
[<ExtensionAttribute>]
static member FindImplementations :
        edit : IScriptEdit *
        position : Point *
        references : IRangeList -> int

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
position
Type: System.DrawingPoint
references
Type: Alternet.CommonIRangeList

Return Value

Type: Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.FindReferences Method

CodeEditExtensionsFindReferences Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int FindReferences(
    this IScriptEdit edit,
    Point position,
    IRangeList references
)
<ExtensionAttribute>
Public Shared Function FindReferences (
    edit As IScriptEdit,
    position As Point,
    references As IRangeList
) As Integer
public:
[ExtensionAttribute]
static int FindReferences(
    IScriptEdit^ edit,
    Point position,
    IRangeList^ references
)
[<ExtensionAttribute>]
static member FindReferences :
        edit : IScriptEdit *
        position : Point *
        references : IRangeList -> int

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
position
Type: System.DrawingPoint
references
Type: Alternet.CommonIRangeList

Return Value

Type: Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.InitSyntax Method

CodeEditExtensionsInitSyntax Method
Overload List
Name | Description
InitSyntax |
InitSyntax(IScriptEdit) |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.InitSyntax Method

CodeEditExtensionsInitSyntax Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void InitSyntax()
Public Shared Sub InitSyntax
public:
static void InitSyntax()
static member InitSyntax : unit -> unit
See Also

Reference

CodeEditExtensions Class
InitSyntax Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.InitSyntax Method (IScriptEdit)

CodeEditExtensionsInitSyntax Method (IScriptEdit)

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void InitSyntax(
    this IScriptEdit edit
)
<ExtensionAttribute>
Public Shared Sub InitSyntax (
    edit As IScriptEdit
)
public:
[ExtensionAttribute]
static void InitSyntax(
    IScriptEdit^ edit
)
[<ExtensionAttribute>]
static member InitSyntax :
        edit : IScriptEdit -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
InitSyntax Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.OpenProject Method

CodeEditExtensionsOpenProject Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void OpenProject(
    string extension,
    string projectName,
    string projectPath
)
Public Shared Sub OpenProject (
    extension As String,
    projectName As String,
    projectPath As String
)
public:
static void OpenProject(
    String^ extension,
    String^ projectName,
    String^ projectPath
)
static member OpenProject :
        extension : string *
        projectName : string *
        projectPath : string -> unit

Parameters

extension
Type: SystemString
projectName
Type: SystemString
projectPath
Type: SystemString
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterAssemblies Method

CodeEditExtensionsRegisterAssemblies Method
Overload List
Name | Description
RegisterAssemblies(IScriptEdit, String) |
RegisterAssemblies(String, String, NullableTechnologyEnvironment, Boolean, String, TargetFramework) |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterAssemblies Method (IScriptEdit, String[])

CodeEditExtensionsRegisterAssemblies Method (IScriptEdit, String)

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterAssemblies(
    this IScriptEdit edit,
    string[] references
)
<ExtensionAttribute>
Public Shared Sub RegisterAssemblies (
    edit As IScriptEdit,
    references As String()
)
public:
[ExtensionAttribute]
static void RegisterAssemblies(
    IScriptEdit^ edit,
    array<String^>^ references
)
[<ExtensionAttribute>]
static member RegisterAssemblies :
        edit : IScriptEdit *
        references : string[] -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
references
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
RegisterAssemblies Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterAssemblies Method (String, String[], Nullable(TechnologyEnvironment), Boolean, String, TargetFramework)

CodeEditExtensionsRegisterAssemblies Method (String, String, NullableTechnologyEnvironment, Boolean, String, TargetFramework)

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterAssemblies(
    string extension,
    string[] references,
    Nullable<TechnologyEnvironment> technology = null,
    bool keepExisting = false,
    string projectName = null,
    TargetFramework targetFramework = null
)
Public Shared Sub RegisterAssemblies (
    extension As String,
    references As String(),
    Optional technology As Nullable(Of TechnologyEnvironment) = Nothing,
    Optional keepExisting As Boolean = false,
    Optional projectName As String = Nothing,
    Optional targetFramework As TargetFramework = Nothing
)
public:
static void RegisterAssemblies(
    String^ extension,
    array<String^>^ references,
    Nullable<TechnologyEnvironment> technology = nullptr,
    bool keepExisting = false,
    String^ projectName = nullptr,
    TargetFramework^ targetFramework = nullptr
)
static member RegisterAssemblies :
        extension : string *
        references : string[] *
        ?technology : Nullable<TechnologyEnvironment> *
        ?keepExisting : bool *
        ?projectName : string *
        ?targetFramework : TargetFramework
(* Defaults:
        let _technology = defaultArg technology null
        let _keepExisting = defaultArg keepExisting false
        let _projectName = defaultArg projectName null
        let _targetFramework = defaultArg targetFramework null
*)
-> unit

Parameters

extension
Type: SystemString
references
Type: SystemString
technology (Optional)
Type: SystemNullableTechnologyEnvironment
keepExisting (Optional)
Type: SystemBoolean
projectName (Optional)
Type: SystemString
targetFramework (Optional)
Type: Alternet.Common.DotNet.ProjectsTargetFramework
See Also

Reference

CodeEditExtensions Class
RegisterAssemblies Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterAssembly Method

CodeEditExtensionsRegisterAssembly Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterAssembly(
    this IScriptEdit edit,
    string reference
)
<ExtensionAttribute>
Public Shared Sub RegisterAssembly (
    edit As IScriptEdit,
    reference As String
)
public:
[ExtensionAttribute]
static void RegisterAssembly(
    IScriptEdit^ edit,
    String^ reference
)
[<ExtensionAttribute>]
static member RegisterAssembly :
        edit : IScriptEdit *
        reference : string -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
reference
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterCode Method

CodeEditExtensionsRegisterCode Method
Overload List
Name | Description
RegisterCode(String, String, String) |
RegisterCode(IScriptEdit, String, String) |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterCode Method (String, String[], String)

CodeEditExtensionsRegisterCode Method (String, String, String)

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCode(
    string extension,
    string[] files,
    string projectName = null
)
Public Shared Sub RegisterCode (
    extension As String,
    files As String(),
    Optional projectName As String = Nothing
)
public:
static void RegisterCode(
    String^ extension,
    array<String^>^ files,
    String^ projectName = nullptr
)
static member RegisterCode :
        extension : string *
        files : string[] *
        ?projectName : string
(* Defaults:
        let _projectName = defaultArg projectName null
*)
-> unit

Parameters

extension
Type: SystemString
files
Type: SystemString
projectName (Optional)
Type: SystemString
See Also

Reference

CodeEditExtensions Class
RegisterCode Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterCode Method (IScriptEdit, String, String)

CodeEditExtensionsRegisterCode Method (IScriptEdit, String, String)

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCode(
    this IScriptEdit edit,
    string fileName,
    string text
)
<ExtensionAttribute>
Public Shared Sub RegisterCode (
    edit As IScriptEdit,
    fileName As String,
    text As String
)
public:
[ExtensionAttribute]
static void RegisterCode(
    IScriptEdit^ edit,
    String^ fileName,
    String^ text
)
[<ExtensionAttribute>]
static member RegisterCode :
        edit : IScriptEdit *
        fileName : string *
        text : string -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
fileName
Type: SystemString
text
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
RegisterCode Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterDefaultAssemblies Method

CodeEditExtensionsRegisterDefaultAssemblies Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterDefaultAssemblies(
    this IScriptEdit edit,
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms,
    bool keepExisting = false
)
<ExtensionAttribute>
Public Shared Sub RegisterDefaultAssemblies (
    edit As IScriptEdit,
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms,
    Optional keepExisting As Boolean = false
)
public:
[ExtensionAttribute]
static void RegisterDefaultAssemblies(
    IScriptEdit^ edit,
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms,
    bool keepExisting = false
)
[<ExtensionAttribute>]
static member RegisterDefaultAssemblies :
        edit : IScriptEdit *
        ?technology : TechnologyEnvironment *
        ?keepExisting : bool
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
*)
-> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
keepExisting (Optional)
Type: SystemBoolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterNamespaces Method

CodeEditExtensionsRegisterNamespaces Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterNamespaces(
    this IScriptEdit edit,
    string[] namespaces
)
<ExtensionAttribute>
Public Shared Sub RegisterNamespaces (
    edit As IScriptEdit,
    namespaces As String()
)
public:
[ExtensionAttribute]
static void RegisterNamespaces(
    IScriptEdit^ edit,
    array<String^>^ namespaces
)
[<ExtensionAttribute>]
static member RegisterNamespaces :
        edit : IScriptEdit *
        namespaces : string[] -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
namespaces
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.RegisterProjectReferences Method

CodeEditExtensionsRegisterProjectReferences Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterProjectReferences(
    string extension,
    string[] projectReferences,
    string projectName = null
)
Public Shared Sub RegisterProjectReferences (
    extension As String,
    projectReferences As String(),
    Optional projectName As String = Nothing
)
public:
static void RegisterProjectReferences(
    String^ extension,
    array<String^>^ projectReferences,
    String^ projectName = nullptr
)
static member RegisterProjectReferences :
        extension : string *
        projectReferences : string[] *
        ?projectName : string
(* Defaults:
        let _projectName = defaultArg projectName null
*)
-> unit

Parameters

extension
Type: SystemString
projectReferences
Type: SystemString
projectName (Optional)
Type: SystemString
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.ReplaceCodeFile Method

CodeEditExtensionsReplaceCodeFile Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ReplaceCodeFile(
    string extension,
    string fileName,
    string text,
    string projectName = null
)
Public Shared Sub ReplaceCodeFile (
    extension As String,
    fileName As String,
    text As String,
    Optional projectName As String = Nothing
)
public:
static void ReplaceCodeFile(
    String^ extension,
    String^ fileName,
    String^ text,
    String^ projectName = nullptr
)
static member ReplaceCodeFile :
        extension : string *
        fileName : string *
        text : string *
        ?projectName : string
(* Defaults:
        let _projectName = defaultArg projectName null
*)
-> unit

Parameters

extension
Type: SystemString
fileName
Type: SystemString
text
Type: SystemString
projectName (Optional)
Type: SystemString
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.SetFileNameAndProject Method

CodeEditExtensionsSetFileNameAndProject Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetFileNameAndProject(
    this IScriptEdit edit,
    string fileName,
    string projectName
)
<ExtensionAttribute>
Public Shared Sub SetFileNameAndProject (
    edit As IScriptEdit,
    fileName As String,
    projectName As String
)
public:
[ExtensionAttribute]
static void SetFileNameAndProject(
    IScriptEdit^ edit,
    String^ fileName,
    String^ projectName
)
[<ExtensionAttribute>]
static member SetFileNameAndProject :
        edit : IScriptEdit *
        fileName : string *
        projectName : string -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
fileName
Type: SystemString
projectName
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.UnregisterAssemblies Method

CodeEditExtensionsUnregisterAssemblies Method
Overload List
Name | Description
UnregisterAssemblies(IScriptEdit, String) |
UnregisterAssemblies(String, TechnologyEnvironment, String) |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.UnregisterAssemblies Method (IScriptEdit, String[])

CodeEditExtensionsUnregisterAssemblies Method (IScriptEdit, String)

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterAssemblies(
    this IScriptEdit edit,
    string[] assemblies
)
<ExtensionAttribute>
Public Shared Sub UnregisterAssemblies (
    edit As IScriptEdit,
    assemblies As String()
)
public:
[ExtensionAttribute]
static void UnregisterAssemblies(
    IScriptEdit^ edit,
    array<String^>^ assemblies
)
[<ExtensionAttribute>]
static member UnregisterAssemblies :
        edit : IScriptEdit *
        assemblies : string[] -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
assemblies
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
UnregisterAssemblies Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.UnregisterAssemblies Method (String, TechnologyEnvironment, String)

CodeEditExtensionsUnregisterAssemblies Method (String, TechnologyEnvironment, String)

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterAssemblies(
    string extension,
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms,
    string projectName = null
)
Public Shared Sub UnregisterAssemblies (
    extension As String,
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms,
    Optional projectName As String = Nothing
)
public:
static void UnregisterAssemblies(
    String^ extension,
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms,
    String^ projectName = nullptr
)
static member UnregisterAssemblies :
        extension : string *
        ?technology : TechnologyEnvironment *
        ?projectName : string
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
        let _projectName = defaultArg projectName null
*)
-> unit

Parameters

extension
Type: SystemString
technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
projectName (Optional)
Type: SystemString
See Also

Reference

CodeEditExtensions Class
UnregisterAssemblies Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.UnregisterAssembly Method

CodeEditExtensionsUnregisterAssembly Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterAssembly(
    this IScriptEdit edit,
    string reference
)
<ExtensionAttribute>
Public Shared Sub UnregisterAssembly (
    edit As IScriptEdit,
    reference As String
)
public:
[ExtensionAttribute]
static void UnregisterAssembly(
    IScriptEdit^ edit,
    String^ reference
)
[<ExtensionAttribute>]
static member UnregisterAssembly :
        edit : IScriptEdit *
        reference : string -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
reference
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.UnregisterCode Method

CodeEditExtensionsUnregisterCode Method
Overload List
Name | Description
UnregisterCode(IScriptEdit, String) |
UnregisterCode(String, String, String) |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.UnregisterCode Method (IScriptEdit, String)

CodeEditExtensionsUnregisterCode Method (IScriptEdit, String)

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCode(
    this IScriptEdit edit,
    string fileName
)
<ExtensionAttribute>
Public Shared Sub UnregisterCode (
    edit As IScriptEdit,
    fileName As String
)
public:
[ExtensionAttribute]
static void UnregisterCode(
    IScriptEdit^ edit,
    String^ fileName
)
[<ExtensionAttribute>]
static member UnregisterCode :
        edit : IScriptEdit *
        fileName : string -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
fileName
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
UnregisterCode Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.UnregisterCode Method (String, String[], String)

CodeEditExtensionsUnregisterCode Method (String, String, String)

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCode(
    string extension,
    string[] files,
    string projectName = null
)
Public Shared Sub UnregisterCode (
    extension As String,
    files As String(),
    Optional projectName As String = Nothing
)
public:
static void UnregisterCode(
    String^ extension,
    array<String^>^ files,
    String^ projectName = nullptr
)
static member UnregisterCode :
        extension : string *
        files : string[] *
        ?projectName : string
(* Defaults:
        let _projectName = defaultArg projectName null
*)
-> unit

Parameters

extension
Type: SystemString
files
Type: SystemString
projectName (Optional)
Type: SystemString
See Also

Reference

CodeEditExtensions Class
UnregisterCode Overload
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.UnregisterProjectReferences Method

CodeEditExtensionsUnregisterProjectReferences Method

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterProjectReferences(
    string extension,
    string projectName = null
)
Public Shared Sub UnregisterProjectReferences (
    extension As String,
    Optional projectName As String = Nothing
)
public:
static void UnregisterProjectReferences(
    String^ extension,
    String^ projectName = nullptr
)
static member UnregisterProjectReferences :
        extension : string *
        ?projectName : string
(* Defaults:
        let _projectName = defaultArg projectName null
*)
-> unit

Parameters

extension
Type: SystemString
projectName (Optional)
Type: SystemString
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions Events

CodeEditExtensions Events

The CodeEditExtensions type exposes the following members.

Events
Name | Description
ReferenceResolve |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.ReferenceResolve Event

CodeEditExtensionsReferenceResolve Event

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler<ResolveReferenceEventArgs> ReferenceResolve
Public Shared Event ReferenceResolve As EventHandler(Of ResolveReferenceEventArgs)
public:
static  event EventHandler<ResolveReferenceEventArgs^>^ ReferenceResolve {
    void add (EventHandler<ResolveReferenceEventArgs^>^ value);
    void remove (EventHandler<ResolveReferenceEventArgs^>^ value);
}
member ReferenceResolve : IEvent<EventHandler<ResolveReferenceEventArgs>,
    ResolveReferenceEventArgs>

Value

Type: SystemEventHandlerResolveReferenceEventArgs
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.CsScriptParser Class

CodeEditExtensionsCsScriptParser Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.RoslynRoslynParser
Alternet.Syntax.Parsers.RoslynCsParser
Alternet.Editor.RoslynCodeEditExtensionsCsScriptParser

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CsScriptParser : CsParser
Public Class CsScriptParser
    Inherits CsParser
public ref class CsScriptParser : public CsParser
type CsScriptParser =
    class
        inherit CsParser
    end

The CodeEditExtensionsCsScriptParser type exposes the following members.

Constructors
 | Name | Description
Public method | CodeEditExtensionsCsScriptParser | Initializes a new instance of the CodeEditExtensionsCsScriptParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CsParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from RoslynParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from RoslynParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing. (Inherited from RoslynParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from RoslynParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from CsParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from RoslynParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from CsParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from RoslynParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from RoslynParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from RoslynParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Inherited from RoslynParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from RoslynParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from RoslynParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from RoslynParser.)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from RoslynParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Inherited from RoslynParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from RoslynParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from RoslynParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from RoslynParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from CsParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from CsParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from RoslynParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from RoslynParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from CsParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from CsParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from RoslynParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from RoslynParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from RoslynParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from RoslynParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from RoslynParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName | (Inherited from RoslynParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from RoslynParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer | (Inherited from RoslynParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from RoslynParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from RoslynParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Editor.Roslyn Namespace


CodeEditExtensions.CsScriptParser Constructor

CodeEditExtensionsCsScriptParser Constructor
Initializes a new instance of the CodeEditExtensionsCsScriptParser class

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsScriptParser()
Public Sub New
public:
CsScriptParser()
new : unit -> CsScriptParser
See Also

Reference

CodeEditExtensionsCsScriptParser Class
Alternet.Editor.Roslyn Namespace


CsScriptParser Methods

CsScriptParser Methods

The CodeEditExtensionsCsScriptParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CsParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from RoslynParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from RoslynParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing. (Inherited from RoslynParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from RoslynParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from CsParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from RoslynParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from CsParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from RoslynParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from RoslynParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from RoslynParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Inherited from RoslynParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from RoslynParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from RoslynParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from RoslynParser.)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from RoslynParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Inherited from RoslynParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from RoslynParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from RoslynParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from RoslynParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from CsParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from CsParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from RoslynParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from RoslynParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from CsParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from CsParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from RoslynParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from RoslynParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from RoslynParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from RoslynParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CodeEditExtensionsCsScriptParser Class
Alternet.Editor.Roslyn Namespace


CsScriptParser Properties

CsScriptParser Properties

The CodeEditExtensionsCsScriptParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from RoslynParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName | (Inherited from RoslynParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from RoslynParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer | (Inherited from RoslynParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from RoslynParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from RoslynParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CodeEditExtensionsCsScriptParser Class
Alternet.Editor.Roslyn Namespace


CsScriptParser Events

CsScriptParser Events

The CodeEditExtensionsCsScriptParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CodeEditExtensionsCsScriptParser Class
Alternet.Editor.Roslyn Namespace


CodeEditExtensions.VbScriptParser Class

CodeEditExtensionsVbScriptParser Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.RoslynRoslynParser
Alternet.Syntax.Parsers.RoslynVbParser
Alternet.Editor.RoslynCodeEditExtensionsVbScriptParser

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbScriptParser : VbParser
Public Class VbScriptParser
    Inherits VbParser
public ref class VbScriptParser : public VbParser
type VbScriptParser =
    class
        inherit VbParser
    end

The CodeEditExtensionsVbScriptParser type exposes the following members.

Constructors
 | Name | Description
Public method | CodeEditExtensionsVbScriptParser | Initializes a new instance of the CodeEditExtensionsVbScriptParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from VbParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from RoslynParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from RoslynParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing. (Inherited from RoslynParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from RoslynParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from VbParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from RoslynParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from VbParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from RoslynParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from RoslynParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from RoslynParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Inherited from RoslynParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from RoslynParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from RoslynParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from RoslynParser.)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from RoslynParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Inherited from RoslynParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from RoslynParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from RoslynParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from RoslynParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from VbParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from VbParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from VbParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from RoslynParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from VbParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from VbParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from VbParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from VbParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from VbParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from RoslynParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from RoslynParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from RoslynParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from VbParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from RoslynParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from RoslynParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName | (Inherited from RoslynParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from RoslynParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer | (Inherited from RoslynParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from RoslynParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from RoslynParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Editor.Roslyn Namespace


CodeEditExtensions.VbScriptParser Constructor

CodeEditExtensionsVbScriptParser Constructor
Initializes a new instance of the CodeEditExtensionsVbScriptParser class

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbScriptParser()
Public Sub New
public:
VbScriptParser()
new : unit -> VbScriptParser
See Also

Reference

CodeEditExtensionsVbScriptParser Class
Alternet.Editor.Roslyn Namespace


VbScriptParser Methods

VbScriptParser Methods

The CodeEditExtensionsVbScriptParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from VbParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from RoslynParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from RoslynParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing. (Inherited from RoslynParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from RoslynParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from VbParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from RoslynParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from VbParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from RoslynParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from RoslynParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from RoslynParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Inherited from RoslynParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from RoslynParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from RoslynParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from RoslynParser.)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from RoslynParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Inherited from RoslynParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from RoslynParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from RoslynParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from RoslynParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from VbParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from VbParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from VbParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from RoslynParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from VbParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from VbParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from VbParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from VbParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from VbParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from RoslynParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from RoslynParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from RoslynParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from VbParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from RoslynParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CodeEditExtensionsVbScriptParser Class
Alternet.Editor.Roslyn Namespace


VbScriptParser Properties

VbScriptParser Properties

The CodeEditExtensionsVbScriptParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from RoslynParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName | (Inherited from RoslynParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from RoslynParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer | (Inherited from RoslynParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from RoslynParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from RoslynParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CodeEditExtensionsVbScriptParser Class
Alternet.Editor.Roslyn Namespace


VbScriptParser Events

VbScriptParser Events

The CodeEditExtensionsVbScriptParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CodeEditExtensionsVbScriptParser Class
Alternet.Editor.Roslyn Namespace


CodeExplorer Class

CodeExplorer Class
Represents methods used to explore parsed representation of the source code in the TreeView control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.RoslynCodeExplorer

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeExplorer
Public Class CodeExplorer
public ref class CodeExplorer
type CodeExplorer =  class end

The CodeExplorer type exposes the following members.

Constructors
 | Name | Description
Public method | CodeExplorer | Initializes a new instance of the CodeExplorer class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ScopeImageIndex | Calculates offset for the image index accordingly to the visibility scope.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given source document.
Top
Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore source code.
Top
Events
 | Name | Description
Public event | NavigateToNodeRequested |
Top
See Also

Reference

Alternet.Editor.Roslyn Namespace


CodeExplorer Constructor

CodeExplorer Constructor
Initializes a new instance of the CodeExplorer class with default settings.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeExplorer()
Public Sub New
public:
CodeExplorer()
new : unit -> CodeExplorer
See Also

Reference

CodeExplorer Class
Alternet.Editor.Roslyn Namespace


CodeExplorer Methods

CodeExplorer Methods

The CodeExplorer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ScopeImageIndex | Calculates offset for the image index accordingly to the visibility scope.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given source document.
Top
See Also

Reference

CodeExplorer Class
Alternet.Editor.Roslyn Namespace


CodeExplorer.ScopeImageIndex Method

CodeExplorerScopeImageIndex Method
Calculates offset for the image index accordingly to the visibility scope.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int ScopeImageIndex(
    SyntaxNode node,
    bool isScopedImage
)
Public Shared Function ScopeImageIndex (
    node As SyntaxNode,
    isScopedImage As Boolean
) As Integer
public:
static int ScopeImageIndex(
    SyntaxNode^ node,
    bool isScopedImage
)
static member ScopeImageIndex :
        node : SyntaxNode *
        isScopedImage : bool -> int

Parameters

node
Type: SyntaxNode
Syntax element.
isScopedImage
Type: SystemBoolean
Indicates whether image index needs to be adjusted.

Return Value

Type: Int32
The amount to offset.
See Also

Reference

CodeExplorer Class
Alternet.Editor.Roslyn Namespace


CodeExplorer.UpdateExplorer Method

CodeExplorerUpdateExplorer Method
Updates explorer content from given source document.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateExplorer(
    Object document
)
Public Sub UpdateExplorer (
    document As Object
)
public:
void UpdateExplorer(
    Object^ document
)
member UpdateExplorer :
        document : Object -> unit

Parameters

document
Type: SystemObject
Source code document.
See Also

Reference

CodeExplorer Class
Alternet.Editor.Roslyn Namespace


CodeExplorer Properties

CodeExplorer Properties

The CodeExplorer type exposes the following members.

Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore source code.
Top
See Also

Reference

CodeExplorer Class
Alternet.Editor.Roslyn Namespace


CodeExplorer.ExplorerTree Property

CodeExplorerExplorerTree Property
Gets or sets System.Windows.Forms.TreeView control used to explore source code.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeView ExplorerTree { get; set; }
Public Property ExplorerTree As TreeView
    Get
    Set
public:
property TreeView^ ExplorerTree {
    TreeView^ get ();
    void set (TreeView^ value);
}
member ExplorerTree : TreeView with get, set

Property Value

Type: TreeView
See Also

Reference

CodeExplorer Class
Alternet.Editor.Roslyn Namespace


CodeExplorer Events

CodeExplorer Events

The CodeExplorer type exposes the following members.

Events
 | Name | Description
Public event | NavigateToNodeRequested |
Top
See Also

Reference

CodeExplorer Class
Alternet.Editor.Roslyn Namespace


CodeExplorer.NavigateToNodeRequested Event

CodeExplorerNavigateToNodeRequested Event

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<NavigateToNodeRequestedEventArgs> NavigateToNodeRequested
Public Event NavigateToNodeRequested As EventHandler(Of NavigateToNodeRequestedEventArgs)
public:
 event EventHandler<NavigateToNodeRequestedEventArgs^>^ NavigateToNodeRequested {
    void add (EventHandler<NavigateToNodeRequestedEventArgs^>^ value);
    void remove (EventHandler<NavigateToNodeRequestedEventArgs^>^ value);
}
member NavigateToNodeRequested : IEvent<EventHandler<NavigateToNodeRequestedEventArgs>,
    NavigateToNodeRequestedEventArgs>

Value

Type: SystemEventHandlerNavigateToNodeRequestedEventArgs
See Also

Reference

CodeExplorer Class
Alternet.Editor.Roslyn Namespace


CodeUtils Class

CodeUtils Class
Represents extended functionality to fill classes and methods lists related to the position inside the text document.
Inheritance Hierarchy
SystemObject
Alternet.Editor.RoslynCodeUtils

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeUtils
Public Class CodeUtils
public ref class CodeUtils
type CodeUtils =  class end

The CodeUtils type exposes the following members.

Constructors
 | Name | Description
Public method | CodeUtils | Initializes a new instance of the CodeUtils class
Top
Methods
 | Name | Description
 | DrawItem | Provides a custom drawing for a ComboBox item.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FillClasses | Fills given ComboBox with list of classes obtained from specified document at the given position.
 | FillMethods | Fills given ComboBox with list of methods obtained from specified document at the given position.
 | FormatText | Formats content of specified syntax element accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPosition | Finds position in source code related to the specified syntax element.
 | GetSelectedPosition | Finds position in source code related to the currently selected item in the ComboBox control.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | NavigateClasses | Updates content of given class ComboBox accordingly to given position.
 | NavigateMethods | Updates content of given method ComboBox accordingly to given position.
 | SelectItem | Finds position of the syntax element linked to the currently selected item in the ComboBox control.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Editor.Roslyn Namespace


CodeUtils Constructor

CodeUtils Constructor
Initializes a new instance of the CodeUtils class

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeUtils()
Public Sub New
public:
CodeUtils()
new : unit -> CodeUtils
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils Methods

CodeUtils Methods

The CodeUtils type exposes the following members.

Methods
 | Name | Description
 | DrawItem | Provides a custom drawing for a ComboBox item.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FillClasses | Fills given ComboBox with list of classes obtained from specified document at the given position.
 | FillMethods | Fills given ComboBox with list of methods obtained from specified document at the given position.
 | FormatText | Formats content of specified syntax element accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPosition | Finds position in source code related to the specified syntax element.
 | GetSelectedPosition | Finds position in source code related to the currently selected item in the ComboBox control.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | NavigateClasses | Updates content of given class ComboBox accordingly to given position.
 | NavigateMethods | Updates content of given method ComboBox accordingly to given position.
 | SelectItem | Finds position of the syntax element linked to the currently selected item in the ComboBox control.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils.DrawItem Method

CodeUtilsDrawItem Method
Provides a custom drawing for a ComboBox item.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawItem(
    ComboBox comboBox,
    DrawItemEventArgs e,
    ImageList images
)
Public Shared Sub DrawItem (
    comboBox As ComboBox,
    e As DrawItemEventArgs,
    images As ImageList
)
public:
static void DrawItem(
    ComboBox^ comboBox,
    DrawItemEventArgs^ e,
    ImageList^ images
)
static member DrawItem :
        comboBox : ComboBox *
        e : DrawItemEventArgs *
        images : ImageList -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox which item will be drawn.
e
Type: System.Windows.FormsDrawItemEventArgs
A DrawItemEventArgs that contains the event data.
images
Type: System.Windows.FormsImageList
List of images used to draw with items.
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils.FillClasses Method

CodeUtilsFillClasses Method
Fills given ComboBox with list of classes obtained from specified document at the given position.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void FillClasses(
    ComboBox comboBox,
    Object document,
    Point position
)
Public Shared Sub FillClasses (
    comboBox As ComboBox,
    document As Object,
    position As Point
)
public:
static void FillClasses(
    ComboBox^ comboBox,
    Object^ document,
    Point position
)
static member FillClasses :
        comboBox : ComboBox *
        document : Object *
        position : Point -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox control to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Position in code.
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils.FillMethods Method

CodeUtilsFillMethods Method
Fills given ComboBox with list of methods obtained from specified document at the given position.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void FillMethods(
    ComboBox comboBox,
    Object document,
    Point position,
    ComboBox classCombo
)
Public Shared Sub FillMethods (
    comboBox As ComboBox,
    document As Object,
    position As Point,
    classCombo As ComboBox
)
public:
static void FillMethods(
    ComboBox^ comboBox,
    Object^ document,
    Point position,
    ComboBox^ classCombo
)
static member FillMethods :
        comboBox : ComboBox *
        document : Object *
        position : Point *
        classCombo : ComboBox -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox control to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Position in code.
classCombo
Type: System.Windows.FormsComboBox
Contains list of classes.
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils.FormatText Method

CodeUtilsFormatText Method
Formats content of specified syntax element accordingly to language rules of the document.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FormatText(
    Object item
)
Public Shared Function FormatText (
    item As Object
) As String
public:
static String^ FormatText(
    Object^ item
)
static member FormatText :
        item : Object -> string

Parameters

item
Type: SystemObject
Syntax element to probe.

Return Value

Type: String
Formatted sting that contains a syntax element.
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils.GetPosition Method

CodeUtilsGetPosition Method
Finds position in source code related to the specified syntax element.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GetPosition(
    Object node,
    Object document,
    out Point point
)
Public Shared Function GetPosition (
    node As Object,
    document As Object,
    <OutAttribute> ByRef point As Point
) As Boolean
public:
static bool GetPosition(
    Object^ node,
    Object^ document,
    [OutAttribute] Point% point
)
static member GetPosition :
        node : Object *
        document : Object *
        point : Point byref -> bool

Parameters

node
Type: SystemObject
Syntax element (class or method) to probe.
document
Type: SystemObject
Source code document.
point
Type: System.DrawingPoint
Receives start point of given syntax element.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils.GetSelectedPosition Method

CodeUtilsGetSelectedPosition Method
Finds position in source code related to the currently selected item in the ComboBox control.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point GetSelectedPosition(
    ComboBox comboBox,
    Object document
)
Public Shared Function GetSelectedPosition (
    comboBox As ComboBox,
    document As Object
) As Point
public:
static Point GetSelectedPosition(
    ComboBox^ comboBox,
    Object^ document
)
static member GetSelectedPosition :
        comboBox : ComboBox *
        document : Object -> Point

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox contains list of syntax elements (classes or methods).
document
Type: SystemObject
Source code document.

Return Value

Type: Point
System.Draw.Point represents start point of current syntax element.
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils.NavigateClasses Method

CodeUtilsNavigateClasses Method
Updates content of given class ComboBox accordingly to given position.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void NavigateClasses(
    ComboBox comboBox,
    Object document,
    Point position
)
Public Shared Sub NavigateClasses (
    comboBox As ComboBox,
    document As Object,
    position As Point
)
public:
static void NavigateClasses(
    ComboBox^ comboBox,
    Object^ document,
    Point position
)
static member NavigateClasses :
        comboBox : ComboBox *
        document : Object *
        position : Point -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Position in code.
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils.NavigateMethods Method

CodeUtilsNavigateMethods Method
Updates content of given method ComboBox accordingly to given position.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void NavigateMethods(
    ComboBox comboBox,
    Object document,
    Point position,
    ComboBox classComboBox
)
Public Shared Sub NavigateMethods (
    comboBox As ComboBox,
    document As Object,
    position As Point,
    classComboBox As ComboBox
)
public:
static void NavigateMethods(
    ComboBox^ comboBox,
    Object^ document,
    Point position,
    ComboBox^ classComboBox
)
static member NavigateMethods :
        comboBox : ComboBox *
        document : Object *
        position : Point *
        classComboBox : ComboBox -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Position in code.
classComboBox
Type: System.Windows.FormsComboBox
Contains list of classes.
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CodeUtils.SelectItem Method

CodeUtilsSelectItem Method
Finds position of the syntax element linked to the currently selected item in the ComboBox control.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool SelectItem(
    ComboBox comboBox,
    Object document,
    out Point position
)
Public Shared Function SelectItem (
    comboBox As ComboBox,
    document As Object,
    <OutAttribute> ByRef position As Point
) As Boolean
public:
static bool SelectItem(
    ComboBox^ comboBox,
    Object^ document,
    [OutAttribute] Point% position
)
static member SelectItem :
        comboBox : ComboBox *
        document : Object *
        position : Point byref -> bool

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Receives start point of currently selected syntax element.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

CodeUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils Class

CSUtils Class
Represents extended functionality to explore code in the project.
Inheritance Hierarchy
SystemObject
Alternet.Editor.RoslynCSUtils

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CSUtils
Public Class CSUtils
public ref class CSUtils
type CSUtils =  class end

The CSUtils type exposes the following members.

Constructors
 | Name | Description
Public method | CSUtils | Initializes a new instance of the CSUtils class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetClassNode | Finds parent node of given SyntaxNode that is a class or structure node.
 | GetFormattedText | Formats content of specified SyntaxNode accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetIdentifierName | Gets formatted text describes identifier node.
 | GetMethodName | Gets formatted text describes name of the method node.
 | GetNodeList | Fills given list of SyntaxNode obtained from specified document at the given position.
 | GetNodeName | Gets formatted text describes name of the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidNode | Indicates whether this node is valid for explorer purposes.
 | ProcessMethodParams | Receives parameter data from given method node.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Editor.Roslyn Namespace


CSUtils Constructor

CSUtils Constructor
Initializes a new instance of the CSUtils class

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CSUtils()
Public Sub New
public:
CSUtils()
new : unit -> CSUtils
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils Methods

CSUtils Methods

The CSUtils type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetClassNode | Finds parent node of given SyntaxNode that is a class or structure node.
 | GetFormattedText | Formats content of specified SyntaxNode accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetIdentifierName | Gets formatted text describes identifier node.
 | GetMethodName | Gets formatted text describes name of the method node.
 | GetNodeList | Fills given list of SyntaxNode obtained from specified document at the given position.
 | GetNodeName | Gets formatted text describes name of the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidNode | Indicates whether this node is valid for explorer purposes.
 | ProcessMethodParams | Receives parameter data from given method node.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils.GetClassNode Method

CSUtilsGetClassNode Method
Finds parent node of given SyntaxNode that is a class or structure node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxNode GetClassNode(
    SyntaxNode node
)
Public Shared Function GetClassNode (
    node As SyntaxNode
) As SyntaxNode
public:
static SyntaxNode^ GetClassNode(
    SyntaxNode^ node
)
static member GetClassNode :
        node : SyntaxNode -> SyntaxNode

Parameters

node
Type: SyntaxNode
SyntaxNode to test.

Return Value

Type: SyntaxNode
Class or structure node.
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils.GetFormattedText Method

CSUtilsGetFormattedText Method
Formats content of specified SyntaxNode accordingly to language rules of the document.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFormattedText(
    SyntaxNode node
)
Public Shared Function GetFormattedText (
    node As SyntaxNode
) As String
public:
static String^ GetFormattedText(
    SyntaxNode^ node
)
static member GetFormattedText :
        node : SyntaxNode -> string

Parameters

node
Type: SyntaxNode
SyntaxNode to format.

Return Value

Type: String
Formatted sting that contains a SyntaxNode.
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils.GetIdentifierName Method

CSUtilsGetIdentifierName Method
Gets formatted text describes identifier node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetIdentifierName(
    NameSyntax node
)
Public Shared Function GetIdentifierName (
    node As NameSyntax
) As String
public:
static String^ GetIdentifierName(
    NameSyntax^ node
)
static member GetIdentifierName :
        node : NameSyntax -> string

Parameters

node
Type: NameSyntax
NameSyntax node to test.

Return Value

Type: String
Formatted identifier.
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils.GetMethodName Method

CSUtilsGetMethodName Method
Gets formatted text describes name of the method node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetMethodName(
    SyntaxNode node
)
Public Shared Function GetMethodName (
    node As SyntaxNode
) As String
public:
static String^ GetMethodName(
    SyntaxNode^ node
)
static member GetMethodName :
        node : SyntaxNode -> string

Parameters

node
Type: SyntaxNode
SyntaxNode to test.

Return Value

Type: String
Formatted method node name.
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils.GetNodeList Method

CSUtilsGetNodeList Method
Fills given list of SyntaxNode obtained from specified document at the given position.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void GetNodeList(
    IList<SyntaxNode> list,
    SyntaxNode root,
    SyntaxKind[] types
)
Public Shared Sub GetNodeList (
    list As IList(Of SyntaxNode),
    root As SyntaxNode,
    types As SyntaxKind()
)
public:
static void GetNodeList(
    IList<SyntaxNode^>^ list,
    SyntaxNode^ root,
    array<SyntaxKind>^ types
)
static member GetNodeList :
        list : IList<SyntaxNode> *
        root : SyntaxNode *
        types : SyntaxKind[] -> unit

Parameters

list
Type: System.Collections.GenericIListSyntaxNode
List of SyntaxNode objects to fill.
root
Type: SyntaxNode
Root node contains nodes to fill.
types
Type: SyntaxKind
List of SyntaxKind that determines the selection condition.
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils.GetNodeName Method

CSUtilsGetNodeName Method
Gets formatted text describes name of the node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetNodeName(
    SyntaxNode snode
)
Public Shared Function GetNodeName (
    snode As SyntaxNode
) As String
public:
static String^ GetNodeName(
    SyntaxNode^ snode
)
static member GetNodeName :
        snode : SyntaxNode -> string

Parameters

snode
Type: SyntaxNode
SyntaxNode to test.

Return Value

Type: String
Formatted node name.
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils.IsValidNode Method

CSUtilsIsValidNode Method
Indicates whether this node is valid for explorer purposes.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidNode(
    SyntaxNode node,
    out int index
)
Public Shared Function IsValidNode (
    node As SyntaxNode,
    <OutAttribute> ByRef index As Integer
) As Boolean
public:
static bool IsValidNode(
    SyntaxNode^ node,
    [OutAttribute] int% index
)
static member IsValidNode :
        node : SyntaxNode *
        index : int byref -> bool

Parameters

node
Type: SyntaxNode
SyntaxNode to test.
index
Type: SystemInt32
Receives image index for the node.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


CSUtils.ProcessMethodParams Method

CSUtilsProcessMethodParams Method
Receives parameter data from given method node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ProcessMethodParams(
    SyntaxNode node,
    IList<string> paramTypes,
    IList<string> paramNames
)
Public Shared Sub ProcessMethodParams (
    node As SyntaxNode,
    paramTypes As IList(Of String),
    paramNames As IList(Of String)
)
public:
static void ProcessMethodParams(
    SyntaxNode^ node,
    IList<String^>^ paramTypes,
    IList<String^>^ paramNames
)
static member ProcessMethodParams :
        node : SyntaxNode *
        paramTypes : IList<string> *
        paramNames : IList<string> -> unit

Parameters

node
Type: SyntaxNode
SyntaxNode to test.
paramTypes
Type: System.Collections.GenericIListString
List of parameter types to be filled.
paramNames
Type: System.Collections.GenericIListString
List of parameter names to be filled.
See Also

Reference

CSUtils Class
Alternet.Editor.Roslyn Namespace


NavigateToNodeRequestedEventArgs Class

NavigateToNodeRequestedEventArgs Class
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.RoslynNavigateToNodeRequestedEventArgs

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NavigateToNodeRequestedEventArgs : EventArgs
Public Class NavigateToNodeRequestedEventArgs
    Inherits EventArgs
public ref class NavigateToNodeRequestedEventArgs : public EventArgs
type NavigateToNodeRequestedEventArgs =
    class
        inherit EventArgs
    end

The NavigateToNodeRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NavigateToNodeRequestedEventArgs | Initializes a new instance of the NavigateToNodeRequestedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Node |
Top
See Also

Reference

Alternet.Editor.Roslyn Namespace


NavigateToNodeRequestedEventArgs Constructor

NavigateToNodeRequestedEventArgs Constructor
Initializes a new instance of the NavigateToNodeRequestedEventArgs class

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NavigateToNodeRequestedEventArgs(
    Object node
)
Public Sub New (
    node As Object
)
public:
NavigateToNodeRequestedEventArgs(
    Object^ node
)
new :
        node : Object -> NavigateToNodeRequestedEventArgs

Parameters

node
Type: SystemObject
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.Roslyn Namespace


NavigateToNodeRequestedEventArgs Methods

NavigateToNodeRequestedEventArgs Methods

The NavigateToNodeRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.Roslyn Namespace


NavigateToNodeRequestedEventArgs Properties

NavigateToNodeRequestedEventArgs Properties

The NavigateToNodeRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node |
Top
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.Roslyn Namespace


NavigateToNodeRequestedEventArgs.Node Property

NavigateToNodeRequestedEventArgsNode Property

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Node { get; }
Public ReadOnly Property Node As Object
    Get
public:
property Object^ Node {
    Object^ get ();
}
member Node : Object with get

Property Value

Type: Object
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.Roslyn Namespace


ResolveReferenceEventArgs Class

ResolveReferenceEventArgs Class
Provides data for the IScriptRun.ReferenceResolve event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.RoslynResolveReferenceEventArgs

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ResolveReferenceEventArgs : EventArgs
Public Class ResolveReferenceEventArgs
    Inherits EventArgs
public ref class ResolveReferenceEventArgs : public EventArgs
type ResolveReferenceEventArgs =
    class
        inherit EventArgs
    end

The ResolveReferenceEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveReferenceEventArgs | Initializes a new instance of the ResolveReferenceEventArgs class with specified reference.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyImage | Gets or sets stream suitable Assembly Image.
Public property | AssemblyLocation | Gets or sets suitable Assembly.
Public property | Handled | Gets or sets a value indicating whether the ReferenceResolve event was handled.
Public property | Reference | Gets or sets reference to be resolved.
Top
See Also

Reference

Alternet.Editor.Roslyn Namespace


ResolveReferenceEventArgs Constructor

ResolveReferenceEventArgs Constructor
Initializes a new instance of the ResolveReferenceEventArgs class with specified reference.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResolveReferenceEventArgs(
    string reference
)
Public Sub New (
    reference As String
)
public:
ResolveReferenceEventArgs(
    String^ reference
)
new :
        reference : string -> ResolveReferenceEventArgs

Parameters

reference
Type: SystemString
Reference to resolve.
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Editor.Roslyn Namespace


ResolveReferenceEventArgs Methods

ResolveReferenceEventArgs Methods

The ResolveReferenceEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Editor.Roslyn Namespace


ResolveReferenceEventArgs Properties

ResolveReferenceEventArgs Properties

The ResolveReferenceEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyImage | Gets or sets stream suitable Assembly Image.
Public property | AssemblyLocation | Gets or sets suitable Assembly.
Public property | Handled | Gets or sets a value indicating whether the ReferenceResolve event was handled.
Public property | Reference | Gets or sets reference to be resolved.
Top
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Editor.Roslyn Namespace


ResolveReferenceEventArgs.AssemblyImage Property

ResolveReferenceEventArgsAssemblyImage Property
Gets or sets stream suitable Assembly Image.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] AssemblyImage { get; set; }
Public Property AssemblyImage As Byte()
    Get
    Set
public:
property array<unsigned char>^ AssemblyImage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member AssemblyImage : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Editor.Roslyn Namespace


ResolveReferenceEventArgs.AssemblyLocation Property

ResolveReferenceEventArgsAssemblyLocation Property
Gets or sets suitable Assembly.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyLocation { get; set; }
Public Property AssemblyLocation As String
    Get
    Set
public:
property String^ AssemblyLocation {
    String^ get ();
    void set (String^ value);
}
member AssemblyLocation : string with get, set

Property Value

Type: String
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Editor.Roslyn Namespace


ResolveReferenceEventArgs.Handled Property

ResolveReferenceEventArgsHandled Property
Gets or sets a value indicating whether the ReferenceResolve event was handled.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Editor.Roslyn Namespace


ResolveReferenceEventArgs.Reference Property

ResolveReferenceEventArgsReference Property
Gets or sets reference to be resolved.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Reference { get; set; }
Public Property Reference As String
    Get
    Set
public:
property String^ Reference {
    String^ get ();
    void set (String^ value);
}
member Reference : string with get, set

Property Value

Type: String
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Editor.Roslyn Namespace


VBUtils Class

VBUtils Class
Represents extended functionality to explore code in the project.
Inheritance Hierarchy
SystemObject
Alternet.Editor.RoslynVBUtils

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VBUtils
Public Class VBUtils
public ref class VBUtils
type VBUtils =  class end

The VBUtils type exposes the following members.

Constructors
 | Name | Description
Public method | VBUtils | Initializes a new instance of the VBUtils class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetClassNode | Finds parent node of given SyntaxNode that is a class or structure node.
 | GetFormattedText | Formats content of specified SyntaxNode accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetIdentifierName | Gets formatted text describes identifier node.
 | GetMethodName | Gets formatted text describes name of the method node.
 | GetNodeList | Fills given list of SyntaxNode obtained from specified document at the given position.
 | GetNodeName | Gets formatted text describes name of the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidNode | Indicates whether this node is valid for explorer purposes.
 | ProcessMethodParams | Receives parameter data from given method node.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Editor.Roslyn Namespace


VBUtils Constructor

VBUtils Constructor
Initializes a new instance of the VBUtils class

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VBUtils()
Public Sub New
public:
VBUtils()
new : unit -> VBUtils
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


VBUtils Methods

VBUtils Methods

The VBUtils type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetClassNode | Finds parent node of given SyntaxNode that is a class or structure node.
 | GetFormattedText | Formats content of specified SyntaxNode accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetIdentifierName | Gets formatted text describes identifier node.
 | GetMethodName | Gets formatted text describes name of the method node.
 | GetNodeList | Fills given list of SyntaxNode obtained from specified document at the given position.
 | GetNodeName | Gets formatted text describes name of the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidNode | Indicates whether this node is valid for explorer purposes.
 | ProcessMethodParams | Receives parameter data from given method node.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


VBUtils.GetClassNode Method

VBUtilsGetClassNode Method
Finds parent node of given SyntaxNode that is a class or structure node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxNode GetClassNode(
    SyntaxNode node
)
Public Shared Function GetClassNode (
    node As SyntaxNode
) As SyntaxNode
public:
static SyntaxNode^ GetClassNode(
    SyntaxNode^ node
)
static member GetClassNode :
        node : SyntaxNode -> SyntaxNode

Parameters

node
Type: SyntaxNode
SyntaxNode to test.

Return Value

Type: SyntaxNode
Class or structure node.
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


VBUtils.GetFormattedText Method

VBUtilsGetFormattedText Method
Formats content of specified SyntaxNode accordingly to language rules of the document.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFormattedText(
    SyntaxNode node
)
Public Shared Function GetFormattedText (
    node As SyntaxNode
) As String
public:
static String^ GetFormattedText(
    SyntaxNode^ node
)
static member GetFormattedText :
        node : SyntaxNode -> string

Parameters

node
Type: SyntaxNode
SyntaxNode to format.

Return Value

Type: String
Formatted sting that contains a SyntaxNode.
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


VBUtils.GetIdentifierName Method

VBUtilsGetIdentifierName Method
Gets formatted text describes identifier node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetIdentifierName(
    NameSyntax node
)
Public Shared Function GetIdentifierName (
    node As NameSyntax
) As String
public:
static String^ GetIdentifierName(
    NameSyntax^ node
)
static member GetIdentifierName :
        node : NameSyntax -> string

Parameters

node
Type: NameSyntax
NameSyntax node to test.

Return Value

Type: String
Formatted identifier.
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


VBUtils.GetMethodName Method

VBUtilsGetMethodName Method
Gets formatted text describes name of the method node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetMethodName(
    SyntaxNode node
)
Public Shared Function GetMethodName (
    node As SyntaxNode
) As String
public:
static String^ GetMethodName(
    SyntaxNode^ node
)
static member GetMethodName :
        node : SyntaxNode -> string

Parameters

node
Type: SyntaxNode
SyntaxNode to test.

Return Value

Type: String
Formatted method node name.
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


VBUtils.GetNodeList Method

VBUtilsGetNodeList Method
Fills given list of SyntaxNode obtained from specified document at the given position.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void GetNodeList(
    IList<SyntaxNode> list,
    SyntaxNode root,
    SyntaxKind[] types
)
Public Shared Sub GetNodeList (
    list As IList(Of SyntaxNode),
    root As SyntaxNode,
    types As SyntaxKind()
)
public:
static void GetNodeList(
    IList<SyntaxNode^>^ list,
    SyntaxNode^ root,
    array<SyntaxKind>^ types
)
static member GetNodeList :
        list : IList<SyntaxNode> *
        root : SyntaxNode *
        types : SyntaxKind[] -> unit

Parameters

list
Type: System.Collections.GenericIListSyntaxNode
List of SyntaxNode objects to fill.
root
Type: SyntaxNode
Root node contains nodes to fill.
types
Type: SyntaxKind
List of SyntaxKind that determines the selection condition.
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


VBUtils.GetNodeName Method

VBUtilsGetNodeName Method
Gets formatted text describes name of the node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetNodeName(
    SyntaxNode snode
)
Public Shared Function GetNodeName (
    snode As SyntaxNode
) As String
public:
static String^ GetNodeName(
    SyntaxNode^ snode
)
static member GetNodeName :
        snode : SyntaxNode -> string

Parameters

snode
Type: SyntaxNode
SyntaxNode to test.

Return Value

Type: String
Formatted node name.
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


VBUtils.IsValidNode Method

VBUtilsIsValidNode Method
Indicates whether this node is valid for explorer purposes.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidNode(
    SyntaxNode node,
    out int index
)
Public Shared Function IsValidNode (
    node As SyntaxNode,
    <OutAttribute> ByRef index As Integer
) As Boolean
public:
static bool IsValidNode(
    SyntaxNode^ node,
    [OutAttribute] int% index
)
static member IsValidNode :
        node : SyntaxNode *
        index : int byref -> bool

Parameters

node
Type: SyntaxNode
SyntaxNode to test.
index
Type: SystemInt32
Receives image index for the node.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


VBUtils.ProcessMethodParams Method

VBUtilsProcessMethodParams Method
Receives parameter data from given method node.

Namespace: Alternet.Editor.Roslyn
Assembly: Alternet.Editor.Roslyn.v7 (in Alternet.Editor.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ProcessMethodParams(
    SyntaxNode node,
    IList<string> paramTypes,
    IList<string> paramNames
)
Public Shared Sub ProcessMethodParams (
    node As SyntaxNode,
    paramTypes As IList(Of String),
    paramNames As IList(Of String)
)
public:
static void ProcessMethodParams(
    SyntaxNode^ node,
    IList<String^>^ paramTypes,
    IList<String^>^ paramNames
)
static member ProcessMethodParams :
        node : SyntaxNode *
        paramTypes : IList<string> *
        paramNames : IList<string> -> unit

Parameters

node
Type: SyntaxNode
SyntaxNode to test.
paramTypes
Type: System.Collections.GenericIListString
List of parameter types to be filled.
paramNames
Type: System.Collections.GenericIListString
List of parameter names to be filled.
See Also

Reference

VBUtils Class
Alternet.Editor.Roslyn Namespace


Alternet.Editor.Serialization Namespace

Alternet.Editor.Serialization Namespace
Classes
 | Class | Description
Public class | FmtExport | Provides methods to save IStringItem elements.
Public class | FmtImport | Represents basic class to import Edit control's content from various formats.
Public class | HtmlExport | Represents class that can export Edit control's content to HTML format.
Public class | HtmlImporter | Represents class that can import Edit control's content stored in HTML format.
Public class | RtfExport | Represents class that can export Edit control's content to rich text format.
Public class | XmlMacroKeyDataInfo | Contains information about IKeyListData object's settings.
Public class | XmlMacroKeysDataInfo | Contains information about IKeyListData object's settings.
Public class | XmlSearchSettingsInfo | Contains information about ISearchSettings object's settings.


FmtExport Class

FmtExport Class
Provides methods to save IStringItem elements.
Inheritance Hierarchy
SystemObject
Alternet.Editor.SerializationFmtExport
Alternet.Editor.SerializationHtmlExport
Alternet.Editor.SerializationRtfExport

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FmtExport : IFmtExport, IStringExport
Public Class FmtExport
    Implements IFmtExport, IStringExport
public ref class FmtExport : IFmtExport,
    IStringExport
type FmtExport =
    class
        interface IFmtExport
        interface IStringExport
    end

The FmtExport type exposes the following members.

Constructors
 | Name | Description
Public method | FmtExport | Initializes a new instance of the FmtExport class
Top
Methods
 | Name | Description
Public method | BeginWrite | Starts writing routine.
Public method | EndWrite | Finalizes writing routine.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves entire content.
Public method | WriteLine | Saves a particular IStringItem object.
Top
See Also

Reference

Alternet.Editor.Serialization Namespace


FmtExport Constructor

FmtExport Constructor
Initializes a new instance of the FmtExport class

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FmtExport()
Public Sub New
public:
FmtExport()
new : unit -> FmtExport
See Also

Reference

FmtExport Class
Alternet.Editor.Serialization Namespace


FmtExport Methods

FmtExport Methods

The FmtExport type exposes the following members.

Methods
 | Name | Description
Public method | BeginWrite | Starts writing routine.
Public method | EndWrite | Finalizes writing routine.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves entire content.
Public method | WriteLine | Saves a particular IStringItem object.
Top
See Also

Reference

FmtExport Class
Alternet.Editor.Serialization Namespace


FmtExport.BeginWrite Method

FmtExportBeginWrite Method
Starts writing routine.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void BeginWrite(
    TextWriter writer,
    Object userData
)
Public Overridable Sub BeginWrite (
    writer As TextWriter,
    userData As Object
)
public:
virtual void BeginWrite(
    TextWriter^ writer,
    Object^ userData
)
abstract BeginWrite :
        writer : TextWriter *
        userData : Object -> unit
override BeginWrite :
        writer : TextWriter *
        userData : Object -> unit

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.
userData
Type: SystemObject
Data to be saved.

Implements

IStringExportBeginWrite(TextWriter, Object)
See Also

Reference

FmtExport Class
Alternet.Editor.Serialization Namespace


FmtExport.EndWrite Method

FmtExportEndWrite Method
Finalizes writing routine.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EndWrite()
Public Overridable Sub EndWrite
public:
virtual void EndWrite()
abstract EndWrite : unit -> unit
override EndWrite : unit -> unit

Implements

IStringExportEndWrite
See Also

Reference

FmtExport Class
Alternet.Editor.Serialization Namespace


FmtExport.Write Method

FmtExportWrite Method
Saves entire content.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Write()
Public Overridable Function Write As Boolean
public:
virtual bool Write()
abstract Write : unit -> bool
override Write : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IStringExportWrite
See Also

Reference

FmtExport Class
Alternet.Editor.Serialization Namespace


FmtExport.WriteLine Method

FmtExportWriteLine Method
Saves a particular IStringItem object.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void WriteLine(
    IStringItem item
)
Public Overridable Sub WriteLine (
    item As IStringItem
)
public:
virtual void WriteLine(
    IStringItem^ item
)
abstract WriteLine :
        item : IStringItem -> unit
override WriteLine :
        item : IStringItem -> unit

Parameters

item
Type: Alternet.SyntaxIStringItem
IStringItem to save.

Implements

IStringExportWriteLine(IStringItem)
See Also

Reference

FmtExport Class
Alternet.Editor.Serialization Namespace


FmtImport Class

FmtImport Class
Represents basic class to import Edit control's content from various formats.
Inheritance Hierarchy
SystemObject
Alternet.Editor.SerializationFmtImport
Alternet.Editor.SerializationHtmlImporter

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FmtImport : IFmtImport, IStringImport,
    IDisposable
Public Class FmtImport
    Implements IFmtImport, IStringImport, IDisposable
public ref class FmtImport : IFmtImport,
    IStringImport, IDisposable
type FmtImport =
    class
        interface IFmtImport
        interface IStringImport
        interface IDisposable
    end

The FmtImport type exposes the following members.

Constructors
 | Name | Description
Public method | FmtImport | Initializes a new instance of the FmtImporter class with default settings.
Top
Methods
 | Name | Description
Public method | BeginRead | Starts reading routine.
Public method | Dispose | Disposes this FmtImport and frees resources associated with it.
Public method | EndRead | Finalizes reading routine.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Read | Loads entire content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DefaultBackColor | Defines default back color of the text.
Public property | DefaultForeColor | Defines default fore color of the text.
Public property | DefaultStyle | Defines default font style of the text.
Top
Events
 | Name | Description
Public event | ReadFormattedText | Occurs when formatted text is read.
Top
Remarks
Do not create instances of this class directly; use derived classes like XmlImportet and RtfImporter.
See Also

Reference

Alternet.Editor.Serialization Namespace


FmtImport Constructor

FmtImport Constructor
Initializes a new instance of the FmtImporter class with default settings.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FmtImport()
Public Sub New
public:
FmtImport()
new : unit -> FmtImport
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport Methods

FmtImport Methods

The FmtImport type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Starts reading routine.
Public method | Dispose | Disposes this FmtImport and frees resources associated with it.
Public method | EndRead | Finalizes reading routine.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Read | Loads entire content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport.BeginRead Method

FmtImportBeginRead Method
Starts reading routine.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void BeginRead(
    TextReader reader,
    Object userData
)
Public Overridable Sub BeginRead (
    reader As TextReader,
    userData As Object
)
public:
virtual void BeginRead(
    TextReader^ reader,
    Object^ userData
)
abstract BeginRead :
        reader : TextReader *
        userData : Object -> unit
override BeginRead :
        reader : TextReader *
        userData : Object -> unit

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.
userData
Type: SystemObject
Data to be loaded.

Implements

IStringImportBeginRead(TextReader, Object)
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport.Dispose Method

FmtImportDispose Method
Disposes this FmtImport and frees resources associated with it.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport.EndRead Method

FmtImportEndRead Method
Finalizes reading routine.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EndRead()
Public Overridable Sub EndRead
public:
virtual void EndRead()
abstract EndRead : unit -> unit
override EndRead : unit -> unit

Implements

IStringImportEndRead
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport.Read Method

FmtImportRead Method
Loads entire content.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Read()
Public Overridable Function Read As Boolean
public:
virtual bool Read()
abstract Read : unit -> bool
override Read : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IStringImportRead
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport Properties

FmtImport Properties

The FmtImport type exposes the following members.

Properties
 | Name | Description
Public property | DefaultBackColor | Defines default back color of the text.
Public property | DefaultForeColor | Defines default fore color of the text.
Public property | DefaultStyle | Defines default font style of the text.
Top
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport.DefaultBackColor Property

FmtImportDefaultBackColor Property
Defines default back color of the text.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color DefaultBackColor { get; set; }
Public Property DefaultBackColor As Color
    Get
    Set
public:
virtual property Color DefaultBackColor {
    Color get () sealed;
    void set (Color value) sealed;
}
abstract DefaultBackColor : Color with get, set
override DefaultBackColor : Color with get, set

Property Value

Type: Color

Implements

IFmtImportDefaultBackColor
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport.DefaultForeColor Property

FmtImportDefaultForeColor Property
Defines default fore color of the text.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color DefaultForeColor { get; set; }
Public Property DefaultForeColor As Color
    Get
    Set
public:
virtual property Color DefaultForeColor {
    Color get () sealed;
    void set (Color value) sealed;
}
abstract DefaultForeColor : Color with get, set
override DefaultForeColor : Color with get, set

Property Value

Type: Color

Implements

IFmtImportDefaultForeColor
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport.DefaultStyle Property

FmtImportDefaultStyle Property
Defines default font style of the text.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontStyle DefaultStyle { get; set; }
Public Property DefaultStyle As FontStyle
    Get
    Set
public:
virtual property FontStyle DefaultStyle {
    FontStyle get () sealed;
    void set (FontStyle value) sealed;
}
abstract DefaultStyle : FontStyle with get, set
override DefaultStyle : FontStyle with get, set

Property Value

Type: FontStyle

Implements

IFmtImportDefaultStyle
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport Events

FmtImport Events

The FmtImport type exposes the following members.

Events
 | Name | Description
Public event | ReadFormattedText | Occurs when formatted text is read.
Top
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


FmtImport.ReadFormattedText Event

FmtImportReadFormattedText Event
Occurs when formatted text is read.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event ReadFormattedTextEvent ReadFormattedText
Public Event ReadFormattedText As ReadFormattedTextEvent
public:
virtual  event ReadFormattedTextEvent^ ReadFormattedText {
    void add (ReadFormattedTextEvent^ value);
    void remove (ReadFormattedTextEvent^ value);
}
abstract ReadFormattedText : IEvent<ReadFormattedTextEvent,
    ReadFormattedTextEventArgs>
override ReadFormattedText : IEvent<ReadFormattedTextEvent,
    ReadFormattedTextEventArgs>

Value

Type: Alternet.SyntaxReadFormattedTextEvent

Implements

IFmtImportReadFormattedText
Remarks
The event handler receives an argument of type EventArgs containing data related to this event.
See Also

Reference

FmtImport Class
Alternet.Editor.Serialization Namespace


HtmlExport Class

HtmlExport Class
Represents class that can export Edit control's content to HTML format.
Inheritance Hierarchy
SystemObject
Alternet.Editor.SerializationFmtExport
Alternet.Editor.SerializationHtmlExport

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HtmlExport : FmtExport
Public Class HtmlExport
    Inherits FmtExport
public ref class HtmlExport : public FmtExport
type HtmlExport =
    class
        inherit FmtExport
    end

The HtmlExport type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlExport | Initializes a new instance of the HtmlExport class with default settings.
Top
Methods
 | Name | Description
Public method | BeginWrite | Starts writing routine. (Overrides FmtExportBeginWrite(TextWriter, Object).)
Public method | EndWrite | Finalizes writing routine. (Overrides FmtExportEndWrite.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves entire content. (Inherited from FmtExport.)
Public method | WriteLine | Saves a particular IStringItem object. (Inherited from FmtExport.)
Top
See Also

Reference

Alternet.Editor.Serialization Namespace


HtmlExport Constructor

HtmlExport Constructor
Initializes a new instance of the HtmlExport class with default settings.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HtmlExport()
Public Sub New
public:
HtmlExport()
new : unit -> HtmlExport
See Also

Reference

HtmlExport Class
Alternet.Editor.Serialization Namespace


HtmlExport Methods

HtmlExport Methods

The HtmlExport type exposes the following members.

Methods
 | Name | Description
Public method | BeginWrite | Starts writing routine. (Overrides FmtExportBeginWrite(TextWriter, Object).)
Public method | EndWrite | Finalizes writing routine. (Overrides FmtExportEndWrite.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves entire content. (Inherited from FmtExport.)
Public method | WriteLine | Saves a particular IStringItem object. (Inherited from FmtExport.)
Top
See Also

Reference

HtmlExport Class
Alternet.Editor.Serialization Namespace


HtmlExport.BeginWrite Method

HtmlExportBeginWrite Method
Starts writing routine.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void BeginWrite(
    TextWriter writer,
    Object userData
)
Public Overrides Sub BeginWrite (
    writer As TextWriter,
    userData As Object
)
public:
virtual void BeginWrite(
    TextWriter^ writer,
    Object^ userData
) override
abstract BeginWrite :
        writer : TextWriter *
        userData : Object -> unit
override BeginWrite :
        writer : TextWriter *
        userData : Object -> unit

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.
userData
Type: SystemObject
Data to be saved.

Implements

IStringExportBeginWrite(TextWriter, Object)
See Also

Reference

HtmlExport Class
Alternet.Editor.Serialization Namespace


HtmlExport.EndWrite Method

HtmlExportEndWrite Method
Finalizes writing routine.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void EndWrite()
Public Overrides Sub EndWrite
public:
virtual void EndWrite() override
abstract EndWrite : unit -> unit
override EndWrite : unit -> unit

Implements

IStringExportEndWrite
See Also

Reference

HtmlExport Class
Alternet.Editor.Serialization Namespace


HtmlImporter Class

HtmlImporter Class
Represents class that can import Edit control's content stored in HTML format.
Inheritance Hierarchy
SystemObject
Alternet.Editor.SerializationFmtImport
Alternet.Editor.SerializationHtmlImporter

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HtmlImporter : FmtImport
Public Class HtmlImporter
    Inherits FmtImport
public ref class HtmlImporter : public FmtImport
type HtmlImporter =
    class
        inherit FmtImport
    end

The HtmlImporter type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlImporter | Initializes a new instance of the HtmlImporter class
Top
Methods
 | Name | Description
Public method | BeginRead | Starts reading routine. (Inherited from FmtImport.)
Public method | Dispose | Disposes this FmtImport and frees resources associated with it. (Inherited from FmtImport.)
Public method | EndRead | Finalizes reading routine. (Inherited from FmtImport.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Read | Loads entire content. (Inherited from FmtImport.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DefaultBackColor | Defines default back color of the text. (Inherited from FmtImport.)
Public property | DefaultForeColor | Defines default fore color of the text. (Inherited from FmtImport.)
Public property | DefaultStyle | Defines default font style of the text. (Inherited from FmtImport.)
Top
Events
 | Name | Description
Public event | ReadFormattedText | Occurs when formatted text is read. (Inherited from FmtImport.)
Top
See Also

Reference

Alternet.Editor.Serialization Namespace


HtmlImporter Constructor

HtmlImporter Constructor
Initializes a new instance of the HtmlImporter class

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HtmlImporter()
Public Sub New
public:
HtmlImporter()
new : unit -> HtmlImporter
See Also

Reference

HtmlImporter Class
Alternet.Editor.Serialization Namespace


HtmlImporter Methods

HtmlImporter Methods

The HtmlImporter type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Starts reading routine. (Inherited from FmtImport.)
Public method | Dispose | Disposes this FmtImport and frees resources associated with it. (Inherited from FmtImport.)
Public method | EndRead | Finalizes reading routine. (Inherited from FmtImport.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Read | Loads entire content. (Inherited from FmtImport.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HtmlImporter Class
Alternet.Editor.Serialization Namespace


HtmlImporter Properties

HtmlImporter Properties

The HtmlImporter type exposes the following members.

Properties
 | Name | Description
Public property | DefaultBackColor | Defines default back color of the text. (Inherited from FmtImport.)
Public property | DefaultForeColor | Defines default fore color of the text. (Inherited from FmtImport.)
Public property | DefaultStyle | Defines default font style of the text. (Inherited from FmtImport.)
Top
See Also

Reference

HtmlImporter Class
Alternet.Editor.Serialization Namespace


HtmlImporter Events

HtmlImporter Events

The HtmlImporter type exposes the following members.

Events
 | Name | Description
Public event | ReadFormattedText | Occurs when formatted text is read. (Inherited from FmtImport.)
Top
See Also

Reference

HtmlImporter Class
Alternet.Editor.Serialization Namespace


RtfExport Class

RtfExport Class
Represents class that can export Edit control's content to rich text format.
Inheritance Hierarchy
SystemObject
Alternet.Editor.SerializationFmtExport
Alternet.Editor.SerializationRtfExport

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RtfExport : FmtExport
Public Class RtfExport
    Inherits FmtExport
public ref class RtfExport : public FmtExport
type RtfExport =
    class
        inherit FmtExport
    end

The RtfExport type exposes the following members.

Constructors
 | Name | Description
Public method | RtfExport | Initializes a new instance of the RtfExport class with default settings.
Top
Methods
 | Name | Description
Public method | BeginWrite | Starts writing routine. (Overrides FmtExportBeginWrite(TextWriter, Object).)
Public method | EndWrite | Finalizes writing routine. (Overrides FmtExportEndWrite.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves entire content. (Inherited from FmtExport.)
Public method | WriteLine | Saves a particular IStringItem object. (Inherited from FmtExport.)
Top
See Also

Reference

Alternet.Editor.Serialization Namespace


RtfExport Constructor

RtfExport Constructor
Initializes a new instance of the RtfExport class with default settings.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RtfExport()
Public Sub New
public:
RtfExport()
new : unit -> RtfExport
See Also

Reference

RtfExport Class
Alternet.Editor.Serialization Namespace


RtfExport Methods

RtfExport Methods

The RtfExport type exposes the following members.

Methods
 | Name | Description
Public method | BeginWrite | Starts writing routine. (Overrides FmtExportBeginWrite(TextWriter, Object).)
Public method | EndWrite | Finalizes writing routine. (Overrides FmtExportEndWrite.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Saves entire content. (Inherited from FmtExport.)
Public method | WriteLine | Saves a particular IStringItem object. (Inherited from FmtExport.)
Top
See Also

Reference

RtfExport Class
Alternet.Editor.Serialization Namespace


RtfExport.BeginWrite Method

RtfExportBeginWrite Method
Starts writing routine.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void BeginWrite(
    TextWriter writer,
    Object userData
)
Public Overrides Sub BeginWrite (
    writer As TextWriter,
    userData As Object
)
public:
virtual void BeginWrite(
    TextWriter^ writer,
    Object^ userData
) override
abstract BeginWrite :
        writer : TextWriter *
        userData : Object -> unit
override BeginWrite :
        writer : TextWriter *
        userData : Object -> unit

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.
userData
Type: SystemObject
Data to be saved.

Implements

IStringExportBeginWrite(TextWriter, Object)
See Also

Reference

RtfExport Class
Alternet.Editor.Serialization Namespace


RtfExport.EndWrite Method

RtfExportEndWrite Method
Finalizes writing routine.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void EndWrite()
Public Overrides Sub EndWrite
public:
virtual void EndWrite() override
abstract EndWrite : unit -> unit
override EndWrite : unit -> unit

Implements

IStringExportEndWrite
See Also

Reference

RtfExport Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo Class

XmlMacroKeyDataInfo Class
Contains information about IKeyListData object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Editor.SerializationXmlMacroKeyDataInfo

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlMacroKeyDataInfo : ISerializationInfo
Public Class XmlMacroKeyDataInfo
    Implements ISerializationInfo
public ref class XmlMacroKeyDataInfo : ISerializationInfo
type XmlMacroKeyDataInfo =
    class
        interface ISerializationInfo
    end

The XmlMacroKeyDataInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlMacroKeyDataInfo | Initializes a new instance of the XmlMacroKeyDataInfo class with default settings.
Public method | XmlMacroKeyDataInfo(IMacroKeyData) | Initializes a new instance of the XmlMacroKeyDataInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EventName | Represents a name of the action.
Public property | FullName | Represents a name of the action.
Public property | Keys | Represents a key to which some action is attached.
Public property | LeaveState | Represents a state of the Edit control after key is pressed.
Public property | ParamStr | When implemented by a class, represents parameter text.
Public property | ParamType | When implemented by a class, gets or sets type of the parameter.
Public property | State | Represents a state of the Edit control before key is pressed.
Top
See Also

Reference

Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo Constructor

XmlMacroKeyDataInfo Constructor
Overload List
 | Name | Description
Public method | XmlMacroKeyDataInfo | Initializes a new instance of the XmlMacroKeyDataInfo class with default settings.
Public method | XmlMacroKeyDataInfo(IMacroKeyData) | Initializes a new instance of the XmlMacroKeyDataInfo class with specified owner.
Top
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo Constructor

XmlMacroKeyDataInfo Constructor
Initializes a new instance of the XmlMacroKeyDataInfo class with default settings.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlMacroKeyDataInfo()
Public Sub New
public:
XmlMacroKeyDataInfo()
new : unit -> XmlMacroKeyDataInfo
See Also

Reference

XmlMacroKeyDataInfo Class
XmlMacroKeyDataInfo Overload
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo Constructor (IMacroKeyData)

XmlMacroKeyDataInfo Constructor (IMacroKeyData)
Initializes a new instance of the XmlMacroKeyDataInfo class with specified owner.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlMacroKeyDataInfo(
    IMacroKeyData owner
)
Public Sub New (
    owner As IMacroKeyData
)
public:
XmlMacroKeyDataInfo(
    IMacroKeyData^ owner
)
new :
        owner : IMacroKeyData -> XmlMacroKeyDataInfo

Parameters

owner
Type: Alternet.EditorIMacroKeyData
Specifies IMacroKeyListData object to store settings.
See Also

Reference

XmlMacroKeyDataInfo Class
XmlMacroKeyDataInfo Overload
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo Methods

XmlMacroKeyDataInfo Methods

The XmlMacroKeyDataInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo.FixupReferences Method

XmlMacroKeyDataInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo.Load Method

XmlMacroKeyDataInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo Properties

XmlMacroKeyDataInfo Properties

The XmlMacroKeyDataInfo type exposes the following members.

Properties
 | Name | Description
Public property | EventName | Represents a name of the action.
Public property | FullName | Represents a name of the action.
Public property | Keys | Represents a key to which some action is attached.
Public property | LeaveState | Represents a state of the Edit control after key is pressed.
Public property | ParamStr | When implemented by a class, represents parameter text.
Public property | ParamType | When implemented by a class, gets or sets type of the parameter.
Public property | State | Represents a state of the Edit control before key is pressed.
Top
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo.EventName Property

XmlMacroKeyDataInfoEventName Property
Represents a name of the action.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EventName { get; set; }
Public Property EventName As String
    Get
    Set
public:
property String^ EventName {
    String^ get ();
    void set (String^ value);
}
member EventName : string with get, set

Property Value

Type: String
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo.FullName Property

XmlMacroKeyDataInfoFullName Property
Represents a name of the action.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}
member FullName : string with get, set

Property Value

Type: String
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo.Keys Property

XmlMacroKeyDataInfoKeys Property
Represents a key to which some action is attached.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Keys Keys { get; set; }
Public Property Keys As Keys
    Get
    Set
public:
property Keys Keys {
    Keys get ();
    void set (Keys value);
}
member Keys : Keys with get, set

Property Value

Type: Keys
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo.LeaveState Property

XmlMacroKeyDataInfoLeaveState Property
Represents a state of the Edit control after key is pressed.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LeaveState { get; set; }
Public Property LeaveState As Integer
    Get
    Set
public:
property int LeaveState {
    int get ();
    void set (int value);
}
member LeaveState : int with get, set

Property Value

Type: Int32
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo.ParamStr Property

XmlMacroKeyDataInfoParamStr Property
When implemented by a class, represents parameter text.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ParamStr { get; set; }
Public Property ParamStr As String
    Get
    Set
public:
property String^ ParamStr {
    String^ get ();
    void set (String^ value);
}
member ParamStr : string with get, set

Property Value

Type: String
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo.ParamType Property

XmlMacroKeyDataInfoParamType Property
When implemented by a class, gets or sets type of the parameter.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyEventType ParamType { get; set; }
Public Property ParamType As KeyEventType
    Get
    Set
public:
property KeyEventType ParamType {
    KeyEventType get ();
    void set (KeyEventType value);
}
member ParamType : KeyEventType with get, set

Property Value

Type: KeyEventType
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeyDataInfo.State Property

XmlMacroKeyDataInfoState Property
Represents a state of the Edit control before key is pressed.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int State { get; set; }
Public Property State As Integer
    Get
    Set
public:
property int State {
    int get ();
    void set (int value);
}
member State : int with get, set

Property Value

Type: Int32
See Also

Reference

XmlMacroKeyDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo Class

XmlMacroKeysDataInfo Class
Contains information about IKeyListData object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Editor.SerializationXmlMacroKeysDataInfo

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlMacroKeysDataInfo : ISerializationInfo
Public Class XmlMacroKeysDataInfo
    Implements ISerializationInfo
public ref class XmlMacroKeysDataInfo : ISerializationInfo
type XmlMacroKeysDataInfo =
    class
        interface ISerializationInfo
    end

The XmlMacroKeysDataInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlMacroKeysDataInfo | Initializes a new instance of the XmlMacroKeysDataInfo class with default settings.
Public method | XmlMacroKeysDataInfo(IMacroKeyList) | Initializes a new instance of the XmlMacroKeysDataInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeMarcos | Indicates whether the Marcos property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Macros | Stores Macros property.
Top
See Also

Reference

Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo Constructor

XmlMacroKeysDataInfo Constructor
Overload List
 | Name | Description
Public method | XmlMacroKeysDataInfo | Initializes a new instance of the XmlMacroKeysDataInfo class with default settings.
Public method | XmlMacroKeysDataInfo(IMacroKeyList) | Initializes a new instance of the XmlMacroKeysDataInfo class with specified owner.
Top
See Also

Reference

XmlMacroKeysDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo Constructor

XmlMacroKeysDataInfo Constructor
Initializes a new instance of the XmlMacroKeysDataInfo class with default settings.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlMacroKeysDataInfo()
Public Sub New
public:
XmlMacroKeysDataInfo()
new : unit -> XmlMacroKeysDataInfo
See Also

Reference

XmlMacroKeysDataInfo Class
XmlMacroKeysDataInfo Overload
Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo Constructor (IMacroKeyList)

XmlMacroKeysDataInfo Constructor (IMacroKeyList)
Initializes a new instance of the XmlMacroKeysDataInfo class with specified owner.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlMacroKeysDataInfo(
    IMacroKeyList owner
)
Public Sub New (
    owner As IMacroKeyList
)
public:
XmlMacroKeysDataInfo(
    IMacroKeyList^ owner
)
new :
        owner : IMacroKeyList -> XmlMacroKeysDataInfo

Parameters

owner
Type: Alternet.EditorIMacroKeyList
Specifies IRecordPlayBack object to store settings.
See Also

Reference

XmlMacroKeysDataInfo Class
XmlMacroKeysDataInfo Overload
Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo Methods

XmlMacroKeysDataInfo Methods

The XmlMacroKeysDataInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeMarcos | Indicates whether the Marcos property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlMacroKeysDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo.FixupReferences Method

XmlMacroKeysDataInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlMacroKeysDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo.Load Method

XmlMacroKeysDataInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlMacroKeysDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo.ShouldSerializeMarcos Method

XmlMacroKeysDataInfoShouldSerializeMarcos Method
Indicates whether the Marcos property should be persisted.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeMarcos()
Public Function ShouldSerializeMarcos As Boolean
public:
bool ShouldSerializeMarcos()
member ShouldSerializeMarcos : unit -> bool

Return Value

Type: Boolean
True if Marcos differs from its default value; otherwise false.
See Also

Reference

XmlMacroKeysDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo Properties

XmlMacroKeysDataInfo Properties

The XmlMacroKeysDataInfo type exposes the following members.

Properties
 | Name | Description
Public property | Macros | Stores Macros property.
Top
See Also

Reference

XmlMacroKeysDataInfo Class
Alternet.Editor.Serialization Namespace


XmlMacroKeysDataInfo.Macros Property

XmlMacroKeysDataInfoMacros Property
Stores Macros property.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlMacroKeyDataInfo[] Macros { get; set; }
Public Property Macros As XmlMacroKeyDataInfo()
    Get
    Set
public:
property array<XmlMacroKeyDataInfo^>^ Macros {
    array<XmlMacroKeyDataInfo^>^ get ();
    void set (array<XmlMacroKeyDataInfo^>^ value);
}
member Macros : XmlMacroKeyDataInfo[] with get, set

Property Value

Type: XmlMacroKeyDataInfo
See Also

Reference

XmlMacroKeysDataInfo Class
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo Class

XmlSearchSettingsInfo Class
Contains information about ISearchSettings object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Editor.SerializationXmlSearchSettingsInfo

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlSearchSettingsInfo : ISerializationInfo
Public Class XmlSearchSettingsInfo
    Implements ISerializationInfo
public ref class XmlSearchSettingsInfo : ISerializationInfo
type XmlSearchSettingsInfo =
    class
        interface ISerializationInfo
    end

The XmlSearchSettingsInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSearchSettingsInfo | Initializes a new instance of the XmlSearchSettingsInfo class with default settings.
Public method | XmlSearchSettingsInfo(ISearchSettings) | Initializes a new instance of the XmlSearchSettingsInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ReplaceList | Stores ISearchSettings.ReplaceList property.
Public property | SearchList | Stores ISearchSettings.SearchList property.
Public property | SearchOptions | Stores ISearchSettings.SearchOptions property.
Top
See Also

Reference

Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo Constructor

XmlSearchSettingsInfo Constructor
Overload List
 | Name | Description
Public method | XmlSearchSettingsInfo | Initializes a new instance of the XmlSearchSettingsInfo class with default settings.
Public method | XmlSearchSettingsInfo(ISearchSettings) | Initializes a new instance of the XmlSearchSettingsInfo class with specified owner.
Top
See Also

Reference

XmlSearchSettingsInfo Class
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo Constructor

XmlSearchSettingsInfo Constructor
Initializes a new instance of the XmlSearchSettingsInfo class with default settings.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlSearchSettingsInfo()
Public Sub New
public:
XmlSearchSettingsInfo()
new : unit -> XmlSearchSettingsInfo
See Also

Reference

XmlSearchSettingsInfo Class
XmlSearchSettingsInfo Overload
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo Constructor (ISearchSettings)

XmlSearchSettingsInfo Constructor (ISearchSettings)
Initializes a new instance of the XmlSearchSettingsInfo class with specified owner.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlSearchSettingsInfo(
    ISearchSettings owner
)
Public Sub New (
    owner As ISearchSettings
)
public:
XmlSearchSettingsInfo(
    ISearchSettings^ owner
)
new :
        owner : ISearchSettings -> XmlSearchSettingsInfo

Parameters

owner
Type: Alternet.Editor.DialogsISearchSettings
Specifies ISearchSettings object to store settings.
See Also

Reference

XmlSearchSettingsInfo Class
XmlSearchSettingsInfo Overload
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo Methods

XmlSearchSettingsInfo Methods

The XmlSearchSettingsInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlSearchSettingsInfo Class
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo.FixupReferences Method

XmlSearchSettingsInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlSearchSettingsInfo Class
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo.Load Method

XmlSearchSettingsInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlSearchSettingsInfo Class
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo Properties

XmlSearchSettingsInfo Properties

The XmlSearchSettingsInfo type exposes the following members.

Properties
 | Name | Description
Public property | ReplaceList | Stores ISearchSettings.ReplaceList property.
Public property | SearchList | Stores ISearchSettings.SearchList property.
Public property | SearchOptions | Stores ISearchSettings.SearchOptions property.
Top
See Also

Reference

XmlSearchSettingsInfo Class
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo.ReplaceList Property

XmlSearchSettingsInfoReplaceList Property
Stores ISearchSettings.ReplaceList property.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] ReplaceList { get; set; }
Public Property ReplaceList As String()
    Get
    Set
public:
property array<String^>^ ReplaceList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ReplaceList : string[] with get, set

Property Value

Type: String
See Also

Reference

XmlSearchSettingsInfo Class
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo.SearchList Property

XmlSearchSettingsInfoSearchList Property
Stores ISearchSettings.SearchList property.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] SearchList { get; set; }
Public Property SearchList As String()
    Get
    Set
public:
property array<String^>^ SearchList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member SearchList : string[] with get, set

Property Value

Type: String
See Also

Reference

XmlSearchSettingsInfo Class
Alternet.Editor.Serialization Namespace


XmlSearchSettingsInfo.SearchOptions Property

XmlSearchSettingsInfoSearchOptions Property
Stores ISearchSettings.SearchOptions property.

Namespace: Alternet.Editor.Serialization
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchOptions SearchOptions { get; set; }
Public Property SearchOptions As SearchOptions
    Get
    Set
public:
property SearchOptions SearchOptions {
    SearchOptions get ();
    void set (SearchOptions value);
}
member SearchOptions : SearchOptions with get, set

Property Value

Type: SearchOptions
See Also

Reference

XmlSearchSettingsInfo Class
Alternet.Editor.Serialization Namespace


Alternet.Editor.TextSource Namespace

Alternet.Editor.TextSource Namespace
Classes
 | Class | Description
Public class | BlockDeletingEventArgs | Provides data for the event that occurs when some block of lines within the ITextSource is deleted.
Public class | BookMark | BookMark class is used to store individual bookmark in bookmarks collection of Edit control.
Public class | BookMarks | Represents a collection of the BookMark objects.
Public class | Braces | Represents properties and methods for handling matching braces within the Edit control.
Public class | CodeSnippetRange | Represents individual outlining section that can appear in the Edit control.
Public class | CodeSnippetRanges | Represents collection containing list of code snippet literals.
Public class | CreateSearchManagerEventArgs | Provides data for the CreateSharedSearch handler.
Public class | HyperText | This class is designed to recognize whether some text represents hypertext.
Public class | HyperTextEventArgs | Provides data for the HyperTextEvent handler.
Public class | InnerTextSource | Represents internal text source for Edit control.
Public class | LineStyle | Represents a particular style of the line in Edit control.
Public class | LineStyles | Represents properties and methods for a collection that binds line styles to individual lines within Edit control content.
Public class | LowFootprintStringItem | Represents string-like object with extended properties.
Public class | StringItem | Represents string-like object with extended properties.
Public class | TextSource | Represents class that provides interface between edited text and Edit control.
Public class | TextSourceContentDividers |
Public class | TextStrings | Specifies collection of lines with extended possibilities.
Public class | UndoData | Represents data for a single undo operation.
Public class | UndoEventArgs | Provides data for the event that occurs when the undo/redo operation performed.
Public class | UndoList | Provides an indexed access to undo data.
Public class | WordSpellEventArgs | Provides data for the WordSpellEvent handler.
Interfaces
 | Interface | Description
Public interface | IBookMark | Represents properties and methods to store individual bookmark within Edit control.
Public interface | IBookMarkEx | Do not use this class, it's provided for backward compatibility only.
Public interface | IBookMarks | Represents properties and methods to provide an indexed access to individual IBookMark object.
Public interface | IBraceMatching | Represents properties and methods to handle matching braces within the Edit control.
Public interface | ICodeSnippetRange | Represents properties to store individual code snippet that can appear in the Edit control.
Public interface | ICodeSnippetRanges | Represents methods to provide an indexed access to individual ICodeSnippetRange object.
Public interface | IEdit | Represents properties and methods used for editing the text.
Public interface | IHyperText | Represents methods to operate with hypertext sections within the text.
Public interface | IInnerTextSource | Represents internal text source for Edit control.
Public interface | ILineStyle | This represents a particular style of some text line.
Public interface | ILineStyles | Represents properties and methods for a collection that binds line styles to individual lines within Edit control content.
Public interface | INavigate | Represents properties and methods allowing to navigate within the Edit control's text content.
Public interface | ISpelling | Represents properties and methods allowing check spelling of the text.
Public interface | IStringExport | Provides methods to save IStringItem elements.
Public interface | IStringImport | Provides methods to load text content.
Public interface | ITabulation | Represents properties and methods for handling tabulations within the text.
Public interface | ITextErrors | Represents properties and methods to handle syntax error collection.
Public interface | ITextExport | Represents properties methods to save text content using different formats.
Public interface | ITextImport | Represents methods to load text content in different formats.
Public interface | ITextNotify | Represents properties and methods to perform Text Source notification.
Public interface | ITextParsing | Represents properties and methods to perform Text Source parsing.
Public interface | ITextSearch | Represents method used to search text within the string collection.
Public interface | ITextSnippets | Represents properties and methods to provide code snippet functionality.
Public interface | ITextSource | Represents properties and methods that provide interface between edited text and Edit control.
Public interface | ITextStrings | Represents a collection of strings with extended possibilities.
Public interface | ITextThread | Represents properties and methods allowing to execute actions in thread.
Public interface | IUndo | Represents properties and methods to perform undo/redo operation with the text.
Public interface | IUndoData | Represents data for a single undo operation.
Public interface | IUndoList | Provides an indexed access to undo data.
Public interface | IWordBreak | Represents properties and methods used to separate words within Edit control content.
Delegates
 | Delegate | Description
Public delegate | HyperTextEvent | Represents a method that will handle the SyntaxEdit.CheckHyperText, TextSource.CheckHyperText or HyperTextEx.CheckHyperText events.
Public delegate | ThreadProc | Represents a method that will handle thread method.
Public delegate | UndoEvent | Represents a method that will handle the IUndo.Undo event.
Public delegate | WordSpellEvent | Represents a method that will handle the SyntaxEdit.WordSpell, TextSource.WordSpell or Spelling.WordSpell events.
Enumerations
 | Enumeration | Description
Public enumeration | BracesOptions | Defines braces behaviour. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | IndentOptions | Defines behaviour of Edit control when user presses Enter to insert new text line. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | NavigateOptions | Defines specific options for navigation through the editor's content. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | NotifyState | Represents the last changes to the text stored in the text source. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | SearchOptions | Defines options for search and replace operations. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | UndoFlags | Defines additional flags for undo/redo operation. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | UndoOperation | Defines a type of the operation to undo.
Public enumeration | UndoOptions | Defines undo/redo behaviour. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | UpdateReason | Defines reason of updating control's text content.


BlockDeletingEventArgs Class

BlockDeletingEventArgs Class
Provides data for the event that occurs when some block of lines within the ITextSource is deleted.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.TextSourceBlockDeletingEventArgs

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BlockDeletingEventArgs : EventArgs
Public Class BlockDeletingEventArgs
    Inherits EventArgs
public ref class BlockDeletingEventArgs : public EventArgs
type BlockDeletingEventArgs =
    class
        inherit EventArgs
    end

The BlockDeletingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BlockDeletingEventArgs | Initializes a new instance of the BlockDeletingEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Rect | Represents the rectangle area of block being deleted by ITextSource.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


BlockDeletingEventArgs Constructor

BlockDeletingEventArgs Constructor
Initializes a new instance of the BlockDeletingEventArgs class with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BlockDeletingEventArgs(
    Rectangle rect
)
Public Sub New (
    rect As Rectangle
)
public:
BlockDeletingEventArgs(
    Rectangle rect
)
new :
        rect : Rectangle -> BlockDeletingEventArgs

Parameters

rect
Type: System.DrawingRectangle
Rectangular are of the text being deleted.
See Also

Reference

BlockDeletingEventArgs Class
Alternet.Editor.TextSource Namespace


BlockDeletingEventArgs Methods

BlockDeletingEventArgs Methods

The BlockDeletingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BlockDeletingEventArgs Class
Alternet.Editor.TextSource Namespace


BlockDeletingEventArgs Properties

BlockDeletingEventArgs Properties

The BlockDeletingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Rect | Represents the rectangle area of block being deleted by ITextSource.
Top
See Also

Reference

BlockDeletingEventArgs Class
Alternet.Editor.TextSource Namespace


BlockDeletingEventArgs.Rect Property

BlockDeletingEventArgsRect Property
Represents the rectangle area of block being deleted by ITextSource.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle Rect { get; set; }
Public Property Rect As Rectangle
    Get
    Set
public:
property Rectangle Rect {
    Rectangle get ();
    void set (Rectangle value);
}
member Rect : Rectangle with get, set

Property Value

Type: Rectangle
See Also

Reference

BlockDeletingEventArgs Class
Alternet.Editor.TextSource Namespace


BookMark Class

BookMark Class
BookMark class is used to store individual bookmark in bookmarks collection of Edit control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TextSourceBookMark
Alternet.Editor.TextSourceLineStyle

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BookMark : IBookMark
Public Class BookMark
    Implements IBookMark
public ref class BookMark : IBookMark
type BookMark =
    class
        interface IBookMark
    end

The BookMark type exposes the following members.

Constructors
 | Name | Description
Public method | BookMark | Initializes a new instance of the BookMark class with default settings.
Public method | BookMark(Int32) | Initializes a new instance of the BookMark class with specified settings.
Public method | BookMark(Int32, String) | Initializes a new instance of the BookMark class with specified Line and FileName values.
Public method | BookMark(Int32, Int32, Int32) | Initializes a new instance of the BookMark class with specified Pos, Index and Line values.
Public method | BookMark(Int32, Int32, Int32, Int32, Int32, String) | Initializes a new instance of the BookMark class with specified Pos, Line, Index, Group, Name, Description, Url, ImageIndex, FileName and Tag values.
Public method | BookMark(Int32, Int32, Int32, String, String, String) | Initializes a new instance of the BookMark class with specified Pos, Line, Index, Name, Description and Url values.
Public method | BookMark(Int32, Int32, Int32, String, String, String, Int32, String, Object) | Initializes a new instance of the BookMark class with specified Pos, Line, Index, Name, Description, Url, ImageIndex, FileName and Tag values.
Public method | BookMark(Int32, Int32, Int32, Int32, Int32, String, String, String, String, Object) | Initializes a new instance of the BookMark class with specified Pos, Line, Index, Group, ImageIndex, Name, Description, Url, ImageIndex, FileName and Tag values.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another bookmark object to the bookmark.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeDescription | Indicates whether the Description should be persisted.
Public method | ShouldSerializeFileName | Indicates whether the FileName should be persisted.
Public method | ShouldSerializeGroup | Indicates whether the Group should be persisted.
Public method | ShouldSerializeImageIndex | Indicates whether the ImageIndex should be persisted.
Public method | ShouldSerializeIndex | Indicates whether the Index should be persisted.
Public method | ShouldSerializeLine | Indicates whether the Line should be persisted.
Public method | ShouldSerializeName | Indicates whether the Name should be persisted.
Public method | ShouldSerializePos | Indicates whether the Pos should be persisted.
Public method | ShouldSerializeUrl | Indicates whether the Url should be persisted.
Public method | ShouldSerializeZIndex | Indicates whether the ZIndex should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | Gets or sets bookmark description.
Public property | FileName | Gets or sets an file name associated with this IBookMark.
Public property | Group | When implemented by a class, gets or sets a group associated with this IBookMark.
Public property | ImageIndex | Gets or sets an image index associated with this IBookMark.
Public property | Index | Gets an integer value that specifies ordinal number of the bookmark.
Public property | Line | Gets position of the bookmark within the text. 0 corresponds to the first line, 1 to second the line, and so on.
Public property | Name | Gets or sets name of the bookmark.
Public property | Pos | Gets position of the bookmark within the text line. 0 corresponds to the first character in a line, 1 to the second character, and so on.
Public property | Position | Gets position of the bookmark within the text (index of character and line). Corresponds to Pos and Line properties.
Public property | Tag | Gets or sets user-defined data associated with this IBookMark.
Public property | Url | Gets or sets bookmark url.
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark.
Top
Remarks
Implements IBookMark interface.
See Also

Reference

Alternet.Editor.TextSource Namespace
Alternet.Editor.TextSourceIBookMark


BookMark Constructor

BookMark Constructor
Overload List
 | Name | Description
Public method | BookMark | Initializes a new instance of the BookMark class with default settings.
Public method | BookMark(Int32) | Initializes a new instance of the BookMark class with specified settings.
Public method | BookMark(Int32, String) | Initializes a new instance of the BookMark class with specified Line and FileName values.
Public method | BookMark(Int32, Int32, Int32) | Initializes a new instance of the BookMark class with specified Pos, Index and Line values.
Public method | BookMark(Int32, Int32, Int32, Int32, Int32, String) | Initializes a new instance of the BookMark class with specified Pos, Line, Index, Group, Name, Description, Url, ImageIndex, FileName and Tag values.
Public method | BookMark(Int32, Int32, Int32, String, String, String) | Initializes a new instance of the BookMark class with specified Pos, Line, Index, Name, Description and Url values.
Public method | BookMark(Int32, Int32, Int32, String, String, String, Int32, String, Object) | Initializes a new instance of the BookMark class with specified Pos, Line, Index, Name, Description, Url, ImageIndex, FileName and Tag values.
Public method | BookMark(Int32, Int32, Int32, Int32, Int32, String, String, String, String, Object) | Initializes a new instance of the BookMark class with specified Pos, Line, Index, Group, ImageIndex, Name, Description, Url, ImageIndex, FileName and Tag values.
Top
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark Constructor

BookMark Constructor
Initializes a new instance of the BookMark class with default settings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMark()
Public Sub New
public:
BookMark()
new : unit -> BookMark
See Also

Reference

BookMark Class
BookMark Overload
Alternet.Editor.TextSource Namespace


BookMark Constructor (Int32)

BookMark Constructor (Int32)
Initializes a new instance of the BookMark class with specified settings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMark(
    int line
)
Public Sub New (
    line As Integer
)
public:
BookMark(
    int line
)
new :
        line : int -> BookMark

Parameters

line
Type: SystemInt32
Specifies Line property of a new instance.
See Also

Reference

BookMark Class
BookMark Overload
Alternet.Editor.TextSource Namespace


BookMark Constructor (Int32, String)

BookMark Constructor (Int32, String)
Initializes a new instance of the BookMark class with specified Line and FileName values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMark(
    int line,
    string fileName
)
Public Sub New (
    line As Integer,
    fileName As String
)
public:
BookMark(
    int line,
    String^ fileName
)
new :
        line : int *
        fileName : string -> BookMark

Parameters

line
Type: SystemInt32
Specifies Line property of a new instance.
fileName
Type: SystemString
Specifies FileName property of a new instance.
See Also

Reference

BookMark Class
BookMark Overload
Alternet.Editor.TextSource Namespace


BookMark Constructor (Int32, Int32, Int32)

BookMark Constructor (Int32, Int32, Int32)
Initializes a new instance of the BookMark class with specified Pos, Index and Line values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMark(
    int line,
    int pos,
    int index
)
Public Sub New (
    line As Integer,
    pos As Integer,
    index As Integer
)
public:
BookMark(
    int line,
    int pos,
    int index
)
new :
        line : int *
        pos : int *
        index : int -> BookMark

Parameters

line
Type: SystemInt32
Specifies Line property of a new instance.
pos
Type: SystemInt32
Specifies Pos property of a new instance.
index
Type: SystemInt32
Specifies Index property of a new instance.
See Also

Reference

BookMark Class
BookMark Overload
Alternet.Editor.TextSource Namespace


BookMark Constructor (Int32, Int32, Int32, Int32, Int32, String)

BookMark Constructor (Int32, Int32, Int32, Int32, Int32, String)
Initializes a new instance of the BookMark class with specified Pos, Line, Index, Group, Name, Description, Url, ImageIndex, FileName and Tag values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMark(
    int line,
    int pos,
    int index,
    int group,
    int imageIndex,
    string fileName
)
Public Sub New (
    line As Integer,
    pos As Integer,
    index As Integer,
    group As Integer,
    imageIndex As Integer,
    fileName As String
)
public:
BookMark(
    int line,
    int pos,
    int index,
    int group,
    int imageIndex,
    String^ fileName
)
new :
        line : int *
        pos : int *
        index : int *
        group : int *
        imageIndex : int *
        fileName : string -> BookMark

Parameters

line
Type: SystemInt32
Specifies Line property of a new instance.
pos
Type: SystemInt32
Specifies Pos property of a new instance.
index
Type: SystemInt32
Specifies Index property of a new instance.
group
Type: SystemInt32
Specifies Group property of a new instance.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of a new instance.
fileName
Type: SystemString
Specifies FileName property of a new instance.
See Also

Reference

BookMark Class
BookMark Overload
Alternet.Editor.TextSource Namespace


BookMark Constructor (Int32, Int32, Int32, String, String, String)

BookMark Constructor (Int32, Int32, Int32, String, String, String)
Initializes a new instance of the BookMark class with specified Pos, Line, Index, Name, Description and Url values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMark(
    int line,
    int pos,
    int index,
    string name,
    string description,
    string url
)
Public Sub New (
    line As Integer,
    pos As Integer,
    index As Integer,
    name As String,
    description As String,
    url As String
)
public:
BookMark(
    int line,
    int pos,
    int index,
    String^ name,
    String^ description,
    String^ url
)
new :
        line : int *
        pos : int *
        index : int *
        name : string *
        description : string *
        url : string -> BookMark

Parameters

line
Type: SystemInt32
Specifies Line property of a new instance.
pos
Type: SystemInt32
Specifies Pos property of a new instance.
index
Type: SystemInt32
Specifies Index property of a new instance.
name
Type: SystemString
Specifies Name property of a new instance.
description
Type: SystemString
Specifies Description property of a new instance.
url
Type: SystemString
Specifies Url property of a new instance.
See Also

Reference

BookMark Class
BookMark Overload
Alternet.Editor.TextSource Namespace


BookMark Constructor (Int32, Int32, Int32, String, String, String, Int32, String, Object)

BookMark Constructor (Int32, Int32, Int32, String, String, String, Int32, String, Object)
Initializes a new instance of the BookMark class with specified Pos, Line, Index, Name, Description, Url, ImageIndex, FileName and Tag values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMark(
    int line,
    int pos,
    int index,
    string name,
    string description,
    string url,
    int imageIndex,
    string fileName,
    Object tag
)
Public Sub New (
    line As Integer,
    pos As Integer,
    index As Integer,
    name As String,
    description As String,
    url As String,
    imageIndex As Integer,
    fileName As String,
    tag As Object
)
public:
BookMark(
    int line,
    int pos,
    int index,
    String^ name,
    String^ description,
    String^ url,
    int imageIndex,
    String^ fileName,
    Object^ tag
)
new :
        line : int *
        pos : int *
        index : int *
        name : string *
        description : string *
        url : string *
        imageIndex : int *
        fileName : string *
        tag : Object -> BookMark

Parameters

line
Type: SystemInt32
Specifies Line property of a new instance.
pos
Type: SystemInt32
Specifies Pos property of a new instance.
index
Type: SystemInt32
Specifies Index property of a new instance.
name
Type: SystemString
Specifies Name property of a new instance.
description
Type: SystemString
Specifies Description property of a new instance.
url
Type: SystemString
Specifies Url property of a new instance.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of a new instance.
fileName
Type: SystemString
Specifies FileName property of a new instance.
tag
Type: SystemObject
Specifies Tag property of a new instance.
See Also

Reference

BookMark Class
BookMark Overload
Alternet.Editor.TextSource Namespace


BookMark Constructor (Int32, Int32, Int32, Int32, Int32, String, String, String, String, Object)

BookMark Constructor (Int32, Int32, Int32, Int32, Int32, String, String, String, String, Object)
Initializes a new instance of the BookMark class with specified Pos, Line, Index, Group, ImageIndex, Name, Description, Url, ImageIndex, FileName and Tag values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMark(
    int line,
    int pos,
    int group,
    int index,
    int imageIndex,
    string name,
    string description,
    string url,
    string fileName,
    Object tag
)
Public Sub New (
    line As Integer,
    pos As Integer,
    group As Integer,
    index As Integer,
    imageIndex As Integer,
    name As String,
    description As String,
    url As String,
    fileName As String,
    tag As Object
)
public:
BookMark(
    int line,
    int pos,
    int group,
    int index,
    int imageIndex,
    String^ name,
    String^ description,
    String^ url,
    String^ fileName,
    Object^ tag
)
new :
        line : int *
        pos : int *
        group : int *
        index : int *
        imageIndex : int *
        name : string *
        description : string *
        url : string *
        fileName : string *
        tag : Object -> BookMark

Parameters

line
Type: SystemInt32
Specifies Line property of a new instance.
pos
Type: SystemInt32
Specifies Pos property of a new instance.
group
Type: SystemInt32
Specifies Group property of a new instance.
index
Type: SystemInt32
Specifies Index property of a new instance.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of a new instance.
name
Type: SystemString
Specifies Name property of a new instance.
description
Type: SystemString
Specifies Description property of a new instance.
url
Type: SystemString
Specifies Url property of a new instance.
fileName
Type: SystemString
Specifies FileName property of a new instance.
tag
Type: SystemObject
Specifies Tag property of a new instance.
See Also

Reference

BookMark Class
BookMark Overload
Alternet.Editor.TextSource Namespace


BookMark Methods

BookMark Methods

The BookMark type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another bookmark object to the bookmark.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeDescription | Indicates whether the Description should be persisted.
Public method | ShouldSerializeFileName | Indicates whether the FileName should be persisted.
Public method | ShouldSerializeGroup | Indicates whether the Group should be persisted.
Public method | ShouldSerializeImageIndex | Indicates whether the ImageIndex should be persisted.
Public method | ShouldSerializeIndex | Indicates whether the Index should be persisted.
Public method | ShouldSerializeLine | Indicates whether the Line should be persisted.
Public method | ShouldSerializeName | Indicates whether the Name should be persisted.
Public method | ShouldSerializePos | Indicates whether the Pos should be persisted.
Public method | ShouldSerializeUrl | Indicates whether the Url should be persisted.
Public method | ShouldSerializeZIndex | Indicates whether the ZIndex should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.Assign Method

BookMarkAssign Method
Copies the contents of another bookmark object to the bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IBookMark source
)
Public Overridable Sub Assign (
    source As IBookMark
)
public:
virtual void Assign(
    IBookMark^ source
)
abstract Assign :
        source : IBookMark -> unit
override Assign :
        source : IBookMark -> unit

Parameters

source
Type: Alternet.Editor.TextSourceIBookMark
Specifies bookmark to copy content from. Call Assign to copy Line, Index and Pos property from source bookmark.

Implements

IBookMarkAssign(IBookMark)
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializeDescription Method

BookMarkShouldSerializeDescription Method
Indicates whether the Description should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeDescription()
Public Function ShouldSerializeDescription As Boolean
public:
bool ShouldSerializeDescription()
member ShouldSerializeDescription : unit -> bool

Return Value

Type: Boolean
True if Description differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializeFileName Method

BookMarkShouldSerializeFileName Method
Indicates whether the FileName should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeFileName()
Public Function ShouldSerializeFileName As Boolean
public:
bool ShouldSerializeFileName()
member ShouldSerializeFileName : unit -> bool

Return Value

Type: Boolean
True if FileName differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializeGroup Method

BookMarkShouldSerializeGroup Method
Indicates whether the Group should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeGroup()
Public Function ShouldSerializeGroup As Boolean
public:
bool ShouldSerializeGroup()
member ShouldSerializeGroup : unit -> bool

Return Value

Type: Boolean
True if Group differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializeImageIndex Method

BookMarkShouldSerializeImageIndex Method
Indicates whether the ImageIndex should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeImageIndex()
Public Function ShouldSerializeImageIndex As Boolean
public:
bool ShouldSerializeImageIndex()
member ShouldSerializeImageIndex : unit -> bool

Return Value

Type: Boolean
True if ImageIndex differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializeIndex Method

BookMarkShouldSerializeIndex Method
Indicates whether the Index should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeIndex()
Public Function ShouldSerializeIndex As Boolean
public:
bool ShouldSerializeIndex()
member ShouldSerializeIndex : unit -> bool

Return Value

Type: Boolean
True if Index differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializeLine Method

BookMarkShouldSerializeLine Method
Indicates whether the Line should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLine()
Public Function ShouldSerializeLine As Boolean
public:
bool ShouldSerializeLine()
member ShouldSerializeLine : unit -> bool

Return Value

Type: Boolean
True if Line differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializeName Method

BookMarkShouldSerializeName Method
Indicates whether the Name should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeName()
Public Function ShouldSerializeName As Boolean
public:
bool ShouldSerializeName()
member ShouldSerializeName : unit -> bool

Return Value

Type: Boolean
True if Name differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializePos Method

BookMarkShouldSerializePos Method
Indicates whether the Pos should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializePos()
Public Function ShouldSerializePos As Boolean
public:
bool ShouldSerializePos()
member ShouldSerializePos : unit -> bool

Return Value

Type: Boolean
True if Pos differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializeUrl Method

BookMarkShouldSerializeUrl Method
Indicates whether the Url should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeUrl()
Public Function ShouldSerializeUrl As Boolean
public:
bool ShouldSerializeUrl()
member ShouldSerializeUrl : unit -> bool

Return Value

Type: Boolean
True if Url differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ShouldSerializeZIndex Method

BookMarkShouldSerializeZIndex Method
Indicates whether the ZIndex should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeZIndex()
Public Function ShouldSerializeZIndex As Boolean
public:
bool ShouldSerializeZIndex()
member ShouldSerializeZIndex : unit -> bool

Return Value

Type: Boolean
True if ZIndex differs from its default value; otherwise false.
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark Properties

BookMark Properties

The BookMark type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets bookmark description.
Public property | FileName | Gets or sets an file name associated with this IBookMark.
Public property | Group | When implemented by a class, gets or sets a group associated with this IBookMark.
Public property | ImageIndex | Gets or sets an image index associated with this IBookMark.
Public property | Index | Gets an integer value that specifies ordinal number of the bookmark.
Public property | Line | Gets position of the bookmark within the text. 0 corresponds to the first line, 1 to second the line, and so on.
Public property | Name | Gets or sets name of the bookmark.
Public property | Pos | Gets position of the bookmark within the text line. 0 corresponds to the first character in a line, 1 to the second character, and so on.
Public property | Position | Gets position of the bookmark within the text (index of character and line). Corresponds to Pos and Line properties.
Public property | Tag | Gets or sets user-defined data associated with this IBookMark.
Public property | Url | Gets or sets bookmark url.
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark.
Top
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.Description Property

BookMarkDescription Property
Gets or sets bookmark description.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

IBookMarkDescription
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.FileName Property

BookMarkFileName Property
Gets or sets an file name associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string FileName { get; set; }
Public Overridable Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

IBookMarkFileName
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.Group Property

BookMarkGroup Property
When implemented by a class, gets or sets a group associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Group { get; set; }
Public Overridable Property Group As Integer
    Get
    Set
public:
virtual property int Group {
    int get ();
    void set (int value);
}
abstract Group : int with get, set
override Group : int with get, set

Property Value

Type: Int32

Implements

IBookMarkGroup
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ImageIndex Property

BookMarkImageIndex Property
Gets or sets an image index associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ImageIndex { get; set; }
Public Overridable Property ImageIndex As Integer
    Get
    Set
public:
virtual property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set
override ImageIndex : int with get, set

Property Value

Type: Int32

Implements

IBookMarkImageIndex
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.Index Property

BookMarkIndex Property
Gets an integer value that specifies ordinal number of the bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Index { get; }
Public Overridable ReadOnly Property Index As Integer
    Get
public:
virtual property int Index {
    int get ();
}
abstract Index : int with get
override Index : int with get

Property Value

Type: Int32

Implements

IBookMarkIndex
Remarks
Edit can display bookmarks that have Index between 0 and 9, or unnumbered bookmarks (with Index equal to Int.MaxValue).
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace
BookMarkLine
BookMarkPos


BookMark.Line Property

BookMarkLine Property
Gets position of the bookmark within the text. 0 corresponds to the first line, 1 to second the line, and so on.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Line { get; }
Public Overridable ReadOnly Property Line As Integer
    Get
public:
virtual property int Line {
    int get ();
}
abstract Line : int with get
override Line : int with get

Property Value

Type: Int32

Implements

IBookMarkLine
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace
BookMarkPos
BookMarkIndex


BookMark.Name Property

BookMarkName Property
Gets or sets name of the bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IBookMarkName
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.Pos Property

BookMarkPos Property
Gets position of the bookmark within the text line. 0 corresponds to the first character in a line, 1 to the second character, and so on.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Pos { get; }
Public Overridable ReadOnly Property Pos As Integer
    Get
public:
virtual property int Pos {
    int get ();
}
abstract Pos : int with get
override Pos : int with get

Property Value

Type: Int32

Implements

IBookMarkPos
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace
BookMarkLine
BookMarkIndex


BookMark.Position Property

BookMarkPosition Property
Gets position of the bookmark within the text (index of character and line). Corresponds to Pos and Line properties.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Position { get; set; }
Public Overridable Property Position As Point
    Get
    Set
public:
virtual property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set
override Position : Point with get, set

Property Value

Type: Point

Implements

IBookMarkPosition
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace
BookMarkPos
BookMarkLine
BookMarkIndex


BookMark.Tag Property

BookMarkTag Property
Gets or sets user-defined data associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Tag { get; set; }
Public Overridable Property Tag As Object
    Get
    Set
public:
virtual property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
abstract Tag : Object with get, set
override Tag : Object with get, set

Property Value

Type: Object

Implements

IBookMarkTag
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.Url Property

BookMarkUrl Property
Gets or sets bookmark url.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Url { get; set; }
Public Overridable Property Url As String
    Get
    Set
public:
virtual property String^ Url {
    String^ get ();
    void set (String^ value);
}
abstract Url : string with get, set
override Url : string with get, set

Property Value

Type: String

Implements

IBookMarkUrl
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMark.ZIndex Property

BookMarkZIndex Property
When implemented by a class, gets or sets an z-index associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ZIndex { get; set; }
Public Overridable Property ZIndex As Integer
    Get
    Set
public:
virtual property int ZIndex {
    int get ();
    void set (int value);
}
abstract ZIndex : int with get, set
override ZIndex : int with get, set

Property Value

Type: Int32

Implements

IBookMarkZIndex
See Also

Reference

BookMark Class
Alternet.Editor.TextSource Namespace


BookMarks Class

BookMarks Class
Represents a collection of the BookMark objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIBookMark
Alternet.CommonSortList IBookMark
Alternet.Editor.TextSourceBookMarks

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BookMarks : SortList<IBookMark>,
    IBookMarks, IList<IBookMark>, ICollection<IBookMark>,
    IEnumerable<IBookMark>, IEnumerable
Public Class BookMarks
    Inherits SortList(Of IBookMark)
    Implements IBookMarks, IList(Of IBookMark),
    ICollection(Of IBookMark), IEnumerable(Of IBookMark), IEnumerable
public ref class BookMarks : public SortList<IBookMark^>,
    IBookMarks, IList<IBookMark^>, ICollection<IBookMark^>,
    IEnumerable<IBookMark^>, IEnumerable
type BookMarks =
    class
        inherit SortList<IBookMark>
        interface IBookMarks
        interface IList<IBookMark>
        interface ICollection<IBookMark>
        interface IEnumerable<IBookMark>
        interface IEnumerable
    end

The BookMarks type exposes the following members.

Constructors
 | Name | Description
Public method | BookMarks | Initializes a new instance of the BookMarksclass with default settings.
Public method | BookMarks(ITextSource) | Initializes a new instance of the BookMarks class with specified owner.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIBookMark .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIBookMark .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIBookMark .)
Public method | Assign | Copies the contents of the another BookMarks collection to the bookmark collection.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIBookMark .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIBookMark .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIBookMark .)
Public method | BlockDeleting | Removes all bookmarks within specified rectangle.
Public method | Clear | Removes all bookmarks from the bookmarks collection.
Public method | ClearAllBookMarks | Removes all bookmarks from the bookmarks collection.
Public method | ClearAllUnnumberedBookmarks | Removes all unnumbered bookmarks from the bookmarks collection.
Public method | ClearBookMark(Int32) | Finds the bookmark with specified index and removes it from bookmarks collection.
Public method | ClearBookMark(Int32, Int32) | Finds the bookmark by given index in a given line and removes its from bookmark collection.
Public method | ClearBookMark(Int32, Int32, Int32) | Finds the bookmark by given index and group in a given line and removes its from bookmark collection.
Public method | ClearBookMarkByIndex | Removes the bookmark from bookmarks collection at the specified index. Updates state of the TextSource owning this collection.
Public method | ClearBookMarks | Removes all bookmarks.
Public method | ClearBookMarks(Int32) | Removes all bookmarks from the specified line.
Public method | ClearBookMarks(Int32, Int32) | Removes all bookmarks from the specified line for specified Group.
Public method | ClearBookMarksByGroup | Removes all bookmarks for the specified Bookmarks group.
Public method | ClearUnnumberedBookMarks | Removes all Unnumbered Bookmarks.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIBookMark .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIBookMark .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIBookMark .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIBookMark .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIBookMark .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIBookMark .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIBookMark .)
Public method | FindBookMark(Int32) | Locates the bookmark with specified Index.
Public method | FindBookMark(String) | Locates the bookmark with specified Name.
Public method | FindBookMark(Int32, Point) | Locates the bookmark with specified Index.
Public method | FindBookMark(Int32, Int32) | Locates the bookmark with specified index within the specified line.
Public method | FindBookMark(Int32, Int32, Int32) | Locates the bookmark with specified index within the specified line.
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIBookMark .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIBookMark .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIBookMark .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIBookMark .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIBookMark .)
Public method | GetBookMark(Int32) | Finds the first bookmark in the BookMarks collection located within the specified text line.
Public method | GetBookMark(Point, Point) | Finds the first bookmark in the BookMarks collection that locates within the specified range.
Public method | GetBookMark(Int32, Int32) | Finds the first item in the bookmark collection located within the specified text line and associated with specified group.
Public method | GetBookMark(Point, Point, Int32) | Finds the first item in the bookmark collection located within the specified scope and associated with specified group.
Public method | GetBookMarks(IListIBookMark) | Finds all items in the bookmark collection.
Public method | GetBookMarks(Int32, IListIBookMark) | Finds all items in the bookmark collection associated with specified group.
Public method | GetBookMarks(Point, Point, IListIBookMark) | Finds all bookmarks in the BookMarks collection located within the specified range.
Public method | GetBookMarks(Point, Point, Int32, IListIBookMark) | Finds all items in the bookmark collection located within the specified scope and associated with specified group.
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIBookMark .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImages | Returns image list by its group.
Public method | GetImagesScaled | Returns image list by its group, scaled for DPI.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIBookMark .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoBookMark | Moves caret to the location of the bookmark in the text source.
Public method | GotoNextBookMark | Moves to the location of the next unnumbered bookmark in the text source.
Public method | GotoNextBookMark(Int32) | Moves to the location of the next unnumbered bookmark in the text source.
Public method | GotoPrevBookMark | Moves caret to the location of the previous unnumbered bookmark in the text source.
Public method | GotoPrevBookMark(Int32) | Moves caret to the location of the previous unnumbered bookmark in the text source.
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIBookMark .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIBookMark .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIBookMark .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIBookMark .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIBookMark .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIBookMark .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | NextBookMark | Returns the minimal possible value of the bookmark Index property of the new bookmark.
Public method | NextBookMark(Int32) | Returns the minimal possible value of the bookmark Index property of the new bookmark.
Public method | OnClick | Raises OnClick event.
Public method | OnDoubleClick | Raises OnDoubleClick event.
Public method | OnShowTooltip | Raises OnShowTooltip event.
Public method | PositionChanged | Updates all bookmarks starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIBookMark .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIBookMark .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIBookMark .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIBookMark .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIBookMark .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIBookMark .)
Public method | SetBookMark(IBookMark) | Sets the bookmark specified by bookMark parameter.
Public method | SetBookMark(Point, Int32) | Sets the bookmark with specified index to the position specified by Point parameter.
Public method | SetBookMark(Int32, Int32) | Sets the bookmark with specified index to the position specified by line parameter.
Public method | SetBookMark(Point, Int32, Int32, Int32) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Int32, Int32, Int32, Int32) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Point, Int32, String, String, String) | Sets the bookmark with specified index, name, description and url to the position specified by Point parameter.
Public method | SetBookMark(Point, Int32, Int32, Int32, String, String, String) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Point, Int32, Int32, Int32, String, String, String, Object) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Point, Int32, String, String, String, Int32, String, Object, Boolean) | Sets the bookmark with specified index, name, description and url to the position specified by Point parameter.
Public method | SetForcedMarker |
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIBookMark .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIBookMark .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIBookMark .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIBookMark .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIBookMark .)
Public method | ToggleBookMark | Sets or removes an unnumbered bookmark on the current line.
Public method | ToggleBookMark(Int32) | Sets or removes bookmark with specified index at the current line.
Public method | ToggleBookMark(IBookMark) | Sets or removes bookmark specified by bookMark parameter.
Public method | ToggleBookMark(Point, Int32) | Sets or removes bookmark with specified index at the specified line.
Public method | ToggleBookMark(Int32, Int32) | Sets or removes bookmark with specified index at the specified line.
Public method | ToggleBookMark(Int32, Int32, Int32) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, Int32, Int32) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Int32, Int32, Int32, Int32) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, String, String, String) | Sets or removes bookmark with specified index at the specified line.
Public method | ToggleBookMark(Point, Int32, Int32, Int32, String, String, String) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, Int32, Int32, String, String, String, Object) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, String, String, String, Int32, String, Object) | Sets or removes bookmark with specified index at the specified line.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIBookMark .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIBookMark .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIBookMark | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIBookMark | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIBookMark, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIBookMark .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIBookMark .)
Public property | Shared | Specifies if bookmarks should be shared across all documents.
Top
Events
 | Name | Description
Public event | Click | Occurs when Bookmark is being clicked.
Public event | DoubleClick | When implemented by a class, occurs when Bookmark is being double clicked.
Public event | ShowToolTip | Occurs when Bookmark Tooltip needs to be displayed.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


BookMarks Constructor

BookMarks Constructor
Overload List
 | Name | Description
Public method | BookMarks | Initializes a new instance of the BookMarksclass with default settings.
Public method | BookMarks(ITextSource) | Initializes a new instance of the BookMarks class with specified owner.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks Constructor

BookMarks Constructor
Initializes a new instance of the BookMarksclass with default settings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMarks()
Public Sub New
public:
BookMarks()
new : unit -> BookMarks
See Also

Reference

BookMarks Class
BookMarks Overload
Alternet.Editor.TextSource Namespace


BookMarks Constructor (ITextSource)

BookMarks Constructor (ITextSource)
Initializes a new instance of the BookMarks class with specified owner.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BookMarks(
    ITextSource owner
)
Public Sub New (
    owner As ITextSource
)
public:
BookMarks(
    ITextSource^ owner
)
new :
        owner : ITextSource -> BookMarks

Parameters

owner
Type: Alternet.Editor.TextSourceITextSource
Class implementing ITextSource interface that owns the collection.
See Also

Reference

BookMarks Class
BookMarks Overload
Alternet.Editor.TextSource Namespace


BookMarks Methods

BookMarks Methods

The BookMarks type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIBookMark .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIBookMark .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIBookMark .)
Public method | Assign | Copies the contents of the another BookMarks collection to the bookmark collection.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIBookMark .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIBookMark .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIBookMark .)
Public method | BlockDeleting | Removes all bookmarks within specified rectangle.
Public method | Clear | Removes all bookmarks from the bookmarks collection.
Public method | ClearAllBookMarks | Removes all bookmarks from the bookmarks collection.
Public method | ClearAllUnnumberedBookmarks | Removes all unnumbered bookmarks from the bookmarks collection.
Public method | ClearBookMark(Int32) | Finds the bookmark with specified index and removes it from bookmarks collection.
Public method | ClearBookMark(Int32, Int32) | Finds the bookmark by given index in a given line and removes its from bookmark collection.
Public method | ClearBookMark(Int32, Int32, Int32) | Finds the bookmark by given index and group in a given line and removes its from bookmark collection.
Public method | ClearBookMarkByIndex | Removes the bookmark from bookmarks collection at the specified index. Updates state of the TextSource owning this collection.
Public method | ClearBookMarks | Removes all bookmarks.
Public method | ClearBookMarks(Int32) | Removes all bookmarks from the specified line.
Public method | ClearBookMarks(Int32, Int32) | Removes all bookmarks from the specified line for specified Group.
Public method | ClearBookMarksByGroup | Removes all bookmarks for the specified Bookmarks group.
Public method | ClearUnnumberedBookMarks | Removes all Unnumbered Bookmarks.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIBookMark .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIBookMark .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIBookMark .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIBookMark .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIBookMark .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIBookMark .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIBookMark .)
Public method | FindBookMark(Int32) | Locates the bookmark with specified Index.
Public method | FindBookMark(String) | Locates the bookmark with specified Name.
Public method | FindBookMark(Int32, Point) | Locates the bookmark with specified Index.
Public method | FindBookMark(Int32, Int32) | Locates the bookmark with specified index within the specified line.
Public method | FindBookMark(Int32, Int32, Int32) | Locates the bookmark with specified index within the specified line.
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIBookMark .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIBookMark .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIBookMark .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIBookMark .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIBookMark .)
Public method | GetBookMark(Int32) | Finds the first bookmark in the BookMarks collection located within the specified text line.
Public method | GetBookMark(Point, Point) | Finds the first bookmark in the BookMarks collection that locates within the specified range.
Public method | GetBookMark(Int32, Int32) | Finds the first item in the bookmark collection located within the specified text line and associated with specified group.
Public method | GetBookMark(Point, Point, Int32) | Finds the first item in the bookmark collection located within the specified scope and associated with specified group.
Public method | GetBookMarks(IListIBookMark) | Finds all items in the bookmark collection.
Public method | GetBookMarks(Int32, IListIBookMark) | Finds all items in the bookmark collection associated with specified group.
Public method | GetBookMarks(Point, Point, IListIBookMark) | Finds all bookmarks in the BookMarks collection located within the specified range.
Public method | GetBookMarks(Point, Point, Int32, IListIBookMark) | Finds all items in the bookmark collection located within the specified scope and associated with specified group.
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIBookMark .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImages | Returns image list by its group.
Public method | GetImagesScaled | Returns image list by its group, scaled for DPI.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIBookMark .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoBookMark | Moves caret to the location of the bookmark in the text source.
Public method | GotoNextBookMark | Moves to the location of the next unnumbered bookmark in the text source.
Public method | GotoNextBookMark(Int32) | Moves to the location of the next unnumbered bookmark in the text source.
Public method | GotoPrevBookMark | Moves caret to the location of the previous unnumbered bookmark in the text source.
Public method | GotoPrevBookMark(Int32) | Moves caret to the location of the previous unnumbered bookmark in the text source.
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIBookMark .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIBookMark .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIBookMark .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIBookMark .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIBookMark .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIBookMark .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIBookMark .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | NextBookMark | Returns the minimal possible value of the bookmark Index property of the new bookmark.
Public method | NextBookMark(Int32) | Returns the minimal possible value of the bookmark Index property of the new bookmark.
Public method | OnClick | Raises OnClick event.
Public method | OnDoubleClick | Raises OnDoubleClick event.
Public method | OnShowTooltip | Raises OnShowTooltip event.
Public method | PositionChanged | Updates all bookmarks starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIBookMark .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIBookMark .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIBookMark .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIBookMark .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIBookMark .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIBookMark .)
Public method | SetBookMark(IBookMark) | Sets the bookmark specified by bookMark parameter.
Public method | SetBookMark(Point, Int32) | Sets the bookmark with specified index to the position specified by Point parameter.
Public method | SetBookMark(Int32, Int32) | Sets the bookmark with specified index to the position specified by line parameter.
Public method | SetBookMark(Point, Int32, Int32, Int32) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Int32, Int32, Int32, Int32) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Point, Int32, String, String, String) | Sets the bookmark with specified index, name, description and url to the position specified by Point parameter.
Public method | SetBookMark(Point, Int32, Int32, Int32, String, String, String) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Point, Int32, Int32, Int32, String, String, String, Object) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Point, Int32, String, String, String, Int32, String, Object, Boolean) | Sets the bookmark with specified index, name, description and url to the position specified by Point parameter.
Public method | SetForcedMarker |
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIBookMark .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIBookMark .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIBookMark .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIBookMark .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIBookMark .)
Public method | ToggleBookMark | Sets or removes an unnumbered bookmark on the current line.
Public method | ToggleBookMark(Int32) | Sets or removes bookmark with specified index at the current line.
Public method | ToggleBookMark(IBookMark) | Sets or removes bookmark specified by bookMark parameter.
Public method | ToggleBookMark(Point, Int32) | Sets or removes bookmark with specified index at the specified line.
Public method | ToggleBookMark(Int32, Int32) | Sets or removes bookmark with specified index at the specified line.
Public method | ToggleBookMark(Int32, Int32, Int32) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, Int32, Int32) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Int32, Int32, Int32, Int32) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, String, String, String) | Sets or removes bookmark with specified index at the specified line.
Public method | ToggleBookMark(Point, Int32, Int32, Int32, String, String, String) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, Int32, Int32, String, String, String, Object) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, String, String, String, Int32, String, Object) | Sets or removes bookmark with specified index at the specified line.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIBookMark .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIBookMark .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIBookMark | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIBookMark | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIBookMark, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.Assign Method

BookMarksAssign Method
Copies the contents of the another BookMarks collection to the bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IBookMarks source
)
Public Overridable Sub Assign (
    source As IBookMarks
)
public:
virtual void Assign(
    IBookMarks^ source
)
abstract Assign :
        source : IBookMarks -> unit
override Assign :
        source : IBookMarks -> unit

Parameters

source
Type: Alternet.Editor.TextSourceIBookMarks
Specifies bookmark collection to copy content from. Call Assign to replace contents of one IBookMarks instance to another. The Assign method deletes all items from the destination collection then adds a copy of each item in the source bookmark collection.

Implements

IBookMarksAssign(IBookMarks)
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.BlockDeleting Method

BookMarksBlockDeleting Method
Removes all bookmarks within specified rectangle.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect
)
Public Overridable Function BlockDeleting (
    rect As Rectangle
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool
override BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to check.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBookMarksBlockDeleting(Rectangle)
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.Clear Method

BookMarksClear Method
Removes all bookmarks from the bookmarks collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ClearAllBookMarks Method

BookMarksClearAllBookMarks Method
Removes all bookmarks from the bookmarks collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearAllBookMarks()
Public Overridable Sub ClearAllBookMarks
public:
virtual void ClearAllBookMarks()
abstract ClearAllBookMarks : unit -> unit
override ClearAllBookMarks : unit -> unit

Implements

IBookMarksClearAllBookMarks
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ClearAllUnnumberedBookmarks Method

BookMarksClearAllUnnumberedBookmarks Method
Removes all unnumbered bookmarks from the bookmarks collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearAllUnnumberedBookmarks()
Public Overridable Sub ClearAllUnnumberedBookmarks
public:
virtual void ClearAllUnnumberedBookmarks()
abstract ClearAllUnnumberedBookmarks : unit -> unit
override ClearAllUnnumberedBookmarks : unit -> unit

Implements

IBookMarksClearAllUnnumberedBookmarks
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ClearBookMark Method

BookMarksClearBookMark Method
Overload List
 | Name | Description
Public method | ClearBookMark(Int32) | Finds the bookmark with specified index and removes it from bookmarks collection.
Public method | ClearBookMark(Int32, Int32) | Finds the bookmark by given index in a given line and removes its from bookmark collection.
Public method | ClearBookMark(Int32, Int32, Int32) | Finds the bookmark by given index and group in a given line and removes its from bookmark collection.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ClearBookMark Method (Int32)

BookMarksClearBookMark Method (Int32)
Finds the bookmark with specified index and removes it from bookmarks collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearBookMark(
    int bookMark
)
Public Overridable Sub ClearBookMark (
    bookMark As Integer
)
public:
virtual void ClearBookMark(
    int bookMark
)
abstract ClearBookMark :
        bookMark : int -> unit
override ClearBookMark :
        bookMark : int -> unit

Parameters

bookMark
Type: SystemInt32
The integer value that specifies bookmark index.

Implements

IBookMarksClearBookMark(Int32)
Remarks
If the bookmark is not found the method does nothing.
See Also

Reference

BookMarks Class
ClearBookMark Overload
Alternet.Editor.TextSource Namespace
BookMarksClearBookMarkByIndex(Int32)


BookMarks.ClearBookMark Method (Int32, Int32)

BookMarksClearBookMark Method (Int32, Int32)
Finds the bookmark by given index in a given line and removes its from bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearBookMark(
    int line,
    int bookmark
)
Public Overridable Sub ClearBookMark (
    line As Integer,
    bookmark As Integer
)
public:
virtual void ClearBookMark(
    int line,
    int bookmark
)
abstract ClearBookMark :
        line : int *
        bookmark : int -> unit
override ClearBookMark :
        line : int *
        bookmark : int -> unit

Parameters

line
Type: SystemInt32
Index of line in lines collection.
bookmark
Type: SystemInt32
Index of the bookmark in the bookmark collection.

Implements

IBookMarksClearBookMark(Int32, Int32)
See Also

Reference

BookMarks Class
ClearBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ClearBookMark Method (Int32, Int32, Int32)

BookMarksClearBookMark Method (Int32, Int32, Int32)
Finds the bookmark by given index and group in a given line and removes its from bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearBookMark(
    int line,
    int group,
    int bookMark
)
Public Overridable Sub ClearBookMark (
    line As Integer,
    group As Integer,
    bookMark As Integer
)
public:
virtual void ClearBookMark(
    int line,
    int group,
    int bookMark
)
abstract ClearBookMark :
        line : int *
        group : int *
        bookMark : int -> unit
override ClearBookMark :
        line : int *
        group : int *
        bookMark : int -> unit

Parameters

line
Type: SystemInt32
Index of line in lines collection.
group
Type: SystemInt32
Specifies index of Bookmark group.
bookMark
Type: SystemInt32
Index of the bookmark in the bookmark collection.
See Also

Reference

BookMarks Class
ClearBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ClearBookMarkByIndex Method

BookMarksClearBookMarkByIndex Method
Removes the bookmark from bookmarks collection at the specified index. Updates state of the TextSource owning this collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearBookMarkByIndex(
    int index
)
Public Overridable Sub ClearBookMarkByIndex (
    index As Integer
)
public:
virtual void ClearBookMarkByIndex(
    int index
)
abstract ClearBookMarkByIndex :
        index : int -> unit
override ClearBookMarkByIndex :
        index : int -> unit

Parameters

index
Type: SystemInt32
The integer value that specifies the zero-based index of bookmark in a bookmarks collection to remove.
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ClearBookMarks Method

BookMarksClearBookMarks Method
Overload List
 | Name | Description
Public method | ClearBookMarks | Removes all bookmarks.
Public method | ClearBookMarks(Int32) | Removes all bookmarks from the specified line.
Public method | ClearBookMarks(Int32, Int32) | Removes all bookmarks from the specified line for specified Group.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ClearBookMarks Method

BookMarksClearBookMarks Method
Removes all bookmarks.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearBookMarks()
Public Overridable Sub ClearBookMarks
public:
virtual void ClearBookMarks()
abstract ClearBookMarks : unit -> unit
override ClearBookMarks : unit -> unit
See Also

Reference

BookMarks Class
ClearBookMarks Overload
Alternet.Editor.TextSource Namespace


BookMarks.ClearBookMarks Method (Int32)

BookMarksClearBookMarks Method (Int32)
Removes all bookmarks from the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearBookMarks(
    int line
)
Public Overridable Sub ClearBookMarks (
    line As Integer
)
public:
virtual void ClearBookMarks(
    int line
)
abstract ClearBookMarks :
        line : int -> unit
override ClearBookMarks :
        line : int -> unit

Parameters

line
Type: SystemInt32
The integer value that specifies index of the text line.

Implements

IBookMarksClearBookMarks(Int32)
See Also

Reference

BookMarks Class
ClearBookMarks Overload
Alternet.Editor.TextSource Namespace


BookMarks.ClearBookMarks Method (Int32, Int32)

BookMarksClearBookMarks Method (Int32, Int32)
Removes all bookmarks from the specified line for specified Group.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearBookMarks(
    int line,
    int group
)
Public Overridable Sub ClearBookMarks (
    line As Integer,
    group As Integer
)
public:
virtual void ClearBookMarks(
    int line,
    int group
)
abstract ClearBookMarks :
        line : int *
        group : int -> unit
override ClearBookMarks :
        line : int *
        group : int -> unit

Parameters

line
Type: SystemInt32
The integer value that specifies index of the text line.
group
Type: SystemInt32
Specifies index of Bookmark group.
See Also

Reference

BookMarks Class
ClearBookMarks Overload
Alternet.Editor.TextSource Namespace


BookMarks.ClearBookMarksByGroup Method

BookMarksClearBookMarksByGroup Method
Removes all bookmarks for the specified Bookmarks group.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearBookMarksByGroup(
    int group
)
Public Overridable Sub ClearBookMarksByGroup (
    group As Integer
)
public:
virtual void ClearBookMarksByGroup(
    int group
)
abstract ClearBookMarksByGroup :
        group : int -> unit
override ClearBookMarksByGroup :
        group : int -> unit

Parameters

group
Type: SystemInt32
The Bookmark group index.
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ClearUnnumberedBookMarks Method

BookMarksClearUnnumberedBookMarks Method
Removes all Unnumbered Bookmarks.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearUnnumberedBookMarks()
Public Overridable Sub ClearUnnumberedBookMarks
public:
virtual void ClearUnnumberedBookMarks()
abstract ClearUnnumberedBookMarks : unit -> unit
override ClearUnnumberedBookMarks : unit -> unit
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.FindBookMark Method

BookMarksFindBookMark Method
Overload List
 | Name | Description
Public method | FindBookMark(Int32) | Locates the bookmark with specified Index.
Public method | FindBookMark(String) | Locates the bookmark with specified Name.
Public method | FindBookMark(Int32, Point) | Locates the bookmark with specified Index.
Public method | FindBookMark(Int32, Int32) | Locates the bookmark with specified index within the specified line.
Public method | FindBookMark(Int32, Int32, Int32) | Locates the bookmark with specified index within the specified line.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.FindBookMark Method (Int32)

BookMarksFindBookMark Method (Int32)
Locates the bookmark with specified Index.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IBookMark FindBookMark(
    int bookMark
)
Public Overridable Function FindBookMark (
    bookMark As Integer
) As IBookMark
public:
virtual IBookMark^ FindBookMark(
    int bookMark
)
abstract FindBookMark :
        bookMark : int -> IBookMark
override FindBookMark :
        bookMark : int -> IBookMark

Parameters

bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to find.

Return Value

Type: IBookMark
IBookmark object if the bookmarks was found; otherwise null.

Implements

IBookMarksFindBookMark(Int32)
See Also

Reference

BookMarks Class
FindBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.FindBookMark Method (String)

BookMarksFindBookMark Method (String)
Locates the bookmark with specified Name.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IBookMark FindBookMark(
    string name
)
Public Overridable Function FindBookMark (
    name As String
) As IBookMark
public:
virtual IBookMark^ FindBookMark(
    String^ name
)
abstract FindBookMark :
        name : string -> IBookMark
override FindBookMark :
        name : string -> IBookMark

Parameters

name
Type: SystemString
The string value that specifies Name of the bookmark to find.

Return Value

Type: IBookMark
IBookmark object if the bookmarks was found; otherwise null.

Implements

IBookMarksFindBookMark(String)
See Also

Reference

BookMarks Class
FindBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.FindBookMark Method (Int32, Point)

BookMarksFindBookMark Method (Int32, Point)
Locates the bookmark with specified Index.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindBookMark(
    int bookMark,
    out Point position
)
Public Overridable Function FindBookMark (
    bookMark As Integer,
    <OutAttribute> ByRef position As Point
) As Boolean
public:
virtual bool FindBookMark(
    int bookMark,
    [OutAttribute] Point% position
)
abstract FindBookMark :
        bookMark : int *
        position : Point byref -> bool
override FindBookMark :
        bookMark : int *
        position : Point byref -> bool

Parameters

bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to find.
position
Type: System.DrawingPoint
The out Point value to receive Line and Pos properties of the found bookmark.

Return Value

Type: Boolean
True if the bookmark is found; otherwise false.

Implements

IBookMarksFindBookMark(Int32, Point)
Remarks
If the search is not successful the Point parameter obtain empty value.
See Also

Reference

BookMarks Class
FindBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.FindBookMark Method (Int32, Int32)

BookMarksFindBookMark Method (Int32, Int32)
Locates the bookmark with specified index within the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IBookMark FindBookMark(
    int bookMark,
    int line
)
Public Overridable Function FindBookMark (
    bookMark As Integer,
    line As Integer
) As IBookMark
public:
virtual IBookMark^ FindBookMark(
    int bookMark,
    int line
)
abstract FindBookMark :
        bookMark : int *
        line : int -> IBookMark
override FindBookMark :
        bookMark : int *
        line : int -> IBookMark

Parameters

bookMark
Type: SystemInt32
The integer value that specifies Index of the bookmark to find.
line
Type: SystemInt32
The integer value that specifies index of the text line in where to locate bookmark.

Return Value

Type: IBookMark
IBookMark object found.

Implements

IBookMarksFindBookMark(Int32, Int32)
See Also

Reference

BookMarks Class
FindBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.FindBookMark Method (Int32, Int32, Int32)

BookMarksFindBookMark Method (Int32, Int32, Int32)
Locates the bookmark with specified index within the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IBookMark FindBookMark(
    int group,
    int bookMark,
    int line
)
Public Overridable Function FindBookMark (
    group As Integer,
    bookMark As Integer,
    line As Integer
) As IBookMark
public:
virtual IBookMark^ FindBookMark(
    int group,
    int bookMark,
    int line
)
abstract FindBookMark :
        group : int *
        bookMark : int *
        line : int -> IBookMark
override FindBookMark :
        group : int *
        bookMark : int *
        line : int -> IBookMark

Parameters

group
Type: SystemInt32
Specifies bookmark group.
bookMark
Type: SystemInt32
The integer value that specifies Index of the bookmark to find.
line
Type: SystemInt32
The integer value that specifies index of the text line in where to locate bookmark.

Return Value

Type: IBookMark
IBookMark object found.
See Also

Reference

BookMarks Class
FindBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMark Method

BookMarksGetBookMark Method
Overload List
 | Name | Description
Public method | GetBookMark(Int32) | Finds the first bookmark in the BookMarks collection located within the specified text line.
Public method | GetBookMark(Point, Point) | Finds the first bookmark in the BookMarks collection that locates within the specified range.
Public method | GetBookMark(Int32, Int32) | Finds the first item in the bookmark collection located within the specified text line and associated with specified group.
Public method | GetBookMark(Point, Point, Int32) | Finds the first item in the bookmark collection located within the specified scope and associated with specified group.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMark Method (Int32)

BookMarksGetBookMark Method (Int32)
Finds the first bookmark in the BookMarks collection located within the specified text line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetBookMark(
    int line
)
Public Overridable Function GetBookMark (
    line As Integer
) As Integer
public:
virtual int GetBookMark(
    int line
)
abstract GetBookMark :
        line : int -> int
override GetBookMark :
        line : int -> int

Parameters

line
Type: SystemInt32
The integer value that specifies index of the text line where to find bookmark.

Return Value

Type: Int32
Bookmark index if the bookmarks was found; otherwise -1.

Implements

IBookMarksGetBookMark(Int32)
See Also

Reference

BookMarks Class
GetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMark Method (Point, Point)

BookMarksGetBookMark Method (Point, Point)
Finds the first bookmark in the BookMarks collection that locates within the specified range.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetBookMark(
    Point startPoint,
    Point endPoint
)
Public Overridable Function GetBookMark (
    startPoint As Point,
    endPoint As Point
) As Integer
public:
virtual int GetBookMark(
    Point startPoint,
    Point endPoint
)
abstract GetBookMark :
        startPoint : Point *
        endPoint : Point -> int
override GetBookMark :
        startPoint : Point *
        endPoint : Point -> int

Parameters

startPoint
Type: System.DrawingPoint
The Point value that specifies start position to find.
endPoint
Type: System.DrawingPoint
The Point value that specifies end position to find.

Return Value

Type: Int32
Bookmark index if the bookmarks was found; otherwise -1.

Implements

IBookMarksGetBookMark(Point, Point)
Remarks
The X-coordinates of the startPoint and endPoint structures represents the position within the text line. The Y-coordinates represents the index of the text line.
See Also

Reference

BookMarks Class
GetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMark Method (Int32, Int32)

BookMarksGetBookMark Method (Int32, Int32)
Finds the first item in the bookmark collection located within the specified text line and associated with specified group.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetBookMark(
    int line,
    int group
)
Public Overridable Function GetBookMark (
    line As Integer,
    group As Integer
) As Integer
public:
virtual int GetBookMark(
    int line,
    int group
)
abstract GetBookMark :
        line : int *
        group : int -> int
override GetBookMark :
        line : int *
        group : int -> int

Parameters

line
Type: SystemInt32
Index of the text line.
group
Type: SystemInt32
BookMark Group.

Return Value

Type: Int32
Index of the found bookmark.
See Also

Reference

BookMarks Class
GetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMark Method (Point, Point, Int32)

BookMarksGetBookMark Method (Point, Point, Int32)
Finds the first item in the bookmark collection located within the specified scope and associated with specified group.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetBookMark(
    Point startPoint,
    Point endPoint,
    int group
)
Public Overridable Function GetBookMark (
    startPoint As Point,
    endPoint As Point,
    group As Integer
) As Integer
public:
virtual int GetBookMark(
    Point startPoint,
    Point endPoint,
    int group
)
abstract GetBookMark :
        startPoint : Point *
        endPoint : Point *
        group : int -> int
override GetBookMark :
        startPoint : Point *
        endPoint : Point *
        group : int -> int

Parameters

startPoint
Type: System.DrawingPoint
The Point value that specifies start position to search.
endPoint
Type: System.DrawingPoint
The Point value that specifies end position to search.
group
Type: SystemInt32
BookMark Group.

Return Value

Type: Int32
Index of the found bookmark.
See Also

Reference

BookMarks Class
GetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMarks Method

BookMarksGetBookMarks Method
Overload List
 | Name | Description
Public method | GetBookMarks(IListIBookMark) | Finds all items in the bookmark collection.
Public method | GetBookMarks(Int32, IListIBookMark) | Finds all items in the bookmark collection associated with specified group.
Public method | GetBookMarks(Point, Point, IListIBookMark) | Finds all bookmarks in the BookMarks collection located within the specified range.
Public method | GetBookMarks(Point, Point, Int32, IListIBookMark) | Finds all items in the bookmark collection located within the specified scope and associated with specified group.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMarks Method (IList(IBookMark))

BookMarksGetBookMarks Method (IListIBookMark)
Finds all items in the bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetBookMarks(
    IList<IBookMark> list
)
Public Overridable Function GetBookMarks (
    list As IList(Of IBookMark)
) As Integer
public:
virtual int GetBookMarks(
    IList<IBookMark^>^ list
)
abstract GetBookMarks :
        list : IList<IBookMark> -> int
override GetBookMarks :
        list : IList<IBookMark> -> int

Parameters

list
Type: System.Collections.GenericIListIBookMark
Represents the collection of the bookmarks located within the specified scope.

Return Value

Type: Int32
Index of the located bookmarks.

Implements

IBookMarksGetBookMarks(IListIBookMark)
See Also

Reference

BookMarks Class
GetBookMarks Overload
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMarks Method (Int32, IList(IBookMark))

BookMarksGetBookMarks Method (Int32, IListIBookMark)
Finds all items in the bookmark collection associated with specified group.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetBookMarks(
    int group,
    IList<IBookMark> list
)
Public Overridable Function GetBookMarks (
    group As Integer,
    list As IList(Of IBookMark)
) As Integer
public:
virtual int GetBookMarks(
    int group,
    IList<IBookMark^>^ list
)
abstract GetBookMarks :
        group : int *
        list : IList<IBookMark> -> int
override GetBookMarks :
        group : int *
        list : IList<IBookMark> -> int

Parameters

group
Type: SystemInt32
BookMark Group.
list
Type: System.Collections.GenericIListIBookMark
Represents the collection of the located bookmarks.

Return Value

Type: Int32
Count of the found bookmarks.
See Also

Reference

BookMarks Class
GetBookMarks Overload
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMarks Method (Point, Point, IList(IBookMark))

BookMarksGetBookMarks Method (Point, Point, IListIBookMark)
Finds all bookmarks in the BookMarks collection located within the specified range.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetBookMarks(
    Point startPoint,
    Point endPoint,
    IList<IBookMark> list
)
Public Overridable Function GetBookMarks (
    startPoint As Point,
    endPoint As Point,
    list As IList(Of IBookMark)
) As Integer
public:
virtual int GetBookMarks(
    Point startPoint,
    Point endPoint,
    IList<IBookMark^>^ list
)
abstract GetBookMarks :
        startPoint : Point *
        endPoint : Point *
        list : IList<IBookMark> -> int
override GetBookMarks :
        startPoint : Point *
        endPoint : Point *
        list : IList<IBookMark> -> int

Parameters

startPoint
Type: System.DrawingPoint
The Point value that specifies start position to find.
endPoint
Type: System.DrawingPoint
The Point value that specifies end position to find.
list
Type: System.Collections.GenericIListIBookMark
Represents the collection of the bookmarks located within the specified range.

Return Value

Type: Int32
The number of the bookmarks located within the specified range.

Implements

IBookMarksGetBookMarks(Point, Point, IListIBookMark)
Remarks
The X-coordinates of the startPoint and endPoint structures represents the position within the text line. The Y-coordinates represents the index of the text line.
See Also

Reference

BookMarks Class
GetBookMarks Overload
Alternet.Editor.TextSource Namespace


BookMarks.GetBookMarks Method (Point, Point, Int32, IList(IBookMark))

BookMarksGetBookMarks Method (Point, Point, Int32, IListIBookMark)
Finds all items in the bookmark collection located within the specified scope and associated with specified group.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetBookMarks(
    Point startPoint,
    Point endPoint,
    int group,
    IList<IBookMark> list
)
Public Overridable Function GetBookMarks (
    startPoint As Point,
    endPoint As Point,
    group As Integer,
    list As IList(Of IBookMark)
) As Integer
public:
virtual int GetBookMarks(
    Point startPoint,
    Point endPoint,
    int group,
    IList<IBookMark^>^ list
)
abstract GetBookMarks :
        startPoint : Point *
        endPoint : Point *
        group : int *
        list : IList<IBookMark> -> int
override GetBookMarks :
        startPoint : Point *
        endPoint : Point *
        group : int *
        list : IList<IBookMark> -> int

Parameters

startPoint
Type: System.DrawingPoint
The Point value that specifies start position to search.
endPoint
Type: System.DrawingPoint
The Point value that specifies end position to search.
group
Type: SystemInt32
BookMark Group.
list
Type: System.Collections.GenericIListIBookMark
Represents the collection of the bookmarks located within the specified scope.

Return Value

Type: Int32
Index of the found bookmark.
See Also

Reference

BookMarks Class
GetBookMarks Overload
Alternet.Editor.TextSource Namespace


BookMarks.GetImages Method

BookMarksGetImages Method
Returns image list by its group.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList GetImages(
    int group
)
Public Overridable Function GetImages (
    group As Integer
) As ImageList
public:
virtual ImageList^ GetImages(
    int group
)
abstract GetImages :
        group : int -> ImageList
override GetImages :
        group : int -> ImageList

Parameters

group
Type: SystemInt32
Given group.

Return Value

Type: ImageList
ImageList associated with group.

Implements

IBookMarksGetImages(Int32)
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.GetImagesScaled Method

BookMarksGetImagesScaled Method
Returns image list by its group, scaled for DPI.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList GetImagesScaled(
    int group
)
Public Overridable Function GetImagesScaled (
    group As Integer
) As ImageList
public:
virtual ImageList^ GetImagesScaled(
    int group
)
abstract GetImagesScaled :
        group : int -> ImageList
override GetImagesScaled :
        group : int -> ImageList

Parameters

group
Type: SystemInt32
Given group.

Return Value

Type: ImageList
ImageList associated with group.

Implements

IBookMarksGetImagesScaled(Int32)
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.GotoBookMark Method

BookMarksGotoBookMark Method
Moves caret to the location of the bookmark in the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GotoBookMark(
    int bookMark
)
Public Overridable Sub GotoBookMark (
    bookMark As Integer
)
public:
virtual void GotoBookMark(
    int bookMark
)
abstract GotoBookMark :
        bookMark : int -> unit
override GotoBookMark :
        bookMark : int -> unit

Parameters

bookMark
Type: SystemInt32
The integer value that specifies bookmark Index property of the bookmark to locate.

Implements

IBookMarksGotoBookMark(Int32)
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.GotoNextBookMark Method

BookMarksGotoNextBookMark Method
Overload List
 | Name | Description
Public method | GotoNextBookMark | Moves to the location of the next unnumbered bookmark in the text source.
Public method | GotoNextBookMark(Int32) | Moves to the location of the next unnumbered bookmark in the text source.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.GotoNextBookMark Method

BookMarksGotoNextBookMark Method
Moves to the location of the next unnumbered bookmark in the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GotoNextBookMark()
Public Overridable Sub GotoNextBookMark
public:
virtual void GotoNextBookMark()
abstract GotoNextBookMark : unit -> unit
override GotoNextBookMark : unit -> unit

Implements

IBookMarksGotoNextBookMark
Remarks
If the currently selected bookmark is the last bookmark within the bookmarks collection the method moves to the first bookmark.
See Also

Reference

BookMarks Class
GotoNextBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.GotoNextBookMark Method (Int32)

BookMarksGotoNextBookMark Method (Int32)
Moves to the location of the next unnumbered bookmark in the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GotoNextBookMark(
    int group
)
Public Overridable Sub GotoNextBookMark (
    group As Integer
)
public:
virtual void GotoNextBookMark(
    int group
)
abstract GotoNextBookMark :
        group : int -> unit
override GotoNextBookMark :
        group : int -> unit

Parameters

group
Type: SystemInt32
Specifies group index of bookmark groups.
Remarks
If the currently selected bookmark is the last bookmark within the bookmarks collection the method moves to the first bookmark.
See Also

Reference

BookMarks Class
GotoNextBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.GotoPrevBookMark Method

BookMarksGotoPrevBookMark Method
Overload List
 | Name | Description
Public method | GotoPrevBookMark | Moves caret to the location of the previous unnumbered bookmark in the text source.
Public method | GotoPrevBookMark(Int32) | Moves caret to the location of the previous unnumbered bookmark in the text source.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.GotoPrevBookMark Method

BookMarksGotoPrevBookMark Method
Moves caret to the location of the previous unnumbered bookmark in the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GotoPrevBookMark()
Public Overridable Sub GotoPrevBookMark
public:
virtual void GotoPrevBookMark()
abstract GotoPrevBookMark : unit -> unit
override GotoPrevBookMark : unit -> unit

Implements

IBookMarksGotoPrevBookMark
Remarks
If the currently selected bookmark is the first bookmark within the bookmarks collection the method moves to the last bookmark.
See Also

Reference

BookMarks Class
GotoPrevBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.GotoPrevBookMark Method (Int32)

BookMarksGotoPrevBookMark Method (Int32)
Moves caret to the location of the previous unnumbered bookmark in the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GotoPrevBookMark(
    int group
)
Public Overridable Sub GotoPrevBookMark (
    group As Integer
)
public:
virtual void GotoPrevBookMark(
    int group
)
abstract GotoPrevBookMark :
        group : int -> unit
override GotoPrevBookMark :
        group : int -> unit

Parameters

group
Type: SystemInt32
Specifies group index of bookmark groups.
Remarks
If the currently selected bookmark is the first bookmark within the bookmarks collection the method moves to the last bookmark.
See Also

Reference

BookMarks Class
GotoPrevBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.NextBookMark Method

BookMarksNextBookMark Method
Overload List
 | Name | Description
Public method | NextBookMark | Returns the minimal possible value of the bookmark Index property of the new bookmark.
Public method | NextBookMark(Int32) | Returns the minimal possible value of the bookmark Index property of the new bookmark.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.NextBookMark Method

BookMarksNextBookMark Method
Returns the minimal possible value of the bookmark Index property of the new bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int NextBookMark()
Public Overridable Function NextBookMark As Integer
public:
virtual int NextBookMark()
abstract NextBookMark : unit -> int
override NextBookMark : unit -> int

Return Value

Type: Int32
Bookmark index.

Implements

IBookMarksNextBookMark
Remarks
If the bookmarks collection is empty method returns 0.
See Also

Reference

BookMarks Class
NextBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.NextBookMark Method (Int32)

BookMarksNextBookMark Method (Int32)
Returns the minimal possible value of the bookmark Index property of the new bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int NextBookMark(
    int group
)
Public Overridable Function NextBookMark (
    group As Integer
) As Integer
public:
virtual int NextBookMark(
    int group
)
abstract NextBookMark :
        group : int -> int
override NextBookMark :
        group : int -> int

Parameters

group
Type: SystemInt32
Specifies index of the bookmark groups.

Return Value

Type: Int32
Bookmark index.
Remarks
If the bookmarks collection is empty method returns 0.
See Also

Reference

BookMarks Class
NextBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.OnClick Method

BookMarksOnClick Method
Raises OnClick event.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnClick(
    IBookMark bookMark
)
Public Overridable Sub OnClick (
    bookMark As IBookMark
)
public:
virtual void OnClick(
    IBookMark^ bookMark
)
abstract OnClick :
        bookMark : IBookMark -> unit
override OnClick :
        bookMark : IBookMark -> unit

Parameters

bookMark
Type: Alternet.Editor.TextSourceIBookMark
Bookmark being clicked.

Implements

IBookMarksOnClick(IBookMark)
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.OnDoubleClick Method

BookMarksOnDoubleClick Method
Raises OnDoubleClick event.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnDoubleClick(
    IBookMark bookMark
)
Public Overridable Sub OnDoubleClick (
    bookMark As IBookMark
)
public:
virtual void OnDoubleClick(
    IBookMark^ bookMark
)
abstract OnDoubleClick :
        bookMark : IBookMark -> unit
override OnDoubleClick :
        bookMark : IBookMark -> unit

Parameters

bookMark
Type: Alternet.Editor.TextSourceIBookMark
Bookmark being clicked.

Implements

IBookMarksOnDoubleClick(IBookMark)
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.OnShowTooltip Method

BookMarksOnShowTooltip Method
Raises OnShowTooltip event.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool OnShowTooltip(
    ref string tooltip,
    IBookMark bookMark
)
Public Overridable Function OnShowTooltip (
    ByRef tooltip As String,
    bookMark As IBookMark
) As Boolean
public:
virtual bool OnShowTooltip(
    String^% tooltip,
    IBookMark^ bookMark
)
abstract OnShowTooltip :
        tooltip : string byref *
        bookMark : IBookMark -> bool
override OnShowTooltip :
        tooltip : string byref *
        bookMark : IBookMark -> bool

Parameters

tooltip
Type: SystemString
Tooltip to be displayed.
bookMark
Type: Alternet.Editor.TextSourceIBookMark
Bookmark under the mouse cursor.

Return Value

Type: Boolean
True if event is handled, otherwise false.

Implements

IBookMarksOnShowTooltip(String, IBookMark)
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.PositionChanged Method

BookMarksPositionChanged Method
Updates all bookmarks starting from specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBookMarksPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method

BookMarksSetBookMark Method
Overload List
 | Name | Description
Public method | SetBookMark(IBookMark) | Sets the bookmark specified by bookMark parameter.
Public method | SetBookMark(Point, Int32) | Sets the bookmark with specified index to the position specified by Point parameter.
Public method | SetBookMark(Int32, Int32) | Sets the bookmark with specified index to the position specified by line parameter.
Public method | SetBookMark(Point, Int32, Int32, Int32) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Int32, Int32, Int32, Int32) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Point, Int32, String, String, String) | Sets the bookmark with specified index, name, description and url to the position specified by Point parameter.
Public method | SetBookMark(Point, Int32, Int32, Int32, String, String, String) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Point, Int32, Int32, Int32, String, String, String, Object) | Sets the bookmark with specified parameters.
Public method | SetBookMark(Point, Int32, String, String, String, Int32, String, Object, Boolean) | Sets the bookmark with specified index, name, description and url to the position specified by Point parameter.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method (IBookMark)

BookMarksSetBookMark Method (IBookMark)
Sets the bookmark specified by bookMark parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBookMark(
    IBookMark bookMark
)
Public Overridable Sub SetBookMark (
    bookMark As IBookMark
)
public:
virtual void SetBookMark(
    IBookMark^ bookMark
)
abstract SetBookMark :
        bookMark : IBookMark -> unit
override SetBookMark :
        bookMark : IBookMark -> unit

Parameters

bookMark
Type: Alternet.Editor.TextSourceIBookMark
Specifies bookmark to set.

Implements

IBookMarksSetBookMark(IBookMark)
See Also

Reference

BookMarks Class
SetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method (Point, Int32)

BookMarksSetBookMark Method (Point, Int32)
Sets the bookmark with specified index to the position specified by Point parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBookMark(
    Point position,
    int bookMark
)
Public Overridable Sub SetBookMark (
    position As Point,
    bookMark As Integer
)
public:
virtual void SetBookMark(
    Point position,
    int bookMark
)
abstract SetBookMark :
        position : Point *
        bookMark : int -> unit
override SetBookMark :
        position : Point *
        bookMark : int -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the BookMark.
bookMark
Type: SystemInt32
The integer value that specifies BookMark index.

Implements

IBookMarksSetBookMark(Point, Int32)
Remarks
If the Bookmark with the same index already exists in the collection, the method removes it before inserting new BookMark to the BookMarks collection.
See Also

Reference

BookMarks Class
SetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method (Int32, Int32)

BookMarksSetBookMark Method (Int32, Int32)
Sets the bookmark with specified index to the position specified by line parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBookMark(
    int line,
    int bookMark
)
Public Overridable Sub SetBookMark (
    line As Integer,
    bookMark As Integer
)
public:
virtual void SetBookMark(
    int line,
    int bookMark
)
abstract SetBookMark :
        line : int *
        bookMark : int -> unit
override SetBookMark :
        line : int *
        bookMark : int -> unit

Parameters

line
Type: SystemInt32
The integer value that specifies index of the text line where to set bookmark.
bookMark
Type: SystemInt32
The integer value that specifies BookMark index.

Implements

IBookMarksSetBookMark(Int32, Int32)
Remarks
If the Bookmark with the same index already exists in the collection, the method removes it before inserting new BookMark to the BookMarks collection.
See Also

Reference

BookMarks Class
SetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method (Point, Int32, Int32, Int32)

BookMarksSetBookMark Method (Point, Int32, Int32, Int32)
Sets the bookmark with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex
)
Public Overridable Sub SetBookMark (
    position As Point,
    group As Integer,
    bookMark As Integer,
    imageIndex As Integer
)
public:
virtual void SetBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex
)
abstract SetBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int -> unit
override SetBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the BookMark.
group
Type: SystemInt32
The integer value that specifies group associated with this BookMark.
bookMark
Type: SystemInt32
The integer value that specifies BookMark index.
imageIndex
Type: SystemInt32
The integer value that specifies BookMark imageIndex.
See Also

Reference

BookMarks Class
SetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method (Int32, Int32, Int32, Int32)

BookMarksSetBookMark Method (Int32, Int32, Int32, Int32)
Sets the bookmark with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBookMark(
    int line,
    int group,
    int bookMark,
    int imageIndex
)
Public Overridable Sub SetBookMark (
    line As Integer,
    group As Integer,
    bookMark As Integer,
    imageIndex As Integer
)
public:
virtual void SetBookMark(
    int line,
    int group,
    int bookMark,
    int imageIndex
)
abstract SetBookMark :
        line : int *
        group : int *
        bookMark : int *
        imageIndex : int -> unit
override SetBookMark :
        line : int *
        group : int *
        bookMark : int *
        imageIndex : int -> unit

Parameters

line
Type: SystemInt32
The integer value that specifies index of the text line.
group
Type: SystemInt32
The integer value that specifies group associated with this BookMark.
bookMark
Type: SystemInt32
The integer value that specifies BookMark index.
imageIndex
Type: SystemInt32
The integer value that specifies BookMark imageIndex.
See Also

Reference

BookMarks Class
SetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method (Point, Int32, String, String, String)

BookMarksSetBookMark Method (Point, Int32, String, String, String)
Sets the bookmark with specified index, name, description and url to the position specified by Point parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBookMark(
    Point position,
    int bookMark,
    string name,
    string description,
    string url
)
Public Overridable Sub SetBookMark (
    position As Point,
    bookMark As Integer,
    name As String,
    description As String,
    url As String
)
public:
virtual void SetBookMark(
    Point position,
    int bookMark,
    String^ name,
    String^ description,
    String^ url
)
abstract SetBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string -> unit
override SetBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the BookMark.
bookMark
Type: SystemInt32
The integer value that specifies BookMark index.
name
Type: SystemString
The string value that specifies BookMark name.
description
Type: SystemString
The string value that specifies BookMark description.
url
Type: SystemString
The string value that specifies BookMark url.

Implements

IBookMarksSetBookMark(Point, Int32, String, String, String)
Remarks
If the Bookmark with the same index already exists in the collection, the method removes it before inserting new BookMark to the BookMarks collection.
See Also

Reference

BookMarks Class
SetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method (Point, Int32, Int32, Int32, String, String, String)

BookMarksSetBookMark Method (Point, Int32, Int32, Int32, String, String, String)
Sets the bookmark with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex,
    string name,
    string description,
    string url
)
Public Overridable Sub SetBookMark (
    position As Point,
    group As Integer,
    bookMark As Integer,
    imageIndex As Integer,
    name As String,
    description As String,
    url As String
)
public:
virtual void SetBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex,
    String^ name,
    String^ description,
    String^ url
)
abstract SetBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int *
        name : string *
        description : string *
        url : string -> unit
override SetBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int *
        name : string *
        description : string *
        url : string -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the BookMark.
group
Type: SystemInt32
The integer value that specifies group associated with this BookMark.
bookMark
Type: SystemInt32
The integer value that specifies BookMark index.
imageIndex
Type: SystemInt32
The integer value that specifies BookMark imageIndex.
name
Type: SystemString
The string value that specifies BookMark name.
description
Type: SystemString
The string value that specifies BookMark description.
url
Type: SystemString
The string value that specifies BookMark url.
See Also

Reference

BookMarks Class
SetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method (Point, Int32, Int32, Int32, String, String, String, Object)

BookMarksSetBookMark Method (Point, Int32, Int32, Int32, String, String, String, Object)
Sets the bookmark with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex,
    string name,
    string description,
    string url,
    Object tag
)
Public Overridable Sub SetBookMark (
    position As Point,
    group As Integer,
    bookMark As Integer,
    imageIndex As Integer,
    name As String,
    description As String,
    url As String,
    tag As Object
)
public:
virtual void SetBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex,
    String^ name,
    String^ description,
    String^ url,
    Object^ tag
)
abstract SetBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int *
        name : string *
        description : string *
        url : string *
        tag : Object -> unit
override SetBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int *
        name : string *
        description : string *
        url : string *
        tag : Object -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the BookMark.
group
Type: SystemInt32
The integer value that specifies group associated with this BookMark.
bookMark
Type: SystemInt32
The integer value that specifies BookMark index.
imageIndex
Type: SystemInt32
The integer value that specifies BookMark imageIndex.
name
Type: SystemString
The string value that specifies BookMark name.
description
Type: SystemString
The string value that specifies BookMark description.
url
Type: SystemString
The string value that specifies url of the bookmark to toggle.
tag
Type: SystemObject
The Tag property of BookMark.
See Also

Reference

BookMarks Class
SetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.SetBookMark Method (Point, Int32, String, String, String, Int32, String, Object, Boolean)

BookMarksSetBookMark Method (Point, Int32, String, String, String, Int32, String, Object, Boolean)
Sets the bookmark with specified index, name, description and url to the position specified by Point parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBookMark(
    Point position,
    int bookMark,
    string name,
    string description,
    string url,
    int imageIndex,
    string fileName,
    Object tag,
    bool clear
)
Public Overridable Sub SetBookMark (
    position As Point,
    bookMark As Integer,
    name As String,
    description As String,
    url As String,
    imageIndex As Integer,
    fileName As String,
    tag As Object,
    clear As Boolean
)
public:
virtual void SetBookMark(
    Point position,
    int bookMark,
    String^ name,
    String^ description,
    String^ url,
    int imageIndex,
    String^ fileName,
    Object^ tag,
    bool clear
)
abstract SetBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string *
        imageIndex : int *
        fileName : string *
        tag : Object *
        clear : bool -> unit
override SetBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string *
        imageIndex : int *
        fileName : string *
        tag : Object *
        clear : bool -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the BookMark.
bookMark
Type: SystemInt32
The integer value that specifies BookMark index.
name
Type: SystemString
The string value that specifies BookMark name.
description
Type: SystemString
The string value that specifies BookMark description.
url
Type: SystemString
The string value that specifies BookMark url.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of a new instance.
fileName
Type: SystemString
Specifies FileName property of a new instance.
tag
Type: SystemObject
Specifies Tag property of a new instance.
clear
Type: SystemBoolean
Specifies whether previously found bookmark should be removed.
Remarks
If the Bookmark with the same index already exists in the collection, the method removes it before inserting new BookMark to the BookMarks collection.
See Also

Reference

BookMarks Class
SetBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.SetForcedMarker Method

BookMarksSetForcedMarker Method

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetForcedMarker(
    Point position,
    int bookMark,
    string name,
    string description,
    string url,
    int imageIndex,
    string fileName,
    Object tag
)
Public Overridable Sub SetForcedMarker (
    position As Point,
    bookMark As Integer,
    name As String,
    description As String,
    url As String,
    imageIndex As Integer,
    fileName As String,
    tag As Object
)
public:
virtual void SetForcedMarker(
    Point position,
    int bookMark,
    String^ name,
    String^ description,
    String^ url,
    int imageIndex,
    String^ fileName,
    Object^ tag
)
abstract SetForcedMarker :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string *
        imageIndex : int *
        fileName : string *
        tag : Object -> unit
override SetForcedMarker :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string *
        imageIndex : int *
        fileName : string *
        tag : Object -> unit

Parameters

position
Type: System.DrawingPoint
bookMark
Type: SystemInt32
name
Type: SystemString
description
Type: SystemString
url
Type: SystemString
imageIndex
Type: SystemInt32
fileName
Type: SystemString
tag
Type: SystemObject
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method

BookMarksToggleBookMark Method
Overload List
 | Name | Description
Public method | ToggleBookMark | Sets or removes an unnumbered bookmark on the current line.
Public method | ToggleBookMark(Int32) | Sets or removes bookmark with specified index at the current line.
Public method | ToggleBookMark(IBookMark) | Sets or removes bookmark specified by bookMark parameter.
Public method | ToggleBookMark(Point, Int32) | Sets or removes bookmark with specified index at the specified line.
Public method | ToggleBookMark(Int32, Int32) | Sets or removes bookmark with specified index at the specified line.
Public method | ToggleBookMark(Int32, Int32, Int32) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, Int32, Int32) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Int32, Int32, Int32, Int32) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, String, String, String) | Sets or removes bookmark with specified index at the specified line.
Public method | ToggleBookMark(Point, Int32, Int32, Int32, String, String, String) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, Int32, Int32, String, String, String, Object) | Sets or removes bookmark with specified parameters.
Public method | ToggleBookMark(Point, Int32, String, String, String, Int32, String, Object) | Sets or removes bookmark with specified index at the specified line.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method

BookMarksToggleBookMark Method
Sets or removes an unnumbered bookmark on the current line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark()
Public Overridable Sub ToggleBookMark
public:
virtual void ToggleBookMark()
abstract ToggleBookMark : unit -> unit
override ToggleBookMark : unit -> unit

Implements

IBookMarksToggleBookMark
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Int32)

BookMarksToggleBookMark Method (Int32)
Sets or removes bookmark with specified index at the current line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    int bookMark
)
Public Overridable Sub ToggleBookMark (
    bookMark As Integer
)
public:
virtual void ToggleBookMark(
    int bookMark
)
abstract ToggleBookMark :
        bookMark : int -> unit
override ToggleBookMark :
        bookMark : int -> unit

Parameters

bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to toggle.

Implements

IBookMarksToggleBookMark(Int32)
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (IBookMark)

BookMarksToggleBookMark Method (IBookMark)
Sets or removes bookmark specified by bookMark parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    IBookMark bookMark
)
Public Overridable Sub ToggleBookMark (
    bookMark As IBookMark
)
public:
virtual void ToggleBookMark(
    IBookMark^ bookMark
)
abstract ToggleBookMark :
        bookMark : IBookMark -> unit
override ToggleBookMark :
        bookMark : IBookMark -> unit

Parameters

bookMark
Type: Alternet.Editor.TextSourceIBookMark
Specifies bookmark to toggle.

Implements

IBookMarksToggleBookMark(IBookMark)
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Point, Int32)

BookMarksToggleBookMark Method (Point, Int32)
Sets or removes bookmark with specified index at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    Point position,
    int bookMark
)
Public Overridable Sub ToggleBookMark (
    position As Point,
    bookMark As Integer
)
public:
virtual void ToggleBookMark(
    Point position,
    int bookMark
)
abstract ToggleBookMark :
        position : Point *
        bookMark : int -> unit
override ToggleBookMark :
        position : Point *
        bookMark : int -> unit

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position of the bookmark (index of char and current line).
bookMark
Type: SystemInt32
The integer value specifying index of the bookmark to toggle.

Implements

IBookMarksToggleBookMark(Point, Int32)
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Int32, Int32)

BookMarksToggleBookMark Method (Int32, Int32)
Sets or removes bookmark with specified index at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    int line,
    int bookMark
)
Public Overridable Sub ToggleBookMark (
    line As Integer,
    bookMark As Integer
)
public:
virtual void ToggleBookMark(
    int line,
    int bookMark
)
abstract ToggleBookMark :
        line : int *
        bookMark : int -> unit
override ToggleBookMark :
        line : int *
        bookMark : int -> unit

Parameters

line
Type: SystemInt32
Index of line where to toggle bookmark.
bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to toggle.

Implements

IBookMarksToggleBookMark(Int32, Int32)
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Int32, Int32, Int32)

BookMarksToggleBookMark Method (Int32, Int32, Int32)
Sets or removes bookmark with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    int group,
    int bookMark,
    int imageIndex
)
Public Overridable Sub ToggleBookMark (
    group As Integer,
    bookMark As Integer,
    imageIndex As Integer
)
public:
virtual void ToggleBookMark(
    int group,
    int bookMark,
    int imageIndex
)
abstract ToggleBookMark :
        group : int *
        bookMark : int *
        imageIndex : int -> unit
override ToggleBookMark :
        group : int *
        bookMark : int *
        imageIndex : int -> unit

Parameters

group
Type: SystemInt32
The integer value that specifies group associated with BookMark to toggle.
bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to toggle.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of the bookmark to toggle.
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Point, Int32, Int32, Int32)

BookMarksToggleBookMark Method (Point, Int32, Int32, Int32)
Sets or removes bookmark with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex
)
Public Overridable Sub ToggleBookMark (
    position As Point,
    group As Integer,
    bookMark As Integer,
    imageIndex As Integer
)
public:
virtual void ToggleBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex
)
abstract ToggleBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int -> unit
override ToggleBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int -> unit

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position of the bookmark (index of char and current line).
group
Type: SystemInt32
The integer value that specifies group associated with BookMark to toggle.
bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to toggle.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of the bookmark to toggle.
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Int32, Int32, Int32, Int32)

BookMarksToggleBookMark Method (Int32, Int32, Int32, Int32)
Sets or removes bookmark with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    int line,
    int group,
    int bookMark,
    int imageIndex
)
Public Overridable Sub ToggleBookMark (
    line As Integer,
    group As Integer,
    bookMark As Integer,
    imageIndex As Integer
)
public:
virtual void ToggleBookMark(
    int line,
    int group,
    int bookMark,
    int imageIndex
)
abstract ToggleBookMark :
        line : int *
        group : int *
        bookMark : int *
        imageIndex : int -> unit
override ToggleBookMark :
        line : int *
        group : int *
        bookMark : int *
        imageIndex : int -> unit

Parameters

line
Type: SystemInt32
Specifies line of the bookmark to toggle.
group
Type: SystemInt32
The integer value that specifies group associated with BookMark to toggle.
bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to toggle.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of the bookmark to toggle.
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Point, Int32, String, String, String)

BookMarksToggleBookMark Method (Point, Int32, String, String, String)
Sets or removes bookmark with specified index at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    Point position,
    int bookMark,
    string name,
    string description,
    string url
)
Public Overridable Sub ToggleBookMark (
    position As Point,
    bookMark As Integer,
    name As String,
    description As String,
    url As String
)
public:
virtual void ToggleBookMark(
    Point position,
    int bookMark,
    String^ name,
    String^ description,
    String^ url
)
abstract ToggleBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string -> unit
override ToggleBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string -> unit

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position of the bookmark (index of char and current line).
bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to toggle.
name
Type: SystemString
The string value that specifies name of the bookmark to toggle.
description
Type: SystemString
The string value that specifies description of the bookmark to toggle.
url
Type: SystemString
The string value that specifies url of the bookmark to toggle.

Implements

IBookMarksToggleBookMark(Point, Int32, String, String, String)
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Point, Int32, Int32, Int32, String, String, String)

BookMarksToggleBookMark Method (Point, Int32, Int32, Int32, String, String, String)
Sets or removes bookmark with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex,
    string name,
    string description,
    string url
)
Public Overridable Sub ToggleBookMark (
    position As Point,
    group As Integer,
    bookMark As Integer,
    imageIndex As Integer,
    name As String,
    description As String,
    url As String
)
public:
virtual void ToggleBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex,
    String^ name,
    String^ description,
    String^ url
)
abstract ToggleBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int *
        name : string *
        description : string *
        url : string -> unit
override ToggleBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int *
        name : string *
        description : string *
        url : string -> unit

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position of the bookmark (index of char and current line).
group
Type: SystemInt32
The integer value that specifies group associated with BookMark to toggle.
bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to toggle.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of the bookmark to toggle.
name
Type: SystemString
The string value that specifies name of the bookmark to toggle.
description
Type: SystemString
The string value that specifies description of the bookmark to toggle.
url
Type: SystemString
The string value that specifies url of the bookmark to toggle.
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Point, Int32, Int32, Int32, String, String, String, Object)

BookMarksToggleBookMark Method (Point, Int32, Int32, Int32, String, String, String, Object)
Sets or removes bookmark with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex,
    string name,
    string description,
    string url,
    Object tag
)
Public Overridable Sub ToggleBookMark (
    position As Point,
    group As Integer,
    bookMark As Integer,
    imageIndex As Integer,
    name As String,
    description As String,
    url As String,
    tag As Object
)
public:
virtual void ToggleBookMark(
    Point position,
    int group,
    int bookMark,
    int imageIndex,
    String^ name,
    String^ description,
    String^ url,
    Object^ tag
)
abstract ToggleBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int *
        name : string *
        description : string *
        url : string *
        tag : Object -> unit
override ToggleBookMark :
        position : Point *
        group : int *
        bookMark : int *
        imageIndex : int *
        name : string *
        description : string *
        url : string *
        tag : Object -> unit

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position of the bookmark (index of char and current line).
group
Type: SystemInt32
The integer value that specifies group associated with BookMark to toggle.
bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to toggle.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of the bookmark to toggle.
name
Type: SystemString
The string value that specifies name of the bookmark to toggle.
description
Type: SystemString
The string value that specifies description of the bookmark to toggle.
url
Type: SystemString
The string value that specifies url of the bookmark to toggle.
tag
Type: SystemObject
Specifies Tag property of the bookmark to toggle.
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks.ToggleBookMark Method (Point, Int32, String, String, String, Int32, String, Object)

BookMarksToggleBookMark Method (Point, Int32, String, String, String, Int32, String, Object)
Sets or removes bookmark with specified index at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleBookMark(
    Point position,
    int bookMark,
    string name,
    string description,
    string url,
    int imageIndex,
    string fileName,
    Object tag
)
Public Overridable Sub ToggleBookMark (
    position As Point,
    bookMark As Integer,
    name As String,
    description As String,
    url As String,
    imageIndex As Integer,
    fileName As String,
    tag As Object
)
public:
virtual void ToggleBookMark(
    Point position,
    int bookMark,
    String^ name,
    String^ description,
    String^ url,
    int imageIndex,
    String^ fileName,
    Object^ tag
)
abstract ToggleBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string *
        imageIndex : int *
        fileName : string *
        tag : Object -> unit
override ToggleBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string *
        imageIndex : int *
        fileName : string *
        tag : Object -> unit

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position of the bookmark (index of char and current line).
bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark to toggle.
name
Type: SystemString
The string value that specifies name of the bookmark to toggle.
description
Type: SystemString
The string value that specifies description of the bookmark to toggle.
url
Type: SystemString
The string value that specifies url of the bookmark to toggle.
imageIndex
Type: SystemInt32
Specifies ImageIndex property of the bookmark to toggle.
fileName
Type: SystemString
Specifies FileName property of the bookmark to toggle.
tag
Type: SystemObject
Specifies Tag property of the bookmark to toggle.
See Also

Reference

BookMarks Class
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


BookMarks Properties

BookMarks Properties

The BookMarks type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIBookMark .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIBookMark .)
Public property | Shared | Specifies if bookmarks should be shared across all documents.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.Shared Property

BookMarksShared Property
Specifies if bookmarks should be shared across all documents.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Shared { get; set; }
Public Property Shared As Boolean
    Get
    Set
public:
virtual property bool Shared {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Shared : bool with get, set
override Shared : bool with get, set

Property Value

Type: Boolean

Implements

IBookMarksShared
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks Events

BookMarks Events

The BookMarks type exposes the following members.

Events
 | Name | Description
Public event | Click | Occurs when Bookmark is being clicked.
Public event | DoubleClick | When implemented by a class, occurs when Bookmark is being double clicked.
Public event | ShowToolTip | Occurs when Bookmark Tooltip needs to be displayed.
Top
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.Click Event

BookMarksClick Event
Occurs when Bookmark is being clicked.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual event BookmarkClickEvent Click
Public Overridable Event Click As BookmarkClickEvent
public:
virtual  event BookmarkClickEvent^ Click {
    void add (BookmarkClickEvent^ value);
    void remove (BookmarkClickEvent^ value);
}
abstract Click : IEvent<BookmarkClickEvent,
    BookmarkClickEventArgs>
override Click : IEvent<BookmarkClickEvent,
    BookmarkClickEventArgs>

Value

Type: BookmarkClickEvent

Implements

IBookMarksClick
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.DoubleClick Event

BookMarksDoubleClick Event
When implemented by a class, occurs when Bookmark is being double clicked.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual event BookmarkClickEvent DoubleClick
Public Overridable Event DoubleClick As BookmarkClickEvent
public:
virtual  event BookmarkClickEvent^ DoubleClick {
    void add (BookmarkClickEvent^ value);
    void remove (BookmarkClickEvent^ value);
}
abstract DoubleClick : IEvent<BookmarkClickEvent,
    BookmarkClickEventArgs>
override DoubleClick : IEvent<BookmarkClickEvent,
    BookmarkClickEventArgs>

Value

Type: BookmarkClickEvent

Implements

IBookMarksDoubleClick
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


BookMarks.ShowToolTip Event

BookMarksShowToolTip Event
Occurs when Bookmark Tooltip needs to be displayed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual event TooltipEvent ShowToolTip
Public Overridable Event ShowToolTip As TooltipEvent
public:
virtual  event TooltipEvent^ ShowToolTip {
    void add (TooltipEvent^ value);
    void remove (TooltipEvent^ value);
}
abstract ShowToolTip : IEvent<TooltipEvent,
    ToolTipEventArgs>
override ShowToolTip : IEvent<TooltipEvent,
    ToolTipEventArgs>

Value

Type: TooltipEvent

Implements

IBookMarksShowToolTip
See Also

Reference

BookMarks Class
Alternet.Editor.TextSource Namespace


Braces Class

Braces Class
Represents properties and methods for handling matching braces within the Edit control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TextSourceBraces

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Braces : IEditBraceMatching, IBraceMatching
Public Class Braces
    Implements IEditBraceMatching, IBraceMatching
public ref class Braces : IEditBraceMatching, IBraceMatching
type Braces =
    class
        interface IEditBraceMatching
        interface IBraceMatching
    end

The Braces type exposes the following members.

Constructors
 | Name | Description
Public method | Braces | Initializes a new instance of the Braces class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another Braces object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindClosingBrace(Point) | Locates matching closing brace.
Public method | FindClosingBrace(Int32, Int32) | Locates matching closing brace.
Public method | FindOpenBrace(Point) | Locates matching open brace.
Public method | FindOpenBrace(Int32, Int32) | Locates matching open brace.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightBraces | Highlights braces containing caret position.
Public method | ResetBackColor | Resets the BackColor to its default value.
Public method | ResetBracesOptions | Resets the BracesOptions to its default value.
Public method | ResetClosingBraces | Resets the ClosingBraces to its default value.
Public method | ResetFontStyle | Resets the Style to its default value.
Public method | ResetForeColor | Resets the ForeColor to its default value.
Public method | ResetOpenBraces | Resets the OpenBraces to its default value.
Public method | ResetUseRoundRect | Resets the UseRoundRect to its default value.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor should be persisted.
Public method | ShouldSerializeClosingBraces | Indicates whether the ClosingBraces property should be persisted.
Public method | ShouldSerializeFontStyle | Indicates whether the FontStyle property should be persisted.
Public method | ShouldSerializeForeColor | Indicates whether the ForeColor should be persisted.
Public method | ShouldSerializeOpenBraces | Indicates whether the OpenBraces should be persisted.
Public method | TempHighlightBraces | Temporary highlights all text within the area specified by rects.
Public method | TempUnhighlightBraces | Cancels text highlighting, turned on by TempHighlightBraces method.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhighlightBraces | Unhighlights braces containing caret position.
Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets a value that represents background color to draw matching braces.
Public property | BracesOptions | Gets or sets options specifying appearance and behaviour of matching braces within Edit control.
Public property | ClosingBraces | Gets or sets an array of characters each one representing a closing brace.
Public property | FontStyle | Gets or sets a FontStyle value that is used to draw matching braces.
Public property | ForeColor | Gets or sets a value that represents foreground color to draw matching braces.
Public property | OpenBraces | Gets or sets an array of characters each one representing an open brace.
Public property | UseRoundRect | Gets or sets a boolean value that indicates whether Edit control should draw rectangle around matching braces.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


Braces Constructor

Braces Constructor
Initializes a new instance of the Braces class with specified owner.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Braces(
    ISyntaxEdit owner
)
Public Sub New (
    owner As ISyntaxEdit
)
public:
Braces(
    ISyntaxEdit^ owner
)
new :
        owner : ISyntaxEdit -> Braces

Parameters

owner
Type: Alternet.EditorISyntaxEdit
Specifies the class implementing ISyntaxEdit that owns a new instance.
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces Methods

Braces Methods

The Braces type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another Braces object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindClosingBrace(Point) | Locates matching closing brace.
Public method | FindClosingBrace(Int32, Int32) | Locates matching closing brace.
Public method | FindOpenBrace(Point) | Locates matching open brace.
Public method | FindOpenBrace(Int32, Int32) | Locates matching open brace.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightBraces | Highlights braces containing caret position.
Public method | ResetBackColor | Resets the BackColor to its default value.
Public method | ResetBracesOptions | Resets the BracesOptions to its default value.
Public method | ResetClosingBraces | Resets the ClosingBraces to its default value.
Public method | ResetFontStyle | Resets the Style to its default value.
Public method | ResetForeColor | Resets the ForeColor to its default value.
Public method | ResetOpenBraces | Resets the OpenBraces to its default value.
Public method | ResetUseRoundRect | Resets the UseRoundRect to its default value.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor should be persisted.
Public method | ShouldSerializeClosingBraces | Indicates whether the ClosingBraces property should be persisted.
Public method | ShouldSerializeFontStyle | Indicates whether the FontStyle property should be persisted.
Public method | ShouldSerializeForeColor | Indicates whether the ForeColor should be persisted.
Public method | ShouldSerializeOpenBraces | Indicates whether the OpenBraces should be persisted.
Public method | TempHighlightBraces | Temporary highlights all text within the area specified by rects.
Public method | TempUnhighlightBraces | Cancels text highlighting, turned on by TempHighlightBraces method.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhighlightBraces | Unhighlights braces containing caret position.
Top
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.Assign Method

BracesAssign Method
Copies the contents of another Braces object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    IEditBraceMatching source
)
Public Overridable Sub Assign (
    source As IEditBraceMatching
)
public:
virtual void Assign(
    IEditBraceMatching^ source
)
abstract Assign :
        source : IEditBraceMatching -> unit
override Assign :
        source : IEditBraceMatching -> unit

Parameters

source
Type: Alternet.EditorIEditBraceMatching
Specifies IEditBraceMatching to copy content from.

Implements

IEditBraceMatchingAssign(IEditBraceMatching)
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.FindClosingBrace Method

BracesFindClosingBrace Method
Overload List
 | Name | Description
Public method | FindClosingBrace(Point) | Locates matching closing brace.
Public method | FindClosingBrace(Int32, Int32) | Locates matching closing brace.
Top
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.FindClosingBrace Method (Point)

BracesFindClosingBrace Method (Point)
Locates matching closing brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindClosingBrace(
    ref Point position
)
Public Overridable Function FindClosingBrace (
    ByRef position As Point
) As Boolean
public:
virtual bool FindClosingBrace(
    Point% position
)
abstract FindClosingBrace :
        position : Point byref -> bool
override FindClosingBrace :
        position : Point byref -> bool

Parameters

position
Type: System.DrawingPoint
Retrieves position of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBraceMatchingFindClosingBrace(Point)
See Also

Reference

Braces Class
FindClosingBrace Overload
Alternet.Editor.TextSource Namespace


Braces.FindClosingBrace Method (Int32, Int32)

BracesFindClosingBrace Method (Int32, Int32)
Locates matching closing brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindClosingBrace(
    ref int x,
    ref int y
)
Public Overridable Function FindClosingBrace (
    ByRef x As Integer,
    ByRef y As Integer
) As Boolean
public:
virtual bool FindClosingBrace(
    int% x,
    int% y
)
abstract FindClosingBrace :
        x : int byref *
        y : int byref -> bool
override FindClosingBrace :
        x : int byref *
        y : int byref -> bool

Parameters

x
Type: SystemInt32
Retrieves X-coordinate of the found brace.
y
Type: SystemInt32
Retrieves Y-coordinate of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBraceMatchingFindClosingBrace(Int32, Int32)
See Also

Reference

Braces Class
FindClosingBrace Overload
Alternet.Editor.TextSource Namespace


Braces.FindOpenBrace Method

BracesFindOpenBrace Method
Overload List
 | Name | Description
Public method | FindOpenBrace(Point) | Locates matching open brace.
Public method | FindOpenBrace(Int32, Int32) | Locates matching open brace.
Top
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.FindOpenBrace Method (Point)

BracesFindOpenBrace Method (Point)
Locates matching open brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindOpenBrace(
    ref Point position
)
Public Overridable Function FindOpenBrace (
    ByRef position As Point
) As Boolean
public:
virtual bool FindOpenBrace(
    Point% position
)
abstract FindOpenBrace :
        position : Point byref -> bool
override FindOpenBrace :
        position : Point byref -> bool

Parameters

position
Type: System.DrawingPoint
Retrieves position of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBraceMatchingFindOpenBrace(Point)
See Also

Reference

Braces Class
FindOpenBrace Overload
Alternet.Editor.TextSource Namespace


Braces.FindOpenBrace Method (Int32, Int32)

BracesFindOpenBrace Method (Int32, Int32)
Locates matching open brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindOpenBrace(
    ref int x,
    ref int y
)
Public Overridable Function FindOpenBrace (
    ByRef x As Integer,
    ByRef y As Integer
) As Boolean
public:
virtual bool FindOpenBrace(
    int% x,
    int% y
)
abstract FindOpenBrace :
        x : int byref *
        y : int byref -> bool
override FindOpenBrace :
        x : int byref *
        y : int byref -> bool

Parameters

x
Type: SystemInt32
Retrieves X-coordinate of the found brace.
y
Type: SystemInt32
Retrieves Y-coordinate of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBraceMatchingFindOpenBrace(Int32, Int32)
See Also

Reference

Braces Class
FindOpenBrace Overload
Alternet.Editor.TextSource Namespace


Braces.HighlightBraces Method

BracesHighlightBraces Method
Highlights braces containing caret position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void HighlightBraces()
Public Overridable Sub HighlightBraces
public:
virtual void HighlightBraces()
abstract HighlightBraces : unit -> unit
override HighlightBraces : unit -> unit

Implements

IBraceMatchingHighlightBraces
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace
IBraceMatchingUnhighlightBraces


Braces.ResetBackColor Method

BracesResetBackColor Method
Resets the BackColor to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBackColor()
Public Overridable Sub ResetBackColor
public:
virtual void ResetBackColor()
abstract ResetBackColor : unit -> unit
override ResetBackColor : unit -> unit

Implements

IEditBraceMatchingResetBackColor
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ResetBracesOptions Method

BracesResetBracesOptions Method
Resets the BracesOptions to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBracesOptions()
Public Overridable Sub ResetBracesOptions
public:
virtual void ResetBracesOptions()
abstract ResetBracesOptions : unit -> unit
override ResetBracesOptions : unit -> unit

Implements

IBraceMatchingResetBracesOptions
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ResetClosingBraces Method

BracesResetClosingBraces Method
Resets the ClosingBraces to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetClosingBraces()
Public Overridable Sub ResetClosingBraces
public:
virtual void ResetClosingBraces()
abstract ResetClosingBraces : unit -> unit
override ResetClosingBraces : unit -> unit

Implements

IBraceMatchingResetClosingBraces
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ResetFontStyle Method

BracesResetFontStyle Method
Resets the Style to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetFontStyle()
Public Overridable Sub ResetFontStyle
public:
virtual void ResetFontStyle()
abstract ResetFontStyle : unit -> unit
override ResetFontStyle : unit -> unit

Implements

IEditBraceMatchingResetFontStyle
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ResetForeColor Method

BracesResetForeColor Method
Resets the ForeColor to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetForeColor()
Public Overridable Sub ResetForeColor
public:
virtual void ResetForeColor()
abstract ResetForeColor : unit -> unit
override ResetForeColor : unit -> unit

Implements

IEditBraceMatchingResetForeColor
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ResetOpenBraces Method

BracesResetOpenBraces Method
Resets the OpenBraces to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOpenBraces()
Public Overridable Sub ResetOpenBraces
public:
virtual void ResetOpenBraces()
abstract ResetOpenBraces : unit -> unit
override ResetOpenBraces : unit -> unit

Implements

IBraceMatchingResetOpenBraces
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ResetUseRoundRect Method

BracesResetUseRoundRect Method
Resets the UseRoundRect to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUseRoundRect()
Public Overridable Sub ResetUseRoundRect
public:
virtual void ResetUseRoundRect()
abstract ResetUseRoundRect : unit -> unit
override ResetUseRoundRect : unit -> unit

Implements

IEditBraceMatchingResetUseRoundRect
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ShouldSerializeBackColor Method

BracesShouldSerializeBackColor Method
Indicates whether the BackColor should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeBackColor()
Public Function ShouldSerializeBackColor As Boolean
public:
bool ShouldSerializeBackColor()
member ShouldSerializeBackColor : unit -> bool

Return Value

Type: Boolean
True if BackColor differs from its default value; otherwise false.
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ShouldSerializeClosingBraces Method

BracesShouldSerializeClosingBraces Method
Indicates whether the ClosingBraces property should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeClosingBraces()
Public Function ShouldSerializeClosingBraces As Boolean
public:
bool ShouldSerializeClosingBraces()
member ShouldSerializeClosingBraces : unit -> bool

Return Value

Type: Boolean
True if ClosingBraces differs from its default value; otherwise false.
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ShouldSerializeFontStyle Method

BracesShouldSerializeFontStyle Method
Indicates whether the FontStyle property should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeFontStyle()
Public Function ShouldSerializeFontStyle As Boolean
public:
bool ShouldSerializeFontStyle()
member ShouldSerializeFontStyle : unit -> bool

Return Value

Type: Boolean
True if FontStyle differs from its default value; otherwise false.
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ShouldSerializeForeColor Method

BracesShouldSerializeForeColor Method
Indicates whether the ForeColor should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeForeColor()
Public Function ShouldSerializeForeColor As Boolean
public:
bool ShouldSerializeForeColor()
member ShouldSerializeForeColor : unit -> bool

Return Value

Type: Boolean
True if ForeColor differs from its default value; otherwise false.
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ShouldSerializeOpenBraces Method

BracesShouldSerializeOpenBraces Method
Indicates whether the OpenBraces should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOpenBraces()
Public Function ShouldSerializeOpenBraces As Boolean
public:
bool ShouldSerializeOpenBraces()
member ShouldSerializeOpenBraces : unit -> bool

Return Value

Type: Boolean
True if OpenBraces differs from its default value; otherwise false.
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.TempHighlightBraces Method

BracesTempHighlightBraces Method
Temporary highlights all text within the area specified by rects.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempHighlightBraces(
    Rectangle[] rects
)
Public Overridable Sub TempHighlightBraces (
    rects As Rectangle()
)
public:
virtual void TempHighlightBraces(
    array<Rectangle>^ rects
)
abstract TempHighlightBraces :
        rects : Rectangle[] -> unit
override TempHighlightBraces :
        rects : Rectangle[] -> unit

Parameters

rects
Type: System.DrawingRectangle
Specifies the area to highlight text in.

Implements

IBraceMatchingTempHighlightBraces(Rectangle)
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace
BracesTempUnhighlightBraces


Braces.TempUnhighlightBraces Method

BracesTempUnhighlightBraces Method
Cancels text highlighting, turned on by TempHighlightBraces method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempUnhighlightBraces()
Public Overridable Sub TempUnhighlightBraces
public:
virtual void TempUnhighlightBraces()
abstract TempUnhighlightBraces : unit -> unit
override TempUnhighlightBraces : unit -> unit

Implements

IBraceMatchingTempUnhighlightBraces
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace
BracesTempHighlightBraces(Rectangle)


Braces.UnhighlightBraces Method

BracesUnhighlightBraces Method
Unhighlights braces containing caret position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnhighlightBraces()
Public Overridable Sub UnhighlightBraces
public:
virtual void UnhighlightBraces()
abstract UnhighlightBraces : unit -> unit
override UnhighlightBraces : unit -> unit

Implements

IBraceMatchingUnhighlightBraces
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace
IBraceMatchingHighlightBraces


Braces Properties

Braces Properties

The Braces type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets a value that represents background color to draw matching braces.
Public property | BracesOptions | Gets or sets options specifying appearance and behaviour of matching braces within Edit control.
Public property | ClosingBraces | Gets or sets an array of characters each one representing a closing brace.
Public property | FontStyle | Gets or sets a FontStyle value that is used to draw matching braces.
Public property | ForeColor | Gets or sets a value that represents foreground color to draw matching braces.
Public property | OpenBraces | Gets or sets an array of characters each one representing an open brace.
Public property | UseRoundRect | Gets or sets a boolean value that indicates whether Edit control should draw rectangle around matching braces.
Top
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.BackColor Property

BracesBackColor Property
Gets or sets a value that represents background color to draw matching braces.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BackColor { get; set; }
Public Overridable Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color

Implements

IEditBraceMatchingBackColor
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.BracesOptions Property

BracesBracesOptions Property
Gets or sets options specifying appearance and behaviour of matching braces within Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual BracesOptions BracesOptions { get; set; }
Public Overridable Property BracesOptions As BracesOptions
    Get
    Set
public:
virtual property BracesOptions BracesOptions {
    BracesOptions get ();
    void set (BracesOptions value);
}
abstract BracesOptions : BracesOptions with get, set
override BracesOptions : BracesOptions with get, set

Property Value

Type: BracesOptions

Implements

IEditBraceMatchingBracesOptions
IBraceMatchingBracesOptions
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ClosingBraces Property

BracesClosingBraces Property
Gets or sets an array of characters each one representing a closing brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] ClosingBraces { get; set; }
Public Overridable Property ClosingBraces As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ ClosingBraces {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract ClosingBraces : char[] with get, set
override ClosingBraces : char[] with get, set

Property Value

Type: Char

Implements

IEditBraceMatchingClosingBraces
IBraceMatchingClosingBraces
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.FontStyle Property

BracesFontStyle Property
Gets or sets a FontStyle value that is used to draw matching braces.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FontStyle FontStyle { get; set; }
Public Overridable Property FontStyle As FontStyle
    Get
    Set
public:
virtual property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract FontStyle : FontStyle with get, set
override FontStyle : FontStyle with get, set

Property Value

Type: FontStyle

Implements

IEditBraceMatchingFontStyle
Remarks
The default value of this property is FontStyle.Bold.
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.ForeColor Property

BracesForeColor Property
Gets or sets a value that represents foreground color to draw matching braces.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ForeColor { get; set; }
Public Overridable Property ForeColor As Color
    Get
    Set
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set
override ForeColor : Color with get, set

Property Value

Type: Color

Implements

IEditBraceMatchingForeColor
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.OpenBraces Property

BracesOpenBraces Property
Gets or sets an array of characters each one representing an open brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] OpenBraces { get; set; }
Public Overridable Property OpenBraces As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ OpenBraces {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract OpenBraces : char[] with get, set
override OpenBraces : char[] with get, set

Property Value

Type: Char

Implements

IEditBraceMatchingOpenBraces
IBraceMatchingOpenBraces
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


Braces.UseRoundRect Property

BracesUseRoundRect Property
Gets or sets a boolean value that indicates whether Edit control should draw rectangle around matching braces.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UseRoundRect { get; set; }
Public Overridable Property UseRoundRect As Boolean
    Get
    Set
public:
virtual property bool UseRoundRect {
    bool get ();
    void set (bool value);
}
abstract UseRoundRect : bool with get, set
override UseRoundRect : bool with get, set

Property Value

Type: Boolean

Implements

IEditBraceMatchingUseRoundRect
See Also

Reference

Braces Class
Alternet.Editor.TextSource Namespace


BracesOptions Enumeration

BracesOptions Enumeration
Defines braces behaviour. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum BracesOptions
<FlagsAttribute>
Public Enumeration BracesOptions
[FlagsAttribute]
public enum class BracesOptions
[<FlagsAttribute>]
type BracesOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Highlight | 1 | Specifies that matching braces should be highlighted.
HighlightBounds | 2 | Specifies that matching braces should be highlighted only if caret is positioned on the brace.
TempHighlight | 4 | Specifies that the highlighting will disappear after small delay.
See Also

Reference

Alternet.Editor.TextSource Namespace


CodeSnippetRange Class

CodeSnippetRange Class
Represents individual outlining section that can appear in the Edit control.
Inheritance Hierarchy
SystemObject
Alternet.CommonRange
Alternet.Editor.TextSourceCodeSnippetRange

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetRange : Range,
    ICodeSnippetRange, IRange, ICloneable
Public Class CodeSnippetRange
    Inherits Range
    Implements ICodeSnippetRange, IRange, ICloneable
public ref class CodeSnippetRange : public Range,
    ICodeSnippetRange, IRange, ICloneable
type CodeSnippetRange =
    class
        inherit Range
        interface ICodeSnippetRange
        interface IRange
        interface ICloneable
    end

The CodeSnippetRange type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetRange(Point, Point) | Initializes a new instance of the CodeSnippetRange class with specified parameters.
Public method | CodeSnippetRange(Point, Point, String, String, Boolean) | Initializes a new instance of the SnippetRange class with specified parameter.
Public method | CodeSnippetRange(Point, Point, String, String, Boolean, Boolean) | Initializes a new instance of the SnippetRange class with specified parameter.
Public method | CodeSnippetRange(Point, Point, String, String, Boolean, Boolean, Boolean) | Initializes a new instance of the SnippetRange class with specified parameter.
Top
Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from Range.)
Public method | Clone | Creates a new object that is a copy of the current CodeSnippetRange object. (Overrides RangeClone.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted. (Inherited from Range.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EndPoint | Gets or sets end of IRange area. (Inherited from Range.)
Public property | ID | Represents name of code snippet.
Public property | IsEditable | Gets or sets a boolean value that indicates whether code snippet can be edited.
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size. (Inherited from Range.)
Public property | Size | Gets or sets size of IRange area. (Inherited from Range.)
Public property | StartPoint | Gets or sets begin of IRange area. (Inherited from Range.)
Public property | SupportsCode | Gets or sets a boolean value that indicates whether code snippet can fill code.
Public property | Tooltip | Represents short description of the code snippet.
Public property | Visible | Gets or sets a boolean value that indicates whether code snippet is visible.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


CodeSnippetRange Constructor

CodeSnippetRange Constructor
Overload List
 | Name | Description
Public method | CodeSnippetRange(Point, Point) | Initializes a new instance of the CodeSnippetRange class with specified parameters.
Public method | CodeSnippetRange(Point, Point, String, String, Boolean) | Initializes a new instance of the SnippetRange class with specified parameter.
Public method | CodeSnippetRange(Point, Point, String, String, Boolean, Boolean) | Initializes a new instance of the SnippetRange class with specified parameter.
Public method | CodeSnippetRange(Point, Point, String, String, Boolean, Boolean, Boolean) | Initializes a new instance of the SnippetRange class with specified parameter.
Top
See Also

Reference

CodeSnippetRange Class
Alternet.Editor.TextSource Namespace


CodeSnippetRange Constructor (Point, Point)

CodeSnippetRange Constructor (Point, Point)
Initializes a new instance of the CodeSnippetRange class with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetRange(
    Point start,
    Point end
)
Public Sub New (
    start As Point,
    end As Point
)
public:
CodeSnippetRange(
    Point start,
    Point end
)
new :
        start : Point *
        end : Point -> CodeSnippetRange

Parameters

start
Type: System.DrawingPoint
Start of CodeSnippetRange area.
end
Type: System.DrawingPoint
End of CodeSnippetRange area.
See Also

Reference

CodeSnippetRange Class
CodeSnippetRange Overload
Alternet.Editor.TextSource Namespace


CodeSnippetRange Constructor (Point, Point, String, String, Boolean)

CodeSnippetRange Constructor (Point, Point, String, String, Boolean)
Initializes a new instance of the SnippetRange class with specified parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetRange(
    Point start,
    Point end,
    string id,
    string tooltip,
    bool isEditable
)
Public Sub New (
    start As Point,
    end As Point,
    id As String,
    tooltip As String,
    isEditable As Boolean
)
public:
CodeSnippetRange(
    Point start,
    Point end,
    String^ id,
    String^ tooltip,
    bool isEditable
)
new :
        start : Point *
        end : Point *
        id : string *
        tooltip : string *
        isEditable : bool -> CodeSnippetRange

Parameters

start
Type: System.DrawingPoint
Specifies start position of the code snippet.
end
Type: System.DrawingPoint
Specifies end position of the code snippet.
id
Type: SystemString
Specifies id of the code snippet.
tooltip
Type: SystemString
Specifies short description of the code snippet.
isEditable
Type: SystemBoolean
Specifies whether code snippet can be edited.
See Also

Reference

CodeSnippetRange Class
CodeSnippetRange Overload
Alternet.Editor.TextSource Namespace


CodeSnippetRange Constructor (Point, Point, String, String, Boolean, Boolean)

CodeSnippetRange Constructor (Point, Point, String, String, Boolean, Boolean)
Initializes a new instance of the SnippetRange class with specified parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetRange(
    Point start,
    Point end,
    string id,
    string tooltip,
    bool isEditable,
    bool supportsCode
)
Public Sub New (
    start As Point,
    end As Point,
    id As String,
    tooltip As String,
    isEditable As Boolean,
    supportsCode As Boolean
)
public:
CodeSnippetRange(
    Point start,
    Point end,
    String^ id,
    String^ tooltip,
    bool isEditable,
    bool supportsCode
)
new :
        start : Point *
        end : Point *
        id : string *
        tooltip : string *
        isEditable : bool *
        supportsCode : bool -> CodeSnippetRange

Parameters

start
Type: System.DrawingPoint
Specifies start position of the code snippet.
end
Type: System.DrawingPoint
Specifies end position of the code snippet.
id
Type: SystemString
Specifies id of the code snippet.
tooltip
Type: SystemString
Specifies short description of the code snippet.
isEditable
Type: SystemBoolean
Specifies whether code snippet can be edited.
supportsCode
Type: SystemBoolean
Specifies whether code snippet supports code.
See Also

Reference

CodeSnippetRange Class
CodeSnippetRange Overload
Alternet.Editor.TextSource Namespace


CodeSnippetRange Constructor (Point, Point, String, String, Boolean, Boolean, Boolean)

CodeSnippetRange Constructor (Point, Point, String, String, Boolean, Boolean, Boolean)
Initializes a new instance of the SnippetRange class with specified parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetRange(
    Point start,
    Point end,
    string id,
    string tooltip,
    bool isEditable,
    bool supportsCode,
    bool visible
)
Public Sub New (
    start As Point,
    end As Point,
    id As String,
    tooltip As String,
    isEditable As Boolean,
    supportsCode As Boolean,
    visible As Boolean
)
public:
CodeSnippetRange(
    Point start,
    Point end,
    String^ id,
    String^ tooltip,
    bool isEditable,
    bool supportsCode,
    bool visible
)
new :
        start : Point *
        end : Point *
        id : string *
        tooltip : string *
        isEditable : bool *
        supportsCode : bool *
        visible : bool -> CodeSnippetRange

Parameters

start
Type: System.DrawingPoint
Specifies start position of the code snippet.
end
Type: System.DrawingPoint
Specifies end position of the code snippet.
id
Type: SystemString
Specifies id of the code snippet.
tooltip
Type: SystemString
Specifies short description of the code snippet.
isEditable
Type: SystemBoolean
Specifies whether code snippet can be edited.
supportsCode
Type: SystemBoolean
Specifies whether code snippet supports code.
visible
Type: SystemBoolean
Specifies whether code snippet should be highlighted.
See Also

Reference

CodeSnippetRange Class
CodeSnippetRange Overload
Alternet.Editor.TextSource Namespace


CodeSnippetRange Methods

CodeSnippetRange Methods

The CodeSnippetRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from Range.)
Public method | Clone | Creates a new object that is a copy of the current CodeSnippetRange object. (Overrides RangeClone.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted. (Inherited from Range.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetRange Class
Alternet.Editor.TextSource Namespace


CodeSnippetRange.Clone Method

CodeSnippetRangeClone Method
Creates a new object that is a copy of the current CodeSnippetRange object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object Clone()
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of System.Object that is the memberwise clone of the current CodeSnippetRange object.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

CodeSnippetRange Class
Alternet.Editor.TextSource Namespace


CodeSnippetRange Properties

CodeSnippetRange Properties

The CodeSnippetRange type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | Gets or sets end of IRange area. (Inherited from Range.)
Public property | ID | Represents name of code snippet.
Public property | IsEditable | Gets or sets a boolean value that indicates whether code snippet can be edited.
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size. (Inherited from Range.)
Public property | Size | Gets or sets size of IRange area. (Inherited from Range.)
Public property | StartPoint | Gets or sets begin of IRange area. (Inherited from Range.)
Public property | SupportsCode | Gets or sets a boolean value that indicates whether code snippet can fill code.
Public property | Tooltip | Represents short description of the code snippet.
Public property | Visible | Gets or sets a boolean value that indicates whether code snippet is visible.
Top
See Also

Reference

CodeSnippetRange Class
Alternet.Editor.TextSource Namespace


CodeSnippetRange.ID Property

CodeSnippetRangeID Property
Represents name of code snippet.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
virtual property String^ ID {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ID : string with get, set
override ID : string with get, set

Property Value

Type: String

Implements

ICodeSnippetRangeID
See Also

Reference

CodeSnippetRange Class
Alternet.Editor.TextSource Namespace


CodeSnippetRange.IsEditable Property

CodeSnippetRangeIsEditable Property
Gets or sets a boolean value that indicates whether code snippet can be edited.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set
public:
virtual property bool IsEditable {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsEditable : bool with get, set
override IsEditable : bool with get, set

Property Value

Type: Boolean

Implements

ICodeSnippetRangeIsEditable
See Also

Reference

CodeSnippetRange Class
Alternet.Editor.TextSource Namespace


CodeSnippetRange.SupportsCode Property

CodeSnippetRangeSupportsCode Property
Gets or sets a boolean value that indicates whether code snippet can fill code.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsCode { get; set; }
Public Property SupportsCode As Boolean
    Get
    Set
public:
virtual property bool SupportsCode {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SupportsCode : bool with get, set
override SupportsCode : bool with get, set

Property Value

Type: Boolean

Implements

ICodeSnippetRangeSupportsCode
See Also

Reference

CodeSnippetRange Class
Alternet.Editor.TextSource Namespace


CodeSnippetRange.Tooltip Property

CodeSnippetRangeTooltip Property
Represents short description of the code snippet.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
virtual property String^ Tooltip {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Tooltip : string with get, set
override Tooltip : string with get, set

Property Value

Type: String

Implements

ICodeSnippetRangeTooltip
See Also

Reference

CodeSnippetRange Class
Alternet.Editor.TextSource Namespace


CodeSnippetRange.Visible Property

CodeSnippetRangeVisible Property
Gets or sets a boolean value that indicates whether code snippet is visible.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

ICodeSnippetRangeVisible
See Also

Reference

CodeSnippetRange Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges Class

CodeSnippetRanges Class
Represents collection containing list of code snippet literals.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeSnippetRange
Alternet.CommonSortList ICodeSnippetRange
Alternet.Editor.TextSourceCodeSnippetRanges

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetRanges : SortList<ICodeSnippetRange>,
    ICodeSnippetRanges, IList<ICodeSnippetRange>, ICollection<ICodeSnippetRange>,
    IEnumerable<ICodeSnippetRange>, IEnumerable
Public Class CodeSnippetRanges
    Inherits SortList(Of ICodeSnippetRange)
    Implements ICodeSnippetRanges, IList(Of ICodeSnippetRange),
    ICollection(Of ICodeSnippetRange), IEnumerable(Of ICodeSnippetRange), IEnumerable
public ref class CodeSnippetRanges : public SortList<ICodeSnippetRange^>,
    ICodeSnippetRanges, IList<ICodeSnippetRange^>, ICollection<ICodeSnippetRange^>,
    IEnumerable<ICodeSnippetRange^>, IEnumerable
type CodeSnippetRanges =
    class
        inherit SortList<ICodeSnippetRange>
        interface ICodeSnippetRanges
        interface IList<ICodeSnippetRange>
        interface ICollection<ICodeSnippetRange>
        interface IEnumerable<ICodeSnippetRange>
        interface IEnumerable
    end

The CodeSnippetRanges type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetRanges | Initializes a new instance of the CodeSnippetList class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetRange .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetRange .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetRange .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetRange .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetRange .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetRange .)
Public method | BlockDeleting | Removes all snippets from the snippet collection which position in the specified rectangle.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetRange .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetRange .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetRange .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetRange .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetRange .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetRange .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetRange .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetRange .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetRange .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetRange .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetRange .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetRange .)
Public method | FindSnippet | Locates code snippet at specified position.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetRange .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetRange .)
Public method | GetFirstSnippet | Finds first snippet in snippet collection with nonempty id.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNextSnippet | Finds next snippet in snippet collection with different id.
Public method | GetPrevSnippet | Finds previous snippet in snippet collection with different id.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetRange .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetRange .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetRange .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetRange .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetRange .)
Public method | IsFirstSnippet(Int32) | Checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | IsFirstSnippet(ICodeSnippetRange) | Checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetRange .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetRange .)
Public method | NeedClear(Rectangle) | Obtains boolean value indicating whether all snippets need removing from the list.
Public method | NeedClear(Int32) | Obtains boolean value indicating whether all snippets need removing from the list.
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Changes positions of any code snippet located next to the specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetRange .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetRange .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetRange .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetRange .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetRange .)
Public method | Sort | Sorts the snippet list.
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetRange .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetRange .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetRange .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetRange .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetRange .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetRange .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetRange | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetRange | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetRange, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetRange .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetRange .)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


CodeSnippetRanges Constructor

CodeSnippetRanges Constructor
Initializes a new instance of the CodeSnippetList class with default settings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetRanges()
Public Sub New
public:
CodeSnippetRanges()
new : unit -> CodeSnippetRanges
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges Methods

CodeSnippetRanges Methods

The CodeSnippetRanges type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetRange .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetRange .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetRange .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetRange .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetRange .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetRange .)
Public method | BlockDeleting | Removes all snippets from the snippet collection which position in the specified rectangle.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetRange .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetRange .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetRange .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetRange .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetRange .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetRange .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetRange .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetRange .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetRange .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetRange .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetRange .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetRange .)
Public method | FindSnippet | Locates code snippet at specified position.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetRange .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetRange .)
Public method | GetFirstSnippet | Finds first snippet in snippet collection with nonempty id.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNextSnippet | Finds next snippet in snippet collection with different id.
Public method | GetPrevSnippet | Finds previous snippet in snippet collection with different id.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetRange .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetRange .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetRange .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetRange .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetRange .)
Public method | IsFirstSnippet(Int32) | Checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | IsFirstSnippet(ICodeSnippetRange) | Checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetRange .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetRange .)
Public method | NeedClear(Rectangle) | Obtains boolean value indicating whether all snippets need removing from the list.
Public method | NeedClear(Int32) | Obtains boolean value indicating whether all snippets need removing from the list.
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Changes positions of any code snippet located next to the specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetRange .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetRange .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetRange .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetRange .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetRange .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetRange .)
Public method | Sort | Sorts the snippet list.
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetRange .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetRange .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetRange .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetRange .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetRange .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetRange .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetRange | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetRange | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetRange, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.BlockDeleting Method

CodeSnippetRangesBlockDeleting Method
Removes all snippets from the snippet collection which position in the specified rectangle.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect
)
Public Overridable Function BlockDeleting (
    rect As Rectangle
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool
override BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove snippets.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ICodeSnippetRangesBlockDeleting(Rectangle)
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.FindSnippet Method

CodeSnippetRangesFindSnippet Method
Locates code snippet at specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FindSnippet(
    Point position,
    bool exact,
    out int index
)
Public Function FindSnippet (
    position As Point,
    exact As Boolean,
    <OutAttribute> ByRef index As Integer
) As Boolean
public:
virtual bool FindSnippet(
    Point position,
    bool exact,
    [OutAttribute] int% index
) sealed
abstract FindSnippet :
        position : Point *
        exact : bool *
        index : int byref -> bool
override FindSnippet :
        position : Point *
        exact : bool *
        index : int byref -> bool

Parameters

position
Type: System.DrawingPoint
Position to locate code snippet.
exact
Type: SystemBoolean
Specifies whether search should be precise.
index
Type: SystemInt32
Receives index of code snippet in the snippets collection.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ICodeSnippetRangesFindSnippet(Point, Boolean, Int32)
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.GetFirstSnippet Method

CodeSnippetRangesGetFirstSnippet Method
Finds first snippet in snippet collection with nonempty id.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetFirstSnippet()
Public Function GetFirstSnippet As Integer
public:
virtual int GetFirstSnippet() sealed
abstract GetFirstSnippet : unit -> int
override GetFirstSnippet : unit -> int

Return Value

Type: Int32
Index of found snippet.

Implements

ICodeSnippetRangesGetFirstSnippet
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.GetNextSnippet Method

CodeSnippetRangesGetNextSnippet Method
Finds next snippet in snippet collection with different id.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNextSnippet(
    int index
)
Public Function GetNextSnippet (
    index As Integer
) As Integer
public:
virtual int GetNextSnippet(
    int index
) sealed
abstract GetNextSnippet :
        index : int -> int
override GetNextSnippet :
        index : int -> int

Parameters

index
Type: SystemInt32
Specified index of snippet to search from.

Return Value

Type: Int32
Index of found snippet.

Implements

ICodeSnippetRangesGetNextSnippet(Int32)
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.GetPrevSnippet Method

CodeSnippetRangesGetPrevSnippet Method
Finds previous snippet in snippet collection with different id.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPrevSnippet(
    int index
)
Public Function GetPrevSnippet (
    index As Integer
) As Integer
public:
virtual int GetPrevSnippet(
    int index
) sealed
abstract GetPrevSnippet :
        index : int -> int
override GetPrevSnippet :
        index : int -> int

Parameters

index
Type: SystemInt32
Specified index of snippet to search from.

Return Value

Type: Int32
Index of found snippet.

Implements

ICodeSnippetRangesGetPrevSnippet(Int32)
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.IsFirstSnippet Method

CodeSnippetRangesIsFirstSnippet Method
Overload List
 | Name | Description
Public method | IsFirstSnippet(Int32) | Checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | IsFirstSnippet(ICodeSnippetRange) | Checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Top
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.IsFirstSnippet Method (Int32)

CodeSnippetRangesIsFirstSnippet Method (Int32)
Checks whether code snippet represents first snippet in subset of snippets that have the same ids.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFirstSnippet(
    int index
)
Public Function IsFirstSnippet (
    index As Integer
) As Boolean
public:
virtual bool IsFirstSnippet(
    int index
) sealed
abstract IsFirstSnippet :
        index : int -> bool
override IsFirstSnippet :
        index : int -> bool

Parameters

index
Type: SystemInt32
Specified index of the snippet.

Return Value

Type: Boolean
Returns True if snippet represents the first snippet with unique id.

Implements

ICodeSnippetRangesIsFirstSnippet(Int32)
See Also

Reference

CodeSnippetRanges Class
IsFirstSnippet Overload
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.IsFirstSnippet Method (ICodeSnippetRange)

CodeSnippetRangesIsFirstSnippet Method (ICodeSnippetRange)
Checks whether code snippet represents first snippet in subset of snippets that have the same ids.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFirstSnippet(
    ICodeSnippetRange range
)
Public Function IsFirstSnippet (
    range As ICodeSnippetRange
) As Boolean
public:
virtual bool IsFirstSnippet(
    ICodeSnippetRange^ range
) sealed
abstract IsFirstSnippet :
        range : ICodeSnippetRange -> bool
override IsFirstSnippet :
        range : ICodeSnippetRange -> bool

Parameters

range
Type: Alternet.Editor.TextSourceICodeSnippetRange
Specified the code snippet.

Return Value

Type: Boolean
Returns True if snippet represents the first snippet with unique id.

Implements

ICodeSnippetRangesIsFirstSnippet(ICodeSnippetRange)
See Also

Reference

CodeSnippetRanges Class
IsFirstSnippet Overload
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.NeedClear Method

CodeSnippetRangesNeedClear Method
Overload List
 | Name | Description
Public method | NeedClear(Rectangle) | Obtains boolean value indicating whether all snippets need removing from the list.
Public method | NeedClear(Int32) | Obtains boolean value indicating whether all snippets need removing from the list.
Top
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.NeedClear Method (Rectangle)

CodeSnippetRangesNeedClear Method (Rectangle)
Obtains boolean value indicating whether all snippets need removing from the list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedClear(
    Rectangle rect
)
Public Function NeedClear (
    rect As Rectangle
) As Boolean
public:
virtual bool NeedClear(
    Rectangle rect
) sealed
abstract NeedClear :
        rect : Rectangle -> bool
override NeedClear :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Rectangle specifying block being deleted.

Return Value

Type: Boolean

Implements

ICodeSnippetRangesNeedClear(Rectangle)
See Also

Reference

CodeSnippetRanges Class
NeedClear Overload
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.NeedClear Method (Int32)

CodeSnippetRangesNeedClear Method (Int32)
Obtains boolean value indicating whether all snippets need removing from the list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedClear(
    int y
)
Public Function NeedClear (
    y As Integer
) As Boolean
public:
virtual bool NeedClear(
    int y
) sealed
abstract NeedClear :
        y : int -> bool
override NeedClear :
        y : int -> bool

Parameters

y
Type: SystemInt32
Line being changed.

Return Value

Type: Boolean

Implements

ICodeSnippetRangesNeedClear(Int32)
See Also

Reference

CodeSnippetRanges Class
NeedClear Overload
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.PositionChanged Method

CodeSnippetRangesPositionChanged Method
Changes positions of any code snippet located next to the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    bool preserveBounds
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    preserveBounds As Boolean
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    bool preserveBounds
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        preserveBounds : bool -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        preserveBounds : bool -> bool

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.
preserveBounds
Type: SystemBoolean
Specifies whether snippet bounds should be preserved.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ICodeSnippetRangesPositionChanged(Int32, Int32, Int32, Int32, Boolean)
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.Sort Method

CodeSnippetRangesSort Method
Overload List
 | Name | Description
Public method | Sort | Sorts the snippet list.
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetRange .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetRange .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetRange .)
Top
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CodeSnippetRanges.Sort Method

CodeSnippetRangesSort Method
Sorts the snippet list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Sort()
Public Sub Sort
public:
virtual void Sort() sealed
abstract Sort : unit -> unit
override Sort : unit -> unit

Implements

ICodeSnippetRangesSort
See Also

Reference

CodeSnippetRanges Class
Sort Overload
Alternet.Editor.TextSource Namespace


CodeSnippetRanges Properties

CodeSnippetRanges Properties

The CodeSnippetRanges type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetRange .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetRange .)
Top
See Also

Reference

CodeSnippetRanges Class
Alternet.Editor.TextSource Namespace


CreateSearchManagerEventArgs Class

CreateSearchManagerEventArgs Class
Provides data for the CreateSharedSearch handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.TextSourceCreateSearchManagerEventArgs

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CreateSearchManagerEventArgs : EventArgs
Public Class CreateSearchManagerEventArgs
    Inherits EventArgs
public ref class CreateSearchManagerEventArgs : public EventArgs
type CreateSearchManagerEventArgs =
    class
        inherit EventArgs
    end

The CreateSearchManagerEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CreateSearchManagerEventArgs | Initializes a new instance of the CreateSearchManagerEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SearchManager | The newly created Search Manager.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


CreateSearchManagerEventArgs Constructor

CreateSearchManagerEventArgs Constructor
Initializes a new instance of the CreateSearchManagerEventArgs class

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CreateSearchManagerEventArgs()
Public Sub New
public:
CreateSearchManagerEventArgs()
new : unit -> CreateSearchManagerEventArgs
See Also

Reference

CreateSearchManagerEventArgs Class
Alternet.Editor.TextSource Namespace


CreateSearchManagerEventArgs Methods

CreateSearchManagerEventArgs Methods

The CreateSearchManagerEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateSearchManagerEventArgs Class
Alternet.Editor.TextSource Namespace


CreateSearchManagerEventArgs Properties

CreateSearchManagerEventArgs Properties

The CreateSearchManagerEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SearchManager | The newly created Search Manager.
Top
See Also

Reference

CreateSearchManagerEventArgs Class
Alternet.Editor.TextSource Namespace


CreateSearchManagerEventArgs.SearchManager Property

CreateSearchManagerEventArgsSearchManager Property
The newly created Search Manager.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SearchManager SearchManager { get; set; }
Public Property SearchManager As SearchManager
    Get
    Set
public:
property SearchManager^ SearchManager {
    SearchManager^ get ();
    void set (SearchManager^ value);
}
member SearchManager : SearchManager with get, set

Property Value

Type: SearchManager
See Also

Reference

CreateSearchManagerEventArgs Class
Alternet.Editor.TextSource Namespace


HyperText Class

HyperText Class
This class is designed to recognize whether some text represents hypertext.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TextSourceHyperText

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HyperText
Public Class HyperText
public ref class HyperText
type HyperText =  class end

The HyperText type exposes the following members.

Constructors
 | Name | Description
Public method | HyperText | Initializes a new instance of the HyperText class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmailString | Indicates whether given text is e-mail address.
 | IsFileString | Indicates whether given text is address string for the local file on the disk.
 | IsFtpString | Indicates whether given text is address string for File Transfer Protocol.
 | IsGopherString | Indicates whether given text is internet address string for the Gopher protocol.
 | IsHttpsString | Indicates whether given text is internet address used Secure Hypertext Transfer Protocol.
 | IsHttpString | Indicates whether given text is internet address used Hypertext Transfer Protocol.
 | IsHyperText | Indicates whether given text is hypertext.
 | IsWWWString | Indicates whether given text is internet address within the World Wide Web.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


HyperText Constructor

HyperText Constructor
Initializes a new instance of the HyperText class

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HyperText()
Public Sub New
public:
HyperText()
new : unit -> HyperText
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperText Methods

HyperText Methods

The HyperText type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmailString | Indicates whether given text is e-mail address.
 | IsFileString | Indicates whether given text is address string for the local file on the disk.
 | IsFtpString | Indicates whether given text is address string for File Transfer Protocol.
 | IsGopherString | Indicates whether given text is internet address string for the Gopher protocol.
 | IsHttpsString | Indicates whether given text is internet address used Secure Hypertext Transfer Protocol.
 | IsHttpString | Indicates whether given text is internet address used Hypertext Transfer Protocol.
 | IsHyperText | Indicates whether given text is hypertext.
 | IsWWWString | Indicates whether given text is internet address within the World Wide Web.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperText.IsEmailString Method

HyperTextIsEmailString Method
Indicates whether given text is e-mail address.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsEmailString(
    string text
)
Public Shared Function IsEmailString (
    text As String
) As Boolean
public:
static bool IsEmailString(
    String^ text
)
static member IsEmailString :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies string to check.

Return Value

Type: Boolean
True if given text is e-mail address; otherwise false.
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperText.IsFileString Method

HyperTextIsFileString Method
Indicates whether given text is address string for the local file on the disk.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsFileString(
    string text
)
Public Shared Function IsFileString (
    text As String
) As Boolean
public:
static bool IsFileString(
    String^ text
)
static member IsFileString :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies string to check.

Return Value

Type: Boolean
True if given text is local file address; otherwise false.
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperText.IsFtpString Method

HyperTextIsFtpString Method
Indicates whether given text is address string for File Transfer Protocol.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsFtpString(
    string text
)
Public Shared Function IsFtpString (
    text As String
) As Boolean
public:
static bool IsFtpString(
    String^ text
)
static member IsFtpString :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies string to check.

Return Value

Type: Boolean
True if given text is Ftp address; otherwise false.
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperText.IsGopherString Method

HyperTextIsGopherString Method
Indicates whether given text is internet address string for the Gopher protocol.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsGopherString(
    string text
)
Public Shared Function IsGopherString (
    text As String
) As Boolean
public:
static bool IsGopherString(
    String^ text
)
static member IsGopherString :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies string to check.

Return Value

Type: Boolean
True if given text is Gopher address; otherwise false.
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperText.IsHttpsString Method

HyperTextIsHttpsString Method
Indicates whether given text is internet address used Secure Hypertext Transfer Protocol.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsHttpsString(
    string text
)
Public Shared Function IsHttpsString (
    text As String
) As Boolean
public:
static bool IsHttpsString(
    String^ text
)
static member IsHttpsString :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies string to check.

Return Value

Type: Boolean
True if given text is internet address; otherwise false.
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperText.IsHttpString Method

HyperTextIsHttpString Method
Indicates whether given text is internet address used Hypertext Transfer Protocol.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsHttpString(
    string text
)
Public Shared Function IsHttpString (
    text As String
) As Boolean
public:
static bool IsHttpString(
    String^ text
)
static member IsHttpString :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies string to check.

Return Value

Type: Boolean
True if given text is internet address; otherwise false.
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperText.IsHyperText Method

HyperTextIsHyperText Method
Indicates whether given text is hypertext.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsHyperText(
    string text
)
Public Shared Function IsHyperText (
    text As String
) As Boolean
public:
static bool IsHyperText(
    String^ text
)
static member IsHyperText :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies string to check.

Return Value

Type: Boolean
True if given text is hypertext; otherwise false.
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperText.IsWWWString Method

HyperTextIsWWWString Method
Indicates whether given text is internet address within the World Wide Web.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsWWWString(
    string text
)
Public Shared Function IsWWWString (
    text As String
) As Boolean
public:
static bool IsWWWString(
    String^ text
)
static member IsWWWString :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies string to check.

Return Value

Type: Boolean
True if given text is internet address; otherwise false.
See Also

Reference

HyperText Class
Alternet.Editor.TextSource Namespace


HyperTextEvent Delegate

HyperTextEvent Delegate
Represents a method that will handle the SyntaxEdit.CheckHyperText, TextSource.CheckHyperText or HyperTextEx.CheckHyperText events.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void HyperTextEvent(
    Object sender,
    HyperTextEventArgs e
)
Public Delegate Sub HyperTextEvent (
    sender As Object,
    e As HyperTextEventArgs
)
public delegate void HyperTextEvent(
    Object^ sender,
    HyperTextEventArgs^ e
)
type HyperTextEvent =
    delegate of
        sender : Object *
        e : HyperTextEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.Editor.TextSourceHyperTextEventArgs
A HyperTextEventArgs that contains the event data.
See Also

Reference

Alternet.Editor.TextSource Namespace


HyperTextEventArgs Class

HyperTextEventArgs Class
Provides data for the HyperTextEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.TextSourceHyperTextEventArgs

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HyperTextEventArgs : EventArgs
Public Class HyperTextEventArgs
    Inherits EventArgs
public ref class HyperTextEventArgs : public EventArgs
type HyperTextEventArgs =
    class
        inherit EventArgs
    end

The HyperTextEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | HyperTextEventArgs | Initializes a new instance of the HyperTextEventArgs class with specified Text and HyperText values.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsHyperText | Returns value indicating whether HyperTextEventArgs.Text represents hypertext.
Public property | Text | Contains string to check.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


HyperTextEventArgs Constructor

HyperTextEventArgs Constructor
Initializes a new instance of the HyperTextEventArgs class with specified Text and HyperText values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HyperTextEventArgs(
    string text,
    bool isHyperText
)
Public Sub New (
    text As String,
    isHyperText As Boolean
)
public:
HyperTextEventArgs(
    String^ text,
    bool isHyperText
)
new :
        text : string *
        isHyperText : bool -> HyperTextEventArgs

Parameters

text
Type: SystemString
Specifies text to check.
isHyperText
Type: SystemBoolean
Indicates whether given text represents hypertext.
See Also

Reference

HyperTextEventArgs Class
Alternet.Editor.TextSource Namespace


HyperTextEventArgs Methods

HyperTextEventArgs Methods

The HyperTextEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HyperTextEventArgs Class
Alternet.Editor.TextSource Namespace


HyperTextEventArgs Properties

HyperTextEventArgs Properties

The HyperTextEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsHyperText | Returns value indicating whether HyperTextEventArgs.Text represents hypertext.
Public property | Text | Contains string to check.
Top
See Also

Reference

HyperTextEventArgs Class
Alternet.Editor.TextSource Namespace


HyperTextEventArgs.IsHyperText Property

HyperTextEventArgsIsHyperText Property
Returns value indicating whether HyperTextEventArgs.Text represents hypertext.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHyperText { get; set; }
Public Property IsHyperText As Boolean
    Get
    Set
public:
property bool IsHyperText {
    bool get ();
    void set (bool value);
}
member IsHyperText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HyperTextEventArgs Class
Alternet.Editor.TextSource Namespace


HyperTextEventArgs.Text Property

HyperTextEventArgsText Property
Contains string to check.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

HyperTextEventArgs Class
Alternet.Editor.TextSource Namespace


IBookMark Interface

IBookMark Interface
Represents properties and methods to store individual bookmark within Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBookMark
Public Interface IBookMark
public interface class IBookMark
type IBookMark =  interface end

The IBookMark type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IBookMark object.
Top
Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of this IBookMark.
Public property | FileName | When implemented by a class, gets or sets an file name associated with this IBookMark.
Public property | Group | When implemented by a class, gets or sets a category associated with this IBookMark.
Public property | ImageIndex | When implemented by a class, gets or sets an image index associated with this IBookMark.
Public property | Index | When implemented by a class, gets an integer value that specifies ordinal number of the bookmark.
Public property | Line | When implemented by a class, gets Y-coordinate of the position (index of line) within the Edit control's text.
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of this IBookMark.
Public property | Pos | When implemented by a class, gets X-coordinate of the bookmark position (position of character in a line) within the control's text.
Public property | Position | When implemented by a class, gets or sets position of the bookmark within the control's text. Y-Coordinate represents index of line and X-Coordinate - index of character in this line.
Public property | Tag | When implemented by a class, gets or sets user-defined data associated with this IBookMark.
Public property | Url | When implemented by a class, gets or sets an Url address of this IBookMark.
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IBookMark Methods

IBookMark Methods

The IBookMark type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IBookMark object.
Top
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Assign Method

IBookMarkAssign Method
When implemented by a class, copies the contents of another IBookMark object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IBookMark source
)
Sub Assign (
    source As IBookMark
)
void Assign(
    IBookMark^ source
)
abstract Assign :
        source : IBookMark -> unit

Parameters

source
Type: Alternet.Editor.TextSourceIBookMark
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark Properties

IBookMark Properties

The IBookMark type exposes the following members.

Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of this IBookMark.
Public property | FileName | When implemented by a class, gets or sets an file name associated with this IBookMark.
Public property | Group | When implemented by a class, gets or sets a category associated with this IBookMark.
Public property | ImageIndex | When implemented by a class, gets or sets an image index associated with this IBookMark.
Public property | Index | When implemented by a class, gets an integer value that specifies ordinal number of the bookmark.
Public property | Line | When implemented by a class, gets Y-coordinate of the position (index of line) within the Edit control's text.
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of this IBookMark.
Public property | Pos | When implemented by a class, gets X-coordinate of the bookmark position (position of character in a line) within the control's text.
Public property | Position | When implemented by a class, gets or sets position of the bookmark within the control's text. Y-Coordinate represents index of line and X-Coordinate - index of character in this line.
Public property | Tag | When implemented by a class, gets or sets user-defined data associated with this IBookMark.
Public property | Url | When implemented by a class, gets or sets an Url address of this IBookMark.
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark.
Top
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Description Property

IBookMarkDescription Property
When implemented by a class, gets or sets a string value that specifies short description of this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.FileName Property

IBookMarkFileName Property
When implemented by a class, gets or sets an file name associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Group Property

IBookMarkGroup Property
When implemented by a class, gets or sets a category associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Group { get; set; }
Property Group As Integer
    Get
    Set
property int Group {
    int get ();
    void set (int value);
}
abstract Group : int with get, set

Property Value

Type: Int32
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.ImageIndex Property

IBookMarkImageIndex Property
When implemented by a class, gets or sets an image index associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ImageIndex { get; set; }
Property ImageIndex As Integer
    Get
    Set
property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Index Property

IBookMarkIndex Property
When implemented by a class, gets an integer value that specifies ordinal number of the bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Line Property

IBookMarkLine Property
When implemented by a class, gets Y-coordinate of the position (index of line) within the Edit control's text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Line { get; }
ReadOnly Property Line As Integer
    Get
property int Line {
    int get ();
}
abstract Line : int with get

Property Value

Type: Int32
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Name Property

IBookMarkName Property
When implemented by a class, gets or sets a string value that specifies the name of this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Pos Property

IBookMarkPos Property
When implemented by a class, gets X-coordinate of the bookmark position (position of character in a line) within the control's text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Pos { get; }
ReadOnly Property Pos As Integer
    Get
property int Pos {
    int get ();
}
abstract Pos : int with get

Property Value

Type: Int32
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Position Property

IBookMarkPosition Property
When implemented by a class, gets or sets position of the bookmark within the control's text. Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Position { get; set; }
Property Position As Point
    Get
    Set
property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set

Property Value

Type: Point
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Tag Property

IBookMarkTag Property
When implemented by a class, gets or sets user-defined data associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
abstract Tag : Object with get, set

Property Value

Type: Object
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.Url Property

IBookMarkUrl Property
When implemented by a class, gets or sets an Url address of this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Url { get; set; }
Property Url As String
    Get
    Set
property String^ Url {
    String^ get ();
    void set (String^ value);
}
abstract Url : string with get, set

Property Value

Type: String
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMark.ZIndex Property

IBookMarkZIndex Property
When implemented by a class, gets or sets an z-index associated with this IBookMark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ZIndex { get; set; }
Property ZIndex As Integer
    Get
    Set
property int ZIndex {
    int get ();
    void set (int value);
}
abstract ZIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IBookMark Interface
Alternet.Editor.TextSource Namespace


IBookMarkEx Interface

IBookMarkEx Interface
Do not use this class, it's provided for backward compatibility only.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBookMarkEx : IBookMark
Public Interface IBookMarkEx
    Inherits IBookMark
public interface class IBookMarkEx : IBookMark
type IBookMarkEx =
    interface
        interface IBookMark
    end

The IBookMarkEx type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IBookMark object. (Inherited from IBookMark.)
Top
Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of this IBookMark. (Inherited from IBookMark.)
Public property | FileName | When implemented by a class, gets or sets an file name associated with this IBookMark. (Inherited from IBookMark.)
Public property | Group | When implemented by a class, gets or sets a category associated with this IBookMark. (Inherited from IBookMark.)
Public property | ImageIndex | When implemented by a class, gets or sets an image index associated with this IBookMark. (Inherited from IBookMark.)
Public property | Index | When implemented by a class, gets an integer value that specifies ordinal number of the bookmark. (Inherited from IBookMark.)
Public property | Line | When implemented by a class, gets Y-coordinate of the position (index of line) within the Edit control's text. (Inherited from IBookMark.)
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of this IBookMark. (Inherited from IBookMark.)
Public property | Pos | When implemented by a class, gets X-coordinate of the bookmark position (position of character in a line) within the control's text. (Inherited from IBookMark.)
Public property | Position | When implemented by a class, gets or sets position of the bookmark within the control's text. Y-Coordinate represents index of line and X-Coordinate - index of character in this line. (Inherited from IBookMark.)
Public property | Tag | When implemented by a class, gets or sets user-defined data associated with this IBookMark. (Inherited from IBookMark.)
Public property | Url | When implemented by a class, gets or sets an Url address of this IBookMark. (Inherited from IBookMark.)
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark. (Inherited from IBookMark.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IBookMarkEx Methods

IBookMarkEx Methods

The IBookMarkEx type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IBookMark object. (Inherited from IBookMark.)
Top
See Also

Reference

IBookMarkEx Interface
Alternet.Editor.TextSource Namespace


IBookMarkEx Properties

IBookMarkEx Properties

The IBookMarkEx type exposes the following members.

Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of this IBookMark. (Inherited from IBookMark.)
Public property | FileName | When implemented by a class, gets or sets an file name associated with this IBookMark. (Inherited from IBookMark.)
Public property | Group | When implemented by a class, gets or sets a category associated with this IBookMark. (Inherited from IBookMark.)
Public property | ImageIndex | When implemented by a class, gets or sets an image index associated with this IBookMark. (Inherited from IBookMark.)
Public property | Index | When implemented by a class, gets an integer value that specifies ordinal number of the bookmark. (Inherited from IBookMark.)
Public property | Line | When implemented by a class, gets Y-coordinate of the position (index of line) within the Edit control's text. (Inherited from IBookMark.)
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of this IBookMark. (Inherited from IBookMark.)
Public property | Pos | When implemented by a class, gets X-coordinate of the bookmark position (position of character in a line) within the control's text. (Inherited from IBookMark.)
Public property | Position | When implemented by a class, gets or sets position of the bookmark within the control's text. Y-Coordinate represents index of line and X-Coordinate - index of character in this line. (Inherited from IBookMark.)
Public property | Tag | When implemented by a class, gets or sets user-defined data associated with this IBookMark. (Inherited from IBookMark.)
Public property | Url | When implemented by a class, gets or sets an Url address of this IBookMark. (Inherited from IBookMark.)
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark. (Inherited from IBookMark.)
Top
See Also

Reference

IBookMarkEx Interface
Alternet.Editor.TextSource Namespace


IBookMarks Interface

IBookMarks Interface
Represents properties and methods to provide an indexed access to individual IBookMark object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBookMarks : IList<IBookMark>,
    ICollection<IBookMark>, IEnumerable<IBookMark>, IEnumerable
Public Interface IBookMarks
    Inherits IList(Of IBookMark), ICollection(Of IBookMark),
    IEnumerable(Of IBookMark), IEnumerable
public interface class IBookMarks : IList<IBookMark^>,
    ICollection<IBookMark^>, IEnumerable<IBookMark^>, IEnumerable
type IBookMarks =
    interface
        interface IList<IBookMark>
        interface ICollection<IBookMark>
        interface IEnumerable<IBookMark>
        interface IEnumerable
    end

The IBookMarks type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIBookMark .)
Public method | Assign | When implemented by a class, copies the contents from another IBookMarks object.
Public method | BlockDeleting | When implemented by a class, removes all bookmarks within specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIBookMark .)
Public method | ClearAllBookMarks | When implemented by a class, removes all items from the bookmark collection.
Public method | ClearAllUnnumberedBookmarks | When implemented by a class, removes all unnumbered bookmarks from the bookmarks collection.
Public method | ClearBookMark(Int32) | When implemented by a class, finds the bookmark by given index and removes its from bookmark collection.
Public method | ClearBookMark(Int32, Int32) | When implemented by a class, finds the bookmark by given index in a given line and removes its from bookmark collection.
Public method | ClearBookMarks | When implemented by a class, removes all bookmarks from the specified line.
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIBookMark .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIBookMark .)
Public method | FindBookMark(Int32) | When implemented by a class, finds the bookmark with specified Index property within bookmark collection.
Public method | FindBookMark(String) | When implemented by a class, finds the bookmark with specified Name property within bookmark collection.
Public method | FindBookMark(Int32, Point) | When implemented by a class, finds the bookmark with specified Index property within bookmark collection.
Public method | FindBookMark(Int32, Int32) | When implemented by a class, finds the bookmark with specified Index in a specific line within bookmark collection.
Public method | GetBookMark(Int32) | When implemented by a class, finds the first item in the bookmark collection located within the specified text line.
Public method | GetBookMark(Point, Point) | When implemented by a class, finds the first item in the bookmark collection located within the specified scope.
Public method | GetBookMarks(IListIBookMark) | When implemented by a class, finds all items in the bookmark collection.
Public method | GetBookMarks(Point, Point, IListIBookMark) | When implemented by a class, finds all items in the bookmark collection located within the specified scope.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIBookMark .)
Public method | GetImages | When implemented by a class, returns image list by its group.
Public method | GetImagesScaled | Returns image list by its group, scaled for DPI.
Public method | GotoBookMark | When implemented by a class, moves Edit control's caret to the location of the specified bookmark.
Public method | GotoNextBookMark | When implemented by a class, moves Edit control's caret to the location of the next unnumbered bookmark.
Public method | GotoPrevBookMark | When implemented by a class, moves Edit control's caret to the location of the previous unnumbered bookmark.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIBookMark .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIBookMark .)
Public method | NextBookMark | When implemented by a class, returns the minimal possible value of the bookmark's Index property of the new bookmark.
Public method | OnClick | When implemented by a class, raises OnClick event.
Public method | OnDoubleClick | When implemented by a class, raises OnDoubleClick event.
Public method | OnShowTooltip | When implemented by a class, raises OnShowTooltip event.
Public method | PositionChanged | When implemented by a class, updates all bookmarks starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIBookMark .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIBookMark .)
Public method | SetBookMark(IBookMark) | When implemented by a class, sets bookmark specified by bookMark parameter.
Public method | SetBookMark(Point, Int32) | When implemented by a class, sets the bookmark with specified index to the specified position.
Public method | SetBookMark(Int32, Int32) | When implemented by a class, sets the bookmark with specified index to the position specified by Line parameter.
Public method | SetBookMark(Point, Int32, String, String, String) | When implemented by a class, sets the bookmark with specified index, name, description and url to the position specified by Point parameter.
Public method | ToggleBookMark | When implemented by a class, toggles (sets or removes) an unnumbered bookmark on the current line in the control's text.
Public method | ToggleBookMark(Int32) | When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the current line.
Public method | ToggleBookMark(IBookMark) | When implemented by a class, toggles (sets or removes) specified bookmark.
Public method | ToggleBookMark(Point, Int32) | When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the specified position.
Public method | ToggleBookMark(Int32, Int32) | When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the specified line.
Public method | ToggleBookMark(Point, Int32, String, String, String) | When implemented by a class, toggles (sets or removes) the bookmark with specified index, name, description and url to the position specified by Point parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIBookMark | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIBookMark | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIBookMark, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIBookMark .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIBookMark .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIBookMark .)
Public property | Shared | When implemented by a class, specifies if bookmarks should be shared across all documents.
Top
Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when Bookmark is being clicked.
Public event | DoubleClick | When implemented by a class, occurs when Bookmark is being double clicked.
Public event | ShowToolTip | When implemented by a class, occurs when Bookmark Tooltip needs to be displayed.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IBookMarks Methods

IBookMarks Methods

The IBookMarks type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIBookMark .)
Public method | Assign | When implemented by a class, copies the contents from another IBookMarks object.
Public method | BlockDeleting | When implemented by a class, removes all bookmarks within specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIBookMark .)
Public method | ClearAllBookMarks | When implemented by a class, removes all items from the bookmark collection.
Public method | ClearAllUnnumberedBookmarks | When implemented by a class, removes all unnumbered bookmarks from the bookmarks collection.
Public method | ClearBookMark(Int32) | When implemented by a class, finds the bookmark by given index and removes its from bookmark collection.
Public method | ClearBookMark(Int32, Int32) | When implemented by a class, finds the bookmark by given index in a given line and removes its from bookmark collection.
Public method | ClearBookMarks | When implemented by a class, removes all bookmarks from the specified line.
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIBookMark .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIBookMark .)
Public method | FindBookMark(Int32) | When implemented by a class, finds the bookmark with specified Index property within bookmark collection.
Public method | FindBookMark(String) | When implemented by a class, finds the bookmark with specified Name property within bookmark collection.
Public method | FindBookMark(Int32, Point) | When implemented by a class, finds the bookmark with specified Index property within bookmark collection.
Public method | FindBookMark(Int32, Int32) | When implemented by a class, finds the bookmark with specified Index in a specific line within bookmark collection.
Public method | GetBookMark(Int32) | When implemented by a class, finds the first item in the bookmark collection located within the specified text line.
Public method | GetBookMark(Point, Point) | When implemented by a class, finds the first item in the bookmark collection located within the specified scope.
Public method | GetBookMarks(IListIBookMark) | When implemented by a class, finds all items in the bookmark collection.
Public method | GetBookMarks(Point, Point, IListIBookMark) | When implemented by a class, finds all items in the bookmark collection located within the specified scope.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIBookMark .)
Public method | GetImages | When implemented by a class, returns image list by its group.
Public method | GetImagesScaled | Returns image list by its group, scaled for DPI.
Public method | GotoBookMark | When implemented by a class, moves Edit control's caret to the location of the specified bookmark.
Public method | GotoNextBookMark | When implemented by a class, moves Edit control's caret to the location of the next unnumbered bookmark.
Public method | GotoPrevBookMark | When implemented by a class, moves Edit control's caret to the location of the previous unnumbered bookmark.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIBookMark .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIBookMark .)
Public method | NextBookMark | When implemented by a class, returns the minimal possible value of the bookmark's Index property of the new bookmark.
Public method | OnClick | When implemented by a class, raises OnClick event.
Public method | OnDoubleClick | When implemented by a class, raises OnDoubleClick event.
Public method | OnShowTooltip | When implemented by a class, raises OnShowTooltip event.
Public method | PositionChanged | When implemented by a class, updates all bookmarks starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIBookMark .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIBookMark .)
Public method | SetBookMark(IBookMark) | When implemented by a class, sets bookmark specified by bookMark parameter.
Public method | SetBookMark(Point, Int32) | When implemented by a class, sets the bookmark with specified index to the specified position.
Public method | SetBookMark(Int32, Int32) | When implemented by a class, sets the bookmark with specified index to the position specified by Line parameter.
Public method | SetBookMark(Point, Int32, String, String, String) | When implemented by a class, sets the bookmark with specified index, name, description and url to the position specified by Point parameter.
Public method | ToggleBookMark | When implemented by a class, toggles (sets or removes) an unnumbered bookmark on the current line in the control's text.
Public method | ToggleBookMark(Int32) | When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the current line.
Public method | ToggleBookMark(IBookMark) | When implemented by a class, toggles (sets or removes) specified bookmark.
Public method | ToggleBookMark(Point, Int32) | When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the specified position.
Public method | ToggleBookMark(Int32, Int32) | When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the specified line.
Public method | ToggleBookMark(Point, Int32, String, String, String) | When implemented by a class, toggles (sets or removes) the bookmark with specified index, name, description and url to the position specified by Point parameter.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIBookMark | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIBookMark | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIBookMark, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.Assign Method

IBookMarksAssign Method
When implemented by a class, copies the contents from another IBookMarks object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    IBookMarks source
)
Sub Assign (
    source As IBookMarks
)
void Assign(
    IBookMarks^ source
)
abstract Assign :
        source : IBookMarks -> unit

Parameters

source
Type: Alternet.Editor.TextSourceIBookMarks
Specifies IBookMarks to assign.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.BlockDeleting Method

IBookMarksBlockDeleting Method
When implemented by a class, removes all bookmarks within specified rectangle.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BlockDeleting(
    Rectangle rect
)
Function BlockDeleting (
    rect As Rectangle
) As Boolean
bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to check.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.ClearAllBookMarks Method

IBookMarksClearAllBookMarks Method
When implemented by a class, removes all items from the bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearAllBookMarks()
Sub ClearAllBookMarks
void ClearAllBookMarks()
abstract ClearAllBookMarks : unit -> unit
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.ClearAllUnnumberedBookmarks Method

IBookMarksClearAllUnnumberedBookmarks Method
When implemented by a class, removes all unnumbered bookmarks from the bookmarks collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearAllUnnumberedBookmarks()
Sub ClearAllUnnumberedBookmarks
void ClearAllUnnumberedBookmarks()
abstract ClearAllUnnumberedBookmarks : unit -> unit
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.ClearBookMark Method

IBookMarksClearBookMark Method
Overload List
 | Name | Description
Public method | ClearBookMark(Int32) | When implemented by a class, finds the bookmark by given index and removes its from bookmark collection.
Public method | ClearBookMark(Int32, Int32) | When implemented by a class, finds the bookmark by given index in a given line and removes its from bookmark collection.
Top
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.ClearBookMark Method (Int32)

IBookMarksClearBookMark Method (Int32)
When implemented by a class, finds the bookmark by given index and removes its from bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearBookMark(
    int bookMark
)
Sub ClearBookMark (
    bookMark As Integer
)
void ClearBookMark(
    int bookMark
)
abstract ClearBookMark :
        bookMark : int -> unit

Parameters

bookMark
Type: SystemInt32
Index of the bookmark in the bookmark collection.
See Also

Reference

IBookMarks Interface
ClearBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.ClearBookMark Method (Int32, Int32)

IBookMarksClearBookMark Method (Int32, Int32)
When implemented by a class, finds the bookmark by given index in a given line and removes its from bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearBookMark(
    int line,
    int bookmark
)
Sub ClearBookMark (
    line As Integer,
    bookmark As Integer
)
void ClearBookMark(
    int line,
    int bookmark
)
abstract ClearBookMark :
        line : int *
        bookmark : int -> unit

Parameters

line
Type: SystemInt32
Index of line in lines collection.
bookmark
Type: SystemInt32
Index of the bookmark in the bookmark collection.
See Also

Reference

IBookMarks Interface
ClearBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.ClearBookMarks Method

IBookMarksClearBookMarks Method
When implemented by a class, removes all bookmarks from the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearBookMarks(
    int line
)
Sub ClearBookMarks (
    line As Integer
)
void ClearBookMarks(
    int line
)
abstract ClearBookMarks :
        line : int -> unit

Parameters

line
Type: SystemInt32
The integer value that specifies index of the text line.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.FindBookMark Method

IBookMarksFindBookMark Method
Overload List
 | Name | Description
Public method | FindBookMark(Int32) | When implemented by a class, finds the bookmark with specified Index property within bookmark collection.
Public method | FindBookMark(String) | When implemented by a class, finds the bookmark with specified Name property within bookmark collection.
Public method | FindBookMark(Int32, Point) | When implemented by a class, finds the bookmark with specified Index property within bookmark collection.
Public method | FindBookMark(Int32, Int32) | When implemented by a class, finds the bookmark with specified Index in a specific line within bookmark collection.
Top
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.FindBookMark Method (Int32)

IBookMarksFindBookMark Method (Int32)
When implemented by a class, finds the bookmark with specified Index property within bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IBookMark FindBookMark(
    int bookMark
)
Function FindBookMark (
    bookMark As Integer
) As IBookMark
IBookMark^ FindBookMark(
    int bookMark
)
abstract FindBookMark :
        bookMark : int -> IBookMark

Parameters

bookMark
Type: SystemInt32
Specifies bookmark Index.

Return Value

Type: IBookMark
IBookMark object found.
See Also

Reference

IBookMarks Interface
FindBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.FindBookMark Method (String)

IBookMarksFindBookMark Method (String)
When implemented by a class, finds the bookmark with specified Name property within bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IBookMark FindBookMark(
    string name
)
Function FindBookMark (
    name As String
) As IBookMark
IBookMark^ FindBookMark(
    String^ name
)
abstract FindBookMark :
        name : string -> IBookMark

Parameters

name
Type: SystemString
Specifies bookmark name.

Return Value

Type: IBookMark
IBookMark object found.
See Also

Reference

IBookMarks Interface
FindBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.FindBookMark Method (Int32, Point)

IBookMarksFindBookMark Method (Int32, Point)
When implemented by a class, finds the bookmark with specified Index property within bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindBookMark(
    int bookMark,
    out Point position
)
Function FindBookMark (
    bookMark As Integer,
    <OutAttribute> ByRef position As Point
) As Boolean
bool FindBookMark(
    int bookMark,
    [OutAttribute] Point% position
)
abstract FindBookMark :
        bookMark : int *
        position : Point byref -> bool

Parameters

bookMark
Type: SystemInt32
Specifies bookmark index.
position
Type: System.DrawingPoint
Receives position(index of character and line) of the found bookmark.

Return Value

Type: Boolean
True if the bookmark successfully found; otherwise false.
See Also

Reference

IBookMarks Interface
FindBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.FindBookMark Method (Int32, Int32)

IBookMarksFindBookMark Method (Int32, Int32)
When implemented by a class, finds the bookmark with specified Index in a specific line within bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IBookMark FindBookMark(
    int bookMark,
    int line
)
Function FindBookMark (
    bookMark As Integer,
    line As Integer
) As IBookMark
IBookMark^ FindBookMark(
    int bookMark,
    int line
)
abstract FindBookMark :
        bookMark : int *
        line : int -> IBookMark

Parameters

bookMark
Type: SystemInt32
Specifies bookmark Index.
line
Type: SystemInt32
Specifies line Index.

Return Value

Type: IBookMark
IBookMark object found.
See Also

Reference

IBookMarks Interface
FindBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.GetBookMark Method

IBookMarksGetBookMark Method
Overload List
 | Name | Description
Public method | GetBookMark(Int32) | When implemented by a class, finds the first item in the bookmark collection located within the specified text line.
Public method | GetBookMark(Point, Point) | When implemented by a class, finds the first item in the bookmark collection located within the specified scope.
Top
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.GetBookMark Method (Int32)

IBookMarksGetBookMark Method (Int32)
When implemented by a class, finds the first item in the bookmark collection located within the specified text line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetBookMark(
    int line
)
Function GetBookMark (
    line As Integer
) As Integer
int GetBookMark(
    int line
)
abstract GetBookMark :
        line : int -> int

Parameters

line
Type: SystemInt32
Index of the text line.

Return Value

Type: Int32
Index of the found bookmark.
See Also

Reference

IBookMarks Interface
GetBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.GetBookMark Method (Point, Point)

IBookMarksGetBookMark Method (Point, Point)
When implemented by a class, finds the first item in the bookmark collection located within the specified scope.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetBookMark(
    Point startPoint,
    Point endPoint
)
Function GetBookMark (
    startPoint As Point,
    endPoint As Point
) As Integer
int GetBookMark(
    Point startPoint,
    Point endPoint
)
abstract GetBookMark :
        startPoint : Point *
        endPoint : Point -> int

Parameters

startPoint
Type: System.DrawingPoint
The Point value that specifies start position to search.
endPoint
Type: System.DrawingPoint
The Point value that specifies end position to search.

Return Value

Type: Int32
Index of the found bookmark.
See Also

Reference

IBookMarks Interface
GetBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.GetBookMarks Method

IBookMarksGetBookMarks Method
Overload List
 | Name | Description
Public method | GetBookMarks(IListIBookMark) | When implemented by a class, finds all items in the bookmark collection.
Public method | GetBookMarks(Point, Point, IListIBookMark) | When implemented by a class, finds all items in the bookmark collection located within the specified scope.
Top
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.GetBookMarks Method (IList(IBookMark))

IBookMarksGetBookMarks Method (IListIBookMark)
When implemented by a class, finds all items in the bookmark collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetBookMarks(
    IList<IBookMark> list
)
Function GetBookMarks (
    list As IList(Of IBookMark)
) As Integer
int GetBookMarks(
    IList<IBookMark^>^ list
)
abstract GetBookMarks :
        list : IList<IBookMark> -> int

Parameters

list
Type: System.Collections.GenericIListIBookMark
Represents the collection of the bookmarks located within the specified scope.

Return Value

Type: Int32
Index of the located bookmarks.
See Also

Reference

IBookMarks Interface
GetBookMarks Overload
Alternet.Editor.TextSource Namespace


IBookMarks.GetBookMarks Method (Point, Point, IList(IBookMark))

IBookMarksGetBookMarks Method (Point, Point, IListIBookMark)
When implemented by a class, finds all items in the bookmark collection located within the specified scope.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetBookMarks(
    Point startPoint,
    Point endPoint,
    IList<IBookMark> list
)
Function GetBookMarks (
    startPoint As Point,
    endPoint As Point,
    list As IList(Of IBookMark)
) As Integer
int GetBookMarks(
    Point startPoint,
    Point endPoint,
    IList<IBookMark^>^ list
)
abstract GetBookMarks :
        startPoint : Point *
        endPoint : Point *
        list : IList<IBookMark> -> int

Parameters

startPoint
Type: System.DrawingPoint
The Point value that specifies start position to search.
endPoint
Type: System.DrawingPoint
The Point value that specifies end position to search.
list
Type: System.Collections.GenericIListIBookMark
Represents the collection of the bookmarks located within the specified scope.

Return Value

Type: Int32
Index of the located bookmarks.
See Also

Reference

IBookMarks Interface
GetBookMarks Overload
Alternet.Editor.TextSource Namespace


IBookMarks.GetImages Method

IBookMarksGetImages Method
When implemented by a class, returns image list by its group.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList GetImages(
    int category
)
Function GetImages (
    category As Integer
) As ImageList
ImageList^ GetImages(
    int category
)
abstract GetImages :
        category : int -> ImageList

Parameters

category
Type: SystemInt32
Given category.

Return Value

Type: ImageList
ImageList associated with category.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.GetImagesScaled Method

IBookMarksGetImagesScaled Method
Returns image list by its group, scaled for DPI.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList GetImagesScaled(
    int group
)
Function GetImagesScaled (
    group As Integer
) As ImageList
ImageList^ GetImagesScaled(
    int group
)
abstract GetImagesScaled :
        group : int -> ImageList

Parameters

group
Type: SystemInt32
Given group.

Return Value

Type: ImageList
ImageList associated with group.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.GotoBookMark Method

IBookMarksGotoBookMark Method
When implemented by a class, moves Edit control's caret to the location of the specified bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GotoBookMark(
    int bookMark
)
Sub GotoBookMark (
    bookMark As Integer
)
void GotoBookMark(
    int bookMark
)
abstract GotoBookMark :
        bookMark : int -> unit

Parameters

bookMark
Type: SystemInt32
Specifies Index property of the bookmark.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.GotoNextBookMark Method

IBookMarksGotoNextBookMark Method
When implemented by a class, moves Edit control's caret to the location of the next unnumbered bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GotoNextBookMark()
Sub GotoNextBookMark
void GotoNextBookMark()
abstract GotoNextBookMark : unit -> unit
Remarks
If the currently selected bookmark is the last bookmark within the bookmarks collection the method moves to the first bookmark.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.GotoPrevBookMark Method

IBookMarksGotoPrevBookMark Method
When implemented by a class, moves Edit control's caret to the location of the previous unnumbered bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GotoPrevBookMark()
Sub GotoPrevBookMark
void GotoPrevBookMark()
abstract GotoPrevBookMark : unit -> unit
Remarks
If the currently selected bookmark is the first bookmark within the bookmarks collection the method moves to the last bookmark.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.NextBookMark Method

IBookMarksNextBookMark Method
When implemented by a class, returns the minimal possible value of the bookmark's Index property of the new bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int NextBookMark()
Function NextBookMark As Integer
int NextBookMark()
abstract NextBookMark : unit -> int

Return Value

Type: Int32
Bookmark index.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.OnClick Method

IBookMarksOnClick Method
When implemented by a class, raises OnClick event.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnClick(
    IBookMark bookMark
)
Sub OnClick (
    bookMark As IBookMark
)
void OnClick(
    IBookMark^ bookMark
)
abstract OnClick :
        bookMark : IBookMark -> unit

Parameters

bookMark
Type: Alternet.Editor.TextSourceIBookMark
Bookmark being clicked.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.OnDoubleClick Method

IBookMarksOnDoubleClick Method
When implemented by a class, raises OnDoubleClick event.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnDoubleClick(
    IBookMark bookMark
)
Sub OnDoubleClick (
    bookMark As IBookMark
)
void OnDoubleClick(
    IBookMark^ bookMark
)
abstract OnDoubleClick :
        bookMark : IBookMark -> unit

Parameters

bookMark
Type: Alternet.Editor.TextSourceIBookMark
Bookmark being clicked.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.OnShowTooltip Method

IBookMarksOnShowTooltip Method
When implemented by a class, raises OnShowTooltip event.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OnShowTooltip(
    ref string tooltip,
    IBookMark bookMark
)
Function OnShowTooltip (
    ByRef tooltip As String,
    bookMark As IBookMark
) As Boolean
bool OnShowTooltip(
    String^% tooltip,
    IBookMark^ bookMark
)
abstract OnShowTooltip :
        tooltip : string byref *
        bookMark : IBookMark -> bool

Parameters

tooltip
Type: SystemString
Tooltip to be displayed.
bookMark
Type: Alternet.Editor.TextSourceIBookMark
Bookmark under the mouse cursor.

Return Value

Type: Boolean
True if event is handled, otherwise false.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.PositionChanged Method

IBookMarksPositionChanged Method
When implemented by a class, updates all bookmarks starting from specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.SetBookMark Method

IBookMarksSetBookMark Method
Overload List
 | Name | Description
Public method | SetBookMark(IBookMark) | When implemented by a class, sets bookmark specified by bookMark parameter.
Public method | SetBookMark(Point, Int32) | When implemented by a class, sets the bookmark with specified index to the specified position.
Public method | SetBookMark(Int32, Int32) | When implemented by a class, sets the bookmark with specified index to the position specified by Line parameter.
Public method | SetBookMark(Point, Int32, String, String, String) | When implemented by a class, sets the bookmark with specified index, name, description and url to the position specified by Point parameter.
Top
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.SetBookMark Method (IBookMark)

IBookMarksSetBookMark Method (IBookMark)
When implemented by a class, sets bookmark specified by bookMark parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetBookMark(
    IBookMark bookMark
)
Sub SetBookMark (
    bookMark As IBookMark
)
void SetBookMark(
    IBookMark^ bookMark
)
abstract SetBookMark :
        bookMark : IBookMark -> unit

Parameters

bookMark
Type: Alternet.Editor.TextSourceIBookMark
Specifies bookmark to set.
See Also

Reference

IBookMarks Interface
SetBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.SetBookMark Method (Point, Int32)

IBookMarksSetBookMark Method (Point, Int32)
When implemented by a class, sets the bookmark with specified index to the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetBookMark(
    Point position,
    int bookMark
)
Sub SetBookMark (
    position As Point,
    bookMark As Integer
)
void SetBookMark(
    Point position,
    int bookMark
)
abstract SetBookMark :
        position : Point *
        bookMark : int -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the bookmark.
bookMark
Type: SystemInt32
The integer value that specifies index of the bookmark.
See Also

Reference

IBookMarks Interface
SetBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.SetBookMark Method (Int32, Int32)

IBookMarksSetBookMark Method (Int32, Int32)
When implemented by a class, sets the bookmark with specified index to the position specified by Line parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetBookMark(
    int line,
    int bookMark
)
Sub SetBookMark (
    line As Integer,
    bookMark As Integer
)
void SetBookMark(
    int line,
    int bookMark
)
abstract SetBookMark :
        line : int *
        bookMark : int -> unit

Parameters

line
Type: SystemInt32
The integer value that specifies index of the text line.
bookMark
Type: SystemInt32
The integer value that specifies bookmark index.
See Also

Reference

IBookMarks Interface
SetBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.SetBookMark Method (Point, Int32, String, String, String)

IBookMarksSetBookMark Method (Point, Int32, String, String, String)
When implemented by a class, sets the bookmark with specified index, name, description and url to the position specified by Point parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetBookMark(
    Point position,
    int bookMark,
    string name,
    string description,
    string url
)
Sub SetBookMark (
    position As Point,
    bookMark As Integer,
    name As String,
    description As String,
    url As String
)
void SetBookMark(
    Point position,
    int bookMark,
    String^ name,
    String^ description,
    String^ url
)
abstract SetBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the BookMark.
bookMark
Type: SystemInt32
The integer value that specifies BookMark index.
name
Type: SystemString
The string value that specifies BookMark name.
description
Type: SystemString
The string value that specifies BookMark description.
url
Type: SystemString
The string value that specifies BookMark url.
See Also

Reference

IBookMarks Interface
SetBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.ToggleBookMark Method

IBookMarksToggleBookMark Method
Overload List
 | Name | Description
Public method | ToggleBookMark | When implemented by a class, toggles (sets or removes) an unnumbered bookmark on the current line in the control's text.
Public method | ToggleBookMark(Int32) | When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the current line.
Public method | ToggleBookMark(IBookMark) | When implemented by a class, toggles (sets or removes) specified bookmark.
Public method | ToggleBookMark(Point, Int32) | When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the specified position.
Public method | ToggleBookMark(Int32, Int32) | When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the specified line.
Public method | ToggleBookMark(Point, Int32, String, String, String) | When implemented by a class, toggles (sets or removes) the bookmark with specified index, name, description and url to the position specified by Point parameter.
Top
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.ToggleBookMark Method

IBookMarksToggleBookMark Method
When implemented by a class, toggles (sets or removes) an unnumbered bookmark on the current line in the control's text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleBookMark()
Sub ToggleBookMark
void ToggleBookMark()
abstract ToggleBookMark : unit -> unit
See Also

Reference

IBookMarks Interface
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.ToggleBookMark Method (Int32)

IBookMarksToggleBookMark Method (Int32)
When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the current line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleBookMark(
    int bookMark
)
Sub ToggleBookMark (
    bookMark As Integer
)
void ToggleBookMark(
    int bookMark
)
abstract ToggleBookMark :
        bookMark : int -> unit

Parameters

bookMark
Type: SystemInt32
See Also

Reference

IBookMarks Interface
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.ToggleBookMark Method (IBookMark)

IBookMarksToggleBookMark Method (IBookMark)
When implemented by a class, toggles (sets or removes) specified bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleBookMark(
    IBookMark bookMark
)
Sub ToggleBookMark (
    bookMark As IBookMark
)
void ToggleBookMark(
    IBookMark^ bookMark
)
abstract ToggleBookMark :
        bookMark : IBookMark -> unit

Parameters

bookMark
Type: Alternet.Editor.TextSourceIBookMark
Specifies bookmark to toggle.
See Also

Reference

IBookMarks Interface
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.ToggleBookMark Method (Point, Int32)

IBookMarksToggleBookMark Method (Point, Int32)
When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleBookMark(
    Point position,
    int bookMark
)
Sub ToggleBookMark (
    position As Point,
    bookMark As Integer
)
void ToggleBookMark(
    Point position,
    int bookMark
)
abstract ToggleBookMark :
        position : Point *
        bookMark : int -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the bookmark (index of character and current line).
bookMark
Type: SystemInt32
Specifies Index property of the bookmark to toggle.
See Also

Reference

IBookMarks Interface
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.ToggleBookMark Method (Int32, Int32)

IBookMarksToggleBookMark Method (Int32, Int32)
When implemented by a class, toggles (sets or removes) bookmark with specified Index property at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleBookMark(
    int line,
    int bookMark
)
Sub ToggleBookMark (
    line As Integer,
    bookMark As Integer
)
void ToggleBookMark(
    int line,
    int bookMark
)
abstract ToggleBookMark :
        line : int *
        bookMark : int -> unit

Parameters

line
Type: SystemInt32
Index of line to toggle.
bookMark
Type: SystemInt32
Specifies Index property of the bookmark to toggle.
See Also

Reference

IBookMarks Interface
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks.ToggleBookMark Method (Point, Int32, String, String, String)

IBookMarksToggleBookMark Method (Point, Int32, String, String, String)
When implemented by a class, toggles (sets or removes) the bookmark with specified index, name, description and url to the position specified by Point parameter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleBookMark(
    Point position,
    int bookMark,
    string name,
    string description,
    string url
)
Sub ToggleBookMark (
    position As Point,
    bookMark As Integer,
    name As String,
    description As String,
    url As String
)
void ToggleBookMark(
    Point position,
    int bookMark,
    String^ name,
    String^ description,
    String^ url
)
abstract ToggleBookMark :
        position : Point *
        bookMark : int *
        name : string *
        description : string *
        url : string -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position of the bookmark to toggle.
bookMark
Type: SystemInt32
Specifies BookMark index.
name
Type: SystemString
Specifies BookMark name.
description
Type: SystemString
Specifies BookMark description.
url
Type: SystemString
Specifies BookMark url.
See Also

Reference

IBookMarks Interface
ToggleBookMark Overload
Alternet.Editor.TextSource Namespace


IBookMarks Properties

IBookMarks Properties

The IBookMarks type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIBookMark .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIBookMark .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIBookMark .)
Public property | Shared | When implemented by a class, specifies if bookmarks should be shared across all documents.
Top
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.Shared Property

IBookMarksShared Property
When implemented by a class, specifies if bookmarks should be shared across all documents.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Shared { get; set; }
Property Shared As Boolean
    Get
    Set
property bool Shared {
    bool get ();
    void set (bool value);
}
abstract Shared : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks Events

IBookMarks Events

The IBookMarks type exposes the following members.

Events
 | Name | Description
Public event | Click | When implemented by a class, occurs when Bookmark is being clicked.
Public event | DoubleClick | When implemented by a class, occurs when Bookmark is being double clicked.
Public event | ShowToolTip | When implemented by a class, occurs when Bookmark Tooltip needs to be displayed.
Top
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.Click Event

IBookMarksClick Event
When implemented by a class, occurs when Bookmark is being clicked.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event BookmarkClickEvent Click
Event Click As BookmarkClickEvent
 event BookmarkClickEvent^ Click {
    void add (BookmarkClickEvent^ value);
    void remove (BookmarkClickEvent^ value);
}
abstract Click : IEvent<BookmarkClickEvent,
    BookmarkClickEventArgs>

Value

Type: BookmarkClickEvent
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.DoubleClick Event

IBookMarksDoubleClick Event
When implemented by a class, occurs when Bookmark is being double clicked.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event BookmarkClickEvent DoubleClick
Event DoubleClick As BookmarkClickEvent
 event BookmarkClickEvent^ DoubleClick {
    void add (BookmarkClickEvent^ value);
    void remove (BookmarkClickEvent^ value);
}
abstract DoubleClick : IEvent<BookmarkClickEvent,
    BookmarkClickEventArgs>

Value

Type: BookmarkClickEvent
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBookMarks.ShowToolTip Event

IBookMarksShowToolTip Event
When implemented by a class, occurs when Bookmark Tooltip needs to be displayed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event TooltipEvent ShowToolTip
Event ShowToolTip As TooltipEvent
 event TooltipEvent^ ShowToolTip {
    void add (TooltipEvent^ value);
    void remove (TooltipEvent^ value);
}
abstract ShowToolTip : IEvent<TooltipEvent,
    ToolTipEventArgs>

Value

Type: TooltipEvent
See Also

Reference

IBookMarks Interface
Alternet.Editor.TextSource Namespace


IBraceMatching Interface

IBraceMatching Interface
Represents properties and methods to handle matching braces within the Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBraceMatching
Public Interface IBraceMatching
public interface class IBraceMatching
type IBraceMatching =  interface end

The IBraceMatching type exposes the following members.

Methods
 | Name | Description
Public method | FindClosingBrace(Point) | When implemented by a class, locates closing brace.
Public method | FindClosingBrace(Int32, Int32) | When implemented by a class, locates closing brace.
Public method | FindOpenBrace(Point) | When implemented by a class, locates open brace.
Public method | FindOpenBrace(Int32, Int32) | When implemented by a class, locates open brace.
Public method | HighlightBraces | When implemented by a class, highlights braces containing caret position.
Public method | ResetBracesOptions | When implemented by a class, resets the BracesOptions to its default value.
Public method | ResetClosingBraces | When implemented by a class, resets the ClosingBraces to its default value.
Public method | ResetOpenBraces | When implemented by a class, resets the OpenBraces to its default value.
Public method | TempHighlightBraces | When implemented by a class, temporary highlights all text within the area specified by rects.
Public method | TempUnhighlightBraces | When implemented by a class, cancels text highlighting turned on using TempHighlightBraces
Public method | UnhighlightBraces | When implemented by a class, unhighlights braces containing caret position.
Top
Properties
 | Name | Description
Public property | BracesOptions | When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control.
Public property | ClosingBraces | When implemented by a class, gets or sets an array of characters each one representing a closing brace.
Public property | OpenBraces | When implemented by a class, gets or sets an array of characters each one representing an open brace.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IBraceMatching Methods

IBraceMatching Methods

The IBraceMatching type exposes the following members.

Methods
 | Name | Description
Public method | FindClosingBrace(Point) | When implemented by a class, locates closing brace.
Public method | FindClosingBrace(Int32, Int32) | When implemented by a class, locates closing brace.
Public method | FindOpenBrace(Point) | When implemented by a class, locates open brace.
Public method | FindOpenBrace(Int32, Int32) | When implemented by a class, locates open brace.
Public method | HighlightBraces | When implemented by a class, highlights braces containing caret position.
Public method | ResetBracesOptions | When implemented by a class, resets the BracesOptions to its default value.
Public method | ResetClosingBraces | When implemented by a class, resets the ClosingBraces to its default value.
Public method | ResetOpenBraces | When implemented by a class, resets the OpenBraces to its default value.
Public method | TempHighlightBraces | When implemented by a class, temporary highlights all text within the area specified by rects.
Public method | TempUnhighlightBraces | When implemented by a class, cancels text highlighting turned on using TempHighlightBraces
Public method | UnhighlightBraces | When implemented by a class, unhighlights braces containing caret position.
Top
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


IBraceMatching.FindClosingBrace Method

IBraceMatchingFindClosingBrace Method
Overload List
 | Name | Description
Public method | FindClosingBrace(Point) | When implemented by a class, locates closing brace.
Public method | FindClosingBrace(Int32, Int32) | When implemented by a class, locates closing brace.
Top
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


IBraceMatching.FindClosingBrace Method (Point)

IBraceMatchingFindClosingBrace Method (Point)
When implemented by a class, locates closing brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindClosingBrace(
    ref Point position
)
Function FindClosingBrace (
    ByRef position As Point
) As Boolean
bool FindClosingBrace(
    Point% position
)
abstract FindClosingBrace :
        position : Point byref -> bool

Parameters

position
Type: System.DrawingPoint
Retrieves position of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IBraceMatching Interface
FindClosingBrace Overload
Alternet.Editor.TextSource Namespace


IBraceMatching.FindClosingBrace Method (Int32, Int32)

IBraceMatchingFindClosingBrace Method (Int32, Int32)
When implemented by a class, locates closing brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindClosingBrace(
    ref int x,
    ref int y
)
Function FindClosingBrace (
    ByRef x As Integer,
    ByRef y As Integer
) As Boolean
bool FindClosingBrace(
    int% x,
    int% y
)
abstract FindClosingBrace :
        x : int byref *
        y : int byref -> bool

Parameters

x
Type: SystemInt32
Retrieves X-coordinate of the found brace.
y
Type: SystemInt32
Retrieves Y-coordinate of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IBraceMatching Interface
FindClosingBrace Overload
Alternet.Editor.TextSource Namespace


IBraceMatching.FindOpenBrace Method

IBraceMatchingFindOpenBrace Method
Overload List
 | Name | Description
Public method | FindOpenBrace(Point) | When implemented by a class, locates open brace.
Public method | FindOpenBrace(Int32, Int32) | When implemented by a class, locates open brace.
Top
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


IBraceMatching.FindOpenBrace Method (Point)

IBraceMatchingFindOpenBrace Method (Point)
When implemented by a class, locates open brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindOpenBrace(
    ref Point position
)
Function FindOpenBrace (
    ByRef position As Point
) As Boolean
bool FindOpenBrace(
    Point% position
)
abstract FindOpenBrace :
        position : Point byref -> bool

Parameters

position
Type: System.DrawingPoint
Retrieves position of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IBraceMatching Interface
FindOpenBrace Overload
Alternet.Editor.TextSource Namespace


IBraceMatching.FindOpenBrace Method (Int32, Int32)

IBraceMatchingFindOpenBrace Method (Int32, Int32)
When implemented by a class, locates open brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindOpenBrace(
    ref int x,
    ref int y
)
Function FindOpenBrace (
    ByRef x As Integer,
    ByRef y As Integer
) As Boolean
bool FindOpenBrace(
    int% x,
    int% y
)
abstract FindOpenBrace :
        x : int byref *
        y : int byref -> bool

Parameters

x
Type: SystemInt32
Retrieves X-coordinate of the found brace.
y
Type: SystemInt32
Retrieves Y-coordinate of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IBraceMatching Interface
FindOpenBrace Overload
Alternet.Editor.TextSource Namespace


IBraceMatching.HighlightBraces Method

IBraceMatchingHighlightBraces Method
When implemented by a class, highlights braces containing caret position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HighlightBraces()
Sub HighlightBraces
void HighlightBraces()
abstract HighlightBraces : unit -> unit
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace
IBraceMatchingUnhighlightBraces


IBraceMatching.ResetBracesOptions Method

IBraceMatchingResetBracesOptions Method
When implemented by a class, resets the BracesOptions to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBracesOptions()
Sub ResetBracesOptions
void ResetBracesOptions()
abstract ResetBracesOptions : unit -> unit
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


IBraceMatching.ResetClosingBraces Method

IBraceMatchingResetClosingBraces Method
When implemented by a class, resets the ClosingBraces to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetClosingBraces()
Sub ResetClosingBraces
void ResetClosingBraces()
abstract ResetClosingBraces : unit -> unit
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


IBraceMatching.ResetOpenBraces Method

IBraceMatchingResetOpenBraces Method
When implemented by a class, resets the OpenBraces to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOpenBraces()
Sub ResetOpenBraces
void ResetOpenBraces()
abstract ResetOpenBraces : unit -> unit
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


IBraceMatching.TempHighlightBraces Method

IBraceMatchingTempHighlightBraces Method
When implemented by a class, temporary highlights all text within the area specified by rects.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TempHighlightBraces(
    Rectangle[] rects
)
Sub TempHighlightBraces (
    rects As Rectangle()
)
void TempHighlightBraces(
    array<Rectangle>^ rects
)
abstract TempHighlightBraces :
        rects : Rectangle[] -> unit

Parameters

rects
Type: System.DrawingRectangle
Specifies the area to highlight the text.
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace
IBraceMatchingTempUnhighlightBraces


IBraceMatching.TempUnhighlightBraces Method

IBraceMatchingTempUnhighlightBraces Method
When implemented by a class, cancels text highlighting turned on using TempHighlightBraces

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TempUnhighlightBraces()
Sub TempUnhighlightBraces
void TempUnhighlightBraces()
abstract TempUnhighlightBraces : unit -> unit
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace
IBraceMatchingTempHighlightBraces(Rectangle)


IBraceMatching.UnhighlightBraces Method

IBraceMatchingUnhighlightBraces Method
When implemented by a class, unhighlights braces containing caret position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnhighlightBraces()
Sub UnhighlightBraces
void UnhighlightBraces()
abstract UnhighlightBraces : unit -> unit
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace
IBraceMatchingHighlightBraces


IBraceMatching Properties

IBraceMatching Properties

The IBraceMatching type exposes the following members.

Properties
 | Name | Description
Public property | BracesOptions | When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control.
Public property | ClosingBraces | When implemented by a class, gets or sets an array of characters each one representing a closing brace.
Public property | OpenBraces | When implemented by a class, gets or sets an array of characters each one representing an open brace.
Top
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


IBraceMatching.BracesOptions Property

IBraceMatchingBracesOptions Property
When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
BracesOptions BracesOptions { get; set; }
Property BracesOptions As BracesOptions
    Get
    Set
property BracesOptions BracesOptions {
    BracesOptions get ();
    void set (BracesOptions value);
}
abstract BracesOptions : BracesOptions with get, set

Property Value

Type: BracesOptions
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


IBraceMatching.ClosingBraces Property

IBraceMatchingClosingBraces Property
When implemented by a class, gets or sets an array of characters each one representing a closing brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] ClosingBraces { get; set; }
Property ClosingBraces As Char()
    Get
    Set
property array<wchar_t>^ ClosingBraces {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract ClosingBraces : char[] with get, set

Property Value

Type: Char
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


IBraceMatching.OpenBraces Property

IBraceMatchingOpenBraces Property
When implemented by a class, gets or sets an array of characters each one representing an open brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] OpenBraces { get; set; }
Property OpenBraces As Char()
    Get
    Set
property array<wchar_t>^ OpenBraces {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract OpenBraces : char[] with get, set

Property Value

Type: Char
See Also

Reference

IBraceMatching Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRange Interface

ICodeSnippetRange Interface
Represents properties to store individual code snippet that can appear in the Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetRange : IRange,
    ICloneable
Public Interface ICodeSnippetRange
    Inherits IRange, ICloneable
public interface class ICodeSnippetRange : IRange,
    ICloneable
type ICodeSnippetRange =
    interface
        interface IRange
        interface ICloneable
    end

The ICodeSnippetRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from IRange.)
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
Properties
 | Name | Description
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area. (Inherited from IRange.)
Public property | ID | When implemented by a class, represents name of code snippet.
Public property | IsEditable | When implemented by a class, gets or sets a boolean value that indicates whether code snippet can be edited.
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size. (Inherited from IRange.)
Public property | Size | When implemented by a class, gets or sets size of IRange area. (Inherited from IRange.)
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area. (Inherited from IRange.)
Public property | SupportsCode | When implemented by a class, gets or sets a boolean value that indicates whether code snippet can fill code.
Public property | Tooltip | When implemented by a class, represents short description of the code snippet.
Public property | Visible | When implemented by a class, gets or sets a boolean value that indicates whether code snippet is visible.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ICodeSnippetRange Methods

ICodeSnippetRange Methods

The ICodeSnippetRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from IRange.)
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

ICodeSnippetRange Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRange Properties

ICodeSnippetRange Properties

The ICodeSnippetRange type exposes the following members.

Properties
 | Name | Description
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area. (Inherited from IRange.)
Public property | ID | When implemented by a class, represents name of code snippet.
Public property | IsEditable | When implemented by a class, gets or sets a boolean value that indicates whether code snippet can be edited.
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size. (Inherited from IRange.)
Public property | Size | When implemented by a class, gets or sets size of IRange area. (Inherited from IRange.)
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area. (Inherited from IRange.)
Public property | SupportsCode | When implemented by a class, gets or sets a boolean value that indicates whether code snippet can fill code.
Public property | Tooltip | When implemented by a class, represents short description of the code snippet.
Public property | Visible | When implemented by a class, gets or sets a boolean value that indicates whether code snippet is visible.
Top
See Also

Reference

ICodeSnippetRange Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRange.ID Property

ICodeSnippetRangeID Property
When implemented by a class, represents name of code snippet.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ID { get; set; }
Property ID As String
    Get
    Set
property String^ ID {
    String^ get ();
    void set (String^ value);
}
abstract ID : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetRange Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRange.IsEditable Property

ICodeSnippetRangeIsEditable Property
When implemented by a class, gets or sets a boolean value that indicates whether code snippet can be edited.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsEditable { get; set; }
Property IsEditable As Boolean
    Get
    Set
property bool IsEditable {
    bool get ();
    void set (bool value);
}
abstract IsEditable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeSnippetRange Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRange.SupportsCode Property

ICodeSnippetRangeSupportsCode Property
When implemented by a class, gets or sets a boolean value that indicates whether code snippet can fill code.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SupportsCode { get; set; }
Property SupportsCode As Boolean
    Get
    Set
property bool SupportsCode {
    bool get ();
    void set (bool value);
}
abstract SupportsCode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeSnippetRange Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRange.Tooltip Property

ICodeSnippetRangeTooltip Property
When implemented by a class, represents short description of the code snippet.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Tooltip { get; set; }
Property Tooltip As String
    Get
    Set
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
abstract Tooltip : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetRange Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRange.Visible Property

ICodeSnippetRangeVisible Property
When implemented by a class, gets or sets a boolean value that indicates whether code snippet is visible.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeSnippetRange Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges Interface

ICodeSnippetRanges Interface
Represents methods to provide an indexed access to individual ICodeSnippetRange object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetRanges : IList<ICodeSnippetRange>,
    ICollection<ICodeSnippetRange>, IEnumerable<ICodeSnippetRange>, IEnumerable
Public Interface ICodeSnippetRanges
    Inherits IList(Of ICodeSnippetRange), ICollection(Of ICodeSnippetRange),
    IEnumerable(Of ICodeSnippetRange), IEnumerable
public interface class ICodeSnippetRanges : IList<ICodeSnippetRange^>,
    ICollection<ICodeSnippetRange^>, IEnumerable<ICodeSnippetRange^>, IEnumerable
type ICodeSnippetRanges =
    interface
        interface IList<ICodeSnippetRange>
        interface ICollection<ICodeSnippetRange>
        interface IEnumerable<ICodeSnippetRange>
        interface IEnumerable
    end

The ICodeSnippetRanges type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetRange .)
Public method | BlockDeleting | When implemented by a class, removes all snippets from the snippet collection which position in the specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetRange .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetRange .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetRange .)
Public method | FindSnippet | When implemented by a class, locates code snippet at specified position.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetRange .)
Public method | GetFirstSnippet | When implemented by a class, finds first snippet in snippet collection with nonempty id.
Public method | GetNextSnippet | When implemented by a class, finds next snippet in snippet collection with different id.
Public method | GetPrevSnippet | When implemented by a class, finds previous snippet in snippet collection with different id.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetRange .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetRange .)
Public method | IsFirstSnippet(Int32) | When implemented by a class, checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | IsFirstSnippet(ICodeSnippetRange) | When implemented by a class, checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | NeedClear(Rectangle) | When implemented by a class, obtains boolean value indicating whether all snippets need removing from the list.
Public method | NeedClear(Int32) | When implemented by a class, obtains boolean value indicating whether all snippets need removing from the list.
Public method | PositionChanged | When implemented by a class, changes positions of any code snippet located next to the specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetRange .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetRange .)
Public method | Sort | When implemented by a class, sorts the snippet list.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetRange | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetRange | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetRange, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetRange .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetRange .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetRange .)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ICodeSnippetRanges Methods

ICodeSnippetRanges Methods

The ICodeSnippetRanges type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetRange .)
Public method | BlockDeleting | When implemented by a class, removes all snippets from the snippet collection which position in the specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetRange .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetRange .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetRange .)
Public method | FindSnippet | When implemented by a class, locates code snippet at specified position.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetRange .)
Public method | GetFirstSnippet | When implemented by a class, finds first snippet in snippet collection with nonempty id.
Public method | GetNextSnippet | When implemented by a class, finds next snippet in snippet collection with different id.
Public method | GetPrevSnippet | When implemented by a class, finds previous snippet in snippet collection with different id.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetRange .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetRange .)
Public method | IsFirstSnippet(Int32) | When implemented by a class, checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | IsFirstSnippet(ICodeSnippetRange) | When implemented by a class, checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | NeedClear(Rectangle) | When implemented by a class, obtains boolean value indicating whether all snippets need removing from the list.
Public method | NeedClear(Int32) | When implemented by a class, obtains boolean value indicating whether all snippets need removing from the list.
Public method | PositionChanged | When implemented by a class, changes positions of any code snippet located next to the specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetRange .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetRange .)
Public method | Sort | When implemented by a class, sorts the snippet list.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetRange | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetRange | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetRange, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.BlockDeleting Method

ICodeSnippetRangesBlockDeleting Method
When implemented by a class, removes all snippets from the snippet collection which position in the specified rectangle.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BlockDeleting(
    Rectangle rect
)
Function BlockDeleting (
    rect As Rectangle
) As Boolean
bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove snippets.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.FindSnippet Method

ICodeSnippetRangesFindSnippet Method
When implemented by a class, locates code snippet at specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindSnippet(
    Point position,
    bool exact,
    out int index
)
Function FindSnippet (
    position As Point,
    exact As Boolean,
    <OutAttribute> ByRef index As Integer
) As Boolean
bool FindSnippet(
    Point position,
    bool exact,
    [OutAttribute] int% index
)
abstract FindSnippet :
        position : Point *
        exact : bool *
        index : int byref -> bool

Parameters

position
Type: System.DrawingPoint
Position to locate code snippet.
exact
Type: SystemBoolean
Specifies whether search should be precise.
index
Type: SystemInt32
Receives index of code snippet in the snippets collection.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.GetFirstSnippet Method

ICodeSnippetRangesGetFirstSnippet Method
When implemented by a class, finds first snippet in snippet collection with nonempty id.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetFirstSnippet()
Function GetFirstSnippet As Integer
int GetFirstSnippet()
abstract GetFirstSnippet : unit -> int

Return Value

Type: Int32
Index of found snippet.
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.GetNextSnippet Method

ICodeSnippetRangesGetNextSnippet Method
When implemented by a class, finds next snippet in snippet collection with different id.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetNextSnippet(
    int index
)
Function GetNextSnippet (
    index As Integer
) As Integer
int GetNextSnippet(
    int index
)
abstract GetNextSnippet :
        index : int -> int

Parameters

index
Type: SystemInt32
Specified index of snippet to search from.

Return Value

Type: Int32
Index of found snippet.
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.GetPrevSnippet Method

ICodeSnippetRangesGetPrevSnippet Method
When implemented by a class, finds previous snippet in snippet collection with different id.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPrevSnippet(
    int index
)
Function GetPrevSnippet (
    index As Integer
) As Integer
int GetPrevSnippet(
    int index
)
abstract GetPrevSnippet :
        index : int -> int

Parameters

index
Type: SystemInt32
Specified index of snippet to search from.

Return Value

Type: Int32
Index of found snippet.
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.IsFirstSnippet Method

ICodeSnippetRangesIsFirstSnippet Method
Overload List
 | Name | Description
Public method | IsFirstSnippet(Int32) | When implemented by a class, checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Public method | IsFirstSnippet(ICodeSnippetRange) | When implemented by a class, checks whether code snippet represents first snippet in subset of snippets that have the same ids.
Top
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.IsFirstSnippet Method (Int32)

ICodeSnippetRangesIsFirstSnippet Method (Int32)
When implemented by a class, checks whether code snippet represents first snippet in subset of snippets that have the same ids.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsFirstSnippet(
    int index
)
Function IsFirstSnippet (
    index As Integer
) As Boolean
bool IsFirstSnippet(
    int index
)
abstract IsFirstSnippet :
        index : int -> bool

Parameters

index
Type: SystemInt32
Specified index of the snippet.

Return Value

Type: Boolean
Returns True if snippet represents the first snippet with unique id.
See Also

Reference

ICodeSnippetRanges Interface
IsFirstSnippet Overload
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.IsFirstSnippet Method (ICodeSnippetRange)

ICodeSnippetRangesIsFirstSnippet Method (ICodeSnippetRange)
When implemented by a class, checks whether code snippet represents first snippet in subset of snippets that have the same ids.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsFirstSnippet(
    ICodeSnippetRange range
)
Function IsFirstSnippet (
    range As ICodeSnippetRange
) As Boolean
bool IsFirstSnippet(
    ICodeSnippetRange^ range
)
abstract IsFirstSnippet :
        range : ICodeSnippetRange -> bool

Parameters

range
Type: Alternet.Editor.TextSourceICodeSnippetRange
Specified the code snippet.

Return Value

Type: Boolean
Returns True if snippet represents the first snippet with unique id.
See Also

Reference

ICodeSnippetRanges Interface
IsFirstSnippet Overload
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.NeedClear Method

ICodeSnippetRangesNeedClear Method
Overload List
 | Name | Description
Public method | NeedClear(Rectangle) | When implemented by a class, obtains boolean value indicating whether all snippets need removing from the list.
Public method | NeedClear(Int32) | When implemented by a class, obtains boolean value indicating whether all snippets need removing from the list.
Top
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.NeedClear Method (Rectangle)

ICodeSnippetRangesNeedClear Method (Rectangle)
When implemented by a class, obtains boolean value indicating whether all snippets need removing from the list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedClear(
    Rectangle rect
)
Function NeedClear (
    rect As Rectangle
) As Boolean
bool NeedClear(
    Rectangle rect
)
abstract NeedClear :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Rectangle specifying block being deleted.

Return Value

Type: Boolean
See Also

Reference

ICodeSnippetRanges Interface
NeedClear Overload
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.NeedClear Method (Int32)

ICodeSnippetRangesNeedClear Method (Int32)
When implemented by a class, obtains boolean value indicating whether all snippets need removing from the list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedClear(
    int y
)
Function NeedClear (
    y As Integer
) As Boolean
bool NeedClear(
    int y
)
abstract NeedClear :
        y : int -> bool

Parameters

y
Type: SystemInt32
Line being changed.

Return Value

Type: Boolean
See Also

Reference

ICodeSnippetRanges Interface
NeedClear Overload
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.PositionChanged Method

ICodeSnippetRangesPositionChanged Method
When implemented by a class, changes positions of any code snippet located next to the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    bool preserveBounds
)
Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    preserveBounds As Boolean
) As Boolean
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    bool preserveBounds
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        preserveBounds : bool -> bool

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.
preserveBounds
Type: SystemBoolean
Specifies whether snippet bounds should be preserved.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges.Sort Method

ICodeSnippetRangesSort Method
When implemented by a class, sorts the snippet list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Sort()
Sub Sort
void Sort()
abstract Sort : unit -> unit
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


ICodeSnippetRanges Properties

ICodeSnippetRanges Properties

The ICodeSnippetRanges type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetRange .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetRange .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetRange .)
Top
See Also

Reference

ICodeSnippetRanges Interface
Alternet.Editor.TextSource Namespace


IEdit Interface

IEdit Interface
Represents properties and methods used for editing the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEdit
Public Interface IEdit
public interface class IEdit
type IEdit =  interface end

The IEdit type exposes the following members.

Methods
 | Name | Description
Public method | BreakLine | When implemented by a class, breaks current line into two lines.
Public method | DeleteBlock | When implemented by a class, deletes a specified block of characters.
Public method | DeleteLeft | When implemented by a class, deletes a specified number of characters to the left of the active point.
Public method | DeleteRight | When implemented by a class, deletes a specified number of characters to the right of the active point.
Public method | GetIndentString | When implemented by a class, gets indentation string at current position.
Public method | IndentLine | When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
Public method | IndentLine(String, Boolean) | When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
Public method | Insert | When implemented by a class, inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string array at the specified location.
Public method | InsertBlock(ITextStrings, Boolean) | When implemented by a class, inserts the given string collection at the specified location.
Public method | InsertBlock(String, Boolean, Boolean) | When implemented by a class, inserts the given string array at the specified location.
Public method | InsertFromFile | When implemented by a class, inserts the file text content at the specified location.
Public method | LineIsHidden | When implemented by a class, determines whether the given line is hidden.
Public method | LineIsReadonly | When implemented by a class, determines whether the given line is readonly.
Public method | NewLine | When implemented by a class, inserts a line break at the current position.
Public method | NewLine(String, Boolean) | When implemented by a class, inserts a line break at the current position with indentation.
Public method | NewLineAbove | When implemented by a class, inserts a line break above the current position.
Public method | NewLineBelow | When implemented by a class, inserts a line break below the current position.
Public method | PositionIsReadonly | When implemented by a class, determines whether the text at given position is readonly.
Public method | ResetIndentOptions | When implemented by a class, resets the IndentOptions to the default value.
Public method | ResetMaxLength | When implemented by a class, resets the MaxLength to the default value.
Public method | ResetModified | When implemented by a class, resets the Modified to the default value.
Public method | ResetOverWrite | When implemented by a class, resets the OverWrite to the default value.
Public method | ResetReadOnly | When implemented by a class, resets the Readonly to the default value.
Public method | ResetSingleLineMode | When implemented by a class, resets the SingleLineMode to the default value.
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line.
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line.
Public method | UnBreakLine | When implemented by a class, concatenates lines at current position.
Top
Properties
 | Name | Description
Public property | IndentOptions | When implemented by a class, gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line.
Public property | MaxLength | When implemented by a class, specifies the maximum number of characters that can be entered into the edit control.
Public property | Modified | When implemented by a class, gets or sets a value indicating whether the control's text content is modified.
Public property | Overwrite | When implemented by a class, gets or sets a value indicating whether the inserted text overwrites existing text.
Public property | ReadOnly | When implemented by a class, gets or sets a value indicating whether the control's content is read-only.
Public property | SingleLineMode | When implemented by a class, gets or sets a value indicating whether the control accepts only one line of the text.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IEdit Methods

IEdit Methods

The IEdit type exposes the following members.

Methods
 | Name | Description
Public method | BreakLine | When implemented by a class, breaks current line into two lines.
Public method | DeleteBlock | When implemented by a class, deletes a specified block of characters.
Public method | DeleteLeft | When implemented by a class, deletes a specified number of characters to the left of the active point.
Public method | DeleteRight | When implemented by a class, deletes a specified number of characters to the right of the active point.
Public method | GetIndentString | When implemented by a class, gets indentation string at current position.
Public method | IndentLine | When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
Public method | IndentLine(String, Boolean) | When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
Public method | Insert | When implemented by a class, inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string array at the specified location.
Public method | InsertBlock(ITextStrings, Boolean) | When implemented by a class, inserts the given string collection at the specified location.
Public method | InsertBlock(String, Boolean, Boolean) | When implemented by a class, inserts the given string array at the specified location.
Public method | InsertFromFile | When implemented by a class, inserts the file text content at the specified location.
Public method | LineIsHidden | When implemented by a class, determines whether the given line is hidden.
Public method | LineIsReadonly | When implemented by a class, determines whether the given line is readonly.
Public method | NewLine | When implemented by a class, inserts a line break at the current position.
Public method | NewLine(String, Boolean) | When implemented by a class, inserts a line break at the current position with indentation.
Public method | NewLineAbove | When implemented by a class, inserts a line break above the current position.
Public method | NewLineBelow | When implemented by a class, inserts a line break below the current position.
Public method | PositionIsReadonly | When implemented by a class, determines whether the text at given position is readonly.
Public method | ResetIndentOptions | When implemented by a class, resets the IndentOptions to the default value.
Public method | ResetMaxLength | When implemented by a class, resets the MaxLength to the default value.
Public method | ResetModified | When implemented by a class, resets the Modified to the default value.
Public method | ResetOverWrite | When implemented by a class, resets the OverWrite to the default value.
Public method | ResetReadOnly | When implemented by a class, resets the Readonly to the default value.
Public method | ResetSingleLineMode | When implemented by a class, resets the SingleLineMode to the default value.
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line.
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line.
Public method | UnBreakLine | When implemented by a class, concatenates lines at current position.
Top
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.BreakLine Method

IEditBreakLine Method
When implemented by a class, breaks current line into two lines.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BreakLine(
    bool withChange = false
)
Function BreakLine (
    Optional withChange As Boolean = false
) As Boolean
bool BreakLine(
    bool withChange = false
)
abstract BreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.DeleteBlock Method

IEditDeleteBlock Method
When implemented by a class, deletes a specified block of characters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DeleteBlock(
    Rectangle rect,
    bool withChange = false
)
Function DeleteBlock (
    rect As Rectangle,
    Optional withChange As Boolean = false
) As Boolean
bool DeleteBlock(
    Rectangle rect,
    bool withChange = false
)
abstract DeleteBlock :
        rect : Rectangle *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies coordinates of characters block to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if method succeed; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.DeleteLeft Method

IEditDeleteLeft Method
When implemented by a class, deletes a specified number of characters to the left of the active point.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DeleteLeft(
    int len,
    bool withChange = false
)
Function DeleteLeft (
    len As Integer,
    Optional withChange As Boolean = false
) As Boolean
bool DeleteLeft(
    int len,
    bool withChange = false
)
abstract DeleteLeft :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

len
Type: SystemInt32
Specifies number of characters to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.

Return Value

Type: Boolean
True if method succeed; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.DeleteRight Method

IEditDeleteRight Method
When implemented by a class, deletes a specified number of characters to the right of the active point.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DeleteRight(
    int len,
    bool withChange = false
)
Function DeleteRight (
    len As Integer,
    Optional withChange As Boolean = false
) As Boolean
bool DeleteRight(
    int len,
    bool withChange = false
)
abstract DeleteRight :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

len
Type: SystemInt32
Specifies number of characters to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.

Return Value

Type: Boolean
True if method succeed; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.GetIndentString Method

IEditGetIndentString Method
When implemented by a class, gets indentation string at current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetIndentString()
Function GetIndentString As String
String^ GetIndentString()
abstract GetIndentString : unit -> string

Return Value

Type: String
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.IndentLine Method

IEditIndentLine Method
Overload List
 | Name | Description
Public method | IndentLine | When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
Public method | IndentLine(String, Boolean) | When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
Top
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.IndentLine Method

IEditIndentLine Method
When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void IndentLine()
Sub IndentLine
void IndentLine()
abstract IndentLine : unit -> unit
See Also

Reference

IEdit Interface
IndentLine Overload
Alternet.Editor.TextSource Namespace


IEdit.IndentLine Method (String, Boolean)

IEditIndentLine Method (String, Boolean)
When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void IndentLine(
    string indent,
    bool withChange = false
)
Sub IndentLine (
    indent As String,
    Optional withChange As Boolean = false
)
void IndentLine(
    String^ indent,
    bool withChange = false
)
abstract IndentLine :
        indent : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit

Parameters

indent
Type: SystemString
withChange (Optional)
Type: SystemBoolean
See Also

Reference

IEdit Interface
IndentLine Overload
Alternet.Editor.TextSource Namespace


IEdit.Insert Method

IEditInsert Method
When implemented by a class, inserts the given string at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Insert(
    string text,
    bool withChange = false
)
Function Insert (
    text As String,
    Optional withChange As Boolean = false
) As Boolean
bool Insert(
    String^ text,
    bool withChange = false
)
abstract Insert :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

text
Type: SystemString
The text to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.InsertBlock Method

IEditInsertBlock Method
Overload List
 | Name | Description
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string array at the specified location.
Public method | InsertBlock(ITextStrings, Boolean) | When implemented by a class, inserts the given string collection at the specified location.
Public method | InsertBlock(String, Boolean, Boolean) | When implemented by a class, inserts the given string array at the specified location.
Top
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.InsertBlock Method (String, Boolean)

IEditInsertBlock Method (String, Boolean)
When implemented by a class, inserts the given string at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool InsertBlock(
    string text,
    bool withChange = false
)
Function InsertBlock (
    text As String,
    Optional withChange As Boolean = false
) As Boolean
bool InsertBlock(
    String^ text,
    bool withChange = false
)
abstract InsertBlock :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

text
Type: SystemString
String to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
InsertBlock Overload
Alternet.Editor.TextSource Namespace


IEdit.InsertBlock Method (String[], Boolean)

IEditInsertBlock Method (String, Boolean)
When implemented by a class, inserts the given string array at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool InsertBlock(
    string[] strings,
    bool withChange = false
)
Function InsertBlock (
    strings As String(),
    Optional withChange As Boolean = false
) As Boolean
bool InsertBlock(
    array<String^>^ strings,
    bool withChange = false
)
abstract InsertBlock :
        strings : string[] *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

strings
Type: SystemString
String array to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
InsertBlock Overload
Alternet.Editor.TextSource Namespace


IEdit.InsertBlock Method (ITextStrings, Boolean)

IEditInsertBlock Method (ITextStrings, Boolean)
When implemented by a class, inserts the given string collection at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool InsertBlock(
    ITextStrings strings,
    bool withChange = false
)
Function InsertBlock (
    strings As ITextStrings,
    Optional withChange As Boolean = false
) As Boolean
bool InsertBlock(
    ITextStrings^ strings,
    bool withChange = false
)
abstract InsertBlock :
        strings : ITextStrings *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

strings
Type: Alternet.Editor.TextSourceITextStrings
Collection of strings to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
InsertBlock Overload
Alternet.Editor.TextSource Namespace


IEdit.InsertBlock Method (String[], Boolean, Boolean)

IEditInsertBlock Method (String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool InsertBlock(
    string[] strings,
    bool select,
    bool withChange = false
)
Function InsertBlock (
    strings As String(),
    select As Boolean,
    Optional withChange As Boolean = false
) As Boolean
bool InsertBlock(
    array<String^>^ strings,
    bool select,
    bool withChange = false
)
abstract InsertBlock :
        strings : string[] *
        select : bool *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

strings
Type: SystemString
String array to insert.
select
Type: SystemBoolean
Specifies whether inserted block should be selected.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
InsertBlock Overload
Alternet.Editor.TextSource Namespace


IEdit.InsertFromFile Method

IEditInsertFromFile Method
When implemented by a class, inserts the file text content at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool InsertFromFile(
    string fileName
)
Function InsertFromFile (
    fileName As String
) As Boolean
bool InsertFromFile(
    String^ fileName
)
abstract InsertFromFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load text from.

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.LineIsHidden Method

IEditLineIsHidden Method
When implemented by a class, determines whether the given line is hidden.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LineIsHidden(
    int index
)
Function LineIsHidden (
    index As Integer
) As Boolean
bool LineIsHidden(
    int index
)
abstract LineIsHidden :
        index : int -> bool

Parameters

index
Type: SystemInt32
Line index.

Return Value

Type: Boolean
True if the line at given index is hidden; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.LineIsReadonly Method

IEditLineIsReadonly Method
When implemented by a class, determines whether the given line is readonly.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LineIsReadonly(
    int index
)
Function LineIsReadonly (
    index As Integer
) As Boolean
bool LineIsReadonly(
    int index
)
abstract LineIsReadonly :
        index : int -> bool

Parameters

index
Type: SystemInt32
Line index.

Return Value

Type: Boolean
True if the line at given index is readonly; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.NewLine Method

IEditNewLine Method
Overload List
 | Name | Description
Public method | NewLine | When implemented by a class, inserts a line break at the current position.
Public method | NewLine(String, Boolean) | When implemented by a class, inserts a line break at the current position with indentation.
Top
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.NewLine Method

IEditNewLine Method
When implemented by a class, inserts a line break at the current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NewLine()
Function NewLine As Boolean
bool NewLine()
abstract NewLine : unit -> bool

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
NewLine Overload
Alternet.Editor.TextSource Namespace


IEdit.NewLine Method (String, Boolean)

IEditNewLine Method (String, Boolean)
When implemented by a class, inserts a line break at the current position with indentation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NewLine(
    ref string indent,
    bool withChange = false
)
Function NewLine (
    ByRef indent As String,
    Optional withChange As Boolean = false
) As Boolean
bool NewLine(
    String^% indent,
    bool withChange = false
)
abstract NewLine :
        indent : string byref *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

indent
Type: SystemString
pass desired indentation level, or null for automatic indentation
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
NewLine Overload
Alternet.Editor.TextSource Namespace


IEdit.NewLineAbove Method

IEditNewLineAbove Method
When implemented by a class, inserts a line break above the current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NewLineAbove()
Function NewLineAbove As Boolean
bool NewLineAbove()
abstract NewLineAbove : unit -> bool

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.NewLineBelow Method

IEditNewLineBelow Method
When implemented by a class, inserts a line break below the current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NewLineBelow()
Function NewLineBelow As Boolean
bool NewLineBelow()
abstract NewLineBelow : unit -> bool

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.PositionIsReadonly Method

IEditPositionIsReadonly Method
When implemented by a class, determines whether the text at given position is readonly.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionIsReadonly(
    Point position
)
Function PositionIsReadonly (
    position As Point
) As Boolean
bool PositionIsReadonly(
    Point position
)
abstract PositionIsReadonly :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position in text coordinates.

Return Value

Type: Boolean
True if the text can be edited at given position; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.ResetIndentOptions Method

IEditResetIndentOptions Method
When implemented by a class, resets the IndentOptions to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetIndentOptions()
Sub ResetIndentOptions
void ResetIndentOptions()
abstract ResetIndentOptions : unit -> unit
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.ResetMaxLength Method

IEditResetMaxLength Method
When implemented by a class, resets the MaxLength to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetMaxLength()
Sub ResetMaxLength
void ResetMaxLength()
abstract ResetMaxLength : unit -> unit
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.ResetModified Method

IEditResetModified Method
When implemented by a class, resets the Modified to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetModified()
Sub ResetModified
void ResetModified()
abstract ResetModified : unit -> unit
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.ResetOverWrite Method

IEditResetOverWrite Method
When implemented by a class, resets the OverWrite to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOverWrite()
Sub ResetOverWrite
void ResetOverWrite()
abstract ResetOverWrite : unit -> unit
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.ResetReadOnly Method

IEditResetReadOnly Method
When implemented by a class, resets the Readonly to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetReadOnly()
Sub ResetReadOnly
void ResetReadOnly()
abstract ResetReadOnly : unit -> unit
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.ResetSingleLineMode Method

IEditResetSingleLineMode Method
When implemented by a class, resets the SingleLineMode to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetSingleLineMode()
Sub ResetSingleLineMode
void ResetSingleLineMode()
abstract ResetSingleLineMode : unit -> unit
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.SetLineHidden Method

IEditSetLineHidden Method
Overload List
 | Name | Description
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line.
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line.
Top
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.SetLineHidden Method (Int32, Boolean)

IEditSetLineHidden Method (Int32, Boolean)
When implemented by a class, sets hidden state for the given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLineHidden(
    int index,
    bool hidden
)
Sub SetLineHidden (
    index As Integer,
    hidden As Boolean
)
void SetLineHidden(
    int index,
    bool hidden
)
abstract SetLineHidden :
        index : int *
        hidden : bool -> unit

Parameters

index
Type: SystemInt32
Line index.
hidden
Type: SystemBoolean
Indicates hidden flag should be set or cleared.
See Also

Reference

IEdit Interface
SetLineHidden Overload
Alternet.Editor.TextSource Namespace


IEdit.SetLineHidden Method (Int32[], Boolean)

IEditSetLineHidden Method (Int32, Boolean)
When implemented by a class, sets hidden state for the given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLineHidden(
    int[] indexes,
    bool hidden
)
Sub SetLineHidden (
    indexes As Integer(),
    hidden As Boolean
)
void SetLineHidden(
    array<int>^ indexes,
    bool hidden
)
abstract SetLineHidden :
        indexes : int[] *
        hidden : bool -> unit

Parameters

indexes
Type: SystemInt32
Line indexes.
hidden
Type: SystemBoolean
Indicates hidden flag should be set or cleared.
See Also

Reference

IEdit Interface
SetLineHidden Overload
Alternet.Editor.TextSource Namespace


IEdit.SetLineReadonly Method

IEditSetLineReadonly Method
Overload List
 | Name | Description
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line.
Top
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.SetLineReadonly Method (Int32, Boolean)

IEditSetLineReadonly Method (Int32, Boolean)
When implemented by a class, sets readonly state for the given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLineReadonly(
    int index,
    bool readOnly
)
Sub SetLineReadonly (
    index As Integer,
    readOnly As Boolean
)
void SetLineReadonly(
    int index,
    bool readOnly
)
abstract SetLineReadonly :
        index : int *
        readOnly : bool -> unit

Parameters

index
Type: SystemInt32
Line indexes.
readOnly
Type: SystemBoolean
Indicates readonly flag should be set or cleared.
See Also

Reference

IEdit Interface
SetLineReadonly Overload
Alternet.Editor.TextSource Namespace


IEdit.SetLineReadonly Method (Int32[], Boolean)

IEditSetLineReadonly Method (Int32, Boolean)
When implemented by a class, sets readonly state for the given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLineReadonly(
    int[] indexes,
    bool readOnly
)
Sub SetLineReadonly (
    indexes As Integer(),
    readOnly As Boolean
)
void SetLineReadonly(
    array<int>^ indexes,
    bool readOnly
)
abstract SetLineReadonly :
        indexes : int[] *
        readOnly : bool -> unit

Parameters

indexes
Type: SystemInt32
Line indexes.
readOnly
Type: SystemBoolean
Indicates readonly flag should be set or cleared.
See Also

Reference

IEdit Interface
SetLineReadonly Overload
Alternet.Editor.TextSource Namespace


IEdit.UnBreakLine Method

IEditUnBreakLine Method
When implemented by a class, concatenates lines at current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnBreakLine(
    bool withChange = false
)
Function UnBreakLine (
    Optional withChange As Boolean = false
) As Boolean
bool UnBreakLine(
    bool withChange = false
)
abstract UnBreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit Properties

IEdit Properties

The IEdit type exposes the following members.

Properties
 | Name | Description
Public property | IndentOptions | When implemented by a class, gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line.
Public property | MaxLength | When implemented by a class, specifies the maximum number of characters that can be entered into the edit control.
Public property | Modified | When implemented by a class, gets or sets a value indicating whether the control's text content is modified.
Public property | Overwrite | When implemented by a class, gets or sets a value indicating whether the inserted text overwrites existing text.
Public property | ReadOnly | When implemented by a class, gets or sets a value indicating whether the control's content is read-only.
Public property | SingleLineMode | When implemented by a class, gets or sets a value indicating whether the control accepts only one line of the text.
Top
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.IndentOptions Property

IEditIndentOptions Property
When implemented by a class, gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IndentOptions IndentOptions { get; set; }
Property IndentOptions As IndentOptions
    Get
    Set
property IndentOptions IndentOptions {
    IndentOptions get ();
    void set (IndentOptions value);
}
abstract IndentOptions : IndentOptions with get, set

Property Value

Type: IndentOptions
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.MaxLength Property

IEditMaxLength Property
When implemented by a class, specifies the maximum number of characters that can be entered into the edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MaxLength { get; set; }
Property MaxLength As Integer
    Get
    Set
property int MaxLength {
    int get ();
    void set (int value);
}
abstract MaxLength : int with get, set

Property Value

Type: Int32
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.Modified Property

IEditModified Property
When implemented by a class, gets or sets a value indicating whether the control's text content is modified.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Modified { get; set; }
Property Modified As Boolean
    Get
    Set
property bool Modified {
    bool get ();
    void set (bool value);
}
abstract Modified : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.Overwrite Property

IEditOverwrite Property
When implemented by a class, gets or sets a value indicating whether the inserted text overwrites existing text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Overwrite { get; set; }
Property Overwrite As Boolean
    Get
    Set
property bool Overwrite {
    bool get ();
    void set (bool value);
}
abstract Overwrite : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.ReadOnly Property

IEditReadOnly Property
When implemented by a class, gets or sets a value indicating whether the control's content is read-only.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReadOnly { get; set; }
Property ReadOnly As Boolean
    Get
    Set
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
abstract ReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IEdit.SingleLineMode Property

IEditSingleLineMode Property
When implemented by a class, gets or sets a value indicating whether the control accepts only one line of the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SingleLineMode { get; set; }
Property SingleLineMode As Boolean
    Get
    Set
property bool SingleLineMode {
    bool get ();
    void set (bool value);
}
abstract SingleLineMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEdit Interface
Alternet.Editor.TextSource Namespace


IHyperText Interface

IHyperText Interface
Represents methods to operate with hypertext sections within the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IHyperText
Public Interface IHyperText
public interface class IHyperText
type IHyperText =  interface end

The IHyperText type exposes the following members.

Methods
 | Name | Description
Public method | IsHyperText | When implemented by a class, indicates whether given text represents hypertext.
Public method | ResetHighlightHyperText | When implemented by a class, resets HighlightUrls to the default value.
Top
Properties
 | Name | Description
Public property | HighlightHyperText | When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted.
Public property | UrlTable | When implemented by a class, represents hash table containing hyper-text characters.
Top
Events
 | Name | Description
Public event | HyperText | When implemented by a class, occurs when a control needs checking whether some string represents hypertext.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IHyperText Methods

IHyperText Methods

The IHyperText type exposes the following members.

Methods
 | Name | Description
Public method | IsHyperText | When implemented by a class, indicates whether given text represents hypertext.
Public method | ResetHighlightHyperText | When implemented by a class, resets HighlightUrls to the default value.
Top
See Also

Reference

IHyperText Interface
Alternet.Editor.TextSource Namespace


IHyperText.IsHyperText Method

IHyperTextIsHyperText Method
When implemented by a class, indicates whether given text represents hypertext.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsHyperText(
    string text
)
Function IsHyperText (
    text As String
) As Boolean
bool IsHyperText(
    String^ text
)
abstract IsHyperText :
        text : string -> bool

Parameters

text
Type: SystemString
Text to test.

Return Value

Type: Boolean
True if given text represents hypertext; otherwise false.
See Also

Reference

IHyperText Interface
Alternet.Editor.TextSource Namespace


IHyperText.ResetHighlightHyperText Method

IHyperTextResetHighlightHyperText Method
When implemented by a class, resets HighlightUrls to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetHighlightHyperText()
Sub ResetHighlightHyperText
void ResetHighlightHyperText()
abstract ResetHighlightHyperText : unit -> unit
See Also

Reference

IHyperText Interface
Alternet.Editor.TextSource Namespace


IHyperText Properties

IHyperText Properties

The IHyperText type exposes the following members.

Properties
 | Name | Description
Public property | HighlightHyperText | When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted.
Public property | UrlTable | When implemented by a class, represents hash table containing hyper-text characters.
Top
See Also

Reference

IHyperText Interface
Alternet.Editor.TextSource Namespace


IHyperText.HighlightHyperText Property

IHyperTextHighlightHyperText Property
When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HighlightHyperText { get; set; }
Property HighlightHyperText As Boolean
    Get
    Set
property bool HighlightHyperText {
    bool get ();
    void set (bool value);
}
abstract HighlightHyperText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IHyperText Interface
Alternet.Editor.TextSource Namespace


IHyperText.UrlTable Property

IHyperTextUrlTable Property
When implemented by a class, represents hash table containing hyper-text characters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Hashtable UrlTable { get; }
ReadOnly Property UrlTable As Hashtable
    Get
property Hashtable^ UrlTable {
    Hashtable^ get ();
}
abstract UrlTable : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

IHyperText Interface
Alternet.Editor.TextSource Namespace


IHyperText Events

IHyperText Events

The IHyperText type exposes the following members.

Events
 | Name | Description
Public event | HyperText | When implemented by a class, occurs when a control needs checking whether some string represents hypertext.
Top
See Also

Reference

IHyperText Interface
Alternet.Editor.TextSource Namespace


IHyperText.HyperText Event

IHyperTextHyperText Event
When implemented by a class, occurs when a control needs checking whether some string represents hypertext.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event HyperTextEvent HyperText
Event HyperText As HyperTextEvent
 event HyperTextEvent^ HyperText {
    void add (HyperTextEvent^ value);
    void remove (HyperTextEvent^ value);
}
abstract HyperText : IEvent<HyperTextEvent,
    HyperTextEventArgs>

Value

Type: Alternet.Editor.TextSourceHyperTextEvent
See Also

Reference

IHyperText Interface
Alternet.Editor.TextSource Namespace


IInnerTextSource Interface

IInnerTextSource Interface
Represents internal text source for Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IInnerTextSource : ITextSource,
    IEdit, INavigate, IUndo, ITextNotify, INotify,
    IUpdate, INotifier, ITextImport, IImport, ITextExport,
    IExport, IHyperText, ISpelling, IBraceMatching, ITextParsing,
    ITextSnippets, ITextErrors, ITextThread
Public Interface IInnerTextSource
    Inherits ITextSource, IEdit, INavigate, IUndo,
    ITextNotify, INotify, IUpdate, INotifier, ITextImport,
    IImport, ITextExport, IExport, IHyperText, ISpelling,
    IBraceMatching, ITextParsing, ITextSnippets, ITextErrors, ITextThread
public interface class IInnerTextSource : ITextSource,
    IEdit, INavigate, IUndo, ITextNotify, INotify,
    IUpdate, INotifier, ITextImport, IImport, ITextExport,
    IExport, IHyperText, ISpelling, IBraceMatching, ITextParsing,
    ITextSnippets, ITextErrors, ITextThread
type IInnerTextSource =
    interface
        interface ITextSource
        interface IEdit
        interface INavigate
        interface IUndo
        interface ITextNotify
        interface INotify
        interface IUpdate
        interface INotifier
        interface ITextImport
        interface IImport
        interface ITextExport
        interface IExport
        interface IHyperText
        interface ISpelling
        interface IBraceMatching
        interface ITextParsing
        interface ITextSnippets
        interface ITextErrors
        interface ITextThread
    end

The IInnerTextSource type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | When implemented by a class, converts given absolute position to position as Point value. (Inherited from ITextSource.)
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | AddUndo | When implemented by a class, stores undo operation in the appropriate list. (Inherited from IUndo.)
Public method | BeginUndoUpdate | When implemented by a class, allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method. (Inherited from IUndo.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BeginUpdate(UpdateReason) | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from ITextNotify.)
Public method | BeginUpdateSnippet | When implemented by a class, prevents the Edit control from updating snippets until the EndUpdateSnippet method is called. (Inherited from ITextSnippets.)
Public method | BreakLine | When implemented by a class, breaks current line into two lines. (Inherited from IEdit.)
Public method | CancelParsing | When implemented by a class, stops formatting timer. (Inherited from ITextSource.)
Public method | CanRedo | When implemented by a class, indicating whether the redo operation can be performed. (Inherited from IUndo.)
Public method | CanUndo | When implemented by a class, indicating whether the undo operation can be performed. (Inherited from IUndo.)
Public method | Clear | When implemented by a class, clears content of the TextSource (Inherited from ITextSource.)
Public method | ClearRedo | When implemented by a class, clears list of redo operations. (Inherited from IUndo.)
Public method | ClearUndo | When implemented by a class, clears list of undo operations. (Inherited from IUndo.)
Public method | CreateStringItem | Create a new IStrItem object containing specified text. (Inherited from ITextSource.)
Public method | DeleteBlock | When implemented by a class, deletes a specified block of characters. (Inherited from IEdit.)
Public method | DeleteLeft | When implemented by a class, deletes a specified number of characters to the left of the active point. (Inherited from IEdit.)
Public method | DeleteRight | When implemented by a class, deletes a specified number of characters to the right of the active point. (Inherited from IEdit.)
Public method | DisablePositionUpdate | When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method. (Inherited from INavigate.)
Public method | DisableUndo | When implemented by a class, disables recording of undo/redo operations. (Inherited from IUndo.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnablePositionUpdate | When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method. (Inherited from INavigate.)
Public method | EnableUndo | When implemented by a class, re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method. (Inherited from IUndo.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUndoUpdate | When implemented by a class, ends undo block, that was started by BeginUndoUpdate method. (Inherited from IUndo.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | EndUpdateSnippet | When implemented by a class, resumes updating snippets after updating is suspended by the BeginUpdateSnippet method. (Inherited from ITextSnippets.)
Public method | FindClosingBrace(Point) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindClosingBrace(Int32, Int32) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Point) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Int32, Int32) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FormatText | When implemented by a class, formats and outlines TextSource text using attached Lexer. (Inherited from ITextParsing.)
Public method | FormatText(Boolean, Boolean) | When implemented by a class, formats and outlines TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing (Inherited from ITextParsing.)
Public method | GetCharIndexFromPosition | When implemented by a class, converts given Point value to the index of character. (Inherited from ITextSource.)
Public method | GetCodeFixes | When implemented by a class, gets code fixes for a given syntax error. (Inherited from ITextErrors.)
Public method | GetCodeSnippetRangeAt | When implemented by a class, locates code snippet at specified position. (Inherited from ITextSnippets.)
Public method | GetIndentString | When implemented by a class, gets indentation string at current position. (Inherited from IEdit.)
Public method | GetPositionFromCharIndex | When implemented by a class, converts given character index to position as Point value. (Inherited from ITextSource.)
Public method | GetStructureGuideLines | When implemented by a class, gets list of guide lines. (Inherited from ITextParsing.)
Public method | GetSyntaxErrorAt | When implemented by a class, gets syntax error at specified position. (Inherited from ITextErrors.)
Public method | HighlightBraces | When implemented by a class, highlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | HighlightCodeFixes | When implemented by a class, highlights code fixes if needed. (Inherited from ITextErrors.)
Public method | HighlightCodeSnippets | When implemented by a class, highlights code snippets using appropriate style. (Inherited from ITextSnippets.)
Public method | HighlightSyntaxErrors | When implemented by a class, highlights syntax errors. (Inherited from ITextErrors.)
Public method | IndentLine | When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned. (Inherited from IEdit.)
Public method | IndentLine(String, Boolean) | When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser (Inherited from IEdit.)
Public method | Insert | When implemented by a class, inserts the given string at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string array at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(ITextStrings, Boolean) | When implemented by a class, inserts the given string collection at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean, Boolean) | When implemented by a class, inserts the given string array at the specified location. (Inherited from IEdit.)
Public method | InsertFromFile | When implemented by a class, inserts the file text content at the specified location. (Inherited from IEdit.)
Public method | InvalidateSyntaxErrors | When implemented by a class, invalidates highlighting of syntax errors. (Inherited from ITextErrors.)
Public method | IsContentDivider | When implemented by a class, gets boolean value indicating whether text content is divided at given line. (Inherited from ITextParsing.)
Public method | IsHyperText | When implemented by a class, indicates whether given text represents hypertext. (Inherited from IHyperText.)
Public method | IsWordCorrect(String) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | IsWordCorrect(String, Point) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | LineIsHidden | When implemented by a class, determines whether the given line is hidden. (Inherited from IEdit.)
Public method | LineIsModified(Int32) | When implemented by a class, indicates whether specified line already modified. (Inherited from IUndo.)
Public method | LineIsModified(Int32, Boolean) | When implemented by a class, indicates whether specified line already modified. (Inherited from IUndo.)
Public method | LineIsReadonly | When implemented by a class, determines whether the given line is readonly. (Inherited from IEdit.)
Public method | LinesChanged(Int32, Int32) | When implemented by a class, specifies range of lines that was changed. (Inherited from ITextNotify.)
Public method | LinesChanged(Int32, Int32, Boolean) | When implemented by a class, specifies range of lines that was changed. (Inherited from ITextNotify.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer. (Inherited from ITextImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding. (Inherited from ITextImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | MoveTo(Point) | When implemented by a class, moves the current position to the given position. (Inherited from INavigate.)
Public method | MoveTo(Int32, Int32) | When implemented by a class, moves the current position to the given position. (Inherited from INavigate.)
Public method | MoveToChar | When implemented by a class, moves the current position to the specified character in the current line. (Inherited from INavigate.)
Public method | MoveToLine(Int32) | When implemented by a class, moves the current position to the specified line. (Inherited from INavigate.)
Public method | MoveToLine(Int32, Int32) | When implemented by a class, moves the current position to the specified line. (Inherited from INavigate.)
Public method | Navigate | When implemented by a class, moves current position by the given offset value. (Inherited from INavigate.)
Public method | NeedAutoComplete | When implemented by a class, indicates whether ITextSource should try to autocomplete statements. (Inherited from ITextParsing.)
Public method | NeedCacheIndent | When implemented by a class, indicates whether ITextSource can reuse previous indentation. (Inherited from ITextParsing.)
Public method | NeedCodeCompletion | When implemented by a class, indicates whether ITextSource can provide code completion operation for its content. (Inherited from ITextParsing.)
Public method | NeedCodeCompletionTabs | When implemented by a class, indicates code completion content can be filtered based on its priority. (Inherited from ITextParsing.)
Public method | NeedCodeFixes | When implemented by a class, indicates whether ITextSource can provide code fixes operations for its content. (Inherited from ITextParsing.)
Public method | NeedCodeRefactors | When implemented by a class, indicates whether ITextSource can provide code refactor operations for its content. (Inherited from ITextParsing.)
Public method | NeedFormatText | When implemented by a class, indicates whether ITextSource can format its content. (Inherited from ITextParsing.)
Public method | NeedFormatTextOnLineChange | When implemented by a class, indicates whether ITextSource should format spaces and case when changing the current line. (Inherited from ITextParsing.)
Public method | NeedIndentText | When implemented by a class, indicates whether ITextSource can indent its content. (Inherited from ITextParsing.)
Public method | NeedOutlineText | When implemented by a class, indicates whether ITextSource can outline its content. (Inherited from ITextParsing.)
Public method | NeedParse | When implemented by a class, indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted. (Inherited from ITextParsing.)
Public method | NeedQuickInfoTips | When implemented by a class, indicates whether ITextSource can obtain short description for syntax tokens within its content. (Inherited from ITextParsing.)
Public method | NeedReparseTextOnLineChange | When implemented by a class, indicates whether ITextSource should replace text when changing the current line. (Inherited from ITextParsing.)
Public method | NeedStructureGuideLines | When implemented by a class, indicates whether ITextSource can structure guidelines for its content. (Inherited from ITextParsing.)
Public method | NewLine | When implemented by a class, inserts a line break at the current position. (Inherited from IEdit.)
Public method | NewLine(String, Boolean) | When implemented by a class, inserts a line break at the current position with indentation. (Inherited from IEdit.)
Public method | NewLineAbove | When implemented by a class, inserts a line break above the current position. (Inherited from IEdit.)
Public method | NewLineBelow | When implemented by a class, inserts a line break below the current position. (Inherited from IEdit.)
Public method | Notification | When implemented by a class, updates control's content according to the parameters of notification. (Inherited from INotifier.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | ParseString | When implemented by a class, perform lexical analysis of the specified string. (Inherited from ITextParsing.)
Public method | ParseStrings | When implemented by a class, perform lexical analysis specified strings. (Inherited from ITextParsing.)
Public method | ParseToString | When implemented by a class, perform lexical analysis of specified strings. (Inherited from ITextParsing.)
Public method | PositionIsReadonly | When implemented by a class, determines whether the text at given position is readonly. (Inherited from IEdit.)
Public method | ProcessAutoComplete | When implemented by a class, inserts end-of-block code fragment if needed. (Inherited from ITextParsing.)
Public method | Redo | When implemented by a class, performs the last redo operation. (Inherited from IUndo.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | ResetBracesOptions | When implemented by a class, resets the BracesOptions to its default value. (Inherited from IBraceMatching.)
Public method | ResetCheckSpelling | When implemented by a class, resets the CheckSpelling to the default value. (Inherited from ISpelling.)
Public method | ResetClosingBraces | When implemented by a class, resets the ClosingBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetHighlightHyperText | When implemented by a class, resets HighlightUrls to the default value. (Inherited from IHyperText.)
Public method | ResetIndentOptions | When implemented by a class, resets the IndentOptions to the default value. (Inherited from IEdit.)
Public method | ResetMaxLength | When implemented by a class, resets the MaxLength to the default value. (Inherited from IEdit.)
Public method | ResetModified | When implemented by a class, resets the Modified to the default value. (Inherited from IEdit.)
Public method | ResetNavigateOptions | When implemented by a class, resets the NavigateOptions to the default value. (Inherited from INavigate.)
Public method | ResetOpenBraces | When implemented by a class, resets the OpenBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetOverWrite | When implemented by a class, resets the OverWrite to the default value. (Inherited from IEdit.)
Public method | ResetReadOnly | When implemented by a class, resets the Readonly to the default value. (Inherited from IEdit.)
Public method | ResetSingleLineMode | When implemented by a class, resets the SingleLineMode to the default value. (Inherited from IEdit.)
Public method | ResetSpellDelimiters | When implemented by a class, resets the SpellDelimiters to the default value. (Inherited from ISpelling.)
Public method | ResetUndoLimit | When implemented by a class, resets the UndoLimit to the default value. (Inherited from IUndo.)
Public method | ResetUndoOptions | When implemented by a class, resets the UndoOptions to the default value. (Inherited from IUndo.)
Public method | RestorePosition | When implemented by a class, restores position from stored position list by given index. (Inherited from INavigate.)
Public method | RestorePositionWithUndo | When implemented by a class, restores position from stored position list by given index. (Inherited from INavigate.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter. (Inherited from ITextExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding. (Inherited from ITextExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SetLastParsed | When implemented by a class, updates the last parsed line and resets first changed line to it's default value. (Inherited from ITextParsing.)
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line. (Inherited from IEdit.)
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line. (Inherited from IEdit.)
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line. (Inherited from IEdit.)
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line. (Inherited from IEdit.)
Public method | SetNavigateOptions | When implemented by a class, sets navigating options without validating position. (Inherited from INavigate.)
Public method | StartThread | When implemented in a class, executes action in thread. (Inherited from ITextThread.)
Public method | StopThread | When implemented in a class, aborts executing action in thread. (Inherited from ITextThread.)
Public method | StorePosition(Point) | When implemented by a class, stores given position to stored position list. (Inherited from INavigate.)
Public method | StorePosition(Point, Boolean) | When implemented by a class, stores given position to stored position list. (Inherited from INavigate.)
Public method | StorePositionWithUndo | When implemented by a class, stores given position to stored position list preserving it for undo. (Inherited from INavigate.)
Public method | TempHighlightBraces | When implemented by a class, temporary highlights all text within the area specified by rects. (Inherited from IBraceMatching.)
Public method | TempHighlightReferences | When implemented by a class, highlights found references. (Inherited from ITextSource.)
Public method | TempHighlightSearchResults | When implemented by a class, highlights search results. (Inherited from ITextSource.)
Public method | TempUnhighlightBraces | When implemented by a class, cancels text highlighting turned on using TempHighlightBraces (Inherited from IBraceMatching.)
Public method | TempUnhighlightReferences | When implemented by a class, unhighlights references highlighted with previous call of TempHighlightReferences. (Inherited from ITextSource.)
Public method | TempUnhighlightSearchResults | When implemented by a class, unhighlights search results highlighted with previous call of TempHighlightSearchResults. (Inherited from ITextSource.)
Public method | TextPointToAbsolutePosition | When implemented by a class, converts given Point value to the absolute position. (Inherited from ITextSource.)
Public method | UnBreakLine | When implemented by a class, concatenates lines at current position. (Inherited from IEdit.)
Public method | Undo(Boolean) | When implemented by a class, performs the last undo operation. (Inherited from IUndo.)
Public method | Undo(IUndoData, Boolean) | When implemented by a class, performs the single undo operation. (Inherited from IUndo.)
Public method | UnhighlightBraces | When implemented by a class, unhighlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | UnhighlightCodeSnippets | When implemented by a class, removes highlighting from code snippets and clears snippet collection. (Inherited from ITextSnippets.)
Public method | UnhighlightSyntaxErrors | When implemented by a class, removes syntax errors highlighting. (Inherited from ITextErrors.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | ValidatePosition | When implemented by a class, validates given position within control's text content. (Inherited from INavigate.)
Top
Properties
 | Name | Description
Public property | ActiveEdit | When implemented by a class, gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source. (Inherited from ITextSource.)
Public property | BookMarks | When implemented by a class, represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source. (Inherited from ITextSource.)
Public property | BracesOptions | When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control. (Inherited from IBraceMatching.)
Public property | CheckSpelling | When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content. (Inherited from ISpelling.)
Public property | ClosingBraces | When implemented by a class, gets or sets an array of characters each one representing a closing brace. (Inherited from IBraceMatching.)
Public property | CodeSnippets | When implemented by a class, gets or sets ICodeSnippetRangeList for Edit control. (Inherited from ITextSnippets.)
Public property | CurrentSnippet | When implemented by a class, gets or sets current ICodeSnippetRange object. (Inherited from ITextSnippets.)
Public property | Edits | When implemented by a class, represents a collection of ISyntaxEdit controls linked to the text source. (Inherited from ITextSource.)
Public property | FileName | When implemented by a class, gets or sets name of file that holds text source content. (Inherited from ITextSource.)
Public property | FirstChanged | When implemented by a class, represents index of the first changed line. (Inherited from ITextNotify.)
Public property | GlobalSearch | When implemented by a class, specifies whether search should be global. (Inherited from ITextSource.)
Public property | HasSpelling | When implemented by a class, gets boolean value indicating that editor has external spell checker assigned. (Inherited from ISpelling.)
Public property | HighlightHyperText | When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted. (Inherited from IHyperText.)
Public property | HighlightMatchingBlocks | When implemented by a class, specifies that edit control should highlight begin/end blocks. (Inherited from ITextSource.)
Public property | HighlightReferences | When implemented by a class, specifies that edit control should highlight found references. (Inherited from ITextSource.)
Public property | IndentOptions | When implemented by a class, gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from IEdit.)
Public property | LastChanged | When implemented by a class, represents index of the last changed line. (Inherited from ITextNotify.)
Public property | Lexer | When implemented by a class, gets or sets object that can perform lexical analysis of the text source content. (Inherited from ITextParsing.)
Public property | Lines | When implemented by a class, represents the object that implements ITextStrings interface containing collection of strings determining text source content. (Inherited from ITextSource.)
Public property | LineStyles | When implemented by a class, represents an object that implements ILineStyles interface holding collection of line styles for this document. (Inherited from ITextSource.)
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | MaxLength | When implemented by a class, specifies the maximum number of characters that can be entered into the edit control. (Inherited from IEdit.)
Public property | Modified | When implemented by a class, gets or sets a value indicating whether the control's text content is modified. (Inherited from IEdit.)
Public property | ModifiedLineRegions | When implemented by a class, gets modified lines information, grouped in regions. (Inherited from IUndo.)
Public property | ModifiedLines | When implemented by a class, gets modified lines information. (Inherited from IUndo.)
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options. (Inherited from INavigate.)
Public property | OpenBraces | When implemented by a class, gets or sets an array of characters each one representing an open brace. (Inherited from IBraceMatching.)
Public property | OptimizedForMemory | When implemented by a class, specifies whether internal text representation should optimized memory usage. (Inherited from ITextSource.)
Public property | Overwrite | When implemented by a class, gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from IEdit.)
Public property | ParserLine | When implemented in a class, gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text. (Inherited from ITextParsing.)
Public property | Position | When implemented by a class, gets or sets current position within the control's text content. (Inherited from INavigate.)
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content. (Inherited from INavigate.)
Public property | ReadOnly | When implemented by a class, gets or sets a value indicating whether the control's content is read-only. (Inherited from IEdit.)
Public property | RedoList | When implemented by a class, provides an indexed access to redo data. (Inherited from IUndo.)
Public property | References | When implemented by a class, gets or sets IRangeList of found references for Edit control. (Inherited from ITextSource.)
Public property | SearchResults | When implemented by a class, gets IRangeList of search results highlighted by TempHighlightSearchResults. (Inherited from ITextSource.)
Public property | SelectBlockRect | When implemented by a class, represents a rectangular block of selected text. (Inherited from ITextNotify.)
Public property | SingleLineMode | When implemented by a class, gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from IEdit.)
Public property | SpellDelimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text when performing spelling check. (Inherited from ISpelling.)
Public property | SpellDelimiterString | When implemented by a class, gets or sets SpellDelimiters as a single string. (Inherited from ISpelling.)
Public property | SpellTable | When implemented by a class, represents a hash table containing delimiters. (Inherited from ISpelling.)
Public property | State | When implemented by a class, gets or sets last changes to the text stored in the text source. (Inherited from ITextNotify.)
Public property | SyntaxErrors | When implemented by a class, represents a syntax errors collection. (Inherited from ITextErrors.)
Public property | Text | When implemented by a class, gets or sets text source content as a single string with the individual strings delimited by carriage returns. (Inherited from ITextSource.)
Public property | ThreadAction | When implemented by a class, returns method executed in thread when parsing. (Inherited from ITextSource.)
Public property | UndoLimit | When implemented by a class, gets or sets a value that limits number of undo operations. (Inherited from IUndo.)
Public property | UndoList | When implemented by a class, provides an indexed access to undo data. (Inherited from IUndo.)
Public property | UndoOptions | When implemented by a class, gets or sets options for undo and redo operations. (Inherited from IUndo.)
Public property | UndoUpdateCount | When implemented by a class, keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested. (Inherited from IUndo.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UrlTable | When implemented by a class, represents hash table containing hyper-text characters. (Inherited from IHyperText.)
Top
Events
 | Name | Description
Public event | HyperText | When implemented by a class, occurs when a control needs checking whether some string represents hypertext. (Inherited from IHyperText.)
Public event | UndoEvent | When implemented by a class, occurs when undo/redo operation performed. (Inherited from IUndo.)
Public event | WordSpell | When implemented by a class, occurs when spelling of some word within the text needs checking. (Inherited from ISpelling.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IInnerTextSource Methods

IInnerTextSource Methods

The IInnerTextSource type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | When implemented by a class, converts given absolute position to position as Point value. (Inherited from ITextSource.)
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | AddUndo | When implemented by a class, stores undo operation in the appropriate list. (Inherited from IUndo.)
Public method | BeginUndoUpdate | When implemented by a class, allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method. (Inherited from IUndo.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BeginUpdate(UpdateReason) | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from ITextNotify.)
Public method | BeginUpdateSnippet | When implemented by a class, prevents the Edit control from updating snippets until the EndUpdateSnippet method is called. (Inherited from ITextSnippets.)
Public method | BreakLine | When implemented by a class, breaks current line into two lines. (Inherited from IEdit.)
Public method | CancelParsing | When implemented by a class, stops formatting timer. (Inherited from ITextSource.)
Public method | CanRedo | When implemented by a class, indicating whether the redo operation can be performed. (Inherited from IUndo.)
Public method | CanUndo | When implemented by a class, indicating whether the undo operation can be performed. (Inherited from IUndo.)
Public method | Clear | When implemented by a class, clears content of the TextSource (Inherited from ITextSource.)
Public method | ClearRedo | When implemented by a class, clears list of redo operations. (Inherited from IUndo.)
Public method | ClearUndo | When implemented by a class, clears list of undo operations. (Inherited from IUndo.)
Public method | CreateStringItem | Create a new IStrItem object containing specified text. (Inherited from ITextSource.)
Public method | DeleteBlock | When implemented by a class, deletes a specified block of characters. (Inherited from IEdit.)
Public method | DeleteLeft | When implemented by a class, deletes a specified number of characters to the left of the active point. (Inherited from IEdit.)
Public method | DeleteRight | When implemented by a class, deletes a specified number of characters to the right of the active point. (Inherited from IEdit.)
Public method | DisablePositionUpdate | When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method. (Inherited from INavigate.)
Public method | DisableUndo | When implemented by a class, disables recording of undo/redo operations. (Inherited from IUndo.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnablePositionUpdate | When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method. (Inherited from INavigate.)
Public method | EnableUndo | When implemented by a class, re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method. (Inherited from IUndo.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUndoUpdate | When implemented by a class, ends undo block, that was started by BeginUndoUpdate method. (Inherited from IUndo.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | EndUpdateSnippet | When implemented by a class, resumes updating snippets after updating is suspended by the BeginUpdateSnippet method. (Inherited from ITextSnippets.)
Public method | FindClosingBrace(Point) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindClosingBrace(Int32, Int32) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Point) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Int32, Int32) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FormatText | When implemented by a class, formats and outlines TextSource text using attached Lexer. (Inherited from ITextParsing.)
Public method | FormatText(Boolean, Boolean) | When implemented by a class, formats and outlines TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing (Inherited from ITextParsing.)
Public method | GetCharIndexFromPosition | When implemented by a class, converts given Point value to the index of character. (Inherited from ITextSource.)
Public method | GetCodeFixes | When implemented by a class, gets code fixes for a given syntax error. (Inherited from ITextErrors.)
Public method | GetCodeSnippetRangeAt | When implemented by a class, locates code snippet at specified position. (Inherited from ITextSnippets.)
Public method | GetIndentString | When implemented by a class, gets indentation string at current position. (Inherited from IEdit.)
Public method | GetPositionFromCharIndex | When implemented by a class, converts given character index to position as Point value. (Inherited from ITextSource.)
Public method | GetStructureGuideLines | When implemented by a class, gets list of guide lines. (Inherited from ITextParsing.)
Public method | GetSyntaxErrorAt | When implemented by a class, gets syntax error at specified position. (Inherited from ITextErrors.)
Public method | HighlightBraces | When implemented by a class, highlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | HighlightCodeFixes | When implemented by a class, highlights code fixes if needed. (Inherited from ITextErrors.)
Public method | HighlightCodeSnippets | When implemented by a class, highlights code snippets using appropriate style. (Inherited from ITextSnippets.)
Public method | HighlightSyntaxErrors | When implemented by a class, highlights syntax errors. (Inherited from ITextErrors.)
Public method | IndentLine | When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned. (Inherited from IEdit.)
Public method | IndentLine(String, Boolean) | When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser (Inherited from IEdit.)
Public method | Insert | When implemented by a class, inserts the given string at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string array at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(ITextStrings, Boolean) | When implemented by a class, inserts the given string collection at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean, Boolean) | When implemented by a class, inserts the given string array at the specified location. (Inherited from IEdit.)
Public method | InsertFromFile | When implemented by a class, inserts the file text content at the specified location. (Inherited from IEdit.)
Public method | InvalidateSyntaxErrors | When implemented by a class, invalidates highlighting of syntax errors. (Inherited from ITextErrors.)
Public method | IsContentDivider | When implemented by a class, gets boolean value indicating whether text content is divided at given line. (Inherited from ITextParsing.)
Public method | IsHyperText | When implemented by a class, indicates whether given text represents hypertext. (Inherited from IHyperText.)
Public method | IsWordCorrect(String) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | IsWordCorrect(String, Point) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | LineIsHidden | When implemented by a class, determines whether the given line is hidden. (Inherited from IEdit.)
Public method | LineIsModified(Int32) | When implemented by a class, indicates whether specified line already modified. (Inherited from IUndo.)
Public method | LineIsModified(Int32, Boolean) | When implemented by a class, indicates whether specified line already modified. (Inherited from IUndo.)
Public method | LineIsReadonly | When implemented by a class, determines whether the given line is readonly. (Inherited from IEdit.)
Public method | LinesChanged(Int32, Int32) | When implemented by a class, specifies range of lines that was changed. (Inherited from ITextNotify.)
Public method | LinesChanged(Int32, Int32, Boolean) | When implemented by a class, specifies range of lines that was changed. (Inherited from ITextNotify.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer. (Inherited from ITextImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding. (Inherited from ITextImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | MoveTo(Point) | When implemented by a class, moves the current position to the given position. (Inherited from INavigate.)
Public method | MoveTo(Int32, Int32) | When implemented by a class, moves the current position to the given position. (Inherited from INavigate.)
Public method | MoveToChar | When implemented by a class, moves the current position to the specified character in the current line. (Inherited from INavigate.)
Public method | MoveToLine(Int32) | When implemented by a class, moves the current position to the specified line. (Inherited from INavigate.)
Public method | MoveToLine(Int32, Int32) | When implemented by a class, moves the current position to the specified line. (Inherited from INavigate.)
Public method | Navigate | When implemented by a class, moves current position by the given offset value. (Inherited from INavigate.)
Public method | NeedAutoComplete | When implemented by a class, indicates whether ITextSource should try to autocomplete statements. (Inherited from ITextParsing.)
Public method | NeedCacheIndent | When implemented by a class, indicates whether ITextSource can reuse previous indentation. (Inherited from ITextParsing.)
Public method | NeedCodeCompletion | When implemented by a class, indicates whether ITextSource can provide code completion operation for its content. (Inherited from ITextParsing.)
Public method | NeedCodeCompletionTabs | When implemented by a class, indicates code completion content can be filtered based on its priority. (Inherited from ITextParsing.)
Public method | NeedCodeFixes | When implemented by a class, indicates whether ITextSource can provide code fixes operations for its content. (Inherited from ITextParsing.)
Public method | NeedCodeRefactors | When implemented by a class, indicates whether ITextSource can provide code refactor operations for its content. (Inherited from ITextParsing.)
Public method | NeedFormatText | When implemented by a class, indicates whether ITextSource can format its content. (Inherited from ITextParsing.)
Public method | NeedFormatTextOnLineChange | When implemented by a class, indicates whether ITextSource should format spaces and case when changing the current line. (Inherited from ITextParsing.)
Public method | NeedIndentText | When implemented by a class, indicates whether ITextSource can indent its content. (Inherited from ITextParsing.)
Public method | NeedOutlineText | When implemented by a class, indicates whether ITextSource can outline its content. (Inherited from ITextParsing.)
Public method | NeedParse | When implemented by a class, indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted. (Inherited from ITextParsing.)
Public method | NeedQuickInfoTips | When implemented by a class, indicates whether ITextSource can obtain short description for syntax tokens within its content. (Inherited from ITextParsing.)
Public method | NeedReparseTextOnLineChange | When implemented by a class, indicates whether ITextSource should replace text when changing the current line. (Inherited from ITextParsing.)
Public method | NeedStructureGuideLines | When implemented by a class, indicates whether ITextSource can structure guidelines for its content. (Inherited from ITextParsing.)
Public method | NewLine | When implemented by a class, inserts a line break at the current position. (Inherited from IEdit.)
Public method | NewLine(String, Boolean) | When implemented by a class, inserts a line break at the current position with indentation. (Inherited from IEdit.)
Public method | NewLineAbove | When implemented by a class, inserts a line break above the current position. (Inherited from IEdit.)
Public method | NewLineBelow | When implemented by a class, inserts a line break below the current position. (Inherited from IEdit.)
Public method | Notification | When implemented by a class, updates control's content according to the parameters of notification. (Inherited from INotifier.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | ParseString | When implemented by a class, perform lexical analysis of the specified string. (Inherited from ITextParsing.)
Public method | ParseStrings | When implemented by a class, perform lexical analysis specified strings. (Inherited from ITextParsing.)
Public method | ParseToString | When implemented by a class, perform lexical analysis of specified strings. (Inherited from ITextParsing.)
Public method | PositionIsReadonly | When implemented by a class, determines whether the text at given position is readonly. (Inherited from IEdit.)
Public method | ProcessAutoComplete | When implemented by a class, inserts end-of-block code fragment if needed. (Inherited from ITextParsing.)
Public method | Redo | When implemented by a class, performs the last redo operation. (Inherited from IUndo.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | ResetBracesOptions | When implemented by a class, resets the BracesOptions to its default value. (Inherited from IBraceMatching.)
Public method | ResetCheckSpelling | When implemented by a class, resets the CheckSpelling to the default value. (Inherited from ISpelling.)
Public method | ResetClosingBraces | When implemented by a class, resets the ClosingBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetHighlightHyperText | When implemented by a class, resets HighlightUrls to the default value. (Inherited from IHyperText.)
Public method | ResetIndentOptions | When implemented by a class, resets the IndentOptions to the default value. (Inherited from IEdit.)
Public method | ResetMaxLength | When implemented by a class, resets the MaxLength to the default value. (Inherited from IEdit.)
Public method | ResetModified | When implemented by a class, resets the Modified to the default value. (Inherited from IEdit.)
Public method | ResetNavigateOptions | When implemented by a class, resets the NavigateOptions to the default value. (Inherited from INavigate.)
Public method | ResetOpenBraces | When implemented by a class, resets the OpenBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetOverWrite | When implemented by a class, resets the OverWrite to the default value. (Inherited from IEdit.)
Public method | ResetReadOnly | When implemented by a class, resets the Readonly to the default value. (Inherited from IEdit.)
Public method | ResetSingleLineMode | When implemented by a class, resets the SingleLineMode to the default value. (Inherited from IEdit.)
Public method | ResetSpellDelimiters | When implemented by a class, resets the SpellDelimiters to the default value. (Inherited from ISpelling.)
Public method | ResetUndoLimit | When implemented by a class, resets the UndoLimit to the default value. (Inherited from IUndo.)
Public method | ResetUndoOptions | When implemented by a class, resets the UndoOptions to the default value. (Inherited from IUndo.)
Public method | RestorePosition | When implemented by a class, restores position from stored position list by given index. (Inherited from INavigate.)
Public method | RestorePositionWithUndo | When implemented by a class, restores position from stored position list by given index. (Inherited from INavigate.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter. (Inherited from ITextExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding. (Inherited from ITextExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SetLastParsed | When implemented by a class, updates the last parsed line and resets first changed line to it's default value. (Inherited from ITextParsing.)
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line. (Inherited from IEdit.)
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line. (Inherited from IEdit.)
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line. (Inherited from IEdit.)
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line. (Inherited from IEdit.)
Public method | SetNavigateOptions | When implemented by a class, sets navigating options without validating position. (Inherited from INavigate.)
Public method | StartThread | When implemented in a class, executes action in thread. (Inherited from ITextThread.)
Public method | StopThread | When implemented in a class, aborts executing action in thread. (Inherited from ITextThread.)
Public method | StorePosition(Point) | When implemented by a class, stores given position to stored position list. (Inherited from INavigate.)
Public method | StorePosition(Point, Boolean) | When implemented by a class, stores given position to stored position list. (Inherited from INavigate.)
Public method | StorePositionWithUndo | When implemented by a class, stores given position to stored position list preserving it for undo. (Inherited from INavigate.)
Public method | TempHighlightBraces | When implemented by a class, temporary highlights all text within the area specified by rects. (Inherited from IBraceMatching.)
Public method | TempHighlightReferences | When implemented by a class, highlights found references. (Inherited from ITextSource.)
Public method | TempHighlightSearchResults | When implemented by a class, highlights search results. (Inherited from ITextSource.)
Public method | TempUnhighlightBraces | When implemented by a class, cancels text highlighting turned on using TempHighlightBraces (Inherited from IBraceMatching.)
Public method | TempUnhighlightReferences | When implemented by a class, unhighlights references highlighted with previous call of TempHighlightReferences. (Inherited from ITextSource.)
Public method | TempUnhighlightSearchResults | When implemented by a class, unhighlights search results highlighted with previous call of TempHighlightSearchResults. (Inherited from ITextSource.)
Public method | TextPointToAbsolutePosition | When implemented by a class, converts given Point value to the absolute position. (Inherited from ITextSource.)
Public method | UnBreakLine | When implemented by a class, concatenates lines at current position. (Inherited from IEdit.)
Public method | Undo(Boolean) | When implemented by a class, performs the last undo operation. (Inherited from IUndo.)
Public method | Undo(IUndoData, Boolean) | When implemented by a class, performs the single undo operation. (Inherited from IUndo.)
Public method | UnhighlightBraces | When implemented by a class, unhighlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | UnhighlightCodeSnippets | When implemented by a class, removes highlighting from code snippets and clears snippet collection. (Inherited from ITextSnippets.)
Public method | UnhighlightSyntaxErrors | When implemented by a class, removes syntax errors highlighting. (Inherited from ITextErrors.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | ValidatePosition | When implemented by a class, validates given position within control's text content. (Inherited from INavigate.)
Top
See Also

Reference

IInnerTextSource Interface
Alternet.Editor.TextSource Namespace


IInnerTextSource Properties

IInnerTextSource Properties

The IInnerTextSource type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEdit | When implemented by a class, gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source. (Inherited from ITextSource.)
Public property | BookMarks | When implemented by a class, represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source. (Inherited from ITextSource.)
Public property | BracesOptions | When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control. (Inherited from IBraceMatching.)
Public property | CheckSpelling | When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content. (Inherited from ISpelling.)
Public property | ClosingBraces | When implemented by a class, gets or sets an array of characters each one representing a closing brace. (Inherited from IBraceMatching.)
Public property | CodeSnippets | When implemented by a class, gets or sets ICodeSnippetRangeList for Edit control. (Inherited from ITextSnippets.)
Public property | CurrentSnippet | When implemented by a class, gets or sets current ICodeSnippetRange object. (Inherited from ITextSnippets.)
Public property | Edits | When implemented by a class, represents a collection of ISyntaxEdit controls linked to the text source. (Inherited from ITextSource.)
Public property | FileName | When implemented by a class, gets or sets name of file that holds text source content. (Inherited from ITextSource.)
Public property | FirstChanged | When implemented by a class, represents index of the first changed line. (Inherited from ITextNotify.)
Public property | GlobalSearch | When implemented by a class, specifies whether search should be global. (Inherited from ITextSource.)
Public property | HasSpelling | When implemented by a class, gets boolean value indicating that editor has external spell checker assigned. (Inherited from ISpelling.)
Public property | HighlightHyperText | When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted. (Inherited from IHyperText.)
Public property | HighlightMatchingBlocks | When implemented by a class, specifies that edit control should highlight begin/end blocks. (Inherited from ITextSource.)
Public property | HighlightReferences | When implemented by a class, specifies that edit control should highlight found references. (Inherited from ITextSource.)
Public property | IndentOptions | When implemented by a class, gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from IEdit.)
Public property | LastChanged | When implemented by a class, represents index of the last changed line. (Inherited from ITextNotify.)
Public property | Lexer | When implemented by a class, gets or sets object that can perform lexical analysis of the text source content. (Inherited from ITextParsing.)
Public property | Lines | When implemented by a class, represents the object that implements ITextStrings interface containing collection of strings determining text source content. (Inherited from ITextSource.)
Public property | LineStyles | When implemented by a class, represents an object that implements ILineStyles interface holding collection of line styles for this document. (Inherited from ITextSource.)
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | MaxLength | When implemented by a class, specifies the maximum number of characters that can be entered into the edit control. (Inherited from IEdit.)
Public property | Modified | When implemented by a class, gets or sets a value indicating whether the control's text content is modified. (Inherited from IEdit.)
Public property | ModifiedLineRegions | When implemented by a class, gets modified lines information, grouped in regions. (Inherited from IUndo.)
Public property | ModifiedLines | When implemented by a class, gets modified lines information. (Inherited from IUndo.)
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options. (Inherited from INavigate.)
Public property | OpenBraces | When implemented by a class, gets or sets an array of characters each one representing an open brace. (Inherited from IBraceMatching.)
Public property | OptimizedForMemory | When implemented by a class, specifies whether internal text representation should optimized memory usage. (Inherited from ITextSource.)
Public property | Overwrite | When implemented by a class, gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from IEdit.)
Public property | ParserLine | When implemented in a class, gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text. (Inherited from ITextParsing.)
Public property | Position | When implemented by a class, gets or sets current position within the control's text content. (Inherited from INavigate.)
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content. (Inherited from INavigate.)
Public property | ReadOnly | When implemented by a class, gets or sets a value indicating whether the control's content is read-only. (Inherited from IEdit.)
Public property | RedoList | When implemented by a class, provides an indexed access to redo data. (Inherited from IUndo.)
Public property | References | When implemented by a class, gets or sets IRangeList of found references for Edit control. (Inherited from ITextSource.)
Public property | SearchResults | When implemented by a class, gets IRangeList of search results highlighted by TempHighlightSearchResults. (Inherited from ITextSource.)
Public property | SelectBlockRect | When implemented by a class, represents a rectangular block of selected text. (Inherited from ITextNotify.)
Public property | SingleLineMode | When implemented by a class, gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from IEdit.)
Public property | SpellDelimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text when performing spelling check. (Inherited from ISpelling.)
Public property | SpellDelimiterString | When implemented by a class, gets or sets SpellDelimiters as a single string. (Inherited from ISpelling.)
Public property | SpellTable | When implemented by a class, represents a hash table containing delimiters. (Inherited from ISpelling.)
Public property | State | When implemented by a class, gets or sets last changes to the text stored in the text source. (Inherited from ITextNotify.)
Public property | SyntaxErrors | When implemented by a class, represents a syntax errors collection. (Inherited from ITextErrors.)
Public property | Text | When implemented by a class, gets or sets text source content as a single string with the individual strings delimited by carriage returns. (Inherited from ITextSource.)
Public property | ThreadAction | When implemented by a class, returns method executed in thread when parsing. (Inherited from ITextSource.)
Public property | UndoLimit | When implemented by a class, gets or sets a value that limits number of undo operations. (Inherited from IUndo.)
Public property | UndoList | When implemented by a class, provides an indexed access to undo data. (Inherited from IUndo.)
Public property | UndoOptions | When implemented by a class, gets or sets options for undo and redo operations. (Inherited from IUndo.)
Public property | UndoUpdateCount | When implemented by a class, keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested. (Inherited from IUndo.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UrlTable | When implemented by a class, represents hash table containing hyper-text characters. (Inherited from IHyperText.)
Top
See Also

Reference

IInnerTextSource Interface
Alternet.Editor.TextSource Namespace


IInnerTextSource Events

IInnerTextSource Events

The IInnerTextSource type exposes the following members.

Events
 | Name | Description
Public event | HyperText | When implemented by a class, occurs when a control needs checking whether some string represents hypertext. (Inherited from IHyperText.)
Public event | UndoEvent | When implemented by a class, occurs when undo/redo operation performed. (Inherited from IUndo.)
Public event | WordSpell | When implemented by a class, occurs when spelling of some word within the text needs checking. (Inherited from ISpelling.)
Top
See Also

Reference

IInnerTextSource Interface
Alternet.Editor.TextSource Namespace


ILineStyle Interface

ILineStyle Interface
This represents a particular style of some text line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILineStyle : IBookMark
Public Interface ILineStyle
    Inherits IBookMark
public interface class ILineStyle : IBookMark
type ILineStyle =
    interface
        interface IBookMark
    end

The ILineStyle type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IBookMark object. (Inherited from IBookMark.)
Top
Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of this IBookMark. (Inherited from IBookMark.)
Public property | FileName | When implemented by a class, gets or sets an file name associated with this IBookMark. (Inherited from IBookMark.)
Public property | Group | When implemented by a class, gets or sets a category associated with this IBookMark. (Inherited from IBookMark.)
Public property | ImageIndex | When implemented by a class, gets or sets an image index associated with this IBookMark. (Inherited from IBookMark.)
Public property | Index | When implemented by a class, gets an integer value that specifies ordinal number of the bookmark. (Inherited from IBookMark.)
Public property | Line | When implemented by a class, gets Y-coordinate of the position (index of line) within the Edit control's text. (Inherited from IBookMark.)
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of this IBookMark. (Inherited from IBookMark.)
Public property | Pos | When implemented by a class, gets X-coordinate of the bookmark position (position of character in a line) within the control's text. (Inherited from IBookMark.)
Public property | Position | When implemented by a class, gets or sets position of the bookmark within the control's text. Y-Coordinate represents index of line and X-Coordinate - index of character in this line. (Inherited from IBookMark.)
Public property | Priority | Specifies priority of the line style.
Public property | Range | Specifies range where line style is displayed.
Public property | Tag | When implemented by a class, gets or sets user-defined data associated with this IBookMark. (Inherited from IBookMark.)
Public property | Url | When implemented by a class, gets or sets an Url address of this IBookMark. (Inherited from IBookMark.)
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark. (Inherited from IBookMark.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ILineStyle Methods

ILineStyle Methods

The ILineStyle type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another IBookMark object. (Inherited from IBookMark.)
Top
See Also

Reference

ILineStyle Interface
Alternet.Editor.TextSource Namespace


ILineStyle Properties

ILineStyle Properties

The ILineStyle type exposes the following members.

Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of this IBookMark. (Inherited from IBookMark.)
Public property | FileName | When implemented by a class, gets or sets an file name associated with this IBookMark. (Inherited from IBookMark.)
Public property | Group | When implemented by a class, gets or sets a category associated with this IBookMark. (Inherited from IBookMark.)
Public property | ImageIndex | When implemented by a class, gets or sets an image index associated with this IBookMark. (Inherited from IBookMark.)
Public property | Index | When implemented by a class, gets an integer value that specifies ordinal number of the bookmark. (Inherited from IBookMark.)
Public property | Line | When implemented by a class, gets Y-coordinate of the position (index of line) within the Edit control's text. (Inherited from IBookMark.)
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of this IBookMark. (Inherited from IBookMark.)
Public property | Pos | When implemented by a class, gets X-coordinate of the bookmark position (position of character in a line) within the control's text. (Inherited from IBookMark.)
Public property | Position | When implemented by a class, gets or sets position of the bookmark within the control's text. Y-Coordinate represents index of line and X-Coordinate - index of character in this line. (Inherited from IBookMark.)
Public property | Priority | Specifies priority of the line style.
Public property | Range | Specifies range where line style is displayed.
Public property | Tag | When implemented by a class, gets or sets user-defined data associated with this IBookMark. (Inherited from IBookMark.)
Public property | Url | When implemented by a class, gets or sets an Url address of this IBookMark. (Inherited from IBookMark.)
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark. (Inherited from IBookMark.)
Top
See Also

Reference

ILineStyle Interface
Alternet.Editor.TextSource Namespace


ILineStyle.Priority Property

ILineStylePriority Property
Specifies priority of the line style.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Priority { get; set; }
Property Priority As Integer
    Get
    Set
property int Priority {
    int get ();
    void set (int value);
}
abstract Priority : int with get, set

Property Value

Type: Int32
See Also

Reference

ILineStyle Interface
Alternet.Editor.TextSource Namespace


ILineStyle.Range Property

ILineStyleRange Property
Specifies range where line style is displayed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange Range { get; set; }
Property Range As IRange
    Get
    Set
property IRange^ Range {
    IRange^ get ();
    void set (IRange^ value);
}
abstract Range : IRange with get, set

Property Value

Type: IRange
See Also

Reference

ILineStyle Interface
Alternet.Editor.TextSource Namespace


ILineStyles Interface

ILineStyles Interface
Represents properties and methods for a collection that binds line styles to individual lines within Edit control content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILineStyles : IList<ILineStyle>,
    ICollection<ILineStyle>, IEnumerable<ILineStyle>, IEnumerable
Public Interface ILineStyles
    Inherits IList(Of ILineStyle), ICollection(Of ILineStyle),
    IEnumerable(Of ILineStyle), IEnumerable
public interface class ILineStyles : IList<ILineStyle^>,
    ICollection<ILineStyle^>, IEnumerable<ILineStyle^>, IEnumerable
type ILineStyles =
    interface
        interface IList<ILineStyle>
        interface ICollection<ILineStyle>
        interface IEnumerable<ILineStyle>
        interface IEnumerable
    end

The ILineStyles type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILineStyle .)
Public method | Assign | When implemented by a class, copies the contents from another ILineStyles object.
Public method | BlockDeleting | When implemented by a class, removes all line styles within specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILineStyle .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILineStyle .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILineStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILineStyle .)
Public method | GetLineStyle | When implemented by a class, finds the first element in the line style collection located at the specified text line.
Public method | GetLineStyles | When implemented by a class, finds all linestyles in the ILineStyles collection located inside specified line.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILineStyle .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILineStyle .)
Public method | PositionChanged | When implemented by a class, updates all line styles starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILineStyle .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILineStyle .)
Public method | RemoveLineStyle(Int32) | When implemented by a class, removes the first line style at the specified line.
Public method | RemoveLineStyle(Int32, Int32) | When implemented by a class, removes the first line style at the specified line.
Public method | SetLineStyle(Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(Point, Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(Int32, Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(IRange, Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(Point, IRange, Int32, Int32) | Sets given line style to the specified line.
Public method | ToggleLineStyle(Int32, Int32) | When implemented by a class, sets or removes line style at the specified line.
Public method | ToggleLineStyle(Int32, Int32, Int32) | When implemented by a class, sets or removes line style at the specified line.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILineStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILineStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILineStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILineStyle .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILineStyle .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILineStyle .)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ILineStyles Methods

ILineStyles Methods

The ILineStyles type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILineStyle .)
Public method | Assign | When implemented by a class, copies the contents from another ILineStyles object.
Public method | BlockDeleting | When implemented by a class, removes all line styles within specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILineStyle .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILineStyle .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILineStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILineStyle .)
Public method | GetLineStyle | When implemented by a class, finds the first element in the line style collection located at the specified text line.
Public method | GetLineStyles | When implemented by a class, finds all linestyles in the ILineStyles collection located inside specified line.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILineStyle .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILineStyle .)
Public method | PositionChanged | When implemented by a class, updates all line styles starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILineStyle .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILineStyle .)
Public method | RemoveLineStyle(Int32) | When implemented by a class, removes the first line style at the specified line.
Public method | RemoveLineStyle(Int32, Int32) | When implemented by a class, removes the first line style at the specified line.
Public method | SetLineStyle(Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(Point, Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(Int32, Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(IRange, Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(Point, IRange, Int32, Int32) | Sets given line style to the specified line.
Public method | ToggleLineStyle(Int32, Int32) | When implemented by a class, sets or removes line style at the specified line.
Public method | ToggleLineStyle(Int32, Int32, Int32) | When implemented by a class, sets or removes line style at the specified line.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILineStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILineStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILineStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


ILineStyles.Assign Method

ILineStylesAssign Method
When implemented by a class, copies the contents from another ILineStyles object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ILineStyles source
)
Sub Assign (
    source As ILineStyles
)
void Assign(
    ILineStyles^ source
)
abstract Assign :
        source : ILineStyles -> unit

Parameters

source
Type: Alternet.Editor.TextSourceILineStyles
Specifies ILineStyles to assign.
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


ILineStyles.BlockDeleting Method

ILineStylesBlockDeleting Method
When implemented by a class, removes all line styles within specified rectangle.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BlockDeleting(
    Rectangle rect
)
Function BlockDeleting (
    rect As Rectangle
) As Boolean
bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to check.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


ILineStyles.GetLineStyle Method

ILineStylesGetLineStyle Method
When implemented by a class, finds the first element in the line style collection located at the specified text line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetLineStyle(
    int index
)
Function GetLineStyle (
    index As Integer
) As Integer
int GetLineStyle(
    int index
)
abstract GetLineStyle :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of the text line.

Return Value

Type: Int32
Index of the found line style if the search succeed; otherwise -1.
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


ILineStyles.GetLineStyles Method

ILineStylesGetLineStyles Method
When implemented by a class, finds all linestyles in the ILineStyles collection located inside specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetLineStyles(
    int line,
    IList<ILineStyle> list
)
Function GetLineStyles (
    line As Integer,
    list As IList(Of ILineStyle)
) As Integer
int GetLineStyles(
    int line,
    IList<ILineStyle^>^ list
)
abstract GetLineStyles :
        line : int *
        list : IList<ILineStyle> -> int

Parameters

line
Type: SystemInt32
The index of the line to find.
list
Type: System.Collections.GenericIListILineStyle
Represents the collection of the bookmarks located within the specified range.

Return Value

Type: Int32
The number of the linestyles located within the specified range.
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


ILineStyles.PositionChanged Method

ILineStylesPositionChanged Method
When implemented by a class, updates all line styles starting from specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


ILineStyles.RemoveLineStyle Method

ILineStylesRemoveLineStyle Method
Overload List
 | Name | Description
Public method | RemoveLineStyle(Int32) | When implemented by a class, removes the first line style at the specified line.
Public method | RemoveLineStyle(Int32, Int32) | When implemented by a class, removes the first line style at the specified line.
Top
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


ILineStyles.RemoveLineStyle Method (Int32)

ILineStylesRemoveLineStyle Method (Int32)
When implemented by a class, removes the first line style at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveLineStyle(
    int line
)
Sub RemoveLineStyle (
    line As Integer
)
void RemoveLineStyle(
    int line
)
abstract RemoveLineStyle :
        line : int -> unit

Parameters

line
Type: SystemInt32
Index of the text line.
See Also

Reference

ILineStyles Interface
RemoveLineStyle Overload
Alternet.Editor.TextSource Namespace


ILineStyles.RemoveLineStyle Method (Int32, Int32)

ILineStylesRemoveLineStyle Method (Int32, Int32)
When implemented by a class, removes the first line style at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveLineStyle(
    int line,
    int style
)
Sub RemoveLineStyle (
    line As Integer,
    style As Integer
)
void RemoveLineStyle(
    int line,
    int style
)
abstract RemoveLineStyle :
        line : int *
        style : int -> unit

Parameters

line
Type: SystemInt32
Index of the text line.
style
Type: SystemInt32
Index of style.
See Also

Reference

ILineStyles Interface
RemoveLineStyle Overload
Alternet.Editor.TextSource Namespace


ILineStyles.SetLineStyle Method

ILineStylesSetLineStyle Method
Overload List
 | Name | Description
Public method | SetLineStyle(Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(Point, Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(Int32, Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(IRange, Int32, Int32) | When implemented by a class, sets given line style to the specified line.
Public method | SetLineStyle(Point, IRange, Int32, Int32) | Sets given line style to the specified line.
Top
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


ILineStyles.SetLineStyle Method (Int32, Int32)

ILineStylesSetLineStyle Method (Int32, Int32)
When implemented by a class, sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLineStyle(
    int index,
    int style
)
Sub SetLineStyle (
    index As Integer,
    style As Integer
)
void SetLineStyle(
    int index,
    int style
)
abstract SetLineStyle :
        index : int *
        style : int -> unit

Parameters

index
Type: SystemInt32
Index of the text line.
style
Type: SystemInt32
Index of the line style.
See Also

Reference

ILineStyles Interface
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


ILineStyles.SetLineStyle Method (Point, Int32, Int32)

ILineStylesSetLineStyle Method (Point, Int32, Int32)
When implemented by a class, sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLineStyle(
    Point position,
    int priority,
    int style
)
Sub SetLineStyle (
    position As Point,
    priority As Integer,
    style As Integer
)
void SetLineStyle(
    Point position,
    int priority,
    int style
)
abstract SetLineStyle :
        position : Point *
        priority : int *
        style : int -> unit

Parameters

position
Type: System.DrawingPoint
Position of the line style.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of the line style.
See Also

Reference

ILineStyles Interface
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


ILineStyles.SetLineStyle Method (Int32, Int32, Int32)

ILineStylesSetLineStyle Method (Int32, Int32, Int32)
When implemented by a class, sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLineStyle(
    int line,
    int priority,
    int style
)
Sub SetLineStyle (
    line As Integer,
    priority As Integer,
    style As Integer
)
void SetLineStyle(
    int line,
    int priority,
    int style
)
abstract SetLineStyle :
        line : int *
        priority : int *
        style : int -> unit

Parameters

line
Type: SystemInt32
Index of the text line.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of the line style.
See Also

Reference

ILineStyles Interface
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


ILineStyles.SetLineStyle Method (IRange, Int32, Int32)

ILineStylesSetLineStyle Method (IRange, Int32, Int32)
When implemented by a class, sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLineStyle(
    IRange range,
    int priority,
    int style
)
Sub SetLineStyle (
    range As IRange,
    priority As Integer,
    style As Integer
)
void SetLineStyle(
    IRange^ range,
    int priority,
    int style
)
abstract SetLineStyle :
        range : IRange *
        priority : int *
        style : int -> unit

Parameters

range
Type: Alternet.CommonIRange
Range where line style is defined.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of the line style.
See Also

Reference

ILineStyles Interface
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


ILineStyles.SetLineStyle Method (Point, IRange, Int32, Int32)

ILineStylesSetLineStyle Method (Point, IRange, Int32, Int32)
Sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLineStyle(
    Point position,
    IRange range,
    int priority,
    int style
)
Sub SetLineStyle (
    position As Point,
    range As IRange,
    priority As Integer,
    style As Integer
)
void SetLineStyle(
    Point position,
    IRange^ range,
    int priority,
    int style
)
abstract SetLineStyle :
        position : Point *
        range : IRange *
        priority : int *
        style : int -> unit

Parameters

position
Type: System.DrawingPoint
Position of the line style.
range
Type: Alternet.CommonIRange
Range where line style is defined.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of the line style.
See Also

Reference

ILineStyles Interface
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


ILineStyles.ToggleLineStyle Method

ILineStylesToggleLineStyle Method
Overload List
 | Name | Description
Public method | ToggleLineStyle(Int32, Int32) | When implemented by a class, sets or removes line style at the specified line.
Public method | ToggleLineStyle(Int32, Int32, Int32) | When implemented by a class, sets or removes line style at the specified line.
Top
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


ILineStyles.ToggleLineStyle Method (Int32, Int32)

ILineStylesToggleLineStyle Method (Int32, Int32)
When implemented by a class, sets or removes line style at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleLineStyle(
    int line,
    int style
)
Sub ToggleLineStyle (
    line As Integer,
    style As Integer
)
void ToggleLineStyle(
    int line,
    int style
)
abstract ToggleLineStyle :
        line : int *
        style : int -> unit

Parameters

line
Type: SystemInt32
Index of line to toggle line style.
style
Type: SystemInt32
Index of style.
See Also

Reference

ILineStyles Interface
ToggleLineStyle Overload
Alternet.Editor.TextSource Namespace


ILineStyles.ToggleLineStyle Method (Int32, Int32, Int32)

ILineStylesToggleLineStyle Method (Int32, Int32, Int32)
When implemented by a class, sets or removes line style at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ToggleLineStyle(
    int line,
    int priority,
    int style
)
Sub ToggleLineStyle (
    line As Integer,
    priority As Integer,
    style As Integer
)
void ToggleLineStyle(
    int line,
    int priority,
    int style
)
abstract ToggleLineStyle :
        line : int *
        priority : int *
        style : int -> unit

Parameters

line
Type: SystemInt32
Index of line to toggle line style.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of style.
See Also

Reference

ILineStyles Interface
ToggleLineStyle Overload
Alternet.Editor.TextSource Namespace


ILineStyles Properties

ILineStyles Properties

The ILineStyles type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILineStyle .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILineStyle .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILineStyle .)
Top
See Also

Reference

ILineStyles Interface
Alternet.Editor.TextSource Namespace


INavigate Interface

INavigate Interface
Represents properties and methods allowing to navigate within the Edit control's text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INavigate
Public Interface INavigate
public interface class INavigate
type INavigate =  interface end

The INavigate type exposes the following members.

Methods
 | Name | Description
Public method | DisablePositionUpdate | When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method.
Public method | EnablePositionUpdate | When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
Public method | MoveTo(Point) | When implemented by a class, moves the current position to the given position.
Public method | MoveTo(Int32, Int32) | When implemented by a class, moves the current position to the given position.
Public method | MoveToChar | When implemented by a class, moves the current position to the specified character in the current line.
Public method | MoveToLine(Int32) | When implemented by a class, moves the current position to the specified line.
Public method | MoveToLine(Int32, Int32) | When implemented by a class, moves the current position to the specified line.
Public method | Navigate | When implemented by a class, moves current position by the given offset value.
Public method | ResetNavigateOptions | When implemented by a class, resets the NavigateOptions to the default value.
Public method | RestorePosition | When implemented by a class, restores position from stored position list by given index.
Public method | RestorePositionWithUndo | When implemented by a class, restores position from stored position list by given index.
Public method | SetNavigateOptions | When implemented by a class, sets navigating options without validating position.
Public method | StorePosition(Point) | When implemented by a class, stores given position to stored position list.
Public method | StorePosition(Point, Boolean) | When implemented by a class, stores given position to stored position list.
Public method | StorePositionWithUndo | When implemented by a class, stores given position to stored position list preserving it for undo.
Public method | ValidatePosition | When implemented by a class, validates given position within control's text content.
Top
Properties
 | Name | Description
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options.
Public property | Position | When implemented by a class, gets or sets current position within the control's text content.
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


INavigate Methods

INavigate Methods

The INavigate type exposes the following members.

Methods
 | Name | Description
Public method | DisablePositionUpdate | When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method.
Public method | EnablePositionUpdate | When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
Public method | MoveTo(Point) | When implemented by a class, moves the current position to the given position.
Public method | MoveTo(Int32, Int32) | When implemented by a class, moves the current position to the given position.
Public method | MoveToChar | When implemented by a class, moves the current position to the specified character in the current line.
Public method | MoveToLine(Int32) | When implemented by a class, moves the current position to the specified line.
Public method | MoveToLine(Int32, Int32) | When implemented by a class, moves the current position to the specified line.
Public method | Navigate | When implemented by a class, moves current position by the given offset value.
Public method | ResetNavigateOptions | When implemented by a class, resets the NavigateOptions to the default value.
Public method | RestorePosition | When implemented by a class, restores position from stored position list by given index.
Public method | RestorePositionWithUndo | When implemented by a class, restores position from stored position list by given index.
Public method | SetNavigateOptions | When implemented by a class, sets navigating options without validating position.
Public method | StorePosition(Point) | When implemented by a class, stores given position to stored position list.
Public method | StorePosition(Point, Boolean) | When implemented by a class, stores given position to stored position list.
Public method | StorePositionWithUndo | When implemented by a class, stores given position to stored position list preserving it for undo.
Public method | ValidatePosition | When implemented by a class, validates given position within control's text content.
Top
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.DisablePositionUpdate Method

INavigateDisablePositionUpdate Method
When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DisablePositionUpdate()
Sub DisablePositionUpdate
void DisablePositionUpdate()
abstract DisablePositionUpdate : unit -> unit

Return Value

Type:
Number of object state updating locks.
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.EnablePositionUpdate Method

INavigateEnablePositionUpdate Method
When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EnablePositionUpdate()
Sub EnablePositionUpdate
void EnablePositionUpdate()
abstract EnablePositionUpdate : unit -> unit

Return Value

Type:
Number of object state updating locks.
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.MoveTo Method

INavigateMoveTo Method
Overload List
 | Name | Description
Public method | MoveTo(Point) | When implemented by a class, moves the current position to the given position.
Public method | MoveTo(Int32, Int32) | When implemented by a class, moves the current position to the given position.
Top
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.MoveTo Method (Point)

INavigateMoveTo Method (Point)
When implemented by a class, moves the current position to the given position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveTo(
    Point position
)
Sub MoveTo (
    position As Point
)
void MoveTo(
    Point position
)
abstract MoveTo :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
New location of the current position.
See Also

Reference

INavigate Interface
MoveTo Overload
Alternet.Editor.TextSource Namespace


INavigate.MoveTo Method (Int32, Int32)

INavigateMoveTo Method (Int32, Int32)
When implemented by a class, moves the current position to the given position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveTo(
    int x,
    int y
)
Sub MoveTo (
    x As Integer,
    y As Integer
)
void MoveTo(
    int x,
    int y
)
abstract MoveTo :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
Index of character in the line to move to.
y
Type: SystemInt32
Index of line to move to.
See Also

Reference

INavigate Interface
MoveTo Overload
Alternet.Editor.TextSource Namespace


INavigate.MoveToChar Method

INavigateMoveToChar Method
When implemented by a class, moves the current position to the specified character in the current line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveToChar(
    int x
)
Sub MoveToChar (
    x As Integer
)
void MoveToChar(
    int x
)
abstract MoveToChar :
        x : int -> unit

Parameters

x
Type: SystemInt32
Index of character in the current line to move to.
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.MoveToLine Method

INavigateMoveToLine Method
Overload List
 | Name | Description
Public method | MoveToLine(Int32) | When implemented by a class, moves the current position to the specified line.
Public method | MoveToLine(Int32, Int32) | When implemented by a class, moves the current position to the specified line.
Top
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.MoveToLine Method (Int32)

INavigateMoveToLine Method (Int32)
When implemented by a class, moves the current position to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveToLine(
    int y
)
Sub MoveToLine (
    y As Integer
)
void MoveToLine(
    int y
)
abstract MoveToLine :
        y : int -> unit

Parameters

y
Type: SystemInt32
Index of line to move to.
See Also

Reference

INavigate Interface
MoveToLine Overload
Alternet.Editor.TextSource Namespace


INavigate.MoveToLine Method (Int32, Int32)

INavigateMoveToLine Method (Int32, Int32)
When implemented by a class, moves the current position to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveToLine(
    int y,
    int linesAbove
)
Sub MoveToLine (
    y As Integer,
    linesAbove As Integer
)
void MoveToLine(
    int y,
    int linesAbove
)
abstract MoveToLine :
        y : int *
        linesAbove : int -> unit

Parameters

y
Type: SystemInt32
Index of line to move to.
linesAbove
Type: SystemInt32
Number of lines to leave above cursor.
See Also

Reference

INavigate Interface
MoveToLine Overload
Alternet.Editor.TextSource Namespace


INavigate.Navigate Method

INavigateNavigate Method
When implemented by a class, moves current position by the given offset value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Navigate(
    int deltaX,
    int deltaY
)
Sub Navigate (
    deltaX As Integer,
    deltaY As Integer
)
void Navigate(
    int deltaX,
    int deltaY
)
abstract Navigate :
        deltaX : int *
        deltaY : int -> unit

Parameters

deltaX
Type: SystemInt32
Horizontal offset.
deltaY
Type: SystemInt32
Vertical offset.
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.ResetNavigateOptions Method

INavigateResetNavigateOptions Method
When implemented by a class, resets the NavigateOptions to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetNavigateOptions()
Sub ResetNavigateOptions
void ResetNavigateOptions()
abstract ResetNavigateOptions : unit -> unit
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.RestorePosition Method

INavigateRestorePosition Method
When implemented by a class, restores position from stored position list by given index.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point RestorePosition(
    int index
)
Function RestorePosition (
    index As Integer
) As Point
Point RestorePosition(
    int index
)
abstract RestorePosition :
        index : int -> Point

Parameters

index
Type: SystemInt32
Index of position to restore.

Return Value

Type: Point
Point value that represents stored position.
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.RestorePositionWithUndo Method

INavigateRestorePositionWithUndo Method
When implemented by a class, restores position from stored position list by given index.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RestorePositionWithUndo(
    int index
)
Sub RestorePositionWithUndo (
    index As Integer
)
void RestorePositionWithUndo(
    int index
)
abstract RestorePositionWithUndo :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of position to restore.
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.SetNavigateOptions Method

INavigateSetNavigateOptions Method
When implemented by a class, sets navigating options without validating position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetNavigateOptions(
    NavigateOptions navigateOptions
)
Sub SetNavigateOptions (
    navigateOptions As NavigateOptions
)
void SetNavigateOptions(
    NavigateOptions navigateOptions
)
abstract SetNavigateOptions :
        navigateOptions : NavigateOptions -> unit

Parameters

navigateOptions
Type: Alternet.Editor.TextSourceNavigateOptions
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.StorePosition Method

INavigateStorePosition Method
Overload List
 | Name | Description
Public method | StorePosition(Point) | When implemented by a class, stores given position to stored position list.
Public method | StorePosition(Point, Boolean) | When implemented by a class, stores given position to stored position list.
Top
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.StorePosition Method (Point)

INavigateStorePosition Method (Point)
When implemented by a class, stores given position to stored position list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int StorePosition(
    Point position
)
Function StorePosition (
    position As Point
) As Integer
int StorePosition(
    Point position
)
abstract StorePosition :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position to store.

Return Value

Type: Int32
Index of stored position in list.
See Also

Reference

INavigate Interface
StorePosition Overload
Alternet.Editor.TextSource Namespace


INavigate.StorePosition Method (Point, Boolean)

INavigateStorePosition Method (Point, Boolean)
When implemented by a class, stores given position to stored position list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int StorePosition(
    Point position,
    bool endPos
)
Function StorePosition (
    position As Point,
    endPos As Boolean
) As Integer
int StorePosition(
    Point position,
    bool endPos
)
abstract StorePosition :
        position : Point *
        endPos : bool -> int

Parameters

position
Type: System.DrawingPoint
Position to store.
endPos
Type: SystemBoolean
Specifies whether position represents end of range.

Return Value

Type: Int32
Index of stored position in list.
See Also

Reference

INavigate Interface
StorePosition Overload
Alternet.Editor.TextSource Namespace


INavigate.StorePositionWithUndo Method

INavigateStorePositionWithUndo Method
When implemented by a class, stores given position to stored position list preserving it for undo.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int StorePositionWithUndo(
    Point position
)
Function StorePositionWithUndo (
    position As Point
) As Integer
int StorePositionWithUndo(
    Point position
)
abstract StorePositionWithUndo :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position to store.

Return Value

Type: Int32
Index of stored position in list.
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.ValidatePosition Method

INavigateValidatePosition Method
When implemented by a class, validates given position within control's text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ValidatePosition(
    ref Point position
)
Sub ValidatePosition (
    ByRef position As Point
)
void ValidatePosition(
    Point% position
)
abstract ValidatePosition :
        position : Point byref -> unit

Parameters

position
Type: System.DrawingPoint
Position to validate.
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate Properties

INavigate Properties

The INavigate type exposes the following members.

Properties
 | Name | Description
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options.
Public property | Position | When implemented by a class, gets or sets current position within the control's text content.
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content.
Top
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.NavigateOptions Property

INavigateNavigateOptions Property
When implemented by a class, gets or sets navigating options.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
NavigateOptions NavigateOptions { get; set; }
Property NavigateOptions As NavigateOptions
    Get
    Set
property NavigateOptions NavigateOptions {
    NavigateOptions get ();
    void set (NavigateOptions value);
}
abstract NavigateOptions : NavigateOptions with get, set

Property Value

Type: NavigateOptions
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.Position Property

INavigatePosition Property
When implemented by a class, gets or sets current position within the control's text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Position { get; set; }
Property Position As Point
    Get
    Set
property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set

Property Value

Type: Point
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


INavigate.PrevPosition Property

INavigatePrevPosition Property
When implemented by a class, gets previous position within the control's text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point PrevPosition { get; }
ReadOnly Property PrevPosition As Point
    Get
property Point PrevPosition {
    Point get ();
}
abstract PrevPosition : Point with get

Property Value

Type: Point
See Also

Reference

INavigate Interface
Alternet.Editor.TextSource Namespace


IndentOptions Enumeration

IndentOptions Enumeration
Defines behaviour of Edit control when user presses Enter to insert new text line. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum IndentOptions
<FlagsAttribute>
Public Enumeration IndentOptions
[FlagsAttribute]
public enum class IndentOptions
[<FlagsAttribute>]
type IndentOptions
Members
Member name | Value | Description
None | 0 | No indentation.
AutoIndent | 1 | Positions the cursor under the first nonblank character of the preceding nonblank line when user presses Enter.
SmartIndent | 2 | Positions the cursor to the line indentation level, obtained from parser supporting option SyntaxOptions.SmartIndent when user presses Enter.
UsePrevIndent | 4 | Uses spaces and tabs from previous line when indenting the line.
JumpToIndent | 8 | Jumps to indent position rather than adding tabs or spaces.
See Also

Reference

Alternet.Editor.TextSource Namespace


InnerTextSource Class

InnerTextSource Class
Represents internal text source for Edit control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Editor.TextSourceTextSource
Alternet.Editor.TextSourceInnerTextSource

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InnerTextSource : TextSource,
    IInnerTextSource, ITextSource, IEdit, INavigate, IUndo,
    ITextNotify, INotify, IUpdate, INotifier, ITextImport,
    IImport, ITextExport, IExport, IHyperText, ISpelling,
    IBraceMatching, ITextParsing, ITextSnippets, ITextErrors, ITextThread
Public Class InnerTextSource
    Inherits TextSource
    Implements IInnerTextSource, ITextSource, IEdit, INavigate,
    IUndo, ITextNotify, INotify, IUpdate, INotifier,
    ITextImport, IImport, ITextExport, IExport, IHyperText,
    ISpelling, IBraceMatching, ITextParsing, ITextSnippets, ITextErrors,
    ITextThread
public ref class InnerTextSource : public TextSource,
    IInnerTextSource, ITextSource, IEdit, INavigate, IUndo,
    ITextNotify, INotify, IUpdate, INotifier, ITextImport,
    IImport, ITextExport, IExport, IHyperText, ISpelling,
    IBraceMatching, ITextParsing, ITextSnippets, ITextErrors, ITextThread
type InnerTextSource =
    class
        inherit TextSource
        interface IInnerTextSource
        interface ITextSource
        interface IEdit
        interface INavigate
        interface IUndo
        interface ITextNotify
        interface INotify
        interface IUpdate
        interface INotifier
        interface ITextImport
        interface IImport
        interface ITextExport
        interface IExport
        interface IHyperText
        interface ISpelling
        interface IBraceMatching
        interface ITextParsing
        interface ITextSnippets
        interface ITextErrors
        interface ITextThread
    end

The InnerTextSource type exposes the following members.

Constructors
 | Name | Description
Public method | InnerTextSource | Initializes a new instance of the InnerTextSource class
Public method | InnerTextSource(IContainer) | Initializes a new instance of the InnerTextSource class
Top
Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | Converts given absolute position to position as Point value. (Inherited from TextSource.)
Public method | AddNotifier | Adds new handler to respond for notification. (Inherited from TextSource.)
Public method | AddUndo | Stores undo operation in the appropriate list. (Inherited from TextSource.)
Public method | BeginUndoUpdate | Allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method. (Inherited from TextSource.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from TextSource.)
Public method | BeginUpdate(UpdateReason) | Prevents object state updating until calling EndUpdate method. (Inherited from TextSource.)
Public method | BeginUpdateSnippet | Prevents the Edit control from updating snippets until the EndUpdateSnippet method is called. (Inherited from TextSource.)
Public method | BreakLine | Breaks current line into two lines. (Inherited from TextSource.)
Public method | CancelParsing | Stops formatting timer. (Inherited from TextSource.)
Public method | CanRedo | Indicating whether the redo operation can be performed. (Inherited from TextSource.)
Public method | CanUndo | Indicating whether the undo operation can be performed. (Inherited from TextSource.)
Public method | Clear | Clears content of the TextSource (Inherited from TextSource.)
Public method | ClearRedo | Clears list of redo operations. (Inherited from TextSource.)
Public method | ClearUndo | Clears list of undo operations. (Inherited from TextSource.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateStringItem | Create a new IStringItem object containing specified text. (Inherited from TextSource.)
Public method | DeleteBlock(Rectangle, Boolean) | Deletes a specified block of characters. (Inherited from TextSource.)
Public method | DeleteBlock(Int32, Boolean) | Deletes a specified block of characters. (Inherited from TextSource.)
Public method | DeleteLeft | Deletes a specified number of characters to the left of the active point. (Inherited from TextSource.)
Public method | DeleteRight | Deletes a specified number of characters to the right of the active point. (Inherited from TextSource.)
Public method | DisablePositionUpdate | Prevents notification of changing of caret position until calling EnablePositionUpdate method. (Inherited from TextSource.)
Public method | DisableUndo | Disables recording of undo/redo operations. (Inherited from TextSource.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from TextSource.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnablePositionUpdate | Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method. (Inherited from TextSource.)
Public method | EnableUndo | Re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method. (Inherited from TextSource.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from TextSource.)
Public method | EndUndoUpdate | Ends undo block, that was started by BeginUndoUpdate method. (Inherited from TextSource.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from TextSource.)
Public method | EndUpdateSnippet | Resumes updating snippets after updating is suspended by the BeginUpdateSnippet method. (Inherited from TextSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindClosingBrace(Point) | Locates closing brace. (Inherited from TextSource.)
Public method | FindClosingBrace(Int32, Int32) | Locates closing brace. (Inherited from TextSource.)
Public method | FindOpenBrace(Point) | Locates open brace. (Inherited from TextSource.)
Public method | FindOpenBrace(Int32, Int32) | Locates open brace. (Inherited from TextSource.)
Public method | FormatText | Tries to format and outline TextSource text using attached Lexer. (Inherited from TextSource.)
Public method | FormatText(Boolean, Boolean) | Tries to format and outline TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing (Inherited from TextSource.)
Public method | GetCharIndexFromPosition | Converts given Point value to the index of character. (Inherited from TextSource.)
Public method | GetCodeFixes | Gets code fixes for a given syntax error. (Inherited from TextSource.)
Public method | GetCodeSnippetRangeAt | Locates code snippet at specified position. (Inherited from TextSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString | Gets indentation string at current position. (Inherited from TextSource.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPositionFromCharIndex | Converts given character index to position as Point value. (Inherited from TextSource.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from TextSource.)
Public method | GetSyntaxErrorAt | Gets syntax error at specified position. (Inherited from TextSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightBraces | Highlights braces containing caret position. (Inherited from TextSource.)
Public method | HighlightCodeFixes | Highlights code fixes if needed. (Inherited from TextSource.)
Public method | HighlightCodeRefactors | Highlights code fixes if needed. (Inherited from TextSource.)
Public method | HighlightCodeSnippets | Highlights code snippets using appropriate style. (Inherited from TextSource.)
Public method | HighlightSyntaxErrors | Highlights syntax errors. (Inherited from TextSource.)
Public method | IndentLine | Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned. (Inherited from TextSource.)
Public method | IndentLine(String, Boolean) | Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser (Inherited from TextSource.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Insert | Inserts the given string at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean) | Inserts the given string at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean) | Inserts the given string array at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(ITextStrings, Boolean) | Inserts the given string collection at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean, Boolean) | Inserts the given string array at the specified location. (Inherited from TextSource.)
Public method | InsertFromFile | Inserts the file text content at the specified location. (Inherited from TextSource.)
Public method | InvalidateSyntaxErrors | Invalidates highlighting of syntax errors. (Inherited from TextSource.)
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line. (Inherited from TextSource.)
Public method | IsHyperText | Indicates whether given text represents hypertext. (Inherited from TextSource.)
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct. (Inherited from TextSource.)
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct. (Inherited from TextSource.)
Public method | LineIsHidden | Determines whether the given line is readonly. (Inherited from TextSource.)
Public method | LineIsModified(Int32) | Indicates whether specified line already modified. (Inherited from TextSource.)
Public method | LineIsModified(Int32, Boolean) | Indicates whether specified line already modified. (Inherited from TextSource.)
Public method | LineIsReadonly | Determines whether the given line is readonly. (Inherited from TextSource.)
Public method | LinesChanged(Int32, Int32) | Specifies range of lines that was changed. (Inherited from TextSource.)
Public method | LinesChanged(Int32, Int32, Boolean) | Specifies range of lines that was changed. (Inherited from TextSource.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from TextSource.)
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer. (Inherited from TextSource.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from TextSource.)
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding. (Inherited from TextSource.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer. (Inherited from TextSource.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer. (Inherited from TextSource.)
Public method | MoveTo(Point) | Moves the current position to the given position. (Inherited from TextSource.)
Public method | MoveTo(Int32, Int32) | Moves the current position to the given position. (Inherited from TextSource.)
Public method | MoveToChar | Moves the current position to the specified character in the current line. (Inherited from TextSource.)
Public method | MoveToLine(Int32) | Moves the current position to the specified line. (Inherited from TextSource.)
Public method | MoveToLine(Int32, Int32) | Moves the current position to the specified line. (Inherited from TextSource.)
Public method | Navigate | Moves current position by the given offset value. (Inherited from TextSource.)
Public method | NeedAutoComplete | Indicates whether ITextSource should try to autocomplete statements. (Inherited from TextSource.)
Public method | NeedCacheIndent | Indicates whether ITextSource can reuse previous indentation. (Inherited from TextSource.)
Public method | NeedCodeCompletion | Indicates whether ITextSource can provide code completion operation for its content. (Inherited from TextSource.)
Public method | NeedCodeCompletionTabs | Indicates code completion content can be filtered based on its priority. (Inherited from TextSource.)
Public method | NeedCodeFixes | Indicates whether ITextSource can provide code fixes operation for its content. (Inherited from TextSource.)
Public method | NeedCodeRefactors | Indicates whether ITextSource can provide code fixes operation for its content. (Inherited from TextSource.)
Public method | NeedContentDividers | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedFormatText | Indicates whether ITextSource can format its content. (Inherited from TextSource.)
Public method | NeedFormatTextOnLineChange | Indicates whether ITextSource should format spaces and case when changing the current line. (Inherited from TextSource.)
Public method | NeedIndentText | Indicates whether ITextSource can indent its content. (Inherited from TextSource.)
Public method | NeedOutlineText | Indicates whether ITextSource can outline its content. (Inherited from TextSource.)
Public method | NeedParse | Indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted. (Inherited from TextSource.)
Public method | NeedQuickInfoTips | Indicates whether ITextSource can obtain short description for syntax tokens within its content. (Inherited from TextSource.)
Public method | NeedReparseText | Indicates whether ITextSource can perform syntax analysis of its content. (Inherited from TextSource.)
Public method | NeedReparseTextOnLineChange | Indicates whether ITextSource should replace text when changing the current line. (Inherited from TextSource.)
Public method | NeedStructureGuideLines | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedSyntaxErrors | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedWorkInThread | Indicates whether ITextSource can perform syntax analysis in thread. (Inherited from TextSource.)
Public method | NewLine | Inserts a line break at the current position. (Inherited from TextSource.)
Public method | NewLine(String, Boolean) | Inserts a line break at the current position with indentation. (Inherited from TextSource.)
Public method | NewLineAbove | Inserts a line break above the current position. (Inherited from TextSource.)
Public method | NewLineBelow | Inserts a line break below the current position. (Inherited from TextSource.)
Public method | Notification | Updates control's content according to parameters of notification. (Inherited from TextSource.)
Public method | Notify | Notifies all notifiers about changing source state. (Inherited from TextSource.)
Public method | ParseString | Perform lexical analysis of the specified string. (Inherited from TextSource.)
Public method | ParseStrings | Perform lexical analysis specified strings. (Inherited from TextSource.)
Public method | ParseToString | Perform lexical analysis of specified strings. (Inherited from TextSource.)
Public method | PositionIsReadonly | Determines whether the text at given position is readonly. (Inherited from TextSource.)
Public method | ProcessAutoComplete | Inserts end-of-block code fragment if needed. (Inherited from TextSource.)
Public method | Redo | Performs the last redo operation. (Inherited from TextSource.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from TextSource.)
Public method | ResetBracesOptions | Resets the BracesOptions to its default value. (Inherited from TextSource.)
Public method | ResetCheckSpelling | Resets the CheckSpelling to the default value. (Inherited from TextSource.)
Public method | ResetClosingBraces | Resets the ClosingBraces to its default value. (Inherited from TextSource.)
Public method | ResetHighlightHyperText | Resets HighlightHyperText to the default value. (Inherited from TextSource.)
Public method | ResetIndentOptions | Resets the IndentOptions to the default value. (Inherited from TextSource.)
Public method | ResetMaxLength | Resets the MaxLength to the default value. (Inherited from TextSource.)
Public method | ResetModified | Resets the Modified to the default value. (Inherited from TextSource.)
Public method | ResetNavigateOptions | Resets the NavigateOptions to the default value. (Inherited from TextSource.)
Public method | ResetOpenBraces | Resets the OpenBraces to its default value. (Inherited from TextSource.)
Public method | ResetOverWrite | Resets the OverWrite to the default value. (Inherited from TextSource.)
Public method | ResetReadOnly | Resets the ReadOnly to the default value. (Inherited from TextSource.)
Public method | ResetSingleLineMode | Resets the SingleLineMode to the default value. (Inherited from TextSource.)
Public method | ResetSpellDelimiters | Resets the SpellDelimiters to the default value. (Inherited from TextSource.)
Public method | ResetUndoLimit | Resets the UndoLimit to the default value. (Inherited from TextSource.)
Public method | ResetUndoOptions | Resets the UndoOptions to the default value. (Inherited from TextSource.)
Public method | RestorePosition | Restores position from stored position list by given index. (Inherited from TextSource.)
Public method | RestorePositionWithUndo | Restores position from stored position list by given index. (Inherited from TextSource.)
Public method | SaveFile(String) | Saves text content to the specific file. (Inherited from TextSource.)
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specific exporter. (Inherited from TextSource.)
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding. (Inherited from TextSource.)
Public method | SaveFile(String, IStringExport, Encoding) | Saves text content to the specific file with specific exporter and encoding. (Inherited from TextSource.)
Public method | SaveStream(Stream) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SetLastParsed | Updates the last parsed line and resets first changed line to it's default value. (Inherited from TextSource.)
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineState | Sets item state for the given line. (Inherited from TextSource.)
Public method | SetNavigateOptions | Sets navigating options without validating position. (Inherited from TextSource.)
Public method | ShouldSerializeClosingBraces | Indicates whether the ClosingBraces property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeIndentOptions | Indicates whether the IndentOptions property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeLexer | Indicates whether the Lexer property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeNavigateOptions | Indicates whether the NavigateOptions property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeOpenBraces | Indicates whether the OpenBraces property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeText | Indicates whether the Text property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeUndoOptions | Indicates whether the UndoOptions property should be persisted. (Inherited from TextSource.)
Public method | StartThread | Executes action in thread. (Inherited from TextSource.)
Public method | StopThread | Aborts executing action in thread. (Inherited from TextSource.)
Public method | StorePosition(Point) | Stores given position to stored position list. (Inherited from TextSource.)
Public method | StorePosition(Point, Boolean) | Stores given position to stored position list. (Inherited from TextSource.)
Public method | StorePositionWithUndo | Stores given position to stored position list preserving it for undo. (Inherited from TextSource.)
Public method | SupportsAsyncParsing | (Inherited from TextSource.)
Public method | TempHighlightBraces | Temporary highlights all text within the area specified by rects. (Inherited from TextSource.)
Public method | TempHighlightMatchingBlocks | Highlights block match. (Inherited from TextSource.)
Public method | TempHighlightReferences | Highlights found references. (Inherited from TextSource.)
Public method | TempHighlightSearchResults | Highlights search results. (Inherited from TextSource.)
Public method | TempUnhighlightBraces | Cancels text highlighting turned on using TempHighlightBraces (Inherited from TextSource.)
Public method | TempUnhighlightBraces(Boolean) | Unhighlights temporary braces areas. (Inherited from TextSource.)
Public method | TempUnhighlightReferences | Unhighlights references highlighted with previous call of TempHighlightReferences. (Inherited from TextSource.)
Public method | TempUnhighlightSearchResults | Unhighlights search results highlighted with previous call of TempHighlightSearchResults. (Inherited from TextSource.)
Public method | TextPointToAbsolutePosition | Converts given Point value to the absolute position. (Inherited from TextSource.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnBreakLine | Concatenates lines at current position. (Inherited from TextSource.)
Public method | Undo(Boolean) | Performs the last undo operation. (Inherited from TextSource.)
Public method | Undo(IUndoData, Boolean) | Performs the single undo operation. (Inherited from TextSource.)
Public method | UnhighlightBraces | Unhighlights braces containing caret position. (Inherited from TextSource.)
Public method | UnhighlightBraces(Boolean) | Unhighlights braces. (Inherited from TextSource.)
Public method | UnhighlightCodeSnippets | Removes highlighting from code snippets and clears snippet collection. (Inherited from TextSource.)
Public method | UnhighlightSyntaxErrors | Removes syntax errors highlighting. (Inherited from TextSource.)
Public method | Update | Updates an object state. (Inherited from TextSource.)
Public method | ValidatePosition | Validates given position within control's text content. (Inherited from TextSource.)
Top
Properties
 | Name | Description
Public property | ActiveEdit | Gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source. (Inherited from TextSource.)
Public property | BookMarks | Represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source. (Inherited from TextSource.)
Public property | BracesOptions | Gets or sets options specifying appearance and behaviour of matching braces within Edit control. (Inherited from TextSource.)
Public property | CheckSpelling | Gets or sets a value indicating whether the document can check spelling for its content. (Inherited from TextSource.)
Public property | ClosingBraces | Gets or sets an array of characters each one representing a closing brace. (Inherited from TextSource.)
Public property | CodeSnippets | Gets or sets ICodeSnippetRangeList for Edit control. (Inherited from TextSource.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentSnippet | Gets or sets current ICodeSnippetRange object. (Inherited from TextSource.)
Public property | Edits | Represents a collection of ISyntaxEdit controls linked to the text source. (Inherited from TextSource.)
Public property | FileName | Gets or sets name of file that holds text source content. (Inherited from TextSource.)
Public property | FirstChanged | Represents index of the first changed line. (Inherited from TextSource.)
Public property | GlobalSearch | Specifies whether search should be global. (Inherited from TextSource.)
Public property | HasSpelling | Gets boolean value indicating that editor has external spell checker assigned. (Inherited from TextSource.)
Public property | HighlightHyperText | Gets or sets a value indicating whether hypertext in the text should be highlighted. (Inherited from TextSource.)
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight found block matches. (Inherited from TextSource.)
Public property | HighlightReferences | Specifies that edit control should highlight found references. (Inherited from TextSource.)
Public property | IndentOptions | Gets or sets Alternet.Editor.TextSource.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from TextSource.)
Public property | LastChanged | Represents index of the last changed line. (Inherited from TextSource.)
Public property | Lexer | Gets or sets object that can perform lexical analysis of the text source content. (Inherited from TextSource.)
Public property | Lines | Represents the object that implements ITextStrings interface containing collection of strings determining text source content. (Inherited from TextSource.)
Public property | LineStyles | Represents an object that implements ILineStyles interface holding collection of line styles for this document. (Inherited from TextSource.)
Public property | LineTerminator | Gets or sets a string value that terminates line. (Inherited from TextSource.)
Public property | MatchingBlocks | Gets or sets IRangeList of matching begin/end blocks for Edit control. (Inherited from TextSource.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control. (Inherited from TextSource.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified. (Inherited from TextSource.)
Public property | ModifiedLineRegions | Gets modified lines information, grouped in regions. (Inherited from TextSource.)
Public property | ModifiedLines | Gets modified lines information. (Inherited from TextSource.)
Public property | NavigateOptions | Gets or sets navigating options. (Inherited from TextSource.)
Public property | OpenBraces | Gets or sets an array of characters each one representing an open brace. (Inherited from TextSource.)
Public property | OptimizedForMemory | Specifies whether internal text representation should optimized memory usage. (Inherited from TextSource.)
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from TextSource.)
Public property | ParserLine | Gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text. (Inherited from TextSource.)
Public property | Position | Gets or sets current position within the control's text content. (Inherited from TextSource.)
Public property | PrevPosition | Gets previous position within the control's text content. (Inherited from TextSource.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only. (Inherited from TextSource.)
Public property | RedoList | Provides an indexed access to redo data. (Inherited from TextSource.)
Public property | References | Gets or sets IRangeList of found references for Edit control. (Inherited from TextSource.)
Public property | SearchResults | Gets or sets IRangeList of search results for Edit control. (Inherited from TextSource.)
Public property | SelectBlockRect | Represents a rectangular block of selected text. (Inherited from TextSource.)
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from TextSource.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpellDelimiters | Gets or sets an array of chars used to separate words in a text. (Inherited from TextSource.)
Public property | SpellDelimiterString | Gets or sets Delimiters as a single string. (Inherited from TextSource.)
Public property | SpellTable | Represents a hash table containing delimiters. (Inherited from TextSource.)
Public property | State | Gets or sets last changes to the text stored in the text source. (Inherited from TextSource.)
Public property | Strings | Gets or sets text source content in the form of string array. (Inherited from TextSource.)
Public property | StructureGuideLines | Represents a syntax errors collection. (Inherited from TextSource.)
Public property | SyntaxErrors | Represents a syntax errors collection. (Inherited from TextSource.)
Public property | Text | Gets or sets text source content as a single string with the individual strings delimited by carriage returns. (Inherited from TextSource.)
Public property | ThreadAction | Returns method executed in thread when parsing. (Inherited from TextSource.)
Public property | UndoLimit | Gets or sets a value that limits number of undo operations. (Inherited from TextSource.)
Public property | UndoList | Provides an indexed access to undo data. (Inherited from TextSource.)
Public property | UndoOptions | Gets or sets options for undo and redo operations. (Inherited from TextSource.)
Public property | UndoUpdateCount | Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested. (Inherited from TextSource.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from TextSource.)
Public property | UrlTable | Represents hash table containing hyper-text characters. (Inherited from TextSource.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | HyperText | Occurs when a control needs checking whether some string represents hypertext. (Inherited from TextSource.)
Public event | UndoEvent | Occurs when undo/redo operation performed. (Inherited from TextSource.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking. (Inherited from TextSource.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


InnerTextSource Constructor

InnerTextSource Constructor
Overload List
 | Name | Description
Public method | InnerTextSource | Initializes a new instance of the InnerTextSource class
Public method | InnerTextSource(IContainer) | Initializes a new instance of the InnerTextSource class
Top
See Also

Reference

InnerTextSource Class
Alternet.Editor.TextSource Namespace


InnerTextSource Constructor

InnerTextSource Constructor
Initializes a new instance of the InnerTextSource class

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public InnerTextSource()
Public Sub New
public:
InnerTextSource()
new : unit -> InnerTextSource
See Also

Reference

InnerTextSource Class
InnerTextSource Overload
Alternet.Editor.TextSource Namespace


InnerTextSource Constructor (IContainer)

InnerTextSource Constructor (IContainer)
Initializes a new instance of the InnerTextSource class

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public InnerTextSource(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
InnerTextSource(
    IContainer^ container
)
new :
        container : IContainer -> InnerTextSource

Parameters

container
Type: System.ComponentModelIContainer
See Also

Reference

InnerTextSource Class
InnerTextSource Overload
Alternet.Editor.TextSource Namespace


InnerTextSource Methods

InnerTextSource Methods

The InnerTextSource type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | Converts given absolute position to position as Point value. (Inherited from TextSource.)
Public method | AddNotifier | Adds new handler to respond for notification. (Inherited from TextSource.)
Public method | AddUndo | Stores undo operation in the appropriate list. (Inherited from TextSource.)
Public method | BeginUndoUpdate | Allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method. (Inherited from TextSource.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from TextSource.)
Public method | BeginUpdate(UpdateReason) | Prevents object state updating until calling EndUpdate method. (Inherited from TextSource.)
Public method | BeginUpdateSnippet | Prevents the Edit control from updating snippets until the EndUpdateSnippet method is called. (Inherited from TextSource.)
Public method | BreakLine | Breaks current line into two lines. (Inherited from TextSource.)
Public method | CancelParsing | Stops formatting timer. (Inherited from TextSource.)
Public method | CanRedo | Indicating whether the redo operation can be performed. (Inherited from TextSource.)
Public method | CanUndo | Indicating whether the undo operation can be performed. (Inherited from TextSource.)
Public method | Clear | Clears content of the TextSource (Inherited from TextSource.)
Public method | ClearRedo | Clears list of redo operations. (Inherited from TextSource.)
Public method | ClearUndo | Clears list of undo operations. (Inherited from TextSource.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateStringItem | Create a new IStringItem object containing specified text. (Inherited from TextSource.)
Public method | DeleteBlock(Rectangle, Boolean) | Deletes a specified block of characters. (Inherited from TextSource.)
Public method | DeleteBlock(Int32, Boolean) | Deletes a specified block of characters. (Inherited from TextSource.)
Public method | DeleteLeft | Deletes a specified number of characters to the left of the active point. (Inherited from TextSource.)
Public method | DeleteRight | Deletes a specified number of characters to the right of the active point. (Inherited from TextSource.)
Public method | DisablePositionUpdate | Prevents notification of changing of caret position until calling EnablePositionUpdate method. (Inherited from TextSource.)
Public method | DisableUndo | Disables recording of undo/redo operations. (Inherited from TextSource.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from TextSource.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnablePositionUpdate | Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method. (Inherited from TextSource.)
Public method | EnableUndo | Re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method. (Inherited from TextSource.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from TextSource.)
Public method | EndUndoUpdate | Ends undo block, that was started by BeginUndoUpdate method. (Inherited from TextSource.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from TextSource.)
Public method | EndUpdateSnippet | Resumes updating snippets after updating is suspended by the BeginUpdateSnippet method. (Inherited from TextSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindClosingBrace(Point) | Locates closing brace. (Inherited from TextSource.)
Public method | FindClosingBrace(Int32, Int32) | Locates closing brace. (Inherited from TextSource.)
Public method | FindOpenBrace(Point) | Locates open brace. (Inherited from TextSource.)
Public method | FindOpenBrace(Int32, Int32) | Locates open brace. (Inherited from TextSource.)
Public method | FormatText | Tries to format and outline TextSource text using attached Lexer. (Inherited from TextSource.)
Public method | FormatText(Boolean, Boolean) | Tries to format and outline TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing (Inherited from TextSource.)
Public method | GetCharIndexFromPosition | Converts given Point value to the index of character. (Inherited from TextSource.)
Public method | GetCodeFixes | Gets code fixes for a given syntax error. (Inherited from TextSource.)
Public method | GetCodeSnippetRangeAt | Locates code snippet at specified position. (Inherited from TextSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString | Gets indentation string at current position. (Inherited from TextSource.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPositionFromCharIndex | Converts given character index to position as Point value. (Inherited from TextSource.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from TextSource.)
Public method | GetSyntaxErrorAt | Gets syntax error at specified position. (Inherited from TextSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightBraces | Highlights braces containing caret position. (Inherited from TextSource.)
Public method | HighlightCodeFixes | Highlights code fixes if needed. (Inherited from TextSource.)
Public method | HighlightCodeRefactors | Highlights code fixes if needed. (Inherited from TextSource.)
Public method | HighlightCodeSnippets | Highlights code snippets using appropriate style. (Inherited from TextSource.)
Public method | HighlightSyntaxErrors | Highlights syntax errors. (Inherited from TextSource.)
Public method | IndentLine | Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned. (Inherited from TextSource.)
Public method | IndentLine(String, Boolean) | Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser (Inherited from TextSource.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Insert | Inserts the given string at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean) | Inserts the given string at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean) | Inserts the given string array at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(ITextStrings, Boolean) | Inserts the given string collection at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean, Boolean) | Inserts the given string array at the specified location. (Inherited from TextSource.)
Public method | InsertFromFile | Inserts the file text content at the specified location. (Inherited from TextSource.)
Public method | InvalidateSyntaxErrors | Invalidates highlighting of syntax errors. (Inherited from TextSource.)
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line. (Inherited from TextSource.)
Public method | IsHyperText | Indicates whether given text represents hypertext. (Inherited from TextSource.)
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct. (Inherited from TextSource.)
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct. (Inherited from TextSource.)
Public method | LineIsHidden | Determines whether the given line is readonly. (Inherited from TextSource.)
Public method | LineIsModified(Int32) | Indicates whether specified line already modified. (Inherited from TextSource.)
Public method | LineIsModified(Int32, Boolean) | Indicates whether specified line already modified. (Inherited from TextSource.)
Public method | LineIsReadonly | Determines whether the given line is readonly. (Inherited from TextSource.)
Public method | LinesChanged(Int32, Int32) | Specifies range of lines that was changed. (Inherited from TextSource.)
Public method | LinesChanged(Int32, Int32, Boolean) | Specifies range of lines that was changed. (Inherited from TextSource.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from TextSource.)
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer. (Inherited from TextSource.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from TextSource.)
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding. (Inherited from TextSource.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer. (Inherited from TextSource.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer. (Inherited from TextSource.)
Public method | MoveTo(Point) | Moves the current position to the given position. (Inherited from TextSource.)
Public method | MoveTo(Int32, Int32) | Moves the current position to the given position. (Inherited from TextSource.)
Public method | MoveToChar | Moves the current position to the specified character in the current line. (Inherited from TextSource.)
Public method | MoveToLine(Int32) | Moves the current position to the specified line. (Inherited from TextSource.)
Public method | MoveToLine(Int32, Int32) | Moves the current position to the specified line. (Inherited from TextSource.)
Public method | Navigate | Moves current position by the given offset value. (Inherited from TextSource.)
Public method | NeedAutoComplete | Indicates whether ITextSource should try to autocomplete statements. (Inherited from TextSource.)
Public method | NeedCacheIndent | Indicates whether ITextSource can reuse previous indentation. (Inherited from TextSource.)
Public method | NeedCodeCompletion | Indicates whether ITextSource can provide code completion operation for its content. (Inherited from TextSource.)
Public method | NeedCodeCompletionTabs | Indicates code completion content can be filtered based on its priority. (Inherited from TextSource.)
Public method | NeedCodeFixes | Indicates whether ITextSource can provide code fixes operation for its content. (Inherited from TextSource.)
Public method | NeedCodeRefactors | Indicates whether ITextSource can provide code fixes operation for its content. (Inherited from TextSource.)
Public method | NeedContentDividers | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedFormatText | Indicates whether ITextSource can format its content. (Inherited from TextSource.)
Public method | NeedFormatTextOnLineChange | Indicates whether ITextSource should format spaces and case when changing the current line. (Inherited from TextSource.)
Public method | NeedIndentText | Indicates whether ITextSource can indent its content. (Inherited from TextSource.)
Public method | NeedOutlineText | Indicates whether ITextSource can outline its content. (Inherited from TextSource.)
Public method | NeedParse | Indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted. (Inherited from TextSource.)
Public method | NeedQuickInfoTips | Indicates whether ITextSource can obtain short description for syntax tokens within its content. (Inherited from TextSource.)
Public method | NeedReparseText | Indicates whether ITextSource can perform syntax analysis of its content. (Inherited from TextSource.)
Public method | NeedReparseTextOnLineChange | Indicates whether ITextSource should replace text when changing the current line. (Inherited from TextSource.)
Public method | NeedStructureGuideLines | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedSyntaxErrors | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedWorkInThread | Indicates whether ITextSource can perform syntax analysis in thread. (Inherited from TextSource.)
Public method | NewLine | Inserts a line break at the current position. (Inherited from TextSource.)
Public method | NewLine(String, Boolean) | Inserts a line break at the current position with indentation. (Inherited from TextSource.)
Public method | NewLineAbove | Inserts a line break above the current position. (Inherited from TextSource.)
Public method | NewLineBelow | Inserts a line break below the current position. (Inherited from TextSource.)
Public method | Notification | Updates control's content according to parameters of notification. (Inherited from TextSource.)
Public method | Notify | Notifies all notifiers about changing source state. (Inherited from TextSource.)
Public method | ParseString | Perform lexical analysis of the specified string. (Inherited from TextSource.)
Public method | ParseStrings | Perform lexical analysis specified strings. (Inherited from TextSource.)
Public method | ParseToString | Perform lexical analysis of specified strings. (Inherited from TextSource.)
Public method | PositionIsReadonly | Determines whether the text at given position is readonly. (Inherited from TextSource.)
Public method | ProcessAutoComplete | Inserts end-of-block code fragment if needed. (Inherited from TextSource.)
Public method | Redo | Performs the last redo operation. (Inherited from TextSource.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from TextSource.)
Public method | ResetBracesOptions | Resets the BracesOptions to its default value. (Inherited from TextSource.)
Public method | ResetCheckSpelling | Resets the CheckSpelling to the default value. (Inherited from TextSource.)
Public method | ResetClosingBraces | Resets the ClosingBraces to its default value. (Inherited from TextSource.)
Public method | ResetHighlightHyperText | Resets HighlightHyperText to the default value. (Inherited from TextSource.)
Public method | ResetIndentOptions | Resets the IndentOptions to the default value. (Inherited from TextSource.)
Public method | ResetMaxLength | Resets the MaxLength to the default value. (Inherited from TextSource.)
Public method | ResetModified | Resets the Modified to the default value. (Inherited from TextSource.)
Public method | ResetNavigateOptions | Resets the NavigateOptions to the default value. (Inherited from TextSource.)
Public method | ResetOpenBraces | Resets the OpenBraces to its default value. (Inherited from TextSource.)
Public method | ResetOverWrite | Resets the OverWrite to the default value. (Inherited from TextSource.)
Public method | ResetReadOnly | Resets the ReadOnly to the default value. (Inherited from TextSource.)
Public method | ResetSingleLineMode | Resets the SingleLineMode to the default value. (Inherited from TextSource.)
Public method | ResetSpellDelimiters | Resets the SpellDelimiters to the default value. (Inherited from TextSource.)
Public method | ResetUndoLimit | Resets the UndoLimit to the default value. (Inherited from TextSource.)
Public method | ResetUndoOptions | Resets the UndoOptions to the default value. (Inherited from TextSource.)
Public method | RestorePosition | Restores position from stored position list by given index. (Inherited from TextSource.)
Public method | RestorePositionWithUndo | Restores position from stored position list by given index. (Inherited from TextSource.)
Public method | SaveFile(String) | Saves text content to the specific file. (Inherited from TextSource.)
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specific exporter. (Inherited from TextSource.)
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding. (Inherited from TextSource.)
Public method | SaveFile(String, IStringExport, Encoding) | Saves text content to the specific file with specific exporter and encoding. (Inherited from TextSource.)
Public method | SaveStream(Stream) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SetLastParsed | Updates the last parsed line and resets first changed line to it's default value. (Inherited from TextSource.)
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineState | Sets item state for the given line. (Inherited from TextSource.)
Public method | SetNavigateOptions | Sets navigating options without validating position. (Inherited from TextSource.)
Public method | ShouldSerializeClosingBraces | Indicates whether the ClosingBraces property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeIndentOptions | Indicates whether the IndentOptions property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeLexer | Indicates whether the Lexer property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeNavigateOptions | Indicates whether the NavigateOptions property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeOpenBraces | Indicates whether the OpenBraces property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeText | Indicates whether the Text property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeUndoOptions | Indicates whether the UndoOptions property should be persisted. (Inherited from TextSource.)
Public method | StartThread | Executes action in thread. (Inherited from TextSource.)
Public method | StopThread | Aborts executing action in thread. (Inherited from TextSource.)
Public method | StorePosition(Point) | Stores given position to stored position list. (Inherited from TextSource.)
Public method | StorePosition(Point, Boolean) | Stores given position to stored position list. (Inherited from TextSource.)
Public method | StorePositionWithUndo | Stores given position to stored position list preserving it for undo. (Inherited from TextSource.)
Public method | SupportsAsyncParsing | (Inherited from TextSource.)
Public method | TempHighlightBraces | Temporary highlights all text within the area specified by rects. (Inherited from TextSource.)
Public method | TempHighlightMatchingBlocks | Highlights block match. (Inherited from TextSource.)
Public method | TempHighlightReferences | Highlights found references. (Inherited from TextSource.)
Public method | TempHighlightSearchResults | Highlights search results. (Inherited from TextSource.)
Public method | TempUnhighlightBraces | Cancels text highlighting turned on using TempHighlightBraces (Inherited from TextSource.)
Public method | TempUnhighlightBraces(Boolean) | Unhighlights temporary braces areas. (Inherited from TextSource.)
Public method | TempUnhighlightReferences | Unhighlights references highlighted with previous call of TempHighlightReferences. (Inherited from TextSource.)
Public method | TempUnhighlightSearchResults | Unhighlights search results highlighted with previous call of TempHighlightSearchResults. (Inherited from TextSource.)
Public method | TextPointToAbsolutePosition | Converts given Point value to the absolute position. (Inherited from TextSource.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnBreakLine | Concatenates lines at current position. (Inherited from TextSource.)
Public method | Undo(Boolean) | Performs the last undo operation. (Inherited from TextSource.)
Public method | Undo(IUndoData, Boolean) | Performs the single undo operation. (Inherited from TextSource.)
Public method | UnhighlightBraces | Unhighlights braces containing caret position. (Inherited from TextSource.)
Public method | UnhighlightBraces(Boolean) | Unhighlights braces. (Inherited from TextSource.)
Public method | UnhighlightCodeSnippets | Removes highlighting from code snippets and clears snippet collection. (Inherited from TextSource.)
Public method | UnhighlightSyntaxErrors | Removes syntax errors highlighting. (Inherited from TextSource.)
Public method | Update | Updates an object state. (Inherited from TextSource.)
Public method | ValidatePosition | Validates given position within control's text content. (Inherited from TextSource.)
Top
See Also

Reference

InnerTextSource Class
Alternet.Editor.TextSource Namespace


InnerTextSource Properties

InnerTextSource Properties

The InnerTextSource type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEdit | Gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source. (Inherited from TextSource.)
Public property | BookMarks | Represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source. (Inherited from TextSource.)
Public property | BracesOptions | Gets or sets options specifying appearance and behaviour of matching braces within Edit control. (Inherited from TextSource.)
Public property | CheckSpelling | Gets or sets a value indicating whether the document can check spelling for its content. (Inherited from TextSource.)
Public property | ClosingBraces | Gets or sets an array of characters each one representing a closing brace. (Inherited from TextSource.)
Public property | CodeSnippets | Gets or sets ICodeSnippetRangeList for Edit control. (Inherited from TextSource.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentSnippet | Gets or sets current ICodeSnippetRange object. (Inherited from TextSource.)
Public property | Edits | Represents a collection of ISyntaxEdit controls linked to the text source. (Inherited from TextSource.)
Public property | FileName | Gets or sets name of file that holds text source content. (Inherited from TextSource.)
Public property | FirstChanged | Represents index of the first changed line. (Inherited from TextSource.)
Public property | GlobalSearch | Specifies whether search should be global. (Inherited from TextSource.)
Public property | HasSpelling | Gets boolean value indicating that editor has external spell checker assigned. (Inherited from TextSource.)
Public property | HighlightHyperText | Gets or sets a value indicating whether hypertext in the text should be highlighted. (Inherited from TextSource.)
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight found block matches. (Inherited from TextSource.)
Public property | HighlightReferences | Specifies that edit control should highlight found references. (Inherited from TextSource.)
Public property | IndentOptions | Gets or sets Alternet.Editor.TextSource.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from TextSource.)
Public property | LastChanged | Represents index of the last changed line. (Inherited from TextSource.)
Public property | Lexer | Gets or sets object that can perform lexical analysis of the text source content. (Inherited from TextSource.)
Public property | Lines | Represents the object that implements ITextStrings interface containing collection of strings determining text source content. (Inherited from TextSource.)
Public property | LineStyles | Represents an object that implements ILineStyles interface holding collection of line styles for this document. (Inherited from TextSource.)
Public property | LineTerminator | Gets or sets a string value that terminates line. (Inherited from TextSource.)
Public property | MatchingBlocks | Gets or sets IRangeList of matching begin/end blocks for Edit control. (Inherited from TextSource.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control. (Inherited from TextSource.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified. (Inherited from TextSource.)
Public property | ModifiedLineRegions | Gets modified lines information, grouped in regions. (Inherited from TextSource.)
Public property | ModifiedLines | Gets modified lines information. (Inherited from TextSource.)
Public property | NavigateOptions | Gets or sets navigating options. (Inherited from TextSource.)
Public property | OpenBraces | Gets or sets an array of characters each one representing an open brace. (Inherited from TextSource.)
Public property | OptimizedForMemory | Specifies whether internal text representation should optimized memory usage. (Inherited from TextSource.)
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from TextSource.)
Public property | ParserLine | Gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text. (Inherited from TextSource.)
Public property | Position | Gets or sets current position within the control's text content. (Inherited from TextSource.)
Public property | PrevPosition | Gets previous position within the control's text content. (Inherited from TextSource.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only. (Inherited from TextSource.)
Public property | RedoList | Provides an indexed access to redo data. (Inherited from TextSource.)
Public property | References | Gets or sets IRangeList of found references for Edit control. (Inherited from TextSource.)
Public property | SearchResults | Gets or sets IRangeList of search results for Edit control. (Inherited from TextSource.)
Public property | SelectBlockRect | Represents a rectangular block of selected text. (Inherited from TextSource.)
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from TextSource.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpellDelimiters | Gets or sets an array of chars used to separate words in a text. (Inherited from TextSource.)
Public property | SpellDelimiterString | Gets or sets Delimiters as a single string. (Inherited from TextSource.)
Public property | SpellTable | Represents a hash table containing delimiters. (Inherited from TextSource.)
Public property | State | Gets or sets last changes to the text stored in the text source. (Inherited from TextSource.)
Public property | Strings | Gets or sets text source content in the form of string array. (Inherited from TextSource.)
Public property | StructureGuideLines | Represents a syntax errors collection. (Inherited from TextSource.)
Public property | SyntaxErrors | Represents a syntax errors collection. (Inherited from TextSource.)
Public property | Text | Gets or sets text source content as a single string with the individual strings delimited by carriage returns. (Inherited from TextSource.)
Public property | ThreadAction | Returns method executed in thread when parsing. (Inherited from TextSource.)
Public property | UndoLimit | Gets or sets a value that limits number of undo operations. (Inherited from TextSource.)
Public property | UndoList | Provides an indexed access to undo data. (Inherited from TextSource.)
Public property | UndoOptions | Gets or sets options for undo and redo operations. (Inherited from TextSource.)
Public property | UndoUpdateCount | Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested. (Inherited from TextSource.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from TextSource.)
Public property | UrlTable | Represents hash table containing hyper-text characters. (Inherited from TextSource.)
Top
See Also

Reference

InnerTextSource Class
Alternet.Editor.TextSource Namespace


InnerTextSource Events

InnerTextSource Events

The InnerTextSource type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | HyperText | Occurs when a control needs checking whether some string represents hypertext. (Inherited from TextSource.)
Public event | UndoEvent | Occurs when undo/redo operation performed. (Inherited from TextSource.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking. (Inherited from TextSource.)
Top
See Also

Reference

InnerTextSource Class
Alternet.Editor.TextSource Namespace


ISpelling Interface

ISpelling Interface
Represents properties and methods allowing check spelling of the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISpelling
Public Interface ISpelling
public interface class ISpelling
type ISpelling =  interface end

The ISpelling type exposes the following members.

Methods
 | Name | Description
Public method | IsWordCorrect(String) | When implemented by a class, checks whether spelling for the given word is correct.
Public method | IsWordCorrect(String, Point) | When implemented by a class, checks whether spelling for the given word is correct.
Public method | ResetCheckSpelling | When implemented by a class, resets the CheckSpelling to the default value.
Public method | ResetSpellDelimiters | When implemented by a class, resets the SpellDelimiters to the default value.
Top
Properties
 | Name | Description
Public property | CheckSpelling | When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content.
Public property | HasSpelling | When implemented by a class, gets boolean value indicating that editor has external spell checker assigned.
Public property | SpellDelimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text when performing spelling check.
Public property | SpellDelimiterString | When implemented by a class, gets or sets SpellDelimiters as a single string.
Public property | SpellTable | When implemented by a class, represents a hash table containing delimiters.
Top
Events
 | Name | Description
Public event | WordSpell | When implemented by a class, occurs when spelling of some word within the text needs checking.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ISpelling Methods

ISpelling Methods

The ISpelling type exposes the following members.

Methods
 | Name | Description
Public method | IsWordCorrect(String) | When implemented by a class, checks whether spelling for the given word is correct.
Public method | IsWordCorrect(String, Point) | When implemented by a class, checks whether spelling for the given word is correct.
Public method | ResetCheckSpelling | When implemented by a class, resets the CheckSpelling to the default value.
Public method | ResetSpellDelimiters | When implemented by a class, resets the SpellDelimiters to the default value.
Top
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling.IsWordCorrect Method

ISpellingIsWordCorrect Method
Overload List
 | Name | Description
Public method | IsWordCorrect(String) | When implemented by a class, checks whether spelling for the given word is correct.
Public method | IsWordCorrect(String, Point) | When implemented by a class, checks whether spelling for the given word is correct.
Top
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling.IsWordCorrect Method (String)

ISpellingIsWordCorrect Method (String)
When implemented by a class, checks whether spelling for the given word is correct.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsWordCorrect(
    string text
)
Function IsWordCorrect (
    text As String
) As Boolean
bool IsWordCorrect(
    String^ text
)
abstract IsWordCorrect :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies text to check-up.

Return Value

Type: Boolean
True if correct; otherwise false.
See Also

Reference

ISpelling Interface
IsWordCorrect Overload
Alternet.Editor.TextSource Namespace


ISpelling.IsWordCorrect Method (String, Point)

ISpellingIsWordCorrect Method (String, Point)
When implemented by a class, checks whether spelling for the given word is correct.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsWordCorrect(
    string text,
    Point position
)
Function IsWordCorrect (
    text As String,
    position As Point
) As Boolean
bool IsWordCorrect(
    String^ text,
    Point position
)
abstract IsWordCorrect :
        text : string *
        position : Point -> bool

Parameters

text
Type: SystemString
Specifies text to check-up.
position
Type: System.DrawingPoint
Specifies position of the word within the text.

Return Value

Type: Boolean
True if correct; otherwise false.
See Also

Reference

ISpelling Interface
IsWordCorrect Overload
Alternet.Editor.TextSource Namespace


ISpelling.ResetCheckSpelling Method

ISpellingResetCheckSpelling Method
When implemented by a class, resets the CheckSpelling to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetCheckSpelling()
Sub ResetCheckSpelling
void ResetCheckSpelling()
abstract ResetCheckSpelling : unit -> unit
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling.ResetSpellDelimiters Method

ISpellingResetSpellDelimiters Method
When implemented by a class, resets the SpellDelimiters to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetSpellDelimiters()
Sub ResetSpellDelimiters
void ResetSpellDelimiters()
abstract ResetSpellDelimiters : unit -> unit
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling Properties

ISpelling Properties

The ISpelling type exposes the following members.

Properties
 | Name | Description
Public property | CheckSpelling | When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content.
Public property | HasSpelling | When implemented by a class, gets boolean value indicating that editor has external spell checker assigned.
Public property | SpellDelimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text when performing spelling check.
Public property | SpellDelimiterString | When implemented by a class, gets or sets SpellDelimiters as a single string.
Public property | SpellTable | When implemented by a class, represents a hash table containing delimiters.
Top
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling.CheckSpelling Property

ISpellingCheckSpelling Property
When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CheckSpelling { get; set; }
Property CheckSpelling As Boolean
    Get
    Set
property bool CheckSpelling {
    bool get ();
    void set (bool value);
}
abstract CheckSpelling : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling.HasSpelling Property

ISpellingHasSpelling Property
When implemented by a class, gets boolean value indicating that editor has external spell checker assigned.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasSpelling { get; }
ReadOnly Property HasSpelling As Boolean
    Get
property bool HasSpelling {
    bool get ();
}
abstract HasSpelling : bool with get

Property Value

Type: Boolean
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling.SpellDelimiters Property

ISpellingSpellDelimiters Property
When implemented by a class, gets or sets an array of characters used as delimiters between words in the text when performing spelling check.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] SpellDelimiters { get; set; }
Property SpellDelimiters As Char()
    Get
    Set
property array<wchar_t>^ SpellDelimiters {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract SpellDelimiters : char[] with get, set

Property Value

Type: Char
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling.SpellDelimiterString Property

ISpellingSpellDelimiterString Property
When implemented by a class, gets or sets SpellDelimiters as a single string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string SpellDelimiterString { get; set; }
Property SpellDelimiterString As String
    Get
    Set
property String^ SpellDelimiterString {
    String^ get ();
    void set (String^ value);
}
abstract SpellDelimiterString : string with get, set

Property Value

Type: String
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling.SpellTable Property

ISpellingSpellTable Property
When implemented by a class, represents a hash table containing delimiters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Hashtable SpellTable { get; }
ReadOnly Property SpellTable As Hashtable
    Get
property Hashtable^ SpellTable {
    Hashtable^ get ();
}
abstract SpellTable : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling Events

ISpelling Events

The ISpelling type exposes the following members.

Events
 | Name | Description
Public event | WordSpell | When implemented by a class, occurs when spelling of some word within the text needs checking.
Top
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


ISpelling.WordSpell Event

ISpellingWordSpell Event
When implemented by a class, occurs when spelling of some word within the text needs checking.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event WordSpellEvent WordSpell
Event WordSpell As WordSpellEvent
 event WordSpellEvent^ WordSpell {
    void add (WordSpellEvent^ value);
    void remove (WordSpellEvent^ value);
}
abstract WordSpell : IEvent<WordSpellEvent,
    WordSpellEventArgs>

Value

Type: Alternet.Editor.TextSourceWordSpellEvent
See Also

Reference

ISpelling Interface
Alternet.Editor.TextSource Namespace


IStringExport Interface

IStringExport Interface
Provides methods to save IStringItem elements.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStringExport
Public Interface IStringExport
public interface class IStringExport
type IStringExport =  interface end

The IStringExport type exposes the following members.

Methods
 | Name | Description
Public method | BeginWrite | When implemented by a class, starts writing routine.
Public method | EndWrite | When implemented by a class, finalizes writing routine.
Public method | Write | When implemented by a class, saves entire content.
Public method | WriteLine | When implemented by a class, saves a particular IStringItem object.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IStringExport Methods

IStringExport Methods

The IStringExport type exposes the following members.

Methods
 | Name | Description
Public method | BeginWrite | When implemented by a class, starts writing routine.
Public method | EndWrite | When implemented by a class, finalizes writing routine.
Public method | Write | When implemented by a class, saves entire content.
Public method | WriteLine | When implemented by a class, saves a particular IStringItem object.
Top
See Also

Reference

IStringExport Interface
Alternet.Editor.TextSource Namespace


IStringExport.BeginWrite Method

IStringExportBeginWrite Method
When implemented by a class, starts writing routine.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BeginWrite(
    TextWriter writer,
    Object userData
)
Sub BeginWrite (
    writer As TextWriter,
    userData As Object
)
void BeginWrite(
    TextWriter^ writer,
    Object^ userData
)
abstract BeginWrite :
        writer : TextWriter *
        userData : Object -> unit

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.
userData
Type: SystemObject
Data to be saved.
See Also

Reference

IStringExport Interface
Alternet.Editor.TextSource Namespace


IStringExport.EndWrite Method

IStringExportEndWrite Method
When implemented by a class, finalizes writing routine.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EndWrite()
Sub EndWrite
void EndWrite()
abstract EndWrite : unit -> unit
See Also

Reference

IStringExport Interface
Alternet.Editor.TextSource Namespace


IStringExport.Write Method

IStringExportWrite Method
When implemented by a class, saves entire content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Write()
Function Write As Boolean
bool Write()
abstract Write : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IStringExport Interface
Alternet.Editor.TextSource Namespace


IStringExport.WriteLine Method

IStringExportWriteLine Method
When implemented by a class, saves a particular IStringItem object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void WriteLine(
    IStringItem item
)
Sub WriteLine (
    item As IStringItem
)
void WriteLine(
    IStringItem^ item
)
abstract WriteLine :
        item : IStringItem -> unit

Parameters

item
Type: Alternet.SyntaxIStringItem
IStringItem to save.
See Also

Reference

IStringExport Interface
Alternet.Editor.TextSource Namespace


IStringImport Interface

IStringImport Interface
Provides methods to load text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStringImport
Public Interface IStringImport
public interface class IStringImport
type IStringImport =  interface end

The IStringImport type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | When implemented by a class, starts reading routine.
Public method | EndRead | When implemented by a class, finalizes reading routine.
Public method | Read | When implemented by a class, loads entire content.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IStringImport Methods

IStringImport Methods

The IStringImport type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | When implemented by a class, starts reading routine.
Public method | EndRead | When implemented by a class, finalizes reading routine.
Public method | Read | When implemented by a class, loads entire content.
Top
See Also

Reference

IStringImport Interface
Alternet.Editor.TextSource Namespace


IStringImport.BeginRead Method

IStringImportBeginRead Method
When implemented by a class, starts reading routine.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BeginRead(
    TextReader reader,
    Object userData
)
Sub BeginRead (
    reader As TextReader,
    userData As Object
)
void BeginRead(
    TextReader^ reader,
    Object^ userData
)
abstract BeginRead :
        reader : TextReader *
        userData : Object -> unit

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.
userData
Type: SystemObject
Data to be loaded.
See Also

Reference

IStringImport Interface
Alternet.Editor.TextSource Namespace


IStringImport.EndRead Method

IStringImportEndRead Method
When implemented by a class, finalizes reading routine.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EndRead()
Sub EndRead
void EndRead()
abstract EndRead : unit -> unit
See Also

Reference

IStringImport Interface
Alternet.Editor.TextSource Namespace


IStringImport.Read Method

IStringImportRead Method
When implemented by a class, loads entire content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Read()
Function Read As Boolean
bool Read()
abstract Read : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IStringImport Interface
Alternet.Editor.TextSource Namespace


ITabulation Interface

ITabulation Interface
Represents properties and methods for handling tabulations within the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITabulation
Public Interface ITabulation
public interface class ITabulation
type ITabulation =  interface end

The ITabulation type exposes the following members.

Methods
 | Name | Description
Public method | GetIndentString(Int32, Int32) | When implemented by a class, returns indentation string which consist of tabs and spaces.
Public method | GetIndentString(Int32, Int32, Boolean) | When implemented by a class, returns indentation string which consist of tabs and spaces.
Public method | GetPrevTabStop | When implemented by a class, returns number of spaces to the previous TabStop.
Public method | GetTabStop | When implemented by a class, returns number of spaces to the next TabStop at the specified position.
Public method | GetTabString(String) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTabString(String, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | PosToTabPos(String, Int32) | When implemented by a class, returns specified position within given string as tabbed position.
Public method | PosToTabPos(String, Int32, Boolean) | When implemented by a class, returns specified position within given string as tabbed position.
Public method | ResetTabStops | When implemented by a class, resets the ITabulation.TabStops to the default value.
Public method | ResetUseSpaces | When implemented by a class, resets the ITabulation.UseSpaces to the default value.
Public method | TabPosToPos | When implemented by a class, returns specified position within given string as untabbed position.
Top
Properties
 | Name | Description
Public property | TabStops | When implemented by a class, gets or sets the character columns that the cursor will move to each time you press Tab.
Public property | UseSpaces | When implemented by a class, gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITabulation Methods

ITabulation Methods

The ITabulation type exposes the following members.

Methods
 | Name | Description
Public method | GetIndentString(Int32, Int32) | When implemented by a class, returns indentation string which consist of tabs and spaces.
Public method | GetIndentString(Int32, Int32, Boolean) | When implemented by a class, returns indentation string which consist of tabs and spaces.
Public method | GetPrevTabStop | When implemented by a class, returns number of spaces to the previous TabStop.
Public method | GetTabStop | When implemented by a class, returns number of spaces to the next TabStop at the specified position.
Public method | GetTabString(String) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTabString(String, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | PosToTabPos(String, Int32) | When implemented by a class, returns specified position within given string as tabbed position.
Public method | PosToTabPos(String, Int32, Boolean) | When implemented by a class, returns specified position within given string as tabbed position.
Public method | ResetTabStops | When implemented by a class, resets the ITabulation.TabStops to the default value.
Public method | ResetUseSpaces | When implemented by a class, resets the ITabulation.UseSpaces to the default value.
Public method | TabPosToPos | When implemented by a class, returns specified position within given string as untabbed position.
Top
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.GetIndentString Method

ITabulationGetIndentString Method
Overload List
 | Name | Description
Public method | GetIndentString(Int32, Int32) | When implemented by a class, returns indentation string which consist of tabs and spaces.
Public method | GetIndentString(Int32, Int32, Boolean) | When implemented by a class, returns indentation string which consist of tabs and spaces.
Top
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.GetIndentString Method (Int32, Int32)

ITabulationGetIndentString Method (Int32, Int32)
When implemented by a class, returns indentation string which consist of tabs and spaces.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetIndentString(
    int count,
    int pos
)
Function GetIndentString (
    count As Integer,
    pos As Integer
) As String
String^ GetIndentString(
    int count,
    int pos
)
abstract GetIndentString :
        count : int *
        pos : int -> string

Parameters

count
Type: SystemInt32
Specifies number of characters in the string.
pos
Type: SystemInt32
Specifies start position of the string.

Return Value

Type: String
Indented string that containing tabs and spaces.
See Also

Reference

ITabulation Interface
GetIndentString Overload
Alternet.Editor.TextSource Namespace


ITabulation.GetIndentString Method (Int32, Int32, Boolean)

ITabulationGetIndentString Method (Int32, Int32, Boolean)
When implemented by a class, returns indentation string which consist of tabs and spaces.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetIndentString(
    int count,
    int p,
    bool useSpaces
)
Function GetIndentString (
    count As Integer,
    p As Integer,
    useSpaces As Boolean
) As String
String^ GetIndentString(
    int count,
    int p,
    bool useSpaces
)
abstract GetIndentString :
        count : int *
        p : int *
        useSpaces : bool -> string

Parameters

count
Type: SystemInt32
Specifies number of characters in the string.
p
Type: SystemInt32
Specifies start position of the string.
useSpaces
Type: SystemBoolean
Specifies that spaces should be used instead of tab characters.

Return Value

Type: String
Indented string that containing tabs and spaces.
See Also

Reference

ITabulation Interface
GetIndentString Overload
Alternet.Editor.TextSource Namespace


ITabulation.GetPrevTabStop Method

ITabulationGetPrevTabStop Method
When implemented by a class, returns number of spaces to the previous TabStop.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPrevTabStop(
    int pos
)
Function GetPrevTabStop (
    pos As Integer
) As Integer
int GetPrevTabStop(
    int pos
)
abstract GetPrevTabStop :
        pos : int -> int

Parameters

pos
Type: SystemInt32
Position to check.

Return Value

Type: Int32
Number of spaces.
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.GetTabStop Method

ITabulationGetTabStop Method
When implemented by a class, returns number of spaces to the next TabStop at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetTabStop(
    int pos
)
Function GetTabStop (
    pos As Integer
) As Integer
int GetTabStop(
    int pos
)
abstract GetTabStop :
        pos : int -> int

Parameters

pos
Type: SystemInt32
Position to check.

Return Value

Type: Int32
Number of spaces.
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.GetTabString Method

ITabulationGetTabString Method
Overload List
 | Name | Description
Public method | GetTabString(String) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTabString(String, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property.
Top
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.GetTabString Method (String)

ITabulationGetTabString Method (String)
When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetTabString(
    string s
)
Function GetTabString (
    s As String
) As String
String^ GetTabString(
    String^ s
)
abstract GetTabString :
        s : string -> string

Parameters

s
Type: SystemString
Text to convert.

Return Value

Type: String
Tabbed string.
See Also

Reference

ITabulation Interface
GetTabString Overload
Alternet.Editor.TextSource Namespace


ITabulation.GetTabString Method (String, ITextUndoList)

ITabulationGetTabString Method (String, ITextUndoList)
When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetTabString(
    string s,
    ITextUndoList operations
)
Sub GetTabString (
    s As String,
    operations As ITextUndoList
)
void GetTabString(
    String^ s,
    ITextUndoList^ operations
)
abstract GetTabString :
        s : string *
        operations : ITextUndoList -> unit

Parameters

s
Type: SystemString
Text to convert.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments(spaces or tabs).
See Also

Reference

ITabulation Interface
GetTabString Overload
Alternet.Editor.TextSource Namespace


ITabulation.PosToTabPos Method

ITabulationPosToTabPos Method
Overload List
 | Name | Description
Public method | PosToTabPos(String, Int32) | When implemented by a class, returns specified position within given string as tabbed position.
Public method | PosToTabPos(String, Int32, Boolean) | When implemented by a class, returns specified position within given string as tabbed position.
Top
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.PosToTabPos Method (String, Int32)

ITabulationPosToTabPos Method (String, Int32)
When implemented by a class, returns specified position within given string as tabbed position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int PosToTabPos(
    string s,
    int pos
)
Function PosToTabPos (
    s As String,
    pos As Integer
) As Integer
int PosToTabPos(
    String^ s,
    int pos
)
abstract PosToTabPos :
        s : string *
        pos : int -> int

Parameters

s
Type: SystemString
Specifies string to check.
pos
Type: SystemInt32
Position of the character in the string.

Return Value

Type: Int32
Tabbed position.
See Also

Reference

ITabulation Interface
PosToTabPos Overload
Alternet.Editor.TextSource Namespace


ITabulation.PosToTabPos Method (String, Int32, Boolean)

ITabulationPosToTabPos Method (String, Int32, Boolean)
When implemented by a class, returns specified position within given string as tabbed position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int PosToTabPos(
    string s,
    int pos,
    bool tabEnd
)
Function PosToTabPos (
    s As String,
    pos As Integer,
    tabEnd As Boolean
) As Integer
int PosToTabPos(
    String^ s,
    int pos,
    bool tabEnd
)
abstract PosToTabPos :
        s : string *
        pos : int *
        tabEnd : bool -> int

Parameters

s
Type: SystemString
Specifies string to check.
pos
Type: SystemInt32
Position of the character in the string.
tabEnd
Type: SystemBoolean
Reserved for internal use.

Return Value

Type: Int32
Tabbed position.
See Also

Reference

ITabulation Interface
PosToTabPos Overload
Alternet.Editor.TextSource Namespace


ITabulation.ResetTabStops Method

ITabulationResetTabStops Method
When implemented by a class, resets the ITabulation.TabStops to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetTabStops()
Sub ResetTabStops
void ResetTabStops()
abstract ResetTabStops : unit -> unit
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.ResetUseSpaces Method

ITabulationResetUseSpaces Method
When implemented by a class, resets the ITabulation.UseSpaces to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUseSpaces()
Sub ResetUseSpaces
void ResetUseSpaces()
abstract ResetUseSpaces : unit -> unit
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.TabPosToPos Method

ITabulationTabPosToPos Method
When implemented by a class, returns specified position within given string as untabbed position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int TabPosToPos(
    string s,
    int pos
)
Function TabPosToPos (
    s As String,
    pos As Integer
) As Integer
int TabPosToPos(
    String^ s,
    int pos
)
abstract TabPosToPos :
        s : string *
        pos : int -> int

Parameters

s
Type: SystemString
Specifies string to convert.
pos
Type: SystemInt32
Specifies index of character which position should be converted.

Return Value

Type: Int32
Untabbed position.
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation Properties

ITabulation Properties

The ITabulation type exposes the following members.

Properties
 | Name | Description
Public property | TabStops | When implemented by a class, gets or sets the character columns that the cursor will move to each time you press Tab.
Public property | UseSpaces | When implemented by a class, gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters.
Top
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.TabStops Property

ITabulationTabStops Property
When implemented by a class, gets or sets the character columns that the cursor will move to each time you press Tab.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int[] TabStops { get; set; }
Property TabStops As Integer()
    Get
    Set
property array<int>^ TabStops {
    array<int>^ get ();
    void set (array<int>^ value);
}
abstract TabStops : int[] with get, set

Property Value

Type: Int32
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITabulation.UseSpaces Property

ITabulationUseSpaces Property
When implemented by a class, gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseSpaces { get; set; }
Property UseSpaces As Boolean
    Get
    Set
property bool UseSpaces {
    bool get ();
    void set (bool value);
}
abstract UseSpaces : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITabulation Interface
Alternet.Editor.TextSource Namespace


ITextErrors Interface

ITextErrors Interface
Represents properties and methods to handle syntax error collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextErrors
Public Interface ITextErrors
public interface class ITextErrors
type ITextErrors =  interface end

The ITextErrors type exposes the following members.

Methods
 | Name | Description
Public method | GetCodeFixes | When implemented by a class, gets code fixes for a given syntax error.
Public method | GetSyntaxErrorAt | When implemented by a class, gets syntax error at specified position.
Public method | HighlightCodeFixes | When implemented by a class, highlights code fixes if needed.
Public method | HighlightSyntaxErrors | When implemented by a class, highlights syntax errors.
Public method | InvalidateSyntaxErrors | When implemented by a class, invalidates highlighting of syntax errors.
Public method | UnhighlightSyntaxErrors | When implemented by a class, removes syntax errors highlighting.
Top
Properties
 | Name | Description
Public property | SyntaxErrors | When implemented by a class, represents a syntax errors collection.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextErrors Methods

ITextErrors Methods

The ITextErrors type exposes the following members.

Methods
 | Name | Description
Public method | GetCodeFixes | When implemented by a class, gets code fixes for a given syntax error.
Public method | GetSyntaxErrorAt | When implemented by a class, gets syntax error at specified position.
Public method | HighlightCodeFixes | When implemented by a class, highlights code fixes if needed.
Public method | HighlightSyntaxErrors | When implemented by a class, highlights syntax errors.
Public method | InvalidateSyntaxErrors | When implemented by a class, invalidates highlighting of syntax errors.
Public method | UnhighlightSyntaxErrors | When implemented by a class, removes syntax errors highlighting.
Top
See Also

Reference

ITextErrors Interface
Alternet.Editor.TextSource Namespace


ITextErrors.GetCodeFixes Method

ITextErrorsGetCodeFixes Method
When implemented by a class, gets code fixes for a given syntax error.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<ICodeFix> GetCodeFixes(
    ISyntaxError error,
    bool allDocuments
)
Function GetCodeFixes (
    error As ISyntaxError,
    allDocuments As Boolean
) As IList(Of ICodeFix)
IList<ICodeFix^>^ GetCodeFixes(
    ISyntaxError^ error,
    bool allDocuments
)
abstract GetCodeFixes :
        error : ISyntaxError *
        allDocuments : bool -> IList<ICodeFix>

Parameters

error
Type: Alternet.SyntaxISyntaxError
Specifies syntax error..
allDocuments
Type: SystemBoolean
Specifies if all documents in the solution need to be processed.

Return Value

Type: IListICodeFix
List of code fixes for a given error if succeed; otherwise null.
See Also

Reference

ITextErrors Interface
Alternet.Editor.TextSource Namespace


ITextErrors.GetSyntaxErrorAt Method

ITextErrorsGetSyntaxErrorAt Method
When implemented by a class, gets syntax error at specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxError GetSyntaxErrorAt(
    int x,
    int y
)
Function GetSyntaxErrorAt (
    x As Integer,
    y As Integer
) As ISyntaxError
ISyntaxError^ GetSyntaxErrorAt(
    int x,
    int y
)
abstract GetSyntaxErrorAt :
        x : int *
        y : int -> ISyntaxError

Parameters

x
Type: SystemInt32
X-coordinate of the position to evaluate.
y
Type: SystemInt32
Y-coordinate of the position to evaluate.

Return Value

Type: ISyntaxError
ISyntaxError object at specified position if succeed; otherwise null.
See Also

Reference

ITextErrors Interface
Alternet.Editor.TextSource Namespace


ITextErrors.HighlightCodeFixes Method

ITextErrorsHighlightCodeFixes Method
When implemented by a class, highlights code fixes if needed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HighlightCodeFixes()
Sub HighlightCodeFixes
void HighlightCodeFixes()
abstract HighlightCodeFixes : unit -> unit
See Also

Reference

ITextErrors Interface
Alternet.Editor.TextSource Namespace


ITextErrors.HighlightSyntaxErrors Method

ITextErrorsHighlightSyntaxErrors Method
When implemented by a class, highlights syntax errors.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HighlightSyntaxErrors()
Sub HighlightSyntaxErrors
void HighlightSyntaxErrors()
abstract HighlightSyntaxErrors : unit -> unit
See Also

Reference

ITextErrors Interface
Alternet.Editor.TextSource Namespace


ITextErrors.InvalidateSyntaxErrors Method

ITextErrorsInvalidateSyntaxErrors Method
When implemented by a class, invalidates highlighting of syntax errors.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void InvalidateSyntaxErrors()
Sub InvalidateSyntaxErrors
void InvalidateSyntaxErrors()
abstract InvalidateSyntaxErrors : unit -> unit
See Also

Reference

ITextErrors Interface
Alternet.Editor.TextSource Namespace


ITextErrors.UnhighlightSyntaxErrors Method

ITextErrorsUnhighlightSyntaxErrors Method
When implemented by a class, removes syntax errors highlighting.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnhighlightSyntaxErrors()
Sub UnhighlightSyntaxErrors
void UnhighlightSyntaxErrors()
abstract UnhighlightSyntaxErrors : unit -> unit
See Also

Reference

ITextErrors Interface
Alternet.Editor.TextSource Namespace


ITextErrors Properties

ITextErrors Properties

The ITextErrors type exposes the following members.

Properties
 | Name | Description
Public property | SyntaxErrors | When implemented by a class, represents a syntax errors collection.
Top
See Also

Reference

ITextErrors Interface
Alternet.Editor.TextSource Namespace


ITextErrors.SyntaxErrors Property

ITextErrorsSyntaxErrors Property
When implemented by a class, represents a syntax errors collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxErrors SyntaxErrors { get; }
ReadOnly Property SyntaxErrors As ISyntaxErrors
    Get
property ISyntaxErrors^ SyntaxErrors {
    ISyntaxErrors^ get ();
}
abstract SyntaxErrors : ISyntaxErrors with get

Property Value

Type: ISyntaxErrors
See Also

Reference

ITextErrors Interface
Alternet.Editor.TextSource Namespace


ITextExport Interface

ITextExport Interface
Represents properties methods to save text content using different formats.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextExport : IExport
Public Interface ITextExport
    Inherits IExport
public interface class ITextExport : IExport
type ITextExport =
    interface
        interface IExport
    end

The ITextExport type exposes the following members.

Methods
 | Name | Description
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter.
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding.
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter.
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter.
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter.
Top
Properties
 | Name | Description
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextExport Methods

ITextExport Methods
Methods
 | Name | Description
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter.
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding.
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter.
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter.
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter.
Top
See Also

Reference

ITextExport Interface
Alternet.Editor.TextSource Namespace


ITextExport.SaveFile Method

ITextExportSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter.
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding.
Top
See Also

Reference

ITextExport Interface
Alternet.Editor.TextSource Namespace


ITextExport.SaveFile Method (String, IStringExport)

ITextExportSaveFile Method (String, IStringExport)
When implemented by a class, saves content to the given file with specified exporter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveFile(
    string fileName,
    IStringExport exporter
)
Function SaveFile (
    fileName As String,
    exporter As IStringExport
) As Boolean
bool SaveFile(
    String^ fileName,
    IStringExport^ exporter
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextExport Interface
SaveFile Overload
Alternet.Editor.TextSource Namespace


ITextExport.SaveFile Method (String, IStringExport, Encoding)

ITextExportSaveFile Method (String, IStringExport, Encoding)
When implemented by a class, saves content to the given file with specified exported and specific encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveFile(
    string fileName,
    IStringExport exporter,
    Encoding encoding
)
Function SaveFile (
    fileName As String,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
bool SaveFile(
    String^ fileName,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextExport Interface
SaveFile Overload
Alternet.Editor.TextSource Namespace


ITextExport.SaveStream Method

ITextExportSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter.
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter.
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter.
Top
See Also

Reference

ITextExport Interface
Alternet.Editor.TextSource Namespace


ITextExport.SaveStream Method (Stream, IStringExport)

ITextExportSaveStream Method (Stream, IStringExport)
When implemented by a class, saves the text content to the given stream with specified exporter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveStream(
    Stream stream,
    IStringExport exporter
)
Function SaveStream (
    stream As Stream,
    exporter As IStringExport
) As Boolean
bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextExport Interface
SaveStream Overload
Alternet.Editor.TextSource Namespace


ITextExport.SaveStream Method (TextWriter, IStringExport)

ITextExportSaveStream Method (TextWriter, IStringExport)
When implemented by a class, saves the text content to the given stream with specified exporter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveStream(
    TextWriter writer,
    IStringExport exporter
)
Function SaveStream (
    writer As TextWriter,
    exporter As IStringExport
) As Boolean
bool SaveStream(
    TextWriter^ writer,
    IStringExport^ exporter
)
abstract SaveStream :
        writer : TextWriter *
        exporter : IStringExport -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextExport Interface
SaveStream Overload
Alternet.Editor.TextSource Namespace


ITextExport.SaveStream Method (Stream, IStringExport, Encoding)

ITextExportSaveStream Method (Stream, IStringExport, Encoding)
When implemented by a class, saves the text content to the given stream with specified exporter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveStream(
    Stream stream,
    IStringExport exporter,
    Encoding encoding
)
Function SaveStream (
    stream As Stream,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextExport Interface
SaveStream Overload
Alternet.Editor.TextSource Namespace


ITextExport Properties

ITextExport Properties

The ITextExport type exposes the following members.

Properties
 | Name | Description
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line.
Top
See Also

Reference

ITextExport Interface
Alternet.Editor.TextSource Namespace


ITextExport.LineTerminator Property

ITextExportLineTerminator Property
When implemented by a class, gets or sets a string value that terminates line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string LineTerminator { get; set; }
Property LineTerminator As String
    Get
    Set
property String^ LineTerminator {
    String^ get ();
    void set (String^ value);
}
abstract LineTerminator : string with get, set

Property Value

Type: String
See Also

Reference

ITextExport Interface
Alternet.Editor.TextSource Namespace


ITextImport Interface

ITextImport Interface
Represents methods to load text content in different formats.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextImport : IImport
Public Interface ITextImport
    Inherits IImport
public interface class ITextImport : IImport
type ITextImport =
    interface
        interface IImport
    end
Methods
 | Name | Description
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding.
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer.
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextImport Methods

ITextImport Methods
Methods
 | Name | Description
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding.
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer.
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer.
Top
See Also

Reference

ITextImport Interface
Alternet.Editor.TextSource Namespace


ITextImport.LoadFile Method

ITextImportLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding.
Top
See Also

Reference

ITextImport Interface
Alternet.Editor.TextSource Namespace


ITextImport.LoadFile Method (String, IStringImport)

ITextImportLoadFile Method (String, IStringImport)
When implemented by a class, loads content from the given file with specified importer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadFile(
    string fileName,
    IStringImport importer
)
Function LoadFile (
    fileName As String,
    importer As IStringImport
) As Boolean
bool LoadFile(
    String^ fileName,
    IStringImport^ importer
)
abstract LoadFile :
        fileName : string *
        importer : IStringImport -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextImport Interface
LoadFile Overload
Alternet.Editor.TextSource Namespace


ITextImport.LoadFile Method (String, IStringImport, Encoding)

ITextImportLoadFile Method (String, IStringImport, Encoding)
When implemented by a class, loads content from the given file with specified importer and specific encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadFile(
    string fileName,
    IStringImport importer,
    Encoding encoding
)
Function LoadFile (
    fileName As String,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
bool LoadFile(
    String^ fileName,
    IStringImport^ importer,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextImport Interface
LoadFile Overload
Alternet.Editor.TextSource Namespace


ITextImport.LoadStream Method

ITextImportLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer.
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer.
Top
See Also

Reference

ITextImport Interface
Alternet.Editor.TextSource Namespace


ITextImport.LoadStream Method (Stream, IStringImport)

ITextImportLoadStream Method (Stream, IStringImport)
When implemented by a class, loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadStream(
    Stream stream,
    IStringImport importer
)
Function LoadStream (
    stream As Stream,
    importer As IStringImport
) As Boolean
bool LoadStream(
    Stream^ stream,
    IStringImport^ importer
)
abstract LoadStream :
        stream : Stream *
        importer : IStringImport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextImport Interface
LoadStream Overload
Alternet.Editor.TextSource Namespace


ITextImport.LoadStream Method (TextReader, IStringImport)

ITextImportLoadStream Method (TextReader, IStringImport)
When implemented by a class, loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadStream(
    TextReader reader,
    IStringImport importer
)
Function LoadStream (
    reader As TextReader,
    importer As IStringImport
) As Boolean
bool LoadStream(
    TextReader^ reader,
    IStringImport^ importer
)
abstract LoadStream :
        reader : TextReader *
        importer : IStringImport -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to load the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextImport Interface
LoadStream Overload
Alternet.Editor.TextSource Namespace


ITextImport.LoadStream Method (Stream, IStringImport, Encoding)

ITextImportLoadStream Method (Stream, IStringImport, Encoding)
When implemented by a class, loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadStream(
    Stream stream,
    IStringImport importer,
    Encoding encoding
)
Function LoadStream (
    stream As Stream,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
bool LoadStream(
    Stream^ stream,
    IStringImport^ importer,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to load the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

ITextImport Interface
LoadStream Overload
Alternet.Editor.TextSource Namespace


ITextNotify Interface

ITextNotify Interface
Represents properties and methods to perform Text Source notification.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextNotify : INotify,
    IUpdate
Public Interface ITextNotify
    Inherits INotify, IUpdate
public interface class ITextNotify : INotify,
    IUpdate
type ITextNotify =
    interface
        interface INotify
        interface IUpdate
    end

The ITextNotify type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BeginUpdate(UpdateReason) | When implemented by a class, prevents object state updating until calling EndUpdate method.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | LinesChanged(Int32, Int32) | When implemented by a class, specifies range of lines that was changed.
Public method | LinesChanged(Int32, Int32, Boolean) | When implemented by a class, specifies range of lines that was changed.
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | FirstChanged | When implemented by a class, represents index of the first changed line.
Public property | LastChanged | When implemented by a class, represents index of the last changed line.
Public property | SelectBlockRect | When implemented by a class, represents a rectangular block of selected text.
Public property | State | When implemented by a class, gets or sets last changes to the text stored in the text source.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextNotify Methods

ITextNotify Methods

The ITextNotify type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BeginUpdate(UpdateReason) | When implemented by a class, prevents object state updating until calling EndUpdate method.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | LinesChanged(Int32, Int32) | When implemented by a class, specifies range of lines that was changed.
Public method | LinesChanged(Int32, Int32, Boolean) | When implemented by a class, specifies range of lines that was changed.
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

ITextNotify Interface
Alternet.Editor.TextSource Namespace


ITextNotify.BeginUpdate Method

ITextNotifyBeginUpdate Method
Overload List
 | Name | Description
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BeginUpdate(UpdateReason) | When implemented by a class, prevents object state updating until calling EndUpdate method.
Top
See Also

Reference

ITextNotify Interface
Alternet.Editor.TextSource Namespace


ITextNotify.BeginUpdate Method (UpdateReason)

ITextNotifyBeginUpdate Method (UpdateReason)
When implemented by a class, prevents object state updating until calling EndUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int BeginUpdate(
    UpdateReason reason
)
Function BeginUpdate (
    reason As UpdateReason
) As Integer
int BeginUpdate(
    UpdateReason reason
)
abstract BeginUpdate :
        reason : UpdateReason -> int

Parameters

reason
Type: Alternet.Editor.TextSourceUpdateReason
Reason of the source state updating.

Return Value

Type: Int32
Number of object state updating locks.
See Also

Reference

ITextNotify Interface
BeginUpdate Overload
Alternet.Editor.TextSource Namespace


ITextNotify.LinesChanged Method

ITextNotifyLinesChanged Method
Overload List
 | Name | Description
Public method | LinesChanged(Int32, Int32) | When implemented by a class, specifies range of lines that was changed.
Public method | LinesChanged(Int32, Int32, Boolean) | When implemented by a class, specifies range of lines that was changed.
Top
See Also

Reference

ITextNotify Interface
Alternet.Editor.TextSource Namespace


ITextNotify.LinesChanged Method (Int32, Int32)

ITextNotifyLinesChanged Method (Int32, Int32)
When implemented by a class, specifies range of lines that was changed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LinesChanged(
    int first,
    int last
)
Sub LinesChanged (
    first As Integer,
    last As Integer
)
void LinesChanged(
    int first,
    int last
)
abstract LinesChanged :
        first : int *
        last : int -> unit

Parameters

first
Type: SystemInt32
First changed line.
last
Type: SystemInt32
Last changed line.
See Also

Reference

ITextNotify Interface
LinesChanged Overload
Alternet.Editor.TextSource Namespace


ITextNotify.LinesChanged Method (Int32, Int32, Boolean)

ITextNotifyLinesChanged Method (Int32, Int32, Boolean)
When implemented by a class, specifies range of lines that was changed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LinesChanged(
    int first,
    int last,
    bool modified
)
Sub LinesChanged (
    first As Integer,
    last As Integer,
    modified As Boolean
)
void LinesChanged(
    int first,
    int last,
    bool modified
)
abstract LinesChanged :
        first : int *
        last : int *
        modified : bool -> unit

Parameters

first
Type: SystemInt32
First changed line.
last
Type: SystemInt32
Last changed line.
modified
Type: SystemBoolean
Indicates that content of specified lines is modified.
See Also

Reference

ITextNotify Interface
LinesChanged Overload
Alternet.Editor.TextSource Namespace


ITextNotify Properties

ITextNotify Properties

The ITextNotify type exposes the following members.

Properties
 | Name | Description
Public property | FirstChanged | When implemented by a class, represents index of the first changed line.
Public property | LastChanged | When implemented by a class, represents index of the last changed line.
Public property | SelectBlockRect | When implemented by a class, represents a rectangular block of selected text.
Public property | State | When implemented by a class, gets or sets last changes to the text stored in the text source.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

ITextNotify Interface
Alternet.Editor.TextSource Namespace


ITextNotify.FirstChanged Property

ITextNotifyFirstChanged Property
When implemented by a class, represents index of the first changed line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FirstChanged { get; }
ReadOnly Property FirstChanged As Integer
    Get
property int FirstChanged {
    int get ();
}
abstract FirstChanged : int with get

Property Value

Type: Int32
See Also

Reference

ITextNotify Interface
Alternet.Editor.TextSource Namespace


ITextNotify.LastChanged Property

ITextNotifyLastChanged Property
When implemented by a class, represents index of the last changed line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LastChanged { get; }
ReadOnly Property LastChanged As Integer
    Get
property int LastChanged {
    int get ();
}
abstract LastChanged : int with get

Property Value

Type: Int32
See Also

Reference

ITextNotify Interface
Alternet.Editor.TextSource Namespace


ITextNotify.SelectBlockRect Property

ITextNotifySelectBlockRect Property
When implemented by a class, represents a rectangular block of selected text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle SelectBlockRect { get; }
ReadOnly Property SelectBlockRect As Rectangle
    Get
property Rectangle SelectBlockRect {
    Rectangle get ();
}
abstract SelectBlockRect : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

ITextNotify Interface
Alternet.Editor.TextSource Namespace


ITextNotify.State Property

ITextNotifyState Property
When implemented by a class, gets or sets last changes to the text stored in the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
NotifyState State { get; set; }
Property State As NotifyState
    Get
    Set
property NotifyState State {
    NotifyState get ();
    void set (NotifyState value);
}
abstract State : NotifyState with get, set

Property Value

Type: NotifyState
See Also

Reference

ITextNotify Interface
Alternet.Editor.TextSource Namespace


ITextParsing Interface

ITextParsing Interface
Represents properties and methods to perform Text Source parsing.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextParsing
Public Interface ITextParsing
public interface class ITextParsing
type ITextParsing =  interface end

The ITextParsing type exposes the following members.

Methods
 | Name | Description
Public method | FormatText | When implemented by a class, formats and outlines TextSource text using attached Lexer.
Public method | FormatText(Boolean, Boolean) | When implemented by a class, formats and outlines TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing
Public method | GetStructureGuideLines | When implemented by a class, gets list of guide lines.
Public method | IsContentDivider | When implemented by a class, gets boolean value indicating whether text content is divided at given line.
Public method | NeedAutoComplete | When implemented by a class, indicates whether ITextSource should try to autocomplete statements.
Public method | NeedCacheIndent | When implemented by a class, indicates whether ITextSource can reuse previous indentation.
Public method | NeedCodeCompletion | When implemented by a class, indicates whether ITextSource can provide code completion operation for its content.
Public method | NeedCodeCompletionTabs | When implemented by a class, indicates code completion content can be filtered based on its priority.
Public method | NeedCodeFixes | When implemented by a class, indicates whether ITextSource can provide code fixes operations for its content.
Public method | NeedCodeRefactors | When implemented by a class, indicates whether ITextSource can provide code refactor operations for its content.
Public method | NeedFormatText | When implemented by a class, indicates whether ITextSource can format its content.
Public method | NeedFormatTextOnLineChange | When implemented by a class, indicates whether ITextSource should format spaces and case when changing the current line.
Public method | NeedIndentText | When implemented by a class, indicates whether ITextSource can indent its content.
Public method | NeedOutlineText | When implemented by a class, indicates whether ITextSource can outline its content.
Public method | NeedParse | When implemented by a class, indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted.
Public method | NeedQuickInfoTips | When implemented by a class, indicates whether ITextSource can obtain short description for syntax tokens within its content.
Public method | NeedReparseTextOnLineChange | When implemented by a class, indicates whether ITextSource should replace text when changing the current line.
Public method | NeedStructureGuideLines | When implemented by a class, indicates whether ITextSource can structure guidelines for its content.
Public method | ParseString | When implemented by a class, perform lexical analysis of the specified string.
Public method | ParseStrings | When implemented by a class, perform lexical analysis specified strings.
Public method | ParseToString | When implemented by a class, perform lexical analysis of specified strings.
Public method | ProcessAutoComplete | When implemented by a class, inserts end-of-block code fragment if needed.
Public method | SetLastParsed | When implemented by a class, updates the last parsed line and resets first changed line to it's default value.
Top
Properties
 | Name | Description
Public property | Lexer | When implemented by a class, gets or sets object that can perform lexical analysis of the text source content.
Public property | ParserLine | When implemented in a class, gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextParsing Methods

ITextParsing Methods

The ITextParsing type exposes the following members.

Methods
 | Name | Description
Public method | FormatText | When implemented by a class, formats and outlines TextSource text using attached Lexer.
Public method | FormatText(Boolean, Boolean) | When implemented by a class, formats and outlines TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing
Public method | GetStructureGuideLines | When implemented by a class, gets list of guide lines.
Public method | IsContentDivider | When implemented by a class, gets boolean value indicating whether text content is divided at given line.
Public method | NeedAutoComplete | When implemented by a class, indicates whether ITextSource should try to autocomplete statements.
Public method | NeedCacheIndent | When implemented by a class, indicates whether ITextSource can reuse previous indentation.
Public method | NeedCodeCompletion | When implemented by a class, indicates whether ITextSource can provide code completion operation for its content.
Public method | NeedCodeCompletionTabs | When implemented by a class, indicates code completion content can be filtered based on its priority.
Public method | NeedCodeFixes | When implemented by a class, indicates whether ITextSource can provide code fixes operations for its content.
Public method | NeedCodeRefactors | When implemented by a class, indicates whether ITextSource can provide code refactor operations for its content.
Public method | NeedFormatText | When implemented by a class, indicates whether ITextSource can format its content.
Public method | NeedFormatTextOnLineChange | When implemented by a class, indicates whether ITextSource should format spaces and case when changing the current line.
Public method | NeedIndentText | When implemented by a class, indicates whether ITextSource can indent its content.
Public method | NeedOutlineText | When implemented by a class, indicates whether ITextSource can outline its content.
Public method | NeedParse | When implemented by a class, indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted.
Public method | NeedQuickInfoTips | When implemented by a class, indicates whether ITextSource can obtain short description for syntax tokens within its content.
Public method | NeedReparseTextOnLineChange | When implemented by a class, indicates whether ITextSource should replace text when changing the current line.
Public method | NeedStructureGuideLines | When implemented by a class, indicates whether ITextSource can structure guidelines for its content.
Public method | ParseString | When implemented by a class, perform lexical analysis of the specified string.
Public method | ParseStrings | When implemented by a class, perform lexical analysis specified strings.
Public method | ParseToString | When implemented by a class, perform lexical analysis of specified strings.
Public method | ProcessAutoComplete | When implemented by a class, inserts end-of-block code fragment if needed.
Public method | SetLastParsed | When implemented by a class, updates the last parsed line and resets first changed line to it's default value.
Top
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.FormatText Method

ITextParsingFormatText Method
Overload List
 | Name | Description
Public method | FormatText | When implemented by a class, formats and outlines TextSource text using attached Lexer.
Public method | FormatText(Boolean, Boolean) | When implemented by a class, formats and outlines TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing
Top
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.FormatText Method

ITextParsingFormatText Method
When implemented by a class, formats and outlines TextSource text using attached Lexer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FormatText()
Sub FormatText
void FormatText()
abstract FormatText : unit -> unit
See Also

Reference

ITextParsing Interface
FormatText Overload
Alternet.Editor.TextSource Namespace


ITextParsing.FormatText Method (Boolean, Boolean)

ITextParsingFormatText Method (Boolean, Boolean)
When implemented by a class, formats and outlines TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FormatText(
    bool immediate,
    bool notify
)
Sub FormatText (
    immediate As Boolean,
    notify As Boolean
)
void FormatText(
    bool immediate,
    bool notify
)
abstract FormatText :
        immediate : bool *
        notify : bool -> unit

Parameters

immediate
Type: SystemBoolean
notify
Type: SystemBoolean
See Also

Reference

ITextParsing Interface
FormatText Overload
Alternet.Editor.TextSource Namespace


ITextParsing.GetStructureGuideLines Method

ITextParsingGetStructureGuideLines Method
When implemented by a class, gets list of guide lines.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetStructureGuideLines(
    int line,
    IList<IRange> guideLines
)
Function GetStructureGuideLines (
    line As Integer,
    guideLines As IList(Of IRange)
) As Integer
int GetStructureGuideLines(
    int line,
    IList<IRange^>^ guideLines
)
abstract GetStructureGuideLines :
        line : int *
        guideLines : IList<IRange> -> int

Parameters

line
Type: SystemInt32
Start of guide line.
guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.IsContentDivider Method

ITextParsingIsContentDivider Method
When implemented by a class, gets boolean value indicating whether text content is divided at given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsContentDivider(
    int index
)
Function IsContentDivider (
    index As Integer
) As Boolean
bool IsContentDivider(
    int index
)
abstract IsContentDivider :
        index : int -> bool

Parameters

index
Type: SystemInt32
Line to check.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedAutoComplete Method

ITextParsingNeedAutoComplete Method
When implemented by a class, indicates whether ITextSource should try to autocomplete statements.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedAutoComplete()
Function NeedAutoComplete As Boolean
bool NeedAutoComplete()
abstract NeedAutoComplete : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedCacheIndent Method

ITextParsingNeedCacheIndent Method
When implemented by a class, indicates whether ITextSource can reuse previous indentation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedCacheIndent()
Function NeedCacheIndent As Boolean
bool NeedCacheIndent()
abstract NeedCacheIndent : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedCodeCompletion Method

ITextParsingNeedCodeCompletion Method
When implemented by a class, indicates whether ITextSource can provide code completion operation for its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedCodeCompletion()
Function NeedCodeCompletion As Boolean
bool NeedCodeCompletion()
abstract NeedCodeCompletion : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedCodeCompletionTabs Method

ITextParsingNeedCodeCompletionTabs Method
When implemented by a class, indicates code completion content can be filtered based on its priority.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedCodeCompletionTabs(
    CodeCompletionType completionType
)
Function NeedCodeCompletionTabs (
    completionType As CodeCompletionType
) As Boolean
bool NeedCodeCompletionTabs(
    CodeCompletionType completionType
)
abstract NeedCodeCompletionTabs :
        completionType : CodeCompletionType -> bool

Parameters

completionType
Type: Alternet.SyntaxCodeCompletionType

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedCodeFixes Method

ITextParsingNeedCodeFixes Method
When implemented by a class, indicates whether ITextSource can provide code fixes operations for its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedCodeFixes()
Function NeedCodeFixes As Boolean
bool NeedCodeFixes()
abstract NeedCodeFixes : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedCodeRefactors Method

ITextParsingNeedCodeRefactors Method
When implemented by a class, indicates whether ITextSource can provide code refactor operations for its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedCodeRefactors()
Function NeedCodeRefactors As Boolean
bool NeedCodeRefactors()
abstract NeedCodeRefactors : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedFormatText Method

ITextParsingNeedFormatText Method
When implemented by a class, indicates whether ITextSource can format its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedFormatText()
Function NeedFormatText As Boolean
bool NeedFormatText()
abstract NeedFormatText : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedFormatTextOnLineChange Method

ITextParsingNeedFormatTextOnLineChange Method
When implemented by a class, indicates whether ITextSource should format spaces and case when changing the current line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedFormatTextOnLineChange()
Function NeedFormatTextOnLineChange As Boolean
bool NeedFormatTextOnLineChange()
abstract NeedFormatTextOnLineChange : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedIndentText Method

ITextParsingNeedIndentText Method
When implemented by a class, indicates whether ITextSource can indent its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedIndentText()
Function NeedIndentText As Boolean
bool NeedIndentText()
abstract NeedIndentText : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedOutlineText Method

ITextParsingNeedOutlineText Method
When implemented by a class, indicates whether ITextSource can outline its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedOutlineText()
Function NeedOutlineText As Boolean
bool NeedOutlineText()
abstract NeedOutlineText : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedParse Method

ITextParsingNeedParse Method
When implemented by a class, indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedParse()
Function NeedParse As Boolean
bool NeedParse()
abstract NeedParse : unit -> bool

Return Value

Type: Boolean
True if need to perform syntax parsing; otherwise false.
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedQuickInfoTips Method

ITextParsingNeedQuickInfoTips Method
When implemented by a class, indicates whether ITextSource can obtain short description for syntax tokens within its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedQuickInfoTips()
Function NeedQuickInfoTips As Boolean
bool NeedQuickInfoTips()
abstract NeedQuickInfoTips : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedReparseTextOnLineChange Method

ITextParsingNeedReparseTextOnLineChange Method
When implemented by a class, indicates whether ITextSource should replace text when changing the current line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedReparseTextOnLineChange()
Function NeedReparseTextOnLineChange As Boolean
bool NeedReparseTextOnLineChange()
abstract NeedReparseTextOnLineChange : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.NeedStructureGuideLines Method

ITextParsingNeedStructureGuideLines Method
When implemented by a class, indicates whether ITextSource can structure guidelines for its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedStructureGuideLines()
Function NeedStructureGuideLines As Boolean
bool NeedStructureGuideLines()
abstract NeedStructureGuideLines : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.ParseString Method

ITextParsingParseString Method
When implemented by a class, perform lexical analysis of the specified string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ParseString(
    int index
)
Sub ParseString (
    index As Integer
)
void ParseString(
    int index
)
abstract ParseString :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of line to parse.
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.ParseStrings Method

ITextParsingParseStrings Method
When implemented by a class, perform lexical analysis specified strings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ParseStrings(
    int first,
    int last
)
Sub ParseStrings (
    first As Integer,
    last As Integer
)
void ParseStrings(
    int first,
    int last
)
abstract ParseStrings :
        first : int *
        last : int -> unit

Parameters

first
Type: SystemInt32
Index of the first line to parse.
last
Type: SystemInt32
Index of the last line to parse.
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.ParseToString Method

ITextParsingParseToString Method
When implemented by a class, perform lexical analysis of specified strings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ParseToString(
    int index
)
Sub ParseToString (
    index As Integer
)
void ParseToString(
    int index
)
abstract ParseToString :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of the last string to parse.
Remarks
Method parses string collection from last parsed string to the string specified by Index parameter.
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.ProcessAutoComplete Method

ITextParsingProcessAutoComplete Method
When implemented by a class, inserts end-of-block code fragment if needed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessAutoComplete(
    out string code
)
Function ProcessAutoComplete (
    <OutAttribute> ByRef code As String
) As Boolean
bool ProcessAutoComplete(
    [OutAttribute] String^% code
)
abstract ProcessAutoComplete :
        code : string byref -> bool

Parameters

code
Type: SystemString
Code fragment to be inserted.

Return Value

Type: Boolean
True if end-of-block is inserted; otherwise false.
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.SetLastParsed Method

ITextParsingSetLastParsed Method
When implemented by a class, updates the last parsed line and resets first changed line to it's default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLastParsed(
    int index
)
Sub SetLastParsed (
    index As Integer
)
void SetLastParsed(
    int index
)
abstract SetLastParsed :
        index : int -> unit

Parameters

index
Type: SystemInt32
New value of the last parsed line.
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing Properties

ITextParsing Properties

The ITextParsing type exposes the following members.

Properties
 | Name | Description
Public property | Lexer | When implemented by a class, gets or sets object that can perform lexical analysis of the text source content.
Public property | ParserLine | When implemented in a class, gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text.
Top
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.Lexer Property

ITextParsingLexer Property
When implemented by a class, gets or sets object that can perform lexical analysis of the text source content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexer Lexer { get; set; }
Property Lexer As ILexer
    Get
    Set
property ILexer^ Lexer {
    ILexer^ get ();
    void set (ILexer^ value);
}
abstract Lexer : ILexer with get, set

Property Value

Type: ILexer
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextParsing.ParserLine Property

ITextParsingParserLine Property
When implemented in a class, gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ParserLine { get; }
ReadOnly Property ParserLine As Integer
    Get
property int ParserLine {
    int get ();
}
abstract ParserLine : int with get

Property Value

Type: Int32
See Also

Reference

ITextParsing Interface
Alternet.Editor.TextSource Namespace


ITextSearch Interface

ITextSearch Interface
Represents method used to search text within the string collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextSearch
Public Interface ITextSearch
public interface class ITextSearch
type ITextSearch =  interface end

The ITextSearch type exposes the following members.

Methods
 | Name | Description
Public method | Find | When implemented by a class, searches for given text within the control's text content.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextSearch Methods

ITextSearch Methods

The ITextSearch type exposes the following members.

Methods
 | Name | Description
Public method | Find | When implemented by a class, searches for given text within the control's text content.
Top
See Also

Reference

ITextSearch Interface
Alternet.Editor.TextSource Namespace


ITextSearch.Find Method

ITextSearchFind Method
When implemented by a class, searches for given text within the control's text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Find(
    string s,
    SearchOptions options,
    Regex expression,
    ref Point position,
    out int len,
    out Match match
)
Function Find (
    s As String,
    options As SearchOptions,
    expression As Regex,
    ByRef position As Point,
    <OutAttribute> ByRef len As Integer,
    <OutAttribute> ByRef match As Match
) As Boolean
bool Find(
    String^ s,
    SearchOptions options,
    Regex^ expression,
    Point% position,
    [OutAttribute] int% len,
    [OutAttribute] Match^% match
)
abstract Find :
        s : string *
        options : SearchOptions *
        expression : Regex *
        position : Point byref *
        len : int byref *
        match : Match byref -> bool

Parameters

s
Type: SystemString
The text to locate in the collection.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
position
Type: System.DrawingPoint
Position in strings collection to start search.
len
Type: SystemInt32
Receives length of the found text.
match
Type: System.Text.RegularExpressionsMatch
Receives match if regular expression search successful.

Return Value

Type: Boolean
True if search succeed; otherwise false.
Remarks
If search succeed Position parameter receive location of the found text.
See Also

Reference

ITextSearch Interface
Alternet.Editor.TextSource Namespace


ITextSnippets Interface

ITextSnippets Interface
Represents properties and methods to provide code snippet functionality.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextSnippets
Public Interface ITextSnippets
public interface class ITextSnippets
type ITextSnippets =  interface end

The ITextSnippets type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdateSnippet | When implemented by a class, prevents the Edit control from updating snippets until the EndUpdateSnippet method is called.
Public method | EndUpdateSnippet | When implemented by a class, resumes updating snippets after updating is suspended by the BeginUpdateSnippet method.
Public method | GetCodeSnippetRangeAt | When implemented by a class, locates code snippet at specified position.
Public method | HighlightCodeSnippets | When implemented by a class, highlights code snippets using appropriate style.
Public method | UnhighlightCodeSnippets | When implemented by a class, removes highlighting from code snippets and clears snippet collection.
Top
Properties
 | Name | Description
Public property | CodeSnippets | When implemented by a class, gets or sets ICodeSnippetRangeList for Edit control.
Public property | CurrentSnippet | When implemented by a class, gets or sets current ICodeSnippetRange object.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextSnippets Methods

ITextSnippets Methods

The ITextSnippets type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdateSnippet | When implemented by a class, prevents the Edit control from updating snippets until the EndUpdateSnippet method is called.
Public method | EndUpdateSnippet | When implemented by a class, resumes updating snippets after updating is suspended by the BeginUpdateSnippet method.
Public method | GetCodeSnippetRangeAt | When implemented by a class, locates code snippet at specified position.
Public method | HighlightCodeSnippets | When implemented by a class, highlights code snippets using appropriate style.
Public method | UnhighlightCodeSnippets | When implemented by a class, removes highlighting from code snippets and clears snippet collection.
Top
See Also

Reference

ITextSnippets Interface
Alternet.Editor.TextSource Namespace


ITextSnippets.BeginUpdateSnippet Method

ITextSnippetsBeginUpdateSnippet Method
When implemented by a class, prevents the Edit control from updating snippets until the EndUpdateSnippet method is called.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int BeginUpdateSnippet()
Function BeginUpdateSnippet As Integer
int BeginUpdateSnippet()
abstract BeginUpdateSnippet : unit -> int

Return Value

Type: Int32
Number of snippet updating locks.
See Also

Reference

ITextSnippets Interface
Alternet.Editor.TextSource Namespace


ITextSnippets.EndUpdateSnippet Method

ITextSnippetsEndUpdateSnippet Method
When implemented by a class, resumes updating snippets after updating is suspended by the BeginUpdateSnippet method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int EndUpdateSnippet()
Function EndUpdateSnippet As Integer
int EndUpdateSnippet()
abstract EndUpdateSnippet : unit -> int

Return Value

Type: Int32
Number of snippet updating locks.
See Also

Reference

ITextSnippets Interface
Alternet.Editor.TextSource Namespace


ITextSnippets.GetCodeSnippetRangeAt Method

ITextSnippetsGetCodeSnippetRangeAt Method
When implemented by a class, locates code snippet at specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetRange GetCodeSnippetRangeAt(
    Point position
)
Function GetCodeSnippetRangeAt (
    position As Point
) As ICodeSnippetRange
ICodeSnippetRange^ GetCodeSnippetRangeAt(
    Point position
)
abstract GetCodeSnippetRangeAt :
        position : Point -> ICodeSnippetRange

Parameters

position
Type: System.DrawingPoint
Position to evaluate.

Return Value

Type: ICodeSnippetRange
ICodeSnippetRange at specified position if succeed; otherwise null.
See Also

Reference

ITextSnippets Interface
Alternet.Editor.TextSource Namespace


ITextSnippets.HighlightCodeSnippets Method

ITextSnippetsHighlightCodeSnippets Method
When implemented by a class, highlights code snippets using appropriate style.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HighlightCodeSnippets()
Sub HighlightCodeSnippets
void HighlightCodeSnippets()
abstract HighlightCodeSnippets : unit -> unit
See Also

Reference

ITextSnippets Interface
Alternet.Editor.TextSource Namespace


ITextSnippets.UnhighlightCodeSnippets Method

ITextSnippetsUnhighlightCodeSnippets Method
When implemented by a class, removes highlighting from code snippets and clears snippet collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnhighlightCodeSnippets()
Sub UnhighlightCodeSnippets
void UnhighlightCodeSnippets()
abstract UnhighlightCodeSnippets : unit -> unit
See Also

Reference

ITextSnippets Interface
Alternet.Editor.TextSource Namespace


ITextSnippets Properties

ITextSnippets Properties

The ITextSnippets type exposes the following members.

Properties
 | Name | Description
Public property | CodeSnippets | When implemented by a class, gets or sets ICodeSnippetRangeList for Edit control.
Public property | CurrentSnippet | When implemented by a class, gets or sets current ICodeSnippetRange object.
Top
See Also

Reference

ITextSnippets Interface
Alternet.Editor.TextSource Namespace


ITextSnippets.CodeSnippets Property

ITextSnippetsCodeSnippets Property
When implemented by a class, gets or sets ICodeSnippetRangeList for Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetRanges CodeSnippets { get; set; }
Property CodeSnippets As ICodeSnippetRanges
    Get
    Set
property ICodeSnippetRanges^ CodeSnippets {
    ICodeSnippetRanges^ get ();
    void set (ICodeSnippetRanges^ value);
}
abstract CodeSnippets : ICodeSnippetRanges with get, set

Property Value

Type: ICodeSnippetRanges
See Also

Reference

ITextSnippets Interface
Alternet.Editor.TextSource Namespace


ITextSnippets.CurrentSnippet Property

ITextSnippetsCurrentSnippet Property
When implemented by a class, gets or sets current ICodeSnippetRange object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetRange CurrentSnippet { get; set; }
Property CurrentSnippet As ICodeSnippetRange
    Get
    Set
property ICodeSnippetRange^ CurrentSnippet {
    ICodeSnippetRange^ get ();
    void set (ICodeSnippetRange^ value);
}
abstract CurrentSnippet : ICodeSnippetRange with get, set

Property Value

Type: ICodeSnippetRange
See Also

Reference

ITextSnippets Interface
Alternet.Editor.TextSource Namespace


ITextSource Interface

ITextSource Interface
Represents properties and methods that provide interface between edited text and Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextSource : IEdit,
    INavigate, IUndo, ITextNotify, INotify, IUpdate,
    INotifier, ITextImport, IImport, ITextExport, IExport,
    IHyperText, ISpelling, IBraceMatching, ITextParsing, ITextSnippets,
    ITextErrors, ITextThread
Public Interface ITextSource
    Inherits IEdit, INavigate, IUndo, ITextNotify,
    INotify, IUpdate, INotifier, ITextImport, IImport,
    ITextExport, IExport, IHyperText, ISpelling, IBraceMatching,
    ITextParsing, ITextSnippets, ITextErrors, ITextThread
public interface class ITextSource : IEdit,
    INavigate, IUndo, ITextNotify, INotify, IUpdate,
    INotifier, ITextImport, IImport, ITextExport, IExport,
    IHyperText, ISpelling, IBraceMatching, ITextParsing, ITextSnippets,
    ITextErrors, ITextThread
type ITextSource =
    interface
        interface IEdit
        interface INavigate
        interface IUndo
        interface ITextNotify
        interface INotify
        interface IUpdate
        interface INotifier
        interface ITextImport
        interface IImport
        interface ITextExport
        interface IExport
        interface IHyperText
        interface ISpelling
        interface IBraceMatching
        interface ITextParsing
        interface ITextSnippets
        interface ITextErrors
        interface ITextThread
    end

The ITextSource type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | When implemented by a class, converts given absolute position to position as Point value.
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | AddUndo | When implemented by a class, stores undo operation in the appropriate list. (Inherited from IUndo.)
Public method | BeginUndoUpdate | When implemented by a class, allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method. (Inherited from IUndo.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BeginUpdate(UpdateReason) | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from ITextNotify.)
Public method | BeginUpdateSnippet | When implemented by a class, prevents the Edit control from updating snippets until the EndUpdateSnippet method is called. (Inherited from ITextSnippets.)
Public method | BreakLine | When implemented by a class, breaks current line into two lines. (Inherited from IEdit.)
Public method | CancelParsing | When implemented by a class, stops formatting timer.
Public method | CanRedo | When implemented by a class, indicating whether the redo operation can be performed. (Inherited from IUndo.)
Public method | CanUndo | When implemented by a class, indicating whether the undo operation can be performed. (Inherited from IUndo.)
Public method | Clear | When implemented by a class, clears content of the TextSource
Public method | ClearRedo | When implemented by a class, clears list of redo operations. (Inherited from IUndo.)
Public method | ClearUndo | When implemented by a class, clears list of undo operations. (Inherited from IUndo.)
Public method | CreateStringItem | Create a new IStrItem object containing specified text.
Public method | DeleteBlock | When implemented by a class, deletes a specified block of characters. (Inherited from IEdit.)
Public method | DeleteLeft | When implemented by a class, deletes a specified number of characters to the left of the active point. (Inherited from IEdit.)
Public method | DeleteRight | When implemented by a class, deletes a specified number of characters to the right of the active point. (Inherited from IEdit.)
Public method | DisablePositionUpdate | When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method. (Inherited from INavigate.)
Public method | DisableUndo | When implemented by a class, disables recording of undo/redo operations. (Inherited from IUndo.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnablePositionUpdate | When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method. (Inherited from INavigate.)
Public method | EnableUndo | When implemented by a class, re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method. (Inherited from IUndo.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUndoUpdate | When implemented by a class, ends undo block, that was started by BeginUndoUpdate method. (Inherited from IUndo.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | EndUpdateSnippet | When implemented by a class, resumes updating snippets after updating is suspended by the BeginUpdateSnippet method. (Inherited from ITextSnippets.)
Public method | FindClosingBrace(Point) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindClosingBrace(Int32, Int32) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Point) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Int32, Int32) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FormatText | When implemented by a class, formats and outlines TextSource text using attached Lexer. (Inherited from ITextParsing.)
Public method | FormatText(Boolean, Boolean) | When implemented by a class, formats and outlines TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing (Inherited from ITextParsing.)
Public method | GetCharIndexFromPosition | When implemented by a class, converts given Point value to the index of character.
Public method | GetCodeFixes | When implemented by a class, gets code fixes for a given syntax error. (Inherited from ITextErrors.)
Public method | GetCodeSnippetRangeAt | When implemented by a class, locates code snippet at specified position. (Inherited from ITextSnippets.)
Public method | GetIndentString | When implemented by a class, gets indentation string at current position. (Inherited from IEdit.)
Public method | GetPositionFromCharIndex | When implemented by a class, converts given character index to position as Point value.
Public method | GetStructureGuideLines | When implemented by a class, gets list of guide lines. (Inherited from ITextParsing.)
Public method | GetSyntaxErrorAt | When implemented by a class, gets syntax error at specified position. (Inherited from ITextErrors.)
Public method | HighlightBraces | When implemented by a class, highlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | HighlightCodeFixes | When implemented by a class, highlights code fixes if needed. (Inherited from ITextErrors.)
Public method | HighlightCodeSnippets | When implemented by a class, highlights code snippets using appropriate style. (Inherited from ITextSnippets.)
Public method | HighlightSyntaxErrors | When implemented by a class, highlights syntax errors. (Inherited from ITextErrors.)
Public method | IndentLine | When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned. (Inherited from IEdit.)
Public method | IndentLine(String, Boolean) | When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser (Inherited from IEdit.)
Public method | Insert | When implemented by a class, inserts the given string at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string array at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(ITextStrings, Boolean) | When implemented by a class, inserts the given string collection at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean, Boolean) | When implemented by a class, inserts the given string array at the specified location. (Inherited from IEdit.)
Public method | InsertFromFile | When implemented by a class, inserts the file text content at the specified location. (Inherited from IEdit.)
Public method | InvalidateSyntaxErrors | When implemented by a class, invalidates highlighting of syntax errors. (Inherited from ITextErrors.)
Public method | IsContentDivider | When implemented by a class, gets boolean value indicating whether text content is divided at given line. (Inherited from ITextParsing.)
Public method | IsHyperText | When implemented by a class, indicates whether given text represents hypertext. (Inherited from IHyperText.)
Public method | IsWordCorrect(String) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | IsWordCorrect(String, Point) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | LineIsHidden | When implemented by a class, determines whether the given line is hidden. (Inherited from IEdit.)
Public method | LineIsModified(Int32) | When implemented by a class, indicates whether specified line already modified. (Inherited from IUndo.)
Public method | LineIsModified(Int32, Boolean) | When implemented by a class, indicates whether specified line already modified. (Inherited from IUndo.)
Public method | LineIsReadonly | When implemented by a class, determines whether the given line is readonly. (Inherited from IEdit.)
Public method | LinesChanged(Int32, Int32) | When implemented by a class, specifies range of lines that was changed. (Inherited from ITextNotify.)
Public method | LinesChanged(Int32, Int32, Boolean) | When implemented by a class, specifies range of lines that was changed. (Inherited from ITextNotify.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer. (Inherited from ITextImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding. (Inherited from ITextImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | MoveTo(Point) | When implemented by a class, moves the current position to the given position. (Inherited from INavigate.)
Public method | MoveTo(Int32, Int32) | When implemented by a class, moves the current position to the given position. (Inherited from INavigate.)
Public method | MoveToChar | When implemented by a class, moves the current position to the specified character in the current line. (Inherited from INavigate.)
Public method | MoveToLine(Int32) | When implemented by a class, moves the current position to the specified line. (Inherited from INavigate.)
Public method | MoveToLine(Int32, Int32) | When implemented by a class, moves the current position to the specified line. (Inherited from INavigate.)
Public method | Navigate | When implemented by a class, moves current position by the given offset value. (Inherited from INavigate.)
Public method | NeedAutoComplete | When implemented by a class, indicates whether ITextSource should try to autocomplete statements. (Inherited from ITextParsing.)
Public method | NeedCacheIndent | When implemented by a class, indicates whether ITextSource can reuse previous indentation. (Inherited from ITextParsing.)
Public method | NeedCodeCompletion | When implemented by a class, indicates whether ITextSource can provide code completion operation for its content. (Inherited from ITextParsing.)
Public method | NeedCodeCompletionTabs | When implemented by a class, indicates code completion content can be filtered based on its priority. (Inherited from ITextParsing.)
Public method | NeedCodeFixes | When implemented by a class, indicates whether ITextSource can provide code fixes operations for its content. (Inherited from ITextParsing.)
Public method | NeedCodeRefactors | When implemented by a class, indicates whether ITextSource can provide code refactor operations for its content. (Inherited from ITextParsing.)
Public method | NeedFormatText | When implemented by a class, indicates whether ITextSource can format its content. (Inherited from ITextParsing.)
Public method | NeedFormatTextOnLineChange | When implemented by a class, indicates whether ITextSource should format spaces and case when changing the current line. (Inherited from ITextParsing.)
Public method | NeedIndentText | When implemented by a class, indicates whether ITextSource can indent its content. (Inherited from ITextParsing.)
Public method | NeedOutlineText | When implemented by a class, indicates whether ITextSource can outline its content. (Inherited from ITextParsing.)
Public method | NeedParse | When implemented by a class, indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted. (Inherited from ITextParsing.)
Public method | NeedQuickInfoTips | When implemented by a class, indicates whether ITextSource can obtain short description for syntax tokens within its content. (Inherited from ITextParsing.)
Public method | NeedReparseTextOnLineChange | When implemented by a class, indicates whether ITextSource should replace text when changing the current line. (Inherited from ITextParsing.)
Public method | NeedStructureGuideLines | When implemented by a class, indicates whether ITextSource can structure guidelines for its content. (Inherited from ITextParsing.)
Public method | NewLine | When implemented by a class, inserts a line break at the current position. (Inherited from IEdit.)
Public method | NewLine(String, Boolean) | When implemented by a class, inserts a line break at the current position with indentation. (Inherited from IEdit.)
Public method | NewLineAbove | When implemented by a class, inserts a line break above the current position. (Inherited from IEdit.)
Public method | NewLineBelow | When implemented by a class, inserts a line break below the current position. (Inherited from IEdit.)
Public method | Notification | When implemented by a class, updates control's content according to the parameters of notification. (Inherited from INotifier.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | ParseString | When implemented by a class, perform lexical analysis of the specified string. (Inherited from ITextParsing.)
Public method | ParseStrings | When implemented by a class, perform lexical analysis specified strings. (Inherited from ITextParsing.)
Public method | ParseToString | When implemented by a class, perform lexical analysis of specified strings. (Inherited from ITextParsing.)
Public method | PositionIsReadonly | When implemented by a class, determines whether the text at given position is readonly. (Inherited from IEdit.)
Public method | ProcessAutoComplete | When implemented by a class, inserts end-of-block code fragment if needed. (Inherited from ITextParsing.)
Public method | Redo | When implemented by a class, performs the last redo operation. (Inherited from IUndo.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | ResetBracesOptions | When implemented by a class, resets the BracesOptions to its default value. (Inherited from IBraceMatching.)
Public method | ResetCheckSpelling | When implemented by a class, resets the CheckSpelling to the default value. (Inherited from ISpelling.)
Public method | ResetClosingBraces | When implemented by a class, resets the ClosingBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetHighlightHyperText | When implemented by a class, resets HighlightUrls to the default value. (Inherited from IHyperText.)
Public method | ResetIndentOptions | When implemented by a class, resets the IndentOptions to the default value. (Inherited from IEdit.)
Public method | ResetMaxLength | When implemented by a class, resets the MaxLength to the default value. (Inherited from IEdit.)
Public method | ResetModified | When implemented by a class, resets the Modified to the default value. (Inherited from IEdit.)
Public method | ResetNavigateOptions | When implemented by a class, resets the NavigateOptions to the default value. (Inherited from INavigate.)
Public method | ResetOpenBraces | When implemented by a class, resets the OpenBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetOverWrite | When implemented by a class, resets the OverWrite to the default value. (Inherited from IEdit.)
Public method | ResetReadOnly | When implemented by a class, resets the Readonly to the default value. (Inherited from IEdit.)
Public method | ResetSingleLineMode | When implemented by a class, resets the SingleLineMode to the default value. (Inherited from IEdit.)
Public method | ResetSpellDelimiters | When implemented by a class, resets the SpellDelimiters to the default value. (Inherited from ISpelling.)
Public method | ResetUndoLimit | When implemented by a class, resets the UndoLimit to the default value. (Inherited from IUndo.)
Public method | ResetUndoOptions | When implemented by a class, resets the UndoOptions to the default value. (Inherited from IUndo.)
Public method | RestorePosition | When implemented by a class, restores position from stored position list by given index. (Inherited from INavigate.)
Public method | RestorePositionWithUndo | When implemented by a class, restores position from stored position list by given index. (Inherited from INavigate.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter. (Inherited from ITextExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding. (Inherited from ITextExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SetLastParsed | When implemented by a class, updates the last parsed line and resets first changed line to it's default value. (Inherited from ITextParsing.)
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line. (Inherited from IEdit.)
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line. (Inherited from IEdit.)
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line. (Inherited from IEdit.)
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line. (Inherited from IEdit.)
Public method | SetNavigateOptions | When implemented by a class, sets navigating options without validating position. (Inherited from INavigate.)
Public method | StartThread | When implemented in a class, executes action in thread. (Inherited from ITextThread.)
Public method | StopThread | When implemented in a class, aborts executing action in thread. (Inherited from ITextThread.)
Public method | StorePosition(Point) | When implemented by a class, stores given position to stored position list. (Inherited from INavigate.)
Public method | StorePosition(Point, Boolean) | When implemented by a class, stores given position to stored position list. (Inherited from INavigate.)
Public method | StorePositionWithUndo | When implemented by a class, stores given position to stored position list preserving it for undo. (Inherited from INavigate.)
Public method | TempHighlightBraces | When implemented by a class, temporary highlights all text within the area specified by rects. (Inherited from IBraceMatching.)
Public method | TempHighlightReferences | When implemented by a class, highlights found references.
Public method | TempHighlightSearchResults | When implemented by a class, highlights search results.
Public method | TempUnhighlightBraces | When implemented by a class, cancels text highlighting turned on using TempHighlightBraces (Inherited from IBraceMatching.)
Public method | TempUnhighlightReferences | When implemented by a class, unhighlights references highlighted with previous call of TempHighlightReferences.
Public method | TempUnhighlightSearchResults | When implemented by a class, unhighlights search results highlighted with previous call of TempHighlightSearchResults.
Public method | TextPointToAbsolutePosition | When implemented by a class, converts given Point value to the absolute position.
Public method | UnBreakLine | When implemented by a class, concatenates lines at current position. (Inherited from IEdit.)
Public method | Undo(Boolean) | When implemented by a class, performs the last undo operation. (Inherited from IUndo.)
Public method | Undo(IUndoData, Boolean) | When implemented by a class, performs the single undo operation. (Inherited from IUndo.)
Public method | UnhighlightBraces | When implemented by a class, unhighlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | UnhighlightCodeSnippets | When implemented by a class, removes highlighting from code snippets and clears snippet collection. (Inherited from ITextSnippets.)
Public method | UnhighlightSyntaxErrors | When implemented by a class, removes syntax errors highlighting. (Inherited from ITextErrors.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | ValidatePosition | When implemented by a class, validates given position within control's text content. (Inherited from INavigate.)
Top
Properties
 | Name | Description
Public property | ActiveEdit | When implemented by a class, gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source.
Public property | BookMarks | When implemented by a class, represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source.
Public property | BracesOptions | When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control. (Inherited from IBraceMatching.)
Public property | CheckSpelling | When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content. (Inherited from ISpelling.)
Public property | ClosingBraces | When implemented by a class, gets or sets an array of characters each one representing a closing brace. (Inherited from IBraceMatching.)
Public property | CodeSnippets | When implemented by a class, gets or sets ICodeSnippetRangeList for Edit control. (Inherited from ITextSnippets.)
Public property | CurrentSnippet | When implemented by a class, gets or sets current ICodeSnippetRange object. (Inherited from ITextSnippets.)
Public property | Edits | When implemented by a class, represents a collection of ISyntaxEdit controls linked to the text source.
Public property | FileName | When implemented by a class, gets or sets name of file that holds text source content.
Public property | FirstChanged | When implemented by a class, represents index of the first changed line. (Inherited from ITextNotify.)
Public property | GlobalSearch | When implemented by a class, specifies whether search should be global.
Public property | HasSpelling | When implemented by a class, gets boolean value indicating that editor has external spell checker assigned. (Inherited from ISpelling.)
Public property | HighlightHyperText | When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted. (Inherited from IHyperText.)
Public property | HighlightMatchingBlocks | When implemented by a class, specifies that edit control should highlight begin/end blocks.
Public property | HighlightReferences | When implemented by a class, specifies that edit control should highlight found references.
Public property | IndentOptions | When implemented by a class, gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from IEdit.)
Public property | LastChanged | When implemented by a class, represents index of the last changed line. (Inherited from ITextNotify.)
Public property | Lexer | When implemented by a class, gets or sets object that can perform lexical analysis of the text source content. (Inherited from ITextParsing.)
Public property | Lines | When implemented by a class, represents the object that implements ITextStrings interface containing collection of strings determining text source content.
Public property | LineStyles | When implemented by a class, represents an object that implements ILineStyles interface holding collection of line styles for this document.
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | MaxLength | When implemented by a class, specifies the maximum number of characters that can be entered into the edit control. (Inherited from IEdit.)
Public property | Modified | When implemented by a class, gets or sets a value indicating whether the control's text content is modified. (Inherited from IEdit.)
Public property | ModifiedLineRegions | When implemented by a class, gets modified lines information, grouped in regions. (Inherited from IUndo.)
Public property | ModifiedLines | When implemented by a class, gets modified lines information. (Inherited from IUndo.)
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options. (Inherited from INavigate.)
Public property | OpenBraces | When implemented by a class, gets or sets an array of characters each one representing an open brace. (Inherited from IBraceMatching.)
Public property | OptimizedForMemory | When implemented by a class, specifies whether internal text representation should optimized memory usage.
Public property | Overwrite | When implemented by a class, gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from IEdit.)
Public property | ParserLine | When implemented in a class, gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text. (Inherited from ITextParsing.)
Public property | Position | When implemented by a class, gets or sets current position within the control's text content. (Inherited from INavigate.)
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content. (Inherited from INavigate.)
Public property | ReadOnly | When implemented by a class, gets or sets a value indicating whether the control's content is read-only. (Inherited from IEdit.)
Public property | RedoList | When implemented by a class, provides an indexed access to redo data. (Inherited from IUndo.)
Public property | References | When implemented by a class, gets or sets IRangeList of found references for Edit control.
Public property | SearchResults | When implemented by a class, gets IRangeList of search results highlighted by TempHighlightSearchResults.
Public property | SelectBlockRect | When implemented by a class, represents a rectangular block of selected text. (Inherited from ITextNotify.)
Public property | SingleLineMode | When implemented by a class, gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from IEdit.)
Public property | SpellDelimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text when performing spelling check. (Inherited from ISpelling.)
Public property | SpellDelimiterString | When implemented by a class, gets or sets SpellDelimiters as a single string. (Inherited from ISpelling.)
Public property | SpellTable | When implemented by a class, represents a hash table containing delimiters. (Inherited from ISpelling.)
Public property | State | When implemented by a class, gets or sets last changes to the text stored in the text source. (Inherited from ITextNotify.)
Public property | SyntaxErrors | When implemented by a class, represents a syntax errors collection. (Inherited from ITextErrors.)
Public property | Text | When implemented by a class, gets or sets text source content as a single string with the individual strings delimited by carriage returns.
Public property | ThreadAction | When implemented by a class, returns method executed in thread when parsing.
Public property | UndoLimit | When implemented by a class, gets or sets a value that limits number of undo operations. (Inherited from IUndo.)
Public property | UndoList | When implemented by a class, provides an indexed access to undo data. (Inherited from IUndo.)
Public property | UndoOptions | When implemented by a class, gets or sets options for undo and redo operations. (Inherited from IUndo.)
Public property | UndoUpdateCount | When implemented by a class, keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested. (Inherited from IUndo.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UrlTable | When implemented by a class, represents hash table containing hyper-text characters. (Inherited from IHyperText.)
Top
Events
 | Name | Description
Public event | HyperText | When implemented by a class, occurs when a control needs checking whether some string represents hypertext. (Inherited from IHyperText.)
Public event | UndoEvent | When implemented by a class, occurs when undo/redo operation performed. (Inherited from IUndo.)
Public event | WordSpell | When implemented by a class, occurs when spelling of some word within the text needs checking. (Inherited from ISpelling.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextSource Methods

ITextSource Methods

The ITextSource type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | When implemented by a class, converts given absolute position to position as Point value.
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | AddUndo | When implemented by a class, stores undo operation in the appropriate list. (Inherited from IUndo.)
Public method | BeginUndoUpdate | When implemented by a class, allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method. (Inherited from IUndo.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BeginUpdate(UpdateReason) | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from ITextNotify.)
Public method | BeginUpdateSnippet | When implemented by a class, prevents the Edit control from updating snippets until the EndUpdateSnippet method is called. (Inherited from ITextSnippets.)
Public method | BreakLine | When implemented by a class, breaks current line into two lines. (Inherited from IEdit.)
Public method | CancelParsing | When implemented by a class, stops formatting timer.
Public method | CanRedo | When implemented by a class, indicating whether the redo operation can be performed. (Inherited from IUndo.)
Public method | CanUndo | When implemented by a class, indicating whether the undo operation can be performed. (Inherited from IUndo.)
Public method | Clear | When implemented by a class, clears content of the TextSource
Public method | ClearRedo | When implemented by a class, clears list of redo operations. (Inherited from IUndo.)
Public method | ClearUndo | When implemented by a class, clears list of undo operations. (Inherited from IUndo.)
Public method | CreateStringItem | Create a new IStrItem object containing specified text.
Public method | DeleteBlock | When implemented by a class, deletes a specified block of characters. (Inherited from IEdit.)
Public method | DeleteLeft | When implemented by a class, deletes a specified number of characters to the left of the active point. (Inherited from IEdit.)
Public method | DeleteRight | When implemented by a class, deletes a specified number of characters to the right of the active point. (Inherited from IEdit.)
Public method | DisablePositionUpdate | When implemented by a class, prevents notification of changing of caret position until calling EnablePositionUpdate method. (Inherited from INavigate.)
Public method | DisableUndo | When implemented by a class, disables recording of undo/redo operations. (Inherited from IUndo.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnablePositionUpdate | When implemented by a class, re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method. (Inherited from INavigate.)
Public method | EnableUndo | When implemented by a class, re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method. (Inherited from IUndo.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUndoUpdate | When implemented by a class, ends undo block, that was started by BeginUndoUpdate method. (Inherited from IUndo.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | EndUpdateSnippet | When implemented by a class, resumes updating snippets after updating is suspended by the BeginUpdateSnippet method. (Inherited from ITextSnippets.)
Public method | FindClosingBrace(Point) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindClosingBrace(Int32, Int32) | When implemented by a class, locates closing brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Point) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FindOpenBrace(Int32, Int32) | When implemented by a class, locates open brace. (Inherited from IBraceMatching.)
Public method | FormatText | When implemented by a class, formats and outlines TextSource text using attached Lexer. (Inherited from ITextParsing.)
Public method | FormatText(Boolean, Boolean) | When implemented by a class, formats and outlines TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing (Inherited from ITextParsing.)
Public method | GetCharIndexFromPosition | When implemented by a class, converts given Point value to the index of character.
Public method | GetCodeFixes | When implemented by a class, gets code fixes for a given syntax error. (Inherited from ITextErrors.)
Public method | GetCodeSnippetRangeAt | When implemented by a class, locates code snippet at specified position. (Inherited from ITextSnippets.)
Public method | GetIndentString | When implemented by a class, gets indentation string at current position. (Inherited from IEdit.)
Public method | GetPositionFromCharIndex | When implemented by a class, converts given character index to position as Point value.
Public method | GetStructureGuideLines | When implemented by a class, gets list of guide lines. (Inherited from ITextParsing.)
Public method | GetSyntaxErrorAt | When implemented by a class, gets syntax error at specified position. (Inherited from ITextErrors.)
Public method | HighlightBraces | When implemented by a class, highlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | HighlightCodeFixes | When implemented by a class, highlights code fixes if needed. (Inherited from ITextErrors.)
Public method | HighlightCodeSnippets | When implemented by a class, highlights code snippets using appropriate style. (Inherited from ITextSnippets.)
Public method | HighlightSyntaxErrors | When implemented by a class, highlights syntax errors. (Inherited from ITextErrors.)
Public method | IndentLine | When implemented by a class, inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned. (Inherited from IEdit.)
Public method | IndentLine(String, Boolean) | When implemented by a class, inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser (Inherited from IEdit.)
Public method | Insert | When implemented by a class, inserts the given string at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean) | When implemented by a class, inserts the given string array at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(ITextStrings, Boolean) | When implemented by a class, inserts the given string collection at the specified location. (Inherited from IEdit.)
Public method | InsertBlock(String, Boolean, Boolean) | When implemented by a class, inserts the given string array at the specified location. (Inherited from IEdit.)
Public method | InsertFromFile | When implemented by a class, inserts the file text content at the specified location. (Inherited from IEdit.)
Public method | InvalidateSyntaxErrors | When implemented by a class, invalidates highlighting of syntax errors. (Inherited from ITextErrors.)
Public method | IsContentDivider | When implemented by a class, gets boolean value indicating whether text content is divided at given line. (Inherited from ITextParsing.)
Public method | IsHyperText | When implemented by a class, indicates whether given text represents hypertext. (Inherited from IHyperText.)
Public method | IsWordCorrect(String) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | IsWordCorrect(String, Point) | When implemented by a class, checks whether spelling for the given word is correct. (Inherited from ISpelling.)
Public method | LineIsHidden | When implemented by a class, determines whether the given line is hidden. (Inherited from IEdit.)
Public method | LineIsModified(Int32) | When implemented by a class, indicates whether specified line already modified. (Inherited from IUndo.)
Public method | LineIsModified(Int32, Boolean) | When implemented by a class, indicates whether specified line already modified. (Inherited from IUndo.)
Public method | LineIsReadonly | When implemented by a class, determines whether the given line is readonly. (Inherited from IEdit.)
Public method | LinesChanged(Int32, Int32) | When implemented by a class, specifies range of lines that was changed. (Inherited from ITextNotify.)
Public method | LinesChanged(Int32, Int32, Boolean) | When implemented by a class, specifies range of lines that was changed. (Inherited from ITextNotify.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer. (Inherited from ITextImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding. (Inherited from ITextImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | MoveTo(Point) | When implemented by a class, moves the current position to the given position. (Inherited from INavigate.)
Public method | MoveTo(Int32, Int32) | When implemented by a class, moves the current position to the given position. (Inherited from INavigate.)
Public method | MoveToChar | When implemented by a class, moves the current position to the specified character in the current line. (Inherited from INavigate.)
Public method | MoveToLine(Int32) | When implemented by a class, moves the current position to the specified line. (Inherited from INavigate.)
Public method | MoveToLine(Int32, Int32) | When implemented by a class, moves the current position to the specified line. (Inherited from INavigate.)
Public method | Navigate | When implemented by a class, moves current position by the given offset value. (Inherited from INavigate.)
Public method | NeedAutoComplete | When implemented by a class, indicates whether ITextSource should try to autocomplete statements. (Inherited from ITextParsing.)
Public method | NeedCacheIndent | When implemented by a class, indicates whether ITextSource can reuse previous indentation. (Inherited from ITextParsing.)
Public method | NeedCodeCompletion | When implemented by a class, indicates whether ITextSource can provide code completion operation for its content. (Inherited from ITextParsing.)
Public method | NeedCodeCompletionTabs | When implemented by a class, indicates code completion content can be filtered based on its priority. (Inherited from ITextParsing.)
Public method | NeedCodeFixes | When implemented by a class, indicates whether ITextSource can provide code fixes operations for its content. (Inherited from ITextParsing.)
Public method | NeedCodeRefactors | When implemented by a class, indicates whether ITextSource can provide code refactor operations for its content. (Inherited from ITextParsing.)
Public method | NeedFormatText | When implemented by a class, indicates whether ITextSource can format its content. (Inherited from ITextParsing.)
Public method | NeedFormatTextOnLineChange | When implemented by a class, indicates whether ITextSource should format spaces and case when changing the current line. (Inherited from ITextParsing.)
Public method | NeedIndentText | When implemented by a class, indicates whether ITextSource can indent its content. (Inherited from ITextParsing.)
Public method | NeedOutlineText | When implemented by a class, indicates whether ITextSource can outline its content. (Inherited from ITextParsing.)
Public method | NeedParse | When implemented by a class, indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted. (Inherited from ITextParsing.)
Public method | NeedQuickInfoTips | When implemented by a class, indicates whether ITextSource can obtain short description for syntax tokens within its content. (Inherited from ITextParsing.)
Public method | NeedReparseTextOnLineChange | When implemented by a class, indicates whether ITextSource should replace text when changing the current line. (Inherited from ITextParsing.)
Public method | NeedStructureGuideLines | When implemented by a class, indicates whether ITextSource can structure guidelines for its content. (Inherited from ITextParsing.)
Public method | NewLine | When implemented by a class, inserts a line break at the current position. (Inherited from IEdit.)
Public method | NewLine(String, Boolean) | When implemented by a class, inserts a line break at the current position with indentation. (Inherited from IEdit.)
Public method | NewLineAbove | When implemented by a class, inserts a line break above the current position. (Inherited from IEdit.)
Public method | NewLineBelow | When implemented by a class, inserts a line break below the current position. (Inherited from IEdit.)
Public method | Notification | When implemented by a class, updates control's content according to the parameters of notification. (Inherited from INotifier.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | ParseString | When implemented by a class, perform lexical analysis of the specified string. (Inherited from ITextParsing.)
Public method | ParseStrings | When implemented by a class, perform lexical analysis specified strings. (Inherited from ITextParsing.)
Public method | ParseToString | When implemented by a class, perform lexical analysis of specified strings. (Inherited from ITextParsing.)
Public method | PositionIsReadonly | When implemented by a class, determines whether the text at given position is readonly. (Inherited from IEdit.)
Public method | ProcessAutoComplete | When implemented by a class, inserts end-of-block code fragment if needed. (Inherited from ITextParsing.)
Public method | Redo | When implemented by a class, performs the last redo operation. (Inherited from IUndo.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | ResetBracesOptions | When implemented by a class, resets the BracesOptions to its default value. (Inherited from IBraceMatching.)
Public method | ResetCheckSpelling | When implemented by a class, resets the CheckSpelling to the default value. (Inherited from ISpelling.)
Public method | ResetClosingBraces | When implemented by a class, resets the ClosingBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetHighlightHyperText | When implemented by a class, resets HighlightUrls to the default value. (Inherited from IHyperText.)
Public method | ResetIndentOptions | When implemented by a class, resets the IndentOptions to the default value. (Inherited from IEdit.)
Public method | ResetMaxLength | When implemented by a class, resets the MaxLength to the default value. (Inherited from IEdit.)
Public method | ResetModified | When implemented by a class, resets the Modified to the default value. (Inherited from IEdit.)
Public method | ResetNavigateOptions | When implemented by a class, resets the NavigateOptions to the default value. (Inherited from INavigate.)
Public method | ResetOpenBraces | When implemented by a class, resets the OpenBraces to its default value. (Inherited from IBraceMatching.)
Public method | ResetOverWrite | When implemented by a class, resets the OverWrite to the default value. (Inherited from IEdit.)
Public method | ResetReadOnly | When implemented by a class, resets the Readonly to the default value. (Inherited from IEdit.)
Public method | ResetSingleLineMode | When implemented by a class, resets the SingleLineMode to the default value. (Inherited from IEdit.)
Public method | ResetSpellDelimiters | When implemented by a class, resets the SpellDelimiters to the default value. (Inherited from ISpelling.)
Public method | ResetUndoLimit | When implemented by a class, resets the UndoLimit to the default value. (Inherited from IUndo.)
Public method | ResetUndoOptions | When implemented by a class, resets the UndoOptions to the default value. (Inherited from IUndo.)
Public method | RestorePosition | When implemented by a class, restores position from stored position list by given index. (Inherited from INavigate.)
Public method | RestorePositionWithUndo | When implemented by a class, restores position from stored position list by given index. (Inherited from INavigate.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter. (Inherited from ITextExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding. (Inherited from ITextExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SetLastParsed | When implemented by a class, updates the last parsed line and resets first changed line to it's default value. (Inherited from ITextParsing.)
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line. (Inherited from IEdit.)
Public method | SetLineHidden(Int32, Boolean) | When implemented by a class, sets hidden state for the given line. (Inherited from IEdit.)
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line. (Inherited from IEdit.)
Public method | SetLineReadonly(Int32, Boolean) | When implemented by a class, sets readonly state for the given line. (Inherited from IEdit.)
Public method | SetNavigateOptions | When implemented by a class, sets navigating options without validating position. (Inherited from INavigate.)
Public method | StartThread | When implemented in a class, executes action in thread. (Inherited from ITextThread.)
Public method | StopThread | When implemented in a class, aborts executing action in thread. (Inherited from ITextThread.)
Public method | StorePosition(Point) | When implemented by a class, stores given position to stored position list. (Inherited from INavigate.)
Public method | StorePosition(Point, Boolean) | When implemented by a class, stores given position to stored position list. (Inherited from INavigate.)
Public method | StorePositionWithUndo | When implemented by a class, stores given position to stored position list preserving it for undo. (Inherited from INavigate.)
Public method | TempHighlightBraces | When implemented by a class, temporary highlights all text within the area specified by rects. (Inherited from IBraceMatching.)
Public method | TempHighlightReferences | When implemented by a class, highlights found references.
Public method | TempHighlightSearchResults | When implemented by a class, highlights search results.
Public method | TempUnhighlightBraces | When implemented by a class, cancels text highlighting turned on using TempHighlightBraces (Inherited from IBraceMatching.)
Public method | TempUnhighlightReferences | When implemented by a class, unhighlights references highlighted with previous call of TempHighlightReferences.
Public method | TempUnhighlightSearchResults | When implemented by a class, unhighlights search results highlighted with previous call of TempHighlightSearchResults.
Public method | TextPointToAbsolutePosition | When implemented by a class, converts given Point value to the absolute position.
Public method | UnBreakLine | When implemented by a class, concatenates lines at current position. (Inherited from IEdit.)
Public method | Undo(Boolean) | When implemented by a class, performs the last undo operation. (Inherited from IUndo.)
Public method | Undo(IUndoData, Boolean) | When implemented by a class, performs the single undo operation. (Inherited from IUndo.)
Public method | UnhighlightBraces | When implemented by a class, unhighlights braces containing caret position. (Inherited from IBraceMatching.)
Public method | UnhighlightCodeSnippets | When implemented by a class, removes highlighting from code snippets and clears snippet collection. (Inherited from ITextSnippets.)
Public method | UnhighlightSyntaxErrors | When implemented by a class, removes syntax errors highlighting. (Inherited from ITextErrors.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Public method | ValidatePosition | When implemented by a class, validates given position within control's text content. (Inherited from INavigate.)
Top
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.AbsolutePositionToTextPoint Method

ITextSourceAbsolutePositionToTextPoint Method
When implemented by a class, converts given absolute position to position as Point value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point AbsolutePositionToTextPoint(
    int position
)
Function AbsolutePositionToTextPoint (
    position As Integer
) As Point
Point AbsolutePositionToTextPoint(
    int position
)
abstract AbsolutePositionToTextPoint :
        position : int -> Point

Parameters

position
Type: SystemInt32
Specifies index of character if the text considered as a single string.

Return Value

Type: Point
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.CancelParsing Method

ITextSourceCancelParsing Method
When implemented by a class, stops formatting timer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CancelParsing()
Sub CancelParsing
void CancelParsing()
abstract CancelParsing : unit -> unit
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.Clear Method

ITextSourceClear Method
When implemented by a class, clears content of the TextSource

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.CreateStringItem Method

ITextSourceCreateStringItem Method
Create a new IStrItem object containing specified text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IStringItem CreateStringItem(
    string s
)
Function CreateStringItem (
    s As String
) As IStringItem
IStringItem^ CreateStringItem(
    String^ s
)
abstract CreateStringItem :
        s : string -> IStringItem

Parameters

s
Type: SystemString
String that IStrItem contain.

Return Value

Type: IStringItem
Created IStrItem object.
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.GetCharIndexFromPosition Method

ITextSourceGetCharIndexFromPosition Method
When implemented by a class, converts given Point value to the index of character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetCharIndexFromPosition(
    Point position
)
Function GetCharIndexFromPosition (
    position As Point
) As Integer
int GetCharIndexFromPosition(
    Point position
)
abstract GetCharIndexFromPosition :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Return Value

Type: Int32
Index of character if the text considered as a single string.
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.GetPositionFromCharIndex Method

ITextSourceGetPositionFromCharIndex Method
When implemented by a class, converts given character index to position as Point value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point GetPositionFromCharIndex(
    int charIndex
)
Function GetPositionFromCharIndex (
    charIndex As Integer
) As Point
Point GetPositionFromCharIndex(
    int charIndex
)
abstract GetPositionFromCharIndex :
        charIndex : int -> Point

Parameters

charIndex
Type: SystemInt32
Specifies index of character if the text considered as a single string.

Return Value

Type: Point
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.TempHighlightReferences Method

ITextSourceTempHighlightReferences Method
When implemented by a class, highlights found references.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TempHighlightReferences()
Sub TempHighlightReferences
void TempHighlightReferences()
abstract TempHighlightReferences : unit -> unit
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.TempHighlightSearchResults Method

ITextSourceTempHighlightSearchResults Method
When implemented by a class, highlights search results.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TempHighlightSearchResults(
    IRangeList searchResults
)
Sub TempHighlightSearchResults (
    searchResults As IRangeList
)
void TempHighlightSearchResults(
    IRangeList^ searchResults
)
abstract TempHighlightSearchResults :
        searchResults : IRangeList -> unit

Parameters

searchResults
Type: Alternet.CommonIRangeList
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.TempUnhighlightReferences Method

ITextSourceTempUnhighlightReferences Method
When implemented by a class, unhighlights references highlighted with previous call of TempHighlightReferences.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TempUnhighlightReferences()
Sub TempUnhighlightReferences
void TempUnhighlightReferences()
abstract TempUnhighlightReferences : unit -> unit
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.TempUnhighlightSearchResults Method

ITextSourceTempUnhighlightSearchResults Method
When implemented by a class, unhighlights search results highlighted with previous call of TempHighlightSearchResults.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TempUnhighlightSearchResults()
Sub TempUnhighlightSearchResults
void TempUnhighlightSearchResults()
abstract TempUnhighlightSearchResults : unit -> unit
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.TextPointToAbsolutePosition Method

ITextSourceTextPointToAbsolutePosition Method
When implemented by a class, converts given Point value to the absolute position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int TextPointToAbsolutePosition(
    Point position
)
Function TextPointToAbsolutePosition (
    position As Point
) As Integer
int TextPointToAbsolutePosition(
    Point position
)
abstract TextPointToAbsolutePosition :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Return Value

Type: Int32
Absolute position of given point.
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource Properties

ITextSource Properties

The ITextSource type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEdit | When implemented by a class, gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source.
Public property | BookMarks | When implemented by a class, represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source.
Public property | BracesOptions | When implemented by a class, gets or sets options specifying appearance and behaviour of matching braces within Edit control. (Inherited from IBraceMatching.)
Public property | CheckSpelling | When implemented by a class, gets or sets a value indicating whether the document can check spelling for its content. (Inherited from ISpelling.)
Public property | ClosingBraces | When implemented by a class, gets or sets an array of characters each one representing a closing brace. (Inherited from IBraceMatching.)
Public property | CodeSnippets | When implemented by a class, gets or sets ICodeSnippetRangeList for Edit control. (Inherited from ITextSnippets.)
Public property | CurrentSnippet | When implemented by a class, gets or sets current ICodeSnippetRange object. (Inherited from ITextSnippets.)
Public property | Edits | When implemented by a class, represents a collection of ISyntaxEdit controls linked to the text source.
Public property | FileName | When implemented by a class, gets or sets name of file that holds text source content.
Public property | FirstChanged | When implemented by a class, represents index of the first changed line. (Inherited from ITextNotify.)
Public property | GlobalSearch | When implemented by a class, specifies whether search should be global.
Public property | HasSpelling | When implemented by a class, gets boolean value indicating that editor has external spell checker assigned. (Inherited from ISpelling.)
Public property | HighlightHyperText | When implemented by a class, gets or sets a value indicating whether hypertext urls in the text should be highlighted. (Inherited from IHyperText.)
Public property | HighlightMatchingBlocks | When implemented by a class, specifies that edit control should highlight begin/end blocks.
Public property | HighlightReferences | When implemented by a class, specifies that edit control should highlight found references.
Public property | IndentOptions | When implemented by a class, gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from IEdit.)
Public property | LastChanged | When implemented by a class, represents index of the last changed line. (Inherited from ITextNotify.)
Public property | Lexer | When implemented by a class, gets or sets object that can perform lexical analysis of the text source content. (Inherited from ITextParsing.)
Public property | Lines | When implemented by a class, represents the object that implements ITextStrings interface containing collection of strings determining text source content.
Public property | LineStyles | When implemented by a class, represents an object that implements ILineStyles interface holding collection of line styles for this document.
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | MaxLength | When implemented by a class, specifies the maximum number of characters that can be entered into the edit control. (Inherited from IEdit.)
Public property | Modified | When implemented by a class, gets or sets a value indicating whether the control's text content is modified. (Inherited from IEdit.)
Public property | ModifiedLineRegions | When implemented by a class, gets modified lines information, grouped in regions. (Inherited from IUndo.)
Public property | ModifiedLines | When implemented by a class, gets modified lines information. (Inherited from IUndo.)
Public property | NavigateOptions | When implemented by a class, gets or sets navigating options. (Inherited from INavigate.)
Public property | OpenBraces | When implemented by a class, gets or sets an array of characters each one representing an open brace. (Inherited from IBraceMatching.)
Public property | OptimizedForMemory | When implemented by a class, specifies whether internal text representation should optimized memory usage.
Public property | Overwrite | When implemented by a class, gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from IEdit.)
Public property | ParserLine | When implemented in a class, gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text. (Inherited from ITextParsing.)
Public property | Position | When implemented by a class, gets or sets current position within the control's text content. (Inherited from INavigate.)
Public property | PrevPosition | When implemented by a class, gets previous position within the control's text content. (Inherited from INavigate.)
Public property | ReadOnly | When implemented by a class, gets or sets a value indicating whether the control's content is read-only. (Inherited from IEdit.)
Public property | RedoList | When implemented by a class, provides an indexed access to redo data. (Inherited from IUndo.)
Public property | References | When implemented by a class, gets or sets IRangeList of found references for Edit control.
Public property | SearchResults | When implemented by a class, gets IRangeList of search results highlighted by TempHighlightSearchResults.
Public property | SelectBlockRect | When implemented by a class, represents a rectangular block of selected text. (Inherited from ITextNotify.)
Public property | SingleLineMode | When implemented by a class, gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from IEdit.)
Public property | SpellDelimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text when performing spelling check. (Inherited from ISpelling.)
Public property | SpellDelimiterString | When implemented by a class, gets or sets SpellDelimiters as a single string. (Inherited from ISpelling.)
Public property | SpellTable | When implemented by a class, represents a hash table containing delimiters. (Inherited from ISpelling.)
Public property | State | When implemented by a class, gets or sets last changes to the text stored in the text source. (Inherited from ITextNotify.)
Public property | SyntaxErrors | When implemented by a class, represents a syntax errors collection. (Inherited from ITextErrors.)
Public property | Text | When implemented by a class, gets or sets text source content as a single string with the individual strings delimited by carriage returns.
Public property | ThreadAction | When implemented by a class, returns method executed in thread when parsing.
Public property | UndoLimit | When implemented by a class, gets or sets a value that limits number of undo operations. (Inherited from IUndo.)
Public property | UndoList | When implemented by a class, provides an indexed access to undo data. (Inherited from IUndo.)
Public property | UndoOptions | When implemented by a class, gets or sets options for undo and redo operations. (Inherited from IUndo.)
Public property | UndoUpdateCount | When implemented by a class, keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested. (Inherited from IUndo.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UrlTable | When implemented by a class, represents hash table containing hyper-text characters. (Inherited from IHyperText.)
Top
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.ActiveEdit Property

ITextSourceActiveEdit Property
When implemented by a class, gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxEdit ActiveEdit { get; set; }
Property ActiveEdit As ISyntaxEdit
    Get
    Set
property ISyntaxEdit^ ActiveEdit {
    ISyntaxEdit^ get ();
    void set (ISyntaxEdit^ value);
}
abstract ActiveEdit : ISyntaxEdit with get, set

Property Value

Type: ISyntaxEdit
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.BookMarks Property

ITextSourceBookMarks Property
When implemented by a class, represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IBookMarks BookMarks { get; set; }
Property BookMarks As IBookMarks
    Get
    Set
property IBookMarks^ BookMarks {
    IBookMarks^ get ();
    void set (IBookMarks^ value);
}
abstract BookMarks : IBookMarks with get, set

Property Value

Type: IBookMarks
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.Edits Property

ITextSourceEdits Property
When implemented by a class, represents a collection of ISyntaxEdit controls linked to the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<ISyntaxEdit> Edits { get; }
ReadOnly Property Edits As IList(Of ISyntaxEdit)
    Get
property IList<ISyntaxEdit^>^ Edits {
    IList<ISyntaxEdit^>^ get ();
}
abstract Edits : IList<ISyntaxEdit> with get

Property Value

Type: IListISyntaxEdit
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.FileName Property

ITextSourceFileName Property
When implemented by a class, gets or sets name of file that holds text source content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.GlobalSearch Property

ITextSourceGlobalSearch Property
When implemented by a class, specifies whether search should be global.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GlobalSearch { get; set; }
Property GlobalSearch As Boolean
    Get
    Set
property bool GlobalSearch {
    bool get ();
    void set (bool value);
}
abstract GlobalSearch : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.HighlightMatchingBlocks Property

ITextSourceHighlightMatchingBlocks Property
When implemented by a class, specifies that edit control should highlight begin/end blocks.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HighlightMatchingBlocks { get; set; }
Property HighlightMatchingBlocks As Boolean
    Get
    Set
property bool HighlightMatchingBlocks {
    bool get ();
    void set (bool value);
}
abstract HighlightMatchingBlocks : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.HighlightReferences Property

ITextSourceHighlightReferences Property
When implemented by a class, specifies that edit control should highlight found references.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HighlightReferences { get; set; }
Property HighlightReferences As Boolean
    Get
    Set
property bool HighlightReferences {
    bool get ();
    void set (bool value);
}
abstract HighlightReferences : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.Lines Property

ITextSourceLines Property
When implemented by a class, represents the object that implements ITextStrings interface containing collection of strings determining text source content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ITextStrings Lines { get; set; }
Property Lines As ITextStrings
    Get
    Set
property ITextStrings^ Lines {
    ITextStrings^ get ();
    void set (ITextStrings^ value);
}
abstract Lines : ITextStrings with get, set

Property Value

Type: ITextStrings
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.LineStyles Property

ITextSourceLineStyles Property
When implemented by a class, represents an object that implements ILineStyles interface holding collection of line styles for this document.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILineStyles LineStyles { get; set; }
Property LineStyles As ILineStyles
    Get
    Set
property ILineStyles^ LineStyles {
    ILineStyles^ get ();
    void set (ILineStyles^ value);
}
abstract LineStyles : ILineStyles with get, set

Property Value

Type: ILineStyles
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.OptimizedForMemory Property

ITextSourceOptimizedForMemory Property
When implemented by a class, specifies whether internal text representation should optimized memory usage.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OptimizedForMemory { get; set; }
Property OptimizedForMemory As Boolean
    Get
    Set
property bool OptimizedForMemory {
    bool get ();
    void set (bool value);
}
abstract OptimizedForMemory : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.References Property

ITextSourceReferences Property
When implemented by a class, gets or sets IRangeList of found references for Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRangeList References { get; set; }
Property References As IRangeList
    Get
    Set
property IRangeList^ References {
    IRangeList^ get ();
    void set (IRangeList^ value);
}
abstract References : IRangeList with get, set

Property Value

Type: IRangeList
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.SearchResults Property

ITextSourceSearchResults Property
When implemented by a class, gets IRangeList of search results highlighted by TempHighlightSearchResults.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRangeList SearchResults { get; }
ReadOnly Property SearchResults As IRangeList
    Get
property IRangeList^ SearchResults {
    IRangeList^ get ();
}
abstract SearchResults : IRangeList with get

Property Value

Type: IRangeList
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.Text Property

ITextSourceText Property
When implemented by a class, gets or sets text source content as a single string with the individual strings delimited by carriage returns.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource.ThreadAction Property

ITextSourceThreadAction Property
When implemented by a class, returns method executed in thread when parsing.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ThreadProc ThreadAction { get; }
ReadOnly Property ThreadAction As ThreadProc
    Get
property ThreadProc^ ThreadAction {
    ThreadProc^ get ();
}
abstract ThreadAction : ThreadProc with get

Property Value

Type: ThreadProc
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextSource Events

ITextSource Events

The ITextSource type exposes the following members.

Events
 | Name | Description
Public event | HyperText | When implemented by a class, occurs when a control needs checking whether some string represents hypertext. (Inherited from IHyperText.)
Public event | UndoEvent | When implemented by a class, occurs when undo/redo operation performed. (Inherited from IUndo.)
Public event | WordSpell | When implemented by a class, occurs when spelling of some word within the text needs checking. (Inherited from ISpelling.)
Top
See Also

Reference

ITextSource Interface
Alternet.Editor.TextSource Namespace


ITextStrings Interface

ITextStrings Interface
Represents a collection of strings with extended possibilities.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextStrings : IStringListWithItem,
    IStringList, IList<string>, ICollection<string>,
    IEnumerable<string>, IEnumerable, IImport, IExport,
    ITextExport, ITextImport, ITextSearch, ITabulation, IWordBreak,
    INotify, IUpdate
Public Interface ITextStrings
    Inherits IStringListWithItem, IStringList, IList(Of String),
    ICollection(Of String), IEnumerable(Of String), IEnumerable,
    IImport, IExport, ITextExport, ITextImport, ITextSearch,
    ITabulation, IWordBreak, INotify, IUpdate
public interface class ITextStrings : IStringListWithItem,
    IStringList, IList<String^>, ICollection<String^>,
    IEnumerable<String^>, IEnumerable, IImport, IExport,
    ITextExport, ITextImport, ITextSearch, ITabulation, IWordBreak,
    INotify, IUpdate
type ITextStrings =
    interface
        interface IStringListWithItem
        interface IStringList
        interface IList<string>
        interface ICollection<string>
        interface IEnumerable<string>
        interface IEnumerable
        interface IImport
        interface IExport
        interface ITextExport
        interface ITextImport
        interface ITextSearch
        interface ITabulation
        interface IWordBreak
        interface INotify
        interface IUpdate
    end

The ITextStrings type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | When implemented by a class, converts given absolute position to position as Point value.
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionString.)
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | AfterSave | When implemented by a class, performs additional actions after ITextStrings saves its content to the file.
Public method | Assign | When implemented by a class, copies the contents from another ITextStrings object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | Changed(Int32) | When implemented by a class, notifies about string state changing.
Public method | Changed(Int32, Int32) | When implemented by a class, notifies about string state changing.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionString.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionString.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionString.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Find | When implemented by a class, searches for given text within the control's text content. (Inherited from ITextSearch.)
Public method | GetCharAt(Point) | When implemented by a class, returns character from specified position.
Public method | GetCharAt(Int32, Int32) | When implemented by a class, returns character from specified position.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableString.)
Public method | GetIndentString(Int32, Int32) | When implemented by a class, returns indentation string which consist of tabs and spaces. (Inherited from ITabulation.)
Public method | GetIndentString(Int32, Int32, Boolean) | When implemented by a class, returns indentation string which consist of tabs and spaces. (Inherited from ITabulation.)
Public method | GetItem | When implemented by a class, returns the IStrItem object at the given position of the collection. (Inherited from IStringListWithItem.)
Public method | GetLength | When implemented by a class, returns length of the string that corresponds to specified item in the collection.
Public method | GetLexStyle | When implemented by a class, returns lexical style at specified position.
Public method | GetPrevTabStop | When implemented by a class, returns number of spaces to the previous TabStop. (Inherited from ITabulation.)
Public method | GetTabStop | When implemented by a class, returns number of spaces to the next TabStop at the specified position. (Inherited from ITabulation.)
Public method | GetTabString(String) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTabString(String, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTabString(String, StringItemInfo, Boolean, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on TabStops property.
Public method | GetTextAt(Point) | When implemented by a class, returns word at the specific text position. (Inherited from IWordBreak.)
Public method | GetTextAt(Int32, Int32) | When implemented by a class, returns word at the specific text position. (Inherited from IWordBreak.)
Public method | GetWord(Int32, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32, Char) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListString.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListString.)
Public method | IsDelimiter(Char) | When implemented by a class, indicates whether the specified character is delimiter character. (Inherited from IWordBreak.)
Public method | IsDelimiter(Int32, Int32) | When implemented by a class, indicates whether the character at the specific position of the string collection is delimiter character. (Inherited from IWordBreak.)
Public method | IsDelimiter(String, Int32) | When implemented by a class, indicates whether the character at the specific position of given string is a delimiter character. (Inherited from IWordBreak.)
Public method | IsWhitespace | When implemented by a class, indicates whether the character at the specific position of given string is a whitespace character. (Inherited from IWordBreak.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer. (Inherited from ITextImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding. (Inherited from ITextImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | PosToTabPos(String, Int32) | When implemented by a class, returns specified position within given string as tabbed position. (Inherited from ITabulation.)
Public method | PosToTabPos(String, Int32, Boolean) | When implemented by a class, returns specified position within given string as tabbed position. (Inherited from ITabulation.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionString.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListString.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | ResetDelimiters | When implemented by a class, resets the Delimiters to the default value. (Inherited from IWordBreak.)
Public method | ResetTabStops | When implemented by a class, resets the ITabulation.TabStops to the default value. (Inherited from ITabulation.)
Public method | ResetUseSpaces | When implemented by a class, resets the ITabulation.UseSpaces to the default value. (Inherited from ITabulation.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter. (Inherited from ITextExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding. (Inherited from ITextExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SetTextAndData | When implemented by a class, sets the text and color data at the same time.
Public method | TabPosToPos | When implemented by a class, returns specified position within given string as untabbed position. (Inherited from ITabulation.)
Public method | TextPointToAbsolutePosition | When implemented by a class, converts given Point value to the absolute position.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionString.)
Public property | Delimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text. (Inherited from IWordBreak.)
Public property | DelimiterString | When implemented by a class, gets or sets Delimiters as a single string. (Inherited from IWordBreak.)
Public property | DelimTable | When implemented by a class, represents delimiters as a key-and-value pairs collection where each key is a single delimiter character.
Public property | FirstChanged | When implemented by a class, represents index of the first changed line.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionString.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListString.)
Public property | LastChanged | When implemented by a class, represents index of the last changed line.
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | Owner | When implemented by a class, gets or set the ISyntaxEdit control that owns this collection.
Public property | RemoveTrailingSpaces | When implemented by a class, gets or set a boolean value that indicates whether ITextStrings should remove trailing spaces from the end of each its strings.
Public property | Source | When implemented by a class, gets the text source owning the ITextStrings.
Public property | TabStops | When implemented by a class, gets or sets the character columns that the cursor will move to each time you press Tab. (Inherited from ITabulation.)
Public property | Text | When implemented by a class, gets or sets the strings in the IStringList as a single string with the individual strings delimited by carriage returns. (Inherited from IStringList.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UseSpaces | When implemented by a class, gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters. (Inherited from ITabulation.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextStrings Methods

ITextStrings Methods

The ITextStrings type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | When implemented by a class, converts given absolute position to position as Point value.
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionString.)
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | AfterSave | When implemented by a class, performs additional actions after ITextStrings saves its content to the file.
Public method | Assign | When implemented by a class, copies the contents from another ITextStrings object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | Changed(Int32) | When implemented by a class, notifies about string state changing.
Public method | Changed(Int32, Int32) | When implemented by a class, notifies about string state changing.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionString.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionString.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionString.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Find | When implemented by a class, searches for given text within the control's text content. (Inherited from ITextSearch.)
Public method | GetCharAt(Point) | When implemented by a class, returns character from specified position.
Public method | GetCharAt(Int32, Int32) | When implemented by a class, returns character from specified position.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableString.)
Public method | GetIndentString(Int32, Int32) | When implemented by a class, returns indentation string which consist of tabs and spaces. (Inherited from ITabulation.)
Public method | GetIndentString(Int32, Int32, Boolean) | When implemented by a class, returns indentation string which consist of tabs and spaces. (Inherited from ITabulation.)
Public method | GetItem | When implemented by a class, returns the IStrItem object at the given position of the collection. (Inherited from IStringListWithItem.)
Public method | GetLength | When implemented by a class, returns length of the string that corresponds to specified item in the collection.
Public method | GetLexStyle | When implemented by a class, returns lexical style at specified position.
Public method | GetPrevTabStop | When implemented by a class, returns number of spaces to the previous TabStop. (Inherited from ITabulation.)
Public method | GetTabStop | When implemented by a class, returns number of spaces to the next TabStop at the specified position. (Inherited from ITabulation.)
Public method | GetTabString(String) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTabString(String, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTabString(String, StringItemInfo, Boolean, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on TabStops property.
Public method | GetTextAt(Point) | When implemented by a class, returns word at the specific text position. (Inherited from IWordBreak.)
Public method | GetTextAt(Int32, Int32) | When implemented by a class, returns word at the specific text position. (Inherited from IWordBreak.)
Public method | GetWord(Int32, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32, Char) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | When implemented by a class, returns word start and end, if there is word at the specified position. (Inherited from IWordBreak.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListString.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListString.)
Public method | IsDelimiter(Char) | When implemented by a class, indicates whether the specified character is delimiter character. (Inherited from IWordBreak.)
Public method | IsDelimiter(Int32, Int32) | When implemented by a class, indicates whether the character at the specific position of the string collection is delimiter character. (Inherited from IWordBreak.)
Public method | IsDelimiter(String, Int32) | When implemented by a class, indicates whether the character at the specific position of given string is a delimiter character. (Inherited from IWordBreak.)
Public method | IsWhitespace | When implemented by a class, indicates whether the character at the specific position of given string is a whitespace character. (Inherited from IWordBreak.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport) | When implemented by a class, loads content from the given file with specified importer. (Inherited from ITextImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadFile(String, IStringImport, Encoding) | When implemented by a class, loads content from the given file with specified importer and specific encoding. (Inherited from ITextImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(TextReader, IStringImport) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, IStringImport, Encoding) | When implemented by a class, loads the text content from the given stream with specified importer. (Inherited from ITextImport.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | PosToTabPos(String, Int32) | When implemented by a class, returns specified position within given string as tabbed position. (Inherited from ITabulation.)
Public method | PosToTabPos(String, Int32, Boolean) | When implemented by a class, returns specified position within given string as tabbed position. (Inherited from ITabulation.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionString.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListString.)
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | ResetDelimiters | When implemented by a class, resets the Delimiters to the default value. (Inherited from IWordBreak.)
Public method | ResetTabStops | When implemented by a class, resets the ITabulation.TabStops to the default value. (Inherited from ITabulation.)
Public method | ResetUseSpaces | When implemented by a class, resets the ITabulation.UseSpaces to the default value. (Inherited from ITabulation.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport) | When implemented by a class, saves content to the given file with specified exporter. (Inherited from ITextExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveFile(String, IStringExport, Encoding) | When implemented by a class, saves content to the given file with specified exported and specific encoding. (Inherited from ITextExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(TextWriter, IStringExport) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, IStringExport, Encoding) | When implemented by a class, saves the text content to the given stream with specified exporter. (Inherited from ITextExport.)
Public method | SetTextAndData | When implemented by a class, sets the text and color data at the same time.
Public method | TabPosToPos | When implemented by a class, returns specified position within given string as untabbed position. (Inherited from ITabulation.)
Public method | TextPointToAbsolutePosition | When implemented by a class, converts given Point value to the absolute position.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.AbsolutePositionToTextPoint Method

ITextStringsAbsolutePositionToTextPoint Method
When implemented by a class, converts given absolute position to position as Point value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point AbsolutePositionToTextPoint(
    int position
)
Function AbsolutePositionToTextPoint (
    position As Integer
) As Point
Point AbsolutePositionToTextPoint(
    int position
)
abstract AbsolutePositionToTextPoint :
        position : int -> Point

Parameters

position
Type: SystemInt32
Specifies index of character if the text considered as a single string.

Return Value

Type: Point
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.AfterSave Method

ITextStringsAfterSave Method
When implemented by a class, performs additional actions after ITextStrings saves its content to the file.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AfterSave()
Sub AfterSave
void AfterSave()
abstract AfterSave : unit -> unit
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.Assign Method

ITextStringsAssign Method
When implemented by a class, copies the contents from another ITextStrings object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ITextStrings source
)
Sub Assign (
    source As ITextStrings
)
void Assign(
    ITextStrings^ source
)
abstract Assign :
        source : ITextStrings -> unit

Parameters

source
Type: Alternet.Editor.TextSourceITextStrings
Specifies ITextStrings to assign.
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.Changed Method

ITextStringsChanged Method
Overload List
 | Name | Description
Public method | Changed(Int32) | When implemented by a class, notifies about string state changing.
Public method | Changed(Int32, Int32) | When implemented by a class, notifies about string state changing.
Top
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.Changed Method (Int32)

ITextStringsChanged Method (Int32)
When implemented by a class, notifies about string state changing.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Changed(
    int index
)
Sub Changed (
    index As Integer
)
void Changed(
    int index
)
abstract Changed :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of string to update.
See Also

Reference

ITextStrings Interface
Changed Overload
Alternet.Editor.TextSource Namespace


ITextStrings.Changed Method (Int32, Int32)

ITextStringsChanged Method (Int32, Int32)
When implemented by a class, notifies about string state changing.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Changed(
    int first,
    int last
)
Sub Changed (
    first As Integer,
    last As Integer
)
void Changed(
    int first,
    int last
)
abstract Changed :
        first : int *
        last : int -> unit

Parameters

first
Type: SystemInt32
Index of the first string to update.
last
Type: SystemInt32
Index of the last string to update.
See Also

Reference

ITextStrings Interface
Changed Overload
Alternet.Editor.TextSource Namespace


ITextStrings.GetCharAt Method

ITextStringsGetCharAt Method
Overload List
 | Name | Description
Public method | GetCharAt(Point) | When implemented by a class, returns character from specified position.
Public method | GetCharAt(Int32, Int32) | When implemented by a class, returns character from specified position.
Top
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.GetCharAt Method (Point)

ITextStringsGetCharAt Method (Point)
When implemented by a class, returns character from specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char GetCharAt(
    Point position
)
Function GetCharAt (
    position As Point
) As Char
wchar_t GetCharAt(
    Point position
)
abstract GetCharAt :
        position : Point -> char

Parameters

position
Type: System.DrawingPoint
Position of character where Y is index of item in string collection and X is index of character in this string.

Return Value

Type: Char
Character from specified position.
See Also

Reference

ITextStrings Interface
GetCharAt Overload
Alternet.Editor.TextSource Namespace


ITextStrings.GetCharAt Method (Int32, Int32)

ITextStringsGetCharAt Method (Int32, Int32)
When implemented by a class, returns character from specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char GetCharAt(
    int x,
    int y
)
Function GetCharAt (
    x As Integer,
    y As Integer
) As Char
wchar_t GetCharAt(
    int x,
    int y
)
abstract GetCharAt :
        x : int *
        y : int -> char

Parameters

x
Type: SystemInt32
Specifies position of character in string.
y
Type: SystemInt32
Specifies index of item in string collection.

Return Value

Type: Char
Character from specified position.
See Also

Reference

ITextStrings Interface
GetCharAt Overload
Alternet.Editor.TextSource Namespace


ITextStrings.GetLength Method

ITextStringsGetLength Method
When implemented by a class, returns length of the string that corresponds to specified item in the collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetLength(
    int index
)
Function GetLength (
    index As Integer
) As Integer
int GetLength(
    int index
)
abstract GetLength :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of item in the collection.

Return Value

Type: Int32
If collection do not contain specified item method returns 0.
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.GetLexStyle Method

ITextStringsGetLexStyle Method
When implemented by a class, returns lexical style at specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
StringItemInfo GetLexStyle(
    Point position
)
Function GetLexStyle (
    position As Point
) As StringItemInfo
StringItemInfo GetLexStyle(
    Point position
)
abstract GetLexStyle :
        position : Point -> StringItemInfo

Parameters

position
Type: System.DrawingPoint
Position of style where Y is index of item in string collection and X is index of character in this string.

Return Value

Type: StringItemInfo
Lexical style at specified position.
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.GetTabString Method

ITextStringsGetTabString Method
Overload List
 | Name | Description
Public method | GetTabString(String) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTabString(String, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on ITabulation.TabStops property. (Inherited from ITabulation.)
Public method | GetTabString(String, StringItemInfo, Boolean, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on TabStops property.
Top
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.GetTabString Method (String, StringItemInfo[], Boolean, ITextUndoList)

ITextStringsGetTabString Method (String, StringItemInfo, Boolean, ITextUndoList)
When implemented by a class, converts all tab character to spaces depending on TabStops property.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetTabString(
    ref string str,
    ref StringItemInfo[] data,
    bool needData,
    ITextUndoList operations
)
Sub GetTabString (
    ByRef str As String,
    ByRef data As StringItemInfo(),
    needData As Boolean,
    operations As ITextUndoList
)
void GetTabString(
    String^% str,
    array<StringItemInfo>^% data,
    bool needData,
    ITextUndoList^ operations
)
abstract GetTabString :
        str : string byref *
        data : StringItemInfo[] byref *
        needData : bool *
        operations : ITextUndoList -> unit

Parameters

str
Type: SystemString
Text to convert.
data
Type: Alternet.SyntaxStringItemInfo
Color data of specified string.
needData
Type: SystemBoolean
Indicates whether method should return color data.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments(spaces or tabs).
See Also

Reference

ITextStrings Interface
GetTabString Overload
Alternet.Editor.TextSource Namespace


ITextStrings.SetTextAndData Method

ITextStringsSetTextAndData Method
When implemented by a class, sets the text and color data at the same time.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetTextAndData(
    string text,
    string data
)
Sub SetTextAndData (
    text As String,
    data As String
)
void SetTextAndData(
    String^ text,
    String^ data
)
abstract SetTextAndData :
        text : string *
        data : string -> unit

Parameters

text
Type: SystemString
Text of the strings.
data
Type: SystemString
Color data associated with the text.
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.TextPointToAbsolutePosition Method

ITextStringsTextPointToAbsolutePosition Method
When implemented by a class, converts given Point value to the absolute position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int TextPointToAbsolutePosition(
    Point position
)
Function TextPointToAbsolutePosition (
    position As Point
) As Integer
int TextPointToAbsolutePosition(
    Point position
)
abstract TextPointToAbsolutePosition :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Return Value

Type: Int32
Absolute position of given point.
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings Properties

ITextStrings Properties

The ITextStrings type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionString.)
Public property | Delimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text. (Inherited from IWordBreak.)
Public property | DelimiterString | When implemented by a class, gets or sets Delimiters as a single string. (Inherited from IWordBreak.)
Public property | DelimTable | When implemented by a class, represents delimiters as a key-and-value pairs collection where each key is a single delimiter character.
Public property | FirstChanged | When implemented by a class, represents index of the first changed line.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionString.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListString.)
Public property | LastChanged | When implemented by a class, represents index of the last changed line.
Public property | LineTerminator | When implemented by a class, gets or sets a string value that terminates line. (Inherited from ITextExport.)
Public property | Owner | When implemented by a class, gets or set the ISyntaxEdit control that owns this collection.
Public property | RemoveTrailingSpaces | When implemented by a class, gets or set a boolean value that indicates whether ITextStrings should remove trailing spaces from the end of each its strings.
Public property | Source | When implemented by a class, gets the text source owning the ITextStrings.
Public property | TabStops | When implemented by a class, gets or sets the character columns that the cursor will move to each time you press Tab. (Inherited from ITabulation.)
Public property | Text | When implemented by a class, gets or sets the strings in the IStringList as a single string with the individual strings delimited by carriage returns. (Inherited from IStringList.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UseSpaces | When implemented by a class, gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters. (Inherited from ITabulation.)
Top
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.DelimTable Property

ITextStringsDelimTable Property
When implemented by a class, represents delimiters as a key-and-value pairs collection where each key is a single delimiter character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Hashtable DelimTable { get; }
ReadOnly Property DelimTable As Hashtable
    Get
property Hashtable^ DelimTable {
    Hashtable^ get ();
}
abstract DelimTable : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.FirstChanged Property

ITextStringsFirstChanged Property
When implemented by a class, represents index of the first changed line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FirstChanged { get; }
ReadOnly Property FirstChanged As Integer
    Get
property int FirstChanged {
    int get ();
}
abstract FirstChanged : int with get

Property Value

Type: Int32
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.LastChanged Property

ITextStringsLastChanged Property
When implemented by a class, represents index of the last changed line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LastChanged { get; }
ReadOnly Property LastChanged As Integer
    Get
property int LastChanged {
    int get ();
}
abstract LastChanged : int with get

Property Value

Type: Int32
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.Owner Property

ITextStringsOwner Property
When implemented by a class, gets or set the ISyntaxEdit control that owns this collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxEdit Owner { get; set; }
Property Owner As ISyntaxEdit
    Get
    Set
property ISyntaxEdit^ Owner {
    ISyntaxEdit^ get ();
    void set (ISyntaxEdit^ value);
}
abstract Owner : ISyntaxEdit with get, set

Property Value

Type: ISyntaxEdit
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.RemoveTrailingSpaces Property

ITextStringsRemoveTrailingSpaces Property
When implemented by a class, gets or set a boolean value that indicates whether ITextStrings should remove trailing spaces from the end of each its strings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RemoveTrailingSpaces { get; set; }
Property RemoveTrailingSpaces As Boolean
    Get
    Set
property bool RemoveTrailingSpaces {
    bool get ();
    void set (bool value);
}
abstract RemoveTrailingSpaces : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextStrings.Source Property

ITextStringsSource Property
When implemented by a class, gets the text source owning the ITextStrings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ITextSource Source { get; }
ReadOnly Property Source As ITextSource
    Get
property ITextSource^ Source {
    ITextSource^ get ();
}
abstract Source : ITextSource with get

Property Value

Type: ITextSource
See Also

Reference

ITextStrings Interface
Alternet.Editor.TextSource Namespace


ITextThread Interface

ITextThread Interface
Represents properties and methods allowing to execute actions in thread.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextThread
Public Interface ITextThread
public interface class ITextThread
type ITextThread =  interface end

The ITextThread type exposes the following members.

Methods
 | Name | Description
Public method | StartThread | When implemented in a class, executes action in thread.
Public method | StopThread | When implemented in a class, aborts executing action in thread.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


ITextThread Methods

ITextThread Methods

The ITextThread type exposes the following members.

Methods
 | Name | Description
Public method | StartThread | When implemented in a class, executes action in thread.
Public method | StopThread | When implemented in a class, aborts executing action in thread.
Top
See Also

Reference

ITextThread Interface
Alternet.Editor.TextSource Namespace


ITextThread.StartThread Method

ITextThreadStartThread Method
When implemented in a class, executes action in thread.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartThread(
    ThreadProc action,
    ThreadProc start,
    ThreadProc end,
    ThreadProc stop
)
Sub StartThread (
    action As ThreadProc,
    start As ThreadProc,
    end As ThreadProc,
    stop As ThreadProc
)
void StartThread(
    ThreadProc^ action,
    ThreadProc^ start,
    ThreadProc^ end,
    ThreadProc^ stop
)
abstract StartThread :
        action : ThreadProc *
        start : ThreadProc *
        end : ThreadProc *
        stop : ThreadProc -> unit

Parameters

action
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to execute in thread.
start
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to execute in thread.
end
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to execute when thread starts.
stop
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to execute when user aborts thread execution.
See Also

Reference

ITextThread Interface
Alternet.Editor.TextSource Namespace


ITextThread.StopThread Method

ITextThreadStopThread Method
When implemented in a class, aborts executing action in thread.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StopThread(
    ThreadProc action,
    bool wait
)
Sub StopThread (
    action As ThreadProc,
    wait As Boolean
)
void StopThread(
    ThreadProc^ action,
    bool wait
)
abstract StopThread :
        action : ThreadProc *
        wait : bool -> unit

Parameters

action
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to abort.
wait
Type: SystemBoolean
Specifies whether calling application should wait for background thread to finish execution.
See Also

Reference

ITextThread Interface
Alternet.Editor.TextSource Namespace


IUndo Interface

IUndo Interface
Represents properties and methods to perform undo/redo operation with the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUndo
Public Interface IUndo
public interface class IUndo
type IUndo =  interface end

The IUndo type exposes the following members.

Methods
 | Name | Description
Public method | AddUndo | When implemented by a class, stores undo operation in the appropriate list.
Public method | BeginUndoUpdate | When implemented by a class, allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method.
Public method | CanRedo | When implemented by a class, indicating whether the redo operation can be performed.
Public method | CanUndo | When implemented by a class, indicating whether the undo operation can be performed.
Public method | ClearRedo | When implemented by a class, clears list of redo operations.
Public method | ClearUndo | When implemented by a class, clears list of undo operations.
Public method | DisableUndo | When implemented by a class, disables recording of undo/redo operations.
Public method | EnableUndo | When implemented by a class, re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method.
Public method | EndUndoUpdate | When implemented by a class, ends undo block, that was started by BeginUndoUpdate method.
Public method | LineIsModified(Int32) | When implemented by a class, indicates whether specified line already modified.
Public method | LineIsModified(Int32, Boolean) | When implemented by a class, indicates whether specified line already modified.
Public method | Redo | When implemented by a class, performs the last redo operation.
Public method | ResetUndoLimit | When implemented by a class, resets the UndoLimit to the default value.
Public method | ResetUndoOptions | When implemented by a class, resets the UndoOptions to the default value.
Public method | Undo(Boolean) | When implemented by a class, performs the last undo operation.
Public method | Undo(IUndoData, Boolean) | When implemented by a class, performs the single undo operation.
Top
Properties
 | Name | Description
Public property | ModifiedLineRegions | When implemented by a class, gets modified lines information, grouped in regions.
Public property | ModifiedLines | When implemented by a class, gets modified lines information.
Public property | RedoList | When implemented by a class, provides an indexed access to redo data.
Public property | UndoLimit | When implemented by a class, gets or sets a value that limits number of undo operations.
Public property | UndoList | When implemented by a class, provides an indexed access to undo data.
Public property | UndoOptions | When implemented by a class, gets or sets options for undo and redo operations.
Public property | UndoUpdateCount | When implemented by a class, keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested.
Top
Events
 | Name | Description
Public event | UndoEvent | When implemented by a class, occurs when undo/redo operation performed.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IUndo Methods

IUndo Methods

The IUndo type exposes the following members.

Methods
 | Name | Description
Public method | AddUndo | When implemented by a class, stores undo operation in the appropriate list.
Public method | BeginUndoUpdate | When implemented by a class, allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method.
Public method | CanRedo | When implemented by a class, indicating whether the redo operation can be performed.
Public method | CanUndo | When implemented by a class, indicating whether the undo operation can be performed.
Public method | ClearRedo | When implemented by a class, clears list of redo operations.
Public method | ClearUndo | When implemented by a class, clears list of undo operations.
Public method | DisableUndo | When implemented by a class, disables recording of undo/redo operations.
Public method | EnableUndo | When implemented by a class, re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method.
Public method | EndUndoUpdate | When implemented by a class, ends undo block, that was started by BeginUndoUpdate method.
Public method | LineIsModified(Int32) | When implemented by a class, indicates whether specified line already modified.
Public method | LineIsModified(Int32, Boolean) | When implemented by a class, indicates whether specified line already modified.
Public method | Redo | When implemented by a class, performs the last redo operation.
Public method | ResetUndoLimit | When implemented by a class, resets the UndoLimit to the default value.
Public method | ResetUndoOptions | When implemented by a class, resets the UndoOptions to the default value.
Public method | Undo(Boolean) | When implemented by a class, performs the last undo operation.
Public method | Undo(IUndoData, Boolean) | When implemented by a class, performs the single undo operation.
Top
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.AddUndo Method

IUndoAddUndo Method
When implemented by a class, stores undo operation in the appropriate list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddUndo(
    UndoOperation operation,
    Object data
)
Sub AddUndo (
    operation As UndoOperation,
    data As Object
)
void AddUndo(
    UndoOperation operation,
    Object^ data
)
abstract AddUndo :
        operation : UndoOperation *
        data : Object -> unit

Parameters

operation
Type: Alternet.Editor.TextSourceUndoOperation
Operation to store.
data
Type: SystemObject
Data to store.
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.BeginUndoUpdate Method

IUndoBeginUndoUpdate Method
When implemented by a class, allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int BeginUndoUpdate()
Function BeginUndoUpdate As Integer
int BeginUndoUpdate()
abstract BeginUndoUpdate : unit -> int

Return Value

Type: Int32
Number of undo updating locks.
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.CanRedo Method

IUndoCanRedo Method
When implemented by a class, indicating whether the redo operation can be performed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanRedo()
Function CanRedo As Boolean
bool CanRedo()
abstract CanRedo : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.CanUndo Method

IUndoCanUndo Method
When implemented by a class, indicating whether the undo operation can be performed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanUndo()
Function CanUndo As Boolean
bool CanUndo()
abstract CanUndo : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.ClearRedo Method

IUndoClearRedo Method
When implemented by a class, clears list of redo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearRedo()
Sub ClearRedo
void ClearRedo()
abstract ClearRedo : unit -> unit
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.ClearUndo Method

IUndoClearUndo Method
When implemented by a class, clears list of undo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearUndo()
Sub ClearUndo
void ClearUndo()
abstract ClearUndo : unit -> unit
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.DisableUndo Method

IUndoDisableUndo Method
When implemented by a class, disables recording of undo/redo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int DisableUndo()
Function DisableUndo As Integer
int DisableUndo()
abstract DisableUndo : unit -> int

Return Value

Type: Int32
Number of undo/redo operations locks.
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace
IUndoEnableUndo


IUndo.EnableUndo Method

IUndoEnableUndo Method
When implemented by a class, re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int EnableUndo()
Function EnableUndo As Integer
int EnableUndo()
abstract EnableUndo : unit -> int

Return Value

Type: Int32
Number of undo/redo operations locks.
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace
IUndoDisableUndo


IUndo.EndUndoUpdate Method

IUndoEndUndoUpdate Method
When implemented by a class, ends undo block, that was started by BeginUndoUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int EndUndoUpdate()
Function EndUndoUpdate As Integer
int EndUndoUpdate()
abstract EndUndoUpdate : unit -> int

Return Value

Type: Int32
Number of undo updating locks.
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.LineIsModified Method

IUndoLineIsModified Method
Overload List
 | Name | Description
Public method | LineIsModified(Int32) | When implemented by a class, indicates whether specified line already modified.
Public method | LineIsModified(Int32, Boolean) | When implemented by a class, indicates whether specified line already modified.
Top
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.LineIsModified Method (Int32)

IUndoLineIsModified Method (Int32)
When implemented by a class, indicates whether specified line already modified.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LineIsModified(
    int index
)
Function LineIsModified (
    index As Integer
) As Boolean
bool LineIsModified(
    int index
)
abstract LineIsModified :
        index : int -> bool

Parameters

index
Type: SystemInt32
Index of line to check.

Return Value

Type: Boolean
True is line modified; otherwise false.
See Also

Reference

IUndo Interface
LineIsModified Overload
Alternet.Editor.TextSource Namespace


IUndo.LineIsModified Method (Int32, Boolean)

IUndoLineIsModified Method (Int32, Boolean)
When implemented by a class, indicates whether specified line already modified.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LineIsModified(
    int index,
    out bool saved
)
Function LineIsModified (
    index As Integer,
    <OutAttribute> ByRef saved As Boolean
) As Boolean
bool LineIsModified(
    int index,
    [OutAttribute] bool% saved
)
abstract LineIsModified :
        index : int *
        saved : bool byref -> bool

Parameters

index
Type: SystemInt32
Index of line to check.
saved
Type: SystemBoolean
Receives boolean value that indicates whether line was not changed since last saving.

Return Value

Type: Boolean
True is line modified; otherwise false.
See Also

Reference

IUndo Interface
LineIsModified Overload
Alternet.Editor.TextSource Namespace


IUndo.Redo Method

IUndoRedo Method
When implemented by a class, performs the last redo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Redo()
Sub Redo
void Redo()
abstract Redo : unit -> unit
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.ResetUndoLimit Method

IUndoResetUndoLimit Method
When implemented by a class, resets the UndoLimit to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUndoLimit()
Sub ResetUndoLimit
void ResetUndoLimit()
abstract ResetUndoLimit : unit -> unit
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.ResetUndoOptions Method

IUndoResetUndoOptions Method
When implemented by a class, resets the UndoOptions to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetUndoOptions()
Sub ResetUndoOptions
void ResetUndoOptions()
abstract ResetUndoOptions : unit -> unit
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.Undo Method

IUndoUndo Method
Overload List
 | Name | Description
Public method | Undo(Boolean) | When implemented by a class, performs the last undo operation.
Public method | Undo(IUndoData, Boolean) | When implemented by a class, performs the single undo operation.
Top
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.Undo Method (Boolean)

IUndoUndo Method (Boolean)
When implemented by a class, performs the last undo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Undo(
    bool withChange = false
)
Sub Undo (
    Optional withChange As Boolean = false
)
void Undo(
    bool withChange = false
)
abstract Undo :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit

Parameters

withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.
See Also

Reference

IUndo Interface
Undo Overload
Alternet.Editor.TextSource Namespace


IUndo.Undo Method (IUndoData, Boolean)

IUndoUndo Method (IUndoData, Boolean)
When implemented by a class, performs the single undo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Undo(
    IUndoData undoData,
    bool withChange = false
)
Sub Undo (
    undoData As IUndoData,
    Optional withChange As Boolean = false
)
void Undo(
    IUndoData^ undoData,
    bool withChange = false
)
abstract Undo :
        undoData : IUndoData *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit

Parameters

undoData
Type: Alternet.Editor.TextSourceIUndoData
Data related to the undo operation.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.
See Also

Reference

IUndo Interface
Undo Overload
Alternet.Editor.TextSource Namespace


IUndo Properties

IUndo Properties

The IUndo type exposes the following members.

Properties
 | Name | Description
Public property | ModifiedLineRegions | When implemented by a class, gets modified lines information, grouped in regions.
Public property | ModifiedLines | When implemented by a class, gets modified lines information.
Public property | RedoList | When implemented by a class, provides an indexed access to redo data.
Public property | UndoLimit | When implemented by a class, gets or sets a value that limits number of undo operations.
Public property | UndoList | When implemented by a class, provides an indexed access to undo data.
Public property | UndoOptions | When implemented by a class, gets or sets options for undo and redo operations.
Public property | UndoUpdateCount | When implemented by a class, keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested.
Top
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.ModifiedLineRegions Property

IUndoModifiedLineRegions Property
When implemented by a class, gets modified lines information, grouped in regions.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ModifiedLineRegion> ModifiedLineRegions { get; }
ReadOnly Property ModifiedLineRegions As IEnumerable(Of ModifiedLineRegion)
    Get
property IEnumerable<ModifiedLineRegion^>^ ModifiedLineRegions {
    IEnumerable<ModifiedLineRegion^>^ get ();
}
abstract ModifiedLineRegions : IEnumerable<ModifiedLineRegion> with get

Property Value

Type: IEnumerableModifiedLineRegion
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.ModifiedLines Property

IUndoModifiedLines Property
When implemented by a class, gets modified lines information.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ModifiedLine> ModifiedLines { get; }
ReadOnly Property ModifiedLines As IEnumerable(Of ModifiedLine)
    Get
property IEnumerable<ModifiedLine^>^ ModifiedLines {
    IEnumerable<ModifiedLine^>^ get ();
}
abstract ModifiedLines : IEnumerable<ModifiedLine> with get

Property Value

Type: IEnumerableModifiedLine
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.RedoList Property

IUndoRedoList Property
When implemented by a class, provides an indexed access to redo data.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IUndoList RedoList { get; }
ReadOnly Property RedoList As IUndoList
    Get
property IUndoList^ RedoList {
    IUndoList^ get ();
}
abstract RedoList : IUndoList with get

Property Value

Type: IUndoList
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.UndoLimit Property

IUndoUndoLimit Property
When implemented by a class, gets or sets a value that limits number of undo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int UndoLimit { get; set; }
Property UndoLimit As Integer
    Get
    Set
property int UndoLimit {
    int get ();
    void set (int value);
}
abstract UndoLimit : int with get, set

Property Value

Type: Int32
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.UndoList Property

IUndoUndoList Property
When implemented by a class, provides an indexed access to undo data.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IUndoList UndoList { get; }
ReadOnly Property UndoList As IUndoList
    Get
property IUndoList^ UndoList {
    IUndoList^ get ();
}
abstract UndoList : IUndoList with get

Property Value

Type: IUndoList
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.UndoOptions Property

IUndoUndoOptions Property
When implemented by a class, gets or sets options for undo and redo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
UndoOptions UndoOptions { get; set; }
Property UndoOptions As UndoOptions
    Get
    Set
property UndoOptions UndoOptions {
    UndoOptions get ();
    void set (UndoOptions value);
}
abstract UndoOptions : UndoOptions with get, set

Property Value

Type: UndoOptions
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.UndoUpdateCount Property

IUndoUndoUpdateCount Property
When implemented by a class, keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int UndoUpdateCount { get; }
ReadOnly Property UndoUpdateCount As Integer
    Get
property int UndoUpdateCount {
    int get ();
}
abstract UndoUpdateCount : int with get

Property Value

Type: Int32
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo Events

IUndo Events

The IUndo type exposes the following members.

Events
 | Name | Description
Public event | UndoEvent | When implemented by a class, occurs when undo/redo operation performed.
Top
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndo.UndoEvent Event

IUndoUndoEvent Event
When implemented by a class, occurs when undo/redo operation performed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event UndoEvent UndoEvent
Event UndoEvent As UndoEvent
 event UndoEvent^ UndoEvent {
    void add (UndoEvent^ value);
    void remove (UndoEvent^ value);
}
abstract UndoEvent : IEvent<UndoEvent,
    UndoEventArgs>

Value

Type: Alternet.Editor.TextSourceUndoEvent
See Also

Reference

IUndo Interface
Alternet.Editor.TextSource Namespace


IUndoData Interface

IUndoData Interface
Represents data for a single undo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUndoData
Public Interface IUndoData
public interface class IUndoData
type IUndoData =  interface end

The IUndoData type exposes the following members.

Properties
 | Name | Description
Public property | Data | When implemented by a class, represents the object associated with this IUndoData.
Public property | Operation | When implemented by a class, represents the type of the undo operation.
Public property | Position | When implemented by a class, represents the position of the undoable operation within the text.
Public property | Reason | When implemented by a class, represents the reason of the undo operation.
Public property | UndoFlag | Reserved for internal use.
Public property | UpdateCount | When implemented by a class, keeps track of nested undo operations.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IUndoData Properties

IUndoData Properties

The IUndoData type exposes the following members.

Properties
 | Name | Description
Public property | Data | When implemented by a class, represents the object associated with this IUndoData.
Public property | Operation | When implemented by a class, represents the type of the undo operation.
Public property | Position | When implemented by a class, represents the position of the undoable operation within the text.
Public property | Reason | When implemented by a class, represents the reason of the undo operation.
Public property | UndoFlag | Reserved for internal use.
Public property | UpdateCount | When implemented by a class, keeps track of nested undo operations.
Top
See Also

Reference

IUndoData Interface
Alternet.Editor.TextSource Namespace


IUndoData.Data Property

IUndoDataData Property
When implemented by a class, represents the object associated with this IUndoData.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Data { get; set; }
Property Data As Object
    Get
    Set
property Object^ Data {
    Object^ get ();
    void set (Object^ value);
}
abstract Data : Object with get, set

Property Value

Type: Object
See Also

Reference

IUndoData Interface
Alternet.Editor.TextSource Namespace


IUndoData.Operation Property

IUndoDataOperation Property
When implemented by a class, represents the type of the undo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
UndoOperation Operation { get; set; }
Property Operation As UndoOperation
    Get
    Set
property UndoOperation Operation {
    UndoOperation get ();
    void set (UndoOperation value);
}
abstract Operation : UndoOperation with get, set

Property Value

Type: UndoOperation
See Also

Reference

IUndoData Interface
Alternet.Editor.TextSource Namespace


IUndoData.Position Property

IUndoDataPosition Property
When implemented by a class, represents the position of the undoable operation within the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Position { get; set; }
Property Position As Point
    Get
    Set
property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set

Property Value

Type: Point
See Also

Reference

IUndoData Interface
Alternet.Editor.TextSource Namespace


IUndoData.Reason Property

IUndoDataReason Property
When implemented by a class, represents the reason of the undo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
UpdateReason Reason { get; set; }
Property Reason As UpdateReason
    Get
    Set
property UpdateReason Reason {
    UpdateReason get ();
    void set (UpdateReason value);
}
abstract Reason : UpdateReason with get, set

Property Value

Type: UpdateReason
See Also

Reference

IUndoData Interface
Alternet.Editor.TextSource Namespace


IUndoData.UndoFlag Property

IUndoDataUndoFlag Property
Reserved for internal use.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
UndoFlags UndoFlag { get; set; }
Property UndoFlag As UndoFlags
    Get
    Set
property UndoFlags UndoFlag {
    UndoFlags get ();
    void set (UndoFlags value);
}
abstract UndoFlag : UndoFlags with get, set

Property Value

Type: UndoFlags
See Also

Reference

IUndoData Interface
Alternet.Editor.TextSource Namespace


IUndoData.UpdateCount Property

IUndoDataUpdateCount Property
When implemented by a class, keeps track of nested undo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int UpdateCount { get; set; }
Property UpdateCount As Integer
    Get
    Set
property int UpdateCount {
    int get ();
    void set (int value);
}
abstract UpdateCount : int with get, set

Property Value

Type: Int32
See Also

Reference

IUndoData Interface
Alternet.Editor.TextSource Namespace


IUndoList Interface

IUndoList Interface
Provides an indexed access to undo data.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUndoList : IList<IUndoData>,
    ICollection<IUndoData>, IEnumerable<IUndoData>, IEnumerable,
    IUpdate
Public Interface IUndoList
    Inherits IList(Of IUndoData), ICollection(Of IUndoData),
    IEnumerable(Of IUndoData), IEnumerable, IUpdate
public interface class IUndoList : IList<IUndoData^>,
    ICollection<IUndoData^>, IEnumerable<IUndoData^>, IEnumerable,
    IUpdate
type IUndoList =
    interface
        interface IList<IUndoData>
        interface ICollection<IUndoData>
        interface IEnumerable<IUndoData>
        interface IEnumerable
        interface IUpdate
    end

The IUndoList type exposes the following members.

Methods
 | Name | Description
Public method | Add | When implemented by a class, adds an item to the collection.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | Clear | When implemented by a class, clears entire collection.
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIUndoData .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIUndoData .)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIUndoData .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIUndoData .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIUndoData .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIUndoData .)
Public method | RemoveAt | When implemented by a class, removes item at the specified index.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIUndoData | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIUndoData | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIUndoData, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIUndoData .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIUndoData .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIUndoData .)
Public property | UndoCount | When implemented by a class, determines number of undo operations stored in the list.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IUndoList Methods

IUndoList Methods

The IUndoList type exposes the following members.

Methods
 | Name | Description
Public method | Add | When implemented by a class, adds an item to the collection.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | Clear | When implemented by a class, clears entire collection.
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIUndoData .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIUndoData .)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIUndoData .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIUndoData .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIUndoData .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIUndoData .)
Public method | RemoveAt | When implemented by a class, removes item at the specified index.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIUndoData | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIUndoData | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIUndoData, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IUndoList Interface
Alternet.Editor.TextSource Namespace


IUndoList.Add Method

IUndoListAdd Method
When implemented by a class, adds an item to the collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Add(
    IUndoData item
)
Sub Add (
    item As IUndoData
)
void Add(
    IUndoData^ item
)
abstract Add :
        item : IUndoData -> unit

Parameters

item
Type: Alternet.Editor.TextSourceIUndoData

Implements

ICollectionTAdd(T)
See Also

Reference

IUndoList Interface
Alternet.Editor.TextSource Namespace


IUndoList.Clear Method

IUndoListClear Method
When implemented by a class, clears entire collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

IUndoList Interface
Alternet.Editor.TextSource Namespace


IUndoList.RemoveAt Method

IUndoListRemoveAt Method
When implemented by a class, removes item at the specified index.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveAt(
    int index
)
Sub RemoveAt (
    index As Integer
)
void RemoveAt(
    int index
)
abstract RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies index of item to remove.

Implements

IListTRemoveAt(Int32)
See Also

Reference

IUndoList Interface
Alternet.Editor.TextSource Namespace


IUndoList Properties

IUndoList Properties

The IUndoList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIUndoData .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIUndoData .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIUndoData .)
Public property | UndoCount | When implemented by a class, determines number of undo operations stored in the list.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

IUndoList Interface
Alternet.Editor.TextSource Namespace


IUndoList.UndoCount Property

IUndoListUndoCount Property
When implemented by a class, determines number of undo operations stored in the list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int UndoCount { get; }
ReadOnly Property UndoCount As Integer
    Get
property int UndoCount {
    int get ();
}
abstract UndoCount : int with get

Property Value

Type: Int32
See Also

Reference

IUndoList Interface
Alternet.Editor.TextSource Namespace


IWordBreak Interface

IWordBreak Interface
Represents properties and methods used to separate words within Edit control content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWordBreak
Public Interface IWordBreak
public interface class IWordBreak
type IWordBreak =  interface end

The IWordBreak type exposes the following members.

Methods
 | Name | Description
Public method | GetTextAt(Point) | When implemented by a class, returns word at the specific text position.
Public method | GetTextAt(Int32, Int32) | When implemented by a class, returns word at the specific text position.
Public method | GetWord(Int32, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Char) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | IsDelimiter(Char) | When implemented by a class, indicates whether the specified character is delimiter character.
Public method | IsDelimiter(Int32, Int32) | When implemented by a class, indicates whether the character at the specific position of the string collection is delimiter character.
Public method | IsDelimiter(String, Int32) | When implemented by a class, indicates whether the character at the specific position of given string is a delimiter character.
Public method | IsWhitespace | When implemented by a class, indicates whether the character at the specific position of given string is a whitespace character.
Public method | ResetDelimiters | When implemented by a class, resets the Delimiters to the default value.
Top
Properties
 | Name | Description
Public property | Delimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text.
Public property | DelimiterString | When implemented by a class, gets or sets Delimiters as a single string.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


IWordBreak Methods

IWordBreak Methods

The IWordBreak type exposes the following members.

Methods
 | Name | Description
Public method | GetTextAt(Point) | When implemented by a class, returns word at the specific text position.
Public method | GetTextAt(Int32, Int32) | When implemented by a class, returns word at the specific text position.
Public method | GetWord(Int32, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Char) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | IsDelimiter(Char) | When implemented by a class, indicates whether the specified character is delimiter character.
Public method | IsDelimiter(Int32, Int32) | When implemented by a class, indicates whether the character at the specific position of the string collection is delimiter character.
Public method | IsDelimiter(String, Int32) | When implemented by a class, indicates whether the character at the specific position of given string is a delimiter character.
Public method | IsWhitespace | When implemented by a class, indicates whether the character at the specific position of given string is a whitespace character.
Public method | ResetDelimiters | When implemented by a class, resets the Delimiters to the default value.
Top
See Also

Reference

IWordBreak Interface
Alternet.Editor.TextSource Namespace


IWordBreak.GetTextAt Method

IWordBreakGetTextAt Method
Overload List
 | Name | Description
Public method | GetTextAt(Point) | When implemented by a class, returns word at the specific text position.
Public method | GetTextAt(Int32, Int32) | When implemented by a class, returns word at the specific text position.
Top
See Also

Reference

IWordBreak Interface
Alternet.Editor.TextSource Namespace


IWordBreak.GetTextAt Method (Point)

IWordBreakGetTextAt Method (Point)
When implemented by a class, returns word at the specific text position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetTextAt(
    Point position
)
Function GetTextAt (
    position As Point
) As String
String^ GetTextAt(
    Point position
)
abstract GetTextAt :
        position : Point -> string

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position in the text.

Return Value

Type: String
Word found at the specified position.
See Also

Reference

IWordBreak Interface
GetTextAt Overload
Alternet.Editor.TextSource Namespace


IWordBreak.GetTextAt Method (Int32, Int32)

IWordBreakGetTextAt Method (Int32, Int32)
When implemented by a class, returns word at the specific text position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetTextAt(
    int pos,
    int line
)
Function GetTextAt (
    pos As Integer,
    line As Integer
) As String
String^ GetTextAt(
    int pos,
    int line
)
abstract GetTextAt :
        pos : int *
        line : int -> string

Parameters

pos
Type: SystemInt32
Specifies index of the line.
line
Type: SystemInt32
Specifies index of character in the text string.

Return Value

Type: String
Word found at the specified position.
See Also

Reference

IWordBreak Interface
GetTextAt Overload
Alternet.Editor.TextSource Namespace


IWordBreak.GetWord Method

IWordBreakGetWord Method
Overload List
 | Name | Description
Public method | GetWord(Int32, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Char) | When implemented by a class, returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | When implemented by a class, returns word start and end, if there is word at the specified position.
Top
See Also

Reference

IWordBreak Interface
Alternet.Editor.TextSource Namespace


IWordBreak.GetWord Method (Int32, Int32, Int32, Int32)

IWordBreakGetWord Method (Int32, Int32, Int32, Int32)
When implemented by a class, returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetWord(
    int index,
    int pos,
    out int left,
    out int right
)
Function GetWord (
    index As Integer,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer
) As Boolean
bool GetWord(
    int index,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right
)
abstract GetWord :
        index : int *
        pos : int *
        left : int byref *
        right : int byref -> bool

Parameters

index
Type: SystemInt32
The index of line in the text.
pos
Type: SystemInt32
The index of character in the within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.

Return Value

Type: Boolean
True if any word found; otherwise false.
See Also

Reference

IWordBreak Interface
GetWord Overload
Alternet.Editor.TextSource Namespace


IWordBreak.GetWord Method (String, Int32, Int32, Int32)

IWordBreakGetWord Method (String, Int32, Int32, Int32)
When implemented by a class, returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetWord(
    string s,
    int pos,
    out int left,
    out int right
)
Function GetWord (
    s As String,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer
) As Boolean
bool GetWord(
    String^ s,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right
)
abstract GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref -> bool

Parameters

s
Type: SystemString
The given string.
pos
Type: SystemInt32
The index of character within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.

Return Value

Type: Boolean
True if any word found; otherwise false.
See Also

Reference

IWordBreak Interface
GetWord Overload
Alternet.Editor.TextSource Namespace


IWordBreak.GetWord Method (String, Int32, Int32, Int32, Char[])

IWordBreakGetWord Method (String, Int32, Int32, Int32, Char)
When implemented by a class, returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetWord(
    string s,
    int pos,
    out int left,
    out int right,
    char[] delims
)
Function GetWord (
    s As String,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer,
    delims As Char()
) As Boolean
bool GetWord(
    String^ s,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right,
    array<wchar_t>^ delims
)
abstract GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : char[] -> bool

Parameters

s
Type: SystemString
The given string.
pos
Type: SystemInt32
The index of character within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.
delims
Type: SystemChar
Collection of delimiters.

Return Value

Type: Boolean
True if any word found; otherwise false.
See Also

Reference

IWordBreak Interface
GetWord Overload
Alternet.Editor.TextSource Namespace


IWordBreak.GetWord Method (String, Int32, Int32, Int32, Hashtable)

IWordBreakGetWord Method (String, Int32, Int32, Int32, Hashtable)
When implemented by a class, returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetWord(
    string s,
    int pos,
    out int left,
    out int right,
    Hashtable delims
)
Function GetWord (
    s As String,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer,
    delims As Hashtable
) As Boolean
bool GetWord(
    String^ s,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right,
    Hashtable^ delims
)
abstract GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : Hashtable -> bool

Parameters

s
Type: SystemString
The given string.
pos
Type: SystemInt32
The index of character within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.
delims
Type: System.CollectionsHashtable
Collection of delimiters.

Return Value

Type: Boolean
True if any word found; otherwise false.
See Also

Reference

IWordBreak Interface
GetWord Overload
Alternet.Editor.TextSource Namespace


IWordBreak.IsDelimiter Method

IWordBreakIsDelimiter Method
Overload List
 | Name | Description
Public method | IsDelimiter(Char) | When implemented by a class, indicates whether the specified character is delimiter character.
Public method | IsDelimiter(Int32, Int32) | When implemented by a class, indicates whether the character at the specific position of the string collection is delimiter character.
Public method | IsDelimiter(String, Int32) | When implemented by a class, indicates whether the character at the specific position of given string is a delimiter character.
Top
See Also

Reference

IWordBreak Interface
Alternet.Editor.TextSource Namespace


IWordBreak.IsDelimiter Method (Char)

IWordBreakIsDelimiter Method (Char)
When implemented by a class, indicates whether the specified character is delimiter character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsDelimiter(
    char ch
)
Function IsDelimiter (
    ch As Char
) As Boolean
bool IsDelimiter(
    wchar_t ch
)
abstract IsDelimiter :
        ch : char -> bool

Parameters

ch
Type: SystemChar
The char value that should be tested.

Return Value

Type: Boolean
True if specified character is delimiter; otherwise false.
See Also

Reference

IWordBreak Interface
IsDelimiter Overload
Alternet.Editor.TextSource Namespace


IWordBreak.IsDelimiter Method (Int32, Int32)

IWordBreakIsDelimiter Method (Int32, Int32)
When implemented by a class, indicates whether the character at the specific position of the string collection is delimiter character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsDelimiter(
    int index,
    int pos
)
Function IsDelimiter (
    index As Integer,
    pos As Integer
) As Boolean
bool IsDelimiter(
    int index,
    int pos
)
abstract IsDelimiter :
        index : int *
        pos : int -> bool

Parameters

index
Type: SystemInt32
The index of line in which character should be tested.
pos
Type: SystemInt32
The index of character in the specific string.

Return Value

Type: Boolean
True if specified character is delimiter; otherwise false.
See Also

Reference

IWordBreak Interface
IsDelimiter Overload
Alternet.Editor.TextSource Namespace


IWordBreak.IsDelimiter Method (String, Int32)

IWordBreakIsDelimiter Method (String, Int32)
When implemented by a class, indicates whether the character at the specific position of given string is a delimiter character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsDelimiter(
    string s,
    int pos
)
Function IsDelimiter (
    s As String,
    pos As Integer
) As Boolean
bool IsDelimiter(
    String^ s,
    int pos
)
abstract IsDelimiter :
        s : string *
        pos : int -> bool

Parameters

s
Type: SystemString
The string in which character should be tested.
pos
Type: SystemInt32
The index of character in the given string.

Return Value

Type: Boolean
True if specified character is delimiter; otherwise false.
See Also

Reference

IWordBreak Interface
IsDelimiter Overload
Alternet.Editor.TextSource Namespace


IWordBreak.IsWhitespace Method

IWordBreakIsWhitespace Method
When implemented by a class, indicates whether the character at the specific position of given string is a whitespace character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsWhitespace(
    string s,
    int pos
)
Function IsWhitespace (
    s As String,
    pos As Integer
) As Boolean
bool IsWhitespace(
    String^ s,
    int pos
)
abstract IsWhitespace :
        s : string *
        pos : int -> bool

Parameters

s
Type: SystemString
The string in which character should be tested.
pos
Type: SystemInt32
The index of character in the given string.

Return Value

Type: Boolean
True if specified character is whitespace; otherwise false.
See Also

Reference

IWordBreak Interface
Alternet.Editor.TextSource Namespace


IWordBreak.ResetDelimiters Method

IWordBreakResetDelimiters Method
When implemented by a class, resets the Delimiters to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDelimiters()
Sub ResetDelimiters
void ResetDelimiters()
abstract ResetDelimiters : unit -> unit
See Also

Reference

IWordBreak Interface
Alternet.Editor.TextSource Namespace


IWordBreak Properties

IWordBreak Properties

The IWordBreak type exposes the following members.

Properties
 | Name | Description
Public property | Delimiters | When implemented by a class, gets or sets an array of characters used as delimiters between words in the text.
Public property | DelimiterString | When implemented by a class, gets or sets Delimiters as a single string.
Top
See Also

Reference

IWordBreak Interface
Alternet.Editor.TextSource Namespace


IWordBreak.Delimiters Property

IWordBreakDelimiters Property
When implemented by a class, gets or sets an array of characters used as delimiters between words in the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] Delimiters { get; set; }
Property Delimiters As Char()
    Get
    Set
property array<wchar_t>^ Delimiters {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract Delimiters : char[] with get, set

Property Value

Type: Char
See Also

Reference

IWordBreak Interface
Alternet.Editor.TextSource Namespace


IWordBreak.DelimiterString Property

IWordBreakDelimiterString Property
When implemented by a class, gets or sets Delimiters as a single string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string DelimiterString { get; set; }
Property DelimiterString As String
    Get
    Set
property String^ DelimiterString {
    String^ get ();
    void set (String^ value);
}
abstract DelimiterString : string with get, set

Property Value

Type: String
See Also

Reference

IWordBreak Interface
Alternet.Editor.TextSource Namespace


LineStyle Class

LineStyle Class
Represents a particular style of the line in Edit control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TextSourceBookMark
Alternet.Editor.TextSourceLineStyle

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineStyle : BookMark, ILineStyle,
    IBookMark
Public Class LineStyle
    Inherits BookMark
    Implements ILineStyle, IBookMark
public ref class LineStyle : public BookMark,
    ILineStyle, IBookMark
type LineStyle =
    class
        inherit BookMark
        interface ILineStyle
        interface IBookMark
    end

The LineStyle type exposes the following members.

Constructors
 | Name | Description
Public method | LineStyle | Initializes a new instance of the LineStyle class with default settings.
Public method | LineStyle(Int32) | Initializes a new instance of the LineStyle class with specified parameters.
Public method | LineStyle(Int32, Int32, Int32) | Initializes a new instance of the LineStyle class with specified parameters.
Public method | LineStyle(Int32, Int32, Int32, Int32, IRange) | Initializes a new instance of the LineStyle class with specified parameters.
Top
Methods
 | Name | Description
Public method | Assign(IBookMark) | Copies the contents of another bookmark object to the bookmark. (Inherited from BookMark.)
Public method | Assign(ILineStyle) | Copies the contents of another bookmark object to the bookmark.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeDescription | Indicates whether the Description should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeFileName | Indicates whether the FileName should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeGroup | Indicates whether the Group should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeImageIndex | Indicates whether the ImageIndex should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeIndex | Indicates whether the Index should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeLine | Indicates whether the Line should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeName | Indicates whether the Name should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializePos | Indicates whether the Pos should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeUrl | Indicates whether the Url should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeZIndex | Indicates whether the ZIndex should be persisted. (Inherited from BookMark.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | Gets or sets bookmark description. (Inherited from BookMark.)
Public property | FileName | Gets or sets an file name associated with this IBookMark. (Inherited from BookMark.)
Public property | Group | When implemented by a class, gets or sets a group associated with this IBookMark. (Inherited from BookMark.)
Public property | ImageIndex | Gets or sets an image index associated with this IBookMark. (Inherited from BookMark.)
Public property | Index | Gets an integer value that specifies ordinal number of the bookmark. (Inherited from BookMark.)
Public property | Line | Gets position of the bookmark within the text. 0 corresponds to the first line, 1 to second the line, and so on. (Inherited from BookMark.)
Public property | Name | Gets or sets name of the bookmark. (Inherited from BookMark.)
Public property | Pos | Gets position of the bookmark within the text line. 0 corresponds to the first character in a line, 1 to the second character, and so on. (Inherited from BookMark.)
Public property | Position | Gets position of the bookmark within the text (index of character and line). Corresponds to Pos and Line properties. (Inherited from BookMark.)
Public property | Priority | Specifies priority of the line style.
Public property | Range | Specifies range where line style is displayed.
Public property | Tag | Gets or sets user-defined data associated with this IBookMark. (Inherited from BookMark.)
Public property | Url | Gets or sets bookmark url. (Inherited from BookMark.)
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark. (Inherited from BookMark.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


LineStyle Constructor

LineStyle Constructor
Overload List
 | Name | Description
Public method | LineStyle | Initializes a new instance of the LineStyle class with default settings.
Public method | LineStyle(Int32) | Initializes a new instance of the LineStyle class with specified parameters.
Public method | LineStyle(Int32, Int32, Int32) | Initializes a new instance of the LineStyle class with specified parameters.
Public method | LineStyle(Int32, Int32, Int32, Int32, IRange) | Initializes a new instance of the LineStyle class with specified parameters.
Top
See Also

Reference

LineStyle Class
Alternet.Editor.TextSource Namespace


LineStyle Constructor

LineStyle Constructor
Initializes a new instance of the LineStyle class with default settings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineStyle()
Public Sub New
public:
LineStyle()
new : unit -> LineStyle
See Also

Reference

LineStyle Class
LineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyle Constructor (Int32)

LineStyle Constructor (Int32)
Initializes a new instance of the LineStyle class with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineStyle(
    int line
)
Public Sub New (
    line As Integer
)
public:
LineStyle(
    int line
)
new :
        line : int -> LineStyle

Parameters

line
Type: SystemInt32
Specifies index of the text line.
See Also

Reference

LineStyle Class
LineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyle Constructor (Int32, Int32, Int32)

LineStyle Constructor (Int32, Int32, Int32)
Initializes a new instance of the LineStyle class with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineStyle(
    int line,
    int ch,
    int index
)
Public Sub New (
    line As Integer,
    ch As Integer,
    index As Integer
)
public:
LineStyle(
    int line,
    int ch,
    int index
)
new :
        line : int *
        ch : int *
        index : int -> LineStyle

Parameters

line
Type: SystemInt32
Specifies index of the text line.
ch
Type: SystemInt32
Specifies position of character within text line.
index
Type: SystemInt32
Specifies ordinal number of line style within line styles collection.
See Also

Reference

LineStyle Class
LineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyle Constructor (Int32, Int32, Int32, Int32, IRange)

LineStyle Constructor (Int32, Int32, Int32, Int32, IRange)
Initializes a new instance of the LineStyle class with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineStyle(
    int line,
    int ch,
    int index,
    int priority,
    IRange range
)
Public Sub New (
    line As Integer,
    ch As Integer,
    index As Integer,
    priority As Integer,
    range As IRange
)
public:
LineStyle(
    int line,
    int ch,
    int index,
    int priority,
    IRange^ range
)
new :
        line : int *
        ch : int *
        index : int *
        priority : int *
        range : IRange -> LineStyle

Parameters

line
Type: SystemInt32
Specifies index of the text line.
ch
Type: SystemInt32
Specifies position of character within text line.
index
Type: SystemInt32
Specifies ordinal number of line style within line styles collection.
priority
Type: SystemInt32
Specifies priority of the line style.
range
Type: Alternet.CommonIRange
Specifies range where line style is displayed.
See Also

Reference

LineStyle Class
LineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyle Methods

LineStyle Methods

The LineStyle type exposes the following members.

Methods
 | Name | Description
Public method | Assign(IBookMark) | Copies the contents of another bookmark object to the bookmark. (Inherited from BookMark.)
Public method | Assign(ILineStyle) | Copies the contents of another bookmark object to the bookmark.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeDescription | Indicates whether the Description should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeFileName | Indicates whether the FileName should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeGroup | Indicates whether the Group should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeImageIndex | Indicates whether the ImageIndex should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeIndex | Indicates whether the Index should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeLine | Indicates whether the Line should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeName | Indicates whether the Name should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializePos | Indicates whether the Pos should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeUrl | Indicates whether the Url should be persisted. (Inherited from BookMark.)
Public method | ShouldSerializeZIndex | Indicates whether the ZIndex should be persisted. (Inherited from BookMark.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineStyle Class
Alternet.Editor.TextSource Namespace


LineStyle.Assign Method

LineStyleAssign Method
Overload List
 | Name | Description
Public method | Assign(IBookMark) | Copies the contents of another bookmark object to the bookmark. (Inherited from BookMark.)
Public method | Assign(ILineStyle) | Copies the contents of another bookmark object to the bookmark.
Top
See Also

Reference

LineStyle Class
Alternet.Editor.TextSource Namespace


LineStyle.Assign Method (ILineStyle)

LineStyleAssign Method (ILineStyle)
Copies the contents of another bookmark object to the bookmark.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ILineStyle source
)
Public Overridable Sub Assign (
    source As ILineStyle
)
public:
virtual void Assign(
    ILineStyle^ source
)
abstract Assign :
        source : ILineStyle -> unit
override Assign :
        source : ILineStyle -> unit

Parameters

source
Type: Alternet.Editor.TextSourceILineStyle
Specifies bookmark to copy content from. Call Assign to copy Line, Index and Pos property from source bookmark.
See Also

Reference

LineStyle Class
Assign Overload
Alternet.Editor.TextSource Namespace


LineStyle Properties

LineStyle Properties

The LineStyle type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets bookmark description. (Inherited from BookMark.)
Public property | FileName | Gets or sets an file name associated with this IBookMark. (Inherited from BookMark.)
Public property | Group | When implemented by a class, gets or sets a group associated with this IBookMark. (Inherited from BookMark.)
Public property | ImageIndex | Gets or sets an image index associated with this IBookMark. (Inherited from BookMark.)
Public property | Index | Gets an integer value that specifies ordinal number of the bookmark. (Inherited from BookMark.)
Public property | Line | Gets position of the bookmark within the text. 0 corresponds to the first line, 1 to second the line, and so on. (Inherited from BookMark.)
Public property | Name | Gets or sets name of the bookmark. (Inherited from BookMark.)
Public property | Pos | Gets position of the bookmark within the text line. 0 corresponds to the first character in a line, 1 to the second character, and so on. (Inherited from BookMark.)
Public property | Position | Gets position of the bookmark within the text (index of character and line). Corresponds to Pos and Line properties. (Inherited from BookMark.)
Public property | Priority | Specifies priority of the line style.
Public property | Range | Specifies range where line style is displayed.
Public property | Tag | Gets or sets user-defined data associated with this IBookMark. (Inherited from BookMark.)
Public property | Url | Gets or sets bookmark url. (Inherited from BookMark.)
Public property | ZIndex | When implemented by a class, gets or sets an z-index associated with this IBookMark. (Inherited from BookMark.)
Top
See Also

Reference

LineStyle Class
Alternet.Editor.TextSource Namespace


LineStyle.Priority Property

LineStylePriority Property
Specifies priority of the line style.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Priority { get; set; }
Public Overridable Property Priority As Integer
    Get
    Set
public:
virtual property int Priority {
    int get ();
    void set (int value);
}
abstract Priority : int with get, set
override Priority : int with get, set

Property Value

Type: Int32

Implements

ILineStylePriority
See Also

Reference

LineStyle Class
Alternet.Editor.TextSource Namespace


LineStyle.Range Property

LineStyleRange Property
Specifies range where line style is displayed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange Range { get; set; }
Public Overridable Property Range As IRange
    Get
    Set
public:
virtual property IRange^ Range {
    IRange^ get ();
    void set (IRange^ value);
}
abstract Range : IRange with get, set
override Range : IRange with get, set

Property Value

Type: IRange

Implements

ILineStyleRange
See Also

Reference

LineStyle Class
Alternet.Editor.TextSource Namespace


LineStyles Class

LineStyles Class
Represents properties and methods for a collection that binds line styles to individual lines within Edit control content.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListILineStyle
Alternet.CommonSortList ILineStyle
Alternet.Editor.TextSourceLineStyles

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineStyles : SortList<ILineStyle>,
    ILineStyles, IList<ILineStyle>, ICollection<ILineStyle>,
    IEnumerable<ILineStyle>, IEnumerable
Public Class LineStyles
    Inherits SortList(Of ILineStyle)
    Implements ILineStyles, IList(Of ILineStyle),
    ICollection(Of ILineStyle), IEnumerable(Of ILineStyle), IEnumerable
public ref class LineStyles : public SortList<ILineStyle^>,
    ILineStyles, IList<ILineStyle^>, ICollection<ILineStyle^>,
    IEnumerable<ILineStyle^>, IEnumerable
type LineStyles =
    class
        inherit SortList<ILineStyle>
        interface ILineStyles
        interface IList<ILineStyle>
        interface ICollection<ILineStyle>
        interface IEnumerable<ILineStyle>
        interface IEnumerable
    end

The LineStyles type exposes the following members.

Constructors
 | Name | Description
Public method | LineStyles | Initializes a new instance of the LineStyles class with default parameters.
Public method | LineStyles(ITextSource) | Initializes a new instance of the LineStyles class with specified owner.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILineStyle .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILineStyle .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILineStyle .)
Public method | Assign | Copies the contents from another ILineStyles object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILineStyle .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILineStyle .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILineStyle .)
Public method | BlockDeleting | Removes all bookmarks within specified rectangle.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILineStyle .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILineStyle .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILineStyle .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILineStyle .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILineStyle .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILineStyle .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILineStyle .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILineStyle .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILineStyle .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILineStyle .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILineStyle .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILineStyle .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILineStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILineStyle .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLineStyle | Finds the first element in the line style collection located at the specified text line.
Public method | GetLineStyles | Finds all linestyles in the LineStyles collection located inside specified line.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILineStyle .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILineStyle .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILineStyle .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILineStyle .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILineStyle .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILineStyle .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILineStyle .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Updates all bookmarks starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILineStyle .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILineStyle .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILineStyle .)
Public method | RemoveLineStyle(Int32) | Removes the first line style at the specified line.
Public method | RemoveLineStyle(Int32, Int32) | When implemented by a class, removes the first line style at the specified line.
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILineStyle .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILineStyle .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILineStyle .)
Public method | SetLineStyle(Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(Point, Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(Int32, Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(IRange, Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(Point, IRange, Int32, Int32) | Sets given line style to the specified line.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILineStyle .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILineStyle .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILineStyle .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILineStyle .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILineStyle .)
Public method | ToggleLineStyle(Int32, Int32) | Sets or removes line style at the specified line.
Public method | ToggleLineStyle(Int32, Int32, Int32) | Sets or removes line style at the specified line.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILineStyle .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILineStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILineStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILineStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILineStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILineStyle .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILineStyle .)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


LineStyles Constructor

LineStyles Constructor
Overload List
 | Name | Description
Public method | LineStyles | Initializes a new instance of the LineStyles class with default parameters.
Public method | LineStyles(ITextSource) | Initializes a new instance of the LineStyles class with specified owner.
Top
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles Constructor

LineStyles Constructor
Initializes a new instance of the LineStyles class with default parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineStyles()
Public Sub New
public:
LineStyles()
new : unit -> LineStyles
See Also

Reference

LineStyles Class
LineStyles Overload
Alternet.Editor.TextSource Namespace


LineStyles Constructor (ITextSource)

LineStyles Constructor (ITextSource)
Initializes a new instance of the LineStyles class with specified owner.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineStyles(
    ITextSource owner
)
Public Sub New (
    owner As ITextSource
)
public:
LineStyles(
    ITextSource^ owner
)
new :
        owner : ITextSource -> LineStyles

Parameters

owner
Type: Alternet.Editor.TextSourceITextSource
ITextSource that owns this new instance.
See Also

Reference

LineStyles Class
LineStyles Overload
Alternet.Editor.TextSource Namespace


LineStyles Methods

LineStyles Methods

The LineStyles type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILineStyle .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILineStyle .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILineStyle .)
Public method | Assign | Copies the contents from another ILineStyles object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILineStyle .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILineStyle .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILineStyle .)
Public method | BlockDeleting | Removes all bookmarks within specified rectangle.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILineStyle .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILineStyle .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILineStyle .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILineStyle .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILineStyle .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILineStyle .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILineStyle .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILineStyle .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILineStyle .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILineStyle .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILineStyle .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILineStyle .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILineStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILineStyle .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLineStyle | Finds the first element in the line style collection located at the specified text line.
Public method | GetLineStyles | Finds all linestyles in the LineStyles collection located inside specified line.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILineStyle .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILineStyle .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILineStyle .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILineStyle .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILineStyle .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILineStyle .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILineStyle .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILineStyle .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Updates all bookmarks starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILineStyle .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILineStyle .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILineStyle .)
Public method | RemoveLineStyle(Int32) | Removes the first line style at the specified line.
Public method | RemoveLineStyle(Int32, Int32) | When implemented by a class, removes the first line style at the specified line.
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILineStyle .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILineStyle .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILineStyle .)
Public method | SetLineStyle(Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(Point, Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(Int32, Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(IRange, Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(Point, IRange, Int32, Int32) | Sets given line style to the specified line.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILineStyle .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILineStyle .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILineStyle .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILineStyle .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILineStyle .)
Public method | ToggleLineStyle(Int32, Int32) | Sets or removes line style at the specified line.
Public method | ToggleLineStyle(Int32, Int32, Int32) | Sets or removes line style at the specified line.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILineStyle .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILineStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILineStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILineStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILineStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles.Assign Method

LineStylesAssign Method
Copies the contents from another ILineStyles object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ILineStyles source
)
Public Overridable Sub Assign (
    source As ILineStyles
)
public:
virtual void Assign(
    ILineStyles^ source
)
abstract Assign :
        source : ILineStyles -> unit
override Assign :
        source : ILineStyles -> unit

Parameters

source
Type: Alternet.Editor.TextSourceILineStyles
Specifies ILineStyles to assign.

Implements

ILineStylesAssign(ILineStyles)
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles.BlockDeleting Method

LineStylesBlockDeleting Method
Removes all bookmarks within specified rectangle.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect
)
Public Overridable Function BlockDeleting (
    rect As Rectangle
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool
override BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to check.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ILineStylesBlockDeleting(Rectangle)
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles.GetLineStyle Method

LineStylesGetLineStyle Method
Finds the first element in the line style collection located at the specified text line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetLineStyle(
    int index
)
Public Overridable Function GetLineStyle (
    index As Integer
) As Integer
public:
virtual int GetLineStyle(
    int index
)
abstract GetLineStyle :
        index : int -> int
override GetLineStyle :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of the text line.

Return Value

Type: Int32
Index of the found line style if the search succeed; otherwise -1.

Implements

ILineStylesGetLineStyle(Int32)
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles.GetLineStyles Method

LineStylesGetLineStyles Method
Finds all linestyles in the LineStyles collection located inside specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetLineStyles(
    int line,
    IList<ILineStyle> list
)
Public Overridable Function GetLineStyles (
    line As Integer,
    list As IList(Of ILineStyle)
) As Integer
public:
virtual int GetLineStyles(
    int line,
    IList<ILineStyle^>^ list
)
abstract GetLineStyles :
        line : int *
        list : IList<ILineStyle> -> int
override GetLineStyles :
        line : int *
        list : IList<ILineStyle> -> int

Parameters

line
Type: SystemInt32
The index of the line to find.
list
Type: System.Collections.GenericIListILineStyle
Represents the collection of the bookmarks located within the specified range.

Return Value

Type: Int32
The number of the linestyles located within the specified range.

Implements

ILineStylesGetLineStyles(Int32, IListILineStyle)
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles.PositionChanged Method

LineStylesPositionChanged Method
Updates all bookmarks starting from specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ILineStylesPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles.RemoveLineStyle Method

LineStylesRemoveLineStyle Method
Overload List
 | Name | Description
Public method | RemoveLineStyle(Int32) | Removes the first line style at the specified line.
Public method | RemoveLineStyle(Int32, Int32) | When implemented by a class, removes the first line style at the specified line.
Top
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles.RemoveLineStyle Method (Int32)

LineStylesRemoveLineStyle Method (Int32)
Removes the first line style at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveLineStyle(
    int line
)
Public Overridable Sub RemoveLineStyle (
    line As Integer
)
public:
virtual void RemoveLineStyle(
    int line
)
abstract RemoveLineStyle :
        line : int -> unit
override RemoveLineStyle :
        line : int -> unit

Parameters

line
Type: SystemInt32
Index of the text line.

Implements

ILineStylesRemoveLineStyle(Int32)
See Also

Reference

LineStyles Class
RemoveLineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyles.RemoveLineStyle Method (Int32, Int32)

LineStylesRemoveLineStyle Method (Int32, Int32)
When implemented by a class, removes the first line style at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveLineStyle(
    int line,
    int style
)
Public Overridable Sub RemoveLineStyle (
    line As Integer,
    style As Integer
)
public:
virtual void RemoveLineStyle(
    int line,
    int style
)
abstract RemoveLineStyle :
        line : int *
        style : int -> unit
override RemoveLineStyle :
        line : int *
        style : int -> unit

Parameters

line
Type: SystemInt32
Index of the text line.
style
Type: SystemInt32
Index of style.

Implements

ILineStylesRemoveLineStyle(Int32, Int32)
See Also

Reference

LineStyles Class
RemoveLineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyles.SetLineStyle Method

LineStylesSetLineStyle Method
Overload List
 | Name | Description
Public method | SetLineStyle(Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(Point, Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(Int32, Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(IRange, Int32, Int32) | Sets given line style to the specified line.
Public method | SetLineStyle(Point, IRange, Int32, Int32) | Sets given line style to the specified line.
Top
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles.SetLineStyle Method (Int32, Int32)

LineStylesSetLineStyle Method (Int32, Int32)
Sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineStyle(
    int index,
    int style
)
Public Overridable Sub SetLineStyle (
    index As Integer,
    style As Integer
)
public:
virtual void SetLineStyle(
    int index,
    int style
)
abstract SetLineStyle :
        index : int *
        style : int -> unit
override SetLineStyle :
        index : int *
        style : int -> unit

Parameters

index
Type: SystemInt32
Index of the text line.
style
Type: SystemInt32
Index of the line style.

Implements

ILineStylesSetLineStyle(Int32, Int32)
See Also

Reference

LineStyles Class
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyles.SetLineStyle Method (Point, Int32, Int32)

LineStylesSetLineStyle Method (Point, Int32, Int32)
Sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineStyle(
    Point position,
    int priority,
    int style
)
Public Overridable Sub SetLineStyle (
    position As Point,
    priority As Integer,
    style As Integer
)
public:
virtual void SetLineStyle(
    Point position,
    int priority,
    int style
)
abstract SetLineStyle :
        position : Point *
        priority : int *
        style : int -> unit
override SetLineStyle :
        position : Point *
        priority : int *
        style : int -> unit

Parameters

position
Type: System.DrawingPoint
Position of the line style.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of the line style.

Implements

ILineStylesSetLineStyle(Point, Int32, Int32)
See Also

Reference

LineStyles Class
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyles.SetLineStyle Method (Int32, Int32, Int32)

LineStylesSetLineStyle Method (Int32, Int32, Int32)
Sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineStyle(
    int line,
    int priority,
    int style
)
Public Overridable Sub SetLineStyle (
    line As Integer,
    priority As Integer,
    style As Integer
)
public:
virtual void SetLineStyle(
    int line,
    int priority,
    int style
)
abstract SetLineStyle :
        line : int *
        priority : int *
        style : int -> unit
override SetLineStyle :
        line : int *
        priority : int *
        style : int -> unit

Parameters

line
Type: SystemInt32
Index of the text line.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of the line style.

Implements

ILineStylesSetLineStyle(Int32, Int32, Int32)
See Also

Reference

LineStyles Class
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyles.SetLineStyle Method (IRange, Int32, Int32)

LineStylesSetLineStyle Method (IRange, Int32, Int32)
Sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineStyle(
    IRange range,
    int priority,
    int style
)
Public Overridable Sub SetLineStyle (
    range As IRange,
    priority As Integer,
    style As Integer
)
public:
virtual void SetLineStyle(
    IRange^ range,
    int priority,
    int style
)
abstract SetLineStyle :
        range : IRange *
        priority : int *
        style : int -> unit
override SetLineStyle :
        range : IRange *
        priority : int *
        style : int -> unit

Parameters

range
Type: Alternet.CommonIRange
Range where line style is defined.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of the line style.

Implements

ILineStylesSetLineStyle(IRange, Int32, Int32)
See Also

Reference

LineStyles Class
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyles.SetLineStyle Method (Point, IRange, Int32, Int32)

LineStylesSetLineStyle Method (Point, IRange, Int32, Int32)
Sets given line style to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineStyle(
    Point position,
    IRange range,
    int priority,
    int style
)
Public Overridable Sub SetLineStyle (
    position As Point,
    range As IRange,
    priority As Integer,
    style As Integer
)
public:
virtual void SetLineStyle(
    Point position,
    IRange^ range,
    int priority,
    int style
)
abstract SetLineStyle :
        position : Point *
        range : IRange *
        priority : int *
        style : int -> unit
override SetLineStyle :
        position : Point *
        range : IRange *
        priority : int *
        style : int -> unit

Parameters

position
Type: System.DrawingPoint
Position of the line style.
range
Type: Alternet.CommonIRange
Range where line style is defined.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of the line style.

Implements

ILineStylesSetLineStyle(Point, IRange, Int32, Int32)
See Also

Reference

LineStyles Class
SetLineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyles.ToggleLineStyle Method

LineStylesToggleLineStyle Method
Overload List
 | Name | Description
Public method | ToggleLineStyle(Int32, Int32) | Sets or removes line style at the specified line.
Public method | ToggleLineStyle(Int32, Int32, Int32) | Sets or removes line style at the specified line.
Top
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LineStyles.ToggleLineStyle Method (Int32, Int32)

LineStylesToggleLineStyle Method (Int32, Int32)
Sets or removes line style at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleLineStyle(
    int line,
    int style
)
Public Overridable Sub ToggleLineStyle (
    line As Integer,
    style As Integer
)
public:
virtual void ToggleLineStyle(
    int line,
    int style
)
abstract ToggleLineStyle :
        line : int *
        style : int -> unit
override ToggleLineStyle :
        line : int *
        style : int -> unit

Parameters

line
Type: SystemInt32
Index of line to toggle line style.
style
Type: SystemInt32
Index of style.

Implements

ILineStylesToggleLineStyle(Int32, Int32)
See Also

Reference

LineStyles Class
ToggleLineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyles.ToggleLineStyle Method (Int32, Int32, Int32)

LineStylesToggleLineStyle Method (Int32, Int32, Int32)
Sets or removes line style at the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ToggleLineStyle(
    int line,
    int priority,
    int style
)
Public Overridable Sub ToggleLineStyle (
    line As Integer,
    priority As Integer,
    style As Integer
)
public:
virtual void ToggleLineStyle(
    int line,
    int priority,
    int style
)
abstract ToggleLineStyle :
        line : int *
        priority : int *
        style : int -> unit
override ToggleLineStyle :
        line : int *
        priority : int *
        style : int -> unit

Parameters

line
Type: SystemInt32
Index of line to toggle line style.
priority
Type: SystemInt32
Priority of the line style. This parameter is useful only for line styles having image indexes.
style
Type: SystemInt32
Index of style.

Implements

ILineStylesToggleLineStyle(Int32, Int32, Int32)
See Also

Reference

LineStyles Class
ToggleLineStyle Overload
Alternet.Editor.TextSource Namespace


LineStyles Properties

LineStyles Properties

The LineStyles type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILineStyle .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILineStyle .)
Top
See Also

Reference

LineStyles Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem Class

LowFootprintStringItem Class
Represents string-like object with extended properties.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TextSourceLowFootprintStringItem

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LowFootprintStringItem : IStringItem
Public Class LowFootprintStringItem
    Implements IStringItem
public ref class LowFootprintStringItem : IStringItem
type LowFootprintStringItem =
    class
        interface IStringItem
    end

The LowFootprintStringItem type exposes the following members.

Constructors
 | Name | Description
Public method | LowFootprintStringItem | Initializes a new instance of the StringItem class with specified string.
Top
Methods
 | Name | Description
Public method | ClearTextStyle | Removes style information from specified part of string.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetTextStyle | Sets style information to specified part of string.
Public method | TextStyleAt | Retrieves style information from IStringItem.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | LexState | Gets or sets index of lexical state at item end.
Public property | PrevLexState | Gets or sets index of lexical state at item start.
Public property | State | Gets or sets current state of the IStringItem.
Public property | String | Gets or sets string content of the IStringItem.
Public property | TextData | Gets or sets information of the IStringItem.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


LowFootprintStringItem Constructor

LowFootprintStringItem Constructor
Initializes a new instance of the StringItem class with specified string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LowFootprintStringItem(
    string s
)
Public Sub New (
    s As String
)
public:
LowFootprintStringItem(
    String^ s
)
new :
        s : string -> LowFootprintStringItem

Parameters

s
Type: SystemString
Specifies string content of this new instance.
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem Methods

LowFootprintStringItem Methods

The LowFootprintStringItem type exposes the following members.

Methods
 | Name | Description
Public method | ClearTextStyle | Removes style information from specified part of string.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetTextStyle | Sets style information to specified part of string.
Public method | TextStyleAt | Retrieves style information from IStringItem.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem.ClearTextStyle Method

LowFootprintStringItemClearTextStyle Method
Removes style information from specified part of string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearTextStyle(
    int start,
    int len,
    TextStyle style
)
Public Overridable Sub ClearTextStyle (
    start As Integer,
    len As Integer,
    style As TextStyle
)
public:
virtual void ClearTextStyle(
    int start,
    int len,
    TextStyle style
)
abstract ClearTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit
override ClearTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit

Parameters

start
Type: SystemInt32
Specifies the first character in string to remove.
len
Type: SystemInt32
Specifies number of characters in string to remove.
style
Type: Alternet.SyntaxTextStyle
Specifies TextStyle to remove.

Implements

IStringItemClearTextStyle(Int32, Int32, TextStyle)
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem.SetTextStyle Method

LowFootprintStringItemSetTextStyle Method
Sets style information to specified part of string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetTextStyle(
    int start,
    int len,
    TextStyle style
)
Public Overridable Sub SetTextStyle (
    start As Integer,
    len As Integer,
    style As TextStyle
)
public:
virtual void SetTextStyle(
    int start,
    int len,
    TextStyle style
)
abstract SetTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit
override SetTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit

Parameters

start
Type: SystemInt32
Specifies the first character in string to set.
len
Type: SystemInt32
Specifies number of characters in string to set.
style
Type: Alternet.SyntaxTextStyle
Specifies TextStyle to set.

Implements

IStringItemSetTextStyle(Int32, Int32, TextStyle)
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem.TextStyleAt Method

LowFootprintStringItemTextStyleAt Method
Retrieves style information from IStringItem.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual TextStyle TextStyleAt(
    int pos
)
Public Overridable Function TextStyleAt (
    pos As Integer
) As TextStyle
public:
virtual TextStyle TextStyleAt(
    int pos
)
abstract TextStyleAt :
        pos : int -> TextStyle
override TextStyleAt :
        pos : int -> TextStyle

Parameters

pos
Type: SystemInt32
Specifies position in IStringItem to obtain style information.

Return Value

Type: TextStyle
TextStyle at specified position.

Implements

IStringItemTextStyleAt(Int32)
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem Properties

LowFootprintStringItem Properties

The LowFootprintStringItem type exposes the following members.

Properties
 | Name | Description
Public property | LexState | Gets or sets index of lexical state at item end.
Public property | PrevLexState | Gets or sets index of lexical state at item start.
Public property | State | Gets or sets current state of the IStringItem.
Public property | String | Gets or sets string content of the IStringItem.
Public property | TextData | Gets or sets information of the IStringItem.
Top
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem.LexState Property

LowFootprintStringItemLexState Property
Gets or sets index of lexical state at item end.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LexState { get; set; }
Public Overridable Property LexState As Integer
    Get
    Set
public:
virtual property int LexState {
    int get ();
    void set (int value);
}
abstract LexState : int with get, set
override LexState : int with get, set

Property Value

Type: Int32

Implements

IStringItemLexState
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem.PrevLexState Property

LowFootprintStringItemPrevLexState Property
Gets or sets index of lexical state at item start.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PrevLexState { get; set; }
Public Overridable Property PrevLexState As Integer
    Get
    Set
public:
virtual property int PrevLexState {
    int get ();
    void set (int value);
}
abstract PrevLexState : int with get, set
override PrevLexState : int with get, set

Property Value

Type: Int32

Implements

IStringItemPrevLexState
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem.State Property

LowFootprintStringItemState Property
Gets or sets current state of the IStringItem.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ItemState State { get; set; }
Public Overridable Property State As ItemState
    Get
    Set
public:
virtual property ItemState State {
    ItemState get ();
    void set (ItemState value);
}
abstract State : ItemState with get, set
override State : ItemState with get, set

Property Value

Type: ItemState

Implements

IStringItemState
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem.String Property

LowFootprintStringItemString Property
Gets or sets string content of the IStringItem.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string String { get; set; }
Public Overridable Property String As String
    Get
    Set
public:
virtual property String^ String {
    String^ get ();
    void set (String^ value);
}
abstract String : string with get, set
override String : string with get, set

Property Value

Type: String

Implements

IStringItemString
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


LowFootprintStringItem.TextData Property

LowFootprintStringItemTextData Property
Gets or sets information of the IStringItem.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual StringItemInfo[] TextData { get; set; }
Public Overridable Property TextData As StringItemInfo()
    Get
    Set
public:
virtual property array<StringItemInfo>^ TextData {
    array<StringItemInfo>^ get ();
    void set (array<StringItemInfo>^ value);
}
abstract TextData : StringItemInfo[] with get, set
override TextData : StringItemInfo[] with get, set

Property Value

Type: StringItemInfo

Implements

IStringItemTextData
See Also

Reference

LowFootprintStringItem Class
Alternet.Editor.TextSource Namespace


NavigateOptions Enumeration

NavigateOptions Enumeration
Defines specific options for navigation through the editor's content. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum NavigateOptions
<FlagsAttribute>
Public Enumeration NavigateOptions
[FlagsAttribute]
public enum class NavigateOptions
[<FlagsAttribute>]
type NavigateOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
BeyondEol | 1 | Specifies that user can navigate beyond end of line.
BeyondEof | 2 | Specifies that user can navigate beyond end of file.
UpAtLineBegin | 4 | Specifies that the current position should move to the previous line when user click Left key and caret locates at the line begin.
DownAtLineEnd | 8 | Specifies that the current position should move to the next line when user click Right key at the end of the line.
MoveOnRightButton | 16 | Specifies that current position should move to the mouse pointer when user clicks right mouse button.
KeepCaret | 32 | Specifies that caret should not move when modifying lines programmatically.
See Also

Reference

Alternet.Editor.TextSource Namespace


NotifyState Enumeration

NotifyState Enumeration
Represents the last changes to the text stored in the text source. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum NotifyState
<FlagsAttribute>
Public Enumeration NotifyState
[FlagsAttribute]
public enum class NotifyState
[<FlagsAttribute>]
type NotifyState
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
PositionChanged | 1 | Current position in the text was changed.
CountChanged | 2 | Amount of lines in the text was changed.
OverWriteChanged | 4 | Overwrite mode was changed.
ModifiedChanged | 8 | Modified state was changed.
SyntaxChanged | 16 | Syntax scheme or Lexer was changed.
ReadOnlyChanged | 32 | ReadOnly state was changed.
BlockChanged | 64 | Block of text was changed and needs invalidating.
BookMarkChanged | 128 | Bookmark was set or removed.
IncrementalSearchChanged | 256 | Incremental search state was changed.
SearcRectChanged | 512 | Rectangle that holds last found text was changed.
Undo | 1024 | Undo operation was performed.
Edit | 2048 | Text was edited.
Modified | 4096 | Modified state was changed.
Outline | 8192 | Outline section was collapsed or expanded.
WordWrap | 16384 | Lines were wrapped.
GotoBookMark | 32768 | Position of the text was changed due to moving to the bookmark.
SelectBlock | 65536 | Block of text was selected or unselected.
FirstSearchChanged | 131072 | SyntaxEdit.FirstSearch property was changed.
CenterLine | 262144 | SyntaxEdit should center current line if it's not in view.
TextParsed | 524288 | Text was completely parsed.
SmartFormat | 1048576 | Selection was formatted.
StringsChanged | 2097152 | Strings was changed programmatically.
PageOptionsChanged | 4194304 | Page options was changed.
ScrollingOptionsChanged | 8388608 | Scrolling options was changed.
ScrollingOriginChanged | 16777216 | Window was scrolled.
SelectionOptionsChanged | 33554432 | Selection options was changed.
SelectionChanged | 67108864 | Selection options was changed.
SelectedTextChanged | 134217728 | Selected text was changed.
TextLineChanged | 268435456 | Text was modified and changed.
See Also

Reference

Alternet.Editor.TextSource Namespace


SearchOptions Enumeration

SearchOptions Enumeration
Defines options for search and replace operations. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum SearchOptions
<FlagsAttribute>
Public Enumeration SearchOptions
[FlagsAttribute]
public enum class SearchOptions
[<FlagsAttribute>]
type SearchOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
CaseSensitive | 1 | Specifies that search should be case sensitive.
WholeWordsOnly | 2 | Searches only for whole words, rather than matching the text as it occurs within words.
RegularExpressions | 4 | Specifies that text to find represents notations for patterns of text rather than the literal character.
BackwardSearch | 8 | Specifies that search should be executed towards the beginning of text.
SelectionOnly | 16 | Searches only within the selected text in the currently active document.
EntireScope | 32 | Specifies that search should start from the beginning of text.
SearchHiddenText | 64 | Specifies that the search includes invisible text, such as an collapsed section.
FindTextAtCursor | 128 | Specifies that text at the current position of the active document should be used as text to find.
PromptOnReplace | 256 | Specifies that confirm dialog should appear before replacing found text.
FindSelectedText | 512 | Specifies that selected text of the active document should be used as text to find.
CycledSearch | 1024 | Search until current position is reached.
SilentSearch | 2048 | Search until current position is reached.
AllDocuments | 4096 | Search is performed in all documents.
CurrentProject | 8192 | Search is performed in current project.
EntireSolution | 16384 | Search is performed in entire solution.
See Also

Reference

Alternet.Editor.TextSource Namespace


StringItem Class

StringItem Class
Represents string-like object with extended properties.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TextSourceStringItem

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StringItem : IStringItem
Public Class StringItem
    Implements IStringItem
public ref class StringItem : IStringItem
type StringItem =
    class
        interface IStringItem
    end

The StringItem type exposes the following members.

Constructors
 | Name | Description
Public method | StringItem | Initializes a new instance of the StringItem class with specified string.
Top
Methods
 | Name | Description
Public method | ClearTextStyle(Int32, Int32, TextStyle) | Removes style information from specified part of string.
 | ClearTextStyle(StringItemInfo, Int32, Int32, TextStyle) | Removes style information from specified part of string.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetTextStyle(Int32, Int32, TextStyle) | Sets style information to specified part of string.
 | SetTextStyle(StringItemInfo, Int32, Int32, TextStyle) | Sets text style to text fragment.
 | Split | Converts specified text to string array.
Public method | TextStyleAt | Retrieves style information from IStringItem.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | LexState | Gets or sets index of lexical state at item end.
Public property | PrevLexState | Gets or sets index of lexical state at item start.
Public property | State | Gets or sets current state of the IStringItem.
Public property | String | Gets or sets string content of the IStringItem.
Public property | TextData | Gets or sets information of the IStringItem.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


StringItem Constructor

StringItem Constructor
Initializes a new instance of the StringItem class with specified string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringItem(
    string s
)
Public Sub New (
    s As String
)
public:
StringItem(
    String^ s
)
new :
        s : string -> StringItem

Parameters

s
Type: SystemString
Specifies string content of this new instance.
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem Methods

StringItem Methods

The StringItem type exposes the following members.

Methods
 | Name | Description
Public method | ClearTextStyle(Int32, Int32, TextStyle) | Removes style information from specified part of string.
 | ClearTextStyle(StringItemInfo, Int32, Int32, TextStyle) | Removes style information from specified part of string.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetTextStyle(Int32, Int32, TextStyle) | Sets style information to specified part of string.
 | SetTextStyle(StringItemInfo, Int32, Int32, TextStyle) | Sets text style to text fragment.
 | Split | Converts specified text to string array.
Public method | TextStyleAt | Retrieves style information from IStringItem.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem.ClearTextStyle Method

StringItemClearTextStyle Method
Overload List
 | Name | Description
Public method | ClearTextStyle(Int32, Int32, TextStyle) | Removes style information from specified part of string.
 | ClearTextStyle(StringItemInfo, Int32, Int32, TextStyle) | Removes style information from specified part of string.
Top
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem.ClearTextStyle Method (Int32, Int32, TextStyle)

StringItemClearTextStyle Method (Int32, Int32, TextStyle)
Removes style information from specified part of string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearTextStyle(
    int start,
    int len,
    TextStyle style
)
Public Overridable Sub ClearTextStyle (
    start As Integer,
    len As Integer,
    style As TextStyle
)
public:
virtual void ClearTextStyle(
    int start,
    int len,
    TextStyle style
)
abstract ClearTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit
override ClearTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit

Parameters

start
Type: SystemInt32
Specifies the first character in string to remove.
len
Type: SystemInt32
Specifies number of characters in string to remove.
style
Type: Alternet.SyntaxTextStyle
Specifies TextStyle to remove.

Implements

IStringItemClearTextStyle(Int32, Int32, TextStyle)
See Also

Reference

StringItem Class
ClearTextStyle Overload
Alternet.Editor.TextSource Namespace


StringItem.ClearTextStyle Method (StringItemInfo[], Int32, Int32, TextStyle)

StringItemClearTextStyle Method (StringItemInfo, Int32, Int32, TextStyle)
Removes style information from specified part of string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ClearTextStyle(
    ref StringItemInfo[] textData,
    int start,
    int len,
    TextStyle style
)
Public Shared Sub ClearTextStyle (
    ByRef textData As StringItemInfo(),
    start As Integer,
    len As Integer,
    style As TextStyle
)
public:
static void ClearTextStyle(
    array<StringItemInfo>^% textData,
    int start,
    int len,
    TextStyle style
)
static member ClearTextStyle :
        textData : StringItemInfo[] byref *
        start : int *
        len : int *
        style : TextStyle -> unit

Parameters

textData
Type: Alternet.SyntaxStringItemInfo
Retrieves style information.
start
Type: SystemInt32
Specifies the first character in string to remove.
len
Type: SystemInt32
Specifies number of characters in string to remove.
style
Type: Alternet.SyntaxTextStyle
Specifies TextStyle to remove.
See Also

Reference

StringItem Class
ClearTextStyle Overload
Alternet.Editor.TextSource Namespace


StringItem.SetTextStyle Method

StringItemSetTextStyle Method
Overload List
 | Name | Description
Public method | SetTextStyle(Int32, Int32, TextStyle) | Sets style information to specified part of string.
 | SetTextStyle(StringItemInfo, Int32, Int32, TextStyle) | Sets text style to text fragment.
Top
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem.SetTextStyle Method (Int32, Int32, TextStyle)

StringItemSetTextStyle Method (Int32, Int32, TextStyle)
Sets style information to specified part of string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetTextStyle(
    int start,
    int len,
    TextStyle style
)
Public Overridable Sub SetTextStyle (
    start As Integer,
    len As Integer,
    style As TextStyle
)
public:
virtual void SetTextStyle(
    int start,
    int len,
    TextStyle style
)
abstract SetTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit
override SetTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit

Parameters

start
Type: SystemInt32
Specifies the first character in string to set.
len
Type: SystemInt32
Specifies number of characters in string to set.
style
Type: Alternet.SyntaxTextStyle
Specifies TextStyle to set.

Implements

IStringItemSetTextStyle(Int32, Int32, TextStyle)
See Also

Reference

StringItem Class
SetTextStyle Overload
Alternet.Editor.TextSource Namespace


StringItem.SetTextStyle Method (StringItemInfo[], Int32, Int32, TextStyle)

StringItemSetTextStyle Method (StringItemInfo, Int32, Int32, TextStyle)
Sets text style to text fragment.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetTextStyle(
    ref StringItemInfo[] textData,
    int start,
    int len,
    TextStyle style
)
Public Shared Sub SetTextStyle (
    ByRef textData As StringItemInfo(),
    start As Integer,
    len As Integer,
    style As TextStyle
)
public:
static void SetTextStyle(
    array<StringItemInfo>^% textData,
    int start,
    int len,
    TextStyle style
)
static member SetTextStyle :
        textData : StringItemInfo[] byref *
        start : int *
        len : int *
        style : TextStyle -> unit

Parameters

textData
Type: Alternet.SyntaxStringItemInfo
Retrieves style information.
start
Type: SystemInt32
Specifies the first character in the string.
len
Type: SystemInt32
Specifies number of characters in the string.
style
Type: Alternet.SyntaxTextStyle
Specifies style to set.
See Also

Reference

StringItem Class
SetTextStyle Overload
Alternet.Editor.TextSource Namespace


StringItem.Split Method

StringItemSplit Method
Converts specified text to string array.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] Split(
    string text
)
Public Shared Function Split (
    text As String
) As String()
public:
static array<String^>^ Split(
    String^ text
)
static member Split :
        text : string -> string[]

Parameters

text
Type: SystemString
String to convert.

Return Value

Type: String
String array representation of given text.
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem.TextStyleAt Method

StringItemTextStyleAt Method
Retrieves style information from IStringItem.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual TextStyle TextStyleAt(
    int pos
)
Public Overridable Function TextStyleAt (
    pos As Integer
) As TextStyle
public:
virtual TextStyle TextStyleAt(
    int pos
)
abstract TextStyleAt :
        pos : int -> TextStyle
override TextStyleAt :
        pos : int -> TextStyle

Parameters

pos
Type: SystemInt32
Specifies position in IStringItem to obtain style information.

Return Value

Type: TextStyle
TextStyle at specified position.

Implements

IStringItemTextStyleAt(Int32)
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem Properties

StringItem Properties

The StringItem type exposes the following members.

Properties
 | Name | Description
Public property | LexState | Gets or sets index of lexical state at item end.
Public property | PrevLexState | Gets or sets index of lexical state at item start.
Public property | State | Gets or sets current state of the IStringItem.
Public property | String | Gets or sets string content of the IStringItem.
Public property | TextData | Gets or sets information of the IStringItem.
Top
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem.LexState Property

StringItemLexState Property
Gets or sets index of lexical state at item end.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LexState { get; set; }
Public Overridable Property LexState As Integer
    Get
    Set
public:
virtual property int LexState {
    int get ();
    void set (int value);
}
abstract LexState : int with get, set
override LexState : int with get, set

Property Value

Type: Int32

Implements

IStringItemLexState
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem.PrevLexState Property

StringItemPrevLexState Property
Gets or sets index of lexical state at item start.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PrevLexState { get; set; }
Public Overridable Property PrevLexState As Integer
    Get
    Set
public:
virtual property int PrevLexState {
    int get ();
    void set (int value);
}
abstract PrevLexState : int with get, set
override PrevLexState : int with get, set

Property Value

Type: Int32

Implements

IStringItemPrevLexState
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem.State Property

StringItemState Property
Gets or sets current state of the IStringItem.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ItemState State { get; set; }
Public Overridable Property State As ItemState
    Get
    Set
public:
virtual property ItemState State {
    ItemState get ();
    void set (ItemState value);
}
abstract State : ItemState with get, set
override State : ItemState with get, set

Property Value

Type: ItemState

Implements

IStringItemState
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem.String Property

StringItemString Property
Gets or sets string content of the IStringItem.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string String { get; set; }
Public Overridable Property String As String
    Get
    Set
public:
virtual property String^ String {
    String^ get ();
    void set (String^ value);
}
abstract String : string with get, set
override String : string with get, set

Property Value

Type: String

Implements

IStringItemString
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


StringItem.TextData Property

StringItemTextData Property
Gets or sets information of the IStringItem.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual StringItemInfo[] TextData { get; set; }
Public Overridable Property TextData As StringItemInfo()
    Get
    Set
public:
virtual property array<StringItemInfo>^ TextData {
    array<StringItemInfo>^ get ();
    void set (array<StringItemInfo>^ value);
}
abstract TextData : StringItemInfo[] with get, set
override TextData : StringItemInfo[] with get, set

Property Value

Type: StringItemInfo

Implements

IStringItemTextData
See Also

Reference

StringItem Class
Alternet.Editor.TextSource Namespace


TextSource Class

TextSource Class
Represents class that provides interface between edited text and Edit control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Editor.TextSourceTextSource
Alternet.Editor.TextSourceInnerTextSource
Alternet.FormDesigner.IntegrationFormDesignerTextSource

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextSource : Component, ITextSource,
    IEdit, INavigate, IUndo, ITextNotify, INotify,
    IUpdate, INotifier, ITextImport, IImport, ITextExport,
    IExport, IHyperText, ISpelling, IBraceMatching, ITextParsing,
    ITextSnippets, ITextErrors, ITextThread
Public Class TextSource
    Inherits Component
    Implements ITextSource, IEdit, INavigate, IUndo,
    ITextNotify, INotify, IUpdate, INotifier, ITextImport,
    IImport, ITextExport, IExport, IHyperText, ISpelling,
    IBraceMatching, ITextParsing, ITextSnippets, ITextErrors, ITextThread
public ref class TextSource : public Component,
    ITextSource, IEdit, INavigate, IUndo, ITextNotify,
    INotify, IUpdate, INotifier, ITextImport, IImport,
    ITextExport, IExport, IHyperText, ISpelling, IBraceMatching,
    ITextParsing, ITextSnippets, ITextErrors, ITextThread
type TextSource =
    class
        inherit Component
        interface ITextSource
        interface IEdit
        interface INavigate
        interface IUndo
        interface ITextNotify
        interface INotify
        interface IUpdate
        interface INotifier
        interface ITextImport
        interface IImport
        interface ITextExport
        interface IExport
        interface IHyperText
        interface ISpelling
        interface IBraceMatching
        interface ITextParsing
        interface ITextSnippets
        interface ITextErrors
        interface ITextThread
    end

The TextSource type exposes the following members.

Constructors
 | Name | Description
Public method | TextSource | Initializes a new instance of the TextSource class with default settings.
Public method | TextSource(IContainer) | Initializes a new instance of the TextSource class with specified container.
Top
Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | Converts given absolute position to position as Point value.
Public method | AddNotifier | Adds new handler to respond for notification.
Public method | AddUndo | Stores undo operation in the appropriate list.
Public method | BeginUndoUpdate | Allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method.
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | BeginUpdate(UpdateReason) | Prevents object state updating until calling EndUpdate method.
Public method | BeginUpdateSnippet | Prevents the Edit control from updating snippets until the EndUpdateSnippet method is called.
Public method | BreakLine | Breaks current line into two lines.
Public method | CancelParsing | Stops formatting timer.
Public method | CanRedo | Indicating whether the redo operation can be performed.
Public method | CanUndo | Indicating whether the undo operation can be performed.
Public method | Clear | Clears content of the TextSource
Public method | ClearRedo | Clears list of redo operations.
Public method | ClearUndo | Clears list of undo operations.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateStringItem | Create a new IStringItem object containing specified text.
Public method | DeleteBlock(Rectangle, Boolean) | Deletes a specified block of characters.
Public method | DeleteBlock(Int32, Boolean) | Deletes a specified block of characters.
Public method | DeleteLeft | Deletes a specified number of characters to the left of the active point.
Public method | DeleteRight | Deletes a specified number of characters to the right of the active point.
Public method | DisablePositionUpdate | Prevents notification of changing of caret position until calling EnablePositionUpdate method.
Public method | DisableUndo | Disables recording of undo/redo operations.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnablePositionUpdate | Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
Public method | EnableUndo | Re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUndoUpdate | Ends undo block, that was started by BeginUndoUpdate method.
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | EndUpdateSnippet | Resumes updating snippets after updating is suspended by the BeginUpdateSnippet method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindClosingBrace(Point) | Locates closing brace.
Public method | FindClosingBrace(Int32, Int32) | Locates closing brace.
Public method | FindOpenBrace(Point) | Locates open brace.
Public method | FindOpenBrace(Int32, Int32) | Locates open brace.
Public method | FormatText | Tries to format and outline TextSource text using attached Lexer.
Public method | FormatText(Boolean, Boolean) | Tries to format and outline TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing
Public method | GetCharIndexFromPosition | Converts given Point value to the index of character.
Public method | GetCodeFixes | Gets code fixes for a given syntax error.
Public method | GetCodeSnippetRangeAt | Locates code snippet at specified position.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString | Gets indentation string at current position.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPositionFromCharIndex | Converts given character index to position as Point value.
Public method | GetStructureGuideLines | Gets list of guide lines.
Public method | GetSyntaxErrorAt | Gets syntax error at specified position.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightBraces | Highlights braces containing caret position.
Public method | HighlightCodeFixes | Highlights code fixes if needed.
Public method | HighlightCodeRefactors | Highlights code fixes if needed.
Public method | HighlightCodeSnippets | Highlights code snippets using appropriate style.
Public method | HighlightSyntaxErrors | Highlights syntax errors.
Public method | IndentLine | Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
Public method | IndentLine(String, Boolean) | Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Insert | Inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | Inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | Inserts the given string array at the specified location.
Public method | InsertBlock(ITextStrings, Boolean) | Inserts the given string collection at the specified location.
Public method | InsertBlock(String, Boolean, Boolean) | Inserts the given string array at the specified location.
Public method | InsertFromFile | Inserts the file text content at the specified location.
Public method | InvalidateSyntaxErrors | Invalidates highlighting of syntax errors.
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line.
Public method | IsHyperText | Indicates whether given text represents hypertext.
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct.
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct.
Public method | LineIsHidden | Determines whether the given line is readonly.
Public method | LineIsModified(Int32) | Indicates whether specified line already modified.
Public method | LineIsModified(Int32, Boolean) | Indicates whether specified line already modified.
Public method | LineIsReadonly | Determines whether the given line is readonly.
Public method | LinesChanged(Int32, Int32) | Specifies range of lines that was changed.
Public method | LinesChanged(Int32, Int32, Boolean) | Specifies range of lines that was changed.
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Public method | MoveTo(Point) | Moves the current position to the given position.
Public method | MoveTo(Int32, Int32) | Moves the current position to the given position.
Public method | MoveToChar | Moves the current position to the specified character in the current line.
Public method | MoveToLine(Int32) | Moves the current position to the specified line.
Public method | MoveToLine(Int32, Int32) | Moves the current position to the specified line.
Public method | Navigate | Moves current position by the given offset value.
Public method | NeedAutoComplete | Indicates whether ITextSource should try to autocomplete statements.
Public method | NeedCacheIndent | Indicates whether ITextSource can reuse previous indentation.
Public method | NeedCodeCompletion | Indicates whether ITextSource can provide code completion operation for its content.
Public method | NeedCodeCompletionTabs | Indicates code completion content can be filtered based on its priority.
Public method | NeedCodeFixes | Indicates whether ITextSource can provide code fixes operation for its content.
Public method | NeedCodeRefactors | Indicates whether ITextSource can provide code fixes operation for its content.
Public method | NeedContentDividers | Indicates whether ITextSource can proceed syntax errors in its content.
Public method | NeedFormatText | Indicates whether ITextSource can format its content.
Public method | NeedFormatTextOnLineChange | Indicates whether ITextSource should format spaces and case when changing the current line.
Public method | NeedIndentText | Indicates whether ITextSource can indent its content.
Public method | NeedOutlineText | Indicates whether ITextSource can outline its content.
Public method | NeedParse | Indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted.
Public method | NeedQuickInfoTips | Indicates whether ITextSource can obtain short description for syntax tokens within its content.
Public method | NeedReparseText | Indicates whether ITextSource can perform syntax analysis of its content.
Public method | NeedReparseTextOnLineChange | Indicates whether ITextSource should replace text when changing the current line.
Public method | NeedStructureGuideLines | Indicates whether ITextSource can proceed syntax errors in its content.
Public method | NeedSyntaxErrors | Indicates whether ITextSource can proceed syntax errors in its content.
Public method | NeedWorkInThread | Indicates whether ITextSource can perform syntax analysis in thread.
Public method | NewLine | Inserts a line break at the current position.
Public method | NewLine(String, Boolean) | Inserts a line break at the current position with indentation.
Public method | NewLineAbove | Inserts a line break above the current position.
Public method | NewLineBelow | Inserts a line break below the current position.
Public method | Notification | Updates control's content according to parameters of notification.
Public method | Notify | Notifies all notifiers about changing source state.
Public method | ParseString | Perform lexical analysis of the specified string.
Public method | ParseStrings | Perform lexical analysis specified strings.
Public method | ParseToString | Perform lexical analysis of specified strings.
Public method | PositionIsReadonly | Determines whether the text at given position is readonly.
Public method | ProcessAutoComplete | Inserts end-of-block code fragment if needed.
Public method | Redo | Performs the last redo operation.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list.
Public method | ResetBracesOptions | Resets the BracesOptions to its default value.
Public method | ResetCheckSpelling | Resets the CheckSpelling to the default value.
Public method | ResetClosingBraces | Resets the ClosingBraces to its default value.
Public method | ResetHighlightHyperText | Resets HighlightHyperText to the default value.
Public method | ResetIndentOptions | Resets the IndentOptions to the default value.
Public method | ResetMaxLength | Resets the MaxLength to the default value.
Public method | ResetModified | Resets the Modified to the default value.
Public method | ResetNavigateOptions | Resets the NavigateOptions to the default value.
Public method | ResetOpenBraces | Resets the OpenBraces to its default value.
Public method | ResetOverWrite | Resets the OverWrite to the default value.
Public method | ResetReadOnly | Resets the ReadOnly to the default value.
Public method | ResetSingleLineMode | Resets the SingleLineMode to the default value.
Public method | ResetSpellDelimiters | Resets the SpellDelimiters to the default value.
Public method | ResetUndoLimit | Resets the UndoLimit to the default value.
Public method | ResetUndoOptions | Resets the UndoOptions to the default value.
Public method | RestorePosition | Restores position from stored position list by given index.
Public method | RestorePositionWithUndo | Restores position from stored position list by given index.
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specific exporter.
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves text content to the specific file with specific exporter and encoding.
Public method | SaveStream(Stream) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the specified stream.
Public method | SetLastParsed | Updates the last parsed line and resets first changed line to it's default value.
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineState | Sets item state for the given line.
Public method | SetNavigateOptions | Sets navigating options without validating position.
Public method | ShouldSerializeClosingBraces | Indicates whether the ClosingBraces property should be persisted.
Public method | ShouldSerializeIndentOptions | Indicates whether the IndentOptions property should be persisted.
Public method | ShouldSerializeLexer | Indicates whether the Lexer property should be persisted.
Public method | ShouldSerializeNavigateOptions | Indicates whether the NavigateOptions property should be persisted.
Public method | ShouldSerializeOpenBraces | Indicates whether the OpenBraces property should be persisted.
Public method | ShouldSerializeText | Indicates whether the Text property should be persisted.
Public method | ShouldSerializeUndoOptions | Indicates whether the UndoOptions property should be persisted.
Public method | StartThread | Executes action in thread.
Public method | StopThread | Aborts executing action in thread.
Public method | StorePosition(Point) | Stores given position to stored position list.
Public method | StorePosition(Point, Boolean) | Stores given position to stored position list.
Public method | StorePositionWithUndo | Stores given position to stored position list preserving it for undo.
Public method | SupportsAsyncParsing |
Public method | TempHighlightBraces | Temporary highlights all text within the area specified by rects.
Public method | TempHighlightMatchingBlocks | Highlights block match.
Public method | TempHighlightReferences | Highlights found references.
Public method | TempHighlightSearchResults | Highlights search results.
Public method | TempUnhighlightBraces | Cancels text highlighting turned on using TempHighlightBraces
Public method | TempUnhighlightBraces(Boolean) | Unhighlights temporary braces areas.
Public method | TempUnhighlightReferences | Unhighlights references highlighted with previous call of TempHighlightReferences.
Public method | TempUnhighlightSearchResults | Unhighlights search results highlighted with previous call of TempHighlightSearchResults.
Public method | TextPointToAbsolutePosition | Converts given Point value to the absolute position.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnBreakLine | Concatenates lines at current position.
Public method | Undo(Boolean) | Performs the last undo operation.
Public method | Undo(IUndoData, Boolean) | Performs the single undo operation.
Public method | UnhighlightBraces | Unhighlights braces containing caret position.
Public method | UnhighlightBraces(Boolean) | Unhighlights braces.
Public method | UnhighlightCodeSnippets | Removes highlighting from code snippets and clears snippet collection.
Public method | UnhighlightSyntaxErrors | Removes syntax errors highlighting.
Public method | Update | Updates an object state.
Public method | ValidatePosition | Validates given position within control's text content.
Top
Properties
 | Name | Description
Public property | ActiveEdit | Gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source.
Public property | BookMarks | Represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source.
Public property | BracesOptions | Gets or sets options specifying appearance and behaviour of matching braces within Edit control.
Public property | CheckSpelling | Gets or sets a value indicating whether the document can check spelling for its content.
Public property | ClosingBraces | Gets or sets an array of characters each one representing a closing brace.
Public property | CodeSnippets | Gets or sets ICodeSnippetRangeList for Edit control.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentSnippet | Gets or sets current ICodeSnippetRange object.
Public property | Edits | Represents a collection of ISyntaxEdit controls linked to the text source.
Public property | FileName | Gets or sets name of file that holds text source content.
Public property | FirstChanged | Represents index of the first changed line.
Public property | GlobalSearch | Specifies whether search should be global.
Public property | HasSpelling | Gets boolean value indicating that editor has external spell checker assigned.
Public property | HighlightHyperText | Gets or sets a value indicating whether hypertext in the text should be highlighted.
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight found block matches.
Public property | HighlightReferences | Specifies that edit control should highlight found references.
Public property | IndentOptions | Gets or sets Alternet.Editor.TextSource.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line.
Public property | LastChanged | Represents index of the last changed line.
Public property | Lexer | Gets or sets object that can perform lexical analysis of the text source content.
Public property | Lines | Represents the object that implements ITextStrings interface containing collection of strings determining text source content.
Public property | LineStyles | Represents an object that implements ILineStyles interface holding collection of line styles for this document.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | MatchingBlocks | Gets or sets IRangeList of matching begin/end blocks for Edit control.
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control.
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified.
Public property | ModifiedLineRegions | Gets modified lines information, grouped in regions.
Public property | ModifiedLines | Gets modified lines information.
Public property | NavigateOptions | Gets or sets navigating options.
Public property | OpenBraces | Gets or sets an array of characters each one representing an open brace.
Public property | OptimizedForMemory | Specifies whether internal text representation should optimized memory usage.
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text.
Public property | ParserLine | Gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text.
Public property | Position | Gets or sets current position within the control's text content.
Public property | PrevPosition | Gets previous position within the control's text content.
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only.
Public property | RedoList | Provides an indexed access to redo data.
Public property | References | Gets or sets IRangeList of found references for Edit control.
Public property | SearchResults | Gets or sets IRangeList of search results for Edit control.
Public property | SelectBlockRect | Represents a rectangular block of selected text.
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpellDelimiters | Gets or sets an array of chars used to separate words in a text.
Public property | SpellDelimiterString | Gets or sets Delimiters as a single string.
Public property | SpellTable | Represents a hash table containing delimiters.
Public property | State | Gets or sets last changes to the text stored in the text source.
Public property | Strings | Gets or sets text source content in the form of string array.
Public property | StructureGuideLines | Represents a syntax errors collection.
Public property | SyntaxErrors | Represents a syntax errors collection.
Public property | Text | Gets or sets text source content as a single string with the individual strings delimited by carriage returns.
Public property | ThreadAction | Returns method executed in thread when parsing.
Public property | UndoLimit | Gets or sets a value that limits number of undo operations.
Public property | UndoList | Provides an indexed access to undo data.
Public property | UndoOptions | Gets or sets options for undo and redo operations.
Public property | UndoUpdateCount | Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UrlTable | Represents hash table containing hyper-text characters.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | HyperText | Occurs when a control needs checking whether some string represents hypertext.
Public event | UndoEvent | Occurs when undo/redo operation performed.
Public event | WordSpell | Occurs when spelling of some word within the text needs checking.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


TextSource Constructor

TextSource Constructor
Overload List
 | Name | Description
Public method | TextSource | Initializes a new instance of the TextSource class with default settings.
Public method | TextSource(IContainer) | Initializes a new instance of the TextSource class with specified container.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource Constructor

TextSource Constructor
Initializes a new instance of the TextSource class with default settings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextSource()
Public Sub New
public:
TextSource()
new : unit -> TextSource
See Also

Reference

TextSource Class
TextSource Overload
Alternet.Editor.TextSource Namespace


TextSource Constructor (IContainer)

TextSource Constructor (IContainer)
Initializes a new instance of the TextSource class with specified container.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextSource(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
TextSource(
    IContainer^ container
)
new :
        container : IContainer -> TextSource

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

TextSource Class
TextSource Overload
Alternet.Editor.TextSource Namespace


TextSource Methods

TextSource Methods

The TextSource type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | Converts given absolute position to position as Point value.
Public method | AddNotifier | Adds new handler to respond for notification.
Public method | AddUndo | Stores undo operation in the appropriate list.
Public method | BeginUndoUpdate | Allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method.
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | BeginUpdate(UpdateReason) | Prevents object state updating until calling EndUpdate method.
Public method | BeginUpdateSnippet | Prevents the Edit control from updating snippets until the EndUpdateSnippet method is called.
Public method | BreakLine | Breaks current line into two lines.
Public method | CancelParsing | Stops formatting timer.
Public method | CanRedo | Indicating whether the redo operation can be performed.
Public method | CanUndo | Indicating whether the undo operation can be performed.
Public method | Clear | Clears content of the TextSource
Public method | ClearRedo | Clears list of redo operations.
Public method | ClearUndo | Clears list of undo operations.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateStringItem | Create a new IStringItem object containing specified text.
Public method | DeleteBlock(Rectangle, Boolean) | Deletes a specified block of characters.
Public method | DeleteBlock(Int32, Boolean) | Deletes a specified block of characters.
Public method | DeleteLeft | Deletes a specified number of characters to the left of the active point.
Public method | DeleteRight | Deletes a specified number of characters to the right of the active point.
Public method | DisablePositionUpdate | Prevents notification of changing of caret position until calling EnablePositionUpdate method.
Public method | DisableUndo | Disables recording of undo/redo operations.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnablePositionUpdate | Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
Public method | EnableUndo | Re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUndoUpdate | Ends undo block, that was started by BeginUndoUpdate method.
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | EndUpdateSnippet | Resumes updating snippets after updating is suspended by the BeginUpdateSnippet method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindClosingBrace(Point) | Locates closing brace.
Public method | FindClosingBrace(Int32, Int32) | Locates closing brace.
Public method | FindOpenBrace(Point) | Locates open brace.
Public method | FindOpenBrace(Int32, Int32) | Locates open brace.
Public method | FormatText | Tries to format and outline TextSource text using attached Lexer.
Public method | FormatText(Boolean, Boolean) | Tries to format and outline TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing
Public method | GetCharIndexFromPosition | Converts given Point value to the index of character.
Public method | GetCodeFixes | Gets code fixes for a given syntax error.
Public method | GetCodeSnippetRangeAt | Locates code snippet at specified position.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString | Gets indentation string at current position.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPositionFromCharIndex | Converts given character index to position as Point value.
Public method | GetStructureGuideLines | Gets list of guide lines.
Public method | GetSyntaxErrorAt | Gets syntax error at specified position.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightBraces | Highlights braces containing caret position.
Public method | HighlightCodeFixes | Highlights code fixes if needed.
Public method | HighlightCodeRefactors | Highlights code fixes if needed.
Public method | HighlightCodeSnippets | Highlights code snippets using appropriate style.
Public method | HighlightSyntaxErrors | Highlights syntax errors.
Public method | IndentLine | Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
Public method | IndentLine(String, Boolean) | Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Insert | Inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | Inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | Inserts the given string array at the specified location.
Public method | InsertBlock(ITextStrings, Boolean) | Inserts the given string collection at the specified location.
Public method | InsertBlock(String, Boolean, Boolean) | Inserts the given string array at the specified location.
Public method | InsertFromFile | Inserts the file text content at the specified location.
Public method | InvalidateSyntaxErrors | Invalidates highlighting of syntax errors.
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line.
Public method | IsHyperText | Indicates whether given text represents hypertext.
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct.
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct.
Public method | LineIsHidden | Determines whether the given line is readonly.
Public method | LineIsModified(Int32) | Indicates whether specified line already modified.
Public method | LineIsModified(Int32, Boolean) | Indicates whether specified line already modified.
Public method | LineIsReadonly | Determines whether the given line is readonly.
Public method | LinesChanged(Int32, Int32) | Specifies range of lines that was changed.
Public method | LinesChanged(Int32, Int32, Boolean) | Specifies range of lines that was changed.
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Public method | MoveTo(Point) | Moves the current position to the given position.
Public method | MoveTo(Int32, Int32) | Moves the current position to the given position.
Public method | MoveToChar | Moves the current position to the specified character in the current line.
Public method | MoveToLine(Int32) | Moves the current position to the specified line.
Public method | MoveToLine(Int32, Int32) | Moves the current position to the specified line.
Public method | Navigate | Moves current position by the given offset value.
Public method | NeedAutoComplete | Indicates whether ITextSource should try to autocomplete statements.
Public method | NeedCacheIndent | Indicates whether ITextSource can reuse previous indentation.
Public method | NeedCodeCompletion | Indicates whether ITextSource can provide code completion operation for its content.
Public method | NeedCodeCompletionTabs | Indicates code completion content can be filtered based on its priority.
Public method | NeedCodeFixes | Indicates whether ITextSource can provide code fixes operation for its content.
Public method | NeedCodeRefactors | Indicates whether ITextSource can provide code fixes operation for its content.
Public method | NeedContentDividers | Indicates whether ITextSource can proceed syntax errors in its content.
Public method | NeedFormatText | Indicates whether ITextSource can format its content.
Public method | NeedFormatTextOnLineChange | Indicates whether ITextSource should format spaces and case when changing the current line.
Public method | NeedIndentText | Indicates whether ITextSource can indent its content.
Public method | NeedOutlineText | Indicates whether ITextSource can outline its content.
Public method | NeedParse | Indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted.
Public method | NeedQuickInfoTips | Indicates whether ITextSource can obtain short description for syntax tokens within its content.
Public method | NeedReparseText | Indicates whether ITextSource can perform syntax analysis of its content.
Public method | NeedReparseTextOnLineChange | Indicates whether ITextSource should replace text when changing the current line.
Public method | NeedStructureGuideLines | Indicates whether ITextSource can proceed syntax errors in its content.
Public method | NeedSyntaxErrors | Indicates whether ITextSource can proceed syntax errors in its content.
Public method | NeedWorkInThread | Indicates whether ITextSource can perform syntax analysis in thread.
Public method | NewLine | Inserts a line break at the current position.
Public method | NewLine(String, Boolean) | Inserts a line break at the current position with indentation.
Public method | NewLineAbove | Inserts a line break above the current position.
Public method | NewLineBelow | Inserts a line break below the current position.
Public method | Notification | Updates control's content according to parameters of notification.
Public method | Notify | Notifies all notifiers about changing source state.
Public method | ParseString | Perform lexical analysis of the specified string.
Public method | ParseStrings | Perform lexical analysis specified strings.
Public method | ParseToString | Perform lexical analysis of specified strings.
Public method | PositionIsReadonly | Determines whether the text at given position is readonly.
Public method | ProcessAutoComplete | Inserts end-of-block code fragment if needed.
Public method | Redo | Performs the last redo operation.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list.
Public method | ResetBracesOptions | Resets the BracesOptions to its default value.
Public method | ResetCheckSpelling | Resets the CheckSpelling to the default value.
Public method | ResetClosingBraces | Resets the ClosingBraces to its default value.
Public method | ResetHighlightHyperText | Resets HighlightHyperText to the default value.
Public method | ResetIndentOptions | Resets the IndentOptions to the default value.
Public method | ResetMaxLength | Resets the MaxLength to the default value.
Public method | ResetModified | Resets the Modified to the default value.
Public method | ResetNavigateOptions | Resets the NavigateOptions to the default value.
Public method | ResetOpenBraces | Resets the OpenBraces to its default value.
Public method | ResetOverWrite | Resets the OverWrite to the default value.
Public method | ResetReadOnly | Resets the ReadOnly to the default value.
Public method | ResetSingleLineMode | Resets the SingleLineMode to the default value.
Public method | ResetSpellDelimiters | Resets the SpellDelimiters to the default value.
Public method | ResetUndoLimit | Resets the UndoLimit to the default value.
Public method | ResetUndoOptions | Resets the UndoOptions to the default value.
Public method | RestorePosition | Restores position from stored position list by given index.
Public method | RestorePositionWithUndo | Restores position from stored position list by given index.
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specific exporter.
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves text content to the specific file with specific exporter and encoding.
Public method | SaveStream(Stream) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the specified stream.
Public method | SetLastParsed | Updates the last parsed line and resets first changed line to it's default value.
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineState | Sets item state for the given line.
Public method | SetNavigateOptions | Sets navigating options without validating position.
Public method | ShouldSerializeClosingBraces | Indicates whether the ClosingBraces property should be persisted.
Public method | ShouldSerializeIndentOptions | Indicates whether the IndentOptions property should be persisted.
Public method | ShouldSerializeLexer | Indicates whether the Lexer property should be persisted.
Public method | ShouldSerializeNavigateOptions | Indicates whether the NavigateOptions property should be persisted.
Public method | ShouldSerializeOpenBraces | Indicates whether the OpenBraces property should be persisted.
Public method | ShouldSerializeText | Indicates whether the Text property should be persisted.
Public method | ShouldSerializeUndoOptions | Indicates whether the UndoOptions property should be persisted.
Public method | StartThread | Executes action in thread.
Public method | StopThread | Aborts executing action in thread.
Public method | StorePosition(Point) | Stores given position to stored position list.
Public method | StorePosition(Point, Boolean) | Stores given position to stored position list.
Public method | StorePositionWithUndo | Stores given position to stored position list preserving it for undo.
Public method | SupportsAsyncParsing |
Public method | TempHighlightBraces | Temporary highlights all text within the area specified by rects.
Public method | TempHighlightMatchingBlocks | Highlights block match.
Public method | TempHighlightReferences | Highlights found references.
Public method | TempHighlightSearchResults | Highlights search results.
Public method | TempUnhighlightBraces | Cancels text highlighting turned on using TempHighlightBraces
Public method | TempUnhighlightBraces(Boolean) | Unhighlights temporary braces areas.
Public method | TempUnhighlightReferences | Unhighlights references highlighted with previous call of TempHighlightReferences.
Public method | TempUnhighlightSearchResults | Unhighlights search results highlighted with previous call of TempHighlightSearchResults.
Public method | TextPointToAbsolutePosition | Converts given Point value to the absolute position.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnBreakLine | Concatenates lines at current position.
Public method | Undo(Boolean) | Performs the last undo operation.
Public method | Undo(IUndoData, Boolean) | Performs the single undo operation.
Public method | UnhighlightBraces | Unhighlights braces containing caret position.
Public method | UnhighlightBraces(Boolean) | Unhighlights braces.
Public method | UnhighlightCodeSnippets | Removes highlighting from code snippets and clears snippet collection.
Public method | UnhighlightSyntaxErrors | Removes syntax errors highlighting.
Public method | Update | Updates an object state.
Public method | ValidatePosition | Validates given position within control's text content.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.AbsolutePositionToTextPoint Method

TextSourceAbsolutePositionToTextPoint Method
Converts given absolute position to position as Point value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point AbsolutePositionToTextPoint(
    int position
)
Public Overridable Function AbsolutePositionToTextPoint (
    position As Integer
) As Point
public:
virtual Point AbsolutePositionToTextPoint(
    int position
)
abstract AbsolutePositionToTextPoint :
        position : int -> Point
override AbsolutePositionToTextPoint :
        position : int -> Point

Parameters

position
Type: SystemInt32
Specifies index of character if the text considered as a single string.

Return Value

Type: Point
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Implements

ITextSourceAbsolutePositionToTextPoint(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.AddNotifier Method

TextSourceAddNotifier Method
Adds new handler to respond for notification.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddNotifier(
    INotifier sender
)
Public Overridable Sub AddNotifier (
    sender As INotifier
)
public:
virtual void AddNotifier(
    INotifier^ sender
)
abstract AddNotifier :
        sender : INotifier -> unit
override AddNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.

Implements

INotifyAddNotifier(INotifier)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.AddUndo Method

TextSourceAddUndo Method
Stores undo operation in the appropriate list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddUndo(
    UndoOperation operation,
    Object data
)
Public Overridable Sub AddUndo (
    operation As UndoOperation,
    data As Object
)
public:
virtual void AddUndo(
    UndoOperation operation,
    Object^ data
)
abstract AddUndo :
        operation : UndoOperation *
        data : Object -> unit
override AddUndo :
        operation : UndoOperation *
        data : Object -> unit

Parameters

operation
Type: Alternet.Editor.TextSourceUndoOperation
Operation to store.
data
Type: SystemObject
Data to store.

Implements

IUndoAddUndo(UndoOperation, Object)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.BeginUndoUpdate Method

TextSourceBeginUndoUpdate Method
Allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUndoUpdate()
Public Overridable Function BeginUndoUpdate As Integer
public:
virtual int BeginUndoUpdate()
abstract BeginUndoUpdate : unit -> int
override BeginUndoUpdate : unit -> int

Return Value

Type: Int32
Number of undo updating locks.

Implements

IUndoBeginUndoUpdate
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.BeginUpdate Method

TextSourceBeginUpdate Method
Overload List
 | Name | Description
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | BeginUpdate(UpdateReason) | Prevents object state updating until calling EndUpdate method.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.BeginUpdate Method

TextSourceBeginUpdate Method
Prevents object state updating until calling EndUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

TextSource Class
BeginUpdate Overload
Alternet.Editor.TextSource Namespace


TextSource.BeginUpdate Method (UpdateReason)

TextSourceBeginUpdate Method (UpdateReason)
Prevents object state updating until calling EndUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate(
    UpdateReason reason
)
Public Overridable Function BeginUpdate (
    reason As UpdateReason
) As Integer
public:
virtual int BeginUpdate(
    UpdateReason reason
)
abstract BeginUpdate :
        reason : UpdateReason -> int
override BeginUpdate :
        reason : UpdateReason -> int

Parameters

reason
Type: Alternet.Editor.TextSourceUpdateReason
Reason of the source state updating.

Return Value

Type: Int32
Number of object state updating locks.

Implements

ITextNotifyBeginUpdate(UpdateReason)
See Also

Reference

TextSource Class
BeginUpdate Overload
Alternet.Editor.TextSource Namespace


TextSource.BeginUpdateSnippet Method

TextSourceBeginUpdateSnippet Method
Prevents the Edit control from updating snippets until the EndUpdateSnippet method is called.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdateSnippet()
Public Overridable Function BeginUpdateSnippet As Integer
public:
virtual int BeginUpdateSnippet()
abstract BeginUpdateSnippet : unit -> int
override BeginUpdateSnippet : unit -> int

Return Value

Type: Int32
Number of snippet updating locks.

Implements

ITextSnippetsBeginUpdateSnippet
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.BreakLine Method

TextSourceBreakLine Method
Breaks current line into two lines.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BreakLine(
    bool withChange = false
)
Public Overridable Function BreakLine (
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool BreakLine(
    bool withChange = false
)
abstract BreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override BreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditBreakLine(Boolean)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.CancelParsing Method

TextSourceCancelParsing Method
Stops formatting timer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CancelParsing()
Public Overridable Sub CancelParsing
public:
virtual void CancelParsing()
abstract CancelParsing : unit -> unit
override CancelParsing : unit -> unit

Implements

ITextSourceCancelParsing
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.CanRedo Method

TextSourceCanRedo Method
Indicating whether the redo operation can be performed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanRedo()
Public Overridable Function CanRedo As Boolean
public:
virtual bool CanRedo()
abstract CanRedo : unit -> bool
override CanRedo : unit -> bool

Return Value

Type: Boolean

Implements

IUndoCanRedo
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.CanUndo Method

TextSourceCanUndo Method
Indicating whether the undo operation can be performed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanUndo()
Public Overridable Function CanUndo As Boolean
public:
virtual bool CanUndo()
abstract CanUndo : unit -> bool
override CanUndo : unit -> bool

Return Value

Type: Boolean

Implements

IUndoCanUndo
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Clear Method

TextSourceClear Method
Clears content of the TextSource

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ITextSourceClear
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ClearRedo Method

TextSourceClearRedo Method
Clears list of redo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearRedo()
Public Sub ClearRedo
public:
virtual void ClearRedo() sealed
abstract ClearRedo : unit -> unit
override ClearRedo : unit -> unit

Implements

IUndoClearRedo
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ClearUndo Method

TextSourceClearUndo Method
Clears list of undo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearUndo()
Public Overridable Sub ClearUndo
public:
virtual void ClearUndo()
abstract ClearUndo : unit -> unit
override ClearUndo : unit -> unit

Implements

IUndoClearUndo
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.CreateStringItem Method

TextSourceCreateStringItem Method
Create a new IStringItem object containing specified text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IStringItem CreateStringItem(
    string s
)
Public Overridable Function CreateStringItem (
    s As String
) As IStringItem
public:
virtual IStringItem^ CreateStringItem(
    String^ s
)
abstract CreateStringItem :
        s : string -> IStringItem
override CreateStringItem :
        s : string -> IStringItem

Parameters

s
Type: SystemString
String that IStringItem contain.

Return Value

Type: IStringItem
Created IStringItem object.

Implements

ITextSourceCreateStringItem(String)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.DeleteBlock Method

TextSourceDeleteBlock Method
Overload List
 | Name | Description
Public method | DeleteBlock(Rectangle, Boolean) | Deletes a specified block of characters.
Public method | DeleteBlock(Int32, Boolean) | Deletes a specified block of characters.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.DeleteBlock Method (Rectangle, Boolean)

TextSourceDeleteBlock Method (Rectangle, Boolean)
Deletes a specified block of characters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DeleteBlock(
    Rectangle rect,
    bool withChange = false
)
Public Overridable Function DeleteBlock (
    rect As Rectangle,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool DeleteBlock(
    Rectangle rect,
    bool withChange = false
)
abstract DeleteBlock :
        rect : Rectangle *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override DeleteBlock :
        rect : Rectangle *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies coordinates of characters block to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if method succeed; otherwise false.

Implements

IEditDeleteBlock(Rectangle, Boolean)
See Also

Reference

TextSource Class
DeleteBlock Overload
Alternet.Editor.TextSource Namespace


TextSource.DeleteBlock Method (Int32, Boolean)

TextSourceDeleteBlock Method (Int32, Boolean)
Deletes a specified block of characters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DeleteBlock(
    int len,
    bool withChange = false
)
Public Overridable Function DeleteBlock (
    len As Integer,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool DeleteBlock(
    int len,
    bool withChange = false
)
abstract DeleteBlock :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override DeleteBlock :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

len
Type: SystemInt32
Specifies length of block (number of characters) to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if method succeed; otherwise false.
Remarks
The method deletes block of characters starting from the current position.
See Also

Reference

TextSource Class
DeleteBlock Overload
Alternet.Editor.TextSource Namespace


TextSource.DeleteLeft Method

TextSourceDeleteLeft Method
Deletes a specified number of characters to the left of the active point.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DeleteLeft(
    int len,
    bool withChange = false
)
Public Overridable Function DeleteLeft (
    len As Integer,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool DeleteLeft(
    int len,
    bool withChange = false
)
abstract DeleteLeft :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override DeleteLeft :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

len
Type: SystemInt32
Specifies number of characters to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.

Return Value

Type: Boolean
True if method succeed; otherwise false.

Implements

IEditDeleteLeft(Int32, Boolean)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.DeleteRight Method

TextSourceDeleteRight Method
Deletes a specified number of characters to the right of the active point.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool DeleteRight(
    int len,
    bool withChange = false
)
Public Overridable Function DeleteRight (
    len As Integer,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool DeleteRight(
    int len,
    bool withChange = false
)
abstract DeleteRight :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override DeleteRight :
        len : int *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

len
Type: SystemInt32
Specifies number of characters to delete.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.

Return Value

Type: Boolean
True if method succeed; otherwise false.

Implements

IEditDeleteRight(Int32, Boolean)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.DisablePositionUpdate Method

TextSourceDisablePositionUpdate Method
Prevents notification of changing of caret position until calling EnablePositionUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DisablePositionUpdate()
Public Overridable Sub DisablePositionUpdate
public:
virtual void DisablePositionUpdate()
abstract DisablePositionUpdate : unit -> unit
override DisablePositionUpdate : unit -> unit

Return Value

Type:
Number of object state updating locks.

Implements

INavigateDisablePositionUpdate
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.DisableUndo Method

TextSourceDisableUndo Method
Disables recording of undo/redo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUndo()
Public Overridable Function DisableUndo As Integer
public:
virtual int DisableUndo()
abstract DisableUndo : unit -> int
override DisableUndo : unit -> int

Return Value

Type: Int32
Number of undo/redo operations locks.

Implements

IUndoDisableUndo
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace
TextSourceEnableUndo


TextSource.DisableUpdate Method

TextSourceDisableUpdate Method
Prevents object state updating until calling EnableUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.EnablePositionUpdate Method

TextSourceEnablePositionUpdate Method
Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void EnablePositionUpdate()
Public Overridable Sub EnablePositionUpdate
public:
virtual void EnablePositionUpdate()
abstract EnablePositionUpdate : unit -> unit
override EnablePositionUpdate : unit -> unit

Return Value

Type:
Number of object state updating locks.

Implements

INavigateEnablePositionUpdate
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.EnableUndo Method

TextSourceEnableUndo Method
Re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUndo()
Public Overridable Function EnableUndo As Integer
public:
virtual int EnableUndo()
abstract EnableUndo : unit -> int
override EnableUndo : unit -> int

Return Value

Type: Int32
Number of undo/redo operations locks.

Implements

IUndoEnableUndo
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace
TextSourceDisableUndo


TextSource.EnableUpdate Method

TextSourceEnableUpdate Method
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.EndUndoUpdate Method

TextSourceEndUndoUpdate Method
Ends undo block, that was started by BeginUndoUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUndoUpdate()
Public Overridable Function EndUndoUpdate As Integer
public:
virtual int EndUndoUpdate()
abstract EndUndoUpdate : unit -> int
override EndUndoUpdate : unit -> int

Return Value

Type: Int32
Number of undo updating locks.

Implements

IUndoEndUndoUpdate
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.EndUpdate Method

TextSourceEndUpdate Method
Re-enables object state updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.EndUpdateSnippet Method

TextSourceEndUpdateSnippet Method
Resumes updating snippets after updating is suspended by the BeginUpdateSnippet method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdateSnippet()
Public Overridable Function EndUpdateSnippet As Integer
public:
virtual int EndUpdateSnippet()
abstract EndUpdateSnippet : unit -> int
override EndUpdateSnippet : unit -> int

Return Value

Type: Int32
Number of snippet updating locks.

Implements

ITextSnippetsEndUpdateSnippet
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.FindClosingBrace Method

TextSourceFindClosingBrace Method
Overload List
 | Name | Description
Public method | FindClosingBrace(Point) | Locates closing brace.
Public method | FindClosingBrace(Int32, Int32) | Locates closing brace.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.FindClosingBrace Method (Point)

TextSourceFindClosingBrace Method (Point)
Locates closing brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindClosingBrace(
    ref Point position
)
Public Overridable Function FindClosingBrace (
    ByRef position As Point
) As Boolean
public:
virtual bool FindClosingBrace(
    Point% position
)
abstract FindClosingBrace :
        position : Point byref -> bool
override FindClosingBrace :
        position : Point byref -> bool

Parameters

position
Type: System.DrawingPoint
Retrieves position of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBraceMatchingFindClosingBrace(Point)
See Also

Reference

TextSource Class
FindClosingBrace Overload
Alternet.Editor.TextSource Namespace


TextSource.FindClosingBrace Method (Int32, Int32)

TextSourceFindClosingBrace Method (Int32, Int32)
Locates closing brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindClosingBrace(
    ref int x,
    ref int y
)
Public Overridable Function FindClosingBrace (
    ByRef x As Integer,
    ByRef y As Integer
) As Boolean
public:
virtual bool FindClosingBrace(
    int% x,
    int% y
)
abstract FindClosingBrace :
        x : int byref *
        y : int byref -> bool
override FindClosingBrace :
        x : int byref *
        y : int byref -> bool

Parameters

x
Type: SystemInt32
Retrieves X-coordinate of the found brace.
y
Type: SystemInt32
Retrieves Y-coordinate of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBraceMatchingFindClosingBrace(Int32, Int32)
See Also

Reference

TextSource Class
FindClosingBrace Overload
Alternet.Editor.TextSource Namespace


TextSource.FindOpenBrace Method

TextSourceFindOpenBrace Method
Overload List
 | Name | Description
Public method | FindOpenBrace(Point) | Locates open brace.
Public method | FindOpenBrace(Int32, Int32) | Locates open brace.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.FindOpenBrace Method (Point)

TextSourceFindOpenBrace Method (Point)
Locates open brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindOpenBrace(
    ref Point position
)
Public Overridable Function FindOpenBrace (
    ByRef position As Point
) As Boolean
public:
virtual bool FindOpenBrace(
    Point% position
)
abstract FindOpenBrace :
        position : Point byref -> bool
override FindOpenBrace :
        position : Point byref -> bool

Parameters

position
Type: System.DrawingPoint
Retrieves position of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBraceMatchingFindOpenBrace(Point)
See Also

Reference

TextSource Class
FindOpenBrace Overload
Alternet.Editor.TextSource Namespace


TextSource.FindOpenBrace Method (Int32, Int32)

TextSourceFindOpenBrace Method (Int32, Int32)
Locates open brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindOpenBrace(
    ref int x,
    ref int y
)
Public Overridable Function FindOpenBrace (
    ByRef x As Integer,
    ByRef y As Integer
) As Boolean
public:
virtual bool FindOpenBrace(
    int% x,
    int% y
)
abstract FindOpenBrace :
        x : int byref *
        y : int byref -> bool
override FindOpenBrace :
        x : int byref *
        y : int byref -> bool

Parameters

x
Type: SystemInt32
Retrieves X-coordinate of the found brace.
y
Type: SystemInt32
Retrieves Y-coordinate of the found brace.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IBraceMatchingFindOpenBrace(Int32, Int32)
See Also

Reference

TextSource Class
FindOpenBrace Overload
Alternet.Editor.TextSource Namespace


TextSource.FormatText Method

TextSourceFormatText Method
Overload List
 | Name | Description
Public method | FormatText | Tries to format and outline TextSource text using attached Lexer.
Public method | FormatText(Boolean, Boolean) | Tries to format and outline TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.FormatText Method

TextSourceFormatText Method
Tries to format and outline TextSource text using attached Lexer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FormatText()
Public Overridable Sub FormatText
public:
virtual void FormatText()
abstract FormatText : unit -> unit
override FormatText : unit -> unit

Implements

ITextParsingFormatText
See Also

Reference

TextSource Class
FormatText Overload
Alternet.Editor.TextSource Namespace


TextSource.FormatText Method (Boolean, Boolean)

TextSourceFormatText Method (Boolean, Boolean)
Tries to format and outline TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FormatText(
    bool immediate,
    bool notify
)
Public Overridable Sub FormatText (
    immediate As Boolean,
    notify As Boolean
)
public:
virtual void FormatText(
    bool immediate,
    bool notify
)
abstract FormatText :
        immediate : bool *
        notify : bool -> unit
override FormatText :
        immediate : bool *
        notify : bool -> unit

Parameters

immediate
Type: SystemBoolean
notify
Type: SystemBoolean

Implements

ITextParsingFormatText(Boolean, Boolean)
See Also

Reference

TextSource Class
FormatText Overload
Alternet.Editor.TextSource Namespace


TextSource.GetCharIndexFromPosition Method

TextSourceGetCharIndexFromPosition Method
Converts given Point value to the index of character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetCharIndexFromPosition(
    Point position
)
Public Overridable Function GetCharIndexFromPosition (
    position As Point
) As Integer
public:
virtual int GetCharIndexFromPosition(
    Point position
)
abstract GetCharIndexFromPosition :
        position : Point -> int
override GetCharIndexFromPosition :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Return Value

Type: Int32
Index of character if the text considered as a single string.

Implements

ITextSourceGetCharIndexFromPosition(Point)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.GetCodeFixes Method

TextSourceGetCodeFixes Method
Gets code fixes for a given syntax error.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<ICodeFix> GetCodeFixes(
    ISyntaxError error,
    bool allDocuments
)
Public Overridable Function GetCodeFixes (
    error As ISyntaxError,
    allDocuments As Boolean
) As IList(Of ICodeFix)
public:
virtual IList<ICodeFix^>^ GetCodeFixes(
    ISyntaxError^ error,
    bool allDocuments
)
abstract GetCodeFixes :
        error : ISyntaxError *
        allDocuments : bool -> IList<ICodeFix>
override GetCodeFixes :
        error : ISyntaxError *
        allDocuments : bool -> IList<ICodeFix>

Parameters

error
Type: Alternet.SyntaxISyntaxError
Specifies syntax error..
allDocuments
Type: SystemBoolean
Specifies if all documents in the solution need to be processed.

Return Value

Type: IListICodeFix
List of code fixes for a given error if succeed; otherwise null.

Implements

ITextErrorsGetCodeFixes(ISyntaxError, Boolean)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.GetCodeSnippetRangeAt Method

TextSourceGetCodeSnippetRangeAt Method
Locates code snippet at specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetRange GetCodeSnippetRangeAt(
    Point position
)
Public Overridable Function GetCodeSnippetRangeAt (
    position As Point
) As ICodeSnippetRange
public:
virtual ICodeSnippetRange^ GetCodeSnippetRangeAt(
    Point position
)
abstract GetCodeSnippetRangeAt :
        position : Point -> ICodeSnippetRange
override GetCodeSnippetRangeAt :
        position : Point -> ICodeSnippetRange

Parameters

position
Type: System.DrawingPoint
Position to evaluate.

Return Value

Type: ICodeSnippetRange
ICodeSnippetRange at specified position if succeed; otherwise null.

Implements

ITextSnippetsGetCodeSnippetRangeAt(Point)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.GetIndentString Method

TextSourceGetIndentString Method
Gets indentation string at current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetIndentString()
Public Overridable Function GetIndentString As String
public:
virtual String^ GetIndentString()
abstract GetIndentString : unit -> string
override GetIndentString : unit -> string

Return Value

Type: String

Implements

IEditGetIndentString
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.GetPositionFromCharIndex Method

TextSourceGetPositionFromCharIndex Method
Converts given character index to position as Point value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point GetPositionFromCharIndex(
    int charIndex
)
Public Overridable Function GetPositionFromCharIndex (
    charIndex As Integer
) As Point
public:
virtual Point GetPositionFromCharIndex(
    int charIndex
)
abstract GetPositionFromCharIndex :
        charIndex : int -> Point
override GetPositionFromCharIndex :
        charIndex : int -> Point

Parameters

charIndex
Type: SystemInt32
Specifies index of character if the text considered as a single string.

Return Value

Type: Point
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Implements

ITextSourceGetPositionFromCharIndex(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.GetStructureGuideLines Method

TextSourceGetStructureGuideLines Method
Gets list of guide lines.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetStructureGuideLines(
    int line,
    IList<IRange> guideLines
)
Public Overridable Function GetStructureGuideLines (
    line As Integer,
    guideLines As IList(Of IRange)
) As Integer
public:
virtual int GetStructureGuideLines(
    int line,
    IList<IRange^>^ guideLines
)
abstract GetStructureGuideLines :
        line : int *
        guideLines : IList<IRange> -> int
override GetStructureGuideLines :
        line : int *
        guideLines : IList<IRange> -> int

Parameters

line
Type: SystemInt32
Start of guide line.
guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.

Implements

ITextParsingGetStructureGuideLines(Int32, IListIRange)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.GetSyntaxErrorAt Method

TextSourceGetSyntaxErrorAt Method
Gets syntax error at specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxError GetSyntaxErrorAt(
    int x,
    int y
)
Public Overridable Function GetSyntaxErrorAt (
    x As Integer,
    y As Integer
) As ISyntaxError
public:
virtual ISyntaxError^ GetSyntaxErrorAt(
    int x,
    int y
)
abstract GetSyntaxErrorAt :
        x : int *
        y : int -> ISyntaxError
override GetSyntaxErrorAt :
        x : int *
        y : int -> ISyntaxError

Parameters

x
Type: SystemInt32
X-coordinate of the position to evaluate.
y
Type: SystemInt32
Y-coordinate of the position to evaluate.

Return Value

Type: ISyntaxError
ISyntaxError object at specified position if succeed; otherwise null.

Implements

ITextErrorsGetSyntaxErrorAt(Int32, Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.HighlightBraces Method

TextSourceHighlightBraces Method
Highlights braces containing caret position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void HighlightBraces()
Public Overridable Sub HighlightBraces
public:
virtual void HighlightBraces()
abstract HighlightBraces : unit -> unit
override HighlightBraces : unit -> unit

Implements

IBraceMatchingHighlightBraces
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace
IBraceMatchingUnhighlightBraces


TextSource.HighlightCodeFixes Method

TextSourceHighlightCodeFixes Method
Highlights code fixes if needed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void HighlightCodeFixes()
Public Overridable Sub HighlightCodeFixes
public:
virtual void HighlightCodeFixes()
abstract HighlightCodeFixes : unit -> unit
override HighlightCodeFixes : unit -> unit

Implements

ITextErrorsHighlightCodeFixes
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.HighlightCodeRefactors Method

TextSourceHighlightCodeRefactors Method
Highlights code fixes if needed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void HighlightCodeRefactors()
Public Overridable Sub HighlightCodeRefactors
public:
virtual void HighlightCodeRefactors()
abstract HighlightCodeRefactors : unit -> unit
override HighlightCodeRefactors : unit -> unit
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.HighlightCodeSnippets Method

TextSourceHighlightCodeSnippets Method
Highlights code snippets using appropriate style.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void HighlightCodeSnippets()
Public Overridable Sub HighlightCodeSnippets
public:
virtual void HighlightCodeSnippets()
abstract HighlightCodeSnippets : unit -> unit
override HighlightCodeSnippets : unit -> unit

Implements

ITextSnippetsHighlightCodeSnippets
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.HighlightSyntaxErrors Method

TextSourceHighlightSyntaxErrors Method
Highlights syntax errors.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HighlightSyntaxErrors()
Public Sub HighlightSyntaxErrors
public:
virtual void HighlightSyntaxErrors() sealed
abstract HighlightSyntaxErrors : unit -> unit
override HighlightSyntaxErrors : unit -> unit

Implements

ITextErrorsHighlightSyntaxErrors
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.IndentLine Method

TextSourceIndentLine Method
Overload List
 | Name | Description
Public method | IndentLine | Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
Public method | IndentLine(String, Boolean) | Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.IndentLine Method

TextSourceIndentLine Method
Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void IndentLine()
Public Overridable Sub IndentLine
public:
virtual void IndentLine()
abstract IndentLine : unit -> unit
override IndentLine : unit -> unit

Implements

IEditIndentLine
See Also

Reference

TextSource Class
IndentLine Overload
Alternet.Editor.TextSource Namespace


TextSource.IndentLine Method (String, Boolean)

TextSourceIndentLine Method (String, Boolean)
Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void IndentLine(
    string indent,
    bool withChange = false
)
Public Overridable Sub IndentLine (
    indent As String,
    Optional withChange As Boolean = false
)
public:
virtual void IndentLine(
    String^ indent,
    bool withChange = false
)
abstract IndentLine :
        indent : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit
override IndentLine :
        indent : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit

Parameters

indent
Type: SystemString
withChange (Optional)
Type: SystemBoolean

Implements

IEditIndentLine(String, Boolean)
See Also

Reference

TextSource Class
IndentLine Overload
Alternet.Editor.TextSource Namespace


TextSource.Insert Method

TextSourceInsert Method
Inserts the given string at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    string text,
    bool withChange = false
)
Public Overridable Function Insert (
    text As String,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool Insert(
    String^ text,
    bool withChange = false
)
abstract Insert :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override Insert :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

text
Type: SystemString
The text to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsert(String, Boolean)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.InsertBlock Method

TextSourceInsertBlock Method
Overload List
 | Name | Description
Public method | InsertBlock(String, Boolean) | Inserts the given string at the specified location.
Public method | InsertBlock(String, Boolean) | Inserts the given string array at the specified location.
Public method | InsertBlock(ITextStrings, Boolean) | Inserts the given string collection at the specified location.
Public method | InsertBlock(String, Boolean, Boolean) | Inserts the given string array at the specified location.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.InsertBlock Method (String, Boolean)

TextSourceInsertBlock Method (String, Boolean)
Inserts the given string at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertBlock(
    string text,
    bool withChange = false
)
Public Overridable Function InsertBlock (
    text As String,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool InsertBlock(
    String^ text,
    bool withChange = false
)
abstract InsertBlock :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override InsertBlock :
        text : string *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

text
Type: SystemString
String to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertBlock(String, Boolean)
See Also

Reference

TextSource Class
InsertBlock Overload
Alternet.Editor.TextSource Namespace


TextSource.InsertBlock Method (String[], Boolean)

TextSourceInsertBlock Method (String, Boolean)
Inserts the given string array at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertBlock(
    string[] strings,
    bool withChange = false
)
Public Overridable Function InsertBlock (
    strings As String(),
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool InsertBlock(
    array<String^>^ strings,
    bool withChange = false
)
abstract InsertBlock :
        strings : string[] *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override InsertBlock :
        strings : string[] *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

strings
Type: SystemString
String array to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertBlock(String, Boolean)
See Also

Reference

TextSource Class
InsertBlock Overload
Alternet.Editor.TextSource Namespace


TextSource.InsertBlock Method (ITextStrings, Boolean)

TextSourceInsertBlock Method (ITextStrings, Boolean)
Inserts the given string collection at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertBlock(
    ITextStrings strings,
    bool withChange = false
)
Public Overridable Function InsertBlock (
    strings As ITextStrings,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool InsertBlock(
    ITextStrings^ strings,
    bool withChange = false
)
abstract InsertBlock :
        strings : ITextStrings *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override InsertBlock :
        strings : ITextStrings *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

strings
Type: Alternet.Editor.TextSourceITextStrings
Collection of strings to insert.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertBlock(ITextStrings, Boolean)
See Also

Reference

TextSource Class
InsertBlock Overload
Alternet.Editor.TextSource Namespace


TextSource.InsertBlock Method (String[], Boolean, Boolean)

TextSourceInsertBlock Method (String, Boolean, Boolean)
Inserts the given string array at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertBlock(
    string[] strings,
    bool select,
    bool withChange = false
)
Public Overridable Function InsertBlock (
    strings As String(),
    select As Boolean,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool InsertBlock(
    array<String^>^ strings,
    bool select,
    bool withChange = false
)
abstract InsertBlock :
        strings : string[] *
        select : bool *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override InsertBlock :
        strings : string[] *
        select : bool *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

strings
Type: SystemString
String array to insert.
select
Type: SystemBoolean
Specifies whether inserted block should be selected.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertBlock(String, Boolean, Boolean)
See Also

Reference

TextSource Class
InsertBlock Overload
Alternet.Editor.TextSource Namespace


TextSource.InsertFromFile Method

TextSourceInsertFromFile Method
Inserts the file text content at the specified location.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertFromFile(
    string fileName
)
Public Overridable Function InsertFromFile (
    fileName As String
) As Boolean
public:
virtual bool InsertFromFile(
    String^ fileName
)
abstract InsertFromFile :
        fileName : string -> bool
override InsertFromFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load text from.

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditInsertFromFile(String)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.InvalidateSyntaxErrors Method

TextSourceInvalidateSyntaxErrors Method
Invalidates highlighting of syntax errors.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InvalidateSyntaxErrors()
Public Sub InvalidateSyntaxErrors
public:
virtual void InvalidateSyntaxErrors() sealed
abstract InvalidateSyntaxErrors : unit -> unit
override InvalidateSyntaxErrors : unit -> unit

Implements

ITextErrorsInvalidateSyntaxErrors
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.IsContentDivider Method

TextSourceIsContentDivider Method
Gets boolean value indicating whether text content is divided at given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsContentDivider(
    int index
)
Public Overridable Function IsContentDivider (
    index As Integer
) As Boolean
public:
virtual bool IsContentDivider(
    int index
)
abstract IsContentDivider :
        index : int -> bool
override IsContentDivider :
        index : int -> bool

Parameters

index
Type: SystemInt32
Line to check.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ITextParsingIsContentDivider(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.IsHyperText Method

TextSourceIsHyperText Method
Indicates whether given text represents hypertext.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsHyperText(
    string text
)
Public Overridable Function IsHyperText (
    text As String
) As Boolean
public:
virtual bool IsHyperText(
    String^ text
)
abstract IsHyperText :
        text : string -> bool
override IsHyperText :
        text : string -> bool

Parameters

text
Type: SystemString
Text to test.

Return Value

Type: Boolean
True if given text represents hypertext; otherwise false.

Implements

IHyperTextIsHyperText(String)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.IsWordCorrect Method

TextSourceIsWordCorrect Method
Overload List
 | Name | Description
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct.
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.IsWordCorrect Method (String)

TextSourceIsWordCorrect Method (String)
Checks whether spelling for the given word is correct.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsWordCorrect(
    string text
)
Public Overridable Function IsWordCorrect (
    text As String
) As Boolean
public:
virtual bool IsWordCorrect(
    String^ text
)
abstract IsWordCorrect :
        text : string -> bool
override IsWordCorrect :
        text : string -> bool

Parameters

text
Type: SystemString
Specifies text to check-up.

Return Value

Type: Boolean
True if correct; otherwise false.

Implements

ISpellingIsWordCorrect(String)
See Also

Reference

TextSource Class
IsWordCorrect Overload
Alternet.Editor.TextSource Namespace


TextSource.IsWordCorrect Method (String, Point)

TextSourceIsWordCorrect Method (String, Point)
Checks whether spelling for the given word is correct.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsWordCorrect(
    string text,
    Point position
)
Public Overridable Function IsWordCorrect (
    text As String,
    position As Point
) As Boolean
public:
virtual bool IsWordCorrect(
    String^ text,
    Point position
)
abstract IsWordCorrect :
        text : string *
        position : Point -> bool
override IsWordCorrect :
        text : string *
        position : Point -> bool

Parameters

text
Type: SystemString
Specifies text to check-up.
position
Type: System.DrawingPoint
Specifies position of the word within the text.

Return Value

Type: Boolean
True if correct; otherwise false.

Implements

ISpellingIsWordCorrect(String, Point)
See Also

Reference

TextSource Class
IsWordCorrect Overload
Alternet.Editor.TextSource Namespace


TextSource.LineIsHidden Method

TextSourceLineIsHidden Method
Determines whether the given line is readonly.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LineIsHidden(
    int index
)
Public Overridable Function LineIsHidden (
    index As Integer
) As Boolean
public:
virtual bool LineIsHidden(
    int index
)
abstract LineIsHidden :
        index : int -> bool
override LineIsHidden :
        index : int -> bool

Parameters

index
Type: SystemInt32
Line index.

Return Value

Type: Boolean
True if the line at given index is hidden; otherwise false.

Implements

IEditLineIsHidden(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.LineIsModified Method

TextSourceLineIsModified Method
Overload List
 | Name | Description
Public method | LineIsModified(Int32) | Indicates whether specified line already modified.
Public method | LineIsModified(Int32, Boolean) | Indicates whether specified line already modified.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.LineIsModified Method (Int32)

TextSourceLineIsModified Method (Int32)
Indicates whether specified line already modified.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LineIsModified(
    int index
)
Public Overridable Function LineIsModified (
    index As Integer
) As Boolean
public:
virtual bool LineIsModified(
    int index
)
abstract LineIsModified :
        index : int -> bool
override LineIsModified :
        index : int -> bool

Parameters

index
Type: SystemInt32
Index of line to check.

Return Value

Type: Boolean
True is line modified; otherwise false.

Implements

IUndoLineIsModified(Int32)
See Also

Reference

TextSource Class
LineIsModified Overload
Alternet.Editor.TextSource Namespace


TextSource.LineIsModified Method (Int32, Boolean)

TextSourceLineIsModified Method (Int32, Boolean)
Indicates whether specified line already modified.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LineIsModified(
    int index,
    out bool saved
)
Public Overridable Function LineIsModified (
    index As Integer,
    <OutAttribute> ByRef saved As Boolean
) As Boolean
public:
virtual bool LineIsModified(
    int index,
    [OutAttribute] bool% saved
)
abstract LineIsModified :
        index : int *
        saved : bool byref -> bool
override LineIsModified :
        index : int *
        saved : bool byref -> bool

Parameters

index
Type: SystemInt32
Index of line to check.
saved
Type: SystemBoolean
Receives boolean value that indicates whether line was not changed since last saving.

Return Value

Type: Boolean
True is line modified; otherwise false.

Implements

IUndoLineIsModified(Int32, Boolean)
See Also

Reference

TextSource Class
LineIsModified Overload
Alternet.Editor.TextSource Namespace


TextSource.LineIsReadonly Method

TextSourceLineIsReadonly Method
Determines whether the given line is readonly.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LineIsReadonly(
    int index
)
Public Overridable Function LineIsReadonly (
    index As Integer
) As Boolean
public:
virtual bool LineIsReadonly(
    int index
)
abstract LineIsReadonly :
        index : int -> bool
override LineIsReadonly :
        index : int -> bool

Parameters

index
Type: SystemInt32
Line index.

Return Value

Type: Boolean
True if the line at given index is readonly; otherwise false.

Implements

IEditLineIsReadonly(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.LinesChanged Method

TextSourceLinesChanged Method
Overload List
 | Name | Description
Public method | LinesChanged(Int32, Int32) | Specifies range of lines that was changed.
Public method | LinesChanged(Int32, Int32, Boolean) | Specifies range of lines that was changed.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.LinesChanged Method (Int32, Int32)

TextSourceLinesChanged Method (Int32, Int32)
Specifies range of lines that was changed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void LinesChanged(
    int first,
    int last
)
Public Overridable Sub LinesChanged (
    first As Integer,
    last As Integer
)
public:
virtual void LinesChanged(
    int first,
    int last
)
abstract LinesChanged :
        first : int *
        last : int -> unit
override LinesChanged :
        first : int *
        last : int -> unit

Parameters

first
Type: SystemInt32
First changed line.
last
Type: SystemInt32
Last changed line.

Implements

ITextNotifyLinesChanged(Int32, Int32)
See Also

Reference

TextSource Class
LinesChanged Overload
Alternet.Editor.TextSource Namespace


TextSource.LinesChanged Method (Int32, Int32, Boolean)

TextSourceLinesChanged Method (Int32, Int32, Boolean)
Specifies range of lines that was changed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void LinesChanged(
    int first,
    int last,
    bool modified
)
Public Overridable Sub LinesChanged (
    first As Integer,
    last As Integer,
    modified As Boolean
)
public:
virtual void LinesChanged(
    int first,
    int last,
    bool modified
)
abstract LinesChanged :
        first : int *
        last : int *
        modified : bool -> unit
override LinesChanged :
        first : int *
        last : int *
        modified : bool -> unit

Parameters

first
Type: SystemInt32
First changed line.
last
Type: SystemInt32
Last changed line.
modified
Type: SystemBoolean
Indicates that content of specified lines is modified.

Implements

ITextNotifyLinesChanged(Int32, Int32, Boolean)
See Also

Reference

TextSource Class
LinesChanged Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadFile Method

TextSourceLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.LoadFile Method (String)

TextSourceLoadFile Method (String)
Loads the contents of the specified file.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName
)
Public Overridable Function LoadFile (
    fileName As String
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool
override LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String)
See Also

Reference

TextSource Class
LoadFile Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadFile Method (String, IStringImport)

TextSourceLoadFile Method (String, IStringImport)
Loads content from the given file with specified importer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    IStringImport importer
)
Public Overridable Function LoadFile (
    fileName As String,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    IStringImport^ importer
)
abstract LoadFile :
        fileName : string *
        importer : IStringImport -> bool
override LoadFile :
        fileName : string *
        importer : IStringImport -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadFile(String, IStringImport)
See Also

Reference

TextSource Class
LoadFile Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadFile Method (String, Encoding)

TextSourceLoadFile Method (String, Encoding)
Loads the contents of the specified file with specified encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

TextSource Class
LoadFile Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadFile Method (String, IStringImport, Encoding)

TextSourceLoadFile Method (String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    IStringImport importer,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    IStringImport^ importer,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        importer : IStringImport *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadFile(String, IStringImport, Encoding)
See Also

Reference

TextSource Class
LoadFile Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadStream Method

TextSourceLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.LoadStream Method (Stream)

TextSourceLoadStream Method (Stream)
Loads the contents of the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream
)
Public Overridable Function LoadStream (
    stream As Stream
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream
)
abstract LoadStream :
        stream : Stream -> bool
override LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream)
See Also

Reference

TextSource Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadStream Method (TextReader)

TextSourceLoadStream Method (TextReader)
Loads the contents of the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader
)
Public Overridable Function LoadStream (
    reader As TextReader
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool
override LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(TextReader)
See Also

Reference

TextSource Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadStream Method (Stream, IStringImport)

TextSourceLoadStream Method (Stream, IStringImport)
Loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    IStringImport importer
)
Public Overridable Function LoadStream (
    stream As Stream,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    IStringImport^ importer
)
abstract LoadStream :
        stream : Stream *
        importer : IStringImport -> bool
override LoadStream :
        stream : Stream *
        importer : IStringImport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(Stream, IStringImport)
See Also

Reference

TextSource Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadStream Method (Stream, Encoding)

TextSourceLoadStream Method (Stream, Encoding)
Loads the contents of the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream, Encoding)
See Also

Reference

TextSource Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadStream Method (TextReader, IStringImport)

TextSourceLoadStream Method (TextReader, IStringImport)
Loads the contents of the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader,
    IStringImport importer
)
Public Overridable Function LoadStream (
    reader As TextReader,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader,
    IStringImport^ importer
)
abstract LoadStream :
        reader : TextReader *
        importer : IStringImport -> bool
override LoadStream :
        reader : TextReader *
        importer : IStringImport -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(TextReader, IStringImport)
See Also

Reference

TextSource Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextSource.LoadStream Method (Stream, IStringImport, Encoding)

TextSourceLoadStream Method (Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    IStringImport importer,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    IStringImport^ importer,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        importer : IStringImport *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(Stream, IStringImport, Encoding)
See Also

Reference

TextSource Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextSource.MoveTo Method

TextSourceMoveTo Method
Overload List
 | Name | Description
Public method | MoveTo(Point) | Moves the current position to the given position.
Public method | MoveTo(Int32, Int32) | Moves the current position to the given position.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.MoveTo Method (Point)

TextSourceMoveTo Method (Point)
Moves the current position to the given position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveTo(
    Point position
)
Public Overridable Sub MoveTo (
    position As Point
)
public:
virtual void MoveTo(
    Point position
)
abstract MoveTo :
        position : Point -> unit
override MoveTo :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
New location of the current position.

Implements

INavigateMoveTo(Point)
See Also

Reference

TextSource Class
MoveTo Overload
Alternet.Editor.TextSource Namespace


TextSource.MoveTo Method (Int32, Int32)

TextSourceMoveTo Method (Int32, Int32)
Moves the current position to the given position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveTo(
    int x,
    int y
)
Public Overridable Sub MoveTo (
    x As Integer,
    y As Integer
)
public:
virtual void MoveTo(
    int x,
    int y
)
abstract MoveTo :
        x : int *
        y : int -> unit
override MoveTo :
        x : int *
        y : int -> unit

Parameters

x
Type: SystemInt32
Index of character in the line to move to.
y
Type: SystemInt32
Index of line to move to.

Implements

INavigateMoveTo(Int32, Int32)
See Also

Reference

TextSource Class
MoveTo Overload
Alternet.Editor.TextSource Namespace


TextSource.MoveToChar Method

TextSourceMoveToChar Method
Moves the current position to the specified character in the current line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveToChar(
    int x
)
Public Overridable Sub MoveToChar (
    x As Integer
)
public:
virtual void MoveToChar(
    int x
)
abstract MoveToChar :
        x : int -> unit
override MoveToChar :
        x : int -> unit

Parameters

x
Type: SystemInt32
Index of character in the current line to move to.

Implements

INavigateMoveToChar(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.MoveToLine Method

TextSourceMoveToLine Method
Overload List
 | Name | Description
Public method | MoveToLine(Int32) | Moves the current position to the specified line.
Public method | MoveToLine(Int32, Int32) | Moves the current position to the specified line.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.MoveToLine Method (Int32)

TextSourceMoveToLine Method (Int32)
Moves the current position to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveToLine(
    int y
)
Public Overridable Sub MoveToLine (
    y As Integer
)
public:
virtual void MoveToLine(
    int y
)
abstract MoveToLine :
        y : int -> unit
override MoveToLine :
        y : int -> unit

Parameters

y
Type: SystemInt32
Index of line to move to.

Implements

INavigateMoveToLine(Int32)
See Also

Reference

TextSource Class
MoveToLine Overload
Alternet.Editor.TextSource Namespace


TextSource.MoveToLine Method (Int32, Int32)

TextSourceMoveToLine Method (Int32, Int32)
Moves the current position to the specified line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveToLine(
    int y,
    int linesAbove
)
Public Overridable Sub MoveToLine (
    y As Integer,
    linesAbove As Integer
)
public:
virtual void MoveToLine(
    int y,
    int linesAbove
)
abstract MoveToLine :
        y : int *
        linesAbove : int -> unit
override MoveToLine :
        y : int *
        linesAbove : int -> unit

Parameters

y
Type: SystemInt32
Index of line to move to.
linesAbove
Type: SystemInt32
Number of lines to leave above cursor.

Implements

INavigateMoveToLine(Int32, Int32)
See Also

Reference

TextSource Class
MoveToLine Overload
Alternet.Editor.TextSource Namespace


TextSource.Navigate Method

TextSourceNavigate Method
Moves current position by the given offset value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Navigate(
    int deltaX,
    int deltaY
)
Public Overridable Sub Navigate (
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void Navigate(
    int deltaX,
    int deltaY
)
abstract Navigate :
        deltaX : int *
        deltaY : int -> unit
override Navigate :
        deltaX : int *
        deltaY : int -> unit

Parameters

deltaX
Type: SystemInt32
Horizontal offset.
deltaY
Type: SystemInt32
Vertical offset.

Implements

INavigateNavigate(Int32, Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedAutoComplete Method

TextSourceNeedAutoComplete Method
Indicates whether ITextSource should try to autocomplete statements.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedAutoComplete()
Public Overridable Function NeedAutoComplete As Boolean
public:
virtual bool NeedAutoComplete()
abstract NeedAutoComplete : unit -> bool
override NeedAutoComplete : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedAutoComplete
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedCacheIndent Method

TextSourceNeedCacheIndent Method
Indicates whether ITextSource can reuse previous indentation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedCacheIndent()
Public Overridable Function NeedCacheIndent As Boolean
public:
virtual bool NeedCacheIndent()
abstract NeedCacheIndent : unit -> bool
override NeedCacheIndent : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedCacheIndent
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedCodeCompletion Method

TextSourceNeedCodeCompletion Method
Indicates whether ITextSource can provide code completion operation for its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedCodeCompletion()
Public Overridable Function NeedCodeCompletion As Boolean
public:
virtual bool NeedCodeCompletion()
abstract NeedCodeCompletion : unit -> bool
override NeedCodeCompletion : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedCodeCompletion
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedCodeCompletionTabs Method

TextSourceNeedCodeCompletionTabs Method
Indicates code completion content can be filtered based on its priority.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedCodeCompletionTabs(
    CodeCompletionType completionType
)
Public Overridable Function NeedCodeCompletionTabs (
    completionType As CodeCompletionType
) As Boolean
public:
virtual bool NeedCodeCompletionTabs(
    CodeCompletionType completionType
)
abstract NeedCodeCompletionTabs :
        completionType : CodeCompletionType -> bool
override NeedCodeCompletionTabs :
        completionType : CodeCompletionType -> bool

Parameters

completionType
Type: Alternet.SyntaxCodeCompletionType

Return Value

Type: Boolean

Implements

ITextParsingNeedCodeCompletionTabs(CodeCompletionType)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedCodeFixes Method

TextSourceNeedCodeFixes Method
Indicates whether ITextSource can provide code fixes operation for its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedCodeFixes()
Public Overridable Function NeedCodeFixes As Boolean
public:
virtual bool NeedCodeFixes()
abstract NeedCodeFixes : unit -> bool
override NeedCodeFixes : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedCodeFixes
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedCodeRefactors Method

TextSourceNeedCodeRefactors Method
Indicates whether ITextSource can provide code fixes operation for its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedCodeRefactors()
Public Overridable Function NeedCodeRefactors As Boolean
public:
virtual bool NeedCodeRefactors()
abstract NeedCodeRefactors : unit -> bool
override NeedCodeRefactors : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedCodeRefactors
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedContentDividers Method

TextSourceNeedContentDividers Method
Indicates whether ITextSource can proceed syntax errors in its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedContentDividers()
Public Overridable Function NeedContentDividers As Boolean
public:
virtual bool NeedContentDividers()
abstract NeedContentDividers : unit -> bool
override NeedContentDividers : unit -> bool

Return Value

Type: Boolean
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedFormatText Method

TextSourceNeedFormatText Method
Indicates whether ITextSource can format its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedFormatText()
Public Overridable Function NeedFormatText As Boolean
public:
virtual bool NeedFormatText()
abstract NeedFormatText : unit -> bool
override NeedFormatText : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedFormatText
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedFormatTextOnLineChange Method

TextSourceNeedFormatTextOnLineChange Method
Indicates whether ITextSource should format spaces and case when changing the current line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedFormatTextOnLineChange()
Public Overridable Function NeedFormatTextOnLineChange As Boolean
public:
virtual bool NeedFormatTextOnLineChange()
abstract NeedFormatTextOnLineChange : unit -> bool
override NeedFormatTextOnLineChange : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedFormatTextOnLineChange
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedIndentText Method

TextSourceNeedIndentText Method
Indicates whether ITextSource can indent its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedIndentText()
Public Overridable Function NeedIndentText As Boolean
public:
virtual bool NeedIndentText()
abstract NeedIndentText : unit -> bool
override NeedIndentText : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedIndentText
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedOutlineText Method

TextSourceNeedOutlineText Method
Indicates whether ITextSource can outline its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedOutlineText()
Public Overridable Function NeedOutlineText As Boolean
public:
virtual bool NeedOutlineText()
abstract NeedOutlineText : unit -> bool
override NeedOutlineText : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedOutlineText
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedParse Method

TextSourceNeedParse Method
Indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedParse()
Public Overridable Function NeedParse As Boolean
public:
virtual bool NeedParse()
abstract NeedParse : unit -> bool
override NeedParse : unit -> bool

Return Value

Type: Boolean
True if need to perform syntax parsing; otherwise false.

Implements

ITextParsingNeedParse
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedQuickInfoTips Method

TextSourceNeedQuickInfoTips Method
Indicates whether ITextSource can obtain short description for syntax tokens within its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedQuickInfoTips()
Public Overridable Function NeedQuickInfoTips As Boolean
public:
virtual bool NeedQuickInfoTips()
abstract NeedQuickInfoTips : unit -> bool
override NeedQuickInfoTips : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedQuickInfoTips
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedReparseText Method

TextSourceNeedReparseText Method
Indicates whether ITextSource can perform syntax analysis of its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedReparseText()
Public Overridable Function NeedReparseText As Boolean
public:
virtual bool NeedReparseText()
abstract NeedReparseText : unit -> bool
override NeedReparseText : unit -> bool

Return Value

Type: Boolean
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedReparseTextOnLineChange Method

TextSourceNeedReparseTextOnLineChange Method
Indicates whether ITextSource should replace text when changing the current line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedReparseTextOnLineChange()
Public Overridable Function NeedReparseTextOnLineChange As Boolean
public:
virtual bool NeedReparseTextOnLineChange()
abstract NeedReparseTextOnLineChange : unit -> bool
override NeedReparseTextOnLineChange : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedReparseTextOnLineChange
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedStructureGuideLines Method

TextSourceNeedStructureGuideLines Method
Indicates whether ITextSource can proceed syntax errors in its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedStructureGuideLines()
Public Overridable Function NeedStructureGuideLines As Boolean
public:
virtual bool NeedStructureGuideLines()
abstract NeedStructureGuideLines : unit -> bool
override NeedStructureGuideLines : unit -> bool

Return Value

Type: Boolean

Implements

ITextParsingNeedStructureGuideLines
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedSyntaxErrors Method

TextSourceNeedSyntaxErrors Method
Indicates whether ITextSource can proceed syntax errors in its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedSyntaxErrors()
Public Overridable Function NeedSyntaxErrors As Boolean
public:
virtual bool NeedSyntaxErrors()
abstract NeedSyntaxErrors : unit -> bool
override NeedSyntaxErrors : unit -> bool

Return Value

Type: Boolean
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NeedWorkInThread Method

TextSourceNeedWorkInThread Method
Indicates whether ITextSource can perform syntax analysis in thread.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedWorkInThread()
Public Overridable Function NeedWorkInThread As Boolean
public:
virtual bool NeedWorkInThread()
abstract NeedWorkInThread : unit -> bool
override NeedWorkInThread : unit -> bool

Return Value

Type: Boolean
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NewLine Method

TextSourceNewLine Method
Overload List
 | Name | Description
Public method | NewLine | Inserts a line break at the current position.
Public method | NewLine(String, Boolean) | Inserts a line break at the current position with indentation.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NewLine Method

TextSourceNewLine Method
Inserts a line break at the current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NewLine()
Public Overridable Function NewLine As Boolean
public:
virtual bool NewLine()
abstract NewLine : unit -> bool
override NewLine : unit -> bool

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditNewLine
See Also

Reference

TextSource Class
NewLine Overload
Alternet.Editor.TextSource Namespace


TextSource.NewLine Method (String, Boolean)

TextSourceNewLine Method (String, Boolean)
Inserts a line break at the current position with indentation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NewLine(
    ref string indent,
    bool withChange = false
)
Public Overridable Function NewLine (
    ByRef indent As String,
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool NewLine(
    String^% indent,
    bool withChange = false
)
abstract NewLine :
        indent : string byref *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override NewLine :
        indent : string byref *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

indent
Type: SystemString
pass desired indentation level, or null for automatic indentation
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditNewLine(String, Boolean)
See Also

Reference

TextSource Class
NewLine Overload
Alternet.Editor.TextSource Namespace


TextSource.NewLineAbove Method

TextSourceNewLineAbove Method
Inserts a line break above the current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NewLineAbove()
Public Overridable Function NewLineAbove As Boolean
public:
virtual bool NewLineAbove()
abstract NewLineAbove : unit -> bool
override NewLineAbove : unit -> bool

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditNewLineAbove
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NewLineBelow Method

TextSourceNewLineBelow Method
Inserts a line break below the current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NewLineBelow()
Public Overridable Function NewLineBelow As Boolean
public:
virtual bool NewLineBelow()
abstract NewLineBelow : unit -> bool
override NewLineBelow : unit -> bool

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditNewLineBelow
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Notification Method

TextSourceNotification Method
Updates control's content according to parameters of notification.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Notification(
    Object sender,
    EventArgs e
)
Public Overridable Sub Notification (
    sender As Object,
    e As EventArgs
)
public:
virtual void Notification(
    Object^ sender,
    EventArgs^ e
)
abstract Notification :
        sender : Object *
        e : EventArgs -> unit
override Notification :
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the notification.
e
Type: SystemEventArgs
An EventArgs that contains the event data.

Implements

INotifierNotification(Object, EventArgs)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Notify Method

TextSourceNotify Method
Notifies all notifiers about changing source state.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Notify(
    EventArgs e
)
Public Overridable Sub Notify (
    e As EventArgs
)
public:
virtual void Notify(
    EventArgs^ e
)
abstract Notify :
        e : EventArgs -> unit
override Notify :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

Implements

INotifyNotify(EventArgs)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ParseString Method

TextSourceParseString Method
Perform lexical analysis of the specified string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ParseString(
    int index
)
Public Overridable Sub ParseString (
    index As Integer
)
public:
virtual void ParseString(
    int index
)
abstract ParseString :
        index : int -> unit
override ParseString :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of line to parse.

Implements

ITextParsingParseString(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ParseStrings Method

TextSourceParseStrings Method
Perform lexical analysis specified strings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ParseStrings(
    int first,
    int last
)
Public Overridable Sub ParseStrings (
    first As Integer,
    last As Integer
)
public:
virtual void ParseStrings(
    int first,
    int last
)
abstract ParseStrings :
        first : int *
        last : int -> unit
override ParseStrings :
        first : int *
        last : int -> unit

Parameters

first
Type: SystemInt32
Index of the first line to parse.
last
Type: SystemInt32
Index of the last line to parse.

Implements

ITextParsingParseStrings(Int32, Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ParseToString Method

TextSourceParseToString Method
Perform lexical analysis of specified strings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ParseToString(
    int index
)
Public Overridable Sub ParseToString (
    index As Integer
)
public:
virtual void ParseToString(
    int index
)
abstract ParseToString :
        index : int -> unit
override ParseToString :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of the last string to parse.

Implements

ITextParsingParseToString(Int32)
Remarks
Method parses string collection from the last parsed string to the string specified by Index parameter.
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.PositionIsReadonly Method

TextSourcePositionIsReadonly Method
Determines whether the text at given position is readonly.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionIsReadonly(
    Point position
)
Public Overridable Function PositionIsReadonly (
    position As Point
) As Boolean
public:
virtual bool PositionIsReadonly(
    Point position
)
abstract PositionIsReadonly :
        position : Point -> bool
override PositionIsReadonly :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Position in text coordinates.

Return Value

Type: Boolean
True if the text can be edited at given position; otherwise false.

Implements

IEditPositionIsReadonly(Point)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ProcessAutoComplete Method

TextSourceProcessAutoComplete Method
Inserts end-of-block code fragment if needed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ProcessAutoComplete(
    out string code
)
Public Overridable Function ProcessAutoComplete (
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessAutoComplete(
    [OutAttribute] String^% code
)
abstract ProcessAutoComplete :
        code : string byref -> bool
override ProcessAutoComplete :
        code : string byref -> bool

Parameters

code
Type: SystemString
Code fragment to be inserted.

Return Value

Type: Boolean
True if end-of-block is inserted; otherwise false.

Implements

ITextParsingProcessAutoComplete(String)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Redo Method

TextSourceRedo Method
Performs the last redo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Redo()
Public Overridable Sub Redo
public:
virtual void Redo()
abstract Redo : unit -> unit
override Redo : unit -> unit

Implements

IUndoRedo
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.RemoveNotifier Method

TextSourceRemoveNotifier Method
Exclude specified handler from notification handlers list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveNotifier(
    INotifier sender
)
Public Overridable Sub RemoveNotifier (
    sender As INotifier
)
public:
virtual void RemoveNotifier(
    INotifier^ sender
)
abstract RemoveNotifier :
        sender : INotifier -> unit
override RemoveNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.

Implements

INotifyRemoveNotifier(INotifier)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetBracesOptions Method

TextSourceResetBracesOptions Method
Resets the BracesOptions to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBracesOptions()
Public Overridable Sub ResetBracesOptions
public:
virtual void ResetBracesOptions()
abstract ResetBracesOptions : unit -> unit
override ResetBracesOptions : unit -> unit

Implements

IBraceMatchingResetBracesOptions
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetCheckSpelling Method

TextSourceResetCheckSpelling Method
Resets the CheckSpelling to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetCheckSpelling()
Public Overridable Sub ResetCheckSpelling
public:
virtual void ResetCheckSpelling()
abstract ResetCheckSpelling : unit -> unit
override ResetCheckSpelling : unit -> unit

Implements

ISpellingResetCheckSpelling
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetClosingBraces Method

TextSourceResetClosingBraces Method
Resets the ClosingBraces to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetClosingBraces()
Public Overridable Sub ResetClosingBraces
public:
virtual void ResetClosingBraces()
abstract ResetClosingBraces : unit -> unit
override ResetClosingBraces : unit -> unit

Implements

IBraceMatchingResetClosingBraces
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetHighlightHyperText Method

TextSourceResetHighlightHyperText Method
Resets HighlightHyperText to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetHighlightHyperText()
Public Overridable Sub ResetHighlightHyperText
public:
virtual void ResetHighlightHyperText()
abstract ResetHighlightHyperText : unit -> unit
override ResetHighlightHyperText : unit -> unit

Implements

IHyperTextResetHighlightHyperText
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetIndentOptions Method

TextSourceResetIndentOptions Method
Resets the IndentOptions to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetIndentOptions()
Public Overridable Sub ResetIndentOptions
public:
virtual void ResetIndentOptions()
abstract ResetIndentOptions : unit -> unit
override ResetIndentOptions : unit -> unit

Implements

IEditResetIndentOptions
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetMaxLength Method

TextSourceResetMaxLength Method
Resets the MaxLength to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetMaxLength()
Public Overridable Sub ResetMaxLength
public:
virtual void ResetMaxLength()
abstract ResetMaxLength : unit -> unit
override ResetMaxLength : unit -> unit

Implements

IEditResetMaxLength
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetModified Method

TextSourceResetModified Method
Resets the Modified to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetModified()
Public Overridable Sub ResetModified
public:
virtual void ResetModified()
abstract ResetModified : unit -> unit
override ResetModified : unit -> unit

Implements

IEditResetModified
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetNavigateOptions Method

TextSourceResetNavigateOptions Method
Resets the NavigateOptions to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetNavigateOptions()
Public Overridable Sub ResetNavigateOptions
public:
virtual void ResetNavigateOptions()
abstract ResetNavigateOptions : unit -> unit
override ResetNavigateOptions : unit -> unit

Implements

INavigateResetNavigateOptions
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetOpenBraces Method

TextSourceResetOpenBraces Method
Resets the OpenBraces to its default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOpenBraces()
Public Overridable Sub ResetOpenBraces
public:
virtual void ResetOpenBraces()
abstract ResetOpenBraces : unit -> unit
override ResetOpenBraces : unit -> unit

Implements

IBraceMatchingResetOpenBraces
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetOverWrite Method

TextSourceResetOverWrite Method
Resets the OverWrite to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOverWrite()
Public Overridable Sub ResetOverWrite
public:
virtual void ResetOverWrite()
abstract ResetOverWrite : unit -> unit
override ResetOverWrite : unit -> unit

Implements

IEditResetOverWrite
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetReadOnly Method

TextSourceResetReadOnly Method
Resets the ReadOnly to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetReadOnly()
Public Overridable Sub ResetReadOnly
public:
virtual void ResetReadOnly()
abstract ResetReadOnly : unit -> unit
override ResetReadOnly : unit -> unit

Implements

IEditResetReadOnly
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetSingleLineMode Method

TextSourceResetSingleLineMode Method
Resets the SingleLineMode to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSingleLineMode()
Public Overridable Sub ResetSingleLineMode
public:
virtual void ResetSingleLineMode()
abstract ResetSingleLineMode : unit -> unit
override ResetSingleLineMode : unit -> unit

Implements

IEditResetSingleLineMode
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetSpellDelimiters Method

TextSourceResetSpellDelimiters Method
Resets the SpellDelimiters to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSpellDelimiters()
Public Overridable Sub ResetSpellDelimiters
public:
virtual void ResetSpellDelimiters()
abstract ResetSpellDelimiters : unit -> unit
override ResetSpellDelimiters : unit -> unit

Implements

ISpellingResetSpellDelimiters
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetUndoLimit Method

TextSourceResetUndoLimit Method
Resets the UndoLimit to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUndoLimit()
Public Overridable Sub ResetUndoLimit
public:
virtual void ResetUndoLimit()
abstract ResetUndoLimit : unit -> unit
override ResetUndoLimit : unit -> unit

Implements

IUndoResetUndoLimit
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ResetUndoOptions Method

TextSourceResetUndoOptions Method
Resets the UndoOptions to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUndoOptions()
Public Overridable Sub ResetUndoOptions
public:
virtual void ResetUndoOptions()
abstract ResetUndoOptions : unit -> unit
override ResetUndoOptions : unit -> unit

Implements

IUndoResetUndoOptions
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.RestorePosition Method

TextSourceRestorePosition Method
Restores position from stored position list by given index.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point RestorePosition(
    int index
)
Public Overridable Function RestorePosition (
    index As Integer
) As Point
public:
virtual Point RestorePosition(
    int index
)
abstract RestorePosition :
        index : int -> Point
override RestorePosition :
        index : int -> Point

Parameters

index
Type: SystemInt32
Index of position to restore.

Return Value

Type: Point
Point value that represents stored position.

Implements

INavigateRestorePosition(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.RestorePositionWithUndo Method

TextSourceRestorePositionWithUndo Method
Restores position from stored position list by given index.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RestorePositionWithUndo(
    int index
)
Public Overridable Sub RestorePositionWithUndo (
    index As Integer
)
public:
virtual void RestorePositionWithUndo(
    int index
)
abstract RestorePositionWithUndo :
        index : int -> unit
override RestorePositionWithUndo :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of position to restore.

Implements

INavigateRestorePositionWithUndo(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SaveFile Method

TextSourceSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specific exporter.
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves text content to the specific file with specific exporter and encoding.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SaveFile Method (String)

TextSourceSaveFile Method (String)
Saves text content to the specific file.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName
)
Public Overridable Function SaveFile (
    fileName As String
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> bool
override SaveFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String)
See Also

Reference

TextSource Class
SaveFile Overload
Alternet.Editor.TextSource Namespace


TextSource.SaveFile Method (String, IStringExport)

TextSourceSaveFile Method (String, IStringExport)
Saves text content to the specific file with specific exporter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    IStringExport exporter
)
Public Overridable Function SaveFile (
    fileName As String,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    IStringExport^ exporter
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport -> bool
override SaveFile :
        fileName : string *
        exporter : IStringExport -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Object to perform writing.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveFile(String, IStringExport)
See Also

Reference

TextSource Class
SaveFile Overload
Alternet.Editor.TextSource Namespace


TextSource.SaveFile Method (String, Encoding)

TextSourceSaveFile Method (String, Encoding)
Saves text content to the specific file with specific encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String, Encoding)
See Also

Reference

TextSource Class
SaveFile Overload
Alternet.Editor.TextSource Namespace


TextSource.SaveFile Method (String, IStringExport, Encoding)

TextSourceSaveFile Method (String, IStringExport, Encoding)
Saves text content to the specific file with specific exporter and encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    IStringExport exporter,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Object to perform writing.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveFile(String, IStringExport, Encoding)
See Also

Reference

TextSource Class
SaveFile Overload
Alternet.Editor.TextSource Namespace


TextSource.SaveStream Method

TextSourceSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the specified stream.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SaveStream Method (Stream)

TextSourceSaveStream Method (Stream)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream
)
Public Overridable Function SaveStream (
    stream As Stream
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream
)
abstract SaveStream :
        stream : Stream -> bool
override SaveStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream)
See Also

Reference

TextSource Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextSource.SaveStream Method (TextWriter)

TextSourceSaveStream Method (TextWriter)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer
)
Public Overridable Function SaveStream (
    writer As TextWriter
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer
)
abstract SaveStream :
        writer : TextWriter -> bool
override SaveStream :
        writer : TextWriter -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(TextWriter)
See Also

Reference

TextSource Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextSource.SaveStream Method (Stream, IStringExport)

TextSourceSaveStream Method (Stream, IStringExport)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    IStringExport exporter
)
Public Overridable Function SaveStream (
    stream As Stream,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport -> bool
override SaveStream :
        stream : Stream *
        exporter : IStringExport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Object to perform writing.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveStream(Stream, IStringExport)
See Also

Reference

TextSource Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextSource.SaveStream Method (Stream, Encoding)

TextSourceSaveStream Method (Stream, Encoding)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream, Encoding)
See Also

Reference

TextSource Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextSource.SaveStream Method (TextWriter, IStringExport)

TextSourceSaveStream Method (TextWriter, IStringExport)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer,
    IStringExport exporter
)
Public Overridable Function SaveStream (
    writer As TextWriter,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer,
    IStringExport^ exporter
)
abstract SaveStream :
        writer : TextWriter *
        exporter : IStringExport -> bool
override SaveStream :
        writer : TextWriter *
        exporter : IStringExport -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveStream(TextWriter, IStringExport)
See Also

Reference

TextSource Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextSource.SaveStream Method (Stream, IStringExport, Encoding)

TextSourceSaveStream Method (Stream, IStringExport, Encoding)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    IStringExport exporter,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Object to perform writing.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveStream(Stream, IStringExport, Encoding)
See Also

Reference

TextSource Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextSource.SetLastParsed Method

TextSourceSetLastParsed Method
Updates the last parsed line and resets first changed line to it's default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLastParsed(
    int index
)
Public Overridable Sub SetLastParsed (
    index As Integer
)
public:
virtual void SetLastParsed(
    int index
)
abstract SetLastParsed :
        index : int -> unit
override SetLastParsed :
        index : int -> unit

Parameters

index
Type: SystemInt32
New value of the last parsed line.

Implements

ITextParsingSetLastParsed(Int32)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SetLineHidden Method

TextSourceSetLineHidden Method
Overload List
 | Name | Description
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SetLineHidden Method (Int32, Boolean)

TextSourceSetLineHidden Method (Int32, Boolean)
Sets readonly state for the given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineHidden(
    int index,
    bool hidden
)
Public Overridable Sub SetLineHidden (
    index As Integer,
    hidden As Boolean
)
public:
virtual void SetLineHidden(
    int index,
    bool hidden
)
abstract SetLineHidden :
        index : int *
        hidden : bool -> unit
override SetLineHidden :
        index : int *
        hidden : bool -> unit

Parameters

index
Type: SystemInt32
Line index.
hidden
Type: SystemBoolean
Indicates hidden flag should be set or cleared.

Implements

IEditSetLineHidden(Int32, Boolean)
See Also

Reference

TextSource Class
SetLineHidden Overload
Alternet.Editor.TextSource Namespace


TextSource.SetLineHidden Method (Int32[], Boolean)

TextSourceSetLineHidden Method (Int32, Boolean)
Sets readonly state for the given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineHidden(
    int[] indexes,
    bool hidden
)
Public Overridable Sub SetLineHidden (
    indexes As Integer(),
    hidden As Boolean
)
public:
virtual void SetLineHidden(
    array<int>^ indexes,
    bool hidden
)
abstract SetLineHidden :
        indexes : int[] *
        hidden : bool -> unit
override SetLineHidden :
        indexes : int[] *
        hidden : bool -> unit

Parameters

indexes
Type: SystemInt32
Line indexes.
hidden
Type: SystemBoolean
Indicates hidden flag should be set or cleared.

Implements

IEditSetLineHidden(Int32, Boolean)
See Also

Reference

TextSource Class
SetLineHidden Overload
Alternet.Editor.TextSource Namespace


TextSource.SetLineReadonly Method

TextSourceSetLineReadonly Method
Overload List
 | Name | Description
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line.
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SetLineReadonly Method (Int32, Boolean)

TextSourceSetLineReadonly Method (Int32, Boolean)
Sets readonly state for the given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineReadonly(
    int index,
    bool readOnly
)
Public Overridable Sub SetLineReadonly (
    index As Integer,
    readOnly As Boolean
)
public:
virtual void SetLineReadonly(
    int index,
    bool readOnly
)
abstract SetLineReadonly :
        index : int *
        readOnly : bool -> unit
override SetLineReadonly :
        index : int *
        readOnly : bool -> unit

Parameters

index
Type: SystemInt32
Line index.
readOnly
Type: SystemBoolean
Indicates readonly flag should be set or cleared.

Implements

IEditSetLineReadonly(Int32, Boolean)
See Also

Reference

TextSource Class
SetLineReadonly Overload
Alternet.Editor.TextSource Namespace


TextSource.SetLineReadonly Method (Int32[], Boolean)

TextSourceSetLineReadonly Method (Int32, Boolean)
Sets readonly state for the given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineReadonly(
    int[] indexes,
    bool readOnly
)
Public Overridable Sub SetLineReadonly (
    indexes As Integer(),
    readOnly As Boolean
)
public:
virtual void SetLineReadonly(
    array<int>^ indexes,
    bool readOnly
)
abstract SetLineReadonly :
        indexes : int[] *
        readOnly : bool -> unit
override SetLineReadonly :
        indexes : int[] *
        readOnly : bool -> unit

Parameters

indexes
Type: SystemInt32
Line indexes.
readOnly
Type: SystemBoolean
Indicates readonly flag should be set or cleared.

Implements

IEditSetLineReadonly(Int32, Boolean)
See Also

Reference

TextSource Class
SetLineReadonly Overload
Alternet.Editor.TextSource Namespace


TextSource.SetLineState Method

TextSourceSetLineState Method
Sets item state for the given line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetLineState(
    int[] indexes,
    ItemState itemState,
    bool setState
)
Public Overridable Sub SetLineState (
    indexes As Integer(),
    itemState As ItemState,
    setState As Boolean
)
public:
virtual void SetLineState(
    array<int>^ indexes,
    ItemState itemState,
    bool setState
)
abstract SetLineState :
        indexes : int[] *
        itemState : ItemState *
        setState : bool -> unit
override SetLineState :
        indexes : int[] *
        itemState : ItemState *
        setState : bool -> unit

Parameters

indexes
Type: SystemInt32
Line indexes.
itemState
Type: Alternet.SyntaxItemState
setState
Type: SystemBoolean
Indicates if itemstate should be set or cleared.
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SetNavigateOptions Method

TextSourceSetNavigateOptions Method
Sets navigating options without validating position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetNavigateOptions(
    NavigateOptions navigateOptions
)
Public Overridable Sub SetNavigateOptions (
    navigateOptions As NavigateOptions
)
public:
virtual void SetNavigateOptions(
    NavigateOptions navigateOptions
)
abstract SetNavigateOptions :
        navigateOptions : NavigateOptions -> unit
override SetNavigateOptions :
        navigateOptions : NavigateOptions -> unit

Parameters

navigateOptions
Type: Alternet.Editor.TextSourceNavigateOptions

Implements

INavigateSetNavigateOptions(NavigateOptions)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ShouldSerializeClosingBraces Method

TextSourceShouldSerializeClosingBraces Method
Indicates whether the ClosingBraces property should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeClosingBraces()
Public Function ShouldSerializeClosingBraces As Boolean
public:
bool ShouldSerializeClosingBraces()
member ShouldSerializeClosingBraces : unit -> bool

Return Value

Type: Boolean
True if ClosingBraces differs from its default value; otherwise false.
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ShouldSerializeIndentOptions Method

TextSourceShouldSerializeIndentOptions Method
Indicates whether the IndentOptions property should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeIndentOptions()
Public Function ShouldSerializeIndentOptions As Boolean
public:
bool ShouldSerializeIndentOptions()
member ShouldSerializeIndentOptions : unit -> bool

Return Value

Type: Boolean
True if IndentOptions differs from its default value; otherwise false.
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ShouldSerializeLexer Method

TextSourceShouldSerializeLexer Method
Indicates whether the Lexer property should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeLexer()
Public Function ShouldSerializeLexer As Boolean
public:
bool ShouldSerializeLexer()
member ShouldSerializeLexer : unit -> bool

Return Value

Type: Boolean
True if Lexer differs from its default value; otherwise false.
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ShouldSerializeNavigateOptions Method

TextSourceShouldSerializeNavigateOptions Method
Indicates whether the NavigateOptions property should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeNavigateOptions()
Public Function ShouldSerializeNavigateOptions As Boolean
public:
bool ShouldSerializeNavigateOptions()
member ShouldSerializeNavigateOptions : unit -> bool

Return Value

Type: Boolean
True if NavigateOptions differs from its default value; otherwise false.
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ShouldSerializeOpenBraces Method

TextSourceShouldSerializeOpenBraces Method
Indicates whether the OpenBraces property should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeOpenBraces()
Public Function ShouldSerializeOpenBraces As Boolean
public:
bool ShouldSerializeOpenBraces()
member ShouldSerializeOpenBraces : unit -> bool

Return Value

Type: Boolean
True if OpenBraces differs from its default value; otherwise false.
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ShouldSerializeText Method

TextSourceShouldSerializeText Method
Indicates whether the Text property should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeText()
Public Function ShouldSerializeText As Boolean
public:
bool ShouldSerializeText()
member ShouldSerializeText : unit -> bool

Return Value

Type: Boolean
True if Text differs from its default value; otherwise false.
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ShouldSerializeUndoOptions Method

TextSourceShouldSerializeUndoOptions Method
Indicates whether the UndoOptions property should be persisted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeUndoOptions()
Public Function ShouldSerializeUndoOptions As Boolean
public:
bool ShouldSerializeUndoOptions()
member ShouldSerializeUndoOptions : unit -> bool

Return Value

Type: Boolean
True if UndoOptions differs from its default value; otherwise false.
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.StartThread Method

TextSourceStartThread Method
Executes action in thread.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StartThread(
    ThreadProc action,
    ThreadProc start,
    ThreadProc end,
    ThreadProc stop
)
Public Overridable Sub StartThread (
    action As ThreadProc,
    start As ThreadProc,
    end As ThreadProc,
    stop As ThreadProc
)
public:
virtual void StartThread(
    ThreadProc^ action,
    ThreadProc^ start,
    ThreadProc^ end,
    ThreadProc^ stop
)
abstract StartThread :
        action : ThreadProc *
        start : ThreadProc *
        end : ThreadProc *
        stop : ThreadProc -> unit
override StartThread :
        action : ThreadProc *
        start : ThreadProc *
        end : ThreadProc *
        stop : ThreadProc -> unit

Parameters

action
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to execute in thread.
start
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to execute in thread.
end
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to execute when thread starts.
stop
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to execute when user aborts thread execution.

Implements

ITextThreadStartThread(ThreadProc, ThreadProc, ThreadProc, ThreadProc)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.StopThread Method

TextSourceStopThread Method
Aborts executing action in thread.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StopThread(
    ThreadProc action,
    bool wait
)
Public Overridable Sub StopThread (
    action As ThreadProc,
    wait As Boolean
)
public:
virtual void StopThread(
    ThreadProc^ action,
    bool wait
)
abstract StopThread :
        action : ThreadProc *
        wait : bool -> unit
override StopThread :
        action : ThreadProc *
        wait : bool -> unit

Parameters

action
Type: Alternet.Editor.TextSourceThreadProc
Specifies action to abort.
wait
Type: SystemBoolean
Specifies whether calling application should wait for background thread to finish execution.

Implements

ITextThreadStopThread(ThreadProc, Boolean)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.StorePosition Method

TextSourceStorePosition Method
Overload List
 | Name | Description
Public method | StorePosition(Point) | Stores given position to stored position list.
Public method | StorePosition(Point, Boolean) | Stores given position to stored position list.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.StorePosition Method (Point)

TextSourceStorePosition Method (Point)
Stores given position to stored position list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StorePosition(
    Point position
)
Public Overridable Function StorePosition (
    position As Point
) As Integer
public:
virtual int StorePosition(
    Point position
)
abstract StorePosition :
        position : Point -> int
override StorePosition :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position to store.

Return Value

Type: Int32
Index of stored position in list.

Implements

INavigateStorePosition(Point)
See Also

Reference

TextSource Class
StorePosition Overload
Alternet.Editor.TextSource Namespace


TextSource.StorePosition Method (Point, Boolean)

TextSourceStorePosition Method (Point, Boolean)
Stores given position to stored position list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StorePosition(
    Point position,
    bool endPos
)
Public Overridable Function StorePosition (
    position As Point,
    endPos As Boolean
) As Integer
public:
virtual int StorePosition(
    Point position,
    bool endPos
)
abstract StorePosition :
        position : Point *
        endPos : bool -> int
override StorePosition :
        position : Point *
        endPos : bool -> int

Parameters

position
Type: System.DrawingPoint
Position to store.
endPos
Type: SystemBoolean
Specifies whether position represents end of range.

Return Value

Type: Int32
Index of stored position in list.

Implements

INavigateStorePosition(Point, Boolean)
See Also

Reference

TextSource Class
StorePosition Overload
Alternet.Editor.TextSource Namespace


TextSource.StorePositionWithUndo Method

TextSourceStorePositionWithUndo Method
Stores given position to stored position list preserving it for undo.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int StorePositionWithUndo(
    Point position
)
Public Overridable Function StorePositionWithUndo (
    position As Point
) As Integer
public:
virtual int StorePositionWithUndo(
    Point position
)
abstract StorePositionWithUndo :
        position : Point -> int
override StorePositionWithUndo :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Position to store.

Return Value

Type: Int32
Index of stored position in list.

Implements

INavigateStorePositionWithUndo(Point)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SupportsAsyncParsing Method

TextSourceSupportsAsyncParsing Method

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SupportsAsyncParsing()
Public Overridable Function SupportsAsyncParsing As Boolean
public:
virtual bool SupportsAsyncParsing()
abstract SupportsAsyncParsing : unit -> bool
override SupportsAsyncParsing : unit -> bool

Return Value

Type: Boolean
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.TempHighlightBraces Method

TextSourceTempHighlightBraces Method
Temporary highlights all text within the area specified by rects.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempHighlightBraces(
    Rectangle[] rects
)
Public Overridable Sub TempHighlightBraces (
    rects As Rectangle()
)
public:
virtual void TempHighlightBraces(
    array<Rectangle>^ rects
)
abstract TempHighlightBraces :
        rects : Rectangle[] -> unit
override TempHighlightBraces :
        rects : Rectangle[] -> unit

Parameters

rects
Type: System.DrawingRectangle
Specifies the area to highlight the text.

Implements

IBraceMatchingTempHighlightBraces(Rectangle)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace
TextSourceTempUnhighlightBraces


TextSource.TempHighlightMatchingBlocks Method

TextSourceTempHighlightMatchingBlocks Method
Highlights block match.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempHighlightMatchingBlocks()
Public Overridable Sub TempHighlightMatchingBlocks
public:
virtual void TempHighlightMatchingBlocks()
abstract TempHighlightMatchingBlocks : unit -> unit
override TempHighlightMatchingBlocks : unit -> unit
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.TempHighlightReferences Method

TextSourceTempHighlightReferences Method
Highlights found references.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempHighlightReferences()
Public Overridable Sub TempHighlightReferences
public:
virtual void TempHighlightReferences()
abstract TempHighlightReferences : unit -> unit
override TempHighlightReferences : unit -> unit

Implements

ITextSourceTempHighlightReferences
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.TempHighlightSearchResults Method

TextSourceTempHighlightSearchResults Method
Highlights search results.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempHighlightSearchResults(
    IRangeList searchResults
)
Public Overridable Sub TempHighlightSearchResults (
    searchResults As IRangeList
)
public:
virtual void TempHighlightSearchResults(
    IRangeList^ searchResults
)
abstract TempHighlightSearchResults :
        searchResults : IRangeList -> unit
override TempHighlightSearchResults :
        searchResults : IRangeList -> unit

Parameters

searchResults
Type: Alternet.CommonIRangeList

Implements

ITextSourceTempHighlightSearchResults(IRangeList)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.TempUnhighlightBraces Method

TextSourceTempUnhighlightBraces Method
Overload List
 | Name | Description
Public method | TempUnhighlightBraces | Cancels text highlighting turned on using TempHighlightBraces
Public method | TempUnhighlightBraces(Boolean) | Unhighlights temporary braces areas.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.TempUnhighlightBraces Method

TextSourceTempUnhighlightBraces Method
Cancels text highlighting turned on using TempHighlightBraces

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempUnhighlightBraces()
Public Overridable Sub TempUnhighlightBraces
public:
virtual void TempUnhighlightBraces()
abstract TempUnhighlightBraces : unit -> unit
override TempUnhighlightBraces : unit -> unit

Implements

IBraceMatchingTempUnhighlightBraces
See Also

Reference

TextSource Class
TempUnhighlightBraces Overload
Alternet.Editor.TextSource Namespace
TextSourceTempHighlightBraces(Rectangle)


TextSource.TempUnhighlightBraces Method (Boolean)

TextSourceTempUnhighlightBraces Method (Boolean)
Unhighlights temporary braces areas.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempUnhighlightBraces(
    bool needUpdate
)
Public Overridable Sub TempUnhighlightBraces (
    needUpdate As Boolean
)
public:
virtual void TempUnhighlightBraces(
    bool needUpdate
)
abstract TempUnhighlightBraces :
        needUpdate : bool -> unit
override TempUnhighlightBraces :
        needUpdate : bool -> unit

Parameters

needUpdate
Type: SystemBoolean
Specifies whether current brace pair should be updated.
See Also

Reference

TextSource Class
TempUnhighlightBraces Overload
Alternet.Editor.TextSource Namespace


TextSource.TempUnhighlightReferences Method

TextSourceTempUnhighlightReferences Method
Unhighlights references highlighted with previous call of TempHighlightReferences.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempUnhighlightReferences()
Public Overridable Sub TempUnhighlightReferences
public:
virtual void TempUnhighlightReferences()
abstract TempUnhighlightReferences : unit -> unit
override TempUnhighlightReferences : unit -> unit

Implements

ITextSourceTempUnhighlightReferences
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.TempUnhighlightSearchResults Method

TextSourceTempUnhighlightSearchResults Method
Unhighlights search results highlighted with previous call of TempHighlightSearchResults.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void TempUnhighlightSearchResults()
Public Overridable Sub TempUnhighlightSearchResults
public:
virtual void TempUnhighlightSearchResults()
abstract TempUnhighlightSearchResults : unit -> unit
override TempUnhighlightSearchResults : unit -> unit

Implements

ITextSourceTempUnhighlightSearchResults
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.TextPointToAbsolutePosition Method

TextSourceTextPointToAbsolutePosition Method
Converts given Point value to the absolute position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int TextPointToAbsolutePosition(
    Point position
)
Public Overridable Function TextPointToAbsolutePosition (
    position As Point
) As Integer
public:
virtual int TextPointToAbsolutePosition(
    Point position
)
abstract TextPointToAbsolutePosition :
        position : Point -> int
override TextPointToAbsolutePosition :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Return Value

Type: Int32
Absolute position of given point.

Implements

ITextSourceTextPointToAbsolutePosition(Point)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UnBreakLine Method

TextSourceUnBreakLine Method
Concatenates lines at current position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnBreakLine(
    bool withChange = false
)
Public Overridable Function UnBreakLine (
    Optional withChange As Boolean = false
) As Boolean
public:
virtual bool UnBreakLine(
    bool withChange = false
)
abstract UnBreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool
override UnBreakLine :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> bool

Parameters

withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser

Return Value

Type: Boolean
True if the method succeed; otherwise false.

Implements

IEditUnBreakLine(Boolean)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Undo Method

TextSourceUndo Method
Overload List
 | Name | Description
Public method | Undo(Boolean) | Performs the last undo operation.
Public method | Undo(IUndoData, Boolean) | Performs the single undo operation.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Undo Method (Boolean)

TextSourceUndo Method (Boolean)
Performs the last undo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Undo(
    bool withChange = false
)
Public Overridable Sub Undo (
    Optional withChange As Boolean = false
)
public:
virtual void Undo(
    bool withChange = false
)
abstract Undo :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit
override Undo :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit

Parameters

withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.

Implements

IUndoUndo(Boolean)
See Also

Reference

TextSource Class
Undo Overload
Alternet.Editor.TextSource Namespace


TextSource.Undo Method (IUndoData, Boolean)

TextSourceUndo Method (IUndoData, Boolean)
Performs the single undo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Undo(
    IUndoData undoData,
    bool withChange = false
)
Public Overridable Sub Undo (
    undoData As IUndoData,
    Optional withChange As Boolean = false
)
public:
virtual void Undo(
    IUndoData^ undoData,
    bool withChange = false
)
abstract Undo :
        undoData : IUndoData *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit
override Undo :
        undoData : IUndoData *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit

Parameters

undoData
Type: Alternet.Editor.TextSourceIUndoData
Data related to the undo operation.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.

Implements

IUndoUndo(IUndoData, Boolean)
See Also

Reference

TextSource Class
Undo Overload
Alternet.Editor.TextSource Namespace


TextSource.UnhighlightBraces Method

TextSourceUnhighlightBraces Method
Overload List
 | Name | Description
Public method | UnhighlightBraces | Unhighlights braces containing caret position.
Public method | UnhighlightBraces(Boolean) | Unhighlights braces.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UnhighlightBraces Method

TextSourceUnhighlightBraces Method
Unhighlights braces containing caret position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnhighlightBraces()
Public Overridable Sub UnhighlightBraces
public:
virtual void UnhighlightBraces()
abstract UnhighlightBraces : unit -> unit
override UnhighlightBraces : unit -> unit

Implements

IBraceMatchingUnhighlightBraces
See Also

Reference

TextSource Class
UnhighlightBraces Overload
Alternet.Editor.TextSource Namespace
IBraceMatchingHighlightBraces


TextSource.UnhighlightBraces Method (Boolean)

TextSourceUnhighlightBraces Method (Boolean)
Unhighlights braces.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnhighlightBraces(
    bool needUpdate
)
Public Overridable Sub UnhighlightBraces (
    needUpdate As Boolean
)
public:
virtual void UnhighlightBraces(
    bool needUpdate
)
abstract UnhighlightBraces :
        needUpdate : bool -> unit
override UnhighlightBraces :
        needUpdate : bool -> unit

Parameters

needUpdate
Type: SystemBoolean
Specifies whether current brace pair should be updated.
See Also

Reference

TextSource Class
UnhighlightBraces Overload
Alternet.Editor.TextSource Namespace


TextSource.UnhighlightCodeSnippets Method

TextSourceUnhighlightCodeSnippets Method
Removes highlighting from code snippets and clears snippet collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnhighlightCodeSnippets()
Public Overridable Sub UnhighlightCodeSnippets
public:
virtual void UnhighlightCodeSnippets()
abstract UnhighlightCodeSnippets : unit -> unit
override UnhighlightCodeSnippets : unit -> unit

Implements

ITextSnippetsUnhighlightCodeSnippets
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UnhighlightSyntaxErrors Method

TextSourceUnhighlightSyntaxErrors Method
Removes syntax errors highlighting.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnhighlightSyntaxErrors()
Public Sub UnhighlightSyntaxErrors
public:
virtual void UnhighlightSyntaxErrors() sealed
abstract UnhighlightSyntaxErrors : unit -> unit
override UnhighlightSyntaxErrors : unit -> unit

Implements

ITextErrorsUnhighlightSyntaxErrors
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Update Method

TextSourceUpdate Method
Updates an object state.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ValidatePosition Method

TextSourceValidatePosition Method
Validates given position within control's text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ValidatePosition(
    ref Point position
)
Public Overridable Sub ValidatePosition (
    ByRef position As Point
)
public:
virtual void ValidatePosition(
    Point% position
)
abstract ValidatePosition :
        position : Point byref -> unit
override ValidatePosition :
        position : Point byref -> unit

Parameters

position
Type: System.DrawingPoint
Position to validate.

Implements

INavigateValidatePosition(Point)
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource Properties

TextSource Properties

The TextSource type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEdit | Gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source.
Public property | BookMarks | Represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source.
Public property | BracesOptions | Gets or sets options specifying appearance and behaviour of matching braces within Edit control.
Public property | CheckSpelling | Gets or sets a value indicating whether the document can check spelling for its content.
Public property | ClosingBraces | Gets or sets an array of characters each one representing a closing brace.
Public property | CodeSnippets | Gets or sets ICodeSnippetRangeList for Edit control.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentSnippet | Gets or sets current ICodeSnippetRange object.
Public property | Edits | Represents a collection of ISyntaxEdit controls linked to the text source.
Public property | FileName | Gets or sets name of file that holds text source content.
Public property | FirstChanged | Represents index of the first changed line.
Public property | GlobalSearch | Specifies whether search should be global.
Public property | HasSpelling | Gets boolean value indicating that editor has external spell checker assigned.
Public property | HighlightHyperText | Gets or sets a value indicating whether hypertext in the text should be highlighted.
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight found block matches.
Public property | HighlightReferences | Specifies that edit control should highlight found references.
Public property | IndentOptions | Gets or sets Alternet.Editor.TextSource.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line.
Public property | LastChanged | Represents index of the last changed line.
Public property | Lexer | Gets or sets object that can perform lexical analysis of the text source content.
Public property | Lines | Represents the object that implements ITextStrings interface containing collection of strings determining text source content.
Public property | LineStyles | Represents an object that implements ILineStyles interface holding collection of line styles for this document.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | MatchingBlocks | Gets or sets IRangeList of matching begin/end blocks for Edit control.
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control.
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified.
Public property | ModifiedLineRegions | Gets modified lines information, grouped in regions.
Public property | ModifiedLines | Gets modified lines information.
Public property | NavigateOptions | Gets or sets navigating options.
Public property | OpenBraces | Gets or sets an array of characters each one representing an open brace.
Public property | OptimizedForMemory | Specifies whether internal text representation should optimized memory usage.
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text.
Public property | ParserLine | Gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text.
Public property | Position | Gets or sets current position within the control's text content.
Public property | PrevPosition | Gets previous position within the control's text content.
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only.
Public property | RedoList | Provides an indexed access to redo data.
Public property | References | Gets or sets IRangeList of found references for Edit control.
Public property | SearchResults | Gets or sets IRangeList of search results for Edit control.
Public property | SelectBlockRect | Represents a rectangular block of selected text.
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpellDelimiters | Gets or sets an array of chars used to separate words in a text.
Public property | SpellDelimiterString | Gets or sets Delimiters as a single string.
Public property | SpellTable | Represents a hash table containing delimiters.
Public property | State | Gets or sets last changes to the text stored in the text source.
Public property | Strings | Gets or sets text source content in the form of string array.
Public property | StructureGuideLines | Represents a syntax errors collection.
Public property | SyntaxErrors | Represents a syntax errors collection.
Public property | Text | Gets or sets text source content as a single string with the individual strings delimited by carriage returns.
Public property | ThreadAction | Returns method executed in thread when parsing.
Public property | UndoLimit | Gets or sets a value that limits number of undo operations.
Public property | UndoList | Provides an indexed access to undo data.
Public property | UndoOptions | Gets or sets options for undo and redo operations.
Public property | UndoUpdateCount | Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UrlTable | Represents hash table containing hyper-text characters.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ActiveEdit Property

TextSourceActiveEdit Property
Gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxEdit ActiveEdit { get; set; }
Public Overridable Property ActiveEdit As ISyntaxEdit
    Get
    Set
public:
virtual property ISyntaxEdit^ ActiveEdit {
    ISyntaxEdit^ get ();
    void set (ISyntaxEdit^ value);
}
abstract ActiveEdit : ISyntaxEdit with get, set
override ActiveEdit : ISyntaxEdit with get, set

Property Value

Type: ISyntaxEdit

Implements

ITextSourceActiveEdit
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.BookMarks Property

TextSourceBookMarks Property
Represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IBookMarks BookMarks { get; set; }
Public Overridable Property BookMarks As IBookMarks
    Get
    Set
public:
virtual property IBookMarks^ BookMarks {
    IBookMarks^ get ();
    void set (IBookMarks^ value);
}
abstract BookMarks : IBookMarks with get, set
override BookMarks : IBookMarks with get, set

Property Value

Type: IBookMarks

Implements

ITextSourceBookMarks
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.BracesOptions Property

TextSourceBracesOptions Property
Gets or sets options specifying appearance and behaviour of matching braces within Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual BracesOptions BracesOptions { get; set; }
Public Overridable Property BracesOptions As BracesOptions
    Get
    Set
public:
virtual property BracesOptions BracesOptions {
    BracesOptions get ();
    void set (BracesOptions value);
}
abstract BracesOptions : BracesOptions with get, set
override BracesOptions : BracesOptions with get, set

Property Value

Type: BracesOptions

Implements

IBraceMatchingBracesOptions
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.CheckSpelling Property

TextSourceCheckSpelling Property
Gets or sets a value indicating whether the document can check spelling for its content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CheckSpelling { get; set; }
Public Overridable Property CheckSpelling As Boolean
    Get
    Set
public:
virtual property bool CheckSpelling {
    bool get ();
    void set (bool value);
}
abstract CheckSpelling : bool with get, set
override CheckSpelling : bool with get, set

Property Value

Type: Boolean

Implements

ISpellingCheckSpelling
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ClosingBraces Property

TextSourceClosingBraces Property
Gets or sets an array of characters each one representing a closing brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] ClosingBraces { get; set; }
Public Overridable Property ClosingBraces As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ ClosingBraces {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract ClosingBraces : char[] with get, set
override ClosingBraces : char[] with get, set

Property Value

Type: Char

Implements

IBraceMatchingClosingBraces
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.CodeSnippets Property

TextSourceCodeSnippets Property
Gets or sets ICodeSnippetRangeList for Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetRanges CodeSnippets { get; set; }
Public Overridable Property CodeSnippets As ICodeSnippetRanges
    Get
    Set
public:
virtual property ICodeSnippetRanges^ CodeSnippets {
    ICodeSnippetRanges^ get ();
    void set (ICodeSnippetRanges^ value);
}
abstract CodeSnippets : ICodeSnippetRanges with get, set
override CodeSnippets : ICodeSnippetRanges with get, set

Property Value

Type: ICodeSnippetRanges

Implements

ITextSnippetsCodeSnippets
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.CurrentSnippet Property

TextSourceCurrentSnippet Property
Gets or sets current ICodeSnippetRange object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetRange CurrentSnippet { get; set; }
Public Overridable Property CurrentSnippet As ICodeSnippetRange
    Get
    Set
public:
virtual property ICodeSnippetRange^ CurrentSnippet {
    ICodeSnippetRange^ get ();
    void set (ICodeSnippetRange^ value);
}
abstract CurrentSnippet : ICodeSnippetRange with get, set
override CurrentSnippet : ICodeSnippetRange with get, set

Property Value

Type: ICodeSnippetRange

Implements

ITextSnippetsCurrentSnippet
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Edits Property

TextSourceEdits Property
Represents a collection of ISyntaxEdit controls linked to the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<ISyntaxEdit> Edits { get; }
Public Overridable ReadOnly Property Edits As IList(Of ISyntaxEdit)
    Get
public:
virtual property IList<ISyntaxEdit^>^ Edits {
    IList<ISyntaxEdit^>^ get ();
}
abstract Edits : IList<ISyntaxEdit> with get
override Edits : IList<ISyntaxEdit> with get

Property Value

Type: IListISyntaxEdit

Implements

ITextSourceEdits
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.FileName Property

TextSourceFileName Property
Gets or sets name of file that holds text source content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string FileName { get; set; }
Public Overridable Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

ITextSourceFileName
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.FirstChanged Property

TextSourceFirstChanged Property
Represents index of the first changed line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FirstChanged { get; }
Public Overridable ReadOnly Property FirstChanged As Integer
    Get
public:
virtual property int FirstChanged {
    int get ();
}
abstract FirstChanged : int with get
override FirstChanged : int with get

Property Value

Type: Int32

Implements

ITextNotifyFirstChanged
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.GlobalSearch Property

TextSourceGlobalSearch Property
Specifies whether search should be global.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GlobalSearch { get; set; }
Public Overridable Property GlobalSearch As Boolean
    Get
    Set
public:
virtual property bool GlobalSearch {
    bool get ();
    void set (bool value);
}
abstract GlobalSearch : bool with get, set
override GlobalSearch : bool with get, set

Property Value

Type: Boolean

Implements

ITextSourceGlobalSearch
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.HasSpelling Property

TextSourceHasSpelling Property
Gets boolean value indicating that editor has external spell checker assigned.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasSpelling { get; }
Public Overridable ReadOnly Property HasSpelling As Boolean
    Get
public:
virtual property bool HasSpelling {
    bool get ();
}
abstract HasSpelling : bool with get
override HasSpelling : bool with get

Property Value

Type: Boolean

Implements

ISpellingHasSpelling
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.HighlightHyperText Property

TextSourceHighlightHyperText Property
Gets or sets a value indicating whether hypertext in the text should be highlighted.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HighlightHyperText { get; set; }
Public Overridable Property HighlightHyperText As Boolean
    Get
    Set
public:
virtual property bool HighlightHyperText {
    bool get ();
    void set (bool value);
}
abstract HighlightHyperText : bool with get, set
override HighlightHyperText : bool with get, set

Property Value

Type: Boolean

Implements

IHyperTextHighlightHyperText
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.HighlightMatchingBlocks Property

TextSourceHighlightMatchingBlocks Property
Specifies that edit control should highlight found block matches.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HighlightMatchingBlocks { get; set; }
Public Overridable Property HighlightMatchingBlocks As Boolean
    Get
    Set
public:
virtual property bool HighlightMatchingBlocks {
    bool get ();
    void set (bool value);
}
abstract HighlightMatchingBlocks : bool with get, set
override HighlightMatchingBlocks : bool with get, set

Property Value

Type: Boolean

Implements

ITextSourceHighlightMatchingBlocks
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.HighlightReferences Property

TextSourceHighlightReferences Property
Specifies that edit control should highlight found references.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HighlightReferences { get; set; }
Public Overridable Property HighlightReferences As Boolean
    Get
    Set
public:
virtual property bool HighlightReferences {
    bool get ();
    void set (bool value);
}
abstract HighlightReferences : bool with get, set
override HighlightReferences : bool with get, set

Property Value

Type: Boolean

Implements

ITextSourceHighlightReferences
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.IndentOptions Property

TextSourceIndentOptions Property
Gets or sets Alternet.Editor.TextSource.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IndentOptions IndentOptions { get; set; }
Public Overridable Property IndentOptions As IndentOptions
    Get
    Set
public:
virtual property IndentOptions IndentOptions {
    IndentOptions get ();
    void set (IndentOptions value);
}
abstract IndentOptions : IndentOptions with get, set
override IndentOptions : IndentOptions with get, set

Property Value

Type: IndentOptions

Implements

IEditIndentOptions
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.LastChanged Property

TextSourceLastChanged Property
Represents index of the last changed line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LastChanged { get; }
Public Overridable ReadOnly Property LastChanged As Integer
    Get
public:
virtual property int LastChanged {
    int get ();
}
abstract LastChanged : int with get
override LastChanged : int with get

Property Value

Type: Int32

Implements

ITextNotifyLastChanged
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Lexer Property

TextSourceLexer Property
Gets or sets object that can perform lexical analysis of the text source content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexer Lexer { get; set; }
Public Overridable Property Lexer As ILexer
    Get
    Set
public:
virtual property ILexer^ Lexer {
    ILexer^ get ();
    void set (ILexer^ value);
}
abstract Lexer : ILexer with get, set
override Lexer : ILexer with get, set

Property Value

Type: ILexer

Implements

ITextParsingLexer
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Lines Property

TextSourceLines Property
Represents the object that implements ITextStrings interface containing collection of strings determining text source content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ITextStrings Lines { get; set; }
Public Overridable Property Lines As ITextStrings
    Get
    Set
public:
virtual property ITextStrings^ Lines {
    ITextStrings^ get ();
    void set (ITextStrings^ value);
}
abstract Lines : ITextStrings with get, set
override Lines : ITextStrings with get, set

Property Value

Type: ITextStrings

Implements

ITextSourceLines
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.LineStyles Property

TextSourceLineStyles Property
Represents an object that implements ILineStyles interface holding collection of line styles for this document.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILineStyles LineStyles { get; set; }
Public Overridable Property LineStyles As ILineStyles
    Get
    Set
public:
virtual property ILineStyles^ LineStyles {
    ILineStyles^ get ();
    void set (ILineStyles^ value);
}
abstract LineStyles : ILineStyles with get, set
override LineStyles : ILineStyles with get, set

Property Value

Type: ILineStyles

Implements

ITextSourceLineStyles
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.LineTerminator Property

TextSourceLineTerminator Property
Gets or sets a string value that terminates line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string LineTerminator { get; set; }
Public Overridable Property LineTerminator As String
    Get
    Set
public:
virtual property String^ LineTerminator {
    String^ get ();
    void set (String^ value);
}
abstract LineTerminator : string with get, set
override LineTerminator : string with get, set

Property Value

Type: String

Implements

ITextExportLineTerminator
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.MatchingBlocks Property

TextSourceMatchingBlocks Property
Gets or sets IRangeList of matching begin/end blocks for Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRangeList MatchingBlocks { get; set; }
Public Overridable Property MatchingBlocks As IRangeList
    Get
    Set
public:
virtual property IRangeList^ MatchingBlocks {
    IRangeList^ get ();
    void set (IRangeList^ value);
}
abstract MatchingBlocks : IRangeList with get, set
override MatchingBlocks : IRangeList with get, set

Property Value

Type: IRangeList
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.MaxLength Property

TextSourceMaxLength Property
Specifies the maximum number of characters that can be entered into the edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MaxLength { get; set; }
Public Overridable Property MaxLength As Integer
    Get
    Set
public:
virtual property int MaxLength {
    int get ();
    void set (int value);
}
abstract MaxLength : int with get, set
override MaxLength : int with get, set

Property Value

Type: Int32

Implements

IEditMaxLength
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Modified Property

TextSourceModified Property
Gets or sets a value indicating whether the control's text content is modified.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Modified { get; set; }
Public Overridable Property Modified As Boolean
    Get
    Set
public:
virtual property bool Modified {
    bool get ();
    void set (bool value);
}
abstract Modified : bool with get, set
override Modified : bool with get, set

Property Value

Type: Boolean

Implements

IEditModified
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ModifiedLineRegions Property

TextSourceModifiedLineRegions Property
Gets modified lines information, grouped in regions.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ModifiedLineRegion> ModifiedLineRegions { get; }
Public ReadOnly Property ModifiedLineRegions As IEnumerable(Of ModifiedLineRegion)
    Get
public:
virtual property IEnumerable<ModifiedLineRegion^>^ ModifiedLineRegions {
    IEnumerable<ModifiedLineRegion^>^ get () sealed;
}
abstract ModifiedLineRegions : IEnumerable<ModifiedLineRegion> with get
override ModifiedLineRegions : IEnumerable<ModifiedLineRegion> with get

Property Value

Type: IEnumerableModifiedLineRegion

Implements

IUndoModifiedLineRegions
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ModifiedLines Property

TextSourceModifiedLines Property
Gets modified lines information.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ModifiedLine> ModifiedLines { get; }
Public ReadOnly Property ModifiedLines As IEnumerable(Of ModifiedLine)
    Get
public:
virtual property IEnumerable<ModifiedLine^>^ ModifiedLines {
    IEnumerable<ModifiedLine^>^ get () sealed;
}
abstract ModifiedLines : IEnumerable<ModifiedLine> with get
override ModifiedLines : IEnumerable<ModifiedLine> with get

Property Value

Type: IEnumerableModifiedLine

Implements

IUndoModifiedLines
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.NavigateOptions Property

TextSourceNavigateOptions Property
Gets or sets navigating options.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual NavigateOptions NavigateOptions { get; set; }
Public Overridable Property NavigateOptions As NavigateOptions
    Get
    Set
public:
virtual property NavigateOptions NavigateOptions {
    NavigateOptions get ();
    void set (NavigateOptions value);
}
abstract NavigateOptions : NavigateOptions with get, set
override NavigateOptions : NavigateOptions with get, set

Property Value

Type: NavigateOptions

Implements

INavigateNavigateOptions
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.OpenBraces Property

TextSourceOpenBraces Property
Gets or sets an array of characters each one representing an open brace.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] OpenBraces { get; set; }
Public Overridable Property OpenBraces As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ OpenBraces {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract OpenBraces : char[] with get, set
override OpenBraces : char[] with get, set

Property Value

Type: Char

Implements

IBraceMatchingOpenBraces
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.OptimizedForMemory Property

TextSourceOptimizedForMemory Property
Specifies whether internal text representation should optimized memory usage.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OptimizedForMemory { get; set; }
Public Property OptimizedForMemory As Boolean
    Get
    Set
public:
virtual property bool OptimizedForMemory {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract OptimizedForMemory : bool with get, set
override OptimizedForMemory : bool with get, set

Property Value

Type: Boolean

Implements

ITextSourceOptimizedForMemory
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Overwrite Property

TextSourceOverwrite Property
Gets or sets a value indicating whether the inserted text overwrites existing text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Overwrite { get; set; }
Public Overridable Property Overwrite As Boolean
    Get
    Set
public:
virtual property bool Overwrite {
    bool get ();
    void set (bool value);
}
abstract Overwrite : bool with get, set
override Overwrite : bool with get, set

Property Value

Type: Boolean

Implements

IEditOverwrite
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ParserLine Property

TextSourceParserLine Property
Gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ParserLine { get; }
Public Overridable ReadOnly Property ParserLine As Integer
    Get
public:
virtual property int ParserLine {
    int get ();
}
abstract ParserLine : int with get
override ParserLine : int with get

Property Value

Type: Int32

Implements

ITextParsingParserLine
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Position Property

TextSourcePosition Property
Gets or sets current position within the control's text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Position { get; set; }
Public Overridable Property Position As Point
    Get
    Set
public:
virtual property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set
override Position : Point with get, set

Property Value

Type: Point

Implements

INavigatePosition
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.PrevPosition Property

TextSourcePrevPosition Property
Gets previous position within the control's text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point PrevPosition { get; }
Public Overridable ReadOnly Property PrevPosition As Point
    Get
public:
virtual property Point PrevPosition {
    Point get ();
}
abstract PrevPosition : Point with get
override PrevPosition : Point with get

Property Value

Type: Point

Implements

INavigatePrevPosition
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ReadOnly Property

TextSourceReadOnly Property
Gets or sets a value indicating whether the control's content is read-only.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReadOnly { get; set; }
Public Overridable Property ReadOnly As Boolean
    Get
    Set
public:
virtual property bool ReadOnly {
    bool get ();
    void set (bool value);
}
abstract ReadOnly : bool with get, set
override ReadOnly : bool with get, set

Property Value

Type: Boolean

Implements

IEditReadOnly
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.RedoList Property

TextSourceRedoList Property
Provides an indexed access to redo data.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IUndoList RedoList { get; }
Public Overridable ReadOnly Property RedoList As IUndoList
    Get
public:
virtual property IUndoList^ RedoList {
    IUndoList^ get ();
}
abstract RedoList : IUndoList with get
override RedoList : IUndoList with get

Property Value

Type: IUndoList

Implements

IUndoRedoList
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.References Property

TextSourceReferences Property
Gets or sets IRangeList of found references for Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRangeList References { get; set; }
Public Overridable Property References As IRangeList
    Get
    Set
public:
virtual property IRangeList^ References {
    IRangeList^ get ();
    void set (IRangeList^ value);
}
abstract References : IRangeList with get, set
override References : IRangeList with get, set

Property Value

Type: IRangeList

Implements

ITextSourceReferences
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SearchResults Property

TextSourceSearchResults Property
Gets or sets IRangeList of search results for Edit control.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRangeList SearchResults { get; set; }
Public Overridable Property SearchResults As IRangeList
    Get
    Set
public:
virtual property IRangeList^ SearchResults {
    IRangeList^ get ();
    void set (IRangeList^ value);
}
abstract SearchResults : IRangeList with get, set
override SearchResults : IRangeList with get, set

Property Value

Type: IRangeList

Implements

ITextSourceSearchResults
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SelectBlockRect Property

TextSourceSelectBlockRect Property
Represents a rectangular block of selected text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle SelectBlockRect { get; }
Public Overridable ReadOnly Property SelectBlockRect As Rectangle
    Get
public:
virtual property Rectangle SelectBlockRect {
    Rectangle get ();
}
abstract SelectBlockRect : Rectangle with get
override SelectBlockRect : Rectangle with get

Property Value

Type: Rectangle

Implements

ITextNotifySelectBlockRect
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SingleLineMode Property

TextSourceSingleLineMode Property
Gets or sets a value indicating whether the control accepts only one line of the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SingleLineMode { get; set; }
Public Overridable Property SingleLineMode As Boolean
    Get
    Set
public:
virtual property bool SingleLineMode {
    bool get ();
    void set (bool value);
}
abstract SingleLineMode : bool with get, set
override SingleLineMode : bool with get, set

Property Value

Type: Boolean

Implements

IEditSingleLineMode
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SpellDelimiters Property

TextSourceSpellDelimiters Property
Gets or sets an array of chars used to separate words in a text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] SpellDelimiters { get; set; }
Public Overridable Property SpellDelimiters As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ SpellDelimiters {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract SpellDelimiters : char[] with get, set
override SpellDelimiters : char[] with get, set

Property Value

Type: Char

Implements

ISpellingSpellDelimiters
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SpellDelimiterString Property

TextSourceSpellDelimiterString Property
Gets or sets Delimiters as a single string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string SpellDelimiterString { get; set; }
Public Overridable Property SpellDelimiterString As String
    Get
    Set
public:
virtual property String^ SpellDelimiterString {
    String^ get ();
    void set (String^ value);
}
abstract SpellDelimiterString : string with get, set
override SpellDelimiterString : string with get, set

Property Value

Type: String

Implements

ISpellingSpellDelimiterString
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SpellTable Property

TextSourceSpellTable Property
Represents a hash table containing delimiters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Hashtable SpellTable { get; }
Public Overridable ReadOnly Property SpellTable As Hashtable
    Get
public:
virtual property Hashtable^ SpellTable {
    Hashtable^ get ();
}
abstract SpellTable : Hashtable with get
override SpellTable : Hashtable with get

Property Value

Type: Hashtable

Implements

ISpellingSpellTable
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.State Property

TextSourceState Property
Gets or sets last changes to the text stored in the text source.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual NotifyState State { get; set; }
Public Overridable Property State As NotifyState
    Get
    Set
public:
virtual property NotifyState State {
    NotifyState get ();
    void set (NotifyState value);
}
abstract State : NotifyState with get, set
override State : NotifyState with get, set

Property Value

Type: NotifyState

Implements

ITextNotifyState
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Strings Property

TextSourceStrings Property
Gets or sets text source content in the form of string array.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(CollectionConverter))]
public virtual string[] Strings { get; set; }
<TypeConverterAttribute(GetType(CollectionConverter))>
Public Overridable Property Strings As String()
    Get
    Set
public:
[TypeConverterAttribute(typeof(CollectionConverter))]
virtual property array<String^>^ Strings {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
[<TypeConverterAttribute(typeof(CollectionConverter))>]
abstract Strings : string[] with get, set
[<TypeConverterAttribute(typeof(CollectionConverter))>]
override Strings : string[] with get, set

Property Value

Type: String
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.StructureGuideLines Property

TextSourceStructureGuideLines Property
Represents a syntax errors collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRangeList StructureGuideLines { get; }
Public ReadOnly Property StructureGuideLines As IRangeList
    Get
public:
property IRangeList^ StructureGuideLines {
    IRangeList^ get ();
}
member StructureGuideLines : IRangeList with get

Property Value

Type: IRangeList
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.SyntaxErrors Property

TextSourceSyntaxErrors Property
Represents a syntax errors collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISyntaxErrors SyntaxErrors { get; }
Public ReadOnly Property SyntaxErrors As ISyntaxErrors
    Get
public:
virtual property ISyntaxErrors^ SyntaxErrors {
    ISyntaxErrors^ get () sealed;
}
abstract SyntaxErrors : ISyntaxErrors with get
override SyntaxErrors : ISyntaxErrors with get

Property Value

Type: ISyntaxErrors

Implements

ITextErrorsSyntaxErrors
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.Text Property

TextSourceText Property
Gets or sets text source content as a single string with the individual strings delimited by carriage returns.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

ITextSourceText
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ThreadAction Property

TextSourceThreadAction Property
Returns method executed in thread when parsing.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadProc ThreadAction { get; }
Public ReadOnly Property ThreadAction As ThreadProc
    Get
public:
virtual property ThreadProc^ ThreadAction {
    ThreadProc^ get () sealed;
}
abstract ThreadAction : ThreadProc with get
override ThreadAction : ThreadProc with get

Property Value

Type: ThreadProc

Implements

ITextSourceThreadAction
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UndoLimit Property

TextSourceUndoLimit Property
Gets or sets a value that limits number of undo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UndoLimit { get; set; }
Public Overridable Property UndoLimit As Integer
    Get
    Set
public:
virtual property int UndoLimit {
    int get ();
    void set (int value);
}
abstract UndoLimit : int with get, set
override UndoLimit : int with get, set

Property Value

Type: Int32

Implements

IUndoUndoLimit
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UndoList Property

TextSourceUndoList Property
Provides an indexed access to undo data.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IUndoList UndoList { get; }
Public Overridable ReadOnly Property UndoList As IUndoList
    Get
public:
virtual property IUndoList^ UndoList {
    IUndoList^ get ();
}
abstract UndoList : IUndoList with get
override UndoList : IUndoList with get

Property Value

Type: IUndoList

Implements

IUndoUndoList
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UndoOptions Property

TextSourceUndoOptions Property
Gets or sets options for undo and redo operations.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual UndoOptions UndoOptions { get; set; }
Public Overridable Property UndoOptions As UndoOptions
    Get
    Set
public:
virtual property UndoOptions UndoOptions {
    UndoOptions get ();
    void set (UndoOptions value);
}
abstract UndoOptions : UndoOptions with get, set
override UndoOptions : UndoOptions with get, set

Property Value

Type: UndoOptions

Implements

IUndoUndoOptions
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UndoUpdateCount Property

TextSourceUndoUpdateCount Property
Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UndoUpdateCount { get; }
Public Overridable ReadOnly Property UndoUpdateCount As Integer
    Get
public:
virtual property int UndoUpdateCount {
    int get ();
}
abstract UndoUpdateCount : int with get
override UndoUpdateCount : int with get

Property Value

Type: Int32

Implements

IUndoUndoUpdateCount
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UpdateCount Property

TextSourceUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UrlTable Property

TextSourceUrlTable Property
Represents hash table containing hyper-text characters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hashtable UrlTable { get; }
Public ReadOnly Property UrlTable As Hashtable
    Get
public:
virtual property Hashtable^ UrlTable {
    Hashtable^ get () sealed;
}
abstract UrlTable : Hashtable with get
override UrlTable : Hashtable with get

Property Value

Type: Hashtable

Implements

IHyperTextUrlTable
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource Events

TextSource Events

The TextSource type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | HyperText | Occurs when a control needs checking whether some string represents hypertext.
Public event | UndoEvent | Occurs when undo/redo operation performed.
Public event | WordSpell | Occurs when spelling of some word within the text needs checking.
Top
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.HyperText Event

TextSourceHyperText Event
Occurs when a control needs checking whether some string represents hypertext.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event HyperTextEvent HyperText
Public Event HyperText As HyperTextEvent
public:
virtual  event HyperTextEvent^ HyperText {
    void add (HyperTextEvent^ value);
    void remove (HyperTextEvent^ value);
}
abstract HyperText : IEvent<HyperTextEvent,
    HyperTextEventArgs>
override HyperText : IEvent<HyperTextEvent,
    HyperTextEventArgs>

Value

Type: Alternet.Editor.TextSourceHyperTextEvent

Implements

IHyperTextHyperText
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.UndoEvent Event

TextSourceUndoEvent Event
Occurs when undo/redo operation performed.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event UndoEvent UndoEvent
Public Event UndoEvent As UndoEvent
public:
virtual  event UndoEvent^ UndoEvent {
    void add (UndoEvent^ value);
    void remove (UndoEvent^ value);
}
abstract UndoEvent : IEvent<UndoEvent,
    UndoEventArgs>
override UndoEvent : IEvent<UndoEvent,
    UndoEventArgs>

Value

Type: Alternet.Editor.TextSourceUndoEvent

Implements

IUndoUndoEvent
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.WordSpell Event

TextSourceWordSpell Event
Occurs when spelling of some word within the text needs checking.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event WordSpellEvent WordSpell
Public Event WordSpell As WordSpellEvent
public:
virtual  event WordSpellEvent^ WordSpell {
    void add (WordSpellEvent^ value);
    void remove (WordSpellEvent^ value);
}
abstract WordSpell : IEvent<WordSpellEvent,
    WordSpellEventArgs>
override WordSpell : IEvent<WordSpellEvent,
    WordSpellEventArgs>

Value

Type: Alternet.Editor.TextSourceWordSpellEvent

Implements

ISpellingWordSpell
See Also

Reference

TextSource Class
Alternet.Editor.TextSource Namespace


TextSource.ContentDividers Class

TextSourceContentDividers Class
Inheritance Hierarchy
SystemObject
System.Collections.GenericListInt32
Alternet.CommonSortList Int32
Alternet.Editor.TextSourceTextSourceContentDividers

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ContentDividers : SortList<int>
Public Class ContentDividers
    Inherits SortList(Of Integer)
public ref class ContentDividers : public SortList<int>
type ContentDividers =
    class
        inherit SortList<int>
    end

The TextSourceContentDividers type exposes the following members.

Constructors
 | Name | Description
Public method | TextSourceContentDividers | Initializes a new instance of the TextSourceContentDividers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListInt32.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListInt32.)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListInt32.)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListInt32.)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListInt32.)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListInt32.)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListInt32.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListInt32.)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListInt32.)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListInt32.)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListInt32.)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListInt32.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists(PredicateT) | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListInt32.)
Public method | Exists(Int32) |
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListInt32.)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListInt32.)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListInt32.)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListInt32.)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListInt32.)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListInt32.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListInt32.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListInt32.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListInt32.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListInt32.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListInt32.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListInt32.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListInt32.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListInt32.)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged |
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListInt32.)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListInt32.)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListInt32.)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListInt32.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListInt32.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListInt32.)
Public method | Sort |
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListInt32.)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListInt32.)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListInt32.)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListInt32.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListInt32.)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListInt32.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListInt32.)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListInt32.)
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


TextSource.ContentDividers Constructor

TextSourceContentDividers Constructor
Initializes a new instance of the TextSourceContentDividers class

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContentDividers()
Public Sub New
public:
ContentDividers()
new : unit -> ContentDividers
See Also

Reference

TextSourceContentDividers Class
Alternet.Editor.TextSource Namespace


ContentDividers Methods

ContentDividers Methods

The TextSourceContentDividers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListInt32.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListInt32.)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListInt32.)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListInt32.)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListInt32.)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListInt32.)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListInt32.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListInt32.)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListInt32.)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListInt32.)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListInt32.)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListInt32.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists(PredicateT) | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListInt32.)
Public method | Exists(Int32) |
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListInt32.)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListInt32.)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListInt32.)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListInt32.)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListInt32.)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListInt32.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListInt32.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListInt32.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListInt32.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListInt32.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListInt32.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListInt32.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListInt32.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListInt32.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListInt32.)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged |
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListInt32.)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListInt32.)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListInt32.)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListInt32.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListInt32.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListInt32.)
Public method | Sort |
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListInt32.)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListInt32.)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListInt32.)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListInt32.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListInt32.)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListInt32.)
Top
See Also

Reference

TextSourceContentDividers Class
Alternet.Editor.TextSource Namespace


ContentDividers.Exists Method

ContentDividersExists Method
Overload List
 | Name | Description
Public method | Exists(PredicateT) | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListInt32.)
Public method | Exists(Int32) |
Top
See Also

Reference

TextSourceContentDividers Class
Alternet.Editor.TextSource Namespace


TextSource.ContentDividers.Exists Method (Int32)

TextSourceContentDividersExists Method (Int32)

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Exists(
    int index
)
Public Function Exists (
    index As Integer
) As Boolean
public:
bool Exists(
    int index
)
member Exists :
        index : int -> bool

Parameters

index
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

TextSourceContentDividers Class
Exists Overload
Alternet.Editor.TextSource Namespace


TextSource.ContentDividers.PositionChanged Method

TextSourceContentDividersPositionChanged Method

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaX
Type: SystemInt32
deltaY
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

TextSourceContentDividers Class
Alternet.Editor.TextSource Namespace


ContentDividers.Sort Method

ContentDividersSort Method
Overload List
 | Name | Description
Public method | Sort |
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListInt32.)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListInt32.)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListInt32.)
Top
See Also

Reference

TextSourceContentDividers Class
Alternet.Editor.TextSource Namespace


TextSource.ContentDividers.Sort Method

TextSourceContentDividersSort Method

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Sort()
Public Sub Sort
public:
void Sort()
member Sort : unit -> unit
See Also

Reference

TextSourceContentDividers Class
Sort Overload
Alternet.Editor.TextSource Namespace


ContentDividers Properties

ContentDividers Properties

The TextSourceContentDividers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListInt32.)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListInt32.)
Top
See Also

Reference

TextSourceContentDividers Class
Alternet.Editor.TextSource Namespace


TextStrings Class

TextStrings Class
Specifies collection of lines with extended possibilities.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TextSourceTextStrings

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextStrings : ITextStrings,
    IStringListWithItem, IStringList, IList<string>, ICollection<string>,
    IEnumerable<string>, IEnumerable, IImport, IExport,
    ITextExport, ITextImport, ITextSearch, ITabulation, IWordBreak,
    INotify, IUpdate
Public Class TextStrings
    Implements ITextStrings, IStringListWithItem, IStringList, IList(Of String),
    ICollection(Of String), IEnumerable(Of String), IEnumerable,
    IImport, IExport, ITextExport, ITextImport, ITextSearch,
    ITabulation, IWordBreak, INotify, IUpdate
public ref class TextStrings : ITextStrings,
    IStringListWithItem, IStringList, IList<String^>, ICollection<String^>,
    IEnumerable<String^>, IEnumerable, IImport, IExport,
    ITextExport, ITextImport, ITextSearch, ITabulation, IWordBreak,
    INotify, IUpdate
type TextStrings =
    class
        interface ITextStrings
        interface IStringListWithItem
        interface IStringList
        interface IList<string>
        interface ICollection<string>
        interface IEnumerable<string>
        interface IEnumerable
        interface IImport
        interface IExport
        interface ITextExport
        interface ITextImport
        interface ITextSearch
        interface ITabulation
        interface IWordBreak
        interface INotify
        interface IUpdate
    end

The TextStrings type exposes the following members.

Constructors
 | Name | Description
Public method | TextStrings | Initializes a new instance of the TextStrings class with default settings.
Public method | TextStrings(ITextSource) | Initializes a new instance of the TextStrings class with specified parameters.
Top
Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint(Int32) | Converts given absolute position to position as Point value.
 | AbsolutePositionToTextPoint(IListString, Int32, String) | Converts given absolute position to position as Point value.
Public method | Add | Adds a new item to the end of string collection.
Public method | AddNotifier | Adds new handler to respond for notification.
Public method | AfterSave | Performs additional actions after TextStrings saves its content to the file.
Public method | Assign | Copies the contents from another ITextStrings object.
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | Changed(Int32) | Notifies about string state changing.
Public method | Changed(Int32, Int32) | Notifies about string state changing.
Public method | Clear | Removes all items from string collection.
Public method | Contains | Indicates whether string collection contains specified string.
Public method | CopyTo | Copies the entire string collection to a another array, starting at the specified index of the target array.
Public method | CreateStringItem | Creates a new IStringItem object containing specified text.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Find(String, SearchOptions, Regex, Point, Int32, Match) | Searches for given text.
 | Find(IStringList, Hashtable, String, SearchOptions, Regex, Point, Int32, Match, String) | Searches for given text.
Public method | GetCharAt(Point) | Returns character from specified position.
Public method | GetCharAt(Int32, Int32) | Returns character from specified position.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString(Int32, Int32) | Returns indentation string which consist of tabs and spaces.
Public method | GetIndentString(Int32, Int32, Boolean) | Returns indentation string which consist of tabs and spaces.
Public method | GetItem | Returns the IStringItem object at the given position of the collection.
Public method | GetLength | Returns length of the string that corresponds to specified item in the collection.
Public method | GetLexStyle | Returns lexical style at specified position.
Public method | GetPrevTabStop | Returns number of spaces to the previous TabStop.
Public method | GetTabStop | Returns number of spaces to the next TabStop at the specified position.
Public method | GetTabString(String) | Converts all tab character to spaces depending on TabStops property.
Public method | GetTabString(String, ITextUndoList) | Converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTabString(String, StringItemInfo, Boolean, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on TabStops property.
Public method | GetTextAt(Point) | Returns word at the specific text position.
Public method | GetTextAt(Int32, Int32) | Returns word at the specific text position.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWord(Int32, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Char) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | Returns word start and end, if there is word at the specified position.
Public method | IndexOf | Returns the index of the first occurrence of given string in the string collection.
Public method | Insert | Inserts value at the specified position.
Public method | IsDelimiter(Char) | Indicates whether the specified character is delimiter character.
Public method | IsDelimiter(Int32, Int32) | Indicates whether the character at the specific position of the string collection is delimiter character.
Public method | IsDelimiter(String, Int32) | Indicates whether the character at the specific position of given string is a delimiter character.
 | IsWhitespace(Char) | Indicates whether the character at the specific position of the string collection is a whitespace character.
Public method | IsWhitespace(String, Int32) | Indicates whether the character at the specific position of the string collection is a whitespace character.
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified exporter.
Public method | LoadFile(String, Encoding) | Loads content from the given file with specific encoding.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Public method | Notify | Notifies all notifiers about updating object state.
Public method | PosToTabPos(String, Int32) | Returns specified position within given string as tabbed position.
Public method | PosToTabPos(String, Int32, Boolean) | Returns specified position within given string as tabbed position.
Public method | PosToTabPosOriginal |
Public method | Remove | Removes the first occurrence of given string from the string collection.
Public method | RemoveAt | Removes string item at specified position.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list.
Public method | ResetDelimiters | Resets the Delimiters to the default value.
Public method | ResetTabStops | Resets the TabStops to the default value.
Public method | ResetUseSpaces | Resets the UseSpaces to the default value.
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specified exporter.
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves content to the given file with specified exported and specific encoding.
Public method | SaveStream(Stream) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the given stream with specified exporter.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the given stream with specified exporter.
Public method | SetTextAndData | Sets the text and color data at the same time.
Public method | TabPosToPos | Returns specified position within given string as untabbed position.
Public method | TextPointToAbsolutePosition(Point) | Converts given Point value to the absolute position.
 | TextPointToAbsolutePosition(IListString, Point, String) | Converts given Point value to the absolute position.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates an object state.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Represents number of strings in the collection.
Public property | Delimiters | Gets or sets an array of characters used as delimiters between words in the text.
Public property | DelimiterString | Gets or sets Delimiters as a single string.
Public property | DelimTable | Represents delimiters as a key-and-value pairs collection where each key is a single delimiter character.
Public property | FirstChanged | Represents number of the first changed line.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | Item | Provides an indexed access to individual string stored in the collection.
Public property | LastChanged | Represents number of the last changed line.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | Owner | Gets or set the ISyntaxEdit control that owns this collection.
Public property | RemoveTrailingSpaces | Gets or set a boolean value that indicates whether TextStrings should remove trailing spaces from the end of each its strings.
Public property | Source | Gets the text source owning the TextStrings.
Public property | TabStops | Gets or sets the character columns that the cursor will move to each time you press Tab.
Public property | Text | Gets or sets the strings in the ITextStrings as a single string with the individual strings delimited by carriage returns.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UseSpaces | Gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


TextStrings Constructor

TextStrings Constructor
Overload List
 | Name | Description
Public method | TextStrings | Initializes a new instance of the TextStrings class with default settings.
Public method | TextStrings(ITextSource) | Initializes a new instance of the TextStrings class with specified parameters.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings Constructor

TextStrings Constructor
Initializes a new instance of the TextStrings class with default settings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextStrings()
Public Sub New
public:
TextStrings()
new : unit -> TextStrings
See Also

Reference

TextStrings Class
TextStrings Overload
Alternet.Editor.TextSource Namespace


TextStrings Constructor (ITextSource)

TextStrings Constructor (ITextSource)
Initializes a new instance of the TextStrings class with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextStrings(
    ITextSource source
)
Public Sub New (
    source As ITextSource
)
public:
TextStrings(
    ITextSource^ source
)
new :
        source : ITextSource -> TextStrings

Parameters

source
Type: Alternet.Editor.TextSourceITextSource
ITextSource that contains this collection of lines.
See Also

Reference

TextStrings Class
TextStrings Overload
Alternet.Editor.TextSource Namespace


TextStrings Methods

TextStrings Methods

The TextStrings type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint(Int32) | Converts given absolute position to position as Point value.
 | AbsolutePositionToTextPoint(IListString, Int32, String) | Converts given absolute position to position as Point value.
Public method | Add | Adds a new item to the end of string collection.
Public method | AddNotifier | Adds new handler to respond for notification.
Public method | AfterSave | Performs additional actions after TextStrings saves its content to the file.
Public method | Assign | Copies the contents from another ITextStrings object.
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | Changed(Int32) | Notifies about string state changing.
Public method | Changed(Int32, Int32) | Notifies about string state changing.
Public method | Clear | Removes all items from string collection.
Public method | Contains | Indicates whether string collection contains specified string.
Public method | CopyTo | Copies the entire string collection to a another array, starting at the specified index of the target array.
Public method | CreateStringItem | Creates a new IStringItem object containing specified text.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Find(String, SearchOptions, Regex, Point, Int32, Match) | Searches for given text.
 | Find(IStringList, Hashtable, String, SearchOptions, Regex, Point, Int32, Match, String) | Searches for given text.
Public method | GetCharAt(Point) | Returns character from specified position.
Public method | GetCharAt(Int32, Int32) | Returns character from specified position.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString(Int32, Int32) | Returns indentation string which consist of tabs and spaces.
Public method | GetIndentString(Int32, Int32, Boolean) | Returns indentation string which consist of tabs and spaces.
Public method | GetItem | Returns the IStringItem object at the given position of the collection.
Public method | GetLength | Returns length of the string that corresponds to specified item in the collection.
Public method | GetLexStyle | Returns lexical style at specified position.
Public method | GetPrevTabStop | Returns number of spaces to the previous TabStop.
Public method | GetTabStop | Returns number of spaces to the next TabStop at the specified position.
Public method | GetTabString(String) | Converts all tab character to spaces depending on TabStops property.
Public method | GetTabString(String, ITextUndoList) | Converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTabString(String, StringItemInfo, Boolean, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on TabStops property.
Public method | GetTextAt(Point) | Returns word at the specific text position.
Public method | GetTextAt(Int32, Int32) | Returns word at the specific text position.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWord(Int32, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Char) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | Returns word start and end, if there is word at the specified position.
Public method | IndexOf | Returns the index of the first occurrence of given string in the string collection.
Public method | Insert | Inserts value at the specified position.
Public method | IsDelimiter(Char) | Indicates whether the specified character is delimiter character.
Public method | IsDelimiter(Int32, Int32) | Indicates whether the character at the specific position of the string collection is delimiter character.
Public method | IsDelimiter(String, Int32) | Indicates whether the character at the specific position of given string is a delimiter character.
 | IsWhitespace(Char) | Indicates whether the character at the specific position of the string collection is a whitespace character.
Public method | IsWhitespace(String, Int32) | Indicates whether the character at the specific position of the string collection is a whitespace character.
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified exporter.
Public method | LoadFile(String, Encoding) | Loads content from the given file with specific encoding.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Public method | Notify | Notifies all notifiers about updating object state.
Public method | PosToTabPos(String, Int32) | Returns specified position within given string as tabbed position.
Public method | PosToTabPos(String, Int32, Boolean) | Returns specified position within given string as tabbed position.
Public method | PosToTabPosOriginal |
Public method | Remove | Removes the first occurrence of given string from the string collection.
Public method | RemoveAt | Removes string item at specified position.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list.
Public method | ResetDelimiters | Resets the Delimiters to the default value.
Public method | ResetTabStops | Resets the TabStops to the default value.
Public method | ResetUseSpaces | Resets the UseSpaces to the default value.
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specified exporter.
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves content to the given file with specified exported and specific encoding.
Public method | SaveStream(Stream) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the given stream with specified exporter.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the given stream with specified exporter.
Public method | SetTextAndData | Sets the text and color data at the same time.
Public method | TabPosToPos | Returns specified position within given string as untabbed position.
Public method | TextPointToAbsolutePosition(Point) | Converts given Point value to the absolute position.
 | TextPointToAbsolutePosition(IListString, Point, String) | Converts given Point value to the absolute position.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates an object state.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.AbsolutePositionToTextPoint Method

TextStringsAbsolutePositionToTextPoint Method
Overload List
 | Name | Description
Public method | AbsolutePositionToTextPoint(Int32) | Converts given absolute position to position as Point value.
 | AbsolutePositionToTextPoint(IListString, Int32, String) | Converts given absolute position to position as Point value.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.AbsolutePositionToTextPoint Method (Int32)

TextStringsAbsolutePositionToTextPoint Method (Int32)
Converts given absolute position to position as Point value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point AbsolutePositionToTextPoint(
    int position
)
Public Overridable Function AbsolutePositionToTextPoint (
    position As Integer
) As Point
public:
virtual Point AbsolutePositionToTextPoint(
    int position
)
abstract AbsolutePositionToTextPoint :
        position : int -> Point
override AbsolutePositionToTextPoint :
        position : int -> Point

Parameters

position
Type: SystemInt32
Specifies index of character if the text considered as a single string.

Return Value

Type: Point
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Implements

ITextStringsAbsolutePositionToTextPoint(Int32)
See Also

Reference

TextStrings Class
AbsolutePositionToTextPoint Overload
Alternet.Editor.TextSource Namespace


TextStrings.AbsolutePositionToTextPoint Method (IList(String), Int32, String)

TextStringsAbsolutePositionToTextPoint Method (IListString, Int32, String)
Converts given absolute position to position as Point value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point AbsolutePositionToTextPoint(
    IList<string> list,
    int position,
    string lineTerminator
)
Public Shared Function AbsolutePositionToTextPoint (
    list As IList(Of String),
    position As Integer,
    lineTerminator As String
) As Point
public:
static Point AbsolutePositionToTextPoint(
    IList<String^>^ list,
    int position,
    String^ lineTerminator
)
static member AbsolutePositionToTextPoint :
        list : IList<string> *
        position : int *
        lineTerminator : string -> Point

Parameters

list
Type: System.Collections.GenericIListString
Strings collection to convert.
position
Type: SystemInt32
Specifies index of character if the text considered as a single string.
lineTerminator
Type: SystemString
Specifies line terminator.

Return Value

Type: Point
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.
See Also

Reference

TextStrings Class
AbsolutePositionToTextPoint Overload
Alternet.Editor.TextSource Namespace


TextStrings.Add Method

TextStringsAdd Method
Adds a new item to the end of string collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    string item
)
Public Overridable Sub Add (
    item As String
)
public:
virtual void Add(
    String^ item
)
abstract Add :
        item : string -> unit
override Add :
        item : string -> unit

Parameters

item
Type: SystemString
String to be added to the end of the collection.

Implements

ICollectionTAdd(T)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.AddNotifier Method

TextStringsAddNotifier Method
Adds new handler to respond for notification.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddNotifier(
    INotifier sender
)
Public Overridable Sub AddNotifier (
    sender As INotifier
)
public:
virtual void AddNotifier(
    INotifier^ sender
)
abstract AddNotifier :
        sender : INotifier -> unit
override AddNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.

Implements

INotifyAddNotifier(INotifier)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.AfterSave Method

TextStringsAfterSave Method
Performs additional actions after TextStrings saves its content to the file.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AfterSave()
Public Overridable Sub AfterSave
public:
virtual void AfterSave()
abstract AfterSave : unit -> unit
override AfterSave : unit -> unit

Implements

ITextStringsAfterSave
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Assign Method

TextStringsAssign Method
Copies the contents from another ITextStrings object.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ITextStrings source
)
Public Overridable Sub Assign (
    source As ITextStrings
)
public:
virtual void Assign(
    ITextStrings^ source
)
abstract Assign :
        source : ITextStrings -> unit
override Assign :
        source : ITextStrings -> unit

Parameters

source
Type: Alternet.Editor.TextSourceITextStrings
Specifies ITextStrings to assign.

Implements

ITextStringsAssign(ITextStrings)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.BeginUpdate Method

TextStringsBeginUpdate Method
Prevents object state updating until calling EndUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Changed Method

TextStringsChanged Method
Overload List
 | Name | Description
Public method | Changed(Int32) | Notifies about string state changing.
Public method | Changed(Int32, Int32) | Notifies about string state changing.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Changed Method (Int32)

TextStringsChanged Method (Int32)
Notifies about string state changing.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Changed(
    int index
)
Public Overridable Sub Changed (
    index As Integer
)
public:
virtual void Changed(
    int index
)
abstract Changed :
        index : int -> unit
override Changed :
        index : int -> unit

Parameters

index
Type: SystemInt32
Index of string to update.

Implements

ITextStringsChanged(Int32)
See Also

Reference

TextStrings Class
Changed Overload
Alternet.Editor.TextSource Namespace


TextStrings.Changed Method (Int32, Int32)

TextStringsChanged Method (Int32, Int32)
Notifies about string state changing.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Changed(
    int first,
    int last
)
Public Overridable Sub Changed (
    first As Integer,
    last As Integer
)
public:
virtual void Changed(
    int first,
    int last
)
abstract Changed :
        first : int *
        last : int -> unit
override Changed :
        first : int *
        last : int -> unit

Parameters

first
Type: SystemInt32
Index of the first string to update.
last
Type: SystemInt32
Index of the last string to update.

Implements

ITextStringsChanged(Int32, Int32)
See Also

Reference

TextStrings Class
Changed Overload
Alternet.Editor.TextSource Namespace


TextStrings.Clear Method

TextStringsClear Method
Removes all items from string collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICollectionTClear
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Contains Method

TextStringsContains Method
Indicates whether string collection contains specified string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    string item
)
Public Overridable Function Contains (
    item As String
) As Boolean
public:
virtual bool Contains(
    String^ item
)
abstract Contains :
        item : string -> bool
override Contains :
        item : string -> bool

Parameters

item
Type: SystemString
String to check.

Return Value

Type: Boolean
True if contains; otherwise false.

Implements

ICollectionTContains(T)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.CopyTo Method

TextStringsCopyTo Method
Copies the entire string collection to a another array, starting at the specified index of the target array.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CopyTo(
    string[] array,
    int arrayIndex
)
Public Overridable Sub CopyTo (
    array As String(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<String^>^ array,
    int arrayIndex
)
abstract CopyTo :
        array : string[] *
        arrayIndex : int -> unit
override CopyTo :
        array : string[] *
        arrayIndex : int -> unit

Parameters

array
Type: SystemString
The Array that is the destination of the elements copied from string collection.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.CreateStringItem Method

TextStringsCreateStringItem Method
Creates a new IStringItem object containing specified text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IStringItem CreateStringItem(
    string s
)
Public Overridable Function CreateStringItem (
    s As String
) As IStringItem
public:
virtual IStringItem^ CreateStringItem(
    String^ s
)
abstract CreateStringItem :
        s : string -> IStringItem
override CreateStringItem :
        s : string -> IStringItem

Parameters

s
Type: SystemString
String placed into a new IStringItem object.

Return Value

Type: IStringItem
New IStringItem object.
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.DisableUpdate Method

TextStringsDisableUpdate Method
Prevents object state updating until calling EnableUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.EnableUpdate Method

TextStringsEnableUpdate Method
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.EndUpdate Method

TextStringsEndUpdate Method
Re-enables object state updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Find Method

TextStringsFind Method
Overload List
 | Name | Description
Public method | Find(String, SearchOptions, Regex, Point, Int32, Match) | Searches for given text.
 | Find(IStringList, Hashtable, String, SearchOptions, Regex, Point, Int32, Match, String) | Searches for given text.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Find Method (String, SearchOptions, Regex, Point, Int32, Match)

TextStringsFind Method (String, SearchOptions, Regex, Point, Int32, Match)
Searches for given text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Find(
    string s,
    SearchOptions options,
    Regex expression,
    ref Point position,
    out int len,
    out Match match
)
Public Overridable Function Find (
    s As String,
    options As SearchOptions,
    expression As Regex,
    ByRef position As Point,
    <OutAttribute> ByRef len As Integer,
    <OutAttribute> ByRef match As Match
) As Boolean
public:
virtual bool Find(
    String^ s,
    SearchOptions options,
    Regex^ expression,
    Point% position,
    [OutAttribute] int% len,
    [OutAttribute] Match^% match
)
abstract Find :
        s : string *
        options : SearchOptions *
        expression : Regex *
        position : Point byref *
        len : int byref *
        match : Match byref -> bool
override Find :
        s : string *
        options : SearchOptions *
        expression : Regex *
        position : Point byref *
        len : int byref *
        match : Match byref -> bool

Parameters

s
Type: SystemString
The text to locate in the collection.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
position
Type: System.DrawingPoint
Position in strings collection to start search.
len
Type: SystemInt32
Receives length of the found text.
match
Type: System.Text.RegularExpressionsMatch
Receives match if regular expression search successful.

Return Value

Type: Boolean
True if search succeed; otherwise false.

Implements

ITextSearchFind(String, SearchOptions, Regex, Point, Int32, Match)
Remarks
If search succeed Position parameter receive location of the found text.
See Also

Reference

TextStrings Class
Find Overload
Alternet.Editor.TextSource Namespace


TextStrings.Find Method (IStringList, Hashtable, String, SearchOptions, Regex, Point, Int32, Match, String)

TextStringsFind Method (IStringList, Hashtable, String, SearchOptions, Regex, Point, Int32, Match, String)
Searches for given text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Find(
    IStringList list,
    Hashtable delimTable,
    string s,
    SearchOptions options,
    Regex expression,
    ref Point position,
    out int len,
    out Match match,
    string lineTerminator
)
Public Shared Function Find (
    list As IStringList,
    delimTable As Hashtable,
    s As String,
    options As SearchOptions,
    expression As Regex,
    ByRef position As Point,
    <OutAttribute> ByRef len As Integer,
    <OutAttribute> ByRef match As Match,
    lineTerminator As String
) As Boolean
public:
static bool Find(
    IStringList^ list,
    Hashtable^ delimTable,
    String^ s,
    SearchOptions options,
    Regex^ expression,
    Point% position,
    [OutAttribute] int% len,
    [OutAttribute] Match^% match,
    String^ lineTerminator
)
static member Find :
        list : IStringList *
        delimTable : Hashtable *
        s : string *
        options : SearchOptions *
        expression : Regex *
        position : Point byref *
        len : int byref *
        match : Match byref *
        lineTerminator : string -> bool

Parameters

list
Type: Alternet.SyntaxIStringList
IStringList collection to find from.
delimTable
Type: System.CollectionsHashtable
Specifies collection of characters that is used as word delimiters.
s
Type: SystemString
The text to locate in the collection.
options
Type: Alternet.Editor.TextSourceSearchOptions
Specifies parameters of search.
expression
Type: System.Text.RegularExpressionsRegex
Represents a regular expression to find text.
position
Type: System.DrawingPoint
Position in strings collection to start search.
len
Type: SystemInt32
Receives length of the found text.
match
Type: System.Text.RegularExpressionsMatch
Receives match if regular expression search successful.
lineTerminator
Type: SystemString
Specifies line terminator.

Return Value

Type: Boolean
True if search succeed; otherwise false.
Remarks
If search succeed Position parameter receive location of the found text.
See Also

Reference

TextStrings Class
Find Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetCharAt Method

TextStringsGetCharAt Method
Overload List
 | Name | Description
Public method | GetCharAt(Point) | Returns character from specified position.
Public method | GetCharAt(Int32, Int32) | Returns character from specified position.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetCharAt Method (Point)

TextStringsGetCharAt Method (Point)
Returns character from specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char GetCharAt(
    Point position
)
Public Overridable Function GetCharAt (
    position As Point
) As Char
public:
virtual wchar_t GetCharAt(
    Point position
)
abstract GetCharAt :
        position : Point -> char
override GetCharAt :
        position : Point -> char

Parameters

position
Type: System.DrawingPoint
Position of character where Y is index of item in string collection and X is index of character in this string.

Return Value

Type: Char
Character from specified position.

Implements

ITextStringsGetCharAt(Point)
See Also

Reference

TextStrings Class
GetCharAt Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetCharAt Method (Int32, Int32)

TextStringsGetCharAt Method (Int32, Int32)
Returns character from specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char GetCharAt(
    int x,
    int y
)
Public Overridable Function GetCharAt (
    x As Integer,
    y As Integer
) As Char
public:
virtual wchar_t GetCharAt(
    int x,
    int y
)
abstract GetCharAt :
        x : int *
        y : int -> char
override GetCharAt :
        x : int *
        y : int -> char

Parameters

x
Type: SystemInt32
Specifies position of character in string.
y
Type: SystemInt32
Specifies index of item in string collection.

Return Value

Type: Char
Character from specified position.

Implements

ITextStringsGetCharAt(Int32, Int32)
See Also

Reference

TextStrings Class
GetCharAt Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetEnumerator Method

TextStringsGetEnumerator Method
Returns an enumerator that iterates through a collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<string> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of String)
public:
virtual IEnumerator<String^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<string>
override GetEnumerator : unit -> IEnumerator<string>

Return Value

Type: IEnumeratorString
A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetIndentString Method

TextStringsGetIndentString Method
Overload List
 | Name | Description
Public method | GetIndentString(Int32, Int32) | Returns indentation string which consist of tabs and spaces.
Public method | GetIndentString(Int32, Int32, Boolean) | Returns indentation string which consist of tabs and spaces.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetIndentString Method (Int32, Int32)

TextStringsGetIndentString Method (Int32, Int32)
Returns indentation string which consist of tabs and spaces.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetIndentString(
    int count,
    int pos
)
Public Overridable Function GetIndentString (
    count As Integer,
    pos As Integer
) As String
public:
virtual String^ GetIndentString(
    int count,
    int pos
)
abstract GetIndentString :
        count : int *
        pos : int -> string
override GetIndentString :
        count : int *
        pos : int -> string

Parameters

count
Type: SystemInt32
Specifies number of characters in the string.
pos
Type: SystemInt32
Specifies start position of the string.

Return Value

Type: String
Indented string that containing tabs and spaces.

Implements

ITabulationGetIndentString(Int32, Int32)
See Also

Reference

TextStrings Class
GetIndentString Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetIndentString Method (Int32, Int32, Boolean)

TextStringsGetIndentString Method (Int32, Int32, Boolean)
Returns indentation string which consist of tabs and spaces.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetIndentString(
    int count,
    int p,
    bool useSpaces
)
Public Overridable Function GetIndentString (
    count As Integer,
    p As Integer,
    useSpaces As Boolean
) As String
public:
virtual String^ GetIndentString(
    int count,
    int p,
    bool useSpaces
)
abstract GetIndentString :
        count : int *
        p : int *
        useSpaces : bool -> string
override GetIndentString :
        count : int *
        p : int *
        useSpaces : bool -> string

Parameters

count
Type: SystemInt32
Specifies number of characters in the string.
p
Type: SystemInt32
Specifies start position of the string.
useSpaces
Type: SystemBoolean
Specifies that spaces should be used instead of tab characters.

Return Value

Type: String
Indented string that containing tabs and spaces.

Implements

ITabulationGetIndentString(Int32, Int32, Boolean)
See Also

Reference

TextStrings Class
GetIndentString Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetItem Method

TextStringsGetItem Method
Returns the IStringItem object at the given position of the collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IStringItem GetItem(
    int index
)
Public Overridable Function GetItem (
    index As Integer
) As IStringItem
public:
virtual IStringItem^ GetItem(
    int index
)
abstract GetItem :
        index : int -> IStringItem
override GetItem :
        index : int -> IStringItem

Parameters

index
Type: SystemInt32
Index of item in the collection.

Return Value

Type: IStringItem
IStringItem object at specified position.

Implements

IStringListWithItemGetItem(Int32)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetLength Method

TextStringsGetLength Method
Returns length of the string that corresponds to specified item in the collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetLength(
    int index
)
Public Overridable Function GetLength (
    index As Integer
) As Integer
public:
virtual int GetLength(
    int index
)
abstract GetLength :
        index : int -> int
override GetLength :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of item in the collection.

Return Value

Type: Int32
If collection do not contain specified item method returns 0.

Implements

ITextStringsGetLength(Int32)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetLexStyle Method

TextStringsGetLexStyle Method
Returns lexical style at specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual StringItemInfo GetLexStyle(
    Point position
)
Public Overridable Function GetLexStyle (
    position As Point
) As StringItemInfo
public:
virtual StringItemInfo GetLexStyle(
    Point position
)
abstract GetLexStyle :
        position : Point -> StringItemInfo
override GetLexStyle :
        position : Point -> StringItemInfo

Parameters

position
Type: System.DrawingPoint
Position of style where Y is index of item in string collection and X is index of character in this string.

Return Value

Type: StringItemInfo
Lexical style at specified position.

Implements

ITextStringsGetLexStyle(Point)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetPrevTabStop Method

TextStringsGetPrevTabStop Method
Returns number of spaces to the previous TabStop.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPrevTabStop(
    int pos
)
Public Overridable Function GetPrevTabStop (
    pos As Integer
) As Integer
public:
virtual int GetPrevTabStop(
    int pos
)
abstract GetPrevTabStop :
        pos : int -> int
override GetPrevTabStop :
        pos : int -> int

Parameters

pos
Type: SystemInt32
Position to check.

Return Value

Type: Int32
Number of spaces.

Implements

ITabulationGetPrevTabStop(Int32)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetTabStop Method

TextStringsGetTabStop Method
Returns number of spaces to the next TabStop at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetTabStop(
    int pos
)
Public Overridable Function GetTabStop (
    pos As Integer
) As Integer
public:
virtual int GetTabStop(
    int pos
)
abstract GetTabStop :
        pos : int -> int
override GetTabStop :
        pos : int -> int

Parameters

pos
Type: SystemInt32
Position to check.

Return Value

Type: Int32
Number of spaces.

Implements

ITabulationGetTabStop(Int32)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetTabString Method

TextStringsGetTabString Method
Overload List
 | Name | Description
Public method | GetTabString(String) | Converts all tab character to spaces depending on TabStops property.
Public method | GetTabString(String, ITextUndoList) | Converts all tab character to spaces depending on ITabulation.TabStops property.
Public method | GetTabString(String, StringItemInfo, Boolean, ITextUndoList) | When implemented by a class, converts all tab character to spaces depending on TabStops property.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetTabString Method (String)

TextStringsGetTabString Method (String)
Converts all tab character to spaces depending on TabStops property.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTabString(
    string s
)
Public Overridable Function GetTabString (
    s As String
) As String
public:
virtual String^ GetTabString(
    String^ s
)
abstract GetTabString :
        s : string -> string
override GetTabString :
        s : string -> string

Parameters

s
Type: SystemString
Text to convert.

Return Value

Type: String
Tabbed string.

Implements

ITabulationGetTabString(String)
See Also

Reference

TextStrings Class
GetTabString Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetTabString Method (String, ITextUndoList)

TextStringsGetTabString Method (String, ITextUndoList)
Converts all tab character to spaces depending on ITabulation.TabStops property.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GetTabString(
    string s,
    ITextUndoList operations
)
Public Overridable Sub GetTabString (
    s As String,
    operations As ITextUndoList
)
public:
virtual void GetTabString(
    String^ s,
    ITextUndoList^ operations
)
abstract GetTabString :
        s : string *
        operations : ITextUndoList -> unit
override GetTabString :
        s : string *
        operations : ITextUndoList -> unit

Parameters

s
Type: SystemString
Text to convert.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments(spaces or tabs).

Implements

ITabulationGetTabString(String, ITextUndoList)
See Also

Reference

TextStrings Class
GetTabString Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetTabString Method (String, StringItemInfo[], Boolean, ITextUndoList)

TextStringsGetTabString Method (String, StringItemInfo, Boolean, ITextUndoList)
When implemented by a class, converts all tab character to spaces depending on TabStops property.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void GetTabString(
    ref string str,
    ref StringItemInfo[] data,
    bool needData,
    ITextUndoList operations
)
Public Overridable Sub GetTabString (
    ByRef str As String,
    ByRef data As StringItemInfo(),
    needData As Boolean,
    operations As ITextUndoList
)
public:
virtual void GetTabString(
    String^% str,
    array<StringItemInfo>^% data,
    bool needData,
    ITextUndoList^ operations
)
abstract GetTabString :
        str : string byref *
        data : StringItemInfo[] byref *
        needData : bool *
        operations : ITextUndoList -> unit
override GetTabString :
        str : string byref *
        data : StringItemInfo[] byref *
        needData : bool *
        operations : ITextUndoList -> unit

Parameters

str
Type: SystemString
Text to convert.
data
Type: Alternet.SyntaxStringItemInfo
Color data of specified string.
needData
Type: SystemBoolean
Indicates whether method should return color data.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments(spaces or tabs).

Implements

ITextStringsGetTabString(String, StringItemInfo, Boolean, ITextUndoList)
See Also

Reference

TextStrings Class
GetTabString Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetTextAt Method

TextStringsGetTextAt Method
Overload List
 | Name | Description
Public method | GetTextAt(Point) | Returns word at the specific text position.
Public method | GetTextAt(Int32, Int32) | Returns word at the specific text position.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetTextAt Method (Point)

TextStringsGetTextAt Method (Point)
Returns word at the specific text position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTextAt(
    Point position
)
Public Overridable Function GetTextAt (
    position As Point
) As String
public:
virtual String^ GetTextAt(
    Point position
)
abstract GetTextAt :
        position : Point -> string
override GetTextAt :
        position : Point -> string

Parameters

position
Type: System.DrawingPoint
The Point value that specifies position in the text.

Return Value

Type: String
Word found at the specified position.

Implements

IWordBreakGetTextAt(Point)
See Also

Reference

TextStrings Class
GetTextAt Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetTextAt Method (Int32, Int32)

TextStringsGetTextAt Method (Int32, Int32)
Returns word at the specific text position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTextAt(
    int pos,
    int line
)
Public Overridable Function GetTextAt (
    pos As Integer,
    line As Integer
) As String
public:
virtual String^ GetTextAt(
    int pos,
    int line
)
abstract GetTextAt :
        pos : int *
        line : int -> string
override GetTextAt :
        pos : int *
        line : int -> string

Parameters

pos
Type: SystemInt32
Specifies index of the line.
line
Type: SystemInt32
Specifies index of character in the text string.

Return Value

Type: String
Word found at the specified position.

Implements

IWordBreakGetTextAt(Int32, Int32)
See Also

Reference

TextStrings Class
GetTextAt Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetWord Method

TextStringsGetWord Method
Overload List
 | Name | Description
Public method | GetWord(Int32, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Char) | Returns word start and end, if there is word at the specified position.
Public method | GetWord(String, Int32, Int32, Int32, Hashtable) | Returns word start and end, if there is word at the specified position.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.GetWord Method (Int32, Int32, Int32, Int32)

TextStringsGetWord Method (Int32, Int32, Int32, Int32)
Returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetWord(
    int index,
    int pos,
    out int left,
    out int right
)
Public Overridable Function GetWord (
    index As Integer,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer
) As Boolean
public:
virtual bool GetWord(
    int index,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right
)
abstract GetWord :
        index : int *
        pos : int *
        left : int byref *
        right : int byref -> bool
override GetWord :
        index : int *
        pos : int *
        left : int byref *
        right : int byref -> bool

Parameters

index
Type: SystemInt32
The index of line in the text.
pos
Type: SystemInt32
The index of character in the within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.

Return Value

Type: Boolean
True if any word found; otherwise false.

Implements

IWordBreakGetWord(Int32, Int32, Int32, Int32)
See Also

Reference

TextStrings Class
GetWord Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetWord Method (String, Int32, Int32, Int32)

TextStringsGetWord Method (String, Int32, Int32, Int32)
Returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetWord(
    string s,
    int pos,
    out int left,
    out int right
)
Public Overridable Function GetWord (
    s As String,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer
) As Boolean
public:
virtual bool GetWord(
    String^ s,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right
)
abstract GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref -> bool
override GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref -> bool

Parameters

s
Type: SystemString
The given string.
pos
Type: SystemInt32
The index of character within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.

Return Value

Type: Boolean
True if any word found; otherwise false.

Implements

IWordBreakGetWord(String, Int32, Int32, Int32)
See Also

Reference

TextStrings Class
GetWord Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetWord Method (String, Int32, Int32, Int32, Char[])

TextStringsGetWord Method (String, Int32, Int32, Int32, Char)
Returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetWord(
    string s,
    int pos,
    out int left,
    out int right,
    char[] delims
)
Public Overridable Function GetWord (
    s As String,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer,
    delims As Char()
) As Boolean
public:
virtual bool GetWord(
    String^ s,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right,
    array<wchar_t>^ delims
)
abstract GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : char[] -> bool
override GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : char[] -> bool

Parameters

s
Type: SystemString
The given string.
pos
Type: SystemInt32
The index of character within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.
delims
Type: SystemChar
Collection of delimiters.

Return Value

Type: Boolean
True if any word found; otherwise false.

Implements

IWordBreakGetWord(String, Int32, Int32, Int32, Char)
See Also

Reference

TextStrings Class
GetWord Overload
Alternet.Editor.TextSource Namespace


TextStrings.GetWord Method (String, Int32, Int32, Int32, Hashtable)

TextStringsGetWord Method (String, Int32, Int32, Int32, Hashtable)
Returns word start and end, if there is word at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetWord(
    string s,
    int pos,
    out int left,
    out int right,
    Hashtable delims
)
Public Overridable Function GetWord (
    s As String,
    pos As Integer,
    <OutAttribute> ByRef left As Integer,
    <OutAttribute> ByRef right As Integer,
    delims As Hashtable
) As Boolean
public:
virtual bool GetWord(
    String^ s,
    int pos,
    [OutAttribute] int% left,
    [OutAttribute] int% right,
    Hashtable^ delims
)
abstract GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : Hashtable -> bool
override GetWord :
        s : string *
        pos : int *
        left : int byref *
        right : int byref *
        delims : Hashtable -> bool

Parameters

s
Type: SystemString
The given string.
pos
Type: SystemInt32
The index of character within the string.
left
Type: SystemInt32
Receives start position of the word.
right
Type: SystemInt32
Receives end position of the word.
delims
Type: System.CollectionsHashtable
Collection of delimiters.

Return Value

Type: Boolean
True if any word found; otherwise false.

Implements

IWordBreakGetWord(String, Int32, Int32, Int32, Hashtable)
See Also

Reference

TextStrings Class
GetWord Overload
Alternet.Editor.TextSource Namespace


TextStrings.IndexOf Method

TextStringsIndexOf Method
Returns the index of the first occurrence of given string in the string collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int IndexOf(
    string item
)
Public Overridable Function IndexOf (
    item As String
) As Integer
public:
virtual int IndexOf(
    String^ item
)
abstract IndexOf :
        item : string -> int
override IndexOf :
        item : string -> int

Parameters

item
Type: SystemString
The string to locate in string collection.

Return Value

Type: Int32
The index of the first occurrence of string within the string collection, if found; otherwise -1.

Implements

IListTIndexOf(T)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Insert Method

TextStringsInsert Method
Inserts value at the specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    int index,
    string item
)
Public Overridable Sub Insert (
    index As Integer,
    item As String
)
public:
virtual void Insert(
    int index,
    String^ item
)
abstract Insert :
        index : int *
        item : string -> unit
override Insert :
        index : int *
        item : string -> unit

Parameters

index
Type: SystemInt32
Specifies position to insert.
item
Type: SystemString
Specifies string to insert.

Implements

IListTInsert(Int32, T)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.IsDelimiter Method

TextStringsIsDelimiter Method
Overload List
 | Name | Description
Public method | IsDelimiter(Char) | Indicates whether the specified character is delimiter character.
Public method | IsDelimiter(Int32, Int32) | Indicates whether the character at the specific position of the string collection is delimiter character.
Public method | IsDelimiter(String, Int32) | Indicates whether the character at the specific position of given string is a delimiter character.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.IsDelimiter Method (Char)

TextStringsIsDelimiter Method (Char)
Indicates whether the specified character is delimiter character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDelimiter(
    char ch
)
Public Overridable Function IsDelimiter (
    ch As Char
) As Boolean
public:
virtual bool IsDelimiter(
    wchar_t ch
)
abstract IsDelimiter :
        ch : char -> bool
override IsDelimiter :
        ch : char -> bool

Parameters

ch
Type: SystemChar
The char value that should be tested.

Return Value

Type: Boolean
True if specified character is delimiter; otherwise false.

Implements

IWordBreakIsDelimiter(Char)
See Also

Reference

TextStrings Class
IsDelimiter Overload
Alternet.Editor.TextSource Namespace


TextStrings.IsDelimiter Method (Int32, Int32)

TextStringsIsDelimiter Method (Int32, Int32)
Indicates whether the character at the specific position of the string collection is delimiter character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDelimiter(
    int index,
    int pos
)
Public Overridable Function IsDelimiter (
    index As Integer,
    pos As Integer
) As Boolean
public:
virtual bool IsDelimiter(
    int index,
    int pos
)
abstract IsDelimiter :
        index : int *
        pos : int -> bool
override IsDelimiter :
        index : int *
        pos : int -> bool

Parameters

index
Type: SystemInt32
The index of line in which character should be tested.
pos
Type: SystemInt32
The index of character in the specific string.

Return Value

Type: Boolean
True if specified character is delimiter; otherwise false.

Implements

IWordBreakIsDelimiter(Int32, Int32)
See Also

Reference

TextStrings Class
IsDelimiter Overload
Alternet.Editor.TextSource Namespace


TextStrings.IsDelimiter Method (String, Int32)

TextStringsIsDelimiter Method (String, Int32)
Indicates whether the character at the specific position of given string is a delimiter character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDelimiter(
    string s,
    int pos
)
Public Overridable Function IsDelimiter (
    s As String,
    pos As Integer
) As Boolean
public:
virtual bool IsDelimiter(
    String^ s,
    int pos
)
abstract IsDelimiter :
        s : string *
        pos : int -> bool
override IsDelimiter :
        s : string *
        pos : int -> bool

Parameters

s
Type: SystemString
The string in which character should be tested.
pos
Type: SystemInt32
The index of character in the given string.

Return Value

Type: Boolean
True if specified character is delimiter; otherwise false.

Implements

IWordBreakIsDelimiter(String, Int32)
See Also

Reference

TextStrings Class
IsDelimiter Overload
Alternet.Editor.TextSource Namespace


TextStrings.IsWhitespace Method

TextStringsIsWhitespace Method
Overload List
 | Name | Description
 | IsWhitespace(Char) | Indicates whether the character at the specific position of the string collection is a whitespace character.
Public method | IsWhitespace(String, Int32) | Indicates whether the character at the specific position of the string collection is a whitespace character.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.IsWhitespace Method (Char)

TextStringsIsWhitespace Method (Char)
Indicates whether the character at the specific position of the string collection is a whitespace character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsWhitespace(
    char ch
)
Public Shared Function IsWhitespace (
    ch As Char
) As Boolean
public:
static bool IsWhitespace(
    wchar_t ch
)
static member IsWhitespace :
        ch : char -> bool

Parameters

ch
Type: SystemChar
The character to check.

Return Value

Type: Boolean
True if specified character is whitespace; otherwise false.
See Also

Reference

TextStrings Class
IsWhitespace Overload
Alternet.Editor.TextSource Namespace


TextStrings.IsWhitespace Method (String, Int32)

TextStringsIsWhitespace Method (String, Int32)
Indicates whether the character at the specific position of the string collection is a whitespace character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsWhitespace(
    string s,
    int pos
)
Public Overridable Function IsWhitespace (
    s As String,
    pos As Integer
) As Boolean
public:
virtual bool IsWhitespace(
    String^ s,
    int pos
)
abstract IsWhitespace :
        s : string *
        pos : int -> bool
override IsWhitespace :
        s : string *
        pos : int -> bool

Parameters

s
Type: SystemString
The string in which character should be tested.
pos
Type: SystemInt32
The index of character in the specific string.

Return Value

Type: Boolean
True if specified character is whitespace; otherwise false.

Implements

IWordBreakIsWhitespace(String, Int32)
See Also

Reference

TextStrings Class
IsWhitespace Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadFile Method

TextStringsLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified exporter.
Public method | LoadFile(String, Encoding) | Loads content from the given file with specific encoding.
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.LoadFile Method (String)

TextStringsLoadFile Method (String)
Loads the contents of the specified file.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName
)
Public Overridable Function LoadFile (
    fileName As String
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool
override LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String)
See Also

Reference

TextStrings Class
LoadFile Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadFile Method (String, IStringImport)

TextStringsLoadFile Method (String, IStringImport)
Loads content from the given file with specified exporter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFile(
    string fileName,
    IStringImport importer
)
Public Function LoadFile (
    fileName As String,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    IStringImport^ importer
) sealed
abstract LoadFile :
        fileName : string *
        importer : IStringImport -> bool
override LoadFile :
        fileName : string *
        importer : IStringImport -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadFile(String, IStringImport)
See Also

Reference

TextStrings Class
LoadFile Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadFile Method (String, Encoding)

TextStringsLoadFile Method (String, Encoding)
Loads content from the given file with specific encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
) sealed
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

TextStrings Class
LoadFile Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadFile Method (String, IStringImport, Encoding)

TextStringsLoadFile Method (String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFile(
    string fileName,
    IStringImport importer,
    Encoding encoding
)
Public Function LoadFile (
    fileName As String,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    IStringImport^ importer,
    Encoding^ encoding
) sealed
abstract LoadFile :
        fileName : string *
        importer : IStringImport *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load content.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadFile(String, IStringImport, Encoding)
See Also

Reference

TextStrings Class
LoadFile Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadStream Method

TextStringsLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.LoadStream Method (Stream)

TextStringsLoadStream Method (Stream)
Loads the contents of the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream
)
Public Overridable Function LoadStream (
    stream As Stream
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream
)
abstract LoadStream :
        stream : Stream -> bool
override LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream)
See Also

Reference

TextStrings Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadStream Method (TextReader)

TextStringsLoadStream Method (TextReader)
Loads the contents of the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader
)
Public Overridable Function LoadStream (
    reader As TextReader
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool
override LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(TextReader)
See Also

Reference

TextStrings Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadStream Method (Stream, IStringImport)

TextStringsLoadStream Method (Stream, IStringImport)
Loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadStream(
    Stream stream,
    IStringImport importer
)
Public Function LoadStream (
    stream As Stream,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    IStringImport^ importer
) sealed
abstract LoadStream :
        stream : Stream *
        importer : IStringImport -> bool
override LoadStream :
        stream : Stream *
        importer : IStringImport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(Stream, IStringImport)
See Also

Reference

TextStrings Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadStream Method (Stream, Encoding)

TextStringsLoadStream Method (Stream, Encoding)
Loads the contents of the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream, Encoding)
See Also

Reference

TextStrings Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadStream Method (TextReader, IStringImport)

TextStringsLoadStream Method (TextReader, IStringImport)
Loads the contents of the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader,
    IStringImport importer
)
Public Overridable Function LoadStream (
    reader As TextReader,
    importer As IStringImport
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader,
    IStringImport^ importer
)
abstract LoadStream :
        reader : TextReader *
        importer : IStringImport -> bool
override LoadStream :
        reader : TextReader *
        importer : IStringImport -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(TextReader, IStringImport)
See Also

Reference

TextStrings Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.LoadStream Method (Stream, IStringImport, Encoding)

TextStringsLoadStream Method (Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadStream(
    Stream stream,
    IStringImport importer,
    Encoding encoding
)
Public Function LoadStream (
    stream As Stream,
    importer As IStringImport,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    IStringImport^ importer,
    Encoding^ encoding
) sealed
abstract LoadStream :
        stream : Stream *
        importer : IStringImport *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        importer : IStringImport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
importer
Type: Alternet.Editor.TextSourceIStringImport
Specifies importer to load content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextImportLoadStream(Stream, IStringImport, Encoding)
See Also

Reference

TextStrings Class
LoadStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.Notify Method

TextStringsNotify Method
Notifies all notifiers about updating object state.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Notify(
    EventArgs e
)
Public Overridable Sub Notify (
    e As EventArgs
)
public:
virtual void Notify(
    EventArgs^ e
)
abstract Notify :
        e : EventArgs -> unit
override Notify :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

Implements

INotifyNotify(EventArgs)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.PosToTabPos Method

TextStringsPosToTabPos Method
Overload List
 | Name | Description
Public method | PosToTabPos(String, Int32) | Returns specified position within given string as tabbed position.
Public method | PosToTabPos(String, Int32, Boolean) | Returns specified position within given string as tabbed position.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.PosToTabPos Method (String, Int32)

TextStringsPosToTabPos Method (String, Int32)
Returns specified position within given string as tabbed position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PosToTabPos(
    string s,
    int pos
)
Public Overridable Function PosToTabPos (
    s As String,
    pos As Integer
) As Integer
public:
virtual int PosToTabPos(
    String^ s,
    int pos
)
abstract PosToTabPos :
        s : string *
        pos : int -> int
override PosToTabPos :
        s : string *
        pos : int -> int

Parameters

s
Type: SystemString
Specifies string to check.
pos
Type: SystemInt32
Position of the character in the string.

Return Value

Type: Int32
Tabbed position.

Implements

ITabulationPosToTabPos(String, Int32)
See Also

Reference

TextStrings Class
PosToTabPos Overload
Alternet.Editor.TextSource Namespace


TextStrings.PosToTabPos Method (String, Int32, Boolean)

TextStringsPosToTabPos Method (String, Int32, Boolean)
Returns specified position within given string as tabbed position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PosToTabPos(
    string s,
    int pos,
    bool tabEnd
)
Public Overridable Function PosToTabPos (
    s As String,
    pos As Integer,
    tabEnd As Boolean
) As Integer
public:
virtual int PosToTabPos(
    String^ s,
    int pos,
    bool tabEnd
)
abstract PosToTabPos :
        s : string *
        pos : int *
        tabEnd : bool -> int
override PosToTabPos :
        s : string *
        pos : int *
        tabEnd : bool -> int

Parameters

s
Type: SystemString
Specifies string to check.
pos
Type: SystemInt32
Position of the character in the string.
tabEnd
Type: SystemBoolean
Reserved for internal use.

Return Value

Type: Int32
Tabbed position.

Implements

ITabulationPosToTabPos(String, Int32, Boolean)
See Also

Reference

TextStrings Class
PosToTabPos Overload
Alternet.Editor.TextSource Namespace


TextStrings.PosToTabPosOriginal Method

TextStringsPosToTabPosOriginal Method

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PosToTabPosOriginal(
    string s,
    int pos,
    bool tabEnd
)
Public Overridable Function PosToTabPosOriginal (
    s As String,
    pos As Integer,
    tabEnd As Boolean
) As Integer
public:
virtual int PosToTabPosOriginal(
    String^ s,
    int pos,
    bool tabEnd
)
abstract PosToTabPosOriginal :
        s : string *
        pos : int *
        tabEnd : bool -> int
override PosToTabPosOriginal :
        s : string *
        pos : int *
        tabEnd : bool -> int

Parameters

s
Type: SystemString
pos
Type: SystemInt32
tabEnd
Type: SystemBoolean

Return Value

Type: Int32
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Remove Method

TextStringsRemove Method
Removes the first occurrence of given string from the string collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Remove(
    string item
)
Public Overridable Function Remove (
    item As String
) As Boolean
public:
virtual bool Remove(
    String^ item
)
abstract Remove :
        item : string -> bool
override Remove :
        item : string -> bool

Parameters

item
Type: SystemString
String to remove.

Return Value

Type: Boolean
True if item was successfully removed from the ICollection; otherwise, false. This method also returns false if item is not found in the original ICollection.

Implements

ICollectionTRemove(T)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.RemoveAt Method

TextStringsRemoveAt Method
Removes string item at specified position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
)
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies index of item in the string collection to remove.

Implements

IListTRemoveAt(Int32)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.RemoveNotifier Method

TextStringsRemoveNotifier Method
Exclude specified handler from notification handlers list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveNotifier(
    INotifier sender
)
Public Overridable Sub RemoveNotifier (
    sender As INotifier
)
public:
virtual void RemoveNotifier(
    INotifier^ sender
)
abstract RemoveNotifier :
        sender : INotifier -> unit
override RemoveNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.

Implements

INotifyRemoveNotifier(INotifier)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.ResetDelimiters Method

TextStringsResetDelimiters Method
Resets the Delimiters to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDelimiters()
Public Overridable Sub ResetDelimiters
public:
virtual void ResetDelimiters()
abstract ResetDelimiters : unit -> unit
override ResetDelimiters : unit -> unit

Implements

IWordBreakResetDelimiters
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.ResetTabStops Method

TextStringsResetTabStops Method
Resets the TabStops to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetTabStops()
Public Overridable Sub ResetTabStops
public:
virtual void ResetTabStops()
abstract ResetTabStops : unit -> unit
override ResetTabStops : unit -> unit

Implements

ITabulationResetTabStops
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.ResetUseSpaces Method

TextStringsResetUseSpaces Method
Resets the UseSpaces to the default value.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetUseSpaces()
Public Overridable Sub ResetUseSpaces
public:
virtual void ResetUseSpaces()
abstract ResetUseSpaces : unit -> unit
override ResetUseSpaces : unit -> unit

Implements

ITabulationResetUseSpaces
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.SaveFile Method

TextStringsSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specified exporter.
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding.
Public method | SaveFile(String, IStringExport, Encoding) | Saves content to the given file with specified exported and specific encoding.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.SaveFile Method (String)

TextStringsSaveFile Method (String)
Saves text content to the specific file.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName
)
Public Overridable Function SaveFile (
    fileName As String
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> bool
override SaveFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String)
See Also

Reference

TextStrings Class
SaveFile Overload
Alternet.Editor.TextSource Namespace


TextStrings.SaveFile Method (String, IStringExport)

TextStringsSaveFile Method (String, IStringExport)
Saves text content to the specific file with specified exporter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    IStringExport exporter
)
Public Overridable Function SaveFile (
    fileName As String,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    IStringExport^ exporter
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport -> bool
override SaveFile :
        fileName : string *
        exporter : IStringExport -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveFile(String, IStringExport)
See Also

Reference

TextStrings Class
SaveFile Overload
Alternet.Editor.TextSource Namespace


TextStrings.SaveFile Method (String, Encoding)

TextStringsSaveFile Method (String, Encoding)
Saves text content to the specific file with specific encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String, Encoding)
See Also

Reference

TextStrings Class
SaveFile Overload
Alternet.Editor.TextSource Namespace


TextStrings.SaveFile Method (String, IStringExport, Encoding)

TextStringsSaveFile Method (String, IStringExport, Encoding)
Saves content to the given file with specified exported and specific encoding.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    IStringExport exporter,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        exporter : IStringExport *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveFile(String, IStringExport, Encoding)
See Also

Reference

TextStrings Class
SaveFile Overload
Alternet.Editor.TextSource Namespace


TextStrings.SaveStream Method

TextStringsSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the given stream with specified exporter.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the given stream with specified exporter.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.SaveStream Method (Stream)

TextStringsSaveStream Method (Stream)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream
)
Public Overridable Function SaveStream (
    stream As Stream
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream
)
abstract SaveStream :
        stream : Stream -> bool
override SaveStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream)
See Also

Reference

TextStrings Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.SaveStream Method (TextWriter)

TextStringsSaveStream Method (TextWriter)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer
)
Public Overridable Function SaveStream (
    writer As TextWriter
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer
)
abstract SaveStream :
        writer : TextWriter -> bool
override SaveStream :
        writer : TextWriter -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(TextWriter)
See Also

Reference

TextStrings Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.SaveStream Method (Stream, IStringExport)

TextStringsSaveStream Method (Stream, IStringExport)
Saves the text content to the given stream with specified exporter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    IStringExport exporter
)
Public Overridable Function SaveStream (
    stream As Stream,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport -> bool
override SaveStream :
        stream : Stream *
        exporter : IStringExport -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveStream(Stream, IStringExport)
See Also

Reference

TextStrings Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.SaveStream Method (Stream, Encoding)

TextStringsSaveStream Method (Stream, Encoding)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream, Encoding)
See Also

Reference

TextStrings Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.SaveStream Method (TextWriter, IStringExport)

TextStringsSaveStream Method (TextWriter, IStringExport)
Saves the text content to the specified stream.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer,
    IStringExport exporter
)
Public Overridable Function SaveStream (
    writer As TextWriter,
    exporter As IStringExport
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer,
    IStringExport^ exporter
)
abstract SaveStream :
        writer : TextWriter *
        exporter : IStringExport -> bool
override SaveStream :
        writer : TextWriter *
        exporter : IStringExport -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveStream(TextWriter, IStringExport)
See Also

Reference

TextStrings Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.SaveStream Method (Stream, IStringExport, Encoding)

TextStringsSaveStream Method (Stream, IStringExport, Encoding)
Saves the text content to the given stream with specified exporter.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    IStringExport exporter,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    exporter As IStringExport,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    IStringExport^ exporter,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        exporter : IStringExport *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        exporter : IStringExport *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
exporter
Type: Alternet.Editor.TextSourceIStringExport
Specifies exporter to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

ITextExportSaveStream(Stream, IStringExport, Encoding)
See Also

Reference

TextStrings Class
SaveStream Overload
Alternet.Editor.TextSource Namespace


TextStrings.SetTextAndData Method

TextStringsSetTextAndData Method
Sets the text and color data at the same time.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetTextAndData(
    string text,
    string data
)
Public Overridable Sub SetTextAndData (
    text As String,
    data As String
)
public:
virtual void SetTextAndData(
    String^ text,
    String^ data
)
abstract SetTextAndData :
        text : string *
        data : string -> unit
override SetTextAndData :
        text : string *
        data : string -> unit

Parameters

text
Type: SystemString
Text of the strings.
data
Type: SystemString
Color data associated with the text.

Implements

ITextStringsSetTextAndData(String, String)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.TabPosToPos Method

TextStringsTabPosToPos Method
Returns specified position within given string as untabbed position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int TabPosToPos(
    string s,
    int pos
)
Public Overridable Function TabPosToPos (
    s As String,
    pos As Integer
) As Integer
public:
virtual int TabPosToPos(
    String^ s,
    int pos
)
abstract TabPosToPos :
        s : string *
        pos : int -> int
override TabPosToPos :
        s : string *
        pos : int -> int

Parameters

s
Type: SystemString
Specifies string to convert.
pos
Type: SystemInt32
Specifies index of character which position should be converted.

Return Value

Type: Int32
Untabbed position.

Implements

ITabulationTabPosToPos(String, Int32)
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.TextPointToAbsolutePosition Method

TextStringsTextPointToAbsolutePosition Method
Overload List
 | Name | Description
Public method | TextPointToAbsolutePosition(Point) | Converts given Point value to the absolute position.
 | TextPointToAbsolutePosition(IListString, Point, String) | Converts given Point value to the absolute position.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.TextPointToAbsolutePosition Method (Point)

TextStringsTextPointToAbsolutePosition Method (Point)
Converts given Point value to the absolute position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int TextPointToAbsolutePosition(
    Point position
)
Public Overridable Function TextPointToAbsolutePosition (
    position As Point
) As Integer
public:
virtual int TextPointToAbsolutePosition(
    Point position
)
abstract TextPointToAbsolutePosition :
        position : Point -> int
override TextPointToAbsolutePosition :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.

Return Value

Type: Int32
Absolute position of given point.

Implements

ITextStringsTextPointToAbsolutePosition(Point)
See Also

Reference

TextStrings Class
TextPointToAbsolutePosition Overload
Alternet.Editor.TextSource Namespace


TextStrings.TextPointToAbsolutePosition Method (IList(String), Point, String)

TextStringsTextPointToAbsolutePosition Method (IListString, Point, String)
Converts given Point value to the absolute position.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int TextPointToAbsolutePosition(
    IList<string> list,
    Point position,
    string lineTerminator
)
Public Shared Function TextPointToAbsolutePosition (
    list As IList(Of String),
    position As Point,
    lineTerminator As String
) As Integer
public:
static int TextPointToAbsolutePosition(
    IList<String^>^ list,
    Point position,
    String^ lineTerminator
)
static member TextPointToAbsolutePosition :
        list : IList<string> *
        position : Point *
        lineTerminator : string -> int

Parameters

list
Type: System.Collections.GenericIListString
Strings collection to convert.
position
Type: System.DrawingPoint
Point value where Y-Coordinate represents index of line and X-Coordinate - index of character in this line.
lineTerminator
Type: SystemString
Specifies line terminator.

Return Value

Type: Int32
Absolute position of given point.
See Also

Reference

TextStrings Class
TextPointToAbsolutePosition Overload
Alternet.Editor.TextSource Namespace


TextStrings.Update Method

TextStringsUpdate Method
Updates an object state.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings Properties

TextStrings Properties

The TextStrings type exposes the following members.

Properties
 | Name | Description
Public property | Count | Represents number of strings in the collection.
Public property | Delimiters | Gets or sets an array of characters used as delimiters between words in the text.
Public property | DelimiterString | Gets or sets Delimiters as a single string.
Public property | DelimTable | Represents delimiters as a key-and-value pairs collection where each key is a single delimiter character.
Public property | FirstChanged | Represents number of the first changed line.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | Item | Provides an indexed access to individual string stored in the collection.
Public property | LastChanged | Represents number of the last changed line.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | Owner | Gets or set the ISyntaxEdit control that owns this collection.
Public property | RemoveTrailingSpaces | Gets or set a boolean value that indicates whether TextStrings should remove trailing spaces from the end of each its strings.
Public property | Source | Gets the text source owning the TextStrings.
Public property | TabStops | Gets or sets the character columns that the cursor will move to each time you press Tab.
Public property | Text | Gets or sets the strings in the ITextStrings as a single string with the individual strings delimited by carriage returns.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | UseSpaces | Gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters.
Top
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Count Property

TextStringsCount Property
Represents number of strings in the collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Delimiters Property

TextStringsDelimiters Property
Gets or sets an array of characters used as delimiters between words in the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] Delimiters { get; set; }
Public Overridable Property Delimiters As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ Delimiters {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract Delimiters : char[] with get, set
override Delimiters : char[] with get, set

Property Value

Type: Char

Implements

IWordBreakDelimiters
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.DelimiterString Property

TextStringsDelimiterString Property
Gets or sets Delimiters as a single string.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DelimiterString { get; set; }
Public Overridable Property DelimiterString As String
    Get
    Set
public:
virtual property String^ DelimiterString {
    String^ get ();
    void set (String^ value);
}
abstract DelimiterString : string with get, set
override DelimiterString : string with get, set

Property Value

Type: String

Implements

IWordBreakDelimiterString
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.DelimTable Property

TextStringsDelimTable Property
Represents delimiters as a key-and-value pairs collection where each key is a single delimiter character.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Hashtable DelimTable { get; }
Public Overridable ReadOnly Property DelimTable As Hashtable
    Get
public:
virtual property Hashtable^ DelimTable {
    Hashtable^ get ();
}
abstract DelimTable : Hashtable with get
override DelimTable : Hashtable with get

Property Value

Type: Hashtable

Implements

ITextStringsDelimTable
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.FirstChanged Property

TextStringsFirstChanged Property
Represents number of the first changed line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FirstChanged { get; }
Public Overridable ReadOnly Property FirstChanged As Integer
    Get
public:
virtual property int FirstChanged {
    int get ();
}
abstract FirstChanged : int with get
override FirstChanged : int with get

Property Value

Type: Int32

Implements

ITextStringsFirstChanged
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.IsReadOnly Property

TextStringsIsReadOnly Property
Gets a value indicating whether the collection is read-only.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Item Property

TextStringsItem Property
Provides an indexed access to individual string stored in the collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As String
    Get
    Set
public:
virtual property String^ default[int index] {
    String^ get (int index);
    void set (int index, String^ value);
}
abstract Item : string with get, set
override Item : string with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: String

Implements

IListTItemInt32
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.LastChanged Property

TextStringsLastChanged Property
Represents number of the last changed line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int LastChanged { get; }
Public Overridable ReadOnly Property LastChanged As Integer
    Get
public:
virtual property int LastChanged {
    int get ();
}
abstract LastChanged : int with get
override LastChanged : int with get

Property Value

Type: Int32

Implements

ITextStringsLastChanged
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.LineTerminator Property

TextStringsLineTerminator Property
Gets or sets a string value that terminates line.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string LineTerminator { get; set; }
Public Overridable Property LineTerminator As String
    Get
    Set
public:
virtual property String^ LineTerminator {
    String^ get ();
    void set (String^ value);
}
abstract LineTerminator : string with get, set
override LineTerminator : string with get, set

Property Value

Type: String

Implements

ITextExportLineTerminator
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Owner Property

TextStringsOwner Property
Gets or set the ISyntaxEdit control that owns this collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxEdit Owner { get; set; }
Public Overridable Property Owner As ISyntaxEdit
    Get
    Set
public:
virtual property ISyntaxEdit^ Owner {
    ISyntaxEdit^ get ();
    void set (ISyntaxEdit^ value);
}
abstract Owner : ISyntaxEdit with get, set
override Owner : ISyntaxEdit with get, set

Property Value

Type: ISyntaxEdit

Implements

ITextStringsOwner
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.RemoveTrailingSpaces Property

TextStringsRemoveTrailingSpaces Property
Gets or set a boolean value that indicates whether TextStrings should remove trailing spaces from the end of each its strings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RemoveTrailingSpaces { get; set; }
Public Overridable Property RemoveTrailingSpaces As Boolean
    Get
    Set
public:
virtual property bool RemoveTrailingSpaces {
    bool get ();
    void set (bool value);
}
abstract RemoveTrailingSpaces : bool with get, set
override RemoveTrailingSpaces : bool with get, set

Property Value

Type: Boolean

Implements

ITextStringsRemoveTrailingSpaces
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Source Property

TextStringsSource Property
Gets the text source owning the TextStrings.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ITextSource Source { get; }
Public Overridable ReadOnly Property Source As ITextSource
    Get
public:
virtual property ITextSource^ Source {
    ITextSource^ get ();
}
abstract Source : ITextSource with get
override Source : ITextSource with get

Property Value

Type: ITextSource

Implements

ITextStringsSource
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.TabStops Property

TextStringsTabStops Property
Gets or sets the character columns that the cursor will move to each time you press Tab.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int[] TabStops { get; set; }
Public Overridable Property TabStops As Integer()
    Get
    Set
public:
virtual property array<int>^ TabStops {
    array<int>^ get ();
    void set (array<int>^ value);
}
abstract TabStops : int[] with get, set
override TabStops : int[] with get, set

Property Value

Type: Int32

Implements

ITabulationTabStops
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.Text Property

TextStringsText Property
Gets or sets the strings in the ITextStrings as a single string with the individual strings delimited by carriage returns.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

IStringListText
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.UpdateCount Property

TextStringsUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


TextStrings.UseSpaces Property

TextStringsUseSpaces Property
Gets or sets a value indicating whether indent or TAB operations insert space characters rather than TAB characters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UseSpaces { get; set; }
Public Overridable Property UseSpaces As Boolean
    Get
    Set
public:
virtual property bool UseSpaces {
    bool get ();
    void set (bool value);
}
abstract UseSpaces : bool with get, set
override UseSpaces : bool with get, set

Property Value

Type: Boolean

Implements

ITabulationUseSpaces
See Also

Reference

TextStrings Class
Alternet.Editor.TextSource Namespace


ThreadProc Delegate

ThreadProc Delegate
Represents a method that will handle thread method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ThreadProc()
Public Delegate Sub ThreadProc
public delegate void ThreadProc()
type ThreadProc =
    delegate of unit -> unit
See Also

Reference

Alternet.Editor.TextSource Namespace


UndoData Class

UndoData Class
Represents data for a single undo operation.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TextSourceUndoData

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UndoData : IUndoData
Public Class UndoData
    Implements IUndoData
public ref class UndoData : IUndoData
type UndoData =
    class
        interface IUndoData
    end

The UndoData type exposes the following members.

Constructors
 | Name | Description
Public method | UndoData | Initializes a new instance of the UndoData class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Data | Represents the object associated with this UndoData.
Public property | Operation | Represents the type of the undo operation.
Public property | Position | Represents the position of the undoable operation within the text.
Public property | Reason | Represents the reason of the undo operation.
Public property | UndoFlag | Reserved for internal use.
Public property | UpdateCount | Number of undo operations that can be executed as single block.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


UndoData Constructor

UndoData Constructor
Initializes a new instance of the UndoData class with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UndoData(
    UndoOperation operation,
    Object data
)
Public Sub New (
    operation As UndoOperation,
    data As Object
)
public:
UndoData(
    UndoOperation operation,
    Object^ data
)
new :
        operation : UndoOperation *
        data : Object -> UndoData

Parameters

operation
Type: Alternet.Editor.TextSourceUndoOperation
Specifies type of the operation that can be undone.
data
Type: SystemObject
The object stored within the UndoData.
See Also

Reference

UndoData Class
Alternet.Editor.TextSource Namespace


UndoData Methods

UndoData Methods

The UndoData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UndoData Class
Alternet.Editor.TextSource Namespace


UndoData Properties

UndoData Properties

The UndoData type exposes the following members.

Properties
 | Name | Description
Public property | Data | Represents the object associated with this UndoData.
Public property | Operation | Represents the type of the undo operation.
Public property | Position | Represents the position of the undoable operation within the text.
Public property | Reason | Represents the reason of the undo operation.
Public property | UndoFlag | Reserved for internal use.
Public property | UpdateCount | Number of undo operations that can be executed as single block.
Top
See Also

Reference

UndoData Class
Alternet.Editor.TextSource Namespace


UndoData.Data Property

UndoDataData Property
Represents the object associated with this UndoData.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Data { get; set; }
Public Overridable Property Data As Object
    Get
    Set
public:
virtual property Object^ Data {
    Object^ get ();
    void set (Object^ value);
}
abstract Data : Object with get, set
override Data : Object with get, set

Property Value

Type: Object

Implements

IUndoDataData
See Also

Reference

UndoData Class
Alternet.Editor.TextSource Namespace


UndoData.Operation Property

UndoDataOperation Property
Represents the type of the undo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual UndoOperation Operation { get; set; }
Public Overridable Property Operation As UndoOperation
    Get
    Set
public:
virtual property UndoOperation Operation {
    UndoOperation get ();
    void set (UndoOperation value);
}
abstract Operation : UndoOperation with get, set
override Operation : UndoOperation with get, set

Property Value

Type: UndoOperation

Implements

IUndoDataOperation
See Also

Reference

UndoData Class
Alternet.Editor.TextSource Namespace


UndoData.Position Property

UndoDataPosition Property
Represents the position of the undoable operation within the text.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Position { get; set; }
Public Overridable Property Position As Point
    Get
    Set
public:
virtual property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set
override Position : Point with get, set

Property Value

Type: Point

Implements

IUndoDataPosition
See Also

Reference

UndoData Class
Alternet.Editor.TextSource Namespace


UndoData.Reason Property

UndoDataReason Property
Represents the reason of the undo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual UpdateReason Reason { get; set; }
Public Overridable Property Reason As UpdateReason
    Get
    Set
public:
virtual property UpdateReason Reason {
    UpdateReason get ();
    void set (UpdateReason value);
}
abstract Reason : UpdateReason with get, set
override Reason : UpdateReason with get, set

Property Value

Type: UpdateReason

Implements

IUndoDataReason
See Also

Reference

UndoData Class
Alternet.Editor.TextSource Namespace


UndoData.UndoFlag Property

UndoDataUndoFlag Property
Reserved for internal use.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual UndoFlags UndoFlag { get; set; }
Public Overridable Property UndoFlag As UndoFlags
    Get
    Set
public:
virtual property UndoFlags UndoFlag {
    UndoFlags get ();
    void set (UndoFlags value);
}
abstract UndoFlag : UndoFlags with get, set
override UndoFlag : UndoFlags with get, set

Property Value

Type: UndoFlags

Implements

IUndoDataUndoFlag
See Also

Reference

UndoData Class
Alternet.Editor.TextSource Namespace


UndoData.UpdateCount Property

UndoDataUpdateCount Property
Number of undo operations that can be executed as single block.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; set; }
Public Overridable Property UpdateCount As Integer
    Get
    Set
public:
virtual property int UpdateCount {
    int get ();
    void set (int value);
}
abstract UpdateCount : int with get, set
override UpdateCount : int with get, set

Property Value

Type: Int32

Implements

IUndoDataUpdateCount
See Also

Reference

UndoData Class
Alternet.Editor.TextSource Namespace


UndoEvent Delegate

UndoEvent Delegate
Represents a method that will handle the IUndo.Undo event.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void UndoEvent(
    Object sender,
    UndoEventArgs e
)
Public Delegate Sub UndoEvent (
    sender As Object,
    e As UndoEventArgs
)
public delegate void UndoEvent(
    Object^ sender,
    UndoEventArgs^ e
)
type UndoEvent =
    delegate of
        sender : Object *
        e : UndoEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.Editor.TextSourceUndoEventArgs
A UndoEventArgs that contains the event data.
See Also

Reference

Alternet.Editor.TextSource Namespace


UndoEventArgs Class

UndoEventArgs Class
Provides data for the event that occurs when the undo/redo operation performed.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.TextSourceUndoEventArgs

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UndoEventArgs : EventArgs
Public Class UndoEventArgs
    Inherits EventArgs
public ref class UndoEventArgs : public EventArgs
type UndoEventArgs =
    class
        inherit EventArgs
    end

The UndoEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UndoEventArgs | Initializes a new instance of the UndoEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | UndoData | Represents the data of the undo/redo operation.
Public property | WithChange | Indicates if undo change needs to be translated to the parser.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


UndoEventArgs Constructor

UndoEventArgs Constructor
Initializes a new instance of the UndoEventArgs class with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UndoEventArgs(
    IUndoData undoData,
    bool withChange = false
)
Public Sub New (
    undoData As IUndoData,
    Optional withChange As Boolean = false
)
public:
UndoEventArgs(
    IUndoData^ undoData,
    bool withChange = false
)
new :
        undoData : IUndoData *
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> UndoEventArgs

Parameters

undoData
Type: Alternet.Editor.TextSourceIUndoData
Data related to the undo operation.
withChange (Optional)
Type: SystemBoolean
Indicates if the change needs to be translated to the parser.
See Also

Reference

UndoEventArgs Class
Alternet.Editor.TextSource Namespace


UndoEventArgs Methods

UndoEventArgs Methods

The UndoEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UndoEventArgs Class
Alternet.Editor.TextSource Namespace


UndoEventArgs Properties

UndoEventArgs Properties

The UndoEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | UndoData | Represents the data of the undo/redo operation.
Public property | WithChange | Indicates if undo change needs to be translated to the parser.
Top
See Also

Reference

UndoEventArgs Class
Alternet.Editor.TextSource Namespace


UndoEventArgs.UndoData Property

UndoEventArgsUndoData Property
Represents the data of the undo/redo operation.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IUndoData UndoData { get; set; }
Public Property UndoData As IUndoData
    Get
    Set
public:
property IUndoData^ UndoData {
    IUndoData^ get ();
    void set (IUndoData^ value);
}
member UndoData : IUndoData with get, set

Property Value

Type: IUndoData
See Also

Reference

UndoEventArgs Class
Alternet.Editor.TextSource Namespace


UndoEventArgs.WithChange Property

UndoEventArgsWithChange Property
Indicates if undo change needs to be translated to the parser.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WithChange { get; set; }
Public Property WithChange As Boolean
    Get
    Set
public:
property bool WithChange {
    bool get ();
    void set (bool value);
}
member WithChange : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UndoEventArgs Class
Alternet.Editor.TextSource Namespace


UndoFlags Enumeration

UndoFlags Enumeration
Defines additional flags for undo/redo operation. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum UndoFlags
<FlagsAttribute>
Public Enumeration UndoFlags
[FlagsAttribute]
public enum class UndoFlags
[<FlagsAttribute>]
type UndoFlags
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
FirstTime | 1 | Indicates first undo operation in the undo sequences.
Saved | 2 | Indicates that undoable operation occurred prior to saving editor's content.
See Also

Reference

Alternet.Editor.TextSource Namespace


UndoList Class

UndoList Class
Provides an indexed access to undo data.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIUndoData
Alternet.Editor.TextSourceUndoList

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UndoList : List<IUndoData>,
    IUndoList, IList<IUndoData>, ICollection<IUndoData>,
    IEnumerable<IUndoData>, IEnumerable, IUpdate
Public Class UndoList
    Inherits List(Of IUndoData)
    Implements IUndoList, IList(Of IUndoData),
    ICollection(Of IUndoData), IEnumerable(Of IUndoData), IEnumerable,
    IUpdate
public ref class UndoList : public List<IUndoData^>,
    IUndoList, IList<IUndoData^>, ICollection<IUndoData^>,
    IEnumerable<IUndoData^>, IEnumerable, IUpdate
type UndoList =
    class
        inherit List<IUndoData>
        interface IUndoList
        interface IList<IUndoData>
        interface ICollection<IUndoData>
        interface IEnumerable<IUndoData>
        interface IEnumerable
        interface IUpdate
    end

The UndoList type exposes the following members.

Constructors
 | Name | Description
Public method | UndoList | Initializes a new instance of the UndoList class
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIUndoData .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIUndoData .)
Public method | BeginUpdate | Prevents undo list updating until calling IUndoList.EndUpdate method.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIUndoData .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIUndoData .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIUndoData .)
Public method | Clear | Clears entire collection.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIUndoData .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIUndoData .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIUndoData .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIUndoData .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIUndoData .)
Public method | DisableUpdate | Prevents undo list updating until calling IUndoList.EndUpdate method.
Public method | EnableUpdate | Re-enables undo list updating, that was turn of by calling IUndoList.BeginUpdate method.
Public method | EndUpdate | Re-enables undo list updating, that was turn of by calling IUndoList.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIUndoData .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIUndoData .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIUndoData .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIUndoData .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIUndoData .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIUndoData .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIUndoData .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIUndoData .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIUndoData .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIUndoData .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIUndoData .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIUndoData .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIUndoData .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIUndoData .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIUndoData .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIUndoData .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIUndoData .)
Public method | RemoveAt | Removes item at the specified index.
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIUndoData .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIUndoData .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIUndoData .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIUndoData .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIUndoData .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIUndoData .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIUndoData .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIUndoData .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIUndoData .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIUndoData .)
Public method | Update | Rescans the undo list.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIUndoData | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIUndoData | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIUndoData, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIUndoData .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIUndoData .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIUndoData .)
Public property | UndoCount | Determines number of undo operations stored in the list.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


UndoList Constructor

UndoList Constructor
Initializes a new instance of the UndoList class

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UndoList()
Public Sub New
public:
UndoList()
new : unit -> UndoList
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList Methods

UndoList Methods

The UndoList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIUndoData .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIUndoData .)
Public method | BeginUpdate | Prevents undo list updating until calling IUndoList.EndUpdate method.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIUndoData .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIUndoData .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIUndoData .)
Public method | Clear | Clears entire collection.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIUndoData .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIUndoData .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIUndoData .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIUndoData .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIUndoData .)
Public method | DisableUpdate | Prevents undo list updating until calling IUndoList.EndUpdate method.
Public method | EnableUpdate | Re-enables undo list updating, that was turn of by calling IUndoList.BeginUpdate method.
Public method | EndUpdate | Re-enables undo list updating, that was turn of by calling IUndoList.BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIUndoData .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIUndoData .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIUndoData .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIUndoData .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIUndoData .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIUndoData .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIUndoData .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIUndoData .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIUndoData .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIUndoData .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIUndoData .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIUndoData .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIUndoData .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIUndoData .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIUndoData .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIUndoData .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIUndoData .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIUndoData .)
Public method | RemoveAt | Removes item at the specified index.
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIUndoData .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIUndoData .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIUndoData .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIUndoData .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIUndoData .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIUndoData .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIUndoData .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIUndoData .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIUndoData .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIUndoData .)
Public method | Update | Rescans the undo list.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIUndoData | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIUndoData | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIUndoData, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.Add Method

UndoListAdd Method
Adds an item to the collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    IUndoData item
)
Public Sub Add (
    item As IUndoData
)
public:
virtual void Add(
    IUndoData^ item
) sealed
abstract Add :
        item : IUndoData -> unit
override Add :
        item : IUndoData -> unit

Parameters

item
Type: Alternet.Editor.TextSourceIUndoData

Implements

IUndoListAdd(IUndoData)
ICollectionTAdd(T)
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.BeginUpdate Method

UndoListBeginUpdate Method
Prevents undo list updating until calling IUndoList.EndUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of undo list updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.Clear Method

UndoListClear Method
Clears entire collection.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IUndoListClear
ICollectionTClear
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.DisableUpdate Method

UndoListDisableUpdate Method
Prevents undo list updating until calling IUndoList.EndUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of page updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.EnableUpdate Method

UndoListEnableUpdate Method
Re-enables undo list updating, that was turn of by calling IUndoList.BeginUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of gutter updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.EndUpdate Method

UndoListEndUpdate Method
Re-enables undo list updating, that was turn of by calling IUndoList.BeginUpdate method.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of undo list updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.RemoveAt Method

UndoListRemoveAt Method
Removes item at the specified index.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
public:
virtual void RemoveAt(
    int index
) sealed
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
Specifies index of item to remove.

Implements

IUndoListRemoveAt(Int32)
IListTRemoveAt(Int32)
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.Update Method

UndoListUpdate Method
Rescans the undo list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
virtual void Update() sealed
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList Properties

UndoList Properties

The UndoList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIUndoData .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIUndoData .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIUndoData .)
Public property | UndoCount | Determines number of undo operations stored in the list.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.UndoCount Property

UndoListUndoCount Property
Determines number of undo operations stored in the list.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UndoCount { get; }
Public ReadOnly Property UndoCount As Integer
    Get
public:
virtual property int UndoCount {
    int get () sealed;
}
abstract UndoCount : int with get
override UndoCount : int with get

Property Value

Type: Int32

Implements

IUndoListUndoCount
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoList.UpdateCount Property

UndoListUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

UndoList Class
Alternet.Editor.TextSource Namespace


UndoOperation Enumeration

UndoOperation Enumeration
Defines a type of the operation to undo.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum UndoOperation
Public Enumeration UndoOperation
public enum class UndoOperation
type UndoOperation
Members
Member name | Value | Description
Insert | 0 | Specifies operation that inserts some text.
Delete | 1 | Specifies operation that deletes some text.
Break | 2 | Specifies operation that breaks text line into two lines.
UnBreak | 3 | Specifies operation that concatenates two text lines.
InsertBlock | 4 | Specifies operation that inserts some block of text.
DeleteBlock | 5 | Specifies operation that deletes some block of text.
Navigate | 6 | Specifies operation that navigates within text content.
NavigateEx | 7 | Specifies operation that navigates within text content. (this operation is always undone, regardless of UndoOptions).
UndoBlock | 8 | Specifies that subsequent undo operations will be undone at once.
Unknown | 9 | Specifies unknown operation.
See Also

Reference

Alternet.Editor.TextSource Namespace


UndoOptions Enumeration

UndoOptions Enumeration
Defines undo/redo behaviour. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum UndoOptions
<FlagsAttribute>
Public Enumeration UndoOptions
[FlagsAttribute]
public enum class UndoOptions
[<FlagsAttribute>]
type UndoOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
AllowUndo | 1 | Allows undo/redo operations.
GroupUndo | 2 | Specifies that last editing command should be undone together with any subsequent editing commands of the same type.
UndoNavigations | 4 | Specifies that navigate operations can be undone.
UndoAfterSave | 8 | Allows undo operation after a save.
UngroupBreaks | 16 | Specifies whether single break and unbreak operation should be undone rather than subsequent operations.
See Also

Reference

Alternet.Editor.TextSource Namespace


UpdateReason Enumeration

UpdateReason Enumeration
Defines reason of updating control's text content.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum UpdateReason
Public Enumeration UpdateReason
public enum class UpdateReason
type UpdateReason
Members
Member name | Value | Description
Navigate | 0 | Specifies that current position in the control's text content changed.
Insert | 1 | Specifies that some text inserted.
Delete | 2 | Specifies that some text deleted.
Break | 3 | Specifies that text line was broken into two lines.
UnBreak | 4 | Specifies that two lines concatenated.
DeleteBlock | 5 | Specifies that some block of text deleted.
InsertBlock | 6 | Specifies that some block of text inserted.
Other | 7 | Specifies another reason of the control's text content updating.
See Also

Reference

Alternet.Editor.TextSource Namespace


WordSpellEvent Delegate

WordSpellEvent Delegate
Represents a method that will handle the SyntaxEdit.WordSpell, TextSource.WordSpell or Spelling.WordSpell events.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void WordSpellEvent(
    Object sender,
    WordSpellEventArgs e
)
Public Delegate Sub WordSpellEvent (
    sender As Object,
    e As WordSpellEventArgs
)
public delegate void WordSpellEvent(
    Object^ sender,
    WordSpellEventArgs^ e
)
type WordSpellEvent =
    delegate of
        sender : Object *
        e : WordSpellEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.Editor.TextSourceWordSpellEventArgs
A WordSpellEventArgs that contains the event data.
See Also

Reference

Alternet.Editor.TextSource Namespace


WordSpellEventArgs Class

WordSpellEventArgs Class
Provides data for the WordSpellEvent handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.TextSourceWordSpellEventArgs

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WordSpellEventArgs : EventArgs
Public Class WordSpellEventArgs
    Inherits EventArgs
public ref class WordSpellEventArgs : public EventArgs
type WordSpellEventArgs =
    class
        inherit EventArgs
    end

The WordSpellEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WordSpellEventArgs | Initializes a new instance of the WordSpellEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ColorStyle | Represents index of lexical style in LexStyles collection for WordSpellEventArgs.Text. This allows to skip checking spelling for keywords, numbers or identifiers.
Public property | Correct | Represents a value indicating whether WordSpellEventArgs.Text has correct spelling.
Public property | Text | Represents string to check.
Top
See Also

Reference

Alternet.Editor.TextSource Namespace


WordSpellEventArgs Constructor

WordSpellEventArgs Constructor
Initializes a new instance of the WordSpellEventArgs class with specified parameters.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public WordSpellEventArgs(
    string text,
    bool correct,
    StringItemInfo colorStyle
)
Public Sub New (
    text As String,
    correct As Boolean,
    colorStyle As StringItemInfo
)
public:
WordSpellEventArgs(
    String^ text,
    bool correct,
    StringItemInfo colorStyle
)
new :
        text : string *
        correct : bool *
        colorStyle : StringItemInfo -> WordSpellEventArgs

Parameters

text
Type: SystemString
Text to check.
correct
Type: SystemBoolean
Specifies whether text spelling is correct.
colorStyle
Type: Alternet.SyntaxStringItemInfo
Color style for text to check-up.
See Also

Reference

WordSpellEventArgs Class
Alternet.Editor.TextSource Namespace


WordSpellEventArgs Methods

WordSpellEventArgs Methods

The WordSpellEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WordSpellEventArgs Class
Alternet.Editor.TextSource Namespace


WordSpellEventArgs Properties

WordSpellEventArgs Properties

The WordSpellEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ColorStyle | Represents index of lexical style in LexStyles collection for WordSpellEventArgs.Text. This allows to skip checking spelling for keywords, numbers or identifiers.
Public property | Correct | Represents a value indicating whether WordSpellEventArgs.Text has correct spelling.
Public property | Text | Represents string to check.
Top
See Also

Reference

WordSpellEventArgs Class
Alternet.Editor.TextSource Namespace


WordSpellEventArgs.ColorStyle Property

WordSpellEventArgsColorStyle Property
Represents index of lexical style in LexStyles collection for WordSpellEventArgs.Text. This allows to skip checking spelling for keywords, numbers or identifiers.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringItemInfo ColorStyle { get; set; }
Public Property ColorStyle As StringItemInfo
    Get
    Set
public:
property StringItemInfo ColorStyle {
    StringItemInfo get ();
    void set (StringItemInfo value);
}
member ColorStyle : StringItemInfo with get, set

Property Value

Type: StringItemInfo
See Also

Reference

WordSpellEventArgs Class
Alternet.Editor.TextSource Namespace


WordSpellEventArgs.Correct Property

WordSpellEventArgsCorrect Property
Represents a value indicating whether WordSpellEventArgs.Text has correct spelling.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Correct { get; set; }
Public Property Correct As Boolean
    Get
    Set
public:
property bool Correct {
    bool get ();
    void set (bool value);
}
member Correct : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WordSpellEventArgs Class
Alternet.Editor.TextSource Namespace


WordSpellEventArgs.Text Property

WordSpellEventArgsText Property
Represents string to check.

Namespace: Alternet.Editor.TextSource
Assembly: Alternet.Editor.v7 (in Alternet.Editor.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

WordSpellEventArgs Class
Alternet.Editor.TextSource Namespace


Alternet.Editor.TypeScript Namespace

Alternet.Editor.TypeScript Namespace
Classes
 | Class | Description
Public class | CodeEditExtensions |
Public class | CodeExplorer | Represents methods used to explore parsed representation of the source code in the TreeView control.
Public class | CodeUtils | Represents extended functionality to fill classes and methods lists related to the position inside the text document.
Public class | NavigateToNodeRequestedEventArgs |
Public class | TSProject | Represents properties and methods used to store and manipulate TypeScript project content.
Public class | TSProjectExplorer | Represents methods used to explore particular project in the TreeView control.


CodeEditExtensions Class

CodeEditExtensions Class
Inheritance Hierarchy
SystemObject
Alternet.Editor.TypeScriptCodeEditExtensions

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CodeEditExtensions
<ExtensionAttribute>
Public NotInheritable Class CodeEditExtensions
[ExtensionAttribute]
public ref class CodeEditExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type CodeEditExtensions =  class end

The CodeEditExtensions type exposes the following members.

Methods
Name | Description
CanFindDeclaration |
CloseProject |
FindDeclaration |
FindReferences |
InitSyntax |
InitSyntax(IScriptEdit) |
OpenProject |
RegisterCode(String, String) |
RegisterCode(IScriptEdit, String, String) |
ReplaceCodeFile |
UnregisterCode(String, String) |
UnregisterCode(IScriptEdit, String) |
Top
Properties
Name | Description
DefaultParser |
DefaultProject |
Top
See Also

Reference

Alternet.Editor.TypeScript Namespace


CodeEditExtensions Methods

CodeEditExtensions Methods

The CodeEditExtensions type exposes the following members.

Methods
Name | Description
CanFindDeclaration |
CloseProject |
FindDeclaration |
FindReferences |
InitSyntax |
InitSyntax(IScriptEdit) |
OpenProject |
RegisterCode(String, String) |
RegisterCode(IScriptEdit, String, String) |
ReplaceCodeFile |
UnregisterCode(String, String) |
UnregisterCode(IScriptEdit, String) |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.CanFindDeclaration Method

CodeEditExtensionsCanFindDeclaration Method

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanFindDeclaration(
    this IScriptEdit edit,
    Point position
)
<ExtensionAttribute>
Public Shared Function CanFindDeclaration (
    edit As IScriptEdit,
    position As Point
) As Boolean
public:
[ExtensionAttribute]
static bool CanFindDeclaration(
    IScriptEdit^ edit,
    Point position
)
[<ExtensionAttribute>]
static member CanFindDeclaration :
        edit : IScriptEdit *
        position : Point -> bool

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
position
Type: System.DrawingPoint

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.CloseProject Method

CodeEditExtensionsCloseProject Method

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CloseProject(
    string extension
)
Public Shared Sub CloseProject (
    extension As String
)
public:
static void CloseProject(
    String^ extension
)
static member CloseProject :
        extension : string -> unit

Parameters

extension
Type: SystemString
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.FindDeclaration Method

CodeEditExtensionsFindDeclaration Method

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SymbolLocation FindDeclaration(
    this IScriptEdit edit,
    Point position
)
<ExtensionAttribute>
Public Shared Function FindDeclaration (
    edit As IScriptEdit,
    position As Point
) As SymbolLocation
public:
[ExtensionAttribute]
static SymbolLocation^ FindDeclaration(
    IScriptEdit^ edit,
    Point position
)
[<ExtensionAttribute>]
static member FindDeclaration :
        edit : IScriptEdit *
        position : Point -> SymbolLocation

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
position
Type: System.DrawingPoint

Return Value

Type: SymbolLocation

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.FindReferences Method

CodeEditExtensionsFindReferences Method

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int FindReferences(
    this IScriptEdit edit,
    Point position,
    IRangeList references
)
<ExtensionAttribute>
Public Shared Function FindReferences (
    edit As IScriptEdit,
    position As Point,
    references As IRangeList
) As Integer
public:
[ExtensionAttribute]
static int FindReferences(
    IScriptEdit^ edit,
    Point position,
    IRangeList^ references
)
[<ExtensionAttribute>]
static member FindReferences :
        edit : IScriptEdit *
        position : Point *
        references : IRangeList -> int

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
position
Type: System.DrawingPoint
references
Type: Alternet.CommonIRangeList

Return Value

Type: Int32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.InitSyntax Method

CodeEditExtensionsInitSyntax Method
Overload List
Name | Description
InitSyntax |
InitSyntax(IScriptEdit) |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.InitSyntax Method

CodeEditExtensionsInitSyntax Method

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void InitSyntax()
Public Shared Sub InitSyntax
public:
static void InitSyntax()
static member InitSyntax : unit -> unit
See Also

Reference

CodeEditExtensions Class
InitSyntax Overload
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.InitSyntax Method (IScriptEdit)

CodeEditExtensionsInitSyntax Method (IScriptEdit)

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void InitSyntax(
    this IScriptEdit edit
)
<ExtensionAttribute>
Public Shared Sub InitSyntax (
    edit As IScriptEdit
)
public:
[ExtensionAttribute]
static void InitSyntax(
    IScriptEdit^ edit
)
[<ExtensionAttribute>]
static member InitSyntax :
        edit : IScriptEdit -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
InitSyntax Overload
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.OpenProject Method

CodeEditExtensionsOpenProject Method

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void OpenProject(
    string projectFileName,
    ProjectData projectData
)
Public Shared Sub OpenProject (
    projectFileName As String,
    projectData As ProjectData
)
public:
static void OpenProject(
    String^ projectFileName,
    ProjectData^ projectData
)
static member OpenProject :
        projectFileName : string *
        projectData : ProjectData -> unit

Parameters

projectFileName
Type: SystemString
projectData
Type: ProjectData
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.RegisterCode Method

CodeEditExtensionsRegisterCode Method
Overload List
Name | Description
RegisterCode(String, String) |
RegisterCode(IScriptEdit, String, String) |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.RegisterCode Method (String, String[])

CodeEditExtensionsRegisterCode Method (String, String)

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCode(
    string extension,
    string[] files
)
Public Shared Sub RegisterCode (
    extension As String,
    files As String()
)
public:
static void RegisterCode(
    String^ extension,
    array<String^>^ files
)
static member RegisterCode :
        extension : string *
        files : string[] -> unit

Parameters

extension
Type: SystemString
files
Type: SystemString
See Also

Reference

CodeEditExtensions Class
RegisterCode Overload
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.RegisterCode Method (IScriptEdit, String, String)

CodeEditExtensionsRegisterCode Method (IScriptEdit, String, String)

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCode(
    this IScriptEdit edit,
    string fileName,
    string text
)
<ExtensionAttribute>
Public Shared Sub RegisterCode (
    edit As IScriptEdit,
    fileName As String,
    text As String
)
public:
[ExtensionAttribute]
static void RegisterCode(
    IScriptEdit^ edit,
    String^ fileName,
    String^ text
)
[<ExtensionAttribute>]
static member RegisterCode :
        edit : IScriptEdit *
        fileName : string *
        text : string -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
fileName
Type: SystemString
text
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
RegisterCode Overload
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.ReplaceCodeFile Method

CodeEditExtensionsReplaceCodeFile Method

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ReplaceCodeFile(
    string extension,
    string fileName,
    string text
)
Public Shared Sub ReplaceCodeFile (
    extension As String,
    fileName As String,
    text As String
)
public:
static void ReplaceCodeFile(
    String^ extension,
    String^ fileName,
    String^ text
)
static member ReplaceCodeFile :
        extension : string *
        fileName : string *
        text : string -> unit

Parameters

extension
Type: SystemString
fileName
Type: SystemString
text
Type: SystemString
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.UnregisterCode Method

CodeEditExtensionsUnregisterCode Method
Overload List
Name | Description
UnregisterCode(String, String) |
UnregisterCode(IScriptEdit, String) |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.UnregisterCode Method (String, String[])

CodeEditExtensionsUnregisterCode Method (String, String)

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCode(
    string extension,
    string[] files
)
Public Shared Sub UnregisterCode (
    extension As String,
    files As String()
)
public:
static void UnregisterCode(
    String^ extension,
    array<String^>^ files
)
static member UnregisterCode :
        extension : string *
        files : string[] -> unit

Parameters

extension
Type: SystemString
files
Type: SystemString
See Also

Reference

CodeEditExtensions Class
UnregisterCode Overload
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.UnregisterCode Method (IScriptEdit, String)

CodeEditExtensionsUnregisterCode Method (IScriptEdit, String)

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCode(
    this IScriptEdit edit,
    string fileName
)
<ExtensionAttribute>
Public Shared Sub UnregisterCode (
    edit As IScriptEdit,
    fileName As String
)
public:
[ExtensionAttribute]
static void UnregisterCode(
    IScriptEdit^ edit,
    String^ fileName
)
[<ExtensionAttribute>]
static member UnregisterCode :
        edit : IScriptEdit *
        fileName : string -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
fileName
Type: SystemString

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IScriptEdit. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CodeEditExtensions Class
UnregisterCode Overload
Alternet.Editor.TypeScript Namespace


CodeEditExtensions Properties

CodeEditExtensions Properties

The CodeEditExtensions type exposes the following members.

Properties
Name | Description
DefaultParser |
DefaultProject |
Top
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.DefaultParser Property

CodeEditExtensionsDefaultParser Property

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static V8Parser DefaultParser { get; }
Public Shared ReadOnly Property DefaultParser As V8Parser
    Get
public:
static property V8Parser^ DefaultParser {
    V8Parser^ get ();
}
static member DefaultParser : V8Parser with get

Property Value

Type: V8Parser
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeEditExtensions.DefaultProject Property

CodeEditExtensionsDefaultProject Property

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ITypeScriptProject DefaultProject { get; set; }
Public Shared Property DefaultProject As ITypeScriptProject
    Get
    Set
public:
static property ITypeScriptProject^ DefaultProject {
    ITypeScriptProject^ get ();
    void set (ITypeScriptProject^ value);
}
static member DefaultProject : ITypeScriptProject with get, set

Property Value

Type: ITypeScriptProject
See Also

Reference

CodeEditExtensions Class
Alternet.Editor.TypeScript Namespace


CodeExplorer Class

CodeExplorer Class
Represents methods used to explore parsed representation of the source code in the TreeView control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TypeScriptCodeExplorer

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeExplorer
Public Class CodeExplorer
public ref class CodeExplorer
type CodeExplorer =  class end

The CodeExplorer type exposes the following members.

Constructors
 | Name | Description
Public method | CodeExplorer | Initializes a new instance of the CodeExplorer class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ScopeImageIndex | Calculates offset for the image index accordingly to the visibility scope.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorerAsync | Updates explorer content from given source document.
Top
Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore source code.
Top
Events
 | Name | Description
Public event | NavigateToNodeRequested |
Top
See Also

Reference

Alternet.Editor.TypeScript Namespace


CodeExplorer Constructor

CodeExplorer Constructor
Initializes a new instance of the CodeExplorer class with default settings.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeExplorer()
Public Sub New
public:
CodeExplorer()
new : unit -> CodeExplorer
See Also

Reference

CodeExplorer Class
Alternet.Editor.TypeScript Namespace


CodeExplorer Methods

CodeExplorer Methods

The CodeExplorer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ScopeImageIndex | Calculates offset for the image index accordingly to the visibility scope.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorerAsync | Updates explorer content from given source document.
Top
See Also

Reference

CodeExplorer Class
Alternet.Editor.TypeScript Namespace


CodeExplorer.ScopeImageIndex Method

CodeExplorerScopeImageIndex Method
Calculates offset for the image index accordingly to the visibility scope.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int ScopeImageIndex(
    bool isScopedImage
)
Public Shared Function ScopeImageIndex (
    isScopedImage As Boolean
) As Integer
public:
static int ScopeImageIndex(
    bool isScopedImage
)
static member ScopeImageIndex :
        isScopedImage : bool -> int

Parameters

isScopedImage
Type: SystemBoolean
Indicates whether image index needs to be adjusted.

Return Value

Type: Int32
The amount to offset.
See Also

Reference

CodeExplorer Class
Alternet.Editor.TypeScript Namespace


CodeExplorer.UpdateExplorerAsync Method

CodeExplorerUpdateExplorerAsync Method
Updates explorer content from given source document.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task UpdateExplorerAsync(
    Object document,
    V8Parser parser
)
Public Function UpdateExplorerAsync (
    document As Object,
    parser As V8Parser
) As Task
public:
Task^ UpdateExplorerAsync(
    Object^ document,
    V8Parser^ parser
)
member UpdateExplorerAsync :
        document : Object *
        parser : V8Parser -> Task

Parameters

document
Type: SystemObject
Source code document.
parser
Type: V8Parser
Parser process code.

Return Value

Type: Task
See Also

Reference

CodeExplorer Class
Alternet.Editor.TypeScript Namespace


CodeExplorer Properties

CodeExplorer Properties

The CodeExplorer type exposes the following members.

Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore source code.
Top
See Also

Reference

CodeExplorer Class
Alternet.Editor.TypeScript Namespace


CodeExplorer.ExplorerTree Property

CodeExplorerExplorerTree Property
Gets or sets System.Windows.Forms.TreeView control used to explore source code.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeView ExplorerTree { get; set; }
Public Property ExplorerTree As TreeView
    Get
    Set
public:
property TreeView^ ExplorerTree {
    TreeView^ get ();
    void set (TreeView^ value);
}
member ExplorerTree : TreeView with get, set

Property Value

Type: TreeView
See Also

Reference

CodeExplorer Class
Alternet.Editor.TypeScript Namespace


CodeExplorer Events

CodeExplorer Events

The CodeExplorer type exposes the following members.

Events
 | Name | Description
Public event | NavigateToNodeRequested |
Top
See Also

Reference

CodeExplorer Class
Alternet.Editor.TypeScript Namespace


CodeExplorer.NavigateToNodeRequested Event

CodeExplorerNavigateToNodeRequested Event

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<NavigateToNodeRequestedEventArgs> NavigateToNodeRequested
Public Event NavigateToNodeRequested As EventHandler(Of NavigateToNodeRequestedEventArgs)
public:
 event EventHandler<NavigateToNodeRequestedEventArgs^>^ NavigateToNodeRequested {
    void add (EventHandler<NavigateToNodeRequestedEventArgs^>^ value);
    void remove (EventHandler<NavigateToNodeRequestedEventArgs^>^ value);
}
member NavigateToNodeRequested : IEvent<EventHandler<NavigateToNodeRequestedEventArgs>,
    NavigateToNodeRequestedEventArgs>

Value

Type: SystemEventHandlerNavigateToNodeRequestedEventArgs
See Also

Reference

CodeExplorer Class
Alternet.Editor.TypeScript Namespace


CodeUtils Class

CodeUtils Class
Represents extended functionality to fill classes and methods lists related to the position inside the text document.
Inheritance Hierarchy
SystemObject
Alternet.Editor.TypeScriptCodeUtils

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeUtils
Public Class CodeUtils
public ref class CodeUtils
type CodeUtils =  class end

The CodeUtils type exposes the following members.

Constructors
 | Name | Description
Public method | CodeUtils | Initializes a new instance of the CodeUtils class
Top
Methods
 | Name | Description
 | DrawItem | Provides a custom drawing for a ComboBox item.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FillClassesAsync | Fills given ComboBox with list of classes obtained from specified document at the given position.
 | FillMethods | Fills given ComboBox with list of methods obtained from specified document at the given position.
 | FormatText | Formats content of specified syntax element accordingly to language rules of the document.
 | GetFormattedText | Retrieves content of specified syntax element accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPosition | Finds position in source code related to the specified syntax element.
 | GetSelectedPosition | Finds position in source code related to the currently selected item in the ComboBox control.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidKind |
 | NavigateClasses | Updates content of given class ComboBox accordingly to given position.
 | NavigateMethods | Updates content of given method ComboBox accordingly to given position.
 | SelectItem | Finds position of the syntax element linked to the currently selected item in the ComboBox control.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Editor.TypeScript Namespace


CodeUtils Constructor

CodeUtils Constructor
Initializes a new instance of the CodeUtils class

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeUtils()
Public Sub New
public:
CodeUtils()
new : unit -> CodeUtils
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils Methods

CodeUtils Methods

The CodeUtils type exposes the following members.

Methods
 | Name | Description
 | DrawItem | Provides a custom drawing for a ComboBox item.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FillClassesAsync | Fills given ComboBox with list of classes obtained from specified document at the given position.
 | FillMethods | Fills given ComboBox with list of methods obtained from specified document at the given position.
 | FormatText | Formats content of specified syntax element accordingly to language rules of the document.
 | GetFormattedText | Retrieves content of specified syntax element accordingly to language rules of the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPosition | Finds position in source code related to the specified syntax element.
 | GetSelectedPosition | Finds position in source code related to the currently selected item in the ComboBox control.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidKind |
 | NavigateClasses | Updates content of given class ComboBox accordingly to given position.
 | NavigateMethods | Updates content of given method ComboBox accordingly to given position.
 | SelectItem | Finds position of the syntax element linked to the currently selected item in the ComboBox control.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.DrawItem Method

CodeUtilsDrawItem Method
Provides a custom drawing for a ComboBox item.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DrawItem(
    ComboBox comboBox,
    DrawItemEventArgs e,
    ImageList images
)
Public Shared Sub DrawItem (
    comboBox As ComboBox,
    e As DrawItemEventArgs,
    images As ImageList
)
public:
static void DrawItem(
    ComboBox^ comboBox,
    DrawItemEventArgs^ e,
    ImageList^ images
)
static member DrawItem :
        comboBox : ComboBox *
        e : DrawItemEventArgs *
        images : ImageList -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox which item will be drawn.
e
Type: System.Windows.FormsDrawItemEventArgs
A DrawItemEventArgs that contains the event data.
images
Type: System.Windows.FormsImageList
List of images used to draw with items.
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.FillClassesAsync Method

CodeUtilsFillClassesAsync Method
Fills given ComboBox with list of classes obtained from specified document at the given position.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Task FillClassesAsync(
    ComboBox comboBox,
    Object document,
    Point position,
    V8Parser parser
)
Public Shared Function FillClassesAsync (
    comboBox As ComboBox,
    document As Object,
    position As Point,
    parser As V8Parser
) As Task
public:
static Task^ FillClassesAsync(
    ComboBox^ comboBox,
    Object^ document,
    Point position,
    V8Parser^ parser
)
static member FillClassesAsync :
        comboBox : ComboBox *
        document : Object *
        position : Point *
        parser : V8Parser -> Task

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox control to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Position in code.
parser
Type: V8Parser
Parser process code.

Return Value

Type: Task
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.FillMethods Method

CodeUtilsFillMethods Method
Fills given ComboBox with list of methods obtained from specified document at the given position.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void FillMethods(
    ComboBox comboBox,
    Object document,
    Point position,
    ComboBox classCombo,
    V8Parser parser
)
Public Shared Sub FillMethods (
    comboBox As ComboBox,
    document As Object,
    position As Point,
    classCombo As ComboBox,
    parser As V8Parser
)
public:
static void FillMethods(
    ComboBox^ comboBox,
    Object^ document,
    Point position,
    ComboBox^ classCombo,
    V8Parser^ parser
)
static member FillMethods :
        comboBox : ComboBox *
        document : Object *
        position : Point *
        classCombo : ComboBox *
        parser : V8Parser -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox control to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Position in code.
classCombo
Type: System.Windows.FormsComboBox
Contains list of classes.
parser
Type: V8Parser
Parser process code.
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.FormatText Method

CodeUtilsFormatText Method
Formats content of specified syntax element accordingly to language rules of the document.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string FormatText(
    Object item
)
Public Shared Function FormatText (
    item As Object
) As String
public:
static String^ FormatText(
    Object^ item
)
static member FormatText :
        item : Object -> string

Parameters

item
Type: SystemObject
Syntax element to probe.

Return Value

Type: String
Formatted sting that contains a syntax element.
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.GetFormattedText Method

CodeUtilsGetFormattedText Method
Retrieves content of specified syntax element accordingly to language rules of the document.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFormattedText(
    NavigationBarItem item
)
Public Shared Function GetFormattedText (
    item As NavigationBarItem
) As String
public:
static String^ GetFormattedText(
    NavigationBarItem^ item
)
static member GetFormattedText :
        item : NavigationBarItem -> string

Parameters

item
Type: NavigationBarItem
Item to probe.

Return Value

Type: String
Formatted sting that contains a syntax element.
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.GetPosition Method

CodeUtilsGetPosition Method
Finds position in source code related to the specified syntax element.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GetPosition(
    Object item,
    Object document,
    out Point point,
    V8Parser parser
)
Public Shared Function GetPosition (
    item As Object,
    document As Object,
    <OutAttribute> ByRef point As Point,
    parser As V8Parser
) As Boolean
public:
static bool GetPosition(
    Object^ item,
    Object^ document,
    [OutAttribute] Point% point,
    V8Parser^ parser
)
static member GetPosition :
        item : Object *
        document : Object *
        point : Point byref *
        parser : V8Parser -> bool

Parameters

item
Type: SystemObject
Syntax element (class or method) to probe.
document
Type: SystemObject
Source code document.
point
Type: System.DrawingPoint
Receives start point of given syntax element.
parser
Type: V8Parser
Parser process code.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.GetSelectedPosition Method

CodeUtilsGetSelectedPosition Method
Finds position in source code related to the currently selected item in the ComboBox control.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point GetSelectedPosition(
    ComboBox comboBox,
    Object document,
    V8Parser parser
)
Public Shared Function GetSelectedPosition (
    comboBox As ComboBox,
    document As Object,
    parser As V8Parser
) As Point
public:
static Point GetSelectedPosition(
    ComboBox^ comboBox,
    Object^ document,
    V8Parser^ parser
)
static member GetSelectedPosition :
        comboBox : ComboBox *
        document : Object *
        parser : V8Parser -> Point

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox contains list of syntax elements (classes or methods).
document
Type: SystemObject
Source code document.
parser
Type: V8Parser
Parser process code.

Return Value

Type: Point
System.Draw.Point represents start point of current syntax element.
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.IsValidKind Method

CodeUtilsIsValidKind Method

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidKind(
    ScriptElementKind kind,
    out int imageIndex
)
Public Shared Function IsValidKind (
    kind As ScriptElementKind,
    <OutAttribute> ByRef imageIndex As Integer
) As Boolean
public:
static bool IsValidKind(
    ScriptElementKind^ kind,
    [OutAttribute] int% imageIndex
)
static member IsValidKind :
        kind : ScriptElementKind *
        imageIndex : int byref -> bool

Parameters

kind
Type: ScriptElementKind
imageIndex
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.NavigateClasses Method

CodeUtilsNavigateClasses Method
Updates content of given class ComboBox accordingly to given position.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void NavigateClasses(
    ComboBox comboBox,
    Object document,
    Point position,
    V8Parser parser
)
Public Shared Sub NavigateClasses (
    comboBox As ComboBox,
    document As Object,
    position As Point,
    parser As V8Parser
)
public:
static void NavigateClasses(
    ComboBox^ comboBox,
    Object^ document,
    Point position,
    V8Parser^ parser
)
static member NavigateClasses :
        comboBox : ComboBox *
        document : Object *
        position : Point *
        parser : V8Parser -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Position in code.
parser
Type: V8Parser
Parser process code.
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.NavigateMethods Method

CodeUtilsNavigateMethods Method
Updates content of given method ComboBox accordingly to given position.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void NavigateMethods(
    ComboBox comboBox,
    Object document,
    Point position,
    ComboBox classComboBox,
    V8Parser parser
)
Public Shared Sub NavigateMethods (
    comboBox As ComboBox,
    document As Object,
    position As Point,
    classComboBox As ComboBox,
    parser As V8Parser
)
public:
static void NavigateMethods(
    ComboBox^ comboBox,
    Object^ document,
    Point position,
    ComboBox^ classComboBox,
    V8Parser^ parser
)
static member NavigateMethods :
        comboBox : ComboBox *
        document : Object *
        position : Point *
        classComboBox : ComboBox *
        parser : V8Parser -> unit

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Position in code.
classComboBox
Type: System.Windows.FormsComboBox
Contains list of classes.
parser
Type: V8Parser
Parser process code.
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


CodeUtils.SelectItem Method

CodeUtilsSelectItem Method
Finds position of the syntax element linked to the currently selected item in the ComboBox control.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool SelectItem(
    ComboBox comboBox,
    Object document,
    out Point position,
    V8Parser parser
)
Public Shared Function SelectItem (
    comboBox As ComboBox,
    document As Object,
    <OutAttribute> ByRef position As Point,
    parser As V8Parser
) As Boolean
public:
static bool SelectItem(
    ComboBox^ comboBox,
    Object^ document,
    [OutAttribute] Point% position,
    V8Parser^ parser
)
static member SelectItem :
        comboBox : ComboBox *
        document : Object *
        position : Point byref *
        parser : V8Parser -> bool

Parameters

comboBox
Type: System.Windows.FormsComboBox
ComboBox to process.
document
Type: SystemObject
Source code document.
position
Type: System.DrawingPoint
Receives start point of currently selected syntax element.
parser
Type: V8Parser
Parser process code.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

CodeUtils Class
Alternet.Editor.TypeScript Namespace


NavigateToNodeRequestedEventArgs Class

NavigateToNodeRequestedEventArgs Class
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Editor.TypeScriptNavigateToNodeRequestedEventArgs

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NavigateToNodeRequestedEventArgs : EventArgs
Public Class NavigateToNodeRequestedEventArgs
    Inherits EventArgs
public ref class NavigateToNodeRequestedEventArgs : public EventArgs
type NavigateToNodeRequestedEventArgs =
    class
        inherit EventArgs
    end

The NavigateToNodeRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NavigateToNodeRequestedEventArgs | Initializes a new instance of the NavigateToNodeRequestedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Node |
Top
See Also

Reference

Alternet.Editor.TypeScript Namespace


NavigateToNodeRequestedEventArgs Constructor

NavigateToNodeRequestedEventArgs Constructor
Initializes a new instance of the NavigateToNodeRequestedEventArgs class

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NavigateToNodeRequestedEventArgs(
    Object node
)
Public Sub New (
    node As Object
)
public:
NavigateToNodeRequestedEventArgs(
    Object^ node
)
new :
        node : Object -> NavigateToNodeRequestedEventArgs

Parameters

node
Type: SystemObject
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.TypeScript Namespace


NavigateToNodeRequestedEventArgs Methods

NavigateToNodeRequestedEventArgs Methods

The NavigateToNodeRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.TypeScript Namespace


NavigateToNodeRequestedEventArgs Properties

NavigateToNodeRequestedEventArgs Properties

The NavigateToNodeRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node |
Top
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.TypeScript Namespace


NavigateToNodeRequestedEventArgs.Node Property

NavigateToNodeRequestedEventArgsNode Property

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Node { get; }
Public ReadOnly Property Node As Object
    Get
public:
property Object^ Node {
    Object^ get ();
}
member Node : Object with get

Property Value

Type: Object
See Also

Reference

NavigateToNodeRequestedEventArgs Class
Alternet.Editor.TypeScript Namespace


TSProject Class

TSProject Class
Represents properties and methods used to store and manipulate TypeScript project content.
Inheritance Hierarchy
SystemObject
Alternet.Common.ProjectsProject
Alternet.Editor.TypeScriptTSProject

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TSProject : Project
Public Class TSProject
    Inherits Project
public ref class TSProject : public Project
type TSProject =
    class
        inherit Project
    end

The TSProject type exposes the following members.

Constructors
 | Name | Description
Public method | TSProject | Initializes a new instance of the TSProject class
Top
Methods
 | Name | Description
Public method | AddFile | Adds specified code or resource file to the project. (Inherited from Project.)
Public method | AddHostAssembly | Adds specified reference to the project.
Public method | AllFiles | Gets list of files included in the project. (Inherited from Project.)
Public method | BeginUpdate | Prevents project updating until calling EndUpdate method. (Inherited from Project.)
Public method | Create | Creates new template project and saves it to the file system.
Public method | EndUpdate | Re-enables project updating, that was turn of by calling BeginUpdate method. (Inherited from Project.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProjectData | Retrieves content of the TypeScript project.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load(String) | Loads project from specified source.
Public method | Load(String, String) | Loads project from specified source.
Public method | MoveFileDown | Moves specified file down one position.
Public method | MoveFileUp | Moves specified file down one position.
Public method | RemoveFile | Removes specified file from the project. (Inherited from Project.)
Public method | RemoveHostAssembly | Removes specified reference from the project.
Public method | Reset | Resets Project to the default state. (Overrides ProjectReset.)
Public method | Save | Saves the project to the file system, if modified.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateHostConfiguration | Updates HostItemsConfiguration for specified project.
Top
Properties
 | Name | Description
Public property | AssemblyNames | Gets list of assembly references included in the project.
Public property | DefaultExtension | Gets a default extension of the project's code files. (Overrides ProjectDefaultExtension.)
Public property | Files | Gets list of files included in the project. (Inherited from Project.)
Public property | HasProject | Gets a value indicating whether project contains some data. (Inherited from Project.)
Public property | HostAssemblies | Gets list of host assemblies included in the project.
Public property | HostAssembliesSearchPaths | Gets list of host assemblies search paths.
Public property | IsFolder | Gets or sets a boolean value indicates whether this Project represents a folder within project collection. (Inherited from Project.)
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save. (Inherited from Project.)
Public property | Language | Gets or sets programming language of the script.
Public property | ProjectExtension | Gets an extension of the this project.
Public property | ProjectFileName | Gets fully qualified name of the project file. (Inherited from Project.)
Public property | ProjectName | Gets or sets project's name. (Inherited from Project.)
Public property | Resources | Gets the list of the resources embedded into the project. (Inherited from Project.)
Public property | TypeDefinitionsSearchPaths | Gets list of type definition search paths.
Public property | UserSettings | Gets user defined settings for this project. (Inherited from Project.)
Top
Events
 | Name | Description
Public event | ProjectModified | Occurs when project content was modified. (Inherited from Project.)
Top
See Also

Reference

Alternet.Editor.TypeScript Namespace


TSProject Constructor

TSProject Constructor
Initializes a new instance of the TSProject class

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TSProject()
Public Sub New
public:
TSProject()
new : unit -> TSProject
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject Methods

TSProject Methods

The TSProject type exposes the following members.

Methods
 | Name | Description
Public method | AddFile | Adds specified code or resource file to the project. (Inherited from Project.)
Public method | AddHostAssembly | Adds specified reference to the project.
Public method | AllFiles | Gets list of files included in the project. (Inherited from Project.)
Public method | BeginUpdate | Prevents project updating until calling EndUpdate method. (Inherited from Project.)
Public method | Create | Creates new template project and saves it to the file system.
Public method | EndUpdate | Re-enables project updating, that was turn of by calling BeginUpdate method. (Inherited from Project.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProjectData | Retrieves content of the TypeScript project.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load(String) | Loads project from specified source.
Public method | Load(String, String) | Loads project from specified source.
Public method | MoveFileDown | Moves specified file down one position.
Public method | MoveFileUp | Moves specified file down one position.
Public method | RemoveFile | Removes specified file from the project. (Inherited from Project.)
Public method | RemoveHostAssembly | Removes specified reference from the project.
Public method | Reset | Resets Project to the default state. (Overrides ProjectReset.)
Public method | Save | Saves the project to the file system, if modified.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateHostConfiguration | Updates HostItemsConfiguration for specified project.
Top
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.AddHostAssembly Method

TSProjectAddHostAssembly Method
Adds specified reference to the project.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AddHostAssembly(
    string fileName
)
Public Function AddHostAssembly (
    fileName As String
) As Boolean
public:
bool AddHostAssembly(
    String^ fileName
)
member AddHostAssembly :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Assembly file to add.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.Create Method

TSProjectCreate Method
Creates new template project and saves it to the file system.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Create(
    ProjectCreationData projectData,
    string basePath
)
Public Function Create (
    projectData As ProjectCreationData,
    basePath As String
) As String
public:
String^ Create(
    ProjectCreationData projectData,
    String^ basePath
)
member Create :
        projectData : ProjectCreationData *
        basePath : string -> string

Parameters

projectData
Type: Alternet.Common.ProjectsProjectCreationData
Data of the project.
basePath
Type: SystemString
Relative path to the template project file.

Return Value

Type: String
Full project name.
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.GetProjectData Method

TSProjectGetProjectData Method
Retrieves content of the TypeScript project.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectData GetProjectData()
Public Function GetProjectData As ProjectData
public:
ProjectData^ GetProjectData()
member GetProjectData : unit -> ProjectData

Return Value

Type: ProjectData
ProjectData contains all project data.
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.Load Method

TSProjectLoad Method
Overload List
 | Name | Description
Public method | Load(String) | Loads project from specified source.
Public method | Load(String, String) | Loads project from specified source.
Top
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.Load Method (String)

TSProjectLoad Method (String)
Loads project from specified source.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ProjectData Load(
    string projectFileName
)
Public Overridable Function Load (
    projectFileName As String
) As ProjectData
public:
virtual ProjectData^ Load(
    String^ projectFileName
)
abstract Load :
        projectFileName : string -> ProjectData
override Load :
        projectFileName : string -> ProjectData

Parameters

projectFileName
Type: SystemString
Path to the project file.

Return Value

Type: ProjectData
ProjectData containing project-related data.
See Also

Reference

TSProject Class
Load Overload
Alternet.Editor.TypeScript Namespace


TSProject.Load Method (String, String)

TSProjectLoad Method (String, String)
Loads project from specified source.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ProjectData Load(
    string projectFileName,
    string projectName
)
Public Overridable Function Load (
    projectFileName As String,
    projectName As String
) As ProjectData
public:
virtual ProjectData^ Load(
    String^ projectFileName,
    String^ projectName
)
abstract Load :
        projectFileName : string *
        projectName : string -> ProjectData
override Load :
        projectFileName : string *
        projectName : string -> ProjectData

Parameters

projectFileName
Type: SystemString
Path to the project file.
projectName
Type: SystemString
Project name.

Return Value

Type: ProjectData
ProjectData containing project-related data.
See Also

Reference

TSProject Class
Load Overload
Alternet.Editor.TypeScript Namespace


TSProject.MoveFileDown Method

TSProjectMoveFileDown Method
Moves specified file down one position.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveFileDown(
    string fileName
)
Public Sub MoveFileDown (
    fileName As String
)
public:
void MoveFileDown(
    String^ fileName
)
member MoveFileDown :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
File to reposition.
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.MoveFileUp Method

TSProjectMoveFileUp Method
Moves specified file down one position.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveFileUp(
    string fileName
)
Public Sub MoveFileUp (
    fileName As String
)
public:
void MoveFileUp(
    String^ fileName
)
member MoveFileUp :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
File to reposition.
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.RemoveHostAssembly Method

TSProjectRemoveHostAssembly Method
Removes specified reference from the project.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveHostAssembly(
    string name
)
Public Function RemoveHostAssembly (
    name As String
) As Boolean
public:
bool RemoveHostAssembly(
    String^ name
)
member RemoveHostAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Assembly name to remove.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.Reset Method

TSProjectReset Method
Resets Project to the default state.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.Save Method

TSProjectSave Method
Saves the project to the file system, if modified.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Save()
Public Overridable Sub Save
public:
virtual void Save()
abstract Save : unit -> unit
override Save : unit -> unit
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.UpdateHostConfiguration Method

TSProjectUpdateHostConfiguration Method
Updates HostItemsConfiguration for specified project.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateHostConfiguration(
    ITypeScriptProject typeScriptProject,
    HostItemsConfiguration hostItemsConfiguration
)
Public Sub UpdateHostConfiguration (
    typeScriptProject As ITypeScriptProject,
    hostItemsConfiguration As HostItemsConfiguration
)
public:
void UpdateHostConfiguration(
    ITypeScriptProject^ typeScriptProject,
    HostItemsConfiguration^ hostItemsConfiguration
)
member UpdateHostConfiguration :
        typeScriptProject : ITypeScriptProject *
        hostItemsConfiguration : HostItemsConfiguration -> unit

Parameters

typeScriptProject
Type: ITypeScriptProject
Project to be updated.
hostItemsConfiguration
Type: HostItemsConfiguration
New HostItemsConfiguration value.
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject Properties

TSProject Properties

The TSProject type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyNames | Gets list of assembly references included in the project.
Public property | DefaultExtension | Gets a default extension of the project's code files. (Overrides ProjectDefaultExtension.)
Public property | Files | Gets list of files included in the project. (Inherited from Project.)
Public property | HasProject | Gets a value indicating whether project contains some data. (Inherited from Project.)
Public property | HostAssemblies | Gets list of host assemblies included in the project.
Public property | HostAssembliesSearchPaths | Gets list of host assemblies search paths.
Public property | IsFolder | Gets or sets a boolean value indicates whether this Project represents a folder within project collection. (Inherited from Project.)
Public property | IsModified | Gets or sets a value indicating whether project content has been modified since last save. (Inherited from Project.)
Public property | Language | Gets or sets programming language of the script.
Public property | ProjectExtension | Gets an extension of the this project.
Public property | ProjectFileName | Gets fully qualified name of the project file. (Inherited from Project.)
Public property | ProjectName | Gets or sets project's name. (Inherited from Project.)
Public property | Resources | Gets the list of the resources embedded into the project. (Inherited from Project.)
Public property | TypeDefinitionsSearchPaths | Gets list of type definition search paths.
Public property | UserSettings | Gets user defined settings for this project. (Inherited from Project.)
Top
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.AssemblyNames Property

TSProjectAssemblyNames Property
Gets list of assembly references included in the project.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> AssemblyNames { get; }
Public ReadOnly Property AssemblyNames As IList(Of String)
    Get
public:
property IList<String^>^ AssemblyNames {
    IList<String^>^ get ();
}
member AssemblyNames : IList<string> with get

Property Value

Type: IListString
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.DefaultExtension Property

TSProjectDefaultExtension Property
Gets a default extension of the project's code files.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string DefaultExtension { get; }
Public Overrides ReadOnly Property DefaultExtension As String
    Get
public:
virtual property String^ DefaultExtension {
    String^ get () override;
}
abstract DefaultExtension : string with get
override DefaultExtension : string with get

Property Value

Type: String
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.HostAssemblies Property

TSProjectHostAssemblies Property
Gets list of host assemblies included in the project.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<HostAssembly> HostAssemblies { get; }
Public ReadOnly Property HostAssemblies As IList(Of HostAssembly)
    Get
public:
property IList<HostAssembly^>^ HostAssemblies {
    IList<HostAssembly^>^ get ();
}
member HostAssemblies : IList<HostAssembly> with get

Property Value

Type: IListHostAssembly
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.HostAssembliesSearchPaths Property

TSProjectHostAssembliesSearchPaths Property
Gets list of host assemblies search paths.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> HostAssembliesSearchPaths { get; }
Public ReadOnly Property HostAssembliesSearchPaths As IList(Of String)
    Get
public:
property IList<String^>^ HostAssembliesSearchPaths {
    IList<String^>^ get ();
}
member HostAssembliesSearchPaths : IList<string> with get

Property Value

Type: IListString
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.Language Property

TSProjectLanguage Property
Gets or sets programming language of the script.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Property Value

Type: String
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.ProjectExtension Property

TSProjectProjectExtension Property
Gets an extension of the this project.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectExtension { get; }
Public ReadOnly Property ProjectExtension As String
    Get
public:
property String^ ProjectExtension {
    String^ get ();
}
member ProjectExtension : string with get

Property Value

Type: String
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject.TypeDefinitionsSearchPaths Property

TSProjectTypeDefinitionsSearchPaths Property
Gets list of type definition search paths.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> TypeDefinitionsSearchPaths { get; }
Public ReadOnly Property TypeDefinitionsSearchPaths As IList(Of String)
    Get
public:
property IList<String^>^ TypeDefinitionsSearchPaths {
    IList<String^>^ get ();
}
member TypeDefinitionsSearchPaths : IList<string> with get

Property Value

Type: IListString
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProject Events

TSProject Events

The TSProject type exposes the following members.

Events
 | Name | Description
Public event | ProjectModified | Occurs when project content was modified. (Inherited from Project.)
Top
See Also

Reference

TSProject Class
Alternet.Editor.TypeScript Namespace


TSProjectExplorer Class

TSProjectExplorer Class
Represents methods used to explore particular project in the TreeView control.
Inheritance Hierarchy
SystemObject
Alternet.Editor.CommonProjectExplorer
Alternet.Editor.TypeScriptTSProjectExplorer

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TSProjectExplorer : ProjectExplorer
Public Class TSProjectExplorer
    Inherits ProjectExplorer
public ref class TSProjectExplorer : public ProjectExplorer
type TSProjectExplorer =
    class
        inherit ProjectExplorer
    end

The TSProjectExplorer type exposes the following members.

Constructors
 | Name | Description
Public method | TSProjectExplorer | Initializes a new instance of the ProjectExplorer class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given project. (Inherited from ProjectExplorer.)
Top
Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore project's content. (Inherited from ProjectExplorer.)
Top
See Also

Reference

Alternet.Editor.TypeScript Namespace


TSProjectExplorer Constructor

TSProjectExplorer Constructor
Initializes a new instance of the ProjectExplorer class with default settings.

Namespace: Alternet.Editor.TypeScript
Assembly: Alternet.Editor.TypeScript.v7 (in Alternet.Editor.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TSProjectExplorer()
Public Sub New
public:
TSProjectExplorer()
new : unit -> TSProjectExplorer
See Also

Reference

TSProjectExplorer Class
Alternet.Editor.TypeScript Namespace


TSProjectExplorer Methods

TSProjectExplorer Methods

The TSProjectExplorer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExplorer | Updates explorer content from given project. (Inherited from ProjectExplorer.)
Top
See Also

Reference

TSProjectExplorer Class
Alternet.Editor.TypeScript Namespace


TSProjectExplorer Properties

TSProjectExplorer Properties

The TSProjectExplorer type exposes the following members.

Properties
 | Name | Description
Public property | ExplorerTree | Gets or sets System.Windows.Forms.TreeView control used to explore project's content. (Inherited from ProjectExplorer.)
Top
See Also

Reference

TSProjectExplorer Class
Alternet.Editor.TypeScript Namespace


Alternet.FormDesigner.Integration Namespace

Alternet.FormDesigner.Integration Namespace
Classes
 | Class | Description
Public class | FormDesignerEditorHelpers |
Public class | FormDesignerTextSource |


FormDesignerEditorHelpers Class

FormDesignerEditorHelpers Class
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.IntegrationFormDesignerEditorHelpers

Namespace: Alternet.FormDesigner.Integration
Assembly: Alternet.FormDesigner.Integration.v7 (in Alternet.FormDesigner.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FormDesignerEditorHelpers
Public NotInheritable Class FormDesignerEditorHelpers
public ref class FormDesignerEditorHelpers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FormDesignerEditorHelpers =  class end

The FormDesignerEditorHelpers type exposes the following members.

Methods
Name | Description
SetEditorSource |
Top
See Also

Reference

Alternet.FormDesigner.Integration Namespace


FormDesignerEditorHelpers Methods

FormDesignerEditorHelpers Methods

The FormDesignerEditorHelpers type exposes the following members.

Methods
Name | Description
SetEditorSource |
Top
See Also

Reference

FormDesignerEditorHelpers Class
Alternet.FormDesigner.Integration Namespace


FormDesignerEditorHelpers.SetEditorSource Method

FormDesignerEditorHelpersSetEditorSource Method

Namespace: Alternet.FormDesigner.Integration
Assembly: Alternet.FormDesigner.Integration.v7 (in Alternet.FormDesigner.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetEditorSource(
    IScriptEdit edit,
    string fileName,
    EditorFormDesignerDataSource source
)
Public Shared Sub SetEditorSource (
    edit As IScriptEdit,
    fileName As String,
    source As EditorFormDesignerDataSource
)
public:
static void SetEditorSource(
    IScriptEdit^ edit,
    String^ fileName,
    EditorFormDesignerDataSource^ source
)
static member SetEditorSource :
        edit : IScriptEdit *
        fileName : string *
        source : EditorFormDesignerDataSource -> unit

Parameters

edit
Type: Alternet.Editor.CommonIScriptEdit
fileName
Type: SystemString
source
Type: Alternet.FormDesigner.WinFormsEditorFormDesignerDataSource
See Also

Reference

FormDesignerEditorHelpers Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource Class

FormDesignerTextSource Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Editor.TextSourceTextSource
Alternet.FormDesigner.IntegrationFormDesignerTextSource

Namespace: Alternet.FormDesigner.Integration
Assembly: Alternet.FormDesigner.Integration.v7 (in Alternet.FormDesigner.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormDesignerTextSource : TextSource,
    IFormDesignerTextSource
Public Class FormDesignerTextSource
    Inherits TextSource
    Implements IFormDesignerTextSource
public ref class FormDesignerTextSource : public TextSource,
    IFormDesignerTextSource
type FormDesignerTextSource =
    class
        inherit TextSource
        interface IFormDesignerTextSource
    end

The FormDesignerTextSource type exposes the following members.

Constructors
 | Name | Description
Public method | FormDesignerTextSource | Initializes a new instance of the FormDesignerTextSource class
Top
Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | Converts given absolute position to position as Point value. (Inherited from TextSource.)
Public method | AddNotifier | Adds new handler to respond for notification. (Inherited from TextSource.)
Public method | AddUndo | Stores undo operation in the appropriate list. (Inherited from TextSource.)
Public method | BeginUndoUpdate | Allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method. (Inherited from TextSource.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from TextSource.)
Public method | BeginUpdate(UpdateReason) | Prevents object state updating until calling EndUpdate method. (Inherited from TextSource.)
Public method | BeginUpdateSnippet | Prevents the Edit control from updating snippets until the EndUpdateSnippet method is called. (Inherited from TextSource.)
Public method | BreakLine | Breaks current line into two lines. (Inherited from TextSource.)
Public method | CancelParsing | Stops formatting timer. (Inherited from TextSource.)
Public method | CanRedo | Indicating whether the redo operation can be performed. (Inherited from TextSource.)
Public method | CanUndo | Indicating whether the undo operation can be performed. (Inherited from TextSource.)
Public method | Clear | Clears content of the TextSource (Inherited from TextSource.)
Public method | ClearRedo | Clears list of redo operations. (Inherited from TextSource.)
Public method | ClearUndo | Clears list of undo operations. (Inherited from TextSource.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateStringItem | Create a new IStringItem object containing specified text. (Inherited from TextSource.)
Public method | DeleteBlock(Rectangle, Boolean) | Deletes a specified block of characters. (Inherited from TextSource.)
Public method | DeleteBlock(Int32, Boolean) | Deletes a specified block of characters. (Inherited from TextSource.)
Public method | DeleteLeft | Deletes a specified number of characters to the left of the active point. (Inherited from TextSource.)
Public method | DeleteRight | Deletes a specified number of characters to the right of the active point. (Inherited from TextSource.)
Public method | DisablePositionUpdate | Prevents notification of changing of caret position until calling EnablePositionUpdate method. (Inherited from TextSource.)
Public method | DisableUndo | Disables recording of undo/redo operations. (Inherited from TextSource.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from TextSource.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnablePositionUpdate | Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method. (Inherited from TextSource.)
Public method | EnableUndo | Re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method. (Inherited from TextSource.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from TextSource.)
Public method | EndUndoUpdate | Ends undo block, that was started by BeginUndoUpdate method. (Inherited from TextSource.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from TextSource.)
Public method | EndUpdateSnippet | Resumes updating snippets after updating is suspended by the BeginUpdateSnippet method. (Inherited from TextSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindClosingBrace(Point) | Locates closing brace. (Inherited from TextSource.)
Public method | FindClosingBrace(Int32, Int32) | Locates closing brace. (Inherited from TextSource.)
Public method | FindOpenBrace(Point) | Locates open brace. (Inherited from TextSource.)
Public method | FindOpenBrace(Int32, Int32) | Locates open brace. (Inherited from TextSource.)
Public method | FormatText | Tries to format and outline TextSource text using attached Lexer. (Inherited from TextSource.)
Public method | FormatText(Boolean, Boolean) | Tries to format and outline TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing (Inherited from TextSource.)
Public method | GetCharIndexFromPosition | Converts given Point value to the index of character. (Inherited from TextSource.)
Public method | GetCodeFixes | Gets code fixes for a given syntax error. (Inherited from TextSource.)
Public method | GetCodeSnippetRangeAt | Locates code snippet at specified position. (Inherited from TextSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString | Gets indentation string at current position. (Inherited from TextSource.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPositionFromCharIndex | Converts given character index to position as Point value. (Inherited from TextSource.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from TextSource.)
Public method | GetSyntaxErrorAt | Gets syntax error at specified position. (Inherited from TextSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightBraces | Highlights braces containing caret position. (Inherited from TextSource.)
Public method | HighlightCodeFixes | Highlights code fixes if needed. (Inherited from TextSource.)
Public method | HighlightCodeRefactors | Highlights code fixes if needed. (Inherited from TextSource.)
Public method | HighlightCodeSnippets | Highlights code snippets using appropriate style. (Inherited from TextSource.)
Public method | HighlightSyntaxErrors | Highlights syntax errors. (Inherited from TextSource.)
Public method | IndentLine | Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned. (Inherited from TextSource.)
Public method | IndentLine(String, Boolean) | Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser (Inherited from TextSource.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Insert | Inserts the given string at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean) | Inserts the given string at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean) | Inserts the given string array at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(ITextStrings, Boolean) | Inserts the given string collection at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean, Boolean) | Inserts the given string array at the specified location. (Inherited from TextSource.)
Public method | InsertFromFile | Inserts the file text content at the specified location. (Inherited from TextSource.)
Public method | InsertText |
Public method | InvalidateSyntaxErrors | Invalidates highlighting of syntax errors. (Inherited from TextSource.)
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line. (Inherited from TextSource.)
Public method | IsHyperText | Indicates whether given text represents hypertext. (Inherited from TextSource.)
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct. (Inherited from TextSource.)
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct. (Inherited from TextSource.)
Public method | LineIsHidden | Determines whether the given line is readonly. (Inherited from TextSource.)
Public method | LineIsModified(Int32) | Indicates whether specified line already modified. (Inherited from TextSource.)
Public method | LineIsModified(Int32, Boolean) | Indicates whether specified line already modified. (Inherited from TextSource.)
Public method | LineIsReadonly | Determines whether the given line is readonly. (Inherited from TextSource.)
Public method | LinesChanged(Int32, Int32) | Specifies range of lines that was changed. (Inherited from TextSource.)
Public method | LinesChanged(Int32, Int32, Boolean) | Specifies range of lines that was changed. (Inherited from TextSource.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from TextSource.)
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer. (Inherited from TextSource.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from TextSource.)
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding. (Inherited from TextSource.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer. (Inherited from TextSource.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer. (Inherited from TextSource.)
Public method | MoveTo(Point) | Moves the current position to the given position. (Inherited from TextSource.)
Public method | MoveTo(Int32, Int32) | Moves the current position to the given position. (Inherited from TextSource.)
Public method | MoveToChar | Moves the current position to the specified character in the current line. (Inherited from TextSource.)
Public method | MoveToLine(Int32) | Moves the current position to the specified line. (Inherited from TextSource.)
Public method | MoveToLine(Int32, Int32) | Moves the current position to the specified line. (Inherited from TextSource.)
Public method | Navigate | Moves current position by the given offset value. (Inherited from TextSource.)
Public method | NeedAutoComplete | Indicates whether ITextSource should try to autocomplete statements. (Inherited from TextSource.)
Public method | NeedCacheIndent | Indicates whether ITextSource can reuse previous indentation. (Inherited from TextSource.)
Public method | NeedCodeCompletion | Indicates whether ITextSource can provide code completion operation for its content. (Inherited from TextSource.)
Public method | NeedCodeCompletionTabs | Indicates code completion content can be filtered based on its priority. (Inherited from TextSource.)
Public method | NeedCodeFixes | Indicates whether ITextSource can provide code fixes operation for its content. (Inherited from TextSource.)
Public method | NeedCodeRefactors | Indicates whether ITextSource can provide code fixes operation for its content. (Inherited from TextSource.)
Public method | NeedContentDividers | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedFormatText | Indicates whether ITextSource can format its content. (Inherited from TextSource.)
Public method | NeedFormatTextOnLineChange | Indicates whether ITextSource should format spaces and case when changing the current line. (Inherited from TextSource.)
Public method | NeedIndentText | Indicates whether ITextSource can indent its content. (Inherited from TextSource.)
Public method | NeedOutlineText | Indicates whether ITextSource can outline its content. (Inherited from TextSource.)
Public method | NeedParse | Indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted. (Inherited from TextSource.)
Public method | NeedQuickInfoTips | Indicates whether ITextSource can obtain short description for syntax tokens within its content. (Inherited from TextSource.)
Public method | NeedReparseText | Indicates whether ITextSource can perform syntax analysis of its content. (Inherited from TextSource.)
Public method | NeedReparseTextOnLineChange | Indicates whether ITextSource should replace text when changing the current line. (Inherited from TextSource.)
Public method | NeedStructureGuideLines | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedSyntaxErrors | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedWorkInThread | Indicates whether ITextSource can perform syntax analysis in thread. (Inherited from TextSource.)
Public method | NewLine | Inserts a line break at the current position. (Inherited from TextSource.)
Public method | NewLine(String, Boolean) | Inserts a line break at the current position with indentation. (Inherited from TextSource.)
Public method | NewLineAbove | Inserts a line break above the current position. (Inherited from TextSource.)
Public method | NewLineBelow | Inserts a line break below the current position. (Inherited from TextSource.)
Public method | Notification | Updates control's content according to parameters of notification. (Inherited from TextSource.)
Public method | Notify | Notifies all notifiers about changing source state. (Inherited from TextSource.)
Public method | ParseString | Perform lexical analysis of the specified string. (Inherited from TextSource.)
Public method | ParseStrings | Perform lexical analysis specified strings. (Inherited from TextSource.)
Public method | ParseToString | Perform lexical analysis of specified strings. (Inherited from TextSource.)
Public method | PositionIsReadonly | Determines whether the text at given position is readonly. (Inherited from TextSource.)
Public method | ProcessAutoComplete | Inserts end-of-block code fragment if needed. (Inherited from TextSource.)
Public method | Redo | Performs the last redo operation. (Inherited from TextSource.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from TextSource.)
Public method | ReplaceText |
Public method | ResetBracesOptions | Resets the BracesOptions to its default value. (Inherited from TextSource.)
Public method | ResetCheckSpelling | Resets the CheckSpelling to the default value. (Inherited from TextSource.)
Public method | ResetClosingBraces | Resets the ClosingBraces to its default value. (Inherited from TextSource.)
Public method | ResetHighlightHyperText | Resets HighlightHyperText to the default value. (Inherited from TextSource.)
Public method | ResetIndentOptions | Resets the IndentOptions to the default value. (Inherited from TextSource.)
Public method | ResetMaxLength | Resets the MaxLength to the default value. (Inherited from TextSource.)
Public method | ResetModified | Resets the Modified to the default value. (Inherited from TextSource.)
Public method | ResetNavigateOptions | Resets the NavigateOptions to the default value. (Inherited from TextSource.)
Public method | ResetOpenBraces | Resets the OpenBraces to its default value. (Inherited from TextSource.)
Public method | ResetOverWrite | Resets the OverWrite to the default value. (Inherited from TextSource.)
Public method | ResetReadOnly | Resets the ReadOnly to the default value. (Inherited from TextSource.)
Public method | ResetSingleLineMode | Resets the SingleLineMode to the default value. (Inherited from TextSource.)
Public method | ResetSpellDelimiters | Resets the SpellDelimiters to the default value. (Inherited from TextSource.)
Public method | ResetUndoLimit | Resets the UndoLimit to the default value. (Inherited from TextSource.)
Public method | ResetUndoOptions | Resets the UndoOptions to the default value. (Inherited from TextSource.)
Public method | RestorePosition | Restores position from stored position list by given index. (Inherited from TextSource.)
Public method | RestorePositionWithUndo | Restores position from stored position list by given index. (Inherited from TextSource.)
Public method | SaveFile(String) | Saves text content to the specific file. (Inherited from TextSource.)
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specific exporter. (Inherited from TextSource.)
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding. (Inherited from TextSource.)
Public method | SaveFile(String, IStringExport, Encoding) | Saves text content to the specific file with specific exporter and encoding. (Inherited from TextSource.)
Public method | SaveStream(Stream) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SetLastParsed | Updates the last parsed line and resets first changed line to it's default value. (Inherited from TextSource.)
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineState | Sets item state for the given line. (Inherited from TextSource.)
Public method | SetNavigateOptions | Sets navigating options without validating position. (Inherited from TextSource.)
Public method | ShouldSerializeClosingBraces | Indicates whether the ClosingBraces property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeIndentOptions | Indicates whether the IndentOptions property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeLexer | Indicates whether the Lexer property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeNavigateOptions | Indicates whether the NavigateOptions property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeOpenBraces | Indicates whether the OpenBraces property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeText | Indicates whether the Text property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeUndoOptions | Indicates whether the UndoOptions property should be persisted. (Inherited from TextSource.)
Public method | StartThread | Executes action in thread. (Inherited from TextSource.)
Public method | StopThread | Aborts executing action in thread. (Inherited from TextSource.)
Public method | StorePosition(Point) | Stores given position to stored position list. (Inherited from TextSource.)
Public method | StorePosition(Point, Boolean) | Stores given position to stored position list. (Inherited from TextSource.)
Public method | StorePositionWithUndo | Stores given position to stored position list preserving it for undo. (Inherited from TextSource.)
Public method | SupportsAsyncParsing | (Inherited from TextSource.)
Public method | TempHighlightBraces | Temporary highlights all text within the area specified by rects. (Inherited from TextSource.)
Public method | TempHighlightMatchingBlocks | Highlights block match. (Inherited from TextSource.)
Public method | TempHighlightReferences | Highlights found references. (Inherited from TextSource.)
Public method | TempHighlightSearchResults | Highlights search results. (Inherited from TextSource.)
Public method | TempUnhighlightBraces | Cancels text highlighting turned on using TempHighlightBraces (Inherited from TextSource.)
Public method | TempUnhighlightBraces(Boolean) | Unhighlights temporary braces areas. (Inherited from TextSource.)
Public method | TempUnhighlightReferences | Unhighlights references highlighted with previous call of TempHighlightReferences. (Inherited from TextSource.)
Public method | TempUnhighlightSearchResults | Unhighlights search results highlighted with previous call of TempHighlightSearchResults. (Inherited from TextSource.)
Public method | TextPointToAbsolutePosition | Converts given Point value to the absolute position. (Inherited from TextSource.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnBreakLine | Concatenates lines at current position. (Inherited from TextSource.)
Public method | Undo(Boolean) | (Overrides TextSourceUndo(Boolean).)
Public method | Undo(IUndoData, Boolean) | Performs the single undo operation. (Inherited from TextSource.)
Public method | UnhighlightBraces | Unhighlights braces containing caret position. (Inherited from TextSource.)
Public method | UnhighlightBraces(Boolean) | Unhighlights braces. (Inherited from TextSource.)
Public method | UnhighlightCodeSnippets | Removes highlighting from code snippets and clears snippet collection. (Inherited from TextSource.)
Public method | UnhighlightSyntaxErrors | Removes syntax errors highlighting. (Inherited from TextSource.)
Public method | Update | Updates an object state. (Inherited from TextSource.)
Public method | ValidatePosition | Validates given position within control's text content. (Inherited from TextSource.)
Top
Fields
Name | Description
FormDesignerTitle |
ModifiedByDesignerWhileUndo |
Top
Properties
 | Name | Description
Public property | ActiveEdit | Gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source. (Inherited from TextSource.)
Public property | BookMarks | Represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source. (Inherited from TextSource.)
Public property | BracesOptions | Gets or sets options specifying appearance and behaviour of matching braces within Edit control. (Inherited from TextSource.)
Public property | CheckSpelling | Gets or sets a value indicating whether the document can check spelling for its content. (Inherited from TextSource.)
Public property | ClosingBraces | Gets or sets an array of characters each one representing a closing brace. (Inherited from TextSource.)
Public property | CodeSnippets | Gets or sets ICodeSnippetRangeList for Edit control. (Inherited from TextSource.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentSnippet | Gets or sets current ICodeSnippetRange object. (Inherited from TextSource.)
Public property | Edits | Represents a collection of ISyntaxEdit controls linked to the text source. (Inherited from TextSource.)
Public property | FileName | Gets or sets name of file that holds text source content. (Inherited from TextSource.)
Public property | FirstChanged | Represents index of the first changed line. (Inherited from TextSource.)
Public property | GlobalSearch | Specifies whether search should be global. (Inherited from TextSource.)
Public property | HasSpelling | Gets boolean value indicating that editor has external spell checker assigned. (Inherited from TextSource.)
Public property | HighlightHyperText | Gets or sets a value indicating whether hypertext in the text should be highlighted. (Inherited from TextSource.)
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight found block matches. (Inherited from TextSource.)
Public property | HighlightReferences | Specifies that edit control should highlight found references. (Inherited from TextSource.)
Public property | IndentOptions | Gets or sets Alternet.Editor.TextSource.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from TextSource.)
Public property | LastChanged | Represents index of the last changed line. (Inherited from TextSource.)
Public property | Lexer | Gets or sets object that can perform lexical analysis of the text source content. (Inherited from TextSource.)
Public property | Lines | Represents the object that implements ITextStrings interface containing collection of strings determining text source content. (Inherited from TextSource.)
Public property | LineStyles | Represents an object that implements ILineStyles interface holding collection of line styles for this document. (Inherited from TextSource.)
Public property | LineTerminator | Gets or sets a string value that terminates line. (Inherited from TextSource.)
Public property | MatchingBlocks | Gets or sets IRangeList of matching begin/end blocks for Edit control. (Inherited from TextSource.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control. (Inherited from TextSource.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified. (Inherited from TextSource.)
Public property | ModifiedLineRegions | Gets modified lines information, grouped in regions. (Inherited from TextSource.)
Public property | ModifiedLines | Gets modified lines information. (Inherited from TextSource.)
Public property | NavigateOptions | Gets or sets navigating options. (Inherited from TextSource.)
Public property | OpenBraces | Gets or sets an array of characters each one representing an open brace. (Inherited from TextSource.)
Public property | OptimizedForMemory | Specifies whether internal text representation should optimized memory usage. (Inherited from TextSource.)
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from TextSource.)
Public property | ParserLine | Gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text. (Inherited from TextSource.)
Public property | Position | Gets or sets current position within the control's text content. (Inherited from TextSource.)
Public property | PrevPosition | Gets previous position within the control's text content. (Inherited from TextSource.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only. (Inherited from TextSource.)
Public property | RedoList | Provides an indexed access to redo data. (Inherited from TextSource.)
Public property | References | Gets or sets IRangeList of found references for Edit control. (Inherited from TextSource.)
Public property | SearchResults | Gets or sets IRangeList of search results for Edit control. (Inherited from TextSource.)
Public property | SelectBlockRect | Represents a rectangular block of selected text. (Inherited from TextSource.)
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from TextSource.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpellDelimiters | Gets or sets an array of chars used to separate words in a text. (Inherited from TextSource.)
Public property | SpellDelimiterString | Gets or sets Delimiters as a single string. (Inherited from TextSource.)
Public property | SpellTable | Represents a hash table containing delimiters. (Inherited from TextSource.)
Public property | State | Gets or sets last changes to the text stored in the text source. (Inherited from TextSource.)
Public property | Strings | Gets or sets text source content in the form of string array. (Inherited from TextSource.)
Public property | StructureGuideLines | Represents a syntax errors collection. (Inherited from TextSource.)
Public property | SyntaxErrors | Represents a syntax errors collection. (Inherited from TextSource.)
Public property | Text | Gets or sets text source content as a single string with the individual strings delimited by carriage returns. (Inherited from TextSource.)
Public property | ThreadAction | Returns method executed in thread when parsing. (Inherited from TextSource.)
Public property | UndoLimit | Gets or sets a value that limits number of undo operations. (Inherited from TextSource.)
Public property | UndoList | Provides an indexed access to undo data. (Inherited from TextSource.)
Public property | UndoOptions | Gets or sets options for undo and redo operations. (Inherited from TextSource.)
Public property | UndoUpdateCount | Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested. (Inherited from TextSource.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from TextSource.)
Public property | UrlTable | Represents hash table containing hyper-text characters. (Inherited from TextSource.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | HyperText | Occurs when a control needs checking whether some string represents hypertext. (Inherited from TextSource.)
Public event | UndoEvent | Occurs when undo/redo operation performed. (Inherited from TextSource.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking. (Inherited from TextSource.)
Top
See Also

Reference

Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource Constructor

FormDesignerTextSource Constructor
Initializes a new instance of the FormDesignerTextSource class

Namespace: Alternet.FormDesigner.Integration
Assembly: Alternet.FormDesigner.Integration.v7 (in Alternet.FormDesigner.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormDesignerTextSource()
Public Sub New
public:
FormDesignerTextSource()
new : unit -> FormDesignerTextSource
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource Fields

FormDesignerTextSource Fields

The FormDesignerTextSource type exposes the following members.

Fields
Name | Description
FormDesignerTitle |
ModifiedByDesignerWhileUndo |
Top
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource.FormDesignerTitle Field

FormDesignerTextSourceFormDesignerTitle Field

Namespace: Alternet.FormDesigner.Integration
Assembly: Alternet.FormDesigner.Integration.v7 (in Alternet.FormDesigner.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string FormDesignerTitle
Public Const FormDesignerTitle As String
public:
literal String^ FormDesignerTitle
static val mutable FormDesignerTitle: string

Field Value

Type: String
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource.ModifiedByDesignerWhileUndo Field

FormDesignerTextSourceModifiedByDesignerWhileUndo Field

Namespace: Alternet.FormDesigner.Integration
Assembly: Alternet.FormDesigner.Integration.v7 (in Alternet.FormDesigner.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ModifiedByDesignerWhileUndo
Public Const ModifiedByDesignerWhileUndo As String
public:
literal String^ ModifiedByDesignerWhileUndo
static val mutable ModifiedByDesignerWhileUndo: string

Field Value

Type: String
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource Methods

FormDesignerTextSource Methods

The FormDesignerTextSource type exposes the following members.

Methods
 | Name | Description
Public method | AbsolutePositionToTextPoint | Converts given absolute position to position as Point value. (Inherited from TextSource.)
Public method | AddNotifier | Adds new handler to respond for notification. (Inherited from TextSource.)
Public method | AddUndo | Stores undo operation in the appropriate list. (Inherited from TextSource.)
Public method | BeginUndoUpdate | Allows to consider number of undo redo operations as single operation, until calling EndUndoUpdate method. (Inherited from TextSource.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from TextSource.)
Public method | BeginUpdate(UpdateReason) | Prevents object state updating until calling EndUpdate method. (Inherited from TextSource.)
Public method | BeginUpdateSnippet | Prevents the Edit control from updating snippets until the EndUpdateSnippet method is called. (Inherited from TextSource.)
Public method | BreakLine | Breaks current line into two lines. (Inherited from TextSource.)
Public method | CancelParsing | Stops formatting timer. (Inherited from TextSource.)
Public method | CanRedo | Indicating whether the redo operation can be performed. (Inherited from TextSource.)
Public method | CanUndo | Indicating whether the undo operation can be performed. (Inherited from TextSource.)
Public method | Clear | Clears content of the TextSource (Inherited from TextSource.)
Public method | ClearRedo | Clears list of redo operations. (Inherited from TextSource.)
Public method | ClearUndo | Clears list of undo operations. (Inherited from TextSource.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateStringItem | Create a new IStringItem object containing specified text. (Inherited from TextSource.)
Public method | DeleteBlock(Rectangle, Boolean) | Deletes a specified block of characters. (Inherited from TextSource.)
Public method | DeleteBlock(Int32, Boolean) | Deletes a specified block of characters. (Inherited from TextSource.)
Public method | DeleteLeft | Deletes a specified number of characters to the left of the active point. (Inherited from TextSource.)
Public method | DeleteRight | Deletes a specified number of characters to the right of the active point. (Inherited from TextSource.)
Public method | DisablePositionUpdate | Prevents notification of changing of caret position until calling EnablePositionUpdate method. (Inherited from TextSource.)
Public method | DisableUndo | Disables recording of undo/redo operations. (Inherited from TextSource.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from TextSource.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnablePositionUpdate | Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method. (Inherited from TextSource.)
Public method | EnableUndo | Re-enables recording of undo/redo operations, that was turn of by calling DisableUndo method. (Inherited from TextSource.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from TextSource.)
Public method | EndUndoUpdate | Ends undo block, that was started by BeginUndoUpdate method. (Inherited from TextSource.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from TextSource.)
Public method | EndUpdateSnippet | Resumes updating snippets after updating is suspended by the BeginUpdateSnippet method. (Inherited from TextSource.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindClosingBrace(Point) | Locates closing brace. (Inherited from TextSource.)
Public method | FindClosingBrace(Int32, Int32) | Locates closing brace. (Inherited from TextSource.)
Public method | FindOpenBrace(Point) | Locates open brace. (Inherited from TextSource.)
Public method | FindOpenBrace(Int32, Int32) | Locates open brace. (Inherited from TextSource.)
Public method | FormatText | Tries to format and outline TextSource text using attached Lexer. (Inherited from TextSource.)
Public method | FormatText(Boolean, Boolean) | Tries to format and outline TextSource text using attached Lexer. Indicates if parsing should be performed without instantiating parser thread.Indicates if attached editors should be notified on reparsing (Inherited from TextSource.)
Public method | GetCharIndexFromPosition | Converts given Point value to the index of character. (Inherited from TextSource.)
Public method | GetCodeFixes | Gets code fixes for a given syntax error. (Inherited from TextSource.)
Public method | GetCodeSnippetRangeAt | Locates code snippet at specified position. (Inherited from TextSource.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentString | Gets indentation string at current position. (Inherited from TextSource.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPositionFromCharIndex | Converts given character index to position as Point value. (Inherited from TextSource.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from TextSource.)
Public method | GetSyntaxErrorAt | Gets syntax error at specified position. (Inherited from TextSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightBraces | Highlights braces containing caret position. (Inherited from TextSource.)
Public method | HighlightCodeFixes | Highlights code fixes if needed. (Inherited from TextSource.)
Public method | HighlightCodeRefactors | Highlights code fixes if needed. (Inherited from TextSource.)
Public method | HighlightCodeSnippets | Highlights code snippets using appropriate style. (Inherited from TextSource.)
Public method | HighlightSyntaxErrors | Highlights syntax errors. (Inherited from TextSource.)
Public method | IndentLine | Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned. (Inherited from TextSource.)
Public method | IndentLine(String, Boolean) | Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser (Inherited from TextSource.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Insert | Inserts the given string at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean) | Inserts the given string at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean) | Inserts the given string array at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(ITextStrings, Boolean) | Inserts the given string collection at the specified location. (Inherited from TextSource.)
Public method | InsertBlock(String, Boolean, Boolean) | Inserts the given string array at the specified location. (Inherited from TextSource.)
Public method | InsertFromFile | Inserts the file text content at the specified location. (Inherited from TextSource.)
Public method | InsertText |
Public method | InvalidateSyntaxErrors | Invalidates highlighting of syntax errors. (Inherited from TextSource.)
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line. (Inherited from TextSource.)
Public method | IsHyperText | Indicates whether given text represents hypertext. (Inherited from TextSource.)
Public method | IsWordCorrect(String) | Checks whether spelling for the given word is correct. (Inherited from TextSource.)
Public method | IsWordCorrect(String, Point) | Checks whether spelling for the given word is correct. (Inherited from TextSource.)
Public method | LineIsHidden | Determines whether the given line is readonly. (Inherited from TextSource.)
Public method | LineIsModified(Int32) | Indicates whether specified line already modified. (Inherited from TextSource.)
Public method | LineIsModified(Int32, Boolean) | Indicates whether specified line already modified. (Inherited from TextSource.)
Public method | LineIsReadonly | Determines whether the given line is readonly. (Inherited from TextSource.)
Public method | LinesChanged(Int32, Int32) | Specifies range of lines that was changed. (Inherited from TextSource.)
Public method | LinesChanged(Int32, Int32, Boolean) | Specifies range of lines that was changed. (Inherited from TextSource.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from TextSource.)
Public method | LoadFile(String, IStringImport) | Loads content from the given file with specified importer. (Inherited from TextSource.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from TextSource.)
Public method | LoadFile(String, IStringImport, Encoding) | Loads content from the given file with specified importer and specific encoding. (Inherited from TextSource.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(Stream, IStringImport) | Loads the text content from the given stream with specified importer. (Inherited from TextSource.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(TextReader, IStringImport) | Loads the contents of the specified stream. (Inherited from TextSource.)
Public method | LoadStream(Stream, IStringImport, Encoding) | Loads the text content from the given stream with specified importer. (Inherited from TextSource.)
Public method | MoveTo(Point) | Moves the current position to the given position. (Inherited from TextSource.)
Public method | MoveTo(Int32, Int32) | Moves the current position to the given position. (Inherited from TextSource.)
Public method | MoveToChar | Moves the current position to the specified character in the current line. (Inherited from TextSource.)
Public method | MoveToLine(Int32) | Moves the current position to the specified line. (Inherited from TextSource.)
Public method | MoveToLine(Int32, Int32) | Moves the current position to the specified line. (Inherited from TextSource.)
Public method | Navigate | Moves current position by the given offset value. (Inherited from TextSource.)
Public method | NeedAutoComplete | Indicates whether ITextSource should try to autocomplete statements. (Inherited from TextSource.)
Public method | NeedCacheIndent | Indicates whether ITextSource can reuse previous indentation. (Inherited from TextSource.)
Public method | NeedCodeCompletion | Indicates whether ITextSource can provide code completion operation for its content. (Inherited from TextSource.)
Public method | NeedCodeCompletionTabs | Indicates code completion content can be filtered based on its priority. (Inherited from TextSource.)
Public method | NeedCodeFixes | Indicates whether ITextSource can provide code fixes operation for its content. (Inherited from TextSource.)
Public method | NeedCodeRefactors | Indicates whether ITextSource can provide code fixes operation for its content. (Inherited from TextSource.)
Public method | NeedContentDividers | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedFormatText | Indicates whether ITextSource can format its content. (Inherited from TextSource.)
Public method | NeedFormatTextOnLineChange | Indicates whether ITextSource should format spaces and case when changing the current line. (Inherited from TextSource.)
Public method | NeedIndentText | Indicates whether ITextSource can indent its content. (Inherited from TextSource.)
Public method | NeedOutlineText | Indicates whether ITextSource can outline its content. (Inherited from TextSource.)
Public method | NeedParse | Indicates whether syntax parsing can be performed for the text, or some of formatting text elements, such as urls or braces, should be highlighted. (Inherited from TextSource.)
Public method | NeedQuickInfoTips | Indicates whether ITextSource can obtain short description for syntax tokens within its content. (Inherited from TextSource.)
Public method | NeedReparseText | Indicates whether ITextSource can perform syntax analysis of its content. (Inherited from TextSource.)
Public method | NeedReparseTextOnLineChange | Indicates whether ITextSource should replace text when changing the current line. (Inherited from TextSource.)
Public method | NeedStructureGuideLines | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedSyntaxErrors | Indicates whether ITextSource can proceed syntax errors in its content. (Inherited from TextSource.)
Public method | NeedWorkInThread | Indicates whether ITextSource can perform syntax analysis in thread. (Inherited from TextSource.)
Public method | NewLine | Inserts a line break at the current position. (Inherited from TextSource.)
Public method | NewLine(String, Boolean) | Inserts a line break at the current position with indentation. (Inherited from TextSource.)
Public method | NewLineAbove | Inserts a line break above the current position. (Inherited from TextSource.)
Public method | NewLineBelow | Inserts a line break below the current position. (Inherited from TextSource.)
Public method | Notification | Updates control's content according to parameters of notification. (Inherited from TextSource.)
Public method | Notify | Notifies all notifiers about changing source state. (Inherited from TextSource.)
Public method | ParseString | Perform lexical analysis of the specified string. (Inherited from TextSource.)
Public method | ParseStrings | Perform lexical analysis specified strings. (Inherited from TextSource.)
Public method | ParseToString | Perform lexical analysis of specified strings. (Inherited from TextSource.)
Public method | PositionIsReadonly | Determines whether the text at given position is readonly. (Inherited from TextSource.)
Public method | ProcessAutoComplete | Inserts end-of-block code fragment if needed. (Inherited from TextSource.)
Public method | Redo | Performs the last redo operation. (Inherited from TextSource.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from TextSource.)
Public method | ReplaceText |
Public method | ResetBracesOptions | Resets the BracesOptions to its default value. (Inherited from TextSource.)
Public method | ResetCheckSpelling | Resets the CheckSpelling to the default value. (Inherited from TextSource.)
Public method | ResetClosingBraces | Resets the ClosingBraces to its default value. (Inherited from TextSource.)
Public method | ResetHighlightHyperText | Resets HighlightHyperText to the default value. (Inherited from TextSource.)
Public method | ResetIndentOptions | Resets the IndentOptions to the default value. (Inherited from TextSource.)
Public method | ResetMaxLength | Resets the MaxLength to the default value. (Inherited from TextSource.)
Public method | ResetModified | Resets the Modified to the default value. (Inherited from TextSource.)
Public method | ResetNavigateOptions | Resets the NavigateOptions to the default value. (Inherited from TextSource.)
Public method | ResetOpenBraces | Resets the OpenBraces to its default value. (Inherited from TextSource.)
Public method | ResetOverWrite | Resets the OverWrite to the default value. (Inherited from TextSource.)
Public method | ResetReadOnly | Resets the ReadOnly to the default value. (Inherited from TextSource.)
Public method | ResetSingleLineMode | Resets the SingleLineMode to the default value. (Inherited from TextSource.)
Public method | ResetSpellDelimiters | Resets the SpellDelimiters to the default value. (Inherited from TextSource.)
Public method | ResetUndoLimit | Resets the UndoLimit to the default value. (Inherited from TextSource.)
Public method | ResetUndoOptions | Resets the UndoOptions to the default value. (Inherited from TextSource.)
Public method | RestorePosition | Restores position from stored position list by given index. (Inherited from TextSource.)
Public method | RestorePositionWithUndo | Restores position from stored position list by given index. (Inherited from TextSource.)
Public method | SaveFile(String) | Saves text content to the specific file. (Inherited from TextSource.)
Public method | SaveFile(String, IStringExport) | Saves text content to the specific file with specific exporter. (Inherited from TextSource.)
Public method | SaveFile(String, Encoding) | Saves text content to the specific file with specific encoding. (Inherited from TextSource.)
Public method | SaveFile(String, IStringExport, Encoding) | Saves text content to the specific file with specific exporter and encoding. (Inherited from TextSource.)
Public method | SaveStream(Stream) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, IStringExport) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(TextWriter, IStringExport) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SaveStream(Stream, IStringExport, Encoding) | Saves the text content to the specified stream. (Inherited from TextSource.)
Public method | SetLastParsed | Updates the last parsed line and resets first changed line to it's default value. (Inherited from TextSource.)
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineHidden(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineReadonly(Int32, Boolean) | Sets readonly state for the given line. (Inherited from TextSource.)
Public method | SetLineState | Sets item state for the given line. (Inherited from TextSource.)
Public method | SetNavigateOptions | Sets navigating options without validating position. (Inherited from TextSource.)
Public method | ShouldSerializeClosingBraces | Indicates whether the ClosingBraces property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeIndentOptions | Indicates whether the IndentOptions property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeLexer | Indicates whether the Lexer property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeNavigateOptions | Indicates whether the NavigateOptions property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeOpenBraces | Indicates whether the OpenBraces property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeText | Indicates whether the Text property should be persisted. (Inherited from TextSource.)
Public method | ShouldSerializeUndoOptions | Indicates whether the UndoOptions property should be persisted. (Inherited from TextSource.)
Public method | StartThread | Executes action in thread. (Inherited from TextSource.)
Public method | StopThread | Aborts executing action in thread. (Inherited from TextSource.)
Public method | StorePosition(Point) | Stores given position to stored position list. (Inherited from TextSource.)
Public method | StorePosition(Point, Boolean) | Stores given position to stored position list. (Inherited from TextSource.)
Public method | StorePositionWithUndo | Stores given position to stored position list preserving it for undo. (Inherited from TextSource.)
Public method | SupportsAsyncParsing | (Inherited from TextSource.)
Public method | TempHighlightBraces | Temporary highlights all text within the area specified by rects. (Inherited from TextSource.)
Public method | TempHighlightMatchingBlocks | Highlights block match. (Inherited from TextSource.)
Public method | TempHighlightReferences | Highlights found references. (Inherited from TextSource.)
Public method | TempHighlightSearchResults | Highlights search results. (Inherited from TextSource.)
Public method | TempUnhighlightBraces | Cancels text highlighting turned on using TempHighlightBraces (Inherited from TextSource.)
Public method | TempUnhighlightBraces(Boolean) | Unhighlights temporary braces areas. (Inherited from TextSource.)
Public method | TempUnhighlightReferences | Unhighlights references highlighted with previous call of TempHighlightReferences. (Inherited from TextSource.)
Public method | TempUnhighlightSearchResults | Unhighlights search results highlighted with previous call of TempHighlightSearchResults. (Inherited from TextSource.)
Public method | TextPointToAbsolutePosition | Converts given Point value to the absolute position. (Inherited from TextSource.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnBreakLine | Concatenates lines at current position. (Inherited from TextSource.)
Public method | Undo(Boolean) | (Overrides TextSourceUndo(Boolean).)
Public method | Undo(IUndoData, Boolean) | Performs the single undo operation. (Inherited from TextSource.)
Public method | UnhighlightBraces | Unhighlights braces containing caret position. (Inherited from TextSource.)
Public method | UnhighlightBraces(Boolean) | Unhighlights braces. (Inherited from TextSource.)
Public method | UnhighlightCodeSnippets | Removes highlighting from code snippets and clears snippet collection. (Inherited from TextSource.)
Public method | UnhighlightSyntaxErrors | Removes syntax errors highlighting. (Inherited from TextSource.)
Public method | Update | Updates an object state. (Inherited from TextSource.)
Public method | ValidatePosition | Validates given position within control's text content. (Inherited from TextSource.)
Top
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource.InsertText Method

FormDesignerTextSourceInsertText Method

Namespace: Alternet.FormDesigner.Integration
Assembly: Alternet.FormDesigner.Integration.v7 (in Alternet.FormDesigner.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertText(
    FormDesignerTextSourceOperationsTextInsertionOperation[] operations
)
Public Sub InsertText (
    operations As FormDesignerTextSourceOperationsTextInsertionOperation()
)
public:
virtual void InsertText(
    array<FormDesignerTextSourceOperationsTextInsertionOperation^>^ operations
) sealed
abstract InsertText :
        operations : FormDesignerTextSourceOperationsTextInsertionOperation[] -> unit
override InsertText :
        operations : FormDesignerTextSourceOperationsTextInsertionOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextInsertionOperation

Implements

IFormDesignerTextSourceInsertText(FormDesignerTextSourceOperationsTextInsertionOperation)
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource.ReplaceText Method

FormDesignerTextSourceReplaceText Method

Namespace: Alternet.FormDesigner.Integration
Assembly: Alternet.FormDesigner.Integration.v7 (in Alternet.FormDesigner.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReplaceText(
    FormDesignerTextSourceOperationsTextReplacementOperation[] operations
)
Public Sub ReplaceText (
    operations As FormDesignerTextSourceOperationsTextReplacementOperation()
)
public:
virtual void ReplaceText(
    array<FormDesignerTextSourceOperationsTextReplacementOperation^>^ operations
) sealed
abstract ReplaceText :
        operations : FormDesignerTextSourceOperationsTextReplacementOperation[] -> unit
override ReplaceText :
        operations : FormDesignerTextSourceOperationsTextReplacementOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextReplacementOperation

Implements

IFormDesignerTextSourceReplaceText(FormDesignerTextSourceOperationsTextReplacementOperation)
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource.Undo Method

FormDesignerTextSourceUndo Method
Overload List
 | Name | Description
Public method | Undo(Boolean) | (Overrides TextSourceUndo(Boolean).)
Public method | Undo(IUndoData, Boolean) | Performs the single undo operation. (Inherited from TextSource.)
Top
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource.Undo Method (Boolean)

FormDesignerTextSourceUndo Method (Boolean)

Namespace: Alternet.FormDesigner.Integration
Assembly: Alternet.FormDesigner.Integration.v7 (in Alternet.FormDesigner.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Undo(
    bool withChange = false
)
Public Overrides Sub Undo (
    Optional withChange As Boolean = false
)
public:
virtual void Undo(
    bool withChange = false
) override
abstract Undo :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit
override Undo :
        ?withChange : bool
(* Defaults:
        let _withChange = defaultArg withChange false
*)
-> unit

Parameters

withChange (Optional)
Type: SystemBoolean

Implements

IUndoUndo(Boolean)
See Also

Reference

FormDesignerTextSource Class
Undo Overload
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource Properties

FormDesignerTextSource Properties

The FormDesignerTextSource type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEdit | Gets or sets an object that represent currently active (focused) ISyntaxEdit control linked to the text source. (Inherited from TextSource.)
Public property | BookMarks | Represents an object that implements IBookMarks interface holding collection of IBookMark objects each determining particular bookmark within the text source. (Inherited from TextSource.)
Public property | BracesOptions | Gets or sets options specifying appearance and behaviour of matching braces within Edit control. (Inherited from TextSource.)
Public property | CheckSpelling | Gets or sets a value indicating whether the document can check spelling for its content. (Inherited from TextSource.)
Public property | ClosingBraces | Gets or sets an array of characters each one representing a closing brace. (Inherited from TextSource.)
Public property | CodeSnippets | Gets or sets ICodeSnippetRangeList for Edit control. (Inherited from TextSource.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentSnippet | Gets or sets current ICodeSnippetRange object. (Inherited from TextSource.)
Public property | Edits | Represents a collection of ISyntaxEdit controls linked to the text source. (Inherited from TextSource.)
Public property | FileName | Gets or sets name of file that holds text source content. (Inherited from TextSource.)
Public property | FirstChanged | Represents index of the first changed line. (Inherited from TextSource.)
Public property | GlobalSearch | Specifies whether search should be global. (Inherited from TextSource.)
Public property | HasSpelling | Gets boolean value indicating that editor has external spell checker assigned. (Inherited from TextSource.)
Public property | HighlightHyperText | Gets or sets a value indicating whether hypertext in the text should be highlighted. (Inherited from TextSource.)
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight found block matches. (Inherited from TextSource.)
Public property | HighlightReferences | Specifies that edit control should highlight found references. (Inherited from TextSource.)
Public property | IndentOptions | Gets or sets Alternet.Editor.TextSource.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from TextSource.)
Public property | LastChanged | Represents index of the last changed line. (Inherited from TextSource.)
Public property | Lexer | Gets or sets object that can perform lexical analysis of the text source content. (Inherited from TextSource.)
Public property | Lines | Represents the object that implements ITextStrings interface containing collection of strings determining text source content. (Inherited from TextSource.)
Public property | LineStyles | Represents an object that implements ILineStyles interface holding collection of line styles for this document. (Inherited from TextSource.)
Public property | LineTerminator | Gets or sets a string value that terminates line. (Inherited from TextSource.)
Public property | MatchingBlocks | Gets or sets IRangeList of matching begin/end blocks for Edit control. (Inherited from TextSource.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control. (Inherited from TextSource.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified. (Inherited from TextSource.)
Public property | ModifiedLineRegions | Gets modified lines information, grouped in regions. (Inherited from TextSource.)
Public property | ModifiedLines | Gets modified lines information. (Inherited from TextSource.)
Public property | NavigateOptions | Gets or sets navigating options. (Inherited from TextSource.)
Public property | OpenBraces | Gets or sets an array of characters each one representing an open brace. (Inherited from TextSource.)
Public property | OptimizedForMemory | Specifies whether internal text representation should optimized memory usage. (Inherited from TextSource.)
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from TextSource.)
Public property | ParserLine | Gets the line currently parsed by the attached Lexer, when text source performs syntax parsing of the text. (Inherited from TextSource.)
Public property | Position | Gets or sets current position within the control's text content. (Inherited from TextSource.)
Public property | PrevPosition | Gets previous position within the control's text content. (Inherited from TextSource.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only. (Inherited from TextSource.)
Public property | RedoList | Provides an indexed access to redo data. (Inherited from TextSource.)
Public property | References | Gets or sets IRangeList of found references for Edit control. (Inherited from TextSource.)
Public property | SearchResults | Gets or sets IRangeList of search results for Edit control. (Inherited from TextSource.)
Public property | SelectBlockRect | Represents a rectangular block of selected text. (Inherited from TextSource.)
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from TextSource.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SpellDelimiters | Gets or sets an array of chars used to separate words in a text. (Inherited from TextSource.)
Public property | SpellDelimiterString | Gets or sets Delimiters as a single string. (Inherited from TextSource.)
Public property | SpellTable | Represents a hash table containing delimiters. (Inherited from TextSource.)
Public property | State | Gets or sets last changes to the text stored in the text source. (Inherited from TextSource.)
Public property | Strings | Gets or sets text source content in the form of string array. (Inherited from TextSource.)
Public property | StructureGuideLines | Represents a syntax errors collection. (Inherited from TextSource.)
Public property | SyntaxErrors | Represents a syntax errors collection. (Inherited from TextSource.)
Public property | Text | Gets or sets text source content as a single string with the individual strings delimited by carriage returns. (Inherited from TextSource.)
Public property | ThreadAction | Returns method executed in thread when parsing. (Inherited from TextSource.)
Public property | UndoLimit | Gets or sets a value that limits number of undo operations. (Inherited from TextSource.)
Public property | UndoList | Provides an indexed access to undo data. (Inherited from TextSource.)
Public property | UndoOptions | Gets or sets options for undo and redo operations. (Inherited from TextSource.)
Public property | UndoUpdateCount | Keeps track of calls to BeginUndoUpdate and EndUndoUpdate so that they can be nested. (Inherited from TextSource.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from TextSource.)
Public property | UrlTable | Represents hash table containing hyper-text characters. (Inherited from TextSource.)
Top
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


FormDesignerTextSource Events

FormDesignerTextSource Events

The FormDesignerTextSource type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | HyperText | Occurs when a control needs checking whether some string represents hypertext. (Inherited from TextSource.)
Public event | UndoEvent | Occurs when undo/redo operation performed. (Inherited from TextSource.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking. (Inherited from TextSource.)
Top
See Also

Reference

FormDesignerTextSource Class
Alternet.FormDesigner.Integration Namespace


Alternet.FormDesigner.TypeScript Namespace

Alternet.FormDesigner.TypeScript Namespace
Classes
 | Class | Description
Public class | JavaScriptCodeGenerator |
Public class | JavaScriptLanguageService | Represents various methods for JavaScript language service for Form Designer.
Public class | NodeExtensions | Contains extended methods for Alternet.Common.TypeScript.Types.Node class.
Public class | TypeScriptCodeGenerator |
Public class | TypeScriptLanguageService | Represents various methods for TypeScript language service for Form Designer.


JavaScriptCodeGenerator Class

JavaScriptCodeGenerator Class
Inheritance Hierarchy
SystemObject
System.CodeDom.CompilerCodeGenerator
System.CodeDom.CompilerCodeCompiler
Alternet.FormDesigner.TypeScriptTypeScriptCodeGenerator
Alternet.FormDesigner.TypeScriptJavaScriptCodeGenerator

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaScriptCodeGenerator : TypeScriptCodeGenerator
Public Class JavaScriptCodeGenerator
    Inherits TypeScriptCodeGenerator
public ref class JavaScriptCodeGenerator : public TypeScriptCodeGenerator
type JavaScriptCodeGenerator =
    class
        inherit TypeScriptCodeGenerator
    end

The JavaScriptCodeGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptCodeGenerator | Initializes a new instance of the JavaScriptCodeGenerator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GenerateCodeFromMember | Generates code for the specified class member using the specified text writer and code generator options. (Inherited from CodeGenerator.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.FormDesigner.TypeScript Namespace


JavaScriptCodeGenerator Constructor

JavaScriptCodeGenerator Constructor
Initializes a new instance of the JavaScriptCodeGenerator class

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaScriptCodeGenerator(
    IServiceProvider serviceProvider
)
Public Sub New (
    serviceProvider As IServiceProvider
)
public:
JavaScriptCodeGenerator(
    IServiceProvider^ serviceProvider
)
new :
        serviceProvider : IServiceProvider -> JavaScriptCodeGenerator

Parameters

serviceProvider
Type: SystemIServiceProvider
See Also

Reference

JavaScriptCodeGenerator Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptCodeGenerator Methods

JavaScriptCodeGenerator Methods

The JavaScriptCodeGenerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GenerateCodeFromMember | Generates code for the specified class member using the specified text writer and code generator options. (Inherited from CodeGenerator.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JavaScriptCodeGenerator Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService Class

JavaScriptLanguageService Class
Represents various methods for JavaScript language service for Form Designer.
Inheritance Hierarchy
SystemObject
LanguageService
Alternet.FormDesigner.TypeScriptJavaScriptLanguageService

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaScriptLanguageService : LanguageService
Public Class JavaScriptLanguageService
    Inherits LanguageService
public ref class JavaScriptLanguageService : public LanguageService
type JavaScriptLanguageService =
    class
        inherit LanguageService
    end

The JavaScriptLanguageService type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptLanguageService | Initializes a new instance of the JavaScriptLanguageService class with specified language.
Top
Methods
 | Name | Description
Public method | CreateCodeProvider | Creates a code provider for the TypeScript language. (Overrides LanguageService.CreateCodeProvider(IServiceProvider).)
Public method | CreateEventBindingService | Creates an event binding service for TypeScript language. (Overrides LanguageService.CreateEventBindingService(IServiceContainer, IFormDesignerDataSource, FuncNavigateToUserMethodRequestedEventArgs, Boolean).)
Public method | CreateParser | Creates a new instance of the Alternet.FormDesigner.TypeScript.TypeScriptParser with specified parameters. (Overrides LanguageService.CreateParser(IServiceProvider, DesignerReferencedAssemblies, IEnumerableDesignerAssemblyResources, DesignerImportedNamespaces, IDesignedComponentAssemblyProvider).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAssemblyResourcesParameters | Retrieves default resources directory name and project file extension for the TypeScript project. (Overrides LanguageService.GetAssemblyResourcesParameters(String, String).)
Public method | GetDesignedClassName | Retrieves form class name from the content of specified file. (Overrides LanguageService.GetDesignedClassName(String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Init | Initializes a new Alternet.FormDesigner.TypeScript.JavaScriptLanguageService object for the JavScript language and adds it to the language services collection.
Public method | PreprocessCodeDomBeforeSaving | Preprocesses CodeDom representation of the form before saving its content. (Overrides LanguageService.PreprocessCodeDomBeforeSaving(CodeTypeDeclaration).)
Public method | SaveDifferencesInCode | Saves changes from the Form Designer to the TypeScript code. (Overrides LanguageService.SaveDifferencesInCode(IFormDesignerDataSource, IFormDesignerLoader, IFormDesignerControl).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService Constructor

JavaScriptLanguageService Constructor
Initializes a new instance of the JavaScriptLanguageService class with specified language.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaScriptLanguageService(
    Language language
)
Public Sub New (
    language As Language
)
public:
JavaScriptLanguageService(
    Language^ language
)
new :
        language : Language -> JavaScriptLanguageService

Parameters

language
Type: Language
Language to be supported.
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService Methods

JavaScriptLanguageService Methods

The JavaScriptLanguageService type exposes the following members.

Methods
 | Name | Description
Public method | CreateCodeProvider | Creates a code provider for the TypeScript language. (Overrides LanguageService.CreateCodeProvider(IServiceProvider).)
Public method | CreateEventBindingService | Creates an event binding service for TypeScript language. (Overrides LanguageService.CreateEventBindingService(IServiceContainer, IFormDesignerDataSource, FuncNavigateToUserMethodRequestedEventArgs, Boolean).)
Public method | CreateParser | Creates a new instance of the Alternet.FormDesigner.TypeScript.TypeScriptParser with specified parameters. (Overrides LanguageService.CreateParser(IServiceProvider, DesignerReferencedAssemblies, IEnumerableDesignerAssemblyResources, DesignerImportedNamespaces, IDesignedComponentAssemblyProvider).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAssemblyResourcesParameters | Retrieves default resources directory name and project file extension for the TypeScript project. (Overrides LanguageService.GetAssemblyResourcesParameters(String, String).)
Public method | GetDesignedClassName | Retrieves form class name from the content of specified file. (Overrides LanguageService.GetDesignedClassName(String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Init | Initializes a new Alternet.FormDesigner.TypeScript.JavaScriptLanguageService object for the JavScript language and adds it to the language services collection.
Public method | PreprocessCodeDomBeforeSaving | Preprocesses CodeDom representation of the form before saving its content. (Overrides LanguageService.PreprocessCodeDomBeforeSaving(CodeTypeDeclaration).)
Public method | SaveDifferencesInCode | Saves changes from the Form Designer to the TypeScript code. (Overrides LanguageService.SaveDifferencesInCode(IFormDesignerDataSource, IFormDesignerLoader, IFormDesignerControl).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService.CreateCodeProvider Method

JavaScriptLanguageServiceCreateCodeProvider Method
Creates a code provider for the TypeScript language.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeDomProvider CreateCodeProvider(
    IServiceProvider serviceProvider
)
Public Overrides Function CreateCodeProvider (
    serviceProvider As IServiceProvider
) As CodeDomProvider
public:
virtual CodeDomProvider^ CreateCodeProvider(
    IServiceProvider^ serviceProvider
) override
abstract CreateCodeProvider :
        serviceProvider : IServiceProvider -> CodeDomProvider
override CreateCodeProvider :
        serviceProvider : IServiceProvider -> CodeDomProvider

Parameters

serviceProvider
Type: SystemIServiceProvider
Specifies a IServiceProvider support object for the TypeScript language.

Return Value

Type: CodeDomProvider
CodeDomProvider for the TypeScript language.
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService.CreateEventBindingService Method

JavaScriptLanguageServiceCreateEventBindingService Method
Creates an event binding service for TypeScript language.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IEventBindingServiceExtended CreateEventBindingService(
    IServiceContainer serviceContainer,
    IFormDesignerDataSource source,
    Func<NavigateToUserMethodRequestedEventArgs, bool> showUserCodeFunc
)
Public Overrides Function CreateEventBindingService (
    serviceContainer As IServiceContainer,
    source As IFormDesignerDataSource,
    showUserCodeFunc As Func(Of NavigateToUserMethodRequestedEventArgs, Boolean)
) As IEventBindingServiceExtended
public:
virtual IEventBindingServiceExtended^ CreateEventBindingService(
    IServiceContainer^ serviceContainer,
    IFormDesignerDataSource^ source,
    Func<NavigateToUserMethodRequestedEventArgs^, bool>^ showUserCodeFunc
) override
abstract CreateEventBindingService :
        serviceContainer : IServiceContainer *
        source : IFormDesignerDataSource *
        showUserCodeFunc : Func<NavigateToUserMethodRequestedEventArgs, bool> -> IEventBindingServiceExtended
override CreateEventBindingService :
        serviceContainer : IServiceContainer *
        source : IFormDesignerDataSource *
        showUserCodeFunc : Func<NavigateToUserMethodRequestedEventArgs, bool> -> IEventBindingServiceExtended

Parameters

serviceContainer
Type: System.ComponentModel.DesignIServiceContainer
IServiceContainer for this new service.
source
Type: Alternet.FormDesigner.WinFormsIFormDesignerDataSource
IFormDesignerDataSource object contains data for this new service.
showUserCodeFunc
Type: SystemFuncNavigateToUserMethodRequestedEventArgs, Boolean
Method used to show user code.

Return Value

Type: IEventBindingServiceExtended
An EventBindingServiceTypeScript object that provides default service for the TypeScript language.
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService.CreateParser Method

JavaScriptLanguageServiceCreateParser Method
Creates a new instance of the Alternet.FormDesigner.TypeScript.TypeScriptParser with specified parameters.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Parser CreateParser(
    IServiceProvider serviceProvider,
    DesignerReferencedAssemblies referencedAssemblies,
    IEnumerable<DesignerAssemblyResources> assemblyResources,
    DesignerImportedNamespaces importedNamespaces,
    IDesignedComponentAssemblyProvider designedComponentAssembly
)
Public Overrides Function CreateParser (
    serviceProvider As IServiceProvider,
    referencedAssemblies As DesignerReferencedAssemblies,
    assemblyResources As IEnumerable(Of DesignerAssemblyResources),
    importedNamespaces As DesignerImportedNamespaces,
    designedComponentAssembly As IDesignedComponentAssemblyProvider
) As Parser
public:
virtual Parser^ CreateParser(
    IServiceProvider^ serviceProvider,
    DesignerReferencedAssemblies^ referencedAssemblies,
    IEnumerable<DesignerAssemblyResources^>^ assemblyResources,
    DesignerImportedNamespaces^ importedNamespaces,
    IDesignedComponentAssemblyProvider^ designedComponentAssembly
) override
abstract CreateParser :
        serviceProvider : IServiceProvider *
        referencedAssemblies : DesignerReferencedAssemblies *
        assemblyResources : IEnumerable<DesignerAssemblyResources> *
        importedNamespaces : DesignerImportedNamespaces *
        designedComponentAssembly : IDesignedComponentAssemblyProvider -> Parser
override CreateParser :
        serviceProvider : IServiceProvider *
        referencedAssemblies : DesignerReferencedAssemblies *
        assemblyResources : IEnumerable<DesignerAssemblyResources> *
        importedNamespaces : DesignerImportedNamespaces *
        designedComponentAssembly : IDesignedComponentAssemblyProvider -> Parser

Parameters

serviceProvider
Type: SystemIServiceProvider
IServiceProvider for this new parser
referencedAssemblies
Type: Alternet.FormDesigner.WinFormsDesignerReferencedAssemblies
List of referenced assemblies
assemblyResources
Type: System.Collections.GenericIEnumerableDesignerAssemblyResources
List of designer resources
importedNamespaces
Type: Alternet.FormDesigner.WinFormsDesignerImportedNamespaces
List of imported namespaces
designedComponentAssembly
Type: Alternet.FormDesigner.WinFormsIDesignedComponentAssemblyProvider

Return Value

Type: Parser
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService.GetAssemblyResourcesParameters Method

JavaScriptLanguageServiceGetAssemblyResourcesParameters Method
Retrieves default resources directory name and project file extension for the TypeScript project.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void GetAssemblyResourcesParameters(
    out string resourcesDirectoryName,
    out string projectFileExtension
)
Public Overrides Sub GetAssemblyResourcesParameters (
    <OutAttribute> ByRef resourcesDirectoryName As String,
    <OutAttribute> ByRef projectFileExtension As String
)
public:
virtual void GetAssemblyResourcesParameters(
    [OutAttribute] String^% resourcesDirectoryName,
    [OutAttribute] String^% projectFileExtension
) override
abstract GetAssemblyResourcesParameters :
        resourcesDirectoryName : string byref *
        projectFileExtension : string byref -> unit
override GetAssemblyResourcesParameters :
        resourcesDirectoryName : string byref *
        projectFileExtension : string byref -> unit

Parameters

resourcesDirectoryName
Type: SystemString
Default directory name where TypeScript project stores its resources.
projectFileExtension
Type: SystemString
Default TypeScript project extension.
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService.GetDesignedClassName Method

JavaScriptLanguageServiceGetDesignedClassName Method
Retrieves form class name from the content of specified file.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDesignedClassName(
    string userCodeFileName
)
Public Overrides Function GetDesignedClassName (
    userCodeFileName As String
) As String
public:
virtual String^ GetDesignedClassName(
    String^ userCodeFileName
) override
abstract GetDesignedClassName :
        userCodeFileName : string -> string
override GetDesignedClassName :
        userCodeFileName : string -> string

Parameters

userCodeFileName
Type: SystemString
Name of the file.

Return Value

Type: String
The name of form class.
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService.Init Method

JavaScriptLanguageServiceInit Method
Initializes a new Alternet.FormDesigner.TypeScript.JavaScriptLanguageService object for the JavScript language and adds it to the language services collection.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Init()
Public Shared Sub Init
public:
static void Init()
static member Init : unit -> unit
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService.PreprocessCodeDomBeforeSaving Method

JavaScriptLanguageServicePreprocessCodeDomBeforeSaving Method
Preprocesses CodeDom representation of the form before saving its content.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PreprocessCodeDomBeforeSaving(
    CodeTypeDeclaration rootForm
)
Public Overrides Sub PreprocessCodeDomBeforeSaving (
    rootForm As CodeTypeDeclaration
)
public:
virtual void PreprocessCodeDomBeforeSaving(
    CodeTypeDeclaration^ rootForm
) override
abstract PreprocessCodeDomBeforeSaving :
        rootForm : CodeTypeDeclaration -> unit
override PreprocessCodeDomBeforeSaving :
        rootForm : CodeTypeDeclaration -> unit

Parameters

rootForm
Type: System.CodeDomCodeTypeDeclaration
CodeTypeDeclaration object to be preprocessed.
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


JavaScriptLanguageService.SaveDifferencesInCode Method

JavaScriptLanguageServiceSaveDifferencesInCode Method
Saves changes from the Form Designer to the TypeScript code.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void SaveDifferencesInCode(
    IFormDesignerDataSource source,
    IFormDesignerLoader designerLoader,
    IFormDesignerControl designer
)
Public Overrides Sub SaveDifferencesInCode (
    source As IFormDesignerDataSource,
    designerLoader As IFormDesignerLoader,
    designer As IFormDesignerControl
)
public:
virtual void SaveDifferencesInCode(
    IFormDesignerDataSource^ source,
    IFormDesignerLoader^ designerLoader,
    IFormDesignerControl^ designer
) override
abstract SaveDifferencesInCode :
        source : IFormDesignerDataSource *
        designerLoader : IFormDesignerLoader *
        designer : IFormDesignerControl -> unit
override SaveDifferencesInCode :
        source : IFormDesignerDataSource *
        designerLoader : IFormDesignerLoader *
        designer : IFormDesignerControl -> unit

Parameters

source
Type: Alternet.FormDesigner.WinFormsIFormDesignerDataSource
IFormDesignerDataSource where the changes will be saved.
designerLoader
Type: Alternet.FormDesigner.WinFormsIFormDesignerLoader
IFormDesignerLoader used to load form being designed.
designer
Type: Alternet.FormDesigner.WinFormsIFormDesignerControl
IFormDesignerControl that contains the form being designed.
See Also

Reference

JavaScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions Class

NodeExtensions Class
Contains extended methods for Alternet.Common.TypeScript.Types.Node class.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.TypeScriptNodeExtensions

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class NodeExtensions
<ExtensionAttribute>
Public NotInheritable Class NodeExtensions
[ExtensionAttribute]
public ref class NodeExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type NodeExtensions =  class end

The NodeExtensions type exposes the following members.

Methods
Name | Description
FindArgumentList | Finds child node which represents list of arguments of the current node.
FindArrayList | Finds child node which represents array list of the current node.
FindLast | Finds last child node with specified SyntaxKind of the current node.
FindMemberName | Finds child node which contains last name part of the current node.
FindParamList | Finds child node which represents list of parameters of the current node.
GetBaseNode | Finds child node which represents base type of the current node.
GetLastChild | Finds last child node with specified SyntaxKind of the current node.
GetName | Finds child node which contains full name of the current node.
GetTypeName | Finds child node which contains type information of the current node.
Top
See Also

Reference

Alternet.FormDesigner.TypeScript Namespace


NodeExtensions Methods

NodeExtensions Methods

The NodeExtensions type exposes the following members.

Methods
Name | Description
FindArgumentList | Finds child node which represents list of arguments of the current node.
FindArrayList | Finds child node which represents array list of the current node.
FindLast | Finds last child node with specified SyntaxKind of the current node.
FindMemberName | Finds child node which contains last name part of the current node.
FindParamList | Finds child node which represents list of parameters of the current node.
GetBaseNode | Finds child node which represents base type of the current node.
GetLastChild | Finds last child node with specified SyntaxKind of the current node.
GetName | Finds child node which contains full name of the current node.
GetTypeName | Finds child node which contains type information of the current node.
Top
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions.FindArgumentList Method

NodeExtensionsFindArgumentList Method
Finds child node which represents list of arguments of the current node.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Node FindArgumentList(
    this Node node
)
<ExtensionAttribute>
Public Shared Function FindArgumentList (
    node As Node
) As Node
public:
[ExtensionAttribute]
static Node^ FindArgumentList(
    Node^ node
)
[<ExtensionAttribute>]
static member FindArgumentList :
        node : Node -> Node

Parameters

node
Type: Node
Node to check.

Return Value

Type: Node
Node object that matches the search criteria.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Node. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions.FindArrayList Method

NodeExtensionsFindArrayList Method
Finds child node which represents array list of the current node.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Node FindArrayList(
    this Node node
)
<ExtensionAttribute>
Public Shared Function FindArrayList (
    node As Node
) As Node
public:
[ExtensionAttribute]
static Node^ FindArrayList(
    Node^ node
)
[<ExtensionAttribute>]
static member FindArrayList :
        node : Node -> Node

Parameters

node
Type: Node
Node to check.

Return Value

Type: Node
Node object that matches the search criteria.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Node. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions.FindLast Method

NodeExtensionsFindLast Method
Finds last child node with specified SyntaxKind of the current node.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Node FindLast(
    this Node node,
    SyntaxKind syntaxKind
)
<ExtensionAttribute>
Public Shared Function FindLast (
    node As Node,
    syntaxKind As SyntaxKind
) As Node
public:
[ExtensionAttribute]
static Node^ FindLast(
    Node^ node,
    SyntaxKind syntaxKind
)
[<ExtensionAttribute>]
static member FindLast :
        node : Node *
        syntaxKind : SyntaxKind -> Node

Parameters

node
Type: Node
Node to check.
syntaxKind
Type: SyntaxKind
Specifies type of the node.

Return Value

Type: Node
Node object that matches the search criteria.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Node. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions.FindMemberName Method

NodeExtensionsFindMemberName Method
Finds child node which contains last name part of the current node.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Node FindMemberName(
    this Node node
)
<ExtensionAttribute>
Public Shared Function FindMemberName (
    node As Node
) As Node
public:
[ExtensionAttribute]
static Node^ FindMemberName(
    Node^ node
)
[<ExtensionAttribute>]
static member FindMemberName :
        node : Node -> Node

Parameters

node
Type: Node
Node to check.

Return Value

Type: Node
Node object that matches the search criteria.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Node. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions.FindParamList Method

NodeExtensionsFindParamList Method
Finds child node which represents list of parameters of the current node.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Node FindParamList(
    this Node node
)
<ExtensionAttribute>
Public Shared Function FindParamList (
    node As Node
) As Node
public:
[ExtensionAttribute]
static Node^ FindParamList(
    Node^ node
)
[<ExtensionAttribute>]
static member FindParamList :
        node : Node -> Node

Parameters

node
Type: Node
Node to check.

Return Value

Type: Node
Node object that matches the search criteria.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Node. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions.GetBaseNode Method

NodeExtensionsGetBaseNode Method
Finds child node which represents base type of the current node.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Node GetBaseNode(
    this Node node
)
<ExtensionAttribute>
Public Shared Function GetBaseNode (
    node As Node
) As Node
public:
[ExtensionAttribute]
static Node^ GetBaseNode(
    Node^ node
)
[<ExtensionAttribute>]
static member GetBaseNode :
        node : Node -> Node

Parameters

node
Type: Node
Node to check.

Return Value

Type: Node
Node object that matches the search criteria.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Node. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions.GetLastChild Method

NodeExtensionsGetLastChild Method
Finds last child node with specified SyntaxKind of the current node.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Node GetLastChild(
    this Node node,
    bool recursive
)
<ExtensionAttribute>
Public Shared Function GetLastChild (
    node As Node,
    recursive As Boolean
) As Node
public:
[ExtensionAttribute]
static Node^ GetLastChild(
    Node^ node,
    bool recursive
)
[<ExtensionAttribute>]
static member GetLastChild :
        node : Node *
        recursive : bool -> Node

Parameters

node
Type: Node
Node to check.
recursive
Type: SystemBoolean
Indicates whether the search should be recursive.

Return Value

Type: Node
Node object that matches the search criteria.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Node. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions.GetName Method

NodeExtensionsGetName Method
Finds child node which contains full name of the current node.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetName(
    this Node node
)
<ExtensionAttribute>
Public Shared Function GetName (
    node As Node
) As String
public:
[ExtensionAttribute]
static String^ GetName(
    Node^ node
)
[<ExtensionAttribute>]
static member GetName :
        node : Node -> string

Parameters

node
Type: Node
Node to check.

Return Value

Type: String
Full name of the current node.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Node. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


NodeExtensions.GetTypeName Method

NodeExtensionsGetTypeName Method
Finds child node which contains type information of the current node.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetTypeName(
    this Node node
)
<ExtensionAttribute>
Public Shared Function GetTypeName (
    node As Node
) As String
public:
[ExtensionAttribute]
static String^ GetTypeName(
    Node^ node
)
[<ExtensionAttribute>]
static member GetTypeName :
        node : Node -> string

Parameters

node
Type: Node
Node to check.

Return Value

Type: String
String describing type of the current node.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Node. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NodeExtensions Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptCodeGenerator Class

TypeScriptCodeGenerator Class
Inheritance Hierarchy
SystemObject
System.CodeDom.CompilerCodeGenerator
System.CodeDom.CompilerCodeCompiler
Alternet.FormDesigner.TypeScriptTypeScriptCodeGenerator
Alternet.FormDesigner.TypeScriptJavaScriptCodeGenerator

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TypeScriptCodeGenerator : CodeCompiler
Public Class TypeScriptCodeGenerator
    Inherits CodeCompiler
public ref class TypeScriptCodeGenerator : public CodeCompiler
type TypeScriptCodeGenerator =
    class
        inherit CodeCompiler
    end

The TypeScriptCodeGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | TypeScriptCodeGenerator | Initializes a new instance of the TypeScriptCodeGenerator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GenerateCodeFromMember | Generates code for the specified class member using the specified text writer and code generator options. (Inherited from CodeGenerator.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.FormDesigner.TypeScript Namespace


TypeScriptCodeGenerator Constructor

TypeScriptCodeGenerator Constructor
Initializes a new instance of the TypeScriptCodeGenerator class

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptCodeGenerator(
    IServiceProvider serviceProvider
)
Public Sub New (
    serviceProvider As IServiceProvider
)
public:
TypeScriptCodeGenerator(
    IServiceProvider^ serviceProvider
)
new :
        serviceProvider : IServiceProvider -> TypeScriptCodeGenerator

Parameters

serviceProvider
Type: SystemIServiceProvider
See Also

Reference

TypeScriptCodeGenerator Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptCodeGenerator Methods

TypeScriptCodeGenerator Methods

The TypeScriptCodeGenerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GenerateCodeFromMember | Generates code for the specified class member using the specified text writer and code generator options. (Inherited from CodeGenerator.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TypeScriptCodeGenerator Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService Class

TypeScriptLanguageService Class
Represents various methods for TypeScript language service for Form Designer.
Inheritance Hierarchy
SystemObject
LanguageService
Alternet.FormDesigner.TypeScriptTypeScriptLanguageService

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TypeScriptLanguageService : LanguageService
Public Class TypeScriptLanguageService
    Inherits LanguageService
public ref class TypeScriptLanguageService : public LanguageService
type TypeScriptLanguageService =
    class
        inherit LanguageService
    end

The TypeScriptLanguageService type exposes the following members.

Constructors
 | Name | Description
Public method | TypeScriptLanguageService | Initializes a new instance of the TypeScriptLanguageService class with specified language.
Top
Methods
 | Name | Description
Public method | CreateCodeProvider | Creates a code provider for the TypeScript language. (Overrides LanguageService.CreateCodeProvider(IServiceProvider).)
Public method | CreateEventBindingService | Creates an event binding service for TypeScript language. (Overrides LanguageService.CreateEventBindingService(IServiceContainer, IFormDesignerDataSource, FuncNavigateToUserMethodRequestedEventArgs, Boolean).)
Public method | CreateParser | Creates a new instance of the Alternet.FormDesigner.TypeScript.TypeScriptParser with specified parameters. (Overrides LanguageService.CreateParser(IServiceProvider, DesignerReferencedAssemblies, IEnumerableDesignerAssemblyResources, DesignerImportedNamespaces, IDesignedComponentAssemblyProvider).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAssemblyResourcesParameters | Retrieves default resources directory name and project file extension for the TypeScript project. (Overrides LanguageService.GetAssemblyResourcesParameters(String, String).)
Public method | GetDesignedClassName | Retrieves form class name from the content of specified file. (Overrides LanguageService.GetDesignedClassName(String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Init | Initializes a new Alternet.FormDesigner.TypeScript.TypeScriptLanguageService object for the TypeScript language and adds it to the language services collection.
Public method | PreprocessCodeDomBeforeSaving | Preprocesses CodeDom representation of the form before saving its content. (Overrides LanguageService.PreprocessCodeDomBeforeSaving(CodeTypeDeclaration).)
Public method | SaveDifferencesInCode | Saves changes from the Form Designer to the TypeScript code. (Overrides LanguageService.SaveDifferencesInCode(IFormDesignerDataSource, IFormDesignerLoader, IFormDesignerControl).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService Constructor

TypeScriptLanguageService Constructor
Initializes a new instance of the TypeScriptLanguageService class with specified language.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptLanguageService(
    Language language
)
Public Sub New (
    language As Language
)
public:
TypeScriptLanguageService(
    Language^ language
)
new :
        language : Language -> TypeScriptLanguageService

Parameters

language
Type: Language
Language to be supported.
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService Methods

TypeScriptLanguageService Methods

The TypeScriptLanguageService type exposes the following members.

Methods
 | Name | Description
Public method | CreateCodeProvider | Creates a code provider for the TypeScript language. (Overrides LanguageService.CreateCodeProvider(IServiceProvider).)
Public method | CreateEventBindingService | Creates an event binding service for TypeScript language. (Overrides LanguageService.CreateEventBindingService(IServiceContainer, IFormDesignerDataSource, FuncNavigateToUserMethodRequestedEventArgs, Boolean).)
Public method | CreateParser | Creates a new instance of the Alternet.FormDesigner.TypeScript.TypeScriptParser with specified parameters. (Overrides LanguageService.CreateParser(IServiceProvider, DesignerReferencedAssemblies, IEnumerableDesignerAssemblyResources, DesignerImportedNamespaces, IDesignedComponentAssemblyProvider).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAssemblyResourcesParameters | Retrieves default resources directory name and project file extension for the TypeScript project. (Overrides LanguageService.GetAssemblyResourcesParameters(String, String).)
Public method | GetDesignedClassName | Retrieves form class name from the content of specified file. (Overrides LanguageService.GetDesignedClassName(String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Init | Initializes a new Alternet.FormDesigner.TypeScript.TypeScriptLanguageService object for the TypeScript language and adds it to the language services collection.
Public method | PreprocessCodeDomBeforeSaving | Preprocesses CodeDom representation of the form before saving its content. (Overrides LanguageService.PreprocessCodeDomBeforeSaving(CodeTypeDeclaration).)
Public method | SaveDifferencesInCode | Saves changes from the Form Designer to the TypeScript code. (Overrides LanguageService.SaveDifferencesInCode(IFormDesignerDataSource, IFormDesignerLoader, IFormDesignerControl).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService.CreateCodeProvider Method

TypeScriptLanguageServiceCreateCodeProvider Method
Creates a code provider for the TypeScript language.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeDomProvider CreateCodeProvider(
    IServiceProvider serviceProvider
)
Public Overrides Function CreateCodeProvider (
    serviceProvider As IServiceProvider
) As CodeDomProvider
public:
virtual CodeDomProvider^ CreateCodeProvider(
    IServiceProvider^ serviceProvider
) override
abstract CreateCodeProvider :
        serviceProvider : IServiceProvider -> CodeDomProvider
override CreateCodeProvider :
        serviceProvider : IServiceProvider -> CodeDomProvider

Parameters

serviceProvider
Type: SystemIServiceProvider
Specifies a IServiceProvider support object for the TypeScript language.

Return Value

Type: CodeDomProvider
CodeDomProvider for the TypeScript language.
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService.CreateEventBindingService Method

TypeScriptLanguageServiceCreateEventBindingService Method
Creates an event binding service for TypeScript language.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IEventBindingServiceExtended CreateEventBindingService(
    IServiceContainer serviceContainer,
    IFormDesignerDataSource source,
    Func<NavigateToUserMethodRequestedEventArgs, bool> showUserCodeFunc
)
Public Overrides Function CreateEventBindingService (
    serviceContainer As IServiceContainer,
    source As IFormDesignerDataSource,
    showUserCodeFunc As Func(Of NavigateToUserMethodRequestedEventArgs, Boolean)
) As IEventBindingServiceExtended
public:
virtual IEventBindingServiceExtended^ CreateEventBindingService(
    IServiceContainer^ serviceContainer,
    IFormDesignerDataSource^ source,
    Func<NavigateToUserMethodRequestedEventArgs^, bool>^ showUserCodeFunc
) override
abstract CreateEventBindingService :
        serviceContainer : IServiceContainer *
        source : IFormDesignerDataSource *
        showUserCodeFunc : Func<NavigateToUserMethodRequestedEventArgs, bool> -> IEventBindingServiceExtended
override CreateEventBindingService :
        serviceContainer : IServiceContainer *
        source : IFormDesignerDataSource *
        showUserCodeFunc : Func<NavigateToUserMethodRequestedEventArgs, bool> -> IEventBindingServiceExtended

Parameters

serviceContainer
Type: System.ComponentModel.DesignIServiceContainer
IServiceContainer for this new service.
source
Type: Alternet.FormDesigner.WinFormsIFormDesignerDataSource
IFormDesignerDataSource object contains data for this new service.
showUserCodeFunc
Type: SystemFuncNavigateToUserMethodRequestedEventArgs, Boolean
Method used to show user code.

Return Value

Type: IEventBindingServiceExtended
An EventBindingServiceTypeScript object that provides default service for the TypeScript language.
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService.CreateParser Method

TypeScriptLanguageServiceCreateParser Method
Creates a new instance of the Alternet.FormDesigner.TypeScript.TypeScriptParser with specified parameters.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Parser CreateParser(
    IServiceProvider serviceProvider,
    DesignerReferencedAssemblies referencedAssemblies,
    IEnumerable<DesignerAssemblyResources> assemblyResources,
    DesignerImportedNamespaces importedNamespaces,
    IDesignedComponentAssemblyProvider designedComponentAssembly
)
Public Overrides Function CreateParser (
    serviceProvider As IServiceProvider,
    referencedAssemblies As DesignerReferencedAssemblies,
    assemblyResources As IEnumerable(Of DesignerAssemblyResources),
    importedNamespaces As DesignerImportedNamespaces,
    designedComponentAssembly As IDesignedComponentAssemblyProvider
) As Parser
public:
virtual Parser^ CreateParser(
    IServiceProvider^ serviceProvider,
    DesignerReferencedAssemblies^ referencedAssemblies,
    IEnumerable<DesignerAssemblyResources^>^ assemblyResources,
    DesignerImportedNamespaces^ importedNamespaces,
    IDesignedComponentAssemblyProvider^ designedComponentAssembly
) override
abstract CreateParser :
        serviceProvider : IServiceProvider *
        referencedAssemblies : DesignerReferencedAssemblies *
        assemblyResources : IEnumerable<DesignerAssemblyResources> *
        importedNamespaces : DesignerImportedNamespaces *
        designedComponentAssembly : IDesignedComponentAssemblyProvider -> Parser
override CreateParser :
        serviceProvider : IServiceProvider *
        referencedAssemblies : DesignerReferencedAssemblies *
        assemblyResources : IEnumerable<DesignerAssemblyResources> *
        importedNamespaces : DesignerImportedNamespaces *
        designedComponentAssembly : IDesignedComponentAssemblyProvider -> Parser

Parameters

serviceProvider
Type: SystemIServiceProvider
IServiceProvider for this new parser
referencedAssemblies
Type: Alternet.FormDesigner.WinFormsDesignerReferencedAssemblies
List of referenced assemblies
assemblyResources
Type: System.Collections.GenericIEnumerableDesignerAssemblyResources
List of designer resources
importedNamespaces
Type: Alternet.FormDesigner.WinFormsDesignerImportedNamespaces
List of imported namespaces
designedComponentAssembly
Type: Alternet.FormDesigner.WinFormsIDesignedComponentAssemblyProvider

Return Value

Type: Parser
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService.GetAssemblyResourcesParameters Method

TypeScriptLanguageServiceGetAssemblyResourcesParameters Method
Retrieves default resources directory name and project file extension for the TypeScript project.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void GetAssemblyResourcesParameters(
    out string resourcesDirectoryName,
    out string projectFileExtension
)
Public Overrides Sub GetAssemblyResourcesParameters (
    <OutAttribute> ByRef resourcesDirectoryName As String,
    <OutAttribute> ByRef projectFileExtension As String
)
public:
virtual void GetAssemblyResourcesParameters(
    [OutAttribute] String^% resourcesDirectoryName,
    [OutAttribute] String^% projectFileExtension
) override
abstract GetAssemblyResourcesParameters :
        resourcesDirectoryName : string byref *
        projectFileExtension : string byref -> unit
override GetAssemblyResourcesParameters :
        resourcesDirectoryName : string byref *
        projectFileExtension : string byref -> unit

Parameters

resourcesDirectoryName
Type: SystemString
Default directory name where TypeScript project stores its resources.
projectFileExtension
Type: SystemString
Default TypeScript project extension.
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService.GetDesignedClassName Method

TypeScriptLanguageServiceGetDesignedClassName Method
Retrieves form class name from the content of specified file.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDesignedClassName(
    string userCodeFileName
)
Public Overrides Function GetDesignedClassName (
    userCodeFileName As String
) As String
public:
virtual String^ GetDesignedClassName(
    String^ userCodeFileName
) override
abstract GetDesignedClassName :
        userCodeFileName : string -> string
override GetDesignedClassName :
        userCodeFileName : string -> string

Parameters

userCodeFileName
Type: SystemString
Name of the file.

Return Value

Type: String
The name of form class.
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService.Init Method

TypeScriptLanguageServiceInit Method
Initializes a new Alternet.FormDesigner.TypeScript.TypeScriptLanguageService object for the TypeScript language and adds it to the language services collection.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Init()
Public Shared Sub Init
public:
static void Init()
static member Init : unit -> unit
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService.PreprocessCodeDomBeforeSaving Method

TypeScriptLanguageServicePreprocessCodeDomBeforeSaving Method
Preprocesses CodeDom representation of the form before saving its content.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PreprocessCodeDomBeforeSaving(
    CodeTypeDeclaration rootForm
)
Public Overrides Sub PreprocessCodeDomBeforeSaving (
    rootForm As CodeTypeDeclaration
)
public:
virtual void PreprocessCodeDomBeforeSaving(
    CodeTypeDeclaration^ rootForm
) override
abstract PreprocessCodeDomBeforeSaving :
        rootForm : CodeTypeDeclaration -> unit
override PreprocessCodeDomBeforeSaving :
        rootForm : CodeTypeDeclaration -> unit

Parameters

rootForm
Type: System.CodeDomCodeTypeDeclaration
CodeTypeDeclaration object to be preprocessed.
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


TypeScriptLanguageService.SaveDifferencesInCode Method

TypeScriptLanguageServiceSaveDifferencesInCode Method
Saves changes from the Form Designer to the TypeScript code.

Namespace: Alternet.FormDesigner.TypeScript
Assembly: Alternet.FormDesigner.TypeScript.v7 (in Alternet.FormDesigner.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void SaveDifferencesInCode(
    IFormDesignerDataSource source,
    IFormDesignerLoader designerLoader,
    IFormDesignerControl designer
)
Public Overrides Sub SaveDifferencesInCode (
    source As IFormDesignerDataSource,
    designerLoader As IFormDesignerLoader,
    designer As IFormDesignerControl
)
public:
virtual void SaveDifferencesInCode(
    IFormDesignerDataSource^ source,
    IFormDesignerLoader^ designerLoader,
    IFormDesignerControl^ designer
) override
abstract SaveDifferencesInCode :
        source : IFormDesignerDataSource *
        designerLoader : IFormDesignerLoader *
        designer : IFormDesignerControl -> unit
override SaveDifferencesInCode :
        source : IFormDesignerDataSource *
        designerLoader : IFormDesignerLoader *
        designer : IFormDesignerControl -> unit

Parameters

source
Type: Alternet.FormDesigner.WinFormsIFormDesignerDataSource
IFormDesignerDataSource where the changes will be saved.
designerLoader
Type: Alternet.FormDesigner.WinFormsIFormDesignerLoader
IFormDesignerLoader used to load form being designed.
designer
Type: Alternet.FormDesigner.WinFormsIFormDesignerControl
IFormDesignerControl that contains the form being designed.
See Also

Reference

TypeScriptLanguageService Class
Alternet.FormDesigner.TypeScript Namespace


Alternet.FormDesigner.WinForms Namespace

Alternet.FormDesigner.WinForms Namespace
Classes
 | Class | Description
Public class | CodeGenerationUtility | Stores a set of options used for form designer code generation.
Public class | CommandKeyBinding | Represents a key combination bound with some action.
Public class | ContextMenuHostControl |
Public class | CustomToolboxImage | Represents the toolbox image for different resolution.
Public class | DesignedComponentAssemblyFileProvider |
Public class | DesignerAssemblyResources | Represents a single resource for designer's assembly.
Public class | DesignerCompilerError | Provides data for designer compiler error.
Public class | DesignerCompilerErrorClickEventArgs | Provides data for the CompilerErrorClick handler.
Public class | DesignerImportedNamespaces | Represents a collection of default namespaces for the designer control.
Public class | DesignerLoadingCompilerErrorsException | Represents errors that occur during designer's content loading.
Public class | DesignerLoadingErrorEventArgs | Provides data for the LoadingErrorOccured handler.
Public class | DesignerReferencedAssemblies | Represents a collection of assemblies that can be referenced in the form designer's content.
Public class | DesignerSerializationService |
Public class | EditorFormDesignerDataSource | Provides extended properties and methods for a Form Designer control's data source.
Public class | EventBindingServiceBase | This class provides a default implementation of the event binding service. This class is abstract.
Public class | ExtendedDesignerOptionService |
Public class | ExtendedMenuCommandService |
Public class | FormDesignerAssemblyReferenceResolver | Provides functionality to resolve assembly references.
Public class | FormDesignerControl | Represents a control supports all standard form editing operations with controls.
Public class | FormDesignerDataSource | Provides properties and methods for a Form Designer control's data source.
Public class | FormDesignerHostContext | Encapsulates designer host together with the actual form designer control and its state.
Public class | FormDesignerOptions | Provides designer options for grid settings, grid size, snap lines and smart tags.
Public class | FormDesignerTextSourceOperations | Represents operations applied to IFormDesignerTextSource content.
Public class | FormDesignerTextSourceOperationsTextInsertionOperation | Represents properties applied to the text insertion operation.
Public class | FormDesignerTextSourceOperationsTextReplacementOperation | Represents properties applied to the text replacement operation.
Public class | NameCreationService |
Public class | NavigateToUserMethodRequestedEventArgs | Provides data for the NavigateToUserMethodRequested handler.
Public class | OutlineContextMenu | Implements a outline context menu.
Public class | OutlineControl | Represents the outline control.
Public class | PlaceToolboxItemAtDefaultLocationEventArgs | Provides parameters for PlaceItemAtDefaultLocation event.
Public class | PropertyGridControl | Provides a user interface for browsing the properties of an object.
Public class | ResourceService | Provides methods for designers to access resource readers and writers for specific System.Globalization.CultureInfo resource types.
Public class | TextSourceStream |
Public class | ToolboxControl | Displays and manipulates list of icons for components and controls that user can place onto design surface
Public class | UndoEngineService |
Interfaces
 | Interface | Description
Public interface | IDesignedComponentAssemblyProvider |
Public interface | IEventBindingServiceExtended | Provides an additional service for registering event handlers for component events.
Public interface | IFormDesignerCommands | Represents the set of commands that are available to the Form Designer.
Public interface | IFormDesignerControl | Represents a properties and methods to support all standard form editing operations with controls.
Public interface | IFormDesignerDataSource | Represents a properties and methods for a Form Designer control's data source.
Public interface | IFormDesignerHostContext | Represents methods and properties declaration to encapsulate designer host together with the actual form designer control and its state.
Public interface | IFormDesignerLoader | Represents methods and properties declaration to load and save designer's content.
Public interface | IFormDesignerTextSource | Represents a properties and methods for a Form Designer control's text.
Public interface | IOutlineControl | Represents the outline control.
Public interface | IPropertyGridControl | Provides a user interface for browsing the properties and methods of an object.
Public interface | IResourceServiceExtended | Provides an additional interface for designers to access resource readers and writers for specific System.Globalization.CultureInfo resource types.
Public interface | IToolboxControl | Represents properties and methods to display and manipulate list of icons for components and controls that user can place onto design surface.
Public interface | IToolboxServiceExtended | Provides additional properties to manage and query the toolbox in the development environment.
Public interface | IUndoEngine | Represents properties declaration for undo service.
Delegates
 | Delegate | Description
Public delegate | InsertTextIntoCodeDelegate | Represents a method that will handle inserting text into user's code.
Public delegate | OpenStreamDelegate | Represents a method that will handle opening form designer-generated code
Public delegate | OpenStreamForReadingDelegate | Represents a method that will handle opening user-defined code.
Enumerations
 | Enumeration | Description
Public enumeration | ContextMenuHostControlMenuPurpose |
Public enumeration | OutlineControlTypeNameDisplayStyle | Defines appearance of the item's type name in the outline control.
Public enumeration | StreamAccessMode | Defines constants for read, write access to a stream.


CodeGenerationUtility Class

CodeGenerationUtility Class
Stores a set of options used for form designer code generation.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsCodeGenerationUtility

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CodeGenerationUtility
Public NotInheritable Class CodeGenerationUtility
public ref class CodeGenerationUtility abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CodeGenerationUtility =  class end

The CodeGenerationUtility type exposes the following members.

Properties
Name | Description
GeneratorOptions | Gets or sets an options that define code generation rules.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


CodeGenerationUtility Properties

CodeGenerationUtility Properties

The CodeGenerationUtility type exposes the following members.

Properties
Name | Description
GeneratorOptions | Gets or sets an options that define code generation rules.
Top
See Also

Reference

CodeGenerationUtility Class
Alternet.FormDesigner.WinForms Namespace


CodeGenerationUtility.GeneratorOptions Property

CodeGenerationUtilityGeneratorOptions Property
Gets or sets an options that define code generation rules.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CodeGeneratorOptions GeneratorOptions { get; set; }
Public Shared Property GeneratorOptions As CodeGeneratorOptions
    Get
    Set
public:
static property CodeGeneratorOptions^ GeneratorOptions {
    CodeGeneratorOptions^ get ();
    void set (CodeGeneratorOptions^ value);
}
static member GeneratorOptions : CodeGeneratorOptions with get, set

Property Value

Type: CodeGeneratorOptions
See Also

Reference

CodeGenerationUtility Class
Alternet.FormDesigner.WinForms Namespace


CommandKeyBinding Class

CommandKeyBinding Class
Represents a key combination bound with some action.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsCommandKeyBinding

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CommandKeyBinding
Public Class CommandKeyBinding
public ref class CommandKeyBinding
type CommandKeyBinding =  class end

The CommandKeyBinding type exposes the following members.

Constructors
 | Name | Description
Public method | CommandKeyBinding | Initializes a new instance of the CommandKeyBinding class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CanDo | Represents the method to verify whether action can be performed.
Public property | Do | Represents the action that executes when the key combination is pressed.
Public property | KeyCode | Represents the keys associated with the action.
Public property | Modifiers | Represents the modifier keys associated with the action.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


CommandKeyBinding Constructor

CommandKeyBinding Constructor
Initializes a new instance of the CommandKeyBinding class with specified settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CommandKeyBinding(
    Keys keyCode,
    Keys modifierKeys,
    Action do,
    Func<bool> canDo
)
Public Sub New (
    keyCode As Keys,
    modifierKeys As Keys,
    do As Action,
    canDo As Func(Of Boolean)
)
public:
CommandKeyBinding(
    Keys keyCode,
    Keys modifierKeys,
    Action^ do,
    Func<bool>^ canDo
)
new :
        keyCode : Keys *
        modifierKeys : Keys *
        do : Action *
        canDo : Func<bool> -> CommandKeyBinding

Parameters

keyCode
Type: System.Windows.FormsKeys
The keys associated with the action.
modifierKeys
Type: System.Windows.FormsKeys
The modifier keys associated with the action.
do
Type: SystemAction
Action that executes when the key combination is pressed.
canDo
Type: SystemFuncBoolean
The method to verify whether action can be performed.
See Also

Reference

CommandKeyBinding Class
Alternet.FormDesigner.WinForms Namespace


CommandKeyBinding Methods

CommandKeyBinding Methods

The CommandKeyBinding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommandKeyBinding Class
Alternet.FormDesigner.WinForms Namespace


CommandKeyBinding Properties

CommandKeyBinding Properties

The CommandKeyBinding type exposes the following members.

Properties
 | Name | Description
Public property | CanDo | Represents the method to verify whether action can be performed.
Public property | Do | Represents the action that executes when the key combination is pressed.
Public property | KeyCode | Represents the keys associated with the action.
Public property | Modifiers | Represents the modifier keys associated with the action.
Top
See Also

Reference

CommandKeyBinding Class
Alternet.FormDesigner.WinForms Namespace


CommandKeyBinding.CanDo Property

CommandKeyBindingCanDo Property
Represents the method to verify whether action can be performed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<bool> CanDo { get; }
Public ReadOnly Property CanDo As Func(Of Boolean)
    Get
public:
property Func<bool>^ CanDo {
    Func<bool>^ get ();
}
member CanDo : Func<bool> with get

Property Value

Type: FuncBoolean
See Also

Reference

CommandKeyBinding Class
Alternet.FormDesigner.WinForms Namespace


CommandKeyBinding.Do Property

CommandKeyBindingDo Property
Represents the action that executes when the key combination is pressed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action Do { get; }
Public ReadOnly Property Do As Action
    Get
public:
property Action^ Do {
    Action^ get ();
}
member Do : Action with get

Property Value

Type: Action
See Also

Reference

CommandKeyBinding Class
Alternet.FormDesigner.WinForms Namespace


CommandKeyBinding.KeyCode Property

CommandKeyBindingKeyCode Property
Represents the keys associated with the action.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Keys KeyCode { get; }
Public ReadOnly Property KeyCode As Keys
    Get
public:
property Keys KeyCode {
    Keys get ();
}
member KeyCode : Keys with get

Property Value

Type: Keys
See Also

Reference

CommandKeyBinding Class
Alternet.FormDesigner.WinForms Namespace


CommandKeyBinding.Modifiers Property

CommandKeyBindingModifiers Property
Represents the modifier keys associated with the action.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Keys Modifiers { get; }
Public ReadOnly Property Modifiers As Keys
    Get
public:
property Keys Modifiers {
    Keys get ();
}
member Modifiers : Keys with get

Property Value

Type: Keys
See Also

Reference

CommandKeyBinding Class
Alternet.FormDesigner.WinForms Namespace


ContextMenuHostControl Class

ContextMenuHostControl Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.FormDesigner.WinFormsContextMenuHostControl

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ContextMenuHostControl : UserControl
Public NotInheritable Class ContextMenuHostControl
    Inherits UserControl
public ref class ContextMenuHostControl sealed : public UserControl
[<SealedAttribute>]
type ContextMenuHostControl =
    class
        inherit UserControl
    end

The ContextMenuHostControl type exposes the following members.

Constructors
 | Name | Description
Public method | ContextMenuHostControl | Initializes a new instance of the ContextMenuHostControl class
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetContextMenuStrip |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialize |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


ContextMenuHostControl Constructor

ContextMenuHostControl Constructor
Initializes a new instance of the ContextMenuHostControl class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContextMenuHostControl()
Public Sub New
public:
ContextMenuHostControl()
new : unit -> ContextMenuHostControl
See Also

Reference

ContextMenuHostControl Class
Alternet.FormDesigner.WinForms Namespace


ContextMenuHostControl Methods

ContextMenuHostControl Methods

The ContextMenuHostControl type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetContextMenuStrip |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | Initialize |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

ContextMenuHostControl Class
Alternet.FormDesigner.WinForms Namespace


ContextMenuHostControl.GetContextMenuStrip Method

ContextMenuHostControlGetContextMenuStrip Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContextMenuStrip GetContextMenuStrip(
    ContextMenuHostControlMenuPurpose purpose
)
Public Function GetContextMenuStrip (
    purpose As ContextMenuHostControlMenuPurpose
) As ContextMenuStrip
public:
ContextMenuStrip^ GetContextMenuStrip(
    ContextMenuHostControlMenuPurpose purpose
)
member GetContextMenuStrip :
        purpose : ContextMenuHostControlMenuPurpose -> ContextMenuStrip

Parameters

purpose
Type: Alternet.FormDesigner.WinFormsContextMenuHostControlMenuPurpose

Return Value

Type: ContextMenuStrip
See Also

Reference

ContextMenuHostControl Class
Alternet.FormDesigner.WinForms Namespace


ContextMenuHostControl.Initialize Method

ContextMenuHostControlInitialize Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialize(
    IServiceProvider serviceProvider
)
Public Sub Initialize (
    serviceProvider As IServiceProvider
)
public:
void Initialize(
    IServiceProvider^ serviceProvider
)
member Initialize :
        serviceProvider : IServiceProvider -> unit

Parameters

serviceProvider
Type: SystemIServiceProvider
See Also

Reference

ContextMenuHostControl Class
Alternet.FormDesigner.WinForms Namespace


ContextMenuHostControl.Localize Method

ContextMenuHostControlLocalize Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

ContextMenuHostControl Class
Alternet.FormDesigner.WinForms Namespace


ContextMenuHostControl Properties

ContextMenuHostControl Properties

The ContextMenuHostControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ContextMenuHostControl Class
Alternet.FormDesigner.WinForms Namespace


ContextMenuHostControl Events

ContextMenuHostControl Events

The ContextMenuHostControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ContextMenuHostControl Class
Alternet.FormDesigner.WinForms Namespace


ContextMenuHostControl.MenuPurpose Enumeration

ContextMenuHostControlMenuPurpose Enumeration

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MenuPurpose
Public Enumeration MenuPurpose
public enum class MenuPurpose
type MenuPurpose
Members
Member name | Value | Description
SingleObject | 0 |
MultipleObjects | 1 |
Surface | 2 |
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


CustomToolboxImage Class

CustomToolboxImage Class
Represents the toolbox image for different resolution.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsCustomToolboxImage

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CustomToolboxImage
Public Class CustomToolboxImage
public ref class CustomToolboxImage
type CustomToolboxImage =  class end

The CustomToolboxImage type exposes the following members.

Constructors
 | Name | Description
Public method | CustomToolboxImage | Initializes a new instance of the CustomToolboxImage class with specific settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Image | Represents an image in normal resolution.
Public property | ImageHighDpi | Represents an image in HighDpi resolution.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


CustomToolboxImage Constructor

CustomToolboxImage Constructor
Initializes a new instance of the CustomToolboxImage class with specific settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CustomToolboxImage(
    Image image,
    Image imageHighDpi
)
Public Sub New (
    image As Image,
    imageHighDpi As Image
)
public:
CustomToolboxImage(
    Image^ image,
    Image^ imageHighDpi
)
new :
        image : Image *
        imageHighDpi : Image -> CustomToolboxImage

Parameters

image
Type: System.DrawingImage
The image in normal resolution.
imageHighDpi
Type: System.DrawingImage
The image in HighDpi resolution.
See Also

Reference

CustomToolboxImage Class
Alternet.FormDesigner.WinForms Namespace


CustomToolboxImage Methods

CustomToolboxImage Methods

The CustomToolboxImage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomToolboxImage Class
Alternet.FormDesigner.WinForms Namespace


CustomToolboxImage Properties

CustomToolboxImage Properties

The CustomToolboxImage type exposes the following members.

Properties
 | Name | Description
Public property | Image | Represents an image in normal resolution.
Public property | ImageHighDpi | Represents an image in HighDpi resolution.
Top
See Also

Reference

CustomToolboxImage Class
Alternet.FormDesigner.WinForms Namespace


CustomToolboxImage.Image Property

CustomToolboxImageImage Property
Represents an image in normal resolution.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
property Image^ Image {
    Image^ get ();
}
member Image : Image with get

Property Value

Type: Image
See Also

Reference

CustomToolboxImage Class
Alternet.FormDesigner.WinForms Namespace


CustomToolboxImage.ImageHighDpi Property

CustomToolboxImageImageHighDpi Property
Represents an image in HighDpi resolution.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image ImageHighDpi { get; }
Public ReadOnly Property ImageHighDpi As Image
    Get
public:
property Image^ ImageHighDpi {
    Image^ get ();
}
member ImageHighDpi : Image with get

Property Value

Type: Image
See Also

Reference

CustomToolboxImage Class
Alternet.FormDesigner.WinForms Namespace


DesignedComponentAssemblyFileProvider Class

DesignedComponentAssemblyFileProvider Class
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsDesignedComponentAssemblyFileProvider

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignedComponentAssemblyFileProvider : IDesignedComponentAssemblyProvider
Public Class DesignedComponentAssemblyFileProvider
    Implements IDesignedComponentAssemblyProvider
public ref class DesignedComponentAssemblyFileProvider : IDesignedComponentAssemblyProvider
type DesignedComponentAssemblyFileProvider =
    class
        interface IDesignedComponentAssemblyProvider
    end

The DesignedComponentAssemblyFileProvider type exposes the following members.

Constructors
 | Name | Description
Public method | DesignedComponentAssemblyFileProvider | Initializes a new instance of the DesignedComponentAssemblyFileProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NotifyAssemblyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetAssemblyBytes |
Top
Properties
 | Name | Description
Public property | AssemblyFilePath |
Top
Events
 | Name | Description
Public event | AssemblyChanged |
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


DesignedComponentAssemblyFileProvider Constructor

DesignedComponentAssemblyFileProvider Constructor
Initializes a new instance of the DesignedComponentAssemblyFileProvider class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignedComponentAssemblyFileProvider()
Public Sub New
public:
DesignedComponentAssemblyFileProvider()
new : unit -> DesignedComponentAssemblyFileProvider
See Also

Reference

DesignedComponentAssemblyFileProvider Class
Alternet.FormDesigner.WinForms Namespace


DesignedComponentAssemblyFileProvider Methods

DesignedComponentAssemblyFileProvider Methods

The DesignedComponentAssemblyFileProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NotifyAssemblyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetAssemblyBytes |
Top
See Also

Reference

DesignedComponentAssemblyFileProvider Class
Alternet.FormDesigner.WinForms Namespace


DesignedComponentAssemblyFileProvider.NotifyAssemblyChanged Method

DesignedComponentAssemblyFileProviderNotifyAssemblyChanged Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void NotifyAssemblyChanged()
Public Sub NotifyAssemblyChanged
public:
virtual void NotifyAssemblyChanged() sealed
abstract NotifyAssemblyChanged : unit -> unit
override NotifyAssemblyChanged : unit -> unit

Implements

IDesignedComponentAssemblyProviderNotifyAssemblyChanged
See Also

Reference

DesignedComponentAssemblyFileProvider Class
Alternet.FormDesigner.WinForms Namespace


DesignedComponentAssemblyFileProvider.TryGetAssemblyBytes Method

DesignedComponentAssemblyFileProviderTryGetAssemblyBytes Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TryGetAssemblyBytes(
    out byte[] assemblyBytes
)
Public Function TryGetAssemblyBytes (
    <OutAttribute> ByRef assemblyBytes As Byte()
) As Boolean
public:
virtual bool TryGetAssemblyBytes(
    [OutAttribute] array<unsigned char>^% assemblyBytes
) sealed
abstract TryGetAssemblyBytes :
        assemblyBytes : byte[] byref -> bool
override TryGetAssemblyBytes :
        assemblyBytes : byte[] byref -> bool

Parameters

assemblyBytes
Type: SystemByte

Return Value

Type: Boolean

Implements

IDesignedComponentAssemblyProviderTryGetAssemblyBytes(Byte)
See Also

Reference

DesignedComponentAssemblyFileProvider Class
Alternet.FormDesigner.WinForms Namespace


DesignedComponentAssemblyFileProvider Properties

DesignedComponentAssemblyFileProvider Properties

The DesignedComponentAssemblyFileProvider type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyFilePath |
Top
See Also

Reference

DesignedComponentAssemblyFileProvider Class
Alternet.FormDesigner.WinForms Namespace


DesignedComponentAssemblyFileProvider.AssemblyFilePath Property

DesignedComponentAssemblyFileProviderAssemblyFilePath Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyFilePath { get; set; }
Public Property AssemblyFilePath As String
    Get
    Set
public:
property String^ AssemblyFilePath {
    String^ get ();
    void set (String^ value);
}
member AssemblyFilePath : string with get, set

Property Value

Type: String
See Also

Reference

DesignedComponentAssemblyFileProvider Class
Alternet.FormDesigner.WinForms Namespace


DesignedComponentAssemblyFileProvider Events

DesignedComponentAssemblyFileProvider Events

The DesignedComponentAssemblyFileProvider type exposes the following members.

Events
 | Name | Description
Public event | AssemblyChanged |
Top
See Also

Reference

DesignedComponentAssemblyFileProvider Class
Alternet.FormDesigner.WinForms Namespace


DesignedComponentAssemblyFileProvider.AssemblyChanged Event

DesignedComponentAssemblyFileProviderAssemblyChanged Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler AssemblyChanged
Public Event AssemblyChanged As EventHandler
public:
virtual  event EventHandler^ AssemblyChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract AssemblyChanged : IEvent<EventHandler,
    EventArgs>
override AssemblyChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IDesignedComponentAssemblyProviderAssemblyChanged
See Also

Reference

DesignedComponentAssemblyFileProvider Class
Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources Class

DesignerAssemblyResources Class
Represents a single resource for designer's assembly.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsDesignerAssemblyResources

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignerAssemblyResources
Public Class DesignerAssemblyResources
public ref class DesignerAssemblyResources
type DesignerAssemblyResources =  class end

The DesignerAssemblyResources type exposes the following members.

Constructors
 | Name | Description
Public method | DesignerAssemblyResources | Initializes a new instance of the DesignerAssemblyResources class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromResXFilePath | Creates DesignerAssemblyResources using specified parameters.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyRootNamespace | Represents the assembly root namespace.
Public property | BaseDirectoryPath | Represents the base directory for the assembly resource.
Public property | CodeFilePath | Represents the full path of the code file.
Public property | FullClassName | Represents the fully qualified class name.
Public property | ResXFilePath | Represents the full path of the .resx file
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources Constructor

DesignerAssemblyResources Constructor
Initializes a new instance of the DesignerAssemblyResources class with specified settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerAssemblyResources(
    string resXFilePath,
    string codeFilePath,
    string fullClassName,
    string baseDirectoryPath,
    string assemblyRootNamespace
)
Public Sub New (
    resXFilePath As String,
    codeFilePath As String,
    fullClassName As String,
    baseDirectoryPath As String,
    assemblyRootNamespace As String
)
public:
DesignerAssemblyResources(
    String^ resXFilePath,
    String^ codeFilePath,
    String^ fullClassName,
    String^ baseDirectoryPath,
    String^ assemblyRootNamespace
)
new :
        resXFilePath : string *
        codeFilePath : string *
        fullClassName : string *
        baseDirectoryPath : string *
        assemblyRootNamespace : string -> DesignerAssemblyResources

Parameters

resXFilePath
Type: SystemString
The full path of the .resx file.
codeFilePath
Type: SystemString
The full path of the code file.
fullClassName
Type: SystemString
The fully qualified class name.
baseDirectoryPath
Type: SystemString
The base directory for the assembly resource.
assemblyRootNamespace
Type: SystemString
The assembly root namespace.
See Also

Reference

DesignerAssemblyResources Class
Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources Methods

DesignerAssemblyResources Methods

The DesignerAssemblyResources type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromResXFilePath | Creates DesignerAssemblyResources using specified parameters.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DesignerAssemblyResources Class
Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources.FromResXFilePath Method

DesignerAssemblyResourcesFromResXFilePath Method
Creates DesignerAssemblyResources using specified parameters.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DesignerAssemblyResources FromResXFilePath(
    string resXFilePath,
    Language language,
    string assemblyRootNamespace
)
Public Shared Function FromResXFilePath (
    resXFilePath As String,
    language As Language,
    assemblyRootNamespace As String
) As DesignerAssemblyResources
public:
static DesignerAssemblyResources^ FromResXFilePath(
    String^ resXFilePath,
    Language^ language,
    String^ assemblyRootNamespace
)
static member FromResXFilePath :
        resXFilePath : string *
        language : Language *
        assemblyRootNamespace : string -> DesignerAssemblyResources

Parameters

resXFilePath
Type: SystemString
The full path of the .resx file.
language
Type: Language
The .NET language used to write designer's code.
assemblyRootNamespace
Type: SystemString
The assembly root namespace.

Return Value

Type: DesignerAssemblyResources
See Also

Reference

DesignerAssemblyResources Class
Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources Properties

DesignerAssemblyResources Properties

The DesignerAssemblyResources type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyRootNamespace | Represents the assembly root namespace.
Public property | BaseDirectoryPath | Represents the base directory for the assembly resource.
Public property | CodeFilePath | Represents the full path of the code file.
Public property | FullClassName | Represents the fully qualified class name.
Public property | ResXFilePath | Represents the full path of the .resx file
Top
See Also

Reference

DesignerAssemblyResources Class
Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources.AssemblyRootNamespace Property

DesignerAssemblyResourcesAssemblyRootNamespace Property
Represents the assembly root namespace.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyRootNamespace { get; }
Public ReadOnly Property AssemblyRootNamespace As String
    Get
public:
property String^ AssemblyRootNamespace {
    String^ get ();
}
member AssemblyRootNamespace : string with get

Property Value

Type: String
See Also

Reference

DesignerAssemblyResources Class
Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources.BaseDirectoryPath Property

DesignerAssemblyResourcesBaseDirectoryPath Property
Represents the base directory for the assembly resource.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BaseDirectoryPath { get; }
Public ReadOnly Property BaseDirectoryPath As String
    Get
public:
property String^ BaseDirectoryPath {
    String^ get ();
}
member BaseDirectoryPath : string with get

Property Value

Type: String
See Also

Reference

DesignerAssemblyResources Class
Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources.CodeFilePath Property

DesignerAssemblyResourcesCodeFilePath Property
Represents the full path of the code file.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CodeFilePath { get; }
Public ReadOnly Property CodeFilePath As String
    Get
public:
property String^ CodeFilePath {
    String^ get ();
}
member CodeFilePath : string with get

Property Value

Type: String
See Also

Reference

DesignerAssemblyResources Class
Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources.FullClassName Property

DesignerAssemblyResourcesFullClassName Property
Represents the fully qualified class name.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullClassName { get; }
Public ReadOnly Property FullClassName As String
    Get
public:
property String^ FullClassName {
    String^ get ();
}
member FullClassName : string with get

Property Value

Type: String
See Also

Reference

DesignerAssemblyResources Class
Alternet.FormDesigner.WinForms Namespace


DesignerAssemblyResources.ResXFilePath Property

DesignerAssemblyResourcesResXFilePath Property
Represents the full path of the .resx file

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ResXFilePath { get; }
Public ReadOnly Property ResXFilePath As String
    Get
public:
property String^ ResXFilePath {
    String^ get ();
}
member ResXFilePath : string with get

Property Value

Type: String
See Also

Reference

DesignerAssemblyResources Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerError Class

DesignerCompilerError Class
Provides data for designer compiler error.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsDesignerCompilerError

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignerCompilerError
Public Class DesignerCompilerError
public ref class DesignerCompilerError
type DesignerCompilerError =  class end

The DesignerCompilerError type exposes the following members.

Constructors
 | Name | Description
Public method | DesignerCompilerError | Initializes a new instance of the DesignerCompilerError class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current DesignerCompilerError. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | CharacterNumber | Represents the number of the character where error occurred.
Public property | FilePath | Represents the name of the file where error occurred.
Public property | LineNumber | Represents the number of the line where error occurred.
Public property | Message | Represents the text describes error.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


DesignerCompilerError Constructor

DesignerCompilerError Constructor
Initializes a new instance of the DesignerCompilerError class with specified parameters.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerCompilerError(
    string filePath,
    int lineNumber,
    int characterNumber,
    string message
)
Public Sub New (
    filePath As String,
    lineNumber As Integer,
    characterNumber As Integer,
    message As String
)
public:
DesignerCompilerError(
    String^ filePath,
    int lineNumber,
    int characterNumber,
    String^ message
)
new :
        filePath : string *
        lineNumber : int *
        characterNumber : int *
        message : string -> DesignerCompilerError

Parameters

filePath
Type: SystemString
The name of the file where error occurred.
lineNumber
Type: SystemInt32
The number of the line where error occurred.
characterNumber
Type: SystemInt32
The number of the character where error occurred.
message
Type: SystemString
Text describes error.
See Also

Reference

DesignerCompilerError Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerError Methods

DesignerCompilerError Methods

The DesignerCompilerError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current DesignerCompilerError. (Overrides ObjectToString.)
Top
See Also

Reference

DesignerCompilerError Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerError.ToString Method

DesignerCompilerErrorToString Method
Returns a String that represents the current DesignerCompilerError.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents the current DesignerCompilerError.
See Also

Reference

DesignerCompilerError Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerError Properties

DesignerCompilerError Properties

The DesignerCompilerError type exposes the following members.

Properties
 | Name | Description
Public property | CharacterNumber | Represents the number of the character where error occurred.
Public property | FilePath | Represents the name of the file where error occurred.
Public property | LineNumber | Represents the number of the line where error occurred.
Public property | Message | Represents the text describes error.
Top
See Also

Reference

DesignerCompilerError Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerError.CharacterNumber Property

DesignerCompilerErrorCharacterNumber Property
Represents the number of the character where error occurred.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CharacterNumber { get; }
Public ReadOnly Property CharacterNumber As Integer
    Get
public:
property int CharacterNumber {
    int get ();
}
member CharacterNumber : int with get

Property Value

Type: Int32
See Also

Reference

DesignerCompilerError Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerError.FilePath Property

DesignerCompilerErrorFilePath Property
Represents the name of the file where error occurred.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get
public:
property String^ FilePath {
    String^ get ();
}
member FilePath : string with get

Property Value

Type: String
See Also

Reference

DesignerCompilerError Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerError.LineNumber Property

DesignerCompilerErrorLineNumber Property
Represents the number of the line where error occurred.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LineNumber { get; }
Public ReadOnly Property LineNumber As Integer
    Get
public:
property int LineNumber {
    int get ();
}
member LineNumber : int with get

Property Value

Type: Int32
See Also

Reference

DesignerCompilerError Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerError.Message Property

DesignerCompilerErrorMessage Property
Represents the text describes error.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}
member Message : string with get

Property Value

Type: String
See Also

Reference

DesignerCompilerError Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerErrorClickEventArgs Class

DesignerCompilerErrorClickEventArgs Class
Provides data for the CompilerErrorClick handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.FormDesigner.WinFormsDesignerCompilerErrorClickEventArgs

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignerCompilerErrorClickEventArgs : EventArgs
Public Class DesignerCompilerErrorClickEventArgs
    Inherits EventArgs
public ref class DesignerCompilerErrorClickEventArgs : public EventArgs
type DesignerCompilerErrorClickEventArgs =
    class
        inherit EventArgs
    end

The DesignerCompilerErrorClickEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DesignerCompilerErrorClickEventArgs | Initializes a new instance of the DesignerCompilerErrorClickEventArgs class with specified error.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Error | Represents the error occurred while compilation designer's content.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


DesignerCompilerErrorClickEventArgs Constructor

DesignerCompilerErrorClickEventArgs Constructor
Initializes a new instance of the DesignerCompilerErrorClickEventArgs class with specified error.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerCompilerErrorClickEventArgs(
    DesignerCompilerError error
)
Public Sub New (
    error As DesignerCompilerError
)
public:
DesignerCompilerErrorClickEventArgs(
    DesignerCompilerError^ error
)
new :
        error : DesignerCompilerError -> DesignerCompilerErrorClickEventArgs

Parameters

error
Type: Alternet.FormDesigner.WinFormsDesignerCompilerError
The error occurred while compilation designer's content.
See Also

Reference

DesignerCompilerErrorClickEventArgs Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerErrorClickEventArgs Methods

DesignerCompilerErrorClickEventArgs Methods

The DesignerCompilerErrorClickEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DesignerCompilerErrorClickEventArgs Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerErrorClickEventArgs Properties

DesignerCompilerErrorClickEventArgs Properties

The DesignerCompilerErrorClickEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Error | Represents the error occurred while compilation designer's content.
Top
See Also

Reference

DesignerCompilerErrorClickEventArgs Class
Alternet.FormDesigner.WinForms Namespace


DesignerCompilerErrorClickEventArgs.Error Property

DesignerCompilerErrorClickEventArgsError Property
Represents the error occurred while compilation designer's content.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerCompilerError Error { get; }
Public ReadOnly Property Error As DesignerCompilerError
    Get
public:
property DesignerCompilerError^ Error {
    DesignerCompilerError^ get ();
}
member Error : DesignerCompilerError with get

Property Value

Type: DesignerCompilerError
See Also

Reference

DesignerCompilerErrorClickEventArgs Class
Alternet.FormDesigner.WinForms Namespace


DesignerImportedNamespaces Class

DesignerImportedNamespaces Class
Represents a collection of default namespaces for the designer control.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsDesignerImportedNamespaces

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignerImportedNamespaces
Public Class DesignerImportedNamespaces
public ref class DesignerImportedNamespaces
type DesignerImportedNamespaces =  class end

The DesignerImportedNamespaces type exposes the following members.

Constructors
 | Name | Description
Public method | DesignerImportedNamespaces | Initializes a new instance of the DesignerImportedNamespaces class with specified namespace's list.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DefaultForVisualBasic | Represents a collection of namespaces default for Visual Basic language project.
Top
Properties
 | Name | Description
Public property | Namespaces | Gets or sets a list of namespaces.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


DesignerImportedNamespaces Constructor

DesignerImportedNamespaces Constructor
Initializes a new instance of the DesignerImportedNamespaces class with specified namespace's list.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerImportedNamespaces(
    params string[] namespaces
)
Public Sub New (
    ParamArray namespaces As String()
)
public:
DesignerImportedNamespaces(
    ... array<String^>^ namespaces
)
new :
        namespaces : string[] -> DesignerImportedNamespaces

Parameters

namespaces
Type: SystemString
List of namespaces.
See Also

Reference

DesignerImportedNamespaces Class
Alternet.FormDesigner.WinForms Namespace


DesignerImportedNamespaces Fields

DesignerImportedNamespaces Fields

The DesignerImportedNamespaces type exposes the following members.

Fields
Name | Description
DefaultForVisualBasic | Represents a collection of namespaces default for Visual Basic language project.
Top
See Also

Reference

DesignerImportedNamespaces Class
Alternet.FormDesigner.WinForms Namespace


DesignerImportedNamespaces.DefaultForVisualBasic Field

DesignerImportedNamespacesDefaultForVisualBasic Field
Represents a collection of namespaces default for Visual Basic language project.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly DesignerImportedNamespaces DefaultForVisualBasic
Public Shared ReadOnly DefaultForVisualBasic As DesignerImportedNamespaces
public:
static initonly DesignerImportedNamespaces^ DefaultForVisualBasic
static val DefaultForVisualBasic: DesignerImportedNamespaces

Field Value

Type: DesignerImportedNamespaces
See Also

Reference

DesignerImportedNamespaces Class
Alternet.FormDesigner.WinForms Namespace


DesignerImportedNamespaces Methods

DesignerImportedNamespaces Methods

The DesignerImportedNamespaces type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DesignerImportedNamespaces Class
Alternet.FormDesigner.WinForms Namespace


DesignerImportedNamespaces Properties

DesignerImportedNamespaces Properties

The DesignerImportedNamespaces type exposes the following members.

Properties
 | Name | Description
Public property | Namespaces | Gets or sets a list of namespaces.
Top
See Also

Reference

DesignerImportedNamespaces Class
Alternet.FormDesigner.WinForms Namespace


DesignerImportedNamespaces.Namespaces Property

DesignerImportedNamespacesNamespaces Property
Gets or sets a list of namespaces.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Namespaces { get; }
Public ReadOnly Property Namespaces As String()
    Get
public:
property array<String^>^ Namespaces {
    array<String^>^ get ();
}
member Namespaces : string[] with get

Property Value

Type: String
See Also

Reference

DesignerImportedNamespaces Class
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingCompilerErrorsException Class

DesignerLoadingCompilerErrorsException Class
Represents errors that occur during designer's content loading.
Inheritance Hierarchy
SystemObject
SystemException
Alternet.FormDesigner.WinFormsDesignerLoadingCompilerErrorsException

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignerLoadingCompilerErrorsException : Exception
Public Class DesignerLoadingCompilerErrorsException
    Inherits Exception
public ref class DesignerLoadingCompilerErrorsException : public Exception
type DesignerLoadingCompilerErrorsException =
    class
        inherit Exception
    end

The DesignerLoadingCompilerErrorsException type exposes the following members.

Constructors
 | Name | Description
Public method | DesignerLoadingCompilerErrorsException | Initializes a new instance of the DesignerLoadingCompilerErrorsException class with specified errors.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | CompilerErrors | Represents list of the DesignerCompilerError occurred during designer's content loading.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


DesignerLoadingCompilerErrorsException Constructor

DesignerLoadingCompilerErrorsException Constructor
Initializes a new instance of the DesignerLoadingCompilerErrorsException class with specified errors.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerLoadingCompilerErrorsException(
    IEnumerable<DesignerCompilerError> errors
)
Public Sub New (
    errors As IEnumerable(Of DesignerCompilerError)
)
public:
DesignerLoadingCompilerErrorsException(
    IEnumerable<DesignerCompilerError^>^ errors
)
new :
        errors : IEnumerable<DesignerCompilerError> -> DesignerLoadingCompilerErrorsException

Parameters

errors
Type: System.Collections.GenericIEnumerableDesignerCompilerError
List of the DesignerCompilerError.
See Also

Reference

DesignerLoadingCompilerErrorsException Class
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingCompilerErrorsException Methods

DesignerLoadingCompilerErrorsException Methods

The DesignerLoadingCompilerErrorsException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DesignerLoadingCompilerErrorsException Class
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingCompilerErrorsException Properties

DesignerLoadingCompilerErrorsException Properties

The DesignerLoadingCompilerErrorsException type exposes the following members.

Properties
 | Name | Description
Public property | CompilerErrors | Represents list of the DesignerCompilerError occurred during designer's content loading.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DesignerLoadingCompilerErrorsException Class
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingCompilerErrorsException.CompilerErrors Property

DesignerLoadingCompilerErrorsExceptionCompilerErrors Property
Represents list of the DesignerCompilerError occurred during designer's content loading.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DesignerCompilerError> CompilerErrors { get; }
Public ReadOnly Property CompilerErrors As IEnumerable(Of DesignerCompilerError)
    Get
public:
property IEnumerable<DesignerCompilerError^>^ CompilerErrors {
    IEnumerable<DesignerCompilerError^>^ get ();
}
member CompilerErrors : IEnumerable<DesignerCompilerError> with get

Property Value

Type: IEnumerableDesignerCompilerError
See Also

Reference

DesignerLoadingCompilerErrorsException Class
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingErrorEventArgs Class

DesignerLoadingErrorEventArgs Class
Provides data for the LoadingErrorOccured handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.FormDesigner.WinFormsDesignerLoadingErrorEventArgs

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignerLoadingErrorEventArgs : EventArgs
Public Class DesignerLoadingErrorEventArgs
    Inherits EventArgs
public ref class DesignerLoadingErrorEventArgs : public EventArgs
type DesignerLoadingErrorEventArgs =
    class
        inherit EventArgs
    end

The DesignerLoadingErrorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DesignerLoadingErrorEventArgs(String) | Initializes a new instance of the DesignerLoadingErrorEventArgs class with specified error message.
Public method | DesignerLoadingErrorEventArgs(IEnumerableDesignerCompilerError) | Initializes a new instance of the DesignerLoadingErrorEventArgs class with specified errors.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Errors | Represents list of the DesignerCompilerError occurred during designer's content loading.
Public property | Message | Represents text describes error occurred during designer's content loading.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


DesignerLoadingErrorEventArgs Constructor

DesignerLoadingErrorEventArgs Constructor
Overload List
 | Name | Description
Public method | DesignerLoadingErrorEventArgs(String) | Initializes a new instance of the DesignerLoadingErrorEventArgs class with specified error message.
Public method | DesignerLoadingErrorEventArgs(IEnumerableDesignerCompilerError) | Initializes a new instance of the DesignerLoadingErrorEventArgs class with specified errors.
Top
See Also

Reference

DesignerLoadingErrorEventArgs Class
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingErrorEventArgs Constructor (String)

DesignerLoadingErrorEventArgs Constructor (String)
Initializes a new instance of the DesignerLoadingErrorEventArgs class with specified error message.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerLoadingErrorEventArgs(
    string message
)
Public Sub New (
    message As String
)
public:
DesignerLoadingErrorEventArgs(
    String^ message
)
new :
        message : string -> DesignerLoadingErrorEventArgs

Parameters

message
Type: SystemString
Text describes error.
See Also

Reference

DesignerLoadingErrorEventArgs Class
DesignerLoadingErrorEventArgs Overload
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingErrorEventArgs Constructor (IEnumerable(DesignerCompilerError))

DesignerLoadingErrorEventArgs Constructor (IEnumerableDesignerCompilerError)
Initializes a new instance of the DesignerLoadingErrorEventArgs class with specified errors.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerLoadingErrorEventArgs(
    IEnumerable<DesignerCompilerError> errors
)
Public Sub New (
    errors As IEnumerable(Of DesignerCompilerError)
)
public:
DesignerLoadingErrorEventArgs(
    IEnumerable<DesignerCompilerError^>^ errors
)
new :
        errors : IEnumerable<DesignerCompilerError> -> DesignerLoadingErrorEventArgs

Parameters

errors
Type: System.Collections.GenericIEnumerableDesignerCompilerError
List of the DesignerCompilerError.
See Also

Reference

DesignerLoadingErrorEventArgs Class
DesignerLoadingErrorEventArgs Overload
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingErrorEventArgs Methods

DesignerLoadingErrorEventArgs Methods

The DesignerLoadingErrorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DesignerLoadingErrorEventArgs Class
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingErrorEventArgs Properties

DesignerLoadingErrorEventArgs Properties

The DesignerLoadingErrorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Represents list of the DesignerCompilerError occurred during designer's content loading.
Public property | Message | Represents text describes error occurred during designer's content loading.
Top
See Also

Reference

DesignerLoadingErrorEventArgs Class
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingErrorEventArgs.Errors Property

DesignerLoadingErrorEventArgsErrors Property
Represents list of the DesignerCompilerError occurred during designer's content loading.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DesignerCompilerError> Errors { get; }
Public ReadOnly Property Errors As IEnumerable(Of DesignerCompilerError)
    Get
public:
property IEnumerable<DesignerCompilerError^>^ Errors {
    IEnumerable<DesignerCompilerError^>^ get ();
}
member Errors : IEnumerable<DesignerCompilerError> with get

Property Value

Type: IEnumerableDesignerCompilerError
See Also

Reference

DesignerLoadingErrorEventArgs Class
Alternet.FormDesigner.WinForms Namespace


DesignerLoadingErrorEventArgs.Message Property

DesignerLoadingErrorEventArgsMessage Property
Represents text describes error occurred during designer's content loading.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}
member Message : string with get

Property Value

Type: String
See Also

Reference

DesignerLoadingErrorEventArgs Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies Class

DesignerReferencedAssemblies Class
Represents a collection of assemblies that can be referenced in the form designer's content.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsDesignerReferencedAssemblies

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignerReferencedAssemblies
Public Class DesignerReferencedAssemblies
public ref class DesignerReferencedAssemblies
type DesignerReferencedAssemblies =  class end

The DesignerReferencedAssemblies type exposes the following members.

Constructors
 | Name | Description
Public method | DesignerReferencedAssemblies(IEnumerableString) | Initializes a new instance of the DesignerReferencedAssemblies class with specified assemblies's list.
Public method | DesignerReferencedAssemblies(String) | Initializes a new instance of the DesignerReferencedAssemblies class with specified assemblies's list.
Public method | DesignerReferencedAssemblies(IEnumerableString, String, String, String) | Initializes a new instance of the DesignerReferencedAssemblies class with specified settings.
Public method | DesignerReferencedAssemblies(IEnumerableString, String, String, IEnumerableString, TargetNETFrameworkVersion) | Initializes a new instance of the DesignerReferencedAssemblies class with specified parameters.
Top
Methods
 | Name | Description
Public method | AddAssemblyName | Creates a new DesignerReferencedAssemblies instance with the list of assemblies updated to include specified assembly.
Public method | AddAssemblyNames | Creates a new DesignerReferencedAssemblies instance with the list of assemblies updated to include specified assemblies.
Public method | AddSearchPath | Creates a new DesignerReferencedAssemblies instance with the list of search paths updated to include specified search path.
Public method | AddSearchPaths | Creates a new DesignerReferencedAssemblies instance with the list of search paths updated to include specified search paths.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithAssemblyNames | Creates a new DesignerReferencedAssemblies instance with the list of assemblies updated to include only specified assemblies.
Public method | WithSearchPaths | Creates a new DesignerReferencedAssemblies instance with the list of search paths updated to include only specified search paths.
Top
Fields
Name | Description
DefaultForCSharp | Represents a collection of assemblies default for C# language project.
DefaultForTypeScript | Represents a collection of assemblies default for C# language project.
DefaultForVisualBasic | Represents a collection of assemblies default for Visual Basic language project.
Top
Properties
 | Name | Description
Public property | AssemblyNames | Represents a list of assemblies.
Public property | BaseDirectory | Represents path to the base project's directory.
Public property | FrameworkPath | Represents path to the current framework.
Public property | SearchPaths | Represents a collection of assembly search paths.
Public property | TargetFrameworkVersion | Gets or sets version of the .NET Framework to be used for locating Framework assemblies.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies Constructor

DesignerReferencedAssemblies Constructor
Overload List
 | Name | Description
Public method | DesignerReferencedAssemblies(IEnumerableString) | Initializes a new instance of the DesignerReferencedAssemblies class with specified assemblies's list.
Public method | DesignerReferencedAssemblies(String) | Initializes a new instance of the DesignerReferencedAssemblies class with specified assemblies's list.
Public method | DesignerReferencedAssemblies(IEnumerableString, String, String, String) | Initializes a new instance of the DesignerReferencedAssemblies class with specified settings.
Public method | DesignerReferencedAssemblies(IEnumerableString, String, String, IEnumerableString, TargetNETFrameworkVersion) | Initializes a new instance of the DesignerReferencedAssemblies class with specified parameters.
Top
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies Constructor (IEnumerable(String))

DesignerReferencedAssemblies Constructor (IEnumerableString)
Initializes a new instance of the DesignerReferencedAssemblies class with specified assemblies's list.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies(
    IEnumerable<string> assemblyNames
)
Public Sub New (
    assemblyNames As IEnumerable(Of String)
)
public:
DesignerReferencedAssemblies(
    IEnumerable<String^>^ assemblyNames
)
new :
        assemblyNames : IEnumerable<string> -> DesignerReferencedAssemblies

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerableString
List of assemblies.
See Also

Reference

DesignerReferencedAssemblies Class
DesignerReferencedAssemblies Overload
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies Constructor (String[])

DesignerReferencedAssemblies Constructor (String)
Initializes a new instance of the DesignerReferencedAssemblies class with specified assemblies's list.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies(
    params string[] assemblyNames
)
Public Sub New (
    ParamArray assemblyNames As String()
)
public:
DesignerReferencedAssemblies(
    ... array<String^>^ assemblyNames
)
new :
        assemblyNames : string[] -> DesignerReferencedAssemblies

Parameters

assemblyNames
Type: SystemString
List of assemblies.
See Also

Reference

DesignerReferencedAssemblies Class
DesignerReferencedAssemblies Overload
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies Constructor (IEnumerable(String), String, String, String[])

DesignerReferencedAssemblies Constructor (IEnumerableString, String, String, String)
Initializes a new instance of the DesignerReferencedAssemblies class with specified settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies(
    IEnumerable<string> searchPaths,
    string frameworkPath,
    string baseDirectory,
    params string[] assemblyNames
)
Public Sub New (
    searchPaths As IEnumerable(Of String),
    frameworkPath As String,
    baseDirectory As String,
    ParamArray assemblyNames As String()
)
public:
DesignerReferencedAssemblies(
    IEnumerable<String^>^ searchPaths,
    String^ frameworkPath,
    String^ baseDirectory,
    ... array<String^>^ assemblyNames
)
new :
        searchPaths : IEnumerable<string> *
        frameworkPath : string *
        baseDirectory : string *
        assemblyNames : string[] -> DesignerReferencedAssemblies

Parameters

searchPaths
Type: System.Collections.GenericIEnumerableString
Collection of assembly search paths.
frameworkPath
Type: SystemString
Path to the current framework.
baseDirectory
Type: SystemString
Path to the base project's directory.
assemblyNames
Type: SystemString
List of assemblies.
See Also

Reference

DesignerReferencedAssemblies Class
DesignerReferencedAssemblies Overload
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies Constructor (IEnumerable(String), String, String, IEnumerable(String), TargetNETFrameworkVersion)

DesignerReferencedAssemblies Constructor (IEnumerableString, String, String, IEnumerableString, TargetNETFrameworkVersion)
Initializes a new instance of the DesignerReferencedAssemblies class with specified parameters.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies(
    IEnumerable<string> searchPaths,
    string frameworkPath,
    string baseDirectory,
    IEnumerable<string> assemblyNames,
    TargetNETFrameworkVersion targetFrameworkVersion
)
Public Sub New (
    searchPaths As IEnumerable(Of String),
    frameworkPath As String,
    baseDirectory As String,
    assemblyNames As IEnumerable(Of String),
    targetFrameworkVersion As TargetNETFrameworkVersion
)
public:
DesignerReferencedAssemblies(
    IEnumerable<String^>^ searchPaths,
    String^ frameworkPath,
    String^ baseDirectory,
    IEnumerable<String^>^ assemblyNames,
    TargetNETFrameworkVersion targetFrameworkVersion
)
new :
        searchPaths : IEnumerable<string> *
        frameworkPath : string *
        baseDirectory : string *
        assemblyNames : IEnumerable<string> *
        targetFrameworkVersion : TargetNETFrameworkVersion -> DesignerReferencedAssemblies

Parameters

searchPaths
Type: System.Collections.GenericIEnumerableString
Collection of assembly search paths.
frameworkPath
Type: SystemString
Path to the current framework.
baseDirectory
Type: SystemString
Path to the base project's directory.
assemblyNames
Type: System.Collections.GenericIEnumerableString
List of assemblies.
targetFrameworkVersion
Type: Alternet.CommonTargetNETFrameworkVersion
Version of the .NET Framework to be used for locating Framework assemblies.
See Also

Reference

DesignerReferencedAssemblies Class
DesignerReferencedAssemblies Overload
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies Fields

DesignerReferencedAssemblies Fields

The DesignerReferencedAssemblies type exposes the following members.

Fields
Name | Description
DefaultForCSharp | Represents a collection of assemblies default for C# language project.
DefaultForTypeScript | Represents a collection of assemblies default for C# language project.
DefaultForVisualBasic | Represents a collection of assemblies default for Visual Basic language project.
Top
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.DefaultForCSharp Field

DesignerReferencedAssembliesDefaultForCSharp Field
Represents a collection of assemblies default for C# language project.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DesignerReferencedAssemblies DefaultForCSharp
Public Shared DefaultForCSharp As DesignerReferencedAssemblies
public:
static DesignerReferencedAssemblies^ DefaultForCSharp
static val mutable DefaultForCSharp: DesignerReferencedAssemblies

Field Value

Type: DesignerReferencedAssemblies
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.DefaultForTypeScript Field

DesignerReferencedAssembliesDefaultForTypeScript Field
Represents a collection of assemblies default for C# language project.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DesignerReferencedAssemblies DefaultForTypeScript
Public Shared DefaultForTypeScript As DesignerReferencedAssemblies
public:
static DesignerReferencedAssemblies^ DefaultForTypeScript
static val mutable DefaultForTypeScript: DesignerReferencedAssemblies

Field Value

Type: DesignerReferencedAssemblies
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.DefaultForVisualBasic Field

DesignerReferencedAssembliesDefaultForVisualBasic Field
Represents a collection of assemblies default for Visual Basic language project.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DesignerReferencedAssemblies DefaultForVisualBasic
Public Shared DefaultForVisualBasic As DesignerReferencedAssemblies
public:
static DesignerReferencedAssemblies^ DefaultForVisualBasic
static val mutable DefaultForVisualBasic: DesignerReferencedAssemblies

Field Value

Type: DesignerReferencedAssemblies
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies Methods

DesignerReferencedAssemblies Methods

The DesignerReferencedAssemblies type exposes the following members.

Methods
 | Name | Description
Public method | AddAssemblyName | Creates a new DesignerReferencedAssemblies instance with the list of assemblies updated to include specified assembly.
Public method | AddAssemblyNames | Creates a new DesignerReferencedAssemblies instance with the list of assemblies updated to include specified assemblies.
Public method | AddSearchPath | Creates a new DesignerReferencedAssemblies instance with the list of search paths updated to include specified search path.
Public method | AddSearchPaths | Creates a new DesignerReferencedAssemblies instance with the list of search paths updated to include specified search paths.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithAssemblyNames | Creates a new DesignerReferencedAssemblies instance with the list of assemblies updated to include only specified assemblies.
Public method | WithSearchPaths | Creates a new DesignerReferencedAssemblies instance with the list of search paths updated to include only specified search paths.
Top
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.AddAssemblyName Method

DesignerReferencedAssembliesAddAssemblyName Method
Creates a new DesignerReferencedAssemblies instance with the list of assemblies updated to include specified assembly.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies AddAssemblyName(
    string assemblyName
)
Public Function AddAssemblyName (
    assemblyName As String
) As DesignerReferencedAssemblies
public:
DesignerReferencedAssemblies^ AddAssemblyName(
    String^ assemblyName
)
member AddAssemblyName :
        assemblyName : string -> DesignerReferencedAssemblies

Parameters

assemblyName
Type: SystemString
Additional assembly.

Return Value

Type: DesignerReferencedAssemblies
Updated DesignerReferencedAssemblies.
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.AddAssemblyNames Method

DesignerReferencedAssembliesAddAssemblyNames Method
Creates a new DesignerReferencedAssemblies instance with the list of assemblies updated to include specified assemblies.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies AddAssemblyNames(
    IEnumerable<string> assemblyNames
)
Public Function AddAssemblyNames (
    assemblyNames As IEnumerable(Of String)
) As DesignerReferencedAssemblies
public:
DesignerReferencedAssemblies^ AddAssemblyNames(
    IEnumerable<String^>^ assemblyNames
)
member AddAssemblyNames :
        assemblyNames : IEnumerable<string> -> DesignerReferencedAssemblies

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerableString
List of additional assemblies.

Return Value

Type: DesignerReferencedAssemblies
Updated DesignerReferencedAssemblies.
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.AddSearchPath Method

DesignerReferencedAssembliesAddSearchPath Method
Creates a new DesignerReferencedAssemblies instance with the list of search paths updated to include specified search path.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies AddSearchPath(
    string searchPath
)
Public Function AddSearchPath (
    searchPath As String
) As DesignerReferencedAssemblies
public:
DesignerReferencedAssemblies^ AddSearchPath(
    String^ searchPath
)
member AddSearchPath :
        searchPath : string -> DesignerReferencedAssemblies

Parameters

searchPath
Type: SystemString
Additional search path.

Return Value

Type: DesignerReferencedAssemblies
Updated DesignerReferencedAssemblies.
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.AddSearchPaths Method

DesignerReferencedAssembliesAddSearchPaths Method
Creates a new DesignerReferencedAssemblies instance with the list of search paths updated to include specified search paths.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies AddSearchPaths(
    IEnumerable<string> searchPaths
)
Public Function AddSearchPaths (
    searchPaths As IEnumerable(Of String)
) As DesignerReferencedAssemblies
public:
DesignerReferencedAssemblies^ AddSearchPaths(
    IEnumerable<String^>^ searchPaths
)
member AddSearchPaths :
        searchPaths : IEnumerable<string> -> DesignerReferencedAssemblies

Parameters

searchPaths
Type: System.Collections.GenericIEnumerableString
List of additional search paths.

Return Value

Type: DesignerReferencedAssemblies
Updated DesignerReferencedAssemblies.
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.WithAssemblyNames Method

DesignerReferencedAssembliesWithAssemblyNames Method
Creates a new DesignerReferencedAssemblies instance with the list of assemblies updated to include only specified assemblies.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies WithAssemblyNames(
    IEnumerable<string> assemblyNames
)
Public Function WithAssemblyNames (
    assemblyNames As IEnumerable(Of String)
) As DesignerReferencedAssemblies
public:
DesignerReferencedAssemblies^ WithAssemblyNames(
    IEnumerable<String^>^ assemblyNames
)
member WithAssemblyNames :
        assemblyNames : IEnumerable<string> -> DesignerReferencedAssemblies

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerableString
List of new assemblies.

Return Value

Type: DesignerReferencedAssemblies
Updated DesignerReferencedAssemblies.
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.WithSearchPaths Method

DesignerReferencedAssembliesWithSearchPaths Method
Creates a new DesignerReferencedAssemblies instance with the list of search paths updated to include only specified search paths.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies WithSearchPaths(
    IEnumerable<string> searchPaths
)
Public Function WithSearchPaths (
    searchPaths As IEnumerable(Of String)
) As DesignerReferencedAssemblies
public:
DesignerReferencedAssemblies^ WithSearchPaths(
    IEnumerable<String^>^ searchPaths
)
member WithSearchPaths :
        searchPaths : IEnumerable<string> -> DesignerReferencedAssemblies

Parameters

searchPaths
Type: System.Collections.GenericIEnumerableString
List of new search paths.

Return Value

Type: DesignerReferencedAssemblies
Updated DesignerReferencedAssemblies.
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies Properties

DesignerReferencedAssemblies Properties

The DesignerReferencedAssemblies type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyNames | Represents a list of assemblies.
Public property | BaseDirectory | Represents path to the base project's directory.
Public property | FrameworkPath | Represents path to the current framework.
Public property | SearchPaths | Represents a collection of assembly search paths.
Public property | TargetFrameworkVersion | Gets or sets version of the .NET Framework to be used for locating Framework assemblies.
Top
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.AssemblyNames Property

DesignerReferencedAssembliesAssemblyNames Property
Represents a list of assemblies.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> AssemblyNames { get; }
Public ReadOnly Property AssemblyNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ AssemblyNames {
    IEnumerable<String^>^ get ();
}
member AssemblyNames : IEnumerable<string> with get

Property Value

Type: IEnumerableString
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.BaseDirectory Property

DesignerReferencedAssembliesBaseDirectory Property
Represents path to the base project's directory.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BaseDirectory { get; }
Public ReadOnly Property BaseDirectory As String
    Get
public:
property String^ BaseDirectory {
    String^ get ();
}
member BaseDirectory : string with get

Property Value

Type: String
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.FrameworkPath Property

DesignerReferencedAssembliesFrameworkPath Property
Represents path to the current framework.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FrameworkPath { get; }
Public ReadOnly Property FrameworkPath As String
    Get
public:
property String^ FrameworkPath {
    String^ get ();
}
member FrameworkPath : string with get

Property Value

Type: String
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.SearchPaths Property

DesignerReferencedAssembliesSearchPaths Property
Represents a collection of assembly search paths.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> SearchPaths { get; }
Public ReadOnly Property SearchPaths As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ SearchPaths {
    IEnumerable<String^>^ get ();
}
member SearchPaths : IEnumerable<string> with get

Property Value

Type: IEnumerableString
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerReferencedAssemblies.TargetFrameworkVersion Property

DesignerReferencedAssembliesTargetFrameworkVersion Property
Gets or sets version of the .NET Framework to be used for locating Framework assemblies.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetNETFrameworkVersion TargetFrameworkVersion { get; set; }
Public Property TargetFrameworkVersion As TargetNETFrameworkVersion
    Get
    Set
public:
property TargetNETFrameworkVersion TargetFrameworkVersion {
    TargetNETFrameworkVersion get ();
    void set (TargetNETFrameworkVersion value);
}
member TargetFrameworkVersion : TargetNETFrameworkVersion with get, set

Property Value

Type: TargetNETFrameworkVersion
See Also

Reference

DesignerReferencedAssemblies Class
Alternet.FormDesigner.WinForms Namespace


DesignerSerializationService Class

DesignerSerializationService Class
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsDesignerSerializationService

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DesignerSerializationService : IDesignerSerializationService
Public NotInheritable Class DesignerSerializationService
    Implements IDesignerSerializationService
public ref class DesignerSerializationService sealed : IDesignerSerializationService
[<SealedAttribute>]
type DesignerSerializationService =
    class
        interface IDesignerSerializationService
    end

The DesignerSerializationService type exposes the following members.

Constructors
 | Name | Description
Public method | DesignerSerializationService | Initializes a new instance of the DesignerSerializationService class
Top
Methods
 | Name | Description
Public method | Deserialize |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Serialize |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


DesignerSerializationService Constructor

DesignerSerializationService Constructor
Initializes a new instance of the DesignerSerializationService class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerSerializationService(
    IServiceProvider serviceProvider
)
Public Sub New (
    serviceProvider As IServiceProvider
)
public:
DesignerSerializationService(
    IServiceProvider^ serviceProvider
)
new :
        serviceProvider : IServiceProvider -> DesignerSerializationService

Parameters

serviceProvider
Type: SystemIServiceProvider
See Also

Reference

DesignerSerializationService Class
Alternet.FormDesigner.WinForms Namespace


DesignerSerializationService Methods

DesignerSerializationService Methods

The DesignerSerializationService type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Serialize |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DesignerSerializationService Class
Alternet.FormDesigner.WinForms Namespace


DesignerSerializationService.Deserialize Method

DesignerSerializationServiceDeserialize Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection Deserialize(
    Object serializationData
)
Public Function Deserialize (
    serializationData As Object
) As ICollection
public:
virtual ICollection^ Deserialize(
    Object^ serializationData
) sealed
abstract Deserialize :
        serializationData : Object -> ICollection
override Deserialize :
        serializationData : Object -> ICollection

Parameters

serializationData
Type: SystemObject

Return Value

Type: ICollection

Implements

IDesignerSerializationServiceDeserialize(Object)
See Also

Reference

DesignerSerializationService Class
Alternet.FormDesigner.WinForms Namespace


DesignerSerializationService.Serialize Method

DesignerSerializationServiceSerialize Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Serialize(
    ICollection objects
)
Public Function Serialize (
    objects As ICollection
) As Object
public:
virtual Object^ Serialize(
    ICollection^ objects
) sealed
abstract Serialize :
        objects : ICollection -> Object
override Serialize :
        objects : ICollection -> Object

Parameters

objects
Type: System.CollectionsICollection

Return Value

Type: Object

Implements

IDesignerSerializationServiceSerialize(ICollection)
See Also

Reference

DesignerSerializationService Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource Class

EditorFormDesignerDataSource Class
Provides extended properties and methods for a Form Designer control's data source.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsEditorFormDesignerDataSource

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditorFormDesignerDataSource : IFormDesignerDataSource
Public Class EditorFormDesignerDataSource
    Implements IFormDesignerDataSource
public ref class EditorFormDesignerDataSource : IFormDesignerDataSource
type EditorFormDesignerDataSource =
    class
        interface IFormDesignerDataSource
    end

The EditorFormDesignerDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | EditorFormDesignerDataSource | Initializes a new instance of the EditorFormDesignerDataSource class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResourceFileName | Finds resource file name.
Public method | GetResourceTextSource | Finds text source containing resource data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertTextIntoUserCode | Inserts specified text fragments into the user code.
Public method | OpenDesignerStream | Opens designer stream with specified access mode.
Public method | OpenResourceStream | Opens resource stream with specified access mode.
Public method | OpenUserCodeStreamForReading | Opens user code stream with default access mode.
Public method | ReplaceTextInDesignerCode | Replaces specified text fragments within the user code.
Public method | Save | Serializes designer content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyResources | Gets the list of form designer's assembly resources.
Public property | DefaultResourceFileName | Gets name of the resource file.
Public property | DefaultResourceTextSource | Gets IFormDesignerTextSource corresponding to the resource code.
Public property | DesignedClassFullName | Gets the fully qualified name of designed class.
Public property | DesignedComponentAssembly |
Public property | DesignerFileName | Gets name of the file with designer generated code.
Public property | DesignerTextSource | Gets IFormDesignerTextSource corresponding to the designer generated code.
Public property | IsModified | Represents a value indicating whether designer content has been modified since last save.
Public property | ResourceFileName | Obsolete. Gets name of the resource file.
Public property | ResourceFileNames |
Public property | ResourceTextSource | Obsolete. Gets IFormDesignerTextSource corresponding to the resource code.
Public property | ResourceTextSources |
Public property | UserCodeFileName | Gets name of the file with user code.
Public property | UserCodeTextSource | Gets IFormDesignerTextSource corresponding to the user code.
Top
Events
 | Name | Description
Public event | ResourceCultureAdded |
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource Constructor

EditorFormDesignerDataSource Constructor
Initializes a new instance of the EditorFormDesignerDataSource class with specified settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditorFormDesignerDataSource(
    string userCodeFileName,
    Func<string, IFormDesignerTextSource> openTextSourceFunc,
    IEnumerable<DesignerAssemblyResources> assemblyResources = null
)
Public Sub New (
    userCodeFileName As String,
    openTextSourceFunc As Func(Of String, IFormDesignerTextSource),
    Optional assemblyResources As IEnumerable(Of DesignerAssemblyResources) = Nothing
)
public:
EditorFormDesignerDataSource(
    String^ userCodeFileName,
    Func<String^, IFormDesignerTextSource^>^ openTextSourceFunc,
    IEnumerable<DesignerAssemblyResources^>^ assemblyResources = nullptr
)
new :
        userCodeFileName : string *
        openTextSourceFunc : Func<string, IFormDesignerTextSource> *
        ?assemblyResources : IEnumerable<DesignerAssemblyResources>
(* Defaults:
        let _assemblyResources = defaultArg assemblyResources null
*)
-> EditorFormDesignerDataSource

Parameters

userCodeFileName
Type: SystemString
Name of the file with user code.
openTextSourceFunc
Type: SystemFuncString, IFormDesignerTextSource
Function responsible to open text source.
assemblyResources (Optional)
Type: System.Collections.GenericIEnumerableDesignerAssemblyResources
The list of assembly resources.
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource Methods

EditorFormDesignerDataSource Methods

The EditorFormDesignerDataSource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResourceFileName | Finds resource file name.
Public method | GetResourceTextSource | Finds text source containing resource data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertTextIntoUserCode | Inserts specified text fragments into the user code.
Public method | OpenDesignerStream | Opens designer stream with specified access mode.
Public method | OpenResourceStream | Opens resource stream with specified access mode.
Public method | OpenUserCodeStreamForReading | Opens user code stream with default access mode.
Public method | ReplaceTextInDesignerCode | Replaces specified text fragments within the user code.
Public method | Save | Serializes designer content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.GetResourceFileName Method

EditorFormDesignerDataSourceGetResourceFileName Method
Finds resource file name.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetResourceFileName(
    CultureInfo cultureInfo
)
Public Function GetResourceFileName (
    cultureInfo As CultureInfo
) As String
public:
virtual String^ GetResourceFileName(
    CultureInfo^ cultureInfo
) sealed
abstract GetResourceFileName :
        cultureInfo : CultureInfo -> string
override GetResourceFileName :
        cultureInfo : CultureInfo -> string

Parameters

cultureInfo
Type: System.GlobalizationCultureInfo
Specifies information about a specific culture.

Return Value

Type: String
Name of the resource file containing culture-specific resource data.

Implements

IFormDesignerDataSourceGetResourceFileName(CultureInfo)
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.GetResourceTextSource Method

EditorFormDesignerDataSourceGetResourceTextSource Method
Finds text source containing resource data.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerTextSource GetResourceTextSource(
    CultureInfo cultureInfo
)
Public Function GetResourceTextSource (
    cultureInfo As CultureInfo
) As IFormDesignerTextSource
public:
IFormDesignerTextSource^ GetResourceTextSource(
    CultureInfo^ cultureInfo
)
member GetResourceTextSource :
        cultureInfo : CultureInfo -> IFormDesignerTextSource

Parameters

cultureInfo
Type: System.GlobalizationCultureInfo
Specifies information about a specific culture.

Return Value

Type: IFormDesignerTextSource
IFormDesignerTextSource containing culture-specific resource data.
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.InsertTextIntoUserCode Method

EditorFormDesignerDataSourceInsertTextIntoUserCode Method
Inserts specified text fragments into the user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertTextIntoUserCode(
    FormDesignerTextSourceOperationsTextInsertionOperation[] operations
)
Public Sub InsertTextIntoUserCode (
    operations As FormDesignerTextSourceOperationsTextInsertionOperation()
)
public:
virtual void InsertTextIntoUserCode(
    array<FormDesignerTextSourceOperationsTextInsertionOperation^>^ operations
) sealed
abstract InsertTextIntoUserCode :
        operations : FormDesignerTextSourceOperationsTextInsertionOperation[] -> unit
override InsertTextIntoUserCode :
        operations : FormDesignerTextSourceOperationsTextInsertionOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextInsertionOperation
Contains data to insert.

Implements

IFormDesignerDataSourceInsertTextIntoUserCode(FormDesignerTextSourceOperationsTextInsertionOperation)
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.OpenDesignerStream Method

EditorFormDesignerDataSourceOpenDesignerStream Method
Opens designer stream with specified access mode.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Stream OpenDesignerStream(
    StreamAccessMode mode
)
Public Function OpenDesignerStream (
    mode As StreamAccessMode
) As Stream
public:
virtual Stream^ OpenDesignerStream(
    StreamAccessMode mode
) sealed
abstract OpenDesignerStream :
        mode : StreamAccessMode -> Stream
override OpenDesignerStream :
        mode : StreamAccessMode -> Stream

Parameters

mode
Type: Alternet.FormDesigner.WinFormsStreamAccessMode
Specifies operation can be performed on the stream.

Return Value

Type: Stream
Designer stream.

Implements

IFormDesignerDataSourceOpenDesignerStream(StreamAccessMode)
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.OpenResourceStream Method

EditorFormDesignerDataSourceOpenResourceStream Method
Opens resource stream with specified access mode.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Stream OpenResourceStream(
    StreamAccessMode mode,
    CultureInfo cultureInfo
)
Public Function OpenResourceStream (
    mode As StreamAccessMode,
    cultureInfo As CultureInfo
) As Stream
public:
virtual Stream^ OpenResourceStream(
    StreamAccessMode mode,
    CultureInfo^ cultureInfo
) sealed
abstract OpenResourceStream :
        mode : StreamAccessMode *
        cultureInfo : CultureInfo -> Stream
override OpenResourceStream :
        mode : StreamAccessMode *
        cultureInfo : CultureInfo -> Stream

Parameters

mode
Type: Alternet.FormDesigner.WinFormsStreamAccessMode
Specifies operation can be performed on the stream.
cultureInfo
Type: System.GlobalizationCultureInfo
Specifies information about a specific culture.

Return Value

Type: Stream
Resource stream.

Implements

IFormDesignerDataSourceOpenResourceStream(StreamAccessMode, CultureInfo)
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.OpenUserCodeStreamForReading Method

EditorFormDesignerDataSourceOpenUserCodeStreamForReading Method
Opens user code stream with default access mode.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Stream OpenUserCodeStreamForReading()
Public Function OpenUserCodeStreamForReading As Stream
public:
virtual Stream^ OpenUserCodeStreamForReading() sealed
abstract OpenUserCodeStreamForReading : unit -> Stream
override OpenUserCodeStreamForReading : unit -> Stream

Return Value

Type: Stream
User code stream.

Implements

IFormDesignerDataSourceOpenUserCodeStreamForReading
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.ReplaceTextInDesignerCode Method

EditorFormDesignerDataSourceReplaceTextInDesignerCode Method
Replaces specified text fragments within the user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReplaceTextInDesignerCode(
    FormDesignerTextSourceOperationsTextReplacementOperation[] operations
)
Public Sub ReplaceTextInDesignerCode (
    operations As FormDesignerTextSourceOperationsTextReplacementOperation()
)
public:
virtual void ReplaceTextInDesignerCode(
    array<FormDesignerTextSourceOperationsTextReplacementOperation^>^ operations
) sealed
abstract ReplaceTextInDesignerCode :
        operations : FormDesignerTextSourceOperationsTextReplacementOperation[] -> unit
override ReplaceTextInDesignerCode :
        operations : FormDesignerTextSourceOperationsTextReplacementOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextReplacementOperation
Contains data to replace.

Implements

IFormDesignerDataSourceReplaceTextInDesignerCode(FormDesignerTextSourceOperationsTextReplacementOperation)
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.Save Method

EditorFormDesignerDataSourceSave Method
Serializes designer content.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource Properties

EditorFormDesignerDataSource Properties

The EditorFormDesignerDataSource type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyResources | Gets the list of form designer's assembly resources.
Public property | DefaultResourceFileName | Gets name of the resource file.
Public property | DefaultResourceTextSource | Gets IFormDesignerTextSource corresponding to the resource code.
Public property | DesignedClassFullName | Gets the fully qualified name of designed class.
Public property | DesignedComponentAssembly |
Public property | DesignerFileName | Gets name of the file with designer generated code.
Public property | DesignerTextSource | Gets IFormDesignerTextSource corresponding to the designer generated code.
Public property | IsModified | Represents a value indicating whether designer content has been modified since last save.
Public property | ResourceFileName | Obsolete. Gets name of the resource file.
Public property | ResourceFileNames |
Public property | ResourceTextSource | Obsolete. Gets IFormDesignerTextSource corresponding to the resource code.
Public property | ResourceTextSources |
Public property | UserCodeFileName | Gets name of the file with user code.
Public property | UserCodeTextSource | Gets IFormDesignerTextSource corresponding to the user code.
Top
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.AssemblyResources Property

EditorFormDesignerDataSourceAssemblyResources Property
Gets the list of form designer's assembly resources.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DesignerAssemblyResources> AssemblyResources { get; }
Public ReadOnly Property AssemblyResources As IEnumerable(Of DesignerAssemblyResources)
    Get
public:
virtual property IEnumerable<DesignerAssemblyResources^>^ AssemblyResources {
    IEnumerable<DesignerAssemblyResources^>^ get () sealed;
}
abstract AssemblyResources : IEnumerable<DesignerAssemblyResources> with get
override AssemblyResources : IEnumerable<DesignerAssemblyResources> with get

Property Value

Type: IEnumerableDesignerAssemblyResources

Implements

IFormDesignerDataSourceAssemblyResources
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.DefaultResourceFileName Property

EditorFormDesignerDataSourceDefaultResourceFileName Property
Gets name of the resource file.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DefaultResourceFileName { get; }
Public ReadOnly Property DefaultResourceFileName As String
    Get
public:
property String^ DefaultResourceFileName {
    String^ get ();
}
member DefaultResourceFileName : string with get

Property Value

Type: String
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.DefaultResourceTextSource Property

EditorFormDesignerDataSourceDefaultResourceTextSource Property
Gets IFormDesignerTextSource corresponding to the resource code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerTextSource DefaultResourceTextSource { get; }
Public ReadOnly Property DefaultResourceTextSource As IFormDesignerTextSource
    Get
public:
property IFormDesignerTextSource^ DefaultResourceTextSource {
    IFormDesignerTextSource^ get ();
}
member DefaultResourceTextSource : IFormDesignerTextSource with get

Property Value

Type: IFormDesignerTextSource
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.DesignedClassFullName Property

EditorFormDesignerDataSourceDesignedClassFullName Property
Gets the fully qualified name of designed class.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DesignedClassFullName { get; }
Public ReadOnly Property DesignedClassFullName As String
    Get
public:
virtual property String^ DesignedClassFullName {
    String^ get () sealed;
}
abstract DesignedClassFullName : string with get
override DesignedClassFullName : string with get

Property Value

Type: String

Implements

IFormDesignerDataSourceDesignedClassFullName
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.DesignedComponentAssembly Property

EditorFormDesignerDataSourceDesignedComponentAssembly Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignedComponentAssemblyFileProvider DesignedComponentAssembly { get; }
Public ReadOnly Property DesignedComponentAssembly As DesignedComponentAssemblyFileProvider
    Get
public:
property DesignedComponentAssemblyFileProvider^ DesignedComponentAssembly {
    DesignedComponentAssemblyFileProvider^ get ();
}
member DesignedComponentAssembly : DesignedComponentAssemblyFileProvider with get

Property Value

Type: DesignedComponentAssemblyFileProvider
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.DesignerFileName Property

EditorFormDesignerDataSourceDesignerFileName Property
Gets name of the file with designer generated code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DesignerFileName { get; }
Public ReadOnly Property DesignerFileName As String
    Get
public:
virtual property String^ DesignerFileName {
    String^ get () sealed;
}
abstract DesignerFileName : string with get
override DesignerFileName : string with get

Property Value

Type: String

Implements

IFormDesignerDataSourceDesignerFileName
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.DesignerTextSource Property

EditorFormDesignerDataSourceDesignerTextSource Property
Gets IFormDesignerTextSource corresponding to the designer generated code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerTextSource DesignerTextSource { get; }
Public ReadOnly Property DesignerTextSource As IFormDesignerTextSource
    Get
public:
property IFormDesignerTextSource^ DesignerTextSource {
    IFormDesignerTextSource^ get ();
}
member DesignerTextSource : IFormDesignerTextSource with get

Property Value

Type: IFormDesignerTextSource
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.IsModified Property

EditorFormDesignerDataSourceIsModified Property
Represents a value indicating whether designer content has been modified since last save.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModified { get; }
Public ReadOnly Property IsModified As Boolean
    Get
public:
virtual property bool IsModified {
    bool get () sealed;
}
abstract IsModified : bool with get
override IsModified : bool with get

Property Value

Type: Boolean

Implements

IFormDesignerDataSourceIsModified
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.ResourceFileName Property

EditorFormDesignerDataSourceResourceFileName Property

Note: This API is now obsolete.

Gets name of the resource file.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use DefaultResourceFileName instead.")]
public string ResourceFileName { get; }
<ObsoleteAttribute("Use DefaultResourceFileName instead.")>
Public ReadOnly Property ResourceFileName As String
    Get
public:
[ObsoleteAttribute(L"Use DefaultResourceFileName instead.")]
property String^ ResourceFileName {
    String^ get ();
}
[<ObsoleteAttribute("Use DefaultResourceFileName instead.")>]
member ResourceFileName : string with get

Property Value

Type: String
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.ResourceFileNames Property

EditorFormDesignerDataSourceResourceFileNames Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ResourceFileNames { get; }
Public ReadOnly Property ResourceFileNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ ResourceFileNames {
    IEnumerable<String^>^ get ();
}
member ResourceFileNames : IEnumerable<string> with get

Property Value

Type: IEnumerableString
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.ResourceTextSource Property

EditorFormDesignerDataSourceResourceTextSource Property

Note: This API is now obsolete.

Gets IFormDesignerTextSource corresponding to the resource code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use DefaultResourceTextSource instead.")]
public IFormDesignerTextSource ResourceTextSource { get; }
<ObsoleteAttribute("Use DefaultResourceTextSource instead.")>
Public ReadOnly Property ResourceTextSource As IFormDesignerTextSource
    Get
public:
[ObsoleteAttribute(L"Use DefaultResourceTextSource instead.")]
property IFormDesignerTextSource^ ResourceTextSource {
    IFormDesignerTextSource^ get ();
}
[<ObsoleteAttribute("Use DefaultResourceTextSource instead.")>]
member ResourceTextSource : IFormDesignerTextSource with get

Property Value

Type: IFormDesignerTextSource
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.ResourceTextSources Property

EditorFormDesignerDataSourceResourceTextSources Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Tuple<CultureInfo, IFormDesignerTextSource>> ResourceTextSources { get; }
Public ReadOnly Property ResourceTextSources As IEnumerable(Of Tuple(Of CultureInfo, IFormDesignerTextSource))
    Get
public:
property IEnumerable<Tuple<CultureInfo^, IFormDesignerTextSource^>^>^ ResourceTextSources {
    IEnumerable<Tuple<CultureInfo^, IFormDesignerTextSource^>^>^ get ();
}
member ResourceTextSources : IEnumerable<Tuple<CultureInfo, IFormDesignerTextSource>> with get

Property Value

Type: IEnumerableTupleCultureInfo, IFormDesignerTextSource
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.UserCodeFileName Property

EditorFormDesignerDataSourceUserCodeFileName Property
Gets name of the file with user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserCodeFileName { get; }
Public ReadOnly Property UserCodeFileName As String
    Get
public:
virtual property String^ UserCodeFileName {
    String^ get () sealed;
}
abstract UserCodeFileName : string with get
override UserCodeFileName : string with get

Property Value

Type: String

Implements

IFormDesignerDataSourceUserCodeFileName
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.UserCodeTextSource Property

EditorFormDesignerDataSourceUserCodeTextSource Property
Gets IFormDesignerTextSource corresponding to the user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerTextSource UserCodeTextSource { get; }
Public ReadOnly Property UserCodeTextSource As IFormDesignerTextSource
    Get
public:
property IFormDesignerTextSource^ UserCodeTextSource {
    IFormDesignerTextSource^ get ();
}
member UserCodeTextSource : IFormDesignerTextSource with get

Property Value

Type: IFormDesignerTextSource
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource Events

EditorFormDesignerDataSource Events

The EditorFormDesignerDataSource type exposes the following members.

Events
 | Name | Description
Public event | ResourceCultureAdded |
Top
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EditorFormDesignerDataSource.ResourceCultureAdded Event

EditorFormDesignerDataSourceResourceCultureAdded Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ResourceCultureAddedEventArgs> ResourceCultureAdded
Public Event ResourceCultureAdded As EventHandler(Of ResourceCultureAddedEventArgs)
public:
virtual  event EventHandler<ResourceCultureAddedEventArgs^>^ ResourceCultureAdded {
    void add (EventHandler<ResourceCultureAddedEventArgs^>^ value);
    void remove (EventHandler<ResourceCultureAddedEventArgs^>^ value);
}
abstract ResourceCultureAdded : IEvent<EventHandler<ResourceCultureAddedEventArgs>,
    ResourceCultureAddedEventArgs>
override ResourceCultureAdded : IEvent<EventHandler<ResourceCultureAddedEventArgs>,
    ResourceCultureAddedEventArgs>

Value

Type: SystemEventHandlerResourceCultureAddedEventArgs

Implements

IFormDesignerDataSourceResourceCultureAdded
See Also

Reference

EditorFormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase Class

EventBindingServiceBase Class
This class provides a default implementation of the event binding service. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsEventBindingServiceBase

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class EventBindingServiceBase : IEventBindingServiceExtended,
    IEventBindingService
Public MustInherit Class EventBindingServiceBase
    Implements IEventBindingServiceExtended, IEventBindingService
public ref class EventBindingServiceBase abstract : IEventBindingServiceExtended,
    IEventBindingService
[<AbstractClassAttribute>]
type EventBindingServiceBase =
    class
        interface IEventBindingServiceExtended
        interface IEventBindingService
    end

The EventBindingServiceBase type exposes the following members.

Constructors
 | Name | Description
Public method | EventBindingServiceBase | Initializes a new instance of the EventBindingServiceBase class with specified settings.
Top
Methods
 | Name | Description
Public method | CreateUniqueMethodName | This creates a name for an event handling method for the given component and event. The name that is created is guaranteed to be unique in the user's source code.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCompatibleMethods | Retrieves a collection of strings. Each string is the name of a method in user code that has a signature that is compatible with the given event.
Public method | GetEvent | For properties that are representing events, this will return the event that the property represents.
Public method | GetEventProperties | Converts a set of events to a set of properties.
Public method | GetEventProperty | Converts a single event to a property.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowCode | Shows the user code. This method does not show any particular code; generally it shows the last code the user typed. This returns true if it was possible to show the code, or false if not. We are never showing code since we do not generate handler methods.
Public method | ShowCode(Int32) | Shows the user code at the given line number. Line numbers are one-based. This returns true if it was possible to show the code, or false if not. We are never showing code since we do not generate handler methods.
Public method | ShowCode(IComponent, EventDescriptor) | Displays the user code for the given event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DesignedClassName | Represents name of the class being designed.
Public property | UserFileName | Represents file name with the form designer code.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase Constructor

EventBindingServiceBase Constructor
Initializes a new instance of the EventBindingServiceBase class with specified settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventBindingServiceBase(
    IServiceProvider provider,
    InsertTextIntoCodeDelegate insertTextIntoCodeFunc,
    Func<Stream> openStreamForReadingFunc,
    string userFileName,
    string designedClassName,
    Func<NavigateToUserMethodRequestedEventArgs, bool> showUserCodeFunc
)
Public Sub New (
    provider As IServiceProvider,
    insertTextIntoCodeFunc As InsertTextIntoCodeDelegate,
    openStreamForReadingFunc As Func(Of Stream),
    userFileName As String,
    designedClassName As String,
    showUserCodeFunc As Func(Of NavigateToUserMethodRequestedEventArgs, Boolean)
)
public:
EventBindingServiceBase(
    IServiceProvider^ provider,
    InsertTextIntoCodeDelegate^ insertTextIntoCodeFunc,
    Func<Stream^>^ openStreamForReadingFunc,
    String^ userFileName,
    String^ designedClassName,
    Func<NavigateToUserMethodRequestedEventArgs^, bool>^ showUserCodeFunc
)
new :
        provider : IServiceProvider *
        insertTextIntoCodeFunc : InsertTextIntoCodeDelegate *
        openStreamForReadingFunc : Func<Stream> *
        userFileName : string *
        designedClassName : string *
        showUserCodeFunc : Func<NavigateToUserMethodRequestedEventArgs, bool> -> EventBindingServiceBase

Parameters

provider
Type: SystemIServiceProvider
IServiceProvider for this new instance.
insertTextIntoCodeFunc
Type: Alternet.FormDesigner.WinFormsInsertTextIntoCodeDelegate
Method used to insert text into the code.
openStreamForReadingFunc
Type: SystemFuncStream
Method used to open stream in read mode.
userFileName
Type: SystemString
File name with the Form designer code.
designedClassName
Type: SystemString
Name of the class being designed.
showUserCodeFunc
Type: SystemFuncNavigateToUserMethodRequestedEventArgs, Boolean
Method used to show user code.
Remarks
You must provide a service provider to the binding service. We give it our host.
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase Methods

EventBindingServiceBase Methods

The EventBindingServiceBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateUniqueMethodName | This creates a name for an event handling method for the given component and event. The name that is created is guaranteed to be unique in the user's source code.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCompatibleMethods | Retrieves a collection of strings. Each string is the name of a method in user code that has a signature that is compatible with the given event.
Public method | GetEvent | For properties that are representing events, this will return the event that the property represents.
Public method | GetEventProperties | Converts a set of events to a set of properties.
Public method | GetEventProperty | Converts a single event to a property.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowCode | Shows the user code. This method does not show any particular code; generally it shows the last code the user typed. This returns true if it was possible to show the code, or false if not. We are never showing code since we do not generate handler methods.
Public method | ShowCode(Int32) | Shows the user code at the given line number. Line numbers are one-based. This returns true if it was possible to show the code, or false if not. We are never showing code since we do not generate handler methods.
Public method | ShowCode(IComponent, EventDescriptor) | Displays the user code for the given event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.CreateUniqueMethodName Method

EventBindingServiceBaseCreateUniqueMethodName Method
This creates a name for an event handling method for the given component and event. The name that is created is guaranteed to be unique in the user's source code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CreateUniqueMethodName(
    IComponent component,
    EventDescriptor e
)
Public Function CreateUniqueMethodName (
    component As IComponent,
    e As EventDescriptor
) As String
public:
virtual String^ CreateUniqueMethodName(
    IComponent^ component,
    EventDescriptor^ e
) sealed
abstract CreateUniqueMethodName :
        component : IComponent *
        e : EventDescriptor -> string
override CreateUniqueMethodName :
        component : IComponent *
        e : EventDescriptor -> string

Parameters

component
Type: System.ComponentModelIComponent
IComponent owns this method.
e
Type: System.ComponentModelEventDescriptor
Information about method.

Return Value

Type: String
Unique method name for specified component.

Implements

IEventBindingServiceCreateUniqueMethodName(IComponent, EventDescriptor)
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.GetCompatibleMethods Method

EventBindingServiceBaseGetCompatibleMethods Method
Retrieves a collection of strings. Each string is the name of a method in user code that has a signature that is compatible with the given event.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract ICollection GetCompatibleMethods(
    EventDescriptor e
)
Public MustOverride Function GetCompatibleMethods (
    e As EventDescriptor
) As ICollection
public:
virtual ICollection^ GetCompatibleMethods(
    EventDescriptor^ e
) abstract
abstract GetCompatibleMethods :
        e : EventDescriptor -> ICollection

Parameters

e
Type: System.ComponentModelEventDescriptor
Condition for methods.

Return Value

Type: ICollection
List of methods suitable specified condition.

Implements

IEventBindingServiceGetCompatibleMethods(EventDescriptor)
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.GetEvent Method

EventBindingServiceBaseGetEvent Method
For properties that are representing events, this will return the event that the property represents.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventDescriptor GetEvent(
    PropertyDescriptor property
)
Public Function GetEvent (
    property As PropertyDescriptor
) As EventDescriptor
public:
virtual EventDescriptor^ GetEvent(
    PropertyDescriptor^ property
) sealed
abstract GetEvent :
        property : PropertyDescriptor -> EventDescriptor
override GetEvent :
        property : PropertyDescriptor -> EventDescriptor

Parameters

property
Type: System.ComponentModelPropertyDescriptor
Information about property.

Return Value

Type: EventDescriptor
EventDescriptor if succeed; otherwise null.

Implements

IEventBindingServiceGetEvent(PropertyDescriptor)
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.GetEventProperties Method

EventBindingServiceBaseGetEventProperties Method
Converts a set of events to a set of properties.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyDescriptorCollection GetEventProperties(
    EventDescriptorCollection events
)
Public Function GetEventProperties (
    events As EventDescriptorCollection
) As PropertyDescriptorCollection
public:
virtual PropertyDescriptorCollection^ GetEventProperties(
    EventDescriptorCollection^ events
) sealed
abstract GetEventProperties :
        events : EventDescriptorCollection -> PropertyDescriptorCollection
override GetEventProperties :
        events : EventDescriptorCollection -> PropertyDescriptorCollection

Parameters

events
Type: System.ComponentModelEventDescriptorCollection
List of events to convert.

Return Value

Type: PropertyDescriptorCollection
List of properties.

Implements

IEventBindingServiceGetEventProperties(EventDescriptorCollection)
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.GetEventProperty Method

EventBindingServiceBaseGetEventProperty Method
Converts a single event to a property.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyDescriptor GetEventProperty(
    EventDescriptor e
)
Public Function GetEventProperty (
    e As EventDescriptor
) As PropertyDescriptor
public:
virtual PropertyDescriptor^ GetEventProperty(
    EventDescriptor^ e
) sealed
abstract GetEventProperty :
        e : EventDescriptor -> PropertyDescriptor
override GetEventProperty :
        e : EventDescriptor -> PropertyDescriptor

Parameters

e
Type: System.ComponentModelEventDescriptor
Event to convert.

Return Value

Type: PropertyDescriptor
Converted property.

Implements

IEventBindingServiceGetEventProperty(EventDescriptor)
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.ShowCode Method

EventBindingServiceBaseShowCode Method
Overload List
 | Name | Description
Public method | ShowCode | Shows the user code. This method does not show any particular code; generally it shows the last code the user typed. This returns true if it was possible to show the code, or false if not. We are never showing code since we do not generate handler methods.
Public method | ShowCode(Int32) | Shows the user code at the given line number. Line numbers are one-based. This returns true if it was possible to show the code, or false if not. We are never showing code since we do not generate handler methods.
Public method | ShowCode(IComponent, EventDescriptor) | Displays the user code for the given event.
Top
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.ShowCode Method

EventBindingServiceBaseShowCode Method
Shows the user code. This method does not show any particular code; generally it shows the last code the user typed. This returns true if it was possible to show the code, or false if not. We are never showing code since we do not generate handler methods.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowCode()
Public Function ShowCode As Boolean
public:
virtual bool ShowCode() sealed
abstract ShowCode : unit -> bool
override ShowCode : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IEventBindingServiceShowCode
See Also

Reference

EventBindingServiceBase Class
ShowCode Overload
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.ShowCode Method (Int32)

EventBindingServiceBaseShowCode Method (Int32)
Shows the user code at the given line number. Line numbers are one-based. This returns true if it was possible to show the code, or false if not. We are never showing code since we do not generate handler methods.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowCode(
    int lineNumber
)
Public Function ShowCode (
    lineNumber As Integer
) As Boolean
public:
virtual bool ShowCode(
    int lineNumber
) sealed
abstract ShowCode :
        lineNumber : int -> bool
override ShowCode :
        lineNumber : int -> bool

Parameters

lineNumber
Type: SystemInt32
Number of line to check.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IEventBindingServiceShowCode(Int32)
See Also

Reference

EventBindingServiceBase Class
ShowCode Overload
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.ShowCode Method (IComponent, EventDescriptor)

EventBindingServiceBaseShowCode Method (IComponent, EventDescriptor)
Displays the user code for the given event.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowCode(
    IComponent component,
    EventDescriptor e
)
Public Function ShowCode (
    component As IComponent,
    e As EventDescriptor
) As Boolean
public:
virtual bool ShowCode(
    IComponent^ component,
    EventDescriptor^ e
) sealed
abstract ShowCode :
        component : IComponent *
        e : EventDescriptor -> bool
override ShowCode :
        component : IComponent *
        e : EventDescriptor -> bool

Parameters

component
Type: System.ComponentModelIComponent
IComponent owns specified event.
e
Type: System.ComponentModelEventDescriptor
Information about event.

Return Value

Type: Boolean
This will return true if the user code could be displayed, or false otherwise.

Implements

IEventBindingServiceShowCode(IComponent, EventDescriptor)
See Also

Reference

EventBindingServiceBase Class
ShowCode Overload
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase Properties

EventBindingServiceBase Properties

The EventBindingServiceBase type exposes the following members.

Properties
 | Name | Description
Public property | DesignedClassName | Represents name of the class being designed.
Public property | UserFileName | Represents file name with the form designer code.
Top
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.DesignedClassName Property

EventBindingServiceBaseDesignedClassName Property
Represents name of the class being designed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DesignedClassName { get; }
Public ReadOnly Property DesignedClassName As String
    Get
public:
property String^ DesignedClassName {
    String^ get ();
}
member DesignedClassName : string with get

Property Value

Type: String
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


EventBindingServiceBase.UserFileName Property

EventBindingServiceBaseUserFileName Property
Represents file name with the form designer code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserFileName { get; }
Public ReadOnly Property UserFileName As String
    Get
public:
property String^ UserFileName {
    String^ get ();
}
member UserFileName : string with get

Property Value

Type: String
See Also

Reference

EventBindingServiceBase Class
Alternet.FormDesigner.WinForms Namespace


ExtendedDesignerOptionService Class

ExtendedDesignerOptionService Class
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignDesignerOptionService
Alternet.FormDesigner.WinFormsExtendedDesignerOptionService

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ExtendedDesignerOptionService : DesignerOptionService
Public NotInheritable Class ExtendedDesignerOptionService
    Inherits DesignerOptionService
public ref class ExtendedDesignerOptionService sealed : public DesignerOptionService
[<SealedAttribute>]
type ExtendedDesignerOptionService =
    class
        inherit DesignerOptionService
    end

The ExtendedDesignerOptionService type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedDesignerOptionService | Initializes a new instance of the ExtendedDesignerOptionService class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Options | Gets the options collection for this service. (Inherited from DesignerOptionService.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


ExtendedDesignerOptionService Constructor

ExtendedDesignerOptionService Constructor
Initializes a new instance of the ExtendedDesignerOptionService class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExtendedDesignerOptionService()
Public Sub New
public:
ExtendedDesignerOptionService()
new : unit -> ExtendedDesignerOptionService
See Also

Reference

ExtendedDesignerOptionService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedDesignerOptionService Methods

ExtendedDesignerOptionService Methods

The ExtendedDesignerOptionService type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtendedDesignerOptionService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedDesignerOptionService Properties

ExtendedDesignerOptionService Properties

The ExtendedDesignerOptionService type exposes the following members.

Properties
 | Name | Description
Public property | Options | Gets the options collection for this service. (Inherited from DesignerOptionService.)
Top
See Also

Reference

ExtendedDesignerOptionService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService Class

ExtendedMenuCommandService Class
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignMenuCommandService
Alternet.FormDesigner.WinFormsExtendedMenuCommandService

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ExtendedMenuCommandService : MenuCommandService
Public NotInheritable Class ExtendedMenuCommandService
    Inherits MenuCommandService
public ref class ExtendedMenuCommandService sealed : public MenuCommandService
[<SealedAttribute>]
type ExtendedMenuCommandService =
    class
        inherit MenuCommandService
    end

The ExtendedMenuCommandService type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedMenuCommandService | Initializes a new instance of the ExtendedMenuCommandService class
Top
Methods
 | Name | Description
Public method | AddCommand | Adds a command handler to the menu command service. (Inherited from MenuCommandService.)
Public method | AddVerb | Adds a verb to the verb table of the MenuCommandService. (Inherited from MenuCommandService.)
Public method | Dispose | Releases all resources used by the MenuCommandService. (Inherited from MenuCommandService.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCommand | Searches for the MenuCommand associated with the given command ID. (Inherited from MenuCommandService.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GlobalInvoke(CommandID) | Invokes the given command on the local form or in the global environment. (Inherited from MenuCommandService.)
Public method | GlobalInvoke(CommandID, Object) | Invokes the given command with the given parameter on the local form or in the global environment. (Inherited from MenuCommandService.)
Public method | RemoveCommand | Removes the given menu command from the document. (Inherited from MenuCommandService.)
Public method | RemoveVerb | Removes the given verb from the document. (Inherited from MenuCommandService.)
Public method | ShowContextMenu | (Overrides MenuCommandServiceShowContextMenu(CommandID, Int32, Int32).)
Public method | SynchronizeToolStrip |
Public method | SynchronizeToolStripItem |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContextMenuHostControl |
Public property | Verbs | Gets a collection of the designer verbs that are currently available. (Inherited from MenuCommandService.)
Top
Events
 | Name | Description
Public event | MenuCommandsChanged | Occurs when the status of a menu command has changed. (Inherited from MenuCommandService.)
Public event | UpdateMenuCommands |
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService Constructor

ExtendedMenuCommandService Constructor
Initializes a new instance of the ExtendedMenuCommandService class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExtendedMenuCommandService(
    IServiceProvider serviceProvider
)
Public Sub New (
    serviceProvider As IServiceProvider
)
public:
ExtendedMenuCommandService(
    IServiceProvider^ serviceProvider
)
new :
        serviceProvider : IServiceProvider -> ExtendedMenuCommandService

Parameters

serviceProvider
Type: SystemIServiceProvider
See Also

Reference

ExtendedMenuCommandService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService Methods

ExtendedMenuCommandService Methods

The ExtendedMenuCommandService type exposes the following members.

Methods
 | Name | Description
Public method | AddCommand | Adds a command handler to the menu command service. (Inherited from MenuCommandService.)
Public method | AddVerb | Adds a verb to the verb table of the MenuCommandService. (Inherited from MenuCommandService.)
Public method | Dispose | Releases all resources used by the MenuCommandService. (Inherited from MenuCommandService.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCommand | Searches for the MenuCommand associated with the given command ID. (Inherited from MenuCommandService.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GlobalInvoke(CommandID) | Invokes the given command on the local form or in the global environment. (Inherited from MenuCommandService.)
Public method | GlobalInvoke(CommandID, Object) | Invokes the given command with the given parameter on the local form or in the global environment. (Inherited from MenuCommandService.)
Public method | RemoveCommand | Removes the given menu command from the document. (Inherited from MenuCommandService.)
Public method | RemoveVerb | Removes the given verb from the document. (Inherited from MenuCommandService.)
Public method | ShowContextMenu | (Overrides MenuCommandServiceShowContextMenu(CommandID, Int32, Int32).)
Public method | SynchronizeToolStrip |
Public method | SynchronizeToolStripItem |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtendedMenuCommandService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService.ShowContextMenu Method

ExtendedMenuCommandServiceShowContextMenu Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ShowContextMenu(
    CommandID menuID,
    int x,
    int y
)
Public Overrides Sub ShowContextMenu (
    menuID As CommandID,
    x As Integer,
    y As Integer
)
public:
virtual void ShowContextMenu(
    CommandID^ menuID,
    int x,
    int y
) override
abstract ShowContextMenu :
        menuID : CommandID *
        x : int *
        y : int -> unit
override ShowContextMenu :
        menuID : CommandID *
        x : int *
        y : int -> unit

Parameters

menuID
Type: System.ComponentModel.DesignCommandID
x
Type: SystemInt32
y
Type: SystemInt32

Implements

IMenuCommandServiceShowContextMenu(CommandID, Int32, Int32)
See Also

Reference

ExtendedMenuCommandService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService.SynchronizeToolStrip Method

ExtendedMenuCommandServiceSynchronizeToolStrip Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SynchronizeToolStrip(
    ToolStrip toolStrip
)
Public Sub SynchronizeToolStrip (
    toolStrip As ToolStrip
)
public:
void SynchronizeToolStrip(
    ToolStrip^ toolStrip
)
member SynchronizeToolStrip :
        toolStrip : ToolStrip -> unit

Parameters

toolStrip
Type: System.Windows.FormsToolStrip
See Also

Reference

ExtendedMenuCommandService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService.SynchronizeToolStripItem Method

ExtendedMenuCommandServiceSynchronizeToolStripItem Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SynchronizeToolStripItem(
    ToolStripItem item
)
Public Sub SynchronizeToolStripItem (
    item As ToolStripItem
)
public:
void SynchronizeToolStripItem(
    ToolStripItem^ item
)
member SynchronizeToolStripItem :
        item : ToolStripItem -> unit

Parameters

item
Type: System.Windows.FormsToolStripItem
See Also

Reference

ExtendedMenuCommandService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService Properties

ExtendedMenuCommandService Properties

The ExtendedMenuCommandService type exposes the following members.

Properties
 | Name | Description
Public property | ContextMenuHostControl |
Public property | Verbs | Gets a collection of the designer verbs that are currently available. (Inherited from MenuCommandService.)
Top
See Also

Reference

ExtendedMenuCommandService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService.ContextMenuHostControl Property

ExtendedMenuCommandServiceContextMenuHostControl Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContextMenuHostControl ContextMenuHostControl { get; }
Public ReadOnly Property ContextMenuHostControl As ContextMenuHostControl
    Get
public:
property ContextMenuHostControl^ ContextMenuHostControl {
    ContextMenuHostControl^ get ();
}
member ContextMenuHostControl : ContextMenuHostControl with get

Property Value

Type: ContextMenuHostControl
See Also

Reference

ExtendedMenuCommandService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService Events

ExtendedMenuCommandService Events

The ExtendedMenuCommandService type exposes the following members.

Events
 | Name | Description
Public event | MenuCommandsChanged | Occurs when the status of a menu command has changed. (Inherited from MenuCommandService.)
Public event | UpdateMenuCommands |
Top
See Also

Reference

ExtendedMenuCommandService Class
Alternet.FormDesigner.WinForms Namespace


ExtendedMenuCommandService.UpdateMenuCommands Event

ExtendedMenuCommandServiceUpdateMenuCommands Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UpdateMenuCommands
Public Event UpdateMenuCommands As EventHandler
public:
 event EventHandler^ UpdateMenuCommands {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member UpdateMenuCommands : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ExtendedMenuCommandService Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerAssemblyReferenceResolver Class

FormDesignerAssemblyReferenceResolver Class
Provides functionality to resolve assembly references.
Inheritance Hierarchy
SystemObject
Alternet.CommonAssemblyReferenceResolver
Alternet.FormDesigner.WinFormsFormDesignerAssemblyReferenceResolver

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormDesignerAssemblyReferenceResolver : AssemblyReferenceResolver
Public Class FormDesignerAssemblyReferenceResolver
    Inherits AssemblyReferenceResolver
public ref class FormDesignerAssemblyReferenceResolver : public AssemblyReferenceResolver
type FormDesignerAssemblyReferenceResolver =
    class
        inherit AssemblyReferenceResolver
    end

The FormDesignerAssemblyReferenceResolver type exposes the following members.

Constructors
 | Name | Description
Public method | FormDesignerAssemblyReferenceResolver | Initializes a new instance of the FormDesignerAssemblyReferenceResolver class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResolveAssemblyName | Try to find real assembly name matches the given name. (Inherited from AssemblyReferenceResolver.)
Public method | ResolveReference | Returns assembly reference accordingly to specified parameters. (Inherited from AssemblyReferenceResolver.)
Public method | ResolveReferenceAssemblyName | Returns assembly reference name accordingly to specified parameters. (Inherited from AssemblyReferenceResolver.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseDirectory | Gets the base directory that the assembly resolver uses to look for assemblies. (Inherited from AssemblyReferenceResolver.)
Public property | FrameworkPath | Gets location of .NET Framework assemblies. (Inherited from AssemblyReferenceResolver.)
Public property | SearchPaths | Gets list of search directories to look for source files and referenced assemblies. (Inherited from AssemblyReferenceResolver.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


FormDesignerAssemblyReferenceResolver Constructor

FormDesignerAssemblyReferenceResolver Constructor
Initializes a new instance of the FormDesignerAssemblyReferenceResolver class with specified settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormDesignerAssemblyReferenceResolver(
    IEnumerable<string> searchPaths,
    string frameworkPath,
    string baseDirectory
)
Public Sub New (
    searchPaths As IEnumerable(Of String),
    frameworkPath As String,
    baseDirectory As String
)
public:
FormDesignerAssemblyReferenceResolver(
    IEnumerable<String^>^ searchPaths,
    String^ frameworkPath,
    String^ baseDirectory
)
new :
        searchPaths : IEnumerable<string> *
        frameworkPath : string *
        baseDirectory : string -> FormDesignerAssemblyReferenceResolver

Parameters

searchPaths
Type: System.Collections.GenericIEnumerableString
Collection of assembly search paths.
frameworkPath
Type: SystemString
Path to the current framework.
baseDirectory
Type: SystemString
Path to the base project's directory.
See Also

Reference

FormDesignerAssemblyReferenceResolver Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerAssemblyReferenceResolver Methods

FormDesignerAssemblyReferenceResolver Methods

The FormDesignerAssemblyReferenceResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResolveAssemblyName | Try to find real assembly name matches the given name. (Inherited from AssemblyReferenceResolver.)
Public method | ResolveReference | Returns assembly reference accordingly to specified parameters. (Inherited from AssemblyReferenceResolver.)
Public method | ResolveReferenceAssemblyName | Returns assembly reference name accordingly to specified parameters. (Inherited from AssemblyReferenceResolver.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormDesignerAssemblyReferenceResolver Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerAssemblyReferenceResolver Properties

FormDesignerAssemblyReferenceResolver Properties

The FormDesignerAssemblyReferenceResolver type exposes the following members.

Properties
 | Name | Description
Public property | BaseDirectory | Gets the base directory that the assembly resolver uses to look for assemblies. (Inherited from AssemblyReferenceResolver.)
Public property | FrameworkPath | Gets location of .NET Framework assemblies. (Inherited from AssemblyReferenceResolver.)
Public property | SearchPaths | Gets list of search directories to look for source files and referenced assemblies. (Inherited from AssemblyReferenceResolver.)
Top
See Also

Reference

FormDesignerAssemblyReferenceResolver Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl Class

FormDesignerControl Class
Represents a control supports all standard form editing operations with controls.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.FormDesigner.WinFormsFormDesignerControl

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormDesignerControl : Control,
    IFormDesignerControl, ITypeDiscoveryService
Public Class FormDesignerControl
    Inherits Control
    Implements IFormDesignerControl, ITypeDiscoveryService
public ref class FormDesignerControl : public Control,
    IFormDesignerControl, ITypeDiscoveryService
type FormDesignerControl =
    class
        inherit Control
        interface IFormDesignerControl
        interface ITypeDiscoveryService
    end

The FormDesignerControl type exposes the following members.

Constructors
 | Name | Description
Public method | FormDesignerControl | Initializes a new instance of the FormDesignerControl class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLocalizationLanguage | Gets current culture information
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RaiseComponentChanged |
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | Reload | Reloads form to be designed from the source.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Save | Serializes designer to C# or Visual Basic file.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetLocalizationLanguage | Sets current culture information
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowPropertiesWindow |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | ViewCode |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoAddComponentAssemblyReferences | Gets or sets a boolean value indicating whether designer should automatically try to add assembly references after a control is added.
Public property | AutoSaveToSource | Gets or sets a boolean value indicating whether designer should automatically translate changes to the source upon every change.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CommandKeyBindings | Represents a list of CommandKeyBinding accepted by this FormDesignerControl.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesignerCommands | Represents a collection of standard designer commands like selecting, copying, pasting, moving and resizing controls.
Public property | DesignerHost | Provides an interface for managing designer transactions and components.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | ImportedNamespaces | In case of Visual Basic, gets collection of globally available namespaces.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsBeingLoaded | When implemented by a class, gets a boolean value indicating that designer is currently being loaded.
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsModified | Represents a value indicates whether designer content has been modified since last save.
Public property | IsSmartDiffCodeSerializationRequired | Gets or sets method used to identify whether FormDesignerControl content should be saved only by taking into account code difference.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Options | Gets designer options like snap settings, grid size etc.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PrimarySelection | Gets first selected component or control.
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | ReferencedAssemblies | Gets collection of assemblies where the controls and components used on the form being designed are declared.
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedComponents | Contains list of selected components or controls.
Public property | ServiceContainer | Represents a container for designer-related services.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Source | Gets or sets FormDesigner Source.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ToolboxControl | Gets or sets toolbox control associated with the designer.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UserData | Gets or sets user-specific data associated with this Form Designer
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CommandStateChanged | Occurs when state of designer commands changes (for example when undo stack becomes available).
Public event | CompilerErrorClick | Occurs when user clicks on compiler error on Form Designer surface.
Public event | ComponentAdded | Occurs when some component was added on the designer surface.
Public event | ComponentChanged | Occurs when some component was changed on the designer surface.
Public event | ComponentRemoved | Occurs when some component was removed from the designer surface.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DesignedContentChanged | Occurs when user modifies any aspect of the control being designed.
Public event | DesignerHostChanged | Occurs when designer host changes, for example if new form is loaded.
Public event | DesignSurfaceKeyDown | Occurs when user presses a key when design surface is focused.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LoadingErrorOccured | Occurs when there is a parse error of the design code during loading.
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NavigateToUserMethodRequested | Occurs when form designer is requested to navigate to the event handler. For example, when user double clicks on the control.
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | ReferencedAssembliesChanged |
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when user selects different control in the designer.
Public event | ShowPropertiesRequested | Occurs when user request to open Property Window.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TypeDiscoveryRequested |
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ViewCodeRequested | Occurs when user request to view designer source code.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


FormDesignerControl Constructor

FormDesignerControl Constructor
Initializes a new instance of the FormDesignerControl class with default settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormDesignerControl()
Public Sub New
public:
FormDesignerControl()
new : unit -> FormDesignerControl
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl Methods

FormDesignerControl Methods

The FormDesignerControl type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLocalizationLanguage | Gets current culture information
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RaiseComponentChanged |
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | Reload | Reloads form to be designed from the source.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Save | Serializes designer to C# or Visual Basic file.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetLocalizationLanguage | Sets current culture information
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowPropertiesWindow |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | ViewCode |
Top
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.GetLocalizationLanguage Method

FormDesignerControlGetLocalizationLanguage Method
Gets current culture information

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CultureInfo GetLocalizationLanguage()
Public Function GetLocalizationLanguage As CultureInfo
public:
virtual CultureInfo^ GetLocalizationLanguage() sealed
abstract GetLocalizationLanguage : unit -> CultureInfo
override GetLocalizationLanguage : unit -> CultureInfo

Return Value

Type: CultureInfo
Current culture info

Implements

IFormDesignerControlGetLocalizationLanguage
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.RaiseComponentChanged Method

FormDesignerControlRaiseComponentChanged Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RaiseComponentChanged(
    Object changedComponent
)
Public Sub RaiseComponentChanged (
    changedComponent As Object
)
public:
virtual void RaiseComponentChanged(
    Object^ changedComponent
) sealed
abstract RaiseComponentChanged :
        changedComponent : Object -> unit
override RaiseComponentChanged :
        changedComponent : Object -> unit

Parameters

changedComponent
Type: SystemObject

Implements

IFormDesignerControlRaiseComponentChanged(Object)
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.Reload Method

FormDesignerControlReload Method
Reloads form to be designed from the source.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reload()
Public Sub Reload
public:
virtual void Reload() sealed
abstract Reload : unit -> unit
override Reload : unit -> unit

Implements

IFormDesignerControlReload
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.Save Method

FormDesignerControlSave Method
Serializes designer to C# or Visual Basic file.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
virtual void Save() sealed
abstract Save : unit -> unit
override Save : unit -> unit

Implements

IFormDesignerControlSave
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.SetLocalizationLanguage Method

FormDesignerControlSetLocalizationLanguage Method
Sets current culture information

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLocalizationLanguage(
    CultureInfo language
)
Public Sub SetLocalizationLanguage (
    language As CultureInfo
)
public:
virtual void SetLocalizationLanguage(
    CultureInfo^ language
) sealed
abstract SetLocalizationLanguage :
        language : CultureInfo -> unit
override SetLocalizationLanguage :
        language : CultureInfo -> unit

Parameters

language
Type: System.GlobalizationCultureInfo
Culture information to set.

Implements

IFormDesignerControlSetLocalizationLanguage(CultureInfo)
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ShowPropertiesWindow Method

FormDesignerControlShowPropertiesWindow Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowPropertiesWindow(
    Object sender,
    EventArgs e
)
Public Sub ShowPropertiesWindow (
    sender As Object,
    e As EventArgs
)
public:
void ShowPropertiesWindow(
    Object^ sender,
    EventArgs^ e
)
member ShowPropertiesWindow :
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ViewCode Method

FormDesignerControlViewCode Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ViewCode(
    Object sender,
    EventArgs e
)
Public Sub ViewCode (
    sender As Object,
    e As EventArgs
)
public:
void ViewCode(
    Object^ sender,
    EventArgs^ e
)
member ViewCode :
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl Properties

FormDesignerControl Properties

The FormDesignerControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoAddComponentAssemblyReferences | Gets or sets a boolean value indicating whether designer should automatically try to add assembly references after a control is added.
Public property | AutoSaveToSource | Gets or sets a boolean value indicating whether designer should automatically translate changes to the source upon every change.
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CommandKeyBindings | Represents a list of CommandKeyBinding accepted by this FormDesignerControl.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesignerCommands | Represents a collection of standard designer commands like selecting, copying, pasting, moving and resizing controls.
Public property | DesignerHost | Provides an interface for managing designer transactions and components.
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | ImportedNamespaces | In case of Visual Basic, gets collection of globally available namespaces.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsBeingLoaded | When implemented by a class, gets a boolean value indicating that designer is currently being loaded.
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsModified | Represents a value indicates whether designer content has been modified since last save.
Public property | IsSmartDiffCodeSerializationRequired | Gets or sets method used to identify whether FormDesignerControl content should be saved only by taking into account code difference.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Options | Gets designer options like snap settings, grid size etc.
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PrimarySelection | Gets first selected component or control.
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | ReferencedAssemblies | Gets collection of assemblies where the controls and components used on the form being designed are declared.
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedComponents | Contains list of selected components or controls.
Public property | ServiceContainer | Represents a container for designer-related services.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Source | Gets or sets FormDesigner Source.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | ToolboxControl | Gets or sets toolbox control associated with the designer.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UserData | Gets or sets user-specific data associated with this Form Designer
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.AutoAddComponentAssemblyReferences Property

FormDesignerControlAutoAddComponentAssemblyReferences Property
Gets or sets a boolean value indicating whether designer should automatically try to add assembly references after a control is added.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoAddComponentAssemblyReferences { get; set; }
Public Property AutoAddComponentAssemblyReferences As Boolean
    Get
    Set
public:
virtual property bool AutoAddComponentAssemblyReferences {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AutoAddComponentAssemblyReferences : bool with get, set
override AutoAddComponentAssemblyReferences : bool with get, set

Property Value

Type: Boolean

Implements

IFormDesignerControlAutoAddComponentAssemblyReferences
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.AutoSaveToSource Property

FormDesignerControlAutoSaveToSource Property
Gets or sets a boolean value indicating whether designer should automatically translate changes to the source upon every change.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoSaveToSource { get; set; }
Public Property AutoSaveToSource As Boolean
    Get
    Set
public:
virtual property bool AutoSaveToSource {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AutoSaveToSource : bool with get, set
override AutoSaveToSource : bool with get, set

Property Value

Type: Boolean

Implements

IFormDesignerControlAutoSaveToSource
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.CommandKeyBindings Property

FormDesignerControlCommandKeyBindings Property
Represents a list of CommandKeyBinding accepted by this FormDesignerControl.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<CommandKeyBinding> CommandKeyBindings { get; }
Public ReadOnly Property CommandKeyBindings As List(Of CommandKeyBinding)
    Get
public:
virtual property List<CommandKeyBinding^>^ CommandKeyBindings {
    List<CommandKeyBinding^>^ get () sealed;
}
abstract CommandKeyBindings : List<CommandKeyBinding> with get
override CommandKeyBindings : List<CommandKeyBinding> with get

Property Value

Type: ListCommandKeyBinding

Implements

IFormDesignerControlCommandKeyBindings
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.DesignerCommands Property

FormDesignerControlDesignerCommands Property
Represents a collection of standard designer commands like selecting, copying, pasting, moving and resizing controls.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerCommands DesignerCommands { get; }
Public ReadOnly Property DesignerCommands As IFormDesignerCommands
    Get
public:
virtual property IFormDesignerCommands^ DesignerCommands {
    IFormDesignerCommands^ get () sealed;
}
abstract DesignerCommands : IFormDesignerCommands with get
override DesignerCommands : IFormDesignerCommands with get

Property Value

Type: IFormDesignerCommands

Implements

IFormDesignerControlDesignerCommands
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.DesignerHost Property

FormDesignerControlDesignerHost Property
Provides an interface for managing designer transactions and components.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDesignerHost DesignerHost { get; }
Public ReadOnly Property DesignerHost As IDesignerHost
    Get
public:
virtual property IDesignerHost^ DesignerHost {
    IDesignerHost^ get () sealed;
}
abstract DesignerHost : IDesignerHost with get
override DesignerHost : IDesignerHost with get

Property Value

Type: IDesignerHost

Implements

IFormDesignerControlDesignerHost
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ImportedNamespaces Property

FormDesignerControlImportedNamespaces Property
In case of Visual Basic, gets collection of globally available namespaces.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerImportedNamespaces ImportedNamespaces { get; set; }
Public Property ImportedNamespaces As DesignerImportedNamespaces
    Get
    Set
public:
virtual property DesignerImportedNamespaces^ ImportedNamespaces {
    DesignerImportedNamespaces^ get () sealed;
    void set (DesignerImportedNamespaces^ value) sealed;
}
abstract ImportedNamespaces : DesignerImportedNamespaces with get, set
override ImportedNamespaces : DesignerImportedNamespaces with get, set

Property Value

Type: DesignerImportedNamespaces

Implements

IFormDesignerControlImportedNamespaces
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.IsBeingLoaded Property

FormDesignerControlIsBeingLoaded Property
When implemented by a class, gets a boolean value indicating that designer is currently being loaded.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBeingLoaded { get; }
Public ReadOnly Property IsBeingLoaded As Boolean
    Get
public:
virtual property bool IsBeingLoaded {
    bool get () sealed;
}
abstract IsBeingLoaded : bool with get
override IsBeingLoaded : bool with get

Property Value

Type: Boolean

Implements

IFormDesignerControlIsBeingLoaded
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.IsModified Property

FormDesignerControlIsModified Property
Represents a value indicates whether designer content has been modified since last save.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModified { get; }
Public ReadOnly Property IsModified As Boolean
    Get
public:
virtual property bool IsModified {
    bool get () sealed;
}
abstract IsModified : bool with get
override IsModified : bool with get

Property Value

Type: Boolean

Implements

IFormDesignerControlIsModified
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.IsSmartDiffCodeSerializationRequired Property

FormDesignerControlIsSmartDiffCodeSerializationRequired Property
Gets or sets method used to identify whether FormDesignerControl content should be saved only by taking into account code difference.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<IFormDesignerControl, bool> IsSmartDiffCodeSerializationRequired { get; set; }
Public Property IsSmartDiffCodeSerializationRequired As Func(Of IFormDesignerControl, Boolean)
    Get
    Set
public:
virtual property Func<IFormDesignerControl^, bool>^ IsSmartDiffCodeSerializationRequired {
    Func<IFormDesignerControl^, bool>^ get () sealed;
    void set (Func<IFormDesignerControl^, bool>^ value) sealed;
}
abstract IsSmartDiffCodeSerializationRequired : Func<IFormDesignerControl, bool> with get, set
override IsSmartDiffCodeSerializationRequired : Func<IFormDesignerControl, bool> with get, set

Property Value

Type: FuncIFormDesignerControl, Boolean

Implements

IFormDesignerControlIsSmartDiffCodeSerializationRequired
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.Options Property

FormDesignerControlOptions Property
Gets designer options like snap settings, grid size etc.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormDesignerOptions Options { get; }
Public ReadOnly Property Options As FormDesignerOptions
    Get
public:
virtual property FormDesignerOptions^ Options {
    FormDesignerOptions^ get () sealed;
}
abstract Options : FormDesignerOptions with get
override Options : FormDesignerOptions with get

Property Value

Type: FormDesignerOptions

Implements

IFormDesignerControlOptions
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.PrimarySelection Property

FormDesignerControlPrimarySelection Property
Gets first selected component or control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IComponent PrimarySelection { get; }
Public ReadOnly Property PrimarySelection As IComponent
    Get
public:
virtual property IComponent^ PrimarySelection {
    IComponent^ get () sealed;
}
abstract PrimarySelection : IComponent with get
override PrimarySelection : IComponent with get

Property Value

Type: IComponent

Implements

IFormDesignerControlPrimarySelection
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ReferencedAssemblies Property

FormDesignerControlReferencedAssemblies Property
Gets collection of assemblies where the controls and components used on the form being designed are declared.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignerReferencedAssemblies ReferencedAssemblies { get; set; }
Public Property ReferencedAssemblies As DesignerReferencedAssemblies
    Get
    Set
public:
virtual property DesignerReferencedAssemblies^ ReferencedAssemblies {
    DesignerReferencedAssemblies^ get () sealed;
    void set (DesignerReferencedAssemblies^ value) sealed;
}
abstract ReferencedAssemblies : DesignerReferencedAssemblies with get, set
override ReferencedAssemblies : DesignerReferencedAssemblies with get, set

Property Value

Type: DesignerReferencedAssemblies

Implements

IFormDesignerControlReferencedAssemblies
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.SelectedComponents Property

FormDesignerControlSelectedComponents Property
Contains list of selected components or controls.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IComponent> SelectedComponents { get; set; }
Public Property SelectedComponents As IEnumerable(Of IComponent)
    Get
    Set
public:
virtual property IEnumerable<IComponent^>^ SelectedComponents {
    IEnumerable<IComponent^>^ get () sealed;
    void set (IEnumerable<IComponent^>^ value) sealed;
}
abstract SelectedComponents : IEnumerable<IComponent> with get, set
override SelectedComponents : IEnumerable<IComponent> with get, set

Property Value

Type: IEnumerableIComponent

Implements

IFormDesignerControlSelectedComponents
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ServiceContainer Property

FormDesignerControlServiceContainer Property
Represents a container for designer-related services.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IServiceContainer ServiceContainer { get; }
Public ReadOnly Property ServiceContainer As IServiceContainer
    Get
public:
virtual property IServiceContainer^ ServiceContainer {
    IServiceContainer^ get () sealed;
}
abstract ServiceContainer : IServiceContainer with get
override ServiceContainer : IServiceContainer with get

Property Value

Type: IServiceContainer

Implements

IFormDesignerControlServiceContainer
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.Source Property

FormDesignerControlSource Property
Gets or sets FormDesigner Source.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerDataSource Source { get; set; }
Public Property Source As IFormDesignerDataSource
    Get
    Set
public:
virtual property IFormDesignerDataSource^ Source {
    IFormDesignerDataSource^ get () sealed;
    void set (IFormDesignerDataSource^ value) sealed;
}
abstract Source : IFormDesignerDataSource with get, set
override Source : IFormDesignerDataSource with get, set

Property Value

Type: IFormDesignerDataSource

Implements

IFormDesignerControlSource
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ToolboxControl Property

FormDesignerControlToolboxControl Property
Gets or sets toolbox control associated with the designer.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IToolboxControl ToolboxControl { get; set; }
Public Property ToolboxControl As IToolboxControl
    Get
    Set
public:
virtual property IToolboxControl^ ToolboxControl {
    IToolboxControl^ get () sealed;
    void set (IToolboxControl^ value) sealed;
}
abstract ToolboxControl : IToolboxControl with get, set
override ToolboxControl : IToolboxControl with get, set

Property Value

Type: IToolboxControl

Implements

IFormDesignerControlToolboxControl
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.UserData Property

FormDesignerControlUserData Property
Gets or sets user-specific data associated with this Form Designer

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, Object> UserData { get; }
Public ReadOnly Property UserData As IDictionary(Of String, Object)
    Get
public:
virtual property IDictionary<String^, Object^>^ UserData {
    IDictionary<String^, Object^>^ get () sealed;
}
abstract UserData : IDictionary<string, Object> with get
override UserData : IDictionary<string, Object> with get

Property Value

Type: IDictionaryString, Object

Implements

IFormDesignerControlUserData
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl Events

FormDesignerControl Events

The FormDesignerControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | CommandStateChanged | Occurs when state of designer commands changes (for example when undo stack becomes available).
Public event | CompilerErrorClick | Occurs when user clicks on compiler error on Form Designer surface.
Public event | ComponentAdded | Occurs when some component was added on the designer surface.
Public event | ComponentChanged | Occurs when some component was changed on the designer surface.
Public event | ComponentRemoved | Occurs when some component was removed from the designer surface.
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DesignedContentChanged | Occurs when user modifies any aspect of the control being designed.
Public event | DesignerHostChanged | Occurs when designer host changes, for example if new form is loaded.
Public event | DesignSurfaceKeyDown | Occurs when user presses a key when design surface is focused.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LoadingErrorOccured | Occurs when there is a parse error of the design code during loading.
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NavigateToUserMethodRequested | Occurs when form designer is requested to navigate to the event handler. For example, when user double clicks on the control.
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | ReferencedAssembliesChanged |
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectionChanged | Occurs when user selects different control in the designer.
Public event | ShowPropertiesRequested | Occurs when user request to open Property Window.
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | TypeDiscoveryRequested |
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ViewCodeRequested | Occurs when user request to view designer source code.
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.CommandStateChanged Event

FormDesignerControlCommandStateChanged Event
Occurs when state of designer commands changes (for example when undo stack becomes available).

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler CommandStateChanged
Public Event CommandStateChanged As EventHandler
public:
virtual  event EventHandler^ CommandStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CommandStateChanged : IEvent<EventHandler,
    EventArgs>
override CommandStateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IFormDesignerControlCommandStateChanged
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.CompilerErrorClick Event

FormDesignerControlCompilerErrorClick Event
Occurs when user clicks on compiler error on Form Designer surface.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DesignerCompilerErrorClickEventArgs> CompilerErrorClick
Public Event CompilerErrorClick As EventHandler(Of DesignerCompilerErrorClickEventArgs)
public:
virtual  event EventHandler<DesignerCompilerErrorClickEventArgs^>^ CompilerErrorClick {
    void add (EventHandler<DesignerCompilerErrorClickEventArgs^>^ value);
    void remove (EventHandler<DesignerCompilerErrorClickEventArgs^>^ value);
}
abstract CompilerErrorClick : IEvent<EventHandler<DesignerCompilerErrorClickEventArgs>,
    DesignerCompilerErrorClickEventArgs>
override CompilerErrorClick : IEvent<EventHandler<DesignerCompilerErrorClickEventArgs>,
    DesignerCompilerErrorClickEventArgs>

Value

Type: SystemEventHandlerDesignerCompilerErrorClickEventArgs

Implements

IFormDesignerControlCompilerErrorClick
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ComponentAdded Event

FormDesignerControlComponentAdded Event
Occurs when some component was added on the designer surface.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ComponentEventArgs> ComponentAdded
Public Event ComponentAdded As EventHandler(Of ComponentEventArgs)
public:
virtual  event EventHandler<ComponentEventArgs^>^ ComponentAdded {
    void add (EventHandler<ComponentEventArgs^>^ value);
    void remove (EventHandler<ComponentEventArgs^>^ value);
}
abstract ComponentAdded : IEvent<EventHandler<ComponentEventArgs>,
    ComponentEventArgs>
override ComponentAdded : IEvent<EventHandler<ComponentEventArgs>,
    ComponentEventArgs>

Value

Type: SystemEventHandlerComponentEventArgs

Implements

IFormDesignerControlComponentAdded
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ComponentChanged Event

FormDesignerControlComponentChanged Event
Occurs when some component was changed on the designer surface.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ComponentChangedEventArgs> ComponentChanged
Public Event ComponentChanged As EventHandler(Of ComponentChangedEventArgs)
public:
virtual  event EventHandler<ComponentChangedEventArgs^>^ ComponentChanged {
    void add (EventHandler<ComponentChangedEventArgs^>^ value);
    void remove (EventHandler<ComponentChangedEventArgs^>^ value);
}
abstract ComponentChanged : IEvent<EventHandler<ComponentChangedEventArgs>,
    ComponentChangedEventArgs>
override ComponentChanged : IEvent<EventHandler<ComponentChangedEventArgs>,
    ComponentChangedEventArgs>

Value

Type: SystemEventHandlerComponentChangedEventArgs

Implements

IFormDesignerControlComponentChanged
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ComponentRemoved Event

FormDesignerControlComponentRemoved Event
Occurs when some component was removed from the designer surface.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ComponentEventArgs> ComponentRemoved
Public Event ComponentRemoved As EventHandler(Of ComponentEventArgs)
public:
virtual  event EventHandler<ComponentEventArgs^>^ ComponentRemoved {
    void add (EventHandler<ComponentEventArgs^>^ value);
    void remove (EventHandler<ComponentEventArgs^>^ value);
}
abstract ComponentRemoved : IEvent<EventHandler<ComponentEventArgs>,
    ComponentEventArgs>
override ComponentRemoved : IEvent<EventHandler<ComponentEventArgs>,
    ComponentEventArgs>

Value

Type: SystemEventHandlerComponentEventArgs

Implements

IFormDesignerControlComponentRemoved
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.DesignedContentChanged Event

FormDesignerControlDesignedContentChanged Event
Occurs when user modifies any aspect of the control being designed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DesignedContentChanged
Public Event DesignedContentChanged As EventHandler
public:
virtual  event EventHandler^ DesignedContentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DesignedContentChanged : IEvent<EventHandler,
    EventArgs>
override DesignedContentChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IFormDesignerControlDesignedContentChanged
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.DesignerHostChanged Event

FormDesignerControlDesignerHostChanged Event
Occurs when designer host changes, for example if new form is loaded.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DesignerHostChanged
Public Event DesignerHostChanged As EventHandler
public:
virtual  event EventHandler^ DesignerHostChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DesignerHostChanged : IEvent<EventHandler,
    EventArgs>
override DesignerHostChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IFormDesignerControlDesignerHostChanged
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.DesignSurfaceKeyDown Event

FormDesignerControlDesignSurfaceKeyDown Event
Occurs when user presses a key when design surface is focused.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event KeyEventHandler DesignSurfaceKeyDown
Public Event DesignSurfaceKeyDown As KeyEventHandler
public:
virtual  event KeyEventHandler^ DesignSurfaceKeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract DesignSurfaceKeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>
override DesignSurfaceKeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>

Value

Type: System.Windows.FormsKeyEventHandler

Implements

IFormDesignerControlDesignSurfaceKeyDown
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.LoadingErrorOccured Event

FormDesignerControlLoadingErrorOccured Event
Occurs when there is a parse error of the design code during loading.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DesignerLoadingErrorEventArgs> LoadingErrorOccured
Public Event LoadingErrorOccured As EventHandler(Of DesignerLoadingErrorEventArgs)
public:
virtual  event EventHandler<DesignerLoadingErrorEventArgs^>^ LoadingErrorOccured {
    void add (EventHandler<DesignerLoadingErrorEventArgs^>^ value);
    void remove (EventHandler<DesignerLoadingErrorEventArgs^>^ value);
}
abstract LoadingErrorOccured : IEvent<EventHandler<DesignerLoadingErrorEventArgs>,
    DesignerLoadingErrorEventArgs>
override LoadingErrorOccured : IEvent<EventHandler<DesignerLoadingErrorEventArgs>,
    DesignerLoadingErrorEventArgs>

Value

Type: SystemEventHandlerDesignerLoadingErrorEventArgs

Implements

IFormDesignerControlLoadingErrorOccured
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.NavigateToUserMethodRequested Event

FormDesignerControlNavigateToUserMethodRequested Event
Occurs when form designer is requested to navigate to the event handler. For example, when user double clicks on the control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<NavigateToUserMethodRequestedEventArgs> NavigateToUserMethodRequested
Public Event NavigateToUserMethodRequested As EventHandler(Of NavigateToUserMethodRequestedEventArgs)
public:
virtual  event EventHandler<NavigateToUserMethodRequestedEventArgs^>^ NavigateToUserMethodRequested {
    void add (EventHandler<NavigateToUserMethodRequestedEventArgs^>^ value);
    void remove (EventHandler<NavigateToUserMethodRequestedEventArgs^>^ value);
}
abstract NavigateToUserMethodRequested : IEvent<EventHandler<NavigateToUserMethodRequestedEventArgs>,
    NavigateToUserMethodRequestedEventArgs>
override NavigateToUserMethodRequested : IEvent<EventHandler<NavigateToUserMethodRequestedEventArgs>,
    NavigateToUserMethodRequestedEventArgs>

Value

Type: SystemEventHandlerNavigateToUserMethodRequestedEventArgs

Implements

IFormDesignerControlNavigateToUserMethodRequested
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ReferencedAssembliesChanged Event

FormDesignerControlReferencedAssembliesChanged Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ReferencedAssembliesChanged
Public Event ReferencedAssembliesChanged As EventHandler
public:
virtual  event EventHandler^ ReferencedAssembliesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ReferencedAssembliesChanged : IEvent<EventHandler,
    EventArgs>
override ReferencedAssembliesChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IFormDesignerControlReferencedAssembliesChanged
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.SelectionChanged Event

FormDesignerControlSelectionChanged Event
Occurs when user selects different control in the designer.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
public:
virtual  event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectionChanged : IEvent<EventHandler,
    EventArgs>
override SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IFormDesignerControlSelectionChanged
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ShowPropertiesRequested Event

FormDesignerControlShowPropertiesRequested Event
Occurs when user request to open Property Window.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ShowPropertiesRequested
Public Event ShowPropertiesRequested As EventHandler
public:
 event EventHandler^ ShowPropertiesRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ShowPropertiesRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.TypeDiscoveryRequested Event

FormDesignerControlTypeDiscoveryRequested Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<TypeDiscoveryEventArgs> TypeDiscoveryRequested
Public Event TypeDiscoveryRequested As EventHandler(Of TypeDiscoveryEventArgs)
public:
virtual  event EventHandler<TypeDiscoveryEventArgs^>^ TypeDiscoveryRequested {
    void add (EventHandler<TypeDiscoveryEventArgs^>^ value);
    void remove (EventHandler<TypeDiscoveryEventArgs^>^ value);
}
abstract TypeDiscoveryRequested : IEvent<EventHandler<TypeDiscoveryEventArgs>,
    TypeDiscoveryEventArgs>
override TypeDiscoveryRequested : IEvent<EventHandler<TypeDiscoveryEventArgs>,
    TypeDiscoveryEventArgs>

Value

Type: SystemEventHandlerTypeDiscoveryEventArgs

Implements

IFormDesignerControlTypeDiscoveryRequested
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerControl.ViewCodeRequested Event

FormDesignerControlViewCodeRequested Event
Occurs when user request to view designer source code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ViewCodeRequested
Public Event ViewCodeRequested As EventHandler
public:
 event EventHandler^ ViewCodeRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ViewCodeRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

FormDesignerControl Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource Class

FormDesignerDataSource Class
Provides properties and methods for a Form Designer control's data source.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsFormDesignerDataSource

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormDesignerDataSource : IFormDesignerDataSource
Public Class FormDesignerDataSource
    Implements IFormDesignerDataSource
public ref class FormDesignerDataSource : IFormDesignerDataSource
type FormDesignerDataSource =
    class
        interface IFormDesignerDataSource
    end

The FormDesignerDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | FormDesignerDataSource | Initializes a new instance of the FormDesignerDataSource class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResourceFileName |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertTextIntoUserCode | Inserts specified text fragments into the user code.
Public method | OpenDesignerStream | Opens designer stream with specified access mode.
Public method | OpenResourceStream | Opens resource stream with specified access mode.
Public method | OpenUserCodeStreamForReading | Opens user code stream with default access mode.
Public method | ReplaceTextInDesignerCode | Replaces specified text fragments within the user code.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyResources | Gets the list of form designer's assembly resources.
Public property | DefaultResourceFileName | Gets name of the resource file.
Public property | DesignedClassFullName | Gets the fully qualified name of designed class.
Public property | DesignedComponentAssembly |
Public property | DesignerFileName | Gets name of the file with designer generated code.
Public property | IsModified | Represents a value indicating whether designer content has been modified since last save.
Public property | ResourceFileName | Obsolete. Gets name of the resource file.
Public property | UserCodeFileName | Gets name of the file with user code.
Top
Events
 | Name | Description
Public event | ResourceCultureAdded |
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource Constructor

FormDesignerDataSource Constructor
Initializes a new instance of the FormDesignerDataSource class with specified settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormDesignerDataSource(
    string userCodeFileName,
    string namespaceName = "",
    string className = "",
    IEnumerable<DesignerAssemblyResources> assemblyResources = null
)
Public Sub New (
    userCodeFileName As String,
    Optional namespaceName As String = "",
    Optional className As String = "",
    Optional assemblyResources As IEnumerable(Of DesignerAssemblyResources) = Nothing
)
public:
FormDesignerDataSource(
    String^ userCodeFileName,
    String^ namespaceName = L"",
    String^ className = L"",
    IEnumerable<DesignerAssemblyResources^>^ assemblyResources = nullptr
)
new :
        userCodeFileName : string *
        ?namespaceName : string *
        ?className : string *
        ?assemblyResources : IEnumerable<DesignerAssemblyResources>
(* Defaults:
        let _namespaceName = defaultArg namespaceName ""
        let _className = defaultArg className ""
        let _assemblyResources = defaultArg assemblyResources null
*)
-> FormDesignerDataSource

Parameters

userCodeFileName
Type: SystemString
Name of the file with user code.
namespaceName (Optional)
Type: SystemString
Root namespace name.
className (Optional)
Type: SystemString
assemblyResources (Optional)
Type: System.Collections.GenericIEnumerableDesignerAssemblyResources
The list of assembly resources.
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource Methods

FormDesignerDataSource Methods

The FormDesignerDataSource type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResourceFileName |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertTextIntoUserCode | Inserts specified text fragments into the user code.
Public method | OpenDesignerStream | Opens designer stream with specified access mode.
Public method | OpenResourceStream | Opens resource stream with specified access mode.
Public method | OpenUserCodeStreamForReading | Opens user code stream with default access mode.
Public method | ReplaceTextInDesignerCode | Replaces specified text fragments within the user code.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.GetResourceFileName Method

FormDesignerDataSourceGetResourceFileName Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetResourceFileName(
    CultureInfo cultureInfo
)
Public Function GetResourceFileName (
    cultureInfo As CultureInfo
) As String
public:
virtual String^ GetResourceFileName(
    CultureInfo^ cultureInfo
) sealed
abstract GetResourceFileName :
        cultureInfo : CultureInfo -> string
override GetResourceFileName :
        cultureInfo : CultureInfo -> string

Parameters

cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: String

Implements

IFormDesignerDataSourceGetResourceFileName(CultureInfo)
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.InsertTextIntoUserCode Method

FormDesignerDataSourceInsertTextIntoUserCode Method
Inserts specified text fragments into the user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertTextIntoUserCode(
    FormDesignerTextSourceOperationsTextInsertionOperation[] operations
)
Public Sub InsertTextIntoUserCode (
    operations As FormDesignerTextSourceOperationsTextInsertionOperation()
)
public:
virtual void InsertTextIntoUserCode(
    array<FormDesignerTextSourceOperationsTextInsertionOperation^>^ operations
) sealed
abstract InsertTextIntoUserCode :
        operations : FormDesignerTextSourceOperationsTextInsertionOperation[] -> unit
override InsertTextIntoUserCode :
        operations : FormDesignerTextSourceOperationsTextInsertionOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextInsertionOperation
Contains data to insert.

Implements

IFormDesignerDataSourceInsertTextIntoUserCode(FormDesignerTextSourceOperationsTextInsertionOperation)
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.OpenDesignerStream Method

FormDesignerDataSourceOpenDesignerStream Method
Opens designer stream with specified access mode.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Stream OpenDesignerStream(
    StreamAccessMode mode
)
Public Function OpenDesignerStream (
    mode As StreamAccessMode
) As Stream
public:
virtual Stream^ OpenDesignerStream(
    StreamAccessMode mode
) sealed
abstract OpenDesignerStream :
        mode : StreamAccessMode -> Stream
override OpenDesignerStream :
        mode : StreamAccessMode -> Stream

Parameters

mode
Type: Alternet.FormDesigner.WinFormsStreamAccessMode
Specifies operation can be performed on the stream.

Return Value

Type: Stream
Designer stream.

Implements

IFormDesignerDataSourceOpenDesignerStream(StreamAccessMode)
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.OpenResourceStream Method

FormDesignerDataSourceOpenResourceStream Method
Opens resource stream with specified access mode.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Stream OpenResourceStream(
    StreamAccessMode mode,
    CultureInfo cultureInfo
)
Public Function OpenResourceStream (
    mode As StreamAccessMode,
    cultureInfo As CultureInfo
) As Stream
public:
virtual Stream^ OpenResourceStream(
    StreamAccessMode mode,
    CultureInfo^ cultureInfo
) sealed
abstract OpenResourceStream :
        mode : StreamAccessMode *
        cultureInfo : CultureInfo -> Stream
override OpenResourceStream :
        mode : StreamAccessMode *
        cultureInfo : CultureInfo -> Stream

Parameters

mode
Type: Alternet.FormDesigner.WinFormsStreamAccessMode
Specifies operation can be performed on the stream.
cultureInfo
Type: System.GlobalizationCultureInfo
Specifies information about a specific culture.

Return Value

Type: Stream
Resource stream.

Implements

IFormDesignerDataSourceOpenResourceStream(StreamAccessMode, CultureInfo)
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.OpenUserCodeStreamForReading Method

FormDesignerDataSourceOpenUserCodeStreamForReading Method
Opens user code stream with default access mode.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Stream OpenUserCodeStreamForReading()
Public Function OpenUserCodeStreamForReading As Stream
public:
virtual Stream^ OpenUserCodeStreamForReading() sealed
abstract OpenUserCodeStreamForReading : unit -> Stream
override OpenUserCodeStreamForReading : unit -> Stream

Return Value

Type: Stream
User code stream.

Implements

IFormDesignerDataSourceOpenUserCodeStreamForReading
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.ReplaceTextInDesignerCode Method

FormDesignerDataSourceReplaceTextInDesignerCode Method
Replaces specified text fragments within the user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReplaceTextInDesignerCode(
    FormDesignerTextSourceOperationsTextReplacementOperation[] operations
)
Public Sub ReplaceTextInDesignerCode (
    operations As FormDesignerTextSourceOperationsTextReplacementOperation()
)
public:
virtual void ReplaceTextInDesignerCode(
    array<FormDesignerTextSourceOperationsTextReplacementOperation^>^ operations
) sealed
abstract ReplaceTextInDesignerCode :
        operations : FormDesignerTextSourceOperationsTextReplacementOperation[] -> unit
override ReplaceTextInDesignerCode :
        operations : FormDesignerTextSourceOperationsTextReplacementOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextReplacementOperation
Contains data to replace.

Implements

IFormDesignerDataSourceReplaceTextInDesignerCode(FormDesignerTextSourceOperationsTextReplacementOperation)
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource Properties

FormDesignerDataSource Properties

The FormDesignerDataSource type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyResources | Gets the list of form designer's assembly resources.
Public property | DefaultResourceFileName | Gets name of the resource file.
Public property | DesignedClassFullName | Gets the fully qualified name of designed class.
Public property | DesignedComponentAssembly |
Public property | DesignerFileName | Gets name of the file with designer generated code.
Public property | IsModified | Represents a value indicating whether designer content has been modified since last save.
Public property | ResourceFileName | Obsolete. Gets name of the resource file.
Public property | UserCodeFileName | Gets name of the file with user code.
Top
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.AssemblyResources Property

FormDesignerDataSourceAssemblyResources Property
Gets the list of form designer's assembly resources.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DesignerAssemblyResources> AssemblyResources { get; }
Public ReadOnly Property AssemblyResources As IEnumerable(Of DesignerAssemblyResources)
    Get
public:
virtual property IEnumerable<DesignerAssemblyResources^>^ AssemblyResources {
    IEnumerable<DesignerAssemblyResources^>^ get () sealed;
}
abstract AssemblyResources : IEnumerable<DesignerAssemblyResources> with get
override AssemblyResources : IEnumerable<DesignerAssemblyResources> with get

Property Value

Type: IEnumerableDesignerAssemblyResources

Implements

IFormDesignerDataSourceAssemblyResources
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.DefaultResourceFileName Property

FormDesignerDataSourceDefaultResourceFileName Property
Gets name of the resource file.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DefaultResourceFileName { get; }
Public ReadOnly Property DefaultResourceFileName As String
    Get
public:
property String^ DefaultResourceFileName {
    String^ get ();
}
member DefaultResourceFileName : string with get

Property Value

Type: String
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.DesignedClassFullName Property

FormDesignerDataSourceDesignedClassFullName Property
Gets the fully qualified name of designed class.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DesignedClassFullName { get; }
Public ReadOnly Property DesignedClassFullName As String
    Get
public:
virtual property String^ DesignedClassFullName {
    String^ get () sealed;
}
abstract DesignedClassFullName : string with get
override DesignedClassFullName : string with get

Property Value

Type: String

Implements

IFormDesignerDataSourceDesignedClassFullName
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.DesignedComponentAssembly Property

FormDesignerDataSourceDesignedComponentAssembly Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignedComponentAssemblyFileProvider DesignedComponentAssembly { get; }
Public ReadOnly Property DesignedComponentAssembly As DesignedComponentAssemblyFileProvider
    Get
public:
property DesignedComponentAssemblyFileProvider^ DesignedComponentAssembly {
    DesignedComponentAssemblyFileProvider^ get ();
}
member DesignedComponentAssembly : DesignedComponentAssemblyFileProvider with get

Property Value

Type: DesignedComponentAssemblyFileProvider
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.DesignerFileName Property

FormDesignerDataSourceDesignerFileName Property
Gets name of the file with designer generated code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DesignerFileName { get; }
Public ReadOnly Property DesignerFileName As String
    Get
public:
virtual property String^ DesignerFileName {
    String^ get () sealed;
}
abstract DesignerFileName : string with get
override DesignerFileName : string with get

Property Value

Type: String

Implements

IFormDesignerDataSourceDesignerFileName
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.IsModified Property

FormDesignerDataSourceIsModified Property
Represents a value indicating whether designer content has been modified since last save.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModified { get; set; }
Public Property IsModified As Boolean
    Get
    Set
public:
virtual property bool IsModified {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsModified : bool with get, set
override IsModified : bool with get, set

Property Value

Type: Boolean

Implements

IFormDesignerDataSourceIsModified
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.ResourceFileName Property

FormDesignerDataSourceResourceFileName Property

Note: This API is now obsolete.

Gets name of the resource file.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use DefaultResourceFileName instead.")]
public string ResourceFileName { get; }
<ObsoleteAttribute("Use DefaultResourceFileName instead.")>
Public ReadOnly Property ResourceFileName As String
    Get
public:
[ObsoleteAttribute(L"Use DefaultResourceFileName instead.")]
property String^ ResourceFileName {
    String^ get ();
}
[<ObsoleteAttribute("Use DefaultResourceFileName instead.")>]
member ResourceFileName : string with get

Property Value

Type: String
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.UserCodeFileName Property

FormDesignerDataSourceUserCodeFileName Property
Gets name of the file with user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserCodeFileName { get; }
Public ReadOnly Property UserCodeFileName As String
    Get
public:
virtual property String^ UserCodeFileName {
    String^ get () sealed;
}
abstract UserCodeFileName : string with get
override UserCodeFileName : string with get

Property Value

Type: String

Implements

IFormDesignerDataSourceUserCodeFileName
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource Events

FormDesignerDataSource Events

The FormDesignerDataSource type exposes the following members.

Events
 | Name | Description
Public event | ResourceCultureAdded |
Top
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerDataSource.ResourceCultureAdded Event

FormDesignerDataSourceResourceCultureAdded Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ResourceCultureAddedEventArgs> ResourceCultureAdded
Public Event ResourceCultureAdded As EventHandler(Of ResourceCultureAddedEventArgs)
public:
virtual  event EventHandler<ResourceCultureAddedEventArgs^>^ ResourceCultureAdded {
    void add (EventHandler<ResourceCultureAddedEventArgs^>^ value);
    void remove (EventHandler<ResourceCultureAddedEventArgs^>^ value);
}
abstract ResourceCultureAdded : IEvent<EventHandler<ResourceCultureAddedEventArgs>,
    ResourceCultureAddedEventArgs>
override ResourceCultureAdded : IEvent<EventHandler<ResourceCultureAddedEventArgs>,
    ResourceCultureAddedEventArgs>

Value

Type: SystemEventHandlerResourceCultureAddedEventArgs

Implements

IFormDesignerDataSourceResourceCultureAdded
See Also

Reference

FormDesignerDataSource Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext Class

FormDesignerHostContext Class
Encapsulates designer host together with the actual form designer control and its state.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsFormDesignerHostContext

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormDesignerHostContext : IFormDesignerHostContext,
    IDisposable
Public Class FormDesignerHostContext
    Implements IFormDesignerHostContext, IDisposable
public ref class FormDesignerHostContext : IFormDesignerHostContext,
    IDisposable
type FormDesignerHostContext =
    class
        interface IFormDesignerHostContext
        interface IDisposable
    end

The FormDesignerHostContext type exposes the following members.

Constructors
 | Name | Description
Public method | FormDesignerHostContext | Initializes a new instance of the FormDesignerHostContext class with specified settings.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes FormDesignerHostContext object and releases all associated resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RaiseComponentChanged |
Public method | Save | Saves designer's content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DesignerControl | Gets the view for the root designer.
Public property | DesignerHost | Gets IDesignerHost object encapsulated in this host.
Public property | DesignerLoader | Gets an object provides load and save designer's content functionality.
Public property | EventBindingService | Gets an object provides a service for registering event handlers for component events.
Public property | Owner | Gets an actual form designer control.
Public property | PrimarySelection | Gets first selected component or control.
Public property | ResourceService | Gets an object provides functionality to access resource readers and writers for specific System.Globalization.CultureInfo resource types.
Public property | SelectedComponents | Gets or sets list of selected components or controls.
Public property | ServiceContainer | Gets a container for designer-related services.
Public property | Source | Gets data source of the designer control.
Public property | ToolboxService | Gets an object provides communication between the designer and toolbox.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext Constructor

FormDesignerHostContext Constructor
Initializes a new instance of the FormDesignerHostContext class with specified settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormDesignerHostContext(
    FormDesignerControl owner,
    IFormDesignerDataSource source
)
Public Sub New (
    owner As FormDesignerControl,
    source As IFormDesignerDataSource
)
public:
FormDesignerHostContext(
    FormDesignerControl^ owner,
    IFormDesignerDataSource^ source
)
new :
        owner : FormDesignerControl *
        source : IFormDesignerDataSource -> FormDesignerHostContext

Parameters

owner
Type: Alternet.FormDesigner.WinFormsFormDesignerControl
FormDesignerControl that owns this new instance.
source
Type: Alternet.FormDesigner.WinFormsIFormDesignerDataSource
Data source of the designer control.
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext Methods

FormDesignerHostContext Methods

The FormDesignerHostContext type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes FormDesignerHostContext object and releases all associated resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RaiseComponentChanged |
Public method | Save | Saves designer's content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.Dispose Method

FormDesignerHostContextDispose Method
Disposes FormDesignerHostContext object and releases all associated resources.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.RaiseComponentChanged Method

FormDesignerHostContextRaiseComponentChanged Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RaiseComponentChanged(
    Object changedComponent
)
Public Sub RaiseComponentChanged (
    changedComponent As Object
)
public:
virtual void RaiseComponentChanged(
    Object^ changedComponent
) sealed
abstract RaiseComponentChanged :
        changedComponent : Object -> unit
override RaiseComponentChanged :
        changedComponent : Object -> unit

Parameters

changedComponent
Type: SystemObject

Implements

IFormDesignerHostContextRaiseComponentChanged(Object)
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.Save Method

FormDesignerHostContextSave Method
Saves designer's content.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
virtual void Save() sealed
abstract Save : unit -> unit
override Save : unit -> unit

Implements

IFormDesignerHostContextSave
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext Properties

FormDesignerHostContext Properties

The FormDesignerHostContext type exposes the following members.

Properties
 | Name | Description
Public property | DesignerControl | Gets the view for the root designer.
Public property | DesignerHost | Gets IDesignerHost object encapsulated in this host.
Public property | DesignerLoader | Gets an object provides load and save designer's content functionality.
Public property | EventBindingService | Gets an object provides a service for registering event handlers for component events.
Public property | Owner | Gets an actual form designer control.
Public property | PrimarySelection | Gets first selected component or control.
Public property | ResourceService | Gets an object provides functionality to access resource readers and writers for specific System.Globalization.CultureInfo resource types.
Public property | SelectedComponents | Gets or sets list of selected components or controls.
Public property | ServiceContainer | Gets a container for designer-related services.
Public property | Source | Gets data source of the designer control.
Public property | ToolboxService | Gets an object provides communication between the designer and toolbox.
Top
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.DesignerControl Property

FormDesignerHostContextDesignerControl Property
Gets the view for the root designer.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Control DesignerControl { get; }
Public ReadOnly Property DesignerControl As Control
    Get
public:
virtual property Control^ DesignerControl {
    Control^ get () sealed;
}
abstract DesignerControl : Control with get
override DesignerControl : Control with get

Property Value

Type: Control

Implements

IFormDesignerHostContextDesignerControl
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.DesignerHost Property

FormDesignerHostContextDesignerHost Property
Gets IDesignerHost object encapsulated in this host.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDesignerHost DesignerHost { get; }
Public ReadOnly Property DesignerHost As IDesignerHost
    Get
public:
virtual property IDesignerHost^ DesignerHost {
    IDesignerHost^ get () sealed;
}
abstract DesignerHost : IDesignerHost with get
override DesignerHost : IDesignerHost with get

Property Value

Type: IDesignerHost

Implements

IFormDesignerHostContextDesignerHost
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.DesignerLoader Property

FormDesignerHostContextDesignerLoader Property
Gets an object provides load and save designer's content functionality.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerLoader DesignerLoader { get; }
Public ReadOnly Property DesignerLoader As IFormDesignerLoader
    Get
public:
virtual property IFormDesignerLoader^ DesignerLoader {
    IFormDesignerLoader^ get () sealed;
}
abstract DesignerLoader : IFormDesignerLoader with get
override DesignerLoader : IFormDesignerLoader with get

Property Value

Type: IFormDesignerLoader

Implements

IFormDesignerHostContextDesignerLoader
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.EventBindingService Property

FormDesignerHostContextEventBindingService Property
Gets an object provides a service for registering event handlers for component events.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEventBindingServiceExtended EventBindingService { get; }
Public ReadOnly Property EventBindingService As IEventBindingServiceExtended
    Get
public:
property IEventBindingServiceExtended^ EventBindingService {
    IEventBindingServiceExtended^ get ();
}
member EventBindingService : IEventBindingServiceExtended with get

Property Value

Type: IEventBindingServiceExtended
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.Owner Property

FormDesignerHostContextOwner Property
Gets an actual form designer control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerControl Owner { get; }
Public ReadOnly Property Owner As IFormDesignerControl
    Get
public:
virtual property IFormDesignerControl^ Owner {
    IFormDesignerControl^ get () sealed;
}
abstract Owner : IFormDesignerControl with get
override Owner : IFormDesignerControl with get

Property Value

Type: IFormDesignerControl

Implements

IFormDesignerHostContextOwner
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.PrimarySelection Property

FormDesignerHostContextPrimarySelection Property
Gets first selected component or control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IComponent PrimarySelection { get; }
Public ReadOnly Property PrimarySelection As IComponent
    Get
public:
virtual property IComponent^ PrimarySelection {
    IComponent^ get () sealed;
}
abstract PrimarySelection : IComponent with get
override PrimarySelection : IComponent with get

Property Value

Type: IComponent

Implements

IFormDesignerHostContextPrimarySelection
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.ResourceService Property

FormDesignerHostContextResourceService Property
Gets an object provides functionality to access resource readers and writers for specific System.Globalization.CultureInfo resource types.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IResourceServiceExtended ResourceService { get; }
Public ReadOnly Property ResourceService As IResourceServiceExtended
    Get
public:
property IResourceServiceExtended^ ResourceService {
    IResourceServiceExtended^ get ();
}
member ResourceService : IResourceServiceExtended with get

Property Value

Type: IResourceServiceExtended
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.SelectedComponents Property

FormDesignerHostContextSelectedComponents Property
Gets or sets list of selected components or controls.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<IComponent> SelectedComponents { get; set; }
Public Property SelectedComponents As IEnumerable(Of IComponent)
    Get
    Set
public:
virtual property IEnumerable<IComponent^>^ SelectedComponents {
    IEnumerable<IComponent^>^ get () sealed;
    void set (IEnumerable<IComponent^>^ value) sealed;
}
abstract SelectedComponents : IEnumerable<IComponent> with get, set
override SelectedComponents : IEnumerable<IComponent> with get, set

Property Value

Type: IEnumerableIComponent

Implements

IFormDesignerHostContextSelectedComponents
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.ServiceContainer Property

FormDesignerHostContextServiceContainer Property
Gets a container for designer-related services.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IServiceContainer ServiceContainer { get; }
Public ReadOnly Property ServiceContainer As IServiceContainer
    Get
public:
virtual property IServiceContainer^ ServiceContainer {
    IServiceContainer^ get () sealed;
}
abstract ServiceContainer : IServiceContainer with get
override ServiceContainer : IServiceContainer with get

Property Value

Type: IServiceContainer

Implements

IFormDesignerHostContextServiceContainer
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.Source Property

FormDesignerHostContextSource Property
Gets data source of the designer control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerDataSource Source { get; }
Public ReadOnly Property Source As IFormDesignerDataSource
    Get
public:
virtual property IFormDesignerDataSource^ Source {
    IFormDesignerDataSource^ get () sealed;
}
abstract Source : IFormDesignerDataSource with get
override Source : IFormDesignerDataSource with get

Property Value

Type: IFormDesignerDataSource

Implements

IFormDesignerHostContextSource
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerHostContext.ToolboxService Property

FormDesignerHostContextToolboxService Property
Gets an object provides communication between the designer and toolbox.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IToolboxServiceExtended ToolboxService { get; }
Public ReadOnly Property ToolboxService As IToolboxServiceExtended
    Get
public:
virtual property IToolboxServiceExtended^ ToolboxService {
    IToolboxServiceExtended^ get () sealed;
}
abstract ToolboxService : IToolboxServiceExtended with get
override ToolboxService : IToolboxServiceExtended with get

Property Value

Type: IToolboxServiceExtended

Implements

IFormDesignerHostContextToolboxService
See Also

Reference

FormDesignerHostContext Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerOptions Class

FormDesignerOptions Class
Provides designer options for grid settings, grid size, snap lines and smart tags.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsFormDesignerOptions

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class FormDesignerOptions
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class FormDesignerOptions
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class FormDesignerOptions
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type FormDesignerOptions =  class end

The FormDesignerOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FormDesignerOptions | Initializes a new instance of the FormDesignerOptions class with specified designer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | GridSize | Sets the default X and Y grid setting on designer. Effective only when UseSnapLines is set false.
Public property | ShowGrid | Controls whether designer should display a sizing grid. Effective only when UseSnapLines is set false.
Public property | SnapToGrid | Controls whether designer should snap to grid dots. Effective only when UseSnapLines is set false.
Public property | UseSmartTags | Controls whether designer should show smart tag popup windows. Designer needs to be reloaded for this change to take effect.
Public property | UseSnapLines | Controls whether designer should use snap lines. If true, snap lines will be used as guides. If false, grid lines will be used. Designer needs to be reloaded for this change to take effect.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


FormDesignerOptions Constructor

FormDesignerOptions Constructor
Initializes a new instance of the FormDesignerOptions class with specified designer.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormDesignerOptions(
    FormDesignerControl designer
)
Public Sub New (
    designer As FormDesignerControl
)
public:
FormDesignerOptions(
    FormDesignerControl^ designer
)
new :
        designer : FormDesignerControl -> FormDesignerOptions

Parameters

designer
Type: Alternet.FormDesigner.WinFormsFormDesignerControl
FormDesignerControl which behaviour will be defined by this new instance.
See Also

Reference

FormDesignerOptions Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerOptions Methods

FormDesignerOptions Methods

The FormDesignerOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormDesignerOptions Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerOptions Properties

FormDesignerOptions Properties

The FormDesignerOptions type exposes the following members.

Properties
 | Name | Description
Public property | GridSize | Sets the default X and Y grid setting on designer. Effective only when UseSnapLines is set false.
Public property | ShowGrid | Controls whether designer should display a sizing grid. Effective only when UseSnapLines is set false.
Public property | SnapToGrid | Controls whether designer should snap to grid dots. Effective only when UseSnapLines is set false.
Public property | UseSmartTags | Controls whether designer should show smart tag popup windows. Designer needs to be reloaded for this change to take effect.
Public property | UseSnapLines | Controls whether designer should use snap lines. If true, snap lines will be used as guides. If false, grid lines will be used. Designer needs to be reloaded for this change to take effect.
Top
See Also

Reference

FormDesignerOptions Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerOptions.GridSize Property

FormDesignerOptionsGridSize Property
Sets the default X and Y grid setting on designer. Effective only when UseSnapLines is set false.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Size GridSize { get; set; }
Public Property GridSize As Size
    Get
    Set
public:
property Size GridSize {
    Size get ();
    void set (Size value);
}
member GridSize : Size with get, set

Property Value

Type: Size
See Also

Reference

FormDesignerOptions Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerOptions.ShowGrid Property

FormDesignerOptionsShowGrid Property
Controls whether designer should display a sizing grid. Effective only when UseSnapLines is set false.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGrid { get; set; }
Public Property ShowGrid As Boolean
    Get
    Set
public:
property bool ShowGrid {
    bool get ();
    void set (bool value);
}
member ShowGrid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FormDesignerOptions Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerOptions.SnapToGrid Property

FormDesignerOptionsSnapToGrid Property
Controls whether designer should snap to grid dots. Effective only when UseSnapLines is set false.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SnapToGrid { get; set; }
Public Property SnapToGrid As Boolean
    Get
    Set
public:
property bool SnapToGrid {
    bool get ();
    void set (bool value);
}
member SnapToGrid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FormDesignerOptions Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerOptions.UseSmartTags Property

FormDesignerOptionsUseSmartTags Property
Controls whether designer should show smart tag popup windows. Designer needs to be reloaded for this change to take effect.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseSmartTags { get; set; }
Public Property UseSmartTags As Boolean
    Get
    Set
public:
property bool UseSmartTags {
    bool get ();
    void set (bool value);
}
member UseSmartTags : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FormDesignerOptions Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerOptions.UseSnapLines Property

FormDesignerOptionsUseSnapLines Property
Controls whether designer should use snap lines. If true, snap lines will be used as guides. If false, grid lines will be used. Designer needs to be reloaded for this change to take effect.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseSnapLines { get; set; }
Public Property UseSnapLines As Boolean
    Get
    Set
public:
property bool UseSnapLines {
    bool get ();
    void set (bool value);
}
member UseSnapLines : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FormDesignerOptions Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerTextSourceOperations Class

FormDesignerTextSourceOperations Class
Represents operations applied to IFormDesignerTextSource content.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperations

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FormDesignerTextSourceOperations
Public NotInheritable Class FormDesignerTextSourceOperations
public ref class FormDesignerTextSourceOperations abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FormDesignerTextSourceOperations =  class end
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


FormDesignerTextSourceOperations.TextInsertionOperation Class

FormDesignerTextSourceOperationsTextInsertionOperation Class
Represents properties applied to the text insertion operation.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextInsertionOperation

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextInsertionOperation
Public Class TextInsertionOperation
public ref class TextInsertionOperation
type TextInsertionOperation =  class end

The FormDesignerTextSourceOperationsTextInsertionOperation type exposes the following members.

Constructors
 | Name | Description
Public method | FormDesignerTextSourceOperationsTextInsertionOperation | Initializes a new instance of the FormDesignerTextSourceOperationsTextInsertionOperation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | InsertionPoint | Gets or sets a position to insert text.
Public property | Text | Gets or sets a string to insert.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


FormDesignerTextSourceOperations.TextInsertionOperation Constructor

FormDesignerTextSourceOperationsTextInsertionOperation Constructor
Initializes a new instance of the FormDesignerTextSourceOperationsTextInsertionOperation class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextInsertionOperation()
Public Sub New
public:
TextInsertionOperation()
new : unit -> TextInsertionOperation
See Also

Reference

FormDesignerTextSourceOperationsTextInsertionOperation Class
Alternet.FormDesigner.WinForms Namespace


TextInsertionOperation Methods

TextInsertionOperation Methods

The FormDesignerTextSourceOperationsTextInsertionOperation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormDesignerTextSourceOperationsTextInsertionOperation Class
Alternet.FormDesigner.WinForms Namespace


TextInsertionOperation Properties

TextInsertionOperation Properties

The FormDesignerTextSourceOperationsTextInsertionOperation type exposes the following members.

Properties
 | Name | Description
Public property | InsertionPoint | Gets or sets a position to insert text.
Public property | Text | Gets or sets a string to insert.
Top
See Also

Reference

FormDesignerTextSourceOperationsTextInsertionOperation Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerTextSourceOperations.TextInsertionOperation.InsertionPoint Property

FormDesignerTextSourceOperationsTextInsertionOperationInsertionPoint Property
Gets or sets a position to insert text.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point InsertionPoint { get; set; }
Public Property InsertionPoint As Point
    Get
    Set
public:
property Point InsertionPoint {
    Point get ();
    void set (Point value);
}
member InsertionPoint : Point with get, set

Property Value

Type: Point
See Also

Reference

FormDesignerTextSourceOperationsTextInsertionOperation Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerTextSourceOperations.TextInsertionOperation.Text Property

FormDesignerTextSourceOperationsTextInsertionOperationText Property
Gets or sets a string to insert.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

FormDesignerTextSourceOperationsTextInsertionOperation Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerTextSourceOperations.TextReplacementOperation Class

FormDesignerTextSourceOperationsTextReplacementOperation Class
Represents properties applied to the text replacement operation.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextReplacementOperation

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextReplacementOperation
Public Class TextReplacementOperation
public ref class TextReplacementOperation
type TextReplacementOperation =  class end

The FormDesignerTextSourceOperationsTextReplacementOperation type exposes the following members.

Constructors
 | Name | Description
Public method | FormDesignerTextSourceOperationsTextReplacementOperation | Initializes a new instance of the FormDesignerTextSourceOperationsTextReplacementOperation class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | NewText | Gets or set a string replaces old text.
Public property | OldTextRegion | Gets or sets an area where new text will be placed.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


FormDesignerTextSourceOperations.TextReplacementOperation Constructor

FormDesignerTextSourceOperationsTextReplacementOperation Constructor
Initializes a new instance of the FormDesignerTextSourceOperationsTextReplacementOperation class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextReplacementOperation()
Public Sub New
public:
TextReplacementOperation()
new : unit -> TextReplacementOperation
See Also

Reference

FormDesignerTextSourceOperationsTextReplacementOperation Class
Alternet.FormDesigner.WinForms Namespace


TextReplacementOperation Methods

TextReplacementOperation Methods

The FormDesignerTextSourceOperationsTextReplacementOperation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormDesignerTextSourceOperationsTextReplacementOperation Class
Alternet.FormDesigner.WinForms Namespace


TextReplacementOperation Properties

TextReplacementOperation Properties

The FormDesignerTextSourceOperationsTextReplacementOperation type exposes the following members.

Properties
 | Name | Description
Public property | NewText | Gets or set a string replaces old text.
Public property | OldTextRegion | Gets or sets an area where new text will be placed.
Top
See Also

Reference

FormDesignerTextSourceOperationsTextReplacementOperation Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerTextSourceOperations.TextReplacementOperation.NewText Property

FormDesignerTextSourceOperationsTextReplacementOperationNewText Property
Gets or set a string replaces old text.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string NewText { get; set; }
Public Property NewText As String
    Get
    Set
public:
property String^ NewText {
    String^ get ();
    void set (String^ value);
}
member NewText : string with get, set

Property Value

Type: String
See Also

Reference

FormDesignerTextSourceOperationsTextReplacementOperation Class
Alternet.FormDesigner.WinForms Namespace


FormDesignerTextSourceOperations.TextReplacementOperation.OldTextRegion Property

FormDesignerTextSourceOperationsTextReplacementOperationOldTextRegion Property
Gets or sets an area where new text will be placed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle OldTextRegion { get; set; }
Public Property OldTextRegion As Rectangle
    Get
    Set
public:
property Rectangle OldTextRegion {
    Rectangle get ();
    void set (Rectangle value);
}
member OldTextRegion : Rectangle with get, set

Property Value

Type: Rectangle
See Also

Reference

FormDesignerTextSourceOperationsTextReplacementOperation Class
Alternet.FormDesigner.WinForms Namespace


IDesignedComponentAssemblyProvider Interface

IDesignedComponentAssemblyProvider Interface

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDesignedComponentAssemblyProvider
Public Interface IDesignedComponentAssemblyProvider
public interface class IDesignedComponentAssemblyProvider
type IDesignedComponentAssemblyProvider =  interface end

The IDesignedComponentAssemblyProvider type exposes the following members.

Methods
 | Name | Description
Public method | NotifyAssemblyChanged |
Public method | TryGetAssemblyBytes |
Top
Events
 | Name | Description
Public event | AssemblyChanged |
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IDesignedComponentAssemblyProvider Methods

IDesignedComponentAssemblyProvider Methods

The IDesignedComponentAssemblyProvider type exposes the following members.

Methods
 | Name | Description
Public method | NotifyAssemblyChanged |
Public method | TryGetAssemblyBytes |
Top
See Also

Reference

IDesignedComponentAssemblyProvider Interface
Alternet.FormDesigner.WinForms Namespace


IDesignedComponentAssemblyProvider.NotifyAssemblyChanged Method

IDesignedComponentAssemblyProviderNotifyAssemblyChanged Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void NotifyAssemblyChanged()
Sub NotifyAssemblyChanged
void NotifyAssemblyChanged()
abstract NotifyAssemblyChanged : unit -> unit
See Also

Reference

IDesignedComponentAssemblyProvider Interface
Alternet.FormDesigner.WinForms Namespace


IDesignedComponentAssemblyProvider.TryGetAssemblyBytes Method

IDesignedComponentAssemblyProviderTryGetAssemblyBytes Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool TryGetAssemblyBytes(
    out byte[] assemblyBytes
)
Function TryGetAssemblyBytes (
    <OutAttribute> ByRef assemblyBytes As Byte()
) As Boolean
bool TryGetAssemblyBytes(
    [OutAttribute] array<unsigned char>^% assemblyBytes
)
abstract TryGetAssemblyBytes :
        assemblyBytes : byte[] byref -> bool

Parameters

assemblyBytes
Type: SystemByte

Return Value

Type: Boolean
See Also

Reference

IDesignedComponentAssemblyProvider Interface
Alternet.FormDesigner.WinForms Namespace


IDesignedComponentAssemblyProvider Events

IDesignedComponentAssemblyProvider Events

The IDesignedComponentAssemblyProvider type exposes the following members.

Events
 | Name | Description
Public event | AssemblyChanged |
Top
See Also

Reference

IDesignedComponentAssemblyProvider Interface
Alternet.FormDesigner.WinForms Namespace


IDesignedComponentAssemblyProvider.AssemblyChanged Event

IDesignedComponentAssemblyProviderAssemblyChanged Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler AssemblyChanged
Event AssemblyChanged As EventHandler
 event EventHandler^ AssemblyChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract AssemblyChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IDesignedComponentAssemblyProvider Interface
Alternet.FormDesigner.WinForms Namespace


IEventBindingServiceExtended Interface

IEventBindingServiceExtended Interface
Provides an additional service for registering event handlers for component events.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEventBindingServiceExtended : IEventBindingService
Public Interface IEventBindingServiceExtended
    Inherits IEventBindingService
public interface class IEventBindingServiceExtended : IEventBindingService
type IEventBindingServiceExtended =
    interface
        interface IEventBindingService
    end

The IEventBindingServiceExtended type exposes the following members.

Methods
 | Name | Description
Public method | CreateUniqueMethodName | Creates a unique name for an event-handler method for the specified component and event. (Inherited from IEventBindingService.)
Public method | GetCompatibleMethods | Gets a collection of event-handler methods that have a method signature compatible with the specified event. (Inherited from IEventBindingService.)
Public method | GetEvent | Gets an EventDescriptor for the event that the specified property descriptor represents, if it represents an event. (Inherited from IEventBindingService.)
Public method | GetEventProperties | Converts a set of event descriptors to a set of property descriptors. (Inherited from IEventBindingService.)
Public method | GetEventProperty | Converts a single event descriptor to a property descriptor. (Inherited from IEventBindingService.)
Public method | ShowCode | Displays the user code for the designer. (Inherited from IEventBindingService.)
Public method | ShowCode(Int32) | Displays the user code for the designer at the specified line. (Inherited from IEventBindingService.)
Public method | ShowCode(IComponent, EventDescriptor) | Displays the user code for the specified event. (Inherited from IEventBindingService.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IEventBindingServiceExtended Methods

IEventBindingServiceExtended Methods

The IEventBindingServiceExtended type exposes the following members.

Methods
 | Name | Description
Public method | CreateUniqueMethodName | Creates a unique name for an event-handler method for the specified component and event. (Inherited from IEventBindingService.)
Public method | GetCompatibleMethods | Gets a collection of event-handler methods that have a method signature compatible with the specified event. (Inherited from IEventBindingService.)
Public method | GetEvent | Gets an EventDescriptor for the event that the specified property descriptor represents, if it represents an event. (Inherited from IEventBindingService.)
Public method | GetEventProperties | Converts a set of event descriptors to a set of property descriptors. (Inherited from IEventBindingService.)
Public method | GetEventProperty | Converts a single event descriptor to a property descriptor. (Inherited from IEventBindingService.)
Public method | ShowCode | Displays the user code for the designer. (Inherited from IEventBindingService.)
Public method | ShowCode(Int32) | Displays the user code for the designer at the specified line. (Inherited from IEventBindingService.)
Public method | ShowCode(IComponent, EventDescriptor) | Displays the user code for the specified event. (Inherited from IEventBindingService.)
Top
See Also

Reference

IEventBindingServiceExtended Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands Interface

IFormDesignerCommands Interface
Represents the set of commands that are available to the Form Designer.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFormDesignerCommands
Public Interface IFormDesignerCommands
public interface class IFormDesignerCommands
type IFormDesignerCommands =  interface end

The IFormDesignerCommands type exposes the following members.

Methods
 | Name | Description
Public method | AlignBottom | When implemented by a class, aligns selected control to the bottom of its containing control.
Public method | AlignHorizontalCenters | When implemented by a class, aligns selected control horizontally to the center of its containing control.
Public method | AlignLeft | When implemented by a class, aligns selected control to the left edge of its containing control.
Public method | AlignRight | When implemented by a class, aligns selected control to the right edge of its containing control.
Public method | AlignToGrid | When implemented by a class, aligns selected control to the closest grid.
Public method | AlignTop | When implemented by a class, aligns selected control to the top of its containing control.
Public method | AlignVerticalCenters | When implemented by a class, aligns selected control vertically to the center of its containing control.
Public method | ArrangeBottom | When implemented by a class, arranges selected control along the bottom of a form.
Public method | ArrangeIcons | When implemented by a class, executes ArrangeIcons command.
Public method | ArrangeRight | When implemented by a class, arranges selected control along the right edge of a form.
Public method | BringForward | When implemented by a class, bring forward selected control in the z-order.
Public method | BringToFront | When implemented by a class, bring selected control to the front of the z-order.
Public method | CenterHorizontally | When implemented by a class, center selected control horizontally of its containing control.
Public method | CenterVertically | When implemented by a class, center selected control vertically of its containing control.
Public method | Copy | When implemented by a class, copies selected control content.
Public method | Cut | When implemented by a class, cuts selected control content.
Public method | Delete | When implemented by a class, deletes selected control.
Public method | DocumentOutline | When implemented by a class, executes DocumentOutline command.
Public method | F1Help | When implemented by a class, executes F1Help command.
Public method | Group | When implemented by a class, executes Group command.
Public method | HorizSpaceConcatenate | When implemented by a class, executes HorizSpaceConcatenate command.
Public method | HorizSpaceDecrease | When implemented by a class, executes HorizSpaceDecrease command.
Public method | HorizSpaceIncrease | When implemented by a class, executes HorizSpaceIncrease command.
Public method | HorizSpaceMakeEqual | When implemented by a class, executes HorizSpaceMakeEqual command.
Public method | KeyCancel | When implemented by a class, executes KeyCancel command.
Public method | KeyDefaultAction | When implemented by a class, executes KeyDefaultAction command.
Public method | KeyMoveDown | When implemented by a class, executes KeyMoveDown command.
Public method | KeyMoveLeft | When implemented by a class, executes KeyMoveLeft command.
Public method | KeyMoveRight | When implemented by a class, executes KeyMoveRight command.
Public method | KeyMoveUp | When implemented by a class, executes KeyMoveUp command.
Public method | KeyNudgeDown | When implemented by a class, executes KeyNudgeDown command.
Public method | KeyNudgeHeightDecrease | When implemented by a class, executes KeyNudgeHeightDecrease command.
Public method | KeyNudgeHeightIncrease | When implemented by a class, executes KeyNudgeHeightIncrease command.
Public method | KeyNudgeLeft | When implemented by a class, executes KeyNudgeLeft command.
Public method | KeyNudgeRight | When implemented by a class, executes KeyNudgeRight command.
Public method | KeyNudgeUp | When implemented by a class, executes KeyNudgeUp command.
Public method | KeyNudgeWidthDecrease | When implemented by a class, executes KeyNudgeWidthDecrease command.
Public method | KeyNudgeWidthIncrease | When implemented by a class, executes KeyNudgeWidthIncrease command.
Public method | KeySelectNext | When implemented by a class, executes KeySelectNext command.
Public method | KeySelectPrevious | When implemented by a class, executes KeySelectPrevious command.
Public method | KeySizeHeightDecrease | When implemented by a class, executes KeySizeHeightDecrease command.
Public method | KeySizeHeightIncrease | When implemented by a class, executes KeySizeHeightIncrease command.
Public method | KeySizeWidthDecrease | When implemented by a class, executes KeySizeWidthDecrease command.
Public method | KeySizeWidthIncrease | When implemented by a class, executes KeySizeWidthIncrease command.
Public method | LineupIcons | When implemented by a class, executes LineupIcons command.
Public method | LockControls | When implemented by a class, executes LockControls command.
Public method | MultiLevelRedo | When implemented by a class, executes MultiLevelRedo command.
Public method | MultiLevelUndo | When implemented by a class, executes MultiLevelUndo command.
Public method | Paste | When implemented by a class, executes Paste command.
Public method | Properties | When implemented by a class, executes Properties command.
Public method | PropertiesWindow | When implemented by a class, executes PropertiesWindow command.
Public method | Redo | When implemented by a class, executes Redo command.
Public method | Replace | When implemented by a class, executes Replace command.
Public method | SelectAll | When implemented by a class, executes SelectAll command.
Public method | SendBackward | When implemented by a class, executes SendBackward command.
Public method | SendToBack | When implemented by a class, executes SendToBack command.
Public method | ShowGrid | When implemented by a class, executes ShowGrid command.
Public method | ShowLargeIcons | When implemented by a class, executes ShowLargeIcons command.
Public method | SizeToControl | When implemented by a class, executes SizeToControl command.
Public method | SizeToControlHeight | When implemented by a class, executes SizeToControlHeight command.
Public method | SizeToControlWidth | When implemented by a class, executes SizeToControlWidth command.
Public method | SizeToFit | When implemented by a class, executes SizeToFit command.
Public method | SizeToGrid | When implemented by a class, executes SizeToGrid command.
Public method | SnapToGrid | When implemented by a class, executes SnapToGrid command.
Public method | TabOrder | When implemented by a class, executes TabOrder command.
Public method | Undo | When implemented by a class, executes Undo command.
Public method | Ungroup | When implemented by a class, executes Ungroup command.
Public method | VerbFirst | When implemented by a class, executes VerbFirst command.
Public method | VerbLast | When implemented by a class, executes VerbLast command.
Public method | VertSpaceConcatenate | When implemented by a class, executes VertSpaceConcatenate command.
Public method | VertSpaceDecrease | When implemented by a class, executes VertSpaceDecrease command.
Public method | VertSpaceIncrease | When implemented by a class, executes VertSpaceIncrease command.
Public method | VertSpaceMakeEqual | When implemented by a class, executes VertSpaceMakeEqual command.
Public method | ViewCode | When implemented by a class, executes ViewCode command.
Public method | ViewGrid | When implemented by a class, executes ViewGrid command.
Top
Properties
 | Name | Description
Public property | CanAlignBottom | When implemented by a class, gets a value indicating whether selected controls can be aligned to the bottom of its containing control.
Public property | CanAlignHorizontalCenters | When implemented by a class, gets a value indicating whether selected controls can be aligned horizontally to the center of its containing control.
Public property | CanAlignLeft | When implemented by a class, gets a value indicating whether selected controls can be aligned to the left edge of its containing control.
Public property | CanAlignRight | When implemented by a class, gets a value indicating whether selected controls can be aligned to the right edge of its containing control.
Public property | CanAlignToGrid | When implemented by a class, gets a value indicating whether selected controls can be aligned to the closest grid.
Public property | CanAlignTop | When implemented by a class, gets a value indicating whether selected controls can be aligned to the top of its containing control.
Public property | CanAlignVerticalCenters | When implemented by a class, gets a value indicating whether selected controls can be aligned vertically to the center of its containing control.
Public property | CanArrangeBottom | When implemented by a class, gets a value indicating whether selected controls can be arranged along the bottom of a form.
Public property | CanArrangeIcons | When implemented by a class, indicates whether ArrangeIcons command can be executed.
Public property | CanArrangeRight | When implemented by a class, gets a value indicating whether selected controls can be arranged along the right edge of a form.
Public property | CanBringForward | When implemented by a class, gets a value indicating whether selected controls can be bring forward in the z-order.
Public property | CanBringToFront | When implemented by a class, gets a value indicating whether selected controls can be bring to the front of the z-order.
Public property | CanCenterHorizontally | When implemented by a class, gets a value indicating whether selected controls can be centered horizontally of its containing control.
Public property | CanCenterVertically | When implemented by a class, gets a value indicating whether selected controls can be centered vertically of its containing control.
Public property | CanCopy | When implemented by a class, indicates whether selected controls can be copied.
Public property | CanCut | When implemented by a class, indicates whether selected controls can be cut.
Public property | CanDelete | When implemented by a class, indicates whether selected controls can be deleted.
Public property | CanDocumentOutline | When implemented by a class, indicates whether DocumentOutline command can be executed.
Public property | CanF1Help | When implemented by a class, indicates whether F1Help command can be executed.
Public property | CanGroup | When implemented by a class, indicates whether Group command can be executed.
Public property | CanHorizSpaceConcatenate | When implemented by a class, indicates whether HorizSpaceConcatenate command can be executed.
Public property | CanHorizSpaceDecrease | When implemented by a class, indicates whether HorizSpaceDecrease command can be executed.
Public property | CanHorizSpaceIncrease | When implemented by a class, indicates whether HorizSpaceIncrease command can be executed.
Public property | CanHorizSpaceMakeEqual | When implemented by a class, indicates whether HorizSpaceMakeEqual command can be executed.
Public property | CanKeyCancel | When implemented by a class, indicates whether KeyCancel command can be executed.
Public property | CanKeyDefaultAction | When implemented by a class, indicates whether KeyDefaultAction command can be executed.
Public property | CanKeyMoveDown | When implemented by a class, gets a value indicating whether selected controls can be moved down by key.
Public property | CanKeyMoveLeft | When implemented by a class, gets a value indicating whether selected controls can be moved left by key.
Public property | CanKeyMoveRight | When implemented by a class, gets a value indicating whether selected controls can be moved right by key.
Public property | CanKeyMoveUp | When implemented by a class, gets a value indicating whether selected controls can be moved up by key.
Public property | CanKeyNudgeDown | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge down key handler.
Public property | CanKeyNudgeHeightDecrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge height decrease key handler.
Public property | CanKeyNudgeHeightIncrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge height increase key handler.
Public property | CanKeyNudgeLeft | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge left key handler.
Public property | CanKeyNudgeRight | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge right key handler.
Public property | CanKeyNudgeUp | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge up key handler.
Public property | CanKeyNudgeWidthDecrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge width decrease key handler.
Public property | CanKeyNudgeWidthIncrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge width increase key handler.
Public property | CanKeySelectNext | When implemented by a class, indicates whether KeySelectNext command can be executed.
Public property | CanKeySelectPrevious | When implemented by a class, indicates whether KeySelectPrevious command can be executed.
Public property | CanKeySizeHeightDecrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the size height decrease key handler.
Public property | CanKeySizeHeightIncrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the size height increase key handler.
Public property | CanKeySizeWidthDecrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the size width decrease key handler.
Public property | CanKeySizeWidthIncrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the size width increase key handler.
Public property | CanLineupIcons | When implemented by a class, indicates whether LineupIcons command can be executed.
Public property | CanLockControls | When implemented by a class, indicates whether LockControls command can be executed.
Public property | CanMultiLevelRedo | When implemented by a class, indicates whether MultiLevelRedo command can be executed.
Public property | CanMultiLevelUndo | When implemented by a class, indicates whether HorizSpaceDecrease command can be executed.
Public property | CanPaste | When implemented by a class, indicates whether Paste command can be executed.
Public property | CanProperties | When implemented by a class, indicates whether Properties command can be executed.
Public property | CanPropertiesWindow | When implemented by a class, indicates whether PropertiesWindow command can be executed.
Public property | CanRedo | When implemented by a class, indicates whether Redo command can be executed.
Public property | CanReplace | When implemented by a class, indicates whether Replace command can be executed.
Public property | CanSelectAll | When implemented by a class, indicates whether SelectAll command can be executed.
Public property | CanSendBackward | When implemented by a class, indicates whether SendBackward command can be executed.
Public property | CanSendToBack | When implemented by a class, indicates whether SendToBack command can be executed.
Public property | CanShowGrid | When implemented by a class, indicates whether ShowGrid command can be executed.
Public property | CanShowLargeIcons | When implemented by a class, indicates whether ShowLargeIcons command can be executed.
Public property | CanSizeToControl | When implemented by a class, indicates whether SizeToControl command can be executed.
Public property | CanSizeToControlHeight | When implemented by a class, indicates whether SizeToControlHeight command can be executed.
Public property | CanSizeToControlWidth | When implemented by a class, indicates whether SizeToControlWidth command can be executed.
Public property | CanSizeToFit | When implemented by a class, indicates whether SizeToFit command can be executed.
Public property | CanSizeToGrid | When implemented by a class, indicates whether SizeToGrid command can be executed.
Public property | CanSnapToGrid | When implemented by a class, indicates whether SnapToGrid command can be executed.
Public property | CanTabOrder | When implemented by a class, indicates whether TabOrder command can be executed.
Public property | CanUndo | When implemented by a class, indicates whether Undo command can be executed.
Public property | CanUngroup | When implemented by a class, indicates whether Ungroup command can be executed.
Public property | CanVerbFirst | When implemented by a class, indicates whether VerbFirst command can be executed.
Public property | CanVerbLast | When implemented by a class, indicates whether VerbLast command can be executed.
Public property | CanVertSpaceConcatenate | When implemented by a class, indicates whether VertSpaceConcatenate command can be executed.
Public property | CanVertSpaceDecrease | When implemented by a class, indicates whether VertSpaceDecrease command can be executed.
Public property | CanVertSpaceIncrease | When implemented by a class, indicates whether VertSpaceIncrease command can be executed.
Public property | CanVertSpaceMakeEqual | When implemented by a class, indicates whether VertSpaceMakeEqual command can be executed.
Public property | CanViewCode | When implemented by a class, indicates whether ViewCode command can be executed.
Public property | CanViewGrid | When implemented by a class, indicates whether ViewGrid command can be executed.
Public property | IsLockControlsChecked | When implemented by a class, indicates whether all controls on designer surface is locked.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands Methods

IFormDesignerCommands Methods

The IFormDesignerCommands type exposes the following members.

Methods
 | Name | Description
Public method | AlignBottom | When implemented by a class, aligns selected control to the bottom of its containing control.
Public method | AlignHorizontalCenters | When implemented by a class, aligns selected control horizontally to the center of its containing control.
Public method | AlignLeft | When implemented by a class, aligns selected control to the left edge of its containing control.
Public method | AlignRight | When implemented by a class, aligns selected control to the right edge of its containing control.
Public method | AlignToGrid | When implemented by a class, aligns selected control to the closest grid.
Public method | AlignTop | When implemented by a class, aligns selected control to the top of its containing control.
Public method | AlignVerticalCenters | When implemented by a class, aligns selected control vertically to the center of its containing control.
Public method | ArrangeBottom | When implemented by a class, arranges selected control along the bottom of a form.
Public method | ArrangeIcons | When implemented by a class, executes ArrangeIcons command.
Public method | ArrangeRight | When implemented by a class, arranges selected control along the right edge of a form.
Public method | BringForward | When implemented by a class, bring forward selected control in the z-order.
Public method | BringToFront | When implemented by a class, bring selected control to the front of the z-order.
Public method | CenterHorizontally | When implemented by a class, center selected control horizontally of its containing control.
Public method | CenterVertically | When implemented by a class, center selected control vertically of its containing control.
Public method | Copy | When implemented by a class, copies selected control content.
Public method | Cut | When implemented by a class, cuts selected control content.
Public method | Delete | When implemented by a class, deletes selected control.
Public method | DocumentOutline | When implemented by a class, executes DocumentOutline command.
Public method | F1Help | When implemented by a class, executes F1Help command.
Public method | Group | When implemented by a class, executes Group command.
Public method | HorizSpaceConcatenate | When implemented by a class, executes HorizSpaceConcatenate command.
Public method | HorizSpaceDecrease | When implemented by a class, executes HorizSpaceDecrease command.
Public method | HorizSpaceIncrease | When implemented by a class, executes HorizSpaceIncrease command.
Public method | HorizSpaceMakeEqual | When implemented by a class, executes HorizSpaceMakeEqual command.
Public method | KeyCancel | When implemented by a class, executes KeyCancel command.
Public method | KeyDefaultAction | When implemented by a class, executes KeyDefaultAction command.
Public method | KeyMoveDown | When implemented by a class, executes KeyMoveDown command.
Public method | KeyMoveLeft | When implemented by a class, executes KeyMoveLeft command.
Public method | KeyMoveRight | When implemented by a class, executes KeyMoveRight command.
Public method | KeyMoveUp | When implemented by a class, executes KeyMoveUp command.
Public method | KeyNudgeDown | When implemented by a class, executes KeyNudgeDown command.
Public method | KeyNudgeHeightDecrease | When implemented by a class, executes KeyNudgeHeightDecrease command.
Public method | KeyNudgeHeightIncrease | When implemented by a class, executes KeyNudgeHeightIncrease command.
Public method | KeyNudgeLeft | When implemented by a class, executes KeyNudgeLeft command.
Public method | KeyNudgeRight | When implemented by a class, executes KeyNudgeRight command.
Public method | KeyNudgeUp | When implemented by a class, executes KeyNudgeUp command.
Public method | KeyNudgeWidthDecrease | When implemented by a class, executes KeyNudgeWidthDecrease command.
Public method | KeyNudgeWidthIncrease | When implemented by a class, executes KeyNudgeWidthIncrease command.
Public method | KeySelectNext | When implemented by a class, executes KeySelectNext command.
Public method | KeySelectPrevious | When implemented by a class, executes KeySelectPrevious command.
Public method | KeySizeHeightDecrease | When implemented by a class, executes KeySizeHeightDecrease command.
Public method | KeySizeHeightIncrease | When implemented by a class, executes KeySizeHeightIncrease command.
Public method | KeySizeWidthDecrease | When implemented by a class, executes KeySizeWidthDecrease command.
Public method | KeySizeWidthIncrease | When implemented by a class, executes KeySizeWidthIncrease command.
Public method | LineupIcons | When implemented by a class, executes LineupIcons command.
Public method | LockControls | When implemented by a class, executes LockControls command.
Public method | MultiLevelRedo | When implemented by a class, executes MultiLevelRedo command.
Public method | MultiLevelUndo | When implemented by a class, executes MultiLevelUndo command.
Public method | Paste | When implemented by a class, executes Paste command.
Public method | Properties | When implemented by a class, executes Properties command.
Public method | PropertiesWindow | When implemented by a class, executes PropertiesWindow command.
Public method | Redo | When implemented by a class, executes Redo command.
Public method | Replace | When implemented by a class, executes Replace command.
Public method | SelectAll | When implemented by a class, executes SelectAll command.
Public method | SendBackward | When implemented by a class, executes SendBackward command.
Public method | SendToBack | When implemented by a class, executes SendToBack command.
Public method | ShowGrid | When implemented by a class, executes ShowGrid command.
Public method | ShowLargeIcons | When implemented by a class, executes ShowLargeIcons command.
Public method | SizeToControl | When implemented by a class, executes SizeToControl command.
Public method | SizeToControlHeight | When implemented by a class, executes SizeToControlHeight command.
Public method | SizeToControlWidth | When implemented by a class, executes SizeToControlWidth command.
Public method | SizeToFit | When implemented by a class, executes SizeToFit command.
Public method | SizeToGrid | When implemented by a class, executes SizeToGrid command.
Public method | SnapToGrid | When implemented by a class, executes SnapToGrid command.
Public method | TabOrder | When implemented by a class, executes TabOrder command.
Public method | Undo | When implemented by a class, executes Undo command.
Public method | Ungroup | When implemented by a class, executes Ungroup command.
Public method | VerbFirst | When implemented by a class, executes VerbFirst command.
Public method | VerbLast | When implemented by a class, executes VerbLast command.
Public method | VertSpaceConcatenate | When implemented by a class, executes VertSpaceConcatenate command.
Public method | VertSpaceDecrease | When implemented by a class, executes VertSpaceDecrease command.
Public method | VertSpaceIncrease | When implemented by a class, executes VertSpaceIncrease command.
Public method | VertSpaceMakeEqual | When implemented by a class, executes VertSpaceMakeEqual command.
Public method | ViewCode | When implemented by a class, executes ViewCode command.
Public method | ViewGrid | When implemented by a class, executes ViewGrid command.
Top
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.AlignBottom Method

IFormDesignerCommandsAlignBottom Method
When implemented by a class, aligns selected control to the bottom of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AlignBottom()
Sub AlignBottom
void AlignBottom()
abstract AlignBottom : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.AlignHorizontalCenters Method

IFormDesignerCommandsAlignHorizontalCenters Method
When implemented by a class, aligns selected control horizontally to the center of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AlignHorizontalCenters()
Sub AlignHorizontalCenters
void AlignHorizontalCenters()
abstract AlignHorizontalCenters : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.AlignLeft Method

IFormDesignerCommandsAlignLeft Method
When implemented by a class, aligns selected control to the left edge of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AlignLeft()
Sub AlignLeft
void AlignLeft()
abstract AlignLeft : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.AlignRight Method

IFormDesignerCommandsAlignRight Method
When implemented by a class, aligns selected control to the right edge of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AlignRight()
Sub AlignRight
void AlignRight()
abstract AlignRight : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.AlignToGrid Method

IFormDesignerCommandsAlignToGrid Method
When implemented by a class, aligns selected control to the closest grid.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AlignToGrid()
Sub AlignToGrid
void AlignToGrid()
abstract AlignToGrid : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.AlignTop Method

IFormDesignerCommandsAlignTop Method
When implemented by a class, aligns selected control to the top of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AlignTop()
Sub AlignTop
void AlignTop()
abstract AlignTop : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.AlignVerticalCenters Method

IFormDesignerCommandsAlignVerticalCenters Method
When implemented by a class, aligns selected control vertically to the center of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AlignVerticalCenters()
Sub AlignVerticalCenters
void AlignVerticalCenters()
abstract AlignVerticalCenters : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.ArrangeBottom Method

IFormDesignerCommandsArrangeBottom Method
When implemented by a class, arranges selected control along the bottom of a form.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ArrangeBottom()
Sub ArrangeBottom
void ArrangeBottom()
abstract ArrangeBottom : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.ArrangeIcons Method

IFormDesignerCommandsArrangeIcons Method
When implemented by a class, executes ArrangeIcons command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ArrangeIcons()
Sub ArrangeIcons
void ArrangeIcons()
abstract ArrangeIcons : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.ArrangeRight Method

IFormDesignerCommandsArrangeRight Method
When implemented by a class, arranges selected control along the right edge of a form.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ArrangeRight()
Sub ArrangeRight
void ArrangeRight()
abstract ArrangeRight : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.BringForward Method

IFormDesignerCommandsBringForward Method
When implemented by a class, bring forward selected control in the z-order.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BringForward()
Sub BringForward
void BringForward()
abstract BringForward : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.BringToFront Method

IFormDesignerCommandsBringToFront Method
When implemented by a class, bring selected control to the front of the z-order.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BringToFront()
Sub BringToFront
void BringToFront()
abstract BringToFront : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CenterHorizontally Method

IFormDesignerCommandsCenterHorizontally Method
When implemented by a class, center selected control horizontally of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CenterHorizontally()
Sub CenterHorizontally
void CenterHorizontally()
abstract CenterHorizontally : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CenterVertically Method

IFormDesignerCommandsCenterVertically Method
When implemented by a class, center selected control vertically of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CenterVertically()
Sub CenterVertically
void CenterVertically()
abstract CenterVertically : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Copy Method

IFormDesignerCommandsCopy Method
When implemented by a class, copies selected control content.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Copy()
Sub Copy
void Copy()
abstract Copy : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Cut Method

IFormDesignerCommandsCut Method
When implemented by a class, cuts selected control content.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Cut()
Sub Cut
void Cut()
abstract Cut : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Delete Method

IFormDesignerCommandsDelete Method
When implemented by a class, deletes selected control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Delete()
Sub Delete
void Delete()
abstract Delete : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.DocumentOutline Method

IFormDesignerCommandsDocumentOutline Method
When implemented by a class, executes DocumentOutline command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void DocumentOutline()
Sub DocumentOutline
void DocumentOutline()
abstract DocumentOutline : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.F1Help Method

IFormDesignerCommandsF1Help Method
When implemented by a class, executes F1Help command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void F1Help()
Sub F1Help
void F1Help()
abstract F1Help : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Group Method

IFormDesignerCommandsGroup Method
When implemented by a class, executes Group command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Group()
Sub Group
void Group()
abstract Group : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.HorizSpaceConcatenate Method

IFormDesignerCommandsHorizSpaceConcatenate Method
When implemented by a class, executes HorizSpaceConcatenate command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HorizSpaceConcatenate()
Sub HorizSpaceConcatenate
void HorizSpaceConcatenate()
abstract HorizSpaceConcatenate : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.HorizSpaceDecrease Method

IFormDesignerCommandsHorizSpaceDecrease Method
When implemented by a class, executes HorizSpaceDecrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HorizSpaceDecrease()
Sub HorizSpaceDecrease
void HorizSpaceDecrease()
abstract HorizSpaceDecrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.HorizSpaceIncrease Method

IFormDesignerCommandsHorizSpaceIncrease Method
When implemented by a class, executes HorizSpaceIncrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HorizSpaceIncrease()
Sub HorizSpaceIncrease
void HorizSpaceIncrease()
abstract HorizSpaceIncrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.HorizSpaceMakeEqual Method

IFormDesignerCommandsHorizSpaceMakeEqual Method
When implemented by a class, executes HorizSpaceMakeEqual command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void HorizSpaceMakeEqual()
Sub HorizSpaceMakeEqual
void HorizSpaceMakeEqual()
abstract HorizSpaceMakeEqual : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyCancel Method

IFormDesignerCommandsKeyCancel Method
When implemented by a class, executes KeyCancel command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyCancel()
Sub KeyCancel
void KeyCancel()
abstract KeyCancel : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyDefaultAction Method

IFormDesignerCommandsKeyDefaultAction Method
When implemented by a class, executes KeyDefaultAction command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyDefaultAction()
Sub KeyDefaultAction
void KeyDefaultAction()
abstract KeyDefaultAction : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyMoveDown Method

IFormDesignerCommandsKeyMoveDown Method
When implemented by a class, executes KeyMoveDown command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyMoveDown()
Sub KeyMoveDown
void KeyMoveDown()
abstract KeyMoveDown : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyMoveLeft Method

IFormDesignerCommandsKeyMoveLeft Method
When implemented by a class, executes KeyMoveLeft command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyMoveLeft()
Sub KeyMoveLeft
void KeyMoveLeft()
abstract KeyMoveLeft : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyMoveRight Method

IFormDesignerCommandsKeyMoveRight Method
When implemented by a class, executes KeyMoveRight command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyMoveRight()
Sub KeyMoveRight
void KeyMoveRight()
abstract KeyMoveRight : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyMoveUp Method

IFormDesignerCommandsKeyMoveUp Method
When implemented by a class, executes KeyMoveUp command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyMoveUp()
Sub KeyMoveUp
void KeyMoveUp()
abstract KeyMoveUp : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyNudgeDown Method

IFormDesignerCommandsKeyNudgeDown Method
When implemented by a class, executes KeyNudgeDown command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyNudgeDown()
Sub KeyNudgeDown
void KeyNudgeDown()
abstract KeyNudgeDown : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyNudgeHeightDecrease Method

IFormDesignerCommandsKeyNudgeHeightDecrease Method
When implemented by a class, executes KeyNudgeHeightDecrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyNudgeHeightDecrease()
Sub KeyNudgeHeightDecrease
void KeyNudgeHeightDecrease()
abstract KeyNudgeHeightDecrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyNudgeHeightIncrease Method

IFormDesignerCommandsKeyNudgeHeightIncrease Method
When implemented by a class, executes KeyNudgeHeightIncrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyNudgeHeightIncrease()
Sub KeyNudgeHeightIncrease
void KeyNudgeHeightIncrease()
abstract KeyNudgeHeightIncrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyNudgeLeft Method

IFormDesignerCommandsKeyNudgeLeft Method
When implemented by a class, executes KeyNudgeLeft command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyNudgeLeft()
Sub KeyNudgeLeft
void KeyNudgeLeft()
abstract KeyNudgeLeft : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyNudgeRight Method

IFormDesignerCommandsKeyNudgeRight Method
When implemented by a class, executes KeyNudgeRight command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyNudgeRight()
Sub KeyNudgeRight
void KeyNudgeRight()
abstract KeyNudgeRight : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyNudgeUp Method

IFormDesignerCommandsKeyNudgeUp Method
When implemented by a class, executes KeyNudgeUp command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyNudgeUp()
Sub KeyNudgeUp
void KeyNudgeUp()
abstract KeyNudgeUp : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyNudgeWidthDecrease Method

IFormDesignerCommandsKeyNudgeWidthDecrease Method
When implemented by a class, executes KeyNudgeWidthDecrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyNudgeWidthDecrease()
Sub KeyNudgeWidthDecrease
void KeyNudgeWidthDecrease()
abstract KeyNudgeWidthDecrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeyNudgeWidthIncrease Method

IFormDesignerCommandsKeyNudgeWidthIncrease Method
When implemented by a class, executes KeyNudgeWidthIncrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeyNudgeWidthIncrease()
Sub KeyNudgeWidthIncrease
void KeyNudgeWidthIncrease()
abstract KeyNudgeWidthIncrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeySelectNext Method

IFormDesignerCommandsKeySelectNext Method
When implemented by a class, executes KeySelectNext command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeySelectNext()
Sub KeySelectNext
void KeySelectNext()
abstract KeySelectNext : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeySelectPrevious Method

IFormDesignerCommandsKeySelectPrevious Method
When implemented by a class, executes KeySelectPrevious command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeySelectPrevious()
Sub KeySelectPrevious
void KeySelectPrevious()
abstract KeySelectPrevious : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeySizeHeightDecrease Method

IFormDesignerCommandsKeySizeHeightDecrease Method
When implemented by a class, executes KeySizeHeightDecrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeySizeHeightDecrease()
Sub KeySizeHeightDecrease
void KeySizeHeightDecrease()
abstract KeySizeHeightDecrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeySizeHeightIncrease Method

IFormDesignerCommandsKeySizeHeightIncrease Method
When implemented by a class, executes KeySizeHeightIncrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeySizeHeightIncrease()
Sub KeySizeHeightIncrease
void KeySizeHeightIncrease()
abstract KeySizeHeightIncrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeySizeWidthDecrease Method

IFormDesignerCommandsKeySizeWidthDecrease Method
When implemented by a class, executes KeySizeWidthDecrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeySizeWidthDecrease()
Sub KeySizeWidthDecrease
void KeySizeWidthDecrease()
abstract KeySizeWidthDecrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.KeySizeWidthIncrease Method

IFormDesignerCommandsKeySizeWidthIncrease Method
When implemented by a class, executes KeySizeWidthIncrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void KeySizeWidthIncrease()
Sub KeySizeWidthIncrease
void KeySizeWidthIncrease()
abstract KeySizeWidthIncrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.LineupIcons Method

IFormDesignerCommandsLineupIcons Method
When implemented by a class, executes LineupIcons command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LineupIcons()
Sub LineupIcons
void LineupIcons()
abstract LineupIcons : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.LockControls Method

IFormDesignerCommandsLockControls Method
When implemented by a class, executes LockControls command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LockControls()
Sub LockControls
void LockControls()
abstract LockControls : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.MultiLevelRedo Method

IFormDesignerCommandsMultiLevelRedo Method
When implemented by a class, executes MultiLevelRedo command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MultiLevelRedo()
Sub MultiLevelRedo
void MultiLevelRedo()
abstract MultiLevelRedo : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.MultiLevelUndo Method

IFormDesignerCommandsMultiLevelUndo Method
When implemented by a class, executes MultiLevelUndo command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MultiLevelUndo()
Sub MultiLevelUndo
void MultiLevelUndo()
abstract MultiLevelUndo : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Paste Method

IFormDesignerCommandsPaste Method
When implemented by a class, executes Paste command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Paste()
Sub Paste
void Paste()
abstract Paste : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Properties Method

IFormDesignerCommandsProperties Method
When implemented by a class, executes Properties command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Properties()
Sub Properties
void Properties()
abstract Properties : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.PropertiesWindow Method

IFormDesignerCommandsPropertiesWindow Method
When implemented by a class, executes PropertiesWindow command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PropertiesWindow()
Sub PropertiesWindow
void PropertiesWindow()
abstract PropertiesWindow : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Redo Method

IFormDesignerCommandsRedo Method
When implemented by a class, executes Redo command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Redo()
Sub Redo
void Redo()
abstract Redo : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Replace Method

IFormDesignerCommandsReplace Method
When implemented by a class, executes Replace command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Replace()
Sub Replace
void Replace()
abstract Replace : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.SelectAll Method

IFormDesignerCommandsSelectAll Method
When implemented by a class, executes SelectAll command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectAll()
Sub SelectAll
void SelectAll()
abstract SelectAll : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.SendBackward Method

IFormDesignerCommandsSendBackward Method
When implemented by a class, executes SendBackward command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendBackward()
Sub SendBackward
void SendBackward()
abstract SendBackward : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.SendToBack Method

IFormDesignerCommandsSendToBack Method
When implemented by a class, executes SendToBack command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SendToBack()
Sub SendToBack
void SendToBack()
abstract SendToBack : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.ShowGrid Method

IFormDesignerCommandsShowGrid Method
When implemented by a class, executes ShowGrid command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowGrid()
Sub ShowGrid
void ShowGrid()
abstract ShowGrid : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.ShowLargeIcons Method

IFormDesignerCommandsShowLargeIcons Method
When implemented by a class, executes ShowLargeIcons command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowLargeIcons()
Sub ShowLargeIcons
void ShowLargeIcons()
abstract ShowLargeIcons : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.SizeToControl Method

IFormDesignerCommandsSizeToControl Method
When implemented by a class, executes SizeToControl command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SizeToControl()
Sub SizeToControl
void SizeToControl()
abstract SizeToControl : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.SizeToControlHeight Method

IFormDesignerCommandsSizeToControlHeight Method
When implemented by a class, executes SizeToControlHeight command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SizeToControlHeight()
Sub SizeToControlHeight
void SizeToControlHeight()
abstract SizeToControlHeight : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.SizeToControlWidth Method

IFormDesignerCommandsSizeToControlWidth Method
When implemented by a class, executes SizeToControlWidth command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SizeToControlWidth()
Sub SizeToControlWidth
void SizeToControlWidth()
abstract SizeToControlWidth : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.SizeToFit Method

IFormDesignerCommandsSizeToFit Method
When implemented by a class, executes SizeToFit command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SizeToFit()
Sub SizeToFit
void SizeToFit()
abstract SizeToFit : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.SizeToGrid Method

IFormDesignerCommandsSizeToGrid Method
When implemented by a class, executes SizeToGrid command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SizeToGrid()
Sub SizeToGrid
void SizeToGrid()
abstract SizeToGrid : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.SnapToGrid Method

IFormDesignerCommandsSnapToGrid Method
When implemented by a class, executes SnapToGrid command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SnapToGrid()
Sub SnapToGrid
void SnapToGrid()
abstract SnapToGrid : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.TabOrder Method

IFormDesignerCommandsTabOrder Method
When implemented by a class, executes TabOrder command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void TabOrder()
Sub TabOrder
void TabOrder()
abstract TabOrder : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Undo Method

IFormDesignerCommandsUndo Method
When implemented by a class, executes Undo command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Undo()
Sub Undo
void Undo()
abstract Undo : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.Ungroup Method

IFormDesignerCommandsUngroup Method
When implemented by a class, executes Ungroup command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Ungroup()
Sub Ungroup
void Ungroup()
abstract Ungroup : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.VerbFirst Method

IFormDesignerCommandsVerbFirst Method
When implemented by a class, executes VerbFirst command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void VerbFirst()
Sub VerbFirst
void VerbFirst()
abstract VerbFirst : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.VerbLast Method

IFormDesignerCommandsVerbLast Method
When implemented by a class, executes VerbLast command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void VerbLast()
Sub VerbLast
void VerbLast()
abstract VerbLast : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.VertSpaceConcatenate Method

IFormDesignerCommandsVertSpaceConcatenate Method
When implemented by a class, executes VertSpaceConcatenate command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void VertSpaceConcatenate()
Sub VertSpaceConcatenate
void VertSpaceConcatenate()
abstract VertSpaceConcatenate : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.VertSpaceDecrease Method

IFormDesignerCommandsVertSpaceDecrease Method
When implemented by a class, executes VertSpaceDecrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void VertSpaceDecrease()
Sub VertSpaceDecrease
void VertSpaceDecrease()
abstract VertSpaceDecrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.VertSpaceIncrease Method

IFormDesignerCommandsVertSpaceIncrease Method
When implemented by a class, executes VertSpaceIncrease command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void VertSpaceIncrease()
Sub VertSpaceIncrease
void VertSpaceIncrease()
abstract VertSpaceIncrease : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.VertSpaceMakeEqual Method

IFormDesignerCommandsVertSpaceMakeEqual Method
When implemented by a class, executes VertSpaceMakeEqual command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void VertSpaceMakeEqual()
Sub VertSpaceMakeEqual
void VertSpaceMakeEqual()
abstract VertSpaceMakeEqual : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.ViewCode Method

IFormDesignerCommandsViewCode Method
When implemented by a class, executes ViewCode command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ViewCode()
Sub ViewCode
void ViewCode()
abstract ViewCode : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.ViewGrid Method

IFormDesignerCommandsViewGrid Method
When implemented by a class, executes ViewGrid command.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ViewGrid()
Sub ViewGrid
void ViewGrid()
abstract ViewGrid : unit -> unit
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands Properties

IFormDesignerCommands Properties

The IFormDesignerCommands type exposes the following members.

Properties
 | Name | Description
Public property | CanAlignBottom | When implemented by a class, gets a value indicating whether selected controls can be aligned to the bottom of its containing control.
Public property | CanAlignHorizontalCenters | When implemented by a class, gets a value indicating whether selected controls can be aligned horizontally to the center of its containing control.
Public property | CanAlignLeft | When implemented by a class, gets a value indicating whether selected controls can be aligned to the left edge of its containing control.
Public property | CanAlignRight | When implemented by a class, gets a value indicating whether selected controls can be aligned to the right edge of its containing control.
Public property | CanAlignToGrid | When implemented by a class, gets a value indicating whether selected controls can be aligned to the closest grid.
Public property | CanAlignTop | When implemented by a class, gets a value indicating whether selected controls can be aligned to the top of its containing control.
Public property | CanAlignVerticalCenters | When implemented by a class, gets a value indicating whether selected controls can be aligned vertically to the center of its containing control.
Public property | CanArrangeBottom | When implemented by a class, gets a value indicating whether selected controls can be arranged along the bottom of a form.
Public property | CanArrangeIcons | When implemented by a class, indicates whether ArrangeIcons command can be executed.
Public property | CanArrangeRight | When implemented by a class, gets a value indicating whether selected controls can be arranged along the right edge of a form.
Public property | CanBringForward | When implemented by a class, gets a value indicating whether selected controls can be bring forward in the z-order.
Public property | CanBringToFront | When implemented by a class, gets a value indicating whether selected controls can be bring to the front of the z-order.
Public property | CanCenterHorizontally | When implemented by a class, gets a value indicating whether selected controls can be centered horizontally of its containing control.
Public property | CanCenterVertically | When implemented by a class, gets a value indicating whether selected controls can be centered vertically of its containing control.
Public property | CanCopy | When implemented by a class, indicates whether selected controls can be copied.
Public property | CanCut | When implemented by a class, indicates whether selected controls can be cut.
Public property | CanDelete | When implemented by a class, indicates whether selected controls can be deleted.
Public property | CanDocumentOutline | When implemented by a class, indicates whether DocumentOutline command can be executed.
Public property | CanF1Help | When implemented by a class, indicates whether F1Help command can be executed.
Public property | CanGroup | When implemented by a class, indicates whether Group command can be executed.
Public property | CanHorizSpaceConcatenate | When implemented by a class, indicates whether HorizSpaceConcatenate command can be executed.
Public property | CanHorizSpaceDecrease | When implemented by a class, indicates whether HorizSpaceDecrease command can be executed.
Public property | CanHorizSpaceIncrease | When implemented by a class, indicates whether HorizSpaceIncrease command can be executed.
Public property | CanHorizSpaceMakeEqual | When implemented by a class, indicates whether HorizSpaceMakeEqual command can be executed.
Public property | CanKeyCancel | When implemented by a class, indicates whether KeyCancel command can be executed.
Public property | CanKeyDefaultAction | When implemented by a class, indicates whether KeyDefaultAction command can be executed.
Public property | CanKeyMoveDown | When implemented by a class, gets a value indicating whether selected controls can be moved down by key.
Public property | CanKeyMoveLeft | When implemented by a class, gets a value indicating whether selected controls can be moved left by key.
Public property | CanKeyMoveRight | When implemented by a class, gets a value indicating whether selected controls can be moved right by key.
Public property | CanKeyMoveUp | When implemented by a class, gets a value indicating whether selected controls can be moved up by key.
Public property | CanKeyNudgeDown | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge down key handler.
Public property | CanKeyNudgeHeightDecrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge height decrease key handler.
Public property | CanKeyNudgeHeightIncrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge height increase key handler.
Public property | CanKeyNudgeLeft | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge left key handler.
Public property | CanKeyNudgeRight | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge right key handler.
Public property | CanKeyNudgeUp | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge up key handler.
Public property | CanKeyNudgeWidthDecrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge width decrease key handler.
Public property | CanKeyNudgeWidthIncrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge width increase key handler.
Public property | CanKeySelectNext | When implemented by a class, indicates whether KeySelectNext command can be executed.
Public property | CanKeySelectPrevious | When implemented by a class, indicates whether KeySelectPrevious command can be executed.
Public property | CanKeySizeHeightDecrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the size height decrease key handler.
Public property | CanKeySizeHeightIncrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the size height increase key handler.
Public property | CanKeySizeWidthDecrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the size width decrease key handler.
Public property | CanKeySizeWidthIncrease | When implemented by a class, gets a value indicating whether selected controls can be accessed to the size width increase key handler.
Public property | CanLineupIcons | When implemented by a class, indicates whether LineupIcons command can be executed.
Public property | CanLockControls | When implemented by a class, indicates whether LockControls command can be executed.
Public property | CanMultiLevelRedo | When implemented by a class, indicates whether MultiLevelRedo command can be executed.
Public property | CanMultiLevelUndo | When implemented by a class, indicates whether HorizSpaceDecrease command can be executed.
Public property | CanPaste | When implemented by a class, indicates whether Paste command can be executed.
Public property | CanProperties | When implemented by a class, indicates whether Properties command can be executed.
Public property | CanPropertiesWindow | When implemented by a class, indicates whether PropertiesWindow command can be executed.
Public property | CanRedo | When implemented by a class, indicates whether Redo command can be executed.
Public property | CanReplace | When implemented by a class, indicates whether Replace command can be executed.
Public property | CanSelectAll | When implemented by a class, indicates whether SelectAll command can be executed.
Public property | CanSendBackward | When implemented by a class, indicates whether SendBackward command can be executed.
Public property | CanSendToBack | When implemented by a class, indicates whether SendToBack command can be executed.
Public property | CanShowGrid | When implemented by a class, indicates whether ShowGrid command can be executed.
Public property | CanShowLargeIcons | When implemented by a class, indicates whether ShowLargeIcons command can be executed.
Public property | CanSizeToControl | When implemented by a class, indicates whether SizeToControl command can be executed.
Public property | CanSizeToControlHeight | When implemented by a class, indicates whether SizeToControlHeight command can be executed.
Public property | CanSizeToControlWidth | When implemented by a class, indicates whether SizeToControlWidth command can be executed.
Public property | CanSizeToFit | When implemented by a class, indicates whether SizeToFit command can be executed.
Public property | CanSizeToGrid | When implemented by a class, indicates whether SizeToGrid command can be executed.
Public property | CanSnapToGrid | When implemented by a class, indicates whether SnapToGrid command can be executed.
Public property | CanTabOrder | When implemented by a class, indicates whether TabOrder command can be executed.
Public property | CanUndo | When implemented by a class, indicates whether Undo command can be executed.
Public property | CanUngroup | When implemented by a class, indicates whether Ungroup command can be executed.
Public property | CanVerbFirst | When implemented by a class, indicates whether VerbFirst command can be executed.
Public property | CanVerbLast | When implemented by a class, indicates whether VerbLast command can be executed.
Public property | CanVertSpaceConcatenate | When implemented by a class, indicates whether VertSpaceConcatenate command can be executed.
Public property | CanVertSpaceDecrease | When implemented by a class, indicates whether VertSpaceDecrease command can be executed.
Public property | CanVertSpaceIncrease | When implemented by a class, indicates whether VertSpaceIncrease command can be executed.
Public property | CanVertSpaceMakeEqual | When implemented by a class, indicates whether VertSpaceMakeEqual command can be executed.
Public property | CanViewCode | When implemented by a class, indicates whether ViewCode command can be executed.
Public property | CanViewGrid | When implemented by a class, indicates whether ViewGrid command can be executed.
Public property | IsLockControlsChecked | When implemented by a class, indicates whether all controls on designer surface is locked.
Top
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanAlignBottom Property

IFormDesignerCommandsCanAlignBottom Property
When implemented by a class, gets a value indicating whether selected controls can be aligned to the bottom of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanAlignBottom { get; }
ReadOnly Property CanAlignBottom As Boolean
    Get
property bool CanAlignBottom {
    bool get ();
}
abstract CanAlignBottom : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanAlignHorizontalCenters Property

IFormDesignerCommandsCanAlignHorizontalCenters Property
When implemented by a class, gets a value indicating whether selected controls can be aligned horizontally to the center of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanAlignHorizontalCenters { get; }
ReadOnly Property CanAlignHorizontalCenters As Boolean
    Get
property bool CanAlignHorizontalCenters {
    bool get ();
}
abstract CanAlignHorizontalCenters : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanAlignLeft Property

IFormDesignerCommandsCanAlignLeft Property
When implemented by a class, gets a value indicating whether selected controls can be aligned to the left edge of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanAlignLeft { get; }
ReadOnly Property CanAlignLeft As Boolean
    Get
property bool CanAlignLeft {
    bool get ();
}
abstract CanAlignLeft : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanAlignRight Property

IFormDesignerCommandsCanAlignRight Property
When implemented by a class, gets a value indicating whether selected controls can be aligned to the right edge of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanAlignRight { get; }
ReadOnly Property CanAlignRight As Boolean
    Get
property bool CanAlignRight {
    bool get ();
}
abstract CanAlignRight : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanAlignToGrid Property

IFormDesignerCommandsCanAlignToGrid Property
When implemented by a class, gets a value indicating whether selected controls can be aligned to the closest grid.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanAlignToGrid { get; }
ReadOnly Property CanAlignToGrid As Boolean
    Get
property bool CanAlignToGrid {
    bool get ();
}
abstract CanAlignToGrid : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanAlignTop Property

IFormDesignerCommandsCanAlignTop Property
When implemented by a class, gets a value indicating whether selected controls can be aligned to the top of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanAlignTop { get; }
ReadOnly Property CanAlignTop As Boolean
    Get
property bool CanAlignTop {
    bool get ();
}
abstract CanAlignTop : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanAlignVerticalCenters Property

IFormDesignerCommandsCanAlignVerticalCenters Property
When implemented by a class, gets a value indicating whether selected controls can be aligned vertically to the center of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanAlignVerticalCenters { get; }
ReadOnly Property CanAlignVerticalCenters As Boolean
    Get
property bool CanAlignVerticalCenters {
    bool get ();
}
abstract CanAlignVerticalCenters : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanArrangeBottom Property

IFormDesignerCommandsCanArrangeBottom Property
When implemented by a class, gets a value indicating whether selected controls can be arranged along the bottom of a form.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanArrangeBottom { get; }
ReadOnly Property CanArrangeBottom As Boolean
    Get
property bool CanArrangeBottom {
    bool get ();
}
abstract CanArrangeBottom : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanArrangeIcons Property

IFormDesignerCommandsCanArrangeIcons Property
When implemented by a class, indicates whether ArrangeIcons command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanArrangeIcons { get; }
ReadOnly Property CanArrangeIcons As Boolean
    Get
property bool CanArrangeIcons {
    bool get ();
}
abstract CanArrangeIcons : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanArrangeRight Property

IFormDesignerCommandsCanArrangeRight Property
When implemented by a class, gets a value indicating whether selected controls can be arranged along the right edge of a form.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanArrangeRight { get; }
ReadOnly Property CanArrangeRight As Boolean
    Get
property bool CanArrangeRight {
    bool get ();
}
abstract CanArrangeRight : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanBringForward Property

IFormDesignerCommandsCanBringForward Property
When implemented by a class, gets a value indicating whether selected controls can be bring forward in the z-order.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanBringForward { get; }
ReadOnly Property CanBringForward As Boolean
    Get
property bool CanBringForward {
    bool get ();
}
abstract CanBringForward : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanBringToFront Property

IFormDesignerCommandsCanBringToFront Property
When implemented by a class, gets a value indicating whether selected controls can be bring to the front of the z-order.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanBringToFront { get; }
ReadOnly Property CanBringToFront As Boolean
    Get
property bool CanBringToFront {
    bool get ();
}
abstract CanBringToFront : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanCenterHorizontally Property

IFormDesignerCommandsCanCenterHorizontally Property
When implemented by a class, gets a value indicating whether selected controls can be centered horizontally of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCenterHorizontally { get; }
ReadOnly Property CanCenterHorizontally As Boolean
    Get
property bool CanCenterHorizontally {
    bool get ();
}
abstract CanCenterHorizontally : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanCenterVertically Property

IFormDesignerCommandsCanCenterVertically Property
When implemented by a class, gets a value indicating whether selected controls can be centered vertically of its containing control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCenterVertically { get; }
ReadOnly Property CanCenterVertically As Boolean
    Get
property bool CanCenterVertically {
    bool get ();
}
abstract CanCenterVertically : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanCopy Property

IFormDesignerCommandsCanCopy Property
When implemented by a class, indicates whether selected controls can be copied.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCopy { get; }
ReadOnly Property CanCopy As Boolean
    Get
property bool CanCopy {
    bool get ();
}
abstract CanCopy : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanCut Property

IFormDesignerCommandsCanCut Property
When implemented by a class, indicates whether selected controls can be cut.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanCut { get; }
ReadOnly Property CanCut As Boolean
    Get
property bool CanCut {
    bool get ();
}
abstract CanCut : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanDelete Property

IFormDesignerCommandsCanDelete Property
When implemented by a class, indicates whether selected controls can be deleted.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanDelete { get; }
ReadOnly Property CanDelete As Boolean
    Get
property bool CanDelete {
    bool get ();
}
abstract CanDelete : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanDocumentOutline Property

IFormDesignerCommandsCanDocumentOutline Property
When implemented by a class, indicates whether DocumentOutline command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanDocumentOutline { get; }
ReadOnly Property CanDocumentOutline As Boolean
    Get
property bool CanDocumentOutline {
    bool get ();
}
abstract CanDocumentOutline : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanF1Help Property

IFormDesignerCommandsCanF1Help Property
When implemented by a class, indicates whether F1Help command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanF1Help { get; }
ReadOnly Property CanF1Help As Boolean
    Get
property bool CanF1Help {
    bool get ();
}
abstract CanF1Help : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanGroup Property

IFormDesignerCommandsCanGroup Property
When implemented by a class, indicates whether Group command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanGroup { get; }
ReadOnly Property CanGroup As Boolean
    Get
property bool CanGroup {
    bool get ();
}
abstract CanGroup : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanHorizSpaceConcatenate Property

IFormDesignerCommandsCanHorizSpaceConcatenate Property
When implemented by a class, indicates whether HorizSpaceConcatenate command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanHorizSpaceConcatenate { get; }
ReadOnly Property CanHorizSpaceConcatenate As Boolean
    Get
property bool CanHorizSpaceConcatenate {
    bool get ();
}
abstract CanHorizSpaceConcatenate : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanHorizSpaceDecrease Property

IFormDesignerCommandsCanHorizSpaceDecrease Property
When implemented by a class, indicates whether HorizSpaceDecrease command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanHorizSpaceDecrease { get; }
ReadOnly Property CanHorizSpaceDecrease As Boolean
    Get
property bool CanHorizSpaceDecrease {
    bool get ();
}
abstract CanHorizSpaceDecrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanHorizSpaceIncrease Property

IFormDesignerCommandsCanHorizSpaceIncrease Property
When implemented by a class, indicates whether HorizSpaceIncrease command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanHorizSpaceIncrease { get; }
ReadOnly Property CanHorizSpaceIncrease As Boolean
    Get
property bool CanHorizSpaceIncrease {
    bool get ();
}
abstract CanHorizSpaceIncrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanHorizSpaceMakeEqual Property

IFormDesignerCommandsCanHorizSpaceMakeEqual Property
When implemented by a class, indicates whether HorizSpaceMakeEqual command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanHorizSpaceMakeEqual { get; }
ReadOnly Property CanHorizSpaceMakeEqual As Boolean
    Get
property bool CanHorizSpaceMakeEqual {
    bool get ();
}
abstract CanHorizSpaceMakeEqual : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyCancel Property

IFormDesignerCommandsCanKeyCancel Property
When implemented by a class, indicates whether KeyCancel command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyCancel { get; }
ReadOnly Property CanKeyCancel As Boolean
    Get
property bool CanKeyCancel {
    bool get ();
}
abstract CanKeyCancel : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyDefaultAction Property

IFormDesignerCommandsCanKeyDefaultAction Property
When implemented by a class, indicates whether KeyDefaultAction command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyDefaultAction { get; }
ReadOnly Property CanKeyDefaultAction As Boolean
    Get
property bool CanKeyDefaultAction {
    bool get ();
}
abstract CanKeyDefaultAction : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyMoveDown Property

IFormDesignerCommandsCanKeyMoveDown Property
When implemented by a class, gets a value indicating whether selected controls can be moved down by key.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyMoveDown { get; }
ReadOnly Property CanKeyMoveDown As Boolean
    Get
property bool CanKeyMoveDown {
    bool get ();
}
abstract CanKeyMoveDown : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyMoveLeft Property

IFormDesignerCommandsCanKeyMoveLeft Property
When implemented by a class, gets a value indicating whether selected controls can be moved left by key.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyMoveLeft { get; }
ReadOnly Property CanKeyMoveLeft As Boolean
    Get
property bool CanKeyMoveLeft {
    bool get ();
}
abstract CanKeyMoveLeft : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyMoveRight Property

IFormDesignerCommandsCanKeyMoveRight Property
When implemented by a class, gets a value indicating whether selected controls can be moved right by key.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyMoveRight { get; }
ReadOnly Property CanKeyMoveRight As Boolean
    Get
property bool CanKeyMoveRight {
    bool get ();
}
abstract CanKeyMoveRight : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyMoveUp Property

IFormDesignerCommandsCanKeyMoveUp Property
When implemented by a class, gets a value indicating whether selected controls can be moved up by key.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyMoveUp { get; }
ReadOnly Property CanKeyMoveUp As Boolean
    Get
property bool CanKeyMoveUp {
    bool get ();
}
abstract CanKeyMoveUp : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyNudgeDown Property

IFormDesignerCommandsCanKeyNudgeDown Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge down key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyNudgeDown { get; }
ReadOnly Property CanKeyNudgeDown As Boolean
    Get
property bool CanKeyNudgeDown {
    bool get ();
}
abstract CanKeyNudgeDown : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyNudgeHeightDecrease Property

IFormDesignerCommandsCanKeyNudgeHeightDecrease Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge height decrease key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyNudgeHeightDecrease { get; }
ReadOnly Property CanKeyNudgeHeightDecrease As Boolean
    Get
property bool CanKeyNudgeHeightDecrease {
    bool get ();
}
abstract CanKeyNudgeHeightDecrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyNudgeHeightIncrease Property

IFormDesignerCommandsCanKeyNudgeHeightIncrease Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge height increase key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyNudgeHeightIncrease { get; }
ReadOnly Property CanKeyNudgeHeightIncrease As Boolean
    Get
property bool CanKeyNudgeHeightIncrease {
    bool get ();
}
abstract CanKeyNudgeHeightIncrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyNudgeLeft Property

IFormDesignerCommandsCanKeyNudgeLeft Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge left key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyNudgeLeft { get; }
ReadOnly Property CanKeyNudgeLeft As Boolean
    Get
property bool CanKeyNudgeLeft {
    bool get ();
}
abstract CanKeyNudgeLeft : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyNudgeRight Property

IFormDesignerCommandsCanKeyNudgeRight Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge right key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyNudgeRight { get; }
ReadOnly Property CanKeyNudgeRight As Boolean
    Get
property bool CanKeyNudgeRight {
    bool get ();
}
abstract CanKeyNudgeRight : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyNudgeUp Property

IFormDesignerCommandsCanKeyNudgeUp Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge up key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyNudgeUp { get; }
ReadOnly Property CanKeyNudgeUp As Boolean
    Get
property bool CanKeyNudgeUp {
    bool get ();
}
abstract CanKeyNudgeUp : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyNudgeWidthDecrease Property

IFormDesignerCommandsCanKeyNudgeWidthDecrease Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge width decrease key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyNudgeWidthDecrease { get; }
ReadOnly Property CanKeyNudgeWidthDecrease As Boolean
    Get
property bool CanKeyNudgeWidthDecrease {
    bool get ();
}
abstract CanKeyNudgeWidthDecrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeyNudgeWidthIncrease Property

IFormDesignerCommandsCanKeyNudgeWidthIncrease Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the nudge width increase key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeyNudgeWidthIncrease { get; }
ReadOnly Property CanKeyNudgeWidthIncrease As Boolean
    Get
property bool CanKeyNudgeWidthIncrease {
    bool get ();
}
abstract CanKeyNudgeWidthIncrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeySelectNext Property

IFormDesignerCommandsCanKeySelectNext Property
When implemented by a class, indicates whether KeySelectNext command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeySelectNext { get; }
ReadOnly Property CanKeySelectNext As Boolean
    Get
property bool CanKeySelectNext {
    bool get ();
}
abstract CanKeySelectNext : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeySelectPrevious Property

IFormDesignerCommandsCanKeySelectPrevious Property
When implemented by a class, indicates whether KeySelectPrevious command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeySelectPrevious { get; }
ReadOnly Property CanKeySelectPrevious As Boolean
    Get
property bool CanKeySelectPrevious {
    bool get ();
}
abstract CanKeySelectPrevious : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeySizeHeightDecrease Property

IFormDesignerCommandsCanKeySizeHeightDecrease Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the size height decrease key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeySizeHeightDecrease { get; }
ReadOnly Property CanKeySizeHeightDecrease As Boolean
    Get
property bool CanKeySizeHeightDecrease {
    bool get ();
}
abstract CanKeySizeHeightDecrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeySizeHeightIncrease Property

IFormDesignerCommandsCanKeySizeHeightIncrease Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the size height increase key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeySizeHeightIncrease { get; }
ReadOnly Property CanKeySizeHeightIncrease As Boolean
    Get
property bool CanKeySizeHeightIncrease {
    bool get ();
}
abstract CanKeySizeHeightIncrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeySizeWidthDecrease Property

IFormDesignerCommandsCanKeySizeWidthDecrease Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the size width decrease key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeySizeWidthDecrease { get; }
ReadOnly Property CanKeySizeWidthDecrease As Boolean
    Get
property bool CanKeySizeWidthDecrease {
    bool get ();
}
abstract CanKeySizeWidthDecrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanKeySizeWidthIncrease Property

IFormDesignerCommandsCanKeySizeWidthIncrease Property
When implemented by a class, gets a value indicating whether selected controls can be accessed to the size width increase key handler.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanKeySizeWidthIncrease { get; }
ReadOnly Property CanKeySizeWidthIncrease As Boolean
    Get
property bool CanKeySizeWidthIncrease {
    bool get ();
}
abstract CanKeySizeWidthIncrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanLineupIcons Property

IFormDesignerCommandsCanLineupIcons Property
When implemented by a class, indicates whether LineupIcons command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanLineupIcons { get; }
ReadOnly Property CanLineupIcons As Boolean
    Get
property bool CanLineupIcons {
    bool get ();
}
abstract CanLineupIcons : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanLockControls Property

IFormDesignerCommandsCanLockControls Property
When implemented by a class, indicates whether LockControls command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanLockControls { get; }
ReadOnly Property CanLockControls As Boolean
    Get
property bool CanLockControls {
    bool get ();
}
abstract CanLockControls : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanMultiLevelRedo Property

IFormDesignerCommandsCanMultiLevelRedo Property
When implemented by a class, indicates whether MultiLevelRedo command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanMultiLevelRedo { get; }
ReadOnly Property CanMultiLevelRedo As Boolean
    Get
property bool CanMultiLevelRedo {
    bool get ();
}
abstract CanMultiLevelRedo : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanMultiLevelUndo Property

IFormDesignerCommandsCanMultiLevelUndo Property
When implemented by a class, indicates whether HorizSpaceDecrease command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanMultiLevelUndo { get; }
ReadOnly Property CanMultiLevelUndo As Boolean
    Get
property bool CanMultiLevelUndo {
    bool get ();
}
abstract CanMultiLevelUndo : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanPaste Property

IFormDesignerCommandsCanPaste Property
When implemented by a class, indicates whether Paste command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanPaste { get; }
ReadOnly Property CanPaste As Boolean
    Get
property bool CanPaste {
    bool get ();
}
abstract CanPaste : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanProperties Property

IFormDesignerCommandsCanProperties Property
When implemented by a class, indicates whether Properties command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanProperties { get; }
ReadOnly Property CanProperties As Boolean
    Get
property bool CanProperties {
    bool get ();
}
abstract CanProperties : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanPropertiesWindow Property

IFormDesignerCommandsCanPropertiesWindow Property
When implemented by a class, indicates whether PropertiesWindow command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanPropertiesWindow { get; }
ReadOnly Property CanPropertiesWindow As Boolean
    Get
property bool CanPropertiesWindow {
    bool get ();
}
abstract CanPropertiesWindow : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanRedo Property

IFormDesignerCommandsCanRedo Property
When implemented by a class, indicates whether Redo command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanRedo { get; }
ReadOnly Property CanRedo As Boolean
    Get
property bool CanRedo {
    bool get ();
}
abstract CanRedo : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanReplace Property

IFormDesignerCommandsCanReplace Property
When implemented by a class, indicates whether Replace command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanReplace { get; }
ReadOnly Property CanReplace As Boolean
    Get
property bool CanReplace {
    bool get ();
}
abstract CanReplace : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanSelectAll Property

IFormDesignerCommandsCanSelectAll Property
When implemented by a class, indicates whether SelectAll command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSelectAll { get; }
ReadOnly Property CanSelectAll As Boolean
    Get
property bool CanSelectAll {
    bool get ();
}
abstract CanSelectAll : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanSendBackward Property

IFormDesignerCommandsCanSendBackward Property
When implemented by a class, indicates whether SendBackward command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSendBackward { get; }
ReadOnly Property CanSendBackward As Boolean
    Get
property bool CanSendBackward {
    bool get ();
}
abstract CanSendBackward : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanSendToBack Property

IFormDesignerCommandsCanSendToBack Property
When implemented by a class, indicates whether SendToBack command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSendToBack { get; }
ReadOnly Property CanSendToBack As Boolean
    Get
property bool CanSendToBack {
    bool get ();
}
abstract CanSendToBack : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanShowGrid Property

IFormDesignerCommandsCanShowGrid Property
When implemented by a class, indicates whether ShowGrid command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanShowGrid { get; }
ReadOnly Property CanShowGrid As Boolean
    Get
property bool CanShowGrid {
    bool get ();
}
abstract CanShowGrid : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanShowLargeIcons Property

IFormDesignerCommandsCanShowLargeIcons Property
When implemented by a class, indicates whether ShowLargeIcons command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanShowLargeIcons { get; }
ReadOnly Property CanShowLargeIcons As Boolean
    Get
property bool CanShowLargeIcons {
    bool get ();
}
abstract CanShowLargeIcons : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanSizeToControl Property

IFormDesignerCommandsCanSizeToControl Property
When implemented by a class, indicates whether SizeToControl command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSizeToControl { get; }
ReadOnly Property CanSizeToControl As Boolean
    Get
property bool CanSizeToControl {
    bool get ();
}
abstract CanSizeToControl : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanSizeToControlHeight Property

IFormDesignerCommandsCanSizeToControlHeight Property
When implemented by a class, indicates whether SizeToControlHeight command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSizeToControlHeight { get; }
ReadOnly Property CanSizeToControlHeight As Boolean
    Get
property bool CanSizeToControlHeight {
    bool get ();
}
abstract CanSizeToControlHeight : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanSizeToControlWidth Property

IFormDesignerCommandsCanSizeToControlWidth Property
When implemented by a class, indicates whether SizeToControlWidth command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSizeToControlWidth { get; }
ReadOnly Property CanSizeToControlWidth As Boolean
    Get
property bool CanSizeToControlWidth {
    bool get ();
}
abstract CanSizeToControlWidth : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanSizeToFit Property

IFormDesignerCommandsCanSizeToFit Property
When implemented by a class, indicates whether SizeToFit command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSizeToFit { get; }
ReadOnly Property CanSizeToFit As Boolean
    Get
property bool CanSizeToFit {
    bool get ();
}
abstract CanSizeToFit : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanSizeToGrid Property

IFormDesignerCommandsCanSizeToGrid Property
When implemented by a class, indicates whether SizeToGrid command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSizeToGrid { get; }
ReadOnly Property CanSizeToGrid As Boolean
    Get
property bool CanSizeToGrid {
    bool get ();
}
abstract CanSizeToGrid : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanSnapToGrid Property

IFormDesignerCommandsCanSnapToGrid Property
When implemented by a class, indicates whether SnapToGrid command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanSnapToGrid { get; }
ReadOnly Property CanSnapToGrid As Boolean
    Get
property bool CanSnapToGrid {
    bool get ();
}
abstract CanSnapToGrid : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanTabOrder Property

IFormDesignerCommandsCanTabOrder Property
When implemented by a class, indicates whether TabOrder command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanTabOrder { get; }
ReadOnly Property CanTabOrder As Boolean
    Get
property bool CanTabOrder {
    bool get ();
}
abstract CanTabOrder : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanUndo Property

IFormDesignerCommandsCanUndo Property
When implemented by a class, indicates whether Undo command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanUndo { get; }
ReadOnly Property CanUndo As Boolean
    Get
property bool CanUndo {
    bool get ();
}
abstract CanUndo : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanUngroup Property

IFormDesignerCommandsCanUngroup Property
When implemented by a class, indicates whether Ungroup command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanUngroup { get; }
ReadOnly Property CanUngroup As Boolean
    Get
property bool CanUngroup {
    bool get ();
}
abstract CanUngroup : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanVerbFirst Property

IFormDesignerCommandsCanVerbFirst Property
When implemented by a class, indicates whether VerbFirst command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanVerbFirst { get; }
ReadOnly Property CanVerbFirst As Boolean
    Get
property bool CanVerbFirst {
    bool get ();
}
abstract CanVerbFirst : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanVerbLast Property

IFormDesignerCommandsCanVerbLast Property
When implemented by a class, indicates whether VerbLast command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanVerbLast { get; }
ReadOnly Property CanVerbLast As Boolean
    Get
property bool CanVerbLast {
    bool get ();
}
abstract CanVerbLast : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanVertSpaceConcatenate Property

IFormDesignerCommandsCanVertSpaceConcatenate Property
When implemented by a class, indicates whether VertSpaceConcatenate command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanVertSpaceConcatenate { get; }
ReadOnly Property CanVertSpaceConcatenate As Boolean
    Get
property bool CanVertSpaceConcatenate {
    bool get ();
}
abstract CanVertSpaceConcatenate : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanVertSpaceDecrease Property

IFormDesignerCommandsCanVertSpaceDecrease Property
When implemented by a class, indicates whether VertSpaceDecrease command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanVertSpaceDecrease { get; }
ReadOnly Property CanVertSpaceDecrease As Boolean
    Get
property bool CanVertSpaceDecrease {
    bool get ();
}
abstract CanVertSpaceDecrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanVertSpaceIncrease Property

IFormDesignerCommandsCanVertSpaceIncrease Property
When implemented by a class, indicates whether VertSpaceIncrease command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanVertSpaceIncrease { get; }
ReadOnly Property CanVertSpaceIncrease As Boolean
    Get
property bool CanVertSpaceIncrease {
    bool get ();
}
abstract CanVertSpaceIncrease : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanVertSpaceMakeEqual Property

IFormDesignerCommandsCanVertSpaceMakeEqual Property
When implemented by a class, indicates whether VertSpaceMakeEqual command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanVertSpaceMakeEqual { get; }
ReadOnly Property CanVertSpaceMakeEqual As Boolean
    Get
property bool CanVertSpaceMakeEqual {
    bool get ();
}
abstract CanVertSpaceMakeEqual : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanViewCode Property

IFormDesignerCommandsCanViewCode Property
When implemented by a class, indicates whether ViewCode command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanViewCode { get; }
ReadOnly Property CanViewCode As Boolean
    Get
property bool CanViewCode {
    bool get ();
}
abstract CanViewCode : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.CanViewGrid Property

IFormDesignerCommandsCanViewGrid Property
When implemented by a class, indicates whether ViewGrid command can be executed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanViewGrid { get; }
ReadOnly Property CanViewGrid As Boolean
    Get
property bool CanViewGrid {
    bool get ();
}
abstract CanViewGrid : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerCommands.IsLockControlsChecked Property

IFormDesignerCommandsIsLockControlsChecked Property
When implemented by a class, indicates whether all controls on designer surface is locked.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsLockControlsChecked { get; }
ReadOnly Property IsLockControlsChecked As Boolean
    Get
property bool IsLockControlsChecked {
    bool get ();
}
abstract IsLockControlsChecked : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerCommands Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl Interface

IFormDesignerControl Interface
Represents a properties and methods to support all standard form editing operations with controls.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFormDesignerControl
Public Interface IFormDesignerControl
public interface class IFormDesignerControl
type IFormDesignerControl =  interface end

The IFormDesignerControl type exposes the following members.

Methods
 | Name | Description
Public method | GetLocalizationLanguage | When implemented by a class, gets current culture information
Public method | RaiseComponentChanged |
Public method | Reload | When implemented by a class, reloads form to be designed from the source.
Public method | Save | When implemented by a class, serializes designer to C# or Visual Basic file.
Public method | SetLocalizationLanguage | When implemented by a class, sets current culture information
Top
Properties
 | Name | Description
Public property | AutoAddComponentAssemblyReferences | When implemented by a class, gets or sets a boolean value indicating whether designer should automatically try to add assembly references after a control is added.
Public property | AutoSaveToSource | When implemented by a class, gets or sets a boolean value indicating whether designer should automatically translate changes to the source upon every change.
Public property | CommandKeyBindings | When implemented by a class, represents a list of CommandKeyBinding accepted by this FormDesignerControl.
Public property | DesignerCommands | When implemented by a class, represents a collection of standard designer commands like selecting, copying, pasting, moving and resizing controls.
Public property | DesignerHost | When implemented by a class, provides an interface for managing designer transactions and components..
Public property | ImportedNamespaces | When implemented by a class, in case of Visual Basic, gets collection of globally available namespaces.
Public property | IsBeingLoaded | When implemented by a class, gets a boolean value indicating that designer is currently being loaded.
Public property | IsModified | When implemented by a class, represents a value indicates whether designer content has been modified since last save.
Public property | IsSmartDiffCodeSerializationRequired | When implemented by a class, gets or sets method used to identify whether FormDesignerControl content should be saved only by taking into account code difference.
Public property | Options | When implemented by a class, gets designer options like snap settings, grid size etc.
Public property | PrimarySelection | When implemented by a class, gets first selected component or control.
Public property | ReferencedAssemblies | When implemented by a class, gets collection of assemblies where the controls and components used on the form being designed are declared.
Public property | SelectedComponents | When implemented by a class, contains list of selected components or controls.
Public property | ServiceContainer | When implemented by a class, represents a container for designer-related services.
Public property | Source | When implemented by a class, gets or sets FormDesigner Source.
Public property | ToolboxControl | When implemented by a class, gets or sets toolbox control associated with the designer.
Public property | UserData | When implemented by a class, gets or sets user-specific data associated with this Form Designer
Top
Events
 | Name | Description
Public event | CommandStateChanged | When implemented by a class, occurs when state of designer commands changes (for example when undo stack becomes available).
Public event | CompilerErrorClick | When implemented by a class, occurs when user clicks on compiler error on Form Designer surface.
Public event | ComponentAdded | When implemented by a class, occurs when some component was added on the designer surface.
Public event | ComponentChanged | Occurs when some component was changed on the designer surface.
Public event | ComponentRemoved | When implemented by a class, occurs when some component was removed from the designer surface.
Public event | DesignedContentChanged | When implemented by a class, occurs when user modifies any aspect of the control being designed.
Public event | DesignerHostChanged | When implemented by a class, occurs when designer host changes, for example if new form is loaded.
Public event | DesignSurfaceKeyDown | When implemented by a class, occurs when user presses a key when design surface is focused.
Public event | LoadingErrorOccured | When implemented by a class, occurs when there is a parse error of the design code during loading.
Public event | NavigateToUserMethodRequested | When implemented by a class, occurs when form designer is requested to navigate to the event handler. For example, when user double clicks on the control.
Public event | ReferencedAssembliesChanged |
Public event | SelectionChanged | When implemented by a class, occurs when user selects different control in the designer.
Public event | TypeDiscoveryRequested |
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl Methods

IFormDesignerControl Methods

The IFormDesignerControl type exposes the following members.

Methods
 | Name | Description
Public method | GetLocalizationLanguage | When implemented by a class, gets current culture information
Public method | RaiseComponentChanged |
Public method | Reload | When implemented by a class, reloads form to be designed from the source.
Public method | Save | When implemented by a class, serializes designer to C# or Visual Basic file.
Public method | SetLocalizationLanguage | When implemented by a class, sets current culture information
Top
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.GetLocalizationLanguage Method

IFormDesignerControlGetLocalizationLanguage Method
When implemented by a class, gets current culture information

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
CultureInfo GetLocalizationLanguage()
Function GetLocalizationLanguage As CultureInfo
CultureInfo^ GetLocalizationLanguage()
abstract GetLocalizationLanguage : unit -> CultureInfo

Return Value

Type: CultureInfo
Current culture info
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.RaiseComponentChanged Method

IFormDesignerControlRaiseComponentChanged Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RaiseComponentChanged(
    Object changedComponent
)
Sub RaiseComponentChanged (
    changedComponent As Object
)
void RaiseComponentChanged(
    Object^ changedComponent
)
abstract RaiseComponentChanged :
        changedComponent : Object -> unit

Parameters

changedComponent
Type: SystemObject
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.Reload Method

IFormDesignerControlReload Method
When implemented by a class, reloads form to be designed from the source.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reload()
Sub Reload
void Reload()
abstract Reload : unit -> unit
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.Save Method

IFormDesignerControlSave Method
When implemented by a class, serializes designer to C# or Visual Basic file.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save()
Sub Save
void Save()
abstract Save : unit -> unit
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.SetLocalizationLanguage Method

IFormDesignerControlSetLocalizationLanguage Method
When implemented by a class, sets current culture information

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetLocalizationLanguage(
    CultureInfo language
)
Sub SetLocalizationLanguage (
    language As CultureInfo
)
void SetLocalizationLanguage(
    CultureInfo^ language
)
abstract SetLocalizationLanguage :
        language : CultureInfo -> unit

Parameters

language
Type: System.GlobalizationCultureInfo
Culture information to set.
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl Properties

IFormDesignerControl Properties

The IFormDesignerControl type exposes the following members.

Properties
 | Name | Description
Public property | AutoAddComponentAssemblyReferences | When implemented by a class, gets or sets a boolean value indicating whether designer should automatically try to add assembly references after a control is added.
Public property | AutoSaveToSource | When implemented by a class, gets or sets a boolean value indicating whether designer should automatically translate changes to the source upon every change.
Public property | CommandKeyBindings | When implemented by a class, represents a list of CommandKeyBinding accepted by this FormDesignerControl.
Public property | DesignerCommands | When implemented by a class, represents a collection of standard designer commands like selecting, copying, pasting, moving and resizing controls.
Public property | DesignerHost | When implemented by a class, provides an interface for managing designer transactions and components..
Public property | ImportedNamespaces | When implemented by a class, in case of Visual Basic, gets collection of globally available namespaces.
Public property | IsBeingLoaded | When implemented by a class, gets a boolean value indicating that designer is currently being loaded.
Public property | IsModified | When implemented by a class, represents a value indicates whether designer content has been modified since last save.
Public property | IsSmartDiffCodeSerializationRequired | When implemented by a class, gets or sets method used to identify whether FormDesignerControl content should be saved only by taking into account code difference.
Public property | Options | When implemented by a class, gets designer options like snap settings, grid size etc.
Public property | PrimarySelection | When implemented by a class, gets first selected component or control.
Public property | ReferencedAssemblies | When implemented by a class, gets collection of assemblies where the controls and components used on the form being designed are declared.
Public property | SelectedComponents | When implemented by a class, contains list of selected components or controls.
Public property | ServiceContainer | When implemented by a class, represents a container for designer-related services.
Public property | Source | When implemented by a class, gets or sets FormDesigner Source.
Public property | ToolboxControl | When implemented by a class, gets or sets toolbox control associated with the designer.
Public property | UserData | When implemented by a class, gets or sets user-specific data associated with this Form Designer
Top
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.AutoAddComponentAssemblyReferences Property

IFormDesignerControlAutoAddComponentAssemblyReferences Property
When implemented by a class, gets or sets a boolean value indicating whether designer should automatically try to add assembly references after a control is added.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AutoAddComponentAssemblyReferences { get; set; }
Property AutoAddComponentAssemblyReferences As Boolean
    Get
    Set
property bool AutoAddComponentAssemblyReferences {
    bool get ();
    void set (bool value);
}
abstract AutoAddComponentAssemblyReferences : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.AutoSaveToSource Property

IFormDesignerControlAutoSaveToSource Property
When implemented by a class, gets or sets a boolean value indicating whether designer should automatically translate changes to the source upon every change.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AutoSaveToSource { get; set; }
Property AutoSaveToSource As Boolean
    Get
    Set
property bool AutoSaveToSource {
    bool get ();
    void set (bool value);
}
abstract AutoSaveToSource : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.CommandKeyBindings Property

IFormDesignerControlCommandKeyBindings Property
When implemented by a class, represents a list of CommandKeyBinding accepted by this FormDesignerControl.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
List<CommandKeyBinding> CommandKeyBindings { get; }
ReadOnly Property CommandKeyBindings As List(Of CommandKeyBinding)
    Get
property List<CommandKeyBinding^>^ CommandKeyBindings {
    List<CommandKeyBinding^>^ get ();
}
abstract CommandKeyBindings : List<CommandKeyBinding> with get

Property Value

Type: ListCommandKeyBinding
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.DesignerCommands Property

IFormDesignerControlDesignerCommands Property
When implemented by a class, represents a collection of standard designer commands like selecting, copying, pasting, moving and resizing controls.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IFormDesignerCommands DesignerCommands { get; }
ReadOnly Property DesignerCommands As IFormDesignerCommands
    Get
property IFormDesignerCommands^ DesignerCommands {
    IFormDesignerCommands^ get ();
}
abstract DesignerCommands : IFormDesignerCommands with get

Property Value

Type: IFormDesignerCommands
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.DesignerHost Property

IFormDesignerControlDesignerHost Property
When implemented by a class, provides an interface for managing designer transactions and components..

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDesignerHost DesignerHost { get; }
ReadOnly Property DesignerHost As IDesignerHost
    Get
property IDesignerHost^ DesignerHost {
    IDesignerHost^ get ();
}
abstract DesignerHost : IDesignerHost with get

Property Value

Type: IDesignerHost
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.ImportedNamespaces Property

IFormDesignerControlImportedNamespaces Property
When implemented by a class, in case of Visual Basic, gets collection of globally available namespaces.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DesignerImportedNamespaces ImportedNamespaces { get; set; }
Property ImportedNamespaces As DesignerImportedNamespaces
    Get
    Set
property DesignerImportedNamespaces^ ImportedNamespaces {
    DesignerImportedNamespaces^ get ();
    void set (DesignerImportedNamespaces^ value);
}
abstract ImportedNamespaces : DesignerImportedNamespaces with get, set

Property Value

Type: DesignerImportedNamespaces
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.IsBeingLoaded Property

IFormDesignerControlIsBeingLoaded Property
When implemented by a class, gets a boolean value indicating that designer is currently being loaded.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsBeingLoaded { get; }
ReadOnly Property IsBeingLoaded As Boolean
    Get
property bool IsBeingLoaded {
    bool get ();
}
abstract IsBeingLoaded : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.IsModified Property

IFormDesignerControlIsModified Property
When implemented by a class, represents a value indicates whether designer content has been modified since last save.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsModified { get; }
ReadOnly Property IsModified As Boolean
    Get
property bool IsModified {
    bool get ();
}
abstract IsModified : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.IsSmartDiffCodeSerializationRequired Property

IFormDesignerControlIsSmartDiffCodeSerializationRequired Property
When implemented by a class, gets or sets method used to identify whether FormDesignerControl content should be saved only by taking into account code difference.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Func<IFormDesignerControl, bool> IsSmartDiffCodeSerializationRequired { get; set; }
Property IsSmartDiffCodeSerializationRequired As Func(Of IFormDesignerControl, Boolean)
    Get
    Set
property Func<IFormDesignerControl^, bool>^ IsSmartDiffCodeSerializationRequired {
    Func<IFormDesignerControl^, bool>^ get ();
    void set (Func<IFormDesignerControl^, bool>^ value);
}
abstract IsSmartDiffCodeSerializationRequired : Func<IFormDesignerControl, bool> with get, set

Property Value

Type: FuncIFormDesignerControl, Boolean
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.Options Property

IFormDesignerControlOptions Property
When implemented by a class, gets designer options like snap settings, grid size etc.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
FormDesignerOptions Options { get; }
ReadOnly Property Options As FormDesignerOptions
    Get
property FormDesignerOptions^ Options {
    FormDesignerOptions^ get ();
}
abstract Options : FormDesignerOptions with get

Property Value

Type: FormDesignerOptions
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.PrimarySelection Property

IFormDesignerControlPrimarySelection Property
When implemented by a class, gets first selected component or control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IComponent PrimarySelection { get; }
ReadOnly Property PrimarySelection As IComponent
    Get
property IComponent^ PrimarySelection {
    IComponent^ get ();
}
abstract PrimarySelection : IComponent with get

Property Value

Type: IComponent
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.ReferencedAssemblies Property

IFormDesignerControlReferencedAssemblies Property
When implemented by a class, gets collection of assemblies where the controls and components used on the form being designed are declared.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DesignerReferencedAssemblies ReferencedAssemblies { get; set; }
Property ReferencedAssemblies As DesignerReferencedAssemblies
    Get
    Set
property DesignerReferencedAssemblies^ ReferencedAssemblies {
    DesignerReferencedAssemblies^ get ();
    void set (DesignerReferencedAssemblies^ value);
}
abstract ReferencedAssemblies : DesignerReferencedAssemblies with get, set

Property Value

Type: DesignerReferencedAssemblies
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.SelectedComponents Property

IFormDesignerControlSelectedComponents Property
When implemented by a class, contains list of selected components or controls.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<IComponent> SelectedComponents { get; set; }
Property SelectedComponents As IEnumerable(Of IComponent)
    Get
    Set
property IEnumerable<IComponent^>^ SelectedComponents {
    IEnumerable<IComponent^>^ get ();
    void set (IEnumerable<IComponent^>^ value);
}
abstract SelectedComponents : IEnumerable<IComponent> with get, set

Property Value

Type: IEnumerableIComponent
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.ServiceContainer Property

IFormDesignerControlServiceContainer Property
When implemented by a class, represents a container for designer-related services.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IServiceContainer ServiceContainer { get; }
ReadOnly Property ServiceContainer As IServiceContainer
    Get
property IServiceContainer^ ServiceContainer {
    IServiceContainer^ get ();
}
abstract ServiceContainer : IServiceContainer with get

Property Value

Type: IServiceContainer
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.Source Property

IFormDesignerControlSource Property
When implemented by a class, gets or sets FormDesigner Source.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IFormDesignerDataSource Source { get; set; }
Property Source As IFormDesignerDataSource
    Get
    Set
property IFormDesignerDataSource^ Source {
    IFormDesignerDataSource^ get ();
    void set (IFormDesignerDataSource^ value);
}
abstract Source : IFormDesignerDataSource with get, set

Property Value

Type: IFormDesignerDataSource
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.ToolboxControl Property

IFormDesignerControlToolboxControl Property
When implemented by a class, gets or sets toolbox control associated with the designer.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IToolboxControl ToolboxControl { get; set; }
Property ToolboxControl As IToolboxControl
    Get
    Set
property IToolboxControl^ ToolboxControl {
    IToolboxControl^ get ();
    void set (IToolboxControl^ value);
}
abstract ToolboxControl : IToolboxControl with get, set

Property Value

Type: IToolboxControl
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.UserData Property

IFormDesignerControlUserData Property
When implemented by a class, gets or sets user-specific data associated with this Form Designer

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDictionary<string, Object> UserData { get; }
ReadOnly Property UserData As IDictionary(Of String, Object)
    Get
property IDictionary<String^, Object^>^ UserData {
    IDictionary<String^, Object^>^ get ();
}
abstract UserData : IDictionary<string, Object> with get

Property Value

Type: IDictionaryString, Object
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl Events

IFormDesignerControl Events

The IFormDesignerControl type exposes the following members.

Events
 | Name | Description
Public event | CommandStateChanged | When implemented by a class, occurs when state of designer commands changes (for example when undo stack becomes available).
Public event | CompilerErrorClick | When implemented by a class, occurs when user clicks on compiler error on Form Designer surface.
Public event | ComponentAdded | When implemented by a class, occurs when some component was added on the designer surface.
Public event | ComponentChanged | Occurs when some component was changed on the designer surface.
Public event | ComponentRemoved | When implemented by a class, occurs when some component was removed from the designer surface.
Public event | DesignedContentChanged | When implemented by a class, occurs when user modifies any aspect of the control being designed.
Public event | DesignerHostChanged | When implemented by a class, occurs when designer host changes, for example if new form is loaded.
Public event | DesignSurfaceKeyDown | When implemented by a class, occurs when user presses a key when design surface is focused.
Public event | LoadingErrorOccured | When implemented by a class, occurs when there is a parse error of the design code during loading.
Public event | NavigateToUserMethodRequested | When implemented by a class, occurs when form designer is requested to navigate to the event handler. For example, when user double clicks on the control.
Public event | ReferencedAssembliesChanged |
Public event | SelectionChanged | When implemented by a class, occurs when user selects different control in the designer.
Public event | TypeDiscoveryRequested |
Top
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.CommandStateChanged Event

IFormDesignerControlCommandStateChanged Event
When implemented by a class, occurs when state of designer commands changes (for example when undo stack becomes available).

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler CommandStateChanged
Event CommandStateChanged As EventHandler
 event EventHandler^ CommandStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CommandStateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.CompilerErrorClick Event

IFormDesignerControlCompilerErrorClick Event
When implemented by a class, occurs when user clicks on compiler error on Form Designer surface.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<DesignerCompilerErrorClickEventArgs> CompilerErrorClick
Event CompilerErrorClick As EventHandler(Of DesignerCompilerErrorClickEventArgs)
 event EventHandler<DesignerCompilerErrorClickEventArgs^>^ CompilerErrorClick {
    void add (EventHandler<DesignerCompilerErrorClickEventArgs^>^ value);
    void remove (EventHandler<DesignerCompilerErrorClickEventArgs^>^ value);
}
abstract CompilerErrorClick : IEvent<EventHandler<DesignerCompilerErrorClickEventArgs>,
    DesignerCompilerErrorClickEventArgs>

Value

Type: SystemEventHandlerDesignerCompilerErrorClickEventArgs
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.ComponentAdded Event

IFormDesignerControlComponentAdded Event
When implemented by a class, occurs when some component was added on the designer surface.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ComponentEventArgs> ComponentAdded
Event ComponentAdded As EventHandler(Of ComponentEventArgs)
 event EventHandler<ComponentEventArgs^>^ ComponentAdded {
    void add (EventHandler<ComponentEventArgs^>^ value);
    void remove (EventHandler<ComponentEventArgs^>^ value);
}
abstract ComponentAdded : IEvent<EventHandler<ComponentEventArgs>,
    ComponentEventArgs>

Value

Type: SystemEventHandlerComponentEventArgs
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.ComponentChanged Event

IFormDesignerControlComponentChanged Event
Occurs when some component was changed on the designer surface.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ComponentChangedEventArgs> ComponentChanged
Event ComponentChanged As EventHandler(Of ComponentChangedEventArgs)
 event EventHandler<ComponentChangedEventArgs^>^ ComponentChanged {
    void add (EventHandler<ComponentChangedEventArgs^>^ value);
    void remove (EventHandler<ComponentChangedEventArgs^>^ value);
}
abstract ComponentChanged : IEvent<EventHandler<ComponentChangedEventArgs>,
    ComponentChangedEventArgs>

Value

Type: SystemEventHandlerComponentChangedEventArgs
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.ComponentRemoved Event

IFormDesignerControlComponentRemoved Event
When implemented by a class, occurs when some component was removed from the designer surface.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ComponentEventArgs> ComponentRemoved
Event ComponentRemoved As EventHandler(Of ComponentEventArgs)
 event EventHandler<ComponentEventArgs^>^ ComponentRemoved {
    void add (EventHandler<ComponentEventArgs^>^ value);
    void remove (EventHandler<ComponentEventArgs^>^ value);
}
abstract ComponentRemoved : IEvent<EventHandler<ComponentEventArgs>,
    ComponentEventArgs>

Value

Type: SystemEventHandlerComponentEventArgs
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.DesignedContentChanged Event

IFormDesignerControlDesignedContentChanged Event
When implemented by a class, occurs when user modifies any aspect of the control being designed.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler DesignedContentChanged
Event DesignedContentChanged As EventHandler
 event EventHandler^ DesignedContentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DesignedContentChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.DesignerHostChanged Event

IFormDesignerControlDesignerHostChanged Event
When implemented by a class, occurs when designer host changes, for example if new form is loaded.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler DesignerHostChanged
Event DesignerHostChanged As EventHandler
 event EventHandler^ DesignerHostChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DesignerHostChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.DesignSurfaceKeyDown Event

IFormDesignerControlDesignSurfaceKeyDown Event
When implemented by a class, occurs when user presses a key when design surface is focused.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event KeyEventHandler DesignSurfaceKeyDown
Event DesignSurfaceKeyDown As KeyEventHandler
 event KeyEventHandler^ DesignSurfaceKeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
abstract DesignSurfaceKeyDown : IEvent<KeyEventHandler,
    KeyEventArgs>

Value

Type: System.Windows.FormsKeyEventHandler
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.LoadingErrorOccured Event

IFormDesignerControlLoadingErrorOccured Event
When implemented by a class, occurs when there is a parse error of the design code during loading.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<DesignerLoadingErrorEventArgs> LoadingErrorOccured
Event LoadingErrorOccured As EventHandler(Of DesignerLoadingErrorEventArgs)
 event EventHandler<DesignerLoadingErrorEventArgs^>^ LoadingErrorOccured {
    void add (EventHandler<DesignerLoadingErrorEventArgs^>^ value);
    void remove (EventHandler<DesignerLoadingErrorEventArgs^>^ value);
}
abstract LoadingErrorOccured : IEvent<EventHandler<DesignerLoadingErrorEventArgs>,
    DesignerLoadingErrorEventArgs>

Value

Type: SystemEventHandlerDesignerLoadingErrorEventArgs
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.NavigateToUserMethodRequested Event

IFormDesignerControlNavigateToUserMethodRequested Event
When implemented by a class, occurs when form designer is requested to navigate to the event handler. For example, when user double clicks on the control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<NavigateToUserMethodRequestedEventArgs> NavigateToUserMethodRequested
Event NavigateToUserMethodRequested As EventHandler(Of NavigateToUserMethodRequestedEventArgs)
 event EventHandler<NavigateToUserMethodRequestedEventArgs^>^ NavigateToUserMethodRequested {
    void add (EventHandler<NavigateToUserMethodRequestedEventArgs^>^ value);
    void remove (EventHandler<NavigateToUserMethodRequestedEventArgs^>^ value);
}
abstract NavigateToUserMethodRequested : IEvent<EventHandler<NavigateToUserMethodRequestedEventArgs>,
    NavigateToUserMethodRequestedEventArgs>

Value

Type: SystemEventHandlerNavigateToUserMethodRequestedEventArgs
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.ReferencedAssembliesChanged Event

IFormDesignerControlReferencedAssembliesChanged Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ReferencedAssembliesChanged
Event ReferencedAssembliesChanged As EventHandler
 event EventHandler^ ReferencedAssembliesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ReferencedAssembliesChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.SelectionChanged Event

IFormDesignerControlSelectionChanged Event
When implemented by a class, occurs when user selects different control in the designer.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SelectionChanged
Event SelectionChanged As EventHandler
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerControl.TypeDiscoveryRequested Event

IFormDesignerControlTypeDiscoveryRequested Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<TypeDiscoveryEventArgs> TypeDiscoveryRequested
Event TypeDiscoveryRequested As EventHandler(Of TypeDiscoveryEventArgs)
 event EventHandler<TypeDiscoveryEventArgs^>^ TypeDiscoveryRequested {
    void add (EventHandler<TypeDiscoveryEventArgs^>^ value);
    void remove (EventHandler<TypeDiscoveryEventArgs^>^ value);
}
abstract TypeDiscoveryRequested : IEvent<EventHandler<TypeDiscoveryEventArgs>,
    TypeDiscoveryEventArgs>

Value

Type: SystemEventHandlerTypeDiscoveryEventArgs
See Also

Reference

IFormDesignerControl Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource Interface

IFormDesignerDataSource Interface
Represents a properties and methods for a Form Designer control's data source.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFormDesignerDataSource
Public Interface IFormDesignerDataSource
public interface class IFormDesignerDataSource
type IFormDesignerDataSource =  interface end

The IFormDesignerDataSource type exposes the following members.

Methods
 | Name | Description
Public method | GetResourceFileName | When implemented by a class, gets resource file specific to the culture.
Public method | InsertTextIntoUserCode | When implemented by a class, inserts specified text fragments into the user code.
Public method | OpenDesignerStream | When implemented by a class, opens designer stream with specified access mode.
Public method | OpenResourceStream | When implemented by a class, opens resource stream with specified access mode.
Public method | OpenUserCodeStreamForReading | When implemented by a class, opens user code stream with default access mode.
Public method | ReplaceTextInDesignerCode | When implemented by a class, replaces specified text fragments within the user code.
Top
Properties
 | Name | Description
Public property | AssemblyResources | When implemented by a class, gets the list of form designer's assembly resources.
Public property | DesignedClassFullName | When implemented by a class, gets the fully qualified name of designed class.
Public property | DesignedComponentAssembly |
Public property | DesignerFileName | When implemented by a class, gets name of the file with designer generated code.
Public property | IsModified | When implemented by a class, represents a value indicating whether designer content has been modified since last save.
Public property | UserCodeFileName | When implemented by a class, gets name of the file with user code.
Top
Events
 | Name | Description
Public event | ResourceCultureAdded |
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource Methods

IFormDesignerDataSource Methods

The IFormDesignerDataSource type exposes the following members.

Methods
 | Name | Description
Public method | GetResourceFileName | When implemented by a class, gets resource file specific to the culture.
Public method | InsertTextIntoUserCode | When implemented by a class, inserts specified text fragments into the user code.
Public method | OpenDesignerStream | When implemented by a class, opens designer stream with specified access mode.
Public method | OpenResourceStream | When implemented by a class, opens resource stream with specified access mode.
Public method | OpenUserCodeStreamForReading | When implemented by a class, opens user code stream with default access mode.
Public method | ReplaceTextInDesignerCode | When implemented by a class, replaces specified text fragments within the user code.
Top
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.GetResourceFileName Method

IFormDesignerDataSourceGetResourceFileName Method
When implemented by a class, gets resource file specific to the culture.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetResourceFileName(
    CultureInfo cultureInfo
)
Function GetResourceFileName (
    cultureInfo As CultureInfo
) As String
String^ GetResourceFileName(
    CultureInfo^ cultureInfo
)
abstract GetResourceFileName :
        cultureInfo : CultureInfo -> string

Parameters

cultureInfo
Type: System.GlobalizationCultureInfo
Culture information

Return Value

Type: String
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.InsertTextIntoUserCode Method

IFormDesignerDataSourceInsertTextIntoUserCode Method
When implemented by a class, inserts specified text fragments into the user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertTextIntoUserCode(
    FormDesignerTextSourceOperationsTextInsertionOperation[] operations
)
Sub InsertTextIntoUserCode (
    operations As FormDesignerTextSourceOperationsTextInsertionOperation()
)
void InsertTextIntoUserCode(
    array<FormDesignerTextSourceOperationsTextInsertionOperation^>^ operations
)
abstract InsertTextIntoUserCode :
        operations : FormDesignerTextSourceOperationsTextInsertionOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextInsertionOperation
Contains data to insert.
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.OpenDesignerStream Method

IFormDesignerDataSourceOpenDesignerStream Method
When implemented by a class, opens designer stream with specified access mode.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Stream OpenDesignerStream(
    StreamAccessMode mode
)
Function OpenDesignerStream (
    mode As StreamAccessMode
) As Stream
Stream^ OpenDesignerStream(
    StreamAccessMode mode
)
abstract OpenDesignerStream :
        mode : StreamAccessMode -> Stream

Parameters

mode
Type: Alternet.FormDesigner.WinFormsStreamAccessMode
Specifies operation can be performed on the stream.

Return Value

Type: Stream
Designer stream.
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.OpenResourceStream Method

IFormDesignerDataSourceOpenResourceStream Method
When implemented by a class, opens resource stream with specified access mode.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Stream OpenResourceStream(
    StreamAccessMode mode,
    CultureInfo cultureInfo
)
Function OpenResourceStream (
    mode As StreamAccessMode,
    cultureInfo As CultureInfo
) As Stream
Stream^ OpenResourceStream(
    StreamAccessMode mode,
    CultureInfo^ cultureInfo
)
abstract OpenResourceStream :
        mode : StreamAccessMode *
        cultureInfo : CultureInfo -> Stream

Parameters

mode
Type: Alternet.FormDesigner.WinFormsStreamAccessMode
Specifies operation can be performed on the stream.
cultureInfo
Type: System.GlobalizationCultureInfo
Specifies information about a specific culture.

Return Value

Type: Stream
Resource stream.
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.OpenUserCodeStreamForReading Method

IFormDesignerDataSourceOpenUserCodeStreamForReading Method
When implemented by a class, opens user code stream with default access mode.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Stream OpenUserCodeStreamForReading()
Function OpenUserCodeStreamForReading As Stream
Stream^ OpenUserCodeStreamForReading()
abstract OpenUserCodeStreamForReading : unit -> Stream

Return Value

Type: Stream
User code stream.
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.ReplaceTextInDesignerCode Method

IFormDesignerDataSourceReplaceTextInDesignerCode Method
When implemented by a class, replaces specified text fragments within the user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReplaceTextInDesignerCode(
    FormDesignerTextSourceOperationsTextReplacementOperation[] operations
)
Sub ReplaceTextInDesignerCode (
    operations As FormDesignerTextSourceOperationsTextReplacementOperation()
)
void ReplaceTextInDesignerCode(
    array<FormDesignerTextSourceOperationsTextReplacementOperation^>^ operations
)
abstract ReplaceTextInDesignerCode :
        operations : FormDesignerTextSourceOperationsTextReplacementOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextReplacementOperation
Contains data to replace.
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource Properties

IFormDesignerDataSource Properties

The IFormDesignerDataSource type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyResources | When implemented by a class, gets the list of form designer's assembly resources.
Public property | DesignedClassFullName | When implemented by a class, gets the fully qualified name of designed class.
Public property | DesignedComponentAssembly |
Public property | DesignerFileName | When implemented by a class, gets name of the file with designer generated code.
Public property | IsModified | When implemented by a class, represents a value indicating whether designer content has been modified since last save.
Public property | UserCodeFileName | When implemented by a class, gets name of the file with user code.
Top
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.AssemblyResources Property

IFormDesignerDataSourceAssemblyResources Property
When implemented by a class, gets the list of form designer's assembly resources.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<DesignerAssemblyResources> AssemblyResources { get; }
ReadOnly Property AssemblyResources As IEnumerable(Of DesignerAssemblyResources)
    Get
property IEnumerable<DesignerAssemblyResources^>^ AssemblyResources {
    IEnumerable<DesignerAssemblyResources^>^ get ();
}
abstract AssemblyResources : IEnumerable<DesignerAssemblyResources> with get

Property Value

Type: IEnumerableDesignerAssemblyResources
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.DesignedClassFullName Property

IFormDesignerDataSourceDesignedClassFullName Property
When implemented by a class, gets the fully qualified name of designed class.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string DesignedClassFullName { get; }
ReadOnly Property DesignedClassFullName As String
    Get
property String^ DesignedClassFullName {
    String^ get ();
}
abstract DesignedClassFullName : string with get

Property Value

Type: String
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.DesignedComponentAssembly Property

IFormDesignerDataSourceDesignedComponentAssembly Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDesignedComponentAssemblyProvider DesignedComponentAssembly { get; }
ReadOnly Property DesignedComponentAssembly As IDesignedComponentAssemblyProvider
    Get
property IDesignedComponentAssemblyProvider^ DesignedComponentAssembly {
    IDesignedComponentAssemblyProvider^ get ();
}
abstract DesignedComponentAssembly : IDesignedComponentAssemblyProvider with get

Property Value

Type: IDesignedComponentAssemblyProvider
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.DesignerFileName Property

IFormDesignerDataSourceDesignerFileName Property
When implemented by a class, gets name of the file with designer generated code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string DesignerFileName { get; }
ReadOnly Property DesignerFileName As String
    Get
property String^ DesignerFileName {
    String^ get ();
}
abstract DesignerFileName : string with get

Property Value

Type: String
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.IsModified Property

IFormDesignerDataSourceIsModified Property
When implemented by a class, represents a value indicating whether designer content has been modified since last save.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsModified { get; }
ReadOnly Property IsModified As Boolean
    Get
property bool IsModified {
    bool get ();
}
abstract IsModified : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.UserCodeFileName Property

IFormDesignerDataSourceUserCodeFileName Property
When implemented by a class, gets name of the file with user code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string UserCodeFileName { get; }
ReadOnly Property UserCodeFileName As String
    Get
property String^ UserCodeFileName {
    String^ get ();
}
abstract UserCodeFileName : string with get

Property Value

Type: String
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource Events

IFormDesignerDataSource Events

The IFormDesignerDataSource type exposes the following members.

Events
 | Name | Description
Public event | ResourceCultureAdded |
Top
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerDataSource.ResourceCultureAdded Event

IFormDesignerDataSourceResourceCultureAdded Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ResourceCultureAddedEventArgs> ResourceCultureAdded
Event ResourceCultureAdded As EventHandler(Of ResourceCultureAddedEventArgs)
 event EventHandler<ResourceCultureAddedEventArgs^>^ ResourceCultureAdded {
    void add (EventHandler<ResourceCultureAddedEventArgs^>^ value);
    void remove (EventHandler<ResourceCultureAddedEventArgs^>^ value);
}
abstract ResourceCultureAdded : IEvent<EventHandler<ResourceCultureAddedEventArgs>,
    ResourceCultureAddedEventArgs>

Value

Type: SystemEventHandlerResourceCultureAddedEventArgs
See Also

Reference

IFormDesignerDataSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext Interface

IFormDesignerHostContext Interface
Represents methods and properties declaration to encapsulate designer host together with the actual form designer control and its state.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFormDesignerHostContext : IDisposable
Public Interface IFormDesignerHostContext
    Inherits IDisposable
public interface class IFormDesignerHostContext : IDisposable
type IFormDesignerHostContext =
    interface
        interface IDisposable
    end

The IFormDesignerHostContext type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RaiseComponentChanged |
Public method | Save | When implemented by a class, saves designer's content.
Top
Properties
 | Name | Description
Public property | DesignerControl | When implemented by a class, represents the view for the root designer.
Public property | DesignerHost | When implemented by a class, represents IDesignerHost object encapsulated in this host.
Public property | DesignerLoader | When implemented by a class, represents an object provides load and save designer's content functionality.
Public property | Owner | When implemented by a class, represents an actual form designer control.
Public property | PrimarySelection | When implemented by a class, represents first selected component or control.
Public property | SelectedComponents | When implemented by a class, represents list of selected components or controls.
Public property | ServiceContainer | When implemented by a class, represents a container for designer-related services.
Public property | Source | When implemented by a class, represents data source of the designer control.
Public property | ToolboxService | When implemented by a class, represents an object provides communication between the designer and toolbox.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext Methods

IFormDesignerHostContext Methods

The IFormDesignerHostContext type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RaiseComponentChanged |
Public method | Save | When implemented by a class, saves designer's content.
Top
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.RaiseComponentChanged Method

IFormDesignerHostContextRaiseComponentChanged Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RaiseComponentChanged(
    Object changedComponent
)
Sub RaiseComponentChanged (
    changedComponent As Object
)
void RaiseComponentChanged(
    Object^ changedComponent
)
abstract RaiseComponentChanged :
        changedComponent : Object -> unit

Parameters

changedComponent
Type: SystemObject
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.Save Method

IFormDesignerHostContextSave Method
When implemented by a class, saves designer's content.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save()
Sub Save
void Save()
abstract Save : unit -> unit
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext Properties

IFormDesignerHostContext Properties

The IFormDesignerHostContext type exposes the following members.

Properties
 | Name | Description
Public property | DesignerControl | When implemented by a class, represents the view for the root designer.
Public property | DesignerHost | When implemented by a class, represents IDesignerHost object encapsulated in this host.
Public property | DesignerLoader | When implemented by a class, represents an object provides load and save designer's content functionality.
Public property | Owner | When implemented by a class, represents an actual form designer control.
Public property | PrimarySelection | When implemented by a class, represents first selected component or control.
Public property | SelectedComponents | When implemented by a class, represents list of selected components or controls.
Public property | ServiceContainer | When implemented by a class, represents a container for designer-related services.
Public property | Source | When implemented by a class, represents data source of the designer control.
Public property | ToolboxService | When implemented by a class, represents an object provides communication between the designer and toolbox.
Top
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.DesignerControl Property

IFormDesignerHostContextDesignerControl Property
When implemented by a class, represents the view for the root designer.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Control DesignerControl { get; }
ReadOnly Property DesignerControl As Control
    Get
property Control^ DesignerControl {
    Control^ get ();
}
abstract DesignerControl : Control with get

Property Value

Type: Control
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.DesignerHost Property

IFormDesignerHostContextDesignerHost Property
When implemented by a class, represents IDesignerHost object encapsulated in this host.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDesignerHost DesignerHost { get; }
ReadOnly Property DesignerHost As IDesignerHost
    Get
property IDesignerHost^ DesignerHost {
    IDesignerHost^ get ();
}
abstract DesignerHost : IDesignerHost with get

Property Value

Type: IDesignerHost
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.DesignerLoader Property

IFormDesignerHostContextDesignerLoader Property
When implemented by a class, represents an object provides load and save designer's content functionality.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IFormDesignerLoader DesignerLoader { get; }
ReadOnly Property DesignerLoader As IFormDesignerLoader
    Get
property IFormDesignerLoader^ DesignerLoader {
    IFormDesignerLoader^ get ();
}
abstract DesignerLoader : IFormDesignerLoader with get

Property Value

Type: IFormDesignerLoader
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.Owner Property

IFormDesignerHostContextOwner Property
When implemented by a class, represents an actual form designer control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IFormDesignerControl Owner { get; }
ReadOnly Property Owner As IFormDesignerControl
    Get
property IFormDesignerControl^ Owner {
    IFormDesignerControl^ get ();
}
abstract Owner : IFormDesignerControl with get

Property Value

Type: IFormDesignerControl
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.PrimarySelection Property

IFormDesignerHostContextPrimarySelection Property
When implemented by a class, represents first selected component or control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IComponent PrimarySelection { get; }
ReadOnly Property PrimarySelection As IComponent
    Get
property IComponent^ PrimarySelection {
    IComponent^ get ();
}
abstract PrimarySelection : IComponent with get

Property Value

Type: IComponent
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.SelectedComponents Property

IFormDesignerHostContextSelectedComponents Property
When implemented by a class, represents list of selected components or controls.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<IComponent> SelectedComponents { get; set; }
Property SelectedComponents As IEnumerable(Of IComponent)
    Get
    Set
property IEnumerable<IComponent^>^ SelectedComponents {
    IEnumerable<IComponent^>^ get ();
    void set (IEnumerable<IComponent^>^ value);
}
abstract SelectedComponents : IEnumerable<IComponent> with get, set

Property Value

Type: IEnumerableIComponent
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.ServiceContainer Property

IFormDesignerHostContextServiceContainer Property
When implemented by a class, represents a container for designer-related services.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IServiceContainer ServiceContainer { get; }
ReadOnly Property ServiceContainer As IServiceContainer
    Get
property IServiceContainer^ ServiceContainer {
    IServiceContainer^ get ();
}
abstract ServiceContainer : IServiceContainer with get

Property Value

Type: IServiceContainer
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.Source Property

IFormDesignerHostContextSource Property
When implemented by a class, represents data source of the designer control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IFormDesignerDataSource Source { get; }
ReadOnly Property Source As IFormDesignerDataSource
    Get
property IFormDesignerDataSource^ Source {
    IFormDesignerDataSource^ get ();
}
abstract Source : IFormDesignerDataSource with get

Property Value

Type: IFormDesignerDataSource
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerHostContext.ToolboxService Property

IFormDesignerHostContextToolboxService Property
When implemented by a class, represents an object provides communication between the designer and toolbox.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IToolboxServiceExtended ToolboxService { get; }
ReadOnly Property ToolboxService As IToolboxServiceExtended
    Get
property IToolboxServiceExtended^ ToolboxService {
    IToolboxServiceExtended^ get ();
}
abstract ToolboxService : IToolboxServiceExtended with get

Property Value

Type: IToolboxServiceExtended
See Also

Reference

IFormDesignerHostContext Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerLoader Interface

IFormDesignerLoader Interface
Represents methods and properties declaration to load and save designer's content.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFormDesignerLoader
Public Interface IFormDesignerLoader
public interface class IFormDesignerLoader
type IFormDesignerLoader =  interface end

The IFormDesignerLoader type exposes the following members.

Methods
 | Name | Description
Public method | Save | When implemented by a class, saves designer's content.
Public method | Save(StringBuilder) | When implemented by a class, saves designer's content into the specified target.
Top
Properties
 | Name | Description
Public property | IsModified | When implemented by a class, represents a boolean value indicating whether designer content has been modified since last save.
Public property | Loader | When implemented by a class, represents an object used to load designer's content.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IFormDesignerLoader Methods

IFormDesignerLoader Methods
Methods
 | Name | Description
Public method | Save | When implemented by a class, saves designer's content.
Public method | Save(StringBuilder) | When implemented by a class, saves designer's content into the specified target.
Top
See Also

Reference

IFormDesignerLoader Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerLoader.Save Method

IFormDesignerLoaderSave Method
Overload List
 | Name | Description
Public method | Save | When implemented by a class, saves designer's content.
Public method | Save(StringBuilder) | When implemented by a class, saves designer's content into the specified target.
Top
See Also

Reference

IFormDesignerLoader Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerLoader.Save Method

IFormDesignerLoaderSave Method
When implemented by a class, saves designer's content.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save()
Sub Save
void Save()
abstract Save : unit -> unit
See Also

Reference

IFormDesignerLoader Interface
Save Overload
Alternet.FormDesigner.WinForms Namespace


IFormDesignerLoader.Save Method (StringBuilder)

IFormDesignerLoaderSave Method (StringBuilder)
When implemented by a class, saves designer's content into the specified target.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save(
    StringBuilder target
)
Sub Save (
    target As StringBuilder
)
void Save(
    StringBuilder^ target
)
abstract Save :
        target : StringBuilder -> unit

Parameters

target
Type: System.TextStringBuilder
Destination where content should be saved.
See Also

Reference

IFormDesignerLoader Interface
Save Overload
Alternet.FormDesigner.WinForms Namespace


IFormDesignerLoader Properties

IFormDesignerLoader Properties

The IFormDesignerLoader type exposes the following members.

Properties
 | Name | Description
Public property | IsModified | When implemented by a class, represents a boolean value indicating whether designer content has been modified since last save.
Public property | Loader | When implemented by a class, represents an object used to load designer's content.
Top
See Also

Reference

IFormDesignerLoader Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerLoader.IsModified Property

IFormDesignerLoaderIsModified Property
When implemented by a class, represents a boolean value indicating whether designer content has been modified since last save.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsModified { get; }
ReadOnly Property IsModified As Boolean
    Get
property bool IsModified {
    bool get ();
}
abstract IsModified : bool with get

Property Value

Type: Boolean
See Also

Reference

IFormDesignerLoader Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerLoader.Loader Property

IFormDesignerLoaderLoader Property
When implemented by a class, represents an object used to load designer's content.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DesignerLoader Loader { get; }
ReadOnly Property Loader As DesignerLoader
    Get
property DesignerLoader^ Loader {
    DesignerLoader^ get ();
}
abstract Loader : DesignerLoader with get

Property Value

Type: DesignerLoader
See Also

Reference

IFormDesignerLoader Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerTextSource Interface

IFormDesignerTextSource Interface
Represents a properties and methods for a Form Designer control's text.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFormDesignerTextSource
Public Interface IFormDesignerTextSource
public interface class IFormDesignerTextSource
type IFormDesignerTextSource =  interface end

The IFormDesignerTextSource type exposes the following members.

Methods
 | Name | Description
Public method | InsertText | When implemented by a class, performs number of text insertions defined in the specified operations.
Public method | LoadFile | When implemented by a class, loads the contents of a text file into Text property.
Public method | ReplaceText | When implemented by a class, performs number of text replacements defined in the specified operations.
Public method | SaveFile | When implemented by a class, saves IFormDesignerTextSource content to the specific file.
Top
Properties
 | Name | Description
Public property | Text | When implemented by a class, gets or sets text source content as a single string with the individual strings delimited by carriage returns.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IFormDesignerTextSource Methods

IFormDesignerTextSource Methods

The IFormDesignerTextSource type exposes the following members.

Methods
 | Name | Description
Public method | InsertText | When implemented by a class, performs number of text insertions defined in the specified operations.
Public method | LoadFile | When implemented by a class, loads the contents of a text file into Text property.
Public method | ReplaceText | When implemented by a class, performs number of text replacements defined in the specified operations.
Public method | SaveFile | When implemented by a class, saves IFormDesignerTextSource content to the specific file.
Top
See Also

Reference

IFormDesignerTextSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerTextSource.InsertText Method

IFormDesignerTextSourceInsertText Method
When implemented by a class, performs number of text insertions defined in the specified operations.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertText(
    FormDesignerTextSourceOperationsTextInsertionOperation[] operations
)
Sub InsertText (
    operations As FormDesignerTextSourceOperationsTextInsertionOperation()
)
void InsertText(
    array<FormDesignerTextSourceOperationsTextInsertionOperation^>^ operations
)
abstract InsertText :
        operations : FormDesignerTextSourceOperationsTextInsertionOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextInsertionOperation
List of operation each one contains insertion data.
See Also

Reference

IFormDesignerTextSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerTextSource.LoadFile Method

IFormDesignerTextSourceLoadFile Method
When implemented by a class, loads the contents of a text file into Text property.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadFile(
    string filePath
)
Function LoadFile (
    filePath As String
) As Boolean
bool LoadFile(
    String^ filePath
)
abstract LoadFile :
        filePath : string -> bool

Parameters

filePath
Type: SystemString
Represents name of file on disk.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IFormDesignerTextSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerTextSource.ReplaceText Method

IFormDesignerTextSourceReplaceText Method
When implemented by a class, performs number of text replacements defined in the specified operations.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReplaceText(
    FormDesignerTextSourceOperationsTextReplacementOperation[] operations
)
Sub ReplaceText (
    operations As FormDesignerTextSourceOperationsTextReplacementOperation()
)
void ReplaceText(
    array<FormDesignerTextSourceOperationsTextReplacementOperation^>^ operations
)
abstract ReplaceText :
        operations : FormDesignerTextSourceOperationsTextReplacementOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextReplacementOperation
List of operation each one contains replacement data.
See Also

Reference

IFormDesignerTextSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerTextSource.SaveFile Method

IFormDesignerTextSourceSaveFile Method
When implemented by a class, saves IFormDesignerTextSource content to the specific file.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveFile(
    string filePath
)
Function SaveFile (
    filePath As String
) As Boolean
bool SaveFile(
    String^ filePath
)
abstract SaveFile :
        filePath : string -> bool

Parameters

filePath
Type: SystemString
Name of the file to save content.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IFormDesignerTextSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerTextSource Properties

IFormDesignerTextSource Properties

The IFormDesignerTextSource type exposes the following members.

Properties
 | Name | Description
Public property | Text | When implemented by a class, gets or sets text source content as a single string with the individual strings delimited by carriage returns.
Top
See Also

Reference

IFormDesignerTextSource Interface
Alternet.FormDesigner.WinForms Namespace


IFormDesignerTextSource.Text Property

IFormDesignerTextSourceText Property
When implemented by a class, gets or sets text source content as a single string with the individual strings delimited by carriage returns.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IFormDesignerTextSource Interface
Alternet.FormDesigner.WinForms Namespace


InsertTextIntoCodeDelegate Delegate

InsertTextIntoCodeDelegate Delegate
Represents a method that will handle inserting text into user's code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void InsertTextIntoCodeDelegate(
    FormDesignerTextSourceOperationsTextInsertionOperation[] operations
)
Public Delegate Sub InsertTextIntoCodeDelegate (
    operations As FormDesignerTextSourceOperationsTextInsertionOperation()
)
public delegate void InsertTextIntoCodeDelegate(
    array<FormDesignerTextSourceOperationsTextInsertionOperation^>^ operations
)
type InsertTextIntoCodeDelegate =
    delegate of
        operations : FormDesignerTextSourceOperationsTextInsertionOperation[] -> unit

Parameters

operations
Type: Alternet.FormDesigner.WinFormsFormDesignerTextSourceOperationsTextInsertionOperation
Contains data to insert.
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IOutlineControl Interface

IOutlineControl Interface
Represents the outline control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IOutlineControl
Public Interface IOutlineControl
public interface class IOutlineControl
type IOutlineControl =  interface end

The IOutlineControl type exposes the following members.

Methods
 | Name | Description
Public method | MoveDown | When implemented by a class, moves outline item down in the container.
Public method | MoveIn | When implemented by a class, moves outline item into the next container.
Public method | MoveOut | When implemented by a class, moves outline item out of current container.
Public method | MoveUp | When implemented by a class, moves outline item up in the container.
Public method | ShowRenameSelectedNodeUI | When implemented by a class, starts the editing of the outline item name.
Top
Properties
 | Name | Description
Public property | FormDesignerControl | When implemented by a class, gets or sets an IFormDesignerControl related to this outline control.
Public property | Toolbox | When implemented by a class, gets or sets an IToolboxControl related to this outline control.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IOutlineControl Methods

IOutlineControl Methods

The IOutlineControl type exposes the following members.

Methods
 | Name | Description
Public method | MoveDown | When implemented by a class, moves outline item down in the container.
Public method | MoveIn | When implemented by a class, moves outline item into the next container.
Public method | MoveOut | When implemented by a class, moves outline item out of current container.
Public method | MoveUp | When implemented by a class, moves outline item up in the container.
Public method | ShowRenameSelectedNodeUI | When implemented by a class, starts the editing of the outline item name.
Top
See Also

Reference

IOutlineControl Interface
Alternet.FormDesigner.WinForms Namespace


IOutlineControl.MoveDown Method

IOutlineControlMoveDown Method
When implemented by a class, moves outline item down in the container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveDown()
Sub MoveDown
void MoveDown()
abstract MoveDown : unit -> unit
See Also

Reference

IOutlineControl Interface
Alternet.FormDesigner.WinForms Namespace


IOutlineControl.MoveIn Method

IOutlineControlMoveIn Method
When implemented by a class, moves outline item into the next container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveIn()
Sub MoveIn
void MoveIn()
abstract MoveIn : unit -> unit
See Also

Reference

IOutlineControl Interface
Alternet.FormDesigner.WinForms Namespace


IOutlineControl.MoveOut Method

IOutlineControlMoveOut Method
When implemented by a class, moves outline item out of current container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveOut()
Sub MoveOut
void MoveOut()
abstract MoveOut : unit -> unit
See Also

Reference

IOutlineControl Interface
Alternet.FormDesigner.WinForms Namespace


IOutlineControl.MoveUp Method

IOutlineControlMoveUp Method
When implemented by a class, moves outline item up in the container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveUp()
Sub MoveUp
void MoveUp()
abstract MoveUp : unit -> unit
See Also

Reference

IOutlineControl Interface
Alternet.FormDesigner.WinForms Namespace


IOutlineControl.ShowRenameSelectedNodeUI Method

IOutlineControlShowRenameSelectedNodeUI Method
When implemented by a class, starts the editing of the outline item name.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ShowRenameSelectedNodeUI()
Sub ShowRenameSelectedNodeUI
void ShowRenameSelectedNodeUI()
abstract ShowRenameSelectedNodeUI : unit -> unit
See Also

Reference

IOutlineControl Interface
Alternet.FormDesigner.WinForms Namespace


IOutlineControl Properties

IOutlineControl Properties

The IOutlineControl type exposes the following members.

Properties
 | Name | Description
Public property | FormDesignerControl | When implemented by a class, gets or sets an IFormDesignerControl related to this outline control.
Public property | Toolbox | When implemented by a class, gets or sets an IToolboxControl related to this outline control.
Top
See Also

Reference

IOutlineControl Interface
Alternet.FormDesigner.WinForms Namespace


IOutlineControl.FormDesignerControl Property

IOutlineControlFormDesignerControl Property
When implemented by a class, gets or sets an IFormDesignerControl related to this outline control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IFormDesignerControl FormDesignerControl { get; set; }
Property FormDesignerControl As IFormDesignerControl
    Get
    Set
property IFormDesignerControl^ FormDesignerControl {
    IFormDesignerControl^ get ();
    void set (IFormDesignerControl^ value);
}
abstract FormDesignerControl : IFormDesignerControl with get, set

Property Value

Type: IFormDesignerControl
See Also

Reference

IOutlineControl Interface
Alternet.FormDesigner.WinForms Namespace


IOutlineControl.Toolbox Property

IOutlineControlToolbox Property
When implemented by a class, gets or sets an IToolboxControl related to this outline control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IToolboxControl Toolbox { get; set; }
Property Toolbox As IToolboxControl
    Get
    Set
property IToolboxControl^ Toolbox {
    IToolboxControl^ get ();
    void set (IToolboxControl^ value);
}
abstract Toolbox : IToolboxControl with get, set

Property Value

Type: IToolboxControl
See Also

Reference

IOutlineControl Interface
Alternet.FormDesigner.WinForms Namespace


IPropertyGridControl Interface

IPropertyGridControl Interface
Provides a user interface for browsing the properties and methods of an object.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPropertyGridControl
Public Interface IPropertyGridControl
public interface class IPropertyGridControl
type IPropertyGridControl =  interface end

The IPropertyGridControl type exposes the following members.

Properties
 | Name | Description
Public property | FormDesignerControl | When implemented by a class, gets or sets an IFormDesignerControl related to this property grid.
Public property | SelectedObjects | When implemented by a class, gets or sets the currently selected objects.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IPropertyGridControl Properties

IPropertyGridControl Properties

The IPropertyGridControl type exposes the following members.

Properties
 | Name | Description
Public property | FormDesignerControl | When implemented by a class, gets or sets an IFormDesignerControl related to this property grid.
Public property | SelectedObjects | When implemented by a class, gets or sets the currently selected objects.
Top
See Also

Reference

IPropertyGridControl Interface
Alternet.FormDesigner.WinForms Namespace


IPropertyGridControl.FormDesignerControl Property

IPropertyGridControlFormDesignerControl Property
When implemented by a class, gets or sets an IFormDesignerControl related to this property grid.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IFormDesignerControl FormDesignerControl { get; set; }
Property FormDesignerControl As IFormDesignerControl
    Get
    Set
property IFormDesignerControl^ FormDesignerControl {
    IFormDesignerControl^ get ();
    void set (IFormDesignerControl^ value);
}
abstract FormDesignerControl : IFormDesignerControl with get, set

Property Value

Type: IFormDesignerControl
See Also

Reference

IPropertyGridControl Interface
Alternet.FormDesigner.WinForms Namespace


IPropertyGridControl.SelectedObjects Property

IPropertyGridControlSelectedObjects Property
When implemented by a class, gets or sets the currently selected objects.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object[] SelectedObjects { get; set; }
Property SelectedObjects As Object()
    Get
    Set
property array<Object^>^ SelectedObjects {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}
abstract SelectedObjects : Object[] with get, set

Property Value

Type: Object
See Also

Reference

IPropertyGridControl Interface
Alternet.FormDesigner.WinForms Namespace


IResourceServiceExtended Interface

IResourceServiceExtended Interface
Provides an additional interface for designers to access resource readers and writers for specific System.Globalization.CultureInfo resource types.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IResourceServiceExtended : IResourceService,
    IDisposable
Public Interface IResourceServiceExtended
    Inherits IResourceService, IDisposable
public interface class IResourceServiceExtended : IResourceService,
    IDisposable
type IResourceServiceExtended =
    interface
        interface IResourceService
        interface IDisposable
    end

The IResourceServiceExtended type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetResourceReader | Locates the resource reader for the specified culture and returns it. (Inherited from IResourceService.)
Public method | GetResourceWriter | Locates the resource writer for the specified culture and returns it. (Inherited from IResourceService.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IResourceServiceExtended Methods

IResourceServiceExtended Methods

The IResourceServiceExtended type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetResourceReader | Locates the resource reader for the specified culture and returns it. (Inherited from IResourceService.)
Public method | GetResourceWriter | Locates the resource writer for the specified culture and returns it. (Inherited from IResourceService.)
Top
See Also

Reference

IResourceServiceExtended Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl Interface

IToolboxControl Interface
Represents properties and methods to display and manipulate list of icons for components and controls that user can place onto design surface.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IToolboxControl
Public Interface IToolboxControl
public interface class IToolboxControl
type IToolboxControl =  interface end

The IToolboxControl type exposes the following members.

Methods
 | Name | Description
Public method | AddCategory | When implemented by a class, adds new category to the toolbox.
Public method | AddItem | When implemented by a class, places toolbox item onto specified toolbox tab.
Public method | AddItemForType | When implemented by a class, adds toolbox item from type name.
Public method | AddItemsFromAssembly | When implemented by a class, add all types that can appear on the toolbox from the assembly.
Public method | BeginUpdate | When implemented by a class, prevents repainting of the toolbox until EndUpdate is called.
Public method | ClearItemsInCategory | When implemented by a class, clears items in the specified tab.
Public method | DoesCategoryExist | When implemented by a class, identifies whether given category exist in the IToolboxControl.
Public method | DoesItemExist | When implemented by a class, identifies whether given item exist in the specified tab.
Public method | EndUpdate | When implemented by a class, re-enables toolbox repainting.
Public method | GetAllTools | When implemented by a class, gets all toolbox items.
Public method | GetToolsFromCategory | When implemented by a class, gets toolbox items on the specified tab.
Public method | InsertCategory | When implemented by a class, inserts category in the specified position.
Public method | InsertItem | When implemented by a class, inserts item in the specified position.
Public method | Load | When implemented by a class, loads the toolbox content from the specified stream.
Public method | MoveCategory | When implemented by a class, moves category to its current position plus value specified by positionDifference parameter.
Public method | MoveItem | When implemented by a class, moves item to its current position plus value specified by positionDifference parameter.
Public method | Refresh | When implemented by a class, forces the IToolboxControl to invalidate its client area and immediately redraw itself and any child controls.
Public method | RemoveAllCategories | When implemented by a class, removes all categories from the toolbox control.
Public method | RemoveCategory | When implemented by a class, removes specified tab.
Public method | RemoveItem | When implemented by a class, removes toolbox item from the category.
Public method | RenameCategory | When implemented by a class, renames the specified category.
Public method | Reset | When implemented by a class, resets the toolbox content to defaults.
Public method | Save | When implemented by a class, saves the toolbox content to the specified stream.
Public method | ScrollToCategory | When implemented by a class, scrolls toolbox control to the specified category.
Public method | ScrollToItem | When implemented by a class, scrolls toolbox control to the specified item.
Public method | SelectPointer | When implemented by a class, deselects currently selected toolbox item and selects pointer tool.
Public method | SetSelectedItem | When implemented by a class, selects toolbox item.
Top
Properties
 | Name | Description
Public property | CategoryNames | When implemented by a class, gets collection of Categories (Tabs) displayed by the toolbox
Public property | SearchEnabled |
Public property | SelectedCategory | When implemented by a class, gets or sets currently selected toolbox category.
Public property | SelectedTool | When implemented by a class, returns currently selected toolbox item.
Top
Events
 | Name | Description
Public event | PlaceItemAtDefaultLocation | When implemented by a class, event which is fired when user double clicks on a toolbox item.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IToolboxControl Methods

IToolboxControl Methods

The IToolboxControl type exposes the following members.

Methods
 | Name | Description
Public method | AddCategory | When implemented by a class, adds new category to the toolbox.
Public method | AddItem | When implemented by a class, places toolbox item onto specified toolbox tab.
Public method | AddItemForType | When implemented by a class, adds toolbox item from type name.
Public method | AddItemsFromAssembly | When implemented by a class, add all types that can appear on the toolbox from the assembly.
Public method | BeginUpdate | When implemented by a class, prevents repainting of the toolbox until EndUpdate is called.
Public method | ClearItemsInCategory | When implemented by a class, clears items in the specified tab.
Public method | DoesCategoryExist | When implemented by a class, identifies whether given category exist in the IToolboxControl.
Public method | DoesItemExist | When implemented by a class, identifies whether given item exist in the specified tab.
Public method | EndUpdate | When implemented by a class, re-enables toolbox repainting.
Public method | GetAllTools | When implemented by a class, gets all toolbox items.
Public method | GetToolsFromCategory | When implemented by a class, gets toolbox items on the specified tab.
Public method | InsertCategory | When implemented by a class, inserts category in the specified position.
Public method | InsertItem | When implemented by a class, inserts item in the specified position.
Public method | Load | When implemented by a class, loads the toolbox content from the specified stream.
Public method | MoveCategory | When implemented by a class, moves category to its current position plus value specified by positionDifference parameter.
Public method | MoveItem | When implemented by a class, moves item to its current position plus value specified by positionDifference parameter.
Public method | Refresh | When implemented by a class, forces the IToolboxControl to invalidate its client area and immediately redraw itself and any child controls.
Public method | RemoveAllCategories | When implemented by a class, removes all categories from the toolbox control.
Public method | RemoveCategory | When implemented by a class, removes specified tab.
Public method | RemoveItem | When implemented by a class, removes toolbox item from the category.
Public method | RenameCategory | When implemented by a class, renames the specified category.
Public method | Reset | When implemented by a class, resets the toolbox content to defaults.
Public method | Save | When implemented by a class, saves the toolbox content to the specified stream.
Public method | ScrollToCategory | When implemented by a class, scrolls toolbox control to the specified category.
Public method | ScrollToItem | When implemented by a class, scrolls toolbox control to the specified item.
Public method | SelectPointer | When implemented by a class, deselects currently selected toolbox item and selects pointer tool.
Public method | SetSelectedItem | When implemented by a class, selects toolbox item.
Top
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.AddCategory Method

IToolboxControlAddCategory Method
When implemented by a class, adds new category to the toolbox.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddCategory(
    string categoryName
)
Sub AddCategory (
    categoryName As String
)
void AddCategory(
    String^ categoryName
)
abstract AddCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Category name to add.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.AddItem Method

IToolboxControlAddItem Method
When implemented by a class, places toolbox item onto specified toolbox tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddItem(
    string categoryName,
    ToolboxItem item
)
Sub AddItem (
    categoryName As String,
    item As ToolboxItem
)
void AddItem(
    String^ categoryName,
    ToolboxItem^ item
)
abstract AddItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Tab name where new item will be placed.
item
Type: System.Drawing.DesignToolboxItem
Item to add.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.AddItemForType Method

IToolboxControlAddItemForType Method
When implemented by a class, adds toolbox item from type name.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddItemForType(
    string categoryName,
    Type type,
    CustomToolboxImage customImage = null
)
Sub AddItemForType (
    categoryName As String,
    type As Type,
    Optional customImage As CustomToolboxImage = Nothing
)
void AddItemForType(
    String^ categoryName,
    Type^ type,
    CustomToolboxImage^ customImage = nullptr
)
abstract AddItemForType :
        categoryName : string *
        type : Type *
        ?customImage : CustomToolboxImage
(* Defaults:
        let _customImage = defaultArg customImage null
*)
-> unit

Parameters

categoryName
Type: SystemString
Tab name where new items will be placed.
type
Type: SystemType
Type to get items from.
customImage (Optional)
Type: Alternet.FormDesigner.WinFormsCustomToolboxImage
Specifies Bitmap to draw with items.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.AddItemsFromAssembly Method

IToolboxControlAddItemsFromAssembly Method
When implemented by a class, add all types that can appear on the toolbox from the assembly.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddItemsFromAssembly(
    string categoryName,
    Assembly assembly
)
Sub AddItemsFromAssembly (
    categoryName As String,
    assembly As Assembly
)
void AddItemsFromAssembly(
    String^ categoryName,
    Assembly^ assembly
)
abstract AddItemsFromAssembly :
        categoryName : string *
        assembly : Assembly -> unit

Parameters

categoryName
Type: SystemString
Tab name where new items will be placed.
assembly
Type: System.ReflectionAssembly
Assembly to get items from.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.BeginUpdate Method

IToolboxControlBeginUpdate Method
When implemented by a class, prevents repainting of the toolbox until EndUpdate is called.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BeginUpdate()
Sub BeginUpdate
void BeginUpdate()
abstract BeginUpdate : unit -> unit
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.ClearItemsInCategory Method

IToolboxControlClearItemsInCategory Method
When implemented by a class, clears items in the specified tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearItemsInCategory(
    string categoryName
)
Sub ClearItemsInCategory (
    categoryName As String
)
void ClearItemsInCategory(
    String^ categoryName
)
abstract ClearItemsInCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Name of tab for clearing.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.DoesCategoryExist Method

IToolboxControlDoesCategoryExist Method
When implemented by a class, identifies whether given category exist in the IToolboxControl.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DoesCategoryExist(
    string categoryName
)
Function DoesCategoryExist (
    categoryName As String
) As Boolean
bool DoesCategoryExist(
    String^ categoryName
)
abstract DoesCategoryExist :
        categoryName : string -> bool

Parameters

categoryName
Type: SystemString
Name of tab to check.

Return Value

Type: Boolean
True if exists; otherwise false.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.DoesItemExist Method

IToolboxControlDoesItemExist Method
When implemented by a class, identifies whether given item exist in the specified tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DoesItemExist(
    string categoryName,
    ToolboxItem item
)
Function DoesItemExist (
    categoryName As String,
    item As ToolboxItem
) As Boolean
bool DoesItemExist(
    String^ categoryName,
    ToolboxItem^ item
)
abstract DoesItemExist :
        categoryName : string *
        item : ToolboxItem -> bool

Parameters

categoryName
Type: SystemString
Name of tab to check.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to check.

Return Value

Type: Boolean
True if exists; otherwise false.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.EndUpdate Method

IToolboxControlEndUpdate Method
When implemented by a class, re-enables toolbox repainting.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EndUpdate()
Sub EndUpdate
void EndUpdate()
abstract EndUpdate : unit -> unit
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.GetAllTools Method

IToolboxControlGetAllTools Method
When implemented by a class, gets all toolbox items.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ToolboxItemCollection GetAllTools()
Function GetAllTools As ToolboxItemCollection
ToolboxItemCollection^ GetAllTools()
abstract GetAllTools : unit -> ToolboxItemCollection

Return Value

Type: ToolboxItemCollection
Collection of toolbox items stored in the IToolboxControl.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.GetToolsFromCategory Method

IToolboxControlGetToolsFromCategory Method
When implemented by a class, gets toolbox items on the specified tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ToolboxItemCollection GetToolsFromCategory(
    string category
)
Function GetToolsFromCategory (
    category As String
) As ToolboxItemCollection
ToolboxItemCollection^ GetToolsFromCategory(
    String^ category
)
abstract GetToolsFromCategory :
        category : string -> ToolboxItemCollection

Parameters

category
Type: SystemString
Name of tab to get items from.

Return Value

Type: ToolboxItemCollection
Collection of toolbox items displayed on the specified tab.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.InsertCategory Method

IToolboxControlInsertCategory Method
When implemented by a class, inserts category in the specified position.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertCategory(
    int index,
    string categoryName
)
Sub InsertCategory (
    index As Integer,
    categoryName As String
)
void InsertCategory(
    int index,
    String^ categoryName
)
abstract InsertCategory :
        index : int *
        categoryName : string -> unit

Parameters

index
Type: SystemInt32
categoryName
Type: SystemString
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.InsertItem Method

IToolboxControlInsertItem Method
When implemented by a class, inserts item in the specified position.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void InsertItem(
    int index,
    string categoryName,
    ToolboxItem item
)
Sub InsertItem (
    index As Integer,
    categoryName As String,
    item As ToolboxItem
)
void InsertItem(
    int index,
    String^ categoryName,
    ToolboxItem^ item
)
abstract InsertItem :
        index : int *
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

index
Type: SystemInt32
categoryName
Type: SystemString
item
Type: System.Drawing.DesignToolboxItem
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.Load Method

IToolboxControlLoad Method
When implemented by a class, loads the toolbox content from the specified stream.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Load(
    Stream stream
)
Sub Load (
    stream As Stream
)
void Load(
    Stream^ stream
)
abstract Load :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.MoveCategory Method

IToolboxControlMoveCategory Method
When implemented by a class, moves category to its current position plus value specified by positionDifference parameter.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveCategory(
    string categoryName,
    int positionDifference
)
Sub MoveCategory (
    categoryName As String,
    positionDifference As Integer
)
void MoveCategory(
    String^ categoryName,
    int positionDifference
)
abstract MoveCategory :
        categoryName : string *
        positionDifference : int -> unit

Parameters

categoryName
Type: SystemString
positionDifference
Type: SystemInt32
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.MoveItem Method

IToolboxControlMoveItem Method
When implemented by a class, moves item to its current position plus value specified by positionDifference parameter.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void MoveItem(
    string categoryName,
    ToolboxItem item,
    int positionDifference
)
Sub MoveItem (
    categoryName As String,
    item As ToolboxItem,
    positionDifference As Integer
)
void MoveItem(
    String^ categoryName,
    ToolboxItem^ item,
    int positionDifference
)
abstract MoveItem :
        categoryName : string *
        item : ToolboxItem *
        positionDifference : int -> unit

Parameters

categoryName
Type: SystemString
item
Type: System.Drawing.DesignToolboxItem
positionDifference
Type: SystemInt32
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.Refresh Method

IToolboxControlRefresh Method
When implemented by a class, forces the IToolboxControl to invalidate its client area and immediately redraw itself and any child controls.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Refresh()
Sub Refresh
void Refresh()
abstract Refresh : unit -> unit
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.RemoveAllCategories Method

IToolboxControlRemoveAllCategories Method
When implemented by a class, removes all categories from the toolbox control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveAllCategories()
Sub RemoveAllCategories
void RemoveAllCategories()
abstract RemoveAllCategories : unit -> unit
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.RemoveCategory Method

IToolboxControlRemoveCategory Method
When implemented by a class, removes specified tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveCategory(
    string categoryName
)
Sub RemoveCategory (
    categoryName As String
)
void RemoveCategory(
    String^ categoryName
)
abstract RemoveCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Name of tab to remove.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.RemoveItem Method

IToolboxControlRemoveItem Method
When implemented by a class, removes toolbox item from the category.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveItem(
    string categoryName,
    ToolboxItem item
)
Sub RemoveItem (
    categoryName As String,
    item As ToolboxItem
)
void RemoveItem(
    String^ categoryName,
    ToolboxItem^ item
)
abstract RemoveItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Name of tab from which specific item should be removed.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to remove.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.RenameCategory Method

IToolboxControlRenameCategory Method
When implemented by a class, renames the specified category.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RenameCategory(
    string oldName,
    string newName
)
Sub RenameCategory (
    oldName As String,
    newName As String
)
void RenameCategory(
    String^ oldName,
    String^ newName
)
abstract RenameCategory :
        oldName : string *
        newName : string -> unit

Parameters

oldName
Type: SystemString
newName
Type: SystemString
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.Reset Method

IToolboxControlReset Method
When implemented by a class, resets the toolbox content to defaults.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.Save Method

IToolboxControlSave Method
When implemented by a class, saves the toolbox content to the specified stream.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Save(
    Stream stream
)
Sub Save (
    stream As Stream
)
void Save(
    Stream^ stream
)
abstract Save :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.ScrollToCategory Method

IToolboxControlScrollToCategory Method
When implemented by a class, scrolls toolbox control to the specified category.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollToCategory(
    string name
)
Sub ScrollToCategory (
    name As String
)
void ScrollToCategory(
    String^ name
)
abstract ScrollToCategory :
        name : string -> unit

Parameters

name
Type: SystemString
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.ScrollToItem Method

IToolboxControlScrollToItem Method
When implemented by a class, scrolls toolbox control to the specified item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ScrollToItem(
    string categoryName,
    ToolboxItem item
)
Sub ScrollToItem (
    categoryName As String,
    item As ToolboxItem
)
void ScrollToItem(
    String^ categoryName,
    ToolboxItem^ item
)
abstract ScrollToItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
item
Type: System.Drawing.DesignToolboxItem
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.SelectPointer Method

IToolboxControlSelectPointer Method
When implemented by a class, deselects currently selected toolbox item and selects pointer tool.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SelectPointer()
Sub SelectPointer
void SelectPointer()
abstract SelectPointer : unit -> unit
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.SetSelectedItem Method

IToolboxControlSetSelectedItem Method
When implemented by a class, selects toolbox item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetSelectedItem(
    string categoryName,
    ToolboxItem item
)
Sub SetSelectedItem (
    categoryName As String,
    item As ToolboxItem
)
void SetSelectedItem(
    String^ categoryName,
    ToolboxItem^ item
)
abstract SetSelectedItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Name of tab where item should be selected.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to select.
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl Properties

IToolboxControl Properties

The IToolboxControl type exposes the following members.

Properties
 | Name | Description
Public property | CategoryNames | When implemented by a class, gets collection of Categories (Tabs) displayed by the toolbox
Public property | SearchEnabled |
Public property | SelectedCategory | When implemented by a class, gets or sets currently selected toolbox category.
Public property | SelectedTool | When implemented by a class, returns currently selected toolbox item.
Top
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.CategoryNames Property

IToolboxControlCategoryNames Property
When implemented by a class, gets collection of Categories (Tabs) displayed by the toolbox

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
CategoryNameCollection CategoryNames { get; }
ReadOnly Property CategoryNames As CategoryNameCollection
    Get
property CategoryNameCollection^ CategoryNames {
    CategoryNameCollection^ get ();
}
abstract CategoryNames : CategoryNameCollection with get

Property Value

Type: CategoryNameCollection
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.SearchEnabled Property

IToolboxControlSearchEnabled Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SearchEnabled { get; set; }
Property SearchEnabled As Boolean
    Get
    Set
property bool SearchEnabled {
    bool get ();
    void set (bool value);
}
abstract SearchEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.SelectedCategory Property

IToolboxControlSelectedCategory Property
When implemented by a class, gets or sets currently selected toolbox category.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string SelectedCategory { get; set; }
Property SelectedCategory As String
    Get
    Set
property String^ SelectedCategory {
    String^ get ();
    void set (String^ value);
}
abstract SelectedCategory : string with get, set

Property Value

Type: String
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.SelectedTool Property

IToolboxControlSelectedTool Property
When implemented by a class, returns currently selected toolbox item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ToolboxItem SelectedTool { get; }
ReadOnly Property SelectedTool As ToolboxItem
    Get
property ToolboxItem^ SelectedTool {
    ToolboxItem^ get ();
}
abstract SelectedTool : ToolboxItem with get

Property Value

Type: ToolboxItem
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl Events

IToolboxControl Events

The IToolboxControl type exposes the following members.

Events
 | Name | Description
Public event | PlaceItemAtDefaultLocation | When implemented by a class, event which is fired when user double clicks on a toolbox item.
Top
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxControl.PlaceItemAtDefaultLocation Event

IToolboxControlPlaceItemAtDefaultLocation Event
When implemented by a class, event which is fired when user double clicks on a toolbox item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs> PlaceItemAtDefaultLocation
Event PlaceItemAtDefaultLocation As EventHandler(Of PlaceToolboxItemAtDefaultLocationEventArgs)
 event EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs^>^ PlaceItemAtDefaultLocation {
    void add (EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs^>^ value);
    void remove (EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs^>^ value);
}
abstract PlaceItemAtDefaultLocation : IEvent<EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs>,
    PlaceToolboxItemAtDefaultLocationEventArgs>

Value

Type: SystemEventHandlerPlaceToolboxItemAtDefaultLocationEventArgs
See Also

Reference

IToolboxControl Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxServiceExtended Interface

IToolboxServiceExtended Interface
Provides additional properties to manage and query the toolbox in the development environment.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IToolboxServiceExtended : IToolboxService
Public Interface IToolboxServiceExtended
    Inherits IToolboxService
public interface class IToolboxServiceExtended : IToolboxService
type IToolboxServiceExtended =
    interface
        interface IToolboxService
    end

The IToolboxServiceExtended type exposes the following members.

Methods
 | Name | Description
Public method | AddCreator(ToolboxItemCreatorCallback, String) | Adds a new toolbox item creator for a specified data format. (Inherited from IToolboxService.)
Public method | AddCreator(ToolboxItemCreatorCallback, String, IDesignerHost) | Adds a new toolbox item creator for a specified data format and designer host. (Inherited from IToolboxService.)
Public method | AddLinkedToolboxItem(ToolboxItem, IDesignerHost) | Adds the specified project-linked toolbox item to the toolbox. (Inherited from IToolboxService.)
Public method | AddLinkedToolboxItem(ToolboxItem, String, IDesignerHost) | Adds the specified project-linked toolbox item to the toolbox in the specified category. (Inherited from IToolboxService.)
Public method | AddToolboxItem(ToolboxItem) | Adds the specified toolbox item to the toolbox. (Inherited from IToolboxService.)
Public method | AddToolboxItem(ToolboxItem, String) | Adds the specified toolbox item to the toolbox in the specified category. (Inherited from IToolboxService.)
Public method | DeserializeToolboxItem(Object) | Gets a toolbox item from the specified object that represents a toolbox item in serialized form. (Inherited from IToolboxService.)
Public method | DeserializeToolboxItem(Object, IDesignerHost) | Gets a toolbox item from the specified object that represents a toolbox item in serialized form, using the specified designer host. (Inherited from IToolboxService.)
Public method | GetSelectedToolboxItem | Gets the currently selected toolbox item. (Inherited from IToolboxService.)
Public method | GetSelectedToolboxItem(IDesignerHost) | Gets the currently selected toolbox item if it is available to all designers, or if it supports the specified designer. (Inherited from IToolboxService.)
Public method | GetToolboxItems | Gets the entire collection of toolbox items from the toolbox. (Inherited from IToolboxService.)
Public method | GetToolboxItems(IDesignerHost) | Gets the collection of toolbox items that are associated with the specified designer host from the toolbox. (Inherited from IToolboxService.)
Public method | GetToolboxItems(String) | Gets a collection of toolbox items from the toolbox that match the specified category. (Inherited from IToolboxService.)
Public method | GetToolboxItems(String, IDesignerHost) | Gets the collection of toolbox items that are associated with the specified designer host and category from the toolbox. (Inherited from IToolboxService.)
Public method | IsSupported(Object, IDesignerHost) | Gets a value indicating whether the specified object which represents a serialized toolbox item can be used by the specified designer host. (Inherited from IToolboxService.)
Public method | IsSupported(Object, ICollection) | Gets a value indicating whether the specified object which represents a serialized toolbox item matches the specified attributes. (Inherited from IToolboxService.)
Public method | IsToolboxItem(Object) | Gets a value indicating whether the specified object is a serialized toolbox item. (Inherited from IToolboxService.)
Public method | IsToolboxItem(Object, IDesignerHost) | Gets a value indicating whether the specified object is a serialized toolbox item, using the specified designer host. (Inherited from IToolboxService.)
Public method | Refresh | Refreshes the state of the toolbox items. (Inherited from IToolboxService.)
Public method | RemoveCreator(String) | Removes a previously added toolbox item creator of the specified data format. (Inherited from IToolboxService.)
Public method | RemoveCreator(String, IDesignerHost) | Removes a previously added toolbox creator that is associated with the specified data format and the specified designer host. (Inherited from IToolboxService.)
Public method | RemoveToolboxItem(ToolboxItem) | Removes the specified toolbox item from the toolbox. (Inherited from IToolboxService.)
Public method | RemoveToolboxItem(ToolboxItem, String) | Removes the specified toolbox item from the toolbox. (Inherited from IToolboxService.)
Public method | SelectedToolboxItemUsed | Notifies the toolbox service that the selected tool has been used. (Inherited from IToolboxService.)
Public method | SerializeToolboxItem | Gets a serializable object that represents the specified toolbox item. (Inherited from IToolboxService.)
Public method | SetCursor | Sets the current application's cursor to a cursor that represents the currently selected tool. (Inherited from IToolboxService.)
Public method | SetSelectedToolboxItem | Selects the specified toolbox item. (Inherited from IToolboxService.)
Top
Properties
 | Name | Description
Public property | CategoryNames | Gets the names of all the tool categories currently on the toolbox. (Inherited from IToolboxService.)
Public property | SelectedCategory | Gets or sets the name of the currently selected tool category from the toolbox. (Inherited from IToolboxService.)
Public property | ToolboxControl | When implemented by a class, gets or sets IToolboxControl which this service communicates with.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IToolboxServiceExtended Methods

IToolboxServiceExtended Methods

The IToolboxServiceExtended type exposes the following members.

Methods
 | Name | Description
Public method | AddCreator(ToolboxItemCreatorCallback, String) | Adds a new toolbox item creator for a specified data format. (Inherited from IToolboxService.)
Public method | AddCreator(ToolboxItemCreatorCallback, String, IDesignerHost) | Adds a new toolbox item creator for a specified data format and designer host. (Inherited from IToolboxService.)
Public method | AddLinkedToolboxItem(ToolboxItem, IDesignerHost) | Adds the specified project-linked toolbox item to the toolbox. (Inherited from IToolboxService.)
Public method | AddLinkedToolboxItem(ToolboxItem, String, IDesignerHost) | Adds the specified project-linked toolbox item to the toolbox in the specified category. (Inherited from IToolboxService.)
Public method | AddToolboxItem(ToolboxItem) | Adds the specified toolbox item to the toolbox. (Inherited from IToolboxService.)
Public method | AddToolboxItem(ToolboxItem, String) | Adds the specified toolbox item to the toolbox in the specified category. (Inherited from IToolboxService.)
Public method | DeserializeToolboxItem(Object) | Gets a toolbox item from the specified object that represents a toolbox item in serialized form. (Inherited from IToolboxService.)
Public method | DeserializeToolboxItem(Object, IDesignerHost) | Gets a toolbox item from the specified object that represents a toolbox item in serialized form, using the specified designer host. (Inherited from IToolboxService.)
Public method | GetSelectedToolboxItem | Gets the currently selected toolbox item. (Inherited from IToolboxService.)
Public method | GetSelectedToolboxItem(IDesignerHost) | Gets the currently selected toolbox item if it is available to all designers, or if it supports the specified designer. (Inherited from IToolboxService.)
Public method | GetToolboxItems | Gets the entire collection of toolbox items from the toolbox. (Inherited from IToolboxService.)
Public method | GetToolboxItems(IDesignerHost) | Gets the collection of toolbox items that are associated with the specified designer host from the toolbox. (Inherited from IToolboxService.)
Public method | GetToolboxItems(String) | Gets a collection of toolbox items from the toolbox that match the specified category. (Inherited from IToolboxService.)
Public method | GetToolboxItems(String, IDesignerHost) | Gets the collection of toolbox items that are associated with the specified designer host and category from the toolbox. (Inherited from IToolboxService.)
Public method | IsSupported(Object, IDesignerHost) | Gets a value indicating whether the specified object which represents a serialized toolbox item can be used by the specified designer host. (Inherited from IToolboxService.)
Public method | IsSupported(Object, ICollection) | Gets a value indicating whether the specified object which represents a serialized toolbox item matches the specified attributes. (Inherited from IToolboxService.)
Public method | IsToolboxItem(Object) | Gets a value indicating whether the specified object is a serialized toolbox item. (Inherited from IToolboxService.)
Public method | IsToolboxItem(Object, IDesignerHost) | Gets a value indicating whether the specified object is a serialized toolbox item, using the specified designer host. (Inherited from IToolboxService.)
Public method | Refresh | Refreshes the state of the toolbox items. (Inherited from IToolboxService.)
Public method | RemoveCreator(String) | Removes a previously added toolbox item creator of the specified data format. (Inherited from IToolboxService.)
Public method | RemoveCreator(String, IDesignerHost) | Removes a previously added toolbox creator that is associated with the specified data format and the specified designer host. (Inherited from IToolboxService.)
Public method | RemoveToolboxItem(ToolboxItem) | Removes the specified toolbox item from the toolbox. (Inherited from IToolboxService.)
Public method | RemoveToolboxItem(ToolboxItem, String) | Removes the specified toolbox item from the toolbox. (Inherited from IToolboxService.)
Public method | SelectedToolboxItemUsed | Notifies the toolbox service that the selected tool has been used. (Inherited from IToolboxService.)
Public method | SerializeToolboxItem | Gets a serializable object that represents the specified toolbox item. (Inherited from IToolboxService.)
Public method | SetCursor | Sets the current application's cursor to a cursor that represents the currently selected tool. (Inherited from IToolboxService.)
Public method | SetSelectedToolboxItem | Selects the specified toolbox item. (Inherited from IToolboxService.)
Top
See Also

Reference

IToolboxServiceExtended Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxServiceExtended Properties

IToolboxServiceExtended Properties

The IToolboxServiceExtended type exposes the following members.

Properties
 | Name | Description
Public property | CategoryNames | Gets the names of all the tool categories currently on the toolbox. (Inherited from IToolboxService.)
Public property | SelectedCategory | Gets or sets the name of the currently selected tool category from the toolbox. (Inherited from IToolboxService.)
Public property | ToolboxControl | When implemented by a class, gets or sets IToolboxControl which this service communicates with.
Top
See Also

Reference

IToolboxServiceExtended Interface
Alternet.FormDesigner.WinForms Namespace


IToolboxServiceExtended.ToolboxControl Property

IToolboxServiceExtendedToolboxControl Property
When implemented by a class, gets or sets IToolboxControl which this service communicates with.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IToolboxControl ToolboxControl { get; set; }
Property ToolboxControl As IToolboxControl
    Get
    Set
property IToolboxControl^ ToolboxControl {
    IToolboxControl^ get ();
    void set (IToolboxControl^ value);
}
abstract ToolboxControl : IToolboxControl with get, set

Property Value

Type: IToolboxControl
See Also

Reference

IToolboxServiceExtended Interface
Alternet.FormDesigner.WinForms Namespace


IUndoEngine Interface

IUndoEngine Interface
Represents properties declaration for undo service.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUndoEngine
Public Interface IUndoEngine
public interface class IUndoEngine
type IUndoEngine =  interface end

The IUndoEngine type exposes the following members.

Properties
 | Name | Description
Public property | Engine | When implemented by a class, represents an object used to provide undo/redo functionality at design time.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


IUndoEngine Properties

IUndoEngine Properties

The IUndoEngine type exposes the following members.

Properties
 | Name | Description
Public property | Engine | When implemented by a class, represents an object used to provide undo/redo functionality at design time.
Top
See Also

Reference

IUndoEngine Interface
Alternet.FormDesigner.WinForms Namespace


IUndoEngine.Engine Property

IUndoEngineEngine Property
When implemented by a class, represents an object used to provide undo/redo functionality at design time.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
UndoEngine Engine { get; }
ReadOnly Property Engine As UndoEngine
    Get
property UndoEngine^ Engine {
    UndoEngine^ get ();
}
abstract Engine : UndoEngine with get

Property Value

Type: UndoEngine
See Also

Reference

IUndoEngine Interface
Alternet.FormDesigner.WinForms Namespace


NameCreationService Class

NameCreationService Class
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsNameCreationService

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class NameCreationService : INameCreationService
Public NotInheritable Class NameCreationService
    Implements INameCreationService
public ref class NameCreationService sealed : INameCreationService
[<SealedAttribute>]
type NameCreationService =
    class
        interface INameCreationService
    end

The NameCreationService type exposes the following members.

Constructors
 | Name | Description
Public method | NameCreationService | Initializes a new instance of the NameCreationService class
Top
Methods
 | Name | Description
Public method | CreateName |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidName |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateName |
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


NameCreationService Constructor

NameCreationService Constructor
Initializes a new instance of the NameCreationService class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NameCreationService()
Public Sub New
public:
NameCreationService()
new : unit -> NameCreationService
See Also

Reference

NameCreationService Class
Alternet.FormDesigner.WinForms Namespace


NameCreationService Methods

NameCreationService Methods

The NameCreationService type exposes the following members.

Methods
 | Name | Description
Public method | CreateName |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidName |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateName |
Top
See Also

Reference

NameCreationService Class
Alternet.FormDesigner.WinForms Namespace


NameCreationService.CreateName Method

NameCreationServiceCreateName Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CreateName(
    IContainer container,
    Type type
)
Public Function CreateName (
    container As IContainer,
    type As Type
) As String
public:
virtual String^ CreateName(
    IContainer^ container,
    Type^ type
) sealed
abstract CreateName :
        container : IContainer *
        type : Type -> string
override CreateName :
        container : IContainer *
        type : Type -> string

Parameters

container
Type: System.ComponentModelIContainer
type
Type: SystemType

Return Value

Type: String

Implements

INameCreationServiceCreateName(IContainer, Type)
See Also

Reference

NameCreationService Class
Alternet.FormDesigner.WinForms Namespace


NameCreationService.IsValidName Method

NameCreationServiceIsValidName Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidName(
    string name
)
Public Function IsValidName (
    name As String
) As Boolean
public:
virtual bool IsValidName(
    String^ name
) sealed
abstract IsValidName :
        name : string -> bool
override IsValidName :
        name : string -> bool

Parameters

name
Type: SystemString

Return Value

Type: Boolean

Implements

INameCreationServiceIsValidName(String)
See Also

Reference

NameCreationService Class
Alternet.FormDesigner.WinForms Namespace


NameCreationService.ValidateName Method

NameCreationServiceValidateName Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ValidateName(
    string name
)
Public Sub ValidateName (
    name As String
)
public:
virtual void ValidateName(
    String^ name
) sealed
abstract ValidateName :
        name : string -> unit
override ValidateName :
        name : string -> unit

Parameters

name
Type: SystemString

Implements

INameCreationServiceValidateName(String)
See Also

Reference

NameCreationService Class
Alternet.FormDesigner.WinForms Namespace


NavigateToUserMethodRequestedEventArgs Class

NavigateToUserMethodRequestedEventArgs Class
Provides data for the NavigateToUserMethodRequested handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.FormDesigner.WinFormsNavigateToUserMethodRequestedEventArgs

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NavigateToUserMethodRequestedEventArgs : EventArgs
Public Class NavigateToUserMethodRequestedEventArgs
    Inherits EventArgs
public ref class NavigateToUserMethodRequestedEventArgs : public EventArgs
type NavigateToUserMethodRequestedEventArgs =
    class
        inherit EventArgs
    end

The NavigateToUserMethodRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | LineNumber | Represents number of line to navigate.
Public property | MethodName | Represents name of method to navigate.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


NavigateToUserMethodRequestedEventArgs Methods

NavigateToUserMethodRequestedEventArgs Methods

The NavigateToUserMethodRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NavigateToUserMethodRequestedEventArgs Class
Alternet.FormDesigner.WinForms Namespace


NavigateToUserMethodRequestedEventArgs Properties

NavigateToUserMethodRequestedEventArgs Properties

The NavigateToUserMethodRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | LineNumber | Represents number of line to navigate.
Public property | MethodName | Represents name of method to navigate.
Top
See Also

Reference

NavigateToUserMethodRequestedEventArgs Class
Alternet.FormDesigner.WinForms Namespace


NavigateToUserMethodRequestedEventArgs.LineNumber Property

NavigateToUserMethodRequestedEventArgsLineNumber Property
Represents number of line to navigate.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> LineNumber { get; }
Public ReadOnly Property LineNumber As Nullable(Of Integer)
    Get
public:
property Nullable<int> LineNumber {
    Nullable<int> get ();
}
member LineNumber : Nullable<int> with get

Property Value

Type: NullableInt32
See Also

Reference

NavigateToUserMethodRequestedEventArgs Class
Alternet.FormDesigner.WinForms Namespace


NavigateToUserMethodRequestedEventArgs.MethodName Property

NavigateToUserMethodRequestedEventArgsMethodName Property
Represents name of method to navigate.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MethodName { get; }
Public ReadOnly Property MethodName As String
    Get
public:
property String^ MethodName {
    String^ get ();
}
member MethodName : string with get

Property Value

Type: String
See Also

Reference

NavigateToUserMethodRequestedEventArgs Class
Alternet.FormDesigner.WinForms Namespace


OpenStreamDelegate Delegate

OpenStreamDelegate Delegate
Represents a method that will handle opening form designer-generated code

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate Stream OpenStreamDelegate(
    StreamAccessMode mode,
    CultureInfo cultureInfo
)
Public Delegate Function OpenStreamDelegate (
    mode As StreamAccessMode,
    cultureInfo As CultureInfo
) As Stream
public delegate Stream^ OpenStreamDelegate(
    StreamAccessMode mode,
    CultureInfo^ cultureInfo
)
type OpenStreamDelegate =
    delegate of
        mode : StreamAccessMode *
        cultureInfo : CultureInfo -> Stream

Parameters

mode
Type: Alternet.FormDesigner.WinFormsStreamAccessMode
Specifies operation can be performed on the stream.
cultureInfo
Type: System.GlobalizationCultureInfo
Specifies information about a specific culture.

Return Value

Type: Stream
Stream to manipulate designer code.
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


OpenStreamForReadingDelegate Delegate

OpenStreamForReadingDelegate Delegate
Represents a method that will handle opening user-defined code.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate Stream OpenStreamForReadingDelegate()
Public Delegate Function OpenStreamForReadingDelegate As Stream
public delegate Stream^ OpenStreamForReadingDelegate()
type OpenStreamForReadingDelegate =
    delegate of unit -> Stream

Return Value

Type: Stream
Stream to read user code.
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


OutlineContextMenu Class

OutlineContextMenu Class
Implements a outline context menu.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.FormDesigner.WinFormsOutlineContextMenu

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OutlineContextMenu : UserControl
Public Class OutlineContextMenu
    Inherits UserControl
public ref class OutlineContextMenu : public UserControl
type OutlineContextMenu =
    class
        inherit UserControl
    end

The OutlineContextMenu type exposes the following members.

Constructors
 | Name | Description
Public method | OutlineContextMenu | Initializes a new instance of the OutlineContextMenu class and associates it with the specified container.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowContextMenu | Shows the context menu at the specified location.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


OutlineContextMenu Constructor

OutlineContextMenu Constructor
Initializes a new instance of the OutlineContextMenu class and associates it with the specified container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public OutlineContextMenu(
    OutlineControl outlineControl
)
Public Sub New (
    outlineControl As OutlineControl
)
public:
OutlineContextMenu(
    OutlineControl^ outlineControl
)
new :
        outlineControl : OutlineControl -> OutlineContextMenu

Parameters

outlineControl
Type: Alternet.FormDesigner.WinFormsOutlineControl
A IOutlineControl that is the container of this menu.
See Also

Reference

OutlineContextMenu Class
Alternet.FormDesigner.WinForms Namespace


OutlineContextMenu Methods

OutlineContextMenu Methods

The OutlineContextMenu type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowContextMenu | Shows the context menu at the specified location.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

OutlineContextMenu Class
Alternet.FormDesigner.WinForms Namespace


OutlineContextMenu.ShowContextMenu Method

OutlineContextMenuShowContextMenu Method
Shows the context menu at the specified location.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowContextMenu(
    Point screenLocation
)
Public Overridable Sub ShowContextMenu (
    screenLocation As Point
)
public:
virtual void ShowContextMenu(
    Point screenLocation
)
abstract ShowContextMenu :
        screenLocation : Point -> unit
override ShowContextMenu :
        screenLocation : Point -> unit

Parameters

screenLocation
Type: System.DrawingPoint
See Also

Reference

OutlineContextMenu Class
Alternet.FormDesigner.WinForms Namespace


OutlineContextMenu Properties

OutlineContextMenu Properties

The OutlineContextMenu type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

OutlineContextMenu Class
Alternet.FormDesigner.WinForms Namespace


OutlineContextMenu Events

OutlineContextMenu Events

The OutlineContextMenu type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

OutlineContextMenu Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl Class

OutlineControl Class
Represents the outline control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.FormDesigner.WinFormsOutlineControl

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OutlineControl : Control,
    IOutlineControl
Public Class OutlineControl
    Inherits Control
    Implements IOutlineControl
public ref class OutlineControl : public Control,
    IOutlineControl
type OutlineControl =
    class
        inherit Control
        interface IOutlineControl
    end

The OutlineControl type exposes the following members.

Constructors
 | Name | Description
Public method | OutlineControl | Initializes a new instance of the OutlineControl class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanMoveDown | Indicates whether current item can be moved down in the container.
Public method | CanMoveIn | Indicates whether current item can be moved into the next container.
Public method | CanMoveOut | Indicates whether current item can be moved out of current container.
Public method | CanMoveUp | Indicates whether current item can be moved up in the container.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | MoveDown | Moves outline item down in the container.
Public method | MoveIn | Moves outline item into the next container.
Public method | MoveOut | Moves outline item out of current container.
Public method | MoveUp | Moves outline item up in the container.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowRenameSelectedNodeUI | Starts the editing of the outline item name.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormDesignerControl | Gets or sets an IFormDesignerControl related to this outline control.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Painter | Provides an interface to draw outline control.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Toolbox | Gets or sets toolbox control associated with the outline control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TreeView | Gets TreeView used to display outline items.
Public property | TypeNameDisplayStyle | Gets or sets an appearance of the item's type name in the outline control.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


OutlineControl Constructor

OutlineControl Constructor
Initializes a new instance of the OutlineControl class with default settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public OutlineControl()
Public Sub New
public:
OutlineControl()
new : unit -> OutlineControl
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl Methods

OutlineControl Methods

The OutlineControl type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CanMoveDown | Indicates whether current item can be moved down in the container.
Public method | CanMoveIn | Indicates whether current item can be moved into the next container.
Public method | CanMoveOut | Indicates whether current item can be moved out of current container.
Public method | CanMoveUp | Indicates whether current item can be moved up in the container.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | MoveDown | Moves outline item down in the container.
Public method | MoveIn | Moves outline item into the next container.
Public method | MoveOut | Moves outline item out of current container.
Public method | MoveUp | Moves outline item up in the container.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowRenameSelectedNodeUI | Starts the editing of the outline item name.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.BeginUpdate Method

OutlineControlBeginUpdate Method
Prevents object state updating until calling EndUpdate method.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BeginUpdate()
Public Sub BeginUpdate
public:
void BeginUpdate()
member BeginUpdate : unit -> unit
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.CanMoveDown Method

OutlineControlCanMoveDown Method
Indicates whether current item can be moved down in the container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanMoveDown()
Public Function CanMoveDown As Boolean
public:
bool CanMoveDown()
member CanMoveDown : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.CanMoveIn Method

OutlineControlCanMoveIn Method
Indicates whether current item can be moved into the next container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanMoveIn()
Public Function CanMoveIn As Boolean
public:
bool CanMoveIn()
member CanMoveIn : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.CanMoveOut Method

OutlineControlCanMoveOut Method
Indicates whether current item can be moved out of current container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanMoveOut()
Public Function CanMoveOut As Boolean
public:
bool CanMoveOut()
member CanMoveOut : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.CanMoveUp Method

OutlineControlCanMoveUp Method
Indicates whether current item can be moved up in the container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanMoveUp()
Public Function CanMoveUp As Boolean
public:
bool CanMoveUp()
member CanMoveUp : unit -> bool

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.EndUpdate Method

OutlineControlEndUpdate Method
Re-enables object state updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EndUpdate()
Public Sub EndUpdate
public:
void EndUpdate()
member EndUpdate : unit -> unit
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.MoveDown Method

OutlineControlMoveDown Method
Moves outline item down in the container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveDown()
Public Sub MoveDown
public:
virtual void MoveDown() sealed
abstract MoveDown : unit -> unit
override MoveDown : unit -> unit

Implements

IOutlineControlMoveDown
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.MoveIn Method

OutlineControlMoveIn Method
Moves outline item into the next container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveIn()
Public Sub MoveIn
public:
virtual void MoveIn() sealed
abstract MoveIn : unit -> unit
override MoveIn : unit -> unit

Implements

IOutlineControlMoveIn
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.MoveOut Method

OutlineControlMoveOut Method
Moves outline item out of current container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveOut()
Public Sub MoveOut
public:
virtual void MoveOut() sealed
abstract MoveOut : unit -> unit
override MoveOut : unit -> unit

Implements

IOutlineControlMoveOut
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.MoveUp Method

OutlineControlMoveUp Method
Moves outline item up in the container.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveUp()
Public Sub MoveUp
public:
virtual void MoveUp() sealed
abstract MoveUp : unit -> unit
override MoveUp : unit -> unit

Implements

IOutlineControlMoveUp
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.ShowRenameSelectedNodeUI Method

OutlineControlShowRenameSelectedNodeUI Method
Starts the editing of the outline item name.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowRenameSelectedNodeUI()
Public Sub ShowRenameSelectedNodeUI
public:
virtual void ShowRenameSelectedNodeUI() sealed
abstract ShowRenameSelectedNodeUI : unit -> unit
override ShowRenameSelectedNodeUI : unit -> unit

Implements

IOutlineControlShowRenameSelectedNodeUI
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl Properties

OutlineControl Properties

The OutlineControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormDesignerControl | Gets or sets an IFormDesignerControl related to this outline control.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Painter | Provides an interface to draw outline control.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Toolbox | Gets or sets toolbox control associated with the outline control.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TreeView | Gets TreeView used to display outline items.
Public property | TypeNameDisplayStyle | Gets or sets an appearance of the item's type name in the outline control.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.FormDesignerControl Property

OutlineControlFormDesignerControl Property
Gets or sets an IFormDesignerControl related to this outline control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerControl FormDesignerControl { get; set; }
Public Property FormDesignerControl As IFormDesignerControl
    Get
    Set
public:
virtual property IFormDesignerControl^ FormDesignerControl {
    IFormDesignerControl^ get () sealed;
    void set (IFormDesignerControl^ value) sealed;
}
abstract FormDesignerControl : IFormDesignerControl with get, set
override FormDesignerControl : IFormDesignerControl with get, set

Property Value

Type: IFormDesignerControl

Implements

IOutlineControlFormDesignerControl
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.Painter Property

OutlineControlPainter Property
Provides an interface to draw outline control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IOutlineControlPainter Painter { get; set; }
Public Property Painter As IOutlineControlPainter
    Get
    Set
public:
property IOutlineControlPainter^ Painter {
    IOutlineControlPainter^ get ();
    void set (IOutlineControlPainter^ value);
}
member Painter : IOutlineControlPainter with get, set

Property Value

Type: IOutlineControlPainter
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.Toolbox Property

OutlineControlToolbox Property
Gets or sets toolbox control associated with the outline control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IToolboxControl Toolbox { get; set; }
Public Property Toolbox As IToolboxControl
    Get
    Set
public:
virtual property IToolboxControl^ Toolbox {
    IToolboxControl^ get () sealed;
    void set (IToolboxControl^ value) sealed;
}
abstract Toolbox : IToolboxControl with get, set
override Toolbox : IToolboxControl with get, set

Property Value

Type: IToolboxControl

Implements

IOutlineControlToolbox
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.TreeView Property

OutlineControlTreeView Property
Gets TreeView used to display outline items.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeView TreeView { get; }
Public ReadOnly Property TreeView As TreeView
    Get
public:
property TreeView^ TreeView {
    TreeView^ get ();
}
member TreeView : TreeView with get

Property Value

Type: TreeView
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl.TypeNameDisplayStyle Property

OutlineControlTypeNameDisplayStyle Property
Gets or sets an appearance of the item's type name in the outline control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public OutlineControlTypeNameDisplayStyle TypeNameDisplayStyle { get; set; }
Public Property TypeNameDisplayStyle As OutlineControlTypeNameDisplayStyle
    Get
    Set
public:
property OutlineControlTypeNameDisplayStyle TypeNameDisplayStyle {
    OutlineControlTypeNameDisplayStyle get ();
    void set (OutlineControlTypeNameDisplayStyle value);
}
member TypeNameDisplayStyle : OutlineControlTypeNameDisplayStyle with get, set

Property Value

Type: OutlineControlTypeNameDisplayStyle
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControl Events

OutlineControl Events

The OutlineControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

OutlineControl Class
Alternet.FormDesigner.WinForms Namespace


OutlineControlTypeNameDisplayStyle Enumeration

OutlineControlTypeNameDisplayStyle Enumeration
Defines appearance of the item's type name in the outline control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OutlineControlTypeNameDisplayStyle
Public Enumeration OutlineControlTypeNameDisplayStyle
public enum class OutlineControlTypeNameDisplayStyle
type OutlineControlTypeNameDisplayStyle
Members
Member name | Value | Description
None | 0 | Specifies no type name.
Short | 1 | Specifies short type name.
Full | 2 | Specifies full type name.
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


PlaceToolboxItemAtDefaultLocationEventArgs Class

PlaceToolboxItemAtDefaultLocationEventArgs Class
Provides parameters for PlaceItemAtDefaultLocation event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.FormDesigner.WinFormsPlaceToolboxItemAtDefaultLocationEventArgs

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PlaceToolboxItemAtDefaultLocationEventArgs : EventArgs
Public Class PlaceToolboxItemAtDefaultLocationEventArgs
    Inherits EventArgs
public ref class PlaceToolboxItemAtDefaultLocationEventArgs : public EventArgs
type PlaceToolboxItemAtDefaultLocationEventArgs =
    class
        inherit EventArgs
    end

The PlaceToolboxItemAtDefaultLocationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PlaceToolboxItemAtDefaultLocationEventArgs | Creates a new instance of PlaceToolboxItemAtDefaultLocationEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Handled | Gets or sets the flag indicating that this event has been handled by a user.
Public property | Item | Gets the toolbox item.
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


PlaceToolboxItemAtDefaultLocationEventArgs Constructor

PlaceToolboxItemAtDefaultLocationEventArgs Constructor
Creates a new instance of PlaceToolboxItemAtDefaultLocationEventArgs class.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlaceToolboxItemAtDefaultLocationEventArgs(
    ToolboxItem item
)
Public Sub New (
    item As ToolboxItem
)
public:
PlaceToolboxItemAtDefaultLocationEventArgs(
    ToolboxItem^ item
)
new :
        item : ToolboxItem -> PlaceToolboxItemAtDefaultLocationEventArgs

Parameters

item
Type: System.Drawing.DesignToolboxItem
The toolbox item.
See Also

Reference

PlaceToolboxItemAtDefaultLocationEventArgs Class
Alternet.FormDesigner.WinForms Namespace


PlaceToolboxItemAtDefaultLocationEventArgs Methods

PlaceToolboxItemAtDefaultLocationEventArgs Methods

The PlaceToolboxItemAtDefaultLocationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlaceToolboxItemAtDefaultLocationEventArgs Class
Alternet.FormDesigner.WinForms Namespace


PlaceToolboxItemAtDefaultLocationEventArgs Properties

PlaceToolboxItemAtDefaultLocationEventArgs Properties

The PlaceToolboxItemAtDefaultLocationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Gets or sets the flag indicating that this event has been handled by a user.
Public property | Item | Gets the toolbox item.
Top
See Also

Reference

PlaceToolboxItemAtDefaultLocationEventArgs Class
Alternet.FormDesigner.WinForms Namespace


PlaceToolboxItemAtDefaultLocationEventArgs.Handled Property

PlaceToolboxItemAtDefaultLocationEventArgsHandled Property
Gets or sets the flag indicating that this event has been handled by a user.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PlaceToolboxItemAtDefaultLocationEventArgs Class
Alternet.FormDesigner.WinForms Namespace


PlaceToolboxItemAtDefaultLocationEventArgs.Item Property

PlaceToolboxItemAtDefaultLocationEventArgsItem Property
Gets the toolbox item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItem Item { get; }
Public ReadOnly Property Item As ToolboxItem
    Get
public:
property ToolboxItem^ Item {
    ToolboxItem^ get ();
}
member Item : ToolboxItem with get

Property Value

Type: ToolboxItem
See Also

Reference

PlaceToolboxItemAtDefaultLocationEventArgs Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl Class

PropertyGridControl Class
Provides a user interface for browsing the properties of an object.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.FormDesigner.WinFormsPropertyGridControl

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PropertyGridControl : Control,
    IPropertyGridControl, IPropertyFilterProvider
Public Class PropertyGridControl
    Inherits Control
    Implements IPropertyGridControl, IPropertyFilterProvider
public ref class PropertyGridControl : public Control,
    IPropertyGridControl, IPropertyFilterProvider
type PropertyGridControl =
    class
        inherit Control
        interface IPropertyGridControl
        interface IPropertyFilterProvider
    end

The PropertyGridControl type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridControl | Initializes a new instance of the PropertyGridControl class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | FilterTextBoxVisible |
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormDesignerControl | Gets or sets an IFormDesignerControl related to this property grid.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor |
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | PropertyBlacklist |
Public property | PropertyGrid |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedObjects |
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreFilterProperties |
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


PropertyGridControl Constructor

PropertyGridControl Constructor
Initializes a new instance of the PropertyGridControl class with default settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyGridControl()
Public Sub New
public:
PropertyGridControl()
new : unit -> PropertyGridControl
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl Methods

PropertyGridControl Methods

The PropertyGridControl type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl Properties

PropertyGridControl Properties

The PropertyGridControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | FilterTextBoxVisible |
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormDesignerControl | Gets or sets an IFormDesignerControl related to this property grid.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor |
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | PropertyBlacklist |
Public property | PropertyGrid |
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedObjects |
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl.FilterTextBoxVisible Property

PropertyGridControlFilterTextBoxVisible Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FilterTextBoxVisible { get; set; }
Public Property FilterTextBoxVisible As Boolean
    Get
    Set
public:
property bool FilterTextBoxVisible {
    bool get ();
    void set (bool value);
}
member FilterTextBoxVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl.FormDesignerControl Property

PropertyGridControlFormDesignerControl Property
Gets or sets an IFormDesignerControl related to this property grid.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerControl FormDesignerControl { get; set; }
Public Property FormDesignerControl As IFormDesignerControl
    Get
    Set
public:
virtual property IFormDesignerControl^ FormDesignerControl {
    IFormDesignerControl^ get () sealed;
    void set (IFormDesignerControl^ value) sealed;
}
abstract FormDesignerControl : IFormDesignerControl with get, set
override FormDesignerControl : IFormDesignerControl with get, set

Property Value

Type: IFormDesignerControl

Implements

IPropertyGridControlFormDesignerControl
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl.LineColor Property

PropertyGridControlLineColor Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color LineColor { get; set; }
Public Property LineColor As Color
    Get
    Set
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
member LineColor : Color with get, set

Property Value

Type: Color
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl.PropertyBlacklist Property

PropertyGridControlPropertyBlacklist Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<string> PropertyBlacklist { get; }
Public ReadOnly Property PropertyBlacklist As List(Of String)
    Get
public:
property List<String^>^ PropertyBlacklist {
    List<String^>^ get ();
}
member PropertyBlacklist : List<string> with get

Property Value

Type: ListString
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl.PropertyGrid Property

PropertyGridControlPropertyGrid Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyGrid PropertyGrid { get; }
Public ReadOnly Property PropertyGrid As PropertyGrid
    Get
public:
property PropertyGrid^ PropertyGrid {
    PropertyGrid^ get ();
}
member PropertyGrid : PropertyGrid with get

Property Value

Type: PropertyGrid
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl.SelectedObjects Property

PropertyGridControlSelectedObjects Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object[] SelectedObjects { get; set; }
Public Property SelectedObjects As Object()
    Get
    Set
public:
virtual property array<Object^>^ SelectedObjects {
    array<Object^>^ get () sealed;
    void set (array<Object^>^ value) sealed;
}
abstract SelectedObjects : Object[] with get, set
override SelectedObjects : Object[] with get, set

Property Value

Type: Object

Implements

IPropertyGridControlSelectedObjects
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl Events

PropertyGridControl Events

The PropertyGridControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreFilterProperties |
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


PropertyGridControl.PreFilterProperties Event

PropertyGridControlPreFilterProperties Event

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PreFilterPropertiesEventArgs> PreFilterProperties
Public Event PreFilterProperties As EventHandler(Of PreFilterPropertiesEventArgs)
public:
 event EventHandler<PreFilterPropertiesEventArgs^>^ PreFilterProperties {
    void add (EventHandler<PreFilterPropertiesEventArgs^>^ value);
    void remove (EventHandler<PreFilterPropertiesEventArgs^>^ value);
}
member PreFilterProperties : IEvent<EventHandler<PreFilterPropertiesEventArgs>,
    PreFilterPropertiesEventArgs>

Value

Type: SystemEventHandlerPreFilterPropertiesEventArgs
See Also

Reference

PropertyGridControl Class
Alternet.FormDesigner.WinForms Namespace


ResourceService Class

ResourceService Class
Provides methods for designers to access resource readers and writers for specific System.Globalization.CultureInfo resource types.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinFormsResourceService

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ResourceService : IResourceServiceExtended,
    IResourceService, IDisposable
Public Class ResourceService
    Implements IResourceServiceExtended, IResourceService, IDisposable
public ref class ResourceService : IResourceServiceExtended,
    IResourceService, IDisposable
type ResourceService =
    class
        interface IResourceServiceExtended
        interface IResourceService
        interface IDisposable
    end

The ResourceService type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceService | Initializes a new instance of the ResourceService class with specified settings.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes ResourceService object and releases all associated resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResourceReader | Finds out an object used to read data from resource files.
Public method | GetResourceWriter | Finds out an object used to write data to resource files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


ResourceService Constructor

ResourceService Constructor
Initializes a new instance of the ResourceService class with specified settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResourceService(
    IServiceContainer serviceContainer,
    OpenStreamDelegate openStreamFunc
)
Public Sub New (
    serviceContainer As IServiceContainer,
    openStreamFunc As OpenStreamDelegate
)
public:
ResourceService(
    IServiceContainer^ serviceContainer,
    OpenStreamDelegate^ openStreamFunc
)
new :
        serviceContainer : IServiceContainer *
        openStreamFunc : OpenStreamDelegate -> ResourceService

Parameters

serviceContainer
Type: System.ComponentModel.DesignIServiceContainer
Container for this new instance.
openStreamFunc
Type: Alternet.FormDesigner.WinFormsOpenStreamDelegate
Method used to open stream.
See Also

Reference

ResourceService Class
Alternet.FormDesigner.WinForms Namespace


ResourceService Methods

ResourceService Methods

The ResourceService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes ResourceService object and releases all associated resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResourceReader | Finds out an object used to read data from resource files.
Public method | GetResourceWriter | Finds out an object used to write data to resource files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResourceService Class
Alternet.FormDesigner.WinForms Namespace


ResourceService.Dispose Method

ResourceServiceDispose Method
Disposes ResourceService object and releases all associated resources.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ResourceService Class
Alternet.FormDesigner.WinForms Namespace


ResourceService.GetResourceReader Method

ResourceServiceGetResourceReader Method
Finds out an object used to read data from resource files.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IResourceReader GetResourceReader(
    CultureInfo info
)
Public Function GetResourceReader (
    info As CultureInfo
) As IResourceReader
public:
virtual IResourceReader^ GetResourceReader(
    CultureInfo^ info
) sealed
abstract GetResourceReader :
        info : CultureInfo -> IResourceReader
override GetResourceReader :
        info : CultureInfo -> IResourceReader

Parameters

info
Type: System.GlobalizationCultureInfo

Return Value

Type: IResourceReader
IResourceReader performs reading data functionality.

Implements

IResourceServiceGetResourceReader(CultureInfo)
See Also

Reference

ResourceService Class
Alternet.FormDesigner.WinForms Namespace


ResourceService.GetResourceWriter Method

ResourceServiceGetResourceWriter Method
Finds out an object used to write data to resource files.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IResourceWriter GetResourceWriter(
    CultureInfo info
)
Public Function GetResourceWriter (
    info As CultureInfo
) As IResourceWriter
public:
virtual IResourceWriter^ GetResourceWriter(
    CultureInfo^ info
) sealed
abstract GetResourceWriter :
        info : CultureInfo -> IResourceWriter
override GetResourceWriter :
        info : CultureInfo -> IResourceWriter

Parameters

info
Type: System.GlobalizationCultureInfo

Return Value

Type: IResourceWriter
IResourceWriter performs writing data functionality.

Implements

IResourceServiceGetResourceWriter(CultureInfo)
See Also

Reference

ResourceService Class
Alternet.FormDesigner.WinForms Namespace


StreamAccessMode Enumeration

StreamAccessMode Enumeration
Defines constants for read, write access to a stream.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StreamAccessMode
Public Enumeration StreamAccessMode
public enum class StreamAccessMode
type StreamAccessMode
Members
Member name | Value | Description
Read | 0 | Read access to the stream. Data can be read from the stream.
Write | 1 | Write access to the stream. Data can be written to the stream.
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


TextSourceStream Class

TextSourceStream Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
Alternet.FormDesigner.WinFormsTextSourceStream

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextSourceStream : Stream
Public Class TextSourceStream
    Inherits Stream
public ref class TextSourceStream : public Stream
type TextSourceStream =
    class
        inherit Stream
    end

The TextSourceStream type exposes the following members.

Constructors
 | Name | Description
Public method | TextSourceStream | Initializes a new instance of the TextSourceStream class
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAllBytes | Receives content of the specified input. (Defined by StreamExtensions.)
Public Extension Method | GetAllText | Receives content of the specified input. (Defined by StreamExtensions.)
Top
Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


TextSourceStream Constructor

TextSourceStream Constructor
Initializes a new instance of the TextSourceStream class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextSourceStream(
    IFormDesignerTextSource textSource
)
Public Sub New (
    textSource As IFormDesignerTextSource
)
public:
TextSourceStream(
    IFormDesignerTextSource^ textSource
)
new :
        textSource : IFormDesignerTextSource -> TextSourceStream

Parameters

textSource
Type: Alternet.FormDesigner.WinFormsIFormDesignerTextSource
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream Methods

TextSourceStream Methods

The TextSourceStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAllBytes | Receives content of the specified input. (Defined by StreamExtensions.)
Public Extension Method | GetAllText | Receives content of the specified input. (Defined by StreamExtensions.)
Top
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.Flush Method

TextSourceStreamFlush Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.Read Method

TextSourceStreamRead Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: SystemByte
offset
Type: SystemInt32
count
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.Seek Method

TextSourceStreamSeek Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: SystemInt64
origin
Type: System.IOSeekOrigin

Return Value

Type: Int64
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.SetLength Method

TextSourceStreamSetLength Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit

Parameters

value
Type: SystemInt64
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.Write Method

TextSourceStreamWrite Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: SystemByte
offset
Type: SystemInt32
count
Type: SystemInt32
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream Properties

TextSourceStream Properties

The TextSourceStream type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.CanRead Property

TextSourceStreamCanRead Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get

Property Value

Type: Boolean
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.CanSeek Property

TextSourceStreamCanSeek Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get

Property Value

Type: Boolean
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.CanWrite Property

TextSourceStreamCanWrite Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get

Property Value

Type: Boolean
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.Length Property

TextSourceStreamLength Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get

Property Value

Type: Int64
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


TextSourceStream.Position Property

TextSourceStreamPosition Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set

Property Value

Type: Int64
See Also

Reference

TextSourceStream Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl Class

ToolboxControl Class
Displays and manipulates list of icons for components and controls that user can place onto design surface
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Alternet.FormDesigner.WinFormsToolboxControl

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxControl : Panel,
    IToolboxControl, IToolboxContentControlSite, ISupportInitialize
Public Class ToolboxControl
    Inherits Panel
    Implements IToolboxControl, IToolboxContentControlSite, ISupportInitialize
public ref class ToolboxControl : public Panel,
    IToolboxControl, IToolboxContentControlSite, ISupportInitialize
type ToolboxControl =
    class
        inherit Panel
        interface IToolboxControl
        interface IToolboxContentControlSite
        interface ISupportInitialize
    end

The ToolboxControl type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxControl | Initializes a new instance of the ToolboxControl class with default settings.
Top
Methods
 | Name | Description
Public method | AddCategory | Adds new category to the toolbox.
Public method | AddItem | Places toolbox item onto specified toolbox tab.
Public method | AddItemForType | Adds toolbox item from type name.
Public method | AddItemsFromAssembly | Add all types that can appear on the toolbox from the assembly.
Public method | BeginInit | Signals the start of the ToolboxControl initialization.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents repainting of the toolbox until EndUpdate is called.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearItemsInCategory | Clears items in the specified tab.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DoesCategoryExist | Identifies whether given category exist in the ToolboxControl.
Public method | DoesItemExist(String, ToolboxItem) | Identifies whether given item exist in the specified tab.
Public method | DoesItemExist(String, String) | Identifies whether given item exist in the specified tab.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInit | Signals the end of the ToolboxControl initialization.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Re-enables toolbox repainting.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillWithStandardItems | Fills ToolboxControl with standard items.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetAllTools | Gets all toolbox items.
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetToolsFromCategory | Gets toolbox items on the specified tab.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertCategory | Inserts category in the specified position.
Public method | InsertItem | Inserts item in the specified position.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | IsCategoryCollapsed | Indicates whether specified category is in the collapsed state.
Public method | Load | Loads the toolbox content from the specified stream.
Public method | MoveCategory | Moves category to its current position plus value specified by positionDifference parameter.
Public method | MoveItem | Moves item to its current position plus value specified by positionDifference parameter.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveAllCategories | Removes all categories from the toolbox control.
Public method | RemoveCategory | Removes specified tab.
Public method | RemoveItem | Removes toolbox item from the category.
Public method | RenameCategory | Renames the specified category.
Public method | Reset | Resets the toolbox content to defaults.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Save | Saves the toolbox content to the specified stream.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollToCategory | Scrolls toolbox control to the specified category.
Public method | ScrollToItem | Scrolls toolbox control to the specified item.
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SelectPointer | Deselects currently selected toolbox item and selects pointer tool.
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetCategoryCollapsed | Sets specified collapsed state to the given category.
Public method | SetSelectedItem | Selects toolbox item.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor property should be persisted.
Public method | ShouldSerializeSearchFilter | Indicates whether the SearchFilter property should be persisted.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoFillWithStandardItems | Gets or sets a boolean value indicating whether ToolboxControl content should be automatically filled by the standard collection of the toolbox items.
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | (Overrides ControlBackColor.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CategoryNames | Gets collection of Categories (Tabs) displayed by the toolbox.
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesignerHost | Provides an interface for managing designer transactions and components.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormDesignerControl | Provides an interface to support all standard form editing operations with controls.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideContentsWhenNoFormDesignerIsSet | Gets or sets a boolean value indicates whether toolbox control should display it's content when FormDesignerControl is not set.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Painter | Provides an interface to draw toolbox item.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SearchEnabled |
Public property | SearchFilter |
Public property | SelectedCategory | Gets or sets currently selected toolbox category.
Public property | SelectedTool | Returns currently selected toolbox item.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseMetroIconsForStandardItems | Gets or sets a boolean value indicating whether ToolboxControl should draw standard items using internal icon's collection.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PlaceItemAtDefaultLocation | Event which is fired when user double clicks on a toolbox item.
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


ToolboxControl Constructor

ToolboxControl Constructor
Initializes a new instance of the ToolboxControl class with default settings.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxControl()
Public Sub New
public:
ToolboxControl()
new : unit -> ToolboxControl
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl Methods

ToolboxControl Methods

The ToolboxControl type exposes the following members.

Methods
 | Name | Description
Public method | AddCategory | Adds new category to the toolbox.
Public method | AddItem | Places toolbox item onto specified toolbox tab.
Public method | AddItemForType | Adds toolbox item from type name.
Public method | AddItemsFromAssembly | Add all types that can appear on the toolbox from the assembly.
Public method | BeginInit | Signals the start of the ToolboxControl initialization.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents repainting of the toolbox until EndUpdate is called.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearItemsInCategory | Clears items in the specified tab.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DoesCategoryExist | Identifies whether given category exist in the ToolboxControl.
Public method | DoesItemExist(String, ToolboxItem) | Identifies whether given item exist in the specified tab.
Public method | DoesItemExist(String, String) | Identifies whether given item exist in the specified tab.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInit | Signals the end of the ToolboxControl initialization.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Re-enables toolbox repainting.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillWithStandardItems | Fills ToolboxControl with standard items.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetAllTools | Gets all toolbox items.
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetToolsFromCategory | Gets toolbox items on the specified tab.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertCategory | Inserts category in the specified position.
Public method | InsertItem | Inserts item in the specified position.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | IsCategoryCollapsed | Indicates whether specified category is in the collapsed state.
Public method | Load | Loads the toolbox content from the specified stream.
Public method | MoveCategory | Moves category to its current position plus value specified by positionDifference parameter.
Public method | MoveItem | Moves item to its current position plus value specified by positionDifference parameter.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveAllCategories | Removes all categories from the toolbox control.
Public method | RemoveCategory | Removes specified tab.
Public method | RemoveItem | Removes toolbox item from the category.
Public method | RenameCategory | Renames the specified category.
Public method | Reset | Resets the toolbox content to defaults.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Save | Saves the toolbox content to the specified stream.
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollToCategory | Scrolls toolbox control to the specified category.
Public method | ScrollToItem | Scrolls toolbox control to the specified item.
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SelectPointer | Deselects currently selected toolbox item and selects pointer tool.
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetCategoryCollapsed | Sets specified collapsed state to the given category.
Public method | SetSelectedItem | Selects toolbox item.
Public method | ShouldSerializeBackColor | Indicates whether the BackColor property should be persisted.
Public method | ShouldSerializeSearchFilter | Indicates whether the SearchFilter property should be persisted.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.AddCategory Method

ToolboxControlAddCategory Method
Adds new category to the toolbox.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCategory(
    string categoryName
)
Public Sub AddCategory (
    categoryName As String
)
public:
virtual void AddCategory(
    String^ categoryName
) sealed
abstract AddCategory :
        categoryName : string -> unit
override AddCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Category name to add.

Implements

IToolboxControlAddCategory(String)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.AddItem Method

ToolboxControlAddItem Method
Places toolbox item onto specified toolbox tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddItem(
    string categoryName,
    ToolboxItem item
)
Public Sub AddItem (
    categoryName As String,
    item As ToolboxItem
)
public:
virtual void AddItem(
    String^ categoryName,
    ToolboxItem^ item
) sealed
abstract AddItem :
        categoryName : string *
        item : ToolboxItem -> unit
override AddItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Tab name where new items will be placed.
item
Type: System.Drawing.DesignToolboxItem
Item to add.

Implements

IToolboxControlAddItem(String, ToolboxItem)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.AddItemForType Method

ToolboxControlAddItemForType Method
Adds toolbox item from type name.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddItemForType(
    string categoryName,
    Type type,
    CustomToolboxImage customImage = null
)
Public Sub AddItemForType (
    categoryName As String,
    type As Type,
    Optional customImage As CustomToolboxImage = Nothing
)
public:
virtual void AddItemForType(
    String^ categoryName,
    Type^ type,
    CustomToolboxImage^ customImage = nullptr
) sealed
abstract AddItemForType :
        categoryName : string *
        type : Type *
        ?customImage : CustomToolboxImage
(* Defaults:
        let _customImage = defaultArg customImage null
*)
-> unit
override AddItemForType :
        categoryName : string *
        type : Type *
        ?customImage : CustomToolboxImage
(* Defaults:
        let _customImage = defaultArg customImage null
*)
-> unit

Parameters

categoryName
Type: SystemString
Tab name where new items will be placed.
type
Type: SystemType
Type to get items from.
customImage (Optional)
Type: Alternet.FormDesigner.WinFormsCustomToolboxImage
Specifies Bitmap to draw with items.

Implements

IToolboxControlAddItemForType(String, Type, CustomToolboxImage)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.AddItemsFromAssembly Method

ToolboxControlAddItemsFromAssembly Method
Add all types that can appear on the toolbox from the assembly.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddItemsFromAssembly(
    string categoryName,
    Assembly assembly
)
Public Sub AddItemsFromAssembly (
    categoryName As String,
    assembly As Assembly
)
public:
virtual void AddItemsFromAssembly(
    String^ categoryName,
    Assembly^ assembly
) sealed
abstract AddItemsFromAssembly :
        categoryName : string *
        assembly : Assembly -> unit
override AddItemsFromAssembly :
        categoryName : string *
        assembly : Assembly -> unit

Parameters

categoryName
Type: SystemString
Tab name where new items will be placed.
assembly
Type: System.ReflectionAssembly
Assembly to get items from.

Implements

IToolboxControlAddItemsFromAssembly(String, Assembly)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.BeginInit Method

ToolboxControlBeginInit Method
Signals the start of the ToolboxControl initialization.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BeginInit()
Public Sub BeginInit
public:
virtual void BeginInit() sealed
abstract BeginInit : unit -> unit
override BeginInit : unit -> unit

Implements

ISupportInitializeBeginInit
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.BeginUpdate Method

ToolboxControlBeginUpdate Method
Prevents repainting of the toolbox until EndUpdate is called.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BeginUpdate()
Public Sub BeginUpdate
public:
virtual void BeginUpdate() sealed
abstract BeginUpdate : unit -> unit
override BeginUpdate : unit -> unit

Implements

IToolboxControlBeginUpdate
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.ClearItemsInCategory Method

ToolboxControlClearItemsInCategory Method
Clears items in the specified tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearItemsInCategory(
    string categoryName
)
Public Sub ClearItemsInCategory (
    categoryName As String
)
public:
virtual void ClearItemsInCategory(
    String^ categoryName
) sealed
abstract ClearItemsInCategory :
        categoryName : string -> unit
override ClearItemsInCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Name of tab for clearing.

Implements

IToolboxControlClearItemsInCategory(String)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.DoesCategoryExist Method

ToolboxControlDoesCategoryExist Method
Identifies whether given category exist in the ToolboxControl.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoesCategoryExist(
    string categoryName
)
Public Function DoesCategoryExist (
    categoryName As String
) As Boolean
public:
virtual bool DoesCategoryExist(
    String^ categoryName
) sealed
abstract DoesCategoryExist :
        categoryName : string -> bool
override DoesCategoryExist :
        categoryName : string -> bool

Parameters

categoryName
Type: SystemString
Name of tab to check.

Return Value

Type: Boolean
True if exists; otherwise false.

Implements

IToolboxControlDoesCategoryExist(String)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.DoesItemExist Method

ToolboxControlDoesItemExist Method
Overload List
 | Name | Description
Public method | DoesItemExist(String, ToolboxItem) | Identifies whether given item exist in the specified tab.
Public method | DoesItemExist(String, String) | Identifies whether given item exist in the specified tab.
Top
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.DoesItemExist Method (String, ToolboxItem)

ToolboxControlDoesItemExist Method (String, ToolboxItem)
Identifies whether given item exist in the specified tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoesItemExist(
    string categoryName,
    ToolboxItem item
)
Public Function DoesItemExist (
    categoryName As String,
    item As ToolboxItem
) As Boolean
public:
virtual bool DoesItemExist(
    String^ categoryName,
    ToolboxItem^ item
) sealed
abstract DoesItemExist :
        categoryName : string *
        item : ToolboxItem -> bool
override DoesItemExist :
        categoryName : string *
        item : ToolboxItem -> bool

Parameters

categoryName
Type: SystemString
Name of tab to check.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to check.

Return Value

Type: Boolean
True if exists; otherwise false.

Implements

IToolboxControlDoesItemExist(String, ToolboxItem)
See Also

Reference

ToolboxControl Class
DoesItemExist Overload
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.DoesItemExist Method (String, String)

ToolboxControlDoesItemExist Method (String, String)
Identifies whether given item exist in the specified tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoesItemExist(
    string categoryName,
    string itemName
)
Public Function DoesItemExist (
    categoryName As String,
    itemName As String
) As Boolean
public:
bool DoesItemExist(
    String^ categoryName,
    String^ itemName
)
member DoesItemExist :
        categoryName : string *
        itemName : string -> bool

Parameters

categoryName
Type: SystemString
Name of tab to check.
itemName
Type: SystemString
Item name to check.

Return Value

Type: Boolean
True if exists; otherwise false.
See Also

Reference

ToolboxControl Class
DoesItemExist Overload
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.EndInit Method

ToolboxControlEndInit Method
Signals the end of the ToolboxControl initialization.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EndInit()
Public Sub EndInit
public:
virtual void EndInit() sealed
abstract EndInit : unit -> unit
override EndInit : unit -> unit

Implements

ISupportInitializeEndInit
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.EndUpdate Method

ToolboxControlEndUpdate Method
Re-enables toolbox repainting.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EndUpdate()
Public Sub EndUpdate
public:
virtual void EndUpdate() sealed
abstract EndUpdate : unit -> unit
override EndUpdate : unit -> unit

Implements

IToolboxControlEndUpdate
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.FillWithStandardItems Method

ToolboxControlFillWithStandardItems Method
Fills ToolboxControl with standard items.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FillWithStandardItems(
    bool useMetroIcons
)
Public Sub FillWithStandardItems (
    useMetroIcons As Boolean
)
public:
void FillWithStandardItems(
    bool useMetroIcons
)
member FillWithStandardItems :
        useMetroIcons : bool -> unit

Parameters

useMetroIcons
Type: SystemBoolean
Specifies whether internal icon collection should be used to draw these items.
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.GetAllTools Method

ToolboxControlGetAllTools Method
Gets all toolbox items.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemCollection GetAllTools()
Public Function GetAllTools As ToolboxItemCollection
public:
virtual ToolboxItemCollection^ GetAllTools() sealed
abstract GetAllTools : unit -> ToolboxItemCollection
override GetAllTools : unit -> ToolboxItemCollection

Return Value

Type: ToolboxItemCollection
Collection of toolbox items stored in the IToolboxControl.

Implements

IToolboxControlGetAllTools
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.GetToolsFromCategory Method

ToolboxControlGetToolsFromCategory Method
Gets toolbox items on the specified tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemCollection GetToolsFromCategory(
    string category
)
Public Function GetToolsFromCategory (
    category As String
) As ToolboxItemCollection
public:
virtual ToolboxItemCollection^ GetToolsFromCategory(
    String^ category
) sealed
abstract GetToolsFromCategory :
        category : string -> ToolboxItemCollection
override GetToolsFromCategory :
        category : string -> ToolboxItemCollection

Parameters

category
Type: SystemString
Name of tab to get items from.

Return Value

Type: ToolboxItemCollection
Collection of toolbox items displayed on the specified tab.

Implements

IToolboxControlGetToolsFromCategory(String)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.InsertCategory Method

ToolboxControlInsertCategory Method
Inserts category in the specified position.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertCategory(
    int index,
    string categoryName
)
Public Sub InsertCategory (
    index As Integer,
    categoryName As String
)
public:
virtual void InsertCategory(
    int index,
    String^ categoryName
) sealed
abstract InsertCategory :
        index : int *
        categoryName : string -> unit
override InsertCategory :
        index : int *
        categoryName : string -> unit

Parameters

index
Type: SystemInt32
categoryName
Type: SystemString

Implements

IToolboxControlInsertCategory(Int32, String)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.InsertItem Method

ToolboxControlInsertItem Method
Inserts item in the specified position.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertItem(
    int index,
    string categoryName,
    ToolboxItem item
)
Public Sub InsertItem (
    index As Integer,
    categoryName As String,
    item As ToolboxItem
)
public:
virtual void InsertItem(
    int index,
    String^ categoryName,
    ToolboxItem^ item
) sealed
abstract InsertItem :
        index : int *
        categoryName : string *
        item : ToolboxItem -> unit
override InsertItem :
        index : int *
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

index
Type: SystemInt32
categoryName
Type: SystemString
item
Type: System.Drawing.DesignToolboxItem

Implements

IToolboxControlInsertItem(Int32, String, ToolboxItem)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.IsCategoryCollapsed Method

ToolboxControlIsCategoryCollapsed Method
Indicates whether specified category is in the collapsed state.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCategoryCollapsed(
    string categoryName
)
Public Function IsCategoryCollapsed (
    categoryName As String
) As Boolean
public:
bool IsCategoryCollapsed(
    String^ categoryName
)
member IsCategoryCollapsed :
        categoryName : string -> bool

Parameters

categoryName
Type: SystemString
Name of tab to check.

Return Value

Type: Boolean
True if tab is collapsed; otherwise false.
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.Load Method

ToolboxControlLoad Method
Loads the toolbox content from the specified stream.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Load(
    Stream stream
)
Public Sub Load (
    stream As Stream
)
public:
virtual void Load(
    Stream^ stream
) sealed
abstract Load :
        stream : Stream -> unit
override Load :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream

Implements

IToolboxControlLoad(Stream)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.MoveCategory Method

ToolboxControlMoveCategory Method
Moves category to its current position plus value specified by positionDifference parameter.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveCategory(
    string categoryName,
    int positionDifference
)
Public Sub MoveCategory (
    categoryName As String,
    positionDifference As Integer
)
public:
virtual void MoveCategory(
    String^ categoryName,
    int positionDifference
) sealed
abstract MoveCategory :
        categoryName : string *
        positionDifference : int -> unit
override MoveCategory :
        categoryName : string *
        positionDifference : int -> unit

Parameters

categoryName
Type: SystemString
positionDifference
Type: SystemInt32

Implements

IToolboxControlMoveCategory(String, Int32)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.MoveItem Method

ToolboxControlMoveItem Method
Moves item to its current position plus value specified by positionDifference parameter.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveItem(
    string categoryName,
    ToolboxItem item,
    int positionDifference
)
Public Sub MoveItem (
    categoryName As String,
    item As ToolboxItem,
    positionDifference As Integer
)
public:
virtual void MoveItem(
    String^ categoryName,
    ToolboxItem^ item,
    int positionDifference
) sealed
abstract MoveItem :
        categoryName : string *
        item : ToolboxItem *
        positionDifference : int -> unit
override MoveItem :
        categoryName : string *
        item : ToolboxItem *
        positionDifference : int -> unit

Parameters

categoryName
Type: SystemString
item
Type: System.Drawing.DesignToolboxItem
positionDifference
Type: SystemInt32

Implements

IToolboxControlMoveItem(String, ToolboxItem, Int32)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.RemoveAllCategories Method

ToolboxControlRemoveAllCategories Method
Removes all categories from the toolbox control.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveAllCategories()
Public Sub RemoveAllCategories
public:
virtual void RemoveAllCategories() sealed
abstract RemoveAllCategories : unit -> unit
override RemoveAllCategories : unit -> unit

Implements

IToolboxControlRemoveAllCategories
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.RemoveCategory Method

ToolboxControlRemoveCategory Method
Removes specified tab.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCategory(
    string categoryName
)
Public Sub RemoveCategory (
    categoryName As String
)
public:
virtual void RemoveCategory(
    String^ categoryName
) sealed
abstract RemoveCategory :
        categoryName : string -> unit
override RemoveCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Name of tab to remove.

Implements

IToolboxControlRemoveCategory(String)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.RemoveItem Method

ToolboxControlRemoveItem Method
Removes toolbox item from the category.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveItem(
    string categoryName,
    ToolboxItem item
)
Public Sub RemoveItem (
    categoryName As String,
    item As ToolboxItem
)
public:
virtual void RemoveItem(
    String^ categoryName,
    ToolboxItem^ item
) sealed
abstract RemoveItem :
        categoryName : string *
        item : ToolboxItem -> unit
override RemoveItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Name of tab from which specific item should be removed.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to remove.

Implements

IToolboxControlRemoveItem(String, ToolboxItem)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.RenameCategory Method

ToolboxControlRenameCategory Method
Renames the specified category.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RenameCategory(
    string oldName,
    string newName
)
Public Sub RenameCategory (
    oldName As String,
    newName As String
)
public:
virtual void RenameCategory(
    String^ oldName,
    String^ newName
) sealed
abstract RenameCategory :
        oldName : string *
        newName : string -> unit
override RenameCategory :
        oldName : string *
        newName : string -> unit

Parameters

oldName
Type: SystemString
newName
Type: SystemString

Implements

IToolboxControlRenameCategory(String, String)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.Reset Method

ToolboxControlReset Method
Resets the toolbox content to defaults.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IToolboxControlReset
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.Save Method

ToolboxControlSave Method
Saves the toolbox content to the specified stream.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save(
    Stream stream
)
Public Sub Save (
    stream As Stream
)
public:
virtual void Save(
    Stream^ stream
) sealed
abstract Save :
        stream : Stream -> unit
override Save :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream

Implements

IToolboxControlSave(Stream)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.ScrollToCategory Method

ToolboxControlScrollToCategory Method
Scrolls toolbox control to the specified category.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ScrollToCategory(
    string categoryName
)
Public Sub ScrollToCategory (
    categoryName As String
)
public:
virtual void ScrollToCategory(
    String^ categoryName
) sealed
abstract ScrollToCategory :
        categoryName : string -> unit
override ScrollToCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString

Implements

IToolboxControlScrollToCategory(String)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.ScrollToItem Method

ToolboxControlScrollToItem Method
Scrolls toolbox control to the specified item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ScrollToItem(
    string categoryName,
    ToolboxItem item
)
Public Sub ScrollToItem (
    categoryName As String,
    item As ToolboxItem
)
public:
virtual void ScrollToItem(
    String^ categoryName,
    ToolboxItem^ item
) sealed
abstract ScrollToItem :
        categoryName : string *
        item : ToolboxItem -> unit
override ScrollToItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
item
Type: System.Drawing.DesignToolboxItem

Implements

IToolboxControlScrollToItem(String, ToolboxItem)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.SelectPointer Method

ToolboxControlSelectPointer Method
Deselects currently selected toolbox item and selects pointer tool.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectPointer()
Public Sub SelectPointer
public:
virtual void SelectPointer() sealed
abstract SelectPointer : unit -> unit
override SelectPointer : unit -> unit

Implements

IToolboxControlSelectPointer
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.SetCategoryCollapsed Method

ToolboxControlSetCategoryCollapsed Method
Sets specified collapsed state to the given category.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCategoryCollapsed(
    string categoryName,
    bool collapsed
)
Public Sub SetCategoryCollapsed (
    categoryName As String,
    collapsed As Boolean
)
public:
void SetCategoryCollapsed(
    String^ categoryName,
    bool collapsed
)
member SetCategoryCollapsed :
        categoryName : string *
        collapsed : bool -> unit

Parameters

categoryName
Type: SystemString
Name of tab to expand or collapse.
collapsed
Type: SystemBoolean
Collapsed state to set.
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.SetSelectedItem Method

ToolboxControlSetSelectedItem Method
Selects toolbox item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSelectedItem(
    string categoryName,
    ToolboxItem item
)
Public Sub SetSelectedItem (
    categoryName As String,
    item As ToolboxItem
)
public:
virtual void SetSelectedItem(
    String^ categoryName,
    ToolboxItem^ item
) sealed
abstract SetSelectedItem :
        categoryName : string *
        item : ToolboxItem -> unit
override SetSelectedItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Name of tab where item should be selected.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to select.

Implements

IToolboxControlSetSelectedItem(String, ToolboxItem)
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.ShouldSerializeBackColor Method

ToolboxControlShouldSerializeBackColor Method
Indicates whether the BackColor property should be persisted.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeBackColor()
Public Overridable Function ShouldSerializeBackColor As Boolean
public:
virtual bool ShouldSerializeBackColor()
abstract ShouldSerializeBackColor : unit -> bool
override ShouldSerializeBackColor : unit -> bool

Return Value

Type: Boolean
True if BackColor differs from its default value; otherwise false.
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.ShouldSerializeSearchFilter Method

ToolboxControlShouldSerializeSearchFilter Method
Indicates whether the SearchFilter property should be persisted.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeSearchFilter()
Public Overridable Function ShouldSerializeSearchFilter As Boolean
public:
virtual bool ShouldSerializeSearchFilter()
abstract ShouldSerializeSearchFilter : unit -> bool
override ShouldSerializeSearchFilter : unit -> bool

Return Value

Type: Boolean
True if SearchFilter differs from its default value; otherwise false.
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl Properties

ToolboxControl Properties

The ToolboxControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoFillWithStandardItems | Gets or sets a boolean value indicating whether ToolboxControl content should be automatically filled by the standard collection of the toolbox items.
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | (Overrides ControlBackColor.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CategoryNames | Gets collection of Categories (Tabs) displayed by the toolbox.
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesignerHost | Provides an interface for managing designer transactions and components.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormDesignerControl | Provides an interface to support all standard form editing operations with controls.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideContentsWhenNoFormDesignerIsSet | Gets or sets a boolean value indicates whether toolbox control should display it's content when FormDesignerControl is not set.
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Painter | Provides an interface to draw toolbox item.
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SearchEnabled |
Public property | SearchFilter |
Public property | SelectedCategory | Gets or sets currently selected toolbox category.
Public property | SelectedTool | Returns currently selected toolbox item.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseMetroIconsForStandardItems | Gets or sets a boolean value indicating whether ToolboxControl should draw standard items using internal icon's collection.
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.AutoFillWithStandardItems Property

ToolboxControlAutoFillWithStandardItems Property
Gets or sets a boolean value indicating whether ToolboxControl content should be automatically filled by the standard collection of the toolbox items.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoFillWithStandardItems { get; set; }
Public Property AutoFillWithStandardItems As Boolean
    Get
    Set
public:
property bool AutoFillWithStandardItems {
    bool get ();
    void set (bool value);
}
member AutoFillWithStandardItems : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.BackColor Property

ToolboxControlBackColor Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.CategoryNames Property

ToolboxControlCategoryNames Property
Gets collection of Categories (Tabs) displayed by the toolbox.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CategoryNameCollection CategoryNames { get; }
Public ReadOnly Property CategoryNames As CategoryNameCollection
    Get
public:
virtual property CategoryNameCollection^ CategoryNames {
    CategoryNameCollection^ get () sealed;
}
abstract CategoryNames : CategoryNameCollection with get
override CategoryNames : CategoryNameCollection with get

Property Value

Type: CategoryNameCollection

Implements

IToolboxControlCategoryNames
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.DesignerHost Property

ToolboxControlDesignerHost Property
Provides an interface for managing designer transactions and components.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDesignerHost DesignerHost { get; }
Public ReadOnly Property DesignerHost As IDesignerHost
    Get
public:
property IDesignerHost^ DesignerHost {
    IDesignerHost^ get ();
}
member DesignerHost : IDesignerHost with get

Property Value

Type: IDesignerHost
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.FormDesignerControl Property

ToolboxControlFormDesignerControl Property
Provides an interface to support all standard form editing operations with controls.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFormDesignerControl FormDesignerControl { get; set; }
Public Property FormDesignerControl As IFormDesignerControl
    Get
    Set
public:
property IFormDesignerControl^ FormDesignerControl {
    IFormDesignerControl^ get ();
    void set (IFormDesignerControl^ value);
}
member FormDesignerControl : IFormDesignerControl with get, set

Property Value

Type: IFormDesignerControl
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.HideContentsWhenNoFormDesignerIsSet Property

ToolboxControlHideContentsWhenNoFormDesignerIsSet Property
Gets or sets a boolean value indicates whether toolbox control should display it's content when FormDesignerControl is not set.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideContentsWhenNoFormDesignerIsSet { get; set; }
Public Property HideContentsWhenNoFormDesignerIsSet As Boolean
    Get
    Set
public:
property bool HideContentsWhenNoFormDesignerIsSet {
    bool get ();
    void set (bool value);
}
member HideContentsWhenNoFormDesignerIsSet : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.Painter Property

ToolboxControlPainter Property
Provides an interface to draw toolbox item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IToolboxPainter Painter { get; set; }
Public Property Painter As IToolboxPainter
    Get
    Set
public:
virtual property IToolboxPainter^ Painter {
    IToolboxPainter^ get () sealed;
    void set (IToolboxPainter^ value) sealed;
}
abstract Painter : IToolboxPainter with get, set
override Painter : IToolboxPainter with get, set

Property Value

Type: IToolboxPainter

Implements

IToolboxContentControlSitePainter
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.SearchEnabled Property

ToolboxControlSearchEnabled Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SearchEnabled { get; set; }
Public Property SearchEnabled As Boolean
    Get
    Set
public:
virtual property bool SearchEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SearchEnabled : bool with get, set
override SearchEnabled : bool with get, set

Property Value

Type: Boolean

Implements

IToolboxControlSearchEnabled
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.SearchFilter Property

ToolboxControlSearchFilter Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SearchFilter { get; set; }
Public Property SearchFilter As String
    Get
    Set
public:
property String^ SearchFilter {
    String^ get ();
    void set (String^ value);
}
member SearchFilter : string with get, set

Property Value

Type: String
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.SelectedCategory Property

ToolboxControlSelectedCategory Property
Gets or sets currently selected toolbox category.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SelectedCategory { get; set; }
Public Property SelectedCategory As String
    Get
    Set
public:
virtual property String^ SelectedCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract SelectedCategory : string with get, set
override SelectedCategory : string with get, set

Property Value

Type: String

Implements

IToolboxControlSelectedCategory
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.SelectedTool Property

ToolboxControlSelectedTool Property
Returns currently selected toolbox item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItem SelectedTool { get; }
Public ReadOnly Property SelectedTool As ToolboxItem
    Get
public:
virtual property ToolboxItem^ SelectedTool {
    ToolboxItem^ get () sealed;
}
abstract SelectedTool : ToolboxItem with get
override SelectedTool : ToolboxItem with get

Property Value

Type: ToolboxItem

Implements

IToolboxControlSelectedTool
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.UseMetroIconsForStandardItems Property

ToolboxControlUseMetroIconsForStandardItems Property
Gets or sets a boolean value indicating whether ToolboxControl should draw standard items using internal icon's collection.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseMetroIconsForStandardItems { get; set; }
Public Property UseMetroIconsForStandardItems As Boolean
    Get
    Set
public:
property bool UseMetroIconsForStandardItems {
    bool get ();
    void set (bool value);
}
member UseMetroIconsForStandardItems : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl Events

ToolboxControl Events

The ToolboxControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PlaceItemAtDefaultLocation | Event which is fired when user double clicks on a toolbox item.
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


ToolboxControl.PlaceItemAtDefaultLocation Event

ToolboxControlPlaceItemAtDefaultLocation Event
Event which is fired when user double clicks on a toolbox item.

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs> PlaceItemAtDefaultLocation
Public Event PlaceItemAtDefaultLocation As EventHandler(Of PlaceToolboxItemAtDefaultLocationEventArgs)
public:
virtual  event EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs^>^ PlaceItemAtDefaultLocation {
    void add (EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs^>^ value);
    void remove (EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs^>^ value);
}
abstract PlaceItemAtDefaultLocation : IEvent<EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs>,
    PlaceToolboxItemAtDefaultLocationEventArgs>
override PlaceItemAtDefaultLocation : IEvent<EventHandler<PlaceToolboxItemAtDefaultLocationEventArgs>,
    PlaceToolboxItemAtDefaultLocationEventArgs>

Value

Type: SystemEventHandlerPlaceToolboxItemAtDefaultLocationEventArgs

Implements

IToolboxControlPlaceItemAtDefaultLocation
See Also

Reference

ToolboxControl Class
Alternet.FormDesigner.WinForms Namespace


UndoEngineService Class

UndoEngineService Class
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignUndoEngine
Alternet.FormDesigner.WinFormsUndoEngineService

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UndoEngineService : UndoEngine,
    IUndoEngine
Public Class UndoEngineService
    Inherits UndoEngine
    Implements IUndoEngine
public ref class UndoEngineService : public UndoEngine,
    IUndoEngine
type UndoEngineService =
    class
        inherit UndoEngine
        interface IUndoEngine
    end

The UndoEngineService type exposes the following members.

Constructors
 | Name | Description
Public method | UndoEngineService | Initializes a new instance of the UndoEngineService class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the UndoEngine. (Inherited from UndoEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Redo |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo |
Top
Properties
 | Name | Description
Public property | CanRedo |
Public property | CanUndo |
Public property | Enabled | Enables or disables the UndoEngine. (Inherited from UndoEngine.)
Public property | Engine |
Public property | UndoInProgress | Indicates if an undo action is in progress. (Inherited from UndoEngine.)
Top
Events
 | Name | Description
Public event | Undoing | Occurs immediately before an undo action is performed. (Inherited from UndoEngine.)
Public event | Undone | Occurs immediately after an undo action is performed. (Inherited from UndoEngine.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms Namespace


UndoEngineService Constructor

UndoEngineService Constructor
Initializes a new instance of the UndoEngineService class

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UndoEngineService(
    IServiceProvider serviceProvider,
    Action onUndoStateChanged
)
Public Sub New (
    serviceProvider As IServiceProvider,
    onUndoStateChanged As Action
)
public:
UndoEngineService(
    IServiceProvider^ serviceProvider,
    Action^ onUndoStateChanged
)
new :
        serviceProvider : IServiceProvider *
        onUndoStateChanged : Action -> UndoEngineService

Parameters

serviceProvider
Type: SystemIServiceProvider
onUndoStateChanged
Type: SystemAction
See Also

Reference

UndoEngineService Class
Alternet.FormDesigner.WinForms Namespace


UndoEngineService Methods

UndoEngineService Methods

The UndoEngineService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the UndoEngine. (Inherited from UndoEngine.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Redo |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo |
Top
See Also

Reference

UndoEngineService Class
Alternet.FormDesigner.WinForms Namespace


UndoEngineService.Redo Method

UndoEngineServiceRedo Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Redo()
Public Sub Redo
public:
void Redo()
member Redo : unit -> unit
See Also

Reference

UndoEngineService Class
Alternet.FormDesigner.WinForms Namespace


UndoEngineService.Undo Method

UndoEngineServiceUndo Method

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Undo()
Public Sub Undo
public:
void Undo()
member Undo : unit -> unit
See Also

Reference

UndoEngineService Class
Alternet.FormDesigner.WinForms Namespace


UndoEngineService Properties

UndoEngineService Properties

The UndoEngineService type exposes the following members.

Properties
 | Name | Description
Public property | CanRedo |
Public property | CanUndo |
Public property | Enabled | Enables or disables the UndoEngine. (Inherited from UndoEngine.)
Public property | Engine |
Public property | UndoInProgress | Indicates if an undo action is in progress. (Inherited from UndoEngine.)
Top
See Also

Reference

UndoEngineService Class
Alternet.FormDesigner.WinForms Namespace


UndoEngineService.CanRedo Property

UndoEngineServiceCanRedo Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRedo { get; }
Public ReadOnly Property CanRedo As Boolean
    Get
public:
property bool CanRedo {
    bool get ();
}
member CanRedo : bool with get

Property Value

Type: Boolean
See Also

Reference

UndoEngineService Class
Alternet.FormDesigner.WinForms Namespace


UndoEngineService.CanUndo Property

UndoEngineServiceCanUndo Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUndo { get; }
Public ReadOnly Property CanUndo As Boolean
    Get
public:
property bool CanUndo {
    bool get ();
}
member CanUndo : bool with get

Property Value

Type: Boolean
See Also

Reference

UndoEngineService Class
Alternet.FormDesigner.WinForms Namespace


UndoEngineService.Engine Property

UndoEngineServiceEngine Property

Namespace: Alternet.FormDesigner.WinForms
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public UndoEngine Engine { get; }
Public ReadOnly Property Engine As UndoEngine
    Get
public:
virtual property UndoEngine^ Engine {
    UndoEngine^ get () sealed;
}
abstract Engine : UndoEngine with get
override Engine : UndoEngine with get

Property Value

Type: UndoEngine

Implements

IUndoEngineEngine
See Also

Reference

UndoEngineService Class
Alternet.FormDesigner.WinForms Namespace


UndoEngineService Events

UndoEngineService Events

The UndoEngineService type exposes the following members.

Events
 | Name | Description
Public event | Undoing | Occurs immediately before an undo action is performed. (Inherited from UndoEngine.)
Public event | Undone | Occurs immediately after an undo action is performed. (Inherited from UndoEngine.)
Top
See Also

Reference

UndoEngineService Class
Alternet.FormDesigner.WinForms Namespace


Alternet.FormDesigner.WinForms.License Namespace

Alternet.FormDesigner.WinForms.License Namespace
Classes
 | Class | Description
Public class | FormDesignerWinFormsLicenseProvider | Provides a license provider functionality for the FormDesignerControl.


FormDesignerWinFormsLicenseProvider Class

FormDesignerWinFormsLicenseProvider Class
Provides a license provider functionality for the FormDesignerControl.
Inheritance Hierarchy
SystemObject
System.ComponentModelLicenseProvider
ComponentLicenseProvider
Alternet.FormDesigner.WinForms.LicenseFormDesignerWinFormsLicenseProvider

Namespace: Alternet.FormDesigner.WinForms.License
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormDesignerWinFormsLicenseProvider : ComponentLicenseProvider
Public Class FormDesignerWinFormsLicenseProvider
    Inherits ComponentLicenseProvider
public ref class FormDesignerWinFormsLicenseProvider : public ComponentLicenseProvider
type FormDesignerWinFormsLicenseProvider =
    class
        inherit ComponentLicenseProvider
    end

The FormDesignerWinFormsLicenseProvider type exposes the following members.

Constructors
 | Name | Description
Public method | FormDesignerWinFormsLicenseProvider | Initializes a new instance of the FormDesignerWinFormsLicenseProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLicense | When overridden in a derived class, gets a license for an instance or type of component, when given a context and whether the denial of a license throws an exception. (Inherited from LicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.License Namespace


FormDesignerWinFormsLicenseProvider Constructor

FormDesignerWinFormsLicenseProvider Constructor
Initializes a new instance of the FormDesignerWinFormsLicenseProvider class

Namespace: Alternet.FormDesigner.WinForms.License
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormDesignerWinFormsLicenseProvider()
Public Sub New
public:
FormDesignerWinFormsLicenseProvider()
new : unit -> FormDesignerWinFormsLicenseProvider
See Also

Reference

FormDesignerWinFormsLicenseProvider Class
Alternet.FormDesigner.WinForms.License Namespace


FormDesignerWinFormsLicenseProvider Methods

FormDesignerWinFormsLicenseProvider Methods

The FormDesignerWinFormsLicenseProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLicense | When overridden in a derived class, gets a license for an instance or type of component, when given a context and whether the denial of a license throws an exception. (Inherited from LicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormDesignerWinFormsLicenseProvider Class
Alternet.FormDesigner.WinForms.License Namespace


Alternet.FormDesigner.WinForms.Outline Namespace

Alternet.FormDesigner.WinForms.Outline Namespace
Classes
 | Class | Description
Public class | OutlineTreeNodePaintData |
Public class | VisualStudioOutlineControlPainter |
Interfaces
 | Interface | Description
Public interface | IOutlineControlPainter |
Enumerations
 | Enumeration | Description
Public enumeration | TreeNodePart |


IOutlineControlPainter Interface

IOutlineControlPainter Interface

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IOutlineControlPainter
Public Interface IOutlineControlPainter
public interface class IOutlineControlPainter
type IOutlineControlPainter =  interface end

The IOutlineControlPainter type exposes the following members.

Methods
 | Name | Description
Public method | GetNodeDropMarkerBounds |
Public method | NodeExpandButtonHitTest |
Public method | PaintTreeNode |
Top
Properties
 | Name | Description
Public property | BackgroundColor |
Public property | Font |
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Outline Namespace


IOutlineControlPainter Methods

IOutlineControlPainter Methods

The IOutlineControlPainter type exposes the following members.

Methods
 | Name | Description
Public method | GetNodeDropMarkerBounds |
Public method | NodeExpandButtonHitTest |
Public method | PaintTreeNode |
Top
See Also

Reference

IOutlineControlPainter Interface
Alternet.FormDesigner.WinForms.Outline Namespace


IOutlineControlPainter.GetNodeDropMarkerBounds Method

IOutlineControlPainterGetNodeDropMarkerBounds Method

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle GetNodeDropMarkerBounds(
    OutlineTreeNodePaintData data,
    int treeViewWidth
)
Function GetNodeDropMarkerBounds (
    data As OutlineTreeNodePaintData,
    treeViewWidth As Integer
) As Rectangle
Rectangle GetNodeDropMarkerBounds(
    OutlineTreeNodePaintData^ data,
    int treeViewWidth
)
abstract GetNodeDropMarkerBounds :
        data : OutlineTreeNodePaintData *
        treeViewWidth : int -> Rectangle

Parameters

data
Type: Alternet.FormDesigner.WinForms.OutlineOutlineTreeNodePaintData
treeViewWidth
Type: SystemInt32

Return Value

Type: Rectangle
See Also

Reference

IOutlineControlPainter Interface
Alternet.FormDesigner.WinForms.Outline Namespace


IOutlineControlPainter.NodeExpandButtonHitTest Method

IOutlineControlPainterNodeExpandButtonHitTest Method

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TreeNodePart NodeExpandButtonHitTest(
    int nodeNestingLevel,
    Point locationInNode
)
Function NodeExpandButtonHitTest (
    nodeNestingLevel As Integer,
    locationInNode As Point
) As TreeNodePart
TreeNodePart NodeExpandButtonHitTest(
    int nodeNestingLevel,
    Point locationInNode
)
abstract NodeExpandButtonHitTest :
        nodeNestingLevel : int *
        locationInNode : Point -> TreeNodePart

Parameters

nodeNestingLevel
Type: SystemInt32
locationInNode
Type: System.DrawingPoint

Return Value

Type: TreeNodePart
See Also

Reference

IOutlineControlPainter Interface
Alternet.FormDesigner.WinForms.Outline Namespace


IOutlineControlPainter.PaintTreeNode Method

IOutlineControlPainterPaintTreeNode Method

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintTreeNode(
    OutlineTreeNodePaintData data
)
Sub PaintTreeNode (
    data As OutlineTreeNodePaintData
)
void PaintTreeNode(
    OutlineTreeNodePaintData^ data
)
abstract PaintTreeNode :
        data : OutlineTreeNodePaintData -> unit

Parameters

data
Type: Alternet.FormDesigner.WinForms.OutlineOutlineTreeNodePaintData
See Also

Reference

IOutlineControlPainter Interface
Alternet.FormDesigner.WinForms.Outline Namespace


IOutlineControlPainter Properties

IOutlineControlPainter Properties

The IOutlineControlPainter type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor |
Public property | Font |
Top
See Also

Reference

IOutlineControlPainter Interface
Alternet.FormDesigner.WinForms.Outline Namespace


IOutlineControlPainter.BackgroundColor Property

IOutlineControlPainterBackgroundColor Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackgroundColor { get; }
ReadOnly Property BackgroundColor As Color
    Get
property Color BackgroundColor {
    Color get ();
}
abstract BackgroundColor : Color with get

Property Value

Type: Color
See Also

Reference

IOutlineControlPainter Interface
Alternet.FormDesigner.WinForms.Outline Namespace


IOutlineControlPainter.Font Property

IOutlineControlPainterFont Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Font Font { get; }
ReadOnly Property Font As Font
    Get
property Font^ Font {
    Font^ get ();
}
abstract Font : Font with get

Property Value

Type: Font
See Also

Reference

IOutlineControlPainter Interface
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData Class

OutlineTreeNodePaintData Class
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.OutlineOutlineTreeNodePaintData

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OutlineTreeNodePaintData
Public Class OutlineTreeNodePaintData
public ref class OutlineTreeNodePaintData
type OutlineTreeNodePaintData =  class end

The OutlineTreeNodePaintData type exposes the following members.

Constructors
 | Name | Description
Public method | OutlineTreeNodePaintData | Initializes a new instance of the OutlineTreeNodePaintData class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Component |
Public property | Graphics |
Public property | HasChildren |
Public property | Image |
Public property | IsEditing |
Public property | IsExpanded |
Public property | IsSelected |
Public property | NestingLevel |
Public property | NodeBounds |
Public property | Text |
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData Constructor

OutlineTreeNodePaintData Constructor
Initializes a new instance of the OutlineTreeNodePaintData class

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public OutlineTreeNodePaintData(
    Graphics graphics,
    Rectangle nodeBounds,
    bool isSelected,
    bool isExpanded,
    bool isEditing,
    IComponent component,
    string text,
    Image image,
    int nestingLevel,
    bool hasChildren
)
Public Sub New (
    graphics As Graphics,
    nodeBounds As Rectangle,
    isSelected As Boolean,
    isExpanded As Boolean,
    isEditing As Boolean,
    component As IComponent,
    text As String,
    image As Image,
    nestingLevel As Integer,
    hasChildren As Boolean
)
public:
OutlineTreeNodePaintData(
    Graphics^ graphics,
    Rectangle nodeBounds,
    bool isSelected,
    bool isExpanded,
    bool isEditing,
    IComponent^ component,
    String^ text,
    Image^ image,
    int nestingLevel,
    bool hasChildren
)
new :
        graphics : Graphics *
        nodeBounds : Rectangle *
        isSelected : bool *
        isExpanded : bool *
        isEditing : bool *
        component : IComponent *
        text : string *
        image : Image *
        nestingLevel : int *
        hasChildren : bool -> OutlineTreeNodePaintData

Parameters

graphics
Type: System.DrawingGraphics
nodeBounds
Type: System.DrawingRectangle
isSelected
Type: SystemBoolean
isExpanded
Type: SystemBoolean
isEditing
Type: SystemBoolean
component
Type: System.ComponentModelIComponent
text
Type: SystemString
image
Type: System.DrawingImage
nestingLevel
Type: SystemInt32
hasChildren
Type: SystemBoolean
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData Methods

OutlineTreeNodePaintData Methods

The OutlineTreeNodePaintData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData Properties

OutlineTreeNodePaintData Properties

The OutlineTreeNodePaintData type exposes the following members.

Properties
 | Name | Description
Public property | Component |
Public property | Graphics |
Public property | HasChildren |
Public property | Image |
Public property | IsEditing |
Public property | IsExpanded |
Public property | IsSelected |
Public property | NestingLevel |
Public property | NodeBounds |
Public property | Text |
Top
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.Component Property

OutlineTreeNodePaintDataComponent Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IComponent Component { get; }
Public ReadOnly Property Component As IComponent
    Get
public:
property IComponent^ Component {
    IComponent^ get ();
}
member Component : IComponent with get

Property Value

Type: IComponent
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.Graphics Property

OutlineTreeNodePaintDataGraphics Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Graphics Graphics { get; }
Public ReadOnly Property Graphics As Graphics
    Get
public:
property Graphics^ Graphics {
    Graphics^ get ();
}
member Graphics : Graphics with get

Property Value

Type: Graphics
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.HasChildren Property

OutlineTreeNodePaintDataHasChildren Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasChildren { get; }
Public ReadOnly Property HasChildren As Boolean
    Get
public:
property bool HasChildren {
    bool get ();
}
member HasChildren : bool with get

Property Value

Type: Boolean
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.Image Property

OutlineTreeNodePaintDataImage Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
property Image^ Image {
    Image^ get ();
}
member Image : Image with get

Property Value

Type: Image
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.IsEditing Property

OutlineTreeNodePaintDataIsEditing Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEditing { get; }
Public ReadOnly Property IsEditing As Boolean
    Get
public:
property bool IsEditing {
    bool get ();
}
member IsEditing : bool with get

Property Value

Type: Boolean
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.IsExpanded Property

OutlineTreeNodePaintDataIsExpanded Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExpanded { get; }
Public ReadOnly Property IsExpanded As Boolean
    Get
public:
property bool IsExpanded {
    bool get ();
}
member IsExpanded : bool with get

Property Value

Type: Boolean
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.IsSelected Property

OutlineTreeNodePaintDataIsSelected Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelected { get; }
Public ReadOnly Property IsSelected As Boolean
    Get
public:
property bool IsSelected {
    bool get ();
}
member IsSelected : bool with get

Property Value

Type: Boolean
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.NestingLevel Property

OutlineTreeNodePaintDataNestingLevel Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NestingLevel { get; }
Public ReadOnly Property NestingLevel As Integer
    Get
public:
property int NestingLevel {
    int get ();
}
member NestingLevel : int with get

Property Value

Type: Int32
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.NodeBounds Property

OutlineTreeNodePaintDataNodeBounds Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle NodeBounds { get; }
Public ReadOnly Property NodeBounds As Rectangle
    Get
public:
property Rectangle NodeBounds {
    Rectangle get ();
}
member NodeBounds : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


OutlineTreeNodePaintData.Text Property

OutlineTreeNodePaintDataText Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
member Text : string with get

Property Value

Type: String
See Also

Reference

OutlineTreeNodePaintData Class
Alternet.FormDesigner.WinForms.Outline Namespace


TreeNodePart Enumeration

TreeNodePart Enumeration

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TreeNodePart
Public Enumeration TreeNodePart
public enum class TreeNodePart
type TreeNodePart
Members
Member name | Value | Description
None | 0 |
ExpandButton | 1 |
See Also

Reference

Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter Class

VisualStudioOutlineControlPainter Class
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.OutlineVisualStudioOutlineControlPainter

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VisualStudioOutlineControlPainter : IOutlineControlPainter
Public Class VisualStudioOutlineControlPainter
    Implements IOutlineControlPainter
public ref class VisualStudioOutlineControlPainter : IOutlineControlPainter
type VisualStudioOutlineControlPainter =
    class
        interface IOutlineControlPainter
    end

The VisualStudioOutlineControlPainter type exposes the following members.

Constructors
 | Name | Description
Public method | VisualStudioOutlineControlPainter | Initializes a new instance of the VisualStudioOutlineControlPainter class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNodeDropMarkerBounds |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NodeExpandButtonHitTest |
Public method | PaintTreeNode |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BackgroundColor |
Public property | DropMarkerRightPadding |
Public property | ExpandButtonHitTestPadding |
Public property | Font |
Public property | ImageLeftPadding |
Public property | ImageRightPadding |
Public property | NestedNodeLeftPadding |
Public property | RootNodeLeftPadding |
Public property | SelectedBackgroundColor |
Public property | SelectedTextColor |
Public property | TextColor |
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter Constructor

VisualStudioOutlineControlPainter Constructor
Initializes a new instance of the VisualStudioOutlineControlPainter class

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualStudioOutlineControlPainter()
Public Sub New
public:
VisualStudioOutlineControlPainter()
new : unit -> VisualStudioOutlineControlPainter
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter Methods

VisualStudioOutlineControlPainter Methods

The VisualStudioOutlineControlPainter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNodeDropMarkerBounds |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NodeExpandButtonHitTest |
Public method | PaintTreeNode |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.GetNodeDropMarkerBounds Method

VisualStudioOutlineControlPainterGetNodeDropMarkerBounds Method

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle GetNodeDropMarkerBounds(
    OutlineTreeNodePaintData data,
    int treeViewWidth
)
Public Function GetNodeDropMarkerBounds (
    data As OutlineTreeNodePaintData,
    treeViewWidth As Integer
) As Rectangle
public:
virtual Rectangle GetNodeDropMarkerBounds(
    OutlineTreeNodePaintData^ data,
    int treeViewWidth
) sealed
abstract GetNodeDropMarkerBounds :
        data : OutlineTreeNodePaintData *
        treeViewWidth : int -> Rectangle
override GetNodeDropMarkerBounds :
        data : OutlineTreeNodePaintData *
        treeViewWidth : int -> Rectangle

Parameters

data
Type: Alternet.FormDesigner.WinForms.OutlineOutlineTreeNodePaintData
treeViewWidth
Type: SystemInt32

Return Value

Type: Rectangle

Implements

IOutlineControlPainterGetNodeDropMarkerBounds(OutlineTreeNodePaintData, Int32)
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.NodeExpandButtonHitTest Method

VisualStudioOutlineControlPainterNodeExpandButtonHitTest Method

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeNodePart NodeExpandButtonHitTest(
    int nodeNestingLevel,
    Point locationInNode
)
Public Function NodeExpandButtonHitTest (
    nodeNestingLevel As Integer,
    locationInNode As Point
) As TreeNodePart
public:
virtual TreeNodePart NodeExpandButtonHitTest(
    int nodeNestingLevel,
    Point locationInNode
) sealed
abstract NodeExpandButtonHitTest :
        nodeNestingLevel : int *
        locationInNode : Point -> TreeNodePart
override NodeExpandButtonHitTest :
        nodeNestingLevel : int *
        locationInNode : Point -> TreeNodePart

Parameters

nodeNestingLevel
Type: SystemInt32
locationInNode
Type: System.DrawingPoint

Return Value

Type: TreeNodePart

Implements

IOutlineControlPainterNodeExpandButtonHitTest(Int32, Point)
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.PaintTreeNode Method

VisualStudioOutlineControlPainterPaintTreeNode Method

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PaintTreeNode(
    OutlineTreeNodePaintData data
)
Public Sub PaintTreeNode (
    data As OutlineTreeNodePaintData
)
public:
virtual void PaintTreeNode(
    OutlineTreeNodePaintData^ data
) sealed
abstract PaintTreeNode :
        data : OutlineTreeNodePaintData -> unit
override PaintTreeNode :
        data : OutlineTreeNodePaintData -> unit

Parameters

data
Type: Alternet.FormDesigner.WinForms.OutlineOutlineTreeNodePaintData

Implements

IOutlineControlPainterPaintTreeNode(OutlineTreeNodePaintData)
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter Properties

VisualStudioOutlineControlPainter Properties

The VisualStudioOutlineControlPainter type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor |
Public property | DropMarkerRightPadding |
Public property | ExpandButtonHitTestPadding |
Public property | Font |
Public property | ImageLeftPadding |
Public property | ImageRightPadding |
Public property | NestedNodeLeftPadding |
Public property | RootNodeLeftPadding |
Public property | SelectedBackgroundColor |
Public property | SelectedTextColor |
Public property | TextColor |
Top
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.BackgroundColor Property

VisualStudioOutlineControlPainterBackgroundColor Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BackgroundColor { get; }
Public ReadOnly Property BackgroundColor As Color
    Get
public:
virtual property Color BackgroundColor {
    Color get () sealed;
}
abstract BackgroundColor : Color with get
override BackgroundColor : Color with get

Property Value

Type: Color

Implements

IOutlineControlPainterBackgroundColor
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.DropMarkerRightPadding Property

VisualStudioOutlineControlPainterDropMarkerRightPadding Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DropMarkerRightPadding { get; }
Public ReadOnly Property DropMarkerRightPadding As Integer
    Get
public:
property int DropMarkerRightPadding {
    int get ();
}
member DropMarkerRightPadding : int with get

Property Value

Type: Int32
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.ExpandButtonHitTestPadding Property

VisualStudioOutlineControlPainterExpandButtonHitTestPadding Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ExpandButtonHitTestPadding { get; }
Public ReadOnly Property ExpandButtonHitTestPadding As Integer
    Get
public:
property int ExpandButtonHitTestPadding {
    int get ();
}
member ExpandButtonHitTestPadding : int with get

Property Value

Type: Int32
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.Font Property

VisualStudioOutlineControlPainterFont Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Font Font { get; }
Public ReadOnly Property Font As Font
    Get
public:
virtual property Font^ Font {
    Font^ get () sealed;
}
abstract Font : Font with get
override Font : Font with get

Property Value

Type: Font

Implements

IOutlineControlPainterFont
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.ImageLeftPadding Property

VisualStudioOutlineControlPainterImageLeftPadding Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ImageLeftPadding { get; }
Public ReadOnly Property ImageLeftPadding As Integer
    Get
public:
property int ImageLeftPadding {
    int get ();
}
member ImageLeftPadding : int with get

Property Value

Type: Int32
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.ImageRightPadding Property

VisualStudioOutlineControlPainterImageRightPadding Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ImageRightPadding { get; }
Public ReadOnly Property ImageRightPadding As Integer
    Get
public:
property int ImageRightPadding {
    int get ();
}
member ImageRightPadding : int with get

Property Value

Type: Int32
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.NestedNodeLeftPadding Property

VisualStudioOutlineControlPainterNestedNodeLeftPadding Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NestedNodeLeftPadding { get; }
Public ReadOnly Property NestedNodeLeftPadding As Integer
    Get
public:
property int NestedNodeLeftPadding {
    int get ();
}
member NestedNodeLeftPadding : int with get

Property Value

Type: Int32
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.RootNodeLeftPadding Property

VisualStudioOutlineControlPainterRootNodeLeftPadding Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RootNodeLeftPadding { get; }
Public ReadOnly Property RootNodeLeftPadding As Integer
    Get
public:
property int RootNodeLeftPadding {
    int get ();
}
member RootNodeLeftPadding : int with get

Property Value

Type: Int32
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.SelectedBackgroundColor Property

VisualStudioOutlineControlPainterSelectedBackgroundColor Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SelectedBackgroundColor { get; }
Public ReadOnly Property SelectedBackgroundColor As Color
    Get
public:
property Color SelectedBackgroundColor {
    Color get ();
}
member SelectedBackgroundColor : Color with get

Property Value

Type: Color
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.SelectedTextColor Property

VisualStudioOutlineControlPainterSelectedTextColor Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SelectedTextColor { get; }
Public ReadOnly Property SelectedTextColor As Color
    Get
public:
property Color SelectedTextColor {
    Color get ();
}
member SelectedTextColor : Color with get

Property Value

Type: Color
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


VisualStudioOutlineControlPainter.TextColor Property

VisualStudioOutlineControlPainterTextColor Property

Namespace: Alternet.FormDesigner.WinForms.Outline
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color TextColor { get; }
Public ReadOnly Property TextColor As Color
    Get
public:
property Color TextColor {
    Color get ();
}
member TextColor : Color with get

Property Value

Type: Color
See Also

Reference

VisualStudioOutlineControlPainter Class
Alternet.FormDesigner.WinForms.Outline Namespace


Alternet.FormDesigner.WinForms.PropertyGrid Namespace

Alternet.FormDesigner.WinForms.PropertyGrid Namespace
Classes
 | Class | Description
Public class | PreFilterPropertiesEventArgs |


PreFilterPropertiesEventArgs Class

PreFilterPropertiesEventArgs Class
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.FormDesigner.WinForms.PropertyGridPreFilterPropertiesEventArgs

Namespace: Alternet.FormDesigner.WinForms.PropertyGrid
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PreFilterPropertiesEventArgs : EventArgs
Public Class PreFilterPropertiesEventArgs
    Inherits EventArgs
public ref class PreFilterPropertiesEventArgs : public EventArgs
type PreFilterPropertiesEventArgs =
    class
        inherit EventArgs
    end

The PreFilterPropertiesEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PreFilterPropertiesEventArgs | Initializes a new instance of the PreFilterPropertiesEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsExcluded |
Public property | Property |
Top
See Also

Reference

Alternet.FormDesigner.WinForms.PropertyGrid Namespace


PreFilterPropertiesEventArgs Constructor

PreFilterPropertiesEventArgs Constructor
Initializes a new instance of the PreFilterPropertiesEventArgs class

Namespace: Alternet.FormDesigner.WinForms.PropertyGrid
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PreFilterPropertiesEventArgs(
    PropertyDescriptor property
)
Public Sub New (
    property As PropertyDescriptor
)
public:
PreFilterPropertiesEventArgs(
    PropertyDescriptor^ property
)
new :
        property : PropertyDescriptor -> PreFilterPropertiesEventArgs

Parameters

property
Type: System.ComponentModelPropertyDescriptor
See Also

Reference

PreFilterPropertiesEventArgs Class
Alternet.FormDesigner.WinForms.PropertyGrid Namespace


PreFilterPropertiesEventArgs Methods

PreFilterPropertiesEventArgs Methods

The PreFilterPropertiesEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PreFilterPropertiesEventArgs Class
Alternet.FormDesigner.WinForms.PropertyGrid Namespace


PreFilterPropertiesEventArgs Properties

PreFilterPropertiesEventArgs Properties

The PreFilterPropertiesEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsExcluded |
Public property | Property |
Top
See Also

Reference

PreFilterPropertiesEventArgs Class
Alternet.FormDesigner.WinForms.PropertyGrid Namespace


PreFilterPropertiesEventArgs.IsExcluded Property

PreFilterPropertiesEventArgsIsExcluded Property

Namespace: Alternet.FormDesigner.WinForms.PropertyGrid
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExcluded { get; set; }
Public Property IsExcluded As Boolean
    Get
    Set
public:
property bool IsExcluded {
    bool get ();
    void set (bool value);
}
member IsExcluded : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PreFilterPropertiesEventArgs Class
Alternet.FormDesigner.WinForms.PropertyGrid Namespace


PreFilterPropertiesEventArgs.Property Property

PreFilterPropertiesEventArgsProperty Property

Namespace: Alternet.FormDesigner.WinForms.PropertyGrid
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyDescriptor Property { get; }
Public ReadOnly Property Property As PropertyDescriptor
    Get
public:
property PropertyDescriptor^ Property {
    PropertyDescriptor^ get ();
}
member Property : PropertyDescriptor with get

Property Value

Type: PropertyDescriptor
See Also

Reference

PreFilterPropertiesEventArgs Class
Alternet.FormDesigner.WinForms.PropertyGrid Namespace


Alternet.FormDesigner.WinForms.Toolbox Namespace

Alternet.FormDesigner.WinForms.Toolbox Namespace
Classes
 | Class | Description
Public class | ToolboxCategoryHeaderPaintData | Provides data to paint toolbox category header.
Public class | ToolboxCategoryItemsListBox | Provides ListBox holds a collection of elements for toolbox category.
Public class | ToolboxCategoryItemsListBoxToolboxItemWithVisibility |
Public class | ToolboxConsts |
Public class | ToolboxContentControl | Provides a container for the toolbox content which is a collection of category.
Public class | ToolboxContextMenu | Implements a toolbox context menu.
Public class | ToolboxItemPaintData | Provides data to paint toolbox item.
Public class | ToolboxPaintBaseData | Provides base data to paint toolbox item.
Public class | ToolboxSearchButton |
Public class | ToolboxSearchControl |
Public class | ToolboxSearchTextBox |
Public class | ToolboxSerialization | Implements Load and Save logic for toolbox.
Public class | ToolboxSerializationLoadedCategory | Contains information about toolbox category.
Public class | ToolboxSerializationLoadedCategoryItem | Contains information about toolbox item.
Public class | ToolboxStandardItems | Provides a collection of the standard toolbox items.
Interfaces
 | Interface | Description
Public interface | IToolboxContentControlSite | Provides an interface to manipulate toolbox content.
Public interface | IToolboxPainter | Provides an interface to draw toolbox item.
Public interface | ToolboxSearchButtonISite |
Enumerations
 | Enumeration | Description
Public enumeration | ToolboxItemPaintState | Defines state of the painted toolbox item.
Public enumeration | ToolboxSearchButtonImage |


IToolboxContentControlSite Interface

IToolboxContentControlSite Interface
Provides an interface to manipulate toolbox content.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IToolboxContentControlSite
Public Interface IToolboxContentControlSite
public interface class IToolboxContentControlSite
type IToolboxContentControlSite =  interface end

The IToolboxContentControlSite type exposes the following members.

Methods
 | Name | Description
Public method | OnContentPreferredSizeChanged | When implemented by a class, adjusts the specified child control into view on an auto-scroll enabled control.
Public method | PlaceItemAtDefaultLocation | When implemented by a class, forces designer instance to select the specified item.
Public method | SerializeItemForDragAndDrop | When implemented by a class, gets a serializable object for drag and drop operations that represents the specified toolbox item.
Top
Properties
 | Name | Description
Public property | CategoryExpandToggleByMouseAllowed | When implemented by a class, indicates whether category can be expanded or collapsed by mouse.
Public property | Painter | When implemented by a class, provides an interface to draw toolbox item.
Public property | ToolboxControl | When implemented by a class, provides an interface to display and manipulate list of icons for components and controls that user can place onto design surface.
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxContentControlSite Methods

IToolboxContentControlSite Methods

The IToolboxContentControlSite type exposes the following members.

Methods
 | Name | Description
Public method | OnContentPreferredSizeChanged | When implemented by a class, adjusts the specified child control into view on an auto-scroll enabled control.
Public method | PlaceItemAtDefaultLocation | When implemented by a class, forces designer instance to select the specified item.
Public method | SerializeItemForDragAndDrop | When implemented by a class, gets a serializable object for drag and drop operations that represents the specified toolbox item.
Top
See Also

Reference

IToolboxContentControlSite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxContentControlSite.OnContentPreferredSizeChanged Method

IToolboxContentControlSiteOnContentPreferredSizeChanged Method
When implemented by a class, adjusts the specified child control into view on an auto-scroll enabled control.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnContentPreferredSizeChanged(
    Control controlToScrollTo,
    int vertialOffset
)
Sub OnContentPreferredSizeChanged (
    controlToScrollTo As Control,
    vertialOffset As Integer
)
void OnContentPreferredSizeChanged(
    Control^ controlToScrollTo,
    int vertialOffset
)
abstract OnContentPreferredSizeChanged :
        controlToScrollTo : Control *
        vertialOffset : int -> unit

Parameters

controlToScrollTo
Type: System.Windows.FormsControl
The child control to adjust.
vertialOffset
Type: SystemInt32
Vertical offset.
See Also

Reference

IToolboxContentControlSite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxContentControlSite.PlaceItemAtDefaultLocation Method

IToolboxContentControlSitePlaceItemAtDefaultLocation Method
When implemented by a class, forces designer instance to select the specified item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PlaceItemAtDefaultLocation(
    ToolboxItem item
)
Sub PlaceItemAtDefaultLocation (
    item As ToolboxItem
)
void PlaceItemAtDefaultLocation(
    ToolboxItem^ item
)
abstract PlaceItemAtDefaultLocation :
        item : ToolboxItem -> unit

Parameters

item
Type: System.Drawing.DesignToolboxItem
The ToolboxItem to select.
See Also

Reference

IToolboxContentControlSite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxContentControlSite.SerializeItemForDragAndDrop Method

IToolboxContentControlSiteSerializeItemForDragAndDrop Method
When implemented by a class, gets a serializable object for drag and drop operations that represents the specified toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DataObject SerializeItemForDragAndDrop(
    ToolboxItem item
)
Function SerializeItemForDragAndDrop (
    item As ToolboxItem
) As DataObject
DataObject^ SerializeItemForDragAndDrop(
    ToolboxItem^ item
)
abstract SerializeItemForDragAndDrop :
        item : ToolboxItem -> DataObject

Parameters

item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to serialize.

Return Value

Type: DataObject
Serializable DataObject.
See Also

Reference

IToolboxContentControlSite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxContentControlSite Properties

IToolboxContentControlSite Properties

The IToolboxContentControlSite type exposes the following members.

Properties
 | Name | Description
Public property | CategoryExpandToggleByMouseAllowed | When implemented by a class, indicates whether category can be expanded or collapsed by mouse.
Public property | Painter | When implemented by a class, provides an interface to draw toolbox item.
Public property | ToolboxControl | When implemented by a class, provides an interface to display and manipulate list of icons for components and controls that user can place onto design surface.
Top
See Also

Reference

IToolboxContentControlSite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxContentControlSite.CategoryExpandToggleByMouseAllowed Property

IToolboxContentControlSiteCategoryExpandToggleByMouseAllowed Property
When implemented by a class, indicates whether category can be expanded or collapsed by mouse.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CategoryExpandToggleByMouseAllowed { get; }
ReadOnly Property CategoryExpandToggleByMouseAllowed As Boolean
    Get
property bool CategoryExpandToggleByMouseAllowed {
    bool get ();
}
abstract CategoryExpandToggleByMouseAllowed : bool with get

Property Value

Type: Boolean
See Also

Reference

IToolboxContentControlSite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxContentControlSite.Painter Property

IToolboxContentControlSitePainter Property
When implemented by a class, provides an interface to draw toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IToolboxPainter Painter { get; }
ReadOnly Property Painter As IToolboxPainter
    Get
property IToolboxPainter^ Painter {
    IToolboxPainter^ get ();
}
abstract Painter : IToolboxPainter with get

Property Value

Type: IToolboxPainter
See Also

Reference

IToolboxContentControlSite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxContentControlSite.ToolboxControl Property

IToolboxContentControlSiteToolboxControl Property
When implemented by a class, provides an interface to display and manipulate list of icons for components and controls that user can place onto design surface.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IToolboxControl ToolboxControl { get; }
ReadOnly Property ToolboxControl As IToolboxControl
    Get
property IToolboxControl^ ToolboxControl {
    IToolboxControl^ get ();
}
abstract ToolboxControl : IToolboxControl with get

Property Value

Type: IToolboxControl
See Also

Reference

IToolboxContentControlSite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter Interface

IToolboxPainter Interface
Provides an interface to draw toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IToolboxPainter
Public Interface IToolboxPainter
public interface class IToolboxPainter
type IToolboxPainter =  interface end

The IToolboxPainter type exposes the following members.

Methods
 | Name | Description
Public method | GetCategoryHeaderHeight | When implemented by a class, returns height of given category's header.
Public method | GetItemHeight | When implemented by a class, returns height of given item.
Public method | GetSearchTextBoxColors |
Public method | PaintCategoryHeader | When implemented by a class, draws specific category header.
Public method | PaintNoResultsFound |
Public method | PaintSearchButton |
Public method | PaintSearchControl |
Public method | PaintToolboxItem | When implemented by a class, draws specific item.
Top
Properties
 | Name | Description
Public property | BackgroundColor | When implemented by a class, gets the background color of the toolbox categories and items.
Public property | SearchButtonWidth |
Public property | SearchControlBorderThickness |
Public property | SearchControlHeight |
Public property | SearchTextBoxLeftPadding |
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter Methods

IToolboxPainter Methods

The IToolboxPainter type exposes the following members.

Methods
 | Name | Description
Public method | GetCategoryHeaderHeight | When implemented by a class, returns height of given category's header.
Public method | GetItemHeight | When implemented by a class, returns height of given item.
Public method | GetSearchTextBoxColors |
Public method | PaintCategoryHeader | When implemented by a class, draws specific category header.
Public method | PaintNoResultsFound |
Public method | PaintSearchButton |
Public method | PaintSearchControl |
Public method | PaintToolboxItem | When implemented by a class, draws specific item.
Top
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.GetCategoryHeaderHeight Method

IToolboxPainterGetCategoryHeaderHeight Method
When implemented by a class, returns height of given category's header.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetCategoryHeaderHeight(
    ToolboxCategoryHeaderPaintData data
)
Function GetCategoryHeaderHeight (
    data As ToolboxCategoryHeaderPaintData
) As Integer
int GetCategoryHeaderHeight(
    ToolboxCategoryHeaderPaintData^ data
)
abstract GetCategoryHeaderHeight :
        data : ToolboxCategoryHeaderPaintData -> int

Parameters

data
Type: Alternet.FormDesigner.WinForms.ToolboxToolboxCategoryHeaderPaintData
Category data to check.

Return Value

Type: Int32
Header's height.
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.GetItemHeight Method

IToolboxPainterGetItemHeight Method
When implemented by a class, returns height of given item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetItemHeight(
    ToolboxItemPaintData data
)
Function GetItemHeight (
    data As ToolboxItemPaintData
) As Integer
int GetItemHeight(
    ToolboxItemPaintData^ data
)
abstract GetItemHeight :
        data : ToolboxItemPaintData -> int

Parameters

data
Type: Alternet.FormDesigner.WinForms.ToolboxToolboxItemPaintData
Item data to check.

Return Value

Type: Int32
Item's height.
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.GetSearchTextBoxColors Method

IToolboxPainterGetSearchTextBoxColors Method

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetSearchTextBoxColors(
    ControlState state,
    out Color backgroundColor,
    out Color watermarkColor,
    out Color borderColor
)
Sub GetSearchTextBoxColors (
    state As ControlState,
    <OutAttribute> ByRef backgroundColor As Color,
    <OutAttribute> ByRef watermarkColor As Color,
    <OutAttribute> ByRef borderColor As Color
)
void GetSearchTextBoxColors(
    ControlState state,
    [OutAttribute] Color% backgroundColor,
    [OutAttribute] Color% watermarkColor,
    [OutAttribute] Color% borderColor
)
abstract GetSearchTextBoxColors :
        state : ControlState *
        backgroundColor : Color byref *
        watermarkColor : Color byref *
        borderColor : Color byref -> unit

Parameters

state
Type: Alternet.CommonControlState
backgroundColor
Type: System.DrawingColor
watermarkColor
Type: System.DrawingColor
borderColor
Type: System.DrawingColor
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.PaintCategoryHeader Method

IToolboxPainterPaintCategoryHeader Method
When implemented by a class, draws specific category header.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintCategoryHeader(
    ToolboxCategoryHeaderPaintData data
)
Sub PaintCategoryHeader (
    data As ToolboxCategoryHeaderPaintData
)
void PaintCategoryHeader(
    ToolboxCategoryHeaderPaintData^ data
)
abstract PaintCategoryHeader :
        data : ToolboxCategoryHeaderPaintData -> unit

Parameters

data
Type: Alternet.FormDesigner.WinForms.ToolboxToolboxCategoryHeaderPaintData
Specifies header's data to paint.
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.PaintNoResultsFound Method

IToolboxPainterPaintNoResultsFound Method

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintNoResultsFound(
    Graphics graphics,
    Rectangle bounds,
    Font font
)
Sub PaintNoResultsFound (
    graphics As Graphics,
    bounds As Rectangle,
    font As Font
)
void PaintNoResultsFound(
    Graphics^ graphics,
    Rectangle bounds,
    Font^ font
)
abstract PaintNoResultsFound :
        graphics : Graphics *
        bounds : Rectangle *
        font : Font -> unit

Parameters

graphics
Type: System.DrawingGraphics
bounds
Type: System.DrawingRectangle
font
Type: System.DrawingFont
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.PaintSearchButton Method

IToolboxPainterPaintSearchButton Method

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintSearchButton(
    Graphics graphics,
    Rectangle bounds,
    ControlState state,
    ToolboxSearchButtonImage image
)
Sub PaintSearchButton (
    graphics As Graphics,
    bounds As Rectangle,
    state As ControlState,
    image As ToolboxSearchButtonImage
)
void PaintSearchButton(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState state,
    ToolboxSearchButtonImage image
)
abstract PaintSearchButton :
        graphics : Graphics *
        bounds : Rectangle *
        state : ControlState *
        image : ToolboxSearchButtonImage -> unit

Parameters

graphics
Type: System.DrawingGraphics
bounds
Type: System.DrawingRectangle
state
Type: Alternet.CommonControlState
image
Type: Alternet.FormDesigner.WinForms.ToolboxToolboxSearchButtonImage
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.PaintSearchControl Method

IToolboxPainterPaintSearchControl Method

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintSearchControl(
    Graphics graphics,
    Rectangle bounds,
    ControlState state
)
Sub PaintSearchControl (
    graphics As Graphics,
    bounds As Rectangle,
    state As ControlState
)
void PaintSearchControl(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState state
)
abstract PaintSearchControl :
        graphics : Graphics *
        bounds : Rectangle *
        state : ControlState -> unit

Parameters

graphics
Type: System.DrawingGraphics
bounds
Type: System.DrawingRectangle
state
Type: Alternet.CommonControlState
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.PaintToolboxItem Method

IToolboxPainterPaintToolboxItem Method
When implemented by a class, draws specific item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PaintToolboxItem(
    ToolboxItemPaintData data
)
Sub PaintToolboxItem (
    data As ToolboxItemPaintData
)
void PaintToolboxItem(
    ToolboxItemPaintData^ data
)
abstract PaintToolboxItem :
        data : ToolboxItemPaintData -> unit

Parameters

data
Type: Alternet.FormDesigner.WinForms.ToolboxToolboxItemPaintData
Specifies item's data to paint.
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter Properties

IToolboxPainter Properties

The IToolboxPainter type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | When implemented by a class, gets the background color of the toolbox categories and items.
Public property | SearchButtonWidth |
Public property | SearchControlBorderThickness |
Public property | SearchControlHeight |
Public property | SearchTextBoxLeftPadding |
Top
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.BackgroundColor Property

IToolboxPainterBackgroundColor Property
When implemented by a class, gets the background color of the toolbox categories and items.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackgroundColor { get; }
ReadOnly Property BackgroundColor As Color
    Get
property Color BackgroundColor {
    Color get ();
}
abstract BackgroundColor : Color with get

Property Value

Type: Color
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.SearchButtonWidth Property

IToolboxPainterSearchButtonWidth Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SearchButtonWidth { get; }
ReadOnly Property SearchButtonWidth As Integer
    Get
property int SearchButtonWidth {
    int get ();
}
abstract SearchButtonWidth : int with get

Property Value

Type: Int32
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.SearchControlBorderThickness Property

IToolboxPainterSearchControlBorderThickness Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SearchControlBorderThickness { get; }
ReadOnly Property SearchControlBorderThickness As Integer
    Get
property int SearchControlBorderThickness {
    int get ();
}
abstract SearchControlBorderThickness : int with get

Property Value

Type: Int32
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.SearchControlHeight Property

IToolboxPainterSearchControlHeight Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SearchControlHeight { get; }
ReadOnly Property SearchControlHeight As Integer
    Get
property int SearchControlHeight {
    int get ();
}
abstract SearchControlHeight : int with get

Property Value

Type: Int32
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


IToolboxPainter.SearchTextBoxLeftPadding Property

IToolboxPainterSearchTextBoxLeftPadding Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SearchTextBoxLeftPadding { get; }
ReadOnly Property SearchTextBoxLeftPadding As Integer
    Get
property int SearchTextBoxLeftPadding {
    int get ();
}
abstract SearchTextBoxLeftPadding : int with get

Property Value

Type: Int32
See Also

Reference

IToolboxPainter Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryHeaderPaintData Class

ToolboxCategoryHeaderPaintData Class
Provides data to paint toolbox category header.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.ToolboxToolboxPaintBaseData
Alternet.FormDesigner.WinForms.ToolboxToolboxCategoryHeaderPaintData

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxCategoryHeaderPaintData : ToolboxPaintBaseData
Public Class ToolboxCategoryHeaderPaintData
    Inherits ToolboxPaintBaseData
public ref class ToolboxCategoryHeaderPaintData : public ToolboxPaintBaseData
type ToolboxCategoryHeaderPaintData =
    class
        inherit ToolboxPaintBaseData
    end

The ToolboxCategoryHeaderPaintData type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxCategoryHeaderPaintData | Initializes a new instance of the ToolboxCategoryHeaderPaintData class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets a size and location of the toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | CategoryName | Gets or sets name of the category.
Public property | Font | Gets or sets the font of the text displayed by the toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | Graphics | Gets or sets the graphics used to paint toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | IsCollapsed | Gets or sets collapsed state of the category.
Public property | IsSelected | Gets or sets a boolean value indicating whether toolbox item is selected. (Inherited from ToolboxPaintBaseData.)
Public property | State | Gets or sets state of the toolbox item. (Inherited from ToolboxPaintBaseData.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryHeaderPaintData Constructor

ToolboxCategoryHeaderPaintData Constructor
Initializes a new instance of the ToolboxCategoryHeaderPaintData class

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxCategoryHeaderPaintData()
Public Sub New
public:
ToolboxCategoryHeaderPaintData()
new : unit -> ToolboxCategoryHeaderPaintData
See Also

Reference

ToolboxCategoryHeaderPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryHeaderPaintData Methods

ToolboxCategoryHeaderPaintData Methods

The ToolboxCategoryHeaderPaintData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToolboxCategoryHeaderPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryHeaderPaintData Properties

ToolboxCategoryHeaderPaintData Properties

The ToolboxCategoryHeaderPaintData type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets a size and location of the toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | CategoryName | Gets or sets name of the category.
Public property | Font | Gets or sets the font of the text displayed by the toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | Graphics | Gets or sets the graphics used to paint toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | IsCollapsed | Gets or sets collapsed state of the category.
Public property | IsSelected | Gets or sets a boolean value indicating whether toolbox item is selected. (Inherited from ToolboxPaintBaseData.)
Public property | State | Gets or sets state of the toolbox item. (Inherited from ToolboxPaintBaseData.)
Top
See Also

Reference

ToolboxCategoryHeaderPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryHeaderPaintData.CategoryName Property

ToolboxCategoryHeaderPaintDataCategoryName Property
Gets or sets name of the category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CategoryName { get; set; }
Public Property CategoryName As String
    Get
    Set
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}
member CategoryName : string with get, set

Property Value

Type: String
See Also

Reference

ToolboxCategoryHeaderPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryHeaderPaintData.IsCollapsed Property

ToolboxCategoryHeaderPaintDataIsCollapsed Property
Gets or sets collapsed state of the category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCollapsed { get; set; }
Public Property IsCollapsed As Boolean
    Get
    Set
public:
property bool IsCollapsed {
    bool get ();
    void set (bool value);
}
member IsCollapsed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ToolboxCategoryHeaderPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox Class

ToolboxCategoryItemsListBox Class
Provides ListBox holds a collection of elements for toolbox category.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsListBox
Alternet.CommonFlickerFreeListBox
Alternet.FormDesigner.WinForms.ToolboxToolboxCategoryItemsListBox

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxCategoryItemsListBox : FlickerFreeListBox
Public Class ToolboxCategoryItemsListBox
    Inherits FlickerFreeListBox
public ref class ToolboxCategoryItemsListBox : public FlickerFreeListBox
type ToolboxCategoryItemsListBox =
    class
        inherit FlickerFreeListBox
    end

The ToolboxCategoryItemsListBox type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxCategoryItemsListBox | Initializes a new instance of the ToolboxCategoryItemsListBox class with specified settings.
Top
Methods
 | Name | Description
Public method | AddItem | Adds an item to the list of items for a list box.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearItems | Removes all items from the collection.
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DoesItemExist(ToolboxItem) | Indicates whether specified item is a member of the collection.
Public method | DoesItemExist(String) | Indicates whether specified item is a member of the collection.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | (Overrides ControlGetPreferredSize(Size).)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertItem | Inserts an item into the list box at the specified index.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | RemoveItem | Removes the specified item from the collection.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectItem | Selects the specified item in a list box.
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetItemsVisibility |
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CategoryName | Gets or sets name of category.
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | Items | Gets the items of the ListBox. (Inherited from ListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | ToolboxItems | Gets the toolbox items of the ToolboxCategoryItemsListBox.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox Constructor

ToolboxCategoryItemsListBox Constructor
Initializes a new instance of the ToolboxCategoryItemsListBox class with specified settings.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxCategoryItemsListBox(
    ToolboxContentControl contentControl,
    string categoryName
)
Public Sub New (
    contentControl As ToolboxContentControl,
    categoryName As String
)
public:
ToolboxCategoryItemsListBox(
    ToolboxContentControl^ contentControl,
    String^ categoryName
)
new :
        contentControl : ToolboxContentControl *
        categoryName : string -> ToolboxCategoryItemsListBox

Parameters

contentControl
Type: Alternet.FormDesigner.WinForms.ToolboxToolboxContentControl
ToolboxContentControl that holds list box content.
categoryName
Type: SystemString
Name of category.
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox Methods

ToolboxCategoryItemsListBox Methods

The ToolboxCategoryItemsListBox type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds an item to the list of items for a list box.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearItems | Removes all items from the collection.
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DoesItemExist(ToolboxItem) | Indicates whether specified item is a member of the collection.
Public method | DoesItemExist(String) | Indicates whether specified item is a member of the collection.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | (Overrides ControlGetPreferredSize(Size).)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertItem | Inserts an item into the list box at the specified index.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | RemoveItem | Removes the specified item from the collection.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectItem | Selects the specified item in a list box.
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetItemsVisibility |
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.AddItem Method

ToolboxCategoryItemsListBoxAddItem Method
Adds an item to the list of items for a list box.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddItem(
    ToolboxItem item
)
Public Sub AddItem (
    item As ToolboxItem
)
public:
void AddItem(
    ToolboxItem^ item
)
member AddItem :
        item : ToolboxItem -> unit

Parameters

item
Type: System.Drawing.DesignToolboxItem
A ToolboxItem representing the item to add to the collection.
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.ClearItems Method

ToolboxCategoryItemsListBoxClearItems Method
Removes all items from the collection.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearItems()
Public Sub ClearItems
public:
void ClearItems()
member ClearItems : unit -> unit
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.DoesItemExist Method

ToolboxCategoryItemsListBoxDoesItemExist Method
Overload List
 | Name | Description
Public method | DoesItemExist(ToolboxItem) | Indicates whether specified item is a member of the collection.
Public method | DoesItemExist(String) | Indicates whether specified item is a member of the collection.
Top
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.DoesItemExist Method (ToolboxItem)

ToolboxCategoryItemsListBoxDoesItemExist Method (ToolboxItem)
Indicates whether specified item is a member of the collection.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoesItemExist(
    ToolboxItem item
)
Public Function DoesItemExist (
    item As ToolboxItem
) As Boolean
public:
bool DoesItemExist(
    ToolboxItem^ item
)
member DoesItemExist :
        item : ToolboxItem -> bool

Parameters

item
Type: System.Drawing.DesignToolboxItem
A ToolboxItem representing the item to locate in the collection.

Return Value

Type: Boolean
TTrue if exists; otherwise false.
See Also

Reference

ToolboxCategoryItemsListBox Class
DoesItemExist Overload
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.DoesItemExist Method (String)

ToolboxCategoryItemsListBoxDoesItemExist Method (String)
Indicates whether specified item is a member of the collection.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoesItemExist(
    string itemName
)
Public Function DoesItemExist (
    itemName As String
) As Boolean
public:
bool DoesItemExist(
    String^ itemName
)
member DoesItemExist :
        itemName : string -> bool

Parameters

itemName
Type: SystemString
Item name to locate in the collection.

Return Value

Type: Boolean
TTrue if exists; otherwise false.
See Also

Reference

ToolboxCategoryItemsListBox Class
DoesItemExist Overload
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.GetPreferredSize Method

ToolboxCategoryItemsListBoxGetPreferredSize Method

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Size GetPreferredSize(
    Size proposedSize
)
Public Overrides Function GetPreferredSize (
    proposedSize As Size
) As Size
public:
virtual Size GetPreferredSize(
    Size proposedSize
) override
abstract GetPreferredSize :
        proposedSize : Size -> Size
override GetPreferredSize :
        proposedSize : Size -> Size

Parameters

proposedSize
Type: System.DrawingSize

Return Value

Type: Size
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.InsertItem Method

ToolboxCategoryItemsListBoxInsertItem Method
Inserts an item into the list box at the specified index.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertItem(
    int index,
    ToolboxItem item
)
Public Sub InsertItem (
    index As Integer,
    item As ToolboxItem
)
public:
void InsertItem(
    int index,
    ToolboxItem^ item
)
member InsertItem :
        index : int *
        item : ToolboxItem -> unit

Parameters

index
Type: SystemInt32
The zero-based index location where the item is inserted.
item
Type: System.Drawing.DesignToolboxItem
A ToolboxItem representing the item to insert to the collection.
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.RemoveItem Method

ToolboxCategoryItemsListBoxRemoveItem Method
Removes the specified item from the collection.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveItem(
    ToolboxItem item
)
Public Sub RemoveItem (
    item As ToolboxItem
)
public:
void RemoveItem(
    ToolboxItem^ item
)
member RemoveItem :
        item : ToolboxItem -> unit

Parameters

item
Type: System.Drawing.DesignToolboxItem
A ToolboxItem representing the item to remove from the collection.
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.SelectItem Method

ToolboxCategoryItemsListBoxSelectItem Method
Selects the specified item in a list box.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectItem(
    ToolboxItem item
)
Public Sub SelectItem (
    item As ToolboxItem
)
public:
void SelectItem(
    ToolboxItem^ item
)
member SelectItem :
        item : ToolboxItem -> unit

Parameters

item
Type: System.Drawing.DesignToolboxItem
A ToolboxItem representing the item to select in the collection.
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.SetItemsVisibility Method

ToolboxCategoryItemsListBoxSetItemsVisibility Method

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetItemsVisibility(
    ToolboxCategoryItemsListBoxToolboxItemWithVisibility[] items
)
Public Sub SetItemsVisibility (
    items As ToolboxCategoryItemsListBoxToolboxItemWithVisibility()
)
public:
void SetItemsVisibility(
    array<ToolboxCategoryItemsListBoxToolboxItemWithVisibility^>^ items
)
member SetItemsVisibility :
        items : ToolboxCategoryItemsListBoxToolboxItemWithVisibility[] -> unit

Parameters

items
Type: Alternet.FormDesigner.WinForms.ToolboxToolboxCategoryItemsListBoxToolboxItemWithVisibility
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox Properties

ToolboxCategoryItemsListBox Properties

The ToolboxCategoryItemsListBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CategoryName | Gets or sets name of category.
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | Items | Gets the items of the ListBox. (Inherited from ListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | ToolboxItems | Gets the toolbox items of the ToolboxCategoryItemsListBox.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.CategoryName Property

ToolboxCategoryItemsListBoxCategoryName Property
Gets or sets name of category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CategoryName { get; set; }
Public Property CategoryName As String
    Get
    Set
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}
member CategoryName : string with get, set

Property Value

Type: String
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.ToolboxItems Property

ToolboxCategoryItemsListBoxToolboxItems Property
Gets the toolbox items of the ToolboxCategoryItemsListBox.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItem[] ToolboxItems { get; }
Public ReadOnly Property ToolboxItems As ToolboxItem()
    Get
public:
property array<ToolboxItem^>^ ToolboxItems {
    array<ToolboxItem^>^ get ();
}
member ToolboxItems : ToolboxItem[] with get

Property Value

Type: ToolboxItem
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox Events

ToolboxCategoryItemsListBox Events

The ToolboxCategoryItemsListBox type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ToolboxCategoryItemsListBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.ToolboxItemWithVisibility Class

ToolboxCategoryItemsListBoxToolboxItemWithVisibility Class
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.ToolboxToolboxCategoryItemsListBoxToolboxItemWithVisibility

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxItemWithVisibility
Public Class ToolboxItemWithVisibility
public ref class ToolboxItemWithVisibility
type ToolboxItemWithVisibility =  class end

The ToolboxCategoryItemsListBoxToolboxItemWithVisibility type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxCategoryItemsListBoxToolboxItemWithVisibility | Initializes a new instance of the ToolboxCategoryItemsListBoxToolboxItemWithVisibility class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Item |
Public property | Visible |
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.ToolboxItemWithVisibility Constructor

ToolboxCategoryItemsListBoxToolboxItemWithVisibility Constructor
Initializes a new instance of the ToolboxCategoryItemsListBoxToolboxItemWithVisibility class

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemWithVisibility(
    ToolboxItem item,
    bool visible
)
Public Sub New (
    item As ToolboxItem,
    visible As Boolean
)
public:
ToolboxItemWithVisibility(
    ToolboxItem^ item,
    bool visible
)
new :
        item : ToolboxItem *
        visible : bool -> ToolboxItemWithVisibility

Parameters

item
Type: System.Drawing.DesignToolboxItem
visible
Type: SystemBoolean
See Also

Reference

ToolboxCategoryItemsListBoxToolboxItemWithVisibility Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemWithVisibility Methods

ToolboxItemWithVisibility Methods

The ToolboxCategoryItemsListBoxToolboxItemWithVisibility type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToolboxCategoryItemsListBoxToolboxItemWithVisibility Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemWithVisibility Properties

ToolboxItemWithVisibility Properties

The ToolboxCategoryItemsListBoxToolboxItemWithVisibility type exposes the following members.

Properties
 | Name | Description
Public property | Item |
Public property | Visible |
Top
See Also

Reference

ToolboxCategoryItemsListBoxToolboxItemWithVisibility Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.ToolboxItemWithVisibility.Item Property

ToolboxCategoryItemsListBoxToolboxItemWithVisibilityItem Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItem Item { get; }
Public ReadOnly Property Item As ToolboxItem
    Get
public:
property ToolboxItem^ Item {
    ToolboxItem^ get ();
}
member Item : ToolboxItem with get

Property Value

Type: ToolboxItem
See Also

Reference

ToolboxCategoryItemsListBoxToolboxItemWithVisibility Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxCategoryItemsListBox.ToolboxItemWithVisibility.Visible Property

ToolboxCategoryItemsListBoxToolboxItemWithVisibilityVisible Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; }
Public ReadOnly Property Visible As Boolean
    Get
public:
property bool Visible {
    bool get ();
}
member Visible : bool with get

Property Value

Type: Boolean
See Also

Reference

ToolboxCategoryItemsListBoxToolboxItemWithVisibility Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxConsts Class

ToolboxConsts Class
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.ToolboxToolboxConsts

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ToolboxConsts
Public NotInheritable Class ToolboxConsts
public ref class ToolboxConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ToolboxConsts =  class end

The ToolboxConsts type exposes the following members.

Properties
Name | Description
NoResultsFound |
SearchTextBoxWatermark |
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxConsts Properties

ToolboxConsts Properties

The ToolboxConsts type exposes the following members.

Properties
Name | Description
NoResultsFound |
SearchTextBoxWatermark |
Top
See Also

Reference

ToolboxConsts Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxConsts.NoResultsFound Property

ToolboxConstsNoResultsFound Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NoResultsFound { get; set; }
Public Shared Property NoResultsFound As String
    Get
    Set
public:
static property String^ NoResultsFound {
    String^ get ();
    void set (String^ value);
}
static member NoResultsFound : string with get, set

Property Value

Type: String
See Also

Reference

ToolboxConsts Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxConsts.SearchTextBoxWatermark Property

ToolboxConstsSearchTextBoxWatermark Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SearchTextBoxWatermark { get; set; }
Public Shared Property SearchTextBoxWatermark As String
    Get
    Set
public:
static property String^ SearchTextBoxWatermark {
    String^ get ();
    void set (String^ value);
}
static member SearchTextBoxWatermark : string with get, set

Property Value

Type: String
See Also

Reference

ToolboxConsts Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl Class

ToolboxContentControl Class
Provides a container for the toolbox content which is a collection of category.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Alternet.FormDesigner.WinForms.ToolboxToolboxContentControl

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxContentControl : Panel
Public Class ToolboxContentControl
    Inherits Panel
public ref class ToolboxContentControl : public Panel
type ToolboxContentControl =
    class
        inherit Panel
    end

The ToolboxContentControl type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxContentControl | Initializes a new instance of the ToolboxContentControl class with specified site.
Top
Methods
 | Name | Description
Public method | AddCategory | Add new category to the collection.
Public method | AddItem | Adds an item to the list of items of specified category.
Public method | ApplySearchFilter |
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearItemsInCategory | Removes all items from the list of items of specified category.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DoesCategoryExist | Indicates whether specified category exists.
Public method | DoesItemExist(String, ToolboxItem) | Indicates whether specified item presents in specified category.
Public method | DoesItemExist(String, String) | Indicates whether specified item presents in specified category.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a category collection can be fitted. (Overrides ControlGetPreferredSize(Size).)
Public method | GetToolsFromCategory | Returns an array of ToolboxItem within specified category.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertCategory | Inserts new category to specified position.
Public method | InsertItem | Adds an item to the list of items of specified category into the specified position.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | IsCategoryCollapsed | Indicates whether specified category is in collapsed state.
Public method | MoveCategory | Changes position of category within collection.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveCategory | Removes specified category from the category collection.
Public method | RemoveItem | Removes specified item from the item collection of specified category.
Public method | RenameCategory | Renames category.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollToCategory | Scrolls control content to the specified category.
Public method | ScrollToItem | Scrolls control content to make visible specified item.
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetCategoryCollapsed | Set specified category to the collapsed\expanded state.
Public method | SetSelectedItem | Selects the specified item in the item collection of specified category.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllItems | Represents an array of all toolbox items in the container.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CategoryNames | Represents an array of category names.
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControlSite | Represents an object that manipulates toolbox content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedCategoryName | Returns name of currently selected category or selects category by it's name.
Public property | SelectedItem | Returns currently selected toolbox item.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl Constructor

ToolboxContentControl Constructor
Initializes a new instance of the ToolboxContentControl class with specified site.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxContentControl(
    IToolboxContentControlSite site
)
Public Sub New (
    site As IToolboxContentControlSite
)
public:
ToolboxContentControl(
    IToolboxContentControlSite^ site
)
new :
        site : IToolboxContentControlSite -> ToolboxContentControl

Parameters

site
Type: Alternet.FormDesigner.WinForms.ToolboxIToolboxContentControlSite
An object that manipulates toolbox content.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl Methods

ToolboxContentControl Methods

The ToolboxContentControl type exposes the following members.

Methods
 | Name | Description
Public method | AddCategory | Add new category to the collection.
Public method | AddItem | Adds an item to the list of items of specified category.
Public method | ApplySearchFilter |
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearItemsInCategory | Removes all items from the list of items of specified category.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DoesCategoryExist | Indicates whether specified category exists.
Public method | DoesItemExist(String, ToolboxItem) | Indicates whether specified item presents in specified category.
Public method | DoesItemExist(String, String) | Indicates whether specified item presents in specified category.
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a category collection can be fitted. (Overrides ControlGetPreferredSize(Size).)
Public method | GetToolsFromCategory | Returns an array of ToolboxItem within specified category.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertCategory | Inserts new category to specified position.
Public method | InsertItem | Adds an item to the list of items of specified category into the specified position.
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | IsCategoryCollapsed | Indicates whether specified category is in collapsed state.
Public method | MoveCategory | Changes position of category within collection.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveCategory | Removes specified category from the category collection.
Public method | RemoveItem | Removes specified item from the item collection of specified category.
Public method | RenameCategory | Renames category.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | ScrollToCategory | Scrolls control content to the specified category.
Public method | ScrollToItem | Scrolls control content to make visible specified item.
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetCategoryCollapsed | Set specified category to the collapsed\expanded state.
Public method | SetSelectedItem | Selects the specified item in the item collection of specified category.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.AddCategory Method

ToolboxContentControlAddCategory Method
Add new category to the collection.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCategory(
    string categoryName
)
Public Sub AddCategory (
    categoryName As String
)
public:
void AddCategory(
    String^ categoryName
)
member AddCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Name of category to add.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.AddItem Method

ToolboxContentControlAddItem Method
Adds an item to the list of items of specified category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddItem(
    string categoryName,
    ToolboxItem item
)
Public Sub AddItem (
    categoryName As String,
    item As ToolboxItem
)
public:
void AddItem(
    String^ categoryName,
    ToolboxItem^ item
)
member AddItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Name of category to add item.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to add.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.ApplySearchFilter Method

ToolboxContentControlApplySearchFilter Method

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplySearchFilter(
    string searchFilter
)
Public Sub ApplySearchFilter (
    searchFilter As String
)
public:
void ApplySearchFilter(
    String^ searchFilter
)
member ApplySearchFilter :
        searchFilter : string -> unit

Parameters

searchFilter
Type: SystemString
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.BeginUpdate Method

ToolboxContentControlBeginUpdate Method
Prevents object state updating until calling EndUpdate method.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BeginUpdate()
Public Sub BeginUpdate
public:
void BeginUpdate()
member BeginUpdate : unit -> unit
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.ClearItemsInCategory Method

ToolboxContentControlClearItemsInCategory Method
Removes all items from the list of items of specified category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearItemsInCategory(
    string categoryName
)
Public Sub ClearItemsInCategory (
    categoryName As String
)
public:
void ClearItemsInCategory(
    String^ categoryName
)
member ClearItemsInCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Name of category to clear.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.DoesCategoryExist Method

ToolboxContentControlDoesCategoryExist Method
Indicates whether specified category exists.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoesCategoryExist(
    string categoryName
)
Public Function DoesCategoryExist (
    categoryName As String
) As Boolean
public:
bool DoesCategoryExist(
    String^ categoryName
)
member DoesCategoryExist :
        categoryName : string -> bool

Parameters

categoryName
Type: SystemString
Name of category to check.

Return Value

Type: Boolean
True if exists; otherwise false.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.DoesItemExist Method

ToolboxContentControlDoesItemExist Method
Overload List
 | Name | Description
Public method | DoesItemExist(String, ToolboxItem) | Indicates whether specified item presents in specified category.
Public method | DoesItemExist(String, String) | Indicates whether specified item presents in specified category.
Top
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.DoesItemExist Method (String, ToolboxItem)

ToolboxContentControlDoesItemExist Method (String, ToolboxItem)
Indicates whether specified item presents in specified category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoesItemExist(
    string categoryName,
    ToolboxItem item
)
Public Function DoesItemExist (
    categoryName As String,
    item As ToolboxItem
) As Boolean
public:
bool DoesItemExist(
    String^ categoryName,
    ToolboxItem^ item
)
member DoesItemExist :
        categoryName : string *
        item : ToolboxItem -> bool

Parameters

categoryName
Type: SystemString
Name of category to check.
item
Type: System.Drawing.DesignToolboxItem
Item to check.

Return Value

Type: Boolean
True if exists; otherwise false.
See Also

Reference

ToolboxContentControl Class
DoesItemExist Overload
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.DoesItemExist Method (String, String)

ToolboxContentControlDoesItemExist Method (String, String)
Indicates whether specified item presents in specified category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoesItemExist(
    string categoryName,
    string itemName
)
Public Function DoesItemExist (
    categoryName As String,
    itemName As String
) As Boolean
public:
bool DoesItemExist(
    String^ categoryName,
    String^ itemName
)
member DoesItemExist :
        categoryName : string *
        itemName : string -> bool

Parameters

categoryName
Type: SystemString
Name of category to check.
itemName
Type: SystemString
Item name to check.

Return Value

Type: Boolean
True if exists; otherwise false.
See Also

Reference

ToolboxContentControl Class
DoesItemExist Overload
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.EndUpdate Method

ToolboxContentControlEndUpdate Method
Re-enables object state updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EndUpdate()
Public Sub EndUpdate
public:
void EndUpdate()
member EndUpdate : unit -> unit
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.GetPreferredSize Method

ToolboxContentControlGetPreferredSize Method
Retrieves the size of a rectangular area into which a category collection can be fitted.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Size GetPreferredSize(
    Size proposedSize
)
Public Overrides Function GetPreferredSize (
    proposedSize As Size
) As Size
public:
virtual Size GetPreferredSize(
    Size proposedSize
) override
abstract GetPreferredSize :
        proposedSize : Size -> Size
override GetPreferredSize :
        proposedSize : Size -> Size

Parameters

proposedSize
Type: System.DrawingSize
The custom-sized area for a control.

Return Value

Type: Size
An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.GetToolsFromCategory Method

ToolboxContentControlGetToolsFromCategory Method
Returns an array of ToolboxItem within specified category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItem[] GetToolsFromCategory(
    string categoryName
)
Public Function GetToolsFromCategory (
    categoryName As String
) As ToolboxItem()
public:
array<ToolboxItem^>^ GetToolsFromCategory(
    String^ categoryName
)
member GetToolsFromCategory :
        categoryName : string -> ToolboxItem[]

Parameters

categoryName
Type: SystemString
Name of category to check.

Return Value

Type: ToolboxItem
List of items belongs to category.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.InsertCategory Method

ToolboxContentControlInsertCategory Method
Inserts new category to specified position.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertCategory(
    int index,
    string categoryName
)
Public Sub InsertCategory (
    index As Integer,
    categoryName As String
)
public:
void InsertCategory(
    int index,
    String^ categoryName
)
member InsertCategory :
        index : int *
        categoryName : string -> unit

Parameters

index
Type: SystemInt32
Position to insert.
categoryName
Type: SystemString
Name of category to insert.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.InsertItem Method

ToolboxContentControlInsertItem Method
Adds an item to the list of items of specified category into the specified position.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertItem(
    int index,
    string categoryName,
    ToolboxItem item
)
Public Sub InsertItem (
    index As Integer,
    categoryName As String,
    item As ToolboxItem
)
public:
void InsertItem(
    int index,
    String^ categoryName,
    ToolboxItem^ item
)
member InsertItem :
        index : int *
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

index
Type: SystemInt32
Position to insert.
categoryName
Type: SystemString
Name of category to insert item.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to insert.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.IsCategoryCollapsed Method

ToolboxContentControlIsCategoryCollapsed Method
Indicates whether specified category is in collapsed state.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCategoryCollapsed(
    string categoryName
)
Public Function IsCategoryCollapsed (
    categoryName As String
) As Boolean
public:
bool IsCategoryCollapsed(
    String^ categoryName
)
member IsCategoryCollapsed :
        categoryName : string -> bool

Parameters

categoryName
Type: SystemString
Name of category to check.

Return Value

Type: Boolean
True if category collapsed; otherwise false.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.MoveCategory Method

ToolboxContentControlMoveCategory Method
Changes position of category within collection.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveCategory(
    string categoryName,
    int positionDifference
)
Public Sub MoveCategory (
    categoryName As String,
    positionDifference As Integer
)
public:
void MoveCategory(
    String^ categoryName,
    int positionDifference
)
member MoveCategory :
        categoryName : string *
        positionDifference : int -> unit

Parameters

categoryName
Type: SystemString
Name of category to move.
positionDifference
Type: SystemInt32
Difference between new and old index.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.RemoveCategory Method

ToolboxContentControlRemoveCategory Method
Removes specified category from the category collection.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCategory(
    string categoryName
)
Public Sub RemoveCategory (
    categoryName As String
)
public:
void RemoveCategory(
    String^ categoryName
)
member RemoveCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Name of category to remove.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.RemoveItem Method

ToolboxContentControlRemoveItem Method
Removes specified item from the item collection of specified category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveItem(
    string categoryName,
    ToolboxItem item
)
Public Sub RemoveItem (
    categoryName As String,
    item As ToolboxItem
)
public:
void RemoveItem(
    String^ categoryName,
    ToolboxItem^ item
)
member RemoveItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Name of category to remove it's item.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to remove.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.RenameCategory Method

ToolboxContentControlRenameCategory Method
Renames category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RenameCategory(
    string oldName,
    string newName
)
Public Sub RenameCategory (
    oldName As String,
    newName As String
)
public:
void RenameCategory(
    String^ oldName,
    String^ newName
)
member RenameCategory :
        oldName : string *
        newName : string -> unit

Parameters

oldName
Type: SystemString
Previous name of category.
newName
Type: SystemString
New name of category.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.ScrollToCategory Method

ToolboxContentControlScrollToCategory Method
Scrolls control content to the specified category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ScrollToCategory(
    string categoryName
)
Public Sub ScrollToCategory (
    categoryName As String
)
public:
void ScrollToCategory(
    String^ categoryName
)
member ScrollToCategory :
        categoryName : string -> unit

Parameters

categoryName
Type: SystemString
Name of category to make visible.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.ScrollToItem Method

ToolboxContentControlScrollToItem Method
Scrolls control content to make visible specified item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ScrollToItem(
    string categoryName,
    ToolboxItem item
)
Public Sub ScrollToItem (
    categoryName As String,
    item As ToolboxItem
)
public:
void ScrollToItem(
    String^ categoryName,
    ToolboxItem^ item
)
member ScrollToItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Name of category holds item.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to make visible.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.SetCategoryCollapsed Method

ToolboxContentControlSetCategoryCollapsed Method
Set specified category to the collapsed\expanded state.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCategoryCollapsed(
    string categoryName,
    bool collapsed
)
Public Sub SetCategoryCollapsed (
    categoryName As String,
    collapsed As Boolean
)
public:
void SetCategoryCollapsed(
    String^ categoryName,
    bool collapsed
)
member SetCategoryCollapsed :
        categoryName : string *
        collapsed : bool -> unit

Parameters

categoryName
Type: SystemString
name of category to collapse.
collapsed
Type: SystemBoolean
New collapsed state.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.SetSelectedItem Method

ToolboxContentControlSetSelectedItem Method
Selects the specified item in the item collection of specified category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSelectedItem(
    string categoryName,
    ToolboxItem item
)
Public Sub SetSelectedItem (
    categoryName As String,
    item As ToolboxItem
)
public:
void SetSelectedItem(
    String^ categoryName,
    ToolboxItem^ item
)
member SetSelectedItem :
        categoryName : string *
        item : ToolboxItem -> unit

Parameters

categoryName
Type: SystemString
Name of category to select item.
item
Type: System.Drawing.DesignToolboxItem
ToolboxItem to select.
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl Properties

ToolboxContentControl Properties

The ToolboxContentControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllItems | Represents an array of all toolbox items in the container.
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CategoryNames | Represents an array of category names.
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContentControlSite | Represents an object that manipulates toolbox content.
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedCategoryName | Returns name of currently selected category or selects category by it's name.
Public property | SelectedItem | Returns currently selected toolbox item.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.AllItems Property

ToolboxContentControlAllItems Property
Represents an array of all toolbox items in the container.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItem[] AllItems { get; }
Public ReadOnly Property AllItems As ToolboxItem()
    Get
public:
property array<ToolboxItem^>^ AllItems {
    array<ToolboxItem^>^ get ();
}
member AllItems : ToolboxItem[] with get

Property Value

Type: ToolboxItem
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.CategoryNames Property

ToolboxContentControlCategoryNames Property
Represents an array of category names.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] CategoryNames { get; }
Public ReadOnly Property CategoryNames As String()
    Get
public:
property array<String^>^ CategoryNames {
    array<String^>^ get ();
}
member CategoryNames : string[] with get

Property Value

Type: String
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.ContentControlSite Property

ToolboxContentControlContentControlSite Property
Represents an object that manipulates toolbox content.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IToolboxContentControlSite ContentControlSite { get; }
Public ReadOnly Property ContentControlSite As IToolboxContentControlSite
    Get
public:
property IToolboxContentControlSite^ ContentControlSite {
    IToolboxContentControlSite^ get ();
}
member ContentControlSite : IToolboxContentControlSite with get

Property Value

Type: IToolboxContentControlSite
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.SelectedCategoryName Property

ToolboxContentControlSelectedCategoryName Property
Returns name of currently selected category or selects category by it's name.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SelectedCategoryName { get; set; }
Public Property SelectedCategoryName As String
    Get
    Set
public:
property String^ SelectedCategoryName {
    String^ get ();
    void set (String^ value);
}
member SelectedCategoryName : string with get, set

Property Value

Type: String
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl.SelectedItem Property

ToolboxContentControlSelectedItem Property
Returns currently selected toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItem SelectedItem { get; }
Public ReadOnly Property SelectedItem As ToolboxItem
    Get
public:
property ToolboxItem^ SelectedItem {
    ToolboxItem^ get ();
}
member SelectedItem : ToolboxItem with get

Property Value

Type: ToolboxItem
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContentControl Events

ToolboxContentControl Events

The ToolboxContentControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ToolboxContentControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContextMenu Class

ToolboxContextMenu Class
Implements a toolbox context menu.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.FormDesigner.WinForms.ToolboxToolboxContextMenu

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxContextMenu : UserControl
Public Class ToolboxContextMenu
    Inherits UserControl
public ref class ToolboxContextMenu : public UserControl
type ToolboxContextMenu =
    class
        inherit UserControl
    end

The ToolboxContextMenu type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxContextMenu | Initializes a new instance of the ToolboxContextMenu class and associates it with the specified container.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowContextMenu | Shows the context menu at the specified location.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContextMenu Constructor

ToolboxContextMenu Constructor
Initializes a new instance of the ToolboxContextMenu class and associates it with the specified container.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxContextMenu(
    IToolboxControl toolboxControl
)
Public Sub New (
    toolboxControl As IToolboxControl
)
public:
ToolboxContextMenu(
    IToolboxControl^ toolboxControl
)
new :
        toolboxControl : IToolboxControl -> ToolboxContextMenu

Parameters

toolboxControl
Type: Alternet.FormDesigner.WinFormsIToolboxControl
A IToolboxControl that is the container of this menu.
See Also

Reference

ToolboxContextMenu Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContextMenu Methods

ToolboxContextMenu Methods

The ToolboxContextMenu type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | ShowContextMenu | Shows the context menu at the specified location.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

ToolboxContextMenu Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContextMenu.Localize Method

ToolboxContextMenuLocalize Method

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

ToolboxContextMenu Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContextMenu.ShowContextMenu Method

ToolboxContextMenuShowContextMenu Method
Shows the context menu at the specified location.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowContextMenu(
    Point screenLocation
)
Public Overridable Sub ShowContextMenu (
    screenLocation As Point
)
public:
virtual void ShowContextMenu(
    Point screenLocation
)
abstract ShowContextMenu :
        screenLocation : Point -> unit
override ShowContextMenu :
        screenLocation : Point -> unit

Parameters

screenLocation
Type: System.DrawingPoint
See Also

Reference

ToolboxContextMenu Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContextMenu Properties

ToolboxContextMenu Properties

The ToolboxContextMenu type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ToolboxContextMenu Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxContextMenu Events

ToolboxContextMenu Events

The ToolboxContextMenu type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ToolboxContextMenu Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemPaintData Class

ToolboxItemPaintData Class
Provides data to paint toolbox item.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.ToolboxToolboxPaintBaseData
Alternet.FormDesigner.WinForms.ToolboxToolboxItemPaintData

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxItemPaintData : ToolboxPaintBaseData
Public Class ToolboxItemPaintData
    Inherits ToolboxPaintBaseData
public ref class ToolboxItemPaintData : public ToolboxPaintBaseData
type ToolboxItemPaintData =
    class
        inherit ToolboxPaintBaseData
    end

The ToolboxItemPaintData type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxItemPaintData | Initializes a new instance of the ToolboxItemPaintData class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets a size and location of the toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | CategoryName | Gets or sets name of the category contains toolbox item.
Public property | Font | Gets or sets the font of the text displayed by the toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | Graphics | Gets or sets the graphics used to paint toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | Image | Gets or sets an image to paint within toolbox item.
Public property | IsSelected | Gets or sets a boolean value indicating whether toolbox item is selected. (Inherited from ToolboxPaintBaseData.)
Public property | Item | Gets or sets a ToolboxItem to paint.
Public property | State | Gets or sets state of the toolbox item. (Inherited from ToolboxPaintBaseData.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemPaintData Constructor

ToolboxItemPaintData Constructor
Initializes a new instance of the ToolboxItemPaintData class

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemPaintData()
Public Sub New
public:
ToolboxItemPaintData()
new : unit -> ToolboxItemPaintData
See Also

Reference

ToolboxItemPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemPaintData Methods

ToolboxItemPaintData Methods

The ToolboxItemPaintData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToolboxItemPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemPaintData Properties

ToolboxItemPaintData Properties

The ToolboxItemPaintData type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets a size and location of the toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | CategoryName | Gets or sets name of the category contains toolbox item.
Public property | Font | Gets or sets the font of the text displayed by the toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | Graphics | Gets or sets the graphics used to paint toolbox item. (Inherited from ToolboxPaintBaseData.)
Public property | Image | Gets or sets an image to paint within toolbox item.
Public property | IsSelected | Gets or sets a boolean value indicating whether toolbox item is selected. (Inherited from ToolboxPaintBaseData.)
Public property | Item | Gets or sets a ToolboxItem to paint.
Public property | State | Gets or sets state of the toolbox item. (Inherited from ToolboxPaintBaseData.)
Top
See Also

Reference

ToolboxItemPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemPaintData.CategoryName Property

ToolboxItemPaintDataCategoryName Property
Gets or sets name of the category contains toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CategoryName { get; set; }
Public Property CategoryName As String
    Get
    Set
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}
member CategoryName : string with get, set

Property Value

Type: String
See Also

Reference

ToolboxItemPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemPaintData.Image Property

ToolboxItemPaintDataImage Property
Gets or sets an image to paint within toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Property Value

Type: Image
See Also

Reference

ToolboxItemPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemPaintData.Item Property

ToolboxItemPaintDataItem Property
Gets or sets a ToolboxItem to paint.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItem Item { get; set; }
Public Property Item As ToolboxItem
    Get
    Set
public:
property ToolboxItem^ Item {
    ToolboxItem^ get ();
    void set (ToolboxItem^ value);
}
member Item : ToolboxItem with get, set

Property Value

Type: ToolboxItem
See Also

Reference

ToolboxItemPaintData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxItemPaintState Enumeration

ToolboxItemPaintState Enumeration
Defines state of the painted toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ToolboxItemPaintState
Public Enumeration ToolboxItemPaintState
public enum class ToolboxItemPaintState
type ToolboxItemPaintState
Members
Member name | Value | Description
Normal | 0 | Specifies normal state.
Hovered | 1 | Specifies hovered state.
Pressed | 2 | Specifies pressed state.
Disabled | 3 | Specifies disabled state.
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxPaintBaseData Class

ToolboxPaintBaseData Class
Provides base data to paint toolbox item.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.ToolboxToolboxPaintBaseData
Alternet.FormDesigner.WinForms.ToolboxToolboxCategoryHeaderPaintData
Alternet.FormDesigner.WinForms.ToolboxToolboxItemPaintData

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxPaintBaseData
Public Class ToolboxPaintBaseData
public ref class ToolboxPaintBaseData
type ToolboxPaintBaseData =  class end

The ToolboxPaintBaseData type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxPaintBaseData | Initializes a new instance of the ToolboxPaintBaseData class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Bounds | Gets or sets a size and location of the toolbox item.
Public property | Font | Gets or sets the font of the text displayed by the toolbox item.
Public property | Graphics | Gets or sets the graphics used to paint toolbox item.
Public property | IsSelected | Gets or sets a boolean value indicating whether toolbox item is selected.
Public property | State | Gets or sets state of the toolbox item.
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxPaintBaseData Constructor

ToolboxPaintBaseData Constructor
Initializes a new instance of the ToolboxPaintBaseData class

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxPaintBaseData()
Public Sub New
public:
ToolboxPaintBaseData()
new : unit -> ToolboxPaintBaseData
See Also

Reference

ToolboxPaintBaseData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxPaintBaseData Methods

ToolboxPaintBaseData Methods

The ToolboxPaintBaseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToolboxPaintBaseData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxPaintBaseData Properties

ToolboxPaintBaseData Properties

The ToolboxPaintBaseData type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Gets or sets a size and location of the toolbox item.
Public property | Font | Gets or sets the font of the text displayed by the toolbox item.
Public property | Graphics | Gets or sets the graphics used to paint toolbox item.
Public property | IsSelected | Gets or sets a boolean value indicating whether toolbox item is selected.
Public property | State | Gets or sets state of the toolbox item.
Top
See Also

Reference

ToolboxPaintBaseData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxPaintBaseData.Bounds Property

ToolboxPaintBaseDataBounds Property
Gets or sets a size and location of the toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle Bounds { get; set; }
Public Property Bounds As Rectangle
    Get
    Set
public:
property Rectangle Bounds {
    Rectangle get ();
    void set (Rectangle value);
}
member Bounds : Rectangle with get, set

Property Value

Type: Rectangle
See Also

Reference

ToolboxPaintBaseData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxPaintBaseData.Font Property

ToolboxPaintBaseDataFont Property
Gets or sets the font of the text displayed by the toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
member Font : Font with get, set

Property Value

Type: Font
See Also

Reference

ToolboxPaintBaseData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxPaintBaseData.Graphics Property

ToolboxPaintBaseDataGraphics Property
Gets or sets the graphics used to paint toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Graphics Graphics { get; set; }
Public Property Graphics As Graphics
    Get
    Set
public:
property Graphics^ Graphics {
    Graphics^ get ();
    void set (Graphics^ value);
}
member Graphics : Graphics with get, set

Property Value

Type: Graphics
See Also

Reference

ToolboxPaintBaseData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxPaintBaseData.IsSelected Property

ToolboxPaintBaseDataIsSelected Property
Gets or sets a boolean value indicating whether toolbox item is selected.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
member IsSelected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ToolboxPaintBaseData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxPaintBaseData.State Property

ToolboxPaintBaseDataState Property
Gets or sets state of the toolbox item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemPaintState State { get; set; }
Public Property State As ToolboxItemPaintState
    Get
    Set
public:
property ToolboxItemPaintState State {
    ToolboxItemPaintState get ();
    void set (ToolboxItemPaintState value);
}
member State : ToolboxItemPaintState with get, set

Property Value

Type: ToolboxItemPaintState
See Also

Reference

ToolboxPaintBaseData Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchButton Class

ToolboxSearchButton Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsButton
Alternet.FormDesigner.WinForms.ToolboxToolboxSearchButton

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxSearchButton : Button
Public Class ToolboxSearchButton
    Inherits Button
public ref class ToolboxSearchButton : public Button
type ToolboxSearchButton =
    class
        inherit Button
    end

The ToolboxSearchButton type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxSearchButton | Initializes a new instance of the ToolboxSearchButton class
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the Graphics class (GDI+) or the TextRenderer class (GDI) to render text. (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchButton Constructor

ToolboxSearchButton Constructor
Initializes a new instance of the ToolboxSearchButton class

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxSearchButton(
    ToolboxSearchButtonISite site,
    ToolboxSearchButtonImage image
)
Public Sub New (
    site As ToolboxSearchButtonISite,
    image As ToolboxSearchButtonImage
)
public:
ToolboxSearchButton(
    ToolboxSearchButtonISite^ site,
    ToolboxSearchButtonImage image
)
new :
        site : ToolboxSearchButtonISite *
        image : ToolboxSearchButtonImage -> ToolboxSearchButton

Parameters

site
Type: Alternet.FormDesigner.WinForms.ToolboxToolboxSearchButtonISite
image
Type: Alternet.FormDesigner.WinForms.ToolboxToolboxSearchButtonImage
See Also

Reference

ToolboxSearchButton Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchButton Methods

ToolboxSearchButton Methods

The ToolboxSearchButton type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from ButtonBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | NotifyDefault | Notifies the Button whether it is the default button so that it can adjust its appearance accordingly. (Inherited from Button.)
Public method | PerformClick | Generates a Click event for a button. (Inherited from Button.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | (Inherited from Button.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ToolboxSearchButton Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchButton Properties

ToolboxSearchButton Properties

The ToolboxSearchButton type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the control, denoting that the control text extends beyond the specified length of the control. (Inherited from ButtonBase.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from ButtonBase.)
Public property | AutoSizeMode | Gets or sets the mode by which the Button automatically resizes itself. (Inherited from Button.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from ButtonBase.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked. (Inherited from Button.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | FlatAppearance | Gets the appearance of the border and the colors used to indicate check state and mouse state. (Inherited from ButtonBase.)
Public property | FlatStyle | Gets or sets the flat style appearance of the button control. (Inherited from ButtonBase.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | Image | Gets or sets the image that is displayed on a button control. (Inherited from ButtonBase.)
Public property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from ButtonBase.)
Public property | ImageIndex | Gets or sets the image list index value of the image displayed on the button control. (Inherited from ButtonBase.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from ButtonBase.)
Public property | ImageList | Gets or sets the ImageList that contains the Image displayed on a button control. (Inherited from ButtonBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. This property is not relevant for this class. (Inherited from ButtonBase.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from ButtonBase.)
Public property | TextAlign | Gets or sets the alignment of the text on the button control. (Inherited from ButtonBase.)
Public property | TextImageRelation | Gets or sets the position of text and image relative to each other. (Inherited from ButtonBase.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleTextRendering | Gets or sets a value that determines whether to use the Graphics class (GDI+) or the TextRenderer class (GDI) to render text. (Inherited from ButtonBase.)
Public property | UseMnemonic | Gets or sets a value indicating whether the first character that is preceded by an ampersand (&) is used as the mnemonic key of the control. (Inherited from ButtonBase.)
Public property | UseVisualStyleBackColor | Gets or sets a value that determines if the background is drawn using visual styles, if supported. (Inherited from ButtonBase.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ToolboxSearchButton Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchButton Events

ToolboxSearchButton Events

The ToolboxSearchButton type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from ButtonBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the user double-clicks the Button control. (Inherited from Button.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property is changed. This event is not relevant for this class. (Inherited from ButtonBase.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the user double-clicks the Button control with the mouse. (Inherited from Button.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ToolboxSearchButton Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchButton.ISite Interface

ToolboxSearchButtonISite Interface

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISite
Public Interface ISite
public interface class ISite
type ISite =  interface end

The ToolboxSearchButtonISite type exposes the following members.

Properties
 | Name | Description
Public property | Painter |
Public property | ParentControlState |
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ISite Properties

ISite Properties

The ToolboxSearchButtonISite type exposes the following members.

Properties
 | Name | Description
Public property | Painter |
Public property | ParentControlState |
Top
See Also

Reference

ToolboxSearchButtonISite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchButton.ISite.Painter Property

ToolboxSearchButtonISitePainter Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IToolboxPainter Painter { get; }
ReadOnly Property Painter As IToolboxPainter
    Get
property IToolboxPainter^ Painter {
    IToolboxPainter^ get ();
}
abstract Painter : IToolboxPainter with get

Property Value

Type: IToolboxPainter
See Also

Reference

ToolboxSearchButtonISite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchButton.ISite.ParentControlState Property

ToolboxSearchButtonISiteParentControlState Property

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ControlState ParentControlState { get; }
ReadOnly Property ParentControlState As ControlState
    Get
property ControlState ParentControlState {
    ControlState get ();
}
abstract ParentControlState : ControlState with get

Property Value

Type: ControlState
See Also

Reference

ToolboxSearchButtonISite Interface
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchButtonImage Enumeration

ToolboxSearchButtonImage Enumeration

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ToolboxSearchButtonImage
Public Enumeration ToolboxSearchButtonImage
public enum class ToolboxSearchButtonImage
type ToolboxSearchButtonImage
Members
Member name | Value | Description
Clear | 0 |
Focus | 1 |
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchControl Class

ToolboxSearchControl Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Alternet.FormDesigner.WinForms.ToolboxToolboxSearchControl

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxSearchControl : Panel,
    ToolboxSearchButtonISite
Public Class ToolboxSearchControl
    Inherits Panel
    Implements ToolboxSearchButtonISite
public ref class ToolboxSearchControl : public Panel,
    ToolboxSearchButtonISite
type ToolboxSearchControl =
    class
        inherit Panel
        interface ToolboxSearchButtonISite
    end

The ToolboxSearchControl type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxSearchControl | Initializes a new instance of the ToolboxSearchControl class
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | (Overrides ControlGetPreferredSize(Size).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchControl Constructor

ToolboxSearchControl Constructor
Initializes a new instance of the ToolboxSearchControl class

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxSearchControl(
    ToolboxControl toolboxControl
)
Public Sub New (
    toolboxControl As ToolboxControl
)
public:
ToolboxSearchControl(
    ToolboxControl^ toolboxControl
)
new :
        toolboxControl : ToolboxControl -> ToolboxSearchControl

Parameters

toolboxControl
Type: Alternet.FormDesigner.WinFormsToolboxControl
See Also

Reference

ToolboxSearchControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchControl Methods

ToolboxSearchControl Methods

The ToolboxSearchControl type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | (Overrides ControlGetPreferredSize(Size).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation for this control. (Inherited from Panel.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ToolboxSearchControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchControl.GetPreferredSize Method

ToolboxSearchControlGetPreferredSize Method

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Size GetPreferredSize(
    Size proposedSize
)
Public Overrides Function GetPreferredSize (
    proposedSize As Size
) As Size
public:
virtual Size GetPreferredSize(
    Size proposedSize
) override
abstract GetPreferredSize :
        proposedSize : Size -> Size
override GetPreferredSize :
        proposedSize : Size -> Size

Parameters

proposedSize
Type: System.DrawingSize

Return Value

Type: Size
See Also

Reference

ToolboxSearchControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchControl Properties

ToolboxSearchControl Properties

The ToolboxSearchControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value that indicates whether the control resizes based on its contents. (Inherited from Panel.)
Public property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Indicates the border style for the control. (Inherited from Panel.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Panel.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from Panel.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ToolboxSearchControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchControl Events

ToolboxSearchControl Events

The ToolboxSearchControl type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the value of the AutoSize property has changed. (Inherited from Panel.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyPress | This member is not meaningful for this control. (Inherited from Panel.)
Public event | KeyUp | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | This member is not meaningful for this control. (Inherited from Panel.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ToolboxSearchControl Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchTextBox Class

ToolboxSearchTextBox Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Alternet.CommonCueTextBox
Alternet.FormDesigner.WinForms.ToolboxToolboxSearchTextBox

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxSearchTextBox : CueTextBox
Public Class ToolboxSearchTextBox
    Inherits CueTextBox
public ref class ToolboxSearchTextBox : public CueTextBox
type ToolboxSearchTextBox =
    class
        inherit CueTextBox
    end

The ToolboxSearchTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxSearchTextBox | Initializes a new instance of the ToolboxSearchTextBox class
Top
Methods
 | Name | Description
Public method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from TextBoxBase.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from TextBoxBase.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from TextBoxBase.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Public method | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from TextBox.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Public method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Public method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox.)
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from TextBox.)
Public property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from TextBox.)
Public property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from TextBox.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. (Inherited from TextBoxBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
Public property | BackgroundImage | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | BackgroundImageLayout | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from TextBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cue | (Inherited from CueTextBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from TextBoxBase.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from TextBoxBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Public property | Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from TextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from TextBox.)
Public property | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox.)
Public property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the current text in the TextBox. (Inherited from TextBox.)
Public property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox.)
Public property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from TextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Top
Events
 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
Public event | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from TextBox.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchTextBox Constructor

ToolboxSearchTextBox Constructor
Initializes a new instance of the ToolboxSearchTextBox class

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxSearchTextBox()
Public Sub New
public:
ToolboxSearchTextBox()
new : unit -> ToolboxSearchTextBox
See Also

Reference

ToolboxSearchTextBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchTextBox Methods

ToolboxSearchTextBox Methods

The ToolboxSearchTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase.)
Public method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from TextBoxBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from TextBoxBase.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from TextBoxBase.)
Public method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from TextBoxBase.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from TextBoxBase.)
Public method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from TextBoxBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from TextBoxBase.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from TextBoxBase.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase.)
Public method | Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from TextBox.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | Select(Int32, Int32) | Selects a range of text in the text box. (Inherited from TextBoxBase.)
Public method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from TextBoxBase.)
Public method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBoxBase.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

ToolboxSearchTextBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchTextBox Properties

ToolboxSearchTextBox Properties

The ToolboxSearchTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox.)
Public property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from TextBoxBase.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from TextBox.)
Public property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from TextBox.)
Public property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from TextBox.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed. (Inherited from TextBoxBase.)
Public property | BackColor | Gets or sets the background color of the control. (Inherited from TextBoxBase.)
Public property | BackgroundImage | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | BackgroundImageLayout | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from TextBoxBase.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBoxBase.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from TextBox.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cue | (Inherited from CueTextBox.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from TextBoxBase.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from TextBoxBase.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lines | Gets or sets the lines of text in a text box control. (Inherited from TextBoxBase.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from TextBoxBase.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from TextBoxBase.)
Public property | Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from TextBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant for this class. (Inherited from TextBoxBase.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from TextBox.)
Public property | PreferredHeight | Gets the preferred height for a text box. (Inherited from TextBoxBase.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from TextBoxBase.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox.)
Public property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase.)
Public property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from TextBoxBase.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the current text in the TextBox. (Inherited from TextBox.)
Public property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox.)
Public property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from TextBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from TextBoxBase.)
Top
See Also

Reference

ToolboxSearchTextBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSearchTextBox Events

ToolboxSearchTextBox Events

The ToolboxSearchTextBox type exposes the following members.

Events
 | Name | Description
Public event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from TextBoxBase.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from TextBoxBase.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the text box is clicked. (Inherited from TextBoxBase.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from TextBoxBase.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from TextBoxBase.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from TextBoxBase.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from TextBoxBase.)
Public event | PaddingChanged | This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | Paint | Occurs when the control is redrawn. This event is not relevant for this class. (Inherited from TextBoxBase.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from TextBoxBase.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from TextBox.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ToolboxSearchTextBox Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization Class

ToolboxSerialization Class
Implements Load and Save logic for toolbox.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.ToolboxToolboxSerialization

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToolboxSerialization
Public Class ToolboxSerialization
public ref class ToolboxSerialization
type ToolboxSerialization =  class end

The ToolboxSerialization type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxSerialization | Initializes a new instance of the ToolboxSerialization class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the toolbox content from the specified stream.
Public method | Save | Saves the toolbox content to the specified stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization Constructor

ToolboxSerialization Constructor
Initializes a new instance of the ToolboxSerialization class

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxSerialization()
Public Sub New
public:
ToolboxSerialization()
new : unit -> ToolboxSerialization
See Also

Reference

ToolboxSerialization Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization Methods

ToolboxSerialization Methods

The ToolboxSerialization type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the toolbox content from the specified stream.
Public method | Save | Saves the toolbox content to the specified stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToolboxSerialization Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.Load Method

ToolboxSerializationLoad Method
Loads the toolbox content from the specified stream.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ToolboxSerializationLoadedCategory> Load(
    Stream stream
)
Public Function Load (
    stream As Stream
) As IEnumerable(Of ToolboxSerializationLoadedCategory)
public:
IEnumerable<ToolboxSerializationLoadedCategory^>^ Load(
    Stream^ stream
)
member Load :
        stream : Stream -> IEnumerable<ToolboxSerializationLoadedCategory>

Parameters

stream
Type: System.IOStream

Return Value

Type: IEnumerableToolboxSerializationLoadedCategory
See Also

Reference

ToolboxSerialization Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.Save Method

ToolboxSerializationSave Method
Saves the toolbox content to the specified stream.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save(
    IToolboxControl toolbox,
    Stream stream
)
Public Sub Save (
    toolbox As IToolboxControl,
    stream As Stream
)
public:
void Save(
    IToolboxControl^ toolbox,
    Stream^ stream
)
member Save :
        toolbox : IToolboxControl *
        stream : Stream -> unit

Parameters

toolbox
Type: Alternet.FormDesigner.WinFormsIToolboxControl
stream
Type: System.IOStream
See Also

Reference

ToolboxSerialization Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.LoadedCategory Class

ToolboxSerializationLoadedCategory Class
Contains information about toolbox category.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.ToolboxToolboxSerializationLoadedCategory

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LoadedCategory
Public Class LoadedCategory
public ref class LoadedCategory
type LoadedCategory =  class end

The ToolboxSerializationLoadedCategory type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxSerializationLoadedCategory | Initializes a new instance of the LoadedCategory class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Items | Represents list of items belongs to the category.
Public property | Name | Represents name of the category.
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.LoadedCategory Constructor

ToolboxSerializationLoadedCategory Constructor
Initializes a new instance of the LoadedCategory class with specified settings.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LoadedCategory(
    string name,
    IEnumerable<ToolboxSerializationLoadedCategoryItem> items
)
Public Sub New (
    name As String,
    items As IEnumerable(Of ToolboxSerializationLoadedCategoryItem)
)
public:
LoadedCategory(
    String^ name,
    IEnumerable<ToolboxSerializationLoadedCategoryItem^>^ items
)
new :
        name : string *
        items : IEnumerable<ToolboxSerializationLoadedCategoryItem> -> LoadedCategory

Parameters

name
Type: SystemString
Name of the category.
items
Type: System.Collections.GenericIEnumerableToolboxSerializationLoadedCategoryItem
List of items belongs to the category.
See Also

Reference

ToolboxSerializationLoadedCategory Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


LoadedCategory Methods

LoadedCategory Methods

The ToolboxSerializationLoadedCategory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToolboxSerializationLoadedCategory Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


LoadedCategory Properties

LoadedCategory Properties

The ToolboxSerializationLoadedCategory type exposes the following members.

Properties
 | Name | Description
Public property | Items | Represents list of items belongs to the category.
Public property | Name | Represents name of the category.
Top
See Also

Reference

ToolboxSerializationLoadedCategory Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.LoadedCategory.Items Property

ToolboxSerializationLoadedCategoryItems Property
Represents list of items belongs to the category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ToolboxSerializationLoadedCategoryItem> Items { get; }
Public ReadOnly Property Items As IEnumerable(Of ToolboxSerializationLoadedCategoryItem)
    Get
public:
property IEnumerable<ToolboxSerializationLoadedCategoryItem^>^ Items {
    IEnumerable<ToolboxSerializationLoadedCategoryItem^>^ get ();
}
member Items : IEnumerable<ToolboxSerializationLoadedCategoryItem> with get

Property Value

Type: IEnumerableToolboxSerializationLoadedCategoryItem
See Also

Reference

ToolboxSerializationLoadedCategory Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.LoadedCategory.Name Property

ToolboxSerializationLoadedCategoryName Property
Represents name of the category.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

ToolboxSerializationLoadedCategory Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.LoadedCategory.Item Class

ToolboxSerializationLoadedCategoryItem Class
Contains information about toolbox item.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.ToolboxToolboxSerializationLoadedCategoryItem

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Item
Public Class Item
public ref class Item
type Item =  class end

The ToolboxSerializationLoadedCategoryItem type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxSerializationLoadedCategoryItem | Initializes a new instance of the Item class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ToolboxItem | Represents a ToolboxItem to load and save.
Public property | Type | Represents type of the item.
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.LoadedCategory.Item Constructor

ToolboxSerializationLoadedCategoryItem Constructor
Initializes a new instance of the Item class with specified settings.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Item(
    Type type,
    ToolboxItem toolboxItem
)
Public Sub New (
    type As Type,
    toolboxItem As ToolboxItem
)
public:
Item(
    Type^ type,
    ToolboxItem^ toolboxItem
)
new :
        type : Type *
        toolboxItem : ToolboxItem -> Item

Parameters

type
Type: SystemType
Type of the item.
toolboxItem
Type: System.Drawing.DesignToolboxItem
A ToolboxItem to load and save.
See Also

Reference

ToolboxSerializationLoadedCategoryItem Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


Item Methods

Item Methods

The ToolboxSerializationLoadedCategoryItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToolboxSerializationLoadedCategoryItem Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


Item Properties

Item Properties

The ToolboxSerializationLoadedCategoryItem type exposes the following members.

Properties
 | Name | Description
Public property | ToolboxItem | Represents a ToolboxItem to load and save.
Public property | Type | Represents type of the item.
Top
See Also

Reference

ToolboxSerializationLoadedCategoryItem Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.LoadedCategory.Item.ToolboxItem Property

ToolboxSerializationLoadedCategoryItemToolboxItem Property
Represents a ToolboxItem to load and save.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolboxItem ToolboxItem { get; }
Public ReadOnly Property ToolboxItem As ToolboxItem
    Get
public:
property ToolboxItem^ ToolboxItem {
    ToolboxItem^ get ();
}
member ToolboxItem : ToolboxItem with get

Property Value

Type: ToolboxItem
See Also

Reference

ToolboxSerializationLoadedCategoryItem Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxSerialization.LoadedCategory.Item.Type Property

ToolboxSerializationLoadedCategoryItemType Property
Represents type of the item.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}
member Type : Type with get

Property Value

Type: Type
See Also

Reference

ToolboxSerializationLoadedCategoryItem Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxStandardItems Class

ToolboxStandardItems Class
Provides a collection of the standard toolbox items.
Inheritance Hierarchy
SystemObject
Alternet.FormDesigner.WinForms.ToolboxToolboxStandardItems

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ToolboxStandardItems
Public NotInheritable Class ToolboxStandardItems
public ref class ToolboxStandardItems abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ToolboxStandardItems =  class end

The ToolboxStandardItems type exposes the following members.

Fields
Name | Description
TypesByCategoryName | Represents a list of toolbox items arranged by categories.
Top
See Also

Reference

Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxStandardItems Fields

ToolboxStandardItems Fields

The ToolboxStandardItems type exposes the following members.

Fields
Name | Description
TypesByCategoryName | Represents a list of toolbox items arranged by categories.
Top
See Also

Reference

ToolboxStandardItems Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


ToolboxStandardItems.TypesByCategoryName Field

ToolboxStandardItemsTypesByCategoryName Field
Represents a list of toolbox items arranged by categories.

Namespace: Alternet.FormDesigner.WinForms.Toolbox
Assembly: Alternet.FormDesigner.v7 (in Alternet.FormDesigner.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly Dictionary<string, List<Type>> TypesByCategoryName
Public Shared ReadOnly TypesByCategoryName As Dictionary(Of String, List(Of Type))
public:
static initonly Dictionary<String^, List<Type^>^>^ TypesByCategoryName
static val TypesByCategoryName: Dictionary<string, List<Type>>

Field Value

Type: DictionaryString, ListType
See Also

Reference

ToolboxStandardItems Class
Alternet.FormDesigner.WinForms.Toolbox Namespace


Alternet.Scripter Namespace

Alternet.Scripter Namespace
Classes
 | Class | Description
Public class | CoreClrLauncher |
Public class | FileLoadEventArgs | Provides data for the IScriptRun.FileLoad event.
Public class | ResolveReferenceEventArgs | Provides data for the IScriptRun.ReferenceResolve event.
Public class | ScriptConsts | Contains constants related to Scripter component.
Public class | ScriptErrorEventArgs | Provides data for the IScriptHost.ScriptError and IScriptRun.ScriptError events.
Public class | ScriptGlobalItem | Describes a global object from the script.
Public class | ScriptHost | Provides a base class for script execution. This class is abstract.
Public class | ScriptMethod | Provides functionality to run particular script method.
Public class | ScriptRun | Represents runner for script engine.
Public class | ScriptSource | Provides methods and properties to work with script text, files or projects.
Structures
 | Structure | Description
Public structure | ScriptCompilationDiagnostic | Provides data for compiler error.
Public structure | ScriptCompilationResult | Represent structured information of code compilation result.
Interfaces
 | Interface | Description
Public interface | IScriptDebuggerRemoteControl | Represents methods for remote communication between application that executes script and debugger.
Public interface | IScriptGlobalItem | Represents properties declaration to describe a global object from the script.
Public interface | IScriptHost | Represents methods and properties declaration to support a script engine functionality.
Public interface | IScriptRemoteControl | Represents methods for remote communication between application that executes script and debugger.
Public interface | IScriptRun | Represents methods and properties declaration to describe runner for script engine.
Public interface | IScriptRunBase | Represents methods and properties declaration to describe runner for script engine.
Public interface | IScriptSource | Represents methods and properties to work with script text, files or projects.
Public interface | IScriptSourceBase | Represents methods and properties to work with script text, files or projects.
Delegates
 | Delegate | Description
Public delegate | ScriptCompiledDelegate | Delegate for notification of remote control about the end of the compilation process.
Public delegate | ScriptFinishedDelegate | Delegate for notification of remote control about the end of the script execution.
Enumerations
 | Enumeration | Description
Public enumeration | ScriptAssemblyKind | Defines programming language used by the script engine.
Public enumeration | ScriptCompilationDiagnosticKind | Defines script error severity
Public enumeration | ScriptLanguage | Defines programming language used by the script engine.
Public enumeration | ScriptMode | Defines debug or release mode for the scripts.
Public enumeration | ScriptPlatform | Defines target platform.
Public enumeration | ScriptTechnologyEnvironment | Defines a technology environment


CoreClrLauncher Class

CoreClrLauncher Class
Inheritance Hierarchy
SystemObject
Alternet.ScripterCoreClrLauncher

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CoreClrLauncher
Public NotInheritable Class CoreClrLauncher
public ref class CoreClrLauncher abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CoreClrLauncher =  class end

The CoreClrLauncher type exposes the following members.

Methods
Name | Description
GetDotNetExePath |
RunProcess |
WriteRuntimeConfigFile |
Top
See Also

Reference

Alternet.Scripter Namespace


CoreClrLauncher Methods

CoreClrLauncher Methods

The CoreClrLauncher type exposes the following members.

Methods
Name | Description
GetDotNetExePath |
RunProcess |
WriteRuntimeConfigFile |
Top
See Also

Reference

CoreClrLauncher Class
Alternet.Scripter Namespace


CoreClrLauncher.GetDotNetExePath Method

CoreClrLauncherGetDotNetExePath Method

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDotNetExePath()
Public Shared Function GetDotNetExePath As String
public:
static String^ GetDotNetExePath()
static member GetDotNetExePath : unit -> string

Return Value

Type: String
See Also

Reference

CoreClrLauncher Class
Alternet.Scripter Namespace


CoreClrLauncher.RunProcess Method

CoreClrLauncherRunProcess Method

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int RunProcess(
    string executableFile,
    Object[] args,
    bool wait
)
Public Shared Function RunProcess (
    executableFile As String,
    args As Object(),
    wait As Boolean
) As Integer
public:
static int RunProcess(
    String^ executableFile,
    array<Object^>^ args,
    bool wait
)
static member RunProcess :
        executableFile : string *
        args : Object[] *
        wait : bool -> int

Parameters

executableFile
Type: SystemString
args
Type: SystemObject
wait
Type: SystemBoolean

Return Value

Type: Int32
See Also

Reference

CoreClrLauncher Class
Alternet.Scripter Namespace


CoreClrLauncher.WriteRuntimeConfigFile Method

CoreClrLauncherWriteRuntimeConfigFile Method

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void WriteRuntimeConfigFile(
    string executablePath,
    Version coreClrVersion
)
Public Shared Sub WriteRuntimeConfigFile (
    executablePath As String,
    coreClrVersion As Version
)
public:
static void WriteRuntimeConfigFile(
    String^ executablePath,
    Version^ coreClrVersion
)
static member WriteRuntimeConfigFile :
        executablePath : string *
        coreClrVersion : Version -> unit

Parameters

executablePath
Type: SystemString
coreClrVersion
Type: SystemVersion
See Also

Reference

CoreClrLauncher Class
Alternet.Scripter Namespace


FileLoadEventArgs Class

FileLoadEventArgs Class
Provides data for the IScriptRun.FileLoad event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.ScripterFileLoadEventArgs

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FileLoadEventArgs : EventArgs
Public Class FileLoadEventArgs
    Inherits EventArgs
public ref class FileLoadEventArgs : public EventArgs
type FileLoadEventArgs =
    class
        inherit EventArgs
    end

The FileLoadEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FileLoadEventArgs | Initializes a new instance of the FileLoadEventArgs class with specified file.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FileName | Gets file name to load.
Public property | Handled | Gets or sets a value indicating whether the FileLoad event was handled.
Public property | Text | Gets or sets a text contained in the file.
Top
See Also

Reference

Alternet.Scripter Namespace


FileLoadEventArgs Constructor

FileLoadEventArgs Constructor
Initializes a new instance of the FileLoadEventArgs class with specified file.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FileLoadEventArgs(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
FileLoadEventArgs(
    String^ fileName
)
new :
        fileName : string -> FileLoadEventArgs

Parameters

fileName
Type: SystemString
File to load.
See Also

Reference

FileLoadEventArgs Class
Alternet.Scripter Namespace


FileLoadEventArgs Methods

FileLoadEventArgs Methods

The FileLoadEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileLoadEventArgs Class
Alternet.Scripter Namespace


FileLoadEventArgs Properties

FileLoadEventArgs Properties

The FileLoadEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets file name to load.
Public property | Handled | Gets or sets a value indicating whether the FileLoad event was handled.
Public property | Text | Gets or sets a text contained in the file.
Top
See Also

Reference

FileLoadEventArgs Class
Alternet.Scripter Namespace


FileLoadEventArgs.FileName Property

FileLoadEventArgsFileName Property
Gets file name to load.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

FileLoadEventArgs Class
Alternet.Scripter Namespace


FileLoadEventArgs.Handled Property

FileLoadEventArgsHandled Property
Gets or sets a value indicating whether the FileLoad event was handled.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileLoadEventArgs Class
Alternet.Scripter Namespace


FileLoadEventArgs.Text Property

FileLoadEventArgsText Property
Gets or sets a text contained in the file.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

FileLoadEventArgs Class
Alternet.Scripter Namespace


IScriptDebuggerRemoteControl Interface

IScriptDebuggerRemoteControl Interface
Represents methods for remote communication between application that executes script and debugger.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptDebuggerRemoteControl
Public Interface IScriptDebuggerRemoteControl
public interface class IScriptDebuggerRemoteControl
type IScriptDebuggerRemoteControl =  interface end

The IScriptDebuggerRemoteControl type exposes the following members.

Methods
 | Name | Description
Public method | CompileScript | When implemented by a class, compiles scripts, and calls back the given delegate when compilation is complete.
Public method | IsScriptRunning | When implementing by a class, returns boolean value indicating that script is currently running.
Public method | StartScript | When implemented by a class, starts script execution.
Public method | StopScript | When implemented by a class, stops script execution.
Top
See Also

Reference

Alternet.Scripter Namespace


IScriptDebuggerRemoteControl Methods

IScriptDebuggerRemoteControl Methods

The IScriptDebuggerRemoteControl type exposes the following members.

Methods
 | Name | Description
Public method | CompileScript | When implemented by a class, compiles scripts, and calls back the given delegate when compilation is complete.
Public method | IsScriptRunning | When implementing by a class, returns boolean value indicating that script is currently running.
Public method | StartScript | When implemented by a class, starts script execution.
Public method | StopScript | When implemented by a class, stops script execution.
Top
See Also

Reference

IScriptDebuggerRemoteControl Interface
Alternet.Scripter Namespace


IScriptDebuggerRemoteControl.CompileScript Method

IScriptDebuggerRemoteControlCompileScript Method
When implemented by a class, compiles scripts, and calls back the given delegate when compilation is complete.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CompileScript(
    ScriptCompiledDelegate onScriptCompiled
)
Sub CompileScript (
    onScriptCompiled As ScriptCompiledDelegate
)
void CompileScript(
    ScriptCompiledDelegate^ onScriptCompiled
)
abstract CompileScript :
        onScriptCompiled : ScriptCompiledDelegate -> unit

Parameters

onScriptCompiled
Type: Alternet.ScripterScriptCompiledDelegate
See Also

Reference

IScriptDebuggerRemoteControl Interface
Alternet.Scripter Namespace


IScriptDebuggerRemoteControl.IsScriptRunning Method

IScriptDebuggerRemoteControlIsScriptRunning Method
When implementing by a class, returns boolean value indicating that script is currently running.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsScriptRunning()
Function IsScriptRunning As Boolean
bool IsScriptRunning()
abstract IsScriptRunning : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IScriptDebuggerRemoteControl Interface
Alternet.Scripter Namespace


IScriptDebuggerRemoteControl.StartScript Method

IScriptDebuggerRemoteControlStartScript Method
When implemented by a class, starts script execution.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartScript(
    ScriptFinishedDelegate onScriptFinished
)
Sub StartScript (
    onScriptFinished As ScriptFinishedDelegate
)
void StartScript(
    ScriptFinishedDelegate^ onScriptFinished
)
abstract StartScript :
        onScriptFinished : ScriptFinishedDelegate -> unit

Parameters

onScriptFinished
Type: Alternet.ScripterScriptFinishedDelegate
See Also

Reference

IScriptDebuggerRemoteControl Interface
Alternet.Scripter Namespace


IScriptDebuggerRemoteControl.StopScript Method

IScriptDebuggerRemoteControlStopScript Method
When implemented by a class, stops script execution.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StopScript()
Sub StopScript
void StopScript()
abstract StopScript : unit -> unit
See Also

Reference

IScriptDebuggerRemoteControl Interface
Alternet.Scripter Namespace


IScriptGlobalItem Interface

IScriptGlobalItem Interface
Represents properties declaration to describe a global object from the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptGlobalItem
Public Interface IScriptGlobalItem
public interface class IScriptGlobalItem
type IScriptGlobalItem =  interface end

The IScriptGlobalItem type exposes the following members.

Properties
 | Name | Description
Public property | Name | When implemented by a class, gets or sets name of this item.
Public property | Obj | When implemented by a class, gets or sets object contained by this item.
Public property | Type | When implemented by a class, gets or sets object type of this item.
Top
See Also

Reference

Alternet.Scripter Namespace


IScriptGlobalItem Properties

IScriptGlobalItem Properties

The IScriptGlobalItem type exposes the following members.

Properties
 | Name | Description
Public property | Name | When implemented by a class, gets or sets name of this item.
Public property | Obj | When implemented by a class, gets or sets object contained by this item.
Public property | Type | When implemented by a class, gets or sets object type of this item.
Top
See Also

Reference

IScriptGlobalItem Interface
Alternet.Scripter Namespace


IScriptGlobalItem.Name Property

IScriptGlobalItemName Property
When implemented by a class, gets or sets name of this item.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IScriptGlobalItem Interface
Alternet.Scripter Namespace


IScriptGlobalItem.Obj Property

IScriptGlobalItemObj Property
When implemented by a class, gets or sets object contained by this item.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Obj { get; set; }
Property Obj As Object
    Get
    Set
property Object^ Obj {
    Object^ get ();
    void set (Object^ value);
}
abstract Obj : Object with get, set

Property Value

Type: Object
See Also

Reference

IScriptGlobalItem Interface
Alternet.Scripter Namespace


IScriptGlobalItem.Type Property

IScriptGlobalItemType Property
When implemented by a class, gets or sets object type of this item.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Type Type { get; set; }
Property Type As Type
    Get
    Set
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}
abstract Type : Type with get, set

Property Value

Type: Type
See Also

Reference

IScriptGlobalItem Interface
Alternet.Scripter Namespace


IScriptHost Interface

IScriptHost Interface
Represents methods and properties declaration to support a script engine functionality.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptHost : IDisposable
Public Interface IScriptHost
    Inherits IDisposable
public interface class IScriptHost : IDisposable
type IScriptHost =
    interface
        interface IDisposable
    end

The IScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | CopyReferencedAssemblies | When implemented by a class, copies all non-GAC assemblies referenced by a script to the output directories.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | ReferencesDotNetCoreRuntime |
Public method | Reset | When implemented by a class, closes the script engine and releases all resources.
Public method | ResolveReferences | When implemented by a class, returns list of assembly references used by the script.
Public method | ResolveReferences(IListString) | When implemented by a class, returns list of assembly references used by the script.
Public method | Run | When implemented by a class, executes script starting from the main entry point.
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunMethod | When implemented by a class, executes specified method.
Public method | RunMethodAsync | When implemented by a class, executes specified method asynchronously.
Public method | RunProcess | When implemented by a class, executes script starting from the main entry point in standalone process.
Top
Properties
 | Name | Description
Public property | AssemblyFileName | When implemented by a class, gets script assembly file name.
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | When implemented by a class, gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | When implemented by a class, gets list of compiler errors associated with the script being executed.
Public property | ExecutableModulePath | When implemented by a class, gets script assembly path.
Public property | GenerateModulesOnDisk | When implemented by a class, gets or sets value indicating whether script assembly should be written to the disk or kept in memory.
Public property | GlobalCode | When implemented by a class, gets a global code required for global items.
Public property | ModulesDirectoryPath | When implemented by a class, gets or sets path for compiled script assemblies.
Public property | ReuseCompiledModulesFromDisk | When implemented by a class, gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date.
Public property | ScriptAssembly | When implemented by a class, returns compiled script assembly.
Public property | ScriptRun | When implemented by a class, gets IScriptRun associated this script host.
Top
See Also

Reference

Alternet.Scripter Namespace


IScriptHost Methods

IScriptHost Methods

The IScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | CopyReferencedAssemblies | When implemented by a class, copies all non-GAC assemblies referenced by a script to the output directories.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | ReferencesDotNetCoreRuntime |
Public method | Reset | When implemented by a class, closes the script engine and releases all resources.
Public method | ResolveReferences | When implemented by a class, returns list of assembly references used by the script.
Public method | ResolveReferences(IListString) | When implemented by a class, returns list of assembly references used by the script.
Public method | Run | When implemented by a class, executes script starting from the main entry point.
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunMethod | When implemented by a class, executes specified method.
Public method | RunMethodAsync | When implemented by a class, executes specified method asynchronously.
Public method | RunProcess | When implemented by a class, executes script starting from the main entry point in standalone process.
Top
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.Compile Method

IScriptHostCompile Method
When implemented by a class, initializes script engine and compiles the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Compile(
    bool copyReferences = true
)
Function Compile (
    Optional copyReferences As Boolean = true
) As Boolean
bool Compile(
    bool copyReferences = true
)
abstract Compile :
        ?copyReferences : bool
(* Defaults:
        let _copyReferences = defaultArg copyReferences true
*)
-> bool

Parameters

copyReferences (Optional)
Type: SystemBoolean
Specifies if all required assemblies should be copied to the output location

Return Value

Type: Boolean
True if succeed, otherwise false.
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.CopyReferencedAssemblies Method

IScriptHostCopyReferencedAssemblies Method
When implemented by a class, copies all non-GAC assemblies referenced by a script to the output directories.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CopyReferencedAssemblies()
Sub CopyReferencedAssemblies
void CopyReferencedAssemblies()
abstract CopyReferencedAssemblies : unit -> unit
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.EvaluateExpression Method

IScriptHostEvaluateExpression Method
When implemented by a class, evaluates specified expression.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object EvaluateExpression(
    string expression
)
Function EvaluateExpression (
    expression As String
) As Object
Object^ EvaluateExpression(
    String^ expression
)
abstract EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.EvaluateExpressionAsync Method

IScriptHostEvaluateExpressionAsync Method
When implemented by a class, evaluates specified expression asynchronously.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.ReferencesDotNetCoreRuntime Method

IScriptHostReferencesDotNetCoreRuntime Method

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReferencesDotNetCoreRuntime(
    out Version dotNetCoreVersion
)
Function ReferencesDotNetCoreRuntime (
    <OutAttribute> ByRef dotNetCoreVersion As Version
) As Boolean
bool ReferencesDotNetCoreRuntime(
    [OutAttribute] Version^% dotNetCoreVersion
)
abstract ReferencesDotNetCoreRuntime :
        dotNetCoreVersion : Version byref -> bool

Parameters

dotNetCoreVersion
Type: SystemVersion

Return Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.Reset Method

IScriptHostReset Method
When implemented by a class, closes the script engine and releases all resources.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.ResolveReferences Method

IScriptHostResolveReferences Method
Overload List
 | Name | Description
Public method | ResolveReferences | When implemented by a class, returns list of assembly references used by the script.
Public method | ResolveReferences(IListString) | When implemented by a class, returns list of assembly references used by the script.
Top
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.ResolveReferences Method

IScriptHostResolveReferences Method
When implemented by a class, returns list of assembly references used by the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> ResolveReferences()
Function ResolveReferences As IList(Of String)
IList<String^>^ ResolveReferences()
abstract ResolveReferences : unit -> IList<string>

Return Value

Type: IListString
List of assembly references.
See Also

Reference

IScriptHost Interface
ResolveReferences Overload
Alternet.Scripter Namespace


IScriptHost.ResolveReferences Method (IList(String))

IScriptHostResolveReferences Method (IListString)
When implemented by a class, returns list of assembly references used by the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> ResolveReferences(
    IList<string> unresolvedReferences
)
Function ResolveReferences (
    unresolvedReferences As IList(Of String)
) As IList(Of String)
IList<String^>^ ResolveReferences(
    IList<String^>^ unresolvedReferences
)
abstract ResolveReferences :
        unresolvedReferences : IList<string> -> IList<string>

Parameters

unresolvedReferences
Type: System.Collections.GenericIListString
Contains list of references that can not be resolved.

Return Value

Type: IListString
List of assembly references.
See Also

Reference

IScriptHost Interface
ResolveReferences Overload
Alternet.Scripter Namespace


IScriptHost.Run Method

IScriptHostRun Method
When implemented by a class, executes script starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Run(
    string[] args = null
)
Function Run (
    Optional args As String() = Nothing
) As Object
Object^ Run(
    array<String^>^ args = nullptr
)
abstract Run :
        ?args : string[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.

Return Value

Type: Object
Return value of the script being executed.
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.RunAsync Method

IScriptHostRunAsync Method
When implemented by a class, executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> RunAsync(
    string[] args = null,
    CancellationToken cancellationToken = null
)
Function RunAsync (
    Optional args As String() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ RunAsync(
    array<String^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?args : string[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
Return value of the script being executed.
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.RunMethod Method

IScriptHostRunMethod Method
When implemented by a class, executes specified method.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object RunMethod(
    string method,
    Object obj = null,
    Object[] args = null
)
Function RunMethod (
    method As String,
    Optional obj As Object = Nothing,
    Optional args As Object() = Nothing
) As Object
Object^ RunMethod(
    String^ method,
    Object^ obj = nullptr,
    array<Object^>^ args = nullptr
)
abstract RunMethod :
        method : string *
        ?obj : Object *
        ?args : Object[]
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
*)
-> Object

Parameters

method
Type: SystemString
Name of method to execute.
obj (Optional)
Type: SystemObject
Object, contains method to execute.
args (Optional)
Type: SystemObject
Array of method's parameters.

Return Value

Type: Object
An object containing return value of the executed method.
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.RunMethodAsync Method

IScriptHostRunMethodAsync Method
When implemented by a class, executes specified method asynchronously.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> RunMethodAsync(
    string method,
    Object obj = null,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Function RunMethodAsync (
    method As String,
    Optional obj As Object = Nothing,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ RunMethodAsync(
    String^ method,
    Object^ obj = nullptr,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunMethodAsync :
        method : string *
        ?obj : Object *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

method
Type: SystemString
Name of method to execute.
obj (Optional)
Type: SystemObject
Object, contains method to execute.
args (Optional)
Type: SystemObject
Array of method's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed method.
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.RunProcess Method

IScriptHostRunProcess Method
When implemented by a class, executes script starting from the main entry point in standalone process.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int RunProcess(
    string[] args = null,
    bool wait = true
)
Function RunProcess (
    Optional args As String() = Nothing,
    Optional wait As Boolean = true
) As Integer
int RunProcess(
    array<String^>^ args = nullptr,
    bool wait = true
)
abstract RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
wait (Optional)
Type: SystemBoolean
Specifies if calling application should wait for process termination

Return Value

Type: Int32
Return process exit code.
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost Properties

IScriptHost Properties

The IScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyFileName | When implemented by a class, gets script assembly file name.
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | When implemented by a class, gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | When implemented by a class, gets list of compiler errors associated with the script being executed.
Public property | ExecutableModulePath | When implemented by a class, gets script assembly path.
Public property | GenerateModulesOnDisk | When implemented by a class, gets or sets value indicating whether script assembly should be written to the disk or kept in memory.
Public property | GlobalCode | When implemented by a class, gets a global code required for global items.
Public property | ModulesDirectoryPath | When implemented by a class, gets or sets path for compiled script assemblies.
Public property | ReuseCompiledModulesFromDisk | When implemented by a class, gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date.
Public property | ScriptAssembly | When implemented by a class, returns compiled script assembly.
Public property | ScriptRun | When implemented by a class, gets IScriptRun associated this script host.
Top
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.AssemblyFileName Property

IScriptHostAssemblyFileName Property
When implemented by a class, gets script assembly file name.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string AssemblyFileName { get; set; }
Property AssemblyFileName As String
    Get
    Set
property String^ AssemblyFileName {
    String^ get ();
    void set (String^ value);
}
abstract AssemblyFileName : string with get, set

Property Value

Type: String
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.Compiled Property

IScriptHostCompiled Property
When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Compiled { get; }
ReadOnly Property Compiled As Boolean
    Get
property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.CompileFailed Property

IScriptHostCompileFailed Property
When implemented by a class, gets or sets boolean value indicating unsuccessful script compilation.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CompileFailed { get; }
ReadOnly Property CompileFailed As Boolean
    Get
property bool CompileFailed {
    bool get ();
}
abstract CompileFailed : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.CompilerErrors Property

IScriptHostCompilerErrors Property
When implemented by a class, gets list of compiler errors associated with the script being executed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptCompilationDiagnostic[] CompilerErrors { get; }
ReadOnly Property CompilerErrors As ScriptCompilationDiagnostic()
    Get
property array<ScriptCompilationDiagnostic>^ CompilerErrors {
    array<ScriptCompilationDiagnostic>^ get ();
}
abstract CompilerErrors : ScriptCompilationDiagnostic[] with get

Property Value

Type: ScriptCompilationDiagnostic
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.ExecutableModulePath Property

IScriptHostExecutableModulePath Property
When implemented by a class, gets script assembly path.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ExecutableModulePath { get; }
ReadOnly Property ExecutableModulePath As String
    Get
property String^ ExecutableModulePath {
    String^ get ();
}
abstract ExecutableModulePath : string with get

Property Value

Type: String
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.GenerateModulesOnDisk Property

IScriptHostGenerateModulesOnDisk Property
When implemented by a class, gets or sets value indicating whether script assembly should be written to the disk or kept in memory.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GenerateModulesOnDisk { get; set; }
Property GenerateModulesOnDisk As Boolean
    Get
    Set
property bool GenerateModulesOnDisk {
    bool get ();
    void set (bool value);
}
abstract GenerateModulesOnDisk : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.GlobalCode Property

IScriptHostGlobalCode Property
When implemented by a class, gets a global code required for global items.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GlobalCode { get; }
ReadOnly Property GlobalCode As String
    Get
property String^ GlobalCode {
    String^ get ();
}
abstract GlobalCode : string with get

Property Value

Type: String
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.ModulesDirectoryPath Property

IScriptHostModulesDirectoryPath Property
When implemented by a class, gets or sets path for compiled script assemblies.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ModulesDirectoryPath { get; set; }
Property ModulesDirectoryPath As String
    Get
    Set
property String^ ModulesDirectoryPath {
    String^ get ();
    void set (String^ value);
}
abstract ModulesDirectoryPath : string with get, set

Property Value

Type: String
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.ReuseCompiledModulesFromDisk Property

IScriptHostReuseCompiledModulesFromDisk Property
When implemented by a class, gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReuseCompiledModulesFromDisk { get; set; }
Property ReuseCompiledModulesFromDisk As Boolean
    Get
    Set
property bool ReuseCompiledModulesFromDisk {
    bool get ();
    void set (bool value);
}
abstract ReuseCompiledModulesFromDisk : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.ScriptAssembly Property

IScriptHostScriptAssembly Property
When implemented by a class, returns compiled script assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Assembly ScriptAssembly { get; }
ReadOnly Property ScriptAssembly As Assembly
    Get
property Assembly^ ScriptAssembly {
    Assembly^ get ();
}
abstract ScriptAssembly : Assembly with get

Property Value

Type: Assembly
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptHost.ScriptRun Property

IScriptHostScriptRun Property
When implemented by a class, gets IScriptRun associated this script host.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptRun ScriptRun { get; }
ReadOnly Property ScriptRun As IScriptRun
    Get
property IScriptRun^ ScriptRun {
    IScriptRun^ get ();
}
abstract ScriptRun : IScriptRun with get

Property Value

Type: IScriptRun
See Also

Reference

IScriptHost Interface
Alternet.Scripter Namespace


IScriptRemoteControl Interface

IScriptRemoteControl Interface
Represents methods for remote communication between application that executes script and debugger.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptRemoteControl
Public Interface IScriptRemoteControl
public interface class IScriptRemoteControl
type IScriptRemoteControl =  interface end

The IScriptRemoteControl type exposes the following members.

Methods
 | Name | Description
Public method | CompileScript | When implemented by a class, compiles scripts, and calls back the given delegate when compilation is complete.
Public method | IsScriptRunning | When implementing by a class, returns boolean value indicating that script is currently running.
Public method | StartScript | When implemented by a class, compiles script if needed and starts execution.
Public method | StopScript | When implemented by a class, stops script execution.
Top
See Also

Reference

Alternet.Scripter Namespace


IScriptRemoteControl Methods

IScriptRemoteControl Methods

The IScriptRemoteControl type exposes the following members.

Methods
 | Name | Description
Public method | CompileScript | When implemented by a class, compiles scripts, and calls back the given delegate when compilation is complete.
Public method | IsScriptRunning | When implementing by a class, returns boolean value indicating that script is currently running.
Public method | StartScript | When implemented by a class, compiles script if needed and starts execution.
Public method | StopScript | When implemented by a class, stops script execution.
Top
See Also

Reference

IScriptRemoteControl Interface
Alternet.Scripter Namespace


IScriptRemoteControl.CompileScript Method

IScriptRemoteControlCompileScript Method
When implemented by a class, compiles scripts, and calls back the given delegate when compilation is complete.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CompileScript(
    ScriptCompiledDelegate onScriptCompiled
)
Sub CompileScript (
    onScriptCompiled As ScriptCompiledDelegate
)
void CompileScript(
    ScriptCompiledDelegate^ onScriptCompiled
)
abstract CompileScript :
        onScriptCompiled : ScriptCompiledDelegate -> unit

Parameters

onScriptCompiled
Type: Alternet.ScripterScriptCompiledDelegate
See Also

Reference

IScriptRemoteControl Interface
Alternet.Scripter Namespace


IScriptRemoteControl.IsScriptRunning Method

IScriptRemoteControlIsScriptRunning Method
When implementing by a class, returns boolean value indicating that script is currently running.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsScriptRunning()
Function IsScriptRunning As Boolean
bool IsScriptRunning()
abstract IsScriptRunning : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IScriptRemoteControl Interface
Alternet.Scripter Namespace


IScriptRemoteControl.StartScript Method

IScriptRemoteControlStartScript Method
When implemented by a class, compiles script if needed and starts execution.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartScript(
    ScriptFinishedDelegate onScriptFinished
)
Sub StartScript (
    onScriptFinished As ScriptFinishedDelegate
)
void StartScript(
    ScriptFinishedDelegate^ onScriptFinished
)
abstract StartScript :
        onScriptFinished : ScriptFinishedDelegate -> unit

Parameters

onScriptFinished
Type: Alternet.ScripterScriptFinishedDelegate
See Also

Reference

IScriptRemoteControl Interface
Alternet.Scripter Namespace


IScriptRemoteControl.StopScript Method

IScriptRemoteControlStopScript Method
When implemented by a class, stops script execution.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StopScript()
Sub StopScript
void StopScript()
abstract StopScript : unit -> unit
See Also

Reference

IScriptRemoteControl Interface
Alternet.Scripter Namespace


IScriptRun Interface

IScriptRun Interface
Represents methods and properties declaration to describe runner for script engine.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptRun : IScriptRunBase
Public Interface IScriptRun
    Inherits IScriptRunBase
public interface class IScriptRun : IScriptRunBase
type IScriptRun =
    interface
        interface IScriptRunBase
    end

The IScriptRun type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script. (Inherited from IScriptRunBase.)
Public method | CreateScriptHost | When implemented by a class, creates a new IScriptHost object with appropriate characteristics.
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression. (Inherited from IScriptRunBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | LoadScript | When implemented by a class, load script from specified file. (Inherited from IScriptRunBase.)
Public method | OnFileLoad | When implemented by a class, invokes FileLoad event handler. (Inherited from IScriptRunBase.)
Public method | OnResolveReference | When implemented by a class, invokes ReferenceResolve event handler.
Public method | OnScriptCompiled | When implemented by a class, invokes ScriptCompiled event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptError | When implemented by a class, invokes ScriptError event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptExecuted | When implemented by a class, invokes ScriptExecuted event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptReset | When implemented by a class, invokes ScriptReset event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptRunning | When implemented by a class, invokes ScriptRunning event handler. (Inherited from IScriptRunBase.)
Public method | Reset | When implemented by a class, removes the script engine from the running state and disconnects automatically bound event handlers. (Inherited from IScriptRunBase.)
Public method | Run | When implemented by a class, executes script starting from the main entry point. (Inherited from IScriptRunBase.)
Public method | Run(String) | When implemented by a class, executes script starting from the main entry point.
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunMethod | When implemented by a class, executes specified method.
Public method | RunMethodAsync | When implemented by a class, executes specified method asynchronously.
Public method | RunProcess | When implemented by a class, executes script starting from the main entry point in stand-alone process
Top
Properties
 | Name | Description
Public property | AssemblyKind | When implemented by a class, gets or sets output kind for the script assembly.
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive. (Inherited from IScriptRunBase.)
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed. (Inherited from IScriptRunBase.)
Public property | Executed | When implemented by a class, gets boolean value indicating that script has been executed at least once. (Inherited from IScriptRunBase.)
Public property | GlobalItems | When implemented by a class, gets or sets a script items collection attached to this runner.
Public property | Platform | When implemented by a class, gets or sets target platform (32 or 64 bits).
Public property | ScriptHost | When implemented by a class, returns object that implements IScriptHost interface for this runner.
Public property | ScriptLanguage | When implemented by a class, gets or sets programming language of the script.
Public property | ScriptMode | When implemented by a class, gets or sets debug or release mode for the scripts being executed.
Public property | ScriptSource | When implemented by a class, gets source of the script to execute.
Public property | TargetFrameworkVersion | When implemented by a class, gets or sets target framework version for locating .NET Framework assemblies.
Public property | Win32ManifestOptions | When implemented by a class, gets or sets Win32 manifest options for the script assembly.
Top
Events
 | Name | Description
Public event | FileLoad | When implemented by a class, occurs when script code is loaded from file. (Inherited from IScriptRunBase.)
Public event | ReferenceResolve | When implemented by a class, occurs when script code is loaded from file.
Public event | ScriptCompiled | When implemented by a class, occurs when the script engine running successfully. (Inherited from IScriptRunBase.)
Public event | ScriptError | When implemented by a class, occurs when the script engine running is failed. (Inherited from IScriptRunBase.)
Public event | ScriptExecuted | When implemented by a class, occurs when script engine executes the script. (Inherited from IScriptRunBase.)
Public event | ScriptReset | When implemented by a class, occurs when the script engine is reset. (Inherited from IScriptRunBase.)
Public event | ScriptRunning | When implemented by a class, occurs when script engine tries to running script. (Inherited from IScriptRunBase.)
Top
See Also

Reference

Alternet.Scripter Namespace


IScriptRun Methods

IScriptRun Methods

The IScriptRun type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script. (Inherited from IScriptRunBase.)
Public method | CreateScriptHost | When implemented by a class, creates a new IScriptHost object with appropriate characteristics.
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression. (Inherited from IScriptRunBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | LoadScript | When implemented by a class, load script from specified file. (Inherited from IScriptRunBase.)
Public method | OnFileLoad | When implemented by a class, invokes FileLoad event handler. (Inherited from IScriptRunBase.)
Public method | OnResolveReference | When implemented by a class, invokes ReferenceResolve event handler.
Public method | OnScriptCompiled | When implemented by a class, invokes ScriptCompiled event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptError | When implemented by a class, invokes ScriptError event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptExecuted | When implemented by a class, invokes ScriptExecuted event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptReset | When implemented by a class, invokes ScriptReset event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptRunning | When implemented by a class, invokes ScriptRunning event handler. (Inherited from IScriptRunBase.)
Public method | Reset | When implemented by a class, removes the script engine from the running state and disconnects automatically bound event handlers. (Inherited from IScriptRunBase.)
Public method | Run | When implemented by a class, executes script starting from the main entry point. (Inherited from IScriptRunBase.)
Public method | Run(String) | When implemented by a class, executes script starting from the main entry point.
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunMethod | When implemented by a class, executes specified method.
Public method | RunMethodAsync | When implemented by a class, executes specified method asynchronously.
Public method | RunProcess | When implemented by a class, executes script starting from the main entry point in stand-alone process
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.CreateScriptHost Method

IScriptRunCreateScriptHost Method
When implemented by a class, creates a new IScriptHost object with appropriate characteristics.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptHost CreateScriptHost()
Function CreateScriptHost As IScriptHost
IScriptHost^ CreateScriptHost()
abstract CreateScriptHost : unit -> IScriptHost

Return Value

Type: IScriptHost
Created IScriptHost object.
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.EvaluateExpressionAsync Method

IScriptRunEvaluateExpressionAsync Method
When implemented by a class, evaluates specified expression asynchronously.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.OnResolveReference Method

IScriptRunOnResolveReference Method
When implemented by a class, invokes ReferenceResolve event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OnResolveReference(
    string reference,
    out string assemblyLocation,
    out byte[] assemblyImage
)
Function OnResolveReference (
    reference As String,
    <OutAttribute> ByRef assemblyLocation As String,
    <OutAttribute> ByRef assemblyImage As Byte()
) As Boolean
bool OnResolveReference(
    String^ reference,
    [OutAttribute] String^% assemblyLocation,
    [OutAttribute] array<unsigned char>^% assemblyImage
)
abstract OnResolveReference :
        reference : string *
        assemblyLocation : string byref *
        assemblyImage : byte[] byref -> bool

Parameters

reference
Type: SystemString
Reference to resolve.
assemblyLocation
Type: SystemString
Path to suitable assembly.
assemblyImage
Type: SystemByte
Image containing suitable assembly.

Return Value

Type: Boolean
true if reference was resolved otherwise false
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.Run Method

IScriptRunRun Method
Overload List
 | Name | Description
Public method | Run | When implemented by a class, executes script starting from the main entry point. (Inherited from IScriptRunBase.)
Public method | Run(String) | When implemented by a class, executes script starting from the main entry point.
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.Run Method (String[])

IScriptRunRun Method (String)
When implemented by a class, executes script starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Run(
    string[] args = null
)
Function Run (
    Optional args As String() = Nothing
) As Object
Object^ Run(
    array<String^>^ args = nullptr
)
abstract Run :
        ?args : string[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.

Return Value

Type: Object
Return value of the script being executed.
See Also

Reference

IScriptRun Interface
Run Overload
Alternet.Scripter Namespace


IScriptRun.RunAsync Method

IScriptRunRunAsync Method
When implemented by a class, executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> RunAsync(
    string[] args = null,
    CancellationToken cancellationToken = null
)
Function RunAsync (
    Optional args As String() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ RunAsync(
    array<String^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?args : string[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
Return value of the script being executed.
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.RunMethod Method

IScriptRunRunMethod Method
When implemented by a class, executes specified method.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object RunMethod(
    string method,
    Object obj = null,
    Object[] args = null
)
Function RunMethod (
    method As String,
    Optional obj As Object = Nothing,
    Optional args As Object() = Nothing
) As Object
Object^ RunMethod(
    String^ method,
    Object^ obj = nullptr,
    array<Object^>^ args = nullptr
)
abstract RunMethod :
        method : string *
        ?obj : Object *
        ?args : Object[]
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
*)
-> Object

Parameters

method
Type: SystemString
Name of method to execute.
obj (Optional)
Type: SystemObject
Object, contains method to execute.
args (Optional)
Type: SystemObject
Array of method's parameters.

Return Value

Type: Object
An object containing return value of the executed method.
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.RunMethodAsync Method

IScriptRunRunMethodAsync Method
When implemented by a class, executes specified method asynchronously.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> RunMethodAsync(
    string method,
    Object obj = null,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Function RunMethodAsync (
    method As String,
    Optional obj As Object = Nothing,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ RunMethodAsync(
    String^ method,
    Object^ obj = nullptr,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunMethodAsync :
        method : string *
        ?obj : Object *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

method
Type: SystemString
Name of method to execute.
obj (Optional)
Type: SystemObject
Object, contains method to execute.
args (Optional)
Type: SystemObject
Array of method's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed method.
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.RunProcess Method

IScriptRunRunProcess Method
When implemented by a class, executes script starting from the main entry point in stand-alone process

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int RunProcess(
    string[] args = null,
    bool wait = true
)
Function RunProcess (
    Optional args As String() = Nothing,
    Optional wait As Boolean = true
) As Integer
int RunProcess(
    array<String^>^ args = nullptr,
    bool wait = true
)
abstract RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
wait (Optional)
Type: SystemBoolean
Specifies if calling application should wait for process termination

Return Value

Type: Int32
Return process exit code.
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun Properties

IScriptRun Properties

The IScriptRun type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyKind | When implemented by a class, gets or sets output kind for the script assembly.
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive. (Inherited from IScriptRunBase.)
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed. (Inherited from IScriptRunBase.)
Public property | Executed | When implemented by a class, gets boolean value indicating that script has been executed at least once. (Inherited from IScriptRunBase.)
Public property | GlobalItems | When implemented by a class, gets or sets a script items collection attached to this runner.
Public property | Platform | When implemented by a class, gets or sets target platform (32 or 64 bits).
Public property | ScriptHost | When implemented by a class, returns object that implements IScriptHost interface for this runner.
Public property | ScriptLanguage | When implemented by a class, gets or sets programming language of the script.
Public property | ScriptMode | When implemented by a class, gets or sets debug or release mode for the scripts being executed.
Public property | ScriptSource | When implemented by a class, gets source of the script to execute.
Public property | TargetFrameworkVersion | When implemented by a class, gets or sets target framework version for locating .NET Framework assemblies.
Public property | Win32ManifestOptions | When implemented by a class, gets or sets Win32 manifest options for the script assembly.
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.AssemblyKind Property

IScriptRunAssemblyKind Property
When implemented by a class, gets or sets output kind for the script assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptAssemblyKind AssemblyKind { get; set; }
Property AssemblyKind As ScriptAssemblyKind
    Get
    Set
property ScriptAssemblyKind AssemblyKind {
    ScriptAssemblyKind get ();
    void set (ScriptAssemblyKind value);
}
abstract AssemblyKind : ScriptAssemblyKind with get, set

Property Value

Type: ScriptAssemblyKind
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.GlobalItems Property

IScriptRunGlobalItems Property
When implemented by a class, gets or sets a script items collection attached to this runner.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<IScriptGlobalItem> GlobalItems { get; }
ReadOnly Property GlobalItems As IList(Of IScriptGlobalItem)
    Get
property IList<IScriptGlobalItem^>^ GlobalItems {
    IList<IScriptGlobalItem^>^ get ();
}
abstract GlobalItems : IList<IScriptGlobalItem> with get

Property Value

Type: IListIScriptGlobalItem
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.Platform Property

IScriptRunPlatform Property
When implemented by a class, gets or sets target platform (32 or 64 bits).

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptPlatform Platform { get; set; }
Property Platform As ScriptPlatform
    Get
    Set
property ScriptPlatform Platform {
    ScriptPlatform get ();
    void set (ScriptPlatform value);
}
abstract Platform : ScriptPlatform with get, set

Property Value

Type: ScriptPlatform
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.ScriptHost Property

IScriptRunScriptHost Property
When implemented by a class, returns object that implements IScriptHost interface for this runner.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptHost ScriptHost { get; set; }
Property ScriptHost As IScriptHost
    Get
    Set
property IScriptHost^ ScriptHost {
    IScriptHost^ get ();
    void set (IScriptHost^ value);
}
abstract ScriptHost : IScriptHost with get, set

Property Value

Type: IScriptHost
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.ScriptLanguage Property

IScriptRunScriptLanguage Property
When implemented by a class, gets or sets programming language of the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptLanguage ScriptLanguage { get; set; }
Property ScriptLanguage As ScriptLanguage
    Get
    Set
property ScriptLanguage ScriptLanguage {
    ScriptLanguage get ();
    void set (ScriptLanguage value);
}
abstract ScriptLanguage : ScriptLanguage with get, set

Property Value

Type: ScriptLanguage
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.ScriptMode Property

IScriptRunScriptMode Property
When implemented by a class, gets or sets debug or release mode for the scripts being executed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptMode ScriptMode { get; set; }
Property ScriptMode As ScriptMode
    Get
    Set
property ScriptMode ScriptMode {
    ScriptMode get ();
    void set (ScriptMode value);
}
abstract ScriptMode : ScriptMode with get, set

Property Value

Type: ScriptMode
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.ScriptSource Property

IScriptRunScriptSource Property
When implemented by a class, gets source of the script to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource ScriptSource { get; }
ReadOnly Property ScriptSource As IScriptSource
    Get
property IScriptSource^ ScriptSource {
    IScriptSource^ get ();
}
abstract ScriptSource : IScriptSource with get

Property Value

Type: IScriptSource
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.TargetFrameworkVersion Property

IScriptRunTargetFrameworkVersion Property
When implemented by a class, gets or sets target framework version for locating .NET Framework assemblies.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TargetNETFrameworkVersion TargetFrameworkVersion { get; set; }
Property TargetFrameworkVersion As TargetNETFrameworkVersion
    Get
    Set
property TargetNETFrameworkVersion TargetFrameworkVersion {
    TargetNETFrameworkVersion get ();
    void set (TargetNETFrameworkVersion value);
}
abstract TargetFrameworkVersion : TargetNETFrameworkVersion with get, set

Property Value

Type: TargetNETFrameworkVersion
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.Win32ManifestOptions Property

IScriptRunWin32ManifestOptions Property
When implemented by a class, gets or sets Win32 manifest options for the script assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Win32ManifestOptions Win32ManifestOptions { get; set; }
Property Win32ManifestOptions As Win32ManifestOptions
    Get
    Set
property Win32ManifestOptions^ Win32ManifestOptions {
    Win32ManifestOptions^ get ();
    void set (Win32ManifestOptions^ value);
}
abstract Win32ManifestOptions : Win32ManifestOptions with get, set

Property Value

Type: Win32ManifestOptions
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun Events

IScriptRun Events

The IScriptRun type exposes the following members.

Events
 | Name | Description
Public event | FileLoad | When implemented by a class, occurs when script code is loaded from file. (Inherited from IScriptRunBase.)
Public event | ReferenceResolve | When implemented by a class, occurs when script code is loaded from file.
Public event | ScriptCompiled | When implemented by a class, occurs when the script engine running successfully. (Inherited from IScriptRunBase.)
Public event | ScriptError | When implemented by a class, occurs when the script engine running is failed. (Inherited from IScriptRunBase.)
Public event | ScriptExecuted | When implemented by a class, occurs when script engine executes the script. (Inherited from IScriptRunBase.)
Public event | ScriptReset | When implemented by a class, occurs when the script engine is reset. (Inherited from IScriptRunBase.)
Public event | ScriptRunning | When implemented by a class, occurs when script engine tries to running script. (Inherited from IScriptRunBase.)
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRun.ReferenceResolve Event

IScriptRunReferenceResolve Event
When implemented by a class, occurs when script code is loaded from file.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ResolveReferenceEventArgs> ReferenceResolve
Event ReferenceResolve As EventHandler(Of ResolveReferenceEventArgs)
 event EventHandler<ResolveReferenceEventArgs^>^ ReferenceResolve {
    void add (EventHandler<ResolveReferenceEventArgs^>^ value);
    void remove (EventHandler<ResolveReferenceEventArgs^>^ value);
}
abstract ReferenceResolve : IEvent<EventHandler<ResolveReferenceEventArgs>,
    ResolveReferenceEventArgs>

Value

Type: SystemEventHandlerResolveReferenceEventArgs
See Also

Reference

IScriptRun Interface
Alternet.Scripter Namespace


IScriptRunBase Interface

IScriptRunBase Interface
Represents methods and properties declaration to describe runner for script engine.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptRunBase
Public Interface IScriptRunBase
public interface class IScriptRunBase
type IScriptRunBase =  interface end

The IScriptRunBase type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression.
Public method | LoadScript | When implemented by a class, load script from specified file.
Public method | OnFileLoad | When implemented by a class, invokes FileLoad event handler.
Public method | OnScriptCompiled | When implemented by a class, invokes ScriptCompiled event handler.
Public method | OnScriptError | When implemented by a class, invokes ScriptError event handler.
Public method | OnScriptExecuted | When implemented by a class, invokes ScriptExecuted event handler.
Public method | OnScriptReset | When implemented by a class, invokes ScriptReset event handler.
Public method | OnScriptRunning | When implemented by a class, invokes ScriptRunning event handler.
Public method | Reset | When implemented by a class, removes the script engine from the running state and disconnects automatically bound event handlers.
Public method | Run | When implemented by a class, executes script starting from the main entry point.
Top
Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive.
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.
Public property | Executed | When implemented by a class, gets boolean value indicating that script has been executed at least once.
Public property | ScriptSource |
Top
Events
 | Name | Description
Public event | FileLoad | When implemented by a class, occurs when script code is loaded from file.
Public event | ScriptCompiled | When implemented by a class, occurs when the script engine running successfully.
Public event | ScriptError | When implemented by a class, occurs when the script engine running is failed.
Public event | ScriptExecuted | When implemented by a class, occurs when script engine executes the script.
Public event | ScriptReset | When implemented by a class, occurs when the script engine is reset.
Public event | ScriptRunning | When implemented by a class, occurs when script engine tries to running script.
Top
See Also

Reference

Alternet.Scripter Namespace


IScriptRunBase Methods

IScriptRunBase Methods

The IScriptRunBase type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression.
Public method | LoadScript | When implemented by a class, load script from specified file.
Public method | OnFileLoad | When implemented by a class, invokes FileLoad event handler.
Public method | OnScriptCompiled | When implemented by a class, invokes ScriptCompiled event handler.
Public method | OnScriptError | When implemented by a class, invokes ScriptError event handler.
Public method | OnScriptExecuted | When implemented by a class, invokes ScriptExecuted event handler.
Public method | OnScriptReset | When implemented by a class, invokes ScriptReset event handler.
Public method | OnScriptRunning | When implemented by a class, invokes ScriptRunning event handler.
Public method | Reset | When implemented by a class, removes the script engine from the running state and disconnects automatically bound event handlers.
Public method | Run | When implemented by a class, executes script starting from the main entry point.
Top
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.Compile Method

IScriptRunBaseCompile Method
When implemented by a class, initializes script engine and compiles the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Compile()
Function Compile As Boolean
bool Compile()
abstract Compile : unit -> bool

Return Value

Type: Boolean
True if succeed, otherwise false.
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.EvaluateExpression Method

IScriptRunBaseEvaluateExpression Method
When implemented by a class, evaluates specified expression.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object EvaluateExpression(
    string expression
)
Function EvaluateExpression (
    expression As String
) As Object
Object^ EvaluateExpression(
    String^ expression
)
abstract EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.LoadScript Method

IScriptRunBaseLoadScript Method
When implemented by a class, load script from specified file.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string LoadScript(
    string fileName
)
Function LoadScript (
    fileName As String
) As String
String^ LoadScript(
    String^ fileName
)
abstract LoadScript :
        fileName : string -> string

Parameters

fileName
Type: SystemString
File name contains script to load.

Return Value

Type: String
String representation of loaded script.
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.OnFileLoad Method

IScriptRunBaseOnFileLoad Method
When implemented by a class, invokes FileLoad event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string OnFileLoad(
    string fileName
)
Function OnFileLoad (
    fileName As String
) As String
String^ OnFileLoad(
    String^ fileName
)
abstract OnFileLoad :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.OnScriptCompiled Method

IScriptRunBaseOnScriptCompiled Method
When implemented by a class, invokes ScriptCompiled event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnScriptCompiled()
Sub OnScriptCompiled
void OnScriptCompiled()
abstract OnScriptCompiled : unit -> unit
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.OnScriptError Method

IScriptRunBaseOnScriptError Method
When implemented by a class, invokes ScriptError event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnScriptError(
    ScriptErrorEventArgs e
)
Sub OnScriptError (
    e As ScriptErrorEventArgs
)
void OnScriptError(
    ScriptErrorEventArgs^ e
)
abstract OnScriptError :
        e : ScriptErrorEventArgs -> unit

Parameters

e
Type: Alternet.ScripterScriptErrorEventArgs
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.OnScriptExecuted Method

IScriptRunBaseOnScriptExecuted Method
When implemented by a class, invokes ScriptExecuted event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnScriptExecuted()
Sub OnScriptExecuted
void OnScriptExecuted()
abstract OnScriptExecuted : unit -> unit
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.OnScriptReset Method

IScriptRunBaseOnScriptReset Method
When implemented by a class, invokes ScriptReset event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnScriptReset()
Sub OnScriptReset
void OnScriptReset()
abstract OnScriptReset : unit -> unit
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.OnScriptRunning Method

IScriptRunBaseOnScriptRunning Method
When implemented by a class, invokes ScriptRunning event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnScriptRunning()
Sub OnScriptRunning
void OnScriptRunning()
abstract OnScriptRunning : unit -> unit
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.Reset Method

IScriptRunBaseReset Method
When implemented by a class, removes the script engine from the running state and disconnects automatically bound event handlers.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.Run Method

IScriptRunBaseRun Method
When implemented by a class, executes script starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Run()
Function Run As Object
Object^ Run()
abstract Run : unit -> Object

Return Value

Type: Object
Return value of the script being executed.
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase Properties

IScriptRunBase Properties

The IScriptRunBase type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive.
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.
Public property | Executed | When implemented by a class, gets boolean value indicating that script has been executed at least once.
Public property | ScriptSource |
Top
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.CaseSensitive Property

IScriptRunBaseCaseSensitive Property
When implemented by a class, indicates whether script language is case sensitive.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CaseSensitive { get; }
ReadOnly Property CaseSensitive As Boolean
    Get
property bool CaseSensitive {
    bool get ();
}
abstract CaseSensitive : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.Compiled Property

IScriptRunBaseCompiled Property
When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Compiled { get; }
ReadOnly Property Compiled As Boolean
    Get
property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.Executed Property

IScriptRunBaseExecuted Property
When implemented by a class, gets boolean value indicating that script has been executed at least once.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Executed { get; }
ReadOnly Property Executed As Boolean
    Get
property bool Executed {
    bool get ();
}
abstract Executed : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.ScriptSource Property

IScriptRunBaseScriptSource Property

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSourceBase ScriptSource { get; }
ReadOnly Property ScriptSource As IScriptSourceBase
    Get
property IScriptSourceBase^ ScriptSource {
    IScriptSourceBase^ get ();
}
abstract ScriptSource : IScriptSourceBase with get

Property Value

Type: IScriptSourceBase
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase Events

IScriptRunBase Events

The IScriptRunBase type exposes the following members.

Events
 | Name | Description
Public event | FileLoad | When implemented by a class, occurs when script code is loaded from file.
Public event | ScriptCompiled | When implemented by a class, occurs when the script engine running successfully.
Public event | ScriptError | When implemented by a class, occurs when the script engine running is failed.
Public event | ScriptExecuted | When implemented by a class, occurs when script engine executes the script.
Public event | ScriptReset | When implemented by a class, occurs when the script engine is reset.
Public event | ScriptRunning | When implemented by a class, occurs when script engine tries to running script.
Top
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.FileLoad Event

IScriptRunBaseFileLoad Event
When implemented by a class, occurs when script code is loaded from file.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<FileLoadEventArgs> FileLoad
Event FileLoad As EventHandler(Of FileLoadEventArgs)
 event EventHandler<FileLoadEventArgs^>^ FileLoad {
    void add (EventHandler<FileLoadEventArgs^>^ value);
    void remove (EventHandler<FileLoadEventArgs^>^ value);
}
abstract FileLoad : IEvent<EventHandler<FileLoadEventArgs>,
    FileLoadEventArgs>

Value

Type: SystemEventHandlerFileLoadEventArgs
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.ScriptCompiled Event

IScriptRunBaseScriptCompiled Event
When implemented by a class, occurs when the script engine running successfully.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ScriptCompiled
Event ScriptCompiled As EventHandler
 event EventHandler^ ScriptCompiled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptCompiled : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.ScriptError Event

IScriptRunBaseScriptError Event
When implemented by a class, occurs when the script engine running is failed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ScriptErrorEventArgs> ScriptError
Event ScriptError As EventHandler(Of ScriptErrorEventArgs)
 event EventHandler<ScriptErrorEventArgs^>^ ScriptError {
    void add (EventHandler<ScriptErrorEventArgs^>^ value);
    void remove (EventHandler<ScriptErrorEventArgs^>^ value);
}
abstract ScriptError : IEvent<EventHandler<ScriptErrorEventArgs>,
    ScriptErrorEventArgs>

Value

Type: SystemEventHandlerScriptErrorEventArgs
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.ScriptExecuted Event

IScriptRunBaseScriptExecuted Event
When implemented by a class, occurs when script engine executes the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ScriptExecuted
Event ScriptExecuted As EventHandler
 event EventHandler^ ScriptExecuted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptExecuted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.ScriptReset Event

IScriptRunBaseScriptReset Event
When implemented by a class, occurs when the script engine is reset.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ScriptReset
Event ScriptReset As EventHandler
 event EventHandler^ ScriptReset {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptReset : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptRunBase.ScriptRunning Event

IScriptRunBaseScriptRunning Event
When implemented by a class, occurs when script engine tries to running script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ScriptRunning
Event ScriptRunning As EventHandler
 event EventHandler^ ScriptRunning {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptRunning : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptRunBase Interface
Alternet.Scripter Namespace


IScriptSource Interface

IScriptSource Interface
Represents methods and properties to work with script text, files or projects.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptSource : IScriptSourceBase,
    ICloneable, IEquatable<IScriptSource>
Public Interface IScriptSource
    Inherits IScriptSourceBase, ICloneable, IEquatable(Of IScriptSource)
public interface class IScriptSource : IScriptSourceBase,
    ICloneable, IEquatable<IScriptSource^>
type IScriptSource =
    interface
        interface IScriptSourceBase
        interface ICloneable
        interface IEquatable<IScriptSource>
    end

The IScriptSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatableIScriptSource.)
Public method | FromExpression | When implemented by a class, loads script source from the expression.
Public method | FromScriptCode(String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptCode(String, String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptFile | When implemented by a class, loads script source from the script file.
Public method | FromScriptProject | When implemented by a class, loads script source from the Visual Studio project.
Public method | GetLastModifiedDate | When implemented by a class, gets file date time when script source was compiled.
Public method | HasBeenModified | When implemented by a class, compares file modification dates against to other script source.
Public method | Reset | When implemented by a class, clears script source.
Public method | WithDefaultReferences | When implemented by a class, set default assembly references to the script source.
Top
Properties
 | Name | Description
Public property | Changed | When implemented by a class, gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Conditionals | When implemented by a class, gets list of conditional compilation symbols.
Public property | Expression | When implemented by a class, gets expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | Files | When implemented by a class, gets list of files containing script to execute.
Public property | FrameworkPath | When implemented by a class, gets location of .NET Framework assemblies.
Public property | HasExpression | When implemented by a class, returns boolean value indicating whether ScriptSource contains expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | HasProject | When implemented by a class, returns boolean value indicating whether ScriptSource is associated with the project. (Inherited from IScriptSourceBase.)
Public property | HasScriptCode | When implemented by a class, returns boolean value indicating whether ScriptSource contains script code to execute. (Inherited from IScriptSourceBase.)
Public property | HasScriptFile | When implemented by a class, returns boolean value indicating whether ScriptSource contains script file to execute. (Inherited from IScriptSourceBase.)
Public property | Imports | When implemented by a class, gets list of namespaces to be used in the script.
Public property | IsWpfProject | When implemented by a class, returns boolean value indicating whether ScriptSource contains a Wpf project
Public property | Language | When implemented by a class, returns script programming language.
Public property | ProjectFileName | When implemented by a class, gets a file name of the Visual Studio project containing script files to execute. (Inherited from IScriptSourceBase.)
Public property | ProjectName | When implemented by a class, gets or sets name of the Visual Studio project containing script files to execute.
Public property | ProjectTargetFramework |
Public property | References | When implemented by a class, gets list of external assemblies referenced from the script.
Public property | Resources | When implemented by a class, gets list of embedded resource files.
Public property | RootNamespace | When implemented by a class, gets or sets root namespace to be used for manifest resources.
Public property | ScriptCode | When implemented by a class, gets script code to execute. (Inherited from IScriptSourceBase.)
Public property | ScriptFile | When implemented by a class, gets single script file to execute. (Inherited from IScriptSourceBase.)
Public property | SearchPaths | When implemented by a class, gets list of search directories to look for source files and referenced assemblies.
Public property | WpfResources | When implemented by a class, gets list of wpf resource files.
Top
See Also

Reference

Alternet.Scripter Namespace


IScriptSource Methods

IScriptSource Methods

The IScriptSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatableIScriptSource .)
Public method | FromExpression | When implemented by a class, loads script source from the expression.
Public method | FromScriptCode(String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptCode(String, String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptFile | When implemented by a class, loads script source from the script file.
Public method | FromScriptProject | When implemented by a class, loads script source from the Visual Studio project.
Public method | GetLastModifiedDate | When implemented by a class, gets file date time when script source was compiled.
Public method | HasBeenModified | When implemented by a class, compares file modification dates against to other script source.
Public method | Reset | When implemented by a class, clears script source.
Public method | WithDefaultReferences | When implemented by a class, set default assembly references to the script source.
Top
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.FromExpression Method

IScriptSourceFromExpression Method
When implemented by a class, loads script source from the expression.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromExpression(
    string expression
)
Function FromExpression (
    expression As String
) As IScriptSource
IScriptSource^ FromExpression(
    String^ expression
)
abstract FromExpression :
        expression : string -> IScriptSource

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.FromScriptCode Method

IScriptSourceFromScriptCode Method
Overload List
 | Name | Description
Public method | FromScriptCode(String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptCode(String, String) | When implemented by a class, loads script source from the script code.
Top
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.FromScriptCode Method (String)

IScriptSourceFromScriptCode Method (String)
When implemented by a class, loads script source from the script code.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptCode(
    string scriptCode
)
Function FromScriptCode (
    scriptCode As String
) As IScriptSource
IScriptSource^ FromScriptCode(
    String^ scriptCode
)
abstract FromScriptCode :
        scriptCode : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
FromScriptCode Overload
Alternet.Scripter Namespace


IScriptSource.FromScriptCode Method (String, String)

IScriptSourceFromScriptCode Method (String, String)
When implemented by a class, loads script source from the script code.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptCode(
    string scriptCode,
    string fileName
)
Function FromScriptCode (
    scriptCode As String,
    fileName As String
) As IScriptSource
IScriptSource^ FromScriptCode(
    String^ scriptCode,
    String^ fileName
)
abstract FromScriptCode :
        scriptCode : string *
        fileName : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.
fileName
Type: SystemString
Specifis name if the file containing script code.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
FromScriptCode Overload
Alternet.Scripter Namespace


IScriptSource.FromScriptFile Method

IScriptSourceFromScriptFile Method
When implemented by a class, loads script source from the script file.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptFile(
    string fileName
)
Function FromScriptFile (
    fileName As String
) As IScriptSource
IScriptSource^ FromScriptFile(
    String^ fileName
)
abstract FromScriptFile :
        fileName : string -> IScriptSource

Parameters

fileName
Type: SystemString
File Name to load the script.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.FromScriptProject Method

IScriptSourceFromScriptProject Method
When implemented by a class, loads script source from the Visual Studio project.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptProject(
    string projectFileName
)
Function FromScriptProject (
    projectFileName As String
) As IScriptSource
IScriptSource^ FromScriptProject(
    String^ projectFileName
)
abstract FromScriptProject :
        projectFileName : string -> IScriptSource

Parameters

projectFileName
Type: SystemString
Project file name to load script.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.GetLastModifiedDate Method

IScriptSourceGetLastModifiedDate Method
When implemented by a class, gets file date time when script source was compiled.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime GetLastModifiedDate(
    string fileName
)
Function GetLastModifiedDate (
    fileName As String
) As DateTime
DateTime GetLastModifiedDate(
    String^ fileName
)
abstract GetLastModifiedDate :
        fileName : string -> DateTime

Parameters

fileName
Type: SystemString
FileName to check last modified date.

Return Value

Type: DateTime
File date of the given file at the time it was compiled.
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.HasBeenModified Method

IScriptSourceHasBeenModified Method
When implemented by a class, compares file modification dates against to other script source.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasBeenModified(
    IScriptSource other
)
Function HasBeenModified (
    other As IScriptSource
) As Boolean
bool HasBeenModified(
    IScriptSource^ other
)
abstract HasBeenModified :
        other : IScriptSource -> bool

Parameters

other
Type: Alternet.ScripterIScriptSource
IScriptSource to compare.

Return Value

Type: Boolean
True, if source has been changed since last compilation; otherwise false.
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.Reset Method

IScriptSourceReset Method
When implemented by a class, clears script source.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.WithDefaultReferences Method

IScriptSourceWithDefaultReferences Method
When implemented by a class, set default assembly references to the script source.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource WithDefaultReferences(
    ScriptTechnologyEnvironment technology = ScriptTechnologyEnvironment.WindowsForms,
    bool keepExisting = false
)
Function WithDefaultReferences (
    Optional technology As ScriptTechnologyEnvironment = ScriptTechnologyEnvironment.WindowsForms,
    Optional keepExisting As Boolean = false
) As IScriptSource
IScriptSource^ WithDefaultReferences(
    ScriptTechnologyEnvironment technology = ScriptTechnologyEnvironment::WindowsForms,
    bool keepExisting = false
)
abstract WithDefaultReferences :
        ?technology : ScriptTechnologyEnvironment *
        ?keepExisting : bool
(* Defaults:
        let _technology = defaultArg technology ScriptTechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
*)
-> IScriptSource

Parameters

technology (Optional)
Type: Alternet.ScripterScriptTechnologyEnvironment
Specifies technology platform
keepExisting (Optional)
Type: SystemBoolean
Specifies whether existing assemblies should be persisted.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource Properties

IScriptSource Properties

The IScriptSource type exposes the following members.

Properties
 | Name | Description
Public property | Changed | When implemented by a class, gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Conditionals | When implemented by a class, gets list of conditional compilation symbols.
Public property | Expression | When implemented by a class, gets expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | Files | When implemented by a class, gets list of files containing script to execute.
Public property | FrameworkPath | When implemented by a class, gets location of .NET Framework assemblies.
Public property | HasExpression | When implemented by a class, returns boolean value indicating whether ScriptSource contains expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | HasProject | When implemented by a class, returns boolean value indicating whether ScriptSource is associated with the project. (Inherited from IScriptSourceBase.)
Public property | HasScriptCode | When implemented by a class, returns boolean value indicating whether ScriptSource contains script code to execute. (Inherited from IScriptSourceBase.)
Public property | HasScriptFile | When implemented by a class, returns boolean value indicating whether ScriptSource contains script file to execute. (Inherited from IScriptSourceBase.)
Public property | Imports | When implemented by a class, gets list of namespaces to be used in the script.
Public property | IsWpfProject | When implemented by a class, returns boolean value indicating whether ScriptSource contains a Wpf project
Public property | Language | When implemented by a class, returns script programming language.
Public property | ProjectFileName | When implemented by a class, gets a file name of the Visual Studio project containing script files to execute. (Inherited from IScriptSourceBase.)
Public property | ProjectName | When implemented by a class, gets or sets name of the Visual Studio project containing script files to execute.
Public property | ProjectTargetFramework |
Public property | References | When implemented by a class, gets list of external assemblies referenced from the script.
Public property | Resources | When implemented by a class, gets list of embedded resource files.
Public property | RootNamespace | When implemented by a class, gets or sets root namespace to be used for manifest resources.
Public property | ScriptCode | When implemented by a class, gets script code to execute. (Inherited from IScriptSourceBase.)
Public property | ScriptFile | When implemented by a class, gets single script file to execute. (Inherited from IScriptSourceBase.)
Public property | SearchPaths | When implemented by a class, gets list of search directories to look for source files and referenced assemblies.
Public property | WpfResources | When implemented by a class, gets list of wpf resource files.
Top
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.Changed Property

IScriptSourceChanged Property
When implemented by a class, gets or sets boolean value indicating if script source has been modified since last compilation.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Changed { get; set; }
Property Changed As Boolean
    Get
    Set
property bool Changed {
    bool get ();
    void set (bool value);
}
abstract Changed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.Conditionals Property

IScriptSourceConditionals Property
When implemented by a class, gets list of conditional compilation symbols.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> Conditionals { get; }
ReadOnly Property Conditionals As IList(Of String)
    Get
property IList<String^>^ Conditionals {
    IList<String^>^ get ();
}
abstract Conditionals : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.Files Property

IScriptSourceFiles Property
When implemented by a class, gets list of files containing script to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> Files { get; }
ReadOnly Property Files As IList(Of String)
    Get
property IList<String^>^ Files {
    IList<String^>^ get ();
}
abstract Files : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.FrameworkPath Property

IScriptSourceFrameworkPath Property
When implemented by a class, gets location of .NET Framework assemblies.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FrameworkPath { get; set; }
Property FrameworkPath As String
    Get
    Set
property String^ FrameworkPath {
    String^ get ();
    void set (String^ value);
}
abstract FrameworkPath : string with get, set

Property Value

Type: String
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.Imports Property

IScriptSourceImports Property
When implemented by a class, gets list of namespaces to be used in the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> Imports { get; }
ReadOnly Property Imports As IList(Of String)
    Get
property IList<String^>^ Imports {
    IList<String^>^ get ();
}
abstract Imports : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.IsWpfProject Property

IScriptSourceIsWpfProject Property
When implemented by a class, returns boolean value indicating whether ScriptSource contains a Wpf project

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsWpfProject { get; }
ReadOnly Property IsWpfProject As Boolean
    Get
property bool IsWpfProject {
    bool get ();
}
abstract IsWpfProject : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.Language Property

IScriptSourceLanguage Property
When implemented by a class, returns script programming language.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptLanguage Language { get; }
ReadOnly Property Language As ScriptLanguage
    Get
property ScriptLanguage Language {
    ScriptLanguage get ();
}
abstract Language : ScriptLanguage with get

Property Value

Type: ScriptLanguage
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.ProjectName Property

IScriptSourceProjectName Property
When implemented by a class, gets or sets name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ProjectName { get; set; }
Property ProjectName As String
    Get
    Set
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}
abstract ProjectName : string with get, set

Property Value

Type: String
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.ProjectTargetFramework Property

IScriptSourceProjectTargetFramework Property

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TargetFramework ProjectTargetFramework { get; }
ReadOnly Property ProjectTargetFramework As TargetFramework
    Get
property TargetFramework^ ProjectTargetFramework {
    TargetFramework^ get ();
}
abstract ProjectTargetFramework : TargetFramework with get

Property Value

Type: TargetFramework
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.References Property

IScriptSourceReferences Property
When implemented by a class, gets list of external assemblies referenced from the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> References { get; }
ReadOnly Property References As IList(Of String)
    Get
property IList<String^>^ References {
    IList<String^>^ get ();
}
abstract References : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.Resources Property

IScriptSourceResources Property
When implemented by a class, gets list of embedded resource files.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> Resources { get; }
ReadOnly Property Resources As IList(Of String)
    Get
property IList<String^>^ Resources {
    IList<String^>^ get ();
}
abstract Resources : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.RootNamespace Property

IScriptSourceRootNamespace Property
When implemented by a class, gets or sets root namespace to be used for manifest resources.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string RootNamespace { get; set; }
Property RootNamespace As String
    Get
    Set
property String^ RootNamespace {
    String^ get ();
    void set (String^ value);
}
abstract RootNamespace : string with get, set

Property Value

Type: String
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.SearchPaths Property

IScriptSourceSearchPaths Property
When implemented by a class, gets list of search directories to look for source files and referenced assemblies.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> SearchPaths { get; }
ReadOnly Property SearchPaths As IList(Of String)
    Get
property IList<String^>^ SearchPaths {
    IList<String^>^ get ();
}
abstract SearchPaths : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSource.WpfResources Property

IScriptSourceWpfResources Property
When implemented by a class, gets list of wpf resource files.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> WpfResources { get; }
ReadOnly Property WpfResources As IList(Of String)
    Get
property IList<String^>^ WpfResources {
    IList<String^>^ get ();
}
abstract WpfResources : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter Namespace


IScriptSourceBase Interface

IScriptSourceBase Interface
Represents methods and properties to work with script text, files or projects.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptSourceBase
Public Interface IScriptSourceBase
public interface class IScriptSourceBase
type IScriptSourceBase =  interface end

The IScriptSourceBase type exposes the following members.

Properties
 | Name | Description
Public property | Expression | When implemented by a class, gets expression to evaluate.
Public property | HasExpression | When implemented by a class, returns boolean value indicating whether ScriptSource contains expression to evaluate.
Public property | HasProject | When implemented by a class, returns boolean value indicating whether ScriptSource is associated with the project.
Public property | HasScriptCode | When implemented by a class, returns boolean value indicating whether ScriptSource contains script code to execute.
Public property | HasScriptFile | When implemented by a class, returns boolean value indicating whether ScriptSource contains script file to execute.
Public property | ProjectFileName | When implemented by a class, gets a file name of the Visual Studio project containing script files to execute.
Public property | ScriptCode | When implemented by a class, gets script code to execute.
Public property | ScriptFile | When implemented by a class, gets single script file to execute.
Top
See Also

Reference

Alternet.Scripter Namespace


IScriptSourceBase Properties

IScriptSourceBase Properties

The IScriptSourceBase type exposes the following members.

Properties
 | Name | Description
Public property | Expression | When implemented by a class, gets expression to evaluate.
Public property | HasExpression | When implemented by a class, returns boolean value indicating whether ScriptSource contains expression to evaluate.
Public property | HasProject | When implemented by a class, returns boolean value indicating whether ScriptSource is associated with the project.
Public property | HasScriptCode | When implemented by a class, returns boolean value indicating whether ScriptSource contains script code to execute.
Public property | HasScriptFile | When implemented by a class, returns boolean value indicating whether ScriptSource contains script file to execute.
Public property | ProjectFileName | When implemented by a class, gets a file name of the Visual Studio project containing script files to execute.
Public property | ScriptCode | When implemented by a class, gets script code to execute.
Public property | ScriptFile | When implemented by a class, gets single script file to execute.
Top
See Also

Reference

IScriptSourceBase Interface
Alternet.Scripter Namespace


IScriptSourceBase.Expression Property

IScriptSourceBaseExpression Property
When implemented by a class, gets expression to evaluate.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Expression { get; }
ReadOnly Property Expression As String
    Get
property String^ Expression {
    String^ get ();
}
abstract Expression : string with get

Property Value

Type: String
See Also

Reference

IScriptSourceBase Interface
Alternet.Scripter Namespace


IScriptSourceBase.HasExpression Property

IScriptSourceBaseHasExpression Property
When implemented by a class, returns boolean value indicating whether ScriptSource contains expression to evaluate.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasExpression { get; }
ReadOnly Property HasExpression As Boolean
    Get
property bool HasExpression {
    bool get ();
}
abstract HasExpression : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptSourceBase Interface
Alternet.Scripter Namespace


IScriptSourceBase.HasProject Property

IScriptSourceBaseHasProject Property
When implemented by a class, returns boolean value indicating whether ScriptSource is associated with the project.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasProject { get; }
ReadOnly Property HasProject As Boolean
    Get
property bool HasProject {
    bool get ();
}
abstract HasProject : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptSourceBase Interface
Alternet.Scripter Namespace


IScriptSourceBase.HasScriptCode Property

IScriptSourceBaseHasScriptCode Property
When implemented by a class, returns boolean value indicating whether ScriptSource contains script code to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasScriptCode { get; }
ReadOnly Property HasScriptCode As Boolean
    Get
property bool HasScriptCode {
    bool get ();
}
abstract HasScriptCode : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptSourceBase Interface
Alternet.Scripter Namespace


IScriptSourceBase.HasScriptFile Property

IScriptSourceBaseHasScriptFile Property
When implemented by a class, returns boolean value indicating whether ScriptSource contains script file to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasScriptFile { get; }
ReadOnly Property HasScriptFile As Boolean
    Get
property bool HasScriptFile {
    bool get ();
}
abstract HasScriptFile : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptSourceBase Interface
Alternet.Scripter Namespace


IScriptSourceBase.ProjectFileName Property

IScriptSourceBaseProjectFileName Property
When implemented by a class, gets a file name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ProjectFileName { get; }
ReadOnly Property ProjectFileName As String
    Get
property String^ ProjectFileName {
    String^ get ();
}
abstract ProjectFileName : string with get

Property Value

Type: String
See Also

Reference

IScriptSourceBase Interface
Alternet.Scripter Namespace


IScriptSourceBase.ScriptCode Property

IScriptSourceBaseScriptCode Property
When implemented by a class, gets script code to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ScriptCode { get; }
ReadOnly Property ScriptCode As String
    Get
property String^ ScriptCode {
    String^ get ();
}
abstract ScriptCode : string with get

Property Value

Type: String
See Also

Reference

IScriptSourceBase Interface
Alternet.Scripter Namespace


IScriptSourceBase.ScriptFile Property

IScriptSourceBaseScriptFile Property
When implemented by a class, gets single script file to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ScriptFile { get; }
ReadOnly Property ScriptFile As String
    Get
property String^ ScriptFile {
    String^ get ();
}
abstract ScriptFile : string with get

Property Value

Type: String
See Also

Reference

IScriptSourceBase Interface
Alternet.Scripter Namespace


ResolveReferenceEventArgs Class

ResolveReferenceEventArgs Class
Provides data for the IScriptRun.ReferenceResolve event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.ScripterResolveReferenceEventArgs

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ResolveReferenceEventArgs : EventArgs
Public Class ResolveReferenceEventArgs
    Inherits EventArgs
public ref class ResolveReferenceEventArgs : public EventArgs
type ResolveReferenceEventArgs =
    class
        inherit EventArgs
    end

The ResolveReferenceEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveReferenceEventArgs | Initializes a new instance of the ResolveReferenceEventArgs class with specified reference.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyImage | Gets or sets stream suitable Assembly Image.
Public property | AssemblyLocation | Gets or sets suitable Assembly.
Public property | Handled | Gets or sets a value indicating whether the ReferenceResolve event was handled.
Public property | Reference | Gets or sets reference to be resolved.
Top
See Also

Reference

Alternet.Scripter Namespace


ResolveReferenceEventArgs Constructor

ResolveReferenceEventArgs Constructor
Initializes a new instance of the ResolveReferenceEventArgs class with specified reference.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResolveReferenceEventArgs(
    string reference
)
Public Sub New (
    reference As String
)
public:
ResolveReferenceEventArgs(
    String^ reference
)
new :
        reference : string -> ResolveReferenceEventArgs

Parameters

reference
Type: SystemString
Reference to resolve.
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter Namespace


ResolveReferenceEventArgs Methods

ResolveReferenceEventArgs Methods

The ResolveReferenceEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter Namespace


ResolveReferenceEventArgs Properties

ResolveReferenceEventArgs Properties

The ResolveReferenceEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyImage | Gets or sets stream suitable Assembly Image.
Public property | AssemblyLocation | Gets or sets suitable Assembly.
Public property | Handled | Gets or sets a value indicating whether the ReferenceResolve event was handled.
Public property | Reference | Gets or sets reference to be resolved.
Top
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter Namespace


ResolveReferenceEventArgs.AssemblyImage Property

ResolveReferenceEventArgsAssemblyImage Property
Gets or sets stream suitable Assembly Image.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] AssemblyImage { get; set; }
Public Property AssemblyImage As Byte()
    Get
    Set
public:
property array<unsigned char>^ AssemblyImage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member AssemblyImage : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter Namespace


ResolveReferenceEventArgs.AssemblyLocation Property

ResolveReferenceEventArgsAssemblyLocation Property
Gets or sets suitable Assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyLocation { get; set; }
Public Property AssemblyLocation As String
    Get
    Set
public:
property String^ AssemblyLocation {
    String^ get ();
    void set (String^ value);
}
member AssemblyLocation : string with get, set

Property Value

Type: String
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter Namespace


ResolveReferenceEventArgs.Handled Property

ResolveReferenceEventArgsHandled Property
Gets or sets a value indicating whether the ReferenceResolve event was handled.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter Namespace


ResolveReferenceEventArgs.Reference Property

ResolveReferenceEventArgsReference Property
Gets or sets reference to be resolved.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Reference { get; set; }
Public Property Reference As String
    Get
    Set
public:
property String^ Reference {
    String^ get ();
    void set (String^ value);
}
member Reference : string with get, set

Property Value

Type: String
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter Namespace


ScriptAssemblyKind Enumeration

ScriptAssemblyKind Enumeration
Defines programming language used by the script engine.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptAssemblyKind
Public Enumeration ScriptAssemblyKind
public enum class ScriptAssemblyKind
type ScriptAssemblyKind
Members
Member name | Value | Description
WindowsApplication | 0 | Specifies windows executable.
ConsoleApplication | 1 | Specifies console application.
DynamicLibrary | 2 | Specifies dynamic linked library.
WebApplication | 3 | Specifies Web application.
See Also

Reference

Alternet.Scripter Namespace


ScriptCompilationDiagnostic Structure

ScriptCompilationDiagnostic Structure
Provides data for compiler error.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct ScriptCompilationDiagnostic
<SerializableAttribute>
Public Structure ScriptCompilationDiagnostic
[SerializableAttribute]
public value class ScriptCompilationDiagnostic
[<SealedAttribute>]
[<SerializableAttribute>]
type ScriptCompilationDiagnostic =  struct end

The ScriptCompilationDiagnostic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the diagnostic. (Overrides ValueTypeToString.)
Top
Properties
 | Name | Description
Public property | Code | Gets or sets string of code related to diagnostic.
Public property | Column | Gets or sets column number of diagnostic.
Public property | FileName | Gets or sets name of file of diagnostic.
Public property | IsEmpty | Gets a boolean value indicating whether diagnostic is empty (contains no data).
Public property | Kind | Gets or sets diagnostic's kind.
Public property | Line | Gets or sets line number of diagnostic.
Public property | Message | Gets or sets message describes compilation error.
 | Zero | Gets an empty ScriptCompilationDiagnostic object.
Top
See Also

Reference

Alternet.Scripter Namespace


ScriptCompilationDiagnostic Methods

ScriptCompilationDiagnostic Methods

The ScriptCompilationDiagnostic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the diagnostic. (Overrides ValueTypeToString.)
Top
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic.ToString Method

ScriptCompilationDiagnosticToString Method
Returns a String that represents the diagnostic.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents the ScriptCompilationDiagnostic.
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic Properties

ScriptCompilationDiagnostic Properties

The ScriptCompilationDiagnostic type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets or sets string of code related to diagnostic.
Public property | Column | Gets or sets column number of diagnostic.
Public property | FileName | Gets or sets name of file of diagnostic.
Public property | IsEmpty | Gets a boolean value indicating whether diagnostic is empty (contains no data).
Public property | Kind | Gets or sets diagnostic's kind.
Public property | Line | Gets or sets line number of diagnostic.
Public property | Message | Gets or sets message describes compilation error.
 | Zero | Gets an empty ScriptCompilationDiagnostic object.
Top
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic.Code Property

ScriptCompilationDiagnosticCode Property
Gets or sets string of code related to diagnostic.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Property Value

Type: String
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic.Column Property

ScriptCompilationDiagnosticColumn Property
Gets or sets column number of diagnostic.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Column { get; set; }
Public Property Column As Integer
    Get
    Set
public:
property int Column {
    int get ();
    void set (int value);
}
member Column : int with get, set

Property Value

Type: Int32
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic.FileName Property

ScriptCompilationDiagnosticFileName Property
Gets or sets name of file of diagnostic.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic.IsEmpty Property

ScriptCompilationDiagnosticIsEmpty Property
Gets a boolean value indicating whether diagnostic is empty (contains no data).

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic.Kind Property

ScriptCompilationDiagnosticKind Property
Gets or sets diagnostic's kind.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCompilationDiagnosticKind Kind { get; set; }
Public Property Kind As ScriptCompilationDiagnosticKind
    Get
    Set
public:
property ScriptCompilationDiagnosticKind Kind {
    ScriptCompilationDiagnosticKind get ();
    void set (ScriptCompilationDiagnosticKind value);
}
member Kind : ScriptCompilationDiagnosticKind with get, set

Property Value

Type: ScriptCompilationDiagnosticKind
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic.Line Property

ScriptCompilationDiagnosticLine Property
Gets or sets line number of diagnostic.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic.Message Property

ScriptCompilationDiagnosticMessage Property
Gets or sets message describes compilation error.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnostic.Zero Property

ScriptCompilationDiagnosticZero Property
Gets an empty ScriptCompilationDiagnostic object.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptCompilationDiagnostic Zero { get; }
Public Shared ReadOnly Property Zero As ScriptCompilationDiagnostic
    Get
public:
static property ScriptCompilationDiagnostic Zero {
    ScriptCompilationDiagnostic get ();
}
static member Zero : ScriptCompilationDiagnostic with get

Property Value

Type: ScriptCompilationDiagnostic
See Also

Reference

ScriptCompilationDiagnostic Structure
Alternet.Scripter Namespace


ScriptCompilationDiagnosticKind Enumeration

ScriptCompilationDiagnosticKind Enumeration
Defines script error severity

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptCompilationDiagnosticKind
Public Enumeration ScriptCompilationDiagnosticKind
public enum class ScriptCompilationDiagnosticKind
type ScriptCompilationDiagnosticKind
Members
Member name | Value | Description
Error | 0 | Represents compiler error
Warning | 1 | Represents compiler warning
Info | 2 | Represents information message
See Also

Reference

Alternet.Scripter Namespace


ScriptCompilationResult Structure

ScriptCompilationResult Structure
Represent structured information of code compilation result.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct ScriptCompilationResult
<SerializableAttribute>
Public Structure ScriptCompilationResult
[SerializableAttribute]
public value class ScriptCompilationResult
[<SealedAttribute>]
[<SerializableAttribute>]
type ScriptCompilationResult =  struct end

The ScriptCompilationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Properties
 | Name | Description
Public property | Errors | When implemented by a class, represents errors collection.
Public property | IsSuccessful | When implemented by a class, represents a value indicating whether compilation was successful.
Public property | TargetAssemblyName | When implemented by a class, represents fully qualified name of the compiled assembly.
Top
See Also

Reference

Alternet.Scripter Namespace


ScriptCompilationResult Methods

ScriptCompilationResult Methods

The ScriptCompilationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ScriptCompilationResult Structure
Alternet.Scripter Namespace


ScriptCompilationResult Properties

ScriptCompilationResult Properties

The ScriptCompilationResult type exposes the following members.

Properties
 | Name | Description
Public property | Errors | When implemented by a class, represents errors collection.
Public property | IsSuccessful | When implemented by a class, represents a value indicating whether compilation was successful.
Public property | TargetAssemblyName | When implemented by a class, represents fully qualified name of the compiled assembly.
Top
See Also

Reference

ScriptCompilationResult Structure
Alternet.Scripter Namespace


ScriptCompilationResult.Errors Property

ScriptCompilationResultErrors Property
When implemented by a class, represents errors collection.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCompilationDiagnostic[] Errors { get; set; }
Public Property Errors As ScriptCompilationDiagnostic()
    Get
    Set
public:
property array<ScriptCompilationDiagnostic>^ Errors {
    array<ScriptCompilationDiagnostic>^ get ();
    void set (array<ScriptCompilationDiagnostic>^ value);
}
member Errors : ScriptCompilationDiagnostic[] with get, set

Property Value

Type: ScriptCompilationDiagnostic
See Also

Reference

ScriptCompilationResult Structure
Alternet.Scripter Namespace


ScriptCompilationResult.IsSuccessful Property

ScriptCompilationResultIsSuccessful Property
When implemented by a class, represents a value indicating whether compilation was successful.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSuccessful { get; set; }
Public Property IsSuccessful As Boolean
    Get
    Set
public:
property bool IsSuccessful {
    bool get ();
    void set (bool value);
}
member IsSuccessful : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScriptCompilationResult Structure
Alternet.Scripter Namespace


ScriptCompilationResult.TargetAssemblyName Property

ScriptCompilationResultTargetAssemblyName Property
When implemented by a class, represents fully qualified name of the compiled assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetAssemblyName { get; set; }
Public Property TargetAssemblyName As String
    Get
    Set
public:
property String^ TargetAssemblyName {
    String^ get ();
    void set (String^ value);
}
member TargetAssemblyName : string with get, set

Property Value

Type: String
See Also

Reference

ScriptCompilationResult Structure
Alternet.Scripter Namespace


ScriptCompiledDelegate Delegate

ScriptCompiledDelegate Delegate
Delegate for notification of remote control about the end of the compilation process.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ScriptCompiledDelegate(
    ScriptCompilationResult result
)
Public Delegate Sub ScriptCompiledDelegate (
    result As ScriptCompilationResult
)
public delegate void ScriptCompiledDelegate(
    ScriptCompilationResult result
)
type ScriptCompiledDelegate =
    delegate of
        result : ScriptCompilationResult -> unit

Parameters

result
Type: Alternet.ScripterScriptCompilationResult
Contains result of the compilation.
See Also

Reference

Alternet.Scripter Namespace


ScriptConsts Class

ScriptConsts Class
Contains constants related to Scripter component.
Inheritance Hierarchy
SystemObject
Alternet.ScripterScriptConsts

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptConsts
Public Class ScriptConsts
public ref class ScriptConsts
type ScriptConsts =  class end

The ScriptConsts type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptConsts | Initializes a new instance of the ScriptConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
CSharpExpressionCode |
CSharpExpressionCodeGlobals |
CSharpGlobalCode |
CSharpGlobalField |
DefaultCSharpExtension |
DefaultCSharpProjectExtension |
DefaultCSharpScriptExtension |
DefaultModuleGeneratedDirectory |
DefaultVisualBasicExtension |
DefaultVisualBasicProjectExtension |
DefaultVisualBasicScriptExtension |
EvaluateExpressionMethod |
GlobalClassName |
GlobalCSharpFile |
GlobalVisualBasicFile |
VisualBasicExpressionCode |
VisualBasicGlobalCode |
VisualBasicGlobalField |
Top
See Also

Reference

Alternet.Scripter Namespace


ScriptConsts Constructor

ScriptConsts Constructor
Initializes a new instance of the ScriptConsts class

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptConsts()
Public Sub New
public:
ScriptConsts()
new : unit -> ScriptConsts
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts Fields

ScriptConsts Fields

The ScriptConsts type exposes the following members.

Fields
Name | Description
CSharpExpressionCode |
CSharpExpressionCodeGlobals |
CSharpGlobalCode |
CSharpGlobalField |
DefaultCSharpExtension |
DefaultCSharpProjectExtension |
DefaultCSharpScriptExtension |
DefaultModuleGeneratedDirectory |
DefaultVisualBasicExtension |
DefaultVisualBasicProjectExtension |
DefaultVisualBasicScriptExtension |
EvaluateExpressionMethod |
GlobalClassName |
GlobalCSharpFile |
GlobalVisualBasicFile |
VisualBasicExpressionCode |
VisualBasicGlobalCode |
VisualBasicGlobalField |
Top
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.CSharpExpressionCode Field

ScriptConstsCSharpExpressionCode Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CSharpExpressionCode
Public Shared CSharpExpressionCode As String
public:
static String^ CSharpExpressionCode
static val mutable CSharpExpressionCode: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.CSharpExpressionCodeGlobals Field

ScriptConstsCSharpExpressionCodeGlobals Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CSharpExpressionCodeGlobals
Public Shared CSharpExpressionCodeGlobals As String
public:
static String^ CSharpExpressionCodeGlobals
static val mutable CSharpExpressionCodeGlobals: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.CSharpGlobalCode Field

ScriptConstsCSharpGlobalCode Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CSharpGlobalCode
Public Shared CSharpGlobalCode As String
public:
static String^ CSharpGlobalCode
static val mutable CSharpGlobalCode: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.CSharpGlobalField Field

ScriptConstsCSharpGlobalField Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CSharpGlobalField
Public Shared CSharpGlobalField As String
public:
static String^ CSharpGlobalField
static val mutable CSharpGlobalField: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.DefaultCSharpExtension Field

ScriptConstsDefaultCSharpExtension Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultCSharpExtension
Public Const DefaultCSharpExtension As String
public:
literal String^ DefaultCSharpExtension
static val mutable DefaultCSharpExtension: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.DefaultCSharpProjectExtension Field

ScriptConstsDefaultCSharpProjectExtension Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultCSharpProjectExtension
Public Const DefaultCSharpProjectExtension As String
public:
literal String^ DefaultCSharpProjectExtension
static val mutable DefaultCSharpProjectExtension: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.DefaultCSharpScriptExtension Field

ScriptConstsDefaultCSharpScriptExtension Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultCSharpScriptExtension
Public Const DefaultCSharpScriptExtension As String
public:
literal String^ DefaultCSharpScriptExtension
static val mutable DefaultCSharpScriptExtension: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.DefaultModuleGeneratedDirectory Field

ScriptConstsDefaultModuleGeneratedDirectory Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultModuleGeneratedDirectory
Public Shared DefaultModuleGeneratedDirectory As String
public:
static String^ DefaultModuleGeneratedDirectory
static val mutable DefaultModuleGeneratedDirectory: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.DefaultVisualBasicExtension Field

ScriptConstsDefaultVisualBasicExtension Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultVisualBasicExtension
Public Const DefaultVisualBasicExtension As String
public:
literal String^ DefaultVisualBasicExtension
static val mutable DefaultVisualBasicExtension: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.DefaultVisualBasicProjectExtension Field

ScriptConstsDefaultVisualBasicProjectExtension Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultVisualBasicProjectExtension
Public Const DefaultVisualBasicProjectExtension As String
public:
literal String^ DefaultVisualBasicProjectExtension
static val mutable DefaultVisualBasicProjectExtension: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.DefaultVisualBasicScriptExtension Field

ScriptConstsDefaultVisualBasicScriptExtension Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultVisualBasicScriptExtension
Public Const DefaultVisualBasicScriptExtension As String
public:
literal String^ DefaultVisualBasicScriptExtension
static val mutable DefaultVisualBasicScriptExtension: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.EvaluateExpressionMethod Field

ScriptConstsEvaluateExpressionMethod Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EvaluateExpressionMethod
Public Shared EvaluateExpressionMethod As String
public:
static String^ EvaluateExpressionMethod
static val mutable EvaluateExpressionMethod: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.GlobalClassName Field

ScriptConstsGlobalClassName Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GlobalClassName
Public Shared GlobalClassName As String
public:
static String^ GlobalClassName
static val mutable GlobalClassName: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.GlobalCSharpFile Field

ScriptConstsGlobalCSharpFile Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string GlobalCSharpFile
Public Const GlobalCSharpFile As String
public:
literal String^ GlobalCSharpFile
static val mutable GlobalCSharpFile: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.GlobalVisualBasicFile Field

ScriptConstsGlobalVisualBasicFile Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string GlobalVisualBasicFile
Public Const GlobalVisualBasicFile As String
public:
literal String^ GlobalVisualBasicFile
static val mutable GlobalVisualBasicFile: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.VisualBasicExpressionCode Field

ScriptConstsVisualBasicExpressionCode Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VisualBasicExpressionCode
Public Shared VisualBasicExpressionCode As String
public:
static String^ VisualBasicExpressionCode
static val mutable VisualBasicExpressionCode: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.VisualBasicGlobalCode Field

ScriptConstsVisualBasicGlobalCode Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VisualBasicGlobalCode
Public Shared VisualBasicGlobalCode As String
public:
static String^ VisualBasicGlobalCode
static val mutable VisualBasicGlobalCode: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts.VisualBasicGlobalField Field

ScriptConstsVisualBasicGlobalField Field

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string VisualBasicGlobalField
Public Shared VisualBasicGlobalField As String
public:
static String^ VisualBasicGlobalField
static val mutable VisualBasicGlobalField: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptConsts Methods

ScriptConsts Methods

The ScriptConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptConsts Class
Alternet.Scripter Namespace


ScriptErrorEventArgs Class

ScriptErrorEventArgs Class
Provides data for the IScriptHost.ScriptError and IScriptRun.ScriptError events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.ScripterScriptErrorEventArgs

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptErrorEventArgs : EventArgs
Public Class ScriptErrorEventArgs
    Inherits EventArgs
public ref class ScriptErrorEventArgs : public EventArgs
type ScriptErrorEventArgs =
    class
        inherit EventArgs
    end

The ScriptErrorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptErrorEventArgs(String) | Initializes a new instance of the ScriptErrorArgs class with specified parameter.
Public method | ScriptErrorEventArgs(ScriptCompilationDiagnostic) | Initializes a new instance of the ScriptErrorArgs class with specified parameter.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorMessage | Gets a message that describes the current error.
Public property | Errors | Represents errors collection.
Public property | Handled | Gets or sets a value indicating whether the error event was handled.
Top
See Also

Reference

Alternet.Scripter Namespace


ScriptErrorEventArgs Constructor

ScriptErrorEventArgs Constructor
Overload List
 | Name | Description
Public method | ScriptErrorEventArgs(String) | Initializes a new instance of the ScriptErrorArgs class with specified parameter.
Public method | ScriptErrorEventArgs(ScriptCompilationDiagnostic) | Initializes a new instance of the ScriptErrorArgs class with specified parameter.
Top
See Also

Reference

ScriptErrorEventArgs Class
Alternet.Scripter Namespace


ScriptErrorEventArgs Constructor (String)

ScriptErrorEventArgs Constructor (String)
Initializes a new instance of the ScriptErrorArgs class with specified parameter.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptErrorEventArgs(
    string errorMessage
)
Public Sub New (
    errorMessage As String
)
public:
ScriptErrorEventArgs(
    String^ errorMessage
)
new :
        errorMessage : string -> ScriptErrorEventArgs

Parameters

errorMessage
Type: SystemString
Specifies error information for the new instance.
See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Overload
Alternet.Scripter Namespace


ScriptErrorEventArgs Constructor (ScriptCompilationDiagnostic[])

ScriptErrorEventArgs Constructor (ScriptCompilationDiagnostic)
Initializes a new instance of the ScriptErrorArgs class with specified parameter.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptErrorEventArgs(
    ScriptCompilationDiagnostic[] errors
)
Public Sub New (
    errors As ScriptCompilationDiagnostic()
)
public:
ScriptErrorEventArgs(
    array<ScriptCompilationDiagnostic>^ errors
)
new :
        errors : ScriptCompilationDiagnostic[] -> ScriptErrorEventArgs

Parameters

errors
Type: Alternet.ScripterScriptCompilationDiagnostic
Specifies collection of errors.
See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Overload
Alternet.Scripter Namespace


ScriptErrorEventArgs Methods

ScriptErrorEventArgs Methods

The ScriptErrorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptErrorEventArgs Class
Alternet.Scripter Namespace


ScriptErrorEventArgs Properties

ScriptErrorEventArgs Properties

The ScriptErrorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Gets a message that describes the current error.
Public property | Errors | Represents errors collection.
Public property | Handled | Gets or sets a value indicating whether the error event was handled.
Top
See Also

Reference

ScriptErrorEventArgs Class
Alternet.Scripter Namespace


ScriptErrorEventArgs.ErrorMessage Property

ScriptErrorEventArgsErrorMessage Property
Gets a message that describes the current error.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
public:
property String^ ErrorMessage {
    String^ get ();
}
member ErrorMessage : string with get

Property Value

Type: String
See Also

Reference

ScriptErrorEventArgs Class
Alternet.Scripter Namespace


ScriptErrorEventArgs.Errors Property

ScriptErrorEventArgsErrors Property
Represents errors collection.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCompilationDiagnostic[] Errors { get; }
Public ReadOnly Property Errors As ScriptCompilationDiagnostic()
    Get
public:
property array<ScriptCompilationDiagnostic>^ Errors {
    array<ScriptCompilationDiagnostic>^ get ();
}
member Errors : ScriptCompilationDiagnostic[] with get

Property Value

Type: ScriptCompilationDiagnostic
See Also

Reference

ScriptErrorEventArgs Class
Alternet.Scripter Namespace


ScriptErrorEventArgs.Handled Property

ScriptErrorEventArgsHandled Property
Gets or sets a value indicating whether the error event was handled.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScriptErrorEventArgs Class
Alternet.Scripter Namespace


ScriptFinishedDelegate Delegate

ScriptFinishedDelegate Delegate
Delegate for notification of remote control about the end of the script execution.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ScriptFinishedDelegate()
Public Delegate Sub ScriptFinishedDelegate
public delegate void ScriptFinishedDelegate()
type ScriptFinishedDelegate =
    delegate of unit -> unit
See Also

Reference

Alternet.Scripter Namespace


ScriptGlobalItem Class

ScriptGlobalItem Class
Describes a global object from the script.
Inheritance Hierarchy
SystemObject
Alternet.ScripterScriptGlobalItem

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptGlobalItem : IScriptGlobalItem
Public Class ScriptGlobalItem
    Implements IScriptGlobalItem
public ref class ScriptGlobalItem : IScriptGlobalItem
type ScriptGlobalItem =
    class
        interface IScriptGlobalItem
    end

The ScriptGlobalItem type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptGlobalItem | Initializes a new instance of the ScriptItem class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets name of this item.
Public property | Obj | Gets or sets object contained by this item.
Public property | Type | Gets or sets string representation of Obj type.
Top
See Also

Reference

Alternet.Scripter Namespace


ScriptGlobalItem Constructor

ScriptGlobalItem Constructor
Initializes a new instance of the ScriptItem class with specified parameters.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptGlobalItem(
    string name,
    Type type = null,
    Object obj = null
)
Public Sub New (
    name As String,
    Optional type As Type = Nothing,
    Optional obj As Object = Nothing
)
public:
ScriptGlobalItem(
    String^ name,
    Type^ type = nullptr,
    Object^ obj = nullptr
)
new :
        name : string *
        ?type : Type *
        ?obj : Object
(* Defaults:
        let _type = defaultArg type null
        let _obj = defaultArg obj null
*)
-> ScriptGlobalItem

Parameters

name
Type: SystemString
Specifies name of the new instance.
type (Optional)
Type: SystemType
Specifies type of the object.
obj (Optional)
Type: SystemObject
Specifies object the new instance should contain.
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter Namespace


ScriptGlobalItem Methods

ScriptGlobalItem Methods

The ScriptGlobalItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter Namespace


ScriptGlobalItem Properties

ScriptGlobalItem Properties

The ScriptGlobalItem type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets name of this item.
Public property | Obj | Gets or sets object contained by this item.
Public property | Type | Gets or sets string representation of Obj type.
Top
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter Namespace


ScriptGlobalItem.Name Property

ScriptGlobalItemName Property
Gets or sets name of this item.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IScriptGlobalItemName
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter Namespace


ScriptGlobalItem.Obj Property

ScriptGlobalItemObj Property
Gets or sets object contained by this item.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Obj { get; set; }
Public Overridable Property Obj As Object
    Get
    Set
public:
virtual property Object^ Obj {
    Object^ get ();
    void set (Object^ value);
}
abstract Obj : Object with get, set
override Obj : Object with get, set

Property Value

Type: Object

Implements

IScriptGlobalItemObj
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter Namespace


ScriptGlobalItem.Type Property

ScriptGlobalItemType Property
Gets or sets string representation of Obj type.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Type Type { get; set; }
Public Overridable Property Type As Type
    Get
    Set
public:
virtual property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}
abstract Type : Type with get, set
override Type : Type with get, set

Property Value

Type: Type

Implements

IScriptGlobalItemType
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter Namespace


ScriptHost Class

ScriptHost Class
Provides a base class for script execution. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.ScripterScriptHost
Alternet.Scripter.CodeDOMCodeDOMScriptHost
Alternet.Scripter.RoslynRoslynScriptHost

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ScriptHost : IScriptHost,
    IDisposable
Public MustInherit Class ScriptHost
    Implements IScriptHost, IDisposable
public ref class ScriptHost abstract : IScriptHost,
    IDisposable
[<AbstractClassAttribute>]
type ScriptHost =
    class
        interface IScriptHost
        interface IDisposable
    end

The ScriptHost type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptHost | Initializes a new instance of ScriptHost with specified script runner.
Top
Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | CopyReferencedAssemblies | Copies all non-GAC assemblies referenced by a script to the output directories.
 | DetermineTargetPlatform | Determines target application platform.
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime |
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers.
Public method | ResolveReferences | Returns list of assembly references used by the script.
Public method | ResolveReferences(IListString) | Returns list of assembly references used by the script.
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunMethod | Executes specified method.
Public method | RunMethodAsync | Executes specified method asynchronously.
Public method | RunProcess | Executes script starting from the main entry point in standalone process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyFileName | Gets script assembly file name.
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed.
Public property | ExecutableModulePath | Gets script assembly path.
Public property | GenerateModulesOnDisk | Gets or sets value indicating whether script assembly should be written to the disk or kept in memory.
Public property | GlobalCode | Gets a global code required for global items.
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies.
Public property | ReuseCompiledModulesFromDisk | Gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date.
Public property | ScriptAssembly | Returns compiled script assembly.
Public property | ScriptRun | Gets IScriptRun associated this script host.
Top
See Also

Reference

Alternet.Scripter Namespace


ScriptHost Constructor

ScriptHost Constructor
Initializes a new instance of ScriptHost with specified script runner.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptHost(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
ScriptHost(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> ScriptHost

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost Methods

ScriptHost Methods

The ScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | CopyReferencedAssemblies | Copies all non-GAC assemblies referenced by a script to the output directories.
 | DetermineTargetPlatform | Determines target application platform.
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime |
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers.
Public method | ResolveReferences | Returns list of assembly references used by the script.
Public method | ResolveReferences(IListString) | Returns list of assembly references used by the script.
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunMethod | Executes specified method.
Public method | RunMethodAsync | Executes specified method asynchronously.
Public method | RunProcess | Executes script starting from the main entry point in standalone process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.Compile Method

ScriptHostCompile Method
Initializes script engine and compiles the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compile(
    bool copyReferences = true
)
Public Overridable Function Compile (
    Optional copyReferences As Boolean = true
) As Boolean
public:
virtual bool Compile(
    bool copyReferences = true
)
abstract Compile :
        ?copyReferences : bool
(* Defaults:
        let _copyReferences = defaultArg copyReferences true
*)
-> bool
override Compile :
        ?copyReferences : bool
(* Defaults:
        let _copyReferences = defaultArg copyReferences true
*)
-> bool

Parameters

copyReferences (Optional)
Type: SystemBoolean
Specifies if all required assemblies should be copied to the output location

Return Value

Type: Boolean
True if succeed, otherwise false.

Implements

IScriptHostCompile(Boolean)
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.CopyReferencedAssemblies Method

ScriptHostCopyReferencedAssemblies Method
Copies all non-GAC assemblies referenced by a script to the output directories.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CopyReferencedAssemblies()
Public Overridable Sub CopyReferencedAssemblies
public:
virtual void CopyReferencedAssemblies()
abstract CopyReferencedAssemblies : unit -> unit
override CopyReferencedAssemblies : unit -> unit

Implements

IScriptHostCopyReferencedAssemblies
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.DetermineTargetPlatform Method

ScriptHostDetermineTargetPlatform Method
Determines target application platform.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptPlatform DetermineTargetPlatform(
    ScriptAssemblyKind assemblyKind
)
Public Shared Function DetermineTargetPlatform (
    assemblyKind As ScriptAssemblyKind
) As ScriptPlatform
public:
static ScriptPlatform DetermineTargetPlatform(
    ScriptAssemblyKind assemblyKind
)
static member DetermineTargetPlatform :
        assemblyKind : ScriptAssemblyKind -> ScriptPlatform

Parameters

assemblyKind
Type: Alternet.ScripterScriptAssemblyKind

Return Value

Type: ScriptPlatform
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.Dispose Method

ScriptHostDispose Method
Disposes this ScriptHost and frees resources associated with it.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.EvaluateExpression Method

ScriptHostEvaluateExpression Method
Evaluates specified expression.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object EvaluateExpression(
    string expression
)
Public Overridable Function EvaluateExpression (
    expression As String
) As Object
public:
virtual Object^ EvaluateExpression(
    String^ expression
)
abstract EvaluateExpression :
        expression : string -> Object
override EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.

Implements

IScriptHostEvaluateExpression(String)
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.EvaluateExpressionAsync Method

ScriptHostEvaluateExpressionAsync Method
Evaluates specified expression asynchronously.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Public Overridable Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.

Implements

IScriptHostEvaluateExpressionAsync(String, CancellationToken)
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.ReferencesDotNetCoreRuntime Method

ScriptHostReferencesDotNetCoreRuntime Method

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract bool ReferencesDotNetCoreRuntime(
    out Version dotNetCoreVersion
)
Public MustOverride Function ReferencesDotNetCoreRuntime (
    <OutAttribute> ByRef dotNetCoreVersion As Version
) As Boolean
public:
virtual bool ReferencesDotNetCoreRuntime(
    [OutAttribute] Version^% dotNetCoreVersion
) abstract
abstract ReferencesDotNetCoreRuntime :
        dotNetCoreVersion : Version byref -> bool

Parameters

dotNetCoreVersion
Type: SystemVersion

Return Value

Type: Boolean

Implements

IScriptHostReferencesDotNetCoreRuntime(Version)
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.Reset Method

ScriptHostReset Method
Removes the script engine from the running state and disconnects automatically bound event handlers.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptHostReset
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.ResolveReferences Method

ScriptHostResolveReferences Method
Overload List
 | Name | Description
Public method | ResolveReferences | Returns list of assembly references used by the script.
Public method | ResolveReferences(IListString) | Returns list of assembly references used by the script.
Top
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.ResolveReferences Method

ScriptHostResolveReferences Method
Returns list of assembly references used by the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<string> ResolveReferences()
Public Overridable Function ResolveReferences As IList(Of String)
public:
virtual IList<String^>^ ResolveReferences()
abstract ResolveReferences : unit -> IList<string>
override ResolveReferences : unit -> IList<string>

Return Value

Type: IListString
List of assembly references.

Implements

IScriptHostResolveReferences
See Also

Reference

ScriptHost Class
ResolveReferences Overload
Alternet.Scripter Namespace


ScriptHost.ResolveReferences Method (IList(String))

ScriptHostResolveReferences Method (IListString)
Returns list of assembly references used by the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<string> ResolveReferences(
    IList<string> unresolvedReferences
)
Public Overridable Function ResolveReferences (
    unresolvedReferences As IList(Of String)
) As IList(Of String)
public:
virtual IList<String^>^ ResolveReferences(
    IList<String^>^ unresolvedReferences
)
abstract ResolveReferences :
        unresolvedReferences : IList<string> -> IList<string>
override ResolveReferences :
        unresolvedReferences : IList<string> -> IList<string>

Parameters

unresolvedReferences
Type: System.Collections.GenericIListString
Contains list of references that can not be resolved.

Return Value

Type: IListString
List of assembly references.

Implements

IScriptHostResolveReferences(IListString)
See Also

Reference

ScriptHost Class
ResolveReferences Overload
Alternet.Scripter Namespace


ScriptHost.Run Method

ScriptHostRun Method
Executes script starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Run(
    string[] args = null
)
Public Overridable Function Run (
    Optional args As String() = Nothing
) As Object
public:
virtual Object^ Run(
    array<String^>^ args = nullptr
)
abstract Run :
        ?args : string[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object
override Run :
        ?args : string[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.

Return Value

Type: Object
Return value of the script being executed.

Implements

IScriptHostRun(String)
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.RunAsync Method

ScriptHostRunAsync Method
Executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<Object> RunAsync(
    string[] args = null,
    CancellationToken cancellationToken = null
)
Public Overridable Function RunAsync (
    Optional args As String() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ RunAsync(
    array<String^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?args : string[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override RunAsync :
        ?args : string[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
Return value of the script being executed.

Implements

IScriptHostRunAsync(String, CancellationToken)
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.RunMethod Method

ScriptHostRunMethod Method
Executes specified method.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object RunMethod(
    string method,
    Object obj = null,
    Object[] args = null
)
Public Overridable Function RunMethod (
    method As String,
    Optional obj As Object = Nothing,
    Optional args As Object() = Nothing
) As Object
public:
virtual Object^ RunMethod(
    String^ method,
    Object^ obj = nullptr,
    array<Object^>^ args = nullptr
)
abstract RunMethod :
        method : string *
        ?obj : Object *
        ?args : Object[]
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
*)
-> Object
override RunMethod :
        method : string *
        ?obj : Object *
        ?args : Object[]
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
*)
-> Object

Parameters

method
Type: SystemString
Name of method to execute.
obj (Optional)
Type: SystemObject
Object, contains method to execute.
args (Optional)
Type: SystemObject
Array of method's parameters.

Return Value

Type: Object
An object containing return value of the executed method.

Implements

IScriptHostRunMethod(String, Object, Object)
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.RunMethodAsync Method

ScriptHostRunMethodAsync Method
Executes specified method asynchronously.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<Object> RunMethodAsync(
    string method,
    Object obj = null,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Public Overridable Function RunMethodAsync (
    method As String,
    Optional obj As Object = Nothing,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ RunMethodAsync(
    String^ method,
    Object^ obj = nullptr,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunMethodAsync :
        method : string *
        ?obj : Object *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override RunMethodAsync :
        method : string *
        ?obj : Object *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

method
Type: SystemString
Name of method to execute.
obj (Optional)
Type: SystemObject
Object, contains method to execute.
args (Optional)
Type: SystemObject
Array of method's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed method.

Implements

IScriptHostRunMethodAsync(String, Object, Object, CancellationToken)
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.RunProcess Method

ScriptHostRunProcess Method
Executes script starting from the main entry point in standalone process.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int RunProcess(
    string[] args = null,
    bool wait = true
)
Public Overridable Function RunProcess (
    Optional args As String() = Nothing,
    Optional wait As Boolean = true
) As Integer
public:
virtual int RunProcess(
    array<String^>^ args = nullptr,
    bool wait = true
)
abstract RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int
override RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
wait (Optional)
Type: SystemBoolean
Specifies if calling application should wait for process termination

Return Value

Type: Int32
Return process exit code.

Implements

IScriptHostRunProcess(String, Boolean)
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost Properties

ScriptHost Properties

The ScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyFileName | Gets script assembly file name.
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed.
Public property | ExecutableModulePath | Gets script assembly path.
Public property | GenerateModulesOnDisk | Gets or sets value indicating whether script assembly should be written to the disk or kept in memory.
Public property | GlobalCode | Gets a global code required for global items.
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies.
Public property | ReuseCompiledModulesFromDisk | Gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date.
Public property | ScriptAssembly | Returns compiled script assembly.
Public property | ScriptRun | Gets IScriptRun associated this script host.
Top
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.AssemblyFileName Property

ScriptHostAssemblyFileName Property
Gets script assembly file name.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyFileName { get; set; }
Public Property AssemblyFileName As String
    Get
    Set
public:
virtual property String^ AssemblyFileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract AssemblyFileName : string with get, set
override AssemblyFileName : string with get, set

Property Value

Type: String

Implements

IScriptHostAssemblyFileName
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.Compiled Property

ScriptHostCompiled Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compiled { get; }
Public Overridable ReadOnly Property Compiled As Boolean
    Get
public:
virtual property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get
override Compiled : bool with get

Property Value

Type: Boolean

Implements

IScriptHostCompiled
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.CompileFailed Property

ScriptHostCompileFailed Property
Gets or sets boolean value indicating unsuccessful script compilation.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CompileFailed { get; }
Public ReadOnly Property CompileFailed As Boolean
    Get
public:
virtual property bool CompileFailed {
    bool get () sealed;
}
abstract CompileFailed : bool with get
override CompileFailed : bool with get

Property Value

Type: Boolean

Implements

IScriptHostCompileFailed
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.CompilerErrors Property

ScriptHostCompilerErrors Property
Gets list of compiler errors associated with the script being executed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCompilationDiagnostic[] CompilerErrors { get; }
Public ReadOnly Property CompilerErrors As ScriptCompilationDiagnostic()
    Get
public:
virtual property array<ScriptCompilationDiagnostic>^ CompilerErrors {
    array<ScriptCompilationDiagnostic>^ get () sealed;
}
abstract CompilerErrors : ScriptCompilationDiagnostic[] with get
override CompilerErrors : ScriptCompilationDiagnostic[] with get

Property Value

Type: ScriptCompilationDiagnostic

Implements

IScriptHostCompilerErrors
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.ExecutableModulePath Property

ScriptHostExecutableModulePath Property
Gets script assembly path.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ExecutableModulePath { get; }
Public ReadOnly Property ExecutableModulePath As String
    Get
public:
virtual property String^ ExecutableModulePath {
    String^ get () sealed;
}
abstract ExecutableModulePath : string with get
override ExecutableModulePath : string with get

Property Value

Type: String

Implements

IScriptHostExecutableModulePath
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.GenerateModulesOnDisk Property

ScriptHostGenerateModulesOnDisk Property
Gets or sets value indicating whether script assembly should be written to the disk or kept in memory.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GenerateModulesOnDisk { get; set; }
Public Property GenerateModulesOnDisk As Boolean
    Get
    Set
public:
virtual property bool GenerateModulesOnDisk {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract GenerateModulesOnDisk : bool with get, set
override GenerateModulesOnDisk : bool with get, set

Property Value

Type: Boolean

Implements

IScriptHostGenerateModulesOnDisk
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.GlobalCode Property

ScriptHostGlobalCode Property
Gets a global code required for global items.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GlobalCode { get; }
Public Overridable ReadOnly Property GlobalCode As String
    Get
public:
virtual property String^ GlobalCode {
    String^ get ();
}
abstract GlobalCode : string with get
override GlobalCode : string with get

Property Value

Type: String

Implements

IScriptHostGlobalCode
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.ModulesDirectoryPath Property

ScriptHostModulesDirectoryPath Property
Gets or sets path for compiled script assemblies.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModulesDirectoryPath { get; set; }
Public Property ModulesDirectoryPath As String
    Get
    Set
public:
virtual property String^ ModulesDirectoryPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ModulesDirectoryPath : string with get, set
override ModulesDirectoryPath : string with get, set

Property Value

Type: String

Implements

IScriptHostModulesDirectoryPath
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.ReuseCompiledModulesFromDisk Property

ScriptHostReuseCompiledModulesFromDisk Property
Gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReuseCompiledModulesFromDisk { get; set; }
Public Property ReuseCompiledModulesFromDisk As Boolean
    Get
    Set
public:
virtual property bool ReuseCompiledModulesFromDisk {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ReuseCompiledModulesFromDisk : bool with get, set
override ReuseCompiledModulesFromDisk : bool with get, set

Property Value

Type: Boolean

Implements

IScriptHostReuseCompiledModulesFromDisk
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.ScriptAssembly Property

ScriptHostScriptAssembly Property
Returns compiled script assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Assembly ScriptAssembly { get; }
Public Overridable ReadOnly Property ScriptAssembly As Assembly
    Get
public:
virtual property Assembly^ ScriptAssembly {
    Assembly^ get ();
}
abstract ScriptAssembly : Assembly with get
override ScriptAssembly : Assembly with get

Property Value

Type: Assembly

Implements

IScriptHostScriptAssembly
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptHost.ScriptRun Property

ScriptHostScriptRun Property
Gets IScriptRun associated this script host.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptRun ScriptRun { get; }
Public ReadOnly Property ScriptRun As IScriptRun
    Get
public:
virtual property IScriptRun^ ScriptRun {
    IScriptRun^ get () sealed;
}
abstract ScriptRun : IScriptRun with get
override ScriptRun : IScriptRun with get

Property Value

Type: IScriptRun

Implements

IScriptHostScriptRun
See Also

Reference

ScriptHost Class
Alternet.Scripter Namespace


ScriptLanguage Enumeration

ScriptLanguage Enumeration
Defines programming language used by the script engine.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptLanguage
Public Enumeration ScriptLanguage
public enum class ScriptLanguage
type ScriptLanguage
Members
Member name | Value | Description
CSharp | 0 | Specifies C# language.
VisualBasic | 1 | Specifies Visual Basic language.
CSharpScript | 2 | Specifies C# class-less script language.
VisualBasicScript | 3 | Specifies Visual Basic class-less script language.
See Also

Reference

Alternet.Scripter Namespace


ScriptMethod Class

ScriptMethod Class
Provides functionality to run particular script method.
Inheritance Hierarchy
SystemObject
Alternet.ScripterScriptMethod

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptMethod
Public Class ScriptMethod
public ref class ScriptMethod
type ScriptMethod =  class end

The ScriptMethod type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptMethod | Initializes a new instance of the ScriptMethod class
Top
Methods
 | Name | Description
 | DisposeGlobalObjects | Disposes global objects registered in the specified assembly.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPropertyValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitGlobalObjects | Initializes global objects belongs to the specified assembly.
 | Run | Executes script starting from the main entry point.
 | RunAsync | Executes script asynchronously starting from the main entry point.
 | RunMethod | Executes specified method.
 | RunMethodAsync | Executes specified method asynchronously.
 | RunProcess | Executes script starting from the main entry point in standalone process.
 | SetPropertyValue |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter Namespace


ScriptMethod Constructor

ScriptMethod Constructor
Initializes a new instance of the ScriptMethod class

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptMethod()
Public Sub New
public:
ScriptMethod()
new : unit -> ScriptMethod
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod Methods

ScriptMethod Methods

The ScriptMethod type exposes the following members.

Methods
 | Name | Description
 | DisposeGlobalObjects | Disposes global objects registered in the specified assembly.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPropertyValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitGlobalObjects | Initializes global objects belongs to the specified assembly.
 | Run | Executes script starting from the main entry point.
 | RunAsync | Executes script asynchronously starting from the main entry point.
 | RunMethod | Executes specified method.
 | RunMethodAsync | Executes specified method asynchronously.
 | RunProcess | Executes script starting from the main entry point in standalone process.
 | SetPropertyValue |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod.DisposeGlobalObjects Method

ScriptMethodDisposeGlobalObjects Method
Disposes global objects registered in the specified assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DisposeGlobalObjects(
    Assembly assembly
)
Public Shared Sub DisposeGlobalObjects (
    assembly As Assembly
)
public:
static void DisposeGlobalObjects(
    Assembly^ assembly
)
static member DisposeGlobalObjects :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to process.
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod.GetPropertyValue Method

ScriptMethodGetPropertyValue Method

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object GetPropertyValue(
    IScriptRun scriptRun,
    Assembly assembly,
    string property,
    Object obj,
    Object[] index = null
)
Public Shared Function GetPropertyValue (
    scriptRun As IScriptRun,
    assembly As Assembly,
    property As String,
    obj As Object,
    Optional index As Object() = Nothing
) As Object
public:
static Object^ GetPropertyValue(
    IScriptRun^ scriptRun,
    Assembly^ assembly,
    String^ property,
    Object^ obj,
    array<Object^>^ index = nullptr
)
static member GetPropertyValue :
        scriptRun : IScriptRun *
        assembly : Assembly *
        property : string *
        obj : Object *
        ?index : Object[]
(* Defaults:
        let _index = defaultArg index null
*)
-> Object

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
assembly
Type: System.ReflectionAssembly
property
Type: SystemString
obj
Type: SystemObject
index (Optional)
Type: SystemObject

Return Value

Type: Object
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod.InitGlobalObjects Method

ScriptMethodInitGlobalObjects Method
Initializes global objects belongs to the specified assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void InitGlobalObjects(
    IScriptRun scriptRun,
    Assembly assembly
)
Public Shared Sub InitGlobalObjects (
    scriptRun As IScriptRun,
    assembly As Assembly
)
public:
static void InitGlobalObjects(
    IScriptRun^ scriptRun,
    Assembly^ assembly
)
static member InitGlobalObjects :
        scriptRun : IScriptRun *
        assembly : Assembly -> unit

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
IScriptRun associated this script method.
assembly
Type: System.ReflectionAssembly
Assembly contains global objects.
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod.Run Method

ScriptMethodRun Method
Executes script starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object Run(
    IScriptRun scriptRun,
    Assembly assembly,
    Object[] args
)
Public Shared Function Run (
    scriptRun As IScriptRun,
    assembly As Assembly,
    args As Object()
) As Object
public:
static Object^ Run(
    IScriptRun^ scriptRun,
    Assembly^ assembly,
    array<Object^>^ args
)
static member Run :
        scriptRun : IScriptRun *
        assembly : Assembly *
        args : Object[] -> Object

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
IScriptRun associated this script method.
assembly
Type: System.ReflectionAssembly
Assembly contains method to execute.
args
Type: SystemObject
Specifies main method parameters.

Return Value

Type: Object
Return value of the script being executed.
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod.RunAsync Method

ScriptMethodRunAsync Method
Executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<Object> RunAsync(
    IScriptRun scriptRun,
    Assembly assembly,
    Object[] args,
    CancellationToken cancellationToken
)
Public Shared Function RunAsync (
    scriptRun As IScriptRun,
    assembly As Assembly,
    args As Object(),
    cancellationToken As CancellationToken
) As Task(Of Object)
public:
static Task<Object^>^ RunAsync(
    IScriptRun^ scriptRun,
    Assembly^ assembly,
    array<Object^>^ args,
    CancellationToken cancellationToken
)
static member RunAsync :
        scriptRun : IScriptRun *
        assembly : Assembly *
        args : Object[] *
        cancellationToken : CancellationToken -> Task<Object>

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
IScriptRun associated this script method.
assembly
Type: System.ReflectionAssembly
Assembly contains method to execute.
args
Type: SystemObject
Specifies main method parameters.
cancellationToken
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
Return value of the script being executed.
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod.RunMethod Method

ScriptMethodRunMethod Method
Executes specified method.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object RunMethod(
    IScriptRun scriptRun,
    Assembly assembly,
    string method,
    Object obj,
    Object[] args
)
Public Shared Function RunMethod (
    scriptRun As IScriptRun,
    assembly As Assembly,
    method As String,
    obj As Object,
    args As Object()
) As Object
public:
static Object^ RunMethod(
    IScriptRun^ scriptRun,
    Assembly^ assembly,
    String^ method,
    Object^ obj,
    array<Object^>^ args
)
static member RunMethod :
        scriptRun : IScriptRun *
        assembly : Assembly *
        method : string *
        obj : Object *
        args : Object[] -> Object

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
IScriptRun associated this script method.
assembly
Type: System.ReflectionAssembly
Assembly contains method to execute.
method
Type: SystemString
Name of method to execute.
obj
Type: SystemObject
Object, contains method to execute.
args
Type: SystemObject
Array of method's parameters.

Return Value

Type: Object
An object containing return value of the executed method.
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod.RunMethodAsync Method

ScriptMethodRunMethodAsync Method
Executes specified method asynchronously.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<Object> RunMethodAsync(
    IScriptRun scriptRun,
    Assembly assembly,
    string method,
    Object obj,
    Object[] args,
    CancellationToken cancellationToken
)
Public Shared Function RunMethodAsync (
    scriptRun As IScriptRun,
    assembly As Assembly,
    method As String,
    obj As Object,
    args As Object(),
    cancellationToken As CancellationToken
) As Task(Of Object)
public:
static Task<Object^>^ RunMethodAsync(
    IScriptRun^ scriptRun,
    Assembly^ assembly,
    String^ method,
    Object^ obj,
    array<Object^>^ args,
    CancellationToken cancellationToken
)
static member RunMethodAsync :
        scriptRun : IScriptRun *
        assembly : Assembly *
        method : string *
        obj : Object *
        args : Object[] *
        cancellationToken : CancellationToken -> Task<Object>

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
IScriptRun associated this script method.
assembly
Type: System.ReflectionAssembly
Assembly contains method to execute.
method
Type: SystemString
Name of method to execute.
obj
Type: SystemObject
Object, contains method to execute.
args
Type: SystemObject
Array of method's parameters.
cancellationToken
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed method.
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod.RunProcess Method

ScriptMethodRunProcess Method
Executes script starting from the main entry point in standalone process.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int RunProcess(
    IScriptRun scriptRun,
    string assemblyLocation,
    Object[] args,
    bool wait
)
Public Shared Function RunProcess (
    scriptRun As IScriptRun,
    assemblyLocation As String,
    args As Object(),
    wait As Boolean
) As Integer
public:
static int RunProcess(
    IScriptRun^ scriptRun,
    String^ assemblyLocation,
    array<Object^>^ args,
    bool wait
)
static member RunProcess :
        scriptRun : IScriptRun *
        assemblyLocation : string *
        args : Object[] *
        wait : bool -> int

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
IScriptRun associated this script method.
assemblyLocation
Type: SystemString
Fully qualified name of application to execute.
args
Type: SystemObject
Specifies main method parameters.
wait
Type: SystemBoolean
Specifies if calling application should wait for process termination

Return Value

Type: Int32
Return process exit code.
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMethod.SetPropertyValue Method

ScriptMethodSetPropertyValue Method

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetPropertyValue(
    IScriptRun scriptRun,
    Assembly assembly,
    string property,
    Object obj,
    Object newValue
)
Public Shared Sub SetPropertyValue (
    scriptRun As IScriptRun,
    assembly As Assembly,
    property As String,
    obj As Object,
    newValue As Object
)
public:
static void SetPropertyValue(
    IScriptRun^ scriptRun,
    Assembly^ assembly,
    String^ property,
    Object^ obj,
    Object^ newValue
)
static member SetPropertyValue :
        scriptRun : IScriptRun *
        assembly : Assembly *
        property : string *
        obj : Object *
        newValue : Object -> unit

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
assembly
Type: System.ReflectionAssembly
property
Type: SystemString
obj
Type: SystemObject
newValue
Type: SystemObject
See Also

Reference

ScriptMethod Class
Alternet.Scripter Namespace


ScriptMode Enumeration

ScriptMode Enumeration
Defines debug or release mode for the scripts.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptMode
Public Enumeration ScriptMode
public enum class ScriptMode
type ScriptMode
Members
Member name | Value | Description
Debug | 0 | Specifies Debug mode.
Release | 1 | Specifies Release mode.
See Also

Reference

Alternet.Scripter Namespace


ScriptPlatform Enumeration

ScriptPlatform Enumeration
Defines target platform.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptPlatform
Public Enumeration ScriptPlatform
public enum class ScriptPlatform
type ScriptPlatform
Members
Member name | Value | Description
Auto | 0 | Determines scripting platform depending on calling application target platform.
AnyCpu | 1 | AnyCPU (default) compiles the assembly to run on any platform.
X86 | 2 | x86 compiles the assembly to be run by the 32-bit, x86-compatible common language runtime
X64 | 3 | x64 compiles the assembly to be run by the 64-bit common language runtime on a computer that supports the AMD64 or EM64T instruction set.
AnyCpu32BitPreferred | 4 | Compiles your assembly to run on any platform. Your application runs in 32-bit mode on systems that support both 64-bit and 32-bit applications.
See Also

Reference

Alternet.Scripter Namespace


ScriptRun Class

ScriptRun Class
Represents runner for script engine.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.ScripterScriptRun

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptRun : Component, IScriptRun,
    IScriptRunBase
Public Class ScriptRun
    Inherits Component
    Implements IScriptRun, IScriptRunBase
public ref class ScriptRun : public Component,
    IScriptRun, IScriptRunBase
type ScriptRun =
    class
        inherit Component
        interface IScriptRun
        interface IScriptRunBase
    end

The ScriptRun type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptRun | Initializes a new instance of the ScriptRun class with default settings.
Public method | ScriptRun(IContainer) | Initializes a new instance of the ScriptRun class with specified parameters.
Top
Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateScriptHost | Creates a new IScriptHost object with appropriate characteristics.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadScript | Load script from specified file.
Public method | OnFileLoad | Invokes FileLoad event handler.
Public method | OnResolveReference | Invokes ReferenceResolve event handler.
Public method | OnScriptCompiled | Invokes ScriptCompiled event handler.
Public method | OnScriptError | Invokes ScriptError event handler.
Public method | OnScriptExecuted | Invokes ScriptRunning event handler.
Public method | OnScriptReset | Invokes ScriptReset event handler.
Public method | OnScriptRunning | Invokes ScriptRunning event handler.
Public method | Reset | Resets the script engine and releases all resources.
Public method | Run | Executes script starting from the main entry point.
Public method | Run(String) | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunMethod | Executes specified method.
Public method | RunMethodAsync | Executes specified method asynchronously.
Public method | RunProcess | Executes script starting from the main entry point in stand-alone process
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Properties
 | Name | Description
Public property | AssemblyKind | Gets or sets output kind for the script assembly.
Public property | CaseSensitive | Indicates whether script language is case sensitive.
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Executed | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | GlobalItems | Gets or sets a script items collection attached to this runner.
Public property | Platform | Gets or sets target platform (32 or 64 bits).
Public property | ScriptHost | Returns object that implements IScriptHost interface for this runner.
Public property | ScriptLanguage | Gets or sets programming language of the script.
Public property | ScriptMode | Gets or sets debug or release mode for the scripts being executed.
Public property | ScriptSource | Gets source of the script to execute.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | TargetFrameworkVersion | Gets or sets target framework version for locating Framework assemblies.
Public property | Win32ManifestOptions | Gets or sets Win32 manifest options for the script assembly.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileLoad | Occurs when script code is loaded from file.
Public event | ReferenceResolve | Occurs when assembly reference needs to be resolved.
Public event | ScriptCompiled | Occurs when the script engine running successfully.
Public event | ScriptError | Occurs when the script engine running is failed.
Public event | ScriptExecuted | Occurs when script engine executes the script.
Public event | ScriptReset | Occurs when the script engine is reset.
Public event | ScriptRunning | Occurs when script engine tries to running script.
Top
See Also

Reference

Alternet.Scripter Namespace


ScriptRun Constructor

ScriptRun Constructor
Overload List
 | Name | Description
Public method | ScriptRun | Initializes a new instance of the ScriptRun class with default settings.
Public method | ScriptRun(IContainer) | Initializes a new instance of the ScriptRun class with specified parameters.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun Constructor

ScriptRun Constructor
Initializes a new instance of the ScriptRun class with default settings.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRun()
Public Sub New
public:
ScriptRun()
new : unit -> ScriptRun
See Also

Reference

ScriptRun Class
ScriptRun Overload
Alternet.Scripter Namespace


ScriptRun Constructor (IContainer)

ScriptRun Constructor (IContainer)
Initializes a new instance of the ScriptRun class with specified parameters.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRun(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
ScriptRun(
    IContainer^ container
)
new :
        container : IContainer -> ScriptRun

Parameters

container
Type: System.ComponentModelIContainer
Specifies container of this new instance.
See Also

Reference

ScriptRun Class
ScriptRun Overload
Alternet.Scripter Namespace


ScriptRun Methods

ScriptRun Methods

The ScriptRun type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateScriptHost | Creates a new IScriptHost object with appropriate characteristics.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadScript | Load script from specified file.
Public method | OnFileLoad | Invokes FileLoad event handler.
Public method | OnResolveReference | Invokes ReferenceResolve event handler.
Public method | OnScriptCompiled | Invokes ScriptCompiled event handler.
Public method | OnScriptError | Invokes ScriptError event handler.
Public method | OnScriptExecuted | Invokes ScriptRunning event handler.
Public method | OnScriptReset | Invokes ScriptReset event handler.
Public method | OnScriptRunning | Invokes ScriptRunning event handler.
Public method | Reset | Resets the script engine and releases all resources.
Public method | Run | Executes script starting from the main entry point.
Public method | Run(String) | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunMethod | Executes specified method.
Public method | RunMethodAsync | Executes specified method asynchronously.
Public method | RunProcess | Executes script starting from the main entry point in stand-alone process
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.Compile Method

ScriptRunCompile Method
Initializes script engine and compiles the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compile()
Public Overridable Function Compile As Boolean
public:
virtual bool Compile()
abstract Compile : unit -> bool
override Compile : unit -> bool

Return Value

Type: Boolean
True if succeed, otherwise false.

Implements

IScriptRunBaseCompile
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.CreateScriptHost Method

ScriptRunCreateScriptHost Method
Creates a new IScriptHost object with appropriate characteristics.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptHost CreateScriptHost()
Public Overridable Function CreateScriptHost As IScriptHost
public:
virtual IScriptHost^ CreateScriptHost()
abstract CreateScriptHost : unit -> IScriptHost
override CreateScriptHost : unit -> IScriptHost

Return Value

Type: IScriptHost
Created IScriptHost object.

Implements

IScriptRunCreateScriptHost
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.EvaluateExpression Method

ScriptRunEvaluateExpression Method
Evaluates specified expression.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object EvaluateExpression(
    string expression
)
Public Function EvaluateExpression (
    expression As String
) As Object
public:
virtual Object^ EvaluateExpression(
    String^ expression
) sealed
abstract EvaluateExpression :
        expression : string -> Object
override EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.

Implements

IScriptRunBaseEvaluateExpression(String)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.EvaluateExpressionAsync Method

ScriptRunEvaluateExpressionAsync Method
Evaluates specified expression asynchronously.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Public Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.

Implements

IScriptRunEvaluateExpressionAsync(String, CancellationToken)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.LoadScript Method

ScriptRunLoadScript Method
Load script from specified file.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string LoadScript(
    string fileName
)
Public Overridable Function LoadScript (
    fileName As String
) As String
public:
virtual String^ LoadScript(
    String^ fileName
)
abstract LoadScript :
        fileName : string -> string
override LoadScript :
        fileName : string -> string

Parameters

fileName
Type: SystemString
File name contains script to load.

Return Value

Type: String
String representation of loaded script.

Implements

IScriptRunBaseLoadScript(String)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.OnFileLoad Method

ScriptRunOnFileLoad Method
Invokes FileLoad event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string OnFileLoad(
    string fileName
)
Public Overridable Function OnFileLoad (
    fileName As String
) As String
public:
virtual String^ OnFileLoad(
    String^ fileName
)
abstract OnFileLoad :
        fileName : string -> string
override OnFileLoad :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String

Implements

IScriptRunBaseOnFileLoad(String)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.OnResolveReference Method

ScriptRunOnResolveReference Method
Invokes ReferenceResolve event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool OnResolveReference(
    string reference,
    out string assemblyLocation,
    out byte[] assemblyImage
)
Public Overridable Function OnResolveReference (
    reference As String,
    <OutAttribute> ByRef assemblyLocation As String,
    <OutAttribute> ByRef assemblyImage As Byte()
) As Boolean
public:
virtual bool OnResolveReference(
    String^ reference,
    [OutAttribute] String^% assemblyLocation,
    [OutAttribute] array<unsigned char>^% assemblyImage
)
abstract OnResolveReference :
        reference : string *
        assemblyLocation : string byref *
        assemblyImage : byte[] byref -> bool
override OnResolveReference :
        reference : string *
        assemblyLocation : string byref *
        assemblyImage : byte[] byref -> bool

Parameters

reference
Type: SystemString
Reference to resolve.
assemblyLocation
Type: SystemString
Path to suitable assembly.
assemblyImage
Type: SystemByte
Image containing suitable assembly.

Return Value

Type: Boolean
true if reference was resolved otherwise false

Implements

IScriptRunOnResolveReference(String, String, Byte)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.OnScriptCompiled Method

ScriptRunOnScriptCompiled Method
Invokes ScriptCompiled event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptCompiled()
Public Overridable Sub OnScriptCompiled
public:
virtual void OnScriptCompiled()
abstract OnScriptCompiled : unit -> unit
override OnScriptCompiled : unit -> unit

Implements

IScriptRunBaseOnScriptCompiled
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.OnScriptError Method

ScriptRunOnScriptError Method
Invokes ScriptError event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptError(
    ScriptErrorEventArgs e
)
Public Overridable Sub OnScriptError (
    e As ScriptErrorEventArgs
)
public:
virtual void OnScriptError(
    ScriptErrorEventArgs^ e
)
abstract OnScriptError :
        e : ScriptErrorEventArgs -> unit
override OnScriptError :
        e : ScriptErrorEventArgs -> unit

Parameters

e
Type: Alternet.ScripterScriptErrorEventArgs

Implements

IScriptRunBaseOnScriptError(ScriptErrorEventArgs)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.OnScriptExecuted Method

ScriptRunOnScriptExecuted Method
Invokes ScriptRunning event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptExecuted()
Public Overridable Sub OnScriptExecuted
public:
virtual void OnScriptExecuted()
abstract OnScriptExecuted : unit -> unit
override OnScriptExecuted : unit -> unit

Implements

IScriptRunBaseOnScriptExecuted
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.OnScriptReset Method

ScriptRunOnScriptReset Method
Invokes ScriptReset event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptReset()
Public Overridable Sub OnScriptReset
public:
virtual void OnScriptReset()
abstract OnScriptReset : unit -> unit
override OnScriptReset : unit -> unit

Implements

IScriptRunBaseOnScriptReset
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.OnScriptRunning Method

ScriptRunOnScriptRunning Method
Invokes ScriptRunning event handler.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptRunning()
Public Overridable Sub OnScriptRunning
public:
virtual void OnScriptRunning()
abstract OnScriptRunning : unit -> unit
override OnScriptRunning : unit -> unit

Implements

IScriptRunBaseOnScriptRunning
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.Reset Method

ScriptRunReset Method
Resets the script engine and releases all resources.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptRunBaseReset
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.Run Method

ScriptRunRun Method
Overload List
 | Name | Description
Public method | Run | Executes script starting from the main entry point.
Public method | Run(String) | Executes script starting from the main entry point.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.Run Method

ScriptRunRun Method
Executes script starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Run()
Public Overridable Function Run As Object
public:
virtual Object^ Run()
abstract Run : unit -> Object
override Run : unit -> Object

Return Value

Type: Object
Return value of the script being executed.

Implements

IScriptRunBaseRun
See Also

Reference

ScriptRun Class
Run Overload
Alternet.Scripter Namespace


ScriptRun.Run Method (String[])

ScriptRunRun Method (String)
Executes script starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Run(
    string[] args = null
)
Public Overridable Function Run (
    Optional args As String() = Nothing
) As Object
public:
virtual Object^ Run(
    array<String^>^ args = nullptr
)
abstract Run :
        ?args : string[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object
override Run :
        ?args : string[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.

Return Value

Type: Object
Return value of the script being executed.

Implements

IScriptRunRun(String)
See Also

Reference

ScriptRun Class
Run Overload
Alternet.Scripter Namespace


ScriptRun.RunAsync Method

ScriptRunRunAsync Method
Executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<Object> RunAsync(
    string[] args = null,
    CancellationToken cancellationToken = null
)
Public Overridable Function RunAsync (
    Optional args As String() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ RunAsync(
    array<String^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?args : string[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override RunAsync :
        ?args : string[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
Return value of the script being executed.

Implements

IScriptRunRunAsync(String, CancellationToken)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.RunMethod Method

ScriptRunRunMethod Method
Executes specified method.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object RunMethod(
    string method,
    Object obj = null,
    Object[] args = null
)
Public Overridable Function RunMethod (
    method As String,
    Optional obj As Object = Nothing,
    Optional args As Object() = Nothing
) As Object
public:
virtual Object^ RunMethod(
    String^ method,
    Object^ obj = nullptr,
    array<Object^>^ args = nullptr
)
abstract RunMethod :
        method : string *
        ?obj : Object *
        ?args : Object[]
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
*)
-> Object
override RunMethod :
        method : string *
        ?obj : Object *
        ?args : Object[]
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
*)
-> Object

Parameters

method
Type: SystemString
Name of method to execute.
obj (Optional)
Type: SystemObject
Object, contains method to execute.
args (Optional)
Type: SystemObject
Array of method's parameters.

Return Value

Type: Object
An object containing return value of the executed method.

Implements

IScriptRunRunMethod(String, Object, Object)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.RunMethodAsync Method

ScriptRunRunMethodAsync Method
Executes specified method asynchronously.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<Object> RunMethodAsync(
    string method,
    Object obj = null,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Public Function RunMethodAsync (
    method As String,
    Optional obj As Object = Nothing,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ RunMethodAsync(
    String^ method,
    Object^ obj = nullptr,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
) sealed
abstract RunMethodAsync :
        method : string *
        ?obj : Object *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override RunMethodAsync :
        method : string *
        ?obj : Object *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _obj = defaultArg obj null
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

method
Type: SystemString
Name of method to execute.
obj (Optional)
Type: SystemObject
Object, contains method to execute.
args (Optional)
Type: SystemObject
Array of method's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed method.

Implements

IScriptRunRunMethodAsync(String, Object, Object, CancellationToken)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.RunProcess Method

ScriptRunRunProcess Method
Executes script starting from the main entry point in stand-alone process

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int RunProcess(
    string[] args = null,
    bool wait = true
)
Public Overridable Function RunProcess (
    Optional args As String() = Nothing,
    Optional wait As Boolean = true
) As Integer
public:
virtual int RunProcess(
    array<String^>^ args = nullptr,
    bool wait = true
)
abstract RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int
override RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
wait (Optional)
Type: SystemBoolean
Specifies if calling application should wait for process termination

Return Value

Type: Int32
Return process exit code.

Implements

IScriptRunRunProcess(String, Boolean)
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun Properties

ScriptRun Properties

The ScriptRun type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyKind | Gets or sets output kind for the script assembly.
Public property | CaseSensitive | Indicates whether script language is case sensitive.
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Executed | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | GlobalItems | Gets or sets a script items collection attached to this runner.
Public property | Platform | Gets or sets target platform (32 or 64 bits).
Public property | ScriptHost | Returns object that implements IScriptHost interface for this runner.
Public property | ScriptLanguage | Gets or sets programming language of the script.
Public property | ScriptMode | Gets or sets debug or release mode for the scripts being executed.
Public property | ScriptSource | Gets source of the script to execute.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | TargetFrameworkVersion | Gets or sets target framework version for locating Framework assemblies.
Public property | Win32ManifestOptions | Gets or sets Win32 manifest options for the script assembly.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.AssemblyKind Property

ScriptRunAssemblyKind Property
Gets or sets output kind for the script assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptAssemblyKind AssemblyKind { get; set; }
Public Property AssemblyKind As ScriptAssemblyKind
    Get
    Set
public:
virtual property ScriptAssemblyKind AssemblyKind {
    ScriptAssemblyKind get () sealed;
    void set (ScriptAssemblyKind value) sealed;
}
abstract AssemblyKind : ScriptAssemblyKind with get, set
override AssemblyKind : ScriptAssemblyKind with get, set

Property Value

Type: ScriptAssemblyKind

Implements

IScriptRunAssemblyKind
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.CaseSensitive Property

ScriptRunCaseSensitive Property
Indicates whether script language is case sensitive.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CaseSensitive { get; }
Public Overridable ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get ();
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

IScriptRunBaseCaseSensitive
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.Compiled Property

ScriptRunCompiled Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compiled { get; }
Public Overridable ReadOnly Property Compiled As Boolean
    Get
public:
virtual property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get
override Compiled : bool with get

Property Value

Type: Boolean

Implements

IScriptRunBaseCompiled
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.Executed Property

ScriptRunExecuted Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Executed { get; }
Public Overridable ReadOnly Property Executed As Boolean
    Get
public:
virtual property bool Executed {
    bool get ();
}
abstract Executed : bool with get
override Executed : bool with get

Property Value

Type: Boolean

Implements

IScriptRunBaseExecuted
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.GlobalItems Property

ScriptRunGlobalItems Property
Gets or sets a script items collection attached to this runner.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IScriptGlobalItem> GlobalItems { get; }
Public ReadOnly Property GlobalItems As IList(Of IScriptGlobalItem)
    Get
public:
virtual property IList<IScriptGlobalItem^>^ GlobalItems {
    IList<IScriptGlobalItem^>^ get () sealed;
}
abstract GlobalItems : IList<IScriptGlobalItem> with get
override GlobalItems : IList<IScriptGlobalItem> with get

Property Value

Type: IListIScriptGlobalItem

Implements

IScriptRunGlobalItems
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.Platform Property

ScriptRunPlatform Property
Gets or sets target platform (32 or 64 bits).

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ScriptPlatform Platform { get; set; }
Public Overridable Property Platform As ScriptPlatform
    Get
    Set
public:
virtual property ScriptPlatform Platform {
    ScriptPlatform get ();
    void set (ScriptPlatform value);
}
abstract Platform : ScriptPlatform with get, set
override Platform : ScriptPlatform with get, set

Property Value

Type: ScriptPlatform

Implements

IScriptRunPlatform
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ScriptHost Property

ScriptRunScriptHost Property
Returns object that implements IScriptHost interface for this runner.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptHost ScriptHost { get; set; }
Public Overridable Property ScriptHost As IScriptHost
    Get
    Set
public:
virtual property IScriptHost^ ScriptHost {
    IScriptHost^ get ();
    void set (IScriptHost^ value);
}
abstract ScriptHost : IScriptHost with get, set
override ScriptHost : IScriptHost with get, set

Property Value

Type: IScriptHost

Implements

IScriptRunScriptHost
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ScriptLanguage Property

ScriptRunScriptLanguage Property
Gets or sets programming language of the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptLanguage ScriptLanguage { get; set; }
Public Property ScriptLanguage As ScriptLanguage
    Get
    Set
public:
virtual property ScriptLanguage ScriptLanguage {
    ScriptLanguage get () sealed;
    void set (ScriptLanguage value) sealed;
}
abstract ScriptLanguage : ScriptLanguage with get, set
override ScriptLanguage : ScriptLanguage with get, set

Property Value

Type: ScriptLanguage

Implements

IScriptRunScriptLanguage
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ScriptMode Property

ScriptRunScriptMode Property
Gets or sets debug or release mode for the scripts being executed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptMode ScriptMode { get; set; }
Public Property ScriptMode As ScriptMode
    Get
    Set
public:
virtual property ScriptMode ScriptMode {
    ScriptMode get () sealed;
    void set (ScriptMode value) sealed;
}
abstract ScriptMode : ScriptMode with get, set
override ScriptMode : ScriptMode with get, set

Property Value

Type: ScriptMode

Implements

IScriptRunScriptMode
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ScriptSource Property

ScriptRunScriptSource Property
Gets source of the script to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptSource ScriptSource { get; }
Public ReadOnly Property ScriptSource As IScriptSource
    Get
public:
virtual property IScriptSource^ ScriptSource {
    IScriptSource^ get () sealed;
}
abstract ScriptSource : IScriptSource with get
override ScriptSource : IScriptSource with get

Property Value

Type: IScriptSource

Implements

IScriptRunScriptSource
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.TargetFrameworkVersion Property

ScriptRunTargetFrameworkVersion Property
Gets or sets target framework version for locating Framework assemblies.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetNETFrameworkVersion TargetFrameworkVersion { get; set; }
Public Property TargetFrameworkVersion As TargetNETFrameworkVersion
    Get
    Set
public:
virtual property TargetNETFrameworkVersion TargetFrameworkVersion {
    TargetNETFrameworkVersion get () sealed;
    void set (TargetNETFrameworkVersion value) sealed;
}
abstract TargetFrameworkVersion : TargetNETFrameworkVersion with get, set
override TargetFrameworkVersion : TargetNETFrameworkVersion with get, set

Property Value

Type: TargetNETFrameworkVersion

Implements

IScriptRunTargetFrameworkVersion
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.Win32ManifestOptions Property

ScriptRunWin32ManifestOptions Property
Gets or sets Win32 manifest options for the script assembly.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Win32ManifestOptions Win32ManifestOptions { get; set; }
Public Property Win32ManifestOptions As Win32ManifestOptions
    Get
    Set
public:
virtual property Win32ManifestOptions^ Win32ManifestOptions {
    Win32ManifestOptions^ get () sealed;
    void set (Win32ManifestOptions^ value) sealed;
}
abstract Win32ManifestOptions : Win32ManifestOptions with get, set
override Win32ManifestOptions : Win32ManifestOptions with get, set

Property Value

Type: Win32ManifestOptions

Implements

IScriptRunWin32ManifestOptions
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun Events

ScriptRun Events

The ScriptRun type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileLoad | Occurs when script code is loaded from file.
Public event | ReferenceResolve | Occurs when assembly reference needs to be resolved.
Public event | ScriptCompiled | Occurs when the script engine running successfully.
Public event | ScriptError | Occurs when the script engine running is failed.
Public event | ScriptExecuted | Occurs when script engine executes the script.
Public event | ScriptReset | Occurs when the script engine is reset.
Public event | ScriptRunning | Occurs when script engine tries to running script.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.FileLoad Event

ScriptRunFileLoad Event
Occurs when script code is loaded from file.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileLoadEventArgs> FileLoad
Public Event FileLoad As EventHandler(Of FileLoadEventArgs)
public:
virtual  event EventHandler<FileLoadEventArgs^>^ FileLoad {
    void add (EventHandler<FileLoadEventArgs^>^ value);
    void remove (EventHandler<FileLoadEventArgs^>^ value);
}
abstract FileLoad : IEvent<EventHandler<FileLoadEventArgs>,
    FileLoadEventArgs>
override FileLoad : IEvent<EventHandler<FileLoadEventArgs>,
    FileLoadEventArgs>

Value

Type: SystemEventHandlerFileLoadEventArgs

Implements

IScriptRunBaseFileLoad
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ReferenceResolve Event

ScriptRunReferenceResolve Event
Occurs when assembly reference needs to be resolved.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ResolveReferenceEventArgs> ReferenceResolve
Public Event ReferenceResolve As EventHandler(Of ResolveReferenceEventArgs)
public:
virtual  event EventHandler<ResolveReferenceEventArgs^>^ ReferenceResolve {
    void add (EventHandler<ResolveReferenceEventArgs^>^ value);
    void remove (EventHandler<ResolveReferenceEventArgs^>^ value);
}
abstract ReferenceResolve : IEvent<EventHandler<ResolveReferenceEventArgs>,
    ResolveReferenceEventArgs>
override ReferenceResolve : IEvent<EventHandler<ResolveReferenceEventArgs>,
    ResolveReferenceEventArgs>

Value

Type: SystemEventHandlerResolveReferenceEventArgs

Implements

IScriptRunReferenceResolve
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ScriptCompiled Event

ScriptRunScriptCompiled Event
Occurs when the script engine running successfully.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptCompiled
Public Event ScriptCompiled As EventHandler
public:
virtual  event EventHandler^ ScriptCompiled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptCompiled : IEvent<EventHandler,
    EventArgs>
override ScriptCompiled : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptCompiled
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ScriptError Event

ScriptRunScriptError Event
Occurs when the script engine running is failed.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ScriptErrorEventArgs> ScriptError
Public Event ScriptError As EventHandler(Of ScriptErrorEventArgs)
public:
virtual  event EventHandler<ScriptErrorEventArgs^>^ ScriptError {
    void add (EventHandler<ScriptErrorEventArgs^>^ value);
    void remove (EventHandler<ScriptErrorEventArgs^>^ value);
}
abstract ScriptError : IEvent<EventHandler<ScriptErrorEventArgs>,
    ScriptErrorEventArgs>
override ScriptError : IEvent<EventHandler<ScriptErrorEventArgs>,
    ScriptErrorEventArgs>

Value

Type: SystemEventHandlerScriptErrorEventArgs

Implements

IScriptRunBaseScriptError
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ScriptExecuted Event

ScriptRunScriptExecuted Event
Occurs when script engine executes the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptExecuted
Public Event ScriptExecuted As EventHandler
public:
virtual  event EventHandler^ ScriptExecuted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptExecuted : IEvent<EventHandler,
    EventArgs>
override ScriptExecuted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptExecuted
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ScriptReset Event

ScriptRunScriptReset Event
Occurs when the script engine is reset.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptReset
Public Event ScriptReset As EventHandler
public:
virtual  event EventHandler^ ScriptReset {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptReset : IEvent<EventHandler,
    EventArgs>
override ScriptReset : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptReset
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptRun.ScriptRunning Event

ScriptRunScriptRunning Event
Occurs when script engine tries to running script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptRunning
Public Event ScriptRunning As EventHandler
public:
virtual  event EventHandler^ ScriptRunning {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptRunning : IEvent<EventHandler,
    EventArgs>
override ScriptRunning : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptRunning
See Also

Reference

ScriptRun Class
Alternet.Scripter Namespace


ScriptSource Class

ScriptSource Class
Provides methods and properties to work with script text, files or projects.
Inheritance Hierarchy
SystemObject
Alternet.ScripterScriptSource

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptSource : IScriptSource,
    IScriptSourceBase, ICloneable, IEquatable<IScriptSource>
Public Class ScriptSource
    Implements IScriptSource, IScriptSourceBase, ICloneable, IEquatable(Of IScriptSource)
public ref class ScriptSource : IScriptSource,
    IScriptSourceBase, ICloneable, IEquatable<IScriptSource^>
type ScriptSource =
    class
        interface IScriptSource
        interface IScriptSourceBase
        interface ICloneable
        interface IEquatable<IScriptSource>
    end

The ScriptSource type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptSource | Initializes a new instance of the ScriptSource class with specified script runner.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ScriptSource object.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IScriptSource) | Determines whether the specified IScriptSource is equal to the current ScriptSource.
Public method | FromExpression | Loads script source from the expression.
Public method | FromScriptCode(String) | Loads script source from the script code.
Public method | FromScriptCode(String, String) | Loads script source from the script code.
Public method | FromScriptFile | Loads script source from the script file.
Public method | FromScriptProject | Loads script source from the Visual Studio project.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLastModifiedDate | Gets file date time when script source was compiled.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBeenModified | Compares file modification dates against to other script source.
Public method | Reset | Clears script source.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithDefaultReferences | Sets default assembly references to the script source.
Top
Properties
 | Name | Description
Public property | Changed | Gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Conditionals | Gets list of conditional compilation symbols.
Public property | Expression | Gets expression to evaluate.
Public property | Files | Gets list of files containing script to execute.
Public property | FrameworkPath | Gets location of .NET Framework assemblies.
Public property | HasExpression | Returns boolean value indicating whether ScriptSource contains expression to evaluate.
Public property | HasProject | Returns boolean value indicating whether ScriptSource is associated with the project.
Public property | HasScriptCode | Returns boolean value indicating whether ScriptSource contains script code to execute.
Public property | HasScriptFile | Returns boolean value indicating whether ScriptSource contains script file to execute.
Public property | Imports | Gets list of namespaces to be used in the script.
Public property | IsWpfProject | Returns boolean value indicating whether ScriptSource contains a Wpf project
Public property | Language | Returns script programming language.
Public property | ProjectFileName | Gets a file name of the Visual Studio project containing script files to execute.
Public property | ProjectName | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | ProjectTargetFramework |
Public property | References | Gets list of external assemblies referenced from the script.
Public property | Resources | Gets list of embedded resource files.
Public property | RootNamespace | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | ScriptCode | Gets script code to execute.
Public property | ScriptFile | Gets single script file to execute.
Public property | SearchPaths | Gets list of search directories to look for source files and referenced assemblies.
Public property | WpfResources | Gets list of wpf resource files.
Top
See Also

Reference

Alternet.Scripter Namespace


ScriptSource Constructor

ScriptSource Constructor
Initializes a new instance of the ScriptSource class with specified script runner.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptSource(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
ScriptSource(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> ScriptSource

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
Specifies object that implements IScriptRun interface for this new instance.
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource Methods

ScriptSource Methods

The ScriptSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ScriptSource object.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IScriptSource) | Determines whether the specified IScriptSource is equal to the current ScriptSource.
Public method | FromExpression | Loads script source from the expression.
Public method | FromScriptCode(String) | Loads script source from the script code.
Public method | FromScriptCode(String, String) | Loads script source from the script code.
Public method | FromScriptFile | Loads script source from the script file.
Public method | FromScriptProject | Loads script source from the Visual Studio project.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLastModifiedDate | Gets file date time when script source was compiled.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBeenModified | Compares file modification dates against to other script source.
Public method | Reset | Clears script source.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithDefaultReferences | Sets default assembly references to the script source.
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Clone Method

ScriptSourceClone Method
Creates a new object that is a copy of the current ScriptSource object.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of ScriptSource that is the memberwise clone of the current ScriptSource object.

Implements

ICloneableClone
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Equals Method

ScriptSourceEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IScriptSource) | Determines whether the specified IScriptSource is equal to the current ScriptSource.
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Equals Method (IScriptSource)

ScriptSourceEquals Method (IScriptSource)
Determines whether the specified IScriptSource is equal to the current ScriptSource.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IScriptSource other
)
Public Function Equals (
    other As IScriptSource
) As Boolean
public:
virtual bool Equals(
    IScriptSource^ other
) sealed
abstract Equals :
        other : IScriptSource -> bool
override Equals :
        other : IScriptSource -> bool

Parameters

other
Type: Alternet.ScripterIScriptSource
The IScriptSource to compare with the current source.

Return Value

Type: Boolean
True if the specified source is equal to the current source; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

ScriptSource Class
Equals Overload
Alternet.Scripter Namespace


ScriptSource.FromExpression Method

ScriptSourceFromExpression Method
Loads script source from the expression.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromExpression(
    string expression
)
Public Overridable Function FromExpression (
    expression As String
) As IScriptSource
public:
virtual IScriptSource^ FromExpression(
    String^ expression
)
abstract FromExpression :
        expression : string -> IScriptSource
override FromExpression :
        expression : string -> IScriptSource

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromExpression(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.FromScriptCode Method

ScriptSourceFromScriptCode Method
Overload List
 | Name | Description
Public method | FromScriptCode(String) | Loads script source from the script code.
Public method | FromScriptCode(String, String) | Loads script source from the script code.
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.FromScriptCode Method (String)

ScriptSourceFromScriptCode Method (String)
Loads script source from the script code.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptCode(
    string scriptCode
)
Public Overridable Function FromScriptCode (
    scriptCode As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptCode(
    String^ scriptCode
)
abstract FromScriptCode :
        scriptCode : string -> IScriptSource
override FromScriptCode :
        scriptCode : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptCode(String)
See Also

Reference

ScriptSource Class
FromScriptCode Overload
Alternet.Scripter Namespace


ScriptSource.FromScriptCode Method (String, String)

ScriptSourceFromScriptCode Method (String, String)
Loads script source from the script code.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptCode(
    string scriptCode,
    string fileName
)
Public Overridable Function FromScriptCode (
    scriptCode As String,
    fileName As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptCode(
    String^ scriptCode,
    String^ fileName
)
abstract FromScriptCode :
        scriptCode : string *
        fileName : string -> IScriptSource
override FromScriptCode :
        scriptCode : string *
        fileName : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.
fileName
Type: SystemString
Specifis name if the file containing script code.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptCode(String, String)
See Also

Reference

ScriptSource Class
FromScriptCode Overload
Alternet.Scripter Namespace


ScriptSource.FromScriptFile Method

ScriptSourceFromScriptFile Method
Loads script source from the script file.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptFile(
    string fileName
)
Public Overridable Function FromScriptFile (
    fileName As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptFile(
    String^ fileName
)
abstract FromScriptFile :
        fileName : string -> IScriptSource
override FromScriptFile :
        fileName : string -> IScriptSource

Parameters

fileName
Type: SystemString
File Name to load the script.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptFile(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.FromScriptProject Method

ScriptSourceFromScriptProject Method
Loads script source from the Visual Studio project.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptProject(
    string projectFileName
)
Public Overridable Function FromScriptProject (
    projectFileName As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptProject(
    String^ projectFileName
)
abstract FromScriptProject :
        projectFileName : string -> IScriptSource
override FromScriptProject :
        projectFileName : string -> IScriptSource

Parameters

projectFileName
Type: SystemString
Project file name to load script.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptProject(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.GetLastModifiedDate Method

ScriptSourceGetLastModifiedDate Method
Gets file date time when script source was compiled.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime GetLastModifiedDate(
    string fileName
)
Public Function GetLastModifiedDate (
    fileName As String
) As DateTime
public:
virtual DateTime GetLastModifiedDate(
    String^ fileName
) sealed
abstract GetLastModifiedDate :
        fileName : string -> DateTime
override GetLastModifiedDate :
        fileName : string -> DateTime

Parameters

fileName
Type: SystemString
FileName to check last modified date.

Return Value

Type: DateTime
File date of the given file at the time it was compiled.

Implements

IScriptSourceGetLastModifiedDate(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.HasBeenModified Method

ScriptSourceHasBeenModified Method
Compares file modification dates against to other script source.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBeenModified(
    IScriptSource other
)
Public Function HasBeenModified (
    other As IScriptSource
) As Boolean
public:
virtual bool HasBeenModified(
    IScriptSource^ other
) sealed
abstract HasBeenModified :
        other : IScriptSource -> bool
override HasBeenModified :
        other : IScriptSource -> bool

Parameters

other
Type: Alternet.ScripterIScriptSource
IScriptSource to compare.

Return Value

Type: Boolean
True, if source has been changed since last compilation; otherwise false.

Implements

IScriptSourceHasBeenModified(IScriptSource)
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Reset Method

ScriptSourceReset Method
Clears script source.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptSourceReset
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.WithDefaultReferences Method

ScriptSourceWithDefaultReferences Method
Sets default assembly references to the script source.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource WithDefaultReferences(
    ScriptTechnologyEnvironment technology = ScriptTechnologyEnvironment.WindowsForms,
    bool keepExisting = false
)
Public Overridable Function WithDefaultReferences (
    Optional technology As ScriptTechnologyEnvironment = ScriptTechnologyEnvironment.WindowsForms,
    Optional keepExisting As Boolean = false
) As IScriptSource
public:
virtual IScriptSource^ WithDefaultReferences(
    ScriptTechnologyEnvironment technology = ScriptTechnologyEnvironment::WindowsForms,
    bool keepExisting = false
)
abstract WithDefaultReferences :
        ?technology : ScriptTechnologyEnvironment *
        ?keepExisting : bool
(* Defaults:
        let _technology = defaultArg technology ScriptTechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
*)
-> IScriptSource
override WithDefaultReferences :
        ?technology : ScriptTechnologyEnvironment *
        ?keepExisting : bool
(* Defaults:
        let _technology = defaultArg technology ScriptTechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
*)
-> IScriptSource

Parameters

technology (Optional)
Type: Alternet.ScripterScriptTechnologyEnvironment
keepExisting (Optional)
Type: SystemBoolean

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceWithDefaultReferences(ScriptTechnologyEnvironment, Boolean)
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource Properties

ScriptSource Properties

The ScriptSource type exposes the following members.

Properties
 | Name | Description
Public property | Changed | Gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Conditionals | Gets list of conditional compilation symbols.
Public property | Expression | Gets expression to evaluate.
Public property | Files | Gets list of files containing script to execute.
Public property | FrameworkPath | Gets location of .NET Framework assemblies.
Public property | HasExpression | Returns boolean value indicating whether ScriptSource contains expression to evaluate.
Public property | HasProject | Returns boolean value indicating whether ScriptSource is associated with the project.
Public property | HasScriptCode | Returns boolean value indicating whether ScriptSource contains script code to execute.
Public property | HasScriptFile | Returns boolean value indicating whether ScriptSource contains script file to execute.
Public property | Imports | Gets list of namespaces to be used in the script.
Public property | IsWpfProject | Returns boolean value indicating whether ScriptSource contains a Wpf project
Public property | Language | Returns script programming language.
Public property | ProjectFileName | Gets a file name of the Visual Studio project containing script files to execute.
Public property | ProjectName | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | ProjectTargetFramework |
Public property | References | Gets list of external assemblies referenced from the script.
Public property | Resources | Gets list of embedded resource files.
Public property | RootNamespace | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | ScriptCode | Gets script code to execute.
Public property | ScriptFile | Gets single script file to execute.
Public property | SearchPaths | Gets list of search directories to look for source files and referenced assemblies.
Public property | WpfResources | Gets list of wpf resource files.
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Changed Property

ScriptSourceChanged Property
Gets or sets boolean value indicating if script source has been modified since last compilation.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Changed { get; set; }
Public Property Changed As Boolean
    Get
    Set
public:
virtual property bool Changed {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Changed : bool with get, set
override Changed : bool with get, set

Property Value

Type: Boolean

Implements

IScriptSourceChanged
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Conditionals Property

ScriptSourceConditionals Property
Gets list of conditional compilation symbols.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Conditionals { get; }
Public ReadOnly Property Conditionals As IList(Of String)
    Get
public:
virtual property IList<String^>^ Conditionals {
    IList<String^>^ get () sealed;
}
abstract Conditionals : IList<string> with get
override Conditionals : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceConditionals
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Expression Property

ScriptSourceExpression Property
Gets expression to evaluate.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; }
Public ReadOnly Property Expression As String
    Get
public:
virtual property String^ Expression {
    String^ get () sealed;
}
abstract Expression : string with get
override Expression : string with get

Property Value

Type: String

Implements

IScriptSourceBaseExpression
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Files Property

ScriptSourceFiles Property
Gets list of files containing script to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Files { get; }
Public ReadOnly Property Files As IList(Of String)
    Get
public:
virtual property IList<String^>^ Files {
    IList<String^>^ get () sealed;
}
abstract Files : IList<string> with get
override Files : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceFiles
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.FrameworkPath Property

ScriptSourceFrameworkPath Property
Gets location of .NET Framework assemblies.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FrameworkPath { get; set; }
Public Property FrameworkPath As String
    Get
    Set
public:
virtual property String^ FrameworkPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FrameworkPath : string with get, set
override FrameworkPath : string with get, set

Property Value

Type: String

Implements

IScriptSourceFrameworkPath
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.HasExpression Property

ScriptSourceHasExpression Property
Returns boolean value indicating whether ScriptSource contains expression to evaluate.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasExpression { get; }
Public ReadOnly Property HasExpression As Boolean
    Get
public:
virtual property bool HasExpression {
    bool get () sealed;
}
abstract HasExpression : bool with get
override HasExpression : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasExpression
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.HasProject Property

ScriptSourceHasProject Property
Returns boolean value indicating whether ScriptSource is associated with the project.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasProject { get; }
Public ReadOnly Property HasProject As Boolean
    Get
public:
virtual property bool HasProject {
    bool get () sealed;
}
abstract HasProject : bool with get
override HasProject : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasProject
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.HasScriptCode Property

ScriptSourceHasScriptCode Property
Returns boolean value indicating whether ScriptSource contains script code to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasScriptCode { get; }
Public ReadOnly Property HasScriptCode As Boolean
    Get
public:
virtual property bool HasScriptCode {
    bool get () sealed;
}
abstract HasScriptCode : bool with get
override HasScriptCode : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasScriptCode
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.HasScriptFile Property

ScriptSourceHasScriptFile Property
Returns boolean value indicating whether ScriptSource contains script file to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasScriptFile { get; }
Public ReadOnly Property HasScriptFile As Boolean
    Get
public:
virtual property bool HasScriptFile {
    bool get () sealed;
}
abstract HasScriptFile : bool with get
override HasScriptFile : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasScriptFile
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Imports Property

ScriptSourceImports Property
Gets list of namespaces to be used in the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Imports { get; }
Public ReadOnly Property Imports As IList(Of String)
    Get
public:
virtual property IList<String^>^ Imports {
    IList<String^>^ get () sealed;
}
abstract Imports : IList<string> with get
override Imports : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceImports
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.IsWpfProject Property

ScriptSourceIsWpfProject Property
Returns boolean value indicating whether ScriptSource contains a Wpf project

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWpfProject { get; }
Public ReadOnly Property IsWpfProject As Boolean
    Get
public:
virtual property bool IsWpfProject {
    bool get () sealed;
}
abstract IsWpfProject : bool with get
override IsWpfProject : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceIsWpfProject
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Language Property

ScriptSourceLanguage Property
Returns script programming language.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptLanguage Language { get; }
Public ReadOnly Property Language As ScriptLanguage
    Get
public:
virtual property ScriptLanguage Language {
    ScriptLanguage get () sealed;
}
abstract Language : ScriptLanguage with get
override Language : ScriptLanguage with get

Property Value

Type: ScriptLanguage

Implements

IScriptSourceLanguage
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.ProjectFileName Property

ScriptSourceProjectFileName Property
Gets a file name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectFileName { get; }
Public ReadOnly Property ProjectFileName As String
    Get
public:
virtual property String^ ProjectFileName {
    String^ get () sealed;
}
abstract ProjectFileName : string with get
override ProjectFileName : string with get

Property Value

Type: String

Implements

IScriptSourceBaseProjectFileName
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.ProjectName Property

ScriptSourceProjectName Property
Gets or sets name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectName { get; set; }
Public Property ProjectName As String
    Get
    Set
public:
virtual property String^ ProjectName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ProjectName : string with get, set
override ProjectName : string with get, set

Property Value

Type: String

Implements

IScriptSourceProjectName
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.ProjectTargetFramework Property

ScriptSourceProjectTargetFramework Property

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetFramework ProjectTargetFramework { get; }
Public ReadOnly Property ProjectTargetFramework As TargetFramework
    Get
public:
virtual property TargetFramework^ ProjectTargetFramework {
    TargetFramework^ get () sealed;
}
abstract ProjectTargetFramework : TargetFramework with get
override ProjectTargetFramework : TargetFramework with get

Property Value

Type: TargetFramework

Implements

IScriptSourceProjectTargetFramework
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.References Property

ScriptSourceReferences Property
Gets list of external assemblies referenced from the script.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> References { get; }
Public ReadOnly Property References As IList(Of String)
    Get
public:
virtual property IList<String^>^ References {
    IList<String^>^ get () sealed;
}
abstract References : IList<string> with get
override References : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceReferences
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.Resources Property

ScriptSourceResources Property
Gets list of embedded resource files.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Resources { get; }
Public ReadOnly Property Resources As IList(Of String)
    Get
public:
virtual property IList<String^>^ Resources {
    IList<String^>^ get () sealed;
}
abstract Resources : IList<string> with get
override Resources : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceResources
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.RootNamespace Property

ScriptSourceRootNamespace Property
Gets or sets name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RootNamespace { get; set; }
Public Property RootNamespace As String
    Get
    Set
public:
virtual property String^ RootNamespace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract RootNamespace : string with get, set
override RootNamespace : string with get, set

Property Value

Type: String

Implements

IScriptSourceRootNamespace
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.ScriptCode Property

ScriptSourceScriptCode Property
Gets script code to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptCode { get; }
Public ReadOnly Property ScriptCode As String
    Get
public:
virtual property String^ ScriptCode {
    String^ get () sealed;
}
abstract ScriptCode : string with get
override ScriptCode : string with get

Property Value

Type: String

Implements

IScriptSourceBaseScriptCode
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.ScriptFile Property

ScriptSourceScriptFile Property
Gets single script file to execute.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptFile { get; }
Public ReadOnly Property ScriptFile As String
    Get
public:
virtual property String^ ScriptFile {
    String^ get () sealed;
}
abstract ScriptFile : string with get
override ScriptFile : string with get

Property Value

Type: String

Implements

IScriptSourceBaseScriptFile
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.SearchPaths Property

ScriptSourceSearchPaths Property
Gets list of search directories to look for source files and referenced assemblies.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> SearchPaths { get; }
Public ReadOnly Property SearchPaths As IList(Of String)
    Get
public:
virtual property IList<String^>^ SearchPaths {
    IList<String^>^ get () sealed;
}
abstract SearchPaths : IList<string> with get
override SearchPaths : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceSearchPaths
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptSource.WpfResources Property

ScriptSourceWpfResources Property
Gets list of wpf resource files.

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> WpfResources { get; }
Public ReadOnly Property WpfResources As IList(Of String)
    Get
public:
virtual property IList<String^>^ WpfResources {
    IList<String^>^ get () sealed;
}
abstract WpfResources : IList<string> with get
override WpfResources : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceWpfResources
See Also

Reference

ScriptSource Class
Alternet.Scripter Namespace


ScriptTechnologyEnvironment Enumeration

ScriptTechnologyEnvironment Enumeration
Defines a technology environment

Namespace: Alternet.Scripter
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptTechnologyEnvironment
Public Enumeration ScriptTechnologyEnvironment
public enum class ScriptTechnologyEnvironment
type ScriptTechnologyEnvironment
Members
Member name | Value | Description
WindowsForms | 0 | Specifies Windows Forms.
Wpf | 1 | Specifies Wpf.
See Also

Reference

Alternet.Scripter Namespace


Alternet.Scripter.CodeDOM Namespace

Alternet.Scripter.CodeDOM Namespace
Classes
 | Class | Description
Public class | CodeDOMScriptHost | Provides properties and methods to support script engine functionality based on System.CodeDom.Compiler technology.


CodeDOMScriptHost Class

CodeDOMScriptHost Class
Provides properties and methods to support script engine functionality based on System.CodeDom.Compiler technology.
Inheritance Hierarchy
SystemObject
Alternet.ScripterScriptHost
Alternet.Scripter.CodeDOMCodeDOMScriptHost

Namespace: Alternet.Scripter.CodeDOM
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeDOMScriptHost : ScriptHost
Public Class CodeDOMScriptHost
    Inherits ScriptHost
public ref class CodeDOMScriptHost : public ScriptHost
type CodeDOMScriptHost =
    class
        inherit ScriptHost
    end

The CodeDOMScriptHost type exposes the following members.

Constructors
 | Name | Description
Public method | CodeDOMScriptHost | Initializes a new instance of the CodeDomScriptHost class with specified script runner.
Top
Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script. (Overrides ScriptHostCompile(Boolean).)
Public method | CopyReferencedAssemblies | Copies all non-GAC assemblies referenced by a script to the output directories. (Inherited from ScriptHost.)
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it. (Inherited from ScriptHost.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression. (Inherited from ScriptHost.)
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously. (Inherited from ScriptHost.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime | (Overrides ScriptHostReferencesDotNetCoreRuntime(Version).)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers. (Overrides ScriptHostReset.)
Public method | ResolveReferences | Returns list of assembly references used by the script. (Inherited from ScriptHost.)
Public method | ResolveReferences(IListString) | Returns list of assembly references used by the script. (Inherited from ScriptHost.)
Public method | Run | Executes script starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunAsync | Executes script asynchronously starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunMethod | Executes specified method. (Inherited from ScriptHost.)
Public method | RunMethodAsync | Executes specified method asynchronously. (Inherited from ScriptHost.)
Public method | RunProcess | Executes script starting from the main entry point in standalone process. (Inherited from ScriptHost.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyFileName | Gets script assembly file name. (Inherited from ScriptHost.)
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed. (Overrides ScriptHostCompiled.)
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation. (Inherited from ScriptHost.)
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed. (Inherited from ScriptHost.)
Public property | ExecutableModulePath | Gets script assembly path. (Inherited from ScriptHost.)
Public property | GenerateModulesOnDisk | Gets or sets value indicating whether script assembly should be written to the disk or kept in memory. (Inherited from ScriptHost.)
Public property | GlobalCode | Gets a global code required for global items. (Inherited from ScriptHost.)
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies. (Inherited from ScriptHost.)
Public property | ReuseCompiledModulesFromDisk | Gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date. (Inherited from ScriptHost.)
Public property | ScriptAssembly | Returns compiled script assembly. (Overrides ScriptHostScriptAssembly.)
Public property | ScriptRun | Gets IScriptRun associated this script host. (Inherited from ScriptHost.)
Top
See Also

Reference

Alternet.Scripter.CodeDOM Namespace


CodeDOMScriptHost Constructor

CodeDOMScriptHost Constructor
Initializes a new instance of the CodeDomScriptHost class with specified script runner.

Namespace: Alternet.Scripter.CodeDOM
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeDOMScriptHost(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
CodeDOMScriptHost(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> CodeDOMScriptHost

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
Specifies object that implements IScriptRun interface for this new instance.
See Also

Reference

CodeDOMScriptHost Class
Alternet.Scripter.CodeDOM Namespace


CodeDOMScriptHost Methods

CodeDOMScriptHost Methods

The CodeDOMScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script. (Overrides ScriptHostCompile(Boolean).)
Public method | CopyReferencedAssemblies | Copies all non-GAC assemblies referenced by a script to the output directories. (Inherited from ScriptHost.)
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it. (Inherited from ScriptHost.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression. (Inherited from ScriptHost.)
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously. (Inherited from ScriptHost.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime | (Overrides ScriptHostReferencesDotNetCoreRuntime(Version).)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers. (Overrides ScriptHostReset.)
Public method | ResolveReferences | Returns list of assembly references used by the script. (Inherited from ScriptHost.)
Public method | ResolveReferences(IListString) | Returns list of assembly references used by the script. (Inherited from ScriptHost.)
Public method | Run | Executes script starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunAsync | Executes script asynchronously starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunMethod | Executes specified method. (Inherited from ScriptHost.)
Public method | RunMethodAsync | Executes specified method asynchronously. (Inherited from ScriptHost.)
Public method | RunProcess | Executes script starting from the main entry point in standalone process. (Inherited from ScriptHost.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeDOMScriptHost Class
Alternet.Scripter.CodeDOM Namespace


CodeDOMScriptHost.Compile Method

CodeDOMScriptHostCompile Method
Initializes script engine and compiles the script.

Namespace: Alternet.Scripter.CodeDOM
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Compile(
    bool copyReferences = true
)
Public Overrides Function Compile (
    Optional copyReferences As Boolean = true
) As Boolean
public:
virtual bool Compile(
    bool copyReferences = true
) override
abstract Compile :
        ?copyReferences : bool
(* Defaults:
        let _copyReferences = defaultArg copyReferences true
*)
-> bool
override Compile :
        ?copyReferences : bool
(* Defaults:
        let _copyReferences = defaultArg copyReferences true
*)
-> bool

Parameters

copyReferences (Optional)
Type: SystemBoolean
Specifies if all required assemblies should be copied to the output location

Return Value

Type: Boolean
True if succeed, otherwise false.

Implements

IScriptHostCompile(Boolean)
See Also

Reference

CodeDOMScriptHost Class
Alternet.Scripter.CodeDOM Namespace


CodeDOMScriptHost.ReferencesDotNetCoreRuntime Method

CodeDOMScriptHostReferencesDotNetCoreRuntime Method

Namespace: Alternet.Scripter.CodeDOM
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReferencesDotNetCoreRuntime(
    out Version dotNetCoreVersion
)
Public Overrides Function ReferencesDotNetCoreRuntime (
    <OutAttribute> ByRef dotNetCoreVersion As Version
) As Boolean
public:
virtual bool ReferencesDotNetCoreRuntime(
    [OutAttribute] Version^% dotNetCoreVersion
) override
abstract ReferencesDotNetCoreRuntime :
        dotNetCoreVersion : Version byref -> bool
override ReferencesDotNetCoreRuntime :
        dotNetCoreVersion : Version byref -> bool

Parameters

dotNetCoreVersion
Type: SystemVersion

Return Value

Type: Boolean

Implements

IScriptHostReferencesDotNetCoreRuntime(Version)
See Also

Reference

CodeDOMScriptHost Class
Alternet.Scripter.CodeDOM Namespace


CodeDOMScriptHost.Reset Method

CodeDOMScriptHostReset Method
Removes the script engine from the running state and disconnects automatically bound event handlers.

Namespace: Alternet.Scripter.CodeDOM
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptHostReset
See Also

Reference

CodeDOMScriptHost Class
Alternet.Scripter.CodeDOM Namespace


CodeDOMScriptHost Properties

CodeDOMScriptHost Properties

The CodeDOMScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyFileName | Gets script assembly file name. (Inherited from ScriptHost.)
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed. (Overrides ScriptHostCompiled.)
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation. (Inherited from ScriptHost.)
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed. (Inherited from ScriptHost.)
Public property | ExecutableModulePath | Gets script assembly path. (Inherited from ScriptHost.)
Public property | GenerateModulesOnDisk | Gets or sets value indicating whether script assembly should be written to the disk or kept in memory. (Inherited from ScriptHost.)
Public property | GlobalCode | Gets a global code required for global items. (Inherited from ScriptHost.)
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies. (Inherited from ScriptHost.)
Public property | ReuseCompiledModulesFromDisk | Gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date. (Inherited from ScriptHost.)
Public property | ScriptAssembly | Returns compiled script assembly. (Overrides ScriptHostScriptAssembly.)
Public property | ScriptRun | Gets IScriptRun associated this script host. (Inherited from ScriptHost.)
Top
See Also

Reference

CodeDOMScriptHost Class
Alternet.Scripter.CodeDOM Namespace


CodeDOMScriptHost.Compiled Property

CodeDOMScriptHostCompiled Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.CodeDOM
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Compiled { get; }
Public Overrides ReadOnly Property Compiled As Boolean
    Get
public:
virtual property bool Compiled {
    bool get () override;
}
abstract Compiled : bool with get
override Compiled : bool with get

Property Value

Type: Boolean

Implements

IScriptHostCompiled
See Also

Reference

CodeDOMScriptHost Class
Alternet.Scripter.CodeDOM Namespace


CodeDOMScriptHost.ScriptAssembly Property

CodeDOMScriptHostScriptAssembly Property
Returns compiled script assembly.

Namespace: Alternet.Scripter.CodeDOM
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Assembly ScriptAssembly { get; }
Public Overrides ReadOnly Property ScriptAssembly As Assembly
    Get
public:
virtual property Assembly^ ScriptAssembly {
    Assembly^ get () override;
}
abstract ScriptAssembly : Assembly with get
override ScriptAssembly : Assembly with get

Property Value

Type: Assembly

Implements

IScriptHostScriptAssembly
See Also

Reference

CodeDOMScriptHost Class
Alternet.Scripter.CodeDOM Namespace


Alternet.Scripter.Debugger Namespace

Alternet.Scripter.Debugger Namespace
Classes
 | Class | Description
Public class | ActiveThreadChangedEventArgs | Provides data for the IScriptDebugger.ActiveThreadChanged event.
Public class | BaseDefaultDebuggerUICommands |
Public class | Breakpoint | Breakpoint class is used to store individual breakpoint within debugger breakpoint collection.
Public class | BreakpointEventArgs | Provides data for the debugger breakpoint change events.
Public class | DebuggerCommunication | Provides methods to manage debugger communication between client and server via .NET Remoting.
Public class | DebuggerCommunicationScriptDebuggerRemoteControl | Provides methods for remote communication between application that executes and debugs user script.
Public class | DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink | Provides call back for remote script compilation.
Public class | DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink | Provides call back functionality remote debugging.
Public class | DebuggerConsts | Contains default constants related to debugger errors.
Public class | DebuggerErrorOccuredEventArgs | Provides data for the IScriptDebugger.DebuggerError event.
Public class | DebuggerStateChangedEventArgs | Provides data for the IScriptDebugger.StateChanged event.
Public class | DebuggingStartedEventArgs | Provides data for the IScriptDebugger.DebuggingStarted event.
Public class | DebuggingStoppedEventArgs | Provides data for the IScriptDebugger.DebuggingStopped event.
Public class | ErrorMessages | Contains default string constants related to debugger errors.
Public class | ExceptionDescription | Represents information describes an exception occurred during process execution.
Public class | ExecutionPosition | Represents information describes process's execution position.
Public class | ExecutionResumedEventArgs | Provides data for the IScriptDebugger.ExecutionResumed event.
Public class | ExecutionStoppedEventArgs | Provides data for the IScriptDebugger.ExecutionStopped event.
Public class | ExpressionEvaluationRequest | Represents data for ExpressionEvaluation request.
Public class | ExpressionEvaluationResult | Represents data of evaluated expression.
Public class | ExpressionEvaluationResultItem | Represents information describes expression evaluation result.
Public class | LogMessageReceivedEventArgs | Provides data for the IScriptDebugger.LogMessageReceived event.
Public class | RunToPositionBreakpoint | Specifies breakpoint position inside the file.
Public class | ScriptBreakpoints | Provides list of Breakpoint objects.
Public class | ScriptDebugger | Enables communication with a debugger.
Public class | ScriptFilePathService |
Public class | StackFrame | Represents information describes particular stack frame.
Public class | StackFramesRetrievalResult | Provides data for method calls that are currently on a stack.
Public class | StackFrameSwitchedEventArgs | Provides data for the IScriptDebugger.StackFrameSwitched event.
Public class | StartDebuggingOptions | Defines debug process settings.
Public class | ThreadInfo | Provides data for the ThreadClick event.
Public class | ThreadsRetrievalResult | Provides data for list of active threads.
Public class | VariablesRetrievalResult | Provides data for list of variable names.
Interfaces
 | Interface | Description
Public interface | IDebuggerUICommands | Represents Debugger commands processed by the Debugger UI.
Public interface | IScriptBreakpoints | Represents methods and properties declaration to describe list of breakpoints.
Public interface | IScriptDebugger | Provides methods and properties that allow developers to debug applications in the common language runtime (CLR) environment.
Public interface | IScriptDebuggerBase | Provides methods and properties that allow developers to debug applications in the common language runtime (CLR) environment.
Enumerations
 | Enumeration | Description
Public enumeration | DebuggerCapabilities | Defines debugger capabilities.
Public enumeration | DebuggerState | Specifies the possible debugger states.
Public enumeration | ExecutionStopReason | Defines possible causes stop execution.


ActiveThreadChangedEventArgs Class

ActiveThreadChangedEventArgs Class
Provides data for the IScriptDebugger.ActiveThreadChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerActiveThreadChangedEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ActiveThreadChangedEventArgs : EventArgs
Public Class ActiveThreadChangedEventArgs
    Inherits EventArgs
public ref class ActiveThreadChangedEventArgs : public EventArgs
type ActiveThreadChangedEventArgs =
    class
        inherit EventArgs
    end

The ActiveThreadChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveThreadChangedEventArgs | Initializes a new instance of the ActiveThreadChangedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ActivatedThread | Gets or sets newly activated thread.
Public property | DeactivatedThread | Gets or sets deactivated thread.
Public property | ErrorMessage | Gets or sets an error message. Non empty if some error occurred while changing active thread.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ActiveThreadChangedEventArgs Constructor

ActiveThreadChangedEventArgs Constructor
Initializes a new instance of the ActiveThreadChangedEventArgs class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActiveThreadChangedEventArgs()
Public Sub New
public:
ActiveThreadChangedEventArgs()
new : unit -> ActiveThreadChangedEventArgs
See Also

Reference

ActiveThreadChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


ActiveThreadChangedEventArgs Methods

ActiveThreadChangedEventArgs Methods

The ActiveThreadChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActiveThreadChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


ActiveThreadChangedEventArgs Properties

ActiveThreadChangedEventArgs Properties

The ActiveThreadChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ActivatedThread | Gets or sets newly activated thread.
Public property | DeactivatedThread | Gets or sets deactivated thread.
Public property | ErrorMessage | Gets or sets an error message. Non empty if some error occurred while changing active thread.
Top
See Also

Reference

ActiveThreadChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


ActiveThreadChangedEventArgs.ActivatedThread Property

ActiveThreadChangedEventArgsActivatedThread Property
Gets or sets newly activated thread.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadInfo ActivatedThread { get; set; }
Public Property ActivatedThread As ThreadInfo
    Get
    Set
public:
property ThreadInfo^ ActivatedThread {
    ThreadInfo^ get ();
    void set (ThreadInfo^ value);
}
member ActivatedThread : ThreadInfo with get, set

Property Value

Type: ThreadInfo
See Also

Reference

ActiveThreadChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


ActiveThreadChangedEventArgs.DeactivatedThread Property

ActiveThreadChangedEventArgsDeactivatedThread Property
Gets or sets deactivated thread.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadInfo DeactivatedThread { get; set; }
Public Property DeactivatedThread As ThreadInfo
    Get
    Set
public:
property ThreadInfo^ DeactivatedThread {
    ThreadInfo^ get ();
    void set (ThreadInfo^ value);
}
member DeactivatedThread : ThreadInfo with get, set

Property Value

Type: ThreadInfo
See Also

Reference

ActiveThreadChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


ActiveThreadChangedEventArgs.ErrorMessage Property

ActiveThreadChangedEventArgsErrorMessage Property
Gets or sets an error message. Non empty if some error occurred while changing active thread.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
See Also

Reference

ActiveThreadChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands Class

BaseDefaultDebuggerUICommands Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerBaseDefaultDebuggerUICommands
Alternet.Scripter.Debugger.UIDefaultDebuggerUICommands

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseDefaultDebuggerUICommands : IDebuggerUICommands
Public MustInherit Class BaseDefaultDebuggerUICommands
    Implements IDebuggerUICommands
public ref class BaseDefaultDebuggerUICommands abstract : IDebuggerUICommands
[<AbstractClassAttribute>]
type BaseDefaultDebuggerUICommands =
    class
        interface IDebuggerUICommands
    end

The BaseDefaultDebuggerUICommands type exposes the following members.

Constructors
 | Name | Description
Public method | BaseDefaultDebuggerUICommands | Initializes a new instance of the BaseDefaultDebuggerUICommands class
Top
Methods
 | Name | Description
Public method | Break |
Public method | Compile |
Public method | Continue |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentException |
Public method | EvaluateExpression |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PreStartup |
Public method | Start |
Public method | StepInto |
Public method | StepOver |
Public method | Stop |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands Constructor

BaseDefaultDebuggerUICommands Constructor
Initializes a new instance of the BaseDefaultDebuggerUICommands class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BaseDefaultDebuggerUICommands(
    IScriptDebuggerBase debugger
)
Public Sub New (
    debugger As IScriptDebuggerBase
)
public:
BaseDefaultDebuggerUICommands(
    IScriptDebuggerBase^ debugger
)
new :
        debugger : IScriptDebuggerBase -> BaseDefaultDebuggerUICommands

Parameters

debugger
Type: Alternet.Scripter.DebuggerIScriptDebuggerBase
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands Methods

BaseDefaultDebuggerUICommands Methods

The BaseDefaultDebuggerUICommands type exposes the following members.

Methods
 | Name | Description
Public method | Break |
Public method | Compile |
Public method | Continue |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentException |
Public method | EvaluateExpression |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PreStartup |
Public method | Start |
Public method | StepInto |
Public method | StepOver |
Public method | Stop |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.Break Method

BaseDefaultDebuggerUICommandsBreak Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Break()
Public Overridable Function Break As Boolean
public:
virtual bool Break()
abstract Break : unit -> bool
override Break : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsBreak
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.Compile Method

BaseDefaultDebuggerUICommandsCompile Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compile()
Public Overridable Function Compile As Boolean
public:
virtual bool Compile()
abstract Compile : unit -> bool
override Compile : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsCompile
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.Continue Method

BaseDefaultDebuggerUICommandsContinue Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Continue()
Public Overridable Function Continue As Boolean
public:
virtual bool Continue()
abstract Continue : unit -> bool
override Continue : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsContinue
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.EvaluateCurrentException Method

BaseDefaultDebuggerUICommandsEvaluateCurrentException Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract bool EvaluateCurrentException()
Public MustOverride Function EvaluateCurrentException As Boolean
public:
virtual bool EvaluateCurrentException() abstract
abstract EvaluateCurrentException : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsEvaluateCurrentException
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.EvaluateExpression Method

BaseDefaultDebuggerUICommandsEvaluateExpression Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract bool EvaluateExpression()
Public MustOverride Function EvaluateExpression As Boolean
public:
virtual bool EvaluateExpression() abstract
abstract EvaluateExpression : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsEvaluateExpression
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.PreStartup Method

BaseDefaultDebuggerUICommandsPreStartup Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PreStartup()
Public Function PreStartup As Boolean
public:
virtual bool PreStartup() sealed
abstract PreStartup : unit -> bool
override PreStartup : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsPreStartup
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.Start Method

BaseDefaultDebuggerUICommandsStart Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Start()
Public Overridable Function Start As Boolean
public:
virtual bool Start()
abstract Start : unit -> bool
override Start : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsStart
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.StepInto Method

BaseDefaultDebuggerUICommandsStepInto Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool StepInto()
Public Overridable Function StepInto As Boolean
public:
virtual bool StepInto()
abstract StepInto : unit -> bool
override StepInto : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsStepInto
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.StepOver Method

BaseDefaultDebuggerUICommandsStepOver Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool StepOver()
Public Overridable Function StepOver As Boolean
public:
virtual bool StepOver()
abstract StepOver : unit -> bool
override StepOver : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsStepOver
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


BaseDefaultDebuggerUICommands.Stop Method

BaseDefaultDebuggerUICommandsStop Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Stop()
Public Overridable Function Stop As Boolean
public:
virtual bool Stop()
abstract Stop : unit -> bool
override Stop : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsStop
See Also

Reference

BaseDefaultDebuggerUICommands Class
Alternet.Scripter.Debugger Namespace


Breakpoint Class

Breakpoint Class
Breakpoint class is used to store individual breakpoint within debugger breakpoint collection.
Inheritance Hierarchy
SystemObject
ValueObjectBreakpoint
Alternet.Scripter.DebuggerBreakpoint

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Breakpoint : ValueObject<Breakpoint>
Public Class Breakpoint
    Inherits ValueObject(Of Breakpoint)
public ref class Breakpoint : public ValueObject<Breakpoint^>
type Breakpoint =
    class
        inherit ValueObject<Breakpoint>
    end

The Breakpoint type exposes the following members.

Constructors
 | Name | Description
Public method | Breakpoint | Initializes a new instance of the Breakpoint class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value indicating whether this breakpoint is enabled.
Public property | FilePath | Gets or sets name of file where breakpoint is set.
Public property | LineNumber | Gets or sets number of line at which breakpoint is set.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


Breakpoint Constructor

Breakpoint Constructor
Initializes a new instance of the Breakpoint class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoint(
    IScriptBreakpoints owner,
    string fileName,
    int lineNumber
)
Public Sub New (
    owner As IScriptBreakpoints,
    fileName As String,
    lineNumber As Integer
)
public:
Breakpoint(
    IScriptBreakpoints^ owner,
    String^ fileName,
    int lineNumber
)
new :
        owner : IScriptBreakpoints *
        fileName : string *
        lineNumber : int -> Breakpoint

Parameters

owner
Type: Alternet.Scripter.DebuggerIScriptBreakpoints
fileName
Type: SystemString
lineNumber
Type: SystemInt32
See Also

Reference

Breakpoint Class
Alternet.Scripter.Debugger Namespace


Breakpoint Methods

Breakpoint Methods

The Breakpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Breakpoint Class
Alternet.Scripter.Debugger Namespace


Breakpoint Properties

Breakpoint Properties

The Breakpoint type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value indicating whether this breakpoint is enabled.
Public property | FilePath | Gets or sets name of file where breakpoint is set.
Public property | LineNumber | Gets or sets number of line at which breakpoint is set.
Top
See Also

Reference

Breakpoint Class
Alternet.Scripter.Debugger Namespace


Breakpoint.Enabled Property

BreakpointEnabled Property
Gets or sets a boolean value indicating whether this breakpoint is enabled.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Breakpoint Class
Alternet.Scripter.Debugger Namespace


Breakpoint.FilePath Property

BreakpointFilePath Property
Gets or sets name of file where breakpoint is set.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get
public:
property String^ FilePath {
    String^ get ();
}
member FilePath : string with get

Property Value

Type: String
See Also

Reference

Breakpoint Class
Alternet.Scripter.Debugger Namespace


Breakpoint.LineNumber Property

BreakpointLineNumber Property
Gets or sets number of line at which breakpoint is set.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LineNumber { get; }
Public ReadOnly Property LineNumber As Integer
    Get
public:
property int LineNumber {
    int get ();
}
member LineNumber : int with get

Property Value

Type: Int32
See Also

Reference

Breakpoint Class
Alternet.Scripter.Debugger Namespace


BreakpointEventArgs Class

BreakpointEventArgs Class
Provides data for the debugger breakpoint change events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerBreakpointEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BreakpointEventArgs : EventArgs
Public Class BreakpointEventArgs
    Inherits EventArgs
public ref class BreakpointEventArgs : public EventArgs
type BreakpointEventArgs =
    class
        inherit EventArgs
    end

The BreakpointEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BreakpointEventArgs | Initializes a new instance of BreakpointEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Breakpoint | The Breakpoint instance related to the event.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


BreakpointEventArgs Constructor

BreakpointEventArgs Constructor
Initializes a new instance of BreakpointEventArgs class.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BreakpointEventArgs(
    Breakpoint breakpoint
)
Public Sub New (
    breakpoint As Breakpoint
)
public:
BreakpointEventArgs(
    Breakpoint^ breakpoint
)
new :
        breakpoint : Breakpoint -> BreakpointEventArgs

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
See Also

Reference

BreakpointEventArgs Class
Alternet.Scripter.Debugger Namespace


BreakpointEventArgs Methods

BreakpointEventArgs Methods

The BreakpointEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BreakpointEventArgs Class
Alternet.Scripter.Debugger Namespace


BreakpointEventArgs Properties

BreakpointEventArgs Properties

The BreakpointEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoint | The Breakpoint instance related to the event.
Top
See Also

Reference

BreakpointEventArgs Class
Alternet.Scripter.Debugger Namespace


BreakpointEventArgs.Breakpoint Property

BreakpointEventArgsBreakpoint Property
The Breakpoint instance related to the event.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoint Breakpoint { get; }
Public ReadOnly Property Breakpoint As Breakpoint
    Get
public:
property Breakpoint^ Breakpoint {
    Breakpoint^ get ();
}
member Breakpoint : Breakpoint with get

Property Value

Type: Breakpoint
See Also

Reference

BreakpointEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggerCapabilities Enumeration

DebuggerCapabilities Enumeration
Defines debugger capabilities.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum DebuggerCapabilities
<FlagsAttribute>
Public Enumeration DebuggerCapabilities
[FlagsAttribute]
public enum class DebuggerCapabilities
[<FlagsAttribute>]
type DebuggerCapabilities
Members
Member name | Value | Description
None | 0 | No capabilities.
SetValue | 1 | Debugger is capable of setting variable values.
BreakpointStatement | 2 | Debugger is capable of setting breakpoint statement.
Threads | 4 | Debugger is capable of managing program threads.
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggerCommunication Class

DebuggerCommunication Class
Provides methods to manage debugger communication between client and server via .NET Remoting.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerDebuggerCommunication

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DebuggerCommunication
Public NotInheritable Class DebuggerCommunication
public ref class DebuggerCommunication abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DebuggerCommunication =  class end

The DebuggerCommunication type exposes the following members.

Methods
Name | Description
StartClient(String, String, String) | Start client using specified parameters.
StartClient(IChannel, String, String, String) | Start client using specified parameters.
StartServer | Start remote server using specified parameters.
StopClient | Stops client which is connected to the specified channel.
StopServer | Stops server connected to the specified channel.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggerCommunication Methods

DebuggerCommunication Methods

The DebuggerCommunication type exposes the following members.

Methods
Name | Description
StartClient(String, String, String) | Start client using specified parameters.
StartClient(IChannel, String, String, String) | Start client using specified parameters.
StartServer | Start remote server using specified parameters.
StopClient | Stops client which is connected to the specified channel.
StopServer | Stops server connected to the specified channel.
Top
See Also

Reference

DebuggerCommunication Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.StartClient Method

DebuggerCommunicationStartClient Method
Overload List
Name | Description
StartClient(String, String, String) | Start client using specified parameters.
StartClient(IChannel, String, String, String) | Start client using specified parameters.
Top
See Also

Reference

DebuggerCommunication Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.StartClient Method (String, String, String)

DebuggerCommunicationStartClient Method (String, String, String)
Start client using specified parameters.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IScriptDebuggerRemoteControl StartClient(
    string ipcPortName = null,
    string ipcObjectUri = null,
    string ipcClientChannel = null
)
Public Shared Function StartClient (
    Optional ipcPortName As String = Nothing,
    Optional ipcObjectUri As String = Nothing,
    Optional ipcClientChannel As String = Nothing
) As IScriptDebuggerRemoteControl
public:
static IScriptDebuggerRemoteControl^ StartClient(
    String^ ipcPortName = nullptr,
    String^ ipcObjectUri = nullptr,
    String^ ipcClientChannel = nullptr
)
static member StartClient :
        ?ipcPortName : string *
        ?ipcObjectUri : string *
        ?ipcClientChannel : string
(* Defaults:
        let _ipcPortName = defaultArg ipcPortName null
        let _ipcObjectUri = defaultArg ipcObjectUri null
        let _ipcClientChannel = defaultArg ipcClientChannel null
*)
-> IScriptDebuggerRemoteControl

Parameters

ipcPortName (Optional)
Type: SystemString
Name of IPC port.
ipcObjectUri (Optional)
Type: SystemString
URL of IPC port.
ipcClientChannel (Optional)
Type: SystemString
IPC client channel.

Return Value

Type: IScriptDebuggerRemoteControl
Object that provides remote communication.
See Also

Reference

DebuggerCommunication Class
StartClient Overload
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.StartClient Method (IChannel, String, String, String)

DebuggerCommunicationStartClient Method (IChannel, String, String, String)
Start client using specified parameters.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IScriptDebuggerRemoteControl StartClient(
    out IChannel channel,
    string ipcPortName = null,
    string ipcObjectUri = null,
    string ipcClientChannel = null
)
Public Shared Function StartClient (
    <OutAttribute> ByRef channel As IChannel,
    Optional ipcPortName As String = Nothing,
    Optional ipcObjectUri As String = Nothing,
    Optional ipcClientChannel As String = Nothing
) As IScriptDebuggerRemoteControl
public:
static IScriptDebuggerRemoteControl^ StartClient(
    [OutAttribute] IChannel^% channel,
    String^ ipcPortName = nullptr,
    String^ ipcObjectUri = nullptr,
    String^ ipcClientChannel = nullptr
)
static member StartClient :
        channel : IChannel byref *
        ?ipcPortName : string *
        ?ipcObjectUri : string *
        ?ipcClientChannel : string
(* Defaults:
        let _ipcPortName = defaultArg ipcPortName null
        let _ipcObjectUri = defaultArg ipcObjectUri null
        let _ipcClientChannel = defaultArg ipcClientChannel null
*)
-> IScriptDebuggerRemoteControl

Parameters

channel
Type: System.Runtime.Remoting.ChannelsIChannel
Receives created IPC channel to transmit messages between server and client.
ipcPortName (Optional)
Type: SystemString
Name of IPC port.
ipcObjectUri (Optional)
Type: SystemString
URL of IPC port.
ipcClientChannel (Optional)
Type: SystemString
IPC client channel.

Return Value

Type: IScriptDebuggerRemoteControl
Object that provides remote communication.
See Also

Reference

DebuggerCommunication Class
StartClient Overload
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.StartServer Method

DebuggerCommunicationStartServer Method
Start remote server using specified parameters.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IChannel StartServer(
    IScriptRemoteControl scriptControl,
    string ipcPortName = null,
    string ipcObjectUri = null
)
Public Shared Function StartServer (
    scriptControl As IScriptRemoteControl,
    Optional ipcPortName As String = Nothing,
    Optional ipcObjectUri As String = Nothing
) As IChannel
public:
static IChannel^ StartServer(
    IScriptRemoteControl^ scriptControl,
    String^ ipcPortName = nullptr,
    String^ ipcObjectUri = nullptr
)
static member StartServer :
        scriptControl : IScriptRemoteControl *
        ?ipcPortName : string *
        ?ipcObjectUri : string
(* Defaults:
        let _ipcPortName = defaultArg ipcPortName null
        let _ipcObjectUri = defaultArg ipcObjectUri null
*)
-> IChannel

Parameters

scriptControl
Type: Alternet.ScripterIScriptRemoteControl
Control to compile script and start debugger.
ipcPortName (Optional)
Type: SystemString
Name of IPC port.
ipcObjectUri (Optional)
Type: SystemString
URL of IPC port.

Return Value

Type: IChannel
IPC channel to transmit messages between server and client.
See Also

Reference

DebuggerCommunication Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.StopClient Method

DebuggerCommunicationStopClient Method
Stops client which is connected to the specified channel.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void StopClient(
    IChannel channel
)
Public Shared Sub StopClient (
    channel As IChannel
)
public:
static void StopClient(
    IChannel^ channel
)
static member StopClient :
        channel : IChannel -> unit

Parameters

channel
Type: System.Runtime.Remoting.ChannelsIChannel
IChannel connected to the client that will be stopped.
See Also

Reference

DebuggerCommunication Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.StopServer Method

DebuggerCommunicationStopServer Method
Stops server connected to the specified channel.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void StopServer(
    IChannel channel
)
Public Shared Sub StopServer (
    channel As IChannel
)
public:
static void StopServer(
    IChannel^ channel
)
static member StopServer :
        channel : IChannel -> unit

Parameters

channel
Type: System.Runtime.Remoting.ChannelsIChannel
IChannel connected to the server that will be stopped.
See Also

Reference

DebuggerCommunication Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControl Class

DebuggerCommunicationScriptDebuggerRemoteControl Class
Provides methods for remote communication between application that executes and debugs user script.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Alternet.Scripter.DebuggerDebuggerCommunicationScriptDebuggerRemoteControl

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptDebuggerRemoteControl : MarshalByRefObject,
    IScriptDebuggerRemoteControl
Public Class ScriptDebuggerRemoteControl
    Inherits MarshalByRefObject
    Implements IScriptDebuggerRemoteControl
public ref class ScriptDebuggerRemoteControl : public MarshalByRefObject,
    IScriptDebuggerRemoteControl
type ScriptDebuggerRemoteControl =
    class
        inherit MarshalByRefObject
        interface IScriptDebuggerRemoteControl
    end

The DebuggerCommunicationScriptDebuggerRemoteControl type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerCommunicationScriptDebuggerRemoteControl | Initializes a new instance of the DebuggerCommunicationScriptDebuggerRemoteControl class
Top
Methods
 | Name | Description
Public method | CompileScript | Compiles scripts, and calls back the given delegate when compilation is complete.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsScriptRunning | Returns boolean value indicating that script is currently running.
Public method | StartScript | Starts script execution.
Public method | StopScript | Stops script execution.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControl Constructor

DebuggerCommunicationScriptDebuggerRemoteControl Constructor
Initializes a new instance of the DebuggerCommunicationScriptDebuggerRemoteControl class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptDebuggerRemoteControl()
Public Sub New
public:
ScriptDebuggerRemoteControl()
new : unit -> ScriptDebuggerRemoteControl
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControl Class
Alternet.Scripter.Debugger Namespace


ScriptDebuggerRemoteControl Methods

ScriptDebuggerRemoteControl Methods

The DebuggerCommunicationScriptDebuggerRemoteControl type exposes the following members.

Methods
 | Name | Description
Public method | CompileScript | Compiles scripts, and calls back the given delegate when compilation is complete.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsScriptRunning | Returns boolean value indicating that script is currently running.
Public method | StartScript | Starts script execution.
Public method | StopScript | Stops script execution.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControl Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControl.CompileScript Method

DebuggerCommunicationScriptDebuggerRemoteControlCompileScript Method
Compiles scripts, and calls back the given delegate when compilation is complete.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CompileScript(
    ScriptCompiledDelegate onScriptCompiled
)
Public Sub CompileScript (
    onScriptCompiled As ScriptCompiledDelegate
)
public:
virtual void CompileScript(
    ScriptCompiledDelegate^ onScriptCompiled
) sealed
abstract CompileScript :
        onScriptCompiled : ScriptCompiledDelegate -> unit
override CompileScript :
        onScriptCompiled : ScriptCompiledDelegate -> unit

Parameters

onScriptCompiled
Type: Alternet.ScripterScriptCompiledDelegate

Implements

IScriptDebuggerRemoteControlCompileScript(ScriptCompiledDelegate)
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControl Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControl.IsScriptRunning Method

DebuggerCommunicationScriptDebuggerRemoteControlIsScriptRunning Method
Returns boolean value indicating that script is currently running.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsScriptRunning()
Public Function IsScriptRunning As Boolean
public:
virtual bool IsScriptRunning() sealed
abstract IsScriptRunning : unit -> bool
override IsScriptRunning : unit -> bool

Return Value

Type: Boolean

Implements

IScriptDebuggerRemoteControlIsScriptRunning
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControl Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControl.StartScript Method

DebuggerCommunicationScriptDebuggerRemoteControlStartScript Method
Starts script execution.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartScript(
    ScriptFinishedDelegate onScriptFinished
)
Public Sub StartScript (
    onScriptFinished As ScriptFinishedDelegate
)
public:
virtual void StartScript(
    ScriptFinishedDelegate^ onScriptFinished
) sealed
abstract StartScript :
        onScriptFinished : ScriptFinishedDelegate -> unit
override StartScript :
        onScriptFinished : ScriptFinishedDelegate -> unit

Parameters

onScriptFinished
Type: Alternet.ScripterScriptFinishedDelegate

Implements

IScriptDebuggerRemoteControlStartScript(ScriptFinishedDelegate)
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControl Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControl.StopScript Method

DebuggerCommunicationScriptDebuggerRemoteControlStopScript Method
Stops script execution.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StopScript()
Public Sub StopScript
public:
virtual void StopScript() sealed
abstract StopScript : unit -> unit
override StopScript : unit -> unit

Implements

IScriptDebuggerRemoteControlStopScript
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControl Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControlCompileCallbackSink Class

DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink Class
Provides call back for remote script compilation.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Alternet.Scripter.DebuggerDebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptDebuggerRemoteControlCompileCallbackSink : MarshalByRefObject
Public Class ScriptDebuggerRemoteControlCompileCallbackSink
    Inherits MarshalByRefObject
public ref class ScriptDebuggerRemoteControlCompileCallbackSink : public MarshalByRefObject
type ScriptDebuggerRemoteControlCompileCallbackSink =
    class
        inherit MarshalByRefObject
    end

The DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink | Initializes a new instance of ScriptDebuggerRemoteControlCompileCallbackSink with specified call back delegate.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | OnScriptCompiled | Call back method executed after script was compiled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControlCompileCallbackSink Constructor

DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink Constructor
Initializes a new instance of ScriptDebuggerRemoteControlCompileCallbackSink with specified call back delegate.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptDebuggerRemoteControlCompileCallbackSink(
    ScriptCompiledDelegate onScriptCompiled
)
Public Sub New (
    onScriptCompiled As ScriptCompiledDelegate
)
public:
ScriptDebuggerRemoteControlCompileCallbackSink(
    ScriptCompiledDelegate^ onScriptCompiled
)
new :
        onScriptCompiled : ScriptCompiledDelegate -> ScriptDebuggerRemoteControlCompileCallbackSink

Parameters

onScriptCompiled
Type: Alternet.ScripterScriptCompiledDelegate
Delegate receives call back.
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink Class
Alternet.Scripter.Debugger Namespace


ScriptDebuggerRemoteControlCompileCallbackSink Methods

ScriptDebuggerRemoteControlCompileCallbackSink Methods

The DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | OnScriptCompiled | Call back method executed after script was compiled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControlCompileCallbackSink.OnScriptCompiled Method

DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSinkOnScriptCompiled Method
Call back method executed after script was compiled.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void OnScriptCompiled(
    ScriptCompilationResult result
)
Public Sub OnScriptCompiled (
    result As ScriptCompilationResult
)
public:
void OnScriptCompiled(
    ScriptCompilationResult result
)
member OnScriptCompiled :
        result : ScriptCompilationResult -> unit

Parameters

result
Type: Alternet.ScripterScriptCompilationResult
Stores compilation result.
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControlCompileCallbackSink Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControlStartCallbackSink Class

DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink Class
Provides call back functionality remote debugging.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Alternet.Scripter.DebuggerDebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptDebuggerRemoteControlStartCallbackSink : MarshalByRefObject
Public Class ScriptDebuggerRemoteControlStartCallbackSink
    Inherits MarshalByRefObject
public ref class ScriptDebuggerRemoteControlStartCallbackSink : public MarshalByRefObject
type ScriptDebuggerRemoteControlStartCallbackSink =
    class
        inherit MarshalByRefObject
    end

The DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink | Initializes a new instance of ScriptDebuggerRemoteControlStartCallbackSink with specified call back delegate.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | OnScriptFinished | Call back method executed after script executing was finished.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControlStartCallbackSink Constructor

DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink Constructor
Initializes a new instance of ScriptDebuggerRemoteControlStartCallbackSink with specified call back delegate.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptDebuggerRemoteControlStartCallbackSink(
    ScriptFinishedDelegate onScriptFinished
)
Public Sub New (
    onScriptFinished As ScriptFinishedDelegate
)
public:
ScriptDebuggerRemoteControlStartCallbackSink(
    ScriptFinishedDelegate^ onScriptFinished
)
new :
        onScriptFinished : ScriptFinishedDelegate -> ScriptDebuggerRemoteControlStartCallbackSink

Parameters

onScriptFinished
Type: Alternet.ScripterScriptFinishedDelegate
Delegate receives call back.
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink Class
Alternet.Scripter.Debugger Namespace


ScriptDebuggerRemoteControlStartCallbackSink Methods

ScriptDebuggerRemoteControlStartCallbackSink Methods

The DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | OnScriptFinished | Call back method executed after script executing was finished.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink Class
Alternet.Scripter.Debugger Namespace


DebuggerCommunication.ScriptDebuggerRemoteControlStartCallbackSink.OnScriptFinished Method

DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSinkOnScriptFinished Method
Call back method executed after script executing was finished.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void OnScriptFinished()
Public Sub OnScriptFinished
public:
void OnScriptFinished()
member OnScriptFinished : unit -> unit
See Also

Reference

DebuggerCommunicationScriptDebuggerRemoteControlStartCallbackSink Class
Alternet.Scripter.Debugger Namespace


DebuggerConsts Class

DebuggerConsts Class
Contains default constants related to debugger errors.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerDebuggerConsts

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebuggerConsts
Public Class DebuggerConsts
public ref class DebuggerConsts
type DebuggerConsts =  class end

The DebuggerConsts type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerConsts | Initializes a new instance of the DebuggerConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ExceptionEvaluationExpression |
UnableToEvaluateExpression |
WaitForUserCodeInSeconds |
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggerConsts Constructor

DebuggerConsts Constructor
Initializes a new instance of the DebuggerConsts class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerConsts()
Public Sub New
public:
DebuggerConsts()
new : unit -> DebuggerConsts
See Also

Reference

DebuggerConsts Class
Alternet.Scripter.Debugger Namespace


DebuggerConsts Fields

DebuggerConsts Fields

The DebuggerConsts type exposes the following members.

Fields
Name | Description
ExceptionEvaluationExpression |
UnableToEvaluateExpression |
WaitForUserCodeInSeconds |
Top
See Also

Reference

DebuggerConsts Class
Alternet.Scripter.Debugger Namespace


DebuggerConsts.ExceptionEvaluationExpression Field

DebuggerConstsExceptionEvaluationExpression Field

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ExceptionEvaluationExpression
Public Const ExceptionEvaluationExpression As String
public:
literal String^ ExceptionEvaluationExpression
static val mutable ExceptionEvaluationExpression: string

Field Value

Type: String
See Also

Reference

DebuggerConsts Class
Alternet.Scripter.Debugger Namespace


DebuggerConsts.UnableToEvaluateExpression Field

DebuggerConstsUnableToEvaluateExpression Field

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string UnableToEvaluateExpression
Public Const UnableToEvaluateExpression As String
public:
literal String^ UnableToEvaluateExpression
static val mutable UnableToEvaluateExpression: string

Field Value

Type: String
See Also

Reference

DebuggerConsts Class
Alternet.Scripter.Debugger Namespace


DebuggerConsts.WaitForUserCodeInSeconds Field

DebuggerConstsWaitForUserCodeInSeconds Field

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int WaitForUserCodeInSeconds
Public Shared WaitForUserCodeInSeconds As Integer
public:
static int WaitForUserCodeInSeconds
static val mutable WaitForUserCodeInSeconds: int

Field Value

Type: Int32
See Also

Reference

DebuggerConsts Class
Alternet.Scripter.Debugger Namespace


DebuggerConsts Methods

DebuggerConsts Methods

The DebuggerConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggerConsts Class
Alternet.Scripter.Debugger Namespace


DebuggerErrorOccuredEventArgs Class

DebuggerErrorOccuredEventArgs Class
Provides data for the IScriptDebugger.DebuggerError event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerDebuggerErrorOccuredEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebuggerErrorOccuredEventArgs : EventArgs
Public Class DebuggerErrorOccuredEventArgs
    Inherits EventArgs
public ref class DebuggerErrorOccuredEventArgs : public EventArgs
type DebuggerErrorOccuredEventArgs =
    class
        inherit EventArgs
    end

The DebuggerErrorOccuredEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerErrorOccuredEventArgs | Initializes a new instance of the DebuggerErrorOccuredEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the Exception to process.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggerErrorOccuredEventArgs Constructor

DebuggerErrorOccuredEventArgs Constructor
Initializes a new instance of the DebuggerErrorOccuredEventArgs class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerErrorOccuredEventArgs()
Public Sub New
public:
DebuggerErrorOccuredEventArgs()
new : unit -> DebuggerErrorOccuredEventArgs
See Also

Reference

DebuggerErrorOccuredEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggerErrorOccuredEventArgs Methods

DebuggerErrorOccuredEventArgs Methods

The DebuggerErrorOccuredEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggerErrorOccuredEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggerErrorOccuredEventArgs Properties

DebuggerErrorOccuredEventArgs Properties

The DebuggerErrorOccuredEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the Exception to process.
Top
See Also

Reference

DebuggerErrorOccuredEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggerErrorOccuredEventArgs.Exception Property

DebuggerErrorOccuredEventArgsException Property
Gets or sets the Exception to process.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Exception Exception { get; set; }
Public Property Exception As Exception
    Get
    Set
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}
member Exception : Exception with get, set

Property Value

Type: Exception
See Also

Reference

DebuggerErrorOccuredEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggerState Enumeration

DebuggerState Enumeration
Specifies the possible debugger states.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DebuggerState
Public Enumeration DebuggerState
public enum class DebuggerState
type DebuggerState
Members
Member name | Value | Description
Off | 0 | Debugger is off.
Startup | 1 | Debugger is ready to start.
Running | 2 | Debugger is running.
Stopped | 3 | Debugger is stopped.
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggerStateChangedEventArgs Class

DebuggerStateChangedEventArgs Class
Provides data for the IScriptDebugger.StateChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerDebuggerStateChangedEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebuggerStateChangedEventArgs : EventArgs
Public Class DebuggerStateChangedEventArgs
    Inherits EventArgs
public ref class DebuggerStateChangedEventArgs : public EventArgs
type DebuggerStateChangedEventArgs =
    class
        inherit EventArgs
    end

The DebuggerStateChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerStateChangedEventArgs | Initializes a new instance of the DebuggerStateChangedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | NewState | Gets or sets new debugger state.
Public property | OldState | Gets or sets debugger state before change.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggerStateChangedEventArgs Constructor

DebuggerStateChangedEventArgs Constructor
Initializes a new instance of the DebuggerStateChangedEventArgs class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerStateChangedEventArgs()
Public Sub New
public:
DebuggerStateChangedEventArgs()
new : unit -> DebuggerStateChangedEventArgs
See Also

Reference

DebuggerStateChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggerStateChangedEventArgs Methods

DebuggerStateChangedEventArgs Methods

The DebuggerStateChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggerStateChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggerStateChangedEventArgs Properties

DebuggerStateChangedEventArgs Properties

The DebuggerStateChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewState | Gets or sets new debugger state.
Public property | OldState | Gets or sets debugger state before change.
Top
See Also

Reference

DebuggerStateChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggerStateChangedEventArgs.NewState Property

DebuggerStateChangedEventArgsNewState Property
Gets or sets new debugger state.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerState NewState { get; set; }
Public Property NewState As DebuggerState
    Get
    Set
public:
property DebuggerState NewState {
    DebuggerState get ();
    void set (DebuggerState value);
}
member NewState : DebuggerState with get, set

Property Value

Type: DebuggerState
See Also

Reference

DebuggerStateChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggerStateChangedEventArgs.OldState Property

DebuggerStateChangedEventArgsOldState Property
Gets or sets debugger state before change.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerState OldState { get; set; }
Public Property OldState As DebuggerState
    Get
    Set
public:
property DebuggerState OldState {
    DebuggerState get ();
    void set (DebuggerState value);
}
member OldState : DebuggerState with get, set

Property Value

Type: DebuggerState
See Also

Reference

DebuggerStateChangedEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggingStartedEventArgs Class

DebuggingStartedEventArgs Class
Provides data for the IScriptDebugger.DebuggingStarted event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerDebuggingStartedEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebuggingStartedEventArgs : EventArgs
Public Class DebuggingStartedEventArgs
    Inherits EventArgs
public ref class DebuggingStartedEventArgs : public EventArgs
type DebuggingStartedEventArgs =
    class
        inherit EventArgs
    end

The DebuggingStartedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggingStartedEventArgs | Initializes a new instance of the DebuggingStartedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggingStartedEventArgs Constructor

DebuggingStartedEventArgs Constructor
Initializes a new instance of the DebuggingStartedEventArgs class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggingStartedEventArgs()
Public Sub New
public:
DebuggingStartedEventArgs()
new : unit -> DebuggingStartedEventArgs
See Also

Reference

DebuggingStartedEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggingStartedEventArgs Methods

DebuggingStartedEventArgs Methods

The DebuggingStartedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggingStartedEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggingStoppedEventArgs Class

DebuggingStoppedEventArgs Class
Provides data for the IScriptDebugger.DebuggingStopped event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerDebuggingStoppedEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebuggingStoppedEventArgs : EventArgs
Public Class DebuggingStoppedEventArgs
    Inherits EventArgs
public ref class DebuggingStoppedEventArgs : public EventArgs
type DebuggingStoppedEventArgs =
    class
        inherit EventArgs
    end

The DebuggingStoppedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggingStoppedEventArgs | Initializes a new instance of the DebuggingStoppedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


DebuggingStoppedEventArgs Constructor

DebuggingStoppedEventArgs Constructor
Initializes a new instance of the DebuggingStoppedEventArgs class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggingStoppedEventArgs()
Public Sub New
public:
DebuggingStoppedEventArgs()
new : unit -> DebuggingStoppedEventArgs
See Also

Reference

DebuggingStoppedEventArgs Class
Alternet.Scripter.Debugger Namespace


DebuggingStoppedEventArgs Methods

DebuggingStoppedEventArgs Methods

The DebuggingStoppedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggingStoppedEventArgs Class
Alternet.Scripter.Debugger Namespace


ErrorMessages Class

ErrorMessages Class
Contains default string constants related to debugger errors.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerErrorMessages

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ErrorMessages
Public Class ErrorMessages
public ref class ErrorMessages
type ErrorMessages =  class end

The ErrorMessages type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorMessages | Initializes a new instance of the ErrorMessages class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
UnableToEvaluteExpressionWhenNotStarted |
UnableToEvaluteExpressionWhileRunning |
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ErrorMessages Constructor

ErrorMessages Constructor
Initializes a new instance of the ErrorMessages class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ErrorMessages()
Public Sub New
public:
ErrorMessages()
new : unit -> ErrorMessages
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger Namespace


ErrorMessages Fields

ErrorMessages Fields

The ErrorMessages type exposes the following members.

Fields
Name | Description
UnableToEvaluteExpressionWhenNotStarted |
UnableToEvaluteExpressionWhileRunning |
Top
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger Namespace


ErrorMessages.UnableToEvaluteExpressionWhenNotStarted Field

ErrorMessagesUnableToEvaluteExpressionWhenNotStarted Field

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string UnableToEvaluteExpressionWhenNotStarted
Public Const UnableToEvaluteExpressionWhenNotStarted As String
public:
literal String^ UnableToEvaluteExpressionWhenNotStarted
static val mutable UnableToEvaluteExpressionWhenNotStarted: string

Field Value

Type: String
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger Namespace


ErrorMessages.UnableToEvaluteExpressionWhileRunning Field

ErrorMessagesUnableToEvaluteExpressionWhileRunning Field

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string UnableToEvaluteExpressionWhileRunning
Public Const UnableToEvaluteExpressionWhileRunning As String
public:
literal String^ UnableToEvaluteExpressionWhileRunning
static val mutable UnableToEvaluteExpressionWhileRunning: string

Field Value

Type: String
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger Namespace


ErrorMessages Methods

ErrorMessages Methods

The ErrorMessages type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger Namespace


ExceptionDescription Class

ExceptionDescription Class
Represents information describes an exception occurred during process execution.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerExceptionDescription

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExceptionDescription
Public Class ExceptionDescription
public ref class ExceptionDescription
type ExceptionDescription =  class end

The ExceptionDescription type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionDescription | Initializes a new instance of the ExceptionDescription class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the exception. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | ExceptionEvaluationExpression | Gets or sets an expression that is a source of exception.
Public property | ExceptionType | Gets or sets an exception type.
Public property | Message | Gets or sets a message that describes exception.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ExceptionDescription Constructor

ExceptionDescription Constructor
Initializes a new instance of the ExceptionDescription class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDescription()
Public Sub New
public:
ExceptionDescription()
new : unit -> ExceptionDescription
See Also

Reference

ExceptionDescription Class
Alternet.Scripter.Debugger Namespace


ExceptionDescription Methods

ExceptionDescription Methods

The ExceptionDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the exception. (Overrides ObjectToString.)
Top
See Also

Reference

ExceptionDescription Class
Alternet.Scripter.Debugger Namespace


ExceptionDescription.ToString Method

ExceptionDescriptionToString Method
Returns a String that represents the exception.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents the ExceptionDescription.
See Also

Reference

ExceptionDescription Class
Alternet.Scripter.Debugger Namespace


ExceptionDescription Properties

ExceptionDescription Properties

The ExceptionDescription type exposes the following members.

Properties
 | Name | Description
Public property | ExceptionEvaluationExpression | Gets or sets an expression that is a source of exception.
Public property | ExceptionType | Gets or sets an exception type.
Public property | Message | Gets or sets a message that describes exception.
Top
See Also

Reference

ExceptionDescription Class
Alternet.Scripter.Debugger Namespace


ExceptionDescription.ExceptionEvaluationExpression Property

ExceptionDescriptionExceptionEvaluationExpression Property
Gets or sets an expression that is a source of exception.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ExceptionEvaluationExpression { get; set; }
Public Property ExceptionEvaluationExpression As String
    Get
    Set
public:
property String^ ExceptionEvaluationExpression {
    String^ get ();
    void set (String^ value);
}
member ExceptionEvaluationExpression : string with get, set

Property Value

Type: String
See Also

Reference

ExceptionDescription Class
Alternet.Scripter.Debugger Namespace


ExceptionDescription.ExceptionType Property

ExceptionDescriptionExceptionType Property
Gets or sets an exception type.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ExceptionType { get; set; }
Public Property ExceptionType As String
    Get
    Set
public:
property String^ ExceptionType {
    String^ get ();
    void set (String^ value);
}
member ExceptionType : string with get, set

Property Value

Type: String
See Also

Reference

ExceptionDescription Class
Alternet.Scripter.Debugger Namespace


ExceptionDescription.Message Property

ExceptionDescriptionMessage Property
Gets or sets a message that describes exception.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

ExceptionDescription Class
Alternet.Scripter.Debugger Namespace


ExecutionPosition Class

ExecutionPosition Class
Represents information describes process's execution position.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerExecutionPosition

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExecutionPosition
Public Class ExecutionPosition
public ref class ExecutionPosition
type ExecutionPosition =  class end

The ExecutionPosition type exposes the following members.

Constructors
 | Name | Description
Public method | ExecutionPosition | Initializes a new instance of the ExecutionPosition class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EndColumn | Gets or sets end column number that is executed.
Public property | EndLine | Gets or sets end line number that is executed.
Public property | File | Gets or sets name of file that is executed.
Public property | Line | Gets or sets line number that is executed.
Public property | StartColumn | Gets or sets start column number that is executed.
Public property | StartLine | Gets or sets start line number that is executed.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ExecutionPosition Constructor

ExecutionPosition Constructor
Initializes a new instance of the ExecutionPosition class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExecutionPosition()
Public Sub New
public:
ExecutionPosition()
new : unit -> ExecutionPosition
See Also

Reference

ExecutionPosition Class
Alternet.Scripter.Debugger Namespace


ExecutionPosition Methods

ExecutionPosition Methods

The ExecutionPosition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExecutionPosition Class
Alternet.Scripter.Debugger Namespace


ExecutionPosition Properties

ExecutionPosition Properties

The ExecutionPosition type exposes the following members.

Properties
 | Name | Description
Public property | EndColumn | Gets or sets end column number that is executed.
Public property | EndLine | Gets or sets end line number that is executed.
Public property | File | Gets or sets name of file that is executed.
Public property | Line | Gets or sets line number that is executed.
Public property | StartColumn | Gets or sets start column number that is executed.
Public property | StartLine | Gets or sets start line number that is executed.
Top
See Also

Reference

ExecutionPosition Class
Alternet.Scripter.Debugger Namespace


ExecutionPosition.EndColumn Property

ExecutionPositionEndColumn Property
Gets or sets end column number that is executed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndColumn { get; set; }
Public Property EndColumn As Integer
    Get
    Set
public:
property int EndColumn {
    int get ();
    void set (int value);
}
member EndColumn : int with get, set

Property Value

Type: Int32
See Also

Reference

ExecutionPosition Class
Alternet.Scripter.Debugger Namespace


ExecutionPosition.EndLine Property

ExecutionPositionEndLine Property
Gets or sets end line number that is executed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndLine { get; set; }
Public Property EndLine As Integer
    Get
    Set
public:
property int EndLine {
    int get ();
    void set (int value);
}
member EndLine : int with get, set

Property Value

Type: Int32
See Also

Reference

ExecutionPosition Class
Alternet.Scripter.Debugger Namespace


ExecutionPosition.File Property

ExecutionPositionFile Property
Gets or sets name of file that is executed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string File { get; set; }
Public Property File As String
    Get
    Set
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
member File : string with get, set

Property Value

Type: String
See Also

Reference

ExecutionPosition Class
Alternet.Scripter.Debugger Namespace


ExecutionPosition.Line Property

ExecutionPositionLine Property
Gets or sets line number that is executed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

ExecutionPosition Class
Alternet.Scripter.Debugger Namespace


ExecutionPosition.StartColumn Property

ExecutionPositionStartColumn Property
Gets or sets start column number that is executed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int StartColumn { get; set; }
Public Property StartColumn As Integer
    Get
    Set
public:
property int StartColumn {
    int get ();
    void set (int value);
}
member StartColumn : int with get, set

Property Value

Type: Int32
See Also

Reference

ExecutionPosition Class
Alternet.Scripter.Debugger Namespace


ExecutionPosition.StartLine Property

ExecutionPositionStartLine Property
Gets or sets start line number that is executed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int StartLine { get; set; }
Public Property StartLine As Integer
    Get
    Set
public:
property int StartLine {
    int get ();
    void set (int value);
}
member StartLine : int with get, set

Property Value

Type: Int32
See Also

Reference

ExecutionPosition Class
Alternet.Scripter.Debugger Namespace


ExecutionResumedEventArgs Class

ExecutionResumedEventArgs Class
Provides data for the IScriptDebugger.ExecutionResumed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerExecutionResumedEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExecutionResumedEventArgs : EventArgs
Public Class ExecutionResumedEventArgs
    Inherits EventArgs
public ref class ExecutionResumedEventArgs : public EventArgs
type ExecutionResumedEventArgs =
    class
        inherit EventArgs
    end

The ExecutionResumedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ExecutionResumedEventArgs | Initializes a new instance of the ExecutionResumedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ExecutionResumedEventArgs Constructor

ExecutionResumedEventArgs Constructor
Initializes a new instance of the ExecutionResumedEventArgs class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExecutionResumedEventArgs()
Public Sub New
public:
ExecutionResumedEventArgs()
new : unit -> ExecutionResumedEventArgs
See Also

Reference

ExecutionResumedEventArgs Class
Alternet.Scripter.Debugger Namespace


ExecutionResumedEventArgs Methods

ExecutionResumedEventArgs Methods

The ExecutionResumedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExecutionResumedEventArgs Class
Alternet.Scripter.Debugger Namespace


ExecutionStoppedEventArgs Class

ExecutionStoppedEventArgs Class
Provides data for the IScriptDebugger.ExecutionStopped event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerExecutionStoppedEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExecutionStoppedEventArgs : EventArgs
Public Class ExecutionStoppedEventArgs
    Inherits EventArgs
public ref class ExecutionStoppedEventArgs : public EventArgs
type ExecutionStoppedEventArgs =
    class
        inherit EventArgs
    end

The ExecutionStoppedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ExecutionStoppedEventArgs | Initializes a new instance of the ExecutionStoppedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets information about execution exception.
Public property | Position | Gets or sets execution position (line number and file name).
Public property | StopReason | Gets or sets reason of stop.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ExecutionStoppedEventArgs Constructor

ExecutionStoppedEventArgs Constructor
Initializes a new instance of the ExecutionStoppedEventArgs class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExecutionStoppedEventArgs()
Public Sub New
public:
ExecutionStoppedEventArgs()
new : unit -> ExecutionStoppedEventArgs
See Also

Reference

ExecutionStoppedEventArgs Class
Alternet.Scripter.Debugger Namespace


ExecutionStoppedEventArgs Methods

ExecutionStoppedEventArgs Methods

The ExecutionStoppedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExecutionStoppedEventArgs Class
Alternet.Scripter.Debugger Namespace


ExecutionStoppedEventArgs Properties

ExecutionStoppedEventArgs Properties

The ExecutionStoppedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets information about execution exception.
Public property | Position | Gets or sets execution position (line number and file name).
Public property | StopReason | Gets or sets reason of stop.
Top
See Also

Reference

ExecutionStoppedEventArgs Class
Alternet.Scripter.Debugger Namespace


ExecutionStoppedEventArgs.Exception Property

ExecutionStoppedEventArgsException Property
Gets or sets information about execution exception.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDescription Exception { get; set; }
Public Property Exception As ExceptionDescription
    Get
    Set
public:
property ExceptionDescription^ Exception {
    ExceptionDescription^ get ();
    void set (ExceptionDescription^ value);
}
member Exception : ExceptionDescription with get, set

Property Value

Type: ExceptionDescription
See Also

Reference

ExecutionStoppedEventArgs Class
Alternet.Scripter.Debugger Namespace


ExecutionStoppedEventArgs.Position Property

ExecutionStoppedEventArgsPosition Property
Gets or sets execution position (line number and file name).

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExecutionPosition Position { get; set; }
Public Property Position As ExecutionPosition
    Get
    Set
public:
property ExecutionPosition^ Position {
    ExecutionPosition^ get ();
    void set (ExecutionPosition^ value);
}
member Position : ExecutionPosition with get, set

Property Value

Type: ExecutionPosition
See Also

Reference

ExecutionStoppedEventArgs Class
Alternet.Scripter.Debugger Namespace


ExecutionStoppedEventArgs.StopReason Property

ExecutionStoppedEventArgsStopReason Property
Gets or sets reason of stop.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExecutionStopReason StopReason { get; set; }
Public Property StopReason As ExecutionStopReason
    Get
    Set
public:
property ExecutionStopReason StopReason {
    ExecutionStopReason get ();
    void set (ExecutionStopReason value);
}
member StopReason : ExecutionStopReason with get, set

Property Value

Type: ExecutionStopReason
See Also

Reference

ExecutionStoppedEventArgs Class
Alternet.Scripter.Debugger Namespace


ExecutionStopReason Enumeration

ExecutionStopReason Enumeration
Defines possible causes stop execution.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExecutionStopReason
Public Enumeration ExecutionStopReason
public enum class ExecutionStopReason
type ExecutionStopReason
Members
Member name | Value | Description
Break | 0 | Execution stopped because of IScriptDebugger.Break method called.
BreakpointHit | 1 | Execution stopped because process reached breakpoint.
StepComplete | 2 | Execution stopped because process completes next step.
Exception | 3 | Execution stopped because process raises exception.
SetNextStatement | 4 | Execution stopped because user set next statement.
See Also

Reference

Alternet.Scripter.Debugger Namespace


ExpressionEvaluationRequest Class

ExpressionEvaluationRequest Class
Represents data for ExpressionEvaluation request.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerExpressionEvaluationRequest

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExpressionEvaluationRequest
Public Class ExpressionEvaluationRequest
public ref class ExpressionEvaluationRequest
type ExpressionEvaluationRequest =  class end

The ExpressionEvaluationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionEvaluationRequest | Initializes a new instance of the ExpressionEvaluationRequest class with specified expression.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExpandValues | Gets or sets a boolean value indicating whether values of the expression's children should be expanded.
Public property | Expression | Represents expression to be evaluated.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ExpressionEvaluationRequest Constructor

ExpressionEvaluationRequest Constructor
Initializes a new instance of the ExpressionEvaluationRequest class with specified expression.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpressionEvaluationRequest(
    string expression
)
Public Sub New (
    expression As String
)
public:
ExpressionEvaluationRequest(
    String^ expression
)
new :
        expression : string -> ExpressionEvaluationRequest

Parameters

expression
Type: SystemString
Expression to be evaluated.
See Also

Reference

ExpressionEvaluationRequest Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationRequest Methods

ExpressionEvaluationRequest Methods

The ExpressionEvaluationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExpressionEvaluationRequest Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationRequest Properties

ExpressionEvaluationRequest Properties

The ExpressionEvaluationRequest type exposes the following members.

Properties
 | Name | Description
Public property | ExpandValues | Gets or sets a boolean value indicating whether values of the expression's children should be expanded.
Public property | Expression | Represents expression to be evaluated.
Top
See Also

Reference

ExpressionEvaluationRequest Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationRequest.ExpandValues Property

ExpressionEvaluationRequestExpandValues Property
Gets or sets a boolean value indicating whether values of the expression's children should be expanded.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExpandValues { get; set; }
Public Property ExpandValues As Boolean
    Get
    Set
public:
property bool ExpandValues {
    bool get ();
    void set (bool value);
}
member ExpandValues : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ExpressionEvaluationRequest Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationRequest.Expression Property

ExpressionEvaluationRequestExpression Property
Represents expression to be evaluated.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; }
Public ReadOnly Property Expression As String
    Get
public:
property String^ Expression {
    String^ get ();
}
member Expression : string with get

Property Value

Type: String
See Also

Reference

ExpressionEvaluationRequest Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResult Class

ExpressionEvaluationResult Class
Represents data of evaluated expression.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerExpressionEvaluationResult

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExpressionEvaluationResult
Public Class ExpressionEvaluationResult
public ref class ExpressionEvaluationResult
type ExpressionEvaluationResult =  class end

The ExpressionEvaluationResult type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionEvaluationResult | Initializes a new instance of the ExpressionEvaluationResult class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Children | Gets or sets list of child expressions if present.
Public property | Expression | Gets or sets expression to evaluate.
Public property | Result | Gets or sets information of expression to evaluate.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResult Constructor

ExpressionEvaluationResult Constructor
Initializes a new instance of the ExpressionEvaluationResult class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpressionEvaluationResult()
Public Sub New
public:
ExpressionEvaluationResult()
new : unit -> ExpressionEvaluationResult
See Also

Reference

ExpressionEvaluationResult Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResult Methods

ExpressionEvaluationResult Methods

The ExpressionEvaluationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExpressionEvaluationResult Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResult Properties

ExpressionEvaluationResult Properties

The ExpressionEvaluationResult type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets or sets list of child expressions if present.
Public property | Expression | Gets or sets expression to evaluate.
Public property | Result | Gets or sets information of expression to evaluate.
Top
See Also

Reference

ExpressionEvaluationResult Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResult.Children Property

ExpressionEvaluationResultChildren Property
Gets or sets list of child expressions if present.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpressionEvaluationResultItem[] Children { get; set; }
Public Property Children As ExpressionEvaluationResultItem()
    Get
    Set
public:
property array<ExpressionEvaluationResultItem^>^ Children {
    array<ExpressionEvaluationResultItem^>^ get ();
    void set (array<ExpressionEvaluationResultItem^>^ value);
}
member Children : ExpressionEvaluationResultItem[] with get, set

Property Value

Type: ExpressionEvaluationResultItem
See Also

Reference

ExpressionEvaluationResult Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResult.Expression Property

ExpressionEvaluationResultExpression Property
Gets or sets expression to evaluate.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; set; }
Public Property Expression As String
    Get
    Set
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}
member Expression : string with get, set

Property Value

Type: String
See Also

Reference

ExpressionEvaluationResult Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResult.Result Property

ExpressionEvaluationResultResult Property
Gets or sets information of expression to evaluate.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpressionEvaluationResultItem Result { get; set; }
Public Property Result As ExpressionEvaluationResultItem
    Get
    Set
public:
property ExpressionEvaluationResultItem^ Result {
    ExpressionEvaluationResultItem^ get ();
    void set (ExpressionEvaluationResultItem^ value);
}
member Result : ExpressionEvaluationResultItem with get, set

Property Value

Type: ExpressionEvaluationResultItem
See Also

Reference

ExpressionEvaluationResult Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResultItem Class

ExpressionEvaluationResultItem Class
Represents information describes expression evaluation result.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerExpressionEvaluationResultItem

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExpressionEvaluationResultItem
Public Class ExpressionEvaluationResultItem
public ref class ExpressionEvaluationResultItem
type ExpressionEvaluationResultItem =  class end

The ExpressionEvaluationResultItem type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionEvaluationResultItem | Initializes a new instance of the ExpressionEvaluationResultItem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CanExpand | Gets or sets a boolean value indicates whether expression can be expanded.
Public property | ErrorMessage | Gets or sets an error message. Non empty if some error occurred while evaluating expression.
Public property | Expression | Gets or sets expression to evaluate.
Public property | Type | Gets or sets an expression type.
Public property | Value | Gets or sets a value that is result of expression evaluation.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResultItem Constructor

ExpressionEvaluationResultItem Constructor
Initializes a new instance of the ExpressionEvaluationResultItem class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpressionEvaluationResultItem()
Public Sub New
public:
ExpressionEvaluationResultItem()
new : unit -> ExpressionEvaluationResultItem
See Also

Reference

ExpressionEvaluationResultItem Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResultItem Methods

ExpressionEvaluationResultItem Methods

The ExpressionEvaluationResultItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExpressionEvaluationResultItem Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResultItem Properties

ExpressionEvaluationResultItem Properties

The ExpressionEvaluationResultItem type exposes the following members.

Properties
 | Name | Description
Public property | CanExpand | Gets or sets a boolean value indicates whether expression can be expanded.
Public property | ErrorMessage | Gets or sets an error message. Non empty if some error occurred while evaluating expression.
Public property | Expression | Gets or sets expression to evaluate.
Public property | Type | Gets or sets an expression type.
Public property | Value | Gets or sets a value that is result of expression evaluation.
Top
See Also

Reference

ExpressionEvaluationResultItem Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResultItem.CanExpand Property

ExpressionEvaluationResultItemCanExpand Property
Gets or sets a boolean value indicates whether expression can be expanded.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanExpand { get; set; }
Public Property CanExpand As Boolean
    Get
    Set
public:
property bool CanExpand {
    bool get ();
    void set (bool value);
}
member CanExpand : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ExpressionEvaluationResultItem Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResultItem.ErrorMessage Property

ExpressionEvaluationResultItemErrorMessage Property
Gets or sets an error message. Non empty if some error occurred while evaluating expression.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
See Also

Reference

ExpressionEvaluationResultItem Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResultItem.Expression Property

ExpressionEvaluationResultItemExpression Property
Gets or sets expression to evaluate.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; set; }
Public Property Expression As String
    Get
    Set
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}
member Expression : string with get, set

Property Value

Type: String
See Also

Reference

ExpressionEvaluationResultItem Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResultItem.Type Property

ExpressionEvaluationResultItemType Property
Gets or sets an expression type.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

ExpressionEvaluationResultItem Class
Alternet.Scripter.Debugger Namespace


ExpressionEvaluationResultItem.Value Property

ExpressionEvaluationResultItemValue Property
Gets or sets a value that is result of expression evaluation.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

ExpressionEvaluationResultItem Class
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands Interface

IDebuggerUICommands Interface
Represents Debugger commands processed by the Debugger UI.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDebuggerUICommands
Public Interface IDebuggerUICommands
public interface class IDebuggerUICommands
type IDebuggerUICommands =  interface end

The IDebuggerUICommands type exposes the following members.

Methods
 | Name | Description
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed.
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes.
Public method | EvaluateCurrentException | When implemented by a class, displays EvaluateDialog for current exception.
Public method | EvaluateExpression | When implemented by a class, displays EvaluateDialog.
Public method | PreStartup | This method is invoked before debugger starts execution.
Public method | Start | When implemented by a class, starts executing the program from the entry point with specified settings.
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible.
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call.
Public method | Stop | When implemented by a class, stops executing the program.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


IDebuggerUICommands Methods

IDebuggerUICommands Methods

The IDebuggerUICommands type exposes the following members.

Methods
 | Name | Description
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed.
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes.
Public method | EvaluateCurrentException | When implemented by a class, displays EvaluateDialog for current exception.
Public method | EvaluateExpression | When implemented by a class, displays EvaluateDialog.
Public method | PreStartup | This method is invoked before debugger starts execution.
Public method | Start | When implemented by a class, starts executing the program from the entry point with specified settings.
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible.
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call.
Public method | Stop | When implemented by a class, stops executing the program.
Top
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.Break Method

IDebuggerUICommandsBreak Method
When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Break()
Function Break As Boolean
bool Break()
abstract Break : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.Compile Method

IDebuggerUICommandsCompile Method
When implemented by a class, initializes script engine and compiles the script.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Compile()
Function Compile As Boolean
bool Compile()
abstract Compile : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.Continue Method

IDebuggerUICommandsContinue Method
When implemented by a class, continues given process to the next breakpoint or until process finishes.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Continue()
Function Continue As Boolean
bool Continue()
abstract Continue : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.EvaluateCurrentException Method

IDebuggerUICommandsEvaluateCurrentException Method
When implemented by a class, displays EvaluateDialog for current exception.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool EvaluateCurrentException()
Function EvaluateCurrentException As Boolean
bool EvaluateCurrentException()
abstract EvaluateCurrentException : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.EvaluateExpression Method

IDebuggerUICommandsEvaluateExpression Method
When implemented by a class, displays EvaluateDialog.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool EvaluateExpression()
Function EvaluateExpression As Boolean
bool EvaluateExpression()
abstract EvaluateExpression : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.PreStartup Method

IDebuggerUICommandsPreStartup Method
This method is invoked before debugger starts execution.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PreStartup()
Function PreStartup As Boolean
bool PreStartup()
abstract PreStartup : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.Start Method

IDebuggerUICommandsStart Method
When implemented by a class, starts executing the program from the entry point with specified settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Start()
Function Start As Boolean
bool Start()
abstract Start : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.StepInto Method

IDebuggerUICommandsStepInto Method
When implemented by a class, executes one statement of code; steps into the next function call, if possible.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool StepInto()
Function StepInto As Boolean
bool StepInto()
abstract StepInto : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.StepOver Method

IDebuggerUICommandsStepOver Method
When implemented by a class, executes one statement of code; steps over the next function call.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool StepOver()
Function StepOver As Boolean
bool StepOver()
abstract StepOver : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IDebuggerUICommands.Stop Method

IDebuggerUICommandsStop Method
When implemented by a class, stops executing the program.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Stop()
Function Stop As Boolean
bool Stop()
abstract Stop : unit -> bool

Return Value

Type: Boolean
true if succeed otherwise false;
See Also

Reference

IDebuggerUICommands Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints Interface

IScriptBreakpoints Interface
Represents methods and properties declaration to describe list of breakpoints.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptBreakpoints : IUpdate
Public Interface IScriptBreakpoints
    Inherits IUpdate
public interface class IScriptBreakpoints : IUpdate
type IScriptBreakpoints =
    interface
        interface IUpdate
    end

The IScriptBreakpoints type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint | When implemented by a class, adds a Breakpoint to the list.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | Clear | When implemented by a class, removes all breakpoints.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableBreakpoint | When implemented by a class, enables or disables specified breakpoint.
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | RemoveBreakpoint | When implemented by a class, removes a Breakpoint from the list.
Public method | RemoveBreakpoints | When implemented by a class, removes several Breakpoint from the list.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, gets an array of Breakpoint objects.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
Events
 | Name | Description
Public event | BreakpointAdded | When implemented by a class, occurs when a breakpoint is added.
Public event | BreakpointRemoved | When implemented by a class, occurs when a breakpoint is removed.
Public event | BreakpointStateChanged | When implemented by a class, occurs when a breakpoint state is changed.
Public event | Changed | When implemented by a class, occurs when breakpoints are changed.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


IScriptBreakpoints Methods

IScriptBreakpoints Methods

The IScriptBreakpoints type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint | When implemented by a class, adds a Breakpoint to the list.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | Clear | When implemented by a class, removes all breakpoints.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableBreakpoint | When implemented by a class, enables or disables specified breakpoint.
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | RemoveBreakpoint | When implemented by a class, removes a Breakpoint from the list.
Public method | RemoveBreakpoints | When implemented by a class, removes several Breakpoint from the list.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.AddBreakpoint Method

IScriptBreakpointsAddBreakpoint Method
When implemented by a class, adds a Breakpoint to the list.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddBreakpoint(
    string filePath,
    int lineNumber
)
Sub AddBreakpoint (
    filePath As String,
    lineNumber As Integer
)
void AddBreakpoint(
    String^ filePath,
    int lineNumber
)
abstract AddBreakpoint :
        filePath : string *
        lineNumber : int -> unit

Parameters

filePath
Type: SystemString
lineNumber
Type: SystemInt32
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.Clear Method

IScriptBreakpointsClear Method
When implemented by a class, removes all breakpoints.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.EnableBreakpoint Method

IScriptBreakpointsEnableBreakpoint Method
When implemented by a class, enables or disables specified breakpoint.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EnableBreakpoint(
    Breakpoint breakpoint,
    bool enable
)
Sub EnableBreakpoint (
    breakpoint As Breakpoint,
    enable As Boolean
)
void EnableBreakpoint(
    Breakpoint^ breakpoint,
    bool enable
)
abstract EnableBreakpoint :
        breakpoint : Breakpoint *
        enable : bool -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
Breakpoint to process.
enable
Type: SystemBoolean
New breakpoint's state.
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.RemoveBreakpoint Method

IScriptBreakpointsRemoveBreakpoint Method
When implemented by a class, removes a Breakpoint from the list.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RemoveBreakpoint(
    Breakpoint breakpoint
)
Function RemoveBreakpoint (
    breakpoint As Breakpoint
) As Boolean
bool RemoveBreakpoint(
    Breakpoint^ breakpoint
)
abstract RemoveBreakpoint :
        breakpoint : Breakpoint -> bool

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
The Breakpoint to remove from the list.

Return Value

Type: Boolean
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.RemoveBreakpoints Method

IScriptBreakpointsRemoveBreakpoints Method
When implemented by a class, removes several Breakpoint from the list.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveBreakpoints(
    IList<Breakpoint> breakpoints
)
Sub RemoveBreakpoints (
    breakpoints As IList(Of Breakpoint)
)
void RemoveBreakpoints(
    IList<Breakpoint^>^ breakpoints
)
abstract RemoveBreakpoints :
        breakpoints : IList<Breakpoint> -> unit

Parameters

breakpoints
Type: System.Collections.GenericIListBreakpoint
The number of Breakpoint to remove from the list.
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints Properties

IScriptBreakpoints Properties

The IScriptBreakpoints type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, gets an array of Breakpoint objects.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.Breakpoints Property

IScriptBreakpointsBreakpoints Property
When implemented by a class, gets an array of Breakpoint objects.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Breakpoint[] Breakpoints { get; }
ReadOnly Property Breakpoints As Breakpoint()
    Get
property array<Breakpoint^>^ Breakpoints {
    array<Breakpoint^>^ get ();
}
abstract Breakpoints : Breakpoint[] with get

Property Value

Type: Breakpoint
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints Events

IScriptBreakpoints Events

The IScriptBreakpoints type exposes the following members.

Events
 | Name | Description
Public event | BreakpointAdded | When implemented by a class, occurs when a breakpoint is added.
Public event | BreakpointRemoved | When implemented by a class, occurs when a breakpoint is removed.
Public event | BreakpointStateChanged | When implemented by a class, occurs when a breakpoint state is changed.
Public event | Changed | When implemented by a class, occurs when breakpoints are changed.
Top
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.BreakpointAdded Event

IScriptBreakpointsBreakpointAdded Event
When implemented by a class, occurs when a breakpoint is added.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<BreakpointEventArgs> BreakpointAdded
Event BreakpointAdded As EventHandler(Of BreakpointEventArgs)
 event EventHandler<BreakpointEventArgs^>^ BreakpointAdded {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointAdded : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.BreakpointRemoved Event

IScriptBreakpointsBreakpointRemoved Event
When implemented by a class, occurs when a breakpoint is removed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<BreakpointEventArgs> BreakpointRemoved
Event BreakpointRemoved As EventHandler(Of BreakpointEventArgs)
 event EventHandler<BreakpointEventArgs^>^ BreakpointRemoved {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointRemoved : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.BreakpointStateChanged Event

IScriptBreakpointsBreakpointStateChanged Event
When implemented by a class, occurs when a breakpoint state is changed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<BreakpointEventArgs> BreakpointStateChanged
Event BreakpointStateChanged As EventHandler(Of BreakpointEventArgs)
 event EventHandler<BreakpointEventArgs^>^ BreakpointStateChanged {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointStateChanged : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptBreakpoints.Changed Event

IScriptBreakpointsChanged Event
When implemented by a class, occurs when breakpoints are changed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler Changed
Event Changed As EventHandler
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Changed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptBreakpoints Interface
Alternet.Scripter.Debugger Namespace


IScriptDebugger Interface

IScriptDebugger Interface
Provides methods and properties that allow developers to debug applications in the common language runtime (CLR) environment.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptDebugger : IScriptDebuggerBase,
    IDisposable
Public Interface IScriptDebugger
    Inherits IScriptDebuggerBase, IDisposable
public interface class IScriptDebugger : IScriptDebuggerBase,
    IDisposable
type IScriptDebugger =
    interface
        interface IScriptDebuggerBase
        interface IDisposable
    end

The IScriptDebugger type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | When implemented by a class, switches debugging to the specified thread. (Inherited from IScriptDebuggerBase.)
Public method | AttachToProcessAsync(Int32, CancellationToken) | When implemented by a class, attaches debugger to the process.
Public method | AttachToProcessAsync(Int32, StartDebuggingOptions, CancellationToken) | When implemented by a class, attaches debugger to the process.
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed. (Inherited from IScriptDebuggerBase.)
Public method | ClearTemporaryGeneratedModules | When implemented by a class, clears temporary generated modules on disk. (Inherited from IScriptDebuggerBase.)
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes. (Inherited from IScriptDebuggerBase.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionsAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | GetExecutionPositionAsync | When implemented by a class, finds out current ExecutionPosition based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | GetStackFramesAsync | When implemented by a class, gets list of method calls that are currently on a stack (Inherited from IScriptDebuggerBase.)
Public method | GetThreadsAsync | When implemented by a class, gets list of active threads. (Inherited from IScriptDebuggerBase.)
Public method | GetVariablesInScopeAsync | When implemented by a class, receives all local variables based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | SetRunToPositionBreakpoint | When implemented by a class, causes debugger to stop at the specified position. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging | When implemented by a class, starts executing the program from the entry point with default settings. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging(StartDebuggingOptions) | When implemented by a class, starts executing the program from the entry point with specified settings. (Inherited from IScriptDebuggerBase.)
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible. (Inherited from IScriptDebuggerBase.)
Public method | StepOut | When implemented by a class, executes one statement of code; steps out of the function currently being executed. (Inherited from IScriptDebuggerBase.)
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call. (Inherited from IScriptDebuggerBase.)
Public method | StopDebuggingAsync | When implemented by a class, stops executing the program. (Inherited from IScriptDebuggerBase.)
Public method | SwitchToStackFrame | When implemented by a class, switches debugging to the given stack frame. (Inherited from IScriptDebuggerBase.)
Public method | TrySetNextStatementAsync | When implemented by a class, tries to set the execution point to the specified line of code. (Inherited from IScriptDebuggerBase.)
Top
Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, returns collection of debugger breakpoints. (Inherited from IScriptDebuggerBase.)
Public property | Capabilities | When implemented by a class, gets debugger capabilities. (Inherited from IScriptDebuggerBase.)
Public property | EventsSyncAction | When implemented by a class, gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke) (Inherited from IScriptDebuggerBase.)
Public property | ExpressionEvaluator | When implemented by a class, gets IExpressionEvaluator object used to evaluate expressions. (Inherited from IScriptDebuggerBase.)
Public property | GeneratedModulesPath | When implemented by a class, gets directory where assemblies for the scripts being debugged are located.
Public property | IsStarted | When implemented by a class, indicates whether debugging was started. (Inherited from IScriptDebuggerBase.)
Public property | MyCodeModules | When implemented by a class, gets or sets collection of module names to be debugged.
Public property | ScopeResolutionService | When implemented by a class, gets IScopeResolutionService object used to evaluate method names and parameters. (Inherited from IScriptDebuggerBase.)
Public property | ScriptRun | When implemented by a class, contains all information required to compile and run the script
Public property | State | When implemented by a class, gets current debugger state. (Inherited from IScriptDebuggerBase.)
Top
Events
 | Name | Description
Public event | ActiveThreadChanged | When implemented by a class, occurs when thread to be debugged changes. (Inherited from IScriptDebuggerBase.)
Public event | BeforeContinue | When implemented by a class, occurs before debugger continues to program execution. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStep | When implemented by a class, occurs before debugger performs a step. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStop | When implemented by a class, occurs before debugger stop debugging. (Inherited from IScriptDebuggerBase.)
Public event | DebuggerErrorOccured | When implemented by a class, occurs when encounters error during debugging session. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStarted | When implemented by a class, occurs when debugging session is started. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStopped | When implemented by a class, occurs when debugging session is stopped. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionResumed | When implemented by a class, occurs when debugging is resumed after being paused. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionStopped | When implemented by a class, occurs when debugging is paused. (Inherited from IScriptDebuggerBase.)
Public event | LogMessageReceived | When implemented by a class, occurs when debug message is received. (Inherited from IScriptDebuggerBase.)
Public event | StackFrameSwitched | When implemented by a class, occurs debugger switches to the stack frame (Inherited from IScriptDebuggerBase.)
Public event | StateChanged | When implemented by a class, occurs when debugger state is changed. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


IScriptDebugger Methods

IScriptDebugger Methods

The IScriptDebugger type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | When implemented by a class, switches debugging to the specified thread. (Inherited from IScriptDebuggerBase.)
Public method | AttachToProcessAsync(Int32, CancellationToken) | When implemented by a class, attaches debugger to the process.
Public method | AttachToProcessAsync(Int32, StartDebuggingOptions, CancellationToken) | When implemented by a class, attaches debugger to the process.
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed. (Inherited from IScriptDebuggerBase.)
Public method | ClearTemporaryGeneratedModules | When implemented by a class, clears temporary generated modules on disk. (Inherited from IScriptDebuggerBase.)
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes. (Inherited from IScriptDebuggerBase.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionsAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | GetExecutionPositionAsync | When implemented by a class, finds out current ExecutionPosition based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | GetStackFramesAsync | When implemented by a class, gets list of method calls that are currently on a stack (Inherited from IScriptDebuggerBase.)
Public method | GetThreadsAsync | When implemented by a class, gets list of active threads. (Inherited from IScriptDebuggerBase.)
Public method | GetVariablesInScopeAsync | When implemented by a class, receives all local variables based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | SetRunToPositionBreakpoint | When implemented by a class, causes debugger to stop at the specified position. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging | When implemented by a class, starts executing the program from the entry point with default settings. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging(StartDebuggingOptions) | When implemented by a class, starts executing the program from the entry point with specified settings. (Inherited from IScriptDebuggerBase.)
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible. (Inherited from IScriptDebuggerBase.)
Public method | StepOut | When implemented by a class, executes one statement of code; steps out of the function currently being executed. (Inherited from IScriptDebuggerBase.)
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call. (Inherited from IScriptDebuggerBase.)
Public method | StopDebuggingAsync | When implemented by a class, stops executing the program. (Inherited from IScriptDebuggerBase.)
Public method | SwitchToStackFrame | When implemented by a class, switches debugging to the given stack frame. (Inherited from IScriptDebuggerBase.)
Public method | TrySetNextStatementAsync | When implemented by a class, tries to set the execution point to the specified line of code. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger Namespace


IScriptDebugger.AttachToProcessAsync Method

IScriptDebuggerAttachToProcessAsync Method
Overload List
 | Name | Description
Public method | AttachToProcessAsync(Int32, CancellationToken) | When implemented by a class, attaches debugger to the process.
Public method | AttachToProcessAsync(Int32, StartDebuggingOptions, CancellationToken) | When implemented by a class, attaches debugger to the process.
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger Namespace


IScriptDebugger.AttachToProcessAsync Method (Int32, CancellationToken)

IScriptDebuggerAttachToProcessAsync Method (Int32, CancellationToken)
When implemented by a class, attaches debugger to the process.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task AttachToProcessAsync(
    int processId,
    CancellationToken cancellationToken = null
)
Function AttachToProcessAsync (
    processId As Integer,
    Optional cancellationToken As CancellationToken = Nothing
) As Task
Task^ AttachToProcessAsync(
    int processId,
    CancellationToken cancellationToken = nullptr
)
abstract AttachToProcessAsync :
        processId : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

processId
Type: SystemInt32
Process ID to attach.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task
See Also

Reference

IScriptDebugger Interface
AttachToProcessAsync Overload
Alternet.Scripter.Debugger Namespace


IScriptDebugger.AttachToProcessAsync Method (Int32, StartDebuggingOptions, CancellationToken)

IScriptDebuggerAttachToProcessAsync Method (Int32, StartDebuggingOptions, CancellationToken)
When implemented by a class, attaches debugger to the process.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task AttachToProcessAsync(
    int processId,
    StartDebuggingOptions options,
    CancellationToken cancellationToken = null
)
Function AttachToProcessAsync (
    processId As Integer,
    options As StartDebuggingOptions,
    Optional cancellationToken As CancellationToken = Nothing
) As Task
Task^ AttachToProcessAsync(
    int processId,
    StartDebuggingOptions^ options,
    CancellationToken cancellationToken = nullptr
)
abstract AttachToProcessAsync :
        processId : int *
        options : StartDebuggingOptions *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

processId
Type: SystemInt32
Process ID to attach.
options
Type: Alternet.Scripter.DebuggerStartDebuggingOptions
Process attach options.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task
See Also

Reference

IScriptDebugger Interface
AttachToProcessAsync Overload
Alternet.Scripter.Debugger Namespace


IScriptDebugger Properties

IScriptDebugger Properties

The IScriptDebugger type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, returns collection of debugger breakpoints. (Inherited from IScriptDebuggerBase.)
Public property | Capabilities | When implemented by a class, gets debugger capabilities. (Inherited from IScriptDebuggerBase.)
Public property | EventsSyncAction | When implemented by a class, gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke) (Inherited from IScriptDebuggerBase.)
Public property | ExpressionEvaluator | When implemented by a class, gets IExpressionEvaluator object used to evaluate expressions. (Inherited from IScriptDebuggerBase.)
Public property | GeneratedModulesPath | When implemented by a class, gets directory where assemblies for the scripts being debugged are located.
Public property | IsStarted | When implemented by a class, indicates whether debugging was started. (Inherited from IScriptDebuggerBase.)
Public property | MyCodeModules | When implemented by a class, gets or sets collection of module names to be debugged.
Public property | ScopeResolutionService | When implemented by a class, gets IScopeResolutionService object used to evaluate method names and parameters. (Inherited from IScriptDebuggerBase.)
Public property | ScriptRun | When implemented by a class, contains all information required to compile and run the script
Public property | State | When implemented by a class, gets current debugger state. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger Namespace


IScriptDebugger.GeneratedModulesPath Property

IScriptDebuggerGeneratedModulesPath Property
When implemented by a class, gets directory where assemblies for the scripts being debugged are located.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GeneratedModulesPath { get; set; }
Property GeneratedModulesPath As String
    Get
    Set
property String^ GeneratedModulesPath {
    String^ get ();
    void set (String^ value);
}
abstract GeneratedModulesPath : string with get, set

Property Value

Type: String
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger Namespace


IScriptDebugger.MyCodeModules Property

IScriptDebuggerMyCodeModules Property
When implemented by a class, gets or sets collection of module names to be debugged.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] MyCodeModules { get; set; }
Property MyCodeModules As String()
    Get
    Set
property array<String^>^ MyCodeModules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract MyCodeModules : string[] with get, set

Property Value

Type: String
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger Namespace


IScriptDebugger.ScriptRun Property

IScriptDebuggerScriptRun Property
When implemented by a class, contains all information required to compile and run the script

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptRun ScriptRun { get; }
ReadOnly Property ScriptRun As IScriptRun
    Get
property IScriptRun^ ScriptRun {
    IScriptRun^ get ();
}
abstract ScriptRun : IScriptRun with get

Property Value

Type: IScriptRun
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger Namespace


IScriptDebugger Events

IScriptDebugger Events

The IScriptDebugger type exposes the following members.

Events
 | Name | Description
Public event | ActiveThreadChanged | When implemented by a class, occurs when thread to be debugged changes. (Inherited from IScriptDebuggerBase.)
Public event | BeforeContinue | When implemented by a class, occurs before debugger continues to program execution. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStep | When implemented by a class, occurs before debugger performs a step. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStop | When implemented by a class, occurs before debugger stop debugging. (Inherited from IScriptDebuggerBase.)
Public event | DebuggerErrorOccured | When implemented by a class, occurs when encounters error during debugging session. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStarted | When implemented by a class, occurs when debugging session is started. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStopped | When implemented by a class, occurs when debugging session is stopped. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionResumed | When implemented by a class, occurs when debugging is resumed after being paused. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionStopped | When implemented by a class, occurs when debugging is paused. (Inherited from IScriptDebuggerBase.)
Public event | LogMessageReceived | When implemented by a class, occurs when debug message is received. (Inherited from IScriptDebuggerBase.)
Public event | StackFrameSwitched | When implemented by a class, occurs debugger switches to the stack frame (Inherited from IScriptDebuggerBase.)
Public event | StateChanged | When implemented by a class, occurs when debugger state is changed. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase Interface

IScriptDebuggerBase Interface
Provides methods and properties that allow developers to debug applications in the common language runtime (CLR) environment.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptDebuggerBase
Public Interface IScriptDebuggerBase
public interface class IScriptDebuggerBase
type IScriptDebuggerBase =  interface end

The IScriptDebuggerBase type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | When implemented by a class, switches debugging to the specified thread.
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed.
Public method | ClearTemporaryGeneratedModules | When implemented by a class, clears temporary generated modules on disk.
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes.
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionsAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | GetExecutionPositionAsync | When implemented by a class, finds out current ExecutionPosition based on the current stack frame.
Public method | GetStackFramesAsync | When implemented by a class, gets list of method calls that are currently on a stack
Public method | GetThreadsAsync | When implemented by a class, gets list of active threads.
Public method | GetVariablesInScopeAsync | When implemented by a class, receives all local variables based on the current stack frame.
Public method | SetRunToPositionBreakpoint | When implemented by a class, causes debugger to stop at the specified position.
Public method | StartDebugging | When implemented by a class, starts executing the program from the entry point with default settings.
Public method | StartDebugging(StartDebuggingOptions) | When implemented by a class, starts executing the program from the entry point with specified settings.
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible.
Public method | StepOut | When implemented by a class, executes one statement of code; steps out of the function currently being executed.
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call.
Public method | StopDebuggingAsync | When implemented by a class, stops executing the program.
Public method | SwitchToStackFrame | When implemented by a class, switches debugging to the given stack frame.
Public method | TrySetNextStatementAsync | When implemented by a class, tries to set the execution point to the specified line of code.
Top
Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, returns collection of debugger breakpoints.
Public property | Capabilities | When implemented by a class, gets debugger capabilities.
Public property | EventsSyncAction | When implemented by a class, gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)
Public property | ExpressionEvaluator | When implemented by a class, gets IExpressionEvaluator object used to evaluate expressions.
Public property | IsStarted | When implemented by a class, indicates whether debugging was started.
Public property | ScopeResolutionService | When implemented by a class, gets IScopeResolutionService object used to evaluate method names and parameters.
Public property | ScriptRun | When implemented by a class, contains all information required to compile and run the script
Public property | State | When implemented by a class, gets current debugger state.
Top
Events
 | Name | Description
Public event | ActiveThreadChanged | When implemented by a class, occurs when thread to be debugged changes.
Public event | BeforeContinue | When implemented by a class, occurs before debugger continues to program execution.
Public event | BeforeStep | When implemented by a class, occurs before debugger performs a step.
Public event | BeforeStop | When implemented by a class, occurs before debugger stop debugging.
Public event | DebuggerErrorOccured | When implemented by a class, occurs when encounters error during debugging session.
Public event | DebuggingStarted | When implemented by a class, occurs when debugging session is started.
Public event | DebuggingStopped | When implemented by a class, occurs when debugging session is stopped.
Public event | ExecutionResumed | When implemented by a class, occurs when debugging is resumed after being paused.
Public event | ExecutionStopped | When implemented by a class, occurs when debugging is paused.
Public event | LogMessageReceived | When implemented by a class, occurs when debug message is received.
Public event | StackFrameSwitched | When implemented by a class, occurs debugger switches to the stack frame
Public event | StateChanged | When implemented by a class, occurs when debugger state is changed.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase Methods

IScriptDebuggerBase Methods

The IScriptDebuggerBase type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | When implemented by a class, switches debugging to the specified thread.
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed.
Public method | ClearTemporaryGeneratedModules | When implemented by a class, clears temporary generated modules on disk.
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes.
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionsAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | GetExecutionPositionAsync | When implemented by a class, finds out current ExecutionPosition based on the current stack frame.
Public method | GetStackFramesAsync | When implemented by a class, gets list of method calls that are currently on a stack
Public method | GetThreadsAsync | When implemented by a class, gets list of active threads.
Public method | GetVariablesInScopeAsync | When implemented by a class, receives all local variables based on the current stack frame.
Public method | SetRunToPositionBreakpoint | When implemented by a class, causes debugger to stop at the specified position.
Public method | StartDebugging | When implemented by a class, starts executing the program from the entry point with default settings.
Public method | StartDebugging(StartDebuggingOptions) | When implemented by a class, starts executing the program from the entry point with specified settings.
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible.
Public method | StepOut | When implemented by a class, executes one statement of code; steps out of the function currently being executed.
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call.
Public method | StopDebuggingAsync | When implemented by a class, stops executing the program.
Public method | SwitchToStackFrame | When implemented by a class, switches debugging to the given stack frame.
Public method | TrySetNextStatementAsync | When implemented by a class, tries to set the execution point to the specified line of code.
Top
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.ActivateThread Method

IScriptDebuggerBaseActivateThread Method
When implemented by a class, switches debugging to the specified thread.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ActivateThread(
    int threadId
)
Sub ActivateThread (
    threadId As Integer
)
void ActivateThread(
    int threadId
)
abstract ActivateThread :
        threadId : int -> unit

Parameters

threadId
Type: SystemInt32
Thread ID to be activated.
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.Break Method

IScriptDebuggerBaseBreak Method
When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Break()
Sub Break
void Break()
abstract Break : unit -> unit
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.ClearTemporaryGeneratedModules Method

IScriptDebuggerBaseClearTemporaryGeneratedModules Method
When implemented by a class, clears temporary generated modules on disk.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearTemporaryGeneratedModules()
Sub ClearTemporaryGeneratedModules
void ClearTemporaryGeneratedModules()
abstract ClearTemporaryGeneratedModules : unit -> unit
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.Continue Method

IScriptDebuggerBaseContinue Method
When implemented by a class, continues given process to the next breakpoint or until process finishes.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Continue()
Sub Continue
void Continue()
abstract Continue : unit -> unit
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.EvaluateCurrentExceptionAsync Method

IScriptDebuggerBaseEvaluateCurrentExceptionAsync Method
When implemented by a class, evaluates current expression based on the current stack frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<ExpressionEvaluationResult> EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = null
)
Function EvaluateCurrentExceptionAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExpressionEvaluationResult)
Task<ExpressionEvaluationResult^>^ EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateCurrentExceptionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExpressionEvaluationResult
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.EvaluateExpressionAsync Method

IScriptDebuggerBaseEvaluateExpressionAsync Method
When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<ExpressionEvaluationResult> EvaluateExpressionAsync(
    ExpressionEvaluationRequest request,
    CancellationToken cancellationToken = null
)
Function EvaluateExpressionAsync (
    request As ExpressionEvaluationRequest,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExpressionEvaluationResult)
Task<ExpressionEvaluationResult^>^ EvaluateExpressionAsync(
    ExpressionEvaluationRequest^ request,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        request : ExpressionEvaluationRequest *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>

Parameters

request
Type: Alternet.Scripter.DebuggerExpressionEvaluationRequest
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExpressionEvaluationResult
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.EvaluateExpressionsAsync Method

IScriptDebuggerBaseEvaluateExpressionsAsync Method
When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<IEnumerable<ExpressionEvaluationResult>> EvaluateExpressionsAsync(
    IEnumerable<ExpressionEvaluationRequest> requests,
    CancellationToken cancellationToken = null
)
Function EvaluateExpressionsAsync (
    requests As IEnumerable(Of ExpressionEvaluationRequest),
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of IEnumerable(Of ExpressionEvaluationResult))
Task<IEnumerable<ExpressionEvaluationResult^>^>^ EvaluateExpressionsAsync(
    IEnumerable<ExpressionEvaluationRequest^>^ requests,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionsAsync :
        requests : IEnumerable<ExpressionEvaluationRequest> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<IEnumerable<ExpressionEvaluationResult>>

Parameters

requests
Type: System.Collections.GenericIEnumerableExpressionEvaluationRequest
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskIEnumerableExpressionEvaluationResult
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.GetExecutionPositionAsync Method

IScriptDebuggerBaseGetExecutionPositionAsync Method
When implemented by a class, finds out current ExecutionPosition based on the current stack frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<ExecutionPosition> GetExecutionPositionAsync(
    CancellationToken cancellationToken = null
)
Function GetExecutionPositionAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExecutionPosition)
Task<ExecutionPosition^>^ GetExecutionPositionAsync(
    CancellationToken cancellationToken = nullptr
)
abstract GetExecutionPositionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExecutionPosition>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExecutionPosition
Position of execution.
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.GetStackFramesAsync Method

IScriptDebuggerBaseGetStackFramesAsync Method
When implemented by a class, gets list of method calls that are currently on a stack

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<StackFramesRetrievalResult> GetStackFramesAsync(
    CancellationToken cancellationToken = null
)
Function GetStackFramesAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of StackFramesRetrievalResult)
Task<StackFramesRetrievalResult^>^ GetStackFramesAsync(
    CancellationToken cancellationToken = nullptr
)
abstract GetStackFramesAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<StackFramesRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskStackFramesRetrievalResult
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.GetThreadsAsync Method

IScriptDebuggerBaseGetThreadsAsync Method
When implemented by a class, gets list of active threads.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<ThreadsRetrievalResult> GetThreadsAsync(
    CancellationToken cancellationToken = null
)
Function GetThreadsAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ThreadsRetrievalResult)
Task<ThreadsRetrievalResult^>^ GetThreadsAsync(
    CancellationToken cancellationToken = nullptr
)
abstract GetThreadsAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ThreadsRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskThreadsRetrievalResult
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.GetVariablesInScopeAsync Method

IScriptDebuggerBaseGetVariablesInScopeAsync Method
When implemented by a class, receives all local variables based on the current stack frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<VariablesRetrievalResult> GetVariablesInScopeAsync(
    CancellationToken cancellationToken = null
)
Function GetVariablesInScopeAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of VariablesRetrievalResult)
Task<VariablesRetrievalResult^>^ GetVariablesInScopeAsync(
    CancellationToken cancellationToken = nullptr
)
abstract GetVariablesInScopeAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<VariablesRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskVariablesRetrievalResult
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.SetRunToPositionBreakpoint Method

IScriptDebuggerBaseSetRunToPositionBreakpoint Method
When implemented by a class, causes debugger to stop at the specified position.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetRunToPositionBreakpoint(
    RunToPositionBreakpoint breakpoint
)
Sub SetRunToPositionBreakpoint (
    breakpoint As RunToPositionBreakpoint
)
void SetRunToPositionBreakpoint(
    RunToPositionBreakpoint^ breakpoint
)
abstract SetRunToPositionBreakpoint :
        breakpoint : RunToPositionBreakpoint -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerRunToPositionBreakpoint
Position in the source file.
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.StartDebugging Method

IScriptDebuggerBaseStartDebugging Method
Overload List
 | Name | Description
Public method | StartDebugging | When implemented by a class, starts executing the program from the entry point with default settings.
Public method | StartDebugging(StartDebuggingOptions) | When implemented by a class, starts executing the program from the entry point with specified settings.
Top
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.StartDebugging Method

IScriptDebuggerBaseStartDebugging Method
When implemented by a class, starts executing the program from the entry point with default settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartDebugging()
Sub StartDebugging
void StartDebugging()
abstract StartDebugging : unit -> unit
See Also

Reference

IScriptDebuggerBase Interface
StartDebugging Overload
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.StartDebugging Method (StartDebuggingOptions)

IScriptDebuggerBaseStartDebugging Method (StartDebuggingOptions)
When implemented by a class, starts executing the program from the entry point with specified settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartDebugging(
    StartDebuggingOptions options
)
Sub StartDebugging (
    options As StartDebuggingOptions
)
void StartDebugging(
    StartDebuggingOptions^ options
)
abstract StartDebugging :
        options : StartDebuggingOptions -> unit

Parameters

options
Type: Alternet.Scripter.DebuggerStartDebuggingOptions
Settings of debug process.
See Also

Reference

IScriptDebuggerBase Interface
StartDebugging Overload
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.StepInto Method

IScriptDebuggerBaseStepInto Method
When implemented by a class, executes one statement of code; steps into the next function call, if possible.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StepInto()
Sub StepInto
void StepInto()
abstract StepInto : unit -> unit
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.StepOut Method

IScriptDebuggerBaseStepOut Method
When implemented by a class, executes one statement of code; steps out of the function currently being executed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StepOut()
Sub StepOut
void StepOut()
abstract StepOut : unit -> unit
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.StepOver Method

IScriptDebuggerBaseStepOver Method
When implemented by a class, executes one statement of code; steps over the next function call.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StepOver()
Sub StepOver
void StepOver()
abstract StepOver : unit -> unit
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.StopDebuggingAsync Method

IScriptDebuggerBaseStopDebuggingAsync Method
When implemented by a class, stops executing the program.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task StopDebuggingAsync(
    CancellationToken cancellationToken = null
)
Function StopDebuggingAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
Task^ StopDebuggingAsync(
    CancellationToken cancellationToken = nullptr
)
abstract StopDebuggingAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.SwitchToStackFrame Method

IScriptDebuggerBaseSwitchToStackFrame Method
When implemented by a class, switches debugging to the given stack frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SwitchToStackFrame(
    StackFrame frame
)
Sub SwitchToStackFrame (
    frame As StackFrame
)
void SwitchToStackFrame(
    StackFrame^ frame
)
abstract SwitchToStackFrame :
        frame : StackFrame -> unit

Parameters

frame
Type: Alternet.Scripter.DebuggerStackFrame
StackFrame to be switched to.
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.TrySetNextStatementAsync Method

IScriptDebuggerBaseTrySetNextStatementAsync Method
When implemented by a class, tries to set the execution point to the specified line of code.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Result> TrySetNextStatementAsync(
    int lineNumber,
    CancellationToken cancellationToken = null
)
Function TrySetNextStatementAsync (
    lineNumber As Integer,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Result)
Task<Result^>^ TrySetNextStatementAsync(
    int lineNumber,
    CancellationToken cancellationToken = nullptr
)
abstract TrySetNextStatementAsync :
        lineNumber : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Result>

Parameters

lineNumber
Type: SystemInt32
Line number to be going to.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskResult
Result of executing.
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase Properties

IScriptDebuggerBase Properties

The IScriptDebuggerBase type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, returns collection of debugger breakpoints.
Public property | Capabilities | When implemented by a class, gets debugger capabilities.
Public property | EventsSyncAction | When implemented by a class, gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)
Public property | ExpressionEvaluator | When implemented by a class, gets IExpressionEvaluator object used to evaluate expressions.
Public property | IsStarted | When implemented by a class, indicates whether debugging was started.
Public property | ScopeResolutionService | When implemented by a class, gets IScopeResolutionService object used to evaluate method names and parameters.
Public property | ScriptRun | When implemented by a class, contains all information required to compile and run the script
Public property | State | When implemented by a class, gets current debugger state.
Top
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.Breakpoints Property

IScriptDebuggerBaseBreakpoints Property
When implemented by a class, returns collection of debugger breakpoints.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptBreakpoints Breakpoints { get; }
ReadOnly Property Breakpoints As IScriptBreakpoints
    Get
property IScriptBreakpoints^ Breakpoints {
    IScriptBreakpoints^ get ();
}
abstract Breakpoints : IScriptBreakpoints with get

Property Value

Type: IScriptBreakpoints
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.Capabilities Property

IScriptDebuggerBaseCapabilities Property
When implemented by a class, gets debugger capabilities.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DebuggerCapabilities Capabilities { get; }
ReadOnly Property Capabilities As DebuggerCapabilities
    Get
property DebuggerCapabilities Capabilities {
    DebuggerCapabilities get ();
}
abstract Capabilities : DebuggerCapabilities with get

Property Value

Type: DebuggerCapabilities
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.EventsSyncAction Property

IScriptDebuggerBaseEventsSyncAction Property
When implemented by a class, gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Action<Delegate> EventsSyncAction { get; set; }
Property EventsSyncAction As Action(Of Delegate)
    Get
    Set
property Action<Delegate^>^ EventsSyncAction {
    Action<Delegate^>^ get ();
    void set (Action<Delegate^>^ value);
}
abstract EventsSyncAction : Action<Delegate> with get, set

Property Value

Type: ActionDelegate
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.ExpressionEvaluator Property

IScriptDebuggerBaseExpressionEvaluator Property
When implemented by a class, gets IExpressionEvaluator object used to evaluate expressions.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IExpressionEvaluator ExpressionEvaluator { get; }
ReadOnly Property ExpressionEvaluator As IExpressionEvaluator
    Get
property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get ();
}
abstract ExpressionEvaluator : IExpressionEvaluator with get

Property Value

Type: IExpressionEvaluator
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.IsStarted Property

IScriptDebuggerBaseIsStarted Property
When implemented by a class, indicates whether debugging was started.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsStarted { get; }
ReadOnly Property IsStarted As Boolean
    Get
property bool IsStarted {
    bool get ();
}
abstract IsStarted : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.ScopeResolutionService Property

IScriptDebuggerBaseScopeResolutionService Property
When implemented by a class, gets IScopeResolutionService object used to evaluate method names and parameters.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScopeResolutionService ScopeResolutionService { get; }
ReadOnly Property ScopeResolutionService As IScopeResolutionService
    Get
property IScopeResolutionService^ ScopeResolutionService {
    IScopeResolutionService^ get ();
}
abstract ScopeResolutionService : IScopeResolutionService with get

Property Value

Type: IScopeResolutionService
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.ScriptRun Property

IScriptDebuggerBaseScriptRun Property
When implemented by a class, contains all information required to compile and run the script

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptRunBase ScriptRun { get; }
ReadOnly Property ScriptRun As IScriptRunBase
    Get
property IScriptRunBase^ ScriptRun {
    IScriptRunBase^ get ();
}
abstract ScriptRun : IScriptRunBase with get

Property Value

Type: IScriptRunBase
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.State Property

IScriptDebuggerBaseState Property
When implemented by a class, gets current debugger state.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DebuggerState State { get; }
ReadOnly Property State As DebuggerState
    Get
property DebuggerState State {
    DebuggerState get ();
}
abstract State : DebuggerState with get

Property Value

Type: DebuggerState
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase Events

IScriptDebuggerBase Events

The IScriptDebuggerBase type exposes the following members.

Events
 | Name | Description
Public event | ActiveThreadChanged | When implemented by a class, occurs when thread to be debugged changes.
Public event | BeforeContinue | When implemented by a class, occurs before debugger continues to program execution.
Public event | BeforeStep | When implemented by a class, occurs before debugger performs a step.
Public event | BeforeStop | When implemented by a class, occurs before debugger stop debugging.
Public event | DebuggerErrorOccured | When implemented by a class, occurs when encounters error during debugging session.
Public event | DebuggingStarted | When implemented by a class, occurs when debugging session is started.
Public event | DebuggingStopped | When implemented by a class, occurs when debugging session is stopped.
Public event | ExecutionResumed | When implemented by a class, occurs when debugging is resumed after being paused.
Public event | ExecutionStopped | When implemented by a class, occurs when debugging is paused.
Public event | LogMessageReceived | When implemented by a class, occurs when debug message is received.
Public event | StackFrameSwitched | When implemented by a class, occurs debugger switches to the stack frame
Public event | StateChanged | When implemented by a class, occurs when debugger state is changed.
Top
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.ActiveThreadChanged Event

IScriptDebuggerBaseActiveThreadChanged Event
When implemented by a class, occurs when thread to be debugged changes.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ActiveThreadChangedEventArgs> ActiveThreadChanged
Event ActiveThreadChanged As EventHandler(Of ActiveThreadChangedEventArgs)
 event EventHandler<ActiveThreadChangedEventArgs^>^ ActiveThreadChanged {
    void add (EventHandler<ActiveThreadChangedEventArgs^>^ value);
    void remove (EventHandler<ActiveThreadChangedEventArgs^>^ value);
}
abstract ActiveThreadChanged : IEvent<EventHandler<ActiveThreadChangedEventArgs>,
    ActiveThreadChangedEventArgs>

Value

Type: SystemEventHandlerActiveThreadChangedEventArgs
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.BeforeContinue Event

IScriptDebuggerBaseBeforeContinue Event
When implemented by a class, occurs before debugger continues to program execution.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler BeforeContinue
Event BeforeContinue As EventHandler
 event EventHandler^ BeforeContinue {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeContinue : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.BeforeStep Event

IScriptDebuggerBaseBeforeStep Event
When implemented by a class, occurs before debugger performs a step.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler BeforeStep
Event BeforeStep As EventHandler
 event EventHandler^ BeforeStep {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeStep : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.BeforeStop Event

IScriptDebuggerBaseBeforeStop Event
When implemented by a class, occurs before debugger stop debugging.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler BeforeStop
Event BeforeStop As EventHandler
 event EventHandler^ BeforeStop {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeStop : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.DebuggerErrorOccured Event

IScriptDebuggerBaseDebuggerErrorOccured Event
When implemented by a class, occurs when encounters error during debugging session.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<DebuggerErrorOccuredEventArgs> DebuggerErrorOccured
Event DebuggerErrorOccured As EventHandler(Of DebuggerErrorOccuredEventArgs)
 event EventHandler<DebuggerErrorOccuredEventArgs^>^ DebuggerErrorOccured {
    void add (EventHandler<DebuggerErrorOccuredEventArgs^>^ value);
    void remove (EventHandler<DebuggerErrorOccuredEventArgs^>^ value);
}
abstract DebuggerErrorOccured : IEvent<EventHandler<DebuggerErrorOccuredEventArgs>,
    DebuggerErrorOccuredEventArgs>

Value

Type: SystemEventHandlerDebuggerErrorOccuredEventArgs
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.DebuggingStarted Event

IScriptDebuggerBaseDebuggingStarted Event
When implemented by a class, occurs when debugging session is started.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<DebuggingStartedEventArgs> DebuggingStarted
Event DebuggingStarted As EventHandler(Of DebuggingStartedEventArgs)
 event EventHandler<DebuggingStartedEventArgs^>^ DebuggingStarted {
    void add (EventHandler<DebuggingStartedEventArgs^>^ value);
    void remove (EventHandler<DebuggingStartedEventArgs^>^ value);
}
abstract DebuggingStarted : IEvent<EventHandler<DebuggingStartedEventArgs>,
    DebuggingStartedEventArgs>

Value

Type: SystemEventHandlerDebuggingStartedEventArgs
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.DebuggingStopped Event

IScriptDebuggerBaseDebuggingStopped Event
When implemented by a class, occurs when debugging session is stopped.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<DebuggingStoppedEventArgs> DebuggingStopped
Event DebuggingStopped As EventHandler(Of DebuggingStoppedEventArgs)
 event EventHandler<DebuggingStoppedEventArgs^>^ DebuggingStopped {
    void add (EventHandler<DebuggingStoppedEventArgs^>^ value);
    void remove (EventHandler<DebuggingStoppedEventArgs^>^ value);
}
abstract DebuggingStopped : IEvent<EventHandler<DebuggingStoppedEventArgs>,
    DebuggingStoppedEventArgs>

Value

Type: SystemEventHandlerDebuggingStoppedEventArgs
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.ExecutionResumed Event

IScriptDebuggerBaseExecutionResumed Event
When implemented by a class, occurs when debugging is resumed after being paused.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ExecutionResumedEventArgs> ExecutionResumed
Event ExecutionResumed As EventHandler(Of ExecutionResumedEventArgs)
 event EventHandler<ExecutionResumedEventArgs^>^ ExecutionResumed {
    void add (EventHandler<ExecutionResumedEventArgs^>^ value);
    void remove (EventHandler<ExecutionResumedEventArgs^>^ value);
}
abstract ExecutionResumed : IEvent<EventHandler<ExecutionResumedEventArgs>,
    ExecutionResumedEventArgs>

Value

Type: SystemEventHandlerExecutionResumedEventArgs
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.ExecutionStopped Event

IScriptDebuggerBaseExecutionStopped Event
When implemented by a class, occurs when debugging is paused.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ExecutionStoppedEventArgs> ExecutionStopped
Event ExecutionStopped As EventHandler(Of ExecutionStoppedEventArgs)
 event EventHandler<ExecutionStoppedEventArgs^>^ ExecutionStopped {
    void add (EventHandler<ExecutionStoppedEventArgs^>^ value);
    void remove (EventHandler<ExecutionStoppedEventArgs^>^ value);
}
abstract ExecutionStopped : IEvent<EventHandler<ExecutionStoppedEventArgs>,
    ExecutionStoppedEventArgs>

Value

Type: SystemEventHandlerExecutionStoppedEventArgs
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.LogMessageReceived Event

IScriptDebuggerBaseLogMessageReceived Event
When implemented by a class, occurs when debug message is received.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<LogMessageReceivedEventArgs> LogMessageReceived
Event LogMessageReceived As EventHandler(Of LogMessageReceivedEventArgs)
 event EventHandler<LogMessageReceivedEventArgs^>^ LogMessageReceived {
    void add (EventHandler<LogMessageReceivedEventArgs^>^ value);
    void remove (EventHandler<LogMessageReceivedEventArgs^>^ value);
}
abstract LogMessageReceived : IEvent<EventHandler<LogMessageReceivedEventArgs>,
    LogMessageReceivedEventArgs>

Value

Type: SystemEventHandlerLogMessageReceivedEventArgs
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.StackFrameSwitched Event

IScriptDebuggerBaseStackFrameSwitched Event
When implemented by a class, occurs debugger switches to the stack frame

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<StackFrameSwitchedEventArgs> StackFrameSwitched
Event StackFrameSwitched As EventHandler(Of StackFrameSwitchedEventArgs)
 event EventHandler<StackFrameSwitchedEventArgs^>^ StackFrameSwitched {
    void add (EventHandler<StackFrameSwitchedEventArgs^>^ value);
    void remove (EventHandler<StackFrameSwitchedEventArgs^>^ value);
}
abstract StackFrameSwitched : IEvent<EventHandler<StackFrameSwitchedEventArgs>,
    StackFrameSwitchedEventArgs>

Value

Type: SystemEventHandlerStackFrameSwitchedEventArgs
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


IScriptDebuggerBase.StateChanged Event

IScriptDebuggerBaseStateChanged Event
When implemented by a class, occurs when debugger state is changed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<DebuggerStateChangedEventArgs> StateChanged
Event StateChanged As EventHandler(Of DebuggerStateChangedEventArgs)
 event EventHandler<DebuggerStateChangedEventArgs^>^ StateChanged {
    void add (EventHandler<DebuggerStateChangedEventArgs^>^ value);
    void remove (EventHandler<DebuggerStateChangedEventArgs^>^ value);
}
abstract StateChanged : IEvent<EventHandler<DebuggerStateChangedEventArgs>,
    DebuggerStateChangedEventArgs>

Value

Type: SystemEventHandlerDebuggerStateChangedEventArgs
See Also

Reference

IScriptDebuggerBase Interface
Alternet.Scripter.Debugger Namespace


LogMessageReceivedEventArgs Class

LogMessageReceivedEventArgs Class
Provides data for the IScriptDebugger.LogMessageReceived event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerLogMessageReceivedEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LogMessageReceivedEventArgs : EventArgs
Public Class LogMessageReceivedEventArgs
    Inherits EventArgs
public ref class LogMessageReceivedEventArgs : public EventArgs
type LogMessageReceivedEventArgs =
    class
        inherit EventArgs
    end

The LogMessageReceivedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LogMessageReceivedEventArgs | Initializes a new instance of the LogMessageReceivedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Message | Gets or sets log message.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


LogMessageReceivedEventArgs Constructor

LogMessageReceivedEventArgs Constructor
Initializes a new instance of the LogMessageReceivedEventArgs class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogMessageReceivedEventArgs()
Public Sub New
public:
LogMessageReceivedEventArgs()
new : unit -> LogMessageReceivedEventArgs
See Also

Reference

LogMessageReceivedEventArgs Class
Alternet.Scripter.Debugger Namespace


LogMessageReceivedEventArgs Methods

LogMessageReceivedEventArgs Methods

The LogMessageReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogMessageReceivedEventArgs Class
Alternet.Scripter.Debugger Namespace


LogMessageReceivedEventArgs Properties

LogMessageReceivedEventArgs Properties

The LogMessageReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets or sets log message.
Top
See Also

Reference

LogMessageReceivedEventArgs Class
Alternet.Scripter.Debugger Namespace


LogMessageReceivedEventArgs.Message Property

LogMessageReceivedEventArgsMessage Property
Gets or sets log message.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

LogMessageReceivedEventArgs Class
Alternet.Scripter.Debugger Namespace


RunToPositionBreakpoint Class

RunToPositionBreakpoint Class
Specifies breakpoint position inside the file.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerRunToPositionBreakpoint

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RunToPositionBreakpoint
Public Class RunToPositionBreakpoint
public ref class RunToPositionBreakpoint
type RunToPositionBreakpoint =  class end

The RunToPositionBreakpoint type exposes the following members.

Constructors
 | Name | Description
Public method | RunToPositionBreakpoint | Initializes a new instance of the RunToPositionBreakpoint class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FilePath | Gets or sets name of file where breakpoint is set.
Public property | LineNumber | Gets or sets number of line at which breakpoint is set.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


RunToPositionBreakpoint Constructor

RunToPositionBreakpoint Constructor
Initializes a new instance of the RunToPositionBreakpoint class with specified parameters.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RunToPositionBreakpoint(
    string fileName,
    int lineNumber
)
Public Sub New (
    fileName As String,
    lineNumber As Integer
)
public:
RunToPositionBreakpoint(
    String^ fileName,
    int lineNumber
)
new :
        fileName : string *
        lineNumber : int -> RunToPositionBreakpoint

Parameters

fileName
Type: SystemString
Name of file where breakpoint is set.
lineNumber
Type: SystemInt32
Index of line at which breakpoint is set.
See Also

Reference

RunToPositionBreakpoint Class
Alternet.Scripter.Debugger Namespace


RunToPositionBreakpoint Methods

RunToPositionBreakpoint Methods

The RunToPositionBreakpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunToPositionBreakpoint Class
Alternet.Scripter.Debugger Namespace


RunToPositionBreakpoint Properties

RunToPositionBreakpoint Properties

The RunToPositionBreakpoint type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | Gets or sets name of file where breakpoint is set.
Public property | LineNumber | Gets or sets number of line at which breakpoint is set.
Top
See Also

Reference

RunToPositionBreakpoint Class
Alternet.Scripter.Debugger Namespace


RunToPositionBreakpoint.FilePath Property

RunToPositionBreakpointFilePath Property
Gets or sets name of file where breakpoint is set.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get
public:
property String^ FilePath {
    String^ get ();
}
member FilePath : string with get

Property Value

Type: String
See Also

Reference

RunToPositionBreakpoint Class
Alternet.Scripter.Debugger Namespace


RunToPositionBreakpoint.LineNumber Property

RunToPositionBreakpointLineNumber Property
Gets or sets number of line at which breakpoint is set.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LineNumber { get; }
Public ReadOnly Property LineNumber As Integer
    Get
public:
property int LineNumber {
    int get ();
}
member LineNumber : int with get

Property Value

Type: Int32
See Also

Reference

RunToPositionBreakpoint Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints Class

ScriptBreakpoints Class
Provides list of Breakpoint objects.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerScriptBreakpoints

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptBreakpoints : IScriptBreakpoints,
    IUpdate
Public Class ScriptBreakpoints
    Implements IScriptBreakpoints, IUpdate
public ref class ScriptBreakpoints : IScriptBreakpoints,
    IUpdate
type ScriptBreakpoints =
    class
        interface IScriptBreakpoints
        interface IUpdate
    end

The ScriptBreakpoints type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptBreakpoints | Initializes a new instance of the ScriptBreakpoints class with corresponds to specified ScriptDebugger object.
Top
Methods
 | Name | Description
Public method | AddBreakpoint | Adds a Breakpoint to the list.
Public method | BeginUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Clear | Removes all breakpoints.
Public method | DisableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EnableBreakpoint | Enables or disables specified breakpoint.
Public method | EnableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveBreakpoint | Removes a Breakpoint from the list.
Public method | RemoveBreakpoints | Removes several Breakpoint from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Raises Changed event
Top
Properties
 | Name | Description
Public property | Breakpoints | Gets an array of Breakpoint objects.
Public property | Debugger | Represents ScriptDebugger owner of this ScriptBreakpoints.
Public property | UpdateCount |
Top
Events
 | Name | Description
Public event | BreakpointAdded | Occurs when a breakpoint is added.
Public event | BreakpointRemoved | Occurs when a breakpoint is removed.
Public event | BreakpointStateChanged | Occurs when a breakpoint state is changed.
Public event | Changed | Occurs when breakpoints are changed.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ScriptBreakpoints Constructor

ScriptBreakpoints Constructor
Initializes a new instance of the ScriptBreakpoints class with corresponds to specified ScriptDebugger object.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptBreakpoints(
    ScriptDebugger debugger
)
Public Sub New (
    debugger As ScriptDebugger
)
public:
ScriptBreakpoints(
    ScriptDebugger^ debugger
)
new :
        debugger : ScriptDebugger -> ScriptBreakpoints

Parameters

debugger
Type: Alternet.Scripter.DebuggerScriptDebugger
ScriptDebugger that owns this new instance.
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints Methods

ScriptBreakpoints Methods

The ScriptBreakpoints type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint | Adds a Breakpoint to the list.
Public method | BeginUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Clear | Removes all breakpoints.
Public method | DisableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EnableBreakpoint | Enables or disables specified breakpoint.
Public method | EnableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveBreakpoint | Removes a Breakpoint from the list.
Public method | RemoveBreakpoints | Removes several Breakpoint from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Raises Changed event
Top
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.AddBreakpoint Method

ScriptBreakpointsAddBreakpoint Method
Adds a Breakpoint to the list.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddBreakpoint(
    string filePath,
    int lineNumber
)
Public Sub AddBreakpoint (
    filePath As String,
    lineNumber As Integer
)
public:
virtual void AddBreakpoint(
    String^ filePath,
    int lineNumber
) sealed
abstract AddBreakpoint :
        filePath : string *
        lineNumber : int -> unit
override AddBreakpoint :
        filePath : string *
        lineNumber : int -> unit

Parameters

filePath
Type: SystemString
Name of file where breakpoint is set.
lineNumber
Type: SystemInt32
Number of line at which breakpoint is set.

Implements

IScriptBreakpointsAddBreakpoint(String, Int32)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.BeginUpdate Method

ScriptBreakpointsBeginUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BeginUpdate()
Public Function BeginUpdate As Integer
public:
virtual int BeginUpdate() sealed
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateBeginUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.Clear Method

ScriptBreakpointsClear Method
Removes all breakpoints.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IScriptBreakpointsClear
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.DisableUpdate Method

ScriptBreakpointsDisableUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DisableUpdate()
Public Function DisableUpdate As Integer
public:
virtual int DisableUpdate() sealed
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateDisableUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.EnableBreakpoint Method

ScriptBreakpointsEnableBreakpoint Method
Enables or disables specified breakpoint.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableBreakpoint(
    Breakpoint breakpoint,
    bool enable
)
Public Sub EnableBreakpoint (
    breakpoint As Breakpoint,
    enable As Boolean
)
public:
virtual void EnableBreakpoint(
    Breakpoint^ breakpoint,
    bool enable
) sealed
abstract EnableBreakpoint :
        breakpoint : Breakpoint *
        enable : bool -> unit
override EnableBreakpoint :
        breakpoint : Breakpoint *
        enable : bool -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
Breakpoint to process.
enable
Type: SystemBoolean
New breakpoint's state.

Implements

IScriptBreakpointsEnableBreakpoint(Breakpoint, Boolean)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.EnableUpdate Method

ScriptBreakpointsEnableUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EnableUpdate()
Public Function EnableUpdate As Integer
public:
virtual int EnableUpdate() sealed
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateEnableUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.EndUpdate Method

ScriptBreakpointsEndUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndUpdate()
Public Function EndUpdate As Integer
public:
virtual int EndUpdate() sealed
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateEndUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.RemoveBreakpoint Method

ScriptBreakpointsRemoveBreakpoint Method
Removes a Breakpoint from the list.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveBreakpoint(
    Breakpoint breakpoint
)
Public Function RemoveBreakpoint (
    breakpoint As Breakpoint
) As Boolean
public:
virtual bool RemoveBreakpoint(
    Breakpoint^ breakpoint
) sealed
abstract RemoveBreakpoint :
        breakpoint : Breakpoint -> bool
override RemoveBreakpoint :
        breakpoint : Breakpoint -> bool

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
The Breakpoint to remove from the list.

Return Value

Type: Boolean

Implements

IScriptBreakpointsRemoveBreakpoint(Breakpoint)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.RemoveBreakpoints Method

ScriptBreakpointsRemoveBreakpoints Method
Removes several Breakpoint from the list.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveBreakpoints(
    IList<Breakpoint> breakpoints
)
Public Sub RemoveBreakpoints (
    breakpoints As IList(Of Breakpoint)
)
public:
virtual void RemoveBreakpoints(
    IList<Breakpoint^>^ breakpoints
) sealed
abstract RemoveBreakpoints :
        breakpoints : IList<Breakpoint> -> unit
override RemoveBreakpoints :
        breakpoints : IList<Breakpoint> -> unit

Parameters

breakpoints
Type: System.Collections.GenericIListBreakpoint
The number of Breakpoint to remove from the list.

Implements

IScriptBreakpointsRemoveBreakpoints(IListBreakpoint)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.Update Method

ScriptBreakpointsUpdate Method
Raises Changed event

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints Properties

ScriptBreakpoints Properties

The ScriptBreakpoints type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Gets an array of Breakpoint objects.
Public property | Debugger | Represents ScriptDebugger owner of this ScriptBreakpoints.
Public property | UpdateCount |
Top
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.Breakpoints Property

ScriptBreakpointsBreakpoints Property
Gets an array of Breakpoint objects.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoint[] Breakpoints { get; }
Public ReadOnly Property Breakpoints As Breakpoint()
    Get
public:
virtual property array<Breakpoint^>^ Breakpoints {
    array<Breakpoint^>^ get () sealed;
}
abstract Breakpoints : Breakpoint[] with get
override Breakpoints : Breakpoint[] with get

Property Value

Type: Breakpoint

Implements

IScriptBreakpointsBreakpoints
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.Debugger Property

ScriptBreakpointsDebugger Property
Represents ScriptDebugger owner of this ScriptBreakpoints.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptDebugger Debugger { get; }
Public ReadOnly Property Debugger As ScriptDebugger
    Get
public:
property ScriptDebugger^ Debugger {
    ScriptDebugger^ get ();
}
member Debugger : ScriptDebugger with get

Property Value

Type: ScriptDebugger
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.UpdateCount Property

ScriptBreakpointsUpdateCount Property

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UpdateCount { get; }
Public ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get () sealed;
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints Events

ScriptBreakpoints Events

The ScriptBreakpoints type exposes the following members.

Events
 | Name | Description
Public event | BreakpointAdded | Occurs when a breakpoint is added.
Public event | BreakpointRemoved | Occurs when a breakpoint is removed.
Public event | BreakpointStateChanged | Occurs when a breakpoint state is changed.
Public event | Changed | Occurs when breakpoints are changed.
Top
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.BreakpointAdded Event

ScriptBreakpointsBreakpointAdded Event
Occurs when a breakpoint is added.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointEventArgs> BreakpointAdded
Public Event BreakpointAdded As EventHandler(Of BreakpointEventArgs)
public:
virtual  event EventHandler<BreakpointEventArgs^>^ BreakpointAdded {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointAdded : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>
override BreakpointAdded : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs

Implements

IScriptBreakpointsBreakpointAdded
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.BreakpointRemoved Event

ScriptBreakpointsBreakpointRemoved Event
Occurs when a breakpoint is removed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointEventArgs> BreakpointRemoved
Public Event BreakpointRemoved As EventHandler(Of BreakpointEventArgs)
public:
virtual  event EventHandler<BreakpointEventArgs^>^ BreakpointRemoved {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointRemoved : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>
override BreakpointRemoved : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs

Implements

IScriptBreakpointsBreakpointRemoved
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.BreakpointStateChanged Event

ScriptBreakpointsBreakpointStateChanged Event
Occurs when a breakpoint state is changed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointEventArgs> BreakpointStateChanged
Public Event BreakpointStateChanged As EventHandler(Of BreakpointEventArgs)
public:
virtual  event EventHandler<BreakpointEventArgs^>^ BreakpointStateChanged {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointStateChanged : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>
override BreakpointStateChanged : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs

Implements

IScriptBreakpointsBreakpointStateChanged
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptBreakpoints.Changed Event

ScriptBreakpointsChanged Event
Occurs when breakpoints are changed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Changed
Public Event Changed As EventHandler
public:
virtual  event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Changed : IEvent<EventHandler,
    EventArgs>
override Changed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptBreakpointsChanged
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger Class

ScriptDebugger Class
Enables communication with a debugger.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerScriptDebugger

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptDebugger : IScriptDebugger,
    IScriptDebuggerBase, IDisposable, IDebuggerCommandDispatcher
Public Class ScriptDebugger
    Implements IScriptDebugger, IScriptDebuggerBase, IDisposable, IDebuggerCommandDispatcher
public ref class ScriptDebugger : IScriptDebugger,
    IScriptDebuggerBase, IDisposable, IDebuggerCommandDispatcher
type ScriptDebugger =
    class
        interface IScriptDebugger
        interface IScriptDebuggerBase
        interface IDisposable
        interface IDebuggerCommandDispatcher
    end

The ScriptDebugger type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptDebugger | Initializes a new instance of the ScriptDebugger class with default settings.
Top
Methods
 | Name | Description
Public method | ActivateThread | Switches debugging to the specified thread.
Public method | AttachToProcessAsync(Int32, CancellationToken) | Attaches debugger to the process.
Public method | AttachToProcessAsync(Int32, StartDebuggingOptions, CancellationToken) | Attaches debugger to the process.
Public method | Break | Causes the given process to pause its execution so that its current state can be analyzed.
Public method | ClearTemporaryGeneratedModules | Clears temporary generated modules on disk.
Public method | Continue | Continues given process to the next breakpoint or until process finishes.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnableBreakpoint | Enables or disables breakpoint at specified position.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentExceptionAsync | Evaluates current expression based on the current stack frame.
Public method | EvaluateExpressionAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionsAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | ExecuteCommandInDebuggerThread | Executes action in the UI thread.
Public method | ExecuteCommandInDebuggerThreadAndMarshalException | Executes action in the UI thread; in case action throws exception, it's handled in the UI thread as well.
Public method | GetExecutionPositionAsync | Finds out current ExecutionPosition based on the current stack frame.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetStackFramesAsync | Gets list of method calls that are currently on a stack.
Public method | GetThreadsAsync | Gets list of active threads.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVariablesInScopeAsync | Receives all local variables based on the current stack frame.
Public method | SetRunToPositionBreakpoint | Causes debugger to stop at the specified position.
Public method | StartDebugging | Starts executing the program from the entry point with default settings.
Public method | StartDebugging(StartDebuggingOptions) | Starts executing the program from the entry point with specified settings.
Public method | StepInto | Executes one statement of code; steps into the next function call, if possible.
Public method | StepOut | Executes one statement of code; steps out of the function currently being executed.
Public method | StepOver | Executes one statement of code; steps over the next function call.
Public method | StopDebuggingAsync | Stops executing the program.
Public method | SwitchToStackFrame | Switches debugging to the given stack frame.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrySetNextStatementAsync | Tries to set the execution point to the specified line of code.
Top
Properties
 | Name | Description
Public property | Breakpoints | Returns collection of debugger breakpoints.
Public property | Capabilities | Gets debugger capabilities.
Public property | EventsSyncAction | Gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)
Public property | ExpressionEvaluator | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | GeneratedModulesPath | Gets directory where assemblies for the scripts being debugged are located.
Public property | IsStarted | Indicates whether debugging was started.
Public property | MyCodeModules | Gets or sets collection of module names to be debugged.
Public property | ScopeResolutionService | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | ScriptRun | Contains all information required to compile and run the script.
Public property | State | Gets current debugger state.
Top
Events
 | Name | Description
Public event | ActiveThreadChanged | Occurs when thread to be debugged changes.
Public event | BeforeContinue | Occurs before debugger continues to program execution.
Public event | BeforeStep | Occurs before debugger performs a step.
Public event | BeforeStop | Occurs before debugger stop debugging.
Public event | DebuggerErrorOccured | Occurs when encounters error during debugging session.
Public event | DebuggingStarted | Occurs when debugging session is started.
Public event | DebuggingStopped | Occurs when debugging session is stopped.
Public event | ExecutionResumed | Occurs when debugging is resumed after being paused.
Public event | ExecutionStopped | Occurs when debugging is paused.
Public event | LogMessageReceived | Occurs when debug message is received.
Public event | StackFrameSwitched | Occurs debugger switches to the stack frame.
Public event | StateChanged | Occurs when debugger state is changed.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ScriptDebugger Constructor

ScriptDebugger Constructor
Initializes a new instance of the ScriptDebugger class with default settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptDebugger()
Public Sub New
public:
ScriptDebugger()
new : unit -> ScriptDebugger
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger Methods

ScriptDebugger Methods

The ScriptDebugger type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | Switches debugging to the specified thread.
Public method | AttachToProcessAsync(Int32, CancellationToken) | Attaches debugger to the process.
Public method | AttachToProcessAsync(Int32, StartDebuggingOptions, CancellationToken) | Attaches debugger to the process.
Public method | Break | Causes the given process to pause its execution so that its current state can be analyzed.
Public method | ClearTemporaryGeneratedModules | Clears temporary generated modules on disk.
Public method | Continue | Continues given process to the next breakpoint or until process finishes.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnableBreakpoint | Enables or disables breakpoint at specified position.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentExceptionAsync | Evaluates current expression based on the current stack frame.
Public method | EvaluateExpressionAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionsAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | ExecuteCommandInDebuggerThread | Executes action in the UI thread.
Public method | ExecuteCommandInDebuggerThreadAndMarshalException | Executes action in the UI thread; in case action throws exception, it's handled in the UI thread as well.
Public method | GetExecutionPositionAsync | Finds out current ExecutionPosition based on the current stack frame.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetStackFramesAsync | Gets list of method calls that are currently on a stack.
Public method | GetThreadsAsync | Gets list of active threads.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVariablesInScopeAsync | Receives all local variables based on the current stack frame.
Public method | SetRunToPositionBreakpoint | Causes debugger to stop at the specified position.
Public method | StartDebugging | Starts executing the program from the entry point with default settings.
Public method | StartDebugging(StartDebuggingOptions) | Starts executing the program from the entry point with specified settings.
Public method | StepInto | Executes one statement of code; steps into the next function call, if possible.
Public method | StepOut | Executes one statement of code; steps out of the function currently being executed.
Public method | StepOver | Executes one statement of code; steps over the next function call.
Public method | StopDebuggingAsync | Stops executing the program.
Public method | SwitchToStackFrame | Switches debugging to the given stack frame.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrySetNextStatementAsync | Tries to set the execution point to the specified line of code.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ActivateThread Method

ScriptDebuggerActivateThread Method
Switches debugging to the specified thread.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateThread(
    int threadId
)
Public Sub ActivateThread (
    threadId As Integer
)
public:
virtual void ActivateThread(
    int threadId
) sealed
abstract ActivateThread :
        threadId : int -> unit
override ActivateThread :
        threadId : int -> unit

Parameters

threadId
Type: SystemInt32
Thread ID to be activated.

Implements

IScriptDebuggerBaseActivateThread(Int32)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.AttachToProcessAsync Method

ScriptDebuggerAttachToProcessAsync Method
Overload List
 | Name | Description
Public method | AttachToProcessAsync(Int32, CancellationToken) | Attaches debugger to the process.
Public method | AttachToProcessAsync(Int32, StartDebuggingOptions, CancellationToken) | Attaches debugger to the process.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.AttachToProcessAsync Method (Int32, CancellationToken)

ScriptDebuggerAttachToProcessAsync Method (Int32, CancellationToken)
Attaches debugger to the process.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task AttachToProcessAsync(
    int processId,
    CancellationToken cancellationToken = null
)
Public Function AttachToProcessAsync (
    processId As Integer,
    Optional cancellationToken As CancellationToken = Nothing
) As Task
public:
virtual Task^ AttachToProcessAsync(
    int processId,
    CancellationToken cancellationToken = nullptr
) sealed
abstract AttachToProcessAsync :
        processId : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task
override AttachToProcessAsync :
        processId : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

processId
Type: SystemInt32
Process ID to attach.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task

Implements

IScriptDebuggerAttachToProcessAsync(Int32, CancellationToken)
See Also

Reference

ScriptDebugger Class
AttachToProcessAsync Overload
Alternet.Scripter.Debugger Namespace


ScriptDebugger.AttachToProcessAsync Method (Int32, StartDebuggingOptions, CancellationToken)

ScriptDebuggerAttachToProcessAsync Method (Int32, StartDebuggingOptions, CancellationToken)
Attaches debugger to the process.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task AttachToProcessAsync(
    int processId,
    StartDebuggingOptions options,
    CancellationToken cancellationToken = null
)
Public Function AttachToProcessAsync (
    processId As Integer,
    options As StartDebuggingOptions,
    Optional cancellationToken As CancellationToken = Nothing
) As Task
public:
virtual Task^ AttachToProcessAsync(
    int processId,
    StartDebuggingOptions^ options,
    CancellationToken cancellationToken = nullptr
) sealed
abstract AttachToProcessAsync :
        processId : int *
        options : StartDebuggingOptions *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task
override AttachToProcessAsync :
        processId : int *
        options : StartDebuggingOptions *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

processId
Type: SystemInt32
Process ID to attach.
options
Type: Alternet.Scripter.DebuggerStartDebuggingOptions
Debugging options.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task

Implements

IScriptDebuggerAttachToProcessAsync(Int32, StartDebuggingOptions, CancellationToken)
See Also

Reference

ScriptDebugger Class
AttachToProcessAsync Overload
Alternet.Scripter.Debugger Namespace


ScriptDebugger.Break Method

ScriptDebuggerBreak Method
Causes the given process to pause its execution so that its current state can be analyzed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Break()
Public Sub Break
public:
virtual void Break() sealed
abstract Break : unit -> unit
override Break : unit -> unit

Implements

IScriptDebuggerBaseBreak
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ClearTemporaryGeneratedModules Method

ScriptDebuggerClearTemporaryGeneratedModules Method
Clears temporary generated modules on disk.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearTemporaryGeneratedModules()
Public Sub ClearTemporaryGeneratedModules
public:
virtual void ClearTemporaryGeneratedModules() sealed
abstract ClearTemporaryGeneratedModules : unit -> unit
override ClearTemporaryGeneratedModules : unit -> unit

Implements

IScriptDebuggerBaseClearTemporaryGeneratedModules
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.Continue Method

ScriptDebuggerContinue Method
Continues given process to the next breakpoint or until process finishes.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Continue()
Public Sub Continue
public:
virtual void Continue() sealed
abstract Continue : unit -> unit
override Continue : unit -> unit

Implements

IScriptDebuggerBaseContinue
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.Dispose Method

ScriptDebuggerDispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.EnableBreakpoint Method

ScriptDebuggerEnableBreakpoint Method
Enables or disables breakpoint at specified position.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableBreakpoint(
    string filePath,
    int lineNumber,
    bool enable
)
Public Sub EnableBreakpoint (
    filePath As String,
    lineNumber As Integer,
    enable As Boolean
)
public:
void EnableBreakpoint(
    String^ filePath,
    int lineNumber,
    bool enable
)
member EnableBreakpoint :
        filePath : string *
        lineNumber : int *
        enable : bool -> unit

Parameters

filePath
Type: SystemString
Name of file where breakpoint is set.
lineNumber
Type: SystemInt32
Index of line at which breakpoint is set.
enable
Type: SystemBoolean
New breakpoint's state.
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.EvaluateCurrentExceptionAsync Method

ScriptDebuggerEvaluateCurrentExceptionAsync Method
Evaluates current expression based on the current stack frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ExpressionEvaluationResult> EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = null
)
Public Function EvaluateCurrentExceptionAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExpressionEvaluationResult)
public:
virtual Task<ExpressionEvaluationResult^>^ EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateCurrentExceptionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>
override EvaluateCurrentExceptionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExpressionEvaluationResult

Implements

IScriptDebuggerBaseEvaluateCurrentExceptionAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.EvaluateExpressionAsync Method

ScriptDebuggerEvaluateExpressionAsync Method
Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ExpressionEvaluationResult> EvaluateExpressionAsync(
    ExpressionEvaluationRequest request,
    CancellationToken cancellationToken = null
)
Public Function EvaluateExpressionAsync (
    request As ExpressionEvaluationRequest,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExpressionEvaluationResult)
public:
virtual Task<ExpressionEvaluationResult^>^ EvaluateExpressionAsync(
    ExpressionEvaluationRequest^ request,
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateExpressionAsync :
        request : ExpressionEvaluationRequest *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>
override EvaluateExpressionAsync :
        request : ExpressionEvaluationRequest *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>

Parameters

request
Type: Alternet.Scripter.DebuggerExpressionEvaluationRequest
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExpressionEvaluationResult

Implements

IScriptDebuggerBaseEvaluateExpressionAsync(ExpressionEvaluationRequest, CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.EvaluateExpressionsAsync Method

ScriptDebuggerEvaluateExpressionsAsync Method
Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<IEnumerable<ExpressionEvaluationResult>> EvaluateExpressionsAsync(
    IEnumerable<ExpressionEvaluationRequest> requests,
    CancellationToken cancellationToken = null
)
Public Function EvaluateExpressionsAsync (
    requests As IEnumerable(Of ExpressionEvaluationRequest),
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of IEnumerable(Of ExpressionEvaluationResult))
public:
virtual Task<IEnumerable<ExpressionEvaluationResult^>^>^ EvaluateExpressionsAsync(
    IEnumerable<ExpressionEvaluationRequest^>^ requests,
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateExpressionsAsync :
        requests : IEnumerable<ExpressionEvaluationRequest> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<IEnumerable<ExpressionEvaluationResult>>
override EvaluateExpressionsAsync :
        requests : IEnumerable<ExpressionEvaluationRequest> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<IEnumerable<ExpressionEvaluationResult>>

Parameters

requests
Type: System.Collections.GenericIEnumerableExpressionEvaluationRequest
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskIEnumerableExpressionEvaluationResult

Implements

IScriptDebuggerBaseEvaluateExpressionsAsync(IEnumerableExpressionEvaluationRequest, CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ExecuteCommandInDebuggerThread Method

ScriptDebuggerExecuteCommandInDebuggerThread Method
Executes action in the UI thread.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task ExecuteCommandInDebuggerThread(
    Action action
)
Public Function ExecuteCommandInDebuggerThread (
    action As Action
) As Task
public:
virtual Task^ ExecuteCommandInDebuggerThread(
    Action^ action
) sealed
abstract ExecuteCommandInDebuggerThread :
        action : Action -> Task
override ExecuteCommandInDebuggerThread :
        action : Action -> Task

Parameters

action
Type: SystemAction
Action to be executed.

Return Value

Type: Task
Task containing result of execution.
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ExecuteCommandInDebuggerThreadAndMarshalException Method

ScriptDebuggerExecuteCommandInDebuggerThreadAndMarshalException Method
Executes action in the UI thread; in case action throws exception, it's handled in the UI thread as well.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task ExecuteCommandInDebuggerThreadAndMarshalException(
    Action action
)
Public Function ExecuteCommandInDebuggerThreadAndMarshalException (
    action As Action
) As Task
public:
virtual Task^ ExecuteCommandInDebuggerThreadAndMarshalException(
    Action^ action
) sealed
abstract ExecuteCommandInDebuggerThreadAndMarshalException :
        action : Action -> Task
override ExecuteCommandInDebuggerThreadAndMarshalException :
        action : Action -> Task

Parameters

action
Type: SystemAction
Action to be executed.

Return Value

Type: Task
Task containing result of execution.
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.GetExecutionPositionAsync Method

ScriptDebuggerGetExecutionPositionAsync Method
Finds out current ExecutionPosition based on the current stack frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ExecutionPosition> GetExecutionPositionAsync(
    CancellationToken cancellationToken = null
)
Public Function GetExecutionPositionAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExecutionPosition)
public:
virtual Task<ExecutionPosition^>^ GetExecutionPositionAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetExecutionPositionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExecutionPosition>
override GetExecutionPositionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExecutionPosition>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExecutionPosition
Position of execution.

Implements

IScriptDebuggerBaseGetExecutionPositionAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.GetStackFramesAsync Method

ScriptDebuggerGetStackFramesAsync Method
Gets list of method calls that are currently on a stack.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<StackFramesRetrievalResult> GetStackFramesAsync(
    CancellationToken cancellationToken = null
)
Public Function GetStackFramesAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of StackFramesRetrievalResult)
public:
virtual Task<StackFramesRetrievalResult^>^ GetStackFramesAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetStackFramesAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<StackFramesRetrievalResult>
override GetStackFramesAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<StackFramesRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskStackFramesRetrievalResult

Implements

IScriptDebuggerBaseGetStackFramesAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.GetThreadsAsync Method

ScriptDebuggerGetThreadsAsync Method
Gets list of active threads.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ThreadsRetrievalResult> GetThreadsAsync(
    CancellationToken cancellationToken = null
)
Public Function GetThreadsAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ThreadsRetrievalResult)
public:
virtual Task<ThreadsRetrievalResult^>^ GetThreadsAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetThreadsAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ThreadsRetrievalResult>
override GetThreadsAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ThreadsRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskThreadsRetrievalResult

Implements

IScriptDebuggerBaseGetThreadsAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.GetVariablesInScopeAsync Method

ScriptDebuggerGetVariablesInScopeAsync Method
Receives all local variables based on the current stack frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<VariablesRetrievalResult> GetVariablesInScopeAsync(
    CancellationToken cancellationToken = null
)
Public Function GetVariablesInScopeAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of VariablesRetrievalResult)
public:
virtual Task<VariablesRetrievalResult^>^ GetVariablesInScopeAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetVariablesInScopeAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<VariablesRetrievalResult>
override GetVariablesInScopeAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<VariablesRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskVariablesRetrievalResult

Implements

IScriptDebuggerBaseGetVariablesInScopeAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.SetRunToPositionBreakpoint Method

ScriptDebuggerSetRunToPositionBreakpoint Method
Causes debugger to stop at the specified position.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRunToPositionBreakpoint(
    RunToPositionBreakpoint breakpoint
)
Public Sub SetRunToPositionBreakpoint (
    breakpoint As RunToPositionBreakpoint
)
public:
virtual void SetRunToPositionBreakpoint(
    RunToPositionBreakpoint^ breakpoint
) sealed
abstract SetRunToPositionBreakpoint :
        breakpoint : RunToPositionBreakpoint -> unit
override SetRunToPositionBreakpoint :
        breakpoint : RunToPositionBreakpoint -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerRunToPositionBreakpoint
Position in the source file.

Implements

IScriptDebuggerBaseSetRunToPositionBreakpoint(RunToPositionBreakpoint)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.StartDebugging Method

ScriptDebuggerStartDebugging Method
Overload List
 | Name | Description
Public method | StartDebugging | Starts executing the program from the entry point with default settings.
Public method | StartDebugging(StartDebuggingOptions) | Starts executing the program from the entry point with specified settings.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.StartDebugging Method

ScriptDebuggerStartDebugging Method
Starts executing the program from the entry point with default settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartDebugging()
Public Sub StartDebugging
public:
virtual void StartDebugging() sealed
abstract StartDebugging : unit -> unit
override StartDebugging : unit -> unit

Implements

IScriptDebuggerBaseStartDebugging
See Also

Reference

ScriptDebugger Class
StartDebugging Overload
Alternet.Scripter.Debugger Namespace


ScriptDebugger.StartDebugging Method (StartDebuggingOptions)

ScriptDebuggerStartDebugging Method (StartDebuggingOptions)
Starts executing the program from the entry point with specified settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartDebugging(
    StartDebuggingOptions options
)
Public Sub StartDebugging (
    options As StartDebuggingOptions
)
public:
virtual void StartDebugging(
    StartDebuggingOptions^ options
) sealed
abstract StartDebugging :
        options : StartDebuggingOptions -> unit
override StartDebugging :
        options : StartDebuggingOptions -> unit

Parameters

options
Type: Alternet.Scripter.DebuggerStartDebuggingOptions
Debugging options.

Implements

IScriptDebuggerBaseStartDebugging(StartDebuggingOptions)
See Also

Reference

ScriptDebugger Class
StartDebugging Overload
Alternet.Scripter.Debugger Namespace


ScriptDebugger.StepInto Method

ScriptDebuggerStepInto Method
Executes one statement of code; steps into the next function call, if possible.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StepInto()
Public Sub StepInto
public:
virtual void StepInto() sealed
abstract StepInto : unit -> unit
override StepInto : unit -> unit

Implements

IScriptDebuggerBaseStepInto
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.StepOut Method

ScriptDebuggerStepOut Method
Executes one statement of code; steps out of the function currently being executed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StepOut()
Public Sub StepOut
public:
virtual void StepOut() sealed
abstract StepOut : unit -> unit
override StepOut : unit -> unit

Implements

IScriptDebuggerBaseStepOut
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.StepOver Method

ScriptDebuggerStepOver Method
Executes one statement of code; steps over the next function call.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StepOver()
Public Sub StepOver
public:
virtual void StepOver() sealed
abstract StepOver : unit -> unit
override StepOver : unit -> unit

Implements

IScriptDebuggerBaseStepOver
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.StopDebuggingAsync Method

ScriptDebuggerStopDebuggingAsync Method
Stops executing the program.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task StopDebuggingAsync(
    CancellationToken cancellationToken = null
)
Public Function StopDebuggingAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
public:
virtual Task^ StopDebuggingAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract StopDebuggingAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task
override StopDebuggingAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task

Implements

IScriptDebuggerBaseStopDebuggingAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.SwitchToStackFrame Method

ScriptDebuggerSwitchToStackFrame Method
Switches debugging to the given stack frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SwitchToStackFrame(
    StackFrame frame
)
Public Sub SwitchToStackFrame (
    frame As StackFrame
)
public:
virtual void SwitchToStackFrame(
    StackFrame^ frame
) sealed
abstract SwitchToStackFrame :
        frame : StackFrame -> unit
override SwitchToStackFrame :
        frame : StackFrame -> unit

Parameters

frame
Type: Alternet.Scripter.DebuggerStackFrame
StackFrame to be switched to.

Implements

IScriptDebuggerBaseSwitchToStackFrame(StackFrame)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.TrySetNextStatementAsync Method

ScriptDebuggerTrySetNextStatementAsync Method
Tries to set the execution point to the specified line of code.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<Result> TrySetNextStatementAsync(
    int lineNumber,
    CancellationToken cancellationToken = null
)
Public Function TrySetNextStatementAsync (
    lineNumber As Integer,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Result)
public:
virtual Task<Result^>^ TrySetNextStatementAsync(
    int lineNumber,
    CancellationToken cancellationToken = nullptr
) sealed
abstract TrySetNextStatementAsync :
        lineNumber : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Result>
override TrySetNextStatementAsync :
        lineNumber : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Result>

Parameters

lineNumber
Type: SystemInt32
Line number to be going to.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskResult
Result of executing.

Implements

IScriptDebuggerBaseTrySetNextStatementAsync(Int32, CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger Properties

ScriptDebugger Properties

The ScriptDebugger type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Returns collection of debugger breakpoints.
Public property | Capabilities | Gets debugger capabilities.
Public property | EventsSyncAction | Gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)
Public property | ExpressionEvaluator | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | GeneratedModulesPath | Gets directory where assemblies for the scripts being debugged are located.
Public property | IsStarted | Indicates whether debugging was started.
Public property | MyCodeModules | Gets or sets collection of module names to be debugged.
Public property | ScopeResolutionService | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | ScriptRun | Contains all information required to compile and run the script.
Public property | State | Gets current debugger state.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.Breakpoints Property

ScriptDebuggerBreakpoints Property
Returns collection of debugger breakpoints.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptBreakpoints Breakpoints { get; }
Public ReadOnly Property Breakpoints As IScriptBreakpoints
    Get
public:
virtual property IScriptBreakpoints^ Breakpoints {
    IScriptBreakpoints^ get () sealed;
}
abstract Breakpoints : IScriptBreakpoints with get
override Breakpoints : IScriptBreakpoints with get

Property Value

Type: IScriptBreakpoints

Implements

IScriptDebuggerBaseBreakpoints
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.Capabilities Property

ScriptDebuggerCapabilities Property
Gets debugger capabilities.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerCapabilities Capabilities { get; }
Public ReadOnly Property Capabilities As DebuggerCapabilities
    Get
public:
virtual property DebuggerCapabilities Capabilities {
    DebuggerCapabilities get () sealed;
}
abstract Capabilities : DebuggerCapabilities with get
override Capabilities : DebuggerCapabilities with get

Property Value

Type: DebuggerCapabilities

Implements

IScriptDebuggerBaseCapabilities
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.EventsSyncAction Property

ScriptDebuggerEventsSyncAction Property
Gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action<Delegate> EventsSyncAction { get; set; }
Public Property EventsSyncAction As Action(Of Delegate)
    Get
    Set
public:
virtual property Action<Delegate^>^ EventsSyncAction {
    Action<Delegate^>^ get () sealed;
    void set (Action<Delegate^>^ value) sealed;
}
abstract EventsSyncAction : Action<Delegate> with get, set
override EventsSyncAction : Action<Delegate> with get, set

Property Value

Type: ActionDelegate

Implements

IScriptDebuggerBaseEventsSyncAction
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ExpressionEvaluator Property

ScriptDebuggerExpressionEvaluator Property
Gets IExpressionEvaluator object used to evaluate expressions.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IExpressionEvaluator ExpressionEvaluator { get; }
Public ReadOnly Property ExpressionEvaluator As IExpressionEvaluator
    Get
public:
virtual property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get () sealed;
}
abstract ExpressionEvaluator : IExpressionEvaluator with get
override ExpressionEvaluator : IExpressionEvaluator with get

Property Value

Type: IExpressionEvaluator

Implements

IScriptDebuggerBaseExpressionEvaluator
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.GeneratedModulesPath Property

ScriptDebuggerGeneratedModulesPath Property
Gets directory where assemblies for the scripts being debugged are located.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GeneratedModulesPath { get; set; }
Public Property GeneratedModulesPath As String
    Get
    Set
public:
virtual property String^ GeneratedModulesPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract GeneratedModulesPath : string with get, set
override GeneratedModulesPath : string with get, set

Property Value

Type: String

Implements

IScriptDebuggerGeneratedModulesPath
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.IsStarted Property

ScriptDebuggerIsStarted Property
Indicates whether debugging was started.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStarted { get; }
Public ReadOnly Property IsStarted As Boolean
    Get
public:
virtual property bool IsStarted {
    bool get () sealed;
}
abstract IsStarted : bool with get
override IsStarted : bool with get

Property Value

Type: Boolean

Implements

IScriptDebuggerBaseIsStarted
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.MyCodeModules Property

ScriptDebuggerMyCodeModules Property
Gets or sets collection of module names to be debugged.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MyCodeModules { get; set; }
Public Property MyCodeModules As String()
    Get
    Set
public:
virtual property array<String^>^ MyCodeModules {
    array<String^>^ get () sealed;
    void set (array<String^>^ value) sealed;
}
abstract MyCodeModules : string[] with get, set
override MyCodeModules : string[] with get, set

Property Value

Type: String

Implements

IScriptDebuggerMyCodeModules
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ScopeResolutionService Property

ScriptDebuggerScopeResolutionService Property
Gets IExpressionEvaluator object used to evaluate expressions.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScopeResolutionService ScopeResolutionService { get; }
Public ReadOnly Property ScopeResolutionService As IScopeResolutionService
    Get
public:
virtual property IScopeResolutionService^ ScopeResolutionService {
    IScopeResolutionService^ get () sealed;
}
abstract ScopeResolutionService : IScopeResolutionService with get
override ScopeResolutionService : IScopeResolutionService with get

Property Value

Type: IScopeResolutionService

Implements

IScriptDebuggerBaseScopeResolutionService
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ScriptRun Property

ScriptDebuggerScriptRun Property
Contains all information required to compile and run the script.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptRun ScriptRun { get; set; }
Public Property ScriptRun As IScriptRun
    Get
    Set
public:
virtual property IScriptRun^ ScriptRun {
    IScriptRun^ get () sealed;
    void set (IScriptRun^ value) sealed;
}
abstract ScriptRun : IScriptRun with get, set
override ScriptRun : IScriptRun with get, set

Property Value

Type: IScriptRun

Implements

IScriptDebuggerScriptRun
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.State Property

ScriptDebuggerState Property
Gets current debugger state.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerState State { get; }
Public ReadOnly Property State As DebuggerState
    Get
public:
virtual property DebuggerState State {
    DebuggerState get () sealed;
}
abstract State : DebuggerState with get
override State : DebuggerState with get

Property Value

Type: DebuggerState

Implements

IScriptDebuggerBaseState
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger Events

ScriptDebugger Events

The ScriptDebugger type exposes the following members.

Events
 | Name | Description
Public event | ActiveThreadChanged | Occurs when thread to be debugged changes.
Public event | BeforeContinue | Occurs before debugger continues to program execution.
Public event | BeforeStep | Occurs before debugger performs a step.
Public event | BeforeStop | Occurs before debugger stop debugging.
Public event | DebuggerErrorOccured | Occurs when encounters error during debugging session.
Public event | DebuggingStarted | Occurs when debugging session is started.
Public event | DebuggingStopped | Occurs when debugging session is stopped.
Public event | ExecutionResumed | Occurs when debugging is resumed after being paused.
Public event | ExecutionStopped | Occurs when debugging is paused.
Public event | LogMessageReceived | Occurs when debug message is received.
Public event | StackFrameSwitched | Occurs debugger switches to the stack frame.
Public event | StateChanged | Occurs when debugger state is changed.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ActiveThreadChanged Event

ScriptDebuggerActiveThreadChanged Event
Occurs when thread to be debugged changes.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ActiveThreadChangedEventArgs> ActiveThreadChanged
Public Event ActiveThreadChanged As EventHandler(Of ActiveThreadChangedEventArgs)
public:
virtual  event EventHandler<ActiveThreadChangedEventArgs^>^ ActiveThreadChanged {
    void add (EventHandler<ActiveThreadChangedEventArgs^>^ value);
    void remove (EventHandler<ActiveThreadChangedEventArgs^>^ value);
}
abstract ActiveThreadChanged : IEvent<EventHandler<ActiveThreadChangedEventArgs>,
    ActiveThreadChangedEventArgs>
override ActiveThreadChanged : IEvent<EventHandler<ActiveThreadChangedEventArgs>,
    ActiveThreadChangedEventArgs>

Value

Type: SystemEventHandlerActiveThreadChangedEventArgs

Implements

IScriptDebuggerBaseActiveThreadChanged
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.BeforeContinue Event

ScriptDebuggerBeforeContinue Event
Occurs before debugger continues to program execution.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BeforeContinue
Public Event BeforeContinue As EventHandler
public:
virtual  event EventHandler^ BeforeContinue {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeContinue : IEvent<EventHandler,
    EventArgs>
override BeforeContinue : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptDebuggerBaseBeforeContinue
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.BeforeStep Event

ScriptDebuggerBeforeStep Event
Occurs before debugger performs a step.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BeforeStep
Public Event BeforeStep As EventHandler
public:
virtual  event EventHandler^ BeforeStep {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeStep : IEvent<EventHandler,
    EventArgs>
override BeforeStep : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptDebuggerBaseBeforeStep
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.BeforeStop Event

ScriptDebuggerBeforeStop Event
Occurs before debugger stop debugging.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BeforeStop
Public Event BeforeStop As EventHandler
public:
virtual  event EventHandler^ BeforeStop {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeStop : IEvent<EventHandler,
    EventArgs>
override BeforeStop : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptDebuggerBaseBeforeStop
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.DebuggerErrorOccured Event

ScriptDebuggerDebuggerErrorOccured Event
Occurs when encounters error during debugging session.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggerErrorOccuredEventArgs> DebuggerErrorOccured
Public Event DebuggerErrorOccured As EventHandler(Of DebuggerErrorOccuredEventArgs)
public:
virtual  event EventHandler<DebuggerErrorOccuredEventArgs^>^ DebuggerErrorOccured {
    void add (EventHandler<DebuggerErrorOccuredEventArgs^>^ value);
    void remove (EventHandler<DebuggerErrorOccuredEventArgs^>^ value);
}
abstract DebuggerErrorOccured : IEvent<EventHandler<DebuggerErrorOccuredEventArgs>,
    DebuggerErrorOccuredEventArgs>
override DebuggerErrorOccured : IEvent<EventHandler<DebuggerErrorOccuredEventArgs>,
    DebuggerErrorOccuredEventArgs>

Value

Type: SystemEventHandlerDebuggerErrorOccuredEventArgs

Implements

IScriptDebuggerBaseDebuggerErrorOccured
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.DebuggingStarted Event

ScriptDebuggerDebuggingStarted Event
Occurs when debugging session is started.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggingStartedEventArgs> DebuggingStarted
Public Event DebuggingStarted As EventHandler(Of DebuggingStartedEventArgs)
public:
virtual  event EventHandler<DebuggingStartedEventArgs^>^ DebuggingStarted {
    void add (EventHandler<DebuggingStartedEventArgs^>^ value);
    void remove (EventHandler<DebuggingStartedEventArgs^>^ value);
}
abstract DebuggingStarted : IEvent<EventHandler<DebuggingStartedEventArgs>,
    DebuggingStartedEventArgs>
override DebuggingStarted : IEvent<EventHandler<DebuggingStartedEventArgs>,
    DebuggingStartedEventArgs>

Value

Type: SystemEventHandlerDebuggingStartedEventArgs

Implements

IScriptDebuggerBaseDebuggingStarted
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.DebuggingStopped Event

ScriptDebuggerDebuggingStopped Event
Occurs when debugging session is stopped.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggingStoppedEventArgs> DebuggingStopped
Public Event DebuggingStopped As EventHandler(Of DebuggingStoppedEventArgs)
public:
virtual  event EventHandler<DebuggingStoppedEventArgs^>^ DebuggingStopped {
    void add (EventHandler<DebuggingStoppedEventArgs^>^ value);
    void remove (EventHandler<DebuggingStoppedEventArgs^>^ value);
}
abstract DebuggingStopped : IEvent<EventHandler<DebuggingStoppedEventArgs>,
    DebuggingStoppedEventArgs>
override DebuggingStopped : IEvent<EventHandler<DebuggingStoppedEventArgs>,
    DebuggingStoppedEventArgs>

Value

Type: SystemEventHandlerDebuggingStoppedEventArgs

Implements

IScriptDebuggerBaseDebuggingStopped
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ExecutionResumed Event

ScriptDebuggerExecutionResumed Event
Occurs when debugging is resumed after being paused.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ExecutionResumedEventArgs> ExecutionResumed
Public Event ExecutionResumed As EventHandler(Of ExecutionResumedEventArgs)
public:
virtual  event EventHandler<ExecutionResumedEventArgs^>^ ExecutionResumed {
    void add (EventHandler<ExecutionResumedEventArgs^>^ value);
    void remove (EventHandler<ExecutionResumedEventArgs^>^ value);
}
abstract ExecutionResumed : IEvent<EventHandler<ExecutionResumedEventArgs>,
    ExecutionResumedEventArgs>
override ExecutionResumed : IEvent<EventHandler<ExecutionResumedEventArgs>,
    ExecutionResumedEventArgs>

Value

Type: SystemEventHandlerExecutionResumedEventArgs

Implements

IScriptDebuggerBaseExecutionResumed
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.ExecutionStopped Event

ScriptDebuggerExecutionStopped Event
Occurs when debugging is paused.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ExecutionStoppedEventArgs> ExecutionStopped
Public Event ExecutionStopped As EventHandler(Of ExecutionStoppedEventArgs)
public:
virtual  event EventHandler<ExecutionStoppedEventArgs^>^ ExecutionStopped {
    void add (EventHandler<ExecutionStoppedEventArgs^>^ value);
    void remove (EventHandler<ExecutionStoppedEventArgs^>^ value);
}
abstract ExecutionStopped : IEvent<EventHandler<ExecutionStoppedEventArgs>,
    ExecutionStoppedEventArgs>
override ExecutionStopped : IEvent<EventHandler<ExecutionStoppedEventArgs>,
    ExecutionStoppedEventArgs>

Value

Type: SystemEventHandlerExecutionStoppedEventArgs

Implements

IScriptDebuggerBaseExecutionStopped
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.LogMessageReceived Event

ScriptDebuggerLogMessageReceived Event
Occurs when debug message is received.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<LogMessageReceivedEventArgs> LogMessageReceived
Public Event LogMessageReceived As EventHandler(Of LogMessageReceivedEventArgs)
public:
virtual  event EventHandler<LogMessageReceivedEventArgs^>^ LogMessageReceived {
    void add (EventHandler<LogMessageReceivedEventArgs^>^ value);
    void remove (EventHandler<LogMessageReceivedEventArgs^>^ value);
}
abstract LogMessageReceived : IEvent<EventHandler<LogMessageReceivedEventArgs>,
    LogMessageReceivedEventArgs>
override LogMessageReceived : IEvent<EventHandler<LogMessageReceivedEventArgs>,
    LogMessageReceivedEventArgs>

Value

Type: SystemEventHandlerLogMessageReceivedEventArgs

Implements

IScriptDebuggerBaseLogMessageReceived
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.StackFrameSwitched Event

ScriptDebuggerStackFrameSwitched Event
Occurs debugger switches to the stack frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<StackFrameSwitchedEventArgs> StackFrameSwitched
Public Event StackFrameSwitched As EventHandler(Of StackFrameSwitchedEventArgs)
public:
virtual  event EventHandler<StackFrameSwitchedEventArgs^>^ StackFrameSwitched {
    void add (EventHandler<StackFrameSwitchedEventArgs^>^ value);
    void remove (EventHandler<StackFrameSwitchedEventArgs^>^ value);
}
abstract StackFrameSwitched : IEvent<EventHandler<StackFrameSwitchedEventArgs>,
    StackFrameSwitchedEventArgs>
override StackFrameSwitched : IEvent<EventHandler<StackFrameSwitchedEventArgs>,
    StackFrameSwitchedEventArgs>

Value

Type: SystemEventHandlerStackFrameSwitchedEventArgs

Implements

IScriptDebuggerBaseStackFrameSwitched
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptDebugger.StateChanged Event

ScriptDebuggerStateChanged Event
Occurs when debugger state is changed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggerStateChangedEventArgs> StateChanged
Public Event StateChanged As EventHandler(Of DebuggerStateChangedEventArgs)
public:
virtual  event EventHandler<DebuggerStateChangedEventArgs^>^ StateChanged {
    void add (EventHandler<DebuggerStateChangedEventArgs^>^ value);
    void remove (EventHandler<DebuggerStateChangedEventArgs^>^ value);
}
abstract StateChanged : IEvent<EventHandler<DebuggerStateChangedEventArgs>,
    DebuggerStateChangedEventArgs>
override StateChanged : IEvent<EventHandler<DebuggerStateChangedEventArgs>,
    DebuggerStateChangedEventArgs>

Value

Type: SystemEventHandlerDebuggerStateChangedEventArgs

Implements

IScriptDebuggerBaseStateChanged
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger Namespace


ScriptFilePathService Class

ScriptFilePathService Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerScriptFilePathService

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ScriptFilePathService
Public NotInheritable Class ScriptFilePathService
public ref class ScriptFilePathService abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ScriptFilePathService =  class end

The ScriptFilePathService type exposes the following members.

Methods
Name | Description
GetRelativeFilePath |
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ScriptFilePathService Methods

ScriptFilePathService Methods

The ScriptFilePathService type exposes the following members.

Methods
Name | Description
GetRelativeFilePath |
Top
See Also

Reference

ScriptFilePathService Class
Alternet.Scripter.Debugger Namespace


ScriptFilePathService.GetRelativeFilePath Method

ScriptFilePathServiceGetRelativeFilePath Method

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Common.v7 (in Alternet.Scripter.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetRelativeFilePath(
    IScriptSourceBase scriptSource,
    string fileName
)
Public Shared Function GetRelativeFilePath (
    scriptSource As IScriptSourceBase,
    fileName As String
) As String
public:
static String^ GetRelativeFilePath(
    IScriptSourceBase^ scriptSource,
    String^ fileName
)
static member GetRelativeFilePath :
        scriptSource : IScriptSourceBase *
        fileName : string -> string

Parameters

scriptSource
Type: Alternet.ScripterIScriptSourceBase
fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

ScriptFilePathService Class
Alternet.Scripter.Debugger Namespace


StackFrame Class

StackFrame Class
Represents information describes particular stack frame.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerStackFrame

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StackFrame
Public Class StackFrame
public ref class StackFrame
type StackFrame =  class end

The StackFrame type exposes the following members.

Constructors
 | Name | Description
Public method | StackFrame | Initializes a new instance of the StackFrame class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | File | Gets or sets stack frame file.
Public property | Index | Gets or sets stack frame index.
Public property | IsManaged | Gets or sets a boolean value indicating whether stack frame is managed.
Public property | IsMyCode | Gets or sets a boolean value indicating whether stack frame is inside executing script.
Public property | IsTop | Gets or sets a boolean value indicating whether stack frame is current frame.
Public property | Line | Gets or sets stack frame line.
Public property | Name | Gets or sets stack frame name.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


StackFrame Constructor

StackFrame Constructor
Initializes a new instance of the StackFrame class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StackFrame()
Public Sub New
public:
StackFrame()
new : unit -> StackFrame
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFrame Methods

StackFrame Methods

The StackFrame type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFrame Properties

StackFrame Properties

The StackFrame type exposes the following members.

Properties
 | Name | Description
Public property | File | Gets or sets stack frame file.
Public property | Index | Gets or sets stack frame index.
Public property | IsManaged | Gets or sets a boolean value indicating whether stack frame is managed.
Public property | IsMyCode | Gets or sets a boolean value indicating whether stack frame is inside executing script.
Public property | IsTop | Gets or sets a boolean value indicating whether stack frame is current frame.
Public property | Line | Gets or sets stack frame line.
Public property | Name | Gets or sets stack frame name.
Top
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFrame.File Property

StackFrameFile Property
Gets or sets stack frame file.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string File { get; set; }
Public Property File As String
    Get
    Set
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
member File : string with get, set

Property Value

Type: String
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFrame.Index Property

StackFrameIndex Property
Gets or sets stack frame index.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFrame.IsManaged Property

StackFrameIsManaged Property
Gets or sets a boolean value indicating whether stack frame is managed.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsManaged { get; set; }
Public Property IsManaged As Boolean
    Get
    Set
public:
property bool IsManaged {
    bool get ();
    void set (bool value);
}
member IsManaged : bool with get, set

Property Value

Type: Boolean
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFrame.IsMyCode Property

StackFrameIsMyCode Property
Gets or sets a boolean value indicating whether stack frame is inside executing script.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMyCode { get; set; }
Public Property IsMyCode As Boolean
    Get
    Set
public:
property bool IsMyCode {
    bool get ();
    void set (bool value);
}
member IsMyCode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFrame.IsTop Property

StackFrameIsTop Property
Gets or sets a boolean value indicating whether stack frame is current frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTop { get; set; }
Public Property IsTop As Boolean
    Get
    Set
public:
property bool IsTop {
    bool get ();
    void set (bool value);
}
member IsTop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFrame.Line Property

StackFrameLine Property
Gets or sets stack frame line.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Line { get; set; }
Public Property Line As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Line {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Line : Nullable<int> with get, set

Property Value

Type: NullableInt32
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFrame.Name Property

StackFrameName Property
Gets or sets stack frame name.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

StackFrame Class
Alternet.Scripter.Debugger Namespace


StackFramesRetrievalResult Class

StackFramesRetrievalResult Class
Provides data for method calls that are currently on a stack.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerStackFramesRetrievalResult

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StackFramesRetrievalResult : EventArgs
Public Class StackFramesRetrievalResult
    Inherits EventArgs
public ref class StackFramesRetrievalResult : public EventArgs
type StackFramesRetrievalResult =
    class
        inherit EventArgs
    end

The StackFramesRetrievalResult type exposes the following members.

Constructors
 | Name | Description
Public method | StackFramesRetrievalResult | Initializes a new instance of the StackFramesRetrievalResult class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Frames | Gets or sets list of stack frames.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


StackFramesRetrievalResult Constructor

StackFramesRetrievalResult Constructor
Initializes a new instance of the StackFramesRetrievalResult class with default settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StackFramesRetrievalResult()
Public Sub New
public:
StackFramesRetrievalResult()
new : unit -> StackFramesRetrievalResult
See Also

Reference

StackFramesRetrievalResult Class
Alternet.Scripter.Debugger Namespace


StackFramesRetrievalResult Methods

StackFramesRetrievalResult Methods

The StackFramesRetrievalResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StackFramesRetrievalResult Class
Alternet.Scripter.Debugger Namespace


StackFramesRetrievalResult Properties

StackFramesRetrievalResult Properties

The StackFramesRetrievalResult type exposes the following members.

Properties
 | Name | Description
Public property | Frames | Gets or sets list of stack frames.
Top
See Also

Reference

StackFramesRetrievalResult Class
Alternet.Scripter.Debugger Namespace


StackFramesRetrievalResult.Frames Property

StackFramesRetrievalResultFrames Property
Gets or sets list of stack frames.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StackFrame[] Frames { get; set; }
Public Property Frames As StackFrame()
    Get
    Set
public:
property array<StackFrame^>^ Frames {
    array<StackFrame^>^ get ();
    void set (array<StackFrame^>^ value);
}
member Frames : StackFrame[] with get, set

Property Value

Type: StackFrame
See Also

Reference

StackFramesRetrievalResult Class
Alternet.Scripter.Debugger Namespace


StackFrameSwitchedEventArgs Class

StackFrameSwitchedEventArgs Class
Provides data for the IScriptDebugger.StackFrameSwitched event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerStackFrameSwitchedEventArgs

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StackFrameSwitchedEventArgs : EventArgs
Public Class StackFrameSwitchedEventArgs
    Inherits EventArgs
public ref class StackFrameSwitchedEventArgs : public EventArgs
type StackFrameSwitchedEventArgs =
    class
        inherit EventArgs
    end

The StackFrameSwitchedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StackFrameSwitchedEventArgs | Initializes a new instance of the StackFrameSwitchedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorMessage | Gets or sets an error message. Non empty if some error occurred while switching frame.
Public property | Frame | Gets or sets a stack frame to switch to.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


StackFrameSwitchedEventArgs Constructor

StackFrameSwitchedEventArgs Constructor
Initializes a new instance of the StackFrameSwitchedEventArgs class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StackFrameSwitchedEventArgs()
Public Sub New
public:
StackFrameSwitchedEventArgs()
new : unit -> StackFrameSwitchedEventArgs
See Also

Reference

StackFrameSwitchedEventArgs Class
Alternet.Scripter.Debugger Namespace


StackFrameSwitchedEventArgs Methods

StackFrameSwitchedEventArgs Methods

The StackFrameSwitchedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StackFrameSwitchedEventArgs Class
Alternet.Scripter.Debugger Namespace


StackFrameSwitchedEventArgs Properties

StackFrameSwitchedEventArgs Properties

The StackFrameSwitchedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Gets or sets an error message. Non empty if some error occurred while switching frame.
Public property | Frame | Gets or sets a stack frame to switch to.
Top
See Also

Reference

StackFrameSwitchedEventArgs Class
Alternet.Scripter.Debugger Namespace


StackFrameSwitchedEventArgs.ErrorMessage Property

StackFrameSwitchedEventArgsErrorMessage Property
Gets or sets an error message. Non empty if some error occurred while switching frame.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
See Also

Reference

StackFrameSwitchedEventArgs Class
Alternet.Scripter.Debugger Namespace


StackFrameSwitchedEventArgs.Frame Property

StackFrameSwitchedEventArgsFrame Property
Gets or sets a stack frame to switch to.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StackFrame Frame { get; set; }
Public Property Frame As StackFrame
    Get
    Set
public:
property StackFrame^ Frame {
    StackFrame^ get ();
    void set (StackFrame^ value);
}
member Frame : StackFrame with get, set

Property Value

Type: StackFrame
See Also

Reference

StackFrameSwitchedEventArgs Class
Alternet.Scripter.Debugger Namespace


StartDebuggingOptions Class

StartDebuggingOptions Class
Defines debug process settings.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerStartDebuggingOptions

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StartDebuggingOptions
Public Class StartDebuggingOptions
public ref class StartDebuggingOptions
type StartDebuggingOptions =  class end

The StartDebuggingOptions type exposes the following members.

Constructors
 | Name | Description
Public method | StartDebuggingOptions | Initializes a new instance of the StartDebuggingOptions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets command line argument for debug process.
Public property | BreakOnStart | Gets or sets a boolean value indicating whether debugging should be paused immediately after start.
 | Default | Defines default debug process settings.
Public property | DisableJustMyCode | Gets or sets a boolean value indicating Just My Code is enabled. If true, MyCodeModules property has no effect.
Public property | HostApplication | Gets or sets host application for dll being debugged.
Public property | MyCodeModules | Gets or sets an array of full paths to modules treated as "My Code" for Just My Code debugging. If null, the main executable module is treated as "My Code".
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


StartDebuggingOptions Constructor

StartDebuggingOptions Constructor
Initializes a new instance of the StartDebuggingOptions class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StartDebuggingOptions()
Public Sub New
public:
StartDebuggingOptions()
new : unit -> StartDebuggingOptions
See Also

Reference

StartDebuggingOptions Class
Alternet.Scripter.Debugger Namespace


StartDebuggingOptions Methods

StartDebuggingOptions Methods

The StartDebuggingOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StartDebuggingOptions Class
Alternet.Scripter.Debugger Namespace


StartDebuggingOptions Properties

StartDebuggingOptions Properties

The StartDebuggingOptions type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets command line argument for debug process.
Public property | BreakOnStart | Gets or sets a boolean value indicating whether debugging should be paused immediately after start.
 | Default | Defines default debug process settings.
Public property | DisableJustMyCode | Gets or sets a boolean value indicating Just My Code is enabled. If true, MyCodeModules property has no effect.
Public property | HostApplication | Gets or sets host application for dll being debugged.
Public property | MyCodeModules | Gets or sets an array of full paths to modules treated as "My Code" for Just My Code debugging. If null, the main executable module is treated as "My Code".
Top
See Also

Reference

StartDebuggingOptions Class
Alternet.Scripter.Debugger Namespace


StartDebuggingOptions.Arguments Property

StartDebuggingOptionsArguments Property
Gets or sets command line argument for debug process.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Arguments { get; set; }
Public Property Arguments As String()
    Get
    Set
public:
property array<String^>^ Arguments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Arguments : string[] with get, set

Property Value

Type: String
See Also

Reference

StartDebuggingOptions Class
Alternet.Scripter.Debugger Namespace


StartDebuggingOptions.BreakOnStart Property

StartDebuggingOptionsBreakOnStart Property
Gets or sets a boolean value indicating whether debugging should be paused immediately after start.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BreakOnStart { get; set; }
Public Property BreakOnStart As Boolean
    Get
    Set
public:
property bool BreakOnStart {
    bool get ();
    void set (bool value);
}
member BreakOnStart : bool with get, set

Property Value

Type: Boolean
See Also

Reference

StartDebuggingOptions Class
Alternet.Scripter.Debugger Namespace


StartDebuggingOptions.Default Property

StartDebuggingOptionsDefault Property
Defines default debug process settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static StartDebuggingOptions Default { get; }
Public Shared ReadOnly Property Default As StartDebuggingOptions
    Get
public:
static property StartDebuggingOptions^ Default {
    StartDebuggingOptions^ get ();
}
static member Default : StartDebuggingOptions with get

Property Value

Type: StartDebuggingOptions
See Also

Reference

StartDebuggingOptions Class
Alternet.Scripter.Debugger Namespace


StartDebuggingOptions.DisableJustMyCode Property

StartDebuggingOptionsDisableJustMyCode Property
Gets or sets a boolean value indicating Just My Code is enabled. If true, MyCodeModules property has no effect.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DisableJustMyCode { get; set; }
Public Property DisableJustMyCode As Boolean
    Get
    Set
public:
property bool DisableJustMyCode {
    bool get ();
    void set (bool value);
}
member DisableJustMyCode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

StartDebuggingOptions Class
Alternet.Scripter.Debugger Namespace


StartDebuggingOptions.HostApplication Property

StartDebuggingOptionsHostApplication Property
Gets or sets host application for dll being debugged.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string HostApplication { get; set; }
Public Property HostApplication As String
    Get
    Set
public:
property String^ HostApplication {
    String^ get ();
    void set (String^ value);
}
member HostApplication : string with get, set

Property Value

Type: String
See Also

Reference

StartDebuggingOptions Class
Alternet.Scripter.Debugger Namespace


StartDebuggingOptions.MyCodeModules Property

StartDebuggingOptionsMyCodeModules Property
Gets or sets an array of full paths to modules treated as "My Code" for Just My Code debugging. If null, the main executable module is treated as "My Code".

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MyCodeModules { get; set; }
Public Property MyCodeModules As String()
    Get
    Set
public:
property array<String^>^ MyCodeModules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MyCodeModules : string[] with get, set

Property Value

Type: String
See Also

Reference

StartDebuggingOptions Class
Alternet.Scripter.Debugger Namespace


ThreadInfo Class

ThreadInfo Class
Provides data for the ThreadClick event.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerThreadInfo

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ThreadInfo
Public Class ThreadInfo
public ref class ThreadInfo
type ThreadInfo =  class end

The ThreadInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ThreadInfo | Initializes a new instance of the ThreadInfo class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | File | Gets or sets file name of execution position associated with the thread.
Public property | HasNoManagedFrames | Gets or sets a value indicating whether the thread has unmanaged frames.
Public property | IsActive | Gets or sets a value indicating whether the thread in the active state.
Public property | Line | Gets or sets line of the execution position associated with the thread.
Public property | ThreadId | Gets or sets thread's ID.
Public property | Title | Gets or sets title associated with the thread.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ThreadInfo Constructor

ThreadInfo Constructor
Initializes a new instance of the ThreadInfo class

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadInfo()
Public Sub New
public:
ThreadInfo()
new : unit -> ThreadInfo
See Also

Reference

ThreadInfo Class
Alternet.Scripter.Debugger Namespace


ThreadInfo Methods

ThreadInfo Methods

The ThreadInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThreadInfo Class
Alternet.Scripter.Debugger Namespace


ThreadInfo Properties

ThreadInfo Properties

The ThreadInfo type exposes the following members.

Properties
 | Name | Description
Public property | File | Gets or sets file name of execution position associated with the thread.
Public property | HasNoManagedFrames | Gets or sets a value indicating whether the thread has unmanaged frames.
Public property | IsActive | Gets or sets a value indicating whether the thread in the active state.
Public property | Line | Gets or sets line of the execution position associated with the thread.
Public property | ThreadId | Gets or sets thread's ID.
Public property | Title | Gets or sets title associated with the thread.
Top
See Also

Reference

ThreadInfo Class
Alternet.Scripter.Debugger Namespace


ThreadInfo.File Property

ThreadInfoFile Property
Gets or sets file name of execution position associated with the thread.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string File { get; set; }
Public Property File As String
    Get
    Set
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
member File : string with get, set

Property Value

Type: String
See Also

Reference

ThreadInfo Class
Alternet.Scripter.Debugger Namespace


ThreadInfo.HasNoManagedFrames Property

ThreadInfoHasNoManagedFrames Property
Gets or sets a value indicating whether the thread has unmanaged frames.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasNoManagedFrames { get; set; }
Public Property HasNoManagedFrames As Boolean
    Get
    Set
public:
property bool HasNoManagedFrames {
    bool get ();
    void set (bool value);
}
member HasNoManagedFrames : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ThreadInfo Class
Alternet.Scripter.Debugger Namespace


ThreadInfo.IsActive Property

ThreadInfoIsActive Property
Gets or sets a value indicating whether the thread in the active state.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsActive { get; set; }
Public Property IsActive As Boolean
    Get
    Set
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
member IsActive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ThreadInfo Class
Alternet.Scripter.Debugger Namespace


ThreadInfo.Line Property

ThreadInfoLine Property
Gets or sets line of the execution position associated with the thread.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Line { get; set; }
Public Property Line As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Line {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Line : Nullable<int> with get, set

Property Value

Type: NullableInt32
See Also

Reference

ThreadInfo Class
Alternet.Scripter.Debugger Namespace


ThreadInfo.ThreadId Property

ThreadInfoThreadId Property
Gets or sets thread's ID.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ThreadId { get; set; }
Public Property ThreadId As Integer
    Get
    Set
public:
property int ThreadId {
    int get ();
    void set (int value);
}
member ThreadId : int with get, set

Property Value

Type: Int32
See Also

Reference

ThreadInfo Class
Alternet.Scripter.Debugger Namespace


ThreadInfo.Title Property

ThreadInfoTitle Property
Gets or sets title associated with the thread.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

ThreadInfo Class
Alternet.Scripter.Debugger Namespace


ThreadsRetrievalResult Class

ThreadsRetrievalResult Class
Provides data for list of active threads.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.DebuggerThreadsRetrievalResult

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ThreadsRetrievalResult : EventArgs
Public Class ThreadsRetrievalResult
    Inherits EventArgs
public ref class ThreadsRetrievalResult : public EventArgs
type ThreadsRetrievalResult =
    class
        inherit EventArgs
    end

The ThreadsRetrievalResult type exposes the following members.

Constructors
 | Name | Description
Public method | ThreadsRetrievalResult | Initializes a new instance of the ThreadsRetrievalResult class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Threads | Gets or sets list of active threads
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


ThreadsRetrievalResult Constructor

ThreadsRetrievalResult Constructor
Initializes a new instance of the ThreadsRetrievalResult class with default settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadsRetrievalResult()
Public Sub New
public:
ThreadsRetrievalResult()
new : unit -> ThreadsRetrievalResult
See Also

Reference

ThreadsRetrievalResult Class
Alternet.Scripter.Debugger Namespace


ThreadsRetrievalResult Methods

ThreadsRetrievalResult Methods

The ThreadsRetrievalResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThreadsRetrievalResult Class
Alternet.Scripter.Debugger Namespace


ThreadsRetrievalResult Properties

ThreadsRetrievalResult Properties

The ThreadsRetrievalResult type exposes the following members.

Properties
 | Name | Description
Public property | Threads | Gets or sets list of active threads
Top
See Also

Reference

ThreadsRetrievalResult Class
Alternet.Scripter.Debugger Namespace


ThreadsRetrievalResult.Threads Property

ThreadsRetrievalResultThreads Property
Gets or sets list of active threads

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadInfo[] Threads { get; set; }
Public Property Threads As ThreadInfo()
    Get
    Set
public:
property array<ThreadInfo^>^ Threads {
    array<ThreadInfo^>^ get ();
    void set (array<ThreadInfo^>^ value);
}
member Threads : ThreadInfo[] with get, set

Property Value

Type: ThreadInfo
See Also

Reference

ThreadsRetrievalResult Class
Alternet.Scripter.Debugger Namespace


VariablesRetrievalResult Class

VariablesRetrievalResult Class
Provides data for list of variable names.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerVariablesRetrievalResult

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VariablesRetrievalResult
Public Class VariablesRetrievalResult
public ref class VariablesRetrievalResult
type VariablesRetrievalResult =  class end

The VariablesRetrievalResult type exposes the following members.

Constructors
 | Name | Description
Public method | VariablesRetrievalResult | Initializes a new instance of the VariablesRetrievalResult class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | VariableNames | Gets or sets list of variable names.
Top
See Also

Reference

Alternet.Scripter.Debugger Namespace


VariablesRetrievalResult Constructor

VariablesRetrievalResult Constructor
Initializes a new instance of the VariablesRetrievalResult class with default settings.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VariablesRetrievalResult()
Public Sub New
public:
VariablesRetrievalResult()
new : unit -> VariablesRetrievalResult
See Also

Reference

VariablesRetrievalResult Class
Alternet.Scripter.Debugger Namespace


VariablesRetrievalResult Methods

VariablesRetrievalResult Methods

The VariablesRetrievalResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VariablesRetrievalResult Class
Alternet.Scripter.Debugger Namespace


VariablesRetrievalResult Properties

VariablesRetrievalResult Properties

The VariablesRetrievalResult type exposes the following members.

Properties
 | Name | Description
Public property | VariableNames | Gets or sets list of variable names.
Top
See Also

Reference

VariablesRetrievalResult Class
Alternet.Scripter.Debugger Namespace


VariablesRetrievalResult.VariableNames Property

VariablesRetrievalResultVariableNames Property
Gets or sets list of variable names.

Namespace: Alternet.Scripter.Debugger
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] VariableNames { get; set; }
Public Property VariableNames As String()
    Get
    Set
public:
property array<String^>^ VariableNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VariableNames : string[] with get, set

Property Value

Type: String
See Also

Reference

VariablesRetrievalResult Class
Alternet.Scripter.Debugger Namespace


Alternet.Scripter.Debugger.ExpressionEvaluation Namespace

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace
Classes
 | Class | Description
Public class | DebuggerValue |
Public class | ErrorEvaluationResult | Provides data for result of unsuccessful evaluation.
Public class | EvaluatedMemberMetadata | Provides evaluation metadata.
Public class | EvaluationProvider | See https://docs.microsoft.com/en-us/visualstudio/debugger/format-specifiers-in-csharp
Public class | EvaluationProviderFactory |
Public class | EvaluationResult | Provides a base class defines results of evaluation. This class is abstract.
Public class | GroupEvaluationResult | Provides data for result of group evaluation.
Public class | GroupEvaluationResultTags | Contains default string constants related to group evaluation results.
Public class | MemberEvaluationService |
Public class | ValueEvaluationResult | Provides data for result of successful evaluation.
Interfaces
 | Interface | Description
Public interface | IEvaluationProviderSite |
Public interface | IExpressionEvaluator | Provides methods and properties that allow developers to evaluate expressions while debugging applications in the common language runtime (CLR) environment.
Public interface | IMemberAccessExpressionBuilder |
Enumerations
 | Enumeration | Description
Public enumeration | EvaluatedMemberAttributes |
Public enumeration | EvaluatedMemberKind | Specifies the possible kinds of evaluated members.
Public enumeration | EvaluatedMemberVisibility | Specifies the possible accessibility levels of evaluation result.
Public enumeration | EvaluationOptions |


DebuggerValue Class

DebuggerValue Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationDebuggerValue
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluationObjectValue

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class DebuggerValue
Public MustInherit Class DebuggerValue
public ref class DebuggerValue abstract
[<AbstractClassAttribute>]
type DebuggerValue =  class end

The DebuggerValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsArrayType |
Public property | Name |
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


DebuggerValue Methods

DebuggerValue Methods

The DebuggerValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggerValue Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


DebuggerValue Properties

DebuggerValue Properties

The DebuggerValue type exposes the following members.

Properties
 | Name | Description
Public property | IsArrayType |
Public property | Name |
Top
See Also

Reference

DebuggerValue Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


DebuggerValue.IsArrayType Property

DebuggerValueIsArrayType Property

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract bool IsArrayType { get; }
Public MustOverride ReadOnly Property IsArrayType As Boolean
    Get
public:
virtual property bool IsArrayType {
    bool get () abstract;
}
abstract IsArrayType : bool with get

Property Value

Type: Boolean
See Also

Reference

DebuggerValue Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


DebuggerValue.Name Property

DebuggerValueName Property

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract string Name { get; }
Public MustOverride ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () abstract;
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

DebuggerValue Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ErrorEvaluationResult Class

ErrorEvaluationResult Class
Provides data for result of unsuccessful evaluation.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
Alternet.Scripter.Debugger.ExpressionEvaluationErrorEvaluationResult

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ErrorEvaluationResult : EvaluationResult
Public Class ErrorEvaluationResult
    Inherits EvaluationResult
public ref class ErrorEvaluationResult : public EvaluationResult
type ErrorEvaluationResult =
    class
        inherit EvaluationResult
    end

The ErrorEvaluationResult type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorEvaluationResult | Initializes a new instance of ErrorEvaluationResult with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorMessage | Represents string describes error of evaluation.
Public property | Expression | Represents evaluated expression. (Inherited from EvaluationResult.)
Public property | Name | Represents name of the result. (Inherited from EvaluationResult.)
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ErrorEvaluationResult Constructor

ErrorEvaluationResult Constructor
Initializes a new instance of ErrorEvaluationResult with specified settings.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ErrorEvaluationResult(
    string expression,
    string name,
    string errorMessage
)
Public Sub New (
    expression As String,
    name As String,
    errorMessage As String
)
public:
ErrorEvaluationResult(
    String^ expression,
    String^ name,
    String^ errorMessage
)
new :
        expression : string *
        name : string *
        errorMessage : string -> ErrorEvaluationResult

Parameters

expression
Type: SystemString
Evaluated expression.
name
Type: SystemString
Name of the result.
errorMessage
Type: SystemString
String describes error of evaluation.
See Also

Reference

ErrorEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ErrorEvaluationResult Methods

ErrorEvaluationResult Methods

The ErrorEvaluationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ErrorEvaluationResult Properties

ErrorEvaluationResult Properties

The ErrorEvaluationResult type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Represents string describes error of evaluation.
Public property | Expression | Represents evaluated expression. (Inherited from EvaluationResult.)
Public property | Name | Represents name of the result. (Inherited from EvaluationResult.)
Top
See Also

Reference

ErrorEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ErrorEvaluationResult.ErrorMessage Property

ErrorEvaluationResultErrorMessage Property
Represents string describes error of evaluation.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
public:
property String^ ErrorMessage {
    String^ get ();
}
member ErrorMessage : string with get

Property Value

Type: String
See Also

Reference

ErrorEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberAttributes Enumeration

EvaluatedMemberAttributes Enumeration

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum EvaluatedMemberAttributes
<FlagsAttribute>
Public Enumeration EvaluatedMemberAttributes
[FlagsAttribute]
public enum class EvaluatedMemberAttributes
[<FlagsAttribute>]
type EvaluatedMemberAttributes
Members
Member name | Value | Description
Instance | 1 |
Static | 2 |
PublicAndProtected | 4 |
PrivateAndInternal | 8 |
All | 15 |
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberKind Enumeration

EvaluatedMemberKind Enumeration
Specifies the possible kinds of evaluated members.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EvaluatedMemberKind
Public Enumeration EvaluatedMemberKind
public enum class EvaluatedMemberKind
type EvaluatedMemberKind
Members
Member name | Value | Description
Unknown | 0 | Member is unknown.
Property | 1 | Member is a property.
Field | 2 | Member is a field.
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberMetadata Class

EvaluatedMemberMetadata Class
Provides evaluation metadata.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberMetadata

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EvaluatedMemberMetadata
Public Class EvaluatedMemberMetadata
public ref class EvaluatedMemberMetadata
type EvaluatedMemberMetadata =  class end

The EvaluatedMemberMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | EvaluatedMemberMetadata | Initializes a new instance of EvaluatedMemberMetadata with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsStatic | Represents boolean value indicating whether evaluation result is static.
Public property | MemberKind | Represents kind of the evaluation result.
Public property | TypeFullName | Represents fully qualified name of result type.
Public property | Visibility | Represents accessibility level of the evaluation result.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberMetadata Constructor

EvaluatedMemberMetadata Constructor
Initializes a new instance of EvaluatedMemberMetadata with specified settings.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluatedMemberMetadata(
    string typeFullName,
    EvaluatedMemberKind kind,
    EvaluatedMemberVisibility visibility,
    bool isStatic
)
Public Sub New (
    typeFullName As String,
    kind As EvaluatedMemberKind,
    visibility As EvaluatedMemberVisibility,
    isStatic As Boolean
)
public:
EvaluatedMemberMetadata(
    String^ typeFullName,
    EvaluatedMemberKind kind,
    EvaluatedMemberVisibility visibility,
    bool isStatic
)
new :
        typeFullName : string *
        kind : EvaluatedMemberKind *
        visibility : EvaluatedMemberVisibility *
        isStatic : bool -> EvaluatedMemberMetadata

Parameters

typeFullName
Type: SystemString
Fully qualified name of result type.
kind
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberKind
Kind of the evaluation result.
visibility
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberVisibility
Accessibility level of the evaluation result.
isStatic
Type: SystemBoolean
Indicates whether evaluation result is static.
See Also

Reference

EvaluatedMemberMetadata Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberMetadata Methods

EvaluatedMemberMetadata Methods

The EvaluatedMemberMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EvaluatedMemberMetadata Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberMetadata Properties

EvaluatedMemberMetadata Properties

The EvaluatedMemberMetadata type exposes the following members.

Properties
 | Name | Description
Public property | IsStatic | Represents boolean value indicating whether evaluation result is static.
Public property | MemberKind | Represents kind of the evaluation result.
Public property | TypeFullName | Represents fully qualified name of result type.
Public property | Visibility | Represents accessibility level of the evaluation result.
Top
See Also

Reference

EvaluatedMemberMetadata Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberMetadata.IsStatic Property

EvaluatedMemberMetadataIsStatic Property
Represents boolean value indicating whether evaluation result is static.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
property bool IsStatic {
    bool get ();
}
member IsStatic : bool with get

Property Value

Type: Boolean
See Also

Reference

EvaluatedMemberMetadata Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberMetadata.MemberKind Property

EvaluatedMemberMetadataMemberKind Property
Represents kind of the evaluation result.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluatedMemberKind MemberKind { get; }
Public ReadOnly Property MemberKind As EvaluatedMemberKind
    Get
public:
property EvaluatedMemberKind MemberKind {
    EvaluatedMemberKind get ();
}
member MemberKind : EvaluatedMemberKind with get

Property Value

Type: EvaluatedMemberKind
See Also

Reference

EvaluatedMemberMetadata Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberMetadata.TypeFullName Property

EvaluatedMemberMetadataTypeFullName Property
Represents fully qualified name of result type.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TypeFullName { get; }
Public ReadOnly Property TypeFullName As String
    Get
public:
property String^ TypeFullName {
    String^ get ();
}
member TypeFullName : string with get

Property Value

Type: String
See Also

Reference

EvaluatedMemberMetadata Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberMetadata.Visibility Property

EvaluatedMemberMetadataVisibility Property
Represents accessibility level of the evaluation result.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluatedMemberVisibility Visibility { get; }
Public ReadOnly Property Visibility As EvaluatedMemberVisibility
    Get
public:
property EvaluatedMemberVisibility Visibility {
    EvaluatedMemberVisibility get ();
}
member Visibility : EvaluatedMemberVisibility with get

Property Value

Type: EvaluatedMemberVisibility
See Also

Reference

EvaluatedMemberMetadata Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluatedMemberVisibility Enumeration

EvaluatedMemberVisibility Enumeration
Specifies the possible accessibility levels of evaluation result.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EvaluatedMemberVisibility
Public Enumeration EvaluatedMemberVisibility
public enum class EvaluatedMemberVisibility
type EvaluatedMemberVisibility
Members
Member name | Value | Description
Unknown | 0 | Access level is undefined.
Public | 1 | Access is not restricted.
Protected | 2 | Access is limited to the containing class or types derived from the containing class.
Internal | 3 | Access is limited to the current assembly.
Private | 4 | Access is limited to the containing type.
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationOptions Enumeration

EvaluationOptions Enumeration

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum EvaluationOptions
<FlagsAttribute>
Public Enumeration EvaluationOptions
[FlagsAttribute]
public enum class EvaluationOptions
[<FlagsAttribute>]
type EvaluationOptions
Members
Member name | Value | Description
None | 0 |
LegacyAllMembersMode | 1 |
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationProvider Class

EvaluationProvider Class
See https://docs.microsoft.com/en-us/visualstudio/debugger/format-specifiers-in-csharp
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationProvider

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class EvaluationProvider
Public MustInherit Class EvaluationProvider
public ref class EvaluationProvider abstract
[<AbstractClassAttribute>]
type EvaluationProvider =  class end

The EvaluationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate |
Public method | EvaluateChildren |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationProvider Methods

EvaluationProvider Methods

The EvaluationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate |
Public method | EvaluateChildren |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EvaluationProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationProvider.Evaluate Method

EvaluationProviderEvaluate Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual EvaluationResult Evaluate(
    string expression
)
Public Overridable Function Evaluate (
    expression As String
) As EvaluationResult
public:
virtual EvaluationResult^ Evaluate(
    String^ expression
)
abstract Evaluate :
        expression : string -> EvaluationResult
override Evaluate :
        expression : string -> EvaluationResult

Parameters

expression
Type: SystemString

Return Value

Type: EvaluationResult
See Also

Reference

EvaluationProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationProvider.EvaluateChildren Method

EvaluationProviderEvaluateChildren Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract IEnumerable<EvaluationResult> EvaluateChildren(
    string expression
)
Public MustOverride Function EvaluateChildren (
    expression As String
) As IEnumerable(Of EvaluationResult)
public:
virtual IEnumerable<EvaluationResult^>^ EvaluateChildren(
    String^ expression
) abstract
abstract EvaluateChildren :
        expression : string -> IEnumerable<EvaluationResult>

Parameters

expression
Type: SystemString

Return Value

Type: IEnumerableEvaluationResult
See Also

Reference

EvaluationProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationProviderFactory Class

EvaluationProviderFactory Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationProviderFactory

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EvaluationProviderFactory
Public Class EvaluationProviderFactory
public ref class EvaluationProviderFactory
type EvaluationProviderFactory =  class end

The EvaluationProviderFactory type exposes the following members.

Constructors
 | Name | Description
Public method | EvaluationProviderFactory | Initializes a new instance of the EvaluationProviderFactory class
Top
Methods
 | Name | Description
Public method | CreateProvider |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationProviderFactory Constructor

EvaluationProviderFactory Constructor
Initializes a new instance of the EvaluationProviderFactory class

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluationProviderFactory(
    IEvaluationProviderSite site
)
Public Sub New (
    site As IEvaluationProviderSite
)
public:
EvaluationProviderFactory(
    IEvaluationProviderSite^ site
)
new :
        site : IEvaluationProviderSite -> EvaluationProviderFactory

Parameters

site
Type: Alternet.Scripter.Debugger.ExpressionEvaluationIEvaluationProviderSite
See Also

Reference

EvaluationProviderFactory Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationProviderFactory Methods

EvaluationProviderFactory Methods

The EvaluationProviderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateProvider |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EvaluationProviderFactory Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationProviderFactory.CreateProvider Method

EvaluationProviderFactoryCreateProvider Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluationProvider CreateProvider(
    string expression,
    EvaluationOptions options
)
Public Function CreateProvider (
    expression As String,
    options As EvaluationOptions
) As EvaluationProvider
public:
EvaluationProvider^ CreateProvider(
    String^ expression,
    EvaluationOptions options
)
member CreateProvider :
        expression : string *
        options : EvaluationOptions -> EvaluationProvider

Parameters

expression
Type: SystemString
options
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationOptions

Return Value

Type: EvaluationProvider
See Also

Reference

EvaluationProviderFactory Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationResult Class

EvaluationResult Class
Provides a base class defines results of evaluation. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
Alternet.Scripter.Debugger.ExpressionEvaluationErrorEvaluationResult
Alternet.Scripter.Debugger.ExpressionEvaluationGroupEvaluationResult
Alternet.Scripter.Debugger.ExpressionEvaluationValueEvaluationResult

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class EvaluationResult
Public MustInherit Class EvaluationResult
public ref class EvaluationResult abstract
[<AbstractClassAttribute>]
type EvaluationResult =  class end

The EvaluationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Expression | Represents evaluated expression.
Public property | Name | Represents name of the result.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationResult Methods

EvaluationResult Methods

The EvaluationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationResult Properties

EvaluationResult Properties

The EvaluationResult type exposes the following members.

Properties
 | Name | Description
Public property | Expression | Represents evaluated expression.
Public property | Name | Represents name of the result.
Top
See Also

Reference

EvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationResult.Expression Property

EvaluationResultExpression Property
Represents evaluated expression.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; }
Public ReadOnly Property Expression As String
    Get
public:
property String^ Expression {
    String^ get ();
}
member Expression : string with get

Property Value

Type: String
See Also

Reference

EvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


EvaluationResult.Name Property

EvaluationResultName Property
Represents name of the result.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

EvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResult Class

GroupEvaluationResult Class
Provides data for result of group evaluation.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
Alternet.Scripter.Debugger.ExpressionEvaluationGroupEvaluationResult

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GroupEvaluationResult : EvaluationResult
Public Class GroupEvaluationResult
    Inherits EvaluationResult
public ref class GroupEvaluationResult : public EvaluationResult
type GroupEvaluationResult =
    class
        inherit EvaluationResult
    end

The GroupEvaluationResult type exposes the following members.

Constructors
 | Name | Description
Public method | GroupEvaluationResult | Initializes a new instance of GroupEvaluationResult with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | Represents evaluation description.
Public property | Expression | Represents evaluated expression. (Inherited from EvaluationResult.)
Public property | Name | Represents name of the result. (Inherited from EvaluationResult.)
Public property | Tag | Represents evaluation tag.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResult Constructor

GroupEvaluationResult Constructor
Initializes a new instance of GroupEvaluationResult with specified settings.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public GroupEvaluationResult(
    string expression,
    string name,
    string description,
    string tag
)
Public Sub New (
    expression As String,
    name As String,
    description As String,
    tag As String
)
public:
GroupEvaluationResult(
    String^ expression,
    String^ name,
    String^ description,
    String^ tag
)
new :
        expression : string *
        name : string *
        description : string *
        tag : string -> GroupEvaluationResult

Parameters

expression
Type: SystemString
Evaluated expression.
name
Type: SystemString
Name of the result.
description
Type: SystemString
Description of the result.
tag
Type: SystemString
Tag of the result.
See Also

Reference

GroupEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResult Methods

GroupEvaluationResult Methods

The GroupEvaluationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GroupEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResult Properties

GroupEvaluationResult Properties

The GroupEvaluationResult type exposes the following members.

Properties
 | Name | Description
Public property | Description | Represents evaluation description.
Public property | Expression | Represents evaluated expression. (Inherited from EvaluationResult.)
Public property | Name | Represents name of the result. (Inherited from EvaluationResult.)
Public property | Tag | Represents evaluation tag.
Top
See Also

Reference

GroupEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResult.Description Property

GroupEvaluationResultDescription Property
Represents evaluation description.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

GroupEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResult.Tag Property

GroupEvaluationResultTag Property
Represents evaluation tag.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Tag { get; }
Public ReadOnly Property Tag As String
    Get
public:
property String^ Tag {
    String^ get ();
}
member Tag : string with get

Property Value

Type: String
See Also

Reference

GroupEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResultTags Class

GroupEvaluationResultTags Class
Contains default string constants related to group evaluation results.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationGroupEvaluationResultTags

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GroupEvaluationResultTags
Public NotInheritable Class GroupEvaluationResultTags
public ref class GroupEvaluationResultTags abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GroupEvaluationResultTags =  class end

The GroupEvaluationResultTags type exposes the following members.

Fields
Name | Description
NonPublicMembers |
RawView |
ResultsView |
StaticMembers |
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResultTags Fields

GroupEvaluationResultTags Fields

The GroupEvaluationResultTags type exposes the following members.

Fields
Name | Description
NonPublicMembers |
RawView |
ResultsView |
StaticMembers |
Top
See Also

Reference

GroupEvaluationResultTags Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResultTags.NonPublicMembers Field

GroupEvaluationResultTagsNonPublicMembers Field

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string NonPublicMembers
Public Const NonPublicMembers As String
public:
literal String^ NonPublicMembers
static val mutable NonPublicMembers: string

Field Value

Type: String
See Also

Reference

GroupEvaluationResultTags Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResultTags.RawView Field

GroupEvaluationResultTagsRawView Field

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string RawView
Public Const RawView As String
public:
literal String^ RawView
static val mutable RawView: string

Field Value

Type: String
See Also

Reference

GroupEvaluationResultTags Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResultTags.ResultsView Field

GroupEvaluationResultTagsResultsView Field

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ResultsView
Public Const ResultsView As String
public:
literal String^ ResultsView
static val mutable ResultsView: string

Field Value

Type: String
See Also

Reference

GroupEvaluationResultTags Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


GroupEvaluationResultTags.StaticMembers Field

GroupEvaluationResultTagsStaticMembers Field

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string StaticMembers
Public Const StaticMembers As String
public:
literal String^ StaticMembers
static val mutable StaticMembers: string

Field Value

Type: String
See Also

Reference

GroupEvaluationResultTags Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IEvaluationProviderSite Interface

IEvaluationProviderSite Interface

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IEvaluationProviderSite
Public Interface IEvaluationProviderSite
public interface class IEvaluationProviderSite
type IEvaluationProviderSite =  interface end

The IEvaluationProviderSite type exposes the following members.

Methods
 | Name | Description
Public method | EnsureAssemblyLoadedToProcess |
Public method | EvaluateExpression |
Public method | EvaluateMembersOrArrayElements |
Public method | GetExpressionEvaluationResult |
Public method | GetObjectCreationExpression |
Public method | GetValueType |
Public method | HasMembers |
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IEvaluationProviderSite Methods

IEvaluationProviderSite Methods

The IEvaluationProviderSite type exposes the following members.

Methods
 | Name | Description
Public method | EnsureAssemblyLoadedToProcess |
Public method | EvaluateExpression |
Public method | EvaluateMembersOrArrayElements |
Public method | GetExpressionEvaluationResult |
Public method | GetObjectCreationExpression |
Public method | GetValueType |
Public method | HasMembers |
Top
See Also

Reference

IEvaluationProviderSite Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IEvaluationProviderSite.EnsureAssemblyLoadedToProcess Method

IEvaluationProviderSiteEnsureAssemblyLoadedToProcess Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void EnsureAssemblyLoadedToProcess(
    AssemblyName assemblyName
)
Sub EnsureAssemblyLoadedToProcess (
    assemblyName As AssemblyName
)
void EnsureAssemblyLoadedToProcess(
    AssemblyName^ assemblyName
)
abstract EnsureAssemblyLoadedToProcess :
        assemblyName : AssemblyName -> unit

Parameters

assemblyName
Type: System.ReflectionAssemblyName
See Also

Reference

IEvaluationProviderSite Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IEvaluationProviderSite.EvaluateExpression Method

IEvaluationProviderSiteEvaluateExpression Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Result<DebuggerValue> EvaluateExpression(
    string expression
)
Function EvaluateExpression (
    expression As String
) As Result(Of DebuggerValue)
Result<DebuggerValue^>^ EvaluateExpression(
    String^ expression
)
abstract EvaluateExpression :
        expression : string -> Result<DebuggerValue>

Parameters

expression
Type: SystemString

Return Value

Type: Result DebuggerValue
See Also

Reference

IEvaluationProviderSite Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IEvaluationProviderSite.EvaluateMembersOrArrayElements Method

IEvaluationProviderSiteEvaluateMembersOrArrayElements Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<EvaluationResult> EvaluateMembersOrArrayElements(
    string expression,
    DebuggerValue value,
    EvaluatedMemberAttributes allowedAttributes,
    Func<FieldInfo, bool> fieldPredicate = null,
    Func<MethodInfo, bool> methodPredicate = null
)
Function EvaluateMembersOrArrayElements (
    expression As String,
    value As DebuggerValue,
    allowedAttributes As EvaluatedMemberAttributes,
    Optional fieldPredicate As Func(Of FieldInfo, Boolean) = Nothing,
    Optional methodPredicate As Func(Of MethodInfo, Boolean) = Nothing
) As IEnumerable(Of EvaluationResult)
IEnumerable<EvaluationResult^>^ EvaluateMembersOrArrayElements(
    String^ expression,
    DebuggerValue^ value,
    EvaluatedMemberAttributes allowedAttributes,
    Func<FieldInfo^, bool>^ fieldPredicate = nullptr,
    Func<MethodInfo^, bool>^ methodPredicate = nullptr
)
abstract EvaluateMembersOrArrayElements :
        expression : string *
        value : DebuggerValue *
        allowedAttributes : EvaluatedMemberAttributes *
        ?fieldPredicate : Func<FieldInfo, bool> *
        ?methodPredicate : Func<MethodInfo, bool>
(* Defaults:
        let _fieldPredicate = defaultArg fieldPredicate null
        let _methodPredicate = defaultArg methodPredicate null
*)
-> IEnumerable<EvaluationResult>

Parameters

expression
Type: SystemString
value
Type: Alternet.Scripter.Debugger.ExpressionEvaluationDebuggerValue
allowedAttributes
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberAttributes
fieldPredicate (Optional)
Type: SystemFuncFieldInfo, Boolean
methodPredicate (Optional)
Type: SystemFuncMethodInfo, Boolean

Return Value

Type: IEnumerableEvaluationResult
See Also

Reference

IEvaluationProviderSite Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IEvaluationProviderSite.GetExpressionEvaluationResult Method

IEvaluationProviderSiteGetExpressionEvaluationResult Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
EvaluationResult GetExpressionEvaluationResult(
    string expression,
    Result<DebuggerValue> mv
)
Function GetExpressionEvaluationResult (
    expression As String,
    mv As Result(Of DebuggerValue)
) As EvaluationResult
EvaluationResult^ GetExpressionEvaluationResult(
    String^ expression,
    Result<DebuggerValue^>^ mv
)
abstract GetExpressionEvaluationResult :
        expression : string *
        mv : Result<DebuggerValue> -> EvaluationResult

Parameters

expression
Type: SystemString
mv
Type: Alternet.CommonResult DebuggerValue

Return Value

Type: EvaluationResult
See Also

Reference

IEvaluationProviderSite Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IEvaluationProviderSite.GetObjectCreationExpression Method

IEvaluationProviderSiteGetObjectCreationExpression Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetObjectCreationExpression(
    string className,
    string parameterList
)
Function GetObjectCreationExpression (
    className As String,
    parameterList As String
) As String
String^ GetObjectCreationExpression(
    String^ className,
    String^ parameterList
)
abstract GetObjectCreationExpression :
        className : string *
        parameterList : string -> string

Parameters

className
Type: SystemString
parameterList
Type: SystemString

Return Value

Type: String
See Also

Reference

IEvaluationProviderSite Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IEvaluationProviderSite.GetValueType Method

IEvaluationProviderSiteGetValueType Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Type GetValueType(
    DebuggerValue value
)
Function GetValueType (
    value As DebuggerValue
) As Type
Type^ GetValueType(
    DebuggerValue^ value
)
abstract GetValueType :
        value : DebuggerValue -> Type

Parameters

value
Type: Alternet.Scripter.Debugger.ExpressionEvaluationDebuggerValue

Return Value

Type: Type
See Also

Reference

IEvaluationProviderSite Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IEvaluationProviderSite.HasMembers Method

IEvaluationProviderSiteHasMembers Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasMembers(
    DebuggerValue value,
    EvaluatedMemberAttributes allowedAttributes
)
Function HasMembers (
    value As DebuggerValue,
    allowedAttributes As EvaluatedMemberAttributes
) As Boolean
bool HasMembers(
    DebuggerValue^ value,
    EvaluatedMemberAttributes allowedAttributes
)
abstract HasMembers :
        value : DebuggerValue *
        allowedAttributes : EvaluatedMemberAttributes -> bool

Parameters

value
Type: Alternet.Scripter.Debugger.ExpressionEvaluationDebuggerValue
allowedAttributes
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberAttributes

Return Value

Type: Boolean
See Also

Reference

IEvaluationProviderSite Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IExpressionEvaluator Interface

IExpressionEvaluator Interface
Provides methods and properties that allow developers to evaluate expressions while debugging applications in the common language runtime (CLR) environment.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExpressionEvaluator
Public Interface IExpressionEvaluator
public interface class IExpressionEvaluator
type IExpressionEvaluator =  interface end

The IExpressionEvaluator type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateChildrenAsync | When implemented by a class, evaluates all children for specified expression.
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | GetCodeCompletionService | When implemented by a class, gets ICodeCompletionService object used to provide code completion for the expression evaluation.
Public method | SetExpressionValueAsync |
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IExpressionEvaluator Methods

IExpressionEvaluator Methods

The IExpressionEvaluator type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateChildrenAsync | When implemented by a class, evaluates all children for specified expression.
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | GetCodeCompletionService | When implemented by a class, gets ICodeCompletionService object used to provide code completion for the expression evaluation.
Public method | SetExpressionValueAsync |
Top
See Also

Reference

IExpressionEvaluator Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IExpressionEvaluator.EvaluateChildrenAsync Method

IExpressionEvaluatorEvaluateChildrenAsync Method
When implemented by a class, evaluates all children for specified expression.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<IEnumerable<EvaluationResult>> EvaluateChildrenAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Function EvaluateChildrenAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of IEnumerable(Of EvaluationResult))
Task<IEnumerable<EvaluationResult^>^>^ EvaluateChildrenAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateChildrenAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<IEnumerable<EvaluationResult>>

Parameters

expression
Type: SystemString
Expression which children should be evaluated.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Propagates notification that operations should be canceled.

Return Value

Type: TaskIEnumerableEvaluationResult
Result of evaluation.
See Also

Reference

IExpressionEvaluator Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IExpressionEvaluator.EvaluateCurrentExceptionAsync Method

IExpressionEvaluatorEvaluateCurrentExceptionAsync Method
When implemented by a class, evaluates current expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<EvaluationResult> EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = null
)
Function EvaluateCurrentExceptionAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of EvaluationResult)
Task<EvaluationResult^>^ EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateCurrentExceptionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<EvaluationResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Propagates notification that operations should be canceled.

Return Value

Type: TaskEvaluationResult
Result of evaluation.
See Also

Reference

IExpressionEvaluator Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IExpressionEvaluator.EvaluateExpressionAsync Method

IExpressionEvaluatorEvaluateExpressionAsync Method
When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<EvaluationResult> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of EvaluationResult)
Task<EvaluationResult^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<EvaluationResult>

Parameters

expression
Type: SystemString
Expression to evaluate.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Propagates notification that operations should be canceled.

Return Value

Type: TaskEvaluationResult
Result of evaluation.
See Also

Reference

IExpressionEvaluator Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IExpressionEvaluator.GetCodeCompletionService Method

IExpressionEvaluatorGetCodeCompletionService Method
When implemented by a class, gets ICodeCompletionService object used to provide code completion for the expression evaluation.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionService GetCodeCompletionService(
    ExecutionPosition position,
    KeyConfiguration keyConfiguration = null
)
Function GetCodeCompletionService (
    position As ExecutionPosition,
    Optional keyConfiguration As KeyConfiguration = Nothing
) As ICodeCompletionService
ICodeCompletionService^ GetCodeCompletionService(
    ExecutionPosition^ position,
    KeyConfiguration^ keyConfiguration = nullptr
)
abstract GetCodeCompletionService :
        position : ExecutionPosition *
        ?keyConfiguration : KeyConfiguration
(* Defaults:
        let _keyConfiguration = defaultArg keyConfiguration null
*)
-> ICodeCompletionService

Parameters

position
Type: Alternet.Scripter.DebuggerExecutionPosition
current execution position
keyConfiguration (Optional)
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionKeyConfiguration
key configuration

Return Value

Type: ICodeCompletionService
See Also

Reference

IExpressionEvaluator Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IExpressionEvaluator.SetExpressionValueAsync Method

IExpressionEvaluatorSetExpressionValueAsync Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<EvaluationResult> SetExpressionValueAsync(
    string leftSideExpression,
    string rightSideExpression,
    CancellationToken cancellationToken = null
)
Function SetExpressionValueAsync (
    leftSideExpression As String,
    rightSideExpression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of EvaluationResult)
Task<EvaluationResult^>^ SetExpressionValueAsync(
    String^ leftSideExpression,
    String^ rightSideExpression,
    CancellationToken cancellationToken = nullptr
)
abstract SetExpressionValueAsync :
        leftSideExpression : string *
        rightSideExpression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<EvaluationResult>

Parameters

leftSideExpression
Type: SystemString
rightSideExpression
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskEvaluationResult
See Also

Reference

IExpressionEvaluator Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IMemberAccessExpressionBuilder Interface

IMemberAccessExpressionBuilder Interface

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMemberAccessExpressionBuilder
Public Interface IMemberAccessExpressionBuilder
public interface class IMemberAccessExpressionBuilder
type IMemberAccessExpressionBuilder =  interface end

The IMemberAccessExpressionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | MakeArrayElementAccessExpression |
Public method | MakeMemberAccessExpression |
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IMemberAccessExpressionBuilder Methods

IMemberAccessExpressionBuilder Methods

The IMemberAccessExpressionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | MakeArrayElementAccessExpression |
Public method | MakeMemberAccessExpression |
Top
See Also

Reference

IMemberAccessExpressionBuilder Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IMemberAccessExpressionBuilder.MakeArrayElementAccessExpression Method

IMemberAccessExpressionBuilderMakeArrayElementAccessExpression Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string MakeArrayElementAccessExpression(
    string arrayExpression,
    int index
)
Function MakeArrayElementAccessExpression (
    arrayExpression As String,
    index As Integer
) As String
String^ MakeArrayElementAccessExpression(
    String^ arrayExpression,
    int index
)
abstract MakeArrayElementAccessExpression :
        arrayExpression : string *
        index : int -> string

Parameters

arrayExpression
Type: SystemString
index
Type: SystemInt32

Return Value

Type: String
See Also

Reference

IMemberAccessExpressionBuilder Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


IMemberAccessExpressionBuilder.MakeMemberAccessExpression Method

IMemberAccessExpressionBuilderMakeMemberAccessExpression Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string MakeMemberAccessExpression(
    string left,
    string right
)
Function MakeMemberAccessExpression (
    left As String,
    right As String
) As String
String^ MakeMemberAccessExpression(
    String^ left,
    String^ right
)
abstract MakeMemberAccessExpression :
        left : string *
        right : string -> string

Parameters

left
Type: SystemString
right
Type: SystemString

Return Value

Type: String
See Also

Reference

IMemberAccessExpressionBuilder Interface
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


MemberEvaluationService Class

MemberEvaluationService Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationMemberEvaluationService

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MemberEvaluationService
Public NotInheritable Class MemberEvaluationService
public ref class MemberEvaluationService abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MemberEvaluationService =  class end

The MemberEvaluationService type exposes the following members.

Methods
Name | Description
GetBindingFlagsForMemberAttributes |
GetFieldPredicateForMemberAttributes |
GetFieldVisibility |
GetMethodPredicateForMemberAttributes |
GetMethodVisibility |
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


MemberEvaluationService Methods

MemberEvaluationService Methods

The MemberEvaluationService type exposes the following members.

Methods
Name | Description
GetBindingFlagsForMemberAttributes |
GetFieldPredicateForMemberAttributes |
GetFieldVisibility |
GetMethodPredicateForMemberAttributes |
GetMethodVisibility |
Top
See Also

Reference

MemberEvaluationService Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


MemberEvaluationService.GetBindingFlagsForMemberAttributes Method

MemberEvaluationServiceGetBindingFlagsForMemberAttributes Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BindingFlags GetBindingFlagsForMemberAttributes(
    EvaluatedMemberAttributes attributes
)
Public Shared Function GetBindingFlagsForMemberAttributes (
    attributes As EvaluatedMemberAttributes
) As BindingFlags
public:
static BindingFlags GetBindingFlagsForMemberAttributes(
    EvaluatedMemberAttributes attributes
)
static member GetBindingFlagsForMemberAttributes :
        attributes : EvaluatedMemberAttributes -> BindingFlags

Parameters

attributes
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberAttributes

Return Value

Type: BindingFlags
See Also

Reference

MemberEvaluationService Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


MemberEvaluationService.GetFieldPredicateForMemberAttributes Method

MemberEvaluationServiceGetFieldPredicateForMemberAttributes Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Func<FieldInfo, bool> GetFieldPredicateForMemberAttributes(
    EvaluatedMemberAttributes attributes
)
Public Shared Function GetFieldPredicateForMemberAttributes (
    attributes As EvaluatedMemberAttributes
) As Func(Of FieldInfo, Boolean)
public:
static Func<FieldInfo^, bool>^ GetFieldPredicateForMemberAttributes(
    EvaluatedMemberAttributes attributes
)
static member GetFieldPredicateForMemberAttributes :
        attributes : EvaluatedMemberAttributes -> Func<FieldInfo, bool>

Parameters

attributes
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberAttributes

Return Value

Type: FuncFieldInfo, Boolean
See Also

Reference

MemberEvaluationService Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


MemberEvaluationService.GetFieldVisibility Method

MemberEvaluationServiceGetFieldVisibility Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static EvaluatedMemberVisibility GetFieldVisibility(
    FieldInfo field
)
Public Shared Function GetFieldVisibility (
    field As FieldInfo
) As EvaluatedMemberVisibility
public:
static EvaluatedMemberVisibility GetFieldVisibility(
    FieldInfo^ field
)
static member GetFieldVisibility :
        field : FieldInfo -> EvaluatedMemberVisibility

Parameters

field
Type: System.ReflectionFieldInfo

Return Value

Type: EvaluatedMemberVisibility
See Also

Reference

MemberEvaluationService Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


MemberEvaluationService.GetMethodPredicateForMemberAttributes Method

MemberEvaluationServiceGetMethodPredicateForMemberAttributes Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Func<MethodInfo, bool> GetMethodPredicateForMemberAttributes(
    EvaluatedMemberAttributes attributes
)
Public Shared Function GetMethodPredicateForMemberAttributes (
    attributes As EvaluatedMemberAttributes
) As Func(Of MethodInfo, Boolean)
public:
static Func<MethodInfo^, bool>^ GetMethodPredicateForMemberAttributes(
    EvaluatedMemberAttributes attributes
)
static member GetMethodPredicateForMemberAttributes :
        attributes : EvaluatedMemberAttributes -> Func<MethodInfo, bool>

Parameters

attributes
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberAttributes

Return Value

Type: FuncMethodInfo, Boolean
See Also

Reference

MemberEvaluationService Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


MemberEvaluationService.GetMethodVisibility Method

MemberEvaluationServiceGetMethodVisibility Method

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static EvaluatedMemberVisibility GetMethodVisibility(
    MethodInfo method
)
Public Shared Function GetMethodVisibility (
    method As MethodInfo
) As EvaluatedMemberVisibility
public:
static EvaluatedMemberVisibility GetMethodVisibility(
    MethodInfo^ method
)
static member GetMethodVisibility :
        method : MethodInfo -> EvaluatedMemberVisibility

Parameters

method
Type: System.ReflectionMethodInfo

Return Value

Type: EvaluatedMemberVisibility
See Also

Reference

MemberEvaluationService Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ValueEvaluationResult Class

ValueEvaluationResult Class
Provides data for result of successful evaluation.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
Alternet.Scripter.Debugger.ExpressionEvaluationValueEvaluationResult

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValueEvaluationResult : EvaluationResult
Public Class ValueEvaluationResult
    Inherits EvaluationResult
public ref class ValueEvaluationResult : public EvaluationResult
type ValueEvaluationResult =
    class
        inherit EvaluationResult
    end

The ValueEvaluationResult type exposes the following members.

Constructors
 | Name | Description
Public method | ValueEvaluationResult | Initializes a new instance of ValueEvaluationResult with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Expression | Represents evaluated expression. (Inherited from EvaluationResult.)
Public property | HasChildren | Represents boolean value indicating whether result has children.
Public property | Metadata | Represents evaluation metadata.
Public property | Name | Represents name of the result. (Inherited from EvaluationResult.)
Public property | ValueString | Represents evaluation value as string.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ValueEvaluationResult Constructor

ValueEvaluationResult Constructor
Initializes a new instance of ValueEvaluationResult with specified settings.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValueEvaluationResult(
    string expression,
    string name,
    EvaluatedMemberMetadata metadata,
    string valueString,
    bool hasChildren
)
Public Sub New (
    expression As String,
    name As String,
    metadata As EvaluatedMemberMetadata,
    valueString As String,
    hasChildren As Boolean
)
public:
ValueEvaluationResult(
    String^ expression,
    String^ name,
    EvaluatedMemberMetadata^ metadata,
    String^ valueString,
    bool hasChildren
)
new :
        expression : string *
        name : string *
        metadata : EvaluatedMemberMetadata *
        valueString : string *
        hasChildren : bool -> ValueEvaluationResult

Parameters

expression
Type: SystemString
Evaluated expression.
name
Type: SystemString
Name of the result.
metadata
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberMetadata
Evaluation metadata.
valueString
Type: SystemString
String value representation.
hasChildren
Type: SystemBoolean
Indicates whether evaluation result has children.
See Also

Reference

ValueEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ValueEvaluationResult Methods

ValueEvaluationResult Methods

The ValueEvaluationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ValueEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ValueEvaluationResult Properties

ValueEvaluationResult Properties

The ValueEvaluationResult type exposes the following members.

Properties
 | Name | Description
Public property | Expression | Represents evaluated expression. (Inherited from EvaluationResult.)
Public property | HasChildren | Represents boolean value indicating whether result has children.
Public property | Metadata | Represents evaluation metadata.
Public property | Name | Represents name of the result. (Inherited from EvaluationResult.)
Public property | ValueString | Represents evaluation value as string.
Top
See Also

Reference

ValueEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ValueEvaluationResult.HasChildren Property

ValueEvaluationResultHasChildren Property
Represents boolean value indicating whether result has children.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasChildren { get; }
Public ReadOnly Property HasChildren As Boolean
    Get
public:
property bool HasChildren {
    bool get ();
}
member HasChildren : bool with get

Property Value

Type: Boolean
See Also

Reference

ValueEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ValueEvaluationResult.Metadata Property

ValueEvaluationResultMetadata Property
Represents evaluation metadata.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluatedMemberMetadata Metadata { get; }
Public ReadOnly Property Metadata As EvaluatedMemberMetadata
    Get
public:
property EvaluatedMemberMetadata^ Metadata {
    EvaluatedMemberMetadata^ get ();
}
member Metadata : EvaluatedMemberMetadata with get

Property Value

Type: EvaluatedMemberMetadata
See Also

Reference

ValueEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


ValueEvaluationResult.ValueString Property

ValueEvaluationResultValueString Property
Represents evaluation value as string.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ValueString { get; }
Public ReadOnly Property ValueString As String
    Get
public:
property String^ ValueString {
    String^ get ();
}
member ValueString : string with get

Property Value

Type: String
See Also

Reference

ValueEvaluationResult Class
Alternet.Scripter.Debugger.ExpressionEvaluation Namespace


Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace
Classes
 | Class | Description
Public class | CachingSymbolRecommender | Caching decorator for a symbol recommender. Solves the following problem: When code completion listbox is invoked and you continue typing, we re-invoke it for every character entered (unless it's typed fast). VS does not re-invoke code completion if you continue typing literals(i.e identifier symbols), or when you hit backspace, it's just filters code completion listbox.
Public class | CodeCompletionKeywords | Contains reserved words related to the .NET languages.
Public class | DocumentationComment | A documentation comment derived from either source text or metadata.
Public class | KeyConfiguration | Represents a key configuration for code completion and expression evaluation.
Public class | ParameterInfo | Represents properties and methods used to describe evaluated data.
Public class | ParameterInfoSymbol | Represents a symbol (namespace, class, method, parameter, etc.) exposed by the evaluator.
Public class | ParameterInfoSymbolParameter | Represents a single parameter related to the evaluated Symbol.
Public class | ParameterInfoProvider | Represents methods to provide data related to ParameterInfo.
Public class | ParameterInfoRetrieverCSharp | Provides parameter info generation for C# based on Microsoft Roslyn.
Public class | ParameterInfoRetrieverVisualBasic | Provides class for retrieving parameter information for Visual Basic based on Microsoft Roslyn.
Public class | Symbol | Represents a symbol (namespace, class, method, parameter, etc.) exposed by the evaluator.
Public class | SymbolDocumentation | Provide documentation of a single symbol.
Public class | SymbolRecommender | Provides methods used to find suitable Symbol objects.
Public class | SyntaxData | Contains code syntax and semantic information required for providing code completion during expression evaluation.
Public class | SyntaxDataProvider | Provides syntax and semantic information for a given expression.
Interfaces
 | Interface | Description
Public interface | IParameterInfoProvider | Represents methods to provide data related to ParameterInfo.
Public interface | ISymbolRecommender | Represents methods declaration to find suitable Symbol objects.
Enumerations
 | Enumeration | Description
Public enumeration | SymbolKind | Specifies the possible kinds of symbols.


CachingSymbolRecommender Class

CachingSymbolRecommender Class
Caching decorator for a symbol recommender. Solves the following problem: When code completion listbox is invoked and you continue typing, we re-invoke it for every character entered (unless it's typed fast). VS does not re-invoke code completion if you continue typing literals(i.e identifier symbols), or when you hit backspace, it's just filters code completion listbox.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionCachingSymbolRecommender

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CachingSymbolRecommender : ISymbolRecommender
Public Class CachingSymbolRecommender
    Implements ISymbolRecommender
public ref class CachingSymbolRecommender : ISymbolRecommender
type CachingSymbolRecommender =
    class
        interface ISymbolRecommender
    end

The CachingSymbolRecommender type exposes the following members.

Constructors
 | Name | Description
Public method | CachingSymbolRecommender | Initializes a new instance of CachingSymbolRecommender with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRecommendedSymbols | Gets a List of Symbol objects suitable to specified parameters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


CachingSymbolRecommender Constructor

CachingSymbolRecommender Constructor
Initializes a new instance of CachingSymbolRecommender with specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CachingSymbolRecommender(
    ISymbolRecommender recommender,
    KeyConfiguration keyConfiguration
)
Public Sub New (
    recommender As ISymbolRecommender,
    keyConfiguration As KeyConfiguration
)
public:
CachingSymbolRecommender(
    ISymbolRecommender^ recommender,
    KeyConfiguration^ keyConfiguration
)
new :
        recommender : ISymbolRecommender *
        keyConfiguration : KeyConfiguration -> CachingSymbolRecommender

Parameters

recommender
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionISymbolRecommender
ISymbolRecommender whose symbols should be cashed.
keyConfiguration
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionKeyConfiguration
Specifies amount of key settings.
See Also

Reference

CachingSymbolRecommender Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


CachingSymbolRecommender Methods

CachingSymbolRecommender Methods

The CachingSymbolRecommender type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRecommendedSymbols | Gets a List of Symbol objects suitable to specified parameters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CachingSymbolRecommender Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


CachingSymbolRecommender.GetRecommendedSymbols Method

CachingSymbolRecommenderGetRecommendedSymbols Method
Gets a List of Symbol objects suitable to specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Symbol> GetRecommendedSymbols(
    string expressionToEvaluate,
    int positionInExpression,
    bool excludeKeywords
)
Public Function GetRecommendedSymbols (
    expressionToEvaluate As String,
    positionInExpression As Integer,
    excludeKeywords As Boolean
) As IEnumerable(Of Symbol)
public:
virtual IEnumerable<Symbol^>^ GetRecommendedSymbols(
    String^ expressionToEvaluate,
    int positionInExpression,
    bool excludeKeywords
) sealed
abstract GetRecommendedSymbols :
        expressionToEvaluate : string *
        positionInExpression : int *
        excludeKeywords : bool -> IEnumerable<Symbol>
override GetRecommendedSymbols :
        expressionToEvaluate : string *
        positionInExpression : int *
        excludeKeywords : bool -> IEnumerable<Symbol>

Parameters

expressionToEvaluate
Type: SystemString
Expression to evaluate.
positionInExpression
Type: SystemInt32
Position inside expression to find out proper symbols.
excludeKeywords
Type: SystemBoolean
Indicates whether reserved words should be excluded from the evaluation.

Return Value

Type: IEnumerableSymbol
List of symbols belongs to the specified position within expression to evaluate.

Implements

ISymbolRecommenderGetRecommendedSymbols(String, Int32, Boolean)
See Also

Reference

CachingSymbolRecommender Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


CodeCompletionKeywords Class

CodeCompletionKeywords Class
Contains reserved words related to the .NET languages.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionCodeCompletionKeywords

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionKeywords
Public Class CodeCompletionKeywords
public ref class CodeCompletionKeywords
type CodeCompletionKeywords =  class end

The CodeCompletionKeywords type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionKeywords | Initializes a new instance of the CodeCompletionKeywords class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ExpressionKeywordsCSharp | Defines array of C# language reserved words.
ExpressionKeywordsVisualBasic | Defines array of CVisual Basic language reserved words.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


CodeCompletionKeywords Constructor

CodeCompletionKeywords Constructor
Initializes a new instance of the CodeCompletionKeywords class

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionKeywords()
Public Sub New
public:
CodeCompletionKeywords()
new : unit -> CodeCompletionKeywords
See Also

Reference

CodeCompletionKeywords Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


CodeCompletionKeywords Fields

CodeCompletionKeywords Fields

The CodeCompletionKeywords type exposes the following members.

Fields
Name | Description
ExpressionKeywordsCSharp | Defines array of C# language reserved words.
ExpressionKeywordsVisualBasic | Defines array of CVisual Basic language reserved words.
Top
See Also

Reference

CodeCompletionKeywords Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


CodeCompletionKeywords.ExpressionKeywordsCSharp Field

CodeCompletionKeywordsExpressionKeywordsCSharp Field
Defines array of C# language reserved words.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string[] ExpressionKeywordsCSharp
Public Shared ReadOnly ExpressionKeywordsCSharp As String()
public:
static initonly array<String^>^ ExpressionKeywordsCSharp
static val ExpressionKeywordsCSharp: string[]

Field Value

Type: String
See Also

Reference

CodeCompletionKeywords Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


CodeCompletionKeywords.ExpressionKeywordsVisualBasic Field

CodeCompletionKeywordsExpressionKeywordsVisualBasic Field
Defines array of CVisual Basic language reserved words.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly string[] ExpressionKeywordsVisualBasic
Public Shared ReadOnly ExpressionKeywordsVisualBasic As String()
public:
static initonly array<String^>^ ExpressionKeywordsVisualBasic
static val ExpressionKeywordsVisualBasic: string[]

Field Value

Type: String
See Also

Reference

CodeCompletionKeywords Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


CodeCompletionKeywords Methods

CodeCompletionKeywords Methods

The CodeCompletionKeywords type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeCompletionKeywords Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment Class

DocumentationComment Class
A documentation comment derived from either source text or metadata.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionDocumentationComment

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DocumentationComment
Public NotInheritable Class DocumentationComment
public ref class DocumentationComment sealed
[<SealedAttribute>]
type DocumentationComment =  class end

The DocumentationComment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromXmlFragment | Parses and constructs a DocumentationComment from the given fragment of XML.
Public method | GetExceptionTexts | Returns the texts for a given exception, or an empty ImmutableArray if no documentation was given for the exception.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParameterText | Returns the text for a given parameter, or null if no documentation was given for the parameter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeParameterText | Returns the text for a given type parameter, or null if no documentation was given for the type parameter.
 | StripTextFromTags | Creates clear text from specified input with document comment tags.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Empty | An empty comment.
Top
Properties
 | Name | Description
Public property | ExampleText | The text in the <example> tag. Null if no tag existed.
Public property | ExceptionTypes | The types of items in <exception> tags.
Public property | FullXmlFragment | The full XML text of this tag.
Public property | HadXmlParseError | True if an error occurred when parsing.
Public property | ParameterNames | The names of items in <param> tags.
Public property | RemarksText | The text in the <remarks> tag. Null if no tag existed.
Public property | ReturnsText | The text in the <returns> tag. Null if no tag existed.
Public property | SummaryText | The text in the <summary> tag. Null if no tag existed.
Public property | TypeParameterNames | The names of items in <typeparam> tags.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment Fields

DocumentationComment Fields

The DocumentationComment type exposes the following members.

Fields
Name | Description
Empty | An empty comment.
Top
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.Empty Field

DocumentationCommentEmpty Field
An empty comment.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly DocumentationComment Empty
Public Shared ReadOnly Empty As DocumentationComment
public:
static initonly DocumentationComment^ Empty
static val Empty: DocumentationComment

Field Value

Type: DocumentationComment
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment Methods

DocumentationComment Methods

The DocumentationComment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromXmlFragment | Parses and constructs a DocumentationComment from the given fragment of XML.
Public method | GetExceptionTexts | Returns the texts for a given exception, or an empty ImmutableArray if no documentation was given for the exception.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParameterText | Returns the text for a given parameter, or null if no documentation was given for the parameter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeParameterText | Returns the text for a given type parameter, or null if no documentation was given for the type parameter.
 | StripTextFromTags | Creates clear text from specified input with document comment tags.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.FromXmlFragment Method

DocumentationCommentFromXmlFragment Method
Parses and constructs a DocumentationComment from the given fragment of XML.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DocumentationComment FromXmlFragment(
    string xml
)
Public Shared Function FromXmlFragment (
    xml As String
) As DocumentationComment
public:
static DocumentationComment^ FromXmlFragment(
    String^ xml
)
static member FromXmlFragment :
        xml : string -> DocumentationComment

Parameters

xml
Type: SystemString
The fragment of XML to parse.

Return Value

Type: DocumentationComment
A DocumentationComment instance.
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.GetExceptionTexts Method

DocumentationCommentGetExceptionTexts Method
Returns the texts for a given exception, or an empty ImmutableArray if no documentation was given for the exception.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImmutableArray<string> GetExceptionTexts(
    string exceptionName
)
Public Function GetExceptionTexts (
    exceptionName As String
) As ImmutableArray(Of String)
public:
ImmutableArray<String^> GetExceptionTexts(
    String^ exceptionName
)
member GetExceptionTexts :
        exceptionName : string -> ImmutableArray<string>

Parameters

exceptionName
Type: SystemString

Return Value

Type: ImmutableArrayString
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.GetParameterText Method

DocumentationCommentGetParameterText Method
Returns the text for a given parameter, or null if no documentation was given for the parameter.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetParameterText(
    string parameterName
)
Public Function GetParameterText (
    parameterName As String
) As String
public:
String^ GetParameterText(
    String^ parameterName
)
member GetParameterText :
        parameterName : string -> string

Parameters

parameterName
Type: SystemString

Return Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.GetTypeParameterText Method

DocumentationCommentGetTypeParameterText Method
Returns the text for a given type parameter, or null if no documentation was given for the type parameter.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetTypeParameterText(
    string typeParameterName
)
Public Function GetTypeParameterText (
    typeParameterName As String
) As String
public:
String^ GetTypeParameterText(
    String^ typeParameterName
)
member GetTypeParameterText :
        typeParameterName : string -> string

Parameters

typeParameterName
Type: SystemString

Return Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.StripTextFromTags Method

DocumentationCommentStripTextFromTags Method
Creates clear text from specified input with document comment tags.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StripTextFromTags(
    string input
)
Public Shared Function StripTextFromTags (
    input As String
) As String
public:
static String^ StripTextFromTags(
    String^ input
)
static member StripTextFromTags :
        input : string -> string

Parameters

input
Type: SystemString
Source string to create stripped text from.

Return Value

Type: String
Text formatted using a number of xml tags.
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment Properties

DocumentationComment Properties

The DocumentationComment type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | The text in the <example> tag. Null if no tag existed.
Public property | ExceptionTypes | The types of items in <exception> tags.
Public property | FullXmlFragment | The full XML text of this tag.
Public property | HadXmlParseError | True if an error occurred when parsing.
Public property | ParameterNames | The names of items in <param> tags.
Public property | RemarksText | The text in the <remarks> tag. Null if no tag existed.
Public property | ReturnsText | The text in the <returns> tag. Null if no tag existed.
Public property | SummaryText | The text in the <summary> tag. Null if no tag existed.
Public property | TypeParameterNames | The names of items in <typeparam> tags.
Top
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.ExampleText Property

DocumentationCommentExampleText Property
The text in the <example> tag. Null if no tag existed.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get
public:
property String^ ExampleText {
    String^ get ();
}
member ExampleText : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.ExceptionTypes Property

DocumentationCommentExceptionTypes Property
The types of items in <exception> tags.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImmutableArray<string> ExceptionTypes { get; }
Public ReadOnly Property ExceptionTypes As ImmutableArray(Of String)
    Get
public:
property ImmutableArray<String^> ExceptionTypes {
    ImmutableArray<String^> get ();
}
member ExceptionTypes : ImmutableArray<string> with get

Property Value

Type: ImmutableArrayString
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.FullXmlFragment Property

DocumentationCommentFullXmlFragment Property
The full XML text of this tag.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullXmlFragment { get; }
Public ReadOnly Property FullXmlFragment As String
    Get
public:
property String^ FullXmlFragment {
    String^ get ();
}
member FullXmlFragment : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.HadXmlParseError Property

DocumentationCommentHadXmlParseError Property
True if an error occurred when parsing.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HadXmlParseError { get; }
Public ReadOnly Property HadXmlParseError As Boolean
    Get
public:
property bool HadXmlParseError {
    bool get ();
}
member HadXmlParseError : bool with get

Property Value

Type: Boolean
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.ParameterNames Property

DocumentationCommentParameterNames Property
The names of items in <param> tags.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImmutableArray<string> ParameterNames { get; }
Public ReadOnly Property ParameterNames As ImmutableArray(Of String)
    Get
public:
property ImmutableArray<String^> ParameterNames {
    ImmutableArray<String^> get ();
}
member ParameterNames : ImmutableArray<string> with get

Property Value

Type: ImmutableArrayString
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.RemarksText Property

DocumentationCommentRemarksText Property
The text in the <remarks> tag. Null if no tag existed.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RemarksText { get; }
Public ReadOnly Property RemarksText As String
    Get
public:
property String^ RemarksText {
    String^ get ();
}
member RemarksText : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.ReturnsText Property

DocumentationCommentReturnsText Property
The text in the <returns> tag. Null if no tag existed.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReturnsText { get; }
Public ReadOnly Property ReturnsText As String
    Get
public:
property String^ ReturnsText {
    String^ get ();
}
member ReturnsText : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.SummaryText Property

DocumentationCommentSummaryText Property
The text in the <summary> tag. Null if no tag existed.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SummaryText { get; }
Public ReadOnly Property SummaryText As String
    Get
public:
property String^ SummaryText {
    String^ get ();
}
member SummaryText : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


DocumentationComment.TypeParameterNames Property

DocumentationCommentTypeParameterNames Property
The names of items in <typeparam> tags.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImmutableArray<string> TypeParameterNames { get; }
Public ReadOnly Property TypeParameterNames As ImmutableArray(Of String)
    Get
public:
property ImmutableArray<String^> TypeParameterNames {
    ImmutableArray<String^> get ();
}
member TypeParameterNames : ImmutableArray<string> with get

Property Value

Type: ImmutableArrayString
See Also

Reference

DocumentationComment Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


IParameterInfoProvider Interface

IParameterInfoProvider Interface
Represents methods to provide data related to ParameterInfo.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IParameterInfoProvider
Public Interface IParameterInfoProvider
public interface class IParameterInfoProvider
type IParameterInfoProvider =  interface end

The IParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetFormattedParameterInfoSymbolString | When implemented by a class, returns formatted string corresponding to the specified ParameterInfo.
Public method | GetParameterInfo | When implemented by a class, returns ParameterInfo for specified expression.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


IParameterInfoProvider Methods

IParameterInfoProvider Methods

The IParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetFormattedParameterInfoSymbolString | When implemented by a class, returns formatted string corresponding to the specified ParameterInfo.
Public method | GetParameterInfo | When implemented by a class, returns ParameterInfo for specified expression.
Top
See Also

Reference

IParameterInfoProvider Interface
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


IParameterInfoProvider.GetFormattedParameterInfoSymbolString Method

IParameterInfoProviderGetFormattedParameterInfoSymbolString Method
When implemented by a class, returns formatted string corresponding to the specified ParameterInfo.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetFormattedParameterInfoSymbolString(
    ParameterInfo parameterInfo,
    int currentSymbolIndex
)
Function GetFormattedParameterInfoSymbolString (
    parameterInfo As ParameterInfo,
    currentSymbolIndex As Integer
) As String
String^ GetFormattedParameterInfoSymbolString(
    ParameterInfo^ parameterInfo,
    int currentSymbolIndex
)
abstract GetFormattedParameterInfoSymbolString :
        parameterInfo : ParameterInfo *
        currentSymbolIndex : int -> string

Parameters

parameterInfo
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfo
ParameterInfo to be formatted.
currentSymbolIndex
Type: SystemInt32
Number of current symbol in the parameter info.

Return Value

Type: String
Formatted string contained evaluated expression data.
See Also

Reference

IParameterInfoProvider Interface
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


IParameterInfoProvider.GetParameterInfo Method

IParameterInfoProviderGetParameterInfo Method
When implemented by a class, returns ParameterInfo for specified expression.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ParameterInfo GetParameterInfo(
    string expressionToEvaluate,
    int positionInExpression
)
Function GetParameterInfo (
    expressionToEvaluate As String,
    positionInExpression As Integer
) As ParameterInfo
ParameterInfo^ GetParameterInfo(
    String^ expressionToEvaluate,
    int positionInExpression
)
abstract GetParameterInfo :
        expressionToEvaluate : string *
        positionInExpression : int -> ParameterInfo

Parameters

expressionToEvaluate
Type: SystemString
Expression to evaluate.
positionInExpression
Type: SystemInt32
Position inside expression.

Return Value

Type: ParameterInfo
ParameterInfo that describes evaluated expression.
See Also

Reference

IParameterInfoProvider Interface
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ISymbolRecommender Interface

ISymbolRecommender Interface
Represents methods declaration to find suitable Symbol objects.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISymbolRecommender
Public Interface ISymbolRecommender
public interface class ISymbolRecommender
type ISymbolRecommender =  interface end

The ISymbolRecommender type exposes the following members.

Methods
 | Name | Description
Public method | GetRecommendedSymbols | When implemented by a class, gets a List of Symbol objects suitable to specified parameters.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ISymbolRecommender Methods

ISymbolRecommender Methods

The ISymbolRecommender type exposes the following members.

Methods
 | Name | Description
Public method | GetRecommendedSymbols | When implemented by a class, gets a List of Symbol objects suitable to specified parameters.
Top
See Also

Reference

ISymbolRecommender Interface
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ISymbolRecommender.GetRecommendedSymbols Method

ISymbolRecommenderGetRecommendedSymbols Method
When implemented by a class, gets a List of Symbol objects suitable to specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<Symbol> GetRecommendedSymbols(
    string expressionToEvaluate,
    int positionInExpression,
    bool excludeKeywords
)
Function GetRecommendedSymbols (
    expressionToEvaluate As String,
    positionInExpression As Integer,
    excludeKeywords As Boolean
) As IEnumerable(Of Symbol)
IEnumerable<Symbol^>^ GetRecommendedSymbols(
    String^ expressionToEvaluate,
    int positionInExpression,
    bool excludeKeywords
)
abstract GetRecommendedSymbols :
        expressionToEvaluate : string *
        positionInExpression : int *
        excludeKeywords : bool -> IEnumerable<Symbol>

Parameters

expressionToEvaluate
Type: SystemString
Expression to evaluate.
positionInExpression
Type: SystemInt32
Position inside expression to find out proper symbols.
excludeKeywords
Type: SystemBoolean
Indicates whether reserved words should be exclude from the evaluation.

Return Value

Type: IEnumerableSymbol
List of symbols belongs to the specified position within expression to evaluate.
See Also

Reference

ISymbolRecommender Interface
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration Class

KeyConfiguration Class
Represents a key configuration for code completion and expression evaluation.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionKeyConfiguration

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyConfiguration
Public Class KeyConfiguration
public ref class KeyConfiguration
type KeyConfiguration =  class end

The KeyConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | KeyConfiguration | Initializes a new instance of the KeyConfiguration class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DefaultCompletionKeys |
VisualBasicCompletionKeys |
Top
Properties
 | Name | Description
Public property | CodeCompletionKeys | Gets a List of Code Completion key characters.
Public property | CompletionKeys | Gets a List of Code Completion key characters.
Public property | ExcludeKeywordsCodeCompletionKeys | Gets a List of characters used to exclude some keywords from code completion.
Public property | ExpressionSeparators | Gets an array of characters used as separator within expression.
Public property | PrioritizeCaseSensitiveMatch | Defines if input string is case-sensitive
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration Constructor

KeyConfiguration Constructor
Initializes a new instance of the KeyConfiguration class

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyConfiguration()
Public Sub New
public:
KeyConfiguration()
new : unit -> KeyConfiguration
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration Fields

KeyConfiguration Fields

The KeyConfiguration type exposes the following members.

Fields
Name | Description
DefaultCompletionKeys |
VisualBasicCompletionKeys |
Top
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration.DefaultCompletionKeys Field

KeyConfigurationDefaultCompletionKeys Field

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly char[] DefaultCompletionKeys
Public Shared ReadOnly DefaultCompletionKeys As Char()
public:
static initonly array<wchar_t>^ DefaultCompletionKeys
static val DefaultCompletionKeys: char[]

Field Value

Type: Char
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration.VisualBasicCompletionKeys Field

KeyConfigurationVisualBasicCompletionKeys Field

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly char[] VisualBasicCompletionKeys
Public Shared ReadOnly VisualBasicCompletionKeys As Char()
public:
static initonly array<wchar_t>^ VisualBasicCompletionKeys
static val VisualBasicCompletionKeys: char[]

Field Value

Type: Char
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration Methods

KeyConfiguration Methods

The KeyConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration Properties

KeyConfiguration Properties

The KeyConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | CodeCompletionKeys | Gets a List of Code Completion key characters.
Public property | CompletionKeys | Gets a List of Code Completion key characters.
Public property | ExcludeKeywordsCodeCompletionKeys | Gets a List of characters used to exclude some keywords from code completion.
Public property | ExpressionSeparators | Gets an array of characters used as separator within expression.
Public property | PrioritizeCaseSensitiveMatch | Defines if input string is case-sensitive
Top
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration.CodeCompletionKeys Property

KeyConfigurationCodeCompletionKeys Property
Gets a List of Code Completion key characters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<char> CodeCompletionKeys { get; }
Public ReadOnly Property CodeCompletionKeys As ISet(Of Char)
    Get
public:
property ISet<wchar_t>^ CodeCompletionKeys {
    ISet<wchar_t>^ get ();
}
member CodeCompletionKeys : ISet<char> with get

Property Value

Type: ISetChar
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration.CompletionKeys Property

KeyConfigurationCompletionKeys Property
Gets a List of Code Completion key characters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public char[] CompletionKeys { get; set; }
Public Property CompletionKeys As Char()
    Get
    Set
public:
property array<wchar_t>^ CompletionKeys {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
member CompletionKeys : char[] with get, set

Property Value

Type: Char
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration.ExcludeKeywordsCodeCompletionKeys Property

KeyConfigurationExcludeKeywordsCodeCompletionKeys Property
Gets a List of characters used to exclude some keywords from code completion.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISet<char> ExcludeKeywordsCodeCompletionKeys { get; }
Public Overridable ReadOnly Property ExcludeKeywordsCodeCompletionKeys As ISet(Of Char)
    Get
public:
virtual property ISet<wchar_t>^ ExcludeKeywordsCodeCompletionKeys {
    ISet<wchar_t>^ get ();
}
abstract ExcludeKeywordsCodeCompletionKeys : ISet<char> with get
override ExcludeKeywordsCodeCompletionKeys : ISet<char> with get

Property Value

Type: ISetChar
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration.ExpressionSeparators Property

KeyConfigurationExpressionSeparators Property
Gets an array of characters used as separator within expression.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] ExpressionSeparators { get; }
Public Overridable ReadOnly Property ExpressionSeparators As Char()
    Get
public:
virtual property array<wchar_t>^ ExpressionSeparators {
    array<wchar_t>^ get ();
}
abstract ExpressionSeparators : char[] with get
override ExpressionSeparators : char[] with get

Property Value

Type: Char
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


KeyConfiguration.PrioritizeCaseSensitiveMatch Property

KeyConfigurationPrioritizeCaseSensitiveMatch Property
Defines if input string is case-sensitive

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PrioritizeCaseSensitiveMatch { get; set; }
Public Property PrioritizeCaseSensitiveMatch As Boolean
    Get
    Set
public:
property bool PrioritizeCaseSensitiveMatch {
    bool get ();
    void set (bool value);
}
member PrioritizeCaseSensitiveMatch : bool with get, set

Property Value

Type: Boolean
See Also

Reference

KeyConfiguration Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo Class

ParameterInfo Class
Represents properties and methods used to describe evaluated data.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfo

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterInfo
Public Class ParameterInfo
public ref class ParameterInfo
type ParameterInfo =  class end

The ParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterInfo | Initializes a new instance of the ParameterInfo class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithSymbols | Creates a new instance of this ParameterInfo updated to have the ISymbol list specified.
Top
Properties
 | Name | Description
Public property | DeducedCurrentSymbolIndex | Represents number of current symbol.
Public property | Symbols | Represents a readonly list of ISymbol related to evaluated data.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo Constructor

ParameterInfo Constructor
Initializes a new instance of the ParameterInfo class with specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfo(
    IReadOnlyList<ParameterInfoSymbol> symbols,
    int deducedCurrentSymbolIndex
)
Public Sub New (
    symbols As IReadOnlyList(Of ParameterInfoSymbol),
    deducedCurrentSymbolIndex As Integer
)
public:
ParameterInfo(
    IReadOnlyList<ParameterInfoSymbol^>^ symbols,
    int deducedCurrentSymbolIndex
)
new :
        symbols : IReadOnlyList<ParameterInfoSymbol> *
        deducedCurrentSymbolIndex : int -> ParameterInfo

Parameters

symbols
Type: System.Collections.GenericIReadOnlyListParameterInfoSymbol
List of ISymbol related to evaluated data.
deducedCurrentSymbolIndex
Type: SystemInt32
Number of current symbol.
See Also

Reference

ParameterInfo Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo Methods

ParameterInfo Methods

The ParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithSymbols | Creates a new instance of this ParameterInfo updated to have the ISymbol list specified.
Top
See Also

Reference

ParameterInfo Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.WithSymbols Method

ParameterInfoWithSymbols Method
Creates a new instance of this ParameterInfo updated to have the ISymbol list specified.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfo WithSymbols(
    IReadOnlyList<ParameterInfoSymbol> symbols
)
Public Function WithSymbols (
    symbols As IReadOnlyList(Of ParameterInfoSymbol)
) As ParameterInfo
public:
ParameterInfo^ WithSymbols(
    IReadOnlyList<ParameterInfoSymbol^>^ symbols
)
member WithSymbols :
        symbols : IReadOnlyList<ParameterInfoSymbol> -> ParameterInfo

Parameters

symbols
Type: System.Collections.GenericIReadOnlyListParameterInfoSymbol
List of Symbol to be added.

Return Value

Type: ParameterInfo
Updated ParameterInfo contained additional symbols.
See Also

Reference

ParameterInfo Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo Properties

ParameterInfo Properties

The ParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | DeducedCurrentSymbolIndex | Represents number of current symbol.
Public property | Symbols | Represents a readonly list of ISymbol related to evaluated data.
Top
See Also

Reference

ParameterInfo Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.DeducedCurrentSymbolIndex Property

ParameterInfoDeducedCurrentSymbolIndex Property
Represents number of current symbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DeducedCurrentSymbolIndex { get; }
Public ReadOnly Property DeducedCurrentSymbolIndex As Integer
    Get
public:
property int DeducedCurrentSymbolIndex {
    int get ();
}
member DeducedCurrentSymbolIndex : int with get

Property Value

Type: Int32
See Also

Reference

ParameterInfo Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbols Property

ParameterInfoSymbols Property
Represents a readonly list of ISymbol related to evaluated data.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyList<ParameterInfoSymbol> Symbols { get; }
Public ReadOnly Property Symbols As IReadOnlyList(Of ParameterInfoSymbol)
    Get
public:
property IReadOnlyList<ParameterInfoSymbol^>^ Symbols {
    IReadOnlyList<ParameterInfoSymbol^>^ get ();
}
member Symbols : IReadOnlyList<ParameterInfoSymbol> with get

Property Value

Type: IReadOnlyListParameterInfoSymbol
See Also

Reference

ParameterInfo Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol Class

ParameterInfoSymbol Class
Represents a symbol (namespace, class, method, parameter, etc.) exposed by the evaluator.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfoSymbol

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Symbol
Public Class Symbol
public ref class Symbol
type Symbol =  class end

The ParameterInfoSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterInfoSymbol | Initializes a new instance of the Symbol class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithDescription | Creates a new instance of this Symbol updated to have the description specified.
Public method | WithParameters | Creates a new instance of this Symbol updated to have the parameter list specified.
Top
Properties
 | Name | Description
Public property | CurrentParameterIndex | Represents current parameter index of the symbol.
Public property | Description | Represents description of the symbol.
Public property | Name | Represents name of the symbol.
Public property | Parameters | Represents parameter list of the symbol.
Public property | ReturnType | Represents return type of the symbol.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol Constructor

ParameterInfoSymbol Constructor
Initializes a new instance of the Symbol class with specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Symbol(
    string name,
    string description,
    string returnType,
    IReadOnlyList<ParameterInfoSymbolParameter> parameters,
    int currentParameterIndex
)
Public Sub New (
    name As String,
    description As String,
    returnType As String,
    parameters As IReadOnlyList(Of ParameterInfoSymbolParameter),
    currentParameterIndex As Integer
)
public:
Symbol(
    String^ name,
    String^ description,
    String^ returnType,
    IReadOnlyList<ParameterInfoSymbolParameter^>^ parameters,
    int currentParameterIndex
)
new :
        name : string *
        description : string *
        returnType : string *
        parameters : IReadOnlyList<ParameterInfoSymbolParameter> *
        currentParameterIndex : int -> Symbol

Parameters

name
Type: SystemString
Name of the symbol.
description
Type: SystemString
Description of the symbol.
returnType
Type: SystemString
Return type of the symbol.
parameters
Type: System.Collections.GenericIReadOnlyListParameterInfoSymbolParameter
Parameter list of the symbol.
currentParameterIndex
Type: SystemInt32
Current parameter index of the symbol.
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Symbol Methods

Symbol Methods

The ParameterInfoSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithDescription | Creates a new instance of this Symbol updated to have the description specified.
Public method | WithParameters | Creates a new instance of this Symbol updated to have the parameter list specified.
Top
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.WithDescription Method

ParameterInfoSymbolWithDescription Method
Creates a new instance of this Symbol updated to have the description specified.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfoSymbol WithDescription(
    string description
)
Public Function WithDescription (
    description As String
) As ParameterInfoSymbol
public:
ParameterInfoSymbol^ WithDescription(
    String^ description
)
member WithDescription :
        description : string -> ParameterInfoSymbol

Parameters

description
Type: SystemString
Description to be added.

Return Value

Type: ParameterInfoSymbol
Updated Symbol contained new description.
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.WithParameters Method

ParameterInfoSymbolWithParameters Method
Creates a new instance of this Symbol updated to have the parameter list specified.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfoSymbol WithParameters(
    IReadOnlyList<ParameterInfoSymbolParameter> parameters
)
Public Function WithParameters (
    parameters As IReadOnlyList(Of ParameterInfoSymbolParameter)
) As ParameterInfoSymbol
public:
ParameterInfoSymbol^ WithParameters(
    IReadOnlyList<ParameterInfoSymbolParameter^>^ parameters
)
member WithParameters :
        parameters : IReadOnlyList<ParameterInfoSymbolParameter> -> ParameterInfoSymbol

Parameters

parameters
Type: System.Collections.GenericIReadOnlyListParameterInfoSymbolParameter
Parameter list to be added.

Return Value

Type: ParameterInfoSymbol
Updated Symbol contained new parameters.
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Symbol Properties

Symbol Properties

The ParameterInfoSymbol type exposes the following members.

Properties
 | Name | Description
Public property | CurrentParameterIndex | Represents current parameter index of the symbol.
Public property | Description | Represents description of the symbol.
Public property | Name | Represents name of the symbol.
Public property | Parameters | Represents parameter list of the symbol.
Public property | ReturnType | Represents return type of the symbol.
Top
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.CurrentParameterIndex Property

ParameterInfoSymbolCurrentParameterIndex Property
Represents current parameter index of the symbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CurrentParameterIndex { get; }
Public ReadOnly Property CurrentParameterIndex As Integer
    Get
public:
property int CurrentParameterIndex {
    int get ();
}
member CurrentParameterIndex : int with get

Property Value

Type: Int32
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.Description Property

ParameterInfoSymbolDescription Property
Represents description of the symbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.Name Property

ParameterInfoSymbolName Property
Represents name of the symbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.Parameters Property

ParameterInfoSymbolParameters Property
Represents parameter list of the symbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyList<ParameterInfoSymbolParameter> Parameters { get; }
Public ReadOnly Property Parameters As IReadOnlyList(Of ParameterInfoSymbolParameter)
    Get
public:
property IReadOnlyList<ParameterInfoSymbolParameter^>^ Parameters {
    IReadOnlyList<ParameterInfoSymbolParameter^>^ get ();
}
member Parameters : IReadOnlyList<ParameterInfoSymbolParameter> with get

Property Value

Type: IReadOnlyListParameterInfoSymbolParameter
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.ReturnType Property

ParameterInfoSymbolReturnType Property
Represents return type of the symbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReturnType { get; }
Public ReadOnly Property ReturnType As String
    Get
public:
property String^ ReturnType {
    String^ get ();
}
member ReturnType : string with get

Property Value

Type: String
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.Parameter Class

ParameterInfoSymbolParameter Class
Represents a single parameter related to the evaluated Symbol.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfoSymbolParameter

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Parameter
Public Class Parameter
public ref class Parameter
type Parameter =  class end

The ParameterInfoSymbolParameter type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterInfoSymbolParameter | Initializes a new instance of the Parameter class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithDescription | Creates a new instance of this Parameter updated to have the description specified.
Top
Properties
 | Name | Description
Public property | Description | Represents description of the parameter.
Public property | Name | Represents name of the parameter.
Public property | Type | Represents type of the parameter.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.Parameter Constructor

ParameterInfoSymbolParameter Constructor
Initializes a new instance of the Parameter class with specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parameter(
    string name,
    string description,
    string type
)
Public Sub New (
    name As String,
    description As String,
    type As String
)
public:
Parameter(
    String^ name,
    String^ description,
    String^ type
)
new :
        name : string *
        description : string *
        type : string -> Parameter

Parameters

name
Type: SystemString
Name of the parameter.
description
Type: SystemString
Description of the parameter.
type
Type: SystemString
Type of the parameter.
See Also

Reference

ParameterInfoSymbolParameter Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Parameter Methods

Parameter Methods

The ParameterInfoSymbolParameter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithDescription | Creates a new instance of this Parameter updated to have the description specified.
Top
See Also

Reference

ParameterInfoSymbolParameter Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.Parameter.WithDescription Method

ParameterInfoSymbolParameterWithDescription Method
Creates a new instance of this Parameter updated to have the description specified.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfoSymbolParameter WithDescription(
    string description
)
Public Function WithDescription (
    description As String
) As ParameterInfoSymbolParameter
public:
ParameterInfoSymbolParameter^ WithDescription(
    String^ description
)
member WithDescription :
        description : string -> ParameterInfoSymbolParameter

Parameters

description
Type: SystemString
Description to be added.

Return Value

Type: ParameterInfoSymbolParameter
Updated Parameter contained new description.
See Also

Reference

ParameterInfoSymbolParameter Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Parameter Properties

Parameter Properties

The ParameterInfoSymbolParameter type exposes the following members.

Properties
 | Name | Description
Public property | Description | Represents description of the parameter.
Public property | Name | Represents name of the parameter.
Public property | Type | Represents type of the parameter.
Top
See Also

Reference

ParameterInfoSymbolParameter Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.Parameter.Description Property

ParameterInfoSymbolParameterDescription Property
Represents description of the parameter.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

ParameterInfoSymbolParameter Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.Parameter.Name Property

ParameterInfoSymbolParameterName Property
Represents name of the parameter.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

ParameterInfoSymbolParameter Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfo.Symbol.Parameter.Type Property

ParameterInfoSymbolParameterType Property
Represents type of the parameter.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; }
Public ReadOnly Property Type As String
    Get
public:
property String^ Type {
    String^ get ();
}
member Type : string with get

Property Value

Type: String
See Also

Reference

ParameterInfoSymbolParameter Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoProvider Class

ParameterInfoProvider Class
Represents methods to provide data related to ParameterInfo.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfoProvider

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterInfoProvider : IParameterInfoProvider
Public Class ParameterInfoProvider
    Implements IParameterInfoProvider
public ref class ParameterInfoProvider : IParameterInfoProvider
type ParameterInfoProvider =
    class
        interface IParameterInfoProvider
    end

The ParameterInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterInfoProvider | Initializes a new instance of the ParameterInfoProvider class with specified provider.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFormattedParameterInfoSymbolString | Returns formatted string corresponding to the specified ParameterInfo.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParameterInfo | Returns ParameterInfo for specified expression.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoProvider Constructor

ParameterInfoProvider Constructor
Initializes a new instance of the ParameterInfoProvider class with specified provider.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfoProvider(
    SyntaxDataProvider syntaxDataProvider
)
Public Sub New (
    syntaxDataProvider As SyntaxDataProvider
)
public:
ParameterInfoProvider(
    SyntaxDataProvider^ syntaxDataProvider
)
new :
        syntaxDataProvider : SyntaxDataProvider -> ParameterInfoProvider

Parameters

syntaxDataProvider
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionSyntaxDataProvider
SyntaxDataProvider for this new instance.
See Also

Reference

ParameterInfoProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoProvider Methods

ParameterInfoProvider Methods

The ParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetFormattedParameterInfoSymbolString | Returns formatted string corresponding to the specified ParameterInfo.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParameterInfo | Returns ParameterInfo for specified expression.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParameterInfoProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoProvider.GetFormattedParameterInfoSymbolString Method

ParameterInfoProviderGetFormattedParameterInfoSymbolString Method
Returns formatted string corresponding to the specified ParameterInfo.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetFormattedParameterInfoSymbolString(
    ParameterInfo parameterInfo,
    int currentSymbolIndex
)
Public Function GetFormattedParameterInfoSymbolString (
    parameterInfo As ParameterInfo,
    currentSymbolIndex As Integer
) As String
public:
virtual String^ GetFormattedParameterInfoSymbolString(
    ParameterInfo^ parameterInfo,
    int currentSymbolIndex
) sealed
abstract GetFormattedParameterInfoSymbolString :
        parameterInfo : ParameterInfo *
        currentSymbolIndex : int -> string
override GetFormattedParameterInfoSymbolString :
        parameterInfo : ParameterInfo *
        currentSymbolIndex : int -> string

Parameters

parameterInfo
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfo
ParameterInfo to be formatted.
currentSymbolIndex
Type: SystemInt32
Number of current symbol in the parameter info.

Return Value

Type: String
Formatted string contained evaluated expression data.

Implements

IParameterInfoProviderGetFormattedParameterInfoSymbolString(ParameterInfo, Int32)
See Also

Reference

ParameterInfoProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoProvider.GetParameterInfo Method

ParameterInfoProviderGetParameterInfo Method
Returns ParameterInfo for specified expression.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfo GetParameterInfo(
    string expressionToEvaluate,
    int positionInExpression
)
Public Function GetParameterInfo (
    expressionToEvaluate As String,
    positionInExpression As Integer
) As ParameterInfo
public:
virtual ParameterInfo^ GetParameterInfo(
    String^ expressionToEvaluate,
    int positionInExpression
) sealed
abstract GetParameterInfo :
        expressionToEvaluate : string *
        positionInExpression : int -> ParameterInfo
override GetParameterInfo :
        expressionToEvaluate : string *
        positionInExpression : int -> ParameterInfo

Parameters

expressionToEvaluate
Type: SystemString
Expression to evaluate.
positionInExpression
Type: SystemInt32
Position inside expression.

Return Value

Type: ParameterInfo
ParameterInfo that describes evaluated expression.

Implements

IParameterInfoProviderGetParameterInfo(String, Int32)
See Also

Reference

ParameterInfoProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoRetrieverCSharp Class

ParameterInfoRetrieverCSharp Class
Provides parameter info generation for C# based on Microsoft Roslyn.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfoRetrieverCSharp

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ParameterInfoRetrieverCSharp
Public NotInheritable Class ParameterInfoRetrieverCSharp
public ref class ParameterInfoRetrieverCSharp abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ParameterInfoRetrieverCSharp =  class end

The ParameterInfoRetrieverCSharp type exposes the following members.

Methods
Name | Description
GetFormattedParameterInfoSymbolString | Returns formatted string in C# style corresponding to the specified ParameterInfo.
GetParameterInfo | Retrieves ParameterInfo for specified position inside the code.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoRetrieverCSharp Methods

ParameterInfoRetrieverCSharp Methods

The ParameterInfoRetrieverCSharp type exposes the following members.

Methods
Name | Description
GetFormattedParameterInfoSymbolString | Returns formatted string in C# style corresponding to the specified ParameterInfo.
GetParameterInfo | Retrieves ParameterInfo for specified position inside the code.
Top
See Also

Reference

ParameterInfoRetrieverCSharp Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoRetrieverCSharp.GetFormattedParameterInfoSymbolString Method

ParameterInfoRetrieverCSharpGetFormattedParameterInfoSymbolString Method
Returns formatted string in C# style corresponding to the specified ParameterInfo.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFormattedParameterInfoSymbolString(
    ParameterInfo parameterInfo,
    int currentSymbolIndex
)
Public Shared Function GetFormattedParameterInfoSymbolString (
    parameterInfo As ParameterInfo,
    currentSymbolIndex As Integer
) As String
public:
static String^ GetFormattedParameterInfoSymbolString(
    ParameterInfo^ parameterInfo,
    int currentSymbolIndex
)
static member GetFormattedParameterInfoSymbolString :
        parameterInfo : ParameterInfo *
        currentSymbolIndex : int -> string

Parameters

parameterInfo
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfo
ParameterInfo to be formatted.
currentSymbolIndex
Type: SystemInt32
Number of current symbol in the parameter info.

Return Value

Type: String
Formatted string containing method description.
See Also

Reference

ParameterInfoRetrieverCSharp Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoRetrieverCSharp.GetParameterInfo Method

ParameterInfoRetrieverCSharpGetParameterInfo Method
Retrieves ParameterInfo for specified position inside the code.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ParameterInfo GetParameterInfo(
    SemanticModel model,
    SyntaxNode node,
    int position
)
Public Shared Function GetParameterInfo (
    model As SemanticModel,
    node As SyntaxNode,
    position As Integer
) As ParameterInfo
public:
static ParameterInfo^ GetParameterInfo(
    SemanticModel^ model,
    SyntaxNode^ node,
    int position
)
static member GetParameterInfo :
        model : SemanticModel *
        node : SyntaxNode *
        position : int -> ParameterInfo

Parameters

model
Type: SemanticModel
SemanticModel representing source code.
node
Type: SyntaxNode
SyntaxNode representing method call.
position
Type: SystemInt32
Position inside the code.

Return Value

Type: ParameterInfo
ParameterInfo that describes a method at the specified position.
See Also

Reference

ParameterInfoRetrieverCSharp Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoRetrieverVisualBasic Class

ParameterInfoRetrieverVisualBasic Class
Provides class for retrieving parameter information for Visual Basic based on Microsoft Roslyn.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfoRetrieverVisualBasic

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ParameterInfoRetrieverVisualBasic
Public NotInheritable Class ParameterInfoRetrieverVisualBasic
public ref class ParameterInfoRetrieverVisualBasic abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ParameterInfoRetrieverVisualBasic =  class end

The ParameterInfoRetrieverVisualBasic type exposes the following members.

Methods
Name | Description
GetFormattedParameterInfoSymbolString | Returns formatted string in Visual Basic style corresponding to the specified ParameterInfo.
GetParameterInfo | Retrieves ParameterInfo for specified position inside the code.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoRetrieverVisualBasic Methods

ParameterInfoRetrieverVisualBasic Methods

The ParameterInfoRetrieverVisualBasic type exposes the following members.

Methods
Name | Description
GetFormattedParameterInfoSymbolString | Returns formatted string in Visual Basic style corresponding to the specified ParameterInfo.
GetParameterInfo | Retrieves ParameterInfo for specified position inside the code.
Top
See Also

Reference

ParameterInfoRetrieverVisualBasic Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoRetrieverVisualBasic.GetFormattedParameterInfoSymbolString Method

ParameterInfoRetrieverVisualBasicGetFormattedParameterInfoSymbolString Method
Returns formatted string in Visual Basic style corresponding to the specified ParameterInfo.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFormattedParameterInfoSymbolString(
    ParameterInfo parameterInfo,
    int currentSymbolIndex
)
Public Shared Function GetFormattedParameterInfoSymbolString (
    parameterInfo As ParameterInfo,
    currentSymbolIndex As Integer
) As String
public:
static String^ GetFormattedParameterInfoSymbolString(
    ParameterInfo^ parameterInfo,
    int currentSymbolIndex
)
static member GetFormattedParameterInfoSymbolString :
        parameterInfo : ParameterInfo *
        currentSymbolIndex : int -> string

Parameters

parameterInfo
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionParameterInfo
ParameterInfo to be formatted.
currentSymbolIndex
Type: SystemInt32
Number of current symbol in the parameter info.

Return Value

Type: String
Formatted string containing method description.
See Also

Reference

ParameterInfoRetrieverVisualBasic Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


ParameterInfoRetrieverVisualBasic.GetParameterInfo Method

ParameterInfoRetrieverVisualBasicGetParameterInfo Method
Retrieves ParameterInfo for specified position inside the code.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ParameterInfo GetParameterInfo(
    SemanticModel model,
    SyntaxNode node,
    int position
)
Public Shared Function GetParameterInfo (
    model As SemanticModel,
    node As SyntaxNode,
    position As Integer
) As ParameterInfo
public:
static ParameterInfo^ GetParameterInfo(
    SemanticModel^ model,
    SyntaxNode^ node,
    int position
)
static member GetParameterInfo :
        model : SemanticModel *
        node : SyntaxNode *
        position : int -> ParameterInfo

Parameters

model
Type: SemanticModel
SemanticModel representing source code.
node
Type: SyntaxNode
SyntaxNode representing method call.
position
Type: SystemInt32
Position inside the code.

Return Value

Type: ParameterInfo
ParameterInfo that describes a method at the specified position.
See Also

Reference

ParameterInfoRetrieverVisualBasic Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Symbol Class

Symbol Class
Represents a symbol (namespace, class, method, parameter, etc.) exposed by the evaluator.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionSymbol

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Symbol
Public Class Symbol
public ref class Symbol
type Symbol =  class end

The Symbol type exposes the following members.

Constructors
 | Name | Description
Public method | Symbol | Initializes a new instance of the Symbol class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Documentation | Represents description of the symbol.
Public property | Kind | Represents kind of the symbol.
Public property | Name | Represents name of the symbol.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Symbol Constructor

Symbol Constructor
Initializes a new instance of the Symbol class with specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Symbol(
    SymbolKind kind,
    string name,
    Func<SymbolDocumentation> documentationFactory
)
Public Sub New (
    kind As SymbolKind,
    name As String,
    documentationFactory As Func(Of SymbolDocumentation)
)
public:
Symbol(
    SymbolKind kind,
    String^ name,
    Func<SymbolDocumentation^>^ documentationFactory
)
new :
        kind : SymbolKind *
        name : string *
        documentationFactory : Func<SymbolDocumentation> -> Symbol

Parameters

kind
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionSymbolKind
Kind of the symbol.
name
Type: SystemString
Name of the symbol.
documentationFactory
Type: SystemFuncSymbolDocumentation
The delegate that is invoked to produce the lazily initialized value when it is needed.
See Also

Reference

Symbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Symbol Methods

Symbol Methods

The Symbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Symbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Symbol Properties

Symbol Properties

The Symbol type exposes the following members.

Properties
 | Name | Description
Public property | Documentation | Represents description of the symbol.
Public property | Kind | Represents kind of the symbol.
Public property | Name | Represents name of the symbol.
Top
See Also

Reference

Symbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Symbol.Documentation Property

SymbolDocumentation Property
Represents description of the symbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Lazy<SymbolDocumentation> Documentation { get; }
Public ReadOnly Property Documentation As Lazy(Of SymbolDocumentation)
    Get
public:
property Lazy<SymbolDocumentation^>^ Documentation {
    Lazy<SymbolDocumentation^>^ get ();
}
member Documentation : Lazy<SymbolDocumentation> with get

Property Value

Type: LazySymbolDocumentation
See Also

Reference

Symbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Symbol.Kind Property

SymbolKind Property
Represents kind of the symbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolKind Kind { get; }
Public ReadOnly Property Kind As SymbolKind
    Get
public:
property SymbolKind Kind {
    SymbolKind get ();
}
member Kind : SymbolKind with get

Property Value

Type: SymbolKind
See Also

Reference

Symbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Symbol.Name Property

SymbolName Property
Represents name of the symbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

Symbol Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolDocumentation Class

SymbolDocumentation Class
Provide documentation of a single symbol.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionSymbolDocumentation

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SymbolDocumentation
Public Class SymbolDocumentation
public ref class SymbolDocumentation
type SymbolDocumentation =  class end

The SymbolDocumentation type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolDocumentation | Initializes a new instance of the SymbolDocumentation class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Definition | Gets definition of the ISymbol.
Public property | Summary | Gets summary of the ISymbol.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolDocumentation Constructor

SymbolDocumentation Constructor
Initializes a new instance of the SymbolDocumentation class with specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolDocumentation(
    string definition,
    string summary
)
Public Sub New (
    definition As String,
    summary As String
)
public:
SymbolDocumentation(
    String^ definition,
    String^ summary
)
new :
        definition : string *
        summary : string -> SymbolDocumentation

Parameters

definition
Type: SystemString
Specifies ISymbol definition.
summary
Type: SystemString
Specifies ISymbol summary.
See Also

Reference

SymbolDocumentation Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolDocumentation Methods

SymbolDocumentation Methods

The SymbolDocumentation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SymbolDocumentation Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolDocumentation Properties

SymbolDocumentation Properties

The SymbolDocumentation type exposes the following members.

Properties
 | Name | Description
Public property | Definition | Gets definition of the ISymbol.
Public property | Summary | Gets summary of the ISymbol.
Top
See Also

Reference

SymbolDocumentation Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolDocumentation.Definition Property

SymbolDocumentationDefinition Property
Gets definition of the ISymbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Definition { get; }
Public ReadOnly Property Definition As String
    Get
public:
property String^ Definition {
    String^ get ();
}
member Definition : string with get

Property Value

Type: String
See Also

Reference

SymbolDocumentation Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolDocumentation.Summary Property

SymbolDocumentationSummary Property
Gets summary of the ISymbol.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Summary { get; }
Public ReadOnly Property Summary As String
    Get
public:
property String^ Summary {
    String^ get ();
}
member Summary : string with get

Property Value

Type: String
See Also

Reference

SymbolDocumentation Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolKind Enumeration

SymbolKind Enumeration
Specifies the possible kinds of symbols.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.Common.v7 (in Alternet.Scripter.Debugger.Common.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SymbolKind
Public Enumeration SymbolKind
public enum class SymbolKind
type SymbolKind
Members
Member name | Value | Description
Class | 0 | Symbol is a class.
Method | 1 | Symbol is a method.
Property | 2 | Symbol is a property.
Field | 3 | Symbol is a field.
Namespace | 4 | Symbol is a namespace.
Constant | 5 | Symbol is a constant.
Keyword | 6 | Symbol is a reserved word.
Struct | 7 | Symbol is a structure.
Interface | 8 | Symbol is an interface.
Delegate | 9 | Symbol is a delegate.
LocalOrParameter | 10 | Symbol is a local variable or parameter.
Event | 11 | Symbol is an event.
GenericParameter | 12 | Symbol is a generic parameter.
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolRecommender Class

SymbolRecommender Class
Provides methods used to find suitable Symbol objects.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionSymbolRecommender

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SymbolRecommender : ISymbolRecommender
Public Class SymbolRecommender
    Implements ISymbolRecommender
public ref class SymbolRecommender : ISymbolRecommender
type SymbolRecommender =
    class
        interface ISymbolRecommender
    end

The SymbolRecommender type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolRecommender | Initializes a new instance of the SymbolRecommender class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRecommendedSymbols | Gets a List of Symbol objects suitable to specified parameters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolRecommender Constructor

SymbolRecommender Constructor
Initializes a new instance of the SymbolRecommender class with specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolRecommender(
    SyntaxDataProvider syntaxDataProvider
)
Public Sub New (
    syntaxDataProvider As SyntaxDataProvider
)
public:
SymbolRecommender(
    SyntaxDataProvider^ syntaxDataProvider
)
new :
        syntaxDataProvider : SyntaxDataProvider -> SymbolRecommender

Parameters

syntaxDataProvider
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionSyntaxDataProvider
SyntaxDataProvider related to this new instance.
See Also

Reference

SymbolRecommender Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolRecommender Methods

SymbolRecommender Methods

The SymbolRecommender type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRecommendedSymbols | Gets a List of Symbol objects suitable to specified parameters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SymbolRecommender Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SymbolRecommender.GetRecommendedSymbols Method

SymbolRecommenderGetRecommendedSymbols Method
Gets a List of Symbol objects suitable to specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Symbol> GetRecommendedSymbols(
    string expressionToEvaluate,
    int positionInExpression,
    bool excludeKeywords
)
Public Function GetRecommendedSymbols (
    expressionToEvaluate As String,
    positionInExpression As Integer,
    excludeKeywords As Boolean
) As IEnumerable(Of Symbol)
public:
virtual IEnumerable<Symbol^>^ GetRecommendedSymbols(
    String^ expressionToEvaluate,
    int positionInExpression,
    bool excludeKeywords
) sealed
abstract GetRecommendedSymbols :
        expressionToEvaluate : string *
        positionInExpression : int *
        excludeKeywords : bool -> IEnumerable<Symbol>
override GetRecommendedSymbols :
        expressionToEvaluate : string *
        positionInExpression : int *
        excludeKeywords : bool -> IEnumerable<Symbol>

Parameters

expressionToEvaluate
Type: SystemString
Expression to evaluate.
positionInExpression
Type: SystemInt32
Position inside expression to find out proper symbols.
excludeKeywords
Type: SystemBoolean
Indicates whether reserved words should be exclude from the evaluation.

Return Value

Type: IEnumerableSymbol
List of symbols belongs to the specified position within expression to evaluate.

Implements

ISymbolRecommenderGetRecommendedSymbols(String, Int32, Boolean)
See Also

Reference

SymbolRecommender Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxData Class

SyntaxData Class
Contains code syntax and semantic information required for providing code completion during expression evaluation.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionSyntaxData

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxData
Public Class SyntaxData
public ref class SyntaxData
type SyntaxData =  class end

The SyntaxData type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxData | Initializes a new instance of the SyntaxData class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Model | Gets SemanticModel containing semantic information.
Public property | PositionInSource | Gets current position inside the expression.
Public property | ScriptHost | Gets Roslyn-based script host used to compile the expression.
Public property | Tree | Gets SyntaxTree containing syntax information.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxData Constructor

SyntaxData Constructor
Initializes a new instance of the SyntaxData class with specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxData(
    RoslynScriptHost scriptHost,
    SemanticModel model,
    SyntaxTree tree,
    int positionInSource
)
Public Sub New (
    scriptHost As RoslynScriptHost,
    model As SemanticModel,
    tree As SyntaxTree,
    positionInSource As Integer
)
public:
SyntaxData(
    RoslynScriptHost^ scriptHost,
    SemanticModel^ model,
    SyntaxTree^ tree,
    int positionInSource
)
new :
        scriptHost : RoslynScriptHost *
        model : SemanticModel *
        tree : SyntaxTree *
        positionInSource : int -> SyntaxData

Parameters

scriptHost
Type: Alternet.Scripter.RoslynRoslynScriptHost
Roslyn-based script host used to compile the expression.
model
Type: SemanticModel
SemanticModel containing semantic information.
tree
Type: SyntaxTree
SyntaxTree containing syntax information.
positionInSource
Type: SystemInt32
Current position inside the expression.
See Also

Reference

SyntaxData Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxData Methods

SyntaxData Methods

The SyntaxData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SyntaxData Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxData Properties

SyntaxData Properties

The SyntaxData type exposes the following members.

Properties
 | Name | Description
Public property | Model | Gets SemanticModel containing semantic information.
Public property | PositionInSource | Gets current position inside the expression.
Public property | ScriptHost | Gets Roslyn-based script host used to compile the expression.
Public property | Tree | Gets SyntaxTree containing syntax information.
Top
See Also

Reference

SyntaxData Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxData.Model Property

SyntaxDataModel Property
Gets SemanticModel containing semantic information.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SemanticModel Model { get; }
Public ReadOnly Property Model As SemanticModel
    Get
public:
property SemanticModel^ Model {
    SemanticModel^ get ();
}
member Model : SemanticModel with get

Property Value

Type: SemanticModel
See Also

Reference

SyntaxData Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxData.PositionInSource Property

SyntaxDataPositionInSource Property
Gets current position inside the expression.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PositionInSource { get; }
Public ReadOnly Property PositionInSource As Integer
    Get
public:
property int PositionInSource {
    int get ();
}
member PositionInSource : int with get

Property Value

Type: Int32
See Also

Reference

SyntaxData Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxData.ScriptHost Property

SyntaxDataScriptHost Property
Gets Roslyn-based script host used to compile the expression.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynScriptHost ScriptHost { get; }
Public ReadOnly Property ScriptHost As RoslynScriptHost
    Get
public:
property RoslynScriptHost^ ScriptHost {
    RoslynScriptHost^ get ();
}
member ScriptHost : RoslynScriptHost with get

Property Value

Type: RoslynScriptHost
See Also

Reference

SyntaxData Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxData.Tree Property

SyntaxDataTree Property
Gets SyntaxTree containing syntax information.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxTree Tree { get; }
Public ReadOnly Property Tree As SyntaxTree
    Get
public:
property SyntaxTree^ Tree {
    SyntaxTree^ get ();
}
member Tree : SyntaxTree with get

Property Value

Type: SyntaxTree
See Also

Reference

SyntaxData Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxDataProvider Class

SyntaxDataProvider Class
Provides syntax and semantic information for a given expression.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionSyntaxDataProvider

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxDataProvider
Public Class SyntaxDataProvider
public ref class SyntaxDataProvider
type SyntaxDataProvider =  class end

The SyntaxDataProvider type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxDataProvider | Initializes a new instance of the SyntaxDataProvider class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PrepareSyntaxData | Obtains syntax and semantic information for specified expression.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ScriptLanguage | Gets programming language of the script.
Top
See Also

Reference

Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxDataProvider Constructor

SyntaxDataProvider Constructor
Initializes a new instance of the SyntaxDataProvider class with specified parameters.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxDataProvider(
    IScriptRun scriptRun,
    ExecutionPosition executionPosition
)
Public Sub New (
    scriptRun As IScriptRun,
    executionPosition As ExecutionPosition
)
public:
SyntaxDataProvider(
    IScriptRun^ scriptRun,
    ExecutionPosition^ executionPosition
)
new :
        scriptRun : IScriptRun *
        executionPosition : ExecutionPosition -> SyntaxDataProvider

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
IScriptRun used to compile the expression.
executionPosition
Type: Alternet.Scripter.DebuggerExecutionPosition
Position to get syntax data.
See Also

Reference

SyntaxDataProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxDataProvider Methods

SyntaxDataProvider Methods

The SyntaxDataProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PrepareSyntaxData | Obtains syntax and semantic information for specified expression.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SyntaxDataProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxDataProvider.PrepareSyntaxData Method

SyntaxDataProviderPrepareSyntaxData Method
Obtains syntax and semantic information for specified expression.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SyntaxData PrepareSyntaxData(
    string expressionToEvaluate,
    int positionInExpression
)
Public Overridable Function PrepareSyntaxData (
    expressionToEvaluate As String,
    positionInExpression As Integer
) As SyntaxData
public:
virtual SyntaxData^ PrepareSyntaxData(
    String^ expressionToEvaluate,
    int positionInExpression
)
abstract PrepareSyntaxData :
        expressionToEvaluate : string *
        positionInExpression : int -> SyntaxData
override PrepareSyntaxData :
        expressionToEvaluate : string *
        positionInExpression : int -> SyntaxData

Parameters

expressionToEvaluate
Type: SystemString
Expression to evaluate.
positionInExpression
Type: SystemInt32
Current position inside the expression.

Return Value

Type: SyntaxData
SyntaxData that describes given expression.
See Also

Reference

SyntaxDataProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxDataProvider Properties

SyntaxDataProvider Properties

The SyntaxDataProvider type exposes the following members.

Properties
 | Name | Description
Public property | ScriptLanguage | Gets programming language of the script.
Top
See Also

Reference

SyntaxDataProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


SyntaxDataProvider.ScriptLanguage Property

SyntaxDataProviderScriptLanguage Property
Gets programming language of the script.

Namespace: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.v7 (in Alternet.Scripter.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptLanguage ScriptLanguage { get; }
Public ReadOnly Property ScriptLanguage As ScriptLanguage
    Get
public:
property ScriptLanguage ScriptLanguage {
    ScriptLanguage get ();
}
member ScriptLanguage : ScriptLanguage with get

Property Value

Type: ScriptLanguage
See Also

Reference

SyntaxDataProvider Class
Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletion Namespace


Alternet.Scripter.Debugger.IronPython Namespace

Alternet.Scripter.Debugger.IronPython Namespace
Classes
 | Class | Description
Public class | ErrorMessages | Contains default string constants related to debugger errors.
Public class | ScriptBreakpoints | Provides list of Breakpoint objects.
Public class | ScriptDebugger | Enables communication with a debugger.
Public class | ScriptTerminatedException |
Interfaces
 | Interface | Description
Public interface | IScriptDebugger | Provides methods and properties that allow developers to debug applications in the common language runtime (CLR) environment.


ErrorMessages Class

ErrorMessages Class
Contains default string constants related to debugger errors.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.IronPythonErrorMessages

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ErrorMessages
Public Class ErrorMessages
public ref class ErrorMessages
type ErrorMessages =  class end

The ErrorMessages type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorMessages | Initializes a new instance of the ErrorMessages class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
UnableToEvaluteExpressionWhenNotStarted |
UnableToEvaluteExpressionWhileRunning |
Top
See Also

Reference

Alternet.Scripter.Debugger.IronPython Namespace


ErrorMessages Constructor

ErrorMessages Constructor
Initializes a new instance of the ErrorMessages class

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ErrorMessages()
Public Sub New
public:
ErrorMessages()
new : unit -> ErrorMessages
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.IronPython Namespace


ErrorMessages Fields

ErrorMessages Fields

The ErrorMessages type exposes the following members.

Fields
Name | Description
UnableToEvaluteExpressionWhenNotStarted |
UnableToEvaluteExpressionWhileRunning |
Top
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.IronPython Namespace


ErrorMessages.UnableToEvaluteExpressionWhenNotStarted Field

ErrorMessagesUnableToEvaluteExpressionWhenNotStarted Field

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string UnableToEvaluteExpressionWhenNotStarted
Public Const UnableToEvaluteExpressionWhenNotStarted As String
public:
literal String^ UnableToEvaluteExpressionWhenNotStarted
static val mutable UnableToEvaluteExpressionWhenNotStarted: string

Field Value

Type: String
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.IronPython Namespace


ErrorMessages.UnableToEvaluteExpressionWhileRunning Field

ErrorMessagesUnableToEvaluteExpressionWhileRunning Field

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string UnableToEvaluteExpressionWhileRunning
Public Const UnableToEvaluteExpressionWhileRunning As String
public:
literal String^ UnableToEvaluteExpressionWhileRunning
static val mutable UnableToEvaluteExpressionWhileRunning: string

Field Value

Type: String
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.IronPython Namespace


ErrorMessages Methods

ErrorMessages Methods

The ErrorMessages type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.IronPython Namespace


IScriptDebugger Interface

IScriptDebugger Interface
Provides methods and properties that allow developers to debug applications in the common language runtime (CLR) environment.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptDebugger : IScriptDebuggerBase
Public Interface IScriptDebugger
    Inherits IScriptDebuggerBase
public interface class IScriptDebugger : IScriptDebuggerBase
type IScriptDebugger =
    interface
        interface IScriptDebuggerBase
    end

The IScriptDebugger type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | When implemented by a class, switches debugging to the specified thread. (Inherited from IScriptDebuggerBase.)
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed. (Inherited from IScriptDebuggerBase.)
Public method | ClearTemporaryGeneratedModules | When implemented by a class, clears temporary generated modules on disk. (Inherited from IScriptDebuggerBase.)
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionsAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | GetExecutionPositionAsync | When implemented by a class, finds out current ExecutionPosition based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | GetStackFramesAsync | When implemented by a class, gets list of method calls that are currently on a stack (Inherited from IScriptDebuggerBase.)
Public method | GetThreadsAsync | When implemented by a class, gets list of active threads. (Inherited from IScriptDebuggerBase.)
Public method | GetVariablesInScopeAsync | When implemented by a class, receives all local variables based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | SetRunToPositionBreakpoint | When implemented by a class, causes debugger to stop at the specified position. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging | When implemented by a class, starts executing the program from the entry point with default settings. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging(StartDebuggingOptions) | When implemented by a class, starts executing the program from the entry point with specified settings. (Inherited from IScriptDebuggerBase.)
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible. (Inherited from IScriptDebuggerBase.)
Public method | StepOut | When implemented by a class, executes one statement of code; steps out of the function currently being executed. (Inherited from IScriptDebuggerBase.)
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call. (Inherited from IScriptDebuggerBase.)
Public method | StopDebuggingAsync | When implemented by a class, stops executing the program. (Inherited from IScriptDebuggerBase.)
Public method | SwitchToStackFrame | When implemented by a class, switches debugging to the given stack frame. (Inherited from IScriptDebuggerBase.)
Public method | TrySetNextStatementAsync | When implemented by a class, tries to set the execution point to the specified line of code. (Inherited from IScriptDebuggerBase.)
Top
Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, returns collection of debugger breakpoints. (Inherited from IScriptDebuggerBase.)
Public property | Capabilities | When implemented by a class, gets debugger capabilities. (Inherited from IScriptDebuggerBase.)
Public property | EventsSyncAction | When implemented by a class, gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke) (Inherited from IScriptDebuggerBase.)
Public property | ExpressionEvaluator | When implemented by a class, gets IExpressionEvaluator object used to evaluate expressions. (Inherited from IScriptDebuggerBase.)
Public property | IsStarted | When implemented by a class, indicates whether debugging was started. (Inherited from IScriptDebuggerBase.)
Public property | ScopeResolutionService | When implemented by a class, gets IScopeResolutionService object used to evaluate method names and parameters. (Inherited from IScriptDebuggerBase.)
Public property | ScriptRun | When implemented by a class, contains all information required to compile and run the script
Public property | State | When implemented by a class, gets current debugger state. (Inherited from IScriptDebuggerBase.)
Top
Events
 | Name | Description
Public event | ActiveThreadChanged | When implemented by a class, occurs when thread to be debugged changes. (Inherited from IScriptDebuggerBase.)
Public event | BeforeContinue | When implemented by a class, occurs before debugger continues to program execution. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStep | When implemented by a class, occurs before debugger performs a step. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStop | When implemented by a class, occurs before debugger stop debugging. (Inherited from IScriptDebuggerBase.)
Public event | DebuggerErrorOccured | When implemented by a class, occurs when encounters error during debugging session. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStarted | When implemented by a class, occurs when debugging session is started. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStopped | When implemented by a class, occurs when debugging session is stopped. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionResumed | When implemented by a class, occurs when debugging is resumed after being paused. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionStopped | When implemented by a class, occurs when debugging is paused. (Inherited from IScriptDebuggerBase.)
Public event | LogMessageReceived | When implemented by a class, occurs when debug message is received. (Inherited from IScriptDebuggerBase.)
Public event | StackFrameSwitched | When implemented by a class, occurs debugger switches to the stack frame (Inherited from IScriptDebuggerBase.)
Public event | StateChanged | When implemented by a class, occurs when debugger state is changed. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

Alternet.Scripter.Debugger.IronPython Namespace


IScriptDebugger Methods

IScriptDebugger Methods

The IScriptDebugger type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | When implemented by a class, switches debugging to the specified thread. (Inherited from IScriptDebuggerBase.)
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed. (Inherited from IScriptDebuggerBase.)
Public method | ClearTemporaryGeneratedModules | When implemented by a class, clears temporary generated modules on disk. (Inherited from IScriptDebuggerBase.)
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionsAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | GetExecutionPositionAsync | When implemented by a class, finds out current ExecutionPosition based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | GetStackFramesAsync | When implemented by a class, gets list of method calls that are currently on a stack (Inherited from IScriptDebuggerBase.)
Public method | GetThreadsAsync | When implemented by a class, gets list of active threads. (Inherited from IScriptDebuggerBase.)
Public method | GetVariablesInScopeAsync | When implemented by a class, receives all local variables based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | SetRunToPositionBreakpoint | When implemented by a class, causes debugger to stop at the specified position. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging | When implemented by a class, starts executing the program from the entry point with default settings. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging(StartDebuggingOptions) | When implemented by a class, starts executing the program from the entry point with specified settings. (Inherited from IScriptDebuggerBase.)
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible. (Inherited from IScriptDebuggerBase.)
Public method | StepOut | When implemented by a class, executes one statement of code; steps out of the function currently being executed. (Inherited from IScriptDebuggerBase.)
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call. (Inherited from IScriptDebuggerBase.)
Public method | StopDebuggingAsync | When implemented by a class, stops executing the program. (Inherited from IScriptDebuggerBase.)
Public method | SwitchToStackFrame | When implemented by a class, switches debugging to the given stack frame. (Inherited from IScriptDebuggerBase.)
Public method | TrySetNextStatementAsync | When implemented by a class, tries to set the execution point to the specified line of code. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger.IronPython Namespace


IScriptDebugger Properties

IScriptDebugger Properties

The IScriptDebugger type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, returns collection of debugger breakpoints. (Inherited from IScriptDebuggerBase.)
Public property | Capabilities | When implemented by a class, gets debugger capabilities. (Inherited from IScriptDebuggerBase.)
Public property | EventsSyncAction | When implemented by a class, gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke) (Inherited from IScriptDebuggerBase.)
Public property | ExpressionEvaluator | When implemented by a class, gets IExpressionEvaluator object used to evaluate expressions. (Inherited from IScriptDebuggerBase.)
Public property | IsStarted | When implemented by a class, indicates whether debugging was started. (Inherited from IScriptDebuggerBase.)
Public property | ScopeResolutionService | When implemented by a class, gets IScopeResolutionService object used to evaluate method names and parameters. (Inherited from IScriptDebuggerBase.)
Public property | ScriptRun | When implemented by a class, contains all information required to compile and run the script
Public property | State | When implemented by a class, gets current debugger state. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger.IronPython Namespace


IScriptDebugger.ScriptRun Property

IScriptDebuggerScriptRun Property
When implemented by a class, contains all information required to compile and run the script

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptRun ScriptRun { get; }
ReadOnly Property ScriptRun As IScriptRun
    Get
property IScriptRun^ ScriptRun {
    IScriptRun^ get ();
}
abstract ScriptRun : IScriptRun with get

Property Value

Type: IScriptRun
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger.IronPython Namespace


IScriptDebugger Events

IScriptDebugger Events

The IScriptDebugger type exposes the following members.

Events
 | Name | Description
Public event | ActiveThreadChanged | When implemented by a class, occurs when thread to be debugged changes. (Inherited from IScriptDebuggerBase.)
Public event | BeforeContinue | When implemented by a class, occurs before debugger continues to program execution. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStep | When implemented by a class, occurs before debugger performs a step. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStop | When implemented by a class, occurs before debugger stop debugging. (Inherited from IScriptDebuggerBase.)
Public event | DebuggerErrorOccured | When implemented by a class, occurs when encounters error during debugging session. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStarted | When implemented by a class, occurs when debugging session is started. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStopped | When implemented by a class, occurs when debugging session is stopped. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionResumed | When implemented by a class, occurs when debugging is resumed after being paused. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionStopped | When implemented by a class, occurs when debugging is paused. (Inherited from IScriptDebuggerBase.)
Public event | LogMessageReceived | When implemented by a class, occurs when debug message is received. (Inherited from IScriptDebuggerBase.)
Public event | StackFrameSwitched | When implemented by a class, occurs debugger switches to the stack frame (Inherited from IScriptDebuggerBase.)
Public event | StateChanged | When implemented by a class, occurs when debugger state is changed. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints Class

ScriptBreakpoints Class
Provides list of Breakpoint objects.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.IronPythonScriptBreakpoints

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptBreakpoints : IScriptBreakpoints,
    IUpdate
Public Class ScriptBreakpoints
    Implements IScriptBreakpoints, IUpdate
public ref class ScriptBreakpoints : IScriptBreakpoints,
    IUpdate
type ScriptBreakpoints =
    class
        interface IScriptBreakpoints
        interface IUpdate
    end

The ScriptBreakpoints type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptBreakpoints | Initializes a new instance of the ScriptBreakpoints class with corresponds to specified ScriptDebugger object.
Top
Methods
 | Name | Description
Public method | AddBreakpoint | Adds a Breakpoint to the list.
Public method | BeginUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Clear | Removes all breakpoints.
Public method | DisableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EnableBreakpoint | Enables or disables specified breakpoint.
Public method | EnableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveBreakpoint | Removes a Breakpoint from the list.
Public method | RemoveBreakpoints | Removes several Breakpoint from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Raises Changed event
Top
Properties
 | Name | Description
Public property | Breakpoints | Gets an array of Breakpoint objects.
Public property | Debugger | Represents ScriptDebugger owner of this ScriptBreakpoints.
Public property | UpdateCount |
Top
Events
 | Name | Description
Public event | BreakpointAdded | Occurs when a breakpoint is added.
Public event | BreakpointRemoved | Occurs when a breakpoint is removed.
Public event | BreakpointStateChanged | Occurs when a breakpoint state is changed.
Public event | Changed | Occurs when breakpoints are changed.
Top
See Also

Reference

Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints Constructor

ScriptBreakpoints Constructor
Initializes a new instance of the ScriptBreakpoints class with corresponds to specified ScriptDebugger object.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptBreakpoints(
    ScriptDebugger debugger
)
Public Sub New (
    debugger As ScriptDebugger
)
public:
ScriptBreakpoints(
    ScriptDebugger^ debugger
)
new :
        debugger : ScriptDebugger -> ScriptBreakpoints

Parameters

debugger
Type: Alternet.Scripter.Debugger.IronPythonScriptDebugger
ScriptDebugger that owns this new instance.
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints Methods

ScriptBreakpoints Methods

The ScriptBreakpoints type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint | Adds a Breakpoint to the list.
Public method | BeginUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Clear | Removes all breakpoints.
Public method | DisableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EnableBreakpoint | Enables or disables specified breakpoint.
Public method | EnableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveBreakpoint | Removes a Breakpoint from the list.
Public method | RemoveBreakpoints | Removes several Breakpoint from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Raises Changed event
Top
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.AddBreakpoint Method

ScriptBreakpointsAddBreakpoint Method
Adds a Breakpoint to the list.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddBreakpoint(
    string filePath,
    int lineNumber
)
Public Sub AddBreakpoint (
    filePath As String,
    lineNumber As Integer
)
public:
virtual void AddBreakpoint(
    String^ filePath,
    int lineNumber
) sealed
abstract AddBreakpoint :
        filePath : string *
        lineNumber : int -> unit
override AddBreakpoint :
        filePath : string *
        lineNumber : int -> unit

Parameters

filePath
Type: SystemString
Name of file where breakpoint is set.
lineNumber
Type: SystemInt32
Number of line at which breakpoint is set.

Implements

IScriptBreakpointsAddBreakpoint(String, Int32)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.BeginUpdate Method

ScriptBreakpointsBeginUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BeginUpdate()
Public Function BeginUpdate As Integer
public:
virtual int BeginUpdate() sealed
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateBeginUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.Clear Method

ScriptBreakpointsClear Method
Removes all breakpoints.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IScriptBreakpointsClear
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.DisableUpdate Method

ScriptBreakpointsDisableUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DisableUpdate()
Public Function DisableUpdate As Integer
public:
virtual int DisableUpdate() sealed
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateDisableUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.EnableBreakpoint Method

ScriptBreakpointsEnableBreakpoint Method
Enables or disables specified breakpoint.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableBreakpoint(
    Breakpoint breakpoint,
    bool enable
)
Public Sub EnableBreakpoint (
    breakpoint As Breakpoint,
    enable As Boolean
)
public:
virtual void EnableBreakpoint(
    Breakpoint^ breakpoint,
    bool enable
) sealed
abstract EnableBreakpoint :
        breakpoint : Breakpoint *
        enable : bool -> unit
override EnableBreakpoint :
        breakpoint : Breakpoint *
        enable : bool -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
Breakpoint to process.
enable
Type: SystemBoolean
New breakpoint's state.

Implements

IScriptBreakpointsEnableBreakpoint(Breakpoint, Boolean)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.EnableUpdate Method

ScriptBreakpointsEnableUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EnableUpdate()
Public Function EnableUpdate As Integer
public:
virtual int EnableUpdate() sealed
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateEnableUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.EndUpdate Method

ScriptBreakpointsEndUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndUpdate()
Public Function EndUpdate As Integer
public:
virtual int EndUpdate() sealed
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateEndUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.RemoveBreakpoint Method

ScriptBreakpointsRemoveBreakpoint Method
Removes a Breakpoint from the list.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveBreakpoint(
    Breakpoint breakpoint
)
Public Function RemoveBreakpoint (
    breakpoint As Breakpoint
) As Boolean
public:
virtual bool RemoveBreakpoint(
    Breakpoint^ breakpoint
) sealed
abstract RemoveBreakpoint :
        breakpoint : Breakpoint -> bool
override RemoveBreakpoint :
        breakpoint : Breakpoint -> bool

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
The Breakpoint to remove from the list.

Return Value

Type: Boolean

Implements

IScriptBreakpointsRemoveBreakpoint(Breakpoint)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.RemoveBreakpoints Method

ScriptBreakpointsRemoveBreakpoints Method
Removes several Breakpoint from the list.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveBreakpoints(
    IList<Breakpoint> breakpoints
)
Public Sub RemoveBreakpoints (
    breakpoints As IList(Of Breakpoint)
)
public:
virtual void RemoveBreakpoints(
    IList<Breakpoint^>^ breakpoints
) sealed
abstract RemoveBreakpoints :
        breakpoints : IList<Breakpoint> -> unit
override RemoveBreakpoints :
        breakpoints : IList<Breakpoint> -> unit

Parameters

breakpoints
Type: System.Collections.GenericIListBreakpoint
The number of Breakpoint to remove from the list.

Implements

IScriptBreakpointsRemoveBreakpoints(IListBreakpoint)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.Update Method

ScriptBreakpointsUpdate Method
Raises Changed event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints Properties

ScriptBreakpoints Properties

The ScriptBreakpoints type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Gets an array of Breakpoint objects.
Public property | Debugger | Represents ScriptDebugger owner of this ScriptBreakpoints.
Public property | UpdateCount |
Top
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.Breakpoints Property

ScriptBreakpointsBreakpoints Property
Gets an array of Breakpoint objects.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoint[] Breakpoints { get; }
Public ReadOnly Property Breakpoints As Breakpoint()
    Get
public:
virtual property array<Breakpoint^>^ Breakpoints {
    array<Breakpoint^>^ get () sealed;
}
abstract Breakpoints : Breakpoint[] with get
override Breakpoints : Breakpoint[] with get

Property Value

Type: Breakpoint

Implements

IScriptBreakpointsBreakpoints
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.Debugger Property

ScriptBreakpointsDebugger Property
Represents ScriptDebugger owner of this ScriptBreakpoints.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptDebugger Debugger { get; }
Public ReadOnly Property Debugger As ScriptDebugger
    Get
public:
property ScriptDebugger^ Debugger {
    ScriptDebugger^ get ();
}
member Debugger : ScriptDebugger with get

Property Value

Type: ScriptDebugger
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.UpdateCount Property

ScriptBreakpointsUpdateCount Property

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UpdateCount { get; }
Public ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get () sealed;
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints Events

ScriptBreakpoints Events

The ScriptBreakpoints type exposes the following members.

Events
 | Name | Description
Public event | BreakpointAdded | Occurs when a breakpoint is added.
Public event | BreakpointRemoved | Occurs when a breakpoint is removed.
Public event | BreakpointStateChanged | Occurs when a breakpoint state is changed.
Public event | Changed | Occurs when breakpoints are changed.
Top
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.BreakpointAdded Event

ScriptBreakpointsBreakpointAdded Event
Occurs when a breakpoint is added.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointEventArgs> BreakpointAdded
Public Event BreakpointAdded As EventHandler(Of BreakpointEventArgs)
public:
virtual  event EventHandler<BreakpointEventArgs^>^ BreakpointAdded {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointAdded : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>
override BreakpointAdded : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs

Implements

IScriptBreakpointsBreakpointAdded
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.BreakpointRemoved Event

ScriptBreakpointsBreakpointRemoved Event
Occurs when a breakpoint is removed.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointEventArgs> BreakpointRemoved
Public Event BreakpointRemoved As EventHandler(Of BreakpointEventArgs)
public:
virtual  event EventHandler<BreakpointEventArgs^>^ BreakpointRemoved {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointRemoved : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>
override BreakpointRemoved : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs

Implements

IScriptBreakpointsBreakpointRemoved
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.BreakpointStateChanged Event

ScriptBreakpointsBreakpointStateChanged Event
Occurs when a breakpoint state is changed.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointEventArgs> BreakpointStateChanged
Public Event BreakpointStateChanged As EventHandler(Of BreakpointEventArgs)
public:
virtual  event EventHandler<BreakpointEventArgs^>^ BreakpointStateChanged {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointStateChanged : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>
override BreakpointStateChanged : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs

Implements

IScriptBreakpointsBreakpointStateChanged
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptBreakpoints.Changed Event

ScriptBreakpointsChanged Event
Occurs when breakpoints are changed.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Changed
Public Event Changed As EventHandler
public:
virtual  event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Changed : IEvent<EventHandler,
    EventArgs>
override Changed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptBreakpointsChanged
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger Class

ScriptDebugger Class
Enables communication with a debugger.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.IronPythonScriptDebugger

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptDebugger : IScriptDebugger,
    IScriptDebuggerBase
Public Class ScriptDebugger
    Implements IScriptDebugger, IScriptDebuggerBase
public ref class ScriptDebugger : IScriptDebugger,
    IScriptDebuggerBase
type ScriptDebugger =
    class
        interface IScriptDebugger
        interface IScriptDebuggerBase
    end

The ScriptDebugger type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptDebugger | Initializes a new instance of the ScriptDebugger class
Top
Methods
 | Name | Description
Public method | ActivateThread |
Public method | Break |
Public method | ClearTemporaryGeneratedModules |
Public method | Continue |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentExceptionAsync |
Public method | EvaluateExpressionAsync |
Public method | EvaluateExpressionsAsync |
Public method | GetExecutionPositionAsync |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetStackFramesAsync |
Public method | GetThreadsAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVariablesInScopeAsync |
Public method | SetRunToPositionBreakpoint |
Public method | StartDebugging |
Public method | StartDebugging(StartDebuggingOptions) |
Public method | StepInto |
Public method | StepOut |
Public method | StepOver |
Public method | StopDebuggingAsync |
Public method | SwitchToStackFrame |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrySetNextStatementAsync |
Top
Properties
 | Name | Description
Public property | Breakpoints | Returns collection of debugger breakpoints.
Public property | Capabilities |
Public property | EventsSyncAction | Gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)
Public property | ExpressionEvaluator | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | IsStarted | Indicates whether debugging was started.
Public property | ScopeResolutionService | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | ScriptRun |
Public property | State | Gets current debugger state.
Top
Events
 | Name | Description
Public event | ActiveThreadChanged |
Public event | BeforeContinue | Occurs before debugger continues to program execution.
Public event | BeforeStep | Occurs before debugger performs a step.
Public event | BeforeStop | Occurs before debugger stop debugging.
Public event | DebuggerErrorOccured |
Public event | DebuggingStarted |
Public event | DebuggingStopped |
Public event | ExecutionResumed |
Public event | ExecutionStopped |
Public event | LogMessageReceived |
Public event | StackFrameSwitched |
Public event | StateChanged |
Top
See Also

Reference

Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger Constructor

ScriptDebugger Constructor
Initializes a new instance of the ScriptDebugger class

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptDebugger()
Public Sub New
public:
ScriptDebugger()
new : unit -> ScriptDebugger
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger Methods

ScriptDebugger Methods

The ScriptDebugger type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread |
Public method | Break |
Public method | ClearTemporaryGeneratedModules |
Public method | Continue |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentExceptionAsync |
Public method | EvaluateExpressionAsync |
Public method | EvaluateExpressionsAsync |
Public method | GetExecutionPositionAsync |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetStackFramesAsync |
Public method | GetThreadsAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVariablesInScopeAsync |
Public method | SetRunToPositionBreakpoint |
Public method | StartDebugging |
Public method | StartDebugging(StartDebuggingOptions) |
Public method | StepInto |
Public method | StepOut |
Public method | StepOver |
Public method | StopDebuggingAsync |
Public method | SwitchToStackFrame |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrySetNextStatementAsync |
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.ActivateThread Method

ScriptDebuggerActivateThread Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateThread(
    int threadId
)
Public Sub ActivateThread (
    threadId As Integer
)
public:
virtual void ActivateThread(
    int threadId
) sealed
abstract ActivateThread :
        threadId : int -> unit
override ActivateThread :
        threadId : int -> unit

Parameters

threadId
Type: SystemInt32

Implements

IScriptDebuggerBaseActivateThread(Int32)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.Break Method

ScriptDebuggerBreak Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Break()
Public Sub Break
public:
virtual void Break() sealed
abstract Break : unit -> unit
override Break : unit -> unit

Implements

IScriptDebuggerBaseBreak
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.ClearTemporaryGeneratedModules Method

ScriptDebuggerClearTemporaryGeneratedModules Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearTemporaryGeneratedModules()
Public Sub ClearTemporaryGeneratedModules
public:
virtual void ClearTemporaryGeneratedModules() sealed
abstract ClearTemporaryGeneratedModules : unit -> unit
override ClearTemporaryGeneratedModules : unit -> unit

Implements

IScriptDebuggerBaseClearTemporaryGeneratedModules
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.Continue Method

ScriptDebuggerContinue Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Continue()
Public Sub Continue
public:
virtual void Continue() sealed
abstract Continue : unit -> unit
override Continue : unit -> unit

Implements

IScriptDebuggerBaseContinue
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.EvaluateCurrentExceptionAsync Method

ScriptDebuggerEvaluateCurrentExceptionAsync Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ExpressionEvaluationResult> EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = null
)
Public Function EvaluateCurrentExceptionAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExpressionEvaluationResult)
public:
virtual Task<ExpressionEvaluationResult^>^ EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateCurrentExceptionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>
override EvaluateCurrentExceptionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExpressionEvaluationResult

Implements

IScriptDebuggerBaseEvaluateCurrentExceptionAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.EvaluateExpressionAsync Method

ScriptDebuggerEvaluateExpressionAsync Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ExpressionEvaluationResult> EvaluateExpressionAsync(
    ExpressionEvaluationRequest request,
    CancellationToken cancellationToken = null
)
Public Function EvaluateExpressionAsync (
    request As ExpressionEvaluationRequest,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExpressionEvaluationResult)
public:
virtual Task<ExpressionEvaluationResult^>^ EvaluateExpressionAsync(
    ExpressionEvaluationRequest^ request,
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateExpressionAsync :
        request : ExpressionEvaluationRequest *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>
override EvaluateExpressionAsync :
        request : ExpressionEvaluationRequest *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>

Parameters

request
Type: Alternet.Scripter.DebuggerExpressionEvaluationRequest
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExpressionEvaluationResult

Implements

IScriptDebuggerBaseEvaluateExpressionAsync(ExpressionEvaluationRequest, CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.EvaluateExpressionsAsync Method

ScriptDebuggerEvaluateExpressionsAsync Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<IEnumerable<ExpressionEvaluationResult>> EvaluateExpressionsAsync(
    IEnumerable<ExpressionEvaluationRequest> requests,
    CancellationToken cancellationToken = null
)
Public Function EvaluateExpressionsAsync (
    requests As IEnumerable(Of ExpressionEvaluationRequest),
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of IEnumerable(Of ExpressionEvaluationResult))
public:
virtual Task<IEnumerable<ExpressionEvaluationResult^>^>^ EvaluateExpressionsAsync(
    IEnumerable<ExpressionEvaluationRequest^>^ requests,
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateExpressionsAsync :
        requests : IEnumerable<ExpressionEvaluationRequest> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<IEnumerable<ExpressionEvaluationResult>>
override EvaluateExpressionsAsync :
        requests : IEnumerable<ExpressionEvaluationRequest> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<IEnumerable<ExpressionEvaluationResult>>

Parameters

requests
Type: System.Collections.GenericIEnumerableExpressionEvaluationRequest
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskIEnumerableExpressionEvaluationResult

Implements

IScriptDebuggerBaseEvaluateExpressionsAsync(IEnumerableExpressionEvaluationRequest, CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.GetExecutionPositionAsync Method

ScriptDebuggerGetExecutionPositionAsync Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ExecutionPosition> GetExecutionPositionAsync(
    CancellationToken cancellationToken = null
)
Public Function GetExecutionPositionAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExecutionPosition)
public:
virtual Task<ExecutionPosition^>^ GetExecutionPositionAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetExecutionPositionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExecutionPosition>
override GetExecutionPositionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExecutionPosition>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExecutionPosition

Implements

IScriptDebuggerBaseGetExecutionPositionAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.GetStackFramesAsync Method

ScriptDebuggerGetStackFramesAsync Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<StackFramesRetrievalResult> GetStackFramesAsync(
    CancellationToken cancellationToken = null
)
Public Function GetStackFramesAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of StackFramesRetrievalResult)
public:
virtual Task<StackFramesRetrievalResult^>^ GetStackFramesAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetStackFramesAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<StackFramesRetrievalResult>
override GetStackFramesAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<StackFramesRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskStackFramesRetrievalResult

Implements

IScriptDebuggerBaseGetStackFramesAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.GetThreadsAsync Method

ScriptDebuggerGetThreadsAsync Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ThreadsRetrievalResult> GetThreadsAsync(
    CancellationToken cancellationToken = null
)
Public Function GetThreadsAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ThreadsRetrievalResult)
public:
virtual Task<ThreadsRetrievalResult^>^ GetThreadsAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetThreadsAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ThreadsRetrievalResult>
override GetThreadsAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ThreadsRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskThreadsRetrievalResult

Implements

IScriptDebuggerBaseGetThreadsAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.GetVariablesInScopeAsync Method

ScriptDebuggerGetVariablesInScopeAsync Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<VariablesRetrievalResult> GetVariablesInScopeAsync(
    CancellationToken cancellationToken = null
)
Public Function GetVariablesInScopeAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of VariablesRetrievalResult)
public:
virtual Task<VariablesRetrievalResult^>^ GetVariablesInScopeAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetVariablesInScopeAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<VariablesRetrievalResult>
override GetVariablesInScopeAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<VariablesRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskVariablesRetrievalResult

Implements

IScriptDebuggerBaseGetVariablesInScopeAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.SetRunToPositionBreakpoint Method

ScriptDebuggerSetRunToPositionBreakpoint Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRunToPositionBreakpoint(
    RunToPositionBreakpoint breakpoint
)
Public Sub SetRunToPositionBreakpoint (
    breakpoint As RunToPositionBreakpoint
)
public:
virtual void SetRunToPositionBreakpoint(
    RunToPositionBreakpoint^ breakpoint
) sealed
abstract SetRunToPositionBreakpoint :
        breakpoint : RunToPositionBreakpoint -> unit
override SetRunToPositionBreakpoint :
        breakpoint : RunToPositionBreakpoint -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerRunToPositionBreakpoint

Implements

IScriptDebuggerBaseSetRunToPositionBreakpoint(RunToPositionBreakpoint)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.StartDebugging Method

ScriptDebuggerStartDebugging Method
Overload List
 | Name | Description
Public method | StartDebugging |
Public method | StartDebugging(StartDebuggingOptions) |
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.StartDebugging Method

ScriptDebuggerStartDebugging Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartDebugging()
Public Sub StartDebugging
public:
virtual void StartDebugging() sealed
abstract StartDebugging : unit -> unit
override StartDebugging : unit -> unit

Implements

IScriptDebuggerBaseStartDebugging
See Also

Reference

ScriptDebugger Class
StartDebugging Overload
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.StartDebugging Method (StartDebuggingOptions)

ScriptDebuggerStartDebugging Method (StartDebuggingOptions)

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartDebugging(
    StartDebuggingOptions options
)
Public Sub StartDebugging (
    options As StartDebuggingOptions
)
public:
virtual void StartDebugging(
    StartDebuggingOptions^ options
) sealed
abstract StartDebugging :
        options : StartDebuggingOptions -> unit
override StartDebugging :
        options : StartDebuggingOptions -> unit

Parameters

options
Type: Alternet.Scripter.DebuggerStartDebuggingOptions

Implements

IScriptDebuggerBaseStartDebugging(StartDebuggingOptions)
See Also

Reference

ScriptDebugger Class
StartDebugging Overload
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.StepInto Method

ScriptDebuggerStepInto Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StepInto()
Public Sub StepInto
public:
virtual void StepInto() sealed
abstract StepInto : unit -> unit
override StepInto : unit -> unit

Implements

IScriptDebuggerBaseStepInto
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.StepOut Method

ScriptDebuggerStepOut Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StepOut()
Public Sub StepOut
public:
virtual void StepOut() sealed
abstract StepOut : unit -> unit
override StepOut : unit -> unit

Implements

IScriptDebuggerBaseStepOut
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.StepOver Method

ScriptDebuggerStepOver Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StepOver()
Public Sub StepOver
public:
virtual void StepOver() sealed
abstract StepOver : unit -> unit
override StepOver : unit -> unit

Implements

IScriptDebuggerBaseStepOver
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.StopDebuggingAsync Method

ScriptDebuggerStopDebuggingAsync Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task StopDebuggingAsync(
    CancellationToken cancellationToken = null
)
Public Function StopDebuggingAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
public:
virtual Task^ StopDebuggingAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract StopDebuggingAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task
override StopDebuggingAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task

Implements

IScriptDebuggerBaseStopDebuggingAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.SwitchToStackFrame Method

ScriptDebuggerSwitchToStackFrame Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SwitchToStackFrame(
    StackFrame frame
)
Public Sub SwitchToStackFrame (
    frame As StackFrame
)
public:
virtual void SwitchToStackFrame(
    StackFrame^ frame
) sealed
abstract SwitchToStackFrame :
        frame : StackFrame -> unit
override SwitchToStackFrame :
        frame : StackFrame -> unit

Parameters

frame
Type: Alternet.Scripter.DebuggerStackFrame

Implements

IScriptDebuggerBaseSwitchToStackFrame(StackFrame)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.TrySetNextStatementAsync Method

ScriptDebuggerTrySetNextStatementAsync Method

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<Result> TrySetNextStatementAsync(
    int lineNumber,
    CancellationToken cancellationToken = null
)
Public Function TrySetNextStatementAsync (
    lineNumber As Integer,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Result)
public:
virtual Task<Result^>^ TrySetNextStatementAsync(
    int lineNumber,
    CancellationToken cancellationToken = nullptr
) sealed
abstract TrySetNextStatementAsync :
        lineNumber : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Result>
override TrySetNextStatementAsync :
        lineNumber : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Result>

Parameters

lineNumber
Type: SystemInt32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskResult

Implements

IScriptDebuggerBaseTrySetNextStatementAsync(Int32, CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger Properties

ScriptDebugger Properties

The ScriptDebugger type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Returns collection of debugger breakpoints.
Public property | Capabilities |
Public property | EventsSyncAction | Gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)
Public property | ExpressionEvaluator | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | IsStarted | Indicates whether debugging was started.
Public property | ScopeResolutionService | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | ScriptRun |
Public property | State | Gets current debugger state.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.Breakpoints Property

ScriptDebuggerBreakpoints Property
Returns collection of debugger breakpoints.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptBreakpoints Breakpoints { get; }
Public ReadOnly Property Breakpoints As IScriptBreakpoints
    Get
public:
virtual property IScriptBreakpoints^ Breakpoints {
    IScriptBreakpoints^ get () sealed;
}
abstract Breakpoints : IScriptBreakpoints with get
override Breakpoints : IScriptBreakpoints with get

Property Value

Type: IScriptBreakpoints

Implements

IScriptDebuggerBaseBreakpoints
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.Capabilities Property

ScriptDebuggerCapabilities Property

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerCapabilities Capabilities { get; }
Public ReadOnly Property Capabilities As DebuggerCapabilities
    Get
public:
virtual property DebuggerCapabilities Capabilities {
    DebuggerCapabilities get () sealed;
}
abstract Capabilities : DebuggerCapabilities with get
override Capabilities : DebuggerCapabilities with get

Property Value

Type: DebuggerCapabilities

Implements

IScriptDebuggerBaseCapabilities
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.EventsSyncAction Property

ScriptDebuggerEventsSyncAction Property
Gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action<Delegate> EventsSyncAction { get; set; }
Public Property EventsSyncAction As Action(Of Delegate)
    Get
    Set
public:
virtual property Action<Delegate^>^ EventsSyncAction {
    Action<Delegate^>^ get () sealed;
    void set (Action<Delegate^>^ value) sealed;
}
abstract EventsSyncAction : Action<Delegate> with get, set
override EventsSyncAction : Action<Delegate> with get, set

Property Value

Type: ActionDelegate

Implements

IScriptDebuggerBaseEventsSyncAction
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.ExpressionEvaluator Property

ScriptDebuggerExpressionEvaluator Property
Gets IExpressionEvaluator object used to evaluate expressions.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IExpressionEvaluator ExpressionEvaluator { get; }
Public ReadOnly Property ExpressionEvaluator As IExpressionEvaluator
    Get
public:
virtual property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get () sealed;
}
abstract ExpressionEvaluator : IExpressionEvaluator with get
override ExpressionEvaluator : IExpressionEvaluator with get

Property Value

Type: IExpressionEvaluator

Implements

IScriptDebuggerBaseExpressionEvaluator
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.IsStarted Property

ScriptDebuggerIsStarted Property
Indicates whether debugging was started.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStarted { get; }
Public ReadOnly Property IsStarted As Boolean
    Get
public:
virtual property bool IsStarted {
    bool get () sealed;
}
abstract IsStarted : bool with get
override IsStarted : bool with get

Property Value

Type: Boolean

Implements

IScriptDebuggerBaseIsStarted
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.ScopeResolutionService Property

ScriptDebuggerScopeResolutionService Property
Gets IExpressionEvaluator object used to evaluate expressions.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScopeResolutionService ScopeResolutionService { get; }
Public ReadOnly Property ScopeResolutionService As IScopeResolutionService
    Get
public:
virtual property IScopeResolutionService^ ScopeResolutionService {
    IScopeResolutionService^ get () sealed;
}
abstract ScopeResolutionService : IScopeResolutionService with get
override ScopeResolutionService : IScopeResolutionService with get

Property Value

Type: IScopeResolutionService

Implements

IScriptDebuggerBaseScopeResolutionService
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.ScriptRun Property

ScriptDebuggerScriptRun Property

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptRun ScriptRun { get; set; }
Public Property ScriptRun As IScriptRun
    Get
    Set
public:
property IScriptRun^ ScriptRun {
    IScriptRun^ get ();
    void set (IScriptRun^ value);
}
member ScriptRun : IScriptRun with get, set

Property Value

Type: IScriptRun
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.State Property

ScriptDebuggerState Property
Gets current debugger state.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerState State { get; }
Public ReadOnly Property State As DebuggerState
    Get
public:
virtual property DebuggerState State {
    DebuggerState get () sealed;
}
abstract State : DebuggerState with get
override State : DebuggerState with get

Property Value

Type: DebuggerState

Implements

IScriptDebuggerBaseState
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger Events

ScriptDebugger Events

The ScriptDebugger type exposes the following members.

Events
 | Name | Description
Public event | ActiveThreadChanged |
Public event | BeforeContinue | Occurs before debugger continues to program execution.
Public event | BeforeStep | Occurs before debugger performs a step.
Public event | BeforeStop | Occurs before debugger stop debugging.
Public event | DebuggerErrorOccured |
Public event | DebuggingStarted |
Public event | DebuggingStopped |
Public event | ExecutionResumed |
Public event | ExecutionStopped |
Public event | LogMessageReceived |
Public event | StackFrameSwitched |
Public event | StateChanged |
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.ActiveThreadChanged Event

ScriptDebuggerActiveThreadChanged Event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ActiveThreadChangedEventArgs> ActiveThreadChanged
Public Event ActiveThreadChanged As EventHandler(Of ActiveThreadChangedEventArgs)
public:
virtual  event EventHandler<ActiveThreadChangedEventArgs^>^ ActiveThreadChanged {
    void add (EventHandler<ActiveThreadChangedEventArgs^>^ value);
    void remove (EventHandler<ActiveThreadChangedEventArgs^>^ value);
}
abstract ActiveThreadChanged : IEvent<EventHandler<ActiveThreadChangedEventArgs>,
    ActiveThreadChangedEventArgs>
override ActiveThreadChanged : IEvent<EventHandler<ActiveThreadChangedEventArgs>,
    ActiveThreadChangedEventArgs>

Value

Type: SystemEventHandlerActiveThreadChangedEventArgs

Implements

IScriptDebuggerBaseActiveThreadChanged
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.BeforeContinue Event

ScriptDebuggerBeforeContinue Event
Occurs before debugger continues to program execution.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BeforeContinue
Public Event BeforeContinue As EventHandler
public:
virtual  event EventHandler^ BeforeContinue {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeContinue : IEvent<EventHandler,
    EventArgs>
override BeforeContinue : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptDebuggerBaseBeforeContinue
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.BeforeStep Event

ScriptDebuggerBeforeStep Event
Occurs before debugger performs a step.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BeforeStep
Public Event BeforeStep As EventHandler
public:
virtual  event EventHandler^ BeforeStep {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeStep : IEvent<EventHandler,
    EventArgs>
override BeforeStep : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptDebuggerBaseBeforeStep
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.BeforeStop Event

ScriptDebuggerBeforeStop Event
Occurs before debugger stop debugging.

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BeforeStop
Public Event BeforeStop As EventHandler
public:
virtual  event EventHandler^ BeforeStop {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeStop : IEvent<EventHandler,
    EventArgs>
override BeforeStop : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptDebuggerBaseBeforeStop
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.DebuggerErrorOccured Event

ScriptDebuggerDebuggerErrorOccured Event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggerErrorOccuredEventArgs> DebuggerErrorOccured
Public Event DebuggerErrorOccured As EventHandler(Of DebuggerErrorOccuredEventArgs)
public:
virtual  event EventHandler<DebuggerErrorOccuredEventArgs^>^ DebuggerErrorOccured {
    void add (EventHandler<DebuggerErrorOccuredEventArgs^>^ value);
    void remove (EventHandler<DebuggerErrorOccuredEventArgs^>^ value);
}
abstract DebuggerErrorOccured : IEvent<EventHandler<DebuggerErrorOccuredEventArgs>,
    DebuggerErrorOccuredEventArgs>
override DebuggerErrorOccured : IEvent<EventHandler<DebuggerErrorOccuredEventArgs>,
    DebuggerErrorOccuredEventArgs>

Value

Type: SystemEventHandlerDebuggerErrorOccuredEventArgs

Implements

IScriptDebuggerBaseDebuggerErrorOccured
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.DebuggingStarted Event

ScriptDebuggerDebuggingStarted Event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggingStartedEventArgs> DebuggingStarted
Public Event DebuggingStarted As EventHandler(Of DebuggingStartedEventArgs)
public:
virtual  event EventHandler<DebuggingStartedEventArgs^>^ DebuggingStarted {
    void add (EventHandler<DebuggingStartedEventArgs^>^ value);
    void remove (EventHandler<DebuggingStartedEventArgs^>^ value);
}
abstract DebuggingStarted : IEvent<EventHandler<DebuggingStartedEventArgs>,
    DebuggingStartedEventArgs>
override DebuggingStarted : IEvent<EventHandler<DebuggingStartedEventArgs>,
    DebuggingStartedEventArgs>

Value

Type: SystemEventHandlerDebuggingStartedEventArgs

Implements

IScriptDebuggerBaseDebuggingStarted
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.DebuggingStopped Event

ScriptDebuggerDebuggingStopped Event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggingStoppedEventArgs> DebuggingStopped
Public Event DebuggingStopped As EventHandler(Of DebuggingStoppedEventArgs)
public:
virtual  event EventHandler<DebuggingStoppedEventArgs^>^ DebuggingStopped {
    void add (EventHandler<DebuggingStoppedEventArgs^>^ value);
    void remove (EventHandler<DebuggingStoppedEventArgs^>^ value);
}
abstract DebuggingStopped : IEvent<EventHandler<DebuggingStoppedEventArgs>,
    DebuggingStoppedEventArgs>
override DebuggingStopped : IEvent<EventHandler<DebuggingStoppedEventArgs>,
    DebuggingStoppedEventArgs>

Value

Type: SystemEventHandlerDebuggingStoppedEventArgs

Implements

IScriptDebuggerBaseDebuggingStopped
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.ExecutionResumed Event

ScriptDebuggerExecutionResumed Event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ExecutionResumedEventArgs> ExecutionResumed
Public Event ExecutionResumed As EventHandler(Of ExecutionResumedEventArgs)
public:
virtual  event EventHandler<ExecutionResumedEventArgs^>^ ExecutionResumed {
    void add (EventHandler<ExecutionResumedEventArgs^>^ value);
    void remove (EventHandler<ExecutionResumedEventArgs^>^ value);
}
abstract ExecutionResumed : IEvent<EventHandler<ExecutionResumedEventArgs>,
    ExecutionResumedEventArgs>
override ExecutionResumed : IEvent<EventHandler<ExecutionResumedEventArgs>,
    ExecutionResumedEventArgs>

Value

Type: SystemEventHandlerExecutionResumedEventArgs

Implements

IScriptDebuggerBaseExecutionResumed
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.ExecutionStopped Event

ScriptDebuggerExecutionStopped Event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ExecutionStoppedEventArgs> ExecutionStopped
Public Event ExecutionStopped As EventHandler(Of ExecutionStoppedEventArgs)
public:
virtual  event EventHandler<ExecutionStoppedEventArgs^>^ ExecutionStopped {
    void add (EventHandler<ExecutionStoppedEventArgs^>^ value);
    void remove (EventHandler<ExecutionStoppedEventArgs^>^ value);
}
abstract ExecutionStopped : IEvent<EventHandler<ExecutionStoppedEventArgs>,
    ExecutionStoppedEventArgs>
override ExecutionStopped : IEvent<EventHandler<ExecutionStoppedEventArgs>,
    ExecutionStoppedEventArgs>

Value

Type: SystemEventHandlerExecutionStoppedEventArgs

Implements

IScriptDebuggerBaseExecutionStopped
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.LogMessageReceived Event

ScriptDebuggerLogMessageReceived Event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<LogMessageReceivedEventArgs> LogMessageReceived
Public Event LogMessageReceived As EventHandler(Of LogMessageReceivedEventArgs)
public:
virtual  event EventHandler<LogMessageReceivedEventArgs^>^ LogMessageReceived {
    void add (EventHandler<LogMessageReceivedEventArgs^>^ value);
    void remove (EventHandler<LogMessageReceivedEventArgs^>^ value);
}
abstract LogMessageReceived : IEvent<EventHandler<LogMessageReceivedEventArgs>,
    LogMessageReceivedEventArgs>
override LogMessageReceived : IEvent<EventHandler<LogMessageReceivedEventArgs>,
    LogMessageReceivedEventArgs>

Value

Type: SystemEventHandlerLogMessageReceivedEventArgs

Implements

IScriptDebuggerBaseLogMessageReceived
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.StackFrameSwitched Event

ScriptDebuggerStackFrameSwitched Event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<StackFrameSwitchedEventArgs> StackFrameSwitched
Public Event StackFrameSwitched As EventHandler(Of StackFrameSwitchedEventArgs)
public:
virtual  event EventHandler<StackFrameSwitchedEventArgs^>^ StackFrameSwitched {
    void add (EventHandler<StackFrameSwitchedEventArgs^>^ value);
    void remove (EventHandler<StackFrameSwitchedEventArgs^>^ value);
}
abstract StackFrameSwitched : IEvent<EventHandler<StackFrameSwitchedEventArgs>,
    StackFrameSwitchedEventArgs>
override StackFrameSwitched : IEvent<EventHandler<StackFrameSwitchedEventArgs>,
    StackFrameSwitchedEventArgs>

Value

Type: SystemEventHandlerStackFrameSwitchedEventArgs

Implements

IScriptDebuggerBaseStackFrameSwitched
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptDebugger.StateChanged Event

ScriptDebuggerStateChanged Event

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggerStateChangedEventArgs> StateChanged
Public Event StateChanged As EventHandler(Of DebuggerStateChangedEventArgs)
public:
virtual  event EventHandler<DebuggerStateChangedEventArgs^>^ StateChanged {
    void add (EventHandler<DebuggerStateChangedEventArgs^>^ value);
    void remove (EventHandler<DebuggerStateChangedEventArgs^>^ value);
}
abstract StateChanged : IEvent<EventHandler<DebuggerStateChangedEventArgs>,
    DebuggerStateChangedEventArgs>
override StateChanged : IEvent<EventHandler<DebuggerStateChangedEventArgs>,
    DebuggerStateChangedEventArgs>

Value

Type: SystemEventHandlerDebuggerStateChangedEventArgs

Implements

IScriptDebuggerBaseStateChanged
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptTerminatedException Class

ScriptTerminatedException Class
Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
SystemOperationCanceledException
Alternet.Scripter.Debugger.IronPythonScriptTerminatedException

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptTerminatedException : OperationCanceledException
Public Class ScriptTerminatedException
    Inherits OperationCanceledException
public ref class ScriptTerminatedException : public OperationCanceledException
type ScriptTerminatedException =
    class
        inherit OperationCanceledException
    end

The ScriptTerminatedException type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptTerminatedException | Initializes a new instance of the ScriptTerminatedException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | CancellationToken | Gets a token associated with the operation that was canceled. (Inherited from OperationCanceledException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

Alternet.Scripter.Debugger.IronPython Namespace


ScriptTerminatedException Constructor

ScriptTerminatedException Constructor
Initializes a new instance of the ScriptTerminatedException class

Namespace: Alternet.Scripter.Debugger.IronPython
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptTerminatedException()
Public Sub New
public:
ScriptTerminatedException()
new : unit -> ScriptTerminatedException
See Also

Reference

ScriptTerminatedException Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptTerminatedException Methods

ScriptTerminatedException Methods

The ScriptTerminatedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ScriptTerminatedException Class
Alternet.Scripter.Debugger.IronPython Namespace


ScriptTerminatedException Properties

ScriptTerminatedException Properties

The ScriptTerminatedException type exposes the following members.

Properties
 | Name | Description
Public property | CancellationToken | Gets a token associated with the operation that was canceled. (Inherited from OperationCanceledException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ScriptTerminatedException Class
Alternet.Scripter.Debugger.IronPython Namespace


Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace

Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace
Classes
 | Class | Description
Public class | MemberValue |
Public class | ObjectValue |


MemberValue Class

MemberValue Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluationMemberValue

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MemberValue
Public Class MemberValue
public ref class MemberValue
type MemberValue =  class end

The MemberValue type exposes the following members.

Constructors
 | Name | Description
Public method | MemberValue | Initializes a new instance of the MemberValue class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Kind |
Public property | Name |
Public property | TypeName |
Public property | Value |
Public property | Visibility |
Top
See Also

Reference

Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


MemberValue Constructor

MemberValue Constructor
Initializes a new instance of the MemberValue class

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MemberValue(
    Object value,
    string name,
    string typeName,
    EvaluatedMemberKind kind,
    EvaluatedMemberVisibility visibility
)
Public Sub New (
    value As Object,
    name As String,
    typeName As String,
    kind As EvaluatedMemberKind,
    visibility As EvaluatedMemberVisibility
)
public:
MemberValue(
    Object^ value,
    String^ name,
    String^ typeName,
    EvaluatedMemberKind kind,
    EvaluatedMemberVisibility visibility
)
new :
        value : Object *
        name : string *
        typeName : string *
        kind : EvaluatedMemberKind *
        visibility : EvaluatedMemberVisibility -> MemberValue

Parameters

value
Type: SystemObject
name
Type: SystemString
typeName
Type: SystemString
kind
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberKind
visibility
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluatedMemberVisibility
See Also

Reference

MemberValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


MemberValue Methods

MemberValue Methods

The MemberValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MemberValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


MemberValue Properties

MemberValue Properties

The MemberValue type exposes the following members.

Properties
 | Name | Description
Public property | Kind |
Public property | Name |
Public property | TypeName |
Public property | Value |
Public property | Visibility |
Top
See Also

Reference

MemberValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


MemberValue.Kind Property

MemberValueKind Property

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluatedMemberKind Kind { get; }
Public ReadOnly Property Kind As EvaluatedMemberKind
    Get
public:
property EvaluatedMemberKind Kind {
    EvaluatedMemberKind get ();
}
member Kind : EvaluatedMemberKind with get

Property Value

Type: EvaluatedMemberKind
See Also

Reference

MemberValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


MemberValue.Name Property

MemberValueName Property

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

MemberValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


MemberValue.TypeName Property

MemberValueTypeName Property

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

Type: String
See Also

Reference

MemberValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


MemberValue.Value Property

MemberValueValue Property

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
public:
property Object^ Value {
    Object^ get ();
}
member Value : Object with get

Property Value

Type: Object
See Also

Reference

MemberValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


MemberValue.Visibility Property

MemberValueVisibility Property

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluatedMemberVisibility Visibility { get; }
Public ReadOnly Property Visibility As EvaluatedMemberVisibility
    Get
public:
property EvaluatedMemberVisibility Visibility {
    EvaluatedMemberVisibility get ();
}
member Visibility : EvaluatedMemberVisibility with get

Property Value

Type: EvaluatedMemberVisibility
See Also

Reference

MemberValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


ObjectValue Class

ObjectValue Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.ExpressionEvaluationDebuggerValue
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluationObjectValue

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ObjectValue : DebuggerValue
Public Class ObjectValue
    Inherits DebuggerValue
public ref class ObjectValue : public DebuggerValue
type ObjectValue =
    class
        inherit DebuggerValue
    end

The ObjectValue type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectValue | Initializes a new instance of the ObjectValue class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsArrayType | (Overrides DebuggerValueIsArrayType.)
Public property | Name | (Overrides DebuggerValueName.)
Public property | Value |
Top
See Also

Reference

Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


ObjectValue Constructor

ObjectValue Constructor
Initializes a new instance of the ObjectValue class

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ObjectValue(
    Object value,
    string name
)
Public Sub New (
    value As Object,
    name As String
)
public:
ObjectValue(
    Object^ value,
    String^ name
)
new :
        value : Object *
        name : string -> ObjectValue

Parameters

value
Type: SystemObject
name
Type: SystemString
See Also

Reference

ObjectValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


ObjectValue Methods

ObjectValue Methods

The ObjectValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ObjectValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


ObjectValue Properties

ObjectValue Properties

The ObjectValue type exposes the following members.

Properties
 | Name | Description
Public property | IsArrayType | (Overrides DebuggerValueIsArrayType.)
Public property | Name | (Overrides DebuggerValueName.)
Public property | Value |
Top
See Also

Reference

ObjectValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


ObjectValue.IsArrayType Property

ObjectValueIsArrayType Property

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsArrayType { get; }
Public Overrides ReadOnly Property IsArrayType As Boolean
    Get
public:
virtual property bool IsArrayType {
    bool get () override;
}
abstract IsArrayType : bool with get
override IsArrayType : bool with get

Property Value

Type: Boolean
See Also

Reference

ObjectValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


ObjectValue.Name Property

ObjectValueName Property

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String
See Also

Reference

ObjectValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


ObjectValue.Value Property

ObjectValueValue Property

Namespace: Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation
Assembly: Alternet.Scripter.IronPython.Debugger.v7 (in Alternet.Scripter.IronPython.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
public:
property Object^ Value {
    Object^ get ();
}
member Value : Object with get

Property Value

Type: Object
See Also

Reference

ObjectValue Class
Alternet.Scripter.Debugger.IronPython.ExpressionEvaluation Namespace


Alternet.Scripter.Debugger.TypeScript Namespace

Alternet.Scripter.Debugger.TypeScript Namespace
Classes
 | Class | Description
Public class | ErrorMessages | Contains default string constants related to debugger errors.
Public class | ScriptBreakpoints | Provides list of Breakpoint objects.
Public class | ScriptDebugger | Enables communication with a debugger.
Public class | ScriptDebuggerChromeSessionInfo | Provides data for the particular Internet session.
Interfaces
 | Interface | Description
Public interface | IScriptDebugger | Provides methods and properties that allow developers to debug applications in the common language runtime (CLR) environment.


ErrorMessages Class

ErrorMessages Class
Contains default string constants related to debugger errors.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.TypeScriptErrorMessages

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ErrorMessages
Public Class ErrorMessages
public ref class ErrorMessages
type ErrorMessages =  class end

The ErrorMessages type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorMessages | Initializes a new instance of the ErrorMessages class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
UnableToEvaluteExpressionWhenNotStarted |
UnableToEvaluteExpressionWhileRunning |
Top
See Also

Reference

Alternet.Scripter.Debugger.TypeScript Namespace


ErrorMessages Constructor

ErrorMessages Constructor
Initializes a new instance of the ErrorMessages class

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ErrorMessages()
Public Sub New
public:
ErrorMessages()
new : unit -> ErrorMessages
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.TypeScript Namespace


ErrorMessages Fields

ErrorMessages Fields

The ErrorMessages type exposes the following members.

Fields
Name | Description
UnableToEvaluteExpressionWhenNotStarted |
UnableToEvaluteExpressionWhileRunning |
Top
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.TypeScript Namespace


ErrorMessages.UnableToEvaluteExpressionWhenNotStarted Field

ErrorMessagesUnableToEvaluteExpressionWhenNotStarted Field

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string UnableToEvaluteExpressionWhenNotStarted
Public Const UnableToEvaluteExpressionWhenNotStarted As String
public:
literal String^ UnableToEvaluteExpressionWhenNotStarted
static val mutable UnableToEvaluteExpressionWhenNotStarted: string

Field Value

Type: String
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.TypeScript Namespace


ErrorMessages.UnableToEvaluteExpressionWhileRunning Field

ErrorMessagesUnableToEvaluteExpressionWhileRunning Field

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string UnableToEvaluteExpressionWhileRunning
Public Const UnableToEvaluteExpressionWhileRunning As String
public:
literal String^ UnableToEvaluteExpressionWhileRunning
static val mutable UnableToEvaluteExpressionWhileRunning: string

Field Value

Type: String
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.TypeScript Namespace


ErrorMessages Methods

ErrorMessages Methods

The ErrorMessages type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorMessages Class
Alternet.Scripter.Debugger.TypeScript Namespace


IScriptDebugger Interface

IScriptDebugger Interface
Provides methods and properties that allow developers to debug applications in the common language runtime (CLR) environment.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptDebugger : IScriptDebuggerBase
Public Interface IScriptDebugger
    Inherits IScriptDebuggerBase
public interface class IScriptDebugger : IScriptDebuggerBase
type IScriptDebugger =
    interface
        interface IScriptDebuggerBase
    end

The IScriptDebugger type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | When implemented by a class, switches debugging to the specified thread. (Inherited from IScriptDebuggerBase.)
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed. (Inherited from IScriptDebuggerBase.)
Public method | ClearTemporaryGeneratedModules | When implemented by a class, clears temporary generated modules on disk. (Inherited from IScriptDebuggerBase.)
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionsAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | GetExecutionPositionAsync | When implemented by a class, finds out current ExecutionPosition based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | GetStackFramesAsync | When implemented by a class, gets list of method calls that are currently on a stack (Inherited from IScriptDebuggerBase.)
Public method | GetThreadsAsync | When implemented by a class, gets list of active threads. (Inherited from IScriptDebuggerBase.)
Public method | GetVariablesInScopeAsync | When implemented by a class, receives all local variables based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | SetRunToPositionBreakpoint | When implemented by a class, causes debugger to stop at the specified position. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging | When implemented by a class, starts executing the program from the entry point with default settings. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging(StartDebuggingOptions) | When implemented by a class, starts executing the program from the entry point with specified settings. (Inherited from IScriptDebuggerBase.)
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible. (Inherited from IScriptDebuggerBase.)
Public method | StepOut | When implemented by a class, executes one statement of code; steps out of the function currently being executed. (Inherited from IScriptDebuggerBase.)
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call. (Inherited from IScriptDebuggerBase.)
Public method | StopDebuggingAsync | When implemented by a class, stops executing the program. (Inherited from IScriptDebuggerBase.)
Public method | SwitchToStackFrame | When implemented by a class, switches debugging to the given stack frame. (Inherited from IScriptDebuggerBase.)
Public method | TrySetNextStatementAsync | When implemented by a class, tries to set the execution point to the specified line of code. (Inherited from IScriptDebuggerBase.)
Top
Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, returns collection of debugger breakpoints. (Inherited from IScriptDebuggerBase.)
Public property | Capabilities | When implemented by a class, gets debugger capabilities. (Inherited from IScriptDebuggerBase.)
Public property | EventsSyncAction | When implemented by a class, gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke) (Inherited from IScriptDebuggerBase.)
Public property | ExpressionEvaluator | When implemented by a class, gets IExpressionEvaluator object used to evaluate expressions. (Inherited from IScriptDebuggerBase.)
Public property | IsStarted | When implemented by a class, indicates whether debugging was started. (Inherited from IScriptDebuggerBase.)
Public property | ScopeResolutionService | When implemented by a class, gets IScopeResolutionService object used to evaluate method names and parameters. (Inherited from IScriptDebuggerBase.)
Public property | ScriptRun | When implemented by a class, contains all information required to compile and run the script
Public property | State | When implemented by a class, gets current debugger state. (Inherited from IScriptDebuggerBase.)
Top
Events
 | Name | Description
Public event | ActiveThreadChanged | When implemented by a class, occurs when thread to be debugged changes. (Inherited from IScriptDebuggerBase.)
Public event | BeforeContinue | When implemented by a class, occurs before debugger continues to program execution. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStep | When implemented by a class, occurs before debugger performs a step. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStop | When implemented by a class, occurs before debugger stop debugging. (Inherited from IScriptDebuggerBase.)
Public event | DebuggerErrorOccured | When implemented by a class, occurs when encounters error during debugging session. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStarted | When implemented by a class, occurs when debugging session is started. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStopped | When implemented by a class, occurs when debugging session is stopped. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionResumed | When implemented by a class, occurs when debugging is resumed after being paused. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionStopped | When implemented by a class, occurs when debugging is paused. (Inherited from IScriptDebuggerBase.)
Public event | LogMessageReceived | When implemented by a class, occurs when debug message is received. (Inherited from IScriptDebuggerBase.)
Public event | StackFrameSwitched | When implemented by a class, occurs debugger switches to the stack frame (Inherited from IScriptDebuggerBase.)
Public event | StateChanged | When implemented by a class, occurs when debugger state is changed. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

Alternet.Scripter.Debugger.TypeScript Namespace


IScriptDebugger Methods

IScriptDebugger Methods

The IScriptDebugger type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | When implemented by a class, switches debugging to the specified thread. (Inherited from IScriptDebuggerBase.)
Public method | Break | When implemented by a class, causes the given process to pause its execution so that its current state can be analyzed. (Inherited from IScriptDebuggerBase.)
Public method | ClearTemporaryGeneratedModules | When implemented by a class, clears temporary generated modules on disk. (Inherited from IScriptDebuggerBase.)
Public method | Continue | When implemented by a class, continues given process to the next breakpoint or until process finishes. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateCurrentExceptionAsync | When implemented by a class, evaluates current expression based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | EvaluateExpressionsAsync | When implemented by a class, evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value. (Inherited from IScriptDebuggerBase.)
Public method | GetExecutionPositionAsync | When implemented by a class, finds out current ExecutionPosition based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | GetStackFramesAsync | When implemented by a class, gets list of method calls that are currently on a stack (Inherited from IScriptDebuggerBase.)
Public method | GetThreadsAsync | When implemented by a class, gets list of active threads. (Inherited from IScriptDebuggerBase.)
Public method | GetVariablesInScopeAsync | When implemented by a class, receives all local variables based on the current stack frame. (Inherited from IScriptDebuggerBase.)
Public method | SetRunToPositionBreakpoint | When implemented by a class, causes debugger to stop at the specified position. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging | When implemented by a class, starts executing the program from the entry point with default settings. (Inherited from IScriptDebuggerBase.)
Public method | StartDebugging(StartDebuggingOptions) | When implemented by a class, starts executing the program from the entry point with specified settings. (Inherited from IScriptDebuggerBase.)
Public method | StepInto | When implemented by a class, executes one statement of code; steps into the next function call, if possible. (Inherited from IScriptDebuggerBase.)
Public method | StepOut | When implemented by a class, executes one statement of code; steps out of the function currently being executed. (Inherited from IScriptDebuggerBase.)
Public method | StepOver | When implemented by a class, executes one statement of code; steps over the next function call. (Inherited from IScriptDebuggerBase.)
Public method | StopDebuggingAsync | When implemented by a class, stops executing the program. (Inherited from IScriptDebuggerBase.)
Public method | SwitchToStackFrame | When implemented by a class, switches debugging to the given stack frame. (Inherited from IScriptDebuggerBase.)
Public method | TrySetNextStatementAsync | When implemented by a class, tries to set the execution point to the specified line of code. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger.TypeScript Namespace


IScriptDebugger Properties

IScriptDebugger Properties

The IScriptDebugger type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | When implemented by a class, returns collection of debugger breakpoints. (Inherited from IScriptDebuggerBase.)
Public property | Capabilities | When implemented by a class, gets debugger capabilities. (Inherited from IScriptDebuggerBase.)
Public property | EventsSyncAction | When implemented by a class, gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke) (Inherited from IScriptDebuggerBase.)
Public property | ExpressionEvaluator | When implemented by a class, gets IExpressionEvaluator object used to evaluate expressions. (Inherited from IScriptDebuggerBase.)
Public property | IsStarted | When implemented by a class, indicates whether debugging was started. (Inherited from IScriptDebuggerBase.)
Public property | ScopeResolutionService | When implemented by a class, gets IScopeResolutionService object used to evaluate method names and parameters. (Inherited from IScriptDebuggerBase.)
Public property | ScriptRun | When implemented by a class, contains all information required to compile and run the script
Public property | State | When implemented by a class, gets current debugger state. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger.TypeScript Namespace


IScriptDebugger.ScriptRun Property

IScriptDebuggerScriptRun Property
When implemented by a class, contains all information required to compile and run the script

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptRun ScriptRun { get; }
ReadOnly Property ScriptRun As IScriptRun
    Get
property IScriptRun^ ScriptRun {
    IScriptRun^ get ();
}
abstract ScriptRun : IScriptRun with get

Property Value

Type: IScriptRun
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger.TypeScript Namespace


IScriptDebugger Events

IScriptDebugger Events

The IScriptDebugger type exposes the following members.

Events
 | Name | Description
Public event | ActiveThreadChanged | When implemented by a class, occurs when thread to be debugged changes. (Inherited from IScriptDebuggerBase.)
Public event | BeforeContinue | When implemented by a class, occurs before debugger continues to program execution. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStep | When implemented by a class, occurs before debugger performs a step. (Inherited from IScriptDebuggerBase.)
Public event | BeforeStop | When implemented by a class, occurs before debugger stop debugging. (Inherited from IScriptDebuggerBase.)
Public event | DebuggerErrorOccured | When implemented by a class, occurs when encounters error during debugging session. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStarted | When implemented by a class, occurs when debugging session is started. (Inherited from IScriptDebuggerBase.)
Public event | DebuggingStopped | When implemented by a class, occurs when debugging session is stopped. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionResumed | When implemented by a class, occurs when debugging is resumed after being paused. (Inherited from IScriptDebuggerBase.)
Public event | ExecutionStopped | When implemented by a class, occurs when debugging is paused. (Inherited from IScriptDebuggerBase.)
Public event | LogMessageReceived | When implemented by a class, occurs when debug message is received. (Inherited from IScriptDebuggerBase.)
Public event | StackFrameSwitched | When implemented by a class, occurs debugger switches to the stack frame (Inherited from IScriptDebuggerBase.)
Public event | StateChanged | When implemented by a class, occurs when debugger state is changed. (Inherited from IScriptDebuggerBase.)
Top
See Also

Reference

IScriptDebugger Interface
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints Class

ScriptBreakpoints Class
Provides list of Breakpoint objects.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.TypeScriptScriptBreakpoints

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptBreakpoints : IScriptBreakpoints,
    IUpdate
Public Class ScriptBreakpoints
    Implements IScriptBreakpoints, IUpdate
public ref class ScriptBreakpoints : IScriptBreakpoints,
    IUpdate
type ScriptBreakpoints =
    class
        interface IScriptBreakpoints
        interface IUpdate
    end

The ScriptBreakpoints type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptBreakpoints | Initializes a new instance of the ScriptBreakpoints class with corresponds to specified ScriptDebugger object.
Top
Methods
 | Name | Description
Public method | AddBreakpoint | Adds a Breakpoint to the list.
Public method | BeginUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Clear | Removes all breakpoints.
Public method | DisableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EnableBreakpoint | Enables or disables specified breakpoint.
Public method | EnableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveBreakpoint | Removes a Breakpoint from the list.
Public method | RemoveBreakpoints | Removes several Breakpoint from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Raises Changed event
Top
Properties
 | Name | Description
Public property | Breakpoints | Gets an array of Breakpoint objects.
Public property | Debugger | Represents ScriptDebugger owner of this ScriptBreakpoints.
Public property | UpdateCount |
Top
Events
 | Name | Description
Public event | BreakpointAdded | Occurs when a breakpoint is added.
Public event | BreakpointRemoved | Occurs when a breakpoint is removed.
Public event | BreakpointStateChanged | Occurs when a breakpoint state is changed.
Public event | Changed | Occurs when breakpoints are changed.
Top
See Also

Reference

Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints Constructor

ScriptBreakpoints Constructor
Initializes a new instance of the ScriptBreakpoints class with corresponds to specified ScriptDebugger object.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptBreakpoints(
    ScriptDebugger debugger
)
Public Sub New (
    debugger As ScriptDebugger
)
public:
ScriptBreakpoints(
    ScriptDebugger^ debugger
)
new :
        debugger : ScriptDebugger -> ScriptBreakpoints

Parameters

debugger
Type: Alternet.Scripter.Debugger.TypeScriptScriptDebugger
ScriptDebugger that owns this new instance.
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints Methods

ScriptBreakpoints Methods

The ScriptBreakpoints type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint | Adds a Breakpoint to the list.
Public method | BeginUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Clear | Removes all breakpoints.
Public method | DisableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EnableBreakpoint | Enables or disables specified breakpoint.
Public method | EnableUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveBreakpoint | Removes a Breakpoint from the list.
Public method | RemoveBreakpoints | Removes several Breakpoint from the list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Raises Changed event
Top
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.AddBreakpoint Method

ScriptBreakpointsAddBreakpoint Method
Adds a Breakpoint to the list.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddBreakpoint(
    string filePath,
    int lineNumber
)
Public Sub AddBreakpoint (
    filePath As String,
    lineNumber As Integer
)
public:
virtual void AddBreakpoint(
    String^ filePath,
    int lineNumber
) sealed
abstract AddBreakpoint :
        filePath : string *
        lineNumber : int -> unit
override AddBreakpoint :
        filePath : string *
        lineNumber : int -> unit

Parameters

filePath
Type: SystemString
Name of file where breakpoint is set.
lineNumber
Type: SystemInt32
Number of line at which breakpoint is set.

Implements

IScriptBreakpointsAddBreakpoint(String, Int32)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.BeginUpdate Method

ScriptBreakpointsBeginUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BeginUpdate()
Public Function BeginUpdate As Integer
public:
virtual int BeginUpdate() sealed
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateBeginUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.Clear Method

ScriptBreakpointsClear Method
Removes all breakpoints.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IScriptBreakpointsClear
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.DisableUpdate Method

ScriptBreakpointsDisableUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DisableUpdate()
Public Function DisableUpdate As Integer
public:
virtual int DisableUpdate() sealed
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateDisableUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.EnableBreakpoint Method

ScriptBreakpointsEnableBreakpoint Method
Enables or disables specified breakpoint.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableBreakpoint(
    Breakpoint breakpoint,
    bool enable
)
Public Sub EnableBreakpoint (
    breakpoint As Breakpoint,
    enable As Boolean
)
public:
virtual void EnableBreakpoint(
    Breakpoint^ breakpoint,
    bool enable
) sealed
abstract EnableBreakpoint :
        breakpoint : Breakpoint *
        enable : bool -> unit
override EnableBreakpoint :
        breakpoint : Breakpoint *
        enable : bool -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
Breakpoint to process.
enable
Type: SystemBoolean
New breakpoint's state.

Implements

IScriptBreakpointsEnableBreakpoint(Breakpoint, Boolean)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.EnableUpdate Method

ScriptBreakpointsEnableUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EnableUpdate()
Public Function EnableUpdate As Integer
public:
virtual int EnableUpdate() sealed
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateEnableUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.EndUpdate Method

ScriptBreakpointsEndUpdate Method
Maintains performance while breakpoints are added/removed one at a time by preventing the Changed event from being fired.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndUpdate()
Public Function EndUpdate As Integer
public:
virtual int EndUpdate() sealed
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateEndUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.RemoveBreakpoint Method

ScriptBreakpointsRemoveBreakpoint Method
Removes a Breakpoint from the list.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveBreakpoint(
    Breakpoint breakpoint
)
Public Function RemoveBreakpoint (
    breakpoint As Breakpoint
) As Boolean
public:
virtual bool RemoveBreakpoint(
    Breakpoint^ breakpoint
) sealed
abstract RemoveBreakpoint :
        breakpoint : Breakpoint -> bool
override RemoveBreakpoint :
        breakpoint : Breakpoint -> bool

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
The Breakpoint to remove from the list.

Return Value

Type: Boolean

Implements

IScriptBreakpointsRemoveBreakpoint(Breakpoint)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.RemoveBreakpoints Method

ScriptBreakpointsRemoveBreakpoints Method
Removes several Breakpoint from the list.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveBreakpoints(
    IList<Breakpoint> breakpoints
)
Public Sub RemoveBreakpoints (
    breakpoints As IList(Of Breakpoint)
)
public:
virtual void RemoveBreakpoints(
    IList<Breakpoint^>^ breakpoints
) sealed
abstract RemoveBreakpoints :
        breakpoints : IList<Breakpoint> -> unit
override RemoveBreakpoints :
        breakpoints : IList<Breakpoint> -> unit

Parameters

breakpoints
Type: System.Collections.GenericIListBreakpoint
The number of Breakpoint to remove from the list.

Implements

IScriptBreakpointsRemoveBreakpoints(IListBreakpoint)
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.Update Method

ScriptBreakpointsUpdate Method
Raises Changed event

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints Properties

ScriptBreakpoints Properties

The ScriptBreakpoints type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Gets an array of Breakpoint objects.
Public property | Debugger | Represents ScriptDebugger owner of this ScriptBreakpoints.
Public property | UpdateCount |
Top
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.Breakpoints Property

ScriptBreakpointsBreakpoints Property
Gets an array of Breakpoint objects.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoint[] Breakpoints { get; }
Public ReadOnly Property Breakpoints As Breakpoint()
    Get
public:
virtual property array<Breakpoint^>^ Breakpoints {
    array<Breakpoint^>^ get () sealed;
}
abstract Breakpoints : Breakpoint[] with get
override Breakpoints : Breakpoint[] with get

Property Value

Type: Breakpoint

Implements

IScriptBreakpointsBreakpoints
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.Debugger Property

ScriptBreakpointsDebugger Property
Represents ScriptDebugger owner of this ScriptBreakpoints.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptDebugger Debugger { get; }
Public ReadOnly Property Debugger As ScriptDebugger
    Get
public:
property ScriptDebugger^ Debugger {
    ScriptDebugger^ get ();
}
member Debugger : ScriptDebugger with get

Property Value

Type: ScriptDebugger
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.UpdateCount Property

ScriptBreakpointsUpdateCount Property

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UpdateCount { get; }
Public ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get () sealed;
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints Events

ScriptBreakpoints Events

The ScriptBreakpoints type exposes the following members.

Events
 | Name | Description
Public event | BreakpointAdded | Occurs when a breakpoint is added.
Public event | BreakpointRemoved | Occurs when a breakpoint is removed.
Public event | BreakpointStateChanged | Occurs when a breakpoint state is changed.
Public event | Changed | Occurs when breakpoints are changed.
Top
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.BreakpointAdded Event

ScriptBreakpointsBreakpointAdded Event
Occurs when a breakpoint is added.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointEventArgs> BreakpointAdded
Public Event BreakpointAdded As EventHandler(Of BreakpointEventArgs)
public:
virtual  event EventHandler<BreakpointEventArgs^>^ BreakpointAdded {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointAdded : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>
override BreakpointAdded : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs

Implements

IScriptBreakpointsBreakpointAdded
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.BreakpointRemoved Event

ScriptBreakpointsBreakpointRemoved Event
Occurs when a breakpoint is removed.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointEventArgs> BreakpointRemoved
Public Event BreakpointRemoved As EventHandler(Of BreakpointEventArgs)
public:
virtual  event EventHandler<BreakpointEventArgs^>^ BreakpointRemoved {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointRemoved : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>
override BreakpointRemoved : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs

Implements

IScriptBreakpointsBreakpointRemoved
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.BreakpointStateChanged Event

ScriptBreakpointsBreakpointStateChanged Event
Occurs when a breakpoint state is changed.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointEventArgs> BreakpointStateChanged
Public Event BreakpointStateChanged As EventHandler(Of BreakpointEventArgs)
public:
virtual  event EventHandler<BreakpointEventArgs^>^ BreakpointStateChanged {
    void add (EventHandler<BreakpointEventArgs^>^ value);
    void remove (EventHandler<BreakpointEventArgs^>^ value);
}
abstract BreakpointStateChanged : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>
override BreakpointStateChanged : IEvent<EventHandler<BreakpointEventArgs>,
    BreakpointEventArgs>

Value

Type: SystemEventHandlerBreakpointEventArgs

Implements

IScriptBreakpointsBreakpointStateChanged
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptBreakpoints.Changed Event

ScriptBreakpointsChanged Event
Occurs when breakpoints are changed.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Changed
Public Event Changed As EventHandler
public:
virtual  event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Changed : IEvent<EventHandler,
    EventArgs>
override Changed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptBreakpointsChanged
See Also

Reference

ScriptBreakpoints Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger Class

ScriptDebugger Class
Enables communication with a debugger.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.TypeScriptScriptDebugger

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptDebugger : IScriptDebugger,
    IScriptDebuggerBase
Public Class ScriptDebugger
    Implements IScriptDebugger, IScriptDebuggerBase
public ref class ScriptDebugger : IScriptDebugger,
    IScriptDebuggerBase
type ScriptDebugger =
    class
        interface IScriptDebugger
        interface IScriptDebuggerBase
    end

The ScriptDebugger type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptDebugger | Initializes a new instance of the ScriptDebugger class with default settings.
Top
Methods
 | Name | Description
Public method | ActivateThread | Switches debugging to the specified thread.
Public method | Break | Causes the given process to pause its execution so that its current state can be analyzed.
Public method | ClearTemporaryGeneratedModules | Clears temporary generated modules on disk.
Public method | Continue | Continues given process to the next breakpoint or until process finishes.
Public method | EnableBreakpoint | Enables or disables specified breakpoint.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentExceptionAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionsAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | GetExecutionPositionAsync | Finds out current ExecutionPosition based on the current stack frame.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetSessions | Retrieves list of ChromeSessionInfo asynchronously by given URL.
Public method | GetStackFramesAsync | Gets list of method calls that are currently on a stack.
Public method | GetThreadsAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVariablesInScopeAsync | Receives all local variables based on the current stack frame.
Public method | SetRunToPositionBreakpoint | Causes debugger to stop at the specified position.
Public method | StartDebugging | Starts executing the program from the entry point with default settings.
Public method | StartDebugging(StartDebuggingOptions) | Starts executing the program from the entry point with specified settings.
Public method | StepInto | Executes one statement of code; steps into the next function call, if possible.
Public method | StepOut | Executes one statement of code; steps out of the function currently being executed.
Public method | StepOver | Executes one statement of code; steps over the next function call.
Public method | StopDebuggingAsync | Stops executing the program.
Public method | SwitchToStackFrame | Switches debugging to the given stack frame.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrySetNextStatementAsync | Tries to set the execution point to the specified line of code.
Top
Properties
 | Name | Description
Public property | Breakpoints | Returns collection of debugger breakpoints.
Public property | Capabilities | Gets debugger capabilities.
Public property | EventsSyncAction | Gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)
Public property | ExpressionEvaluator | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | IsStarted | Indicates whether debugging was started.
Public property | ScopeResolutionService | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | ScriptRun | Contains all information required to compile and run the script.
Public property | State | Gets current debugger state.
Top
Events
 | Name | Description
Public event | ActiveThreadChanged | Occurs when thread to be debugged changes.
Public event | BeforeContinue | Occurs before debugger continues to program execution.
Public event | BeforeStep | Occurs before debugger performs a step.
Public event | BeforeStop | Occurs before debugger stop debugging.
Public event | DebuggerErrorOccured | Occurs when encounters error during debugging session.
Public event | DebuggingStarted | Occurs when debugging session is started.
Public event | DebuggingStopped | Occurs when debugging session is stopped.
Public event | ExecutionResumed | Occurs when debugging is resumed after being paused.
Public event | ExecutionStopped | Occurs when debugging is paused.
Public event | LogMessageReceived | Occurs when debug message is received.
Public event | StackFrameSwitched | Occurs debugger switches to the stack frame.
Public event | StateChanged | Occurs when debugger state is changed.
Top
See Also

Reference

Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger Constructor

ScriptDebugger Constructor
Initializes a new instance of the ScriptDebugger class with default settings.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptDebugger()
Public Sub New
public:
ScriptDebugger()
new : unit -> ScriptDebugger
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger Methods

ScriptDebugger Methods

The ScriptDebugger type exposes the following members.

Methods
 | Name | Description
Public method | ActivateThread | Switches debugging to the specified thread.
Public method | Break | Causes the given process to pause its execution so that its current state can be analyzed.
Public method | ClearTemporaryGeneratedModules | Clears temporary generated modules on disk.
Public method | Continue | Continues given process to the next breakpoint or until process finishes.
Public method | EnableBreakpoint | Enables or disables specified breakpoint.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentExceptionAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | EvaluateExpressionsAsync | Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.
Public method | GetExecutionPositionAsync | Finds out current ExecutionPosition based on the current stack frame.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetSessions | Retrieves list of ChromeSessionInfo asynchronously by given URL.
Public method | GetStackFramesAsync | Gets list of method calls that are currently on a stack.
Public method | GetThreadsAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVariablesInScopeAsync | Receives all local variables based on the current stack frame.
Public method | SetRunToPositionBreakpoint | Causes debugger to stop at the specified position.
Public method | StartDebugging | Starts executing the program from the entry point with default settings.
Public method | StartDebugging(StartDebuggingOptions) | Starts executing the program from the entry point with specified settings.
Public method | StepInto | Executes one statement of code; steps into the next function call, if possible.
Public method | StepOut | Executes one statement of code; steps out of the function currently being executed.
Public method | StepOver | Executes one statement of code; steps over the next function call.
Public method | StopDebuggingAsync | Stops executing the program.
Public method | SwitchToStackFrame | Switches debugging to the given stack frame.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrySetNextStatementAsync | Tries to set the execution point to the specified line of code.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ActivateThread Method

ScriptDebuggerActivateThread Method
Switches debugging to the specified thread.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ActivateThread(
    int threadId
)
Public Sub ActivateThread (
    threadId As Integer
)
public:
virtual void ActivateThread(
    int threadId
) sealed
abstract ActivateThread :
        threadId : int -> unit
override ActivateThread :
        threadId : int -> unit

Parameters

threadId
Type: SystemInt32
Thread ID to be activated.

Implements

IScriptDebuggerBaseActivateThread(Int32)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.Break Method

ScriptDebuggerBreak Method
Causes the given process to pause its execution so that its current state can be analyzed.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Break()
Public Sub Break
public:
virtual void Break() sealed
abstract Break : unit -> unit
override Break : unit -> unit

Implements

IScriptDebuggerBaseBreak
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ClearTemporaryGeneratedModules Method

ScriptDebuggerClearTemporaryGeneratedModules Method
Clears temporary generated modules on disk.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearTemporaryGeneratedModules()
Public Sub ClearTemporaryGeneratedModules
public:
virtual void ClearTemporaryGeneratedModules() sealed
abstract ClearTemporaryGeneratedModules : unit -> unit
override ClearTemporaryGeneratedModules : unit -> unit

Implements

IScriptDebuggerBaseClearTemporaryGeneratedModules
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.Continue Method

ScriptDebuggerContinue Method
Continues given process to the next breakpoint or until process finishes.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Continue()
Public Sub Continue
public:
virtual void Continue() sealed
abstract Continue : unit -> unit
override Continue : unit -> unit

Implements

IScriptDebuggerBaseContinue
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.EnableBreakpoint Method

ScriptDebuggerEnableBreakpoint Method
Enables or disables specified breakpoint.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableBreakpoint(
    Breakpoint breakpoint,
    bool enable
)
Public Sub EnableBreakpoint (
    breakpoint As Breakpoint,
    enable As Boolean
)
public:
void EnableBreakpoint(
    Breakpoint^ breakpoint,
    bool enable
)
member EnableBreakpoint :
        breakpoint : Breakpoint *
        enable : bool -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
Breakpoint to process.
enable
Type: SystemBoolean
New breakpoint's state.
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.EvaluateCurrentExceptionAsync Method

ScriptDebuggerEvaluateCurrentExceptionAsync Method
Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ExpressionEvaluationResult> EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = null
)
Public Function EvaluateCurrentExceptionAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExpressionEvaluationResult)
public:
virtual Task<ExpressionEvaluationResult^>^ EvaluateCurrentExceptionAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateCurrentExceptionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>
override EvaluateCurrentExceptionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Token allowing cancellation of request.

Return Value

Type: TaskExpressionEvaluationResult
ExpressionEvaluationResult contains data of evaluated expression.

Implements

IScriptDebuggerBaseEvaluateCurrentExceptionAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.EvaluateExpressionAsync Method

ScriptDebuggerEvaluateExpressionAsync Method
Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ExpressionEvaluationResult> EvaluateExpressionAsync(
    ExpressionEvaluationRequest request,
    CancellationToken cancellationToken = null
)
Public Function EvaluateExpressionAsync (
    request As ExpressionEvaluationRequest,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExpressionEvaluationResult)
public:
virtual Task<ExpressionEvaluationResult^>^ EvaluateExpressionAsync(
    ExpressionEvaluationRequest^ request,
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateExpressionAsync :
        request : ExpressionEvaluationRequest *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>
override EvaluateExpressionAsync :
        request : ExpressionEvaluationRequest *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExpressionEvaluationResult>

Parameters

request
Type: Alternet.Scripter.DebuggerExpressionEvaluationRequest
Data for expression evaluation request.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Token allowing cancellation of request.

Return Value

Type: TaskExpressionEvaluationResult
ExpressionEvaluationResult contains data of evaluated expression.

Implements

IScriptDebuggerBaseEvaluateExpressionAsync(ExpressionEvaluationRequest, CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.EvaluateExpressionsAsync Method

ScriptDebuggerEvaluateExpressionsAsync Method
Evaluates an expression based on the current stack frame. If the expression can be parsed but not evaluated, an object is returned but will not contain a valid value.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<IEnumerable<ExpressionEvaluationResult>> EvaluateExpressionsAsync(
    IEnumerable<ExpressionEvaluationRequest> requests,
    CancellationToken cancellationToken = null
)
Public Function EvaluateExpressionsAsync (
    requests As IEnumerable(Of ExpressionEvaluationRequest),
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of IEnumerable(Of ExpressionEvaluationResult))
public:
virtual Task<IEnumerable<ExpressionEvaluationResult^>^>^ EvaluateExpressionsAsync(
    IEnumerable<ExpressionEvaluationRequest^>^ requests,
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateExpressionsAsync :
        requests : IEnumerable<ExpressionEvaluationRequest> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<IEnumerable<ExpressionEvaluationResult>>
override EvaluateExpressionsAsync :
        requests : IEnumerable<ExpressionEvaluationRequest> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<IEnumerable<ExpressionEvaluationResult>>

Parameters

requests
Type: System.Collections.GenericIEnumerableExpressionEvaluationRequest
List of data for expression evaluation request.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Token allowing cancellation of request.

Return Value

Type: TaskIEnumerableExpressionEvaluationResult
ExpressionEvaluationResult contains data of evaluated expression.

Implements

IScriptDebuggerBaseEvaluateExpressionsAsync(IEnumerableExpressionEvaluationRequest, CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.GetExecutionPositionAsync Method

ScriptDebuggerGetExecutionPositionAsync Method
Finds out current ExecutionPosition based on the current stack frame.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ExecutionPosition> GetExecutionPositionAsync(
    CancellationToken cancellationToken = null
)
Public Function GetExecutionPositionAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ExecutionPosition)
public:
virtual Task<ExecutionPosition^>^ GetExecutionPositionAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetExecutionPositionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExecutionPosition>
override GetExecutionPositionAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ExecutionPosition>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskExecutionPosition
Position of execution.

Implements

IScriptDebuggerBaseGetExecutionPositionAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.GetSessions Method

ScriptDebuggerGetSessions Method
Retrieves list of ChromeSessionInfo asynchronously by given URL.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<ICollection<ScriptDebuggerChromeSessionInfo>> GetSessions(
    string chromeUrl
)
Public Shared Function GetSessions (
    chromeUrl As String
) As Task(Of ICollection(Of ScriptDebuggerChromeSessionInfo))
public:
static Task<ICollection<ScriptDebuggerChromeSessionInfo^>^>^ GetSessions(
    String^ chromeUrl
)
static member GetSessions :
        chromeUrl : string -> Task<ICollection<ScriptDebuggerChromeSessionInfo>>

Parameters

chromeUrl
Type: SystemString
Base address of the Internet resource.

Return Value

Type: TaskICollectionScriptDebuggerChromeSessionInfo
List of ChromeSessionInfo.
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.GetStackFramesAsync Method

ScriptDebuggerGetStackFramesAsync Method
Gets list of method calls that are currently on a stack.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<StackFramesRetrievalResult> GetStackFramesAsync(
    CancellationToken cancellationToken = null
)
Public Function GetStackFramesAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of StackFramesRetrievalResult)
public:
virtual Task<StackFramesRetrievalResult^>^ GetStackFramesAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetStackFramesAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<StackFramesRetrievalResult>
override GetStackFramesAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<StackFramesRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskStackFramesRetrievalResult

Implements

IScriptDebuggerBaseGetStackFramesAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.GetThreadsAsync Method

ScriptDebuggerGetThreadsAsync Method

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ThreadsRetrievalResult> GetThreadsAsync(
    CancellationToken cancellationToken = null
)
Public Function GetThreadsAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ThreadsRetrievalResult)
public:
virtual Task<ThreadsRetrievalResult^>^ GetThreadsAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetThreadsAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ThreadsRetrievalResult>
override GetThreadsAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ThreadsRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskThreadsRetrievalResult

Implements

IScriptDebuggerBaseGetThreadsAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.GetVariablesInScopeAsync Method

ScriptDebuggerGetVariablesInScopeAsync Method
Receives all local variables based on the current stack frame.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<VariablesRetrievalResult> GetVariablesInScopeAsync(
    CancellationToken cancellationToken = null
)
Public Function GetVariablesInScopeAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of VariablesRetrievalResult)
public:
virtual Task<VariablesRetrievalResult^>^ GetVariablesInScopeAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract GetVariablesInScopeAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<VariablesRetrievalResult>
override GetVariablesInScopeAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<VariablesRetrievalResult>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskVariablesRetrievalResult

Implements

IScriptDebuggerBaseGetVariablesInScopeAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.SetRunToPositionBreakpoint Method

ScriptDebuggerSetRunToPositionBreakpoint Method
Causes debugger to stop at the specified position.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRunToPositionBreakpoint(
    RunToPositionBreakpoint breakpoint
)
Public Sub SetRunToPositionBreakpoint (
    breakpoint As RunToPositionBreakpoint
)
public:
virtual void SetRunToPositionBreakpoint(
    RunToPositionBreakpoint^ breakpoint
) sealed
abstract SetRunToPositionBreakpoint :
        breakpoint : RunToPositionBreakpoint -> unit
override SetRunToPositionBreakpoint :
        breakpoint : RunToPositionBreakpoint -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerRunToPositionBreakpoint
Position in the source file.

Implements

IScriptDebuggerBaseSetRunToPositionBreakpoint(RunToPositionBreakpoint)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.StartDebugging Method

ScriptDebuggerStartDebugging Method
Overload List
 | Name | Description
Public method | StartDebugging | Starts executing the program from the entry point with default settings.
Public method | StartDebugging(StartDebuggingOptions) | Starts executing the program from the entry point with specified settings.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.StartDebugging Method

ScriptDebuggerStartDebugging Method
Starts executing the program from the entry point with default settings.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartDebugging()
Public Sub StartDebugging
public:
virtual void StartDebugging() sealed
abstract StartDebugging : unit -> unit
override StartDebugging : unit -> unit

Implements

IScriptDebuggerBaseStartDebugging
See Also

Reference

ScriptDebugger Class
StartDebugging Overload
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.StartDebugging Method (StartDebuggingOptions)

ScriptDebuggerStartDebugging Method (StartDebuggingOptions)
Starts executing the program from the entry point with specified settings.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartDebugging(
    StartDebuggingOptions options
)
Public Sub StartDebugging (
    options As StartDebuggingOptions
)
public:
virtual void StartDebugging(
    StartDebuggingOptions^ options
) sealed
abstract StartDebugging :
        options : StartDebuggingOptions -> unit
override StartDebugging :
        options : StartDebuggingOptions -> unit

Parameters

options
Type: Alternet.Scripter.DebuggerStartDebuggingOptions
Debugging options.

Implements

IScriptDebuggerBaseStartDebugging(StartDebuggingOptions)
See Also

Reference

ScriptDebugger Class
StartDebugging Overload
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.StepInto Method

ScriptDebuggerStepInto Method
Executes one statement of code; steps into the next function call, if possible.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StepInto()
Public Sub StepInto
public:
virtual void StepInto() sealed
abstract StepInto : unit -> unit
override StepInto : unit -> unit

Implements

IScriptDebuggerBaseStepInto
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.StepOut Method

ScriptDebuggerStepOut Method
Executes one statement of code; steps out of the function currently being executed.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StepOut()
Public Sub StepOut
public:
virtual void StepOut() sealed
abstract StepOut : unit -> unit
override StepOut : unit -> unit

Implements

IScriptDebuggerBaseStepOut
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.StepOver Method

ScriptDebuggerStepOver Method
Executes one statement of code; steps over the next function call.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StepOver()
Public Sub StepOver
public:
virtual void StepOver() sealed
abstract StepOver : unit -> unit
override StepOver : unit -> unit

Implements

IScriptDebuggerBaseStepOver
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.StopDebuggingAsync Method

ScriptDebuggerStopDebuggingAsync Method
Stops executing the program.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task StopDebuggingAsync(
    CancellationToken cancellationToken = null
)
Public Function StopDebuggingAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
public:
virtual Task^ StopDebuggingAsync(
    CancellationToken cancellationToken = nullptr
) sealed
abstract StopDebuggingAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task
override StopDebuggingAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task

Implements

IScriptDebuggerBaseStopDebuggingAsync(CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.SwitchToStackFrame Method

ScriptDebuggerSwitchToStackFrame Method
Switches debugging to the given stack frame.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SwitchToStackFrame(
    StackFrame frame
)
Public Sub SwitchToStackFrame (
    frame As StackFrame
)
public:
virtual void SwitchToStackFrame(
    StackFrame^ frame
) sealed
abstract SwitchToStackFrame :
        frame : StackFrame -> unit
override SwitchToStackFrame :
        frame : StackFrame -> unit

Parameters

frame
Type: Alternet.Scripter.DebuggerStackFrame
StackFrame to be switched to.

Implements

IScriptDebuggerBaseSwitchToStackFrame(StackFrame)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.TrySetNextStatementAsync Method

ScriptDebuggerTrySetNextStatementAsync Method
Tries to set the execution point to the specified line of code.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<Result> TrySetNextStatementAsync(
    int lineNumber,
    CancellationToken cancellationToken = null
)
Public Function TrySetNextStatementAsync (
    lineNumber As Integer,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Result)
public:
virtual Task<Result^>^ TrySetNextStatementAsync(
    int lineNumber,
    CancellationToken cancellationToken = nullptr
) sealed
abstract TrySetNextStatementAsync :
        lineNumber : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Result>
override TrySetNextStatementAsync :
        lineNumber : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Result>

Parameters

lineNumber
Type: SystemInt32
Line number to be going to.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: TaskResult
Result of executing.

Implements

IScriptDebuggerBaseTrySetNextStatementAsync(Int32, CancellationToken)
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger Properties

ScriptDebugger Properties

The ScriptDebugger type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Returns collection of debugger breakpoints.
Public property | Capabilities | Gets debugger capabilities.
Public property | EventsSyncAction | Gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)
Public property | ExpressionEvaluator | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | IsStarted | Indicates whether debugging was started.
Public property | ScopeResolutionService | Gets IExpressionEvaluator object used to evaluate expressions.
Public property | ScriptRun | Contains all information required to compile and run the script.
Public property | State | Gets current debugger state.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.Breakpoints Property

ScriptDebuggerBreakpoints Property
Returns collection of debugger breakpoints.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptBreakpoints Breakpoints { get; }
Public ReadOnly Property Breakpoints As IScriptBreakpoints
    Get
public:
virtual property IScriptBreakpoints^ Breakpoints {
    IScriptBreakpoints^ get () sealed;
}
abstract Breakpoints : IScriptBreakpoints with get
override Breakpoints : IScriptBreakpoints with get

Property Value

Type: IScriptBreakpoints

Implements

IScriptDebuggerBaseBreakpoints
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.Capabilities Property

ScriptDebuggerCapabilities Property
Gets debugger capabilities.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerCapabilities Capabilities { get; }
Public ReadOnly Property Capabilities As DebuggerCapabilities
    Get
public:
virtual property DebuggerCapabilities Capabilities {
    DebuggerCapabilities get () sealed;
}
abstract Capabilities : DebuggerCapabilities with get
override Capabilities : DebuggerCapabilities with get

Property Value

Type: DebuggerCapabilities

Implements

IScriptDebuggerBaseCapabilities
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.EventsSyncAction Property

ScriptDebuggerEventsSyncAction Property
Gets or sets an action used to synchronize events raising. This is normally a function provided by the application to sync raised debugger events (for example, perform Control.Invoke)

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Action<Delegate> EventsSyncAction { get; set; }
Public Property EventsSyncAction As Action(Of Delegate)
    Get
    Set
public:
virtual property Action<Delegate^>^ EventsSyncAction {
    Action<Delegate^>^ get () sealed;
    void set (Action<Delegate^>^ value) sealed;
}
abstract EventsSyncAction : Action<Delegate> with get, set
override EventsSyncAction : Action<Delegate> with get, set

Property Value

Type: ActionDelegate

Implements

IScriptDebuggerBaseEventsSyncAction
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ExpressionEvaluator Property

ScriptDebuggerExpressionEvaluator Property
Gets IExpressionEvaluator object used to evaluate expressions.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IExpressionEvaluator ExpressionEvaluator { get; }
Public ReadOnly Property ExpressionEvaluator As IExpressionEvaluator
    Get
public:
virtual property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get () sealed;
}
abstract ExpressionEvaluator : IExpressionEvaluator with get
override ExpressionEvaluator : IExpressionEvaluator with get

Property Value

Type: IExpressionEvaluator

Implements

IScriptDebuggerBaseExpressionEvaluator
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.IsStarted Property

ScriptDebuggerIsStarted Property
Indicates whether debugging was started.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStarted { get; }
Public ReadOnly Property IsStarted As Boolean
    Get
public:
virtual property bool IsStarted {
    bool get () sealed;
}
abstract IsStarted : bool with get
override IsStarted : bool with get

Property Value

Type: Boolean

Implements

IScriptDebuggerBaseIsStarted
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ScopeResolutionService Property

ScriptDebuggerScopeResolutionService Property
Gets IExpressionEvaluator object used to evaluate expressions.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScopeResolutionService ScopeResolutionService { get; }
Public ReadOnly Property ScopeResolutionService As IScopeResolutionService
    Get
public:
virtual property IScopeResolutionService^ ScopeResolutionService {
    IScopeResolutionService^ get () sealed;
}
abstract ScopeResolutionService : IScopeResolutionService with get
override ScopeResolutionService : IScopeResolutionService with get

Property Value

Type: IScopeResolutionService

Implements

IScriptDebuggerBaseScopeResolutionService
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ScriptRun Property

ScriptDebuggerScriptRun Property
Contains all information required to compile and run the script.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptRun ScriptRun { get; set; }
Public Property ScriptRun As IScriptRun
    Get
    Set
public:
virtual property IScriptRun^ ScriptRun {
    IScriptRun^ get () sealed;
    void set (IScriptRun^ value) sealed;
}
abstract ScriptRun : IScriptRun with get, set
override ScriptRun : IScriptRun with get, set

Property Value

Type: IScriptRun

Implements

IScriptDebuggerScriptRun
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.State Property

ScriptDebuggerState Property
Gets current debugger state.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerState State { get; }
Public ReadOnly Property State As DebuggerState
    Get
public:
virtual property DebuggerState State {
    DebuggerState get () sealed;
}
abstract State : DebuggerState with get
override State : DebuggerState with get

Property Value

Type: DebuggerState

Implements

IScriptDebuggerBaseState
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger Events

ScriptDebugger Events

The ScriptDebugger type exposes the following members.

Events
 | Name | Description
Public event | ActiveThreadChanged | Occurs when thread to be debugged changes.
Public event | BeforeContinue | Occurs before debugger continues to program execution.
Public event | BeforeStep | Occurs before debugger performs a step.
Public event | BeforeStop | Occurs before debugger stop debugging.
Public event | DebuggerErrorOccured | Occurs when encounters error during debugging session.
Public event | DebuggingStarted | Occurs when debugging session is started.
Public event | DebuggingStopped | Occurs when debugging session is stopped.
Public event | ExecutionResumed | Occurs when debugging is resumed after being paused.
Public event | ExecutionStopped | Occurs when debugging is paused.
Public event | LogMessageReceived | Occurs when debug message is received.
Public event | StackFrameSwitched | Occurs debugger switches to the stack frame.
Public event | StateChanged | Occurs when debugger state is changed.
Top
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ActiveThreadChanged Event

ScriptDebuggerActiveThreadChanged Event
Occurs when thread to be debugged changes.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ActiveThreadChangedEventArgs> ActiveThreadChanged
Public Event ActiveThreadChanged As EventHandler(Of ActiveThreadChangedEventArgs)
public:
virtual  event EventHandler<ActiveThreadChangedEventArgs^>^ ActiveThreadChanged {
    void add (EventHandler<ActiveThreadChangedEventArgs^>^ value);
    void remove (EventHandler<ActiveThreadChangedEventArgs^>^ value);
}
abstract ActiveThreadChanged : IEvent<EventHandler<ActiveThreadChangedEventArgs>,
    ActiveThreadChangedEventArgs>
override ActiveThreadChanged : IEvent<EventHandler<ActiveThreadChangedEventArgs>,
    ActiveThreadChangedEventArgs>

Value

Type: SystemEventHandlerActiveThreadChangedEventArgs

Implements

IScriptDebuggerBaseActiveThreadChanged
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.BeforeContinue Event

ScriptDebuggerBeforeContinue Event
Occurs before debugger continues to program execution.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BeforeContinue
Public Event BeforeContinue As EventHandler
public:
virtual  event EventHandler^ BeforeContinue {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeContinue : IEvent<EventHandler,
    EventArgs>
override BeforeContinue : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptDebuggerBaseBeforeContinue
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.BeforeStep Event

ScriptDebuggerBeforeStep Event
Occurs before debugger performs a step.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BeforeStep
Public Event BeforeStep As EventHandler
public:
virtual  event EventHandler^ BeforeStep {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeStep : IEvent<EventHandler,
    EventArgs>
override BeforeStep : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptDebuggerBaseBeforeStep
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.BeforeStop Event

ScriptDebuggerBeforeStop Event
Occurs before debugger stop debugging.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BeforeStop
Public Event BeforeStop As EventHandler
public:
virtual  event EventHandler^ BeforeStop {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeforeStop : IEvent<EventHandler,
    EventArgs>
override BeforeStop : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptDebuggerBaseBeforeStop
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.DebuggerErrorOccured Event

ScriptDebuggerDebuggerErrorOccured Event
Occurs when encounters error during debugging session.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggerErrorOccuredEventArgs> DebuggerErrorOccured
Public Event DebuggerErrorOccured As EventHandler(Of DebuggerErrorOccuredEventArgs)
public:
virtual  event EventHandler<DebuggerErrorOccuredEventArgs^>^ DebuggerErrorOccured {
    void add (EventHandler<DebuggerErrorOccuredEventArgs^>^ value);
    void remove (EventHandler<DebuggerErrorOccuredEventArgs^>^ value);
}
abstract DebuggerErrorOccured : IEvent<EventHandler<DebuggerErrorOccuredEventArgs>,
    DebuggerErrorOccuredEventArgs>
override DebuggerErrorOccured : IEvent<EventHandler<DebuggerErrorOccuredEventArgs>,
    DebuggerErrorOccuredEventArgs>

Value

Type: SystemEventHandlerDebuggerErrorOccuredEventArgs

Implements

IScriptDebuggerBaseDebuggerErrorOccured
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.DebuggingStarted Event

ScriptDebuggerDebuggingStarted Event
Occurs when debugging session is started.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggingStartedEventArgs> DebuggingStarted
Public Event DebuggingStarted As EventHandler(Of DebuggingStartedEventArgs)
public:
virtual  event EventHandler<DebuggingStartedEventArgs^>^ DebuggingStarted {
    void add (EventHandler<DebuggingStartedEventArgs^>^ value);
    void remove (EventHandler<DebuggingStartedEventArgs^>^ value);
}
abstract DebuggingStarted : IEvent<EventHandler<DebuggingStartedEventArgs>,
    DebuggingStartedEventArgs>
override DebuggingStarted : IEvent<EventHandler<DebuggingStartedEventArgs>,
    DebuggingStartedEventArgs>

Value

Type: SystemEventHandlerDebuggingStartedEventArgs

Implements

IScriptDebuggerBaseDebuggingStarted
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.DebuggingStopped Event

ScriptDebuggerDebuggingStopped Event
Occurs when debugging session is stopped.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggingStoppedEventArgs> DebuggingStopped
Public Event DebuggingStopped As EventHandler(Of DebuggingStoppedEventArgs)
public:
virtual  event EventHandler<DebuggingStoppedEventArgs^>^ DebuggingStopped {
    void add (EventHandler<DebuggingStoppedEventArgs^>^ value);
    void remove (EventHandler<DebuggingStoppedEventArgs^>^ value);
}
abstract DebuggingStopped : IEvent<EventHandler<DebuggingStoppedEventArgs>,
    DebuggingStoppedEventArgs>
override DebuggingStopped : IEvent<EventHandler<DebuggingStoppedEventArgs>,
    DebuggingStoppedEventArgs>

Value

Type: SystemEventHandlerDebuggingStoppedEventArgs

Implements

IScriptDebuggerBaseDebuggingStopped
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ExecutionResumed Event

ScriptDebuggerExecutionResumed Event
Occurs when debugging is resumed after being paused.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ExecutionResumedEventArgs> ExecutionResumed
Public Event ExecutionResumed As EventHandler(Of ExecutionResumedEventArgs)
public:
virtual  event EventHandler<ExecutionResumedEventArgs^>^ ExecutionResumed {
    void add (EventHandler<ExecutionResumedEventArgs^>^ value);
    void remove (EventHandler<ExecutionResumedEventArgs^>^ value);
}
abstract ExecutionResumed : IEvent<EventHandler<ExecutionResumedEventArgs>,
    ExecutionResumedEventArgs>
override ExecutionResumed : IEvent<EventHandler<ExecutionResumedEventArgs>,
    ExecutionResumedEventArgs>

Value

Type: SystemEventHandlerExecutionResumedEventArgs

Implements

IScriptDebuggerBaseExecutionResumed
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ExecutionStopped Event

ScriptDebuggerExecutionStopped Event
Occurs when debugging is paused.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ExecutionStoppedEventArgs> ExecutionStopped
Public Event ExecutionStopped As EventHandler(Of ExecutionStoppedEventArgs)
public:
virtual  event EventHandler<ExecutionStoppedEventArgs^>^ ExecutionStopped {
    void add (EventHandler<ExecutionStoppedEventArgs^>^ value);
    void remove (EventHandler<ExecutionStoppedEventArgs^>^ value);
}
abstract ExecutionStopped : IEvent<EventHandler<ExecutionStoppedEventArgs>,
    ExecutionStoppedEventArgs>
override ExecutionStopped : IEvent<EventHandler<ExecutionStoppedEventArgs>,
    ExecutionStoppedEventArgs>

Value

Type: SystemEventHandlerExecutionStoppedEventArgs

Implements

IScriptDebuggerBaseExecutionStopped
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.LogMessageReceived Event

ScriptDebuggerLogMessageReceived Event
Occurs when debug message is received.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<LogMessageReceivedEventArgs> LogMessageReceived
Public Event LogMessageReceived As EventHandler(Of LogMessageReceivedEventArgs)
public:
virtual  event EventHandler<LogMessageReceivedEventArgs^>^ LogMessageReceived {
    void add (EventHandler<LogMessageReceivedEventArgs^>^ value);
    void remove (EventHandler<LogMessageReceivedEventArgs^>^ value);
}
abstract LogMessageReceived : IEvent<EventHandler<LogMessageReceivedEventArgs>,
    LogMessageReceivedEventArgs>
override LogMessageReceived : IEvent<EventHandler<LogMessageReceivedEventArgs>,
    LogMessageReceivedEventArgs>

Value

Type: SystemEventHandlerLogMessageReceivedEventArgs

Implements

IScriptDebuggerBaseLogMessageReceived
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.StackFrameSwitched Event

ScriptDebuggerStackFrameSwitched Event
Occurs debugger switches to the stack frame.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<StackFrameSwitchedEventArgs> StackFrameSwitched
Public Event StackFrameSwitched As EventHandler(Of StackFrameSwitchedEventArgs)
public:
virtual  event EventHandler<StackFrameSwitchedEventArgs^>^ StackFrameSwitched {
    void add (EventHandler<StackFrameSwitchedEventArgs^>^ value);
    void remove (EventHandler<StackFrameSwitchedEventArgs^>^ value);
}
abstract StackFrameSwitched : IEvent<EventHandler<StackFrameSwitchedEventArgs>,
    StackFrameSwitchedEventArgs>
override StackFrameSwitched : IEvent<EventHandler<StackFrameSwitchedEventArgs>,
    StackFrameSwitchedEventArgs>

Value

Type: SystemEventHandlerStackFrameSwitchedEventArgs

Implements

IScriptDebuggerBaseStackFrameSwitched
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.StateChanged Event

ScriptDebuggerStateChanged Event
Occurs when debugger state is changed.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebuggerStateChangedEventArgs> StateChanged
Public Event StateChanged As EventHandler(Of DebuggerStateChangedEventArgs)
public:
virtual  event EventHandler<DebuggerStateChangedEventArgs^>^ StateChanged {
    void add (EventHandler<DebuggerStateChangedEventArgs^>^ value);
    void remove (EventHandler<DebuggerStateChangedEventArgs^>^ value);
}
abstract StateChanged : IEvent<EventHandler<DebuggerStateChangedEventArgs>,
    DebuggerStateChangedEventArgs>
override StateChanged : IEvent<EventHandler<DebuggerStateChangedEventArgs>,
    DebuggerStateChangedEventArgs>

Value

Type: SystemEventHandlerDebuggerStateChangedEventArgs

Implements

IScriptDebuggerBaseStateChanged
See Also

Reference

ScriptDebugger Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ChromeSessionInfo Class

ScriptDebuggerChromeSessionInfo Class
Provides data for the particular Internet session.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.TypeScriptScriptDebuggerChromeSessionInfo

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ChromeSessionInfo
Public Class ChromeSessionInfo
public ref class ChromeSessionInfo
type ChromeSessionInfo =  class end

The ScriptDebuggerChromeSessionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptDebuggerChromeSessionInfo | Initializes a new instance of the ScriptDebuggerChromeSessionInfo class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | Gets or sets session description.
Public property | DevToolsFrontendUrl |
Public property | Id | Gets or sets session ID.
Public property | Title | Gets or sets session title.
Public property | Type | Gets or sets session type.
Public property | WebSocketDebuggerUrl | Gets or sets WebSocket debugger URL.
Top
See Also

Reference

Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ChromeSessionInfo Constructor

ScriptDebuggerChromeSessionInfo Constructor
Initializes a new instance of the ScriptDebuggerChromeSessionInfo class

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ChromeSessionInfo()
Public Sub New
public:
ChromeSessionInfo()
new : unit -> ChromeSessionInfo
See Also

Reference

ScriptDebuggerChromeSessionInfo Class
Alternet.Scripter.Debugger.TypeScript Namespace


ChromeSessionInfo Methods

ChromeSessionInfo Methods

The ScriptDebuggerChromeSessionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptDebuggerChromeSessionInfo Class
Alternet.Scripter.Debugger.TypeScript Namespace


ChromeSessionInfo Properties

ChromeSessionInfo Properties

The ScriptDebuggerChromeSessionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets session description.
Public property | DevToolsFrontendUrl |
Public property | Id | Gets or sets session ID.
Public property | Title | Gets or sets session title.
Public property | Type | Gets or sets session type.
Public property | WebSocketDebuggerUrl | Gets or sets WebSocket debugger URL.
Top
See Also

Reference

ScriptDebuggerChromeSessionInfo Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ChromeSessionInfo.Description Property

ScriptDebuggerChromeSessionInfoDescription Property
Gets or sets session description.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

ScriptDebuggerChromeSessionInfo Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ChromeSessionInfo.DevToolsFrontendUrl Property

ScriptDebuggerChromeSessionInfoDevToolsFrontendUrl Property

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DevToolsFrontendUrl { get; set; }
Public Property DevToolsFrontendUrl As String
    Get
    Set
public:
property String^ DevToolsFrontendUrl {
    String^ get ();
    void set (String^ value);
}
member DevToolsFrontendUrl : string with get, set

Property Value

Type: String
See Also

Reference

ScriptDebuggerChromeSessionInfo Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ChromeSessionInfo.Id Property

ScriptDebuggerChromeSessionInfoId Property
Gets or sets session ID.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

ScriptDebuggerChromeSessionInfo Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ChromeSessionInfo.Title Property

ScriptDebuggerChromeSessionInfoTitle Property
Gets or sets session title.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

ScriptDebuggerChromeSessionInfo Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ChromeSessionInfo.Type Property

ScriptDebuggerChromeSessionInfoType Property
Gets or sets session type.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

ScriptDebuggerChromeSessionInfo Class
Alternet.Scripter.Debugger.TypeScript Namespace


ScriptDebugger.ChromeSessionInfo.WebSocketDebuggerUrl Property

ScriptDebuggerChromeSessionInfoWebSocketDebuggerUrl Property
Gets or sets WebSocket debugger URL.

Namespace: Alternet.Scripter.Debugger.TypeScript
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WebSocketDebuggerUrl { get; set; }
Public Property WebSocketDebuggerUrl As String
    Get
    Set
public:
property String^ WebSocketDebuggerUrl {
    String^ get ();
    void set (String^ value);
}
member WebSocketDebuggerUrl : string with get, set

Property Value

Type: String
See Also

Reference

ScriptDebuggerChromeSessionInfo Class
Alternet.Scripter.Debugger.TypeScript Namespace


Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation Namespace

Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation Namespace
Classes
 | Class | Description
Public class | ExpressionValue | Provides a class stores expression value.


ExpressionValue Class

ExpressionValue Class
Provides a class stores expression value.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluationExpressionValue

Namespace: Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExpressionValue
Public Class ExpressionValue
public ref class ExpressionValue
type ExpressionValue =  class end

The ExpressionValue type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionValue | Initializes a new instance of the ExpressionValue class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsArrayType | Gets a boolean value indicates whether expression is array type.
Top
See Also

Reference

Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation Namespace


ExpressionValue Constructor

ExpressionValue Constructor
Initializes a new instance of the ExpressionValue class

Namespace: Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExpressionValue()
Public Sub New
public:
ExpressionValue()
new : unit -> ExpressionValue
See Also

Reference

ExpressionValue Class
Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation Namespace


ExpressionValue Methods

ExpressionValue Methods

The ExpressionValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExpressionValue Class
Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation Namespace


ExpressionValue Properties

ExpressionValue Properties

The ExpressionValue type exposes the following members.

Properties
 | Name | Description
Public property | IsArrayType | Gets a boolean value indicates whether expression is array type.
Top
See Also

Reference

ExpressionValue Class
Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation Namespace


ExpressionValue.IsArrayType Property

ExpressionValueIsArrayType Property
Gets a boolean value indicates whether expression is array type.

Namespace: Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation
Assembly: Alternet.Scripter.TypeScript.Debugger.v7 (in Alternet.Scripter.TypeScript.Debugger.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsArrayType { get; }
Public ReadOnly Property IsArrayType As Boolean
    Get
public:
property bool IsArrayType {
    bool get ();
}
member IsArrayType : bool with get

Property Value

Type: Boolean
See Also

Reference

ExpressionValue Class
Alternet.Scripter.Debugger.TypeScript.ExpressionEvaluation Namespace


Alternet.Scripter.Debugger.UI Namespace

Alternet.Scripter.Debugger.UI Namespace
Classes
 | Class | Description
Public class | AddToWatchClickEventArgs | Provides data for the Locals.AddToWatchClick event.
Public class | BreakpointChangedEventArgs | Provides data for the Breakpoints.BreakpointStateChanged and Breakpoints.BreakpointDeleted event.
Public class | BreakpointClickEventArgs | Provides data for the Breakpoints.BreakpointClick event.
Public class | BreakpointListView | Represents ListView control used in the Breakpoints user control.
Public class | Breakpoints | Displays list of breakpoints during script debugging.
Public class | CallStack | Displays list of call stack frames during script debugging.
Public class | CallStackClickEventArgs | Provides data for the CallStack.CallStackClick event.
Public class | DebuggerControlToolbar |
Public class | DebugMenu |
Public class | DefaultDebuggerUICommands |
Public class | ErrorClickEventArgs | Provides data for the Errors.ErrorClick event.
Public class | Errors | Displays list of compiler errors and warnings.
Public class | EvaluateDialog | Represents a dialog box to evaluate a particular variable or expression.
Public class | EvaluateDialogCodeCompletionOptions | Represents options that affect code completion in the evaluation dialog.
Public class | Locals | Displays and evaluates local variables during script debugging.
Public class | Output | Displays list of output messages during script debugging.
Public class | RunParameters | Represents Run Parameters dialog box used to pass parameters to the process being debugged.
Public class | ThreadClickEventArgs | Provides data for the Threads.ThreadClick event.
Public class | Threads | Displays list of active threads during script debugging.
Public class | VariablesEvaluationControlBase | Provides a base class to evaluate list of expressions during script debugging. This class is abstract.
Public class | WatchAddedEventArgs | Provides data for the EvaluateDialog.WatchAdded event.
Public class | WatchDialog | Represents a dialog box to add a new watch expression.
Public class | Watches | Displays and evaluates watch expressions during script debugging.
Delegates
 | Delegate | Description
Public delegate | EvaluateDialogCreateCodeCompletionControllerDelegate | Represents a method that will handle creation of codecompletion controller object.


AddToWatchClickEventArgs Class

AddToWatchClickEventArgs Class
Provides data for the Locals.AddToWatchClick event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.Debugger.UIAddToWatchClickEventArgs

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AddToWatchClickEventArgs : EventArgs
Public Class AddToWatchClickEventArgs
    Inherits EventArgs
public ref class AddToWatchClickEventArgs : public EventArgs
type AddToWatchClickEventArgs =
    class
        inherit EventArgs
    end

The AddToWatchClickEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AddToWatchClickEventArgs | Initializes a new instance of the AddToWatchClickEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Expression | Gets or sets a variable expression currently selected in the list of local variables.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


AddToWatchClickEventArgs Constructor

AddToWatchClickEventArgs Constructor
Initializes a new instance of the AddToWatchClickEventArgs class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AddToWatchClickEventArgs()
Public Sub New
public:
AddToWatchClickEventArgs()
new : unit -> AddToWatchClickEventArgs
See Also

Reference

AddToWatchClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


AddToWatchClickEventArgs Methods

AddToWatchClickEventArgs Methods

The AddToWatchClickEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddToWatchClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


AddToWatchClickEventArgs Properties

AddToWatchClickEventArgs Properties

The AddToWatchClickEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Expression | Gets or sets a variable expression currently selected in the list of local variables.
Top
See Also

Reference

AddToWatchClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


AddToWatchClickEventArgs.Expression Property

AddToWatchClickEventArgsExpression Property
Gets or sets a variable expression currently selected in the list of local variables.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; set; }
Public Property Expression As String
    Get
    Set
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}
member Expression : string with get, set

Property Value

Type: String
See Also

Reference

AddToWatchClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointChangedEventArgs Class

BreakpointChangedEventArgs Class
Provides data for the Breakpoints.BreakpointStateChanged and Breakpoints.BreakpointDeleted event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.Debugger.UIBreakpointChangedEventArgs

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BreakpointChangedEventArgs : EventArgs
Public Class BreakpointChangedEventArgs
    Inherits EventArgs
public ref class BreakpointChangedEventArgs : public EventArgs
type BreakpointChangedEventArgs =
    class
        inherit EventArgs
    end

The BreakpointChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BreakpointChangedEventArgs | Initializes a new instance of the BreakpointChangedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Breakpoint | Gets or sets a Breakpoint which state was changed.
Public property | Breakpoints | Gets or sets a list of Breakpoint which state was changed.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


BreakpointChangedEventArgs Constructor

BreakpointChangedEventArgs Constructor
Initializes a new instance of the BreakpointChangedEventArgs class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BreakpointChangedEventArgs()
Public Sub New
public:
BreakpointChangedEventArgs()
new : unit -> BreakpointChangedEventArgs
See Also

Reference

BreakpointChangedEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointChangedEventArgs Methods

BreakpointChangedEventArgs Methods

The BreakpointChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BreakpointChangedEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointChangedEventArgs Properties

BreakpointChangedEventArgs Properties

The BreakpointChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoint | Gets or sets a Breakpoint which state was changed.
Public property | Breakpoints | Gets or sets a list of Breakpoint which state was changed.
Top
See Also

Reference

BreakpointChangedEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointChangedEventArgs.Breakpoint Property

BreakpointChangedEventArgsBreakpoint Property
Gets or sets a Breakpoint which state was changed.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoint Breakpoint { get; set; }
Public Property Breakpoint As Breakpoint
    Get
    Set
public:
property Breakpoint^ Breakpoint {
    Breakpoint^ get ();
    void set (Breakpoint^ value);
}
member Breakpoint : Breakpoint with get, set

Property Value

Type: Breakpoint
See Also

Reference

BreakpointChangedEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointChangedEventArgs.Breakpoints Property

BreakpointChangedEventArgsBreakpoints Property
Gets or sets a list of Breakpoint which state was changed.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Breakpoint> Breakpoints { get; set; }
Public Property Breakpoints As IList(Of Breakpoint)
    Get
    Set
public:
property IList<Breakpoint^>^ Breakpoints {
    IList<Breakpoint^>^ get ();
    void set (IList<Breakpoint^>^ value);
}
member Breakpoints : IList<Breakpoint> with get, set

Property Value

Type: IListBreakpoint
See Also

Reference

BreakpointChangedEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointClickEventArgs Class

BreakpointClickEventArgs Class
Provides data for the Breakpoints.BreakpointClick event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.Debugger.UIBreakpointClickEventArgs

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BreakpointClickEventArgs : EventArgs
Public Class BreakpointClickEventArgs
    Inherits EventArgs
public ref class BreakpointClickEventArgs : public EventArgs
type BreakpointClickEventArgs =
    class
        inherit EventArgs
    end

The BreakpointClickEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BreakpointClickEventArgs | Initializes a new instance of the BreakpointClickEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Breakpoint | Gets or sets a Breakpoint currently selected in the list of Breakpoints.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


BreakpointClickEventArgs Constructor

BreakpointClickEventArgs Constructor
Initializes a new instance of the BreakpointClickEventArgs class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BreakpointClickEventArgs()
Public Sub New
public:
BreakpointClickEventArgs()
new : unit -> BreakpointClickEventArgs
See Also

Reference

BreakpointClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointClickEventArgs Methods

BreakpointClickEventArgs Methods

The BreakpointClickEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BreakpointClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointClickEventArgs Properties

BreakpointClickEventArgs Properties

The BreakpointClickEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoint | Gets or sets a Breakpoint currently selected in the list of Breakpoints.
Top
See Also

Reference

BreakpointClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointClickEventArgs.Breakpoint Property

BreakpointClickEventArgsBreakpoint Property
Gets or sets a Breakpoint currently selected in the list of Breakpoints.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoint Breakpoint { get; set; }
Public Property Breakpoint As Breakpoint
    Get
    Set
public:
property Breakpoint^ Breakpoint {
    Breakpoint^ get ();
    void set (Breakpoint^ value);
}
member Breakpoint : Breakpoint with get, set

Property Value

Type: Breakpoint
See Also

Reference

BreakpointClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointListView Class

BreakpointListView Class
Represents ListView control used in the Breakpoints user control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListView
Alternet.Scripter.Debugger.UIBreakpointListView

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BreakpointListView : ListView
Public Class BreakpointListView
    Inherits ListView
public ref class BreakpointListView : public ListView
type BreakpointListView =
    class
        inherit ListView
    end

The BreakpointListView type exposes the following members.

Constructors
 | Name | Description
Public method | BreakpointListView | Initializes a new instance of the BreakpointListView class
Top
Methods
 | Name | Description
Public method | ArrangeIcons | Arranges items in the control when they are displayed as icons based on the value of the Alignment property. (Inherited from ListView.)
Public method | ArrangeIcons(ListViewAlignment) | Arranges items in the control when they are displayed as icons with a specified alignment setting. (Inherited from ListView.)
Public method | AutoResizeColumn | Resizes the width of the given column as indicated by the resize style. (Inherited from ListView.)
Public method | AutoResizeColumns | Resizes the width of the columns as indicated by the resize style. (Inherited from ListView.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents the control from drawing until the EndUpdate method is called. (Inherited from ListView.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Removes all items and columns from the control. (Inherited from ListView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes drawing of the list view control after drawing is suspended by the BeginUpdate method. (Inherited from ListView.)
Public method | EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary. (Inherited from ListView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindItemWithText(String) | Finds the first ListViewItem that begins with the specified text value. (Inherited from ListView.)
Public method | FindItemWithText(String, Boolean, Int32) | Finds the first ListViewItem or ListViewItemListViewSubItem, if indicated, that begins with the specified text value. The search starts at the specified index. (Inherited from ListView.)
Public method | FindItemWithText(String, Boolean, Int32, Boolean) | Finds the first ListViewItem or ListViewItemListViewSubItem, if indicated, that begins with the specified text value. The search starts at the specified index. (Inherited from ListView.)
Public method | FindNearestItem(SearchDirectionHint, Point) | Finds the next item from the given point, searching in the specified direction (Inherited from ListView.)
Public method | FindNearestItem(SearchDirectionHint, Int32, Int32) | Finds the next item from the given x- and y-coordinates, searching in the specified direction. (Inherited from ListView.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemAt | Retrieves the item at the specified location. (Inherited from ListView.)
Public method | GetItemRect(Int32) | Retrieves the bounding rectangle for a specific item within the list view control. (Inherited from ListView.)
Public method | GetItemRect(Int32, ItemBoundsPortion) | Retrieves the specified portion of the bounding rectangle for a specific item within the list view control. (Inherited from ListView.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest(Point) | Provides item information, given a point. (Inherited from ListView.)
Public method | HitTest(Int32, Int32) | Provides item information, given x- and y-coordinates. (Inherited from ListView.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | RedrawItems | Forces a range of ListViewItem objects to be redrawn. (Inherited from ListView.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Sort | Sorts the items of the list view. (Inherited from ListView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListView control. (Inherited from ListView.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Activation | Gets or sets the type of action the user must take to activate an item. (Inherited from ListView.)
Public property | Alignment | Gets or sets the alignment of items in the control. (Inherited from ListView.)
Public property | AllowColumnReorder | Gets or sets a value indicating whether the user can drag column headers to reorder columns in the control. (Inherited from ListView.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoArrange | Gets or sets whether icons are automatically kept arranged. (Inherited from ListView.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color. (Inherited from ListView.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets an ImageLayout value. (Inherited from ListView.)
Public property | BackgroundImageTiled | Gets or sets a value indicating whether the background image of the ListView should be tiled. (Inherited from ListView.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the control. (Inherited from ListView.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control. (Inherited from ListView.)
Public property | CheckedIndices | Gets the indexes of the currently checked items in the control. (Inherited from ListView.)
Public property | CheckedItems | Gets the currently checked items in the control. (Inherited from ListView.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Columns | Gets the collection of all column headers that appear in the control. (Inherited from ListView.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusedItem | Gets or sets the item in the control that currently has focus. (Inherited from ListView.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color. (Inherited from ListView.)
Public property | FullRowSelect | Gets or sets a value indicating whether clicking an item selects all its subitems. (Inherited from ListView.)
Public property | GridLines | Gets or sets a value indicating whether grid lines appear between the rows and columns containing the items and subitems in the control. (Inherited from ListView.)
Public property | Groups | Gets the collection of ListViewGroup objects assigned to the control. (Inherited from ListView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderStyle | Gets or sets the column header style. (Inherited from ListView.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected item in the control remains highlighted when the control loses focus. (Inherited from ListView.)
Public property | HotTracking | Gets or sets a value indicating whether the text of an item or subitem has the appearance of a hyperlink when the mouse pointer passes over it. (Inherited from ListView.)
Public property | HoverSelection | Gets or sets a value indicating whether an item is automatically selected when the mouse pointer remains over the item for a few seconds. (Inherited from ListView.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InsertionMark | Gets an object used to indicate the expected drop location when an item is dragged within a ListView control. (Inherited from ListView.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets a collection containing all items in the control. (Inherited from ListView.)
Public property | LabelEdit | Gets or sets a value indicating whether the user can edit the labels of items in the control. (Inherited from ListView.)
Public property | LabelWrap | Gets or sets a value indicating whether item labels wrap when items are displayed in the control as icons. (Inherited from ListView.)
Public property | LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control. (Inherited from ListView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListViewItemSorter | Gets or sets the sorting comparer for the control. (Inherited from ListView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiSelect | Gets or sets a value indicating whether multiple items can be selected. (Inherited from ListView.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OwnerDraw | Gets or sets a value indicating whether the ListView control is drawn by the operating system or by code that you provide. (Inherited from ListView.)
Public property | Padding | Gets or sets the space between the ListView control and its contents. (Inherited from ListView.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether the control is laid out from right to left. (Inherited from ListView.)
Public property | Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items. (Inherited from ListView.)
Public property | SelectedIndices | Gets the indexes of the selected items in the control. (Inherited from ListView.)
Public property | SelectedItems | Gets the items that are selected in the control. (Inherited from ListView.)
Public property | ShowGroups | Gets or sets a value indicating whether items are displayed in groups. (Inherited from ListView.)
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are shown for the ListViewItem objects contained in the ListView. (Inherited from ListView.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control. (Inherited from ListView.)
Public property | Sorting | Gets or sets the sort order for items in the control. (Inherited from ListView.)
Public property | StateImageList | Gets or sets the ImageList associated with application-defined states in the control. (Inherited from ListView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This property is not relevant for this class. (Inherited from ListView.)
Public property | TileSize | Gets or sets the size of the tiles shown in tile view. (Inherited from ListView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopItem | Gets or sets the first visible item in the control. (Inherited from ListView.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleStateImageBehavior | Gets or sets a value indicating whether the ListView uses state image behavior that is compatible with the .NET Framework 1.1 or the .NET Framework 2.0. (Inherited from ListView.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | View | Gets or sets how items are displayed in the control. (Inherited from ListView.)
Public property | VirtualListSize | Gets or sets the number of ListViewItem objects contained in the list when in virtual mode. (Inherited from ListView.)
Public property | VirtualMode | Gets or sets a value indicating whether you have provided your own data-management operations for the ListView control. (Inherited from ListView.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AfterLabelEdit | Occurs when the label for an item is edited by the user. (Inherited from ListView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListView.)
Public event | BeforeLabelEdit | Occurs when the user starts editing the label of an item. (Inherited from ListView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CacheVirtualItems | Occurs when the contents of the display area for a ListView in virtual mode has changed, and the ListView determines that a new range of items is needed. (Inherited from ListView.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ColumnClick | Occurs when the user clicks a column header within the list view control. (Inherited from ListView.)
Public event | ColumnReordered | Occurs when the column header order is changed. (Inherited from ListView.)
Public event | ColumnWidthChanged | Occurs after the width of a column is successfully changed. (Inherited from ListView.)
Public event | ColumnWidthChanging | Occurs when the width of a column is changing. (Inherited from ListView.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawColumnHeader | Occurs when the details view of a ListView is drawn and the OwnerDraw property is set to true. (Inherited from ListView.)
Public event | DrawItem | Occurs when a ListView is drawn and the OwnerDraw property is set to true. (Inherited from ListView.)
Public event | DrawSubItem | Occurs when the details view of a ListView is drawn and the OwnerDraw property is set to true. (Inherited from ListView.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemActivate | Occurs when an item is activated. (Inherited from ListView.)
Public event | ItemCheck | Occurs when the check state of an item changes. (Inherited from ListView.)
Public event | ItemChecked | Occurs when the checked state of an item changes. (Inherited from ListView.)
Public event | ItemDrag | Occurs when the user begins dragging an item. (Inherited from ListView.)
Public event | ItemMouseHover | Occurs when the mouse hovers over an item. (Inherited from ListView.)
Public event | ItemSelectionChanged | Occurs when the selection state of an item changes. (Inherited from ListView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListView.)
Public event | Paint | Occurs when the ListView control is painted. (Inherited from ListView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RetrieveVirtualItem | Occurs when the ListView is in virtual mode and requires a ListViewItem. (Inherited from ListView.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from ListView.)
Public event | SearchForVirtualItem | Occurs when the ListView is in virtual mode and a search is taking place. (Inherited from ListView.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndices collection changes. (Inherited from ListView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property changes. (Inherited from ListView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VirtualItemsSelectionRangeChanged | Occurs when a ListView is in virtual mode and the selection state of a range of items has changed. (Inherited from ListView.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


BreakpointListView Constructor

BreakpointListView Constructor
Initializes a new instance of the BreakpointListView class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BreakpointListView()
Public Sub New
public:
BreakpointListView()
new : unit -> BreakpointListView
See Also

Reference

BreakpointListView Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointListView Methods

BreakpointListView Methods

The BreakpointListView type exposes the following members.

Methods
 | Name | Description
Public method | ArrangeIcons | Arranges items in the control when they are displayed as icons based on the value of the Alignment property. (Inherited from ListView.)
Public method | ArrangeIcons(ListViewAlignment) | Arranges items in the control when they are displayed as icons with a specified alignment setting. (Inherited from ListView.)
Public method | AutoResizeColumn | Resizes the width of the given column as indicated by the resize style. (Inherited from ListView.)
Public method | AutoResizeColumns | Resizes the width of the columns as indicated by the resize style. (Inherited from ListView.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Prevents the control from drawing until the EndUpdate method is called. (Inherited from ListView.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Removes all items and columns from the control. (Inherited from ListView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes drawing of the list view control after drawing is suspended by the BeginUpdate method. (Inherited from ListView.)
Public method | EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary. (Inherited from ListView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindItemWithText(String) | Finds the first ListViewItem that begins with the specified text value. (Inherited from ListView.)
Public method | FindItemWithText(String, Boolean, Int32) | Finds the first ListViewItem or ListViewItemListViewSubItem, if indicated, that begins with the specified text value. The search starts at the specified index. (Inherited from ListView.)
Public method | FindItemWithText(String, Boolean, Int32, Boolean) | Finds the first ListViewItem or ListViewItemListViewSubItem, if indicated, that begins with the specified text value. The search starts at the specified index. (Inherited from ListView.)
Public method | FindNearestItem(SearchDirectionHint, Point) | Finds the next item from the given point, searching in the specified direction (Inherited from ListView.)
Public method | FindNearestItem(SearchDirectionHint, Int32, Int32) | Finds the next item from the given x- and y-coordinates, searching in the specified direction. (Inherited from ListView.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemAt | Retrieves the item at the specified location. (Inherited from ListView.)
Public method | GetItemRect(Int32) | Retrieves the bounding rectangle for a specific item within the list view control. (Inherited from ListView.)
Public method | GetItemRect(Int32, ItemBoundsPortion) | Retrieves the specified portion of the bounding rectangle for a specific item within the list view control. (Inherited from ListView.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest(Point) | Provides item information, given a point. (Inherited from ListView.)
Public method | HitTest(Int32, Int32) | Provides item information, given x- and y-coordinates. (Inherited from ListView.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | RedrawItems | Forces a range of ListViewItem objects to be redrawn. (Inherited from ListView.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Sort | Sorts the items of the list view. (Inherited from ListView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListView control. (Inherited from ListView.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

BreakpointListView Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointListView Properties

BreakpointListView Properties

The BreakpointListView type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Activation | Gets or sets the type of action the user must take to activate an item. (Inherited from ListView.)
Public property | Alignment | Gets or sets the alignment of items in the control. (Inherited from ListView.)
Public property | AllowColumnReorder | Gets or sets a value indicating whether the user can drag column headers to reorder columns in the control. (Inherited from ListView.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoArrange | Gets or sets whether icons are automatically kept arranged. (Inherited from ListView.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color. (Inherited from ListView.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets an ImageLayout value. (Inherited from ListView.)
Public property | BackgroundImageTiled | Gets or sets a value indicating whether the background image of the ListView should be tiled. (Inherited from ListView.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the control. (Inherited from ListView.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control. (Inherited from ListView.)
Public property | CheckedIndices | Gets the indexes of the currently checked items in the control. (Inherited from ListView.)
Public property | CheckedItems | Gets the currently checked items in the control. (Inherited from ListView.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | Columns | Gets the collection of all column headers that appear in the control. (Inherited from ListView.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusedItem | Gets or sets the item in the control that currently has focus. (Inherited from ListView.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color. (Inherited from ListView.)
Public property | FullRowSelect | Gets or sets a value indicating whether clicking an item selects all its subitems. (Inherited from ListView.)
Public property | GridLines | Gets or sets a value indicating whether grid lines appear between the rows and columns containing the items and subitems in the control. (Inherited from ListView.)
Public property | Groups | Gets the collection of ListViewGroup objects assigned to the control. (Inherited from ListView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | HeaderStyle | Gets or sets the column header style. (Inherited from ListView.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected item in the control remains highlighted when the control loses focus. (Inherited from ListView.)
Public property | HotTracking | Gets or sets a value indicating whether the text of an item or subitem has the appearance of a hyperlink when the mouse pointer passes over it. (Inherited from ListView.)
Public property | HoverSelection | Gets or sets a value indicating whether an item is automatically selected when the mouse pointer remains over the item for a few seconds. (Inherited from ListView.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InsertionMark | Gets an object used to indicate the expected drop location when an item is dragged within a ListView control. (Inherited from ListView.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets a collection containing all items in the control. (Inherited from ListView.)
Public property | LabelEdit | Gets or sets a value indicating whether the user can edit the labels of items in the control. (Inherited from ListView.)
Public property | LabelWrap | Gets or sets a value indicating whether item labels wrap when items are displayed in the control as icons. (Inherited from ListView.)
Public property | LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control. (Inherited from ListView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListViewItemSorter | Gets or sets the sorting comparer for the control. (Inherited from ListView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiSelect | Gets or sets a value indicating whether multiple items can be selected. (Inherited from ListView.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | OwnerDraw | Gets or sets a value indicating whether the ListView control is drawn by the operating system or by code that you provide. (Inherited from ListView.)
Public property | Padding | Gets or sets the space between the ListView control and its contents. (Inherited from ListView.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether the control is laid out from right to left. (Inherited from ListView.)
Public property | Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items. (Inherited from ListView.)
Public property | SelectedIndices | Gets the indexes of the selected items in the control. (Inherited from ListView.)
Public property | SelectedItems | Gets the items that are selected in the control. (Inherited from ListView.)
Public property | ShowGroups | Gets or sets a value indicating whether items are displayed in groups. (Inherited from ListView.)
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are shown for the ListViewItem objects contained in the ListView. (Inherited from ListView.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control. (Inherited from ListView.)
Public property | Sorting | Gets or sets the sort order for items in the control. (Inherited from ListView.)
Public property | StateImageList | Gets or sets the ImageList associated with application-defined states in the control. (Inherited from ListView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This property is not relevant for this class. (Inherited from ListView.)
Public property | TileSize | Gets or sets the size of the tiles shown in tile view. (Inherited from ListView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopItem | Gets or sets the first visible item in the control. (Inherited from ListView.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCompatibleStateImageBehavior | Gets or sets a value indicating whether the ListView uses state image behavior that is compatible with the .NET Framework 1.1 or the .NET Framework 2.0. (Inherited from ListView.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | View | Gets or sets how items are displayed in the control. (Inherited from ListView.)
Public property | VirtualListSize | Gets or sets the number of ListViewItem objects contained in the list when in virtual mode. (Inherited from ListView.)
Public property | VirtualMode | Gets or sets a value indicating whether you have provided your own data-management operations for the ListView control. (Inherited from ListView.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

BreakpointListView Class
Alternet.Scripter.Debugger.UI Namespace


BreakpointListView Events

BreakpointListView Events

The BreakpointListView type exposes the following members.

Events
 | Name | Description
Public event | AfterLabelEdit | Occurs when the label for an item is edited by the user. (Inherited from ListView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListView.)
Public event | BeforeLabelEdit | Occurs when the user starts editing the label of an item. (Inherited from ListView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CacheVirtualItems | Occurs when the contents of the display area for a ListView in virtual mode has changed, and the ListView determines that a new range of items is needed. (Inherited from ListView.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ColumnClick | Occurs when the user clicks a column header within the list view control. (Inherited from ListView.)
Public event | ColumnReordered | Occurs when the column header order is changed. (Inherited from ListView.)
Public event | ColumnWidthChanged | Occurs after the width of a column is successfully changed. (Inherited from ListView.)
Public event | ColumnWidthChanging | Occurs when the width of a column is changing. (Inherited from ListView.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawColumnHeader | Occurs when the details view of a ListView is drawn and the OwnerDraw property is set to true. (Inherited from ListView.)
Public event | DrawItem | Occurs when a ListView is drawn and the OwnerDraw property is set to true. (Inherited from ListView.)
Public event | DrawSubItem | Occurs when the details view of a ListView is drawn and the OwnerDraw property is set to true. (Inherited from ListView.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemActivate | Occurs when an item is activated. (Inherited from ListView.)
Public event | ItemCheck | Occurs when the check state of an item changes. (Inherited from ListView.)
Public event | ItemChecked | Occurs when the checked state of an item changes. (Inherited from ListView.)
Public event | ItemDrag | Occurs when the user begins dragging an item. (Inherited from ListView.)
Public event | ItemMouseHover | Occurs when the mouse hovers over an item. (Inherited from ListView.)
Public event | ItemSelectionChanged | Occurs when the selection state of an item changes. (Inherited from ListView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListView.)
Public event | Paint | Occurs when the ListView control is painted. (Inherited from ListView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RetrieveVirtualItem | Occurs when the ListView is in virtual mode and requires a ListViewItem. (Inherited from ListView.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from ListView.)
Public event | SearchForVirtualItem | Occurs when the ListView is in virtual mode and a search is taking place. (Inherited from ListView.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndices collection changes. (Inherited from ListView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property changes. (Inherited from ListView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VirtualItemsSelectionRangeChanged | Occurs when a ListView is in virtual mode and the selection state of a range of items has changed. (Inherited from ListView.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

BreakpointListView Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints Class

Breakpoints Class
Displays list of breakpoints during script debugging.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Scripter.Debugger.UIBreakpoints

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Breakpoints : UserControl
Public Class Breakpoints
    Inherits UserControl
public ref class Breakpoints : public UserControl
type Breakpoints =
    class
        inherit UserControl
    end

The Breakpoints type exposes the following members.

Constructors
 | Name | Description
Public method | Breakpoints | Initializes a new instance of the Breakpoints class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears breakpoint list.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | Toggle | Sets or removes breakpoint at a specified position.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | UpdateList | Updates list of breakpoints from the debugger's breakpoints collection.
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Fields
 | Name | Description
Public field | lvBreakpoints |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which breakpoints are displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedBreakpoint | Gets currently selected breakpoint.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BreakpointClick | When implemented by a class, occurs when user clicks on a breakpoint in the list.
Public event | BreakpointDeleted | When implemented by a class, occurs when given breakpoint is being deleted.
Public event | BreakpointStateChanged | When implemented by a class, occurs when given breakpoint state changes.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


Breakpoints Constructor

Breakpoints Constructor
Initializes a new instance of the Breakpoints class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoints()
Public Sub New
public:
Breakpoints()
new : unit -> Breakpoints
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints Fields

Breakpoints Fields

The Breakpoints type exposes the following members.

Fields
 | Name | Description
Public field | lvBreakpoints |
Top
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.lvBreakpoints Field

BreakpointslvBreakpoints Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BreakpointListView lvBreakpoints
Public lvBreakpoints As BreakpointListView
public:
BreakpointListView^ lvBreakpoints
val mutable lvBreakpoints: BreakpointListView

Field Value

Type: BreakpointListView
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints Methods

Breakpoints Methods

The Breakpoints type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears breakpoint list.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | Toggle | Sets or removes breakpoint at a specified position.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | UpdateList | Updates list of breakpoints from the debugger's breakpoints collection.
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.Clear Method

BreakpointsClear Method
Clears breakpoint list.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.Localize Method

BreakpointsLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.Toggle Method

BreakpointsToggle Method
Sets or removes breakpoint at a specified position.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Toggle(
    string file,
    int line
)
Public Sub Toggle (
    file As String,
    line As Integer
)
public:
void Toggle(
    String^ file,
    int line
)
member Toggle :
        file : string *
        line : int -> unit

Parameters

file
Type: SystemString
File name where breakpoint is be set or removed.
line
Type: SystemInt32
Index of line where breakpoint is to be set or removed.
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.UpdateList Method

BreakpointsUpdateList Method
Updates list of breakpoints from the debugger's breakpoints collection.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateList()
Public Sub UpdateList
public:
void UpdateList()
member UpdateList : unit -> unit
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints Properties

Breakpoints Properties

The Breakpoints type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which breakpoints are displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedBreakpoint | Gets currently selected breakpoint.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.Debugger Property

BreakpointsDebugger Property
Gets or sets IScriptDebuggerBase which breakpoints are displayed by this user control.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.SelectedBreakpoint Property

BreakpointsSelectedBreakpoint Property
Gets currently selected breakpoint.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoint SelectedBreakpoint { get; }
Public ReadOnly Property SelectedBreakpoint As Breakpoint
    Get
public:
property Breakpoint^ SelectedBreakpoint {
    Breakpoint^ get ();
}
member SelectedBreakpoint : Breakpoint with get

Property Value

Type: Breakpoint
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints Events

Breakpoints Events

The Breakpoints type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BreakpointClick | When implemented by a class, occurs when user clicks on a breakpoint in the list.
Public event | BreakpointDeleted | When implemented by a class, occurs when given breakpoint is being deleted.
Public event | BreakpointStateChanged | When implemented by a class, occurs when given breakpoint state changes.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.BreakpointClick Event

BreakpointsBreakpointClick Event
When implemented by a class, occurs when user clicks on a breakpoint in the list.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointClickEventArgs> BreakpointClick
Public Event BreakpointClick As EventHandler(Of BreakpointClickEventArgs)
public:
 event EventHandler<BreakpointClickEventArgs^>^ BreakpointClick {
    void add (EventHandler<BreakpointClickEventArgs^>^ value);
    void remove (EventHandler<BreakpointClickEventArgs^>^ value);
}
member BreakpointClick : IEvent<EventHandler<BreakpointClickEventArgs>,
    BreakpointClickEventArgs>

Value

Type: SystemEventHandlerBreakpointClickEventArgs
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.BreakpointDeleted Event

BreakpointsBreakpointDeleted Event
When implemented by a class, occurs when given breakpoint is being deleted.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointChangedEventArgs> BreakpointDeleted
Public Event BreakpointDeleted As EventHandler(Of BreakpointChangedEventArgs)
public:
 event EventHandler<BreakpointChangedEventArgs^>^ BreakpointDeleted {
    void add (EventHandler<BreakpointChangedEventArgs^>^ value);
    void remove (EventHandler<BreakpointChangedEventArgs^>^ value);
}
member BreakpointDeleted : IEvent<EventHandler<BreakpointChangedEventArgs>,
    BreakpointChangedEventArgs>

Value

Type: SystemEventHandlerBreakpointChangedEventArgs
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


Breakpoints.BreakpointStateChanged Event

BreakpointsBreakpointStateChanged Event
When implemented by a class, occurs when given breakpoint state changes.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<BreakpointChangedEventArgs> BreakpointStateChanged
Public Event BreakpointStateChanged As EventHandler(Of BreakpointChangedEventArgs)
public:
 event EventHandler<BreakpointChangedEventArgs^>^ BreakpointStateChanged {
    void add (EventHandler<BreakpointChangedEventArgs^>^ value);
    void remove (EventHandler<BreakpointChangedEventArgs^>^ value);
}
member BreakpointStateChanged : IEvent<EventHandler<BreakpointChangedEventArgs>,
    BreakpointChangedEventArgs>

Value

Type: SystemEventHandlerBreakpointChangedEventArgs
See Also

Reference

Breakpoints Class
Alternet.Scripter.Debugger.UI Namespace


CallStack Class

CallStack Class
Displays list of call stack frames during script debugging.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Scripter.Debugger.UICallStack

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CallStack : UserControl
Public Class CallStack
    Inherits UserControl
public ref class CallStack : public UserControl
type CallStack =
    class
        inherit UserControl
    end

The CallStack type exposes the following members.

Constructors
 | Name | Description
Public method | CallStack | Initializes a new instance of the CallStack class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetFrames | Sets list of call stack frames to be displayed.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TrySwitchToTopUserStackFrame | Switches debugging to the given stack frame.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Fields
 | Name | Description
Public field | lvCallStack |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which stack frames displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedFrame | Gets a currently selected stack frame.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CallStackClick | When implemented by a class, occurs when user clicks on a call stack frame in the list.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FramesChanged | When implemented by a class, occurs when current stack frame changes.
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


CallStack Constructor

CallStack Constructor
Initializes a new instance of the CallStack class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CallStack()
Public Sub New
public:
CallStack()
new : unit -> CallStack
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack Fields

CallStack Fields

The CallStack type exposes the following members.

Fields
 | Name | Description
Public field | lvCallStack |
Top
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack.lvCallStack Field

CallStacklvCallStack Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListView lvCallStack
Public lvCallStack As ListView
public:
ListView^ lvCallStack
val mutable lvCallStack: ListView

Field Value

Type: ListView
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack Methods

CallStack Methods

The CallStack type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetFrames | Sets list of call stack frames to be displayed.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TrySwitchToTopUserStackFrame | Switches debugging to the given stack frame.
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack.Localize Method

CallStackLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack.SetFrames Method

CallStackSetFrames Method
Sets list of call stack frames to be displayed.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFrames(
    StackFrame[] frames
)
Public Sub SetFrames (
    frames As StackFrame()
)
public:
void SetFrames(
    array<StackFrame^>^ frames
)
member SetFrames :
        frames : StackFrame[] -> unit

Parameters

frames
Type: Alternet.Scripter.DebuggerStackFrame
List of frames to display.
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack.TrySwitchToTopUserStackFrame Method

CallStackTrySwitchToTopUserStackFrame Method
Switches debugging to the given stack frame.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void TrySwitchToTopUserStackFrame()
Public Sub TrySwitchToTopUserStackFrame
public:
void TrySwitchToTopUserStackFrame()
member TrySwitchToTopUserStackFrame : unit -> unit
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack Properties

CallStack Properties

The CallStack type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which stack frames displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedFrame | Gets a currently selected stack frame.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack.Debugger Property

CallStackDebugger Property
Gets or sets IScriptDebuggerBase which stack frames displayed by this user control.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack.SelectedFrame Property

CallStackSelectedFrame Property
Gets a currently selected stack frame.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StackFrame SelectedFrame { get; }
Public ReadOnly Property SelectedFrame As StackFrame
    Get
public:
property StackFrame^ SelectedFrame {
    StackFrame^ get ();
}
member SelectedFrame : StackFrame with get

Property Value

Type: StackFrame
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack Events

CallStack Events

The CallStack type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CallStackClick | When implemented by a class, occurs when user clicks on a call stack frame in the list.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FramesChanged | When implemented by a class, occurs when current stack frame changes.
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack.CallStackClick Event

CallStackCallStackClick Event
When implemented by a class, occurs when user clicks on a call stack frame in the list.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<CallStackClickEventArgs> CallStackClick
Public Event CallStackClick As EventHandler(Of CallStackClickEventArgs)
public:
 event EventHandler<CallStackClickEventArgs^>^ CallStackClick {
    void add (EventHandler<CallStackClickEventArgs^>^ value);
    void remove (EventHandler<CallStackClickEventArgs^>^ value);
}
member CallStackClick : IEvent<EventHandler<CallStackClickEventArgs>,
    CallStackClickEventArgs>

Value

Type: SystemEventHandlerCallStackClickEventArgs
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStack.FramesChanged Event

CallStackFramesChanged Event
When implemented by a class, occurs when current stack frame changes.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler FramesChanged
Public Event FramesChanged As EventHandler
public:
 event EventHandler^ FramesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member FramesChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

CallStack Class
Alternet.Scripter.Debugger.UI Namespace


CallStackClickEventArgs Class

CallStackClickEventArgs Class
Provides data for the CallStack.CallStackClick event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.Debugger.UICallStackClickEventArgs

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CallStackClickEventArgs : EventArgs
Public Class CallStackClickEventArgs
    Inherits EventArgs
public ref class CallStackClickEventArgs : public EventArgs
type CallStackClickEventArgs =
    class
        inherit EventArgs
    end

The CallStackClickEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CallStackClickEventArgs | Initializes a new instance of the CallStackClickEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | StackFrame | Gets or sets a StackFrame currently selected in the Call Stack list.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


CallStackClickEventArgs Constructor

CallStackClickEventArgs Constructor
Initializes a new instance of the CallStackClickEventArgs class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CallStackClickEventArgs()
Public Sub New
public:
CallStackClickEventArgs()
new : unit -> CallStackClickEventArgs
See Also

Reference

CallStackClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


CallStackClickEventArgs Methods

CallStackClickEventArgs Methods

The CallStackClickEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CallStackClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


CallStackClickEventArgs Properties

CallStackClickEventArgs Properties

The CallStackClickEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | StackFrame | Gets or sets a StackFrame currently selected in the Call Stack list.
Top
See Also

Reference

CallStackClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


CallStackClickEventArgs.StackFrame Property

CallStackClickEventArgsStackFrame Property
Gets or sets a StackFrame currently selected in the Call Stack list.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StackFrame StackFrame { get; set; }
Public Property StackFrame As StackFrame
    Get
    Set
public:
property StackFrame^ StackFrame {
    StackFrame^ get ();
    void set (StackFrame^ value);
}
member StackFrame : StackFrame with get, set

Property Value

Type: StackFrame
See Also

Reference

CallStackClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


DebuggerControlToolbar Class

DebuggerControlToolbar Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsToolStrip
Alternet.Scripter.Debugger.UIDebuggerControlToolbar

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebuggerControlToolbar : ToolStrip
Public Class DebuggerControlToolbar
    Inherits ToolStrip
public ref class DebuggerControlToolbar : public ToolStrip
type DebuggerControlToolbar =
    class
        inherit ToolStrip
    end

The DebuggerControlToolbar type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerControlToolbar | Initializes a new instance of the DebugToolStrip class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
Public method | GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the ToolStrip control. (Inherited from ToolStrip.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
Public property | AllowItemReorder | Gets or sets a value indicating whether drag-and-drop and item reordering are handled privately by the ToolStrip class. (Inherited from ToolStrip.)
Public property | AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
Public property | Anchor | Gets or sets the edges of the container to which a ToolStrip is bound and determines how a ToolStrip is resized with its parent. (Inherited from ToolStrip.)
Public property | AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (Inherited from ToolStrip.)
Public property | BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanOverflow | Gets or sets a value indicating whether items in the ToolStrip can be sent to an overflow menu. (Inherited from ToolStrip.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CommandsListener | Gets or sets list of the Debugger commands for the Debugger UI.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which errors will be displayed by this user control.
Public property | DefaultDropDownDirection | Gets or sets a value representing the default direction in which a ToolStripDropDown control is displayed relative to the ToolStrip. (Inherited from ToolStrip.)
Public property | DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which ToolStrip borders are docked to its parent control and determines how a ToolStrip is resized with its parent. (Inherited from ToolStrip.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font used to display text in the control. (Inherited from ToolStrip.)
Public property | ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
Public property | GripDisplayStyle | Gets the orientation of the ToolStrip move handle. (Inherited from ToolStrip.)
Public property | GripMargin | Gets or sets the space around the ToolStrip move handle. (Inherited from ToolStrip.)
Public property | GripRectangle | Gets the boundaries of the ToolStrip move handle. (Inherited from ToolStrip.)
Public property | GripStyle | Gets or sets whether the ToolStrip move handle is visible or hidden. (Inherited from ToolStrip.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
Public property | ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
Public property | LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
Public property | LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
Public property | LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
Public property | OverflowButton | Gets the ToolStripItem that is the overflow button for a ToolStrip with overflow enabled. (Inherited from ToolStrip.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
Public property | RenderMode | Gets or sets a value that indicates which visual styles will be applied to the ToolStrip. (Inherited from ToolStrip.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Stretch | Gets or sets a value indicating whether the ToolStrip stretches from end to end in the ToolStripContainer. (Inherited from ToolStrip.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextDirection | Gets or sets the direction in which to draw text on a ToolStrip. (Inherited from ToolStrip.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Public event | DebuggerPreStartup |
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStrip.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
Public event | ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
Public event | LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


DebuggerControlToolbar Constructor

DebuggerControlToolbar Constructor
Initializes a new instance of the DebugToolStrip class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerControlToolbar()
Public Sub New
public:
DebuggerControlToolbar()
new : unit -> DebuggerControlToolbar
See Also

Reference

DebuggerControlToolbar Class
Alternet.Scripter.Debugger.UI Namespace


DebuggerControlToolbar Methods

DebuggerControlToolbar Methods

The DebuggerControlToolbar type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
Public method | GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the ToolStrip control. (Inherited from ToolStrip.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

DebuggerControlToolbar Class
Alternet.Scripter.Debugger.UI Namespace


DebuggerControlToolbar.Localize Method

DebuggerControlToolbarLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

DebuggerControlToolbar Class
Alternet.Scripter.Debugger.UI Namespace


DebuggerControlToolbar Properties

DebuggerControlToolbar Properties

The DebuggerControlToolbar type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
Public property | AllowItemReorder | Gets or sets a value indicating whether drag-and-drop and item reordering are handled privately by the ToolStrip class. (Inherited from ToolStrip.)
Public property | AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
Public property | Anchor | Gets or sets the edges of the container to which a ToolStrip is bound and determines how a ToolStrip is resized with its parent. (Inherited from ToolStrip.)
Public property | AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (Inherited from ToolStrip.)
Public property | BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanOverflow | Gets or sets a value indicating whether items in the ToolStrip can be sent to an overflow menu. (Inherited from ToolStrip.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CommandsListener | Gets or sets list of the Debugger commands for the Debugger UI.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which errors will be displayed by this user control.
Public property | DefaultDropDownDirection | Gets or sets a value representing the default direction in which a ToolStripDropDown control is displayed relative to the ToolStrip. (Inherited from ToolStrip.)
Public property | DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which ToolStrip borders are docked to its parent control and determines how a ToolStrip is resized with its parent. (Inherited from ToolStrip.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font used to display text in the control. (Inherited from ToolStrip.)
Public property | ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
Public property | GripDisplayStyle | Gets the orientation of the ToolStrip move handle. (Inherited from ToolStrip.)
Public property | GripMargin | Gets or sets the space around the ToolStrip move handle. (Inherited from ToolStrip.)
Public property | GripRectangle | Gets the boundaries of the ToolStrip move handle. (Inherited from ToolStrip.)
Public property | GripStyle | Gets or sets whether the ToolStrip move handle is visible or hidden. (Inherited from ToolStrip.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
Public property | ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
Public property | LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
Public property | LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
Public property | LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
Public property | OverflowButton | Gets the ToolStripItem that is the overflow button for a ToolStrip with overflow enabled. (Inherited from ToolStrip.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
Public property | RenderMode | Gets or sets a value that indicates which visual styles will be applied to the ToolStrip. (Inherited from ToolStrip.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Stretch | Gets or sets a value indicating whether the ToolStrip stretches from end to end in the ToolStripContainer. (Inherited from ToolStrip.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextDirection | Gets or sets the direction in which to draw text on a ToolStrip. (Inherited from ToolStrip.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DebuggerControlToolbar Class
Alternet.Scripter.Debugger.UI Namespace


DebuggerControlToolbar.CommandsListener Property

DebuggerControlToolbarCommandsListener Property
Gets or sets list of the Debugger commands for the Debugger UI.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDebuggerUICommands CommandsListener { get; set; }
Public Property CommandsListener As IDebuggerUICommands
    Get
    Set
public:
property IDebuggerUICommands^ CommandsListener {
    IDebuggerUICommands^ get ();
    void set (IDebuggerUICommands^ value);
}
member CommandsListener : IDebuggerUICommands with get, set

Property Value

Type: IDebuggerUICommands
See Also

Reference

DebuggerControlToolbar Class
Alternet.Scripter.Debugger.UI Namespace


DebuggerControlToolbar.Debugger Property

DebuggerControlToolbarDebugger Property
Gets or sets IScriptDebuggerBase which errors will be displayed by this user control.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

DebuggerControlToolbar Class
Alternet.Scripter.Debugger.UI Namespace


DebuggerControlToolbar Events

DebuggerControlToolbar Events

The DebuggerControlToolbar type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Public event | DebuggerPreStartup |
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStrip.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
Public event | ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
Public event | LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DebuggerControlToolbar Class
Alternet.Scripter.Debugger.UI Namespace


DebuggerControlToolbar.DebuggerPreStartup Event

DebuggerControlToolbarDebuggerPreStartup Event

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DebuggerPreStartup
Public Event DebuggerPreStartup As EventHandler
public:
 event EventHandler^ DebuggerPreStartup {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DebuggerPreStartup : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

DebuggerControlToolbar Class
Alternet.Scripter.Debugger.UI Namespace


DebugMenu Class

DebugMenu Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripMenuItem
Alternet.Scripter.Debugger.UIDebugMenu

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebugMenu : ToolStripMenuItem
Public Class DebugMenu
    Inherits ToolStripMenuItem
public ref class DebugMenu : public ToolStripMenuItem
type DebugMenu =
    class
        inherit ToolStripMenuItem
    end

The DebugMenu type exposes the following members.

Constructors
 | Name | Description
Public method | DebugMenu | Initializes a new instance of the DebugMenu class with default settings.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from ToolStripItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCurrentParent | Retrieves the ToolStrip that is the container of the current ToolStripItem. (Inherited from ToolStripItem.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fit. (Inherited from ToolStripItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HideDropDown | Makes a visible ToolStripDropDown hidden. (Inherited from ToolStripDropDownItem.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the ToolStripItem and causes it to be redrawn. (Inherited from ToolStripItem.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the ToolStripItem by adding it to the update region of the ToolStripItem, which is the area that will be repainted at the next paint operation, and causes a paint message to be sent to the ToolStripItem. (Inherited from ToolStripItem.)
Public method | Localize |
Public method | PerformClick | Generates a Click event for a ToolStripItem. (Inherited from ToolStripItem.)
Public method | ResetBackColor | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetDisplayStyle | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetFont | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetForeColor | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetImage | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetMargin | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetPadding | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetRightToLeft | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetTextDirection | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | Select | Selects the item. (Inherited from ToolStripItem.)
Public method | ShowDropDown | Displays the ToolStripDropDownItem control associated with this ToolStripDropDownItem. (Inherited from ToolStripDropDownItem.)
Public method | ToString | (Inherited from ToolStripItem.)
Public method | UpdateShortcut |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ToolStripItem.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from ToolStripItem.)
Public property | AccessibleDescription | Gets or sets the description that will be reported to accessibility client applications. (Inherited from ToolStripItem.)
Public property | AccessibleName | Gets or sets the name of the control for use by accessibility client applications. (Inherited from ToolStripItem.)
Public property | AccessibleRole | Gets or sets the accessible role of the control, which specifies the type of user interface element of the control. (Inherited from ToolStripItem.)
Public property | Alignment | Gets or sets a value indicating whether the item aligns towards the beginning or end of the ToolStrip. (Inherited from ToolStripItem.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStripItem.)
Public property | Anchor | Gets or sets the edges of the container to which a ToolStripItem is bound and determines how a ToolStripItem is resized with its parent. (Inherited from ToolStripItem.)
Public property | AutoSize | Gets or sets a value indicating whether the item is automatically sized. (Inherited from ToolStripItem.)
Public property | AutoToolTip | Gets or sets a value indicating whether to use the Text property or the ToolTipText property for the ToolStripItem ToolTip. (Inherited from ToolStripItem.)
Public property | Available | Gets or sets a value indicating whether the ToolStripItem should be placed on a ToolStrip. (Inherited from ToolStripItem.)
Public property | BackColor | Gets or sets the background color for the item. (Inherited from ToolStripItem.)
Public property | BackgroundImage | Gets or sets the background image displayed in the item. (Inherited from ToolStripItem.)
Public property | BackgroundImageLayout | Gets or sets the background image layout used for the ToolStripItem. (Inherited from ToolStripItem.)
Public property | Bounds | Gets the size and location of the item. (Inherited from ToolStripItem.)
Public property | CanSelect | Gets a value indicating whether the item can be selected. (Inherited from ToolStripItem.)
Public property | Checked | Gets or sets a value indicating whether the ToolStripMenuItem is checked. (Inherited from ToolStripMenuItem.)
Public property | CheckOnClick | Gets or sets a value indicating whether the ToolStripMenuItem should automatically appear checked and unchecked when clicked. (Inherited from ToolStripMenuItem.)
Public property | CheckState | Gets or sets a value indicating whether a ToolStripMenuItem is in the checked, unchecked, or indeterminate state. (Inherited from ToolStripMenuItem.)
Public property | CommandsListener | Gets or sets list of the Debugger commands for the Debugger UI.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContentRectangle | Gets the area where content, such as text and icons, can be placed within a ToolStripItem without overwriting background borders. (Inherited from ToolStripItem.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which errors will be displayed by this user control.
Public property | DisplayStyle | Gets or sets whether text and images are displayed on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | Dock | Gets or sets which ToolStripItem borders are docked to its parent control and determines how a ToolStripItem is resized with its parent. (Inherited from ToolStripItem.)
Public property | DoubleClickEnabled | Gets or sets a value indicating whether the ToolStripItem can be activated by double-clicking the mouse. (Inherited from ToolStripItem.)
Public property | DropDown | Gets or sets the ToolStripDropDown that will be displayed when this ToolStripDropDownItem is clicked. (Inherited from ToolStripDropDownItem.)
Public property | DropDownDirection | Gets or sets a value indicating the direction in which the ToolStripDropDownItem emerges from its parent container. (Inherited from ToolStripDropDownItem.)
Public property | DropDownItems | Gets the collection of items in the ToolStripDropDown that is associated with this ToolStripDropDownItem. (Inherited from ToolStripDropDownItem.)
Public property | Enabled | Gets or sets a value indicating whether the control is enabled. (Inherited from ToolStripMenuItem.)
Public property | Font | Gets or sets the font of the text displayed by the item. (Inherited from ToolStripItem.)
Public property | ForeColor | Gets or sets the foreground color of the item. (Inherited from ToolStripItem.)
Public property | HasDropDown | Gets or sets a value that indicates whether the DropDown for the ToolStripDropDownItem has been created. (Inherited from ToolStripDropDownItem.)
Public property | HasDropDownItems | Gets a value indicating whether the ToolStripDropDownItem has ToolStripDropDown controls associated with it. (Inherited from ToolStripDropDownItem.)
Public property | Height | Gets or sets the height, in pixels, of a ToolStripItem. (Inherited from ToolStripItem.)
Public property | Image | Gets or sets the image that is displayed on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | ImageAlign | Gets or sets the alignment of the image on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | ImageIndex | Gets or sets the index value of the image that is displayed on the item. (Inherited from ToolStripItem.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList that is displayed on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | ImageScaling | Gets or sets a value indicating whether an image on a ToolStripItem is automatically resized to fit in a container. (Inherited from ToolStripItem.)
Public property | ImageTransparentColor | Gets or sets the color to treat as transparent in a ToolStripItem image. (Inherited from ToolStripItem.)
Public property | IsDisposed | Gets a value indicating whether the object has been disposed of. (Inherited from ToolStripItem.)
Public property | IsMdiWindowListEntry | Gets a value indicating whether the ToolStripMenuItem appears on a multiple document interface (MDI) window list. (Inherited from ToolStripMenuItem.)
Public property | IsOnDropDown | Gets a value indicating whether the container of the current Control is a ToolStripDropDown. (Inherited from ToolStripItem.)
Public property | IsOnOverflow | Gets a value indicating whether the Placement property is set to Overflow. (Inherited from ToolStripItem.)
Public property | Margin | Gets or sets the space between the item and adjacent items. (Inherited from ToolStripItem.)
Public property | MergeAction | Gets or sets how child menus are merged with parent menus. (Inherited from ToolStripItem.)
Public property | MergeIndex | Gets or sets the position of a merged item within the current ToolStrip. (Inherited from ToolStripItem.)
Public property | Name | Gets or sets the name of the item. (Inherited from ToolStripItem.)
Public property | Overflow | Gets or sets a value indicating whether the ToolStripMenuItem is attached to the ToolStrip or the ToolStripOverflowButton or whether it can float between the two. (Inherited from ToolStripMenuItem.)
Public property | Owner | Gets or sets the owner of this item. (Inherited from ToolStripItem.)
Public property | OwnerItem | Gets the parent ToolStripItem of this ToolStripItem. (Inherited from ToolStripItem.)
Public property | Padding | Gets or sets the internal spacing, in pixels, between the item's contents and its edges. (Inherited from ToolStripItem.)
Public property | Placement | Gets the current layout of the item. (Inherited from ToolStripItem.)
Public property | Pressed | Gets a value indicating whether the ToolStripDropDownItem is in the pressed state. (Inherited from ToolStripDropDownItem.)
Public property | RightToLeft | Gets or sets a value indicating whether items are to be placed from right to left and text is to be written from right to left. (Inherited from ToolStripItem.)
Public property | RightToLeftAutoMirrorImage | Mirrors automatically the ToolStripItem image when the RightToLeft property is set to Yes. (Inherited from ToolStripItem.)
Public property | Selected | Gets a value indicating whether the item is selected. (Inherited from ToolStripItem.)
Public property | ShortcutKeyDisplayString | Gets or sets the shortcut key text. (Inherited from ToolStripMenuItem.)
Public property | ShortcutKeys | Gets or sets the shortcut keys associated with the ToolStripMenuItem. (Inherited from ToolStripMenuItem.)
Public property | ShowShortcutKeys | Gets or sets a value indicating whether the shortcut keys that are associated with the ToolStripMenuItem are displayed next to the ToolStripMenuItem. (Inherited from ToolStripMenuItem.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Size | Gets or sets the size of the item. (Inherited from ToolStripItem.)
Public property | Tag | Gets or sets the object that contains data about the item. (Inherited from ToolStripItem.)
Public property | Text | Gets or sets the text that is to be displayed on the item. (Inherited from ToolStripItem.)
Public property | TextAlign | Gets or sets the alignment of the text on a ToolStripLabel. (Inherited from ToolStripItem.)
Public property | TextDirection | Gets the orientation of text used on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | TextImageRelation | Gets or sets the position of ToolStripItem text and image relative to each other. (Inherited from ToolStripItem.)
Public property | ToolTipText | Gets or sets the text that appears as a ToolTip for a control. (Inherited from ToolStripItem.)
Public property | Visible | Gets or sets a value indicating whether the item is displayed. (Inherited from ToolStripItem.)
Public property | Width | Gets or sets the width in pixels of a ToolStripItem. (Inherited from ToolStripItem.)
Top
Events
 | Name | Description
Public event | AvailableChanged | Occurs when the value of the Available property changes. (Inherited from ToolStripItem.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from ToolStripItem.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from ToolStripMenuItem.)
Public event | CheckStateChanged | Occurs when the value of the CheckState property changes. (Inherited from ToolStripMenuItem.)
Public event | Click | Occurs when the ToolStripItem is clicked. (Inherited from ToolStripItem.)
Public event | DebuggerPreStartup |
Public event | DisplayStyleChanged | Occurs when the DisplayStyle has changed. (Inherited from ToolStripItem.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DoubleClick | Occurs when the item is double-clicked with the mouse. (Inherited from ToolStripItem.)
Public event | DragDrop | Occurs when the user drags an item and the user releases the mouse button, indicating that the item should be dropped into this item. (Inherited from ToolStripItem.)
Public event | DragEnter | Occurs when the user drags an item into the client area of this item. (Inherited from ToolStripItem.)
Public event | DragLeave | Occurs when the user drags an item and the mouse pointer is no longer over the client area of this item. (Inherited from ToolStripItem.)
Public event | DragOver | Occurs when the user drags an item over the client area of this item. (Inherited from ToolStripItem.)
Public event | DropDownClosed | Occurs when the ToolStripDropDown closes. (Inherited from ToolStripDropDownItem.)
Public event | DropDownItemClicked | Occurs when the ToolStripDropDown is clicked. (Inherited from ToolStripDropDownItem.)
Public event | DropDownOpened | Occurs when the ToolStripDropDown has opened. (Inherited from ToolStripDropDownItem.)
Public event | DropDownOpening | Occurs as the ToolStripDropDown is opening. (Inherited from ToolStripDropDownItem.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from ToolStripItem.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from ToolStripItem.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from ToolStripItem.)
Public event | LocationChanged | Occurs when the location of a ToolStripItem is updated. (Inherited from ToolStripItem.)
Public event | MouseDown | Occurs when the mouse pointer is over the item and a mouse button is pressed. (Inherited from ToolStripItem.)
Public event | MouseEnter | Occurs when the mouse pointer enters the item. (Inherited from ToolStripItem.)
Public event | MouseHover | Occurs when the mouse pointer hovers over the item. (Inherited from ToolStripItem.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the item. (Inherited from ToolStripItem.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the item. (Inherited from ToolStripItem.)
Public event | MouseUp | Occurs when the mouse pointer is over the item and a mouse button is released. (Inherited from ToolStripItem.)
Public event | OwnerChanged | Occurs when the Owner property changes. (Inherited from ToolStripItem.)
Public event | Paint | Occurs when the item is redrawn. (Inherited from ToolStripItem.)
Public event | QueryAccessibilityHelp | Occurs when an accessibility client application invokes help for the ToolStripItem. (Inherited from ToolStripItem.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from ToolStripItem.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from ToolStripItem.)
Public event | TextChanged | Occurs when the value of the Text property changes. (Inherited from ToolStripItem.)
Public event | VisibleChanged | Occurs when the value of the Visible property changes. (Inherited from ToolStripItem.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


DebugMenu Constructor

DebugMenu Constructor
Initializes a new instance of the DebugMenu class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebugMenu()
Public Sub New
public:
DebugMenu()
new : unit -> DebugMenu
See Also

Reference

DebugMenu Class
Alternet.Scripter.Debugger.UI Namespace


DebugMenu Methods

DebugMenu Methods

The DebugMenu type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from ToolStripItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCurrentParent | Retrieves the ToolStrip that is the container of the current ToolStripItem. (Inherited from ToolStripItem.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fit. (Inherited from ToolStripItem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HideDropDown | Makes a visible ToolStripDropDown hidden. (Inherited from ToolStripDropDownItem.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the ToolStripItem and causes it to be redrawn. (Inherited from ToolStripItem.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the ToolStripItem by adding it to the update region of the ToolStripItem, which is the area that will be repainted at the next paint operation, and causes a paint message to be sent to the ToolStripItem. (Inherited from ToolStripItem.)
Public method | Localize |
Public method | PerformClick | Generates a Click event for a ToolStripItem. (Inherited from ToolStripItem.)
Public method | ResetBackColor | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetDisplayStyle | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetFont | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetForeColor | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetImage | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetMargin | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetPadding | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetRightToLeft | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | ResetTextDirection | This method is not relevant to this class. (Inherited from ToolStripItem.)
Public method | Select | Selects the item. (Inherited from ToolStripItem.)
Public method | ShowDropDown | Displays the ToolStripDropDownItem control associated with this ToolStripDropDownItem. (Inherited from ToolStripDropDownItem.)
Public method | ToString | (Inherited from ToolStripItem.)
Public method | UpdateShortcut |
Top
See Also

Reference

DebugMenu Class
Alternet.Scripter.Debugger.UI Namespace


DebugMenu.Localize Method

DebugMenuLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

DebugMenu Class
Alternet.Scripter.Debugger.UI Namespace


DebugMenu.UpdateShortcut Method

DebugMenuUpdateShortcut Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateShortcut(
    string name,
    Keys keys
)
Public Sub UpdateShortcut (
    name As String,
    keys As Keys
)
public:
void UpdateShortcut(
    String^ name,
    Keys keys
)
member UpdateShortcut :
        name : string *
        keys : Keys -> unit

Parameters

name
Type: SystemString
keys
Type: System.Windows.FormsKeys
See Also

Reference

DebugMenu Class
Alternet.Scripter.Debugger.UI Namespace


DebugMenu Properties

DebugMenu Properties

The DebugMenu type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from ToolStripItem.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from ToolStripItem.)
Public property | AccessibleDescription | Gets or sets the description that will be reported to accessibility client applications. (Inherited from ToolStripItem.)
Public property | AccessibleName | Gets or sets the name of the control for use by accessibility client applications. (Inherited from ToolStripItem.)
Public property | AccessibleRole | Gets or sets the accessible role of the control, which specifies the type of user interface element of the control. (Inherited from ToolStripItem.)
Public property | Alignment | Gets or sets a value indicating whether the item aligns towards the beginning or end of the ToolStrip. (Inherited from ToolStripItem.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStripItem.)
Public property | Anchor | Gets or sets the edges of the container to which a ToolStripItem is bound and determines how a ToolStripItem is resized with its parent. (Inherited from ToolStripItem.)
Public property | AutoSize | Gets or sets a value indicating whether the item is automatically sized. (Inherited from ToolStripItem.)
Public property | AutoToolTip | Gets or sets a value indicating whether to use the Text property or the ToolTipText property for the ToolStripItem ToolTip. (Inherited from ToolStripItem.)
Public property | Available | Gets or sets a value indicating whether the ToolStripItem should be placed on a ToolStrip. (Inherited from ToolStripItem.)
Public property | BackColor | Gets or sets the background color for the item. (Inherited from ToolStripItem.)
Public property | BackgroundImage | Gets or sets the background image displayed in the item. (Inherited from ToolStripItem.)
Public property | BackgroundImageLayout | Gets or sets the background image layout used for the ToolStripItem. (Inherited from ToolStripItem.)
Public property | Bounds | Gets the size and location of the item. (Inherited from ToolStripItem.)
Public property | CanSelect | Gets a value indicating whether the item can be selected. (Inherited from ToolStripItem.)
Public property | Checked | Gets or sets a value indicating whether the ToolStripMenuItem is checked. (Inherited from ToolStripMenuItem.)
Public property | CheckOnClick | Gets or sets a value indicating whether the ToolStripMenuItem should automatically appear checked and unchecked when clicked. (Inherited from ToolStripMenuItem.)
Public property | CheckState | Gets or sets a value indicating whether a ToolStripMenuItem is in the checked, unchecked, or indeterminate state. (Inherited from ToolStripMenuItem.)
Public property | CommandsListener | Gets or sets list of the Debugger commands for the Debugger UI.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContentRectangle | Gets the area where content, such as text and icons, can be placed within a ToolStripItem without overwriting background borders. (Inherited from ToolStripItem.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which errors will be displayed by this user control.
Public property | DisplayStyle | Gets or sets whether text and images are displayed on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | Dock | Gets or sets which ToolStripItem borders are docked to its parent control and determines how a ToolStripItem is resized with its parent. (Inherited from ToolStripItem.)
Public property | DoubleClickEnabled | Gets or sets a value indicating whether the ToolStripItem can be activated by double-clicking the mouse. (Inherited from ToolStripItem.)
Public property | DropDown | Gets or sets the ToolStripDropDown that will be displayed when this ToolStripDropDownItem is clicked. (Inherited from ToolStripDropDownItem.)
Public property | DropDownDirection | Gets or sets a value indicating the direction in which the ToolStripDropDownItem emerges from its parent container. (Inherited from ToolStripDropDownItem.)
Public property | DropDownItems | Gets the collection of items in the ToolStripDropDown that is associated with this ToolStripDropDownItem. (Inherited from ToolStripDropDownItem.)
Public property | Enabled | Gets or sets a value indicating whether the control is enabled. (Inherited from ToolStripMenuItem.)
Public property | Font | Gets or sets the font of the text displayed by the item. (Inherited from ToolStripItem.)
Public property | ForeColor | Gets or sets the foreground color of the item. (Inherited from ToolStripItem.)
Public property | HasDropDown | Gets or sets a value that indicates whether the DropDown for the ToolStripDropDownItem has been created. (Inherited from ToolStripDropDownItem.)
Public property | HasDropDownItems | Gets a value indicating whether the ToolStripDropDownItem has ToolStripDropDown controls associated with it. (Inherited from ToolStripDropDownItem.)
Public property | Height | Gets or sets the height, in pixels, of a ToolStripItem. (Inherited from ToolStripItem.)
Public property | Image | Gets or sets the image that is displayed on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | ImageAlign | Gets or sets the alignment of the image on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | ImageIndex | Gets or sets the index value of the image that is displayed on the item. (Inherited from ToolStripItem.)
Public property | ImageKey | Gets or sets the key accessor for the image in the ImageList that is displayed on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | ImageScaling | Gets or sets a value indicating whether an image on a ToolStripItem is automatically resized to fit in a container. (Inherited from ToolStripItem.)
Public property | ImageTransparentColor | Gets or sets the color to treat as transparent in a ToolStripItem image. (Inherited from ToolStripItem.)
Public property | IsDisposed | Gets a value indicating whether the object has been disposed of. (Inherited from ToolStripItem.)
Public property | IsMdiWindowListEntry | Gets a value indicating whether the ToolStripMenuItem appears on a multiple document interface (MDI) window list. (Inherited from ToolStripMenuItem.)
Public property | IsOnDropDown | Gets a value indicating whether the container of the current Control is a ToolStripDropDown. (Inherited from ToolStripItem.)
Public property | IsOnOverflow | Gets a value indicating whether the Placement property is set to Overflow. (Inherited from ToolStripItem.)
Public property | Margin | Gets or sets the space between the item and adjacent items. (Inherited from ToolStripItem.)
Public property | MergeAction | Gets or sets how child menus are merged with parent menus. (Inherited from ToolStripItem.)
Public property | MergeIndex | Gets or sets the position of a merged item within the current ToolStrip. (Inherited from ToolStripItem.)
Public property | Name | Gets or sets the name of the item. (Inherited from ToolStripItem.)
Public property | Overflow | Gets or sets a value indicating whether the ToolStripMenuItem is attached to the ToolStrip or the ToolStripOverflowButton or whether it can float between the two. (Inherited from ToolStripMenuItem.)
Public property | Owner | Gets or sets the owner of this item. (Inherited from ToolStripItem.)
Public property | OwnerItem | Gets the parent ToolStripItem of this ToolStripItem. (Inherited from ToolStripItem.)
Public property | Padding | Gets or sets the internal spacing, in pixels, between the item's contents and its edges. (Inherited from ToolStripItem.)
Public property | Placement | Gets the current layout of the item. (Inherited from ToolStripItem.)
Public property | Pressed | Gets a value indicating whether the ToolStripDropDownItem is in the pressed state. (Inherited from ToolStripDropDownItem.)
Public property | RightToLeft | Gets or sets a value indicating whether items are to be placed from right to left and text is to be written from right to left. (Inherited from ToolStripItem.)
Public property | RightToLeftAutoMirrorImage | Mirrors automatically the ToolStripItem image when the RightToLeft property is set to Yes. (Inherited from ToolStripItem.)
Public property | Selected | Gets a value indicating whether the item is selected. (Inherited from ToolStripItem.)
Public property | ShortcutKeyDisplayString | Gets or sets the shortcut key text. (Inherited from ToolStripMenuItem.)
Public property | ShortcutKeys | Gets or sets the shortcut keys associated with the ToolStripMenuItem. (Inherited from ToolStripMenuItem.)
Public property | ShowShortcutKeys | Gets or sets a value indicating whether the shortcut keys that are associated with the ToolStripMenuItem are displayed next to the ToolStripMenuItem. (Inherited from ToolStripMenuItem.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Size | Gets or sets the size of the item. (Inherited from ToolStripItem.)
Public property | Tag | Gets or sets the object that contains data about the item. (Inherited from ToolStripItem.)
Public property | Text | Gets or sets the text that is to be displayed on the item. (Inherited from ToolStripItem.)
Public property | TextAlign | Gets or sets the alignment of the text on a ToolStripLabel. (Inherited from ToolStripItem.)
Public property | TextDirection | Gets the orientation of text used on a ToolStripItem. (Inherited from ToolStripItem.)
Public property | TextImageRelation | Gets or sets the position of ToolStripItem text and image relative to each other. (Inherited from ToolStripItem.)
Public property | ToolTipText | Gets or sets the text that appears as a ToolTip for a control. (Inherited from ToolStripItem.)
Public property | Visible | Gets or sets a value indicating whether the item is displayed. (Inherited from ToolStripItem.)
Public property | Width | Gets or sets the width in pixels of a ToolStripItem. (Inherited from ToolStripItem.)
Top
See Also

Reference

DebugMenu Class
Alternet.Scripter.Debugger.UI Namespace


DebugMenu.CommandsListener Property

DebugMenuCommandsListener Property
Gets or sets list of the Debugger commands for the Debugger UI.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDebuggerUICommands CommandsListener { get; set; }
Public Property CommandsListener As IDebuggerUICommands
    Get
    Set
public:
property IDebuggerUICommands^ CommandsListener {
    IDebuggerUICommands^ get ();
    void set (IDebuggerUICommands^ value);
}
member CommandsListener : IDebuggerUICommands with get, set

Property Value

Type: IDebuggerUICommands
See Also

Reference

DebugMenu Class
Alternet.Scripter.Debugger.UI Namespace


DebugMenu.Debugger Property

DebugMenuDebugger Property
Gets or sets IScriptDebuggerBase which errors will be displayed by this user control.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

DebugMenu Class
Alternet.Scripter.Debugger.UI Namespace


DebugMenu Events

DebugMenu Events

The DebugMenu type exposes the following members.

Events
 | Name | Description
Public event | AvailableChanged | Occurs when the value of the Available property changes. (Inherited from ToolStripItem.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from ToolStripItem.)
Public event | CheckedChanged | Occurs when the value of the Checked property changes. (Inherited from ToolStripMenuItem.)
Public event | CheckStateChanged | Occurs when the value of the CheckState property changes. (Inherited from ToolStripMenuItem.)
Public event | Click | Occurs when the ToolStripItem is clicked. (Inherited from ToolStripItem.)
Public event | DebuggerPreStartup |
Public event | DisplayStyleChanged | Occurs when the DisplayStyle has changed. (Inherited from ToolStripItem.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DoubleClick | Occurs when the item is double-clicked with the mouse. (Inherited from ToolStripItem.)
Public event | DragDrop | Occurs when the user drags an item and the user releases the mouse button, indicating that the item should be dropped into this item. (Inherited from ToolStripItem.)
Public event | DragEnter | Occurs when the user drags an item into the client area of this item. (Inherited from ToolStripItem.)
Public event | DragLeave | Occurs when the user drags an item and the mouse pointer is no longer over the client area of this item. (Inherited from ToolStripItem.)
Public event | DragOver | Occurs when the user drags an item over the client area of this item. (Inherited from ToolStripItem.)
Public event | DropDownClosed | Occurs when the ToolStripDropDown closes. (Inherited from ToolStripDropDownItem.)
Public event | DropDownItemClicked | Occurs when the ToolStripDropDown is clicked. (Inherited from ToolStripDropDownItem.)
Public event | DropDownOpened | Occurs when the ToolStripDropDown has opened. (Inherited from ToolStripDropDownItem.)
Public event | DropDownOpening | Occurs as the ToolStripDropDown is opening. (Inherited from ToolStripDropDownItem.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from ToolStripItem.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from ToolStripItem.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from ToolStripItem.)
Public event | LocationChanged | Occurs when the location of a ToolStripItem is updated. (Inherited from ToolStripItem.)
Public event | MouseDown | Occurs when the mouse pointer is over the item and a mouse button is pressed. (Inherited from ToolStripItem.)
Public event | MouseEnter | Occurs when the mouse pointer enters the item. (Inherited from ToolStripItem.)
Public event | MouseHover | Occurs when the mouse pointer hovers over the item. (Inherited from ToolStripItem.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the item. (Inherited from ToolStripItem.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the item. (Inherited from ToolStripItem.)
Public event | MouseUp | Occurs when the mouse pointer is over the item and a mouse button is released. (Inherited from ToolStripItem.)
Public event | OwnerChanged | Occurs when the Owner property changes. (Inherited from ToolStripItem.)
Public event | Paint | Occurs when the item is redrawn. (Inherited from ToolStripItem.)
Public event | QueryAccessibilityHelp | Occurs when an accessibility client application invokes help for the ToolStripItem. (Inherited from ToolStripItem.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from ToolStripItem.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from ToolStripItem.)
Public event | TextChanged | Occurs when the value of the Text property changes. (Inherited from ToolStripItem.)
Public event | VisibleChanged | Occurs when the value of the Visible property changes. (Inherited from ToolStripItem.)
Top
See Also

Reference

DebugMenu Class
Alternet.Scripter.Debugger.UI Namespace


DebugMenu.DebuggerPreStartup Event

DebugMenuDebuggerPreStartup Event

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DebuggerPreStartup
Public Event DebuggerPreStartup As EventHandler
public:
 event EventHandler^ DebuggerPreStartup {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DebuggerPreStartup : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

DebugMenu Class
Alternet.Scripter.Debugger.UI Namespace


DefaultDebuggerUICommands Class

DefaultDebuggerUICommands Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.DebuggerBaseDefaultDebuggerUICommands
Alternet.Scripter.Debugger.UIDefaultDebuggerUICommands

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefaultDebuggerUICommands : BaseDefaultDebuggerUICommands
Public Class DefaultDebuggerUICommands
    Inherits BaseDefaultDebuggerUICommands
public ref class DefaultDebuggerUICommands : public BaseDefaultDebuggerUICommands
type DefaultDebuggerUICommands =
    class
        inherit BaseDefaultDebuggerUICommands
    end

The DefaultDebuggerUICommands type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultDebuggerUICommands | Initializes a new instance of the DefaultDebuggerUICommands class
Top
Methods
 | Name | Description
Public method | Break | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Compile | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Continue | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentException | (Overrides BaseDefaultDebuggerUICommandsEvaluateCurrentException.)
Public method | EvaluateExpression | (Overrides BaseDefaultDebuggerUICommandsEvaluateExpression.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PreStartup | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Start | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | StepInto | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | StepOver | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Stop | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


DefaultDebuggerUICommands Constructor

DefaultDebuggerUICommands Constructor
Initializes a new instance of the DefaultDebuggerUICommands class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefaultDebuggerUICommands(
    IScriptDebuggerBase debugger
)
Public Sub New (
    debugger As IScriptDebuggerBase
)
public:
DefaultDebuggerUICommands(
    IScriptDebuggerBase^ debugger
)
new :
        debugger : IScriptDebuggerBase -> DefaultDebuggerUICommands

Parameters

debugger
Type: Alternet.Scripter.DebuggerIScriptDebuggerBase
See Also

Reference

DefaultDebuggerUICommands Class
Alternet.Scripter.Debugger.UI Namespace


DefaultDebuggerUICommands Methods

DefaultDebuggerUICommands Methods

The DefaultDebuggerUICommands type exposes the following members.

Methods
 | Name | Description
Public method | Break | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Compile | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Continue | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentException | (Overrides BaseDefaultDebuggerUICommandsEvaluateCurrentException.)
Public method | EvaluateExpression | (Overrides BaseDefaultDebuggerUICommandsEvaluateExpression.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PreStartup | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Start | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | StepInto | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | StepOver | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | Stop | (Inherited from BaseDefaultDebuggerUICommands.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DefaultDebuggerUICommands Class
Alternet.Scripter.Debugger.UI Namespace


DefaultDebuggerUICommands.EvaluateCurrentException Method

DefaultDebuggerUICommandsEvaluateCurrentException Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool EvaluateCurrentException()
Public Overrides Function EvaluateCurrentException As Boolean
public:
virtual bool EvaluateCurrentException() override
abstract EvaluateCurrentException : unit -> bool
override EvaluateCurrentException : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsEvaluateCurrentException
See Also

Reference

DefaultDebuggerUICommands Class
Alternet.Scripter.Debugger.UI Namespace


DefaultDebuggerUICommands.EvaluateExpression Method

DefaultDebuggerUICommandsEvaluateExpression Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool EvaluateExpression()
Public Overrides Function EvaluateExpression As Boolean
public:
virtual bool EvaluateExpression() override
abstract EvaluateExpression : unit -> bool
override EvaluateExpression : unit -> bool

Return Value

Type: Boolean

Implements

IDebuggerUICommandsEvaluateExpression
See Also

Reference

DefaultDebuggerUICommands Class
Alternet.Scripter.Debugger.UI Namespace


ErrorClickEventArgs Class

ErrorClickEventArgs Class
Provides data for the Errors.ErrorClick event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.Debugger.UIErrorClickEventArgs

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ErrorClickEventArgs : EventArgs
Public Class ErrorClickEventArgs
    Inherits EventArgs
public ref class ErrorClickEventArgs : public EventArgs
type ErrorClickEventArgs =
    class
        inherit EventArgs
    end

The ErrorClickEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorClickEventArgs | Initializes a new instance of the ErrorClickEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Error | Gets or sets a ScriptCompilationDiagnostic currently selected in the list of Compiler Errors.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


ErrorClickEventArgs Constructor

ErrorClickEventArgs Constructor
Initializes a new instance of the ErrorClickEventArgs class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ErrorClickEventArgs()
Public Sub New
public:
ErrorClickEventArgs()
new : unit -> ErrorClickEventArgs
See Also

Reference

ErrorClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


ErrorClickEventArgs Methods

ErrorClickEventArgs Methods

The ErrorClickEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


ErrorClickEventArgs Properties

ErrorClickEventArgs Properties

The ErrorClickEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Error | Gets or sets a ScriptCompilationDiagnostic currently selected in the list of Compiler Errors.
Top
See Also

Reference

ErrorClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


ErrorClickEventArgs.Error Property

ErrorClickEventArgsError Property
Gets or sets a ScriptCompilationDiagnostic currently selected in the list of Compiler Errors.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCompilationDiagnostic Error { get; set; }
Public Property Error As ScriptCompilationDiagnostic
    Get
    Set
public:
property ScriptCompilationDiagnostic Error {
    ScriptCompilationDiagnostic get ();
    void set (ScriptCompilationDiagnostic value);
}
member Error : ScriptCompilationDiagnostic with get, set

Property Value

Type: ScriptCompilationDiagnostic
See Also

Reference

ErrorClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


Errors Class

Errors Class
Displays list of compiler errors and warnings.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Scripter.Debugger.UIErrors

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Errors : UserControl
Public Class Errors
    Inherits UserControl
public ref class Errors : public UserControl
type Errors =
    class
        inherit UserControl
    end

The Errors type exposes the following members.

Constructors
 | Name | Description
Public method | Errors | Initializes a new instance of the Errors class with default settings.
Top
Methods
 | Name | Description
Public method | AddCompilerError | Adds specified error to the error's collection.
Public method | AddCompilerErrors | Adds specified errors to the error's collection.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears error list.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | Reset | Resets user control to it's default state.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Fields
 | Name | Description
Public field | lvErrorList |
Public field | sslErrors |
Public field | sslWarning |
Public field | statusStrip1 |
Public field | toolStripStatusLabel1 |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which errors will be displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedError | Gets currently selected error.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | ErrorClick | When implemented by a class, occurs when user clicks on the compiler error or warning.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


Errors Constructor

Errors Constructor
Initializes a new instance of the Errors class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Errors()
Public Sub New
public:
Errors()
new : unit -> Errors
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors Fields

Errors Fields

The Errors type exposes the following members.

Fields
 | Name | Description
Public field | lvErrorList |
Public field | sslErrors |
Public field | sslWarning |
Public field | statusStrip1 |
Public field | toolStripStatusLabel1 |
Top
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.lvErrorList Field

ErrorslvErrorList Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListView lvErrorList
Public lvErrorList As ListView
public:
ListView^ lvErrorList
val mutable lvErrorList: ListView

Field Value

Type: ListView
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.sslErrors Field

ErrorssslErrors Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripStatusLabel sslErrors
Public sslErrors As ToolStripStatusLabel
public:
ToolStripStatusLabel^ sslErrors
val mutable sslErrors: ToolStripStatusLabel

Field Value

Type: ToolStripStatusLabel
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.sslWarning Field

ErrorssslWarning Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripStatusLabel sslWarning
Public sslWarning As ToolStripStatusLabel
public:
ToolStripStatusLabel^ sslWarning
val mutable sslWarning: ToolStripStatusLabel

Field Value

Type: ToolStripStatusLabel
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.statusStrip1 Field

ErrorsstatusStrip1 Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StatusStrip statusStrip1
Public statusStrip1 As StatusStrip
public:
StatusStrip^ statusStrip1
val mutable statusStrip1: StatusStrip

Field Value

Type: StatusStrip
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.toolStripStatusLabel1 Field

ErrorstoolStripStatusLabel1 Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripStatusLabel toolStripStatusLabel1
Public toolStripStatusLabel1 As ToolStripStatusLabel
public:
ToolStripStatusLabel^ toolStripStatusLabel1
val mutable toolStripStatusLabel1: ToolStripStatusLabel

Field Value

Type: ToolStripStatusLabel
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors Methods

Errors Methods

The Errors type exposes the following members.

Methods
 | Name | Description
Public method | AddCompilerError | Adds specified error to the error's collection.
Public method | AddCompilerErrors | Adds specified errors to the error's collection.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears error list.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | Reset | Resets user control to it's default state.
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.AddCompilerError Method

ErrorsAddCompilerError Method
Adds specified error to the error's collection.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCompilerError(
    ScriptCompilationDiagnostic error
)
Public Sub AddCompilerError (
    error As ScriptCompilationDiagnostic
)
public:
void AddCompilerError(
    ScriptCompilationDiagnostic error
)
member AddCompilerError :
        error : ScriptCompilationDiagnostic -> unit

Parameters

error
Type: Alternet.ScripterScriptCompilationDiagnostic
Error to add.
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.AddCompilerErrors Method

ErrorsAddCompilerErrors Method
Adds specified errors to the error's collection.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCompilerErrors(
    ScriptCompilationDiagnostic[] errors
)
Public Sub AddCompilerErrors (
    errors As ScriptCompilationDiagnostic()
)
public:
void AddCompilerErrors(
    array<ScriptCompilationDiagnostic>^ errors
)
member AddCompilerErrors :
        errors : ScriptCompilationDiagnostic[] -> unit

Parameters

errors
Type: Alternet.ScripterScriptCompilationDiagnostic
List of errors to add.
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.Clear Method

ErrorsClear Method
Clears error list.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.Localize Method

ErrorsLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.Reset Method

ErrorsReset Method
Resets user control to it's default state.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors Properties

Errors Properties

The Errors type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which errors will be displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedError | Gets currently selected error.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.Debugger Property

ErrorsDebugger Property
Gets or sets IScriptDebuggerBase which errors will be displayed by this user control.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.SelectedError Property

ErrorsSelectedError Property
Gets currently selected error.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCompilationDiagnostic SelectedError { get; }
Public ReadOnly Property SelectedError As ScriptCompilationDiagnostic
    Get
public:
property ScriptCompilationDiagnostic SelectedError {
    ScriptCompilationDiagnostic get ();
}
member SelectedError : ScriptCompilationDiagnostic with get

Property Value

Type: ScriptCompilationDiagnostic
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors Events

Errors Events

The Errors type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | ErrorClick | When implemented by a class, occurs when user clicks on the compiler error or warning.
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


Errors.ErrorClick Event

ErrorsErrorClick Event
When implemented by a class, occurs when user clicks on the compiler error or warning.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ErrorClickEventArgs> ErrorClick
Public Event ErrorClick As EventHandler(Of ErrorClickEventArgs)
public:
 event EventHandler<ErrorClickEventArgs^>^ ErrorClick {
    void add (EventHandler<ErrorClickEventArgs^>^ value);
    void remove (EventHandler<ErrorClickEventArgs^>^ value);
}
member ErrorClick : IEvent<EventHandler<ErrorClickEventArgs>,
    ErrorClickEventArgs>

Value

Type: SystemEventHandlerErrorClickEventArgs
See Also

Reference

Errors Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog Class

EvaluateDialog Class
Represents a dialog box to evaluate a particular variable or expression.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Scripter.Debugger.UIEvaluateDialog

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EvaluateDialog : Form,
    EvaluationCodeCompletionControllerBaseISite
Public Class EvaluateDialog
    Inherits Form
    Implements EvaluationCodeCompletionControllerBaseISite
public ref class EvaluateDialog : public Form,
    EvaluationCodeCompletionControllerBaseISite
type EvaluateDialog =
    class
        inherit Form
        interface EvaluationCodeCompletionControllerBaseISite
    end

The EvaluateDialog type exposes the following members.

Constructors
 | Name | Description
Public method | EvaluateDialog | Initializes a new instance of the EvaluateDialog class with specified options.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentExpressionAsync | Evaluates current expression asynchronously.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInitialExpression | Gets initial expression displayed when the evaluate dialog is displayed.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase used to evaluate expressions.
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EvaluateCurrentException | Gets or sets a value indicating whether current exception should be evaluated when dialog is displayed.
Public property | Expression | Gets or sets an expression to be evaluated.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | WatchAdded | Occurs when current expression is added to the list of Watches.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog Constructor

EvaluateDialog Constructor
Initializes a new instance of the EvaluateDialog class with specified options.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluateDialog(
    EvaluateDialogCodeCompletionOptions codeCompletionOptions = null
)
Public Sub New (
    Optional codeCompletionOptions As EvaluateDialogCodeCompletionOptions = Nothing
)
public:
EvaluateDialog(
    EvaluateDialogCodeCompletionOptions^ codeCompletionOptions = nullptr
)
new :
        ?codeCompletionOptions : EvaluateDialogCodeCompletionOptions
(* Defaults:
        let _codeCompletionOptions = defaultArg codeCompletionOptions null
*)
-> EvaluateDialog

Parameters

codeCompletionOptions (Optional)
Type: Alternet.Scripter.Debugger.UIEvaluateDialogCodeCompletionOptions
Defines code completion behavior for the expression textbox.
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog Methods

EvaluateDialog Methods

The EvaluateDialog type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCurrentExpressionAsync | Evaluates current expression asynchronously.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInitialExpression | Gets initial expression displayed when the evaluate dialog is displayed.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.EvaluateCurrentExpressionAsync Method

EvaluateDialogEvaluateCurrentExpressionAsync Method
Evaluates current expression asynchronously.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task EvaluateCurrentExpressionAsync()
Public Function EvaluateCurrentExpressionAsync As Task
public:
virtual Task^ EvaluateCurrentExpressionAsync() sealed
abstract EvaluateCurrentExpressionAsync : unit -> Task
override EvaluateCurrentExpressionAsync : unit -> Task

Return Value

Type: Task

Implements

EvaluationCodeCompletionControllerBaseISiteEvaluateCurrentExpressionAsync
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.GetInitialExpression Method

EvaluateDialogGetInitialExpression Method
Gets initial expression displayed when the evaluate dialog is displayed.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetInitialExpression(
    string key
)
Public Function GetInitialExpression (
    key As String
) As String
public:
String^ GetInitialExpression(
    String^ key
)
member GetInitialExpression :
        key : string -> string

Parameters

key
Type: SystemString

Return Value

Type: String
Default expression to evaluate.
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.Localize Method

EvaluateDialogLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog Properties

EvaluateDialog Properties

The EvaluateDialog type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase used to evaluate expressions.
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EvaluateCurrentException | Gets or sets a value indicating whether current exception should be evaluated when dialog is displayed.
Public property | Expression | Gets or sets an expression to be evaluated.
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.Debugger Property

EvaluateDialogDebugger Property
Gets or sets IScriptDebuggerBase used to evaluate expressions.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.EvaluateCurrentException Property

EvaluateDialogEvaluateCurrentException Property
Gets or sets a value indicating whether current exception should be evaluated when dialog is displayed.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EvaluateCurrentException { get; set; }
Public Property EvaluateCurrentException As Boolean
    Get
    Set
public:
property bool EvaluateCurrentException {
    bool get ();
    void set (bool value);
}
member EvaluateCurrentException : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.Expression Property

EvaluateDialogExpression Property
Gets or sets an expression to be evaluated.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; set; }
Public Property Expression As String
    Get
    Set
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}
member Expression : string with get, set

Property Value

Type: String
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog Events

EvaluateDialog Events

The EvaluateDialog type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | WatchAdded | Occurs when current expression is added to the list of Watches.
Top
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.WatchAdded Event

EvaluateDialogWatchAdded Event
Occurs when current expression is added to the list of Watches.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<WatchAddedEventArgs> WatchAdded
Public Event WatchAdded As EventHandler(Of WatchAddedEventArgs)
public:
 event EventHandler<WatchAddedEventArgs^>^ WatchAdded {
    void add (EventHandler<WatchAddedEventArgs^>^ value);
    void remove (EventHandler<WatchAddedEventArgs^>^ value);
}
member WatchAdded : IEvent<EventHandler<WatchAddedEventArgs>,
    WatchAddedEventArgs>

Value

Type: SystemEventHandlerWatchAddedEventArgs
See Also

Reference

EvaluateDialog Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.CodeCompletionOptions Class

EvaluateDialogCodeCompletionOptions Class
Represents options that affect code completion in the evaluation dialog.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UIEvaluateDialogCodeCompletionOptions

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionOptions
Public Class CodeCompletionOptions
public ref class CodeCompletionOptions
type CodeCompletionOptions =  class end

The EvaluateDialogCodeCompletionOptions type exposes the following members.

Methods
 | Name | Description
 | Custom | Gets a custom options for the code completion in the evaluation dialog.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Disabled | Disabled code completion in the evaluation dialog.
Enabled | Enabled code completion in the evaluation dialog.
Top
Properties
 | Name | Description
Public property | CodeCompletionEnabled | Gets a value indicating whether code completion is enabled.
Public property | CreateCustomControllerFunc | Gets a method handles creation of codecompletion controller object.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


CodeCompletionOptions Fields

CodeCompletionOptions Fields

The EvaluateDialogCodeCompletionOptions type exposes the following members.

Fields
Name | Description
Disabled | Disabled code completion in the evaluation dialog.
Enabled | Enabled code completion in the evaluation dialog.
Top
See Also

Reference

EvaluateDialogCodeCompletionOptions Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.CodeCompletionOptions.Disabled Field

EvaluateDialogCodeCompletionOptionsDisabled Field
Disabled code completion in the evaluation dialog.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly EvaluateDialogCodeCompletionOptions Disabled
Public Shared ReadOnly Disabled As EvaluateDialogCodeCompletionOptions
public:
static initonly EvaluateDialogCodeCompletionOptions^ Disabled
static val Disabled: EvaluateDialogCodeCompletionOptions

Field Value

Type: EvaluateDialogCodeCompletionOptions
See Also

Reference

EvaluateDialogCodeCompletionOptions Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.CodeCompletionOptions.Enabled Field

EvaluateDialogCodeCompletionOptionsEnabled Field
Enabled code completion in the evaluation dialog.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly EvaluateDialogCodeCompletionOptions Enabled
Public Shared ReadOnly Enabled As EvaluateDialogCodeCompletionOptions
public:
static initonly EvaluateDialogCodeCompletionOptions^ Enabled
static val Enabled: EvaluateDialogCodeCompletionOptions

Field Value

Type: EvaluateDialogCodeCompletionOptions
See Also

Reference

EvaluateDialogCodeCompletionOptions Class
Alternet.Scripter.Debugger.UI Namespace


CodeCompletionOptions Methods

CodeCompletionOptions Methods

The EvaluateDialogCodeCompletionOptions type exposes the following members.

Methods
 | Name | Description
 | Custom | Gets a custom options for the code completion in the evaluation dialog.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EvaluateDialogCodeCompletionOptions Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.CodeCompletionOptions.Custom Method

EvaluateDialogCodeCompletionOptionsCustom Method
Gets a custom options for the code completion in the evaluation dialog.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static EvaluateDialogCodeCompletionOptions Custom(
    EvaluateDialogCreateCodeCompletionControllerDelegate createCustomControllerFunc
)
Public Shared Function Custom (
    createCustomControllerFunc As EvaluateDialogCreateCodeCompletionControllerDelegate
) As EvaluateDialogCodeCompletionOptions
public:
static EvaluateDialogCodeCompletionOptions^ Custom(
    EvaluateDialogCreateCodeCompletionControllerDelegate^ createCustomControllerFunc
)
static member Custom :
        createCustomControllerFunc : EvaluateDialogCreateCodeCompletionControllerDelegate -> EvaluateDialogCodeCompletionOptions

Parameters

createCustomControllerFunc
Type: Alternet.Scripter.Debugger.UIEvaluateDialogCreateCodeCompletionControllerDelegate
This method handles creation of codecompletion controller object.

Return Value

Type: EvaluateDialogCodeCompletionOptions
See Also

Reference

EvaluateDialogCodeCompletionOptions Class
Alternet.Scripter.Debugger.UI Namespace


CodeCompletionOptions Properties

CodeCompletionOptions Properties

The EvaluateDialogCodeCompletionOptions type exposes the following members.

Properties
 | Name | Description
Public property | CodeCompletionEnabled | Gets a value indicating whether code completion is enabled.
Public property | CreateCustomControllerFunc | Gets a method handles creation of codecompletion controller object.
Top
See Also

Reference

EvaluateDialogCodeCompletionOptions Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.CodeCompletionOptions.CodeCompletionEnabled Property

EvaluateDialogCodeCompletionOptionsCodeCompletionEnabled Property
Gets a value indicating whether code completion is enabled.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CodeCompletionEnabled { get; }
Public ReadOnly Property CodeCompletionEnabled As Boolean
    Get
public:
property bool CodeCompletionEnabled {
    bool get ();
}
member CodeCompletionEnabled : bool with get

Property Value

Type: Boolean
See Also

Reference

EvaluateDialogCodeCompletionOptions Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.CodeCompletionOptions.CreateCustomControllerFunc Property

EvaluateDialogCodeCompletionOptionsCreateCustomControllerFunc Property
Gets a method handles creation of codecompletion controller object.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluateDialogCreateCodeCompletionControllerDelegate CreateCustomControllerFunc { get; }
Public ReadOnly Property CreateCustomControllerFunc As EvaluateDialogCreateCodeCompletionControllerDelegate
    Get
public:
property EvaluateDialogCreateCodeCompletionControllerDelegate^ CreateCustomControllerFunc {
    EvaluateDialogCreateCodeCompletionControllerDelegate^ get ();
}
member CreateCustomControllerFunc : EvaluateDialogCreateCodeCompletionControllerDelegate with get

Property Value

Type: EvaluateDialogCreateCodeCompletionControllerDelegate
See Also

Reference

EvaluateDialogCodeCompletionOptions Class
Alternet.Scripter.Debugger.UI Namespace


EvaluateDialog.CreateCodeCompletionControllerDelegate Delegate

EvaluateDialogCreateCodeCompletionControllerDelegate Delegate
Represents a method that will handle creation of codecompletion controller object.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate EvaluationCodeCompletionController CreateCodeCompletionControllerDelegate(
    EvaluationCodeCompletionControllerBaseISite site,
    IScriptDebuggerBase debugger,
    TextBox expressionTextBox
)
Public Delegate Function CreateCodeCompletionControllerDelegate (
    site As EvaluationCodeCompletionControllerBaseISite,
    debugger As IScriptDebuggerBase,
    expressionTextBox As TextBox
) As EvaluationCodeCompletionController
public delegate EvaluationCodeCompletionController^ CreateCodeCompletionControllerDelegate(
    EvaluationCodeCompletionControllerBaseISite^ site,
    IScriptDebuggerBase^ debugger,
    TextBox^ expressionTextBox
)
type CreateCodeCompletionControllerDelegate =
    delegate of
        site : EvaluationCodeCompletionControllerBaseISite *
        debugger : IScriptDebuggerBase *
        expressionTextBox : TextBox -> EvaluationCodeCompletionController

Parameters

site
Type: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionEvaluationCodeCompletionControllerBaseISite
Site corresponding to the controller.
debugger
Type: Alternet.Scripter.DebuggerIScriptDebuggerBase
IScriptDebuggerBase which evaluates the expressions.
expressionTextBox
Type: System.Windows.FormsTextBox
TextBox that receives user input.

Return Value

Type: EvaluationCodeCompletionController
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


Locals Class

Locals Class
Displays and evaluates local variables during script debugging.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Scripter.Debugger.UIVariablesEvaluationControlBase
Alternet.Scripter.Debugger.UILocals

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Locals : VariablesEvaluationControlBase
Public Class Locals
    Inherits VariablesEvaluationControlBase
public ref class Locals : public VariablesEvaluationControlBase
type Locals =
    class
        inherit VariablesEvaluationControlBase
    end

The Locals type exposes the following members.

Constructors
 | Name | Description
Public method | Locals | Initializes a new instance of the Locals class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CancelEvaluationAsync | Cancels an evaluation task which is currently running. (Inherited from VariablesEvaluationControlBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateVariables | Evaluates values of given variables asynchronously.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Fields
 | Name | Description
Public field | localsTreeView |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | (Inherited from VariablesEvaluationControlBase.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedText | Gets a currently selected text.
Public property | SelectedWatch | Gets a currently selected watch expression.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AddToWatchClick | Occurs when user clicks on the local to add it to the watch window.
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


Locals Constructor

Locals Constructor
Initializes a new instance of the Locals class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Locals()
Public Sub New
public:
Locals()
new : unit -> Locals
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals Fields

Locals Fields

The Locals type exposes the following members.

Fields
 | Name | Description
Public field | localsTreeView |
Top
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals.localsTreeView Field

LocalslocalsTreeView Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeView localsTreeView
Public localsTreeView As TreeView
public:
TreeView^ localsTreeView
val mutable localsTreeView: TreeView

Field Value

Type: TreeView
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals Methods

Locals Methods

The Locals type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CancelEvaluationAsync | Cancels an evaluation task which is currently running. (Inherited from VariablesEvaluationControlBase.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateVariables | Evaluates values of given variables asynchronously.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals.EvaluateVariables Method

LocalsEvaluateVariables Method
Evaluates values of given variables asynchronously.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EvaluateVariables(
    IEnumerable<string> variableNames
)
Public Sub EvaluateVariables (
    variableNames As IEnumerable(Of String)
)
public:
void EvaluateVariables(
    IEnumerable<String^>^ variableNames
)
member EvaluateVariables :
        variableNames : IEnumerable<string> -> unit

Parameters

variableNames
Type: System.Collections.GenericIEnumerableString
List of variables to evaluate.
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals.Localize Method

LocalsLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals Properties

Locals Properties

The Locals type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | (Inherited from VariablesEvaluationControlBase.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedText | Gets a currently selected text.
Public property | SelectedWatch | Gets a currently selected watch expression.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals.SelectedText Property

LocalsSelectedText Property
Gets a currently selected text.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SelectedText { get; }
Public ReadOnly Property SelectedText As String
    Get
public:
property String^ SelectedText {
    String^ get ();
}
member SelectedText : string with get

Property Value

Type: String
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals.SelectedWatch Property

LocalsSelectedWatch Property
Gets a currently selected watch expression.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SelectedWatch { get; }
Public ReadOnly Property SelectedWatch As String
    Get
public:
property String^ SelectedWatch {
    String^ get ();
}
member SelectedWatch : string with get

Property Value

Type: String
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals Events

Locals Events

The Locals type exposes the following members.

Events
 | Name | Description
Public event | AddToWatchClick | Occurs when user clicks on the local to add it to the watch window.
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Locals.AddToWatchClick Event

LocalsAddToWatchClick Event
Occurs when user clicks on the local to add it to the watch window.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<AddToWatchClickEventArgs> AddToWatchClick
Public Event AddToWatchClick As EventHandler(Of AddToWatchClickEventArgs)
public:
 event EventHandler<AddToWatchClickEventArgs^>^ AddToWatchClick {
    void add (EventHandler<AddToWatchClickEventArgs^>^ value);
    void remove (EventHandler<AddToWatchClickEventArgs^>^ value);
}
member AddToWatchClick : IEvent<EventHandler<AddToWatchClickEventArgs>,
    AddToWatchClickEventArgs>

Value

Type: SystemEventHandlerAddToWatchClickEventArgs
See Also

Reference

Locals Class
Alternet.Scripter.Debugger.UI Namespace


Output Class

Output Class
Displays list of output messages during script debugging.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Scripter.Debugger.UIOutput

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Output : UserControl
Public Class Output
    Inherits UserControl
public ref class Output : public UserControl
type Output =
    class
        inherit UserControl
    end

The Output type exposes the following members.

Constructors
 | Name | Description
Public method | Output | Initializes a new instance of the Output class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears output list.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Fields
 | Name | Description
Public field | lbOutput |
Public field | sslDebug |
Public field | sslGeneral |
Public field | statusStrip1 |
Public field | toolStripStatusLabel1 |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which output messages will be displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedMessage | Gets currently selected message.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


Output Constructor

Output Constructor
Initializes a new instance of the Output class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Output()
Public Sub New
public:
Output()
new : unit -> Output
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output Fields

Output Fields

The Output type exposes the following members.

Fields
 | Name | Description
Public field | lbOutput |
Public field | sslDebug |
Public field | sslGeneral |
Public field | statusStrip1 |
Public field | toolStripStatusLabel1 |
Top
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output.lbOutput Field

OutputlbOutput Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextBox lbOutput
Public lbOutput As TextBox
public:
TextBox^ lbOutput
val mutable lbOutput: TextBox

Field Value

Type: TextBox
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output.sslDebug Field

OutputsslDebug Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripStatusLabel sslDebug
Public sslDebug As ToolStripStatusLabel
public:
ToolStripStatusLabel^ sslDebug
val mutable sslDebug: ToolStripStatusLabel

Field Value

Type: ToolStripStatusLabel
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output.sslGeneral Field

OutputsslGeneral Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripStatusLabel sslGeneral
Public sslGeneral As ToolStripStatusLabel
public:
ToolStripStatusLabel^ sslGeneral
val mutable sslGeneral: ToolStripStatusLabel

Field Value

Type: ToolStripStatusLabel
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output.statusStrip1 Field

OutputstatusStrip1 Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StatusStrip statusStrip1
Public statusStrip1 As StatusStrip
public:
StatusStrip^ statusStrip1
val mutable statusStrip1: StatusStrip

Field Value

Type: StatusStrip
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output.toolStripStatusLabel1 Field

OutputtoolStripStatusLabel1 Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ToolStripStatusLabel toolStripStatusLabel1
Public toolStripStatusLabel1 As ToolStripStatusLabel
public:
ToolStripStatusLabel^ toolStripStatusLabel1
val mutable toolStripStatusLabel1: ToolStripStatusLabel

Field Value

Type: ToolStripStatusLabel
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output Methods

Output Methods

The Output type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Clear | Clears output list.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output.Clear Method

OutputClear Method
Clears output list.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output.Localize Method

OutputLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output Properties

Output Properties

The Output type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which output messages will be displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedMessage | Gets currently selected message.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output.Debugger Property

OutputDebugger Property
Gets or sets IScriptDebuggerBase which output messages will be displayed by this user control.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output.SelectedMessage Property

OutputSelectedMessage Property
Gets currently selected message.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SelectedMessage { get; }
Public ReadOnly Property SelectedMessage As String
    Get
public:
property String^ SelectedMessage {
    String^ get ();
}
member SelectedMessage : string with get

Property Value

Type: String
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


Output Events

Output Events

The Output type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Output Class
Alternet.Scripter.Debugger.UI Namespace


RunParameters Class

RunParameters Class
Represents Run Parameters dialog box used to pass parameters to the process being debugged.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Scripter.Debugger.UIRunParameters

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RunParameters : Form
Public Class RunParameters
    Inherits Form
public ref class RunParameters : public Form
type RunParameters =
    class
        inherit Form
    end

The RunParameters type exposes the following members.

Constructors
 | Name | Description
Public method | RunParameters | Initializes a new instance of the RunParameters class with default settings.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CommandLineArgs | Gets or sets command line arguments for the process being debugged.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartExternalProgram | Gets or sets a value indicating that a external program should be started to debug dynamically linked library.
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | StartProgram | Gets or sets the executable which should be started when debugging dynamically linked library.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


RunParameters Constructor

RunParameters Constructor
Initializes a new instance of the RunParameters class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RunParameters()
Public Sub New
public:
RunParameters()
new : unit -> RunParameters
See Also

Reference

RunParameters Class
Alternet.Scripter.Debugger.UI Namespace


RunParameters Methods

RunParameters Methods

The RunParameters type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

RunParameters Class
Alternet.Scripter.Debugger.UI Namespace


RunParameters Properties

RunParameters Properties

The RunParameters type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CommandLineArgs | Gets or sets command line arguments for the process being debugged.
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartExternalProgram | Gets or sets a value indicating that a external program should be started to debug dynamically linked library.
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | StartProgram | Gets or sets the executable which should be started when debugging dynamically linked library.
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

RunParameters Class
Alternet.Scripter.Debugger.UI Namespace


RunParameters.CommandLineArgs Property

RunParametersCommandLineArgs Property
Gets or sets command line arguments for the process being debugged.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] CommandLineArgs { get; set; }
Public Property CommandLineArgs As String()
    Get
    Set
public:
property array<String^>^ CommandLineArgs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member CommandLineArgs : string[] with get, set

Property Value

Type: String
See Also

Reference

RunParameters Class
Alternet.Scripter.Debugger.UI Namespace


RunParameters.StartExternalProgram Property

RunParametersStartExternalProgram Property
Gets or sets a value indicating that a external program should be started to debug dynamically linked library.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StartExternalProgram { get; set; }
Public Property StartExternalProgram As Boolean
    Get
    Set
public:
property bool StartExternalProgram {
    bool get ();
    void set (bool value);
}
member StartExternalProgram : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RunParameters Class
Alternet.Scripter.Debugger.UI Namespace


RunParameters.StartProgram Property

RunParametersStartProgram Property
Gets or sets the executable which should be started when debugging dynamically linked library.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StartProgram { get; set; }
Public Property StartProgram As String
    Get
    Set
public:
property String^ StartProgram {
    String^ get ();
    void set (String^ value);
}
member StartProgram : string with get, set

Property Value

Type: String
See Also

Reference

RunParameters Class
Alternet.Scripter.Debugger.UI Namespace


RunParameters Events

RunParameters Events

The RunParameters type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

RunParameters Class
Alternet.Scripter.Debugger.UI Namespace


ThreadClickEventArgs Class

ThreadClickEventArgs Class
Provides data for the Threads.ThreadClick event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.Debugger.UIThreadClickEventArgs

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ThreadClickEventArgs : EventArgs
Public Class ThreadClickEventArgs
    Inherits EventArgs
public ref class ThreadClickEventArgs : public EventArgs
type ThreadClickEventArgs =
    class
        inherit EventArgs
    end

The ThreadClickEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThreadClickEventArgs | Initializes a new instance of the ThreadClickEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Thread | Gets or sets a ThreadInfo object currently selected in the list of Threads.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


ThreadClickEventArgs Constructor

ThreadClickEventArgs Constructor
Initializes a new instance of the ThreadClickEventArgs class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadClickEventArgs()
Public Sub New
public:
ThreadClickEventArgs()
new : unit -> ThreadClickEventArgs
See Also

Reference

ThreadClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


ThreadClickEventArgs Methods

ThreadClickEventArgs Methods

The ThreadClickEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThreadClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


ThreadClickEventArgs Properties

ThreadClickEventArgs Properties

The ThreadClickEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Thread | Gets or sets a ThreadInfo object currently selected in the list of Threads.
Top
See Also

Reference

ThreadClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


ThreadClickEventArgs.Thread Property

ThreadClickEventArgsThread Property
Gets or sets a ThreadInfo object currently selected in the list of Threads.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadInfo Thread { get; set; }
Public Property Thread As ThreadInfo
    Get
    Set
public:
property ThreadInfo^ Thread {
    ThreadInfo^ get ();
    void set (ThreadInfo^ value);
}
member Thread : ThreadInfo with get, set

Property Value

Type: ThreadInfo
See Also

Reference

ThreadClickEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


Threads Class

Threads Class
Displays list of active threads during script debugging.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Scripter.Debugger.UIThreads

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Threads : UserControl
Public Class Threads
    Inherits UserControl
public ref class Threads : public UserControl
type Threads =
    class
        inherit UserControl
    end

The Threads type exposes the following members.

Constructors
 | Name | Description
Public method | Threads | Initializes a new instance of the Threads class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetThreads | Sets threads to be displayed.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Fields
 | Name | Description
Public field | lvThreads |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which threads will be displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedThread | Gets a currently selected thread.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | ThreadClick | When implemented by a class, occurs when user clicks on the thread in the list.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


Threads Constructor

Threads Constructor
Initializes a new instance of the Threads class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Threads()
Public Sub New
public:
Threads()
new : unit -> Threads
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads Fields

Threads Fields

The Threads type exposes the following members.

Fields
 | Name | Description
Public field | lvThreads |
Top
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads.lvThreads Field

ThreadslvThreads Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListView lvThreads
Public lvThreads As ListView
public:
ListView^ lvThreads
val mutable lvThreads: ListView

Field Value

Type: ListView
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads Methods

Threads Methods

The Threads type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetThreads | Sets threads to be displayed.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads.Localize Method

ThreadsLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads.SetThreads Method

ThreadsSetThreads Method
Sets threads to be displayed.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetThreads(
    ThreadInfo[] threads
)
Public Sub SetThreads (
    threads As ThreadInfo()
)
public:
void SetThreads(
    array<ThreadInfo^>^ threads
)
member SetThreads :
        threads : ThreadInfo[] -> unit

Parameters

threads
Type: Alternet.Scripter.DebuggerThreadInfo
List of threads to be displayed.
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads Properties

Threads Properties

The Threads type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | Gets or sets IScriptDebuggerBase which threads will be displayed by this user control.
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedThread | Gets a currently selected thread.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads.Debugger Property

ThreadsDebugger Property
Gets or sets IScriptDebuggerBase which threads will be displayed by this user control.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads.SelectedThread Property

ThreadsSelectedThread Property
Gets a currently selected thread.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThreadInfo SelectedThread { get; }
Public ReadOnly Property SelectedThread As ThreadInfo
    Get
public:
property ThreadInfo^ SelectedThread {
    ThreadInfo^ get ();
}
member SelectedThread : ThreadInfo with get

Property Value

Type: ThreadInfo
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads Events

Threads Events

The Threads type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | ThreadClick | When implemented by a class, occurs when user clicks on the thread in the list.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


Threads.ThreadClick Event

ThreadsThreadClick Event
When implemented by a class, occurs when user clicks on the thread in the list.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ThreadClickEventArgs> ThreadClick
Public Event ThreadClick As EventHandler(Of ThreadClickEventArgs)
public:
 event EventHandler<ThreadClickEventArgs^>^ ThreadClick {
    void add (EventHandler<ThreadClickEventArgs^>^ value);
    void remove (EventHandler<ThreadClickEventArgs^>^ value);
}
member ThreadClick : IEvent<EventHandler<ThreadClickEventArgs>,
    ThreadClickEventArgs>

Value

Type: SystemEventHandlerThreadClickEventArgs
See Also

Reference

Threads Class
Alternet.Scripter.Debugger.UI Namespace


VariablesEvaluationControlBase Class

VariablesEvaluationControlBase Class
Provides a base class to evaluate list of expressions during script debugging. This class is abstract.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Scripter.Debugger.UIVariablesEvaluationControlBase
Alternet.Scripter.Debugger.UILocals
Alternet.Scripter.Debugger.UIWatches

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VariablesEvaluationControlBase : UserControl
Public Class VariablesEvaluationControlBase
    Inherits UserControl
public ref class VariablesEvaluationControlBase : public UserControl
type VariablesEvaluationControlBase =
    class
        inherit UserControl
    end

The VariablesEvaluationControlBase type exposes the following members.

Constructors
 | Name | Description
Public method | VariablesEvaluationControlBase | Initializes a new instance of the VariablesEvaluationControlBase class
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CancelEvaluationAsync | Cancels an evaluation task which is currently running.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger |
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


VariablesEvaluationControlBase Constructor

VariablesEvaluationControlBase Constructor
Initializes a new instance of the VariablesEvaluationControlBase class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VariablesEvaluationControlBase()
Public Sub New
public:
VariablesEvaluationControlBase()
new : unit -> VariablesEvaluationControlBase
See Also

Reference

VariablesEvaluationControlBase Class
Alternet.Scripter.Debugger.UI Namespace


VariablesEvaluationControlBase Methods

VariablesEvaluationControlBase Methods

The VariablesEvaluationControlBase type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CancelEvaluationAsync | Cancels an evaluation task which is currently running.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

VariablesEvaluationControlBase Class
Alternet.Scripter.Debugger.UI Namespace


VariablesEvaluationControlBase.CancelEvaluationAsync Method

VariablesEvaluationControlBaseCancelEvaluationAsync Method
Cancels an evaluation task which is currently running.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task CancelEvaluationAsync()
Public Function CancelEvaluationAsync As Task
public:
Task^ CancelEvaluationAsync()
member CancelEvaluationAsync : unit -> Task

Return Value

Type: Task
See Also

Reference

VariablesEvaluationControlBase Class
Alternet.Scripter.Debugger.UI Namespace


VariablesEvaluationControlBase Properties

VariablesEvaluationControlBase Properties

The VariablesEvaluationControlBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger |
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

VariablesEvaluationControlBase Class
Alternet.Scripter.Debugger.UI Namespace


VariablesEvaluationControlBase.Debugger Property

VariablesEvaluationControlBaseDebugger Property

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

VariablesEvaluationControlBase Class
Alternet.Scripter.Debugger.UI Namespace


VariablesEvaluationControlBase Events

VariablesEvaluationControlBase Events

The VariablesEvaluationControlBase type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

VariablesEvaluationControlBase Class
Alternet.Scripter.Debugger.UI Namespace


WatchAddedEventArgs Class

WatchAddedEventArgs Class
Provides data for the EvaluateDialog.WatchAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.Debugger.UIWatchAddedEventArgs

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WatchAddedEventArgs : EventArgs
Public Class WatchAddedEventArgs
    Inherits EventArgs
public ref class WatchAddedEventArgs : public EventArgs
type WatchAddedEventArgs =
    class
        inherit EventArgs
    end

The WatchAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WatchAddedEventArgs | Initializes a new instance of the WatchAddedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Expression | Gets or sets expression to watch.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


WatchAddedEventArgs Constructor

WatchAddedEventArgs Constructor
Initializes a new instance of the WatchAddedEventArgs class

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public WatchAddedEventArgs()
Public Sub New
public:
WatchAddedEventArgs()
new : unit -> WatchAddedEventArgs
See Also

Reference

WatchAddedEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


WatchAddedEventArgs Methods

WatchAddedEventArgs Methods

The WatchAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WatchAddedEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


WatchAddedEventArgs Properties

WatchAddedEventArgs Properties

The WatchAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Expression | Gets or sets expression to watch.
Top
See Also

Reference

WatchAddedEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


WatchAddedEventArgs.Expression Property

WatchAddedEventArgsExpression Property
Gets or sets expression to watch.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; set; }
Public Property Expression As String
    Get
    Set
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}
member Expression : string with get, set

Property Value

Type: String
See Also

Reference

WatchAddedEventArgs Class
Alternet.Scripter.Debugger.UI Namespace


WatchDialog Class

WatchDialog Class
Represents a dialog box to add a new watch expression.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Scripter.Debugger.UIWatchDialog

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WatchDialog : Form
Public Class WatchDialog
    Inherits Form
public ref class WatchDialog : public Form
type WatchDialog =
    class
        inherit Form
    end

The WatchDialog type exposes the following members.

Constructors
 | Name | Description
Public method | WatchDialog | Initializes a new instance of the WatchDialog class with default settings.
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Fields
 | Name | Description
Public field | expressionTextBox |
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


WatchDialog Constructor

WatchDialog Constructor
Initializes a new instance of the WatchDialog class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public WatchDialog()
Public Sub New
public:
WatchDialog()
new : unit -> WatchDialog
See Also

Reference

WatchDialog Class
Alternet.Scripter.Debugger.UI Namespace


WatchDialog Fields

WatchDialog Fields

The WatchDialog type exposes the following members.

Fields
 | Name | Description
Public field | expressionTextBox |
Top
See Also

Reference

WatchDialog Class
Alternet.Scripter.Debugger.UI Namespace


WatchDialog.expressionTextBox Field

WatchDialogexpressionTextBox Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextBox expressionTextBox
Public expressionTextBox As TextBox
public:
TextBox^ expressionTextBox
val mutable expressionTextBox: TextBox

Field Value

Type: TextBox
See Also

Reference

WatchDialog Class
Alternet.Scripter.Debugger.UI Namespace


WatchDialog Methods

WatchDialog Methods

The WatchDialog type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

WatchDialog Class
Alternet.Scripter.Debugger.UI Namespace


WatchDialog.Localize Method

WatchDialogLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

WatchDialog Class
Alternet.Scripter.Debugger.UI Namespace


WatchDialog Properties

WatchDialog Properties

The WatchDialog type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

WatchDialog Class
Alternet.Scripter.Debugger.UI Namespace


WatchDialog Events

WatchDialog Events

The WatchDialog type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

WatchDialog Class
Alternet.Scripter.Debugger.UI Namespace


Watches Class

Watches Class
Displays and evaluates watch expressions during script debugging.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Alternet.Scripter.Debugger.UIVariablesEvaluationControlBase
Alternet.Scripter.Debugger.UIWatches

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Watches : VariablesEvaluationControlBase
Public Class Watches
    Inherits VariablesEvaluationControlBase
public ref class Watches : public VariablesEvaluationControlBase
type Watches =
    class
        inherit VariablesEvaluationControlBase
    end

The Watches type exposes the following members.

Constructors
 | Name | Description
Public method | Watches | Initializes a new instance of the Watches class with default settings.
Top
Methods
 | Name | Description
Public method | AddWatch(String) | Adds specified expression to the list of watches.
Public method | AddWatch(String, Boolean, Boolean) | Adds specified expression to the list of watches.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CancelEvaluationAsync | Cancels an evaluation task which is currently running. (Inherited from VariablesEvaluationControlBase.)
Public method | Clear | Clears watches list.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateWatchExpressions | Evaluates values of all expressions asynchronously.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
Fields
 | Name | Description
Public field | watchesTreeView |
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | (Inherited from VariablesEvaluationControlBase.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedWatch | Gets a currently selected watch expression.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI Namespace


Watches Constructor

Watches Constructor
Initializes a new instance of the Watches class with default settings.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Watches()
Public Sub New
public:
Watches()
new : unit -> Watches
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches Fields

Watches Fields

The Watches type exposes the following members.

Fields
 | Name | Description
Public field | watchesTreeView |
Top
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches.watchesTreeView Field

WatcheswatchesTreeView Field

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TreeView watchesTreeView
Public watchesTreeView As TreeView
public:
TreeView^ watchesTreeView
val mutable watchesTreeView: TreeView

Field Value

Type: TreeView
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches Methods

Watches Methods

The Watches type exposes the following members.

Methods
 | Name | Description
Public method | AddWatch(String) | Adds specified expression to the list of watches.
Public method | AddWatch(String, Boolean, Boolean) | Adds specified expression to the list of watches.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CancelEvaluationAsync | Cancels an evaluation task which is currently running. (Inherited from VariablesEvaluationControlBase.)
Public method | Clear | Clears watches list.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateWatchExpressions | Evaluates values of all expressions asynchronously.
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | Localize |
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
Top
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches.AddWatch Method

WatchesAddWatch Method
Overload List
 | Name | Description
Public method | AddWatch(String) | Adds specified expression to the list of watches.
Public method | AddWatch(String, Boolean, Boolean) | Adds specified expression to the list of watches.
Top
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches.AddWatch Method (String)

WatchesAddWatch Method (String)
Adds specified expression to the list of watches.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddWatch(
    string expression
)
Public Sub AddWatch (
    expression As String
)
public:
void AddWatch(
    String^ expression
)
member AddWatch :
        expression : string -> unit

Parameters

expression
Type: SystemString
Watch expression to evaluate.
See Also

Reference

Watches Class
AddWatch Overload
Alternet.Scripter.Debugger.UI Namespace


Watches.AddWatch Method (String, Boolean, Boolean)

WatchesAddWatch Method (String, Boolean, Boolean)
Adds specified expression to the list of watches.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddWatch(
    string expression,
    bool checkIfExists,
    bool selectAdded
)
Public Sub AddWatch (
    expression As String,
    checkIfExists As Boolean,
    selectAdded As Boolean
)
public:
void AddWatch(
    String^ expression,
    bool checkIfExists,
    bool selectAdded
)
member AddWatch :
        expression : string *
        checkIfExists : bool *
        selectAdded : bool -> unit

Parameters

expression
Type: SystemString
Watch expression to evaluate.
checkIfExists
Type: SystemBoolean
Check whether specified watch expression already exists.
selectAdded
Type: SystemBoolean
Selects specified watch.
See Also

Reference

Watches Class
AddWatch Overload
Alternet.Scripter.Debugger.UI Namespace


Watches.Clear Method

WatchesClear Method
Clears watches list.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches.EvaluateWatchExpressions Method

WatchesEvaluateWatchExpressions Method
Evaluates values of all expressions asynchronously.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EvaluateWatchExpressions()
Public Sub EvaluateWatchExpressions
public:
void EvaluateWatchExpressions()
member EvaluateWatchExpressions : unit -> unit
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches.Localize Method

WatchesLocalize Method

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
void Localize()
member Localize : unit -> unit
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches Properties

Watches Properties

The Watches type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger | (Inherited from VariablesEvaluationControlBase.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedWatch | Gets a currently selected watch expression.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches.SelectedWatch Property

WatchesSelectedWatch Property
Gets a currently selected watch expression.

Namespace: Alternet.Scripter.Debugger.UI
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SelectedWatch { get; }
Public ReadOnly Property SelectedWatch As String
    Get
public:
property String^ SelectedWatch {
    String^ get ();
}
member SelectedWatch : string with get

Property Value

Type: String
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Watches Events

Watches Events

The Watches type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Watches Class
Alternet.Scripter.Debugger.UI Namespace


Alternet.Scripter.Debugger.UI.DataTips Namespace

Alternet.Scripter.Debugger.UI.DataTips Namespace
Classes
 | Class | Description
Public class | DataTip | Represents functionality to popup evaluation result of symbols being debugged.
Public class | DataTipShowParameters | Represents evaluation data.
Interfaces
 | Interface | Description
Public interface | IDataTip | Represents properties and methods used to process evaluation data.
Enumerations
 | Enumeration | Description
Public enumeration | DataTipEvaluationMode | Defines type of DataTip evaluation result.
Public enumeration | DataTipState | Defines DataTip states.


DataTip Class

DataTip Class
Represents functionality to popup evaluation result of symbols being debugged.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UI.DataTipsDataTip

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DataTip
Public Class DataTip
public ref class DataTip
type DataTip =  class end

The DataTip type exposes the following members.

Constructors
 | Name | Description
Public method | DataTip | Initializes a new instance of the DataTip class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Show | Shows the IDataTip pop-up window for specified expression.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name | Description
DefaultPainter | Gets or sets DataTipPainter object used to paint DataTip content.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTip Constructor

DataTip Constructor
Initializes a new instance of the DataTip class

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DataTip()
Public Sub New
public:
DataTip()
new : unit -> DataTip
See Also

Reference

DataTip Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTip Methods

DataTip Methods

The DataTip type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Show | Shows the IDataTip pop-up window for specified expression.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataTip Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTip.Show Method

DataTipShow Method
Shows the IDataTip pop-up window for specified expression.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDataTip Show(
    DataTipShowParameters parameters
)
Public Shared Function Show (
    parameters As DataTipShowParameters
) As IDataTip
public:
static IDataTip^ Show(
    DataTipShowParameters^ parameters
)
static member Show :
        parameters : DataTipShowParameters -> IDataTip

Parameters

parameters
Type: Alternet.Scripter.Debugger.UI.DataTipsDataTipShowParameters
Represents evaluation data to display.

Return Value

Type: IDataTip
See Also

Reference

DataTip Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTip Properties

DataTip Properties

The DataTip type exposes the following members.

Properties
Name | Description
DefaultPainter | Gets or sets DataTipPainter object used to paint DataTip content.
Top
See Also

Reference

DataTip Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTip.DefaultPainter Property

DataTipDefaultPainter Property
Gets or sets DataTipPainter object used to paint DataTip content.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DataTipPainter DefaultPainter { get; set; }
Public Shared Property DefaultPainter As DataTipPainter
    Get
    Set
public:
static property DataTipPainter^ DefaultPainter {
    DataTipPainter^ get ();
    void set (DataTipPainter^ value);
}
static member DefaultPainter : DataTipPainter with get, set

Property Value

Type: DataTipPainter
See Also

Reference

DataTip Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipEvaluationMode Enumeration

DataTipEvaluationMode Enumeration
Defines type of DataTip evaluation result.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataTipEvaluationMode
Public Enumeration DataTipEvaluationMode
public enum class DataTipEvaluationMode
type DataTipEvaluationMode
Members
Member name | Value | Description
Value | 0 | Specifies evaluation result belongs to the main expression.
Children | 1 | Specifies evaluation result belongs to the nested expression.
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters Class

DataTipShowParameters Class
Represents evaluation data.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UI.DataTipsDataTipShowParameters

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DataTipShowParameters
Public Class DataTipShowParameters
public ref class DataTipShowParameters
type DataTipShowParameters =  class end

The DataTipShowParameters type exposes the following members.

Constructors
 | Name | Description
Public method | DataTipShowParameters | Initializes a new instance of the DataTipShowParameters class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomPainter | Gets DataTipPainter used to draw DataTipShowParameters content instead of default painter.
Public property | Debugger | Gets IScriptDebuggerBase used to evaluate expression.
Public property | EvaluationMode | Gets evaluation mode.
Public property | Expression | Gets expression to evaluate.
Public property | OwnerDataTip | Gets IDataTip that owns this DataTipShowParameters.
Public property | OwnerEditControl | Gets Control that owns this DataTipShowParameters.
Public property | PopupClientPosition | Gets position to popup DataTip.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters Constructor

DataTipShowParameters Constructor
Initializes a new instance of the DataTipShowParameters class with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DataTipShowParameters(
    Control ownerEditControl,
    IScriptDebuggerBase debugger,
    string expression,
    Point popupClientPosition,
    DataTipEvaluationMode evaluationMode = DataTipEvaluationMode.Value,
    IDataTip ownerDataTip = null,
    DataTipPainter customPainter = null
)
Public Sub New (
    ownerEditControl As Control,
    debugger As IScriptDebuggerBase,
    expression As String,
    popupClientPosition As Point,
    Optional evaluationMode As DataTipEvaluationMode = DataTipEvaluationMode.Value,
    Optional ownerDataTip As IDataTip = Nothing,
    Optional customPainter As DataTipPainter = Nothing
)
public:
DataTipShowParameters(
    Control^ ownerEditControl,
    IScriptDebuggerBase^ debugger,
    String^ expression,
    Point popupClientPosition,
    DataTipEvaluationMode evaluationMode = DataTipEvaluationMode::Value,
    IDataTip^ ownerDataTip = nullptr,
    DataTipPainter^ customPainter = nullptr
)
new :
        ownerEditControl : Control *
        debugger : IScriptDebuggerBase *
        expression : string *
        popupClientPosition : Point *
        ?evaluationMode : DataTipEvaluationMode *
        ?ownerDataTip : IDataTip *
        ?customPainter : DataTipPainter
(* Defaults:
        let _evaluationMode = defaultArg evaluationMode DataTipEvaluationMode.Value
        let _ownerDataTip = defaultArg ownerDataTip null
        let _customPainter = defaultArg customPainter null
*)
-> DataTipShowParameters

Parameters

ownerEditControl
Type: System.Windows.FormsControl
Specifies Control that owns this DataTipShowParameters.
debugger
Type: Alternet.Scripter.DebuggerIScriptDebuggerBase
Specifies IScriptDebuggerBase used to evaluate expression.
expression
Type: SystemString
Specifies expression to evaluate.
popupClientPosition
Type: System.DrawingPoint
Specifies position to popup DataTip.
evaluationMode (Optional)
Type: Alternet.Scripter.Debugger.UI.DataTipsDataTipEvaluationMode
Specifies evaluation mode.
ownerDataTip (Optional)
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
Specifies IDataTip that owns this DataTipShowParameters.
customPainter (Optional)
Type: Alternet.Scripter.Debugger.UI.DataTips.PaintingDataTipPainter
Specifies DataTipPainter used to draw DataTipShowParameters content instead of default painter.
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters Methods

DataTipShowParameters Methods

The DataTipShowParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters Properties

DataTipShowParameters Properties

The DataTipShowParameters type exposes the following members.

Properties
 | Name | Description
Public property | CustomPainter | Gets DataTipPainter used to draw DataTipShowParameters content instead of default painter.
Public property | Debugger | Gets IScriptDebuggerBase used to evaluate expression.
Public property | EvaluationMode | Gets evaluation mode.
Public property | Expression | Gets expression to evaluate.
Public property | OwnerDataTip | Gets IDataTip that owns this DataTipShowParameters.
Public property | OwnerEditControl | Gets Control that owns this DataTipShowParameters.
Public property | PopupClientPosition | Gets position to popup DataTip.
Top
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters.CustomPainter Property

DataTipShowParametersCustomPainter Property
Gets DataTipPainter used to draw DataTipShowParameters content instead of default painter.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DataTipPainter CustomPainter { get; }
Public ReadOnly Property CustomPainter As DataTipPainter
    Get
public:
property DataTipPainter^ CustomPainter {
    DataTipPainter^ get ();
}
member CustomPainter : DataTipPainter with get

Property Value

Type: DataTipPainter
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters.Debugger Property

DataTipShowParametersDebugger Property
Gets IScriptDebuggerBase used to evaluate expression.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; }
Public ReadOnly Property Debugger As IScriptDebuggerBase
    Get
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
}
member Debugger : IScriptDebuggerBase with get

Property Value

Type: IScriptDebuggerBase
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters.EvaluationMode Property

DataTipShowParametersEvaluationMode Property
Gets evaluation mode.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DataTipEvaluationMode EvaluationMode { get; }
Public ReadOnly Property EvaluationMode As DataTipEvaluationMode
    Get
public:
property DataTipEvaluationMode EvaluationMode {
    DataTipEvaluationMode get ();
}
member EvaluationMode : DataTipEvaluationMode with get

Property Value

Type: DataTipEvaluationMode
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters.Expression Property

DataTipShowParametersExpression Property
Gets expression to evaluate.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; }
Public ReadOnly Property Expression As String
    Get
public:
property String^ Expression {
    String^ get ();
}
member Expression : string with get

Property Value

Type: String
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters.OwnerDataTip Property

DataTipShowParametersOwnerDataTip Property
Gets IDataTip that owns this DataTipShowParameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDataTip OwnerDataTip { get; }
Public ReadOnly Property OwnerDataTip As IDataTip
    Get
public:
property IDataTip^ OwnerDataTip {
    IDataTip^ get ();
}
member OwnerDataTip : IDataTip with get

Property Value

Type: IDataTip
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters.OwnerEditControl Property

DataTipShowParametersOwnerEditControl Property
Gets Control that owns this DataTipShowParameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Control OwnerEditControl { get; }
Public ReadOnly Property OwnerEditControl As Control
    Get
public:
property Control^ OwnerEditControl {
    Control^ get ();
}
member OwnerEditControl : Control with get

Property Value

Type: Control
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipShowParameters.PopupClientPosition Property

DataTipShowParametersPopupClientPosition Property
Gets position to popup DataTip.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point PopupClientPosition { get; }
Public ReadOnly Property PopupClientPosition As Point
    Get
public:
property Point PopupClientPosition {
    Point get ();
}
member PopupClientPosition : Point with get

Property Value

Type: Point
See Also

Reference

DataTipShowParameters Class
Alternet.Scripter.Debugger.UI.DataTips Namespace


DataTipState Enumeration

DataTipState Enumeration
Defines DataTip states.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataTipState
Public Enumeration DataTipState
public enum class DataTipState
type DataTipState
Members
Member name | Value | Description
Evaluating | 0 | Specifies that expression is being evaluated.
Visible | 1 | Specifies that DataTip is visible.
Hidden | 2 | Specifies that DataTip is hidden.
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip Interface

IDataTip Interface
Represents properties and methods used to process evaluation data.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDataTip
Public Interface IDataTip
public interface class IDataTip
type IDataTip =  interface end

The IDataTip type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes current DataTip.
Top
Properties
 | Name | Description
Public property | HasExpandedItem | Gets a boolean value indicating whether DataTip has a child items.
Public property | Parameters | Gets DataTip data.
Public property | ScreenBounds | Gets DataTip screen working area.
Public property | State | Gets DataTip state.
Top
Events
 | Name | Description
Public event | AddWatchRequested | Occurs when user clicks on the local to add it to the watch window.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip Methods

IDataTip Methods

The IDataTip type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes current DataTip.
Top
See Also

Reference

IDataTip Interface
Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip.Close Method

IDataTipClose Method
Closes current DataTip.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Close()
Sub Close
void Close()
abstract Close : unit -> unit
See Also

Reference

IDataTip Interface
Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip Properties

IDataTip Properties

The IDataTip type exposes the following members.

Properties
 | Name | Description
Public property | HasExpandedItem | Gets a boolean value indicating whether DataTip has a child items.
Public property | Parameters | Gets DataTip data.
Public property | ScreenBounds | Gets DataTip screen working area.
Public property | State | Gets DataTip state.
Top
See Also

Reference

IDataTip Interface
Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip.HasExpandedItem Property

IDataTipHasExpandedItem Property
Gets a boolean value indicating whether DataTip has a child items.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasExpandedItem { get; }
ReadOnly Property HasExpandedItem As Boolean
    Get
property bool HasExpandedItem {
    bool get ();
}
abstract HasExpandedItem : bool with get

Property Value

Type: Boolean
See Also

Reference

IDataTip Interface
Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip.Parameters Property

IDataTipParameters Property
Gets DataTip data.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DataTipShowParameters Parameters { get; }
ReadOnly Property Parameters As DataTipShowParameters
    Get
property DataTipShowParameters^ Parameters {
    DataTipShowParameters^ get ();
}
abstract Parameters : DataTipShowParameters with get

Property Value

Type: DataTipShowParameters
See Also

Reference

IDataTip Interface
Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip.ScreenBounds Property

IDataTipScreenBounds Property
Gets DataTip screen working area.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle ScreenBounds { get; }
ReadOnly Property ScreenBounds As Rectangle
    Get
property Rectangle ScreenBounds {
    Rectangle get ();
}
abstract ScreenBounds : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

IDataTip Interface
Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip.State Property

IDataTipState Property
Gets DataTip state.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DataTipState State { get; }
ReadOnly Property State As DataTipState
    Get
property DataTipState State {
    DataTipState get ();
}
abstract State : DataTipState with get

Property Value

Type: DataTipState
See Also

Reference

IDataTip Interface
Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip Events

IDataTip Events

The IDataTip type exposes the following members.

Events
 | Name | Description
Public event | AddWatchRequested | Occurs when user clicks on the local to add it to the watch window.
Top
See Also

Reference

IDataTip Interface
Alternet.Scripter.Debugger.UI.DataTips Namespace


IDataTip.AddWatchRequested Event

IDataTipAddWatchRequested Event
Occurs when user clicks on the local to add it to the watch window.

Namespace: Alternet.Scripter.Debugger.UI.DataTips
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AddToWatchClickEventArgs> AddWatchRequested
Event AddWatchRequested As EventHandler(Of AddToWatchClickEventArgs)
 event EventHandler<AddToWatchClickEventArgs^>^ AddWatchRequested {
    void add (EventHandler<AddToWatchClickEventArgs^>^ value);
    void remove (EventHandler<AddToWatchClickEventArgs^>^ value);
}
abstract AddWatchRequested : IEvent<EventHandler<AddToWatchClickEventArgs>,
    AddToWatchClickEventArgs>

Value

Type: SystemEventHandlerAddToWatchClickEventArgs
See Also

Reference

IDataTip Interface
Alternet.Scripter.Debugger.UI.DataTips Namespace


Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace

Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace
Classes
 | Class | Description
Public class | DataTipPainter | Encapsulates a drawing surface, providing properties and methods used to draw DataTip.
Enumerations
 | Enumeration | Description
Public enumeration | DataTipPainterBrush | Defines types of Brush for DataTip elements.
Public enumeration | DataTipPainterImage | Defines types of DataTip images.
Public enumeration | DataTipPainterPen | Defines types of pen for DataTip elements.
Public enumeration | DataTipPainterTextStyle | Defines text styles for DataTip elements.


DataTipPainter Class

DataTipPainter Class
Encapsulates a drawing surface, providing properties and methods used to draw DataTip.
Inheritance Hierarchy
SystemObject
Alternet.CommonPainterResources DataTipPainterBrush, DataTipPainterPen, DataTipPainterImage, DataTipPainterImageList, DataTipPainterTextStyle
Alternet.Scripter.Debugger.UI.DataTips.PaintingDataTipPainter

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DataTipPainter : PainterResources<DataTipPainterBrush, DataTipPainterPen, DataTipPainterImage, DataTipPainterImageList, DataTipPainterTextStyle>
Public Class DataTipPainter
    Inherits PainterResources(Of DataTipPainterBrush, DataTipPainterPen, DataTipPainterImage, DataTipPainterImageList, DataTipPainterTextStyle)
public ref class DataTipPainter : public PainterResources<DataTipPainterBrush, DataTipPainterPen, DataTipPainterImage, DataTipPainterImageList, DataTipPainterTextStyle>
type DataTipPainter =
    class
        inherit PainterResources<DataTipPainterBrush, DataTipPainterPen, DataTipPainterImage, DataTipPainterImageList, DataTipPainterTextStyle>
    end

The DataTipPainter type exposes the following members.

Constructors
 | Name | Description
Public method | DataTipPainter | Initializes a new instance of the DataTipPainter class
Top
Methods
 | Name | Description
Public method | Dispose | Disposes this PainterResources and frees resources associated with it. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrush | Finds stored Brush object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetColumnSeparatorWidth | Gets the width of the Column Separator element.
Public method | GetExpandArrowSize | Gets the width and height, in pixels, of ExpandArrow element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Finds stored Image object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetImageList | Finds stored ImageList object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetItemImageSize | Gets the width and height, in pixels, of Item image.
Public method | GetItemTextHeight | Gets the height of the Item text.
Public method | GetPen | Finds stored Pen object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetTextStyle | Finds stored text style object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureItemNameText | Measures specified text.
Public method | MeasureItemValueText | Measures specified text.
Public method | PaintColumnSeparator | Paints Column Separator element of the IDataTip item with specified parameters.
Public method | PaintItemBackground | Paints background of the IDataTip item with specified parameters.
Public method | PaintItemExpandArrow | Paints ExpandArrow element of the IDataTip item with specified parameters.
Public method | PaintItemImage | Paints image of the IDataTip item with specified parameters.
Public method | PaintItemNameText | Paints name of the IDataTip item with specified parameters.
Public method | PaintItemValueText | Paints Value text of the IDataTip item with specified parameters.
Public method | PaintPopupBackground | Paints entire background of the IDataTip with specified parameters.
Public method | PaintPopupBorder | Paints PopupBorder element of the IDataTip item with specified parameters.
Public method | PaintScrollButton | Paints scrolling button of the IDataTip item with specified parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ColumnSeparatorColor |
Public property | ExpandArrowPadding | Gets the Padding for ExpandArrow element.
Public property | ItemBackgroundHoveredColor |
Public property | ItemImagePadding | Gets the Padding for Item image element.
Public property | ItemNameTextPadding | Gets the Padding for ItemName text.
Public property | ItemTextNormalColor |
Public property | ItemTextOverlappedColor |
Public property | ItemValueTextPadding | Gets the Padding for ItemValue text.
Public property | PopupBackgroundNormalColor |
Public property | PopupBackgroundOverlappedColor |
Public property | PopupBorderColor |
Public property | PopupBorderThickness | Represents width of the popup border.
Public property | PopupPadding | Gets the Padding for Popup element.
Public property | ScrollButtonHeight | Gets height of the scrolling button.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter Constructor

DataTipPainter Constructor
Initializes a new instance of the DataTipPainter class

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DataTipPainter()
Public Sub New
public:
DataTipPainter()
new : unit -> DataTipPainter
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter Methods

DataTipPainter Methods

The DataTipPainter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this PainterResources and frees resources associated with it. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBrush | Finds stored Brush object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetColumnSeparatorWidth | Gets the width of the Column Separator element.
Public method | GetExpandArrowSize | Gets the width and height, in pixels, of ExpandArrow element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Finds stored Image object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetImageList | Finds stored ImageList object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetItemImageSize | Gets the width and height, in pixels, of Item image.
Public method | GetItemTextHeight | Gets the height of the Item text.
Public method | GetPen | Finds stored Pen object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetTextStyle | Finds stored text style object accordingly to the specified type or creates a new one if necessary. (Inherited from PainterResourcesTBrushType, TPenType, TImageType, TImageListType, TTextStyleType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MeasureItemNameText | Measures specified text.
Public method | MeasureItemValueText | Measures specified text.
Public method | PaintColumnSeparator | Paints Column Separator element of the IDataTip item with specified parameters.
Public method | PaintItemBackground | Paints background of the IDataTip item with specified parameters.
Public method | PaintItemExpandArrow | Paints ExpandArrow element of the IDataTip item with specified parameters.
Public method | PaintItemImage | Paints image of the IDataTip item with specified parameters.
Public method | PaintItemNameText | Paints name of the IDataTip item with specified parameters.
Public method | PaintItemValueText | Paints Value text of the IDataTip item with specified parameters.
Public method | PaintPopupBackground | Paints entire background of the IDataTip with specified parameters.
Public method | PaintPopupBorder | Paints PopupBorder element of the IDataTip item with specified parameters.
Public method | PaintScrollButton | Paints scrolling button of the IDataTip item with specified parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.GetColumnSeparatorWidth Method

DataTipPainterGetColumnSeparatorWidth Method
Gets the width of the Column Separator element.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetColumnSeparatorWidth()
Public Overridable Function GetColumnSeparatorWidth As Integer
public:
virtual int GetColumnSeparatorWidth()
abstract GetColumnSeparatorWidth : unit -> int
override GetColumnSeparatorWidth : unit -> int

Return Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.GetExpandArrowSize Method

DataTipPainterGetExpandArrowSize Method
Gets the width and height, in pixels, of ExpandArrow element.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size GetExpandArrowSize()
Public Overridable Function GetExpandArrowSize As Size
public:
virtual Size GetExpandArrowSize()
abstract GetExpandArrowSize : unit -> Size
override GetExpandArrowSize : unit -> Size

Return Value

Type: Size
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.GetItemImageSize Method

DataTipPainterGetItemImageSize Method
Gets the width and height, in pixels, of Item image.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size GetItemImageSize()
Public Overridable Function GetItemImageSize As Size
public:
virtual Size GetItemImageSize()
abstract GetItemImageSize : unit -> Size
override GetItemImageSize : unit -> Size

Return Value

Type: Size
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.GetItemTextHeight Method

DataTipPainterGetItemTextHeight Method
Gets the height of the Item text.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetItemTextHeight()
Public Overridable Function GetItemTextHeight As Integer
public:
virtual int GetItemTextHeight()
abstract GetItemTextHeight : unit -> int
override GetItemTextHeight : unit -> int

Return Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.MeasureItemNameText Method

DataTipPainterMeasureItemNameText Method
Measures specified text.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size MeasureItemNameText(
    EvaluationResult itemData,
    string name
)
Public Overridable Function MeasureItemNameText (
    itemData As EvaluationResult,
    name As String
) As Size
public:
virtual Size MeasureItemNameText(
    EvaluationResult^ itemData,
    String^ name
)
abstract MeasureItemNameText :
        itemData : EvaluationResult *
        name : string -> Size
override MeasureItemNameText :
        itemData : EvaluationResult *
        name : string -> Size

Parameters

itemData
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
The result of evaluation.
name
Type: SystemString
Text to measure.

Return Value

Type: Size
Size, in pixels, of text drawn with the default font and format.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.MeasureItemValueText Method

DataTipPainterMeasureItemValueText Method
Measures specified text.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size MeasureItemValueText(
    EvaluationResult itemData,
    string value
)
Public Overridable Function MeasureItemValueText (
    itemData As EvaluationResult,
    value As String
) As Size
public:
virtual Size MeasureItemValueText(
    EvaluationResult^ itemData,
    String^ value
)
abstract MeasureItemValueText :
        itemData : EvaluationResult *
        value : string -> Size
override MeasureItemValueText :
        itemData : EvaluationResult *
        value : string -> Size

Parameters

itemData
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
The result of evaluation.
value
Type: SystemString
Text to measure.

Return Value

Type: Size
Size, in pixels, of text drawn with the default font and format.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PaintColumnSeparator Method

DataTipPainterPaintColumnSeparator Method
Paints Column Separator element of the IDataTip item with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintColumnSeparator(
    Graphics g,
    Point top,
    Point bottom,
    IDataTip dataTip
)
Public Overridable Sub PaintColumnSeparator (
    g As Graphics,
    top As Point,
    bottom As Point,
    dataTip As IDataTip
)
public:
virtual void PaintColumnSeparator(
    Graphics^ g,
    Point top,
    Point bottom,
    IDataTip^ dataTip
)
abstract PaintColumnSeparator :
        g : Graphics *
        top : Point *
        bottom : Point *
        dataTip : IDataTip -> unit
override PaintColumnSeparator :
        g : Graphics *
        top : Point *
        bottom : Point *
        dataTip : IDataTip -> unit

Parameters

g
Type: System.DrawingGraphics
The Graphics object to draw on.
top
Type: System.DrawingPoint
Top of the Column Separator element.
bottom
Type: System.DrawingPoint
Bottom of the Column Separator element.
dataTip
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
IDataTip to be drawn.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PaintItemBackground Method

DataTipPainterPaintItemBackground Method
Paints background of the IDataTip item with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintItemBackground(
    Graphics g,
    Rectangle bounds,
    IDataTip dataTip,
    bool isHovered
)
Public Overridable Sub PaintItemBackground (
    g As Graphics,
    bounds As Rectangle,
    dataTip As IDataTip,
    isHovered As Boolean
)
public:
virtual void PaintItemBackground(
    Graphics^ g,
    Rectangle bounds,
    IDataTip^ dataTip,
    bool isHovered
)
abstract PaintItemBackground :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        isHovered : bool -> unit
override PaintItemBackground :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        isHovered : bool -> unit

Parameters

g
Type: System.DrawingGraphics
The Graphics object to draw on.
bounds
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the IDataTip object.
dataTip
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
IDataTip to be drawn.
isHovered
Type: SystemBoolean
Indicates whether IDataTip is in hover state.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PaintItemExpandArrow Method

DataTipPainterPaintItemExpandArrow Method
Paints ExpandArrow element of the IDataTip item with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintItemExpandArrow(
    Graphics g,
    Rectangle bounds,
    IDataTip dataTip,
    EvaluationResult itemData,
    bool expanded
)
Public Overridable Sub PaintItemExpandArrow (
    g As Graphics,
    bounds As Rectangle,
    dataTip As IDataTip,
    itemData As EvaluationResult,
    expanded As Boolean
)
public:
virtual void PaintItemExpandArrow(
    Graphics^ g,
    Rectangle bounds,
    IDataTip^ dataTip,
    EvaluationResult^ itemData,
    bool expanded
)
abstract PaintItemExpandArrow :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        itemData : EvaluationResult *
        expanded : bool -> unit
override PaintItemExpandArrow :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        itemData : EvaluationResult *
        expanded : bool -> unit

Parameters

g
Type: System.DrawingGraphics
The Graphics object to draw on.
bounds
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the ExpandArrow element.
dataTip
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
IDataTip to be drawn.
itemData
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
The result of evaluation.
expanded
Type: SystemBoolean
State of the ExpandArrow element.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PaintItemImage Method

DataTipPainterPaintItemImage Method
Paints image of the IDataTip item with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintItemImage(
    Graphics g,
    Rectangle bounds,
    IDataTip dataTip,
    EvaluationResult itemData
)
Public Overridable Sub PaintItemImage (
    g As Graphics,
    bounds As Rectangle,
    dataTip As IDataTip,
    itemData As EvaluationResult
)
public:
virtual void PaintItemImage(
    Graphics^ g,
    Rectangle bounds,
    IDataTip^ dataTip,
    EvaluationResult^ itemData
)
abstract PaintItemImage :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        itemData : EvaluationResult -> unit
override PaintItemImage :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        itemData : EvaluationResult -> unit

Parameters

g
Type: System.DrawingGraphics
The Graphics object to draw on.
bounds
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the image.
dataTip
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
IDataTip to be drawn.
itemData
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
The result of evaluation.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PaintItemNameText Method

DataTipPainterPaintItemNameText Method
Paints name of the IDataTip item with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintItemNameText(
    Graphics g,
    Rectangle bounds,
    IDataTip dataTip,
    EvaluationResult itemData,
    string name
)
Public Overridable Sub PaintItemNameText (
    g As Graphics,
    bounds As Rectangle,
    dataTip As IDataTip,
    itemData As EvaluationResult,
    name As String
)
public:
virtual void PaintItemNameText(
    Graphics^ g,
    Rectangle bounds,
    IDataTip^ dataTip,
    EvaluationResult^ itemData,
    String^ name
)
abstract PaintItemNameText :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        itemData : EvaluationResult *
        name : string -> unit
override PaintItemNameText :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        itemData : EvaluationResult *
        name : string -> unit

Parameters

g
Type: System.DrawingGraphics
The Graphics object to draw on.
bounds
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the name.
dataTip
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
IDataTip to be drawn.
itemData
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
The result of evaluation.
name
Type: SystemString
Text to be drawn as a name.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PaintItemValueText Method

DataTipPainterPaintItemValueText Method
Paints Value text of the IDataTip item with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintItemValueText(
    Graphics g,
    Rectangle bounds,
    IDataTip dataTip,
    EvaluationResult itemData,
    string value
)
Public Overridable Sub PaintItemValueText (
    g As Graphics,
    bounds As Rectangle,
    dataTip As IDataTip,
    itemData As EvaluationResult,
    value As String
)
public:
virtual void PaintItemValueText(
    Graphics^ g,
    Rectangle bounds,
    IDataTip^ dataTip,
    EvaluationResult^ itemData,
    String^ value
)
abstract PaintItemValueText :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        itemData : EvaluationResult *
        value : string -> unit
override PaintItemValueText :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        itemData : EvaluationResult *
        value : string -> unit

Parameters

g
Type: System.DrawingGraphics
The Graphics object to draw on.
bounds
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the ItemValue text.
dataTip
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
IDataTip to be drawn.
itemData
Type: Alternet.Scripter.Debugger.ExpressionEvaluationEvaluationResult
The result of evaluation.
value
Type: SystemString
Text to be drawn.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PaintPopupBackground Method

DataTipPainterPaintPopupBackground Method
Paints entire background of the IDataTip with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PaintPopupBackground(
    Graphics g,
    Region region,
    IDataTip dataTip
)
Public Sub PaintPopupBackground (
    g As Graphics,
    region As Region,
    dataTip As IDataTip
)
public:
void PaintPopupBackground(
    Graphics^ g,
    Region^ region,
    IDataTip^ dataTip
)
member PaintPopupBackground :
        g : Graphics *
        region : Region *
        dataTip : IDataTip -> unit

Parameters

g
Type: System.DrawingGraphics
The Graphics object to draw on.
region
Type: System.DrawingRegion
Region that bounds the drawing area for the IDataTip object.
dataTip
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
IDataTip to be drawn.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PaintPopupBorder Method

DataTipPainterPaintPopupBorder Method
Paints PopupBorder element of the IDataTip item with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintPopupBorder(
    Graphics g,
    Rectangle bounds,
    IDataTip dataTip
)
Public Overridable Sub PaintPopupBorder (
    g As Graphics,
    bounds As Rectangle,
    dataTip As IDataTip
)
public:
virtual void PaintPopupBorder(
    Graphics^ g,
    Rectangle bounds,
    IDataTip^ dataTip
)
abstract PaintPopupBorder :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip -> unit
override PaintPopupBorder :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip -> unit

Parameters

g
Type: System.DrawingGraphics
The Graphics object to draw on.
bounds
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the PopupBorder element.
dataTip
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
IDataTip to be drawn.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PaintScrollButton Method

DataTipPainterPaintScrollButton Method
Paints scrolling button of the IDataTip item with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PaintScrollButton(
    Graphics g,
    Rectangle bounds,
    IDataTip dataTip,
    bool up,
    bool highlighted
)
Public Overridable Sub PaintScrollButton (
    g As Graphics,
    bounds As Rectangle,
    dataTip As IDataTip,
    up As Boolean,
    highlighted As Boolean
)
public:
virtual void PaintScrollButton(
    Graphics^ g,
    Rectangle bounds,
    IDataTip^ dataTip,
    bool up,
    bool highlighted
)
abstract PaintScrollButton :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        up : bool *
        highlighted : bool -> unit
override PaintScrollButton :
        g : Graphics *
        bounds : Rectangle *
        dataTip : IDataTip *
        up : bool *
        highlighted : bool -> unit

Parameters

g
Type: System.DrawingGraphics
The Graphics object to draw on.
bounds
Type: System.DrawingRectangle
Rectangle that bounds the drawing area for the scrolling button.
dataTip
Type: Alternet.Scripter.Debugger.UI.DataTipsIDataTip
IDataTip to be drawn.
up
Type: SystemBoolean
Indicates whether scrolling button is up or down type.
highlighted
Type: SystemBoolean
Indicates whether scrolling button is highlighted.
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter Properties

DataTipPainter Properties

The DataTipPainter type exposes the following members.

Properties
 | Name | Description
Public property | ColumnSeparatorColor |
Public property | ExpandArrowPadding | Gets the Padding for ExpandArrow element.
Public property | ItemBackgroundHoveredColor |
Public property | ItemImagePadding | Gets the Padding for Item image element.
Public property | ItemNameTextPadding | Gets the Padding for ItemName text.
Public property | ItemTextNormalColor |
Public property | ItemTextOverlappedColor |
Public property | ItemValueTextPadding | Gets the Padding for ItemValue text.
Public property | PopupBackgroundNormalColor |
Public property | PopupBackgroundOverlappedColor |
Public property | PopupBorderColor |
Public property | PopupBorderThickness | Represents width of the popup border.
Public property | PopupPadding | Gets the Padding for Popup element.
Public property | ScrollButtonHeight | Gets height of the scrolling button.
Top
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.ColumnSeparatorColor Property

DataTipPainterColumnSeparatorColor Property

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ColumnSeparatorColor { get; }
Public Overridable ReadOnly Property ColumnSeparatorColor As Integer
    Get
public:
virtual property int ColumnSeparatorColor {
    int get ();
}
abstract ColumnSeparatorColor : int with get
override ColumnSeparatorColor : int with get

Property Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.ExpandArrowPadding Property

DataTipPainterExpandArrowPadding Property
Gets the Padding for ExpandArrow element.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Padding ExpandArrowPadding { get; }
Public Overridable ReadOnly Property ExpandArrowPadding As Padding
    Get
public:
virtual property Padding ExpandArrowPadding {
    Padding get ();
}
abstract ExpandArrowPadding : Padding with get
override ExpandArrowPadding : Padding with get

Property Value

Type: Padding
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.ItemBackgroundHoveredColor Property

DataTipPainterItemBackgroundHoveredColor Property

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ItemBackgroundHoveredColor { get; }
Public Overridable ReadOnly Property ItemBackgroundHoveredColor As Integer
    Get
public:
virtual property int ItemBackgroundHoveredColor {
    int get ();
}
abstract ItemBackgroundHoveredColor : int with get
override ItemBackgroundHoveredColor : int with get

Property Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.ItemImagePadding Property

DataTipPainterItemImagePadding Property
Gets the Padding for Item image element.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Padding ItemImagePadding { get; }
Public Overridable ReadOnly Property ItemImagePadding As Padding
    Get
public:
virtual property Padding ItemImagePadding {
    Padding get ();
}
abstract ItemImagePadding : Padding with get
override ItemImagePadding : Padding with get

Property Value

Type: Padding
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.ItemNameTextPadding Property

DataTipPainterItemNameTextPadding Property
Gets the Padding for ItemName text.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Padding ItemNameTextPadding { get; }
Public Overridable ReadOnly Property ItemNameTextPadding As Padding
    Get
public:
virtual property Padding ItemNameTextPadding {
    Padding get ();
}
abstract ItemNameTextPadding : Padding with get
override ItemNameTextPadding : Padding with get

Property Value

Type: Padding
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.ItemTextNormalColor Property

DataTipPainterItemTextNormalColor Property

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ItemTextNormalColor { get; }
Public Overridable ReadOnly Property ItemTextNormalColor As Integer
    Get
public:
virtual property int ItemTextNormalColor {
    int get ();
}
abstract ItemTextNormalColor : int with get
override ItemTextNormalColor : int with get

Property Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.ItemTextOverlappedColor Property

DataTipPainterItemTextOverlappedColor Property

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ItemTextOverlappedColor { get; }
Public Overridable ReadOnly Property ItemTextOverlappedColor As Integer
    Get
public:
virtual property int ItemTextOverlappedColor {
    int get ();
}
abstract ItemTextOverlappedColor : int with get
override ItemTextOverlappedColor : int with get

Property Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.ItemValueTextPadding Property

DataTipPainterItemValueTextPadding Property
Gets the Padding for ItemValue text.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Padding ItemValueTextPadding { get; }
Public Overridable ReadOnly Property ItemValueTextPadding As Padding
    Get
public:
virtual property Padding ItemValueTextPadding {
    Padding get ();
}
abstract ItemValueTextPadding : Padding with get
override ItemValueTextPadding : Padding with get

Property Value

Type: Padding
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PopupBackgroundNormalColor Property

DataTipPainterPopupBackgroundNormalColor Property

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PopupBackgroundNormalColor { get; }
Public Overridable ReadOnly Property PopupBackgroundNormalColor As Integer
    Get
public:
virtual property int PopupBackgroundNormalColor {
    int get ();
}
abstract PopupBackgroundNormalColor : int with get
override PopupBackgroundNormalColor : int with get

Property Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PopupBackgroundOverlappedColor Property

DataTipPainterPopupBackgroundOverlappedColor Property

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PopupBackgroundOverlappedColor { get; }
Public Overridable ReadOnly Property PopupBackgroundOverlappedColor As Integer
    Get
public:
virtual property int PopupBackgroundOverlappedColor {
    int get ();
}
abstract PopupBackgroundOverlappedColor : int with get
override PopupBackgroundOverlappedColor : int with get

Property Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PopupBorderColor Property

DataTipPainterPopupBorderColor Property

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PopupBorderColor { get; }
Public Overridable ReadOnly Property PopupBorderColor As Integer
    Get
public:
virtual property int PopupBorderColor {
    int get ();
}
abstract PopupBorderColor : int with get
override PopupBorderColor : int with get

Property Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PopupBorderThickness Property

DataTipPainterPopupBorderThickness Property
Represents width of the popup border.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PopupBorderThickness { get; }
Public ReadOnly Property PopupBorderThickness As Integer
    Get
public:
property int PopupBorderThickness {
    int get ();
}
member PopupBorderThickness : int with get

Property Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.PopupPadding Property

DataTipPainterPopupPadding Property
Gets the Padding for Popup element.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Padding PopupPadding { get; }
Public Overridable ReadOnly Property PopupPadding As Padding
    Get
public:
virtual property Padding PopupPadding {
    Padding get ();
}
abstract PopupPadding : Padding with get
override PopupPadding : Padding with get

Property Value

Type: Padding
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainter.ScrollButtonHeight Property

DataTipPainterScrollButtonHeight Property
Gets height of the scrolling button.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ScrollButtonHeight { get; }
Public Overridable ReadOnly Property ScrollButtonHeight As Integer
    Get
public:
virtual property int ScrollButtonHeight {
    int get ();
}
abstract ScrollButtonHeight : int with get
override ScrollButtonHeight : int with get

Property Value

Type: Int32
See Also

Reference

DataTipPainter Class
Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainterBrush Enumeration

DataTipPainterBrush Enumeration
Defines types of Brush for DataTip elements.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataTipPainterBrush
Public Enumeration DataTipPainterBrush
public enum class DataTipPainterBrush
type DataTipPainterBrush
Members
Member name | Value | Description
PopupBackgroundNormal | 0 | Specifies brush for normal Popup Background.
PopupBackgroundOverlapped | 1 | Specifies brush for overlapped Popup Background.
ItemBackgroundHovered | 2 | Specifies brush for hovered Item Background.
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainterImage Enumeration

DataTipPainterImage Enumeration
Defines types of DataTip images.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataTipPainterImage
Public Enumeration DataTipPainterImage
public enum class DataTipPainterImage
type DataTipPainterImage
Members
Member name | Value | Description
Error | 0 | Specifies Error image.
FieldPublic | 1 | Specifies Public Field image.
FieldPrivate | 2 | Specifies Private Field image.
FieldInternal | 3 | Specifies Internal Field image.
FieldProtected | 4 | Specifies Protected Field image.
PropertyPublic | 5 | Specifies Public Property image.
PropertyPrivate | 6 | Specifies Private Property image.
PropertyInternal | 7 | Specifies Internal Property image.
PropertyProtected | 8 | Specifies Protected Property image.
StaticMembers | 9 | Specifies Static Members image.
ExpandArrowExpanded | 10 | Specifies ExpandArrow in expanded state image.
ExpandArrowCollapsed | 11 | Specifies ExpandArrow in collapsed state image.
ScrollButtonArrowUpNormal | 12 | Specifies ScrollButton Arrow Up in normal state image.
ScrollButtonArrowDownNormal | 13 | Specifies ScrollButton Arrow Down in normal state image.
ScrollButtonArrowUpHighlighted | 14 | Specifies ScrollButton Arrow Up in highlighted state image.
ScrollButtonArrowDownHighlighted | 15 | Specifies ScrollButton Arrow Down in highlighted state image.
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainterPen Enumeration

DataTipPainterPen Enumeration
Defines types of pen for DataTip elements.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataTipPainterPen
Public Enumeration DataTipPainterPen
public enum class DataTipPainterPen
type DataTipPainterPen
Members
Member name | Value | Description
PopupBorder | 0 | Specifies pen for PopupBorder element.
ColumnSeparator | 1 | Specifies pen for ColumnSeparator element.
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


DataTipPainterTextStyle Enumeration

DataTipPainterTextStyle Enumeration
Defines text styles for DataTip elements.

Namespace: Alternet.Scripter.Debugger.UI.DataTips.Painting
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataTipPainterTextStyle
Public Enumeration DataTipPainterTextStyle
public enum class DataTipPainterTextStyle
type DataTipPainterTextStyle
Members
Member name | Value | Description
ItemTextNormal | 0 | Specifies text style for item text in normal state.
ItemTextOverlapped | 1 | Specifies text style for item text in overlapped state.
See Also

Reference

Alternet.Scripter.Debugger.UI.DataTips.Painting Namespace


Alternet.Scripter.Debugger.UI.Evaluation Namespace

Alternet.Scripter.Debugger.UI.Evaluation Namespace
Classes
 | Class | Description
Public class | SetValueDialog |


SetValueDialog Class

SetValueDialog Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Scripter.Debugger.UI.EvaluationSetValueDialog

Namespace: Alternet.Scripter.Debugger.UI.Evaluation
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SetValueDialog : Form
Public Class SetValueDialog
    Inherits Form
public ref class SetValueDialog : public Form
type SetValueDialog =
    class
        inherit Form
    end

The SetValueDialog type exposes the following members.

Constructors
 | Name | Description
Public method | SetValueDialog | Initializes a new instance of the SetValueDialog class
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LeftSideExpression |
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightSideExpression |
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation Namespace


SetValueDialog Constructor

SetValueDialog Constructor
Initializes a new instance of the SetValueDialog class

Namespace: Alternet.Scripter.Debugger.UI.Evaluation
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SetValueDialog()
Public Sub New
public:
SetValueDialog()
new : unit -> SetValueDialog
See Also

Reference

SetValueDialog Class
Alternet.Scripter.Debugger.UI.Evaluation Namespace


SetValueDialog Methods

SetValueDialog Methods

The SetValueDialog type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

SetValueDialog Class
Alternet.Scripter.Debugger.UI.Evaluation Namespace


SetValueDialog Properties

SetValueDialog Properties

The SetValueDialog type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LeftSideExpression |
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightSideExpression |
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

SetValueDialog Class
Alternet.Scripter.Debugger.UI.Evaluation Namespace


SetValueDialog.LeftSideExpression Property

SetValueDialogLeftSideExpression Property

Namespace: Alternet.Scripter.Debugger.UI.Evaluation
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LeftSideExpression { get; set; }
Public Property LeftSideExpression As String
    Get
    Set
public:
property String^ LeftSideExpression {
    String^ get ();
    void set (String^ value);
}
member LeftSideExpression : string with get, set

Property Value

Type: String
See Also

Reference

SetValueDialog Class
Alternet.Scripter.Debugger.UI.Evaluation Namespace


SetValueDialog.RightSideExpression Property

SetValueDialogRightSideExpression Property

Namespace: Alternet.Scripter.Debugger.UI.Evaluation
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RightSideExpression { get; set; }
Public Property RightSideExpression As String
    Get
    Set
public:
property String^ RightSideExpression {
    String^ get ();
    void set (String^ value);
}
member RightSideExpression : string with get, set

Property Value

Type: String
See Also

Reference

SetValueDialog Class
Alternet.Scripter.Debugger.UI.Evaluation Namespace


SetValueDialog Events

SetValueDialog Events

The SetValueDialog type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SetValueDialog Class
Alternet.Scripter.Debugger.UI.Evaluation Namespace


Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace
Classes
 | Class | Description
Public class | CodeCompletionImages | Provides methods to manage a collection of System.Drawing.Image objects for code completion controller.
Public class | CodeCompletionPopup | Represents a pop-up window for Code Completion controller.
Public class | CodeCompletionPopupListBoxWithImages | Represents a Windows control to display a list of items with text and image.
Public class | CodeCompletionPopupListBoxWithImagesItem | Represents a ListBox item with text and image.
Public class | CodeCompletionPopupConfiguration | Provides properties and methods to setup Code completion pop-up window behaviour.
Public class | CollectionSetterCacheT | Helps to avoid redundant SetItems operations when the items set previously are the same.
Public class | EvaluationCodeCompletionControllerBase | Provides a base class for evaluation controller. This class is abstract.
Public class | ParameterInfoSymbol | Represents data for the parameter info.
Public class | Popup | Represents a pop-up window.
Interfaces
 | Interface | Description
Public interface | EvaluationCodeCompletionControllerBaseISite | Represents methods declaration to support evaluation functionality.
Public interface | ICodeCompletionPopup | Represents a pop-up window for Code Completion controller.
Enumerations
 | Enumeration | Description
Public enumeration | ChangePopupSelectionCommand | Specifies the possible kinds of popup selection command.
Public enumeration | PopupAnimations | Types of animation of the pop-up window.


ChangePopupSelectionCommand Enumeration

ChangePopupSelectionCommand Enumeration
Specifies the possible kinds of popup selection command.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChangePopupSelectionCommand
Public Enumeration ChangePopupSelectionCommand
public enum class ChangePopupSelectionCommand
type ChangePopupSelectionCommand
Members
Member name | Value | Description
Up | 0 | Select up.
Down | 1 | Select down.
PageUp | 2 | Select page up.
PageDown | 3 | Select page down.
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionImages Class

CodeCompletionImages Class
Provides methods to manage a collection of System.Drawing.Image objects for code completion controller.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionCodeCompletionImages

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionImages
Public Class CodeCompletionImages
public ref class CodeCompletionImages
type CodeCompletionImages =  class end

The CodeCompletionImages type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionImages | Initializes a new instance of the CodeCompletionImages class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageListIndex | Gets number of image corresponding to specified SymbolKind.
Public method | GetScaledImageList | Gets output images, with scaling applied, if required.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionImages Constructor

CodeCompletionImages Constructor
Initializes a new instance of the CodeCompletionImages class

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionImages()
Public Sub New
public:
CodeCompletionImages()
new : unit -> CodeCompletionImages
See Also

Reference

CodeCompletionImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionImages Methods

CodeCompletionImages Methods

The CodeCompletionImages type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageListIndex | Gets number of image corresponding to specified SymbolKind.
Public method | GetScaledImageList | Gets output images, with scaling applied, if required.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeCompletionImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionImages.GetImageListIndex Method

CodeCompletionImagesGetImageListIndex Method
Gets number of image corresponding to specified SymbolKind.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetImageListIndex(
    SymbolKind kind
)
Public Overridable Function GetImageListIndex (
    kind As SymbolKind
) As Integer
public:
virtual int GetImageListIndex(
    SymbolKind kind
)
abstract GetImageListIndex :
        kind : SymbolKind -> int
override GetImageListIndex :
        kind : SymbolKind -> int

Parameters

kind
Type: Alternet.Scripter.Debugger.ExpressionEvaluation.CodeCompletionSymbolKind
Kind of symbol to find image index.

Return Value

Type: Int32
Index inside image collection for specified SymbolKind.
See Also

Reference

CodeCompletionImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionImages.GetScaledImageList Method

CodeCompletionImagesGetScaledImageList Method
Gets output images, with scaling applied, if required.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList GetScaledImageList()
Public Overridable Function GetScaledImageList As ImageList
public:
virtual ImageList^ GetScaledImageList()
abstract GetScaledImageList : unit -> ImageList
override GetScaledImageList : unit -> ImageList

Return Value

Type: ImageList
Scaled image list.
See Also

Reference

CodeCompletionImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup Class

CodeCompletionPopup Class
Represents a pop-up window for Code Completion controller.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsToolStrip
System.Windows.FormsToolStripDropDown
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionPopup
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionCodeCompletionPopup

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionPopup : Popup,
    ICodeCompletionPopup
Public Class CodeCompletionPopup
    Inherits Popup
    Implements ICodeCompletionPopup
public ref class CodeCompletionPopup : public Popup,
    ICodeCompletionPopup
type CodeCompletionPopup =
    class
        inherit Popup
        interface ICodeCompletionPopup
    end

The CodeCompletionPopup type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionPopup | Initializes a new instance of the CodeCompletionPopup class with specified settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ChangeSelection | Changes selection accordingly to specified command.
Public method | Close | Closes pop-up control.
Public method | Close(ToolStripDropDownCloseReason) | Closes the ToolStripDropDown control for the specified reason. (Inherited from ToolStripDropDown.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
Public method | GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)
Public method | GetItems | Represents list of items in a string form.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelectedItem | Finds out currently selected item in the pop-up window.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PaintSizeGrip | Paints the sizing grip. (Inherited from Popup.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | ProcessResizing | Processes the resizing messages. (Inherited from Popup.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetItems | Updates Symbol collection to the pop-up control.
Public method | Show | Displays the ToolStripDropDown control in its default position. (Inherited from ToolStripDropDown.)
Public method | Show(Point) | Positions the ToolStripDropDown relative to the specified screen location. (Inherited from ToolStripDropDown.)
Public method | Show(Rectangle) | Shows the pop-up window below the specified area. (Inherited from Popup.)
Public method | Show(Control) | Shows the pop-up window below the specified control. (Inherited from Popup.)
Public method | Show(Control, Point) | Positions the ToolStripDropDown relative to the specified control location. (Inherited from ToolStripDropDown.)
Public method | Show(Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Int32, Int32) | Positions the ToolStripDropDown relative to the specified screen coordinates. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Rectangle) | Shows the pop-up window below the specified area of the specified control. (Inherited from Popup.)
Public method | Show(Control, Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control at the specified location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Int32, Int32) | Positions the ToolStripDropDown relative to the specified control's horizontal and vertical screen coordinates. (Inherited from ToolStripDropDown.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the ToolStrip control. (Inherited from ToolStrip.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AcceptAlt | Gets or sets a value indicating whether pressing the alt key should close the pop-up. (Inherited from Popup.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
Public property | AllowItemReorder | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
Public property | AllowTransparency | Gets or sets a value indicating whether the Opacity of the form can be adjusted. (Inherited from ToolStripDropDown.)
Public property | Anchor | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AnimationDuration | Determines the duration of the animation. (Inherited from Popup.)
Public property | AutoClose | Gets or sets a value indicating whether the ToolStripDropDown control should automatically close when it has lost activation. (Inherited from ToolStripDropDown.)
Public property | AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoSize | Gets or sets a value indicating whether the ToolStripDropDown automatically adjusts its size when the form is resized. (Inherited from ToolStripDropDown.)
Public property | BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanOverflow | Gets or sets a value indicating whether the items in a ToolStripDropDown can be sent to an overflow menu. (Inherited from ToolStripDropDown.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content of the pop-up. (Inherited from Popup.)
Public property | ContextMenu | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | ContextMenuStrip | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultDropDownDirection | Gets or sets the direction in which the ToolStripDropDown is displayed relative to the ToolStrip. (Inherited from ToolStripDropDown.)
Public property | DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DropShadowEnabled | Gets or sets a value indicating whether a three-dimensional shadow effect appears when the ToolStripDropDown is displayed. (Inherited from ToolStripDropDown.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusOnOpen | Gets or sets a value indicating whether the content should receive the focus after the pop-up has been opened. (Inherited from Popup.)
Public property | Font | Gets or sets the font of the text displayed on the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
Public property | GripDisplayStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripMargin | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripRectangle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HidingAnimation | Determines which animation to use while hiding the pop-up window. (Inherited from Popup.)
Public property | HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
Public property | ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsAutoGenerated | Gets a value indicating whether this ToolStripDropDown was automatically generated. (Inherited from ToolStripDropDown.)
Public property | IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
Public property | LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
Public property | LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
Public property | LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets a maximum size of the pop-up. (Inherited from Popup.)
Public property | MinimumSize | Gets or sets a minimum size of the pop-up. (Inherited from Popup.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NonInteractive | Gets or sets a value indicating whether the Popup acts like a transparent windows (so it cannot be clicked). (Inherited from Popup.)
Public property | Opacity | Determines the opacity of the form. (Inherited from ToolStripDropDown.)
Public property | Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
Public property | OverflowButton | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | OwnerItem | Gets or sets the ToolStripItem that is the owner of this ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
Public property | RenderMode | Gets or sets a value that indicates which visual styles will be applied to the ToolStrip. (Inherited from ToolStrip.)
Public property | Resizable | Gets or sets a value indicating whether the Popup is resizable. (Inherited from Popup.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | (Inherited from ToolStripDropDown.)
Public property | ShowingAnimation | Determines which animation to use while showing the pop-up window. (Inherited from Popup.)
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Stretch | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabIndex | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextDirection | Specifies the direction in which to draw the text on the item. (Inherited from ToolStripDropDown.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether the ToolStripDropDown is a top-level control. (Inherited from ToolStripDropDown.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Visible | Gets or sets a value indicating whether the ToolStripDropDown is visible or hidden. (Inherited from ToolStripDropDown.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from ToolStripDropDown.)
Public event | CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from ToolStripDropDown.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the ToolStripDropDown is closed. (Inherited from ToolStripDropDown.)
Public event | Closing | Occurs when the ToolStripDropDown control is about to close. (Inherited from ToolStripDropDown.)
Public event | ContextMenuChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ContextMenuStripChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Public event | Enter | Occurs when the focus enters the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public event | FontChanged | Occurs when the value of the Font property changes. (Inherited from ToolStripDropDown.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStripDropDown.)
Public event | GiveFeedback | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from ToolStripDropDown.)
Public event | ImeModeChanged | Occurs when the ImeModeChanged property has changed. (Inherited from ToolStripDropDown.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
Public event | ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | KeyDown | Occurs when a key is pressed and held down while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyPress | Occurs when a key is pressed while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from ToolStripDropDown.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
Public event | LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from ToolStripDropDown.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | Opened | Occurs when the ToolStripDropDown is opened. (Inherited from ToolStripDropDown.)
Public event | Opening | Occurs when the ToolStripDropDown control is opening. (Inherited from ToolStripDropDown.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from ToolStripDropDown.)
Public event | RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the ToolStripLayoutStyle style changes. (Inherited from ToolStripDropDown.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | TabStopChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | TextChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validated | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validating | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup Constructor

CodeCompletionPopup Constructor
Initializes a new instance of the CodeCompletionPopup class with specified settings.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionPopup(
    Control ownerControl,
    CodeCompletionPopupConfiguration configuration
)
Public Sub New (
    ownerControl As Control,
    configuration As CodeCompletionPopupConfiguration
)
public:
CodeCompletionPopup(
    Control^ ownerControl,
    CodeCompletionPopupConfiguration^ configuration
)
new :
        ownerControl : Control *
        configuration : CodeCompletionPopupConfiguration -> CodeCompletionPopup

Parameters

ownerControl
Type: System.Windows.FormsControl
The control owning this new instance.
configuration
Type: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionCodeCompletionPopupConfiguration
The CodeCompletionPopupConfiguration corresponding to this new instance.
See Also

Reference

CodeCompletionPopup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup Methods

CodeCompletionPopup Methods

The CodeCompletionPopup type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ChangeSelection | Changes selection accordingly to specified command.
Public method | Close | Closes pop-up control.
Public method | Close(ToolStripDropDownCloseReason) | Closes the ToolStripDropDown control for the specified reason. (Inherited from ToolStripDropDown.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
Public method | GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)
Public method | GetItems | Represents list of items in a string form.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelectedItem | Finds out currently selected item in the pop-up window.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PaintSizeGrip | Paints the sizing grip. (Inherited from Popup.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | ProcessResizing | Processes the resizing messages. (Inherited from Popup.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetItems | Updates Symbol collection to the pop-up control.
Public method | Show | Displays the ToolStripDropDown control in its default position. (Inherited from ToolStripDropDown.)
Public method | Show(Point) | Positions the ToolStripDropDown relative to the specified screen location. (Inherited from ToolStripDropDown.)
Public method | Show(Rectangle) | Shows the pop-up window below the specified area. (Inherited from Popup.)
Public method | Show(Control) | Shows the pop-up window below the specified control. (Inherited from Popup.)
Public method | Show(Control, Point) | Positions the ToolStripDropDown relative to the specified control location. (Inherited from ToolStripDropDown.)
Public method | Show(Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Int32, Int32) | Positions the ToolStripDropDown relative to the specified screen coordinates. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Rectangle) | Shows the pop-up window below the specified area of the specified control. (Inherited from Popup.)
Public method | Show(Control, Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control at the specified location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Int32, Int32) | Positions the ToolStripDropDown relative to the specified control's horizontal and vertical screen coordinates. (Inherited from ToolStripDropDown.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the ToolStrip control. (Inherited from ToolStrip.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionPopup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ChangeSelection Method

CodeCompletionPopupChangeSelection Method
Changes selection accordingly to specified command.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ChangeSelection(
    ChangePopupSelectionCommand command
)
Public Sub ChangeSelection (
    command As ChangePopupSelectionCommand
)
public:
virtual void ChangeSelection(
    ChangePopupSelectionCommand command
) sealed
abstract ChangeSelection :
        command : ChangePopupSelectionCommand -> unit
override ChangeSelection :
        command : ChangePopupSelectionCommand -> unit

Parameters

command
Type: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionChangePopupSelectionCommand
Specifies selection command.

Implements

ICodeCompletionPopupChangeSelection(ChangePopupSelectionCommand)
See Also

Reference

CodeCompletionPopup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.Close Method

CodeCompletionPopupClose Method
Overload List
 | Name | Description
Public method | Close | Closes pop-up control.
Public method | Close(ToolStripDropDownCloseReason) | Closes the ToolStripDropDown control for the specified reason. (Inherited from ToolStripDropDown.)
Top
See Also

Reference

CodeCompletionPopup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.Close Method

CodeCompletionPopupClose Method
Closes pop-up control.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
virtual void Close() sealed
abstract Close : unit -> unit
override Close : unit -> unit

Implements

ICodeCompletionPopupClose
See Also

Reference

CodeCompletionPopup Class
Close Overload
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.GetItems Method

CodeCompletionPopupGetItems Method
Represents list of items in a string form.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> GetItems()
Public Function GetItems As IEnumerable(Of String)
public:
virtual IEnumerable<String^>^ GetItems() sealed
abstract GetItems : unit -> IEnumerable<string>
override GetItems : unit -> IEnumerable<string>

Return Value

Type: IEnumerableString
List of items.

Implements

ICodeCompletionPopupGetItems
See Also

Reference

CodeCompletionPopup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.GetSelectedItem Method

CodeCompletionPopupGetSelectedItem Method
Finds out currently selected item in the pop-up window.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetSelectedItem()
Public Function GetSelectedItem As String
public:
virtual String^ GetSelectedItem() sealed
abstract GetSelectedItem : unit -> string
override GetSelectedItem : unit -> string

Return Value

Type: String
Selected item in a string form.

Implements

ICodeCompletionPopupGetSelectedItem
See Also

Reference

CodeCompletionPopup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.SetItems Method

CodeCompletionPopupSetItems Method
Updates Symbol collection to the pop-up control.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetItems(
    IEnumerable<Symbol> items
)
Public Sub SetItems (
    items As IEnumerable(Of Symbol)
)
public:
virtual void SetItems(
    IEnumerable<Symbol^>^ items
) sealed
abstract SetItems :
        items : IEnumerable<Symbol> -> unit
override SetItems :
        items : IEnumerable<Symbol> -> unit

Parameters

items
Type: System.Collections.GenericIEnumerableSymbol
List of Symbol to be set.

Implements

ICodeCompletionPopupSetItems(IEnumerableSymbol)
See Also

Reference

CodeCompletionPopup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup Properties

CodeCompletionPopup Properties

The CodeCompletionPopup type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAlt | Gets or sets a value indicating whether pressing the alt key should close the pop-up. (Inherited from Popup.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
Public property | AllowItemReorder | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
Public property | AllowTransparency | Gets or sets a value indicating whether the Opacity of the form can be adjusted. (Inherited from ToolStripDropDown.)
Public property | Anchor | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AnimationDuration | Determines the duration of the animation. (Inherited from Popup.)
Public property | AutoClose | Gets or sets a value indicating whether the ToolStripDropDown control should automatically close when it has lost activation. (Inherited from ToolStripDropDown.)
Public property | AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoSize | Gets or sets a value indicating whether the ToolStripDropDown automatically adjusts its size when the form is resized. (Inherited from ToolStripDropDown.)
Public property | BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanOverflow | Gets or sets a value indicating whether the items in a ToolStripDropDown can be sent to an overflow menu. (Inherited from ToolStripDropDown.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content of the pop-up. (Inherited from Popup.)
Public property | ContextMenu | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | ContextMenuStrip | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultDropDownDirection | Gets or sets the direction in which the ToolStripDropDown is displayed relative to the ToolStrip. (Inherited from ToolStripDropDown.)
Public property | DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DropShadowEnabled | Gets or sets a value indicating whether a three-dimensional shadow effect appears when the ToolStripDropDown is displayed. (Inherited from ToolStripDropDown.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusOnOpen | Gets or sets a value indicating whether the content should receive the focus after the pop-up has been opened. (Inherited from Popup.)
Public property | Font | Gets or sets the font of the text displayed on the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
Public property | GripDisplayStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripMargin | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripRectangle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HidingAnimation | Determines which animation to use while hiding the pop-up window. (Inherited from Popup.)
Public property | HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
Public property | ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsAutoGenerated | Gets a value indicating whether this ToolStripDropDown was automatically generated. (Inherited from ToolStripDropDown.)
Public property | IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
Public property | LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
Public property | LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
Public property | LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets a maximum size of the pop-up. (Inherited from Popup.)
Public property | MinimumSize | Gets or sets a minimum size of the pop-up. (Inherited from Popup.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NonInteractive | Gets or sets a value indicating whether the Popup acts like a transparent windows (so it cannot be clicked). (Inherited from Popup.)
Public property | Opacity | Determines the opacity of the form. (Inherited from ToolStripDropDown.)
Public property | Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
Public property | OverflowButton | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | OwnerItem | Gets or sets the ToolStripItem that is the owner of this ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
Public property | RenderMode | Gets or sets a value that indicates which visual styles will be applied to the ToolStrip. (Inherited from ToolStrip.)
Public property | Resizable | Gets or sets a value indicating whether the Popup is resizable. (Inherited from Popup.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | (Inherited from ToolStripDropDown.)
Public property | ShowingAnimation | Determines which animation to use while showing the pop-up window. (Inherited from Popup.)
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Stretch | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabIndex | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextDirection | Specifies the direction in which to draw the text on the item. (Inherited from ToolStripDropDown.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether the ToolStripDropDown is a top-level control. (Inherited from ToolStripDropDown.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Visible | Gets or sets a value indicating whether the ToolStripDropDown is visible or hidden. (Inherited from ToolStripDropDown.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionPopup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup Events

CodeCompletionPopup Events

The CodeCompletionPopup type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from ToolStripDropDown.)
Public event | CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from ToolStripDropDown.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the ToolStripDropDown is closed. (Inherited from ToolStripDropDown.)
Public event | Closing | Occurs when the ToolStripDropDown control is about to close. (Inherited from ToolStripDropDown.)
Public event | ContextMenuChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ContextMenuStripChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Public event | Enter | Occurs when the focus enters the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public event | FontChanged | Occurs when the value of the Font property changes. (Inherited from ToolStripDropDown.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStripDropDown.)
Public event | GiveFeedback | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from ToolStripDropDown.)
Public event | ImeModeChanged | Occurs when the ImeModeChanged property has changed. (Inherited from ToolStripDropDown.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
Public event | ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | KeyDown | Occurs when a key is pressed and held down while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyPress | Occurs when a key is pressed while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from ToolStripDropDown.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
Public event | LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from ToolStripDropDown.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | Opened | Occurs when the ToolStripDropDown is opened. (Inherited from ToolStripDropDown.)
Public event | Opening | Occurs when the ToolStripDropDown control is opening. (Inherited from ToolStripDropDown.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from ToolStripDropDown.)
Public event | RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the ToolStripLayoutStyle style changes. (Inherited from ToolStripDropDown.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | TabStopChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | TextChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validated | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validating | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionPopup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImages Class

CodeCompletionPopupListBoxWithImages Class
Represents a Windows control to display a list of items with text and image.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsListBox
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionCodeCompletionPopupListBoxWithImages

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ListBoxWithImages : ListBox
Public Class ListBoxWithImages
    Inherits ListBox
public ref class ListBoxWithImages : public ListBox
type ListBoxWithImages =
    class
        inherit ListBox
    end

The CodeCompletionPopupListBoxWithImages type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionPopupListBoxWithImages | Initializes a new instance of the ListBoxWithImages class with default settings.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemsPreferredSize | Calculates dimension of items area.
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | ImageList | Gets or sets the ImageList that contains the images to display in this ListBoxWithImages.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | Items | Gets the items of the ListBox. (Inherited from ListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImages Constructor

CodeCompletionPopupListBoxWithImages Constructor
Initializes a new instance of the ListBoxWithImages class with default settings.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListBoxWithImages()
Public Sub New
public:
ListBoxWithImages()
new : unit -> ListBoxWithImages
See Also

Reference

CodeCompletionPopupListBoxWithImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ListBoxWithImages Methods

ListBoxWithImages Methods

The CodeCompletionPopupListBoxWithImages type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemsPreferredSize | Calculates dimension of items area.
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionPopupListBoxWithImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImages.GetItemsPreferredSize Method

CodeCompletionPopupListBoxWithImagesGetItemsPreferredSize Method
Calculates dimension of items area.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Size GetItemsPreferredSize()
Public Function GetItemsPreferredSize As Size
public:
Size GetItemsPreferredSize()
member GetItemsPreferredSize : unit -> Size

Return Value

Type: Size
Height and width of the items area.
See Also

Reference

CodeCompletionPopupListBoxWithImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ListBoxWithImages Properties

ListBoxWithImages Properties

The CodeCompletionPopupListBoxWithImages type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | ImageList | Gets or sets the ImageList that contains the images to display in this ListBoxWithImages.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | Items | Gets the items of the ListBox. (Inherited from ListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionPopupListBoxWithImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImages.ImageList Property

CodeCompletionPopupListBoxWithImagesImageList Property
Gets or sets the ImageList that contains the images to display in this ListBoxWithImages.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageList ImageList { get; set; }
Public Property ImageList As ImageList
    Get
    Set
public:
property ImageList^ ImageList {
    ImageList^ get ();
    void set (ImageList^ value);
}
member ImageList : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

CodeCompletionPopupListBoxWithImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ListBoxWithImages Events

ListBoxWithImages Events

The CodeCompletionPopupListBoxWithImages type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CodeCompletionPopupListBoxWithImages Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImagesItem Class

CodeCompletionPopupListBoxWithImagesItem Class
Represents a ListBox item with text and image.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionCodeCompletionPopupListBoxWithImagesItem

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ListBoxWithImagesItem
Public Class ListBoxWithImagesItem
public ref class ListBoxWithImagesItem
type ListBoxWithImagesItem =  class end

The CodeCompletionPopupListBoxWithImagesItem type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionPopupListBoxWithImagesItem | Initializes a new instance of the ListBoxWithImagesItem class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the item. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Documentation | Gets or sets SymbolDocumentation related to this item.
Public property | ImageIndex | Gets or sets the index value of the image displayed on this item.
Public property | Text | Gets or sets item text.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImagesItem Constructor

CodeCompletionPopupListBoxWithImagesItem Constructor
Initializes a new instance of the ListBoxWithImagesItem class with specified settings.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListBoxWithImagesItem(
    string text,
    int index,
    Lazy<SymbolDocumentation> documentation
)
Public Sub New (
    text As String,
    index As Integer,
    documentation As Lazy(Of SymbolDocumentation)
)
public:
ListBoxWithImagesItem(
    String^ text,
    int index,
    Lazy<SymbolDocumentation^>^ documentation
)
new :
        text : string *
        index : int *
        documentation : Lazy<SymbolDocumentation> -> ListBoxWithImagesItem

Parameters

text
Type: SystemString
Text of the new instance.
index
Type: SystemInt32
Image index of the new instance.
documentation
Type: SystemLazySymbolDocumentation
SymbolDocumentation related to this new instance.
See Also

Reference

CodeCompletionPopupListBoxWithImagesItem Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ListBoxWithImagesItem Methods

ListBoxWithImagesItem Methods

The CodeCompletionPopupListBoxWithImagesItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the item. (Overrides ObjectToString.)
Top
See Also

Reference

CodeCompletionPopupListBoxWithImagesItem Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImagesItem.ToString Method

CodeCompletionPopupListBoxWithImagesItemToString Method
Returns a String that represents the item.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents the ListBoxWithImagesItem.
See Also

Reference

CodeCompletionPopupListBoxWithImagesItem Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ListBoxWithImagesItem Properties

ListBoxWithImagesItem Properties

The CodeCompletionPopupListBoxWithImagesItem type exposes the following members.

Properties
 | Name | Description
Public property | Documentation | Gets or sets SymbolDocumentation related to this item.
Public property | ImageIndex | Gets or sets the index value of the image displayed on this item.
Public property | Text | Gets or sets item text.
Top
See Also

Reference

CodeCompletionPopupListBoxWithImagesItem Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImagesItem.Documentation Property

CodeCompletionPopupListBoxWithImagesItemDocumentation Property
Gets or sets SymbolDocumentation related to this item.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Lazy<SymbolDocumentation> Documentation { get; set; }
Public Property Documentation As Lazy(Of SymbolDocumentation)
    Get
    Set
public:
property Lazy<SymbolDocumentation^>^ Documentation {
    Lazy<SymbolDocumentation^>^ get ();
    void set (Lazy<SymbolDocumentation^>^ value);
}
member Documentation : Lazy<SymbolDocumentation> with get, set

Property Value

Type: LazySymbolDocumentation
See Also

Reference

CodeCompletionPopupListBoxWithImagesItem Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImagesItem.ImageIndex Property

CodeCompletionPopupListBoxWithImagesItemImageIndex Property
Gets or sets the index value of the image displayed on this item.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ImageIndex { get; set; }
Public Property ImageIndex As Integer
    Get
    Set
public:
property int ImageIndex {
    int get ();
    void set (int value);
}
member ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

CodeCompletionPopupListBoxWithImagesItem Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopup.ListBoxWithImagesItem.Text Property

CodeCompletionPopupListBoxWithImagesItemText Property
Gets or sets item text.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

CodeCompletionPopupListBoxWithImagesItem Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopupConfiguration Class

CodeCompletionPopupConfiguration Class
Provides properties and methods to setup Code completion pop-up window behaviour.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionCodeCompletionPopupConfiguration

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionPopupConfiguration
Public Class CodeCompletionPopupConfiguration
public ref class CodeCompletionPopupConfiguration
type CodeCompletionPopupConfiguration =  class end

The CodeCompletionPopupConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionPopupConfiguration | Initializes a new instance of the CodeCompletionPopupConfiguration class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | GetImageListIndexFunc | Represents method to get image index accordingly to specified SymbolKind.
Public property | ImageList | Represents the ImageList that contains the images to display in Code completion pop-up window.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopupConfiguration Constructor

CodeCompletionPopupConfiguration Constructor
Initializes a new instance of the CodeCompletionPopupConfiguration class with specified settings.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionPopupConfiguration(
    ImageList imageList,
    Func<SymbolKind, int> getImageIndexFunc
)
Public Sub New (
    imageList As ImageList,
    getImageIndexFunc As Func(Of SymbolKind, Integer)
)
public:
CodeCompletionPopupConfiguration(
    ImageList^ imageList,
    Func<SymbolKind, int>^ getImageIndexFunc
)
new :
        imageList : ImageList *
        getImageIndexFunc : Func<SymbolKind, int> -> CodeCompletionPopupConfiguration

Parameters

imageList
Type: System.Windows.FormsImageList
ImageList related to pop-up window.
getImageIndexFunc
Type: SystemFuncSymbolKind, Int32
Method to get image index accordingly to specified SymbolKind.
See Also

Reference

CodeCompletionPopupConfiguration Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopupConfiguration Methods

CodeCompletionPopupConfiguration Methods

The CodeCompletionPopupConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeCompletionPopupConfiguration Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopupConfiguration Properties

CodeCompletionPopupConfiguration Properties

The CodeCompletionPopupConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | GetImageListIndexFunc | Represents method to get image index accordingly to specified SymbolKind.
Public property | ImageList | Represents the ImageList that contains the images to display in Code completion pop-up window.
Top
See Also

Reference

CodeCompletionPopupConfiguration Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopupConfiguration.GetImageListIndexFunc Property

CodeCompletionPopupConfigurationGetImageListIndexFunc Property
Represents method to get image index accordingly to specified SymbolKind.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Func<SymbolKind, int> GetImageListIndexFunc { get; }
Public ReadOnly Property GetImageListIndexFunc As Func(Of SymbolKind, Integer)
    Get
public:
property Func<SymbolKind, int>^ GetImageListIndexFunc {
    Func<SymbolKind, int>^ get ();
}
member GetImageListIndexFunc : Func<SymbolKind, int> with get

Property Value

Type: FuncSymbolKind, Int32
See Also

Reference

CodeCompletionPopupConfiguration Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CodeCompletionPopupConfiguration.ImageList Property

CodeCompletionPopupConfigurationImageList Property
Represents the ImageList that contains the images to display in Code completion pop-up window.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageList ImageList { get; }
Public ReadOnly Property ImageList As ImageList
    Get
public:
property ImageList^ ImageList {
    ImageList^ get ();
}
member ImageList : ImageList with get

Property Value

Type: ImageList
See Also

Reference

CodeCompletionPopupConfiguration Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CollectionSetterCache(T) Class

CollectionSetterCacheT Class
Helps to avoid redundant SetItems operations when the items set previously are the same.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionCollectionSetterCacheT

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CollectionSetterCache<T>

Public Class CollectionSetterCache(Of T)
generic<typename T>
public ref class CollectionSetterCache
type CollectionSetterCache<'T> =  class end

Type Parameters

T

The CollectionSetterCacheT type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionSetterCacheT | Initializes a new instance of the CollectionSetterCache class with specified parameters.
Top
Methods
 | Name | Description
Public method | Clear | Clears items hash.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetItems | Sets new item collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CollectionSetterCache(T) Constructor

CollectionSetterCacheT Constructor
Initializes a new instance of the CollectionSetterCache class with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CollectionSetterCache(
    Action<IEnumerable<T>> setItemsCore,
    Func<T, int> getItemHashCodeFunc
)
Public Sub New (
    setItemsCore As Action(Of IEnumerable(Of T)),
    getItemHashCodeFunc As Func(Of T, Integer)
)
public:
CollectionSetterCache(
    Action<IEnumerable<T>^>^ setItemsCore,
    Func<T, int>^ getItemHashCodeFunc
)
new :
        setItemsCore : Action<IEnumerable<'T>> *
        getItemHashCodeFunc : Func<'T, int> -> CollectionSetterCache

Parameters

setItemsCore
Type: SystemActionIEnumerableT
Specifies core method to set new item.
getItemHashCodeFunc
Type: SystemFuncT, Int32
Specifies method to handle items hash.
See Also

Reference

CollectionSetterCacheT Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CollectionSetterCache(T) Methods

CollectionSetterCacheT Methods

The CollectionSetterCacheT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears items hash.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetItems | Sets new item collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CollectionSetterCacheT Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CollectionSetterCache(T).Clear Method

CollectionSetterCacheTClear Method
Clears items hash.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

CollectionSetterCacheT Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


CollectionSetterCache(T).SetItems Method

CollectionSetterCacheTSetItems Method
Sets new item collection.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetItems(
    ICollection<T> items
)
Public Sub SetItems (
    items As ICollection(Of T)
)
public:
void SetItems(
    ICollection<T>^ items
)
member SetItems :
        items : ICollection<'T> -> unit

Parameters

items
Type: System.Collections.GenericICollectionT
List of items to set.
See Also

Reference

CollectionSetterCacheT Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


EvaluationCodeCompletionControllerBase Class

EvaluationCodeCompletionControllerBase Class
Provides a base class for evaluation controller. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionEvaluationCodeCompletionControllerBase

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class EvaluationCodeCompletionControllerBase : IDisposable
Public MustInherit Class EvaluationCodeCompletionControllerBase
    Implements IDisposable
public ref class EvaluationCodeCompletionControllerBase abstract : IDisposable
[<AbstractClassAttribute>]
type EvaluationCodeCompletionControllerBase =
    class
        interface IDisposable
    end

The EvaluationCodeCompletionControllerBase type exposes the following members.

Constructors
 | Name | Description
Public method | EvaluationCodeCompletionControllerBase | Initializes a new instance of the EvaluationCodeCompletionControllerBase class with specified parameters.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


EvaluationCodeCompletionControllerBase Constructor

EvaluationCodeCompletionControllerBase Constructor
Initializes a new instance of the EvaluationCodeCompletionControllerBase class with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EvaluationCodeCompletionControllerBase(
    EvaluationCodeCompletionControllerBaseISite site,
    IScriptDebuggerBase debugger
)
Public Sub New (
    site As EvaluationCodeCompletionControllerBaseISite,
    debugger As IScriptDebuggerBase
)
public:
EvaluationCodeCompletionControllerBase(
    EvaluationCodeCompletionControllerBaseISite^ site,
    IScriptDebuggerBase^ debugger
)
new :
        site : EvaluationCodeCompletionControllerBaseISite *
        debugger : IScriptDebuggerBase -> EvaluationCodeCompletionControllerBase

Parameters

site
Type: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionEvaluationCodeCompletionControllerBaseISite
ISite corresponding to this new instance.
debugger
Type: Alternet.Scripter.DebuggerIScriptDebuggerBase
IScriptDebuggerBase corresponding to this new instance.
See Also

Reference

EvaluationCodeCompletionControllerBase Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


EvaluationCodeCompletionControllerBase Methods

EvaluationCodeCompletionControllerBase Methods

The EvaluationCodeCompletionControllerBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EvaluationCodeCompletionControllerBase Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


EvaluationCodeCompletionControllerBase.Dispose Method

EvaluationCodeCompletionControllerBaseDispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

EvaluationCodeCompletionControllerBase Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


EvaluationCodeCompletionControllerBase.ISite Interface

EvaluationCodeCompletionControllerBaseISite Interface
Represents methods declaration to support evaluation functionality.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISite
Public Interface ISite
public interface class ISite
type ISite =  interface end

The EvaluationCodeCompletionControllerBaseISite type exposes the following members.

Methods
 | Name | Description
Public method | Close | When implemented by a class, closes evaluation controller.
Public method | EvaluateCurrentExpressionAsync | When implemented by a class, evaluates current expression.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ISite Methods

ISite Methods

The EvaluationCodeCompletionControllerBaseISite type exposes the following members.

Methods
 | Name | Description
Public method | Close | When implemented by a class, closes evaluation controller.
Public method | EvaluateCurrentExpressionAsync | When implemented by a class, evaluates current expression.
Top
See Also

Reference

EvaluationCodeCompletionControllerBaseISite Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


EvaluationCodeCompletionControllerBase.ISite.Close Method

EvaluationCodeCompletionControllerBaseISiteClose Method
When implemented by a class, closes evaluation controller.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Close()
Sub Close
void Close()
abstract Close : unit -> unit
See Also

Reference

EvaluationCodeCompletionControllerBaseISite Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


EvaluationCodeCompletionControllerBase.ISite.EvaluateCurrentExpressionAsync Method

EvaluationCodeCompletionControllerBaseISiteEvaluateCurrentExpressionAsync Method
When implemented by a class, evaluates current expression.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task EvaluateCurrentExpressionAsync()
Function EvaluateCurrentExpressionAsync As Task
Task^ EvaluateCurrentExpressionAsync()
abstract EvaluateCurrentExpressionAsync : unit -> Task

Return Value

Type: Task
See Also

Reference

EvaluationCodeCompletionControllerBaseISite Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup Interface

ICodeCompletionPopup Interface
Represents a pop-up window for Code Completion controller.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionPopup
Public Interface ICodeCompletionPopup
public interface class ICodeCompletionPopup
type ICodeCompletionPopup =  interface end

The ICodeCompletionPopup type exposes the following members.

Methods
 | Name | Description
Public method | ChangeSelection | When implemented by a class, changes selection accordingly to specified command.
Public method | Close | When implemented by a class, closes pop-up control.
Public method | GetItems | When implemented by a class, represents list of items in a string form.
Public method | GetSelectedItem | When implemented by a class, finds out currently selected item in the pop-up window.
Public method | SetItems | When implemented by a class, updates Symbol collection to the pop-up control.
Public method | Show | When implemented by a class, displays popup window with specified parameters.
Top
Properties
 | Name | Description
Public property | Visible | When implemented by a class, indicates whether pop-up window is visible.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup Methods

ICodeCompletionPopup Methods

The ICodeCompletionPopup type exposes the following members.

Methods
 | Name | Description
Public method | ChangeSelection | When implemented by a class, changes selection accordingly to specified command.
Public method | Close | When implemented by a class, closes pop-up control.
Public method | GetItems | When implemented by a class, represents list of items in a string form.
Public method | GetSelectedItem | When implemented by a class, finds out currently selected item in the pop-up window.
Public method | SetItems | When implemented by a class, updates Symbol collection to the pop-up control.
Public method | Show | When implemented by a class, displays popup window with specified parameters.
Top
See Also

Reference

ICodeCompletionPopup Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup.ChangeSelection Method

ICodeCompletionPopupChangeSelection Method
When implemented by a class, changes selection accordingly to specified command.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ChangeSelection(
    ChangePopupSelectionCommand command
)
Sub ChangeSelection (
    command As ChangePopupSelectionCommand
)
void ChangeSelection(
    ChangePopupSelectionCommand command
)
abstract ChangeSelection :
        command : ChangePopupSelectionCommand -> unit

Parameters

command
Type: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionChangePopupSelectionCommand
Specifies selection command.
See Also

Reference

ICodeCompletionPopup Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup.Close Method

ICodeCompletionPopupClose Method
When implemented by a class, closes pop-up control.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Close()
Sub Close
void Close()
abstract Close : unit -> unit
See Also

Reference

ICodeCompletionPopup Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup.GetItems Method

ICodeCompletionPopupGetItems Method
When implemented by a class, represents list of items in a string form.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> GetItems()
Function GetItems As IEnumerable(Of String)
IEnumerable<String^>^ GetItems()
abstract GetItems : unit -> IEnumerable<string>

Return Value

Type: IEnumerableString
List of items.
See Also

Reference

ICodeCompletionPopup Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup.GetSelectedItem Method

ICodeCompletionPopupGetSelectedItem Method
When implemented by a class, finds out currently selected item in the pop-up window.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetSelectedItem()
Function GetSelectedItem As String
String^ GetSelectedItem()
abstract GetSelectedItem : unit -> string

Return Value

Type: String
Selected item in a string form.
See Also

Reference

ICodeCompletionPopup Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup.SetItems Method

ICodeCompletionPopupSetItems Method
When implemented by a class, updates Symbol collection to the pop-up control.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetItems(
    IEnumerable<Symbol> items
)
Sub SetItems (
    items As IEnumerable(Of Symbol)
)
void SetItems(
    IEnumerable<Symbol^>^ items
)
abstract SetItems :
        items : IEnumerable<Symbol> -> unit

Parameters

items
Type: System.Collections.GenericIEnumerableSymbol
List of Symbol to be set.
See Also

Reference

ICodeCompletionPopup Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup.Show Method

ICodeCompletionPopupShow Method
When implemented by a class, displays popup window with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Show(
    Control ownerControl,
    Point position
)
Sub Show (
    ownerControl As Control,
    position As Point
)
void Show(
    Control^ ownerControl,
    Point position
)
abstract Show :
        ownerControl : Control *
        position : Point -> unit

Parameters

ownerControl
Type: System.Windows.FormsControl
The control that is the reference point for the pop-up position.
position
Type: System.DrawingPoint
The horizontal and vertical location of the reference control's upper-left corner, in pixels.
See Also

Reference

ICodeCompletionPopup Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup Properties

ICodeCompletionPopup Properties

The ICodeCompletionPopup type exposes the following members.

Properties
 | Name | Description
Public property | Visible | When implemented by a class, indicates whether pop-up window is visible.
Top
See Also

Reference

ICodeCompletionPopup Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ICodeCompletionPopup.Visible Property

ICodeCompletionPopupVisible Property
When implemented by a class, indicates whether pop-up window is visible.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; }
ReadOnly Property Visible As Boolean
    Get
property bool Visible {
    bool get ();
}
abstract Visible : bool with get

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionPopup Interface
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ParameterInfoSymbol Class

ParameterInfoSymbol Class
Represents data for the parameter info.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionParameterInfoSymbol

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterInfoSymbol
Public Class ParameterInfoSymbol
public ref class ParameterInfoSymbol
type ParameterInfoSymbol =  class end

The ParameterInfoSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterInfoSymbol | Initializes a new instance of the ParameterInfoSymbol class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CurrentSymbolIndex | Gets index of current symbol.
Public property | DisplayText | Gets formatted string contained parameter data.
Public property | ParameterDescription | Gets description of the parameter.
Public property | SymbolDescription | Gets description of the current symbol.
Public property | SymbolsCount | Gets number of the symbols in the parameter info.
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ParameterInfoSymbol Constructor

ParameterInfoSymbol Constructor
Initializes a new instance of the ParameterInfoSymbol class with specified parameters.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfoSymbol(
    string displayText,
    string symbolDescription,
    string parameterDescription,
    int currentSymbolIndex,
    int symbolsCount
)
Public Sub New (
    displayText As String,
    symbolDescription As String,
    parameterDescription As String,
    currentSymbolIndex As Integer,
    symbolsCount As Integer
)
public:
ParameterInfoSymbol(
    String^ displayText,
    String^ symbolDescription,
    String^ parameterDescription,
    int currentSymbolIndex,
    int symbolsCount
)
new :
        displayText : string *
        symbolDescription : string *
        parameterDescription : string *
        currentSymbolIndex : int *
        symbolsCount : int -> ParameterInfoSymbol

Parameters

displayText
Type: SystemString
Formatted string contained parameter data.
symbolDescription
Type: SystemString
Description of the current symbol.
parameterDescription
Type: SystemString
Description of the parameter
currentSymbolIndex
Type: SystemInt32
Index of current symbol.
symbolsCount
Type: SystemInt32
Number of the symbols in the parameter info.
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ParameterInfoSymbol Methods

ParameterInfoSymbol Methods

The ParameterInfoSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ParameterInfoSymbol Properties

ParameterInfoSymbol Properties

The ParameterInfoSymbol type exposes the following members.

Properties
 | Name | Description
Public property | CurrentSymbolIndex | Gets index of current symbol.
Public property | DisplayText | Gets formatted string contained parameter data.
Public property | ParameterDescription | Gets description of the parameter.
Public property | SymbolDescription | Gets description of the current symbol.
Public property | SymbolsCount | Gets number of the symbols in the parameter info.
Top
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ParameterInfoSymbol.CurrentSymbolIndex Property

ParameterInfoSymbolCurrentSymbolIndex Property
Gets index of current symbol.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CurrentSymbolIndex { get; }
Public ReadOnly Property CurrentSymbolIndex As Integer
    Get
public:
property int CurrentSymbolIndex {
    int get ();
}
member CurrentSymbolIndex : int with get

Property Value

Type: Int32
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ParameterInfoSymbol.DisplayText Property

ParameterInfoSymbolDisplayText Property
Gets formatted string contained parameter data.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DisplayText { get; }
Public ReadOnly Property DisplayText As String
    Get
public:
property String^ DisplayText {
    String^ get ();
}
member DisplayText : string with get

Property Value

Type: String
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ParameterInfoSymbol.ParameterDescription Property

ParameterInfoSymbolParameterDescription Property
Gets description of the parameter.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ParameterDescription { get; }
Public ReadOnly Property ParameterDescription As String
    Get
public:
property String^ ParameterDescription {
    String^ get ();
}
member ParameterDescription : string with get

Property Value

Type: String
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ParameterInfoSymbol.SymbolDescription Property

ParameterInfoSymbolSymbolDescription Property
Gets description of the current symbol.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SymbolDescription { get; }
Public ReadOnly Property SymbolDescription As String
    Get
public:
property String^ SymbolDescription {
    String^ get ();
}
member SymbolDescription : string with get

Property Value

Type: String
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


ParameterInfoSymbol.SymbolsCount Property

ParameterInfoSymbolSymbolsCount Property
Gets number of the symbols in the parameter info.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SymbolsCount { get; }
Public ReadOnly Property SymbolsCount As Integer
    Get
public:
property int SymbolsCount {
    int get ();
}
member SymbolsCount : int with get

Property Value

Type: Int32
See Also

Reference

ParameterInfoSymbol Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup Class

Popup Class
Represents a pop-up window.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsToolStrip
System.Windows.FormsToolStripDropDown
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionPopup
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionCodeCompletionPopup

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Popup : ToolStripDropDown
Public Class Popup
    Inherits ToolStripDropDown
public ref class Popup : public ToolStripDropDown
type Popup =
    class
        inherit ToolStripDropDown
    end

The Popup type exposes the following members.

Constructors
 | Name | Description
Public method | Popup | Initializes a new instance of the Popup class.
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the ToolStripDropDown control. (Inherited from ToolStripDropDown.)
Public method | Close(ToolStripDropDownCloseReason) | Closes the ToolStripDropDown control for the specified reason. (Inherited from ToolStripDropDown.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
Public method | GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PaintSizeGrip | Paints the sizing grip.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | ProcessResizing | Processes the resizing messages.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the ToolStripDropDown control in its default position. (Inherited from ToolStripDropDown.)
Public method | Show(Point) | Positions the ToolStripDropDown relative to the specified screen location. (Inherited from ToolStripDropDown.)
Public method | Show(Rectangle) | Shows the pop-up window below the specified area.
Public method | Show(Control) | Shows the pop-up window below the specified control.
Public method | Show(Control, Point) | Positions the ToolStripDropDown relative to the specified control location. (Inherited from ToolStripDropDown.)
Public method | Show(Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Int32, Int32) | Positions the ToolStripDropDown relative to the specified screen coordinates. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Rectangle) | Shows the pop-up window below the specified area of the specified control.
Public method | Show(Control, Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control at the specified location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Int32, Int32) | Positions the ToolStripDropDown relative to the specified control's horizontal and vertical screen coordinates. (Inherited from ToolStripDropDown.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the ToolStrip control. (Inherited from ToolStrip.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AcceptAlt | Gets or sets a value indicating whether pressing the alt key should close the pop-up.
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
Public property | AllowItemReorder | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
Public property | AllowTransparency | Gets or sets a value indicating whether the Opacity of the form can be adjusted. (Inherited from ToolStripDropDown.)
Public property | Anchor | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AnimationDuration | Determines the duration of the animation.
Public property | AutoClose | Gets or sets a value indicating whether the ToolStripDropDown control should automatically close when it has lost activation. (Inherited from ToolStripDropDown.)
Public property | AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoSize | Gets or sets a value indicating whether the ToolStripDropDown automatically adjusts its size when the form is resized. (Inherited from ToolStripDropDown.)
Public property | BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanOverflow | Gets or sets a value indicating whether the items in a ToolStripDropDown can be sent to an overflow menu. (Inherited from ToolStripDropDown.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content of the pop-up.
Public property | ContextMenu | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | ContextMenuStrip | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultDropDownDirection | Gets or sets the direction in which the ToolStripDropDown is displayed relative to the ToolStrip. (Inherited from ToolStripDropDown.)
Public property | DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DropShadowEnabled | Gets or sets a value indicating whether a three-dimensional shadow effect appears when the ToolStripDropDown is displayed. (Inherited from ToolStripDropDown.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusOnOpen | Gets or sets a value indicating whether the content should receive the focus after the pop-up has been opened.
Public property | Font | Gets or sets the font of the text displayed on the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
Public property | GripDisplayStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripMargin | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripRectangle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HidingAnimation | Determines which animation to use while hiding the pop-up window.
Public property | HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
Public property | ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsAutoGenerated | Gets a value indicating whether this ToolStripDropDown was automatically generated. (Inherited from ToolStripDropDown.)
Public property | IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
Public property | LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
Public property | LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
Public property | LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets a maximum size of the pop-up.
Public property | MinimumSize | Gets or sets a minimum size of the pop-up.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NonInteractive | Gets or sets a value indicating whether the Popup acts like a transparent windows (so it cannot be clicked).
Public property | Opacity | Determines the opacity of the form. (Inherited from ToolStripDropDown.)
Public property | Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
Public property | OverflowButton | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | OwnerItem | Gets or sets the ToolStripItem that is the owner of this ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
Public property | RenderMode | Gets or sets a value that indicates which visual styles will be applied to the ToolStrip. (Inherited from ToolStrip.)
Public property | Resizable | Gets or sets a value indicating whether the Popup is resizable.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | (Inherited from ToolStripDropDown.)
Public property | ShowingAnimation | Determines which animation to use while showing the pop-up window.
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Stretch | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabIndex | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextDirection | Specifies the direction in which to draw the text on the item. (Inherited from ToolStripDropDown.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether the ToolStripDropDown is a top-level control. (Inherited from ToolStripDropDown.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Visible | Gets or sets a value indicating whether the ToolStripDropDown is visible or hidden. (Inherited from ToolStripDropDown.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from ToolStripDropDown.)
Public event | CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from ToolStripDropDown.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the ToolStripDropDown is closed. (Inherited from ToolStripDropDown.)
Public event | Closing | Occurs when the ToolStripDropDown control is about to close. (Inherited from ToolStripDropDown.)
Public event | ContextMenuChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ContextMenuStripChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Public event | Enter | Occurs when the focus enters the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public event | FontChanged | Occurs when the value of the Font property changes. (Inherited from ToolStripDropDown.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStripDropDown.)
Public event | GiveFeedback | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from ToolStripDropDown.)
Public event | ImeModeChanged | Occurs when the ImeModeChanged property has changed. (Inherited from ToolStripDropDown.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
Public event | ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | KeyDown | Occurs when a key is pressed and held down while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyPress | Occurs when a key is pressed while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from ToolStripDropDown.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
Public event | LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from ToolStripDropDown.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | Opened | Occurs when the ToolStripDropDown is opened. (Inherited from ToolStripDropDown.)
Public event | Opening | Occurs when the ToolStripDropDown control is opening. (Inherited from ToolStripDropDown.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from ToolStripDropDown.)
Public event | RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the ToolStripLayoutStyle style changes. (Inherited from ToolStripDropDown.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | TabStopChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | TextChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validated | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validating | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup Constructor

Popup Constructor
Initializes a new instance of the Popup class.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Popup(
    Control content
)
Public Sub New (
    content As Control
)
public:
Popup(
    Control^ content
)
new :
        content : Control -> Popup

Parameters

content
Type: System.Windows.FormsControl
The content of the pop-up.
Exceptions
Exception Condition
ArgumentNullException content is
Copy
null
.
Remarks
Pop-up will be disposed immediately after disposal of the content control.
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup Methods

Popup Methods

The Popup type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the ToolStripDropDown control. (Inherited from ToolStripDropDown.)
Public method | Close(ToolStripDropDownCloseReason) | Closes the ToolStripDropDown control for the specified reason. (Inherited from ToolStripDropDown.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItemAt(Point) | Returns the item located at the specified point in the client area of the ToolStrip. (Inherited from ToolStrip.)
Public method | GetItemAt(Int32, Int32) | Returns the item located at the specified x- and y-coordinates of the ToolStrip client area. (Inherited from ToolStrip.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNextItem | Retrieves the next ToolStripItem from the specified reference point and moving in the specified direction. (Inherited from ToolStrip.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PaintSizeGrip | Paints the sizing grip.
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | ProcessResizing | Processes the resizing messages.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetMinimumSize | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | This method is not relevant for this class. (Inherited from ToolStrip.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the ToolStripDropDown control in its default position. (Inherited from ToolStripDropDown.)
Public method | Show(Point) | Positions the ToolStripDropDown relative to the specified screen location. (Inherited from ToolStripDropDown.)
Public method | Show(Rectangle) | Shows the pop-up window below the specified area.
Public method | Show(Control) | Shows the pop-up window below the specified control.
Public method | Show(Control, Point) | Positions the ToolStripDropDown relative to the specified control location. (Inherited from ToolStripDropDown.)
Public method | Show(Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Int32, Int32) | Positions the ToolStripDropDown relative to the specified screen coordinates. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Rectangle) | Shows the pop-up window below the specified area of the specified control.
Public method | Show(Control, Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control at the specified location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Int32, Int32) | Positions the ToolStripDropDown relative to the specified control's horizontal and vertical screen coordinates. (Inherited from ToolStripDropDown.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the ToolStrip control. (Inherited from ToolStrip.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.PaintSizeGrip Method

PopupPaintSizeGrip Method
Paints the sizing grip.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PaintSizeGrip(
    PaintEventArgs e
)
Public Sub PaintSizeGrip (
    e As PaintEventArgs
)
public:
void PaintSizeGrip(
    PaintEventArgs^ e
)
member PaintSizeGrip :
        e : PaintEventArgs -> unit

Parameters

e
Type: System.Windows.FormsPaintEventArgs
The PaintEventArgs instance containing the event data.
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.ProcessResizing Method

PopupProcessResizing Method
Processes the resizing messages.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ProcessResizing(
    ref Message m
)
Public Function ProcessResizing (
    ByRef m As Message
) As Boolean
public:
bool ProcessResizing(
    Message% m
)
member ProcessResizing :
        m : Message byref -> bool

Parameters

m
Type: System.Windows.FormsMessage
The message.

Return Value

Type: Boolean
true, if the WndProc method from the base class shouldn't be invoked.
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.Show Method

PopupShow Method
Overload List
 | Name | Description
Public method | Show | Displays the ToolStripDropDown control in its default position. (Inherited from ToolStripDropDown.)
Public method | Show(Point) | Positions the ToolStripDropDown relative to the specified screen location. (Inherited from ToolStripDropDown.)
Public method | Show(Rectangle) | Shows the pop-up window below the specified area.
Public method | Show(Control) | Shows the pop-up window below the specified control.
Public method | Show(Control, Point) | Positions the ToolStripDropDown relative to the specified control location. (Inherited from ToolStripDropDown.)
Public method | Show(Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Int32, Int32) | Positions the ToolStripDropDown relative to the specified screen coordinates. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Rectangle) | Shows the pop-up window below the specified area of the specified control.
Public method | Show(Control, Point, ToolStripDropDownDirection) | Positions the ToolStripDropDown relative to the specified control at the specified location and with the specified direction relative to the parent control. (Inherited from ToolStripDropDown.)
Public method | Show(Control, Int32, Int32) | Positions the ToolStripDropDown relative to the specified control's horizontal and vertical screen coordinates. (Inherited from ToolStripDropDown.)
Top
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.Show Method (Rectangle)

PopupShow Method (Rectangle)
Shows the pop-up window below the specified area.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Show(
    Rectangle area
)
Public Sub Show (
    area As Rectangle
)
public:
void Show(
    Rectangle area
)
member Show :
        area : Rectangle -> unit

Parameters

area
Type: System.DrawingRectangle
The area of desktop below which the pop-up will be shown.
Remarks
When there is no space below specified area, the pop-up control is shown above it.
See Also

Reference

Popup Class
Show Overload
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.Show Method (Control)

PopupShow Method (Control)
Shows the pop-up window below the specified control.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Show(
    Control control
)
Public Sub Show (
    control As Control
)
public:
void Show(
    Control^ control
)
member Show :
        control : Control -> unit

Parameters

control
Type: System.Windows.FormsControl
The control below which the pop-up will be shown.
Exceptions
Exception Condition
ArgumentNullException control is
Copy
null
.
Remarks
When there is no space below the specified control, the pop-up control is shown above it.
See Also

Reference

Popup Class
Show Overload
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.Show Method (Control, Rectangle)

PopupShow Method (Control, Rectangle)
Shows the pop-up window below the specified area of the specified control.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Show(
    Control control,
    Rectangle area
)
Public Sub Show (
    control As Control,
    area As Rectangle
)
public:
void Show(
    Control^ control,
    Rectangle area
)
member Show :
        control : Control *
        area : Rectangle -> unit

Parameters

control
Type: System.Windows.FormsControl
The control used to compute screen location of specified area.
area
Type: System.DrawingRectangle
The area of control below which the pop-up will be shown.
Exceptions
Exception Condition
ArgumentNullException control is
Copy
null
.
Remarks
When there is no space below specified area, the pop-up control is shown above it.
See Also

Reference

Popup Class
Show Overload
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup Properties

Popup Properties

The Popup type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAlt | Gets or sets a value indicating whether pressing the alt key should close the pop-up.
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether drag-and-drop and item reordering are handled through events that you implement. (Inherited from ToolStrip.)
Public property | AllowItemReorder | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AllowMerge | Gets or sets a value indicating whether multiple MenuStrip, ToolStripDropDownMenu, ToolStripMenuItem, and other types can be combined. (Inherited from ToolStrip.)
Public property | AllowTransparency | Gets or sets a value indicating whether the Opacity of the form can be adjusted. (Inherited from ToolStripDropDown.)
Public property | Anchor | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | AnimationDuration | Determines the duration of the animation.
Public property | AutoClose | Gets or sets a value indicating whether the ToolStripDropDown control should automatically close when it has lost activation. (Inherited from ToolStripDropDown.)
Public property | AutoScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMargin | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollMinSize | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | AutoSize | Gets or sets a value indicating whether the ToolStripDropDown automatically adjusts its size when the form is resized. (Inherited from ToolStripDropDown.)
Public property | BackColor | Gets or sets the background color for the ToolStrip. (Inherited from ToolStrip.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the binding context for the ToolStrip. (Inherited from ToolStrip.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanOverflow | Gets or sets a value indicating whether the items in a ToolStripDropDown can be sent to an overflow menu. (Inherited from ToolStripDropDown.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the ToolStrip causes validation to be performed on any controls that require validation when it receives focus. (Inherited from ToolStrip.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | Content | Gets the content of the pop-up.
Public property | ContextMenu | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | ContextMenuStrip | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Controls | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the ToolStrip. (Inherited from ToolStrip.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DefaultDropDownDirection | Gets or sets the direction in which the ToolStripDropDown is displayed relative to the ToolStrip. (Inherited from ToolStripDropDown.)
Public property | DisplayRectangle | Retrieves the current display rectangle. (Inherited from ToolStrip.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DropShadowEnabled | Gets or sets a value indicating whether a three-dimensional shadow effect appears when the ToolStripDropDown is displayed. (Inherited from ToolStripDropDown.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusOnOpen | Gets or sets a value indicating whether the content should receive the focus after the pop-up has been opened.
Public property | Font | Gets or sets the font of the text displayed on the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | ForeColor | Gets or sets the foreground color of the ToolStrip. (Inherited from ToolStrip.)
Public property | GripDisplayStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripMargin | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripRectangle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | GripStyle | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HidingAnimation | Determines which animation to use while hiding the pop-up window.
Public property | HorizontalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | ImageList | Gets or sets the image list that contains the image displayed on a ToolStrip item. (Inherited from ToolStrip.)
Public property | ImageScalingSize | Gets or sets the size, in pixels, of an image used on a ToolStrip. (Inherited from ToolStrip.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsAutoGenerated | Gets a value indicating whether this ToolStripDropDown was automatically generated. (Inherited from ToolStripDropDown.)
Public property | IsCurrentlyDragging | Gets a value indicating whether the user is currently moving the ToolStrip from one ToolStripContainer to another. (Inherited from ToolStrip.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsDropDown | Gets a value indicating whether a ToolStrip is a ToolStripDropDown control. (Inherited from ToolStrip.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | Items | Gets all the items that belong to a ToolStrip. (Inherited from ToolStrip.)
Public property | LayoutEngine | Passes a reference to the cached LayoutEngine returned by the layout engine interface. (Inherited from ToolStrip.)
Public property | LayoutSettings | Gets or sets layout scheme characteristics. (Inherited from ToolStrip.)
Public property | LayoutStyle | Gets or sets a value indicating how the ToolStrip lays out the items collection. (Inherited from ToolStrip.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets a maximum size of the pop-up.
Public property | MinimumSize | Gets or sets a minimum size of the pop-up.
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NonInteractive | Gets or sets a value indicating whether the Popup acts like a transparent windows (so it cannot be clicked).
Public property | Opacity | Determines the opacity of the form. (Inherited from ToolStripDropDown.)
Public property | Orientation | Gets the orientation of the ToolStripPanel. (Inherited from ToolStrip.)
Public property | OverflowButton | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | OwnerItem | Gets or sets the ToolStripItem that is the owner of this ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public property | Renderer | Gets or sets a ToolStripRenderer used to customize the look and feel of a ToolStrip. (Inherited from ToolStrip.)
Public property | RenderMode | Gets or sets a value that indicates which visual styles will be applied to the ToolStrip. (Inherited from ToolStrip.)
Public property | Resizable | Gets or sets a value indicating whether the Popup is resizable.
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | (Inherited from ToolStripDropDown.)
Public property | ShowingAnimation | Determines which animation to use while showing the pop-up window.
Public property | ShowItemToolTips | Gets or sets a value indicating whether ToolTips are to be displayed on ToolStrip items. (Inherited from ToolStrip.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Stretch | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabIndex | This property is not relevant to this class. (Inherited from ToolStripDropDown.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to an item in the ToolStrip using the TAB key. (Inherited from ToolStrip.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Control.)
Public property | TextDirection | Specifies the direction in which to draw the text on the item. (Inherited from ToolStripDropDown.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether the ToolStripDropDown is a top-level control. (Inherited from ToolStripDropDown.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | This property is not relevant for this class. (Inherited from ToolStrip.)
Public property | Visible | Gets or sets a value indicating whether the ToolStripDropDown is visible or hidden. (Inherited from ToolStripDropDown.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.AcceptAlt Property

PopupAcceptAlt Property
Gets or sets a value indicating whether pressing the alt key should close the pop-up.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AcceptAlt { get; set; }
Public Property AcceptAlt As Boolean
    Get
    Set
public:
property bool AcceptAlt {
    bool get ();
    void set (bool value);
}
member AcceptAlt : bool with get, set

Property Value

Type: Boolean
true if pressing the alt key does not close the pop-up; otherwise, false.
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.AnimationDuration Property

PopupAnimationDuration Property
Determines the duration of the animation.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AnimationDuration { get; set; }
Public Property AnimationDuration As Integer
    Get
    Set
public:
property int AnimationDuration {
    int get ();
    void set (int value);
}
member AnimationDuration : int with get, set

Property Value

Type: Int32
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.Content Property

PopupContent Property
Gets the content of the pop-up.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Control Content { get; }
Public ReadOnly Property Content As Control
    Get
public:
property Control^ Content {
    Control^ get ();
}
member Content : Control with get

Property Value

Type: Control
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.FocusOnOpen Property

PopupFocusOnOpen Property
Gets or sets a value indicating whether the content should receive the focus after the pop-up has been opened.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FocusOnOpen { get; set; }
Public Property FocusOnOpen As Boolean
    Get
    Set
public:
property bool FocusOnOpen {
    bool get ();
    void set (bool value);
}
member FocusOnOpen : bool with get, set

Property Value

Type: Boolean
true if the content should be focused after the pop-up has been opened; otherwise, false.
Remarks
If the FocusOnOpen property is set to false, then pop-up cannot use the fade effect.
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.HidingAnimation Property

PopupHidingAnimation Property
Determines which animation to use while hiding the pop-up window.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PopupAnimations HidingAnimation { get; set; }
Public Property HidingAnimation As PopupAnimations
    Get
    Set
public:
property PopupAnimations HidingAnimation {
    PopupAnimations get ();
    void set (PopupAnimations value);
}
member HidingAnimation : PopupAnimations with get, set

Property Value

Type: PopupAnimations
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.MaximumSize Property

PopupMaximumSize Property
Gets or sets a maximum size of the pop-up.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Size MaximumSize { get; set; }
Public Property MaximumSize As Size
    Get
    Set
public:
property Size MaximumSize {
    Size get ();
    void set (Size value);
}
member MaximumSize : Size with get, set

Return Value

Type: Size
An ordered pair of type Size representing the width and height of a rectangle.
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.MinimumSize Property

PopupMinimumSize Property
Gets or sets a minimum size of the pop-up.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Size MinimumSize { get; set; }
Public Property MinimumSize As Size
    Get
    Set
public:
property Size MinimumSize {
    Size get ();
    void set (Size value);
}
member MinimumSize : Size with get, set

Return Value

Type: Size
An ordered pair of type Size representing the width and height of a rectangle.
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.NonInteractive Property

PopupNonInteractive Property
Gets or sets a value indicating whether the Popup acts like a transparent windows (so it cannot be clicked).

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NonInteractive { get; set; }
Public Property NonInteractive As Boolean
    Get
    Set
public:
property bool NonInteractive {
    bool get ();
    void set (bool value);
}
member NonInteractive : bool with get, set

Property Value

Type: Boolean
true if the popup is non interactive; otherwise, false.
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.Resizable Property

PopupResizable Property
Gets or sets a value indicating whether the Popup is resizable.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Resizable { get; set; }
Public Property Resizable As Boolean
    Get
    Set
public:
property bool Resizable {
    bool get ();
    void set (bool value);
}
member Resizable : bool with get, set

Property Value

Type: Boolean
true if resizable; otherwise, false.
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup.ShowingAnimation Property

PopupShowingAnimation Property
Determines which animation to use while showing the pop-up window.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PopupAnimations ShowingAnimation { get; set; }
Public Property ShowingAnimation As PopupAnimations
    Get
    Set
public:
property PopupAnimations ShowingAnimation {
    PopupAnimations get ();
    void set (PopupAnimations value);
}
member ShowingAnimation : PopupAnimations with get, set

Property Value

Type: PopupAnimations
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Popup Events

Popup Events

The Popup type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property has changed. (Inherited from ToolStrip.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from ToolStripDropDown.)
Public event | BeginDrag | Occurs when the user begins to drag the ToolStrip control. (Inherited from ToolStrip.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from ToolStripDropDown.)
Public event | CausesValidationChanged | Occurs when the CausesValidation property changes. (Inherited from ToolStrip.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from ToolStripDropDown.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the ToolStripDropDown is closed. (Inherited from ToolStripDropDown.)
Public event | Closing | Occurs when the ToolStripDropDown control is about to close. (Inherited from ToolStripDropDown.)
Public event | ContextMenuChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ContextMenuStripChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | ControlAdded | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | ControlRemoved | This event is not relevant for this class. (Inherited from ToolStrip.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from ToolStrip.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | EndDrag | Occurs when the user stops dragging the ToolStrip control. (Inherited from ToolStrip.)
Public event | Enter | Occurs when the focus enters the ToolStripDropDown. (Inherited from ToolStripDropDown.)
Public event | FontChanged | Occurs when the value of the Font property changes. (Inherited from ToolStripDropDown.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from ToolStripDropDown.)
Public event | GiveFeedback | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from ToolStripDropDown.)
Public event | ImeModeChanged | Occurs when the ImeModeChanged property has changed. (Inherited from ToolStripDropDown.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemAdded | Occurs when a new ToolStripItem is added to the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | ItemClicked | Occurs when the ToolStripItem is clicked. (Inherited from ToolStrip.)
Public event | ItemRemoved | Occurs when a ToolStripItem is removed from the ToolStripItemCollection. (Inherited from ToolStrip.)
Public event | KeyDown | Occurs when a key is pressed and held down while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyPress | Occurs when a key is pressed while the ToolStripDropDown has focus. (Inherited from ToolStripDropDown.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from ToolStripDropDown.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | LayoutCompleted | Occurs when the layout of the ToolStrip is complete. (Inherited from ToolStrip.)
Public event | LayoutStyleChanged | Occurs when the value of the LayoutStyle property changes. (Inherited from ToolStrip.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from ToolStripDropDown.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | Opened | Occurs when the ToolStripDropDown is opened. (Inherited from ToolStripDropDown.)
Public event | Opening | Occurs when the ToolStripDropDown control is opening. (Inherited from ToolStripDropDown.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintGrip | Occurs when the ToolStrip move handle is painted. (Inherited from ToolStrip.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from ToolStripDropDown.)
Public event | RendererChanged | Occurs when the value of the Renderer property changes. (Inherited from ToolStrip.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the ToolStripLayoutStyle style changes. (Inherited from ToolStripDropDown.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | This event is not relevant to this class. (Inherited from ToolStripDropDown.)
Public event | TabStopChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | TextChanged | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validated | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | Validating | This event is not relevant for this class. (Inherited from ToolStripDropDown.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Popup Class
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


PopupAnimations Enumeration

PopupAnimations Enumeration
Types of animation of the pop-up window.

Namespace: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion
Assembly: Alternet.Scripter.Debugger.UI.v7 (in Alternet.Scripter.Debugger.UI.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum PopupAnimations
<FlagsAttribute>
Public Enumeration PopupAnimations
[FlagsAttribute]
public enum class PopupAnimations
[<FlagsAttribute>]
type PopupAnimations
Members
Member name | Value | Description
None | 0 | Uses no animation.
LeftToRight | 1 | Animates the window from left to right. This flag can be used with roll or slide animation.
RightToLeft | 2 | Animates the window from right to left. This flag can be used with roll or slide animation.
TopToBottom | 4 | Animates the window from top to bottom. This flag can be used with roll or slide animation.
BottomToTop | 8 | Animates the window from bottom to top. This flag can be used with roll or slide animation.
Center | 16 | Makes the window appear to collapse inward if it is hiding or expand outward if the window is showing.
Slide | 262144 | Uses a slide animation.
Blend | 524288 | Uses a fade effect.
Roll | 1048576 | Uses a roll animation.
SystemDefault | 2097152 | Uses a default animation.
See Also

Reference

Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletion Namespace


Alternet.Scripter.Integration Namespace

Alternet.Scripter.Integration Namespace
Classes
 | Class | Description
Public class | DebugCodeEdit |
Public class | DebugCodeEditContainer |
Public class | DebugEditCommandExecutedEventArgs |
Public class | DebugEditRequestedEventArgs |
Public class | DebuggerPanelsTabControl |
Public class | DebuggerUIController |
Public class | EditorCodeCompletionController |
Public class | EditorCodeCompletionControllerCodeCompletionBox |
Public class | EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox |
Public class | EditorCodeCompletionControllerCodeCompletionHint |
Public class | EditorCodeCompletionControllerCodeCompletionPopup |
Public class | EditorCodeCompletionControllerParameterInfoToolTip |
Interfaces
 | Interface | Description
Public interface | IDebugEdit | Represents a text box with extended features for script debugging of the source code.
Public interface | IDebugEditContainer |
Public interface | IDebuggerPanels |
Enumerations
 | Enumeration | Description
Public enumeration | AllowedActions | Represents menu actions allowed by the editor.
Public enumeration | DebugEditCommand |
Public enumeration | DebuggerPanelKinds |


AllowedActions Enumeration

AllowedActions Enumeration
Represents menu actions allowed by the editor.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum AllowedActions
<FlagsAttribute>
Public Enumeration AllowedActions
[FlagsAttribute]
public enum class AllowedActions
[<FlagsAttribute>]
type AllowedActions
Members
Member name | Value | Description
None | 0 |
BreakpointToggle | 1 |
SetNextStatement | 2 |
GotoDefinition | 4 |
FindAllReferences | 8 |
FindAllImplementations | 16 |
See Also

Reference

Alternet.Scripter.Integration Namespace


DebugCodeEdit Class

DebugCodeEdit Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Alternet.EditorSyntaxEdit
Alternet.Editor.CommonScriptCodeEdit
Alternet.Scripter.IntegrationDebugCodeEdit

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebugCodeEdit : ScriptCodeEdit,
    IDebugEdit, IScriptEdit, IControl
Public Class DebugCodeEdit
    Inherits ScriptCodeEdit
    Implements IDebugEdit, IScriptEdit, IControl
public ref class DebugCodeEdit : public ScriptCodeEdit,
    IDebugEdit, IScriptEdit, IControl
type DebugCodeEdit =
    class
        inherit ScriptCodeEdit
        interface IDebugEdit
        interface IScriptEdit
        interface IControl
    end

The DebugCodeEdit type exposes the following members.

Constructors
 | Name | Description
Public method | DebugCodeEdit | Initializes a new instance of the DebugCodeEdit class
Top
Methods
Name | Description
Public method ApplyTheme
Applies visual theme to the SyntaxEdit control.
(Inherited from SyntaxEdit.)
Public method Assign
Assigns most relevant properties from another ISyntaxEdit object.
(Inherited from SyntaxEdit.)
Public method BeginInvoke(Delegate)
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginInvoke(Delegate, Object)
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginUpdate
Prevents editor updating until calling EndUpdate method.
(Inherited from SyntaxEdit.)
Public method BreakLine
Breaks current line into two lines.
(Inherited from SyntaxEdit.)
Public method | BreakpointDeleted
Public method | BreakpointStateChanged
Public method BringToFront
Brings the control to the front of the z-order.
(Inherited from Control.)
Public method CanFindNext
Indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindNextSelected
Indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindPrevious
Indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindPreviousSelected
Indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanSearchSelection
Returns whether search can be performed inside selection.
(Inherited from SyntaxEdit.)
Public method CanSplitHorz
Indicates whether control can split its content horizontally.
(Inherited from SyntaxEdit.)
Public method CanSplitVert
Indicates whether control can split its content vertically.
(Inherited from SyntaxEdit.)
Public method CanUnsplitHorz
Indicates whether control has horizontal split view.
(Inherited from SyntaxEdit.)
Public method CanUnsplitVert
Indicates whether control has vertical split view.
(Inherited from SyntaxEdit.)
Public method | ClearDebugStyles
Public method | ClearStackFrame
Public method CodeCompletion
Performs code completion for the specified text representing language element.
(Inherited from SyntaxEdit.)
Public method CodeCompletionWindowFocused
Indicates whether ICodeCompletionWindow has focus.
(Inherited from SyntaxEdit.)
Public method CodeSnippets
Displays a code completion window with list of available code snippets.
(Inherited from SyntaxEdit.)
Public method CompleteCodeFixes
Displays a code completion window with list of available code fixes.
(Inherited from SyntaxEdit.)
Public method CompleteCodeFixesOrRefactors
Displays a code completion window with list of available code fixes or code refactors.
(Inherited from SyntaxEdit.)
Public method CompleteCodeRefactors
Displays a code completion window with list of available code refactors.
(Inherited from SyntaxEdit.)
Public method CompleteWord
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box and locates single member, if possible.
(Inherited from SyntaxEdit.)
Public method Contains
Retrieves a value indicating whether the specified control is a child of the control.
(Inherited from Control.)
Public method | Copy | (Inherited from ScriptCodeEdit.)
Public method CreateCaret
Creates a new shape for the system caret and gets ownership of the caret.
(Inherited from SyntaxEdit.)
Public method CreateControl
Forces the creation of the visible control, including the creation of the handle and any visible child controls.
(Inherited from Control.)
Public method CreateGraphics
Creates the Graphics for the control.
(Inherited from Control.)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method | Cut | (Inherited from ScriptCodeEdit.)
Public method CycledSearch
Performs cycled search.
(Inherited from SyntaxEdit.)
Public method | Delete | (Inherited from ScriptCodeEdit.)
Public method DeleteBlock
Deletes a specified block of characters.
(Inherited from SyntaxEdit.)
Public method DeleteLeft
Deletes a specified number of characters to the left of the active point.
(Inherited from SyntaxEdit.)
Public method DeleteRight
Deletes a specified number of characters to the right of the active point.
(Inherited from SyntaxEdit.)
Public method | DeselectAll | (Inherited from ScriptCodeEdit.)
Public method DestroyCaret
Destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
(Inherited from SyntaxEdit.)
Public method DisablePositionUpdate
Prevents notification of changing of caret position until calling EnablePositionUpdate method.
(Inherited from SyntaxEdit.)
Public method DisableUpdate
Prevents editor updating until calling EnableUpdate method.
(Inherited from SyntaxEdit.)
Public method DisplayDragCaret
Displays dragging caret rather than regular caret.
(Inherited from SyntaxEdit.)
Public method DisplayGotoLineDialog
Initializes and runs a dialog prompting you for index of the line you need to locate.
(Inherited from SyntaxEdit.)
Public method DisplayGotoLineDialog(IWin32Window)
Initializes and runs a dialog prompting you for index of the line you need to locate.
(Inherited from SyntaxEdit.)
Public method DisplayModalReplaceDialog
Initializes and runs a modal dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayModalReplaceDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayModalSearchDialog
Initializes and runs a modal dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayModalSearchDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayReplaceDialog
Initializes and runs a dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayReplaceDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplaySearchDialog
Initializes and runs a dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplaySearchDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayToScreen(Int32, Int32)
Converts given display coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method DisplayToScreen(Int32, Int32, Boolean)
Converts given display coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method Dispose
Releases all resources used by the Component.
(Inherited from Component.)
Public method DoDragDrop
Begins a drag-and-drop operation.
(Inherited from Control.)
Public method DrawToBitmap
Supports rendering to the specified bitmap.
(Inherited from Control.)
Public method EnablePositionUpdate
Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
(Inherited from SyntaxEdit.)
Public method EnableUpdate
Re-enables editor updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from SyntaxEdit.)
Public method EndInvoke
Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
(Inherited from Control.)
Public method EndUpdate
Re-enables outline editor updating, that was turn of by calling BeginUpdate method.
(Inherited from SyntaxEdit.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method | ExecutionStopped
Public method Find(String)
Searches for given text within the control's contents.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions)
Searches for given text within the control's contents with specified options.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex)
Searches for given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, IListIRange)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, Boolean, Boolean)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, Point, Int32, Match)
Searches for given text within the control's text content.
(Inherited from SyntaxEdit.)
Public method FindForm
Retrieves the form that the control is on.
(Inherited from Control.)
Public method FindNext
Searches for the next occurrence of the text specified by previous search.
(Inherited from SyntaxEdit.)
Public method FindNextSelected
Searches for the next occurrence of the selected text.
(Inherited from SyntaxEdit.)
Public method FindPrevious
Searches for the previous occurrence of the text specified by previous search.
(Inherited from SyntaxEdit.)
Public method FindPreviousSelected
Searches for the previous occurrence of the selected text.
(Inherited from SyntaxEdit.)
Public method FinishIncrementalSearch
Leaves control from the incremental search state.
(Inherited from SyntaxEdit.)
Public method Focus
Sets input focus to the control.
(Inherited from Control.)
Public method GetCaretSize
Returns size of the caret's current shape at given position.
(Inherited from SyntaxEdit.)
Public method GetCharsInWidth
Returns number of characters painted with current font that will fit into specified Width.
(Inherited from SyntaxEdit.)
Public method GetChildAtPoint(Point)
Retrieves the child control that is located at the specified coordinates.
(Inherited from Control.)
Public method GetChildAtPoint(Point, GetChildAtPointSkip)
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
(Inherited from Control.)
Public method GetContainerControl
Returns the next ContainerControl up the control's chain of parent controls.
(Inherited from Control.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetHitTest(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTest(Int32, Int32, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTestAtTextPoint(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of control at specified text coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo)
Retrieves information about part of control at specified text coordinate.
(Inherited from SyntaxEdit.)
Public method GetIndentString
Gets indentation string at current position.
(Inherited from SyntaxEdit.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | GetLine | (Inherited from ScriptCodeEdit.)
Public method GetLinesInHeight
Determines how many lines can fit into given Height.
(Inherited from SyntaxEdit.)
Public method GetNextControl
Retrieves the next control forward or back in the tab order of child controls.
(Inherited from Control.)
Public method GetPreferredSize
Retrieves the size of a rectangular area into which a control can be fitted.
(Inherited from Control.)
Public method | GetSymbolAtCursor | (Inherited from ScriptCodeEdit.)
Public method GetTextAtCursor
Returns word at the cursor position.
(Inherited from SyntaxEdit.)
Public method GetTextToSearchAtCursor
Returns word at the cursor position.
(Inherited from SyntaxEdit.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetWordAt
Checks word accordingly to specified conditions.
(Inherited from SyntaxEdit.)
Public method GetWrapMargin
Returns position of the wrapping margin.
(Inherited from SyntaxEdit.)
Public method | GotoLine | (Inherited from ScriptCodeEdit.)
Public method HasAutoCorrection
Checks whether specified word has correction.
(Inherited from SyntaxEdit.)
Public method Hide
Conceals the control from the user.
(Inherited from Control.)
Public method HideDragCaret
Hides dragging caret.
(Inherited from SyntaxEdit.)
Public method HideScrollHint
Hides scroll hint window if necessary.
(Inherited from SyntaxEdit.)
Public method HighlightAll
Highlights all occurrences of specified string in the class text content.
(Inherited from SyntaxEdit.)
Public method IncrementalSearch
Finds given text incrementally.
(Inherited from SyntaxEdit.)
Public method IndentLine
Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
(Inherited from SyntaxEdit.)
Public method IndentLine(String, Boolean)
Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
(Inherited from SyntaxEdit.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method Insert
Inserts the given string at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean)
Inserts the given string at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean)
Inserts the given string array at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(ITextStrings, Boolean)
Inserts the given string collection at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertFromFile
Inserts the file text content at the specified location.
(Inherited from SyntaxEdit.)
Public method Invalidate
Invalidates the entire surface of the control and causes the control to be redrawn.
(Inherited from Control.)
Public method Invalidate(Region)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Boolean)
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Region, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invoke(Delegate)
Executes the specified delegate on the thread that owns the control's underlying window handle.
(Inherited from Control.)
Public method Invoke(Delegate, Object)
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
(Inherited from Control.)
Public method IsValidText
Indicates whether text at the specified position is valid (that is does not contain comments or string constants).
(Inherited from SyntaxEdit.)
Public method KillFocus
Ensure the caret is not visible.
(Inherited from SyntaxEdit.)
Public method LineIsHidden
Determines whether the given line is hidden.
(Inherited from SyntaxEdit.)
Public method LineIsReadonly
Determines whether the given line is readonly.
(Inherited from SyntaxEdit.)
Public method ListMembers
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box.
(Inherited from SyntaxEdit.)
Public method | LoadFile(String) | (Inherited from ScriptCodeEdit.)
Public method LoadFile(String, IStringImport)
Loads content from the given file with specified importer.
(Inherited from SyntaxEdit.)
Public method LoadFile(String, Encoding)
Loads the contents of the specified file with specified encoding.
(Inherited from SyntaxEdit.)
Public method LoadFile(String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.
(Inherited from SyntaxEdit.)
Public method LoadMacros(Stream)
Loads the macro records from the given stream.
(Inherited from SyntaxEdit.)
Public method LoadMacros(TextReader)
Loads the macro records from the given stream.
(Inherited from SyntaxEdit.)
Public method LoadMacros(String)
Loads the macro records from the given file.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(TextReader)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, IStringImport)
Loads the text content from the given stream with specified importer.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, Encoding)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(TextReader, IStringImport)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.
(Inherited from SyntaxEdit.)
Public method | Localize
Public method MakeVisible(Point)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
(Inherited from SyntaxEdit.)
Public method | MakeVisible(Point, Boolean) | (Overrides SyntaxEditMakeVisible(Point, Boolean).)
Public method MarkAll(String, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, SearchOptions, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, SearchOptions, Regex, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MoveCaretOnDrag
Moves caret to the position of drag cursor.
(Inherited from SyntaxEdit.)
Public method MoveCharLeft
Moves the current position one character to the left.
(Inherited from SyntaxEdit.)
Public method MoveCharRight
Moves the current position one character to the right.
(Inherited from SyntaxEdit.)
Public method MoveFileBegin
Moves the current position to the first character of the first line.
(Inherited from SyntaxEdit.)
Public method MoveFileEnd
Moves the current position to the last character of the last line.
(Inherited from SyntaxEdit.)
Public method MoveLineBegin
Moves the current position to the first character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineBeginCycled
Moves the current position to the first not whitespace character/first character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineDown
Moves the current position to the next line.
(Inherited from SyntaxEdit.)
Public method MoveLineEnd
Moves the current position to the last character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineEndCycled
Moves the current position to the last not whitespace character/last character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineUp
Moves the current position to the previous line.
(Inherited from SyntaxEdit.)
Public method MovePageDown
Moves current position to the next page.
(Inherited from SyntaxEdit.)
Public method MovePageUp
Moves current position to the previous page.
(Inherited from SyntaxEdit.)
Public method MoveScreenBottom
Moves the current position to the bottom of the screen.
(Inherited from SyntaxEdit.)
Public method MoveScreenTop
Moves the current position to the top of the screen.
(Inherited from SyntaxEdit.)
Public method MoveTo(Point)
Moves the current position to the given position.
(Inherited from SyntaxEdit.)
Public method MoveTo(Int32, Int32)
Moves the current position to the given position.
(Inherited from SyntaxEdit.)
Public method MoveToBrace
Moves the current position to the next open or close brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveToChar
Moves the current position to the specified character in current line.
(Inherited from SyntaxEdit.)
Public method MoveToCloseBrace
Moves the current position to the next close brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveToLine(Int32)
Moves the current position to the specified line.
(Inherited from SyntaxEdit.)
Public method MoveToLine(Int32, Int32)
Moves the current position to the specified line.
(Inherited from SyntaxEdit.)
Public method MoveToOpenBrace
Moves the current position to the previous open brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveWordLeft
Moves the current position one word to the left.
(Inherited from SyntaxEdit.)
Public method MoveWordRight
Moves the current position one word to the right.
(Inherited from SyntaxEdit.)
Public method Navigate
Moves current position by the given offset value.
(Inherited from SyntaxEdit.)
Public method NeedReplaceCurrent
Indicates whether search engine need to replace successfully found and selected text.
(Inherited from SyntaxEdit.)
Public method NeedReplaceCurrent(Match)
Indicates whether search engine need to replace successfully found and selected text.
(Inherited from SyntaxEdit.)
Public method NewLine
Inserts a line break at the current position.
(Inherited from SyntaxEdit.)
Public method NewLine(String, Boolean)
Inserts a line break at the current position with indentation
(Inherited from SyntaxEdit.)
Public method NewLineAbove
Inserts a line break above the current position.
(Inherited from SyntaxEdit.)
Public method NewLineBelow
Inserts a line break below the current position.
(Inherited from SyntaxEdit.)
Public method Notification
Updates control's content according to parameters of notification.
(Inherited from SyntaxEdit.)
Public method OnStateChanged
Updates control's content according to the state of the source.
(Inherited from SyntaxEdit.)
Public method OnTextFound
When implemented by a class, occurs when search text is found.
(Inherited from SyntaxEdit.)
Public method OutlineText
Forces automatic outlining by getting up-to-date information about outline section from the Parser.
(Inherited from SyntaxEdit.)
Public method ParameterInfo
Displays a code completion window containing information for the current method or parameter in the Editor's content.
(Inherited from SyntaxEdit.)
Public method | Paste | (Inherited from ScriptCodeEdit.)
Public method PauseMacroRecording
Suspends recording the command sequence.
(Inherited from SyntaxEdit.)
Public method PerformLayout
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PerformLayout(Control, String)
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PlayBackMacro
Repeats the stored command sequence.
(Inherited from SyntaxEdit.)
Public method PointToClient
Computes the location of the specified screen point into client coordinates.
(Inherited from Control.)
Public method PointToScreen
Computes the location of the specified client point into screen coordinates.
(Inherited from Control.)
Public method PositionIsReadonly
Determines whether the text at given position is readonly.
(Inherited from SyntaxEdit.)
Public method PreProcessControlMessage
Preprocesses keyboard or input messages within the message loop before they are dispatched.
(Inherited from Control.)
Public method PreProcessMessage
Preprocesses input messages within the message loop before they are dispatched.
(Inherited from SyntaxEdit.)
Public method | Print | (Inherited from ScriptCodeEdit.)
Public method | PrintPreview | (Inherited from ScriptCodeEdit.)
Public method ProcessEnter
Performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method ProcessKeyMsg
Processes a keyboard message.
(Inherited from SyntaxEdit.)
Public method ProcessKeyPress
Processes key press.
(Inherited from SyntaxEdit.)
Public method ProcessShiftTab
Performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method ProcessTab
Performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method QuickInfo
Displays a code completion window with simple tooltip information.
(Inherited from SyntaxEdit.)
Public method RecordKeyData
Adds keyData to the MacroRecords array.
(Inherited from SyntaxEdit.)
Public method RectangleToClient
Computes the size and location of the specified screen rectangle in client coordinates.
(Inherited from Control.)
Public method RectangleToScreen
Computes the size and location of the specified client rectangle in screen coordinates.
(Inherited from Control.)
Public method | Redo | (Inherited from ScriptCodeEdit.)
Public method Refresh
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
(Inherited from Control.)
Public method | Replace | (Inherited from ScriptCodeEdit.)
Public method Replace(String, String)
Searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method Replace(String, String, SearchOptions)
Searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method Replace(String, String, SearchOptions, Regex)
Searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Int32)
Replaces all occurrences of given text within text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceCurrent
Replaces currently selected text.
(Inherited from SyntaxEdit.)
Public method ResetAcceptReturns
Resets the AcceptReturns to the default value.
(Inherited from SyntaxEdit.)
Public method ResetAcceptTabs
Resets the AcceptTabs to the default value.
(Inherited from SyntaxEdit.)
Public method ResetBackColor
Resets the BackColor property to its default value.
(Inherited from Control.)
Public method ResetBindings
Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
(Inherited from Control.)
Public method ResetBorderColor
Resets the BorderColor to the default value.
(Inherited from SyntaxEdit.)
Public method ResetBorderStyle
Resets the BorderStyle to the default value.
(Inherited from SyntaxEdit.)
Public method ResetCursor
Resets the Cursor property to its default value.
(Inherited from SyntaxEdit.)
Public method ResetFont
Resets the Font property to its default value.
(Inherited from SyntaxEdit.)
Public method ResetForeColor
Resets the ForeColor property to its default value.
(Inherited from Control.)
Public method ResetHideCaret
Resets the HideCaret to the default value.
(Inherited from SyntaxEdit.)
Public method ResetImeMode
Resets the ImeMode property to its default value.
(Inherited from Control.)
Public method ResetIndentOptions
Resets the IndentOptions to the default value.
(Inherited from SyntaxEdit.)
Public method ResetKeepCaretOnLostFocus
Resets the KeepCaretOnLostFocus to the default value.
(Inherited from SyntaxEdit.)
Public method ResetLineSpace
Resets the LineSpace to the default value.
(Inherited from SyntaxEdit.)
Public method ResetMaxLength
Resets the MaxLength to the default value.
(Inherited from SyntaxEdit.)
Public method ResetModified
Resets the Modified to the default value.
(Inherited from SyntaxEdit.)
Public method ResetNavigateOptions
Resets the NavigateOptions to the default value.
(Inherited from SyntaxEdit.)
Public method ResetOverWrite
Resets the OverWrite to the default value.
(Inherited from SyntaxEdit.)
Public method ResetReadOnly
Resets the ReadOnly to the default value.
(Inherited from SyntaxEdit.)
Public method ResetRightToLeft
Resets the RightToLeft property to its default value.
(Inherited from Control.)
Public method ResetSingleLineMode
Resets the SingleLineMode to the default value.
(Inherited from SyntaxEdit.)
Public method ResetText
Resets the Text property to its default value.
(Inherited from Control.)
Public method ResetWordWrap
Resets the WordWrap to the default value.
(Inherited from SyntaxEdit.)
Public method ResetWrapAtMargin
Resets the WrapAtMargin to the default value.
(Inherited from SyntaxEdit.)
Public method RestorePosition
Restores position from stored position list by given index.
(Inherited from SyntaxEdit.)
Public method RestorePositionWithUndo
Restores position from stored position list by given index.
(Inherited from SyntaxEdit.)
Public method ResumeLayout
Resumes usual layout logic.
(Inherited from Control.)
Public method ResumeLayout(Boolean)
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.
(Inherited from Control.)
Public method ResumeMacroRecording
Resumes recording the command sequence.
(Inherited from SyntaxEdit.)
Public method | SaveFile(String) | (Inherited from ScriptCodeEdit.)
Public method SaveFile(String, IStringExport)
Saves content to the given file in the specific format.
(Inherited from SyntaxEdit.)
Public method SaveFile(String, Encoding)
Saves text content to the specific file with specific encoding.
(Inherited from SyntaxEdit.)
Public method SaveFile(String, IStringExport, Encoding)
Saves content to the given file in the specific format with specific encoding.
(Inherited from SyntaxEdit.)
Public method SaveMacros(Stream)
Saves the macro records to the given stream in xml format.
(Inherited from SyntaxEdit.)
Public method SaveMacros(TextWriter)
Saves the macro records to the given stream in xml format.
(Inherited from SyntaxEdit.)
Public method SaveMacros(String)
Saves the macro records to the given file in xml format.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream)
Saves content of the snippet to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(TextWriter)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, IStringExport)
Saves content to the specific stream in the specific format.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, Encoding)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(TextWriter, IStringExport)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, IStringExport, Encoding)
Saves content to the specific stream in the specific format and specific encoding.
(Inherited from SyntaxEdit.)
Public method Scale(Single) Obsolete.
Scales the control and any child controls.
(Inherited from Control.)
Public method Scale(SizeF)
Scales the control and all child controls by the specified scaling factor.
(Inherited from Control.)
Public method Scale(Single, Single) Obsolete.
Scales the entire control and any child controls.
(Inherited from Control.)
Public method ScreenToDisplay(Int32, Int32)
Converts given screen coordinates to display coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method | ScreenToDisplay(Int32, Int32, Boolean) | (Inherited from SyntaxEdit.)
Public method ScreenToDisplayX
When implemented by a class, converts given screen coordinates to display coordinate of a character.
(Inherited from SyntaxEdit.)
Public method ScreenToText(Point)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScreenToText(Int32, Int32)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScreenToText(Int32, Int32, Boolean)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScrollLineDown
Scrolls text content one line down.
(Inherited from SyntaxEdit.)
Public method ScrollLineUp
Scrolls text content one line up.
(Inherited from SyntaxEdit.)
Public method | Search | (Inherited from ScriptCodeEdit.)
Public method Select
Activates the control.
(Inherited from Control.)
Public method | SelectAll | (Inherited from ScriptCodeEdit.)
Public method SelectNextControl
Activates the next control.
(Inherited from Control.)
Public method SendToBack
Sends the control to the back of the z-order.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32)
Sets the bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified)
Sets the specified bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetNavigateOptions
Sets navigating options without validating position.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeBorderColor
Indicates whether the BorderColor property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeBorderStyle
Indicates whether the BorderStyle property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeCodeCompletionChars
Indicates whether the CodeCompletionChars property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeCursor
Indicates whether the Cursor property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeFont
Indicates whether the Font property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeIndentOptions
Indicates whether the IndentOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeNavigateOptions
Indicates whether the NavigateOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeReadOnly
Indicates whether the ReadOnly property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeSearchOptions
Indicates whether the SearchOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeText
Indicates whether the Text property should be persisted.
(Inherited from SyntaxEdit.)
Public method Show
Displays the control to the user.
(Inherited from Control.)
Public method ShowCaret
Moves the caret to the specified coordinates.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType)
Shows code completion popup window with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point)
Shows code completion popup window with given Provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionButton(ICodeCompletionProvider)
Shows code completion popup window with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionButton(ICodeCompletionProvider, Point, Boolean)
Shows code completion popup window with given Provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, ILexer)
Displays ICodeCompletionHint with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer)
Displays ICodeCompletionHint with given provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowNotFound
Displays "searched text not found" message box.
(Inherited from SyntaxEdit.)
Public method ShowScrollHint
Displays tooltip indicating destination line when scrolling.
(Inherited from SyntaxEdit.)
Public method SplitViewHorz
Splits control content horizontally.
(Inherited from SyntaxEdit.)
Public method SplitViewVert
Splits control content vertically.
(Inherited from SyntaxEdit.)
Public method StartIncrementalSearch
Enters control to the incremental search state.
(Inherited from SyntaxEdit.)
Public method StartIncrementalSearch(Boolean)
Enters control to the incremental search state.
(Inherited from SyntaxEdit.)
Public method StartMacroRecording
Starts recording the command sequence.
(Inherited from SyntaxEdit.)
Public method StopMacroRecording
Stops recording the command sequence.
(Inherited from SyntaxEdit.)
Public method StorePosition(Point)
Stores given position to stored position list.
(Inherited from SyntaxEdit.)
Public method StorePosition(Point, Boolean)
Stores given position to stored position list.
(Inherited from SyntaxEdit.)
Public method StorePositionWithUndo
Stores given position to stored position list preserving it for undo.
(Inherited from SyntaxEdit.)
Public method SuspendLayout
Temporarily suspends the layout logic for the control.
(Inherited from Control.)
Public method | SwitchStackFrame
Public method | TextStyleAt | (Inherited from SyntaxEdit.)
Public method TextToScreen(Point)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method TextToScreen(Point, Boolean)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method TextToScreen(Int32, Int32)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method ToggleMacroRecording
Toggles recording the command sequence.
(Inherited from SyntaxEdit.)
Public method ToString
Returns a String containing the name of the Component, if any. This method should not be overridden.
(Inherited from Component.)
Public method UnBreakLine
Concatenates lines at current position.
(Inherited from SyntaxEdit.)
Public method | Undo | (Inherited from ScriptCodeEdit.)
Public method UnhighlightAll
Unhighlights search results previously highlighted by HighlightAll.
(Inherited from SyntaxEdit.)
Public method UnsplitViewHorz
Removes horizontal split view.
(Inherited from SyntaxEdit.)
Public method UnsplitViewVert
Removes vertical split view.
(Inherited from SyntaxEdit.)
Public method Update
Causes the control to redraw the invalidated regions within its client area.
(Inherited from Control.)
Public method UpdateCaret
Ensures the caret is displayed in the current position.
(Inherited from SyntaxEdit.)
Public method UpdateCursor
Causes current mouse cursor to be updated.
(Inherited from SyntaxEdit.)
Public method | UpdateSyntax | (Inherited from ScriptCodeEdit.)
Public method UpdateView
Updates editor content, caret and pages area.
(Inherited from SyntaxEdit.)
Public method UpdateWordWrap
Re-wraps all lines in the text.
(Inherited from SyntaxEdit.)
Public method UpdateWordWrap(Int32, Int32)
Re-wraps lines in the text within specific scope.
(Inherited from SyntaxEdit.)
Public method ValidatePosition
Validates given position within control's text content.
(Inherited from SyntaxEdit.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanFindDeclaration | (Defined by CodeEditExtensions.)
Public Extension Method | Document | (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindImplementations | (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterDefaultAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterNamespaces | (Defined by CodeEditExtensions.)
Public Extension Method | SetFileNameAndProject | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Top
Properties
 | Name | Description
Public property | AcceptReturns | Gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key. (Inherited from SyntaxEdit.)
Public property | AcceptTabs | Gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key. (Inherited from SyntaxEdit.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveOutlineRange | Gets currently highlighted outlined range. (Inherited from SyntaxEdit.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from SyntaxEdit.)
Public property | AllowedActions | Gets or sets a allowed actions.
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCorrectDelimiters | Gets or sets an array of chars that used as word delimiters. (Inherited from SyntaxEdit.)
Public property | AutoCorrection | Gets or sets a boolean value indicating whether to auto correct words being typed. (Inherited from SyntaxEdit.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color for the Edit control. (Inherited from SyntaxEdit.)
Public property | BorderStyle | Gets or sets the border style for the Edit control. (Inherited from SyntaxEdit.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Braces | Represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control. (Inherited from SyntaxEdit.)
Public property | CanCopy | (Inherited from ScriptCodeEdit.)
Public property | CanCut | (Inherited from ScriptCodeEdit.)
Public property | CanDelete | (Inherited from ScriptCodeEdit.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanPaste | (Inherited from ScriptCodeEdit.)
Public property | CanRedo | (Inherited from ScriptCodeEdit.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | (Inherited from ScriptCodeEdit.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharsInWidth | Returns number of characters painted with current font that will fit into control's client area. (Inherited from SyntaxEdit.)
Public property | ClientArea | Gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded. (Inherited from SyntaxEdit.)
Public property | ClientHeight | Gets the width of the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | ClientRect | Gets the rectangle that represents the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ClientWidth | Gets the width of the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | CodeCompletionBox | Represents object that specifies a popup window that contains code completion information presented in the form of list. (Inherited from SyntaxEdit.)
Public property | CodeCompletionButton | Represents object that specifies a popup window that contains code completion information presented in the form of list. (Inherited from SyntaxEdit.)
Public property | CodeCompletionChars | Represents a collection of characters that initializes a code completion procedure when typing in the editor. (Inherited from SyntaxEdit.)
Public property | CodeCompletionHint | Represents object that specifies a popup window that contains code completion information presented in the form of the tooltip. (Inherited from SyntaxEdit.)
Public property | CodeCompletionMode | Gets or sets code completion box mode. (Inherited from SyntaxEdit.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentBlockRange | Gets currently highlighted block range. (Inherited from SyntaxEdit.)
Public property | CurrentChar | (Inherited from ScriptCodeEdit.)
Public property | CurrentLine | (Inherited from ScriptCodeEdit.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from SyntaxEdit.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataTipsEnabled | Gets or sets a boolean value indicating whether DataTip functionality is enabled.
Public property | Debugger |
Public property | DefaultMenu | Gets or sets default context menu for the editor control. (Inherited from SyntaxEdit.)
Public property | DisplayLines | Represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control. (Inherited from SyntaxEdit.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | EditMargin | Represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed. (Inherited from SyntaxEdit.)
Public property | EffectiveVisualTheme | Gets current visual theme. (Inherited from SyntaxEdit.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EventHandlers | Represents object that holds EventHandlers containing list of keys with attached actions. (Inherited from SyntaxEdit.)
Public property | FileName | (Inherited from ScriptCodeEdit.)
Public property | FirstSearch | Gets or sets a value indicating whether control launches text search at first. (Inherited from SyntaxEdit.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from SyntaxEdit.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GotoLineDialog | Gets or sets a dialog prompting for index of the line you need to locate. (Inherited from SyntaxEdit.)
Public property | Gutter | Represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control. (Inherited from SyntaxEdit.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideCaret | Gets or sets a value indicating whether the control should display caret when it has input focus. (Inherited from SyntaxEdit.)
Public property | HighlightCurrentBlock | Specifies that edit control should highlight current block. (Inherited from SyntaxEdit.)
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight begin/end blocks. (Inherited from SyntaxEdit.)
Public property | HighlightReferences | Specifies that edit control should highlight found references. (Inherited from SyntaxEdit.)
Public property | HighlightSearchResults | Indicates whether search results are highlighted while the search dialog is open. (Inherited from SyntaxEdit.)
Public property | HorzSplitEdit | Represents horizontal split view control. (Inherited from SyntaxEdit.)
Public property | HorzSplitter | Represents a horizontal Splitter control allowing to split Edit content horizontally. (Inherited from SyntaxEdit.)
Public property | HyperText | Represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control. (Inherited from SyntaxEdit.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IncrementalSearchString | Return text to search if class is in incremental search state; otherwise return empty string. (Inherited from SyntaxEdit.)
Public property | InCycledSearch | Indicates whether control is in incremental search state. (Inherited from SyntaxEdit.)
Public property | IndentOptions | Gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from SyntaxEdit.)
Public property | InIncrementalSearch | Indicates whether control is in incremental search state. (Inherited from SyntaxEdit.)
Public property | InnerTextSource | Gets inner text source (Inherited from SyntaxEdit.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsCodeCompletionWindowFocused | Indicates whether ICodeCompletionWindow has focus. (Inherited from SyntaxEdit.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSearchFocused | Gets a boolean value indicating whether search dialog box has input focus. (Inherited from SyntaxEdit.)
Public property | KeepCaretOnLostFocus | Keeps caret in visible state even Edit control lost focus. (Inherited from SyntaxEdit.)
Public property | KeyList | Represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure. (Inherited from SyntaxEdit.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | (Inherited from ScriptCodeEdit.)
Public property | Lines | Represents object that implements ITextStrings interface containing collection of strings determining control's content. (Inherited from SyntaxEdit.)
Public property | LineSeparator | Represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control. (Inherited from SyntaxEdit.)
Public property | LinesInHeight | Determines how many lines can fit into control's client area. (Inherited from SyntaxEdit.)
Public property | LineSpace | Gets or sets line space between individual lines in the Edit control. (Inherited from SyntaxEdit.)
Public property | LineStyles | Represents an object that implements IEditLineStyles interface holding collection of IEditLineStyle objects each of them determines particular style of the line in the control. (Inherited from SyntaxEdit.)
Public property | LineTerminator | Gets or sets a string value that terminates line. (Inherited from SyntaxEdit.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | MacroRecording | Gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands. (Inherited from SyntaxEdit.)
Public property | MacroRecords | Represents an array containing keyboard commands. (Inherited from SyntaxEdit.)
Public property | MacroSuspendend | Gets or sets a boolean value indicating whether recording is suspended. (Inherited from SyntaxEdit.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control. (Inherited from SyntaxEdit.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified. (Inherited from SyntaxEdit.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavigateOptions | Gets or sets navigating options. (Inherited from SyntaxEdit.)
Public property | OpenSharedEditorFunc | When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment. (Inherited from SyntaxEdit.)
Public property | Outlining | Represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control. (Inherited from SyntaxEdit.)
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from SyntaxEdit.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Pages | Represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages. (Inherited from SyntaxEdit.)
Public property | Painter | Represents an object that implements IPainter interface used to draw control's text. (Inherited from SyntaxEdit.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | Position | Gets or sets current position within the control's text content. (Inherited from SyntaxEdit.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PrevPosition | Gets previous position within the control's text content. (Inherited from SyntaxEdit.)
Public property | Printing | Represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options. (Inherited from SyntaxEdit.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only. (Inherited from SyntaxEdit.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Scrolling | Represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control. (Inherited from SyntaxEdit.)
Public property | SearchDialog | Gets or sets a dialog box allowing to search for the text or replace it. (Inherited from SyntaxEdit.)
Public property | SearchDialogAppearance | (Inherited from SyntaxEdit.)
Public property | SearchGlobal | Gets or sets a value indicating whether search should be global. (Inherited from SyntaxEdit.)
Public property | SearchLen | Represents length of the last found text. (Inherited from SyntaxEdit.)
Public property | SearchOptions | Gets or sets a value that defines search and replace options. (Inherited from SyntaxEdit.)
Public property | SearchPos | Gets or sets a value that represents position of the last found text. (Inherited from SyntaxEdit.)
Public property | Selection | Represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text. (Inherited from SyntaxEdit.)
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from SyntaxEdit.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Source | (Inherited from ScriptCodeEdit.)
Public property | Spelling | Represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words. (Inherited from SyntaxEdit.)
Public property | Status | (Inherited from ScriptCodeEdit.)
Public property | StatusText | Obsolete. (Inherited from ScriptCodeEdit.)
Public property | Strings | Represents Lines property in the form of array of strings. (Inherited from SyntaxEdit.)
Public property | SyntaxPaint | Represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content. (Inherited from SyntaxEdit.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the string collection as a single string with the individual lines delimited by carriage returns. (Inherited from SyntaxEdit.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Transparent | Gets or sets a boolean value that indicates whether Edit control should draw its background. (Inherited from SyntaxEdit.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from SyntaxEdit.)
Public property | UseDefaultMenu | Indicates whether edit control should use built in popup menu. (Inherited from SyntaxEdit.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VertSplitEdit | Represents an vertical split view control. (Inherited from SyntaxEdit.)
Public property | VertSplitter | Represents a vertical Splitter control allowing to split Edit content vertically. (Inherited from SyntaxEdit.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualTheme | Gets or sets visual theme for the editor. (Inherited from SyntaxEdit.)
Public property | VisualThemeType | Gets or sets visual theme type for the editor. (Inherited from SyntaxEdit.)
Public property | WhiteSpace | Represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks. (Inherited from SyntaxEdit.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary. (Inherited from SyntaxEdit.)
Public property | WrapAtMargin | Gets or sets a value indicating whether control automatically wraps words at margin position. (Inherited from SyntaxEdit.)
Public property | WrapMargin | Gets position of the wrapping margin. (Inherited from SyntaxEdit.)
Top
Events
 | Name | Description
Public event | AddToWatchClick | Occurs when user clicks on the local to add it to the watch window.
Public event | AutoCorrect | Occurs when control tries to auto correct word being typed. (Inherited from SyntaxEdit.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BreakpointToggle |
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckHyperText | Occurs when a control needs checking whether some string represents hypertext. (Inherited from SyntaxEdit.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxEdit.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawHeader | Occurs when header or footer part of each page is drawing. (Inherited from SyntaxEdit.)
Public event | DrawUserMargin | Occurs when user margin part of each line is drawing. (Inherited from SyntaxEdit.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FindAllImplementations |
Public event | FindAllReferences |
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | GotoDefinition |
Public event | GutterClick | Occurs when the gutter part of Edit control is clicked. (Inherited from SyntaxEdit.)
Public event | GutterDblClick | Occurs when the gutter part of Edit control is double-clicked. (Inherited from SyntaxEdit.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HorizontalScroll | Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving. (Inherited from SyntaxEdit.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | JumpToUrl | Occurs when user attempts to jump to url. (Inherited from SyntaxEdit.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when modified state is changed. (Inherited from SyntaxEdit.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NeedCodeCompletion | Occurs when code completion window is to be displayed. (Inherited from SyntaxEdit.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintBackground | Occurs when Edit control should paint its background in transparent mode. (Inherited from SyntaxEdit.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | ParserChanged | (Inherited from ScriptCodeEdit.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PromptOnReplace | Occurs when replace dialog prompts on replace action. (Inherited from SyntaxEdit.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollButtonClick | Occurs when some scrolling button is clicked. (Inherited from SyntaxEdit.)
Public event | SelectionChanged | Occurs when selection bounds are changed. (Inherited from SyntaxEdit.)
Public event | SetNextStatement |
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SourceChanged | Occurs when source changes. (Inherited from SyntaxEdit.)
Public event | SourceStateChanged | Occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc. (Inherited from SyntaxEdit.)
Public event | SplitHorz | Occurs when user splits Edit control horizontally. (Inherited from SyntaxEdit.)
Public event | SplitVert | Occurs when user splits Edit control vertically. (Inherited from SyntaxEdit.)
Public event | StatusChanged | (Inherited from ScriptCodeEdit.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from ScriptCodeEdit.)
Public event | UndoEvent | Occurs when undo/redo operation performed. (Inherited from SyntaxEdit.)
Public event | UnsplitHorz | Occurs when horizontal split view is removed. (Inherited from SyntaxEdit.)
Public event | UnsplitVert | Occurs when vertical split view is removed. (Inherited from SyntaxEdit.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VerticalScroll | Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving. (Inherited from SyntaxEdit.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking. (Inherited from SyntaxEdit.)
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


DebugCodeEdit Constructor

DebugCodeEdit Constructor
Initializes a new instance of the DebugCodeEdit class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebugCodeEdit()
Public Sub New
public:
DebugCodeEdit()
new : unit -> DebugCodeEdit
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit Methods

DebugCodeEdit Methods

The DebugCodeEdit type exposes the following members.

Methods
Name | Description
Public method ApplyTheme
Applies visual theme to the SyntaxEdit control.
(Inherited from SyntaxEdit.)
Public method Assign
Assigns most relevant properties from another ISyntaxEdit object.
(Inherited from SyntaxEdit.)
Public method BeginInvoke(Delegate)
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginInvoke(Delegate, Object)
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
(Inherited from Control.)
Public method BeginUpdate
Prevents editor updating until calling EndUpdate method.
(Inherited from SyntaxEdit.)
Public method BreakLine
Breaks current line into two lines.
(Inherited from SyntaxEdit.)
Public method | BreakpointDeleted
Public method | BreakpointStateChanged
Public method BringToFront
Brings the control to the front of the z-order.
(Inherited from Control.)
Public method CanFindNext
Indicates whether search engine can find next occurrence of the text specified by previous search or it is only first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindNextSelected
Indicates whether search engine can find next occurrence of the selected text or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindPrevious
Indicates whether search engine can find previous occurrence of the text specified to search or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanFindPreviousSelected
Indicates whether search engine can find previous occurrence of the selected text or it is the first attempt to search.
(Inherited from SyntaxEdit.)
Public method CanSearchSelection
Returns whether search can be performed inside selection.
(Inherited from SyntaxEdit.)
Public method CanSplitHorz
Indicates whether control can split its content horizontally.
(Inherited from SyntaxEdit.)
Public method CanSplitVert
Indicates whether control can split its content vertically.
(Inherited from SyntaxEdit.)
Public method CanUnsplitHorz
Indicates whether control has horizontal split view.
(Inherited from SyntaxEdit.)
Public method CanUnsplitVert
Indicates whether control has vertical split view.
(Inherited from SyntaxEdit.)
Public method | ClearDebugStyles
Public method | ClearStackFrame
Public method CodeCompletion
Performs code completion for the specified text representing language element.
(Inherited from SyntaxEdit.)
Public method CodeCompletionWindowFocused
Indicates whether ICodeCompletionWindow has focus.
(Inherited from SyntaxEdit.)
Public method CodeSnippets
Displays a code completion window with list of available code snippets.
(Inherited from SyntaxEdit.)
Public method CompleteCodeFixes
Displays a code completion window with list of available code fixes.
(Inherited from SyntaxEdit.)
Public method CompleteCodeFixesOrRefactors
Displays a code completion window with list of available code fixes or code refactors.
(Inherited from SyntaxEdit.)
Public method CompleteCodeRefactors
Displays a code completion window with list of available code refactors.
(Inherited from SyntaxEdit.)
Public method CompleteWord
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box and locates single member, if possible.
(Inherited from SyntaxEdit.)
Public method Contains
Retrieves a value indicating whether the specified control is a child of the control.
(Inherited from Control.)
Public method | Copy | (Inherited from ScriptCodeEdit.)
Public method CreateCaret
Creates a new shape for the system caret and gets ownership of the caret.
(Inherited from SyntaxEdit.)
Public method CreateControl
Forces the creation of the visible control, including the creation of the handle and any visible child controls.
(Inherited from Control.)
Public method CreateGraphics
Creates the Graphics for the control.
(Inherited from Control.)
Public method CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
(Inherited from MarshalByRefObject.)
Public method | Cut | (Inherited from ScriptCodeEdit.)
Public method CycledSearch
Performs cycled search.
(Inherited from SyntaxEdit.)
Public method | Delete | (Inherited from ScriptCodeEdit.)
Public method DeleteBlock
Deletes a specified block of characters.
(Inherited from SyntaxEdit.)
Public method DeleteLeft
Deletes a specified number of characters to the left of the active point.
(Inherited from SyntaxEdit.)
Public method DeleteRight
Deletes a specified number of characters to the right of the active point.
(Inherited from SyntaxEdit.)
Public method | DeselectAll | (Inherited from ScriptCodeEdit.)
Public method DestroyCaret
Destroys the caret's current shape, frees the caret from the control, and removes the caret from the screen.
(Inherited from SyntaxEdit.)
Public method DisablePositionUpdate
Prevents notification of changing of caret position until calling EnablePositionUpdate method.
(Inherited from SyntaxEdit.)
Public method DisableUpdate
Prevents editor updating until calling EnableUpdate method.
(Inherited from SyntaxEdit.)
Public method DisplayDragCaret
Displays dragging caret rather than regular caret.
(Inherited from SyntaxEdit.)
Public method DisplayGotoLineDialog
Initializes and runs a dialog prompting you for index of the line you need to locate.
(Inherited from SyntaxEdit.)
Public method DisplayGotoLineDialog(IWin32Window)
Initializes and runs a dialog prompting you for index of the line you need to locate.
(Inherited from SyntaxEdit.)
Public method DisplayModalReplaceDialog
Initializes and runs a modal dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayModalReplaceDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayModalSearchDialog
Initializes and runs a modal dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayModalSearchDialog(IWin32Window)
Initializes and runs a modal dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayReplaceDialog
Initializes and runs a dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplayReplaceDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for text and replace it.
(Inherited from SyntaxEdit.)
Public method DisplaySearchDialog
Initializes and runs a dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplaySearchDialog(IWin32Window)
Initializes and runs a dialog box allowing you to search for some text.
(Inherited from SyntaxEdit.)
Public method DisplayToScreen(Int32, Int32)
Converts given display coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method DisplayToScreen(Int32, Int32, Boolean)
Converts given display coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method Dispose
Releases all resources used by the Component.
(Inherited from Component.)
Public method DoDragDrop
Begins a drag-and-drop operation.
(Inherited from Control.)
Public method DrawToBitmap
Supports rendering to the specified bitmap.
(Inherited from Control.)
Public method EnablePositionUpdate
Re-enables notification of changing of caret position that was turn of by calling DisablePositionUpdate method.
(Inherited from SyntaxEdit.)
Public method EnableUpdate
Re-enables editor updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from SyntaxEdit.)
Public method EndInvoke
Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
(Inherited from Control.)
Public method EndUpdate
Re-enables outline editor updating, that was turn of by calling BeginUpdate method.
(Inherited from SyntaxEdit.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method | ExecutionStopped
Public method Find(String)
Searches for given text within the control's contents.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions)
Searches for given text within the control's contents with specified options.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex)
Searches for given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, IListIRange)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, Boolean, Boolean)
Searches for all occurrences of given text within the control's contents with specified options using specified regular expression.
(Inherited from SyntaxEdit.)
Public method Find(String, SearchOptions, Regex, Point, Int32, Match)
Searches for given text within the control's text content.
(Inherited from SyntaxEdit.)
Public method FindForm
Retrieves the form that the control is on.
(Inherited from Control.)
Public method FindNext
Searches for the next occurrence of the text specified by previous search.
(Inherited from SyntaxEdit.)
Public method FindNextSelected
Searches for the next occurrence of the selected text.
(Inherited from SyntaxEdit.)
Public method FindPrevious
Searches for the previous occurrence of the text specified by previous search.
(Inherited from SyntaxEdit.)
Public method FindPreviousSelected
Searches for the previous occurrence of the selected text.
(Inherited from SyntaxEdit.)
Public method FinishIncrementalSearch
Leaves control from the incremental search state.
(Inherited from SyntaxEdit.)
Public method Focus
Sets input focus to the control.
(Inherited from Control.)
Public method GetCaretSize
Returns size of the caret's current shape at given position.
(Inherited from SyntaxEdit.)
Public method GetCharsInWidth
Returns number of characters painted with current font that will fit into specified Width.
(Inherited from SyntaxEdit.)
Public method GetChildAtPoint(Point)
Retrieves the child control that is located at the specified coordinates.
(Inherited from Control.)
Public method GetChildAtPoint(Point, GetChildAtPointSkip)
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
(Inherited from Control.)
Public method GetContainerControl
Returns the next ContainerControl up the control's chain of parent controls.
(Inherited from Control.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetHitTest(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTest(Int32, Int32, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of the control at specified coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTestAtTextPoint(Point, IHitTestInfo)
Fills hitTestInfo parameter by information about a part of control at specified text coordinate.
(Inherited from SyntaxEdit.)
Public method GetHitTestAtTextPoint(Int32, Int32, IHitTestInfo)
Retrieves information about part of control at specified text coordinate.
(Inherited from SyntaxEdit.)
Public method GetIndentString
Gets indentation string at current position.
(Inherited from SyntaxEdit.)
Public method GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method | GetLine | (Inherited from ScriptCodeEdit.)
Public method GetLinesInHeight
Determines how many lines can fit into given Height.
(Inherited from SyntaxEdit.)
Public method GetNextControl
Retrieves the next control forward or back in the tab order of child controls.
(Inherited from Control.)
Public method GetPreferredSize
Retrieves the size of a rectangular area into which a control can be fitted.
(Inherited from Control.)
Public method | GetSymbolAtCursor | (Inherited from ScriptCodeEdit.)
Public method GetTextAtCursor
Returns word at the cursor position.
(Inherited from SyntaxEdit.)
Public method GetTextToSearchAtCursor
Returns word at the cursor position.
(Inherited from SyntaxEdit.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetWordAt
Checks word accordingly to specified conditions.
(Inherited from SyntaxEdit.)
Public method GetWrapMargin
Returns position of the wrapping margin.
(Inherited from SyntaxEdit.)
Public method | GotoLine | (Inherited from ScriptCodeEdit.)
Public method HasAutoCorrection
Checks whether specified word has correction.
(Inherited from SyntaxEdit.)
Public method Hide
Conceals the control from the user.
(Inherited from Control.)
Public method HideDragCaret
Hides dragging caret.
(Inherited from SyntaxEdit.)
Public method HideScrollHint
Hides scroll hint window if necessary.
(Inherited from SyntaxEdit.)
Public method HighlightAll
Highlights all occurrences of specified string in the class text content.
(Inherited from SyntaxEdit.)
Public method IncrementalSearch
Finds given text incrementally.
(Inherited from SyntaxEdit.)
Public method IndentLine
Inserts spaces to the start of the current line. Number of spaces is calculated from indent options or SyntaxParser if assigned.
(Inherited from SyntaxEdit.)
Public method IndentLine(String, Boolean)
Inserts white space to the start of the current line. white space stringIndicates if the change needs to be translated to the parser
(Inherited from SyntaxEdit.)
Public method InitializeLifetimeService
Obtains a lifetime service object to control the lifetime policy for this instance.
(Inherited from MarshalByRefObject.)
Public method Insert
Inserts the given string at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean)
Inserts the given string at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean)
Inserts the given string array at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(ITextStrings, Boolean)
Inserts the given string collection at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertBlock(String, Boolean, Boolean)
When implemented by a class, inserts the given string array at the specified location.
(Inherited from SyntaxEdit.)
Public method InsertFromFile
Inserts the file text content at the specified location.
(Inherited from SyntaxEdit.)
Public method Invalidate
Invalidates the entire surface of the control and causes the control to be redrawn.
(Inherited from Control.)
Public method Invalidate(Region)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Boolean)
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
(Inherited from Control.)
Public method Invalidate(Region, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invalidate(Rectangle, Boolean)
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
(Inherited from Control.)
Public method Invoke(Delegate)
Executes the specified delegate on the thread that owns the control's underlying window handle.
(Inherited from Control.)
Public method Invoke(Delegate, Object)
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
(Inherited from Control.)
Public method IsValidText
Indicates whether text at the specified position is valid (that is does not contain comments or string constants).
(Inherited from SyntaxEdit.)
Public method KillFocus
Ensure the caret is not visible.
(Inherited from SyntaxEdit.)
Public method LineIsHidden
Determines whether the given line is hidden.
(Inherited from SyntaxEdit.)
Public method LineIsReadonly
Determines whether the given line is readonly.
(Inherited from SyntaxEdit.)
Public method ListMembers
Displays a code completion window that displays members of the current class in the Editor's content in a form of the popup list box.
(Inherited from SyntaxEdit.)
Public method | LoadFile(String) | (Inherited from ScriptCodeEdit.)
Public method LoadFile(String, IStringImport)
Loads content from the given file with specified importer.
(Inherited from SyntaxEdit.)
Public method LoadFile(String, Encoding)
Loads the contents of the specified file with specified encoding.
(Inherited from SyntaxEdit.)
Public method LoadFile(String, IStringImport, Encoding)
Loads content from the given file with specified importer and specific encoding.
(Inherited from SyntaxEdit.)
Public method LoadMacros(Stream)
Loads the macro records from the given stream.
(Inherited from SyntaxEdit.)
Public method LoadMacros(TextReader)
Loads the macro records from the given stream.
(Inherited from SyntaxEdit.)
Public method LoadMacros(String)
Loads the macro records from the given file.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(TextReader)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, IStringImport)
Loads the text content from the given stream with specified importer.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, Encoding)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(TextReader, IStringImport)
Loads the contents of the specified stream.
(Inherited from SyntaxEdit.)
Public method LoadStream(Stream, IStringImport, Encoding)
Loads the text content from the given stream with specified importer.
(Inherited from SyntaxEdit.)
Public method | Localize
Public method MakeVisible(Point)
Scrolls the control's content, if necessary, to ensure a specified text position is in view.
(Inherited from SyntaxEdit.)
Public method | MakeVisible(Point, Boolean) | (Overrides SyntaxEditMakeVisible(Point, Boolean).)
Public method MarkAll(String, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, SearchOptions, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MarkAll(String, SearchOptions, Regex, Boolean)
Marks all occurrences of specified string in the class text content by unnumbered bookmarks and moves to the last occurrence.
(Inherited from SyntaxEdit.)
Public method MoveCaretOnDrag
Moves caret to the position of drag cursor.
(Inherited from SyntaxEdit.)
Public method MoveCharLeft
Moves the current position one character to the left.
(Inherited from SyntaxEdit.)
Public method MoveCharRight
Moves the current position one character to the right.
(Inherited from SyntaxEdit.)
Public method MoveFileBegin
Moves the current position to the first character of the first line.
(Inherited from SyntaxEdit.)
Public method MoveFileEnd
Moves the current position to the last character of the last line.
(Inherited from SyntaxEdit.)
Public method MoveLineBegin
Moves the current position to the first character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineBeginCycled
Moves the current position to the first not whitespace character/first character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineDown
Moves the current position to the next line.
(Inherited from SyntaxEdit.)
Public method MoveLineEnd
Moves the current position to the last character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineEndCycled
Moves the current position to the last not whitespace character/last character of current line.
(Inherited from SyntaxEdit.)
Public method MoveLineUp
Moves the current position to the previous line.
(Inherited from SyntaxEdit.)
Public method MovePageDown
Moves current position to the next page.
(Inherited from SyntaxEdit.)
Public method MovePageUp
Moves current position to the previous page.
(Inherited from SyntaxEdit.)
Public method MoveScreenBottom
Moves the current position to the bottom of the screen.
(Inherited from SyntaxEdit.)
Public method MoveScreenTop
Moves the current position to the top of the screen.
(Inherited from SyntaxEdit.)
Public method MoveTo(Point)
Moves the current position to the given position.
(Inherited from SyntaxEdit.)
Public method MoveTo(Int32, Int32)
Moves the current position to the given position.
(Inherited from SyntaxEdit.)
Public method MoveToBrace
Moves the current position to the next open or close brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveToChar
Moves the current position to the specified character in current line.
(Inherited from SyntaxEdit.)
Public method MoveToCloseBrace
Moves the current position to the next close brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveToLine(Int32)
Moves the current position to the specified line.
(Inherited from SyntaxEdit.)
Public method MoveToLine(Int32, Int32)
Moves the current position to the specified line.
(Inherited from SyntaxEdit.)
Public method MoveToOpenBrace
Moves the current position to the previous open brace in the text content.
(Inherited from SyntaxEdit.)
Public method MoveWordLeft
Moves the current position one word to the left.
(Inherited from SyntaxEdit.)
Public method MoveWordRight
Moves the current position one word to the right.
(Inherited from SyntaxEdit.)
Public method Navigate
Moves current position by the given offset value.
(Inherited from SyntaxEdit.)
Public method NeedReplaceCurrent
Indicates whether search engine need to replace successfully found and selected text.
(Inherited from SyntaxEdit.)
Public method NeedReplaceCurrent(Match)
Indicates whether search engine need to replace successfully found and selected text.
(Inherited from SyntaxEdit.)
Public method NewLine
Inserts a line break at the current position.
(Inherited from SyntaxEdit.)
Public method NewLine(String, Boolean)
Inserts a line break at the current position with indentation
(Inherited from SyntaxEdit.)
Public method NewLineAbove
Inserts a line break above the current position.
(Inherited from SyntaxEdit.)
Public method NewLineBelow
Inserts a line break below the current position.
(Inherited from SyntaxEdit.)
Public method Notification
Updates control's content according to parameters of notification.
(Inherited from SyntaxEdit.)
Public method OnStateChanged
Updates control's content according to the state of the source.
(Inherited from SyntaxEdit.)
Public method OnTextFound
When implemented by a class, occurs when search text is found.
(Inherited from SyntaxEdit.)
Public method OutlineText
Forces automatic outlining by getting up-to-date information about outline section from the Parser.
(Inherited from SyntaxEdit.)
Public method ParameterInfo
Displays a code completion window containing information for the current method or parameter in the Editor's content.
(Inherited from SyntaxEdit.)
Public method | Paste | (Inherited from ScriptCodeEdit.)
Public method PauseMacroRecording
Suspends recording the command sequence.
(Inherited from SyntaxEdit.)
Public method PerformLayout
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PerformLayout(Control, String)
Forces the control to apply layout logic to all its child controls.
(Inherited from Control.)
Public method PlayBackMacro
Repeats the stored command sequence.
(Inherited from SyntaxEdit.)
Public method PointToClient
Computes the location of the specified screen point into client coordinates.
(Inherited from Control.)
Public method PointToScreen
Computes the location of the specified client point into screen coordinates.
(Inherited from Control.)
Public method PositionIsReadonly
Determines whether the text at given position is readonly.
(Inherited from SyntaxEdit.)
Public method PreProcessControlMessage
Preprocesses keyboard or input messages within the message loop before they are dispatched.
(Inherited from Control.)
Public method PreProcessMessage
Preprocesses input messages within the message loop before they are dispatched.
(Inherited from SyntaxEdit.)
Public method | Print | (Inherited from ScriptCodeEdit.)
Public method | PrintPreview | (Inherited from ScriptCodeEdit.)
Public method ProcessEnter
Performs specific actions when Enter key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method ProcessKeyMsg
Processes a keyboard message.
(Inherited from SyntaxEdit.)
Public method ProcessKeyPress
Processes key press.
(Inherited from SyntaxEdit.)
Public method ProcessShiftTab
Performs specific actions when Shift + Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method ProcessTab
Performs specific actions when Tab key is pressed.

Return Value

Type:
True if key was processed; otherwise false.
(Inherited from SyntaxEdit.)
Public method QuickInfo
Displays a code completion window with simple tooltip information.
(Inherited from SyntaxEdit.)
Public method RecordKeyData
Adds keyData to the MacroRecords array.
(Inherited from SyntaxEdit.)
Public method RectangleToClient
Computes the size and location of the specified screen rectangle in client coordinates.
(Inherited from Control.)
Public method RectangleToScreen
Computes the size and location of the specified client rectangle in screen coordinates.
(Inherited from Control.)
Public method | Redo | (Inherited from ScriptCodeEdit.)
Public method Refresh
Forces the control to invalidate its client area and immediately redraw itself and any child controls.
(Inherited from Control.)
Public method | Replace | (Inherited from ScriptCodeEdit.)
Public method Replace(String, String)
Searches for the first occurrence of given text within the text content and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method Replace(String, String, SearchOptions)
Searches for first occurrence given text within the text content with specified options and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method Replace(String, String, SearchOptions, Regex)
Searches for first occurrence given text within the text content with specified options using specified regular expression and if succeed replaces it by specified string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Int32)
Replaces all occurrences of given text within text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceAll(String, String, SearchOptions, Regex, Int32, Boolean)
Replaces all occurrences of given text within class text content by specified replaceWith string.
(Inherited from SyntaxEdit.)
Public method ReplaceCurrent
Replaces currently selected text.
(Inherited from SyntaxEdit.)
Public method ResetAcceptReturns
Resets the AcceptReturns to the default value.
(Inherited from SyntaxEdit.)
Public method ResetAcceptTabs
Resets the AcceptTabs to the default value.
(Inherited from SyntaxEdit.)
Public method ResetBackColor
Resets the BackColor property to its default value.
(Inherited from Control.)
Public method ResetBindings
Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
(Inherited from Control.)
Public method ResetBorderColor
Resets the BorderColor to the default value.
(Inherited from SyntaxEdit.)
Public method ResetBorderStyle
Resets the BorderStyle to the default value.
(Inherited from SyntaxEdit.)
Public method ResetCursor
Resets the Cursor property to its default value.
(Inherited from SyntaxEdit.)
Public method ResetFont
Resets the Font property to its default value.
(Inherited from SyntaxEdit.)
Public method ResetForeColor
Resets the ForeColor property to its default value.
(Inherited from Control.)
Public method ResetHideCaret
Resets the HideCaret to the default value.
(Inherited from SyntaxEdit.)
Public method ResetImeMode
Resets the ImeMode property to its default value.
(Inherited from Control.)
Public method ResetIndentOptions
Resets the IndentOptions to the default value.
(Inherited from SyntaxEdit.)
Public method ResetKeepCaretOnLostFocus
Resets the KeepCaretOnLostFocus to the default value.
(Inherited from SyntaxEdit.)
Public method ResetLineSpace
Resets the LineSpace to the default value.
(Inherited from SyntaxEdit.)
Public method ResetMaxLength
Resets the MaxLength to the default value.
(Inherited from SyntaxEdit.)
Public method ResetModified
Resets the Modified to the default value.
(Inherited from SyntaxEdit.)
Public method ResetNavigateOptions
Resets the NavigateOptions to the default value.
(Inherited from SyntaxEdit.)
Public method ResetOverWrite
Resets the OverWrite to the default value.
(Inherited from SyntaxEdit.)
Public method ResetReadOnly
Resets the ReadOnly to the default value.
(Inherited from SyntaxEdit.)
Public method ResetRightToLeft
Resets the RightToLeft property to its default value.
(Inherited from Control.)
Public method ResetSingleLineMode
Resets the SingleLineMode to the default value.
(Inherited from SyntaxEdit.)
Public method ResetText
Resets the Text property to its default value.
(Inherited from Control.)
Public method ResetWordWrap
Resets the WordWrap to the default value.
(Inherited from SyntaxEdit.)
Public method ResetWrapAtMargin
Resets the WrapAtMargin to the default value.
(Inherited from SyntaxEdit.)
Public method RestorePosition
Restores position from stored position list by given index.
(Inherited from SyntaxEdit.)
Public method RestorePositionWithUndo
Restores position from stored position list by given index.
(Inherited from SyntaxEdit.)
Public method ResumeLayout
Resumes usual layout logic.
(Inherited from Control.)
Public method ResumeLayout(Boolean)
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.
(Inherited from Control.)
Public method ResumeMacroRecording
Resumes recording the command sequence.
(Inherited from SyntaxEdit.)
Public method | SaveFile(String) | (Inherited from ScriptCodeEdit.)
Public method SaveFile(String, IStringExport)
Saves content to the given file in the specific format.
(Inherited from SyntaxEdit.)
Public method SaveFile(String, Encoding)
Saves text content to the specific file with specific encoding.
(Inherited from SyntaxEdit.)
Public method SaveFile(String, IStringExport, Encoding)
Saves content to the given file in the specific format with specific encoding.
(Inherited from SyntaxEdit.)
Public method SaveMacros(Stream)
Saves the macro records to the given stream in xml format.
(Inherited from SyntaxEdit.)
Public method SaveMacros(TextWriter)
Saves the macro records to the given stream in xml format.
(Inherited from SyntaxEdit.)
Public method SaveMacros(String)
Saves the macro records to the given file in xml format.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream)
Saves content of the snippet to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(TextWriter)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, IStringExport)
Saves content to the specific stream in the specific format.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, Encoding)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(TextWriter, IStringExport)
Saves the text content to the specified stream.
(Inherited from SyntaxEdit.)
Public method SaveStream(Stream, IStringExport, Encoding)
Saves content to the specific stream in the specific format and specific encoding.
(Inherited from SyntaxEdit.)
Public method Scale(Single) Obsolete.
Scales the control and any child controls.
(Inherited from Control.)
Public method Scale(SizeF)
Scales the control and all child controls by the specified scaling factor.
(Inherited from Control.)
Public method Scale(Single, Single) Obsolete.
Scales the entire control and any child controls.
(Inherited from Control.)
Public method ScreenToDisplay(Int32, Int32)
Converts given screen coordinates to display coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method | ScreenToDisplay(Int32, Int32, Boolean) | (Inherited from SyntaxEdit.)
Public method ScreenToDisplayX
When implemented by a class, converts given screen coordinates to display coordinate of a character.
(Inherited from SyntaxEdit.)
Public method ScreenToText(Point)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScreenToText(Int32, Int32)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScreenToText(Int32, Int32, Boolean)
Converts given screen coordinates to text coordinates (index of line and character).
(Inherited from SyntaxEdit.)
Public method ScrollLineDown
Scrolls text content one line down.
(Inherited from SyntaxEdit.)
Public method ScrollLineUp
Scrolls text content one line up.
(Inherited from SyntaxEdit.)
Public method | Search | (Inherited from ScriptCodeEdit.)
Public method Select
Activates the control.
(Inherited from Control.)
Public method | SelectAll | (Inherited from ScriptCodeEdit.)
Public method SelectNextControl
Activates the next control.
(Inherited from Control.)
Public method SendToBack
Sends the control to the back of the z-order.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32)
Sets the bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified)
Sets the specified bounds of the control to the specified location and size.
(Inherited from Control.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineHidden(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetLineReadonly(Int32, Boolean)
Sets readonly state for the given line.
(Inherited from SyntaxEdit.)
Public method SetNavigateOptions
Sets navigating options without validating position.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeBorderColor
Indicates whether the BorderColor property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeBorderStyle
Indicates whether the BorderStyle property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeCodeCompletionChars
Indicates whether the CodeCompletionChars property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeCursor
Indicates whether the Cursor property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeFont
Indicates whether the Font property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeIndentOptions
Indicates whether the IndentOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeNavigateOptions
Indicates whether the NavigateOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeReadOnly
Indicates whether the ReadOnly property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeSearchOptions
Indicates whether the SearchOptions property should be persisted.
(Inherited from SyntaxEdit.)
Public method ShouldSerializeText
Indicates whether the Text property should be persisted.
(Inherited from SyntaxEdit.)
Public method Show
Displays the control to the user.
(Inherited from Control.)
Public method ShowCaret
Moves the caret to the specified coordinates.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType)
Shows code completion popup window with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionBox(ICodeCompletionProvider, CodeCompletionType, Point)
Shows code completion popup window with given Provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionButton(ICodeCompletionProvider)
Shows code completion popup window with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionButton(ICodeCompletionProvider, Point, Boolean)
Shows code completion popup window with given Provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, ILexer)
Displays ICodeCompletionHint with given provider at the current position.
(Inherited from SyntaxEdit.)
Public method ShowCodeCompletionHint(ICodeCompletionProvider, Point, ILexer)
Displays ICodeCompletionHint with given provider at the specified position.
(Inherited from SyntaxEdit.)
Public method ShowNotFound
Displays "searched text not found" message box.
(Inherited from SyntaxEdit.)
Public method ShowScrollHint
Displays tooltip indicating destination line when scrolling.
(Inherited from SyntaxEdit.)
Public method SplitViewHorz
Splits control content horizontally.
(Inherited from SyntaxEdit.)
Public method SplitViewVert
Splits control content vertically.
(Inherited from SyntaxEdit.)
Public method StartIncrementalSearch
Enters control to the incremental search state.
(Inherited from SyntaxEdit.)
Public method StartIncrementalSearch(Boolean)
Enters control to the incremental search state.
(Inherited from SyntaxEdit.)
Public method StartMacroRecording
Starts recording the command sequence.
(Inherited from SyntaxEdit.)
Public method StopMacroRecording
Stops recording the command sequence.
(Inherited from SyntaxEdit.)
Public method StorePosition(Point)
Stores given position to stored position list.
(Inherited from SyntaxEdit.)
Public method StorePosition(Point, Boolean)
Stores given position to stored position list.
(Inherited from SyntaxEdit.)
Public method StorePositionWithUndo
Stores given position to stored position list preserving it for undo.
(Inherited from SyntaxEdit.)
Public method SuspendLayout
Temporarily suspends the layout logic for the control.
(Inherited from Control.)
Public method | SwitchStackFrame
Public method | TextStyleAt | (Inherited from SyntaxEdit.)
Public method TextToScreen(Point)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method TextToScreen(Point, Boolean)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method TextToScreen(Int32, Int32)
Converts given text coordinates, index of line and character, to screen coordinates.
(Inherited from SyntaxEdit.)
Public method ToggleMacroRecording
Toggles recording the command sequence.
(Inherited from SyntaxEdit.)
Public method ToString
Returns a String containing the name of the Component, if any. This method should not be overridden.
(Inherited from Component.)
Public method UnBreakLine
Concatenates lines at current position.
(Inherited from SyntaxEdit.)
Public method | Undo | (Inherited from ScriptCodeEdit.)
Public method UnhighlightAll
Unhighlights search results previously highlighted by HighlightAll.
(Inherited from SyntaxEdit.)
Public method UnsplitViewHorz
Removes horizontal split view.
(Inherited from SyntaxEdit.)
Public method UnsplitViewVert
Removes vertical split view.
(Inherited from SyntaxEdit.)
Public method Update
Causes the control to redraw the invalidated regions within its client area.
(Inherited from Control.)
Public method UpdateCaret
Ensures the caret is displayed in the current position.
(Inherited from SyntaxEdit.)
Public method UpdateCursor
Causes current mouse cursor to be updated.
(Inherited from SyntaxEdit.)
Public method | UpdateSyntax | (Inherited from ScriptCodeEdit.)
Public method UpdateView
Updates editor content, caret and pages area.
(Inherited from SyntaxEdit.)
Public method UpdateWordWrap
Re-wraps all lines in the text.
(Inherited from SyntaxEdit.)
Public method UpdateWordWrap(Int32, Int32)
Re-wraps lines in the text within specific scope.
(Inherited from SyntaxEdit.)
Public method ValidatePosition
Validates given position within control's text content.
(Inherited from SyntaxEdit.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanFindDeclaration | (Defined by CodeEditExtensions.)
Public Extension Method | Document | (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindImplementations | (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterDefaultAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterNamespaces | (Defined by CodeEditExtensions.)
Public Extension Method | SetFileNameAndProject | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Top
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.BreakpointDeleted Method

DebugCodeEditBreakpointDeleted Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BreakpointDeleted(
    Breakpoint breakpoint
)
Public Sub BreakpointDeleted (
    breakpoint As Breakpoint
)
public:
virtual void BreakpointDeleted(
    Breakpoint^ breakpoint
) sealed
abstract BreakpointDeleted :
        breakpoint : Breakpoint -> unit
override BreakpointDeleted :
        breakpoint : Breakpoint -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint

Implements

IDebugEditBreakpointDeleted(Breakpoint)
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.BreakpointStateChanged Method

DebugCodeEditBreakpointStateChanged Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BreakpointStateChanged(
    Breakpoint breakpoint
)
Public Sub BreakpointStateChanged (
    breakpoint As Breakpoint
)
public:
virtual void BreakpointStateChanged(
    Breakpoint^ breakpoint
) sealed
abstract BreakpointStateChanged :
        breakpoint : Breakpoint -> unit
override BreakpointStateChanged :
        breakpoint : Breakpoint -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint

Implements

IDebugEditBreakpointStateChanged(Breakpoint)
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.ClearDebugStyles Method

DebugCodeEditClearDebugStyles Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearDebugStyles(
    ExecutionPosition executionPos
)
Public Sub ClearDebugStyles (
    executionPos As ExecutionPosition
)
public:
virtual void ClearDebugStyles(
    ExecutionPosition^ executionPos
) sealed
abstract ClearDebugStyles :
        executionPos : ExecutionPosition -> unit
override ClearDebugStyles :
        executionPos : ExecutionPosition -> unit

Parameters

executionPos
Type: Alternet.Scripter.DebuggerExecutionPosition

Implements

IDebugEditClearDebugStyles(ExecutionPosition)
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.ClearStackFrame Method

DebugCodeEditClearStackFrame Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearStackFrame(
    StackFrame stackFrame
)
Public Sub ClearStackFrame (
    stackFrame As StackFrame
)
public:
virtual void ClearStackFrame(
    StackFrame^ stackFrame
) sealed
abstract ClearStackFrame :
        stackFrame : StackFrame -> unit
override ClearStackFrame :
        stackFrame : StackFrame -> unit

Parameters

stackFrame
Type: Alternet.Scripter.DebuggerStackFrame

Implements

IDebugEditClearStackFrame(StackFrame)
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.ExecutionStopped Method

DebugCodeEditExecutionStopped Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ExecutionStopped(
    ExecutionPosition executionPos
)
Public Sub ExecutionStopped (
    executionPos As ExecutionPosition
)
public:
virtual void ExecutionStopped(
    ExecutionPosition^ executionPos
) sealed
abstract ExecutionStopped :
        executionPos : ExecutionPosition -> unit
override ExecutionStopped :
        executionPos : ExecutionPosition -> unit

Parameters

executionPos
Type: Alternet.Scripter.DebuggerExecutionPosition

Implements

IDebugEditExecutionStopped(ExecutionPosition)
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.Localize Method

DebugCodeEditLocalize Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Localize()
Public Sub Localize
public:
virtual void Localize() sealed
abstract Localize : unit -> unit
override Localize : unit -> unit

Implements

IDebugEditLocalize
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.MakeVisible Method

DebugCodeEditMakeVisible Method
Overload List
 | Name | Description
Public method | MakeVisible(Point) | Scrolls the control's content, if necessary, to ensure a specified text position is in view. (Inherited from SyntaxEdit.)
Public method | MakeVisible(Point, Boolean) | (Overrides SyntaxEditMakeVisible(Point, Boolean).)
Top
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.MakeVisible Method (Point, Boolean)

DebugCodeEditMakeVisible Method (Point, Boolean)

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void MakeVisible(
    Point position,
    bool centerLine
)
Public Overrides Sub MakeVisible (
    position As Point,
    centerLine As Boolean
)
public:
virtual void MakeVisible(
    Point position,
    bool centerLine
) override
abstract MakeVisible :
        position : Point *
        centerLine : bool -> unit
override MakeVisible :
        position : Point *
        centerLine : bool -> unit

Parameters

position
Type: System.DrawingPoint
centerLine
Type: SystemBoolean

Implements

IScriptEditMakeVisible(Point, Boolean)
ISyntaxEditMakeVisible(Point, Boolean)
See Also

Reference

DebugCodeEdit Class
MakeVisible Overload
Alternet.Scripter.Integration Namespace


DebugCodeEdit.SwitchStackFrame Method

DebugCodeEditSwitchStackFrame Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SwitchStackFrame(
    StackFrame stackFrame,
    ExecutionPosition executionPos
)
Public Sub SwitchStackFrame (
    stackFrame As StackFrame,
    executionPos As ExecutionPosition
)
public:
virtual void SwitchStackFrame(
    StackFrame^ stackFrame,
    ExecutionPosition^ executionPos
) sealed
abstract SwitchStackFrame :
        stackFrame : StackFrame *
        executionPos : ExecutionPosition -> unit
override SwitchStackFrame :
        stackFrame : StackFrame *
        executionPos : ExecutionPosition -> unit

Parameters

stackFrame
Type: Alternet.Scripter.DebuggerStackFrame
executionPos
Type: Alternet.Scripter.DebuggerExecutionPosition

Implements

IDebugEditSwitchStackFrame(StackFrame, ExecutionPosition)
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit Properties

DebugCodeEdit Properties

The DebugCodeEdit type exposes the following members.

Properties
 | Name | Description
Public property | AcceptReturns | Gets or set a boolean value that indicates whether Enter key should be accepted by Edit control as input key. (Inherited from SyntaxEdit.)
Public property | AcceptTabs | Gets or set a boolean value that indicates whether TAB key should be accepted by Edit control as input key. (Inherited from SyntaxEdit.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveOutlineRange | Gets currently highlighted outlined range. (Inherited from SyntaxEdit.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from SyntaxEdit.)
Public property | AllowedActions | Gets or sets a allowed actions.
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoCorrectDelimiters | Gets or sets an array of chars that used as word delimiters. (Inherited from SyntaxEdit.)
Public property | AutoCorrection | Gets or sets a boolean value indicating whether to auto correct words being typed. (Inherited from SyntaxEdit.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderColor | Gets or sets the border color for the Edit control. (Inherited from SyntaxEdit.)
Public property | BorderStyle | Gets or sets the border style for the Edit control. (Inherited from SyntaxEdit.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Braces | Represents an object that implements IEditBraceMatching interface allowing to change appearance of matching braces within the control. (Inherited from SyntaxEdit.)
Public property | CanCopy | (Inherited from ScriptCodeEdit.)
Public property | CanCut | (Inherited from ScriptCodeEdit.)
Public property | CanDelete | (Inherited from ScriptCodeEdit.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanPaste | (Inherited from ScriptCodeEdit.)
Public property | CanRedo | (Inherited from ScriptCodeEdit.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | CanUndo | (Inherited from ScriptCodeEdit.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CharsInWidth | Returns number of characters painted with current font that will fit into control's client area. (Inherited from SyntaxEdit.)
Public property | ClientArea | Gets the rectangle that represents the client area of the Edit control. Non-client areas area like rulers are excluded. (Inherited from SyntaxEdit.)
Public property | ClientHeight | Gets the width of the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | ClientRect | Gets the rectangle that represents the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ClientWidth | Gets the width of the client area of the Edit control. (Inherited from SyntaxEdit.)
Public property | CodeCompletionBox | Represents object that specifies a popup window that contains code completion information presented in the form of list. (Inherited from SyntaxEdit.)
Public property | CodeCompletionButton | Represents object that specifies a popup window that contains code completion information presented in the form of list. (Inherited from SyntaxEdit.)
Public property | CodeCompletionChars | Represents a collection of characters that initializes a code completion procedure when typing in the editor. (Inherited from SyntaxEdit.)
Public property | CodeCompletionHint | Represents object that specifies a popup window that contains code completion information presented in the form of the tooltip. (Inherited from SyntaxEdit.)
Public property | CodeCompletionMode | Gets or sets code completion box mode. (Inherited from SyntaxEdit.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentBlockRange | Gets currently highlighted block range. (Inherited from SyntaxEdit.)
Public property | CurrentChar | (Inherited from ScriptCodeEdit.)
Public property | CurrentLine | (Inherited from ScriptCodeEdit.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from SyntaxEdit.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataTipsEnabled | Gets or sets a boolean value indicating whether DataTip functionality is enabled.
Public property | Debugger |
Public property | DefaultMenu | Gets or sets default context menu for the editor control. (Inherited from SyntaxEdit.)
Public property | DisplayLines | Represents the object that implements IDisplayStrings interface containing collection of lines to be drawn in the control. (Inherited from SyntaxEdit.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | EditMargin | Represents an object that implements IMargin interface and specifies appearance of vertical line drawn over the text and used to mark some limit, for example, of the maximum string length allowed. (Inherited from SyntaxEdit.)
Public property | EffectiveVisualTheme | Gets current visual theme. (Inherited from SyntaxEdit.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EventHandlers | Represents object that holds EventHandlers containing list of keys with attached actions. (Inherited from SyntaxEdit.)
Public property | FileName | (Inherited from ScriptCodeEdit.)
Public property | FirstSearch | Gets or sets a value indicating whether control launches text search at first. (Inherited from SyntaxEdit.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from SyntaxEdit.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GotoLineDialog | Gets or sets a dialog prompting for index of the line you need to locate. (Inherited from SyntaxEdit.)
Public property | Gutter | Represents object that implements IGutter interface containing methods and properties necessary to operate with gutter at the left size of the control. (Inherited from SyntaxEdit.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideCaret | Gets or sets a value indicating whether the control should display caret when it has input focus. (Inherited from SyntaxEdit.)
Public property | HighlightCurrentBlock | Specifies that edit control should highlight current block. (Inherited from SyntaxEdit.)
Public property | HighlightMatchingBlocks | Specifies that edit control should highlight begin/end blocks. (Inherited from SyntaxEdit.)
Public property | HighlightReferences | Specifies that edit control should highlight found references. (Inherited from SyntaxEdit.)
Public property | HighlightSearchResults | Indicates whether search results are highlighted while the search dialog is open. (Inherited from SyntaxEdit.)
Public property | HorzSplitEdit | Represents horizontal split view control. (Inherited from SyntaxEdit.)
Public property | HorzSplitter | Represents a horizontal Splitter control allowing to split Edit content horizontally. (Inherited from SyntaxEdit.)
Public property | HyperText | Represents object that implements IEditHyperText interface allowing to customize appearance and behaviour of hypertext sections within the control. (Inherited from SyntaxEdit.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IncrementalSearchString | Return text to search if class is in incremental search state; otherwise return empty string. (Inherited from SyntaxEdit.)
Public property | InCycledSearch | Indicates whether control is in incremental search state. (Inherited from SyntaxEdit.)
Public property | IndentOptions | Gets or sets Alternet.Editor.IndentOptions for this class, allowing to customize behavior of Edit control when user presses Enter to insert new text line. (Inherited from SyntaxEdit.)
Public property | InIncrementalSearch | Indicates whether control is in incremental search state. (Inherited from SyntaxEdit.)
Public property | InnerTextSource | Gets inner text source (Inherited from SyntaxEdit.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsCodeCompletionWindowFocused | Indicates whether ICodeCompletionWindow has focus. (Inherited from SyntaxEdit.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsSearchFocused | Gets a boolean value indicating whether search dialog box has input focus. (Inherited from SyntaxEdit.)
Public property | KeepCaretOnLostFocus | Keeps caret in visible state even Edit control lost focus. (Inherited from SyntaxEdit.)
Public property | KeyList | Represents object that implements IKeyList containing list of keys with attached actions, which executed by key pressure. (Inherited from SyntaxEdit.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | (Inherited from ScriptCodeEdit.)
Public property | Lines | Represents object that implements ITextStrings interface containing collection of strings determining control's content. (Inherited from SyntaxEdit.)
Public property | LineSeparator | Represents an object that implements ILineSeparator interface containing methods and properties necessary to separate lines and highlight current line within the control. (Inherited from SyntaxEdit.)
Public property | LinesInHeight | Determines how many lines can fit into control's client area. (Inherited from SyntaxEdit.)
Public property | LineSpace | Gets or sets line space between individual lines in the Edit control. (Inherited from SyntaxEdit.)
Public property | LineStyles | Represents an object that implements IEditLineStyles interface holding collection of IEditLineStyle objects each of them determines particular style of the line in the control. (Inherited from SyntaxEdit.)
Public property | LineTerminator | Gets or sets a string value that terminates line. (Inherited from SyntaxEdit.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | MacroRecording | Gets or sets a boolean value indicating whether Edit control should record sequence of keyboard commands. (Inherited from SyntaxEdit.)
Public property | MacroRecords | Represents an array containing keyboard commands. (Inherited from SyntaxEdit.)
Public property | MacroSuspendend | Gets or sets a boolean value indicating whether recording is suspended. (Inherited from SyntaxEdit.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MaxLength | Specifies the maximum number of characters that can be entered into the edit control. (Inherited from SyntaxEdit.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Modified | Gets or sets a value indicating whether the control's text content is modified. (Inherited from SyntaxEdit.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavigateOptions | Gets or sets navigating options. (Inherited from SyntaxEdit.)
Public property | OpenSharedEditorFunc | When implemented by a class, gets or sets function that open ISyntaxEdit instance in multi-document environment. (Inherited from SyntaxEdit.)
Public property | Outlining | Represents an object that implements IOutlining interface that specifies appearance and behaviour of outline sections within the control. (Inherited from SyntaxEdit.)
Public property | Overwrite | Gets or sets a value indicating whether the inserted text overwrites existing text. (Inherited from SyntaxEdit.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Pages | Represents an object that implements IEditPage interface containing properties and methods representing collection of particular pages. (Inherited from SyntaxEdit.)
Public property | Painter | Represents an object that implements IPainter interface used to draw control's text. (Inherited from SyntaxEdit.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | Position | Gets or sets current position within the control's text content. (Inherited from SyntaxEdit.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | PrevPosition | Gets previous position within the control's text content. (Inherited from SyntaxEdit.)
Public property | Printing | Represents an object that implements IPrinting interface allowing to perform various printing actions such as print, preview document, and setup print options. (Inherited from SyntaxEdit.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | ReadOnly | Gets or sets a value indicating whether the control's content is read-only. (Inherited from SyntaxEdit.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | Scrolling | Represents an object that implements IScrolling interface containing properties and methods that describe scrolling behaviour of the control. (Inherited from SyntaxEdit.)
Public property | SearchDialog | Gets or sets a dialog box allowing to search for the text or replace it. (Inherited from SyntaxEdit.)
Public property | SearchDialogAppearance | (Inherited from SyntaxEdit.)
Public property | SearchGlobal | Gets or sets a value indicating whether search should be global. (Inherited from SyntaxEdit.)
Public property | SearchLen | Represents length of the last found text. (Inherited from SyntaxEdit.)
Public property | SearchOptions | Gets or sets a value that defines search and replace options. (Inherited from SyntaxEdit.)
Public property | SearchPos | Gets or sets a value that represents position of the last found text. (Inherited from SyntaxEdit.)
Public property | Selection | Represents an object that implements ISelection interface. This object represents various properties and methods to manipulate text selection, such as copy, paste and drag selected text. (Inherited from SyntaxEdit.)
Public property | SingleLineMode | Gets or sets a value indicating whether the control accepts only one line of the text. (Inherited from SyntaxEdit.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Source | (Inherited from ScriptCodeEdit.)
Public property | Spelling | Represents object that implements IEditSpelling interface containing properties and methods to check control's content spelling and highlight misspelled words. (Inherited from SyntaxEdit.)
Public property | Status | (Inherited from ScriptCodeEdit.)
Public property | StatusText | Obsolete. (Inherited from ScriptCodeEdit.)
Public property | Strings | Represents Lines property in the form of array of strings. (Inherited from SyntaxEdit.)
Public property | SyntaxPaint | Represents an object that implements IEditSyntaxPaint interface containing properties and methods used to draw editor content. (Inherited from SyntaxEdit.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the string collection as a single string with the individual lines delimited by carriage returns. (Inherited from SyntaxEdit.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | Transparent | Gets or sets a boolean value that indicates whether Edit control should draw its background. (Inherited from SyntaxEdit.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from SyntaxEdit.)
Public property | UseDefaultMenu | Indicates whether edit control should use built in popup menu. (Inherited from SyntaxEdit.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VertSplitEdit | Represents an vertical split view control. (Inherited from SyntaxEdit.)
Public property | VertSplitter | Represents a vertical Splitter control allowing to split Edit content vertically. (Inherited from SyntaxEdit.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisualTheme | Gets or sets visual theme for the editor. (Inherited from SyntaxEdit.)
Public property | VisualThemeType | Gets or sets visual theme type for the editor. (Inherited from SyntaxEdit.)
Public property | WhiteSpace | Represents an object that implements IWhiteSpace interface. This object specifies appearance of white space characters, as well as End-of-line and End-of-file marks. (Inherited from SyntaxEdit.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | WordWrap | Gets or sets a value indicating whether control automatically wraps words to the beginning of the next line when necessary. (Inherited from SyntaxEdit.)
Public property | WrapAtMargin | Gets or sets a value indicating whether control automatically wraps words at margin position. (Inherited from SyntaxEdit.)
Public property | WrapMargin | Gets position of the wrapping margin. (Inherited from SyntaxEdit.)
Top
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.AllowedActions Property

DebugCodeEditAllowedActions Property
Gets or sets a allowed actions.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public AllowedActions AllowedActions { get; set; }
Public Property AllowedActions As AllowedActions
    Get
    Set
public:
virtual property AllowedActions AllowedActions {
    AllowedActions get () sealed;
    void set (AllowedActions value) sealed;
}
abstract AllowedActions : AllowedActions with get, set
override AllowedActions : AllowedActions with get, set

Property Value

Type: AllowedActions

Implements

IDebugEditAllowedActions
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.DataTipsEnabled Property

DebugCodeEditDataTipsEnabled Property
Gets or sets a boolean value indicating whether DataTip functionality is enabled.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DataTipsEnabled { get; set; }
Public Property DataTipsEnabled As Boolean
    Get
    Set
public:
property bool DataTipsEnabled {
    bool get ();
    void set (bool value);
}
member DataTipsEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.Debugger Property

DebugCodeEditDebugger Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
virtual property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get () sealed;
    void set (IScriptDebuggerBase^ value) sealed;
}
abstract Debugger : IScriptDebuggerBase with get, set
override Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase

Implements

IDebugEditDebugger
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit Events

DebugCodeEdit Events

The DebugCodeEdit type exposes the following members.

Events
 | Name | Description
Public event | AddToWatchClick | Occurs when user clicks on the local to add it to the watch window.
Public event | AutoCorrect | Occurs when control tries to auto correct word being typed. (Inherited from SyntaxEdit.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | BreakpointToggle |
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | CheckHyperText | Occurs when a control needs checking whether some string represents hypertext. (Inherited from SyntaxEdit.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when control draws its content. (Inherited from SyntaxEdit.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawHeader | Occurs when header or footer part of each page is drawing. (Inherited from SyntaxEdit.)
Public event | DrawUserMargin | Occurs when user margin part of each line is drawing. (Inherited from SyntaxEdit.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FindAllImplementations |
Public event | FindAllReferences |
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | GotoDefinition |
Public event | GutterClick | Occurs when the gutter part of Edit control is clicked. (Inherited from SyntaxEdit.)
Public event | GutterDblClick | Occurs when the gutter part of Edit control is double-clicked. (Inherited from SyntaxEdit.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HorizontalScroll | Occurs when control scrolls its content in horizontal direction. This can be caused by dragging horizontal scroll thumb, or caret moving. (Inherited from SyntaxEdit.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | JumpToUrl | Occurs when user attempts to jump to url. (Inherited from SyntaxEdit.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | ModifiedChanged | Occurs when modified state is changed. (Inherited from SyntaxEdit.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NeedCodeCompletion | Occurs when code completion window is to be displayed. (Inherited from SyntaxEdit.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | PaintBackground | Occurs when Edit control should paint its background in transparent mode. (Inherited from SyntaxEdit.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | ParserChanged | (Inherited from ScriptCodeEdit.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | PromptOnReplace | Occurs when replace dialog prompts on replace action. (Inherited from SyntaxEdit.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | ScrollButtonClick | Occurs when some scrolling button is clicked. (Inherited from SyntaxEdit.)
Public event | SelectionChanged | Occurs when selection bounds are changed. (Inherited from SyntaxEdit.)
Public event | SetNextStatement |
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | SourceChanged | Occurs when source changes. (Inherited from SyntaxEdit.)
Public event | SourceStateChanged | Occurs when text Source's state is changed, for example when caret position moved, text edited, amount of lines changed, lexer changed, etc. (Inherited from SyntaxEdit.)
Public event | SplitHorz | Occurs when user splits Edit control horizontally. (Inherited from SyntaxEdit.)
Public event | SplitVert | Occurs when user splits Edit control vertically. (Inherited from SyntaxEdit.)
Public event | StatusChanged | (Inherited from ScriptCodeEdit.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from ScriptCodeEdit.)
Public event | UndoEvent | Occurs when undo/redo operation performed. (Inherited from SyntaxEdit.)
Public event | UnsplitHorz | Occurs when horizontal split view is removed. (Inherited from SyntaxEdit.)
Public event | UnsplitVert | Occurs when vertical split view is removed. (Inherited from SyntaxEdit.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VerticalScroll | Occurs when control scrolls its content in vertical direction. This can be caused by dragging vertical scroll thumb, or caret moving. (Inherited from SyntaxEdit.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Public event | WordSpell | Occurs when spelling of some word within the text needs checking. (Inherited from SyntaxEdit.)
Top
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.AddToWatchClick Event

DebugCodeEditAddToWatchClick Event
Occurs when user clicks on the local to add it to the watch window.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<AddToWatchClickEventArgs> AddToWatchClick
Public Event AddToWatchClick As EventHandler(Of AddToWatchClickEventArgs)
public:
virtual  event EventHandler<AddToWatchClickEventArgs^>^ AddToWatchClick {
    void add (EventHandler<AddToWatchClickEventArgs^>^ value);
    void remove (EventHandler<AddToWatchClickEventArgs^>^ value);
}
abstract AddToWatchClick : IEvent<EventHandler<AddToWatchClickEventArgs>,
    AddToWatchClickEventArgs>
override AddToWatchClick : IEvent<EventHandler<AddToWatchClickEventArgs>,
    AddToWatchClickEventArgs>

Value

Type: SystemEventHandlerAddToWatchClickEventArgs

Implements

IDebugEditAddToWatchClick
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.BreakpointToggle Event

DebugCodeEditBreakpointToggle Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler BreakpointToggle
Public Event BreakpointToggle As EventHandler
public:
virtual  event EventHandler^ BreakpointToggle {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BreakpointToggle : IEvent<EventHandler,
    EventArgs>
override BreakpointToggle : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IDebugEditBreakpointToggle
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.FindAllImplementations Event

DebugCodeEditFindAllImplementations Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler FindAllImplementations
Public Event FindAllImplementations As EventHandler
public:
virtual  event EventHandler^ FindAllImplementations {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FindAllImplementations : IEvent<EventHandler,
    EventArgs>
override FindAllImplementations : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IDebugEditFindAllImplementations
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.FindAllReferences Event

DebugCodeEditFindAllReferences Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler FindAllReferences
Public Event FindAllReferences As EventHandler
public:
virtual  event EventHandler^ FindAllReferences {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FindAllReferences : IEvent<EventHandler,
    EventArgs>
override FindAllReferences : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IDebugEditFindAllReferences
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.GotoDefinition Event

DebugCodeEditGotoDefinition Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler GotoDefinition
Public Event GotoDefinition As EventHandler
public:
virtual  event EventHandler^ GotoDefinition {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract GotoDefinition : IEvent<EventHandler,
    EventArgs>
override GotoDefinition : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IDebugEditGotoDefinition
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEdit.SetNextStatement Event

DebugCodeEditSetNextStatement Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SetNextStatement
Public Event SetNextStatement As EventHandler
public:
virtual  event EventHandler^ SetNextStatement {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SetNextStatement : IEvent<EventHandler,
    EventArgs>
override SetNextStatement : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IDebugEditSetNextStatement
See Also

Reference

DebugCodeEdit Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer Class

DebugCodeEditContainer Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IntegrationDebugCodeEditContainer

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebugCodeEditContainer : IDebugEditContainer
Public Class DebugCodeEditContainer
    Implements IDebugEditContainer
public ref class DebugCodeEditContainer : IDebugEditContainer
type DebugCodeEditContainer =
    class
        interface IDebugEditContainer
    end

The DebugCodeEditContainer type exposes the following members.

Constructors
 | Name | Description
Public method | DebugCodeEditContainer | Initializes a new instance of the DebugCodeEditContainer class
Top
Methods
 | Name | Description
Public method | CloseFile |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryActivateEditor |
Public method | TryGetEditorByFileName |
Top
Properties
 | Name | Description
Public property | ActiveEditor |
Public property | Debugger |
Public property | Editors |
Top
Events
 | Name | Description
Public event | CommandExecuted |
Public event | EditorRequested |
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


DebugCodeEditContainer Constructor

DebugCodeEditContainer Constructor
Initializes a new instance of the DebugCodeEditContainer class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebugCodeEditContainer(
    TabControl tabControl
)
Public Sub New (
    tabControl As TabControl
)
public:
DebugCodeEditContainer(
    TabControl^ tabControl
)
new :
        tabControl : TabControl -> DebugCodeEditContainer

Parameters

tabControl
Type: System.Windows.FormsTabControl
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer Methods

DebugCodeEditContainer Methods

The DebugCodeEditContainer type exposes the following members.

Methods
 | Name | Description
Public method | CloseFile |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryActivateEditor |
Public method | TryGetEditorByFileName |
Top
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer.CloseFile Method

DebugCodeEditContainerCloseFile Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CloseFile(
    string fileName
)
Public Sub CloseFile (
    fileName As String
)
public:
virtual void CloseFile(
    String^ fileName
) sealed
abstract CloseFile :
        fileName : string -> unit
override CloseFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString

Implements

IDebugEditContainerCloseFile(String)
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer.TryActivateEditor Method

DebugCodeEditContainerTryActivateEditor Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDebugEdit TryActivateEditor(
    string fileName
)
Public Function TryActivateEditor (
    fileName As String
) As IDebugEdit
public:
virtual IDebugEdit^ TryActivateEditor(
    String^ fileName
) sealed
abstract TryActivateEditor :
        fileName : string -> IDebugEdit
override TryActivateEditor :
        fileName : string -> IDebugEdit

Parameters

fileName
Type: SystemString

Return Value

Type: IDebugEdit

Implements

IDebugEditContainerTryActivateEditor(String)
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer.TryGetEditorByFileName Method

DebugCodeEditContainerTryGetEditorByFileName Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDebugEdit TryGetEditorByFileName(
    string fileName
)
Public Function TryGetEditorByFileName (
    fileName As String
) As IDebugEdit
public:
virtual IDebugEdit^ TryGetEditorByFileName(
    String^ fileName
) sealed
abstract TryGetEditorByFileName :
        fileName : string -> IDebugEdit
override TryGetEditorByFileName :
        fileName : string -> IDebugEdit

Parameters

fileName
Type: SystemString

Return Value

Type: IDebugEdit

Implements

IDebugEditContainerTryGetEditorByFileName(String)
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer Properties

DebugCodeEditContainer Properties

The DebugCodeEditContainer type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEditor |
Public property | Debugger |
Public property | Editors |
Top
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer.ActiveEditor Property

DebugCodeEditContainerActiveEditor Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDebugEdit ActiveEditor { get; }
Public ReadOnly Property ActiveEditor As IDebugEdit
    Get
public:
virtual property IDebugEdit^ ActiveEditor {
    IDebugEdit^ get () sealed;
}
abstract ActiveEditor : IDebugEdit with get
override ActiveEditor : IDebugEdit with get

Property Value

Type: IDebugEdit

Implements

IDebugEditContainerActiveEditor
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer.Debugger Property

DebugCodeEditContainerDebugger Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
virtual property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get () sealed;
    void set (IScriptDebuggerBase^ value) sealed;
}
abstract Debugger : IScriptDebuggerBase with get, set
override Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase

Implements

IDebugEditContainerDebugger
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer.Editors Property

DebugCodeEditContainerEditors Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection<IDebugEdit> Editors { get; }
Public ReadOnly Property Editors As IReadOnlyCollection(Of IDebugEdit)
    Get
public:
virtual property IReadOnlyCollection<IDebugEdit^>^ Editors {
    IReadOnlyCollection<IDebugEdit^>^ get () sealed;
}
abstract Editors : IReadOnlyCollection<IDebugEdit> with get
override Editors : IReadOnlyCollection<IDebugEdit> with get

Property Value

Type: IReadOnlyCollectionIDebugEdit

Implements

IDebugEditContainerEditors
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer Events

DebugCodeEditContainer Events

The DebugCodeEditContainer type exposes the following members.

Events
 | Name | Description
Public event | CommandExecuted |
Public event | EditorRequested |
Top
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer.CommandExecuted Event

DebugCodeEditContainerCommandExecuted Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebugEditCommandExecutedEventArgs> CommandExecuted
Public Event CommandExecuted As EventHandler(Of DebugEditCommandExecutedEventArgs)
public:
virtual  event EventHandler<DebugEditCommandExecutedEventArgs^>^ CommandExecuted {
    void add (EventHandler<DebugEditCommandExecutedEventArgs^>^ value);
    void remove (EventHandler<DebugEditCommandExecutedEventArgs^>^ value);
}
abstract CommandExecuted : IEvent<EventHandler<DebugEditCommandExecutedEventArgs>,
    DebugEditCommandExecutedEventArgs>
override CommandExecuted : IEvent<EventHandler<DebugEditCommandExecutedEventArgs>,
    DebugEditCommandExecutedEventArgs>

Value

Type: SystemEventHandlerDebugEditCommandExecutedEventArgs

Implements

IDebugEditContainerCommandExecuted
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugCodeEditContainer.EditorRequested Event

DebugCodeEditContainerEditorRequested Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DebugEditRequestedEventArgs> EditorRequested
Public Event EditorRequested As EventHandler(Of DebugEditRequestedEventArgs)
public:
virtual  event EventHandler<DebugEditRequestedEventArgs^>^ EditorRequested {
    void add (EventHandler<DebugEditRequestedEventArgs^>^ value);
    void remove (EventHandler<DebugEditRequestedEventArgs^>^ value);
}
abstract EditorRequested : IEvent<EventHandler<DebugEditRequestedEventArgs>,
    DebugEditRequestedEventArgs>
override EditorRequested : IEvent<EventHandler<DebugEditRequestedEventArgs>,
    DebugEditRequestedEventArgs>

Value

Type: SystemEventHandlerDebugEditRequestedEventArgs

Implements

IDebugEditContainerEditorRequested
See Also

Reference

DebugCodeEditContainer Class
Alternet.Scripter.Integration Namespace


DebugEditCommand Enumeration

DebugEditCommand Enumeration

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DebugEditCommand
Public Enumeration DebugEditCommand
public enum class DebugEditCommand
type DebugEditCommand
Members
Member name | Value | Description
FindReferences | 0 |
FindImplementations | 1 |
GotoDefinition | 2 |
See Also

Reference

Alternet.Scripter.Integration Namespace


DebugEditCommandExecutedEventArgs Class

DebugEditCommandExecutedEventArgs Class
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.IntegrationDebugEditCommandExecutedEventArgs

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebugEditCommandExecutedEventArgs : EventArgs
Public Class DebugEditCommandExecutedEventArgs
    Inherits EventArgs
public ref class DebugEditCommandExecutedEventArgs : public EventArgs
type DebugEditCommandExecutedEventArgs =
    class
        inherit EventArgs
    end

The DebugEditCommandExecutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DebugEditCommandExecutedEventArgs | Initializes a new instance of the DebugEditCommandExecutedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Command |
Public property | DebugEdit |
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


DebugEditCommandExecutedEventArgs Constructor

DebugEditCommandExecutedEventArgs Constructor
Initializes a new instance of the DebugEditCommandExecutedEventArgs class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebugEditCommandExecutedEventArgs(
    IDebugEdit editor,
    DebugEditCommand command
)
Public Sub New (
    editor As IDebugEdit,
    command As DebugEditCommand
)
public:
DebugEditCommandExecutedEventArgs(
    IDebugEdit^ editor,
    DebugEditCommand command
)
new :
        editor : IDebugEdit *
        command : DebugEditCommand -> DebugEditCommandExecutedEventArgs

Parameters

editor
Type: Alternet.Scripter.IntegrationIDebugEdit
command
Type: Alternet.Scripter.IntegrationDebugEditCommand
See Also

Reference

DebugEditCommandExecutedEventArgs Class
Alternet.Scripter.Integration Namespace


DebugEditCommandExecutedEventArgs Methods

DebugEditCommandExecutedEventArgs Methods

The DebugEditCommandExecutedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebugEditCommandExecutedEventArgs Class
Alternet.Scripter.Integration Namespace


DebugEditCommandExecutedEventArgs Properties

DebugEditCommandExecutedEventArgs Properties

The DebugEditCommandExecutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | DebugEdit |
Top
See Also

Reference

DebugEditCommandExecutedEventArgs Class
Alternet.Scripter.Integration Namespace


DebugEditCommandExecutedEventArgs.Command Property

DebugEditCommandExecutedEventArgsCommand Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebugEditCommand Command { get; set; }
Public Property Command As DebugEditCommand
    Get
    Set
public:
property DebugEditCommand Command {
    DebugEditCommand get ();
    void set (DebugEditCommand value);
}
member Command : DebugEditCommand with get, set

Property Value

Type: DebugEditCommand
See Also

Reference

DebugEditCommandExecutedEventArgs Class
Alternet.Scripter.Integration Namespace


DebugEditCommandExecutedEventArgs.DebugEdit Property

DebugEditCommandExecutedEventArgsDebugEdit Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDebugEdit DebugEdit { get; set; }
Public Property DebugEdit As IDebugEdit
    Get
    Set
public:
property IDebugEdit^ DebugEdit {
    IDebugEdit^ get ();
    void set (IDebugEdit^ value);
}
member DebugEdit : IDebugEdit with get, set

Property Value

Type: IDebugEdit
See Also

Reference

DebugEditCommandExecutedEventArgs Class
Alternet.Scripter.Integration Namespace


DebugEditRequestedEventArgs Class

DebugEditRequestedEventArgs Class
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.IntegrationDebugEditRequestedEventArgs

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebugEditRequestedEventArgs : EventArgs
Public Class DebugEditRequestedEventArgs
    Inherits EventArgs
public ref class DebugEditRequestedEventArgs : public EventArgs
type DebugEditRequestedEventArgs =
    class
        inherit EventArgs
    end

The DebugEditRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DebugEditRequestedEventArgs | Initializes a new instance of the DebugEditRequestedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DebugEdit |
Public property | FileName |
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


DebugEditRequestedEventArgs Constructor

DebugEditRequestedEventArgs Constructor
Initializes a new instance of the DebugEditRequestedEventArgs class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebugEditRequestedEventArgs(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
DebugEditRequestedEventArgs(
    String^ fileName
)
new :
        fileName : string -> DebugEditRequestedEventArgs

Parameters

fileName
Type: SystemString
See Also

Reference

DebugEditRequestedEventArgs Class
Alternet.Scripter.Integration Namespace


DebugEditRequestedEventArgs Methods

DebugEditRequestedEventArgs Methods

The DebugEditRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebugEditRequestedEventArgs Class
Alternet.Scripter.Integration Namespace


DebugEditRequestedEventArgs Properties

DebugEditRequestedEventArgs Properties

The DebugEditRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DebugEdit |
Public property | FileName |
Top
See Also

Reference

DebugEditRequestedEventArgs Class
Alternet.Scripter.Integration Namespace


DebugEditRequestedEventArgs.DebugEdit Property

DebugEditRequestedEventArgsDebugEdit Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDebugEdit DebugEdit { get; set; }
Public Property DebugEdit As IDebugEdit
    Get
    Set
public:
property IDebugEdit^ DebugEdit {
    IDebugEdit^ get ();
    void set (IDebugEdit^ value);
}
member DebugEdit : IDebugEdit with get, set

Property Value

Type: IDebugEdit
See Also

Reference

DebugEditRequestedEventArgs Class
Alternet.Scripter.Integration Namespace


DebugEditRequestedEventArgs.FileName Property

DebugEditRequestedEventArgsFileName Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

DebugEditRequestedEventArgs Class
Alternet.Scripter.Integration Namespace


DebuggerPanelKinds Enumeration

DebuggerPanelKinds Enumeration

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum DebuggerPanelKinds
<FlagsAttribute>
Public Enumeration DebuggerPanelKinds
[FlagsAttribute]
public enum class DebuggerPanelKinds
[<FlagsAttribute>]
type DebuggerPanelKinds
Members
Member name | Value | Description
None | 0 |
Breakpoints | 1 |
CallStack | 2 |
Locals | 4 |
Watches | 8 |
Threads | 16 |
Errors | 32 |
Output | 64 |
FindResults | 128 |
All | 255 |
See Also

Reference

Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl Class

DebuggerPanelsTabControl Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTabControl
Alternet.Scripter.IntegrationDebuggerPanelsTabControl

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebuggerPanelsTabControl : TabControl,
    IDebuggerPanels
Public Class DebuggerPanelsTabControl
    Inherits TabControl
    Implements IDebuggerPanels
public ref class DebuggerPanelsTabControl : public TabControl,
    IDebuggerPanels
type DebuggerPanelsTabControl =
    class
        inherit TabControl
        interface IDebuggerPanels
    end

The DebuggerPanelsTabControl type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerPanelsTabControl | Initializes a new instance of the DebuggerPanelsTabControl class
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DeselectTab(Int32) | Makes the tab following the tab with the specified index the current tab. (Inherited from TabControl.)
Public method | DeselectTab(TabPage) | Makes the tab following the specified TabPage the current tab. (Inherited from TabControl.)
Public method | DeselectTab(String) | Makes the tab following the tab with the specified name the current tab. (Inherited from TabControl.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | FocusPanel |
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetControl | Gets the TabPage control at the specified location. (Inherited from TabControl.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetTabRect | Returns the bounding rectangle for a specified tab in this tab control. (Inherited from TabControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | IsPanelActive |
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SelectTab(Int32) | Makes the tab with the specified index the current tab. (Inherited from TabControl.)
Public method | SelectTab(TabPage) | Makes the specified TabPage the current tab. (Inherited from TabControl.)
Public method | SelectTab(String) | Makes the tab with the specified name the current tab. (Inherited from TabControl.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TabControl control. (Inherited from TabControl.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Alignment | Gets or sets the area of the control (for example, along the top) where the tabs are aligned. (Inherited from TabControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets the visual appearance of the control's tabs. (Inherited from TabControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | BackgroundImage | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | BackgroundImageLayout | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Breakpoints |
Public property | CallStack |
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger |
Public property | DisplayRectangle | Gets the display area of the control's tab pages. (Inherited from TabControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the way that the control's tabs are drawn. (Inherited from TabControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Errors |
Public property | FindResults |
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HotTrack | Gets or sets a value indicating whether the control's tabs change in appearance when the mouse passes over them. (Inherited from TabControl.)
Public property | ImageList | Gets or sets the images to display on the control's tabs. (Inherited from TabControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemSize | Gets or sets the size of the control's tabs. (Inherited from TabControl.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Locals |
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets a value indicating whether more than one row of tabs can be displayed. (Inherited from TabControl.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Output |
Public property | Padding | Gets or sets the amount of space around each item on the control's tab pages. (Inherited from TabControl.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from TabControl.)
Public property | RowCount | Gets the number of rows that are currently being displayed in the control's tab strip. (Inherited from TabControl.)
Public property | SelectedIndex | Gets or sets the index of the currently selected tab page. (Inherited from TabControl.)
Public property | SelectedTab | Gets or sets the currently selected tab page. (Inherited from TabControl.)
Public property | ShowToolTips | Gets or sets a value indicating whether a tab's ToolTip is shown when the mouse passes over the tab. (Inherited from TabControl.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SizeMode | Gets or sets the way that the control's tabs are sized. (Inherited from TabControl.)
Public property | TabCount | Gets the number of tabs in the tab strip. (Inherited from TabControl.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabPages | Gets the collection of tab pages in this tab control. (Inherited from TabControl.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | Threads |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisiblePanels |
Public property | Watches |
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | ActivePanelsChanged |
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | This event is not meaningful for this control. (Inherited from TabControl.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from TabControl.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (Inherited from TabControl.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deselected | Occurs when a tab is deselected. (Inherited from TabControl.)
Public event | Deselecting | Occurs before a tab is deselected, enabling a handler to cancel the tab change. (Inherited from TabControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when the TabControl needs to paint each of its tabs if the DrawMode property is set to OwnerDrawFixed. (Inherited from TabControl.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from TabControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | This event is not meaningful for this control. (Inherited from TabControl.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TabControl.)
Public event | Selected | Occurs when a tab is selected. (Inherited from TabControl.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from TabControl.)
Public event | Selecting | Occurs before a tab is selected, enabling a handler to cancel the tab change. (Inherited from TabControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the value of the Text property changes. (Inherited from TabControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl Constructor

DebuggerPanelsTabControl Constructor
Initializes a new instance of the DebuggerPanelsTabControl class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerPanelsTabControl()
Public Sub New
public:
DebuggerPanelsTabControl()
new : unit -> DebuggerPanelsTabControl
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl Methods

DebuggerPanelsTabControl Methods

The DebuggerPanelsTabControl type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DeselectTab(Int32) | Makes the tab following the tab with the specified index the current tab. (Inherited from TabControl.)
Public method | DeselectTab(TabPage) | Makes the tab following the specified TabPage the current tab. (Inherited from TabControl.)
Public method | DeselectTab(String) | Makes the tab following the tab with the specified name the current tab. (Inherited from TabControl.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | FocusPanel |
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetControl | Gets the TabPage control at the specified location. (Inherited from TabControl.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetTabRect | Returns the bounding rectangle for a specified tab in this tab control. (Inherited from TabControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | IsPanelActive |
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SelectTab(Int32) | Makes the tab with the specified index the current tab. (Inherited from TabControl.)
Public method | SelectTab(TabPage) | Makes the specified TabPage the current tab. (Inherited from TabControl.)
Public method | SelectTab(String) | Makes the tab with the specified name the current tab. (Inherited from TabControl.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string that represents the TabControl control. (Inherited from TabControl.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.FocusPanel Method

DebuggerPanelsTabControlFocusPanel Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FocusPanel(
    DebuggerPanelKinds panelKind
)
Public Sub FocusPanel (
    panelKind As DebuggerPanelKinds
)
public:
virtual void FocusPanel(
    DebuggerPanelKinds panelKind
) sealed
abstract FocusPanel :
        panelKind : DebuggerPanelKinds -> unit
override FocusPanel :
        panelKind : DebuggerPanelKinds -> unit

Parameters

panelKind
Type: Alternet.Scripter.IntegrationDebuggerPanelKinds

Implements

IDebuggerPanelsFocusPanel(DebuggerPanelKinds)
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.IsPanelActive Method

DebuggerPanelsTabControlIsPanelActive Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPanelActive(
    DebuggerPanelKinds panel
)
Public Function IsPanelActive (
    panel As DebuggerPanelKinds
) As Boolean
public:
virtual bool IsPanelActive(
    DebuggerPanelKinds panel
) sealed
abstract IsPanelActive :
        panel : DebuggerPanelKinds -> bool
override IsPanelActive :
        panel : DebuggerPanelKinds -> bool

Parameters

panel
Type: Alternet.Scripter.IntegrationDebuggerPanelKinds

Return Value

Type: Boolean

Implements

IDebuggerPanelsIsPanelActive(DebuggerPanelKinds)
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl Properties

DebuggerPanelsTabControl Properties

The DebuggerPanelsTabControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | Alignment | Gets or sets the area of the control (for example, along the top) where the tabs are aligned. (Inherited from TabControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | Appearance | Gets or sets the visual appearance of the control's tabs. (Inherited from TabControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | BackgroundImage | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | BackgroundImageLayout | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | Breakpoints |
Public property | CallStack |
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | Debugger |
Public property | DisplayRectangle | Gets the display area of the control's tab pages. (Inherited from TabControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the way that the control's tabs are drawn. (Inherited from TabControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Errors |
Public property | FindResults |
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HotTrack | Gets or sets a value indicating whether the control's tabs change in appearance when the mouse passes over them. (Inherited from TabControl.)
Public property | ImageList | Gets or sets the images to display on the control's tabs. (Inherited from TabControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemSize | Gets or sets the size of the control's tabs. (Inherited from TabControl.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Locals |
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Multiline | Gets or sets a value indicating whether more than one row of tabs can be displayed. (Inherited from TabControl.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Output |
Public property | Padding | Gets or sets the amount of space around each item on the control's tab pages. (Inherited from TabControl.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from TabControl.)
Public property | RowCount | Gets the number of rows that are currently being displayed in the control's tab strip. (Inherited from TabControl.)
Public property | SelectedIndex | Gets or sets the index of the currently selected tab page. (Inherited from TabControl.)
Public property | SelectedTab | Gets or sets the currently selected tab page. (Inherited from TabControl.)
Public property | ShowToolTips | Gets or sets a value indicating whether a tab's ToolTip is shown when the mouse passes over the tab. (Inherited from TabControl.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SizeMode | Gets or sets the way that the control's tabs are sized. (Inherited from TabControl.)
Public property | TabCount | Gets the number of tabs in the tab strip. (Inherited from TabControl.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabPages | Gets the collection of tab pages in this tab control. (Inherited from TabControl.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | This member is not meaningful for this control. (Inherited from TabControl.)
Public property | Threads |
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisiblePanels |
Public property | Watches |
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.Breakpoints Property

DebuggerPanelsTabControlBreakpoints Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Breakpoints Breakpoints { get; }
Public ReadOnly Property Breakpoints As Breakpoints
    Get
public:
virtual property Breakpoints^ Breakpoints {
    Breakpoints^ get () sealed;
}
abstract Breakpoints : Breakpoints with get
override Breakpoints : Breakpoints with get

Property Value

Type: Breakpoints

Implements

IDebuggerPanelsBreakpoints
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.CallStack Property

DebuggerPanelsTabControlCallStack Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CallStack CallStack { get; }
Public ReadOnly Property CallStack As CallStack
    Get
public:
virtual property CallStack^ CallStack {
    CallStack^ get () sealed;
}
abstract CallStack : CallStack with get
override CallStack : CallStack with get

Property Value

Type: CallStack

Implements

IDebuggerPanelsCallStack
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.Debugger Property

DebuggerPanelsTabControlDebugger Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.Errors Property

DebuggerPanelsTabControlErrors Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Errors Errors { get; }
Public ReadOnly Property Errors As Errors
    Get
public:
virtual property Errors^ Errors {
    Errors^ get () sealed;
}
abstract Errors : Errors with get
override Errors : Errors with get

Property Value

Type: Errors

Implements

IDebuggerPanelsErrors
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.FindResults Property

DebuggerPanelsTabControlFindResults Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FindResults FindResults { get; }
Public ReadOnly Property FindResults As FindResults
    Get
public:
virtual property FindResults^ FindResults {
    FindResults^ get () sealed;
}
abstract FindResults : FindResults with get
override FindResults : FindResults with get

Property Value

Type: FindResults

Implements

IDebuggerPanelsFindResults
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.Locals Property

DebuggerPanelsTabControlLocals Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Locals Locals { get; }
Public ReadOnly Property Locals As Locals
    Get
public:
virtual property Locals^ Locals {
    Locals^ get () sealed;
}
abstract Locals : Locals with get
override Locals : Locals with get

Property Value

Type: Locals

Implements

IDebuggerPanelsLocals
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.Output Property

DebuggerPanelsTabControlOutput Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Output Output { get; }
Public ReadOnly Property Output As Output
    Get
public:
virtual property Output^ Output {
    Output^ get () sealed;
}
abstract Output : Output with get
override Output : Output with get

Property Value

Type: Output

Implements

IDebuggerPanelsOutput
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.Threads Property

DebuggerPanelsTabControlThreads Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Threads Threads { get; }
Public ReadOnly Property Threads As Threads
    Get
public:
virtual property Threads^ Threads {
    Threads^ get () sealed;
}
abstract Threads : Threads with get
override Threads : Threads with get

Property Value

Type: Threads

Implements

IDebuggerPanelsThreads
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.VisiblePanels Property

DebuggerPanelsTabControlVisiblePanels Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerPanelKinds VisiblePanels { get; set; }
Public Property VisiblePanels As DebuggerPanelKinds
    Get
    Set
public:
property DebuggerPanelKinds VisiblePanels {
    DebuggerPanelKinds get ();
    void set (DebuggerPanelKinds value);
}
member VisiblePanels : DebuggerPanelKinds with get, set

Property Value

Type: DebuggerPanelKinds
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.Watches Property

DebuggerPanelsTabControlWatches Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Watches Watches { get; }
Public ReadOnly Property Watches As Watches
    Get
public:
virtual property Watches^ Watches {
    Watches^ get () sealed;
}
abstract Watches : Watches with get
override Watches : Watches with get

Property Value

Type: Watches

Implements

IDebuggerPanelsWatches
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl Events

DebuggerPanelsTabControl Events

The DebuggerPanelsTabControl type exposes the following members.

Events
 | Name | Description
Public event | ActivePanelsChanged |
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | This event is not meaningful for this control. (Inherited from TabControl.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from TabControl.)
Public event | BackgroundImageLayoutChanged | Occurs when the value of the BackgroundImageLayout property changes. (Inherited from TabControl.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deselected | Occurs when a tab is deselected. (Inherited from TabControl.)
Public event | Deselecting | Occurs before a tab is deselected, enabling a handler to cancel the tab change. (Inherited from TabControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when the TabControl needs to paint each of its tabs if the DrawMode property is set to OwnerDrawFixed. (Inherited from TabControl.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the value of the ForeColor property changes. (Inherited from TabControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | This event is not meaningful for this control. (Inherited from TabControl.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TabControl.)
Public event | Selected | Occurs when a tab is selected. (Inherited from TabControl.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from TabControl.)
Public event | Selecting | Occurs before a tab is selected, enabling a handler to cancel the tab change. (Inherited from TabControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the value of the Text property changes. (Inherited from TabControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerPanelsTabControl.ActivePanelsChanged Event

DebuggerPanelsTabControlActivePanelsChanged Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ActivePanelsChanged
Public Event ActivePanelsChanged As EventHandler
public:
virtual  event EventHandler^ ActivePanelsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ActivePanelsChanged : IEvent<EventHandler,
    EventArgs>
override ActivePanelsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IDebuggerPanelsActivePanelsChanged
See Also

Reference

DebuggerPanelsTabControl Class
Alternet.Scripter.Integration Namespace


DebuggerUIController Class

DebuggerUIController Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IntegrationDebuggerUIController

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DebuggerUIController
Public Class DebuggerUIController
public ref class DebuggerUIController
type DebuggerUIController =  class end

The DebuggerUIController type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerUIController | Initializes a new instance of the DebuggerUIController class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommandsListener |
Public property | Debugger |
Public property | DebuggerPanels |
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


DebuggerUIController Constructor

DebuggerUIController Constructor
Initializes a new instance of the DebuggerUIController class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerUIController(
    Control owner,
    IDebugEditContainer editorContainer
)
Public Sub New (
    owner As Control,
    editorContainer As IDebugEditContainer
)
public:
DebuggerUIController(
    Control^ owner,
    IDebugEditContainer^ editorContainer
)
new :
        owner : Control *
        editorContainer : IDebugEditContainer -> DebuggerUIController

Parameters

owner
Type: System.Windows.FormsControl
editorContainer
Type: Alternet.Scripter.IntegrationIDebugEditContainer
See Also

Reference

DebuggerUIController Class
Alternet.Scripter.Integration Namespace


DebuggerUIController Methods

DebuggerUIController Methods

The DebuggerUIController type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebuggerUIController Class
Alternet.Scripter.Integration Namespace


DebuggerUIController Properties

DebuggerUIController Properties

The DebuggerUIController type exposes the following members.

Properties
 | Name | Description
Public property | CommandsListener |
Public property | Debugger |
Public property | DebuggerPanels |
Top
See Also

Reference

DebuggerUIController Class
Alternet.Scripter.Integration Namespace


DebuggerUIController.CommandsListener Property

DebuggerUIControllerCommandsListener Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDebuggerUICommands CommandsListener { get; set; }
Public Property CommandsListener As IDebuggerUICommands
    Get
    Set
public:
property IDebuggerUICommands^ CommandsListener {
    IDebuggerUICommands^ get ();
    void set (IDebuggerUICommands^ value);
}
member CommandsListener : IDebuggerUICommands with get, set

Property Value

Type: IDebuggerUICommands
See Also

Reference

DebuggerUIController Class
Alternet.Scripter.Integration Namespace


DebuggerUIController.Debugger Property

DebuggerUIControllerDebugger Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptDebuggerBase Debugger { get; set; }
Public Property Debugger As IScriptDebuggerBase
    Get
    Set
public:
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
member Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

DebuggerUIController Class
Alternet.Scripter.Integration Namespace


DebuggerUIController.DebuggerPanels Property

DebuggerUIControllerDebuggerPanels Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDebuggerPanels DebuggerPanels { get; set; }
Public Property DebuggerPanels As IDebuggerPanels
    Get
    Set
public:
property IDebuggerPanels^ DebuggerPanels {
    IDebuggerPanels^ get ();
    void set (IDebuggerPanels^ value);
}
member DebuggerPanels : IDebuggerPanels with get, set

Property Value

Type: IDebuggerPanels
See Also

Reference

DebuggerUIController Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController Class

EditorCodeCompletionController Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionEvaluationCodeCompletionControllerBase
EvaluationCodeCompletionController
Alternet.Scripter.IntegrationEditorCodeCompletionController

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditorCodeCompletionController : EvaluationCodeCompletionController
Public Class EditorCodeCompletionController
    Inherits EvaluationCodeCompletionController
public ref class EditorCodeCompletionController : public EvaluationCodeCompletionController
type EditorCodeCompletionController =
    class
        inherit EvaluationCodeCompletionController
    end

The EditorCodeCompletionController type exposes the following members.

Constructors
 | Name | Description
Public method | EditorCodeCompletionController | Initializes a new instance of the EditorCodeCompletionController class
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from EvaluationCodeCompletionControllerBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


EditorCodeCompletionController Constructor

EditorCodeCompletionController Constructor
Initializes a new instance of the EditorCodeCompletionController class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public EditorCodeCompletionController(
    EvaluationCodeCompletionControllerBaseISite site,
    IScriptDebuggerBase debugger,
    TextBox expressionTextBox
)
Public Sub New (
    site As EvaluationCodeCompletionControllerBaseISite,
    debugger As IScriptDebuggerBase,
    expressionTextBox As TextBox
)
public:
EditorCodeCompletionController(
    EvaluationCodeCompletionControllerBaseISite^ site,
    IScriptDebuggerBase^ debugger,
    TextBox^ expressionTextBox
)
new :
        site : EvaluationCodeCompletionControllerBaseISite *
        debugger : IScriptDebuggerBase *
        expressionTextBox : TextBox -> EditorCodeCompletionController

Parameters

site
Type: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionEvaluationCodeCompletionControllerBaseISite
debugger
Type: Alternet.Scripter.DebuggerIScriptDebuggerBase
expressionTextBox
Type: System.Windows.FormsTextBox
See Also

Reference

EditorCodeCompletionController Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController Methods

EditorCodeCompletionController Methods

The EditorCodeCompletionController type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from EvaluationCodeCompletionControllerBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EditorCodeCompletionController Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionBox Class

EditorCodeCompletionControllerCodeCompletionBox Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CodeCompletionCodeCompletionWindow
Alternet.Editor.CodeCompletionCodeCompletionBox
Alternet.Scripter.IntegrationEditorCodeCompletionControllerCodeCompletionBox

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionBox : CodeCompletionBox
Public Class CodeCompletionBox
    Inherits CodeCompletionBox
public ref class CodeCompletionBox : public CodeCompletionBox
type CodeCompletionBox =
    class
        inherit CodeCompletionBox
    end

The EditorCodeCompletionControllerCodeCompletionBox type exposes the following members.

Constructors
 | Name | Description
Public method | EditorCodeCompletionControllerCodeCompletionBox | Initializes a new instance of the EditorCodeCompletionControllerCodeCompletionBox class
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddColumn | Adds a new column to the CodeCompletionBox column collection. (Inherited from CodeCompletionBox.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CodeCompletionBox column collection. (Inherited from CodeCompletionBox.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Inherited from CodeCompletionBox.)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position in the column collection. (Inherited from CodeCompletionBox.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionBox.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionBox.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveColumnAt | Removes the column at the specified index of the column collection. (Inherited from CodeCompletionBox.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionBox content from its Provider. (Inherited from CodeCompletionBox.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDropDownCount | Resets the DropDownCount to its default value. (Inherited from CodeCompletionBox.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable to its default value. (Inherited from CodeCompletionBox.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CodeCompletionBorderColor | Gets CodeCompletionBox border color. (Inherited from CodeCompletionBox.)
Public property | CodeCompletionBorderThickness | Gets thickness of the CodeCompletionBox border. (Inherited from CodeCompletionBox.)
Public property | Columns | Represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox. (Inherited from CodeCompletionBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionEdit | Represents CodeCompletionEdit object used to display code snippets. (Inherited from CodeCompletionBox.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | CompletionHint | Represents CodeCompletion hint object used to display hints next to completion box. (Inherited from CodeCompletionBox.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | DropDownCount | Gets or sets a value that specifies maximum visible amount of the ListBox items within the control. (Inherited from CodeCompletionBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | Filter | Gets or sets filter string to filter CodeCompletionBox content. (Inherited from CodeCompletionBox.)
Public property | Filtered | Gets or sets a boolean value that indicates whether CodeCompletionBox should filter its content using Filter property. (Inherited from CodeCompletionBox.)
Public property | FilterOptions | Gets or sets rules specifying how CodeCompletionBox should filter its content. (Inherited from CodeCompletionBox.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionEdit control has an input focus. (Inherited from CodeCompletionBox.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox |
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | ShowTabs | Gets or sets boolean value that indicates whether codecompletion window should display additional tabs. (Inherited from CodeCompletionBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | Sorted | Gets or sets a value indicating whether the items in the CodeCompletionBox are sorted alphabetically. (Inherited from CodeCompletionBox.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectionChanged | Occurs when index specifying the currently selected item is changed. (Inherited from CodeCompletionBox.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionBox Constructor

EditorCodeCompletionControllerCodeCompletionBox Constructor
Initializes a new instance of the EditorCodeCompletionControllerCodeCompletionBox class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionBox(
    Control owner,
    EditorCodeCompletionController controller
)
Public Sub New (
    owner As Control,
    controller As EditorCodeCompletionController
)
public:
CodeCompletionBox(
    Control^ owner,
    EditorCodeCompletionController^ controller
)
new :
        owner : Control *
        controller : EditorCodeCompletionController -> CodeCompletionBox

Parameters

owner
Type: System.Windows.FormsControl
controller
Type: Alternet.Scripter.IntegrationEditorCodeCompletionController
See Also

Reference

EditorCodeCompletionControllerCodeCompletionBox Class
Alternet.Scripter.Integration Namespace


CodeCompletionBox Methods

CodeCompletionBox Methods

The EditorCodeCompletionControllerCodeCompletionBox type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddColumn | Adds a new column to the CodeCompletionBox column collection. (Inherited from CodeCompletionBox.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CodeCompletionBox column collection. (Inherited from CodeCompletionBox.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Inherited from CodeCompletionBox.)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position in the column collection. (Inherited from CodeCompletionBox.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionBox.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionBox.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveColumnAt | Removes the column at the specified index of the column collection. (Inherited from CodeCompletionBox.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionBox content from its Provider. (Inherited from CodeCompletionBox.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDropDownCount | Resets the DropDownCount to its default value. (Inherited from CodeCompletionBox.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable to its default value. (Inherited from CodeCompletionBox.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionBox Class
Alternet.Scripter.Integration Namespace


CodeCompletionBox Properties

CodeCompletionBox Properties

The EditorCodeCompletionControllerCodeCompletionBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CodeCompletionBorderColor | Gets CodeCompletionBox border color. (Inherited from CodeCompletionBox.)
Public property | CodeCompletionBorderThickness | Gets thickness of the CodeCompletionBox border. (Inherited from CodeCompletionBox.)
Public property | Columns | Represents collection of ICodeCompletionColumn objects displayed by Code Completion ListBox. (Inherited from CodeCompletionBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionEdit | Represents CodeCompletionEdit object used to display code snippets. (Inherited from CodeCompletionBox.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | CompletionHint | Represents CodeCompletion hint object used to display hints next to completion box. (Inherited from CodeCompletionBox.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | DropDownCount | Gets or sets a value that specifies maximum visible amount of the ListBox items within the control. (Inherited from CodeCompletionBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | Filter | Gets or sets filter string to filter CodeCompletionBox content. (Inherited from CodeCompletionBox.)
Public property | Filtered | Gets or sets a boolean value that indicates whether CodeCompletionBox should filter its content using Filter property. (Inherited from CodeCompletionBox.)
Public property | FilterOptions | Gets or sets rules specifying how CodeCompletionBox should filter its content. (Inherited from CodeCompletionBox.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionEdit control has an input focus. (Inherited from CodeCompletionBox.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | ListBox |
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | ShowTabs | Gets or sets boolean value that indicates whether codecompletion window should display additional tabs. (Inherited from CodeCompletionBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | Sorted | Gets or sets a value indicating whether the items in the CodeCompletionBox are sorted alphabetically. (Inherited from CodeCompletionBox.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionBox Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionBox.ListBox Property

EditorCodeCompletionControllerCodeCompletionBoxListBox Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICompletionListBox ListBox { get; }
Public ReadOnly Property ListBox As ICompletionListBox
    Get
public:
property ICompletionListBox^ ListBox {
    ICompletionListBox^ get ();
}
member ListBox : ICompletionListBox with get

Property Value

Type: ICompletionListBox
See Also

Reference

EditorCodeCompletionControllerCodeCompletionBox Class
Alternet.Scripter.Integration Namespace


CodeCompletionBox Events

CodeCompletionBox Events

The EditorCodeCompletionControllerCodeCompletionBox type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SelectionChanged | Occurs when index specifying the currently selected item is changed. (Inherited from CodeCompletionBox.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionBox Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionBox.CodeCompletionListBox Class

EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsListBox
Alternet.Editor.CodeCompletionListBoxWithAdvancedScrolling
Alternet.Editor.CodeCompletionCompletionListBox
Alternet.Scripter.IntegrationEditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionListBox : CompletionListBox
Public Class CodeCompletionListBox
    Inherits CompletionListBox
public ref class CodeCompletionListBox : public CompletionListBox
type CodeCompletionListBox =
    class
        inherit CompletionListBox
    end

The EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox type exposes the following members.

Constructors
 | Name | Description
Public method | EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox | Initializes a new instance of the EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox class
Top
Methods
 | Name | Description
Public method | AddColumn | Adds a new column to the end of the CompletionListBox column collection. (Inherited from CompletionListBox.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CompletionListBox column collection. (Inherited from CompletionListBox.)
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetColumn | Returns a column by specifies index. (Inherited from CompletionListBox.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndex | Returns current index. (Inherited from CompletionListBox.)
Public method | GetIndex(Boolean) | Returns current index. (Inherited from CompletionListBox.)
Public method | GetIndex(Int32) | Returns current index. (Inherited from CompletionListBox.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position of the CompletionListBox columns collection. (Inherited from CompletionListBox.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | RemoveColumnAt | Removes column at the specified position from the CompletionListBox column collection. (Inherited from CompletionListBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetContent | Updates CompletionListBox content from its Provider. (Inherited from CompletionListBox.)
Public method | ResetContent(Int32) | Updates CompletionListBox content from its Provider. (Inherited from CompletionListBox.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnCount | Returns number of the columns in the listbox. (Inherited from CompletionListBox.)
Public property | Columns | Represents ICodeCompletionColumn collection. (Inherited from CompletionListBox.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Filter | Gets or sets filter string to filter CompletionListBox content. (Inherited from CompletionListBox.)
Public property | Filtered | Gets or sets a boolean value that indicates whether CompletionListBox should filter its content using Filer property. (Inherited from CompletionListBox.)
Public property | FilterOptions | Gets or sets rules specifying how list box should filter its content. (Inherited from CompletionListBox.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusMode | Specifies item preselection mode. (Inherited from CompletionListBox.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | Images | Represents an image list associated with this CompletionListBox. (Inherited from CompletionListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | ItemImagePadding | Gets or sets padding of the image part. (Inherited from CompletionListBox.)
Public property | Items | Gets the items appears in the CompletionListBox. (Inherited from CompletionListBox.)
Public property | ItemTextPadding | Gets or sets padding of the text part. (Inherited from CompletionListBox.)
Public property | ItemWidth | Gets width of the widest item. (Inherited from CompletionListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavKeys | Represents a key collection used to navigate within the CompletionListBox content. (Inherited from CompletionListBox.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | Priority | Gets or sets priority filter to filter CompletionListBox content. (Inherited from CompletionListBox.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Represents the object that provides data for code completion. (Inherited from CompletionListBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in the CompletionListBox. (Inherited from CompletionListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | VerticalScrollBarVisible | (Inherited from ListBoxWithAdvancedScrolling.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemsChanged | (Inherited from ListBoxWithAdvancedScrolling.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | UpdateSize | Occurs when size of the control is changed. (Inherited from CompletionListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VerticalScrollChanged | (Inherited from ListBoxWithAdvancedScrolling.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionBox.CodeCompletionListBox Constructor

EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox Constructor
Initializes a new instance of the EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionListBox()
Public Sub New
public:
CodeCompletionListBox()
new : unit -> CodeCompletionListBox
See Also

Reference

EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox Class
Alternet.Scripter.Integration Namespace


CodeCompletionListBox Methods

CodeCompletionListBox Methods

The EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox type exposes the following members.

Methods
 | Name | Description
Public method | AddColumn | Adds a new column to the end of the CompletionListBox column collection. (Inherited from CompletionListBox.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Maintains performance while items are added to the ListBox one at a time by preventing the control from drawing until the EndUpdate method is called. (Inherited from ListBox.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | ClearColumns | Removes all columns from the CompletionListBox column collection. (Inherited from CompletionListBox.)
Public method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Resumes painting the ListBox control after painting is suspended by the BeginUpdate method. (Inherited from ListBox.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | FindString(String) | Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox.)
Public method | FindString(String, Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | FindStringExact(String) | Finds the first item in the ListBox that exactly matches the specified string. (Inherited from ListBox.)
Public method | FindStringExact(String, Int32) | Finds the first item in the ListBox that exactly matches the specified string. The search starts at a specific starting index. (Inherited from ListBox.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetColumn | Returns a column by specifies index. (Inherited from CompletionListBox.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndex | Returns current index. (Inherited from CompletionListBox.)
Public method | GetIndex(Boolean) | Returns current index. (Inherited from CompletionListBox.)
Public method | GetIndex(Int32) | Returns current index. (Inherited from CompletionListBox.)
Public method | GetItemHeight | Returns the height of an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemRectangle | Returns the bounding rectangle for an item in the ListBox. (Inherited from ListBox.)
Public method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetSelected | Returns a value indicating whether the specified item is selected. (Inherited from ListBox.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | IndexFromPoint(Point) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | IndexFromPoint(Int32, Int32) | Returns the zero-based index of the item at the specified coordinates. (Inherited from ListBox.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InsertColumn | Inserts a new column to the specified position of the CompletionListBox columns collection. (Inherited from CompletionListBox.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from ListBox.)
Public method | RemoveColumnAt | Removes column at the specified position from the CompletionListBox column collection. (Inherited from CompletionListBox.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from ListBox.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetContent | Updates CompletionListBox content from its Provider. (Inherited from CompletionListBox.)
Public method | ResetContent(Int32) | Updates CompletionListBox content from its Provider. (Inherited from CompletionListBox.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from ListBox.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a string representation of the ListBox. (Inherited from ListBox.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox Class
Alternet.Scripter.Integration Namespace


CodeCompletionListBox Properties

CodeCompletionListBox Properties

The EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from ListBox.)
Public property | BackgroundImage | This property is not relevant to this class. (Inherited from ListBox.)
Public property | BackgroundImageLayout | Gets or sets the background image layout for a ListBox as defined in the ImageLayout enumeration. (Inherited from ListBox.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the type of border that is drawn around the ListBox. (Inherited from ListBox.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | ColumnCount | Returns number of the columns in the listbox. (Inherited from CompletionListBox.)
Public property | Columns | Represents ICodeCompletionColumn collection. (Inherited from CompletionListBox.)
Public property | ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox. (Inherited from ListBox.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | CustomTabOffsets | Gets the width of the tabs between the items in the ListBox. (Inherited from ListBox.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl.)
Public property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DrawMode | Gets or sets the drawing mode for the control. (Inherited from ListBox.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Filter | Gets or sets filter string to filter CompletionListBox content. (Inherited from CompletionListBox.)
Public property | Filtered | Gets or sets a boolean value that indicates whether CompletionListBox should filter its content using Filer property. (Inherited from CompletionListBox.)
Public property | FilterOptions | Gets or sets rules specifying how list box should filter its content. (Inherited from CompletionListBox.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | FocusMode | Specifies item preselection mode. (Inherited from CompletionListBox.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from ListBox.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from ListBox.)
Public property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl.)
Public property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl.)
Public property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the DisplayMember property of the ListControl. (Inherited from ListControl.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll. (Inherited from ListBox.)
Public property | HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control. (Inherited from ListBox.)
Public property | Images | Represents an image list associated with this CompletionListBox. (Inherited from CompletionListBox.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from ListBox.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the ListBox. (Inherited from ListBox.)
Public property | ItemImagePadding | Gets or sets padding of the image part. (Inherited from CompletionListBox.)
Public property | Items | Gets the items appears in the CompletionListBox. (Inherited from CompletionListBox.)
Public property | ItemTextPadding | Gets or sets padding of the text part. (Inherited from CompletionListBox.)
Public property | ItemWidth | Gets width of the widest item. (Inherited from CompletionListBox.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns. (Inherited from ListBox.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NavKeys | Represents a key collection used to navigate within the CompletionListBox content. (Inherited from CompletionListBox.)
Public property | Padding | This property is not relevant to this class. (Inherited from ListBox.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PreferredHeight | Gets the combined height of all items in the ListBox. (Inherited from ListBox.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | Priority | Gets or sets priority filter to filter CompletionListBox content. (Inherited from CompletionListBox.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Represents the object that provides data for code completion. (Inherited from CompletionListBox.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether text displayed by the control is displayed from right to left. (Inherited from ListBox.)
Public property | ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times. (Inherited from ListBox.)
Public property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in the CompletionListBox. (Inherited from CompletionListBox.)
Public property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the member property specified by the ValueMember property. (Inherited from ListControl.)
Public property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or searches for the text of the currently selected item in the ListBox. (Inherited from ListBox.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopIndex | Gets or sets the index of the first visible item in the ListBox. (Inherited from ListBox.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseCustomTabOffsets | Gets or sets a value indicating whether the ListBox recognizes and expands tab characters when it draws its strings by using the CustomTabOffsets integer array. (Inherited from ListBox.)
Public property | UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings. (Inherited from ListBox.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the ListControl. (Inherited from ListControl.)
Public property | VerticalScrollBarVisible | (Inherited from ListBoxWithAdvancedScrolling.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox Class
Alternet.Scripter.Integration Namespace


CodeCompletionListBox Events

CodeCompletionListBox Events

The EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property of the label changes. (Inherited from ListBox.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from ListBox.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the ListBox control is clicked. (Inherited from ListBox.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | DataSourceChanged | Occurs when the DataSource changes. (Inherited from ListControl.)
Public event | DisplayMemberChanged | Occurs when the DisplayMember property changes. (Inherited from ListControl.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawItem | Occurs when a visual aspect of an owner-drawn ListBox changes. (Inherited from ListBox.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl.)
Public event | FormatInfoChanged | Occurs when the value of the FormatInfo property changes. (Inherited from ListControl.)
Public event | FormatStringChanged | Occurs when value of the FormatString property changes (Inherited from ListControl.)
Public event | FormattingEnabledChanged | Occurs when the value of the FormattingEnabled property changes. (Inherited from ListControl.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemsChanged | (Inherited from ListBoxWithAdvancedScrolling.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MeasureItem | Occurs when an owner-drawn ListBox is created and the sizes of the list items are determined. (Inherited from ListBox.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the user clicks the ListBox control with the mouse pointer. (Inherited from ListBox.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from ListBox.)
Public event | Paint | Occurs when the ListBox control is painted. (Inherited from ListBox.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | SelectedIndexChanged | Occurs when the SelectedIndex property or the SelectedIndices collection has changed. (Inherited from ListBox.)
Public event | SelectedValueChanged | Occurs when the SelectedValue property changes. (Inherited from ListControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property is changed. (Inherited from ListBox.)
Public event | UpdateSize | Occurs when size of the control is changed. (Inherited from CompletionListBox.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | ValueMemberChanged | Occurs when the ValueMember property changes. (Inherited from ListControl.)
Public event | VerticalScrollChanged | (Inherited from ListBoxWithAdvancedScrolling.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionBoxCodeCompletionListBox Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionHint Class

EditorCodeCompletionControllerCodeCompletionHint Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Alternet.Editor.CodeCompletionCodeCompletionWindow
Alternet.Editor.CodeCompletionCodeCompletionHint
Alternet.Scripter.IntegrationEditorCodeCompletionControllerCodeCompletionHint

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionHint : CodeCompletionHint
Public Class CodeCompletionHint
    Inherits CodeCompletionHint
public ref class CodeCompletionHint : public CodeCompletionHint
type CodeCompletionHint =
    class
        inherit CodeCompletionHint
    end

The EditorCodeCompletionControllerCodeCompletionHint type exposes the following members.

Constructors
 | Name | Description
Public method | EditorCodeCompletionControllerCodeCompletionHint | Initializes a new instance of the EditorCodeCompletionControllerCodeCompletionHint class
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Inherited from CodeCompletionWindow.)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawLine(Int32, Point, Rectangle) | Draws specific line in of the hint control to the graphic surface. (Inherited from CodeCompletionHint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from CodeCompletionHint.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal. (Inherited from CodeCompletionHint.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFontColor | Retrieves font color corresponding to given state. (Inherited from CodeCompletionHint.)
Public method | GetFontStyle | Retrieves font style corresponding to given state. (Inherited from CodeCompletionHint.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style. (Inherited from CodeCompletionHint.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given by its index. (Inherited from CodeCompletionHint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of the given string. (Inherited from CodeCompletionHint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index. (Inherited from CodeCompletionHint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of the given string. (Inherited from CodeCompletionHint.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | OnCustomDraw | Calls Hint.SyntaxPaint.OnCustomDraw method that raises CustomDraw event. (Inherited from CodeCompletionHint.)
Public method | PaintSyntax | Paints a specified part of the hint control. (Inherited from CodeCompletionHint.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionWindow.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoHide | Resets the AutoHide to its default value. (Inherited from CodeCompletionHint.)
Public method | ResetAutoHidePause | Resets the AutoHidePause to its default value. (Inherited from CodeCompletionHint.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionHint content from its Provider. (Inherited from CodeCompletionHint.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to its default value. (Inherited from CodeCompletionHint.)
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to its default value. (Inherited from CodeCompletionHint.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoHide | Gets or sets a value indicating whether CodeCompletionHint should be closed after some period of time. (Inherited from CodeCompletionHint.)
Public property | AutoHidePause | Gets or sets a value that specifies delay, in milliseconds, between displaying and hiding popup hint. (Inherited from CodeCompletionHint.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisableColorPaint | Gets or sets a value indicating whether hint control uses colors to paint its content. (Inherited from CodeCompletionHint.)
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether hint control uses lexical colors/styles to paint its content. (Inherited from CodeCompletionHint.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | Hint |
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionWindow or it's child control has an input focus. (Inherited from CodeCompletionWindow.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | Gets or sets object that can make lexical analysis for the hint control content. (Inherited from CodeCompletionHint.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Painter | (Inherited from CodeCompletionHint.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when hint draws its content. (Inherited from CodeCompletionHint.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HyperTextClick | Occurs when hypertext is clicked. (Inherited from CodeCompletionHint.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionHint Constructor

EditorCodeCompletionControllerCodeCompletionHint Constructor
Initializes a new instance of the EditorCodeCompletionControllerCodeCompletionHint class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionHint(
    Control owner
)
Public Sub New (
    owner As Control
)
public:
CodeCompletionHint(
    Control^ owner
)
new :
        owner : Control -> CodeCompletionHint

Parameters

owner
Type: System.Windows.FormsControl
See Also

Reference

EditorCodeCompletionControllerCodeCompletionHint Class
Alternet.Scripter.Integration Namespace


CodeCompletionHint Methods

CodeCompletionHint Methods

The EditorCodeCompletionControllerCodeCompletionHint type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Close(Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Boolean) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | Close(Boolean, Char) | Closes the popup window. (Inherited from CodeCompletionWindow.)
Public method | CloseDelayed | Closes the popup window with delay. (Inherited from CodeCompletionWindow.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | ContainsControl | Retrieves a value indicating whether the popup window contains the specified control. (Inherited from CodeCompletionWindow.)
Public method | ContainsMouseCursor | Determines whether control contains mouse position, with specified therehold. (Inherited from CodeCompletionWindow.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawLine(Int32, Point, Rectangle) | Draws specific line in of the hint control to the graphic surface. (Inherited from CodeCompletionHint.)
Public method | DrawLine(Int32, String, StringItemInfo, Point, Rectangle) | Draws line given by its index at the specified position. (Inherited from CodeCompletionHint.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EnsureVisible | Ensures that the popup window is visible in the screen working area, moving it if necessary. (Inherited from CodeCompletionWindow.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EqualStyles | Indicates whether given styles are equal. (Inherited from CodeCompletionHint.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetFontColor | Retrieves font color corresponding to given state. (Inherited from CodeCompletionHint.)
Public method | GetFontStyle | Retrieves font style corresponding to given state. (Inherited from CodeCompletionHint.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLexStyle | Retrieves lex state corresponding to given parser style. (Inherited from CodeCompletionHint.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | MeasureLine(Int32, Int32, Int32) | Measures part of the string given by its index. (Inherited from CodeCompletionHint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32) | Measures part of the given string. (Inherited from CodeCompletionHint.)
Public method | MeasureLine(Int32, Int32, Int32, Int32, Int32, Boolean) | Measures part of the string given by its index. (Inherited from CodeCompletionHint.)
Public method | MeasureLine(String, StringItemInfo, Int32, Int32, Int32, Int32, Boolean) | Measures part of the given string. (Inherited from CodeCompletionHint.)
Public method | MouseOverControl | (Inherited from CodeCompletionWindow.)
Public method | OnCustomDraw | Calls Hint.SyntaxPaint.OnCustomDraw method that raises CustomDraw event. (Inherited from CodeCompletionHint.)
Public method | PaintSyntax | Paints a specified part of the hint control. (Inherited from CodeCompletionHint.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformSearch | Performs searching operation. (Inherited from CodeCompletionWindow.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | Popup | Displays popup window at the current mouse position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point) | Displays popup window at the specified screen position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Point, ICodeCompletionProvider) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PopupAt(Int32, Int32) | Displays popup window at the specified position. (Inherited from CodeCompletionWindow.)
Public method | PositionChanged | Responds on changing position in the popup window. (Inherited from CodeCompletionWindow.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetAutoHide | Resets the AutoHide to its default value. (Inherited from CodeCompletionHint.)
Public method | ResetAutoHidePause | Resets the AutoHidePause to its default value. (Inherited from CodeCompletionHint.)
Public method | ResetAutoSize | Resets the AutoSize property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCodeCompletionFlags | Resets the CompletionFlags property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetContent | Updates CodeCompletionHint content from its Provider. (Inherited from CodeCompletionHint.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetDisableColorPaint | Resets the DisableColorPaint to its default value. (Inherited from CodeCompletionHint.)
Public method | ResetDisableSyntaxPaint | Resets the DisableSyntaxPaint to its default value. (Inherited from CodeCompletionHint.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetSizeable | Resets the Sizeable property to its default value. (Inherited from CodeCompletionWindow.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionHint Class
Alternet.Scripter.Integration Namespace


CodeCompletionHint Properties

CodeCompletionHint Properties

The EditorCodeCompletionControllerCodeCompletionHint type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoHide | Gets or sets a value indicating whether CodeCompletionHint should be closed after some period of time. (Inherited from CodeCompletionHint.)
Public property | AutoHidePause | Gets or sets a value that specifies delay, in milliseconds, between displaying and hiding popup hint. (Inherited from CodeCompletionHint.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Gets or sets a value indicating whether a popup window is automatically resized to fit its contents. (Inherited from CodeCompletionWindow.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | CompletionFlags | Gets or sets collection of attributes that specifies behavior of the popup window. (Inherited from CodeCompletionWindow.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisableColorPaint | Gets or sets a value indicating whether hint control uses colors to paint its content. (Inherited from CodeCompletionHint.)
Public property | DisableSyntaxPaint | Gets or sets a value indicating whether hint control uses lexical colors/styles to paint its content. (Inherited from CodeCompletionHint.)
Public property | DisplayPos | Specifies position within the text (as index of line and character) where ICodeCompletionWindow is displayed. (Inherited from CodeCompletionWindow.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | DoNotFocusPopupControl | Gets or sets a value indicating whether popup control should not be focused. (Inherited from CodeCompletionWindow.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | EndPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | FocusControl | Returns child control that has an input focus. (Inherited from CodeCompletionWindow.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | Hint |
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionWindow.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsFocused | Indicates whether CodeCompletionWindow or it's child control has an input focus. (Inherited from CodeCompletionWindow.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | IsVisible | Indicates if window is visible. (Inherited from CodeCompletionWindow.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Lexer | Gets or sets object that can make lexical analysis for the hint control content. (Inherited from CodeCompletionHint.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | OwnerControl | Represents a control owning this CodeCompletionWindow object. (Inherited from CodeCompletionWindow.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Painter | (Inherited from CodeCompletionHint.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PopupControl | Represents control contained in popup window. Usually CodeCompletionHint or CompletionListBox. (Inherited from CodeCompletionWindow.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | Provider | Gets or sets the object that contains data related to the popup window. (Inherited from CodeCompletionWindow.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | Sizeable | Gets or sets a value indicating whether the border of the popup window is sizable. (Inherited from CodeCompletionWindow.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPos | Specifies position within the text where CodeCompletionWindow is valid. (Inherited from CodeCompletionWindow.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionHint Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionHint.Hint Property

EditorCodeCompletionControllerCodeCompletionHintHint Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompletionHint Hint { get; }
Public ReadOnly Property Hint As CompletionHint
    Get
public:
property CompletionHint^ Hint {
    CompletionHint^ get ();
}
member Hint : CompletionHint with get

Property Value

Type: CompletionHint
See Also

Reference

EditorCodeCompletionControllerCodeCompletionHint Class
Alternet.Scripter.Integration Namespace


CodeCompletionHint Events

CodeCompletionHint Events

The EditorCodeCompletionControllerCodeCompletionHint type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | ClosePopup | Occurs when the popup window is closed. (Inherited from CodeCompletionWindow.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | CustomDraw | Occurs when hint draws its content. (Inherited from CodeCompletionHint.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | HyperTextClick | Occurs when hypertext is clicked. (Inherited from CodeCompletionHint.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPreviewEvent | Occurs when the popup window receives key message. (Inherited from CodeCompletionWindow.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | ShowPopup | Occurs when the popup window is displayed. (Inherited from CodeCompletionWindow.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionHint Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionPopup Class

EditorCodeCompletionControllerCodeCompletionPopup Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IntegrationEditorCodeCompletionControllerCodeCompletionPopup

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionPopup : ICodeCompletionPopup
Public Class CodeCompletionPopup
    Implements ICodeCompletionPopup
public ref class CodeCompletionPopup : ICodeCompletionPopup
type CodeCompletionPopup =
    class
        interface ICodeCompletionPopup
    end

The EditorCodeCompletionControllerCodeCompletionPopup type exposes the following members.

Constructors
 | Name | Description
Public method | EditorCodeCompletionControllerCodeCompletionPopup | Initializes a new instance of the EditorCodeCompletionControllerCodeCompletionPopup class
Top
Methods
 | Name | Description
Public method | ChangeSelection |
Public method | Close |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItems |
Public method | GetSelectedItem |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetItems |
Public method | Show |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Visible |
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionPopup Constructor

EditorCodeCompletionControllerCodeCompletionPopup Constructor
Initializes a new instance of the EditorCodeCompletionControllerCodeCompletionPopup class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionPopup(
    EditorCodeCompletionControllerCodeCompletionBox box,
    CodeCompletionPopupConfiguration configuration
)
Public Sub New (
    box As EditorCodeCompletionControllerCodeCompletionBox,
    configuration As CodeCompletionPopupConfiguration
)
public:
CodeCompletionPopup(
    EditorCodeCompletionControllerCodeCompletionBox^ box,
    CodeCompletionPopupConfiguration^ configuration
)
new :
        box : EditorCodeCompletionControllerCodeCompletionBox *
        configuration : CodeCompletionPopupConfiguration -> CodeCompletionPopup

Parameters

box
Type: Alternet.Scripter.IntegrationEditorCodeCompletionControllerCodeCompletionBox
configuration
Type: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionCodeCompletionPopupConfiguration
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


CodeCompletionPopup Methods

CodeCompletionPopup Methods

The EditorCodeCompletionControllerCodeCompletionPopup type exposes the following members.

Methods
 | Name | Description
Public method | ChangeSelection |
Public method | Close |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetItems |
Public method | GetSelectedItem |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetItems |
Public method | Show |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionPopup.ChangeSelection Method

EditorCodeCompletionControllerCodeCompletionPopupChangeSelection Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ChangeSelection(
    ChangePopupSelectionCommand command
)
Public Sub ChangeSelection (
    command As ChangePopupSelectionCommand
)
public:
virtual void ChangeSelection(
    ChangePopupSelectionCommand command
) sealed
abstract ChangeSelection :
        command : ChangePopupSelectionCommand -> unit
override ChangeSelection :
        command : ChangePopupSelectionCommand -> unit

Parameters

command
Type: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionChangePopupSelectionCommand

Implements

ICodeCompletionPopupChangeSelection(ChangePopupSelectionCommand)
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionPopup.Close Method

EditorCodeCompletionControllerCodeCompletionPopupClose Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
virtual void Close() sealed
abstract Close : unit -> unit
override Close : unit -> unit

Implements

ICodeCompletionPopupClose
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionPopup.GetItems Method

EditorCodeCompletionControllerCodeCompletionPopupGetItems Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> GetItems()
Public Function GetItems As IEnumerable(Of String)
public:
virtual IEnumerable<String^>^ GetItems() sealed
abstract GetItems : unit -> IEnumerable<string>
override GetItems : unit -> IEnumerable<string>

Return Value

Type: IEnumerableString

Implements

ICodeCompletionPopupGetItems
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionPopup.GetSelectedItem Method

EditorCodeCompletionControllerCodeCompletionPopupGetSelectedItem Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetSelectedItem()
Public Function GetSelectedItem As String
public:
virtual String^ GetSelectedItem() sealed
abstract GetSelectedItem : unit -> string
override GetSelectedItem : unit -> string

Return Value

Type: String

Implements

ICodeCompletionPopupGetSelectedItem
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionPopup.SetItems Method

EditorCodeCompletionControllerCodeCompletionPopupSetItems Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetItems(
    IEnumerable<Symbol> items
)
Public Sub SetItems (
    items As IEnumerable(Of Symbol)
)
public:
virtual void SetItems(
    IEnumerable<Symbol^>^ items
) sealed
abstract SetItems :
        items : IEnumerable<Symbol> -> unit
override SetItems :
        items : IEnumerable<Symbol> -> unit

Parameters

items
Type: System.Collections.GenericIEnumerableSymbol

Implements

ICodeCompletionPopupSetItems(IEnumerableSymbol)
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionPopup.Show Method

EditorCodeCompletionControllerCodeCompletionPopupShow Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Show(
    Control ownerControl,
    Point position
)
Public Sub Show (
    ownerControl As Control,
    position As Point
)
public:
virtual void Show(
    Control^ ownerControl,
    Point position
) sealed
abstract Show :
        ownerControl : Control *
        position : Point -> unit
override Show :
        ownerControl : Control *
        position : Point -> unit

Parameters

ownerControl
Type: System.Windows.FormsControl
position
Type: System.DrawingPoint

Implements

ICodeCompletionPopupShow(Control, Point)
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


CodeCompletionPopup Properties

CodeCompletionPopup Properties

The EditorCodeCompletionControllerCodeCompletionPopup type exposes the following members.

Properties
 | Name | Description
Public property | Visible |
Top
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.CodeCompletionPopup.Visible Property

EditorCodeCompletionControllerCodeCompletionPopupVisible Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; }
Public ReadOnly Property Visible As Boolean
    Get
public:
virtual property bool Visible {
    bool get () sealed;
}
abstract Visible : bool with get
override Visible : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionPopupVisible
See Also

Reference

EditorCodeCompletionControllerCodeCompletionPopup Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.ParameterInfoToolTip Class

EditorCodeCompletionControllerParameterInfoToolTip Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IntegrationEditorCodeCompletionControllerParameterInfoToolTip

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterInfoToolTip : IParameterInfoToolTip
Public Class ParameterInfoToolTip
    Implements IParameterInfoToolTip
public ref class ParameterInfoToolTip : IParameterInfoToolTip
type ParameterInfoToolTip =
    class
        interface IParameterInfoToolTip
    end

The EditorCodeCompletionControllerParameterInfoToolTip type exposes the following members.

Constructors
 | Name | Description
Public method | EditorCodeCompletionControllerParameterInfoToolTip | Initializes a new instance of the EditorCodeCompletionControllerParameterInfoToolTip class
Top
Methods
 | Name | Description
Public method | Close |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPreferredSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowPopup |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Visible |
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.ParameterInfoToolTip Constructor

EditorCodeCompletionControllerParameterInfoToolTip Constructor
Initializes a new instance of the EditorCodeCompletionControllerParameterInfoToolTip class

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfoToolTip(
    EditorCodeCompletionControllerCodeCompletionHint hint,
    ParameterInfoToolTipConfiguration configuration
)
Public Sub New (
    hint As EditorCodeCompletionControllerCodeCompletionHint,
    configuration As ParameterInfoToolTipConfiguration
)
public:
ParameterInfoToolTip(
    EditorCodeCompletionControllerCodeCompletionHint^ hint,
    ParameterInfoToolTipConfiguration^ configuration
)
new :
        hint : EditorCodeCompletionControllerCodeCompletionHint *
        configuration : ParameterInfoToolTipConfiguration -> ParameterInfoToolTip

Parameters

hint
Type: Alternet.Scripter.IntegrationEditorCodeCompletionControllerCodeCompletionHint
configuration
Type: ParameterInfoToolTipConfiguration
See Also

Reference

EditorCodeCompletionControllerParameterInfoToolTip Class
Alternet.Scripter.Integration Namespace


ParameterInfoToolTip Methods

ParameterInfoToolTip Methods

The EditorCodeCompletionControllerParameterInfoToolTip type exposes the following members.

Methods
 | Name | Description
Public method | Close |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPreferredSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowPopup |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EditorCodeCompletionControllerParameterInfoToolTip Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.ParameterInfoToolTip.Close Method

EditorCodeCompletionControllerParameterInfoToolTipClose Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
virtual void Close() sealed
abstract Close : unit -> unit
override Close : unit -> unit
See Also

Reference

EditorCodeCompletionControllerParameterInfoToolTip Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.ParameterInfoToolTip.GetPreferredSize Method

EditorCodeCompletionControllerParameterInfoToolTipGetPreferredSize Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Size GetPreferredSize()
Public Function GetPreferredSize As Size
public:
virtual Size GetPreferredSize() sealed
abstract GetPreferredSize : unit -> Size
override GetPreferredSize : unit -> Size

Return Value

Type: Size
See Also

Reference

EditorCodeCompletionControllerParameterInfoToolTip Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.ParameterInfoToolTip.ShowPopup Method

EditorCodeCompletionControllerParameterInfoToolTipShowPopup Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowPopup(
    ParameterInfoSymbol data,
    Point position
)
Public Sub ShowPopup (
    data As ParameterInfoSymbol,
    position As Point
)
public:
virtual void ShowPopup(
    ParameterInfoSymbol^ data,
    Point position
) sealed
abstract ShowPopup :
        data : ParameterInfoSymbol *
        position : Point -> unit
override ShowPopup :
        data : ParameterInfoSymbol *
        position : Point -> unit

Parameters

data
Type: Alternet.Scripter.Debugger.UI.Evaluation.CodeCompletionParameterInfoSymbol
position
Type: System.DrawingPoint
See Also

Reference

EditorCodeCompletionControllerParameterInfoToolTip Class
Alternet.Scripter.Integration Namespace


ParameterInfoToolTip Properties

ParameterInfoToolTip Properties

The EditorCodeCompletionControllerParameterInfoToolTip type exposes the following members.

Properties
 | Name | Description
Public property | Visible |
Top
See Also

Reference

EditorCodeCompletionControllerParameterInfoToolTip Class
Alternet.Scripter.Integration Namespace


EditorCodeCompletionController.ParameterInfoToolTip.Visible Property

EditorCodeCompletionControllerParameterInfoToolTipVisible Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; }
Public ReadOnly Property Visible As Boolean
    Get
public:
virtual property bool Visible {
    bool get () sealed;
}
abstract Visible : bool with get
override Visible : bool with get

Property Value

Type: Boolean
See Also

Reference

EditorCodeCompletionControllerParameterInfoToolTip Class
Alternet.Scripter.Integration Namespace


IDebugEdit Interface

IDebugEdit Interface
Represents a text box with extended features for script debugging of the source code.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDebugEdit : IScriptEdit,
    IControl
Public Interface IDebugEdit
    Inherits IScriptEdit, IControl
public interface class IDebugEdit : IScriptEdit,
    IControl
type IDebugEdit =
    interface
        interface IScriptEdit
        interface IControl
    end

The IDebugEdit type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdate | (Inherited from IScriptEdit.)
Public method | BreakpointDeleted | When implemented by a class, updates line styles when given breakpoint is being deleted.
Public method | BreakpointStateChanged | When implemented by a class, updates line styles when given breakpoint state changes.
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | ClearDebugStyles | When implemented by a class, removes visual styles related to the step by step execution at specified position.
Public method | ClearStackFrame | When implemented by a class, removes visual styles related to the step by step execution at specified position.
Public method | Copy | (Inherited from IScriptEdit.)
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | Cut | (Inherited from IScriptEdit.)
Public method | Delete | (Inherited from IScriptEdit.)
Public method | DeselectAll | (Inherited from IScriptEdit.)
Public method | EndUpdate | (Inherited from IScriptEdit.)
Public method | ExecutionStopped | When implemented by a class, updates line styles when debugging is being paused.
Public method | Find | (Inherited from IScriptEdit.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | GetLine | (Inherited from IScriptEdit.)
Public method | GetSymbolAtCursor | (Inherited from IScriptEdit.)
Public method | GotoLine | (Inherited from IScriptEdit.)
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | LoadFile | (Inherited from IScriptEdit.)
Public method | Localize | When implemented by a class, localizes string resources.
Public method | MakeVisible | (Inherited from IScriptEdit.)
Public method | MoveLineEnd | (Inherited from IScriptEdit.)
Public method | MoveToLine | (Inherited from IScriptEdit.)
Public method | Paste | (Inherited from IScriptEdit.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Print | (Inherited from IScriptEdit.)
Public method | PrintPreview | (Inherited from IScriptEdit.)
Public method | Redo | (Inherited from IScriptEdit.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | Replace | (Inherited from IScriptEdit.)
Public method | SaveFile | (Inherited from IScriptEdit.)
Public method | Search | (Inherited from IScriptEdit.)
Public method | SelectAll | (Inherited from IScriptEdit.)
Public method | SwitchStackFrame | When implemented by a class, updates line styles when debugger switches to the stack frame.
Public method | Undo | (Inherited from IScriptEdit.)
Public method | UpdateSyntax | (Inherited from IScriptEdit.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanFindDeclaration | (Defined by CodeEditExtensions.)
Public Extension Method | Document | (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindImplementations | (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterDefaultAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterNamespaces | (Defined by CodeEditExtensions.)
Public Extension Method | SetFileNameAndProject | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Top
Properties
 | Name | Description
Public property | AllowedActions | When implemented by a class, gets or sets allowed actions.
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanCopy | (Inherited from IScriptEdit.)
Public property | CanCut | (Inherited from IScriptEdit.)
Public property | CanDelete | (Inherited from IScriptEdit.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | CanPaste | (Inherited from IScriptEdit.)
Public property | CanRedo | (Inherited from IScriptEdit.)
Public property | CanUndo | (Inherited from IScriptEdit.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | CurrentChar | (Inherited from IScriptEdit.)
Public property | CurrentLine | (Inherited from IScriptEdit.)
Public property | Debugger | When implemented by a class, gets or sets a IScriptDebuggerBase bound to this control.
Public property | DefaultMenu | (Inherited from IScriptEdit.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | FileName | (Inherited from IScriptEdit.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | Modified | (Inherited from IScriptEdit.)
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | Position | (Inherited from IScriptEdit.)
Public property | ReadOnly | (Inherited from IScriptEdit.)
Public property | Status | (Inherited from IScriptEdit.)
Public property | StatusText | Obsolete. (Inherited from IScriptEdit.)
Public property | Text | (Inherited from IScriptEdit.)
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
Events
 | Name | Description
Public event | AddToWatchClick | When implemented by a class, occurs when user executes Find All Implementations command.
Public event | BreakpointToggle | When implemented by a class, occurs when given breakpoint is toggled on/off.
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Public event | FindAllImplementations | When implemented by a class, occurs when user executes Find All Implementations command.
Public event | FindAllReferences | When implemented by a class, occurs when user executes Find All References command.
Public event | GotoDefinition | When implemented by a class, occurs when user executes Goto Definition command.
Public event | ModifiedChanged | (Inherited from IScriptEdit.)
Public event | ParserChanged | (Inherited from IScriptEdit.)
Public event | SetNextStatement | When implemented by a class, occurs when the execution position moves to the different line of code.
Public event | StatusChanged | (Inherited from IScriptEdit.)
Public event | TextChanged | (Inherited from IScriptEdit.)
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


IDebugEdit Methods

IDebugEdit Methods

The IDebugEdit type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdate | (Inherited from IScriptEdit.)
Public method | BreakpointDeleted | When implemented by a class, updates line styles when given breakpoint is being deleted.
Public method | BreakpointStateChanged | When implemented by a class, updates line styles when given breakpoint state changes.
Public method | BringToFront | When implemented by a class, brings the control to the front of the z-order. (Inherited from IControl.)
Public method | ClearDebugStyles | When implemented by a class, removes visual styles related to the step by step execution at specified position.
Public method | ClearStackFrame | When implemented by a class, removes visual styles related to the step by step execution at specified position.
Public method | Copy | (Inherited from IScriptEdit.)
Public method | CreateGraphics | When implemented by a class, creates the Graphics for the control. (Inherited from IControl.)
Public method | Cut | (Inherited from IScriptEdit.)
Public method | Delete | (Inherited from IScriptEdit.)
Public method | DeselectAll | (Inherited from IScriptEdit.)
Public method | EndUpdate | (Inherited from IScriptEdit.)
Public method | ExecutionStopped | When implemented by a class, updates line styles when debugging is being paused.
Public method | Find | (Inherited from IScriptEdit.)
Public method | FindForm | When implemented by a class, retrieves the form that the control is on. (Inherited from IControl.)
Public method | Focus | When implemented by a class, sets input focus to the control. (Inherited from IControl.)
Public method | GetLine | (Inherited from IScriptEdit.)
Public method | GetSymbolAtCursor | (Inherited from IScriptEdit.)
Public method | GotoLine | (Inherited from IScriptEdit.)
Public method | Invalidate | When implemented by a class, invalidates the entire client area of the control. (Inherited from IControl.)
Public method | Invalidate(Rectangle) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invalidate(Region, Boolean) | When implemented by a class, invalidates a specific region of the control. (Inherited from IControl.)
Public method | Invoke | When implemented by a class, executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from IControl.)
Public method | LoadFile | (Inherited from IScriptEdit.)
Public method | Localize | When implemented by a class, localizes string resources.
Public method | MakeVisible | (Inherited from IScriptEdit.)
Public method | MoveLineEnd | (Inherited from IScriptEdit.)
Public method | MoveToLine | (Inherited from IScriptEdit.)
Public method | Paste | (Inherited from IScriptEdit.)
Public method | PointToClient | When implemented by a class, computes the location of the specified screen point into client coordinates. (Inherited from IControl.)
Public method | PointToScreen | When implemented by a class, computes the location of the specified client point into screen coordinates. (Inherited from IControl.)
Public method | Print | (Inherited from IScriptEdit.)
Public method | PrintPreview | (Inherited from IScriptEdit.)
Public method | Redo | (Inherited from IScriptEdit.)
Public method | Refresh | When implemented by a class, causes the control to redraw the invalidated regions within its client area. (Inherited from IControl.)
Public method | Replace | (Inherited from IScriptEdit.)
Public method | SaveFile | (Inherited from IScriptEdit.)
Public method | Search | (Inherited from IScriptEdit.)
Public method | SelectAll | (Inherited from IScriptEdit.)
Public method | SwitchStackFrame | When implemented by a class, updates line styles when debugger switches to the stack frame.
Public method | Undo | (Inherited from IScriptEdit.)
Public method | UpdateSyntax | (Inherited from IScriptEdit.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanFindDeclaration | (Defined by CodeEditExtensions.)
Public Extension Method | Document | (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindDeclaration(Point) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindImplementations | (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | FindReferences(Point, IRangeList) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | InitSyntax | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterCode(String, String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | RegisterDefaultAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | RegisterNamespaces | (Defined by CodeEditExtensions.)
Public Extension Method | SetFileNameAndProject | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssemblies | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterAssembly | (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Public Extension Method | UnregisterCode(String) | Overloaded. (Defined by CodeEditExtensions.)
Top
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.BreakpointDeleted Method

IDebugEditBreakpointDeleted Method
When implemented by a class, updates line styles when given breakpoint is being deleted.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BreakpointDeleted(
    Breakpoint breakpoint
)
Sub BreakpointDeleted (
    breakpoint As Breakpoint
)
void BreakpointDeleted(
    Breakpoint^ breakpoint
)
abstract BreakpointDeleted :
        breakpoint : Breakpoint -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
Breakpoint to be deleted.
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.BreakpointStateChanged Method

IDebugEditBreakpointStateChanged Method
When implemented by a class, updates line styles when given breakpoint state changes.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BreakpointStateChanged(
    Breakpoint breakpoint
)
Sub BreakpointStateChanged (
    breakpoint As Breakpoint
)
void BreakpointStateChanged(
    Breakpoint^ breakpoint
)
abstract BreakpointStateChanged :
        breakpoint : Breakpoint -> unit

Parameters

breakpoint
Type: Alternet.Scripter.DebuggerBreakpoint
Breakpoint which state was changed.
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.ClearDebugStyles Method

IDebugEditClearDebugStyles Method
When implemented by a class, removes visual styles related to the step by step execution at specified position.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearDebugStyles(
    ExecutionPosition executionPos
)
Sub ClearDebugStyles (
    executionPos As ExecutionPosition
)
void ClearDebugStyles(
    ExecutionPosition^ executionPos
)
abstract ClearDebugStyles :
        executionPos : ExecutionPosition -> unit

Parameters

executionPos
Type: Alternet.Scripter.DebuggerExecutionPosition
Current execution line number and a file name.
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.ClearStackFrame Method

IDebugEditClearStackFrame Method
When implemented by a class, removes visual styles related to the step by step execution at specified position.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearStackFrame(
    StackFrame stackFrame
)
Sub ClearStackFrame (
    stackFrame As StackFrame
)
void ClearStackFrame(
    StackFrame^ stackFrame
)
abstract ClearStackFrame :
        stackFrame : StackFrame -> unit

Parameters

stackFrame
Type: Alternet.Scripter.DebuggerStackFrame
StackFrame representing position to be cleared.
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.ExecutionStopped Method

IDebugEditExecutionStopped Method
When implemented by a class, updates line styles when debugging is being paused.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ExecutionStopped(
    ExecutionPosition executionPos
)
Sub ExecutionStopped (
    executionPos As ExecutionPosition
)
void ExecutionStopped(
    ExecutionPosition^ executionPos
)
abstract ExecutionStopped :
        executionPos : ExecutionPosition -> unit

Parameters

executionPos
Type: Alternet.Scripter.DebuggerExecutionPosition
Current execution line number and a file name.
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.Localize Method

IDebugEditLocalize Method
When implemented by a class, localizes string resources.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Localize()
Sub Localize
void Localize()
abstract Localize : unit -> unit
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.SwitchStackFrame Method

IDebugEditSwitchStackFrame Method
When implemented by a class, updates line styles when debugger switches to the stack frame.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SwitchStackFrame(
    StackFrame stackFrame,
    ExecutionPosition executionPos
)
Sub SwitchStackFrame (
    stackFrame As StackFrame,
    executionPos As ExecutionPosition
)
void SwitchStackFrame(
    StackFrame^ stackFrame,
    ExecutionPosition^ executionPos
)
abstract SwitchStackFrame :
        stackFrame : StackFrame *
        executionPos : ExecutionPosition -> unit

Parameters

stackFrame
Type: Alternet.Scripter.DebuggerStackFrame
StackFrame to be switched to.
executionPos
Type: Alternet.Scripter.DebuggerExecutionPosition
Current execution line number and a file name.
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit Properties

IDebugEdit Properties

The IDebugEdit type exposes the following members.

Properties
 | Name | Description
Public property | AllowedActions | When implemented by a class, gets or sets allowed actions.
Public property | BackColor | When implemented by a class, gets or sets the background color for the control. (Inherited from IControl.)
Public property | BackgroundImage | When implemented by a class, gets or sets the background image displayed in the control. (Inherited from IControl.)
Public property | Bounds | When implemented by a class, gets or sets the size and location of the control including its non-client elements. (Inherited from IControl.)
Public property | CanCopy | (Inherited from IScriptEdit.)
Public property | CanCut | (Inherited from IScriptEdit.)
Public property | CanDelete | (Inherited from IScriptEdit.)
Public property | CanFocus | When implemented by a class, returns boolean value indicating whether the control can receive input focus. (Inherited from IControl.)
Public property | CanPaste | (Inherited from IScriptEdit.)
Public property | CanRedo | (Inherited from IScriptEdit.)
Public property | CanUndo | (Inherited from IScriptEdit.)
Public property | ClientRectangle | When implemented by a class, gets the rectangle that represents the client area of the control. (Inherited from IControl.)
Public property | ContextMenuStrip | When implemented by a class, gets or sets the ContextMenuStrip associated with this control. (Inherited from IControl.)
Public property | Created | When implemented by a class, gets a value indicating whether the control has been created. (Inherited from IControl.)
Public property | CurrentChar | (Inherited from IScriptEdit.)
Public property | CurrentLine | (Inherited from IScriptEdit.)
Public property | Debugger | When implemented by a class, gets or sets a IScriptDebuggerBase bound to this control.
Public property | DefaultMenu | (Inherited from IScriptEdit.)
Public property | Dock | When implemented by a class, gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from IControl.)
Public property | Enabled | When implemented by a class, gets or sets a value indicating whether the control can respond to user interaction. (Inherited from IControl.)
Public property | FileName | (Inherited from IScriptEdit.)
Public property | Focused | When implemented by a class, gets a value indicating whether the control has input focus. (Inherited from IControl.)
Public property | Font | When implemented by a class, gets or sets the font of the text displayed by the control. (Inherited from IControl.)
Public property | ForeColor | When implemented by a class, gets or sets the foreground color of the control. (Inherited from IControl.)
Public property | Handle | When implemented by a class, gets the window handle that the control is bound to. (Inherited from IControl.)
Public property | Height | When implemented by a class, gets or sets the height of the control. (Inherited from IControl.)
Public property | IsHandleCreated | When implemented by a class, gets a value indicating whether the control has a handle associated with it. (Inherited from IControl.)
Public property | Left | When implemented by a class, gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from IControl.)
Public property | Location | When implemented by a class, gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from IControl.)
Public property | Modified | (Inherited from IScriptEdit.)
Public property | Parent | When implemented by a class, gets or sets a reference to the server control's parent control in the page control hierarchy. (Inherited from IControl.)
Public property | Position | (Inherited from IScriptEdit.)
Public property | ReadOnly | (Inherited from IScriptEdit.)
Public property | Status | (Inherited from IScriptEdit.)
Public property | StatusText | Obsolete. (Inherited from IScriptEdit.)
Public property | Text | (Inherited from IScriptEdit.)
Public property | Top | When implemented by a class, gets or sets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from IControl.)
Public property | Visible | When implemented by a class, gets or sets a value indicating whether the control is displayed. (Inherited from IControl.)
Public property | Width | When implemented by a class, gets or sets the width of the control. (Inherited from IControl.)
Top
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.AllowedActions Property

IDebugEditAllowedActions Property
When implemented by a class, gets or sets allowed actions.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
AllowedActions AllowedActions { get; set; }
Property AllowedActions As AllowedActions
    Get
    Set
property AllowedActions AllowedActions {
    AllowedActions get ();
    void set (AllowedActions value);
}
abstract AllowedActions : AllowedActions with get, set

Property Value

Type: AllowedActions
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.Debugger Property

IDebugEditDebugger Property
When implemented by a class, gets or sets a IScriptDebuggerBase bound to this control.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptDebuggerBase Debugger { get; set; }
Property Debugger As IScriptDebuggerBase
    Get
    Set
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
abstract Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit Events

IDebugEdit Events

The IDebugEdit type exposes the following members.

Events
 | Name | Description
Public event | AddToWatchClick | When implemented by a class, occurs when user executes Find All Implementations command.
Public event | BreakpointToggle | When implemented by a class, occurs when given breakpoint is toggled on/off.
Public event | Click | When implemented by a class, occurs when the control is clicked. (Inherited from IControl.)
Public event | FindAllImplementations | When implemented by a class, occurs when user executes Find All Implementations command.
Public event | FindAllReferences | When implemented by a class, occurs when user executes Find All References command.
Public event | GotoDefinition | When implemented by a class, occurs when user executes Goto Definition command.
Public event | ModifiedChanged | (Inherited from IScriptEdit.)
Public event | ParserChanged | (Inherited from IScriptEdit.)
Public event | SetNextStatement | When implemented by a class, occurs when the execution position moves to the different line of code.
Public event | StatusChanged | (Inherited from IScriptEdit.)
Public event | TextChanged | (Inherited from IScriptEdit.)
Top
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.AddToWatchClick Event

IDebugEditAddToWatchClick Event
When implemented by a class, occurs when user executes Find All Implementations command.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AddToWatchClickEventArgs> AddToWatchClick
Event AddToWatchClick As EventHandler(Of AddToWatchClickEventArgs)
 event EventHandler<AddToWatchClickEventArgs^>^ AddToWatchClick {
    void add (EventHandler<AddToWatchClickEventArgs^>^ value);
    void remove (EventHandler<AddToWatchClickEventArgs^>^ value);
}
abstract AddToWatchClick : IEvent<EventHandler<AddToWatchClickEventArgs>,
    AddToWatchClickEventArgs>

Value

Type: SystemEventHandlerAddToWatchClickEventArgs
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.BreakpointToggle Event

IDebugEditBreakpointToggle Event
When implemented by a class, occurs when given breakpoint is toggled on/off.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler BreakpointToggle
Event BreakpointToggle As EventHandler
 event EventHandler^ BreakpointToggle {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BreakpointToggle : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.FindAllImplementations Event

IDebugEditFindAllImplementations Event
When implemented by a class, occurs when user executes Find All Implementations command.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler FindAllImplementations
Event FindAllImplementations As EventHandler
 event EventHandler^ FindAllImplementations {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FindAllImplementations : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.FindAllReferences Event

IDebugEditFindAllReferences Event
When implemented by a class, occurs when user executes Find All References command.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler FindAllReferences
Event FindAllReferences As EventHandler
 event EventHandler^ FindAllReferences {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FindAllReferences : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.GotoDefinition Event

IDebugEditGotoDefinition Event
When implemented by a class, occurs when user executes Goto Definition command.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler GotoDefinition
Event GotoDefinition As EventHandler
 event EventHandler^ GotoDefinition {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract GotoDefinition : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEdit.SetNextStatement Event

IDebugEditSetNextStatement Event
When implemented by a class, occurs when the execution position moves to the different line of code.

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler SetNextStatement
Event SetNextStatement As EventHandler
 event EventHandler^ SetNextStatement {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SetNextStatement : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IDebugEdit Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer Interface

IDebugEditContainer Interface

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDebugEditContainer
Public Interface IDebugEditContainer
public interface class IDebugEditContainer
type IDebugEditContainer =  interface end

The IDebugEditContainer type exposes the following members.

Methods
 | Name | Description
Public method | CloseFile |
Public method | TryActivateEditor |
Public method | TryGetEditorByFileName |
Top
Properties
 | Name | Description
Public property | ActiveEditor |
Public property | Debugger |
Public property | Editors |
Top
Events
 | Name | Description
Public event | CommandExecuted |
Public event | EditorRequested |
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


IDebugEditContainer Methods

IDebugEditContainer Methods

The IDebugEditContainer type exposes the following members.

Methods
 | Name | Description
Public method | CloseFile |
Public method | TryActivateEditor |
Public method | TryGetEditorByFileName |
Top
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer.CloseFile Method

IDebugEditContainerCloseFile Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CloseFile(
    string fileName
)
Sub CloseFile (
    fileName As String
)
void CloseFile(
    String^ fileName
)
abstract CloseFile :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer.TryActivateEditor Method

IDebugEditContainerTryActivateEditor Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDebugEdit TryActivateEditor(
    string fileName
)
Function TryActivateEditor (
    fileName As String
) As IDebugEdit
IDebugEdit^ TryActivateEditor(
    String^ fileName
)
abstract TryActivateEditor :
        fileName : string -> IDebugEdit

Parameters

fileName
Type: SystemString

Return Value

Type: IDebugEdit
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer.TryGetEditorByFileName Method

IDebugEditContainerTryGetEditorByFileName Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDebugEdit TryGetEditorByFileName(
    string fileName
)
Function TryGetEditorByFileName (
    fileName As String
) As IDebugEdit
IDebugEdit^ TryGetEditorByFileName(
    String^ fileName
)
abstract TryGetEditorByFileName :
        fileName : string -> IDebugEdit

Parameters

fileName
Type: SystemString

Return Value

Type: IDebugEdit
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer Properties

IDebugEditContainer Properties

The IDebugEditContainer type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEditor |
Public property | Debugger |
Public property | Editors |
Top
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer.ActiveEditor Property

IDebugEditContainerActiveEditor Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDebugEdit ActiveEditor { get; }
ReadOnly Property ActiveEditor As IDebugEdit
    Get
property IDebugEdit^ ActiveEditor {
    IDebugEdit^ get ();
}
abstract ActiveEditor : IDebugEdit with get

Property Value

Type: IDebugEdit
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer.Debugger Property

IDebugEditContainerDebugger Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptDebuggerBase Debugger { get; set; }
Property Debugger As IScriptDebuggerBase
    Get
    Set
property IScriptDebuggerBase^ Debugger {
    IScriptDebuggerBase^ get ();
    void set (IScriptDebuggerBase^ value);
}
abstract Debugger : IScriptDebuggerBase with get, set

Property Value

Type: IScriptDebuggerBase
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer.Editors Property

IDebugEditContainerEditors Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IReadOnlyCollection<IDebugEdit> Editors { get; }
ReadOnly Property Editors As IReadOnlyCollection(Of IDebugEdit)
    Get
property IReadOnlyCollection<IDebugEdit^>^ Editors {
    IReadOnlyCollection<IDebugEdit^>^ get ();
}
abstract Editors : IReadOnlyCollection<IDebugEdit> with get

Property Value

Type: IReadOnlyCollectionIDebugEdit
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer Events

IDebugEditContainer Events

The IDebugEditContainer type exposes the following members.

Events
 | Name | Description
Public event | CommandExecuted |
Public event | EditorRequested |
Top
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer.CommandExecuted Event

IDebugEditContainerCommandExecuted Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<DebugEditCommandExecutedEventArgs> CommandExecuted
Event CommandExecuted As EventHandler(Of DebugEditCommandExecutedEventArgs)
 event EventHandler<DebugEditCommandExecutedEventArgs^>^ CommandExecuted {
    void add (EventHandler<DebugEditCommandExecutedEventArgs^>^ value);
    void remove (EventHandler<DebugEditCommandExecutedEventArgs^>^ value);
}
abstract CommandExecuted : IEvent<EventHandler<DebugEditCommandExecutedEventArgs>,
    DebugEditCommandExecutedEventArgs>

Value

Type: SystemEventHandlerDebugEditCommandExecutedEventArgs
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebugEditContainer.EditorRequested Event

IDebugEditContainerEditorRequested Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<DebugEditRequestedEventArgs> EditorRequested
Event EditorRequested As EventHandler(Of DebugEditRequestedEventArgs)
 event EventHandler<DebugEditRequestedEventArgs^>^ EditorRequested {
    void add (EventHandler<DebugEditRequestedEventArgs^>^ value);
    void remove (EventHandler<DebugEditRequestedEventArgs^>^ value);
}
abstract EditorRequested : IEvent<EventHandler<DebugEditRequestedEventArgs>,
    DebugEditRequestedEventArgs>

Value

Type: SystemEventHandlerDebugEditRequestedEventArgs
See Also

Reference

IDebugEditContainer Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels Interface

IDebuggerPanels Interface

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDebuggerPanels
Public Interface IDebuggerPanels
public interface class IDebuggerPanels
type IDebuggerPanels =  interface end

The IDebuggerPanels type exposes the following members.

Methods
 | Name | Description
Public method | FocusPanel |
Public method | IsPanelActive |
Top
Properties
 | Name | Description
Public property | Breakpoints |
Public property | CallStack |
Public property | Errors |
Public property | FindResults |
Public property | Locals |
Public property | Output |
Public property | Threads |
Public property | Watches |
Top
Events
 | Name | Description
Public event | ActivePanelsChanged |
Top
See Also

Reference

Alternet.Scripter.Integration Namespace


IDebuggerPanels Methods

IDebuggerPanels Methods

The IDebuggerPanels type exposes the following members.

Methods
 | Name | Description
Public method | FocusPanel |
Public method | IsPanelActive |
Top
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.FocusPanel Method

IDebuggerPanelsFocusPanel Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FocusPanel(
    DebuggerPanelKinds panel
)
Sub FocusPanel (
    panel As DebuggerPanelKinds
)
void FocusPanel(
    DebuggerPanelKinds panel
)
abstract FocusPanel :
        panel : DebuggerPanelKinds -> unit

Parameters

panel
Type: Alternet.Scripter.IntegrationDebuggerPanelKinds
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.IsPanelActive Method

IDebuggerPanelsIsPanelActive Method

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPanelActive(
    DebuggerPanelKinds panel
)
Function IsPanelActive (
    panel As DebuggerPanelKinds
) As Boolean
bool IsPanelActive(
    DebuggerPanelKinds panel
)
abstract IsPanelActive :
        panel : DebuggerPanelKinds -> bool

Parameters

panel
Type: Alternet.Scripter.IntegrationDebuggerPanelKinds

Return Value

Type: Boolean
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels Properties

IDebuggerPanels Properties

The IDebuggerPanels type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints |
Public property | CallStack |
Public property | Errors |
Public property | FindResults |
Public property | Locals |
Public property | Output |
Public property | Threads |
Public property | Watches |
Top
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.Breakpoints Property

IDebuggerPanelsBreakpoints Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Breakpoints Breakpoints { get; }
ReadOnly Property Breakpoints As Breakpoints
    Get
property Breakpoints^ Breakpoints {
    Breakpoints^ get ();
}
abstract Breakpoints : Breakpoints with get

Property Value

Type: Breakpoints
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.CallStack Property

IDebuggerPanelsCallStack Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
CallStack CallStack { get; }
ReadOnly Property CallStack As CallStack
    Get
property CallStack^ CallStack {
    CallStack^ get ();
}
abstract CallStack : CallStack with get

Property Value

Type: CallStack
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.Errors Property

IDebuggerPanelsErrors Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Errors Errors { get; }
ReadOnly Property Errors As Errors
    Get
property Errors^ Errors {
    Errors^ get ();
}
abstract Errors : Errors with get

Property Value

Type: Errors
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.FindResults Property

IDebuggerPanelsFindResults Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
FindResults FindResults { get; }
ReadOnly Property FindResults As FindResults
    Get
property FindResults^ FindResults {
    FindResults^ get ();
}
abstract FindResults : FindResults with get

Property Value

Type: FindResults
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.Locals Property

IDebuggerPanelsLocals Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Locals Locals { get; }
ReadOnly Property Locals As Locals
    Get
property Locals^ Locals {
    Locals^ get ();
}
abstract Locals : Locals with get

Property Value

Type: Locals
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.Output Property

IDebuggerPanelsOutput Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Output Output { get; }
ReadOnly Property Output As Output
    Get
property Output^ Output {
    Output^ get ();
}
abstract Output : Output with get

Property Value

Type: Output
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.Threads Property

IDebuggerPanelsThreads Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Threads Threads { get; }
ReadOnly Property Threads As Threads
    Get
property Threads^ Threads {
    Threads^ get ();
}
abstract Threads : Threads with get

Property Value

Type: Threads
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.Watches Property

IDebuggerPanelsWatches Property

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Watches Watches { get; }
ReadOnly Property Watches As Watches
    Get
property Watches^ Watches {
    Watches^ get ();
}
abstract Watches : Watches with get

Property Value

Type: Watches
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels Events

IDebuggerPanels Events

The IDebuggerPanels type exposes the following members.

Events
 | Name | Description
Public event | ActivePanelsChanged |
Top
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


IDebuggerPanels.ActivePanelsChanged Event

IDebuggerPanelsActivePanelsChanged Event

Namespace: Alternet.Scripter.Integration
Assembly: Alternet.Scripter.Integration.v7 (in Alternet.Scripter.Integration.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler ActivePanelsChanged
Event ActivePanelsChanged As EventHandler
 event EventHandler^ ActivePanelsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ActivePanelsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IDebuggerPanels Interface
Alternet.Scripter.Integration Namespace


Alternet.Scripter.IronPython Namespace

Alternet.Scripter.IronPython Namespace
Classes
 | Class | Description
Public class | FileRunnableScript | Represents compiled script assembly stored in the file system.
Public class | InMemoryRunnableScript | Represents compiled script assembly stored in memory.
Public class | IronPythonScriptHost | Provides properties and methods to support script engine functionality based on System.CodeDom.Compiler technology.
Public class | ProjectLoader |
Public class | ResolveReferenceEventArgs | Provides data for the IScriptRun.ReferenceResolve event.
Public class | RunnableScript | A base class represents compiled script assembly. This class is abstract.
Public class | ScriptConsts | Contains constants related to Scripter component.
Public class | ScriptGlobalItem | Describes a global object from the script.
Public class | ScriptHost | Provides a base class for script execution. This class is abstract.
Public class | ScriptRun | Represents runner for script engine.
Public class | ScriptSource | Provides methods and properties to work with script text, files or projects.
Interfaces
 | Interface | Description
Public interface | IScriptHost | Represents methods and properties declaration to support a script engine functionality.
Public interface | IScriptRun | Represents methods and properties declaration to describe runner for script engine.
Public interface | IScriptSource | Represents methods and properties to work with script text, files or projects.


FileRunnableScript Class

FileRunnableScript Class
Represents compiled script assembly stored in the file system.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IronPythonRunnableScript
Alternet.Scripter.IronPythonFileRunnableScript

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FileRunnableScript : RunnableScript
Public Class FileRunnableScript
    Inherits RunnableScript
public ref class FileRunnableScript : public RunnableScript
type FileRunnableScript =
    class
        inherit RunnableScript
    end

The FileRunnableScript type exposes the following members.

Constructors
 | Name | Description
Public method | FileRunnableScript | Initializes a new instance of the FileRunnableScript class with specified list of files.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides RunnableScriptExecute(ScriptEngine, ScriptScope).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSources | (Overrides RunnableScriptGetSources(ScriptEngine).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FilePaths | Gets list of compiled files.
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


FileRunnableScript Constructor

FileRunnableScript Constructor
Initializes a new instance of the FileRunnableScript class with specified list of files.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FileRunnableScript(
    IEnumerable<string> filePaths
)
Public Sub New (
    filePaths As IEnumerable(Of String)
)
public:
FileRunnableScript(
    IEnumerable<String^>^ filePaths
)
new :
        filePaths : IEnumerable<string> -> FileRunnableScript

Parameters

filePaths
Type: System.Collections.GenericIEnumerableString
List of files suitable for this script.
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.IronPython Namespace


FileRunnableScript Methods

FileRunnableScript Methods

The FileRunnableScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides RunnableScriptExecute(ScriptEngine, ScriptScope).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSources | (Overrides RunnableScriptGetSources(ScriptEngine).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.IronPython Namespace


FileRunnableScript.Execute Method

FileRunnableScriptExecute Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object Execute(
    ScriptEngine engine,
    ScriptScope scope
)
Public Overrides Function Execute (
    engine As ScriptEngine,
    scope As ScriptScope
) As Object
public:
virtual Object^ Execute(
    ScriptEngine^ engine,
    ScriptScope^ scope
) override
abstract Execute :
        engine : ScriptEngine *
        scope : ScriptScope -> Object
override Execute :
        engine : ScriptEngine *
        scope : ScriptScope -> Object

Parameters

engine
Type: ScriptEngine
scope
Type: ScriptScope

Return Value

Type: Object
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.IronPython Namespace


FileRunnableScript.GetSources Method

FileRunnableScriptGetSources Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<ScriptSource> GetSources(
    ScriptEngine engine
)
Public Overrides Function GetSources (
    engine As ScriptEngine
) As IEnumerable(Of ScriptSource)
public:
virtual IEnumerable<ScriptSource^>^ GetSources(
    ScriptEngine^ engine
) override
abstract GetSources :
        engine : ScriptEngine -> IEnumerable<ScriptSource>
override GetSources :
        engine : ScriptEngine -> IEnumerable<ScriptSource>

Parameters

engine
Type: ScriptEngine

Return Value

Type: IEnumerableScriptSource
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.IronPython Namespace


FileRunnableScript Properties

FileRunnableScript Properties

The FileRunnableScript type exposes the following members.

Properties
 | Name | Description
Public property | FilePaths | Gets list of compiled files.
Top
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.IronPython Namespace


FileRunnableScript.FilePaths Property

FileRunnableScriptFilePaths Property
Gets list of compiled files.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection<string> FilePaths { get; }
Public ReadOnly Property FilePaths As IReadOnlyCollection(Of String)
    Get
public:
property IReadOnlyCollection<String^>^ FilePaths {
    IReadOnlyCollection<String^>^ get ();
}
member FilePaths : IReadOnlyCollection<string> with get

Property Value

Type: IReadOnlyCollectionString
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.IronPython Namespace


InMemoryRunnableScript Class

InMemoryRunnableScript Class
Represents compiled script assembly stored in memory.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IronPythonRunnableScript
Alternet.Scripter.IronPythonInMemoryRunnableScript

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InMemoryRunnableScript : RunnableScript
Public Class InMemoryRunnableScript
    Inherits RunnableScript
public ref class InMemoryRunnableScript : public RunnableScript
type InMemoryRunnableScript =
    class
        inherit RunnableScript
    end

The InMemoryRunnableScript type exposes the following members.

Constructors
 | Name | Description
Public method | InMemoryRunnableScript | Initializes a new instance of the InMemoryRunnableScript class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides RunnableScriptExecute(ScriptEngine, ScriptScope).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSources | (Overrides RunnableScriptGetSources(ScriptEngine).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ScriptCode | Gets a script code to compile.
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


InMemoryRunnableScript Constructor

InMemoryRunnableScript Constructor
Initializes a new instance of the InMemoryRunnableScript class with specified parameters.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public InMemoryRunnableScript(
    string scriptCode
)
Public Sub New (
    scriptCode As String
)
public:
InMemoryRunnableScript(
    String^ scriptCode
)
new :
        scriptCode : string -> InMemoryRunnableScript

Parameters

scriptCode
Type: SystemString
Script code to compile.
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.IronPython Namespace


InMemoryRunnableScript Methods

InMemoryRunnableScript Methods

The InMemoryRunnableScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides RunnableScriptExecute(ScriptEngine, ScriptScope).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSources | (Overrides RunnableScriptGetSources(ScriptEngine).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.IronPython Namespace


InMemoryRunnableScript.Execute Method

InMemoryRunnableScriptExecute Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object Execute(
    ScriptEngine engine,
    ScriptScope scope
)
Public Overrides Function Execute (
    engine As ScriptEngine,
    scope As ScriptScope
) As Object
public:
virtual Object^ Execute(
    ScriptEngine^ engine,
    ScriptScope^ scope
) override
abstract Execute :
        engine : ScriptEngine *
        scope : ScriptScope -> Object
override Execute :
        engine : ScriptEngine *
        scope : ScriptScope -> Object

Parameters

engine
Type: ScriptEngine
scope
Type: ScriptScope

Return Value

Type: Object
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.IronPython Namespace


InMemoryRunnableScript.GetSources Method

InMemoryRunnableScriptGetSources Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<ScriptSource> GetSources(
    ScriptEngine engine
)
Public Overrides Function GetSources (
    engine As ScriptEngine
) As IEnumerable(Of ScriptSource)
public:
virtual IEnumerable<ScriptSource^>^ GetSources(
    ScriptEngine^ engine
) override
abstract GetSources :
        engine : ScriptEngine -> IEnumerable<ScriptSource>
override GetSources :
        engine : ScriptEngine -> IEnumerable<ScriptSource>

Parameters

engine
Type: ScriptEngine

Return Value

Type: IEnumerableScriptSource
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.IronPython Namespace


InMemoryRunnableScript Properties

InMemoryRunnableScript Properties

The InMemoryRunnableScript type exposes the following members.

Properties
 | Name | Description
Public property | ScriptCode | Gets a script code to compile.
Top
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.IronPython Namespace


InMemoryRunnableScript.ScriptCode Property

InMemoryRunnableScriptScriptCode Property
Gets a script code to compile.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptCode { get; }
Public ReadOnly Property ScriptCode As String
    Get
public:
property String^ ScriptCode {
    String^ get ();
}
member ScriptCode : string with get

Property Value

Type: String
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.IronPython Namespace


IronPythonScriptHost Class

IronPythonScriptHost Class
Provides properties and methods to support script engine functionality based on System.CodeDom.Compiler technology.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IronPythonScriptHost
Alternet.Scripter.IronPythonIronPythonScriptHost

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonScriptHost : ScriptHost
Public Class IronPythonScriptHost
    Inherits ScriptHost
public ref class IronPythonScriptHost : public ScriptHost
type IronPythonScriptHost =
    class
        inherit ScriptHost
    end

The IronPythonScriptHost type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonScriptHost | Initializes a new instance of the CodeDomScriptHost class with specified script runner.
Top
Methods
 | Name | Description
Public method | Compile | (Overrides ScriptHostCompile.)
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it. (Inherited from ScriptHost.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression. (Inherited from ScriptHost.)
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously. (Inherited from ScriptHost.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers. (Overrides ScriptHostReset.)
Public method | ResolveReferences | (Overrides ScriptHostResolveReferences(IListString).)
Public method | Run | Executes script starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunAsync | Executes script asynchronously starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunFunction | Executes specified function. (Inherited from ScriptHost.)
Public method | RunFunctionAsync | Executes specified function asynchronously. (Inherited from ScriptHost.)
Public method | RunProcess | Executes script starting from the main entry point in standalone process. (Inherited from ScriptHost.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed. (Inherited from ScriptHost.)
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation. (Inherited from ScriptHost.)
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed. (Inherited from ScriptHost.)
Public property | Engine |
Public property | ExecutableModulePath | Gets script assembly path. (Inherited from ScriptHost.)
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies. (Inherited from ScriptHost.)
Public property | OutputFileName | Gets script assembly file name. (Inherited from ScriptHost.)
Public property | ScriptRun | Gets IScriptRun associated this script host. (Inherited from ScriptHost.)
Public property | SkipSyntaxErrorCheck | Gets or sets a boolean value indicating whether to skip the script syntax error check. (Inherited from ScriptHost.)
Public property | TraceCallback | (Overrides ScriptHostTraceCallback.)
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


IronPythonScriptHost Constructor

IronPythonScriptHost Constructor
Initializes a new instance of the CodeDomScriptHost class with specified script runner.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonScriptHost(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
IronPythonScriptHost(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> IronPythonScriptHost

Parameters

scriptRun
Type: Alternet.Scripter.IronPythonIScriptRun
Specifies object that implements IScriptRun interface for this new instance.
See Also

Reference

IronPythonScriptHost Class
Alternet.Scripter.IronPython Namespace


IronPythonScriptHost Methods

IronPythonScriptHost Methods

The IronPythonScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | (Overrides ScriptHostCompile.)
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it. (Inherited from ScriptHost.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression. (Inherited from ScriptHost.)
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously. (Inherited from ScriptHost.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers. (Overrides ScriptHostReset.)
Public method | ResolveReferences | (Overrides ScriptHostResolveReferences(IListString).)
Public method | Run | Executes script starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunAsync | Executes script asynchronously starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunFunction | Executes specified function. (Inherited from ScriptHost.)
Public method | RunFunctionAsync | Executes specified function asynchronously. (Inherited from ScriptHost.)
Public method | RunProcess | Executes script starting from the main entry point in standalone process. (Inherited from ScriptHost.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IronPythonScriptHost Class
Alternet.Scripter.IronPython Namespace


IronPythonScriptHost.Compile Method

IronPythonScriptHostCompile Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Compile()
Public Overrides Function Compile As Boolean
public:
virtual bool Compile() override
abstract Compile : unit -> bool
override Compile : unit -> bool

Return Value

Type: Boolean

Implements

IScriptHostCompile
See Also

Reference

IronPythonScriptHost Class
Alternet.Scripter.IronPython Namespace


IronPythonScriptHost.Reset Method

IronPythonScriptHostReset Method
Removes the script engine from the running state and disconnects automatically bound event handlers.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptHostReset
See Also

Reference

IronPythonScriptHost Class
Alternet.Scripter.IronPython Namespace


IronPythonScriptHost.ResolveReferences Method

IronPythonScriptHostResolveReferences Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IList<string> ResolveReferences(
    IList<string> unresolvedReferences
)
Public Overrides Function ResolveReferences (
    unresolvedReferences As IList(Of String)
) As IList(Of String)
public:
virtual IList<String^>^ ResolveReferences(
    IList<String^>^ unresolvedReferences
) override
abstract ResolveReferences :
        unresolvedReferences : IList<string> -> IList<string>
override ResolveReferences :
        unresolvedReferences : IList<string> -> IList<string>

Parameters

unresolvedReferences
Type: System.Collections.GenericIListString

Return Value

Type: IListString

Implements

IScriptHostResolveReferences(IListString)
See Also

Reference

IronPythonScriptHost Class
Alternet.Scripter.IronPython Namespace


IronPythonScriptHost Properties

IronPythonScriptHost Properties

The IronPythonScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed. (Inherited from ScriptHost.)
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation. (Inherited from ScriptHost.)
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed. (Inherited from ScriptHost.)
Public property | Engine |
Public property | ExecutableModulePath | Gets script assembly path. (Inherited from ScriptHost.)
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies. (Inherited from ScriptHost.)
Public property | OutputFileName | Gets script assembly file name. (Inherited from ScriptHost.)
Public property | ScriptRun | Gets IScriptRun associated this script host. (Inherited from ScriptHost.)
Public property | SkipSyntaxErrorCheck | Gets or sets a boolean value indicating whether to skip the script syntax error check. (Inherited from ScriptHost.)
Public property | TraceCallback | (Overrides ScriptHostTraceCallback.)
Top
See Also

Reference

IronPythonScriptHost Class
Alternet.Scripter.IronPython Namespace


IronPythonScriptHost.Engine Property

IronPythonScriptHostEngine Property

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptEngine Engine { get; }
Public ReadOnly Property Engine As ScriptEngine
    Get
public:
property ScriptEngine^ Engine {
    ScriptEngine^ get ();
}
member Engine : ScriptEngine with get

Property Value

Type: ScriptEngine
See Also

Reference

IronPythonScriptHost Class
Alternet.Scripter.IronPython Namespace


IronPythonScriptHost.TraceCallback Property

IronPythonScriptHostTraceCallback Property

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override TracebackDelegate TraceCallback { get; set; }
Public Overrides Property TraceCallback As TracebackDelegate
    Get
    Set
public:
virtual property TracebackDelegate^ TraceCallback {
    TracebackDelegate^ get () override;
    void set (TracebackDelegate^ value) override;
}
abstract TraceCallback : TracebackDelegate with get, set
override TraceCallback : TracebackDelegate with get, set

Property Value

Type: TracebackDelegate

Implements

IScriptHostTraceCallback
See Also

Reference

IronPythonScriptHost Class
Alternet.Scripter.IronPython Namespace


IScriptHost Interface

IScriptHost Interface
Represents methods and properties declaration to support a script engine functionality.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptHost : IDisposable
Public Interface IScriptHost
    Inherits IDisposable
public interface class IScriptHost : IDisposable
type IScriptHost =
    interface
        interface IDisposable
    end

The IScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | Reset | When implemented by a class, closes the script engine and releases all resources.
Public method | ResolveReferences | When implemented by a class, returns list of assembly references used by the script.
Public method | Run | When implemented by a class, executes script starting from the main entry point.
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunFunction | When implemented by a class, executes specified function.
Public method | RunFunctionAsync | When implemented by a class, executes specified function asynchronously.
Public method | RunProcess | When implemented by a class, executes script starting from the main entry point in standalone process.
Top
Properties
 | Name | Description
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | When implemented by a class, gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | When implemented by a class, gets list of compiler errors associated with the script being executed.
Public property | ModulesDirectoryPath | When implemented by a class, gets or sets path for compiled script assemblies.
Public property | OutputFileName | When implemented by a class, gets script assembly file name.
Public property | ScriptRun | When implemented by a class, gets IScriptRun associated this script host.
Public property | SkipSyntaxErrorCheck | When implemented by a class, gets or sets a boolean value indicating whether to skip the script syntax error check.
Public property | TraceCallback |
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


IScriptHost Methods

IScriptHost Methods

The IScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | Reset | When implemented by a class, closes the script engine and releases all resources.
Public method | ResolveReferences | When implemented by a class, returns list of assembly references used by the script.
Public method | Run | When implemented by a class, executes script starting from the main entry point.
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunFunction | When implemented by a class, executes specified function.
Public method | RunFunctionAsync | When implemented by a class, executes specified function asynchronously.
Public method | RunProcess | When implemented by a class, executes script starting from the main entry point in standalone process.
Top
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.Compile Method

IScriptHostCompile Method
When implemented by a class, initializes script engine and compiles the script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Compile()
Function Compile As Boolean
bool Compile()
abstract Compile : unit -> bool

Return Value

Type: Boolean
True if succeed, otherwise false.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.EvaluateExpression Method

IScriptHostEvaluateExpression Method
When implemented by a class, evaluates specified expression.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object EvaluateExpression(
    string expression
)
Function EvaluateExpression (
    expression As String
) As Object
Object^ EvaluateExpression(
    String^ expression
)
abstract EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.EvaluateExpressionAsync Method

IScriptHostEvaluateExpressionAsync Method
When implemented by a class, evaluates specified expression asynchronously.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.Reset Method

IScriptHostReset Method
When implemented by a class, closes the script engine and releases all resources.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.ResolveReferences Method

IScriptHostResolveReferences Method
When implemented by a class, returns list of assembly references used by the script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> ResolveReferences(
    IList<string> unresolvedReferences
)
Function ResolveReferences (
    unresolvedReferences As IList(Of String)
) As IList(Of String)
IList<String^>^ ResolveReferences(
    IList<String^>^ unresolvedReferences
)
abstract ResolveReferences :
        unresolvedReferences : IList<string> -> IList<string>

Parameters

unresolvedReferences
Type: System.Collections.GenericIListString
Contains list of references that can not be resolved.

Return Value

Type: IListString
List of assembly references.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.Run Method

IScriptHostRun Method
When implemented by a class, executes script starting from the main entry point.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Run()
Sub Run
void Run()
abstract Run : unit -> unit

Return Value

Type:
Return value of the script being executed.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.RunAsync Method

IScriptHostRunAsync Method
When implemented by a class, executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task RunAsync(
    CancellationToken cancellationToken = null
)
Function RunAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
Task^ RunAsync(
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: Task
Return value of the script being executed.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.RunFunction Method

IScriptHostRunFunction Method
When implemented by a class, executes specified function.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object RunFunction(
    string functionName,
    Object[] args = null
)
Function RunFunction (
    functionName As String,
    Optional args As Object() = Nothing
) As Object
Object^ RunFunction(
    String^ functionName,
    array<Object^>^ args = nullptr
)
abstract RunFunction :
        functionName : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

functionName
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of functions's parameters.

Return Value

Type: Object
An object containing return value of the executed function.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.RunFunctionAsync Method

IScriptHostRunFunctionAsync Method
When implemented by a class, executes specified function asynchronously.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> RunFunctionAsync(
    string functionName,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Function RunFunctionAsync (
    functionName As String,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ RunFunctionAsync(
    String^ functionName,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunFunctionAsync :
        functionName : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

functionName
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed function.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.RunProcess Method

IScriptHostRunProcess Method
When implemented by a class, executes script starting from the main entry point in standalone process.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int RunProcess(
    string[] args = null,
    bool wait = true
)
Function RunProcess (
    Optional args As String() = Nothing,
    Optional wait As Boolean = true
) As Integer
int RunProcess(
    array<String^>^ args = nullptr,
    bool wait = true
)
abstract RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
wait (Optional)
Type: SystemBoolean
Specifies if calling application should wait for process termination

Return Value

Type: Int32
Return process exit code.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost Properties

IScriptHost Properties

The IScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | When implemented by a class, gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | When implemented by a class, gets list of compiler errors associated with the script being executed.
Public property | ModulesDirectoryPath | When implemented by a class, gets or sets path for compiled script assemblies.
Public property | OutputFileName | When implemented by a class, gets script assembly file name.
Public property | ScriptRun | When implemented by a class, gets IScriptRun associated this script host.
Public property | SkipSyntaxErrorCheck | When implemented by a class, gets or sets a boolean value indicating whether to skip the script syntax error check.
Public property | TraceCallback |
Top
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.Compiled Property

IScriptHostCompiled Property
When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Compiled { get; }
ReadOnly Property Compiled As Boolean
    Get
property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.CompileFailed Property

IScriptHostCompileFailed Property
When implemented by a class, gets or sets boolean value indicating unsuccessful script compilation.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CompileFailed { get; }
ReadOnly Property CompileFailed As Boolean
    Get
property bool CompileFailed {
    bool get ();
}
abstract CompileFailed : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.CompilerErrors Property

IScriptHostCompilerErrors Property
When implemented by a class, gets list of compiler errors associated with the script being executed.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptCompilationDiagnostic[] CompilerErrors { get; }
ReadOnly Property CompilerErrors As ScriptCompilationDiagnostic()
    Get
property array<ScriptCompilationDiagnostic>^ CompilerErrors {
    array<ScriptCompilationDiagnostic>^ get ();
}
abstract CompilerErrors : ScriptCompilationDiagnostic[] with get

Property Value

Type: ScriptCompilationDiagnostic
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.ModulesDirectoryPath Property

IScriptHostModulesDirectoryPath Property
When implemented by a class, gets or sets path for compiled script assemblies.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ModulesDirectoryPath { get; set; }
Property ModulesDirectoryPath As String
    Get
    Set
property String^ ModulesDirectoryPath {
    String^ get ();
    void set (String^ value);
}
abstract ModulesDirectoryPath : string with get, set

Property Value

Type: String
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.OutputFileName Property

IScriptHostOutputFileName Property
When implemented by a class, gets script assembly file name.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string OutputFileName { get; set; }
Property OutputFileName As String
    Get
    Set
property String^ OutputFileName {
    String^ get ();
    void set (String^ value);
}
abstract OutputFileName : string with get, set

Property Value

Type: String
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.ScriptRun Property

IScriptHostScriptRun Property
When implemented by a class, gets IScriptRun associated this script host.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptRun ScriptRun { get; }
ReadOnly Property ScriptRun As IScriptRun
    Get
property IScriptRun^ ScriptRun {
    IScriptRun^ get ();
}
abstract ScriptRun : IScriptRun with get

Property Value

Type: IScriptRun
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.SkipSyntaxErrorCheck Property

IScriptHostSkipSyntaxErrorCheck Property
When implemented by a class, gets or sets a boolean value indicating whether to skip the script syntax error check.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SkipSyntaxErrorCheck { get; set; }
Property SkipSyntaxErrorCheck As Boolean
    Get
    Set
property bool SkipSyntaxErrorCheck {
    bool get ();
    void set (bool value);
}
abstract SkipSyntaxErrorCheck : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptHost.TraceCallback Property

IScriptHostTraceCallback Property

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TracebackDelegate TraceCallback { get; set; }
Property TraceCallback As TracebackDelegate
    Get
    Set
property TracebackDelegate^ TraceCallback {
    TracebackDelegate^ get ();
    void set (TracebackDelegate^ value);
}
abstract TraceCallback : TracebackDelegate with get, set

Property Value

Type: TracebackDelegate
See Also

Reference

IScriptHost Interface
Alternet.Scripter.IronPython Namespace


IScriptRun Interface

IScriptRun Interface
Represents methods and properties declaration to describe runner for script engine.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptRun : IScriptRunBase
Public Interface IScriptRun
    Inherits IScriptRunBase
public interface class IScriptRun : IScriptRunBase
type IScriptRun =
    interface
        interface IScriptRunBase
    end

The IScriptRun type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script. (Inherited from IScriptRunBase.)
Public method | CreateScriptHost | When implemented by a class, creates a new IScriptHost object with appropriate characteristics.
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression. (Inherited from IScriptRunBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | LoadScript | When implemented by a class, load script from specified file. (Inherited from IScriptRunBase.)
Public method | OnFileLoad | When implemented by a class, invokes FileLoad event handler. (Inherited from IScriptRunBase.)
Public method | OnResolveReference | When implemented by a class, invokes ReferenceResolve event handler.
Public method | OnScriptCompiled | When implemented by a class, invokes ScriptCompiled event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptError | When implemented by a class, invokes ScriptError event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptExecuted | When implemented by a class, invokes ScriptExecuted event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptReset | When implemented by a class, invokes ScriptReset event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptRunning | When implemented by a class, invokes ScriptRunning event handler. (Inherited from IScriptRunBase.)
Public method | Reset | When implemented by a class, removes the script engine from the running state and disconnects automatically bound event handlers. (Inherited from IScriptRunBase.)
Public method | Run | When implemented by a class, executes script starting from the main entry point. (Inherited from IScriptRunBase.)
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunFunction | When implemented by a class, executes specified function.
Public method | RunFunctionAsync | When implemented by a class, executes specified function asynchronously.
Top
Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive. (Inherited from IScriptRunBase.)
Public property | CodeEnvironment |
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed. (Inherited from IScriptRunBase.)
Public property | Executed | When implemented by a class, gets boolean value indicating that script has been executed at least once. (Inherited from IScriptRunBase.)
Public property | GlobalItems | When implemented by a class, gets or sets a script items collection attached to this runner.
Public property | ScriptHost | When implemented by a class, returns object that implements IScriptHost interface for this runner.
Public property | ScriptSource | When implemented by a class, gets source of the script to execute.
Top
Events
 | Name | Description
Public event | FileLoad | When implemented by a class, occurs when script code is loaded from file. (Inherited from IScriptRunBase.)
Public event | ReferenceResolve | When implemented by a class, occurs when script code is loaded from file.
Public event | ScriptCompiled | When implemented by a class, occurs when the script engine running successfully. (Inherited from IScriptRunBase.)
Public event | ScriptError | When implemented by a class, occurs when the script engine running is failed. (Inherited from IScriptRunBase.)
Public event | ScriptExecuted | When implemented by a class, occurs when script engine executes the script. (Inherited from IScriptRunBase.)
Public event | ScriptReset | When implemented by a class, occurs when the script engine is reset. (Inherited from IScriptRunBase.)
Public event | ScriptRunning | When implemented by a class, occurs when script engine tries to running script. (Inherited from IScriptRunBase.)
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


IScriptRun Methods

IScriptRun Methods

The IScriptRun type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script. (Inherited from IScriptRunBase.)
Public method | CreateScriptHost | When implemented by a class, creates a new IScriptHost object with appropriate characteristics.
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression. (Inherited from IScriptRunBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | LoadScript | When implemented by a class, load script from specified file. (Inherited from IScriptRunBase.)
Public method | OnFileLoad | When implemented by a class, invokes FileLoad event handler. (Inherited from IScriptRunBase.)
Public method | OnResolveReference | When implemented by a class, invokes ReferenceResolve event handler.
Public method | OnScriptCompiled | When implemented by a class, invokes ScriptCompiled event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptError | When implemented by a class, invokes ScriptError event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptExecuted | When implemented by a class, invokes ScriptExecuted event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptReset | When implemented by a class, invokes ScriptReset event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptRunning | When implemented by a class, invokes ScriptRunning event handler. (Inherited from IScriptRunBase.)
Public method | Reset | When implemented by a class, removes the script engine from the running state and disconnects automatically bound event handlers. (Inherited from IScriptRunBase.)
Public method | Run | When implemented by a class, executes script starting from the main entry point. (Inherited from IScriptRunBase.)
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunFunction | When implemented by a class, executes specified function.
Public method | RunFunctionAsync | When implemented by a class, executes specified function asynchronously.
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.CreateScriptHost Method

IScriptRunCreateScriptHost Method
When implemented by a class, creates a new IScriptHost object with appropriate characteristics.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptHost CreateScriptHost()
Function CreateScriptHost As IScriptHost
IScriptHost^ CreateScriptHost()
abstract CreateScriptHost : unit -> IScriptHost

Return Value

Type: IScriptHost
Created IScriptHost object.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.EvaluateExpressionAsync Method

IScriptRunEvaluateExpressionAsync Method
When implemented by a class, evaluates specified expression asynchronously.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.OnResolveReference Method

IScriptRunOnResolveReference Method
When implemented by a class, invokes ReferenceResolve event handler.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OnResolveReference(
    string reference,
    out string assemblyLocation
)
Function OnResolveReference (
    reference As String,
    <OutAttribute> ByRef assemblyLocation As String
) As Boolean
bool OnResolveReference(
    String^ reference,
    [OutAttribute] String^% assemblyLocation
)
abstract OnResolveReference :
        reference : string *
        assemblyLocation : string byref -> bool

Parameters

reference
Type: SystemString
Reference to resolve.
assemblyLocation
Type: SystemString
Path to suitable assembly.

Return Value

Type: Boolean
true if reference was resolved otherwise false
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.RunAsync Method

IScriptRunRunAsync Method
When implemented by a class, executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task RunAsync(
    CancellationToken cancellationToken = null
)
Function RunAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
Task^ RunAsync(
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: Task
Return value of the script being executed.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.RunFunction Method

IScriptRunRunFunction Method
When implemented by a class, executes specified function.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object RunFunction(
    string function,
    Object[] args = null
)
Function RunFunction (
    function As String,
    Optional args As Object() = Nothing
) As Object
Object^ RunFunction(
    String^ function,
    array<Object^>^ args = nullptr
)
abstract RunFunction :
        function : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.

Return Value

Type: Object
An object containing return value of the executed function.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.RunFunctionAsync Method

IScriptRunRunFunctionAsync Method
When implemented by a class, executes specified function asynchronously.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> RunFunctionAsync(
    string function,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Function RunFunctionAsync (
    function As String,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ RunFunctionAsync(
    String^ function,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed function.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun Properties

IScriptRun Properties

The IScriptRun type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive. (Inherited from IScriptRunBase.)
Public property | CodeEnvironment |
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed. (Inherited from IScriptRunBase.)
Public property | Executed | When implemented by a class, gets boolean value indicating that script has been executed at least once. (Inherited from IScriptRunBase.)
Public property | GlobalItems | When implemented by a class, gets or sets a script items collection attached to this runner.
Public property | ScriptHost | When implemented by a class, returns object that implements IScriptHost interface for this runner.
Public property | ScriptSource | When implemented by a class, gets source of the script to execute.
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.CodeEnvironment Property

IScriptRunCodeEnvironment Property

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeEnvironment CodeEnvironment { get; }
ReadOnly Property CodeEnvironment As ICodeEnvironment
    Get
property ICodeEnvironment^ CodeEnvironment {
    ICodeEnvironment^ get ();
}
abstract CodeEnvironment : ICodeEnvironment with get

Property Value

Type: ICodeEnvironment
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.GlobalItems Property

IScriptRunGlobalItems Property
When implemented by a class, gets or sets a script items collection attached to this runner.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<IScriptGlobalItem> GlobalItems { get; }
ReadOnly Property GlobalItems As IList(Of IScriptGlobalItem)
    Get
property IList<IScriptGlobalItem^>^ GlobalItems {
    IList<IScriptGlobalItem^>^ get ();
}
abstract GlobalItems : IList<IScriptGlobalItem> with get

Property Value

Type: IListIScriptGlobalItem
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.ScriptHost Property

IScriptRunScriptHost Property
When implemented by a class, returns object that implements IScriptHost interface for this runner.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptHost ScriptHost { get; set; }
Property ScriptHost As IScriptHost
    Get
    Set
property IScriptHost^ ScriptHost {
    IScriptHost^ get ();
    void set (IScriptHost^ value);
}
abstract ScriptHost : IScriptHost with get, set

Property Value

Type: IScriptHost
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.ScriptSource Property

IScriptRunScriptSource Property
When implemented by a class, gets source of the script to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource ScriptSource { get; }
ReadOnly Property ScriptSource As IScriptSource
    Get
property IScriptSource^ ScriptSource {
    IScriptSource^ get ();
}
abstract ScriptSource : IScriptSource with get

Property Value

Type: IScriptSource
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun Events

IScriptRun Events

The IScriptRun type exposes the following members.

Events
 | Name | Description
Public event | FileLoad | When implemented by a class, occurs when script code is loaded from file. (Inherited from IScriptRunBase.)
Public event | ReferenceResolve | When implemented by a class, occurs when script code is loaded from file.
Public event | ScriptCompiled | When implemented by a class, occurs when the script engine running successfully. (Inherited from IScriptRunBase.)
Public event | ScriptError | When implemented by a class, occurs when the script engine running is failed. (Inherited from IScriptRunBase.)
Public event | ScriptExecuted | When implemented by a class, occurs when script engine executes the script. (Inherited from IScriptRunBase.)
Public event | ScriptReset | When implemented by a class, occurs when the script engine is reset. (Inherited from IScriptRunBase.)
Public event | ScriptRunning | When implemented by a class, occurs when script engine tries to running script. (Inherited from IScriptRunBase.)
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptRun.ReferenceResolve Event

IScriptRunReferenceResolve Event
When implemented by a class, occurs when script code is loaded from file.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ResolveReferenceEventArgs> ReferenceResolve
Event ReferenceResolve As EventHandler(Of ResolveReferenceEventArgs)
 event EventHandler<ResolveReferenceEventArgs^>^ ReferenceResolve {
    void add (EventHandler<ResolveReferenceEventArgs^>^ value);
    void remove (EventHandler<ResolveReferenceEventArgs^>^ value);
}
abstract ReferenceResolve : IEvent<EventHandler<ResolveReferenceEventArgs>,
    ResolveReferenceEventArgs>

Value

Type: SystemEventHandlerResolveReferenceEventArgs
See Also

Reference

IScriptRun Interface
Alternet.Scripter.IronPython Namespace


IScriptSource Interface

IScriptSource Interface
Represents methods and properties to work with script text, files or projects.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptSource : IScriptSourceBase,
    ICloneable, IEquatable<IScriptSource>
Public Interface IScriptSource
    Inherits IScriptSourceBase, ICloneable, IEquatable(Of IScriptSource)
public interface class IScriptSource : IScriptSourceBase,
    ICloneable, IEquatable<IScriptSource^>
type IScriptSource =
    interface
        interface IScriptSourceBase
        interface ICloneable
        interface IEquatable<IScriptSource>
    end

The IScriptSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatableIScriptSource.)
Public method | FromExpression | When implemented by a class, loads script source from the expression.
Public method | FromScriptCode | When implemented by a class, loads script source from the script code.
Public method | FromScriptFile | When implemented by a class, loads script source from the script file.
Public method | FromScriptProject | When implemented by a class, loads script source from the IronPython project.
Public method | GetLastModifiedDate | When implemented by a class, gets file date time when script source was compiled.
Public method | HasBeenModified | When implemented by a class, compares file modification dates against to other script source.
Public method | Reset | When implemented by a class, clears script source.
Top
Properties
 | Name | Description
Public property | Changed | When implemented by a class, gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Expression | When implemented by a class, gets expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | Files | When implemented by a class, gets list of files containing script to execute.
Public property | FrameworkPath | When implemented by a class, gets location of .NET Framework assemblies.
Public property | HasExpression | When implemented by a class, returns boolean value indicating whether ScriptSource contains expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | HasProject | When implemented by a class, returns boolean value indicating whether ScriptSource is associated with the project. (Inherited from IScriptSourceBase.)
Public property | HasScriptCode | When implemented by a class, returns boolean value indicating whether ScriptSource contains script code to execute. (Inherited from IScriptSourceBase.)
Public property | HasScriptFile | When implemented by a class, returns boolean value indicating whether ScriptSource contains script file to execute. (Inherited from IScriptSourceBase.)
Public property | Imports | When implemented by a class, gets list of namespaces to be used in the script.
Public property | ModulesSearchPaths | When implemented by a class, gets list of search directories to look for Python modules.
Public property | ProjectFileName | When implemented by a class, gets a file name of the Visual Studio project containing script files to execute. (Inherited from IScriptSourceBase.)
Public property | ProjectName | When implemented by a class, gets or sets name of the Visual Studio project containing script files to execute.
Public property | ReferencedFrameworks | Gets or sets a combination of referenced library frameworks.
Public property | References | When implemented by a class, gets list of external assemblies referenced from the script.
Public property | ReferencesSearchPaths | When implemented by a class, gets list of search directories to look for assembly references.
Public property | ScriptCode | When implemented by a class, gets script code to execute. (Inherited from IScriptSourceBase.)
Public property | ScriptFile | When implemented by a class, gets single script file to execute. (Inherited from IScriptSourceBase.)
Public property | StartupFile | When implemented by a class, gets or sets startup Python script file to be executed on script run. When this property is set, the only file that is executed is the StartupFile. When this property is not set, all the script files are executed in order they are specified.
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


IScriptSource Methods

IScriptSource Methods

The IScriptSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatableIScriptSource .)
Public method | FromExpression | When implemented by a class, loads script source from the expression.
Public method | FromScriptCode | When implemented by a class, loads script source from the script code.
Public method | FromScriptFile | When implemented by a class, loads script source from the script file.
Public method | FromScriptProject | When implemented by a class, loads script source from the IronPython project.
Public method | GetLastModifiedDate | When implemented by a class, gets file date time when script source was compiled.
Public method | HasBeenModified | When implemented by a class, compares file modification dates against to other script source.
Public method | Reset | When implemented by a class, clears script source.
Top
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.FromExpression Method

IScriptSourceFromExpression Method
When implemented by a class, loads script source from the expression.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromExpression(
    string expression
)
Function FromExpression (
    expression As String
) As IScriptSource
IScriptSource^ FromExpression(
    String^ expression
)
abstract FromExpression :
        expression : string -> IScriptSource

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.FromScriptCode Method

IScriptSourceFromScriptCode Method
When implemented by a class, loads script source from the script code.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptCode(
    string scriptCode
)
Function FromScriptCode (
    scriptCode As String
) As IScriptSource
IScriptSource^ FromScriptCode(
    String^ scriptCode
)
abstract FromScriptCode :
        scriptCode : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.FromScriptFile Method

IScriptSourceFromScriptFile Method
When implemented by a class, loads script source from the script file.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptFile(
    string fileName
)
Function FromScriptFile (
    fileName As String
) As IScriptSource
IScriptSource^ FromScriptFile(
    String^ fileName
)
abstract FromScriptFile :
        fileName : string -> IScriptSource

Parameters

fileName
Type: SystemString
File Name to load the script.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.FromScriptProject Method

IScriptSourceFromScriptProject Method
When implemented by a class, loads script source from the IronPython project.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptProject(
    string projectFileName
)
Function FromScriptProject (
    projectFileName As String
) As IScriptSource
IScriptSource^ FromScriptProject(
    String^ projectFileName
)
abstract FromScriptProject :
        projectFileName : string -> IScriptSource

Parameters

projectFileName
Type: SystemString
Project file name to load script.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.GetLastModifiedDate Method

IScriptSourceGetLastModifiedDate Method
When implemented by a class, gets file date time when script source was compiled.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime GetLastModifiedDate(
    string fileName
)
Function GetLastModifiedDate (
    fileName As String
) As DateTime
DateTime GetLastModifiedDate(
    String^ fileName
)
abstract GetLastModifiedDate :
        fileName : string -> DateTime

Parameters

fileName
Type: SystemString
FileName to check last modified date.

Return Value

Type: DateTime
File date of the given file at the time it was compiled.
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.HasBeenModified Method

IScriptSourceHasBeenModified Method
When implemented by a class, compares file modification dates against to other script source.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasBeenModified(
    IScriptSource other
)
Function HasBeenModified (
    other As IScriptSource
) As Boolean
bool HasBeenModified(
    IScriptSource^ other
)
abstract HasBeenModified :
        other : IScriptSource -> bool

Parameters

other
Type: Alternet.Scripter.IronPythonIScriptSource
IScriptSource to compare.

Return Value

Type: Boolean
True, if source has been changed since last compilation; otherwise false.
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.Reset Method

IScriptSourceReset Method
When implemented by a class, clears script source.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource Properties

IScriptSource Properties

The IScriptSource type exposes the following members.

Properties
 | Name | Description
Public property | Changed | When implemented by a class, gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Expression | When implemented by a class, gets expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | Files | When implemented by a class, gets list of files containing script to execute.
Public property | FrameworkPath | When implemented by a class, gets location of .NET Framework assemblies.
Public property | HasExpression | When implemented by a class, returns boolean value indicating whether ScriptSource contains expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | HasProject | When implemented by a class, returns boolean value indicating whether ScriptSource is associated with the project. (Inherited from IScriptSourceBase.)
Public property | HasScriptCode | When implemented by a class, returns boolean value indicating whether ScriptSource contains script code to execute. (Inherited from IScriptSourceBase.)
Public property | HasScriptFile | When implemented by a class, returns boolean value indicating whether ScriptSource contains script file to execute. (Inherited from IScriptSourceBase.)
Public property | Imports | When implemented by a class, gets list of namespaces to be used in the script.
Public property | ModulesSearchPaths | When implemented by a class, gets list of search directories to look for Python modules.
Public property | ProjectFileName | When implemented by a class, gets a file name of the Visual Studio project containing script files to execute. (Inherited from IScriptSourceBase.)
Public property | ProjectName | When implemented by a class, gets or sets name of the Visual Studio project containing script files to execute.
Public property | ReferencedFrameworks | Gets or sets a combination of referenced library frameworks.
Public property | References | When implemented by a class, gets list of external assemblies referenced from the script.
Public property | ReferencesSearchPaths | When implemented by a class, gets list of search directories to look for assembly references.
Public property | ScriptCode | When implemented by a class, gets script code to execute. (Inherited from IScriptSourceBase.)
Public property | ScriptFile | When implemented by a class, gets single script file to execute. (Inherited from IScriptSourceBase.)
Public property | StartupFile | When implemented by a class, gets or sets startup Python script file to be executed on script run. When this property is set, the only file that is executed is the StartupFile. When this property is not set, all the script files are executed in order they are specified.
Top
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.Changed Property

IScriptSourceChanged Property
When implemented by a class, gets or sets boolean value indicating if script source has been modified since last compilation.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Changed { get; set; }
Property Changed As Boolean
    Get
    Set
property bool Changed {
    bool get ();
    void set (bool value);
}
abstract Changed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.Files Property

IScriptSourceFiles Property
When implemented by a class, gets list of files containing script to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> Files { get; }
ReadOnly Property Files As IList(Of String)
    Get
property IList<String^>^ Files {
    IList<String^>^ get ();
}
abstract Files : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.FrameworkPath Property

IScriptSourceFrameworkPath Property
When implemented by a class, gets location of .NET Framework assemblies.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FrameworkPath { get; set; }
Property FrameworkPath As String
    Get
    Set
property String^ FrameworkPath {
    String^ get ();
    void set (String^ value);
}
abstract FrameworkPath : string with get, set

Property Value

Type: String
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.Imports Property

IScriptSourceImports Property
When implemented by a class, gets list of namespaces to be used in the script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> Imports { get; }
ReadOnly Property Imports As IList(Of String)
    Get
property IList<String^>^ Imports {
    IList<String^>^ get ();
}
abstract Imports : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.ModulesSearchPaths Property

IScriptSourceModulesSearchPaths Property
When implemented by a class, gets list of search directories to look for Python modules.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> ModulesSearchPaths { get; }
ReadOnly Property ModulesSearchPaths As IList(Of String)
    Get
property IList<String^>^ ModulesSearchPaths {
    IList<String^>^ get ();
}
abstract ModulesSearchPaths : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.ProjectName Property

IScriptSourceProjectName Property
When implemented by a class, gets or sets name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ProjectName { get; set; }
Property ProjectName As String
    Get
    Set
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}
abstract ProjectName : string with get, set

Property Value

Type: String
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.ReferencedFrameworks Property

IScriptSourceReferencedFrameworks Property
Gets or sets a combination of referenced library frameworks.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Framework ReferencedFrameworks { get; set; }
Property ReferencedFrameworks As Framework
    Get
    Set
property Framework ReferencedFrameworks {
    Framework get ();
    void set (Framework value);
}
abstract ReferencedFrameworks : Framework with get, set

Property Value

Type: Framework
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.References Property

IScriptSourceReferences Property
When implemented by a class, gets list of external assemblies referenced from the script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> References { get; }
ReadOnly Property References As IList(Of String)
    Get
property IList<String^>^ References {
    IList<String^>^ get ();
}
abstract References : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.ReferencesSearchPaths Property

IScriptSourceReferencesSearchPaths Property
When implemented by a class, gets list of search directories to look for assembly references.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> ReferencesSearchPaths { get; }
ReadOnly Property ReferencesSearchPaths As IList(Of String)
    Get
property IList<String^>^ ReferencesSearchPaths {
    IList<String^>^ get ();
}
abstract ReferencesSearchPaths : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


IScriptSource.StartupFile Property

IScriptSourceStartupFile Property
When implemented by a class, gets or sets startup Python script file to be executed on script run. When this property is set, the only file that is executed is the StartupFile. When this property is not set, all the script files are executed in order they are specified.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string StartupFile { get; set; }
Property StartupFile As String
    Get
    Set
property String^ StartupFile {
    String^ get ();
    void set (String^ value);
}
abstract StartupFile : string with get, set

Property Value

Type: String
See Also

Reference

IScriptSource Interface
Alternet.Scripter.IronPython Namespace


ProjectLoader Class

ProjectLoader Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IronPythonProjectLoader

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProjectLoader
Public Class ProjectLoader
public ref class ProjectLoader
type ProjectLoader =  class end

The ProjectLoader type exposes the following members.

Constructors
 | Name | Description
Public method | ProjectLoader | Initializes a new instance of the ProjectLoader class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


ProjectLoader Constructor

ProjectLoader Constructor
Initializes a new instance of the ProjectLoader class

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectLoader(
    ScriptSource source
)
Public Sub New (
    source As ScriptSource
)
public:
ProjectLoader(
    ScriptSource^ source
)
new :
        source : ScriptSource -> ProjectLoader

Parameters

source
Type: Alternet.Scripter.IronPythonScriptSource
See Also

Reference

ProjectLoader Class
Alternet.Scripter.IronPython Namespace


ProjectLoader Methods

ProjectLoader Methods

The ProjectLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProjectLoader Class
Alternet.Scripter.IronPython Namespace


ProjectLoader.Load Method

ProjectLoaderLoad Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Load(
    string projectFileName
)
Public Sub Load (
    projectFileName As String
)
public:
void Load(
    String^ projectFileName
)
member Load :
        projectFileName : string -> unit

Parameters

projectFileName
Type: SystemString
See Also

Reference

ProjectLoader Class
Alternet.Scripter.IronPython Namespace


ResolveReferenceEventArgs Class

ResolveReferenceEventArgs Class
Provides data for the IScriptRun.ReferenceResolve event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Scripter.IronPythonResolveReferenceEventArgs

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ResolveReferenceEventArgs : EventArgs
Public Class ResolveReferenceEventArgs
    Inherits EventArgs
public ref class ResolveReferenceEventArgs : public EventArgs
type ResolveReferenceEventArgs =
    class
        inherit EventArgs
    end

The ResolveReferenceEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ResolveReferenceEventArgs | Initializes a new instance of the ResolveReferenceEventArgs class with specified reference.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyLocation | Gets or sets suitable Assembly.
Public property | Handled | Gets or sets a value indicating whether the ReferenceResolve event was handled.
Public property | Reference | Gets or sets reference to be resolved.
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


ResolveReferenceEventArgs Constructor

ResolveReferenceEventArgs Constructor
Initializes a new instance of the ResolveReferenceEventArgs class with specified reference.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResolveReferenceEventArgs(
    string reference
)
Public Sub New (
    reference As String
)
public:
ResolveReferenceEventArgs(
    String^ reference
)
new :
        reference : string -> ResolveReferenceEventArgs

Parameters

reference
Type: SystemString
Reference to resolve.
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter.IronPython Namespace


ResolveReferenceEventArgs Methods

ResolveReferenceEventArgs Methods

The ResolveReferenceEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter.IronPython Namespace


ResolveReferenceEventArgs Properties

ResolveReferenceEventArgs Properties

The ResolveReferenceEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyLocation | Gets or sets suitable Assembly.
Public property | Handled | Gets or sets a value indicating whether the ReferenceResolve event was handled.
Public property | Reference | Gets or sets reference to be resolved.
Top
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter.IronPython Namespace


ResolveReferenceEventArgs.AssemblyLocation Property

ResolveReferenceEventArgsAssemblyLocation Property
Gets or sets suitable Assembly.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyLocation { get; set; }
Public Property AssemblyLocation As String
    Get
    Set
public:
property String^ AssemblyLocation {
    String^ get ();
    void set (String^ value);
}
member AssemblyLocation : string with get, set

Property Value

Type: String
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter.IronPython Namespace


ResolveReferenceEventArgs.Handled Property

ResolveReferenceEventArgsHandled Property
Gets or sets a value indicating whether the ReferenceResolve event was handled.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter.IronPython Namespace


ResolveReferenceEventArgs.Reference Property

ResolveReferenceEventArgsReference Property
Gets or sets reference to be resolved.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Reference { get; set; }
Public Property Reference As String
    Get
    Set
public:
property String^ Reference {
    String^ get ();
    void set (String^ value);
}
member Reference : string with get, set

Property Value

Type: String
See Also

Reference

ResolveReferenceEventArgs Class
Alternet.Scripter.IronPython Namespace


RunnableScript Class

RunnableScript Class
A base class represents compiled script assembly. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IronPythonRunnableScript
Alternet.Scripter.IronPythonFileRunnableScript
Alternet.Scripter.IronPythonInMemoryRunnableScript

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class RunnableScript
Public MustInherit Class RunnableScript
public ref class RunnableScript abstract
[<AbstractClassAttribute>]
type RunnableScript =  class end

The RunnableScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSources |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


RunnableScript Methods

RunnableScript Methods

The RunnableScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSources |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunnableScript Class
Alternet.Scripter.IronPython Namespace


RunnableScript.Execute Method

RunnableScriptExecute Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Object Execute(
    ScriptEngine engine,
    ScriptScope scope
)
Public MustOverride Function Execute (
    engine As ScriptEngine,
    scope As ScriptScope
) As Object
public:
virtual Object^ Execute(
    ScriptEngine^ engine,
    ScriptScope^ scope
) abstract
abstract Execute :
        engine : ScriptEngine *
        scope : ScriptScope -> Object

Parameters

engine
Type: ScriptEngine
scope
Type: ScriptScope

Return Value

Type: Object
See Also

Reference

RunnableScript Class
Alternet.Scripter.IronPython Namespace


RunnableScript.GetSources Method

RunnableScriptGetSources Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract IEnumerable<ScriptSource> GetSources(
    ScriptEngine engine
)
Public MustOverride Function GetSources (
    engine As ScriptEngine
) As IEnumerable(Of ScriptSource)
public:
virtual IEnumerable<ScriptSource^>^ GetSources(
    ScriptEngine^ engine
) abstract
abstract GetSources :
        engine : ScriptEngine -> IEnumerable<ScriptSource>

Parameters

engine
Type: ScriptEngine

Return Value

Type: IEnumerableScriptSource
See Also

Reference

RunnableScript Class
Alternet.Scripter.IronPython Namespace


ScriptConsts Class

ScriptConsts Class
Contains constants related to Scripter component.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IronPythonScriptConsts

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptConsts
Public Class ScriptConsts
public ref class ScriptConsts
type ScriptConsts =  class end

The ScriptConsts type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptConsts | Initializes a new instance of the ScriptConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DefaultModuleGeneratedDirectory |
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


ScriptConsts Constructor

ScriptConsts Constructor
Initializes a new instance of the ScriptConsts class

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptConsts()
Public Sub New
public:
ScriptConsts()
new : unit -> ScriptConsts
See Also

Reference

ScriptConsts Class
Alternet.Scripter.IronPython Namespace


ScriptConsts Fields

ScriptConsts Fields

The ScriptConsts type exposes the following members.

Fields
Name | Description
DefaultModuleGeneratedDirectory |
Top
See Also

Reference

ScriptConsts Class
Alternet.Scripter.IronPython Namespace


ScriptConsts.DefaultModuleGeneratedDirectory Field

ScriptConstsDefaultModuleGeneratedDirectory Field

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultModuleGeneratedDirectory
Public Shared DefaultModuleGeneratedDirectory As String
public:
static String^ DefaultModuleGeneratedDirectory
static val mutable DefaultModuleGeneratedDirectory: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter.IronPython Namespace


ScriptConsts Methods

ScriptConsts Methods

The ScriptConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptConsts Class
Alternet.Scripter.IronPython Namespace


ScriptGlobalItem Class

ScriptGlobalItem Class
Describes a global object from the script.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IronPythonScriptGlobalItem

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptGlobalItem : IScriptGlobalItem
Public Class ScriptGlobalItem
    Implements IScriptGlobalItem
public ref class ScriptGlobalItem : IScriptGlobalItem
type ScriptGlobalItem =
    class
        interface IScriptGlobalItem
    end

The ScriptGlobalItem type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptGlobalItem | Initializes a new instance of the ScriptItem class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets name of this item.
Public property | Obj | Gets or sets object contained by this item.
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


ScriptGlobalItem Constructor

ScriptGlobalItem Constructor
Initializes a new instance of the ScriptItem class with specified parameters.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptGlobalItem(
    string name,
    Object obj
)
Public Sub New (
    name As String,
    obj As Object
)
public:
ScriptGlobalItem(
    String^ name,
    Object^ obj
)
new :
        name : string *
        obj : Object -> ScriptGlobalItem

Parameters

name
Type: SystemString
Specifies name of the new instance.
obj
Type: SystemObject
Specifies object the new instance should contain.
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter.IronPython Namespace


ScriptGlobalItem Methods

ScriptGlobalItem Methods

The ScriptGlobalItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter.IronPython Namespace


ScriptGlobalItem Properties

ScriptGlobalItem Properties

The ScriptGlobalItem type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets name of this item.
Public property | Obj | Gets or sets object contained by this item.
Top
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter.IronPython Namespace


ScriptGlobalItem.Name Property

ScriptGlobalItemName Property
Gets or sets name of this item.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IScriptGlobalItem.Name
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter.IronPython Namespace


ScriptGlobalItem.Obj Property

ScriptGlobalItemObj Property
Gets or sets object contained by this item.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Obj { get; set; }
Public Overridable Property Obj As Object
    Get
    Set
public:
virtual property Object^ Obj {
    Object^ get ();
    void set (Object^ value);
}
abstract Obj : Object with get, set
override Obj : Object with get, set

Property Value

Type: Object

Implements

IScriptGlobalItem.Obj
See Also

Reference

ScriptGlobalItem Class
Alternet.Scripter.IronPython Namespace


ScriptHost Class

ScriptHost Class
Provides a base class for script execution. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IronPythonScriptHost
Alternet.Scripter.IronPythonIronPythonScriptHost

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ScriptHost : IScriptHost,
    IDisposable
Public MustInherit Class ScriptHost
    Implements IScriptHost, IDisposable
public ref class ScriptHost abstract : IScriptHost,
    IDisposable
[<AbstractClassAttribute>]
type ScriptHost =
    class
        interface IScriptHost
        interface IDisposable
    end

The ScriptHost type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptHost | Initializes a new instance of ScriptHost with specified script runner.
Top
Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers.
Public method | ResolveReferences |
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunFunction | Executes specified function.
Public method | RunFunctionAsync | Executes specified function asynchronously.
Public method | RunProcess | Executes script starting from the main entry point in standalone process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed.
Public property | ExecutableModulePath | Gets script assembly path.
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies.
Public property | OutputFileName | Gets script assembly file name.
Public property | ScriptRun | Gets IScriptRun associated this script host.
Public property | SkipSyntaxErrorCheck | Gets or sets a boolean value indicating whether to skip the script syntax error check.
Public property | TraceCallback |
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


ScriptHost Constructor

ScriptHost Constructor
Initializes a new instance of ScriptHost with specified script runner.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptHost(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
ScriptHost(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> ScriptHost

Parameters

scriptRun
Type: Alternet.Scripter.IronPythonIScriptRun
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost Methods

ScriptHost Methods

The ScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers.
Public method | ResolveReferences |
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunFunction | Executes specified function.
Public method | RunFunctionAsync | Executes specified function asynchronously.
Public method | RunProcess | Executes script starting from the main entry point in standalone process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.Compile Method

ScriptHostCompile Method
Initializes script engine and compiles the script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compile()
Public Overridable Function Compile As Boolean
public:
virtual bool Compile()
abstract Compile : unit -> bool
override Compile : unit -> bool

Return Value

Type: Boolean
True if succeed, otherwise false.

Implements

IScriptHostCompile
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.Dispose Method

ScriptHostDispose Method
Disposes this ScriptHost and frees resources associated with it.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.EvaluateExpression Method

ScriptHostEvaluateExpression Method
Evaluates specified expression.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object EvaluateExpression(
    string expression
)
Public Overridable Function EvaluateExpression (
    expression As String
) As Object
public:
virtual Object^ EvaluateExpression(
    String^ expression
)
abstract EvaluateExpression :
        expression : string -> Object
override EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.

Implements

IScriptHostEvaluateExpression(String)
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.EvaluateExpressionAsync Method

ScriptHostEvaluateExpressionAsync Method
Evaluates specified expression asynchronously.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Public Overridable Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.

Implements

IScriptHostEvaluateExpressionAsync(String, CancellationToken)
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.Reset Method

ScriptHostReset Method
Removes the script engine from the running state and disconnects automatically bound event handlers.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptHostReset
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.ResolveReferences Method

ScriptHostResolveReferences Method

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract IList<string> ResolveReferences(
    IList<string> unresolvedReferences
)
Public MustOverride Function ResolveReferences (
    unresolvedReferences As IList(Of String)
) As IList(Of String)
public:
virtual IList<String^>^ ResolveReferences(
    IList<String^>^ unresolvedReferences
) abstract
abstract ResolveReferences :
        unresolvedReferences : IList<string> -> IList<string>

Parameters

unresolvedReferences
Type: System.Collections.GenericIListString

Return Value

Type: IListString

Implements

IScriptHostResolveReferences(IListString)
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.Run Method

ScriptHostRun Method
Executes script starting from the main entry point.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Run()
Public Overridable Sub Run
public:
virtual void Run()
abstract Run : unit -> unit
override Run : unit -> unit

Return Value

Type:
Return value of the script being executed.

Implements

IScriptHostRun
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.RunAsync Method

ScriptHostRunAsync Method
Executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task RunAsync(
    CancellationToken cancellationToken = null
)
Public Overridable Function RunAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
public:
virtual Task^ RunAsync(
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task
override RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: Task
Return value of the script being executed.

Implements

IScriptHostRunAsync(CancellationToken)
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.RunFunction Method

ScriptHostRunFunction Method
Executes specified function.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object RunFunction(
    string functionName,
    Object[] args = null
)
Public Overridable Function RunFunction (
    functionName As String,
    Optional args As Object() = Nothing
) As Object
public:
virtual Object^ RunFunction(
    String^ functionName,
    array<Object^>^ args = nullptr
)
abstract RunFunction :
        functionName : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object
override RunFunction :
        functionName : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

functionName
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.

Return Value

Type: Object
An object containing return value of the executed function.

Implements

IScriptHostRunFunction(String, Object)
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.RunFunctionAsync Method

ScriptHostRunFunctionAsync Method
Executes specified function asynchronously.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<Object> RunFunctionAsync(
    string function,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Public Overridable Function RunFunctionAsync (
    function As String,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ RunFunctionAsync(
    String^ function,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed function.

Implements

IScriptHostRunFunctionAsync(String, Object, CancellationToken)
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.RunProcess Method

ScriptHostRunProcess Method
Executes script starting from the main entry point in standalone process.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int RunProcess(
    string[] args = null,
    bool wait = true
)
Public Overridable Function RunProcess (
    Optional args As String() = Nothing,
    Optional wait As Boolean = true
) As Integer
public:
virtual int RunProcess(
    array<String^>^ args = nullptr,
    bool wait = true
)
abstract RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int
override RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
wait (Optional)
Type: SystemBoolean
Specifies if calling application should wait for process termination

Return Value

Type: Int32
Return process exit code.

Implements

IScriptHostRunProcess(String, Boolean)
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost Properties

ScriptHost Properties

The ScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed.
Public property | ExecutableModulePath | Gets script assembly path.
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies.
Public property | OutputFileName | Gets script assembly file name.
Public property | ScriptRun | Gets IScriptRun associated this script host.
Public property | SkipSyntaxErrorCheck | Gets or sets a boolean value indicating whether to skip the script syntax error check.
Public property | TraceCallback |
Top
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.Compiled Property

ScriptHostCompiled Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compiled { get; }
Public Overridable ReadOnly Property Compiled As Boolean
    Get
public:
virtual property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get
override Compiled : bool with get

Property Value

Type: Boolean

Implements

IScriptHostCompiled
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.CompileFailed Property

ScriptHostCompileFailed Property
Gets or sets boolean value indicating unsuccessful script compilation.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CompileFailed { get; }
Public ReadOnly Property CompileFailed As Boolean
    Get
public:
virtual property bool CompileFailed {
    bool get () sealed;
}
abstract CompileFailed : bool with get
override CompileFailed : bool with get

Property Value

Type: Boolean

Implements

IScriptHostCompileFailed
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.CompilerErrors Property

ScriptHostCompilerErrors Property
Gets list of compiler errors associated with the script being executed.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCompilationDiagnostic[] CompilerErrors { get; }
Public ReadOnly Property CompilerErrors As ScriptCompilationDiagnostic()
    Get
public:
virtual property array<ScriptCompilationDiagnostic>^ CompilerErrors {
    array<ScriptCompilationDiagnostic>^ get () sealed;
}
abstract CompilerErrors : ScriptCompilationDiagnostic[] with get
override CompilerErrors : ScriptCompilationDiagnostic[] with get

Property Value

Type: ScriptCompilationDiagnostic

Implements

IScriptHostCompilerErrors
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.ExecutableModulePath Property

ScriptHostExecutableModulePath Property
Gets script assembly path.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ExecutableModulePath { get; }
Public ReadOnly Property ExecutableModulePath As String
    Get
public:
property String^ ExecutableModulePath {
    String^ get ();
}
member ExecutableModulePath : string with get

Property Value

Type: String
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.ModulesDirectoryPath Property

ScriptHostModulesDirectoryPath Property
Gets or sets path for compiled script assemblies.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModulesDirectoryPath { get; set; }
Public Property ModulesDirectoryPath As String
    Get
    Set
public:
virtual property String^ ModulesDirectoryPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ModulesDirectoryPath : string with get, set
override ModulesDirectoryPath : string with get, set

Property Value

Type: String

Implements

IScriptHostModulesDirectoryPath
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.OutputFileName Property

ScriptHostOutputFileName Property
Gets script assembly file name.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OutputFileName { get; set; }
Public Property OutputFileName As String
    Get
    Set
public:
virtual property String^ OutputFileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OutputFileName : string with get, set
override OutputFileName : string with get, set

Property Value

Type: String

Implements

IScriptHostOutputFileName
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.ScriptRun Property

ScriptHostScriptRun Property
Gets IScriptRun associated this script host.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptRun ScriptRun { get; }
Public ReadOnly Property ScriptRun As IScriptRun
    Get
public:
virtual property IScriptRun^ ScriptRun {
    IScriptRun^ get () sealed;
}
abstract ScriptRun : IScriptRun with get
override ScriptRun : IScriptRun with get

Property Value

Type: IScriptRun

Implements

IScriptHostScriptRun
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.SkipSyntaxErrorCheck Property

ScriptHostSkipSyntaxErrorCheck Property
Gets or sets a boolean value indicating whether to skip the script syntax error check.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SkipSyntaxErrorCheck { get; set; }
Public Property SkipSyntaxErrorCheck As Boolean
    Get
    Set
public:
virtual property bool SkipSyntaxErrorCheck {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SkipSyntaxErrorCheck : bool with get, set
override SkipSyntaxErrorCheck : bool with get, set

Property Value

Type: Boolean

Implements

IScriptHostSkipSyntaxErrorCheck
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptHost.TraceCallback Property

ScriptHostTraceCallback Property

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract TracebackDelegate TraceCallback { get; set; }
Public MustOverride Property TraceCallback As TracebackDelegate
    Get
    Set
public:
virtual property TracebackDelegate^ TraceCallback {
    TracebackDelegate^ get () abstract;
    void set (TracebackDelegate^ value) abstract;
}
abstract TraceCallback : TracebackDelegate with get, set

Property Value

Type: TracebackDelegate

Implements

IScriptHostTraceCallback
See Also

Reference

ScriptHost Class
Alternet.Scripter.IronPython Namespace


ScriptRun Class

ScriptRun Class
Represents runner for script engine.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Scripter.IronPythonScriptRun

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptRun : Component, IScriptRun,
    IScriptRunBase
Public Class ScriptRun
    Inherits Component
    Implements IScriptRun, IScriptRunBase
public ref class ScriptRun : public Component,
    IScriptRun, IScriptRunBase
type ScriptRun =
    class
        inherit Component
        interface IScriptRun
        interface IScriptRunBase
    end

The ScriptRun type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptRun | Initializes a new instance of the ScriptRun class with default settings.
Public method | ScriptRun(IContainer) | Initializes a new instance of the ScriptRun class with specified parameters.
Top
Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateScriptHost | Creates a new IScriptHost object with appropriate characteristics.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadScript | Load script from specified file.
Public method | OnFileLoad | Invokes FileLoad event handler.
Public method | OnResolveReference | Invokes ReferenceResolve event handler.
Public method | OnScriptCompiled | Invokes ScriptCompiled event handler.
Public method | OnScriptError | Invokes ScriptError event handler.
Public method | OnScriptExecuted | Invokes ScriptRunning event handler.
Public method | OnScriptReset | Invokes ScriptReset event handler.
Public method | OnScriptRunning | Invokes ScriptRunning event handler.
Public method | Reset | Resets the script engine and releases all resources.
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunFunction | Executes specified function.
Public method | RunFunctionAsync | Executes specified function asynchronously.
Public method | RunProcess | Executes script starting from the main entry point in stand-alone process
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Properties
 | Name | Description
Public property | AutoGenerateTypeDefinitions | Gets or sets whether project should automatically generate type definitions if possible.
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive.
Public property | CodeEnvironment |
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Executed | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | GlobalItems | Gets or sets a script items collection attached to this runner.
Public property | LoadUserTypeDefinitions | Gets or sets whether users type definitions should be loaded.
Public property | ProjectDirectory | Gets or sets root project directory.
Public property | ScriptHost | Returns object that implements IScriptHost interface for this runner.
Public property | ScriptSource | Gets source of the script to execute.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | TypeDefinitionsSearchPaths | Gets or sets list of search directories to look for type definitions.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileLoad | Occurs when script code is loaded from file.
Public event | ReferenceResolve | Occurs when assembly reference needs to be resolved.
Public event | ScriptCompiled | Occurs when the script engine running successfully.
Public event | ScriptError | Occurs when the script engine running is failed.
Public event | ScriptExecuted | Occurs when script engine executes the script.
Public event | ScriptReset | Occurs when the script engine is reset.
Public event | ScriptRunning | Occurs when script engine tries to running script.
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


ScriptRun Constructor

ScriptRun Constructor
Overload List
 | Name | Description
Public method | ScriptRun | Initializes a new instance of the ScriptRun class with default settings.
Public method | ScriptRun(IContainer) | Initializes a new instance of the ScriptRun class with specified parameters.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun Constructor

ScriptRun Constructor
Initializes a new instance of the ScriptRun class with default settings.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRun()
Public Sub New
public:
ScriptRun()
new : unit -> ScriptRun
See Also

Reference

ScriptRun Class
ScriptRun Overload
Alternet.Scripter.IronPython Namespace


ScriptRun Constructor (IContainer)

ScriptRun Constructor (IContainer)
Initializes a new instance of the ScriptRun class with specified parameters.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRun(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
ScriptRun(
    IContainer^ container
)
new :
        container : IContainer -> ScriptRun

Parameters

container
Type: System.ComponentModelIContainer
Specifies container of this new instance.
See Also

Reference

ScriptRun Class
ScriptRun Overload
Alternet.Scripter.IronPython Namespace


ScriptRun Methods

ScriptRun Methods

The ScriptRun type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateScriptHost | Creates a new IScriptHost object with appropriate characteristics.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadScript | Load script from specified file.
Public method | OnFileLoad | Invokes FileLoad event handler.
Public method | OnResolveReference | Invokes ReferenceResolve event handler.
Public method | OnScriptCompiled | Invokes ScriptCompiled event handler.
Public method | OnScriptError | Invokes ScriptError event handler.
Public method | OnScriptExecuted | Invokes ScriptRunning event handler.
Public method | OnScriptReset | Invokes ScriptReset event handler.
Public method | OnScriptRunning | Invokes ScriptRunning event handler.
Public method | Reset | Resets the script engine and releases all resources.
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunFunction | Executes specified function.
Public method | RunFunctionAsync | Executes specified function asynchronously.
Public method | RunProcess | Executes script starting from the main entry point in stand-alone process
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.Compile Method

ScriptRunCompile Method
Initializes script engine and compiles the script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compile()
Public Overridable Function Compile As Boolean
public:
virtual bool Compile()
abstract Compile : unit -> bool
override Compile : unit -> bool

Return Value

Type: Boolean
True if succeed, otherwise false.

Implements

IScriptRunBaseCompile
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.CreateScriptHost Method

ScriptRunCreateScriptHost Method
Creates a new IScriptHost object with appropriate characteristics.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptHost CreateScriptHost()
Public Overridable Function CreateScriptHost As IScriptHost
public:
virtual IScriptHost^ CreateScriptHost()
abstract CreateScriptHost : unit -> IScriptHost
override CreateScriptHost : unit -> IScriptHost

Return Value

Type: IScriptHost
Created IScriptHost object.

Implements

IScriptRunCreateScriptHost
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.EvaluateExpression Method

ScriptRunEvaluateExpression Method
Evaluates specified expression.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object EvaluateExpression(
    string expression
)
Public Function EvaluateExpression (
    expression As String
) As Object
public:
virtual Object^ EvaluateExpression(
    String^ expression
) sealed
abstract EvaluateExpression :
        expression : string -> Object
override EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.

Implements

IScriptRunBaseEvaluateExpression(String)
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.EvaluateExpressionAsync Method

ScriptRunEvaluateExpressionAsync Method
Evaluates specified expression asynchronously.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Public Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.

Implements

IScriptRunEvaluateExpressionAsync(String, CancellationToken)
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.LoadScript Method

ScriptRunLoadScript Method
Load script from specified file.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string LoadScript(
    string fileName
)
Public Overridable Function LoadScript (
    fileName As String
) As String
public:
virtual String^ LoadScript(
    String^ fileName
)
abstract LoadScript :
        fileName : string -> string
override LoadScript :
        fileName : string -> string

Parameters

fileName
Type: SystemString
File name contains script to load.

Return Value

Type: String
String representation of loaded script.

Implements

IScriptRunBaseLoadScript(String)
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.OnFileLoad Method

ScriptRunOnFileLoad Method
Invokes FileLoad event handler.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string OnFileLoad(
    string fileName
)
Public Overridable Function OnFileLoad (
    fileName As String
) As String
public:
virtual String^ OnFileLoad(
    String^ fileName
)
abstract OnFileLoad :
        fileName : string -> string
override OnFileLoad :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String

Implements

IScriptRunBaseOnFileLoad(String)
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.OnResolveReference Method

ScriptRunOnResolveReference Method
Invokes ReferenceResolve event handler.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool OnResolveReference(
    string reference,
    out string assemblyLocation
)
Public Overridable Function OnResolveReference (
    reference As String,
    <OutAttribute> ByRef assemblyLocation As String
) As Boolean
public:
virtual bool OnResolveReference(
    String^ reference,
    [OutAttribute] String^% assemblyLocation
)
abstract OnResolveReference :
        reference : string *
        assemblyLocation : string byref -> bool
override OnResolveReference :
        reference : string *
        assemblyLocation : string byref -> bool

Parameters

reference
Type: SystemString
Reference to resolve.
assemblyLocation
Type: SystemString
Path to suitable assembly.

Return Value

Type: Boolean
true if reference was resolved otherwise false

Implements

IScriptRunOnResolveReference(String, String)
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.OnScriptCompiled Method

ScriptRunOnScriptCompiled Method
Invokes ScriptCompiled event handler.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptCompiled()
Public Overridable Sub OnScriptCompiled
public:
virtual void OnScriptCompiled()
abstract OnScriptCompiled : unit -> unit
override OnScriptCompiled : unit -> unit

Implements

IScriptRunBaseOnScriptCompiled
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.OnScriptError Method

ScriptRunOnScriptError Method
Invokes ScriptError event handler.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptError(
    ScriptErrorEventArgs e
)
Public Overridable Sub OnScriptError (
    e As ScriptErrorEventArgs
)
public:
virtual void OnScriptError(
    ScriptErrorEventArgs^ e
)
abstract OnScriptError :
        e : ScriptErrorEventArgs -> unit
override OnScriptError :
        e : ScriptErrorEventArgs -> unit

Parameters

e
Type: Alternet.ScripterScriptErrorEventArgs

Implements

IScriptRunBaseOnScriptError(ScriptErrorEventArgs)
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.OnScriptExecuted Method

ScriptRunOnScriptExecuted Method
Invokes ScriptRunning event handler.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptExecuted()
Public Overridable Sub OnScriptExecuted
public:
virtual void OnScriptExecuted()
abstract OnScriptExecuted : unit -> unit
override OnScriptExecuted : unit -> unit

Implements

IScriptRunBaseOnScriptExecuted
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.OnScriptReset Method

ScriptRunOnScriptReset Method
Invokes ScriptReset event handler.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptReset()
Public Overridable Sub OnScriptReset
public:
virtual void OnScriptReset()
abstract OnScriptReset : unit -> unit
override OnScriptReset : unit -> unit

Implements

IScriptRunBaseOnScriptReset
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.OnScriptRunning Method

ScriptRunOnScriptRunning Method
Invokes ScriptRunning event handler.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptRunning()
Public Overridable Sub OnScriptRunning
public:
virtual void OnScriptRunning()
abstract OnScriptRunning : unit -> unit
override OnScriptRunning : unit -> unit

Implements

IScriptRunBaseOnScriptRunning
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.Reset Method

ScriptRunReset Method
Resets the script engine and releases all resources.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptRunBaseReset
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.Run Method

ScriptRunRun Method
Executes script starting from the main entry point.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Run()
Public Overridable Function Run As Object
public:
virtual Object^ Run()
abstract Run : unit -> Object
override Run : unit -> Object

Return Value

Type: Object
Return value of the script being executed.

Implements

IScriptRunBaseRun
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.RunAsync Method

ScriptRunRunAsync Method
Executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task RunAsync(
    CancellationToken cancellationToken = null
)
Public Overridable Function RunAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
public:
virtual Task^ RunAsync(
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task
override RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: Task
Return value of the script being executed.

Implements

IScriptRunRunAsync(CancellationToken)
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.RunFunction Method

ScriptRunRunFunction Method
Executes specified function.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object RunFunction(
    string function,
    Object[] args = null
)
Public Overridable Function RunFunction (
    function As String,
    Optional args As Object() = Nothing
) As Object
public:
virtual Object^ RunFunction(
    String^ function,
    array<Object^>^ args = nullptr
)
abstract RunFunction :
        function : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object
override RunFunction :
        function : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.

Return Value

Type: Object
An object containing return value of the executed function.

Implements

IScriptRunRunFunction(String, Object)
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.RunFunctionAsync Method

ScriptRunRunFunctionAsync Method
Executes specified function asynchronously.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<Object> RunFunctionAsync(
    string function,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Public Function RunFunctionAsync (
    function As String,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ RunFunctionAsync(
    String^ function,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
) sealed
abstract RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed function.

Implements

IScriptRunRunFunctionAsync(String, Object, CancellationToken)
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.RunProcess Method

ScriptRunRunProcess Method
Executes script starting from the main entry point in stand-alone process

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int RunProcess(
    string[] args = null,
    bool wait = true
)
Public Overridable Function RunProcess (
    Optional args As String() = Nothing,
    Optional wait As Boolean = true
) As Integer
public:
virtual int RunProcess(
    array<String^>^ args = nullptr,
    bool wait = true
)
abstract RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int
override RunProcess :
        ?args : string[] *
        ?wait : bool
(* Defaults:
        let _args = defaultArg args null
        let _wait = defaultArg wait true
*)
-> int

Parameters

args (Optional)
Type: SystemString
Specifies main method parameters.
wait (Optional)
Type: SystemBoolean
Specifies if calling application should wait for process termination

Return Value

Type: Int32
Return process exit code.
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun Properties

ScriptRun Properties

The ScriptRun type exposes the following members.

Properties
 | Name | Description
Public property | AutoGenerateTypeDefinitions | Gets or sets whether project should automatically generate type definitions if possible.
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive.
Public property | CodeEnvironment |
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Executed | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | GlobalItems | Gets or sets a script items collection attached to this runner.
Public property | LoadUserTypeDefinitions | Gets or sets whether users type definitions should be loaded.
Public property | ProjectDirectory | Gets or sets root project directory.
Public property | ScriptHost | Returns object that implements IScriptHost interface for this runner.
Public property | ScriptSource | Gets source of the script to execute.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | TypeDefinitionsSearchPaths | Gets or sets list of search directories to look for type definitions.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.AutoGenerateTypeDefinitions Property

ScriptRunAutoGenerateTypeDefinitions Property
Gets or sets whether project should automatically generate type definitions if possible.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoGenerateTypeDefinitions { get; set; }
Public Property AutoGenerateTypeDefinitions As Boolean
    Get
    Set
public:
property bool AutoGenerateTypeDefinitions {
    bool get ();
    void set (bool value);
}
member AutoGenerateTypeDefinitions : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.CaseSensitive Property

ScriptRunCaseSensitive Property
When implemented by a class, indicates whether script language is case sensitive.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CaseSensitive { get; }
Public ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () sealed;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

IScriptRunBaseCaseSensitive
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.CodeEnvironment Property

ScriptRunCodeEnvironment Property

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeEnvironment CodeEnvironment { get; }
Public ReadOnly Property CodeEnvironment As ICodeEnvironment
    Get
public:
virtual property ICodeEnvironment^ CodeEnvironment {
    ICodeEnvironment^ get () sealed;
}
abstract CodeEnvironment : ICodeEnvironment with get
override CodeEnvironment : ICodeEnvironment with get

Property Value

Type: ICodeEnvironment

Implements

IScriptRunCodeEnvironment
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.Compiled Property

ScriptRunCompiled Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compiled { get; }
Public Overridable ReadOnly Property Compiled As Boolean
    Get
public:
virtual property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get
override Compiled : bool with get

Property Value

Type: Boolean

Implements

IScriptRunBaseCompiled
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.Executed Property

ScriptRunExecuted Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Executed { get; }
Public Overridable ReadOnly Property Executed As Boolean
    Get
public:
virtual property bool Executed {
    bool get ();
}
abstract Executed : bool with get
override Executed : bool with get

Property Value

Type: Boolean

Implements

IScriptRunBaseExecuted
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.GlobalItems Property

ScriptRunGlobalItems Property
Gets or sets a script items collection attached to this runner.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IScriptGlobalItem> GlobalItems { get; }
Public ReadOnly Property GlobalItems As IList(Of IScriptGlobalItem)
    Get
public:
virtual property IList<IScriptGlobalItem^>^ GlobalItems {
    IList<IScriptGlobalItem^>^ get () sealed;
}
abstract GlobalItems : IList<IScriptGlobalItem> with get
override GlobalItems : IList<IScriptGlobalItem> with get

Property Value

Type: IListIScriptGlobalItem

Implements

IScriptRunGlobalItems
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.LoadUserTypeDefinitions Property

ScriptRunLoadUserTypeDefinitions Property
Gets or sets whether users type definitions should be loaded.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadUserTypeDefinitions { get; set; }
Public Property LoadUserTypeDefinitions As Boolean
    Get
    Set
public:
property bool LoadUserTypeDefinitions {
    bool get ();
    void set (bool value);
}
member LoadUserTypeDefinitions : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.ProjectDirectory Property

ScriptRunProjectDirectory Property
Gets or sets root project directory.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectDirectory { get; set; }
Public Property ProjectDirectory As String
    Get
    Set
public:
property String^ ProjectDirectory {
    String^ get ();
    void set (String^ value);
}
member ProjectDirectory : string with get, set

Property Value

Type: String
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.ScriptHost Property

ScriptRunScriptHost Property
Returns object that implements IScriptHost interface for this runner.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptHost ScriptHost { get; set; }
Public Overridable Property ScriptHost As IScriptHost
    Get
    Set
public:
virtual property IScriptHost^ ScriptHost {
    IScriptHost^ get ();
    void set (IScriptHost^ value);
}
abstract ScriptHost : IScriptHost with get, set
override ScriptHost : IScriptHost with get, set

Property Value

Type: IScriptHost

Implements

IScriptRunScriptHost
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.ScriptSource Property

ScriptRunScriptSource Property
Gets source of the script to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptSource ScriptSource { get; }
Public ReadOnly Property ScriptSource As IScriptSource
    Get
public:
virtual property IScriptSource^ ScriptSource {
    IScriptSource^ get () sealed;
}
abstract ScriptSource : IScriptSource with get
override ScriptSource : IScriptSource with get

Property Value

Type: IScriptSource

Implements

IScriptRunScriptSource
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.TypeDefinitionsSearchPaths Property

ScriptRunTypeDefinitionsSearchPaths Property
Gets or sets list of search directories to look for type definitions.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> TypeDefinitionsSearchPaths { get; set; }
Public Property TypeDefinitionsSearchPaths As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ TypeDefinitionsSearchPaths {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member TypeDefinitionsSearchPaths : IEnumerable<string> with get, set

Property Value

Type: IEnumerableString
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun Events

ScriptRun Events

The ScriptRun type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileLoad | Occurs when script code is loaded from file.
Public event | ReferenceResolve | Occurs when assembly reference needs to be resolved.
Public event | ScriptCompiled | Occurs when the script engine running successfully.
Public event | ScriptError | Occurs when the script engine running is failed.
Public event | ScriptExecuted | Occurs when script engine executes the script.
Public event | ScriptReset | Occurs when the script engine is reset.
Public event | ScriptRunning | Occurs when script engine tries to running script.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.FileLoad Event

ScriptRunFileLoad Event
Occurs when script code is loaded from file.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileLoadEventArgs> FileLoad
Public Event FileLoad As EventHandler(Of FileLoadEventArgs)
public:
virtual  event EventHandler<FileLoadEventArgs^>^ FileLoad {
    void add (EventHandler<FileLoadEventArgs^>^ value);
    void remove (EventHandler<FileLoadEventArgs^>^ value);
}
abstract FileLoad : IEvent<EventHandler<FileLoadEventArgs>,
    FileLoadEventArgs>
override FileLoad : IEvent<EventHandler<FileLoadEventArgs>,
    FileLoadEventArgs>

Value

Type: SystemEventHandlerFileLoadEventArgs

Implements

IScriptRunBaseFileLoad
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.ReferenceResolve Event

ScriptRunReferenceResolve Event
Occurs when assembly reference needs to be resolved.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ResolveReferenceEventArgs> ReferenceResolve
Public Event ReferenceResolve As EventHandler(Of ResolveReferenceEventArgs)
public:
virtual  event EventHandler<ResolveReferenceEventArgs^>^ ReferenceResolve {
    void add (EventHandler<ResolveReferenceEventArgs^>^ value);
    void remove (EventHandler<ResolveReferenceEventArgs^>^ value);
}
abstract ReferenceResolve : IEvent<EventHandler<ResolveReferenceEventArgs>,
    ResolveReferenceEventArgs>
override ReferenceResolve : IEvent<EventHandler<ResolveReferenceEventArgs>,
    ResolveReferenceEventArgs>

Value

Type: SystemEventHandlerResolveReferenceEventArgs

Implements

IScriptRunReferenceResolve
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.ScriptCompiled Event

ScriptRunScriptCompiled Event
Occurs when the script engine running successfully.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptCompiled
Public Event ScriptCompiled As EventHandler
public:
virtual  event EventHandler^ ScriptCompiled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptCompiled : IEvent<EventHandler,
    EventArgs>
override ScriptCompiled : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptCompiled
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.ScriptError Event

ScriptRunScriptError Event
Occurs when the script engine running is failed.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ScriptErrorEventArgs> ScriptError
Public Event ScriptError As EventHandler(Of ScriptErrorEventArgs)
public:
virtual  event EventHandler<ScriptErrorEventArgs^>^ ScriptError {
    void add (EventHandler<ScriptErrorEventArgs^>^ value);
    void remove (EventHandler<ScriptErrorEventArgs^>^ value);
}
abstract ScriptError : IEvent<EventHandler<ScriptErrorEventArgs>,
    ScriptErrorEventArgs>
override ScriptError : IEvent<EventHandler<ScriptErrorEventArgs>,
    ScriptErrorEventArgs>

Value

Type: SystemEventHandlerScriptErrorEventArgs

Implements

IScriptRunBaseScriptError
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.ScriptExecuted Event

ScriptRunScriptExecuted Event
Occurs when script engine executes the script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptExecuted
Public Event ScriptExecuted As EventHandler
public:
virtual  event EventHandler^ ScriptExecuted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptExecuted : IEvent<EventHandler,
    EventArgs>
override ScriptExecuted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptExecuted
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.ScriptReset Event

ScriptRunScriptReset Event
Occurs when the script engine is reset.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptReset
Public Event ScriptReset As EventHandler
public:
virtual  event EventHandler^ ScriptReset {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptReset : IEvent<EventHandler,
    EventArgs>
override ScriptReset : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptReset
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptRun.ScriptRunning Event

ScriptRunScriptRunning Event
Occurs when script engine tries to running script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptRunning
Public Event ScriptRunning As EventHandler
public:
virtual  event EventHandler^ ScriptRunning {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptRunning : IEvent<EventHandler,
    EventArgs>
override ScriptRunning : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptRunning
See Also

Reference

ScriptRun Class
Alternet.Scripter.IronPython Namespace


ScriptSource Class

ScriptSource Class
Provides methods and properties to work with script text, files or projects.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.IronPythonScriptSource

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptSource : IScriptSource,
    IScriptSourceBase, ICloneable, IEquatable<IScriptSource>
Public Class ScriptSource
    Implements IScriptSource, IScriptSourceBase, ICloneable, IEquatable(Of IScriptSource)
public ref class ScriptSource : IScriptSource,
    IScriptSourceBase, ICloneable, IEquatable<IScriptSource^>
type ScriptSource =
    class
        interface IScriptSource
        interface IScriptSourceBase
        interface ICloneable
        interface IEquatable<IScriptSource>
    end

The ScriptSource type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptSource | Initializes a new instance of the ScriptSource class with specified script runner.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ScriptSource object.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IScriptSource) | Determines whether the specified IScriptSource is equal to the current ScriptSource.
Public method | FromExpression | Loads script source from the expression.
Public method | FromScriptCode | Loads script source from the script code.
Public method | FromScriptFile | Loads script source from the script file.
Public method | FromScriptProject | Loads script source from the Visual Studio project.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLastModifiedDate | Gets file date time when script source was compiled.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBeenModified | Compares file modification dates against to other script source.
Public method | Reset | Clears script source.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Changed | Gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Expression | Gets expression to evaluate.
Public property | Files | Gets list of files containing script to execute.
Public property | FrameworkPath | Gets location of .NET Framework assemblies.
Public property | HasExpression | Returns boolean value indicating whether ScriptSource contains expression to evaluate.
Public property | HasProject | Returns boolean value indicating whether ScriptSource is associated with the project.
Public property | HasScriptCode | Returns boolean value indicating whether ScriptSource contains script code to execute.
Public property | HasScriptFile | Returns boolean value indicating whether ScriptSource contains script file to execute.
Public property | Imports | Gets list of namespaces to be used in the script.
Public property | ModulesSearchPaths | Gets list of search directories to look for Python modules.
Public property | ProjectFileName | Gets a file name of the Visual Studio project containing script files to execute.
Public property | ProjectName | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | ReferencedFrameworks | Gets or sets a combination of referenced library frameworks.
Public property | References | Gets list of external assemblies referenced from the script.
Public property | ReferencesSearchPaths | Gets list of search directories to look for assembly references.
Public property | ScriptCode | Gets script code to execute.
Public property | ScriptFile | Gets single script file to execute.
Public property | StartupFile | When implemented by a class, gets or sets startup Python script file to be executed on script run. When this property is set, the only file that is executed is the StartupFile. When this property is not set, all the script files are executed in order they are specified.
Top
See Also

Reference

Alternet.Scripter.IronPython Namespace


ScriptSource Constructor

ScriptSource Constructor
Initializes a new instance of the ScriptSource class with specified script runner.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptSource(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
ScriptSource(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> ScriptSource

Parameters

scriptRun
Type: Alternet.Scripter.IronPythonIScriptRun
Specifies object that implements IScriptRun interface for this new instance.
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource Methods

ScriptSource Methods

The ScriptSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ScriptSource object.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IScriptSource) | Determines whether the specified IScriptSource is equal to the current ScriptSource.
Public method | FromExpression | Loads script source from the expression.
Public method | FromScriptCode | Loads script source from the script code.
Public method | FromScriptFile | Loads script source from the script file.
Public method | FromScriptProject | Loads script source from the Visual Studio project.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLastModifiedDate | Gets file date time when script source was compiled.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBeenModified | Compares file modification dates against to other script source.
Public method | Reset | Clears script source.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.Clone Method

ScriptSourceClone Method
Creates a new object that is a copy of the current ScriptSource object.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of ScriptSource that is the memberwise clone of the current ScriptSource object.

Implements

ICloneableClone
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.Equals Method

ScriptSourceEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IScriptSource) | Determines whether the specified IScriptSource is equal to the current ScriptSource.
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.Equals Method (IScriptSource)

ScriptSourceEquals Method (IScriptSource)
Determines whether the specified IScriptSource is equal to the current ScriptSource.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IScriptSource other
)
Public Function Equals (
    other As IScriptSource
) As Boolean
public:
virtual bool Equals(
    IScriptSource^ other
) sealed
abstract Equals :
        other : IScriptSource -> bool
override Equals :
        other : IScriptSource -> bool

Parameters

other
Type: Alternet.Scripter.IronPythonIScriptSource
The IScriptSource to compare with the current source.

Return Value

Type: Boolean
True if the specified source is equal to the current source; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

ScriptSource Class
Equals Overload
Alternet.Scripter.IronPython Namespace


ScriptSource.FromExpression Method

ScriptSourceFromExpression Method
Loads script source from the expression.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromExpression(
    string expression
)
Public Overridable Function FromExpression (
    expression As String
) As IScriptSource
public:
virtual IScriptSource^ FromExpression(
    String^ expression
)
abstract FromExpression :
        expression : string -> IScriptSource
override FromExpression :
        expression : string -> IScriptSource

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromExpression(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.FromScriptCode Method

ScriptSourceFromScriptCode Method
Loads script source from the script code.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptCode(
    string scriptCode
)
Public Overridable Function FromScriptCode (
    scriptCode As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptCode(
    String^ scriptCode
)
abstract FromScriptCode :
        scriptCode : string -> IScriptSource
override FromScriptCode :
        scriptCode : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptCode(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.FromScriptFile Method

ScriptSourceFromScriptFile Method
Loads script source from the script file.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptFile(
    string fileName
)
Public Overridable Function FromScriptFile (
    fileName As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptFile(
    String^ fileName
)
abstract FromScriptFile :
        fileName : string -> IScriptSource
override FromScriptFile :
        fileName : string -> IScriptSource

Parameters

fileName
Type: SystemString
File Name to load the script.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptFile(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.FromScriptProject Method

ScriptSourceFromScriptProject Method
Loads script source from the Visual Studio project.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptProject(
    string projectFileName
)
Public Overridable Function FromScriptProject (
    projectFileName As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptProject(
    String^ projectFileName
)
abstract FromScriptProject :
        projectFileName : string -> IScriptSource
override FromScriptProject :
        projectFileName : string -> IScriptSource

Parameters

projectFileName
Type: SystemString
Project file name to load script.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptProject(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.GetLastModifiedDate Method

ScriptSourceGetLastModifiedDate Method
Gets file date time when script source was compiled.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime GetLastModifiedDate(
    string fileName
)
Public Function GetLastModifiedDate (
    fileName As String
) As DateTime
public:
virtual DateTime GetLastModifiedDate(
    String^ fileName
) sealed
abstract GetLastModifiedDate :
        fileName : string -> DateTime
override GetLastModifiedDate :
        fileName : string -> DateTime

Parameters

fileName
Type: SystemString
FileName to check last modified date.

Return Value

Type: DateTime
File date of the given file at the time it was compiled.

Implements

IScriptSourceGetLastModifiedDate(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.HasBeenModified Method

ScriptSourceHasBeenModified Method
Compares file modification dates against to other script source.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBeenModified(
    IScriptSource other
)
Public Function HasBeenModified (
    other As IScriptSource
) As Boolean
public:
virtual bool HasBeenModified(
    IScriptSource^ other
) sealed
abstract HasBeenModified :
        other : IScriptSource -> bool
override HasBeenModified :
        other : IScriptSource -> bool

Parameters

other
Type: Alternet.Scripter.IronPythonIScriptSource
IScriptSource to compare.

Return Value

Type: Boolean
True, if source has been changed since last compilation; otherwise false.

Implements

IScriptSourceHasBeenModified(IScriptSource)
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.Reset Method

ScriptSourceReset Method
Clears script source.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptSourceReset
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource Properties

ScriptSource Properties

The ScriptSource type exposes the following members.

Properties
 | Name | Description
Public property | Changed | Gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Expression | Gets expression to evaluate.
Public property | Files | Gets list of files containing script to execute.
Public property | FrameworkPath | Gets location of .NET Framework assemblies.
Public property | HasExpression | Returns boolean value indicating whether ScriptSource contains expression to evaluate.
Public property | HasProject | Returns boolean value indicating whether ScriptSource is associated with the project.
Public property | HasScriptCode | Returns boolean value indicating whether ScriptSource contains script code to execute.
Public property | HasScriptFile | Returns boolean value indicating whether ScriptSource contains script file to execute.
Public property | Imports | Gets list of namespaces to be used in the script.
Public property | ModulesSearchPaths | Gets list of search directories to look for Python modules.
Public property | ProjectFileName | Gets a file name of the Visual Studio project containing script files to execute.
Public property | ProjectName | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | ReferencedFrameworks | Gets or sets a combination of referenced library frameworks.
Public property | References | Gets list of external assemblies referenced from the script.
Public property | ReferencesSearchPaths | Gets list of search directories to look for assembly references.
Public property | ScriptCode | Gets script code to execute.
Public property | ScriptFile | Gets single script file to execute.
Public property | StartupFile | When implemented by a class, gets or sets startup Python script file to be executed on script run. When this property is set, the only file that is executed is the StartupFile. When this property is not set, all the script files are executed in order they are specified.
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.Changed Property

ScriptSourceChanged Property
Gets or sets boolean value indicating if script source has been modified since last compilation.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Changed { get; set; }
Public Property Changed As Boolean
    Get
    Set
public:
virtual property bool Changed {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Changed : bool with get, set
override Changed : bool with get, set

Property Value

Type: Boolean

Implements

IScriptSourceChanged
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.Expression Property

ScriptSourceExpression Property
Gets expression to evaluate.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; }
Public ReadOnly Property Expression As String
    Get
public:
virtual property String^ Expression {
    String^ get () sealed;
}
abstract Expression : string with get
override Expression : string with get

Property Value

Type: String

Implements

IScriptSourceBaseExpression
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.Files Property

ScriptSourceFiles Property
Gets list of files containing script to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Files { get; }
Public ReadOnly Property Files As IList(Of String)
    Get
public:
virtual property IList<String^>^ Files {
    IList<String^>^ get () sealed;
}
abstract Files : IList<string> with get
override Files : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceFiles
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.FrameworkPath Property

ScriptSourceFrameworkPath Property
Gets location of .NET Framework assemblies.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FrameworkPath { get; set; }
Public Property FrameworkPath As String
    Get
    Set
public:
virtual property String^ FrameworkPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FrameworkPath : string with get, set
override FrameworkPath : string with get, set

Property Value

Type: String

Implements

IScriptSourceFrameworkPath
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.HasExpression Property

ScriptSourceHasExpression Property
Returns boolean value indicating whether ScriptSource contains expression to evaluate.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasExpression { get; }
Public ReadOnly Property HasExpression As Boolean
    Get
public:
virtual property bool HasExpression {
    bool get () sealed;
}
abstract HasExpression : bool with get
override HasExpression : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasExpression
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.HasProject Property

ScriptSourceHasProject Property
Returns boolean value indicating whether ScriptSource is associated with the project.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasProject { get; }
Public ReadOnly Property HasProject As Boolean
    Get
public:
virtual property bool HasProject {
    bool get () sealed;
}
abstract HasProject : bool with get
override HasProject : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasProject
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.HasScriptCode Property

ScriptSourceHasScriptCode Property
Returns boolean value indicating whether ScriptSource contains script code to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasScriptCode { get; }
Public ReadOnly Property HasScriptCode As Boolean
    Get
public:
virtual property bool HasScriptCode {
    bool get () sealed;
}
abstract HasScriptCode : bool with get
override HasScriptCode : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasScriptCode
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.HasScriptFile Property

ScriptSourceHasScriptFile Property
Returns boolean value indicating whether ScriptSource contains script file to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasScriptFile { get; }
Public ReadOnly Property HasScriptFile As Boolean
    Get
public:
virtual property bool HasScriptFile {
    bool get () sealed;
}
abstract HasScriptFile : bool with get
override HasScriptFile : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasScriptFile
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.Imports Property

ScriptSourceImports Property
Gets list of namespaces to be used in the script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Imports { get; }
Public ReadOnly Property Imports As IList(Of String)
    Get
public:
virtual property IList<String^>^ Imports {
    IList<String^>^ get () sealed;
}
abstract Imports : IList<string> with get
override Imports : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceImports
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.ModulesSearchPaths Property

ScriptSourceModulesSearchPaths Property
Gets list of search directories to look for Python modules.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> ModulesSearchPaths { get; }
Public ReadOnly Property ModulesSearchPaths As IList(Of String)
    Get
public:
virtual property IList<String^>^ ModulesSearchPaths {
    IList<String^>^ get () sealed;
}
abstract ModulesSearchPaths : IList<string> with get
override ModulesSearchPaths : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceModulesSearchPaths
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.ProjectFileName Property

ScriptSourceProjectFileName Property
Gets a file name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectFileName { get; }
Public ReadOnly Property ProjectFileName As String
    Get
public:
virtual property String^ ProjectFileName {
    String^ get () sealed;
}
abstract ProjectFileName : string with get
override ProjectFileName : string with get

Property Value

Type: String

Implements

IScriptSourceBaseProjectFileName
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.ProjectName Property

ScriptSourceProjectName Property
Gets or sets name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectName { get; set; }
Public Property ProjectName As String
    Get
    Set
public:
virtual property String^ ProjectName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ProjectName : string with get, set
override ProjectName : string with get, set

Property Value

Type: String

Implements

IScriptSourceProjectName
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.ReferencedFrameworks Property

ScriptSourceReferencedFrameworks Property
Gets or sets a combination of referenced library frameworks.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Framework ReferencedFrameworks { get; set; }
Public Property ReferencedFrameworks As Framework
    Get
    Set
public:
virtual property Framework ReferencedFrameworks {
    Framework get () sealed;
    void set (Framework value) sealed;
}
abstract ReferencedFrameworks : Framework with get, set
override ReferencedFrameworks : Framework with get, set

Property Value

Type: Framework

Implements

IScriptSourceReferencedFrameworks
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.References Property

ScriptSourceReferences Property
Gets list of external assemblies referenced from the script.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> References { get; }
Public ReadOnly Property References As IList(Of String)
    Get
public:
virtual property IList<String^>^ References {
    IList<String^>^ get () sealed;
}
abstract References : IList<string> with get
override References : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceReferences
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.ReferencesSearchPaths Property

ScriptSourceReferencesSearchPaths Property
Gets list of search directories to look for assembly references.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> ReferencesSearchPaths { get; }
Public ReadOnly Property ReferencesSearchPaths As IList(Of String)
    Get
public:
virtual property IList<String^>^ ReferencesSearchPaths {
    IList<String^>^ get () sealed;
}
abstract ReferencesSearchPaths : IList<string> with get
override ReferencesSearchPaths : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceReferencesSearchPaths
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.ScriptCode Property

ScriptSourceScriptCode Property
Gets script code to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptCode { get; }
Public ReadOnly Property ScriptCode As String
    Get
public:
virtual property String^ ScriptCode {
    String^ get () sealed;
}
abstract ScriptCode : string with get
override ScriptCode : string with get

Property Value

Type: String

Implements

IScriptSourceBaseScriptCode
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.ScriptFile Property

ScriptSourceScriptFile Property
Gets single script file to execute.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptFile { get; }
Public ReadOnly Property ScriptFile As String
    Get
public:
virtual property String^ ScriptFile {
    String^ get () sealed;
}
abstract ScriptFile : string with get
override ScriptFile : string with get

Property Value

Type: String

Implements

IScriptSourceBaseScriptFile
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


ScriptSource.StartupFile Property

ScriptSourceStartupFile Property
When implemented by a class, gets or sets startup Python script file to be executed on script run. When this property is set, the only file that is executed is the StartupFile. When this property is not set, all the script files are executed in order they are specified.

Namespace: Alternet.Scripter.IronPython
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StartupFile { get; set; }
Public Property StartupFile As String
    Get
    Set
public:
virtual property String^ StartupFile {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract StartupFile : string with get, set
override StartupFile : string with get, set

Property Value

Type: String

Implements

IScriptSourceStartupFile
See Also

Reference

ScriptSource Class
Alternet.Scripter.IronPython Namespace


Alternet.Scripter.IronPython.License Namespace

Alternet.Scripter.IronPython.License Namespace
Classes
 | Class | Description
Public class | ScripterLicenseProvider | Implements license provider for ScriptRun.


ScripterLicenseProvider Class

ScripterLicenseProvider Class
Implements license provider for ScriptRun.
Inheritance Hierarchy
SystemObject
System.ComponentModelLicenseProvider
ComponentLicenseProvider
Alternet.Scripter.IronPython.LicenseScripterLicenseProvider

Namespace: Alternet.Scripter.IronPython.License
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScripterLicenseProvider : ComponentLicenseProvider
Public Class ScripterLicenseProvider
    Inherits ComponentLicenseProvider
public ref class ScripterLicenseProvider : public ComponentLicenseProvider
type ScripterLicenseProvider =
    class
        inherit ComponentLicenseProvider
    end

The ScripterLicenseProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ScripterLicenseProvider | Initializes a new instance of the ScripterLicenseProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLicense | When overridden in a derived class, gets a license for an instance or type of component, when given a context and whether the denial of a license throws an exception. (Inherited from LicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.IronPython.License Namespace


ScripterLicenseProvider Constructor

ScripterLicenseProvider Constructor
Initializes a new instance of the ScripterLicenseProvider class

Namespace: Alternet.Scripter.IronPython.License
Assembly: Alternet.Scripter.IronPython.v7 (in Alternet.Scripter.IronPython.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScripterLicenseProvider()
Public Sub New
public:
ScripterLicenseProvider()
new : unit -> ScripterLicenseProvider
See Also

Reference

ScripterLicenseProvider Class
Alternet.Scripter.IronPython.License Namespace


ScripterLicenseProvider Methods

ScripterLicenseProvider Methods

The ScripterLicenseProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLicense | When overridden in a derived class, gets a license for an instance or type of component, when given a context and whether the denial of a license throws an exception. (Inherited from LicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScripterLicenseProvider Class
Alternet.Scripter.IronPython.License Namespace


Alternet.Scripter.License Namespace

Alternet.Scripter.License Namespace
Classes
 | Class | Description
Public class | ScripterLicenseProvider | Implements license provider for ScriptRun.


ScripterLicenseProvider Class

ScripterLicenseProvider Class
Implements license provider for ScriptRun.
Inheritance Hierarchy
SystemObject
System.ComponentModelLicenseProvider
ComponentLicenseProvider
Alternet.Scripter.LicenseScripterLicenseProvider

Namespace: Alternet.Scripter.License
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScripterLicenseProvider : ComponentLicenseProvider
Public Class ScripterLicenseProvider
    Inherits ComponentLicenseProvider
public ref class ScripterLicenseProvider : public ComponentLicenseProvider
type ScripterLicenseProvider =
    class
        inherit ComponentLicenseProvider
    end

The ScripterLicenseProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ScripterLicenseProvider | Initializes a new instance of the ScripterLicenseProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLicense | When overridden in a derived class, gets a license for an instance or type of component, when given a context and whether the denial of a license throws an exception. (Inherited from LicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.License Namespace


ScripterLicenseProvider Constructor

ScripterLicenseProvider Constructor
Initializes a new instance of the ScripterLicenseProvider class

Namespace: Alternet.Scripter.License
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScripterLicenseProvider()
Public Sub New
public:
ScripterLicenseProvider()
new : unit -> ScripterLicenseProvider
See Also

Reference

ScripterLicenseProvider Class
Alternet.Scripter.License Namespace


ScripterLicenseProvider Methods

ScripterLicenseProvider Methods

The ScripterLicenseProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLicense | When overridden in a derived class, gets a license for an instance or type of component, when given a context and whether the denial of a license throws an exception. (Inherited from LicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScripterLicenseProvider Class
Alternet.Scripter.License Namespace


Alternet.Scripter.Roslyn Namespace

Alternet.Scripter.Roslyn Namespace
Classes
 | Class | Description
Public class | CSharpScriptProvider | Provides code generation for C# based on Microsoft Roslyn.
Public class | RoslynDocumentationProvider | Provide XML documentation to the compiler for members from metadata.
Public class | RoslynScriptHost | Provides methods and properties to support a Roslyn-based script host.
Public class | RoslynScriptProvider | Provides a base class for Roslyn code generation. This class is abstract.
Public class | VisualBasicScriptProvider | Provides code generation for VisualBasic.NET based on Microsoft Roslyn.
Structures
 | Structure | Description
Public structure | RoslynScriptProviderCompileResult | Represent structured information of code compilation result.


CSharpScriptProvider Class

CSharpScriptProvider Class
Provides code generation for C# based on Microsoft Roslyn.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.RoslynRoslynScriptProvider
Alternet.Scripter.RoslynCSharpScriptProvider

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CSharpScriptProvider : RoslynScriptProvider
Public Class CSharpScriptProvider
    Inherits RoslynScriptProvider
public ref class CSharpScriptProvider : public RoslynScriptProvider
type CSharpScriptProvider =
    class
        inherit RoslynScriptProvider
    end

The CSharpScriptProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpScriptProvider | Initializes a new instance of the CSharpScriptProvider class with specified IScriptHost.
Top
Methods
 | Name | Description
Public method | Compile | Compiles the script. (Inherited from RoslynScriptProvider.)
Public method | Dispose | Destroys the instance of the RoslynScriptProvider class. (Inherited from RoslynScriptProvider.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GenerateGlobalItems | Generates code from given global items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime | (Inherited from RoslynScriptProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyFileName | Gets or sets script assembly file name. (Inherited from RoslynScriptProvider.)
Public property | AssemblyPath | Gets or sets script assembly file path. (Inherited from RoslynScriptProvider.)
Public property | AssemblyTargetPath | Represents the fully qualified path of the assembly file. (Inherited from RoslynScriptProvider.)
Public property | Compilation | Gets a current project or code Microsoft.CodeAnalysis.Compilation. (Inherited from RoslynScriptProvider.)
Public property | EmbeddedResources | List of the compilation's managed resources. Null to indicate that there are none. (Inherited from RoslynScriptProvider.)
Public property | PDBTargetPath | Represents the .pdb file path. (Inherited from RoslynScriptProvider.)
Public property | ScriptAssembly | Gets compiled script assembly. (Inherited from RoslynScriptProvider.)
Public property | ScriptCompiled | Indicates whether script has been successfully compiled. (Inherited from RoslynScriptProvider.)
Public property | Workspace | Gets a current project or code Microsoft.CodeAnalysis.Workspace. (Inherited from RoslynScriptProvider.)
Top
See Also

Reference

Alternet.Scripter.Roslyn Namespace


CSharpScriptProvider Constructor

CSharpScriptProvider Constructor
Initializes a new instance of the CSharpScriptProvider class with specified IScriptHost.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CSharpScriptProvider(
    IScriptHost host,
    SourceCodeKind sourceKind = SourceCodeKind.Regular
)
Public Sub New (
    host As IScriptHost,
    Optional sourceKind As SourceCodeKind = SourceCodeKind.Regular
)
public:
CSharpScriptProvider(
    IScriptHost^ host,
    SourceCodeKind sourceKind = SourceCodeKind::Regular
)
new :
        host : IScriptHost *
        ?sourceKind : SourceCodeKind
(* Defaults:
        let _sourceKind = defaultArg sourceKind SourceCodeKind.Regular
*)
-> CSharpScriptProvider

Parameters

host
Type: Alternet.ScripterIScriptHost
IScriptHost holds script engine functionality.
sourceKind (Optional)
Type: SourceCodeKind
Specifies regular or Script source kind
See Also

Reference

CSharpScriptProvider Class
Alternet.Scripter.Roslyn Namespace


CSharpScriptProvider Methods

CSharpScriptProvider Methods

The CSharpScriptProvider type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the script. (Inherited from RoslynScriptProvider.)
Public method | Dispose | Destroys the instance of the RoslynScriptProvider class. (Inherited from RoslynScriptProvider.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GenerateGlobalItems | Generates code from given global items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime | (Inherited from RoslynScriptProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpScriptProvider Class
Alternet.Scripter.Roslyn Namespace


CSharpScriptProvider.GenerateGlobalItems Method

CSharpScriptProviderGenerateGlobalItems Method
Generates code from given global items.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GenerateGlobalItems(
    IList<IScriptGlobalItem> globalItems
)
Public Shared Function GenerateGlobalItems (
    globalItems As IList(Of IScriptGlobalItem)
) As String
public:
static String^ GenerateGlobalItems(
    IList<IScriptGlobalItem^>^ globalItems
)
static member GenerateGlobalItems :
        globalItems : IList<IScriptGlobalItem> -> string

Parameters

globalItems
Type: System.Collections.GenericIListIScriptGlobalItem
Collection of global items.

Return Value

Type: String
Code contains declaration of global items.
See Also

Reference

CSharpScriptProvider Class
Alternet.Scripter.Roslyn Namespace


CSharpScriptProvider Properties

CSharpScriptProvider Properties

The CSharpScriptProvider type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyFileName | Gets or sets script assembly file name. (Inherited from RoslynScriptProvider.)
Public property | AssemblyPath | Gets or sets script assembly file path. (Inherited from RoslynScriptProvider.)
Public property | AssemblyTargetPath | Represents the fully qualified path of the assembly file. (Inherited from RoslynScriptProvider.)
Public property | Compilation | Gets a current project or code Microsoft.CodeAnalysis.Compilation. (Inherited from RoslynScriptProvider.)
Public property | EmbeddedResources | List of the compilation's managed resources. Null to indicate that there are none. (Inherited from RoslynScriptProvider.)
Public property | PDBTargetPath | Represents the .pdb file path. (Inherited from RoslynScriptProvider.)
Public property | ScriptAssembly | Gets compiled script assembly. (Inherited from RoslynScriptProvider.)
Public property | ScriptCompiled | Indicates whether script has been successfully compiled. (Inherited from RoslynScriptProvider.)
Public property | Workspace | Gets a current project or code Microsoft.CodeAnalysis.Workspace. (Inherited from RoslynScriptProvider.)
Top
See Also

Reference

CSharpScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynDocumentationProvider Class

RoslynDocumentationProvider Class
Provide XML documentation to the compiler for members from metadata.
Inheritance Hierarchy
SystemObject
DocumentationProvider
Alternet.Scripter.RoslynRoslynDocumentationProvider

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoslynDocumentationProvider : DocumentationProvider
Public Class RoslynDocumentationProvider
    Inherits DocumentationProvider
public ref class RoslynDocumentationProvider : public DocumentationProvider
type RoslynDocumentationProvider =
    class
        inherit DocumentationProvider
    end

The RoslynDocumentationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | RoslynDocumentationProvider | Initializes a new instance of the RoslynDocumentationProvider class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Overrides DocumentationProvider.Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides DocumentationProvider.GetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyName | Gets an assembly name.
Public property | FullPath | Gets a full documentation path.
Public property | SystemPath | Gets a system path.
Top
See Also

Reference

Alternet.Scripter.Roslyn Namespace


RoslynDocumentationProvider Constructor

RoslynDocumentationProvider Constructor
Initializes a new instance of the RoslynDocumentationProvider class with specified settings.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynDocumentationProvider(
    string systemPath,
    string fullPath,
    string assemblyName
)
Public Sub New (
    systemPath As String,
    fullPath As String,
    assemblyName As String
)
public:
RoslynDocumentationProvider(
    String^ systemPath,
    String^ fullPath,
    String^ assemblyName
)
new :
        systemPath : string *
        fullPath : string *
        assemblyName : string -> RoslynDocumentationProvider

Parameters

systemPath
Type: SystemString
Path to the system folder.
fullPath
Type: SystemString
Full documentation path.
assemblyName
Type: SystemString
Assembly name.
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynDocumentationProvider Methods

RoslynDocumentationProvider Methods

The RoslynDocumentationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Overrides DocumentationProvider.Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides DocumentationProvider.GetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynDocumentationProvider.Equals Method

RoslynDocumentationProviderEquals Method
Determines whether the specified object is equal to the current object.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynDocumentationProvider.GetHashCode Method

RoslynDocumentationProviderGetHashCode Method
Serves as a hash function for a particular type.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynDocumentationProvider Properties

RoslynDocumentationProvider Properties

The RoslynDocumentationProvider type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an assembly name.
Public property | FullPath | Gets a full documentation path.
Public property | SystemPath | Gets a system path.
Top
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynDocumentationProvider.AssemblyName Property

RoslynDocumentationProviderAssemblyName Property
Gets an assembly name.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyName { get; }
Public ReadOnly Property AssemblyName As String
    Get
public:
property String^ AssemblyName {
    String^ get ();
}
member AssemblyName : string with get

Property Value

Type: String
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynDocumentationProvider.FullPath Property

RoslynDocumentationProviderFullPath Property
Gets a full documentation path.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get
public:
property String^ FullPath {
    String^ get ();
}
member FullPath : string with get

Property Value

Type: String
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynDocumentationProvider.SystemPath Property

RoslynDocumentationProviderSystemPath Property
Gets a system path.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemPath { get; }
Public ReadOnly Property SystemPath As String
    Get
public:
property String^ SystemPath {
    String^ get ();
}
member SystemPath : string with get

Property Value

Type: String
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost Class

RoslynScriptHost Class
Provides methods and properties to support a Roslyn-based script host.
Inheritance Hierarchy
SystemObject
Alternet.ScripterScriptHost
Alternet.Scripter.RoslynRoslynScriptHost

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoslynScriptHost : ScriptHost
Public Class RoslynScriptHost
    Inherits ScriptHost
public ref class RoslynScriptHost : public ScriptHost
type RoslynScriptHost =
    class
        inherit ScriptHost
    end

The RoslynScriptHost type exposes the following members.

Constructors
 | Name | Description
Public method | RoslynScriptHost | Initializes a new instance of the CodeDomScriptHost class with specified script runner.
Top
Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script. (Overrides ScriptHostCompile(Boolean).)
Public method | CopyReferencedAssemblies | Copies all non-GAC assemblies referenced by a script to the output directories. (Inherited from ScriptHost.)
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it. (Inherited from ScriptHost.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression. (Inherited from ScriptHost.)
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously. (Inherited from ScriptHost.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime | (Overrides ScriptHostReferencesDotNetCoreRuntime(Version).)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers. (Overrides ScriptHostReset.)
Public method | ResolveReferences | Returns list of assembly references used by the script. (Inherited from ScriptHost.)
Public method | ResolveReferences(IListString) | Returns list of assembly references used by the script. (Inherited from ScriptHost.)
Public method | Run | Executes script starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunAsync | Executes script asynchronously starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunMethod | Executes specified method. (Inherited from ScriptHost.)
Public method | RunMethodAsync | Executes specified method asynchronously. (Inherited from ScriptHost.)
Public method | RunProcess | Executes script starting from the main entry point in standalone process. (Inherited from ScriptHost.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyFileName | Gets script assembly file name. (Inherited from ScriptHost.)
Public property | Compilation | Gets a current project Microsoft.CodeAnalysis.Compilation.
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed. (Overrides ScriptHostCompiled.)
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation. (Inherited from ScriptHost.)
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed. (Inherited from ScriptHost.)
Public property | ExecutableModulePath | Gets script assembly path. (Inherited from ScriptHost.)
Public property | GenerateModulesOnDisk | Gets or sets value indicating whether script assembly should be written to the disk or kept in memory. (Inherited from ScriptHost.)
Public property | GlobalCode | Gets a global code required for global items. (Inherited from ScriptHost.)
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies. (Inherited from ScriptHost.)
Public property | ReuseCompiledModulesFromDisk | Gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date. (Inherited from ScriptHost.)
Public property | ScriptAssembly | Returns compiled script assembly. (Overrides ScriptHostScriptAssembly.)
Public property | ScriptRun | Gets IScriptRun associated this script host. (Inherited from ScriptHost.)
Public property | Workspace | Gets a current project Microsoft.CodeAnalysis.Workspace.
Top
See Also

Reference

Alternet.Scripter.Roslyn Namespace


RoslynScriptHost Constructor

RoslynScriptHost Constructor
Initializes a new instance of the CodeDomScriptHost class with specified script runner.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynScriptHost(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
RoslynScriptHost(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> RoslynScriptHost

Parameters

scriptRun
Type: Alternet.ScripterIScriptRun
Specifies object that implements IScriptRun interface for this new instance.
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost Methods

RoslynScriptHost Methods

The RoslynScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script. (Overrides ScriptHostCompile(Boolean).)
Public method | CopyReferencedAssemblies | Copies all non-GAC assemblies referenced by a script to the output directories. (Inherited from ScriptHost.)
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it. (Inherited from ScriptHost.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression. (Inherited from ScriptHost.)
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously. (Inherited from ScriptHost.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime | (Overrides ScriptHostReferencesDotNetCoreRuntime(Version).)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers. (Overrides ScriptHostReset.)
Public method | ResolveReferences | Returns list of assembly references used by the script. (Inherited from ScriptHost.)
Public method | ResolveReferences(IListString) | Returns list of assembly references used by the script. (Inherited from ScriptHost.)
Public method | Run | Executes script starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunAsync | Executes script asynchronously starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunMethod | Executes specified method. (Inherited from ScriptHost.)
Public method | RunMethodAsync | Executes specified method asynchronously. (Inherited from ScriptHost.)
Public method | RunProcess | Executes script starting from the main entry point in standalone process. (Inherited from ScriptHost.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost.Compile Method

RoslynScriptHostCompile Method
Initializes script engine and compiles the script.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Compile(
    bool copyReferences = true
)
Public Overrides Function Compile (
    Optional copyReferences As Boolean = true
) As Boolean
public:
virtual bool Compile(
    bool copyReferences = true
) override
abstract Compile :
        ?copyReferences : bool
(* Defaults:
        let _copyReferences = defaultArg copyReferences true
*)
-> bool
override Compile :
        ?copyReferences : bool
(* Defaults:
        let _copyReferences = defaultArg copyReferences true
*)
-> bool

Parameters

copyReferences (Optional)
Type: SystemBoolean
Specifies if all required assemblies should be copied to the output location

Return Value

Type: Boolean
True if succeed, otherwise false.

Implements

IScriptHostCompile(Boolean)
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost.ReferencesDotNetCoreRuntime Method

RoslynScriptHostReferencesDotNetCoreRuntime Method

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReferencesDotNetCoreRuntime(
    out Version dotNetCoreVersion
)
Public Overrides Function ReferencesDotNetCoreRuntime (
    <OutAttribute> ByRef dotNetCoreVersion As Version
) As Boolean
public:
virtual bool ReferencesDotNetCoreRuntime(
    [OutAttribute] Version^% dotNetCoreVersion
) override
abstract ReferencesDotNetCoreRuntime :
        dotNetCoreVersion : Version byref -> bool
override ReferencesDotNetCoreRuntime :
        dotNetCoreVersion : Version byref -> bool

Parameters

dotNetCoreVersion
Type: SystemVersion

Return Value

Type: Boolean

Implements

IScriptHostReferencesDotNetCoreRuntime(Version)
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost.Reset Method

RoslynScriptHostReset Method
Removes the script engine from the running state and disconnects automatically bound event handlers.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptHostReset
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost Properties

RoslynScriptHost Properties

The RoslynScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyFileName | Gets script assembly file name. (Inherited from ScriptHost.)
Public property | Compilation | Gets a current project Microsoft.CodeAnalysis.Compilation.
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed. (Overrides ScriptHostCompiled.)
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation. (Inherited from ScriptHost.)
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed. (Inherited from ScriptHost.)
Public property | ExecutableModulePath | Gets script assembly path. (Inherited from ScriptHost.)
Public property | GenerateModulesOnDisk | Gets or sets value indicating whether script assembly should be written to the disk or kept in memory. (Inherited from ScriptHost.)
Public property | GlobalCode | Gets a global code required for global items. (Inherited from ScriptHost.)
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies. (Inherited from ScriptHost.)
Public property | ReuseCompiledModulesFromDisk | Gets or sets boolean value indicating whether to attempt to reuse existing compile results from disk, if up-to-date. (Inherited from ScriptHost.)
Public property | ScriptAssembly | Returns compiled script assembly. (Overrides ScriptHostScriptAssembly.)
Public property | ScriptRun | Gets IScriptRun associated this script host. (Inherited from ScriptHost.)
Public property | Workspace | Gets a current project Microsoft.CodeAnalysis.Workspace.
Top
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost.Compilation Property

RoslynScriptHostCompilation Property
Gets a current project Microsoft.CodeAnalysis.Compilation.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Compilation Compilation { get; }
Public ReadOnly Property Compilation As Compilation
    Get
public:
property Compilation^ Compilation {
    Compilation^ get ();
}
member Compilation : Compilation with get

Property Value

Type: Compilation
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost.Compiled Property

RoslynScriptHostCompiled Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Compiled { get; }
Public Overrides ReadOnly Property Compiled As Boolean
    Get
public:
virtual property bool Compiled {
    bool get () override;
}
abstract Compiled : bool with get
override Compiled : bool with get

Property Value

Type: Boolean

Implements

IScriptHostCompiled
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost.ScriptAssembly Property

RoslynScriptHostScriptAssembly Property
Returns compiled script assembly.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Assembly ScriptAssembly { get; }
Public Overrides ReadOnly Property ScriptAssembly As Assembly
    Get
public:
virtual property Assembly^ ScriptAssembly {
    Assembly^ get () override;
}
abstract ScriptAssembly : Assembly with get
override ScriptAssembly : Assembly with get

Property Value

Type: Assembly

Implements

IScriptHostScriptAssembly
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptHost.Workspace Property

RoslynScriptHostWorkspace Property
Gets a current project Microsoft.CodeAnalysis.Workspace.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Workspace Workspace { get; }
Public ReadOnly Property Workspace As Workspace
    Get
public:
property Workspace^ Workspace {
    Workspace^ get ();
}
member Workspace : Workspace with get

Property Value

Type: Workspace
See Also

Reference

RoslynScriptHost Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider Class

RoslynScriptProvider Class
Provides a base class for Roslyn code generation. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.RoslynRoslynScriptProvider
Alternet.Scripter.RoslynCSharpScriptProvider
Alternet.Scripter.RoslynVisualBasicScriptProvider

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class RoslynScriptProvider : IDisposable
Public MustInherit Class RoslynScriptProvider
    Implements IDisposable
public ref class RoslynScriptProvider abstract : IDisposable
[<AbstractClassAttribute>]
type RoslynScriptProvider =
    class
        interface IDisposable
    end

The RoslynScriptProvider type exposes the following members.

Constructors
 | Name | Description
Public method | RoslynScriptProvider | Initializes a new instance of the RoslynScriptProvider class with specified IScriptHost.
Top
Methods
 | Name | Description
Public method | Compile | Compiles the script.
Public method | Dispose | Destroys the instance of the RoslynScriptProvider class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyFileName | Gets or sets script assembly file name.
Public property | AssemblyPath | Gets or sets script assembly file path.
Public property | AssemblyTargetPath | Represents the fully qualified path of the assembly file.
Public property | Compilation | Gets a current project or code Microsoft.CodeAnalysis.Compilation.
Public property | EmbeddedResources | List of the compilation's managed resources. Null to indicate that there are none.
Public property | PDBTargetPath | Represents the .pdb file path.
Public property | ScriptAssembly | Gets compiled script assembly.
Public property | ScriptCompiled | Indicates whether script has been successfully compiled.
Public property | Workspace | Gets a current project or code Microsoft.CodeAnalysis.Workspace.
Top
See Also

Reference

Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider Constructor

RoslynScriptProvider Constructor
Initializes a new instance of the RoslynScriptProvider class with specified IScriptHost.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynScriptProvider(
    IScriptHost scriptHost,
    SourceCodeKind sourceKind = SourceCodeKind.Regular
)
Public Sub New (
    scriptHost As IScriptHost,
    Optional sourceKind As SourceCodeKind = SourceCodeKind.Regular
)
public:
RoslynScriptProvider(
    IScriptHost^ scriptHost,
    SourceCodeKind sourceKind = SourceCodeKind::Regular
)
new :
        scriptHost : IScriptHost *
        ?sourceKind : SourceCodeKind
(* Defaults:
        let _sourceKind = defaultArg sourceKind SourceCodeKind.Regular
*)
-> RoslynScriptProvider

Parameters

scriptHost
Type: Alternet.ScripterIScriptHost
IScriptHost holds script engine functionality.
sourceKind (Optional)
Type: SourceCodeKind
Specifies regular or Script source kind
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider Methods

RoslynScriptProvider Methods

The RoslynScriptProvider type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the script.
Public method | Dispose | Destroys the instance of the RoslynScriptProvider class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.Compile Method

RoslynScriptProviderCompile Method
Compiles the script.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynScriptProviderCompileResult Compile()
Public Function Compile As RoslynScriptProviderCompileResult
public:
RoslynScriptProviderCompileResult Compile()
member Compile : unit -> RoslynScriptProviderCompileResult

Return Value

Type: RoslynScriptProviderCompileResult
result of compilation.
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.Dispose Method

RoslynScriptProviderDispose Method
Destroys the instance of the RoslynScriptProvider class.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.ReferencesDotNetCoreRuntime Method

RoslynScriptProviderReferencesDotNetCoreRuntime Method

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReferencesDotNetCoreRuntime(
    out Version dotNetCoreVersion
)
Public Function ReferencesDotNetCoreRuntime (
    <OutAttribute> ByRef dotNetCoreVersion As Version
) As Boolean
public:
bool ReferencesDotNetCoreRuntime(
    [OutAttribute] Version^% dotNetCoreVersion
)
member ReferencesDotNetCoreRuntime :
        dotNetCoreVersion : Version byref -> bool

Parameters

dotNetCoreVersion
Type: SystemVersion

Return Value

Type: Boolean
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider Properties

RoslynScriptProvider Properties

The RoslynScriptProvider type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyFileName | Gets or sets script assembly file name.
Public property | AssemblyPath | Gets or sets script assembly file path.
Public property | AssemblyTargetPath | Represents the fully qualified path of the assembly file.
Public property | Compilation | Gets a current project or code Microsoft.CodeAnalysis.Compilation.
Public property | EmbeddedResources | List of the compilation's managed resources. Null to indicate that there are none.
Public property | PDBTargetPath | Represents the .pdb file path.
Public property | ScriptAssembly | Gets compiled script assembly.
Public property | ScriptCompiled | Indicates whether script has been successfully compiled.
Public property | Workspace | Gets a current project or code Microsoft.CodeAnalysis.Workspace.
Top
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.AssemblyFileName Property

RoslynScriptProviderAssemblyFileName Property
Gets or sets script assembly file name.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyFileName { get; set; }
Public Property AssemblyFileName As String
    Get
    Set
public:
property String^ AssemblyFileName {
    String^ get ();
    void set (String^ value);
}
member AssemblyFileName : string with get, set

Property Value

Type: String
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.AssemblyPath Property

RoslynScriptProviderAssemblyPath Property
Gets or sets script assembly file path.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyPath { get; set; }
Public Property AssemblyPath As String
    Get
    Set
public:
property String^ AssemblyPath {
    String^ get ();
    void set (String^ value);
}
member AssemblyPath : string with get, set

Property Value

Type: String
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.AssemblyTargetPath Property

RoslynScriptProviderAssemblyTargetPath Property
Represents the fully qualified path of the assembly file.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyTargetPath { get; }
Public ReadOnly Property AssemblyTargetPath As String
    Get
public:
property String^ AssemblyTargetPath {
    String^ get ();
}
member AssemblyTargetPath : string with get

Property Value

Type: String
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.Compilation Property

RoslynScriptProviderCompilation Property
Gets a current project or code Microsoft.CodeAnalysis.Compilation.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Compilation Compilation { get; }
Public ReadOnly Property Compilation As Compilation
    Get
public:
property Compilation^ Compilation {
    Compilation^ get ();
}
member Compilation : Compilation with get

Property Value

Type: Compilation
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.EmbeddedResources Property

RoslynScriptProviderEmbeddedResources Property
List of the compilation's managed resources. Null to indicate that there are none.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ResourceDescription> EmbeddedResources { get; }
Public ReadOnly Property EmbeddedResources As IList(Of ResourceDescription)
    Get
public:
property IList<ResourceDescription^>^ EmbeddedResources {
    IList<ResourceDescription^>^ get ();
}
member EmbeddedResources : IList<ResourceDescription> with get

Property Value

Type: IListResourceDescription
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.PDBTargetPath Property

RoslynScriptProviderPDBTargetPath Property
Represents the .pdb file path.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PDBTargetPath { get; }
Public ReadOnly Property PDBTargetPath As String
    Get
public:
property String^ PDBTargetPath {
    String^ get ();
}
member PDBTargetPath : string with get

Property Value

Type: String
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.ScriptAssembly Property

RoslynScriptProviderScriptAssembly Property
Gets compiled script assembly.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Assembly ScriptAssembly { get; }
Public ReadOnly Property ScriptAssembly As Assembly
    Get
public:
property Assembly^ ScriptAssembly {
    Assembly^ get ();
}
member ScriptAssembly : Assembly with get

Property Value

Type: Assembly
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.ScriptCompiled Property

RoslynScriptProviderScriptCompiled Property
Indicates whether script has been successfully compiled.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ScriptCompiled { get; }
Public ReadOnly Property ScriptCompiled As Boolean
    Get
public:
property bool ScriptCompiled {
    bool get ();
}
member ScriptCompiled : bool with get

Property Value

Type: Boolean
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.Workspace Property

RoslynScriptProviderWorkspace Property
Gets a current project or code Microsoft.CodeAnalysis.Workspace.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Workspace Workspace { get; }
Public ReadOnly Property Workspace As Workspace
    Get
public:
property Workspace^ Workspace {
    Workspace^ get ();
}
member Workspace : Workspace with get

Property Value

Type: Workspace
See Also

Reference

RoslynScriptProvider Class
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.CompileResult Structure

RoslynScriptProviderCompileResult Structure
Represent structured information of code compilation result.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct CompileResult
Public Structure CompileResult
public value class CompileResult
[<SealedAttribute>]
type CompileResult =  struct end

The RoslynScriptProviderCompileResult type exposes the following members.

Constructors
 | Name | Description
Public method | RoslynScriptProviderCompileResult(Exception) | Initializes a new instance of the CompileResult class with specified parameters.
Public method | RoslynScriptProviderCompileResult(Boolean, ImmutableArrayDiagnostic) | Initializes a new instance of the CompileResult class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Diagnostics | Represents List of Microsoft.CodeAnalysis.Diagnostic compilation.
Public field | Exception | Represents an Exception occurred during compilation. Null if compilation succeed.
Public field | Success | Represents a boolean value indicating whether compilation succeed.
Top
See Also

Reference

Alternet.Scripter.Roslyn Namespace


CompileResult Constructor

CompileResult Constructor
Overload List
 | Name | Description
Public method | RoslynScriptProviderCompileResult(Exception) | Initializes a new instance of the CompileResult class with specified parameters.
Public method | RoslynScriptProviderCompileResult(Boolean, ImmutableArrayDiagnostic) | Initializes a new instance of the CompileResult class with specified parameters.
Top
See Also

Reference

RoslynScriptProviderCompileResult Structure
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.CompileResult Constructor (Exception)

RoslynScriptProviderCompileResult Constructor (Exception)
Initializes a new instance of the CompileResult class with specified parameters.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompileResult(
    Exception exception
)
Public Sub New (
    exception As Exception
)
public:
CompileResult(
    Exception^ exception
)
new :
        exception : Exception -> CompileResult

Parameters

exception
Type: SystemException
Specifies an Exception occurred during compilation.
See Also

Reference

RoslynScriptProviderCompileResult Structure
RoslynScriptProviderCompileResult Overload
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.CompileResult Constructor (Boolean, ImmutableArray`1(Diagnostic))

RoslynScriptProviderCompileResult Constructor (Boolean, ImmutableArray`1Diagnostic)
Initializes a new instance of the CompileResult class with specified parameters.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompileResult(
    bool success,
    ImmutableArray<Diagnostic> diagnostics
)
Public Sub New (
    success As Boolean,
    diagnostics As ImmutableArray(Of Diagnostic)
)
public:
CompileResult(
    bool success,
    ImmutableArray<Diagnostic^> diagnostics
)
new :
        success : bool *
        diagnostics : ImmutableArray<Diagnostic> -> CompileResult

Parameters

success
Type: SystemBoolean
Indicates whether compilation succeed.
diagnostics
Type: ImmutableArrayDiagnostic
Specifies List of compilation Microsoft.CodeAnalysis.Diagnostic
See Also

Reference

RoslynScriptProviderCompileResult Structure
RoslynScriptProviderCompileResult Overload
Alternet.Scripter.Roslyn Namespace


CompileResult Fields

CompileResult Fields

The RoslynScriptProviderCompileResult type exposes the following members.

Fields
 | Name | Description
Public field | Diagnostics | Represents List of Microsoft.CodeAnalysis.Diagnostic compilation.
Public field | Exception | Represents an Exception occurred during compilation. Null if compilation succeed.
Public field | Success | Represents a boolean value indicating whether compilation succeed.
Top
See Also

Reference

RoslynScriptProviderCompileResult Structure
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.CompileResult.Diagnostics Field

RoslynScriptProviderCompileResultDiagnostics Field
Represents List of Microsoft.CodeAnalysis.Diagnostic compilation.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImmutableArray<Diagnostic> Diagnostics
Public Diagnostics As ImmutableArray(Of Diagnostic)
public:
ImmutableArray<Diagnostic^> Diagnostics
val mutable Diagnostics: ImmutableArray<Diagnostic>

Field Value

Type: ImmutableArrayDiagnostic
See Also

Reference

RoslynScriptProviderCompileResult Structure
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.CompileResult.Exception Field

RoslynScriptProviderCompileResultException Field
Represents an Exception occurred during compilation. Null if compilation succeed.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Exception Exception
Public Exception As Exception
public:
Exception^ Exception
val mutable Exception: Exception

Field Value

Type: Exception
See Also

Reference

RoslynScriptProviderCompileResult Structure
Alternet.Scripter.Roslyn Namespace


RoslynScriptProvider.CompileResult.Success Field

RoslynScriptProviderCompileResultSuccess Field
Represents a boolean value indicating whether compilation succeed.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Success
Public Success As Boolean
public:
bool Success
val mutable Success: bool

Field Value

Type: Boolean
See Also

Reference

RoslynScriptProviderCompileResult Structure
Alternet.Scripter.Roslyn Namespace


CompileResult Methods

CompileResult Methods

The RoslynScriptProviderCompileResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

RoslynScriptProviderCompileResult Structure
Alternet.Scripter.Roslyn Namespace


VisualBasicScriptProvider Class

VisualBasicScriptProvider Class
Provides code generation for VisualBasic.NET based on Microsoft Roslyn.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.RoslynRoslynScriptProvider
Alternet.Scripter.RoslynVisualBasicScriptProvider

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VisualBasicScriptProvider : RoslynScriptProvider
Public Class VisualBasicScriptProvider
    Inherits RoslynScriptProvider
public ref class VisualBasicScriptProvider : public RoslynScriptProvider
type VisualBasicScriptProvider =
    class
        inherit RoslynScriptProvider
    end

The VisualBasicScriptProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VisualBasicScriptProvider | Initializes a new instance of the VisualBasicScriptProvider class with specified IScriptHost.
Top
Methods
 | Name | Description
Public method | Compile | Compiles the script. (Inherited from RoslynScriptProvider.)
Public method | Dispose | Destroys the instance of the RoslynScriptProvider class. (Inherited from RoslynScriptProvider.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GenerateGlobalItems | Generates code from given global items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime | (Inherited from RoslynScriptProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyFileName | Gets or sets script assembly file name. (Inherited from RoslynScriptProvider.)
Public property | AssemblyPath | Gets or sets script assembly file path. (Inherited from RoslynScriptProvider.)
Public property | AssemblyTargetPath | Represents the fully qualified path of the assembly file. (Inherited from RoslynScriptProvider.)
Public property | Compilation | Gets a current project or code Microsoft.CodeAnalysis.Compilation. (Inherited from RoslynScriptProvider.)
Public property | EmbeddedResources | List of the compilation's managed resources. Null to indicate that there are none. (Inherited from RoslynScriptProvider.)
Public property | PDBTargetPath | Represents the .pdb file path. (Inherited from RoslynScriptProvider.)
Public property | ScriptAssembly | Gets compiled script assembly. (Inherited from RoslynScriptProvider.)
Public property | ScriptCompiled | Indicates whether script has been successfully compiled. (Inherited from RoslynScriptProvider.)
Public property | Workspace | Gets a current project or code Microsoft.CodeAnalysis.Workspace. (Inherited from RoslynScriptProvider.)
Top
See Also

Reference

Alternet.Scripter.Roslyn Namespace


VisualBasicScriptProvider Constructor

VisualBasicScriptProvider Constructor
Initializes a new instance of the VisualBasicScriptProvider class with specified IScriptHost.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisualBasicScriptProvider(
    IScriptHost host,
    SourceCodeKind sourceKind = SourceCodeKind.Regular
)
Public Sub New (
    host As IScriptHost,
    Optional sourceKind As SourceCodeKind = SourceCodeKind.Regular
)
public:
VisualBasicScriptProvider(
    IScriptHost^ host,
    SourceCodeKind sourceKind = SourceCodeKind::Regular
)
new :
        host : IScriptHost *
        ?sourceKind : SourceCodeKind
(* Defaults:
        let _sourceKind = defaultArg sourceKind SourceCodeKind.Regular
*)
-> VisualBasicScriptProvider

Parameters

host
Type: Alternet.ScripterIScriptHost
IScriptHost holds script engine functionality.
sourceKind (Optional)
Type: SourceCodeKind
Specifies regular or Script source kind
See Also

Reference

VisualBasicScriptProvider Class
Alternet.Scripter.Roslyn Namespace


VisualBasicScriptProvider Methods

VisualBasicScriptProvider Methods

The VisualBasicScriptProvider type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the script. (Inherited from RoslynScriptProvider.)
Public method | Dispose | Destroys the instance of the RoslynScriptProvider class. (Inherited from RoslynScriptProvider.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GenerateGlobalItems | Generates code from given global items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReferencesDotNetCoreRuntime | (Inherited from RoslynScriptProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VisualBasicScriptProvider Class
Alternet.Scripter.Roslyn Namespace


VisualBasicScriptProvider.GenerateGlobalItems Method

VisualBasicScriptProviderGenerateGlobalItems Method
Generates code from given global items.

Namespace: Alternet.Scripter.Roslyn
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GenerateGlobalItems(
    IList<IScriptGlobalItem> globalItems
)
Public Shared Function GenerateGlobalItems (
    globalItems As IList(Of IScriptGlobalItem)
) As String
public:
static String^ GenerateGlobalItems(
    IList<IScriptGlobalItem^>^ globalItems
)
static member GenerateGlobalItems :
        globalItems : IList<IScriptGlobalItem> -> string

Parameters

globalItems
Type: System.Collections.GenericIListIScriptGlobalItem
Collection of global items.

Return Value

Type: String
Code contains declaration of global items.
See Also

Reference

VisualBasicScriptProvider Class
Alternet.Scripter.Roslyn Namespace


VisualBasicScriptProvider Properties

VisualBasicScriptProvider Properties

The VisualBasicScriptProvider type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyFileName | Gets or sets script assembly file name. (Inherited from RoslynScriptProvider.)
Public property | AssemblyPath | Gets or sets script assembly file path. (Inherited from RoslynScriptProvider.)
Public property | AssemblyTargetPath | Represents the fully qualified path of the assembly file. (Inherited from RoslynScriptProvider.)
Public property | Compilation | Gets a current project or code Microsoft.CodeAnalysis.Compilation. (Inherited from RoslynScriptProvider.)
Public property | EmbeddedResources | List of the compilation's managed resources. Null to indicate that there are none. (Inherited from RoslynScriptProvider.)
Public property | PDBTargetPath | Represents the .pdb file path. (Inherited from RoslynScriptProvider.)
Public property | ScriptAssembly | Gets compiled script assembly. (Inherited from RoslynScriptProvider.)
Public property | ScriptCompiled | Indicates whether script has been successfully compiled. (Inherited from RoslynScriptProvider.)
Public property | Workspace | Gets a current project or code Microsoft.CodeAnalysis.Workspace. (Inherited from RoslynScriptProvider.)
Top
See Also

Reference

VisualBasicScriptProvider Class
Alternet.Scripter.Roslyn Namespace


Alternet.Scripter.TypeScript Namespace

Alternet.Scripter.TypeScript Namespace
Classes
 | Class | Description
Public class | ClearScriptScriptHost | Provides properties and methods to support script engine functionality based on System.CodeDom.Compiler technology.
Public class | CompiledFile | Represents a particular compiled script file.
Public class | FileRunnableScript | Represents compiled script assembly stored in the file system.
Public class | InMemoryRunnableScript | Represents compiled script assembly stored in memory.
Public class | RunnableScript | A base class represents compiled script assembly. This class is abstract.
Public class | ScriptConsts | Contains constants related to Scripter component.
Public class | ScriptHost | Provides a base class for script execution. This class is abstract.
Public class | ScriptRun | Represents runner for script engine.
Public class | ScriptSource | Provides methods and properties to work with script text, files or projects.
Interfaces
 | Interface | Description
Public interface | IScriptHost | Represents methods and properties declaration to support a script engine functionality.
Public interface | IScriptRun | Represents methods and properties declaration to describe runner for script engine.
Public interface | IScriptSource | Represents methods and properties to work with script text, files or projects.
Enumerations
 | Enumeration | Description
Public enumeration | ScriptLanguage | Defines programming language used by the script engine.


ClearScriptScriptHost Class

ClearScriptScriptHost Class
Provides properties and methods to support script engine functionality based on System.CodeDom.Compiler technology.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.TypeScriptScriptHost
Alternet.Scripter.TypeScriptClearScriptScriptHost

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ClearScriptScriptHost : ScriptHost
Public Class ClearScriptScriptHost
    Inherits ScriptHost
public ref class ClearScriptScriptHost : public ScriptHost
type ClearScriptScriptHost =
    class
        inherit ScriptHost
    end

The ClearScriptScriptHost type exposes the following members.

Constructors
 | Name | Description
Public method | ClearScriptScriptHost | Initializes a new instance of the CodeDomScriptHost class with specified script runner.
Top
Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script. (Overrides ScriptHostCompile.)
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it. (Inherited from ScriptHost.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression. (Inherited from ScriptHost.)
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously. (Inherited from ScriptHost.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Interrupt | Interrupts script execution and causes the script engine to throw an exception.
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers. (Overrides ScriptHostReset.)
Public method | Run | Executes script starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunAsync | Executes script asynchronously starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunFunction | Executes specified function. (Inherited from ScriptHost.)
Public method | RunFunctionAsync | Executes specified function asynchronously. (Inherited from ScriptHost.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed. (Overrides ScriptHostCompiled.)
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation. (Inherited from ScriptHost.)
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed. (Inherited from ScriptHost.)
Public property | HostItemsConfiguration | Gets script host configuration. (Inherited from ScriptHost.)
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies. (Inherited from ScriptHost.)
Public property | NeedToRecreateEngine | Gets or sets a boolean value indicates whether Engine need to be recreated.
Public property | OutputFileName | Gets script assembly file name. (Inherited from ScriptHost.)
Public property | RunnableScript | Returns compiled script assembly. (Overrides ScriptHostRunnableScript.)
Public property | Script |
Public property | ScriptCompiled | Indicates whether script has been successfully compiled.
Public property | ScriptRun | Gets IScriptRun associated this script host. (Inherited from ScriptHost.)
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost Constructor

ClearScriptScriptHost Constructor
Initializes a new instance of the CodeDomScriptHost class with specified script runner.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClearScriptScriptHost(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
ClearScriptScriptHost(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> ClearScriptScriptHost

Parameters

scriptRun
Type: Alternet.Scripter.TypeScriptIScriptRun
Specifies object that implements IScriptRun interface for this new instance.
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost Methods

ClearScriptScriptHost Methods

The ClearScriptScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script. (Overrides ScriptHostCompile.)
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it. (Inherited from ScriptHost.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression. (Inherited from ScriptHost.)
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously. (Inherited from ScriptHost.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Interrupt | Interrupts script execution and causes the script engine to throw an exception.
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers. (Overrides ScriptHostReset.)
Public method | Run | Executes script starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunAsync | Executes script asynchronously starting from the main entry point. (Inherited from ScriptHost.)
Public method | RunFunction | Executes specified function. (Inherited from ScriptHost.)
Public method | RunFunctionAsync | Executes specified function asynchronously. (Inherited from ScriptHost.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost.Compile Method

ClearScriptScriptHostCompile Method
Initializes script engine and compiles the script.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Compile()
Public Overrides Function Compile As Boolean
public:
virtual bool Compile() override
abstract Compile : unit -> bool
override Compile : unit -> bool

Return Value

Type: Boolean
True if succeed, otherwise false.

Implements

IScriptHostCompile
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost.Interrupt Method

ClearScriptScriptHostInterrupt Method
Interrupts script execution and causes the script engine to throw an exception.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Interrupt()
Public Sub Interrupt
public:
void Interrupt()
member Interrupt : unit -> unit
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost.Reset Method

ClearScriptScriptHostReset Method
Removes the script engine from the running state and disconnects automatically bound event handlers.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptHostReset
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost Properties

ClearScriptScriptHost Properties

The ClearScriptScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed. (Overrides ScriptHostCompiled.)
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation. (Inherited from ScriptHost.)
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed. (Inherited from ScriptHost.)
Public property | HostItemsConfiguration | Gets script host configuration. (Inherited from ScriptHost.)
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies. (Inherited from ScriptHost.)
Public property | NeedToRecreateEngine | Gets or sets a boolean value indicates whether Engine need to be recreated.
Public property | OutputFileName | Gets script assembly file name. (Inherited from ScriptHost.)
Public property | RunnableScript | Returns compiled script assembly. (Overrides ScriptHostRunnableScript.)
Public property | Script |
Public property | ScriptCompiled | Indicates whether script has been successfully compiled.
Public property | ScriptRun | Gets IScriptRun associated this script host. (Inherited from ScriptHost.)
Top
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost.Compiled Property

ClearScriptScriptHostCompiled Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Compiled { get; }
Public Overrides ReadOnly Property Compiled As Boolean
    Get
public:
virtual property bool Compiled {
    bool get () override;
}
abstract Compiled : bool with get
override Compiled : bool with get

Property Value

Type: Boolean

Implements

IScriptHostCompiled
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost.NeedToRecreateEngine Property

ClearScriptScriptHostNeedToRecreateEngine Property
Gets or sets a boolean value indicates whether Engine need to be recreated.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedToRecreateEngine { get; set; }
Public Property NeedToRecreateEngine As Boolean
    Get
    Set
public:
property bool NeedToRecreateEngine {
    bool get ();
    void set (bool value);
}
member NeedToRecreateEngine : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost.RunnableScript Property

ClearScriptScriptHostRunnableScript Property
Returns compiled script assembly.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override RunnableScript RunnableScript { get; }
Public Overrides ReadOnly Property RunnableScript As RunnableScript
    Get
public:
virtual property RunnableScript^ RunnableScript {
    RunnableScript^ get () override;
}
abstract RunnableScript : RunnableScript with get
override RunnableScript : RunnableScript with get

Property Value

Type: RunnableScript

Implements

IScriptHostRunnableScript
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost.Script Property

ClearScriptScriptHostScript Property

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Script { get; }
Public ReadOnly Property Script As Object
    Get
public:
property Object^ Script {
    Object^ get ();
}
member Script : Object with get

Property Value

Type: Object
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


ClearScriptScriptHost.ScriptCompiled Property

ClearScriptScriptHostScriptCompiled Property
Indicates whether script has been successfully compiled.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ScriptCompiled { get; }
Public ReadOnly Property ScriptCompiled As Boolean
    Get
public:
property bool ScriptCompiled {
    bool get ();
}
member ScriptCompiled : bool with get

Property Value

Type: Boolean
See Also

Reference

ClearScriptScriptHost Class
Alternet.Scripter.TypeScript Namespace


CompiledFile Class

CompiledFile Class
Represents a particular compiled script file.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.TypeScriptCompiledFile

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CompiledFile
Public Class CompiledFile
public ref class CompiledFile
type CompiledFile =  class end

The CompiledFile type exposes the following members.

Constructors
 | Name | Description
Public method | CompiledFile | Initializes a new instance of the CompiledFile class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | InputFilePath | Gets full file name of the original script code.
Public property | OutputFilePath | Gets full file name of the generated script code.
Public property | SourceMap | Gets a SourceMap to bound original and generated code.
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


CompiledFile Constructor

CompiledFile Constructor
Initializes a new instance of the CompiledFile class with specified parameters.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompiledFile(
    string inputFilePath,
    string outputFilePath,
    SourceMap sourceMap
)
Public Sub New (
    inputFilePath As String,
    outputFilePath As String,
    sourceMap As SourceMap
)
public:
CompiledFile(
    String^ inputFilePath,
    String^ outputFilePath,
    SourceMap^ sourceMap
)
new :
        inputFilePath : string *
        outputFilePath : string *
        sourceMap : SourceMap -> CompiledFile

Parameters

inputFilePath
Type: SystemString
Full file name of the original script code.
outputFilePath
Type: SystemString
Full file name of the generated script code.
sourceMap
Type: Alternet.Scripter.TypeScript.SourceMapsSourceMap
SourceMap to bound original and generated code.
See Also

Reference

CompiledFile Class
Alternet.Scripter.TypeScript Namespace


CompiledFile Methods

CompiledFile Methods

The CompiledFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompiledFile Class
Alternet.Scripter.TypeScript Namespace


CompiledFile Properties

CompiledFile Properties

The CompiledFile type exposes the following members.

Properties
 | Name | Description
Public property | InputFilePath | Gets full file name of the original script code.
Public property | OutputFilePath | Gets full file name of the generated script code.
Public property | SourceMap | Gets a SourceMap to bound original and generated code.
Top
See Also

Reference

CompiledFile Class
Alternet.Scripter.TypeScript Namespace


CompiledFile.InputFilePath Property

CompiledFileInputFilePath Property
Gets full file name of the original script code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InputFilePath { get; }
Public ReadOnly Property InputFilePath As String
    Get
public:
property String^ InputFilePath {
    String^ get ();
}
member InputFilePath : string with get

Property Value

Type: String
See Also

Reference

CompiledFile Class
Alternet.Scripter.TypeScript Namespace


CompiledFile.OutputFilePath Property

CompiledFileOutputFilePath Property
Gets full file name of the generated script code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OutputFilePath { get; }
Public ReadOnly Property OutputFilePath As String
    Get
public:
property String^ OutputFilePath {
    String^ get ();
}
member OutputFilePath : string with get

Property Value

Type: String
See Also

Reference

CompiledFile Class
Alternet.Scripter.TypeScript Namespace


CompiledFile.SourceMap Property

CompiledFileSourceMap Property
Gets a SourceMap to bound original and generated code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SourceMap SourceMap { get; }
Public ReadOnly Property SourceMap As SourceMap
    Get
public:
property SourceMap^ SourceMap {
    SourceMap^ get ();
}
member SourceMap : SourceMap with get

Property Value

Type: SourceMap
See Also

Reference

CompiledFile Class
Alternet.Scripter.TypeScript Namespace


FileRunnableScript Class

FileRunnableScript Class
Represents compiled script assembly stored in the file system.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.TypeScriptRunnableScript
Alternet.Scripter.TypeScriptFileRunnableScript

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FileRunnableScript : RunnableScript
Public Class FileRunnableScript
    Inherits RunnableScript
public ref class FileRunnableScript : public RunnableScript
type FileRunnableScript =
    class
        inherit RunnableScript
    end

The FileRunnableScript type exposes the following members.

Constructors
 | Name | Description
Public method | FileRunnableScript | Initializes a new instance of the FileRunnableScript class with specified list of files.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Files | Gets list of compiled files.
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


FileRunnableScript Constructor

FileRunnableScript Constructor
Initializes a new instance of the FileRunnableScript class with specified list of files.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FileRunnableScript(
    IEnumerable<CompiledFile> files
)
Public Sub New (
    files As IEnumerable(Of CompiledFile)
)
public:
FileRunnableScript(
    IEnumerable<CompiledFile^>^ files
)
new :
        files : IEnumerable<CompiledFile> -> FileRunnableScript

Parameters

files
Type: System.Collections.GenericIEnumerableCompiledFile
List of files suitable for this script.
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.TypeScript Namespace


FileRunnableScript Methods

FileRunnableScript Methods

The FileRunnableScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.TypeScript Namespace


FileRunnableScript Properties

FileRunnableScript Properties

The FileRunnableScript type exposes the following members.

Properties
 | Name | Description
Public property | Files | Gets list of compiled files.
Top
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.TypeScript Namespace


FileRunnableScript.Files Property

FileRunnableScriptFiles Property
Gets list of compiled files.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection<CompiledFile> Files { get; }
Public ReadOnly Property Files As IReadOnlyCollection(Of CompiledFile)
    Get
public:
property IReadOnlyCollection<CompiledFile^>^ Files {
    IReadOnlyCollection<CompiledFile^>^ get ();
}
member Files : IReadOnlyCollection<CompiledFile> with get

Property Value

Type: IReadOnlyCollectionCompiledFile
See Also

Reference

FileRunnableScript Class
Alternet.Scripter.TypeScript Namespace


InMemoryRunnableScript Class

InMemoryRunnableScript Class
Represents compiled script assembly stored in memory.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.TypeScriptRunnableScript
Alternet.Scripter.TypeScriptInMemoryRunnableScript

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InMemoryRunnableScript : RunnableScript
Public Class InMemoryRunnableScript
    Inherits RunnableScript
public ref class InMemoryRunnableScript : public RunnableScript
type InMemoryRunnableScript =
    class
        inherit RunnableScript
    end

The InMemoryRunnableScript type exposes the following members.

Constructors
 | Name | Description
Public method | InMemoryRunnableScript | Initializes a new instance of the InMemoryRunnableScript class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ScriptCode | Gets a script code to compile.
Public property | SourceMap | Gets a SourceMap to bound original and generated code.
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


InMemoryRunnableScript Constructor

InMemoryRunnableScript Constructor
Initializes a new instance of the InMemoryRunnableScript class with specified parameters.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public InMemoryRunnableScript(
    string scriptCode,
    SourceMap sourceMap
)
Public Sub New (
    scriptCode As String,
    sourceMap As SourceMap
)
public:
InMemoryRunnableScript(
    String^ scriptCode,
    SourceMap^ sourceMap
)
new :
        scriptCode : string *
        sourceMap : SourceMap -> InMemoryRunnableScript

Parameters

scriptCode
Type: SystemString
Script code to compile.
sourceMap
Type: Alternet.Scripter.TypeScript.SourceMapsSourceMap
SourceMap for this new instance.
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.TypeScript Namespace


InMemoryRunnableScript Methods

InMemoryRunnableScript Methods

The InMemoryRunnableScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.TypeScript Namespace


InMemoryRunnableScript Properties

InMemoryRunnableScript Properties

The InMemoryRunnableScript type exposes the following members.

Properties
 | Name | Description
Public property | ScriptCode | Gets a script code to compile.
Public property | SourceMap | Gets a SourceMap to bound original and generated code.
Top
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.TypeScript Namespace


InMemoryRunnableScript.ScriptCode Property

InMemoryRunnableScriptScriptCode Property
Gets a script code to compile.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptCode { get; }
Public ReadOnly Property ScriptCode As String
    Get
public:
property String^ ScriptCode {
    String^ get ();
}
member ScriptCode : string with get

Property Value

Type: String
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.TypeScript Namespace


InMemoryRunnableScript.SourceMap Property

InMemoryRunnableScriptSourceMap Property
Gets a SourceMap to bound original and generated code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SourceMap SourceMap { get; }
Public Overridable ReadOnly Property SourceMap As SourceMap
    Get
public:
virtual property SourceMap^ SourceMap {
    SourceMap^ get ();
}
abstract SourceMap : SourceMap with get
override SourceMap : SourceMap with get

Property Value

Type: SourceMap
See Also

Reference

InMemoryRunnableScript Class
Alternet.Scripter.TypeScript Namespace


IScriptHost Interface

IScriptHost Interface
Represents methods and properties declaration to support a script engine functionality.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptHost : IDisposable
Public Interface IScriptHost
    Inherits IDisposable
public interface class IScriptHost : IDisposable
type IScriptHost =
    interface
        interface IDisposable
    end

The IScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | Reset | When implemented by a class, closes the script engine and releases all resources.
Public method | Run | When implemented by a class, executes script starting from the main entry point.
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunFunction | When implemented by a class, executes specified function.
Public method | RunFunctionAsync | When implemented by a class, executes specified function asynchronously.
Top
Properties
 | Name | Description
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | When implemented by a class, gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | When implemented by a class, gets list of compiler errors associated with the script being executed.
Public property | HostItemsConfiguration | When implemented by a class, gets script host configuration
Public property | ModulesDirectoryPath | When implemented by a class, gets or sets path for compiled script assemblies.
Public property | OutputFileName | When implemented by a class, gets script assembly file name.
Public property | RunnableScript | When implemented by a class, returns compiled script assembly.
Public property | ScriptRun | When implemented by a class, gets IScriptRun associated this script host.
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


IScriptHost Methods

IScriptHost Methods

The IScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression.
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | Reset | When implemented by a class, closes the script engine and releases all resources.
Public method | Run | When implemented by a class, executes script starting from the main entry point.
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunFunction | When implemented by a class, executes specified function.
Public method | RunFunctionAsync | When implemented by a class, executes specified function asynchronously.
Top
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.Compile Method

IScriptHostCompile Method
When implemented by a class, initializes script engine and compiles the script.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Compile()
Function Compile As Boolean
bool Compile()
abstract Compile : unit -> bool

Return Value

Type: Boolean
True if succeed, otherwise false.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.EvaluateExpression Method

IScriptHostEvaluateExpression Method
When implemented by a class, evaluates specified expression.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object EvaluateExpression(
    string expression
)
Function EvaluateExpression (
    expression As String
) As Object
Object^ EvaluateExpression(
    String^ expression
)
abstract EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.EvaluateExpressionAsync Method

IScriptHostEvaluateExpressionAsync Method
When implemented by a class, evaluates specified expression asynchronously.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.Reset Method

IScriptHostReset Method
When implemented by a class, closes the script engine and releases all resources.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.Run Method

IScriptHostRun Method
When implemented by a class, executes script starting from the main entry point.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Run()
Sub Run
void Run()
abstract Run : unit -> unit

Return Value

Type:
Return value of the script being executed.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.RunAsync Method

IScriptHostRunAsync Method
When implemented by a class, executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task RunAsync(
    CancellationToken cancellationToken = null
)
Function RunAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
Task^ RunAsync(
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: Task
Return value of the script being executed.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.RunFunction Method

IScriptHostRunFunction Method
When implemented by a class, executes specified function.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object RunFunction(
    string functionName,
    Object[] args = null
)
Function RunFunction (
    functionName As String,
    Optional args As Object() = Nothing
) As Object
Object^ RunFunction(
    String^ functionName,
    array<Object^>^ args = nullptr
)
abstract RunFunction :
        functionName : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

functionName
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of functions's parameters.

Return Value

Type: Object
An object containing return value of the executed function.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.RunFunctionAsync Method

IScriptHostRunFunctionAsync Method
When implemented by a class, executes specified function asynchronously.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> RunFunctionAsync(
    string functionName,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Function RunFunctionAsync (
    functionName As String,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ RunFunctionAsync(
    String^ functionName,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunFunctionAsync :
        functionName : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

functionName
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed function.
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost Properties

IScriptHost Properties

The IScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | When implemented by a class, gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | When implemented by a class, gets list of compiler errors associated with the script being executed.
Public property | HostItemsConfiguration | When implemented by a class, gets script host configuration
Public property | ModulesDirectoryPath | When implemented by a class, gets or sets path for compiled script assemblies.
Public property | OutputFileName | When implemented by a class, gets script assembly file name.
Public property | RunnableScript | When implemented by a class, returns compiled script assembly.
Public property | ScriptRun | When implemented by a class, gets IScriptRun associated this script host.
Top
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.Compiled Property

IScriptHostCompiled Property
When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Compiled { get; }
ReadOnly Property Compiled As Boolean
    Get
property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.CompileFailed Property

IScriptHostCompileFailed Property
When implemented by a class, gets or sets boolean value indicating unsuccessful script compilation.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CompileFailed { get; }
ReadOnly Property CompileFailed As Boolean
    Get
property bool CompileFailed {
    bool get ();
}
abstract CompileFailed : bool with get

Property Value

Type: Boolean
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.CompilerErrors Property

IScriptHostCompilerErrors Property
When implemented by a class, gets list of compiler errors associated with the script being executed.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptCompilationDiagnostic[] CompilerErrors { get; }
ReadOnly Property CompilerErrors As ScriptCompilationDiagnostic()
    Get
property array<ScriptCompilationDiagnostic>^ CompilerErrors {
    array<ScriptCompilationDiagnostic>^ get ();
}
abstract CompilerErrors : ScriptCompilationDiagnostic[] with get

Property Value

Type: ScriptCompilationDiagnostic
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.HostItemsConfiguration Property

IScriptHostHostItemsConfiguration Property
When implemented by a class, gets script host configuration

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
HostItemsConfiguration HostItemsConfiguration { get; }
ReadOnly Property HostItemsConfiguration As HostItemsConfiguration
    Get
property HostItemsConfiguration^ HostItemsConfiguration {
    HostItemsConfiguration^ get ();
}
abstract HostItemsConfiguration : HostItemsConfiguration with get

Property Value

Type: HostItemsConfiguration
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.ModulesDirectoryPath Property

IScriptHostModulesDirectoryPath Property
When implemented by a class, gets or sets path for compiled script assemblies.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ModulesDirectoryPath { get; set; }
Property ModulesDirectoryPath As String
    Get
    Set
property String^ ModulesDirectoryPath {
    String^ get ();
    void set (String^ value);
}
abstract ModulesDirectoryPath : string with get, set

Property Value

Type: String
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.OutputFileName Property

IScriptHostOutputFileName Property
When implemented by a class, gets script assembly file name.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string OutputFileName { get; set; }
Property OutputFileName As String
    Get
    Set
property String^ OutputFileName {
    String^ get ();
    void set (String^ value);
}
abstract OutputFileName : string with get, set

Property Value

Type: String
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.RunnableScript Property

IScriptHostRunnableScript Property
When implemented by a class, returns compiled script assembly.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
RunnableScript RunnableScript { get; }
ReadOnly Property RunnableScript As RunnableScript
    Get
property RunnableScript^ RunnableScript {
    RunnableScript^ get ();
}
abstract RunnableScript : RunnableScript with get

Property Value

Type: RunnableScript
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptHost.ScriptRun Property

IScriptHostScriptRun Property
When implemented by a class, gets IScriptRun associated this script host.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptRun ScriptRun { get; }
ReadOnly Property ScriptRun As IScriptRun
    Get
property IScriptRun^ ScriptRun {
    IScriptRun^ get ();
}
abstract ScriptRun : IScriptRun with get

Property Value

Type: IScriptRun
See Also

Reference

IScriptHost Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun Interface

IScriptRun Interface
Represents methods and properties declaration to describe runner for script engine.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptRun : IScriptRunBase,
    ITypeDefinitionsLocator
Public Interface IScriptRun
    Inherits IScriptRunBase, ITypeDefinitionsLocator
public interface class IScriptRun : IScriptRunBase,
    ITypeDefinitionsLocator
type IScriptRun =
    interface
        interface IScriptRunBase
        interface ITypeDefinitionsLocator
    end

The IScriptRun type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script. (Inherited from IScriptRunBase.)
Public method | CreateScriptHost | When implemented by a class, creates a new IScriptHost object with appropriate characteristics.
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression. (Inherited from IScriptRunBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | LoadScript | When implemented by a class, load script from specified file. (Inherited from IScriptRunBase.)
Public method | OnFileLoad | When implemented by a class, invokes FileLoad event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptCompiled | When implemented by a class, invokes ScriptCompiled event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptError | When implemented by a class, invokes ScriptError event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptExecuted | When implemented by a class, invokes ScriptExecuted event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptReset | When implemented by a class, invokes ScriptReset event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptRunning | When implemented by a class, invokes ScriptRunning event handler. (Inherited from IScriptRunBase.)
Public method | Reset | When implemented by a class, removes the script engine from the running state and disconnects automatically bound event handlers. (Inherited from IScriptRunBase.)
Public method | Run | When implemented by a class, executes script starting from the main entry point. (Inherited from IScriptRunBase.)
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunFunction | When implemented by a class, executes specified function.
Public method | RunFunctionAsync | When implemented by a class, executes specified function asynchronously.
Top
Properties
 | Name | Description
Public property | AutoGeneratedTypeDefinitionsPath | (Inherited from ITypeDefinitionsLocator.)
Public property | AutoGenerateTypeDefinitions | (Inherited from ITypeDefinitionsLocator.)
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive. (Inherited from IScriptRunBase.)
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed. (Inherited from IScriptRunBase.)
Public property | EmbeddedTypeDefitionsLocations | (Inherited from ITypeDefinitionsLocator.)
Public property | Executed | When implemented by a class, gets boolean value indicating that script has been executed at least once. (Inherited from IScriptRunBase.)
Public property | LoadUserTypeDefinitions | (Inherited from ITypeDefinitionsLocator.)
Public property | ProjectDirectory | (Inherited from ITypeDefinitionsLocator.)
Public property | ScriptHost | When implemented by a class, returns object that implements IScriptHost interface for this runner.
Public property | ScriptLanguage | When implemented by a class, gets or sets programming language of the script.
Public property | ScriptSource | When implemented by a class, gets source of the script to execute.
Public property | TypeDefinitionsSearchPaths | (Inherited from ITypeDefinitionsLocator.)
Public property | WaitForDebuggerOnStart | When implemented by a class, gets of sets a boolean value indicates whether script engine is to wait for a debugger connection and schedule a pause before executing the first line of application script code.
Top
Events
 | Name | Description
Public event | FileLoad | When implemented by a class, occurs when script code is loaded from file. (Inherited from IScriptRunBase.)
Public event | ScriptCompiled | When implemented by a class, occurs when the script engine running successfully. (Inherited from IScriptRunBase.)
Public event | ScriptError | When implemented by a class, occurs when the script engine running is failed. (Inherited from IScriptRunBase.)
Public event | ScriptExecuted | When implemented by a class, occurs when script engine executes the script. (Inherited from IScriptRunBase.)
Public event | ScriptReset | When implemented by a class, occurs when the script engine is reset. (Inherited from IScriptRunBase.)
Public event | ScriptRunning | When implemented by a class, occurs when script engine tries to running script. (Inherited from IScriptRunBase.)
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


IScriptRun Methods

IScriptRun Methods

The IScriptRun type exposes the following members.

Methods
 | Name | Description
Public method | Compile | When implemented by a class, initializes script engine and compiles the script. (Inherited from IScriptRunBase.)
Public method | CreateScriptHost | When implemented by a class, creates a new IScriptHost object with appropriate characteristics.
Public method | EvaluateExpression | When implemented by a class, evaluates specified expression. (Inherited from IScriptRunBase.)
Public method | EvaluateExpressionAsync | When implemented by a class, evaluates specified expression asynchronously.
Public method | LoadScript | When implemented by a class, load script from specified file. (Inherited from IScriptRunBase.)
Public method | OnFileLoad | When implemented by a class, invokes FileLoad event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptCompiled | When implemented by a class, invokes ScriptCompiled event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptError | When implemented by a class, invokes ScriptError event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptExecuted | When implemented by a class, invokes ScriptExecuted event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptReset | When implemented by a class, invokes ScriptReset event handler. (Inherited from IScriptRunBase.)
Public method | OnScriptRunning | When implemented by a class, invokes ScriptRunning event handler. (Inherited from IScriptRunBase.)
Public method | Reset | When implemented by a class, removes the script engine from the running state and disconnects automatically bound event handlers. (Inherited from IScriptRunBase.)
Public method | Run | When implemented by a class, executes script starting from the main entry point. (Inherited from IScriptRunBase.)
Public method | RunAsync | When implemented by a class, executes script asynchronously starting from the main entry point.
Public method | RunFunction | When implemented by a class, executes specified function.
Public method | RunFunctionAsync | When implemented by a class, executes specified function asynchronously.
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun.CreateScriptHost Method

IScriptRunCreateScriptHost Method
When implemented by a class, creates a new IScriptHost object with appropriate characteristics.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptHost CreateScriptHost()
Function CreateScriptHost As IScriptHost
IScriptHost^ CreateScriptHost()
abstract CreateScriptHost : unit -> IScriptHost

Return Value

Type: IScriptHost
Created IScriptHost object.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun.EvaluateExpressionAsync Method

IScriptRunEvaluateExpressionAsync Method
When implemented by a class, evaluates specified expression asynchronously.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun.RunAsync Method

IScriptRunRunAsync Method
When implemented by a class, executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task RunAsync(
    CancellationToken cancellationToken = null
)
Function RunAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
Task^ RunAsync(
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: Task
Return value of the script being executed.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun.RunFunction Method

IScriptRunRunFunction Method
When implemented by a class, executes specified function.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object RunFunction(
    string function,
    Object[] args = null
)
Function RunFunction (
    function As String,
    Optional args As Object() = Nothing
) As Object
Object^ RunFunction(
    String^ function,
    array<Object^>^ args = nullptr
)
abstract RunFunction :
        function : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.

Return Value

Type: Object
An object containing return value of the executed function.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun.RunFunctionAsync Method

IScriptRunRunFunctionAsync Method
When implemented by a class, executes specified function asynchronously.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<Object> RunFunctionAsync(
    string function,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Function RunFunctionAsync (
    function As String,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
Task<Object^>^ RunFunctionAsync(
    String^ function,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed function.
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun Properties

IScriptRun Properties

The IScriptRun type exposes the following members.

Properties
 | Name | Description
Public property | AutoGeneratedTypeDefinitionsPath | (Inherited from ITypeDefinitionsLocator.)
Public property | AutoGenerateTypeDefinitions | (Inherited from ITypeDefinitionsLocator.)
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive. (Inherited from IScriptRunBase.)
Public property | Compiled | When implemented by a class, gets boolean value indicating that script has been compiled and ready to be executed. (Inherited from IScriptRunBase.)
Public property | EmbeddedTypeDefitionsLocations | (Inherited from ITypeDefinitionsLocator.)
Public property | Executed | When implemented by a class, gets boolean value indicating that script has been executed at least once. (Inherited from IScriptRunBase.)
Public property | LoadUserTypeDefinitions | (Inherited from ITypeDefinitionsLocator.)
Public property | ProjectDirectory | (Inherited from ITypeDefinitionsLocator.)
Public property | ScriptHost | When implemented by a class, returns object that implements IScriptHost interface for this runner.
Public property | ScriptLanguage | When implemented by a class, gets or sets programming language of the script.
Public property | ScriptSource | When implemented by a class, gets source of the script to execute.
Public property | TypeDefinitionsSearchPaths | (Inherited from ITypeDefinitionsLocator.)
Public property | WaitForDebuggerOnStart | When implemented by a class, gets of sets a boolean value indicates whether script engine is to wait for a debugger connection and schedule a pause before executing the first line of application script code.
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun.ScriptHost Property

IScriptRunScriptHost Property
When implemented by a class, returns object that implements IScriptHost interface for this runner.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptHost ScriptHost { get; set; }
Property ScriptHost As IScriptHost
    Get
    Set
property IScriptHost^ ScriptHost {
    IScriptHost^ get ();
    void set (IScriptHost^ value);
}
abstract ScriptHost : IScriptHost with get, set

Property Value

Type: IScriptHost
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun.ScriptLanguage Property

IScriptRunScriptLanguage Property
When implemented by a class, gets or sets programming language of the script.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptLanguage ScriptLanguage { get; set; }
Property ScriptLanguage As ScriptLanguage
    Get
    Set
property ScriptLanguage ScriptLanguage {
    ScriptLanguage get ();
    void set (ScriptLanguage value);
}
abstract ScriptLanguage : ScriptLanguage with get, set

Property Value

Type: ScriptLanguage
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun.ScriptSource Property

IScriptRunScriptSource Property
When implemented by a class, gets source of the script to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource ScriptSource { get; }
ReadOnly Property ScriptSource As IScriptSource
    Get
property IScriptSource^ ScriptSource {
    IScriptSource^ get ();
}
abstract ScriptSource : IScriptSource with get

Property Value

Type: IScriptSource
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun.WaitForDebuggerOnStart Property

IScriptRunWaitForDebuggerOnStart Property
When implemented by a class, gets of sets a boolean value indicates whether script engine is to wait for a debugger connection and schedule a pause before executing the first line of application script code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WaitForDebuggerOnStart { get; set; }
Property WaitForDebuggerOnStart As Boolean
    Get
    Set
property bool WaitForDebuggerOnStart {
    bool get ();
    void set (bool value);
}
abstract WaitForDebuggerOnStart : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptRun Events

IScriptRun Events

The IScriptRun type exposes the following members.

Events
 | Name | Description
Public event | FileLoad | When implemented by a class, occurs when script code is loaded from file. (Inherited from IScriptRunBase.)
Public event | ScriptCompiled | When implemented by a class, occurs when the script engine running successfully. (Inherited from IScriptRunBase.)
Public event | ScriptError | When implemented by a class, occurs when the script engine running is failed. (Inherited from IScriptRunBase.)
Public event | ScriptExecuted | When implemented by a class, occurs when script engine executes the script. (Inherited from IScriptRunBase.)
Public event | ScriptReset | When implemented by a class, occurs when the script engine is reset. (Inherited from IScriptRunBase.)
Public event | ScriptRunning | When implemented by a class, occurs when script engine tries to running script. (Inherited from IScriptRunBase.)
Top
See Also

Reference

IScriptRun Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource Interface

IScriptSource Interface
Represents methods and properties to work with script text, files or projects.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptSource : IScriptSourceBase,
    ICloneable, IEquatable<IScriptSource>
Public Interface IScriptSource
    Inherits IScriptSourceBase, ICloneable, IEquatable(Of IScriptSource)
public interface class IScriptSource : IScriptSourceBase,
    ICloneable, IEquatable<IScriptSource^>
type IScriptSource =
    interface
        interface IScriptSourceBase
        interface ICloneable
        interface IEquatable<IScriptSource>
    end

The IScriptSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatableIScriptSource.)
Public method | FromExpression | When implemented by a class, loads script source from the expression.
Public method | FromScriptCode(String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptCode(String, String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptFile | When implemented by a class, loads script source from the script file.
Public method | FromScriptProject | When implemented by a class, loads script source from the TypeScript project.
Public method | GetLastModifiedDate | When implemented by a class, gets file date time when script source was compiled.
Public method | HasBeenModified | When implemented by a class, compares file modification dates against to other script source.
Public method | Reset | When implemented by a class, clears script source.
Top
Properties
 | Name | Description
Public property | Changed | When implemented by a class, gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Expression | When implemented by a class, gets expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | Files | When implemented by a class, gets list of files containing script to execute.
Public property | HasExpression | When implemented by a class, returns boolean value indicating whether ScriptSource contains expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | HasProject | When implemented by a class, returns boolean value indicating whether ScriptSource is associated with the project. (Inherited from IScriptSourceBase.)
Public property | HasScriptCode | When implemented by a class, returns boolean value indicating whether ScriptSource contains script code to execute. (Inherited from IScriptSourceBase.)
Public property | HasScriptFile | When implemented by a class, returns boolean value indicating whether ScriptSource contains script file to execute. (Inherited from IScriptSourceBase.)
Public property | Language | When implemented by a class, returns script programming language.
Public property | ProjectFileName | When implemented by a class, gets a file name of the Visual Studio project containing script files to execute. (Inherited from IScriptSourceBase.)
Public property | ProjectName | When implemented by a class, gets or sets name of the Visual Studio project containing script files to execute.
Public property | RootNamespace | When implemented by a class, gets or sets root namespace to be used for manifest resources.
Public property | ScriptCode | When implemented by a class, gets script code to execute. (Inherited from IScriptSourceBase.)
Public property | ScriptFile | When implemented by a class, gets single script file to execute. (Inherited from IScriptSourceBase.)
Public property | SearchPaths | When implemented by a class, gets list of search directories to look for source files.
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


IScriptSource Methods

IScriptSource Methods

The IScriptSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatableIScriptSource .)
Public method | FromExpression | When implemented by a class, loads script source from the expression.
Public method | FromScriptCode(String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptCode(String, String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptFile | When implemented by a class, loads script source from the script file.
Public method | FromScriptProject | When implemented by a class, loads script source from the TypeScript project.
Public method | GetLastModifiedDate | When implemented by a class, gets file date time when script source was compiled.
Public method | HasBeenModified | When implemented by a class, compares file modification dates against to other script source.
Public method | Reset | When implemented by a class, clears script source.
Top
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.FromExpression Method

IScriptSourceFromExpression Method
When implemented by a class, loads script source from the expression.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromExpression(
    string expression
)
Function FromExpression (
    expression As String
) As IScriptSource
IScriptSource^ FromExpression(
    String^ expression
)
abstract FromExpression :
        expression : string -> IScriptSource

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.FromScriptCode Method

IScriptSourceFromScriptCode Method
Overload List
 | Name | Description
Public method | FromScriptCode(String) | When implemented by a class, loads script source from the script code.
Public method | FromScriptCode(String, String) | When implemented by a class, loads script source from the script code.
Top
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.FromScriptCode Method (String)

IScriptSourceFromScriptCode Method (String)
When implemented by a class, loads script source from the script code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptCode(
    string scriptCode
)
Function FromScriptCode (
    scriptCode As String
) As IScriptSource
IScriptSource^ FromScriptCode(
    String^ scriptCode
)
abstract FromScriptCode :
        scriptCode : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
FromScriptCode Overload
Alternet.Scripter.TypeScript Namespace


IScriptSource.FromScriptCode Method (String, String)

IScriptSourceFromScriptCode Method (String, String)
When implemented by a class, loads script source from the script code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptCode(
    string scriptCode,
    string fileName
)
Function FromScriptCode (
    scriptCode As String,
    fileName As String
) As IScriptSource
IScriptSource^ FromScriptCode(
    String^ scriptCode,
    String^ fileName
)
abstract FromScriptCode :
        scriptCode : string *
        fileName : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.
fileName
Type: SystemString
Specifis name if the file containing script code.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
FromScriptCode Overload
Alternet.Scripter.TypeScript Namespace


IScriptSource.FromScriptFile Method

IScriptSourceFromScriptFile Method
When implemented by a class, loads script source from the script file.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptFile(
    string fileName
)
Function FromScriptFile (
    fileName As String
) As IScriptSource
IScriptSource^ FromScriptFile(
    String^ fileName
)
abstract FromScriptFile :
        fileName : string -> IScriptSource

Parameters

fileName
Type: SystemString
File Name to load the script.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.FromScriptProject Method

IScriptSourceFromScriptProject Method
When implemented by a class, loads script source from the TypeScript project.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IScriptSource FromScriptProject(
    string projectFileName
)
Function FromScriptProject (
    projectFileName As String
) As IScriptSource
IScriptSource^ FromScriptProject(
    String^ projectFileName
)
abstract FromScriptProject :
        projectFileName : string -> IScriptSource

Parameters

projectFileName
Type: SystemString
Project file name to load script.

Return Value

Type: IScriptSource
Modified IScrptSource instance
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.GetLastModifiedDate Method

IScriptSourceGetLastModifiedDate Method
When implemented by a class, gets file date time when script source was compiled.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DateTime GetLastModifiedDate(
    string fileName
)
Function GetLastModifiedDate (
    fileName As String
) As DateTime
DateTime GetLastModifiedDate(
    String^ fileName
)
abstract GetLastModifiedDate :
        fileName : string -> DateTime

Parameters

fileName
Type: SystemString
FileName to check last modified date.

Return Value

Type: DateTime
File date of the given file at the time it was compiled.
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.HasBeenModified Method

IScriptSourceHasBeenModified Method
When implemented by a class, compares file modification dates against to other script source.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasBeenModified(
    IScriptSource other
)
Function HasBeenModified (
    other As IScriptSource
) As Boolean
bool HasBeenModified(
    IScriptSource^ other
)
abstract HasBeenModified :
        other : IScriptSource -> bool

Parameters

other
Type: Alternet.Scripter.TypeScriptIScriptSource
IScriptSource to compare.

Return Value

Type: Boolean
True, if source has been changed since last compilation; otherwise false.
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.Reset Method

IScriptSourceReset Method
When implemented by a class, clears script source.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource Properties

IScriptSource Properties

The IScriptSource type exposes the following members.

Properties
 | Name | Description
Public property | Changed | When implemented by a class, gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Expression | When implemented by a class, gets expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | Files | When implemented by a class, gets list of files containing script to execute.
Public property | HasExpression | When implemented by a class, returns boolean value indicating whether ScriptSource contains expression to evaluate. (Inherited from IScriptSourceBase.)
Public property | HasProject | When implemented by a class, returns boolean value indicating whether ScriptSource is associated with the project. (Inherited from IScriptSourceBase.)
Public property | HasScriptCode | When implemented by a class, returns boolean value indicating whether ScriptSource contains script code to execute. (Inherited from IScriptSourceBase.)
Public property | HasScriptFile | When implemented by a class, returns boolean value indicating whether ScriptSource contains script file to execute. (Inherited from IScriptSourceBase.)
Public property | Language | When implemented by a class, returns script programming language.
Public property | ProjectFileName | When implemented by a class, gets a file name of the Visual Studio project containing script files to execute. (Inherited from IScriptSourceBase.)
Public property | ProjectName | When implemented by a class, gets or sets name of the Visual Studio project containing script files to execute.
Public property | RootNamespace | When implemented by a class, gets or sets root namespace to be used for manifest resources.
Public property | ScriptCode | When implemented by a class, gets script code to execute. (Inherited from IScriptSourceBase.)
Public property | ScriptFile | When implemented by a class, gets single script file to execute. (Inherited from IScriptSourceBase.)
Public property | SearchPaths | When implemented by a class, gets list of search directories to look for source files.
Top
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.Changed Property

IScriptSourceChanged Property
When implemented by a class, gets or sets boolean value indicating if script source has been modified since last compilation.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Changed { get; set; }
Property Changed As Boolean
    Get
    Set
property bool Changed {
    bool get ();
    void set (bool value);
}
abstract Changed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.Files Property

IScriptSourceFiles Property
When implemented by a class, gets list of files containing script to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> Files { get; }
ReadOnly Property Files As IList(Of String)
    Get
property IList<String^>^ Files {
    IList<String^>^ get ();
}
abstract Files : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.Language Property

IScriptSourceLanguage Property
When implemented by a class, returns script programming language.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ScriptLanguage Language { get; }
ReadOnly Property Language As ScriptLanguage
    Get
property ScriptLanguage Language {
    ScriptLanguage get ();
}
abstract Language : ScriptLanguage with get

Property Value

Type: ScriptLanguage
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.ProjectName Property

IScriptSourceProjectName Property
When implemented by a class, gets or sets name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ProjectName { get; set; }
Property ProjectName As String
    Get
    Set
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}
abstract ProjectName : string with get, set

Property Value

Type: String
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.RootNamespace Property

IScriptSourceRootNamespace Property
When implemented by a class, gets or sets root namespace to be used for manifest resources.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string RootNamespace { get; set; }
Property RootNamespace As String
    Get
    Set
property String^ RootNamespace {
    String^ get ();
    void set (String^ value);
}
abstract RootNamespace : string with get, set

Property Value

Type: String
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


IScriptSource.SearchPaths Property

IScriptSourceSearchPaths Property
When implemented by a class, gets list of search directories to look for source files.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> SearchPaths { get; }
ReadOnly Property SearchPaths As IList(Of String)
    Get
property IList<String^>^ SearchPaths {
    IList<String^>^ get ();
}
abstract SearchPaths : IList<string> with get

Property Value

Type: IListString
See Also

Reference

IScriptSource Interface
Alternet.Scripter.TypeScript Namespace


RunnableScript Class

RunnableScript Class
A base class represents compiled script assembly. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.TypeScriptRunnableScript
Alternet.Scripter.TypeScriptFileRunnableScript
Alternet.Scripter.TypeScriptInMemoryRunnableScript

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class RunnableScript
Public MustInherit Class RunnableScript
public ref class RunnableScript abstract
[<AbstractClassAttribute>]
type RunnableScript =  class end

The RunnableScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


RunnableScript Methods

RunnableScript Methods

The RunnableScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunnableScript Class
Alternet.Scripter.TypeScript Namespace


ScriptConsts Class

ScriptConsts Class
Contains constants related to Scripter component.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.TypeScriptScriptConsts

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptConsts
Public Class ScriptConsts
public ref class ScriptConsts
type ScriptConsts =  class end

The ScriptConsts type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptConsts | Initializes a new instance of the ScriptConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DefaultJavaScriptExtension |
DefaultModuleGeneratedDirectory |
DefaultTypeScriptExtension |
EvaluateExpressionFunction |
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


ScriptConsts Constructor

ScriptConsts Constructor
Initializes a new instance of the ScriptConsts class

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptConsts()
Public Sub New
public:
ScriptConsts()
new : unit -> ScriptConsts
See Also

Reference

ScriptConsts Class
Alternet.Scripter.TypeScript Namespace


ScriptConsts Fields

ScriptConsts Fields

The ScriptConsts type exposes the following members.

Fields
Name | Description
DefaultJavaScriptExtension |
DefaultModuleGeneratedDirectory |
DefaultTypeScriptExtension |
EvaluateExpressionFunction |
Top
See Also

Reference

ScriptConsts Class
Alternet.Scripter.TypeScript Namespace


ScriptConsts.DefaultJavaScriptExtension Field

ScriptConstsDefaultJavaScriptExtension Field

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultJavaScriptExtension
Public Const DefaultJavaScriptExtension As String
public:
literal String^ DefaultJavaScriptExtension
static val mutable DefaultJavaScriptExtension: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter.TypeScript Namespace


ScriptConsts.DefaultModuleGeneratedDirectory Field

ScriptConstsDefaultModuleGeneratedDirectory Field

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultModuleGeneratedDirectory
Public Shared DefaultModuleGeneratedDirectory As String
public:
static String^ DefaultModuleGeneratedDirectory
static val mutable DefaultModuleGeneratedDirectory: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter.TypeScript Namespace


ScriptConsts.DefaultTypeScriptExtension Field

ScriptConstsDefaultTypeScriptExtension Field

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultTypeScriptExtension
Public Const DefaultTypeScriptExtension As String
public:
literal String^ DefaultTypeScriptExtension
static val mutable DefaultTypeScriptExtension: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter.TypeScript Namespace


ScriptConsts.EvaluateExpressionFunction Field

ScriptConstsEvaluateExpressionFunction Field

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string EvaluateExpressionFunction
Public Const EvaluateExpressionFunction As String
public:
literal String^ EvaluateExpressionFunction
static val mutable EvaluateExpressionFunction: string

Field Value

Type: String
See Also

Reference

ScriptConsts Class
Alternet.Scripter.TypeScript Namespace


ScriptConsts Methods

ScriptConsts Methods

The ScriptConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptConsts Class
Alternet.Scripter.TypeScript Namespace


ScriptHost Class

ScriptHost Class
Provides a base class for script execution. This class is abstract.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.TypeScriptScriptHost
Alternet.Scripter.TypeScriptClearScriptScriptHost

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ScriptHost : IScriptHost,
    IDisposable
Public MustInherit Class ScriptHost
    Implements IScriptHost, IDisposable
public ref class ScriptHost abstract : IScriptHost,
    IDisposable
[<AbstractClassAttribute>]
type ScriptHost =
    class
        interface IScriptHost
        interface IDisposable
    end

The ScriptHost type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptHost | Initializes a new instance of ScriptHost with specified script runner.
Top
Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers.
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunFunction | Executes specified function.
Public method | RunFunctionAsync | Executes specified function asynchronously.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed.
Public property | HostItemsConfiguration | Gets script host configuration.
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies.
Public property | OutputFileName | Gets script assembly file name.
Public property | RunnableScript | Returns compiled script assembly.
Public property | ScriptRun | Gets IScriptRun associated this script host.
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


ScriptHost Constructor

ScriptHost Constructor
Initializes a new instance of ScriptHost with specified script runner.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptHost(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
ScriptHost(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> ScriptHost

Parameters

scriptRun
Type: Alternet.Scripter.TypeScriptIScriptRun
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost Methods

ScriptHost Methods

The ScriptHost type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | Dispose | Disposes this ScriptHost and frees resources associated with it.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Removes the script engine from the running state and disconnects automatically bound event handlers.
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunFunction | Executes specified function.
Public method | RunFunctionAsync | Executes specified function asynchronously.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.Compile Method

ScriptHostCompile Method
Initializes script engine and compiles the script.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compile()
Public Overridable Function Compile As Boolean
public:
virtual bool Compile()
abstract Compile : unit -> bool
override Compile : unit -> bool

Return Value

Type: Boolean
True if succeed, otherwise false.

Implements

IScriptHostCompile
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.Dispose Method

ScriptHostDispose Method
Disposes this ScriptHost and frees resources associated with it.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.EvaluateExpression Method

ScriptHostEvaluateExpression Method
Evaluates specified expression.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object EvaluateExpression(
    string expression
)
Public Overridable Function EvaluateExpression (
    expression As String
) As Object
public:
virtual Object^ EvaluateExpression(
    String^ expression
)
abstract EvaluateExpression :
        expression : string -> Object
override EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.

Implements

IScriptHostEvaluateExpression(String)
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.EvaluateExpressionAsync Method

ScriptHostEvaluateExpressionAsync Method
Evaluates specified expression asynchronously.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Public Overridable Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
)
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.

Implements

IScriptHostEvaluateExpressionAsync(String, CancellationToken)
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.Reset Method

ScriptHostReset Method
Removes the script engine from the running state and disconnects automatically bound event handlers.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptHostReset
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.Run Method

ScriptHostRun Method
Executes script starting from the main entry point.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Run()
Public Overridable Sub Run
public:
virtual void Run()
abstract Run : unit -> unit
override Run : unit -> unit

Return Value

Type:
Return value of the script being executed.

Implements

IScriptHostRun
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.RunAsync Method

ScriptHostRunAsync Method
Executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task RunAsync(
    CancellationToken cancellationToken = null
)
Public Overridable Function RunAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
public:
virtual Task^ RunAsync(
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task
override RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: Task
Return value of the script being executed.

Implements

IScriptHostRunAsync(CancellationToken)
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.RunFunction Method

ScriptHostRunFunction Method
Executes specified function.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object RunFunction(
    string functionName,
    Object[] args = null
)
Public Overridable Function RunFunction (
    functionName As String,
    Optional args As Object() = Nothing
) As Object
public:
virtual Object^ RunFunction(
    String^ functionName,
    array<Object^>^ args = nullptr
)
abstract RunFunction :
        functionName : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object
override RunFunction :
        functionName : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

functionName
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.

Return Value

Type: Object
An object containing return value of the executed function.

Implements

IScriptHostRunFunction(String, Object)
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.RunFunctionAsync Method

ScriptHostRunFunctionAsync Method
Executes specified function asynchronously.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<Object> RunFunctionAsync(
    string function,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Public Overridable Function RunFunctionAsync (
    function As String,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ RunFunctionAsync(
    String^ function,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
)
abstract RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed function.

Implements

IScriptHostRunFunctionAsync(String, Object, CancellationToken)
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost Properties

ScriptHost Properties

The ScriptHost type exposes the following members.

Properties
 | Name | Description
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | CompileFailed | Gets or sets boolean value indicating unsuccessful script compilation.
Public property | CompilerErrors | Gets list of compiler errors associated with the script being executed.
Public property | HostItemsConfiguration | Gets script host configuration.
Public property | ModulesDirectoryPath | Gets or sets path for compiled script assemblies.
Public property | OutputFileName | Gets script assembly file name.
Public property | RunnableScript | Returns compiled script assembly.
Public property | ScriptRun | Gets IScriptRun associated this script host.
Top
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.Compiled Property

ScriptHostCompiled Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compiled { get; }
Public Overridable ReadOnly Property Compiled As Boolean
    Get
public:
virtual property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get
override Compiled : bool with get

Property Value

Type: Boolean

Implements

IScriptHostCompiled
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.CompileFailed Property

ScriptHostCompileFailed Property
Gets or sets boolean value indicating unsuccessful script compilation.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CompileFailed { get; }
Public ReadOnly Property CompileFailed As Boolean
    Get
public:
virtual property bool CompileFailed {
    bool get () sealed;
}
abstract CompileFailed : bool with get
override CompileFailed : bool with get

Property Value

Type: Boolean

Implements

IScriptHostCompileFailed
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.CompilerErrors Property

ScriptHostCompilerErrors Property
Gets list of compiler errors associated with the script being executed.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptCompilationDiagnostic[] CompilerErrors { get; }
Public ReadOnly Property CompilerErrors As ScriptCompilationDiagnostic()
    Get
public:
virtual property array<ScriptCompilationDiagnostic>^ CompilerErrors {
    array<ScriptCompilationDiagnostic>^ get () sealed;
}
abstract CompilerErrors : ScriptCompilationDiagnostic[] with get
override CompilerErrors : ScriptCompilationDiagnostic[] with get

Property Value

Type: ScriptCompilationDiagnostic

Implements

IScriptHostCompilerErrors
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.HostItemsConfiguration Property

ScriptHostHostItemsConfiguration Property
Gets script host configuration.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HostItemsConfiguration HostItemsConfiguration { get; }
Public ReadOnly Property HostItemsConfiguration As HostItemsConfiguration
    Get
public:
virtual property HostItemsConfiguration^ HostItemsConfiguration {
    HostItemsConfiguration^ get () sealed;
}
abstract HostItemsConfiguration : HostItemsConfiguration with get
override HostItemsConfiguration : HostItemsConfiguration with get

Property Value

Type: HostItemsConfiguration

Implements

IScriptHostHostItemsConfiguration
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.ModulesDirectoryPath Property

ScriptHostModulesDirectoryPath Property
Gets or sets path for compiled script assemblies.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModulesDirectoryPath { get; set; }
Public Property ModulesDirectoryPath As String
    Get
    Set
public:
virtual property String^ ModulesDirectoryPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ModulesDirectoryPath : string with get, set
override ModulesDirectoryPath : string with get, set

Property Value

Type: String

Implements

IScriptHostModulesDirectoryPath
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.OutputFileName Property

ScriptHostOutputFileName Property
Gets script assembly file name.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OutputFileName { get; set; }
Public Property OutputFileName As String
    Get
    Set
public:
virtual property String^ OutputFileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract OutputFileName : string with get, set
override OutputFileName : string with get, set

Property Value

Type: String

Implements

IScriptHostOutputFileName
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.RunnableScript Property

ScriptHostRunnableScript Property
Returns compiled script assembly.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual RunnableScript RunnableScript { get; }
Public Overridable ReadOnly Property RunnableScript As RunnableScript
    Get
public:
virtual property RunnableScript^ RunnableScript {
    RunnableScript^ get ();
}
abstract RunnableScript : RunnableScript with get
override RunnableScript : RunnableScript with get

Property Value

Type: RunnableScript

Implements

IScriptHostRunnableScript
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptHost.ScriptRun Property

ScriptHostScriptRun Property
Gets IScriptRun associated this script host.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptRun ScriptRun { get; }
Public ReadOnly Property ScriptRun As IScriptRun
    Get
public:
virtual property IScriptRun^ ScriptRun {
    IScriptRun^ get () sealed;
}
abstract ScriptRun : IScriptRun with get
override ScriptRun : IScriptRun with get

Property Value

Type: IScriptRun

Implements

IScriptHostScriptRun
See Also

Reference

ScriptHost Class
Alternet.Scripter.TypeScript Namespace


ScriptLanguage Enumeration

ScriptLanguage Enumeration
Defines programming language used by the script engine.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptLanguage
Public Enumeration ScriptLanguage
public enum class ScriptLanguage
type ScriptLanguage
Members
Member name | Value | Description
TypeScript | 0 | Specifies TypeScript language.
JavaScript | 1 | Specifies JavaScript language.
See Also

Reference

Alternet.Scripter.TypeScript Namespace


ScriptRun Class

ScriptRun Class
Represents runner for script engine.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Scripter.TypeScriptScriptRun

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptRun : Component, IScriptRun,
    IScriptRunBase, ITypeDefinitionsLocator
Public Class ScriptRun
    Inherits Component
    Implements IScriptRun, IScriptRunBase, ITypeDefinitionsLocator
public ref class ScriptRun : public Component,
    IScriptRun, IScriptRunBase, ITypeDefinitionsLocator
type ScriptRun =
    class
        inherit Component
        interface IScriptRun
        interface IScriptRunBase
        interface ITypeDefinitionsLocator
    end

The ScriptRun type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptRun | Initializes a new instance of the ScriptRun class with default settings.
Public method | ScriptRun(IContainer) | Initializes a new instance of the ScriptRun class with specified parameters.
Top
Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateScriptHost | Creates a new IScriptHost object with appropriate characteristics.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadScript | Load script from specified file.
Public method | OnFileLoad | Invokes FileLoad event handler.
Public method | OnScriptCompiled | Invokes ScriptCompiled event handler.
Public method | OnScriptError | Invokes ScriptError event handler.
Public method | OnScriptExecuted | Invokes ScriptRunning event handler.
Public method | OnScriptReset | Invokes ScriptReset event handler.
Public method | OnScriptRunning | Invokes ScriptRunning event handler.
Public method | Reset | Resets the script engine and releases all resources.
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunFunction | Executes specified function.
Public method | RunFunctionAsync | Executes specified function asynchronously.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Properties
 | Name | Description
Public property | AutoGeneratedTypeDefinitionsPath | Gets or sets whether project should automatically generate type definitions if possible.
Public property | AutoGenerateTypeDefinitions | Gets or sets whether project should automatically generate type definitions if possible.
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive.
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | EmbeddedTypeDefitionsLocations | Gets or sets a collection of EmbeddedTypeDefitionsLocation that belong to the project.
Public property | Executed | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | LoadUserTypeDefinitions | Gets or sets whether users type definitions should be loaded.
Public property | ProjectDirectory | Gets or sets root project directory.
Public property | ScriptHost | Returns object that implements IScriptHost interface for this runner.
Public property | ScriptLanguage | Gets or sets programming language of the script.
Public property | ScriptSource | Gets source of the script to execute.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | TypeDefinitionsSearchPaths | Gets or sets list of search directories to look for type definitions.
Public property | WaitForDebuggerOnStart | Gets of sets a boolean value indicates whether script engine is to wait for a debugger connection and schedule a pause before executing the first line of application script code.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileLoad | Occurs when script code is loaded from file.
Public event | ScriptCompiled | Occurs when the script engine running successfully.
Public event | ScriptError | Occurs when the script engine running is failed.
Public event | ScriptExecuted | Occurs when script engine executes the script.
Public event | ScriptReset | Occurs when the script engine is reset.
Public event | ScriptRunning | Occurs when script engine tries to running script.
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


ScriptRun Constructor

ScriptRun Constructor
Overload List
 | Name | Description
Public method | ScriptRun | Initializes a new instance of the ScriptRun class with default settings.
Public method | ScriptRun(IContainer) | Initializes a new instance of the ScriptRun class with specified parameters.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun Constructor

ScriptRun Constructor
Initializes a new instance of the ScriptRun class with default settings.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRun()
Public Sub New
public:
ScriptRun()
new : unit -> ScriptRun
See Also

Reference

ScriptRun Class
ScriptRun Overload
Alternet.Scripter.TypeScript Namespace


ScriptRun Constructor (IContainer)

ScriptRun Constructor (IContainer)
Initializes a new instance of the ScriptRun class with specified parameters.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRun(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
ScriptRun(
    IContainer^ container
)
new :
        container : IContainer -> ScriptRun

Parameters

container
Type: System.ComponentModelIContainer
Specifies container of this new instance.
See Also

Reference

ScriptRun Class
ScriptRun Overload
Alternet.Scripter.TypeScript Namespace


ScriptRun Methods

ScriptRun Methods

The ScriptRun type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Initializes script engine and compiles the script.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateScriptHost | Creates a new IScriptHost object with appropriate characteristics.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateExpression | Evaluates specified expression.
Public method | EvaluateExpressionAsync | Evaluates specified expression asynchronously.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadScript | Load script from specified file.
Public method | OnFileLoad | Invokes FileLoad event handler.
Public method | OnScriptCompiled | Invokes ScriptCompiled event handler.
Public method | OnScriptError | Invokes ScriptError event handler.
Public method | OnScriptExecuted | Invokes ScriptRunning event handler.
Public method | OnScriptReset | Invokes ScriptReset event handler.
Public method | OnScriptRunning | Invokes ScriptRunning event handler.
Public method | Reset | Resets the script engine and releases all resources.
Public method | Run | Executes script starting from the main entry point.
Public method | RunAsync | Executes script asynchronously starting from the main entry point.
Public method | RunFunction | Executes specified function.
Public method | RunFunctionAsync | Executes specified function asynchronously.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.Compile Method

ScriptRunCompile Method
Initializes script engine and compiles the script.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compile()
Public Overridable Function Compile As Boolean
public:
virtual bool Compile()
abstract Compile : unit -> bool
override Compile : unit -> bool

Return Value

Type: Boolean
True if succeed, otherwise false.

Implements

IScriptRunBaseCompile
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.CreateScriptHost Method

ScriptRunCreateScriptHost Method
Creates a new IScriptHost object with appropriate characteristics.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptHost CreateScriptHost()
Public Overridable Function CreateScriptHost As IScriptHost
public:
virtual IScriptHost^ CreateScriptHost()
abstract CreateScriptHost : unit -> IScriptHost
override CreateScriptHost : unit -> IScriptHost

Return Value

Type: IScriptHost
Created IScriptHost object.

Implements

IScriptRunCreateScriptHost
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.EvaluateExpression Method

ScriptRunEvaluateExpression Method
Evaluates specified expression.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object EvaluateExpression(
    string expression
)
Public Function EvaluateExpression (
    expression As String
) As Object
public:
virtual Object^ EvaluateExpression(
    String^ expression
) sealed
abstract EvaluateExpression :
        expression : string -> Object
override EvaluateExpression :
        expression : string -> Object

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
An object containing return value of the expression being evaluated.

Implements

IScriptRunBaseEvaluateExpression(String)
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.EvaluateExpressionAsync Method

ScriptRunEvaluateExpressionAsync Method
Evaluates specified expression asynchronously.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<Object> EvaluateExpressionAsync(
    string expression,
    CancellationToken cancellationToken = null
)
Public Function EvaluateExpressionAsync (
    expression As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ EvaluateExpressionAsync(
    String^ expression,
    CancellationToken cancellationToken = nullptr
) sealed
abstract EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override EvaluateExpressionAsync :
        expression : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

expression
Type: SystemString
Expression to execute.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the expression being evaluated.

Implements

IScriptRunEvaluateExpressionAsync(String, CancellationToken)
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.LoadScript Method

ScriptRunLoadScript Method
Load script from specified file.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string LoadScript(
    string fileName
)
Public Overridable Function LoadScript (
    fileName As String
) As String
public:
virtual String^ LoadScript(
    String^ fileName
)
abstract LoadScript :
        fileName : string -> string
override LoadScript :
        fileName : string -> string

Parameters

fileName
Type: SystemString
File name contains script to load.

Return Value

Type: String
String representation of loaded script.

Implements

IScriptRunBaseLoadScript(String)
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.OnFileLoad Method

ScriptRunOnFileLoad Method
Invokes FileLoad event handler.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string OnFileLoad(
    string fileName
)
Public Overridable Function OnFileLoad (
    fileName As String
) As String
public:
virtual String^ OnFileLoad(
    String^ fileName
)
abstract OnFileLoad :
        fileName : string -> string
override OnFileLoad :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String

Implements

IScriptRunBaseOnFileLoad(String)
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.OnScriptCompiled Method

ScriptRunOnScriptCompiled Method
Invokes ScriptCompiled event handler.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptCompiled()
Public Overridable Sub OnScriptCompiled
public:
virtual void OnScriptCompiled()
abstract OnScriptCompiled : unit -> unit
override OnScriptCompiled : unit -> unit

Implements

IScriptRunBaseOnScriptCompiled
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.OnScriptError Method

ScriptRunOnScriptError Method
Invokes ScriptError event handler.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptError(
    ScriptErrorEventArgs e
)
Public Overridable Sub OnScriptError (
    e As ScriptErrorEventArgs
)
public:
virtual void OnScriptError(
    ScriptErrorEventArgs^ e
)
abstract OnScriptError :
        e : ScriptErrorEventArgs -> unit
override OnScriptError :
        e : ScriptErrorEventArgs -> unit

Parameters

e
Type: Alternet.ScripterScriptErrorEventArgs

Implements

IScriptRunBaseOnScriptError(ScriptErrorEventArgs)
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.OnScriptExecuted Method

ScriptRunOnScriptExecuted Method
Invokes ScriptRunning event handler.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptExecuted()
Public Overridable Sub OnScriptExecuted
public:
virtual void OnScriptExecuted()
abstract OnScriptExecuted : unit -> unit
override OnScriptExecuted : unit -> unit

Implements

IScriptRunBaseOnScriptExecuted
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.OnScriptReset Method

ScriptRunOnScriptReset Method
Invokes ScriptReset event handler.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptReset()
Public Overridable Sub OnScriptReset
public:
virtual void OnScriptReset()
abstract OnScriptReset : unit -> unit
override OnScriptReset : unit -> unit

Implements

IScriptRunBaseOnScriptReset
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.OnScriptRunning Method

ScriptRunOnScriptRunning Method
Invokes ScriptRunning event handler.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnScriptRunning()
Public Overridable Sub OnScriptRunning
public:
virtual void OnScriptRunning()
abstract OnScriptRunning : unit -> unit
override OnScriptRunning : unit -> unit

Implements

IScriptRunBaseOnScriptRunning
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.Reset Method

ScriptRunReset Method
Resets the script engine and releases all resources.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptRunBaseReset
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.Run Method

ScriptRunRun Method
Executes script starting from the main entry point.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Run()
Public Overridable Function Run As Object
public:
virtual Object^ Run()
abstract Run : unit -> Object
override Run : unit -> Object

Return Value

Type: Object
Return value of the script being executed.

Implements

IScriptRunBaseRun
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.RunAsync Method

ScriptRunRunAsync Method
Executes script asynchronously starting from the main entry point.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task RunAsync(
    CancellationToken cancellationToken = null
)
Public Overridable Function RunAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task
public:
virtual Task^ RunAsync(
    CancellationToken cancellationToken = nullptr
)
abstract RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task
override RunAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: Task
Return value of the script being executed.

Implements

IScriptRunRunAsync(CancellationToken)
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.RunFunction Method

ScriptRunRunFunction Method
Executes specified function.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object RunFunction(
    string function,
    Object[] args = null
)
Public Overridable Function RunFunction (
    function As String,
    Optional args As Object() = Nothing
) As Object
public:
virtual Object^ RunFunction(
    String^ function,
    array<Object^>^ args = nullptr
)
abstract RunFunction :
        function : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object
override RunFunction :
        function : string *
        ?args : Object[]
(* Defaults:
        let _args = defaultArg args null
*)
-> Object

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.

Return Value

Type: Object
An object containing return value of the executed function.

Implements

IScriptRunRunFunction(String, Object)
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.RunFunctionAsync Method

ScriptRunRunFunctionAsync Method
Executes specified function asynchronously.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<Object> RunFunctionAsync(
    string function,
    Object[] args = null,
    CancellationToken cancellationToken = null
)
Public Function RunFunctionAsync (
    function As String,
    Optional args As Object() = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Object)
public:
virtual Task<Object^>^ RunFunctionAsync(
    String^ function,
    array<Object^>^ args = nullptr,
    CancellationToken cancellationToken = nullptr
) sealed
abstract RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>
override RunFunctionAsync :
        function : string *
        ?args : Object[] *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _args = defaultArg args null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

Parameters

function
Type: SystemString
Name of function to execute.
args (Optional)
Type: SystemObject
Array of function's parameters.
cancellationToken (Optional)
Type: System.ThreadingCancellationToken
Cancellation token.

Return Value

Type: TaskObject
An object containing return value of the executed function.

Implements

IScriptRunRunFunctionAsync(String, Object, CancellationToken)
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun Properties

ScriptRun Properties

The ScriptRun type exposes the following members.

Properties
 | Name | Description
Public property | AutoGeneratedTypeDefinitionsPath | Gets or sets whether project should automatically generate type definitions if possible.
Public property | AutoGenerateTypeDefinitions | Gets or sets whether project should automatically generate type definitions if possible.
Public property | CaseSensitive | When implemented by a class, indicates whether script language is case sensitive.
Public property | Compiled | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | EmbeddedTypeDefitionsLocations | Gets or sets a collection of EmbeddedTypeDefitionsLocation that belong to the project.
Public property | Executed | Gets boolean value indicating that script has been compiled and ready to be executed.
Public property | LoadUserTypeDefinitions | Gets or sets whether users type definitions should be loaded.
Public property | ProjectDirectory | Gets or sets root project directory.
Public property | ScriptHost | Returns object that implements IScriptHost interface for this runner.
Public property | ScriptLanguage | Gets or sets programming language of the script.
Public property | ScriptSource | Gets source of the script to execute.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | TypeDefinitionsSearchPaths | Gets or sets list of search directories to look for type definitions.
Public property | WaitForDebuggerOnStart | Gets of sets a boolean value indicates whether script engine is to wait for a debugger connection and schedule a pause before executing the first line of application script code.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.AutoGeneratedTypeDefinitionsPath Property

ScriptRunAutoGeneratedTypeDefinitionsPath Property
Gets or sets whether project should automatically generate type definitions if possible.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AutoGeneratedTypeDefinitionsPath { get; set; }
Public Property AutoGeneratedTypeDefinitionsPath As String
    Get
    Set
public:
virtual property String^ AutoGeneratedTypeDefinitionsPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract AutoGeneratedTypeDefinitionsPath : string with get, set
override AutoGeneratedTypeDefinitionsPath : string with get, set

Property Value

Type: String

Implements

ITypeDefinitionsLocator.AutoGeneratedTypeDefinitionsPath
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.AutoGenerateTypeDefinitions Property

ScriptRunAutoGenerateTypeDefinitions Property
Gets or sets whether project should automatically generate type definitions if possible.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoGenerateTypeDefinitions { get; set; }
Public Property AutoGenerateTypeDefinitions As Boolean
    Get
    Set
public:
virtual property bool AutoGenerateTypeDefinitions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AutoGenerateTypeDefinitions : bool with get, set
override AutoGenerateTypeDefinitions : bool with get, set

Property Value

Type: Boolean

Implements

ITypeDefinitionsLocator.AutoGenerateTypeDefinitions
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.CaseSensitive Property

ScriptRunCaseSensitive Property
When implemented by a class, indicates whether script language is case sensitive.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CaseSensitive { get; }
Public ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () sealed;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

IScriptRunBaseCaseSensitive
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.Compiled Property

ScriptRunCompiled Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Compiled { get; }
Public Overridable ReadOnly Property Compiled As Boolean
    Get
public:
virtual property bool Compiled {
    bool get ();
}
abstract Compiled : bool with get
override Compiled : bool with get

Property Value

Type: Boolean

Implements

IScriptRunBaseCompiled
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.EmbeddedTypeDefitionsLocations Property

ScriptRunEmbeddedTypeDefitionsLocations Property
Gets or sets a collection of EmbeddedTypeDefitionsLocation that belong to the project.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<EmbeddedTypeDefitionsLocation> EmbeddedTypeDefitionsLocations { get; set; }
Public Property EmbeddedTypeDefitionsLocations As IEnumerable(Of EmbeddedTypeDefitionsLocation)
    Get
    Set
public:
virtual property IEnumerable<EmbeddedTypeDefitionsLocation^>^ EmbeddedTypeDefitionsLocations {
    IEnumerable<EmbeddedTypeDefitionsLocation^>^ get () sealed;
    void set (IEnumerable<EmbeddedTypeDefitionsLocation^>^ value) sealed;
}
abstract EmbeddedTypeDefitionsLocations : IEnumerable<EmbeddedTypeDefitionsLocation> with get, set
override EmbeddedTypeDefitionsLocations : IEnumerable<EmbeddedTypeDefitionsLocation> with get, set

Property Value

Type: IEnumerableEmbeddedTypeDefitionsLocation

Implements

ITypeDefinitionsLocator.EmbeddedTypeDefitionsLocations
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.Executed Property

ScriptRunExecuted Property
Gets boolean value indicating that script has been compiled and ready to be executed.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Executed { get; }
Public Overridable ReadOnly Property Executed As Boolean
    Get
public:
virtual property bool Executed {
    bool get ();
}
abstract Executed : bool with get
override Executed : bool with get

Property Value

Type: Boolean

Implements

IScriptRunBaseExecuted
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.LoadUserTypeDefinitions Property

ScriptRunLoadUserTypeDefinitions Property
Gets or sets whether users type definitions should be loaded.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadUserTypeDefinitions { get; set; }
Public Property LoadUserTypeDefinitions As Boolean
    Get
    Set
public:
virtual property bool LoadUserTypeDefinitions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract LoadUserTypeDefinitions : bool with get, set
override LoadUserTypeDefinitions : bool with get, set

Property Value

Type: Boolean

Implements

ITypeDefinitionsLocator.LoadUserTypeDefinitions
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.ProjectDirectory Property

ScriptRunProjectDirectory Property
Gets or sets root project directory.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectDirectory { get; set; }
Public Property ProjectDirectory As String
    Get
    Set
public:
virtual property String^ ProjectDirectory {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ProjectDirectory : string with get, set
override ProjectDirectory : string with get, set

Property Value

Type: String

Implements

ITypeDefinitionsLocator.ProjectDirectory
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.ScriptHost Property

ScriptRunScriptHost Property
Returns object that implements IScriptHost interface for this runner.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptHost ScriptHost { get; set; }
Public Overridable Property ScriptHost As IScriptHost
    Get
    Set
public:
virtual property IScriptHost^ ScriptHost {
    IScriptHost^ get ();
    void set (IScriptHost^ value);
}
abstract ScriptHost : IScriptHost with get, set
override ScriptHost : IScriptHost with get, set

Property Value

Type: IScriptHost

Implements

IScriptRunScriptHost
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.ScriptLanguage Property

ScriptRunScriptLanguage Property
Gets or sets programming language of the script.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptLanguage ScriptLanguage { get; set; }
Public Property ScriptLanguage As ScriptLanguage
    Get
    Set
public:
virtual property ScriptLanguage ScriptLanguage {
    ScriptLanguage get () sealed;
    void set (ScriptLanguage value) sealed;
}
abstract ScriptLanguage : ScriptLanguage with get, set
override ScriptLanguage : ScriptLanguage with get, set

Property Value

Type: ScriptLanguage

Implements

IScriptRunScriptLanguage
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.ScriptSource Property

ScriptRunScriptSource Property
Gets source of the script to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptSource ScriptSource { get; }
Public ReadOnly Property ScriptSource As IScriptSource
    Get
public:
virtual property IScriptSource^ ScriptSource {
    IScriptSource^ get () sealed;
}
abstract ScriptSource : IScriptSource with get
override ScriptSource : IScriptSource with get

Property Value

Type: IScriptSource

Implements

IScriptRunScriptSource
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.TypeDefinitionsSearchPaths Property

ScriptRunTypeDefinitionsSearchPaths Property
Gets or sets list of search directories to look for type definitions.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> TypeDefinitionsSearchPaths { get; set; }
Public Property TypeDefinitionsSearchPaths As IEnumerable(Of String)
    Get
    Set
public:
virtual property IEnumerable<String^>^ TypeDefinitionsSearchPaths {
    IEnumerable<String^>^ get () sealed;
    void set (IEnumerable<String^>^ value) sealed;
}
abstract TypeDefinitionsSearchPaths : IEnumerable<string> with get, set
override TypeDefinitionsSearchPaths : IEnumerable<string> with get, set

Property Value

Type: IEnumerableString

Implements

ITypeDefinitionsLocator.TypeDefinitionsSearchPaths
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.WaitForDebuggerOnStart Property

ScriptRunWaitForDebuggerOnStart Property
Gets of sets a boolean value indicates whether script engine is to wait for a debugger connection and schedule a pause before executing the first line of application script code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForDebuggerOnStart { get; set; }
Public Property WaitForDebuggerOnStart As Boolean
    Get
    Set
public:
virtual property bool WaitForDebuggerOnStart {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract WaitForDebuggerOnStart : bool with get, set
override WaitForDebuggerOnStart : bool with get, set

Property Value

Type: Boolean

Implements

IScriptRunWaitForDebuggerOnStart
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun Events

ScriptRun Events

The ScriptRun type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileLoad | Occurs when script code is loaded from file.
Public event | ScriptCompiled | Occurs when the script engine running successfully.
Public event | ScriptError | Occurs when the script engine running is failed.
Public event | ScriptExecuted | Occurs when script engine executes the script.
Public event | ScriptReset | Occurs when the script engine is reset.
Public event | ScriptRunning | Occurs when script engine tries to running script.
Top
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.FileLoad Event

ScriptRunFileLoad Event
Occurs when script code is loaded from file.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileLoadEventArgs> FileLoad
Public Event FileLoad As EventHandler(Of FileLoadEventArgs)
public:
virtual  event EventHandler<FileLoadEventArgs^>^ FileLoad {
    void add (EventHandler<FileLoadEventArgs^>^ value);
    void remove (EventHandler<FileLoadEventArgs^>^ value);
}
abstract FileLoad : IEvent<EventHandler<FileLoadEventArgs>,
    FileLoadEventArgs>
override FileLoad : IEvent<EventHandler<FileLoadEventArgs>,
    FileLoadEventArgs>

Value

Type: SystemEventHandlerFileLoadEventArgs

Implements

IScriptRunBaseFileLoad
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.ScriptCompiled Event

ScriptRunScriptCompiled Event
Occurs when the script engine running successfully.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptCompiled
Public Event ScriptCompiled As EventHandler
public:
virtual  event EventHandler^ ScriptCompiled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptCompiled : IEvent<EventHandler,
    EventArgs>
override ScriptCompiled : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptCompiled
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.ScriptError Event

ScriptRunScriptError Event
Occurs when the script engine running is failed.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ScriptErrorEventArgs> ScriptError
Public Event ScriptError As EventHandler(Of ScriptErrorEventArgs)
public:
virtual  event EventHandler<ScriptErrorEventArgs^>^ ScriptError {
    void add (EventHandler<ScriptErrorEventArgs^>^ value);
    void remove (EventHandler<ScriptErrorEventArgs^>^ value);
}
abstract ScriptError : IEvent<EventHandler<ScriptErrorEventArgs>,
    ScriptErrorEventArgs>
override ScriptError : IEvent<EventHandler<ScriptErrorEventArgs>,
    ScriptErrorEventArgs>

Value

Type: SystemEventHandlerScriptErrorEventArgs

Implements

IScriptRunBaseScriptError
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.ScriptExecuted Event

ScriptRunScriptExecuted Event
Occurs when script engine executes the script.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptExecuted
Public Event ScriptExecuted As EventHandler
public:
virtual  event EventHandler^ ScriptExecuted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptExecuted : IEvent<EventHandler,
    EventArgs>
override ScriptExecuted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptExecuted
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.ScriptReset Event

ScriptRunScriptReset Event
Occurs when the script engine is reset.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptReset
Public Event ScriptReset As EventHandler
public:
virtual  event EventHandler^ ScriptReset {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptReset : IEvent<EventHandler,
    EventArgs>
override ScriptReset : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptReset
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptRun.ScriptRunning Event

ScriptRunScriptRunning Event
Occurs when script engine tries to running script.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScriptRunning
Public Event ScriptRunning As EventHandler
public:
virtual  event EventHandler^ ScriptRunning {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ScriptRunning : IEvent<EventHandler,
    EventArgs>
override ScriptRunning : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IScriptRunBaseScriptRunning
See Also

Reference

ScriptRun Class
Alternet.Scripter.TypeScript Namespace


ScriptSource Class

ScriptSource Class
Provides methods and properties to work with script text, files or projects.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.TypeScriptScriptSource

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptSource : IScriptSource,
    IScriptSourceBase, ICloneable, IEquatable<IScriptSource>
Public Class ScriptSource
    Implements IScriptSource, IScriptSourceBase, ICloneable, IEquatable(Of IScriptSource)
public ref class ScriptSource : IScriptSource,
    IScriptSourceBase, ICloneable, IEquatable<IScriptSource^>
type ScriptSource =
    class
        interface IScriptSource
        interface IScriptSourceBase
        interface ICloneable
        interface IEquatable<IScriptSource>
    end

The ScriptSource type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptSource | Initializes a new instance of the ScriptSource class with specified script runner.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ScriptSource object.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IScriptSource) | Determines whether the specified IScriptSource is equal to the current ScriptSource.
Public method | FromExpression | Loads script source from the expression.
Public method | FromScriptCode(String) | Loads script source from the script code.
Public method | FromScriptCode(String, String) | Loads script source from the script code.
Public method | FromScriptFile | Loads script source from the script file.
Public method | FromScriptProject | Loads script source from the Visual Studio project.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLastModifiedDate | Gets file date time when script source was compiled.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBeenModified | Compares file modification dates against to other script source.
Public method | Reset | Clears script source.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Changed | Gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Expression | Gets expression to evaluate.
Public property | Files | Gets list of files containing script to execute.
Public property | HasExpression | Returns boolean value indicating whether ScriptSource contains expression to evaluate.
Public property | HasProject | Returns boolean value indicating whether ScriptSource is associated with the project.
Public property | HasScriptCode | Returns boolean value indicating whether ScriptSource contains script code to execute.
Public property | HasScriptFile | Returns boolean value indicating whether ScriptSource contains script file to execute.
Public property | Language | Returns script programming language.
Public property | ProjectFileName | Gets a file name of the Visual Studio project containing script files to execute.
Public property | ProjectName | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | RootNamespace | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | ScriptCode | Gets script code to execute.
Public property | ScriptFile | Gets single script file to execute.
Public property | SearchPaths | Gets list of search directories to look for source files.
Top
See Also

Reference

Alternet.Scripter.TypeScript Namespace


ScriptSource Constructor

ScriptSource Constructor
Initializes a new instance of the ScriptSource class with specified script runner.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptSource(
    IScriptRun scriptRun
)
Public Sub New (
    scriptRun As IScriptRun
)
public:
ScriptSource(
    IScriptRun^ scriptRun
)
new :
        scriptRun : IScriptRun -> ScriptSource

Parameters

scriptRun
Type: Alternet.Scripter.TypeScriptIScriptRun
Specifies object that implements IScriptRun interface for this new instance.
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource Methods

ScriptSource Methods

The ScriptSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ScriptSource object.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IScriptSource) | Determines whether the specified IScriptSource is equal to the current ScriptSource.
Public method | FromExpression | Loads script source from the expression.
Public method | FromScriptCode(String) | Loads script source from the script code.
Public method | FromScriptCode(String, String) | Loads script source from the script code.
Public method | FromScriptFile | Loads script source from the script file.
Public method | FromScriptProject | Loads script source from the Visual Studio project.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLastModifiedDate | Gets file date time when script source was compiled.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBeenModified | Compares file modification dates against to other script source.
Public method | Reset | Clears script source.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.Clone Method

ScriptSourceClone Method
Creates a new object that is a copy of the current ScriptSource object.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of ScriptSource that is the memberwise clone of the current ScriptSource object.

Implements

ICloneableClone
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.Equals Method

ScriptSourceEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IScriptSource) | Determines whether the specified IScriptSource is equal to the current ScriptSource.
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.Equals Method (IScriptSource)

ScriptSourceEquals Method (IScriptSource)
Determines whether the specified IScriptSource is equal to the current ScriptSource.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IScriptSource other
)
Public Function Equals (
    other As IScriptSource
) As Boolean
public:
virtual bool Equals(
    IScriptSource^ other
) sealed
abstract Equals :
        other : IScriptSource -> bool
override Equals :
        other : IScriptSource -> bool

Parameters

other
Type: Alternet.Scripter.TypeScriptIScriptSource
The IScriptSource to compare with the current source.

Return Value

Type: Boolean
True if the specified source is equal to the current source; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

ScriptSource Class
Equals Overload
Alternet.Scripter.TypeScript Namespace


ScriptSource.FromExpression Method

ScriptSourceFromExpression Method
Loads script source from the expression.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromExpression(
    string expression
)
Public Overridable Function FromExpression (
    expression As String
) As IScriptSource
public:
virtual IScriptSource^ FromExpression(
    String^ expression
)
abstract FromExpression :
        expression : string -> IScriptSource
override FromExpression :
        expression : string -> IScriptSource

Parameters

expression
Type: SystemString
Expression to evaluate.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromExpression(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.FromScriptCode Method

ScriptSourceFromScriptCode Method
Overload List
 | Name | Description
Public method | FromScriptCode(String) | Loads script source from the script code.
Public method | FromScriptCode(String, String) | Loads script source from the script code.
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.FromScriptCode Method (String)

ScriptSourceFromScriptCode Method (String)
Loads script source from the script code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptCode(
    string scriptCode
)
Public Overridable Function FromScriptCode (
    scriptCode As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptCode(
    String^ scriptCode
)
abstract FromScriptCode :
        scriptCode : string -> IScriptSource
override FromScriptCode :
        scriptCode : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptCode(String)
See Also

Reference

ScriptSource Class
FromScriptCode Overload
Alternet.Scripter.TypeScript Namespace


ScriptSource.FromScriptCode Method (String, String)

ScriptSourceFromScriptCode Method (String, String)
Loads script source from the script code.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptCode(
    string scriptCode,
    string fileName
)
Public Overridable Function FromScriptCode (
    scriptCode As String,
    fileName As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptCode(
    String^ scriptCode,
    String^ fileName
)
abstract FromScriptCode :
        scriptCode : string *
        fileName : string -> IScriptSource
override FromScriptCode :
        scriptCode : string *
        fileName : string -> IScriptSource

Parameters

scriptCode
Type: SystemString
Script code to execute.
fileName
Type: SystemString
Specifis name if the file containing script code.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptCode(String, String)
See Also

Reference

ScriptSource Class
FromScriptCode Overload
Alternet.Scripter.TypeScript Namespace


ScriptSource.FromScriptFile Method

ScriptSourceFromScriptFile Method
Loads script source from the script file.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptFile(
    string fileName
)
Public Overridable Function FromScriptFile (
    fileName As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptFile(
    String^ fileName
)
abstract FromScriptFile :
        fileName : string -> IScriptSource
override FromScriptFile :
        fileName : string -> IScriptSource

Parameters

fileName
Type: SystemString
File Name to load the script.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptFile(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.FromScriptProject Method

ScriptSourceFromScriptProject Method
Loads script source from the Visual Studio project.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IScriptSource FromScriptProject(
    string projectFileName
)
Public Overridable Function FromScriptProject (
    projectFileName As String
) As IScriptSource
public:
virtual IScriptSource^ FromScriptProject(
    String^ projectFileName
)
abstract FromScriptProject :
        projectFileName : string -> IScriptSource
override FromScriptProject :
        projectFileName : string -> IScriptSource

Parameters

projectFileName
Type: SystemString
Project file name to load script.

Return Value

Type: IScriptSource
Modified IScrptSource instance

Implements

IScriptSourceFromScriptProject(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.GetLastModifiedDate Method

ScriptSourceGetLastModifiedDate Method
Gets file date time when script source was compiled.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime GetLastModifiedDate(
    string fileName
)
Public Function GetLastModifiedDate (
    fileName As String
) As DateTime
public:
virtual DateTime GetLastModifiedDate(
    String^ fileName
) sealed
abstract GetLastModifiedDate :
        fileName : string -> DateTime
override GetLastModifiedDate :
        fileName : string -> DateTime

Parameters

fileName
Type: SystemString
FileName to check last modified date.

Return Value

Type: DateTime
File date of the given file at the time it was compiled.

Implements

IScriptSourceGetLastModifiedDate(String)
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.HasBeenModified Method

ScriptSourceHasBeenModified Method
Compares file modification dates against to other script source.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBeenModified(
    IScriptSource other
)
Public Function HasBeenModified (
    other As IScriptSource
) As Boolean
public:
virtual bool HasBeenModified(
    IScriptSource^ other
) sealed
abstract HasBeenModified :
        other : IScriptSource -> bool
override HasBeenModified :
        other : IScriptSource -> bool

Parameters

other
Type: Alternet.Scripter.TypeScriptIScriptSource
IScriptSource to compare.

Return Value

Type: Boolean
True, if source has been changed since last compilation; otherwise false.

Implements

IScriptSourceHasBeenModified(IScriptSource)
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.Reset Method

ScriptSourceReset Method
Clears script source.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IScriptSourceReset
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource Properties

ScriptSource Properties

The ScriptSource type exposes the following members.

Properties
 | Name | Description
Public property | Changed | Gets or sets boolean value indicating if script source has been modified since last compilation.
Public property | Expression | Gets expression to evaluate.
Public property | Files | Gets list of files containing script to execute.
Public property | HasExpression | Returns boolean value indicating whether ScriptSource contains expression to evaluate.
Public property | HasProject | Returns boolean value indicating whether ScriptSource is associated with the project.
Public property | HasScriptCode | Returns boolean value indicating whether ScriptSource contains script code to execute.
Public property | HasScriptFile | Returns boolean value indicating whether ScriptSource contains script file to execute.
Public property | Language | Returns script programming language.
Public property | ProjectFileName | Gets a file name of the Visual Studio project containing script files to execute.
Public property | ProjectName | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | RootNamespace | Gets or sets name of the Visual Studio project containing script files to execute.
Public property | ScriptCode | Gets script code to execute.
Public property | ScriptFile | Gets single script file to execute.
Public property | SearchPaths | Gets list of search directories to look for source files.
Top
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.Changed Property

ScriptSourceChanged Property
Gets or sets boolean value indicating if script source has been modified since last compilation.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Changed { get; set; }
Public Property Changed As Boolean
    Get
    Set
public:
virtual property bool Changed {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Changed : bool with get, set
override Changed : bool with get, set

Property Value

Type: Boolean

Implements

IScriptSourceChanged
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.Expression Property

ScriptSourceExpression Property
Gets expression to evaluate.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; }
Public ReadOnly Property Expression As String
    Get
public:
virtual property String^ Expression {
    String^ get () sealed;
}
abstract Expression : string with get
override Expression : string with get

Property Value

Type: String

Implements

IScriptSourceBaseExpression
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.Files Property

ScriptSourceFiles Property
Gets list of files containing script to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Files { get; }
Public ReadOnly Property Files As IList(Of String)
    Get
public:
virtual property IList<String^>^ Files {
    IList<String^>^ get () sealed;
}
abstract Files : IList<string> with get
override Files : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceFiles
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.HasExpression Property

ScriptSourceHasExpression Property
Returns boolean value indicating whether ScriptSource contains expression to evaluate.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasExpression { get; }
Public ReadOnly Property HasExpression As Boolean
    Get
public:
virtual property bool HasExpression {
    bool get () sealed;
}
abstract HasExpression : bool with get
override HasExpression : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasExpression
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.HasProject Property

ScriptSourceHasProject Property
Returns boolean value indicating whether ScriptSource is associated with the project.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasProject { get; }
Public ReadOnly Property HasProject As Boolean
    Get
public:
virtual property bool HasProject {
    bool get () sealed;
}
abstract HasProject : bool with get
override HasProject : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasProject
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.HasScriptCode Property

ScriptSourceHasScriptCode Property
Returns boolean value indicating whether ScriptSource contains script code to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasScriptCode { get; }
Public ReadOnly Property HasScriptCode As Boolean
    Get
public:
virtual property bool HasScriptCode {
    bool get () sealed;
}
abstract HasScriptCode : bool with get
override HasScriptCode : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasScriptCode
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.HasScriptFile Property

ScriptSourceHasScriptFile Property
Returns boolean value indicating whether ScriptSource contains script file to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasScriptFile { get; }
Public ReadOnly Property HasScriptFile As Boolean
    Get
public:
virtual property bool HasScriptFile {
    bool get () sealed;
}
abstract HasScriptFile : bool with get
override HasScriptFile : bool with get

Property Value

Type: Boolean

Implements

IScriptSourceBaseHasScriptFile
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.Language Property

ScriptSourceLanguage Property
Returns script programming language.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptLanguage Language { get; }
Public ReadOnly Property Language As ScriptLanguage
    Get
public:
virtual property ScriptLanguage Language {
    ScriptLanguage get () sealed;
}
abstract Language : ScriptLanguage with get
override Language : ScriptLanguage with get

Property Value

Type: ScriptLanguage

Implements

IScriptSourceLanguage
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.ProjectFileName Property

ScriptSourceProjectFileName Property
Gets a file name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectFileName { get; }
Public ReadOnly Property ProjectFileName As String
    Get
public:
virtual property String^ ProjectFileName {
    String^ get () sealed;
}
abstract ProjectFileName : string with get
override ProjectFileName : string with get

Property Value

Type: String

Implements

IScriptSourceBaseProjectFileName
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.ProjectName Property

ScriptSourceProjectName Property
Gets or sets name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectName { get; set; }
Public Property ProjectName As String
    Get
    Set
public:
virtual property String^ ProjectName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ProjectName : string with get, set
override ProjectName : string with get, set

Property Value

Type: String

Implements

IScriptSourceProjectName
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.RootNamespace Property

ScriptSourceRootNamespace Property
Gets or sets name of the Visual Studio project containing script files to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RootNamespace { get; set; }
Public Property RootNamespace As String
    Get
    Set
public:
virtual property String^ RootNamespace {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract RootNamespace : string with get, set
override RootNamespace : string with get, set

Property Value

Type: String

Implements

IScriptSourceRootNamespace
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.ScriptCode Property

ScriptSourceScriptCode Property
Gets script code to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptCode { get; }
Public ReadOnly Property ScriptCode As String
    Get
public:
virtual property String^ ScriptCode {
    String^ get () sealed;
}
abstract ScriptCode : string with get
override ScriptCode : string with get

Property Value

Type: String

Implements

IScriptSourceBaseScriptCode
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.ScriptFile Property

ScriptSourceScriptFile Property
Gets single script file to execute.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptFile { get; }
Public ReadOnly Property ScriptFile As String
    Get
public:
virtual property String^ ScriptFile {
    String^ get () sealed;
}
abstract ScriptFile : string with get
override ScriptFile : string with get

Property Value

Type: String

Implements

IScriptSourceBaseScriptFile
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


ScriptSource.SearchPaths Property

ScriptSourceSearchPaths Property
Gets list of search directories to look for source files.

Namespace: Alternet.Scripter.TypeScript
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> SearchPaths { get; }
Public ReadOnly Property SearchPaths As IList(Of String)
    Get
public:
virtual property IList<String^>^ SearchPaths {
    IList<String^>^ get () sealed;
}
abstract SearchPaths : IList<string> with get
override SearchPaths : IList<string> with get

Property Value

Type: IListString

Implements

IScriptSourceSearchPaths
See Also

Reference

ScriptSource Class
Alternet.Scripter.TypeScript Namespace


Alternet.Scripter.TypeScript.License Namespace

Alternet.Scripter.TypeScript.License Namespace
Classes
 | Class | Description
Public class | ScripterLicenseProvider | Implements license provider for ScriptRun.


ScripterLicenseProvider Class

ScripterLicenseProvider Class
Implements license provider for ScriptRun.
Inheritance Hierarchy
SystemObject
System.ComponentModelLicenseProvider
ComponentLicenseProvider
Alternet.Scripter.TypeScript.LicenseScripterLicenseProvider

Namespace: Alternet.Scripter.TypeScript.License
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScripterLicenseProvider : ComponentLicenseProvider
Public Class ScripterLicenseProvider
    Inherits ComponentLicenseProvider
public ref class ScripterLicenseProvider : public ComponentLicenseProvider
type ScripterLicenseProvider =
    class
        inherit ComponentLicenseProvider
    end

The ScripterLicenseProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ScripterLicenseProvider | Initializes a new instance of the ScripterLicenseProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLicense | When overridden in a derived class, gets a license for an instance or type of component, when given a context and whether the denial of a license throws an exception. (Inherited from LicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.TypeScript.License Namespace


ScripterLicenseProvider Constructor

ScripterLicenseProvider Constructor
Initializes a new instance of the ScripterLicenseProvider class

Namespace: Alternet.Scripter.TypeScript.License
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScripterLicenseProvider()
Public Sub New
public:
ScripterLicenseProvider()
new : unit -> ScripterLicenseProvider
See Also

Reference

ScripterLicenseProvider Class
Alternet.Scripter.TypeScript.License Namespace


ScripterLicenseProvider Methods

ScripterLicenseProvider Methods

The ScripterLicenseProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLicense | When overridden in a derived class, gets a license for an instance or type of component, when given a context and whether the denial of a license throws an exception. (Inherited from LicenseProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScripterLicenseProvider Class
Alternet.Scripter.TypeScript.License Namespace


Alternet.Scripter.TypeScript.SourceMaps Namespace

Alternet.Scripter.TypeScript.SourceMaps Namespace
Classes
 | Class | Description
Public class | MappingEntry | Represents properties and methods to bound between a particular positions inside original and generated source code.
Public class | SourceMap | Represents properties and methods to map between original source code and generated source code.
Public class | SourcePosition | Represents properties and methods to describe a particular position inside script text.


MappingEntry Class

MappingEntry Class
Represents properties and methods to bound between a particular positions inside original and generated source code.
Inheritance Hierarchy
SystemObject
ValueObjectMappingEntry
Alternet.Scripter.TypeScript.SourceMapsMappingEntry

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MappingEntry : ValueObject<MappingEntry>
Public Class MappingEntry
    Inherits ValueObject(Of MappingEntry)
public ref class MappingEntry : public ValueObject<MappingEntry^>
type MappingEntry =
    class
        inherit ValueObject<MappingEntry>
    end

The MappingEntry type exposes the following members.

Constructors
 | Name | Description
Public method | MappingEntry | Initializes a new instance of the MappingEntry class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithOriginalFileName | Creates a new MappingEntry that contains the changed OriginalSourcePosition.
Top
Properties
 | Name | Description
Public property | GeneratedSourcePosition | The location of the line of code in the transformed code
Public property | OriginalFileName | The name of the file that originally contained this code
Public property | OriginalName | The original name of the code referenced by this mapping entry
Public property | OriginalSourcePosition | The location of the code in the original source code
Top
See Also

Reference

Alternet.Scripter.TypeScript.SourceMaps Namespace


MappingEntry Constructor

MappingEntry Constructor
Initializes a new instance of the MappingEntry class with specified parameters.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MappingEntry(
    SourcePosition generatedSourcePosition,
    SourcePosition originalSourcePosition,
    string originalName,
    string originalFileName
)
Public Sub New (
    generatedSourcePosition As SourcePosition,
    originalSourcePosition As SourcePosition,
    originalName As String,
    originalFileName As String
)
public:
MappingEntry(
    SourcePosition^ generatedSourcePosition,
    SourcePosition^ originalSourcePosition,
    String^ originalName,
    String^ originalFileName
)
new :
        generatedSourcePosition : SourcePosition *
        originalSourcePosition : SourcePosition *
        originalName : string *
        originalFileName : string -> MappingEntry

Parameters

generatedSourcePosition
Type: Alternet.Scripter.TypeScript.SourceMapsSourcePosition
The location of the line of code in the transformed code
originalSourcePosition
Type: Alternet.Scripter.TypeScript.SourceMapsSourcePosition
The location of the code in the original source code
originalName
Type: SystemString
The original name of the code referenced by this mapping entry
originalFileName
Type: SystemString
The name of the file that originally contained this code
See Also

Reference

MappingEntry Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


MappingEntry Methods

MappingEntry Methods

The MappingEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WithOriginalFileName | Creates a new MappingEntry that contains the changed OriginalSourcePosition.
Top
See Also

Reference

MappingEntry Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


MappingEntry.WithOriginalFileName Method

MappingEntryWithOriginalFileName Method
Creates a new MappingEntry that contains the changed OriginalSourcePosition.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MappingEntry WithOriginalFileName(
    string value
)
Public Function WithOriginalFileName (
    value As String
) As MappingEntry
public:
MappingEntry^ WithOriginalFileName(
    String^ value
)
member WithOriginalFileName :
        value : string -> MappingEntry

Parameters

value
Type: SystemString
New OriginalSourcePosition value.

Return Value

Type: MappingEntry
Updated MappingEntry.
See Also

Reference

MappingEntry Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


MappingEntry Properties

MappingEntry Properties

The MappingEntry type exposes the following members.

Properties
 | Name | Description
Public property | GeneratedSourcePosition | The location of the line of code in the transformed code
Public property | OriginalFileName | The name of the file that originally contained this code
Public property | OriginalName | The original name of the code referenced by this mapping entry
Public property | OriginalSourcePosition | The location of the code in the original source code
Top
See Also

Reference

MappingEntry Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


MappingEntry.GeneratedSourcePosition Property

MappingEntryGeneratedSourcePosition Property
The location of the line of code in the transformed code

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SourcePosition GeneratedSourcePosition { get; }
Public ReadOnly Property GeneratedSourcePosition As SourcePosition
    Get
public:
property SourcePosition^ GeneratedSourcePosition {
    SourcePosition^ get ();
}
member GeneratedSourcePosition : SourcePosition with get

Property Value

Type: SourcePosition
See Also

Reference

MappingEntry Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


MappingEntry.OriginalFileName Property

MappingEntryOriginalFileName Property
The name of the file that originally contained this code

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalFileName { get; }
Public ReadOnly Property OriginalFileName As String
    Get
public:
property String^ OriginalFileName {
    String^ get ();
}
member OriginalFileName : string with get

Property Value

Type: String
See Also

Reference

MappingEntry Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


MappingEntry.OriginalName Property

MappingEntryOriginalName Property
The original name of the code referenced by this mapping entry

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalName { get; }
Public ReadOnly Property OriginalName As String
    Get
public:
property String^ OriginalName {
    String^ get ();
}
member OriginalName : string with get

Property Value

Type: String
See Also

Reference

MappingEntry Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


MappingEntry.OriginalSourcePosition Property

MappingEntryOriginalSourcePosition Property
The location of the code in the original source code

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SourcePosition OriginalSourcePosition { get; }
Public ReadOnly Property OriginalSourcePosition As SourcePosition
    Get
public:
property SourcePosition^ OriginalSourcePosition {
    SourcePosition^ get ();
}
member OriginalSourcePosition : SourcePosition with get

Property Value

Type: SourcePosition
See Also

Reference

MappingEntry Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourceMap Class

SourceMap Class
Represents properties and methods to map between original source code and generated source code.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.TypeScript.SourceMapsSourceMap

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SourceMap
Public Class SourceMap
public ref class SourceMap
type SourceMap =  class end

The SourceMap type exposes the following members.

Constructors
 | Name | Description
Public method | SourceMap | Initializes a new instance of the SourceMap class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMappingEntryForGeneratedSourcePosition | Finds entry for specified position in the generated source code.
Public method | GetMappingEntryForOriginalSourcePosition | Finds entry for specified position in the original source code.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | GeneratedFileName | Gets name of the generated file.
Top
See Also

Reference

Alternet.Scripter.TypeScript.SourceMaps Namespace


SourceMap Constructor

SourceMap Constructor
Initializes a new instance of the SourceMap class with specified parameters.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SourceMap(
    string generatedFileName,
    SourceMap map
)
Public Sub New (
    generatedFileName As String,
    map As SourceMap
)
public:
SourceMap(
    String^ generatedFileName,
    SourceMap^ map
)
new :
        generatedFileName : string *
        map : SourceMap -> SourceMap

Parameters

generatedFileName
Type: SystemString
Name of the generated file.
map
Type: SourceMap
SourcemapToolkit.SourcemapParser.SourceMap for internal use.
See Also

Reference

SourceMap Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourceMap Methods

SourceMap Methods

The SourceMap type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMappingEntryForGeneratedSourcePosition | Finds entry for specified position in the generated source code.
Public method | GetMappingEntryForOriginalSourcePosition | Finds entry for specified position in the original source code.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SourceMap Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourceMap.GetMappingEntryForGeneratedSourcePosition Method

SourceMapGetMappingEntryForGeneratedSourcePosition Method
Finds entry for specified position in the generated source code.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MappingEntry GetMappingEntryForGeneratedSourcePosition(
    SourcePosition generatedSourcePosition
)
Public Function GetMappingEntryForGeneratedSourcePosition (
    generatedSourcePosition As SourcePosition
) As MappingEntry
public:
MappingEntry^ GetMappingEntryForGeneratedSourcePosition(
    SourcePosition^ generatedSourcePosition
)
member GetMappingEntryForGeneratedSourcePosition :
        generatedSourcePosition : SourcePosition -> MappingEntry

Parameters

generatedSourcePosition
Type: Alternet.Scripter.TypeScript.SourceMapsSourcePosition
Position in the generated source code.

Return Value

Type: MappingEntry
MappingEntry if succeed; otherwise null.
See Also

Reference

SourceMap Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourceMap.GetMappingEntryForOriginalSourcePosition Method

SourceMapGetMappingEntryForOriginalSourcePosition Method
Finds entry for specified position in the original source code.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual MappingEntry GetMappingEntryForOriginalSourcePosition(
    string originalFileName,
    SourcePosition originalSourcePosition
)
Public Overridable Function GetMappingEntryForOriginalSourcePosition (
    originalFileName As String,
    originalSourcePosition As SourcePosition
) As MappingEntry
public:
virtual MappingEntry^ GetMappingEntryForOriginalSourcePosition(
    String^ originalFileName,
    SourcePosition^ originalSourcePosition
)
abstract GetMappingEntryForOriginalSourcePosition :
        originalFileName : string *
        originalSourcePosition : SourcePosition -> MappingEntry
override GetMappingEntryForOriginalSourcePosition :
        originalFileName : string *
        originalSourcePosition : SourcePosition -> MappingEntry

Parameters

originalFileName
Type: SystemString
File name of the original source code.
originalSourcePosition
Type: Alternet.Scripter.TypeScript.SourceMapsSourcePosition
Position in the original source code.

Return Value

Type: MappingEntry
MappingEntry if succeed; otherwise null.
See Also

Reference

SourceMap Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourceMap Properties

SourceMap Properties

The SourceMap type exposes the following members.

Properties
 | Name | Description
Public property | GeneratedFileName | Gets name of the generated file.
Top
See Also

Reference

SourceMap Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourceMap.GeneratedFileName Property

SourceMapGeneratedFileName Property
Gets name of the generated file.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GeneratedFileName { get; }
Public ReadOnly Property GeneratedFileName As String
    Get
public:
property String^ GeneratedFileName {
    String^ get ();
}
member GeneratedFileName : string with get

Property Value

Type: String
See Also

Reference

SourceMap Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourcePosition Class

SourcePosition Class
Represents properties and methods to describe a particular position inside script text.
Inheritance Hierarchy
SystemObject
ValueObjectSourcePosition
Alternet.Scripter.TypeScript.SourceMapsSourcePosition

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SourcePosition : ValueObject<SourcePosition>
Public Class SourcePosition
    Inherits ValueObject(Of SourcePosition)
public ref class SourcePosition : public ValueObject<SourcePosition^>
type SourcePosition =
    class
        inherit ValueObject<SourcePosition>
    end

The SourcePosition type exposes the following members.

Constructors
 | Name | Description
Public method | SourcePosition | Initializes a new instance of the SourcePosition class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | ZeroBasedColumnNumber | Gets zero-based column number.
Public property | ZeroBasedLineNumber | Gets zero-based line number.
Top
See Also

Reference

Alternet.Scripter.TypeScript.SourceMaps Namespace


SourcePosition Constructor

SourcePosition Constructor
Initializes a new instance of the SourcePosition class with specified parameters.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SourcePosition(
    int zeroBasedLineNumber,
    int zeroBasedColumnNumber
)
Public Sub New (
    zeroBasedLineNumber As Integer,
    zeroBasedColumnNumber As Integer
)
public:
SourcePosition(
    int zeroBasedLineNumber,
    int zeroBasedColumnNumber
)
new :
        zeroBasedLineNumber : int *
        zeroBasedColumnNumber : int -> SourcePosition

Parameters

zeroBasedLineNumber
Type: SystemInt32
Zero-based line number.
zeroBasedColumnNumber
Type: SystemInt32
Zero-based column number.
See Also

Reference

SourcePosition Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourcePosition Methods

SourcePosition Methods

The SourcePosition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Top
See Also

Reference

SourcePosition Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourcePosition.ToString Method

SourcePositionToString Method
Returns a string that represents the current object.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A string that represents the current object.
See Also

Reference

SourcePosition Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourcePosition Properties

SourcePosition Properties

The SourcePosition type exposes the following members.

Properties
 | Name | Description
Public property | ZeroBasedColumnNumber | Gets zero-based column number.
Public property | ZeroBasedLineNumber | Gets zero-based line number.
Top
See Also

Reference

SourcePosition Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourcePosition.ZeroBasedColumnNumber Property

SourcePositionZeroBasedColumnNumber Property
Gets zero-based column number.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ZeroBasedColumnNumber { get; }
Public ReadOnly Property ZeroBasedColumnNumber As Integer
    Get
public:
property int ZeroBasedColumnNumber {
    int get ();
}
member ZeroBasedColumnNumber : int with get

Property Value

Type: Int32
See Also

Reference

SourcePosition Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


SourcePosition.ZeroBasedLineNumber Property

SourcePositionZeroBasedLineNumber Property
Gets zero-based line number.

Namespace: Alternet.Scripter.TypeScript.SourceMaps
Assembly: Alternet.Scripter.TypeScript.v7 (in Alternet.Scripter.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ZeroBasedLineNumber { get; }
Public ReadOnly Property ZeroBasedLineNumber As Integer
    Get
public:
property int ZeroBasedLineNumber {
    int get ();
}
member ZeroBasedLineNumber : int with get

Property Value

Type: Int32
See Also

Reference

SourcePosition Class
Alternet.Scripter.TypeScript.SourceMaps Namespace


Alternet.Scripter.XAML Namespace

Alternet.Scripter.XAML Namespace
Classes
 | Class | Description
Public class | XAMLExtensions | Provides methods to manipulate xaml content.
Public class | XAMLExtensionsFakeBuildEngine |


XAMLExtensions Class

XAMLExtensions Class
Provides methods to manipulate xaml content.
Inheritance Hierarchy
SystemObject
Alternet.Scripter.XAMLXAMLExtensions

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XAMLExtensions
Public Class XAMLExtensions
public ref class XAMLExtensions
type XAMLExtensions =  class end

The XAMLExtensions type exposes the following members.

Constructors
 | Name | Description
Public method | XAMLExtensions | Initializes a new instance of the XAMLExtensions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetIntermediateFilesAndResources | Generates code and resources files from given list of xaml files.
 | GetIntermediateFilesAndResourcesForSeparateXamlFiles | Generates code and resources files from given list of xaml files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Scripter.XAML Namespace


XAMLExtensions Constructor

XAMLExtensions Constructor
Initializes a new instance of the XAMLExtensions class

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XAMLExtensions()
Public Sub New
public:
XAMLExtensions()
new : unit -> XAMLExtensions
See Also

Reference

XAMLExtensions Class
Alternet.Scripter.XAML Namespace


XAMLExtensions Methods

XAMLExtensions Methods

The XAMLExtensions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetIntermediateFilesAndResources | Generates code and resources files from given list of xaml files.
 | GetIntermediateFilesAndResourcesForSeparateXamlFiles | Generates code and resources files from given list of xaml files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XAMLExtensions Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.GetIntermediateFilesAndResources Method

XAMLExtensionsGetIntermediateFilesAndResources Method
Generates code and resources files from given list of xaml files.

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Result GetIntermediateFilesAndResources(
    string projectFileName,
    string outputPath,
    string targetAssemblyName,
    ScriptMode scriptMode,
    TargetFramework targetFramework,
    bool isDotNetCore,
    IList<string> files,
    IList<string> resources
)
Public Shared Function GetIntermediateFilesAndResources (
    projectFileName As String,
    outputPath As String,
    targetAssemblyName As String,
    scriptMode As ScriptMode,
    targetFramework As TargetFramework,
    isDotNetCore As Boolean,
    files As IList(Of String),
    resources As IList(Of String)
) As Result
public:
static Result^ GetIntermediateFilesAndResources(
    String^ projectFileName,
    String^ outputPath,
    String^ targetAssemblyName,
    ScriptMode scriptMode,
    TargetFramework^ targetFramework,
    bool isDotNetCore,
    IList<String^>^ files,
    IList<String^>^ resources
)
static member GetIntermediateFilesAndResources :
        projectFileName : string *
        outputPath : string *
        targetAssemblyName : string *
        scriptMode : ScriptMode *
        targetFramework : TargetFramework *
        isDotNetCore : bool *
        files : IList<string> *
        resources : IList<string> -> Result

Parameters

projectFileName
Type: SystemString
The full path to the project file.
outputPath
Type: SystemString
Path where generated files will be stored.
targetAssemblyName
Type: SystemString
scriptMode
Type: Alternet.ScripterScriptMode
Debug or release mode.
targetFramework
Type: Alternet.Common.DotNet.ProjectsTargetFramework
isDotNetCore
Type: SystemBoolean
files
Type: System.Collections.GenericIListString
List of generated code files.
resources
Type: System.Collections.GenericIListString
List of generated resource files.

Return Value

Type: Result
True if succeed; otherwise false.
See Also

Reference

XAMLExtensions Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.GetIntermediateFilesAndResourcesForSeparateXamlFiles Method

XAMLExtensionsGetIntermediateFilesAndResourcesForSeparateXamlFiles Method
Generates code and resources files from given list of xaml files.

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GetIntermediateFilesAndResourcesForSeparateXamlFiles(
    string[] xamlFiles,
    string outputPath,
    string assemblyName,
    ScriptLanguage language,
    string[] assemblyReferences,
    List<string> generatedCodeFiles,
    List<Tuple<string, string>> generatedResourceFiles
)
Public Shared Function GetIntermediateFilesAndResourcesForSeparateXamlFiles (
    xamlFiles As String(),
    outputPath As String,
    assemblyName As String,
    language As ScriptLanguage,
    assemblyReferences As String(),
    generatedCodeFiles As List(Of String),
    generatedResourceFiles As List(Of Tuple(Of String, String))
) As Boolean
public:
static bool GetIntermediateFilesAndResourcesForSeparateXamlFiles(
    array<String^>^ xamlFiles,
    String^ outputPath,
    String^ assemblyName,
    ScriptLanguage language,
    array<String^>^ assemblyReferences,
    List<String^>^ generatedCodeFiles,
    List<Tuple<String^, String^>^>^ generatedResourceFiles
)
static member GetIntermediateFilesAndResourcesForSeparateXamlFiles :
        xamlFiles : string[] *
        outputPath : string *
        assemblyName : string *
        language : ScriptLanguage *
        assemblyReferences : string[] *
        generatedCodeFiles : List<string> *
        generatedResourceFiles : List<Tuple<string, string>> -> bool

Parameters

xamlFiles
Type: SystemString
List of source .xaml files.
outputPath
Type: SystemString
Path where generated files will be stored.
assemblyName
Type: SystemString
Target assembly name.
language
Type: Alternet.ScripterScriptLanguage
The .NET language used to generate code.
assemblyReferences
Type: SystemString
generatedCodeFiles
Type: System.Collections.GenericListString
List of generated code files.
generatedResourceFiles
Type: System.Collections.GenericListTupleString, String
List of generated resource files.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

XAMLExtensions Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine Class

XAMLExtensionsFakeBuildEngine Class
Inheritance Hierarchy
SystemObject
Alternet.Scripter.XAMLXAMLExtensionsFakeBuildEngine

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FakeBuildEngine : IBuildEngine
Public Class FakeBuildEngine
    Implements IBuildEngine
public ref class FakeBuildEngine : IBuildEngine
type FakeBuildEngine =
    class
        interface IBuildEngine
    end

The XAMLExtensionsFakeBuildEngine type exposes the following members.

Constructors
 | Name | Description
Public method | XAMLExtensionsFakeBuildEngine | Initializes a new instance of the XAMLExtensionsFakeBuildEngine class
Top
Methods
 | Name | Description
Public method | BuildProjectFile |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LogCustomEvent |
Public method | LogErrorEvent |
Public method | LogMessageEvent |
Public method | LogWarningEvent |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ErrorsLog |
Public field | Log |
Public field | LogCustomEvents |
Public field | LogErrorEvents |
Public field | LogMessageEvents |
Public field | LogWarningEvents |
Top
Properties
 | Name | Description
Public property | ColumnNumberOfTaskNode |
Public property | ContinueOnError |
Public property | LineNumberOfTaskNode |
Public property | ProjectFileOfTaskNode |
Top
See Also

Reference

Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine Constructor

XAMLExtensionsFakeBuildEngine Constructor
Initializes a new instance of the XAMLExtensionsFakeBuildEngine class

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FakeBuildEngine()
Public Sub New
public:
FakeBuildEngine()
new : unit -> FakeBuildEngine
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


FakeBuildEngine Fields

FakeBuildEngine Fields

The XAMLExtensionsFakeBuildEngine type exposes the following members.

Fields
 | Name | Description
Public field | ErrorsLog |
Public field | Log |
Public field | LogCustomEvents |
Public field | LogErrorEvents |
Public field | LogMessageEvents |
Public field | LogWarningEvents |
Top
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.ErrorsLog Field

XAMLExtensionsFakeBuildEngineErrorsLog Field

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringBuilder ErrorsLog
Public ErrorsLog As StringBuilder
public:
StringBuilder^ ErrorsLog
val mutable ErrorsLog: StringBuilder

Field Value

Type: StringBuilder
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.Log Field

XAMLExtensionsFakeBuildEngineLog Field

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringBuilder Log
Public Log As StringBuilder
public:
StringBuilder^ Log
val mutable Log: StringBuilder

Field Value

Type: StringBuilder
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.LogCustomEvents Field

XAMLExtensionsFakeBuildEngineLogCustomEvents Field

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<CustomBuildEventArgs> LogCustomEvents
Public LogCustomEvents As List(Of CustomBuildEventArgs)
public:
List<CustomBuildEventArgs^>^ LogCustomEvents
val mutable LogCustomEvents: List<CustomBuildEventArgs>

Field Value

Type: ListCustomBuildEventArgs
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.LogErrorEvents Field

XAMLExtensionsFakeBuildEngineLogErrorEvents Field

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<BuildErrorEventArgs> LogErrorEvents
Public LogErrorEvents As List(Of BuildErrorEventArgs)
public:
List<BuildErrorEventArgs^>^ LogErrorEvents
val mutable LogErrorEvents: List<BuildErrorEventArgs>

Field Value

Type: ListBuildErrorEventArgs
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.LogMessageEvents Field

XAMLExtensionsFakeBuildEngineLogMessageEvents Field

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<BuildMessageEventArgs> LogMessageEvents
Public LogMessageEvents As List(Of BuildMessageEventArgs)
public:
List<BuildMessageEventArgs^>^ LogMessageEvents
val mutable LogMessageEvents: List<BuildMessageEventArgs>

Field Value

Type: ListBuildMessageEventArgs
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.LogWarningEvents Field

XAMLExtensionsFakeBuildEngineLogWarningEvents Field

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<BuildWarningEventArgs> LogWarningEvents
Public LogWarningEvents As List(Of BuildWarningEventArgs)
public:
List<BuildWarningEventArgs^>^ LogWarningEvents
val mutable LogWarningEvents: List<BuildWarningEventArgs>

Field Value

Type: ListBuildWarningEventArgs
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


FakeBuildEngine Methods

FakeBuildEngine Methods

The XAMLExtensionsFakeBuildEngine type exposes the following members.

Methods
 | Name | Description
Public method | BuildProjectFile |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LogCustomEvent |
Public method | LogErrorEvent |
Public method | LogMessageEvent |
Public method | LogWarningEvent |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.BuildProjectFile Method

XAMLExtensionsFakeBuildEngineBuildProjectFile Method

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BuildProjectFile(
    string projectFileName,
    string[] targetNames,
    IDictionary globalProperties,
    IDictionary targetOutputs
)
Public Function BuildProjectFile (
    projectFileName As String,
    targetNames As String(),
    globalProperties As IDictionary,
    targetOutputs As IDictionary
) As Boolean
public:
virtual bool BuildProjectFile(
    String^ projectFileName,
    array<String^>^ targetNames,
    IDictionary^ globalProperties,
    IDictionary^ targetOutputs
) sealed
abstract BuildProjectFile :
        projectFileName : string *
        targetNames : string[] *
        globalProperties : IDictionary *
        targetOutputs : IDictionary -> bool
override BuildProjectFile :
        projectFileName : string *
        targetNames : string[] *
        globalProperties : IDictionary *
        targetOutputs : IDictionary -> bool

Parameters

projectFileName
Type: SystemString
targetNames
Type: SystemString
globalProperties
Type: System.CollectionsIDictionary
targetOutputs
Type: System.CollectionsIDictionary

Return Value

Type: Boolean

Implements

IBuildEngineBuildProjectFile(String, String, IDictionary, IDictionary)
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.LogCustomEvent Method

XAMLExtensionsFakeBuildEngineLogCustomEvent Method

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LogCustomEvent(
    CustomBuildEventArgs e
)
Public Sub LogCustomEvent (
    e As CustomBuildEventArgs
)
public:
virtual void LogCustomEvent(
    CustomBuildEventArgs^ e
) sealed
abstract LogCustomEvent :
        e : CustomBuildEventArgs -> unit
override LogCustomEvent :
        e : CustomBuildEventArgs -> unit

Parameters

e
Type: Microsoft.Build.FrameworkCustomBuildEventArgs

Implements

IBuildEngineLogCustomEvent(CustomBuildEventArgs)
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.LogErrorEvent Method

XAMLExtensionsFakeBuildEngineLogErrorEvent Method

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LogErrorEvent(
    BuildErrorEventArgs e
)
Public Sub LogErrorEvent (
    e As BuildErrorEventArgs
)
public:
virtual void LogErrorEvent(
    BuildErrorEventArgs^ e
) sealed
abstract LogErrorEvent :
        e : BuildErrorEventArgs -> unit
override LogErrorEvent :
        e : BuildErrorEventArgs -> unit

Parameters

e
Type: Microsoft.Build.FrameworkBuildErrorEventArgs

Implements

IBuildEngineLogErrorEvent(BuildErrorEventArgs)
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.LogMessageEvent Method

XAMLExtensionsFakeBuildEngineLogMessageEvent Method

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LogMessageEvent(
    BuildMessageEventArgs e
)
Public Sub LogMessageEvent (
    e As BuildMessageEventArgs
)
public:
virtual void LogMessageEvent(
    BuildMessageEventArgs^ e
) sealed
abstract LogMessageEvent :
        e : BuildMessageEventArgs -> unit
override LogMessageEvent :
        e : BuildMessageEventArgs -> unit

Parameters

e
Type: Microsoft.Build.FrameworkBuildMessageEventArgs

Implements

IBuildEngineLogMessageEvent(BuildMessageEventArgs)
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.LogWarningEvent Method

XAMLExtensionsFakeBuildEngineLogWarningEvent Method

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LogWarningEvent(
    BuildWarningEventArgs e
)
Public Sub LogWarningEvent (
    e As BuildWarningEventArgs
)
public:
virtual void LogWarningEvent(
    BuildWarningEventArgs^ e
) sealed
abstract LogWarningEvent :
        e : BuildWarningEventArgs -> unit
override LogWarningEvent :
        e : BuildWarningEventArgs -> unit

Parameters

e
Type: Microsoft.Build.FrameworkBuildWarningEventArgs

Implements

IBuildEngineLogWarningEvent(BuildWarningEventArgs)
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


FakeBuildEngine Properties

FakeBuildEngine Properties

The XAMLExtensionsFakeBuildEngine type exposes the following members.

Properties
 | Name | Description
Public property | ColumnNumberOfTaskNode |
Public property | ContinueOnError |
Public property | LineNumberOfTaskNode |
Public property | ProjectFileOfTaskNode |
Top
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.ColumnNumberOfTaskNode Property

XAMLExtensionsFakeBuildEngineColumnNumberOfTaskNode Property

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ColumnNumberOfTaskNode { get; }
Public ReadOnly Property ColumnNumberOfTaskNode As Integer
    Get
public:
virtual property int ColumnNumberOfTaskNode {
    int get () sealed;
}
abstract ColumnNumberOfTaskNode : int with get
override ColumnNumberOfTaskNode : int with get

Property Value

Type: Int32

Implements

IBuildEngineColumnNumberOfTaskNode
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.ContinueOnError Property

XAMLExtensionsFakeBuildEngineContinueOnError Property

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContinueOnError { get; }
Public ReadOnly Property ContinueOnError As Boolean
    Get
public:
virtual property bool ContinueOnError {
    bool get () sealed;
}
abstract ContinueOnError : bool with get
override ContinueOnError : bool with get

Property Value

Type: Boolean

Implements

IBuildEngineContinueOnError
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.LineNumberOfTaskNode Property

XAMLExtensionsFakeBuildEngineLineNumberOfTaskNode Property

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LineNumberOfTaskNode { get; }
Public ReadOnly Property LineNumberOfTaskNode As Integer
    Get
public:
virtual property int LineNumberOfTaskNode {
    int get () sealed;
}
abstract LineNumberOfTaskNode : int with get
override LineNumberOfTaskNode : int with get

Property Value

Type: Int32

Implements

IBuildEngineLineNumberOfTaskNode
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


XAMLExtensions.FakeBuildEngine.ProjectFileOfTaskNode Property

XAMLExtensionsFakeBuildEngineProjectFileOfTaskNode Property

Namespace: Alternet.Scripter.XAML
Assembly: Alternet.Scripter.v7 (in Alternet.Scripter.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectFileOfTaskNode { get; }
Public ReadOnly Property ProjectFileOfTaskNode As String
    Get
public:
virtual property String^ ProjectFileOfTaskNode {
    String^ get () sealed;
}
abstract ProjectFileOfTaskNode : string with get
override ProjectFileOfTaskNode : string with get

Property Value

Type: String

Implements

IBuildEngineProjectFileOfTaskNode
See Also

Reference

XAMLExtensionsFakeBuildEngine Class
Alternet.Scripter.XAML Namespace


Alternet.Syntax Namespace

Alternet.Syntax Namespace
Classes
 | Class | Description
Public class | ClosingEventArgs | Provides data for the ICodeCompletionProvider.ClosePopup event.
Public class | CodeCompletionArgs | Provides data for the code completion events.
Public class | CodeFix | Represents properties to describe a particular code fix action in the code text.
Public class | CodeFixEventArgs | Provides data of the code fixes to be highlighted.
Public class | CodeRefactor | Represents properties to describe a particular code refactor action in the code text.
Public class | CodeRefactorEventArgs | Provides data of the code fixes to be highlighted.
Public class | DescriptionLookupEventArgs | Provides data for the ICodeCompletionRepository.DescriptionLookup event, used to search for the description of specified member.
Public class | HighlightReferencesEventArgs | Provides data of the references to be highlighted.
Public class | HtmlParser | Represents properties and methods to perform syntax analysis of specified html code text.
Public class | MemberLookupEventArgs | Provides data for the ICodeCompletionRepository.MemberLookup event, used to search for the specified member.
Public class | OutlineRange | Represents individual outlining section that can appear in the Edit control.
Public class | Parser | Represents class that performs lexical analysis of specified text.
Public class | ReadFormattedTextEventArgs | Provides data for the FmtImport.ReadFormattedText handler.
Public class | ShowingEventArgs | Provides data for the ICodeCompletionProvider.ShowPopup event.
Public class | StopParseException | Represents error that occurs when parsing text is aborted.
Public class | StringList | Represents collection containing list of strings.
Public class | SyntaxAttribute | Represents a particular attribute of language element.
Public class | SyntaxAttributes | Represents collection containing list of syntax attributes.
Public class | SyntaxConsts | Contains default constants related to lexical and syntax analyzers.
Public class | SyntaxError | Describes a particular syntax error in the code text.
Public class | SyntaxErrors | Represents collection containing list of syntax errors.
Public class | SyntaxNode | Represents a particular language element.
Public class | SyntaxNodes | Represents collection containing list of syntax nodes.
Public class | SyntaxParser | Represents properties and methods to perform syntax analysis of the text.
Public class | SyntaxParserEventArgs | Provides data for the asynchronous syntax parsing.
Public class | SyntaxTree | Describes syntax structure of code text.
Public class | TextUndo | Represents single change of the text fragment.
Public class | TextUndoList | Represents collection containing list of ITextUndo objects.
Public class | XmlParser | Represents properties and methods to perform syntax analysis of specified xml code text.
Structures
 | Structure | Description
Public structure | StringItemInfo | Represent structured information for IStringItem symbol.
Interfaces
 | Interface | Description
Public interface | ICodeFix | Represents properties to describe a particular code fix action in the code text.
Public interface | ICodeRefactor | Represents properties to describe a particular code fix action in the code text.
Public interface | IExport | Represents methods to save text content.
Public interface | IExpressionEvaluator | Represents properties and methods used to evaluate conditional defines.
Public interface | IImport | Represents methods to load text content.
Public interface | IOutlineRange | Represents individual outlining section that can appear in the Edit control.
Public interface | IParser | Represents properties and methods for perform lexical analysis of the text.
Public interface | IStringItem | Represents properties and methods of individual line in the Text Source.
Public interface | IStringList | Represents collection containing list of strings.
Public interface | IStringListWithItem | Represents collection containing list of strings.
Public interface | ISyntaxAttribute | Represents properties to describe a particular attribute of language element.
Public interface | ISyntaxAttributes | Represents collection containing list of syntax attributes.
Public interface | ISyntaxError | Represents properties to describe a particular syntax error in the code text.
Public interface | ISyntaxErrors | Represents collection containing list of syntax errors.
Public interface | ISyntaxNode | Represents properties and methods to describe a particular language element.
Public interface | ISyntaxNodes | Represents collection containing list of syntax nodes.
Public interface | ISyntaxParser | Represents properties and methods to perform syntax analysis of the text.
Public interface | ISyntaxTree | Represents properties and methods to describe syntax structure of code text.
Public interface | ITextUndo | Represents single change of the text fragment.
Public interface | ITextUndoList | Represents collection containing list of ITextUndo objects.
Delegates
 | Delegate | Description
Public delegate | ClosePopupEvent | Represents a method that will handle the CodeCompletionProvider.ClosePopup event.
Public delegate | CodeCompletionEvent | Represents a method that will handle the SyntaxEdit.NeedCodeCompletion event.
Public delegate | DescriptionLookupEvent | Represents a method that will handle the CodeCompletionRepository.DescriptionLookup event.
Public delegate | MemberLookupEvent | Represents a method that will handle the CodeCompletionRepository.MemberLookup event.
Public delegate | ReadFormattedTextEvent | Represents a method that will handle the FmtImport.ReadFormattedText event.
Public delegate | ShowPopupEvent | Represents a method that will handle the CodeCompletionProvider.ShowPopup event.
Enumerations
 | Enumeration | Description
Public enumeration | CodeCompletionScope | Specifies the way in which the search for members and types is conducted by code completion repository. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | CodeCompletionType | Specifies types of code completion window used to complete language elements.
Public enumeration | HtmlLexerToken | Represents lexical tokens for Html parser.
Public enumeration | ItemState | Defines state of the StrItem object, representing individual line in the Source. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | PrepareReason | Defines reason of underlying text in the parser being updated.
Public enumeration | SyntaxErrorType | Defines types of syntax error.
Public enumeration | SyntaxNodeOptions | Defines syntax node behavior. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | SyntaxOptions | Defines possibilities of formatting Edit control's content. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | TextStyle | Defines additional flags for text fragments. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | XmlLexerToken | Represents lexical tokens for Xml parser.
Public enumeration | XmlNodeType | Represents node types for Xml parser.


ClosePopupEvent Delegate

ClosePopupEvent Delegate
Represents a method that will handle the CodeCompletionProvider.ClosePopup event.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ClosePopupEvent(
    Object sender,
    ClosingEventArgs e
)
Public Delegate Sub ClosePopupEvent (
    sender As Object,
    e As ClosingEventArgs
)
public delegate void ClosePopupEvent(
    Object^ sender,
    ClosingEventArgs^ e
)
type ClosePopupEvent =
    delegate of
        sender : Object *
        e : ClosingEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxClosingEventArgs
The ClosingEventArgs that contains the event data.
See Also

Reference

Alternet.Syntax Namespace


ClosingEventArgs Class

ClosingEventArgs Class
Provides data for the ICodeCompletionProvider.ClosePopup event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxClosingEventArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ClosingEventArgs : EventArgs
Public Class ClosingEventArgs
    Inherits EventArgs
public ref class ClosingEventArgs : public EventArgs
type ClosingEventArgs =
    class
        inherit EventArgs
    end

The ClosingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ClosingEventArgs | Initializes a new instance of the ClosingEventArgs class with the specific parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Accepted | Represents a value indicating whether the value displayed in CodeCompletion window should be accepted.
Public property | CaretOffset | Specifies new caret position within the text when completion window is closed.
Public property | EndPosition | Specifies position within the text where code completion window is valid.
Public property | Handled | Represents the boolean value indicating whether popup should be closed or not.
Public property | InsertText | Represents the string value to be inserted that returned by popup being closed.
Public property | KeyChar | Represents key code causing code completion window to close.
Public property | Provider | Represents the object that provides data for code completion.
Public property | SkipKeyChar | Indicates that key character which committed selection should not be inserted in the editor.
Public property | StartPosition | Specifies position within the text where code completion window is valid.
Public property | Text | Represents the string value that returned by popup being closed.
Public property | UseFormat | Represents a value indicating whether the multi-line text should be formatted when inserting to the edit control.
Public property | UseIndent | Represents a value indicating whether the multi-line text should be indented when inserting to the edit control.
Top
See Also

Reference

Alternet.Syntax Namespace


ClosingEventArgs Constructor

ClosingEventArgs Constructor
Initializes a new instance of the ClosingEventArgs class with the specific parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClosingEventArgs(
    bool accepted,
    ICodeCompletionProvider provider
)
Public Sub New (
    accepted As Boolean,
    provider As ICodeCompletionProvider
)
public:
ClosingEventArgs(
    bool accepted,
    ICodeCompletionProvider^ provider
)
new :
        accepted : bool *
        provider : ICodeCompletionProvider -> ClosingEventArgs

Parameters

accepted
Type: SystemBoolean
The boolean value that specifies whether the popup window input is accepted.
provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Specifies the object that provides data for code completion.
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs Methods

ClosingEventArgs Methods

The ClosingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs Properties

ClosingEventArgs Properties

The ClosingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Accepted | Represents a value indicating whether the value displayed in CodeCompletion window should be accepted.
Public property | CaretOffset | Specifies new caret position within the text when completion window is closed.
Public property | EndPosition | Specifies position within the text where code completion window is valid.
Public property | Handled | Represents the boolean value indicating whether popup should be closed or not.
Public property | InsertText | Represents the string value to be inserted that returned by popup being closed.
Public property | KeyChar | Represents key code causing code completion window to close.
Public property | Provider | Represents the object that provides data for code completion.
Public property | SkipKeyChar | Indicates that key character which committed selection should not be inserted in the editor.
Public property | StartPosition | Specifies position within the text where code completion window is valid.
Public property | Text | Represents the string value that returned by popup being closed.
Public property | UseFormat | Represents a value indicating whether the multi-line text should be formatted when inserting to the edit control.
Public property | UseIndent | Represents a value indicating whether the multi-line text should be indented when inserting to the edit control.
Top
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.Accepted Property

ClosingEventArgsAccepted Property
Represents a value indicating whether the value displayed in CodeCompletion window should be accepted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Accepted { get; set; }
Public Property Accepted As Boolean
    Get
    Set
public:
property bool Accepted {
    bool get ();
    void set (bool value);
}
member Accepted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.CaretOffset Property

ClosingEventArgsCaretOffset Property
Specifies new caret position within the text when completion window is closed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CaretOffset { get; set; }
Public Property CaretOffset As Integer
    Get
    Set
public:
property int CaretOffset {
    int get ();
    void set (int value);
}
member CaretOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.EndPosition Property

ClosingEventArgsEndPosition Property
Specifies position within the text where code completion window is valid.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point EndPosition { get; set; }
Public Property EndPosition As Point
    Get
    Set
public:
property Point EndPosition {
    Point get ();
    void set (Point value);
}
member EndPosition : Point with get, set

Property Value

Type: Point
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace
CodeCompletionArgsStartPosition


ClosingEventArgs.Handled Property

ClosingEventArgsHandled Property
Represents the boolean value indicating whether popup should be closed or not.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.InsertText Property

ClosingEventArgsInsertText Property
Represents the string value to be inserted that returned by popup being closed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InsertText { get; set; }
Public Property InsertText As String
    Get
    Set
public:
property String^ InsertText {
    String^ get ();
    void set (String^ value);
}
member InsertText : string with get, set

Property Value

Type: String
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.KeyChar Property

ClosingEventArgsKeyChar Property
Represents key code causing code completion window to close.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public char KeyChar { get; set; }
Public Property KeyChar As Char
    Get
    Set
public:
property wchar_t KeyChar {
    wchar_t get ();
    void set (wchar_t value);
}
member KeyChar : char with get, set

Property Value

Type: Char
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.Provider Property

ClosingEventArgsProvider Property
Represents the object that provides data for code completion.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionProvider Provider { get; set; }
Public Property Provider As ICodeCompletionProvider
    Get
    Set
public:
property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get ();
    void set (ICodeCompletionProvider^ value);
}
member Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.SkipKeyChar Property

ClosingEventArgsSkipKeyChar Property
Indicates that key character which committed selection should not be inserted in the editor.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SkipKeyChar { get; set; }
Public Property SkipKeyChar As Boolean
    Get
    Set
public:
property bool SkipKeyChar {
    bool get ();
    void set (bool value);
}
member SkipKeyChar : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.StartPosition Property

ClosingEventArgsStartPosition Property
Specifies position within the text where code completion window is valid.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point StartPosition { get; set; }
Public Property StartPosition As Point
    Get
    Set
public:
property Point StartPosition {
    Point get ();
    void set (Point value);
}
member StartPosition : Point with get, set

Property Value

Type: Point
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace
CodeCompletionArgsEndPosition


ClosingEventArgs.Text Property

ClosingEventArgsText Property
Represents the string value that returned by popup being closed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.UseFormat Property

ClosingEventArgsUseFormat Property
Represents a value indicating whether the multi-line text should be formatted when inserting to the edit control.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseFormat { get; set; }
Public Property UseFormat As Boolean
    Get
    Set
public:
property bool UseFormat {
    bool get ();
    void set (bool value);
}
member UseFormat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


ClosingEventArgs.UseIndent Property

ClosingEventArgsUseIndent Property
Represents a value indicating whether the multi-line text should be indented when inserting to the edit control.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseIndent { get; set; }
Public Property UseIndent As Boolean
    Get
    Set
public:
property bool UseIndent {
    bool get ();
    void set (bool value);
}
member UseIndent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClosingEventArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs Class

CodeCompletionArgs Class
Provides data for the code completion events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxCodeCompletionArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionArgs : EventArgs
Public Class CodeCompletionArgs
    Inherits EventArgs
public ref class CodeCompletionArgs : public EventArgs
type CodeCompletionArgs =
    class
        inherit EventArgs
    end

The CodeCompletionArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionArgs | Initializes CodeCompletionArgs with default values.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes CodeCompletionArgs with default values.
Public method | Init(CodeCompletionType, Point) | Initializes CodeCompletionArgs with specified parameters.
Public method | Init(CodeCompletionType, Point, Boolean) | Initializes CodeCompletionArgs with specified parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AllowAsync | Specifies whether code completion request can be run asynchronously.
Public property | AllowMultipleDocuments | Specifies whether code completion request can process other files.
Public property | Button | Represents a value indicating whether code completion window should popup in the form of the drop-down button.
Public property | CaretOffset | Specifies new caret position within the text when completion window is closed.
Public property | CompletionName | Specifies text in the editor to be completed.
Public property | CompletionType | Represents type of code completion window.
Public property | CustomData | Specifies code-completion specific data.
Public property | DisplayPosition | Specifies position within the text where code completion window is displayed.
Public property | EndPosition | Specifies position within the text where code completion window is valid.
Public property | Handled | Represents a value indicating whether the CodeCompletion event is handled. If the event is handled, code completion box will not appear.
Public property | Interval | Represents the delay, in milliseconds before displaying code completion window. Set Interval to 0 to make code completion window appearing immediately.
Public property | KeyChar | Represents the character typed in the Edit control.
Public property | Lexer | Specifies lexer used for drawing code completion windows.
Public property | MousePosition | Specifies position in pixels, where code completion window is displayed.
Public property | NeedReparse | Specifies whether current scope should be reparsed when executing code completion request.
Public property | NeedShow | Represents a value indicating whether the code completion popup need showing.
Public property | Notify | Specifies whether code completion request sends notification upon completion.
Public property | Provider | Represents the object that provides data for code completion.
Public property | SelIndex | Represents the index specifying the currently selected item of code completion box.
Public property | StartPosition | Specifies position within the text where code completion window is valid.
Public property | ToolTip | Represents a value indicating whether code completion window should popup in the form of the tooltip.
Public property | UseFormat | Represents a value indicating whether the multi-line text should be formatted when inserting to the edit control.
Top
See Also

Reference

Alternet.Syntax Namespace


CodeCompletionArgs Constructor

CodeCompletionArgs Constructor
Initializes CodeCompletionArgs with default values.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionArgs()
Public Sub New
public:
CodeCompletionArgs()
new : unit -> CodeCompletionArgs
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs Methods

CodeCompletionArgs Methods

The CodeCompletionArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes CodeCompletionArgs with default values.
Public method | Init(CodeCompletionType, Point) | Initializes CodeCompletionArgs with specified parameters.
Public method | Init(CodeCompletionType, Point, Boolean) | Initializes CodeCompletionArgs with specified parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.Init Method

CodeCompletionArgsInit Method
Overload List
 | Name | Description
Public method | Init | Initializes CodeCompletionArgs with default values.
Public method | Init(CodeCompletionType, Point) | Initializes CodeCompletionArgs with specified parameters.
Public method | Init(CodeCompletionType, Point, Boolean) | Initializes CodeCompletionArgs with specified parameters.
Top
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.Init Method

CodeCompletionArgsInit Method
Initializes CodeCompletionArgs with default values.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Init()
Public Sub Init
public:
void Init()
member Init : unit -> unit
See Also

Reference

CodeCompletionArgs Class
Init Overload
Alternet.Syntax Namespace


CodeCompletionArgs.Init Method (CodeCompletionType, Point)

CodeCompletionArgsInit Method (CodeCompletionType, Point)
Initializes CodeCompletionArgs with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Init(
    CodeCompletionType completionType,
    Point position
)
Public Sub Init (
    completionType As CodeCompletionType,
    position As Point
)
public:
void Init(
    CodeCompletionType completionType,
    Point position
)
member Init :
        completionType : CodeCompletionType *
        position : Point -> unit

Parameters

completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion type.
position
Type: System.DrawingPoint
Specifies start position.
See Also

Reference

CodeCompletionArgs Class
Init Overload
Alternet.Syntax Namespace


CodeCompletionArgs.Init Method (CodeCompletionType, Point, Boolean)

CodeCompletionArgsInit Method (CodeCompletionType, Point, Boolean)
Initializes CodeCompletionArgs with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Init(
    CodeCompletionType completionType,
    Point position,
    bool needReparse
)
Public Sub Init (
    completionType As CodeCompletionType,
    position As Point,
    needReparse As Boolean
)
public:
void Init(
    CodeCompletionType completionType,
    Point position,
    bool needReparse
)
member Init :
        completionType : CodeCompletionType *
        position : Point *
        needReparse : bool -> unit

Parameters

completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion type.
position
Type: System.DrawingPoint
Specifies start position.
needReparse
Type: SystemBoolean
Specifies whether current scope should be reparsed when executing code completion request.
See Also

Reference

CodeCompletionArgs Class
Init Overload
Alternet.Syntax Namespace


CodeCompletionArgs Properties

CodeCompletionArgs Properties

The CodeCompletionArgs type exposes the following members.

Properties
 | Name | Description
Public property | AllowAsync | Specifies whether code completion request can be run asynchronously.
Public property | AllowMultipleDocuments | Specifies whether code completion request can process other files.
Public property | Button | Represents a value indicating whether code completion window should popup in the form of the drop-down button.
Public property | CaretOffset | Specifies new caret position within the text when completion window is closed.
Public property | CompletionName | Specifies text in the editor to be completed.
Public property | CompletionType | Represents type of code completion window.
Public property | CustomData | Specifies code-completion specific data.
Public property | DisplayPosition | Specifies position within the text where code completion window is displayed.
Public property | EndPosition | Specifies position within the text where code completion window is valid.
Public property | Handled | Represents a value indicating whether the CodeCompletion event is handled. If the event is handled, code completion box will not appear.
Public property | Interval | Represents the delay, in milliseconds before displaying code completion window. Set Interval to 0 to make code completion window appearing immediately.
Public property | KeyChar | Represents the character typed in the Edit control.
Public property | Lexer | Specifies lexer used for drawing code completion windows.
Public property | MousePosition | Specifies position in pixels, where code completion window is displayed.
Public property | NeedReparse | Specifies whether current scope should be reparsed when executing code completion request.
Public property | NeedShow | Represents a value indicating whether the code completion popup need showing.
Public property | Notify | Specifies whether code completion request sends notification upon completion.
Public property | Provider | Represents the object that provides data for code completion.
Public property | SelIndex | Represents the index specifying the currently selected item of code completion box.
Public property | StartPosition | Specifies position within the text where code completion window is valid.
Public property | ToolTip | Represents a value indicating whether code completion window should popup in the form of the tooltip.
Public property | UseFormat | Represents a value indicating whether the multi-line text should be formatted when inserting to the edit control.
Top
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.AllowAsync Property

CodeCompletionArgsAllowAsync Property
Specifies whether code completion request can be run asynchronously.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowAsync { get; set; }
Public Property AllowAsync As Boolean
    Get
    Set
public:
property bool AllowAsync {
    bool get ();
    void set (bool value);
}
member AllowAsync : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.AllowMultipleDocuments Property

CodeCompletionArgsAllowMultipleDocuments Property
Specifies whether code completion request can process other files.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowMultipleDocuments { get; set; }
Public Property AllowMultipleDocuments As Boolean
    Get
    Set
public:
property bool AllowMultipleDocuments {
    bool get ();
    void set (bool value);
}
member AllowMultipleDocuments : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.Button Property

CodeCompletionArgsButton Property
Represents a value indicating whether code completion window should popup in the form of the drop-down button.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Button { get; set; }
Public Property Button As Boolean
    Get
    Set
public:
property bool Button {
    bool get ();
    void set (bool value);
}
member Button : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.CaretOffset Property

CodeCompletionArgsCaretOffset Property
Specifies new caret position within the text when completion window is closed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CaretOffset { get; set; }
Public Property CaretOffset As Integer
    Get
    Set
public:
property int CaretOffset {
    int get ();
    void set (int value);
}
member CaretOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.CompletionName Property

CodeCompletionArgsCompletionName Property
Specifies text in the editor to be completed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CompletionName { get; set; }
Public Property CompletionName As String
    Get
    Set
public:
property String^ CompletionName {
    String^ get ();
    void set (String^ value);
}
member CompletionName : string with get, set

Property Value

Type: String
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.CompletionType Property

CodeCompletionArgsCompletionType Property
Represents type of code completion window.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionType CompletionType { get; set; }
Public Property CompletionType As CodeCompletionType
    Get
    Set
public:
property CodeCompletionType CompletionType {
    CodeCompletionType get ();
    void set (CodeCompletionType value);
}
member CompletionType : CodeCompletionType with get, set

Property Value

Type: CodeCompletionType
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.CustomData Property

CodeCompletionArgsCustomData Property
Specifies code-completion specific data.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object CustomData { get; set; }
Public Property CustomData As Object
    Get
    Set
public:
property Object^ CustomData {
    Object^ get ();
    void set (Object^ value);
}
member CustomData : Object with get, set

Property Value

Type: Object
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.DisplayPosition Property

CodeCompletionArgsDisplayPosition Property
Specifies position within the text where code completion window is displayed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point DisplayPosition { get; set; }
Public Property DisplayPosition As Point
    Get
    Set
public:
property Point DisplayPosition {
    Point get ();
    void set (Point value);
}
member DisplayPosition : Point with get, set

Property Value

Type: Point
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace
CodeCompletionArgsStartPosition


CodeCompletionArgs.EndPosition Property

CodeCompletionArgsEndPosition Property
Specifies position within the text where code completion window is valid.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point EndPosition { get; set; }
Public Property EndPosition As Point
    Get
    Set
public:
property Point EndPosition {
    Point get ();
    void set (Point value);
}
member EndPosition : Point with get, set

Property Value

Type: Point
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace
CodeCompletionArgsStartPosition


CodeCompletionArgs.Handled Property

CodeCompletionArgsHandled Property
Represents a value indicating whether the CodeCompletion event is handled. If the event is handled, code completion box will not appear.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.Interval Property

CodeCompletionArgsInterval Property
Represents the delay, in milliseconds before displaying code completion window. Set Interval to 0 to make code completion window appearing immediately.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Interval { get; set; }
Public Property Interval As Integer
    Get
    Set
public:
property int Interval {
    int get ();
    void set (int value);
}
member Interval : int with get, set

Property Value

Type: Int32
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.KeyChar Property

CodeCompletionArgsKeyChar Property
Represents the character typed in the Edit control.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public char KeyChar { get; set; }
Public Property KeyChar As Char
    Get
    Set
public:
property wchar_t KeyChar {
    wchar_t get ();
    void set (wchar_t value);
}
member KeyChar : char with get, set

Property Value

Type: Char
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.Lexer Property

CodeCompletionArgsLexer Property
Specifies lexer used for drawing code completion windows.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ILexer Lexer { get; set; }
Public Property Lexer As ILexer
    Get
    Set
public:
property ILexer^ Lexer {
    ILexer^ get ();
    void set (ILexer^ value);
}
member Lexer : ILexer with get, set

Property Value

Type: ILexer
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.MousePosition Property

CodeCompletionArgsMousePosition Property
Specifies position in pixels, where code completion window is displayed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point MousePosition { get; set; }
Public Property MousePosition As Point
    Get
    Set
public:
property Point MousePosition {
    Point get ();
    void set (Point value);
}
member MousePosition : Point with get, set

Property Value

Type: Point
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace
CodeCompletionArgsStartPosition


CodeCompletionArgs.NeedReparse Property

CodeCompletionArgsNeedReparse Property
Specifies whether current scope should be reparsed when executing code completion request.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedReparse { get; set; }
Public Property NeedReparse As Boolean
    Get
    Set
public:
property bool NeedReparse {
    bool get ();
    void set (bool value);
}
member NeedReparse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.NeedShow Property

CodeCompletionArgsNeedShow Property
Represents a value indicating whether the code completion popup need showing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedShow { get; set; }
Public Property NeedShow As Boolean
    Get
    Set
public:
property bool NeedShow {
    bool get ();
    void set (bool value);
}
member NeedShow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.Notify Property

CodeCompletionArgsNotify Property
Specifies whether code completion request sends notification upon completion.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Notify { get; set; }
Public Property Notify As Boolean
    Get
    Set
public:
property bool Notify {
    bool get ();
    void set (bool value);
}
member Notify : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.Provider Property

CodeCompletionArgsProvider Property
Represents the object that provides data for code completion.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionProvider Provider { get; set; }
Public Property Provider As ICodeCompletionProvider
    Get
    Set
public:
property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get ();
    void set (ICodeCompletionProvider^ value);
}
member Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.SelIndex Property

CodeCompletionArgsSelIndex Property
Represents the index specifying the currently selected item of code completion box.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SelIndex { get; set; }
Public Property SelIndex As Integer
    Get
    Set
public:
property int SelIndex {
    int get ();
    void set (int value);
}
member SelIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.StartPosition Property

CodeCompletionArgsStartPosition Property
Specifies position within the text where code completion window is valid.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point StartPosition { get; set; }
Public Property StartPosition As Point
    Get
    Set
public:
property Point StartPosition {
    Point get ();
    void set (Point value);
}
member StartPosition : Point with get, set

Property Value

Type: Point
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace
CodeCompletionArgsEndPosition


CodeCompletionArgs.ToolTip Property

CodeCompletionArgsToolTip Property
Represents a value indicating whether code completion window should popup in the form of the tooltip.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ToolTip { get; set; }
Public Property ToolTip As Boolean
    Get
    Set
public:
property bool ToolTip {
    bool get ();
    void set (bool value);
}
member ToolTip : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionArgs.UseFormat Property

CodeCompletionArgsUseFormat Property
Represents a value indicating whether the multi-line text should be formatted when inserting to the edit control.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseFormat { get; set; }
Public Property UseFormat As Boolean
    Get
    Set
public:
property bool UseFormat {
    bool get ();
    void set (bool value);
}
member UseFormat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CodeCompletionArgs Class
Alternet.Syntax Namespace


CodeCompletionEvent Delegate

CodeCompletionEvent Delegate
Represents a method that will handle the SyntaxEdit.NeedCodeCompletion event.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void CodeCompletionEvent(
    Object sender,
    CodeCompletionArgs e
)
Public Delegate Sub CodeCompletionEvent (
    sender As Object,
    e As CodeCompletionArgs
)
public delegate void CodeCompletionEvent(
    Object^ sender,
    CodeCompletionArgs^ e
)
type CodeCompletionEvent =
    delegate of
        sender : Object *
        e : CodeCompletionArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxCodeCompletionArgs
The CodeCompletionArgs that contains the event data.
See Also

Reference

Alternet.Syntax Namespace


CodeCompletionScope Enumeration

CodeCompletionScope Enumeration
Specifies the way in which the search for members and types is conducted by code completion repository. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum CodeCompletionScope
<FlagsAttribute>
Public Enumeration CodeCompletionScope
[FlagsAttribute]
public enum class CodeCompletionScope
[<FlagsAttribute>]
type CodeCompletionScope
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Static | 1 | Specifies that member to search is a static (belongs to the type itself rather than to a specific object).
Instance | 2 | Specifies that member is instance (belongs to the object).
Global | 4 | Specifies that member is global (belongs to the global module).
Protected | 8 | Specifies that member may be protected.
TypeName | 16 | Specifies that member should display type name in code completion window.
Delegate | 32 | Specifies that member should display event handler code completion window.
Method | 64 | Specifies that member represents Reflection MethodBase.
Property | 128 | Specifies that member represents Reflection PropertyInfo.
Field | 256 | Specifies that member represents Reflection FieldInfo.
ShortType | 512 | Specifies that member should display type short name in rather full name. Appropriate only if TypeName flag is on.
Private | 1024 | Specifies that member may be private.
Overrides | 2048 | Specifies that member to search virtual members in a base class.
BaseType | 4096 | Specifies that member to search is declared in a base class.
Friend | 8192 | Specifies that member may be friend.
Snippets | 16384 | Specifies that code snippets should be displayed.
See Also

Reference

Alternet.Syntax Namespace


CodeCompletionType Enumeration

CodeCompletionType Enumeration
Specifies types of code completion window used to complete language elements.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CodeCompletionType
Public Enumeration CodeCompletionType
public enum class CodeCompletionType
type CodeCompletionType
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
CompleteWord | 1 | Specifies that code completion window displayed to complete the rest of a variable, command, or function name once you have entered enough characters to disambiguate the term.
ListMembers | 2 | Specifies that code completion window displayed with a list of valid member variables or functions for the appropriate class, struct, union or namespace.
ParameterInfo | 3 | Specifies that code completion window displayed with information about the number, names, and types of parameters required by a function or attribute.
QuickInfo | 4 | Specifies that code completion window displayed with information in a form of short description.
CodeSnippets | 5 | Specifies that code completion window displayed with a list of templates with commonly used programming statements that can be inserted into the code.
SpecialListMembers | 6 | Specifies special cases for code completion window.
CompleteComment | 7 | Specifies that xml comment template to be inserted.
GenericParameterInfo | 8 | Specifies that generic to be inserted.
CompleteBrace | 9 | Specifies that matching brace to be inserted.
CompleteInclude | 10 | Specifies that include file to be inserted.
CompleteCodeFixes | 11 | Specifies that code completion window displayed with a list of available code fixes.
CompleteCodeRefactors | 12 | Specifies that code completion window displayed with a list of available code refactors.
XmlCommentListMembers | 13 | Specifies that xml comment members should be displayed.
See Also

Reference

Alternet.Syntax Namespace


CodeFix Class

CodeFix Class
Represents properties to describe a particular code fix action in the code text.
Inheritance Hierarchy
SystemObject
Alternet.SyntaxCodeFix

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeFix : ICodeFix, ICloneable
Public Class CodeFix
    Implements ICodeFix, ICloneable
public ref class CodeFix : ICodeFix,
    ICloneable
type CodeFix =
    class
        interface ICodeFix
        interface ICloneable
    end

The CodeFix type exposes the following members.

Constructors
 | Name | Description
Public method | CodeFix | Initializes a new instance of the CodeFix class with default settings.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ICodeFixAction object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | Gets or sets code fix description.
Public property | TextChanges | Gets or sets collection of code fix changes.
Top
See Also

Reference

Alternet.Syntax Namespace


CodeFix Constructor

CodeFix Constructor
Initializes a new instance of the CodeFix class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeFix()
Public Sub New
public:
CodeFix()
new : unit -> CodeFix
See Also

Reference

CodeFix Class
Alternet.Syntax Namespace


CodeFix Methods

CodeFix Methods

The CodeFix type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ICodeFixAction object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeFix Class
Alternet.Syntax Namespace


CodeFix.Clone Method

CodeFixClone Method
Creates a new object that is a copy of the current ICodeFixAction object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of System.Object that is the memberwise clone of the current CodeFixAction object.

Implements

ICloneableClone
See Also

Reference

CodeFix Class
Alternet.Syntax Namespace


CodeFix Properties

CodeFix Properties

The CodeFix type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets code fix description.
Public property | TextChanges | Gets or sets collection of code fix changes.
Top
See Also

Reference

CodeFix Class
Alternet.Syntax Namespace


CodeFix.Description Property

CodeFixDescription Property
Gets or sets code fix description.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

ICodeFixDescription
See Also

Reference

CodeFix Class
Alternet.Syntax Namespace


CodeFix.TextChanges Property

CodeFixTextChanges Property
Gets or sets collection of code fix changes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ITextUndoList TextChanges { get; set; }
Public Overridable Property TextChanges As ITextUndoList
    Get
    Set
public:
virtual property ITextUndoList^ TextChanges {
    ITextUndoList^ get ();
    void set (ITextUndoList^ value);
}
abstract TextChanges : ITextUndoList with get, set
override TextChanges : ITextUndoList with get, set

Property Value

Type: ITextUndoList

Implements

ICodeFixTextChanges
See Also

Reference

CodeFix Class
Alternet.Syntax Namespace


CodeFixEventArgs Class

CodeFixEventArgs Class
Provides data of the code fixes to be highlighted.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxCodeFixEventArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeFixEventArgs : EventArgs
Public Class CodeFixEventArgs
    Inherits EventArgs
public ref class CodeFixEventArgs : public EventArgs
type CodeFixEventArgs =
    class
        inherit EventArgs
    end

The CodeFixEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CodeFixEventArgs | Initializes CodeFixEventArgs with specified references.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CodeFixes | Gets or sets a list of ICodeFix objects that contains code fixes.
Public property | Error | Gets or sets a ISyntaxError associated with code fixes.
Public property | Position | Specifies position of the code fixes.
Top
See Also

Reference

Alternet.Syntax Namespace


CodeFixEventArgs Constructor

CodeFixEventArgs Constructor
Initializes CodeFixEventArgs with specified references.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeFixEventArgs(
    Point position,
    ISyntaxError error,
    IList<ICodeFix> codeFixes
)
Public Sub New (
    position As Point,
    error As ISyntaxError,
    codeFixes As IList(Of ICodeFix)
)
public:
CodeFixEventArgs(
    Point position,
    ISyntaxError^ error,
    IList<ICodeFix^>^ codeFixes
)
new :
        position : Point *
        error : ISyntaxError *
        codeFixes : IList<ICodeFix> -> CodeFixEventArgs

Parameters

position
Type: System.DrawingPoint
Current position.
error
Type: Alternet.SyntaxISyntaxError
Syntax Error at current position.
codeFixes
Type: System.Collections.GenericIListICodeFix
Collection of code fixes for the given error.
See Also

Reference

CodeFixEventArgs Class
Alternet.Syntax Namespace


CodeFixEventArgs Methods

CodeFixEventArgs Methods

The CodeFixEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeFixEventArgs Class
Alternet.Syntax Namespace


CodeFixEventArgs Properties

CodeFixEventArgs Properties

The CodeFixEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CodeFixes | Gets or sets a list of ICodeFix objects that contains code fixes.
Public property | Error | Gets or sets a ISyntaxError associated with code fixes.
Public property | Position | Specifies position of the code fixes.
Top
See Also

Reference

CodeFixEventArgs Class
Alternet.Syntax Namespace


CodeFixEventArgs.CodeFixes Property

CodeFixEventArgsCodeFixes Property
Gets or sets a list of ICodeFix objects that contains code fixes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ICodeFix> CodeFixes { get; set; }
Public Property CodeFixes As IList(Of ICodeFix)
    Get
    Set
public:
property IList<ICodeFix^>^ CodeFixes {
    IList<ICodeFix^>^ get ();
    void set (IList<ICodeFix^>^ value);
}
member CodeFixes : IList<ICodeFix> with get, set

Property Value

Type: IListICodeFix
See Also

Reference

CodeFixEventArgs Class
Alternet.Syntax Namespace


CodeFixEventArgs.Error Property

CodeFixEventArgsError Property
Gets or sets a ISyntaxError associated with code fixes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISyntaxError Error { get; set; }
Public Property Error As ISyntaxError
    Get
    Set
public:
property ISyntaxError^ Error {
    ISyntaxError^ get ();
    void set (ISyntaxError^ value);
}
member Error : ISyntaxError with get, set

Property Value

Type: ISyntaxError
See Also

Reference

CodeFixEventArgs Class
Alternet.Syntax Namespace


CodeFixEventArgs.Position Property

CodeFixEventArgsPosition Property
Specifies position of the code fixes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set
public:
property Point Position {
    Point get ();
    void set (Point value);
}
member Position : Point with get, set

Property Value

Type: Point
See Also

Reference

CodeFixEventArgs Class
Alternet.Syntax Namespace


CodeRefactor Class

CodeRefactor Class
Represents properties to describe a particular code refactor action in the code text.
Inheritance Hierarchy
SystemObject
Alternet.SyntaxCodeRefactor

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeRefactor : ICodeRefactor,
    ICloneable
Public Class CodeRefactor
    Implements ICodeRefactor, ICloneable
public ref class CodeRefactor : ICodeRefactor,
    ICloneable
type CodeRefactor =
    class
        interface ICodeRefactor
        interface ICloneable
    end

The CodeRefactor type exposes the following members.

Constructors
 | Name | Description
Public method | CodeRefactor | Initializes a new instance of the CodeRefactor class
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ICodeFixAction object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextChanges | Retrieves code changes for particular code refactor.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ActionDescription | Gets or sets code refactor action description.
Public property | ActionName | Gets or sets code refactor action name.
Public property | Description | Gets or sets code fix description.
Public property | EndPos | Gets or sets end position of the text being refactored.
Public property | Name | Gets or sets code fix description.
Public property | Position | Gets or sets start position of the text being refactored.
Public property | TextChangesFunc | Gets or sets functions that retrieves code changes for particular refactor.
Top
See Also

Reference

Alternet.Syntax Namespace


CodeRefactor Constructor

CodeRefactor Constructor
Initializes a new instance of the CodeRefactor class

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeRefactor()
Public Sub New
public:
CodeRefactor()
new : unit -> CodeRefactor
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor Methods

CodeRefactor Methods

The CodeRefactor type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ICodeFixAction object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTextChanges | Retrieves code changes for particular code refactor.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor.Clone Method

CodeRefactorClone Method
Creates a new object that is a copy of the current ICodeFixAction object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of System.Object that is the memberwise clone of the current CodeFixAction object.

Implements

ICloneableClone
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor.GetTextChanges Method

CodeRefactorGetTextChanges Method
Retrieves code changes for particular code refactor.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<ITextUndo> GetTextChanges(
    bool allDocuments
)
Public Overridable Function GetTextChanges (
    allDocuments As Boolean
) As IList(Of ITextUndo)
public:
virtual IList<ITextUndo^>^ GetTextChanges(
    bool allDocuments
)
abstract GetTextChanges :
        allDocuments : bool -> IList<ITextUndo>
override GetTextChanges :
        allDocuments : bool -> IList<ITextUndo>

Parameters

allDocuments
Type: SystemBoolean
Specifies if all documents in the solution needs to be processed.

Return Value

Type: IListITextUndo
List of changes if any, otherwise null.

Implements

ICodeRefactorGetTextChanges(Boolean)
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor Properties

CodeRefactor Properties

The CodeRefactor type exposes the following members.

Properties
 | Name | Description
Public property | ActionDescription | Gets or sets code refactor action description.
Public property | ActionName | Gets or sets code refactor action name.
Public property | Description | Gets or sets code fix description.
Public property | EndPos | Gets or sets end position of the text being refactored.
Public property | Name | Gets or sets code fix description.
Public property | Position | Gets or sets start position of the text being refactored.
Public property | TextChangesFunc | Gets or sets functions that retrieves code changes for particular refactor.
Top
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor.ActionDescription Property

CodeRefactorActionDescription Property
Gets or sets code refactor action description.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ActionDescription { get; set; }
Public Overridable Property ActionDescription As String
    Get
    Set
public:
virtual property String^ ActionDescription {
    String^ get ();
    void set (String^ value);
}
abstract ActionDescription : string with get, set
override ActionDescription : string with get, set

Property Value

Type: String

Implements

ICodeRefactorActionDescription
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor.ActionName Property

CodeRefactorActionName Property
Gets or sets code refactor action name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ActionName { get; set; }
Public Overridable Property ActionName As String
    Get
    Set
public:
virtual property String^ ActionName {
    String^ get ();
    void set (String^ value);
}
abstract ActionName : string with get, set
override ActionName : string with get, set

Property Value

Type: String

Implements

ICodeRefactorActionName
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor.Description Property

CodeRefactorDescription Property
Gets or sets code fix description.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

ICodeRefactorDescription
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor.EndPos Property

CodeRefactorEndPos Property
Gets or sets end position of the text being refactored.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point EndPos { get; set; }
Public Overridable Property EndPos As Point
    Get
    Set
public:
virtual property Point EndPos {
    Point get ();
    void set (Point value);
}
abstract EndPos : Point with get, set
override EndPos : Point with get, set

Property Value

Type: Point

Implements

ICodeRefactorEndPos
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor.Name Property

CodeRefactorName Property
Gets or sets code fix description.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ICodeRefactorName
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor.Position Property

CodeRefactorPosition Property
Gets or sets start position of the text being refactored.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Position { get; set; }
Public Overridable Property Position As Point
    Get
    Set
public:
virtual property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set
override Position : Point with get, set

Property Value

Type: Point

Implements

ICodeRefactorPosition
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactor.TextChangesFunc Property

CodeRefactorTextChangesFunc Property
Gets or sets functions that retrieves code changes for particular refactor.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Func<ICodeRefactor, bool, IList<ITextUndo>> TextChangesFunc { get; set; }
Public Overridable Property TextChangesFunc As Func(Of ICodeRefactor, Boolean, IList(Of ITextUndo))
    Get
    Set
public:
virtual property Func<ICodeRefactor^, bool, IList<ITextUndo^>^>^ TextChangesFunc {
    Func<ICodeRefactor^, bool, IList<ITextUndo^>^>^ get ();
    void set (Func<ICodeRefactor^, bool, IList<ITextUndo^>^>^ value);
}
abstract TextChangesFunc : Func<ICodeRefactor, bool, IList<ITextUndo>> with get, set
override TextChangesFunc : Func<ICodeRefactor, bool, IList<ITextUndo>> with get, set

Property Value

Type: FuncICodeRefactor, Boolean, IListITextUndo

Implements

ICodeRefactorTextChangesFunc
See Also

Reference

CodeRefactor Class
Alternet.Syntax Namespace


CodeRefactorEventArgs Class

CodeRefactorEventArgs Class
Provides data of the code fixes to be highlighted.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxCodeRefactorEventArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeRefactorEventArgs : EventArgs
Public Class CodeRefactorEventArgs
    Inherits EventArgs
public ref class CodeRefactorEventArgs : public EventArgs
type CodeRefactorEventArgs =
    class
        inherit EventArgs
    end

The CodeRefactorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CodeRefactorEventArgs(Point, IListICodeRefactor) | Initializes HighlightCodeFixesEventArgs with specified arguments.
Public method | CodeRefactorEventArgs(Point, Point, IListICodeRefactor) | Initializes HighlightCodeFixesEventArgs with specified arguments.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CodeRefactors |
Public property | EndPosition | Specifies end position of the code to be refactored.
Public property | Position | Specifies position of the code to be refactored.
Top
See Also

Reference

Alternet.Syntax Namespace


CodeRefactorEventArgs Constructor

CodeRefactorEventArgs Constructor
Overload List
 | Name | Description
Public method | CodeRefactorEventArgs(Point, IListICodeRefactor) | Initializes HighlightCodeFixesEventArgs with specified arguments.
Public method | CodeRefactorEventArgs(Point, Point, IListICodeRefactor) | Initializes HighlightCodeFixesEventArgs with specified arguments.
Top
See Also

Reference

CodeRefactorEventArgs Class
Alternet.Syntax Namespace


CodeRefactorEventArgs Constructor (Point, IList(ICodeRefactor))

CodeRefactorEventArgs Constructor (Point, IListICodeRefactor)
Initializes HighlightCodeFixesEventArgs with specified arguments.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeRefactorEventArgs(
    Point position,
    IList<ICodeRefactor> codeRefactors
)
Public Sub New (
    position As Point,
    codeRefactors As IList(Of ICodeRefactor)
)
public:
CodeRefactorEventArgs(
    Point position,
    IList<ICodeRefactor^>^ codeRefactors
)
new :
        position : Point *
        codeRefactors : IList<ICodeRefactor> -> CodeRefactorEventArgs

Parameters

position
Type: System.DrawingPoint
Current position.
codeRefactors
Type: System.Collections.GenericIListICodeRefactor
See Also

Reference

CodeRefactorEventArgs Class
CodeRefactorEventArgs Overload
Alternet.Syntax Namespace


CodeRefactorEventArgs Constructor (Point, Point, IList(ICodeRefactor))

CodeRefactorEventArgs Constructor (Point, Point, IListICodeRefactor)
Initializes HighlightCodeFixesEventArgs with specified arguments.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeRefactorEventArgs(
    Point position,
    Point endPosition,
    IList<ICodeRefactor> codeRefactors
)
Public Sub New (
    position As Point,
    endPosition As Point,
    codeRefactors As IList(Of ICodeRefactor)
)
public:
CodeRefactorEventArgs(
    Point position,
    Point endPosition,
    IList<ICodeRefactor^>^ codeRefactors
)
new :
        position : Point *
        endPosition : Point *
        codeRefactors : IList<ICodeRefactor> -> CodeRefactorEventArgs

Parameters

position
Type: System.DrawingPoint
Current position.End position withi selected text.
endPosition
Type: System.DrawingPoint
codeRefactors
Type: System.Collections.GenericIListICodeRefactor
See Also

Reference

CodeRefactorEventArgs Class
CodeRefactorEventArgs Overload
Alternet.Syntax Namespace


CodeRefactorEventArgs Methods

CodeRefactorEventArgs Methods

The CodeRefactorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeRefactorEventArgs Class
Alternet.Syntax Namespace


CodeRefactorEventArgs Properties

CodeRefactorEventArgs Properties

The CodeRefactorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CodeRefactors |
Public property | EndPosition | Specifies end position of the code to be refactored.
Public property | Position | Specifies position of the code to be refactored.
Top
See Also

Reference

CodeRefactorEventArgs Class
Alternet.Syntax Namespace


CodeRefactorEventArgs.CodeRefactors Property

CodeRefactorEventArgsCodeRefactors Property

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ICodeRefactor> CodeRefactors { get; set; }
Public Property CodeRefactors As IList(Of ICodeRefactor)
    Get
    Set
public:
property IList<ICodeRefactor^>^ CodeRefactors {
    IList<ICodeRefactor^>^ get ();
    void set (IList<ICodeRefactor^>^ value);
}
member CodeRefactors : IList<ICodeRefactor> with get, set

Property Value

Type: IListICodeRefactor
See Also

Reference

CodeRefactorEventArgs Class
Alternet.Syntax Namespace


CodeRefactorEventArgs.EndPosition Property

CodeRefactorEventArgsEndPosition Property
Specifies end position of the code to be refactored.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point EndPosition { get; set; }
Public Property EndPosition As Point
    Get
    Set
public:
property Point EndPosition {
    Point get ();
    void set (Point value);
}
member EndPosition : Point with get, set

Property Value

Type: Point
See Also

Reference

CodeRefactorEventArgs Class
Alternet.Syntax Namespace


CodeRefactorEventArgs.Position Property

CodeRefactorEventArgsPosition Property
Specifies position of the code to be refactored.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point Position { get; set; }
Public Property Position As Point
    Get
    Set
public:
property Point Position {
    Point get ();
    void set (Point value);
}
member Position : Point with get, set

Property Value

Type: Point
See Also

Reference

CodeRefactorEventArgs Class
Alternet.Syntax Namespace


DescriptionLookupEvent Delegate

DescriptionLookupEvent Delegate
Represents a method that will handle the CodeCompletionRepository.DescriptionLookup event.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void DescriptionLookupEvent(
    Object sender,
    DescriptionLookupEventArgs e
)
Public Delegate Sub DescriptionLookupEvent (
    sender As Object,
    e As DescriptionLookupEventArgs
)
public delegate void DescriptionLookupEvent(
    Object^ sender,
    DescriptionLookupEventArgs^ e
)
type DescriptionLookupEvent =
    delegate of
        sender : Object *
        e : DescriptionLookupEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxDescriptionLookupEventArgs
The DescriptionLookupEventArgs that contains the event data.
See Also

Reference

Alternet.Syntax Namespace


DescriptionLookupEventArgs Class

DescriptionLookupEventArgs Class
Provides data for the ICodeCompletionRepository.DescriptionLookup event, used to search for the description of specified member.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxDescriptionLookupEventArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DescriptionLookupEventArgs : EventArgs
Public Class DescriptionLookupEventArgs
    Inherits EventArgs
public ref class DescriptionLookupEventArgs : public EventArgs
type DescriptionLookupEventArgs =
    class
        inherit EventArgs
    end

The DescriptionLookupEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DescriptionLookupEventArgs | Initializes a new instance of the DescriptionLookupEventArgs with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | Result string representing description of the member.
Public property | Member | Represents an object to lookup.
Public property | Name | The String containing the name of the object.
Top
See Also

Reference

Alternet.Syntax Namespace


DescriptionLookupEventArgs Constructor

DescriptionLookupEventArgs Constructor
Initializes a new instance of the DescriptionLookupEventArgs with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DescriptionLookupEventArgs(
    Object member,
    string name
)
Public Sub New (
    member As Object,
    name As String
)
public:
DescriptionLookupEventArgs(
    Object^ member,
    String^ name
)
new :
        member : Object *
        name : string -> DescriptionLookupEventArgs

Parameters

member
Type: SystemObject
Specifies Member property of this new instance.
name
Type: SystemString
Specifies Name property of this new instance.
See Also

Reference

DescriptionLookupEventArgs Class
Alternet.Syntax Namespace


DescriptionLookupEventArgs Methods

DescriptionLookupEventArgs Methods

The DescriptionLookupEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DescriptionLookupEventArgs Class
Alternet.Syntax Namespace


DescriptionLookupEventArgs Properties

DescriptionLookupEventArgs Properties

The DescriptionLookupEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Description | Result string representing description of the member.
Public property | Member | Represents an object to lookup.
Public property | Name | The String containing the name of the object.
Top
See Also

Reference

DescriptionLookupEventArgs Class
Alternet.Syntax Namespace


DescriptionLookupEventArgs.Description Property

DescriptionLookupEventArgsDescription Property
Result string representing description of the member.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

DescriptionLookupEventArgs Class
Alternet.Syntax Namespace


DescriptionLookupEventArgs.Member Property

DescriptionLookupEventArgsMember Property
Represents an object to lookup.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Member { get; set; }
Public Property Member As Object
    Get
    Set
public:
property Object^ Member {
    Object^ get ();
    void set (Object^ value);
}
member Member : Object with get, set

Property Value

Type: Object
See Also

Reference

DescriptionLookupEventArgs Class
Alternet.Syntax Namespace


DescriptionLookupEventArgs.Name Property

DescriptionLookupEventArgsName Property
The String containing the name of the object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

DescriptionLookupEventArgs Class
Alternet.Syntax Namespace


HighlightReferencesEventArgs Class

HighlightReferencesEventArgs Class
Provides data of the references to be highlighted.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxHighlightReferencesEventArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HighlightReferencesEventArgs : EventArgs
Public Class HighlightReferencesEventArgs
    Inherits EventArgs
public ref class HighlightReferencesEventArgs : public EventArgs
type HighlightReferencesEventArgs =
    class
        inherit EventArgs
    end

The HighlightReferencesEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | HighlightReferencesEventArgs | Initializes HighlightReferencesEventArgs with specified references.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | References | Gets or sets a list of IRange objects that contains code references.
Top
See Also

Reference

Alternet.Syntax Namespace


HighlightReferencesEventArgs Constructor

HighlightReferencesEventArgs Constructor
Initializes HighlightReferencesEventArgs with specified references.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HighlightReferencesEventArgs(
    IRangeList references
)
Public Sub New (
    references As IRangeList
)
public:
HighlightReferencesEventArgs(
    IRangeList^ references
)
new :
        references : IRangeList -> HighlightReferencesEventArgs

Parameters

references
Type: Alternet.CommonIRangeList
IRangeList contains area to be highlighted.
See Also

Reference

HighlightReferencesEventArgs Class
Alternet.Syntax Namespace


HighlightReferencesEventArgs Methods

HighlightReferencesEventArgs Methods

The HighlightReferencesEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HighlightReferencesEventArgs Class
Alternet.Syntax Namespace


HighlightReferencesEventArgs Properties

HighlightReferencesEventArgs Properties

The HighlightReferencesEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | References | Gets or sets a list of IRange objects that contains code references.
Top
See Also

Reference

HighlightReferencesEventArgs Class
Alternet.Syntax Namespace


HighlightReferencesEventArgs.References Property

HighlightReferencesEventArgsReferences Property
Gets or sets a list of IRange objects that contains code references.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRangeList References { get; set; }
Public Property References As IRangeList
    Get
    Set
public:
property IRangeList^ References {
    IRangeList^ get ();
    void set (IRangeList^ value);
}
member References : IRangeList with get, set

Property Value

Type: IRangeList
See Also

Reference

HighlightReferencesEventArgs Class
Alternet.Syntax Namespace


HtmlLexerToken Enumeration

HtmlLexerToken Enumeration
Represents lexical tokens for Html parser.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HtmlLexerToken
Public Enumeration HtmlLexerToken
public enum class HtmlLexerToken
type HtmlLexerToken
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
WhiteSpace | 1 | Specifies that lexical token corresponds to whitespace symbol.
Body | 2 | Specifies that lexical token corresponds to html body.
OpenTag | 3 | Specifies that lexical token corresponds to open tag.
CloseTag | 4 | Specifies that lexical token corresponds to close tag.
OpenEndTag | 5 | Specifies that lexical token corresponds to open end tag.
CloseEndTag | 6 | Specifies that lexical token corresponds to close end tag.
Equal | 7 | Specifies that lexical token corresponds to equality symbol.
TagName | 8 | Specifies that lexical token corresponds to name of tag.
ParamName | 9 | Specifies that lexical token corresponds to name of parameter.
ParamValue | 10 | Specifies that lexical token corresponds to parameter value.
Comment | 11 | Specifies that lexical token corresponds to html comment.
See Also

Reference

Alternet.Syntax Namespace


HtmlParser Class

HtmlParser Class
Represents properties and methods to perform syntax analysis of specified html code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.SyntaxXmlParser
Alternet.SyntaxHtmlParser

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HtmlParser : XmlParser
Public Class HtmlParser
    Inherits XmlParser
public ref class HtmlParser : public XmlParser
type HtmlParser =
    class
        inherit XmlParser
    end

The HtmlParser type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlParser | Initializes a new instance of the HtmlParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from XmlParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from XmlParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to it's default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Overrides XmlParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax Namespace


HtmlParser Constructor

HtmlParser Constructor
Initializes a new instance of the HtmlParser class

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HtmlParser()
Public Sub New
public:
HtmlParser()
new : unit -> HtmlParser
See Also

Reference

HtmlParser Class
Alternet.Syntax Namespace


HtmlParser Methods

HtmlParser Methods

The HtmlParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from XmlParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from XmlParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to it's default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

HtmlParser Class
Alternet.Syntax Namespace


HtmlParser.ResetAutoIndentChars Method

HtmlParserResetAutoIndentChars Method
Resets AutoIndentChars to it's default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

HtmlParser Class
Alternet.Syntax Namespace


HtmlParser Properties

HtmlParser Properties

The HtmlParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Overrides XmlParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

HtmlParser Class
Alternet.Syntax Namespace


HtmlParser.CaseSensitive Property

HtmlParserCaseSensitive Property
Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

HtmlParser Class
Alternet.Syntax Namespace


HtmlParser Events

HtmlParser Events

The HtmlParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

HtmlParser Class
Alternet.Syntax Namespace


ICodeFix Interface

ICodeFix Interface
Represents properties to describe a particular code fix action in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeFix : ICloneable
Public Interface ICodeFix
    Inherits ICloneable
public interface class ICodeFix : ICloneable
type ICodeFix =
    interface
        interface ICloneable
    end

The ICodeFix type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets code fix description.
Public property | TextChanges | When implemented by a class, gets or sets collection of code fix changes.
Top
See Also

Reference

Alternet.Syntax Namespace


ICodeFix Methods

ICodeFix Methods

The ICodeFix type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

ICodeFix Interface
Alternet.Syntax Namespace


ICodeFix Properties

ICodeFix Properties

The ICodeFix type exposes the following members.

Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets code fix description.
Public property | TextChanges | When implemented by a class, gets or sets collection of code fix changes.
Top
See Also

Reference

ICodeFix Interface
Alternet.Syntax Namespace


ICodeFix.Description Property

ICodeFixDescription Property
When implemented by a class, gets or sets code fix description.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

ICodeFix Interface
Alternet.Syntax Namespace


ICodeFix.TextChanges Property

ICodeFixTextChanges Property
When implemented by a class, gets or sets collection of code fix changes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ITextUndoList TextChanges { get; set; }
Property TextChanges As ITextUndoList
    Get
    Set
property ITextUndoList^ TextChanges {
    ITextUndoList^ get ();
    void set (ITextUndoList^ value);
}
abstract TextChanges : ITextUndoList with get, set

Property Value

Type: ITextUndoList
See Also

Reference

ICodeFix Interface
Alternet.Syntax Namespace


ICodeRefactor Interface

ICodeRefactor Interface
Represents properties to describe a particular code fix action in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeRefactor : ICloneable
Public Interface ICodeRefactor
    Inherits ICloneable
public interface class ICodeRefactor : ICloneable
type ICodeRefactor =
    interface
        interface ICloneable
    end

The ICodeRefactor type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | GetTextChanges | When implemented by a class, retrieves code changes for particular code refactor.
Top
Properties
 | Name | Description
Public property | ActionDescription | When implemented by a class, gets or sets code refactor action description.
Public property | ActionName | When implemented by a class, gets or sets code refactor action name.
Public property | Description | When implemented by a class, gets or sets code fix description.
Public property | EndPos | When implemneted by a class, gets or sets end position of the text being refactored.
Public property | Name | When implemented by a class, gets or sets code refactor name.
Public property | Position | When implemneted by a class, gets or sets start position of the text being refactored.
Public property | TextChangesFunc | When implemented by a class, gets or sets functions that retrieves code changes for particular code refactor.
Top
See Also

Reference

Alternet.Syntax Namespace


ICodeRefactor Methods

ICodeRefactor Methods

The ICodeRefactor type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | GetTextChanges | When implemented by a class, retrieves code changes for particular code refactor.
Top
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


ICodeRefactor.GetTextChanges Method

ICodeRefactorGetTextChanges Method
When implemented by a class, retrieves code changes for particular code refactor.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<ITextUndo> GetTextChanges(
    bool allDocuments
)
Function GetTextChanges (
    allDocuments As Boolean
) As IList(Of ITextUndo)
IList<ITextUndo^>^ GetTextChanges(
    bool allDocuments
)
abstract GetTextChanges :
        allDocuments : bool -> IList<ITextUndo>

Parameters

allDocuments
Type: SystemBoolean
Specifies if all documents in the solution needs to be processed.

Return Value

Type: IListITextUndo
List of changes if any, otherwise null.
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


ICodeRefactor Properties

ICodeRefactor Properties

The ICodeRefactor type exposes the following members.

Properties
 | Name | Description
Public property | ActionDescription | When implemented by a class, gets or sets code refactor action description.
Public property | ActionName | When implemented by a class, gets or sets code refactor action name.
Public property | Description | When implemented by a class, gets or sets code fix description.
Public property | EndPos | When implemneted by a class, gets or sets end position of the text being refactored.
Public property | Name | When implemented by a class, gets or sets code refactor name.
Public property | Position | When implemneted by a class, gets or sets start position of the text being refactored.
Public property | TextChangesFunc | When implemented by a class, gets or sets functions that retrieves code changes for particular code refactor.
Top
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


ICodeRefactor.ActionDescription Property

ICodeRefactorActionDescription Property
When implemented by a class, gets or sets code refactor action description.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ActionDescription { get; set; }
Property ActionDescription As String
    Get
    Set
property String^ ActionDescription {
    String^ get ();
    void set (String^ value);
}
abstract ActionDescription : string with get, set

Property Value

Type: String
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


ICodeRefactor.ActionName Property

ICodeRefactorActionName Property
When implemented by a class, gets or sets code refactor action name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ActionName { get; set; }
Property ActionName As String
    Get
    Set
property String^ ActionName {
    String^ get ();
    void set (String^ value);
}
abstract ActionName : string with get, set

Property Value

Type: String
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


ICodeRefactor.Description Property

ICodeRefactorDescription Property
When implemented by a class, gets or sets code fix description.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


ICodeRefactor.EndPos Property

ICodeRefactorEndPos Property
When implemneted by a class, gets or sets end position of the text being refactored.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point EndPos { get; set; }
Property EndPos As Point
    Get
    Set
property Point EndPos {
    Point get ();
    void set (Point value);
}
abstract EndPos : Point with get, set

Property Value

Type: Point
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


ICodeRefactor.Name Property

ICodeRefactorName Property
When implemented by a class, gets or sets code refactor name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


ICodeRefactor.Position Property

ICodeRefactorPosition Property
When implemneted by a class, gets or sets start position of the text being refactored.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Position { get; set; }
Property Position As Point
    Get
    Set
property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set

Property Value

Type: Point
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


ICodeRefactor.TextChangesFunc Property

ICodeRefactorTextChangesFunc Property
When implemented by a class, gets or sets functions that retrieves code changes for particular code refactor.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Func<ICodeRefactor, bool, IList<ITextUndo>> TextChangesFunc { get; set; }
Property TextChangesFunc As Func(Of ICodeRefactor, Boolean, IList(Of ITextUndo))
    Get
    Set
property Func<ICodeRefactor^, bool, IList<ITextUndo^>^>^ TextChangesFunc {
    Func<ICodeRefactor^, bool, IList<ITextUndo^>^>^ get ();
    void set (Func<ICodeRefactor^, bool, IList<ITextUndo^>^>^ value);
}
abstract TextChangesFunc : Func<ICodeRefactor, bool, IList<ITextUndo>> with get, set

Property Value

Type: FuncICodeRefactor, Boolean, IListITextUndo
See Also

Reference

ICodeRefactor Interface
Alternet.Syntax Namespace


IExport Interface

IExport Interface
Represents methods to save text content.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExport
Public Interface IExport
public interface class IExport
type IExport =  interface end
Methods
 | Name | Description
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file.
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding.
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream.
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream.
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream.
Top
See Also

Reference

Alternet.Syntax Namespace


IExport Methods

IExport Methods
Methods
 | Name | Description
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file.
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding.
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream.
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream.
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream.
Top
See Also

Reference

IExport Interface
Alternet.Syntax Namespace


IExport.SaveFile Method

IExportSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file.
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding.
Top
See Also

Reference

IExport Interface
Alternet.Syntax Namespace


IExport.SaveFile Method (String)

IExportSaveFile Method (String)
When implemented by a class, saves text content to the specific file.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveFile(
    string fileName
)
Function SaveFile (
    fileName As String
) As Boolean
bool SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IExport Interface
SaveFile Overload
Alternet.Syntax Namespace


IExport.SaveFile Method (String, Encoding)

IExportSaveFile Method (String, Encoding)
When implemented by a class, saves text content to the specific file with specific encoding.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveFile(
    string fileName,
    Encoding encoding
)
Function SaveFile (
    fileName As String,
    encoding As Encoding
) As Boolean
bool SaveFile(
    String^ fileName,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IExport Interface
SaveFile Overload
Alternet.Syntax Namespace


IExport.SaveStream Method

IExportSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream.
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream.
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream.
Top
See Also

Reference

IExport Interface
Alternet.Syntax Namespace


IExport.SaveStream Method (Stream)

IExportSaveStream Method (Stream)
When implemented by a class, saves the text content to the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveStream(
    Stream stream
)
Function SaveStream (
    stream As Stream
) As Boolean
bool SaveStream(
    Stream^ stream
)
abstract SaveStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IExport Interface
SaveStream Overload
Alternet.Syntax Namespace


IExport.SaveStream Method (TextWriter)

IExportSaveStream Method (TextWriter)
When implemented by a class, saves the text content to the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveStream(
    TextWriter writer
)
Function SaveStream (
    writer As TextWriter
) As Boolean
bool SaveStream(
    TextWriter^ writer
)
abstract SaveStream :
        writer : TextWriter -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IExport Interface
SaveStream Overload
Alternet.Syntax Namespace


IExport.SaveStream Method (Stream, Encoding)

IExportSaveStream Method (Stream, Encoding)
When implemented by a class, saves the text content to the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SaveStream(
    Stream stream,
    Encoding encoding
)
Function SaveStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
bool SaveStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IExport Interface
SaveStream Overload
Alternet.Syntax Namespace


IExpressionEvaluator Interface

IExpressionEvaluator Interface
Represents properties and methods used to evaluate conditional defines.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExpressionEvaluator
Public Interface IExpressionEvaluator
public interface class IExpressionEvaluator
type IExpressionEvaluator =  interface end

The IExpressionEvaluator type exposes the following members.

Methods
 | Name | Description
Public method | AddDefine | When implemented by a class, adds given node to the list of evaluation defines.
Public method | AddUndefinedSection | When implemented by a class, add new undefined section.
Public method | Clear | When implemented by a class, clears content of IExpressionEvaluator.
Public method | EvaluateExpression(String) | When implemented by a class, evaluates given expression.
Public method | EvaluateExpression(ISyntaxNode) | When implemented by a class, evaluates content of given node.
Public method | IsLiteral | When implemented by a class, indicates whether specified value is literal.
Public method | RemoveDefine | When implemented by a class, removes specified define from the evaluation defines list.
Top
Properties
 | Name | Description
Public property | UndefinedSections | When implemented by a class, gets list of undefined sections.
Top
See Also

Reference

Alternet.Syntax Namespace


IExpressionEvaluator Methods

IExpressionEvaluator Methods

The IExpressionEvaluator type exposes the following members.

Methods
 | Name | Description
Public method | AddDefine | When implemented by a class, adds given node to the list of evaluation defines.
Public method | AddUndefinedSection | When implemented by a class, add new undefined section.
Public method | Clear | When implemented by a class, clears content of IExpressionEvaluator.
Public method | EvaluateExpression(String) | When implemented by a class, evaluates given expression.
Public method | EvaluateExpression(ISyntaxNode) | When implemented by a class, evaluates content of given node.
Public method | IsLiteral | When implemented by a class, indicates whether specified value is literal.
Public method | RemoveDefine | When implemented by a class, removes specified define from the evaluation defines list.
Top
See Also

Reference

IExpressionEvaluator Interface
Alternet.Syntax Namespace


IExpressionEvaluator.AddDefine Method

IExpressionEvaluatorAddDefine Method
When implemented by a class, adds given node to the list of evaluation defines.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddDefine(
    ISyntaxNode node
)
Sub AddDefine (
    node As ISyntaxNode
)
void AddDefine(
    ISyntaxNode^ node
)
abstract AddDefine :
        node : ISyntaxNode -> unit

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to add.
See Also

Reference

IExpressionEvaluator Interface
Alternet.Syntax Namespace


IExpressionEvaluator.AddUndefinedSection Method

IExpressionEvaluatorAddUndefinedSection Method
When implemented by a class, add new undefined section.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddUndefinedSection(
    Point start,
    Point end
)
Sub AddUndefinedSection (
    start As Point,
    end As Point
)
void AddUndefinedSection(
    Point start,
    Point end
)
abstract AddUndefinedSection :
        start : Point *
        end : Point -> unit

Parameters

start
Type: System.DrawingPoint
Start point of undefined section.
end
Type: System.DrawingPoint
End point of undefined section.
See Also

Reference

IExpressionEvaluator Interface
Alternet.Syntax Namespace


IExpressionEvaluator.Clear Method

IExpressionEvaluatorClear Method
When implemented by a class, clears content of IExpressionEvaluator.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

IExpressionEvaluator Interface
Alternet.Syntax Namespace


IExpressionEvaluator.EvaluateExpression Method

IExpressionEvaluatorEvaluateExpression Method
Overload List
 | Name | Description
Public method | EvaluateExpression(String) | When implemented by a class, evaluates given expression.
Public method | EvaluateExpression(ISyntaxNode) | When implemented by a class, evaluates content of given node.
Top
See Also

Reference

IExpressionEvaluator Interface
Alternet.Syntax Namespace


IExpressionEvaluator.EvaluateExpression Method (String)

IExpressionEvaluatorEvaluateExpression Method (String)
When implemented by a class, evaluates given expression.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object EvaluateExpression(
    string value
)
Function EvaluateExpression (
    value As String
) As Object
Object^ EvaluateExpression(
    String^ value
)
abstract EvaluateExpression :
        value : string -> Object

Parameters

value
Type: SystemString
Expression to evaluate.

Return Value

Type: Object
Result of evaluation.
See Also

Reference

IExpressionEvaluator Interface
EvaluateExpression Overload
Alternet.Syntax Namespace


IExpressionEvaluator.EvaluateExpression Method (ISyntaxNode)

IExpressionEvaluatorEvaluateExpression Method (ISyntaxNode)
When implemented by a class, evaluates content of given node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool EvaluateExpression(
    ISyntaxNode node
)
Function EvaluateExpression (
    node As ISyntaxNode
) As Boolean
bool EvaluateExpression(
    ISyntaxNode^ node
)
abstract EvaluateExpression :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to evaluate.

Return Value

Type: Boolean
Result of evaluation.
See Also

Reference

IExpressionEvaluator Interface
EvaluateExpression Overload
Alternet.Syntax Namespace


IExpressionEvaluator.IsLiteral Method

IExpressionEvaluatorIsLiteral Method
When implemented by a class, indicates whether specified value is literal.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsLiteral(
    string value,
    out Object obj
)
Function IsLiteral (
    value As String,
    <OutAttribute> ByRef obj As Object
) As Boolean
bool IsLiteral(
    String^ value,
    [OutAttribute] Object^% obj
)
abstract IsLiteral :
        value : string *
        obj : Object byref -> bool

Parameters

value
Type: SystemString
String to check up.
obj
Type: SystemObject
Receives literal equivalent.

Return Value

Type: Boolean
True if value is literal; otherwise false.
See Also

Reference

IExpressionEvaluator Interface
Alternet.Syntax Namespace


IExpressionEvaluator.RemoveDefine Method

IExpressionEvaluatorRemoveDefine Method
When implemented by a class, removes specified define from the evaluation defines list.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveDefine(
    string name
)
Sub RemoveDefine (
    name As String
)
void RemoveDefine(
    String^ name
)
abstract RemoveDefine :
        name : string -> unit

Parameters

name
Type: SystemString
Name of define to remove.
See Also

Reference

IExpressionEvaluator Interface
Alternet.Syntax Namespace


IExpressionEvaluator Properties

IExpressionEvaluator Properties

The IExpressionEvaluator type exposes the following members.

Properties
 | Name | Description
Public property | UndefinedSections | When implemented by a class, gets list of undefined sections.
Top
See Also

Reference

IExpressionEvaluator Interface
Alternet.Syntax Namespace


IExpressionEvaluator.UndefinedSections Property

IExpressionEvaluatorUndefinedSections Property
When implemented by a class, gets list of undefined sections.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Rectangle[] UndefinedSections { get; }
ReadOnly Property UndefinedSections As Rectangle()
    Get
property array<Rectangle>^ UndefinedSections {
    array<Rectangle>^ get ();
}
abstract UndefinedSections : Rectangle[] with get

Property Value

Type: Rectangle
See Also

Reference

IExpressionEvaluator Interface
Alternet.Syntax Namespace


IImport Interface

IImport Interface
Represents methods to load text content.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IImport
Public Interface IImport
public interface class IImport
type IImport =  interface end
Methods
 | Name | Description
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding.
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream.
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream.
Top
See Also

Reference

Alternet.Syntax Namespace


IImport Methods

IImport Methods
Methods
 | Name | Description
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding.
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream.
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream.
Top
See Also

Reference

IImport Interface
Alternet.Syntax Namespace


IImport.LoadFile Method

IImportLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding.
Top
See Also

Reference

IImport Interface
Alternet.Syntax Namespace


IImport.LoadFile Method (String)

IImportLoadFile Method (String)
When implemented by a class, loads the contents of the specified file.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadFile(
    string fileName
)
Function LoadFile (
    fileName As String
) As Boolean
bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IImport Interface
LoadFile Overload
Alternet.Syntax Namespace


IImport.LoadFile Method (String, Encoding)

IImportLoadFile Method (String, Encoding)
When implemented by a class, loads the contents of the specified file with specified encoding.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadFile(
    string fileName,
    Encoding encoding
)
Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
bool LoadFile(
    String^ fileName,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IImport Interface
LoadFile Overload
Alternet.Syntax Namespace


IImport.LoadStream Method

IImportLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream.
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream.
Top
See Also

Reference

IImport Interface
Alternet.Syntax Namespace


IImport.LoadStream Method (Stream)

IImportLoadStream Method (Stream)
When implemented by a class, loads the contents of the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadStream(
    Stream stream
)
Function LoadStream (
    stream As Stream
) As Boolean
bool LoadStream(
    Stream^ stream
)
abstract LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IImport Interface
LoadStream Overload
Alternet.Syntax Namespace


IImport.LoadStream Method (TextReader)

IImportLoadStream Method (TextReader)
When implemented by a class, loads the contents of the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadStream(
    TextReader reader
)
Function LoadStream (
    reader As TextReader
) As Boolean
bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IImport Interface
LoadStream Overload
Alternet.Syntax Namespace


IImport.LoadStream Method (Stream, Encoding)

IImportLoadStream Method (Stream, Encoding)
When implemented by a class, loads the contents of the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool LoadStream(
    Stream stream,
    Encoding encoding
)
Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.
See Also

Reference

IImport Interface
LoadStream Overload
Alternet.Syntax Namespace


IOutlineRange Interface

IOutlineRange Interface
Represents individual outlining section that can appear in the Edit control.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IOutlineRange : IRange,
    ICloneable
Public Interface IOutlineRange
    Inherits IRange, ICloneable
public interface class IOutlineRange : IRange,
    ICloneable
type IOutlineRange =
    interface
        interface IRange
        interface ICloneable
    end

The IOutlineRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from IRange.)
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
Properties
 | Name | Description
Public property | CanExpand |
Public property | DisplayText | When implemented by a class, represents text substituting collapsed outline section if outline buttons are displayed.
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area. (Inherited from IRange.)
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size. (Inherited from IRange.)
Public property | Level | When implemented by a class, represents level of outline nesting for the outline section.
Public property | Size | When implemented by a class, gets or sets size of IRange area. (Inherited from IRange.)
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area. (Inherited from IRange.)
Public property | Text | When implemented by a class, represents text substituting collapsed outline section.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether outline section is visible (expanded).
Top
See Also

Reference

Alternet.Syntax Namespace


IOutlineRange Methods

IOutlineRange Methods

The IOutlineRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from IRange.)
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

IOutlineRange Interface
Alternet.Syntax Namespace


IOutlineRange Properties

IOutlineRange Properties

The IOutlineRange type exposes the following members.

Properties
 | Name | Description
Public property | CanExpand |
Public property | DisplayText | When implemented by a class, represents text substituting collapsed outline section if outline buttons are displayed.
Public property | EndPoint | When implemented by a class, gets or sets end of IRange area. (Inherited from IRange.)
Public property | IsEmpty | When implemented by a class, gets boolean value indicating whether IRange has zero size. (Inherited from IRange.)
Public property | Level | When implemented by a class, represents level of outline nesting for the outline section.
Public property | Size | When implemented by a class, gets or sets size of IRange area. (Inherited from IRange.)
Public property | StartPoint | When implemented by a class, gets or sets begin of IRange area. (Inherited from IRange.)
Public property | Text | When implemented by a class, represents text substituting collapsed outline section.
Public property | Visible | When implemented by a class, gets or sets a value indicating whether outline section is visible (expanded).
Top
See Also

Reference

IOutlineRange Interface
Alternet.Syntax Namespace


IOutlineRange.CanExpand Property

IOutlineRangeCanExpand Property

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanExpand { get; }
ReadOnly Property CanExpand As Boolean
    Get
property bool CanExpand {
    bool get ();
}
abstract CanExpand : bool with get

Property Value

Type: Boolean
See Also

Reference

IOutlineRange Interface
Alternet.Syntax Namespace


IOutlineRange.DisplayText Property

IOutlineRangeDisplayText Property
When implemented by a class, represents text substituting collapsed outline section if outline buttons are displayed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string DisplayText { get; }
ReadOnly Property DisplayText As String
    Get
property String^ DisplayText {
    String^ get ();
}
abstract DisplayText : string with get

Property Value

Type: String
See Also

Reference

IOutlineRange Interface
Alternet.Syntax Namespace


IOutlineRange.Level Property

IOutlineRangeLevel Property
When implemented by a class, represents level of outline nesting for the outline section.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Level { get; set; }
Property Level As Integer
    Get
    Set
property int Level {
    int get ();
    void set (int value);
}
abstract Level : int with get, set

Property Value

Type: Int32
See Also

Reference

IOutlineRange Interface
Alternet.Syntax Namespace


IOutlineRange.Text Property

IOutlineRangeText Property
When implemented by a class, represents text substituting collapsed outline section.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IOutlineRange Interface
Alternet.Syntax Namespace


IOutlineRange.Visible Property

IOutlineRangeVisible Property
When implemented by a class, gets or sets a value indicating whether outline section is visible (expanded).

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Visible { get; set; }
Property Visible As Boolean
    Get
    Set
property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IOutlineRange Interface
Alternet.Syntax Namespace


IParser Interface

IParser Interface
Represents properties and methods for perform lexical analysis of the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IParser : ILexer,
    INotify, IUpdate
Public Interface IParser
    Inherits ILexer, INotify, IUpdate
public interface class IParser : ILexer,
    INotify, IUpdate
type IParser =
    interface
        interface ILexer
        interface INotify
        interface IUpdate
    end

The IParser type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexer object. (Inherited from ILexer.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | NextToken | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextToken(String) | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken(String) | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | When implemented by a class, performs lexical analysis of given text. (Inherited from ILexer.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | When implemented by a class, performs lexical analysis of given text. (Inherited from ILexer.)
Public method | PeekToken | When implemented by a class, parses next portion of the text, remaining current position unchanged.
Public method | PeekToken(String) | When implemented by a class, parses next portion of the text, remaining current position unchanged.
Public method | PeekValidToken | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | PeekValidToken(String) | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | RemovePlainText | When implemented by a class, removes all plain (string constants or comments) parts of text from specified text. (Inherited from ILexer.)
Public method | Reset | When implemented by a class, resets IParser to the start position.
Public method | Reset(Int32, Int32, Int32) | When implemented by a class, resets IParser to the specified position.
Public method | ResetDefaultState | When implemented by a class, resets the DefaultState to the default value. (Inherited from ILexer.)
Public method | RestoreState | When implemented by a class, restores IParser state and position stored by SaveState method.
Public method | RestoreState(Boolean) | When implemented by a class, restores IParser state and position stored by SaveState method.
Public method | SaveState | When implemented by a class, saves current IParser state and position.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | CurrentPosition | When implemented by a class, represents position of current character within the current line.
Public property | DefaultState | When implemented by a class, gets or sets default state of the ILexer. (Inherited from ILexer.)
Public property | Eof | When implemented by a class, indicates whether current position is out of the text, signaling that whole text is parsed.
Public property | Lines | When implemented by a class, gets or sets a list of string to parse represented as string array.
Public property | Scheme | When implemented by a class, gets or sets list of rules for lexical analysis. (Inherited from ILexer.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of ILexer. (Inherited from ILexer.)
Public property | State | When implemented by a class, represents current IParser state.
Public property | Strings | When implemented by a class, gets or sets a list of strings to parse.
Public property | Token | When implemented by a class, represents token (index of style in the class style collection) related to the current position in the parsed text.
Public property | TokenPosition | When implemented by a class, represents start position of the current token.
Public property | TokenString | When implemented by a class, represents text of the current syntax token.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
Events
 | Name | Description
Public event | Parse | When implemented by a class, occurs when text line is parsed, allowing to modify colors/styles information for the parsed line. (Inherited from ILexer.)
Top
See Also

Reference

Alternet.Syntax Namespace


IParser Methods

IParser Methods

The IParser type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexer object. (Inherited from ILexer.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | NextToken | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextToken(String) | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken(String) | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | When implemented by a class, performs lexical analysis of given text. (Inherited from ILexer.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | When implemented by a class, performs lexical analysis of given text. (Inherited from ILexer.)
Public method | PeekToken | When implemented by a class, parses next portion of the text, remaining current position unchanged.
Public method | PeekToken(String) | When implemented by a class, parses next portion of the text, remaining current position unchanged.
Public method | PeekValidToken | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | PeekValidToken(String) | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | RemovePlainText | When implemented by a class, removes all plain (string constants or comments) parts of text from specified text. (Inherited from ILexer.)
Public method | Reset | When implemented by a class, resets IParser to the start position.
Public method | Reset(Int32, Int32, Int32) | When implemented by a class, resets IParser to the specified position.
Public method | ResetDefaultState | When implemented by a class, resets the DefaultState to the default value. (Inherited from ILexer.)
Public method | RestoreState | When implemented by a class, restores IParser state and position stored by SaveState method.
Public method | RestoreState(Boolean) | When implemented by a class, restores IParser state and position stored by SaveState method.
Public method | SaveState | When implemented by a class, saves current IParser state and position.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.NextToken Method

IParserNextToken Method
Overload List
 | Name | Description
Public method | NextToken | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextToken(String) | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Top
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.NextToken Method

IParserNextToken Method
When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int NextToken()
Function NextToken As Integer
int NextToken()
abstract NextToken : unit -> int

Return Value

Type: Int32
Token that corresponds to the next position.
See Also

Reference

IParser Interface
NextToken Overload
Alternet.Syntax Namespace


IParser.NextToken Method (String)

IParserNextToken Method (String)
When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int NextToken(
    out string str
)
Function NextToken (
    <OutAttribute> ByRef str As String
) As Integer
int NextToken(
    [OutAttribute] String^% str
)
abstract NextToken :
        str : string byref -> int

Parameters

str
Type: SystemString
Retrieves token string for the next token.

Return Value

Type: Int32
Token that corresponds to the next position.
See Also

Reference

IParser Interface
NextToken Overload
Alternet.Syntax Namespace


IParser.NextValidToken Method

IParserNextValidToken Method
Overload List
 | Name | Description
Public method | NextValidToken | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken(String) | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Top
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.NextValidToken Method

IParserNextValidToken Method
When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int NextValidToken()
Function NextValidToken As Integer
int NextValidToken()
abstract NextValidToken : unit -> int

Return Value

Type: Int32
Next valid token.
See Also

Reference

IParser Interface
NextValidToken Overload
Alternet.Syntax Namespace


IParser.NextValidToken Method (String)

IParserNextValidToken Method (String)
When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int NextValidToken(
    out string str
)
Function NextValidToken (
    <OutAttribute> ByRef str As String
) As Integer
int NextValidToken(
    [OutAttribute] String^% str
)
abstract NextValidToken :
        str : string byref -> int

Parameters

str
Type: SystemString
Retrieves token string for the next valid token.

Return Value

Type: Int32
Next valid token.
See Also

Reference

IParser Interface
NextValidToken Overload
Alternet.Syntax Namespace


IParser.PeekToken Method

IParserPeekToken Method
Overload List
 | Name | Description
Public method | PeekToken | When implemented by a class, parses next portion of the text, remaining current position unchanged.
Public method | PeekToken(String) | When implemented by a class, parses next portion of the text, remaining current position unchanged.
Top
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.PeekToken Method

IParserPeekToken Method
When implemented by a class, parses next portion of the text, remaining current position unchanged.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int PeekToken()
Function PeekToken As Integer
int PeekToken()
abstract PeekToken : unit -> int

Return Value

Type: Int32
Token that corresponds to the next position.
See Also

Reference

IParser Interface
PeekToken Overload
Alternet.Syntax Namespace


IParser.PeekToken Method (String)

IParserPeekToken Method (String)
When implemented by a class, parses next portion of the text, remaining current position unchanged.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int PeekToken(
    out string str
)
Function PeekToken (
    <OutAttribute> ByRef str As String
) As Integer
int PeekToken(
    [OutAttribute] String^% str
)
abstract PeekToken :
        str : string byref -> int

Parameters

str
Type: SystemString
Retrieves token string for the next token.

Return Value

Type: Int32
Token that corresponds to the next position.
See Also

Reference

IParser Interface
PeekToken Overload
Alternet.Syntax Namespace


IParser.PeekValidToken Method

IParserPeekValidToken Method
Overload List
 | Name | Description
Public method | PeekValidToken | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | PeekValidToken(String) | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Top
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.PeekValidToken Method

IParserPeekValidToken Method
When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int PeekValidToken()
Function PeekValidToken As Integer
int PeekValidToken()
abstract PeekValidToken : unit -> int

Return Value

Type: Int32
Next valid token.
See Also

Reference

IParser Interface
PeekValidToken Overload
Alternet.Syntax Namespace


IParser.PeekValidToken Method (String)

IParserPeekValidToken Method (String)
When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int PeekValidToken(
    out string str
)
Function PeekValidToken (
    <OutAttribute> ByRef str As String
) As Integer
int PeekValidToken(
    [OutAttribute] String^% str
)
abstract PeekValidToken :
        str : string byref -> int

Parameters

str
Type: SystemString
Retrieves token string for the next valid token.

Return Value

Type: Int32
Next valid token.
See Also

Reference

IParser Interface
PeekValidToken Overload
Alternet.Syntax Namespace


IParser.Reset Method

IParserReset Method
Overload List
 | Name | Description
Public method | Reset | When implemented by a class, resets IParser to the start position.
Public method | Reset(Int32, Int32, Int32) | When implemented by a class, resets IParser to the specified position.
Top
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.Reset Method

IParserReset Method
When implemented by a class, resets IParser to the start position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IParser Interface
Reset Overload
Alternet.Syntax Namespace


IParser.Reset Method (Int32, Int32, Int32)

IParserReset Method (Int32, Int32, Int32)
When implemented by a class, resets IParser to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Reset(
    int line,
    int pos,
    int state
)
Sub Reset (
    line As Integer,
    pos As Integer,
    state As Integer
)
void Reset(
    int line,
    int pos,
    int state
)
abstract Reset :
        line : int *
        pos : int *
        state : int -> unit

Parameters

line
Type: SystemInt32
Specifies new line index.
pos
Type: SystemInt32
Specifies new position of character within the line.
state
Type: SystemInt32
Specifies new State.
See Also

Reference

IParser Interface
Reset Overload
Alternet.Syntax Namespace


IParser.RestoreState Method

IParserRestoreState Method
Overload List
 | Name | Description
Public method | RestoreState | When implemented by a class, restores IParser state and position stored by SaveState method.
Public method | RestoreState(Boolean) | When implemented by a class, restores IParser state and position stored by SaveState method.
Top
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.RestoreState Method

IParserRestoreState Method
When implemented by a class, restores IParser state and position stored by SaveState method.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RestoreState()
Sub RestoreState
void RestoreState()
abstract RestoreState : unit -> unit
See Also

Reference

IParser Interface
RestoreState Overload
Alternet.Syntax Namespace


IParser.RestoreState Method (Boolean)

IParserRestoreState Method (Boolean)
When implemented by a class, restores IParser state and position stored by SaveState method.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RestoreState(
    bool restore
)
Sub RestoreState (
    restore As Boolean
)
void RestoreState(
    bool restore
)
abstract RestoreState :
        restore : bool -> unit

Parameters

restore
Type: SystemBoolean
Indicates whether IParser should restore it's state to previous position or simply delete information about previously stored state.
See Also

Reference

IParser Interface
RestoreState Overload
Alternet.Syntax Namespace


IParser.SaveState Method

IParserSaveState Method
When implemented by a class, saves current IParser state and position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SaveState()
Sub SaveState
void SaveState()
abstract SaveState : unit -> unit
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser Properties

IParser Properties

The IParser type exposes the following members.

Properties
 | Name | Description
Public property | CurrentPosition | When implemented by a class, represents position of current character within the current line.
Public property | DefaultState | When implemented by a class, gets or sets default state of the ILexer. (Inherited from ILexer.)
Public property | Eof | When implemented by a class, indicates whether current position is out of the text, signaling that whole text is parsed.
Public property | Lines | When implemented by a class, gets or sets a list of string to parse represented as string array.
Public property | Scheme | When implemented by a class, gets or sets list of rules for lexical analysis. (Inherited from ILexer.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of ILexer. (Inherited from ILexer.)
Public property | State | When implemented by a class, represents current IParser state.
Public property | Strings | When implemented by a class, gets or sets a list of strings to parse.
Public property | Token | When implemented by a class, represents token (index of style in the class style collection) related to the current position in the parsed text.
Public property | TokenPosition | When implemented by a class, represents start position of the current token.
Public property | TokenString | When implemented by a class, represents text of the current syntax token.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.CurrentPosition Property

IParserCurrentPosition Property
When implemented by a class, represents position of current character within the current line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point CurrentPosition { get; }
ReadOnly Property CurrentPosition As Point
    Get
property Point CurrentPosition {
    Point get ();
}
abstract CurrentPosition : Point with get

Property Value

Type: Point
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.Eof Property

IParserEof Property
When implemented by a class, indicates whether current position is out of the text, signaling that whole text is parsed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Eof { get; }
ReadOnly Property Eof As Boolean
    Get
property bool Eof {
    bool get ();
}
abstract Eof : bool with get

Property Value

Type: Boolean
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.Lines Property

IParserLines Property
When implemented by a class, gets or sets a list of string to parse represented as string array.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] Lines { get; set; }
Property Lines As String()
    Get
    Set
property array<String^>^ Lines {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract Lines : string[] with get, set

Property Value

Type: String
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.State Property

IParserState Property
When implemented by a class, represents current IParser state.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int State { get; set; }
Property State As Integer
    Get
    Set
property int State {
    int get ();
    void set (int value);
}
abstract State : int with get, set

Property Value

Type: Int32
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.Strings Property

IParserStrings Property
When implemented by a class, gets or sets a list of strings to parse.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IStringList Strings { get; set; }
Property Strings As IStringList
    Get
    Set
property IStringList^ Strings {
    IStringList^ get ();
    void set (IStringList^ value);
}
abstract Strings : IStringList with get, set

Property Value

Type: IStringList
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.Token Property

IParserToken Property
When implemented by a class, represents token (index of style in the class style collection) related to the current position in the parsed text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Token { get; set; }
Property Token As Integer
    Get
    Set
property int Token {
    int get ();
    void set (int value);
}
abstract Token : int with get, set

Property Value

Type: Int32
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.TokenPosition Property

IParserTokenPosition Property
When implemented by a class, represents start position of the current token.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point TokenPosition { get; }
ReadOnly Property TokenPosition As Point
    Get
property Point TokenPosition {
    Point get ();
}
abstract TokenPosition : Point with get

Property Value

Type: Point
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser.TokenString Property

IParserTokenString Property
When implemented by a class, represents text of the current syntax token.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string TokenString { get; }
ReadOnly Property TokenString As String
    Get
property String^ TokenString {
    String^ get ();
}
abstract TokenString : string with get

Property Value

Type: String
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IParser Events

IParser Events

The IParser type exposes the following members.

Events
 | Name | Description
Public event | Parse | When implemented by a class, occurs when text line is parsed, allowing to modify colors/styles information for the parsed line. (Inherited from ILexer.)
Top
See Also

Reference

IParser Interface
Alternet.Syntax Namespace


IStringItem Interface

IStringItem Interface
Represents properties and methods of individual line in the Text Source.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStringItem
Public Interface IStringItem
public interface class IStringItem
type IStringItem =  interface end

The IStringItem type exposes the following members.

Methods
 | Name | Description
Public method | ClearTextStyle | When implemented by a class, removes color information from text fragment.
Public method | SetTextStyle | When implemented by a class, sets text style to text fragment.
Public method | TextStyleAt | When implemented by a class, retrieves text style from the text.
Top
Properties
 | Name | Description
Public property | LexState | When implemented by a class, gets or sets index of lexical state at item end.
Public property | PrevLexState | When implemented by a class, gets or sets index of lexical state at item start.
Public property | State | When implemented by a class, gets or sets current state of the IStrItem.
Public property | String | When implemented by a class, gets or sets string content of the IStrItem.
Public property | TextData | When implemented by a class, gets or sets color information of the IStrItem.
Top
See Also

Reference

Alternet.Syntax Namespace


IStringItem Methods

IStringItem Methods

The IStringItem type exposes the following members.

Methods
 | Name | Description
Public method | ClearTextStyle | When implemented by a class, removes color information from text fragment.
Public method | SetTextStyle | When implemented by a class, sets text style to text fragment.
Public method | TextStyleAt | When implemented by a class, retrieves text style from the text.
Top
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringItem.ClearTextStyle Method

IStringItemClearTextStyle Method
When implemented by a class, removes color information from text fragment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearTextStyle(
    int start,
    int len,
    TextStyle style
)
Sub ClearTextStyle (
    start As Integer,
    len As Integer,
    style As TextStyle
)
void ClearTextStyle(
    int start,
    int len,
    TextStyle style
)
abstract ClearTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit

Parameters

start
Type: SystemInt32
Specifies the first character in the string.
len
Type: SystemInt32
Specifies number of characters in the string.
style
Type: Alternet.SyntaxTextStyle
Specifies style to clear.
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringItem.SetTextStyle Method

IStringItemSetTextStyle Method
When implemented by a class, sets text style to text fragment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetTextStyle(
    int start,
    int len,
    TextStyle style
)
Sub SetTextStyle (
    start As Integer,
    len As Integer,
    style As TextStyle
)
void SetTextStyle(
    int start,
    int len,
    TextStyle style
)
abstract SetTextStyle :
        start : int *
        len : int *
        style : TextStyle -> unit

Parameters

start
Type: SystemInt32
Specifies the first character in the string.
len
Type: SystemInt32
Specifies number of characters in the string.
style
Type: Alternet.SyntaxTextStyle
Specifies style to set.
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringItem.TextStyleAt Method

IStringItemTextStyleAt Method
When implemented by a class, retrieves text style from the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TextStyle TextStyleAt(
    int pos
)
Function TextStyleAt (
    pos As Integer
) As TextStyle
TextStyle TextStyleAt(
    int pos
)
abstract TextStyleAt :
        pos : int -> TextStyle

Parameters

pos
Type: SystemInt32
Specifies position in the string to get text style.

Return Value

Type: TextStyle
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringItem Properties

IStringItem Properties

The IStringItem type exposes the following members.

Properties
 | Name | Description
Public property | LexState | When implemented by a class, gets or sets index of lexical state at item end.
Public property | PrevLexState | When implemented by a class, gets or sets index of lexical state at item start.
Public property | State | When implemented by a class, gets or sets current state of the IStrItem.
Public property | String | When implemented by a class, gets or sets string content of the IStrItem.
Public property | TextData | When implemented by a class, gets or sets color information of the IStrItem.
Top
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringItem.LexState Property

IStringItemLexState Property
When implemented by a class, gets or sets index of lexical state at item end.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int LexState { get; set; }
Property LexState As Integer
    Get
    Set
property int LexState {
    int get ();
    void set (int value);
}
abstract LexState : int with get, set

Property Value

Type: Int32
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringItem.PrevLexState Property

IStringItemPrevLexState Property
When implemented by a class, gets or sets index of lexical state at item start.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int PrevLexState { get; set; }
Property PrevLexState As Integer
    Get
    Set
property int PrevLexState {
    int get ();
    void set (int value);
}
abstract PrevLexState : int with get, set

Property Value

Type: Int32
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringItem.State Property

IStringItemState Property
When implemented by a class, gets or sets current state of the IStrItem.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ItemState State { get; set; }
Property State As ItemState
    Get
    Set
property ItemState State {
    ItemState get ();
    void set (ItemState value);
}
abstract State : ItemState with get, set

Property Value

Type: ItemState
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringItem.String Property

IStringItemString Property
When implemented by a class, gets or sets string content of the IStrItem.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string String { get; set; }
Property String As String
    Get
    Set
property String^ String {
    String^ get ();
    void set (String^ value);
}
abstract String : string with get, set

Property Value

Type: String
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringItem.TextData Property

IStringItemTextData Property
When implemented by a class, gets or sets color information of the IStrItem.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
StringItemInfo[] TextData { get; set; }
Property TextData As StringItemInfo()
    Get
    Set
property array<StringItemInfo>^ TextData {
    array<StringItemInfo>^ get ();
    void set (array<StringItemInfo>^ value);
}
abstract TextData : StringItemInfo[] with get, set

Property Value

Type: StringItemInfo
See Also

Reference

IStringItem Interface
Alternet.Syntax Namespace


IStringList Interface

IStringList Interface
Represents collection containing list of strings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStringList : IList<string>,
    ICollection<string>, IEnumerable<string>, IEnumerable,
    IImport, IExport
Public Interface IStringList
    Inherits IList(Of String), ICollection(Of String),
    IEnumerable(Of String), IEnumerable, IImport, IExport
public interface class IStringList : IList<String^>,
    ICollection<String^>, IEnumerable<String^>, IEnumerable,
    IImport, IExport
type IStringList =
    interface
        interface IList<string>
        interface ICollection<string>
        interface IEnumerable<string>
        interface IEnumerable
        interface IImport
        interface IExport
    end

The IStringList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionString.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionString.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionString.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionString.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableString.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListString.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListString.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionString.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListString.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionString.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionString.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListString.)
Public property | Text | When implemented by a class, gets or sets the strings in the IStringList as a single string with the individual strings delimited by carriage returns.
Top
See Also

Reference

Alternet.Syntax Namespace


IStringList Methods

IStringList Methods

The IStringList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionString.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionString.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionString.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionString.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableString.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListString.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListString.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionString.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListString.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IStringList Interface
Alternet.Syntax Namespace


IStringList Properties

IStringList Properties

The IStringList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionString.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionString.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListString.)
Public property | Text | When implemented by a class, gets or sets the strings in the IStringList as a single string with the individual strings delimited by carriage returns.
Top
See Also

Reference

IStringList Interface
Alternet.Syntax Namespace


IStringList.Text Property

IStringListText Property
When implemented by a class, gets or sets the strings in the IStringList as a single string with the individual strings delimited by carriage returns.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IStringList Interface
Alternet.Syntax Namespace


IStringListWithItem Interface

IStringListWithItem Interface
Represents collection containing list of strings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IStringListWithItem : IStringList,
    IList<string>, ICollection<string>, IEnumerable<string>,
    IEnumerable, IImport, IExport
Public Interface IStringListWithItem
    Inherits IStringList, IList(Of String), ICollection(Of String),
    IEnumerable(Of String), IEnumerable, IImport, IExport
public interface class IStringListWithItem : IStringList,
    IList<String^>, ICollection<String^>, IEnumerable<String^>,
    IEnumerable, IImport, IExport
type IStringListWithItem =
    interface
        interface IStringList
        interface IList<string>
        interface ICollection<string>
        interface IEnumerable<string>
        interface IEnumerable
        interface IImport
        interface IExport
    end

The IStringListWithItem type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionString.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionString.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionString.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionString.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableString.)
Public method | GetItem | When implemented by a class, returns the IStrItem object at the given position of the collection.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListString.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListString.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionString.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListString.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionString.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionString.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListString.)
Public property | Text | When implemented by a class, gets or sets the strings in the IStringList as a single string with the individual strings delimited by carriage returns. (Inherited from IStringList.)
Top
See Also

Reference

Alternet.Syntax Namespace


IStringListWithItem Methods

IStringListWithItem Methods

The IStringListWithItem type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionString.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionString.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionString.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionString.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableString.)
Public method | GetItem | When implemented by a class, returns the IStrItem object at the given position of the collection.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListString.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListString.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionString.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListString.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IStringListWithItem Interface
Alternet.Syntax Namespace


IStringListWithItem.GetItem Method

IStringListWithItemGetItem Method
When implemented by a class, returns the IStrItem object at the given position of the collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IStringItem GetItem(
    int index
)
Function GetItem (
    index As Integer
) As IStringItem
IStringItem^ GetItem(
    int index
)
abstract GetItem :
        index : int -> IStringItem

Parameters

index
Type: SystemInt32
Index of item in the collection.

Return Value

Type: IStringItem
IStrItem object at specified position.
See Also

Reference

IStringListWithItem Interface
Alternet.Syntax Namespace


IStringListWithItem Properties

IStringListWithItem Properties

The IStringListWithItem type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionString.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionString.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListString.)
Public property | Text | When implemented by a class, gets or sets the strings in the IStringList as a single string with the individual strings delimited by carriage returns. (Inherited from IStringList.)
Top
See Also

Reference

IStringListWithItem Interface
Alternet.Syntax Namespace


ISyntaxAttribute Interface

ISyntaxAttribute Interface
Represents properties to describe a particular attribute of language element.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxAttribute : ICloneable
Public Interface ISyntaxAttribute
    Inherits ICloneable
public interface class ISyntaxAttribute : ICloneable
type ISyntaxAttribute =
    interface
        interface ICloneable
    end

The ISyntaxAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
Properties
 | Name | Description
Public property | EndPosition | When implemented by a class, get attribute end position in the code text.
Public property | Name | When implemented by a class, get or sets attribute name.
Public property | Position | When implemented by a class, get or sets attribute position in the code text.
Public property | Range | When implemented by a class, gets attribute scope.
Public property | Value | When implemented by a class, get or sets value of the attribute.
Top
See Also

Reference

Alternet.Syntax Namespace


ISyntaxAttribute Methods

ISyntaxAttribute Methods

The ISyntaxAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

ISyntaxAttribute Interface
Alternet.Syntax Namespace


ISyntaxAttribute Properties

ISyntaxAttribute Properties

The ISyntaxAttribute type exposes the following members.

Properties
 | Name | Description
Public property | EndPosition | When implemented by a class, get attribute end position in the code text.
Public property | Name | When implemented by a class, get or sets attribute name.
Public property | Position | When implemented by a class, get or sets attribute position in the code text.
Public property | Range | When implemented by a class, gets attribute scope.
Public property | Value | When implemented by a class, get or sets value of the attribute.
Top
See Also

Reference

ISyntaxAttribute Interface
Alternet.Syntax Namespace


ISyntaxAttribute.EndPosition Property

ISyntaxAttributeEndPosition Property
When implemented by a class, get attribute end position in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point EndPosition { get; set; }
Property EndPosition As Point
    Get
    Set
property Point EndPosition {
    Point get ();
    void set (Point value);
}
abstract EndPosition : Point with get, set

Property Value

Type: Point
See Also

Reference

ISyntaxAttribute Interface
Alternet.Syntax Namespace


ISyntaxAttribute.Name Property

ISyntaxAttributeName Property
When implemented by a class, get or sets attribute name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ISyntaxAttribute Interface
Alternet.Syntax Namespace


ISyntaxAttribute.Position Property

ISyntaxAttributePosition Property
When implemented by a class, get or sets attribute position in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Position { get; set; }
Property Position As Point
    Get
    Set
property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set

Property Value

Type: Point
See Also

Reference

ISyntaxAttribute Interface
Alternet.Syntax Namespace


ISyntaxAttribute.Range Property

ISyntaxAttributeRange Property
When implemented by a class, gets attribute scope.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange Range { get; }
ReadOnly Property Range As IRange
    Get
property IRange^ Range {
    IRange^ get ();
}
abstract Range : IRange with get

Property Value

Type: IRange
See Also

Reference

ISyntaxAttribute Interface
Alternet.Syntax Namespace


ISyntaxAttribute.Value Property

ISyntaxAttributeValue Property
When implemented by a class, get or sets value of the attribute.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object Value { get; set; }
Property Value As Object
    Get
    Set
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
abstract Value : Object with get, set

Property Value

Type: Object
See Also

Reference

ISyntaxAttribute Interface
Alternet.Syntax Namespace


ISyntaxAttributes Interface

ISyntaxAttributes Interface
Represents collection containing list of syntax attributes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxAttributes : ISortList<ISyntaxAttribute>,
    IList<ISyntaxAttribute>, ICollection<ISyntaxAttribute>, IEnumerable<ISyntaxAttribute>,
    IEnumerable
Public Interface ISyntaxAttributes
    Inherits ISortList(Of ISyntaxAttribute), IList(Of ISyntaxAttribute),
    ICollection(Of ISyntaxAttribute), IEnumerable(Of ISyntaxAttribute), IEnumerable
public interface class ISyntaxAttributes : ISortList<ISyntaxAttribute^>,
    IList<ISyntaxAttribute^>, ICollection<ISyntaxAttribute^>, IEnumerable<ISyntaxAttribute^>,
    IEnumerable
type ISyntaxAttributes =
    interface
        interface ISortList<ISyntaxAttribute>
        interface IList<ISyntaxAttribute>
        interface ICollection<ISyntaxAttribute>
        interface IEnumerable<ISyntaxAttribute>
        interface IEnumerable
    end

The ISyntaxAttributes type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionISyntaxAttribute .)
Public method | BlockDeleting | Removes all syntax errors from the error collection which position in the specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionISyntaxAttribute .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionISyntaxAttribute .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionISyntaxAttribute .)
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableISyntaxAttribute .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListISyntaxAttribute .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListISyntaxAttribute .)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria. (Inherited from ISortListT.)
Public method | PositionChanged | When implemented by a class, updates all syntax errors starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionISyntaxAttribute .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListISyntaxAttribute .)
Public method | Sort | Sorts the syntax errors.
Public method | Sort(IComparerT) | When implemented by a class, sorts the elements in the entire sort list using the specified comparer. (Inherited from ISortListT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxAttribute | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxAttribute | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxAttribute, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionISyntaxAttribute .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionISyntaxAttribute .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListISyntaxAttribute .)
Top
See Also

Reference

Alternet.Syntax Namespace


ISyntaxAttributes Methods

ISyntaxAttributes Methods

The ISyntaxAttributes type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionISyntaxAttribute .)
Public method | BlockDeleting | Removes all syntax errors from the error collection which position in the specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionISyntaxAttribute .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionISyntaxAttribute .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionISyntaxAttribute .)
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableISyntaxAttribute .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListISyntaxAttribute .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListISyntaxAttribute .)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria. (Inherited from ISortListT.)
Public method | PositionChanged | When implemented by a class, updates all syntax errors starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionISyntaxAttribute .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListISyntaxAttribute .)
Public method | Sort | Sorts the syntax errors.
Public method | Sort(IComparerT) | When implemented by a class, sorts the elements in the entire sort list using the specified comparer. (Inherited from ISortListT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxAttribute | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxAttribute | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxAttribute, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ISyntaxAttributes Interface
Alternet.Syntax Namespace


ISyntaxAttributes.BlockDeleting Method

ISyntaxAttributesBlockDeleting Method
Removes all syntax errors from the error collection which position in the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BlockDeleting(
    Rectangle rect
)
Function BlockDeleting (
    rect As Rectangle
) As Boolean
bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove syntax errors.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxAttributes Interface
Alternet.Syntax Namespace


ISyntaxAttributes.PositionChanged Method

ISyntaxAttributesPositionChanged Method
When implemented by a class, updates all syntax errors starting from specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxAttributes Interface
Alternet.Syntax Namespace


ISyntaxAttributes.Sort Method

ISyntaxAttributesSort Method
Overload List
 | Name | Description
Public method | Sort | Sorts the syntax errors.
Public method | Sort(IComparerT) | When implemented by a class, sorts the elements in the entire sort list using the specified comparer. (Inherited from ISortListT.)
Top
See Also

Reference

ISyntaxAttributes Interface
Alternet.Syntax Namespace


ISyntaxAttributes.Sort Method

ISyntaxAttributesSort Method
Sorts the syntax errors.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Sort()
Sub Sort
void Sort()
abstract Sort : unit -> unit
See Also

Reference

ISyntaxAttributes Interface
Sort Overload
Alternet.Syntax Namespace


ISyntaxAttributes Properties

ISyntaxAttributes Properties

The ISyntaxAttributes type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionISyntaxAttribute .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionISyntaxAttribute .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListISyntaxAttribute .)
Top
See Also

Reference

ISyntaxAttributes Interface
Alternet.Syntax Namespace


ISyntaxError Interface

ISyntaxError Interface
Represents properties to describe a particular syntax error in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxError : ICloneable
Public Interface ISyntaxError
    Inherits ICloneable
public interface class ISyntaxError : ICloneable
type ISyntaxError =
    interface
        interface ICloneable
    end

The ISyntaxError type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets error description (reason).
Public property | ErrorCode | When implemented by a class, gets or sets error code.
Public property | ErrorType | When implemented by a class, gets or sets error type.
Public property | Name | When implemented by a class, gets or sets error name.
Public property | Position | When implemented by a class, gets or sets error position in the code text.
Public property | Range | When implemented by a class, gets or sets error scope.
Public property | Size | When implemented by a class, gets or sets error dimension.
Top
See Also

Reference

Alternet.Syntax Namespace


ISyntaxError Methods

ISyntaxError Methods

The ISyntaxError type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

ISyntaxError Interface
Alternet.Syntax Namespace


ISyntaxError Properties

ISyntaxError Properties

The ISyntaxError type exposes the following members.

Properties
 | Name | Description
Public property | Description | When implemented by a class, gets or sets error description (reason).
Public property | ErrorCode | When implemented by a class, gets or sets error code.
Public property | ErrorType | When implemented by a class, gets or sets error type.
Public property | Name | When implemented by a class, gets or sets error name.
Public property | Position | When implemented by a class, gets or sets error position in the code text.
Public property | Range | When implemented by a class, gets or sets error scope.
Public property | Size | When implemented by a class, gets or sets error dimension.
Top
See Also

Reference

ISyntaxError Interface
Alternet.Syntax Namespace


ISyntaxError.Description Property

ISyntaxErrorDescription Property
When implemented by a class, gets or sets error description (reason).

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

ISyntaxError Interface
Alternet.Syntax Namespace


ISyntaxError.ErrorCode Property

ISyntaxErrorErrorCode Property
When implemented by a class, gets or sets error code.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ErrorCode { get; set; }
Property ErrorCode As String
    Get
    Set
property String^ ErrorCode {
    String^ get ();
    void set (String^ value);
}
abstract ErrorCode : string with get, set

Property Value

Type: String
See Also

Reference

ISyntaxError Interface
Alternet.Syntax Namespace


ISyntaxError.ErrorType Property

ISyntaxErrorErrorType Property
When implemented by a class, gets or sets error type.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SyntaxErrorType ErrorType { get; set; }
Property ErrorType As SyntaxErrorType
    Get
    Set
property SyntaxErrorType ErrorType {
    SyntaxErrorType get ();
    void set (SyntaxErrorType value);
}
abstract ErrorType : SyntaxErrorType with get, set

Property Value

Type: SyntaxErrorType
See Also

Reference

ISyntaxError Interface
Alternet.Syntax Namespace


ISyntaxError.Name Property

ISyntaxErrorName Property
When implemented by a class, gets or sets error name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ISyntaxError Interface
Alternet.Syntax Namespace


ISyntaxError.Position Property

ISyntaxErrorPosition Property
When implemented by a class, gets or sets error position in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Position { get; set; }
Property Position As Point
    Get
    Set
property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set

Property Value

Type: Point
See Also

Reference

ISyntaxError Interface
Alternet.Syntax Namespace


ISyntaxError.Range Property

ISyntaxErrorRange Property
When implemented by a class, gets or sets error scope.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange Range { get; set; }
Property Range As IRange
    Get
    Set
property IRange^ Range {
    IRange^ get ();
    void set (IRange^ value);
}
abstract Range : IRange with get, set

Property Value

Type: IRange
See Also

Reference

ISyntaxError Interface
Alternet.Syntax Namespace


ISyntaxError.Size Property

ISyntaxErrorSize Property
When implemented by a class, gets or sets error dimension.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Size Size { get; set; }
Property Size As Size
    Get
    Set
property Size Size {
    Size get ();
    void set (Size value);
}
abstract Size : Size with get, set

Property Value

Type: Size
See Also

Reference

ISyntaxError Interface
Alternet.Syntax Namespace


ISyntaxErrors Interface

ISyntaxErrors Interface
Represents collection containing list of syntax errors.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxErrors : ISortList<ISyntaxError>,
    IList<ISyntaxError>, ICollection<ISyntaxError>, IEnumerable<ISyntaxError>,
    IEnumerable
Public Interface ISyntaxErrors
    Inherits ISortList(Of ISyntaxError), IList(Of ISyntaxError),
    ICollection(Of ISyntaxError), IEnumerable(Of ISyntaxError), IEnumerable
public interface class ISyntaxErrors : ISortList<ISyntaxError^>,
    IList<ISyntaxError^>, ICollection<ISyntaxError^>, IEnumerable<ISyntaxError^>,
    IEnumerable
type ISyntaxErrors =
    interface
        interface ISortList<ISyntaxError>
        interface IList<ISyntaxError>
        interface ICollection<ISyntaxError>
        interface IEnumerable<ISyntaxError>
        interface IEnumerable
    end

The ISyntaxErrors type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionISyntaxError .)
Public method | BlockDeleting(Rectangle) | When implemented by a class, removes all syntax errors from the error collection which position in the specified rectangle.
Public method | BlockDeleting(Rectangle, IComparerISyntaxError) | When implemented by a class, removes all syntax errors from the error collection which position in the specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionISyntaxError .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionISyntaxError .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionISyntaxError .)
Public method | FindErrorAt | Locates error at specified position.
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableISyntaxError .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListISyntaxError .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListISyntaxError .)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria. (Inherited from ISortListT.)
Public method | PositionChanged(Int32, Int32, Int32, Int32) | When implemented by a class, updates all syntax errors starting from specified position.
Public method | PositionChanged(Int32, Int32, Int32, Int32, IComparerISyntaxError) | When implemented by a class, updates all syntax errors starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionISyntaxError .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListISyntaxError .)
Public method | Sort | When implemented by a class, sorts the elements in the entire sort list using the specified comparer. (Inherited from ISortListT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxError | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxError | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxError, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionISyntaxError .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionISyntaxError .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListISyntaxError .)
Top
See Also

Reference

Alternet.Syntax Namespace


ISyntaxErrors Methods

ISyntaxErrors Methods

The ISyntaxErrors type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionISyntaxError .)
Public method | BlockDeleting(Rectangle) | When implemented by a class, removes all syntax errors from the error collection which position in the specified rectangle.
Public method | BlockDeleting(Rectangle, IComparerISyntaxError) | When implemented by a class, removes all syntax errors from the error collection which position in the specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionISyntaxError .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionISyntaxError .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionISyntaxError .)
Public method | FindErrorAt | Locates error at specified position.
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableISyntaxError .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListISyntaxError .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListISyntaxError .)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria. (Inherited from ISortListT.)
Public method | PositionChanged(Int32, Int32, Int32, Int32) | When implemented by a class, updates all syntax errors starting from specified position.
Public method | PositionChanged(Int32, Int32, Int32, Int32, IComparerISyntaxError) | When implemented by a class, updates all syntax errors starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionISyntaxError .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListISyntaxError .)
Public method | Sort | When implemented by a class, sorts the elements in the entire sort list using the specified comparer. (Inherited from ISortListT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxError | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxError | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxError, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ISyntaxErrors Interface
Alternet.Syntax Namespace


ISyntaxErrors.BlockDeleting Method

ISyntaxErrorsBlockDeleting Method
Overload List
 | Name | Description
Public method | BlockDeleting(Rectangle) | When implemented by a class, removes all syntax errors from the error collection which position in the specified rectangle.
Public method | BlockDeleting(Rectangle, IComparerISyntaxError) | When implemented by a class, removes all syntax errors from the error collection which position in the specified rectangle.
Top
See Also

Reference

ISyntaxErrors Interface
Alternet.Syntax Namespace


ISyntaxErrors.BlockDeleting Method (Rectangle)

ISyntaxErrorsBlockDeleting Method (Rectangle)
When implemented by a class, removes all syntax errors from the error collection which position in the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BlockDeleting(
    Rectangle rect
)
Function BlockDeleting (
    rect As Rectangle
) As Boolean
bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove syntax errors.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxErrors Interface
BlockDeleting Overload
Alternet.Syntax Namespace


ISyntaxErrors.BlockDeleting Method (Rectangle, IComparer(ISyntaxError))

ISyntaxErrorsBlockDeleting Method (Rectangle, IComparerISyntaxError)
When implemented by a class, removes all syntax errors from the error collection which position in the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxError> comparer
)
Function BlockDeleting (
    rect As Rectangle,
    comparer As IComparer(Of ISyntaxError)
) As Boolean
bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxError^>^ comparer
)
abstract BlockDeleting :
        rect : Rectangle *
        comparer : IComparer<ISyntaxError> -> bool

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove syntax errors.
comparer
Type: System.Collections.GenericIComparerISyntaxError
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxErrors Interface
BlockDeleting Overload
Alternet.Syntax Namespace


ISyntaxErrors.FindErrorAt Method

ISyntaxErrorsFindErrorAt Method
Locates error at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindErrorAt(
    Point position,
    bool exact,
    out int index,
    IComparer<ISyntaxError> comparer
)
Function FindErrorAt (
    position As Point,
    exact As Boolean,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer(Of ISyntaxError)
) As Boolean
bool FindErrorAt(
    Point position,
    bool exact,
    [OutAttribute] int% index,
    IComparer<ISyntaxError^>^ comparer
)
abstract FindErrorAt :
        position : Point *
        exact : bool *
        index : int byref *
        comparer : IComparer<ISyntaxError> -> bool

Parameters

position
Type: System.DrawingPoint
Position to locate error.
exact
Type: SystemBoolean
Specifies whether search should be precise.
index
Type: SystemInt32
Receives index of syntax error in the error collection.
comparer
Type: System.Collections.GenericIComparerISyntaxError
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxErrors Interface
Alternet.Syntax Namespace


ISyntaxErrors.PositionChanged Method

ISyntaxErrorsPositionChanged Method
Overload List
 | Name | Description
Public method | PositionChanged(Int32, Int32, Int32, Int32) | When implemented by a class, updates all syntax errors starting from specified position.
Public method | PositionChanged(Int32, Int32, Int32, Int32, IComparerISyntaxError) | When implemented by a class, updates all syntax errors starting from specified position.
Top
See Also

Reference

ISyntaxErrors Interface
Alternet.Syntax Namespace


ISyntaxErrors.PositionChanged Method (Int32, Int32, Int32, Int32)

ISyntaxErrorsPositionChanged Method (Int32, Int32, Int32, Int32)
When implemented by a class, updates all syntax errors starting from specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxErrors Interface
PositionChanged Overload
Alternet.Syntax Namespace


ISyntaxErrors.PositionChanged Method (Int32, Int32, Int32, Int32, IComparer(ISyntaxError))

ISyntaxErrorsPositionChanged Method (Int32, Int32, Int32, Int32, IComparerISyntaxError)
When implemented by a class, updates all syntax errors starting from specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxError> comparer
)
Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    comparer As IComparer(Of ISyntaxError)
) As Boolean
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxError^>^ comparer
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        comparer : IComparer<ISyntaxError> -> bool

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.
comparer
Type: System.Collections.GenericIComparerISyntaxError
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxErrors Interface
PositionChanged Overload
Alternet.Syntax Namespace


ISyntaxErrors Properties

ISyntaxErrors Properties

The ISyntaxErrors type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionISyntaxError .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionISyntaxError .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListISyntaxError .)
Top
See Also

Reference

ISyntaxErrors Interface
Alternet.Syntax Namespace


ISyntaxNode Interface

ISyntaxNode Interface
Represents properties and methods to describe a particular language element.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxNode : ICloneable
Public Interface ISyntaxNode
    Inherits ICloneable
public interface class ISyntaxNode : ICloneable
type ISyntaxNode =
    interface
        interface ICloneable
    end

The ISyntaxNode type exposes the following members.

Methods
 | Name | Description
Public method | AddAttribute | When implemented by a class, creates a new ISyntaxAttribute and adds it to the attribute collection.
Public method | AddAttribute(ISyntaxAttribute) | When implemented by a class, adds specified attribute to the attribute collection.
Public method | AddAttributes | When implemented by a class, adds specified attributes to the attribute collection.
Public method | AddChild | When implemented by a class, creates a new ISyntaxNode and adds it to the child collection.
Public method | AddChild(ISyntaxNode) | When implemented by a class, adds specified node to the child collection.
Public method | AddChildren | When implemented by a class, adds specified nodes to the child collection.
Public method | AddError | When implemented by a class, creates a new ISyntaxError and add it to the error collection.
Public method | AddError(ISyntaxError) | When implemented by a class, adds specified error to the error collection.
Public method | AddErrors | When implemented by a class, adds specified errors to the error collection.
Public method | Assign | Copies contents from another ISyntaxNode object.
Public method | BlockDeleting | When implemented by a class, removes node's inside the specified rectangle.
Public method | Clear | When implemented by a class, removes all elements from child nodes, attribute and error collections.
Public method | ClearAfter | When implemented by a class, removes all elements from child nodes, attribute and error collections starting from given position. Specifies starting position
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | ContainsErrors | When implemented by a class, indicates whether node or its children contain errors.
Public method | FindAttribute | When implemented by a class, finds attribute by its name.
Public method | FindAttributes | When implemented by a class, locates all attribute with given name.
Public method | FindNode(Int32) | When implemented by a class, finds child node by its type.
Public method | FindNode(String) | When implemented by a class, finds child node by its name.
Public method | FindNode(ISyntaxNode, IComparerISyntaxNode) | When implemented by a class, finds specified child node.
Public method | FindNodes | When implemented by a class, locates all nodes matching search criteria.
Public method | GetIndent(Int32, Int32) | When implemented by a class, returns indentation level of this syntax node.
Public method | GetIndent(Int32, Int32, Boolean) | When implemented by a class, returns indentation level of this syntax node.
Public method | HasAsParent | When implemented by a class, indicates whether the node has specified node as a parent node.
Public method | InsertChild | When implemented by a class, inserts specified node to the child collection.
Public method | PositionChanged | When implemented by a class, updates content of this ISyntaxNode.
Public method | Sort | When implemented by a class, sorts the ISyntaxNode in the child list using the specified comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetAttrValue | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDescription | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetFileName | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetNamePosition | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetNameRange | (Defined by SyntaxNodeExtensions.)
Public Extension Method | IsValidReference | (Defined by SyntaxNodeExtensions.)
Top
Properties
 | Name | Description
Public property | AttributeCount | When implemented by a class, represents number of attributes in the attribute collection.
Public property | AttributeList | When implemented by a class, gets a list of attributes.
Public property | Attributes | When implemented by a class, gets or sets an attribute collection in the form of array.
Public property | ChildCount | When implemented by a class, represents number of children in the child collection.
Public property | ChildList | When implemented by a class, gets a list of child nodes.
Public property | Childs | When implemented by a class, gets or sets a collection of child nodes in the form of array.
Public property | ErrorCount | When implemented by a class, represents number of syntax errors in the error collection.
Public property | ErrorList | When implemented by a class, gets a list of syntax errors.
Public property | Errors | When implemented by a class, gets or sets an error collection in the form of array.
Public property | HasAttributes | When implemented by a class, indicates whether node has attributes.
Public property | HasChildren | When implemented by a class, indicates whether node has children.
Public property | HasErrors | When implemented by a class, indicates whether node has errors.
Public property | Index | When implemented by a class, represents index of then node within its parent child collection.
Public property | Level | When implemented by a class, represents node level inside SyntaxTree.
Public property | Name | When implemented by a class, gets or sets node name.
Public property | NodeType | When implemented by a class, gets or sets type of the node.
Public property | Options | When implemented by a class, gets or sets node options that defines its behavior.
Public property | Parent | When implemented by a class, gets or sets ISyntaxNode that holds this node in its child list.
Public property | Position | When implemented by a class, gets or sets node position in the code text.
Public property | Range | When implemented by a class, gets or sets node scope.
Public property | Root | When implemented by a class, represents root level ISyntaxNode in the syntax tree.
Public property | Size | When implemented by a class, gets or sets node dimension.
Top
See Also

Reference

Alternet.Syntax Namespace


ISyntaxNode Methods

ISyntaxNode Methods

The ISyntaxNode type exposes the following members.

Methods
 | Name | Description
Public method | AddAttribute | When implemented by a class, creates a new ISyntaxAttribute and adds it to the attribute collection.
Public method | AddAttribute(ISyntaxAttribute) | When implemented by a class, adds specified attribute to the attribute collection.
Public method | AddAttributes | When implemented by a class, adds specified attributes to the attribute collection.
Public method | AddChild | When implemented by a class, creates a new ISyntaxNode and adds it to the child collection.
Public method | AddChild(ISyntaxNode) | When implemented by a class, adds specified node to the child collection.
Public method | AddChildren | When implemented by a class, adds specified nodes to the child collection.
Public method | AddError | When implemented by a class, creates a new ISyntaxError and add it to the error collection.
Public method | AddError(ISyntaxError) | When implemented by a class, adds specified error to the error collection.
Public method | AddErrors | When implemented by a class, adds specified errors to the error collection.
Public method | Assign | Copies contents from another ISyntaxNode object.
Public method | BlockDeleting | When implemented by a class, removes node's inside the specified rectangle.
Public method | Clear | When implemented by a class, removes all elements from child nodes, attribute and error collections.
Public method | ClearAfter | When implemented by a class, removes all elements from child nodes, attribute and error collections starting from given position. Specifies starting position
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Public method | ContainsErrors | When implemented by a class, indicates whether node or its children contain errors.
Public method | FindAttribute | When implemented by a class, finds attribute by its name.
Public method | FindAttributes | When implemented by a class, locates all attribute with given name.
Public method | FindNode(Int32) | When implemented by a class, finds child node by its type.
Public method | FindNode(String) | When implemented by a class, finds child node by its name.
Public method | FindNode(ISyntaxNode, IComparerISyntaxNode) | When implemented by a class, finds specified child node.
Public method | FindNodes | When implemented by a class, locates all nodes matching search criteria.
Public method | GetIndent(Int32, Int32) | When implemented by a class, returns indentation level of this syntax node.
Public method | GetIndent(Int32, Int32, Boolean) | When implemented by a class, returns indentation level of this syntax node.
Public method | HasAsParent | When implemented by a class, indicates whether the node has specified node as a parent node.
Public method | InsertChild | When implemented by a class, inserts specified node to the child collection.
Public method | PositionChanged | When implemented by a class, updates content of this ISyntaxNode.
Public method | Sort | When implemented by a class, sorts the ISyntaxNode in the child list using the specified comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetAttrValue | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDescription | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetFileName | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetNamePosition | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetNameRange | (Defined by SyntaxNodeExtensions.)
Public Extension Method | IsValidReference | (Defined by SyntaxNodeExtensions.)
Top
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.AddAttribute Method

ISyntaxNodeAddAttribute Method
Overload List
 | Name | Description
Public method | AddAttribute | When implemented by a class, creates a new ISyntaxAttribute and adds it to the attribute collection.
Public method | AddAttribute(ISyntaxAttribute) | When implemented by a class, adds specified attribute to the attribute collection.
Top
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.AddAttribute Method

ISyntaxNodeAddAttribute Method
When implemented by a class, creates a new ISyntaxAttribute and adds it to the attribute collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxAttribute AddAttribute()
Function AddAttribute As ISyntaxAttribute
ISyntaxAttribute^ AddAttribute()
abstract AddAttribute : unit -> ISyntaxAttribute

Return Value

Type: ISyntaxAttribute
ISyntaxAttribute that is added.
See Also

Reference

ISyntaxNode Interface
AddAttribute Overload
Alternet.Syntax Namespace


ISyntaxNode.AddAttribute Method (ISyntaxAttribute)

ISyntaxNodeAddAttribute Method (ISyntaxAttribute)
When implemented by a class, adds specified attribute to the attribute collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AddAttribute(
    ISyntaxAttribute attr
)
Function AddAttribute (
    attr As ISyntaxAttribute
) As Integer
int AddAttribute(
    ISyntaxAttribute^ attr
)
abstract AddAttribute :
        attr : ISyntaxAttribute -> int

Parameters

attr
Type: Alternet.SyntaxISyntaxAttribute
Specifies ISyntaxAttribute to add.

Return Value

Type: Int32
Index of added attribute in the attribute collection.
See Also

Reference

ISyntaxNode Interface
AddAttribute Overload
Alternet.Syntax Namespace


ISyntaxNode.AddAttributes Method

ISyntaxNodeAddAttributes Method
When implemented by a class, adds specified attributes to the attribute collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddAttributes(
    ISyntaxAttributes attrs
)
Sub AddAttributes (
    attrs As ISyntaxAttributes
)
void AddAttributes(
    ISyntaxAttributes^ attrs
)
abstract AddAttributes :
        attrs : ISyntaxAttributes -> unit

Parameters

attrs
Type: Alternet.SyntaxISyntaxAttributes
Specifies list of attributes to add.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.AddChild Method

ISyntaxNodeAddChild Method
Overload List
 | Name | Description
Public method | AddChild | When implemented by a class, creates a new ISyntaxNode and adds it to the child collection.
Public method | AddChild(ISyntaxNode) | When implemented by a class, adds specified node to the child collection.
Top
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.AddChild Method

ISyntaxNodeAddChild Method
When implemented by a class, creates a new ISyntaxNode and adds it to the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode AddChild()
Function AddChild As ISyntaxNode
ISyntaxNode^ AddChild()
abstract AddChild : unit -> ISyntaxNode

Return Value

Type: ISyntaxNode
ISyntaxNode that is added.
See Also

Reference

ISyntaxNode Interface
AddChild Overload
Alternet.Syntax Namespace


ISyntaxNode.AddChild Method (ISyntaxNode)

ISyntaxNodeAddChild Method (ISyntaxNode)
When implemented by a class, adds specified node to the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AddChild(
    ISyntaxNode node
)
Function AddChild (
    node As ISyntaxNode
) As Integer
int AddChild(
    ISyntaxNode^ node
)
abstract AddChild :
        node : ISyntaxNode -> int

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to add.

Return Value

Type: Int32
Index of added node within the child collection.
See Also

Reference

ISyntaxNode Interface
AddChild Overload
Alternet.Syntax Namespace


ISyntaxNode.AddChildren Method

ISyntaxNodeAddChildren Method
When implemented by a class, adds specified nodes to the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddChildren(
    ISyntaxNodes nodes
)
Sub AddChildren (
    nodes As ISyntaxNodes
)
void AddChildren(
    ISyntaxNodes^ nodes
)
abstract AddChildren :
        nodes : ISyntaxNodes -> unit

Parameters

nodes
Type: Alternet.SyntaxISyntaxNodes
Specifies list of nodes to add.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.AddError Method

ISyntaxNodeAddError Method
Overload List
 | Name | Description
Public method | AddError | When implemented by a class, creates a new ISyntaxError and add it to the error collection.
Public method | AddError(ISyntaxError) | When implemented by a class, adds specified error to the error collection.
Top
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.AddError Method

ISyntaxNodeAddError Method
When implemented by a class, creates a new ISyntaxError and add it to the error collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxError AddError()
Function AddError As ISyntaxError
ISyntaxError^ AddError()
abstract AddError : unit -> ISyntaxError

Return Value

Type: ISyntaxError
ISyntaxError that is added.
See Also

Reference

ISyntaxNode Interface
AddError Overload
Alternet.Syntax Namespace


ISyntaxNode.AddError Method (ISyntaxError)

ISyntaxNodeAddError Method (ISyntaxError)
When implemented by a class, adds specified error to the error collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AddError(
    ISyntaxError err
)
Function AddError (
    err As ISyntaxError
) As Integer
int AddError(
    ISyntaxError^ err
)
abstract AddError :
        err : ISyntaxError -> int

Parameters

err
Type: Alternet.SyntaxISyntaxError
Specifies ISyntaxError to add.

Return Value

Type: Int32
Number of added error in the error collection.
See Also

Reference

ISyntaxNode Interface
AddError Overload
Alternet.Syntax Namespace


ISyntaxNode.AddErrors Method

ISyntaxNodeAddErrors Method
When implemented by a class, adds specified errors to the error collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddErrors(
    ISyntaxErrors errs
)
Sub AddErrors (
    errs As ISyntaxErrors
)
void AddErrors(
    ISyntaxErrors^ errs
)
abstract AddErrors :
        errs : ISyntaxErrors -> unit

Parameters

errs
Type: Alternet.SyntaxISyntaxErrors
Specifies list of errors to add.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Assign Method

ISyntaxNodeAssign Method
Copies contents from another ISyntaxNode object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ISyntaxNode source
)
Sub Assign (
    source As ISyntaxNode
)
void Assign(
    ISyntaxNode^ source
)
abstract Assign :
        source : ISyntaxNode -> unit

Parameters

source
Type: Alternet.SyntaxISyntaxNode
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.BlockDeleting Method

ISyntaxNodeBlockDeleting Method
When implemented by a class, removes node's inside the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxNode> comparer
)
Function BlockDeleting (
    rect As Rectangle,
    comparer As IComparer(Of ISyntaxNode)
) As Boolean
bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxNode^>^ comparer
)
abstract BlockDeleting :
        rect : Rectangle *
        comparer : IComparer<ISyntaxNode> -> bool

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove node's content.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Clear Method

ISyntaxNodeClear Method
When implemented by a class, removes all elements from child nodes, attribute and error collections.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.ClearAfter Method

ISyntaxNodeClearAfter Method
When implemented by a class, removes all elements from child nodes, attribute and error collections starting from given position. Specifies starting position

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearAfter(
    Point position
)
Sub ClearAfter (
    position As Point
)
void ClearAfter(
    Point position
)
abstract ClearAfter :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.ContainsErrors Method

ISyntaxNodeContainsErrors Method
When implemented by a class, indicates whether node or its children contain errors.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ContainsErrors()
Function ContainsErrors As Boolean
bool ContainsErrors()
abstract ContainsErrors : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.FindAttribute Method

ISyntaxNodeFindAttribute Method
When implemented by a class, finds attribute by its name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxAttribute FindAttribute(
    string name
)
Function FindAttribute (
    name As String
) As ISyntaxAttribute
ISyntaxAttribute^ FindAttribute(
    String^ name
)
abstract FindAttribute :
        name : string -> ISyntaxAttribute

Parameters

name
Type: SystemString
Specifies name of attribute.

Return Value

Type: ISyntaxAttribute
First occurrence of ISyntaxAttribute with specified name.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.FindAttributes Method

ISyntaxNodeFindAttributes Method
When implemented by a class, locates all attribute with given name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxAttribute[] FindAttributes(
    string name
)
Function FindAttributes (
    name As String
) As ISyntaxAttribute()
array<ISyntaxAttribute^>^ FindAttributes(
    String^ name
)
abstract FindAttributes :
        name : string -> ISyntaxAttribute[]

Parameters

name
Type: SystemString
Specifies name of attribute.

Return Value

Type: ISyntaxAttribute
Array ISyntaxAttribute with specified name.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.FindNode Method

ISyntaxNodeFindNode Method
Overload List
 | Name | Description
Public method | FindNode(Int32) | When implemented by a class, finds child node by its type.
Public method | FindNode(String) | When implemented by a class, finds child node by its name.
Public method | FindNode(ISyntaxNode, IComparerISyntaxNode) | When implemented by a class, finds specified child node.
Top
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.FindNode Method (Int32)

ISyntaxNodeFindNode Method (Int32)
When implemented by a class, finds child node by its type.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode FindNode(
    int nodeType
)
Function FindNode (
    nodeType As Integer
) As ISyntaxNode
ISyntaxNode^ FindNode(
    int nodeType
)
abstract FindNode :
        nodeType : int -> ISyntaxNode

Parameters

nodeType
Type: SystemInt32
Specifies type of node.

Return Value

Type: ISyntaxNode
First occurrence of ISyntaxNode with specified type.
See Also

Reference

ISyntaxNode Interface
FindNode Overload
Alternet.Syntax Namespace


ISyntaxNode.FindNode Method (String)

ISyntaxNodeFindNode Method (String)
When implemented by a class, finds child node by its name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode FindNode(
    string name
)
Function FindNode (
    name As String
) As ISyntaxNode
ISyntaxNode^ FindNode(
    String^ name
)
abstract FindNode :
        name : string -> ISyntaxNode

Parameters

name
Type: SystemString
Specifies name of node.

Return Value

Type: ISyntaxNode
First occurrence of ISyntaxNode with specified name.
See Also

Reference

ISyntaxNode Interface
FindNode Overload
Alternet.Syntax Namespace


ISyntaxNode.FindNode Method (ISyntaxNode, IComparer(ISyntaxNode))

ISyntaxNodeFindNode Method (ISyntaxNode, IComparerISyntaxNode)
When implemented by a class, finds specified child node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode FindNode(
    ISyntaxNode obj,
    IComparer<ISyntaxNode> comparer
)
Function FindNode (
    obj As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode)
) As ISyntaxNode
ISyntaxNode^ FindNode(
    ISyntaxNode^ obj,
    IComparer<ISyntaxNode^>^ comparer
)
abstract FindNode :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> -> ISyntaxNode

Parameters

obj
Type: Alternet.SyntaxISyntaxNode
Specifies node to locate.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted child collection.

Return Value

Type: ISyntaxNode
ISyntaxNode that is located.
See Also

Reference

ISyntaxNode Interface
FindNode Overload
Alternet.Syntax Namespace


ISyntaxNode.FindNodes Method

ISyntaxNodeFindNodes Method
When implemented by a class, locates all nodes matching search criteria.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FindNodes(
    ISyntaxNode obj,
    IComparer<ISyntaxNode> comparer,
    ISyntaxNodes nodes
)
Sub FindNodes (
    obj As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode),
    nodes As ISyntaxNodes
)
void FindNodes(
    ISyntaxNode^ obj,
    IComparer<ISyntaxNode^>^ comparer,
    ISyntaxNodes^ nodes
)
abstract FindNodes :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> *
        nodes : ISyntaxNodes -> unit

Parameters

obj
Type: Alternet.SyntaxISyntaxNode
Specifies node to locate.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted node collection.
nodes
Type: Alternet.SyntaxISyntaxNodes
List of located nodes.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.GetIndent Method

ISyntaxNodeGetIndent Method
Overload List
 | Name | Description
Public method | GetIndent(Int32, Int32) | When implemented by a class, returns indentation level of this syntax node.
Public method | GetIndent(Int32, Int32, Boolean) | When implemented by a class, returns indentation level of this syntax node.
Top
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.GetIndent Method (Int32, Int32)

ISyntaxNodeGetIndent Method (Int32, Int32)
When implemented by a class, returns indentation level of this syntax node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetIndent(
    int index,
    int indent
)
Function GetIndent (
    index As Integer,
    indent As Integer
) As Integer
int GetIndent(
    int index,
    int indent
)
abstract GetIndent :
        index : int *
        indent : int -> int

Parameters

index
Type: SystemInt32
Specifies line to obtain indentation level.
indent
Type: SystemInt32
Default value of indentation level.

Return Value

Type: Int32
Indentation level of the node at the specified position.
See Also

Reference

ISyntaxNode Interface
GetIndent Overload
Alternet.Syntax Namespace


ISyntaxNode.GetIndent Method (Int32, Int32, Boolean)

ISyntaxNodeGetIndent Method (Int32, Int32, Boolean)
When implemented by a class, returns indentation level of this syntax node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetIndent(
    int index,
    int indent,
    out bool actualPosition
)
Function GetIndent (
    index As Integer,
    indent As Integer,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
int GetIndent(
    int index,
    int indent,
    [OutAttribute] bool% actualPosition
)
abstract GetIndent :
        index : int *
        indent : int *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies line to obtain indentation level.
indent
Type: SystemInt32
Default value of indentation level.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level of the node at the specified position.
See Also

Reference

ISyntaxNode Interface
GetIndent Overload
Alternet.Syntax Namespace


ISyntaxNode.HasAsParent Method

ISyntaxNodeHasAsParent Method
When implemented by a class, indicates whether the node has specified node as a parent node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasAsParent(
    ISyntaxNode node
)
Function HasAsParent (
    node As ISyntaxNode
) As Boolean
bool HasAsParent(
    ISyntaxNode^ node
)
abstract HasAsParent :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Node to test.

Return Value

Type: Boolean
True if node or one of its parents has a given node as a parent; otherwise false.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.InsertChild Method

ISyntaxNodeInsertChild Method
When implemented by a class, inserts specified node to the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int InsertChild(
    ISyntaxNode node,
    IComparer<ISyntaxNode> comparer
)
Function InsertChild (
    node As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode)
) As Integer
int InsertChild(
    ISyntaxNode^ node,
    IComparer<ISyntaxNode^>^ comparer
)
abstract InsertChild :
        node : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> -> int

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to insert.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted child collection.

Return Value

Type: Int32
Index of inserted node in the child collection.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.PositionChanged Method

ISyntaxNodePositionChanged Method
When implemented by a class, updates content of this ISyntaxNode.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxNode> comparer
)
Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    comparer As IComparer(Of ISyntaxNode)
) As Boolean
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxNode^>^ comparer
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        comparer : IComparer<ISyntaxNode> -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Sort Method

ISyntaxNodeSort Method
When implemented by a class, sorts the ISyntaxNode in the child list using the specified comparer.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Sort(
    IComparer<ISyntaxNode> comparer
)
Sub Sort (
    comparer As IComparer(Of ISyntaxNode)
)
void Sort(
    IComparer<ISyntaxNode^>^ comparer
)
abstract Sort :
        comparer : IComparer<ISyntaxNode> -> unit

Parameters

comparer
Type: System.Collections.GenericIComparerISyntaxNode
The IComparer implementation to use when comparing nodes.
Remarks
This method is recursive, so if some node in the child collection has children they are also sorted.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode Properties

ISyntaxNode Properties

The ISyntaxNode type exposes the following members.

Properties
 | Name | Description
Public property | AttributeCount | When implemented by a class, represents number of attributes in the attribute collection.
Public property | AttributeList | When implemented by a class, gets a list of attributes.
Public property | Attributes | When implemented by a class, gets or sets an attribute collection in the form of array.
Public property | ChildCount | When implemented by a class, represents number of children in the child collection.
Public property | ChildList | When implemented by a class, gets a list of child nodes.
Public property | Childs | When implemented by a class, gets or sets a collection of child nodes in the form of array.
Public property | ErrorCount | When implemented by a class, represents number of syntax errors in the error collection.
Public property | ErrorList | When implemented by a class, gets a list of syntax errors.
Public property | Errors | When implemented by a class, gets or sets an error collection in the form of array.
Public property | HasAttributes | When implemented by a class, indicates whether node has attributes.
Public property | HasChildren | When implemented by a class, indicates whether node has children.
Public property | HasErrors | When implemented by a class, indicates whether node has errors.
Public property | Index | When implemented by a class, represents index of then node within its parent child collection.
Public property | Level | When implemented by a class, represents node level inside SyntaxTree.
Public property | Name | When implemented by a class, gets or sets node name.
Public property | NodeType | When implemented by a class, gets or sets type of the node.
Public property | Options | When implemented by a class, gets or sets node options that defines its behavior.
Public property | Parent | When implemented by a class, gets or sets ISyntaxNode that holds this node in its child list.
Public property | Position | When implemented by a class, gets or sets node position in the code text.
Public property | Range | When implemented by a class, gets or sets node scope.
Public property | Root | When implemented by a class, represents root level ISyntaxNode in the syntax tree.
Public property | Size | When implemented by a class, gets or sets node dimension.
Top
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.AttributeCount Property

ISyntaxNodeAttributeCount Property
When implemented by a class, represents number of attributes in the attribute collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AttributeCount { get; }
ReadOnly Property AttributeCount As Integer
    Get
property int AttributeCount {
    int get ();
}
abstract AttributeCount : int with get

Property Value

Type: Int32
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.AttributeList Property

ISyntaxNodeAttributeList Property
When implemented by a class, gets a list of attributes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxAttributes AttributeList { get; }
ReadOnly Property AttributeList As ISyntaxAttributes
    Get
property ISyntaxAttributes^ AttributeList {
    ISyntaxAttributes^ get ();
}
abstract AttributeList : ISyntaxAttributes with get

Property Value

Type: ISyntaxAttributes
Remarks
If there is no attributes, contains null reference.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Attributes Property

ISyntaxNodeAttributes Property
When implemented by a class, gets or sets an attribute collection in the form of array.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxAttribute[] Attributes { get; set; }
Property Attributes As ISyntaxAttribute()
    Get
    Set
property array<ISyntaxAttribute^>^ Attributes {
    array<ISyntaxAttribute^>^ get ();
    void set (array<ISyntaxAttribute^>^ value);
}
abstract Attributes : ISyntaxAttribute[] with get, set

Property Value

Type: ISyntaxAttribute
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.ChildCount Property

ISyntaxNodeChildCount Property
When implemented by a class, represents number of children in the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ChildCount { get; }
ReadOnly Property ChildCount As Integer
    Get
property int ChildCount {
    int get ();
}
abstract ChildCount : int with get

Property Value

Type: Int32
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.ChildList Property

ISyntaxNodeChildList Property
When implemented by a class, gets a list of child nodes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNodes ChildList { get; }
ReadOnly Property ChildList As ISyntaxNodes
    Get
property ISyntaxNodes^ ChildList {
    ISyntaxNodes^ get ();
}
abstract ChildList : ISyntaxNodes with get

Property Value

Type: ISyntaxNodes
Remarks
If there is no child nodes, contains null reference.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Childs Property

ISyntaxNodeChilds Property
When implemented by a class, gets or sets a collection of child nodes in the form of array.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode[] Childs { get; set; }
Property Childs As ISyntaxNode()
    Get
    Set
property array<ISyntaxNode^>^ Childs {
    array<ISyntaxNode^>^ get ();
    void set (array<ISyntaxNode^>^ value);
}
abstract Childs : ISyntaxNode[] with get, set

Property Value

Type: ISyntaxNode
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.ErrorCount Property

ISyntaxNodeErrorCount Property
When implemented by a class, represents number of syntax errors in the error collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ErrorCount { get; }
ReadOnly Property ErrorCount As Integer
    Get
property int ErrorCount {
    int get ();
}
abstract ErrorCount : int with get

Property Value

Type: Int32
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.ErrorList Property

ISyntaxNodeErrorList Property
When implemented by a class, gets a list of syntax errors.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxErrors ErrorList { get; }
ReadOnly Property ErrorList As ISyntaxErrors
    Get
property ISyntaxErrors^ ErrorList {
    ISyntaxErrors^ get ();
}
abstract ErrorList : ISyntaxErrors with get

Property Value

Type: ISyntaxErrors
Remarks
If there is no errors, contains null reference.
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Errors Property

ISyntaxNodeErrors Property
When implemented by a class, gets or sets an error collection in the form of array.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxError[] Errors { get; set; }
Property Errors As ISyntaxError()
    Get
    Set
property array<ISyntaxError^>^ Errors {
    array<ISyntaxError^>^ get ();
    void set (array<ISyntaxError^>^ value);
}
abstract Errors : ISyntaxError[] with get, set

Property Value

Type: ISyntaxError
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.HasAttributes Property

ISyntaxNodeHasAttributes Property
When implemented by a class, indicates whether node has attributes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasAttributes { get; }
ReadOnly Property HasAttributes As Boolean
    Get
property bool HasAttributes {
    bool get ();
}
abstract HasAttributes : bool with get

Property Value

Type: Boolean
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.HasChildren Property

ISyntaxNodeHasChildren Property
When implemented by a class, indicates whether node has children.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasChildren { get; }
ReadOnly Property HasChildren As Boolean
    Get
property bool HasChildren {
    bool get ();
}
abstract HasChildren : bool with get

Property Value

Type: Boolean
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.HasErrors Property

ISyntaxNodeHasErrors Property
When implemented by a class, indicates whether node has errors.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasErrors { get; }
ReadOnly Property HasErrors As Boolean
    Get
property bool HasErrors {
    bool get ();
}
abstract HasErrors : bool with get

Property Value

Type: Boolean
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Index Property

ISyntaxNodeIndex Property
When implemented by a class, represents index of then node within its parent child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Level Property

ISyntaxNodeLevel Property
When implemented by a class, represents node level inside SyntaxTree.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Level { get; }
ReadOnly Property Level As Integer
    Get
property int Level {
    int get ();
}
abstract Level : int with get

Property Value

Type: Int32
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Name Property

ISyntaxNodeName Property
When implemented by a class, gets or sets node name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.NodeType Property

ISyntaxNodeNodeType Property
When implemented by a class, gets or sets type of the node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int NodeType { get; set; }
Property NodeType As Integer
    Get
    Set
property int NodeType {
    int get ();
    void set (int value);
}
abstract NodeType : int with get, set

Property Value

Type: Int32
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Options Property

ISyntaxNodeOptions Property
When implemented by a class, gets or sets node options that defines its behavior.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SyntaxNodeOptions Options { get; set; }
Property Options As SyntaxNodeOptions
    Get
    Set
property SyntaxNodeOptions Options {
    SyntaxNodeOptions get ();
    void set (SyntaxNodeOptions value);
}
abstract Options : SyntaxNodeOptions with get, set

Property Value

Type: SyntaxNodeOptions
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Parent Property

ISyntaxNodeParent Property
When implemented by a class, gets or sets ISyntaxNode that holds this node in its child list.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode Parent { get; set; }
Property Parent As ISyntaxNode
    Get
    Set
property ISyntaxNode^ Parent {
    ISyntaxNode^ get ();
    void set (ISyntaxNode^ value);
}
abstract Parent : ISyntaxNode with get, set

Property Value

Type: ISyntaxNode
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Position Property

ISyntaxNodePosition Property
When implemented by a class, gets or sets node position in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Position { get; set; }
Property Position As Point
    Get
    Set
property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set

Property Value

Type: Point
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Range Property

ISyntaxNodeRange Property
When implemented by a class, gets or sets node scope.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange Range { get; set; }
Property Range As IRange
    Get
    Set
property IRange^ Range {
    IRange^ get ();
    void set (IRange^ value);
}
abstract Range : IRange with get, set

Property Value

Type: IRange
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Root Property

ISyntaxNodeRoot Property
When implemented by a class, represents root level ISyntaxNode in the syntax tree.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode Root { get; }
ReadOnly Property Root As ISyntaxNode
    Get
property ISyntaxNode^ Root {
    ISyntaxNode^ get ();
}
abstract Root : ISyntaxNode with get

Property Value

Type: ISyntaxNode
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNode.Size Property

ISyntaxNodeSize Property
When implemented by a class, gets or sets node dimension.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Size Size { get; set; }
Property Size As Size
    Get
    Set
property Size Size {
    Size get ();
    void set (Size value);
}
abstract Size : Size with get, set

Property Value

Type: Size
See Also

Reference

ISyntaxNode Interface
Alternet.Syntax Namespace


ISyntaxNodes Interface

ISyntaxNodes Interface
Represents collection containing list of syntax nodes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxNodes : ISortList<ISyntaxNode>,
    IList<ISyntaxNode>, ICollection<ISyntaxNode>, IEnumerable<ISyntaxNode>,
    IEnumerable
Public Interface ISyntaxNodes
    Inherits ISortList(Of ISyntaxNode), IList(Of ISyntaxNode),
    ICollection(Of ISyntaxNode), IEnumerable(Of ISyntaxNode), IEnumerable
public interface class ISyntaxNodes : ISortList<ISyntaxNode^>,
    IList<ISyntaxNode^>, ICollection<ISyntaxNode^>, IEnumerable<ISyntaxNode^>,
    IEnumerable
type ISyntaxNodes =
    interface
        interface ISortList<ISyntaxNode>
        interface IList<ISyntaxNode>
        interface ICollection<ISyntaxNode>
        interface IEnumerable<ISyntaxNode>
        interface IEnumerable
    end

The ISyntaxNodes type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionISyntaxNode .)
Public method | BlockDeleting | When implemented by a class, removes all syntax nodes from the nodes collection which position in the specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionISyntaxNode .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionISyntaxNode .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionISyntaxNode .)
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableISyntaxNode .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListISyntaxNode .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListISyntaxNode .)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria. (Inherited from ISortListT.)
Public method | PositionChanged | When implemented by a class, updates all syntax nodes starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionISyntaxNode .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListISyntaxNode .)
Public method | Sort | When implemented by a class, sorts the elements in the entire sort list using the specified comparer. (Inherited from ISortListT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxNode | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxNode | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxNode, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionISyntaxNode .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionISyntaxNode .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListISyntaxNode .)
Top
See Also

Reference

Alternet.Syntax Namespace


ISyntaxNodes Methods

ISyntaxNodes Methods

The ISyntaxNodes type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionISyntaxNode .)
Public method | BlockDeleting | When implemented by a class, removes all syntax nodes from the nodes collection which position in the specified rectangle.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionISyntaxNode .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionISyntaxNode .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionISyntaxNode .)
Public method | FindExact(Object, Int32, IComparer) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindExact(T, Int32, IComparerT) | When implemented by a class, finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from ISortListT.)
Public method | FindFirst(Object, Int32, IComparer) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindFirst(T, Int32, IComparerT) | When implemented by a class, finds the first occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(Object, Int32, IComparer) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | FindLast(T, Int32, IComparerT) | When implemented by a class, finds the last occurrence of the given object that satisfies searching criteria. (Inherited from ISortListT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableISyntaxNode .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListISyntaxNode .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListISyntaxNode .)
Public method | NeedSort | When implemented by a class, determines if the list needs sorting based on given criteria. (Inherited from ISortListT.)
Public method | PositionChanged | When implemented by a class, updates all syntax nodes starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionISyntaxNode .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListISyntaxNode .)
Public method | Sort | When implemented by a class, sorts the elements in the entire sort list using the specified comparer. (Inherited from ISortListT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxNode | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxNode | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxNode, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ISyntaxNodes Interface
Alternet.Syntax Namespace


ISyntaxNodes.BlockDeleting Method

ISyntaxNodesBlockDeleting Method
When implemented by a class, removes all syntax nodes from the nodes collection which position in the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxNode> comparer
)
Function BlockDeleting (
    rect As Rectangle,
    comparer As IComparer(Of ISyntaxNode)
) As Boolean
bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxNode^>^ comparer
)
abstract BlockDeleting :
        rect : Rectangle *
        comparer : IComparer<ISyntaxNode> -> bool

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove nodes.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxNodes Interface
Alternet.Syntax Namespace


ISyntaxNodes.PositionChanged Method

ISyntaxNodesPositionChanged Method
When implemented by a class, updates all syntax nodes starting from specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxNode> comparer
)
Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    comparer As IComparer(Of ISyntaxNode)
) As Boolean
bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxNode^>^ comparer
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        comparer : IComparer<ISyntaxNode> -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxNodes Interface
Alternet.Syntax Namespace


ISyntaxNodes Properties

ISyntaxNodes Properties

The ISyntaxNodes type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionISyntaxNode .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionISyntaxNode .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListISyntaxNode .)
Top
See Also

Reference

ISyntaxNodes Interface
Alternet.Syntax Namespace


ISyntaxParser Interface

ISyntaxParser Interface
Represents properties and methods to perform syntax analysis of the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxParser : IParser,
    ILexer, INotify, IUpdate, IImport
Public Interface ISyntaxParser
    Inherits IParser, ILexer, INotify, IUpdate,
    IImport
public interface class ISyntaxParser : IParser,
    ILexer, INotify, IUpdate, IImport
type ISyntaxParser =
    interface
        interface IParser
        interface ILexer
        interface INotify
        interface IUpdate
        interface IImport
    end

The ISyntaxParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | When implemented by a class, aborts parsing process by raising StopParseException exception.
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexer object. (Inherited from ILexer.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BlockDeleting | When implemented by a class, removes all nodes from the node collection which position in the specified rectangle.
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | When implemented by a class, performs code completion for the specified text representing language element.
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | When implemented by a class, performs code completion for the specified text representing language element.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | FindCodeFixes | When implemented by a class, locates and highlights available code refactors for given syntax error.
Public method | FindCodeRefactors | When implemented by a class, locates and highlights available code refactors at given position in the text.
Public method | FindDeclaration(Point) | When implemented by a class, finds the declaration at given position.
Public method | FindDeclaration(String, Point) | When implemented by a class, finds the declaration node or type at given position.
Public method | FindImplementations | When implemented by a class, locates all implementations at given position and in the text.
Public method | FindReferences(Point) | When implemented by a class, locates and highlights references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | When implemented by a class, locates all references to the node in the text.
Public method | FindReferences(Point, IRangeList, Boolean) | When implemented by a class, locates declaration at given position and finds all references to this declaration in the text.
Public method | FinishParsing | When implemented by a class, commits parsing process.
Public method | GetActiveStatementAt | When implemented by a class, gets IRange that corresponds to the statement at specified position.
Public method | GetAutoFormatNode | When implemented by a class, gets syntax block node at specified position.
Public method | GetCodeFixes | When implemented by a class, retrieves all code fixes available for the given syntax error.
Public method | GetCodeRefactors(Point, Boolean) | When implemented by a class, retrieves all applicable refactors at given position.
Public method | GetCodeRefactors(Point, Point, Boolean) | When implemented by a class, retrieves all applicable refactors at given range.
Public method | GetContentDividers | When implemented by a class, gets list of content dividers.
Public method | GetMultiLineComment(String, String) | When implemented by a class, gets the start and symbols multi-line comment.
Public method | GetMultiLineComment(Point, String, String) | When implemented by a class, gets the start and symbols multi-line comment.
Public method | GetNodeAt | When implemented by a class, gets ISyntaxNode that corresponds to the specified position.
Public method | GetRangeAt(Point) | When implemented by a class, gets IRange that corresponds to the specified position.
Public method | GetRangeAt(Point, IListIRange) | When implemented by a class, gets IRange list that corresponds to the specified position.
Public method | GetSingleLineComment | When implemented by a class, gets the string that represents start symbol of single line comment.
Public method | GetSingleLineComment(Point) | When implemented by a class, gets the string that represents start symbol of single line comment.
Public method | GetSmartIndent(Int32, Boolean) | When implemented by a class, returns indentation level of specified line.
Public method | GetSmartIndent(Int32, Boolean, Boolean) | When implemented by a class, returns indentation level of specified line.
Public method | GetSmartIndentString | When implemented by a class, returns indentation string for specified line.
Public method | GetStructureGuideLines | When implemented by a class, gets list of guide lines.
Public method | GetSyntaxErrors | When implemented by a class, retrieves all syntax errors that ISyntaxParser found while analyzing the text.
Public method | IsCodeCompletionChar | When implemented by a class, returns boolean value indicating that given character initializes a code completion procedure when typing.
Public method | IsDeclaration | When implemented by a class, indicates whether specified node represents declaration elements.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | NextToken | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from IParser.)
Public method | NextToken(String) | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from IParser.)
Public method | NextValidToken | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from IParser.)
Public method | NextValidToken(String) | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from IParser.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | OnTextChanged | When implemented by a class, responds to incremental change of the text in the editor.
Public method | OnTextParsed | When implemented by a class, raises TextParsed event.
Public method | Outline | When implemented by a class, creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | When implemented by a class, performs lexical analysis of given text. (Inherited from ILexer.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | When implemented by a class, performs lexical analysis of given text. (Inherited from ILexer.)
Public method | PeekToken | When implemented by a class, parses next portion of the text, remaining current position unchanged. (Inherited from IParser.)
Public method | PeekToken(String) | When implemented by a class, parses next portion of the text, remaining current position unchanged. (Inherited from IParser.)
Public method | PeekValidToken | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from IParser.)
Public method | PeekValidToken(String) | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from IParser.)
Public method | PositionChanged | When implemented by a class, changes positions of any syntax nodes and its elements located next to the specified position.
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse.
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | When implemented by a class, sets lines to parse.
Public method | ProcessAutoComplete | When implemented by a class, checks whether end-of-block code needs inserting.
Public method | ProcessSnippetBody | When implemented by a class, checks whether snippet body code needs inserting.
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | RemovePlainText | When implemented by a class, removes all plain (string constants or comments) parts of text from specified text. (Inherited from ILexer.)
Public method | ReparseBlock(Point) | When implemented by a class, reparses syntax block at specified position.
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position.
Public method | ReparseText | When implemented by a class, reparses entire text.
Public method | ReparseText(Boolean) | When implemented by a class, reparses entire text. Specifies whether parser should perform the task in the separate thread
Public method | ReparseText(Boolean, Int32, Int32) | When implemented by a class, reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.
Public method | Reset | When implemented by a class, resets IParser to the start position. (Inherited from IParser.)
Public method | Reset(Int32, Int32, Int32) | When implemented by a class, resets IParser to the specified position. (Inherited from IParser.)
Public method | ResetAutoIndentChars | When implemented by a class, resets AutoIndentChars to the default value.
Public method | ResetCodeCompletionChars | When implemented by a class, resets CodeCompletionChars to the default value.
Public method | ResetCodeCompletionStopChars | When implemented by a class, resets CodeCompletionStopChars to the default value.
Public method | ResetDefaultState | When implemented by a class, resets the DefaultState to the default value. (Inherited from ILexer.)
Public method | ResetOptions | When implemented by a class, resets Options to the default value.
Public method | ResetParseInterval | When implemented by a class, resets ParseInterval to the default value.
Public method | ResetSmartFormatChars | When implemented by a class, resets SmartFormatChars to the default value.
Public method | RestoreState | When implemented by a class, restores IParser state and position stored by SaveState method. (Inherited from IParser.)
Public method | RestoreState(Boolean) | When implemented by a class, restores IParser state and position stored by SaveState method. (Inherited from IParser.)
Public method | RestoreSyntaxTree | When implemented by a class, restores syntax tree, stored by SaveSyntaxTree method.
Public method | SaveState | When implemented by a class, saves current IParser state and position. (Inherited from IParser.)
Public method | SaveSyntaxTree | When implemented by a class, saves current syntax tree.
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | When implemented by a class, formats block of text according to the parser rules.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | When implemented by a class, formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList of changes.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | When implemented by a class, formats line according to the parser rules.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | When implemented by a class, formats line according to the parser rules.
Public method | StartParsing | When implemented by a class, prepares parser to parse the specified range of the text.
Public method | StopParsing | When implemented by a class, aborts parsing process.
Public method | SupportsAsyncParsing | When implemented by a class, indicates whether parser supports async parsing.
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type.
Public method | SupportsContentDividers | When implemented by a class, indicates whether content dividers are supported.
Public method | SupportsTextChanges | When implemented by a class, indicates whether parser supports incremental text changes.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | Aborted | When implemented by a class, gets or sets boolean value indicating whether parsing process has been aborted.
Public property | AutoIndentChars | When implemented by a class, gets or sets a collection of characters that initializes an indentation procedure when typing.
Public property | CaseSensitive | When implemented by a class, gets or sets a boolean value that indicates whether ISyntaxParser should perform case-sensitive analysis if its content.
Public property | CodeCompletionChars | When implemented by a class, gets or sets a collection of characters that initializes a code completion procedure when typing.
Public property | CodeCompletionStopChars | When implemented by a class, gets or sets a collection of characters that finalizes a code completion procedure when typing.
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser.
Public property | CompletionRepository | When implemented by a class, gets or sets an ICodeCompletionRepository that holds methods for code completion purposes.
Public property | CurrentPosition | When implemented by a class, represents position of current character within the current line. (Inherited from IParser.)
Public property | DefaultState | When implemented by a class, gets or sets default state of the ILexer. (Inherited from ILexer.)
Public property | Delimiters | When implemented by a class, gets or sets a collection of characters representing delimiters
Public property | Eof | When implemented by a class, indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from IParser.)
Public property | ExpressionEvaluator | When implemented by a class, gets or sets an IExpressionEvaluator instance using to evaluate conditional defines.
Public property | FileName | When implemented by a class, gets or sets file name of the file being parsed.
Public property | Lines | When implemented by a class, gets or sets a list of string to parse represented as string array. (Inherited from IParser.)
Public property | Options | When implemented by a class, gets or sets a flags determining syntax parsing and formatting behavior.
Public property | ParseInterval | When implemented by a class, specifies delay reparsing should trigger after any change in the editor.
Public property | Scheme | When implemented by a class, gets or sets list of rules for lexical analysis. (Inherited from ILexer.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of ILexer. (Inherited from ILexer.)
Public property | SmartFormatChars | When implemented by a class, gets or sets a collection of characters that initializes a smart formatting procedure when typing.
Public property | State | When implemented by a class, represents current IParser state. (Inherited from IParser.)
Public property | Strings | When implemented by a class, gets or sets a list of strings to parse. (Inherited from IParser.)
Public property | SupportsThread | When implemented by a class, gets boolean value indicating whether parser supports working in thread.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed.
Public property | Token | When implemented by a class, represents token (index of style in the class style collection) related to the current position in the parsed text. (Inherited from IParser.)
Public property | TokenPosition | When implemented by a class, represents start position of the current token. (Inherited from IParser.)
Public property | TokenString | When implemented by a class, represents text of the current syntax token. (Inherited from IParser.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UseScheme | When implemented by a class, gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method.
Top
Events
 | Name | Description
Public event | Parse | When implemented by a class, occurs when text line is parsed, allowing to modify colors/styles information for the parsed line. (Inherited from ILexer.)
Public event | TextReparsed | When implemented by a class, occurs when ISyntaxParser text content is fully parsed.
Top
See Also

Reference

Alternet.Syntax Namespace


ISyntaxParser Methods

ISyntaxParser Methods

The ISyntaxParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | When implemented by a class, aborts parsing process by raising StopParseException exception.
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexer object. (Inherited from ILexer.)
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | BlockDeleting | When implemented by a class, removes all nodes from the node collection which position in the specified rectangle.
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | When implemented by a class, performs code completion for the specified text representing language element.
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | When implemented by a class, performs code completion for the specified text representing language element.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | FindCodeFixes | When implemented by a class, locates and highlights available code refactors for given syntax error.
Public method | FindCodeRefactors | When implemented by a class, locates and highlights available code refactors at given position in the text.
Public method | FindDeclaration(Point) | When implemented by a class, finds the declaration at given position.
Public method | FindDeclaration(String, Point) | When implemented by a class, finds the declaration node or type at given position.
Public method | FindImplementations | When implemented by a class, locates all implementations at given position and in the text.
Public method | FindReferences(Point) | When implemented by a class, locates and highlights references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | When implemented by a class, locates all references to the node in the text.
Public method | FindReferences(Point, IRangeList, Boolean) | When implemented by a class, locates declaration at given position and finds all references to this declaration in the text.
Public method | FinishParsing | When implemented by a class, commits parsing process.
Public method | GetActiveStatementAt | When implemented by a class, gets IRange that corresponds to the statement at specified position.
Public method | GetAutoFormatNode | When implemented by a class, gets syntax block node at specified position.
Public method | GetCodeFixes | When implemented by a class, retrieves all code fixes available for the given syntax error.
Public method | GetCodeRefactors(Point, Boolean) | When implemented by a class, retrieves all applicable refactors at given position.
Public method | GetCodeRefactors(Point, Point, Boolean) | When implemented by a class, retrieves all applicable refactors at given range.
Public method | GetContentDividers | When implemented by a class, gets list of content dividers.
Public method | GetMultiLineComment(String, String) | When implemented by a class, gets the start and symbols multi-line comment.
Public method | GetMultiLineComment(Point, String, String) | When implemented by a class, gets the start and symbols multi-line comment.
Public method | GetNodeAt | When implemented by a class, gets ISyntaxNode that corresponds to the specified position.
Public method | GetRangeAt(Point) | When implemented by a class, gets IRange that corresponds to the specified position.
Public method | GetRangeAt(Point, IListIRange) | When implemented by a class, gets IRange list that corresponds to the specified position.
Public method | GetSingleLineComment | When implemented by a class, gets the string that represents start symbol of single line comment.
Public method | GetSingleLineComment(Point) | When implemented by a class, gets the string that represents start symbol of single line comment.
Public method | GetSmartIndent(Int32, Boolean) | When implemented by a class, returns indentation level of specified line.
Public method | GetSmartIndent(Int32, Boolean, Boolean) | When implemented by a class, returns indentation level of specified line.
Public method | GetSmartIndentString | When implemented by a class, returns indentation string for specified line.
Public method | GetStructureGuideLines | When implemented by a class, gets list of guide lines.
Public method | GetSyntaxErrors | When implemented by a class, retrieves all syntax errors that ISyntaxParser found while analyzing the text.
Public method | IsCodeCompletionChar | When implemented by a class, returns boolean value indicating that given character initializes a code completion procedure when typing.
Public method | IsDeclaration | When implemented by a class, indicates whether specified node represents declaration elements.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | NextToken | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from IParser.)
Public method | NextToken(String) | When implemented by a class, parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from IParser.)
Public method | NextValidToken | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from IParser.)
Public method | NextValidToken(String) | When implemented by a class, parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from IParser.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | OnTextChanged | When implemented by a class, responds to incremental change of the text in the editor.
Public method | OnTextParsed | When implemented by a class, raises TextParsed event.
Public method | Outline | When implemented by a class, creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | When implemented by a class, performs lexical analysis of given text. (Inherited from ILexer.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | When implemented by a class, performs lexical analysis of given text. (Inherited from ILexer.)
Public method | PeekToken | When implemented by a class, parses next portion of the text, remaining current position unchanged. (Inherited from IParser.)
Public method | PeekToken(String) | When implemented by a class, parses next portion of the text, remaining current position unchanged. (Inherited from IParser.)
Public method | PeekValidToken | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from IParser.)
Public method | PeekValidToken(String) | When implemented by a class, parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from IParser.)
Public method | PositionChanged | When implemented by a class, changes positions of any syntax nodes and its elements located next to the specified position.
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse.
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | When implemented by a class, sets lines to parse.
Public method | ProcessAutoComplete | When implemented by a class, checks whether end-of-block code needs inserting.
Public method | ProcessSnippetBody | When implemented by a class, checks whether snippet body code needs inserting.
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | RemovePlainText | When implemented by a class, removes all plain (string constants or comments) parts of text from specified text. (Inherited from ILexer.)
Public method | ReparseBlock(Point) | When implemented by a class, reparses syntax block at specified position.
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position.
Public method | ReparseText | When implemented by a class, reparses entire text.
Public method | ReparseText(Boolean) | When implemented by a class, reparses entire text. Specifies whether parser should perform the task in the separate thread
Public method | ReparseText(Boolean, Int32, Int32) | When implemented by a class, reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.
Public method | Reset | When implemented by a class, resets IParser to the start position. (Inherited from IParser.)
Public method | Reset(Int32, Int32, Int32) | When implemented by a class, resets IParser to the specified position. (Inherited from IParser.)
Public method | ResetAutoIndentChars | When implemented by a class, resets AutoIndentChars to the default value.
Public method | ResetCodeCompletionChars | When implemented by a class, resets CodeCompletionChars to the default value.
Public method | ResetCodeCompletionStopChars | When implemented by a class, resets CodeCompletionStopChars to the default value.
Public method | ResetDefaultState | When implemented by a class, resets the DefaultState to the default value. (Inherited from ILexer.)
Public method | ResetOptions | When implemented by a class, resets Options to the default value.
Public method | ResetParseInterval | When implemented by a class, resets ParseInterval to the default value.
Public method | ResetSmartFormatChars | When implemented by a class, resets SmartFormatChars to the default value.
Public method | RestoreState | When implemented by a class, restores IParser state and position stored by SaveState method. (Inherited from IParser.)
Public method | RestoreState(Boolean) | When implemented by a class, restores IParser state and position stored by SaveState method. (Inherited from IParser.)
Public method | RestoreSyntaxTree | When implemented by a class, restores syntax tree, stored by SaveSyntaxTree method.
Public method | SaveState | When implemented by a class, saves current IParser state and position. (Inherited from IParser.)
Public method | SaveSyntaxTree | When implemented by a class, saves current syntax tree.
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | When implemented by a class, formats block of text according to the parser rules.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | When implemented by a class, formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList of changes.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | When implemented by a class, formats line according to the parser rules.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | When implemented by a class, formats line according to the parser rules.
Public method | StartParsing | When implemented by a class, prepares parser to parse the specified range of the text.
Public method | StopParsing | When implemented by a class, aborts parsing process.
Public method | SupportsAsyncParsing | When implemented by a class, indicates whether parser supports async parsing.
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type.
Public method | SupportsContentDividers | When implemented by a class, indicates whether content dividers are supported.
Public method | SupportsTextChanges | When implemented by a class, indicates whether parser supports incremental text changes.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.Abort Method

ISyntaxParserAbort Method
When implemented by a class, aborts parsing process by raising StopParseException exception.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Abort()
Sub Abort
void Abort()
abstract Abort : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.BlockDeleting Method

ISyntaxParserBlockDeleting Method
When implemented by a class, removes all nodes from the node collection which position in the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BlockDeleting(
    Rectangle rect
)
Sub BlockDeleting (
    rect As Rectangle
)
void BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove syntax nodes.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.CodeCompletion Method

ISyntaxParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | When implemented by a class, performs code completion for the specified text representing language element.
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | When implemented by a class, performs code completion for the specified text representing language element.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.CodeCompletion Method (String, StringItemInfo[], Point, CodeCompletionArgs)

ISyntaxParserCodeCompletion Method (String, StringItemInfo, Point, CodeCompletionArgs)
When implemented by a class, performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    CodeCompletionArgs e
)
Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    e As CodeCompletionArgs
)
void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    CodeCompletionArgs^ e
)
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.
See Also

Reference

ISyntaxParser Interface
CodeCompletion Overload
Alternet.Syntax Namespace


ISyntaxParser.CodeCompletion Method (String, StringItemInfo[], Point, Boolean, CodeCompletionArgs)

ISyntaxParserCodeCompletion Method (String, StringItemInfo, Point, Boolean, CodeCompletionArgs)
When implemented by a class, performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    bool useThread,
    CodeCompletionArgs e
)
Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    useThread As Boolean,
    e As CodeCompletionArgs
)
void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    bool useThread,
    CodeCompletionArgs^ e
)
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        useThread : bool *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
useThread
Type: SystemBoolean
Specifies whether parser should perform the task in the separate thread.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.
See Also

Reference

ISyntaxParser Interface
CodeCompletion Overload
Alternet.Syntax Namespace


ISyntaxParser.FindCodeFixes Method

ISyntaxParserFindCodeFixes Method
When implemented by a class, locates and highlights available code refactors for given syntax error.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FindCodeFixes(
    Point position,
    ISyntaxError error,
    bool allDocuments = false
)
Sub FindCodeFixes (
    position As Point,
    error As ISyntaxError,
    Optional allDocuments As Boolean = false
)
void FindCodeFixes(
    Point position,
    ISyntaxError^ error,
    bool allDocuments = false
)
abstract FindCodeFixes :
        position : Point *
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit

Parameters

position
Type: System.DrawingPoint
Current position within the text.
error
Type: Alternet.SyntaxISyntaxError
Syntax error within the text.
allDocuments (Optional)
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.FindCodeRefactors Method

ISyntaxParserFindCodeRefactors Method
When implemented by a class, locates and highlights available code refactors at given position in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FindCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments = false
)
Sub FindCodeRefactors (
    startPos As Point,
    endPos As Point,
    Optional allDocuments As Boolean = false
)
void FindCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments = false
)
abstract FindCodeRefactors :
        startPos : Point *
        endPos : Point *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit

Parameters

startPos
Type: System.DrawingPoint
Start position within the text.
endPos
Type: System.DrawingPoint
End position within the text.
allDocuments (Optional)
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.FindDeclaration Method

ISyntaxParserFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(Point) | When implemented by a class, finds the declaration at given position.
Public method | FindDeclaration(String, Point) | When implemented by a class, finds the declaration node or type at given position.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.FindDeclaration Method (Point)

ISyntaxParserFindDeclaration Method (Point)
When implemented by a class, finds the declaration at given position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SymbolLocation FindDeclaration(
    Point position
)
Function FindDeclaration (
    position As Point
) As SymbolLocation
SymbolLocation^ FindDeclaration(
    Point position
)
abstract FindDeclaration :
        position : Point -> SymbolLocation

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Return Value

Type: SymbolLocation
SymbolLocation object that is found.
See Also

Reference

ISyntaxParser Interface
FindDeclaration Overload
Alternet.Syntax Namespace


ISyntaxParser.FindDeclaration Method (String, Point)

ISyntaxParserFindDeclaration Method (String, Point)
When implemented by a class, finds the declaration node or type at given position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object FindDeclaration(
    string text,
    Point position
)
Function FindDeclaration (
    text As String,
    position As Point
) As Object
Object^ FindDeclaration(
    String^ text,
    Point position
)
abstract FindDeclaration :
        text : string *
        position : Point -> Object

Parameters

text
Type: SystemString
Contains string used to perform search.
position
Type: System.DrawingPoint
Specifies position to find node.

Return Value

Type: Object
object that is found.
See Also

Reference

ISyntaxParser Interface
FindDeclaration Overload
Alternet.Syntax Namespace


ISyntaxParser.FindImplementations Method

ISyntaxParserFindImplementations Method
When implemented by a class, locates all implementations at given position and in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FindImplementations(
    Point position,
    IRangeList references,
    bool allDocuments = false
)
Function FindImplementations (
    position As Point,
    references As IRangeList,
    Optional allDocuments As Boolean = false
) As Integer
int FindImplementations(
    Point position,
    IRangeList^ references,
    bool allDocuments = false
)
abstract FindImplementations :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
Retrieves references to found declaration.
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found references.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.FindReferences Method

ISyntaxParserFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(Point) | When implemented by a class, locates and highlights references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | When implemented by a class, locates all references to the node in the text.
Public method | FindReferences(Point, IRangeList, Boolean) | When implemented by a class, locates declaration at given position and finds all references to this declaration in the text.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.FindReferences Method (Point)

ISyntaxParserFindReferences Method (Point)
When implemented by a class, locates and highlights references at given position in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FindReferences(
    Point position
)
Sub FindReferences (
    position As Point
)
void FindReferences(
    Point position
)
abstract FindReferences :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
See Also

Reference

ISyntaxParser Interface
FindReferences Overload
Alternet.Syntax Namespace


ISyntaxParser.FindReferences Method (ISyntaxNode, ISyntaxNodes)

ISyntaxParserFindReferences Method (ISyntaxNode, ISyntaxNodes)
When implemented by a class, locates all references to the node in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FindReferences(
    ISyntaxNode node,
    ISyntaxNodes references
)
Function FindReferences (
    node As ISyntaxNode,
    references As ISyntaxNodes
) As Integer
int FindReferences(
    ISyntaxNode^ node,
    ISyntaxNodes^ references
)
abstract FindReferences :
        node : ISyntaxNode *
        references : ISyntaxNodes -> int

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to find references.
references
Type: Alternet.SyntaxISyntaxNodes
Retrieves references to node.

Return Value

Type: Int32
Number of found references.
See Also

Reference

ISyntaxParser Interface
FindReferences Overload
Alternet.Syntax Namespace


ISyntaxParser.FindReferences Method (Point, IRangeList, Boolean)

ISyntaxParserFindReferences Method (Point, IRangeList, Boolean)
When implemented by a class, locates declaration at given position and finds all references to this declaration in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FindReferences(
    Point position,
    IRangeList references,
    bool allDocuments = false
)
Function FindReferences (
    position As Point,
    references As IRangeList,
    Optional allDocuments As Boolean = false
) As Integer
int FindReferences(
    Point position,
    IRangeList^ references,
    bool allDocuments = false
)
abstract FindReferences :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
Retrieves references to found declaration.
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found references.
See Also

Reference

ISyntaxParser Interface
FindReferences Overload
Alternet.Syntax Namespace


ISyntaxParser.FinishParsing Method

ISyntaxParserFinishParsing Method
When implemented by a class, commits parsing process.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FinishParsing()
Sub FinishParsing
void FinishParsing()
abstract FinishParsing : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetActiveStatementAt Method

ISyntaxParserGetActiveStatementAt Method
When implemented by a class, gets IRange that corresponds to the statement at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange GetActiveStatementAt(
    Point position
)
Function GetActiveStatementAt (
    position As Point
) As IRange
IRange^ GetActiveStatementAt(
    Point position
)
abstract GetActiveStatementAt :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.

Return Value

Type: IRange
Statement range at given position
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetAutoFormatNode Method

ISyntaxParserGetAutoFormatNode Method
When implemented by a class, gets syntax block node at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode GetAutoFormatNode(
    Point position,
    bool extended,
    out Point startPt
)
Function GetAutoFormatNode (
    position As Point,
    extended As Boolean,
    <OutAttribute> ByRef startPt As Point
) As ISyntaxNode
ISyntaxNode^ GetAutoFormatNode(
    Point position,
    bool extended,
    [OutAttribute] Point% startPt
)
abstract GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode

Parameters

position
Type: System.DrawingPoint
Position to check-up.
extended
Type: SystemBoolean
Specifies that search should be extended outside current scope
startPt
Type: System.DrawingPoint
Retrieves position of block node.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetCodeFixes Method

ISyntaxParserGetCodeFixes Method
When implemented by a class, retrieves all code fixes available for the given syntax error.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<ICodeFix> GetCodeFixes(
    ISyntaxError error,
    bool allDocuments = false
)
Function GetCodeFixes (
    error As ISyntaxError,
    Optional allDocuments As Boolean = false
) As IList(Of ICodeFix)
IList<ICodeFix^>^ GetCodeFixes(
    ISyntaxError^ error,
    bool allDocuments = false
)
abstract GetCodeFixes :
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> IList<ICodeFix>

Parameters

error
Type: Alternet.SyntaxISyntaxError
Syntax error or warning
allDocuments (Optional)
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Return Value

Type: IListICodeFix
Collection of available code fixes
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetCodeRefactors Method

ISyntaxParserGetCodeRefactors Method
Overload List
 | Name | Description
Public method | GetCodeRefactors(Point, Boolean) | When implemented by a class, retrieves all applicable refactors at given position.
Public method | GetCodeRefactors(Point, Point, Boolean) | When implemented by a class, retrieves all applicable refactors at given range.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetCodeRefactors Method (Point, Boolean)

ISyntaxParserGetCodeRefactors Method (Point, Boolean)
When implemented by a class, retrieves all applicable refactors at given position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<ICodeRefactor> GetCodeRefactors(
    Point position,
    bool allDocuments
)
Function GetCodeRefactors (
    position As Point,
    allDocuments As Boolean
) As IList(Of ICodeRefactor)
IList<ICodeRefactor^>^ GetCodeRefactors(
    Point position,
    bool allDocuments
)
abstract GetCodeRefactors :
        position : Point *
        allDocuments : bool -> IList<ICodeRefactor>

Parameters

position
Type: System.DrawingPoint
Given position
allDocuments
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Return Value

Type: IListICodeRefactor
Collection of available code refactors
See Also

Reference

ISyntaxParser Interface
GetCodeRefactors Overload
Alternet.Syntax Namespace


ISyntaxParser.GetCodeRefactors Method (Point, Point, Boolean)

ISyntaxParserGetCodeRefactors Method (Point, Point, Boolean)
When implemented by a class, retrieves all applicable refactors at given range.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<ICodeRefactor> GetCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments
)
Function GetCodeRefactors (
    startPos As Point,
    endPos As Point,
    allDocuments As Boolean
) As IList(Of ICodeRefactor)
IList<ICodeRefactor^>^ GetCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments
)
abstract GetCodeRefactors :
        startPos : Point *
        endPos : Point *
        allDocuments : bool -> IList<ICodeRefactor>

Parameters

startPos
Type: System.DrawingPoint
Star position within the text.
endPos
Type: System.DrawingPoint
End position within the text..
allDocuments
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Return Value

Type: IListICodeRefactor
Collection of available code refactors
See Also

Reference

ISyntaxParser Interface
GetCodeRefactors Overload
Alternet.Syntax Namespace


ISyntaxParser.GetContentDividers Method

ISyntaxParserGetContentDividers Method
When implemented by a class, gets list of content dividers.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetContentDividers(
    IList<int> dividers
)
Function GetContentDividers (
    dividers As IList(Of Integer)
) As Integer
int GetContentDividers(
    IList<int>^ dividers
)
abstract GetContentDividers :
        dividers : IList<int> -> int

Parameters

dividers
Type: System.Collections.GenericIListInt32

Return Value

Type: Int32
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetMultiLineComment Method

ISyntaxParserGetMultiLineComment Method
Overload List
 | Name | Description
Public method | GetMultiLineComment(String, String) | When implemented by a class, gets the start and symbols multi-line comment.
Public method | GetMultiLineComment(Point, String, String) | When implemented by a class, gets the start and symbols multi-line comment.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetMultiLineComment Method (String, String)

ISyntaxParserGetMultiLineComment Method (String, String)
When implemented by a class, gets the start and symbols multi-line comment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetMultiLineComment(
    out string start,
    out string end
)
Function GetMultiLineComment (
    <OutAttribute> ByRef start As String,
    <OutAttribute> ByRef end As String
) As Boolean
bool GetMultiLineComment(
    [OutAttribute] String^% start,
    [OutAttribute] String^% end
)
abstract GetMultiLineComment :
        start : string byref *
        end : string byref -> bool

Parameters

start
Type: SystemString
Start symbol of multi-line comment.
end
Type: SystemString
End symbol of multi-line comment.

Return Value

Type: Boolean
True if parser supports multi-line comment; otherwise false.
See Also

Reference

ISyntaxParser Interface
GetMultiLineComment Overload
Alternet.Syntax Namespace


ISyntaxParser.GetMultiLineComment Method (Point, String, String)

ISyntaxParserGetMultiLineComment Method (Point, String, String)
When implemented by a class, gets the start and symbols multi-line comment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetMultiLineComment(
    Point pos,
    out string start,
    out string end
)
Function GetMultiLineComment (
    pos As Point,
    <OutAttribute> ByRef start As String,
    <OutAttribute> ByRef end As String
) As Boolean
bool GetMultiLineComment(
    Point pos,
    [OutAttribute] String^% start,
    [OutAttribute] String^% end
)
abstract GetMultiLineComment :
        pos : Point *
        start : string byref *
        end : string byref -> bool

Parameters

pos
Type: System.DrawingPoint
Position to check.
start
Type: SystemString
Start symbol of multi-line comment.
end
Type: SystemString
End symbol of multi-line comment.

Return Value

Type: Boolean
True if parser supports multi-line comment; otherwise false.
See Also

Reference

ISyntaxParser Interface
GetMultiLineComment Overload
Alternet.Syntax Namespace


ISyntaxParser.GetNodeAt Method

ISyntaxParserGetNodeAt Method
When implemented by a class, gets ISyntaxNode that corresponds to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode GetNodeAt(
    Point position
)
Function GetNodeAt (
    position As Point
) As ISyntaxNode
ISyntaxNode^ GetNodeAt(
    Point position
)
abstract GetNodeAt :
        position : Point -> ISyntaxNode

Parameters

position
Type: System.DrawingPoint
Position to find node.

Return Value

Type: ISyntaxNode
ISyntaxNode at specified position.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetRangeAt Method

ISyntaxParserGetRangeAt Method
Overload List
 | Name | Description
Public method | GetRangeAt(Point) | When implemented by a class, gets IRange that corresponds to the specified position.
Public method | GetRangeAt(Point, IListIRange) | When implemented by a class, gets IRange list that corresponds to the specified position.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetRangeAt Method (Point)

ISyntaxParserGetRangeAt Method (Point)
When implemented by a class, gets IRange that corresponds to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange GetRangeAt(
    Point position
)
Function GetRangeAt (
    position As Point
) As IRange
IRange^ GetRangeAt(
    Point position
)
abstract GetRangeAt :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.

Return Value

Type: IRange
IRange at specified position.
See Also

Reference

ISyntaxParser Interface
GetRangeAt Overload
Alternet.Syntax Namespace


ISyntaxParser.GetRangeAt Method (Point, IList(IRange))

ISyntaxParserGetRangeAt Method (Point, IListIRange)
When implemented by a class, gets IRange list that corresponds to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange GetRangeAt(
    Point position,
    IList<IRange> ranges
)
Function GetRangeAt (
    position As Point,
    ranges As IList(Of IRange)
) As IRange
IRange^ GetRangeAt(
    Point position,
    IList<IRange^>^ ranges
)
abstract GetRangeAt :
        position : Point *
        ranges : IList<IRange> -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.
ranges
Type: System.Collections.GenericIListIRange
List of begin/end ranges at the given position.

Return Value

Type: IRange
IRange at specified position.
See Also

Reference

ISyntaxParser Interface
GetRangeAt Overload
Alternet.Syntax Namespace


ISyntaxParser.GetSingleLineComment Method

ISyntaxParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | When implemented by a class, gets the string that represents start symbol of single line comment.
Public method | GetSingleLineComment(Point) | When implemented by a class, gets the string that represents start symbol of single line comment.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetSingleLineComment Method

ISyntaxParserGetSingleLineComment Method
When implemented by a class, gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetSingleLineComment()
Function GetSingleLineComment As String
String^ GetSingleLineComment()
abstract GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.
See Also

Reference

ISyntaxParser Interface
GetSingleLineComment Overload
Alternet.Syntax Namespace


ISyntaxParser.GetSingleLineComment Method (Point)

ISyntaxParserGetSingleLineComment Method (Point)
When implemented by a class, gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetSingleLineComment(
    Point pos
)
Function GetSingleLineComment (
    pos As Point
) As String
String^ GetSingleLineComment(
    Point pos
)
abstract GetSingleLineComment :
        pos : Point -> string

Parameters

pos
Type: System.DrawingPoint
Position to check.

Return Value

Type: String
Single line comment string.
See Also

Reference

ISyntaxParser Interface
GetSingleLineComment Overload
Alternet.Syntax Namespace


ISyntaxParser.GetSmartIndent Method

ISyntaxParserGetSmartIndent Method
Overload List
 | Name | Description
Public method | GetSmartIndent(Int32, Boolean) | When implemented by a class, returns indentation level of specified line.
Public method | GetSmartIndent(Int32, Boolean, Boolean) | When implemented by a class, returns indentation level of specified line.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetSmartIndent Method (Int32, Boolean)

ISyntaxParserGetSmartIndent Method (Int32, Boolean)
When implemented by a class, returns indentation level of specified line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetSmartIndent(
    int index,
    bool autoIndent
)
Function GetSmartIndent (
    index As Integer,
    autoIndent As Boolean
) As Integer
int GetSmartIndent(
    int index,
    bool autoIndent
)
abstract GetSmartIndent :
        index : int *
        autoIndent : bool -> int

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.

Return Value

Type: Int32
Indentation level at line specified by index.
See Also

Reference

ISyntaxParser Interface
GetSmartIndent Overload
Alternet.Syntax Namespace


ISyntaxParser.GetSmartIndent Method (Int32, Boolean, Boolean)

ISyntaxParserGetSmartIndent Method (Int32, Boolean, Boolean)
When implemented by a class, returns indentation level of specified line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetSmartIndent(
    int index,
    bool autoIndent,
    out bool actualPosition
)
Function GetSmartIndent (
    index As Integer,
    autoIndent As Boolean,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
int GetSmartIndent(
    int index,
    bool autoIndent,
    [OutAttribute] bool% actualPosition
)
abstract GetSmartIndent :
        index : int *
        autoIndent : bool *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at line specified by index.
See Also

Reference

ISyntaxParser Interface
GetSmartIndent Overload
Alternet.Syntax Namespace


ISyntaxParser.GetSmartIndentString Method

ISyntaxParserGetSmartIndentString Method
When implemented by a class, returns indentation string for specified line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
Function GetSmartIndentString (
    index As Integer,
    autoIndent As Boolean,
    useSpaces As Boolean,
    spacesInTab As Integer
) As String
String^ GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
abstract GetSmartIndentString :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.

Return Value

Type: String
Indentation text at line specified by index.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetStructureGuideLines Method

ISyntaxParserGetStructureGuideLines Method
When implemented by a class, gets list of guide lines.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetStructureGuideLines(
    IList<IRange> guideLines
)
Function GetStructureGuideLines (
    guideLines As IList(Of IRange)
) As Integer
int GetStructureGuideLines(
    IList<IRange^>^ guideLines
)
abstract GetStructureGuideLines :
        guideLines : IList<IRange> -> int

Parameters

guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.GetSyntaxErrors Method

ISyntaxParserGetSyntaxErrors Method
When implemented by a class, retrieves all syntax errors that ISyntaxParser found while analyzing the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetSyntaxErrors(
    IList<ISyntaxError> errors
)
Function GetSyntaxErrors (
    errors As IList(Of ISyntaxError)
) As Integer
int GetSyntaxErrors(
    IList<ISyntaxError^>^ errors
)
abstract GetSyntaxErrors :
        errors : IList<ISyntaxError> -> int

Parameters

errors
Type: System.Collections.GenericIListISyntaxError
Retrieves a collection of syntax error.

Return Value

Type: Int32
Number of syntax errors that are found.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.IsCodeCompletionChar Method

ISyntaxParserIsCodeCompletionChar Method
When implemented by a class, returns boolean value indicating that given character initializes a code completion procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
)
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
Given character.
style
Type: SystemByte
Specifies text style at cursor.
interval
Type: SystemInt32
Represents the delay, in milliseconds before displaying code completion window.

Return Value

Type: Boolean
True if given character is code completion character; otherwise false.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.IsDeclaration Method

ISyntaxParserIsDeclaration Method
When implemented by a class, indicates whether specified node represents declaration elements.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsDeclaration(
    ISyntaxNode node
)
Function IsDeclaration (
    node As ISyntaxNode
) As Boolean
bool IsDeclaration(
    ISyntaxNode^ node
)
abstract IsDeclaration :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: Boolean
True if specified node represents declaration element; otherwise false.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.OnTextChanged Method

ISyntaxParserOnTextChanged Method
When implemented by a class, responds to incremental change of the text in the editor.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnTextChanged(
    ITextUndo operation
)
Sub OnTextChanged (
    operation As ITextUndo
)
void OnTextChanged(
    ITextUndo^ operation
)
abstract OnTextChanged :
        operation : ITextUndo -> unit

Parameters

operation
Type: Alternet.SyntaxITextUndo
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.OnTextParsed Method

ISyntaxParserOnTextParsed Method
When implemented by a class, raises TextParsed event.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnTextParsed()
Sub OnTextParsed
void OnTextParsed()
abstract OnTextParsed : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.Outline Method

ISyntaxParserOutline Method
When implemented by a class, creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Outline(
    IList<IRange> ranges
)
Function Outline (
    ranges As IList(Of IRange)
) As Integer
int Outline(
    IList<IRange^>^ ranges
)
abstract Outline :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Retrieves IOutlineRange collection for outlined sections.

Return Value

Type: Int32
Number of outlined sections.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.PositionChanged Method

ISyntaxParserPositionChanged Method
When implemented by a class, changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.Prepare Method

ISyntaxParserPrepare Method
Overload List
 | Name | Description
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse.
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | When implemented by a class, sets lines to parse.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.Prepare Method (String, IStringList, PrepareReason)

ISyntaxParserPrepare Method (String, IStringList, PrepareReason)
When implemented by a class, sets lines to parse.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Prepare(
    string fileName,
    IStringList lines,
    PrepareReason reason = PrepareReason.None
)
Sub Prepare (
    fileName As String,
    lines As IStringList,
    Optional reason As PrepareReason = PrepareReason.None
)
void Prepare(
    String^ fileName,
    IStringList^ lines,
    PrepareReason reason = PrepareReason::None
)
abstract Prepare :
        fileName : string *
        lines : IStringList *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit

Parameters

fileName
Type: SystemString
Filename to parse
lines
Type: Alternet.SyntaxIStringList
Strings to parse
reason (Optional)
Type: Alternet.SyntaxPrepareReason
Reason for this method to be called.
See Also

Reference

ISyntaxParser Interface
Prepare Overload
Alternet.Syntax Namespace


ISyntaxParser.Prepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)

ISyntaxParserPrepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)
When implemented by a class, sets lines to parse.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Prepare(
    string fileName,
    IStringList lines,
    ISyntaxTree syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason.None
)
Sub Prepare (
    fileName As String,
    lines As IStringList,
    syntaxTree As ISyntaxTree,
    useThread As Boolean,
    Optional reason As PrepareReason = PrepareReason.None
)
void Prepare(
    String^ fileName,
    IStringList^ lines,
    ISyntaxTree^ syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason::None
)
abstract Prepare :
        fileName : string *
        lines : IStringList *
        syntaxTree : ISyntaxTree *
        useThread : bool *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit

Parameters

fileName
Type: SystemString
Filename to parse
lines
Type: Alternet.SyntaxIStringList
Strings to parse
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies current parser tree.
useThread
Type: SystemBoolean
Specifies whether parser should perform the task in the separate thread
reason (Optional)
Type: Alternet.SyntaxPrepareReason
Reason for this method to be called.
See Also

Reference

ISyntaxParser Interface
Prepare Overload
Alternet.Syntax Namespace


ISyntaxParser.ProcessAutoComplete Method

ISyntaxParserProcessAutoComplete Method
When implemented by a class, checks whether end-of-block code needs inserting.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessAutoComplete(
    string text,
    Point position,
    out string code
)
Function ProcessAutoComplete (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
bool ProcessAutoComplete(
    String^ text,
    Point position,
    [OutAttribute] String^% code
)
abstract ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies line text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if autocompletion of end-of-block needed; otherwise false.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ProcessSnippetBody Method

ISyntaxParserProcessSnippetBody Method
When implemented by a class, checks whether snippet body code needs inserting.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessSnippetBody(
    string text,
    Point position,
    out string code
)
Function ProcessSnippetBody (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
bool ProcessSnippetBody(
    String^ text,
    Point position,
    [OutAttribute] String^% code
)
abstract ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if snippet body code needed; otherwise false.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ReparseBlock Method

ISyntaxParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | When implemented by a class, reparses syntax block at specified position.
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ReparseBlock Method (Point)

ISyntaxParserReparseBlock Method (Point)
When implemented by a class, reparses syntax block at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReparseBlock(
    Point position
)
Function ReparseBlock (
    position As Point
) As Boolean
bool ReparseBlock(
    Point position
)
abstract ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxParser Interface
ReparseBlock Overload
Alternet.Syntax Namespace


ISyntaxParser.ReparseBlock Method (Point, String, ISyntaxNode, CodeCompletionType)

ISyntaxParserReparseBlock Method (Point, String, ISyntaxNode, CodeCompletionType)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReparseBlock(
    ref Point position,
    string text,
    out ISyntaxNode node,
    CodeCompletionType completionType
)
Function ReparseBlock (
    ByRef position As Point,
    text As String,
    <OutAttribute> ByRef node As ISyntaxNode,
    completionType As CodeCompletionType
) As Boolean
bool ReparseBlock(
    Point% position,
    String^ text,
    [OutAttribute] ISyntaxNode^% node,
    CodeCompletionType completionType
)
abstract ReparseBlock :
        position : Point byref *
        text : string *
        node : ISyntaxNode byref *
        completionType : CodeCompletionType -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.
text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Returns node corresponding to the block being reparsed.
completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion reason.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxParser Interface
ReparseBlock Overload
Alternet.Syntax Namespace


ISyntaxParser.ReparseText Method

ISyntaxParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | When implemented by a class, reparses entire text.
Public method | ReparseText(Boolean) | When implemented by a class, reparses entire text. Specifies whether parser should perform the task in the separate thread
Public method | ReparseText(Boolean, Int32, Int32) | When implemented by a class, reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ReparseText Method

ISyntaxParserReparseText Method
When implemented by a class, reparses entire text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReparseText()
Sub ReparseText
void ReparseText()
abstract ReparseText : unit -> unit
See Also

Reference

ISyntaxParser Interface
ReparseText Overload
Alternet.Syntax Namespace


ISyntaxParser.ReparseText Method (Boolean)

ISyntaxParserReparseText Method (Boolean)
When implemented by a class, reparses entire text. Specifies whether parser should perform the task in the separate thread

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReparseText(
    bool useThread
)
Sub ReparseText (
    useThread As Boolean
)
void ReparseText(
    bool useThread
)
abstract ReparseText :
        useThread : bool -> unit

Parameters

useThread
Type: SystemBoolean
See Also

Reference

ISyntaxParser Interface
ReparseText Overload
Alternet.Syntax Namespace


ISyntaxParser.ReparseText Method (Boolean, Int32, Int32)

ISyntaxParserReparseText Method (Boolean, Int32, Int32)
When implemented by a class, reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReparseText(
    bool useThread,
    int first,
    int last
)
Sub ReparseText (
    useThread As Boolean,
    first As Integer,
    last As Integer
)
void ReparseText(
    bool useThread,
    int first,
    int last
)
abstract ReparseText :
        useThread : bool *
        first : int *
        last : int -> unit

Parameters

useThread
Type: SystemBoolean
first
Type: SystemInt32
last
Type: SystemInt32
See Also

Reference

ISyntaxParser Interface
ReparseText Overload
Alternet.Syntax Namespace


ISyntaxParser.ResetAutoIndentChars Method

ISyntaxParserResetAutoIndentChars Method
When implemented by a class, resets AutoIndentChars to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetAutoIndentChars()
Sub ResetAutoIndentChars
void ResetAutoIndentChars()
abstract ResetAutoIndentChars : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ResetCodeCompletionChars Method

ISyntaxParserResetCodeCompletionChars Method
When implemented by a class, resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetCodeCompletionChars()
Sub ResetCodeCompletionChars
void ResetCodeCompletionChars()
abstract ResetCodeCompletionChars : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ResetCodeCompletionStopChars Method

ISyntaxParserResetCodeCompletionStopChars Method
When implemented by a class, resets CodeCompletionStopChars to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetCodeCompletionStopChars()
Sub ResetCodeCompletionStopChars
void ResetCodeCompletionStopChars()
abstract ResetCodeCompletionStopChars : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ResetOptions Method

ISyntaxParserResetOptions Method
When implemented by a class, resets Options to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetOptions()
Sub ResetOptions
void ResetOptions()
abstract ResetOptions : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ResetParseInterval Method

ISyntaxParserResetParseInterval Method
When implemented by a class, resets ParseInterval to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetParseInterval()
Sub ResetParseInterval
void ResetParseInterval()
abstract ResetParseInterval : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ResetSmartFormatChars Method

ISyntaxParserResetSmartFormatChars Method
When implemented by a class, resets SmartFormatChars to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetSmartFormatChars()
Sub ResetSmartFormatChars
void ResetSmartFormatChars()
abstract ResetSmartFormatChars : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.RestoreSyntaxTree Method

ISyntaxParserRestoreSyntaxTree Method
When implemented by a class, restores syntax tree, stored by SaveSyntaxTree method.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RestoreSyntaxTree()
Sub RestoreSyntaxTree
void RestoreSyntaxTree()
abstract RestoreSyntaxTree : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SaveSyntaxTree Method

ISyntaxParserSaveSyntaxTree Method
When implemented by a class, saves current syntax tree.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SaveSyntaxTree()
Sub SaveSyntaxTree
void SaveSyntaxTree()
abstract SaveSyntaxTree : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SmartFormat Method

ISyntaxParserSmartFormat Method
Overload List
 | Name | Description
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | When implemented by a class, formats block of text according to the parser rules.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | When implemented by a class, formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList of changes.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SmartFormat Method (Point, Boolean, Int32, ITextUndoList, String)

ISyntaxParserSmartFormat Method (Point, Boolean, Int32, ITextUndoList, String)
When implemented by a class, formats block of text according to the parser rules.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SmartFormat(
    ref Point pos,
    bool useSpaces,
    int spacesInTab,
    ITextUndoList operations,
    string key = ""
)
Function SmartFormat (
    ByRef pos As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    operations As ITextUndoList,
    Optional key As String = ""
) As Boolean
bool SmartFormat(
    Point% pos,
    bool useSpaces,
    int spacesInTab,
    ITextUndoList^ operations,
    String^ key = L""
)
abstract SmartFormat :
        pos : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        operations : ITextUndoList *
        ?key : string
(* Defaults:
        let _key = defaultArg key ""
*)
-> bool

Parameters

pos
Type: System.DrawingPoint
Position of the text.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.
operations
Type: Alternet.SyntaxITextUndoList
List of changes.
key (Optional)
Type: SystemString
Keystroke being typed.

Return Value

Type: Boolean
See Also

Reference

ISyntaxParser Interface
SmartFormat Overload
Alternet.Syntax Namespace


ISyntaxParser.SmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)

ISyntaxParserSmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)
When implemented by a class, formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList of changes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SmartFormat(
    ref Point start,
    ref Point end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList operations
)
Function SmartFormat (
    ByRef start As Point,
    ByRef end As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    extended As Boolean,
    operations As ITextUndoList
) As Boolean
bool SmartFormat(
    Point% start,
    Point% end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList^ operations
)
abstract SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool

Parameters

start
Type: System.DrawingPoint
end
Type: System.DrawingPoint
useSpaces
Type: SystemBoolean
spacesInTab
Type: SystemInt32
extended
Type: SystemBoolean
operations
Type: Alternet.SyntaxITextUndoList

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ISyntaxParser Interface
SmartFormat Overload
Alternet.Syntax Namespace


ISyntaxParser.SmartFormatLine Method

ISyntaxParserSmartFormatLine Method
Overload List
 | Name | Description
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | When implemented by a class, formats line according to the parser rules.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | When implemented by a class, formats line according to the parser rules.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList)

ISyntaxParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList)
When implemented by a class, formats line according to the parser rules.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations
)
Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList
) As Integer
int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations
)
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.

Return Value

Type: Int32
Indentation level at given line.
See Also

Reference

ISyntaxParser Interface
SmartFormatLine Overload
Alternet.Syntax Namespace


ISyntaxParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList, Boolean)

ISyntaxParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList, Boolean)
When implemented by a class, formats line according to the parser rules.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations,
    out bool actualPosition
)
Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations,
    [OutAttribute] bool% actualPosition
)
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at given line.
See Also

Reference

ISyntaxParser Interface
SmartFormatLine Overload
Alternet.Syntax Namespace


ISyntaxParser.StartParsing Method

ISyntaxParserStartParsing Method
When implemented by a class, prepares parser to parse the specified range of the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StartParsing(
    string fileName,
    int first,
    int last
)
Sub StartParsing (
    fileName As String,
    first As Integer,
    last As Integer
)
void StartParsing(
    String^ fileName,
    int first,
    int last
)
abstract StartParsing :
        fileName : string *
        first : int *
        last : int -> unit

Parameters

fileName
Type: SystemString
Filename to parse
first
Type: SystemInt32
Specifies first changed line in the source text.
last
Type: SystemInt32
Specifies last changed line in the source text.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.StopParsing Method

ISyntaxParserStopParsing Method
When implemented by a class, aborts parsing process.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void StopParsing()
Sub StopParsing
void StopParsing()
abstract StopParsing : unit -> unit
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SupportsAsyncParsing Method

ISyntaxParserSupportsAsyncParsing Method
When implemented by a class, indicates whether parser supports async parsing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SupportsAsyncParsing()
Function SupportsAsyncParsing As Boolean
bool SupportsAsyncParsing()
abstract SupportsAsyncParsing : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SupportsCodeCompletionFiltering Method

ISyntaxParserSupportsCodeCompletionFiltering Method
When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SupportsCodeCompletionFiltering(
    CodeCompletionType completionType
)
Function SupportsCodeCompletionFiltering (
    completionType As CodeCompletionType
) As Boolean
bool SupportsCodeCompletionFiltering(
    CodeCompletionType completionType
)
abstract SupportsCodeCompletionFiltering :
        completionType : CodeCompletionType -> bool

Parameters

completionType
Type: Alternet.SyntaxCodeCompletionType
Given code completion type.

Return Value

Type: Boolean
True if code completion output can be filtered; otherwise false.
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SupportsContentDividers Method

ISyntaxParserSupportsContentDividers Method
When implemented by a class, indicates whether content dividers are supported.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SupportsContentDividers()
Function SupportsContentDividers As Boolean
bool SupportsContentDividers()
abstract SupportsContentDividers : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SupportsTextChanges Method

ISyntaxParserSupportsTextChanges Method
When implemented by a class, indicates whether parser supports incremental text changes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SupportsTextChanges()
Function SupportsTextChanges As Boolean
bool SupportsTextChanges()
abstract SupportsTextChanges : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser Properties

ISyntaxParser Properties

The ISyntaxParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | When implemented by a class, gets or sets boolean value indicating whether parsing process has been aborted.
Public property | AutoIndentChars | When implemented by a class, gets or sets a collection of characters that initializes an indentation procedure when typing.
Public property | CaseSensitive | When implemented by a class, gets or sets a boolean value that indicates whether ISyntaxParser should perform case-sensitive analysis if its content.
Public property | CodeCompletionChars | When implemented by a class, gets or sets a collection of characters that initializes a code completion procedure when typing.
Public property | CodeCompletionStopChars | When implemented by a class, gets or sets a collection of characters that finalizes a code completion procedure when typing.
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser.
Public property | CompletionRepository | When implemented by a class, gets or sets an ICodeCompletionRepository that holds methods for code completion purposes.
Public property | CurrentPosition | When implemented by a class, represents position of current character within the current line. (Inherited from IParser.)
Public property | DefaultState | When implemented by a class, gets or sets default state of the ILexer. (Inherited from ILexer.)
Public property | Delimiters | When implemented by a class, gets or sets a collection of characters representing delimiters
Public property | Eof | When implemented by a class, indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from IParser.)
Public property | ExpressionEvaluator | When implemented by a class, gets or sets an IExpressionEvaluator instance using to evaluate conditional defines.
Public property | FileName | When implemented by a class, gets or sets file name of the file being parsed.
Public property | Lines | When implemented by a class, gets or sets a list of string to parse represented as string array. (Inherited from IParser.)
Public property | Options | When implemented by a class, gets or sets a flags determining syntax parsing and formatting behavior.
Public property | ParseInterval | When implemented by a class, specifies delay reparsing should trigger after any change in the editor.
Public property | Scheme | When implemented by a class, gets or sets list of rules for lexical analysis. (Inherited from ILexer.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of ILexer. (Inherited from ILexer.)
Public property | SmartFormatChars | When implemented by a class, gets or sets a collection of characters that initializes a smart formatting procedure when typing.
Public property | State | When implemented by a class, represents current IParser state. (Inherited from IParser.)
Public property | Strings | When implemented by a class, gets or sets a list of strings to parse. (Inherited from IParser.)
Public property | SupportsThread | When implemented by a class, gets boolean value indicating whether parser supports working in thread.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed.
Public property | Token | When implemented by a class, represents token (index of style in the class style collection) related to the current position in the parsed text. (Inherited from IParser.)
Public property | TokenPosition | When implemented by a class, represents start position of the current token. (Inherited from IParser.)
Public property | TokenString | When implemented by a class, represents text of the current syntax token. (Inherited from IParser.)
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | UseScheme | When implemented by a class, gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.Aborted Property

ISyntaxParserAborted Property
When implemented by a class, gets or sets boolean value indicating whether parsing process has been aborted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Aborted { get; set; }
Property Aborted As Boolean
    Get
    Set
property bool Aborted {
    bool get ();
    void set (bool value);
}
abstract Aborted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.AutoIndentChars Property

ISyntaxParserAutoIndentChars Property
When implemented by a class, gets or sets a collection of characters that initializes an indentation procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] AutoIndentChars { get; set; }
Property AutoIndentChars As Char()
    Get
    Set
property array<wchar_t>^ AutoIndentChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract AutoIndentChars : char[] with get, set

Property Value

Type: Char
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.CaseSensitive Property

ISyntaxParserCaseSensitive Property
When implemented by a class, gets or sets a boolean value that indicates whether ISyntaxParser should perform case-sensitive analysis if its content.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CaseSensitive { get; }
ReadOnly Property CaseSensitive As Boolean
    Get
property bool CaseSensitive {
    bool get ();
}
abstract CaseSensitive : bool with get

Property Value

Type: Boolean
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.CodeCompletionChars Property

ISyntaxParserCodeCompletionChars Property
When implemented by a class, gets or sets a collection of characters that initializes a code completion procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] CodeCompletionChars { get; set; }
Property CodeCompletionChars As Char()
    Get
    Set
property array<wchar_t>^ CodeCompletionChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract CodeCompletionChars : char[] with get, set

Property Value

Type: Char
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.CodeCompletionStopChars Property

ISyntaxParserCodeCompletionStopChars Property
When implemented by a class, gets or sets a collection of characters that finalizes a code completion procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] CodeCompletionStopChars { get; set; }
Property CodeCompletionStopChars As Char()
    Get
    Set
property array<wchar_t>^ CodeCompletionStopChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract CodeCompletionStopChars : char[] with get, set

Property Value

Type: Char
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.CodeSnippets Property

ISyntaxParserCodeSnippets Property
When implemented by a class, returns code snippets for the given parser.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetsProvider CodeSnippets { get; }
ReadOnly Property CodeSnippets As ICodeSnippetsProvider
    Get
property ICodeSnippetsProvider^ CodeSnippets {
    ICodeSnippetsProvider^ get ();
}
abstract CodeSnippets : ICodeSnippetsProvider with get

Property Value

Type: ICodeSnippetsProvider
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.CompletionRepository Property

ISyntaxParserCompletionRepository Property
When implemented by a class, gets or sets an ICodeCompletionRepository that holds methods for code completion purposes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionRepository CompletionRepository { get; set; }
Property CompletionRepository As ICodeCompletionRepository
    Get
    Set
property ICodeCompletionRepository^ CompletionRepository {
    ICodeCompletionRepository^ get ();
    void set (ICodeCompletionRepository^ value);
}
abstract CompletionRepository : ICodeCompletionRepository with get, set

Property Value

Type: ICodeCompletionRepository
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.Delimiters Property

ISyntaxParserDelimiters Property
When implemented by a class, gets or sets a collection of characters representing delimiters

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] Delimiters { get; set; }
Property Delimiters As Char()
    Get
    Set
property array<wchar_t>^ Delimiters {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract Delimiters : char[] with get, set

Property Value

Type: Char
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ExpressionEvaluator Property

ISyntaxParserExpressionEvaluator Property
When implemented by a class, gets or sets an IExpressionEvaluator instance using to evaluate conditional defines.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IExpressionEvaluator ExpressionEvaluator { get; set; }
Property ExpressionEvaluator As IExpressionEvaluator
    Get
    Set
property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get ();
    void set (IExpressionEvaluator^ value);
}
abstract ExpressionEvaluator : IExpressionEvaluator with get, set

Property Value

Type: IExpressionEvaluator
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.FileName Property

ISyntaxParserFileName Property
When implemented by a class, gets or sets file name of the file being parsed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.Options Property

ISyntaxParserOptions Property
When implemented by a class, gets or sets a flags determining syntax parsing and formatting behavior.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SyntaxOptions Options { get; set; }
Property Options As SyntaxOptions
    Get
    Set
property SyntaxOptions Options {
    SyntaxOptions get ();
    void set (SyntaxOptions value);
}
abstract Options : SyntaxOptions with get, set

Property Value

Type: SyntaxOptions
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.ParseInterval Property

ISyntaxParserParseInterval Property
When implemented by a class, specifies delay reparsing should trigger after any change in the editor.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ParseInterval { get; set; }
Property ParseInterval As Integer
    Get
    Set
property int ParseInterval {
    int get ();
    void set (int value);
}
abstract ParseInterval : int with get, set

Property Value

Type: Int32
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SmartFormatChars Property

ISyntaxParserSmartFormatChars Property
When implemented by a class, gets or sets a collection of characters that initializes a smart formatting procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
char[] SmartFormatChars { get; set; }
Property SmartFormatChars As Char()
    Get
    Set
property array<wchar_t>^ SmartFormatChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract SmartFormatChars : char[] with get, set

Property Value

Type: Char
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SupportsThread Property

ISyntaxParserSupportsThread Property
When implemented by a class, gets boolean value indicating whether parser supports working in thread.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SupportsThread { get; }
ReadOnly Property SupportsThread As Boolean
    Get
property bool SupportsThread {
    bool get ();
}
abstract SupportsThread : bool with get

Property Value

Type: Boolean
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.SyntaxTree Property

ISyntaxParserSyntaxTree Property
When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxTree SyntaxTree { get; set; }
Property SyntaxTree As ISyntaxTree
    Get
    Set
property ISyntaxTree^ SyntaxTree {
    ISyntaxTree^ get ();
    void set (ISyntaxTree^ value);
}
abstract SyntaxTree : ISyntaxTree with get, set

Property Value

Type: ISyntaxTree
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.UseScheme Property

ISyntaxParserUseScheme Property
When implemented by a class, gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseScheme { get; set; }
Property UseScheme As Boolean
    Get
    Set
property bool UseScheme {
    bool get ();
    void set (bool value);
}
abstract UseScheme : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser Events

ISyntaxParser Events

The ISyntaxParser type exposes the following members.

Events
 | Name | Description
Public event | Parse | When implemented by a class, occurs when text line is parsed, allowing to modify colors/styles information for the parsed line. (Inherited from ILexer.)
Public event | TextReparsed | When implemented by a class, occurs when ISyntaxParser text content is fully parsed.
Top
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxParser.TextReparsed Event

ISyntaxParserTextReparsed Event
When implemented by a class, occurs when ISyntaxParser text content is fully parsed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler TextReparsed
Event TextReparsed As EventHandler
 event EventHandler^ TextReparsed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextReparsed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISyntaxParser Interface
Alternet.Syntax Namespace


ISyntaxTree Interface

ISyntaxTree Interface
Represents properties and methods to describe syntax structure of code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISyntaxTree
Public Interface ISyntaxTree
public interface class ISyntaxTree
type ISyntaxTree =  interface end

The ISyntaxTree type exposes the following members.

Methods
 | Name | Description
Public method | BlockDeleting | When implemented by a class, removes all nodes from the node collection which position in the specified rectangle.
Public method | Clear | When implemented by a class, removes all nodes from ISyntaxTree node collection.
Public method | FindNode | When implemented by a class, finds specified node.
Public method | FindNodes | When implemented by a class, locates all nodes matching search criteria.
Public method | Pop | When implemented by a class, removes last added node from the stack of nodes.
Public method | PositionChanged | When implemented by a class, changes positions of any syntax nodes and its elements located next to the specified position.
Public method | Push | When implemented by a class, adds specified node to the stack of nodes.
Public method | Sort | When implemented by a class, sorts all ISyntaxNode in the node collection using the specified comparer.
Top
Properties
 | Name | Description
Public property | Current | When implemented by a class, represents current ISyntaxNode in the node collection.
Public property | Root | When implemented by a class, represents root level ISyntaxNode in this syntax tree.
Top
See Also

Reference

Alternet.Syntax Namespace


ISyntaxTree Methods

ISyntaxTree Methods

The ISyntaxTree type exposes the following members.

Methods
 | Name | Description
Public method | BlockDeleting | When implemented by a class, removes all nodes from the node collection which position in the specified rectangle.
Public method | Clear | When implemented by a class, removes all nodes from ISyntaxTree node collection.
Public method | FindNode | When implemented by a class, finds specified node.
Public method | FindNodes | When implemented by a class, locates all nodes matching search criteria.
Public method | Pop | When implemented by a class, removes last added node from the stack of nodes.
Public method | PositionChanged | When implemented by a class, changes positions of any syntax nodes and its elements located next to the specified position.
Public method | Push | When implemented by a class, adds specified node to the stack of nodes.
Public method | Sort | When implemented by a class, sorts all ISyntaxNode in the node collection using the specified comparer.
Top
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.BlockDeleting Method

ISyntaxTreeBlockDeleting Method
When implemented by a class, removes all nodes from the node collection which position in the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void BlockDeleting(
    Rectangle rect
)
Sub BlockDeleting (
    rect As Rectangle
)
void BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove syntax nodes.
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.Clear Method

ISyntaxTreeClear Method
When implemented by a class, removes all nodes from ISyntaxTree node collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.FindNode Method

ISyntaxTreeFindNode Method
When implemented by a class, finds specified node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode FindNode(
    ISyntaxNode obj,
    IComparer<ISyntaxNode> comparer
)
Function FindNode (
    obj As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode)
) As ISyntaxNode
ISyntaxNode^ FindNode(
    ISyntaxNode^ obj,
    IComparer<ISyntaxNode^>^ comparer
)
abstract FindNode :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> -> ISyntaxNode

Parameters

obj
Type: Alternet.SyntaxISyntaxNode
Specifies node to locate.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted node collection.

Return Value

Type: ISyntaxNode
ISyntaxNode that is located.
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.FindNodes Method

ISyntaxTreeFindNodes Method
When implemented by a class, locates all nodes matching search criteria.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FindNodes(
    ISyntaxNode obj,
    IComparer<ISyntaxNode> comparer,
    ISyntaxNodes nodes
)
Sub FindNodes (
    obj As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode),
    nodes As ISyntaxNodes
)
void FindNodes(
    ISyntaxNode^ obj,
    IComparer<ISyntaxNode^>^ comparer,
    ISyntaxNodes^ nodes
)
abstract FindNodes :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> *
        nodes : ISyntaxNodes -> unit

Parameters

obj
Type: Alternet.SyntaxISyntaxNode
Specifies node to locate.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted node collection.
nodes
Type: Alternet.SyntaxISyntaxNodes
List of located nodes.
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.Pop Method

ISyntaxTreePop Method
When implemented by a class, removes last added node from the stack of nodes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode Pop()
Function Pop As ISyntaxNode
ISyntaxNode^ Pop()
abstract Pop : unit -> ISyntaxNode

Return Value

Type: ISyntaxNode
ISyntaxNode that is removed.
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.PositionChanged Method

ISyntaxTreePositionChanged Method
When implemented by a class, changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.Push Method

ISyntaxTreePush Method
When implemented by a class, adds specified node to the stack of nodes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Push(
    ISyntaxNode node
)
Sub Push (
    node As ISyntaxNode
)
void Push(
    ISyntaxNode^ node
)
abstract Push :
        node : ISyntaxNode -> unit

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to add.
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.Sort Method

ISyntaxTreeSort Method
When implemented by a class, sorts all ISyntaxNode in the node collection using the specified comparer.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Sort(
    IComparer<ISyntaxNode> comparer
)
Sub Sort (
    comparer As IComparer(Of ISyntaxNode)
)
void Sort(
    IComparer<ISyntaxNode^>^ comparer
)
abstract Sort :
        comparer : IComparer<ISyntaxNode> -> unit

Parameters

comparer
Type: System.Collections.GenericIComparerISyntaxNode
The IComparer implementation to use when comparing nodes.
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree Properties

ISyntaxTree Properties

The ISyntaxTree type exposes the following members.

Properties
 | Name | Description
Public property | Current | When implemented by a class, represents current ISyntaxNode in the node collection.
Public property | Root | When implemented by a class, represents root level ISyntaxNode in this syntax tree.
Top
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.Current Property

ISyntaxTreeCurrent Property
When implemented by a class, represents current ISyntaxNode in the node collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode Current { get; }
ReadOnly Property Current As ISyntaxNode
    Get
property ISyntaxNode^ Current {
    ISyntaxNode^ get ();
}
abstract Current : ISyntaxNode with get

Property Value

Type: ISyntaxNode
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ISyntaxTree.Root Property

ISyntaxTreeRoot Property
When implemented by a class, represents root level ISyntaxNode in this syntax tree.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode Root { get; set; }
Property Root As ISyntaxNode
    Get
    Set
property ISyntaxNode^ Root {
    ISyntaxNode^ get ();
    void set (ISyntaxNode^ value);
}
abstract Root : ISyntaxNode with get, set

Property Value

Type: ISyntaxNode
See Also

Reference

ISyntaxTree Interface
Alternet.Syntax Namespace


ItemState Enumeration

ItemState Enumeration
Defines state of the StrItem object, representing individual line in the Source. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ItemState
<FlagsAttribute>
Public Enumeration ItemState
[FlagsAttribute]
public enum class ItemState
[<FlagsAttribute>]
type ItemState
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Parsed | 1 | Specifies that StrItem object is already parsed.
ReadOnly | 2 | Specifies that StrItem object is read-only.
Hidden | 4 | Specifies that StrItem object is hidden.
See Also

Reference

Alternet.Syntax Namespace


ITextUndo Interface

ITextUndo Interface
Represents single change of the text fragment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextUndo
Public Interface ITextUndo
public interface class ITextUndo
type ITextUndo =  interface end

The ITextUndo type exposes the following members.

Properties
 | Name | Description
Public property | EndPt | When implemented by a class, represents end Point of the text fragment being changed.
Public property | FileName | When implemented by a class, specifies FieName where the change occurs.
Public property | Len | When implemented by a class, specifies length of the text fragment to delete.
Public property | Start | When implemented by a class, represents starting position of the text fragment being changed.
Public property | StartPt | When implemented by a class, represents starting Point of the text fragment being changed.
Public property | Text | When implemented by a class, specifies text fragment to insert.
Top
See Also

Reference

Alternet.Syntax Namespace


ITextUndo Properties

ITextUndo Properties

The ITextUndo type exposes the following members.

Properties
 | Name | Description
Public property | EndPt | When implemented by a class, represents end Point of the text fragment being changed.
Public property | FileName | When implemented by a class, specifies FieName where the change occurs.
Public property | Len | When implemented by a class, specifies length of the text fragment to delete.
Public property | Start | When implemented by a class, represents starting position of the text fragment being changed.
Public property | StartPt | When implemented by a class, represents starting Point of the text fragment being changed.
Public property | Text | When implemented by a class, specifies text fragment to insert.
Top
See Also

Reference

ITextUndo Interface
Alternet.Syntax Namespace


ITextUndo.EndPt Property

ITextUndoEndPt Property
When implemented by a class, represents end Point of the text fragment being changed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point EndPt { get; set; }
Property EndPt As Point
    Get
    Set
property Point EndPt {
    Point get ();
    void set (Point value);
}
abstract EndPt : Point with get, set

Property Value

Type: Point
See Also

Reference

ITextUndo Interface
Alternet.Syntax Namespace


ITextUndo.FileName Property

ITextUndoFileName Property
When implemented by a class, specifies FieName where the change occurs.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

ITextUndo Interface
Alternet.Syntax Namespace


ITextUndo.Len Property

ITextUndoLen Property
When implemented by a class, specifies length of the text fragment to delete.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Len { get; set; }
Property Len As Integer
    Get
    Set
property int Len {
    int get ();
    void set (int value);
}
abstract Len : int with get, set

Property Value

Type: Int32
See Also

Reference

ITextUndo Interface
Alternet.Syntax Namespace


ITextUndo.Start Property

ITextUndoStart Property
When implemented by a class, represents starting position of the text fragment being changed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Start { get; set; }
Property Start As Integer
    Get
    Set
property int Start {
    int get ();
    void set (int value);
}
abstract Start : int with get, set

Property Value

Type: Int32
See Also

Reference

ITextUndo Interface
Alternet.Syntax Namespace


ITextUndo.StartPt Property

ITextUndoStartPt Property
When implemented by a class, represents starting Point of the text fragment being changed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point StartPt { get; set; }
Property StartPt As Point
    Get
    Set
property Point StartPt {
    Point get ();
    void set (Point value);
}
abstract StartPt : Point with get, set

Property Value

Type: Point
See Also

Reference

ITextUndo Interface
Alternet.Syntax Namespace


ITextUndo.Text Property

ITextUndoText Property
When implemented by a class, specifies text fragment to insert.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

ITextUndo Interface
Alternet.Syntax Namespace


ITextUndoList Interface

ITextUndoList Interface
Represents collection containing list of ITextUndo objects.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITextUndoList : IList<ITextUndo>,
    ICollection<ITextUndo>, IEnumerable<ITextUndo>, IEnumerable
Public Interface ITextUndoList
    Inherits IList(Of ITextUndo), ICollection(Of ITextUndo),
    IEnumerable(Of ITextUndo), IEnumerable
public interface class ITextUndoList : IList<ITextUndo^>,
    ICollection<ITextUndo^>, IEnumerable<ITextUndo^>, IEnumerable
type ITextUndoList =
    interface
        interface IList<ITextUndo>
        interface ICollection<ITextUndo>
        interface IEnumerable<ITextUndo>
        interface IEnumerable
    end

The ITextUndoList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionITextUndo .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionITextUndo .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionITextUndo .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionITextUndo .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableITextUndo .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListITextUndo .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListITextUndo .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionITextUndo .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListITextUndo .)
Public method | Sort | Sorts the elements in the entire sort list using the specified comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfITextUndo | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstITextUndo | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementITextUndo, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionITextUndo .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionITextUndo .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListITextUndo .)
Top
See Also

Reference

Alternet.Syntax Namespace


ITextUndoList Methods

ITextUndoList Methods

The ITextUndoList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionITextUndo .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionITextUndo .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionITextUndo .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionITextUndo .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableITextUndo .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListITextUndo .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListITextUndo .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionITextUndo .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListITextUndo .)
Public method | Sort | Sorts the elements in the entire sort list using the specified comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfITextUndo | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstITextUndo | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementITextUndo, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ITextUndoList Interface
Alternet.Syntax Namespace


ITextUndoList.Sort Method

ITextUndoListSort Method
Sorts the elements in the entire sort list using the specified comparer.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Sort(
    IComparer<ITextUndo> comparer
)
Sub Sort (
    comparer As IComparer(Of ITextUndo)
)
void Sort(
    IComparer<ITextUndo^>^ comparer
)
abstract Sort :
        comparer : IComparer<ITextUndo> -> unit

Parameters

comparer
Type: System.Collections.GenericIComparerITextUndo
The IComparer implementation to use when comparing elements.
See Also

Reference

ITextUndoList Interface
Alternet.Syntax Namespace


ITextUndoList Properties

ITextUndoList Properties

The ITextUndoList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionITextUndo .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionITextUndo .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListITextUndo .)
Top
See Also

Reference

ITextUndoList Interface
Alternet.Syntax Namespace


MemberLookupEvent Delegate

MemberLookupEvent Delegate
Represents a method that will handle the CodeCompletionRepository.MemberLookup event.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void MemberLookupEvent(
    Object sender,
    MemberLookupEventArgs e
)
Public Delegate Sub MemberLookupEvent (
    sender As Object,
    e As MemberLookupEventArgs
)
public delegate void MemberLookupEvent(
    Object^ sender,
    MemberLookupEventArgs^ e
)
type MemberLookupEvent =
    delegate of
        sender : Object *
        e : MemberLookupEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxMemberLookupEventArgs
The MemberLookupEventArgs that contains the event data.
See Also

Reference

Alternet.Syntax Namespace


MemberLookupEventArgs Class

MemberLookupEventArgs Class
Provides data for the ICodeCompletionRepository.MemberLookup event, used to search for the specified member.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxMemberLookupEventArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MemberLookupEventArgs : EventArgs
Public Class MemberLookupEventArgs
    Inherits EventArgs
public ref class MemberLookupEventArgs : public EventArgs
type MemberLookupEventArgs =
    class
        inherit EventArgs
    end

The MemberLookupEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MemberLookupEventArgs | Initializes a new instance of the MemberLookupEventArgs class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Member | Represents an object containing members.
Public property | Name | The String containing the name of the member to get.
Public property | Result | An object representing the member with the specified name, if found; otherwise, a null reference.
Public property | Scope | Specifies the search constraints.
Top
See Also

Reference

Alternet.Syntax Namespace


MemberLookupEventArgs Constructor

MemberLookupEventArgs Constructor
Initializes a new instance of the MemberLookupEventArgs class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MemberLookupEventArgs(
    Object member,
    string name
)
Public Sub New (
    member As Object,
    name As String
)
public:
MemberLookupEventArgs(
    Object^ member,
    String^ name
)
new :
        member : Object *
        name : string -> MemberLookupEventArgs

Parameters

member
Type: SystemObject
Specifies Member property of this new instance.
name
Type: SystemString
Specifies Name property of this new instance.
See Also

Reference

MemberLookupEventArgs Class
Alternet.Syntax Namespace


MemberLookupEventArgs Methods

MemberLookupEventArgs Methods

The MemberLookupEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MemberLookupEventArgs Class
Alternet.Syntax Namespace


MemberLookupEventArgs Properties

MemberLookupEventArgs Properties

The MemberLookupEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Member | Represents an object containing members.
Public property | Name | The String containing the name of the member to get.
Public property | Result | An object representing the member with the specified name, if found; otherwise, a null reference.
Public property | Scope | Specifies the search constraints.
Top
See Also

Reference

MemberLookupEventArgs Class
Alternet.Syntax Namespace


MemberLookupEventArgs.Member Property

MemberLookupEventArgsMember Property
Represents an object containing members.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Member { get; set; }
Public Property Member As Object
    Get
    Set
public:
property Object^ Member {
    Object^ get ();
    void set (Object^ value);
}
member Member : Object with get, set

Property Value

Type: Object
See Also

Reference

MemberLookupEventArgs Class
Alternet.Syntax Namespace


MemberLookupEventArgs.Name Property

MemberLookupEventArgsName Property
The String containing the name of the member to get.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MemberLookupEventArgs Class
Alternet.Syntax Namespace


MemberLookupEventArgs.Result Property

MemberLookupEventArgsResult Property
An object representing the member with the specified name, if found; otherwise, a null reference.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Result { get; set; }
Public Property Result As Object
    Get
    Set
public:
property Object^ Result {
    Object^ get ();
    void set (Object^ value);
}
member Result : Object with get, set

Property Value

Type: Object
See Also

Reference

MemberLookupEventArgs Class
Alternet.Syntax Namespace


MemberLookupEventArgs.Scope Property

MemberLookupEventArgsScope Property
Specifies the search constraints.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionScope Scope { get; set; }
Public Property Scope As CodeCompletionScope
    Get
    Set
public:
property CodeCompletionScope Scope {
    CodeCompletionScope get ();
    void set (CodeCompletionScope value);
}
member Scope : CodeCompletionScope with get, set

Property Value

Type: CodeCompletionScope
See Also

Reference

MemberLookupEventArgs Class
Alternet.Syntax Namespace


OutlineRange Class

OutlineRange Class
Represents individual outlining section that can appear in the Edit control.
Inheritance Hierarchy
SystemObject
Alternet.CommonRange
Alternet.SyntaxOutlineRange

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OutlineRange : Range,
    IOutlineRange, IRange, ICloneable
Public Class OutlineRange
    Inherits Range
    Implements IOutlineRange, IRange, ICloneable
public ref class OutlineRange : public Range,
    IOutlineRange, IRange, ICloneable
type OutlineRange =
    class
        inherit Range
        interface IOutlineRange
        interface IRange
        interface ICloneable
    end

The OutlineRange type exposes the following members.

Constructors
 | Name | Description
Public method | OutlineRange | Initializes a new instance of the OutlineRange class with default settings.
Public method | OutlineRange(Point, Point, Int32, String) | Initializes a new instance of the OutlineRange class with specified parameters.
Public method | OutlineRange(Point, Point, Int32, String, Boolean) | Initializes a new instance of the OutlineRange class with specified parameters.
Top
Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from Range.)
Public method | Clone | Creates a new object that is a copy of the current IOutlineRange object. (Overrides RangeClone.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted. (Inherited from Range.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CanExpand |
Public property | DisplayText | Represents text substituting collapsed outline section if outline buttons are displayed.
Public property | EndPoint | Gets or sets end of IRange area. (Inherited from Range.)
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size. (Inherited from Range.)
Public property | Level | Represents level of outline nesting for the outline section.
Public property | Size | Gets or sets size of IRange area. (Inherited from Range.)
Public property | StartPoint | Gets or sets begin of IRange area. (Inherited from Range.)
Public property | Text | Represents text substituting collapsed outline section.
Public property | Visible | Gets or sets a value indicating whether outline section is visible (expanded).
Top
See Also

Reference

Alternet.Syntax Namespace


OutlineRange Constructor

OutlineRange Constructor
Overload List
 | Name | Description
Public method | OutlineRange | Initializes a new instance of the OutlineRange class with default settings.
Public method | OutlineRange(Point, Point, Int32, String) | Initializes a new instance of the OutlineRange class with specified parameters.
Public method | OutlineRange(Point, Point, Int32, String, Boolean) | Initializes a new instance of the OutlineRange class with specified parameters.
Top
See Also

Reference

OutlineRange Class
Alternet.Syntax Namespace


OutlineRange Constructor

OutlineRange Constructor
Initializes a new instance of the OutlineRange class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public OutlineRange()
Public Sub New
public:
OutlineRange()
new : unit -> OutlineRange
See Also

Reference

OutlineRange Class
OutlineRange Overload
Alternet.Syntax Namespace


OutlineRange Constructor (Point, Point, Int32, String)

OutlineRange Constructor (Point, Point, Int32, String)
Initializes a new instance of the OutlineRange class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public OutlineRange(
    Point start,
    Point end,
    int level,
    string text
)
Public Sub New (
    start As Point,
    end As Point,
    level As Integer,
    text As String
)
public:
OutlineRange(
    Point start,
    Point end,
    int level,
    String^ text
)
new :
        start : Point *
        end : Point *
        level : int *
        text : string -> OutlineRange

Parameters

start
Type: System.DrawingPoint
Specifies start position of the text to outline.
end
Type: System.DrawingPoint
Specifies end position of the text to outline.
level
Type: SystemInt32
Specifies level of outline nesting for new instance.
text
Type: SystemString
Specifies text substituting collapsed outline section.
See Also

Reference

OutlineRange Class
OutlineRange Overload
Alternet.Syntax Namespace


OutlineRange Constructor (Point, Point, Int32, String, Boolean)

OutlineRange Constructor (Point, Point, Int32, String, Boolean)
Initializes a new instance of the OutlineRange class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public OutlineRange(
    Point start,
    Point end,
    int level,
    string text,
    bool visible
)
Public Sub New (
    start As Point,
    end As Point,
    level As Integer,
    text As String,
    visible As Boolean
)
public:
OutlineRange(
    Point start,
    Point end,
    int level,
    String^ text,
    bool visible
)
new :
        start : Point *
        end : Point *
        level : int *
        text : string *
        visible : bool -> OutlineRange

Parameters

start
Type: System.DrawingPoint
Specifies start position of the text to outline.
end
Type: System.DrawingPoint
Specifies end position of the text to outline.
level
Type: SystemInt32
Specifies level of outline nesting for new instance.
text
Type: SystemString
Specifies text substituting collapsed outline section.
visible
Type: SystemBoolean
Indicates whether this new instance is visible (expanded).
See Also

Reference

OutlineRange Class
OutlineRange Overload
Alternet.Syntax Namespace


OutlineRange Methods

OutlineRange Methods

The OutlineRange type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies contents from another IRange object. (Inherited from Range.)
Public method | Clone | Creates a new object that is a copy of the current IOutlineRange object. (Overrides RangeClone.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShouldSerializeSize | Indicates whether the Size property should be persisted. (Inherited from Range.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OutlineRange Class
Alternet.Syntax Namespace


OutlineRange.Clone Method

OutlineRangeClone Method
Creates a new object that is a copy of the current IOutlineRange object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object Clone()
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of System.Object that is the memberwise clone of the current OutlineRange object.

Implements

ICloneableClone
ICloneableClone
See Also

Reference

OutlineRange Class
Alternet.Syntax Namespace


OutlineRange Properties

OutlineRange Properties

The OutlineRange type exposes the following members.

Properties
 | Name | Description
Public property | CanExpand |
Public property | DisplayText | Represents text substituting collapsed outline section if outline buttons are displayed.
Public property | EndPoint | Gets or sets end of IRange area. (Inherited from Range.)
Public property | IsEmpty | Gets boolean value indicating whether IRange has zero size. (Inherited from Range.)
Public property | Level | Represents level of outline nesting for the outline section.
Public property | Size | Gets or sets size of IRange area. (Inherited from Range.)
Public property | StartPoint | Gets or sets begin of IRange area. (Inherited from Range.)
Public property | Text | Represents text substituting collapsed outline section.
Public property | Visible | Gets or sets a value indicating whether outline section is visible (expanded).
Top
See Also

Reference

OutlineRange Class
Alternet.Syntax Namespace


OutlineRange.CanExpand Property

OutlineRangeCanExpand Property

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanExpand { get; }
Public Overridable ReadOnly Property CanExpand As Boolean
    Get
public:
virtual property bool CanExpand {
    bool get ();
}
abstract CanExpand : bool with get
override CanExpand : bool with get

Property Value

Type: Boolean

Implements

IOutlineRangeCanExpand
See Also

Reference

OutlineRange Class
Alternet.Syntax Namespace


OutlineRange.DisplayText Property

OutlineRangeDisplayText Property
Represents text substituting collapsed outline section if outline buttons are displayed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DisplayText { get; set; }
Public Overridable Property DisplayText As String
    Get
    Set
public:
virtual property String^ DisplayText {
    String^ get ();
    void set (String^ value);
}
abstract DisplayText : string with get, set
override DisplayText : string with get, set

Property Value

Type: String

Implements

IOutlineRangeDisplayText
See Also

Reference

OutlineRange Class
Alternet.Syntax Namespace


OutlineRange.Level Property

OutlineRangeLevel Property
Represents level of outline nesting for the outline section.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Level { get; set; }
Public Overridable Property Level As Integer
    Get
    Set
public:
virtual property int Level {
    int get ();
    void set (int value);
}
abstract Level : int with get, set
override Level : int with get, set

Property Value

Type: Int32

Implements

IOutlineRangeLevel
See Also

Reference

OutlineRange Class
Alternet.Syntax Namespace


OutlineRange.Text Property

OutlineRangeText Property
Represents text substituting collapsed outline section.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

IOutlineRangeText
See Also

Reference

OutlineRange Class
Alternet.Syntax Namespace


OutlineRange.Visible Property

OutlineRangeVisible Property
Gets or sets a value indicating whether outline section is visible (expanded).

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Visible { get; set; }
Public Overridable Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
abstract Visible : bool with get, set
override Visible : bool with get, set

Property Value

Type: Boolean

Implements

IOutlineRangeVisible
See Also

Reference

OutlineRange Class
Alternet.Syntax Namespace


Parser Class

Parser Class
Represents class that performs lexical analysis of specified text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Parser : Lexer, IParser,
    ILexer, INotify, IUpdate
<SerializableAttribute>
Public Class Parser
    Inherits Lexer
    Implements IParser, ILexer, INotify, IUpdate
[SerializableAttribute]
public ref class Parser : public Lexer,
    IParser, ILexer, INotify, IUpdate
[<SerializableAttribute>]
type Parser =
    class
        inherit Lexer
        interface IParser
        interface ILexer
        interface INotify
        interface IUpdate
    end

The Parser type exposes the following members.

Constructors
 | Name | Description
Public method | Parser | Initializes a new instance of the Parser class with default settings.
Public method | Parser(IContainer) | Initializes a new instance of the Parser class with default settings.
Top
Methods
 | Name | Description
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from Lexer.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from Lexer.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged.
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged.
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | Reset | Resets Parser to the start position.
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position.
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method.
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method.
Public method | SaveState | Saves current Parser state and position.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line.
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed.
Public property | Lines | Gets or sets a list of string to parse represented as string array.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | State | Represents current Parser state.
Public property | Strings | Gets or sets a list of strings to parse.
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text.
Public property | TokenPosition | Represents start position of the current token.
Public property | TokenString | Represents text of the current syntax token.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from Lexer.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Top
See Also

Reference

Alternet.Syntax Namespace


Parser Constructor

Parser Constructor
Overload List
 | Name | Description
Public method | Parser | Initializes a new instance of the Parser class with default settings.
Public method | Parser(IContainer) | Initializes a new instance of the Parser class with default settings.
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser Constructor

Parser Constructor
Initializes a new instance of the Parser class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parser()
Public Sub New
public:
Parser()
new : unit -> Parser
See Also

Reference

Parser Class
Parser Overload
Alternet.Syntax Namespace


Parser Constructor (IContainer)

Parser Constructor (IContainer)
Initializes a new instance of the Parser class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parser(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
Parser(
    IContainer^ container
)
new :
        container : IContainer -> Parser

Parameters

container
Type: System.ComponentModelIContainer
See Also

Reference

Parser Class
Parser Overload
Alternet.Syntax Namespace


Parser Methods

Parser Methods

The Parser type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from Lexer.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from Lexer.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged.
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged.
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | Reset | Resets Parser to the start position.
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position.
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method.
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method.
Public method | SaveState | Saves current Parser state and position.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.NextToken Method

ParserNextToken Method
Overload List
 | Name | Description
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.NextToken Method

ParserNextToken Method
Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int NextToken()
Public Overridable Function NextToken As Integer
public:
virtual int NextToken()
abstract NextToken : unit -> int
override NextToken : unit -> int

Return Value

Type: Int32
Token that corresponds to the next position.

Implements

IParserNextToken
See Also

Reference

Parser Class
NextToken Overload
Alternet.Syntax Namespace


Parser.NextToken Method (String)

ParserNextToken Method (String)
Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int NextToken(
    out string str
)
Public Overridable Function NextToken (
    <OutAttribute> ByRef str As String
) As Integer
public:
virtual int NextToken(
    [OutAttribute] String^% str
)
abstract NextToken :
        str : string byref -> int
override NextToken :
        str : string byref -> int

Parameters

str
Type: SystemString
Retrieves token string for the next token.

Return Value

Type: Int32
Token that corresponds to the next position.

Implements

IParserNextToken(String)
See Also

Reference

Parser Class
NextToken Overload
Alternet.Syntax Namespace


Parser.NextValidToken Method

ParserNextValidToken Method
Overload List
 | Name | Description
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.NextValidToken Method

ParserNextValidToken Method
Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int NextValidToken()
Public Overridable Function NextValidToken As Integer
public:
virtual int NextValidToken()
abstract NextValidToken : unit -> int
override NextValidToken : unit -> int

Return Value

Type: Int32
Next valid token.

Implements

IParserNextValidToken
See Also

Reference

Parser Class
NextValidToken Overload
Alternet.Syntax Namespace


Parser.NextValidToken Method (String)

ParserNextValidToken Method (String)
Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int NextValidToken(
    out string str
)
Public Overridable Function NextValidToken (
    <OutAttribute> ByRef str As String
) As Integer
public:
virtual int NextValidToken(
    [OutAttribute] String^% str
)
abstract NextValidToken :
        str : string byref -> int
override NextValidToken :
        str : string byref -> int

Parameters

str
Type: SystemString
Retrieves token string for the next valid token.

Return Value

Type: Int32
Next valid token.

Implements

IParserNextValidToken(String)
See Also

Reference

Parser Class
NextValidToken Overload
Alternet.Syntax Namespace


Parser.PeekToken Method

ParserPeekToken Method
Overload List
 | Name | Description
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged.
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged.
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.PeekToken Method

ParserPeekToken Method
Parses next portion of the text, remaining current position unchanged.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PeekToken()
Public Overridable Function PeekToken As Integer
public:
virtual int PeekToken()
abstract PeekToken : unit -> int
override PeekToken : unit -> int

Return Value

Type: Int32
Token that corresponds to the next position.

Implements

IParserPeekToken
See Also

Reference

Parser Class
PeekToken Overload
Alternet.Syntax Namespace


Parser.PeekToken Method (String)

ParserPeekToken Method (String)
Parses next portion of the text, remaining current position unchanged.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PeekToken(
    out string str
)
Public Overridable Function PeekToken (
    <OutAttribute> ByRef str As String
) As Integer
public:
virtual int PeekToken(
    [OutAttribute] String^% str
)
abstract PeekToken :
        str : string byref -> int
override PeekToken :
        str : string byref -> int

Parameters

str
Type: SystemString
Retrieves token string for the next token.

Return Value

Type: Int32
Token that corresponds to the next position.

Implements

IParserPeekToken(String)
See Also

Reference

Parser Class
PeekToken Overload
Alternet.Syntax Namespace


Parser.PeekValidToken Method

ParserPeekValidToken Method
Overload List
 | Name | Description
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.PeekValidToken Method

ParserPeekValidToken Method
Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PeekValidToken()
Public Overridable Function PeekValidToken As Integer
public:
virtual int PeekValidToken()
abstract PeekValidToken : unit -> int
override PeekValidToken : unit -> int

Return Value

Type: Int32
Next valid token.

Implements

IParserPeekValidToken
See Also

Reference

Parser Class
PeekValidToken Overload
Alternet.Syntax Namespace


Parser.PeekValidToken Method (String)

ParserPeekValidToken Method (String)
Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int PeekValidToken(
    out string str
)
Public Overridable Function PeekValidToken (
    <OutAttribute> ByRef str As String
) As Integer
public:
virtual int PeekValidToken(
    [OutAttribute] String^% str
)
abstract PeekValidToken :
        str : string byref -> int
override PeekValidToken :
        str : string byref -> int

Parameters

str
Type: SystemString
Retrieves token string for the next valid token.

Return Value

Type: Int32
Next valid token.

Implements

IParserPeekValidToken(String)
See Also

Reference

Parser Class
PeekValidToken Overload
Alternet.Syntax Namespace


Parser.Reset Method

ParserReset Method
Overload List
 | Name | Description
Public method | Reset | Resets Parser to the start position.
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position.
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.Reset Method

ParserReset Method
Resets Parser to the start position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
See Also

Reference

Parser Class
Reset Overload
Alternet.Syntax Namespace


Parser.Reset Method (Int32, Int32, Int32)

ParserReset Method (Int32, Int32, Int32)
Resets Parser to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset(
    int line,
    int pos,
    int state
)
Public Overridable Sub Reset (
    line As Integer,
    pos As Integer,
    state As Integer
)
public:
virtual void Reset(
    int line,
    int pos,
    int state
)
abstract Reset :
        line : int *
        pos : int *
        state : int -> unit
override Reset :
        line : int *
        pos : int *
        state : int -> unit

Parameters

line
Type: SystemInt32
Specifies new line index.
pos
Type: SystemInt32
Specifies new position of character within the line.
state
Type: SystemInt32
Specifies new State.

Implements

IParserReset(Int32, Int32, Int32)
See Also

Reference

Parser Class
Reset Overload
Alternet.Syntax Namespace


Parser.RestoreState Method

ParserRestoreState Method
Overload List
 | Name | Description
Public method | RestoreState | Restores Parser state and position stored by SaveState method.
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method.
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.RestoreState Method

ParserRestoreState Method
Restores Parser state and position stored by SaveState method.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RestoreState()
Public Overridable Sub RestoreState
public:
virtual void RestoreState()
abstract RestoreState : unit -> unit
override RestoreState : unit -> unit

Implements

IParserRestoreState
See Also

Reference

Parser Class
RestoreState Overload
Alternet.Syntax Namespace


Parser.RestoreState Method (Boolean)

ParserRestoreState Method (Boolean)
Restores Parser state and position stored by SaveState method.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RestoreState(
    bool restore
)
Public Overridable Sub RestoreState (
    restore As Boolean
)
public:
virtual void RestoreState(
    bool restore
)
abstract RestoreState :
        restore : bool -> unit
override RestoreState :
        restore : bool -> unit

Parameters

restore
Type: SystemBoolean
Indicates whether Parser should restore it's state to previous position or simply delete information about previously stored state.

Implements

IParserRestoreState(Boolean)
See Also

Reference

Parser Class
RestoreState Overload
Alternet.Syntax Namespace


Parser.SaveState Method

ParserSaveState Method
Saves current Parser state and position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveState()
Public Overridable Sub SaveState
public:
virtual void SaveState()
abstract SaveState : unit -> unit
override SaveState : unit -> unit

Implements

IParserSaveState
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser Properties

Parser Properties

The Parser type exposes the following members.

Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line.
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed.
Public property | Lines | Gets or sets a list of string to parse represented as string array.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | State | Represents current Parser state.
Public property | Strings | Gets or sets a list of strings to parse.
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text.
Public property | TokenPosition | Represents start position of the current token.
Public property | TokenString | Represents text of the current syntax token.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from Lexer.)
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.CurrentPosition Property

ParserCurrentPosition Property
Represents position of current character within the current line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point CurrentPosition { get; }
Public Overridable ReadOnly Property CurrentPosition As Point
    Get
public:
virtual property Point CurrentPosition {
    Point get ();
}
abstract CurrentPosition : Point with get
override CurrentPosition : Point with get

Property Value

Type: Point

Implements

IParserCurrentPosition
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.Eof Property

ParserEof Property
Indicates whether current position is out of the text, signaling that whole text is parsed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Eof { get; }
Public Overridable ReadOnly Property Eof As Boolean
    Get
public:
virtual property bool Eof {
    bool get ();
}
abstract Eof : bool with get
override Eof : bool with get

Property Value

Type: Boolean

Implements

IParserEof
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.Lines Property

ParserLines Property
Gets or sets a list of string to parse represented as string array.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string[] Lines { get; set; }
Public Overridable Property Lines As String()
    Get
    Set
public:
virtual property array<String^>^ Lines {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract Lines : string[] with get, set
override Lines : string[] with get, set

Property Value

Type: String

Implements

IParserLines
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.State Property

ParserState Property
Represents current Parser state.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int State { get; set; }
Public Overridable Property State As Integer
    Get
    Set
public:
virtual property int State {
    int get ();
    void set (int value);
}
abstract State : int with get, set
override State : int with get, set

Property Value

Type: Int32

Implements

IParserState
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.Strings Property

ParserStrings Property
Gets or sets a list of strings to parse.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IStringList Strings { get; set; }
Public Overridable Property Strings As IStringList
    Get
    Set
public:
virtual property IStringList^ Strings {
    IStringList^ get ();
    void set (IStringList^ value);
}
abstract Strings : IStringList with get, set
override Strings : IStringList with get, set

Property Value

Type: IStringList

Implements

IParserStrings
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.Token Property

ParserToken Property
Represents token (number of style in the class style collection) related to the current position in the parsed text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Token { get; set; }
Public Overridable Property Token As Integer
    Get
    Set
public:
virtual property int Token {
    int get ();
    void set (int value);
}
abstract Token : int with get, set
override Token : int with get, set

Property Value

Type: Int32

Implements

IParserToken
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.TokenPosition Property

ParserTokenPosition Property
Represents start position of the current token.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point TokenPosition { get; }
Public Overridable ReadOnly Property TokenPosition As Point
    Get
public:
virtual property Point TokenPosition {
    Point get ();
}
abstract TokenPosition : Point with get
override TokenPosition : Point with get

Property Value

Type: Point

Implements

IParserTokenPosition
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser.TokenString Property

ParserTokenString Property
Represents text of the current syntax token.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string TokenString { get; }
Public Overridable ReadOnly Property TokenString As String
    Get
public:
virtual property String^ TokenString {
    String^ get ();
}
abstract TokenString : string with get
override TokenString : string with get

Property Value

Type: String

Implements

IParserTokenString
See Also

Reference

Parser Class
Alternet.Syntax Namespace


Parser Events

Parser Events

The Parser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Top
See Also

Reference

Parser Class
Alternet.Syntax Namespace


PrepareReason Enumeration

PrepareReason Enumeration
Defines reason of underlying text in the parser being updated.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PrepareReason
Public Enumeration PrepareReason
public enum class PrepareReason
type PrepareReason
Members
Member name | Value | Description
None | 0 | Specifies that no reason was provided.
TextChanged | 1 | Specifies that text was changed.
SyntaxChanged | 2 | Specifies that syntax was changed.
CodeCompletion | 3 | Specifies that code completion is requested.
Outline | 4 | Specifies that code outlining is requested.
Indentation | 5 | Specifies that indentation is requested.
Formatting | 6 | Specifies that formatting was requested
See Also

Reference

Alternet.Syntax Namespace


ReadFormattedTextEvent Delegate

ReadFormattedTextEvent Delegate
Represents a method that will handle the FmtImport.ReadFormattedText event.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ReadFormattedTextEvent(
    Object sender,
    ReadFormattedTextEventArgs e
)
Public Delegate Sub ReadFormattedTextEvent (
    sender As Object,
    e As ReadFormattedTextEventArgs
)
public delegate void ReadFormattedTextEvent(
    Object^ sender,
    ReadFormattedTextEventArgs^ e
)
type ReadFormattedTextEvent =
    delegate of
        sender : Object *
        e : ReadFormattedTextEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxReadFormattedTextEventArgs
A ReadFormattedTextEventArgs that contains the event data.
See Also

Reference

Alternet.Syntax Namespace


ReadFormattedTextEventArgs Class

ReadFormattedTextEventArgs Class
Provides data for the FmtImport.ReadFormattedText handler.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxReadFormattedTextEventArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReadFormattedTextEventArgs : EventArgs
Public Class ReadFormattedTextEventArgs
    Inherits EventArgs
public ref class ReadFormattedTextEventArgs : public EventArgs
type ReadFormattedTextEventArgs =
    class
        inherit EventArgs
    end

The ReadFormattedTextEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ReadFormattedTextEventArgs | Initializes a new instance of the ReadFormattedTextEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BackColor | Background color of the text fragment.
Public property | FontStyle | FontStyle of the text fragment.
Public property | ForeColor | Foreground color of the text fragment.
Public property | Text | Starting the text fragment.
Public property | TextStyle | TextStyle of the text fragment.
Public property | UserData | User-defined data.
Top
See Also

Reference

Alternet.Syntax Namespace


ReadFormattedTextEventArgs Constructor

ReadFormattedTextEventArgs Constructor
Initializes a new instance of the ReadFormattedTextEventArgs class

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReadFormattedTextEventArgs()
Public Sub New
public:
ReadFormattedTextEventArgs()
new : unit -> ReadFormattedTextEventArgs
See Also

Reference

ReadFormattedTextEventArgs Class
Alternet.Syntax Namespace


ReadFormattedTextEventArgs Methods

ReadFormattedTextEventArgs Methods

The ReadFormattedTextEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReadFormattedTextEventArgs Class
Alternet.Syntax Namespace


ReadFormattedTextEventArgs Properties

ReadFormattedTextEventArgs Properties

The ReadFormattedTextEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Background color of the text fragment.
Public property | FontStyle | FontStyle of the text fragment.
Public property | ForeColor | Foreground color of the text fragment.
Public property | Text | Starting the text fragment.
Public property | TextStyle | TextStyle of the text fragment.
Public property | UserData | User-defined data.
Top
See Also

Reference

ReadFormattedTextEventArgs Class
Alternet.Syntax Namespace


ReadFormattedTextEventArgs.BackColor Property

ReadFormattedTextEventArgsBackColor Property
Background color of the text fragment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ReadFormattedTextEventArgs Class
Alternet.Syntax Namespace


ReadFormattedTextEventArgs.FontStyle Property

ReadFormattedTextEventArgsFontStyle Property
FontStyle of the text fragment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontStyle FontStyle { get; set; }
Public Property FontStyle As FontStyle
    Get
    Set
public:
property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
member FontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

ReadFormattedTextEventArgs Class
Alternet.Syntax Namespace


ReadFormattedTextEventArgs.ForeColor Property

ReadFormattedTextEventArgsForeColor Property
Foreground color of the text fragment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ReadFormattedTextEventArgs Class
Alternet.Syntax Namespace


ReadFormattedTextEventArgs.Text Property

ReadFormattedTextEventArgsText Property
Starting the text fragment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

ReadFormattedTextEventArgs Class
Alternet.Syntax Namespace


ReadFormattedTextEventArgs.TextStyle Property

ReadFormattedTextEventArgsTextStyle Property
TextStyle of the text fragment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextStyle TextStyle { get; set; }
Public Property TextStyle As TextStyle
    Get
    Set
public:
property TextStyle TextStyle {
    TextStyle get ();
    void set (TextStyle value);
}
member TextStyle : TextStyle with get, set

Property Value

Type: TextStyle
See Also

Reference

ReadFormattedTextEventArgs Class
Alternet.Syntax Namespace


ReadFormattedTextEventArgs.UserData Property

ReadFormattedTextEventArgsUserData Property
User-defined data.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object UserData { get; set; }
Public Property UserData As Object
    Get
    Set
public:
property Object^ UserData {
    Object^ get ();
    void set (Object^ value);
}
member UserData : Object with get, set

Property Value

Type: Object
See Also

Reference

ReadFormattedTextEventArgs Class
Alternet.Syntax Namespace


ShowingEventArgs Class

ShowingEventArgs Class
Provides data for the ICodeCompletionProvider.ShowPopup event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxShowingEventArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ShowingEventArgs : EventArgs
Public Class ShowingEventArgs
    Inherits EventArgs
public ref class ShowingEventArgs : public EventArgs
type ShowingEventArgs =
    class
        inherit EventArgs
    end

The ShowingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ShowingEventArgs | Initializes a new instance of the ShowingEventArgs class with specific provider.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | NeedShow | Represents a value indicating whether the popup window needs showing.
Public property | Provider | Represents the object that provides data for code completion window.
Top
See Also

Reference

Alternet.Syntax Namespace


ShowingEventArgs Constructor

ShowingEventArgs Constructor
Initializes a new instance of the ShowingEventArgs class with specific provider.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ShowingEventArgs(
    ICodeCompletionProvider provider
)
Public Sub New (
    provider As ICodeCompletionProvider
)
public:
ShowingEventArgs(
    ICodeCompletionProvider^ provider
)
new :
        provider : ICodeCompletionProvider -> ShowingEventArgs

Parameters

provider
Type: Alternet.Syntax.CodeCompletionICodeCompletionProvider
Specifies Provider property for this new instance.
See Also

Reference

ShowingEventArgs Class
Alternet.Syntax Namespace


ShowingEventArgs Methods

ShowingEventArgs Methods

The ShowingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShowingEventArgs Class
Alternet.Syntax Namespace


ShowingEventArgs Properties

ShowingEventArgs Properties

The ShowingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NeedShow | Represents a value indicating whether the popup window needs showing.
Public property | Provider | Represents the object that provides data for code completion window.
Top
See Also

Reference

ShowingEventArgs Class
Alternet.Syntax Namespace


ShowingEventArgs.NeedShow Property

ShowingEventArgsNeedShow Property
Represents a value indicating whether the popup window needs showing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedShow { get; set; }
Public Property NeedShow As Boolean
    Get
    Set
public:
property bool NeedShow {
    bool get ();
    void set (bool value);
}
member NeedShow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ShowingEventArgs Class
Alternet.Syntax Namespace


ShowingEventArgs.Provider Property

ShowingEventArgsProvider Property
Represents the object that provides data for code completion window.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeCompletionProvider Provider { get; set; }
Public Property Provider As ICodeCompletionProvider
    Get
    Set
public:
property ICodeCompletionProvider^ Provider {
    ICodeCompletionProvider^ get ();
    void set (ICodeCompletionProvider^ value);
}
member Provider : ICodeCompletionProvider with get, set

Property Value

Type: ICodeCompletionProvider
See Also

Reference

ShowingEventArgs Class
Alternet.Syntax Namespace


ShowPopupEvent Delegate

ShowPopupEvent Delegate
Represents a method that will handle the CodeCompletionProvider.ShowPopup event.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ShowPopupEvent(
    Object sender,
    ShowingEventArgs e
)
Public Delegate Sub ShowPopupEvent (
    sender As Object,
    e As ShowingEventArgs
)
public delegate void ShowPopupEvent(
    Object^ sender,
    ShowingEventArgs^ e
)
type ShowPopupEvent =
    delegate of
        sender : Object *
        e : ShowingEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxShowingEventArgs
The ShowingEventArgs that contains the event data.
See Also

Reference

Alternet.Syntax Namespace


StopParseException Class

StopParseException Class
Represents error that occurs when parsing text is aborted.
Inheritance Hierarchy
SystemObject
SystemException
Alternet.SyntaxStopParseException

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StopParseException : Exception
Public Class StopParseException
    Inherits Exception
public ref class StopParseException : public Exception
type StopParseException =
    class
        inherit Exception
    end

The StopParseException type exposes the following members.

Constructors
 | Name | Description
Public method | StopParseException | Initializes a new instance of the StopParseException class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

Alternet.Syntax Namespace


StopParseException Constructor

StopParseException Constructor
Initializes a new instance of the StopParseException class

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StopParseException()
Public Sub New
public:
StopParseException()
new : unit -> StopParseException
See Also

Reference

StopParseException Class
Alternet.Syntax Namespace


StopParseException Methods

StopParseException Methods

The StopParseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

StopParseException Class
Alternet.Syntax Namespace


StopParseException Properties

StopParseException Properties

The StopParseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

StopParseException Class
Alternet.Syntax Namespace


StringItemInfo Structure

StringItemInfo Structure
Represent structured information for IStringItem symbol.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct StringItemInfo
Public Structure StringItemInfo
public value class StringItemInfo
[<SealedAttribute>]
type StringItemInfo =  struct end

The StringItemInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(StringItemInfo) | Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Data | Get/Set current IStringItem symbol data.
Public field | TextStyle | Get/Set current IStringItem symbol style according to TextStyle.
Top
See Also

Reference

Alternet.Syntax Namespace


StringItemInfo Fields

StringItemInfo Fields

The StringItemInfo type exposes the following members.

Fields
 | Name | Description
Public field | Data | Get/Set current IStringItem symbol data.
Public field | TextStyle | Get/Set current IStringItem symbol style according to TextStyle.
Top
See Also

Reference

StringItemInfo Structure
Alternet.Syntax Namespace


StringItemInfo.Data Field

StringItemInfoData Field
Get/Set current IStringItem symbol data.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Data
Public Data As Byte
public:
unsigned char Data
val mutable Data: byte

Field Value

Type: Byte
See Also

Reference

StringItemInfo Structure
Alternet.Syntax Namespace


StringItemInfo.TextStyle Field

StringItemInfoTextStyle Field
Get/Set current IStringItem symbol style according to TextStyle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextStyle TextStyle
Public TextStyle As TextStyle
public:
TextStyle TextStyle
val mutable TextStyle: TextStyle

Field Value

Type: TextStyle
See Also

Reference

StringItemInfo Structure
Alternet.Syntax Namespace


StringItemInfo Methods

StringItemInfo Methods

The StringItemInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(StringItemInfo) | Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

StringItemInfo Structure
Alternet.Syntax Namespace


StringItemInfo.Equals Method

StringItemInfoEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(StringItemInfo) | Indicates whether this instance and a specified object are equal.
Top
See Also

Reference

StringItemInfo Structure
Alternet.Syntax Namespace


StringItemInfo.Equals Method (Object)

StringItemInfoEquals Method (Object)
Indicates whether this instance and a specified object are equal.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
Another object to compare to.

Return Value

Type: Boolean
True if obj and this instance are the same type and represent the same value; otherwise, false.
See Also

Reference

StringItemInfo Structure
Equals Overload
Alternet.Syntax Namespace


StringItemInfo.Equals Method (StringItemInfo)

StringItemInfoEquals Method (StringItemInfo)
Indicates whether this instance and a specified object are equal.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    StringItemInfo itemInfo
)
Public Function Equals (
    itemInfo As StringItemInfo
) As Boolean
public:
bool Equals(
    StringItemInfo itemInfo
)
member Equals :
        itemInfo : StringItemInfo -> bool

Parameters

itemInfo
Type: Alternet.SyntaxStringItemInfo
Another StringItemInfo to compare to.

Return Value

Type: Boolean
True if itemInfo and this instance are the same type and represent the same value; otherwise, false.
See Also

Reference

StringItemInfo Structure
Equals Overload
Alternet.Syntax Namespace


StringItemInfo.GetHashCode Method

StringItemInfoGetHashCode Method
Returns the hash code for this instance.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.
See Also

Reference

StringItemInfo Structure
Alternet.Syntax Namespace


StringList Class

StringList Class
Represents collection containing list of strings.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListString
Alternet.SyntaxStringList

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StringList : List<string>,
    IStringList, IList<string>, ICollection<string>,
    IEnumerable<string>, IEnumerable, IImport, IExport
Public Class StringList
    Inherits List(Of String)
    Implements IStringList, IList(Of String),
    ICollection(Of String), IEnumerable(Of String), IEnumerable,
    IImport, IExport
public ref class StringList : public List<String^>,
    IStringList, IList<String^>, ICollection<String^>,
    IEnumerable<String^>, IEnumerable, IImport, IExport
type StringList =
    class
        inherit List<string>
        interface IStringList
        interface IList<string>
        interface ICollection<string>
        interface IEnumerable<string>
        interface IEnumerable
        interface IImport
        interface IExport
    end

The StringList type exposes the following members.

Constructors
 | Name | Description
Public method | StringList | Initializes a new instance of the CodeSnippetList class with default settings.
Public method | StringList(TextReader) | Initializes a new instance of the CodeSnippetList class with specified reader.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListString.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListString.)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListString.)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListString.)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListString.)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListString.)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListString.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListString.)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListString.)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListString.)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListString.)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListString.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListString.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListString.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListString.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListString.)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListString.)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListString.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListString.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListString.)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListString.)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListString.)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListString.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListString.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListString.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListString.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListString.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListString.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListString.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListString.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListString.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListString.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListString.)
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListString.)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListString.)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListString.)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListString.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListString.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListString.)
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, Encoding) | Saves content to the given file with specified exported and specific encoding.
Public method | SaveStream(Stream) | Saves the text content to the given stream with specified exporter.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the given stream with specified exporter.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListString.)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListString.)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListString.)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListString.)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListString.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListString.)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListString.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListString.)
Public property | Item | Provides an indexed access to individual strings stored in the collection.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | Text | Gets or sets the strings in the SyntaxStrings as a single string with the individual strings delimited by carriage returns.
Top
See Also

Reference

Alternet.Syntax Namespace


StringList Constructor

StringList Constructor
Overload List
 | Name | Description
Public method | StringList | Initializes a new instance of the CodeSnippetList class with default settings.
Public method | StringList(TextReader) | Initializes a new instance of the CodeSnippetList class with specified reader.
Top
See Also

Reference

StringList Class
Alternet.Syntax Namespace


StringList Constructor

StringList Constructor
Initializes a new instance of the CodeSnippetList class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringList()
Public Sub New
public:
StringList()
new : unit -> StringList
See Also

Reference

StringList Class
StringList Overload
Alternet.Syntax Namespace


StringList Constructor (TextReader)

StringList Constructor (TextReader)
Initializes a new instance of the CodeSnippetList class with specified reader.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringList(
    TextReader reader
)
Public Sub New (
    reader As TextReader
)
public:
StringList(
    TextReader^ reader
)
new :
        reader : TextReader -> StringList

Parameters

reader
Type: System.IOTextReader
See Also

Reference

StringList Class
StringList Overload
Alternet.Syntax Namespace


StringList Methods

StringList Methods

The StringList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListString.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListString.)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListString.)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListString.)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListString.)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListString.)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListString.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListString.)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListString.)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListString.)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListString.)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListString.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListString.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListString.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListString.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListString.)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListString.)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListString.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListString.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListString.)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListString.)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListString.)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListString.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListString.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListString.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListString.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListString.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListString.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListString.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListString.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListString.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListString.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListString.)
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListString.)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListString.)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListString.)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListString.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListString.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListString.)
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, Encoding) | Saves content to the given file with specified exported and specific encoding.
Public method | SaveStream(Stream) | Saves the text content to the given stream with specified exporter.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the given stream with specified exporter.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListString.)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListString.)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListString.)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListString.)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListString.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListString.)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfString | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstString | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementString, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

StringList Class
Alternet.Syntax Namespace


StringList.LoadFile Method

StringListLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Top
See Also

Reference

StringList Class
Alternet.Syntax Namespace


StringList.LoadFile Method (String)

StringListLoadFile Method (String)
Loads the contents of the specified file.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName
)
Public Overridable Function LoadFile (
    fileName As String
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool
override LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String)
See Also

Reference

StringList Class
LoadFile Overload
Alternet.Syntax Namespace


StringList.LoadFile Method (String, Encoding)

StringListLoadFile Method (String, Encoding)
Loads the contents of the specified file with specified encoding.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

StringList Class
LoadFile Overload
Alternet.Syntax Namespace


StringList.LoadStream Method

StringListLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Top
See Also

Reference

StringList Class
Alternet.Syntax Namespace


StringList.LoadStream Method (Stream)

StringListLoadStream Method (Stream)
Loads the contents of the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream
)
Public Overridable Function LoadStream (
    stream As Stream
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream
)
abstract LoadStream :
        stream : Stream -> bool
override LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream)
See Also

Reference

StringList Class
LoadStream Overload
Alternet.Syntax Namespace


StringList.LoadStream Method (TextReader)

StringListLoadStream Method (TextReader)
Loads the contents of the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader
)
Public Overridable Function LoadStream (
    reader As TextReader
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool
override LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(TextReader)
See Also

Reference

StringList Class
LoadStream Overload
Alternet.Syntax Namespace


StringList.LoadStream Method (Stream, Encoding)

StringListLoadStream Method (Stream, Encoding)
Loads the contents of the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream, Encoding)
See Also

Reference

StringList Class
LoadStream Overload
Alternet.Syntax Namespace


StringList.SaveFile Method

StringListSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, Encoding) | Saves content to the given file with specified exported and specific encoding.
Top
See Also

Reference

StringList Class
Alternet.Syntax Namespace


StringList.SaveFile Method (String)

StringListSaveFile Method (String)
Saves text content to the specific file.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName
)
Public Overridable Function SaveFile (
    fileName As String
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> bool
override SaveFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String)
See Also

Reference

StringList Class
SaveFile Overload
Alternet.Syntax Namespace


StringList.SaveFile Method (String, Encoding)

StringListSaveFile Method (String, Encoding)
Saves content to the given file with specified exported and specific encoding.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String, Encoding)
See Also

Reference

StringList Class
SaveFile Overload
Alternet.Syntax Namespace


StringList.SaveStream Method

StringListSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | Saves the text content to the given stream with specified exporter.
Public method | SaveStream(TextWriter) | Saves the text content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the given stream with specified exporter.
Top
See Also

Reference

StringList Class
Alternet.Syntax Namespace


StringList.SaveStream Method (Stream)

StringListSaveStream Method (Stream)
Saves the text content to the given stream with specified exporter.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream
)
Public Overridable Function SaveStream (
    stream As Stream
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream
)
abstract SaveStream :
        stream : Stream -> bool
override SaveStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream)
See Also

Reference

StringList Class
SaveStream Overload
Alternet.Syntax Namespace


StringList.SaveStream Method (TextWriter)

StringListSaveStream Method (TextWriter)
Saves the text content to the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer
)
Public Overridable Function SaveStream (
    writer As TextWriter
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer
)
abstract SaveStream :
        writer : TextWriter -> bool
override SaveStream :
        writer : TextWriter -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(TextWriter)
See Also

Reference

StringList Class
SaveStream Overload
Alternet.Syntax Namespace


StringList.SaveStream Method (Stream, Encoding)

StringListSaveStream Method (Stream, Encoding)
Saves the text content to the given stream with specified exporter.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream, Encoding)
See Also

Reference

StringList Class
SaveStream Overload
Alternet.Syntax Namespace


StringList Properties

StringList Properties

The StringList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListString.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListString.)
Public property | Item | Provides an indexed access to individual strings stored in the collection.
Public property | LineTerminator | Gets or sets a string value that terminates line.
Public property | Text | Gets or sets the strings in the SyntaxStrings as a single string with the individual strings delimited by carriage returns.
Top
See Also

Reference

StringList Class
Alternet.Syntax Namespace


StringList.Item Property

StringListItem Property
Provides an indexed access to individual strings stored in the collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As String
    Get
    Set
public:
virtual property String^ default[int index] {
    String^ get (int index);
    void set (int index, String^ value);
}
abstract Item : string with get, set
override Item : string with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: String

Implements

IListTItemInt32
See Also

Reference

StringList Class
Alternet.Syntax Namespace


StringList.LineTerminator Property

StringListLineTerminator Property
Gets or sets a string value that terminates line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LineTerminator { get; set; }
Public Property LineTerminator As String
    Get
    Set
public:
property String^ LineTerminator {
    String^ get ();
    void set (String^ value);
}
member LineTerminator : string with get, set

Property Value

Type: String
See Also

Reference

StringList Class
Alternet.Syntax Namespace


StringList.Text Property

StringListText Property
Gets or sets the strings in the SyntaxStrings as a single string with the individual strings delimited by carriage returns.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

IStringListText
See Also

Reference

StringList Class
Alternet.Syntax Namespace


SyntaxAttribute Class

SyntaxAttribute Class
Represents a particular attribute of language element.
Inheritance Hierarchy
SystemObject
Alternet.SyntaxSyntaxAttribute

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SyntaxAttribute : ISyntaxAttribute,
    ICloneable
<SerializableAttribute>
Public Class SyntaxAttribute
    Implements ISyntaxAttribute, ICloneable
[SerializableAttribute]
public ref class SyntaxAttribute : ISyntaxAttribute,
    ICloneable
[<SerializableAttribute>]
type SyntaxAttribute =
    class
        interface ISyntaxAttribute
        interface ICloneable
    end

The SyntaxAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxAttribute | Initializes a new instance of the SyntaxAttribute class with default settings.
Public method | SyntaxAttribute(Point, String, Object) | Initializes a new instance of the SyntaxAttribute class with specified parameters.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ISyntaxAttribute object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current SyntaxAttribute. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | EndPosition | Get attribute end position in the code text.
Public property | Name | Get or sets attribute name.
Public property | Position | Get or sets attribute position in the code text.
Public property | Range | Gets attribute scope.
Public property | Value | Get or sets value of the attribute.
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxAttribute Constructor

SyntaxAttribute Constructor
Overload List
 | Name | Description
Public method | SyntaxAttribute | Initializes a new instance of the SyntaxAttribute class with default settings.
Public method | SyntaxAttribute(Point, String, Object) | Initializes a new instance of the SyntaxAttribute class with specified parameters.
Top
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttribute Constructor

SyntaxAttribute Constructor
Initializes a new instance of the SyntaxAttribute class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxAttribute()
Public Sub New
public:
SyntaxAttribute()
new : unit -> SyntaxAttribute
See Also

Reference

SyntaxAttribute Class
SyntaxAttribute Overload
Alternet.Syntax Namespace


SyntaxAttribute Constructor (Point, String, Object)

SyntaxAttribute Constructor (Point, String, Object)
Initializes a new instance of the SyntaxAttribute class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxAttribute(
    Point position,
    string name,
    Object value
)
Public Sub New (
    position As Point,
    name As String,
    value As Object
)
public:
SyntaxAttribute(
    Point position,
    String^ name,
    Object^ value
)
new :
        position : Point *
        name : string *
        value : Object -> SyntaxAttribute

Parameters

position
Type: System.DrawingPoint
Specified attribute Position.
name
Type: SystemString
Specifies attribute Name.
value
Type: SystemObject
Specifies attribute Value.
See Also

Reference

SyntaxAttribute Class
SyntaxAttribute Overload
Alternet.Syntax Namespace


SyntaxAttribute Methods

SyntaxAttribute Methods

The SyntaxAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ISyntaxAttribute object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current SyntaxAttribute. (Overrides ObjectToString.)
Top
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttribute.Clone Method

SyntaxAttributeClone Method
Creates a new object that is a copy of the current ISyntaxAttribute object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of System.Object that is the memberwise clone of the current SyntaxAttribute object.

Implements

ICloneableClone
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttribute.ToString Method

SyntaxAttributeToString Method
Returns a String that represents the current SyntaxAttribute.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String> that represents the current SyntaxAttribute.
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttribute Properties

SyntaxAttribute Properties

The SyntaxAttribute type exposes the following members.

Properties
 | Name | Description
Public property | EndPosition | Get attribute end position in the code text.
Public property | Name | Get or sets attribute name.
Public property | Position | Get or sets attribute position in the code text.
Public property | Range | Gets attribute scope.
Public property | Value | Get or sets value of the attribute.
Top
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttribute.EndPosition Property

SyntaxAttributeEndPosition Property
Get attribute end position in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point EndPosition { get; set; }
Public Overridable Property EndPosition As Point
    Get
    Set
public:
virtual property Point EndPosition {
    Point get ();
    void set (Point value);
}
abstract EndPosition : Point with get, set
override EndPosition : Point with get, set

Property Value

Type: Point

Implements

ISyntaxAttributeEndPosition
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttribute.Name Property

SyntaxAttributeName Property
Get or sets attribute name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ISyntaxAttributeName
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttribute.Position Property

SyntaxAttributePosition Property
Get or sets attribute position in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Position { get; set; }
Public Overridable Property Position As Point
    Get
    Set
public:
virtual property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set
override Position : Point with get, set

Property Value

Type: Point

Implements

ISyntaxAttributePosition
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttribute.Range Property

SyntaxAttributeRange Property
Gets attribute scope.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange Range { get; }
Public Overridable ReadOnly Property Range As IRange
    Get
public:
virtual property IRange^ Range {
    IRange^ get ();
}
abstract Range : IRange with get
override Range : IRange with get

Property Value

Type: IRange

Implements

ISyntaxAttributeRange
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttribute.Value Property

SyntaxAttributeValue Property
Get or sets value of the attribute.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Value { get; set; }
Public Overridable Property Value As Object
    Get
    Set
public:
virtual property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
abstract Value : Object with get, set
override Value : Object with get, set

Property Value

Type: Object

Implements

ISyntaxAttributeValue
See Also

Reference

SyntaxAttribute Class
Alternet.Syntax Namespace


SyntaxAttributes Class

SyntaxAttributes Class
Represents collection containing list of syntax attributes.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListISyntaxAttribute
Alternet.CommonSortList ISyntaxAttribute
Alternet.SyntaxSyntaxAttributes

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SyntaxAttributes : SortList<ISyntaxAttribute>,
    ISyntaxAttributes, ISortList<ISyntaxAttribute>, IList<ISyntaxAttribute>,
    ICollection<ISyntaxAttribute>, IEnumerable<ISyntaxAttribute>, IEnumerable
<SerializableAttribute>
Public Class SyntaxAttributes
    Inherits SortList(Of ISyntaxAttribute)
    Implements ISyntaxAttributes, ISortList(Of ISyntaxAttribute),
    IList(Of ISyntaxAttribute), ICollection(Of ISyntaxAttribute), IEnumerable(Of ISyntaxAttribute),
    IEnumerable
[SerializableAttribute]
public ref class SyntaxAttributes : public SortList<ISyntaxAttribute^>,
    ISyntaxAttributes, ISortList<ISyntaxAttribute^>, IList<ISyntaxAttribute^>,
    ICollection<ISyntaxAttribute^>, IEnumerable<ISyntaxAttribute^>, IEnumerable
[<SerializableAttribute>]
type SyntaxAttributes =
    class
        inherit SortList<ISyntaxAttribute>
        interface ISyntaxAttributes
        interface ISortList<ISyntaxAttribute>
        interface IList<ISyntaxAttribute>
        interface ICollection<ISyntaxAttribute>
        interface IEnumerable<ISyntaxAttribute>
        interface IEnumerable
    end

The SyntaxAttributes type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxAttributes | Initializes a new instance of the SyntaxAttributes class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListISyntaxAttribute .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListISyntaxAttribute .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListISyntaxAttribute .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListISyntaxAttribute .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxAttribute .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxAttribute .)
Public method | BlockDeleting | Removes all attributes from specified region.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListISyntaxAttribute .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListISyntaxAttribute .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListISyntaxAttribute .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListISyntaxAttribute .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxAttribute .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxAttribute .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxAttribute .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxAttribute .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxAttribute .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxAttribute .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxAttribute .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxAttribute .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListISyntaxAttribute .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListISyntaxAttribute .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListISyntaxAttribute .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxAttribute .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxAttribute .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListISyntaxAttribute .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListISyntaxAttribute .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxAttribute .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxAttribute .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Updates specified position by DeltaX and DeltaY values for any attributes in the collection.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListISyntaxAttribute .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxAttribute .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListISyntaxAttribute .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListISyntaxAttribute .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListISyntaxAttribute .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListISyntaxAttribute .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListISyntaxAttribute .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListISyntaxAttribute .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListISyntaxAttribute .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListISyntaxAttribute .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListISyntaxAttribute .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListISyntaxAttribute .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxAttribute | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxAttribute | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxAttribute, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListISyntaxAttribute .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListISyntaxAttribute .)
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxAttributes Constructor

SyntaxAttributes Constructor
Initializes a new instance of the SyntaxAttributes class

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxAttributes()
Public Sub New
public:
SyntaxAttributes()
new : unit -> SyntaxAttributes
See Also

Reference

SyntaxAttributes Class
Alternet.Syntax Namespace


SyntaxAttributes Methods

SyntaxAttributes Methods

The SyntaxAttributes type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListISyntaxAttribute .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListISyntaxAttribute .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListISyntaxAttribute .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListISyntaxAttribute .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxAttribute .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxAttribute .)
Public method | BlockDeleting | Removes all attributes from specified region.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListISyntaxAttribute .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListISyntaxAttribute .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListISyntaxAttribute .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListISyntaxAttribute .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxAttribute .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxAttribute .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxAttribute .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxAttribute .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxAttribute .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxAttribute .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxAttribute .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxAttribute .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListISyntaxAttribute .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListISyntaxAttribute .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListISyntaxAttribute .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxAttribute .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxAttribute .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListISyntaxAttribute .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListISyntaxAttribute .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxAttribute .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxAttribute .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Updates specified position by DeltaX and DeltaY values for any attributes in the collection.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListISyntaxAttribute .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxAttribute .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListISyntaxAttribute .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListISyntaxAttribute .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListISyntaxAttribute .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListISyntaxAttribute .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListISyntaxAttribute .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListISyntaxAttribute .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListISyntaxAttribute .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListISyntaxAttribute .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListISyntaxAttribute .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListISyntaxAttribute .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListISyntaxAttribute .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxAttribute | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxAttribute | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxAttribute, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

SyntaxAttributes Class
Alternet.Syntax Namespace


SyntaxAttributes.BlockDeleting Method

SyntaxAttributesBlockDeleting Method
Removes all attributes from specified region.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect
)
Public Overridable Function BlockDeleting (
    rect As Rectangle
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool
override BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to remove nodes from.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxAttributesBlockDeleting(Rectangle)
See Also

Reference

SyntaxAttributes Class
Alternet.Syntax Namespace


SyntaxAttributes.PositionChanged Method

SyntaxAttributesPositionChanged Method
Updates specified position by DeltaX and DeltaY values for any attributes in the collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxAttributesPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

SyntaxAttributes Class
Alternet.Syntax Namespace


SyntaxAttributes Properties

SyntaxAttributes Properties

The SyntaxAttributes type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListISyntaxAttribute .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListISyntaxAttribute .)
Top
See Also

Reference

SyntaxAttributes Class
Alternet.Syntax Namespace


SyntaxConsts Class

SyntaxConsts Class
Contains default constants related to lexical and syntax analyzers.
Inheritance Hierarchy
SystemObject
Alternet.SyntaxSyntaxConsts

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxConsts
Public Class SyntaxConsts
public ref class SyntaxConsts
type SyntaxConsts =  class end

The SyntaxConsts type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxConsts | Initializes a new instance of the SyntaxConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AttributeAccess |
BlockScope |
DeclarationScope |
DefaultAuthor |
DefaultBoldEndTag |
DefaultBoldTag |
DefaultBrTag |
DefaultCaretSymbol |
DefaultCodeSnippetBackColor |
DefaultCodeSnippetForeColor |
DefaultCommentsForeColor |
DefaultCompletionDelay |
DefaultCopyright |
DefaultCurrentCodeSnippetForeColor |
DefaultDirectivesForeColor |
DefaultHtmlAutoIndentChars |
DefaultHtmlCodeCompletionChars |
DefaultHtmlParamsForeColor |
DefaultHtmlSyntaxOptions |
DefaultIndentsForeColor |
DefaultInfoForeColor |
DefaultItalicEndTag |
DefaultItalicTag |
DefaultKnownTypesColor |
DefaultLexSchemeVersion |
DefaultMethodForeColor |
DefaultNumbersForeColor |
DefaultParaTag |
DefaultParseInterval |
DefaultReferenceBackColor |
DefaultReswordForeColor |
DefaultSearchResultBackColor |
DefaultSnippetDelimiter |
DefaultSnippetPathSeparator |
DefaultStringsForeColor |
DefaultSymbolForeColor |
DefaultSyntaxErrorsForeColor |
DefaultSyntaxWarningForeColor |
DefaultTransparentColor |
DefaultXmlCommentsForeColor |
DefaultXmlOptions |
DefinitionScope |
DefinitionScopeEnd |
DefinitionScopeEndExpected |
MinDelay |
OutlineText |
SummaryDescription |
SuppressReparsingScope |
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxConsts Constructor

SyntaxConsts Constructor
Initializes a new instance of the SyntaxConsts class

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxConsts()
Public Sub New
public:
SyntaxConsts()
new : unit -> SyntaxConsts
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts Fields

SyntaxConsts Fields

The SyntaxConsts type exposes the following members.

Fields
Name | Description
AttributeAccess |
BlockScope |
DeclarationScope |
DefaultAuthor |
DefaultBoldEndTag |
DefaultBoldTag |
DefaultBrTag |
DefaultCaretSymbol |
DefaultCodeSnippetBackColor |
DefaultCodeSnippetForeColor |
DefaultCommentsForeColor |
DefaultCompletionDelay |
DefaultCopyright |
DefaultCurrentCodeSnippetForeColor |
DefaultDirectivesForeColor |
DefaultHtmlAutoIndentChars |
DefaultHtmlCodeCompletionChars |
DefaultHtmlParamsForeColor |
DefaultHtmlSyntaxOptions |
DefaultIndentsForeColor |
DefaultInfoForeColor |
DefaultItalicEndTag |
DefaultItalicTag |
DefaultKnownTypesColor |
DefaultLexSchemeVersion |
DefaultMethodForeColor |
DefaultNumbersForeColor |
DefaultParaTag |
DefaultParseInterval |
DefaultReferenceBackColor |
DefaultReswordForeColor |
DefaultSearchResultBackColor |
DefaultSnippetDelimiter |
DefaultSnippetPathSeparator |
DefaultStringsForeColor |
DefaultSymbolForeColor |
DefaultSyntaxErrorsForeColor |
DefaultSyntaxWarningForeColor |
DefaultTransparentColor |
DefaultXmlCommentsForeColor |
DefaultXmlOptions |
DefinitionScope |
DefinitionScopeEnd |
DefinitionScopeEndExpected |
MinDelay |
OutlineText |
SummaryDescription |
SuppressReparsingScope |
Top
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.AttributeAccess Field

SyntaxConstsAttributeAccess Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string AttributeAccess
Public Shared AttributeAccess As String
public:
static String^ AttributeAccess
static val mutable AttributeAccess: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.BlockScope Field

SyntaxConstsBlockScope Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string BlockScope
Public Shared BlockScope As String
public:
static String^ BlockScope
static val mutable BlockScope: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DeclarationScope Field

SyntaxConstsDeclarationScope Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DeclarationScope
Public Shared DeclarationScope As String
public:
static String^ DeclarationScope
static val mutable DeclarationScope: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultAuthor Field

SyntaxConstsDefaultAuthor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultAuthor
Public Const DefaultAuthor As String
public:
literal String^ DefaultAuthor
static val mutable DefaultAuthor: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultBoldEndTag Field

SyntaxConstsDefaultBoldEndTag Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultBoldEndTag
Public Shared DefaultBoldEndTag As String
public:
static String^ DefaultBoldEndTag
static val mutable DefaultBoldEndTag: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultBoldTag Field

SyntaxConstsDefaultBoldTag Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultBoldTag
Public Shared DefaultBoldTag As String
public:
static String^ DefaultBoldTag
static val mutable DefaultBoldTag: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultBrTag Field

SyntaxConstsDefaultBrTag Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultBrTag
Public Shared DefaultBrTag As String
public:
static String^ DefaultBrTag
static val mutable DefaultBrTag: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultCaretSymbol Field

SyntaxConstsDefaultCaretSymbol Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static char DefaultCaretSymbol
Public Shared DefaultCaretSymbol As Char
public:
static wchar_t DefaultCaretSymbol
static val mutable DefaultCaretSymbol: char

Field Value

Type: Char
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultCodeSnippetBackColor Field

SyntaxConstsDefaultCodeSnippetBackColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultCodeSnippetBackColor
Public Shared DefaultCodeSnippetBackColor As Color
public:
static Color DefaultCodeSnippetBackColor
static val mutable DefaultCodeSnippetBackColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultCodeSnippetForeColor Field

SyntaxConstsDefaultCodeSnippetForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultCodeSnippetForeColor
Public Shared DefaultCodeSnippetForeColor As Color
public:
static Color DefaultCodeSnippetForeColor
static val mutable DefaultCodeSnippetForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultCommentsForeColor Field

SyntaxConstsDefaultCommentsForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultCommentsForeColor
Public Shared DefaultCommentsForeColor As Color
public:
static Color DefaultCommentsForeColor
static val mutable DefaultCommentsForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultCompletionDelay Field

SyntaxConstsDefaultCompletionDelay Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultCompletionDelay
Public Shared DefaultCompletionDelay As Integer
public:
static int DefaultCompletionDelay
static val mutable DefaultCompletionDelay: int

Field Value

Type: Int32
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultCopyright Field

SyntaxConstsDefaultCopyright Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultCopyright
Public Const DefaultCopyright As String
public:
literal String^ DefaultCopyright
static val mutable DefaultCopyright: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultCurrentCodeSnippetForeColor Field

SyntaxConstsDefaultCurrentCodeSnippetForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultCurrentCodeSnippetForeColor
Public Shared DefaultCurrentCodeSnippetForeColor As Color
public:
static Color DefaultCurrentCodeSnippetForeColor
static val mutable DefaultCurrentCodeSnippetForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultDirectivesForeColor Field

SyntaxConstsDefaultDirectivesForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultDirectivesForeColor
Public Shared DefaultDirectivesForeColor As Color
public:
static Color DefaultDirectivesForeColor
static val mutable DefaultDirectivesForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultHtmlAutoIndentChars Field

SyntaxConstsDefaultHtmlAutoIndentChars Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultHtmlAutoIndentChars
Public Shared DefaultHtmlAutoIndentChars As String
public:
static String^ DefaultHtmlAutoIndentChars
static val mutable DefaultHtmlAutoIndentChars: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultHtmlCodeCompletionChars Field

SyntaxConstsDefaultHtmlCodeCompletionChars Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultHtmlCodeCompletionChars
Public Shared DefaultHtmlCodeCompletionChars As String
public:
static String^ DefaultHtmlCodeCompletionChars
static val mutable DefaultHtmlCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultHtmlParamsForeColor Field

SyntaxConstsDefaultHtmlParamsForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultHtmlParamsForeColor
Public Shared DefaultHtmlParamsForeColor As Color
public:
static Color DefaultHtmlParamsForeColor
static val mutable DefaultHtmlParamsForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultHtmlSyntaxOptions Field

SyntaxConstsDefaultHtmlSyntaxOptions Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultHtmlSyntaxOptions
Public Shared DefaultHtmlSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultHtmlSyntaxOptions
static val mutable DefaultHtmlSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultIndentsForeColor Field

SyntaxConstsDefaultIndentsForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultIndentsForeColor
Public Shared DefaultIndentsForeColor As Color
public:
static Color DefaultIndentsForeColor
static val mutable DefaultIndentsForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultInfoForeColor Field

SyntaxConstsDefaultInfoForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultInfoForeColor
Public Shared DefaultInfoForeColor As Color
public:
static Color DefaultInfoForeColor
static val mutable DefaultInfoForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultItalicEndTag Field

SyntaxConstsDefaultItalicEndTag Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultItalicEndTag
Public Shared DefaultItalicEndTag As String
public:
static String^ DefaultItalicEndTag
static val mutable DefaultItalicEndTag: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultItalicTag Field

SyntaxConstsDefaultItalicTag Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultItalicTag
Public Shared DefaultItalicTag As String
public:
static String^ DefaultItalicTag
static val mutable DefaultItalicTag: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultKnownTypesColor Field

SyntaxConstsDefaultKnownTypesColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultKnownTypesColor
Public Shared DefaultKnownTypesColor As Color
public:
static Color DefaultKnownTypesColor
static val mutable DefaultKnownTypesColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultLexSchemeVersion Field

SyntaxConstsDefaultLexSchemeVersion Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultLexSchemeVersion
Public Shared DefaultLexSchemeVersion As String
public:
static String^ DefaultLexSchemeVersion
static val mutable DefaultLexSchemeVersion: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultMethodForeColor Field

SyntaxConstsDefaultMethodForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultMethodForeColor
Public Shared DefaultMethodForeColor As Color
public:
static Color DefaultMethodForeColor
static val mutable DefaultMethodForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultNumbersForeColor Field

SyntaxConstsDefaultNumbersForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultNumbersForeColor
Public Shared DefaultNumbersForeColor As Color
public:
static Color DefaultNumbersForeColor
static val mutable DefaultNumbersForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultParaTag Field

SyntaxConstsDefaultParaTag Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultParaTag
Public Shared DefaultParaTag As String
public:
static String^ DefaultParaTag
static val mutable DefaultParaTag: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultParseInterval Field

SyntaxConstsDefaultParseInterval Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultParseInterval
Public Shared DefaultParseInterval As Integer
public:
static int DefaultParseInterval
static val mutable DefaultParseInterval: int

Field Value

Type: Int32
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultReferenceBackColor Field

SyntaxConstsDefaultReferenceBackColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultReferenceBackColor
Public Shared DefaultReferenceBackColor As Color
public:
static Color DefaultReferenceBackColor
static val mutable DefaultReferenceBackColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultReswordForeColor Field

SyntaxConstsDefaultReswordForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultReswordForeColor
Public Shared DefaultReswordForeColor As Color
public:
static Color DefaultReswordForeColor
static val mutable DefaultReswordForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultSearchResultBackColor Field

SyntaxConstsDefaultSearchResultBackColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultSearchResultBackColor
Public Shared DefaultSearchResultBackColor As Color
public:
static Color DefaultSearchResultBackColor
static val mutable DefaultSearchResultBackColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultSnippetDelimiter Field

SyntaxConstsDefaultSnippetDelimiter Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultSnippetDelimiter
Public Shared DefaultSnippetDelimiter As String
public:
static String^ DefaultSnippetDelimiter
static val mutable DefaultSnippetDelimiter: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultSnippetPathSeparator Field

SyntaxConstsDefaultSnippetPathSeparator Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultSnippetPathSeparator
Public Shared DefaultSnippetPathSeparator As String
public:
static String^ DefaultSnippetPathSeparator
static val mutable DefaultSnippetPathSeparator: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultStringsForeColor Field

SyntaxConstsDefaultStringsForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultStringsForeColor
Public Shared DefaultStringsForeColor As Color
public:
static Color DefaultStringsForeColor
static val mutable DefaultStringsForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultSymbolForeColor Field

SyntaxConstsDefaultSymbolForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultSymbolForeColor
Public Shared DefaultSymbolForeColor As Color
public:
static Color DefaultSymbolForeColor
static val mutable DefaultSymbolForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultSyntaxErrorsForeColor Field

SyntaxConstsDefaultSyntaxErrorsForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultSyntaxErrorsForeColor
Public Shared DefaultSyntaxErrorsForeColor As Color
public:
static Color DefaultSyntaxErrorsForeColor
static val mutable DefaultSyntaxErrorsForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultSyntaxWarningForeColor Field

SyntaxConstsDefaultSyntaxWarningForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultSyntaxWarningForeColor
Public Shared DefaultSyntaxWarningForeColor As Color
public:
static Color DefaultSyntaxWarningForeColor
static val mutable DefaultSyntaxWarningForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultTransparentColor Field

SyntaxConstsDefaultTransparentColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultTransparentColor
Public Shared DefaultTransparentColor As Color
public:
static Color DefaultTransparentColor
static val mutable DefaultTransparentColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultXmlCommentsForeColor Field

SyntaxConstsDefaultXmlCommentsForeColor Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultXmlCommentsForeColor
Public Shared DefaultXmlCommentsForeColor As Color
public:
static Color DefaultXmlCommentsForeColor
static val mutable DefaultXmlCommentsForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefaultXmlOptions Field

SyntaxConstsDefaultXmlOptions Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultXmlOptions
Public Shared DefaultXmlOptions As SyntaxOptions
public:
static SyntaxOptions DefaultXmlOptions
static val mutable DefaultXmlOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefinitionScope Field

SyntaxConstsDefinitionScope Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefinitionScope
Public Shared DefinitionScope As String
public:
static String^ DefinitionScope
static val mutable DefinitionScope: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefinitionScopeEnd Field

SyntaxConstsDefinitionScopeEnd Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefinitionScopeEnd
Public Shared DefinitionScopeEnd As String
public:
static String^ DefinitionScopeEnd
static val mutable DefinitionScopeEnd: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.DefinitionScopeEndExpected Field

SyntaxConstsDefinitionScopeEndExpected Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefinitionScopeEndExpected
Public Shared DefinitionScopeEndExpected As String
public:
static String^ DefinitionScopeEndExpected
static val mutable DefinitionScopeEndExpected: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.MinDelay Field

SyntaxConstsMinDelay Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MinDelay
Public Shared MinDelay As Integer
public:
static int MinDelay
static val mutable MinDelay: int

Field Value

Type: Int32
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.OutlineText Field

SyntaxConstsOutlineText Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OutlineText
Public Shared OutlineText As String
public:
static String^ OutlineText
static val mutable OutlineText: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.SummaryDescription Field

SyntaxConstsSummaryDescription Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SummaryDescription
Public Shared SummaryDescription As String
public:
static String^ SummaryDescription
static val mutable SummaryDescription: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts.SuppressReparsingScope Field

SyntaxConstsSuppressReparsingScope Field

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SuppressReparsingScope
Public Shared SuppressReparsingScope As String
public:
static String^ SuppressReparsingScope
static val mutable SuppressReparsingScope: string

Field Value

Type: String
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxConsts Methods

SyntaxConsts Methods

The SyntaxConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SyntaxConsts Class
Alternet.Syntax Namespace


SyntaxError Class

SyntaxError Class
Describes a particular syntax error in the code text.
Inheritance Hierarchy
SystemObject
Alternet.SyntaxSyntaxError

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SyntaxError : ISyntaxError,
    ICloneable
<SerializableAttribute>
Public Class SyntaxError
    Implements ISyntaxError, ICloneable
[SerializableAttribute]
public ref class SyntaxError : ISyntaxError,
    ICloneable
[<SerializableAttribute>]
type SyntaxError =
    class
        interface ISyntaxError
        interface ICloneable
    end

The SyntaxError type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxError | Initializes a new instance of the SyntaxError class with default settings.
Public method | SyntaxError(Point) | Initializes a new instance of the SyntaxError class at specified position.
Public method | SyntaxError(Point, String, String) | Initializes a new instance of the SyntaxError class with specified parameters.
Public method | SyntaxError(Point, String, String, String) | Initializes a new instance of the SyntaxError class with specified parameters.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ISyntaxError object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current SyntaxError. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Description | Gets or sets error description (reason).
Public property | ErrorCode | Gets or sets error type.
Public property | ErrorType | Gets or sets error type.
Public property | Name | Gets or sets error name.
Public property | Position | Gets or sets error position in the code text.
Public property | Range | Gets or sets error scope.
Public property | Size | Gets or sets error dimension.
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxError Constructor

SyntaxError Constructor
Overload List
 | Name | Description
Public method | SyntaxError | Initializes a new instance of the SyntaxError class with default settings.
Public method | SyntaxError(Point) | Initializes a new instance of the SyntaxError class at specified position.
Public method | SyntaxError(Point, String, String) | Initializes a new instance of the SyntaxError class with specified parameters.
Public method | SyntaxError(Point, String, String, String) | Initializes a new instance of the SyntaxError class with specified parameters.
Top
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError Constructor

SyntaxError Constructor
Initializes a new instance of the SyntaxError class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxError()
Public Sub New
public:
SyntaxError()
new : unit -> SyntaxError
See Also

Reference

SyntaxError Class
SyntaxError Overload
Alternet.Syntax Namespace


SyntaxError Constructor (Point)

SyntaxError Constructor (Point)
Initializes a new instance of the SyntaxError class at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxError(
    Point position
)
Public Sub New (
    position As Point
)
public:
SyntaxError(
    Point position
)
new :
        position : Point -> SyntaxError

Parameters

position
Type: System.DrawingPoint
Specifies error Position.
See Also

Reference

SyntaxError Class
SyntaxError Overload
Alternet.Syntax Namespace


SyntaxError Constructor (Point, String, String)

SyntaxError Constructor (Point, String, String)
Initializes a new instance of the SyntaxError class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxError(
    Point position,
    string name,
    string description
)
Public Sub New (
    position As Point,
    name As String,
    description As String
)
public:
SyntaxError(
    Point position,
    String^ name,
    String^ description
)
new :
        position : Point *
        name : string *
        description : string -> SyntaxError

Parameters

position
Type: System.DrawingPoint
Specifies error Position.
name
Type: SystemString
Specifies error Name.
description
Type: SystemString
Specifies error Description.
See Also

Reference

SyntaxError Class
SyntaxError Overload
Alternet.Syntax Namespace


SyntaxError Constructor (Point, String, String, String)

SyntaxError Constructor (Point, String, String, String)
Initializes a new instance of the SyntaxError class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxError(
    Point position,
    string name,
    string description,
    string errorCode
)
Public Sub New (
    position As Point,
    name As String,
    description As String,
    errorCode As String
)
public:
SyntaxError(
    Point position,
    String^ name,
    String^ description,
    String^ errorCode
)
new :
        position : Point *
        name : string *
        description : string *
        errorCode : string -> SyntaxError

Parameters

position
Type: System.DrawingPoint
Specifies error Position.
name
Type: SystemString
Specifies error Name.
description
Type: SystemString
Specifies error Description.
errorCode
Type: SystemString
Specifies error code.
See Also

Reference

SyntaxError Class
SyntaxError Overload
Alternet.Syntax Namespace


SyntaxError Methods

SyntaxError Methods

The SyntaxError type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current ISyntaxError object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current SyntaxError. (Overrides ObjectToString.)
Top
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError.Clone Method

SyntaxErrorClone Method
Creates a new object that is a copy of the current ISyntaxError object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of System.Object that is the memberwise clone of the current SyntaxError object.

Implements

ICloneableClone
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError.ToString Method

SyntaxErrorToString Method
Returns a String that represents the current SyntaxError.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String> that represents the current SyntaxError.
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError Properties

SyntaxError Properties

The SyntaxError type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets error description (reason).
Public property | ErrorCode | Gets or sets error type.
Public property | ErrorType | Gets or sets error type.
Public property | Name | Gets or sets error name.
Public property | Position | Gets or sets error position in the code text.
Public property | Range | Gets or sets error scope.
Public property | Size | Gets or sets error dimension.
Top
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError.Description Property

SyntaxErrorDescription Property
Gets or sets error description (reason).

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

ISyntaxErrorDescription
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError.ErrorCode Property

SyntaxErrorErrorCode Property
Gets or sets error type.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ErrorCode { get; set; }
Public Overridable Property ErrorCode As String
    Get
    Set
public:
virtual property String^ ErrorCode {
    String^ get ();
    void set (String^ value);
}
abstract ErrorCode : string with get, set
override ErrorCode : string with get, set

Property Value

Type: String

Implements

ISyntaxErrorErrorCode
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError.ErrorType Property

SyntaxErrorErrorType Property
Gets or sets error type.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SyntaxErrorType ErrorType { get; set; }
Public Overridable Property ErrorType As SyntaxErrorType
    Get
    Set
public:
virtual property SyntaxErrorType ErrorType {
    SyntaxErrorType get ();
    void set (SyntaxErrorType value);
}
abstract ErrorType : SyntaxErrorType with get, set
override ErrorType : SyntaxErrorType with get, set

Property Value

Type: SyntaxErrorType

Implements

ISyntaxErrorErrorType
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError.Name Property

SyntaxErrorName Property
Gets or sets error name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ISyntaxErrorName
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError.Position Property

SyntaxErrorPosition Property
Gets or sets error position in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Position { get; set; }
Public Overridable Property Position As Point
    Get
    Set
public:
virtual property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set
override Position : Point with get, set

Property Value

Type: Point

Implements

ISyntaxErrorPosition
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError.Range Property

SyntaxErrorRange Property
Gets or sets error scope.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange Range { get; set; }
Public Overridable Property Range As IRange
    Get
    Set
public:
virtual property IRange^ Range {
    IRange^ get ();
    void set (IRange^ value);
}
abstract Range : IRange with get, set
override Range : IRange with get, set

Property Value

Type: IRange

Implements

ISyntaxErrorRange
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxError.Size Property

SyntaxErrorSize Property
Gets or sets error dimension.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size Size { get; set; }
Public Overridable Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get ();
    void set (Size value);
}
abstract Size : Size with get, set
override Size : Size with get, set

Property Value

Type: Size

Implements

ISyntaxErrorSize
See Also

Reference

SyntaxError Class
Alternet.Syntax Namespace


SyntaxErrors Class

SyntaxErrors Class
Represents collection containing list of syntax errors.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListISyntaxError
Alternet.CommonSortList ISyntaxError
Alternet.SyntaxSyntaxErrors

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SyntaxErrors : SortList<ISyntaxError>,
    ISyntaxErrors, ISortList<ISyntaxError>, IList<ISyntaxError>,
    ICollection<ISyntaxError>, IEnumerable<ISyntaxError>, IEnumerable
<SerializableAttribute>
Public Class SyntaxErrors
    Inherits SortList(Of ISyntaxError)
    Implements ISyntaxErrors, ISortList(Of ISyntaxError),
    IList(Of ISyntaxError), ICollection(Of ISyntaxError), IEnumerable(Of ISyntaxError),
    IEnumerable
[SerializableAttribute]
public ref class SyntaxErrors : public SortList<ISyntaxError^>,
    ISyntaxErrors, ISortList<ISyntaxError^>, IList<ISyntaxError^>,
    ICollection<ISyntaxError^>, IEnumerable<ISyntaxError^>, IEnumerable
[<SerializableAttribute>]
type SyntaxErrors =
    class
        inherit SortList<ISyntaxError>
        interface ISyntaxErrors
        interface ISortList<ISyntaxError>
        interface IList<ISyntaxError>
        interface ICollection<ISyntaxError>
        interface IEnumerable<ISyntaxError>
        interface IEnumerable
    end

The SyntaxErrors type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxErrors | Initializes a new instance of the SyntaxErrors class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListISyntaxError .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListISyntaxError .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListISyntaxError .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListISyntaxError .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxError .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxError .)
Public method | BlockDeleting(Rectangle) | Removes all errors from specified region.
Public method | BlockDeleting(Rectangle, IComparerISyntaxError) | Removes all syntax errors from the error collection which position in the specified rectangle.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListISyntaxError .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListISyntaxError .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListISyntaxError .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListISyntaxError .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxError .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxError .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxError .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxError .)
Public method | FindErrorAt | When implemented by a class, locates error at specified position.
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxError .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxError .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxError .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxError .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListISyntaxError .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListISyntaxError .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListISyntaxError .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxError .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxError .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListISyntaxError .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListISyntaxError .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxError .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxError .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged(Int32, Int32, Int32, Int32) | Updates specified position by DeltaX and DeltaY values for any errors in the collection.
Public method | PositionChanged(Int32, Int32, Int32, Int32, IComparerISyntaxError) | Updates all syntax errors starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListISyntaxError .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxError .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListISyntaxError .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListISyntaxError .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListISyntaxError .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListISyntaxError .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListISyntaxError .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListISyntaxError .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListISyntaxError .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListISyntaxError .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListISyntaxError .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListISyntaxError .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListISyntaxError .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxError | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxError | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxError, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListISyntaxError .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListISyntaxError .)
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxErrors Constructor

SyntaxErrors Constructor
Initializes a new instance of the SyntaxErrors class

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxErrors()
Public Sub New
public:
SyntaxErrors()
new : unit -> SyntaxErrors
See Also

Reference

SyntaxErrors Class
Alternet.Syntax Namespace


SyntaxErrors Methods

SyntaxErrors Methods

The SyntaxErrors type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListISyntaxError .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListISyntaxError .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListISyntaxError .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListISyntaxError .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxError .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxError .)
Public method | BlockDeleting(Rectangle) | Removes all errors from specified region.
Public method | BlockDeleting(Rectangle, IComparerISyntaxError) | Removes all syntax errors from the error collection which position in the specified rectangle.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListISyntaxError .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListISyntaxError .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListISyntaxError .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListISyntaxError .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxError .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxError .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxError .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxError .)
Public method | FindErrorAt | When implemented by a class, locates error at specified position.
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxError .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxError .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxError .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxError .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListISyntaxError .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListISyntaxError .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListISyntaxError .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxError .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxError .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListISyntaxError .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListISyntaxError .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxError .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxError .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxError .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged(Int32, Int32, Int32, Int32) | Updates specified position by DeltaX and DeltaY values for any errors in the collection.
Public method | PositionChanged(Int32, Int32, Int32, Int32, IComparerISyntaxError) | Updates all syntax errors starting from specified position.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListISyntaxError .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxError .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListISyntaxError .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListISyntaxError .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListISyntaxError .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListISyntaxError .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListISyntaxError .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListISyntaxError .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListISyntaxError .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListISyntaxError .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListISyntaxError .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListISyntaxError .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListISyntaxError .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxError | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxError | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxError, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

SyntaxErrors Class
Alternet.Syntax Namespace


SyntaxErrors.BlockDeleting Method

SyntaxErrorsBlockDeleting Method
Overload List
 | Name | Description
Public method | BlockDeleting(Rectangle) | Removes all errors from specified region.
Public method | BlockDeleting(Rectangle, IComparerISyntaxError) | Removes all syntax errors from the error collection which position in the specified rectangle.
Top
See Also

Reference

SyntaxErrors Class
Alternet.Syntax Namespace


SyntaxErrors.BlockDeleting Method (Rectangle)

SyntaxErrorsBlockDeleting Method (Rectangle)
Removes all errors from specified region.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect
)
Public Overridable Function BlockDeleting (
    rect As Rectangle
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> bool
override BlockDeleting :
        rect : Rectangle -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to remove errors from.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxErrorsBlockDeleting(Rectangle)
See Also

Reference

SyntaxErrors Class
BlockDeleting Overload
Alternet.Syntax Namespace


SyntaxErrors.BlockDeleting Method (Rectangle, IComparer(ISyntaxError))

SyntaxErrorsBlockDeleting Method (Rectangle, IComparerISyntaxError)
Removes all syntax errors from the error collection which position in the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxError> comparer
)
Public Overridable Function BlockDeleting (
    rect As Rectangle,
    comparer As IComparer(Of ISyntaxError)
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxError^>^ comparer
)
abstract BlockDeleting :
        rect : Rectangle *
        comparer : IComparer<ISyntaxError> -> bool
override BlockDeleting :
        rect : Rectangle *
        comparer : IComparer<ISyntaxError> -> bool

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove syntax errors.
comparer
Type: System.Collections.GenericIComparerISyntaxError
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxErrorsBlockDeleting(Rectangle, IComparerISyntaxError)
See Also

Reference

SyntaxErrors Class
BlockDeleting Overload
Alternet.Syntax Namespace


SyntaxErrors.FindErrorAt Method

SyntaxErrorsFindErrorAt Method
When implemented by a class, locates error at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindErrorAt(
    Point position,
    bool exact,
    out int index,
    IComparer<ISyntaxError> comparer
)
Public Overridable Function FindErrorAt (
    position As Point,
    exact As Boolean,
    <OutAttribute> ByRef index As Integer,
    comparer As IComparer(Of ISyntaxError)
) As Boolean
public:
virtual bool FindErrorAt(
    Point position,
    bool exact,
    [OutAttribute] int% index,
    IComparer<ISyntaxError^>^ comparer
)
abstract FindErrorAt :
        position : Point *
        exact : bool *
        index : int byref *
        comparer : IComparer<ISyntaxError> -> bool
override FindErrorAt :
        position : Point *
        exact : bool *
        index : int byref *
        comparer : IComparer<ISyntaxError> -> bool

Parameters

position
Type: System.DrawingPoint
Position to locate error.
exact
Type: SystemBoolean
Specifies whether search should be precise.
index
Type: SystemInt32
Receives index of syntax error in the error collection.
comparer
Type: System.Collections.GenericIComparerISyntaxError
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxErrorsFindErrorAt(Point, Boolean, Int32, IComparerISyntaxError)
See Also

Reference

SyntaxErrors Class
Alternet.Syntax Namespace


SyntaxErrors.PositionChanged Method

SyntaxErrorsPositionChanged Method
Overload List
 | Name | Description
Public method | PositionChanged(Int32, Int32, Int32, Int32) | Updates specified position by DeltaX and DeltaY values for any errors in the collection.
Public method | PositionChanged(Int32, Int32, Int32, Int32, IComparerISyntaxError) | Updates all syntax errors starting from specified position.
Top
See Also

Reference

SyntaxErrors Class
Alternet.Syntax Namespace


SyntaxErrors.PositionChanged Method (Int32, Int32, Int32, Int32)

SyntaxErrorsPositionChanged Method (Int32, Int32, Int32, Int32)
Updates specified position by DeltaX and DeltaY values for any errors in the collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxErrorsPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

SyntaxErrors Class
PositionChanged Overload
Alternet.Syntax Namespace


SyntaxErrors.PositionChanged Method (Int32, Int32, Int32, Int32, IComparer(ISyntaxError))

SyntaxErrorsPositionChanged Method (Int32, Int32, Int32, Int32, IComparerISyntaxError)
Updates all syntax errors starting from specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxError> comparer
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    comparer As IComparer(Of ISyntaxError)
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxError^>^ comparer
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        comparer : IComparer<ISyntaxError> -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        comparer : IComparer<ISyntaxError> -> bool

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.
comparer
Type: System.Collections.GenericIComparerISyntaxError
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxErrorsPositionChanged(Int32, Int32, Int32, Int32, IComparerISyntaxError)
See Also

Reference

SyntaxErrors Class
PositionChanged Overload
Alternet.Syntax Namespace


SyntaxErrors Properties

SyntaxErrors Properties

The SyntaxErrors type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListISyntaxError .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListISyntaxError .)
Top
See Also

Reference

SyntaxErrors Class
Alternet.Syntax Namespace


SyntaxErrorType Enumeration

SyntaxErrorType Enumeration
Defines types of syntax error.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SyntaxErrorType
Public Enumeration SyntaxErrorType
public enum class SyntaxErrorType
type SyntaxErrorType
Members
Member name | Value | Description
Error | 0 | Something not allowed by the rules of the language or other authority.
Warning | 1 | Something suspicious but allowed.
Info | 2 | Information that does not indicate a problem.
Hidden | 3 | Something that is an issue, as determined by some authority, but is not surfaced through normal means.
See Also

Reference

Alternet.Syntax Namespace


SyntaxNode Class

SyntaxNode Class
Represents a particular language element.
Inheritance Hierarchy
SystemObject
Alternet.SyntaxSyntaxNode

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SyntaxNode : ISyntaxNode, ICloneable
<SerializableAttribute>
Public Class SyntaxNode
    Implements ISyntaxNode, ICloneable
[SerializableAttribute]
public ref class SyntaxNode : ISyntaxNode,
    ICloneable
[<SerializableAttribute>]
type SyntaxNode =
    class
        interface ISyntaxNode
        interface ICloneable
    end

The SyntaxNode type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxNode | Initializes a new instance of the SyntaxNode class with default settings.
Public method | SyntaxNode(Point, String) | Initializes a new instance of the SyntaxNode class with specified parameters.
Public method | SyntaxNode(Point, String, Int32) | Initializes a new instance of the SyntaxNode class with specified parameters.
Public method | SyntaxNode(Point, String, Int32, SyntaxNodeOptions) | Initializes a new instance of the SyntaxNode class with specified parameters.
Top
Methods
 | Name | Description
Public method | AddAttribute | Creates a new ISyntaxAttribute and adds it to the attribute collection.
Public method | AddAttribute(ISyntaxAttribute) | Adds specified attribute to the attribute collection.
Public method | AddAttributes | Adds specified attributes to the attribute collection.
Public method | AddChild | Creates a new ISyntaxNode and adds it to the child collection.
Public method | AddChild(ISyntaxNode) | Adds specified node to the child collection.
Public method | AddChildren | Adds specified nodes to the child collection.
Public method | AddError | Creates a new ISyntaxError and add it to the error collection.
Public method | AddError(ISyntaxError) | Adds specified error to the error collection.
Public method | AddErrors | Adds specified errors to the error collection.
Public method | Assign | Copies contents from another ISyntaxNode object.
Public method | BlockDeleting | When implemented by a class, removes node's inside the specified rectangle.
Public method | Clear | Removes all elements from child nodes, attribute and error collections.
Public method | ClearAfter | Removes all elements from child nodes, attribute and error collections starting from given position. Specifies starting position
Public method | Clone | Creates a new object that is a copy of the current ISyntaxNode object.
Public method | ContainsErrors | Indicates whether node or its children contain errors.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindAttribute | Finds attribute by its name.
Public method | FindAttributes | Locates all attribute with given name.
Public method | FindNode(Int32) | Finds child node by its type.
Public method | FindNode(String) | Finds child node by its name.
Public method | FindNode(ISyntaxNode, IComparerISyntaxNode) | Finds child node by comparing nodes with the given object.
Public method | FindNodes | Locates all nodes matching search criteria.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndent(Int32, Int32) | Returns indentation level of this syntax node.
Public method | GetIndent(Int32, Int32, Boolean) | Returns indentation level of this syntax node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAsParent | Indicates whether the node has specified node as a parent node.
Public method | InsertChild | Inserts specified node to the child collection.
Public method | PositionChanged | Updates content of this ISyntaxNode.
Public method | Sort | Sorts the ISyntaxNode in the child list using the specified comparer.
Public method | ToString | Returns a String that represents the current SyntaxNode. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetAttrValue | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDescription | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetFileName | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetNamePosition | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetNameRange | (Defined by SyntaxNodeExtensions.)
Public Extension Method | IsValidReference | (Defined by SyntaxNodeExtensions.)
Top
Properties
 | Name | Description
Public property | AttributeCount | Represents number of attributes in the attribute collection.
Public property | AttributeList | Gets a list of attributes.
Public property | Attributes | Gets or sets an attribute collection in the form of array.
Public property | ChildCount | Represents number of children in the child collection.
Public property | ChildList | Gets a list of child nodes.
Public property | Childs | Gets or sets a collection of child nodes in the form of array.
Public property | ErrorCount | Represents number of syntax errors in the error collection.
Public property | ErrorList | Gets a list of syntax errors.
Public property | Errors | Gets or sets an error collection in the form of array.
Public property | HasAttributes | Indicates whether node has attributes.
Public property | HasChildren | Indicates whether node has children.
Public property | HasErrors | Indicates whether node has errors.
Public property | Index | Represents index of then node within its parent child collection.
Public property | Level | Represents node level inside SyntaxTree.
Public property | Name | Gets or sets node name.
Public property | NodeType | Gets or sets type of the node.
Public property | Options | Gets or sets node options that defines its behavior.
Public property | Parent | Gets or sets ISyntaxNode that holds this node in its child list.
Public property | Position | Gets or sets node position in the code text.
Public property | Range | Gets or sets node scope.
Public property | Root | Represents root level ISyntaxNode in the syntax tree.
Public property | Size | Gets or sets node dimension.
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxNode Constructor

SyntaxNode Constructor
Overload List
 | Name | Description
Public method | SyntaxNode | Initializes a new instance of the SyntaxNode class with default settings.
Public method | SyntaxNode(Point, String) | Initializes a new instance of the SyntaxNode class with specified parameters.
Public method | SyntaxNode(Point, String, Int32) | Initializes a new instance of the SyntaxNode class with specified parameters.
Public method | SyntaxNode(Point, String, Int32, SyntaxNodeOptions) | Initializes a new instance of the SyntaxNode class with specified parameters.
Top
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode Constructor

SyntaxNode Constructor
Initializes a new instance of the SyntaxNode class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxNode()
Public Sub New
public:
SyntaxNode()
new : unit -> SyntaxNode
See Also

Reference

SyntaxNode Class
SyntaxNode Overload
Alternet.Syntax Namespace


SyntaxNode Constructor (Point, String)

SyntaxNode Constructor (Point, String)
Initializes a new instance of the SyntaxNode class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxNode(
    Point position,
    string name
)
Public Sub New (
    position As Point,
    name As String
)
public:
SyntaxNode(
    Point position,
    String^ name
)
new :
        position : Point *
        name : string -> SyntaxNode

Parameters

position
Type: System.DrawingPoint
Specifies node Position.
name
Type: SystemString
Specifies node Name.
See Also

Reference

SyntaxNode Class
SyntaxNode Overload
Alternet.Syntax Namespace


SyntaxNode Constructor (Point, String, Int32)

SyntaxNode Constructor (Point, String, Int32)
Initializes a new instance of the SyntaxNode class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxNode(
    Point position,
    string name,
    int nodeType
)
Public Sub New (
    position As Point,
    name As String,
    nodeType As Integer
)
public:
SyntaxNode(
    Point position,
    String^ name,
    int nodeType
)
new :
        position : Point *
        name : string *
        nodeType : int -> SyntaxNode

Parameters

position
Type: System.DrawingPoint
Specifies node Position.
name
Type: SystemString
Specifies node Name.
nodeType
Type: SystemInt32
Specifies node type.
See Also

Reference

SyntaxNode Class
SyntaxNode Overload
Alternet.Syntax Namespace


SyntaxNode Constructor (Point, String, Int32, SyntaxNodeOptions)

SyntaxNode Constructor (Point, String, Int32, SyntaxNodeOptions)
Initializes a new instance of the SyntaxNode class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxNode(
    Point position,
    string name,
    int nodeType,
    SyntaxNodeOptions options
)
Public Sub New (
    position As Point,
    name As String,
    nodeType As Integer,
    options As SyntaxNodeOptions
)
public:
SyntaxNode(
    Point position,
    String^ name,
    int nodeType,
    SyntaxNodeOptions options
)
new :
        position : Point *
        name : string *
        nodeType : int *
        options : SyntaxNodeOptions -> SyntaxNode

Parameters

position
Type: System.DrawingPoint
Specifies node Position.
name
Type: SystemString
Specifies node Name.
nodeType
Type: SystemInt32
Specifies node type.
options
Type: Alternet.SyntaxSyntaxNodeOptions
Specifies node options.
See Also

Reference

SyntaxNode Class
SyntaxNode Overload
Alternet.Syntax Namespace


SyntaxNode Methods

SyntaxNode Methods

The SyntaxNode type exposes the following members.

Methods
 | Name | Description
Public method | AddAttribute | Creates a new ISyntaxAttribute and adds it to the attribute collection.
Public method | AddAttribute(ISyntaxAttribute) | Adds specified attribute to the attribute collection.
Public method | AddAttributes | Adds specified attributes to the attribute collection.
Public method | AddChild | Creates a new ISyntaxNode and adds it to the child collection.
Public method | AddChild(ISyntaxNode) | Adds specified node to the child collection.
Public method | AddChildren | Adds specified nodes to the child collection.
Public method | AddError | Creates a new ISyntaxError and add it to the error collection.
Public method | AddError(ISyntaxError) | Adds specified error to the error collection.
Public method | AddErrors | Adds specified errors to the error collection.
Public method | Assign | Copies contents from another ISyntaxNode object.
Public method | BlockDeleting | When implemented by a class, removes node's inside the specified rectangle.
Public method | Clear | Removes all elements from child nodes, attribute and error collections.
Public method | ClearAfter | Removes all elements from child nodes, attribute and error collections starting from given position. Specifies starting position
Public method | Clone | Creates a new object that is a copy of the current ISyntaxNode object.
Public method | ContainsErrors | Indicates whether node or its children contain errors.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindAttribute | Finds attribute by its name.
Public method | FindAttributes | Locates all attribute with given name.
Public method | FindNode(Int32) | Finds child node by its type.
Public method | FindNode(String) | Finds child node by its name.
Public method | FindNode(ISyntaxNode, IComparerISyntaxNode) | Finds child node by comparing nodes with the given object.
Public method | FindNodes | Locates all nodes matching search criteria.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndent(Int32, Int32) | Returns indentation level of this syntax node.
Public method | GetIndent(Int32, Int32, Boolean) | Returns indentation level of this syntax node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAsParent | Indicates whether the node has specified node as a parent node.
Public method | InsertChild | Inserts specified node to the child collection.
Public method | PositionChanged | Updates content of this ISyntaxNode.
Public method | Sort | Sorts the ISyntaxNode in the child list using the specified comparer.
Public method | ToString | Returns a String that represents the current SyntaxNode. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetAttrValue | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDescription | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetFileName | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetNamePosition | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetNameRange | (Defined by SyntaxNodeExtensions.)
Public Extension Method | IsValidReference | (Defined by SyntaxNodeExtensions.)
Top
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.AddAttribute Method

SyntaxNodeAddAttribute Method
Overload List
 | Name | Description
Public method | AddAttribute | Creates a new ISyntaxAttribute and adds it to the attribute collection.
Public method | AddAttribute(ISyntaxAttribute) | Adds specified attribute to the attribute collection.
Top
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.AddAttribute Method

SyntaxNodeAddAttribute Method
Creates a new ISyntaxAttribute and adds it to the attribute collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxAttribute AddAttribute()
Public Overridable Function AddAttribute As ISyntaxAttribute
public:
virtual ISyntaxAttribute^ AddAttribute()
abstract AddAttribute : unit -> ISyntaxAttribute
override AddAttribute : unit -> ISyntaxAttribute

Return Value

Type: ISyntaxAttribute
ISyntaxAttribute that is added.

Implements

ISyntaxNodeAddAttribute
See Also

Reference

SyntaxNode Class
AddAttribute Overload
Alternet.Syntax Namespace


SyntaxNode.AddAttribute Method (ISyntaxAttribute)

SyntaxNodeAddAttribute Method (ISyntaxAttribute)
Adds specified attribute to the attribute collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AddAttribute(
    ISyntaxAttribute attr
)
Public Overridable Function AddAttribute (
    attr As ISyntaxAttribute
) As Integer
public:
virtual int AddAttribute(
    ISyntaxAttribute^ attr
)
abstract AddAttribute :
        attr : ISyntaxAttribute -> int
override AddAttribute :
        attr : ISyntaxAttribute -> int

Parameters

attr
Type: Alternet.SyntaxISyntaxAttribute
Specifies ISyntaxAttribute to add.

Return Value

Type: Int32
Index of added attribute in the attribute collection.

Implements

ISyntaxNodeAddAttribute(ISyntaxAttribute)
See Also

Reference

SyntaxNode Class
AddAttribute Overload
Alternet.Syntax Namespace


SyntaxNode.AddAttributes Method

SyntaxNodeAddAttributes Method
Adds specified attributes to the attribute collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddAttributes(
    ISyntaxAttributes attrs
)
Public Overridable Sub AddAttributes (
    attrs As ISyntaxAttributes
)
public:
virtual void AddAttributes(
    ISyntaxAttributes^ attrs
)
abstract AddAttributes :
        attrs : ISyntaxAttributes -> unit
override AddAttributes :
        attrs : ISyntaxAttributes -> unit

Parameters

attrs
Type: Alternet.SyntaxISyntaxAttributes
Specifies list of attributes to add.

Implements

ISyntaxNodeAddAttributes(ISyntaxAttributes)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.AddChild Method

SyntaxNodeAddChild Method
Overload List
 | Name | Description
Public method | AddChild | Creates a new ISyntaxNode and adds it to the child collection.
Public method | AddChild(ISyntaxNode) | Adds specified node to the child collection.
Top
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.AddChild Method

SyntaxNodeAddChild Method
Creates a new ISyntaxNode and adds it to the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode AddChild()
Public Overridable Function AddChild As ISyntaxNode
public:
virtual ISyntaxNode^ AddChild()
abstract AddChild : unit -> ISyntaxNode
override AddChild : unit -> ISyntaxNode

Return Value

Type: ISyntaxNode
ISyntaxNode that is added.

Implements

ISyntaxNodeAddChild
See Also

Reference

SyntaxNode Class
AddChild Overload
Alternet.Syntax Namespace


SyntaxNode.AddChild Method (ISyntaxNode)

SyntaxNodeAddChild Method (ISyntaxNode)
Adds specified node to the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AddChild(
    ISyntaxNode node
)
Public Overridable Function AddChild (
    node As ISyntaxNode
) As Integer
public:
virtual int AddChild(
    ISyntaxNode^ node
)
abstract AddChild :
        node : ISyntaxNode -> int
override AddChild :
        node : ISyntaxNode -> int

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to add.

Return Value

Type: Int32
Index of added node within the child collection.

Implements

ISyntaxNodeAddChild(ISyntaxNode)
See Also

Reference

SyntaxNode Class
AddChild Overload
Alternet.Syntax Namespace


SyntaxNode.AddChildren Method

SyntaxNodeAddChildren Method
Adds specified nodes to the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddChildren(
    ISyntaxNodes nodes
)
Public Overridable Sub AddChildren (
    nodes As ISyntaxNodes
)
public:
virtual void AddChildren(
    ISyntaxNodes^ nodes
)
abstract AddChildren :
        nodes : ISyntaxNodes -> unit
override AddChildren :
        nodes : ISyntaxNodes -> unit

Parameters

nodes
Type: Alternet.SyntaxISyntaxNodes
Specifies list of nodes to add.

Implements

ISyntaxNodeAddChildren(ISyntaxNodes)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.AddError Method

SyntaxNodeAddError Method
Overload List
 | Name | Description
Public method | AddError | Creates a new ISyntaxError and add it to the error collection.
Public method | AddError(ISyntaxError) | Adds specified error to the error collection.
Top
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.AddError Method

SyntaxNodeAddError Method
Creates a new ISyntaxError and add it to the error collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxError AddError()
Public Overridable Function AddError As ISyntaxError
public:
virtual ISyntaxError^ AddError()
abstract AddError : unit -> ISyntaxError
override AddError : unit -> ISyntaxError

Return Value

Type: ISyntaxError
ISyntaxError that is added.

Implements

ISyntaxNodeAddError
See Also

Reference

SyntaxNode Class
AddError Overload
Alternet.Syntax Namespace


SyntaxNode.AddError Method (ISyntaxError)

SyntaxNodeAddError Method (ISyntaxError)
Adds specified error to the error collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AddError(
    ISyntaxError err
)
Public Overridable Function AddError (
    err As ISyntaxError
) As Integer
public:
virtual int AddError(
    ISyntaxError^ err
)
abstract AddError :
        err : ISyntaxError -> int
override AddError :
        err : ISyntaxError -> int

Parameters

err
Type: Alternet.SyntaxISyntaxError
Specifies ISyntaxError to add.

Return Value

Type: Int32
Number of added error in the error collection.

Implements

ISyntaxNodeAddError(ISyntaxError)
See Also

Reference

SyntaxNode Class
AddError Overload
Alternet.Syntax Namespace


SyntaxNode.AddErrors Method

SyntaxNodeAddErrors Method
Adds specified errors to the error collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddErrors(
    ISyntaxErrors errs
)
Public Overridable Sub AddErrors (
    errs As ISyntaxErrors
)
public:
virtual void AddErrors(
    ISyntaxErrors^ errs
)
abstract AddErrors :
        errs : ISyntaxErrors -> unit
override AddErrors :
        errs : ISyntaxErrors -> unit

Parameters

errs
Type: Alternet.SyntaxISyntaxErrors
Specifies list of errors to add.

Implements

ISyntaxNodeAddErrors(ISyntaxErrors)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Assign Method

SyntaxNodeAssign Method
Copies contents from another ISyntaxNode object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ISyntaxNode source
)
Public Overridable Sub Assign (
    source As ISyntaxNode
)
public:
virtual void Assign(
    ISyntaxNode^ source
)
abstract Assign :
        source : ISyntaxNode -> unit
override Assign :
        source : ISyntaxNode -> unit

Parameters

source
Type: Alternet.SyntaxISyntaxNode

Implements

ISyntaxNodeAssign(ISyntaxNode)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.BlockDeleting Method

SyntaxNodeBlockDeleting Method
When implemented by a class, removes node's inside the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxNode> comparer
)
Public Overridable Function BlockDeleting (
    rect As Rectangle,
    comparer As IComparer(Of ISyntaxNode)
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxNode^>^ comparer
)
abstract BlockDeleting :
        rect : Rectangle *
        comparer : IComparer<ISyntaxNode> -> bool
override BlockDeleting :
        rect : Rectangle *
        comparer : IComparer<ISyntaxNode> -> bool

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove node's content.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Search criteria.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxNodeBlockDeleting(Rectangle, IComparerISyntaxNode)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Clear Method

SyntaxNodeClear Method
Removes all elements from child nodes, attribute and error collections.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ISyntaxNodeClear
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.ClearAfter Method

SyntaxNodeClearAfter Method
Removes all elements from child nodes, attribute and error collections starting from given position. Specifies starting position

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearAfter(
    Point position
)
Public Sub ClearAfter (
    position As Point
)
public:
virtual void ClearAfter(
    Point position
) sealed
abstract ClearAfter :
        position : Point -> unit
override ClearAfter :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint

Implements

ISyntaxNodeClearAfter(Point)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Clone Method

SyntaxNodeClone Method
Creates a new object that is a copy of the current ISyntaxNode object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
A new instance of System.Object that is the memberwise clone of the current SyntaxNode object.

Implements

ICloneableClone
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.ContainsErrors Method

SyntaxNodeContainsErrors Method
Indicates whether node or its children contain errors.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsErrors()
Public Function ContainsErrors As Boolean
public:
virtual bool ContainsErrors() sealed
abstract ContainsErrors : unit -> bool
override ContainsErrors : unit -> bool

Return Value

Type: Boolean

Implements

ISyntaxNodeContainsErrors
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.FindAttribute Method

SyntaxNodeFindAttribute Method
Finds attribute by its name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxAttribute FindAttribute(
    string name
)
Public Overridable Function FindAttribute (
    name As String
) As ISyntaxAttribute
public:
virtual ISyntaxAttribute^ FindAttribute(
    String^ name
)
abstract FindAttribute :
        name : string -> ISyntaxAttribute
override FindAttribute :
        name : string -> ISyntaxAttribute

Parameters

name
Type: SystemString
Specifies name of attribute.

Return Value

Type: ISyntaxAttribute
First occurrence of ISyntaxAttribute with specified name.

Implements

ISyntaxNodeFindAttribute(String)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.FindAttributes Method

SyntaxNodeFindAttributes Method
Locates all attribute with given name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxAttribute[] FindAttributes(
    string name
)
Public Overridable Function FindAttributes (
    name As String
) As ISyntaxAttribute()
public:
virtual array<ISyntaxAttribute^>^ FindAttributes(
    String^ name
)
abstract FindAttributes :
        name : string -> ISyntaxAttribute[]
override FindAttributes :
        name : string -> ISyntaxAttribute[]

Parameters

name
Type: SystemString
Specifies name of attribute.

Return Value

Type: ISyntaxAttribute
Array ISyntaxAttribute with specified name.

Implements

ISyntaxNodeFindAttributes(String)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.FindNode Method

SyntaxNodeFindNode Method
Overload List
 | Name | Description
Public method | FindNode(Int32) | Finds child node by its type.
Public method | FindNode(String) | Finds child node by its name.
Public method | FindNode(ISyntaxNode, IComparerISyntaxNode) | Finds child node by comparing nodes with the given object.
Top
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.FindNode Method (Int32)

SyntaxNodeFindNode Method (Int32)
Finds child node by its type.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode FindNode(
    int nodeType
)
Public Overridable Function FindNode (
    nodeType As Integer
) As ISyntaxNode
public:
virtual ISyntaxNode^ FindNode(
    int nodeType
)
abstract FindNode :
        nodeType : int -> ISyntaxNode
override FindNode :
        nodeType : int -> ISyntaxNode

Parameters

nodeType
Type: SystemInt32
Specifies type of node.

Return Value

Type: ISyntaxNode
First occurrence of ISyntaxNode with specified type.

Implements

ISyntaxNodeFindNode(Int32)
See Also

Reference

SyntaxNode Class
FindNode Overload
Alternet.Syntax Namespace


SyntaxNode.FindNode Method (String)

SyntaxNodeFindNode Method (String)
Finds child node by its name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode FindNode(
    string name
)
Public Overridable Function FindNode (
    name As String
) As ISyntaxNode
public:
virtual ISyntaxNode^ FindNode(
    String^ name
)
abstract FindNode :
        name : string -> ISyntaxNode
override FindNode :
        name : string -> ISyntaxNode

Parameters

name
Type: SystemString
Specifies name of node.

Return Value

Type: ISyntaxNode
First occurrence of ISyntaxNode with specified name.

Implements

ISyntaxNodeFindNode(String)
See Also

Reference

SyntaxNode Class
FindNode Overload
Alternet.Syntax Namespace


SyntaxNode.FindNode Method (ISyntaxNode, IComparer(ISyntaxNode))

SyntaxNodeFindNode Method (ISyntaxNode, IComparerISyntaxNode)
Finds child node by comparing nodes with the given object.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode FindNode(
    ISyntaxNode node,
    IComparer<ISyntaxNode> comparer
)
Public Overridable Function FindNode (
    node As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode)
) As ISyntaxNode
public:
virtual ISyntaxNode^ FindNode(
    ISyntaxNode^ node,
    IComparer<ISyntaxNode^>^ comparer
)
abstract FindNode :
        node : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> -> ISyntaxNode
override FindNode :
        node : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to locate.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted child collection.

Return Value

Type: ISyntaxNode
ISyntaxNode that is located.

Implements

ISyntaxNodeFindNode(ISyntaxNode, IComparerISyntaxNode)
See Also

Reference

SyntaxNode Class
FindNode Overload
Alternet.Syntax Namespace


SyntaxNode.FindNodes Method

SyntaxNodeFindNodes Method
Locates all nodes matching search criteria.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FindNodes(
    ISyntaxNode obj,
    IComparer<ISyntaxNode> comparer,
    ISyntaxNodes nodes
)
Public Overridable Sub FindNodes (
    obj As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode),
    nodes As ISyntaxNodes
)
public:
virtual void FindNodes(
    ISyntaxNode^ obj,
    IComparer<ISyntaxNode^>^ comparer,
    ISyntaxNodes^ nodes
)
abstract FindNodes :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> *
        nodes : ISyntaxNodes -> unit
override FindNodes :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> *
        nodes : ISyntaxNodes -> unit

Parameters

obj
Type: Alternet.SyntaxISyntaxNode
Specifies node to locate.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted node collection.
nodes
Type: Alternet.SyntaxISyntaxNodes
List of located nodes.

Implements

ISyntaxNodeFindNodes(ISyntaxNode, IComparerISyntaxNode, ISyntaxNodes)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.GetIndent Method

SyntaxNodeGetIndent Method
Overload List
 | Name | Description
Public method | GetIndent(Int32, Int32) | Returns indentation level of this syntax node.
Public method | GetIndent(Int32, Int32, Boolean) | Returns indentation level of this syntax node.
Top
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.GetIndent Method (Int32, Int32)

SyntaxNodeGetIndent Method (Int32, Int32)
Returns indentation level of this syntax node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetIndent(
    int index,
    int indent
)
Public Overridable Function GetIndent (
    index As Integer,
    indent As Integer
) As Integer
public:
virtual int GetIndent(
    int index,
    int indent
)
abstract GetIndent :
        index : int *
        indent : int -> int
override GetIndent :
        index : int *
        indent : int -> int

Parameters

index
Type: SystemInt32
Specifies line to obtain indentation level.
indent
Type: SystemInt32
Default value of indentation level.

Return Value

Type: Int32
Indentation level of the node at the specified position.

Implements

ISyntaxNodeGetIndent(Int32, Int32)
See Also

Reference

SyntaxNode Class
GetIndent Overload
Alternet.Syntax Namespace


SyntaxNode.GetIndent Method (Int32, Int32, Boolean)

SyntaxNodeGetIndent Method (Int32, Int32, Boolean)
Returns indentation level of this syntax node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetIndent(
    int index,
    int indent,
    out bool actualPosition
)
Public Overridable Function GetIndent (
    index As Integer,
    indent As Integer,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int GetIndent(
    int index,
    int indent,
    [OutAttribute] bool% actualPosition
)
abstract GetIndent :
        index : int *
        indent : int *
        actualPosition : bool byref -> int
override GetIndent :
        index : int *
        indent : int *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies line to obtain indentation level.
indent
Type: SystemInt32
Default value of indentation level.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level of the node at the specified position.

Implements

ISyntaxNodeGetIndent(Int32, Int32, Boolean)
See Also

Reference

SyntaxNode Class
GetIndent Overload
Alternet.Syntax Namespace


SyntaxNode.HasAsParent Method

SyntaxNodeHasAsParent Method
Indicates whether the node has specified node as a parent node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasAsParent(
    ISyntaxNode node
)
Public Overridable Function HasAsParent (
    node As ISyntaxNode
) As Boolean
public:
virtual bool HasAsParent(
    ISyntaxNode^ node
)
abstract HasAsParent :
        node : ISyntaxNode -> bool
override HasAsParent :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Node to test.

Return Value

Type: Boolean
True if node or one of its parents has a given node as a parent; otherwise false.

Implements

ISyntaxNodeHasAsParent(ISyntaxNode)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.InsertChild Method

SyntaxNodeInsertChild Method
Inserts specified node to the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int InsertChild(
    ISyntaxNode node,
    IComparer<ISyntaxNode> comparer
)
Public Overridable Function InsertChild (
    node As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode)
) As Integer
public:
virtual int InsertChild(
    ISyntaxNode^ node,
    IComparer<ISyntaxNode^>^ comparer
)
abstract InsertChild :
        node : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> -> int
override InsertChild :
        node : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> -> int

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to insert.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted child collection.

Return Value

Type: Int32
Index of inserted node in the child collection.

Implements

ISyntaxNodeInsertChild(ISyntaxNode, IComparerISyntaxNode)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.PositionChanged Method

SyntaxNodePositionChanged Method
Updates content of this ISyntaxNode.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxNode> comparer
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    comparer As IComparer(Of ISyntaxNode)
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxNode^>^ comparer
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        comparer : IComparer<ISyntaxNode> -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        comparer : IComparer<ISyntaxNode> -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxNodePositionChanged(Int32, Int32, Int32, Int32, IComparerISyntaxNode)
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Sort Method

SyntaxNodeSort Method
Sorts the ISyntaxNode in the child list using the specified comparer.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Sort(
    IComparer<ISyntaxNode> comparer
)
Public Overridable Sub Sort (
    comparer As IComparer(Of ISyntaxNode)
)
public:
virtual void Sort(
    IComparer<ISyntaxNode^>^ comparer
)
abstract Sort :
        comparer : IComparer<ISyntaxNode> -> unit
override Sort :
        comparer : IComparer<ISyntaxNode> -> unit

Parameters

comparer
Type: System.Collections.GenericIComparerISyntaxNode
The IComparer implementation to use when comparing nodes.

Implements

ISyntaxNodeSort(IComparerISyntaxNode)
Remarks
This method is recursive, so if some node in the child collection has children they are also sorted.
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.ToString Method

SyntaxNodeToString Method
Returns a String that represents the current SyntaxNode.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String> that represents the current SyntaxNode.
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode Properties

SyntaxNode Properties

The SyntaxNode type exposes the following members.

Properties
 | Name | Description
Public property | AttributeCount | Represents number of attributes in the attribute collection.
Public property | AttributeList | Gets a list of attributes.
Public property | Attributes | Gets or sets an attribute collection in the form of array.
Public property | ChildCount | Represents number of children in the child collection.
Public property | ChildList | Gets a list of child nodes.
Public property | Childs | Gets or sets a collection of child nodes in the form of array.
Public property | ErrorCount | Represents number of syntax errors in the error collection.
Public property | ErrorList | Gets a list of syntax errors.
Public property | Errors | Gets or sets an error collection in the form of array.
Public property | HasAttributes | Indicates whether node has attributes.
Public property | HasChildren | Indicates whether node has children.
Public property | HasErrors | Indicates whether node has errors.
Public property | Index | Represents index of then node within its parent child collection.
Public property | Level | Represents node level inside SyntaxTree.
Public property | Name | Gets or sets node name.
Public property | NodeType | Gets or sets type of the node.
Public property | Options | Gets or sets node options that defines its behavior.
Public property | Parent | Gets or sets ISyntaxNode that holds this node in its child list.
Public property | Position | Gets or sets node position in the code text.
Public property | Range | Gets or sets node scope.
Public property | Root | Represents root level ISyntaxNode in the syntax tree.
Public property | Size | Gets or sets node dimension.
Top
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.AttributeCount Property

SyntaxNodeAttributeCount Property
Represents number of attributes in the attribute collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AttributeCount { get; }
Public Overridable ReadOnly Property AttributeCount As Integer
    Get
public:
virtual property int AttributeCount {
    int get ();
}
abstract AttributeCount : int with get
override AttributeCount : int with get

Property Value

Type: Int32

Implements

ISyntaxNodeAttributeCount
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.AttributeList Property

SyntaxNodeAttributeList Property
Gets a list of attributes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxAttributes AttributeList { get; }
Public Overridable ReadOnly Property AttributeList As ISyntaxAttributes
    Get
public:
virtual property ISyntaxAttributes^ AttributeList {
    ISyntaxAttributes^ get ();
}
abstract AttributeList : ISyntaxAttributes with get
override AttributeList : ISyntaxAttributes with get

Property Value

Type: ISyntaxAttributes

Implements

ISyntaxNodeAttributeList
Remarks
If there is no attributes, contains null reference.
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Attributes Property

SyntaxNodeAttributes Property
Gets or sets an attribute collection in the form of array.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxAttribute[] Attributes { get; set; }
Public Overridable Property Attributes As ISyntaxAttribute()
    Get
    Set
public:
virtual property array<ISyntaxAttribute^>^ Attributes {
    array<ISyntaxAttribute^>^ get ();
    void set (array<ISyntaxAttribute^>^ value);
}
abstract Attributes : ISyntaxAttribute[] with get, set
override Attributes : ISyntaxAttribute[] with get, set

Property Value

Type: ISyntaxAttribute

Implements

ISyntaxNodeAttributes
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.ChildCount Property

SyntaxNodeChildCount Property
Represents number of children in the child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ChildCount { get; }
Public Overridable ReadOnly Property ChildCount As Integer
    Get
public:
virtual property int ChildCount {
    int get ();
}
abstract ChildCount : int with get
override ChildCount : int with get

Property Value

Type: Int32

Implements

ISyntaxNodeChildCount
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.ChildList Property

SyntaxNodeChildList Property
Gets a list of child nodes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNodes ChildList { get; }
Public Overridable ReadOnly Property ChildList As ISyntaxNodes
    Get
public:
virtual property ISyntaxNodes^ ChildList {
    ISyntaxNodes^ get ();
}
abstract ChildList : ISyntaxNodes with get
override ChildList : ISyntaxNodes with get

Property Value

Type: ISyntaxNodes

Implements

ISyntaxNodeChildList
Remarks
If there is no child nodes, contains null reference.
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Childs Property

SyntaxNodeChilds Property
Gets or sets a collection of child nodes in the form of array.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode[] Childs { get; set; }
Public Overridable Property Childs As ISyntaxNode()
    Get
    Set
public:
virtual property array<ISyntaxNode^>^ Childs {
    array<ISyntaxNode^>^ get ();
    void set (array<ISyntaxNode^>^ value);
}
abstract Childs : ISyntaxNode[] with get, set
override Childs : ISyntaxNode[] with get, set

Property Value

Type: ISyntaxNode

Implements

ISyntaxNodeChilds
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.ErrorCount Property

SyntaxNodeErrorCount Property
Represents number of syntax errors in the error collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ErrorCount { get; }
Public Overridable ReadOnly Property ErrorCount As Integer
    Get
public:
virtual property int ErrorCount {
    int get ();
}
abstract ErrorCount : int with get
override ErrorCount : int with get

Property Value

Type: Int32

Implements

ISyntaxNodeErrorCount
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.ErrorList Property

SyntaxNodeErrorList Property
Gets a list of syntax errors.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxErrors ErrorList { get; }
Public Overridable ReadOnly Property ErrorList As ISyntaxErrors
    Get
public:
virtual property ISyntaxErrors^ ErrorList {
    ISyntaxErrors^ get ();
}
abstract ErrorList : ISyntaxErrors with get
override ErrorList : ISyntaxErrors with get

Property Value

Type: ISyntaxErrors

Implements

ISyntaxNodeErrorList
Remarks
If there is no errors, contains null reference.
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Errors Property

SyntaxNodeErrors Property
Gets or sets an error collection in the form of array.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxError[] Errors { get; set; }
Public Overridable Property Errors As ISyntaxError()
    Get
    Set
public:
virtual property array<ISyntaxError^>^ Errors {
    array<ISyntaxError^>^ get ();
    void set (array<ISyntaxError^>^ value);
}
abstract Errors : ISyntaxError[] with get, set
override Errors : ISyntaxError[] with get, set

Property Value

Type: ISyntaxError

Implements

ISyntaxNodeErrors
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.HasAttributes Property

SyntaxNodeHasAttributes Property
Indicates whether node has attributes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasAttributes { get; }
Public Overridable ReadOnly Property HasAttributes As Boolean
    Get
public:
virtual property bool HasAttributes {
    bool get ();
}
abstract HasAttributes : bool with get
override HasAttributes : bool with get

Property Value

Type: Boolean

Implements

ISyntaxNodeHasAttributes
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.HasChildren Property

SyntaxNodeHasChildren Property
Indicates whether node has children.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasChildren { get; }
Public Overridable ReadOnly Property HasChildren As Boolean
    Get
public:
virtual property bool HasChildren {
    bool get ();
}
abstract HasChildren : bool with get
override HasChildren : bool with get

Property Value

Type: Boolean

Implements

ISyntaxNodeHasChildren
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.HasErrors Property

SyntaxNodeHasErrors Property
Indicates whether node has errors.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasErrors { get; }
Public Overridable ReadOnly Property HasErrors As Boolean
    Get
public:
virtual property bool HasErrors {
    bool get ();
}
abstract HasErrors : bool with get
override HasErrors : bool with get

Property Value

Type: Boolean

Implements

ISyntaxNodeHasErrors
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Index Property

SyntaxNodeIndex Property
Represents index of then node within its parent child collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Index { get; }
Public Overridable ReadOnly Property Index As Integer
    Get
public:
virtual property int Index {
    int get ();
}
abstract Index : int with get
override Index : int with get

Property Value

Type: Int32

Implements

ISyntaxNodeIndex
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Level Property

SyntaxNodeLevel Property
Represents node level inside SyntaxTree.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Level { get; }
Public Overridable ReadOnly Property Level As Integer
    Get
public:
virtual property int Level {
    int get ();
}
abstract Level : int with get
override Level : int with get

Property Value

Type: Int32

Implements

ISyntaxNodeLevel
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Name Property

SyntaxNodeName Property
Gets or sets node name.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ISyntaxNodeName
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.NodeType Property

SyntaxNodeNodeType Property
Gets or sets type of the node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int NodeType { get; set; }
Public Overridable Property NodeType As Integer
    Get
    Set
public:
virtual property int NodeType {
    int get ();
    void set (int value);
}
abstract NodeType : int with get, set
override NodeType : int with get, set

Property Value

Type: Int32

Implements

ISyntaxNodeNodeType
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Options Property

SyntaxNodeOptions Property
Gets or sets node options that defines its behavior.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SyntaxNodeOptions Options { get; set; }
Public Overridable Property Options As SyntaxNodeOptions
    Get
    Set
public:
virtual property SyntaxNodeOptions Options {
    SyntaxNodeOptions get ();
    void set (SyntaxNodeOptions value);
}
abstract Options : SyntaxNodeOptions with get, set
override Options : SyntaxNodeOptions with get, set

Property Value

Type: SyntaxNodeOptions

Implements

ISyntaxNodeOptions
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Parent Property

SyntaxNodeParent Property
Gets or sets ISyntaxNode that holds this node in its child list.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode Parent { get; set; }
Public Overridable Property Parent As ISyntaxNode
    Get
    Set
public:
virtual property ISyntaxNode^ Parent {
    ISyntaxNode^ get ();
    void set (ISyntaxNode^ value);
}
abstract Parent : ISyntaxNode with get, set
override Parent : ISyntaxNode with get, set

Property Value

Type: ISyntaxNode

Implements

ISyntaxNodeParent
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Position Property

SyntaxNodePosition Property
Gets or sets node position in the code text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point Position { get; set; }
Public Overridable Property Position As Point
    Get
    Set
public:
virtual property Point Position {
    Point get ();
    void set (Point value);
}
abstract Position : Point with get, set
override Position : Point with get, set

Property Value

Type: Point

Implements

ISyntaxNodePosition
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Range Property

SyntaxNodeRange Property
Gets or sets node scope.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange Range { get; set; }
Public Overridable Property Range As IRange
    Get
    Set
public:
virtual property IRange^ Range {
    IRange^ get ();
    void set (IRange^ value);
}
abstract Range : IRange with get, set
override Range : IRange with get, set

Property Value

Type: IRange

Implements

ISyntaxNodeRange
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Root Property

SyntaxNodeRoot Property
Represents root level ISyntaxNode in the syntax tree.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode Root { get; }
Public Overridable ReadOnly Property Root As ISyntaxNode
    Get
public:
virtual property ISyntaxNode^ Root {
    ISyntaxNode^ get ();
}
abstract Root : ISyntaxNode with get
override Root : ISyntaxNode with get

Property Value

Type: ISyntaxNode

Implements

ISyntaxNodeRoot
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNode.Size Property

SyntaxNodeSize Property
Gets or sets node dimension.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Size Size { get; set; }
Public Overridable Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get ();
    void set (Size value);
}
abstract Size : Size with get, set
override Size : Size with get, set

Property Value

Type: Size

Implements

ISyntaxNodeSize
See Also

Reference

SyntaxNode Class
Alternet.Syntax Namespace


SyntaxNodeOptions Enumeration

SyntaxNodeOptions Enumeration
Defines syntax node behavior. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum SyntaxNodeOptions
<FlagsAttribute>
Public Enumeration SyntaxNodeOptions
[FlagsAttribute]
public enum class SyntaxNodeOptions
[<FlagsAttribute>]
type SyntaxNodeOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Indentation | 1 | Specifies that syntax node increments indentation level.
BackIndentation | 2 | Specifies that syntax node decrements indentation level.
KeepIndentation | 4 | Specifies that syntax node preserves indentation level.
Outlining | 8 | Specifies that syntax node can be outlined.
CodeCompletion | 16 | Specifies that syntax node supports code completion functionality.
Reference | 32 | Specifies that syntax node is reference to the declaration.
See Also

Reference

Alternet.Syntax Namespace


SyntaxNodes Class

SyntaxNodes Class
Represents collection containing list of syntax nodes.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListISyntaxNode
Alternet.CommonSortList ISyntaxNode
Alternet.SyntaxSyntaxNodes

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SyntaxNodes : SortList<ISyntaxNode>,
    ISyntaxNodes, ISortList<ISyntaxNode>, IList<ISyntaxNode>,
    ICollection<ISyntaxNode>, IEnumerable<ISyntaxNode>, IEnumerable
<SerializableAttribute>
Public Class SyntaxNodes
    Inherits SortList(Of ISyntaxNode)
    Implements ISyntaxNodes, ISortList(Of ISyntaxNode),
    IList(Of ISyntaxNode), ICollection(Of ISyntaxNode), IEnumerable(Of ISyntaxNode),
    IEnumerable
[SerializableAttribute]
public ref class SyntaxNodes : public SortList<ISyntaxNode^>,
    ISyntaxNodes, ISortList<ISyntaxNode^>, IList<ISyntaxNode^>,
    ICollection<ISyntaxNode^>, IEnumerable<ISyntaxNode^>, IEnumerable
[<SerializableAttribute>]
type SyntaxNodes =
    class
        inherit SortList<ISyntaxNode>
        interface ISyntaxNodes
        interface ISortList<ISyntaxNode>
        interface IList<ISyntaxNode>
        interface ICollection<ISyntaxNode>
        interface IEnumerable<ISyntaxNode>
        interface IEnumerable
    end

The SyntaxNodes type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxNodes | Initializes a new instance of the SyntaxNodes class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListISyntaxNode .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListISyntaxNode .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListISyntaxNode .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListISyntaxNode .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxNode .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxNode .)
Public method | BlockDeleting | Removes all nodes from specified region.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListISyntaxNode .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListISyntaxNode .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListISyntaxNode .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListISyntaxNode .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxNode .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxNode .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxNode .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxNode .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxNode .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxNode .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxNode .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxNode .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListISyntaxNode .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListISyntaxNode .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListISyntaxNode .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxNode .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxNode .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListISyntaxNode .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListISyntaxNode .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxNode .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxNode .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Updates specified position by DeltaX and DeltaY values for any nodes in the collection.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListISyntaxNode .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxNode .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListISyntaxNode .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListISyntaxNode .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListISyntaxNode .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListISyntaxNode .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListISyntaxNode .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListISyntaxNode .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListISyntaxNode .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListISyntaxNode .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListISyntaxNode .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListISyntaxNode .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListISyntaxNode .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxNode | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxNode | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxNode, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListISyntaxNode .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListISyntaxNode .)
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxNodes Constructor

SyntaxNodes Constructor
Initializes a new instance of the SyntaxNodes class

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxNodes()
Public Sub New
public:
SyntaxNodes()
new : unit -> SyntaxNodes
See Also

Reference

SyntaxNodes Class
Alternet.Syntax Namespace


SyntaxNodes Methods

SyntaxNodes Methods

The SyntaxNodes type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListISyntaxNode .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListISyntaxNode .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListISyntaxNode .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListISyntaxNode .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxNode .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListISyntaxNode .)
Public method | BlockDeleting | Removes all nodes from specified region.
Public method | Clear | Removes all elements from the ListT. (Inherited from ListISyntaxNode .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListISyntaxNode .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListISyntaxNode .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListISyntaxNode .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxNode .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListISyntaxNode .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxNode .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxNode .)
Public method | FindExact(Object, Int32, IComparer) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindExact(T, Int32, IComparerT) | Finds the given object in the sorted list with assumption that sorted list do not have any duplicates. (Inherited from SortListT.)
Public method | FindFirst(Object, Int32, IComparer) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindFirst(T, Int32, IComparerT) | Finds the first occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxNode .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxNode .)
Public method | FindLast(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | FindLast(Object, Int32, IComparer) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLast(T, Int32, IComparerT) | Finds the last occurrence of the given object that satisfies searching criteria. (Inherited from SortListT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxNode .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxNode .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListISyntaxNode .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListISyntaxNode .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListISyntaxNode .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListISyntaxNode .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListISyntaxNode .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListISyntaxNode .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListISyntaxNode .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListISyntaxNode .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListISyntaxNode .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListISyntaxNode .)
Public method | NeedSort | Determines if the list needs sorting based on given criteria. (Inherited from SortListT.)
Public method | PositionChanged | Updates specified position by DeltaX and DeltaY values for any nodes in the collection.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListISyntaxNode .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListISyntaxNode .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListISyntaxNode .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListISyntaxNode .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListISyntaxNode .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListISyntaxNode .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListISyntaxNode .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListISyntaxNode .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListISyntaxNode .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListISyntaxNode .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListISyntaxNode .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListISyntaxNode .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListISyntaxNode .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfISyntaxNode | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstISyntaxNode | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementISyntaxNode, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

SyntaxNodes Class
Alternet.Syntax Namespace


SyntaxNodes.BlockDeleting Method

SyntaxNodesBlockDeleting Method
Removes all nodes from specified region.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxNode> comparer
)
Public Overridable Function BlockDeleting (
    rect As Rectangle,
    comparer As IComparer(Of ISyntaxNode)
) As Boolean
public:
virtual bool BlockDeleting(
    Rectangle rect,
    IComparer<ISyntaxNode^>^ comparer
)
abstract BlockDeleting :
        rect : Rectangle *
        comparer : IComparer<ISyntaxNode> -> bool
override BlockDeleting :
        rect : Rectangle *
        comparer : IComparer<ISyntaxNode> -> bool

Parameters

rect
Type: System.DrawingRectangle
Specifies rectangle to remove nodes from.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxNodesBlockDeleting(Rectangle, IComparerISyntaxNode)
See Also

Reference

SyntaxNodes Class
Alternet.Syntax Namespace


SyntaxNodes.PositionChanged Method

SyntaxNodesPositionChanged Method
Updates specified position by DeltaX and DeltaY values for any nodes in the collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxNode> comparer
)
Public Overridable Function PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    comparer As IComparer(Of ISyntaxNode)
) As Boolean
public:
virtual bool PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    IComparer<ISyntaxNode^>^ comparer
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        comparer : IComparer<ISyntaxNode> -> bool
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        comparer : IComparer<ISyntaxNode> -> bool

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Object that exposes a method to compare two objects.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxNodesPositionChanged(Int32, Int32, Int32, Int32, IComparerISyntaxNode)
See Also

Reference

SyntaxNodes Class
Alternet.Syntax Namespace


SyntaxNodes Properties

SyntaxNodes Properties

The SyntaxNodes type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListISyntaxNode .)
Public property | CompareIndex | Represents index of element that currently comparing. (Inherited from SortListT.)
Public property | Count | Gets the number of elements actually contained in the SortList. (Inherited from SortListT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListISyntaxNode .)
Top
See Also

Reference

SyntaxNodes Class
Alternet.Syntax Namespace


SyntaxOptions Enumeration

SyntaxOptions Enumeration
Defines possibilities of formatting Edit control's content. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum SyntaxOptions
<FlagsAttribute>
Public Enumeration SyntaxOptions
[FlagsAttribute]
public enum class SyntaxOptions
[<FlagsAttribute>]
type SyntaxOptions
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Outline | 1 | Specifies that information about outline sections within the text is available.
SmartIndent | 2 | Specifies that information about indent level of each line in the text is available.
CodeCompletion | 4 | Specifies that information about code completion for language elements within the text is available.
SyntaxErrors | 8 | Specifies that information about syntax errors within the text is available.
ReparseOnLineChange | 16 | Specifies that text should be reparsed when the current line changes.
QuickInfoTips | 32 | Specifies that text quick info tooltip should be displayed when mouse is moved over control.
AutoComplete | 64 | Specifies that parser will complete statements if possible.
FormatCase | 128 | Specifies that parser will change resword case.
FormatSpaces | 256 | Specifies that parser will format line spacing.
CodeCompletionTabs | 512 | Specifies that code completion can be filtered based on priority.
WorkInThread | 1024 | Specifies that code completion and code outlining tasks to be performed in separate thread.
EvaluateConditionals | 2048 | Specifies that code parser should evaluate conditional defines.
NotifyOnParse | 4096 | Specifies async/await pattern for code parsing.
OutlineBlocks | 8192 | Specifies that information about statement blocks within the text is available.
FormatOnLineChange | 16384 | Specifies that text should be formatted when the current line changes.
StructureGuideLines | 32768 | Specifies that information about guide lines within the text is available.
CodeFixes | 65536 | Specifies that information about code fixes within the text is available.
CodeRefactors | 131072 | Specifies that information about code fixes within the text is available.
See Also

Reference

Alternet.Syntax Namespace


SyntaxParser Class

SyntaxParser Class
Represents properties and methods to perform syntax analysis of the text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.SyntaxXmlParser

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxParser : Parser,
    ISyntaxParser, IParser, ILexer, INotify, IUpdate,
    IImport
Public Class SyntaxParser
    Inherits Parser
    Implements ISyntaxParser, IParser, ILexer, INotify,
    IUpdate, IImport
public ref class SyntaxParser : public Parser,
    ISyntaxParser, IParser, ILexer, INotify, IUpdate,
    IImport
type SyntaxParser =
    class
        inherit Parser
        interface ISyntaxParser
        interface IParser
        interface ILexer
        interface INotify
        interface IUpdate
        interface IImport
    end

The SyntaxParser type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxParser | Initializes a new instance of the SyntaxParser class with default settings.
Public method | SyntaxParser(IContainer) | Initializes a new instance of the SyntaxParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception.
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle.
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element.
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error.
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text.
Public method | FindDeclaration(Point) | Finds the declaration node at given position.
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position.
Public method | FindImplementations | Locates all implementations at given position and in the text.
Public method | FindReferences(Point) | Locates and highlights references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text.
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text.
Public method | FinishParsing | Commits parsing process.
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position.
Public method | GetAutoFormatNode | Gets syntax block node at specified position.
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error.
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position.
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range.
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter.
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter.
Public method | GetContentDividers | Gets list of content dividers.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment.
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment.
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position.
Public method | GetRangeAt(Point) | Gets IRange that contains given position.
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position.
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment.
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment.
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line.
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line.
Public method | GetSmartIndentString | Returns indentation string for specified line.
Public method | GetStructureGuideLines | Gets list of guide lines.
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing.
Public method | IsDeclaration | Indicates whether specified node represents declaration elements.
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor.
Public method | OnTextParsed | Raises TextParsed event.
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LexerParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides LexerParseText(Int32, Int32, String, Int32, Int32, Int32).)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position.
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse.
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse.
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting.
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position.
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position.
Public method | ReparseText | Reparses entire text.
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.
Public method | Reset | Resets SyntaxParser to the start position. (Overrides ParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value.
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value.
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value.
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value.
Public method | ResetParseInterval | Resets ParseInterval to the default value.
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value.
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method.
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree.
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted.
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted.
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted.
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted.
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules.
Public method | StartParsing | Prepares parser to parse the specified range of the text.
Public method | StopParsing | Aborts parsing process.
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing.
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type.
Public method | SupportsContentDividers | Indicates whether content dividers are supported.
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted.
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing.
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content.
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing.
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing.
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser.
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines.
Public property | FileName | Gets or sets file name of the file being parsed.
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior.
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing.
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread.
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed.
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method.
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Overrides LexerXmlScheme.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed.
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxParser Constructor

SyntaxParser Constructor
Overload List
 | Name | Description
Public method | SyntaxParser | Initializes a new instance of the SyntaxParser class with default settings.
Public method | SyntaxParser(IContainer) | Initializes a new instance of the SyntaxParser class with default settings.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser Constructor

SyntaxParser Constructor
Initializes a new instance of the SyntaxParser class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxParser()
Public Sub New
public:
SyntaxParser()
new : unit -> SyntaxParser
See Also

Reference

SyntaxParser Class
SyntaxParser Overload
Alternet.Syntax Namespace


SyntaxParser Constructor (IContainer)

SyntaxParser Constructor (IContainer)
Initializes a new instance of the SyntaxParser class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxParser(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
SyntaxParser(
    IContainer^ container
)
new :
        container : IContainer -> SyntaxParser

Parameters

container
Type: System.ComponentModelIContainer
See Also

Reference

SyntaxParser Class
SyntaxParser Overload
Alternet.Syntax Namespace


SyntaxParser Methods

SyntaxParser Methods

The SyntaxParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception.
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle.
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element.
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error.
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text.
Public method | FindDeclaration(Point) | Finds the declaration node at given position.
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position.
Public method | FindImplementations | Locates all implementations at given position and in the text.
Public method | FindReferences(Point) | Locates and highlights references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text.
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text.
Public method | FinishParsing | Commits parsing process.
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position.
Public method | GetAutoFormatNode | Gets syntax block node at specified position.
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error.
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position.
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range.
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter.
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter.
Public method | GetContentDividers | Gets list of content dividers.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment.
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment.
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position.
Public method | GetRangeAt(Point) | Gets IRange that contains given position.
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position.
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment.
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment.
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line.
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line.
Public method | GetSmartIndentString | Returns indentation string for specified line.
Public method | GetStructureGuideLines | Gets list of guide lines.
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing.
Public method | IsDeclaration | Indicates whether specified node represents declaration elements.
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor.
Public method | OnTextParsed | Raises TextParsed event.
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LexerParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides LexerParseText(Int32, Int32, String, Int32, Int32, Int32).)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position.
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse.
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse.
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting.
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position.
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position.
Public method | ReparseText | Reparses entire text.
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.
Public method | Reset | Resets SyntaxParser to the start position. (Overrides ParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value.
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value.
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value.
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value.
Public method | ResetParseInterval | Resets ParseInterval to the default value.
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value.
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method.
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree.
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted.
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted.
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted.
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted.
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted.
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules.
Public method | StartParsing | Prepares parser to parse the specified range of the text.
Public method | StopParsing | Aborts parsing process.
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing.
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type.
Public method | SupportsContentDividers | Indicates whether content dividers are supported.
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.Abort Method

SyntaxParserAbort Method
Aborts parsing process by raising StopParseException exception.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Abort()
Public Overridable Sub Abort
public:
virtual void Abort()
abstract Abort : unit -> unit
override Abort : unit -> unit

Implements

ISyntaxParserAbort
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.BlockDeleting Method

SyntaxParserBlockDeleting Method
Removes all nodes from the node collection which position in the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void BlockDeleting(
    Rectangle rect
)
Public Overridable Sub BlockDeleting (
    rect As Rectangle
)
public:
virtual void BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> unit
override BlockDeleting :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove syntax nodes.

Implements

ISyntaxParserBlockDeleting(Rectangle)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.CodeCompletion Method

SyntaxParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element.
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.CodeCompletion Method (String, StringItemInfo[], Point, CodeCompletionArgs)

SyntaxParserCodeCompletion Method (String, StringItemInfo, Point, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    CodeCompletionArgs e
)
Public Overridable Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    CodeCompletionArgs^ e
)
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs)
See Also

Reference

SyntaxParser Class
CodeCompletion Overload
Alternet.Syntax Namespace


SyntaxParser.CodeCompletion Method (String, StringItemInfo[], Point, Boolean, CodeCompletionArgs)

SyntaxParserCodeCompletion Method (String, StringItemInfo, Point, Boolean, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    bool useThread,
    CodeCompletionArgs e
)
Public Overridable Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    useThread As Boolean,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    bool useThread,
    CodeCompletionArgs^ e
)
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        useThread : bool *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        useThread : bool *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
useThread
Type: SystemBoolean
Specifies whether parser should perform the task in the separate thread.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs)
See Also

Reference

SyntaxParser Class
CodeCompletion Overload
Alternet.Syntax Namespace


SyntaxParser.CreateRepository Method

SyntaxParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionRepository CreateRepository()
Public Overridable Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository()
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.FindCodeFixes Method

SyntaxParserFindCodeFixes Method
Locates and highlights available code refactors for given syntax error.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FindCodeFixes(
    Point position,
    ISyntaxError error,
    bool allDocuments = false
)
Public Overridable Sub FindCodeFixes (
    position As Point,
    error As ISyntaxError,
    Optional allDocuments As Boolean = false
)
public:
virtual void FindCodeFixes(
    Point position,
    ISyntaxError^ error,
    bool allDocuments = false
)
abstract FindCodeFixes :
        position : Point *
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit
override FindCodeFixes :
        position : Point *
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit

Parameters

position
Type: System.DrawingPoint
Current position within the text.
error
Type: Alternet.SyntaxISyntaxError
Syntax error within the text.
allDocuments (Optional)
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Implements

ISyntaxParserFindCodeFixes(Point, ISyntaxError, Boolean)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.FindCodeRefactors Method

SyntaxParserFindCodeRefactors Method
Locates and highlights available code refactors at given position in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FindCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments = false
)
Public Overridable Sub FindCodeRefactors (
    startPos As Point,
    endPos As Point,
    Optional allDocuments As Boolean = false
)
public:
virtual void FindCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments = false
)
abstract FindCodeRefactors :
        startPos : Point *
        endPos : Point *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit
override FindCodeRefactors :
        startPos : Point *
        endPos : Point *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit

Parameters

startPos
Type: System.DrawingPoint
Start position within the text.
endPos
Type: System.DrawingPoint
End position within the text.
allDocuments (Optional)
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Implements

ISyntaxParserFindCodeRefactors(Point, Point, Boolean)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.FindDeclaration Method

SyntaxParserFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(Point) | Finds the declaration node at given position.
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.FindDeclaration Method (Point)

SyntaxParserFindDeclaration Method (Point)
Finds the declaration node at given position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SymbolLocation FindDeclaration(
    Point position
)
Public Overridable Function FindDeclaration (
    position As Point
) As SymbolLocation
public:
virtual SymbolLocation^ FindDeclaration(
    Point position
)
abstract FindDeclaration :
        position : Point -> SymbolLocation
override FindDeclaration :
        position : Point -> SymbolLocation

Parameters

position
Type: System.DrawingPoint
Specifies position to find a declaration.

Return Value

Type: SymbolLocation
SymbolLocation object that is found.

Implements

ISyntaxParserFindDeclaration(Point)
See Also

Reference

SyntaxParser Class
FindDeclaration Overload
Alternet.Syntax Namespace


SyntaxParser.FindDeclaration Method (String, Point)

SyntaxParserFindDeclaration Method (String, Point)
Finds the declaration node at given position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object FindDeclaration(
    string text,
    Point position
)
Public Overridable Function FindDeclaration (
    text As String,
    position As Point
) As Object
public:
virtual Object^ FindDeclaration(
    String^ text,
    Point position
)
abstract FindDeclaration :
        text : string *
        position : Point -> Object
override FindDeclaration :
        text : string *
        position : Point -> Object

Parameters

text
Type: SystemString
Contains string used to perform search.
position
Type: System.DrawingPoint
Specifies position to find node.

Return Value

Type: Object
ISyntaxNode node representing declaration.

Implements

ISyntaxParserFindDeclaration(String, Point)
See Also

Reference

SyntaxParser Class
FindDeclaration Overload
Alternet.Syntax Namespace


SyntaxParser.FindImplementations Method

SyntaxParserFindImplementations Method
Locates all implementations at given position and in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FindImplementations(
    Point position,
    IRangeList references,
    bool allDocuments = false
)
Public Overridable Function FindImplementations (
    position As Point,
    references As IRangeList,
    Optional allDocuments As Boolean = false
) As Integer
public:
virtual int FindImplementations(
    Point position,
    IRangeList^ references,
    bool allDocuments = false
)
abstract FindImplementations :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int
override FindImplementations :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
Retrieves references to found declaration.
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found references.

Implements

ISyntaxParserFindImplementations(Point, IRangeList, Boolean)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.FindReferences Method

SyntaxParserFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(Point) | Locates and highlights references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text.
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.FindReferences Method (Point)

SyntaxParserFindReferences Method (Point)
Locates and highlights references at given position in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FindReferences(
    Point position
)
Public Overridable Sub FindReferences (
    position As Point
)
public:
virtual void FindReferences(
    Point position
)
abstract FindReferences :
        position : Point -> unit
override FindReferences :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Implements

ISyntaxParserFindReferences(Point)
See Also

Reference

SyntaxParser Class
FindReferences Overload
Alternet.Syntax Namespace


SyntaxParser.FindReferences Method (ISyntaxNode, ISyntaxNodes)

SyntaxParserFindReferences Method (ISyntaxNode, ISyntaxNodes)
Locates all references to the node in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FindReferences(
    ISyntaxNode node,
    ISyntaxNodes references
)
Public Overridable Function FindReferences (
    node As ISyntaxNode,
    references As ISyntaxNodes
) As Integer
public:
virtual int FindReferences(
    ISyntaxNode^ node,
    ISyntaxNodes^ references
)
abstract FindReferences :
        node : ISyntaxNode *
        references : ISyntaxNodes -> int
override FindReferences :
        node : ISyntaxNode *
        references : ISyntaxNodes -> int

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to find references.
references
Type: Alternet.SyntaxISyntaxNodes
Retrieves references to node.

Return Value

Type: Int32
Number of found references.

Implements

ISyntaxParserFindReferences(ISyntaxNode, ISyntaxNodes)
See Also

Reference

SyntaxParser Class
FindReferences Overload
Alternet.Syntax Namespace


SyntaxParser.FindReferences Method (Point, IRangeList, Boolean)

SyntaxParserFindReferences Method (Point, IRangeList, Boolean)
Locates declaration at given position and finds all references to this declaration in the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FindReferences(
    Point position,
    IRangeList references,
    bool allDocuments = false
)
Public Overridable Function FindReferences (
    position As Point,
    references As IRangeList,
    Optional allDocuments As Boolean = false
) As Integer
public:
virtual int FindReferences(
    Point position,
    IRangeList^ references,
    bool allDocuments = false
)
abstract FindReferences :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int
override FindReferences :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
Retrieves references to found declaration.
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found references.

Implements

ISyntaxParserFindReferences(Point, IRangeList, Boolean)
See Also

Reference

SyntaxParser Class
FindReferences Overload
Alternet.Syntax Namespace


SyntaxParser.FinishParsing Method

SyntaxParserFinishParsing Method
Commits parsing process.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FinishParsing()
Public Overridable Sub FinishParsing
public:
virtual void FinishParsing()
abstract FinishParsing : unit -> unit
override FinishParsing : unit -> unit

Implements

ISyntaxParserFinishParsing
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetActiveStatementAt Method

SyntaxParserGetActiveStatementAt Method
Gets IRange that corresponds to the statement at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange GetActiveStatementAt(
    Point position
)
Public Overridable Function GetActiveStatementAt (
    position As Point
) As IRange
public:
virtual IRange^ GetActiveStatementAt(
    Point position
)
abstract GetActiveStatementAt :
        position : Point -> IRange
override GetActiveStatementAt :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.

Return Value

Type: IRange
Statement range at given position

Implements

ISyntaxParserGetActiveStatementAt(Point)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetAutoFormatNode Method

SyntaxParserGetAutoFormatNode Method
Gets syntax block node at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode GetAutoFormatNode(
    Point position,
    bool extended,
    out Point startPt
)
Public Overridable Function GetAutoFormatNode (
    position As Point,
    extended As Boolean,
    <OutAttribute> ByRef startPt As Point
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetAutoFormatNode(
    Point position,
    bool extended,
    [OutAttribute] Point% startPt
)
abstract GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode
override GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode

Parameters

position
Type: System.DrawingPoint
Position to check-up.
extended
Type: SystemBoolean
Specifies that search should be extended outside current scope
startPt
Type: System.DrawingPoint
Retrieves position of block node.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.

Implements

ISyntaxParserGetAutoFormatNode(Point, Boolean, Point)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetCodeFixes Method

SyntaxParserGetCodeFixes Method
Retrieves all code fixes available for the given syntax error.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<ICodeFix> GetCodeFixes(
    ISyntaxError error,
    bool allDocuments = false
)
Public Overridable Function GetCodeFixes (
    error As ISyntaxError,
    Optional allDocuments As Boolean = false
) As IList(Of ICodeFix)
public:
virtual IList<ICodeFix^>^ GetCodeFixes(
    ISyntaxError^ error,
    bool allDocuments = false
)
abstract GetCodeFixes :
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> IList<ICodeFix>
override GetCodeFixes :
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> IList<ICodeFix>

Parameters

error
Type: Alternet.SyntaxISyntaxError
Syntaxe error or warning
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: IListICodeFix
Collection of available code fixes.

Implements

ISyntaxParserGetCodeFixes(ISyntaxError, Boolean)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetCodeRefactors Method

SyntaxParserGetCodeRefactors Method
Overload List
 | Name | Description
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position.
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetCodeRefactors Method (Point, Boolean)

SyntaxParserGetCodeRefactors Method (Point, Boolean)
Retrieves all applicable refactors at given position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<ICodeRefactor> GetCodeRefactors(
    Point position,
    bool allDocuments
)
Public Overridable Function GetCodeRefactors (
    position As Point,
    allDocuments As Boolean
) As IList(Of ICodeRefactor)
public:
virtual IList<ICodeRefactor^>^ GetCodeRefactors(
    Point position,
    bool allDocuments
)
abstract GetCodeRefactors :
        position : Point *
        allDocuments : bool -> IList<ICodeRefactor>
override GetCodeRefactors :
        position : Point *
        allDocuments : bool -> IList<ICodeRefactor>

Parameters

position
Type: System.DrawingPoint
Given position
allDocuments
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Return Value

Type: IListICodeRefactor
Collection of available code refactors

Implements

ISyntaxParserGetCodeRefactors(Point, Boolean)
See Also

Reference

SyntaxParser Class
GetCodeRefactors Overload
Alternet.Syntax Namespace


SyntaxParser.GetCodeRefactors Method (Point, Point, Boolean)

SyntaxParserGetCodeRefactors Method (Point, Point, Boolean)
Retrieves all applicable refactors at given range.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<ICodeRefactor> GetCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments
)
Public Overridable Function GetCodeRefactors (
    startPos As Point,
    endPos As Point,
    allDocuments As Boolean
) As IList(Of ICodeRefactor)
public:
virtual IList<ICodeRefactor^>^ GetCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments
)
abstract GetCodeRefactors :
        startPos : Point *
        endPos : Point *
        allDocuments : bool -> IList<ICodeRefactor>
override GetCodeRefactors :
        startPos : Point *
        endPos : Point *
        allDocuments : bool -> IList<ICodeRefactor>

Parameters

startPos
Type: System.DrawingPoint
Star position within the text.
endPos
Type: System.DrawingPoint
End position within the text..
allDocuments
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Return Value

Type: IListICodeRefactor
Collection of available code refactors

Implements

ISyntaxParserGetCodeRefactors(Point, Point, Boolean)
See Also

Reference

SyntaxParser Class
GetCodeRefactors Overload
Alternet.Syntax Namespace


SyntaxParser.GetCompletionType Method

SyntaxParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter.
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetCompletionType Method (Char)

SyntaxParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CodeCompletionType GetCompletionType(
    char ch
)
Public Overridable Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
)
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

SyntaxParser Class
GetCompletionType Overload
Alternet.Syntax Namespace


SyntaxParser.GetCompletionType Method (CodeCompletionArgs)

SyntaxParserGetCompletionType Method (CodeCompletionArgs)
Obtains type of code completion window from specifies CodeCompletionArgs parameter.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CodeCompletionType GetCompletionType(
    CodeCompletionArgs e
)
Public Overridable Function GetCompletionType (
    e As CodeCompletionArgs
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    CodeCompletionArgs^ e
)
abstract GetCompletionType :
        e : CodeCompletionArgs -> CodeCompletionType
override GetCompletionType :
        e : CodeCompletionArgs -> CodeCompletionType

Parameters

e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data of code completion window.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

SyntaxParser Class
GetCompletionType Overload
Alternet.Syntax Namespace


SyntaxParser.GetContentDividers Method

SyntaxParserGetContentDividers Method
Gets list of content dividers.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetContentDividers(
    IList<int> dividers
)
Public Overridable Function GetContentDividers (
    dividers As IList(Of Integer)
) As Integer
public:
virtual int GetContentDividers(
    IList<int>^ dividers
)
abstract GetContentDividers :
        dividers : IList<int> -> int
override GetContentDividers :
        dividers : IList<int> -> int

Parameters

dividers
Type: System.Collections.GenericIListInt32

Return Value

Type: Int32

Implements

ISyntaxParserGetContentDividers(IListInt32)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetMultiLineComment Method

SyntaxParserGetMultiLineComment Method
Overload List
 | Name | Description
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment.
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetMultiLineComment Method (String, String)

SyntaxParserGetMultiLineComment Method (String, String)
Gets the start and symbols multi-line comment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetMultiLineComment(
    out string start,
    out string end
)
Public Overridable Function GetMultiLineComment (
    <OutAttribute> ByRef start As String,
    <OutAttribute> ByRef end As String
) As Boolean
public:
virtual bool GetMultiLineComment(
    [OutAttribute] String^% start,
    [OutAttribute] String^% end
)
abstract GetMultiLineComment :
        start : string byref *
        end : string byref -> bool
override GetMultiLineComment :
        start : string byref *
        end : string byref -> bool

Parameters

start
Type: SystemString
Start symbol of multi-line comment.
end
Type: SystemString
End symbol of multi-line comment.

Return Value

Type: Boolean
True if parser supports multi-line comment; otherwise false.

Implements

ISyntaxParserGetMultiLineComment(String, String)
See Also

Reference

SyntaxParser Class
GetMultiLineComment Overload
Alternet.Syntax Namespace


SyntaxParser.GetMultiLineComment Method (Point, String, String)

SyntaxParserGetMultiLineComment Method (Point, String, String)
Gets the start and symbols multi-line comment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetMultiLineComment(
    Point pos,
    out string start,
    out string end
)
Public Overridable Function GetMultiLineComment (
    pos As Point,
    <OutAttribute> ByRef start As String,
    <OutAttribute> ByRef end As String
) As Boolean
public:
virtual bool GetMultiLineComment(
    Point pos,
    [OutAttribute] String^% start,
    [OutAttribute] String^% end
)
abstract GetMultiLineComment :
        pos : Point *
        start : string byref *
        end : string byref -> bool
override GetMultiLineComment :
        pos : Point *
        start : string byref *
        end : string byref -> bool

Parameters

pos
Type: System.DrawingPoint
Position to check.
start
Type: SystemString
Start symbol of multi-line comment.
end
Type: SystemString
End symbol of multi-line comment.

Return Value

Type: Boolean
True if parser supports multi-line comment; otherwise false.

Implements

ISyntaxParserGetMultiLineComment(Point, String, String)
See Also

Reference

SyntaxParser Class
GetMultiLineComment Overload
Alternet.Syntax Namespace


SyntaxParser.GetNodeAt Method

SyntaxParserGetNodeAt Method
Gets ISyntaxNode that corresponds to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode GetNodeAt(
    Point position
)
Public Overridable Function GetNodeAt (
    position As Point
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetNodeAt(
    Point position
)
abstract GetNodeAt :
        position : Point -> ISyntaxNode
override GetNodeAt :
        position : Point -> ISyntaxNode

Parameters

position
Type: System.DrawingPoint
Position to find node.

Return Value

Type: ISyntaxNode
ISyntaxNode at specified position.

Implements

ISyntaxParserGetNodeAt(Point)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetRangeAt Method

SyntaxParserGetRangeAt Method
Overload List
 | Name | Description
Public method | GetRangeAt(Point) | Gets IRange that contains given position.
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetRangeAt Method (Point)

SyntaxParserGetRangeAt Method (Point)
Gets IRange that contains given position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange GetRangeAt(
    Point position
)
Public Overridable Function GetRangeAt (
    position As Point
) As IRange
public:
virtual IRange^ GetRangeAt(
    Point position
)
abstract GetRangeAt :
        position : Point -> IRange
override GetRangeAt :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.

Return Value

Type: IRange
IRange at specified position.

Implements

ISyntaxParserGetRangeAt(Point)
See Also

Reference

SyntaxParser Class
GetRangeAt Overload
Alternet.Syntax Namespace


SyntaxParser.GetRangeAt Method (Point, IList(IRange))

SyntaxParserGetRangeAt Method (Point, IListIRange)
Gets IRange that contains given position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange GetRangeAt(
    Point position,
    IList<IRange> ranges
)
Public Overridable Function GetRangeAt (
    position As Point,
    ranges As IList(Of IRange)
) As IRange
public:
virtual IRange^ GetRangeAt(
    Point position,
    IList<IRange^>^ ranges
)
abstract GetRangeAt :
        position : Point *
        ranges : IList<IRange> -> IRange
override GetRangeAt :
        position : Point *
        ranges : IList<IRange> -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.
ranges
Type: System.Collections.GenericIListIRange
List of begin/end ranges at the given position.

Return Value

Type: IRange
IRange at specified position.

Implements

ISyntaxParserGetRangeAt(Point, IListIRange)
See Also

Reference

SyntaxParser Class
GetRangeAt Overload
Alternet.Syntax Namespace


SyntaxParser.GetSingleLineComment Method

SyntaxParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment.
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetSingleLineComment Method

SyntaxParserGetSingleLineComment Method
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetSingleLineComment()
Public Overridable Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment()
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

SyntaxParser Class
GetSingleLineComment Overload
Alternet.Syntax Namespace


SyntaxParser.GetSingleLineComment Method (Point)

SyntaxParserGetSingleLineComment Method (Point)
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetSingleLineComment(
    Point pos
)
Public Overridable Function GetSingleLineComment (
    pos As Point
) As String
public:
virtual String^ GetSingleLineComment(
    Point pos
)
abstract GetSingleLineComment :
        pos : Point -> string
override GetSingleLineComment :
        pos : Point -> string

Parameters

pos
Type: System.DrawingPoint
Position to check.

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment(Point)
See Also

Reference

SyntaxParser Class
GetSingleLineComment Overload
Alternet.Syntax Namespace


SyntaxParser.GetSmartIndent Method

SyntaxParserGetSmartIndent Method
Overload List
 | Name | Description
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line.
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetSmartIndent Method (Int32, Boolean)

SyntaxParserGetSmartIndent Method (Int32, Boolean)
Returns indentation level of specified line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetSmartIndent(
    int index,
    bool autoIndent
)
Public Overridable Function GetSmartIndent (
    index As Integer,
    autoIndent As Boolean
) As Integer
public:
virtual int GetSmartIndent(
    int index,
    bool autoIndent
)
abstract GetSmartIndent :
        index : int *
        autoIndent : bool -> int
override GetSmartIndent :
        index : int *
        autoIndent : bool -> int

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.

Return Value

Type: Int32
Indentation level at line specified by index.

Implements

ISyntaxParserGetSmartIndent(Int32, Boolean)
See Also

Reference

SyntaxParser Class
GetSmartIndent Overload
Alternet.Syntax Namespace


SyntaxParser.GetSmartIndent Method (Int32, Boolean, Boolean)

SyntaxParserGetSmartIndent Method (Int32, Boolean, Boolean)
Returns indentation level of specified line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetSmartIndent(
    int index,
    bool autoIndent,
    out bool actualPosition
)
Public Overridable Function GetSmartIndent (
    index As Integer,
    autoIndent As Boolean,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int GetSmartIndent(
    int index,
    bool autoIndent,
    [OutAttribute] bool% actualPosition
)
abstract GetSmartIndent :
        index : int *
        autoIndent : bool *
        actualPosition : bool byref -> int
override GetSmartIndent :
        index : int *
        autoIndent : bool *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at line specified by index.

Implements

ISyntaxParserGetSmartIndent(Int32, Boolean, Boolean)
See Also

Reference

SyntaxParser Class
GetSmartIndent Overload
Alternet.Syntax Namespace


SyntaxParser.GetSmartIndentString Method

SyntaxParserGetSmartIndentString Method
Returns indentation string for specified line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
Public Overridable Function GetSmartIndentString (
    index As Integer,
    autoIndent As Boolean,
    useSpaces As Boolean,
    spacesInTab As Integer
) As String
public:
virtual String^ GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
abstract GetSmartIndentString :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string
override GetSmartIndentString :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.

Return Value

Type: String
Indentation text at line specified by index.

Implements

ISyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetStructureGuideLines Method

SyntaxParserGetStructureGuideLines Method
Gets list of guide lines.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetStructureGuideLines(
    IList<IRange> guideLines
)
Public Overridable Function GetStructureGuideLines (
    guideLines As IList(Of IRange)
) As Integer
public:
virtual int GetStructureGuideLines(
    IList<IRange^>^ guideLines
)
abstract GetStructureGuideLines :
        guideLines : IList<IRange> -> int
override GetStructureGuideLines :
        guideLines : IList<IRange> -> int

Parameters

guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.

Implements

ISyntaxParserGetStructureGuideLines(IListIRange)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.GetSyntaxErrors Method

SyntaxParserGetSyntaxErrors Method
Retrieves all syntax errors found while analyzing the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetSyntaxErrors(
    IList<ISyntaxError> errors
)
Public Overridable Function GetSyntaxErrors (
    errors As IList(Of ISyntaxError)
) As Integer
public:
virtual int GetSyntaxErrors(
    IList<ISyntaxError^>^ errors
)
abstract GetSyntaxErrors :
        errors : IList<ISyntaxError> -> int
override GetSyntaxErrors :
        errors : IList<ISyntaxError> -> int

Parameters

errors
Type: System.Collections.GenericIListISyntaxError
Retrieves a collection of syntax error.

Return Value

Type: Int32
Number of syntax errors that are found.

Implements

ISyntaxParserGetSyntaxErrors(IListISyntaxError)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.IsCodeCompletionChar Method

SyntaxParserIsCodeCompletionChar Method
Returns boolean value indicating that given character initializes a code completion procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Public Overridable Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
public:
virtual bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
)
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool
override IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
Given character.
style
Type: SystemByte
Specifies text style at cursor.
interval
Type: SystemInt32
Represents the delay, in milliseconds before displaying code completion window.

Return Value

Type: Boolean
True if given character is code completion character; otherwise false.

Implements

ISyntaxParserIsCodeCompletionChar(Char, Byte, Int32)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.IsDeclaration Method

SyntaxParserIsDeclaration Method
Indicates whether specified node represents declaration elements.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDeclaration(
    ISyntaxNode node
)
Public Overridable Function IsDeclaration (
    node As ISyntaxNode
) As Boolean
public:
virtual bool IsDeclaration(
    ISyntaxNode^ node
)
abstract IsDeclaration :
        node : ISyntaxNode -> bool
override IsDeclaration :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: Boolean
True if specified node represents declaration element; otherwise false.

Implements

ISyntaxParserIsDeclaration(ISyntaxNode)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.LoadFile Method

SyntaxParserLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.LoadFile Method (String)

SyntaxParserLoadFile Method (String)
Loads the contents of the specified file.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName
)
Public Overridable Function LoadFile (
    fileName As String
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool
override LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String)
See Also

Reference

SyntaxParser Class
LoadFile Overload
Alternet.Syntax Namespace


SyntaxParser.LoadFile Method (String, Encoding)

SyntaxParserLoadFile Method (String, Encoding)
Loads the contents of the specified file with specified encoding.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

SyntaxParser Class
LoadFile Overload
Alternet.Syntax Namespace


SyntaxParser.LoadStream Method

SyntaxParserLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.LoadStream Method (Stream)

SyntaxParserLoadStream Method (Stream)
Loads the contents of the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream
)
Public Overridable Function LoadStream (
    stream As Stream
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream
)
abstract LoadStream :
        stream : Stream -> bool
override LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream)
See Also

Reference

SyntaxParser Class
LoadStream Overload
Alternet.Syntax Namespace


SyntaxParser.LoadStream Method (TextReader)

SyntaxParserLoadStream Method (TextReader)
Loads the contents of the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader
)
Public Overridable Function LoadStream (
    reader As TextReader
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool
override LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(TextReader)
See Also

Reference

SyntaxParser Class
LoadStream Overload
Alternet.Syntax Namespace


SyntaxParser.LoadStream Method (Stream, Encoding)

SyntaxParserLoadStream Method (Stream, Encoding)
Loads the contents of the specified stream.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream, Encoding)
See Also

Reference

SyntaxParser Class
LoadStream Overload
Alternet.Syntax Namespace


SyntaxParser.OnTextChanged Method

SyntaxParserOnTextChanged Method
Responds to incremental change of the text in the editor.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnTextChanged(
    ITextUndo operation
)
Public Overridable Sub OnTextChanged (
    operation As ITextUndo
)
public:
virtual void OnTextChanged(
    ITextUndo^ operation
)
abstract OnTextChanged :
        operation : ITextUndo -> unit
override OnTextChanged :
        operation : ITextUndo -> unit

Parameters

operation
Type: Alternet.SyntaxITextUndo

Implements

ISyntaxParserOnTextChanged(ITextUndo)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.OnTextParsed Method

SyntaxParserOnTextParsed Method
Raises TextParsed event.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnTextParsed()
Public Overridable Sub OnTextParsed
public:
virtual void OnTextParsed()
abstract OnTextParsed : unit -> unit
override OnTextParsed : unit -> unit

Implements

ISyntaxParserOnTextParsed
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.Outline Method

SyntaxParserOutline Method
Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Outline(
    IList<IRange> ranges
)
Public Overridable Function Outline (
    ranges As IList(Of IRange)
) As Integer
public:
virtual int Outline(
    IList<IRange^>^ ranges
)
abstract Outline :
        ranges : IList<IRange> -> int
override Outline :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Retrieves IOutlineRange collection for outlined sections.

Return Value

Type: Int32
Number of outlined sections.

Implements

ISyntaxParserOutline(IListIRange)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ParseText Method

SyntaxParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LexerParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides LexerParseText(Int32, Int32, String, Int32, Int32, Int32).)
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

SyntaxParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

SyntaxParser Class
ParseText Overload
Alternet.Syntax Namespace


SyntaxParser.ParseText Method (Int32, Int32, String, Int32, Int32, Int32)

SyntaxParserParseText Method (Int32, Int32, String, Int32, Int32, Int32)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string s,
    ref int pos,
    ref int len,
    ref int token
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    s As String,
    ByRef pos As Integer,
    ByRef len As Integer,
    ByRef token As Integer
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ s,
    int% pos,
    int% len,
    int% token
) override
abstract ParseText :
        state : int *
        line : int *
        s : string *
        pos : int byref *
        len : int byref *
        token : int byref -> int
override ParseText :
        state : int *
        line : int *
        s : string *
        pos : int byref *
        len : int byref *
        token : int byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
s
Type: SystemString
Text to analyze.
pos
Type: SystemInt32
Starting position.
len
Type: SystemInt32
Integer value to receive length of parsed element.
token
Type: SystemInt32
Retrieves style of text being parsed.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, Int32, Int32, Int32)
ILexerParseText(Int32, Int32, String, Int32, Int32, Int32)
See Also

Reference

SyntaxParser Class
ParseText Overload
Alternet.Syntax Namespace


SyntaxParser.PositionChanged Method

SyntaxParserPositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxParserPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.Prepare Method

SyntaxParserPrepare Method
Overload List
 | Name | Description
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse.
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.Prepare Method (String, IStringList, PrepareReason)

SyntaxParserPrepare Method (String, IStringList, PrepareReason)
When implemented by a class, sets lines to parse.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Prepare(
    string fileName,
    IStringList lines,
    PrepareReason reason = PrepareReason.None
)
Public Sub Prepare (
    fileName As String,
    lines As IStringList,
    Optional reason As PrepareReason = PrepareReason.None
)
public:
virtual void Prepare(
    String^ fileName,
    IStringList^ lines,
    PrepareReason reason = PrepareReason::None
) sealed
abstract Prepare :
        fileName : string *
        lines : IStringList *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit
override Prepare :
        fileName : string *
        lines : IStringList *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit

Parameters

fileName
Type: SystemString
Filename to parse
lines
Type: Alternet.SyntaxIStringList
Strings to parse
reason (Optional)
Type: Alternet.SyntaxPrepareReason
Reason for this method to be called.

Implements

ISyntaxParserPrepare(String, IStringList, PrepareReason)
See Also

Reference

SyntaxParser Class
Prepare Overload
Alternet.Syntax Namespace


SyntaxParser.Prepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)

SyntaxParserPrepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)
Sets lines to parse.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Prepare(
    string fileName,
    IStringList lines,
    ISyntaxTree syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason.None
)
Public Overridable Sub Prepare (
    fileName As String,
    lines As IStringList,
    syntaxTree As ISyntaxTree,
    useThread As Boolean,
    Optional reason As PrepareReason = PrepareReason.None
)
public:
virtual void Prepare(
    String^ fileName,
    IStringList^ lines,
    ISyntaxTree^ syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason::None
)
abstract Prepare :
        fileName : string *
        lines : IStringList *
        syntaxTree : ISyntaxTree *
        useThread : bool *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit
override Prepare :
        fileName : string *
        lines : IStringList *
        syntaxTree : ISyntaxTree *
        useThread : bool *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit

Parameters

fileName
Type: SystemString
File to parse
lines
Type: Alternet.SyntaxIStringList
Strings to parse
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies current parser tree.
useThread
Type: SystemBoolean
Specifies whether parser should perform the task in the separate thread
reason (Optional)
Type: Alternet.SyntaxPrepareReason
Reason for this method to be called.

Implements

ISyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason)
See Also

Reference

SyntaxParser Class
Prepare Overload
Alternet.Syntax Namespace


SyntaxParser.ProcessAutoComplete Method

SyntaxParserProcessAutoComplete Method
Checks whether end-of-block code needs inserting.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ProcessAutoComplete(
    string text,
    Point position,
    out string code
)
Public Overridable Function ProcessAutoComplete (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessAutoComplete(
    String^ text,
    Point position,
    [OutAttribute] String^% code
)
abstract ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if autocompletion of end-of-block needed; otherwise false.

Implements

ISyntaxParserProcessAutoComplete(String, Point, String)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ProcessSnippetBody Method

SyntaxParserProcessSnippetBody Method
Checks whether snippet body code needs inserting.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ProcessSnippetBody(
    string text,
    Point position,
    out string code
)
Public Overridable Function ProcessSnippetBody (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessSnippetBody(
    String^ text,
    Point position,
    [OutAttribute] String^% code
)
abstract ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if snippet body code needed; otherwise false.

Implements

ISyntaxParserProcessSnippetBody(String, Point, String)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ReparseBlock Method

SyntaxParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position.
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ReparseBlock Method (Point)

SyntaxParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReparseBlock(
    Point position
)
Public Overridable Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
)
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

SyntaxParser Class
ReparseBlock Overload
Alternet.Syntax Namespace


SyntaxParser.ReparseBlock Method (Point, String, ISyntaxNode, CodeCompletionType)

SyntaxParserReparseBlock Method (Point, String, ISyntaxNode, CodeCompletionType)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReparseBlock(
    ref Point position,
    string text,
    out ISyntaxNode node,
    CodeCompletionType completionType
)
Public Overridable Function ReparseBlock (
    ByRef position As Point,
    text As String,
    <OutAttribute> ByRef node As ISyntaxNode,
    completionType As CodeCompletionType
) As Boolean
public:
virtual bool ReparseBlock(
    Point% position,
    String^ text,
    [OutAttribute] ISyntaxNode^% node,
    CodeCompletionType completionType
)
abstract ReparseBlock :
        position : Point byref *
        text : string *
        node : ISyntaxNode byref *
        completionType : CodeCompletionType -> bool
override ReparseBlock :
        position : Point byref *
        text : string *
        node : ISyntaxNode byref *
        completionType : CodeCompletionType -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.
text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Returns node corresponding to the block being reparsed.
completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion reason.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point, String, ISyntaxNode, CodeCompletionType)
See Also

Reference

SyntaxParser Class
ReparseBlock Overload
Alternet.Syntax Namespace


SyntaxParser.ReparseText Method

SyntaxParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text.
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ReparseText Method

SyntaxParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ReparseText()
Public Overridable Sub ReparseText
public:
virtual void ReparseText()
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

SyntaxParser Class
ReparseText Overload
Alternet.Syntax Namespace


SyntaxParser.ReparseText Method (Boolean)

SyntaxParserReparseText Method (Boolean)
Reparses entire text. Specifies whether parser should perform the task in the separate thread

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ReparseText(
    bool useThread
)
Public Overridable Sub ReparseText (
    useThread As Boolean
)
public:
virtual void ReparseText(
    bool useThread
)
abstract ReparseText :
        useThread : bool -> unit
override ReparseText :
        useThread : bool -> unit

Parameters

useThread
Type: SystemBoolean

Implements

ISyntaxParserReparseText(Boolean)
See Also

Reference

SyntaxParser Class
ReparseText Overload
Alternet.Syntax Namespace


SyntaxParser.ReparseText Method (Boolean, Int32, Int32)

SyntaxParserReparseText Method (Boolean, Int32, Int32)
Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ReparseText(
    bool useThread,
    int first,
    int last
)
Public Overridable Sub ReparseText (
    useThread As Boolean,
    first As Integer,
    last As Integer
)
public:
virtual void ReparseText(
    bool useThread,
    int first,
    int last
)
abstract ReparseText :
        useThread : bool *
        first : int *
        last : int -> unit
override ReparseText :
        useThread : bool *
        first : int *
        last : int -> unit

Parameters

useThread
Type: SystemBoolean
first
Type: SystemInt32
last
Type: SystemInt32

Implements

ISyntaxParserReparseText(Boolean, Int32, Int32)
See Also

Reference

SyntaxParser Class
ReparseText Overload
Alternet.Syntax Namespace


SyntaxParser.Reset Method

SyntaxParserReset Method
Overload List
 | Name | Description
Public method | Reset | Resets SyntaxParser to the start position. (Overrides ParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.Reset Method

SyntaxParserReset Method
Resets SyntaxParser to the start position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
IParserReset
See Also

Reference

SyntaxParser Class
Reset Overload
Alternet.Syntax Namespace


SyntaxParser.ResetAutoIndentChars Method

SyntaxParserResetAutoIndentChars Method
Resets AutoIndentChars to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetAutoIndentChars()
Public Overridable Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars()
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ResetCodeCompletionChars Method

SyntaxParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetCodeCompletionChars()
Public Overridable Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars()
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ResetCodeCompletionStopChars Method

SyntaxParserResetCodeCompletionStopChars Method
Resets CodeCompletionStopChars to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetCodeCompletionStopChars()
Public Overridable Sub ResetCodeCompletionStopChars
public:
virtual void ResetCodeCompletionStopChars()
abstract ResetCodeCompletionStopChars : unit -> unit
override ResetCodeCompletionStopChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionStopChars
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ResetOptions Method

SyntaxParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetOptions()
Public Overridable Sub ResetOptions
public:
virtual void ResetOptions()
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ResetParseInterval Method

SyntaxParserResetParseInterval Method
Resets ParseInterval to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetParseInterval()
Public Overridable Sub ResetParseInterval
public:
virtual void ResetParseInterval()
abstract ResetParseInterval : unit -> unit
override ResetParseInterval : unit -> unit

Implements

ISyntaxParserResetParseInterval
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ResetSmartFormatChars Method

SyntaxParserResetSmartFormatChars Method
Resets SmartFormatChars to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetSmartFormatChars()
Public Overridable Sub ResetSmartFormatChars
public:
virtual void ResetSmartFormatChars()
abstract ResetSmartFormatChars : unit -> unit
override ResetSmartFormatChars : unit -> unit

Implements

ISyntaxParserResetSmartFormatChars
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.RestoreSyntaxTree Method

SyntaxParserRestoreSyntaxTree Method
Restores syntax tree, stored by SaveSyntaxTree method.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RestoreSyntaxTree()
Public Overridable Sub RestoreSyntaxTree
public:
virtual void RestoreSyntaxTree()
abstract RestoreSyntaxTree : unit -> unit
override RestoreSyntaxTree : unit -> unit

Implements

ISyntaxParserRestoreSyntaxTree
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SaveSyntaxTree Method

SyntaxParserSaveSyntaxTree Method
Saves current syntax tree.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveSyntaxTree()
Public Sub SaveSyntaxTree
public:
virtual void SaveSyntaxTree() sealed
abstract SaveSyntaxTree : unit -> unit
override SaveSyntaxTree : unit -> unit

Implements

ISyntaxParserSaveSyntaxTree
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ShouldSerializeAutoIndentChars Method

SyntaxParserShouldSerializeAutoIndentChars Method
Indicates whether the AutoIndentChars property should be persisted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeAutoIndentChars()
Public Overridable Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars()
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if AutoIndentChars differs from its default value; otherwise false.
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ShouldSerializeCodeCompletionChars Method

SyntaxParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeCodeCompletionChars()
Public Overridable Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars()
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ShouldSerializeCodeCompletionStopChars Method

SyntaxParserShouldSerializeCodeCompletionStopChars Method
Indicates whether the CodeCompletionStopChars property should be persisted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeCodeCompletionStopChars()
Public Overridable Function ShouldSerializeCodeCompletionStopChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionStopChars()
abstract ShouldSerializeCodeCompletionStopChars : unit -> bool
override ShouldSerializeCodeCompletionStopChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionStopChars differs from its default value; otherwise false.
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ShouldSerializeOptions Method

SyntaxParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeOptions()
Public Overridable Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions()
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ShouldSerializeParseInterval Method

SyntaxParserShouldSerializeParseInterval Method
Indicates whether the ParseInterval property should be persisted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeParseInterval()
Public Overridable Function ShouldSerializeParseInterval As Boolean
public:
virtual bool ShouldSerializeParseInterval()
abstract ShouldSerializeParseInterval : unit -> bool
override ShouldSerializeParseInterval : unit -> bool

Return Value

Type: Boolean
True if ParseInterval differs from its default value; otherwise false.
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ShouldSerializeSmartFormatChars Method

SyntaxParserShouldSerializeSmartFormatChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeSmartFormatChars()
Public Overridable Function ShouldSerializeSmartFormatChars As Boolean
public:
virtual bool ShouldSerializeSmartFormatChars()
abstract ShouldSerializeSmartFormatChars : unit -> bool
override ShouldSerializeSmartFormatChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SmartFormat Method

SyntaxParserSmartFormat Method
Overload List
 | Name | Description
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SmartFormat Method (Point, Boolean, Int32, ITextUndoList, String)

SyntaxParserSmartFormat Method (Point, Boolean, Int32, ITextUndoList, String)
Formats block of text according to the parser rules.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SmartFormat(
    ref Point pos,
    bool useSpace,
    int spacesInTab,
    ITextUndoList operations,
    string key = ""
)
Public Overridable Function SmartFormat (
    ByRef pos As Point,
    useSpace As Boolean,
    spacesInTab As Integer,
    operations As ITextUndoList,
    Optional key As String = ""
) As Boolean
public:
virtual bool SmartFormat(
    Point% pos,
    bool useSpace,
    int spacesInTab,
    ITextUndoList^ operations,
    String^ key = L""
)
abstract SmartFormat :
        pos : Point byref *
        useSpace : bool *
        spacesInTab : int *
        operations : ITextUndoList *
        ?key : string
(* Defaults:
        let _key = defaultArg key ""
*)
-> bool
override SmartFormat :
        pos : Point byref *
        useSpace : bool *
        spacesInTab : int *
        operations : ITextUndoList *
        ?key : string
(* Defaults:
        let _key = defaultArg key ""
*)
-> bool

Parameters

pos
Type: System.DrawingPoint
Position of the text
useSpace
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
key (Optional)
Type: SystemString
Keystroke being typed.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserSmartFormat(Point, Boolean, Int32, ITextUndoList, String)
See Also

Reference

SyntaxParser Class
SmartFormat Overload
Alternet.Syntax Namespace


SyntaxParser.SmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)

SyntaxParserSmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)
Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SmartFormat(
    ref Point start,
    ref Point end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList operations
)
Public Overridable Function SmartFormat (
    ByRef start As Point,
    ByRef end As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    extended As Boolean,
    operations As ITextUndoList
) As Boolean
public:
virtual bool SmartFormat(
    Point% start,
    Point% end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList^ operations
)
abstract SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool
override SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool

Parameters

start
Type: System.DrawingPoint
end
Type: System.DrawingPoint
useSpaces
Type: SystemBoolean
spacesInTab
Type: SystemInt32
extended
Type: SystemBoolean
operations
Type: Alternet.SyntaxITextUndoList

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserSmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList)
See Also

Reference

SyntaxParser Class
SmartFormat Overload
Alternet.Syntax Namespace


SyntaxParser.SmartFormatLine Method

SyntaxParserSmartFormatLine Method
Overload List
 | Name | Description
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules.
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList)

SyntaxParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList)
Formats line according to the parser rules.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations
)
Public Overridable Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList
) As Integer
public:
virtual int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations
)
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList -> int
override SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.

Return Value

Type: Int32
Indentation level at given line.

Implements

ISyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList)
See Also

Reference

SyntaxParser Class
SmartFormatLine Overload
Alternet.Syntax Namespace


SyntaxParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList, Boolean)

SyntaxParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList, Boolean)
Formats line according to the parser rules.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations,
    out bool actualPosition
)
Public Overridable Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations,
    [OutAttribute] bool% actualPosition
)
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int
override SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at given line.

Implements

ISyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean)
See Also

Reference

SyntaxParser Class
SmartFormatLine Overload
Alternet.Syntax Namespace


SyntaxParser.StartParsing Method

SyntaxParserStartParsing Method
Prepares parser to parse the specified range of the text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StartParsing(
    string fileName,
    int first,
    int last
)
Public Overridable Sub StartParsing (
    fileName As String,
    first As Integer,
    last As Integer
)
public:
virtual void StartParsing(
    String^ fileName,
    int first,
    int last
)
abstract StartParsing :
        fileName : string *
        first : int *
        last : int -> unit
override StartParsing :
        fileName : string *
        first : int *
        last : int -> unit

Parameters

fileName
Type: SystemString
Filename to parse
first
Type: SystemInt32
Specifies first changed line in the source text.
last
Type: SystemInt32
Specifies last changed line in the source text.

Implements

ISyntaxParserStartParsing(String, Int32, Int32)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.StopParsing Method

SyntaxParserStopParsing Method
Aborts parsing process.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void StopParsing()
Public Overridable Sub StopParsing
public:
virtual void StopParsing()
abstract StopParsing : unit -> unit
override StopParsing : unit -> unit

Implements

ISyntaxParserStopParsing
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SupportsAsyncParsing Method

SyntaxParserSupportsAsyncParsing Method
Indicates whether parser supports async parsing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SupportsAsyncParsing()
Public Overridable Function SupportsAsyncParsing As Boolean
public:
virtual bool SupportsAsyncParsing()
abstract SupportsAsyncParsing : unit -> bool
override SupportsAsyncParsing : unit -> bool

Return Value

Type: Boolean

Implements

ISyntaxParserSupportsAsyncParsing
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SupportsCodeCompletionFiltering Method

SyntaxParserSupportsCodeCompletionFiltering Method
When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SupportsCodeCompletionFiltering(
    CodeCompletionType completionType
)
Public Overridable Function SupportsCodeCompletionFiltering (
    completionType As CodeCompletionType
) As Boolean
public:
virtual bool SupportsCodeCompletionFiltering(
    CodeCompletionType completionType
)
abstract SupportsCodeCompletionFiltering :
        completionType : CodeCompletionType -> bool
override SupportsCodeCompletionFiltering :
        completionType : CodeCompletionType -> bool

Parameters

completionType
Type: Alternet.SyntaxCodeCompletionType
Given code completion type.

Return Value

Type: Boolean
True if code completion output can be filtered; otherwise false.

Implements

ISyntaxParserSupportsCodeCompletionFiltering(CodeCompletionType)
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SupportsContentDividers Method

SyntaxParserSupportsContentDividers Method
Indicates whether content dividers are supported.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SupportsContentDividers()
Public Overridable Function SupportsContentDividers As Boolean
public:
virtual bool SupportsContentDividers()
abstract SupportsContentDividers : unit -> bool
override SupportsContentDividers : unit -> bool

Return Value

Type: Boolean
True if content dividers are supported; otherwise false.

Implements

ISyntaxParserSupportsContentDividers
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SupportsTextChanges Method

SyntaxParserSupportsTextChanges Method
Indicates whether parser supports incremental text changes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SupportsTextChanges()
Public Overridable Function SupportsTextChanges As Boolean
public:
virtual bool SupportsTextChanges()
abstract SupportsTextChanges : unit -> bool
override SupportsTextChanges : unit -> bool

Return Value

Type: Boolean

Implements

ISyntaxParserSupportsTextChanges
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser Properties

SyntaxParser Properties

The SyntaxParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted.
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing.
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content.
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing.
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing.
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser.
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines.
Public property | FileName | Gets or sets file name of the file being parsed.
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior.
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing.
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread.
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed.
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method.
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Overrides LexerXmlScheme.)
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.Aborted Property

SyntaxParserAborted Property
Gets or sets boolean variable indicating whether parsing process has been aborted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Aborted { get; set; }
Public Overridable Property Aborted As Boolean
    Get
    Set
public:
virtual property bool Aborted {
    bool get ();
    void set (bool value);
}
abstract Aborted : bool with get, set
override Aborted : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxParserAborted
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.AutoIndentChars Property

SyntaxParserAutoIndentChars Property
Gets or sets a collection of characters that initializes an indentation procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] AutoIndentChars { get; set; }
Public Overridable Property AutoIndentChars As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ AutoIndentChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract AutoIndentChars : char[] with get, set
override AutoIndentChars : char[] with get, set

Property Value

Type: Char

Implements

ISyntaxParserAutoIndentChars
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.CaseSensitive Property

SyntaxParserCaseSensitive Property
Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CaseSensitive { get; }
Public Overridable ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get ();
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.CodeCompletionChars Property

SyntaxParserCodeCompletionChars Property
Gets or sets a collection of characters that initializes a code completion procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] CodeCompletionChars { get; set; }
Public Overridable Property CodeCompletionChars As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ CodeCompletionChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract CodeCompletionChars : char[] with get, set
override CodeCompletionChars : char[] with get, set

Property Value

Type: Char

Implements

ISyntaxParserCodeCompletionChars
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.CodeCompletionStopChars Property

SyntaxParserCodeCompletionStopChars Property
Gets or sets a collection of characters that finalizes a code completion procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] CodeCompletionStopChars { get; set; }
Public Overridable Property CodeCompletionStopChars As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ CodeCompletionStopChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract CodeCompletionStopChars : char[] with get, set
override CodeCompletionStopChars : char[] with get, set

Property Value

Type: Char

Implements

ISyntaxParserCodeCompletionStopChars
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.CodeSnippets Property

SyntaxParserCodeSnippets Property
When implemented by a class, returns code snippets for the given parser.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetsProvider CodeSnippets { get; }
Public Overridable ReadOnly Property CodeSnippets As ICodeSnippetsProvider
    Get
public:
virtual property ICodeSnippetsProvider^ CodeSnippets {
    ICodeSnippetsProvider^ get ();
}
abstract CodeSnippets : ICodeSnippetsProvider with get
override CodeSnippets : ICodeSnippetsProvider with get

Property Value

Type: ICodeSnippetsProvider

Implements

ISyntaxParserCodeSnippets
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.CompletionRepository Property

SyntaxParserCompletionRepository Property
Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionRepository CompletionRepository { get; set; }
Public Overridable Property CompletionRepository As ICodeCompletionRepository
    Get
    Set
public:
virtual property ICodeCompletionRepository^ CompletionRepository {
    ICodeCompletionRepository^ get ();
    void set (ICodeCompletionRepository^ value);
}
abstract CompletionRepository : ICodeCompletionRepository with get, set
override CompletionRepository : ICodeCompletionRepository with get, set

Property Value

Type: ICodeCompletionRepository

Implements

ISyntaxParserCompletionRepository
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.Delimiters Property

SyntaxParserDelimiters Property
Gets or sets a collection of characters representing delimiters

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public char[] Delimiters { get; set; }
Public Property Delimiters As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ Delimiters {
    array<wchar_t>^ get () sealed;
    void set (array<wchar_t>^ value) sealed;
}
abstract Delimiters : char[] with get, set
override Delimiters : char[] with get, set

Property Value

Type: Char

Implements

ISyntaxParserDelimiters
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ExpressionEvaluator Property

SyntaxParserExpressionEvaluator Property
Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IExpressionEvaluator ExpressionEvaluator { get; set; }
Public Overridable Property ExpressionEvaluator As IExpressionEvaluator
    Get
    Set
public:
virtual property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get ();
    void set (IExpressionEvaluator^ value);
}
abstract ExpressionEvaluator : IExpressionEvaluator with get, set
override ExpressionEvaluator : IExpressionEvaluator with get, set

Property Value

Type: IExpressionEvaluator

Implements

ISyntaxParserExpressionEvaluator
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.FileName Property

SyntaxParserFileName Property
Gets or sets file name of the file being parsed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string FileName { get; set; }
Public Overridable Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

ISyntaxParserFileName
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.Options Property

SyntaxParserOptions Property
Gets or sets a flags determining syntax parsing and formatting behavior.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SyntaxOptions Options { get; set; }
Public Overridable Property Options As SyntaxOptions
    Get
    Set
public:
virtual property SyntaxOptions Options {
    SyntaxOptions get ();
    void set (SyntaxOptions value);
}
abstract Options : SyntaxOptions with get, set
override Options : SyntaxOptions with get, set

Property Value

Type: SyntaxOptions

Implements

ISyntaxParserOptions
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.ParseInterval Property

SyntaxParserParseInterval Property
Specifies delay reparsing should trigger after any change in the editor.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ParseInterval { get; set; }
Public Overridable Property ParseInterval As Integer
    Get
    Set
public:
virtual property int ParseInterval {
    int get ();
    void set (int value);
}
abstract ParseInterval : int with get, set
override ParseInterval : int with get, set

Property Value

Type: Int32

Implements

ISyntaxParserParseInterval
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SmartFormatChars Property

SyntaxParserSmartFormatChars Property
Gets or sets a collection of characters that initializes a smart formatting procedure when typing.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual char[] SmartFormatChars { get; set; }
Public Overridable Property SmartFormatChars As Char()
    Get
    Set
public:
virtual property array<wchar_t>^ SmartFormatChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
abstract SmartFormatChars : char[] with get, set
override SmartFormatChars : char[] with get, set

Property Value

Type: Char

Implements

ISyntaxParserSmartFormatChars
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SupportsThread Property

SyntaxParserSupportsThread Property
Gets boolean value indicating whether parser supports working in thread.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SupportsThread { get; }
Public Overridable ReadOnly Property SupportsThread As Boolean
    Get
public:
virtual property bool SupportsThread {
    bool get ();
}
abstract SupportsThread : bool with get
override SupportsThread : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserSupportsThread
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.SyntaxTree Property

SyntaxParserSyntaxTree Property
Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxTree SyntaxTree { get; set; }
Public Overridable Property SyntaxTree As ISyntaxTree
    Get
    Set
public:
virtual property ISyntaxTree^ SyntaxTree {
    ISyntaxTree^ get ();
    void set (ISyntaxTree^ value);
}
abstract SyntaxTree : ISyntaxTree with get, set
override SyntaxTree : ISyntaxTree with get, set

Property Value

Type: ISyntaxTree

Implements

ISyntaxParserSyntaxTree
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.UseScheme Property

SyntaxParserUseScheme Property
Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UseScheme { get; set; }
Public Overridable Property UseScheme As Boolean
    Get
    Set
public:
virtual property bool UseScheme {
    bool get ();
    void set (bool value);
}
abstract UseScheme : bool with get, set
override UseScheme : bool with get, set

Property Value

Type: Boolean

Implements

ISyntaxParserUseScheme
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.XmlScheme Property

SyntaxParserXmlScheme Property
Gets or sets an xml representation of Scheme property.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string XmlScheme { get; set; }
Public Overrides Property XmlScheme As String
    Get
    Set
public:
virtual property String^ XmlScheme {
    String^ get () override;
    void set (String^ value) override;
}
abstract XmlScheme : string with get, set
override XmlScheme : string with get, set

Property Value

Type: String
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser Events

SyntaxParser Events

The SyntaxParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed.
Top
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParser.TextReparsed Event

SyntaxParserTextReparsed Event
Occurs when SyntaxParser text content is fully parsed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler TextReparsed
Public Event TextReparsed As EventHandler
public:
virtual  event EventHandler^ TextReparsed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextReparsed : IEvent<EventHandler,
    EventArgs>
override TextReparsed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISyntaxParserTextReparsed
See Also

Reference

SyntaxParser Class
Alternet.Syntax Namespace


SyntaxParserEventArgs Class

SyntaxParserEventArgs Class
Provides data for the asynchronous syntax parsing.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.SyntaxSyntaxParserEventArgs

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxParserEventArgs : EventArgs
Public Class SyntaxParserEventArgs
    Inherits EventArgs
public ref class SyntaxParserEventArgs : public EventArgs
type SyntaxParserEventArgs =
    class
        inherit EventArgs
    end

The SyntaxParserEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxParserEventArgs | Initializes a new instance of the SyntaxParserEventArgs class with the specific parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | First | Gets or sets first parsed line.
Public property | Last | Gets or sets last parsed line.
Public property | Rescan | Gets or sets a boolean value indicates whether visual control, linked to the parser should rescan its content
Public property | Update | Gets or sets a boolean value indicates whether visual control, linked to the parser should update its content.
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxParserEventArgs Constructor

SyntaxParserEventArgs Constructor
Initializes a new instance of the SyntaxParserEventArgs class with the specific parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxParserEventArgs(
    bool update,
    bool rescan,
    int first,
    int last
)
Public Sub New (
    update As Boolean,
    rescan As Boolean,
    first As Integer,
    last As Integer
)
public:
SyntaxParserEventArgs(
    bool update,
    bool rescan,
    int first,
    int last
)
new :
        update : bool *
        rescan : bool *
        first : int *
        last : int -> SyntaxParserEventArgs

Parameters

update
Type: SystemBoolean
Indicates whether visual control, linked to the parser should update its content.
rescan
Type: SystemBoolean
Indicates whether visual control, linked to the parser should rescan its content.
first
Type: SystemInt32
First parsed line.
last
Type: SystemInt32
Last parsed line.
See Also

Reference

SyntaxParserEventArgs Class
Alternet.Syntax Namespace


SyntaxParserEventArgs Methods

SyntaxParserEventArgs Methods

The SyntaxParserEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SyntaxParserEventArgs Class
Alternet.Syntax Namespace


SyntaxParserEventArgs Properties

SyntaxParserEventArgs Properties

The SyntaxParserEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | First | Gets or sets first parsed line.
Public property | Last | Gets or sets last parsed line.
Public property | Rescan | Gets or sets a boolean value indicates whether visual control, linked to the parser should rescan its content
Public property | Update | Gets or sets a boolean value indicates whether visual control, linked to the parser should update its content.
Top
See Also

Reference

SyntaxParserEventArgs Class
Alternet.Syntax Namespace


SyntaxParserEventArgs.First Property

SyntaxParserEventArgsFirst Property
Gets or sets first parsed line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int First { get; set; }
Public Property First As Integer
    Get
    Set
public:
property int First {
    int get ();
    void set (int value);
}
member First : int with get, set

Property Value

Type: Int32
See Also

Reference

SyntaxParserEventArgs Class
Alternet.Syntax Namespace


SyntaxParserEventArgs.Last Property

SyntaxParserEventArgsLast Property
Gets or sets last parsed line.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Last { get; set; }
Public Property Last As Integer
    Get
    Set
public:
property int Last {
    int get ();
    void set (int value);
}
member Last : int with get, set

Property Value

Type: Int32
See Also

Reference

SyntaxParserEventArgs Class
Alternet.Syntax Namespace


SyntaxParserEventArgs.Rescan Property

SyntaxParserEventArgsRescan Property
Gets or sets a boolean value indicates whether visual control, linked to the parser should rescan its content

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Rescan { get; set; }
Public Property Rescan As Boolean
    Get
    Set
public:
property bool Rescan {
    bool get ();
    void set (bool value);
}
member Rescan : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SyntaxParserEventArgs Class
Alternet.Syntax Namespace


SyntaxParserEventArgs.Update Property

SyntaxParserEventArgsUpdate Property
Gets or sets a boolean value indicates whether visual control, linked to the parser should update its content.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Update { get; set; }
Public Property Update As Boolean
    Get
    Set
public:
property bool Update {
    bool get ();
    void set (bool value);
}
member Update : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SyntaxParserEventArgs Class
Alternet.Syntax Namespace


SyntaxTree Class

SyntaxTree Class
Describes syntax structure of code text.
Inheritance Hierarchy
SystemObject
Alternet.SyntaxSyntaxTree

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxTree : ISyntaxTree
Public Class SyntaxTree
    Implements ISyntaxTree
public ref class SyntaxTree : ISyntaxTree
type SyntaxTree =
    class
        interface ISyntaxTree
    end

The SyntaxTree type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxTree | Initializes a new instance of the SyntaxTree class with default settings.
Top
Methods
 | Name | Description
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle.
Public method | Clear | Removes all nodes from SyntaxTree node collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindNode | Finds specified node.
Public method | FindNodes | Locates all nodes matching search criteria.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Pop | Removes last added node from the stack of nodes.
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position.
Public method | Push | Adds specified node to the stack of nodes.
Public method | Sort | Sorts all ISyntaxNode in the node collection using the specified comparer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Current | Represents current ISyntaxNode (node on top of the stack) in the node collection.
Public property | Root | Represents root level ISyntaxNode in this syntax tree.
Top
See Also

Reference

Alternet.Syntax Namespace


SyntaxTree Constructor

SyntaxTree Constructor
Initializes a new instance of the SyntaxTree class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxTree()
Public Sub New
public:
SyntaxTree()
new : unit -> SyntaxTree
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree Methods

SyntaxTree Methods

The SyntaxTree type exposes the following members.

Methods
 | Name | Description
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle.
Public method | Clear | Removes all nodes from SyntaxTree node collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindNode | Finds specified node.
Public method | FindNodes | Locates all nodes matching search criteria.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Pop | Removes last added node from the stack of nodes.
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position.
Public method | Push | Adds specified node to the stack of nodes.
Public method | Sort | Sorts all ISyntaxNode in the node collection using the specified comparer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.BlockDeleting Method

SyntaxTreeBlockDeleting Method
Removes all nodes from the node collection which position in the specified rectangle.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void BlockDeleting(
    Rectangle rect
)
Public Overridable Sub BlockDeleting (
    rect As Rectangle
)
public:
virtual void BlockDeleting(
    Rectangle rect
)
abstract BlockDeleting :
        rect : Rectangle -> unit
override BlockDeleting :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
Specified rectangle to remove syntax nodes.

Implements

ISyntaxTreeBlockDeleting(Rectangle)
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.Clear Method

SyntaxTreeClear Method
Removes all nodes from SyntaxTree node collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ISyntaxTreeClear
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.FindNode Method

SyntaxTreeFindNode Method
Finds specified node.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode FindNode(
    ISyntaxNode obj,
    IComparer<ISyntaxNode> comparer
)
Public Overridable Function FindNode (
    obj As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode)
) As ISyntaxNode
public:
virtual ISyntaxNode^ FindNode(
    ISyntaxNode^ obj,
    IComparer<ISyntaxNode^>^ comparer
)
abstract FindNode :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> -> ISyntaxNode
override FindNode :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> -> ISyntaxNode

Parameters

obj
Type: Alternet.SyntaxISyntaxNode
Specifies node to locate.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted node collection.

Return Value

Type: ISyntaxNode
ISyntaxNode that is located.

Implements

ISyntaxTreeFindNode(ISyntaxNode, IComparerISyntaxNode)
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.FindNodes Method

SyntaxTreeFindNodes Method
Locates all nodes matching search criteria.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FindNodes(
    ISyntaxNode obj,
    IComparer<ISyntaxNode> comparer,
    ISyntaxNodes nodes
)
Public Overridable Sub FindNodes (
    obj As ISyntaxNode,
    comparer As IComparer(Of ISyntaxNode),
    nodes As ISyntaxNodes
)
public:
virtual void FindNodes(
    ISyntaxNode^ obj,
    IComparer<ISyntaxNode^>^ comparer,
    ISyntaxNodes^ nodes
)
abstract FindNodes :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> *
        nodes : ISyntaxNodes -> unit
override FindNodes :
        obj : ISyntaxNode *
        comparer : IComparer<ISyntaxNode> *
        nodes : ISyntaxNodes -> unit

Parameters

obj
Type: Alternet.SyntaxISyntaxNode
Specifies node to locate.
comparer
Type: System.Collections.GenericIComparerISyntaxNode
Specifies method that compares nodes in the sorted node collection.
nodes
Type: Alternet.SyntaxISyntaxNodes
List of located nodes.

Implements

ISyntaxTreeFindNodes(ISyntaxNode, IComparerISyntaxNode, ISyntaxNodes)
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.Pop Method

SyntaxTreePop Method
Removes last added node from the stack of nodes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode Pop()
Public Overridable Function Pop As ISyntaxNode
public:
virtual ISyntaxNode^ Pop()
abstract Pop : unit -> ISyntaxNode
override Pop : unit -> ISyntaxNode

Return Value

Type: ISyntaxNode
ISyntaxNode that is removed.

Implements

ISyntaxTreePop
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.PositionChanged Method

SyntaxTreePositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overridable Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxTreePositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.Push Method

SyntaxTreePush Method
Adds specified node to the stack of nodes.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Push(
    ISyntaxNode node
)
Public Overridable Sub Push (
    node As ISyntaxNode
)
public:
virtual void Push(
    ISyntaxNode^ node
)
abstract Push :
        node : ISyntaxNode -> unit
override Push :
        node : ISyntaxNode -> unit

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to add.

Implements

ISyntaxTreePush(ISyntaxNode)
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.Sort Method

SyntaxTreeSort Method
Sorts all ISyntaxNode in the node collection using the specified comparer.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Sort(
    IComparer<ISyntaxNode> comparer
)
Public Overridable Sub Sort (
    comparer As IComparer(Of ISyntaxNode)
)
public:
virtual void Sort(
    IComparer<ISyntaxNode^>^ comparer
)
abstract Sort :
        comparer : IComparer<ISyntaxNode> -> unit
override Sort :
        comparer : IComparer<ISyntaxNode> -> unit

Parameters

comparer
Type: System.Collections.GenericIComparerISyntaxNode
The IComparer implementation to use when comparing nodes.

Implements

ISyntaxTreeSort(IComparerISyntaxNode)
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree Properties

SyntaxTree Properties

The SyntaxTree type exposes the following members.

Properties
 | Name | Description
Public property | Current | Represents current ISyntaxNode (node on top of the stack) in the node collection.
Public property | Root | Represents root level ISyntaxNode in this syntax tree.
Top
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.Current Property

SyntaxTreeCurrent Property
Represents current ISyntaxNode (node on top of the stack) in the node collection.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode Current { get; }
Public Overridable ReadOnly Property Current As ISyntaxNode
    Get
public:
virtual property ISyntaxNode^ Current {
    ISyntaxNode^ get ();
}
abstract Current : ISyntaxNode with get
override Current : ISyntaxNode with get

Property Value

Type: ISyntaxNode

Implements

ISyntaxTreeCurrent
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


SyntaxTree.Root Property

SyntaxTreeRoot Property
Represents root level ISyntaxNode in this syntax tree.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode Root { get; set; }
Public Overridable Property Root As ISyntaxNode
    Get
    Set
public:
virtual property ISyntaxNode^ Root {
    ISyntaxNode^ get ();
    void set (ISyntaxNode^ value);
}
abstract Root : ISyntaxNode with get, set
override Root : ISyntaxNode with get, set

Property Value

Type: ISyntaxNode

Implements

ISyntaxTreeRoot
See Also

Reference

SyntaxTree Class
Alternet.Syntax Namespace


TextStyle Enumeration

TextStyle Enumeration
Defines additional flags for text fragments. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum TextStyle
<FlagsAttribute>
Public Enumeration TextStyle
[FlagsAttribute]
public enum class TextStyle
[<FlagsAttribute>]
type TextStyle
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
WhiteSpace | 1 | Indicates that text fragment consists of whitespace symbol.
Tabulation | 2 | Indicates that text fragment consists of tab symbol.
OutlineSection | 4 | Indicates that text fragment contains outline section.
MisSpelledWord | 8 | Indicates that text fragment contains misspelled word.
HyperText | 16 | Indicates that text fragment contains hypertext.
Brace | 32 | Indicates that text fragment contains matching brace.
WaveLine | 64 | Indicates that text fragment contains wave line.
CodeSnippet | 128 | Indicates that text fragment contains code snippet.
Error | 256 | Indicates that text fragment contains error.
Warning | 512 | Indicates that text fragment contains warning.
Info | 1024 | Indicates that text fragment contains information message.
Reference | 2048 | Indicates that text fragment contains reference to variable declaration.
SearchResult | 4096 | Indicates that text fragment contains highlighted search result.
Hidden | 8192 | Indicates that text fragment contains hidden diagnostic message.
See Also

Reference

Alternet.Syntax Namespace


TextUndo Class

TextUndo Class
Represents single change of the text fragment.
Inheritance Hierarchy
SystemObject
Alternet.SyntaxTextUndo

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextUndo : ITextUndo
Public Class TextUndo
    Implements ITextUndo
public ref class TextUndo : ITextUndo
type TextUndo =
    class
        interface ITextUndo
    end

The TextUndo type exposes the following members.

Constructors
 | Name | Description
Public method | TextUndo | Initializes TextUndo class with default settings.
Public method | TextUndo(Point, Point, String) | Initializes TextUndo class with specified parameters.
Public method | TextUndo(Int32, Int32, String) | Initializes TextUndo class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EndPt | Represents end Point of the text fragment being changed.
Public property | FileName | Specifies FieName where the change occurs.
Public property | Len | Specifies length of the text fragment to delete.
Public property | Start | Represents starting position of the text fragment being changed.
Public property | StartPt | Represents starting Point of the text fragment being changed.
Public property | Text | Specifies length of the text fragment to insert.
Top
See Also

Reference

Alternet.Syntax Namespace


TextUndo Constructor

TextUndo Constructor
Overload List
 | Name | Description
Public method | TextUndo | Initializes TextUndo class with default settings.
Public method | TextUndo(Point, Point, String) | Initializes TextUndo class with specified parameters.
Public method | TextUndo(Int32, Int32, String) | Initializes TextUndo class with specified parameters.
Top
See Also

Reference

TextUndo Class
Alternet.Syntax Namespace


TextUndo Constructor

TextUndo Constructor
Initializes TextUndo class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextUndo()
Public Sub New
public:
TextUndo()
new : unit -> TextUndo
See Also

Reference

TextUndo Class
TextUndo Overload
Alternet.Syntax Namespace


TextUndo Constructor (Point, Point, String)

TextUndo Constructor (Point, Point, String)
Initializes TextUndo class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextUndo(
    Point start,
    Point end,
    string text
)
Public Sub New (
    start As Point,
    end As Point,
    text As String
)
public:
TextUndo(
    Point start,
    Point end,
    String^ text
)
new :
        start : Point *
        end : Point *
        text : string -> TextUndo

Parameters

start
Type: System.DrawingPoint
Specifies start Point of text fragment to delete.
end
Type: System.DrawingPoint
Specifies end Point of the text fragment to delete.
text
Type: SystemString
Specifies text fragment to insert.
See Also

Reference

TextUndo Class
TextUndo Overload
Alternet.Syntax Namespace


TextUndo Constructor (Int32, Int32, String)

TextUndo Constructor (Int32, Int32, String)
Initializes TextUndo class with specified parameters.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextUndo(
    int start,
    int len,
    string text
)
Public Sub New (
    start As Integer,
    len As Integer,
    text As String
)
public:
TextUndo(
    int start,
    int len,
    String^ text
)
new :
        start : int *
        len : int *
        text : string -> TextUndo

Parameters

start
Type: SystemInt32
Specifies start position of text fragment to delete.
len
Type: SystemInt32
Specifies length of the text fragment to delete.
text
Type: SystemString
Specifies text fragment to insert.
See Also

Reference

TextUndo Class
TextUndo Overload
Alternet.Syntax Namespace


TextUndo Methods

TextUndo Methods

The TextUndo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextUndo Class
Alternet.Syntax Namespace


TextUndo Properties

TextUndo Properties

The TextUndo type exposes the following members.

Properties
 | Name | Description
Public property | EndPt | Represents end Point of the text fragment being changed.
Public property | FileName | Specifies FieName where the change occurs.
Public property | Len | Specifies length of the text fragment to delete.
Public property | Start | Represents starting position of the text fragment being changed.
Public property | StartPt | Represents starting Point of the text fragment being changed.
Public property | Text | Specifies length of the text fragment to insert.
Top
See Also

Reference

TextUndo Class
Alternet.Syntax Namespace


TextUndo.EndPt Property

TextUndoEndPt Property
Represents end Point of the text fragment being changed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point EndPt { get; set; }
Public Property EndPt As Point
    Get
    Set
public:
virtual property Point EndPt {
    Point get () sealed;
    void set (Point value) sealed;
}
abstract EndPt : Point with get, set
override EndPt : Point with get, set

Property Value

Type: Point

Implements

ITextUndoEndPt
See Also

Reference

TextUndo Class
Alternet.Syntax Namespace


TextUndo.FileName Property

TextUndoFileName Property
Specifies FieName where the change occurs.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

ITextUndoFileName
See Also

Reference

TextUndo Class
Alternet.Syntax Namespace


TextUndo.Len Property

TextUndoLen Property
Specifies length of the text fragment to delete.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Len { get; set; }
Public Property Len As Integer
    Get
    Set
public:
virtual property int Len {
    int get () sealed;
    void set (int value) sealed;
}
abstract Len : int with get, set
override Len : int with get, set

Property Value

Type: Int32

Implements

ITextUndoLen
See Also

Reference

TextUndo Class
Alternet.Syntax Namespace


TextUndo.Start Property

TextUndoStart Property
Represents starting position of the text fragment being changed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
public:
virtual property int Start {
    int get () sealed;
    void set (int value) sealed;
}
abstract Start : int with get, set
override Start : int with get, set

Property Value

Type: Int32

Implements

ITextUndoStart
See Also

Reference

TextUndo Class
Alternet.Syntax Namespace


TextUndo.StartPt Property

TextUndoStartPt Property
Represents starting Point of the text fragment being changed.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point StartPt { get; set; }
Public Property StartPt As Point
    Get
    Set
public:
virtual property Point StartPt {
    Point get () sealed;
    void set (Point value) sealed;
}
abstract StartPt : Point with get, set
override StartPt : Point with get, set

Property Value

Type: Point

Implements

ITextUndoStartPt
See Also

Reference

TextUndo Class
Alternet.Syntax Namespace


TextUndo.Text Property

TextUndoText Property
Specifies length of the text fragment to insert.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

ITextUndoText
See Also

Reference

TextUndo Class
Alternet.Syntax Namespace


TextUndoList Class

TextUndoList Class
Represents collection containing list of ITextUndo objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListITextUndo
Alternet.SyntaxTextUndoList

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextUndoList : List<ITextUndo>,
    ITextUndoList, IList<ITextUndo>, ICollection<ITextUndo>,
    IEnumerable<ITextUndo>, IEnumerable
Public Class TextUndoList
    Inherits List(Of ITextUndo)
    Implements ITextUndoList, IList(Of ITextUndo),
    ICollection(Of ITextUndo), IEnumerable(Of ITextUndo), IEnumerable
public ref class TextUndoList : public List<ITextUndo^>,
    ITextUndoList, IList<ITextUndo^>, ICollection<ITextUndo^>,
    IEnumerable<ITextUndo^>, IEnumerable
type TextUndoList =
    class
        inherit List<ITextUndo>
        interface ITextUndoList
        interface IList<ITextUndo>
        interface ICollection<ITextUndo>
        interface IEnumerable<ITextUndo>
        interface IEnumerable
    end

The TextUndoList type exposes the following members.

Constructors
 | Name | Description
Public method | TextUndoList | Initializes a new instance of the TextUndoList class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListITextUndo .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListITextUndo .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListITextUndo .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListITextUndo .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListITextUndo .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListITextUndo .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListITextUndo .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListITextUndo .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListITextUndo .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListITextUndo .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListITextUndo .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListITextUndo .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListITextUndo .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListITextUndo .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListITextUndo .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListITextUndo .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListITextUndo .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListITextUndo .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListITextUndo .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListITextUndo .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListITextUndo .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListITextUndo .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListITextUndo .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListITextUndo .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListITextUndo .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListITextUndo .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListITextUndo .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListITextUndo .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListITextUndo .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListITextUndo .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListITextUndo .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListITextUndo .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListITextUndo .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListITextUndo .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListITextUndo .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListITextUndo .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListITextUndo .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListITextUndo .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListITextUndo .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListITextUndo .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfITextUndo | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstITextUndo | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementITextUndo, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListITextUndo .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListITextUndo .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListITextUndo .)
Top
See Also

Reference

Alternet.Syntax Namespace


TextUndoList Constructor

TextUndoList Constructor
Initializes a new instance of the TextUndoList class

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextUndoList()
Public Sub New
public:
TextUndoList()
new : unit -> TextUndoList
See Also

Reference

TextUndoList Class
Alternet.Syntax Namespace


TextUndoList Methods

TextUndoList Methods

The TextUndoList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListITextUndo .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListITextUndo .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListITextUndo .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListITextUndo .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListITextUndo .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListITextUndo .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListITextUndo .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListITextUndo .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListITextUndo .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListITextUndo .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListITextUndo .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListITextUndo .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListITextUndo .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListITextUndo .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListITextUndo .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListITextUndo .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListITextUndo .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListITextUndo .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListITextUndo .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListITextUndo .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListITextUndo .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListITextUndo .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListITextUndo .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListITextUndo .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListITextUndo .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListITextUndo .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListITextUndo .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListITextUndo .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListITextUndo .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListITextUndo .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListITextUndo .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListITextUndo .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListITextUndo .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListITextUndo .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListITextUndo .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListITextUndo .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListITextUndo .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListITextUndo .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListITextUndo .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListITextUndo .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListITextUndo .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfITextUndo | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstITextUndo | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementITextUndo, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

TextUndoList Class
Alternet.Syntax Namespace


TextUndoList Properties

TextUndoList Properties

The TextUndoList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListITextUndo .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListITextUndo .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListITextUndo .)
Top
See Also

Reference

TextUndoList Class
Alternet.Syntax Namespace


XmlLexerToken Enumeration

XmlLexerToken Enumeration
Represents lexical tokens for Xml parser.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum XmlLexerToken
Public Enumeration XmlLexerToken
public enum class XmlLexerToken
type XmlLexerToken
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
WhiteSpace | 1 | Specifies that lexical token corresponds to whitespace symbol.
Body | 2 | Specifies that lexical token corresponds to xml body.
OpenTag | 3 | Specifies that lexical token corresponds to open tag.
CloseTag | 4 | Specifies that lexical token corresponds to close tag.
OpenEndTag | 5 | Specifies that lexical token corresponds to open end tag.
CloseEndTag | 6 | Specifies that lexical token corresponds to close end tag.
Equal | 7 | Specifies that lexical token corresponds to equality symbol.
TagName | 8 | Specifies that lexical token corresponds to name of tag.
ParamName | 9 | Specifies that lexical token corresponds to name of parameter.
ParamValue | 10 | Specifies that lexical token corresponds to parameter value.
Comment | 11 | Specifies that lexical token corresponds to comment tag.
Interr | 12 | Specifies that lexical token corresponds to "?" symbol.
CDATA | 13 | Specifies that lexical token corresponds to CDATA tag.
CDATABody | 14 | Specifies that lexical token corresponds to CDATA body tag.
OpenEmbeddedTag | 15 | Specifies that lexical token corresponds to open embedded tag.
CloseEmbeddedTag | 16 | Specifies that lexical token corresponds to close embedded tag.
See Also

Reference

Alternet.Syntax Namespace


XmlNodeType Enumeration

XmlNodeType Enumeration
Represents node types for Xml parser.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum XmlNodeType
Public Enumeration XmlNodeType
public enum class XmlNodeType
type XmlNodeType
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
XmlUnit | 1 | Specifies that xml node corresponds to entire unit.
XmlOpenTag | 2 | Specifies that xml node corresponds to xml open tag.
XmlCloseTag | 3 | Specifies that xml node corresponds to xml close tag.
XmlParameter | 4 | Specifies that xml node corresponds to xml parameter.
XmlParameters | 5 | Specifies that xml node corresponds to list of xml parameters.
XmlBody | 6 | Specifies that xml node corresponds to xml body.
XmlEmbeddedExpression | 7 | Specifies that xml node corresponds to xml embedded expression.
XmlComment | 8 | Specifies that xml node corresponds to xml comment.
See Also

Reference

Alternet.Syntax Namespace


XmlParser Class

XmlParser Class
Represents properties and methods to perform syntax analysis of specified xml code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.SyntaxXmlParser
Alternet.SyntaxHtmlParser

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlParser : SyntaxParser
Public Class XmlParser
    Inherits SyntaxParser
public ref class XmlParser : public SyntaxParser
type XmlParser =
    class
        inherit SyntaxParser
    end

The XmlParser type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParser | Initializes a new instance of the XmlParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Overrides SyntaxParserGetMultiLineComment(String, String).)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax Namespace


XmlParser Constructor

XmlParser Constructor
Initializes a new instance of the XmlParser class with default settings.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlParser()
Public Sub New
public:
XmlParser()
new : unit -> XmlParser
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


XmlParser Methods

XmlParser Methods

The XmlParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Overrides SyntaxParserGetMultiLineComment(String, String).)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


XmlParser.GetCompletionType Method

XmlParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


XmlParser.GetCompletionType Method (Char)

XmlParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

XmlParser Class
GetCompletionType Overload
Alternet.Syntax Namespace


XmlParser.GetMultiLineComment Method

XmlParserGetMultiLineComment Method
Overload List
 | Name | Description
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Overrides SyntaxParserGetMultiLineComment(String, String).)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


XmlParser.GetMultiLineComment Method (String, String)

XmlParserGetMultiLineComment Method (String, String)
Gets the start and symbols multi-line comment.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool GetMultiLineComment(
    out string start,
    out string end
)
Public Overrides Function GetMultiLineComment (
    <OutAttribute> ByRef start As String,
    <OutAttribute> ByRef end As String
) As Boolean
public:
virtual bool GetMultiLineComment(
    [OutAttribute] String^% start,
    [OutAttribute] String^% end
) override
abstract GetMultiLineComment :
        start : string byref *
        end : string byref -> bool
override GetMultiLineComment :
        start : string byref *
        end : string byref -> bool

Parameters

start
Type: SystemString
Start symbol of multi-line comment.
end
Type: SystemString
End symbol of multi-line comment.

Return Value

Type: Boolean
True if parser supports multi-line comment; otherwise false.

Implements

ISyntaxParserGetMultiLineComment(String, String)
See Also

Reference

XmlParser Class
GetMultiLineComment Overload
Alternet.Syntax Namespace


XmlParser.ReparseText Method

XmlParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


XmlParser.ReparseText Method

XmlParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

XmlParser Class
ReparseText Overload
Alternet.Syntax Namespace


XmlParser.ResetOptions Method

XmlParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


XmlParser.ShouldSerializeOptions Method

XmlParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


XmlParser Properties

XmlParser Properties

The XmlParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


XmlParser.CaseSensitive Property

XmlParserCaseSensitive Property
Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


XmlParser Events

XmlParser Events

The XmlParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax Namespace


Alternet.Syntax.CodeCompletion Namespace

Alternet.Syntax.CodeCompletion Namespace
Classes
 | Class | Description
Public class | BraceInfo | Represents simple text data related to popup hint.
Public class | BraceInfoItem | Stores simple text data related to popup hint.
Public class | CListMember | Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Public class | CListMembers | Represents data collection related to popup list box controls used to describe C language code.
Public class | CodeCompletionCategory | Provides data for the code completion category like class or field.
Public class | CodeCompletionProvider | Represents properties and methods to provide data related to Code Completion popup listbox and popup hint controls.
Public class | CodeCompletionProviderItem | Stores particular code completion item.
Public class | CodeCompletionProviderNamedItem | Represents particular CodeCompletionProviderNamedItem in the code provider items collection.
Public class | CodeCompletionRepository | Represents properties and methods to perform code completion functionality.
Public class | CodeFixItem | Represents particular code ix in the code fix collection.
Public class | CodeFixItems | Represents collection containing list of code fixes.
Public class | CodeRefactorItem | Represents particular code ix in the code refactor collection.
Public class | CodeRefactorItems | Represents collection containing list of code refactors.
Public class | CodeSnippet | Represents particular code snippet in the snippets collection.
Public class | CodeSnippetCode | Specifies the code that you want to insert into a file.
Public class | CodeSnippetDeclaration | Represents literals and objects that make up the parts of a code snippet that you can edit.
Public class | CodeSnippetDeclarations | Provides an indexed access to individual ICodeSnippetDeclaration objects.
Public class | CodeSnippetHeader | Represents code snippet header.
Public class | CodeSnippetImport | Represents imported namespace used by an IntelliSense Code Snippet.
Public class | CodeSnippetImports | Provides an indexed access to individual ICodeSnippetImport objects.
Public class | CodeSnippetLiteral | Represents literal that make up the parts of a code snippet that you can edit.
Public class | CodeSnippetLiterals | Provides an indexed access to individual ICodeSnippetLiteral objects.
Public class | CodeSnippetMember | Represents properties and methods for a particular code snippet member in the data collection of the code completion popups.
Public class | CodeSnippetMembers | Represents collection containing list of code templates.
Public class | CodeSnippetObject | Represents literal that make up the parts of a code snippet that you can edit.
Public class | CodeSnippetObjects | Provides an indexed access to individual ICodeSnippetObject objects.
Public class | CodeSnippetReference | Contains information about assembly references for the code snippet.
Public class | CodeSnippetReferences | Provides an indexed access to individual ICodeSnippetReference objects.
Public class | CodeSnippets | Represents collection containing list of code snippets.
Public class | CodeSnippetsProvider | Represents collection containing list of code snippets.
Public class | CodeSnippetType | Specifies how the code snippet is inserted into the code.
Public class | CodeSnippetTypes | Specifies how the code snippet is inserted into the code.
Public class | CommentInfo | Represents simple text data related to popup hint.
Public class | CommentInfoItem | Stores simple text data related to popup hint.
Public class | CParameterInfo | Represents Parameter Info data related to popup window and popup hint controls used to describe C language code.
Public class | CRepository | Represents properties and methods to perform code completion functionality intended to use for Vb Script language.
Public class | CsListMember | Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Public class | CsListMembers | Represents data collection related to popup list box controls used to describe C# language code.
Public class | CsParameterInfo | Represents Parameter Info data related to popup window and popup hint controls used to describe C# language code.
Public class | CsRepository | Represents properties and methods to perform code completion functionality intended to use for Cs language.
Public class | DescriptionHelper | Provides methods to get member's description.
Public class | JavaScriptRepository | Represents properties and methods to perform code completion functionality intended to use for Java Script language.
Public class | JsListMember | Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Public class | JsListMembers | Represents data collection related to popup list box controls used to describe JScript language code.
Public class | JsParameterInfo | Represents Parameter Info data related to popup window and popup hint controls used to describe JScript language code.
Public class | JsRepository | Represents properties and methods to perform code completion functionality intended to use for Vb Script language.
Public class | ListMember | Implements properties and methods for a particular list member in the data collection of the code completion popups.
Public class | ListMembers | Represents data collection related to popup list box controls.
Public class | MSSqlRepository | Represents properties and methods to perform code completion functionality intended to use for SQL language.
Public class | NetListMembers | Represents data collection related to popup list box controls used to describe NET. family code.
Public class | NetNamespace | Represents a .NET namespace.
Public class | NetParameterInfo | Represents Parameter Info data related to popup window and popup hint controls used to describe C# language code.
Public class | NETRepository | Represents properties and methods to perform code completion functionality intended to use for .NET family of languages.
Public class | NetTypes | Contains collection of build-in types. Reserved for internal use.
Public class | ParameterInfo | Represents Parameter Info data related to popup window and popup hint controls.
Public class | ParameterMember | Implements properties for a particular parameter member within list member parameters.
Public class | ParameterMembers | Provides an indexed access to individual ICodeSnippetLiteral objects.
Public class | QuickInfo | Represents simple text data related to popup hint.
Public class | QuickInfoItem | Stores simple text data related to popup hint.
Public class | ReflectionRepository | Represents properties and methods to perform code completion functionality using reflection.
Public class | SqlListMember |
Public class | SqlListMembers |
Public class | SqlParameterInfo |
Public class | SqlRepository | Represents properties and methods to perform code completion functionality intended to use for SQL language.
Public class | SqlRepositoryBase |
Public class | SqlRepositoryBaseTableItem | Represents a particular table.
Public class | T4Repository | Represents properties and methods to perform code completion functionality intended to use for T4 language.
Public class | VbListMember | Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe Visual Basic language code.
Public class | VbListMembers | Represents data collection related to popup list box controls used to describe Visual Basic language code.
Public class | VbParameterInfo | Represents Parameter Info data related to popup window and popup hint controls used to describe Visual Basic language code.
Public class | VbRepository | Represents properties and methods to perform code completion functionality intended to use for Vb Script language.
Public class | VbScriptRepository | Represents properties and methods to perform code completion functionality intended to use for Vb Script language.
Interfaces
 | Interface | Description
Public interface | IBraceInfo | Represents simple text data related to popup hint.
Public interface | IBraceInfoItem | Stores simple text data related to popup hint.
Public interface | ICategorizedCodeCompletionProvider | Represents a ICodeCompletionProvider that contains categories.
Public interface | ICategorizedListMember | Represents a list member contains category information like Class, Filed and so on.
Public interface | ICodeCompletionProvider | Represents properties and methods to provide data related to Code Completion popup listbox and popup hint controls.
Public interface | ICodeCompletionProviderItem | Stores particular code completion item.
Public interface | ICodeCompletionProviderNamedItem | Represents properties and methods describing particular item in the ICodeCompletionProviderItems collection.
Public interface | ICodeCompletionRepository | Represents properties and methods to perform code completion functionality.
Public interface | ICodeFixItem | Represents properties and methods describing particular code fix in the code fix collection.
Public interface | ICodeFixItems | Represents collection containing list of code fixes.
Public interface | ICodeRefactorItem | Represents properties and methods describing particular code fix in the code fix collection.
Public interface | ICodeRefactorItems | Represents collection containing list of code fixes.
Public interface | ICodeSnippet | Represents properties and methods describing particular code snippet in the snippets collection.
Public interface | ICodeSnippetCode | Specifies the code that you want to insert into a file.
Public interface | ICodeSnippetDeclaration | Represents properties and methods describing literals and objects that make up the parts of a code snippet that you can edit.
Public interface | ICodeSnippetDeclarations | Represents properties and methods to provide an indexed access to individual ICodeSnippetDeclaration objects.
Public interface | ICodeSnippetHeader | Represents properties and methods describing code snippet header.
Public interface | ICodeSnippetImport | Represents imported namespace used by an IntelliSense Code Snippet.
Public interface | ICodeSnippetImports | Represents properties and methods to provide an indexed access to individual ICodeSnippetImport objects.
Public interface | ICodeSnippetLiteral | Represents properties and methods describing literal that make up the parts of a code snippet that you can edit.
Public interface | ICodeSnippetLiterals | Represents properties and methods to provide an indexed access to individual ICodeSnippetLiteral objects.
Public interface | ICodeSnippetMember | Represents properties and methods for a particular code snippet member in the data collection of the code completion popups.
Public interface | ICodeSnippetMembers | Represents collection containing list of code snippets.
Public interface | ICodeSnippetObject | Represents properties and methods describing literal that make up the parts of a code snippet that you can edit.
Public interface | ICodeSnippetObjects | Represents properties and methods to provide an indexed access to individual ICodeSnippetObject objects.
Public interface | ICodeSnippetReference | Contains information about assembly references for the code snippet.
Public interface | ICodeSnippetReferences | Represents properties and methods to provide an indexed access to individual ICodeSnippetReference objects.
Public interface | ICodeSnippets | Represents collection containing list of code snippets.
Public interface | ICodeSnippetsProvider | Represents base interface for code snippets provider.
Public interface | ICodeSnippetType | Specifies how the code snippet is inserted into the code.
Public interface | ICodeSnippetTypes | Specifies how the code snippet is inserted into the code.
Public interface | ICommentInfo | Represents simple text data related to popup hint.
Public interface | ICommentInfoItem | Stores simple text data related to popup hint.
Public interface | IListMember | Represents properties and methods for a particular list member in the data collection of the code completion popups.
Public interface | IListMembers | Represents data collection related to popup list box controls.
Public interface | INetNamespace | Represents a .NET namespace.
Public interface | INETRepository | Represents properties and methods to perform code completion functionality intended to use for .NET family of languages.
Public interface | IParameterInfo | Represents Parameter Info data related to popup hint controls.
Public interface | IParameterMember | Represents properties for a particular parameter member within list member parameters.
Public interface | IParameterMembers | Represents collection containing list of parameters.
Public interface | IQuickInfo | Represents simple text data related to popup hint.
Public interface | IQuickInfoItem | Stores simple text data related to popup hint.
Public interface | IReflectionRepository | Represents properties and methods to perform code completion functionality using reflection.
Enumerations
 | Enumeration | Description
Public enumeration | ItemFocusMode | Specifies item preselection mode
Public enumeration | MemberAttribute | Specifies list of additional attributes associated with a IListMember.
Public enumeration | NetNodeType | Defines types of syntax nodes used to create a hierarchical tree view that examines code text as a collection of syntax members. Intended to use with collection of .NET languages, like C#, J#, and VB.NET.
Public enumeration | ParameterModifer | Defines parameter modifiers.
Public enumeration | SnippetType | Defines snippet behaviour.
Public enumeration | XmlCommentType | Defines types of xml comment elements.


BraceInfo Class

BraceInfo Class
Represents simple text data related to popup hint.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionBraceInfo

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BraceInfo : CodeCompletionProvider, IBraceInfo,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Class BraceInfo
    Inherits CodeCompletionProvider
    Implements IBraceInfo, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class BraceInfo : public CodeCompletionProvider,
    IBraceInfo, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type BraceInfo =
    class
        inherit CodeCompletionProvider
        interface IBraceInfo
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The BraceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | BraceInfo | Initializes a new instance of the QuickInfo class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from CodeCompletionProvider.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from given item in the specified column. (Inherited from CodeCompletionProvider.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from CodeCompletionProvider.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns string reperesenting name of the item. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Brace | Gets or sets content of the ICommentInfo.
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. (Inherited from CodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


BraceInfo Constructor

BraceInfo Constructor
Initializes a new instance of the QuickInfo class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BraceInfo()
Public Sub New
public:
BraceInfo()
new : unit -> BraceInfo
See Also

Reference

BraceInfo Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfo Methods

BraceInfo Methods

The BraceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from CodeCompletionProvider.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from given item in the specified column. (Inherited from CodeCompletionProvider.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from CodeCompletionProvider.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns string reperesenting name of the item. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

BraceInfo Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfo.GetName Method

BraceInfoGetName Method
Returns string reperesenting name of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetName(
    int index
)
Public Overrides Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
) override
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing name of specified item.

Implements

ICodeCompletionProviderGetName(Int32)
ICodeCompletionProviderGetName(Int32)
See Also

Reference

BraceInfo Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfo.GetText Method

BraceInfoGetText Method
Returns string representing default column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetText(
    int index
)
Public Overrides Function GetText (
    index As Integer
) As String
public:
virtual String^ GetText(
    int index
) override
abstract GetText :
        index : int -> string
override GetText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
Text representing default column.

Implements

ICodeCompletionProviderGetText(Int32)
ICodeCompletionProviderGetText(Int32)
Remarks
In this class method returns the same value with GetName method.
See Also

Reference

BraceInfo Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfo Properties

BraceInfo Properties

The BraceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Brace | Gets or sets content of the ICommentInfo.
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. (Inherited from CodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

BraceInfo Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfo.Brace Property

BraceInfoBrace Property
Gets or sets content of the ICommentInfo.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Brace { get; set; }
Public Overridable Property Brace As String
    Get
    Set
public:
virtual property String^ Brace {
    String^ get ();
    void set (String^ value);
}
abstract Brace : string with get, set
override Brace : string with get, set

Property Value

Type: String

Implements

IBraceInfoBrace
See Also

Reference

BraceInfo Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfo Events

BraceInfo Events

The BraceInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

BraceInfo Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfoItem Class

BraceInfoItem Class
Stores simple text data related to popup hint.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionBraceInfoItem

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BraceInfoItem : CodeCompletionProviderItem,
    IBraceInfoItem, ICodeCompletionProviderItem, IComparable
Public Class BraceInfoItem
    Inherits CodeCompletionProviderItem
    Implements IBraceInfoItem, ICodeCompletionProviderItem, IComparable
public ref class BraceInfoItem : public CodeCompletionProviderItem,
    IBraceInfoItem, ICodeCompletionProviderItem, IComparable
type BraceInfoItem =
    class
        inherit CodeCompletionProviderItem
        interface IBraceInfoItem
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The BraceInfoItem type exposes the following members.

Constructors
 | Name | Description
Public method | BraceInfoItem | Initializes a new instance of the CommentInfoItem class with specified settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Brace | Gets or sets content of the ICommentInfoItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


BraceInfoItem Constructor

BraceInfoItem Constructor
Initializes a new instance of the CommentInfoItem class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public BraceInfoItem(
    string brace
)
Public Sub New (
    brace As String
)
public:
BraceInfoItem(
    String^ brace
)
new :
        brace : string -> BraceInfoItem

Parameters

brace
Type: SystemString
Content to store in this new instance.
See Also

Reference

BraceInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfoItem Methods

BraceInfoItem Methods

The BraceInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BraceInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfoItem.CompareTo Method

BraceInfoItemCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

BraceInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfoItem Properties

BraceInfoItem Properties

The BraceInfoItem type exposes the following members.

Properties
 | Name | Description
Public property | Brace | Gets or sets content of the ICommentInfoItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

BraceInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


BraceInfoItem.Brace Property

BraceInfoItemBrace Property
Gets or sets content of the ICommentInfoItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Brace { get; set; }
Public Overridable Property Brace As String
    Get
    Set
public:
virtual property String^ Brace {
    String^ get ();
    void set (String^ value);
}
abstract Brace : string with get, set
override Brace : string with get, set

Property Value

Type: String

Implements

IBraceInfoItemBrace
See Also

Reference

BraceInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


CListMember Class

CListMember Class
Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.CodeCompletionCListMember

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CListMember : ListMember
Public Class CListMember
    Inherits ListMember
public ref class CListMember : public ListMember
type CListMember =
    class
        inherit ListMember
    end

The CListMember type exposes the following members.

Constructors
 | Name | Description
Public method | CListMember | Initializes a new instance of the CListMember class with default settings.
Public method | CListMember(IListMembers, Boolean) | Initializes a new instance of the CListMember class with specified owner. IListMembers owning this instanceBoolean value indicating that member should provide detailed description.
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Overrides ListMemberGetTemplate(Boolean).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBuiltInType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets CodeCompletionCategory to which this IListMember belongs. (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CListMember Constructor

CListMember Constructor
Overload List
 | Name | Description
Public method | CListMember | Initializes a new instance of the CListMember class with default settings.
Public method | CListMember(IListMembers, Boolean) | Initializes a new instance of the CListMember class with specified owner. IListMembers owning this instanceBoolean value indicating that member should provide detailed description.
Top
See Also

Reference

CListMember Class
Alternet.Syntax.CodeCompletion Namespace


CListMember Constructor

CListMember Constructor
Initializes a new instance of the CListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CListMember()
Public Sub New
public:
CListMember()
new : unit -> CListMember
See Also

Reference

CListMember Class
CListMember Overload
Alternet.Syntax.CodeCompletion Namespace


CListMember Constructor (IListMembers, Boolean)

CListMember Constructor (IListMembers, Boolean)
Initializes a new instance of the CListMember class with specified owner. IListMembers owning this instanceBoolean value indicating that member should provide detailed description.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CListMember(
    IListMembers owner,
    bool fullDescription
)
Public Sub New (
    owner As IListMembers,
    fullDescription As Boolean
)
public:
CListMember(
    IListMembers^ owner,
    bool fullDescription
)
new :
        owner : IListMembers *
        fullDescription : bool -> CListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
fullDescription
Type: SystemBoolean
See Also

Reference

CListMember Class
CListMember Overload
Alternet.Syntax.CodeCompletion Namespace


CListMember Methods

CListMember Methods

The CListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Overrides ListMemberGetTemplate(Boolean).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBuiltInType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CListMember Class
Alternet.Syntax.CodeCompletion Namespace


CListMember.GetParamText Method

CListMemberGetParamText Method
Converts Parameters property to a single string.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetParamText(
    bool useFormatting
)
Public Overrides Function GetParamText (
    useFormatting As Boolean
) As String
public:
virtual String^ GetParamText(
    bool useFormatting
) override
abstract GetParamText :
        useFormatting : bool -> string
override GetParamText :
        useFormatting : bool -> string

Parameters

useFormatting
Type: SystemBoolean
Specifies whether to use html formatting tags.

Return Value

Type: String
Returns Parameters in the form of comma separated text, framed by parentheses.

Implements

IListMemberGetParamText(Boolean)
See Also

Reference

CListMember Class
Alternet.Syntax.CodeCompletion Namespace


CListMember.GetTemplate Method

CListMemberGetTemplate Method
Return member's template.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetTemplate(
    bool compact
)
Public Overrides Function GetTemplate (
    compact As Boolean
) As String
public:
virtual String^ GetTemplate(
    bool compact
) override
abstract GetTemplate :
        compact : bool -> string
override GetTemplate :
        compact : bool -> string

Parameters

compact
Type: SystemBoolean
Indicates if template is in a compact form.

Return Value

Type: String
String value that represents member template.

Implements

IListMemberGetTemplate(Boolean)
See Also

Reference

CListMember Class
Alternet.Syntax.CodeCompletion Namespace


CListMember.IsBuiltInType Method

CListMemberIsBuiltInType Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInType(
    string dataType
)
Public Shared Function IsBuiltInType (
    dataType As String
) As Boolean
public:
static bool IsBuiltInType(
    String^ dataType
)
static member IsBuiltInType :
        dataType : string -> bool

Parameters

dataType
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

CListMember Class
Alternet.Syntax.CodeCompletion Namespace


CListMember Properties

CListMember Properties

The CListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets CodeCompletionCategory to which this IListMember belongs. (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

CListMember Class
Alternet.Syntax.CodeCompletion Namespace


CListMember.Category Property

CListMemberCategory Property
Gets or sets CodeCompletionCategory to which this IListMember belongs.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionCategory Category { get; }
Public Overrides ReadOnly Property Category As CodeCompletionCategory
    Get
public:
virtual property CodeCompletionCategory^ Category {
    CodeCompletionCategory^ get () override;
}
abstract Category : CodeCompletionCategory with get
override Category : CodeCompletionCategory with get

Property Value

Type: CodeCompletionCategory

Implements

ICategorizedListMemberCategory
See Also

Reference

CListMember Class
Alternet.Syntax.CodeCompletion Namespace


CListMember.Description Property

CListMemberDescription Property
Return member's description.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Return Value

Type: String
String value that describes the member.

Implements

IListMemberDescription
See Also

Reference

CListMember Class
Alternet.Syntax.CodeCompletion Namespace


CListMembers Class

CListMembers Class
Represents data collection related to popup list box controls used to describe C language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionNetListMembers
Alternet.Syntax.CodeCompletionCListMembers

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CListMembers : NetListMembers
Public Class CListMembers
    Inherits NetListMembers
public ref class CListMembers : public NetListMembers
type CListMembers =
    class
        inherit NetListMembers
    end

The CListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | CListMembers | Initializes a new instance of the CListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from NetListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CListMembers Constructor

CListMembers Constructor
Initializes a new instance of the CListMembers class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CListMembers()
Public Sub New
public:
CListMembers()
new : unit -> CListMembers
See Also

Reference

CListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CListMembers Methods

CListMembers Methods

The CListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from NetListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

CListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CListMembers.CreateListMember Method

CListMembersCreateListMember Method
Initializes a new instance of the CListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

CListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CListMembers Properties

CListMembers Properties

The CListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CListMembers Events

CListMembers Events

The CListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory Class

CodeCompletionCategory Class
Provides data for the code completion category like class or field.
Inheritance Hierarchy
SystemObject
ValueObjectCodeCompletionCategory
Alternet.Syntax.CodeCompletionCodeCompletionCategory

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionCategory : ValueObject<CodeCompletionCategory>
Public Class CodeCompletionCategory
    Inherits ValueObject(Of CodeCompletionCategory)
public ref class CodeCompletionCategory : public ValueObject<CodeCompletionCategory^>
type CodeCompletionCategory =
    class
        inherit ValueObject<CodeCompletionCategory>
    end

The CodeCompletionCategory type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionCategory(String, String, NullableInt32, Image) | Initializes a new instance of the CodeCompletionCategory class with specified parameters.
Public method | CodeCompletionCategory(String, String, String, NullableInt32, Image) | Initializes a new instance of the CodeCompletionCategory class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisplayName | Gets displayed name of the category.
Public property | Id | Gets ID of the category.
Public property | Image | Gets image of the category.
Public property | ImageIndex | Gets image index of the category.
Public property | Name | Gets name of the category.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory Constructor

CodeCompletionCategory Constructor
Overload List
 | Name | Description
Public method | CodeCompletionCategory(String, String, NullableInt32, Image) | Initializes a new instance of the CodeCompletionCategory class with specified parameters.
Public method | CodeCompletionCategory(String, String, String, NullableInt32, Image) | Initializes a new instance of the CodeCompletionCategory class with specified parameters.
Top
See Also

Reference

CodeCompletionCategory Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory Constructor (String, String, Nullable(Int32), Image)

CodeCompletionCategory Constructor (String, String, NullableInt32, Image)
Initializes a new instance of the CodeCompletionCategory class with specified parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionCategory(
    string id,
    string name,
    Nullable<int> imageIndex,
    Image image
)
Public Sub New (
    id As String,
    name As String,
    imageIndex As Nullable(Of Integer),
    image As Image
)
public:
CodeCompletionCategory(
    String^ id,
    String^ name,
    Nullable<int> imageIndex,
    Image^ image
)
new :
        id : string *
        name : string *
        imageIndex : Nullable<int> *
        image : Image -> CodeCompletionCategory

Parameters

id
Type: SystemString
ID of the category.
name
Type: SystemString
Name of the category.
imageIndex
Type: SystemNullableInt32
Image index of the category.
image
Type: System.DrawingImage
Image of the category.
See Also

Reference

CodeCompletionCategory Class
CodeCompletionCategory Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory Constructor (String, String, String, Nullable(Int32), Image)

CodeCompletionCategory Constructor (String, String, String, NullableInt32, Image)
Initializes a new instance of the CodeCompletionCategory class with specified parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionCategory(
    string id,
    string name,
    string displayName,
    Nullable<int> imageIndex,
    Image image
)
Public Sub New (
    id As String,
    name As String,
    displayName As String,
    imageIndex As Nullable(Of Integer),
    image As Image
)
public:
CodeCompletionCategory(
    String^ id,
    String^ name,
    String^ displayName,
    Nullable<int> imageIndex,
    Image^ image
)
new :
        id : string *
        name : string *
        displayName : string *
        imageIndex : Nullable<int> *
        image : Image -> CodeCompletionCategory

Parameters

id
Type: SystemString
ID of the category.
name
Type: SystemString
Name of the category.
displayName
Type: SystemString
Displayed name of the category.
imageIndex
Type: SystemNullableInt32
Image index of the category.
image
Type: System.DrawingImage
Image of the category.
See Also

Reference

CodeCompletionCategory Class
CodeCompletionCategory Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory Methods

CodeCompletionCategory Methods

The CodeCompletionCategory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeCompletionCategory Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory Properties

CodeCompletionCategory Properties

The CodeCompletionCategory type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | Gets displayed name of the category.
Public property | Id | Gets ID of the category.
Public property | Image | Gets image of the category.
Public property | ImageIndex | Gets image index of the category.
Public property | Name | Gets name of the category.
Top
See Also

Reference

CodeCompletionCategory Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory.DisplayName Property

CodeCompletionCategoryDisplayName Property
Gets displayed name of the category.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}
member DisplayName : string with get

Property Value

Type: String
See Also

Reference

CodeCompletionCategory Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory.Id Property

CodeCompletionCategoryId Property
Gets ID of the category.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
public:
property String^ Id {
    String^ get ();
}
member Id : string with get

Property Value

Type: String
See Also

Reference

CodeCompletionCategory Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory.Image Property

CodeCompletionCategoryImage Property
Gets image of the category.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
property Image^ Image {
    Image^ get ();
}
member Image : Image with get

Property Value

Type: Image
See Also

Reference

CodeCompletionCategory Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory.ImageIndex Property

CodeCompletionCategoryImageIndex Property
Gets image index of the category.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ImageIndex { get; }
Public ReadOnly Property ImageIndex As Nullable(Of Integer)
    Get
public:
property Nullable<int> ImageIndex {
    Nullable<int> get ();
}
member ImageIndex : Nullable<int> with get

Property Value

Type: NullableInt32
See Also

Reference

CodeCompletionCategory Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionCategory.Name Property

CodeCompletionCategoryName Property
Gets name of the category.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

CodeCompletionCategory Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider Class

CodeCompletionProvider Class
Represents properties and methods to provide data related to Code Completion popup listbox and popup hint controls.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
More...

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionProvider : List<ICodeCompletionProviderItem>,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Class CodeCompletionProvider
    Inherits List(Of ICodeCompletionProviderItem)
    Implements ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class CodeCompletionProvider : public List<ICodeCompletionProviderItem^>,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type CodeCompletionProvider =
    class
        inherit List<ICodeCompletionProviderItem>
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The CodeCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionProvider | Initializes a new instance of the CodeCompletionProvider class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required.
Public method | ColumnVisible | Indicates whether specified column is visible.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from given item in the specified column.
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection.
Public method | GetDisplayText | Returns string representing the display text of the item.
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index.
Public method | GetImageIndex | Returns number of image that is displayed for item given by index.
Public method | GetInsertText | Returns string to be inserted.
Public method | GetName | Returns string representing name of the item.
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance.
Public method | GetPriority | Returns priority of the item.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name.
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet.
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet.
Public method | OnClosePopup | Raises ClosePopup event.
Public method | OnShowPopup | Raises ShowPopup event.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file.
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file.
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream.
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns.
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column.
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider.
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider.
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected.
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text.
Public property | ImageIndexes | Provides an indexed access to the image index of each column.
Public property | Images | Gets or sets the ImageList for code completion items.
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI.
Public property | InvokeChar | Specifies a character that triggered code completion invocation
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name.
Public property | NeedSort | Specifies if provider content needs to be sorted.
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object.
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control.
Public property | Strings | Provides an indexed access to the text of default column.
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text.
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control.
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed.
Public event | ShowPopup | Occurs when popup control is displayed.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionBraceInfo
Alternet.Syntax.CodeCompletionCodeFixItems
Alternet.Syntax.CodeCompletionCodeRefactorItems
Alternet.Syntax.CodeCompletionCodeSnippetMembers
Alternet.Syntax.CodeCompletionCodeSnippets
Alternet.Syntax.CodeCompletionCodeSnippetsProvider
Alternet.Syntax.CodeCompletionCommentInfo
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionQuickInfo


CodeCompletionProvider Constructor

CodeCompletionProvider Constructor
Initializes a new instance of the CodeCompletionProvider class

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionProvider()
Public Sub New
public:
CodeCompletionProvider()
new : unit -> CodeCompletionProvider
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider Methods

CodeCompletionProvider Methods

The CodeCompletionProvider type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required.
Public method | ColumnVisible | Indicates whether specified column is visible.
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from given item in the specified column.
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection.
Public method | GetDisplayText | Returns string representing the display text of the item.
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index.
Public method | GetImageIndex | Returns number of image that is displayed for item given by index.
Public method | GetInsertText | Returns string to be inserted.
Public method | GetName | Returns string representing name of the item.
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance.
Public method | GetPriority | Returns priority of the item.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name.
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet.
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet.
Public method | OnClosePopup | Raises ClosePopup event.
Public method | OnShowPopup | Raises ShowPopup event.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file.
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file.
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream.
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.ColumnSpace Method

CodeCompletionProviderColumnSpace Method
Indicates whether after specified column SPACE is required.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ColumnSpace(
    int column
)
Public Overridable Function ColumnSpace (
    column As Integer
) As Boolean
public:
virtual bool ColumnSpace(
    int column
)
abstract ColumnSpace :
        column : int -> bool
override ColumnSpace :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if should; otherwise false.

Implements

ICodeCompletionProviderColumnSpace(Int32)
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.ColumnVisible Method

CodeCompletionProviderColumnVisible Method
Indicates whether specified column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ColumnVisible(
    int column
)
Public Overridable Function ColumnVisible (
    column As Integer
) As Boolean
public:
virtual bool ColumnVisible(
    int column
)
abstract ColumnVisible :
        column : int -> bool
override ColumnVisible :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICodeCompletionProviderColumnVisible(Int32)
Remarks
In this class method always return false. Descendant classes can override this method.
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetColumnText Method

CodeCompletionProviderGetColumnText Method
Returns text from given item in the specified column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetColumnText(
    int index,
    int column
)
Public Overridable Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
)
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the item.
column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: String
Text representing specified item.

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
Remarks
In this class method always return empty string. Descendant classes can override this method.
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetDescription Method

CodeCompletionProviderGetDescription Method
Returns a content of the column, named 'Description', of the specified item from the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetDescription(
    int index
)
Public Overridable Function GetDescription (
    index As Integer
) As String
public:
virtual String^ GetDescription(
    int index
)
abstract GetDescription :
        index : int -> string
override GetDescription :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of the item within the collection.

Return Value

Type: String
String content of specified column.

Implements

ICodeCompletionProviderGetDescription(Int32)
Remarks
In this class method always return empty string. Descendant classes can override this method.
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetDisplayText Method

CodeCompletionProviderGetDisplayText Method
Returns string representing the display text of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetDisplayText(
    int index
)
Public Overridable Function GetDisplayText (
    index As Integer
) As String
public:
virtual String^ GetDisplayText(
    int index
)
abstract GetDisplayText :
        index : int -> string
override GetDisplayText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing display text of specified item.

Implements

ICodeCompletionProviderGetDisplayText(Int32)
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetFullDisplayText Method

CodeCompletionProviderGetFullDisplayText Method
Returns string representing full display text of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetFullDisplayText(
    int index
)
Public Overridable Function GetFullDisplayText (
    index As Integer
) As String
public:
virtual String^ GetFullDisplayText(
    int index
)
abstract GetFullDisplayText :
        index : int -> string
override GetFullDisplayText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing full display text of specified item.

Implements

ICodeCompletionProviderGetFullDisplayText(Int32)
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetImage Method

CodeCompletionProviderGetImage Method
Returns number of image that is displayed for item given by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Image GetImage(
    int index
)
Public Overridable Function GetImage (
    index As Integer
) As Image
public:
virtual Image^ GetImage(
    int index
)
abstract GetImage :
        index : int -> Image
override GetImage :
        index : int -> Image

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: Image
Index of image corresponding to given item.

Implements

ICodeCompletionProviderGetImage(Int32)
Remarks
In this class method always return -1. Descendant classes can override this method.
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetImageIndex Method

CodeCompletionProviderGetImageIndex Method
Returns number of image that is displayed for item given by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetImageIndex(
    int index
)
Public Overridable Function GetImageIndex (
    index As Integer
) As Integer
public:
virtual int GetImageIndex(
    int index
)
abstract GetImageIndex :
        index : int -> int
override GetImageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: Int32
Index of image corresponding to given item.

Implements

ICodeCompletionProviderGetImageIndex(Int32)
Remarks
In this class method always return -1. Descendant classes can override this method.
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetInsertText Method

CodeCompletionProviderGetInsertText Method
Returns string to be inserted.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetInsertText(
    int index
)
Public Overridable Function GetInsertText (
    index As Integer
) As String
public:
virtual String^ GetInsertText(
    int index
)
abstract GetInsertText :
        index : int -> string
override GetInsertText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
Text to be inserted.

Implements

ICodeCompletionProviderGetInsertText(Int32)
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetName Method

CodeCompletionProviderGetName Method
Returns string representing name of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetName(
    int index
)
Public Overridable Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
)
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing name of specified item.

Implements

ICodeCompletionProviderGetName(Int32)
Remarks
In this class method always return empty string. Descendant classes can override this method.
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetParent Method

CodeCompletionProviderGetParent Method
Returns code completion provider owning this ICodeCompletionProvider instance.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeCompletionProvider GetParent()
Public Overridable Function GetParent As ICodeCompletionProvider
public:
virtual ICodeCompletionProvider^ GetParent()
abstract GetParent : unit -> ICodeCompletionProvider
override GetParent : unit -> ICodeCompletionProvider

Return Value

Type: ICodeCompletionProvider
Parent of the ICodeCompletionProvider.

Implements

ICodeCompletionProviderGetParent
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetPriority Method

CodeCompletionProviderGetPriority Method
Returns priority of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPriority(
    int index
)
Public Overridable Function GetPriority (
    index As Integer
) As Integer
public:
virtual int GetPriority(
    int index
)
abstract GetPriority :
        index : int -> int
override GetPriority :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: Int32
Integer representing priority of specified item.

Implements

ICodeCompletionProviderGetPriority(Int32)
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.GetText Method

CodeCompletionProviderGetText Method
Returns string representing default column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetText(
    int index
)
Public Overridable Function GetText (
    index As Integer
) As String
public:
virtual String^ GetText(
    int index
)
abstract GetText :
        index : int -> string
override GetText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
Text representing default column.

Implements

ICodeCompletionProviderGetText(Int32)
Remarks
In this class method always return empty string. Descendant classes can override this method.
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.IndexOfName Method

CodeCompletionProviderIndexOfName Method
Returns index of the item within collection by it's name.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int IndexOfName(
    string name,
    bool caseSensitive
)
Public Overridable Function IndexOfName (
    name As String,
    caseSensitive As Boolean
) As Integer
public:
virtual int IndexOfName(
    String^ name,
    bool caseSensitive
)
abstract IndexOfName :
        name : string *
        caseSensitive : bool -> int
override IndexOfName :
        name : string *
        caseSensitive : bool -> int

Parameters

name
Type: SystemString
Specifies Name property of item to locate.
caseSensitive
Type: SystemBoolean
Indicates whether search should be case sensitive.

Return Value

Type: Int32
Index of found item.

Implements

ICodeCompletionProviderIndexOfName(String, Boolean)
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.LoadFile Method

CodeCompletionProviderLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet.
Top
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.LoadFile Method (String)

CodeCompletionProviderLoadFile Method (String)
Loads the contents of the specified file into the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName
)
Public Overridable Function LoadFile (
    fileName As String
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool
override LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String)
See Also

Reference

CodeCompletionProvider Class
LoadFile Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.LoadFile Method (String, Encoding)

CodeCompletionProviderLoadFile Method (String, Encoding)
Loads the contents of the specified file into the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

CodeCompletionProvider Class
LoadFile Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.LoadStream Method

CodeCompletionProviderLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet.
Top
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.LoadStream Method (Stream)

CodeCompletionProviderLoadStream Method (Stream)
Loads the contents of the given stream into the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream
)
Public Overridable Function LoadStream (
    stream As Stream
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream
)
abstract LoadStream :
        stream : Stream -> bool
override LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream)
See Also

Reference

CodeCompletionProvider Class
LoadStream Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.LoadStream Method (TextReader)

CodeCompletionProviderLoadStream Method (TextReader)
Loads the contents of the specified stream into the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader
)
Public Overridable Function LoadStream (
    reader As TextReader
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool
override LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(TextReader)
See Also

Reference

CodeCompletionProvider Class
LoadStream Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.LoadStream Method (Stream, Encoding)

CodeCompletionProviderLoadStream Method (Stream, Encoding)
Loads the contents of the given stream into the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream, Encoding)
See Also

Reference

CodeCompletionProvider Class
LoadStream Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.OnClosePopup Method

CodeCompletionProviderOnClosePopup Method
Raises ClosePopup event.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnClosePopup(
    Object sender,
    ClosingEventArgs e
)
Public Overridable Sub OnClosePopup (
    sender As Object,
    e As ClosingEventArgs
)
public:
virtual void OnClosePopup(
    Object^ sender,
    ClosingEventArgs^ e
)
abstract OnClosePopup :
        sender : Object *
        e : ClosingEventArgs -> unit
override OnClosePopup :
        sender : Object *
        e : ClosingEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxClosingEventArgs
A ClosingEventArgs that contains the event data.

Implements

ICodeCompletionProviderOnClosePopup(Object, ClosingEventArgs)
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.OnShowPopup Method

CodeCompletionProviderOnShowPopup Method
Raises ShowPopup event.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OnShowPopup(
    Object sender,
    ShowingEventArgs e
)
Public Overridable Sub OnShowPopup (
    sender As Object,
    e As ShowingEventArgs
)
public:
virtual void OnShowPopup(
    Object^ sender,
    ShowingEventArgs^ e
)
abstract OnShowPopup :
        sender : Object *
        e : ShowingEventArgs -> unit
override OnShowPopup :
        sender : Object *
        e : ShowingEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxShowingEventArgs
A ShowingEventArgs that contains the event data.

Implements

ICodeCompletionProviderOnShowPopup(Object, ShowingEventArgs)
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.SaveFile Method

CodeCompletionProviderSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | Saves content of the snippet to the specific file.
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file.
Top
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.SaveFile Method (String)

CodeCompletionProviderSaveFile Method (String)
Saves content of the snippet to the specific file.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName
)
Public Overridable Function SaveFile (
    fileName As String
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> bool
override SaveFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String)
See Also

Reference

CodeCompletionProvider Class
SaveFile Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.SaveFile Method (String, Encoding)

CodeCompletionProviderSaveFile Method (String, Encoding)
Saves content of the snippet to the specific file.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String, Encoding)
See Also

Reference

CodeCompletionProvider Class
SaveFile Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.SaveStream Method

CodeCompletionProviderSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream.
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream.
Top
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.SaveStream Method (Stream)

CodeCompletionProviderSaveStream Method (Stream)
Saves content of the snippet to the specified stream.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream
)
Public Overridable Function SaveStream (
    stream As Stream
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream
)
abstract SaveStream :
        stream : Stream -> bool
override SaveStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream)
See Also

Reference

CodeCompletionProvider Class
SaveStream Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.SaveStream Method (TextWriter)

CodeCompletionProviderSaveStream Method (TextWriter)
Saves content of the snippet to the specified stream.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer
)
Public Overridable Function SaveStream (
    writer As TextWriter
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer
)
abstract SaveStream :
        writer : TextWriter -> bool
override SaveStream :
        writer : TextWriter -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write text to stream.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(TextWriter)
See Also

Reference

CodeCompletionProvider Class
SaveStream Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.SaveStream Method (Stream, Encoding)

CodeCompletionProviderSaveStream Method (Stream, Encoding)
Saves content of the snippet to the specified stream.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream, Encoding)
See Also

Reference

CodeCompletionProvider Class
SaveStream Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider Properties

CodeCompletionProvider Properties

The CodeCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns.
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column.
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider.
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider.
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected.
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text.
Public property | ImageIndexes | Provides an indexed access to the image index of each column.
Public property | Images | Gets or sets the ImageList for code completion items.
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI.
Public property | InvokeChar | Specifies a character that triggered code completion invocation
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name.
Public property | NeedSort | Specifies if provider content needs to be sorted.
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object.
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control.
Public property | Strings | Provides an indexed access to the text of default column.
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text.
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control.
Top
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.ColumnCount Property

CodeCompletionProviderColumnCount Property
Returns number of the columns.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ColumnCount { get; }
Public Overridable ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get ();
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

ICodeCompletionProviderColumnCount
Remarks
In this class property value equals to 0. Descendant classes can override this method.
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.Descriptions Property

CodeCompletionProviderDescriptions Property
Provides an indexed access to the description of each column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string[] Descriptions { get; }
Public Overridable ReadOnly Property Descriptions As String()
    Get
public:
virtual property array<String^>^ Descriptions {
    array<String^>^ get ();
}
abstract Descriptions : string[] with get
override Descriptions : string[] with get

Property Value

Type: String

Implements

ICodeCompletionProviderDescriptions
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.EditField Property

CodeCompletionProviderEditField Property
Gets or sets a value indicating editable field of the code completion provider.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string EditField { get; set; }
Public Overridable Property EditField As String
    Get
    Set
public:
virtual property String^ EditField {
    String^ get ();
    void set (String^ value);
}
abstract EditField : string with get, set
override EditField : string with get, set

Property Value

Type: String

Implements

ICodeCompletionProviderEditField
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.EditPath Property

CodeCompletionProviderEditPath Property
Gets or sets a value indicating path to the nested code completion provider.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string EditPath { get; }
Public Overridable ReadOnly Property EditPath As String
    Get
public:
virtual property String^ EditPath {
    String^ get ();
}
abstract EditPath : string with get
override EditPath : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderEditPath
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.FocusMode Property

CodeCompletionProviderFocusMode Property
Specifies mode where pre-selected item in code completion listbox is just focused, but not selected.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ItemFocusMode FocusMode { get; set; }
Public Property FocusMode As ItemFocusMode
    Get
    Set
public:
virtual property ItemFocusMode FocusMode {
    ItemFocusMode get () sealed;
    void set (ItemFocusMode value) sealed;
}
abstract FocusMode : ItemFocusMode with get, set
override FocusMode : ItemFocusMode with get, set

Property Value

Type: ItemFocusMode

Implements

ICodeCompletionProviderFocusMode
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.FormatDisplayText Property

CodeCompletionProviderFormatDisplayText Property
Gets a boolean value indicating that rich text formatting should be applied to display text.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FormatDisplayText { get; }
Public Overridable ReadOnly Property FormatDisplayText As Boolean
    Get
public:
virtual property bool FormatDisplayText {
    bool get ();
}
abstract FormatDisplayText : bool with get
override FormatDisplayText : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionProviderFormatDisplayText
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.ImageIndexes Property

CodeCompletionProviderImageIndexes Property
Provides an indexed access to the image index of each column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int[] ImageIndexes { get; }
Public Overridable ReadOnly Property ImageIndexes As Integer()
    Get
public:
virtual property array<int>^ ImageIndexes {
    array<int>^ get ();
}
abstract ImageIndexes : int[] with get
override ImageIndexes : int[] with get

Property Value

Type: Int32

Implements

ICodeCompletionProviderImageIndexes
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.Images Property

CodeCompletionProviderImages Property
Gets or sets the ImageList for code completion items.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList Images { get; set; }
Public Overridable Property Images As ImageList
    Get
    Set
public:
virtual property ImageList^ Images {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract Images : ImageList with get, set
override Images : ImageList with get, set

Property Value

Type: ImageList

Implements

ICodeCompletionProviderImages
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.ImagesHighDpi Property

CodeCompletionProviderImagesHighDpi Property
Gets or sets the ImageList for code completion items for high DPI.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList ImagesHighDpi { get; set; }
Public Overridable Property ImagesHighDpi As ImageList
    Get
    Set
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract ImagesHighDpi : ImageList with get, set
override ImagesHighDpi : ImageList with get, set

Property Value

Type: ImageList

Implements

ICodeCompletionProviderImagesHighDpi
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.InvokeChar Property

CodeCompletionProviderInvokeChar Property
Specifies a character that triggered code completion invocation

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<char> InvokeChar { get; set; }
Public Property InvokeChar As Nullable(Of Char)
    Get
    Set
public:
virtual property Nullable<wchar_t> InvokeChar {
    Nullable<wchar_t> get () sealed;
    void set (Nullable<wchar_t> value) sealed;
}
abstract InvokeChar : Nullable<char> with get, set
override InvokeChar : Nullable<char> with get, set

Property Value

Type: NullableChar

Implements

ICodeCompletionProviderInvokeChar
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.NameColumnIndex Property

CodeCompletionProviderNameColumnIndex Property
Gets index of the column containing name.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Nullable<int> NameColumnIndex { get; }
Public Overridable ReadOnly Property NameColumnIndex As Nullable(Of Integer)
    Get
public:
virtual property Nullable<int> NameColumnIndex {
    Nullable<int> get ();
}
abstract NameColumnIndex : Nullable<int> with get
override NameColumnIndex : Nullable<int> with get

Property Value

Type: NullableInt32

Implements

ICodeCompletionProviderNameColumnIndex
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.NeedSort Property

CodeCompletionProviderNeedSort Property
Specifies if provider content needs to be sorted.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool NeedSort { get; }
Public Overridable ReadOnly Property NeedSort As Boolean
    Get
public:
virtual property bool NeedSort {
    bool get ();
}
abstract NeedSort : bool with get
override NeedSort : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionProviderNeedSort
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.SelIndex Property

CodeCompletionProviderSelIndex Property
Represents the index specifying the currently selected item of the popup control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int SelIndex { get; set; }
Public Overridable Property SelIndex As Integer
    Get
    Set
public:
virtual property int SelIndex {
    int get ();
    void set (int value);
}
abstract SelIndex : int with get, set
override SelIndex : int with get, set

Property Value

Type: Int32

Implements

ICodeCompletionProviderSelIndex
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.SerializationInfo Property

CodeCompletionProviderSerializationInfo Property
Gets or sets an xml representation of this CodeCompletionProvider object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.ShowDescriptions Property

CodeCompletionProviderShowDescriptions Property
Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowDescriptions { get; set; }
Public Overridable Property ShowDescriptions As Boolean
    Get
    Set
public:
virtual property bool ShowDescriptions {
    bool get ();
    void set (bool value);
}
abstract ShowDescriptions : bool with get, set
override ShowDescriptions : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionProviderShowDescriptions
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.Strings Property

CodeCompletionProviderStrings Property
Provides an indexed access to the text of default column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string[] Strings { get; }
Public Overridable ReadOnly Property Strings As String()
    Get
public:
virtual property array<String^>^ Strings {
    array<String^>^ get ();
}
abstract Strings : string[] with get
override Strings : string[] with get

Property Value

Type: String

Implements

ICodeCompletionProviderStrings
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.UseHtmlFormatting Property

CodeCompletionProviderUseHtmlFormatting Property
Gets or sets a boolean value indicating whether html formatting tags may appear in the text.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UseHtmlFormatting { get; set; }
Public Overridable Property UseHtmlFormatting As Boolean
    Get
    Set
public:
virtual property bool UseHtmlFormatting {
    bool get ();
    void set (bool value);
}
abstract UseHtmlFormatting : bool with get, set
override UseHtmlFormatting : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionProviderUseHtmlFormatting
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.UseIndent Property

CodeCompletionProviderUseIndent Property
Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UseIndent { get; set; }
Public Overridable Property UseIndent As Boolean
    Get
    Set
public:
virtual property bool UseIndent {
    bool get ();
    void set (bool value);
}
abstract UseIndent : bool with get, set
override UseIndent : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionProviderUseIndent
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider Events

CodeCompletionProvider Events

The CodeCompletionProvider type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed.
Public event | ShowPopup | Occurs when popup control is displayed.
Top
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.ClosePopup Event

CodeCompletionProviderClosePopup Event
Occurs when popup control is closed.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event ClosePopupEvent ClosePopup
Public Event ClosePopup As ClosePopupEvent
public:
virtual  event ClosePopupEvent^ ClosePopup {
    void add (ClosePopupEvent^ value);
    void remove (ClosePopupEvent^ value);
}
abstract ClosePopup : IEvent<ClosePopupEvent,
    ClosingEventArgs>
override ClosePopup : IEvent<ClosePopupEvent,
    ClosingEventArgs>

Value

Type: Alternet.SyntaxClosePopupEvent

Implements

ICodeCompletionProviderClosePopup
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProvider.ShowPopup Event

CodeCompletionProviderShowPopup Event
Occurs when popup control is displayed.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event ShowPopupEvent ShowPopup
Public Event ShowPopup As ShowPopupEvent
public:
virtual  event ShowPopupEvent^ ShowPopup {
    void add (ShowPopupEvent^ value);
    void remove (ShowPopupEvent^ value);
}
abstract ShowPopup : IEvent<ShowPopupEvent,
    ShowingEventArgs>
override ShowPopup : IEvent<ShowPopupEvent,
    ShowingEventArgs>

Value

Type: Alternet.SyntaxShowPopupEvent

Implements

ICodeCompletionProviderShowPopup
See Also

Reference

CodeCompletionProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderItem Class

CodeCompletionProviderItem Class
Stores particular code completion item.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
More...

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionProviderItem : ICodeCompletionProviderItem,
    IComparable
Public Class CodeCompletionProviderItem
    Implements ICodeCompletionProviderItem, IComparable
public ref class CodeCompletionProviderItem : ICodeCompletionProviderItem,
    IComparable
type CodeCompletionProviderItem =
    class
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeCompletionProviderItem type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionProviderItem | Initializes a new instance of the CodeCompletionProviderItem class
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionBraceInfoItem
Alternet.Syntax.CodeCompletionCodeCompletionProviderNamedItem
Alternet.Syntax.CodeCompletionCodeSnippet
Alternet.Syntax.CodeCompletionCodeSnippetCode
Alternet.Syntax.CodeCompletionCodeSnippetDeclaration
Alternet.Syntax.CodeCompletionCodeSnippetHeader
Alternet.Syntax.CodeCompletionCodeSnippetImport
Alternet.Syntax.CodeCompletionCodeSnippetLiteral
Alternet.Syntax.CodeCompletionCodeSnippetMember
Alternet.Syntax.CodeCompletionCodeSnippetReference
Alternet.Syntax.CodeCompletionCodeSnippetType
Alternet.Syntax.CodeCompletionCommentInfoItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.CodeCompletionParameterMember
Alternet.Syntax.CodeCompletionQuickInfoItem


CodeCompletionProviderItem Constructor

CodeCompletionProviderItem Constructor
Initializes a new instance of the CodeCompletionProviderItem class

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionProviderItem()
Public Sub New
public:
CodeCompletionProviderItem()
new : unit -> CodeCompletionProviderItem
See Also

Reference

CodeCompletionProviderItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderItem Methods

CodeCompletionProviderItem Methods

The CodeCompletionProviderItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeCompletionProviderItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderItem.CompareTo Method

CodeCompletionProviderItemCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CompareTo(
    Object value
)
Public Overridable Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
)
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
See Also

Reference

CodeCompletionProviderItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderItem Properties

CodeCompletionProviderItem Properties

The CodeCompletionProviderItem type exposes the following members.

Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object.
Top
See Also

Reference

CodeCompletionProviderItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderItem.SerializationInfo Property

CodeCompletionProviderItemSerializationInfo Property
When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeCompletionProviderItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderNamedItem Class

CodeCompletionProviderNamedItem Class
Represents particular CodeCompletionProviderNamedItem in the code provider items collection.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProviderNamedItem
Alternet.Syntax.CodeCompletionCodeFixItem
Alternet.Syntax.CodeCompletionCodeRefactorItem

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionProviderNamedItem : CodeCompletionProviderItem,
    ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
Public Class CodeCompletionProviderNamedItem
    Inherits CodeCompletionProviderItem
    Implements ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
public ref class CodeCompletionProviderNamedItem : public CodeCompletionProviderItem,
    ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
type CodeCompletionProviderNamedItem =
    class
        inherit CodeCompletionProviderItem
        interface ICodeCompletionProviderNamedItem
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeCompletionProviderNamedItem type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionProviderNamedItem | Initializes a new instance of the CodeCompletionProviderNamedItem class with default settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomData | Gets an object that can hold a user defined data attached to the CodeCompletionProviderNamedItem
Public property | Description | Gets string value representing description of the CodeCompletionProviderNamedItem.
Public property | ImageIndex | Gets or sets the index of the image displayed for the snippet.
Public property | Name | Gets string value representing name of the CodeCompletionProviderNamedItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderNamedItem Constructor

CodeCompletionProviderNamedItem Constructor
Initializes a new instance of the CodeCompletionProviderNamedItem class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionProviderNamedItem()
Public Sub New
public:
CodeCompletionProviderNamedItem()
new : unit -> CodeCompletionProviderNamedItem
See Also

Reference

CodeCompletionProviderNamedItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderNamedItem Methods

CodeCompletionProviderNamedItem Methods

The CodeCompletionProviderNamedItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeCompletionProviderNamedItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderNamedItem.CompareTo Method

CodeCompletionProviderNamedItemCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

CodeCompletionProviderNamedItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderNamedItem Properties

CodeCompletionProviderNamedItem Properties

The CodeCompletionProviderNamedItem type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | Gets an object that can hold a user defined data attached to the CodeCompletionProviderNamedItem
Public property | Description | Gets string value representing description of the CodeCompletionProviderNamedItem.
Public property | ImageIndex | Gets or sets the index of the image displayed for the snippet.
Public property | Name | Gets string value representing name of the CodeCompletionProviderNamedItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

CodeCompletionProviderNamedItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderNamedItem.CustomData Property

CodeCompletionProviderNamedItemCustomData Property
Gets an object that can hold a user defined data attached to the CodeCompletionProviderNamedItem

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object CustomData { get; }
Public Overridable ReadOnly Property CustomData As Object
    Get
public:
virtual property Object^ CustomData {
    Object^ get ();
}
abstract CustomData : Object with get
override CustomData : Object with get

Property Value

Type: Object

Implements

ICodeCompletionProviderNamedItemCustomData
See Also

Reference

CodeCompletionProviderNamedItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderNamedItem.Description Property

CodeCompletionProviderNamedItemDescription Property
Gets string value representing description of the CodeCompletionProviderNamedItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; }
Public Overridable ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get ();
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderNamedItemDescription
See Also

Reference

CodeCompletionProviderNamedItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderNamedItem.ImageIndex Property

CodeCompletionProviderNamedItemImageIndex Property
Gets or sets the index of the image displayed for the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ImageIndex { get; set; }
Public Overridable Property ImageIndex As Integer
    Get
    Set
public:
virtual property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set
override ImageIndex : int with get, set

Property Value

Type: Int32

Implements

ICodeCompletionProviderNamedItemImageIndex
See Also

Reference

CodeCompletionProviderNamedItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionProviderNamedItem.Name Property

CodeCompletionProviderNamedItemName Property
Gets string value representing name of the CodeCompletionProviderNamedItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderNamedItemName
See Also

Reference

CodeCompletionProviderNamedItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository Class

CodeCompletionRepository Class
Represents properties and methods to perform code completion functionality.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeCompletionRepository : ICodeCompletionRepository,
    IDisposable
Public Class CodeCompletionRepository
    Implements ICodeCompletionRepository, IDisposable
public ref class CodeCompletionRepository : ICodeCompletionRepository,
    IDisposable
type CodeCompletionRepository =
    class
        interface ICodeCompletionRepository
        interface IDisposable
    end

The CodeCompletionRepository type exposes the following members.

Constructors
 | Name | Description
Public method | CodeCompletionRepository | Initializes a new instance of the CodeCompletionRepository class with specified parameters.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CodeCompletionRepository
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element.
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element.
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FindDeclaration | Obtains information about where the language element is declared.
Public method | FindReferences | Locates all references to the node in the text.
Public method | GetCodeSnippets | Returns code snippets for the given language.
Public method | GetDescription | Obtains description of some language element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element.
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations.
Public method | GetMethodType | Obtains information about some method of specified language element.
Public method | GetNodeType | Obtains information type of the SyntaxNode
Public method | GetPriority | Obtains priority of the given language element. Specifies language element
Public method | GetQuickInfo(Object) | Returns information about the object.
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node.
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window.
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets.
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees.
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive.
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection.
Public property | Images | Gets or sets ImageList attached to this CodeCompletionRepository.
Public property | ImagesHighDpi | Gets or sets ImageList attached to this CodeCompletionRepository for high DPI.
Public property | ImagesResourceNameSuffix |
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window.
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements.
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository.
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element.
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository Constructor

CodeCompletionRepository Constructor
Initializes a new instance of the CodeCompletionRepository class with specified parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeCompletionRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
CodeCompletionRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> CodeCompletionRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository Methods

CodeCompletionRepository Methods

The CodeCompletionRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element.
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element.
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FindDeclaration | Obtains information about where the language element is declared.
Public method | FindReferences | Locates all references to the node in the text.
Public method | GetCodeSnippets | Returns code snippets for the given language.
Public method | GetDescription | Obtains description of some language element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element.
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations.
Public method | GetMethodType | Obtains information about some method of specified language element.
Public method | GetNodeType | Obtains information type of the SyntaxNode
Public method | GetPriority | Obtains priority of the given language element. Specifies language element
Public method | GetQuickInfo(Object) | Returns information about the object.
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node.
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window.
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets.
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees.
Top
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.Dispose Method

CodeCompletionRepositoryDispose Method
Releases all resources used by the CodeCompletionRepository

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.FillMember Method

CodeCompletionRepositoryFillMember Method
Overload List
 | Name | Description
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element.
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element.
Top
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.FillMember Method (IListMembers, Object, String, CodeCompletionScope)

CodeCompletionRepositoryFillMember Method (IListMembers, Object, String, CodeCompletionScope)
Obtains information about individual member of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillMember(
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope
)
Public Overridable Sub FillMember (
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope
)
public:
virtual void FillMember(
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope
)
abstract FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope -> unit
override FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope -> unit

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of member to retrieve.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
See Also

Reference

CodeCompletionRepository Class
FillMember Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.FillMember Method (IListMembers, Object, String, Int32, CodeCompletionScope)

CodeCompletionRepositoryFillMember Method (IListMembers, Object, String, Int32, CodeCompletionScope)
Obtains information about individual member of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillMember(
    IListMembers members,
    Object member,
    string name,
    int paramIndex,
    CodeCompletionScope scope
)
Public Overridable Sub FillMember (
    members As IListMembers,
    member As Object,
    name As String,
    paramIndex As Integer,
    scope As CodeCompletionScope
)
public:
virtual void FillMember(
    IListMembers^ members,
    Object^ member,
    String^ name,
    int paramIndex,
    CodeCompletionScope scope
)
abstract FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        paramIndex : int *
        scope : CodeCompletionScope -> unit
override FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        paramIndex : int *
        scope : CodeCompletionScope -> unit

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of member to retrieve.
paramIndex
Type: SystemInt32
Specifies index of current member parameter.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.

Implements

ICodeCompletionRepositoryFillMember(IListMembers, Object, String, Int32, CodeCompletionScope)
See Also

Reference

CodeCompletionRepository Class
FillMember Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.FillMembers Method

CodeCompletionRepositoryFillMembers Method
Fills list members provider with list of its member, providing available choices for the specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillMembers(
    ISyntaxNode node,
    Point position,
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope,
    ref int selIndex
)
Public Overridable Sub FillMembers (
    node As ISyntaxNode,
    position As Point,
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope,
    ByRef selIndex As Integer
)
public:
virtual void FillMembers(
    ISyntaxNode^ node,
    Point position,
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope,
    int% selIndex
)
abstract FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit
override FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
position
Type: System.DrawingPoint
Specifies position of language element in the text.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies filter used to fill members.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
selIndex
Type: SystemInt32
Specifies index of default list member.

Implements

ICodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.FindDeclaration Method

CodeCompletionRepositoryFindDeclaration Method
Obtains information about where the language element is declared.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object FindDeclaration(
    string text,
    ISyntaxNode node,
    Point position
)
Public Overridable Function FindDeclaration (
    text As String,
    node As ISyntaxNode,
    position As Point
) As Object
public:
virtual Object^ FindDeclaration(
    String^ text,
    ISyntaxNode^ node,
    Point position
)
abstract FindDeclaration :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object
override FindDeclaration :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object

Parameters

text
Type: SystemString
Specifies the source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies position of language element.

Return Value

Type: Object
ISyntaxNode representing declaration of the language element.

Implements

ICodeCompletionRepositoryFindDeclaration(String, ISyntaxNode, Point)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.FindReferences Method

CodeCompletionRepositoryFindReferences Method
Locates all references to the node in the text.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FindReferences(
    ISyntaxNode node,
    ISyntaxNodes references
)
Public Overridable Function FindReferences (
    node As ISyntaxNode,
    references As ISyntaxNodes
) As Integer
public:
virtual int FindReferences(
    ISyntaxNode^ node,
    ISyntaxNodes^ references
)
abstract FindReferences :
        node : ISyntaxNode *
        references : ISyntaxNodes -> int
override FindReferences :
        node : ISyntaxNode *
        references : ISyntaxNodes -> int

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to find references.
references
Type: Alternet.SyntaxISyntaxNodes
Retrieves references to node.

Return Value

Type: Int32
Number of found references.

Implements

ICodeCompletionRepositoryFindReferences(ISyntaxNode, ISyntaxNodes)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetCodeSnippets Method

CodeCompletionRepositoryGetCodeSnippets Method
Returns code snippets for the given language.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetsProvider GetCodeSnippets(
    string language
)
Public Overridable Function GetCodeSnippets (
    language As String
) As ICodeSnippetsProvider
public:
virtual ICodeSnippetsProvider^ GetCodeSnippets(
    String^ language
)
abstract GetCodeSnippets :
        language : string -> ICodeSnippetsProvider
override GetCodeSnippets :
        language : string -> ICodeSnippetsProvider

Parameters

language
Type: SystemString
Represents a language.

Return Value

Type: ICodeSnippetsProvider
ICodeSnippetsProvider instance for a given language.

Implements

ICodeCompletionRepositoryGetCodeSnippets(String)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetDescription Method

CodeCompletionRepositoryGetDescription Method
Obtains description of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetDescription(
    IListMembers members,
    ISyntaxNode node,
    Object member,
    string name,
    bool fullDescription
)
Public Overridable Function GetDescription (
    members As IListMembers,
    node As ISyntaxNode,
    member As Object,
    name As String,
    fullDescription As Boolean
) As String
public:
virtual String^ GetDescription(
    IListMembers^ members,
    ISyntaxNode^ node,
    Object^ member,
    String^ name,
    bool fullDescription
)
abstract GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string
override GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies ListMembers interface used to get language-specific description.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode that representing language element to describe.
member
Type: SystemObject
Specifies language element to describe.
name
Type: SystemString
Specifies name of described language element.
fullDescription
Type: SystemBoolean
Specifies whether description should include name and type of the found element.

Return Value

Type: String

Implements

ICodeCompletionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetMemberType Method

CodeCompletionRepositoryGetMemberType Method
Overload List
 | Name | Description
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element.
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations.
Top
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetMemberType Method (ISyntaxNode, Point, Object, String, CodeCompletionScope)

CodeCompletionRepositoryGetMemberType Method (ISyntaxNode, Point, Object, String, CodeCompletionScope)
Obtains information about a member of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetMemberType(
    ISyntaxNode node,
    Point position,
    Object member,
    string name,
    out CodeCompletionScope scope
)
Public Overridable Function GetMemberType (
    node As ISyntaxNode,
    position As Point,
    member As Object,
    name As String,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetMemberType(
    ISyntaxNode^ node,
    Point position,
    Object^ member,
    String^ name,
    [OutAttribute] CodeCompletionScope% scope
)
abstract GetMemberType :
        node : ISyntaxNode *
        position : Point *
        member : Object *
        name : string *
        scope : CodeCompletionScope byref -> Object
override GetMemberType :
        node : ISyntaxNode *
        position : Point *
        member : Object *
        name : string *
        scope : CodeCompletionScope byref -> Object

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies position of language element.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of the member to locate.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for this language element.

Return Value

Type: Object
Object representing information about found member.

Implements

ICodeCompletionRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope)
See Also

Reference

CodeCompletionRepository Class
GetMemberType Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetMemberType Method (String, ISyntaxNode, String, Point, Point, CodeCompletionScope)

CodeCompletionRepositoryGetMemberType Method (String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
Obtains information about some language element to perform code completion related operations.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetMemberType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out CodeCompletionScope scope
)
Public Overridable Function GetMemberType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetMemberType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] CodeCompletionScope% scope
)
abstract GetMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object
override GetMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found language element.
position
Type: System.DrawingPoint
Specifies position of found language element in the code text and updates it if needed.
endPos
Type: System.DrawingPoint
Specifies end position of found language element in the code text and updates it if needed.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about language element to complete.

Implements

ICodeCompletionRepositoryGetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
See Also

Reference

CodeCompletionRepository Class
GetMemberType Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetMethodType Method

CodeCompletionRepositoryGetMethodType Method
Obtains information about some method of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetMethodType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out int paramIndex,
    out int paramCount,
    out CodeCompletionScope scope
)
Public Overridable Function GetMethodType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef paramIndex As Integer,
    <OutAttribute> ByRef paramCount As Integer,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetMethodType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] int% paramIndex,
    [OutAttribute] int% paramCount,
    [OutAttribute] CodeCompletionScope% scope
)
abstract GetMethodType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        paramIndex : int byref *
        paramCount : int byref *
        scope : CodeCompletionScope byref -> Object
override GetMethodType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        paramIndex : int byref *
        paramCount : int byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found method.
position
Type: System.DrawingPoint
Retrieves start position of the method in the code text.
endPos
Type: System.DrawingPoint
Retrieves end position of the method in the code text.
paramIndex
Type: SystemInt32
Retrieves index of current parameter in the code text.
paramCount
Type: SystemInt32
Retrieves parameters count in the code text.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about found method.

Implements

ICodeCompletionRepositoryGetMethodType(String, ISyntaxNode, String, Point, Point, Int32, Int32, CodeCompletionScope)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetNodeType Method

CodeCompletionRepositoryGetNodeType Method
Obtains information type of the SyntaxNode

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetNodeType(
    string text,
    ISyntaxNode node,
    Point position
)
Public Overridable Function GetNodeType (
    text As String,
    node As ISyntaxNode,
    position As Point
) As Object
public:
virtual Object^ GetNodeType(
    String^ text,
    ISyntaxNode^ node,
    Point position
)
abstract GetNodeType :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object
override GetNodeType :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies starting position to search.

Return Value

Type: Object
Object representing type of found member.

Implements

ICodeCompletionRepositoryGetNodeType(String, ISyntaxNode, Point)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetPriority Method

CodeCompletionRepositoryGetPriority Method
Obtains priority of the given language element. Specifies language element

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPriority(
    Object member
)
Public Overridable Function GetPriority (
    member As Object
) As Integer
public:
virtual int GetPriority(
    Object^ member
)
abstract GetPriority :
        member : Object -> int
override GetPriority :
        member : Object -> int

Parameters

member
Type: SystemObject

Return Value

Type: Int32

Implements

ICodeCompletionRepositoryGetPriority(Object)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetQuickInfo Method

CodeCompletionRepositoryGetQuickInfo Method
Overload List
 | Name | Description
Public method | GetQuickInfo(Object) | Returns information about the object.
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node.
Top
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetQuickInfo Method (Object)

CodeCompletionRepositoryGetQuickInfo Method (Object)
Returns information about the object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IQuickInfo GetQuickInfo(
    Object member
)
Public Overridable Function GetQuickInfo (
    member As Object
) As IQuickInfo
public:
virtual IQuickInfo^ GetQuickInfo(
    Object^ member
)
abstract GetQuickInfo :
        member : Object -> IQuickInfo
override GetQuickInfo :
        member : Object -> IQuickInfo

Parameters

member
Type: SystemObject
Given object.

Return Value

Type: IQuickInfo
IQuickInfo instance.

Implements

ICodeCompletionRepositoryGetQuickInfo(Object)
See Also

Reference

CodeCompletionRepository Class
GetQuickInfo Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetQuickInfo Method (ISyntaxNode)

CodeCompletionRepositoryGetQuickInfo Method (ISyntaxNode)
Returns information about the node.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IQuickInfo GetQuickInfo(
    ISyntaxNode node
)
Public Overridable Function GetQuickInfo (
    node As ISyntaxNode
) As IQuickInfo
public:
virtual IQuickInfo^ GetQuickInfo(
    ISyntaxNode^ node
)
abstract GetQuickInfo :
        node : ISyntaxNode -> IQuickInfo
override GetQuickInfo :
        node : ISyntaxNode -> IQuickInfo

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Given syntax node.

Return Value

Type: IQuickInfo
IQuickInfo instance.

Implements

ICodeCompletionRepositoryGetQuickInfo(ISyntaxNode)
See Also

Reference

CodeCompletionRepository Class
GetQuickInfo Overload
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.GetSpecialMemberType Method

CodeCompletionRepositoryGetSpecialMemberType Method
Obtains information about some language element to perform code completion related operations in special cases.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetSpecialMemberType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out CodeCompletionScope scope
)
Public Overridable Function GetSpecialMemberType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetSpecialMemberType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] CodeCompletionScope% scope
)
abstract GetSpecialMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object
override GetSpecialMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found language element.
position
Type: System.DrawingPoint
Specifies position of found language element in the code text and updates it if needed.
endPos
Type: System.DrawingPoint
Specifies position of found language element in the code text and updates it if needed.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about language element to complete.

Implements

ICodeCompletionRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.IsStructureGuideNode Method

CodeCompletionRepositoryIsStructureGuideNode Method
Indicates whether specified ISyntaxNode is guide node.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsStructureGuideNode(
    ISyntaxNode node,
    out IRange range
)
Public Overridable Function IsStructureGuideNode (
    node As ISyntaxNode,
    <OutAttribute> ByRef range As IRange
) As Boolean
public:
virtual bool IsStructureGuideNode(
    ISyntaxNode^ node,
    [OutAttribute] IRange^% range
)
abstract IsStructureGuideNode :
        node : ISyntaxNode *
        range : IRange byref -> bool
override IsStructureGuideNode :
        node : ISyntaxNode *
        range : IRange byref -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to check.
range
Type: Alternet.CommonIRange
Output parameter receives guide range.

Return Value

Type: Boolean
True if ISyntaxNode is guide node; otherwise false.

Implements

ICodeCompletionRepositoryIsStructureGuideNode(ISyntaxNode, IRange)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.RegisterSnippet Method

CodeCompletionRepositoryRegisterSnippet Method
When implemented by a class, registers snippet to be displayed in code completion window.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterSnippet(
    string snippet,
    bool isStatement
)
Public Overridable Sub RegisterSnippet (
    snippet As String,
    isStatement As Boolean
)
public:
virtual void RegisterSnippet(
    String^ snippet,
    bool isStatement
)
abstract RegisterSnippet :
        snippet : string *
        isStatement : bool -> unit
override RegisterSnippet :
        snippet : string *
        isStatement : bool -> unit

Parameters

snippet
Type: SystemString
Specifies name of snippet to be displayed.
isStatement
Type: SystemBoolean
Specifies whether snippet will have statement image index.

Implements

ICodeCompletionRepositoryRegisterSnippet(String, Boolean)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.RegisterSyntaxTree Method

CodeCompletionRepositoryRegisterSyntaxTree Method
Adds specified tree to the list of syntax trees for code-completion related purposes.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterSyntaxTree(
    ISyntaxTree tree
)
Public Overridable Sub RegisterSyntaxTree (
    tree As ISyntaxTree
)
public:
virtual void RegisterSyntaxTree(
    ISyntaxTree^ tree
)
abstract RegisterSyntaxTree :
        tree : ISyntaxTree -> unit
override RegisterSyntaxTree :
        tree : ISyntaxTree -> unit

Parameters

tree
Type: Alternet.SyntaxISyntaxTree
Specifies ISyntaxTree to add.

Implements

ICodeCompletionRepositoryRegisterSyntaxTree(ISyntaxTree)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.UnregisterSnippet Method

CodeCompletionRepositoryUnregisterSnippet Method
When implemented by a class, removes specified snippet from the list of snippets.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterSnippet(
    string snippet
)
Public Overridable Function UnregisterSnippet (
    snippet As String
) As Boolean
public:
virtual bool UnregisterSnippet(
    String^ snippet
)
abstract UnregisterSnippet :
        snippet : string -> bool
override UnregisterSnippet :
        snippet : string -> bool

Parameters

snippet
Type: SystemString
Specifies name of snippet to be removed.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ICodeCompletionRepositoryUnregisterSnippet(String)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.UnregisterSyntaxTree Method

CodeCompletionRepositoryUnregisterSyntaxTree Method
Removes specified tree from the list of syntax trees.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterSyntaxTree(
    ISyntaxTree tree
)
Public Overridable Function UnregisterSyntaxTree (
    tree As ISyntaxTree
) As Boolean
public:
virtual bool UnregisterSyntaxTree(
    ISyntaxTree^ tree
)
abstract UnregisterSyntaxTree :
        tree : ISyntaxTree -> bool
override UnregisterSyntaxTree :
        tree : ISyntaxTree -> bool

Parameters

tree
Type: Alternet.SyntaxISyntaxTree
Specifies ISyntaxTree to remove.

Return Value

Type: Boolean
True if succeed (tree is present in the tree list); otherwise false.

Implements

ICodeCompletionRepositoryUnregisterSyntaxTree(ISyntaxTree)
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository Properties

CodeCompletionRepository Properties

The CodeCompletionRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive.
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection.
Public property | Images | Gets or sets ImageList attached to this CodeCompletionRepository.
Public property | ImagesHighDpi | Gets or sets ImageList attached to this CodeCompletionRepository for high DPI.
Public property | ImagesResourceNameSuffix |
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window.
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements.
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository.
Top
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.CaseSensitive Property

CodeCompletionRepositoryCaseSensitive Property
Indicates whether searching for language element's members should be case sensitive.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CaseSensitive { get; }
Public Overridable ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get ();
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionRepositoryCaseSensitive
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.FillBaseMembers Property

CodeCompletionRepositoryFillBaseMembers Property
Indicates whether members of Object class should be present in the member collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FillBaseMembers { get; set; }
Public Overridable Property FillBaseMembers As Boolean
    Get
    Set
public:
virtual property bool FillBaseMembers {
    bool get ();
    void set (bool value);
}
abstract FillBaseMembers : bool with get, set
override FillBaseMembers : bool with get, set

Property Value

Type: Boolean

Implements

ICodeCompletionRepositoryFillBaseMembers
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.Images Property

CodeCompletionRepositoryImages Property
Gets or sets ImageList attached to this CodeCompletionRepository.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList Images { get; }
Public Overridable ReadOnly Property Images As ImageList
    Get
public:
virtual property ImageList^ Images {
    ImageList^ get ();
}
abstract Images : ImageList with get
override Images : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImages
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.ImagesHighDpi Property

CodeCompletionRepositoryImagesHighDpi Property
Gets or sets ImageList attached to this CodeCompletionRepository for high DPI.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ImageList ImagesHighDpi { get; }
Public Overridable ReadOnly Property ImagesHighDpi As ImageList
    Get
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get ();
}
abstract ImagesHighDpi : ImageList with get
override ImagesHighDpi : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImagesHighDpi
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.ImagesResourceNameSuffix Property

CodeCompletionRepositoryImagesResourceNameSuffix Property

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ImagesResourceNameSuffix { get; set; }
Public Property ImagesResourceNameSuffix As String
    Get
    Set
public:
virtual property String^ ImagesResourceNameSuffix {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ImagesResourceNameSuffix : string with get, set
override ImagesResourceNameSuffix : string with get, set

Property Value

Type: String

Implements

ICodeCompletionRepositoryImagesResourceNameSuffix
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.Snippets Property

CodeCompletionRepositorySnippets Property
Represents a collection of snippets that are displayed in code completion window.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Hashtable Snippets { get; }
Public Overridable ReadOnly Property Snippets As Hashtable
    Get
public:
virtual property Hashtable^ Snippets {
    Hashtable^ get ();
}
abstract Snippets : Hashtable with get
override Snippets : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.SyntaxTree Property

CodeCompletionRepositorySyntaxTree Property
Gets or sets a hierarchical collection of ISyntaxNode elements.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxTree SyntaxTree { get; }
Public Overridable ReadOnly Property SyntaxTree As ISyntaxTree
    Get
public:
virtual property ISyntaxTree^ SyntaxTree {
    ISyntaxTree^ get ();
}
abstract SyntaxTree : ISyntaxTree with get
override SyntaxTree : ISyntaxTree with get

Property Value

Type: ISyntaxTree

Implements

ICodeCompletionRepositorySyntaxTree
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.SyntaxTrees Property

CodeCompletionRepositorySyntaxTrees Property
Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<ISyntaxTree> SyntaxTrees { get; }
Public Overridable ReadOnly Property SyntaxTrees As IList(Of ISyntaxTree)
    Get
public:
virtual property IList<ISyntaxTree^>^ SyntaxTrees {
    IList<ISyntaxTree^>^ get ();
}
abstract SyntaxTrees : IList<ISyntaxTree> with get
override SyntaxTrees : IList<ISyntaxTree> with get

Property Value

Type: IListISyntaxTree

Implements

ICodeCompletionRepositorySyntaxTrees
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository Events

CodeCompletionRepository Events

The CodeCompletionRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element.
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element.
Top
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.DescriptionLookup Event

CodeCompletionRepositoryDescriptionLookup Event
Occurs while trying to obtain description of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event DescriptionLookupEvent DescriptionLookup
Public Event DescriptionLookup As DescriptionLookupEvent
public:
virtual  event DescriptionLookupEvent^ DescriptionLookup {
    void add (DescriptionLookupEvent^ value);
    void remove (DescriptionLookupEvent^ value);
}
abstract DescriptionLookup : IEvent<DescriptionLookupEvent,
    DescriptionLookupEventArgs>
override DescriptionLookup : IEvent<DescriptionLookupEvent,
    DescriptionLookupEventArgs>

Value

Type: Alternet.SyntaxDescriptionLookupEvent

Implements

ICodeCompletionRepositoryDescriptionLookup
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeCompletionRepository.MemberLookup Event

CodeCompletionRepositoryMemberLookup Event
Occurs while trying to obtain information about some member of language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event MemberLookupEvent MemberLookup
Public Event MemberLookup As MemberLookupEvent
public:
virtual  event MemberLookupEvent^ MemberLookup {
    void add (MemberLookupEvent^ value);
    void remove (MemberLookupEvent^ value);
}
abstract MemberLookup : IEvent<MemberLookupEvent,
    MemberLookupEventArgs>
override MemberLookup : IEvent<MemberLookupEvent,
    MemberLookupEventArgs>

Value

Type: Alternet.SyntaxMemberLookupEvent

Implements

ICodeCompletionRepositoryMemberLookup
See Also

Reference

CodeCompletionRepository Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem Class

CodeFixItem Class
Represents particular code ix in the code fix collection.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProviderNamedItem
Alternet.Syntax.CodeCompletionCodeFixItem

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeFixItem : CodeCompletionProviderNamedItem,
    ICodeFixItem, ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
Public Class CodeFixItem
    Inherits CodeCompletionProviderNamedItem
    Implements ICodeFixItem, ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
public ref class CodeFixItem : public CodeCompletionProviderNamedItem,
    ICodeFixItem, ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
type CodeFixItem =
    class
        inherit CodeCompletionProviderNamedItem
        interface ICodeFixItem
        interface ICodeCompletionProviderNamedItem
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeFixItem type exposes the following members.

Constructors
 | Name | Description
Public method | CodeFixItem | Initializes a new instance of the CodeFixItem class with default settings.
Public method | CodeFixItem(ICodeFixItems) | Initializes a new instance of the CodeFixItem class with specified parent.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeCompletionProviderNamedItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CodeFix | Gets an assosicated code fix object.
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the code fix. (Overrides CodeCompletionProviderNamedItemCustomData.)
Public property | Description | Gets string value representing description of the CodeFixItem. (Overrides CodeCompletionProviderNamedItemDescription.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the snippet. (Inherited from CodeCompletionProviderNamedItem.)
Public property | Name | Gets string value representing description of the CodeFixItem. (Overrides CodeCompletionProviderNamedItemName.)
Public property | Parent | Gets or sets a parent of the CodeFixItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeFixItem Constructor

CodeFixItem Constructor
Overload List
 | Name | Description
Public method | CodeFixItem | Initializes a new instance of the CodeFixItem class with default settings.
Public method | CodeFixItem(ICodeFixItems) | Initializes a new instance of the CodeFixItem class with specified parent.
Top
See Also

Reference

CodeFixItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem Constructor

CodeFixItem Constructor
Initializes a new instance of the CodeFixItem class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeFixItem()
Public Sub New
public:
CodeFixItem()
new : unit -> CodeFixItem
See Also

Reference

CodeFixItem Class
CodeFixItem Overload
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem Constructor (ICodeFixItems)

CodeFixItem Constructor (ICodeFixItems)
Initializes a new instance of the CodeFixItem class with specified parent.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeFixItem(
    ICodeFixItems parent
)
Public Sub New (
    parent As ICodeFixItems
)
public:
CodeFixItem(
    ICodeFixItems^ parent
)
new :
        parent : ICodeFixItems -> CodeFixItem

Parameters

parent
Type: Alternet.Syntax.CodeCompletionICodeFixItems
See Also

Reference

CodeFixItem Class
CodeFixItem Overload
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem Methods

CodeFixItem Methods

The CodeFixItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeCompletionProviderNamedItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeFixItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem Properties

CodeFixItem Properties

The CodeFixItem type exposes the following members.

Properties
 | Name | Description
Public property | CodeFix | Gets an assosicated code fix object.
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the code fix. (Overrides CodeCompletionProviderNamedItemCustomData.)
Public property | Description | Gets string value representing description of the CodeFixItem. (Overrides CodeCompletionProviderNamedItemDescription.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the snippet. (Inherited from CodeCompletionProviderNamedItem.)
Public property | Name | Gets string value representing description of the CodeFixItem. (Overrides CodeCompletionProviderNamedItemName.)
Public property | Parent | Gets or sets a parent of the CodeFixItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

CodeFixItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem.CodeFix Property

CodeFixItemCodeFix Property
Gets an assosicated code fix object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeFix CodeFix { get; set; }
Public Overridable Property CodeFix As ICodeFix
    Get
    Set
public:
virtual property ICodeFix^ CodeFix {
    ICodeFix^ get ();
    void set (ICodeFix^ value);
}
abstract CodeFix : ICodeFix with get, set
override CodeFix : ICodeFix with get, set

Property Value

Type: ICodeFix

Implements

ICodeFixItemCodeFix
See Also

Reference

CodeFixItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem.CustomData Property

CodeFixItemCustomData Property
Gets or sets an object that can hold a user defined data attached to the code fix.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object CustomData { get; }
Public Overrides ReadOnly Property CustomData As Object
    Get
public:
virtual property Object^ CustomData {
    Object^ get () override;
}
abstract CustomData : Object with get
override CustomData : Object with get

Property Value

Type: Object

Implements

ICodeCompletionProviderNamedItemCustomData
ICodeCompletionProviderNamedItemCustomData
See Also

Reference

CodeFixItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem.Description Property

CodeFixItemDescription Property
Gets string value representing description of the CodeFixItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderNamedItemDescription
ICodeCompletionProviderNamedItemDescription
See Also

Reference

CodeFixItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem.Name Property

CodeFixItemName Property
Gets string value representing description of the CodeFixItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderNamedItemName
ICodeCompletionProviderNamedItemName
See Also

Reference

CodeFixItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItem.Parent Property

CodeFixItemParent Property
Gets or sets a parent of the CodeFixItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeFixItems Parent { get; set; }
Public Overridable Property Parent As ICodeFixItems
    Get
    Set
public:
virtual property ICodeFixItems^ Parent {
    ICodeFixItems^ get ();
    void set (ICodeFixItems^ value);
}
abstract Parent : ICodeFixItems with get, set
override Parent : ICodeFixItems with get, set

Property Value

Type: ICodeFixItems

Implements

ICodeFixItemParent
See Also

Reference

CodeFixItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems Class

CodeFixItems Class
Represents collection containing list of code fixes.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionCodeFixItems

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeFixItems : CodeCompletionProvider,
    ICodeFixItems, ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Class CodeFixItems
    Inherits CodeCompletionProvider
    Implements ICodeFixItems, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class CodeFixItems : public CodeCompletionProvider,
    ICodeFixItems, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type CodeFixItems =
    class
        inherit CodeCompletionProvider
        interface ICodeFixItems
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The CodeFixItems type exposes the following members.

Constructors
 | Name | Description
Public method | CodeFixItems | Initializes a new instance of the CodeFixItems class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddCodeFix | Adds a new item to the ICodeFixItem collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns description of the code fix specified by index. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeFixItem.ImageIndex from the code fix collection specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns description of the code fix specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from CodeCompletionProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertCodeFix | Inserts a new item to the specified position within the ICodeFixItems collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to CodeFixItem objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeFixItems Constructor

CodeFixItems Constructor
Initializes a new instance of the CodeFixItems class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeFixItems()
Public Sub New
public:
CodeFixItems()
new : unit -> CodeFixItems
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems Methods

CodeFixItems Methods

The CodeFixItems type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddCodeFix | Adds a new item to the ICodeFixItem collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns description of the code fix specified by index. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeFixItem.ImageIndex from the code fix collection specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns description of the code fix specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from CodeCompletionProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertCodeFix | Inserts a new item to the specified position within the ICodeFixItems collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems.AddCodeFix Method

CodeFixItemsAddCodeFix Method
Adds a new item to the ICodeFixItem collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeFixItem AddCodeFix()
Public Overridable Function AddCodeFix As ICodeFixItem
public:
virtual ICodeFixItem^ AddCodeFix()
abstract AddCodeFix : unit -> ICodeFixItem
override AddCodeFix : unit -> ICodeFixItem

Return Value

Type: ICodeFixItem
ICodeFixItem that is added.

Implements

ICodeFixItemsAddCodeFix
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems.ColumnVisible Method

CodeFixItemsColumnVisible Method
Indicates whether specified column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ColumnVisible(
    int column
)
Public Overrides Function ColumnVisible (
    column As Integer
) As Boolean
public:
virtual bool ColumnVisible(
    int column
) override
abstract ColumnVisible :
        column : int -> bool
override ColumnVisible :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICodeCompletionProviderColumnVisible(Int32)
ICodeCompletionProviderColumnVisible(Int32)
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems.GetColumnText Method

CodeFixItemsGetColumnText Method
Returns text from specified column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the code fix.
column
Type: SystemInt32
Specifies column index.

Return Value

Type: String
Text representing specified code fix.

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems.GetDescription Method

CodeFixItemsGetDescription Method
Returns description of the code fix specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDescription(
    int index
)
Public Overrides Function GetDescription (
    index As Integer
) As String
public:
virtual String^ GetDescription(
    int index
) override
abstract GetDescription :
        index : int -> string
override GetDescription :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the code fix item.

Return Value

Type: String

Implements

ICodeCompletionProviderGetDescription(Int32)
ICodeCompletionProviderGetDescription(Int32)
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems.GetImageIndex Method

CodeFixItemsGetImageIndex Method
Returns ICodeFixItem.ImageIndex from the code fix collection specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetImageIndex(
    int index
)
Public Overrides Function GetImageIndex (
    index As Integer
) As Integer
public:
virtual int GetImageIndex(
    int index
) override
abstract GetImageIndex :
        index : int -> int
override GetImageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Specifies index of the code fix.

Return Value

Type: Int32

Implements

ICodeCompletionProviderGetImageIndex(Int32)
ICodeCompletionProviderGetImageIndex(Int32)
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems.GetName Method

CodeFixItemsGetName Method
Returns description of the code fix specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetName(
    int index
)
Public Overrides Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
) override
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the code fix item.

Return Value

Type: String

Implements

ICodeCompletionProviderGetName(Int32)
ICodeCompletionProviderGetName(Int32)
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems.InsertCodeFix Method

CodeFixItemsInsertCodeFix Method
Inserts a new item to the specified position within the ICodeFixItems collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeFixItem InsertCodeFix(
    int index
)
Public Overridable Function InsertCodeFix (
    index As Integer
) As ICodeFixItem
public:
virtual ICodeFixItem^ InsertCodeFix(
    int index
)
abstract InsertCodeFix :
        index : int -> ICodeFixItem
override InsertCodeFix :
        index : int -> ICodeFixItem

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeFixItem
ICodeFixItem that is inserted.

Implements

ICodeFixItemsInsertCodeFix(Int32)
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems Properties

CodeFixItems Properties

The CodeFixItems type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to CodeFixItem objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems.ColumnCount Property

CodeFixItemsColumnCount Property
Returns number of the columns. In this class ColumnCount always return 1.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

ICodeCompletionProviderColumnCount
ICodeCompletionProviderColumnCount
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems.Item Property

CodeFixItemsItem Property
Provides an indexed access to CodeFixItem objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeFixItem this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ICodeFixItem
    Get
    Set
public:
virtual property ICodeFixItem^ default[int index] {
    ICodeFixItem^ get (int index) sealed;
    void set (int index, ICodeFixItem^ value) sealed;
}
abstract Item : ICodeFixItem with get, set
override Item : ICodeFixItem with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: ICodeFixItem

Implements

ICodeFixItemsItemInt32
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeFixItems Events

CodeFixItems Events

The CodeFixItems type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeFixItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem Class

CodeRefactorItem Class
Represents particular code ix in the code refactor collection.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProviderNamedItem
Alternet.Syntax.CodeCompletionCodeRefactorItem

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeRefactorItem : CodeCompletionProviderNamedItem,
    ICodeRefactorItem, ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
Public Class CodeRefactorItem
    Inherits CodeCompletionProviderNamedItem
    Implements ICodeRefactorItem, ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
public ref class CodeRefactorItem : public CodeCompletionProviderNamedItem,
    ICodeRefactorItem, ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
type CodeRefactorItem =
    class
        inherit CodeCompletionProviderNamedItem
        interface ICodeRefactorItem
        interface ICodeCompletionProviderNamedItem
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeRefactorItem type exposes the following members.

Constructors
 | Name | Description
Public method | CodeRefactorItem | Initializes a new instance of the CodeRefactorItem class with default settings.
Public method | CodeRefactorItem(ICodeRefactorItems) | Initializes a new instance of the CodeRefactorItem class with specified parent.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeCompletionProviderNamedItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CodeRefactor | Gets an assosicated code refactor object.
Public property | CustomData | Gets an object that can hold a user defined data attached to the code refactor. (Overrides CodeCompletionProviderNamedItemCustomData.)
Public property | Description | Gets string value representing description of the CodeRefactorItem. (Overrides CodeCompletionProviderNamedItemDescription.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the snippet. (Inherited from CodeCompletionProviderNamedItem.)
Public property | Name | Gets string value representing name of the CodeRefactorItem. (Overrides CodeCompletionProviderNamedItemName.)
Public property | Parent | Gets or sets a parent of the CodeRefactorItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem Constructor

CodeRefactorItem Constructor
Overload List
 | Name | Description
Public method | CodeRefactorItem | Initializes a new instance of the CodeRefactorItem class with default settings.
Public method | CodeRefactorItem(ICodeRefactorItems) | Initializes a new instance of the CodeRefactorItem class with specified parent.
Top
See Also

Reference

CodeRefactorItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem Constructor

CodeRefactorItem Constructor
Initializes a new instance of the CodeRefactorItem class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeRefactorItem()
Public Sub New
public:
CodeRefactorItem()
new : unit -> CodeRefactorItem
See Also

Reference

CodeRefactorItem Class
CodeRefactorItem Overload
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem Constructor (ICodeRefactorItems)

CodeRefactorItem Constructor (ICodeRefactorItems)
Initializes a new instance of the CodeRefactorItem class with specified parent.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeRefactorItem(
    ICodeRefactorItems parent
)
Public Sub New (
    parent As ICodeRefactorItems
)
public:
CodeRefactorItem(
    ICodeRefactorItems^ parent
)
new :
        parent : ICodeRefactorItems -> CodeRefactorItem

Parameters

parent
Type: Alternet.Syntax.CodeCompletionICodeRefactorItems
See Also

Reference

CodeRefactorItem Class
CodeRefactorItem Overload
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem Methods

CodeRefactorItem Methods

The CodeRefactorItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeCompletionProviderNamedItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeRefactorItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem Properties

CodeRefactorItem Properties

The CodeRefactorItem type exposes the following members.

Properties
 | Name | Description
Public property | CodeRefactor | Gets an assosicated code refactor object.
Public property | CustomData | Gets an object that can hold a user defined data attached to the code refactor. (Overrides CodeCompletionProviderNamedItemCustomData.)
Public property | Description | Gets string value representing description of the CodeRefactorItem. (Overrides CodeCompletionProviderNamedItemDescription.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the snippet. (Inherited from CodeCompletionProviderNamedItem.)
Public property | Name | Gets string value representing name of the CodeRefactorItem. (Overrides CodeCompletionProviderNamedItemName.)
Public property | Parent | Gets or sets a parent of the CodeRefactorItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

CodeRefactorItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem.CodeRefactor Property

CodeRefactorItemCodeRefactor Property
Gets an assosicated code refactor object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeRefactor CodeRefactor { get; set; }
Public Overridable Property CodeRefactor As ICodeRefactor
    Get
    Set
public:
virtual property ICodeRefactor^ CodeRefactor {
    ICodeRefactor^ get ();
    void set (ICodeRefactor^ value);
}
abstract CodeRefactor : ICodeRefactor with get, set
override CodeRefactor : ICodeRefactor with get, set

Property Value

Type: ICodeRefactor

Implements

ICodeRefactorItemCodeRefactor
See Also

Reference

CodeRefactorItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem.CustomData Property

CodeRefactorItemCustomData Property
Gets an object that can hold a user defined data attached to the code refactor.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object CustomData { get; }
Public Overrides ReadOnly Property CustomData As Object
    Get
public:
virtual property Object^ CustomData {
    Object^ get () override;
}
abstract CustomData : Object with get
override CustomData : Object with get

Property Value

Type: Object

Implements

ICodeCompletionProviderNamedItemCustomData
ICodeCompletionProviderNamedItemCustomData
See Also

Reference

CodeRefactorItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem.Description Property

CodeRefactorItemDescription Property
Gets string value representing description of the CodeRefactorItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderNamedItemDescription
ICodeCompletionProviderNamedItemDescription
See Also

Reference

CodeRefactorItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem.Name Property

CodeRefactorItemName Property
Gets string value representing name of the CodeRefactorItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderNamedItemName
ICodeCompletionProviderNamedItemName
See Also

Reference

CodeRefactorItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItem.Parent Property

CodeRefactorItemParent Property
Gets or sets a parent of the CodeRefactorItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeRefactorItems Parent { get; set; }
Public Overridable Property Parent As ICodeRefactorItems
    Get
    Set
public:
virtual property ICodeRefactorItems^ Parent {
    ICodeRefactorItems^ get ();
    void set (ICodeRefactorItems^ value);
}
abstract Parent : ICodeRefactorItems with get, set
override Parent : ICodeRefactorItems with get, set

Property Value

Type: ICodeRefactorItems

Implements

ICodeRefactorItemParent
See Also

Reference

CodeRefactorItem Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems Class

CodeRefactorItems Class
Represents collection containing list of code refactors.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionCodeRefactorItems

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeRefactorItems : CodeCompletionProvider,
    ICodeRefactorItems, ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Class CodeRefactorItems
    Inherits CodeCompletionProvider
    Implements ICodeRefactorItems, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class CodeRefactorItems : public CodeCompletionProvider,
    ICodeRefactorItems, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type CodeRefactorItems =
    class
        inherit CodeCompletionProvider
        interface ICodeRefactorItems
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The CodeRefactorItems type exposes the following members.

Constructors
 | Name | Description
Public method | CodeRefactorItems | Initializes a new instance of the CodeRefactorItems class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddCodeRefactor | Adds a new item to the ICodeRefactorItem collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns description of the code refactor specified by index. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeRefactorItem.ImageIndex from the code Refactor collection specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns description of the code refactor specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from CodeCompletionProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertCodeRefactor | Inserts a new item to the specified position within the ICodeRefactorItems collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to CodeRefactorItem objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems Constructor

CodeRefactorItems Constructor
Initializes a new instance of the CodeRefactorItems class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeRefactorItems()
Public Sub New
public:
CodeRefactorItems()
new : unit -> CodeRefactorItems
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems Methods

CodeRefactorItems Methods

The CodeRefactorItems type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddCodeRefactor | Adds a new item to the ICodeRefactorItem collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns description of the code refactor specified by index. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeRefactorItem.ImageIndex from the code Refactor collection specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns description of the code refactor specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from CodeCompletionProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertCodeRefactor | Inserts a new item to the specified position within the ICodeRefactorItems collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems.AddCodeRefactor Method

CodeRefactorItemsAddCodeRefactor Method
Adds a new item to the ICodeRefactorItem collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeRefactorItem AddCodeRefactor()
Public Overridable Function AddCodeRefactor As ICodeRefactorItem
public:
virtual ICodeRefactorItem^ AddCodeRefactor()
abstract AddCodeRefactor : unit -> ICodeRefactorItem
override AddCodeRefactor : unit -> ICodeRefactorItem

Return Value

Type: ICodeRefactorItem
ICodeRefactorItem that is added.

Implements

ICodeRefactorItemsAddCodeRefactor
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems.ColumnVisible Method

CodeRefactorItemsColumnVisible Method
Indicates whether specified column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ColumnVisible(
    int column
)
Public Overrides Function ColumnVisible (
    column As Integer
) As Boolean
public:
virtual bool ColumnVisible(
    int column
) override
abstract ColumnVisible :
        column : int -> bool
override ColumnVisible :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICodeCompletionProviderColumnVisible(Int32)
ICodeCompletionProviderColumnVisible(Int32)
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems.GetColumnText Method

CodeRefactorItemsGetColumnText Method
Returns text from specified column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the code refactor.
column
Type: SystemInt32
Specifies column index.

Return Value

Type: String
Text representing specified code refactor.

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems.GetDescription Method

CodeRefactorItemsGetDescription Method
Returns description of the code refactor specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDescription(
    int index
)
Public Overrides Function GetDescription (
    index As Integer
) As String
public:
virtual String^ GetDescription(
    int index
) override
abstract GetDescription :
        index : int -> string
override GetDescription :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the code refactor item.

Return Value

Type: String

Implements

ICodeCompletionProviderGetDescription(Int32)
ICodeCompletionProviderGetDescription(Int32)
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems.GetImageIndex Method

CodeRefactorItemsGetImageIndex Method
Returns ICodeRefactorItem.ImageIndex from the code Refactor collection specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetImageIndex(
    int index
)
Public Overrides Function GetImageIndex (
    index As Integer
) As Integer
public:
virtual int GetImageIndex(
    int index
) override
abstract GetImageIndex :
        index : int -> int
override GetImageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Specifies index of the code refactor.

Return Value

Type: Int32

Implements

ICodeCompletionProviderGetImageIndex(Int32)
ICodeCompletionProviderGetImageIndex(Int32)
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems.GetName Method

CodeRefactorItemsGetName Method
Returns description of the code refactor specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetName(
    int index
)
Public Overrides Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
) override
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the code refactor item.

Return Value

Type: String

Implements

ICodeCompletionProviderGetName(Int32)
ICodeCompletionProviderGetName(Int32)
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems.InsertCodeRefactor Method

CodeRefactorItemsInsertCodeRefactor Method
Inserts a new item to the specified position within the ICodeRefactorItems collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeRefactorItem InsertCodeRefactor(
    int index
)
Public Overridable Function InsertCodeRefactor (
    index As Integer
) As ICodeRefactorItem
public:
virtual ICodeRefactorItem^ InsertCodeRefactor(
    int index
)
abstract InsertCodeRefactor :
        index : int -> ICodeRefactorItem
override InsertCodeRefactor :
        index : int -> ICodeRefactorItem

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeRefactorItem
ICodeRefactorItem that is inserted.

Implements

ICodeRefactorItemsInsertCodeRefactor(Int32)
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems Properties

CodeRefactorItems Properties

The CodeRefactorItems type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to CodeRefactorItem objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems.ColumnCount Property

CodeRefactorItemsColumnCount Property
Returns number of the columns. In this class ColumnCount always return 1.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

ICodeCompletionProviderColumnCount
ICodeCompletionProviderColumnCount
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems.Item Property

CodeRefactorItemsItem Property
Provides an indexed access to CodeRefactorItem objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeRefactorItem this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ICodeRefactorItem
    Get
    Set
public:
virtual property ICodeRefactorItem^ default[int index] {
    ICodeRefactorItem^ get (int index) sealed;
    void set (int index, ICodeRefactorItem^ value) sealed;
}
abstract Item : ICodeRefactorItem with get, set
override Item : ICodeRefactorItem with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: ICodeRefactorItem

Implements

ICodeRefactorItemsItemInt32
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeRefactorItems Events

CodeRefactorItems Events

The CodeRefactorItems type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeRefactorItems Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet Class

CodeSnippet Class
Represents particular code snippet in the snippets collection.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippet

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippet : CodeCompletionProviderItem,
    ICodeSnippet, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippet
    Inherits CodeCompletionProviderItem
    Implements ICodeSnippet, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippet : public CodeCompletionProviderItem,
    ICodeSnippet, ICodeCompletionProviderItem, IComparable
type CodeSnippet =
    class
        inherit CodeCompletionProviderItem
        interface ICodeSnippet
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippet type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippet | Initializes a new instance of the CodeSnippets class with default settings.
Public method | CodeSnippet(ICodeSnippets) | Initializes a new instance of the CodeSnippet class with specified parent.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Code | Gets or sets a string value that specifies code of the snippet. The code completion control, that holds a snippet collection inserts code when user accepts the input.
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the snippet.
Public property | Declarations | Specifies the literals and objects that make up the parts of a code snippet that you can edit.
Public property | Description | Gets string value representing description of the CodeSnippet.
Public property | Header | Gets a header associated with the snippet.
Public property | ImageIndex | Gets or sets the index of the image displayed for the snippet.
Public property | Imports | Contains the imported namespaces for the code snippet.
Public property | Parent | Gets or sets a parent of the CodeSnippet.
Public property | References | Contains information about assembly references for the code snippet.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippet object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippet Constructor

CodeSnippet Constructor
Overload List
 | Name | Description
Public method | CodeSnippet | Initializes a new instance of the CodeSnippets class with default settings.
Public method | CodeSnippet(ICodeSnippets) | Initializes a new instance of the CodeSnippet class with specified parent.
Top
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet Constructor

CodeSnippet Constructor
Initializes a new instance of the CodeSnippets class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippet()
Public Sub New
public:
CodeSnippet()
new : unit -> CodeSnippet
See Also

Reference

CodeSnippet Class
CodeSnippet Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet Constructor (ICodeSnippets)

CodeSnippet Constructor (ICodeSnippets)
Initializes a new instance of the CodeSnippet class with specified parent.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippet(
    ICodeSnippets parent
)
Public Sub New (
    parent As ICodeSnippets
)
public:
CodeSnippet(
    ICodeSnippets^ parent
)
new :
        parent : ICodeSnippets -> CodeSnippet

Parameters

parent
Type: Alternet.Syntax.CodeCompletionICodeSnippets
See Also

Reference

CodeSnippet Class
CodeSnippet Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet Methods

CodeSnippet Methods

The CodeSnippet type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.CompareTo Method

CodeSnippetCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet Properties

CodeSnippet Properties

The CodeSnippet type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets or sets a string value that specifies code of the snippet. The code completion control, that holds a snippet collection inserts code when user accepts the input.
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the snippet.
Public property | Declarations | Specifies the literals and objects that make up the parts of a code snippet that you can edit.
Public property | Description | Gets string value representing description of the CodeSnippet.
Public property | Header | Gets a header associated with the snippet.
Public property | ImageIndex | Gets or sets the index of the image displayed for the snippet.
Public property | Imports | Contains the imported namespaces for the code snippet.
Public property | Parent | Gets or sets a parent of the CodeSnippet.
Public property | References | Contains information about assembly references for the code snippet.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippet object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Top
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.Code Property

CodeSnippetCode Property
Gets or sets a string value that specifies code of the snippet. The code completion control, that holds a snippet collection inserts code when user accepts the input.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetCode Code { get; set; }
Public Overridable Property Code As ICodeSnippetCode
    Get
    Set
public:
virtual property ICodeSnippetCode^ Code {
    ICodeSnippetCode^ get ();
    void set (ICodeSnippetCode^ value);
}
abstract Code : ICodeSnippetCode with get, set
override Code : ICodeSnippetCode with get, set

Property Value

Type: ICodeSnippetCode

Implements

ICodeSnippetCode
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.CustomData Property

CodeSnippetCustomData Property
Gets or sets an object that can hold a user defined data attached to the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object CustomData { get; set; }
Public Overridable Property CustomData As Object
    Get
    Set
public:
virtual property Object^ CustomData {
    Object^ get ();
    void set (Object^ value);
}
abstract CustomData : Object with get, set
override CustomData : Object with get, set

Property Value

Type: Object

Implements

ICodeSnippetCustomData
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.Declarations Property

CodeSnippetDeclarations Property
Specifies the literals and objects that make up the parts of a code snippet that you can edit.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetDeclarations Declarations { get; }
Public Overridable ReadOnly Property Declarations As ICodeSnippetDeclarations
    Get
public:
virtual property ICodeSnippetDeclarations^ Declarations {
    ICodeSnippetDeclarations^ get ();
}
abstract Declarations : ICodeSnippetDeclarations with get
override Declarations : ICodeSnippetDeclarations with get

Property Value

Type: ICodeSnippetDeclarations

Implements

ICodeSnippetDeclarations
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.Description Property

CodeSnippetDescription Property
Gets string value representing description of the CodeSnippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; }
Public Overridable ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get ();
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

ICodeSnippetDescription
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.Header Property

CodeSnippetHeader Property
Gets a header associated with the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetHeader Header { get; set; }
Public Overridable Property Header As ICodeSnippetHeader
    Get
    Set
public:
virtual property ICodeSnippetHeader^ Header {
    ICodeSnippetHeader^ get ();
    void set (ICodeSnippetHeader^ value);
}
abstract Header : ICodeSnippetHeader with get, set
override Header : ICodeSnippetHeader with get, set

Property Value

Type: ICodeSnippetHeader

Implements

ICodeSnippetHeader
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.ImageIndex Property

CodeSnippetImageIndex Property
Gets or sets the index of the image displayed for the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ImageIndex { get; set; }
Public Overridable Property ImageIndex As Integer
    Get
    Set
public:
virtual property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set
override ImageIndex : int with get, set

Property Value

Type: Int32

Implements

ICodeSnippetImageIndex
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.Imports Property

CodeSnippetImports Property
Contains the imported namespaces for the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetImports Imports { get; }
Public Overridable ReadOnly Property Imports As ICodeSnippetImports
    Get
public:
virtual property ICodeSnippetImports^ Imports {
    ICodeSnippetImports^ get ();
}
abstract Imports : ICodeSnippetImports with get
override Imports : ICodeSnippetImports with get

Property Value

Type: ICodeSnippetImports

Implements

ICodeSnippetImports
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.Parent Property

CodeSnippetParent Property
Gets or sets a parent of the CodeSnippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippets Parent { get; set; }
Public Overridable Property Parent As ICodeSnippets
    Get
    Set
public:
virtual property ICodeSnippets^ Parent {
    ICodeSnippets^ get ();
    void set (ICodeSnippets^ value);
}
abstract Parent : ICodeSnippets with get, set
override Parent : ICodeSnippets with get, set

Property Value

Type: ICodeSnippets

Implements

ICodeSnippetParent
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.References Property

CodeSnippetReferences Property
Contains information about assembly references for the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetReferences References { get; }
Public Overridable ReadOnly Property References As ICodeSnippetReferences
    Get
public:
virtual property ICodeSnippetReferences^ References {
    ICodeSnippetReferences^ get ();
}
abstract References : ICodeSnippetReferences with get
override References : ICodeSnippetReferences with get

Property Value

Type: ICodeSnippetReferences

Implements

ICodeSnippetReferences
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippet.SerializationInfo Property

CodeSnippetSerializationInfo Property
Gets or sets an xml representation of this CodeSnippet object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippet Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode Class

CodeSnippetCode Class
Specifies the code that you want to insert into a file.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippetCode

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetCode : CodeCompletionProviderItem,
    ICodeSnippetCode, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippetCode
    Inherits CodeCompletionProviderItem
    Implements ICodeSnippetCode, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippetCode : public CodeCompletionProviderItem,
    ICodeSnippetCode, ICodeCompletionProviderItem, IComparable
type CodeSnippetCode =
    class
        inherit CodeCompletionProviderItem
        interface ICodeSnippetCode
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippetCode type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetCode | Initializes a new instance of the CodeSnippetCode class with default settings.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another ICodeSnippetCode object.
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Code | Specifies the code that you want to insert into a file.
Public property | Delimiter | Specifies the delimiter used to describe literals and objects in the code.
Public property | Kind | Specifies the kind of code the snippet contains, and thus, where the snippet can be inserted.
Public property | Language | Specifies the language of the code snippet.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetCode object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode Constructor

CodeSnippetCode Constructor
Initializes a new instance of the CodeSnippetCode class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetCode()
Public Sub New
public:
CodeSnippetCode()
new : unit -> CodeSnippetCode
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode Methods

CodeSnippetCode Methods

The CodeSnippetCode type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another ICodeSnippetCode object.
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode.Assign Method

CodeSnippetCodeAssign Method
Copies the contents of another ICodeSnippetCode object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ICodeSnippetCode source
)
Public Overridable Sub Assign (
    source As ICodeSnippetCode
)
public:
virtual void Assign(
    ICodeSnippetCode^ source
)
abstract Assign :
        source : ICodeSnippetCode -> unit
override Assign :
        source : ICodeSnippetCode -> unit

Parameters

source
Type: Alternet.Syntax.CodeCompletionICodeSnippetCode
Specifies ICodeSnippetCode to assign.

Implements

ICodeSnippetCodeAssign(ICodeSnippetCode)
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode.CompareTo Method

CodeSnippetCodeCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode Properties

CodeSnippetCode Properties

The CodeSnippetCode type exposes the following members.

Properties
 | Name | Description
Public property | Code | Specifies the code that you want to insert into a file.
Public property | Delimiter | Specifies the delimiter used to describe literals and objects in the code.
Public property | Kind | Specifies the kind of code the snippet contains, and thus, where the snippet can be inserted.
Public property | Language | Specifies the language of the code snippet.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetCode object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Top
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode.Code Property

CodeSnippetCodeCode Property
Specifies the code that you want to insert into a file.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Code { get; set; }
Public Overridable Property Code As String
    Get
    Set
public:
virtual property String^ Code {
    String^ get ();
    void set (String^ value);
}
abstract Code : string with get, set
override Code : string with get, set

Property Value

Type: String

Implements

ICodeSnippetCodeCode
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode.Delimiter Property

CodeSnippetCodeDelimiter Property
Specifies the delimiter used to describe literals and objects in the code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Delimiter { get; set; }
Public Overridable Property Delimiter As String
    Get
    Set
public:
virtual property String^ Delimiter {
    String^ get ();
    void set (String^ value);
}
abstract Delimiter : string with get, set
override Delimiter : string with get, set

Property Value

Type: String

Implements

ICodeSnippetCodeDelimiter
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode.Kind Property

CodeSnippetCodeKind Property
Specifies the kind of code the snippet contains, and thus, where the snippet can be inserted.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Kind { get; set; }
Public Overridable Property Kind As String
    Get
    Set
public:
virtual property String^ Kind {
    String^ get ();
    void set (String^ value);
}
abstract Kind : string with get, set
override Kind : string with get, set

Property Value

Type: String

Implements

ICodeSnippetCodeKind
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode.Language Property

CodeSnippetCodeLanguage Property
Specifies the language of the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Language { get; set; }
Public Overridable Property Language As String
    Get
    Set
public:
virtual property String^ Language {
    String^ get ();
    void set (String^ value);
}
abstract Language : string with get, set
override Language : string with get, set

Property Value

Type: String

Implements

ICodeSnippetCodeLanguage
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetCode.SerializationInfo Property

CodeSnippetCodeSerializationInfo Property
Gets or sets an xml representation of this CodeSnippetCode object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippetCode Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclaration Class

CodeSnippetDeclaration Class
Represents literals and objects that make up the parts of a code snippet that you can edit.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippetDeclaration

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetDeclaration : CodeCompletionProviderItem,
    ICodeSnippetDeclaration, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippetDeclaration
    Inherits CodeCompletionProviderItem
    Implements ICodeSnippetDeclaration, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippetDeclaration : public CodeCompletionProviderItem,
    ICodeSnippetDeclaration, ICodeCompletionProviderItem, IComparable
type CodeSnippetDeclaration =
    class
        inherit CodeCompletionProviderItem
        interface ICodeSnippetDeclaration
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippetDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetDeclaration | Initializes a new instance of the CodeSnippetDeclaration with default settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeCompletionProviderItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Literals | Defines the literals of the code snippet that you can edit.
Public property | Objects | Defines the objects of the code snippet that you can edit.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetDeclaration object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclaration Constructor

CodeSnippetDeclaration Constructor
Initializes a new instance of the CodeSnippetDeclaration with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetDeclaration()
Public Sub New
public:
CodeSnippetDeclaration()
new : unit -> CodeSnippetDeclaration
See Also

Reference

CodeSnippetDeclaration Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclaration Methods

CodeSnippetDeclaration Methods

The CodeSnippetDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeCompletionProviderItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetDeclaration Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclaration Properties

CodeSnippetDeclaration Properties

The CodeSnippetDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Literals | Defines the literals of the code snippet that you can edit.
Public property | Objects | Defines the objects of the code snippet that you can edit.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetDeclaration object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Top
See Also

Reference

CodeSnippetDeclaration Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclaration.Literals Property

CodeSnippetDeclarationLiterals Property
Defines the literals of the code snippet that you can edit.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetLiterals Literals { get; }
Public Overridable ReadOnly Property Literals As ICodeSnippetLiterals
    Get
public:
virtual property ICodeSnippetLiterals^ Literals {
    ICodeSnippetLiterals^ get ();
}
abstract Literals : ICodeSnippetLiterals with get
override Literals : ICodeSnippetLiterals with get

Property Value

Type: ICodeSnippetLiterals

Implements

ICodeSnippetDeclarationLiterals
See Also

Reference

CodeSnippetDeclaration Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclaration.Objects Property

CodeSnippetDeclarationObjects Property
Defines the objects of the code snippet that you can edit.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetObjects Objects { get; }
Public Overridable ReadOnly Property Objects As ICodeSnippetObjects
    Get
public:
virtual property ICodeSnippetObjects^ Objects {
    ICodeSnippetObjects^ get ();
}
abstract Objects : ICodeSnippetObjects with get
override Objects : ICodeSnippetObjects with get

Property Value

Type: ICodeSnippetObjects

Implements

ICodeSnippetDeclarationObjects
See Also

Reference

CodeSnippetDeclaration Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclaration.SerializationInfo Property

CodeSnippetDeclarationSerializationInfo Property
Gets or sets an xml representation of this CodeSnippetDeclaration object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippetDeclaration Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclarations Class

CodeSnippetDeclarations Class
Provides an indexed access to individual ICodeSnippetDeclaration objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeSnippetDeclaration
Alternet.Syntax.CodeCompletionCodeSnippetDeclarations

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetDeclarations : List<ICodeSnippetDeclaration>,
    ICodeSnippetDeclarations, IList<ICodeSnippetDeclaration>, ICollection<ICodeSnippetDeclaration>,
    IEnumerable<ICodeSnippetDeclaration>, IEnumerable
Public Class CodeSnippetDeclarations
    Inherits List(Of ICodeSnippetDeclaration)
    Implements ICodeSnippetDeclarations, IList(Of ICodeSnippetDeclaration),
    ICollection(Of ICodeSnippetDeclaration), IEnumerable(Of ICodeSnippetDeclaration), IEnumerable
public ref class CodeSnippetDeclarations : public List<ICodeSnippetDeclaration^>,
    ICodeSnippetDeclarations, IList<ICodeSnippetDeclaration^>, ICollection<ICodeSnippetDeclaration^>,
    IEnumerable<ICodeSnippetDeclaration^>, IEnumerable
type CodeSnippetDeclarations =
    class
        inherit List<ICodeSnippetDeclaration>
        interface ICodeSnippetDeclarations
        interface IList<ICodeSnippetDeclaration>
        interface ICollection<ICodeSnippetDeclaration>
        interface IEnumerable<ICodeSnippetDeclaration>
        interface IEnumerable
    end

The CodeSnippetDeclarations type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetDeclarations | Initializes a new instance of the CodeSnippetDeclarations class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | AddDeclaration | Adds a new item to the specified position within the ICodeSnippetDeclarations collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetDeclaration .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetDeclaration .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetDeclaration .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetDeclaration .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetDeclaration .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetDeclaration .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetDeclaration .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetDeclaration .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetDeclaration .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetDeclaration .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetDeclaration .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | InsertDeclaration | Inserts a new item to the specified position within the ICodeSnippetDeclarations collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetDeclaration .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetDeclaration .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetDeclaration .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetDeclaration .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetDeclaration .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetDeclaration .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetDeclaration .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetDeclaration .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetDeclaration .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetDeclaration | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetDeclaration | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetDeclaration, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetDeclaration .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclarations Constructor

CodeSnippetDeclarations Constructor
Initializes a new instance of the CodeSnippetDeclarations class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetDeclarations()
Public Sub New
public:
CodeSnippetDeclarations()
new : unit -> CodeSnippetDeclarations
See Also

Reference

CodeSnippetDeclarations Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclarations Methods

CodeSnippetDeclarations Methods

The CodeSnippetDeclarations type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | AddDeclaration | Adds a new item to the specified position within the ICodeSnippetDeclarations collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetDeclaration .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetDeclaration .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetDeclaration .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetDeclaration .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetDeclaration .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetDeclaration .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetDeclaration .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetDeclaration .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetDeclaration .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetDeclaration .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetDeclaration .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | InsertDeclaration | Inserts a new item to the specified position within the ICodeSnippetDeclarations collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetDeclaration .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetDeclaration .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetDeclaration .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetDeclaration .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetDeclaration .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetDeclaration .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetDeclaration .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetDeclaration .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetDeclaration .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetDeclaration .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetDeclaration | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetDeclaration | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetDeclaration, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippetDeclarations Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclarations.AddDeclaration Method

CodeSnippetDeclarationsAddDeclaration Method
Adds a new item to the specified position within the ICodeSnippetDeclarations collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetDeclaration AddDeclaration()
Public Overridable Function AddDeclaration As ICodeSnippetDeclaration
public:
virtual ICodeSnippetDeclaration^ AddDeclaration()
abstract AddDeclaration : unit -> ICodeSnippetDeclaration
override AddDeclaration : unit -> ICodeSnippetDeclaration

Return Value

Type: ICodeSnippetDeclaration
ICodeSnippetDeclaration that is added.

Implements

ICodeSnippetDeclarationsAddDeclaration
See Also

Reference

CodeSnippetDeclarations Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclarations.InsertDeclaration Method

CodeSnippetDeclarationsInsertDeclaration Method
Inserts a new item to the specified position within the ICodeSnippetDeclarations collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetDeclaration InsertDeclaration(
    int index
)
Public Overridable Function InsertDeclaration (
    index As Integer
) As ICodeSnippetDeclaration
public:
virtual ICodeSnippetDeclaration^ InsertDeclaration(
    int index
)
abstract InsertDeclaration :
        index : int -> ICodeSnippetDeclaration
override InsertDeclaration :
        index : int -> ICodeSnippetDeclaration

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetDeclaration
ICodeSnippetDeclaration that is inserted.

Implements

ICodeSnippetDeclarationsInsertDeclaration(Int32)
See Also

Reference

CodeSnippetDeclarations Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetDeclarations Properties

CodeSnippetDeclarations Properties

The CodeSnippetDeclarations type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetDeclaration .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetDeclaration .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetDeclaration .)
Top
See Also

Reference

CodeSnippetDeclarations Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader Class

CodeSnippetHeader Class
Represents code snippet header.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippetHeader

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetHeader : CodeCompletionProviderItem,
    ICodeSnippetHeader, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippetHeader
    Inherits CodeCompletionProviderItem
    Implements ICodeSnippetHeader, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippetHeader : public CodeCompletionProviderItem,
    ICodeSnippetHeader, ICodeCompletionProviderItem, IComparable
type CodeSnippetHeader =
    class
        inherit CodeCompletionProviderItem
        interface ICodeSnippetHeader
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippetHeader type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetHeader | Initializes a new instance of the CodeSnippetHeader class with default settings.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another ICodeSnippetHeader object.
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Author | Gets or sets a string value that specifies author of the code snippet.
Public property | Description | Gets or sets a string value that specifies short description of the code snippet, that can help user to choose snippet from the popup window.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetHeader object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | Shortcut | Gets or sets a string value that specifies shortcut of the code snippet. This shortcut is replaced by entire snippet when user presses Tab in the editor.
Public property | Title | Gets or sets a string value that specifies the title of the code snippet. Useful to find necessary item within the snippets collection.
Public property | Types | Specifies how the code snippet is inserted into the code.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader Constructor

CodeSnippetHeader Constructor
Initializes a new instance of the CodeSnippetHeader class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetHeader()
Public Sub New
public:
CodeSnippetHeader()
new : unit -> CodeSnippetHeader
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader Methods

CodeSnippetHeader Methods

The CodeSnippetHeader type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another ICodeSnippetHeader object.
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader.Assign Method

CodeSnippetHeaderAssign Method
Copies the contents of another ICodeSnippetHeader object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ICodeSnippetHeader source
)
Public Overridable Sub Assign (
    source As ICodeSnippetHeader
)
public:
virtual void Assign(
    ICodeSnippetHeader^ source
)
abstract Assign :
        source : ICodeSnippetHeader -> unit
override Assign :
        source : ICodeSnippetHeader -> unit

Parameters

source
Type: Alternet.Syntax.CodeCompletionICodeSnippetHeader
Specifies ICodeSnippetHeader to assign.

Implements

ICodeSnippetHeaderAssign(ICodeSnippetHeader)
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader.CompareTo Method

CodeSnippetHeaderCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader Properties

CodeSnippetHeader Properties

The CodeSnippetHeader type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets or sets a string value that specifies author of the code snippet.
Public property | Description | Gets or sets a string value that specifies short description of the code snippet, that can help user to choose snippet from the popup window.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetHeader object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | Shortcut | Gets or sets a string value that specifies shortcut of the code snippet. This shortcut is replaced by entire snippet when user presses Tab in the editor.
Public property | Title | Gets or sets a string value that specifies the title of the code snippet. Useful to find necessary item within the snippets collection.
Public property | Types | Specifies how the code snippet is inserted into the code.
Top
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader.Author Property

CodeSnippetHeaderAuthor Property
Gets or sets a string value that specifies author of the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Author { get; set; }
Public Overridable Property Author As String
    Get
    Set
public:
virtual property String^ Author {
    String^ get ();
    void set (String^ value);
}
abstract Author : string with get, set
override Author : string with get, set

Property Value

Type: String

Implements

ICodeSnippetHeaderAuthor
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader.Description Property

CodeSnippetHeaderDescription Property
Gets or sets a string value that specifies short description of the code snippet, that can help user to choose snippet from the popup window.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

ICodeSnippetHeaderDescription
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader.SerializationInfo Property

CodeSnippetHeaderSerializationInfo Property
Gets or sets an xml representation of this CodeSnippetHeader object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader.Shortcut Property

CodeSnippetHeaderShortcut Property
Gets or sets a string value that specifies shortcut of the code snippet. This shortcut is replaced by entire snippet when user presses Tab in the editor.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Shortcut { get; set; }
Public Overridable Property Shortcut As String
    Get
    Set
public:
virtual property String^ Shortcut {
    String^ get ();
    void set (String^ value);
}
abstract Shortcut : string with get, set
override Shortcut : string with get, set

Property Value

Type: String

Implements

ICodeSnippetHeaderShortcut
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader.Title Property

CodeSnippetHeaderTitle Property
Gets or sets a string value that specifies the title of the code snippet. Useful to find necessary item within the snippets collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Title { get; set; }
Public Overridable Property Title As String
    Get
    Set
public:
virtual property String^ Title {
    String^ get ();
    void set (String^ value);
}
abstract Title : string with get, set
override Title : string with get, set

Property Value

Type: String

Implements

ICodeSnippetHeaderTitle
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetHeader.Types Property

CodeSnippetHeaderTypes Property
Specifies how the code snippet is inserted into the code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetTypes Types { get; }
Public Overridable ReadOnly Property Types As ICodeSnippetTypes
    Get
public:
virtual property ICodeSnippetTypes^ Types {
    ICodeSnippetTypes^ get ();
}
abstract Types : ICodeSnippetTypes with get
override Types : ICodeSnippetTypes with get

Property Value

Type: ICodeSnippetTypes

Implements

ICodeSnippetHeaderTypes
See Also

Reference

CodeSnippetHeader Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImport Class

CodeSnippetImport Class
Represents imported namespace used by an IntelliSense Code Snippet.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippetImport

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetImport : CodeCompletionProviderItem,
    ICodeSnippetImport, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippetImport
    Inherits CodeCompletionProviderItem
    Implements ICodeSnippetImport, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippetImport : public CodeCompletionProviderItem,
    ICodeSnippetImport, ICodeCompletionProviderItem, IComparable
type CodeSnippetImport =
    class
        inherit CodeCompletionProviderItem
        interface ICodeSnippetImport
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippetImport type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetImport | Initializes a new instance of the CodeSnippetImport class with default settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Namespace | Specifies the namespace used by the code snippet.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetImport object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImport Constructor

CodeSnippetImport Constructor
Initializes a new instance of the CodeSnippetImport class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetImport()
Public Sub New
public:
CodeSnippetImport()
new : unit -> CodeSnippetImport
See Also

Reference

CodeSnippetImport Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImport Methods

CodeSnippetImport Methods

The CodeSnippetImport type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetImport Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImport.CompareTo Method

CodeSnippetImportCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

CodeSnippetImport Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImport Properties

CodeSnippetImport Properties

The CodeSnippetImport type exposes the following members.

Properties
 | Name | Description
Public property | Namespace | Specifies the namespace used by the code snippet.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetImport object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Top
See Also

Reference

CodeSnippetImport Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImport.Namespace Property

CodeSnippetImportNamespace Property
Specifies the namespace used by the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Namespace { get; set; }
Public Overridable Property Namespace As String
    Get
    Set
public:
virtual property String^ Namespace {
    String^ get ();
    void set (String^ value);
}
abstract Namespace : string with get, set
override Namespace : string with get, set

Property Value

Type: String

Implements

ICodeSnippetImportNamespace
See Also

Reference

CodeSnippetImport Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImport.SerializationInfo Property

CodeSnippetImportSerializationInfo Property
Gets or sets an xml representation of this CodeSnippetImport object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippetImport Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImports Class

CodeSnippetImports Class
Provides an indexed access to individual ICodeSnippetImport objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeSnippetImport
Alternet.Syntax.CodeCompletionCodeSnippetImports

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetImports : List<ICodeSnippetImport>,
    ICodeSnippetImports, IList<ICodeSnippetImport>, ICollection<ICodeSnippetImport>,
    IEnumerable<ICodeSnippetImport>, IEnumerable
Public Class CodeSnippetImports
    Inherits List(Of ICodeSnippetImport)
    Implements ICodeSnippetImports, IList(Of ICodeSnippetImport),
    ICollection(Of ICodeSnippetImport), IEnumerable(Of ICodeSnippetImport), IEnumerable
public ref class CodeSnippetImports : public List<ICodeSnippetImport^>,
    ICodeSnippetImports, IList<ICodeSnippetImport^>, ICollection<ICodeSnippetImport^>,
    IEnumerable<ICodeSnippetImport^>, IEnumerable
type CodeSnippetImports =
    class
        inherit List<ICodeSnippetImport>
        interface ICodeSnippetImports
        interface IList<ICodeSnippetImport>
        interface ICollection<ICodeSnippetImport>
        interface IEnumerable<ICodeSnippetImport>
        interface IEnumerable
    end

The CodeSnippetImports type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetImports | Initializes a new instance of the CodeSnippetImports class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetImport .)
Public method | AddImport | Adds a new item to the specified position within the ICodeSnippetImports collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetImport .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetImport .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetImport .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetImport .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetImport .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetImport .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetImport .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetImport .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetImport .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetImport .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetImport .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetImport .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetImport .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetImport .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetImport .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetImport .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetImport .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetImport .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetImport .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetImport .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetImport .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetImport .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetImport .)
Public method | InsertImport | Inserts a new item to the specified position within the ICodeSnippetImports collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetImport .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetImport .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetImport .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetImport .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetImport .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetImport .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetImport .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetImport .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetImport .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetImport .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetImport .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetImport .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetImport .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetImport .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetImport .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetImport | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetImport | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetImport, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetImport .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetImport .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetImport .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImports Constructor

CodeSnippetImports Constructor
Initializes a new instance of the CodeSnippetImports class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetImports()
Public Sub New
public:
CodeSnippetImports()
new : unit -> CodeSnippetImports
See Also

Reference

CodeSnippetImports Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImports Methods

CodeSnippetImports Methods

The CodeSnippetImports type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetImport .)
Public method | AddImport | Adds a new item to the specified position within the ICodeSnippetImports collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetImport .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetImport .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetImport .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetImport .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetImport .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetImport .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetImport .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetImport .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetImport .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetImport .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetImport .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetImport .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetImport .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetImport .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetImport .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetImport .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetImport .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetImport .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetImport .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetImport .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetImport .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetImport .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetImport .)
Public method | InsertImport | Inserts a new item to the specified position within the ICodeSnippetImports collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetImport .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetImport .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetImport .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetImport .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetImport .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetImport .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetImport .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetImport .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetImport .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetImport .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetImport .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetImport .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetImport .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetImport .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetImport .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetImport .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetImport | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetImport | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetImport, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippetImports Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImports.AddImport Method

CodeSnippetImportsAddImport Method
Adds a new item to the specified position within the ICodeSnippetImports collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetImport AddImport()
Public Overridable Function AddImport As ICodeSnippetImport
public:
virtual ICodeSnippetImport^ AddImport()
abstract AddImport : unit -> ICodeSnippetImport
override AddImport : unit -> ICodeSnippetImport

Return Value

Type: ICodeSnippetImport
ICodeSnippetImport that is added.

Implements

ICodeSnippetImportsAddImport
See Also

Reference

CodeSnippetImports Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImports.InsertImport Method

CodeSnippetImportsInsertImport Method
Inserts a new item to the specified position within the ICodeSnippetImports collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetImport InsertImport(
    int index
)
Public Overridable Function InsertImport (
    index As Integer
) As ICodeSnippetImport
public:
virtual ICodeSnippetImport^ InsertImport(
    int index
)
abstract InsertImport :
        index : int -> ICodeSnippetImport
override InsertImport :
        index : int -> ICodeSnippetImport

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetImport
ICodeSnippetImport that is inserted.

Implements

ICodeSnippetImportsInsertImport(Int32)
See Also

Reference

CodeSnippetImports Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetImports Properties

CodeSnippetImports Properties

The CodeSnippetImports type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetImport .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetImport .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetImport .)
Top
See Also

Reference

CodeSnippetImports Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral Class

CodeSnippetLiteral Class
Represents literal that make up the parts of a code snippet that you can edit.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippetLiteral
Alternet.Syntax.CodeCompletionCodeSnippetObject

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetLiteral : CodeCompletionProviderItem,
    ICodeSnippetLiteral, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippetLiteral
    Inherits CodeCompletionProviderItem
    Implements ICodeSnippetLiteral, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippetLiteral : public CodeCompletionProviderItem,
    ICodeSnippetLiteral, ICodeCompletionProviderItem, IComparable
type CodeSnippetLiteral =
    class
        inherit CodeCompletionProviderItem
        interface ICodeSnippetLiteral
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippetLiteral type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetLiteral | Initializes a new instance of the CodeSnippetLiteral class with default settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Default | Specifies the default value of the literal or object for an IntelliSense Code Snippet.
Public property | Editable | Specifies whether literal is editable or not.
Public property | Function | Specifies a function to execute when the literal or object receives focus in the Editor.
Public property | ID | Specifies the unique identifier for the object or literal..
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetLiteral object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | SupportsCode | Specifies whether literal can fill code.
Public property | ToolTip | Specifies the ToolTip description to be associated with the literal in the code snippet.
Public property | Type | Specifies the type of the object.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral Constructor

CodeSnippetLiteral Constructor
Initializes a new instance of the CodeSnippetLiteral class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetLiteral()
Public Sub New
public:
CodeSnippetLiteral()
new : unit -> CodeSnippetLiteral
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral Methods

CodeSnippetLiteral Methods

The CodeSnippetLiteral type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral.CompareTo Method

CodeSnippetLiteralCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral Properties

CodeSnippetLiteral Properties

The CodeSnippetLiteral type exposes the following members.

Properties
 | Name | Description
Public property | Default | Specifies the default value of the literal or object for an IntelliSense Code Snippet.
Public property | Editable | Specifies whether literal is editable or not.
Public property | Function | Specifies a function to execute when the literal or object receives focus in the Editor.
Public property | ID | Specifies the unique identifier for the object or literal..
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetLiteral object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | SupportsCode | Specifies whether literal can fill code.
Public property | ToolTip | Specifies the ToolTip description to be associated with the literal in the code snippet.
Public property | Type | Specifies the type of the object.
Top
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral.Default Property

CodeSnippetLiteralDefault Property
Specifies the default value of the literal or object for an IntelliSense Code Snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Default { get; set; }
Public Overridable Property Default As String
    Get
    Set
public:
virtual property String^ Default {
    String^ get ();
    void set (String^ value);
}
abstract Default : string with get, set
override Default : string with get, set

Property Value

Type: String

Implements

ICodeSnippetLiteralDefault
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral.Editable Property

CodeSnippetLiteralEditable Property
Specifies whether literal is editable or not.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Editable { get; set; }
Public Overridable Property Editable As Boolean
    Get
    Set
public:
virtual property bool Editable {
    bool get ();
    void set (bool value);
}
abstract Editable : bool with get, set
override Editable : bool with get, set

Property Value

Type: Boolean

Implements

ICodeSnippetLiteralEditable
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral.Function Property

CodeSnippetLiteralFunction Property
Specifies a function to execute when the literal or object receives focus in the Editor.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Function { get; set; }
Public Overridable Property Function As String
    Get
    Set
public:
virtual property String^ Function {
    String^ get ();
    void set (String^ value);
}
abstract Function : string with get, set
override Function : string with get, set

Property Value

Type: String

Implements

ICodeSnippetLiteralFunction
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral.ID Property

CodeSnippetLiteralID Property
Specifies the unique identifier for the object or literal..

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ID { get; set; }
Public Overridable Property ID As String
    Get
    Set
public:
virtual property String^ ID {
    String^ get ();
    void set (String^ value);
}
abstract ID : string with get, set
override ID : string with get, set

Property Value

Type: String

Implements

ICodeSnippetLiteralID
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral.SerializationInfo Property

CodeSnippetLiteralSerializationInfo Property
Gets or sets an xml representation of this CodeSnippetLiteral object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral.SupportsCode Property

CodeSnippetLiteralSupportsCode Property
Specifies whether literal can fill code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsCode { get; set; }
Public Property SupportsCode As Boolean
    Get
    Set
public:
virtual property bool SupportsCode {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SupportsCode : bool with get, set
override SupportsCode : bool with get, set

Property Value

Type: Boolean

Implements

ICodeSnippetLiteralSupportsCode
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral.ToolTip Property

CodeSnippetLiteralToolTip Property
Specifies the ToolTip description to be associated with the literal in the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ToolTip { get; set; }
Public Overridable Property ToolTip As String
    Get
    Set
public:
virtual property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
abstract ToolTip : string with get, set
override ToolTip : string with get, set

Property Value

Type: String

Implements

ICodeSnippetLiteralToolTip
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiteral.Type Property

CodeSnippetLiteralType Property
Specifies the type of the object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Type { get; set; }
Public Overridable Property Type As String
    Get
    Set
public:
virtual property String^ Type {
    String^ get ();
    void set (String^ value);
}
abstract Type : string with get, set
override Type : string with get, set

Property Value

Type: String

Implements

ICodeSnippetLiteralType
See Also

Reference

CodeSnippetLiteral Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiterals Class

CodeSnippetLiterals Class
Provides an indexed access to individual ICodeSnippetLiteral objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeSnippetLiteral
Alternet.Syntax.CodeCompletionCodeSnippetLiterals

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetLiterals : List<ICodeSnippetLiteral>,
    ICodeSnippetLiterals, IList<ICodeSnippetLiteral>, ICollection<ICodeSnippetLiteral>,
    IEnumerable<ICodeSnippetLiteral>, IEnumerable
Public Class CodeSnippetLiterals
    Inherits List(Of ICodeSnippetLiteral)
    Implements ICodeSnippetLiterals, IList(Of ICodeSnippetLiteral),
    ICollection(Of ICodeSnippetLiteral), IEnumerable(Of ICodeSnippetLiteral), IEnumerable
public ref class CodeSnippetLiterals : public List<ICodeSnippetLiteral^>,
    ICodeSnippetLiterals, IList<ICodeSnippetLiteral^>, ICollection<ICodeSnippetLiteral^>,
    IEnumerable<ICodeSnippetLiteral^>, IEnumerable
type CodeSnippetLiterals =
    class
        inherit List<ICodeSnippetLiteral>
        interface ICodeSnippetLiterals
        interface IList<ICodeSnippetLiteral>
        interface ICollection<ICodeSnippetLiteral>
        interface IEnumerable<ICodeSnippetLiteral>
        interface IEnumerable
    end

The CodeSnippetLiterals type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetLiterals | Initializes a new instance of the CodeSnippetLiterals class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | AddLiteral | Adds a new item to the specified position within the ICodeSnippetLiterals collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetLiteral .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetLiteral .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetLiteral .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetLiteral .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetLiteral .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetLiteral .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetLiteral .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetLiteral .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetLiteral .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetLiteral .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetLiteral .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetLiteral .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetLiteral .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetLiteral .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | InsertLiteral | Inserts a new item to the specified position within the ICodeSnippetLiterals collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetLiteral .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetLiteral .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetLiteral .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetLiteral .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetLiteral .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetLiteral .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetLiteral .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetLiteral .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetLiteral .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetLiteral | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetLiteral | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetLiteral, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetLiteral .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetLiteral .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetLiteral .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiterals Constructor

CodeSnippetLiterals Constructor
Initializes a new instance of the CodeSnippetLiterals class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetLiterals()
Public Sub New
public:
CodeSnippetLiterals()
new : unit -> CodeSnippetLiterals
See Also

Reference

CodeSnippetLiterals Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiterals Methods

CodeSnippetLiterals Methods

The CodeSnippetLiterals type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | AddLiteral | Adds a new item to the specified position within the ICodeSnippetLiterals collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetLiteral .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetLiteral .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetLiteral .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetLiteral .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetLiteral .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetLiteral .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetLiteral .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetLiteral .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetLiteral .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetLiteral .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetLiteral .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetLiteral .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetLiteral .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetLiteral .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | InsertLiteral | Inserts a new item to the specified position within the ICodeSnippetLiterals collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetLiteral .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetLiteral .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetLiteral .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetLiteral .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetLiteral .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetLiteral .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetLiteral .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetLiteral .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetLiteral .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetLiteral .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetLiteral .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetLiteral | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetLiteral | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetLiteral, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippetLiterals Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiterals.AddLiteral Method

CodeSnippetLiteralsAddLiteral Method
Adds a new item to the specified position within the ICodeSnippetLiterals collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetLiteral AddLiteral()
Public Overridable Function AddLiteral As ICodeSnippetLiteral
public:
virtual ICodeSnippetLiteral^ AddLiteral()
abstract AddLiteral : unit -> ICodeSnippetLiteral
override AddLiteral : unit -> ICodeSnippetLiteral

Return Value

Type: ICodeSnippetLiteral
ICodeSnippetLiteral that is added.

Implements

ICodeSnippetLiteralsAddLiteral
See Also

Reference

CodeSnippetLiterals Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiterals.InsertLiteral Method

CodeSnippetLiteralsInsertLiteral Method
Inserts a new item to the specified position within the ICodeSnippetLiterals collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetLiteral InsertLiteral(
    int index
)
Public Overridable Function InsertLiteral (
    index As Integer
) As ICodeSnippetLiteral
public:
virtual ICodeSnippetLiteral^ InsertLiteral(
    int index
)
abstract InsertLiteral :
        index : int -> ICodeSnippetLiteral
override InsertLiteral :
        index : int -> ICodeSnippetLiteral

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetLiteral
ICodeSnippetLiteral that is inserted.

Implements

ICodeSnippetLiteralsInsertLiteral(Int32)
See Also

Reference

CodeSnippetLiterals Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetLiterals Properties

CodeSnippetLiterals Properties

The CodeSnippetLiterals type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetLiteral .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetLiteral .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetLiteral .)
Top
See Also

Reference

CodeSnippetLiterals Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember Class

CodeSnippetMember Class
Represents properties and methods for a particular code snippet member in the data collection of the code completion popups.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippetMember

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetMember : CodeCompletionProviderItem,
    ICodeSnippetMember, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippetMember
    Inherits CodeCompletionProviderItem
    Implements ICodeSnippetMember, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippetMember : public CodeCompletionProviderItem,
    ICodeSnippetMember, ICodeCompletionProviderItem, IComparable
type CodeSnippetMember =
    class
        inherit CodeCompletionProviderItem
        interface ICodeSnippetMember
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippetMember type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetMember | Initializes a new instance of the CodeSnippetMember class with default settings.
Public method | CodeSnippetMember(ICodeSnippetMembers) | Initializes a new instance of the CodeSnippetMembers class with specified parent.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | EditPath | Gets a string value that specifies the full path of the IListMember.
Public property | ImageIndex | Gets or sets the index of the image displayed for the ICodeSnippetMember.
Public property | Members | Provides an indexed access to the nested ICodeSnippetMember objects.
Public property | Name | Gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the ICodeSnippetMember collection.
Public property | Parent | Gets or sets a parent of the CodeSnippetMember.
Public property | Path | Gets or sets a string value that specifies the path to the file containing source of the ICodeSnippetMember.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetMember object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | Snippets | Provides an indexed access to the nestedICodeSnippet objects.
Public property | SnippetsAndMembers | Provides an indexed access to the nested snippets and members objects.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember Constructor

CodeSnippetMember Constructor
Overload List
 | Name | Description
Public method | CodeSnippetMember | Initializes a new instance of the CodeSnippetMember class with default settings.
Public method | CodeSnippetMember(ICodeSnippetMembers) | Initializes a new instance of the CodeSnippetMembers class with specified parent.
Top
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember Constructor

CodeSnippetMember Constructor
Initializes a new instance of the CodeSnippetMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetMember()
Public Sub New
public:
CodeSnippetMember()
new : unit -> CodeSnippetMember
See Also

Reference

CodeSnippetMember Class
CodeSnippetMember Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember Constructor (ICodeSnippetMembers)

CodeSnippetMember Constructor (ICodeSnippetMembers)
Initializes a new instance of the CodeSnippetMembers class with specified parent.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetMember(
    ICodeSnippetMembers parent
)
Public Sub New (
    parent As ICodeSnippetMembers
)
public:
CodeSnippetMember(
    ICodeSnippetMembers^ parent
)
new :
        parent : ICodeSnippetMembers -> CodeSnippetMember

Parameters

parent
Type: Alternet.Syntax.CodeCompletionICodeSnippetMembers
See Also

Reference

CodeSnippetMember Class
CodeSnippetMember Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember Methods

CodeSnippetMember Methods

The CodeSnippetMember type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.CompareTo Method

CodeSnippetMemberCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember Properties

CodeSnippetMember Properties

The CodeSnippetMember type exposes the following members.

Properties
 | Name | Description
Public property | EditPath | Gets a string value that specifies the full path of the IListMember.
Public property | ImageIndex | Gets or sets the index of the image displayed for the ICodeSnippetMember.
Public property | Members | Provides an indexed access to the nested ICodeSnippetMember objects.
Public property | Name | Gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the ICodeSnippetMember collection.
Public property | Parent | Gets or sets a parent of the CodeSnippetMember.
Public property | Path | Gets or sets a string value that specifies the path to the file containing source of the ICodeSnippetMember.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetMember object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | Snippets | Provides an indexed access to the nestedICodeSnippet objects.
Public property | SnippetsAndMembers | Provides an indexed access to the nested snippets and members objects.
Top
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.EditPath Property

CodeSnippetMemberEditPath Property
Gets a string value that specifies the full path of the IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string EditPath { get; }
Public Overridable ReadOnly Property EditPath As String
    Get
public:
virtual property String^ EditPath {
    String^ get ();
}
abstract EditPath : string with get
override EditPath : string with get

Property Value

Type: String

Implements

ICodeSnippetMemberEditPath
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.ImageIndex Property

CodeSnippetMemberImageIndex Property
Gets or sets the index of the image displayed for the ICodeSnippetMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ImageIndex { get; set; }
Public Overridable Property ImageIndex As Integer
    Get
    Set
public:
virtual property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set
override ImageIndex : int with get, set

Property Value

Type: Int32

Implements

ICodeSnippetMemberImageIndex
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.Members Property

CodeSnippetMemberMembers Property
Provides an indexed access to the nested ICodeSnippetMember objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetMembers Members { get; }
Public Overridable ReadOnly Property Members As ICodeSnippetMembers
    Get
public:
virtual property ICodeSnippetMembers^ Members {
    ICodeSnippetMembers^ get ();
}
abstract Members : ICodeSnippetMembers with get
override Members : ICodeSnippetMembers with get

Property Value

Type: ICodeSnippetMembers

Implements

ICodeSnippetMemberMembers
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.Name Property

CodeSnippetMemberName Property
Gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the ICodeSnippetMember collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ICodeSnippetMemberName
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.Parent Property

CodeSnippetMemberParent Property
Gets or sets a parent of the CodeSnippetMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetMembers Parent { get; set; }
Public Overridable Property Parent As ICodeSnippetMembers
    Get
    Set
public:
virtual property ICodeSnippetMembers^ Parent {
    ICodeSnippetMembers^ get ();
    void set (ICodeSnippetMembers^ value);
}
abstract Parent : ICodeSnippetMembers with get, set
override Parent : ICodeSnippetMembers with get, set

Property Value

Type: ICodeSnippetMembers

Implements

ICodeSnippetMemberParent
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.Path Property

CodeSnippetMemberPath Property
Gets or sets a string value that specifies the path to the file containing source of the ICodeSnippetMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Path { get; set; }
Public Overridable Property Path As String
    Get
    Set
public:
virtual property String^ Path {
    String^ get ();
    void set (String^ value);
}
abstract Path : string with get, set
override Path : string with get, set

Property Value

Type: String

Implements

ICodeSnippetMemberPath
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.SerializationInfo Property

CodeSnippetMemberSerializationInfo Property
Gets or sets an xml representation of this CodeSnippetMember object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.Snippets Property

CodeSnippetMemberSnippets Property
Provides an indexed access to the nestedICodeSnippet objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippets Snippets { get; }
Public Overridable ReadOnly Property Snippets As ICodeSnippets
    Get
public:
virtual property ICodeSnippets^ Snippets {
    ICodeSnippets^ get ();
}
abstract Snippets : ICodeSnippets with get
override Snippets : ICodeSnippets with get

Property Value

Type: ICodeSnippets

Implements

ICodeSnippetMemberSnippets
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMember.SnippetsAndMembers Property

CodeSnippetMemberSnippetsAndMembers Property
Provides an indexed access to the nested snippets and members objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetsProvider SnippetsAndMembers { get; }
Public Overridable ReadOnly Property SnippetsAndMembers As ICodeSnippetsProvider
    Get
public:
virtual property ICodeSnippetsProvider^ SnippetsAndMembers {
    ICodeSnippetsProvider^ get ();
}
abstract SnippetsAndMembers : ICodeSnippetsProvider with get
override SnippetsAndMembers : ICodeSnippetsProvider with get

Property Value

Type: ICodeSnippetsProvider

Implements

ICodeSnippetMemberSnippetsAndMembers
See Also

Reference

CodeSnippetMember Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers Class

CodeSnippetMembers Class
Represents collection containing list of code templates.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionCodeSnippetMembers

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetMembers : CodeCompletionProvider,
    ICodeSnippetMembers, ICodeSnippetsProvider, ICodeCompletionProvider, IList<ICodeCompletionProviderItem>,
    ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>, IEnumerable,
    IExport, IImport
Public Class CodeSnippetMembers
    Inherits CodeCompletionProvider
    Implements ICodeSnippetMembers, ICodeSnippetsProvider, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class CodeSnippetMembers : public CodeCompletionProvider,
    ICodeSnippetMembers, ICodeSnippetsProvider, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>,
    ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>, IEnumerable,
    IExport, IImport
type CodeSnippetMembers =
    class
        inherit CodeCompletionProvider
        interface ICodeSnippetMembers
        interface ICodeSnippetsProvider
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The CodeSnippetMembers type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetMembers | Initializes a new instance of the CodeSnippetMembers class with default settings.
Public method | CodeSnippetMembers(ICodeSnippetMember) | Initializes a new instance of the CodeSnippetMembers class with specified parent.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddSnippetMember | Adds a new item to the ICodeSnippetMembers collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindByShortcut | Gets a code snippet by its shortcut.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column and snippet. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from CodeCompletionProvider.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeSnippetMember.ImageIndex from the snippet specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns ICodeSnippetMember.Name of the snippet member specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Overrides CodeCompletionProviderGetParent.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns an empty string. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertSnippetMember | Inserts a new item to the specified position within the ICodeSnippetMembers collection.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Checks for nested members and raises ClosePopup event if they are not found. (Overrides CodeCompletionProviderOnClosePopup(Object, ClosingEventArgs).)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | ShouldIndent | Gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Overrides CodeCompletionProviderEditPath.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Overrides CodeCompletionProviderImages.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to ICodeSnippetMember objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | Parent | Gets or sets a parent of the CodeSnippetMembers.
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetMembers object. (Overrides CodeCompletionProviderSerializationInfo.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers Constructor

CodeSnippetMembers Constructor
Overload List
 | Name | Description
Public method | CodeSnippetMembers | Initializes a new instance of the CodeSnippetMembers class with default settings.
Public method | CodeSnippetMembers(ICodeSnippetMember) | Initializes a new instance of the CodeSnippetMembers class with specified parent.
Top
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers Constructor

CodeSnippetMembers Constructor
Initializes a new instance of the CodeSnippetMembers class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetMembers()
Public Sub New
public:
CodeSnippetMembers()
new : unit -> CodeSnippetMembers
See Also

Reference

CodeSnippetMembers Class
CodeSnippetMembers Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers Constructor (ICodeSnippetMember)

CodeSnippetMembers Constructor (ICodeSnippetMember)
Initializes a new instance of the CodeSnippetMembers class with specified parent.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetMembers(
    ICodeSnippetMember parent
)
Public Sub New (
    parent As ICodeSnippetMember
)
public:
CodeSnippetMembers(
    ICodeSnippetMember^ parent
)
new :
        parent : ICodeSnippetMember -> CodeSnippetMembers

Parameters

parent
Type: Alternet.Syntax.CodeCompletionICodeSnippetMember
See Also

Reference

CodeSnippetMembers Class
CodeSnippetMembers Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers Methods

CodeSnippetMembers Methods

The CodeSnippetMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddSnippetMember | Adds a new item to the ICodeSnippetMembers collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindByShortcut | Gets a code snippet by its shortcut.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column and snippet. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from CodeCompletionProvider.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeSnippetMember.ImageIndex from the snippet specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns ICodeSnippetMember.Name of the snippet member specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Overrides CodeCompletionProviderGetParent.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns an empty string. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertSnippetMember | Inserts a new item to the specified position within the ICodeSnippetMembers collection.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Checks for nested members and raises ClosePopup event if they are not found. (Overrides CodeCompletionProviderOnClosePopup(Object, ClosingEventArgs).)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | ShouldIndent | Gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.AddSnippetMember Method

CodeSnippetMembersAddSnippetMember Method
Adds a new item to the ICodeSnippetMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetMember AddSnippetMember()
Public Overridable Function AddSnippetMember As ICodeSnippetMember
public:
virtual ICodeSnippetMember^ AddSnippetMember()
abstract AddSnippetMember : unit -> ICodeSnippetMember
override AddSnippetMember : unit -> ICodeSnippetMember

Return Value

Type: ICodeSnippetMember
ICodeSnippetMember that is added.

Implements

ICodeSnippetMembersAddSnippetMember
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.ColumnVisible Method

CodeSnippetMembersColumnVisible Method
Indicates whether specified column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ColumnVisible(
    int column
)
Public Overrides Function ColumnVisible (
    column As Integer
) As Boolean
public:
virtual bool ColumnVisible(
    int column
) override
abstract ColumnVisible :
        column : int -> bool
override ColumnVisible :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICodeCompletionProviderColumnVisible(Int32)
ICodeCompletionProviderColumnVisible(Int32)
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.FindByShortcut Method

CodeSnippetMembersFindByShortcut Method
Gets a code snippet by its shortcut.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippet FindByShortcut(
    string shortcut,
    bool caseSensitive
)
Public Overridable Function FindByShortcut (
    shortcut As String,
    caseSensitive As Boolean
) As ICodeSnippet
public:
virtual ICodeSnippet^ FindByShortcut(
    String^ shortcut,
    bool caseSensitive
)
abstract FindByShortcut :
        shortcut : string *
        caseSensitive : bool -> ICodeSnippet
override FindByShortcut :
        shortcut : string *
        caseSensitive : bool -> ICodeSnippet

Parameters

shortcut
Type: SystemString
caseSensitive
Type: SystemBoolean

Return Value

Type: ICodeSnippet

Implements

ICodeSnippetsProviderFindByShortcut(String, Boolean)
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.GetColumnText Method

CodeSnippetMembersGetColumnText Method
Returns text from specified column and snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the snippet.
column
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: String
Text representing specified snippet.

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.GetImageIndex Method

CodeSnippetMembersGetImageIndex Method
Returns ICodeSnippetMember.ImageIndex from the snippet specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetImageIndex(
    int index
)
Public Overrides Function GetImageIndex (
    index As Integer
) As Integer
public:
virtual int GetImageIndex(
    int index
) override
abstract GetImageIndex :
        index : int -> int
override GetImageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: Int32

Implements

ICodeCompletionProviderGetImageIndex(Int32)
ICodeCompletionProviderGetImageIndex(Int32)
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.GetName Method

CodeSnippetMembersGetName Method
Returns ICodeSnippetMember.Name of the snippet member specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetName(
    int index
)
Public Overrides Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
) override
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: String

Implements

ICodeCompletionProviderGetName(Int32)
ICodeCompletionProviderGetName(Int32)
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.GetParent Method

CodeSnippetMembersGetParent Method
Returns code completion provider owning this ICodeCompletionProvider instance.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionProvider GetParent()
Public Overrides Function GetParent As ICodeCompletionProvider
public:
virtual ICodeCompletionProvider^ GetParent() override
abstract GetParent : unit -> ICodeCompletionProvider
override GetParent : unit -> ICodeCompletionProvider

Return Value

Type: ICodeCompletionProvider
Parent of the ICodeCompletionProvider.

Implements

ICodeCompletionProviderGetParent
ICodeCompletionProviderGetParent
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.GetText Method

CodeSnippetMembersGetText Method
Returns an empty string.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetText(
    int index
)
Public Overrides Function GetText (
    index As Integer
) As String
public:
virtual String^ GetText(
    int index
) override
abstract GetText :
        index : int -> string
override GetText :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: String

Implements

ICodeCompletionProviderGetText(Int32)
ICodeCompletionProviderGetText(Int32)
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.InsertSnippetMember Method

CodeSnippetMembersInsertSnippetMember Method
Inserts a new item to the specified position within the ICodeSnippetMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetMember InsertSnippetMember(
    int index
)
Public Overridable Function InsertSnippetMember (
    index As Integer
) As ICodeSnippetMember
public:
virtual ICodeSnippetMember^ InsertSnippetMember(
    int index
)
abstract InsertSnippetMember :
        index : int -> ICodeSnippetMember
override InsertSnippetMember :
        index : int -> ICodeSnippetMember

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetMember
ICodeSnippetMember that is inserted.

Implements

ICodeSnippetMembersInsertSnippetMember(Int32)
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.OnClosePopup Method

CodeSnippetMembersOnClosePopup Method
Checks for nested members and raises ClosePopup event if they are not found.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void OnClosePopup(
    Object sender,
    ClosingEventArgs e
)
Public Overrides Sub OnClosePopup (
    sender As Object,
    e As ClosingEventArgs
)
public:
virtual void OnClosePopup(
    Object^ sender,
    ClosingEventArgs^ e
) override
abstract OnClosePopup :
        sender : Object *
        e : ClosingEventArgs -> unit
override OnClosePopup :
        sender : Object *
        e : ClosingEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxClosingEventArgs
A ClosingEventArgs that contains the event data.

Implements

ICodeCompletionProviderOnClosePopup(Object, ClosingEventArgs)
ICodeCompletionProviderOnClosePopup(Object, ClosingEventArgs)
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.ShouldIndent Method

CodeSnippetMembersShouldIndent Method
Gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldIndent(
    ICodeSnippet snippet
)
Public Overridable Function ShouldIndent (
    snippet As ICodeSnippet
) As Boolean
public:
virtual bool ShouldIndent(
    ICodeSnippet^ snippet
)
abstract ShouldIndent :
        snippet : ICodeSnippet -> bool
override ShouldIndent :
        snippet : ICodeSnippet -> bool

Parameters

snippet
Type: Alternet.Syntax.CodeCompletionICodeSnippet
Specifies given snippet.

Return Value

Type: Boolean
True if code should be indented, otherwise False.

Implements

ICodeSnippetsProviderShouldIndent(ICodeSnippet)
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers Properties

CodeSnippetMembers Properties

The CodeSnippetMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Overrides CodeCompletionProviderEditPath.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Overrides CodeCompletionProviderImages.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to ICodeSnippetMember objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | Parent | Gets or sets a parent of the CodeSnippetMembers.
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetMembers object. (Overrides CodeCompletionProviderSerializationInfo.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.ColumnCount Property

CodeSnippetMembersColumnCount Property
Returns number of the columns. In this class ColumnCount always return 1.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

ICodeCompletionProviderColumnCount
ICodeCompletionProviderColumnCount
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.EditPath Property

CodeSnippetMembersEditPath Property
Gets or sets a value indicating path to the nested code completion provider.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string EditPath { get; }
Public Overrides ReadOnly Property EditPath As String
    Get
public:
virtual property String^ EditPath {
    String^ get () override;
}
abstract EditPath : string with get
override EditPath : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderEditPath
ICodeCompletionProviderEditPath
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.Images Property

CodeSnippetMembersImages Property
Gets or sets the ImageList for code completion items.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; set; }
Public Overrides Property Images As ImageList
    Get
    Set
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
    void set (ImageList^ value) override;
}
abstract Images : ImageList with get, set
override Images : ImageList with get, set

Property Value

Type: ImageList

Implements

ICodeCompletionProviderImages
ICodeCompletionProviderImages
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.Item Property

CodeSnippetMembersItem Property
Provides an indexed access to ICodeSnippetMember objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeSnippetMember this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ICodeSnippetMember
    Get
    Set
public:
virtual property ICodeSnippetMember^ default[int index] {
    ICodeSnippetMember^ get (int index) sealed;
    void set (int index, ICodeSnippetMember^ value) sealed;
}
abstract Item : ICodeSnippetMember with get, set
override Item : ICodeSnippetMember with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: ICodeSnippetMember

Implements

ICodeSnippetMembersItemInt32
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.Parent Property

CodeSnippetMembersParent Property
Gets or sets a parent of the CodeSnippetMembers.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetMember Parent { get; set; }
Public Overridable Property Parent As ICodeSnippetMember
    Get
    Set
public:
virtual property ICodeSnippetMember^ Parent {
    ICodeSnippetMember^ get ();
    void set (ICodeSnippetMember^ value);
}
abstract Parent : ICodeSnippetMember with get, set
override Parent : ICodeSnippetMember with get, set

Property Value

Type: ICodeSnippetMember

Implements

ICodeSnippetMembersParent
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers.SerializationInfo Property

CodeSnippetMembersSerializationInfo Property
Gets or sets an xml representation of this CodeSnippetMembers object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetMembers Events

CodeSnippetMembers Events

The CodeSnippetMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeSnippetMembers Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObject Class

CodeSnippetObject Class
Represents literal that make up the parts of a code snippet that you can edit.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippetLiteral
Alternet.Syntax.CodeCompletionCodeSnippetObject

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetObject : CodeSnippetLiteral,
    ICodeSnippetObject, ICodeSnippetLiteral, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippetObject
    Inherits CodeSnippetLiteral
    Implements ICodeSnippetObject, ICodeSnippetLiteral, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippetObject : public CodeSnippetLiteral,
    ICodeSnippetObject, ICodeSnippetLiteral, ICodeCompletionProviderItem, IComparable
type CodeSnippetObject =
    class
        inherit CodeSnippetLiteral
        interface ICodeSnippetObject
        interface ICodeSnippetLiteral
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippetObject type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetObject | Initializes a new instance of the CodeSnippetObject class with default settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeSnippetLiteral.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Default | Specifies the default value of the literal or object for an IntelliSense Code Snippet. (Inherited from CodeSnippetLiteral.)
Public property | Editable | Specifies whether literal is editable or not. (Inherited from CodeSnippetLiteral.)
Public property | Function | Specifies a function to execute when the literal or object receives focus in the Editor. (Inherited from CodeSnippetLiteral.)
Public property | ID | Specifies the unique identifier for the object or literal.. (Inherited from CodeSnippetLiteral.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetLiteral object. (Inherited from CodeSnippetLiteral.)
Public property | SupportsCode | Specifies whether literal can fill code. (Inherited from CodeSnippetLiteral.)
Public property | ToolTip | Specifies the ToolTip description to be associated with the literal in the code snippet. (Inherited from CodeSnippetLiteral.)
Public property | Type | Specifies the type of the object. (Inherited from CodeSnippetLiteral.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObject Constructor

CodeSnippetObject Constructor
Initializes a new instance of the CodeSnippetObject class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetObject()
Public Sub New
public:
CodeSnippetObject()
new : unit -> CodeSnippetObject
See Also

Reference

CodeSnippetObject Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObject Methods

CodeSnippetObject Methods

The CodeSnippetObject type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeSnippetLiteral.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetObject Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObject Properties

CodeSnippetObject Properties

The CodeSnippetObject type exposes the following members.

Properties
 | Name | Description
Public property | Default | Specifies the default value of the literal or object for an IntelliSense Code Snippet. (Inherited from CodeSnippetLiteral.)
Public property | Editable | Specifies whether literal is editable or not. (Inherited from CodeSnippetLiteral.)
Public property | Function | Specifies a function to execute when the literal or object receives focus in the Editor. (Inherited from CodeSnippetLiteral.)
Public property | ID | Specifies the unique identifier for the object or literal.. (Inherited from CodeSnippetLiteral.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetLiteral object. (Inherited from CodeSnippetLiteral.)
Public property | SupportsCode | Specifies whether literal can fill code. (Inherited from CodeSnippetLiteral.)
Public property | ToolTip | Specifies the ToolTip description to be associated with the literal in the code snippet. (Inherited from CodeSnippetLiteral.)
Public property | Type | Specifies the type of the object. (Inherited from CodeSnippetLiteral.)
Top
See Also

Reference

CodeSnippetObject Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObjects Class

CodeSnippetObjects Class
Provides an indexed access to individual ICodeSnippetObject objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeSnippetObject
Alternet.Syntax.CodeCompletionCodeSnippetObjects

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetObjects : List<ICodeSnippetObject>,
    ICodeSnippetObjects, IList<ICodeSnippetObject>, ICollection<ICodeSnippetObject>,
    IEnumerable<ICodeSnippetObject>, IEnumerable
Public Class CodeSnippetObjects
    Inherits List(Of ICodeSnippetObject)
    Implements ICodeSnippetObjects, IList(Of ICodeSnippetObject),
    ICollection(Of ICodeSnippetObject), IEnumerable(Of ICodeSnippetObject), IEnumerable
public ref class CodeSnippetObjects : public List<ICodeSnippetObject^>,
    ICodeSnippetObjects, IList<ICodeSnippetObject^>, ICollection<ICodeSnippetObject^>,
    IEnumerable<ICodeSnippetObject^>, IEnumerable
type CodeSnippetObjects =
    class
        inherit List<ICodeSnippetObject>
        interface ICodeSnippetObjects
        interface IList<ICodeSnippetObject>
        interface ICollection<ICodeSnippetObject>
        interface IEnumerable<ICodeSnippetObject>
        interface IEnumerable
    end

The CodeSnippetObjects type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetObjects | Initializes a new instance of the CodeSnippetObjects class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetObject .)
Public method | AddObject | Adds a new item to the specified position within the ICodeSnippetObjects collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetObject .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetObject .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetObject .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetObject .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetObject .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetObject .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetObject .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetObject .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetObject .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetObject .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetObject .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetObject .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetObject .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetObject .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetObject .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetObject .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetObject .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetObject .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetObject .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetObject .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetObject .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetObject .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetObject .)
Public method | InsertObject | Inserts a new item to the specified position within the ICodeSnippetObject collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetObject .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetObject .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetObject .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetObject .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetObject .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetObject .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetObject .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetObject .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetObject .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetObject .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetObject .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetObject .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetObject .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetObject .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetObject .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetObject | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetObject | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetObject, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetObject .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetObject .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetObject .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObjects Constructor

CodeSnippetObjects Constructor
Initializes a new instance of the CodeSnippetObjects class

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetObjects()
Public Sub New
public:
CodeSnippetObjects()
new : unit -> CodeSnippetObjects
See Also

Reference

CodeSnippetObjects Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObjects Methods

CodeSnippetObjects Methods

The CodeSnippetObjects type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetObject .)
Public method | AddObject | Adds a new item to the specified position within the ICodeSnippetObjects collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetObject .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetObject .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetObject .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetObject .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetObject .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetObject .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetObject .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetObject .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetObject .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetObject .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetObject .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetObject .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetObject .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetObject .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetObject .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetObject .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetObject .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetObject .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetObject .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetObject .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetObject .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetObject .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetObject .)
Public method | InsertObject | Inserts a new item to the specified position within the ICodeSnippetObject collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetObject .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetObject .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetObject .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetObject .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetObject .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetObject .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetObject .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetObject .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetObject .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetObject .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetObject .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetObject .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetObject .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetObject .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetObject .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetObject .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetObject | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetObject | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetObject, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippetObjects Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObjects.AddObject Method

CodeSnippetObjectsAddObject Method
Adds a new item to the specified position within the ICodeSnippetObjects collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetObject AddObject()
Public Overridable Function AddObject As ICodeSnippetObject
public:
virtual ICodeSnippetObject^ AddObject()
abstract AddObject : unit -> ICodeSnippetObject
override AddObject : unit -> ICodeSnippetObject

Return Value

Type: ICodeSnippetObject
ICodeSnippetObject that is added.

Implements

ICodeSnippetObjectsAddObject
See Also

Reference

CodeSnippetObjects Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObjects.InsertObject Method

CodeSnippetObjectsInsertObject Method
Inserts a new item to the specified position within the ICodeSnippetObject collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetObject InsertObject(
    int index
)
Public Overridable Function InsertObject (
    index As Integer
) As ICodeSnippetObject
public:
virtual ICodeSnippetObject^ InsertObject(
    int index
)
abstract InsertObject :
        index : int -> ICodeSnippetObject
override InsertObject :
        index : int -> ICodeSnippetObject

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetObject
ICodeSnippetObject that is inserted.

Implements

ICodeSnippetObjectsInsertObject(Int32)
See Also

Reference

CodeSnippetObjects Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetObjects Properties

CodeSnippetObjects Properties

The CodeSnippetObjects type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetObject .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetObject .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetObject .)
Top
See Also

Reference

CodeSnippetObjects Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReference Class

CodeSnippetReference Class
Contains information about assembly references for the code snippet.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippetReference

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetReference : CodeCompletionProviderItem,
    ICodeSnippetReference, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippetReference
    Inherits CodeCompletionProviderItem
    Implements ICodeSnippetReference, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippetReference : public CodeCompletionProviderItem,
    ICodeSnippetReference, ICodeCompletionProviderItem, IComparable
type CodeSnippetReference =
    class
        inherit CodeCompletionProviderItem
        interface ICodeSnippetReference
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippetReference type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetReference | Initializes a new instance of the CodeSnippetReference class with default settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Assembly | Contains the name of the assembly referenced by the code snippet.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetReference object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | Url | Contains a URL that provides more information about the referenced assembly.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReference Constructor

CodeSnippetReference Constructor
Initializes a new instance of the CodeSnippetReference class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetReference()
Public Sub New
public:
CodeSnippetReference()
new : unit -> CodeSnippetReference
See Also

Reference

CodeSnippetReference Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReference Methods

CodeSnippetReference Methods

The CodeSnippetReference type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetReference Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReference.CompareTo Method

CodeSnippetReferenceCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

CodeSnippetReference Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReference Properties

CodeSnippetReference Properties

The CodeSnippetReference type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Contains the name of the assembly referenced by the code snippet.
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetReference object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | Url | Contains a URL that provides more information about the referenced assembly.
Top
See Also

Reference

CodeSnippetReference Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReference.Assembly Property

CodeSnippetReferenceAssembly Property
Contains the name of the assembly referenced by the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Assembly { get; set; }
Public Overridable Property Assembly As String
    Get
    Set
public:
virtual property String^ Assembly {
    String^ get ();
    void set (String^ value);
}
abstract Assembly : string with get, set
override Assembly : string with get, set

Property Value

Type: String

Implements

ICodeSnippetReferenceAssembly
See Also

Reference

CodeSnippetReference Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReference.SerializationInfo Property

CodeSnippetReferenceSerializationInfo Property
Gets or sets an xml representation of this CodeSnippetReference object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippetReference Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReference.Url Property

CodeSnippetReferenceUrl Property
Contains a URL that provides more information about the referenced assembly.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Url { get; set; }
Public Overridable Property Url As String
    Get
    Set
public:
virtual property String^ Url {
    String^ get ();
    void set (String^ value);
}
abstract Url : string with get, set
override Url : string with get, set

Property Value

Type: String

Implements

ICodeSnippetReferenceUrl
See Also

Reference

CodeSnippetReference Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReferences Class

CodeSnippetReferences Class
Provides an indexed access to individual ICodeSnippetReference objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeSnippetReference
Alternet.Syntax.CodeCompletionCodeSnippetReferences

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetReferences : List<ICodeSnippetReference>,
    ICodeSnippetReferences, IList<ICodeSnippetReference>, ICollection<ICodeSnippetReference>,
    IEnumerable<ICodeSnippetReference>, IEnumerable
Public Class CodeSnippetReferences
    Inherits List(Of ICodeSnippetReference)
    Implements ICodeSnippetReferences, IList(Of ICodeSnippetReference),
    ICollection(Of ICodeSnippetReference), IEnumerable(Of ICodeSnippetReference), IEnumerable
public ref class CodeSnippetReferences : public List<ICodeSnippetReference^>,
    ICodeSnippetReferences, IList<ICodeSnippetReference^>, ICollection<ICodeSnippetReference^>,
    IEnumerable<ICodeSnippetReference^>, IEnumerable
type CodeSnippetReferences =
    class
        inherit List<ICodeSnippetReference>
        interface ICodeSnippetReferences
        interface IList<ICodeSnippetReference>
        interface ICollection<ICodeSnippetReference>
        interface IEnumerable<ICodeSnippetReference>
        interface IEnumerable
    end

The CodeSnippetReferences type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetReferences | Initializes a new instance of the CodeSnippetReferences class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetReference .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetReference .)
Public method | AddReference | Adds a new item to the specified position within the ICodeSnippetReferences collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetReference .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetReference .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetReference .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetReference .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetReference .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetReference .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetReference .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetReference .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetReference .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetReference .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetReference .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetReference .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetReference .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetReference .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetReference .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetReference .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetReference .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetReference .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetReference .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetReference .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetReference .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetReference .)
Public method | InsertReference | Inserts a new item to the specified position within the ICodeSnippetReferences collection.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetReference .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetReference .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetReference .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetReference .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetReference .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetReference .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetReference .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetReference .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetReference .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetReference .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetReference .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetReference .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetReference .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetReference | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetReference | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetReference, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetReference .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetReference .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetReference .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReferences Constructor

CodeSnippetReferences Constructor
Initializes a new instance of the CodeSnippetReferences class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetReferences()
Public Sub New
public:
CodeSnippetReferences()
new : unit -> CodeSnippetReferences
See Also

Reference

CodeSnippetReferences Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReferences Methods

CodeSnippetReferences Methods

The CodeSnippetReferences type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetReference .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetReference .)
Public method | AddReference | Adds a new item to the specified position within the ICodeSnippetReferences collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetReference .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetReference .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetReference .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetReference .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetReference .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetReference .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetReference .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetReference .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetReference .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetReference .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetReference .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetReference .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetReference .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetReference .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetReference .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetReference .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetReference .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetReference .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetReference .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetReference .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetReference .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetReference .)
Public method | InsertReference | Inserts a new item to the specified position within the ICodeSnippetReferences collection.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetReference .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetReference .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetReference .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetReference .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetReference .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetReference .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetReference .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetReference .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetReference .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetReference .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetReference .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetReference .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetReference .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetReference .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetReference .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetReference | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetReference | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetReference, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippetReferences Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReferences.AddReference Method

CodeSnippetReferencesAddReference Method
Adds a new item to the specified position within the ICodeSnippetReferences collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetReference AddReference()
Public Overridable Function AddReference As ICodeSnippetReference
public:
virtual ICodeSnippetReference^ AddReference()
abstract AddReference : unit -> ICodeSnippetReference
override AddReference : unit -> ICodeSnippetReference

Return Value

Type: ICodeSnippetReference
ICodeSnippetReference that is added.

Implements

ICodeSnippetReferencesAddReference
See Also

Reference

CodeSnippetReferences Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReferences.InsertReference Method

CodeSnippetReferencesInsertReference Method
Inserts a new item to the specified position within the ICodeSnippetReferences collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetReference InsertReference(
    int index
)
Public Overridable Function InsertReference (
    index As Integer
) As ICodeSnippetReference
public:
virtual ICodeSnippetReference^ InsertReference(
    int index
)
abstract InsertReference :
        index : int -> ICodeSnippetReference
override InsertReference :
        index : int -> ICodeSnippetReference

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetReference
ICodeSnippetReference that is inserted.

Implements

ICodeSnippetReferencesInsertReference(Int32)
See Also

Reference

CodeSnippetReferences Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetReferences Properties

CodeSnippetReferences Properties

The CodeSnippetReferences type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetReference .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetReference .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetReference .)
Top
See Also

Reference

CodeSnippetReferences Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets Class

CodeSnippets Class
Represents collection containing list of code snippets.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionCodeSnippets

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippets : CodeCompletionProvider,
    ICodeSnippets, ICodeSnippetsProvider, ICodeCompletionProvider, IList<ICodeCompletionProviderItem>,
    ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>, IEnumerable,
    IExport, IImport
Public Class CodeSnippets
    Inherits CodeCompletionProvider
    Implements ICodeSnippets, ICodeSnippetsProvider, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class CodeSnippets : public CodeCompletionProvider,
    ICodeSnippets, ICodeSnippetsProvider, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>,
    ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>, IEnumerable,
    IExport, IImport
type CodeSnippets =
    class
        inherit CodeCompletionProvider
        interface ICodeSnippets
        interface ICodeSnippetsProvider
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The CodeSnippets type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippets | Initializes a new instance of the CodeSnippets class with default settings.
Public method | CodeSnippets(ICodeSnippetMember) | Initializes a new instance of the CodeSnippets class with specified parent.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddSnippet | Adds a new item to the ICodeSnippets collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindByShortcut | Gets a code snippet by its shortcut.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column and snippet. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeSnippet.ImageIndex from the snippet specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns value ICodeSnippetHeader.Title of the code snippet specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Overrides CodeCompletionProviderGetParent.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns value of ICodeSnippetCode.Code of the code snippet specified by index. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertSnippet | Inserts a new item to the specified position within the ICodeSnippets collection.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | ShouldIndent | Gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Overrides CodeCompletionProviderEditPath.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Overrides CodeCompletionProviderImages.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to ICodeSnippet objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippets object. (Overrides CodeCompletionProviderSerializationInfo.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippets Constructor

CodeSnippets Constructor
Overload List
 | Name | Description
Public method | CodeSnippets | Initializes a new instance of the CodeSnippets class with default settings.
Public method | CodeSnippets(ICodeSnippetMember) | Initializes a new instance of the CodeSnippets class with specified parent.
Top
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets Constructor

CodeSnippets Constructor
Initializes a new instance of the CodeSnippets class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippets()
Public Sub New
public:
CodeSnippets()
new : unit -> CodeSnippets
See Also

Reference

CodeSnippets Class
CodeSnippets Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets Constructor (ICodeSnippetMember)

CodeSnippets Constructor (ICodeSnippetMember)
Initializes a new instance of the CodeSnippets class with specified parent.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippets(
    ICodeSnippetMember parent
)
Public Sub New (
    parent As ICodeSnippetMember
)
public:
CodeSnippets(
    ICodeSnippetMember^ parent
)
new :
        parent : ICodeSnippetMember -> CodeSnippets

Parameters

parent
Type: Alternet.Syntax.CodeCompletionICodeSnippetMember
See Also

Reference

CodeSnippets Class
CodeSnippets Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets Methods

CodeSnippets Methods

The CodeSnippets type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddSnippet | Adds a new item to the ICodeSnippets collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindByShortcut | Gets a code snippet by its shortcut.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column and snippet. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeSnippet.ImageIndex from the snippet specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns value ICodeSnippetHeader.Title of the code snippet specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Overrides CodeCompletionProviderGetParent.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns value of ICodeSnippetCode.Code of the code snippet specified by index. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertSnippet | Inserts a new item to the specified position within the ICodeSnippets collection.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | ShouldIndent | Gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.AddSnippet Method

CodeSnippetsAddSnippet Method
Adds a new item to the ICodeSnippets collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippet AddSnippet()
Public Overridable Function AddSnippet As ICodeSnippet
public:
virtual ICodeSnippet^ AddSnippet()
abstract AddSnippet : unit -> ICodeSnippet
override AddSnippet : unit -> ICodeSnippet

Return Value

Type: ICodeSnippet
ICodeSnippet that is added.

Implements

ICodeSnippetsAddSnippet
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.ColumnVisible Method

CodeSnippetsColumnVisible Method
Indicates whether specified column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ColumnVisible(
    int column
)
Public Overrides Function ColumnVisible (
    column As Integer
) As Boolean
public:
virtual bool ColumnVisible(
    int column
) override
abstract ColumnVisible :
        column : int -> bool
override ColumnVisible :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICodeCompletionProviderColumnVisible(Int32)
ICodeCompletionProviderColumnVisible(Int32)
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.FindByShortcut Method

CodeSnippetsFindByShortcut Method
Gets a code snippet by its shortcut.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippet FindByShortcut(
    string shortcut,
    bool caseSensitive
)
Public Overridable Function FindByShortcut (
    shortcut As String,
    caseSensitive As Boolean
) As ICodeSnippet
public:
virtual ICodeSnippet^ FindByShortcut(
    String^ shortcut,
    bool caseSensitive
)
abstract FindByShortcut :
        shortcut : string *
        caseSensitive : bool -> ICodeSnippet
override FindByShortcut :
        shortcut : string *
        caseSensitive : bool -> ICodeSnippet

Parameters

shortcut
Type: SystemString
caseSensitive
Type: SystemBoolean

Return Value

Type: ICodeSnippet

Implements

ICodeSnippetsProviderFindByShortcut(String, Boolean)
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.GetColumnText Method

CodeSnippetsGetColumnText Method
Returns text from specified column and snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the snippet.
column
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: String
Text representing specified snippet.

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.GetDescription Method

CodeSnippetsGetDescription Method
Returns a content of the column, named 'Description', of the specified item from the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDescription(
    int index
)
Public Overrides Function GetDescription (
    index As Integer
) As String
public:
virtual String^ GetDescription(
    int index
) override
abstract GetDescription :
        index : int -> string
override GetDescription :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of the item within the collection.

Return Value

Type: String
String content of specified column.

Implements

ICodeCompletionProviderGetDescription(Int32)
ICodeCompletionProviderGetDescription(Int32)
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.GetImageIndex Method

CodeSnippetsGetImageIndex Method
Returns ICodeSnippet.ImageIndex from the snippet specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetImageIndex(
    int index
)
Public Overrides Function GetImageIndex (
    index As Integer
) As Integer
public:
virtual int GetImageIndex(
    int index
) override
abstract GetImageIndex :
        index : int -> int
override GetImageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: Int32

Implements

ICodeCompletionProviderGetImageIndex(Int32)
ICodeCompletionProviderGetImageIndex(Int32)
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.GetName Method

CodeSnippetsGetName Method
Returns value ICodeSnippetHeader.Title of the code snippet specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetName(
    int index
)
Public Overrides Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
) override
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: String

Implements

ICodeCompletionProviderGetName(Int32)
ICodeCompletionProviderGetName(Int32)
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.GetParent Method

CodeSnippetsGetParent Method
Returns code completion provider owning this ICodeCompletionProvider instance.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionProvider GetParent()
Public Overrides Function GetParent As ICodeCompletionProvider
public:
virtual ICodeCompletionProvider^ GetParent() override
abstract GetParent : unit -> ICodeCompletionProvider
override GetParent : unit -> ICodeCompletionProvider

Return Value

Type: ICodeCompletionProvider
Parent of the ICodeCompletionProvider.

Implements

ICodeCompletionProviderGetParent
ICodeCompletionProviderGetParent
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.GetText Method

CodeSnippetsGetText Method
Returns value of ICodeSnippetCode.Code of the code snippet specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetText(
    int index
)
Public Overrides Function GetText (
    index As Integer
) As String
public:
virtual String^ GetText(
    int index
) override
abstract GetText :
        index : int -> string
override GetText :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: String

Implements

ICodeCompletionProviderGetText(Int32)
ICodeCompletionProviderGetText(Int32)
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.InsertSnippet Method

CodeSnippetsInsertSnippet Method
Inserts a new item to the specified position within the ICodeSnippets collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippet InsertSnippet(
    int index
)
Public Overridable Function InsertSnippet (
    index As Integer
) As ICodeSnippet
public:
virtual ICodeSnippet^ InsertSnippet(
    int index
)
abstract InsertSnippet :
        index : int -> ICodeSnippet
override InsertSnippet :
        index : int -> ICodeSnippet

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippet
ICodeSnippet that is inserted.

Implements

ICodeSnippetsInsertSnippet(Int32)
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.ShouldIndent Method

CodeSnippetsShouldIndent Method
Gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldIndent(
    ICodeSnippet snippet
)
Public Overridable Function ShouldIndent (
    snippet As ICodeSnippet
) As Boolean
public:
virtual bool ShouldIndent(
    ICodeSnippet^ snippet
)
abstract ShouldIndent :
        snippet : ICodeSnippet -> bool
override ShouldIndent :
        snippet : ICodeSnippet -> bool

Parameters

snippet
Type: Alternet.Syntax.CodeCompletionICodeSnippet
Specifies given snippet.

Return Value

Type: Boolean
True if code should be indented, otherwise False.

Implements

ICodeSnippetsProviderShouldIndent(ICodeSnippet)
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets Properties

CodeSnippets Properties

The CodeSnippets type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Overrides CodeCompletionProviderEditPath.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Overrides CodeCompletionProviderImages.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to ICodeSnippet objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippets object. (Overrides CodeCompletionProviderSerializationInfo.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.ColumnCount Property

CodeSnippetsColumnCount Property
Returns number of the columns. In this class ColumnCount always return 1.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

ICodeCompletionProviderColumnCount
ICodeCompletionProviderColumnCount
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.EditPath Property

CodeSnippetsEditPath Property
Gets or sets a value indicating path to the nested code completion provider.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string EditPath { get; }
Public Overrides ReadOnly Property EditPath As String
    Get
public:
virtual property String^ EditPath {
    String^ get () override;
}
abstract EditPath : string with get
override EditPath : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderEditPath
ICodeCompletionProviderEditPath
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.Images Property

CodeSnippetsImages Property
Gets or sets the ImageList for code completion items.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; set; }
Public Overrides Property Images As ImageList
    Get
    Set
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
    void set (ImageList^ value) override;
}
abstract Images : ImageList with get, set
override Images : ImageList with get, set

Property Value

Type: ImageList

Implements

ICodeCompletionProviderImages
ICodeCompletionProviderImages
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.Item Property

CodeSnippetsItem Property
Provides an indexed access to ICodeSnippet objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeSnippet this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ICodeSnippet
    Get
    Set
public:
virtual property ICodeSnippet^ default[int index] {
    ICodeSnippet^ get (int index) sealed;
    void set (int index, ICodeSnippet^ value) sealed;
}
abstract Item : ICodeSnippet with get, set
override Item : ICodeSnippet with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: ICodeSnippet

Implements

ICodeSnippetsItemInt32
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets.SerializationInfo Property

CodeSnippetsSerializationInfo Property
Gets or sets an xml representation of this CodeSnippets object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippets Events

CodeSnippets Events

The CodeSnippets type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeSnippets Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider Class

CodeSnippetsProvider Class
Represents collection containing list of code snippets.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionCodeSnippetsProvider

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetsProvider : CodeCompletionProvider,
    ICodeSnippetsProvider, ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Class CodeSnippetsProvider
    Inherits CodeCompletionProvider
    Implements ICodeSnippetsProvider, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class CodeSnippetsProvider : public CodeCompletionProvider,
    ICodeSnippetsProvider, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type CodeSnippetsProvider =
    class
        inherit CodeCompletionProvider
        interface ICodeSnippetsProvider
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The CodeSnippetsProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetsProvider | Initializes a new instance of the CodeSnippets class with default settings.
Public method | CodeSnippetsProvider(ICodeSnippetMember) | Initializes a new instance of the CodeSnippets class with specified parent.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindByShortcut | Gets a code snippet by its shortcut.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column and snippet. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeSnippet.ImageIndex from the snippet specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns value ICodeSnippetHeader.Title of the code snippet specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Overrides CodeCompletionProviderGetParent.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns value of ICodeSnippetCode.Code of the code snippet specified by index. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Checks for nested members and raises ClosePopup event if they are not found. (Overrides CodeCompletionProviderOnClosePopup(Object, ClosingEventArgs).)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | ShouldIndent | Gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Overrides CodeCompletionProviderEditPath.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Overrides CodeCompletionProviderImages.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider Constructor

CodeSnippetsProvider Constructor
Overload List
 | Name | Description
Public method | CodeSnippetsProvider | Initializes a new instance of the CodeSnippets class with default settings.
Public method | CodeSnippetsProvider(ICodeSnippetMember) | Initializes a new instance of the CodeSnippets class with specified parent.
Top
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider Constructor

CodeSnippetsProvider Constructor
Initializes a new instance of the CodeSnippets class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetsProvider()
Public Sub New
public:
CodeSnippetsProvider()
new : unit -> CodeSnippetsProvider
See Also

Reference

CodeSnippetsProvider Class
CodeSnippetsProvider Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider Constructor (ICodeSnippetMember)

CodeSnippetsProvider Constructor (ICodeSnippetMember)
Initializes a new instance of the CodeSnippets class with specified parent.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetsProvider(
    ICodeSnippetMember parent
)
Public Sub New (
    parent As ICodeSnippetMember
)
public:
CodeSnippetsProvider(
    ICodeSnippetMember^ parent
)
new :
        parent : ICodeSnippetMember -> CodeSnippetsProvider

Parameters

parent
Type: Alternet.Syntax.CodeCompletionICodeSnippetMember
See Also

Reference

CodeSnippetsProvider Class
CodeSnippetsProvider Overload
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider Methods

CodeSnippetsProvider Methods

The CodeSnippetsProvider type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindByShortcut | Gets a code snippet by its shortcut.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from specified column and snippet. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeSnippet.ImageIndex from the snippet specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns value ICodeSnippetHeader.Title of the code snippet specified by index. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Overrides CodeCompletionProviderGetParent.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns value of ICodeSnippetCode.Code of the code snippet specified by index. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Checks for nested members and raises ClosePopup event if they are not found. (Overrides CodeCompletionProviderOnClosePopup(Object, ClosingEventArgs).)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | ShouldIndent | Gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.ColumnVisible Method

CodeSnippetsProviderColumnVisible Method
Indicates whether specified column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ColumnVisible(
    int column
)
Public Overrides Function ColumnVisible (
    column As Integer
) As Boolean
public:
virtual bool ColumnVisible(
    int column
) override
abstract ColumnVisible :
        column : int -> bool
override ColumnVisible :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICodeCompletionProviderColumnVisible(Int32)
ICodeCompletionProviderColumnVisible(Int32)
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.FindByShortcut Method

CodeSnippetsProviderFindByShortcut Method
Gets a code snippet by its shortcut.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippet FindByShortcut(
    string shortcut,
    bool caseSensitive
)
Public Overridable Function FindByShortcut (
    shortcut As String,
    caseSensitive As Boolean
) As ICodeSnippet
public:
virtual ICodeSnippet^ FindByShortcut(
    String^ shortcut,
    bool caseSensitive
)
abstract FindByShortcut :
        shortcut : string *
        caseSensitive : bool -> ICodeSnippet
override FindByShortcut :
        shortcut : string *
        caseSensitive : bool -> ICodeSnippet

Parameters

shortcut
Type: SystemString
caseSensitive
Type: SystemBoolean

Return Value

Type: ICodeSnippet

Implements

ICodeSnippetsProviderFindByShortcut(String, Boolean)
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.GetColumnText Method

CodeSnippetsProviderGetColumnText Method
Returns text from specified column and snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the snippet.
column
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: String
Text representing specified snippet.

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.GetDescription Method

CodeSnippetsProviderGetDescription Method
Returns a content of the column, named 'Description', of the specified item from the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDescription(
    int index
)
Public Overrides Function GetDescription (
    index As Integer
) As String
public:
virtual String^ GetDescription(
    int index
) override
abstract GetDescription :
        index : int -> string
override GetDescription :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of the item within the collection.

Return Value

Type: String
String content of specified column.

Implements

ICodeCompletionProviderGetDescription(Int32)
ICodeCompletionProviderGetDescription(Int32)
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.GetImageIndex Method

CodeSnippetsProviderGetImageIndex Method
Returns ICodeSnippet.ImageIndex from the snippet specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetImageIndex(
    int index
)
Public Overrides Function GetImageIndex (
    index As Integer
) As Integer
public:
virtual int GetImageIndex(
    int index
) override
abstract GetImageIndex :
        index : int -> int
override GetImageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: Int32

Implements

ICodeCompletionProviderGetImageIndex(Int32)
ICodeCompletionProviderGetImageIndex(Int32)
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.GetName Method

CodeSnippetsProviderGetName Method
Returns value ICodeSnippetHeader.Title of the code snippet specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetName(
    int index
)
Public Overrides Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
) override
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: String

Implements

ICodeCompletionProviderGetName(Int32)
ICodeCompletionProviderGetName(Int32)
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.GetParent Method

CodeSnippetsProviderGetParent Method
Returns code completion provider owning this ICodeCompletionProvider instance.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionProvider GetParent()
Public Overrides Function GetParent As ICodeCompletionProvider
public:
virtual ICodeCompletionProvider^ GetParent() override
abstract GetParent : unit -> ICodeCompletionProvider
override GetParent : unit -> ICodeCompletionProvider

Return Value

Type: ICodeCompletionProvider
Parent of the ICodeCompletionProvider.

Implements

ICodeCompletionProviderGetParent
ICodeCompletionProviderGetParent
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.GetText Method

CodeSnippetsProviderGetText Method
Returns value of ICodeSnippetCode.Code of the code snippet specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetText(
    int index
)
Public Overrides Function GetText (
    index As Integer
) As String
public:
virtual String^ GetText(
    int index
) override
abstract GetText :
        index : int -> string
override GetText :
        index : int -> string

Parameters

index
Type: SystemInt32
Specifies index of the snippet.

Return Value

Type: String

Implements

ICodeCompletionProviderGetText(Int32)
ICodeCompletionProviderGetText(Int32)
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.OnClosePopup Method

CodeSnippetsProviderOnClosePopup Method
Checks for nested members and raises ClosePopup event if they are not found.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void OnClosePopup(
    Object sender,
    ClosingEventArgs e
)
Public Overrides Sub OnClosePopup (
    sender As Object,
    e As ClosingEventArgs
)
public:
virtual void OnClosePopup(
    Object^ sender,
    ClosingEventArgs^ e
) override
abstract OnClosePopup :
        sender : Object *
        e : ClosingEventArgs -> unit
override OnClosePopup :
        sender : Object *
        e : ClosingEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxClosingEventArgs
A ClosingEventArgs that contains the event data.

Implements

ICodeCompletionProviderOnClosePopup(Object, ClosingEventArgs)
ICodeCompletionProviderOnClosePopup(Object, ClosingEventArgs)
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.ShouldIndent Method

CodeSnippetsProviderShouldIndent Method
Gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldIndent(
    ICodeSnippet snippet
)
Public Overridable Function ShouldIndent (
    snippet As ICodeSnippet
) As Boolean
public:
virtual bool ShouldIndent(
    ICodeSnippet^ snippet
)
abstract ShouldIndent :
        snippet : ICodeSnippet -> bool
override ShouldIndent :
        snippet : ICodeSnippet -> bool

Parameters

snippet
Type: Alternet.Syntax.CodeCompletionICodeSnippet
Specifies given snippet.

Return Value

Type: Boolean
True if code should be indented, otherwise False.

Implements

ICodeSnippetsProviderShouldIndent(ICodeSnippet)
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider Properties

CodeSnippetsProvider Properties

The CodeSnippetsProvider type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. In this class ColumnCount always return 1. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Overrides CodeCompletionProviderEditPath.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Overrides CodeCompletionProviderImages.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.ColumnCount Property

CodeSnippetsProviderColumnCount Property
Returns number of the columns. In this class ColumnCount always return 1.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

ICodeCompletionProviderColumnCount
ICodeCompletionProviderColumnCount
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.EditPath Property

CodeSnippetsProviderEditPath Property
Gets or sets a value indicating path to the nested code completion provider.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string EditPath { get; }
Public Overrides ReadOnly Property EditPath As String
    Get
public:
virtual property String^ EditPath {
    String^ get () override;
}
abstract EditPath : string with get
override EditPath : string with get

Property Value

Type: String

Implements

ICodeCompletionProviderEditPath
ICodeCompletionProviderEditPath
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider.Images Property

CodeSnippetsProviderImages Property
Gets or sets the ImageList for code completion items.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; set; }
Public Overrides Property Images As ImageList
    Get
    Set
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
    void set (ImageList^ value) override;
}
abstract Images : ImageList with get, set
override Images : ImageList with get, set

Property Value

Type: ImageList

Implements

ICodeCompletionProviderImages
ICodeCompletionProviderImages
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetsProvider Events

CodeSnippetsProvider Events

The CodeSnippetsProvider type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CodeSnippetsProvider Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetType Class

CodeSnippetType Class
Specifies how the code snippet is inserted into the code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeSnippetType

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetType : CodeCompletionProviderItem,
    ICodeSnippetType, ICodeCompletionProviderItem, IComparable
Public Class CodeSnippetType
    Inherits CodeCompletionProviderItem
    Implements ICodeSnippetType, ICodeCompletionProviderItem, IComparable
public ref class CodeSnippetType : public CodeCompletionProviderItem,
    ICodeSnippetType, ICodeCompletionProviderItem, IComparable
type CodeSnippetType =
    class
        inherit CodeCompletionProviderItem
        interface ICodeSnippetType
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CodeSnippetType type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetType | Initializes a new instance of the CodeSnippetType class with default settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeCompletionProviderItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetType object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | SnippetType | Specifies how the code snippet is inserted into the code.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetType Constructor

CodeSnippetType Constructor
Initializes a new instance of the CodeSnippetType class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetType()
Public Sub New
public:
CodeSnippetType()
new : unit -> CodeSnippetType
See Also

Reference

CodeSnippetType Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetType Methods

CodeSnippetType Methods

The CodeSnippetType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from CodeCompletionProviderItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSnippetType Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetType Properties

CodeSnippetType Properties

The CodeSnippetType type exposes the following members.

Properties
 | Name | Description
Public property | SerializationInfo | Gets or sets an xml representation of this CodeSnippetType object. (Overrides CodeCompletionProviderItemSerializationInfo.)
Public property | SnippetType | Specifies how the code snippet is inserted into the code.
Top
See Also

Reference

CodeSnippetType Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetType.SerializationInfo Property

CodeSnippetTypeSerializationInfo Property
Gets or sets an xml representation of this CodeSnippetType object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISerializationInfo SerializationInfo { get; set; }
Public Overrides Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get () override;
    void set (ISerializationInfo^ value) override;
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ICodeCompletionProviderItemSerializationInfo
ICodeCompletionProviderItemSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

CodeSnippetType Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetType.SnippetType Property

CodeSnippetTypeSnippetType Property
Specifies how the code snippet is inserted into the code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SnippetType SnippetType { get; set; }
Public Overridable Property SnippetType As SnippetType
    Get
    Set
public:
virtual property SnippetType SnippetType {
    SnippetType get ();
    void set (SnippetType value);
}
abstract SnippetType : SnippetType with get, set
override SnippetType : SnippetType with get, set

Property Value

Type: SnippetType

Implements

ICodeSnippetTypeSnippetType
See Also

Reference

CodeSnippetType Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetTypes Class

CodeSnippetTypes Class
Specifies how the code snippet is inserted into the code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeSnippetType
Alternet.Syntax.CodeCompletionCodeSnippetTypes

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CodeSnippetTypes : List<ICodeSnippetType>,
    ICodeSnippetTypes, IList<ICodeSnippetType>, ICollection<ICodeSnippetType>,
    IEnumerable<ICodeSnippetType>, IEnumerable
Public Class CodeSnippetTypes
    Inherits List(Of ICodeSnippetType)
    Implements ICodeSnippetTypes, IList(Of ICodeSnippetType),
    ICollection(Of ICodeSnippetType), IEnumerable(Of ICodeSnippetType), IEnumerable
public ref class CodeSnippetTypes : public List<ICodeSnippetType^>,
    ICodeSnippetTypes, IList<ICodeSnippetType^>, ICollection<ICodeSnippetType^>,
    IEnumerable<ICodeSnippetType^>, IEnumerable
type CodeSnippetTypes =
    class
        inherit List<ICodeSnippetType>
        interface ICodeSnippetTypes
        interface IList<ICodeSnippetType>
        interface ICollection<ICodeSnippetType>
        interface IEnumerable<ICodeSnippetType>
        interface IEnumerable
    end

The CodeSnippetTypes type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSnippetTypes | Initializes a new instance of the CodeSnippetTypes class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetType .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetType .)
Public method | AddSnippetType | Adds new item to the specified position within the ICodeSnippetTypes collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetType .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetType .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetType .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetType .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetType .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetType .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetType .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetType .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetType .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetType .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetType .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetType .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetType .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetType .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetType .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetType .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetType .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetType .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetType .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetType .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetType .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetType .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetType .)
Public method | InsertSnippetType | Inserts a new item to the specified position within the ICodeSnippetTypes collection.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetType .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetType .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetType .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetType .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetType .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetType .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetType .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetType .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetType .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetType .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetType .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetType .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetType .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetType .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetType | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetType | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetType, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetType .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetType .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetType .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CodeSnippetTypes Constructor

CodeSnippetTypes Constructor
Initializes a new instance of the CodeSnippetTypes class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CodeSnippetTypes()
Public Sub New
public:
CodeSnippetTypes()
new : unit -> CodeSnippetTypes
See Also

Reference

CodeSnippetTypes Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetTypes Methods

CodeSnippetTypes Methods

The CodeSnippetTypes type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeSnippetType .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeSnippetType .)
Public method | AddSnippetType | Adds new item to the specified position within the ICodeSnippetTypes collection.
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeSnippetType .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetType .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetType .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeSnippetType .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeSnippetType .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeSnippetType .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeSnippetType .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeSnippetType .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetType .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeSnippetType .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetType .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetType .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetType .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetType .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetType .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetType .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeSnippetType .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeSnippetType .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeSnippetType .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeSnippetType .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeSnippetType .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeSnippetType .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeSnippetType .)
Public method | InsertSnippetType | Inserts a new item to the specified position within the ICodeSnippetTypes collection.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeSnippetType .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeSnippetType .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeSnippetType .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeSnippetType .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeSnippetType .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeSnippetType .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeSnippetType .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeSnippetType .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeSnippetType .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeSnippetType .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeSnippetType .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeSnippetType .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeSnippetType .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeSnippetType .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeSnippetType .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetType | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetType | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetType, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CodeSnippetTypes Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetTypes.AddSnippetType Method

CodeSnippetTypesAddSnippetType Method
Adds new item to the specified position within the ICodeSnippetTypes collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetType AddSnippetType()
Public Overridable Function AddSnippetType As ICodeSnippetType
public:
virtual ICodeSnippetType^ AddSnippetType()
abstract AddSnippetType : unit -> ICodeSnippetType
override AddSnippetType : unit -> ICodeSnippetType

Return Value

Type: ICodeSnippetType
ICodeSnippetType that is added.

Implements

ICodeSnippetTypesAddSnippetType
See Also

Reference

CodeSnippetTypes Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetTypes.InsertSnippetType Method

CodeSnippetTypesInsertSnippetType Method
Inserts a new item to the specified position within the ICodeSnippetTypes collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ICodeSnippetType InsertSnippetType(
    int index
)
Public Overridable Function InsertSnippetType (
    index As Integer
) As ICodeSnippetType
public:
virtual ICodeSnippetType^ InsertSnippetType(
    int index
)
abstract InsertSnippetType :
        index : int -> ICodeSnippetType
override InsertSnippetType :
        index : int -> ICodeSnippetType

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetType
ICodeSnippetType that is inserted.

Implements

ICodeSnippetTypesInsertSnippetType(Int32)
See Also

Reference

CodeSnippetTypes Class
Alternet.Syntax.CodeCompletion Namespace


CodeSnippetTypes Properties

CodeSnippetTypes Properties

The CodeSnippetTypes type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeSnippetType .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeSnippetType .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeSnippetType .)
Top
See Also

Reference

CodeSnippetTypes Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfo Class

CommentInfo Class
Represents simple text data related to popup hint.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionCommentInfo

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CommentInfo : CodeCompletionProvider,
    ICommentInfo, ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Class CommentInfo
    Inherits CodeCompletionProvider
    Implements ICommentInfo, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class CommentInfo : public CodeCompletionProvider,
    ICommentInfo, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type CommentInfo =
    class
        inherit CodeCompletionProvider
        interface ICommentInfo
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The CommentInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CommentInfo | Initializes a new instance of the QuickInfo class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from CodeCompletionProvider.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from given item in the specified column. (Inherited from CodeCompletionProvider.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from CodeCompletionProvider.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns string representing name of the item. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. (Inherited from CodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | Text | Gets or sets content of the ICommentInfo.
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CommentInfo Constructor

CommentInfo Constructor
Initializes a new instance of the QuickInfo class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CommentInfo()
Public Sub New
public:
CommentInfo()
new : unit -> CommentInfo
See Also

Reference

CommentInfo Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfo Methods

CommentInfo Methods

The CommentInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from CodeCompletionProvider.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from given item in the specified column. (Inherited from CodeCompletionProvider.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from CodeCompletionProvider.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns string representing name of the item. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

CommentInfo Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfo.GetName Method

CommentInfoGetName Method
Returns string representing name of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetName(
    int index
)
Public Overrides Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
) override
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing name of specified item.

Implements

ICodeCompletionProviderGetName(Int32)
ICodeCompletionProviderGetName(Int32)
See Also

Reference

CommentInfo Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfo.GetText Method

CommentInfoGetText Method
Returns string representing default column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetText(
    int index
)
Public Overrides Function GetText (
    index As Integer
) As String
public:
virtual String^ GetText(
    int index
) override
abstract GetText :
        index : int -> string
override GetText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
Text representing default column.

Implements

ICodeCompletionProviderGetText(Int32)
ICodeCompletionProviderGetText(Int32)
Remarks
In this class method returns the same value with GetName method.
See Also

Reference

CommentInfo Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfo Properties

CommentInfo Properties

The CommentInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. (Inherited from CodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | Text | Gets or sets content of the ICommentInfo.
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CommentInfo Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfo.Text Property

CommentInfoText Property
Gets or sets content of the ICommentInfo.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

ICommentInfoText
See Also

Reference

CommentInfo Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfo Events

CommentInfo Events

The CommentInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CommentInfo Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfoItem Class

CommentInfoItem Class
Stores simple text data related to popup hint.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCommentInfoItem

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CommentInfoItem : CodeCompletionProviderItem,
    ICommentInfoItem, ICodeCompletionProviderItem, IComparable
Public Class CommentInfoItem
    Inherits CodeCompletionProviderItem
    Implements ICommentInfoItem, ICodeCompletionProviderItem, IComparable
public ref class CommentInfoItem : public CodeCompletionProviderItem,
    ICommentInfoItem, ICodeCompletionProviderItem, IComparable
type CommentInfoItem =
    class
        inherit CodeCompletionProviderItem
        interface ICommentInfoItem
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The CommentInfoItem type exposes the following members.

Constructors
 | Name | Description
Public method | CommentInfoItem | Initializes a new instance of the CommentInfoItem class with specified settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Public property | Text | Gets or sets content of the ICommentInfoItem.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CommentInfoItem Constructor

CommentInfoItem Constructor
Initializes a new instance of the CommentInfoItem class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CommentInfoItem(
    string text
)
Public Sub New (
    text As String
)
public:
CommentInfoItem(
    String^ text
)
new :
        text : string -> CommentInfoItem

Parameters

text
Type: SystemString
Test to store in this new instance.
See Also

Reference

CommentInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfoItem Methods

CommentInfoItem Methods

The CommentInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommentInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfoItem.CompareTo Method

CommentInfoItemCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

CommentInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfoItem Properties

CommentInfoItem Properties

The CommentInfoItem type exposes the following members.

Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Public property | Text | Gets or sets content of the ICommentInfoItem.
Top
See Also

Reference

CommentInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


CommentInfoItem.Text Property

CommentInfoItemText Property
Gets or sets content of the ICommentInfoItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

ICommentInfoItemText
See Also

Reference

CommentInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


CParameterInfo Class

CParameterInfo Class
Represents Parameter Info data related to popup window and popup hint controls used to describe C language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionParameterInfo
Alternet.Syntax.CodeCompletionNetParameterInfo
Alternet.Syntax.CodeCompletionCParameterInfo

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CParameterInfo : NetParameterInfo
Public Class CParameterInfo
    Inherits NetParameterInfo
public ref class CParameterInfo : public NetParameterInfo
type CParameterInfo =
    class
        inherit NetParameterInfo
    end

The CParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CParameterInfo | Initializes a new instance of the CParameterInfo class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Inherited from NetParameterInfo.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CParameterInfo Constructor

CParameterInfo Constructor
Initializes a new instance of the CParameterInfo class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CParameterInfo()
Public Sub New
public:
CParameterInfo()
new : unit -> CParameterInfo
See Also

Reference

CParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CParameterInfo Methods

CParameterInfo Methods

The CParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Inherited from NetParameterInfo.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

CParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CParameterInfo.CreateListMember Method

CParameterInfoCreateListMember Method
Initializes a new instance of the CListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

CParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CParameterInfo Properties

CParameterInfo Properties

The CParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CParameterInfo Events

CParameterInfo Events

The CParameterInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CRepository Class

CRepository Class
Represents properties and methods to perform code completion functionality intended to use for Vb Script language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionNETRepository
Alternet.Syntax.CodeCompletionCRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CRepository : NETRepository
Public Class CRepository
    Inherits NETRepository
public ref class CRepository : public NETRepository
type CRepository =
    class
        inherit NETRepository
    end

The CRepository type exposes the following members.

Constructors
 | Name | Description
Public method | CRepository | Initializes a new instance of the CRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | (Overrides NETRepositoryFillMember(IListMembers, Object, String, CodeCompletionScope).)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | FindTypeDef |
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | (Overrides NETRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from NETRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from NETRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from NETRepository.)
Public method | GetXmlCommentTemplate | Returns xml comment template for given node in the text.
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
 | IsAnonymusStruct | Indicates whether specified node is anonymous structure node.
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
 | IsEmbeddedStruct | Indicates whether specified node is embedded structure node.
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
 | IsUnnamedStruct(String) | Indicates whether given type is unnamed structure.
 | IsUnnamedStruct(ISyntaxNode) | Indicates whether specified node is unnamed structure node.
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CRepository Constructor

CRepository Constructor
Initializes a new instance of the CRepository class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
CRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> CRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository Methods

CRepository Methods

The CRepository type exposes the following members.

Methods
 | Name | Description
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | (Overrides NETRepositoryFillMember(IListMembers, Object, String, CodeCompletionScope).)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | FindTypeDef |
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | (Overrides NETRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from NETRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from NETRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from NETRepository.)
Public method | GetXmlCommentTemplate | Returns xml comment template for given node in the text.
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
 | IsAnonymusStruct | Indicates whether specified node is anonymous structure node.
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
 | IsEmbeddedStruct | Indicates whether specified node is embedded structure node.
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
 | IsUnnamedStruct(String) | Indicates whether given type is unnamed structure.
 | IsUnnamedStruct(ISyntaxNode) | Indicates whether specified node is unnamed structure node.
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository.FillMember Method

CRepositoryFillMember Method
Overload List
 | Name | Description
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | (Overrides NETRepositoryFillMember(IListMembers, Object, String, CodeCompletionScope).)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Top
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository.FillMember Method (IListMembers, Object, String, CodeCompletionScope)

CRepositoryFillMember Method (IListMembers, Object, String, CodeCompletionScope)

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FillMember(
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope
)
Public Overrides Sub FillMember (
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope
)
public:
virtual void FillMember(
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope
) override
abstract FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope -> unit
override FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope -> unit

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
member
Type: SystemObject
name
Type: SystemString
scope
Type: Alternet.SyntaxCodeCompletionScope
See Also

Reference

CRepository Class
FillMember Overload
Alternet.Syntax.CodeCompletion Namespace


CRepository.FindTypeDef Method

CRepositoryFindTypeDef Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode FindTypeDef(
    ISyntaxNode node,
    ISyntaxNode refNode,
    Point position,
    ref int pointerType
)
Public Overridable Function FindTypeDef (
    node As ISyntaxNode,
    refNode As ISyntaxNode,
    position As Point,
    ByRef pointerType As Integer
) As ISyntaxNode
public:
virtual ISyntaxNode^ FindTypeDef(
    ISyntaxNode^ node,
    ISyntaxNode^ refNode,
    Point position,
    int% pointerType
)
abstract FindTypeDef :
        node : ISyntaxNode *
        refNode : ISyntaxNode *
        position : Point *
        pointerType : int byref -> ISyntaxNode
override FindTypeDef :
        node : ISyntaxNode *
        refNode : ISyntaxNode *
        position : Point *
        pointerType : int byref -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
refNode
Type: Alternet.SyntaxISyntaxNode
position
Type: System.DrawingPoint
pointerType
Type: SystemInt32

Return Value

Type: ISyntaxNode
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository.GetDescription Method

CRepositoryGetDescription Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDescription(
    IListMembers members,
    ISyntaxNode node,
    Object member,
    string name,
    bool fullDescription
)
Public Overrides Function GetDescription (
    members As IListMembers,
    node As ISyntaxNode,
    member As Object,
    name As String,
    fullDescription As Boolean
) As String
public:
virtual String^ GetDescription(
    IListMembers^ members,
    ISyntaxNode^ node,
    Object^ member,
    String^ name,
    bool fullDescription
) override
abstract GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string
override GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
node
Type: Alternet.SyntaxISyntaxNode
member
Type: SystemObject
name
Type: SystemString
fullDescription
Type: SystemBoolean

Return Value

Type: String

Implements

ICodeCompletionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean)
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository.GetXmlCommentTemplate Method

CRepositoryGetXmlCommentTemplate Method
Returns xml comment template for given node in the text.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetXmlCommentTemplate(
    Point position,
    ISyntaxNode node,
    string comment
)
Public Overridable Function GetXmlCommentTemplate (
    position As Point,
    node As ISyntaxNode,
    comment As String
) As String
public:
virtual String^ GetXmlCommentTemplate(
    Point position,
    ISyntaxNode^ node,
    String^ comment
)
abstract GetXmlCommentTemplate :
        position : Point *
        node : ISyntaxNode *
        comment : string -> string
override GetXmlCommentTemplate :
        position : Point *
        node : ISyntaxNode *
        comment : string -> string

Parameters

position
Type: System.DrawingPoint
Specifies position within the text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies node at given position.
comment
Type: SystemString
Specifies xml comment starting string.

Return Value

Type: String
Xml comment template.
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository.IsAnonymusStruct Method

CRepositoryIsAnonymusStruct Method
Indicates whether specified node is anonymous structure node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAnonymusStruct(
    ISyntaxNode node
)
Public Shared Function IsAnonymusStruct (
    node As ISyntaxNode
) As Boolean
public:
static bool IsAnonymusStruct(
    ISyntaxNode^ node
)
static member IsAnonymusStruct :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to check.

Return Value

Type: Boolean
True if node represents anonymous structure; otherwise false.
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository.IsEmbeddedStruct Method

CRepositoryIsEmbeddedStruct Method
Indicates whether specified node is embedded structure node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsEmbeddedStruct(
    ISyntaxNode node
)
Public Shared Function IsEmbeddedStruct (
    node As ISyntaxNode
) As Boolean
public:
static bool IsEmbeddedStruct(
    ISyntaxNode^ node
)
static member IsEmbeddedStruct :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to check.

Return Value

Type: Boolean
True if node is embedded structure; otherwise false.
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository.IsUnnamedStruct Method

CRepositoryIsUnnamedStruct Method
Overload List
Name | Description
IsUnnamedStruct(String) | Indicates whether given type is unnamed structure.
IsUnnamedStruct(ISyntaxNode) | Indicates whether specified node is unnamed structure node.
Top
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository.IsUnnamedStruct Method (String)

CRepositoryIsUnnamedStruct Method (String)
Indicates whether given type is unnamed structure.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUnnamedStruct(
    string type
)
Public Shared Function IsUnnamedStruct (
    type As String
) As Boolean
public:
static bool IsUnnamedStruct(
    String^ type
)
static member IsUnnamedStruct :
        type : string -> bool

Parameters

type
Type: SystemString
Type to check.

Return Value

Type: Boolean
True if type represents unnamed structure; otherwise false.
See Also

Reference

CRepository Class
IsUnnamedStruct Overload
Alternet.Syntax.CodeCompletion Namespace


CRepository.IsUnnamedStruct Method (ISyntaxNode)

CRepositoryIsUnnamedStruct Method (ISyntaxNode)
Indicates whether specified node is unnamed structure node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUnnamedStruct(
    ISyntaxNode node
)
Public Shared Function IsUnnamedStruct (
    node As ISyntaxNode
) As Boolean
public:
static bool IsUnnamedStruct(
    ISyntaxNode^ node
)
static member IsUnnamedStruct :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to check.

Return Value

Type: Boolean
True if node represents unnamed structure; otherwise false.
See Also

Reference

CRepository Class
IsUnnamedStruct Overload
Alternet.Syntax.CodeCompletion Namespace


CRepository Properties

CRepository Properties

The CRepository type exposes the following members.

Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CRepository Events

CRepository Events

The CRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

CRepository Class
Alternet.Syntax.CodeCompletion Namespace


CsListMember Class

CsListMember Class
Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.CodeCompletionCsListMember

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CsListMember : ListMember
Public Class CsListMember
    Inherits ListMember
public ref class CsListMember : public ListMember
type CsListMember =
    class
        inherit ListMember
    end

The CsListMember type exposes the following members.

Constructors
 | Name | Description
Public method | CsListMember | Initializes a new instance of the CsListMember class with default settings.
Public method | CsListMember(IListMembers, Boolean) | Initializes a new instance of the CsListMember class with specified owner. IListMembers owning this instanceBoolean value indicating that member should provide detailed description.
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Overrides ListMemberGetTemplate(Boolean).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBuiltInType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CsListMember Constructor

CsListMember Constructor
Overload List
 | Name | Description
Public method | CsListMember | Initializes a new instance of the CsListMember class with default settings.
Public method | CsListMember(IListMembers, Boolean) | Initializes a new instance of the CsListMember class with specified owner. IListMembers owning this instanceBoolean value indicating that member should provide detailed description.
Top
See Also

Reference

CsListMember Class
Alternet.Syntax.CodeCompletion Namespace


CsListMember Constructor

CsListMember Constructor
Initializes a new instance of the CsListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsListMember()
Public Sub New
public:
CsListMember()
new : unit -> CsListMember
See Also

Reference

CsListMember Class
CsListMember Overload
Alternet.Syntax.CodeCompletion Namespace


CsListMember Constructor (IListMembers, Boolean)

CsListMember Constructor (IListMembers, Boolean)
Initializes a new instance of the CsListMember class with specified owner. IListMembers owning this instanceBoolean value indicating that member should provide detailed description.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsListMember(
    IListMembers owner,
    bool fullDescription
)
Public Sub New (
    owner As IListMembers,
    fullDescription As Boolean
)
public:
CsListMember(
    IListMembers^ owner,
    bool fullDescription
)
new :
        owner : IListMembers *
        fullDescription : bool -> CsListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
fullDescription
Type: SystemBoolean
See Also

Reference

CsListMember Class
CsListMember Overload
Alternet.Syntax.CodeCompletion Namespace


CsListMember Methods

CsListMember Methods

The CsListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Overrides ListMemberGetTemplate(Boolean).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBuiltInType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CsListMember Class
Alternet.Syntax.CodeCompletion Namespace


CsListMember.GetParamText Method

CsListMemberGetParamText Method
Converts Parameters property to a single string.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetParamText(
    bool useFormatting
)
Public Overrides Function GetParamText (
    useFormatting As Boolean
) As String
public:
virtual String^ GetParamText(
    bool useFormatting
) override
abstract GetParamText :
        useFormatting : bool -> string
override GetParamText :
        useFormatting : bool -> string

Parameters

useFormatting
Type: SystemBoolean
Specifies whether to use html formatting tags.

Return Value

Type: String
Returns Parameters in the form of comma separated text, framed by parentheses.

Implements

IListMemberGetParamText(Boolean)
See Also

Reference

CsListMember Class
Alternet.Syntax.CodeCompletion Namespace


CsListMember.GetTemplate Method

CsListMemberGetTemplate Method
Return member's template.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetTemplate(
    bool compact
)
Public Overrides Function GetTemplate (
    compact As Boolean
) As String
public:
virtual String^ GetTemplate(
    bool compact
) override
abstract GetTemplate :
        compact : bool -> string
override GetTemplate :
        compact : bool -> string

Parameters

compact
Type: SystemBoolean
Indicates if template is in a compact form.

Return Value

Type: String
String value that represents member template.

Implements

IListMemberGetTemplate(Boolean)
See Also

Reference

CsListMember Class
Alternet.Syntax.CodeCompletion Namespace


CsListMember.IsBuiltInType Method

CsListMemberIsBuiltInType Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInType(
    string dataType
)
Public Shared Function IsBuiltInType (
    dataType As String
) As Boolean
public:
static bool IsBuiltInType(
    String^ dataType
)
static member IsBuiltInType :
        dataType : string -> bool

Parameters

dataType
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

CsListMember Class
Alternet.Syntax.CodeCompletion Namespace


CsListMember Properties

CsListMember Properties

The CsListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

CsListMember Class
Alternet.Syntax.CodeCompletion Namespace


CsListMember.Category Property

CsListMemberCategory Property

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionCategory Category { get; }
Public Overrides ReadOnly Property Category As CodeCompletionCategory
    Get
public:
virtual property CodeCompletionCategory^ Category {
    CodeCompletionCategory^ get () override;
}
abstract Category : CodeCompletionCategory with get
override Category : CodeCompletionCategory with get

Property Value

Type: CodeCompletionCategory

Implements

ICategorizedListMemberCategory
See Also

Reference

CsListMember Class
Alternet.Syntax.CodeCompletion Namespace


CsListMember.Description Property

CsListMemberDescription Property
Return member's description.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Return Value

Type: String
String value that describes the member.

Implements

IListMemberDescription
See Also

Reference

CsListMember Class
Alternet.Syntax.CodeCompletion Namespace


CsListMembers Class

CsListMembers Class
Represents data collection related to popup list box controls used to describe C# language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionNetListMembers
Alternet.Syntax.CodeCompletionCsListMembers

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CsListMembers : NetListMembers
Public Class CsListMembers
    Inherits NetListMembers
public ref class CsListMembers : public NetListMembers
type CsListMembers =
    class
        inherit NetListMembers
    end

The CsListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | CsListMembers | Initializes a new instance of the CsListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from NetListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CsListMembers Constructor

CsListMembers Constructor
Initializes a new instance of the CsListMembers class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsListMembers()
Public Sub New
public:
CsListMembers()
new : unit -> CsListMembers
See Also

Reference

CsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CsListMembers Methods

CsListMembers Methods

The CsListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from NetListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

CsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CsListMembers.CreateListMember Method

CsListMembersCreateListMember Method
Initializes a new instance of the CsListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

CsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CsListMembers Properties

CsListMembers Properties

The CsListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CsListMembers Events

CsListMembers Events

The CsListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


CsParameterInfo Class

CsParameterInfo Class
Represents Parameter Info data related to popup window and popup hint controls used to describe C# language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionParameterInfo
Alternet.Syntax.CodeCompletionNetParameterInfo
Alternet.Syntax.CodeCompletionCsParameterInfo

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CsParameterInfo : NetParameterInfo
Public Class CsParameterInfo
    Inherits NetParameterInfo
public ref class CsParameterInfo : public NetParameterInfo
type CsParameterInfo =
    class
        inherit NetParameterInfo
    end

The CsParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CsParameterInfo | Initializes a new instance of the CsParameterInfo class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Inherited from NetParameterInfo.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CsParameterInfo Constructor

CsParameterInfo Constructor
Initializes a new instance of the CsParameterInfo class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsParameterInfo()
Public Sub New
public:
CsParameterInfo()
new : unit -> CsParameterInfo
See Also

Reference

CsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CsParameterInfo Methods

CsParameterInfo Methods

The CsParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Inherited from NetParameterInfo.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

CsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CsParameterInfo.CreateListMember Method

CsParameterInfoCreateListMember Method
Initializes a new instance of the CsListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

CsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CsParameterInfo Properties

CsParameterInfo Properties

The CsParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CsParameterInfo Events

CsParameterInfo Events

The CsParameterInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

CsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


CsRepository Class

CsRepository Class
Represents properties and methods to perform code completion functionality intended to use for Cs language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionNETRepository
Alternet.Syntax.CodeCompletionReflectionRepository
Alternet.Syntax.CodeCompletionCsRepository
Alternet.Syntax.CodeCompletionJsRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CsRepository : ReflectionRepository
Public Class CsRepository
    Inherits ReflectionRepository
public ref class CsRepository : public ReflectionRepository
type CsRepository =
    class
        inherit ReflectionRepository
    end

The CsRepository type exposes the following members.

Constructors
 | Name | Description
Public method | CsRepository | Initializes a new instance of the CsRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Overrides CodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32).)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Overrides CodeCompletionRepositoryFindDeclaration(String, ISyntaxNode, Point).)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from ReflectionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Overrides NETRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


CsRepository Constructor

CsRepository Constructor
Initializes a new instance of the CsRepository class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
CsRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> CsRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

CsRepository Class
Alternet.Syntax.CodeCompletion Namespace


CsRepository Methods

CsRepository Methods

The CsRepository type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Overrides CodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32).)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Overrides CodeCompletionRepositoryFindDeclaration(String, ISyntaxNode, Point).)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from ReflectionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Overrides NETRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
See Also

Reference

CsRepository Class
Alternet.Syntax.CodeCompletion Namespace


CsRepository.FillMembers Method

CsRepositoryFillMembers Method
Fills list members provider with list of its member, providing available choices for the specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FillMembers(
    ISyntaxNode node,
    Point position,
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope,
    ref int selIndex
)
Public Overrides Sub FillMembers (
    node As ISyntaxNode,
    position As Point,
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope,
    ByRef selIndex As Integer
)
public:
virtual void FillMembers(
    ISyntaxNode^ node,
    Point position,
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope,
    int% selIndex
) override
abstract FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit
override FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
position
Type: System.DrawingPoint
Specifies position of language element in the text.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies filter used to fill members.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
selIndex
Type: SystemInt32
Specifies index of default list member.

Implements

ICodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32)
See Also

Reference

CsRepository Class
Alternet.Syntax.CodeCompletion Namespace


CsRepository.FindDeclaration Method

CsRepositoryFindDeclaration Method
Obtains information about where the language element is declared.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object FindDeclaration(
    string text,
    ISyntaxNode node,
    Point position
)
Public Overrides Function FindDeclaration (
    text As String,
    node As ISyntaxNode,
    position As Point
) As Object
public:
virtual Object^ FindDeclaration(
    String^ text,
    ISyntaxNode^ node,
    Point position
) override
abstract FindDeclaration :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object
override FindDeclaration :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object

Parameters

text
Type: SystemString
Specifies the source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies position of language element.

Return Value

Type: Object
ISyntaxNode representing declaration of the language element.

Implements

ICodeCompletionRepositoryFindDeclaration(String, ISyntaxNode, Point)
See Also

Reference

CsRepository Class
Alternet.Syntax.CodeCompletion Namespace


CsRepository.GetSpecialMemberType Method

CsRepositoryGetSpecialMemberType Method
Obtains information about a member of some language element in special cases.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetSpecialMemberType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out CodeCompletionScope scope
)
Public Overrides Function GetSpecialMemberType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetSpecialMemberType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] CodeCompletionScope% scope
) override
abstract GetSpecialMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object
override GetSpecialMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Text at specified position.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
name
Type: SystemString
Specifies name of the member to locate.
position
Type: System.DrawingPoint
Specifies position of language element.
endPos
Type: System.DrawingPoint
Specifies end position of found language element in the code text and updates it if needed.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for this language element.

Return Value

Type: Object
Object representing information about found member.

Implements

ICodeCompletionRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
See Also

Reference

CsRepository Class
Alternet.Syntax.CodeCompletion Namespace


CsRepository Properties

CsRepository Properties

The CsRepository type exposes the following members.

Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
See Also

Reference

CsRepository Class
Alternet.Syntax.CodeCompletion Namespace


CsRepository Events

CsRepository Events

The CsRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

CsRepository Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper Class

DescriptionHelper Class
Provides methods to get member's description.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionDescriptionHelper

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DescriptionHelper
Public Class DescriptionHelper
public ref class DescriptionHelper
type DescriptionHelper =  class end

The DescriptionHelper type exposes the following members.

Constructors
 | Name | Description
Public method | DescriptionHelper | Initializes a new instance of the DescriptionHelper class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetDescription(MemberInfo) | Obtains description of the specified MemberInfo.
 | GetDescription(ParameterInfo) | Obtains description of the specified ParameterInfo.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPriority | Obtains priority of the specified MemberInfo.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAssembly(Assembly) | Loads content of the specified assembly.
 | LoadAssembly(Assembly, Stream) | Loads content of the specified assembly.
 | LookupLocalizedXmlDoc |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadAssembly | Removes the specified assembly from the assembly collection.
Top
Properties
Name | Description
CustomXMLDocPath | Gets a custom xml documentation path.
Enabled | Gets or sets a boolean value indicating whether DescriptionHelper should obtain descriptions from assemblies.
SystemAssemblyFolders | Represents directory information where system assembly stored.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper Constructor

DescriptionHelper Constructor
Initializes a new instance of the DescriptionHelper class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DescriptionHelper()
Public Sub New
public:
DescriptionHelper()
new : unit -> DescriptionHelper
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper Methods

DescriptionHelper Methods

The DescriptionHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetDescription(MemberInfo) | Obtains description of the specified MemberInfo.
 | GetDescription(ParameterInfo) | Obtains description of the specified ParameterInfo.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPriority | Obtains priority of the specified MemberInfo.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAssembly(Assembly) | Loads content of the specified assembly.
 | LoadAssembly(Assembly, Stream) | Loads content of the specified assembly.
 | LookupLocalizedXmlDoc |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadAssembly | Removes the specified assembly from the assembly collection.
Top
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.GetDescription Method

DescriptionHelperGetDescription Method
Overload List
Name | Description
GetDescription(MemberInfo) | Obtains description of the specified MemberInfo.
GetDescription(ParameterInfo) | Obtains description of the specified ParameterInfo.
Top
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.GetDescription Method (MemberInfo)

DescriptionHelperGetDescription Method (MemberInfo)
Obtains description of the specified MemberInfo.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDescription(
    MemberInfo info
)
Public Shared Function GetDescription (
    info As MemberInfo
) As String
public:
static String^ GetDescription(
    MemberInfo^ info
)
static member GetDescription :
        info : MemberInfo -> string

Parameters

info
Type: System.ReflectionMemberInfo
MemberInfo to evaluate.

Return Value

Type: String
String that describes specified MemberInfo.
See Also

Reference

DescriptionHelper Class
GetDescription Overload
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.GetDescription Method (ParameterInfo)

DescriptionHelperGetDescription Method (ParameterInfo)
Obtains description of the specified ParameterInfo.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDescription(
    ParameterInfo pinfo
)
Public Shared Function GetDescription (
    pinfo As ParameterInfo
) As String
public:
static String^ GetDescription(
    ParameterInfo^ pinfo
)
static member GetDescription :
        pinfo : ParameterInfo -> string

Parameters

pinfo
Type: System.ReflectionParameterInfo
ParameterInfo to evaluate.

Return Value

Type: String
String that describes specified ParameterInfo.
See Also

Reference

DescriptionHelper Class
GetDescription Overload
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.GetPriority Method

DescriptionHelperGetPriority Method
Obtains priority of the specified MemberInfo.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetPriority(
    MemberInfo info
)
Public Shared Function GetPriority (
    info As MemberInfo
) As Integer
public:
static int GetPriority(
    MemberInfo^ info
)
static member GetPriority :
        info : MemberInfo -> int

Parameters

info
Type: System.ReflectionMemberInfo
MemberInfo to evaluate.

Return Value

Type: Int32
Integer value that specifies priority of given MemberInfo.
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.LoadAssembly Method

DescriptionHelperLoadAssembly Method
Overload List
Name | Description
LoadAssembly(Assembly) | Loads content of the specified assembly.
LoadAssembly(Assembly, Stream) | Loads content of the specified assembly.
Top
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.LoadAssembly Method (Assembly)

DescriptionHelperLoadAssembly Method (Assembly)
Loads content of the specified assembly.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DescriptionInfo LoadAssembly(
    Assembly assembly
)
Public Shared Function LoadAssembly (
    assembly As Assembly
) As DescriptionInfo
public:
static DescriptionInfo^ LoadAssembly(
    Assembly^ assembly
)
static member LoadAssembly :
        assembly : Assembly -> DescriptionInfo

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to load.

Return Value

Type: DescriptionInfo
True if succeed; otherwise false.
See Also

Reference

DescriptionHelper Class
LoadAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.LoadAssembly Method (Assembly, Stream)

DescriptionHelperLoadAssembly Method (Assembly, Stream)
Loads content of the specified assembly.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void LoadAssembly(
    Assembly assembly,
    Stream stream
)
Public Shared Sub LoadAssembly (
    assembly As Assembly,
    stream As Stream
)
public:
static void LoadAssembly(
    Assembly^ assembly,
    Stream^ stream
)
static member LoadAssembly :
        assembly : Assembly *
        stream : Stream -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to load.
stream
Type: System.IOStream
The location of the XML file.

Return Value

Type:
True if succeed; otherwise false.
See Also

Reference

DescriptionHelper Class
LoadAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.LookupLocalizedXmlDoc Method

DescriptionHelperLookupLocalizedXmlDoc Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LookupLocalizedXmlDoc(
    string fileName
)
Public Shared Function LookupLocalizedXmlDoc (
    fileName As String
) As String
public:
static String^ LookupLocalizedXmlDoc(
    String^ fileName
)
static member LookupLocalizedXmlDoc :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.UnloadAssembly Method

DescriptionHelperUnloadAssembly Method
Removes the specified assembly from the assembly collection.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnloadAssembly(
    Assembly assembly
)
Public Shared Sub UnloadAssembly (
    assembly As Assembly
)
public:
static void UnloadAssembly(
    Assembly^ assembly
)
static member UnloadAssembly :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to unload.
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper Properties

DescriptionHelper Properties

The DescriptionHelper type exposes the following members.

Properties
Name | Description
CustomXMLDocPath | Gets a custom xml documentation path.
Enabled | Gets or sets a boolean value indicating whether DescriptionHelper should obtain descriptions from assemblies.
SystemAssemblyFolders | Represents directory information where system assembly stored.
Top
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.CustomXMLDocPath Property

DescriptionHelperCustomXMLDocPath Property
Gets a custom xml documentation path.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CustomXMLDocPath { get; set; }
Public Shared Property CustomXMLDocPath As String
    Get
    Set
public:
static property String^ CustomXMLDocPath {
    String^ get ();
    void set (String^ value);
}
static member CustomXMLDocPath : string with get, set

Property Value

Type: String
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.Enabled Property

DescriptionHelperEnabled Property
Gets or sets a boolean value indicating whether DescriptionHelper should obtain descriptions from assemblies.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Enabled { get; set; }
Public Shared Property Enabled As Boolean
    Get
    Set
public:
static property bool Enabled {
    bool get ();
    void set (bool value);
}
static member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


DescriptionHelper.SystemAssemblyFolders Property

DescriptionHelperSystemAssemblyFolders Property
Represents directory information where system assembly stored.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> SystemAssemblyFolders { get; }
Public Shared ReadOnly Property SystemAssemblyFolders As IList(Of String)
    Get
public:
static property IList<String^>^ SystemAssemblyFolders {
    IList<String^>^ get ();
}
static member SystemAssemblyFolders : IList<string> with get

Property Value

Type: IListString
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.CodeCompletion Namespace


IBraceInfo Interface

IBraceInfo Interface
Represents simple text data related to popup hint.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBraceInfo : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>,
    IEnumerable, IExport, IImport
Public Interface IBraceInfo
    Inherits ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem), ICollection(Of ICodeCompletionProviderItem),
    IEnumerable(Of ICodeCompletionProviderItem), IEnumerable, IExport, IImport
public interface class IBraceInfo : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>,
    IEnumerable, IExport, IImport
type IBraceInfo =
    interface
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The IBraceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Brace | When implemented by a class, gets or sets content of the IQuickInfo.
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IBraceInfo Methods

IBraceInfo Methods

The IBraceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IBraceInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IBraceInfo Properties

IBraceInfo Properties

The IBraceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Brace | When implemented by a class, gets or sets content of the IQuickInfo.
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

IBraceInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IBraceInfo.Brace Property

IBraceInfoBrace Property
When implemented by a class, gets or sets content of the IQuickInfo.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Brace { get; set; }
Property Brace As String
    Get
    Set
property String^ Brace {
    String^ get ();
    void set (String^ value);
}
abstract Brace : string with get, set

Property Value

Type: String
See Also

Reference

IBraceInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IBraceInfo Events

IBraceInfo Events

The IBraceInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

IBraceInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IBraceInfoItem Interface

IBraceInfoItem Interface
Stores simple text data related to popup hint.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IBraceInfoItem : ICodeCompletionProviderItem,
    IComparable
Public Interface IBraceInfoItem
    Inherits ICodeCompletionProviderItem, IComparable
public interface class IBraceInfoItem : ICodeCompletionProviderItem,
    IComparable
type IBraceInfoItem =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The IBraceInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | Brace | When implemented by a class, gets or sets content of the CommentInfoItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IBraceInfoItem Methods

IBraceInfoItem Methods

The IBraceInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

IBraceInfoItem Interface
Alternet.Syntax.CodeCompletion Namespace


IBraceInfoItem Properties

IBraceInfoItem Properties

The IBraceInfoItem type exposes the following members.

Properties
 | Name | Description
Public property | Brace | When implemented by a class, gets or sets content of the CommentInfoItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

IBraceInfoItem Interface
Alternet.Syntax.CodeCompletion Namespace


IBraceInfoItem.Brace Property

IBraceInfoItemBrace Property
When implemented by a class, gets or sets content of the CommentInfoItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Brace { get; set; }
Property Brace As String
    Get
    Set
property String^ Brace {
    String^ get ();
    void set (String^ value);
}
abstract Brace : string with get, set

Property Value

Type: String
See Also

Reference

IBraceInfoItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICategorizedCodeCompletionProvider Interface

ICategorizedCodeCompletionProvider Interface
Represents a ICodeCompletionProvider that contains categories.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICategorizedCodeCompletionProvider : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>,
    IEnumerable, IExport, IImport
Public Interface ICategorizedCodeCompletionProvider
    Inherits ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem), ICollection(Of ICodeCompletionProviderItem),
    IEnumerable(Of ICodeCompletionProviderItem), IEnumerable, IExport, IImport
public interface class ICategorizedCodeCompletionProvider : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>,
    IEnumerable, IExport, IImport
type ICategorizedCodeCompletionProvider =
    interface
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The ICategorizedCodeCompletionProvider type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetAvailableCategories | When implemented by a class, returns list of all available categories.
Public method | GetCategory | When implemented by a class, gets a category by its index.
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICategorizedCodeCompletionProvider Methods

ICategorizedCodeCompletionProvider Methods

The ICategorizedCodeCompletionProvider type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetAvailableCategories | When implemented by a class, returns list of all available categories.
Public method | GetCategory | When implemented by a class, gets a category by its index.
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICategorizedCodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICategorizedCodeCompletionProvider.GetAvailableCategories Method

ICategorizedCodeCompletionProviderGetAvailableCategories Method
When implemented by a class, returns list of all available categories.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<CodeCompletionCategory> GetAvailableCategories()
Function GetAvailableCategories As IEnumerable(Of CodeCompletionCategory)
IEnumerable<CodeCompletionCategory^>^ GetAvailableCategories()
abstract GetAvailableCategories : unit -> IEnumerable<CodeCompletionCategory>

Return Value

Type: IEnumerableCodeCompletionCategory
List of all possible CodeCompletionCategory objects.
See Also

Reference

ICategorizedCodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICategorizedCodeCompletionProvider.GetCategory Method

ICategorizedCodeCompletionProviderGetCategory Method
When implemented by a class, gets a category by its index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
CodeCompletionCategory GetCategory(
    int index
)
Function GetCategory (
    index As Integer
) As CodeCompletionCategory
CodeCompletionCategory^ GetCategory(
    int index
)
abstract GetCategory :
        index : int -> CodeCompletionCategory

Parameters

index
Type: SystemInt32
Index of the item in the categories collection.

Return Value

Type: CodeCompletionCategory
CodeCompletionCategory by its index.
See Also

Reference

ICategorizedCodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICategorizedCodeCompletionProvider Properties

ICategorizedCodeCompletionProvider Properties

The ICategorizedCodeCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICategorizedCodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICategorizedCodeCompletionProvider Events

ICategorizedCodeCompletionProvider Events

The ICategorizedCodeCompletionProvider type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICategorizedCodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICategorizedListMember Interface

ICategorizedListMember Interface
Represents a list member contains category information like Class, Filed and so on.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICategorizedListMember : IListMember,
    ICodeCompletionProviderItem, IComparable
Public Interface ICategorizedListMember
    Inherits IListMember, ICodeCompletionProviderItem, IComparable
public interface class ICategorizedListMember : IListMember,
    ICodeCompletionProviderItem, IComparable
type ICategorizedListMember =
    interface
        interface IListMember
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICategorizedListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | When implemented by a class, appends text to the member description. (Inherited from IListMember.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | GetParamText | When implemented by a class, converts Parameters property to a single string. (Inherited from IListMember.)
Public method | GetTemplate | When implemented by a class, return member's template. (Inherited from IListMember.)
Top
Properties
 | Name | Description
Public property | Attributes | When implemented by a class, gets or sets additional attributes associated with a member. (Inherited from IListMember.)
Public property | Category | When implemented by a class, gets or sets CodeCompletionCategory to which this IListMember belongs.
Public property | CurrentParamIndex | When implemented by a class, gets or sets index of current parameter in the parameters collection. (Inherited from IListMember.)
Public property | CustomData | When implemented by a class, gets or sets an object that can hold a user defined data attached to the IListMember. (Inherited from IListMember.)
Public property | DataType | When implemented by a class, gets or sets a string value that specifies data type of the IListMember. (Inherited from IListMember.)
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of the IListMember. (Inherited from IListMember.)
Public property | DisplayText | When implemented by a class, gets or sets a string value displayed as a "name" part of IListMember. (Inherited from IListMember.)
Public property | Image | When implemented by a class, gets or sets the image displayed for the IListMember. (Inherited from IListMember.)
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the IListMember. (Inherited from IListMember.)
Public property | InsertText | When implemented by a class, gets or sets a string value inserted in the text editor when IListMember is selected. (Inherited from IListMember.)
Public property | MemberType | When implemented by a class, gets or sets the integer value representing type of the member. (Inherited from IListMember.)
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the IListMember collection. (Inherited from IListMember.)
Public property | Overloads | When implemented by a class, gets or sets number of overloading members IListMember in the collection. (Inherited from IListMember.)
Public property | Owner | When implemented by a class, gets IListMembers instance owning the ListMember. (Inherited from IListMember.)
Public property | Parameters | When implemented by a class, gets or sets a collection of parameters of this IListMember. (Inherited from IListMember.)
Public property | ParamText | When implemented by a class, gets or sets a string value that specifies comma separated list of parameters of the IListMember. (Inherited from IListMember.)
Public property | Priority | When implemented by a class, gets or sets priority of the ListMember. (Inherited from IListMember.)
Public property | Qualifier | When implemented by a class, gets or sets a string value that specifies access modifiers of the IListMember. (Inherited from IListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICategorizedListMember Methods

ICategorizedListMember Methods

The ICategorizedListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | When implemented by a class, appends text to the member description. (Inherited from IListMember.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | GetParamText | When implemented by a class, converts Parameters property to a single string. (Inherited from IListMember.)
Public method | GetTemplate | When implemented by a class, return member's template. (Inherited from IListMember.)
Top
See Also

Reference

ICategorizedListMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICategorizedListMember Properties

ICategorizedListMember Properties

The ICategorizedListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | When implemented by a class, gets or sets additional attributes associated with a member. (Inherited from IListMember.)
Public property | Category | When implemented by a class, gets or sets CodeCompletionCategory to which this IListMember belongs.
Public property | CurrentParamIndex | When implemented by a class, gets or sets index of current parameter in the parameters collection. (Inherited from IListMember.)
Public property | CustomData | When implemented by a class, gets or sets an object that can hold a user defined data attached to the IListMember. (Inherited from IListMember.)
Public property | DataType | When implemented by a class, gets or sets a string value that specifies data type of the IListMember. (Inherited from IListMember.)
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of the IListMember. (Inherited from IListMember.)
Public property | DisplayText | When implemented by a class, gets or sets a string value displayed as a "name" part of IListMember. (Inherited from IListMember.)
Public property | Image | When implemented by a class, gets or sets the image displayed for the IListMember. (Inherited from IListMember.)
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the IListMember. (Inherited from IListMember.)
Public property | InsertText | When implemented by a class, gets or sets a string value inserted in the text editor when IListMember is selected. (Inherited from IListMember.)
Public property | MemberType | When implemented by a class, gets or sets the integer value representing type of the member. (Inherited from IListMember.)
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the IListMember collection. (Inherited from IListMember.)
Public property | Overloads | When implemented by a class, gets or sets number of overloading members IListMember in the collection. (Inherited from IListMember.)
Public property | Owner | When implemented by a class, gets IListMembers instance owning the ListMember. (Inherited from IListMember.)
Public property | Parameters | When implemented by a class, gets or sets a collection of parameters of this IListMember. (Inherited from IListMember.)
Public property | ParamText | When implemented by a class, gets or sets a string value that specifies comma separated list of parameters of the IListMember. (Inherited from IListMember.)
Public property | Priority | When implemented by a class, gets or sets priority of the ListMember. (Inherited from IListMember.)
Public property | Qualifier | When implemented by a class, gets or sets a string value that specifies access modifiers of the IListMember. (Inherited from IListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

ICategorizedListMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICategorizedListMember.Category Property

ICategorizedListMemberCategory Property
When implemented by a class, gets or sets CodeCompletionCategory to which this IListMember belongs.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
CodeCompletionCategory Category { get; set; }
Property Category As CodeCompletionCategory
    Get
    Set
property CodeCompletionCategory^ Category {
    CodeCompletionCategory^ get ();
    void set (CodeCompletionCategory^ value);
}
abstract Category : CodeCompletionCategory with get, set

Property Value

Type: CodeCompletionCategory
See Also

Reference

ICategorizedListMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider Interface

ICodeCompletionProvider Interface
Represents properties and methods to provide data related to Code Completion popup listbox and popup hint controls.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionProvider : IList<ICodeCompletionProviderItem>,
    ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>, IEnumerable,
    IExport, IImport
Public Interface ICodeCompletionProvider
    Inherits IList(Of ICodeCompletionProviderItem), ICollection(Of ICodeCompletionProviderItem),
    IEnumerable(Of ICodeCompletionProviderItem), IEnumerable, IExport, IImport
public interface class ICodeCompletionProvider : IList<ICodeCompletionProviderItem^>,
    ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>, IEnumerable,
    IExport, IImport
type ICodeCompletionProvider =
    interface
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The ICodeCompletionProvider type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required.
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible.
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column.
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection.
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item.
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index.
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index.
Public method | GetInsertText | When implemented by a class, returns string to be inserted.
Public method | GetName | When implemented by a class, returns string representing name of the item.
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance.
Public method | GetPriority | When implemented by a class, returns priority of the item.
Public method | GetText | When implemented by a class, returns string representing default column.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event.
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list.
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column.
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider.
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider.
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected.
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text.
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column.
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items.
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI.
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name.
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted.
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control.
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control.
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column.
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text.
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control.
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed.
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider Methods

ICodeCompletionProvider Methods

The ICodeCompletionProvider type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required.
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible.
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column.
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection.
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item.
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index.
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index.
Public method | GetInsertText | When implemented by a class, returns string to be inserted.
Public method | GetName | When implemented by a class, returns string representing name of the item.
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance.
Public method | GetPriority | When implemented by a class, returns priority of the item.
Public method | GetText | When implemented by a class, returns string representing default column.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event.
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list.
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer.
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.ColumnSpace Method

ICodeCompletionProviderColumnSpace Method
When implemented by a class, indicates whether after specified column SPACE is required.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ColumnSpace(
    int column
)
Function ColumnSpace (
    column As Integer
) As Boolean
bool ColumnSpace(
    int column
)
abstract ColumnSpace :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if should; otherwise false.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.ColumnVisible Method

ICodeCompletionProviderColumnVisible Method
When implemented by a class, indicates whether specified column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ColumnVisible(
    int column
)
Function ColumnVisible (
    column As Integer
) As Boolean
bool ColumnVisible(
    int column
)
abstract ColumnVisible :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if visible; otherwise false.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetColumnText Method

ICodeCompletionProviderGetColumnText Method
When implemented by a class, returns text from given item in the specified column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetColumnText(
    int index,
    int column
)
Function GetColumnText (
    index As Integer,
    column As Integer
) As String
String^ GetColumnText(
    int index,
    int column
)
abstract GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
Specifies index of item.
column
Type: SystemInt32
Specifies index of column.

Return Value

Type: String
Text representing specified item.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetDescription Method

ICodeCompletionProviderGetDescription Method
When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetDescription(
    int index
)
Function GetDescription (
    index As Integer
) As String
String^ GetDescription(
    int index
)
abstract GetDescription :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of the item within the collection.

Return Value

Type: String
String content of specified column.
Remarks
In this class method always return empty string. Descendant classes can override this method.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetDisplayText Method

ICodeCompletionProviderGetDisplayText Method
When implemented by a class, returns string representing the display text of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetDisplayText(
    int index
)
Function GetDisplayText (
    index As Integer
) As String
String^ GetDisplayText(
    int index
)
abstract GetDisplayText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing display text of specified item.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetFullDisplayText Method

ICodeCompletionProviderGetFullDisplayText Method
When implemented by a class, returns string representing full text of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetFullDisplayText(
    int index
)
Function GetFullDisplayText (
    index As Integer
) As String
String^ GetFullDisplayText(
    int index
)
abstract GetFullDisplayText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing full display text of specified item.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetImage Method

ICodeCompletionProviderGetImage Method
When implemented by a class, returns number of image that is displayed for item given by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Image GetImage(
    int index
)
Function GetImage (
    index As Integer
) As Image
Image^ GetImage(
    int index
)
abstract GetImage :
        index : int -> Image

Parameters

index
Type: SystemInt32
Index of image within collection.

Return Value

Type: Image
Image corresponding to given item.
Remarks
In this class method always return -1. Descendant classes can override this method.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetImageIndex Method

ICodeCompletionProviderGetImageIndex Method
When implemented by a class, returns number of image that is displayed for item given by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetImageIndex(
    int index
)
Function GetImageIndex (
    index As Integer
) As Integer
int GetImageIndex(
    int index
)
abstract GetImageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: Int32
Index of image corresponding to given item.
Remarks
In this class method always return -1. Descendant classes can override this method.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetInsertText Method

ICodeCompletionProviderGetInsertText Method
When implemented by a class, returns string to be inserted.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetInsertText(
    int index
)
Function GetInsertText (
    index As Integer
) As String
String^ GetInsertText(
    int index
)
abstract GetInsertText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
Text to be inserted.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetName Method

ICodeCompletionProviderGetName Method
When implemented by a class, returns string representing name of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetName(
    int index
)
Function GetName (
    index As Integer
) As String
String^ GetName(
    int index
)
abstract GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing name of specified item.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetParent Method

ICodeCompletionProviderGetParent Method
When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeCompletionProvider GetParent()
Function GetParent As ICodeCompletionProvider
ICodeCompletionProvider^ GetParent()
abstract GetParent : unit -> ICodeCompletionProvider

Return Value

Type: ICodeCompletionProvider
Parent of the ICodeCompletionProvider.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetPriority Method

ICodeCompletionProviderGetPriority Method
When implemented by a class, returns priority of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPriority(
    int index
)
Function GetPriority (
    index As Integer
) As Integer
int GetPriority(
    int index
)
abstract GetPriority :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: Int32
Integer representing priority of specified item.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.GetText Method

ICodeCompletionProviderGetText Method
When implemented by a class, returns string representing default column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetText(
    int index
)
Function GetText (
    index As Integer
) As String
String^ GetText(
    int index
)
abstract GetText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
Text representing default column.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.IndexOfName Method

ICodeCompletionProviderIndexOfName Method
When implemented by a class, returns index of item within collection by it's name.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int IndexOfName(
    string name,
    bool caseSensitive
)
Function IndexOfName (
    name As String,
    caseSensitive As Boolean
) As Integer
int IndexOfName(
    String^ name,
    bool caseSensitive
)
abstract IndexOfName :
        name : string *
        caseSensitive : bool -> int

Parameters

name
Type: SystemString
Specifies Name property of item to find.
caseSensitive
Type: SystemBoolean
Indicates whether search should be case sensitive.

Return Value

Type: Int32
Index of found item.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.OnClosePopup Method

ICodeCompletionProviderOnClosePopup Method
When implemented by a class, raises ClosePopup event.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnClosePopup(
    Object sender,
    ClosingEventArgs e
)
Sub OnClosePopup (
    sender As Object,
    e As ClosingEventArgs
)
void OnClosePopup(
    Object^ sender,
    ClosingEventArgs^ e
)
abstract OnClosePopup :
        sender : Object *
        e : ClosingEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxClosingEventArgs
A ClosingEventArgs that contains the event data.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.OnShowPopup Method

ICodeCompletionProviderOnShowPopup Method
When implemented by a class, raises ShowPopup event.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnShowPopup(
    Object sender,
    ShowingEventArgs e
)
Sub OnShowPopup (
    sender As Object,
    e As ShowingEventArgs
)
void OnShowPopup(
    Object^ sender,
    ShowingEventArgs^ e
)
abstract OnShowPopup :
        sender : Object *
        e : ShowingEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.SyntaxShowingEventArgs
A ShowingEventArgs that contains the event data.
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.Sort Method

ICodeCompletionProviderSort Method
Overload List
 | Name | Description
Public method | Sort | When implemented by a class, sorts elements in the list.
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer.
Top
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.Sort Method

ICodeCompletionProviderSort Method
When implemented by a class, sorts elements in the list.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Sort()
Sub Sort
void Sort()
abstract Sort : unit -> unit
See Also

Reference

ICodeCompletionProvider Interface
Sort Overload
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.Sort Method (IComparer(ICodeCompletionProviderItem))

ICodeCompletionProviderSort Method (IComparerICodeCompletionProviderItem)
When implemented by a class, sorts elements in the list using the specified comparer.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Sort(
    IComparer<ICodeCompletionProviderItem> comparer
)
Sub Sort (
    comparer As IComparer(Of ICodeCompletionProviderItem)
)
void Sort(
    IComparer<ICodeCompletionProviderItem^>^ comparer
)
abstract Sort :
        comparer : IComparer<ICodeCompletionProviderItem> -> unit

Parameters

comparer
Type: System.Collections.GenericIComparerICodeCompletionProviderItem
The IComparer implementation to use when comparing elements.
See Also

Reference

ICodeCompletionProvider Interface
Sort Overload
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider Properties

ICodeCompletionProvider Properties

The ICodeCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column.
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider.
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider.
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected.
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text.
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column.
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items.
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI.
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name.
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted.
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control.
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control.
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column.
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text.
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control.
Top
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.ColumnCount Property

ICodeCompletionProviderColumnCount Property
When implemented by a class, represents number of the columns.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ColumnCount { get; }
ReadOnly Property ColumnCount As Integer
    Get
property int ColumnCount {
    int get ();
}
abstract ColumnCount : int with get

Property Value

Type: Int32
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.Descriptions Property

ICodeCompletionProviderDescriptions Property
When implemented by a class, provides an indexed access to the description of each column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] Descriptions { get; }
ReadOnly Property Descriptions As String()
    Get
property array<String^>^ Descriptions {
    array<String^>^ get ();
}
abstract Descriptions : string[] with get

Property Value

Type: String
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.EditField Property

ICodeCompletionProviderEditField Property
When implemented by a class, gets or sets a value indicating editable field of the code completion provider.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string EditField { get; set; }
Property EditField As String
    Get
    Set
property String^ EditField {
    String^ get ();
    void set (String^ value);
}
abstract EditField : string with get, set

Property Value

Type: String
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.EditPath Property

ICodeCompletionProviderEditPath Property
When implemented by a class, gets or sets a value indicating path to the nested code completion provider.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string EditPath { get; }
ReadOnly Property EditPath As String
    Get
property String^ EditPath {
    String^ get ();
}
abstract EditPath : string with get

Property Value

Type: String
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.FocusMode Property

ICodeCompletionProviderFocusMode Property
When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ItemFocusMode FocusMode { get; set; }
Property FocusMode As ItemFocusMode
    Get
    Set
property ItemFocusMode FocusMode {
    ItemFocusMode get ();
    void set (ItemFocusMode value);
}
abstract FocusMode : ItemFocusMode with get, set

Property Value

Type: ItemFocusMode
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.FormatDisplayText Property

ICodeCompletionProviderFormatDisplayText Property
When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FormatDisplayText { get; }
ReadOnly Property FormatDisplayText As Boolean
    Get
property bool FormatDisplayText {
    bool get ();
}
abstract FormatDisplayText : bool with get

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.ImageIndexes Property

ICodeCompletionProviderImageIndexes Property
When implemented by a class, provides an indexed access to the image index of each column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int[] ImageIndexes { get; }
ReadOnly Property ImageIndexes As Integer()
    Get
property array<int>^ ImageIndexes {
    array<int>^ get ();
}
abstract ImageIndexes : int[] with get

Property Value

Type: Int32
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.Images Property

ICodeCompletionProviderImages Property
When implemented by a class, gets or sets the ImageList for code completion items.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList Images { get; set; }
Property Images As ImageList
    Get
    Set
property ImageList^ Images {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract Images : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.ImagesHighDpi Property

ICodeCompletionProviderImagesHighDpi Property
When implemented by a class, gets or sets the ImageList for code completion items for high DPI.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList ImagesHighDpi { get; set; }
Property ImagesHighDpi As ImageList
    Get
    Set
property ImageList^ ImagesHighDpi {
    ImageList^ get ();
    void set (ImageList^ value);
}
abstract ImagesHighDpi : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.InvokeChar Property

ICodeCompletionProviderInvokeChar Property
When implemented by a class, specifies a character that triggered code completion invocation

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<char> InvokeChar { get; set; }
Property InvokeChar As Nullable(Of Char)
    Get
    Set
property Nullable<wchar_t> InvokeChar {
    Nullable<wchar_t> get ();
    void set (Nullable<wchar_t> value);
}
abstract InvokeChar : Nullable<char> with get, set

Property Value

Type: NullableChar
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.NameColumnIndex Property

ICodeCompletionProviderNameColumnIndex Property
When implemented by a class, gets index of the column containing name.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Nullable<int> NameColumnIndex { get; }
ReadOnly Property NameColumnIndex As Nullable(Of Integer)
    Get
property Nullable<int> NameColumnIndex {
    Nullable<int> get ();
}
abstract NameColumnIndex : Nullable<int> with get

Property Value

Type: NullableInt32
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.NeedSort Property

ICodeCompletionProviderNeedSort Property
When implemented by a class, specifies if provider content needs to be sorted.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool NeedSort { get; }
ReadOnly Property NeedSort As Boolean
    Get
property bool NeedSort {
    bool get ();
}
abstract NeedSort : bool with get

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.SelIndex Property

ICodeCompletionProviderSelIndex Property
When implemented by a class, represents the index specifying the currently selected item of the popup control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int SelIndex { get; set; }
Property SelIndex As Integer
    Get
    Set
property int SelIndex {
    int get ();
    void set (int value);
}
abstract SelIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.ShowDescriptions Property

ICodeCompletionProviderShowDescriptions Property
When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowDescriptions { get; set; }
Property ShowDescriptions As Boolean
    Get
    Set
property bool ShowDescriptions {
    bool get ();
    void set (bool value);
}
abstract ShowDescriptions : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.Strings Property

ICodeCompletionProviderStrings Property
When implemented by a class, provides an indexed access to the text of default column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] Strings { get; }
ReadOnly Property Strings As String()
    Get
property array<String^>^ Strings {
    array<String^>^ get ();
}
abstract Strings : string[] with get

Property Value

Type: String
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.UseHtmlFormatting Property

ICodeCompletionProviderUseHtmlFormatting Property
When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseHtmlFormatting { get; set; }
Property UseHtmlFormatting As Boolean
    Get
    Set
property bool UseHtmlFormatting {
    bool get ();
    void set (bool value);
}
abstract UseHtmlFormatting : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.UseIndent Property

ICodeCompletionProviderUseIndent Property
When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UseIndent { get; set; }
Property UseIndent As Boolean
    Get
    Set
property bool UseIndent {
    bool get ();
    void set (bool value);
}
abstract UseIndent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider Events

ICodeCompletionProvider Events

The ICodeCompletionProvider type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed.
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed.
Top
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.ClosePopup Event

ICodeCompletionProviderClosePopup Event
When implemented by a class, occurs when popup control is closed.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event ClosePopupEvent ClosePopup
Event ClosePopup As ClosePopupEvent
 event ClosePopupEvent^ ClosePopup {
    void add (ClosePopupEvent^ value);
    void remove (ClosePopupEvent^ value);
}
abstract ClosePopup : IEvent<ClosePopupEvent,
    ClosingEventArgs>

Value

Type: Alternet.SyntaxClosePopupEvent
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProvider.ShowPopup Event

ICodeCompletionProviderShowPopup Event
When implemented by a class, occurs when popup control is displayed.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event ShowPopupEvent ShowPopup
Event ShowPopup As ShowPopupEvent
 event ShowPopupEvent^ ShowPopup {
    void add (ShowPopupEvent^ value);
    void remove (ShowPopupEvent^ value);
}
abstract ShowPopup : IEvent<ShowPopupEvent,
    ShowingEventArgs>

Value

Type: Alternet.SyntaxShowPopupEvent
See Also

Reference

ICodeCompletionProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderItem Interface

ICodeCompletionProviderItem Interface
Stores particular code completion item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionProviderItem : IComparable
Public Interface ICodeCompletionProviderItem
    Inherits IComparable
public interface class ICodeCompletionProviderItem : IComparable
type ICodeCompletionProviderItem =
    interface
        interface IComparable
    end

The ICodeCompletionProviderItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderItem Methods

ICodeCompletionProviderItem Methods

The ICodeCompletionProviderItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeCompletionProviderItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderItem Properties

ICodeCompletionProviderItem Properties

The ICodeCompletionProviderItem type exposes the following members.

Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object.
Top
See Also

Reference

ICodeCompletionProviderItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderItem.SerializationInfo Property

ICodeCompletionProviderItemSerializationInfo Property
When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISerializationInfo SerializationInfo { get; set; }
Property SerializationInfo As ISerializationInfo
    Get
    Set
property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

ICodeCompletionProviderItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderNamedItem Interface

ICodeCompletionProviderNamedItem Interface
Represents properties and methods describing particular item in the ICodeCompletionProviderItems collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionProviderNamedItem : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeCompletionProviderNamedItem
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeCompletionProviderNamedItem : ICodeCompletionProviderItem,
    IComparable
type ICodeCompletionProviderNamedItem =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeCompletionProviderNamedItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | CustomData | When implemented by a class, gets a header associated with the ICodeCompletionProviderNamedItem.
Public property | Description | When implemented by a class, gets description of the ICodeCompletionProviderNamedItem.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the ICodeCompletionProviderNamedItem.
Public property | Name | When implemented by a class, gets name of the ICodeCompletionProviderNamedItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderNamedItem Methods

ICodeCompletionProviderNamedItem Methods

The ICodeCompletionProviderNamedItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeCompletionProviderNamedItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderNamedItem Properties

ICodeCompletionProviderNamedItem Properties

The ICodeCompletionProviderNamedItem type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | When implemented by a class, gets a header associated with the ICodeCompletionProviderNamedItem.
Public property | Description | When implemented by a class, gets description of the ICodeCompletionProviderNamedItem.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the ICodeCompletionProviderNamedItem.
Public property | Name | When implemented by a class, gets name of the ICodeCompletionProviderNamedItem.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

ICodeCompletionProviderNamedItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderNamedItem.CustomData Property

ICodeCompletionProviderNamedItemCustomData Property
When implemented by a class, gets a header associated with the ICodeCompletionProviderNamedItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object CustomData { get; }
ReadOnly Property CustomData As Object
    Get
property Object^ CustomData {
    Object^ get ();
}
abstract CustomData : Object with get

Property Value

Type: Object
See Also

Reference

ICodeCompletionProviderNamedItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderNamedItem.Description Property

ICodeCompletionProviderNamedItemDescription Property
When implemented by a class, gets description of the ICodeCompletionProviderNamedItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

ICodeCompletionProviderNamedItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderNamedItem.ImageIndex Property

ICodeCompletionProviderNamedItemImageIndex Property
When implemented by a class, gets or sets the index of the image displayed for the ICodeCompletionProviderNamedItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ImageIndex { get; set; }
Property ImageIndex As Integer
    Get
    Set
property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ICodeCompletionProviderNamedItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionProviderNamedItem.Name Property

ICodeCompletionProviderNamedItemName Property
When implemented by a class, gets name of the ICodeCompletionProviderNamedItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

ICodeCompletionProviderNamedItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository Interface

ICodeCompletionRepository Interface
Represents properties and methods to perform code completion functionality.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeCompletionRepository : IDisposable
Public Interface ICodeCompletionRepository
    Inherits IDisposable
public interface class ICodeCompletionRepository : IDisposable
type ICodeCompletionRepository =
    interface
        interface IDisposable
    end

The ICodeCompletionRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element.
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FindDeclaration | When implemented by a class, obtains information about where the language element is declared.
Public method | FindReferences | When implemented by a class, locates all references to the node in the text.
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language.
Public method | GetDescription | When implemented by a class, obtains description of some language element.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element.
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations.
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element.
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object.
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node.
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases.
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window.
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets.
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees.
Top
Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive.
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection.
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository.
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI.
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements.
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository.
Top
Events
 | Name | Description
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element.
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository Methods

ICodeCompletionRepository Methods

The ICodeCompletionRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element.
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FindDeclaration | When implemented by a class, obtains information about where the language element is declared.
Public method | FindReferences | When implemented by a class, locates all references to the node in the text.
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language.
Public method | GetDescription | When implemented by a class, obtains description of some language element.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element.
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations.
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element.
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object.
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node.
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases.
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window.
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets.
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees.
Top
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.FillMember Method

ICodeCompletionRepositoryFillMember Method
When implemented by a class, obtains information about individual member of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillMember(
    IListMembers members,
    Object member,
    string name,
    int paramIndex,
    CodeCompletionScope scope
)
Sub FillMember (
    members As IListMembers,
    member As Object,
    name As String,
    paramIndex As Integer,
    scope As CodeCompletionScope
)
void FillMember(
    IListMembers^ members,
    Object^ member,
    String^ name,
    int paramIndex,
    CodeCompletionScope scope
)
abstract FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        paramIndex : int *
        scope : CodeCompletionScope -> unit

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of member to retrieve.
paramIndex
Type: SystemInt32
Specifies index of current member parameter.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.FillMembers Method

ICodeCompletionRepositoryFillMembers Method
When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillMembers(
    ISyntaxNode node,
    Point position,
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope,
    ref int selIndex
)
Sub FillMembers (
    node As ISyntaxNode,
    position As Point,
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope,
    ByRef selIndex As Integer
)
void FillMembers(
    ISyntaxNode^ node,
    Point position,
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope,
    int% selIndex
)
abstract FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
position
Type: System.DrawingPoint
Specifies position of language element in the text.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies filter used to fill members.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
selIndex
Type: SystemInt32
Specifies index of default list member.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.FindDeclaration Method

ICodeCompletionRepositoryFindDeclaration Method
When implemented by a class, obtains information about where the language element is declared.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object FindDeclaration(
    string text,
    ISyntaxNode node,
    Point position
)
Function FindDeclaration (
    text As String,
    node As ISyntaxNode,
    position As Point
) As Object
Object^ FindDeclaration(
    String^ text,
    ISyntaxNode^ node,
    Point position
)
abstract FindDeclaration :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object

Parameters

text
Type: SystemString
Specifies the source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies position of language element.

Return Value

Type: Object
object representing declaration of the language element.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.FindReferences Method

ICodeCompletionRepositoryFindReferences Method
When implemented by a class, locates all references to the node in the text.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FindReferences(
    ISyntaxNode node,
    ISyntaxNodes references
)
Function FindReferences (
    node As ISyntaxNode,
    references As ISyntaxNodes
) As Integer
int FindReferences(
    ISyntaxNode^ node,
    ISyntaxNodes^ references
)
abstract FindReferences :
        node : ISyntaxNode *
        references : ISyntaxNodes -> int

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to find references.
references
Type: Alternet.SyntaxISyntaxNodes
Retrieves references to node.

Return Value

Type: Int32
Number of found references.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetCodeSnippets Method

ICodeCompletionRepositoryGetCodeSnippets Method
When implemented by a class, returns code snippets for the given language.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetsProvider GetCodeSnippets(
    string language
)
Function GetCodeSnippets (
    language As String
) As ICodeSnippetsProvider
ICodeSnippetsProvider^ GetCodeSnippets(
    String^ language
)
abstract GetCodeSnippets :
        language : string -> ICodeSnippetsProvider

Parameters

language
Type: SystemString
Represents a language.

Return Value

Type: ICodeSnippetsProvider
ICodeSnippetsProvider instance for a given language.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetDescription Method

ICodeCompletionRepositoryGetDescription Method
When implemented by a class, obtains description of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetDescription(
    IListMembers members,
    ISyntaxNode node,
    Object member,
    string name,
    bool fullDescription
)
Function GetDescription (
    members As IListMembers,
    node As ISyntaxNode,
    member As Object,
    name As String,
    fullDescription As Boolean
) As String
String^ GetDescription(
    IListMembers^ members,
    ISyntaxNode^ node,
    Object^ member,
    String^ name,
    bool fullDescription
)
abstract GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies ListMembers interface used to get language-specific description.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode that representing language element to describe.
member
Type: SystemObject
Specifies language element to describe.
name
Type: SystemString
Specifies name of described language element.
fullDescription
Type: SystemBoolean
Specifies whether description should include name and type of the found element.

Return Value

Type: String
String that describes specified language element.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetMemberType Method

ICodeCompletionRepositoryGetMemberType Method
Overload List
 | Name | Description
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element.
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations.
Top
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetMemberType Method (ISyntaxNode, Point, Object, String, CodeCompletionScope)

ICodeCompletionRepositoryGetMemberType Method (ISyntaxNode, Point, Object, String, CodeCompletionScope)
When implemented by a class, obtains information about a member of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object GetMemberType(
    ISyntaxNode node,
    Point position,
    Object member,
    string name,
    out CodeCompletionScope scope
)
Function GetMemberType (
    node As ISyntaxNode,
    position As Point,
    member As Object,
    name As String,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
Object^ GetMemberType(
    ISyntaxNode^ node,
    Point position,
    Object^ member,
    String^ name,
    [OutAttribute] CodeCompletionScope% scope
)
abstract GetMemberType :
        node : ISyntaxNode *
        position : Point *
        member : Object *
        name : string *
        scope : CodeCompletionScope byref -> Object

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies position of language element.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of the member to locate.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for this language element.

Return Value

Type: Object
Object representing information about found member.
See Also

Reference

ICodeCompletionRepository Interface
GetMemberType Overload
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetMemberType Method (String, ISyntaxNode, String, Point, Point, CodeCompletionScope)

ICodeCompletionRepositoryGetMemberType Method (String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
When implemented by a class, obtains information about some language element to perform code completion related operations.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object GetMemberType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out CodeCompletionScope scope
)
Function GetMemberType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
Object^ GetMemberType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] CodeCompletionScope% scope
)
abstract GetMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found language element.
position
Type: System.DrawingPoint
Specifies position of found language element in the code text and updates it if needed.
endPos
Type: System.DrawingPoint
Specifies end position of found language element in the code text and updates it if needed.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about language element to complete.
See Also

Reference

ICodeCompletionRepository Interface
GetMemberType Overload
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetMethodType Method

ICodeCompletionRepositoryGetMethodType Method
When implemented by a class, obtains information about some method of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object GetMethodType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out int paramIndex,
    out int paramCount,
    out CodeCompletionScope scope
)
Function GetMethodType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef paramIndex As Integer,
    <OutAttribute> ByRef paramCount As Integer,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
Object^ GetMethodType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] int% paramIndex,
    [OutAttribute] int% paramCount,
    [OutAttribute] CodeCompletionScope% scope
)
abstract GetMethodType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        paramIndex : int byref *
        paramCount : int byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found method.
position
Type: System.DrawingPoint
Retrieves start position of the method in the code text.
endPos
Type: System.DrawingPoint
Retrieves end position of the method in the code text.
paramIndex
Type: SystemInt32
Retrieves index of current parameter in the code text.
paramCount
Type: SystemInt32
Retrieves number of the parameters.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about found method.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetNodeType Method

ICodeCompletionRepositoryGetNodeType Method
When implemented by a class, obtains information type of the SyntaxNode

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object GetNodeType(
    string text,
    ISyntaxNode node,
    Point position
)
Function GetNodeType (
    text As String,
    node As ISyntaxNode,
    position As Point
) As Object
Object^ GetNodeType(
    String^ text,
    ISyntaxNode^ node,
    Point position
)
abstract GetNodeType :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies starting position to search.

Return Value

Type: Object
Object representing type of found member.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetPriority Method

ICodeCompletionRepositoryGetPriority Method
When implemented by a class, obtains priority of the given language element. Specifies language element

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPriority(
    Object member
)
Function GetPriority (
    member As Object
) As Integer
int GetPriority(
    Object^ member
)
abstract GetPriority :
        member : Object -> int

Parameters

member
Type: SystemObject

Return Value

Type: Int32
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetQuickInfo Method

ICodeCompletionRepositoryGetQuickInfo Method
Overload List
 | Name | Description
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object.
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node.
Top
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetQuickInfo Method (Object)

ICodeCompletionRepositoryGetQuickInfo Method (Object)
When implemented by a class, returns information about the object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IQuickInfo GetQuickInfo(
    Object member
)
Function GetQuickInfo (
    member As Object
) As IQuickInfo
IQuickInfo^ GetQuickInfo(
    Object^ member
)
abstract GetQuickInfo :
        member : Object -> IQuickInfo

Parameters

member
Type: SystemObject
Given object.

Return Value

Type: IQuickInfo
IQuickInfo instance.
See Also

Reference

ICodeCompletionRepository Interface
GetQuickInfo Overload
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetQuickInfo Method (ISyntaxNode)

ICodeCompletionRepositoryGetQuickInfo Method (ISyntaxNode)
When implemented by a class, returns information about the node.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IQuickInfo GetQuickInfo(
    ISyntaxNode node
)
Function GetQuickInfo (
    node As ISyntaxNode
) As IQuickInfo
IQuickInfo^ GetQuickInfo(
    ISyntaxNode^ node
)
abstract GetQuickInfo :
        node : ISyntaxNode -> IQuickInfo

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Given syntax node.

Return Value

Type: IQuickInfo
IQuickInfo instance.
See Also

Reference

ICodeCompletionRepository Interface
GetQuickInfo Overload
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.GetSpecialMemberType Method

ICodeCompletionRepositoryGetSpecialMemberType Method
When implemented by a class, obtains information about some language element to perform code completion related operations in special cases.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object GetSpecialMemberType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out CodeCompletionScope scope
)
Function GetSpecialMemberType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
Object^ GetSpecialMemberType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] CodeCompletionScope% scope
)
abstract GetSpecialMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found language element.
position
Type: System.DrawingPoint
Specifies position of found language element in the code text and updates it if needed.
endPos
Type: System.DrawingPoint
Specifies end position of found language element in the code text and updates it if needed.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about language element to complete.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.IsStructureGuideNode Method

ICodeCompletionRepositoryIsStructureGuideNode Method
When implemented by a class, indicates whether specified ISyntaxNode is guide node.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsStructureGuideNode(
    ISyntaxNode node,
    out IRange range
)
Function IsStructureGuideNode (
    node As ISyntaxNode,
    <OutAttribute> ByRef range As IRange
) As Boolean
bool IsStructureGuideNode(
    ISyntaxNode^ node,
    [OutAttribute] IRange^% range
)
abstract IsStructureGuideNode :
        node : ISyntaxNode *
        range : IRange byref -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to check.
range
Type: Alternet.CommonIRange
Output parameter receives guide range.

Return Value

Type: Boolean
True if ISyntaxNode is guide node; otherwise false.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.RegisterSnippet Method

ICodeCompletionRepositoryRegisterSnippet Method
When implemented by a class, registers snippet to be displayed in code completion window.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterSnippet(
    string snippet,
    bool isStatement
)
Sub RegisterSnippet (
    snippet As String,
    isStatement As Boolean
)
void RegisterSnippet(
    String^ snippet,
    bool isStatement
)
abstract RegisterSnippet :
        snippet : string *
        isStatement : bool -> unit

Parameters

snippet
Type: SystemString
Specifies name of snippet to be displayed.
isStatement
Type: SystemBoolean
Specifies whether snippet will have statement image index.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.RegisterSyntaxTree Method

ICodeCompletionRepositoryRegisterSyntaxTree Method
When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterSyntaxTree(
    ISyntaxTree tree
)
Sub RegisterSyntaxTree (
    tree As ISyntaxTree
)
void RegisterSyntaxTree(
    ISyntaxTree^ tree
)
abstract RegisterSyntaxTree :
        tree : ISyntaxTree -> unit

Parameters

tree
Type: Alternet.SyntaxISyntaxTree
Specifies ISyntaxTree to add.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.UnregisterSnippet Method

ICodeCompletionRepositoryUnregisterSnippet Method
When implemented by a class, removes specified snippet from the list of snippets.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterSnippet(
    string snippet
)
Function UnregisterSnippet (
    snippet As String
) As Boolean
bool UnregisterSnippet(
    String^ snippet
)
abstract UnregisterSnippet :
        snippet : string -> bool

Parameters

snippet
Type: SystemString
Specifies name of snippet to be removed.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.UnregisterSyntaxTree Method

ICodeCompletionRepositoryUnregisterSyntaxTree Method
When implemented by a class, removes specified tree from the list of syntax trees.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterSyntaxTree(
    ISyntaxTree tree
)
Function UnregisterSyntaxTree (
    tree As ISyntaxTree
) As Boolean
bool UnregisterSyntaxTree(
    ISyntaxTree^ tree
)
abstract UnregisterSyntaxTree :
        tree : ISyntaxTree -> bool

Parameters

tree
Type: Alternet.SyntaxISyntaxTree
Specifies ISyntaxTree to remove.

Return Value

Type: Boolean
True if succeed (tree is present in the tree list); otherwise false.
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository Properties

ICodeCompletionRepository Properties

The ICodeCompletionRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive.
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection.
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository.
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI.
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements.
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository.
Top
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.CaseSensitive Property

ICodeCompletionRepositoryCaseSensitive Property
When implemented by a class, indicates whether searching for language element's members should be case sensitive.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CaseSensitive { get; }
ReadOnly Property CaseSensitive As Boolean
    Get
property bool CaseSensitive {
    bool get ();
}
abstract CaseSensitive : bool with get

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.FillBaseMembers Property

ICodeCompletionRepositoryFillBaseMembers Property
When implemented by a class, indicates whether members of Object class should be present in the member collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FillBaseMembers { get; set; }
Property FillBaseMembers As Boolean
    Get
    Set
property bool FillBaseMembers {
    bool get ();
    void set (bool value);
}
abstract FillBaseMembers : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.Images Property

ICodeCompletionRepositoryImages Property
When implemented by a class, gets ImageList attached to this CodeCompletionRepository.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList Images { get; }
ReadOnly Property Images As ImageList
    Get
property ImageList^ Images {
    ImageList^ get ();
}
abstract Images : ImageList with get

Property Value

Type: ImageList
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.ImagesHighDpi Property

ICodeCompletionRepositoryImagesHighDpi Property
When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ImageList ImagesHighDpi { get; }
ReadOnly Property ImagesHighDpi As ImageList
    Get
property ImageList^ ImagesHighDpi {
    ImageList^ get ();
}
abstract ImagesHighDpi : ImageList with get

Property Value

Type: ImageList
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.ImagesResourceNameSuffix Property

ICodeCompletionRepositoryImagesResourceNameSuffix Property
When implemented by a class, gets or sets the images resource name suffix.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ImagesResourceNameSuffix { get; set; }
Property ImagesResourceNameSuffix As String
    Get
    Set
property String^ ImagesResourceNameSuffix {
    String^ get ();
    void set (String^ value);
}
abstract ImagesResourceNameSuffix : string with get, set

Property Value

Type: String
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.SyntaxTree Property

ICodeCompletionRepositorySyntaxTree Property
When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxTree SyntaxTree { get; }
ReadOnly Property SyntaxTree As ISyntaxTree
    Get
property ISyntaxTree^ SyntaxTree {
    ISyntaxTree^ get ();
}
abstract SyntaxTree : ISyntaxTree with get

Property Value

Type: ISyntaxTree
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.SyntaxTrees Property

ICodeCompletionRepositorySyntaxTrees Property
When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<ISyntaxTree> SyntaxTrees { get; }
ReadOnly Property SyntaxTrees As IList(Of ISyntaxTree)
    Get
property IList<ISyntaxTree^>^ SyntaxTrees {
    IList<ISyntaxTree^>^ get ();
}
abstract SyntaxTrees : IList<ISyntaxTree> with get

Property Value

Type: IListISyntaxTree
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository Events

ICodeCompletionRepository Events

The ICodeCompletionRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element.
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element.
Top
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.DescriptionLookup Event

ICodeCompletionRepositoryDescriptionLookup Event
When implemented by a class, occurs while trying to obtain description of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event DescriptionLookupEvent DescriptionLookup
Event DescriptionLookup As DescriptionLookupEvent
 event DescriptionLookupEvent^ DescriptionLookup {
    void add (DescriptionLookupEvent^ value);
    void remove (DescriptionLookupEvent^ value);
}
abstract DescriptionLookup : IEvent<DescriptionLookupEvent,
    DescriptionLookupEventArgs>

Value

Type: Alternet.SyntaxDescriptionLookupEvent
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeCompletionRepository.MemberLookup Event

ICodeCompletionRepositoryMemberLookup Event
When implemented by a class, occurs while trying to obtain information about some member of language element.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event MemberLookupEvent MemberLookup
Event MemberLookup As MemberLookupEvent
 event MemberLookupEvent^ MemberLookup {
    void add (MemberLookupEvent^ value);
    void remove (MemberLookupEvent^ value);
}
abstract MemberLookup : IEvent<MemberLookupEvent,
    MemberLookupEventArgs>

Value

Type: Alternet.SyntaxMemberLookupEvent
See Also

Reference

ICodeCompletionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItem Interface

ICodeFixItem Interface
Represents properties and methods describing particular code fix in the code fix collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeFixItem : ICodeCompletionProviderNamedItem,
    ICodeCompletionProviderItem, IComparable
Public Interface ICodeFixItem
    Inherits ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
public interface class ICodeFixItem : ICodeCompletionProviderNamedItem,
    ICodeCompletionProviderItem, IComparable
type ICodeFixItem =
    interface
        interface ICodeCompletionProviderNamedItem
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeFixItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | CodeFix | When implemented by a class, gets a header associated with the code fix.
Public property | CustomData | When implemented by a class, gets a header associated with the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Description | When implemented by a class, gets description of the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Name | When implemented by a class, gets name of the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeFixItem Methods

ICodeFixItem Methods

The ICodeFixItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeFixItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItem Properties

ICodeFixItem Properties

The ICodeFixItem type exposes the following members.

Properties
 | Name | Description
Public property | CodeFix | When implemented by a class, gets a header associated with the code fix.
Public property | CustomData | When implemented by a class, gets a header associated with the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Description | When implemented by a class, gets description of the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Name | When implemented by a class, gets name of the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

ICodeFixItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItem.CodeFix Property

ICodeFixItemCodeFix Property
When implemented by a class, gets a header associated with the code fix.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeFix CodeFix { get; set; }
Property CodeFix As ICodeFix
    Get
    Set
property ICodeFix^ CodeFix {
    ICodeFix^ get ();
    void set (ICodeFix^ value);
}
abstract CodeFix : ICodeFix with get, set

Property Value

Type: ICodeFix
See Also

Reference

ICodeFixItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItem.Parent Property

ICodeFixItemParent Property
When implemented by a class, gets or sets a parent of the ICodeSnippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeFixItems Parent { get; set; }
Property Parent As ICodeFixItems
    Get
    Set
property ICodeFixItems^ Parent {
    ICodeFixItems^ get ();
    void set (ICodeFixItems^ value);
}
abstract Parent : ICodeFixItems with get, set

Property Value

Type: ICodeFixItems
See Also

Reference

ICodeFixItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItems Interface

ICodeFixItems Interface
Represents collection containing list of code fixes.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeFixItems : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>,
    IEnumerable, IExport, IImport
Public Interface ICodeFixItems
    Inherits ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem), ICollection(Of ICodeCompletionProviderItem),
    IEnumerable(Of ICodeCompletionProviderItem), IEnumerable, IExport, IImport
public interface class ICodeFixItems : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>,
    IEnumerable, IExport, IImport
type ICodeFixItems =
    interface
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The ICodeFixItems type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddCodeFix | When implemented by a class, adds a new item to the ICodeFixItem collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertCodeFix | When implemented by a class, inserts a new item to the specified position within the ICodeFixItems collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to ICodeFixItem objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeFixItems Methods

ICodeFixItems Methods

The ICodeFixItems type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddCodeFix | When implemented by a class, adds a new item to the ICodeFixItem collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertCodeFix | When implemented by a class, inserts a new item to the specified position within the ICodeFixItems collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeFixItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItems.AddCodeFix Method

ICodeFixItemsAddCodeFix Method
When implemented by a class, adds a new item to the ICodeFixItem collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeFixItem AddCodeFix()
Function AddCodeFix As ICodeFixItem
ICodeFixItem^ AddCodeFix()
abstract AddCodeFix : unit -> ICodeFixItem

Return Value

Type: ICodeFixItem
ICodeFixItem that is added.
See Also

Reference

ICodeFixItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItems.InsertCodeFix Method

ICodeFixItemsInsertCodeFix Method
When implemented by a class, inserts a new item to the specified position within the ICodeFixItems collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeFixItem InsertCodeFix(
    int index
)
Function InsertCodeFix (
    index As Integer
) As ICodeFixItem
ICodeFixItem^ InsertCodeFix(
    int index
)
abstract InsertCodeFix :
        index : int -> ICodeFixItem

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeFixItem
ICodeFixItem that is inserted.
See Also

Reference

ICodeFixItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItems Properties

ICodeFixItems Properties

The ICodeFixItems type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to ICodeFixItem objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeFixItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItems.Item Property

ICodeFixItemsItem Property
When implemented by a class, provides an indexed access to ICodeFixItem objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeFixItem this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As ICodeFixItem
    Get
property ICodeFixItem^ default[int index] {
    ICodeFixItem^ get (int index);
}
abstract Item : ICodeFixItem with get

Parameters

index
Type: SystemInt32

Property Value

Type: ICodeFixItem
See Also

Reference

ICodeFixItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeFixItems Events

ICodeFixItems Events

The ICodeFixItems type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeFixItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItem Interface

ICodeRefactorItem Interface
Represents properties and methods describing particular code fix in the code fix collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeRefactorItem : ICodeCompletionProviderNamedItem,
    ICodeCompletionProviderItem, IComparable
Public Interface ICodeRefactorItem
    Inherits ICodeCompletionProviderNamedItem, ICodeCompletionProviderItem, IComparable
public interface class ICodeRefactorItem : ICodeCompletionProviderNamedItem,
    ICodeCompletionProviderItem, IComparable
type ICodeRefactorItem =
    interface
        interface ICodeCompletionProviderNamedItem
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeRefactorItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | CodeRefactor | When implemented by a class, gets a header associated with the code fix.
Public property | CustomData | When implemented by a class, gets a header associated with the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Description | When implemented by a class, gets description of the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Name | When implemented by a class, gets name of the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItem Methods

ICodeRefactorItem Methods

The ICodeRefactorItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeRefactorItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItem Properties

ICodeRefactorItem Properties

The ICodeRefactorItem type exposes the following members.

Properties
 | Name | Description
Public property | CodeRefactor | When implemented by a class, gets a header associated with the code fix.
Public property | CustomData | When implemented by a class, gets a header associated with the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Description | When implemented by a class, gets description of the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Name | When implemented by a class, gets name of the ICodeCompletionProviderNamedItem. (Inherited from ICodeCompletionProviderNamedItem.)
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

ICodeRefactorItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItem.CodeRefactor Property

ICodeRefactorItemCodeRefactor Property
When implemented by a class, gets a header associated with the code fix.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeRefactor CodeRefactor { get; set; }
Property CodeRefactor As ICodeRefactor
    Get
    Set
property ICodeRefactor^ CodeRefactor {
    ICodeRefactor^ get ();
    void set (ICodeRefactor^ value);
}
abstract CodeRefactor : ICodeRefactor with get, set

Property Value

Type: ICodeRefactor
See Also

Reference

ICodeRefactorItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItem.Parent Property

ICodeRefactorItemParent Property
When implemented by a class, gets or sets a parent of the ICodeSnippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeRefactorItems Parent { get; set; }
Property Parent As ICodeRefactorItems
    Get
    Set
property ICodeRefactorItems^ Parent {
    ICodeRefactorItems^ get ();
    void set (ICodeRefactorItems^ value);
}
abstract Parent : ICodeRefactorItems with get, set

Property Value

Type: ICodeRefactorItems
See Also

Reference

ICodeRefactorItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItems Interface

ICodeRefactorItems Interface
Represents collection containing list of code fixes.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeRefactorItems : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>,
    IEnumerable, IExport, IImport
Public Interface ICodeRefactorItems
    Inherits ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem), ICollection(Of ICodeCompletionProviderItem),
    IEnumerable(Of ICodeCompletionProviderItem), IEnumerable, IExport, IImport
public interface class ICodeRefactorItems : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>,
    IEnumerable, IExport, IImport
type ICodeRefactorItems =
    interface
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The ICodeRefactorItems type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddCodeRefactor | When implemented by a class, adds a new item to the ICodeRefactorItem collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertCodeRefactor | When implemented by a class, inserts a new item to the specified position within the ICodeRefactorItem collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to ICodeRefactorItem objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItems Methods

ICodeRefactorItems Methods

The ICodeRefactorItems type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddCodeRefactor | When implemented by a class, adds a new item to the ICodeRefactorItem collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertCodeRefactor | When implemented by a class, inserts a new item to the specified position within the ICodeRefactorItem collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeRefactorItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItems.AddCodeRefactor Method

ICodeRefactorItemsAddCodeRefactor Method
When implemented by a class, adds a new item to the ICodeRefactorItem collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeRefactorItem AddCodeRefactor()
Function AddCodeRefactor As ICodeRefactorItem
ICodeRefactorItem^ AddCodeRefactor()
abstract AddCodeRefactor : unit -> ICodeRefactorItem

Return Value

Type: ICodeRefactorItem
ICodeRefactorItem that is added.
See Also

Reference

ICodeRefactorItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItems.InsertCodeRefactor Method

ICodeRefactorItemsInsertCodeRefactor Method
When implemented by a class, inserts a new item to the specified position within the ICodeRefactorItem collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeRefactorItem InsertCodeRefactor(
    int index
)
Function InsertCodeRefactor (
    index As Integer
) As ICodeRefactorItem
ICodeRefactorItem^ InsertCodeRefactor(
    int index
)
abstract InsertCodeRefactor :
        index : int -> ICodeRefactorItem

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeRefactorItem
ICodeRefactorItem that is inserted.
See Also

Reference

ICodeRefactorItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItems Properties

ICodeRefactorItems Properties

The ICodeRefactorItems type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to ICodeRefactorItem objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeRefactorItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItems.Item Property

ICodeRefactorItemsItem Property
When implemented by a class, provides an indexed access to ICodeRefactorItem objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeRefactorItem this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As ICodeRefactorItem
    Get
property ICodeRefactorItem^ default[int index] {
    ICodeRefactorItem^ get (int index);
}
abstract Item : ICodeRefactorItem with get

Parameters

index
Type: SystemInt32

Property Value

Type: ICodeRefactorItem
See Also

Reference

ICodeRefactorItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeRefactorItems Events

ICodeRefactorItems Events

The ICodeRefactorItems type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeRefactorItems Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet Interface

ICodeSnippet Interface
Represents properties and methods describing particular code snippet in the snippets collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippet : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeSnippet
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippet : ICodeCompletionProviderItem,
    IComparable
type ICodeSnippet =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippet type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | Code | When implemented by a class, gets or sets a string value that specifies code of the template. The code completion control, that holds a templates collection inserts code when user accepts the input.
Public property | CustomData | When implemented by a class, gets or sets an object that can hold a user defined data attached to the template.
Public property | Declarations | When implemented by a class, specifies the literals and objects that make up the parts of a code snippet that you can edit.
Public property | Description | When implemented by a class, gets description of the ICodeSnippet.
Public property | Header | When implemented by a class, gets a header associated with the snippet.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the template.
Public property | Imports | When implemented by a class, contains the imported namespaces for the code snippet.
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippet.
Public property | References | When implemented by a class, contains information about assembly references for the code snippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet Methods

ICodeSnippet Methods

The ICodeSnippet type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet Properties

ICodeSnippet Properties

The ICodeSnippet type exposes the following members.

Properties
 | Name | Description
Public property | Code | When implemented by a class, gets or sets a string value that specifies code of the template. The code completion control, that holds a templates collection inserts code when user accepts the input.
Public property | CustomData | When implemented by a class, gets or sets an object that can hold a user defined data attached to the template.
Public property | Declarations | When implemented by a class, specifies the literals and objects that make up the parts of a code snippet that you can edit.
Public property | Description | When implemented by a class, gets description of the ICodeSnippet.
Public property | Header | When implemented by a class, gets a header associated with the snippet.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the template.
Public property | Imports | When implemented by a class, contains the imported namespaces for the code snippet.
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippet.
Public property | References | When implemented by a class, contains information about assembly references for the code snippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet.Code Property

ICodeSnippetCode Property
When implemented by a class, gets or sets a string value that specifies code of the template. The code completion control, that holds a templates collection inserts code when user accepts the input.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetCode Code { get; set; }
Property Code As ICodeSnippetCode
    Get
    Set
property ICodeSnippetCode^ Code {
    ICodeSnippetCode^ get ();
    void set (ICodeSnippetCode^ value);
}
abstract Code : ICodeSnippetCode with get, set

Property Value

Type: ICodeSnippetCode
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet.CustomData Property

ICodeSnippetCustomData Property
When implemented by a class, gets or sets an object that can hold a user defined data attached to the template.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object CustomData { get; set; }
Property CustomData As Object
    Get
    Set
property Object^ CustomData {
    Object^ get ();
    void set (Object^ value);
}
abstract CustomData : Object with get, set

Property Value

Type: Object
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet.Declarations Property

ICodeSnippetDeclarations Property
When implemented by a class, specifies the literals and objects that make up the parts of a code snippet that you can edit.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetDeclarations Declarations { get; }
ReadOnly Property Declarations As ICodeSnippetDeclarations
    Get
property ICodeSnippetDeclarations^ Declarations {
    ICodeSnippetDeclarations^ get ();
}
abstract Declarations : ICodeSnippetDeclarations with get

Property Value

Type: ICodeSnippetDeclarations
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet.Description Property

ICodeSnippetDescription Property
When implemented by a class, gets description of the ICodeSnippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet.Header Property

ICodeSnippetHeader Property
When implemented by a class, gets a header associated with the snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetHeader Header { get; set; }
Property Header As ICodeSnippetHeader
    Get
    Set
property ICodeSnippetHeader^ Header {
    ICodeSnippetHeader^ get ();
    void set (ICodeSnippetHeader^ value);
}
abstract Header : ICodeSnippetHeader with get, set

Property Value

Type: ICodeSnippetHeader
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet.ImageIndex Property

ICodeSnippetImageIndex Property
When implemented by a class, gets or sets the index of the image displayed for the template.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ImageIndex { get; set; }
Property ImageIndex As Integer
    Get
    Set
property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet.Imports Property

ICodeSnippetImports Property
When implemented by a class, contains the imported namespaces for the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetImports Imports { get; }
ReadOnly Property Imports As ICodeSnippetImports
    Get
property ICodeSnippetImports^ Imports {
    ICodeSnippetImports^ get ();
}
abstract Imports : ICodeSnippetImports with get

Property Value

Type: ICodeSnippetImports
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet.Parent Property

ICodeSnippetParent Property
When implemented by a class, gets or sets a parent of the ICodeSnippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippets Parent { get; set; }
Property Parent As ICodeSnippets
    Get
    Set
property ICodeSnippets^ Parent {
    ICodeSnippets^ get ();
    void set (ICodeSnippets^ value);
}
abstract Parent : ICodeSnippets with get, set

Property Value

Type: ICodeSnippets
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippet.References Property

ICodeSnippetReferences Property
When implemented by a class, contains information about assembly references for the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetReferences References { get; }
ReadOnly Property References As ICodeSnippetReferences
    Get
property ICodeSnippetReferences^ References {
    ICodeSnippetReferences^ get ();
}
abstract References : ICodeSnippetReferences with get

Property Value

Type: ICodeSnippetReferences
See Also

Reference

ICodeSnippet Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetCode Interface

ICodeSnippetCode Interface
Specifies the code that you want to insert into a file.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetCode : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeSnippetCode
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippetCode : ICodeCompletionProviderItem,
    IComparable
type ICodeSnippetCode =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippetCode type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another ICodeSnippetCode object.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | Code | When implemented by a class, specifies the code that you want to insert into a file.
Public property | Delimiter | When implemented by a class, specifies the delimiter used to describe literals and objects in the code.
Public property | Kind | When implemented by a class, specifies the kind of code the snippet contains, and thus, where the snippet can be inserted.
Public property | Language | When implemented by a class, specifies the language of the code snippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetCode Methods

ICodeSnippetCode Methods

The ICodeSnippetCode type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another ICodeSnippetCode object.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippetCode Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetCode.Assign Method

ICodeSnippetCodeAssign Method
When implemented by a class, copies the contents of another ICodeSnippetCode object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ICodeSnippetCode source
)
Sub Assign (
    source As ICodeSnippetCode
)
void Assign(
    ICodeSnippetCode^ source
)
abstract Assign :
        source : ICodeSnippetCode -> unit

Parameters

source
Type: Alternet.Syntax.CodeCompletionICodeSnippetCode
Specifies ICodeSnippetCode to assign.
See Also

Reference

ICodeSnippetCode Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetCode Properties

ICodeSnippetCode Properties

The ICodeSnippetCode type exposes the following members.

Properties
 | Name | Description
Public property | Code | When implemented by a class, specifies the code that you want to insert into a file.
Public property | Delimiter | When implemented by a class, specifies the delimiter used to describe literals and objects in the code.
Public property | Kind | When implemented by a class, specifies the kind of code the snippet contains, and thus, where the snippet can be inserted.
Public property | Language | When implemented by a class, specifies the language of the code snippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

ICodeSnippetCode Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetCode.Code Property

ICodeSnippetCodeCode Property
When implemented by a class, specifies the code that you want to insert into a file.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Code { get; set; }
Property Code As String
    Get
    Set
property String^ Code {
    String^ get ();
    void set (String^ value);
}
abstract Code : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetCode Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetCode.Delimiter Property

ICodeSnippetCodeDelimiter Property
When implemented by a class, specifies the delimiter used to describe literals and objects in the code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Delimiter { get; set; }
Property Delimiter As String
    Get
    Set
property String^ Delimiter {
    String^ get ();
    void set (String^ value);
}
abstract Delimiter : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetCode Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetCode.Kind Property

ICodeSnippetCodeKind Property
When implemented by a class, specifies the kind of code the snippet contains, and thus, where the snippet can be inserted.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Kind { get; set; }
Property Kind As String
    Get
    Set
property String^ Kind {
    String^ get ();
    void set (String^ value);
}
abstract Kind : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetCode Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetCode.Language Property

ICodeSnippetCodeLanguage Property
When implemented by a class, specifies the language of the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Language { get; set; }
Property Language As String
    Get
    Set
property String^ Language {
    String^ get ();
    void set (String^ value);
}
abstract Language : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetCode Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclaration Interface

ICodeSnippetDeclaration Interface
Represents properties and methods describing literals and objects that make up the parts of a code snippet that you can edit.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetDeclaration : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeSnippetDeclaration
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippetDeclaration : ICodeCompletionProviderItem,
    IComparable
type ICodeSnippetDeclaration =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippetDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | Literals | When implemented by a class, defines the literals of the code snippet that you can edit.
Public property | Objects | When implemented by a class, defines the objects of the code snippet that you can edit.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclaration Methods

ICodeSnippetDeclaration Methods

The ICodeSnippetDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippetDeclaration Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclaration Properties

ICodeSnippetDeclaration Properties

The ICodeSnippetDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Literals | When implemented by a class, defines the literals of the code snippet that you can edit.
Public property | Objects | When implemented by a class, defines the objects of the code snippet that you can edit.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

ICodeSnippetDeclaration Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclaration.Literals Property

ICodeSnippetDeclarationLiterals Property
When implemented by a class, defines the literals of the code snippet that you can edit.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetLiterals Literals { get; }
ReadOnly Property Literals As ICodeSnippetLiterals
    Get
property ICodeSnippetLiterals^ Literals {
    ICodeSnippetLiterals^ get ();
}
abstract Literals : ICodeSnippetLiterals with get

Property Value

Type: ICodeSnippetLiterals
See Also

Reference

ICodeSnippetDeclaration Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclaration.Objects Property

ICodeSnippetDeclarationObjects Property
When implemented by a class, defines the objects of the code snippet that you can edit.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetObjects Objects { get; }
ReadOnly Property Objects As ICodeSnippetObjects
    Get
property ICodeSnippetObjects^ Objects {
    ICodeSnippetObjects^ get ();
}
abstract Objects : ICodeSnippetObjects with get

Property Value

Type: ICodeSnippetObjects
See Also

Reference

ICodeSnippetDeclaration Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclarations Interface

ICodeSnippetDeclarations Interface
Represents properties and methods to provide an indexed access to individual ICodeSnippetDeclaration objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetDeclarations : IList<ICodeSnippetDeclaration>,
    ICollection<ICodeSnippetDeclaration>, IEnumerable<ICodeSnippetDeclaration>, IEnumerable
Public Interface ICodeSnippetDeclarations
    Inherits IList(Of ICodeSnippetDeclaration), ICollection(Of ICodeSnippetDeclaration),
    IEnumerable(Of ICodeSnippetDeclaration), IEnumerable
public interface class ICodeSnippetDeclarations : IList<ICodeSnippetDeclaration^>,
    ICollection<ICodeSnippetDeclaration^>, IEnumerable<ICodeSnippetDeclaration^>, IEnumerable
type ICodeSnippetDeclarations =
    interface
        interface IList<ICodeSnippetDeclaration>
        interface ICollection<ICodeSnippetDeclaration>
        interface IEnumerable<ICodeSnippetDeclaration>
        interface IEnumerable
    end

The ICodeSnippetDeclarations type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | AddDeclaration | When implemented by a class, adds a new item to the specified position within the ICodeSnippetDeclarations collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetDeclaration .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetDeclaration .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetDeclaration .)
Public method | InsertDeclaration | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetDeclarations collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetDeclaration .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetDeclaration | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetDeclaration | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetDeclaration, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetDeclaration .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetDeclaration .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetDeclaration .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclarations Methods

ICodeSnippetDeclarations Methods

The ICodeSnippetDeclarations type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | AddDeclaration | When implemented by a class, adds a new item to the specified position within the ICodeSnippetDeclarations collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetDeclaration .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetDeclaration .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetDeclaration .)
Public method | InsertDeclaration | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetDeclarations collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetDeclaration .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetDeclaration .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetDeclaration | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetDeclaration | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetDeclaration, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippetDeclarations Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclarations.AddDeclaration Method

ICodeSnippetDeclarationsAddDeclaration Method
When implemented by a class, adds a new item to the specified position within the ICodeSnippetDeclarations collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetDeclaration AddDeclaration()
Function AddDeclaration As ICodeSnippetDeclaration
ICodeSnippetDeclaration^ AddDeclaration()
abstract AddDeclaration : unit -> ICodeSnippetDeclaration

Return Value

Type: ICodeSnippetDeclaration
ICodeSnippetDeclaration that is added.
See Also

Reference

ICodeSnippetDeclarations Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclarations.InsertDeclaration Method

ICodeSnippetDeclarationsInsertDeclaration Method
When implemented by a class, inserts a new item to the specified position within the ICodeSnippetDeclarations collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetDeclaration InsertDeclaration(
    int index
)
Function InsertDeclaration (
    index As Integer
) As ICodeSnippetDeclaration
ICodeSnippetDeclaration^ InsertDeclaration(
    int index
)
abstract InsertDeclaration :
        index : int -> ICodeSnippetDeclaration

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetDeclaration
ICodeSnippetDeclaration that is inserted.
See Also

Reference

ICodeSnippetDeclarations Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetDeclarations Properties

ICodeSnippetDeclarations Properties

The ICodeSnippetDeclarations type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetDeclaration .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetDeclaration .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetDeclaration .)
Top
See Also

Reference

ICodeSnippetDeclarations Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetHeader Interface

ICodeSnippetHeader Interface
Represents properties and methods describing code snippet header.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetHeader : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeSnippetHeader
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippetHeader : ICodeCompletionProviderItem,
    IComparable
type ICodeSnippetHeader =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippetHeader type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another ICodeSnippetHeader object.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | Author | When implemented by a class, gets or sets a string value that specifies author of the code snippet.
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of the code snippet, that can help user to choose snippet from the popup window.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Shortcut | When implemented by a class, gets or sets a string value that specifies shortcut of the code snippet. This shortcut is replaced by entire snippet when user presses Tab in the editor.
Public property | Title | When implemented by a class, gets or sets a string value that specifies the title of the code snippet. Useful to find necessary item within the snippets collection.
Public property | Types | Specifies how the code snippet is inserted into the code.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetHeader Methods

ICodeSnippetHeader Methods

The ICodeSnippetHeader type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another ICodeSnippetHeader object.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippetHeader Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetHeader.Assign Method

ICodeSnippetHeaderAssign Method
When implemented by a class, copies the contents of another ICodeSnippetHeader object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ICodeSnippetHeader source
)
Sub Assign (
    source As ICodeSnippetHeader
)
void Assign(
    ICodeSnippetHeader^ source
)
abstract Assign :
        source : ICodeSnippetHeader -> unit

Parameters

source
Type: Alternet.Syntax.CodeCompletionICodeSnippetHeader
Specifies ICodeSnippetHeader to assign.
See Also

Reference

ICodeSnippetHeader Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetHeader Properties

ICodeSnippetHeader Properties

The ICodeSnippetHeader type exposes the following members.

Properties
 | Name | Description
Public property | Author | When implemented by a class, gets or sets a string value that specifies author of the code snippet.
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of the code snippet, that can help user to choose snippet from the popup window.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Shortcut | When implemented by a class, gets or sets a string value that specifies shortcut of the code snippet. This shortcut is replaced by entire snippet when user presses Tab in the editor.
Public property | Title | When implemented by a class, gets or sets a string value that specifies the title of the code snippet. Useful to find necessary item within the snippets collection.
Public property | Types | Specifies how the code snippet is inserted into the code.
Top
See Also

Reference

ICodeSnippetHeader Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetHeader.Author Property

ICodeSnippetHeaderAuthor Property
When implemented by a class, gets or sets a string value that specifies author of the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Author { get; set; }
Property Author As String
    Get
    Set
property String^ Author {
    String^ get ();
    void set (String^ value);
}
abstract Author : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetHeader Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetHeader.Description Property

ICodeSnippetHeaderDescription Property
When implemented by a class, gets or sets a string value that specifies short description of the code snippet, that can help user to choose snippet from the popup window.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetHeader Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetHeader.Shortcut Property

ICodeSnippetHeaderShortcut Property
When implemented by a class, gets or sets a string value that specifies shortcut of the code snippet. This shortcut is replaced by entire snippet when user presses Tab in the editor.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Shortcut { get; set; }
Property Shortcut As String
    Get
    Set
property String^ Shortcut {
    String^ get ();
    void set (String^ value);
}
abstract Shortcut : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetHeader Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetHeader.Title Property

ICodeSnippetHeaderTitle Property
When implemented by a class, gets or sets a string value that specifies the title of the code snippet. Useful to find necessary item within the snippets collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Title { get; set; }
Property Title As String
    Get
    Set
property String^ Title {
    String^ get ();
    void set (String^ value);
}
abstract Title : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetHeader Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetHeader.Types Property

ICodeSnippetHeaderTypes Property
Specifies how the code snippet is inserted into the code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetTypes Types { get; }
ReadOnly Property Types As ICodeSnippetTypes
    Get
property ICodeSnippetTypes^ Types {
    ICodeSnippetTypes^ get ();
}
abstract Types : ICodeSnippetTypes with get

Property Value

Type: ICodeSnippetTypes
See Also

Reference

ICodeSnippetHeader Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetImport Interface

ICodeSnippetImport Interface
Represents imported namespace used by an IntelliSense Code Snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetImport : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeSnippetImport
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippetImport : ICodeCompletionProviderItem,
    IComparable
type ICodeSnippetImport =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippetImport type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | Namespace | When implemented by a class, specifies the namespace used by the code snippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetImport Methods

ICodeSnippetImport Methods

The ICodeSnippetImport type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippetImport Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetImport Properties

ICodeSnippetImport Properties

The ICodeSnippetImport type exposes the following members.

Properties
 | Name | Description
Public property | Namespace | When implemented by a class, specifies the namespace used by the code snippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

ICodeSnippetImport Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetImport.Namespace Property

ICodeSnippetImportNamespace Property
When implemented by a class, specifies the namespace used by the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Namespace { get; set; }
Property Namespace As String
    Get
    Set
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}
abstract Namespace : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetImport Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetImports Interface

ICodeSnippetImports Interface
Represents properties and methods to provide an indexed access to individual ICodeSnippetImport objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetImports : IList<ICodeSnippetImport>,
    ICollection<ICodeSnippetImport>, IEnumerable<ICodeSnippetImport>, IEnumerable
Public Interface ICodeSnippetImports
    Inherits IList(Of ICodeSnippetImport), ICollection(Of ICodeSnippetImport),
    IEnumerable(Of ICodeSnippetImport), IEnumerable
public interface class ICodeSnippetImports : IList<ICodeSnippetImport^>,
    ICollection<ICodeSnippetImport^>, IEnumerable<ICodeSnippetImport^>, IEnumerable
type ICodeSnippetImports =
    interface
        interface IList<ICodeSnippetImport>
        interface ICollection<ICodeSnippetImport>
        interface IEnumerable<ICodeSnippetImport>
        interface IEnumerable
    end

The ICodeSnippetImports type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetImport .)
Public method | AddImport | When implemented by a class, adds a new item to the specified position within the ICodeSnippetImports collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetImport .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetImport .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetImport .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetImport .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetImport .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetImport .)
Public method | InsertImport | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetImports collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetImport .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetImport .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetImport | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetImport | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetImport, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetImport .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetImport .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetImport .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetImports Methods

ICodeSnippetImports Methods

The ICodeSnippetImports type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetImport .)
Public method | AddImport | When implemented by a class, adds a new item to the specified position within the ICodeSnippetImports collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetImport .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetImport .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetImport .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetImport .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetImport .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetImport .)
Public method | InsertImport | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetImports collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetImport .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetImport .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetImport | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetImport | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetImport, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippetImports Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetImports.AddImport Method

ICodeSnippetImportsAddImport Method
When implemented by a class, adds a new item to the specified position within the ICodeSnippetImports collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetImport AddImport()
Function AddImport As ICodeSnippetImport
ICodeSnippetImport^ AddImport()
abstract AddImport : unit -> ICodeSnippetImport

Return Value

Type: ICodeSnippetImport
ICodeSnippetImport that is added.
See Also

Reference

ICodeSnippetImports Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetImports.InsertImport Method

ICodeSnippetImportsInsertImport Method
When implemented by a class, inserts a new item to the specified position within the ICodeSnippetImports collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetImport InsertImport(
    int index
)
Function InsertImport (
    index As Integer
) As ICodeSnippetImport
ICodeSnippetImport^ InsertImport(
    int index
)
abstract InsertImport :
        index : int -> ICodeSnippetImport

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetImport
ICodeSnippetImport that is inserted.
See Also

Reference

ICodeSnippetImports Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetImports Properties

ICodeSnippetImports Properties

The ICodeSnippetImports type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetImport .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetImport .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetImport .)
Top
See Also

Reference

ICodeSnippetImports Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral Interface

ICodeSnippetLiteral Interface
Represents properties and methods describing literal that make up the parts of a code snippet that you can edit.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetLiteral : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeSnippetLiteral
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippetLiteral : ICodeCompletionProviderItem,
    IComparable
type ICodeSnippetLiteral =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippetLiteral type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | Default | When implemented by a class, specifies the default value of the literal or object for an IntelliSense Code Snippet.
Public property | Editable | When implemented by a class, specifies whether literal is editable or not.
Public property | Function | When implemented by a class, specifies a function to execute when the literal or object receives focus in the Editor.
Public property | ID | When implemented by a class, specifies the unique identifier for the object or literal.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | SupportsCode | When implemented by a class, specifies whether literal can fill code.
Public property | ToolTip | When implemented by a class, specifies the ToolTip description to be associated with the literal in the code snippet.
Public property | Type | When implemented by a class, Specifies the type of the object.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral Methods

ICodeSnippetLiteral Methods

The ICodeSnippetLiteral type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippetLiteral Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral Properties

ICodeSnippetLiteral Properties

The ICodeSnippetLiteral type exposes the following members.

Properties
 | Name | Description
Public property | Default | When implemented by a class, specifies the default value of the literal or object for an IntelliSense Code Snippet.
Public property | Editable | When implemented by a class, specifies whether literal is editable or not.
Public property | Function | When implemented by a class, specifies a function to execute when the literal or object receives focus in the Editor.
Public property | ID | When implemented by a class, specifies the unique identifier for the object or literal.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | SupportsCode | When implemented by a class, specifies whether literal can fill code.
Public property | ToolTip | When implemented by a class, specifies the ToolTip description to be associated with the literal in the code snippet.
Public property | Type | When implemented by a class, Specifies the type of the object.
Top
See Also

Reference

ICodeSnippetLiteral Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral.Default Property

ICodeSnippetLiteralDefault Property
When implemented by a class, specifies the default value of the literal or object for an IntelliSense Code Snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Default { get; set; }
Property Default As String
    Get
    Set
property String^ Default {
    String^ get ();
    void set (String^ value);
}
abstract Default : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetLiteral Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral.Editable Property

ICodeSnippetLiteralEditable Property
When implemented by a class, specifies whether literal is editable or not.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Editable { get; set; }
Property Editable As Boolean
    Get
    Set
property bool Editable {
    bool get ();
    void set (bool value);
}
abstract Editable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeSnippetLiteral Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral.Function Property

ICodeSnippetLiteralFunction Property
When implemented by a class, specifies a function to execute when the literal or object receives focus in the Editor.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Function { get; set; }
Property Function As String
    Get
    Set
property String^ Function {
    String^ get ();
    void set (String^ value);
}
abstract Function : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetLiteral Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral.ID Property

ICodeSnippetLiteralID Property
When implemented by a class, specifies the unique identifier for the object or literal.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ID { get; set; }
Property ID As String
    Get
    Set
property String^ ID {
    String^ get ();
    void set (String^ value);
}
abstract ID : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetLiteral Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral.SupportsCode Property

ICodeSnippetLiteralSupportsCode Property
When implemented by a class, specifies whether literal can fill code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SupportsCode { get; set; }
Property SupportsCode As Boolean
    Get
    Set
property bool SupportsCode {
    bool get ();
    void set (bool value);
}
abstract SupportsCode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICodeSnippetLiteral Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral.ToolTip Property

ICodeSnippetLiteralToolTip Property
When implemented by a class, specifies the ToolTip description to be associated with the literal in the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ToolTip { get; set; }
Property ToolTip As String
    Get
    Set
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
abstract ToolTip : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetLiteral Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiteral.Type Property

ICodeSnippetLiteralType Property
When implemented by a class, Specifies the type of the object.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Type { get; set; }
Property Type As String
    Get
    Set
property String^ Type {
    String^ get ();
    void set (String^ value);
}
abstract Type : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetLiteral Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiterals Interface

ICodeSnippetLiterals Interface
Represents properties and methods to provide an indexed access to individual ICodeSnippetLiteral objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetLiterals : IList<ICodeSnippetLiteral>,
    ICollection<ICodeSnippetLiteral>, IEnumerable<ICodeSnippetLiteral>, IEnumerable
Public Interface ICodeSnippetLiterals
    Inherits IList(Of ICodeSnippetLiteral), ICollection(Of ICodeSnippetLiteral),
    IEnumerable(Of ICodeSnippetLiteral), IEnumerable
public interface class ICodeSnippetLiterals : IList<ICodeSnippetLiteral^>,
    ICollection<ICodeSnippetLiteral^>, IEnumerable<ICodeSnippetLiteral^>, IEnumerable
type ICodeSnippetLiterals =
    interface
        interface IList<ICodeSnippetLiteral>
        interface ICollection<ICodeSnippetLiteral>
        interface IEnumerable<ICodeSnippetLiteral>
        interface IEnumerable
    end

The ICodeSnippetLiterals type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | AddLiteral | When implemented by a class, adds a new item to the specified position within the ICodeSnippetLiterals collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetLiteral .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetLiteral .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetLiteral .)
Public method | InsertLiteral | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetLiterals collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetLiteral .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetLiteral | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetLiteral | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetLiteral, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetLiteral .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetLiteral .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetLiteral .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiterals Methods

ICodeSnippetLiterals Methods

The ICodeSnippetLiterals type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | AddLiteral | When implemented by a class, adds a new item to the specified position within the ICodeSnippetLiterals collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetLiteral .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetLiteral .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetLiteral .)
Public method | InsertLiteral | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetLiterals collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetLiteral .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetLiteral .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetLiteral | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetLiteral | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetLiteral, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippetLiterals Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiterals.AddLiteral Method

ICodeSnippetLiteralsAddLiteral Method
When implemented by a class, adds a new item to the specified position within the ICodeSnippetLiterals collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetLiteral AddLiteral()
Function AddLiteral As ICodeSnippetLiteral
ICodeSnippetLiteral^ AddLiteral()
abstract AddLiteral : unit -> ICodeSnippetLiteral

Return Value

Type: ICodeSnippetLiteral
ICodeSnippetLiteral that is added.
See Also

Reference

ICodeSnippetLiterals Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiterals.InsertLiteral Method

ICodeSnippetLiteralsInsertLiteral Method
When implemented by a class, inserts a new item to the specified position within the ICodeSnippetLiterals collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetLiteral InsertLiteral(
    int index
)
Function InsertLiteral (
    index As Integer
) As ICodeSnippetLiteral
ICodeSnippetLiteral^ InsertLiteral(
    int index
)
abstract InsertLiteral :
        index : int -> ICodeSnippetLiteral

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetLiteral
ICodeSnippetLiteral that is inserted.
See Also

Reference

ICodeSnippetLiterals Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetLiterals Properties

ICodeSnippetLiterals Properties

The ICodeSnippetLiterals type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetLiteral .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetLiteral .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetLiteral .)
Top
See Also

Reference

ICodeSnippetLiterals Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember Interface

ICodeSnippetMember Interface
Represents properties and methods for a particular code snippet member in the data collection of the code completion popups.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetMember : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeSnippetMember
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippetMember : ICodeCompletionProviderItem,
    IComparable
type ICodeSnippetMember =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippetMember type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | EditPath | When implemented by a class, gets a string value that specifies the full path of the IListMember.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the ICodeSnippetMember.
Public property | Members | When implemented by a class, provides an indexed access to the nested ICodeSnippetMember objects.
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the ICodeSnippetMember collection.
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippetMember.
Public property | Path | When implemented by a class, gets or sets a string value that specifies the path to the file containing source of the ICodeSnippetMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Snippets | When implemented by a class, provides an indexed access to the nested ICodeSnippet objects.
Public property | SnippetsAndMembers | When implemented by a class, provides an indexed access to the nested ICodeSnippet and ICodeSnippetMember objects.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember Methods

ICodeSnippetMember Methods

The ICodeSnippetMember type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember Properties

ICodeSnippetMember Properties

The ICodeSnippetMember type exposes the following members.

Properties
 | Name | Description
Public property | EditPath | When implemented by a class, gets a string value that specifies the full path of the IListMember.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the ICodeSnippetMember.
Public property | Members | When implemented by a class, provides an indexed access to the nested ICodeSnippetMember objects.
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the ICodeSnippetMember collection.
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippetMember.
Public property | Path | When implemented by a class, gets or sets a string value that specifies the path to the file containing source of the ICodeSnippetMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Snippets | When implemented by a class, provides an indexed access to the nested ICodeSnippet objects.
Public property | SnippetsAndMembers | When implemented by a class, provides an indexed access to the nested ICodeSnippet and ICodeSnippetMember objects.
Top
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember.EditPath Property

ICodeSnippetMemberEditPath Property
When implemented by a class, gets a string value that specifies the full path of the IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string EditPath { get; }
ReadOnly Property EditPath As String
    Get
property String^ EditPath {
    String^ get ();
}
abstract EditPath : string with get

Property Value

Type: String
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember.ImageIndex Property

ICodeSnippetMemberImageIndex Property
When implemented by a class, gets or sets the index of the image displayed for the ICodeSnippetMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ImageIndex { get; set; }
Property ImageIndex As Integer
    Get
    Set
property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember.Members Property

ICodeSnippetMemberMembers Property
When implemented by a class, provides an indexed access to the nested ICodeSnippetMember objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetMembers Members { get; }
ReadOnly Property Members As ICodeSnippetMembers
    Get
property ICodeSnippetMembers^ Members {
    ICodeSnippetMembers^ get ();
}
abstract Members : ICodeSnippetMembers with get

Property Value

Type: ICodeSnippetMembers
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember.Name Property

ICodeSnippetMemberName Property
When implemented by a class, gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the ICodeSnippetMember collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember.Parent Property

ICodeSnippetMemberParent Property
When implemented by a class, gets or sets a parent of the ICodeSnippetMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetMembers Parent { get; set; }
Property Parent As ICodeSnippetMembers
    Get
    Set
property ICodeSnippetMembers^ Parent {
    ICodeSnippetMembers^ get ();
    void set (ICodeSnippetMembers^ value);
}
abstract Parent : ICodeSnippetMembers with get, set

Property Value

Type: ICodeSnippetMembers
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember.Path Property

ICodeSnippetMemberPath Property
When implemented by a class, gets or sets a string value that specifies the path to the file containing source of the ICodeSnippetMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Path { get; set; }
Property Path As String
    Get
    Set
property String^ Path {
    String^ get ();
    void set (String^ value);
}
abstract Path : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember.Snippets Property

ICodeSnippetMemberSnippets Property
When implemented by a class, provides an indexed access to the nested ICodeSnippet objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippets Snippets { get; }
ReadOnly Property Snippets As ICodeSnippets
    Get
property ICodeSnippets^ Snippets {
    ICodeSnippets^ get ();
}
abstract Snippets : ICodeSnippets with get

Property Value

Type: ICodeSnippets
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMember.SnippetsAndMembers Property

ICodeSnippetMemberSnippetsAndMembers Property
When implemented by a class, provides an indexed access to the nested ICodeSnippet and ICodeSnippetMember objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetsProvider SnippetsAndMembers { get; }
ReadOnly Property SnippetsAndMembers As ICodeSnippetsProvider
    Get
property ICodeSnippetsProvider^ SnippetsAndMembers {
    ICodeSnippetsProvider^ get ();
}
abstract SnippetsAndMembers : ICodeSnippetsProvider with get

Property Value

Type: ICodeSnippetsProvider
See Also

Reference

ICodeSnippetMember Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMembers Interface

ICodeSnippetMembers Interface
Represents collection containing list of code snippets.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetMembers : ICodeSnippetsProvider,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Interface ICodeSnippetMembers
    Inherits ICodeSnippetsProvider, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public interface class ICodeSnippetMembers : ICodeSnippetsProvider,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type ICodeSnippetMembers =
    interface
        interface ICodeSnippetsProvider
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The ICodeSnippetMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddSnippetMember | When implemented by a class, adds a new item to the ICodeSnippetMembers collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | FindByShortcut | When implemented by a class, gets a code snippet by its shortcut. (Inherited from ICodeSnippetsProvider.)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertSnippetMember | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetMembers collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | ShouldIndent | When implemented by a class, gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control. (Inherited from ICodeSnippetsProvider.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to ICodeSnippetMember objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippetMembers.
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMembers Methods

ICodeSnippetMembers Methods

The ICodeSnippetMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddSnippetMember | When implemented by a class, adds a new item to the ICodeSnippetMembers collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | FindByShortcut | When implemented by a class, gets a code snippet by its shortcut. (Inherited from ICodeSnippetsProvider.)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertSnippetMember | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetMembers collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | ShouldIndent | When implemented by a class, gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control. (Inherited from ICodeSnippetsProvider.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippetMembers Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMembers.AddSnippetMember Method

ICodeSnippetMembersAddSnippetMember Method
When implemented by a class, adds a new item to the ICodeSnippetMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetMember AddSnippetMember()
Function AddSnippetMember As ICodeSnippetMember
ICodeSnippetMember^ AddSnippetMember()
abstract AddSnippetMember : unit -> ICodeSnippetMember

Return Value

Type: ICodeSnippetMember
ICodeSnippetMember that is added.
See Also

Reference

ICodeSnippetMembers Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMembers.InsertSnippetMember Method

ICodeSnippetMembersInsertSnippetMember Method
When implemented by a class, inserts a new item to the specified position within the ICodeSnippetMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetMember InsertSnippetMember(
    int index
)
Function InsertSnippetMember (
    index As Integer
) As ICodeSnippetMember
ICodeSnippetMember^ InsertSnippetMember(
    int index
)
abstract InsertSnippetMember :
        index : int -> ICodeSnippetMember

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetMember
ICodeSnippetMember that is inserted.
See Also

Reference

ICodeSnippetMembers Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMembers Properties

ICodeSnippetMembers Properties

The ICodeSnippetMembers type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to ICodeSnippetMember objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | Parent | When implemented by a class, gets or sets a parent of the ICodeSnippetMembers.
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeSnippetMembers Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMembers.Item Property

ICodeSnippetMembersItem Property
When implemented by a class, provides an indexed access to ICodeSnippetMember objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetMember this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As ICodeSnippetMember
    Get
property ICodeSnippetMember^ default[int index] {
    ICodeSnippetMember^ get (int index);
}
abstract Item : ICodeSnippetMember with get

Parameters

index
Type: SystemInt32

Property Value

Type: ICodeSnippetMember
See Also

Reference

ICodeSnippetMembers Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMembers.Parent Property

ICodeSnippetMembersParent Property
When implemented by a class, gets or sets a parent of the ICodeSnippetMembers.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetMember Parent { get; set; }
Property Parent As ICodeSnippetMember
    Get
    Set
property ICodeSnippetMember^ Parent {
    ICodeSnippetMember^ get ();
    void set (ICodeSnippetMember^ value);
}
abstract Parent : ICodeSnippetMember with get, set

Property Value

Type: ICodeSnippetMember
See Also

Reference

ICodeSnippetMembers Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetMembers Events

ICodeSnippetMembers Events

The ICodeSnippetMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeSnippetMembers Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetObject Interface

ICodeSnippetObject Interface
Represents properties and methods describing literal that make up the parts of a code snippet that you can edit.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetObject : ICodeSnippetLiteral,
    ICodeCompletionProviderItem, IComparable
Public Interface ICodeSnippetObject
    Inherits ICodeSnippetLiteral, ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippetObject : ICodeSnippetLiteral,
    ICodeCompletionProviderItem, IComparable
type ICodeSnippetObject =
    interface
        interface ICodeSnippetLiteral
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippetObject type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | Default | When implemented by a class, specifies the default value of the literal or object for an IntelliSense Code Snippet. (Inherited from ICodeSnippetLiteral.)
Public property | Editable | When implemented by a class, specifies whether literal is editable or not. (Inherited from ICodeSnippetLiteral.)
Public property | Function | When implemented by a class, specifies a function to execute when the literal or object receives focus in the Editor. (Inherited from ICodeSnippetLiteral.)
Public property | ID | When implemented by a class, specifies the unique identifier for the object or literal. (Inherited from ICodeSnippetLiteral.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | SupportsCode | When implemented by a class, specifies whether literal can fill code. (Inherited from ICodeSnippetLiteral.)
Public property | ToolTip | When implemented by a class, specifies the ToolTip description to be associated with the literal in the code snippet. (Inherited from ICodeSnippetLiteral.)
Public property | Type | When implemented by a class, Specifies the type of the object. (Inherited from ICodeSnippetLiteral.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetObject Methods

ICodeSnippetObject Methods

The ICodeSnippetObject type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippetObject Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetObject Properties

ICodeSnippetObject Properties

The ICodeSnippetObject type exposes the following members.

Properties
 | Name | Description
Public property | Default | When implemented by a class, specifies the default value of the literal or object for an IntelliSense Code Snippet. (Inherited from ICodeSnippetLiteral.)
Public property | Editable | When implemented by a class, specifies whether literal is editable or not. (Inherited from ICodeSnippetLiteral.)
Public property | Function | When implemented by a class, specifies a function to execute when the literal or object receives focus in the Editor. (Inherited from ICodeSnippetLiteral.)
Public property | ID | When implemented by a class, specifies the unique identifier for the object or literal. (Inherited from ICodeSnippetLiteral.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | SupportsCode | When implemented by a class, specifies whether literal can fill code. (Inherited from ICodeSnippetLiteral.)
Public property | ToolTip | When implemented by a class, specifies the ToolTip description to be associated with the literal in the code snippet. (Inherited from ICodeSnippetLiteral.)
Public property | Type | When implemented by a class, Specifies the type of the object. (Inherited from ICodeSnippetLiteral.)
Top
See Also

Reference

ICodeSnippetObject Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetObjects Interface

ICodeSnippetObjects Interface
Represents properties and methods to provide an indexed access to individual ICodeSnippetObject objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetObjects : IList<ICodeSnippetObject>,
    ICollection<ICodeSnippetObject>, IEnumerable<ICodeSnippetObject>, IEnumerable
Public Interface ICodeSnippetObjects
    Inherits IList(Of ICodeSnippetObject), ICollection(Of ICodeSnippetObject),
    IEnumerable(Of ICodeSnippetObject), IEnumerable
public interface class ICodeSnippetObjects : IList<ICodeSnippetObject^>,
    ICollection<ICodeSnippetObject^>, IEnumerable<ICodeSnippetObject^>, IEnumerable
type ICodeSnippetObjects =
    interface
        interface IList<ICodeSnippetObject>
        interface ICollection<ICodeSnippetObject>
        interface IEnumerable<ICodeSnippetObject>
        interface IEnumerable
    end

The ICodeSnippetObjects type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetObject .)
Public method | AddObject | When implemented by a class, adds a new item to the specified position within the ICodeSnippetObjects collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetObject .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetObject .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetObject .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetObject .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetObject .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetObject .)
Public method | InsertObject | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetObject collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetObject .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetObject .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetObject | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetObject | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetObject, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetObject .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetObject .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetObject .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetObjects Methods

ICodeSnippetObjects Methods

The ICodeSnippetObjects type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetObject .)
Public method | AddObject | When implemented by a class, adds a new item to the specified position within the ICodeSnippetObjects collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetObject .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetObject .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetObject .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetObject .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetObject .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetObject .)
Public method | InsertObject | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetObject collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetObject .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetObject .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetObject | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetObject | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetObject, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippetObjects Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetObjects.AddObject Method

ICodeSnippetObjectsAddObject Method
When implemented by a class, adds a new item to the specified position within the ICodeSnippetObjects collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetObject AddObject()
Function AddObject As ICodeSnippetObject
ICodeSnippetObject^ AddObject()
abstract AddObject : unit -> ICodeSnippetObject

Return Value

Type: ICodeSnippetObject
ICodeSnippetObject that is added.
See Also

Reference

ICodeSnippetObjects Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetObjects.InsertObject Method

ICodeSnippetObjectsInsertObject Method
When implemented by a class, inserts a new item to the specified position within the ICodeSnippetObject collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetObject InsertObject(
    int index
)
Function InsertObject (
    index As Integer
) As ICodeSnippetObject
ICodeSnippetObject^ InsertObject(
    int index
)
abstract InsertObject :
        index : int -> ICodeSnippetObject

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetObject
ICodeSnippetObject that is inserted.
See Also

Reference

ICodeSnippetObjects Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetObjects Properties

ICodeSnippetObjects Properties

The ICodeSnippetObjects type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetObject .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetObject .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetObject .)
Top
See Also

Reference

ICodeSnippetObjects Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReference Interface

ICodeSnippetReference Interface
Contains information about assembly references for the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetReference : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeSnippetReference
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippetReference : ICodeCompletionProviderItem,
    IComparable
type ICodeSnippetReference =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippetReference type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | Assembly | When implemented by a class, contains the name of the assembly referenced by the code snippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Url | When implemented by a class, contains a URL that provides more information about the referenced assembly.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReference Methods

ICodeSnippetReference Methods

The ICodeSnippetReference type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippetReference Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReference Properties

ICodeSnippetReference Properties

The ICodeSnippetReference type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | When implemented by a class, contains the name of the assembly referenced by the code snippet.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Url | When implemented by a class, contains a URL that provides more information about the referenced assembly.
Top
See Also

Reference

ICodeSnippetReference Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReference.Assembly Property

ICodeSnippetReferenceAssembly Property
When implemented by a class, contains the name of the assembly referenced by the code snippet.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Assembly { get; set; }
Property Assembly As String
    Get
    Set
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}
abstract Assembly : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetReference Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReference.Url Property

ICodeSnippetReferenceUrl Property
When implemented by a class, contains a URL that provides more information about the referenced assembly.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Url { get; set; }
Property Url As String
    Get
    Set
property String^ Url {
    String^ get ();
    void set (String^ value);
}
abstract Url : string with get, set

Property Value

Type: String
See Also

Reference

ICodeSnippetReference Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReferences Interface

ICodeSnippetReferences Interface
Represents properties and methods to provide an indexed access to individual ICodeSnippetReference objects.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetReferences : IList<ICodeSnippetReference>,
    ICollection<ICodeSnippetReference>, IEnumerable<ICodeSnippetReference>, IEnumerable
Public Interface ICodeSnippetReferences
    Inherits IList(Of ICodeSnippetReference), ICollection(Of ICodeSnippetReference),
    IEnumerable(Of ICodeSnippetReference), IEnumerable
public interface class ICodeSnippetReferences : IList<ICodeSnippetReference^>,
    ICollection<ICodeSnippetReference^>, IEnumerable<ICodeSnippetReference^>, IEnumerable
type ICodeSnippetReferences =
    interface
        interface IList<ICodeSnippetReference>
        interface ICollection<ICodeSnippetReference>
        interface IEnumerable<ICodeSnippetReference>
        interface IEnumerable
    end

The ICodeSnippetReferences type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetReference .)
Public method | AddReference | When implemented by a class, adds a new item to the specified position within the ICodeSnippetReferences collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetReference .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetReference .)
Public method | InsertReference | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetReferences collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetReference .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetReference | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetReference | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetReference, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetReference .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetReference .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReferences Methods

ICodeSnippetReferences Methods

The ICodeSnippetReferences type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetReference .)
Public method | AddReference | When implemented by a class, adds a new item to the specified position within the ICodeSnippetReferences collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetReference .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetReference .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetReference .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetReference .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetReference .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetReference .)
Public method | InsertReference | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetReferences collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetReference .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetReference .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetReference | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetReference | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetReference, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippetReferences Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReferences.AddReference Method

ICodeSnippetReferencesAddReference Method
When implemented by a class, adds a new item to the specified position within the ICodeSnippetReferences collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetReference AddReference()
Function AddReference As ICodeSnippetReference
ICodeSnippetReference^ AddReference()
abstract AddReference : unit -> ICodeSnippetReference

Return Value

Type: ICodeSnippetReference
ICodeSnippetReference that is added.
See Also

Reference

ICodeSnippetReferences Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReferences.InsertReference Method

ICodeSnippetReferencesInsertReference Method
When implemented by a class, inserts a new item to the specified position within the ICodeSnippetReferences collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetReference InsertReference(
    int index
)
Function InsertReference (
    index As Integer
) As ICodeSnippetReference
ICodeSnippetReference^ InsertReference(
    int index
)
abstract InsertReference :
        index : int -> ICodeSnippetReference

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetReference
ICodeSnippetReference that is inserted.
See Also

Reference

ICodeSnippetReferences Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetReferences Properties

ICodeSnippetReferences Properties

The ICodeSnippetReferences type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetReference .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetReference .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetReference .)
Top
See Also

Reference

ICodeSnippetReferences Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippets Interface

ICodeSnippets Interface
Represents collection containing list of code snippets.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippets : ICodeSnippetsProvider,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Interface ICodeSnippets
    Inherits ICodeSnippetsProvider, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public interface class ICodeSnippets : ICodeSnippetsProvider,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type ICodeSnippets =
    interface
        interface ICodeSnippetsProvider
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The ICodeSnippets type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddSnippet | When implemented by a class, adds a new item to the ICodeSnippets collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | FindByShortcut | When implemented by a class, gets a code snippet by its shortcut. (Inherited from ICodeSnippetsProvider.)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertSnippet | When implemented by a class, inserts a new item to the specified position within the ICodeSnippets collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | ShouldIndent | When implemented by a class, gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control. (Inherited from ICodeSnippetsProvider.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to ICodeSnippet objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippets Methods

ICodeSnippets Methods

The ICodeSnippets type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddSnippet | When implemented by a class, adds a new item to the ICodeSnippets collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | FindByShortcut | When implemented by a class, gets a code snippet by its shortcut. (Inherited from ICodeSnippetsProvider.)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertSnippet | When implemented by a class, inserts a new item to the specified position within the ICodeSnippets collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | ShouldIndent | When implemented by a class, gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control. (Inherited from ICodeSnippetsProvider.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippets Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippets.AddSnippet Method

ICodeSnippetsAddSnippet Method
When implemented by a class, adds a new item to the ICodeSnippets collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippet AddSnippet()
Function AddSnippet As ICodeSnippet
ICodeSnippet^ AddSnippet()
abstract AddSnippet : unit -> ICodeSnippet

Return Value

Type: ICodeSnippet
ICodeSnippet that is added.
See Also

Reference

ICodeSnippets Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippets.InsertSnippet Method

ICodeSnippetsInsertSnippet Method
When implemented by a class, inserts a new item to the specified position within the ICodeSnippets collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippet InsertSnippet(
    int index
)
Function InsertSnippet (
    index As Integer
) As ICodeSnippet
ICodeSnippet^ InsertSnippet(
    int index
)
abstract InsertSnippet :
        index : int -> ICodeSnippet

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippet
ICodeSnippet that is inserted.
See Also

Reference

ICodeSnippets Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippets Properties

ICodeSnippets Properties

The ICodeSnippets type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to ICodeSnippet objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeSnippets Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippets.Item Property

ICodeSnippetsItem Property
When implemented by a class, provides an indexed access to ICodeSnippet objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippet this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As ICodeSnippet
    Get
property ICodeSnippet^ default[int index] {
    ICodeSnippet^ get (int index);
}
abstract Item : ICodeSnippet with get

Parameters

index
Type: SystemInt32

Property Value

Type: ICodeSnippet
See Also

Reference

ICodeSnippets Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippets Events

ICodeSnippets Events

The ICodeSnippets type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeSnippets Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetsProvider Interface

ICodeSnippetsProvider Interface
Represents base interface for code snippets provider.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetsProvider : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>,
    IEnumerable, IExport, IImport
Public Interface ICodeSnippetsProvider
    Inherits ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem), ICollection(Of ICodeCompletionProviderItem),
    IEnumerable(Of ICodeCompletionProviderItem), IEnumerable, IExport, IImport
public interface class ICodeSnippetsProvider : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>,
    IEnumerable, IExport, IImport
type ICodeSnippetsProvider =
    interface
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The ICodeSnippetsProvider type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | FindByShortcut | When implemented by a class, gets a code snippet by its shortcut.
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | ShouldIndent | When implemented by a class, gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetsProvider Methods

ICodeSnippetsProvider Methods

The ICodeSnippetsProvider type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | FindByShortcut | When implemented by a class, gets a code snippet by its shortcut.
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | ShouldIndent | When implemented by a class, gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippetsProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetsProvider.FindByShortcut Method

ICodeSnippetsProviderFindByShortcut Method
When implemented by a class, gets a code snippet by its shortcut.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippet FindByShortcut(
    string shortcut,
    bool caseSensitive
)
Function FindByShortcut (
    shortcut As String,
    caseSensitive As Boolean
) As ICodeSnippet
ICodeSnippet^ FindByShortcut(
    String^ shortcut,
    bool caseSensitive
)
abstract FindByShortcut :
        shortcut : string *
        caseSensitive : bool -> ICodeSnippet

Parameters

shortcut
Type: SystemString
caseSensitive
Type: SystemBoolean

Return Value

Type: ICodeSnippet
See Also

Reference

ICodeSnippetsProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetsProvider.ShouldIndent Method

ICodeSnippetsProviderShouldIndent Method
When implemented by a class, gets a boolean value indicating whether the multi-line snippet code should be indented when inserting to the edit control.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShouldIndent(
    ICodeSnippet snippet
)
Function ShouldIndent (
    snippet As ICodeSnippet
) As Boolean
bool ShouldIndent(
    ICodeSnippet^ snippet
)
abstract ShouldIndent :
        snippet : ICodeSnippet -> bool

Parameters

snippet
Type: Alternet.Syntax.CodeCompletionICodeSnippet
Specifies given snippet.

Return Value

Type: Boolean
True if code should be indented, otherwise False.
See Also

Reference

ICodeSnippetsProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetsProvider Properties

ICodeSnippetsProvider Properties

The ICodeSnippetsProvider type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeSnippetsProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetsProvider Events

ICodeSnippetsProvider Events

The ICodeSnippetsProvider type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICodeSnippetsProvider Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetType Interface

ICodeSnippetType Interface
Specifies how the code snippet is inserted into the code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetType : ICodeCompletionProviderItem,
    IComparable
Public Interface ICodeSnippetType
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICodeSnippetType : ICodeCompletionProviderItem,
    IComparable
type ICodeSnippetType =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICodeSnippetType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | SnippetType | When implemented by a class, specifies how the code snippet is inserted into the code.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetType Methods

ICodeSnippetType Methods

The ICodeSnippetType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICodeSnippetType Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetType Properties

ICodeSnippetType Properties

The ICodeSnippetType type exposes the following members.

Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | SnippetType | When implemented by a class, specifies how the code snippet is inserted into the code.
Top
See Also

Reference

ICodeSnippetType Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetType.SnippetType Property

ICodeSnippetTypeSnippetType Property
When implemented by a class, specifies how the code snippet is inserted into the code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SnippetType SnippetType { get; set; }
Property SnippetType As SnippetType
    Get
    Set
property SnippetType SnippetType {
    SnippetType get ();
    void set (SnippetType value);
}
abstract SnippetType : SnippetType with get, set

Property Value

Type: SnippetType
See Also

Reference

ICodeSnippetType Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetTypes Interface

ICodeSnippetTypes Interface
Specifies how the code snippet is inserted into the code.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICodeSnippetTypes : IList<ICodeSnippetType>,
    ICollection<ICodeSnippetType>, IEnumerable<ICodeSnippetType>, IEnumerable
Public Interface ICodeSnippetTypes
    Inherits IList(Of ICodeSnippetType), ICollection(Of ICodeSnippetType),
    IEnumerable(Of ICodeSnippetType), IEnumerable
public interface class ICodeSnippetTypes : IList<ICodeSnippetType^>,
    ICollection<ICodeSnippetType^>, IEnumerable<ICodeSnippetType^>, IEnumerable
type ICodeSnippetTypes =
    interface
        interface IList<ICodeSnippetType>
        interface ICollection<ICodeSnippetType>
        interface IEnumerable<ICodeSnippetType>
        interface IEnumerable
    end

The ICodeSnippetTypes type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetType .)
Public method | AddSnippetType | When implemented by a class, adds a new item to the specified position within the ICodeSnippetTypes collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetType .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetType .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetType .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetType .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetType .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetType .)
Public method | InsertSnippetType | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetTypes collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetType .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetType .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetType | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetType | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetType, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetType .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetType .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetType .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetTypes Methods

ICodeSnippetTypes Methods

The ICodeSnippetTypes type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeSnippetType .)
Public method | AddSnippetType | When implemented by a class, adds a new item to the specified position within the ICodeSnippetTypes collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeSnippetType .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeSnippetType .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeSnippetType .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeSnippetType .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeSnippetType .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeSnippetType .)
Public method | InsertSnippetType | When implemented by a class, inserts a new item to the specified position within the ICodeSnippetTypes collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeSnippetType .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeSnippetType .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeSnippetType | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeSnippetType | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeSnippetType, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICodeSnippetTypes Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetTypes.AddSnippetType Method

ICodeSnippetTypesAddSnippetType Method
When implemented by a class, adds a new item to the specified position within the ICodeSnippetTypes collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetType AddSnippetType()
Function AddSnippetType As ICodeSnippetType
ICodeSnippetType^ AddSnippetType()
abstract AddSnippetType : unit -> ICodeSnippetType

Return Value

Type: ICodeSnippetType
ICodeSnippetType that is added.
See Also

Reference

ICodeSnippetTypes Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetTypes.InsertSnippetType Method

ICodeSnippetTypesInsertSnippetType Method
When implemented by a class, inserts a new item to the specified position within the ICodeSnippetTypes collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeSnippetType InsertSnippetType(
    int index
)
Function InsertSnippetType (
    index As Integer
) As ICodeSnippetType
ICodeSnippetType^ InsertSnippetType(
    int index
)
abstract InsertSnippetType :
        index : int -> ICodeSnippetType

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ICodeSnippetType
ICodeSnippetType that is inserted.
See Also

Reference

ICodeSnippetTypes Interface
Alternet.Syntax.CodeCompletion Namespace


ICodeSnippetTypes Properties

ICodeSnippetTypes Properties

The ICodeSnippetTypes type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeSnippetType .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeSnippetType .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeSnippetType .)
Top
See Also

Reference

ICodeSnippetTypes Interface
Alternet.Syntax.CodeCompletion Namespace


ICommentInfo Interface

ICommentInfo Interface
Represents simple text data related to popup hint.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICommentInfo : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>,
    IEnumerable, IExport, IImport
Public Interface ICommentInfo
    Inherits ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem), ICollection(Of ICodeCompletionProviderItem),
    IEnumerable(Of ICodeCompletionProviderItem), IEnumerable, IExport, IImport
public interface class ICommentInfo : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>,
    IEnumerable, IExport, IImport
type ICommentInfo =
    interface
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The ICommentInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | Text | When implemented by a class, gets or sets content of the IQuickInfo.
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICommentInfo Methods

ICommentInfo Methods

The ICommentInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ICommentInfo Interface
Alternet.Syntax.CodeCompletion Namespace


ICommentInfo Properties

ICommentInfo Properties

The ICommentInfo type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | Text | When implemented by a class, gets or sets content of the IQuickInfo.
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICommentInfo Interface
Alternet.Syntax.CodeCompletion Namespace


ICommentInfo.Text Property

ICommentInfoText Property
When implemented by a class, gets or sets content of the IQuickInfo.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

ICommentInfo Interface
Alternet.Syntax.CodeCompletion Namespace


ICommentInfo Events

ICommentInfo Events

The ICommentInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

ICommentInfo Interface
Alternet.Syntax.CodeCompletion Namespace


ICommentInfoItem Interface

ICommentInfoItem Interface
Stores simple text data related to popup hint.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICommentInfoItem : ICodeCompletionProviderItem,
    IComparable
Public Interface ICommentInfoItem
    Inherits ICodeCompletionProviderItem, IComparable
public interface class ICommentInfoItem : ICodeCompletionProviderItem,
    IComparable
type ICommentInfoItem =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ICommentInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Text | When implemented by a class, gets or sets content of the CommentInfoItem.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ICommentInfoItem Methods

ICommentInfoItem Methods

The ICommentInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

ICommentInfoItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICommentInfoItem Properties

ICommentInfoItem Properties

The ICommentInfoItem type exposes the following members.

Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Text | When implemented by a class, gets or sets content of the CommentInfoItem.
Top
See Also

Reference

ICommentInfoItem Interface
Alternet.Syntax.CodeCompletion Namespace


ICommentInfoItem.Text Property

ICommentInfoItemText Property
When implemented by a class, gets or sets content of the CommentInfoItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

ICommentInfoItem Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember Interface

IListMember Interface
Represents properties and methods for a particular list member in the data collection of the code completion popups.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IListMember : ICodeCompletionProviderItem,
    IComparable
Public Interface IListMember
    Inherits ICodeCompletionProviderItem, IComparable
public interface class IListMember : ICodeCompletionProviderItem,
    IComparable
type IListMember =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The IListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | When implemented by a class, appends text to the member description.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | GetParamText | When implemented by a class, converts Parameters property to a single string.
Public method | GetTemplate | When implemented by a class, return member's template.
Top
Properties
 | Name | Description
Public property | Attributes | When implemented by a class, gets or sets additional attributes associated with a member.
Public property | CurrentParamIndex | When implemented by a class, gets or sets index of current parameter in the parameters collection.
Public property | CustomData | When implemented by a class, gets or sets an object that can hold a user defined data attached to the IListMember.
Public property | DataType | When implemented by a class, gets or sets a string value that specifies data type of the IListMember.
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of the IListMember.
Public property | DisplayText | When implemented by a class, gets or sets a string value displayed as a "name" part of IListMember.
Public property | Image | When implemented by a class, gets or sets the image displayed for the IListMember.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the IListMember.
Public property | InsertText | When implemented by a class, gets or sets a string value inserted in the text editor when IListMember is selected.
Public property | MemberType | When implemented by a class, gets or sets the integer value representing type of the member.
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the IListMember collection.
Public property | Overloads | When implemented by a class, gets or sets number of overloading members IListMember in the collection.
Public property | Owner | When implemented by a class, gets IListMembers instance owning the ListMember.
Public property | Parameters | When implemented by a class, gets or sets a collection of parameters of this IListMember.
Public property | ParamText | When implemented by a class, gets or sets a string value that specifies comma separated list of parameters of the IListMember.
Public property | Priority | When implemented by a class, gets or sets priority of the ListMember.
Public property | Qualifier | When implemented by a class, gets or sets a string value that specifies access modifiers of the IListMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IListMember Methods

IListMember Methods

The IListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | When implemented by a class, appends text to the member description.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | GetParamText | When implemented by a class, converts Parameters property to a single string.
Public method | GetTemplate | When implemented by a class, return member's template.
Top
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.AddDescription Method

IListMemberAddDescription Method
When implemented by a class, appends text to the member description.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddDescription(
    string text
)
Sub AddDescription (
    text As String
)
void AddDescription(
    String^ text
)
abstract AddDescription :
        text : string -> unit

Parameters

text
Type: SystemString
Text to add.
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.GetParamText Method

IListMemberGetParamText Method
When implemented by a class, converts Parameters property to a single string.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetParamText(
    bool useFormatting
)
Function GetParamText (
    useFormatting As Boolean
) As String
String^ GetParamText(
    bool useFormatting
)
abstract GetParamText :
        useFormatting : bool -> string

Parameters

useFormatting
Type: SystemBoolean
Specifies whether to use html formatting.

Return Value

Type: String
Returns Parameters in the form of comma separated text, framed by parentheses.
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.GetTemplate Method

IListMemberGetTemplate Method
When implemented by a class, return member's template.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetTemplate(
    bool compact
)
Function GetTemplate (
    compact As Boolean
) As String
String^ GetTemplate(
    bool compact
)
abstract GetTemplate :
        compact : bool -> string

Parameters

compact
Type: SystemBoolean
Indicates if template is in a compact form.

Return Value

Type: String
String value that represents member template.
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember Properties

IListMember Properties

The IListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | When implemented by a class, gets or sets additional attributes associated with a member.
Public property | CurrentParamIndex | When implemented by a class, gets or sets index of current parameter in the parameters collection.
Public property | CustomData | When implemented by a class, gets or sets an object that can hold a user defined data attached to the IListMember.
Public property | DataType | When implemented by a class, gets or sets a string value that specifies data type of the IListMember.
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of the IListMember.
Public property | DisplayText | When implemented by a class, gets or sets a string value displayed as a "name" part of IListMember.
Public property | Image | When implemented by a class, gets or sets the image displayed for the IListMember.
Public property | ImageIndex | When implemented by a class, gets or sets the index of the image displayed for the IListMember.
Public property | InsertText | When implemented by a class, gets or sets a string value inserted in the text editor when IListMember is selected.
Public property | MemberType | When implemented by a class, gets or sets the integer value representing type of the member.
Public property | Name | When implemented by a class, gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the IListMember collection.
Public property | Overloads | When implemented by a class, gets or sets number of overloading members IListMember in the collection.
Public property | Owner | When implemented by a class, gets IListMembers instance owning the ListMember.
Public property | Parameters | When implemented by a class, gets or sets a collection of parameters of this IListMember.
Public property | ParamText | When implemented by a class, gets or sets a string value that specifies comma separated list of parameters of the IListMember.
Public property | Priority | When implemented by a class, gets or sets priority of the ListMember.
Public property | Qualifier | When implemented by a class, gets or sets a string value that specifies access modifiers of the IListMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Top
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.Attributes Property

IListMemberAttributes Property
When implemented by a class, gets or sets additional attributes associated with a member.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
MemberAttribute Attributes { get; set; }
Property Attributes As MemberAttribute
    Get
    Set
property MemberAttribute Attributes {
    MemberAttribute get ();
    void set (MemberAttribute value);
}
abstract Attributes : MemberAttribute with get, set

Property Value

Type: MemberAttribute
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.CurrentParamIndex Property

IListMemberCurrentParamIndex Property
When implemented by a class, gets or sets index of current parameter in the parameters collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int CurrentParamIndex { get; set; }
Property CurrentParamIndex As Integer
    Get
    Set
property int CurrentParamIndex {
    int get ();
    void set (int value);
}
abstract CurrentParamIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.CustomData Property

IListMemberCustomData Property
When implemented by a class, gets or sets an object that can hold a user defined data attached to the IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object CustomData { get; set; }
Property CustomData As Object
    Get
    Set
property Object^ CustomData {
    Object^ get ();
    void set (Object^ value);
}
abstract CustomData : Object with get, set

Property Value

Type: Object
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.DataType Property

IListMemberDataType Property
When implemented by a class, gets or sets a string value that specifies data type of the IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string DataType { get; set; }
Property DataType As String
    Get
    Set
property String^ DataType {
    String^ get ();
    void set (String^ value);
}
abstract DataType : string with get, set

Property Value

Type: String
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.Description Property

IListMemberDescription Property
When implemented by a class, gets or sets a string value that specifies short description of the IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.DisplayText Property

IListMemberDisplayText Property
When implemented by a class, gets or sets a string value displayed as a "name" part of IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string DisplayText { get; set; }
Property DisplayText As String
    Get
    Set
property String^ DisplayText {
    String^ get ();
    void set (String^ value);
}
abstract DisplayText : string with get, set

Property Value

Type: String
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.Image Property

IListMemberImage Property
When implemented by a class, gets or sets the image displayed for the IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Image Image { get; set; }
Property Image As Image
    Get
    Set
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
abstract Image : Image with get, set

Property Value

Type: Image
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.ImageIndex Property

IListMemberImageIndex Property
When implemented by a class, gets or sets the index of the image displayed for the IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ImageIndex { get; set; }
Property ImageIndex As Integer
    Get
    Set
property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.InsertText Property

IListMemberInsertText Property
When implemented by a class, gets or sets a string value inserted in the text editor when IListMember is selected.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string InsertText { get; set; }
Property InsertText As String
    Get
    Set
property String^ InsertText {
    String^ get ();
    void set (String^ value);
}
abstract InsertText : string with get, set

Property Value

Type: String
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.MemberType Property

IListMemberMemberType Property
When implemented by a class, gets or sets the integer value representing type of the member.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int MemberType { get; set; }
Property MemberType As Integer
    Get
    Set
property int MemberType {
    int get ();
    void set (int value);
}
abstract MemberType : int with get, set

Property Value

Type: Int32
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.Name Property

IListMemberName Property
When implemented by a class, gets or sets a string value that specifies the name of the IListMember. Useful to find necessary item within the IListMember collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.Overloads Property

IListMemberOverloads Property
When implemented by a class, gets or sets number of overloading members IListMember in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Overloads { get; set; }
Property Overloads As Integer
    Get
    Set
property int Overloads {
    int get ();
    void set (int value);
}
abstract Overloads : int with get, set

Property Value

Type: Int32
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.Owner Property

IListMemberOwner Property
When implemented by a class, gets IListMembers instance owning the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IListMembers Owner { get; set; }
Property Owner As IListMembers
    Get
    Set
property IListMembers^ Owner {
    IListMembers^ get ();
    void set (IListMembers^ value);
}
abstract Owner : IListMembers with get, set

Property Value

Type: IListMembers
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.Parameters Property

IListMemberParameters Property
When implemented by a class, gets or sets a collection of parameters of this IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IParameterMembers Parameters { get; set; }
Property Parameters As IParameterMembers
    Get
    Set
property IParameterMembers^ Parameters {
    IParameterMembers^ get ();
    void set (IParameterMembers^ value);
}
abstract Parameters : IParameterMembers with get, set

Property Value

Type: IParameterMembers
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.ParamText Property

IListMemberParamText Property
When implemented by a class, gets or sets a string value that specifies comma separated list of parameters of the IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ParamText { get; set; }
Property ParamText As String
    Get
    Set
property String^ ParamText {
    String^ get ();
    void set (String^ value);
}
abstract ParamText : string with get, set

Property Value

Type: String
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.Priority Property

IListMemberPriority Property
When implemented by a class, gets or sets priority of the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Priority { get; set; }
Property Priority As Integer
    Get
    Set
property int Priority {
    int get ();
    void set (int value);
}
abstract Priority : int with get, set

Property Value

Type: Int32
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMember.Qualifier Property

IListMemberQualifier Property
When implemented by a class, gets or sets a string value that specifies access modifiers of the IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Qualifier { get; set; }
Property Qualifier As String
    Get
    Set
property String^ Qualifier {
    String^ get ();
    void set (String^ value);
}
abstract Qualifier : string with get, set

Property Value

Type: String
See Also

Reference

IListMember Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers Interface

IListMembers Interface
Represents data collection related to popup list box controls.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IListMembers : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>,
    IEnumerable, IExport, IImport
Public Interface IListMembers
    Inherits ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem), ICollection(Of ICodeCompletionProviderItem),
    IEnumerable(Of ICodeCompletionProviderItem), IEnumerable, IExport, IImport
public interface class IListMembers : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>,
    IEnumerable, IExport, IImport
type IListMembers =
    interface
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The IListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddListMember | When implemented by a class, adds a new item to the IListMembers collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings.
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertListMember | When implemented by a class, inserts a new item to the specified position within the IListMembers collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | ResetShowHints | When implemented by a class, resets the ShowHints to the default value.
Public method | ResetShowParams | When implemented by a class, resets the ShowParams to the default value.
Public method | ResetShowQualifiers | When implemented by a class, resets the ShowQualifiers to the default value.
Public method | ResetShowResults | When implemented by a class, resets the ShowResults to the default value.
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to IListMember objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowHints | When implemented by a class, gets or sets a value indicating whether popup listbox should display additional information for selected list member.
Public property | ShowParams | When implemented by a class, gets or sets a value indicating whether the "Params" column is visible.
Public property | ShowQualifiers | When implemented by a class, gets or sets a value indicating whether the "Qualifiers" column is visible.
Public property | ShowResults | When implemented by a class, gets or sets a value indicating whether the "Results" column is visible.
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IListMembers Methods

IListMembers Methods

The IListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddListMember | When implemented by a class, adds a new item to the IListMembers collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings.
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertListMember | When implemented by a class, inserts a new item to the specified position within the IListMembers collection.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | ResetShowHints | When implemented by a class, resets the ShowHints to the default value.
Public method | ResetShowParams | When implemented by a class, resets the ShowParams to the default value.
Public method | ResetShowQualifiers | When implemented by a class, resets the ShowQualifiers to the default value.
Public method | ResetShowResults | When implemented by a class, resets the ShowResults to the default value.
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.AddListMember Method

IListMembersAddListMember Method
When implemented by a class, adds a new item to the IListMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IListMember AddListMember()
Function AddListMember As IListMember
IListMember^ AddListMember()
abstract AddListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that is added.
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.CreateListMember Method

IListMembersCreateListMember Method
Initializes a new instance of the ListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IListMember CreateListMember()
Function CreateListMember As IListMember
IListMember^ CreateListMember()
abstract CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.InsertListMember Method

IListMembersInsertListMember Method
When implemented by a class, inserts a new item to the specified position within the IListMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IListMember InsertListMember(
    int index
)
Function InsertListMember (
    index As Integer
) As IListMember
IListMember^ InsertListMember(
    int index
)
abstract InsertListMember :
        index : int -> IListMember

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: IListMember
IListMember that is inserted.
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.ResetShowHints Method

IListMembersResetShowHints Method
When implemented by a class, resets the ShowHints to the default value.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetShowHints()
Sub ResetShowHints
void ResetShowHints()
abstract ResetShowHints : unit -> unit
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.ResetShowParams Method

IListMembersResetShowParams Method
When implemented by a class, resets the ShowParams to the default value.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetShowParams()
Sub ResetShowParams
void ResetShowParams()
abstract ResetShowParams : unit -> unit
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.ResetShowQualifiers Method

IListMembersResetShowQualifiers Method
When implemented by a class, resets the ShowQualifiers to the default value.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetShowQualifiers()
Sub ResetShowQualifiers
void ResetShowQualifiers()
abstract ResetShowQualifiers : unit -> unit
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.ResetShowResults Method

IListMembersResetShowResults Method
When implemented by a class, resets the ShowResults to the default value.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetShowResults()
Sub ResetShowResults
void ResetShowResults()
abstract ResetShowResults : unit -> unit
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers Properties

IListMembers Properties

The IListMembers type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to IListMember objects stored in the collection.
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowHints | When implemented by a class, gets or sets a value indicating whether popup listbox should display additional information for selected list member.
Public property | ShowParams | When implemented by a class, gets or sets a value indicating whether the "Params" column is visible.
Public property | ShowQualifiers | When implemented by a class, gets or sets a value indicating whether the "Qualifiers" column is visible.
Public property | ShowResults | When implemented by a class, gets or sets a value indicating whether the "Results" column is visible.
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.Item Property

IListMembersItem Property
When implemented by a class, provides an indexed access to IListMember objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IListMember this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As IListMember
    Get
property IListMember^ default[int index] {
    IListMember^ get (int index);
}
abstract Item : IListMember with get

Parameters

index
Type: SystemInt32

Property Value

Type: IListMember
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.ShowHints Property

IListMembersShowHints Property
When implemented by a class, gets or sets a value indicating whether popup listbox should display additional information for selected list member.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowHints { get; set; }
Property ShowHints As Boolean
    Get
    Set
property bool ShowHints {
    bool get ();
    void set (bool value);
}
abstract ShowHints : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.ShowParams Property

IListMembersShowParams Property
When implemented by a class, gets or sets a value indicating whether the "Params" column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowParams { get; set; }
Property ShowParams As Boolean
    Get
    Set
property bool ShowParams {
    bool get ();
    void set (bool value);
}
abstract ShowParams : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.ShowQualifiers Property

IListMembersShowQualifiers Property
When implemented by a class, gets or sets a value indicating whether the "Qualifiers" column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowQualifiers { get; set; }
Property ShowQualifiers As Boolean
    Get
    Set
property bool ShowQualifiers {
    bool get ();
    void set (bool value);
}
abstract ShowQualifiers : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers.ShowResults Property

IListMembersShowResults Property
When implemented by a class, gets or sets a value indicating whether the "Results" column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShowResults { get; set; }
Property ShowResults As Boolean
    Get
    Set
property bool ShowResults {
    bool get ();
    void set (bool value);
}
abstract ShowResults : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IListMembers Events

IListMembers Events

The IListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

IListMembers Interface
Alternet.Syntax.CodeCompletion Namespace


INetNamespace Interface

INetNamespace Interface
Represents a .NET namespace.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INetNamespace
Public Interface INetNamespace
public interface class INetNamespace
type INetNamespace =  interface end

The INetNamespace type exposes the following members.

Methods
 | Name | Description
Public method | GetName | When implemented by a class, gets name or alias of the namespace.
Top
Properties
 | Name | Description
Public property | Alias | When implemented by a class, gets or sets alias of the namespace.
Public property | Namespace | When implemented by a class, gets or sets name of the namespace.
Public property | System | Reserved for internal use.
Public property | UserData | Reserved for internal use.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


INetNamespace Methods

INetNamespace Methods

The INetNamespace type exposes the following members.

Methods
 | Name | Description
Public method | GetName | When implemented by a class, gets name or alias of the namespace.
Top
See Also

Reference

INetNamespace Interface
Alternet.Syntax.CodeCompletion Namespace


INetNamespace.GetName Method

INetNamespaceGetName Method
When implemented by a class, gets name or alias of the namespace.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetName()
Function GetName As String
String^ GetName()
abstract GetName : unit -> string

Return Value

Type: String
See Also

Reference

INetNamespace Interface
Alternet.Syntax.CodeCompletion Namespace


INetNamespace Properties

INetNamespace Properties

The INetNamespace type exposes the following members.

Properties
 | Name | Description
Public property | Alias | When implemented by a class, gets or sets alias of the namespace.
Public property | Namespace | When implemented by a class, gets or sets name of the namespace.
Public property | System | Reserved for internal use.
Public property | UserData | Reserved for internal use.
Top
See Also

Reference

INetNamespace Interface
Alternet.Syntax.CodeCompletion Namespace


INetNamespace.Alias Property

INetNamespaceAlias Property
When implemented by a class, gets or sets alias of the namespace.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Alias { get; set; }
Property Alias As String
    Get
    Set
property String^ Alias {
    String^ get ();
    void set (String^ value);
}
abstract Alias : string with get, set

Property Value

Type: String
See Also

Reference

INetNamespace Interface
Alternet.Syntax.CodeCompletion Namespace


INetNamespace.Namespace Property

INetNamespaceNamespace Property
When implemented by a class, gets or sets name of the namespace.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Namespace { get; set; }
Property Namespace As String
    Get
    Set
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}
abstract Namespace : string with get, set

Property Value

Type: String
See Also

Reference

INetNamespace Interface
Alternet.Syntax.CodeCompletion Namespace


INetNamespace.System Property

INetNamespaceSystem Property
Reserved for internal use.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool System { get; set; }
Property System As Boolean
    Get
    Set
property bool System {
    bool get ();
    void set (bool value);
}
abstract System : bool with get, set

Property Value

Type: Boolean
See Also

Reference

INetNamespace Interface
Alternet.Syntax.CodeCompletion Namespace


INetNamespace.UserData Property

INetNamespaceUserData Property
Reserved for internal use.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Object UserData { get; set; }
Property UserData As Object
    Get
    Set
property Object^ UserData {
    Object^ get ();
    void set (Object^ value);
}
abstract UserData : Object with get, set

Property Value

Type: Object
See Also

Reference

INetNamespace Interface
Alternet.Syntax.CodeCompletion Namespace


INETRepository Interface

INETRepository Interface
Represents properties and methods to perform code completion functionality intended to use for .NET family of languages.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INETRepository
Public Interface INETRepository
public interface class INETRepository
type INETRepository =  interface end

The INETRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetAutoFormatNode | When implemented by a class, Obtains block node at specified position.
Public method | GetCommentTemplate | When implemented by a class, returns xml comment template for given node in the text.
Public method | GetDeclarationNode | When implemented by a class, retrieves declaration node nearest to the specified node.
Public method | GetXmlReferenceNode | When implemented by a class, returns declaration node corresponding to xml comment.
Public method | IsDeclarationNode(ISyntaxNode) | When implemented by a class, indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | When implemented by a class, indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Public method | SmartFormatLine | When implemented by a class, formats line according to the parser rules.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


INETRepository Methods

INETRepository Methods

The INETRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetAutoFormatNode | When implemented by a class, Obtains block node at specified position.
Public method | GetCommentTemplate | When implemented by a class, returns xml comment template for given node in the text.
Public method | GetDeclarationNode | When implemented by a class, retrieves declaration node nearest to the specified node.
Public method | GetXmlReferenceNode | When implemented by a class, returns declaration node corresponding to xml comment.
Public method | IsDeclarationNode(ISyntaxNode) | When implemented by a class, indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | When implemented by a class, indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Public method | SmartFormatLine | When implemented by a class, formats line according to the parser rules.
Top
See Also

Reference

INETRepository Interface
Alternet.Syntax.CodeCompletion Namespace


INETRepository.GetAutoFormatNode Method

INETRepositoryGetAutoFormatNode Method
When implemented by a class, Obtains block node at specified position.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode GetAutoFormatNode(
    ISyntaxNode node,
    bool extended,
    out Point startPt
)
Function GetAutoFormatNode (
    node As ISyntaxNode,
    extended As Boolean,
    <OutAttribute> ByRef startPt As Point
) As ISyntaxNode
ISyntaxNode^ GetAutoFormatNode(
    ISyntaxNode^ node,
    bool extended,
    [OutAttribute] Point% startPt
)
abstract GetAutoFormatNode :
        node : ISyntaxNode *
        extended : bool *
        startPt : Point byref -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Node to check-up.
extended
Type: SystemBoolean
Specifies that search should be extended outside current scope
startPt
Type: System.DrawingPoint
Retrieves position of block node.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.
See Also

Reference

INETRepository Interface
Alternet.Syntax.CodeCompletion Namespace


INETRepository.GetCommentTemplate Method

INETRepositoryGetCommentTemplate Method
When implemented by a class, returns xml comment template for given node in the text.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetCommentTemplate(
    Point position,
    ISyntaxNode node,
    string comment
)
Function GetCommentTemplate (
    position As Point,
    node As ISyntaxNode,
    comment As String
) As String
String^ GetCommentTemplate(
    Point position,
    ISyntaxNode^ node,
    String^ comment
)
abstract GetCommentTemplate :
        position : Point *
        node : ISyntaxNode *
        comment : string -> string

Parameters

position
Type: System.DrawingPoint
Specifies position within the text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies node at given position.
comment
Type: SystemString
Specifies xml comment starting string.

Return Value

Type: String
Xml comment template.
See Also

Reference

INETRepository Interface
Alternet.Syntax.CodeCompletion Namespace


INETRepository.GetDeclarationNode Method

INETRepositoryGetDeclarationNode Method
When implemented by a class, retrieves declaration node nearest to the specified node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode GetDeclarationNode(
    ISyntaxNode node
)
Function GetDeclarationNode (
    node As ISyntaxNode
) As ISyntaxNode
ISyntaxNode^ GetDeclarationNode(
    ISyntaxNode^ node
)
abstract GetDeclarationNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing some declaration.
See Also

Reference

INETRepository Interface
Alternet.Syntax.CodeCompletion Namespace


INETRepository.GetXmlReferenceNode Method

INETRepositoryGetXmlReferenceNode Method
When implemented by a class, returns declaration node corresponding to xml comment.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISyntaxNode GetXmlReferenceNode(
    ISyntaxNode node
)
Function GetXmlReferenceNode (
    node As ISyntaxNode
) As ISyntaxNode
ISyntaxNode^ GetXmlReferenceNode(
    ISyntaxNode^ node
)
abstract GetXmlReferenceNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Xml comment node.

Return Value

Type: ISyntaxNode
Declaration node if found; otherwise null.
See Also

Reference

INETRepository Interface
Alternet.Syntax.CodeCompletion Namespace


INETRepository.IsDeclarationNode Method

INETRepositoryIsDeclarationNode Method
Overload List
 | Name | Description
Public method | IsDeclarationNode(ISyntaxNode) | When implemented by a class, indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | When implemented by a class, indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Top
See Also

Reference

INETRepository Interface
Alternet.Syntax.CodeCompletion Namespace


INETRepository.IsDeclarationNode Method (ISyntaxNode)

INETRepositoryIsDeclarationNode Method (ISyntaxNode)
When implemented by a class, indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsDeclarationNode(
    ISyntaxNode node
)
Function IsDeclarationNode (
    node As ISyntaxNode
) As Boolean
bool IsDeclarationNode(
    ISyntaxNode^ node
)
abstract IsDeclarationNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is declaration node; otherwise false.
See Also

Reference

INETRepository Interface
IsDeclarationNode Overload
Alternet.Syntax.CodeCompletion Namespace


INETRepository.IsDeclarationNode Method (ISyntaxNode, Boolean)

INETRepositoryIsDeclarationNode Method (ISyntaxNode, Boolean)
When implemented by a class, indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsDeclarationNode(
    ref ISyntaxNode node,
    bool checkRegions
)
Function IsDeclarationNode (
    ByRef node As ISyntaxNode,
    checkRegions As Boolean
) As Boolean
bool IsDeclarationNode(
    ISyntaxNode^% node,
    bool checkRegions
)
abstract IsDeclarationNode :
        node : ISyntaxNode byref *
        checkRegions : bool -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.
checkRegions
Type: SystemBoolean
Indicates that region nodes should be skipped.

Return Value

Type: Boolean
True if specified node is declaration node; otherwise false.
See Also

Reference

INETRepository Interface
IsDeclarationNode Overload
Alternet.Syntax.CodeCompletion Namespace


INETRepository.SmartFormatLine Method

INETRepositorySmartFormatLine Method
When implemented by a class, formats line according to the parser rules.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ISyntaxNodes nodes,
    ITextUndoList operations
)
Sub SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    nodes As ISyntaxNodes,
    operations As ITextUndoList
)
void SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ISyntaxNodes^ nodes,
    ITextUndoList^ operations
)
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        nodes : ISyntaxNodes *
        operations : ITextUndoList -> unit

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
nodes
Type: Alternet.SyntaxISyntaxNodes
Specifies nodes collection containing given line.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
See Also

Reference

INETRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterInfo Interface

IParameterInfo Interface
Represents Parameter Info data related to popup hint controls.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IParameterInfo : IListMembers,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Interface IParameterInfo
    Inherits IListMembers, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public interface class IParameterInfo : IListMembers,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type IParameterInfo =
    interface
        interface IListMembers
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The IParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddListMember | When implemented by a class, adds a new item to the IListMembers collection. (Inherited from IListMembers.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from IListMembers.)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertListMember | When implemented by a class, inserts a new item to the specified position within the IListMembers collection. (Inherited from IListMembers.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | ResetShowHints | When implemented by a class, resets the ShowHints to the default value. (Inherited from IListMembers.)
Public method | ResetShowParams | When implemented by a class, resets the ShowParams to the default value. (Inherited from IListMembers.)
Public method | ResetShowQualifiers | When implemented by a class, resets the ShowQualifiers to the default value. (Inherited from IListMembers.)
Public method | ResetShowResults | When implemented by a class, resets the ShowResults to the default value. (Inherited from IListMembers.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to IListMember objects stored in the collection. (Inherited from IListMembers.)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowHints | When implemented by a class, gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from IListMembers.)
Public property | ShowParams | When implemented by a class, gets or sets a value indicating whether the "Params" column is visible. (Inherited from IListMembers.)
Public property | ShowQualifiers | When implemented by a class, gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from IListMembers.)
Public property | ShowResults | When implemented by a class, gets or sets a value indicating whether the "Results" column is visible. (Inherited from IListMembers.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IParameterInfo Methods

IParameterInfo Methods

The IParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | AddListMember | When implemented by a class, adds a new item to the IListMembers collection. (Inherited from IListMembers.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from IListMembers.)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | InsertListMember | When implemented by a class, inserts a new item to the specified position within the IListMembers collection. (Inherited from IListMembers.)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | ResetShowHints | When implemented by a class, resets the ShowHints to the default value. (Inherited from IListMembers.)
Public method | ResetShowParams | When implemented by a class, resets the ShowParams to the default value. (Inherited from IListMembers.)
Public method | ResetShowQualifiers | When implemented by a class, resets the ShowQualifiers to the default value. (Inherited from IListMembers.)
Public method | ResetShowResults | When implemented by a class, resets the ShowResults to the default value. (Inherited from IListMembers.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IParameterInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterInfo Properties

IParameterInfo Properties

The IParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | When implemented by a class, provides an indexed access to IListMember objects stored in the collection. (Inherited from IListMembers.)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowHints | When implemented by a class, gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from IListMembers.)
Public property | ShowParams | When implemented by a class, gets or sets a value indicating whether the "Params" column is visible. (Inherited from IListMembers.)
Public property | ShowQualifiers | When implemented by a class, gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from IListMembers.)
Public property | ShowResults | When implemented by a class, gets or sets a value indicating whether the "Results" column is visible. (Inherited from IListMembers.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

IParameterInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterInfo Events

IParameterInfo Events

The IParameterInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

IParameterInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMember Interface

IParameterMember Interface
Represents properties for a particular parameter member within list member parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IParameterMember : ICodeCompletionProviderItem,
    IComparable
Public Interface IParameterMember
    Inherits ICodeCompletionProviderItem, IComparable
public interface class IParameterMember : ICodeCompletionProviderItem,
    IComparable
type IParameterMember =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The IParameterMember type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | DataType | When implemented by a class, gets or sets a string value that specifies datatype of the IParameterMember.
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of the IParameterMember.
Public property | Modifiers | When implemented by a class, gets or sets a string value that specifies parameter modifier.
Public property | Name | When implemented by a class, gets or sets a string value that specifies name of the IParameterMember.
Public property | Qualifier | When implemented by a class, gets or sets a string value that specifies parameter modifier of the IParameterMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Text | When implemented by a class, gets or sets a string value that represents parameter text.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IParameterMember Methods

IParameterMember Methods

The IParameterMember type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

IParameterMember Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMember Properties

IParameterMember Properties

The IParameterMember type exposes the following members.

Properties
 | Name | Description
Public property | DataType | When implemented by a class, gets or sets a string value that specifies datatype of the IParameterMember.
Public property | Description | When implemented by a class, gets or sets a string value that specifies short description of the IParameterMember.
Public property | Modifiers | When implemented by a class, gets or sets a string value that specifies parameter modifier.
Public property | Name | When implemented by a class, gets or sets a string value that specifies name of the IParameterMember.
Public property | Qualifier | When implemented by a class, gets or sets a string value that specifies parameter modifier of the IParameterMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Text | When implemented by a class, gets or sets a string value that represents parameter text.
Top
See Also

Reference

IParameterMember Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMember.DataType Property

IParameterMemberDataType Property
When implemented by a class, gets or sets a string value that specifies datatype of the IParameterMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string DataType { get; set; }
Property DataType As String
    Get
    Set
property String^ DataType {
    String^ get ();
    void set (String^ value);
}
abstract DataType : string with get, set

Property Value

Type: String
See Also

Reference

IParameterMember Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMember.Description Property

IParameterMemberDescription Property
When implemented by a class, gets or sets a string value that specifies short description of the IParameterMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

IParameterMember Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMember.Modifiers Property

IParameterMemberModifiers Property
When implemented by a class, gets or sets a string value that specifies parameter modifier.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ParameterModifer Modifiers { get; set; }
Property Modifiers As ParameterModifer
    Get
    Set
property ParameterModifer Modifiers {
    ParameterModifer get ();
    void set (ParameterModifer value);
}
abstract Modifiers : ParameterModifer with get, set

Property Value

Type: ParameterModifer
See Also

Reference

IParameterMember Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMember.Name Property

IParameterMemberName Property
When implemented by a class, gets or sets a string value that specifies name of the IParameterMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IParameterMember Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMember.Qualifier Property

IParameterMemberQualifier Property
When implemented by a class, gets or sets a string value that specifies parameter modifier of the IParameterMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Qualifier { get; set; }
Property Qualifier As String
    Get
    Set
property String^ Qualifier {
    String^ get ();
    void set (String^ value);
}
abstract Qualifier : string with get, set

Property Value

Type: String
See Also

Reference

IParameterMember Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMember.Text Property

IParameterMemberText Property
When implemented by a class, gets or sets a string value that represents parameter text.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IParameterMember Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMembers Interface

IParameterMembers Interface
Represents collection containing list of parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IParameterMembers : IList<IParameterMember>,
    ICollection<IParameterMember>, IEnumerable<IParameterMember>, IEnumerable
Public Interface IParameterMembers
    Inherits IList(Of IParameterMember), ICollection(Of IParameterMember),
    IEnumerable(Of IParameterMember), IEnumerable
public interface class IParameterMembers : IList<IParameterMember^>,
    ICollection<IParameterMember^>, IEnumerable<IParameterMember^>, IEnumerable
type IParameterMembers =
    interface
        interface IList<IParameterMember>
        interface ICollection<IParameterMember>
        interface IEnumerable<IParameterMember>
        interface IEnumerable
    end

The IParameterMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIParameterMember .)
Public method | AddParameterMember | When implemented by a class, adds a new item to the IParameterMembers collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIParameterMember .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIParameterMember .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIParameterMember .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIParameterMember .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIParameterMember .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIParameterMember .)
Public method | InsertParameterMember | When implemented by a class, inserts a new item to the specified position within the IParameterMember collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIParameterMember .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIParameterMember .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIParameterMember | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIParameterMember | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIParameterMember, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIParameterMember .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIParameterMember .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIParameterMember .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IParameterMembers Methods

IParameterMembers Methods

The IParameterMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIParameterMember .)
Public method | AddParameterMember | When implemented by a class, adds a new item to the IParameterMembers collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIParameterMember .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIParameterMember .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIParameterMember .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIParameterMember .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIParameterMember .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIParameterMember .)
Public method | InsertParameterMember | When implemented by a class, inserts a new item to the specified position within the IParameterMember collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIParameterMember .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIParameterMember .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIParameterMember | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIParameterMember | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIParameterMember, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IParameterMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMembers.AddParameterMember Method

IParameterMembersAddParameterMember Method
When implemented by a class, adds a new item to the IParameterMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IParameterMember AddParameterMember()
Function AddParameterMember As IParameterMember
IParameterMember^ AddParameterMember()
abstract AddParameterMember : unit -> IParameterMember

Return Value

Type: IParameterMember
IParameterMember that is added.
See Also

Reference

IParameterMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMembers.InsertParameterMember Method

IParameterMembersInsertParameterMember Method
When implemented by a class, inserts a new item to the specified position within the IParameterMember collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IParameterMember InsertParameterMember(
    int index
)
Function InsertParameterMember (
    index As Integer
) As IParameterMember
IParameterMember^ InsertParameterMember(
    int index
)
abstract InsertParameterMember :
        index : int -> IParameterMember

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: IParameterMember
IParameterMember that is inserted.
See Also

Reference

IParameterMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IParameterMembers Properties

IParameterMembers Properties

The IParameterMembers type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIParameterMember .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIParameterMember .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIParameterMember .)
Top
See Also

Reference

IParameterMembers Interface
Alternet.Syntax.CodeCompletion Namespace


IQuickInfo Interface

IQuickInfo Interface
Represents simple text data related to popup hint.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IQuickInfo : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>,
    IEnumerable, IExport, IImport
Public Interface IQuickInfo
    Inherits ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem), ICollection(Of ICodeCompletionProviderItem),
    IEnumerable(Of ICodeCompletionProviderItem), IEnumerable, IExport, IImport
public interface class IQuickInfo : ICodeCompletionProvider,
    IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>,
    IEnumerable, IExport, IImport
type IQuickInfo =
    interface
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The IQuickInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | CanEvaluateSymbol | When implemented by a class, gets or sets a boolean value indicating if the symbol can be evaluated at run-time
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | Symbol | When implemented by a class, gets or sets quick info symbol
Public property | Text | When implemented by a class, gets or sets content of the IQuickInfo.
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IQuickInfo Methods

IQuickInfo Methods

The IQuickInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | ColumnSpace | When implemented by a class, indicates whether after specified column SPACE is required. (Inherited from ICodeCompletionProvider.)
Public method | ColumnVisible | When implemented by a class, indicates whether specified column is visible. (Inherited from ICodeCompletionProvider.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | GetColumnText | When implemented by a class, returns text from given item in the specified column. (Inherited from ICodeCompletionProvider.)
Public method | GetDescription | When implemented by a class, returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ICodeCompletionProvider.)
Public method | GetDisplayText | When implemented by a class, returns string representing the display text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableICodeCompletionProviderItem .)
Public method | GetFullDisplayText | When implemented by a class, returns string representing full text of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetImage | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetImageIndex | When implemented by a class, returns number of image that is displayed for item given by index. (Inherited from ICodeCompletionProvider.)
Public method | GetInsertText | When implemented by a class, returns string to be inserted. (Inherited from ICodeCompletionProvider.)
Public method | GetName | When implemented by a class, returns string representing name of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetParent | When implemented by a class, returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from ICodeCompletionProvider.)
Public method | GetPriority | When implemented by a class, returns priority of the item. (Inherited from ICodeCompletionProvider.)
Public method | GetText | When implemented by a class, returns string representing default column. (Inherited from ICodeCompletionProvider.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListICodeCompletionProviderItem .)
Public method | IndexOfName | When implemented by a class, returns index of item within collection by it's name. (Inherited from ICodeCompletionProvider.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | OnClosePopup | When implemented by a class, raises ClosePopup event. (Inherited from ICodeCompletionProvider.)
Public method | OnShowPopup | When implemented by a class, raises ShowPopup event. (Inherited from ICodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Sort | When implemented by a class, sorts elements in the list. (Inherited from ICodeCompletionProvider.)
Public method | Sort(IComparerICodeCompletionProviderItem) | When implemented by a class, sorts elements in the list using the specified comparer. (Inherited from ICodeCompletionProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

IQuickInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IQuickInfo Properties

IQuickInfo Properties

The IQuickInfo type exposes the following members.

Properties
 | Name | Description
Public property | CanEvaluateSymbol | When implemented by a class, gets or sets a boolean value indicating if the symbol can be evaluated at run-time
Public property | ColumnCount | When implemented by a class, represents number of the columns. (Inherited from ICodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Descriptions | When implemented by a class, provides an indexed access to the description of each column. (Inherited from ICodeCompletionProvider.)
Public property | EditField | When implemented by a class, gets or sets a value indicating editable field of the code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | EditPath | When implemented by a class, gets or sets a value indicating path to the nested code completion provider. (Inherited from ICodeCompletionProvider.)
Public property | FocusMode | When implemented by a class, specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from ICodeCompletionProvider.)
Public property | FormatDisplayText | When implemented by a class, gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ICodeCompletionProvider.)
Public property | ImageIndexes | When implemented by a class, provides an indexed access to the image index of each column. (Inherited from ICodeCompletionProvider.)
Public property | Images | When implemented by a class, gets or sets the ImageList for code completion items. (Inherited from ICodeCompletionProvider.)
Public property | ImagesHighDpi | When implemented by a class, gets or sets the ImageList for code completion items for high DPI. (Inherited from ICodeCompletionProvider.)
Public property | InvokeChar | When implemented by a class, specifies a character that triggered code completion invocation (Inherited from ICodeCompletionProvider.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionICodeCompletionProviderItem .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListICodeCompletionProviderItem .)
Public property | NameColumnIndex | When implemented by a class, gets index of the column containing name. (Inherited from ICodeCompletionProvider.)
Public property | NeedSort | When implemented by a class, specifies if provider content needs to be sorted. (Inherited from ICodeCompletionProvider.)
Public property | SelIndex | When implemented by a class, represents the index specifying the currently selected item of the popup control. (Inherited from ICodeCompletionProvider.)
Public property | ShowDescriptions | When implemented by a class, gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from ICodeCompletionProvider.)
Public property | Strings | When implemented by a class, provides an indexed access to the text of default column. (Inherited from ICodeCompletionProvider.)
Public property | Symbol | When implemented by a class, gets or sets quick info symbol
Public property | Text | When implemented by a class, gets or sets content of the IQuickInfo.
Public property | UseHtmlFormatting | When implemented by a class, gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from ICodeCompletionProvider.)
Public property | UseIndent | When implemented by a class, gets or sets a boolean value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

IQuickInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IQuickInfo.CanEvaluateSymbol Property

IQuickInfoCanEvaluateSymbol Property
When implemented by a class, gets or sets a boolean value indicating if the symbol can be evaluated at run-time

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CanEvaluateSymbol { get; set; }
Property CanEvaluateSymbol As Boolean
    Get
    Set
property bool CanEvaluateSymbol {
    bool get ();
    void set (bool value);
}
abstract CanEvaluateSymbol : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IQuickInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IQuickInfo.Symbol Property

IQuickInfoSymbol Property
When implemented by a class, gets or sets quick info symbol

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Symbol { get; set; }
Property Symbol As String
    Get
    Set
property String^ Symbol {
    String^ get ();
    void set (String^ value);
}
abstract Symbol : string with get, set

Property Value

Type: String
See Also

Reference

IQuickInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IQuickInfo.Text Property

IQuickInfoText Property
When implemented by a class, gets or sets content of the IQuickInfo.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IQuickInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IQuickInfo Events

IQuickInfo Events

The IQuickInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | When implemented by a class, occurs when popup control is closed. (Inherited from ICodeCompletionProvider.)
Public event | ShowPopup | When implemented by a class, occurs when popup control is displayed. (Inherited from ICodeCompletionProvider.)
Top
See Also

Reference

IQuickInfo Interface
Alternet.Syntax.CodeCompletion Namespace


IQuickInfoItem Interface

IQuickInfoItem Interface
Stores simple text data related to popup hint.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IQuickInfoItem : ICodeCompletionProviderItem,
    IComparable
Public Interface IQuickInfoItem
    Inherits ICodeCompletionProviderItem, IComparable
public interface class IQuickInfoItem : ICodeCompletionProviderItem,
    IComparable
type IQuickInfoItem =
    interface
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The IQuickInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Text | When implemented by a class, gets or sets content of the IQuickInfoItem.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IQuickInfoItem Methods

IQuickInfoItem Methods

The IQuickInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Top
See Also

Reference

IQuickInfoItem Interface
Alternet.Syntax.CodeCompletion Namespace


IQuickInfoItem Properties

IQuickInfoItem Properties

The IQuickInfoItem type exposes the following members.

Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from ICodeCompletionProviderItem.)
Public property | Text | When implemented by a class, gets or sets content of the IQuickInfoItem.
Top
See Also

Reference

IQuickInfoItem Interface
Alternet.Syntax.CodeCompletion Namespace


IQuickInfoItem.Text Property

IQuickInfoItemText Property
When implemented by a class, gets or sets content of the IQuickInfoItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IQuickInfoItem Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository Interface

IReflectionRepository Interface
Represents properties and methods to perform code completion functionality using reflection.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IReflectionRepository : ICodeCompletionRepository,
    IDisposable
Public Interface IReflectionRepository
    Inherits ICodeCompletionRepository, IDisposable
public interface class IReflectionRepository : ICodeCompletionRepository,
    IDisposable
type IReflectionRepository =
    interface
        interface ICodeCompletionRepository
        interface IDisposable
    end

The IReflectionRepository type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeMembers | When implemented by a class, re-enables type members from being shown in code completion windows.
Public method | ClearAssemblies | When implemented by a class, clears assembly list.
Public method | ClearNamespaces | When implemented by a class, clears namespace list.
Public method | ClearObjects | When implemented by a class, clears object list.
Public method | ClearTypes | When implemented by a class, clears type list.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindReferences | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | RegisterAllAssemblies | When implemented by a class, registers all assemblies from the current application domain.
Public method | RegisterAssemblies(Assembly) | When implemented by a class, registers list of assemblies for code completion
Public method | RegisterAssemblies(String) | When implemented by a class, registers list of assemblies for code completion by assembly reference
Public method | RegisterAssembly(Assembly) | When implemented by a class, adds specified assembly for code completion to the assembly list.
Public method | RegisterAssembly(String) | When implemented by a class, adds specified assembly for code completion to the assembly list.
Public method | RegisterDefaultAssemblies | When implemented by a class, registers some most frequently used assemblies. Specifies technology platform
Public method | RegisterNamespace(String) | When implemented by a class, adds specified namespace to the namespace list.
Public method | RegisterNamespace(String, String) | When implemented by a class, adds specified namespace to the namespace list.
Public method | RegisterObject | When implemented by a class, adds specified object for code completion to the object list.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | RegisterType(String, Type) | When implemented by a class, adds specified type for code completion to the type list.
Public method | RegisterType(String, Type, Boolean) | When implemented by a class, adds specified type for code completion to the type list.
Public method | RestrictTypeMembers | When implemented by a class, disables type members from being shown in code completion windows.
Public method | UnregisterAssembly(Assembly, Boolean) | When implemented by a class, removes specified assembly from the assembly list.
Public method | UnregisterAssembly(String, Boolean) | When implemented by a class, removes specified assembly from the assembly list.
Public method | UnregisterNamespace | When implemented by a class, removes specified namespace from the namespace list.
Public method | UnregisterObject | When implemented by a class, removes specified object from the object list.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterType | When implemented by a class, removes specified type from the type list.
Top
Properties
 | Name | Description
Public property | Assemblies | When implemented by a class, represents assembly list.
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | Namespaces | When implemented by a class, represents namespace list.
Public property | Objects | When implemented by a class, represents object list in a form of key-value pairs.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | Types | When implemented by a class, represents type list in a form of key-value pairs.
Top
Events
 | Name | Description
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository Methods

IReflectionRepository Methods

The IReflectionRepository type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeMembers | When implemented by a class, re-enables type members from being shown in code completion windows.
Public method | ClearAssemblies | When implemented by a class, clears assembly list.
Public method | ClearNamespaces | When implemented by a class, clears namespace list.
Public method | ClearObjects | When implemented by a class, clears object list.
Public method | ClearTypes | When implemented by a class, clears type list.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindReferences | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | RegisterAllAssemblies | When implemented by a class, registers all assemblies from the current application domain.
Public method | RegisterAssemblies(Assembly) | When implemented by a class, registers list of assemblies for code completion
Public method | RegisterAssemblies(String) | When implemented by a class, registers list of assemblies for code completion by assembly reference
Public method | RegisterAssembly(Assembly) | When implemented by a class, adds specified assembly for code completion to the assembly list.
Public method | RegisterAssembly(String) | When implemented by a class, adds specified assembly for code completion to the assembly list.
Public method | RegisterDefaultAssemblies | When implemented by a class, registers some most frequently used assemblies. Specifies technology platform
Public method | RegisterNamespace(String) | When implemented by a class, adds specified namespace to the namespace list.
Public method | RegisterNamespace(String, String) | When implemented by a class, adds specified namespace to the namespace list.
Public method | RegisterObject | When implemented by a class, adds specified object for code completion to the object list.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | RegisterType(String, Type) | When implemented by a class, adds specified type for code completion to the type list.
Public method | RegisterType(String, Type, Boolean) | When implemented by a class, adds specified type for code completion to the type list.
Public method | RestrictTypeMembers | When implemented by a class, disables type members from being shown in code completion windows.
Public method | UnregisterAssembly(Assembly, Boolean) | When implemented by a class, removes specified assembly from the assembly list.
Public method | UnregisterAssembly(String, Boolean) | When implemented by a class, removes specified assembly from the assembly list.
Public method | UnregisterNamespace | When implemented by a class, removes specified namespace from the namespace list.
Public method | UnregisterObject | When implemented by a class, removes specified object from the object list.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterType | When implemented by a class, removes specified type from the type list.
Top
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.AllowTypeMembers Method

IReflectionRepositoryAllowTypeMembers Method
When implemented by a class, re-enables type members from being shown in code completion windows.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AllowTypeMembers(
    Type type
)
Sub AllowTypeMembers (
    type As Type
)
void AllowTypeMembers(
    Type^ type
)
abstract AllowTypeMembers :
        type : Type -> unit

Parameters

type
Type: SystemType
Specifies type which members will be re-enabled.
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.ClearAssemblies Method

IReflectionRepositoryClearAssemblies Method
When implemented by a class, clears assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearAssemblies()
Sub ClearAssemblies
void ClearAssemblies()
abstract ClearAssemblies : unit -> unit
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.ClearNamespaces Method

IReflectionRepositoryClearNamespaces Method
When implemented by a class, clears namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearNamespaces()
Sub ClearNamespaces
void ClearNamespaces()
abstract ClearNamespaces : unit -> unit
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.ClearObjects Method

IReflectionRepositoryClearObjects Method
When implemented by a class, clears object list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearObjects()
Sub ClearObjects
void ClearObjects()
abstract ClearObjects : unit -> unit
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.ClearTypes Method

IReflectionRepositoryClearTypes Method
When implemented by a class, clears type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearTypes()
Sub ClearTypes
void ClearTypes()
abstract ClearTypes : unit -> unit
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterAllAssemblies Method

IReflectionRepositoryRegisterAllAssemblies Method
When implemented by a class, registers all assemblies from the current application domain.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterAllAssemblies()
Sub RegisterAllAssemblies
void RegisterAllAssemblies()
abstract RegisterAllAssemblies : unit -> unit
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterAssemblies Method

IReflectionRepositoryRegisterAssemblies Method
Overload List
 | Name | Description
Public method | RegisterAssemblies(Assembly) | When implemented by a class, registers list of assemblies for code completion
Public method | RegisterAssemblies(String) | When implemented by a class, registers list of assemblies for code completion by assembly reference
Top
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterAssemblies Method (Assembly[])

IReflectionRepositoryRegisterAssemblies Method (Assembly)
When implemented by a class, registers list of assemblies for code completion

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterAssemblies(
    Assembly[] assemblies
)
Sub RegisterAssemblies (
    assemblies As Assembly()
)
void RegisterAssemblies(
    array<Assembly^>^ assemblies
)
abstract RegisterAssemblies :
        assemblies : Assembly[] -> unit

Parameters

assemblies
Type: System.ReflectionAssembly
See Also

Reference

IReflectionRepository Interface
RegisterAssemblies Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterAssemblies Method (String[])

IReflectionRepositoryRegisterAssemblies Method (String)
When implemented by a class, registers list of assemblies for code completion by assembly reference

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterAssemblies(
    string[] assemblies
)
Sub RegisterAssemblies (
    assemblies As String()
)
void RegisterAssemblies(
    array<String^>^ assemblies
)
abstract RegisterAssemblies :
        assemblies : string[] -> unit

Parameters

assemblies
Type: SystemString
See Also

Reference

IReflectionRepository Interface
RegisterAssemblies Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterAssembly Method

IReflectionRepositoryRegisterAssembly Method
Overload List
 | Name | Description
Public method | RegisterAssembly(Assembly) | When implemented by a class, adds specified assembly for code completion to the assembly list.
Public method | RegisterAssembly(String) | When implemented by a class, adds specified assembly for code completion to the assembly list.
Top
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterAssembly Method (Assembly)

IReflectionRepositoryRegisterAssembly Method (Assembly)
When implemented by a class, adds specified assembly for code completion to the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterAssembly(
    Assembly assembly
)
Sub RegisterAssembly (
    assembly As Assembly
)
void RegisterAssembly(
    Assembly^ assembly
)
abstract RegisterAssembly :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Specifies registered assembly.
See Also

Reference

IReflectionRepository Interface
RegisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterAssembly Method (String)

IReflectionRepositoryRegisterAssembly Method (String)
When implemented by a class, adds specified assembly for code completion to the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RegisterAssembly(
    string name
)
Function RegisterAssembly (
    name As String
) As Boolean
bool RegisterAssembly(
    String^ name
)
abstract RegisterAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of the assembly.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IReflectionRepository Interface
RegisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterDefaultAssemblies Method

IReflectionRepositoryRegisterDefaultAssemblies Method
When implemented by a class, registers some most frequently used assemblies. Specifies technology platform

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms
)
Sub RegisterDefaultAssemblies (
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms
)
void RegisterDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms
)
abstract RegisterDefaultAssemblies :
        ?technology : TechnologyEnvironment
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
*)
-> unit

Parameters

technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterNamespace Method

IReflectionRepositoryRegisterNamespace Method
Overload List
 | Name | Description
Public method | RegisterNamespace(String) | When implemented by a class, adds specified namespace to the namespace list.
Public method | RegisterNamespace(String, String) | When implemented by a class, adds specified namespace to the namespace list.
Top
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterNamespace Method (String)

IReflectionRepositoryRegisterNamespace Method (String)
When implemented by a class, adds specified namespace to the namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterNamespace(
    string nspace
)
Sub RegisterNamespace (
    nspace As String
)
void RegisterNamespace(
    String^ nspace
)
abstract RegisterNamespace :
        nspace : string -> unit

Parameters

nspace
Type: SystemString
Specifies name of namespace to add.
See Also

Reference

IReflectionRepository Interface
RegisterNamespace Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterNamespace Method (String, String)

IReflectionRepositoryRegisterNamespace Method (String, String)
When implemented by a class, adds specified namespace to the namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterNamespace(
    string nspace,
    string alias
)
Sub RegisterNamespace (
    nspace As String,
    alias As String
)
void RegisterNamespace(
    String^ nspace,
    String^ alias
)
abstract RegisterNamespace :
        nspace : string *
        alias : string -> unit

Parameters

nspace
Type: SystemString
Specifies name of namespace to add.
alias
Type: SystemString
Specifies alias of namespace.
See Also

Reference

IReflectionRepository Interface
RegisterNamespace Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterObject Method

IReflectionRepositoryRegisterObject Method
When implemented by a class, adds specified object for code completion to the object list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterObject(
    string name,
    Object obj
)
Sub RegisterObject (
    name As String,
    obj As Object
)
void RegisterObject(
    String^ name,
    Object^ obj
)
abstract RegisterObject :
        name : string *
        obj : Object -> unit

Parameters

name
Type: SystemString
Specifies name of the object.
obj
Type: SystemObject
Specifies object to register.
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterType Method

IReflectionRepositoryRegisterType Method
Overload List
 | Name | Description
Public method | RegisterType(String, Type) | When implemented by a class, adds specified type for code completion to the type list.
Public method | RegisterType(String, Type, Boolean) | When implemented by a class, adds specified type for code completion to the type list.
Top
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterType Method (String, Type)

IReflectionRepositoryRegisterType Method (String, Type)
When implemented by a class, adds specified type for code completion to the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterType(
    string name,
    Type type
)
Sub RegisterType (
    name As String,
    type As Type
)
void RegisterType(
    String^ name,
    Type^ type
)
abstract RegisterType :
        name : string *
        type : Type -> unit

Parameters

name
Type: SystemString
Specifies name of the type.
type
Type: SystemType
Specifies type to register.
See Also

Reference

IReflectionRepository Interface
RegisterType Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RegisterType Method (String, Type, Boolean)

IReflectionRepositoryRegisterType Method (String, Type, Boolean)
When implemented by a class, adds specified type for code completion to the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterType(
    string name,
    Type type,
    bool global
)
Sub RegisterType (
    name As String,
    type As Type,
    global As Boolean
)
void RegisterType(
    String^ name,
    Type^ type,
    bool global
)
abstract RegisterType :
        name : string *
        type : Type *
        global : bool -> unit

Parameters

name
Type: SystemString
Specifies name of the type.
type
Type: SystemType
Specifies type to register.
global
Type: SystemBoolean
Specifies whether the type is global.
See Also

Reference

IReflectionRepository Interface
RegisterType Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.RestrictTypeMembers Method

IReflectionRepositoryRestrictTypeMembers Method
When implemented by a class, disables type members from being shown in code completion windows.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RestrictTypeMembers(
    Type type
)
Sub RestrictTypeMembers (
    type As Type
)
void RestrictTypeMembers(
    Type^ type
)
abstract RestrictTypeMembers :
        type : Type -> unit

Parameters

type
Type: SystemType
Specifies type which members will be disabled.
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.UnregisterAssembly Method

IReflectionRepositoryUnregisterAssembly Method
Overload List
 | Name | Description
Public method | UnregisterAssembly(Assembly, Boolean) | When implemented by a class, removes specified assembly from the assembly list.
Public method | UnregisterAssembly(String, Boolean) | When implemented by a class, removes specified assembly from the assembly list.
Top
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.UnregisterAssembly Method (Assembly, Boolean)

IReflectionRepositoryUnregisterAssembly Method (Assembly, Boolean)
When implemented by a class, removes specified assembly from the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterAssembly(
    Assembly assembly,
    bool removeReferences
)
Function UnregisterAssembly (
    assembly As Assembly,
    removeReferences As Boolean
) As Boolean
bool UnregisterAssembly(
    Assembly^ assembly,
    bool removeReferences
)
abstract UnregisterAssembly :
        assembly : Assembly *
        removeReferences : bool -> bool

Parameters

assembly
Type: System.ReflectionAssembly
Specifies assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all types from the specified assembly should be unregistered.

Return Value

Type: Boolean
True if succeed (assembly is present in the assembly list); otherwise false.
See Also

Reference

IReflectionRepository Interface
UnregisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.UnregisterAssembly Method (String, Boolean)

IReflectionRepositoryUnregisterAssembly Method (String, Boolean)
When implemented by a class, removes specified assembly from the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterAssembly(
    string name,
    bool removeReferences
)
Function UnregisterAssembly (
    name As String,
    removeReferences As Boolean
) As Boolean
bool UnregisterAssembly(
    String^ name,
    bool removeReferences
)
abstract UnregisterAssembly :
        name : string *
        removeReferences : bool -> bool

Parameters

name
Type: SystemString
Specifies name of assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all types from the specified assembly should be unregistered.

Return Value

Type: Boolean
True if succeed (assembly is present in the assembly list); otherwise false.
See Also

Reference

IReflectionRepository Interface
UnregisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.UnregisterNamespace Method

IReflectionRepositoryUnregisterNamespace Method
When implemented by a class, removes specified namespace from the namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterNamespace(
    string nspace
)
Function UnregisterNamespace (
    nspace As String
) As Boolean
bool UnregisterNamespace(
    String^ nspace
)
abstract UnregisterNamespace :
        nspace : string -> bool

Parameters

nspace
Type: SystemString
Specifies name of namespace to remove.

Return Value

Type: Boolean
True if succeed (namespace is present in the namespace list); otherwise false.
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.UnregisterObject Method

IReflectionRepositoryUnregisterObject Method
When implemented by a class, removes specified object from the object list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterObject(
    string name
)
Function UnregisterObject (
    name As String
) As Boolean
bool UnregisterObject(
    String^ name
)
abstract UnregisterObject :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of object to remove.

Return Value

Type: Boolean
True if succeed (object is present in the object list); otherwise false.
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.UnregisterType Method

IReflectionRepositoryUnregisterType Method
When implemented by a class, removes specified type from the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterType(
    string name
)
Function UnregisterType (
    name As String
) As Boolean
bool UnregisterType(
    String^ name
)
abstract UnregisterType :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of type to remove.

Return Value

Type: Boolean
True if succeed (type is present in the type list); otherwise false.
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository Properties

IReflectionRepository Properties

The IReflectionRepository type exposes the following members.

Properties
 | Name | Description
Public property | Assemblies | When implemented by a class, represents assembly list.
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | Namespaces | When implemented by a class, represents namespace list.
Public property | Objects | When implemented by a class, represents object list in a form of key-value pairs.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | Types | When implemented by a class, represents type list in a form of key-value pairs.
Top
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.Assemblies Property

IReflectionRepositoryAssemblies Property
When implemented by a class, represents assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<Assembly> Assemblies { get; }
ReadOnly Property Assemblies As IList(Of Assembly)
    Get
property IList<Assembly^>^ Assemblies {
    IList<Assembly^>^ get ();
}
abstract Assemblies : IList<Assembly> with get

Property Value

Type: IListAssembly
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.Namespaces Property

IReflectionRepositoryNamespaces Property
When implemented by a class, represents namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<INetNamespace> Namespaces { get; }
ReadOnly Property Namespaces As IList(Of INetNamespace)
    Get
property IList<INetNamespace^>^ Namespaces {
    IList<INetNamespace^>^ get ();
}
abstract Namespaces : IList<INetNamespace> with get

Property Value

Type: IListINetNamespace
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.Objects Property

IReflectionRepositoryObjects Property
When implemented by a class, represents object list in a form of key-value pairs.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Hashtable Objects { get; }
ReadOnly Property Objects As Hashtable
    Get
property Hashtable^ Objects {
    Hashtable^ get ();
}
abstract Objects : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository.Types Property

IReflectionRepositoryTypes Property
When implemented by a class, represents type list in a form of key-value pairs.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Hashtable Types { get; }
ReadOnly Property Types As Hashtable
    Get
property Hashtable^ Types {
    Hashtable^ get ();
}
abstract Types : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


IReflectionRepository Events

IReflectionRepository Events

The IReflectionRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IReflectionRepository Interface
Alternet.Syntax.CodeCompletion Namespace


ItemFocusMode Enumeration

ItemFocusMode Enumeration
Specifies item preselection mode

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ItemFocusMode
Public Enumeration ItemFocusMode
public enum class ItemFocusMode
type ItemFocusMode
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Focused | 1 | Specifies that item is in focused state.
AlwaysFocused | 2 | Specifies that item is in always focused state.
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository Class

JavaScriptRepository Class
Represents properties and methods to perform code completion functionality intended to use for Java Script language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionNETRepository
Alternet.Syntax.CodeCompletionReflectionRepository
Alternet.Syntax.CodeCompletionJavaScriptRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaScriptRepository : ReflectionRepository
Public Class JavaScriptRepository
    Inherits ReflectionRepository
public ref class JavaScriptRepository : public ReflectionRepository
type JavaScriptRepository =
    class
        inherit ReflectionRepository
    end

The JavaScriptRepository type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptRepository | Initializes a new instance of the JavaScriptRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Overrides NETRepositoryGetCommentTemplate(Point, ISyntaxNode, String).)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Overrides ReflectionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from NETRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Overrides NETRepositoryGetXmlReferenceNode(ISyntaxNode).)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides NETRepositoryIsDeclarationNode(ISyntaxNode, Boolean).)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Overrides NETRepositoryIsStructureGuideNode(ISyntaxNode, IRange).)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository Constructor

JavaScriptRepository Constructor
Initializes a new instance of the JavaScriptRepository class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaScriptRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
JavaScriptRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> JavaScriptRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

JavaScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository Methods

JavaScriptRepository Methods

The JavaScriptRepository type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Overrides NETRepositoryGetCommentTemplate(Point, ISyntaxNode, String).)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Overrides ReflectionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from NETRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Overrides NETRepositoryGetXmlReferenceNode(ISyntaxNode).)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides NETRepositoryIsDeclarationNode(ISyntaxNode, Boolean).)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Overrides NETRepositoryIsStructureGuideNode(ISyntaxNode, IRange).)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
See Also

Reference

JavaScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository.GetCommentTemplate Method

JavaScriptRepositoryGetCommentTemplate Method
Returns xml comment template for given node in the text.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetCommentTemplate(
    Point position,
    ISyntaxNode node,
    string comment
)
Public Overrides Function GetCommentTemplate (
    position As Point,
    node As ISyntaxNode,
    comment As String
) As String
public:
virtual String^ GetCommentTemplate(
    Point position,
    ISyntaxNode^ node,
    String^ comment
) override
abstract GetCommentTemplate :
        position : Point *
        node : ISyntaxNode *
        comment : string -> string
override GetCommentTemplate :
        position : Point *
        node : ISyntaxNode *
        comment : string -> string

Parameters

position
Type: System.DrawingPoint
Specifies position within the text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies node at given position.
comment
Type: SystemString
Specifies xml comment starting string.

Return Value

Type: String
Xml comment template.

Implements

INETRepositoryGetCommentTemplate(Point, ISyntaxNode, String)
See Also

Reference

JavaScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository.GetDescription Method

JavaScriptRepositoryGetDescription Method
Obtains description of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDescription(
    IListMembers members,
    ISyntaxNode node,
    Object member,
    string name,
    bool fullDescription
)
Public Overrides Function GetDescription (
    members As IListMembers,
    node As ISyntaxNode,
    member As Object,
    name As String,
    fullDescription As Boolean
) As String
public:
virtual String^ GetDescription(
    IListMembers^ members,
    ISyntaxNode^ node,
    Object^ member,
    String^ name,
    bool fullDescription
) override
abstract GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string
override GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies ListMembers interface used to get language-specific description.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode that representing language element to describe.
member
Type: SystemObject
Specifies language element to describe.
name
Type: SystemString
Specifies name of described language element.
fullDescription
Type: SystemBoolean
Specifies whether description should include name and type of the found element.

Return Value

Type: String
String that describes specified language element.

Implements

ICodeCompletionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean)
ICodeCompletionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean)
See Also

Reference

JavaScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository.GetXmlReferenceNode Method

JavaScriptRepositoryGetXmlReferenceNode Method
Returns declaration node corresponding to xml comment.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISyntaxNode GetXmlReferenceNode(
    ISyntaxNode node
)
Public Overrides Function GetXmlReferenceNode (
    node As ISyntaxNode
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetXmlReferenceNode(
    ISyntaxNode^ node
) override
abstract GetXmlReferenceNode :
        node : ISyntaxNode -> ISyntaxNode
override GetXmlReferenceNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Xml comment node.

Return Value

Type: ISyntaxNode
Declaration node if found; otherwise null.

Implements

INETRepositoryGetXmlReferenceNode(ISyntaxNode)
See Also

Reference

JavaScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository.IsDeclarationNode Method

JavaScriptRepositoryIsDeclarationNode Method
Overload List
 | Name | Description
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides NETRepositoryIsDeclarationNode(ISyntaxNode, Boolean).)
Top
See Also

Reference

JavaScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository.IsDeclarationNode Method (ISyntaxNode, Boolean)

JavaScriptRepositoryIsDeclarationNode Method (ISyntaxNode, Boolean)
Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsDeclarationNode(
    ref ISyntaxNode node,
    bool checkRegions
)
Public Overrides Function IsDeclarationNode (
    ByRef node As ISyntaxNode,
    checkRegions As Boolean
) As Boolean
public:
virtual bool IsDeclarationNode(
    ISyntaxNode^% node,
    bool checkRegions
) override
abstract IsDeclarationNode :
        node : ISyntaxNode byref *
        checkRegions : bool -> bool
override IsDeclarationNode :
        node : ISyntaxNode byref *
        checkRegions : bool -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.
checkRegions
Type: SystemBoolean
Indicates that region nodes should be skipped.

Return Value

Type: Boolean
True if specified node is declaration node; otherwise false.

Implements

INETRepositoryIsDeclarationNode(ISyntaxNode, Boolean)
See Also

Reference

JavaScriptRepository Class
IsDeclarationNode Overload
Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository.IsStructureGuideNode Method

JavaScriptRepositoryIsStructureGuideNode Method
Indicates whether specified ISyntaxNode is guide node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsStructureGuideNode(
    ISyntaxNode node,
    out IRange range
)
Public Overrides Function IsStructureGuideNode (
    node As ISyntaxNode,
    <OutAttribute> ByRef range As IRange
) As Boolean
public:
virtual bool IsStructureGuideNode(
    ISyntaxNode^ node,
    [OutAttribute] IRange^% range
) override
abstract IsStructureGuideNode :
        node : ISyntaxNode *
        range : IRange byref -> bool
override IsStructureGuideNode :
        node : ISyntaxNode *
        range : IRange byref -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to check.
range
Type: Alternet.CommonIRange
Output parameter receives guide range.

Return Value

Type: Boolean
True if ISyntaxNode is guide node; otherwise false.

Implements

ICodeCompletionRepositoryIsStructureGuideNode(ISyntaxNode, IRange)
See Also

Reference

JavaScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository Properties

JavaScriptRepository Properties

The JavaScriptRepository type exposes the following members.

Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
See Also

Reference

JavaScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


JavaScriptRepository Events

JavaScriptRepository Events

The JavaScriptRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

JavaScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


JsListMember Class

JsListMember Class
Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.CodeCompletionJsListMember

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JsListMember : ListMember
Public Class JsListMember
    Inherits ListMember
public ref class JsListMember : public ListMember
type JsListMember =
    class
        inherit ListMember
    end

The JsListMember type exposes the following members.

Constructors
 | Name | Description
Public method | JsListMember | Initializes a new instance of the JsListMember class with default settings.
Public method | JsListMember(IListMembers, Boolean) | Initializes a new instance of the JsListMember class with specified owner.
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
 | DataTypeToLower |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBuiltInType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


JsListMember Constructor

JsListMember Constructor
Overload List
 | Name | Description
Public method | JsListMember | Initializes a new instance of the JsListMember class with default settings.
Public method | JsListMember(IListMembers, Boolean) | Initializes a new instance of the JsListMember class with specified owner.
Top
See Also

Reference

JsListMember Class
Alternet.Syntax.CodeCompletion Namespace


JsListMember Constructor

JsListMember Constructor
Initializes a new instance of the JsListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JsListMember()
Public Sub New
public:
JsListMember()
new : unit -> JsListMember
See Also

Reference

JsListMember Class
JsListMember Overload
Alternet.Syntax.CodeCompletion Namespace


JsListMember Constructor (IListMembers, Boolean)

JsListMember Constructor (IListMembers, Boolean)
Initializes a new instance of the JsListMember class with specified owner.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JsListMember(
    IListMembers owner,
    bool fullDescription
)
Public Sub New (
    owner As IListMembers,
    fullDescription As Boolean
)
public:
JsListMember(
    IListMembers^ owner,
    bool fullDescription
)
new :
        owner : IListMembers *
        fullDescription : bool -> JsListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
IListMembers owning this instance.
fullDescription
Type: SystemBoolean
Boolean value indicating that member should provide detailed description.
See Also

Reference

JsListMember Class
JsListMember Overload
Alternet.Syntax.CodeCompletion Namespace


JsListMember Methods

JsListMember Methods

The JsListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
 | DataTypeToLower |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBuiltInType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JsListMember Class
Alternet.Syntax.CodeCompletion Namespace


JsListMember.DataTypeToLower Method

JsListMemberDataTypeToLower Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DataTypeToLower(
    string dataType
)
Public Shared Function DataTypeToLower (
    dataType As String
) As String
public:
static String^ DataTypeToLower(
    String^ dataType
)
static member DataTypeToLower :
        dataType : string -> string

Parameters

dataType
Type: SystemString

Return Value

Type: String
See Also

Reference

JsListMember Class
Alternet.Syntax.CodeCompletion Namespace


JsListMember.GetParamText Method

JsListMemberGetParamText Method
Converts Parameters property to a single string.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetParamText(
    bool useFormatting
)
Public Overrides Function GetParamText (
    useFormatting As Boolean
) As String
public:
virtual String^ GetParamText(
    bool useFormatting
) override
abstract GetParamText :
        useFormatting : bool -> string
override GetParamText :
        useFormatting : bool -> string

Parameters

useFormatting
Type: SystemBoolean
Specifies whether to use html formatting tags.

Return Value

Type: String
Returns Parameters in the form of comma separated text, framed by parentheses.

Implements

IListMemberGetParamText(Boolean)
See Also

Reference

JsListMember Class
Alternet.Syntax.CodeCompletion Namespace


JsListMember.IsBuiltInType Method

JsListMemberIsBuiltInType Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInType(
    string dataType
)
Public Shared Function IsBuiltInType (
    dataType As String
) As Boolean
public:
static bool IsBuiltInType(
    String^ dataType
)
static member IsBuiltInType :
        dataType : string -> bool

Parameters

dataType
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

JsListMember Class
Alternet.Syntax.CodeCompletion Namespace


JsListMember Properties

JsListMember Properties

The JsListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

JsListMember Class
Alternet.Syntax.CodeCompletion Namespace


JsListMember.Category Property

JsListMemberCategory Property

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionCategory Category { get; }
Public Overrides ReadOnly Property Category As CodeCompletionCategory
    Get
public:
virtual property CodeCompletionCategory^ Category {
    CodeCompletionCategory^ get () override;
}
abstract Category : CodeCompletionCategory with get
override Category : CodeCompletionCategory with get

Property Value

Type: CodeCompletionCategory

Implements

ICategorizedListMemberCategory
See Also

Reference

JsListMember Class
Alternet.Syntax.CodeCompletion Namespace


JsListMember.Description Property

JsListMemberDescription Property
Return member's description.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Return Value

Type: String
String value that describes the member.

Implements

IListMemberDescription
See Also

Reference

JsListMember Class
Alternet.Syntax.CodeCompletion Namespace


JsListMembers Class

JsListMembers Class
Represents data collection related to popup list box controls used to describe JScript language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionNetListMembers
Alternet.Syntax.CodeCompletionJsListMembers

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JsListMembers : NetListMembers
Public Class JsListMembers
    Inherits NetListMembers
public ref class JsListMembers : public NetListMembers
type JsListMembers =
    class
        inherit NetListMembers
    end

The JsListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | JsListMembers | Initializes a new instance of the JsListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides NetListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


JsListMembers Constructor

JsListMembers Constructor
Initializes a new instance of the JsListMembers class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JsListMembers()
Public Sub New
public:
JsListMembers()
new : unit -> JsListMembers
See Also

Reference

JsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


JsListMembers Methods

JsListMembers Methods

The JsListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides NetListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

JsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


JsListMembers.CreateListMember Method

JsListMembersCreateListMember Method
Initializes a new instance of the CsListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

JsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


JsListMembers.GetColumnText Method

JsListMembersGetColumnText Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
column
Type: SystemInt32

Return Value

Type: String

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

JsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


JsListMembers Properties

JsListMembers Properties

The JsListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

JsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


JsListMembers Events

JsListMembers Events

The JsListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

JsListMembers Class
Alternet.Syntax.CodeCompletion Namespace


JsParameterInfo Class

JsParameterInfo Class
Represents Parameter Info data related to popup window and popup hint controls used to describe JScript language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionParameterInfo
Alternet.Syntax.CodeCompletionNetParameterInfo
Alternet.Syntax.CodeCompletionJsParameterInfo

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JsParameterInfo : NetParameterInfo
Public Class JsParameterInfo
    Inherits NetParameterInfo
public ref class JsParameterInfo : public NetParameterInfo
type JsParameterInfo =
    class
        inherit NetParameterInfo
    end

The JsParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsParameterInfo | Initializes a new instance of the JsParameterInfo class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides NetParameterInfoGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


JsParameterInfo Constructor

JsParameterInfo Constructor
Initializes a new instance of the JsParameterInfo class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JsParameterInfo()
Public Sub New
public:
JsParameterInfo()
new : unit -> JsParameterInfo
See Also

Reference

JsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


JsParameterInfo Methods

JsParameterInfo Methods

The JsParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides NetParameterInfoGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

JsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


JsParameterInfo.CreateListMember Method

JsParameterInfoCreateListMember Method
Initializes a new instance of the CsListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

JsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


JsParameterInfo.GetColumnText Method

JsParameterInfoGetColumnText Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
column
Type: SystemInt32

Return Value

Type: String

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

JsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


JsParameterInfo Properties

JsParameterInfo Properties

The JsParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

JsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


JsParameterInfo Events

JsParameterInfo Events

The JsParameterInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

JsParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


JsRepository Class

JsRepository Class
Represents properties and methods to perform code completion functionality intended to use for Vb Script language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionNETRepository
Alternet.Syntax.CodeCompletionReflectionRepository
Alternet.Syntax.CodeCompletionCsRepository
Alternet.Syntax.CodeCompletionJsRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JsRepository : CsRepository
Public Class JsRepository
    Inherits CsRepository
public ref class JsRepository : public CsRepository
type JsRepository =
    class
        inherit CsRepository
    end

The JsRepository type exposes the following members.

Constructors
 | Name | Description
Public method | JsRepository | Initializes a new instance of the CsRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Overrides CsRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32).)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CsRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from ReflectionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from CsRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


JsRepository Constructor

JsRepository Constructor
Initializes a new instance of the CsRepository class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JsRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
JsRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> JsRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

JsRepository Class
Alternet.Syntax.CodeCompletion Namespace


JsRepository Methods

JsRepository Methods

The JsRepository type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Overrides CsRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32).)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CsRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from ReflectionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from CsRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
See Also

Reference

JsRepository Class
Alternet.Syntax.CodeCompletion Namespace


JsRepository.FillMembers Method

JsRepositoryFillMembers Method
Fills list members provider with list of its member, providing available choices for the specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FillMembers(
    ISyntaxNode node,
    Point position,
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope,
    ref int selIndex
)
Public Overrides Sub FillMembers (
    node As ISyntaxNode,
    position As Point,
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope,
    ByRef selIndex As Integer
)
public:
virtual void FillMembers(
    ISyntaxNode^ node,
    Point position,
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope,
    int% selIndex
) override
abstract FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit
override FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
position
Type: System.DrawingPoint
Specifies position of language element in the text.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies filter used to fill members.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
selIndex
Type: SystemInt32
Specifies index of default list member.

Implements

ICodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32)
See Also

Reference

JsRepository Class
Alternet.Syntax.CodeCompletion Namespace


JsRepository Properties

JsRepository Properties

The JsRepository type exposes the following members.

Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
See Also

Reference

JsRepository Class
Alternet.Syntax.CodeCompletion Namespace


JsRepository Events

JsRepository Events

The JsRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

JsRepository Class
Alternet.Syntax.CodeCompletion Namespace


ListMember Class

ListMember Class
Implements properties and methods for a particular list member in the data collection of the code completion popups.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ListMember : CodeCompletionProviderItem, ICategorizedListMember,
    IListMember, ICodeCompletionProviderItem, IComparable
Public Class ListMember
    Inherits CodeCompletionProviderItem
    Implements ICategorizedListMember, IListMember, ICodeCompletionProviderItem, IComparable
public ref class ListMember : public CodeCompletionProviderItem,
    ICategorizedListMember, IListMember, ICodeCompletionProviderItem, IComparable
type ListMember =
    class
        inherit CodeCompletionProviderItem
        interface ICategorizedListMember
        interface IListMember
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ListMember type exposes the following members.

Constructors
 | Name | Description
Public method | ListMember | Initializes a new instance of the ListMember class with default settings.
Public method | ListMember(IListMembers) | Initializes a new instance of the ListMember class with specified owner.
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description.
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string.
Public method | GetTemplate | Return member's template.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member.
Public property | Category | Gets or sets a CodeCompletionCategory to which this ListMember belongs.
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection.
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember.
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember.
Public property | Description | Gets or sets a string value that specifies short description of the ListMember.
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember.
Public property | Image | Gets or sets the index of the image for the ListMember.
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember.
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected.
Public property | MemberType | Gets or sets the integer value representing type of the member.
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection.
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection.
Public property | Owner | Gets IListMembers instance owning the ListMember.
Public property | Parameters | Gets or sets a collection of parameters of this ListMember.
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember.
Public property | Priority | Gets or sets priority for the ListMember.
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ListMember Constructor

ListMember Constructor
Overload List
 | Name | Description
Public method | ListMember | Initializes a new instance of the ListMember class with default settings.
Public method | ListMember(IListMembers) | Initializes a new instance of the ListMember class with specified owner.
Top
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember Constructor

ListMember Constructor
Initializes a new instance of the ListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListMember()
Public Sub New
public:
ListMember()
new : unit -> ListMember
See Also

Reference

ListMember Class
ListMember Overload
Alternet.Syntax.CodeCompletion Namespace


ListMember Constructor (IListMembers)

ListMember Constructor (IListMembers)
Initializes a new instance of the ListMember class with specified owner.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListMember(
    IListMembers owner
)
Public Sub New (
    owner As IListMembers
)
public:
ListMember(
    IListMembers^ owner
)
new :
        owner : IListMembers -> ListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
See Also

Reference

ListMember Class
ListMember Overload
Alternet.Syntax.CodeCompletion Namespace


ListMember Methods

ListMember Methods

The ListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description.
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string.
Public method | GetTemplate | Return member's template.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.AddDescription Method

ListMemberAddDescription Method
Appends text to the member description.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddDescription(
    string text
)
Public Overridable Sub AddDescription (
    text As String
)
public:
virtual void AddDescription(
    String^ text
)
abstract AddDescription :
        text : string -> unit
override AddDescription :
        text : string -> unit

Parameters

text
Type: SystemString
Text to add.

Implements

IListMemberAddDescription(String)
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.CompareTo Method

ListMemberCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.GetParamText Method

ListMemberGetParamText Method
Converts Parameters property to a single string.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetParamText(
    bool useFormatting
)
Public Overridable Function GetParamText (
    useFormatting As Boolean
) As String
public:
virtual String^ GetParamText(
    bool useFormatting
)
abstract GetParamText :
        useFormatting : bool -> string
override GetParamText :
        useFormatting : bool -> string

Parameters

useFormatting
Type: SystemBoolean
Specifies whether to use html formatting tags.

Return Value

Type: String
Returns Parameters in the form of comma separated text, framed by parentheses.

Implements

IListMemberGetParamText(Boolean)
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.GetTemplate Method

ListMemberGetTemplate Method
Return member's template.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetTemplate(
    bool addBase
)
Public Overridable Function GetTemplate (
    addBase As Boolean
) As String
public:
virtual String^ GetTemplate(
    bool addBase
)
abstract GetTemplate :
        addBase : bool -> string
override GetTemplate :
        addBase : bool -> string

Parameters

addBase
Type: SystemBoolean
Indicates if template includes base element.

Return Value

Type: String
String value that represents member template.

Implements

IListMemberGetTemplate(Boolean)
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember Properties

ListMember Properties

The ListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member.
Public property | Category | Gets or sets a CodeCompletionCategory to which this ListMember belongs.
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection.
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember.
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember.
Public property | Description | Gets or sets a string value that specifies short description of the ListMember.
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember.
Public property | Image | Gets or sets the index of the image for the ListMember.
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember.
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected.
Public property | MemberType | Gets or sets the integer value representing type of the member.
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection.
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection.
Public property | Owner | Gets IListMembers instance owning the ListMember.
Public property | Parameters | Gets or sets a collection of parameters of this ListMember.
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember.
Public property | Priority | Gets or sets priority for the ListMember.
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Attributes Property

ListMemberAttributes Property
Gets or sets additional attributes associated with a member.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual MemberAttribute Attributes { get; set; }
Public Overridable Property Attributes As MemberAttribute
    Get
    Set
public:
virtual property MemberAttribute Attributes {
    MemberAttribute get ();
    void set (MemberAttribute value);
}
abstract Attributes : MemberAttribute with get, set
override Attributes : MemberAttribute with get, set

Property Value

Type: MemberAttribute

Implements

IListMemberAttributes
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Category Property

ListMemberCategory Property
Gets or sets a CodeCompletionCategory to which this ListMember belongs.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CodeCompletionCategory Category { get; set; }
Public Overridable Property Category As CodeCompletionCategory
    Get
    Set
public:
virtual property CodeCompletionCategory^ Category {
    CodeCompletionCategory^ get ();
    void set (CodeCompletionCategory^ value);
}
abstract Category : CodeCompletionCategory with get, set
override Category : CodeCompletionCategory with get, set

Property Value

Type: CodeCompletionCategory

Implements

ICategorizedListMemberCategory
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.CurrentParamIndex Property

ListMemberCurrentParamIndex Property
Gets or sets index of current parameter in the parameters collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int CurrentParamIndex { get; set; }
Public Overridable Property CurrentParamIndex As Integer
    Get
    Set
public:
virtual property int CurrentParamIndex {
    int get ();
    void set (int value);
}
abstract CurrentParamIndex : int with get, set
override CurrentParamIndex : int with get, set

Property Value

Type: Int32

Implements

IListMemberCurrentParamIndex
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.CustomData Property

ListMemberCustomData Property
Gets or sets an object that can hold a user defined data attached to the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object CustomData { get; set; }
Public Overridable Property CustomData As Object
    Get
    Set
public:
virtual property Object^ CustomData {
    Object^ get ();
    void set (Object^ value);
}
abstract CustomData : Object with get, set
override CustomData : Object with get, set

Property Value

Type: Object

Implements

IListMemberCustomData
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.DataType Property

ListMemberDataType Property
Gets or sets a string value that specifies data type of the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DataType { get; set; }
Public Overridable Property DataType As String
    Get
    Set
public:
virtual property String^ DataType {
    String^ get ();
    void set (String^ value);
}
abstract DataType : string with get, set
override DataType : string with get, set

Property Value

Type: String

Implements

IListMemberDataType
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Description Property

ListMemberDescription Property
Gets or sets a string value that specifies short description of the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

IListMemberDescription
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.DisplayText Property

ListMemberDisplayText Property
Gets or sets a string value displayed as a "name" part of ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DisplayText { get; set; }
Public Overridable Property DisplayText As String
    Get
    Set
public:
virtual property String^ DisplayText {
    String^ get ();
    void set (String^ value);
}
abstract DisplayText : string with get, set
override DisplayText : string with get, set

Property Value

Type: String

Implements

IListMemberDisplayText
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Image Property

ListMemberImage Property
Gets or sets the index of the image for the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Image Image { get; set; }
Public Overridable Property Image As Image
    Get
    Set
public:
virtual property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
abstract Image : Image with get, set
override Image : Image with get, set

Property Value

Type: Image

Implements

IListMemberImage
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.ImageIndex Property

ListMemberImageIndex Property
Gets or sets the index of the image displayed for the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ImageIndex { get; set; }
Public Overridable Property ImageIndex As Integer
    Get
    Set
public:
virtual property int ImageIndex {
    int get ();
    void set (int value);
}
abstract ImageIndex : int with get, set
override ImageIndex : int with get, set

Property Value

Type: Int32

Implements

IListMemberImageIndex
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.InsertText Property

ListMemberInsertText Property
Gets or sets a string value inserted in the Editor when IListMember is selected.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string InsertText { get; set; }
Public Overridable Property InsertText As String
    Get
    Set
public:
virtual property String^ InsertText {
    String^ get ();
    void set (String^ value);
}
abstract InsertText : string with get, set
override InsertText : string with get, set

Property Value

Type: String

Implements

IListMemberInsertText
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.MemberType Property

ListMemberMemberType Property
Gets or sets the integer value representing type of the member.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int MemberType { get; set; }
Public Overridable Property MemberType As Integer
    Get
    Set
public:
virtual property int MemberType {
    int get ();
    void set (int value);
}
abstract MemberType : int with get, set
override MemberType : int with get, set

Property Value

Type: Int32

Implements

IListMemberMemberType
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Name Property

ListMemberName Property
Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IListMemberName
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Overloads Property

ListMemberOverloads Property
Gets or sets number of overloading members ListMember in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Overloads { get; set; }
Public Overridable Property Overloads As Integer
    Get
    Set
public:
virtual property int Overloads {
    int get ();
    void set (int value);
}
abstract Overloads : int with get, set
override Overloads : int with get, set

Property Value

Type: Int32

Implements

IListMemberOverloads
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Owner Property

ListMemberOwner Property
Gets IListMembers instance owning the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IListMembers Owner { get; set; }
Public Overridable Property Owner As IListMembers
    Get
    Set
public:
virtual property IListMembers^ Owner {
    IListMembers^ get ();
    void set (IListMembers^ value);
}
abstract Owner : IListMembers with get, set
override Owner : IListMembers with get, set

Property Value

Type: IListMembers

Implements

IListMemberOwner
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Parameters Property

ListMemberParameters Property
Gets or sets a collection of parameters of this ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IParameterMembers Parameters { get; set; }
Public Overridable Property Parameters As IParameterMembers
    Get
    Set
public:
virtual property IParameterMembers^ Parameters {
    IParameterMembers^ get ();
    void set (IParameterMembers^ value);
}
abstract Parameters : IParameterMembers with get, set
override Parameters : IParameterMembers with get, set

Property Value

Type: IParameterMembers

Implements

IListMemberParameters
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.ParamText Property

ListMemberParamText Property
Gets or sets a string value that specifies comma separated list of parameters of the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ParamText { get; set; }
Public Overridable Property ParamText As String
    Get
    Set
public:
virtual property String^ ParamText {
    String^ get ();
    void set (String^ value);
}
abstract ParamText : string with get, set
override ParamText : string with get, set

Property Value

Type: String

Implements

IListMemberParamText
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Priority Property

ListMemberPriority Property
Gets or sets priority for the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Priority { get; set; }
Public Overridable Property Priority As Integer
    Get
    Set
public:
virtual property int Priority {
    int get ();
    void set (int value);
}
abstract Priority : int with get, set
override Priority : int with get, set

Property Value

Type: Int32

Implements

IListMemberPriority
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMember.Qualifier Property

ListMemberQualifier Property
Gets or sets a string value that specifies access modifiers of the ListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Qualifier { get; set; }
Public Overridable Property Qualifier As String
    Get
    Set
public:
virtual property String^ Qualifier {
    String^ get ();
    void set (String^ value);
}
abstract Qualifier : string with get, set
override Qualifier : string with get, set

Property Value

Type: String

Implements

IListMemberQualifier
See Also

Reference

ListMember Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers Class

ListMembers Class
Represents data collection related to popup list box controls.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionParameterInfo

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ListMembers : CodeCompletionProvider,
    IListMembers, ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport,
    ICategorizedCodeCompletionProvider
Public Class ListMembers
    Inherits CodeCompletionProvider
    Implements IListMembers, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport, ICategorizedCodeCompletionProvider
public ref class ListMembers : public CodeCompletionProvider,
    IListMembers, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport,
    ICategorizedCodeCompletionProvider
type ListMembers =
    class
        inherit CodeCompletionProvider
        interface IListMembers
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
        interface ICategorizedCodeCompletionProvider
    end

The ListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | ListMembers | Initializes a new instance of the ListMembers class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection.
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Overrides CodeCompletionProviderColumnSpace(Int32).)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories.
Public method | GetCategory | Gets a category by its index.
Public method | GetColumnText | Returns text from given list member in the specified column. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Overrides CodeCompletionProviderGetDisplayText(Int32).)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Overrides CodeCompletionProviderGetImage(Int32).)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Overrides CodeCompletionProviderGetInsertText(Int32).)
Public method | GetName | Returns string representing name of the item. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Overrides CodeCompletionProviderGetPriority(Int32).)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value.
Public method | ResetShowParams | Resets the ShowParams to the default value.
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value.
Public method | ResetShowResults | Resets the ShowResults to the default value.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Overrides CodeCompletionProviderNameColumnIndex.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member.
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible.
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible.
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible.
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ListMembers Constructor

ListMembers Constructor
Initializes a new instance of the ListMembers class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListMembers()
Public Sub New
public:
ListMembers()
new : unit -> ListMembers
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers Methods

ListMembers Methods

The ListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection.
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Overrides CodeCompletionProviderColumnSpace(Int32).)
Public method | ColumnVisible | Indicates whether specified column is visible. (Overrides CodeCompletionProviderColumnVisible(Int32).)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories.
Public method | GetCategory | Gets a category by its index.
Public method | GetColumnText | Returns text from given list member in the specified column. (Overrides CodeCompletionProviderGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Overrides CodeCompletionProviderGetDescription(Int32).)
Public method | GetDisplayText | Returns string representing the display text of the item. (Overrides CodeCompletionProviderGetDisplayText(Int32).)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Overrides CodeCompletionProviderGetImage(Int32).)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Overrides CodeCompletionProviderGetInsertText(Int32).)
Public method | GetName | Returns string representing name of the item. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Overrides CodeCompletionProviderGetPriority(Int32).)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value.
Public method | ResetShowParams | Resets the ShowParams to the default value.
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value.
Public method | ResetShowResults | Resets the ShowResults to the default value.
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.AddListMember Method

ListMembersAddListMember Method
Overload List
 | Name | Description
Public method | AddListMember | Adds a new item to the ListMembers collection.
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection.
Top
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.AddListMember Method

ListMembersAddListMember Method
Adds a new item to the ListMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IListMember AddListMember()
Public Overridable Function AddListMember As IListMember
public:
virtual IListMember^ AddListMember()
abstract AddListMember : unit -> IListMember
override AddListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that is added.

Implements

IListMembersAddListMember
See Also

Reference

ListMembers Class
AddListMember Overload
Alternet.Syntax.CodeCompletion Namespace


ListMembers.AddListMember Method (IListMember)

ListMembersAddListMember Method (IListMember)
Adds a new item to the ListMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddListMember(
    IListMember member
)
Public Sub AddListMember (
    member As IListMember
)
public:
void AddListMember(
    IListMember^ member
)
member AddListMember :
        member : IListMember -> unit

Parameters

member
Type: Alternet.Syntax.CodeCompletionIListMember
See Also

Reference

ListMembers Class
AddListMember Overload
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ColumnSpace Method

ListMembersColumnSpace Method
Indicates whether after specified column SPACE is required.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ColumnSpace(
    int column
)
Public Overrides Function ColumnSpace (
    column As Integer
) As Boolean
public:
virtual bool ColumnSpace(
    int column
) override
abstract ColumnSpace :
        column : int -> bool
override ColumnSpace :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICodeCompletionProviderColumnSpace(Int32)
ICodeCompletionProviderColumnSpace(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ColumnVisible Method

ListMembersColumnVisible Method
Indicates whether specified column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ColumnVisible(
    int column
)
Public Overrides Function ColumnVisible (
    column As Integer
) As Boolean
public:
virtual bool ColumnVisible(
    int column
) override
abstract ColumnVisible :
        column : int -> bool
override ColumnVisible :
        column : int -> bool

Parameters

column
Type: SystemInt32
Specifies index of the column.

Return Value

Type: Boolean
True if visible; otherwise false.

Implements

ICodeCompletionProviderColumnVisible(Int32)
ICodeCompletionProviderColumnVisible(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.CreateListMember Method

ListMembersCreateListMember Method
Initializes a new instance of the ListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IListMember CreateListMember()
Public Overridable Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember()
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetAvailableCategories Method

ListMembersGetAvailableCategories Method
Returns list of all available categories.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<CodeCompletionCategory> GetAvailableCategories()
Public Function GetAvailableCategories As IEnumerable(Of CodeCompletionCategory)
public:
virtual IEnumerable<CodeCompletionCategory^>^ GetAvailableCategories() sealed
abstract GetAvailableCategories : unit -> IEnumerable<CodeCompletionCategory>
override GetAvailableCategories : unit -> IEnumerable<CodeCompletionCategory>

Return Value

Type: IEnumerableCodeCompletionCategory
List of all possible CodeCompletionCategory objects.

Implements

ICategorizedCodeCompletionProviderGetAvailableCategories
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetCategory Method

ListMembersGetCategory Method
Gets a category by its index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CodeCompletionCategory GetCategory(
    int index
)
Public Overridable Function GetCategory (
    index As Integer
) As CodeCompletionCategory
public:
virtual CodeCompletionCategory^ GetCategory(
    int index
)
abstract GetCategory :
        index : int -> CodeCompletionCategory
override GetCategory :
        index : int -> CodeCompletionCategory

Parameters

index
Type: SystemInt32
Index of the item in the categories collection.

Return Value

Type: CodeCompletionCategory
CodeCompletionCategory by its index.

Implements

ICategorizedCodeCompletionProviderGetCategory(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetColumnText Method

ListMembersGetColumnText Method
Returns text from given list member in the specified column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
Specifies index of list member.
column
Type: SystemInt32
Specifies index of column.

Return Value

Type: String
Text representing specified list member.

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetDescription Method

ListMembersGetDescription Method
Returns a content of the column, named 'Description', of the specified item from the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDescription(
    int index
)
Public Overrides Function GetDescription (
    index As Integer
) As String
public:
virtual String^ GetDescription(
    int index
) override
abstract GetDescription :
        index : int -> string
override GetDescription :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of the item within the collection.

Return Value

Type: String
String content of specified column.

Implements

ICodeCompletionProviderGetDescription(Int32)
ICodeCompletionProviderGetDescription(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetDisplayText Method

ListMembersGetDisplayText Method
Returns string representing the display text of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayText(
    int index
)
Public Overrides Function GetDisplayText (
    index As Integer
) As String
public:
virtual String^ GetDisplayText(
    int index
) override
abstract GetDisplayText :
        index : int -> string
override GetDisplayText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing display text of specified item.

Implements

ICodeCompletionProviderGetDisplayText(Int32)
ICodeCompletionProviderGetDisplayText(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetImage Method

ListMembersGetImage Method
Returns an image that is displayed for item given by Index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Image GetImage(
    int index
)
Public Overrides Function GetImage (
    index As Integer
) As Image
public:
virtual Image^ GetImage(
    int index
) override
abstract GetImage :
        index : int -> Image
override GetImage :
        index : int -> Image

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: Image
image corresponding to given item.

Implements

ICodeCompletionProviderGetImage(Int32)
ICodeCompletionProviderGetImage(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetImageIndex Method

ListMembersGetImageIndex Method
Returns index of image that is displayed for item given by Index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetImageIndex(
    int index
)
Public Overrides Function GetImageIndex (
    index As Integer
) As Integer
public:
virtual int GetImageIndex(
    int index
) override
abstract GetImageIndex :
        index : int -> int
override GetImageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: Int32
Index of image corresponding to given item.

Implements

ICodeCompletionProviderGetImageIndex(Int32)
ICodeCompletionProviderGetImageIndex(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetInsertText Method

ListMembersGetInsertText Method
Returns string to be inserted.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetInsertText(
    int index
)
Public Overrides Function GetInsertText (
    index As Integer
) As String
public:
virtual String^ GetInsertText(
    int index
) override
abstract GetInsertText :
        index : int -> string
override GetInsertText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
Text to be inserted.

Implements

ICodeCompletionProviderGetInsertText(Int32)
ICodeCompletionProviderGetInsertText(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetName Method

ListMembersGetName Method
Returns string representing name of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetName(
    int index
)
Public Overrides Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
) override
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing name of specified item.

Implements

ICodeCompletionProviderGetName(Int32)
ICodeCompletionProviderGetName(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetPriority Method

ListMembersGetPriority Method
Returns priority of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetPriority(
    int index
)
Public Overrides Function GetPriority (
    index As Integer
) As Integer
public:
virtual int GetPriority(
    int index
) override
abstract GetPriority :
        index : int -> int
override GetPriority :
        index : int -> int

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: Int32
Integer representing priority of specified item.

Implements

ICodeCompletionProviderGetPriority(Int32)
ICodeCompletionProviderGetPriority(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.GetText Method

ListMembersGetText Method
Returns string representing default column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetText(
    int index
)
Public Overrides Function GetText (
    index As Integer
) As String
public:
virtual String^ GetText(
    int index
) override
abstract GetText :
        index : int -> string
override GetText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
Text representing default column.

Implements

ICodeCompletionProviderGetText(Int32)
ICodeCompletionProviderGetText(Int32)
Remarks
In this class method returns the same value with GetName method.
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.InsertListMember Method

ListMembersInsertListMember Method
Inserts a new item to the specified position within the ListMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IListMember InsertListMember(
    int index
)
Public Overridable Function InsertListMember (
    index As Integer
) As IListMember
public:
virtual IListMember^ InsertListMember(
    int index
)
abstract InsertListMember :
        index : int -> IListMember
override InsertListMember :
        index : int -> IListMember

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: IListMember
IListMember that is inserted.

Implements

IListMembersInsertListMember(Int32)
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ResetShowHints Method

ListMembersResetShowHints Method
Resets the ShowHints to the default value.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetShowHints()
Public Overridable Sub ResetShowHints
public:
virtual void ResetShowHints()
abstract ResetShowHints : unit -> unit
override ResetShowHints : unit -> unit

Implements

IListMembersResetShowHints
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ResetShowParams Method

ListMembersResetShowParams Method
Resets the ShowParams to the default value.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetShowParams()
Public Overridable Sub ResetShowParams
public:
virtual void ResetShowParams()
abstract ResetShowParams : unit -> unit
override ResetShowParams : unit -> unit

Implements

IListMembersResetShowParams
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ResetShowQualifiers Method

ListMembersResetShowQualifiers Method
Resets the ShowQualifiers to the default value.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetShowQualifiers()
Public Overridable Sub ResetShowQualifiers
public:
virtual void ResetShowQualifiers()
abstract ResetShowQualifiers : unit -> unit
override ResetShowQualifiers : unit -> unit

Implements

IListMembersResetShowQualifiers
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ResetShowResults Method

ListMembersResetShowResults Method
Resets the ShowResults to the default value.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetShowResults()
Public Overridable Sub ResetShowResults
public:
virtual void ResetShowResults()
abstract ResetShowResults : unit -> unit
override ResetShowResults : unit -> unit

Implements

IListMembersResetShowResults
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers Properties

ListMembers Properties

The ListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Overrides CodeCompletionProviderColumnCount.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection.
Public property | NameColumnIndex | Gets index of the column containing name. (Overrides CodeCompletionProviderNameColumnIndex.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member.
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible.
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible.
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible.
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ColumnCount Property

ListMembersColumnCount Property
Represents number of the columns. In this class ColumnCount always return 4.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () override;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

ICodeCompletionProviderColumnCount
ICodeCompletionProviderColumnCount
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.Item Property

ListMembersItem Property
Provides an indexed access to IListMember objects stored in the collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IListMember this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As IListMember
    Get
    Set
public:
virtual property IListMember^ default[int index] {
    IListMember^ get (int index);
    void set (int index, IListMember^ value);
}
abstract Item : IListMember with get, set
override Item : IListMember with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: IListMember

Implements

IListMembersItemInt32
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.NameColumnIndex Property

ListMembersNameColumnIndex Property
Gets index of the column containing name.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Nullable<int> NameColumnIndex { get; }
Public Overrides ReadOnly Property NameColumnIndex As Nullable(Of Integer)
    Get
public:
virtual property Nullable<int> NameColumnIndex {
    Nullable<int> get () override;
}
abstract NameColumnIndex : Nullable<int> with get
override NameColumnIndex : Nullable<int> with get

Property Value

Type: NullableInt32

Implements

ICodeCompletionProviderNameColumnIndex
ICodeCompletionProviderNameColumnIndex
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ShowHints Property

ListMembersShowHints Property
Gets or sets a value indicating whether popup listbox should display additional information for selected list member.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowHints { get; set; }
Public Overridable Property ShowHints As Boolean
    Get
    Set
public:
virtual property bool ShowHints {
    bool get ();
    void set (bool value);
}
abstract ShowHints : bool with get, set
override ShowHints : bool with get, set

Property Value

Type: Boolean

Implements

IListMembersShowHints
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ShowParams Property

ListMembersShowParams Property
Gets or sets a value indicating whether the "Params" column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowParams { get; set; }
Public Overridable Property ShowParams As Boolean
    Get
    Set
public:
virtual property bool ShowParams {
    bool get ();
    void set (bool value);
}
abstract ShowParams : bool with get, set
override ShowParams : bool with get, set

Property Value

Type: Boolean

Implements

IListMembersShowParams
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ShowQualifiers Property

ListMembersShowQualifiers Property
Gets or sets a value indicating whether the "Qualifiers" column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowQualifiers { get; set; }
Public Overridable Property ShowQualifiers As Boolean
    Get
    Set
public:
virtual property bool ShowQualifiers {
    bool get ();
    void set (bool value);
}
abstract ShowQualifiers : bool with get, set
override ShowQualifiers : bool with get, set

Property Value

Type: Boolean

Implements

IListMembersShowQualifiers
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers.ShowResults Property

ListMembersShowResults Property
Gets or sets a value indicating whether the "Results" column is visible.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowResults { get; set; }
Public Overridable Property ShowResults As Boolean
    Get
    Set
public:
virtual property bool ShowResults {
    bool get ();
    void set (bool value);
}
abstract ShowResults : bool with get, set
override ShowResults : bool with get, set

Property Value

Type: Boolean

Implements

IListMembersShowResults
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


ListMembers Events

ListMembers Events

The ListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

ListMembers Class
Alternet.Syntax.CodeCompletion Namespace


MemberAttribute Enumeration

MemberAttribute Enumeration
Specifies list of additional attributes associated with a IListMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum MemberAttribute
<FlagsAttribute>
Public Enumeration MemberAttribute
[FlagsAttribute]
public enum class MemberAttribute
[<FlagsAttribute>]
type MemberAttribute
Members
Member name | Value | Description
None | 0 | No attributes.
CanRead | 1 | Specifies that property readable.
CanWrite | 2 | Specifies that property writeable.
NoDescription | 4 | Specifies that no description should be generated for a member.
NoIntellisense | 8 | Specifies that member is hidden for intellisense.
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


MSSqlRepository Class

MSSqlRepository Class
Represents properties and methods to perform code completion functionality intended to use for SQL language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionSqlRepositoryBase
Alternet.Syntax.CodeCompletionMSSqlRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MSSqlRepository : SqlRepositoryBase
Public Class MSSqlRepository
    Inherits SqlRepositoryBase
public ref class MSSqlRepository : public SqlRepositoryBase
type MSSqlRepository =
    class
        inherit SqlRepositoryBase
    end

The MSSqlRepository type exposes the following members.

Constructors
 | Name | Description
Public method | MSSqlRepository | Initializes a new instance of the SqlRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from SqlRepositoryBase.)
Public method | FillReswords | (Inherited from SqlRepositoryBase.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from SqlRepositoryBase.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | LoadDataFromXml | (Inherited from SqlRepositoryBase.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from SqlRepositoryBase.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from SqlRepositoryBase.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Reswords | (Inherited from SqlRepositoryBase.)
Public property | SchemaName | Gets or sets name of the SQL schema. (Inherited from SqlRepositoryBase.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Tables | Represents list of tables. (Inherited from SqlRepositoryBase.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


MSSqlRepository Constructor

MSSqlRepository Constructor
Initializes a new instance of the SqlRepository class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MSSqlRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
MSSqlRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> MSSqlRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

MSSqlRepository Class
Alternet.Syntax.CodeCompletion Namespace


MSSqlRepository Methods

MSSqlRepository Methods

The MSSqlRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from SqlRepositoryBase.)
Public method | FillReswords | (Inherited from SqlRepositoryBase.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from SqlRepositoryBase.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | LoadDataFromXml | (Inherited from SqlRepositoryBase.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

MSSqlRepository Class
Alternet.Syntax.CodeCompletion Namespace


MSSqlRepository Properties

MSSqlRepository Properties

The MSSqlRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from SqlRepositoryBase.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from SqlRepositoryBase.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Reswords | (Inherited from SqlRepositoryBase.)
Public property | SchemaName | Gets or sets name of the SQL schema. (Inherited from SqlRepositoryBase.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Tables | Represents list of tables. (Inherited from SqlRepositoryBase.)
Top
See Also

Reference

MSSqlRepository Class
Alternet.Syntax.CodeCompletion Namespace


MSSqlRepository Events

MSSqlRepository Events

The MSSqlRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

MSSqlRepository Class
Alternet.Syntax.CodeCompletion Namespace


NetListMembers Class

NetListMembers Class
Represents data collection related to popup list box controls used to describe NET. family code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionNetListMembers
Alternet.Syntax.CodeCompletionCListMembers
Alternet.Syntax.CodeCompletionCsListMembers
Alternet.Syntax.CodeCompletionJsListMembers
Alternet.Syntax.CodeCompletionVbListMembers

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NetListMembers : ListMembers
Public Class NetListMembers
    Inherits ListMembers
public ref class NetListMembers : public ListMembers
type NetListMembers =
    class
        inherit ListMembers
    end

The NetListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | NetListMembers | Initializes a new instance of the NetListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Overrides ListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


NetListMembers Constructor

NetListMembers Constructor
Initializes a new instance of the NetListMembers class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetListMembers()
Public Sub New
public:
NetListMembers()
new : unit -> NetListMembers
See Also

Reference

NetListMembers Class
Alternet.Syntax.CodeCompletion Namespace


NetListMembers Methods

NetListMembers Methods

The NetListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Overrides ListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

NetListMembers Class
Alternet.Syntax.CodeCompletion Namespace


NetListMembers.GetColumnText Method

NetListMembersGetColumnText Method
Returns text from given list member in the specified column.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
Specifies index of list member.
column
Type: SystemInt32
Specifies index of column.

Return Value

Type: String
Text representing specified list member.

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

NetListMembers Class
Alternet.Syntax.CodeCompletion Namespace


NetListMembers Properties

NetListMembers Properties

The NetListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

NetListMembers Class
Alternet.Syntax.CodeCompletion Namespace


NetListMembers Events

NetListMembers Events

The NetListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

NetListMembers Class
Alternet.Syntax.CodeCompletion Namespace


NetNamespace Class

NetNamespace Class
Represents a .NET namespace.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionNetNamespace

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NetNamespace : INetNamespace
Public Class NetNamespace
    Implements INetNamespace
public ref class NetNamespace : INetNamespace
type NetNamespace =
    class
        interface INetNamespace
    end

The NetNamespace type exposes the following members.

Constructors
 | Name | Description
Public method | NetNamespace(String, Boolean) | Initializes a new instance of the NetNamespace with specified parameters.
Public method | NetNamespace(String, Boolean, String) | Initializes a new instance of the NetNamespace with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetName | Gets name or alias of the namespace.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets alias of the namespace.
Public property | Namespace | Gets or sets name of the namespace.
Public property | System | Reserved for internal use.
Public property | UserData | Reserved for internal use.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


NetNamespace Constructor

NetNamespace Constructor
Overload List
 | Name | Description
Public method | NetNamespace(String, Boolean) | Initializes a new instance of the NetNamespace with specified parameters.
Public method | NetNamespace(String, Boolean, String) | Initializes a new instance of the NetNamespace with specified parameters.
Top
See Also

Reference

NetNamespace Class
Alternet.Syntax.CodeCompletion Namespace


NetNamespace Constructor (String, Boolean)

NetNamespace Constructor (String, Boolean)
Initializes a new instance of the NetNamespace with specified parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetNamespace(
    string nspace,
    bool system
)
Public Sub New (
    nspace As String,
    system As Boolean
)
public:
NetNamespace(
    String^ nspace,
    bool system
)
new :
        nspace : string *
        system : bool -> NetNamespace

Parameters

nspace
Type: SystemString
Specifies namespace name.
system
Type: SystemBoolean
Specifies namespace System property.
See Also

Reference

NetNamespace Class
NetNamespace Overload
Alternet.Syntax.CodeCompletion Namespace


NetNamespace Constructor (String, Boolean, String)

NetNamespace Constructor (String, Boolean, String)
Initializes a new instance of the NetNamespace with specified parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetNamespace(
    string nspace,
    bool system,
    string alias
)
Public Sub New (
    nspace As String,
    system As Boolean,
    alias As String
)
public:
NetNamespace(
    String^ nspace,
    bool system,
    String^ alias
)
new :
        nspace : string *
        system : bool *
        alias : string -> NetNamespace

Parameters

nspace
Type: SystemString
Specifies namespace name.
system
Type: SystemBoolean
Specifies namespace System property.
alias
Type: SystemString
Specifies namespace Alias property.
See Also

Reference

NetNamespace Class
NetNamespace Overload
Alternet.Syntax.CodeCompletion Namespace


NetNamespace Methods

NetNamespace Methods

The NetNamespace type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetName | Gets name or alias of the namespace.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NetNamespace Class
Alternet.Syntax.CodeCompletion Namespace


NetNamespace.GetName Method

NetNamespaceGetName Method
Gets name or alias of the namespace.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetName()
Public Overridable Function GetName As String
public:
virtual String^ GetName()
abstract GetName : unit -> string
override GetName : unit -> string

Return Value

Type: String

Implements

INetNamespaceGetName
See Also

Reference

NetNamespace Class
Alternet.Syntax.CodeCompletion Namespace


NetNamespace Properties

NetNamespace Properties

The NetNamespace type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets alias of the namespace.
Public property | Namespace | Gets or sets name of the namespace.
Public property | System | Reserved for internal use.
Public property | UserData | Reserved for internal use.
Top
See Also

Reference

NetNamespace Class
Alternet.Syntax.CodeCompletion Namespace


NetNamespace.Alias Property

NetNamespaceAlias Property
Gets or sets alias of the namespace.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Alias { get; set; }
Public Overridable Property Alias As String
    Get
    Set
public:
virtual property String^ Alias {
    String^ get ();
    void set (String^ value);
}
abstract Alias : string with get, set
override Alias : string with get, set

Property Value

Type: String

Implements

INetNamespaceAlias
See Also

Reference

NetNamespace Class
Alternet.Syntax.CodeCompletion Namespace


NetNamespace.Namespace Property

NetNamespaceNamespace Property
Gets or sets name of the namespace.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Namespace { get; set; }
Public Overridable Property Namespace As String
    Get
    Set
public:
virtual property String^ Namespace {
    String^ get ();
    void set (String^ value);
}
abstract Namespace : string with get, set
override Namespace : string with get, set

Property Value

Type: String

Implements

INetNamespaceNamespace
See Also

Reference

NetNamespace Class
Alternet.Syntax.CodeCompletion Namespace


NetNamespace.System Property

NetNamespaceSystem Property
Reserved for internal use.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool System { get; set; }
Public Overridable Property System As Boolean
    Get
    Set
public:
virtual property bool System {
    bool get ();
    void set (bool value);
}
abstract System : bool with get, set
override System : bool with get, set

Property Value

Type: Boolean

Implements

INetNamespaceSystem
See Also

Reference

NetNamespace Class
Alternet.Syntax.CodeCompletion Namespace


NetNamespace.UserData Property

NetNamespaceUserData Property
Reserved for internal use.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object UserData { get; set; }
Public Overridable Property UserData As Object
    Get
    Set
public:
virtual property Object^ UserData {
    Object^ get ();
    void set (Object^ value);
}
abstract UserData : Object with get, set
override UserData : Object with get, set

Property Value

Type: Object

Implements

INetNamespaceUserData
See Also

Reference

NetNamespace Class
Alternet.Syntax.CodeCompletion Namespace


NetNodeType Enumeration

NetNodeType Enumeration
Defines types of syntax nodes used to create a hierarchical tree view that examines code text as a collection of syntax members. Intended to use with collection of .NET languages, like C#, J#, and VB.NET.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum NetNodeType
Public Enumeration NetNodeType
public enum class NetNodeType
type NetNodeType
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Unit | 1 | Specifies that syntax node corresponds to entire unit.
UsingList | 2 | Specifies that syntax node corresponds to the list of external namespaces.
Using | 3 | Specifies that syntax node corresponds to external namespace.
UsingAlias | 4 | Specifies that syntax node corresponds to user-defined symbol representing a namespace.
Alias | 5 | Specifies that syntax node corresponds to external alias directive.
AliasList | 6 | Specifies that syntax node corresponds to the list of external alias directives.
Namespace | 7 | Specifies that syntax node corresponds to namespace.
Class | 8 | Specifies that syntax node corresponds to class.
Struct | 9 | Specifies that syntax node corresponds to structure.
Union | 10 | Specifies that syntax node corresponds to union.
Interface | 11 | Specifies that syntax node corresponds to interface.
Enum | 12 | Specifies that syntax node corresponds to enumeration.
Module | 13 | Specifies that syntax node corresponds to module.
Field | 14 | Specifies that syntax node corresponds to field.
Constant | 15 | Specifies that syntax node corresponds to constant.
LocalVariable | 16 | Specifies that syntax node corresponds to local variable.
FixedVariable | 17 | Specifies that syntax node corresponds to fixed variable.
Method | 18 | Specifies that syntax node corresponds to method.
Constructor | 19 | Specifies that syntax node corresponds to constructor.
Destructor | 20 | Specifies that syntax node corresponds to destructor.
Delegate | 21 | Specifies that syntax node corresponds to delegate.
Property | 22 | Specifies that syntax node corresponds to property.
Event | 23 | Specifies that syntax node corresponds to event.
Operator | 24 | Specifies that syntax node corresponds to operator.
OperatorType | 25 | Specifies that syntax node corresponds to operator type.
Indexer | 26 | Specifies that syntax node corresponds to indexer.
Parameter | 27 | Specifies that syntax node corresponds to parameter.
ParameterList | 28 | Specifies that syntax node corresponds to list of parameters.
Argument | 29 | Specifies that syntax node corresponds to method argument.
ArgumentList | 30 | Specifies that syntax node corresponds to list of arguments.
Attribute | 31 | Specifies that syntax node corresponds to attribute.
AttributeList | 32 | Specifies that syntax node corresponds to list of attributes.
AttributeTarget | 33 | Specifies that syntax node corresponds to target of attribute.
VariableInitializer | 34 | Specifies that syntax node corresponds to variable initializer.
Identifier | 35 | Specifies that syntax node corresponds to identifier.
Name | 36 | Specifies that syntax node corresponds to name (identifier).
Type | 37 | Specifies that syntax node corresponds to type.
TypeName | 38 | Specifies that syntax node corresponds to type name.
NamespaceName | 39 | Specifies that syntax node corresponds to namespace name.
PointerDeclaration | 40 | Specifies that syntax node corresponds to pointer declaration.
ArrayDeclaration | 41 | Specifies that syntax node corresponds to array declaration.
ArrayIndexDeclaration | 42 | Specifies that syntax node corresponds to array index declaration.
PropertyAccessor | 43 | Specifies that syntax node corresponds to accessor of property.
EventAccessor | 44 | Specifies that syntax node corresponds to accessor of event.
Modifier | 45 | Specifies that syntax node corresponds to access modifier.
ArrayModifier | 46 | Specifies that syntax node corresponds to array modifier.
Region | 47 | Specifies that syntax node corresponds to region.
Define | 48 | Specifies that syntax node corresponds to conditional define.
ParameterModifier | 49 | Specifies that syntax node corresponds to parameter modifier.
OptionalParameter | 50 | Specifies that syntax node corresponds to default parameter.
ArraySpecifier | 51 | Specifies that syntax attribute corresponds to array specifier.
LocalConst | 52 | Specifies that syntax node corresponds to local constant.
Statement | 53 | Specifies that syntax node corresponds to language statement.
TypeList | 54 | Specifies that syntax node corresponds to list of types.
BaseType | 55 | Specifies that syntax node corresponds to base type.
NullableType | 56 | Specifies that syntax node corresponds to nullable type.
HandlesList | 57 | Specifies that syntax node corresponds to list of handles (procedure that handles some event).
ImplementsList | 58 | Specifies that syntax node corresponds to list of implements (interface implemented in the class).
ThrowsList | 59 | Specifies that syntax node corresponds to list of exception that can be handled by a method.
Comment | 60 | Specifies that syntax node corresponds to comment.
TypeParameter | 61 | Specifies that syntax node corresponds to generic type.
TypeParameterList | 62 | Specifies that syntax node corresponds to list of generic type.
TypeParameterConstraint | 63 | Specifies that syntax node corresponds to parameter constraint.
TypeParameterConstraintsClauseList | 64 | Specifies that syntax node corresponds to list of parameter constraints.
TypeParameterConstraintsClause | 65 | Specifies that syntax node corresponds to parameter constraint clause.
XmlComment | 66 | Specifies that syntax node corresponds to xml comment.
XmlUnit | 67 | Specifies that syntax node corresponds to xml unit.
XmlTag | 68 | Specifies that syntax node corresponds to xml open tag.
XmlCloseTag | 69 | Specifies that syntax node corresponds to xml close tag.
XmlParameter | 70 | Specifies that syntax node corresponds to xml parameter.
XmlParameterList | 71 | Specifies that syntax node corresponds to list of xml parameters.
XmlBody | 72 | Specifies that syntax node corresponds to xml body.
XmlEmbeddedExpression | 73 | Specifies that xml node corresponds to xml embedded expression.
LocalConstantDeclarationStatement | 74 | Specifies that syntax node corresponds to declaration of local constant.
FixedDeclarationStatement | 75 | Specifies that syntax node corresponds to declaration of fixed variable.
IfStatement | 76 | Specifies that syntax node corresponds to "if" statement.
ElseStatement | 77 | Specifies that syntax node corresponds to "else" statement.
SwitchStatement | 78 | Specifies that syntax node corresponds to "switch" statement.
SwitchSectionStatement | 79 | Specifies that syntax node corresponds to "switch" section statement.
SwitchLabelStatement | 80 | Specifies that syntax node corresponds to "switch" label statement.
WhileStatement | 81 | Specifies that syntax node corresponds to "while" statement.
DoStatement | 82 | Specifies that syntax node corresponds to "do" statement.
DoWhileStatement | 83 | Specifies that syntax node corresponds to "do while" statement.
ForStatement | 84 | Specifies that syntax node corresponds to "for" statement.
ForConditionStatement | 85 | Specifies that syntax node corresponds to "for" condition statement.
ForInitializerStatement | 86 | Specifies that syntax node corresponds to "for" initializer statement.
ForIteratorStatement | 87 | Specifies that syntax node corresponds to "for" iterator statement.
ForEachStatement | 88 | Specifies that syntax node corresponds to "for each" statement.
ForEachInitializerStatement | 89 | Specifies that syntax node corresponds to "for each" initializer statement.
ForVarControlStatement | 90 | Specifies that syntax node corresponds to "for" var control statement.
ForVarControlRestStatement | 91 | Specifies that syntax node corresponds to "for" var control rest statement.
VariableDeclaratorsRestStatement | 92 | Specifies that syntax node corresponds to variable declarators rest statement.
Annotation | 93 | Specifies that syntax node corresponds to "Annotation".
ElementValuePair | 94 | Specifies that syntax node corresponds to "Element Value Pair".
AssertStatement | 95 | Specifies that syntax node corresponds to "assert" statement.
SynchronizedStatement | 96 | Specifies that syntax node corresponds to "synchronized" statement.
AsmStatement | 97 | Specifies that syntax node corresponds to "asm" statement.
VariableModifier | 98 | Specifies that syntax node corresponds to variable modifier.
VariableModifierList | 99 | Specifies that syntax node corresponds to list of variable modifiers.
VariableDeclaratorsRest | 100 | Specifies that syntax node corresponds to list of variable declarator rest.
BreakStatement | 101 | Specifies that syntax node corresponds to "break" statement.
ContinueStatement | 102 | Specifies that syntax node corresponds to "continue" statement.
GotoStatement | 103 | Specifies that syntax node corresponds to "goto" statement.
ReturnStatement | 104 | Specifies that syntax node corresponds to "return" statement.
ThrowStatement | 105 | Specifies that syntax node corresponds to "throw" statement.
TryStatement | 106 | Specifies that syntax node corresponds to "try" statement.
CatchStatement | 107 | Specifies that syntax node corresponds to "catch" statement.
FinallyStatement | 108 | Specifies that syntax node corresponds to "finally" statement.
CheckedStatement | 109 | Specifies that syntax node corresponds to "checked" statement.
UncheckedStatement | 110 | Specifies that syntax node corresponds to "unchecked" statement.
UnsafeStatement | 111 | Specifies that syntax node corresponds to "unsafe" statement.
LockStatement | 112 | Specifies that syntax node corresponds to "lock" statement.
UsingStatement | 113 | Specifies that syntax node corresponds to "using" statement.
FixedStatement | 114 | Specifies that syntax node corresponds to "fixed" statement.
LabeledStatement | 115 | Specifies that syntax node corresponds to "labeled" statement.
BlockStatement | 116 | Specifies that syntax node corresponds to "block" statement.
ExpressionStatement | 117 | Specifies that syntax node corresponds to expression statement.
YieldStatement | 118 | Specifies that syntax node corresponds to "yield" statement.
Assignment | 119 | Specifies attribute for assignment expression.
Key | 120 | Specifies attribute for key anonymous type initializer expression.
AddHandlerStatement | 121 | Specifies that syntax node corresponds to "add handler" statement.
AwaitStatement | 122 | Specifies that syntax node corresponds to "await" statement.
CallStatement | 123 | Specifies that syntax node corresponds to "call" statement.
CaseStatement | 124 | Specifies that syntax node corresponds to "case" statement.
CaseElseStatement | 125 | Specifies that syntax node corresponds to "case else" statement.
ElseIfStatement | 126 | Specifies that syntax node corresponds to "else if" statement.
EndStatement | 127 | Specifies that syntax node corresponds to "end" statement.
EraseStatement | 128 | Specifies that syntax node corresponds to "erase" statement.
ErrorStatement | 129 | Specifies that syntax node corresponds to "error" statement.
ExitStatement | 130 | Specifies that syntax node corresponds to "exit" statement.
MidAssignmentStatement | 131 | Specifies that syntax node corresponds to "mid assignment" statement.
OnErrorStatement | 132 | Specifies that syntax node corresponds to "on error" statement.
RaiseEventStatement | 133 | Specifies that syntax node corresponds to "raise event" statement.
RedimStatement | 134 | Specifies that syntax node corresponds to "redim" statement.
RemoveHandlerStatement | 135 | Specifies that syntax node corresponds to "remove handler" statement.
ResumeStatement | 136 | Specifies that syntax node corresponds to "resume" statement.
SelectStatement | 137 | Specifies that syntax node corresponds to "select" statement.
StopStatement | 138 | Specifies that syntax node corresponds to "stop" statement.
SyncLockStatement | 139 | Specifies that syntax node corresponds to "synclock" statement.
WithStatement | 140 | Specifies that syntax node corresponds to "with" statement.
WithStatementMember | 141 | Specifies that syntax node corresponds to with member.
EmptyStatement | 142 | Specifies that syntax node corresponds to "empty" statement.
OrderExpressionList | 143 | Specifies that syntax node corresponds to "LINQ Order Expression" element.
JoinConditionList | 144 | Specifies that syntax node corresponds to "LINQ Join Condition List" element.
CollectionRangeVariableDeclarationList | 145 | Specifies that syntax node corresponds to "LINQ Collection Range Variable Declaration List" element.
CollectionRangeVariableDeclaration | 146 | Specifies that syntax node corresponds to "LINQ Collection Range Variable Declaration" element.
JoinCondition | 147 | Specifies that syntax node corresponds to "LINQ Join Condition" element.
ExpressionRangeVariableDeclarationList | 148 | Specifies that syntax node corresponds to "LINQ Expression Range Variable Declaration List" element.
ExpressionRangeVariableDeclaration | 149 | Specifies that syntax node corresponds to "LINQ Expression Range Variable Declaration" element.
DistinctOperator | 150 | Specifies that syntax node corresponds to "distinct operator" element.
TakeOperator | 151 | Specifies that syntax node corresponds to "take operator" element.
TakeWhileOperator | 152 | Specifies that syntax node corresponds to "take while operator" element.
SkipOperator | 153 | Specifies that syntax node corresponds to "skip operator" element.
SkipWhileOperator | 154 | Specifies that syntax node corresponds to "skip while operator" element.
ExpressionList | 155 | Specifies that syntax node corresponds to expression list.
Expression | 156 | Specifies that syntax node corresponds to expression.
ConditionalExpression | 157 | Specifies that syntax node corresponds to "conditional" expression.
NullConditionalExpression | 158 | Specifies that syntax node corresponds to "null-conditional" expression.
AssignmentExpression | 159 | Specifies that syntax node corresponds to "assignment" expression.
ConditionalOrExpression | 160 | Specifies that syntax node corresponds to "conditional or" expression.
ConditionalAndExpression | 161 | Specifies that syntax node corresponds to "conditional and" expression.
InclusiveOrExpression | 162 | Specifies that syntax node corresponds to "inclusive or" expression.
ExclusiveOrExpression | 163 | Specifies that syntax node corresponds to "exclusive or" expression.
AndExpression | 164 | Specifies that syntax node corresponds to "and" expression.
NotExpression | 165 | Specifies that syntax node corresponds to "not" expression.
EqualityExpression | 166 | Specifies that syntax node corresponds to "equality" expression.
RelationalExpression | 167 | Specifies that syntax node corresponds to "relation" expression.
AsIsExpression | 168 | Specifies that syntax node corresponds to "as is" expression.
InExpression | 169 | Specifies that syntax node corresponds to "in" expression.
ShiftExpression | 170 | Specifies that syntax node corresponds to "shift" expression.
AdditiveExpression | 171 | Specifies that syntax node corresponds to "additive" expression.
MultiplicativeExpression | 172 | Specifies that syntax node corresponds to "multiplicative" expression.
PrefixedUnaryExpression | 173 | Specifies that syntax node corresponds to "prefixed unary" expression.
UnaryExpression | 174 | Specifies that syntax node corresponds to "unary" expression.
CastExpression | 175 | Specifies that syntax node corresponds to "cast" expression.
CastInvocationExpression | 176 | Specifies that syntax node corresponds to "cast invocation" expression.
CastInvocationTargetExpression | 177 | Specifies that syntax node corresponds to "cast invocation target" expression.
CastTargetExpression | 178 | Specifies that syntax node corresponds to "cast target" expression.
PrimaryExpression | 179 | Specifies that syntax node corresponds to "primary" expression.
ArrayCreationExpression | 180 | Specifies that syntax node corresponds to "array creation" expression.
ObjectCreationExpression | 181 | Specifies that syntax node corresponds to "object creation" expression.
ArrayInitializerExpression | 182 | Specifies that syntax node corresponds to "array initializer" expression.
TupleInitializerExpression | 183 | Specifies that syntax node corresponds to "Tuple initializer" expression.
StackallocExpression | 184 | Specifies that syntax node corresponds to "stackalloc" expression.
BaseAccessExpression | 185 | Specifies that syntax node corresponds to "base access" expression.
ThisAccessExpression | 186 | Specifies that syntax node corresponds to "this access" expression.
MemberAccessExpression | 187 | Specifies that syntax node corresponds to "member access" expression.
DescendentMemberAccessExpression | 188 | Specifies that syntax node corresponds to "descendent member access" expression.
NamespaceAliasExpression | 189 | Specifies that syntax node corresponds to "namespace alias" expression.
PointerMemberAccessExpression | 190 | Specifies that syntax node corresponds to "pointer member access" expression.
ElementAccessExpression | 191 | Specifies that syntax node corresponds to "element access" expression.
InvocationExpression | 192 | Specifies that syntax node corresponds to "invocation" expression.
CheckedExpression | 193 | Specifies that syntax node corresponds to "checked" expression.
UncheckedExpression | 194 | Specifies that syntax node corresponds to "unchecked" expression.
NameofExpression | 195 | Specifies that syntax node corresponds to "nameof" expression.
TypeofExpression | 196 | Specifies that syntax node corresponds to "typeof" expression.
SizeofExpression | 197 | Specifies that syntax node corresponds to "sizeof" expression.
ParenthesizedExpression | 198 | Specifies that syntax node corresponds to "parenthesized" expression.
PostIncrementExpression | 199 | Specifies that syntax node corresponds to "post increment" expression.
PostDecrementExpression | 200 | Specifies that syntax node corresponds to "post decrement" expression.
DefaultExpression | 201 | Specifies that syntax node corresponds to "default" expression.
GenericExpression | 202 | Specifies that syntax node corresponds to "generic" expression.
AnonymousMethodExpression | 203 | Specifies that syntax node corresponds to "anonymous method" expression.
NullCoalescingExpression | 204 | Specifies that syntax node corresponds to "null coalescing" expression.
ImplicitVariable | 205 | Specifies that syntax node corresponds to implicit variable declaration.
TupleVariable | 206 | Specifies that syntax node corresponds to tuple variable declaration.
VariableReference | 207 | Specifies that syntax attribute corresponds to implicit variable type reference.
LambdaExpression | 208 | Specifies that syntax node corresponds to "lambda" expression.
LambdaParameter | 209 | Specifies that syntax node corresponds to "lambda" parameter.
LambdaParameterList | 210 | Specifies that syntax node corresponds to "lambda" parameter list.
MemberInitializer | 211 | Specifies that syntax node corresponds to member initializer expression.
ObjectInitializer | 212 | Specifies that syntax node corresponds to object or collection initializer expression.
AnonymousTypeInitializer | 213 | Specifies that syntax node corresponds to anonymous type initializer expression.
TupleMembersList | 214 | Specifies that syntax node corresponds to Tuple member list.
TupleMember | 215 | Specifies that syntax node corresponds to Tuple member.
FieldInitializer | 216 | Specifies that syntax node corresponds to field initializer expression.
QueryExpression | 217 | Specifies that syntax node corresponds to "query" expression.
FromClause | 218 | Specifies that syntax node corresponds to from clause of "query" expression.
JoinClauseList | 219 | Specifies that syntax node corresponds to join clause list of "query" expression.
JoinClause | 220 | Specifies that syntax node corresponds to join clause of "query" expression.
GroupJoinClause | 221 | Specifies that syntax node corresponds to group join clause of "query" expression.
LetClause | 222 | Specifies that syntax node corresponds to let clause of "query" expression.
WhereClause | 223 | Specifies that syntax node corresponds to where clause of "query" expression.
GroupClause | 224 | Specifies that syntax node corresponds to group by clause of "query" expression.
OrderByClause | 225 | Specifies that syntax node corresponds to order by clause of "query" expression.
SelectClause | 226 | Specifies that syntax node corresponds to select clause of "query" expression.
QueryContinuation | 227 | Specifies that syntax node corresponds to query continuation clause of "query" expression.
OrderingDirection | 228 | Specifies that syntax node corresponds to ascending or descending attribute of order clause of "query" expression.
OrderExpression | 229 | Specifies that syntax node corresponds to order expression of order clause of "query" expression.
AddressofExpression | 230 | Specifies that syntax node corresponds to "addressof" expression.
GetTypeExpression | 231 | Specifies that syntax node corresponds to "gettype" expression.
CollectionInitializerExpression | 232 | Specifies that syntax node corresponds to "collection initializer" expression.
OptionStatement | 233 | Specifies that syntax node corresponds to Option statement.
EqualityOrAssignmentExpression | 234 | Specifies that syntax node corresponds to equality or assignment expression.
Extern | 235 | Specifies that syntax node corresponds extern.
EnumBody | 236 | Specifies that syntax node corresponds to enum body.
TypeDeclaration | 237 | Specifies that syntax node corresponds to type declaration.
DeleteExpression | 238 | Specifies that syntax node corresponds to "delete" expression.
InstanceOfExpression | 239 | Specifies that syntax node corresponds to "instanceof" expression.
PrototypeExpression | 240 | Specifies that syntax node corresponds to "function prototype" expression.
TypeExpression | 241 | Specifies that syntax node corresponds to "type definition" expression.
RegularExpression | 242 | Specifies that syntax node corresponds to "regular" expression.
TypeModifier | 243 | Specifies that syntax attribute corresponds to type reference.
Execute | 244 | Specifies that syntax node corresponds to "Execute" statement.
ExecuteGlobal | 245 | Specifies that syntax node corresponds to "ExecuteGlobal" statement.
Randomize | 246 | Specifies that syntax node corresponds to "Randomize" statement.
SetStatement | 247 | Specifies that syntax node corresponds to "Set" statement.
ImpExpression | 248 | Specifies that syntax node corresponds to "Imp" expression.
Macro | 249 | Specifies that syntax node corresponds to the Macro.
MacroField | 250 | Specifies that syntax node corresponds to the Macro Field.
FunctionPointerInitializer | 251 | Specifies that syntax node corresponds to function pointer initializer expression.
FunctionPointer | 252 | Specifies that syntax node corresponds to Function Pointer.
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


NetParameterInfo Class

NetParameterInfo Class
Represents Parameter Info data related to popup window and popup hint controls used to describe C# language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionParameterInfo
Alternet.Syntax.CodeCompletionNetParameterInfo
Alternet.Syntax.CodeCompletionCParameterInfo
Alternet.Syntax.CodeCompletionCsParameterInfo
Alternet.Syntax.CodeCompletionJsParameterInfo
Alternet.Syntax.CodeCompletionVbParameterInfo

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NetParameterInfo : ParameterInfo
Public Class NetParameterInfo
    Inherits ParameterInfo
public ref class NetParameterInfo : public ParameterInfo
type NetParameterInfo =
    class
        inherit ParameterInfo
    end

The NetParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | NetParameterInfo | Initializes a new instance of the NetParameterInfo class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides ListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


NetParameterInfo Constructor

NetParameterInfo Constructor
Initializes a new instance of the NetParameterInfo class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetParameterInfo()
Public Sub New
public:
NetParameterInfo()
new : unit -> NetParameterInfo
See Also

Reference

NetParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


NetParameterInfo Methods

NetParameterInfo Methods

The NetParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides ListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

NetParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


NetParameterInfo.GetColumnText Method

NetParameterInfoGetColumnText Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
column
Type: SystemInt32

Return Value

Type: String

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

NetParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


NetParameterInfo Properties

NetParameterInfo Properties

The NetParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

NetParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


NetParameterInfo Events

NetParameterInfo Events

The NetParameterInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

NetParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository Class

NETRepository Class
Represents properties and methods to perform code completion functionality intended to use for .NET family of languages.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionNETRepository
Alternet.Syntax.CodeCompletionCRepository
Alternet.Syntax.CodeCompletionReflectionRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NETRepository : CodeCompletionRepository,
    INETRepository, IDisposable
Public Class NETRepository
    Inherits CodeCompletionRepository
    Implements INETRepository, IDisposable
public ref class NETRepository : public CodeCompletionRepository,
    INETRepository, IDisposable
type NETRepository =
    class
        inherit CodeCompletionRepository
        interface INETRepository
        interface IDisposable
    end

The NETRepository type exposes the following members.

Constructors
 | Name | Description
Public method | NETRepository | Initializes a new instance of the NETRepository class with specified parameters.
Top
Methods
 | Name | Description
Public method | ClearNamespaces | Clears namespace list.
Public method | ClearObjects | Clears object list.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Overrides CodeCompletionRepositoryFillMember(IListMembers, Object, String, CodeCompletionScope).)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Overrides CodeCompletionRepositoryFillMember(IListMembers, Object, String, Int32, CodeCompletionScope).)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Overrides CodeCompletionRepositoryFindReferences(ISyntaxNode, ISyntaxNodes).)
Public method | GetAutoFormatNode | Obtains block node at specified position.
 | GetBlockNode | Retrieves block node nearest to specified node.
 | GetBlockOrMethodNode | Retrieves block or method node nearest to specified node.
Public method | GetCodeSnippets | Returns code snippets for the given language. (Overrides CodeCompletionRepositoryGetCodeSnippets(String).)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text.
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node.
Public method | GetDescription | Obtains description of some language element. (Overrides CodeCompletionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetInvocationNode | Retrieves invocation node at specified position.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Overrides CodeCompletionRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope).)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Overrides CodeCompletionRepositoryGetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
 | GetMethodNode | Retrieves method node nearest to the specified node.
Public method | GetMethodType | Obtains information about some method of specified language element. (Overrides CodeCompletionRepositoryGetMethodType(String, ISyntaxNode, String, Point, Point, Int32, Int32, CodeCompletionScope).)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Overrides CodeCompletionRepositoryGetNodeType(String, ISyntaxNode, Point).)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Overrides CodeCompletionRepositoryGetQuickInfo(Object).)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Overrides CodeCompletionRepositoryGetQuickInfo(ISyntaxNode).)
Public method | GetRegisteredObject | Retrieves registered object by its name.
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Overrides CodeCompletionRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
 | GetStatementNode | Retrieves block node nearest to specified node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name.
 | GetXmlCommentNode | Retrieves xml comment node nearest to the specified node.
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment.
 | IsBinaryExpressionNode | Indicates whether specified node is a binary expression node.
 | IsBlockNode | Indicates whether specified node is a block node (contains block statement).
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
 | IsInvocationNode | Indicates whether specified node is a invocation node (contains call of some method or function).
 | IsMethodNode | Indicates whether specified node is a method node (contains declaration of some method, constructor, destructor and so on).
 | IsPrefixedUnaryExpressionNode | Indicates whether specified node is a binary expression node.
 | IsStatementNode | Indicates whether specified node is a a statement node.
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Overrides CodeCompletionRepositoryIsStructureGuideNode(ISyntaxNode, IRange).)
 | IsUnaryExpressionNode | Indicates whether specified node is a binary expression node.
 | IsVariableInitializer | Indicates whether specified node is a binary expression node.
 | IsXmlCommentNode | Indicates whether specified node is a xml comment node (contains xml comment).
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list.
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list.
Public method | RegisterObject | Adds specified object for code completion to the object list.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list.
Public method | UnregisterObject | Removes specified object from the object list.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion.
Public property | BaseClassType | Gets or sets name of the base type.
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list.
Public property | Objects | Represents object list in a form of key-value pairs.
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


NETRepository Constructor

NETRepository Constructor
Initializes a new instance of the NETRepository class with specified parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NETRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
NETRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> NETRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository Methods

NETRepository Methods

The NETRepository type exposes the following members.

Methods
 | Name | Description
Public method | ClearNamespaces | Clears namespace list.
Public method | ClearObjects | Clears object list.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Overrides CodeCompletionRepositoryFillMember(IListMembers, Object, String, CodeCompletionScope).)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Overrides CodeCompletionRepositoryFillMember(IListMembers, Object, String, Int32, CodeCompletionScope).)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Overrides CodeCompletionRepositoryFindReferences(ISyntaxNode, ISyntaxNodes).)
Public method | GetAutoFormatNode | Obtains block node at specified position.
 | GetBlockNode | Retrieves block node nearest to specified node.
 | GetBlockOrMethodNode | Retrieves block or method node nearest to specified node.
Public method | GetCodeSnippets | Returns code snippets for the given language. (Overrides CodeCompletionRepositoryGetCodeSnippets(String).)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text.
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node.
Public method | GetDescription | Obtains description of some language element. (Overrides CodeCompletionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetInvocationNode | Retrieves invocation node at specified position.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Overrides CodeCompletionRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope).)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Overrides CodeCompletionRepositoryGetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
 | GetMethodNode | Retrieves method node nearest to the specified node.
Public method | GetMethodType | Obtains information about some method of specified language element. (Overrides CodeCompletionRepositoryGetMethodType(String, ISyntaxNode, String, Point, Point, Int32, Int32, CodeCompletionScope).)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Overrides CodeCompletionRepositoryGetNodeType(String, ISyntaxNode, Point).)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Overrides CodeCompletionRepositoryGetQuickInfo(Object).)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Overrides CodeCompletionRepositoryGetQuickInfo(ISyntaxNode).)
Public method | GetRegisteredObject | Retrieves registered object by its name.
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Overrides CodeCompletionRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
 | GetStatementNode | Retrieves block node nearest to specified node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name.
 | GetXmlCommentNode | Retrieves xml comment node nearest to the specified node.
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment.
 | IsBinaryExpressionNode | Indicates whether specified node is a binary expression node.
 | IsBlockNode | Indicates whether specified node is a block node (contains block statement).
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
 | IsInvocationNode | Indicates whether specified node is a invocation node (contains call of some method or function).
 | IsMethodNode | Indicates whether specified node is a method node (contains declaration of some method, constructor, destructor and so on).
 | IsPrefixedUnaryExpressionNode | Indicates whether specified node is a binary expression node.
 | IsStatementNode | Indicates whether specified node is a a statement node.
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Overrides CodeCompletionRepositoryIsStructureGuideNode(ISyntaxNode, IRange).)
 | IsUnaryExpressionNode | Indicates whether specified node is a binary expression node.
 | IsVariableInitializer | Indicates whether specified node is a binary expression node.
 | IsXmlCommentNode | Indicates whether specified node is a xml comment node (contains xml comment).
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list.
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list.
Public method | RegisterObject | Adds specified object for code completion to the object list.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list.
Public method | UnregisterObject | Removes specified object from the object list.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.ClearNamespaces Method

NETRepositoryClearNamespaces Method
Clears namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearNamespaces()
Public Overridable Sub ClearNamespaces
public:
virtual void ClearNamespaces()
abstract ClearNamespaces : unit -> unit
override ClearNamespaces : unit -> unit
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.ClearObjects Method

NETRepositoryClearObjects Method
Clears object list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearObjects()
Public Overridable Sub ClearObjects
public:
virtual void ClearObjects()
abstract ClearObjects : unit -> unit
override ClearObjects : unit -> unit
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.FillMember Method

NETRepositoryFillMember Method
Overload List
 | Name | Description
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Overrides CodeCompletionRepositoryFillMember(IListMembers, Object, String, CodeCompletionScope).)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Overrides CodeCompletionRepositoryFillMember(IListMembers, Object, String, Int32, CodeCompletionScope).)
Top
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.FillMember Method (IListMembers, Object, String, CodeCompletionScope)

NETRepositoryFillMember Method (IListMembers, Object, String, CodeCompletionScope)
Obtains information about individual member of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FillMember(
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope
)
Public Overrides Sub FillMember (
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope
)
public:
virtual void FillMember(
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope
) override
abstract FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope -> unit
override FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope -> unit

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of member to retrieve.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
See Also

Reference

NETRepository Class
FillMember Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.FillMember Method (IListMembers, Object, String, Int32, CodeCompletionScope)

NETRepositoryFillMember Method (IListMembers, Object, String, Int32, CodeCompletionScope)
Obtains information about individual member of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FillMember(
    IListMembers members,
    Object member,
    string name,
    int paramIndex,
    CodeCompletionScope scope
)
Public Overrides Sub FillMember (
    members As IListMembers,
    member As Object,
    name As String,
    paramIndex As Integer,
    scope As CodeCompletionScope
)
public:
virtual void FillMember(
    IListMembers^ members,
    Object^ member,
    String^ name,
    int paramIndex,
    CodeCompletionScope scope
) override
abstract FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        paramIndex : int *
        scope : CodeCompletionScope -> unit
override FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        paramIndex : int *
        scope : CodeCompletionScope -> unit

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of member to retrieve.
paramIndex
Type: SystemInt32
Specifies index of current member parameter.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.

Implements

ICodeCompletionRepositoryFillMember(IListMembers, Object, String, Int32, CodeCompletionScope)
See Also

Reference

NETRepository Class
FillMember Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.FindReferences Method

NETRepositoryFindReferences Method
Locates all references to the node in the text.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int FindReferences(
    ISyntaxNode node,
    ISyntaxNodes references
)
Public Overrides Function FindReferences (
    node As ISyntaxNode,
    references As ISyntaxNodes
) As Integer
public:
virtual int FindReferences(
    ISyntaxNode^ node,
    ISyntaxNodes^ references
) override
abstract FindReferences :
        node : ISyntaxNode *
        references : ISyntaxNodes -> int
override FindReferences :
        node : ISyntaxNode *
        references : ISyntaxNodes -> int

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to find references.
references
Type: Alternet.SyntaxISyntaxNodes
Retrieves references to node.

Return Value

Type: Int32
Number of found references.

Implements

ICodeCompletionRepositoryFindReferences(ISyntaxNode, ISyntaxNodes)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetAutoFormatNode Method

NETRepositoryGetAutoFormatNode Method
Obtains block node at specified position.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode GetAutoFormatNode(
    ISyntaxNode node,
    bool extended,
    out Point startPt
)
Public Overridable Function GetAutoFormatNode (
    node As ISyntaxNode,
    extended As Boolean,
    <OutAttribute> ByRef startPt As Point
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetAutoFormatNode(
    ISyntaxNode^ node,
    bool extended,
    [OutAttribute] Point% startPt
)
abstract GetAutoFormatNode :
        node : ISyntaxNode *
        extended : bool *
        startPt : Point byref -> ISyntaxNode
override GetAutoFormatNode :
        node : ISyntaxNode *
        extended : bool *
        startPt : Point byref -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Node to check-up.
extended
Type: SystemBoolean
Specifies that search should be extended outside current scope.
startPt
Type: System.DrawingPoint
Retrieves position of block node.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.

Implements

INETRepositoryGetAutoFormatNode(ISyntaxNode, Boolean, Point)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetBlockNode Method

NETRepositoryGetBlockNode Method
Retrieves block node nearest to specified node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISyntaxNode GetBlockNode(
    ISyntaxNode node
)
Public Shared Function GetBlockNode (
    node As ISyntaxNode
) As ISyntaxNode
public:
static ISyntaxNode^ GetBlockNode(
    ISyntaxNode^ node
)
static member GetBlockNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetBlockOrMethodNode Method

NETRepositoryGetBlockOrMethodNode Method
Retrieves block or method node nearest to specified node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISyntaxNode GetBlockOrMethodNode(
    ISyntaxNode node
)
Public Shared Function GetBlockOrMethodNode (
    node As ISyntaxNode
) As ISyntaxNode
public:
static ISyntaxNode^ GetBlockOrMethodNode(
    ISyntaxNode^ node
)
static member GetBlockOrMethodNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block or method.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetCodeSnippets Method

NETRepositoryGetCodeSnippets Method
Returns code snippets for the given language.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeSnippetsProvider GetCodeSnippets(
    string language
)
Public Overrides Function GetCodeSnippets (
    language As String
) As ICodeSnippetsProvider
public:
virtual ICodeSnippetsProvider^ GetCodeSnippets(
    String^ language
) override
abstract GetCodeSnippets :
        language : string -> ICodeSnippetsProvider
override GetCodeSnippets :
        language : string -> ICodeSnippetsProvider

Parameters

language
Type: SystemString
Represents a language.

Return Value

Type: ICodeSnippetsProvider
ICodeCompletionProvider instance for a given language.

Implements

ICodeCompletionRepositoryGetCodeSnippets(String)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetCommentTemplate Method

NETRepositoryGetCommentTemplate Method
Returns xml comment template for given node in the text.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetCommentTemplate(
    Point position,
    ISyntaxNode node,
    string comment
)
Public Overridable Function GetCommentTemplate (
    position As Point,
    node As ISyntaxNode,
    comment As String
) As String
public:
virtual String^ GetCommentTemplate(
    Point position,
    ISyntaxNode^ node,
    String^ comment
)
abstract GetCommentTemplate :
        position : Point *
        node : ISyntaxNode *
        comment : string -> string
override GetCommentTemplate :
        position : Point *
        node : ISyntaxNode *
        comment : string -> string

Parameters

position
Type: System.DrawingPoint
Specifies position within the text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies node at given position.
comment
Type: SystemString
Specifies xml comment starting string.

Return Value

Type: String
Xml comment template.

Implements

INETRepositoryGetCommentTemplate(Point, ISyntaxNode, String)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetDeclarationNode Method

NETRepositoryGetDeclarationNode Method
Retrieves declaration node nearest to the specified node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode GetDeclarationNode(
    ISyntaxNode node
)
Public Overridable Function GetDeclarationNode (
    node As ISyntaxNode
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetDeclarationNode(
    ISyntaxNode^ node
)
abstract GetDeclarationNode :
        node : ISyntaxNode -> ISyntaxNode
override GetDeclarationNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing some declaration.

Implements

INETRepositoryGetDeclarationNode(ISyntaxNode)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetDescription Method

NETRepositoryGetDescription Method
Obtains description of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDescription(
    IListMembers members,
    ISyntaxNode node,
    Object member,
    string name,
    bool fullDescription
)
Public Overrides Function GetDescription (
    members As IListMembers,
    node As ISyntaxNode,
    member As Object,
    name As String,
    fullDescription As Boolean
) As String
public:
virtual String^ GetDescription(
    IListMembers^ members,
    ISyntaxNode^ node,
    Object^ member,
    String^ name,
    bool fullDescription
) override
abstract GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string
override GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies ListMembers interface used to get language-specific description.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode that representing language element to describe.
member
Type: SystemObject
Specifies language element to describe.
name
Type: SystemString
Specifies name of described language element.
fullDescription
Type: SystemBoolean
Specifies whether description should include name and type of the found element.

Return Value

Type: String
String that describes specified language element.

Implements

ICodeCompletionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetInvocationNode Method

NETRepositoryGetInvocationNode Method
Retrieves invocation node at specified position.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISyntaxNode GetInvocationNode(
    string text,
    ISyntaxNode node,
    Point position,
    out int paramIndex,
    out int paramCount
)
Public Shared Function GetInvocationNode (
    text As String,
    node As ISyntaxNode,
    position As Point,
    <OutAttribute> ByRef paramIndex As Integer,
    <OutAttribute> ByRef paramCount As Integer
) As ISyntaxNode
public:
static ISyntaxNode^ GetInvocationNode(
    String^ text,
    ISyntaxNode^ node,
    Point position,
    [OutAttribute] int% paramIndex,
    [OutAttribute] int% paramCount
)
static member GetInvocationNode :
        text : string *
        node : ISyntaxNode *
        position : Point *
        paramIndex : int byref *
        paramCount : int byref -> ISyntaxNode

Parameters

text
Type: SystemString
Text at specified position.
node
Type: Alternet.SyntaxISyntaxNode
Specifies node that contains invocation node.
position
Type: System.DrawingPoint
Specifies position to check-up.
paramIndex
Type: SystemInt32
Retrieves index of current parameter in the parameter list of invocation node.
paramCount
Type: SystemInt32
Retrieves number of the parameters of invocation node.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing method invocation.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetMemberType Method

NETRepositoryGetMemberType Method
Overload List
 | Name | Description
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Overrides CodeCompletionRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope).)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Overrides CodeCompletionRepositoryGetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
Top
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetMemberType Method (ISyntaxNode, Point, Object, String, CodeCompletionScope)

NETRepositoryGetMemberType Method (ISyntaxNode, Point, Object, String, CodeCompletionScope)
Obtains information about a member of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetMemberType(
    ISyntaxNode node,
    Point position,
    Object member,
    string name,
    out CodeCompletionScope scope
)
Public Overrides Function GetMemberType (
    node As ISyntaxNode,
    position As Point,
    member As Object,
    name As String,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetMemberType(
    ISyntaxNode^ node,
    Point position,
    Object^ member,
    String^ name,
    [OutAttribute] CodeCompletionScope% scope
) override
abstract GetMemberType :
        node : ISyntaxNode *
        position : Point *
        member : Object *
        name : string *
        scope : CodeCompletionScope byref -> Object
override GetMemberType :
        node : ISyntaxNode *
        position : Point *
        member : Object *
        name : string *
        scope : CodeCompletionScope byref -> Object

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies position of language element.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of the member to locate.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for this language element.

Return Value

Type: Object
Object representing information about found member.

Implements

ICodeCompletionRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope)
See Also

Reference

NETRepository Class
GetMemberType Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetMemberType Method (String, ISyntaxNode, String, Point, Point, CodeCompletionScope)

NETRepositoryGetMemberType Method (String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
Obtains information about some language element to perform code completion related operations.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetMemberType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out CodeCompletionScope scope
)
Public Overrides Function GetMemberType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetMemberType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] CodeCompletionScope% scope
) override
abstract GetMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object
override GetMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found language element.
position
Type: System.DrawingPoint
Specifies position of found language element in the code text and updates it if needed.
endPos
Type: System.DrawingPoint
Specifies end position of found language element in the code text and updates it if needed.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about language element to complete.

Implements

ICodeCompletionRepositoryGetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
See Also

Reference

NETRepository Class
GetMemberType Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetMethodNode Method

NETRepositoryGetMethodNode Method
Retrieves method node nearest to the specified node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISyntaxNode GetMethodNode(
    ISyntaxNode node
)
Public Shared Function GetMethodNode (
    node As ISyntaxNode
) As ISyntaxNode
public:
static ISyntaxNode^ GetMethodNode(
    ISyntaxNode^ node
)
static member GetMethodNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing some method.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetMethodType Method

NETRepositoryGetMethodType Method
Obtains information about some method of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetMethodType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out int paramIndex,
    out int paramCount,
    out CodeCompletionScope scope
)
Public Overrides Function GetMethodType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef paramIndex As Integer,
    <OutAttribute> ByRef paramCount As Integer,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetMethodType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] int% paramIndex,
    [OutAttribute] int% paramCount,
    [OutAttribute] CodeCompletionScope% scope
) override
abstract GetMethodType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        paramIndex : int byref *
        paramCount : int byref *
        scope : CodeCompletionScope byref -> Object
override GetMethodType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        paramIndex : int byref *
        paramCount : int byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found method.
position
Type: System.DrawingPoint
Retrieves start position of the method in the code text.
endPos
Type: System.DrawingPoint
Retrieves end position of the method in the code text.
paramIndex
Type: SystemInt32
Retrieves index of current parameter in the code text.
paramCount
Type: SystemInt32
Retrieves number of the parameters.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about found method.

Implements

ICodeCompletionRepositoryGetMethodType(String, ISyntaxNode, String, Point, Point, Int32, Int32, CodeCompletionScope)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetNodeType Method

NETRepositoryGetNodeType Method
Obtains information type of the SyntaxNode.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetNodeType(
    string text,
    ISyntaxNode node,
    Point position
)
Public Overrides Function GetNodeType (
    text As String,
    node As ISyntaxNode,
    position As Point
) As Object
public:
virtual Object^ GetNodeType(
    String^ text,
    ISyntaxNode^ node,
    Point position
) override
abstract GetNodeType :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object
override GetNodeType :
        text : string *
        node : ISyntaxNode *
        position : Point -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies starting position to search.

Return Value

Type: Object
Object representing type of found member.

Implements

ICodeCompletionRepositoryGetNodeType(String, ISyntaxNode, Point)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetQuickInfo Method

NETRepositoryGetQuickInfo Method
Overload List
 | Name | Description
Public method | GetQuickInfo(Object) | Returns information about the object. (Overrides CodeCompletionRepositoryGetQuickInfo(Object).)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Overrides CodeCompletionRepositoryGetQuickInfo(ISyntaxNode).)
Top
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetQuickInfo Method (Object)

NETRepositoryGetQuickInfo Method (Object)
Returns information about the object.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IQuickInfo GetQuickInfo(
    Object member
)
Public Overrides Function GetQuickInfo (
    member As Object
) As IQuickInfo
public:
virtual IQuickInfo^ GetQuickInfo(
    Object^ member
) override
abstract GetQuickInfo :
        member : Object -> IQuickInfo
override GetQuickInfo :
        member : Object -> IQuickInfo

Parameters

member
Type: SystemObject
Given object.

Return Value

Type: IQuickInfo
IQuickInfo instance.

Implements

ICodeCompletionRepositoryGetQuickInfo(Object)
See Also

Reference

NETRepository Class
GetQuickInfo Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetQuickInfo Method (ISyntaxNode)

NETRepositoryGetQuickInfo Method (ISyntaxNode)
Returns information about the object.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IQuickInfo GetQuickInfo(
    ISyntaxNode node
)
Public Overrides Function GetQuickInfo (
    node As ISyntaxNode
) As IQuickInfo
public:
virtual IQuickInfo^ GetQuickInfo(
    ISyntaxNode^ node
) override
abstract GetQuickInfo :
        node : ISyntaxNode -> IQuickInfo
override GetQuickInfo :
        node : ISyntaxNode -> IQuickInfo

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Given ISyntaxNode object.

Return Value

Type: IQuickInfo
IQuickInfo instance.

Implements

ICodeCompletionRepositoryGetQuickInfo(ISyntaxNode)
See Also

Reference

NETRepository Class
GetQuickInfo Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetRegisteredObject Method

NETRepositoryGetRegisteredObject Method
Retrieves registered object by its name.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetRegisteredObject(
    string name
)
Public Overridable Function GetRegisteredObject (
    name As String
) As Object
public:
virtual Object^ GetRegisteredObject(
    String^ name
)
abstract GetRegisteredObject :
        name : string -> Object
override GetRegisteredObject :
        name : string -> Object

Parameters

name
Type: SystemString
Specifies name of the object.

Return Value

Type: Object
Registered object found by its name.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetSpecialMemberType Method

NETRepositoryGetSpecialMemberType Method
Obtains information about a member of some language element in special cases.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetSpecialMemberType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out CodeCompletionScope scope
)
Public Overrides Function GetSpecialMemberType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetSpecialMemberType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] CodeCompletionScope% scope
) override
abstract GetSpecialMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object
override GetSpecialMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Text at specified position.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
name
Type: SystemString
Specifies name of the member to locate.
position
Type: System.DrawingPoint
Specifies position of language element.
endPos
Type: System.DrawingPoint
Specifies end position of found language element in the code text and updates it if needed.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for this language element.

Return Value

Type: Object
Object representing information about found member.

Implements

ICodeCompletionRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetStatementNode Method

NETRepositoryGetStatementNode Method
Retrieves block node nearest to specified node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISyntaxNode GetStatementNode(
    ISyntaxNode node
)
Public Shared Function GetStatementNode (
    node As ISyntaxNode
) As ISyntaxNode
public:
static ISyntaxNode^ GetStatementNode(
    ISyntaxNode^ node
)
static member GetStatementNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing a statement.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetTypeByName Method

NETRepositoryGetTypeByName Method
Retrieves type by its name.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetTypeByName(
    string type
)
Public Overridable Function GetTypeByName (
    type As String
) As Object
public:
virtual Object^ GetTypeByName(
    String^ type
)
abstract GetTypeByName :
        type : string -> Object
override GetTypeByName :
        type : string -> Object

Parameters

type
Type: SystemString
Specifies name of type.

Return Value

Type: Object
The found type.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetXmlCommentNode Method

NETRepositoryGetXmlCommentNode Method
Retrieves xml comment node nearest to the specified node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISyntaxNode GetXmlCommentNode(
    ISyntaxNode node
)
Public Shared Function GetXmlCommentNode (
    node As ISyntaxNode
) As ISyntaxNode
public:
static ISyntaxNode^ GetXmlCommentNode(
    ISyntaxNode^ node
)
static member GetXmlCommentNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing xml comment.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.GetXmlReferenceNode Method

NETRepositoryGetXmlReferenceNode Method
Returns declaration node corresponding to xml comment.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISyntaxNode GetXmlReferenceNode(
    ISyntaxNode node
)
Public Overridable Function GetXmlReferenceNode (
    node As ISyntaxNode
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetXmlReferenceNode(
    ISyntaxNode^ node
)
abstract GetXmlReferenceNode :
        node : ISyntaxNode -> ISyntaxNode
override GetXmlReferenceNode :
        node : ISyntaxNode -> ISyntaxNode

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Xml comment node.

Return Value

Type: ISyntaxNode
Declaration node if found; otherwise null.

Implements

INETRepositoryGetXmlReferenceNode(ISyntaxNode)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsBinaryExpressionNode Method

NETRepositoryIsBinaryExpressionNode Method
Indicates whether specified node is a binary expression node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBinaryExpressionNode(
    ISyntaxNode node
)
Public Shared Function IsBinaryExpressionNode (
    node As ISyntaxNode
) As Boolean
public:
static bool IsBinaryExpressionNode(
    ISyntaxNode^ node
)
static member IsBinaryExpressionNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is binary-expression node; otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsBlockNode Method

NETRepositoryIsBlockNode Method
Indicates whether specified node is a block node (contains block statement).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBlockNode(
    ISyntaxNode node
)
Public Shared Function IsBlockNode (
    node As ISyntaxNode
) As Boolean
public:
static bool IsBlockNode(
    ISyntaxNode^ node
)
static member IsBlockNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is block node; otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsDeclarationNode Method

NETRepositoryIsDeclarationNode Method
Overload List
 | Name | Description
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).
Top
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsDeclarationNode Method (ISyntaxNode)

NETRepositoryIsDeclarationNode Method (ISyntaxNode)
Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDeclarationNode(
    ISyntaxNode node
)
Public Overridable Function IsDeclarationNode (
    node As ISyntaxNode
) As Boolean
public:
virtual bool IsDeclarationNode(
    ISyntaxNode^ node
)
abstract IsDeclarationNode :
        node : ISyntaxNode -> bool
override IsDeclarationNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is declaration node; otherwise false.

Implements

INETRepositoryIsDeclarationNode(ISyntaxNode)
See Also

Reference

NETRepository Class
IsDeclarationNode Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsDeclarationNode Method (ISyntaxNode, Boolean)

NETRepositoryIsDeclarationNode Method (ISyntaxNode, Boolean)
Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDeclarationNode(
    ref ISyntaxNode node,
    bool checkRegions
)
Public Overridable Function IsDeclarationNode (
    ByRef node As ISyntaxNode,
    checkRegions As Boolean
) As Boolean
public:
virtual bool IsDeclarationNode(
    ISyntaxNode^% node,
    bool checkRegions
)
abstract IsDeclarationNode :
        node : ISyntaxNode byref *
        checkRegions : bool -> bool
override IsDeclarationNode :
        node : ISyntaxNode byref *
        checkRegions : bool -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.
checkRegions
Type: SystemBoolean
Indicates that region nodes should be skipped.

Return Value

Type: Boolean
True if specified node is declaration node; otherwise false.

Implements

INETRepositoryIsDeclarationNode(ISyntaxNode, Boolean)
See Also

Reference

NETRepository Class
IsDeclarationNode Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsInvocationNode Method

NETRepositoryIsInvocationNode Method
Indicates whether specified node is a invocation node (contains call of some method or function).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsInvocationNode(
    ISyntaxNode node
)
Public Shared Function IsInvocationNode (
    node As ISyntaxNode
) As Boolean
public:
static bool IsInvocationNode(
    ISyntaxNode^ node
)
static member IsInvocationNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is invocation node; otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsMethodNode Method

NETRepositoryIsMethodNode Method
Indicates whether specified node is a method node (contains declaration of some method, constructor, destructor and so on).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsMethodNode(
    ISyntaxNode node
)
Public Shared Function IsMethodNode (
    node As ISyntaxNode
) As Boolean
public:
static bool IsMethodNode(
    ISyntaxNode^ node
)
static member IsMethodNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is method node; otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsPrefixedUnaryExpressionNode Method

NETRepositoryIsPrefixedUnaryExpressionNode Method
Indicates whether specified node is a binary expression node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsPrefixedUnaryExpressionNode(
    ISyntaxNode node
)
Public Shared Function IsPrefixedUnaryExpressionNode (
    node As ISyntaxNode
) As Boolean
public:
static bool IsPrefixedUnaryExpressionNode(
    ISyntaxNode^ node
)
static member IsPrefixedUnaryExpressionNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is prefixed-unary expression node; otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsStatementNode Method

NETRepositoryIsStatementNode Method
Indicates whether specified node is a a statement node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsStatementNode(
    ISyntaxNode node
)
Public Shared Function IsStatementNode (
    node As ISyntaxNode
) As Boolean
public:
static bool IsStatementNode(
    ISyntaxNode^ node
)
static member IsStatementNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is block node; otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsStructureGuideNode Method

NETRepositoryIsStructureGuideNode Method
Indicates whether specified ISyntaxNode is guide node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsStructureGuideNode(
    ISyntaxNode node,
    out IRange range
)
Public Overrides Function IsStructureGuideNode (
    node As ISyntaxNode,
    <OutAttribute> ByRef range As IRange
) As Boolean
public:
virtual bool IsStructureGuideNode(
    ISyntaxNode^ node,
    [OutAttribute] IRange^% range
) override
abstract IsStructureGuideNode :
        node : ISyntaxNode *
        range : IRange byref -> bool
override IsStructureGuideNode :
        node : ISyntaxNode *
        range : IRange byref -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
ISyntaxNode to check.
range
Type: Alternet.CommonIRange
Output parameter receives guide range.

Return Value

Type: Boolean
True if ISyntaxNode is guide node; otherwise false.

Implements

ICodeCompletionRepositoryIsStructureGuideNode(ISyntaxNode, IRange)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsUnaryExpressionNode Method

NETRepositoryIsUnaryExpressionNode Method
Indicates whether specified node is a binary expression node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUnaryExpressionNode(
    ISyntaxNode node
)
Public Shared Function IsUnaryExpressionNode (
    node As ISyntaxNode
) As Boolean
public:
static bool IsUnaryExpressionNode(
    ISyntaxNode^ node
)
static member IsUnaryExpressionNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is unary-expression node; otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsVariableInitializer Method

NETRepositoryIsVariableInitializer Method
Indicates whether specified node is a binary expression node.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsVariableInitializer(
    ISyntaxNode node
)
Public Shared Function IsVariableInitializer (
    node As ISyntaxNode
) As Boolean
public:
static bool IsVariableInitializer(
    ISyntaxNode^ node
)
static member IsVariableInitializer :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is variable-initializer node; otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.IsXmlCommentNode Method

NETRepositoryIsXmlCommentNode Method
Indicates whether specified node is a xml comment node (contains xml comment).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsXmlCommentNode(
    ISyntaxNode node
)
Public Shared Function IsXmlCommentNode (
    node As ISyntaxNode
) As Boolean
public:
static bool IsXmlCommentNode(
    ISyntaxNode^ node
)
static member IsXmlCommentNode :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is xml comment node; otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.RegisterNamespace Method

NETRepositoryRegisterNamespace Method
Overload List
 | Name | Description
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list.
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list.
Top
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.RegisterNamespace Method (String)

NETRepositoryRegisterNamespace Method (String)
Adds specified namespace to the namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterNamespace(
    string nspace
)
Public Overridable Sub RegisterNamespace (
    nspace As String
)
public:
virtual void RegisterNamespace(
    String^ nspace
)
abstract RegisterNamespace :
        nspace : string -> unit
override RegisterNamespace :
        nspace : string -> unit

Parameters

nspace
Type: SystemString
Specifies name of namespace to add.
See Also

Reference

NETRepository Class
RegisterNamespace Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.RegisterNamespace Method (String, String)

NETRepositoryRegisterNamespace Method (String, String)
Adds specified namespace to the namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RegisterNamespace(
    string nspace,
    string alias
)
Public Sub RegisterNamespace (
    nspace As String,
    alias As String
)
public:
virtual void RegisterNamespace(
    String^ nspace,
    String^ alias
) sealed
abstract RegisterNamespace :
        nspace : string *
        alias : string -> unit
override RegisterNamespace :
        nspace : string *
        alias : string -> unit

Parameters

nspace
Type: SystemString
Specifies name of namespace to add.
alias
Type: SystemString
Specifies alias of namespace.
See Also

Reference

NETRepository Class
RegisterNamespace Overload
Alternet.Syntax.CodeCompletion Namespace


NETRepository.RegisterObject Method

NETRepositoryRegisterObject Method
Adds specified object for code completion to the object list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterObject(
    string name,
    Object obj
)
Public Overridable Sub RegisterObject (
    name As String,
    obj As Object
)
public:
virtual void RegisterObject(
    String^ name,
    Object^ obj
)
abstract RegisterObject :
        name : string *
        obj : Object -> unit
override RegisterObject :
        name : string *
        obj : Object -> unit

Parameters

name
Type: SystemString
Specifies name of the object.
obj
Type: SystemObject
Specifies object to register.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.SmartFormatLine Method

NETRepositorySmartFormatLine Method
Formats line according to the parser rules.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ISyntaxNodes nodes,
    ITextUndoList operations
)
Public Overridable Sub SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    nodes As ISyntaxNodes,
    operations As ITextUndoList
)
public:
virtual void SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ISyntaxNodes^ nodes,
    ITextUndoList^ operations
)
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        nodes : ISyntaxNodes *
        operations : ITextUndoList -> unit
override SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        nodes : ISyntaxNodes *
        operations : ITextUndoList -> unit

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
nodes
Type: Alternet.SyntaxISyntaxNodes
Specifies nodes collection containing given line.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.

Implements

INETRepositorySmartFormatLine(Int32, String, StringItemInfo, ISyntaxNodes, ITextUndoList)
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.UnregisterNamespace Method

NETRepositoryUnregisterNamespace Method
Removes specified namespace from the namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterNamespace(
    string nspace
)
Public Overridable Function UnregisterNamespace (
    nspace As String
) As Boolean
public:
virtual bool UnregisterNamespace(
    String^ nspace
)
abstract UnregisterNamespace :
        nspace : string -> bool
override UnregisterNamespace :
        nspace : string -> bool

Parameters

nspace
Type: SystemString
Specifies name of namespace to remove.

Return Value

Type: Boolean
True if succeed (namespace is present in the namespace list); otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.UnregisterObject Method

NETRepositoryUnregisterObject Method
Removes specified object from the object list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterObject(
    string name
)
Public Overridable Function UnregisterObject (
    name As String
) As Boolean
public:
virtual bool UnregisterObject(
    String^ name
)
abstract UnregisterObject :
        name : string -> bool
override UnregisterObject :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of object to remove.

Return Value

Type: Boolean
True if succeed (object is present in the object list); otherwise false.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository Properties

NETRepository Properties

The NETRepository type exposes the following members.

Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion.
Public property | BaseClassType | Gets or sets name of the base type.
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list.
Public property | Objects | Represents object list in a form of key-value pairs.
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.AllowGlobalMembers Property

NETRepositoryAllowGlobalMembers Property
Gets or sets a boolean value indicating whether global members should be included into the code completion.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowGlobalMembers { get; set; }
Public Property AllowGlobalMembers As Boolean
    Get
    Set
public:
property bool AllowGlobalMembers {
    bool get ();
    void set (bool value);
}
member AllowGlobalMembers : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.BaseClassType Property

NETRepositoryBaseClassType Property
Gets or sets name of the base type.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BaseClassType { get; set; }
Public Property BaseClassType As String
    Get
    Set
public:
property String^ BaseClassType {
    String^ get ();
    void set (String^ value);
}
member BaseClassType : string with get, set

Property Value

Type: String
Remarks
It is "object" by default.
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.Images Property

NETRepositoryImages Property
Represents collection of images used for code completion.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; }
Public Overrides ReadOnly Property Images As ImageList
    Get
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
}
abstract Images : ImageList with get
override Images : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImages
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.ImagesHighDpi Property

NETRepositoryImagesHighDpi Property
Represents collection of images used for code completion for high DPI.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList ImagesHighDpi { get; }
Public Overrides ReadOnly Property ImagesHighDpi As ImageList
    Get
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get () override;
}
abstract ImagesHighDpi : ImageList with get
override ImagesHighDpi : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImagesHighDpi
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.Namespaces Property

NETRepositoryNamespaces Property
Represents namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<INetNamespace> Namespaces { get; }
Public ReadOnly Property Namespaces As IList(Of INetNamespace)
    Get
public:
virtual property IList<INetNamespace^>^ Namespaces {
    IList<INetNamespace^>^ get () sealed;
}
abstract Namespaces : IList<INetNamespace> with get
override Namespaces : IList<INetNamespace> with get

Property Value

Type: IListINetNamespace
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository.Objects Property

NETRepositoryObjects Property
Represents object list in a form of key-value pairs.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hashtable Objects { get; }
Public ReadOnly Property Objects As Hashtable
    Get
public:
virtual property Hashtable^ Objects {
    Hashtable^ get () sealed;
}
abstract Objects : Hashtable with get
override Objects : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NETRepository Events

NETRepository Events

The NETRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

NETRepository Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes Class

NetTypes Class
Contains collection of build-in types. Reserved for internal use.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionNetTypes

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NetTypes
Public Class NetTypes
public ref class NetTypes
type NetTypes =  class end

The NetTypes type exposes the following members.

Constructors
 | Name | Description
Public method | NetTypes | Initializes a new instance of the NetTypes class
Top
Methods
 | Name | Description
 | AddAssembly | Adds specified assembly to the collection for assemblies.
 | AddNamespace | Adds specified namespace to the collection of namespaces.
 | AddType | Adds specified type to the collection of types.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetAssemblies | Retrieves collection of namespaces located in specified assemblies.
 | GetGlobalTypes | Finds global types from specified namespace.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetNamespaces | Retrieves collection of namespaces located in specified assemblies.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeByName | Retrieves type by its name.
 | GetTypes | Retrieves collection of types located in specified assembly.
 | IsExtensionMethod | Determines if given method is an extension method.
 | IsSpecialType | Gets a value indicating whether the Type has a name that requires special handling.
 | RemoveAssembly | Removes specified assembly form the list of assemblies.
 | RemoveNamespace | Removes namespace from the list of namespaces.
 | RemoveType | Removes specified type from the list of types.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name | Description
Assemblies | Represents the list of loaded assemblies.
AssembliyTypes | Represents the list of loaded types.
ExtensionMethods |
GlobalTypes | Represents the list of global types.
Namespaces | Represents the list of namespaces.
Types | Represents the list of loaded types.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


NetTypes Constructor

NetTypes Constructor
Initializes a new instance of the NetTypes class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetTypes()
Public Sub New
public:
NetTypes()
new : unit -> NetTypes
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes Methods

NetTypes Methods

The NetTypes type exposes the following members.

Methods
 | Name | Description
 | AddAssembly | Adds specified assembly to the collection for assemblies.
 | AddNamespace | Adds specified namespace to the collection of namespaces.
 | AddType | Adds specified type to the collection of types.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetAssemblies | Retrieves collection of namespaces located in specified assemblies.
 | GetGlobalTypes | Finds global types from specified namespace.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetNamespaces | Retrieves collection of namespaces located in specified assemblies.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeByName | Retrieves type by its name.
 | GetTypes | Retrieves collection of types located in specified assembly.
 | IsExtensionMethod | Determines if given method is an extension method.
 | IsSpecialType | Gets a value indicating whether the Type has a name that requires special handling.
 | RemoveAssembly | Removes specified assembly form the list of assemblies.
 | RemoveNamespace | Removes namespace from the list of namespaces.
 | RemoveType | Removes specified type from the list of types.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.AddAssembly Method

NetTypesAddAssembly Method
Adds specified assembly to the collection for assemblies.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddAssembly(
    Assembly assembly
)
Public Shared Sub AddAssembly (
    assembly As Assembly
)
public:
static void AddAssembly(
    Assembly^ assembly
)
static member AddAssembly :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to add.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.AddNamespace Method

NetTypesAddNamespace Method
Adds specified namespace to the collection of namespaces.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddNamespace(
    string nspace,
    Assembly assembly
)
Public Shared Sub AddNamespace (
    nspace As String,
    assembly As Assembly
)
public:
static void AddNamespace(
    String^ nspace,
    Assembly^ assembly
)
static member AddNamespace :
        nspace : string *
        assembly : Assembly -> unit

Parameters

nspace
Type: SystemString
Namespace to add.
assembly
Type: System.ReflectionAssembly
Assembly contains specified namespace.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.AddType Method

NetTypesAddType Method
Adds specified type to the collection of types.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddType(
    Type type,
    bool global
)
Public Shared Sub AddType (
    type As Type,
    global As Boolean
)
public:
static void AddType(
    Type^ type,
    bool global
)
static member AddType :
        type : Type *
        global : bool -> unit

Parameters

type
Type: SystemType
Type to add.
global
Type: SystemBoolean
True if type should be added to the collection of global type; otherwise false.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.GetAssemblies Method

NetTypesGetAssemblies Method
Retrieves collection of namespaces located in specified assemblies.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void GetAssemblies(
    string nspace,
    IList<Assembly> assemblies
)
Public Shared Sub GetAssemblies (
    nspace As String,
    assemblies As IList(Of Assembly)
)
public:
static void GetAssemblies(
    String^ nspace,
    IList<Assembly^>^ assemblies
)
static member GetAssemblies :
        nspace : string *
        assemblies : IList<Assembly> -> unit

Parameters

nspace
Type: SystemString
Specifies given namespace.
assemblies
Type: System.Collections.GenericIListAssembly
Collection of assemblies where namespaces should be found.

Return Value

Type:
List of assemblies.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.GetGlobalTypes Method

NetTypesGetGlobalTypes Method
Finds global types from specified namespace.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetGlobalTypes(
    IList<Type> types,
    string nspace,
    bool caseSensitive
)
Public Shared Function GetGlobalTypes (
    types As IList(Of Type),
    nspace As String,
    caseSensitive As Boolean
) As Integer
public:
static int GetGlobalTypes(
    IList<Type^>^ types,
    String^ nspace,
    bool caseSensitive
)
static member GetGlobalTypes :
        types : IList<Type> *
        nspace : string *
        caseSensitive : bool -> int

Parameters

types
Type: System.Collections.GenericIListType
Retrieves list of global types.
nspace
Type: SystemString
String representation of namespace to evaluate.
caseSensitive
Type: SystemBoolean
Specifies whether location should be case-sensitive.

Return Value

Type: Int32
Number of found global types.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.GetNamespaces Method

NetTypesGetNamespaces Method
Retrieves collection of namespaces located in specified assemblies.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> GetNamespaces(
    IList<Assembly> assemblies
)
Public Shared Function GetNamespaces (
    assemblies As IList(Of Assembly)
) As IList(Of String)
public:
static IList<String^>^ GetNamespaces(
    IList<Assembly^>^ assemblies
)
static member GetNamespaces :
        assemblies : IList<Assembly> -> IList<string>

Parameters

assemblies
Type: System.Collections.GenericIListAssembly
Collection of assemblies where namespaces should be find.

Return Value

Type: IListString
List of namespaces.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.GetTypeByName Method

NetTypesGetTypeByName Method
Retrieves type by its name.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Object GetTypeByName(
    string name,
    IList<Assembly> assemblies,
    bool caseSensitive
)
Public Shared Function GetTypeByName (
    name As String,
    assemblies As IList(Of Assembly),
    caseSensitive As Boolean
) As Object
public:
static Object^ GetTypeByName(
    String^ name,
    IList<Assembly^>^ assemblies,
    bool caseSensitive
)
static member GetTypeByName :
        name : string *
        assemblies : IList<Assembly> *
        caseSensitive : bool -> Object

Parameters

name
Type: SystemString
Specifies name of type.
assemblies
Type: System.Collections.GenericIListAssembly
Collection of assemblies where type should be located.
caseSensitive
Type: SystemBoolean
True to perform a case-sensitive search for type declaration, false to perform a case-insensitive search for type declaration.

Return Value

Type: Object
The found type.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.GetTypes Method

NetTypesGetTypes Method
Retrieves collection of types located in specified assembly.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void GetTypes(
    Assembly assembly,
    IList<Type> types
)
Public Shared Sub GetTypes (
    assembly As Assembly,
    types As IList(Of Type)
)
public:
static void GetTypes(
    Assembly^ assembly,
    IList<Type^>^ types
)
static member GetTypes :
        assembly : Assembly *
        types : IList<Type> -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Specifies given assembly.
types
Type: System.Collections.GenericIListType
Collection of types declared in given assembly.

Return Value

Type:
List of assemblies.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.IsExtensionMethod Method

NetTypesIsExtensionMethod Method
Determines if given method is an extension method.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsExtensionMethod(
    MethodInfo method
)
Public Shared Function IsExtensionMethod (
    method As MethodInfo
) As Boolean
public:
static bool IsExtensionMethod(
    MethodInfo^ method
)
static member IsExtensionMethod :
        method : MethodInfo -> bool

Parameters

method
Type: System.ReflectionMethodInfo
Specifies method info.

Return Value

Type: Boolean
True if given method is an extension method; otherwise false.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.IsSpecialType Method

NetTypesIsSpecialType Method
Gets a value indicating whether the Type has a name that requires special handling.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSpecialType(
    Type type
)
Public Shared Function IsSpecialType (
    type As Type
) As Boolean
public:
static bool IsSpecialType(
    Type^ type
)
static member IsSpecialType :
        type : Type -> bool

Parameters

type
Type: SystemType
Type to evaluate.

Return Value

Type: Boolean
True if the Type has a name that requires special handling; otherwise, false.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.RemoveAssembly Method

NetTypesRemoveAssembly Method
Removes specified assembly form the list of assemblies.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveAssembly(
    Assembly assembly
)
Public Shared Sub RemoveAssembly (
    assembly As Assembly
)
public:
static void RemoveAssembly(
    Assembly^ assembly
)
static member RemoveAssembly :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to remove.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.RemoveNamespace Method

NetTypesRemoveNamespace Method
Removes namespace from the list of namespaces.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveNamespace(
    string nspace,
    Assembly assembly
)
Public Shared Sub RemoveNamespace (
    nspace As String,
    assembly As Assembly
)
public:
static void RemoveNamespace(
    String^ nspace,
    Assembly^ assembly
)
static member RemoveNamespace :
        nspace : string *
        assembly : Assembly -> unit

Parameters

nspace
Type: SystemString
Namespace to remove.
assembly
Type: System.ReflectionAssembly
Assembly contains specified namespace.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.RemoveType Method

NetTypesRemoveType Method
Removes specified type from the list of types.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveType(
    Type type
)
Public Shared Sub RemoveType (
    type As Type
)
public:
static void RemoveType(
    Type^ type
)
static member RemoveType :
        type : Type -> unit

Parameters

type
Type: SystemType
Type to remove.
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes Properties

NetTypes Properties

The NetTypes type exposes the following members.

Properties
Name | Description
Assemblies | Represents the list of loaded assemblies.
AssembliyTypes | Represents the list of loaded types.
ExtensionMethods |
GlobalTypes | Represents the list of global types.
Namespaces | Represents the list of namespaces.
Types | Represents the list of loaded types.
Top
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.Assemblies Property

NetTypesAssemblies Property
Represents the list of loaded assemblies.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Hashtable Assemblies { get; }
Public Shared ReadOnly Property Assemblies As Hashtable
    Get
public:
static property Hashtable^ Assemblies {
    Hashtable^ get ();
}
static member Assemblies : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.AssembliyTypes Property

NetTypesAssembliyTypes Property
Represents the list of loaded types.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Hashtable AssembliyTypes { get; }
Public Shared ReadOnly Property AssembliyTypes As Hashtable
    Get
public:
static property Hashtable^ AssembliyTypes {
    Hashtable^ get ();
}
static member AssembliyTypes : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.ExtensionMethods Property

NetTypesExtensionMethods Property

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Hashtable ExtensionMethods { get; }
Public Shared ReadOnly Property ExtensionMethods As Hashtable
    Get
public:
static property Hashtable^ ExtensionMethods {
    Hashtable^ get ();
}
static member ExtensionMethods : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.GlobalTypes Property

NetTypesGlobalTypes Property
Represents the list of global types.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Hashtable GlobalTypes { get; }
Public Shared ReadOnly Property GlobalTypes As Hashtable
    Get
public:
static property Hashtable^ GlobalTypes {
    Hashtable^ get ();
}
static member GlobalTypes : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.Namespaces Property

NetTypesNamespaces Property
Represents the list of namespaces.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Hashtable Namespaces { get; }
Public Shared ReadOnly Property Namespaces As Hashtable
    Get
public:
static property Hashtable^ Namespaces {
    Hashtable^ get ();
}
static member Namespaces : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


NetTypes.Types Property

NetTypesTypes Property
Represents the list of loaded types.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Hashtable Types { get; }
Public Shared ReadOnly Property Types As Hashtable
    Get
public:
static property Hashtable^ Types {
    Hashtable^ get ();
}
static member Types : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

NetTypes Class
Alternet.Syntax.CodeCompletion Namespace


ParameterInfo Class

ParameterInfo Class
Represents Parameter Info data related to popup window and popup hint controls.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionParameterInfo

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterInfo : ListMembers,
    IParameterInfo, IListMembers, ICodeCompletionProvider, IList<ICodeCompletionProviderItem>,
    ICollection<ICodeCompletionProviderItem>, IEnumerable<ICodeCompletionProviderItem>, IEnumerable,
    IExport, IImport
Public Class ParameterInfo
    Inherits ListMembers
    Implements IParameterInfo, IListMembers, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class ParameterInfo : public ListMembers,
    IParameterInfo, IListMembers, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>,
    ICollection<ICodeCompletionProviderItem^>, IEnumerable<ICodeCompletionProviderItem^>, IEnumerable,
    IExport, IImport
type ParameterInfo =
    class
        inherit ListMembers
        interface IParameterInfo
        interface IListMembers
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The ParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterInfo | Initializes a new instance of the ParameterInfo class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Overrides CodeCompletionProviderFormatDisplayText.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ParameterInfo Constructor

ParameterInfo Constructor
Initializes a new instance of the ParameterInfo class

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterInfo()
Public Sub New
public:
ParameterInfo()
new : unit -> ParameterInfo
See Also

Reference

ParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


ParameterInfo Methods

ParameterInfo Methods

The ParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


ParameterInfo Properties

ParameterInfo Properties

The ParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Overrides CodeCompletionProviderFormatDisplayText.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

ParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


ParameterInfo.FormatDisplayText Property

ParameterInfoFormatDisplayText Property
Gets a boolean value indicating that rich text formatting should be applied to display text.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool FormatDisplayText { get; }
Public Overrides ReadOnly Property FormatDisplayText As Boolean
    Get
public:
virtual property bool FormatDisplayText {
    bool get () override;
}
abstract FormatDisplayText : bool with get
override FormatDisplayText : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionProviderFormatDisplayText
ICodeCompletionProviderFormatDisplayText
See Also

Reference

ParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


ParameterInfo Events

ParameterInfo Events

The ParameterInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

ParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember Class

ParameterMember Class
Implements properties for a particular parameter member within list member parameters.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionParameterMember

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterMember : CodeCompletionProviderItem,
    IParameterMember, ICodeCompletionProviderItem, IComparable
Public Class ParameterMember
    Inherits CodeCompletionProviderItem
    Implements IParameterMember, ICodeCompletionProviderItem, IComparable
public ref class ParameterMember : public CodeCompletionProviderItem,
    IParameterMember, ICodeCompletionProviderItem, IComparable
type ParameterMember =
    class
        inherit CodeCompletionProviderItem
        interface IParameterMember
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The ParameterMember type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterMember | Initializes a new instance of the ParameterMember class with default settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DataType | Gets or sets a string value that specifies datatype of the IParameterMember.
Public property | Description | Gets or sets a string value that specifies short description of the IParameterMember.
Public property | Modifiers | Gets or sets a string value that specifies parameter modifier.
Public property | Name | Gets or sets a string value that specifies name of the IParameterMember.
Public property | Qualifier | Gets or sets a string value that specifies parameter modifier of the IParameterMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Public property | Text | Gets or sets a string value that specifies parameter modifier of the IParameterMember.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ParameterMember Constructor

ParameterMember Constructor
Initializes a new instance of the ParameterMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterMember()
Public Sub New
public:
ParameterMember()
new : unit -> ParameterMember
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember Methods

ParameterMember Methods

The ParameterMember type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember.CompareTo Method

ParameterMemberCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember Properties

ParameterMember Properties

The ParameterMember type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Gets or sets a string value that specifies datatype of the IParameterMember.
Public property | Description | Gets or sets a string value that specifies short description of the IParameterMember.
Public property | Modifiers | Gets or sets a string value that specifies parameter modifier.
Public property | Name | Gets or sets a string value that specifies name of the IParameterMember.
Public property | Qualifier | Gets or sets a string value that specifies parameter modifier of the IParameterMember.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Public property | Text | Gets or sets a string value that specifies parameter modifier of the IParameterMember.
Top
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember.DataType Property

ParameterMemberDataType Property
Gets or sets a string value that specifies datatype of the IParameterMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DataType { get; set; }
Public Overridable Property DataType As String
    Get
    Set
public:
virtual property String^ DataType {
    String^ get ();
    void set (String^ value);
}
abstract DataType : string with get, set
override DataType : string with get, set

Property Value

Type: String

Implements

IParameterMemberDataType
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember.Description Property

ParameterMemberDescription Property
Gets or sets a string value that specifies short description of the IParameterMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

IParameterMemberDescription
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember.Modifiers Property

ParameterMemberModifiers Property
Gets or sets a string value that specifies parameter modifier.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ParameterModifer Modifiers { get; set; }
Public Overridable Property Modifiers As ParameterModifer
    Get
    Set
public:
virtual property ParameterModifer Modifiers {
    ParameterModifer get ();
    void set (ParameterModifer value);
}
abstract Modifiers : ParameterModifer with get, set
override Modifiers : ParameterModifer with get, set

Property Value

Type: ParameterModifer

Implements

IParameterMemberModifiers
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember.Name Property

ParameterMemberName Property
Gets or sets a string value that specifies name of the IParameterMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IParameterMemberName
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember.Qualifier Property

ParameterMemberQualifier Property
Gets or sets a string value that specifies parameter modifier of the IParameterMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Qualifier { get; set; }
Public Overridable Property Qualifier As String
    Get
    Set
public:
virtual property String^ Qualifier {
    String^ get ();
    void set (String^ value);
}
abstract Qualifier : string with get, set
override Qualifier : string with get, set

Property Value

Type: String

Implements

IParameterMemberQualifier
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMember.Text Property

ParameterMemberText Property
Gets or sets a string value that specifies parameter modifier of the IParameterMember.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

IParameterMemberText
See Also

Reference

ParameterMember Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMembers Class

ParameterMembers Class
Provides an indexed access to individual ICodeSnippetLiteral objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIParameterMember
Alternet.Syntax.CodeCompletionParameterMembers

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterMembers : List<IParameterMember>,
    IParameterMembers, IList<IParameterMember>, ICollection<IParameterMember>,
    IEnumerable<IParameterMember>, IEnumerable
Public Class ParameterMembers
    Inherits List(Of IParameterMember)
    Implements IParameterMembers, IList(Of IParameterMember),
    ICollection(Of IParameterMember), IEnumerable(Of IParameterMember), IEnumerable
public ref class ParameterMembers : public List<IParameterMember^>,
    IParameterMembers, IList<IParameterMember^>, ICollection<IParameterMember^>,
    IEnumerable<IParameterMember^>, IEnumerable
type ParameterMembers =
    class
        inherit List<IParameterMember>
        interface IParameterMembers
        interface IList<IParameterMember>
        interface ICollection<IParameterMember>
        interface IEnumerable<IParameterMember>
        interface IEnumerable
    end

The ParameterMembers type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterMembers | Initializes a new instance of the ParameterMembers class with default settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIParameterMember .)
Public method | AddParameterMember | Adds a new item to the specified position within the IParameterMembers collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIParameterMember .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIParameterMember .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIParameterMember .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIParameterMember .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIParameterMember .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIParameterMember .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIParameterMember .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIParameterMember .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIParameterMember .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIParameterMember .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIParameterMember .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIParameterMember .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIParameterMember .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIParameterMember .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIParameterMember .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIParameterMember .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIParameterMember .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIParameterMember .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIParameterMember .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIParameterMember .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIParameterMember .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIParameterMember .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIParameterMember .)
Public method | InsertParameterMember | Inserts a new item to the specified position within the IParameterMembers collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIParameterMember .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIParameterMember .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIParameterMember .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIParameterMember .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIParameterMember .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIParameterMember .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIParameterMember .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIParameterMember .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIParameterMember .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIParameterMember .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIParameterMember .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIParameterMember .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIParameterMember .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIParameterMember .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIParameterMember .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIParameterMember .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIParameterMember | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIParameterMember | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIParameterMember, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIParameterMember .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIParameterMember .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIParameterMember .)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ParameterMembers Constructor

ParameterMembers Constructor
Initializes a new instance of the ParameterMembers class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterMembers()
Public Sub New
public:
ParameterMembers()
new : unit -> ParameterMembers
See Also

Reference

ParameterMembers Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMembers Methods

ParameterMembers Methods

The ParameterMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIParameterMember .)
Public method | AddParameterMember | Adds a new item to the specified position within the IParameterMembers collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIParameterMember .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIParameterMember .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIParameterMember .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIParameterMember .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIParameterMember .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIParameterMember .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIParameterMember .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIParameterMember .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIParameterMember .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIParameterMember .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIParameterMember .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIParameterMember .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIParameterMember .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIParameterMember .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIParameterMember .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIParameterMember .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIParameterMember .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIParameterMember .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIParameterMember .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIParameterMember .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIParameterMember .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIParameterMember .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIParameterMember .)
Public method | InsertParameterMember | Inserts a new item to the specified position within the IParameterMembers collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIParameterMember .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIParameterMember .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIParameterMember .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIParameterMember .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIParameterMember .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIParameterMember .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIParameterMember .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIParameterMember .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIParameterMember .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIParameterMember .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIParameterMember .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIParameterMember .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIParameterMember .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIParameterMember .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIParameterMember .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIParameterMember .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIParameterMember .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfIParameterMember | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstIParameterMember | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementIParameterMember, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ParameterMembers Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMembers.AddParameterMember Method

ParameterMembersAddParameterMember Method
Adds a new item to the specified position within the IParameterMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IParameterMember AddParameterMember()
Public Overridable Function AddParameterMember As IParameterMember
public:
virtual IParameterMember^ AddParameterMember()
abstract AddParameterMember : unit -> IParameterMember
override AddParameterMember : unit -> IParameterMember

Return Value

Type: IParameterMember
IParameterMember that is added.

Implements

IParameterMembersAddParameterMember
See Also

Reference

ParameterMembers Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMembers.InsertParameterMember Method

ParameterMembersInsertParameterMember Method
Inserts a new item to the specified position within the IParameterMembers collection.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IParameterMember InsertParameterMember(
    int index
)
Public Overridable Function InsertParameterMember (
    index As Integer
) As IParameterMember
public:
virtual IParameterMember^ InsertParameterMember(
    int index
)
abstract InsertParameterMember :
        index : int -> IParameterMember
override InsertParameterMember :
        index : int -> IParameterMember

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: IParameterMember
IParameterMember that is inserted.

Implements

IParameterMembersInsertParameterMember(Int32)
See Also

Reference

ParameterMembers Class
Alternet.Syntax.CodeCompletion Namespace


ParameterMembers Properties

ParameterMembers Properties

The ParameterMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIParameterMember .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIParameterMember .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIParameterMember .)
Top
See Also

Reference

ParameterMembers Class
Alternet.Syntax.CodeCompletion Namespace


ParameterModifer Enumeration

ParameterModifer Enumeration
Defines parameter modifiers.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ParameterModifer
Public Enumeration ParameterModifer
public enum class ParameterModifer
type ParameterModifer
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Optional | 1 | Specifies that parameter is optional.
In | 2 | Specifies that parameter is in.
Out | 4 | Specifies that parameter is out.
Retval | 8 | Specifies that parameter is retval.
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


QuickInfo Class

QuickInfo Class
Represents simple text data related to popup hint.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionQuickInfo

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class QuickInfo : CodeCompletionProvider, IQuickInfo,
    ICodeCompletionProvider, IList<ICodeCompletionProviderItem>, ICollection<ICodeCompletionProviderItem>,
    IEnumerable<ICodeCompletionProviderItem>, IEnumerable, IExport, IImport
Public Class QuickInfo
    Inherits CodeCompletionProvider
    Implements IQuickInfo, ICodeCompletionProvider, IList(Of ICodeCompletionProviderItem),
    ICollection(Of ICodeCompletionProviderItem), IEnumerable(Of ICodeCompletionProviderItem), IEnumerable,
    IExport, IImport
public ref class QuickInfo : public CodeCompletionProvider,
    IQuickInfo, ICodeCompletionProvider, IList<ICodeCompletionProviderItem^>, ICollection<ICodeCompletionProviderItem^>,
    IEnumerable<ICodeCompletionProviderItem^>, IEnumerable, IExport, IImport
type QuickInfo =
    class
        inherit CodeCompletionProvider
        interface IQuickInfo
        interface ICodeCompletionProvider
        interface IList<ICodeCompletionProviderItem>
        interface ICollection<ICodeCompletionProviderItem>
        interface IEnumerable<ICodeCompletionProviderItem>
        interface IEnumerable
        interface IExport
        interface IImport
    end

The QuickInfo type exposes the following members.

Constructors
 | Name | Description
Public method | QuickInfo | Initializes a new instance of the QuickInfo class with default settings.
Public method | QuickInfo(Int32) | Initializes a new instance of the QuickInfo class with specific image index.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from CodeCompletionProvider.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from given item in the specified column. (Inherited from CodeCompletionProvider.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from CodeCompletionProvider.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeSnippetMember.ImageIndex from the snippet specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns string representing name of the item. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | CanEvaluateSymbol | Gets or sets a boolean value indicating if the symbol can be evaluated at run-time
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. (Inherited from CodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | Symbol | Gets or sets quick info symbol
Public property | Text | Gets or sets content of the IQuickInfo.
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


QuickInfo Constructor

QuickInfo Constructor
Overload List
 | Name | Description
Public method | QuickInfo | Initializes a new instance of the QuickInfo class with default settings.
Public method | QuickInfo(Int32) | Initializes a new instance of the QuickInfo class with specific image index.
Top
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfo Constructor

QuickInfo Constructor
Initializes a new instance of the QuickInfo class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public QuickInfo()
Public Sub New
public:
QuickInfo()
new : unit -> QuickInfo
See Also

Reference

QuickInfo Class
QuickInfo Overload
Alternet.Syntax.CodeCompletion Namespace


QuickInfo Constructor (Int32)

QuickInfo Constructor (Int32)
Initializes a new instance of the QuickInfo class with specific image index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public QuickInfo(
    int imageIndex
)
Public Sub New (
    imageIndex As Integer
)
public:
QuickInfo(
    int imageIndex
)
new :
        imageIndex : int -> QuickInfo

Parameters

imageIndex
Type: SystemInt32
Specifies index of the image.
See Also

Reference

QuickInfo Class
QuickInfo Overload
Alternet.Syntax.CodeCompletion Namespace


QuickInfo Methods

QuickInfo Methods

The QuickInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from CodeCompletionProvider.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from CodeCompletionProvider.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetColumnText | Returns text from given item in the specified column. (Inherited from CodeCompletionProvider.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from CodeCompletionProvider.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns number of image that is displayed for item given by index. (Inherited from CodeCompletionProvider.)
Public method | GetImageIndex | Returns ICodeSnippetMember.ImageIndex from the snippet specified by index. (Overrides CodeCompletionProviderGetImageIndex(Int32).)
Public method | GetInsertText | Returns string to be inserted. (Inherited from CodeCompletionProvider.)
Public method | GetName | Returns string representing name of the item. (Overrides CodeCompletionProviderGetName(Int32).)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from CodeCompletionProvider.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Overrides CodeCompletionProviderGetText(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfICodeCompletionProviderItem | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstICodeCompletionProviderItem | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementICodeCompletionProviderItem, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfo.GetImageIndex Method

QuickInfoGetImageIndex Method
Returns ICodeSnippetMember.ImageIndex from the snippet specified by index.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetImageIndex(
    int index
)
Public Overrides Function GetImageIndex (
    index As Integer
) As Integer
public:
virtual int GetImageIndex(
    int index
) override
abstract GetImageIndex :
        index : int -> int
override GetImageIndex :
        index : int -> int

Parameters

index
Type: SystemInt32
Specifies index of the image.

Return Value

Type: Int32

Implements

ICodeCompletionProviderGetImageIndex(Int32)
ICodeCompletionProviderGetImageIndex(Int32)
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfo.GetName Method

QuickInfoGetName Method
Returns string representing name of the item.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetName(
    int index
)
Public Overrides Function GetName (
    index As Integer
) As String
public:
virtual String^ GetName(
    int index
) override
abstract GetName :
        index : int -> string
override GetName :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
String representing name of specified item.

Implements

ICodeCompletionProviderGetName(Int32)
ICodeCompletionProviderGetName(Int32)
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfo.GetText Method

QuickInfoGetText Method
Returns string representing default column.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetText(
    int index
)
Public Overrides Function GetText (
    index As Integer
) As String
public:
virtual String^ GetText(
    int index
) override
abstract GetText :
        index : int -> string
override GetText :
        index : int -> string

Parameters

index
Type: SystemInt32
Index of item within collection.

Return Value

Type: String
Text representing default column.

Implements

ICodeCompletionProviderGetText(Int32)
ICodeCompletionProviderGetText(Int32)
Remarks
In this class method returns the same value with GetName method.
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfo Properties

QuickInfo Properties

The QuickInfo type exposes the following members.

Properties
 | Name | Description
Public property | CanEvaluateSymbol | Gets or sets a boolean value indicating if the symbol can be evaluated at run-time
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Returns number of the columns. (Inherited from CodeCompletionProvider.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from CodeCompletionProvider.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | Symbol | Gets or sets quick info symbol
Public property | Text | Gets or sets content of the IQuickInfo.
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfo.CanEvaluateSymbol Property

QuickInfoCanEvaluateSymbol Property
Gets or sets a boolean value indicating if the symbol can be evaluated at run-time

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanEvaluateSymbol { get; set; }
Public Overridable Property CanEvaluateSymbol As Boolean
    Get
    Set
public:
virtual property bool CanEvaluateSymbol {
    bool get ();
    void set (bool value);
}
abstract CanEvaluateSymbol : bool with get, set
override CanEvaluateSymbol : bool with get, set

Property Value

Type: Boolean

Implements

IQuickInfoCanEvaluateSymbol
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfo.Symbol Property

QuickInfoSymbol Property
Gets or sets quick info symbol

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Symbol { get; set; }
Public Overridable Property Symbol As String
    Get
    Set
public:
virtual property String^ Symbol {
    String^ get ();
    void set (String^ value);
}
abstract Symbol : string with get, set
override Symbol : string with get, set

Property Value

Type: String

Implements

IQuickInfoSymbol
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfo.Text Property

QuickInfoText Property
Gets or sets content of the IQuickInfo.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

IQuickInfoText
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfo Events

QuickInfo Events

The QuickInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

QuickInfo Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfoItem Class

QuickInfoItem Class
Stores simple text data related to popup hint.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionQuickInfoItem

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class QuickInfoItem : CodeCompletionProviderItem,
    IQuickInfoItem, ICodeCompletionProviderItem, IComparable
Public Class QuickInfoItem
    Inherits CodeCompletionProviderItem
    Implements IQuickInfoItem, ICodeCompletionProviderItem, IComparable
public ref class QuickInfoItem : public CodeCompletionProviderItem,
    IQuickInfoItem, ICodeCompletionProviderItem, IComparable
type QuickInfoItem =
    class
        inherit CodeCompletionProviderItem
        interface IQuickInfoItem
        interface ICodeCompletionProviderItem
        interface IComparable
    end

The QuickInfoItem type exposes the following members.

Constructors
 | Name | Description
Public method | QuickInfoItem | Initializes a new instance of the QuickInfoItem class with specified settings.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Public property | Text | Gets or sets content of the IQuickInfoItem.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


QuickInfoItem Constructor

QuickInfoItem Constructor
Initializes a new instance of the QuickInfoItem class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public QuickInfoItem(
    string text
)
Public Sub New (
    text As String
)
public:
QuickInfoItem(
    String^ text
)
new :
        text : string -> QuickInfoItem

Parameters

text
Type: SystemString
Test to store in this new instance.
See Also

Reference

QuickInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfoItem Methods

QuickInfoItem Methods

The QuickInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Overrides CodeCompletionProviderItemCompareTo(Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QuickInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfoItem.CompareTo Method

QuickInfoItemCompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int CompareTo(
    Object value
)
Public Overrides Function CompareTo (
    value As Object
) As Integer
public:
virtual int CompareTo(
    Object^ value
) override
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int

Parameters

value
Type: SystemObject

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value.

Implements

IComparableCompareTo(Object)
IComparableCompareTo(Object)
See Also

Reference

QuickInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfoItem Properties

QuickInfoItem Properties

The QuickInfoItem type exposes the following members.

Properties
 | Name | Description
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Public property | Text | Gets or sets content of the IQuickInfoItem.
Top
See Also

Reference

QuickInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


QuickInfoItem.Text Property

QuickInfoItemText Property
Gets or sets content of the IQuickInfoItem.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

IQuickInfoItemText
See Also

Reference

QuickInfoItem Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository Class

ReflectionRepository Class
Represents properties and methods to perform code completion functionality using reflection.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionNETRepository
Alternet.Syntax.CodeCompletionReflectionRepository
Alternet.Syntax.CodeCompletionCsRepository
Alternet.Syntax.CodeCompletionJavaScriptRepository
Alternet.Syntax.CodeCompletionVbRepository
Alternet.Syntax.CodeCompletionVbScriptRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReflectionRepository : NETRepository,
    IReflectionRepository, ICodeCompletionRepository, IDisposable
Public Class ReflectionRepository
    Inherits NETRepository
    Implements IReflectionRepository, ICodeCompletionRepository, IDisposable
public ref class ReflectionRepository : public NETRepository,
    IReflectionRepository, ICodeCompletionRepository, IDisposable
type ReflectionRepository =
    class
        inherit NETRepository
        interface IReflectionRepository
        interface ICodeCompletionRepository
        interface IDisposable
    end

The ReflectionRepository type exposes the following members.

Constructors
 | Name | Description
Public method | ReflectionRepository | Initializes a new instance of the ReflectionRepository class with specified parameters.
Top
Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows.
Public method | ClearAssemblies | Clears assembly list.
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Overrides NETRepositoryFillMember(IListMembers, Object, String, CodeCompletionScope).)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Overrides NETRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Overrides NETRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope).)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Overrides CodeCompletionRepositoryGetPriority(Object).)
Public method | GetQuickInfo(Object) | Returns information about the object. (Overrides NETRepositoryGetQuickInfo(Object).)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name.
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from NETRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Overrides NETRepositoryGetTypeByName(String).)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain.
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list.
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list.
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list.
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows.
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list.
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list.
Top
Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list.
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs.
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository Constructor

ReflectionRepository Constructor
Initializes a new instance of the ReflectionRepository class with specified parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReflectionRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
ReflectionRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> ReflectionRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository Methods

ReflectionRepository Methods

The ReflectionRepository type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows.
Public method | ClearAssemblies | Clears assembly list.
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Overrides NETRepositoryFillMember(IListMembers, Object, String, CodeCompletionScope).)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Overrides NETRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Overrides NETRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope).)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Overrides CodeCompletionRepositoryGetPriority(Object).)
Public method | GetQuickInfo(Object) | Returns information about the object. (Overrides NETRepositoryGetQuickInfo(Object).)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name.
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from NETRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Overrides NETRepositoryGetTypeByName(String).)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain.
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list.
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list.
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list.
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows.
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list.
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list.
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.AllowTypeMembers Method

ReflectionRepositoryAllowTypeMembers Method
Re-enables type members from being shown in code completion windows.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AllowTypeMembers(
    Type type
)
Public Overridable Sub AllowTypeMembers (
    type As Type
)
public:
virtual void AllowTypeMembers(
    Type^ type
)
abstract AllowTypeMembers :
        type : Type -> unit
override AllowTypeMembers :
        type : Type -> unit

Parameters

type
Type: SystemType
Specifies type which members will be re-enabled.

Implements

IReflectionRepositoryAllowTypeMembers(Type)
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.ClearAssemblies Method

ReflectionRepositoryClearAssemblies Method
Clears assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearAssemblies()
Public Overridable Sub ClearAssemblies
public:
virtual void ClearAssemblies()
abstract ClearAssemblies : unit -> unit
override ClearAssemblies : unit -> unit

Implements

IReflectionRepositoryClearAssemblies
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.ClearTypes Method

ReflectionRepositoryClearTypes Method
Clears type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearTypes()
Public Overridable Sub ClearTypes
public:
virtual void ClearTypes()
abstract ClearTypes : unit -> unit
override ClearTypes : unit -> unit

Implements

IReflectionRepositoryClearTypes
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.FillMember Method

ReflectionRepositoryFillMember Method
Overload List
 | Name | Description
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Overrides NETRepositoryFillMember(IListMembers, Object, String, CodeCompletionScope).)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.FillMember Method (IListMembers, Object, String, CodeCompletionScope)

ReflectionRepositoryFillMember Method (IListMembers, Object, String, CodeCompletionScope)
Obtains information about individual member of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FillMember(
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope
)
Public Overrides Sub FillMember (
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope
)
public:
virtual void FillMember(
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope
) override
abstract FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope -> unit
override FillMember :
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope -> unit

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of member to retrieve.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
See Also

Reference

ReflectionRepository Class
FillMember Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.GetDescription Method

ReflectionRepositoryGetDescription Method
Obtains description of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDescription(
    IListMembers members,
    ISyntaxNode node,
    Object member,
    string name,
    bool fullDescription
)
Public Overrides Function GetDescription (
    members As IListMembers,
    node As ISyntaxNode,
    member As Object,
    name As String,
    fullDescription As Boolean
) As String
public:
virtual String^ GetDescription(
    IListMembers^ members,
    ISyntaxNode^ node,
    Object^ member,
    String^ name,
    bool fullDescription
) override
abstract GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string
override GetDescription :
        members : IListMembers *
        node : ISyntaxNode *
        member : Object *
        name : string *
        fullDescription : bool -> string

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies ListMembers interface used to get language-specific description.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode that representing language element to describe.
member
Type: SystemObject
Specifies language element to describe.
name
Type: SystemString
Specifies name of described language element.
fullDescription
Type: SystemBoolean
Specifies whether description should include name and type of the found element.

Return Value

Type: String
String that describes specified language element.

Implements

ICodeCompletionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean)
ICodeCompletionRepositoryGetDescription(IListMembers, ISyntaxNode, Object, String, Boolean)
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.GetMemberType Method

ReflectionRepositoryGetMemberType Method
Overload List
 | Name | Description
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Overrides NETRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope).)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.GetMemberType Method (ISyntaxNode, Point, Object, String, CodeCompletionScope)

ReflectionRepositoryGetMemberType Method (ISyntaxNode, Point, Object, String, CodeCompletionScope)
Obtains information about a member of some language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetMemberType(
    ISyntaxNode node,
    Point position,
    Object member,
    string name,
    out CodeCompletionScope scope
)
Public Overrides Function GetMemberType (
    node As ISyntaxNode,
    position As Point,
    member As Object,
    name As String,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetMemberType(
    ISyntaxNode^ node,
    Point position,
    Object^ member,
    String^ name,
    [OutAttribute] CodeCompletionScope% scope
) override
abstract GetMemberType :
        node : ISyntaxNode *
        position : Point *
        member : Object *
        name : string *
        scope : CodeCompletionScope byref -> Object
override GetMemberType :
        node : ISyntaxNode *
        position : Point *
        member : Object *
        name : string *
        scope : CodeCompletionScope byref -> Object

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
position
Type: System.DrawingPoint
Specifies position of language element.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies name of the member to locate.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for this language element.

Return Value

Type: Object
Object representing information about found member.

Implements

ICodeCompletionRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope)
ICodeCompletionRepositoryGetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope)
See Also

Reference

ReflectionRepository Class
GetMemberType Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.GetPriority Method

ReflectionRepositoryGetPriority Method
Obtains priority of the given language element. Specifies language element

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetPriority(
    Object member
)
Public Overrides Function GetPriority (
    member As Object
) As Integer
public:
virtual int GetPriority(
    Object^ member
) override
abstract GetPriority :
        member : Object -> int
override GetPriority :
        member : Object -> int

Parameters

member
Type: SystemObject

Return Value

Type: Int32

Implements

ICodeCompletionRepositoryGetPriority(Object)
ICodeCompletionRepositoryGetPriority(Object)
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.GetQuickInfo Method

ReflectionRepositoryGetQuickInfo Method
Overload List
 | Name | Description
Public method | GetQuickInfo(Object) | Returns information about the object. (Overrides NETRepositoryGetQuickInfo(Object).)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.GetQuickInfo Method (Object)

ReflectionRepositoryGetQuickInfo Method (Object)
Returns information about the object.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IQuickInfo GetQuickInfo(
    Object member
)
Public Overrides Function GetQuickInfo (
    member As Object
) As IQuickInfo
public:
virtual IQuickInfo^ GetQuickInfo(
    Object^ member
) override
abstract GetQuickInfo :
        member : Object -> IQuickInfo
override GetQuickInfo :
        member : Object -> IQuickInfo

Parameters

member
Type: SystemObject
Given object.

Return Value

Type: IQuickInfo
IQuickInfo instance.

Implements

ICodeCompletionRepositoryGetQuickInfo(Object)
ICodeCompletionRepositoryGetQuickInfo(Object)
See Also

Reference

ReflectionRepository Class
GetQuickInfo Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.GetRegisteredType Method

ReflectionRepositoryGetRegisteredType Method
Retrieves registered type by its name.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetRegisteredType(
    string name
)
Public Overridable Function GetRegisteredType (
    name As String
) As Object
public:
virtual Object^ GetRegisteredType(
    String^ name
)
abstract GetRegisteredType :
        name : string -> Object
override GetRegisteredType :
        name : string -> Object

Parameters

name
Type: SystemString
Specifies name of the type.

Return Value

Type: Object
Registered type found by its name.
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.GetTypeByName Method

ReflectionRepositoryGetTypeByName Method
Retrieves type by its name.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetTypeByName(
    string type
)
Public Overrides Function GetTypeByName (
    type As String
) As Object
public:
virtual Object^ GetTypeByName(
    String^ type
) override
abstract GetTypeByName :
        type : string -> Object
override GetTypeByName :
        type : string -> Object

Parameters

type
Type: SystemString
Specifies name of type.

Return Value

Type: Object
The found type.
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterAllAssemblies Method

ReflectionRepositoryRegisterAllAssemblies Method
Registers all assemblies from the current application domain.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterAllAssemblies()
Public Overridable Sub RegisterAllAssemblies
public:
virtual void RegisterAllAssemblies()
abstract RegisterAllAssemblies : unit -> unit
override RegisterAllAssemblies : unit -> unit

Implements

IReflectionRepositoryRegisterAllAssemblies
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterAssemblies Method

ReflectionRepositoryRegisterAssemblies Method
Overload List
 | Name | Description
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterAssemblies Method (Assembly[])

ReflectionRepositoryRegisterAssemblies Method (Assembly)
Registers list of assemblies for code completion

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RegisterAssemblies(
    Assembly[] assemblies
)
Public Sub RegisterAssemblies (
    assemblies As Assembly()
)
public:
virtual void RegisterAssemblies(
    array<Assembly^>^ assemblies
) sealed
abstract RegisterAssemblies :
        assemblies : Assembly[] -> unit
override RegisterAssemblies :
        assemblies : Assembly[] -> unit

Parameters

assemblies
Type: System.ReflectionAssembly

Implements

IReflectionRepositoryRegisterAssemblies(Assembly)
See Also

Reference

ReflectionRepository Class
RegisterAssemblies Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterAssemblies Method (String[])

ReflectionRepositoryRegisterAssemblies Method (String)
Registers list of assemblies for code completion by assembly reference

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RegisterAssemblies(
    string[] assemblies
)
Public Sub RegisterAssemblies (
    assemblies As String()
)
public:
virtual void RegisterAssemblies(
    array<String^>^ assemblies
) sealed
abstract RegisterAssemblies :
        assemblies : string[] -> unit
override RegisterAssemblies :
        assemblies : string[] -> unit

Parameters

assemblies
Type: SystemString

Implements

IReflectionRepositoryRegisterAssemblies(String)
See Also

Reference

ReflectionRepository Class
RegisterAssemblies Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterAssembly Method

ReflectionRepositoryRegisterAssembly Method
Overload List
 | Name | Description
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list.
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterAssembly Method (Assembly)

ReflectionRepositoryRegisterAssembly Method (Assembly)
Adds specified assembly for code completion to the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterAssembly(
    Assembly assembly
)
Public Overridable Sub RegisterAssembly (
    assembly As Assembly
)
public:
virtual void RegisterAssembly(
    Assembly^ assembly
)
abstract RegisterAssembly :
        assembly : Assembly -> unit
override RegisterAssembly :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Specifies registered assembly.

Implements

IReflectionRepositoryRegisterAssembly(Assembly)
See Also

Reference

ReflectionRepository Class
RegisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterAssembly Method (String)

ReflectionRepositoryRegisterAssembly Method (String)
Adds specified assembly for code completion to the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RegisterAssembly(
    string name
)
Public Overridable Function RegisterAssembly (
    name As String
) As Boolean
public:
virtual bool RegisterAssembly(
    String^ name
)
abstract RegisterAssembly :
        name : string -> bool
override RegisterAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of the assembly.

Return Value

Type: Boolean

Implements

IReflectionRepositoryRegisterAssembly(String)
See Also

Reference

ReflectionRepository Class
RegisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterDefaultAssemblies Method

ReflectionRepositoryRegisterDefaultAssemblies Method
Registers some most frequently used assemblies. Specifies technology platform

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms
)
Public Overridable Sub RegisterDefaultAssemblies (
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms
)
public:
virtual void RegisterDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms
)
abstract RegisterDefaultAssemblies :
        ?technology : TechnologyEnvironment
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
*)
-> unit
override RegisterDefaultAssemblies :
        ?technology : TechnologyEnvironment
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
*)
-> unit

Parameters

technology (Optional)
Type: Alternet.CommonTechnologyEnvironment

Implements

IReflectionRepositoryRegisterDefaultAssemblies(TechnologyEnvironment)
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterType Method

ReflectionRepositoryRegisterType Method
Overload List
 | Name | Description
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list.
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list.
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterType Method (String, Type)

ReflectionRepositoryRegisterType Method (String, Type)
Adds specified type for code completion to the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterType(
    string name,
    Type type
)
Public Overridable Sub RegisterType (
    name As String,
    type As Type
)
public:
virtual void RegisterType(
    String^ name,
    Type^ type
)
abstract RegisterType :
        name : string *
        type : Type -> unit
override RegisterType :
        name : string *
        type : Type -> unit

Parameters

name
Type: SystemString
Specifies name of the type.
type
Type: SystemType
Specifies type to register.

Implements

IReflectionRepositoryRegisterType(String, Type)
See Also

Reference

ReflectionRepository Class
RegisterType Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RegisterType Method (String, Type, Boolean)

ReflectionRepositoryRegisterType Method (String, Type, Boolean)
Adds specified type for code completion to the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterType(
    string name,
    Type type,
    bool global
)
Public Overridable Sub RegisterType (
    name As String,
    type As Type,
    global As Boolean
)
public:
virtual void RegisterType(
    String^ name,
    Type^ type,
    bool global
)
abstract RegisterType :
        name : string *
        type : Type *
        global : bool -> unit
override RegisterType :
        name : string *
        type : Type *
        global : bool -> unit

Parameters

name
Type: SystemString
Specifies name of the type.
type
Type: SystemType
Specifies type to register.
global
Type: SystemBoolean
Specifies whether the type is global.

Implements

IReflectionRepositoryRegisterType(String, Type, Boolean)
See Also

Reference

ReflectionRepository Class
RegisterType Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.RestrictTypeMembers Method

ReflectionRepositoryRestrictTypeMembers Method
Disables type members from being shown in code completion windows.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RestrictTypeMembers(
    Type type
)
Public Overridable Sub RestrictTypeMembers (
    type As Type
)
public:
virtual void RestrictTypeMembers(
    Type^ type
)
abstract RestrictTypeMembers :
        type : Type -> unit
override RestrictTypeMembers :
        type : Type -> unit

Parameters

type
Type: SystemType
Specifies type which members will be disabled.

Implements

IReflectionRepositoryRestrictTypeMembers(Type)
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.UnregisterAssembly Method

ReflectionRepositoryUnregisterAssembly Method
Overload List
 | Name | Description
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list.
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.UnregisterAssembly Method (Assembly, Boolean)

ReflectionRepositoryUnregisterAssembly Method (Assembly, Boolean)
Removes specified assembly from the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterAssembly(
    Assembly assembly,
    bool removeReferences
)
Public Overridable Function UnregisterAssembly (
    assembly As Assembly,
    removeReferences As Boolean
) As Boolean
public:
virtual bool UnregisterAssembly(
    Assembly^ assembly,
    bool removeReferences
)
abstract UnregisterAssembly :
        assembly : Assembly *
        removeReferences : bool -> bool
override UnregisterAssembly :
        assembly : Assembly *
        removeReferences : bool -> bool

Parameters

assembly
Type: System.ReflectionAssembly
Specifies assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all types from the specified assembly should be unregistered.

Return Value

Type: Boolean
True if succeed (assembly is present in the assembly list); otherwise false.

Implements

IReflectionRepositoryUnregisterAssembly(Assembly, Boolean)
See Also

Reference

ReflectionRepository Class
UnregisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.UnregisterAssembly Method (String, Boolean)

ReflectionRepositoryUnregisterAssembly Method (String, Boolean)
Removes specified assembly from the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterAssembly(
    string name,
    bool removeReferences
)
Public Overridable Function UnregisterAssembly (
    name As String,
    removeReferences As Boolean
) As Boolean
public:
virtual bool UnregisterAssembly(
    String^ name,
    bool removeReferences
)
abstract UnregisterAssembly :
        name : string *
        removeReferences : bool -> bool
override UnregisterAssembly :
        name : string *
        removeReferences : bool -> bool

Parameters

name
Type: SystemString
Specifies name of assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all types from the specified assembly should be unregistered.

Return Value

Type: Boolean
True if succeed (assembly is present in the assembly list); otherwise false.

Implements

IReflectionRepositoryUnregisterAssembly(String, Boolean)
See Also

Reference

ReflectionRepository Class
UnregisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.UnregisterType Method

ReflectionRepositoryUnregisterType Method
Removes specified type from the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterType(
    string name
)
Public Overridable Function UnregisterType (
    name As String
) As Boolean
public:
virtual bool UnregisterType(
    String^ name
)
abstract UnregisterType :
        name : string -> bool
override UnregisterType :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of type to remove.

Return Value

Type: Boolean
True if succeed (type is present in the type list); otherwise false.

Implements

IReflectionRepositoryUnregisterType(String)
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository Properties

ReflectionRepository Properties

The ReflectionRepository type exposes the following members.

Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list.
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs.
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.Assemblies Property

ReflectionRepositoryAssemblies Property
Represents assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<Assembly> Assemblies { get; }
Public Overridable ReadOnly Property Assemblies As IList(Of Assembly)
    Get
public:
virtual property IList<Assembly^>^ Assemblies {
    IList<Assembly^>^ get ();
}
abstract Assemblies : IList<Assembly> with get
override Assemblies : IList<Assembly> with get

Property Value

Type: IListAssembly

Implements

IReflectionRepositoryAssemblies
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository.Types Property

ReflectionRepositoryTypes Property
Represents type list in a form of key-value pairs.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Hashtable Types { get; }
Public Overridable ReadOnly Property Types As Hashtable
    Get
public:
virtual property Hashtable^ Types {
    Hashtable^ get ();
}
abstract Types : Hashtable with get
override Types : Hashtable with get

Property Value

Type: Hashtable

Implements

IReflectionRepositoryTypes
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


ReflectionRepository Events

ReflectionRepository Events

The ReflectionRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

ReflectionRepository Class
Alternet.Syntax.CodeCompletion Namespace


SnippetType Enumeration

SnippetType Enumeration
Defines snippet behaviour.

Namespace: Alternet.Syntax.CodeCompletion
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SnippetType
Public Enumeration SnippetType
public enum class SnippetType
type SnippetType
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
SurroundsWith | 1 | Allows the code snippet to be placed around a selected piece of code.
Expansion | 2 | Allows the code snippet to be inserted at the cursor.
Refactoring | 3 | Specifies that the code snippet is used during Visual C# refactoring. Refactoring cannot be used in custom code snippets.
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


SqlListMember Class

SqlListMember Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.CodeCompletionSqlListMember

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SqlListMember : ListMember
Public Class SqlListMember
    Inherits ListMember
public ref class SqlListMember : public ListMember
type SqlListMember =
    class
        inherit ListMember
    end

The SqlListMember type exposes the following members.

Constructors
 | Name | Description
Public method | SqlListMember | Initializes a new instance of the SqlListMember class
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets a CodeCompletionCategory to which this ListMember belongs. (Inherited from ListMember.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


SqlListMember Constructor

SqlListMember Constructor
Initializes a new instance of the SqlListMember class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlListMember(
    IListMembers owner
)
Public Sub New (
    owner As IListMembers
)
public:
SqlListMember(
    IListMembers^ owner
)
new :
        owner : IListMembers -> SqlListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
See Also

Reference

SqlListMember Class
Alternet.Syntax.CodeCompletion Namespace


SqlListMember Methods

SqlListMember Methods

The SqlListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SqlListMember Class
Alternet.Syntax.CodeCompletion Namespace


SqlListMember.GetParamText Method

SqlListMemberGetParamText Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetParamText(
    bool useFormatting
)
Public Overrides Function GetParamText (
    useFormatting As Boolean
) As String
public:
virtual String^ GetParamText(
    bool useFormatting
) override
abstract GetParamText :
        useFormatting : bool -> string
override GetParamText :
        useFormatting : bool -> string

Parameters

useFormatting
Type: SystemBoolean

Return Value

Type: String

Implements

IListMemberGetParamText(Boolean)
See Also

Reference

SqlListMember Class
Alternet.Syntax.CodeCompletion Namespace


SqlListMember Properties

SqlListMember Properties

The SqlListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets a CodeCompletionCategory to which this ListMember belongs. (Inherited from ListMember.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

SqlListMember Class
Alternet.Syntax.CodeCompletion Namespace


SqlListMember.Description Property

SqlListMemberDescription Property

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

IListMemberDescription
See Also

Reference

SqlListMember Class
Alternet.Syntax.CodeCompletion Namespace


SqlListMembers Class

SqlListMembers Class
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionSqlListMembers

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SqlListMembers : ListMembers
Public Class SqlListMembers
    Inherits ListMembers
public ref class SqlListMembers : public ListMembers
type SqlListMembers =
    class
        inherit ListMembers
    end

The SqlListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | SqlListMembers | Initializes a new instance of the SqlListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


SqlListMembers Constructor

SqlListMembers Constructor
Initializes a new instance of the SqlListMembers class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlListMembers()
Public Sub New
public:
SqlListMembers()
new : unit -> SqlListMembers
See Also

Reference

SqlListMembers Class
Alternet.Syntax.CodeCompletion Namespace


SqlListMembers Methods

SqlListMembers Methods

The SqlListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

SqlListMembers Class
Alternet.Syntax.CodeCompletion Namespace


SqlListMembers.CreateListMember Method

SqlListMembersCreateListMember Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember

Implements

IListMembersCreateListMember
See Also

Reference

SqlListMembers Class
Alternet.Syntax.CodeCompletion Namespace


SqlListMembers Properties

SqlListMembers Properties

The SqlListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

SqlListMembers Class
Alternet.Syntax.CodeCompletion Namespace


SqlListMembers Events

SqlListMembers Events

The SqlListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

SqlListMembers Class
Alternet.Syntax.CodeCompletion Namespace


SqlParameterInfo Class

SqlParameterInfo Class
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionParameterInfo
Alternet.Syntax.CodeCompletionSqlParameterInfo

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SqlParameterInfo : ParameterInfo
Public Class SqlParameterInfo
    Inherits ParameterInfo
public ref class SqlParameterInfo : public ParameterInfo
type SqlParameterInfo =
    class
        inherit ParameterInfo
    end

The SqlParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SqlParameterInfo | Initializes a new instance of the SqlParameterInfo class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


SqlParameterInfo Constructor

SqlParameterInfo Constructor
Initializes a new instance of the SqlParameterInfo class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlParameterInfo()
Public Sub New
public:
SqlParameterInfo()
new : unit -> SqlParameterInfo
See Also

Reference

SqlParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


SqlParameterInfo Methods

SqlParameterInfo Methods

The SqlParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

SqlParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


SqlParameterInfo.CreateListMember Method

SqlParameterInfoCreateListMember Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember

Implements

IListMembersCreateListMember
See Also

Reference

SqlParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


SqlParameterInfo Properties

SqlParameterInfo Properties

The SqlParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

SqlParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


SqlParameterInfo Events

SqlParameterInfo Events

The SqlParameterInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

SqlParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepository Class

SqlRepository Class
Represents properties and methods to perform code completion functionality intended to use for SQL language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionSqlRepositoryBase
Alternet.Syntax.CodeCompletionSqlRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SqlRepository : SqlRepositoryBase
Public Class SqlRepository
    Inherits SqlRepositoryBase
public ref class SqlRepository : public SqlRepositoryBase
type SqlRepository =
    class
        inherit SqlRepositoryBase
    end

The SqlRepository type exposes the following members.

Constructors
 | Name | Description
Public method | SqlRepository | Initializes a new instance of the SqlRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from SqlRepositoryBase.)
Public method | FillReswords | (Inherited from SqlRepositoryBase.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from SqlRepositoryBase.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | LoadDataFromXml | (Inherited from SqlRepositoryBase.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from SqlRepositoryBase.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from SqlRepositoryBase.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Reswords | (Inherited from SqlRepositoryBase.)
Public property | SchemaName | Gets or sets name of the SQL schema. (Inherited from SqlRepositoryBase.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Tables | Represents list of tables. (Inherited from SqlRepositoryBase.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


SqlRepository Constructor

SqlRepository Constructor
Initializes a new instance of the SqlRepository class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
SqlRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> SqlRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

SqlRepository Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepository Methods

SqlRepository Methods

The SqlRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from SqlRepositoryBase.)
Public method | FillReswords | (Inherited from SqlRepositoryBase.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from SqlRepositoryBase.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | LoadDataFromXml | (Inherited from SqlRepositoryBase.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

SqlRepository Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepository Properties

SqlRepository Properties

The SqlRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from SqlRepositoryBase.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from SqlRepositoryBase.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Reswords | (Inherited from SqlRepositoryBase.)
Public property | SchemaName | Gets or sets name of the SQL schema. (Inherited from SqlRepositoryBase.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Tables | Represents list of tables. (Inherited from SqlRepositoryBase.)
Top
See Also

Reference

SqlRepository Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepository Events

SqlRepository Events

The SqlRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

SqlRepository Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase Class

SqlRepositoryBase Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionSqlRepositoryBase
Alternet.Syntax.CodeCompletionMSSqlRepository
Alternet.Syntax.CodeCompletionSqlRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SqlRepositoryBase : CodeCompletionRepository,
    IDisposable
Public Class SqlRepositoryBase
    Inherits CodeCompletionRepository
    Implements IDisposable
public ref class SqlRepositoryBase : public CodeCompletionRepository,
    IDisposable
type SqlRepositoryBase =
    class
        inherit CodeCompletionRepository
        interface IDisposable
    end

The SqlRepositoryBase type exposes the following members.

Constructors
 | Name | Description
Public method | SqlRepositoryBase | Initializes a new instance of the SqlRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Overrides CodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32).)
Public method | FillReswords |
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Overrides CodeCompletionRepositoryGetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | LoadDataFromXml |
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Reswords |
Public property | SchemaName | Gets or sets name of the SQL schema.
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Tables | Represents list of tables.
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase Constructor

SqlRepositoryBase Constructor
Initializes a new instance of the SqlRepository class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlRepositoryBase(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
SqlRepositoryBase(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> SqlRepositoryBase

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase Methods

SqlRepositoryBase Methods

The SqlRepositoryBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Overrides CodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32).)
Public method | FillReswords |
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Overrides CodeCompletionRepositoryGetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | LoadDataFromXml |
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.FillMembers Method

SqlRepositoryBaseFillMembers Method
When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FillMembers(
    ISyntaxNode node,
    Point position,
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope,
    ref int selIndex
)
Public Overrides Sub FillMembers (
    node As ISyntaxNode,
    position As Point,
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope,
    ByRef selIndex As Integer
)
public:
virtual void FillMembers(
    ISyntaxNode^ node,
    Point position,
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope,
    int% selIndex
) override
abstract FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit
override FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
position
Type: System.DrawingPoint
Specifies position of language element in the text.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies filter used to fill members.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
selIndex
Type: SystemInt32
Specifies index of default list member.

Implements

ICodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32)
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.FillReswords Method

SqlRepositoryBaseFillReswords Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillReswords(
    IListMembers members,
    string filter
)
Public Overridable Sub FillReswords (
    members As IListMembers,
    filter As String
)
public:
virtual void FillReswords(
    IListMembers^ members,
    String^ filter
)
abstract FillReswords :
        members : IListMembers *
        filter : string -> unit
override FillReswords :
        members : IListMembers *
        filter : string -> unit

Parameters

members
Type: Alternet.Syntax.CodeCompletionIListMembers
filter
Type: SystemString
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.GetMemberType Method

SqlRepositoryBaseGetMemberType Method
Overload List
 | Name | Description
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Overrides CodeCompletionRepositoryGetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
Top
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.GetMemberType Method (String, ISyntaxNode, String, Point, Point, CodeCompletionScope)

SqlRepositoryBaseGetMemberType Method (String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
Obtains information about some language element to perform code completion related operations.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetMemberType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out CodeCompletionScope scope
)
Public Overrides Function GetMemberType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetMemberType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] CodeCompletionScope% scope
) override
abstract GetMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object
override GetMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found language element.
position
Type: System.DrawingPoint
Specifies position of found language element in the code text and updates it if needed.
endPos
Type: System.DrawingPoint
Specifies end position of found language element in the code text and updates it if needed.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about language element to complete.

Implements

ICodeCompletionRepositoryGetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
See Also

Reference

SqlRepositoryBase Class
GetMemberType Overload
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.LoadDataFromXml Method

SqlRepositoryBaseLoadDataFromXml Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void LoadDataFromXml(
    string fileName
)
Public Overridable Sub LoadDataFromXml (
    fileName As String
)
public:
virtual void LoadDataFromXml(
    String^ fileName
)
abstract LoadDataFromXml :
        fileName : string -> unit
override LoadDataFromXml :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase Properties

SqlRepositoryBase Properties

The SqlRepositoryBase type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Reswords |
Public property | SchemaName | Gets or sets name of the SQL schema.
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Tables | Represents list of tables.
Top
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.Images Property

SqlRepositoryBaseImages Property
Represents collection of images used for code completion.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; }
Public Overrides ReadOnly Property Images As ImageList
    Get
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
}
abstract Images : ImageList with get
override Images : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImages
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.ImagesHighDpi Property

SqlRepositoryBaseImagesHighDpi Property
Represents collection of images used for code completion for high DPI.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList ImagesHighDpi { get; }
Public Overrides ReadOnly Property ImagesHighDpi As ImageList
    Get
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get () override;
}
abstract ImagesHighDpi : ImageList with get
override ImagesHighDpi : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImagesHighDpi
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.Reswords Property

SqlRepositoryBaseReswords Property

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hashtable Reswords { get; set; }
Public Property Reswords As Hashtable
    Get
    Set
public:
property Hashtable^ Reswords {
    Hashtable^ get ();
    void set (Hashtable^ value);
}
member Reswords : Hashtable with get, set

Property Value

Type: Hashtable
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.SchemaName Property

SqlRepositoryBaseSchemaName Property
Gets or sets name of the SQL schema.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SchemaName { get; set; }
Public Property SchemaName As String
    Get
    Set
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}
member SchemaName : string with get, set

Property Value

Type: String
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.Tables Property

SqlRepositoryBaseTables Property
Represents list of tables.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<SqlRepositoryBaseTableItem> Tables { get; }
Public ReadOnly Property Tables As IList(Of SqlRepositoryBaseTableItem)
    Get
public:
property IList<SqlRepositoryBaseTableItem^>^ Tables {
    IList<SqlRepositoryBaseTableItem^>^ get ();
}
member Tables : IList<SqlRepositoryBaseTableItem> with get

Property Value

Type: IListSqlRepositoryBaseTableItem
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase Events

SqlRepositoryBase Events

The SqlRepositoryBase type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

SqlRepositoryBase Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.TableItem Class

SqlRepositoryBaseTableItem Class
Represents a particular table.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionSqlRepositoryBaseTableItem

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableItem
Public Class TableItem
public ref class TableItem
type TableItem =  class end

The SqlRepositoryBaseTableItem type exposes the following members.

Constructors
 | Name | Description
Public method | SqlRepositoryBaseTableItem | Initializes a new instance of the TableItem class with default settings.
Public method | SqlRepositoryBaseTableItem(String) | Initializes a new instance of the TableItem class with specified table name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Fields | Represents a collection of table's fields.
Public property | TableName | Gets or sets table's name.
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


TableItem Constructor

TableItem Constructor
Overload List
 | Name | Description
Public method | SqlRepositoryBaseTableItem | Initializes a new instance of the TableItem class with default settings.
Public method | SqlRepositoryBaseTableItem(String) | Initializes a new instance of the TableItem class with specified table name.
Top
See Also

Reference

SqlRepositoryBaseTableItem Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.TableItem Constructor

SqlRepositoryBaseTableItem Constructor
Initializes a new instance of the TableItem class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableItem()
Public Sub New
public:
TableItem()
new : unit -> TableItem
See Also

Reference

SqlRepositoryBaseTableItem Class
SqlRepositoryBaseTableItem Overload
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.TableItem Constructor (String)

SqlRepositoryBaseTableItem Constructor (String)
Initializes a new instance of the TableItem class with specified table name.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableItem(
    string tableName
)
Public Sub New (
    tableName As String
)
public:
TableItem(
    String^ tableName
)
new :
        tableName : string -> TableItem

Parameters

tableName
Type: SystemString
Table's name.
See Also

Reference

SqlRepositoryBaseTableItem Class
SqlRepositoryBaseTableItem Overload
Alternet.Syntax.CodeCompletion Namespace


TableItem Methods

TableItem Methods

The SqlRepositoryBaseTableItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SqlRepositoryBaseTableItem Class
Alternet.Syntax.CodeCompletion Namespace


TableItem Properties

TableItem Properties

The SqlRepositoryBaseTableItem type exposes the following members.

Properties
 | Name | Description
Public property | Fields | Represents a collection of table's fields.
Public property | TableName | Gets or sets table's name.
Top
See Also

Reference

SqlRepositoryBaseTableItem Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.TableItem.Fields Property

SqlRepositoryBaseTableItemFields Property
Represents a collection of table's fields.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Fields { get; }
Public ReadOnly Property Fields As IList(Of String)
    Get
public:
property IList<String^>^ Fields {
    IList<String^>^ get ();
}
member Fields : IList<string> with get

Property Value

Type: IListString
See Also

Reference

SqlRepositoryBaseTableItem Class
Alternet.Syntax.CodeCompletion Namespace


SqlRepositoryBase.TableItem.TableName Property

SqlRepositoryBaseTableItemTableName Property
Gets or sets table's name.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TableName { get; set; }
Public Property TableName As String
    Get
    Set
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}
member TableName : string with get, set

Property Value

Type: String
See Also

Reference

SqlRepositoryBaseTableItem Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository Class

T4Repository Class
Represents properties and methods to perform code completion functionality intended to use for T4 language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionT4Repository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class T4Repository : CodeCompletionRepository
Public Class T4Repository
    Inherits CodeCompletionRepository
public ref class T4Repository : public CodeCompletionRepository
type T4Repository =
    class
        inherit CodeCompletionRepository
    end

The T4Repository type exposes the following members.

Constructors
 | Name | Description
Public method | T4Repository | Initializes a new instance of the T4Repository class with specified parameters.
Top
Methods
 | Name | Description
Public method | ClearAssemblies | Removes all elements from the assembly list.
Public method | ClearNamespaces | Removes all elements from the namespace list.
Public method | ClearObjects | Removes all elements from the object list.
Public method | ClearTypes | Removes all elements from the type list.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetRegisteredObject | Finds object by its name.
Public method | GetRegisteredType | Find type by its name.
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly to the assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly to the assembly list.
Public method | RegisterNamespace | Adds specified namespace to the namespace list.
Public method | RegisterObject | Adds specified object to the object list.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type to the type list.
Public method | RegisterType(String, Type, Boolean) | Adds specified type to the type list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly form the assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly form the assembly list.
Public method | UnregisterNamespace | Removes specified namespace form the namespace list.
Public method | UnregisterObject | Removes specified object from the object list.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list.
Top
Properties
 | Name | Description
Public property | Assemblies | Represents list of Assemblies available for code completion.
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Gets or sets ImageList attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | ImagesHighDpi | Gets or sets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from CodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents list of namespaces available for code completion..
Public property | Objects | Represents list of objects available for code completion..
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


T4Repository Constructor

T4Repository Constructor
Initializes a new instance of the T4Repository class with specified parameters.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public T4Repository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
T4Repository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> T4Repository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository Methods

T4Repository Methods

The T4Repository type exposes the following members.

Methods
 | Name | Description
Public method | ClearAssemblies | Removes all elements from the assembly list.
Public method | ClearNamespaces | Removes all elements from the namespace list.
Public method | ClearObjects | Removes all elements from the object list.
Public method | ClearTypes | Removes all elements from the type list.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetRegisteredObject | Finds object by its name.
Public method | GetRegisteredType | Find type by its name.
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly to the assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly to the assembly list.
Public method | RegisterNamespace | Adds specified namespace to the namespace list.
Public method | RegisterObject | Adds specified object to the object list.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type to the type list.
Public method | RegisterType(String, Type, Boolean) | Adds specified type to the type list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly form the assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly form the assembly list.
Public method | UnregisterNamespace | Removes specified namespace form the namespace list.
Public method | UnregisterObject | Removes specified object from the object list.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list.
Top
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.ClearAssemblies Method

T4RepositoryClearAssemblies Method
Removes all elements from the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearAssemblies()
Public Overridable Sub ClearAssemblies
public:
virtual void ClearAssemblies()
abstract ClearAssemblies : unit -> unit
override ClearAssemblies : unit -> unit
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.ClearNamespaces Method

T4RepositoryClearNamespaces Method
Removes all elements from the namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearNamespaces()
Public Overridable Sub ClearNamespaces
public:
virtual void ClearNamespaces()
abstract ClearNamespaces : unit -> unit
override ClearNamespaces : unit -> unit
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.ClearObjects Method

T4RepositoryClearObjects Method
Removes all elements from the object list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearObjects()
Public Overridable Sub ClearObjects
public:
virtual void ClearObjects()
abstract ClearObjects : unit -> unit
override ClearObjects : unit -> unit
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.ClearTypes Method

T4RepositoryClearTypes Method
Removes all elements from the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ClearTypes()
Public Overridable Sub ClearTypes
public:
virtual void ClearTypes()
abstract ClearTypes : unit -> unit
override ClearTypes : unit -> unit
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.GetRegisteredObject Method

T4RepositoryGetRegisteredObject Method
Finds object by its name.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetRegisteredObject(
    string name
)
Public Overridable Function GetRegisteredObject (
    name As String
) As Object
public:
virtual Object^ GetRegisteredObject(
    String^ name
)
abstract GetRegisteredObject :
        name : string -> Object
override GetRegisteredObject :
        name : string -> Object

Parameters

name
Type: SystemString
Name of the object.

Return Value

Type: Object
Object found in objects collection by its name; or null if not found.
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.GetRegisteredType Method

T4RepositoryGetRegisteredType Method
Find type by its name.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetRegisteredType(
    string name
)
Public Overridable Function GetRegisteredType (
    name As String
) As Object
public:
virtual Object^ GetRegisteredType(
    String^ name
)
abstract GetRegisteredType :
        name : string -> Object
override GetRegisteredType :
        name : string -> Object

Parameters

name
Type: SystemString
Name of the type.

Return Value

Type: Object
Type found in types collection by its name; or null if not found.
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.RegisterAssembly Method

T4RepositoryRegisterAssembly Method
Overload List
 | Name | Description
Public method | RegisterAssembly(Assembly) | Adds specified assembly to the assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly to the assembly list.
Top
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.RegisterAssembly Method (Assembly)

T4RepositoryRegisterAssembly Method (Assembly)
Adds specified assembly to the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterAssembly(
    Assembly assembly
)
Public Overridable Sub RegisterAssembly (
    assembly As Assembly
)
public:
virtual void RegisterAssembly(
    Assembly^ assembly
)
abstract RegisterAssembly :
        assembly : Assembly -> unit
override RegisterAssembly :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to register.
See Also

Reference

T4Repository Class
RegisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


T4Repository.RegisterAssembly Method (String)

T4RepositoryRegisterAssembly Method (String)
Adds specified assembly to the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RegisterAssembly(
    string name
)
Public Overridable Function RegisterAssembly (
    name As String
) As Boolean
public:
virtual bool RegisterAssembly(
    String^ name
)
abstract RegisterAssembly :
        name : string -> bool
override RegisterAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Name of assembly to register.

Return Value

Type: Boolean
See Also

Reference

T4Repository Class
RegisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


T4Repository.RegisterNamespace Method

T4RepositoryRegisterNamespace Method
Adds specified namespace to the namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterNamespace(
    string nspace
)
Public Overridable Sub RegisterNamespace (
    nspace As String
)
public:
virtual void RegisterNamespace(
    String^ nspace
)
abstract RegisterNamespace :
        nspace : string -> unit
override RegisterNamespace :
        nspace : string -> unit

Parameters

nspace
Type: SystemString
Name of namespace to register.
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.RegisterObject Method

T4RepositoryRegisterObject Method
Adds specified object to the object list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterObject(
    string name,
    Object obj
)
Public Overridable Sub RegisterObject (
    name As String,
    obj As Object
)
public:
virtual void RegisterObject(
    String^ name,
    Object^ obj
)
abstract RegisterObject :
        name : string *
        obj : Object -> unit
override RegisterObject :
        name : string *
        obj : Object -> unit

Parameters

name
Type: SystemString
Key name of the object.
obj
Type: SystemObject
Object to register.
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.RegisterType Method

T4RepositoryRegisterType Method
Overload List
 | Name | Description
Public method | RegisterType(String, Type) | Adds specified type to the type list.
Public method | RegisterType(String, Type, Boolean) | Adds specified type to the type list.
Top
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.RegisterType Method (String, Type)

T4RepositoryRegisterType Method (String, Type)
Adds specified type to the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterType(
    string name,
    Type type
)
Public Overridable Sub RegisterType (
    name As String,
    type As Type
)
public:
virtual void RegisterType(
    String^ name,
    Type^ type
)
abstract RegisterType :
        name : string *
        type : Type -> unit
override RegisterType :
        name : string *
        type : Type -> unit

Parameters

name
Type: SystemString
Key name of the type.
type
Type: SystemType
Type to register.
See Also

Reference

T4Repository Class
RegisterType Overload
Alternet.Syntax.CodeCompletion Namespace


T4Repository.RegisterType Method (String, Type, Boolean)

T4RepositoryRegisterType Method (String, Type, Boolean)
Adds specified type to the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterType(
    string name,
    Type type,
    bool global
)
Public Overridable Sub RegisterType (
    name As String,
    type As Type,
    global As Boolean
)
public:
virtual void RegisterType(
    String^ name,
    Type^ type,
    bool global
)
abstract RegisterType :
        name : string *
        type : Type *
        global : bool -> unit
override RegisterType :
        name : string *
        type : Type *
        global : bool -> unit

Parameters

name
Type: SystemString
Name of the type.
type
Type: SystemType
Type to register.
global
Type: SystemBoolean
Indicates whether type is global.
See Also

Reference

T4Repository Class
RegisterType Overload
Alternet.Syntax.CodeCompletion Namespace


T4Repository.UnregisterAssembly Method

T4RepositoryUnregisterAssembly Method
Overload List
 | Name | Description
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly form the assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly form the assembly list.
Top
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.UnregisterAssembly Method (Assembly, Boolean)

T4RepositoryUnregisterAssembly Method (Assembly, Boolean)
Removes specified assembly form the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterAssembly(
    Assembly assembly,
    bool removeReferences
)
Public Overridable Function UnregisterAssembly (
    assembly As Assembly,
    removeReferences As Boolean
) As Boolean
public:
virtual bool UnregisterAssembly(
    Assembly^ assembly,
    bool removeReferences
)
abstract UnregisterAssembly :
        assembly : Assembly *
        removeReferences : bool -> bool
override UnregisterAssembly :
        assembly : Assembly *
        removeReferences : bool -> bool

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all references to this assembly should been cleared.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

T4Repository Class
UnregisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


T4Repository.UnregisterAssembly Method (String, Boolean)

T4RepositoryUnregisterAssembly Method (String, Boolean)
Removes specified assembly form the assembly list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterAssembly(
    string name,
    bool removeReferences
)
Public Overridable Function UnregisterAssembly (
    name As String,
    removeReferences As Boolean
) As Boolean
public:
virtual bool UnregisterAssembly(
    String^ name,
    bool removeReferences
)
abstract UnregisterAssembly :
        name : string *
        removeReferences : bool -> bool
override UnregisterAssembly :
        name : string *
        removeReferences : bool -> bool

Parameters

name
Type: SystemString
Name of assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all references to this assembly should been cleared.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

T4Repository Class
UnregisterAssembly Overload
Alternet.Syntax.CodeCompletion Namespace


T4Repository.UnregisterNamespace Method

T4RepositoryUnregisterNamespace Method
Removes specified namespace form the namespace list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterNamespace(
    string nspace
)
Public Overridable Function UnregisterNamespace (
    nspace As String
) As Boolean
public:
virtual bool UnregisterNamespace(
    String^ nspace
)
abstract UnregisterNamespace :
        nspace : string -> bool
override UnregisterNamespace :
        nspace : string -> bool

Parameters

nspace
Type: SystemString
Namespace to remove.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.UnregisterObject Method

T4RepositoryUnregisterObject Method
Removes specified object from the object list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterObject(
    string name
)
Public Overridable Function UnregisterObject (
    name As String
) As Boolean
public:
virtual bool UnregisterObject(
    String^ name
)
abstract UnregisterObject :
        name : string -> bool
override UnregisterObject :
        name : string -> bool

Parameters

name
Type: SystemString
Name of object to remove.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.UnregisterType Method

T4RepositoryUnregisterType Method
Removes specified type from the type list.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterType(
    string name
)
Public Overridable Function UnregisterType (
    name As String
) As Boolean
public:
virtual bool UnregisterType(
    String^ name
)
abstract UnregisterType :
        name : string -> bool
override UnregisterType :
        name : string -> bool

Parameters

name
Type: SystemString
Name of type to remove.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository Properties

T4Repository Properties

The T4Repository type exposes the following members.

Properties
 | Name | Description
Public property | Assemblies | Represents list of Assemblies available for code completion.
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Gets or sets ImageList attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | ImagesHighDpi | Gets or sets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from CodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents list of namespaces available for code completion..
Public property | Objects | Represents list of objects available for code completion..
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.Assemblies Property

T4RepositoryAssemblies Property
Represents list of Assemblies available for code completion.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<Assembly> Assemblies { get; }
Public Overridable ReadOnly Property Assemblies As IList(Of Assembly)
    Get
public:
virtual property IList<Assembly^>^ Assemblies {
    IList<Assembly^>^ get ();
}
abstract Assemblies : IList<Assembly> with get
override Assemblies : IList<Assembly> with get

Property Value

Type: IListAssembly
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.Namespaces Property

T4RepositoryNamespaces Property
Represents list of namespaces available for code completion..

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<INetNamespace> Namespaces { get; }
Public ReadOnly Property Namespaces As IList(Of INetNamespace)
    Get
public:
property IList<INetNamespace^>^ Namespaces {
    IList<INetNamespace^>^ get ();
}
member Namespaces : IList<INetNamespace> with get

Property Value

Type: IListINetNamespace
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository.Objects Property

T4RepositoryObjects Property
Represents list of objects available for code completion..

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hashtable Objects { get; }
Public ReadOnly Property Objects As Hashtable
    Get
public:
property Hashtable^ Objects {
    Hashtable^ get ();
}
member Objects : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


T4Repository Events

T4Repository Events

The T4Repository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

T4Repository Class
Alternet.Syntax.CodeCompletion Namespace


VbListMember Class

VbListMember Class
Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe Visual Basic language code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.CodeCompletionVbListMember

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbListMember : ListMember
Public Class VbListMember
    Inherits ListMember
public ref class VbListMember : public ListMember
type VbListMember =
    class
        inherit ListMember
    end

The VbListMember type exposes the following members.

Constructors
 | Name | Description
Public method | VbListMember | Initializes a new instance of the VbListMember class with default settings.
Public method | VbListMember(IListMembers, Boolean) | Initializes a new instance of the VbListMember class with specified owner.
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Overrides ListMemberGetTemplate(Boolean).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBuiltInType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


VbListMember Constructor

VbListMember Constructor
Overload List
 | Name | Description
Public method | VbListMember | Initializes a new instance of the VbListMember class with default settings.
Public method | VbListMember(IListMembers, Boolean) | Initializes a new instance of the VbListMember class with specified owner.
Top
See Also

Reference

VbListMember Class
Alternet.Syntax.CodeCompletion Namespace


VbListMember Constructor

VbListMember Constructor
Initializes a new instance of the VbListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbListMember()
Public Sub New
public:
VbListMember()
new : unit -> VbListMember
See Also

Reference

VbListMember Class
VbListMember Overload
Alternet.Syntax.CodeCompletion Namespace


VbListMember Constructor (IListMembers, Boolean)

VbListMember Constructor (IListMembers, Boolean)
Initializes a new instance of the VbListMember class with specified owner.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbListMember(
    IListMembers owner,
    bool fullDescription
)
Public Sub New (
    owner As IListMembers,
    fullDescription As Boolean
)
public:
VbListMember(
    IListMembers^ owner,
    bool fullDescription
)
new :
        owner : IListMembers *
        fullDescription : bool -> VbListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
IListMembers owning this instance.
fullDescription
Type: SystemBoolean
Boolean value indicating that member should provide detailed description.
See Also

Reference

VbListMember Class
VbListMember Overload
Alternet.Syntax.CodeCompletion Namespace


VbListMember Methods

VbListMember Methods

The VbListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Overrides ListMemberGetTemplate(Boolean).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBuiltInType |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VbListMember Class
Alternet.Syntax.CodeCompletion Namespace


VbListMember.GetParamText Method

VbListMemberGetParamText Method
Converts Parameters property to a single string.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetParamText(
    bool useFormatting
)
Public Overrides Function GetParamText (
    useFormatting As Boolean
) As String
public:
virtual String^ GetParamText(
    bool useFormatting
) override
abstract GetParamText :
        useFormatting : bool -> string
override GetParamText :
        useFormatting : bool -> string

Parameters

useFormatting
Type: SystemBoolean
Specifies whether to use html formatting tags.

Return Value

Type: String
Returns Parameters in the form of comma separated text, framed by parentheses.

Implements

IListMemberGetParamText(Boolean)
See Also

Reference

VbListMember Class
Alternet.Syntax.CodeCompletion Namespace


VbListMember.GetTemplate Method

VbListMemberGetTemplate Method
Return member's template.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetTemplate(
    bool compact
)
Public Overrides Function GetTemplate (
    compact As Boolean
) As String
public:
virtual String^ GetTemplate(
    bool compact
) override
abstract GetTemplate :
        compact : bool -> string
override GetTemplate :
        compact : bool -> string

Parameters

compact
Type: SystemBoolean
Indicates if template is in a compact form.

Return Value

Type: String
String value that represents member template.

Implements

IListMemberGetTemplate(Boolean)
See Also

Reference

VbListMember Class
Alternet.Syntax.CodeCompletion Namespace


VbListMember.IsBuiltInType Method

VbListMemberIsBuiltInType Method

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInType(
    string dataType
)
Public Shared Function IsBuiltInType (
    dataType As String
) As Boolean
public:
static bool IsBuiltInType(
    String^ dataType
)
static member IsBuiltInType :
        dataType : string -> bool

Parameters

dataType
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

VbListMember Class
Alternet.Syntax.CodeCompletion Namespace


VbListMember Properties

VbListMember Properties

The VbListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

VbListMember Class
Alternet.Syntax.CodeCompletion Namespace


VbListMember.Category Property

VbListMemberCategory Property

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionCategory Category { get; }
Public Overrides ReadOnly Property Category As CodeCompletionCategory
    Get
public:
virtual property CodeCompletionCategory^ Category {
    CodeCompletionCategory^ get () override;
}
abstract Category : CodeCompletionCategory with get
override Category : CodeCompletionCategory with get

Property Value

Type: CodeCompletionCategory

Implements

ICategorizedListMemberCategory
See Also

Reference

VbListMember Class
Alternet.Syntax.CodeCompletion Namespace


VbListMember.Description Property

VbListMemberDescription Property
Return member's description.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Return Value

Type: String
String value that describes the member.

Implements

IListMemberDescription
See Also

Reference

VbListMember Class
Alternet.Syntax.CodeCompletion Namespace


VbListMembers Class

VbListMembers Class
Represents data collection related to popup list box controls used to describe Visual Basic language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionNetListMembers
Alternet.Syntax.CodeCompletionVbListMembers

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbListMembers : NetListMembers
Public Class VbListMembers
    Inherits NetListMembers
public ref class VbListMembers : public NetListMembers
type VbListMembers =
    class
        inherit NetListMembers
    end

The VbListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | VbListMembers | Initializes a new instance of the VbListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the VbListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from NetListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


VbListMembers Constructor

VbListMembers Constructor
Initializes a new instance of the VbListMembers class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbListMembers()
Public Sub New
public:
VbListMembers()
new : unit -> VbListMembers
See Also

Reference

VbListMembers Class
Alternet.Syntax.CodeCompletion Namespace


VbListMembers Methods

VbListMembers Methods

The VbListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the VbListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from NetListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

VbListMembers Class
Alternet.Syntax.CodeCompletion Namespace


VbListMembers.CreateListMember Method

VbListMembersCreateListMember Method
Initializes a new instance of the VbListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

VbListMembers Class
Alternet.Syntax.CodeCompletion Namespace


VbListMembers Properties

VbListMembers Properties

The VbListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

VbListMembers Class
Alternet.Syntax.CodeCompletion Namespace


VbListMembers Events

VbListMembers Events

The VbListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

VbListMembers Class
Alternet.Syntax.CodeCompletion Namespace


VbParameterInfo Class

VbParameterInfo Class
Represents Parameter Info data related to popup window and popup hint controls used to describe Visual Basic language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionParameterInfo
Alternet.Syntax.CodeCompletionNetParameterInfo
Alternet.Syntax.CodeCompletionVbParameterInfo

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbParameterInfo : NetParameterInfo
Public Class VbParameterInfo
    Inherits NetParameterInfo
public ref class VbParameterInfo : public NetParameterInfo
type VbParameterInfo =
    class
        inherit NetParameterInfo
    end

The VbParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VbParameterInfo | Initializes a new instance of the VbParameterInfo class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the VbListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Inherited from NetParameterInfo.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


VbParameterInfo Constructor

VbParameterInfo Constructor
Initializes a new instance of the VbParameterInfo class

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbParameterInfo()
Public Sub New
public:
VbParameterInfo()
new : unit -> VbParameterInfo
See Also

Reference

VbParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


VbParameterInfo Methods

VbParameterInfo Methods

The VbParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the VbListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Inherited from NetParameterInfo.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

VbParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


VbParameterInfo.CreateListMember Method

VbParameterInfoCreateListMember Method
Initializes a new instance of the VbListMember class with default settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

VbParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


VbParameterInfo Properties

VbParameterInfo Properties

The VbParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

VbParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


VbParameterInfo Events

VbParameterInfo Events

The VbParameterInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

VbParameterInfo Class
Alternet.Syntax.CodeCompletion Namespace


VbRepository Class

VbRepository Class
Represents properties and methods to perform code completion functionality intended to use for Vb Script language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionNETRepository
Alternet.Syntax.CodeCompletionReflectionRepository
Alternet.Syntax.CodeCompletionVbRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbRepository : ReflectionRepository
Public Class VbRepository
    Inherits ReflectionRepository
public ref class VbRepository : public ReflectionRepository
type VbRepository =
    class
        inherit ReflectionRepository
    end

The VbRepository type exposes the following members.

Constructors
 | Name | Description
Public method | VbRepository | Initializes a new instance of the VbRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Overrides CodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32).)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from ReflectionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Overrides NETRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides NETRepositoryIsDeclarationNode(ISyntaxNode, Boolean).)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


VbRepository Constructor

VbRepository Constructor
Initializes a new instance of the VbRepository class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
VbRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> VbRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

VbRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbRepository Methods

VbRepository Methods

The VbRepository type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Overrides CodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32).)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from ReflectionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from NETRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Overrides NETRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides NETRepositoryIsDeclarationNode(ISyntaxNode, Boolean).)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbRepository.FillMembers Method

VbRepositoryFillMembers Method
Fills list members provider with list of its member, providing available choices for the specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FillMembers(
    ISyntaxNode node,
    Point position,
    IListMembers members,
    Object member,
    string name,
    CodeCompletionScope scope,
    ref int selIndex
)
Public Overrides Sub FillMembers (
    node As ISyntaxNode,
    position As Point,
    members As IListMembers,
    member As Object,
    name As String,
    scope As CodeCompletionScope,
    ByRef selIndex As Integer
)
public:
virtual void FillMembers(
    ISyntaxNode^ node,
    Point position,
    IListMembers^ members,
    Object^ member,
    String^ name,
    CodeCompletionScope scope,
    int% selIndex
) override
abstract FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit
override FillMembers :
        node : ISyntaxNode *
        position : Point *
        members : IListMembers *
        member : Object *
        name : string *
        scope : CodeCompletionScope *
        selIndex : int byref -> unit

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
position
Type: System.DrawingPoint
Specifies position of language element in the text.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
member
Type: SystemObject
Specifies language element.
name
Type: SystemString
Specifies filter used to fill members.
scope
Type: Alternet.SyntaxCodeCompletionScope
Specifies search constraints.
selIndex
Type: SystemInt32
Specifies index of default list member.

Implements

ICodeCompletionRepositoryFillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32)
See Also

Reference

VbRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbRepository.GetSpecialMemberType Method

VbRepositoryGetSpecialMemberType Method
Obtains information about a member of some language element in special cases.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetSpecialMemberType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out CodeCompletionScope scope
)
Public Overrides Function GetSpecialMemberType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetSpecialMemberType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] CodeCompletionScope% scope
) override
abstract GetSpecialMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object
override GetSpecialMemberType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Text at specified position.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing a current language element.
name
Type: SystemString
Specifies name of the member to locate.
position
Type: System.DrawingPoint
Specifies position of language element.
endPos
Type: System.DrawingPoint
Specifies end position of found language element in the code text and updates it if needed.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for this language element.

Return Value

Type: Object
Object representing information about found member.

Implements

ICodeCompletionRepositoryGetSpecialMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope)
See Also

Reference

VbRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbRepository.IsDeclarationNode Method

VbRepositoryIsDeclarationNode Method
Overload List
 | Name | Description
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides NETRepositoryIsDeclarationNode(ISyntaxNode, Boolean).)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbRepository.IsDeclarationNode Method (ISyntaxNode, Boolean)

VbRepositoryIsDeclarationNode Method (ISyntaxNode, Boolean)
Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsDeclarationNode(
    ref ISyntaxNode node,
    bool checkRegions
)
Public Overrides Function IsDeclarationNode (
    ByRef node As ISyntaxNode,
    checkRegions As Boolean
) As Boolean
public:
virtual bool IsDeclarationNode(
    ISyntaxNode^% node,
    bool checkRegions
) override
abstract IsDeclarationNode :
        node : ISyntaxNode byref *
        checkRegions : bool -> bool
override IsDeclarationNode :
        node : ISyntaxNode byref *
        checkRegions : bool -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.
checkRegions
Type: SystemBoolean
Indicates that region nodes should be skipped.

Return Value

Type: Boolean
True if specified node is declaration node; otherwise false.

Implements

INETRepositoryIsDeclarationNode(ISyntaxNode, Boolean)
See Also

Reference

VbRepository Class
IsDeclarationNode Overload
Alternet.Syntax.CodeCompletion Namespace


VbRepository Properties

VbRepository Properties

The VbRepository type exposes the following members.

Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbRepository Events

VbRepository Events

The VbRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbScriptRepository Class

VbScriptRepository Class
Represents properties and methods to perform code completion functionality intended to use for Vb Script language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.CodeCompletionNETRepository
Alternet.Syntax.CodeCompletionReflectionRepository
Alternet.Syntax.CodeCompletionVbScriptRepository

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbScriptRepository : ReflectionRepository
Public Class VbScriptRepository
    Inherits ReflectionRepository
public ref class VbScriptRepository : public ReflectionRepository
type VbScriptRepository =
    class
        inherit ReflectionRepository
    end

The VbScriptRepository type exposes the following members.

Constructors
 | Name | Description
Public method | VbScriptRepository | Initializes a new instance of the VbScriptRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from ReflectionRepository.)
 | GetExpressionType | Gets a type of expression.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Overrides NETRepositoryGetMethodType(String, ISyntaxNode, String, Point, Point, Int32, Int32, CodeCompletionScope).)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from NETRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


VbScriptRepository Constructor

VbScriptRepository Constructor
Initializes a new instance of the VbScriptRepository class with specified settings.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbScriptRepository(
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
VbScriptRepository(
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> VbScriptRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

VbScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbScriptRepository Methods

VbScriptRepository Methods

The VbScriptRepository type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeMembers | Re-enables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | ClearAssemblies | Clears assembly list. (Inherited from ReflectionRepository.)
Public method | ClearNamespaces | Clears namespace list. (Inherited from NETRepository.)
Public method | ClearObjects | Clears object list. (Inherited from NETRepository.)
Public method | ClearTypes | Clears type list. (Inherited from ReflectionRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from ReflectionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from NETRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from NETRepository.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NETRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from NETRepository.)
Public method | GetCommentTemplate | Returns xml comment template for given node in the text. (Inherited from NETRepository.)
Public method | GetDeclarationNode | Retrieves declaration node nearest to the specified node. (Inherited from NETRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from ReflectionRepository.)
 | GetExpressionType | Gets a type of expression.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from ReflectionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from NETRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Overrides NETRepositoryGetMethodType(String, ISyntaxNode, String, Point, Point, Int32, Int32, CodeCompletionScope).)
Public method | GetNodeType | Obtains information type of the SyntaxNode. (Inherited from NETRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from ReflectionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the object. (Inherited from NETRepository.)
Public method | GetRegisteredObject | Retrieves registered object by its name. (Inherited from NETRepository.)
Public method | GetRegisteredType | Retrieves registered type by its name. (Inherited from ReflectionRepository.)
Public method | GetSpecialMemberType | Obtains information about a member of some language element in special cases. (Inherited from NETRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeByName | Retrieves type by its name. (Inherited from ReflectionRepository.)
Public method | GetXmlReferenceNode | Returns declaration node corresponding to xml comment. (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsDeclarationNode(ISyntaxNode, Boolean) | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NETRepository.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from NETRepository.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(Assembly) | Registers list of assemblies for code completion (Inherited from ReflectionRepository.)
Public method | RegisterAssemblies(String) | Registers list of assemblies for code completion by assembly reference (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the assembly list. (Inherited from ReflectionRepository.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. Specifies technology platform (Inherited from ReflectionRepository.)
Public method | RegisterNamespace(String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the namespace list. (Inherited from NETRepository.)
Public method | RegisterObject | Adds specified object for code completion to the object list. (Inherited from NETRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the type list. (Inherited from ReflectionRepository.)
Public method | RestrictTypeMembers | Disables type members from being shown in code completion windows. (Inherited from ReflectionRepository.)
Public method | SmartFormatLine | Formats line according to the parser rules. (Inherited from NETRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the assembly list. (Inherited from ReflectionRepository.)
Public method | UnregisterNamespace | Removes specified namespace from the namespace list. (Inherited from NETRepository.)
Public method | UnregisterObject | Removes specified object from the object list. (Inherited from NETRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | UnregisterType | Removes specified type from the type list. (Inherited from ReflectionRepository.)
Top
See Also

Reference

VbScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbScriptRepository.GetExpressionType Method

VbScriptRepositoryGetExpressionType Method
Gets a type of expression.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetExpressionType(
    ISyntaxNode node,
    out Point typePos
)
Public Shared Function GetExpressionType (
    node As ISyntaxNode,
    <OutAttribute> ByRef typePos As Point
) As String
public:
static String^ GetExpressionType(
    ISyntaxNode^ node,
    [OutAttribute] Point% typePos
)
static member GetExpressionType :
        node : ISyntaxNode *
        typePos : Point byref -> string

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Expression node to check.
typePos
Type: System.DrawingPoint
Receives position of specified type.

Return Value

Type: String
string describing type of the expression
See Also

Reference

VbScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbScriptRepository.GetMethodType Method

VbScriptRepositoryGetMethodType Method
Obtains information about some method of specified language element.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object GetMethodType(
    string text,
    ISyntaxNode node,
    ref string name,
    ref Point position,
    ref Point endPos,
    out int paramIndex,
    out int paramCount,
    out CodeCompletionScope scope
)
Public Overrides Function GetMethodType (
    text As String,
    node As ISyntaxNode,
    ByRef name As String,
    ByRef position As Point,
    ByRef endPos As Point,
    <OutAttribute> ByRef paramIndex As Integer,
    <OutAttribute> ByRef paramCount As Integer,
    <OutAttribute> ByRef scope As CodeCompletionScope
) As Object
public:
virtual Object^ GetMethodType(
    String^ text,
    ISyntaxNode^ node,
    String^% name,
    Point% position,
    Point% endPos,
    [OutAttribute] int% paramIndex,
    [OutAttribute] int% paramCount,
    [OutAttribute] CodeCompletionScope% scope
) override
abstract GetMethodType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        paramIndex : int byref *
        paramCount : int byref *
        scope : CodeCompletionScope byref -> Object
override GetMethodType :
        text : string *
        node : ISyntaxNode *
        name : string byref *
        position : Point byref *
        endPos : Point byref *
        paramIndex : int byref *
        paramCount : int byref *
        scope : CodeCompletionScope byref -> Object

Parameters

text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode representing current language element.
name
Type: SystemString
Retrieves name of found method.
position
Type: System.DrawingPoint
Retrieves start position of the method in the code text.
endPos
Type: System.DrawingPoint
Retrieves end position of the method in the code text.
paramIndex
Type: SystemInt32
Retrieves index of current parameter in the code text.
paramCount
Type: SystemInt32
Retrieves number of the parameters.
scope
Type: Alternet.SyntaxCodeCompletionScope
Retrieves information about search constraints for the language element.

Return Value

Type: Object
Object representing information about found method.

Implements

ICodeCompletionRepositoryGetMethodType(String, ISyntaxNode, String, Point, Point, Int32, Int32, CodeCompletionScope)
See Also

Reference

VbScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbScriptRepository Properties

VbScriptRepository Properties

The VbScriptRepository type exposes the following members.

Properties
 | Name | Description
Public property | AllowGlobalMembers | Gets or sets a boolean value indicating whether global members should be included into the code completion. (Inherited from NETRepository.)
Public property | Assemblies | Represents assembly list. (Inherited from ReflectionRepository.)
Public property | BaseClassType | Gets or sets name of the base type. (Inherited from NETRepository.)
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from NETRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from NETRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Namespaces | Represents namespace list. (Inherited from NETRepository.)
Public property | Objects | Represents object list in a form of key-value pairs. (Inherited from NETRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Types | Represents type list in a form of key-value pairs. (Inherited from ReflectionRepository.)
Top
See Also

Reference

VbScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


VbScriptRepository Events

VbScriptRepository Events

The VbScriptRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

VbScriptRepository Class
Alternet.Syntax.CodeCompletion Namespace


XmlCommentType Enumeration

XmlCommentType Enumeration
Defines types of xml comment elements.

Namespace: Alternet.Syntax.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum XmlCommentType
Public Enumeration XmlCommentType
public enum class XmlCommentType
type XmlCommentType
Members
Member name | Value | Description
C | 0 | Specifies "code" tag.
Para | 1 | Specifies "paragraph" tag.
See | 2 | Specifies "see" (link to another code element in the text) tag.
Code | 3 | Specifies "code" tag.
Param | 4 | Specifies "parameter" tag.
Seealso | 5 | Specifies "see also" (link to another element in the See Also section) tag.
Example | 6 | Specifies example tag.
Paramref | 7 | Specifies "parameter reference" tag.
Summary | 8 | Specifies "summary" tag.
Exception | 9 | Specifies "exception" tag.
Permission | 10 | Specifies "permission" tag.
Name | 11 | Specifies "name" tag.
Value | 12 | Specifies "value" tag.
Include | 13 | Specifies "include" tag.
Remarks | 14 | Specifies "remarks" tag.
List | 15 | Specifies "list" tag.
Returns | 16 | Specifies "returns" tag.
See Also

Reference

Alternet.Syntax.CodeCompletion Namespace


Alternet.Syntax.Lexer Namespace

Alternet.Syntax.Lexer Namespace
Classes
 | Class | Description
Public class | Lexer | Represents class that performs lexical analysis of the specified text.
Public class | LexReswordSet | Represents class to specify keywords for ILexSyntaxBlock.LexReswordSets collection.
Public class | LexReswordSets | Represents properties and methods to provide an indexed access to individual ILexReswordSet objects.
Public class | LexScheme | Represents class contains rules for text lexical analysis.
Public class | LexState | Represents an individual lexical state with collection of lexical states.
Public class | LexStates | Provides an indexed access to individual ILexState objects.
Public class | LexStyle | Represents an individual lexical style with the collection of lexical styles.
Public class | LexStyles | Provides an indexed access to individual ILexStyle objects.
Public class | LexSyntaxBlock | Represents an individual syntax block in the collection of syntax blocks.
Public class | LexSyntaxBlocks | Provides an indexed access to individual ILexSyntaxBlock objects.
Public class | ParseTextEventArgs | Provides data for the ILexer.TextParsed event.
Interfaces
 | Interface | Description
Public interface | ILexer | Represents properties and methods for performing lexical analysis of the specified text.
Public interface | ILexReswordSet | Represents properties and methods to specify keywords for ILexSyntaxBlock.LexReswordSets collection.
Public interface | ILexReswordSets | Represents properties and methods to provide an indexed access to individual ILexReswordSet objects.
Public interface | ILexScheme | When implemented by a class, represents properties and methods to specify rules for text lexical analysis.
Public interface | ILexState | Represents properties and methods for individual lexical state with collection of lexical states.
Public interface | ILexStates | Represents properties and methods to provide an indexed access to individual ILexState objects.
Public interface | ILexStyle | Represents properties and methods for individual lexical style with the collection of lexical styles.
Public interface | ILexStyles | Represents properties and methods to provide an indexed access to individual ILexStyle objects.
Public interface | ILexSyntaxBlock | Represents properties and methods for individual syntax block with collection of syntax blocks.
Public interface | ILexSyntaxBlocks | Represents properties and methods to provide an indexed access to individual ILexSyntaxBlock objects.
Delegates
 | Delegate | Description
Public delegate | LexerProc | Represents a method intended to perform lexical analysis.
Public delegate | ParseTextEvent | Represents a method that will handle the ILexer.Parse event.
Enumerations
 | Enumeration | Description
Public enumeration | LexToken | Defines types of lexical token that represents result lexical analysis of each element within the text.


ILexer Interface

ILexer Interface
Represents properties and methods for performing lexical analysis of the specified text.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexer : INotify, IUpdate
Public Interface ILexer
    Inherits INotify, IUpdate
public interface class ILexer : INotify,
    IUpdate
type ILexer =
    interface
        interface INotify
        interface IUpdate
    end

The ILexer type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexer object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | When implemented by a class, performs lexical analysis of given text.
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | When implemented by a class, performs lexical analysis of given text.
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | RemovePlainText | When implemented by a class, removes all plain (string constants or comments) parts of text from specified text.
Public method | ResetDefaultState | When implemented by a class, resets the DefaultState to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | DefaultState | When implemented by a class, gets or sets default state of the ILexer.
Public property | Scheme | When implemented by a class, gets or sets list of rules for lexical analysis.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of ILexer.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
Events
 | Name | Description
Public event | Parse | When implemented by a class, occurs when text line is parsed, allowing to modify colors/styles information for the parsed line.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexer Methods

ILexer Methods

The ILexer type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | When implemented by a class, adds new handler to respond a notification. (Inherited from INotify.)
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexer object.
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | Notify | When implemented by a class, notifies all notifiers about updating object state. (Inherited from INotify.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | When implemented by a class, performs lexical analysis of given text.
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | When implemented by a class, performs lexical analysis of given text.
Public method | RemoveNotifier | When implemented by a class, exclude specified handler from notification handlers list. (Inherited from INotify.)
Public method | RemovePlainText | When implemented by a class, removes all plain (string constants or comments) parts of text from specified text.
Public method | ResetDefaultState | When implemented by a class, resets the DefaultState to the default value.
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer.Assign Method

ILexerAssign Method
When implemented by a class, assigns most relevant properties from another ILexer object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ILexer source
)
Sub Assign (
    source As ILexer
)
void Assign(
    ILexer^ source
)
abstract Assign :
        source : ILexer -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexer
Specifies source object.
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer.ParseText Method

ILexerParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | When implemented by a class, performs lexical analysis of given text.
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | When implemented by a class, performs lexical analysis of given text.
Top
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer.ParseText Method (Int32, Int32, String, StringItemInfo[])

ILexerParseText Method (Int32, Int32, String, StringItemInfo)
When implemented by a class, performs lexical analysis of given text.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
)
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.
See Also

Reference

ILexer Interface
ParseText Overload
Alternet.Syntax.Lexer Namespace


ILexer.ParseText Method (Int32, Int32, String, Int32, Int32, Int32)

ILexerParseText Method (Int32, Int32, String, Int32, Int32, Int32)
When implemented by a class, performs lexical analysis of given text.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ParseText(
    int state,
    int line,
    string str,
    ref int pos,
    ref int len,
    ref int style
)
Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef pos As Integer,
    ByRef len As Integer,
    ByRef style As Integer
) As Integer
int ParseText(
    int state,
    int line,
    String^ str,
    int% pos,
    int% len,
    int% style
)
abstract ParseText :
        state : int *
        line : int *
        str : string *
        pos : int byref *
        len : int byref *
        style : int byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
pos
Type: SystemInt32
Starting position.
len
Type: SystemInt32
Integer value to receive length of parsed element.
style
Type: SystemInt32
Retrieves style of text being parsed.

Return Value

Type: Int32
Final lexical state.
See Also

Reference

ILexer Interface
ParseText Overload
Alternet.Syntax.Lexer Namespace


ILexer.RemovePlainText Method

ILexerRemovePlainText Method
When implemented by a class, removes all plain (string constants or comments) parts of text from specified text.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string RemovePlainText(
    string s,
    StringItemInfo[] textData
)
Function RemovePlainText (
    s As String,
    textData As StringItemInfo()
) As String
String^ RemovePlainText(
    String^ s,
    array<StringItemInfo>^ textData
)
abstract RemovePlainText :
        s : string *
        textData : StringItemInfo[] -> string

Parameters

s
Type: SystemString
Text to process.
textData
Type: Alternet.SyntaxStringItemInfo
Color information of given text.

Return Value

Type: String
String without plain parts.
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer.ResetDefaultState Method

ILexerResetDefaultState Method
When implemented by a class, resets the DefaultState to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetDefaultState()
Sub ResetDefaultState
void ResetDefaultState()
abstract ResetDefaultState : unit -> unit
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer Properties

ILexer Properties

The ILexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultState | When implemented by a class, gets or sets default state of the ILexer.
Public property | Scheme | When implemented by a class, gets or sets list of rules for lexical analysis.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of ILexer.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer.DefaultState Property

ILexerDefaultState Property
When implemented by a class, gets or sets default state of the ILexer.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int DefaultState { get; set; }
Property DefaultState As Integer
    Get
    Set
property int DefaultState {
    int get ();
    void set (int value);
}
abstract DefaultState : int with get, set

Property Value

Type: Int32
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer.Scheme Property

ILexerScheme Property
When implemented by a class, gets or sets list of rules for lexical analysis.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexScheme Scheme { get; set; }
Property Scheme As ILexScheme
    Get
    Set
property ILexScheme^ Scheme {
    ILexScheme^ get ();
    void set (ILexScheme^ value);
}
abstract Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer.SerializationInfo Property

ILexerSerializationInfo Property
When implemented by a class, gets or sets an xml representation of ILexer.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISerializationInfo SerializationInfo { get; set; }
Property SerializationInfo As ISerializationInfo
    Get
    Set
property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer Events

ILexer Events

The ILexer type exposes the following members.

Events
 | Name | Description
Public event | Parse | When implemented by a class, occurs when text line is parsed, allowing to modify colors/styles information for the parsed line.
Top
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexer.Parse Event

ILexerParse Event
When implemented by a class, occurs when text line is parsed, allowing to modify colors/styles information for the parsed line.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event ParseTextEvent Parse
Event Parse As ParseTextEvent
 event ParseTextEvent^ Parse {
    void add (ParseTextEvent^ value);
    void remove (ParseTextEvent^ value);
}
abstract Parse : IEvent<ParseTextEvent,
    ParseTextEventArgs>

Value

Type: Alternet.Syntax.LexerParseTextEvent
See Also

Reference

ILexer Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet Interface

ILexReswordSet Interface
Represents properties and methods to specify keywords for ILexSyntaxBlock.LexReswordSets collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexReswordSet
Public Interface ILexReswordSet
public interface class ILexReswordSet
type ILexReswordSet =  interface end

The ILexReswordSet type exposes the following members.

Methods
 | Name | Description
Public method | AddResword | When implemented by a class, adds a new element to the resword collection.
Public method | Clear | When implemented in a class, removes all items from Reswords collection.
Public method | FindResword | When implemented by a class, locates given resword in Reswords collection.
Top
Properties
 | Name | Description
Public property | Block | When implemented by a class, gets or sets ILexSyntaxBlock owning this ILexReswordSet.
Public property | CaseSensitive | When implemented by a class, gets or sets a value indicating whether ILexReswordSet is case-sensitive or not.
Public property | Index | When implemented by a class, represents index of the ILexReswordSet within the reswords collection.
Public property | Name | When implemented in a class, gets or set name for the ILexReswordSet.
Public property | Reswords | When implemented by a class, gets or sets a collection of keywords for the ILexReswordSet.
Public property | ReswordStyle | When implemented by a class, gets or sets an ILexStyle of resword collection.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexReswordSet object.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexReswordSet Methods

ILexReswordSet Methods

The ILexReswordSet type exposes the following members.

Methods
 | Name | Description
Public method | AddResword | When implemented by a class, adds a new element to the resword collection.
Public method | Clear | When implemented in a class, removes all items from Reswords collection.
Public method | FindResword | When implemented by a class, locates given resword in Reswords collection.
Top
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.AddResword Method

ILexReswordSetAddResword Method
When implemented by a class, adds a new element to the resword collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AddResword(
    string resword
)
Function AddResword (
    resword As String
) As Integer
int AddResword(
    String^ resword
)
abstract AddResword :
        resword : string -> int

Parameters

resword
Type: SystemString
Resword to add.

Return Value

Type: Int32
Index of added element in the resword collection.
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.Clear Method

ILexReswordSetClear Method
When implemented in a class, removes all items from Reswords collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.FindResword Method

ILexReswordSetFindResword Method
When implemented by a class, locates given resword in Reswords collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool FindResword(
    string resword
)
Function FindResword (
    resword As String
) As Boolean
bool FindResword(
    String^ resword
)
abstract FindResword :
        resword : string -> bool

Parameters

resword
Type: SystemString
Resword to locate.

Return Value

Type: Boolean
True if resword presents in the Reswords collection; otherwise false.
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet Properties

ILexReswordSet Properties

The ILexReswordSet type exposes the following members.

Properties
 | Name | Description
Public property | Block | When implemented by a class, gets or sets ILexSyntaxBlock owning this ILexReswordSet.
Public property | CaseSensitive | When implemented by a class, gets or sets a value indicating whether ILexReswordSet is case-sensitive or not.
Public property | Index | When implemented by a class, represents index of the ILexReswordSet within the reswords collection.
Public property | Name | When implemented in a class, gets or set name for the ILexReswordSet.
Public property | Reswords | When implemented by a class, gets or sets a collection of keywords for the ILexReswordSet.
Public property | ReswordStyle | When implemented by a class, gets or sets an ILexStyle of resword collection.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexReswordSet object.
Top
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.Block Property

ILexReswordSetBlock Property
When implemented by a class, gets or sets ILexSyntaxBlock owning this ILexReswordSet.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexSyntaxBlock Block { get; set; }
Property Block As ILexSyntaxBlock
    Get
    Set
property ILexSyntaxBlock^ Block {
    ILexSyntaxBlock^ get ();
    void set (ILexSyntaxBlock^ value);
}
abstract Block : ILexSyntaxBlock with get, set

Property Value

Type: ILexSyntaxBlock
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.CaseSensitive Property

ILexReswordSetCaseSensitive Property
When implemented by a class, gets or sets a value indicating whether ILexReswordSet is case-sensitive or not.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CaseSensitive { get; set; }
Property CaseSensitive As Boolean
    Get
    Set
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
abstract CaseSensitive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.Index Property

ILexReswordSetIndex Property
When implemented by a class, represents index of the ILexReswordSet within the reswords collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.Name Property

ILexReswordSetName Property
When implemented in a class, gets or set name for the ILexReswordSet.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.Reswords Property

ILexReswordSetReswords Property
When implemented by a class, gets or sets a collection of keywords for the ILexReswordSet.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> Reswords { get; set; }
Property Reswords As IList(Of String)
    Get
    Set
property IList<String^>^ Reswords {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
abstract Reswords : IList<string> with get, set

Property Value

Type: IListString
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.ReswordStyle Property

ILexReswordSetReswordStyle Property
When implemented by a class, gets or sets an ILexStyle of resword collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStyle ReswordStyle { get; set; }
Property ReswordStyle As ILexStyle
    Get
    Set
property ILexStyle^ ReswordStyle {
    ILexStyle^ get ();
    void set (ILexStyle^ value);
}
abstract ReswordStyle : ILexStyle with get, set

Property Value

Type: ILexStyle
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSet.SerializationInfo Property

ILexReswordSetSerializationInfo Property
Gets or sets an xml representation of this ILexReswordSet object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISerializationInfo SerializationInfo { get; set; }
Property SerializationInfo As ISerializationInfo
    Get
    Set
property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

ILexReswordSet Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSets Interface

ILexReswordSets Interface
Represents properties and methods to provide an indexed access to individual ILexReswordSet objects.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexReswordSets : IList<ILexReswordSet>,
    ICollection<ILexReswordSet>, IEnumerable<ILexReswordSet>, IEnumerable
Public Interface ILexReswordSets
    Inherits IList(Of ILexReswordSet), ICollection(Of ILexReswordSet),
    IEnumerable(Of ILexReswordSet), IEnumerable
public interface class ILexReswordSets : IList<ILexReswordSet^>,
    ICollection<ILexReswordSet^>, IEnumerable<ILexReswordSet^>, IEnumerable
type ILexReswordSets =
    interface
        interface IList<ILexReswordSet>
        interface ICollection<ILexReswordSet>
        interface IEnumerable<ILexReswordSet>
        interface IEnumerable
    end

The ILexReswordSets type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILexReswordSet .)
Public method | AddLexReswordSet | When implemented by a class, adds a new item to the specified position within the ILexReswordSets collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILexReswordSet .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILexReswordSet .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILexReswordSet .)
Public method | FindResword | When implemented by a class, locates ILexReswordSet containing given resword.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILexReswordSet .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILexReswordSet .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILexReswordSet .)
Public method | InsertLexReswordSet | When implemented by a class, inserts a new item to the specified position within the ILexReswordSets collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILexReswordSet .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILexReswordSet .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexReswordSet | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexReswordSet | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexReswordSet, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILexReswordSet .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILexReswordSet .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILexReswordSet .)
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexReswordSets Methods

ILexReswordSets Methods

The ILexReswordSets type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILexReswordSet .)
Public method | AddLexReswordSet | When implemented by a class, adds a new item to the specified position within the ILexReswordSets collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILexReswordSet .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILexReswordSet .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILexReswordSet .)
Public method | FindResword | When implemented by a class, locates ILexReswordSet containing given resword.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILexReswordSet .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILexReswordSet .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILexReswordSet .)
Public method | InsertLexReswordSet | When implemented by a class, inserts a new item to the specified position within the ILexReswordSets collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILexReswordSet .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILexReswordSet .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexReswordSet | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexReswordSet | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexReswordSet, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ILexReswordSets Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSets.AddLexReswordSet Method

ILexReswordSetsAddLexReswordSet Method
When implemented by a class, adds a new item to the specified position within the ILexReswordSets collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexReswordSet AddLexReswordSet()
Function AddLexReswordSet As ILexReswordSet
ILexReswordSet^ AddLexReswordSet()
abstract AddLexReswordSet : unit -> ILexReswordSet

Return Value

Type: ILexReswordSet
ILexReswordSet that is added.
See Also

Reference

ILexReswordSets Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSets.FindResword Method

ILexReswordSetsFindResword Method
When implemented by a class, locates ILexReswordSet containing given resword.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FindResword(
    string resword
)
Function FindResword (
    resword As String
) As Integer
int FindResword(
    String^ resword
)
abstract FindResword :
        resword : string -> int

Parameters

resword
Type: SystemString
The resword to search for.

Return Value

Type: Int32
Index of ILexReswordSet if resword collection contains specified resword; otherwise - 1.
See Also

Reference

ILexReswordSets Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSets.InsertLexReswordSet Method

ILexReswordSetsInsertLexReswordSet Method
When implemented by a class, inserts a new item to the specified position within the ILexReswordSets collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexReswordSet InsertLexReswordSet(
    int index
)
Function InsertLexReswordSet (
    index As Integer
) As ILexReswordSet
ILexReswordSet^ InsertLexReswordSet(
    int index
)
abstract InsertLexReswordSet :
        index : int -> ILexReswordSet

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ILexReswordSet
ILexReswordSet that is inserted.
See Also

Reference

ILexReswordSets Interface
Alternet.Syntax.Lexer Namespace


ILexReswordSets Properties

ILexReswordSets Properties

The ILexReswordSets type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILexReswordSet .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILexReswordSet .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILexReswordSet .)
Top
See Also

Reference

ILexReswordSets Interface
Alternet.Syntax.Lexer Namespace


ILexScheme Interface

ILexScheme Interface
When implemented by a class, represents properties and methods to specify rules for text lexical analysis.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexScheme : IImport,
    IExport
Public Interface ILexScheme
    Inherits IImport, IExport
public interface class ILexScheme : IImport,
    IExport
type ILexScheme =
    interface
        interface IImport
        interface IExport
    end

The ILexScheme type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexScheme object.
Public method | Clear | When implemented by a class, removes all states and styles from this LexScheme and sets other properties to default values.
Public method | IsEmpty | When implemented by a class, indicates whether ILexScheme is empty , that is does not contain any styles, states, author, copyright, and description information.
Public method | IsPlainText | When implemented by a class, indicates whether PlainText property of lexical style given by its index is true.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Update | When implemented by a class, causes associated ILexer to update its state.
Top
Properties
 | Name | Description
Public property | Author | When implemented by a class, gets or sets author of the ILexScheme.
Public property | Copyright | When implemented by a class, gets or sets copyright of the ILexScheme.
Public property | Desc | When implemented by a class, gets or sets description of the ILexScheme.
Public property | FileExtension | When implemented by a class, gets or sets string value indicating associated file extension of the ILexScheme.
Public property | FileType | When implemented by a class, gets or sets string value indicating associated file type of the ILexScheme.
Public property | Name | When implemented by a class, gets or sets ILexScheme name.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexScheme object.
Public property | States | When implemented by a class, gets or sets collection of lexical states.
Public property | Styles | When implemented by a class, gets or sets collection of lexical styles.
Public property | Version | When implemented by a class, gets or sets version of the ILexScheme.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexScheme Methods

ILexScheme Methods

The ILexScheme type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexScheme object.
Public method | Clear | When implemented by a class, removes all states and styles from this LexScheme and sets other properties to default values.
Public method | IsEmpty | When implemented by a class, indicates whether ILexScheme is empty , that is does not contain any styles, states, author, copyright, and description information.
Public method | IsPlainText | When implemented by a class, indicates whether PlainText property of lexical style given by its index is true.
Public method | LoadFile(String) | When implemented by a class, loads the contents of the specified file. (Inherited from IImport.)
Public method | LoadFile(String, Encoding) | When implemented by a class, loads the contents of the specified file with specified encoding. (Inherited from IImport.)
Public method | LoadStream(Stream) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(TextReader) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | LoadStream(Stream, Encoding) | When implemented by a class, loads the contents of the specified stream. (Inherited from IImport.)
Public method | SaveFile(String) | When implemented by a class, saves text content to the specific file. (Inherited from IExport.)
Public method | SaveFile(String, Encoding) | When implemented by a class, saves text content to the specific file with specific encoding. (Inherited from IExport.)
Public method | SaveStream(Stream) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(TextWriter) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | SaveStream(Stream, Encoding) | When implemented by a class, saves the text content to the specified stream. (Inherited from IExport.)
Public method | Update | When implemented by a class, causes associated ILexer to update its state.
Top
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.Assign Method

ILexSchemeAssign Method
When implemented by a class, assigns most relevant properties from another ILexScheme object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ILexScheme source
)
Sub Assign (
    source As ILexScheme
)
void Assign(
    ILexScheme^ source
)
abstract Assign :
        source : ILexScheme -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexScheme
Specifies source object.
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.Clear Method

ILexSchemeClear Method
When implemented by a class, removes all states and styles from this LexScheme and sets other properties to default values.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.IsEmpty Method

ILexSchemeIsEmpty Method
When implemented by a class, indicates whether ILexScheme is empty , that is does not contain any styles, states, author, copyright, and description information.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsEmpty()
Function IsEmpty As Boolean
bool IsEmpty()
abstract IsEmpty : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.IsPlainText Method

ILexSchemeIsPlainText Method
When implemented by a class, indicates whether PlainText property of lexical style given by its index is true.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPlainText(
    int style
)
Function IsPlainText (
    style As Integer
) As Boolean
bool IsPlainText(
    int style
)
abstract IsPlainText :
        style : int -> bool

Parameters

style
Type: SystemInt32
Index of lexical style to check-up.

Return Value

Type: Boolean
True if lexical style PlainText property is true; otherwise false.
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.Update Method

ILexSchemeUpdate Method
When implemented by a class, causes associated ILexer to update its state.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Update()
Sub Update
void Update()
abstract Update : unit -> unit
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme Properties

ILexScheme Properties

The ILexScheme type exposes the following members.

Properties
 | Name | Description
Public property | Author | When implemented by a class, gets or sets author of the ILexScheme.
Public property | Copyright | When implemented by a class, gets or sets copyright of the ILexScheme.
Public property | Desc | When implemented by a class, gets or sets description of the ILexScheme.
Public property | FileExtension | When implemented by a class, gets or sets string value indicating associated file extension of the ILexScheme.
Public property | FileType | When implemented by a class, gets or sets string value indicating associated file type of the ILexScheme.
Public property | Name | When implemented by a class, gets or sets ILexScheme name.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexScheme object.
Public property | States | When implemented by a class, gets or sets collection of lexical states.
Public property | Styles | When implemented by a class, gets or sets collection of lexical styles.
Public property | Version | When implemented by a class, gets or sets version of the ILexScheme.
Top
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.Author Property

ILexSchemeAuthor Property
When implemented by a class, gets or sets author of the ILexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Author { get; set; }
Property Author As String
    Get
    Set
property String^ Author {
    String^ get ();
    void set (String^ value);
}
abstract Author : string with get, set

Property Value

Type: String
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.Copyright Property

ILexSchemeCopyright Property
When implemented by a class, gets or sets copyright of the ILexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Copyright { get; set; }
Property Copyright As String
    Get
    Set
property String^ Copyright {
    String^ get ();
    void set (String^ value);
}
abstract Copyright : string with get, set

Property Value

Type: String
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.Desc Property

ILexSchemeDesc Property
When implemented by a class, gets or sets description of the ILexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Desc { get; set; }
Property Desc As String
    Get
    Set
property String^ Desc {
    String^ get ();
    void set (String^ value);
}
abstract Desc : string with get, set

Property Value

Type: String
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.FileExtension Property

ILexSchemeFileExtension Property
When implemented by a class, gets or sets string value indicating associated file extension of the ILexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileExtension { get; set; }
Property FileExtension As String
    Get
    Set
property String^ FileExtension {
    String^ get ();
    void set (String^ value);
}
abstract FileExtension : string with get, set

Property Value

Type: String
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.FileType Property

ILexSchemeFileType Property
When implemented by a class, gets or sets string value indicating associated file type of the ILexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileType { get; set; }
Property FileType As String
    Get
    Set
property String^ FileType {
    String^ get ();
    void set (String^ value);
}
abstract FileType : string with get, set

Property Value

Type: String
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.Name Property

ILexSchemeName Property
When implemented by a class, gets or sets ILexScheme name.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.SerializationInfo Property

ILexSchemeSerializationInfo Property
Gets or sets an xml representation of this ILexScheme object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISerializationInfo SerializationInfo { get; set; }
Property SerializationInfo As ISerializationInfo
    Get
    Set
property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.States Property

ILexSchemeStates Property
When implemented by a class, gets or sets collection of lexical states.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStates States { get; set; }
Property States As ILexStates
    Get
    Set
property ILexStates^ States {
    ILexStates^ get ();
    void set (ILexStates^ value);
}
abstract States : ILexStates with get, set

Property Value

Type: ILexStates
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.Styles Property

ILexSchemeStyles Property
When implemented by a class, gets or sets collection of lexical styles.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStyles Styles { get; set; }
Property Styles As ILexStyles
    Get
    Set
property ILexStyles^ Styles {
    ILexStyles^ get ();
    void set (ILexStyles^ value);
}
abstract Styles : ILexStyles with get, set

Property Value

Type: ILexStyles
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexScheme.Version Property

ILexSchemeVersion Property
When implemented by a class, gets or sets version of the ILexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Version { get; set; }
Property Version As String
    Get
    Set
property String^ Version {
    String^ get ();
    void set (String^ value);
}
abstract Version : string with get, set

Property Value

Type: String
See Also

Reference

ILexScheme Interface
Alternet.Syntax.Lexer Namespace


ILexState Interface

ILexState Interface
Represents properties and methods for individual lexical state with collection of lexical states.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexState
Public Interface ILexState
public interface class ILexState
type ILexState =  interface end

The ILexState type exposes the following members.

Methods
 | Name | Description
Public method | ResetCaseSensitive | When implemented by a class, resets the CaseSensitive to the default value.
Top
Properties
 | Name | Description
Public property | Blocks | When implemented by a class, represents collection of Syntax Blocks associated with this ILexState.
Public property | CaseSensitive | When implemented by a class, gets or sets a value indicating whether the analyzer should perform case sensitive parsing for this ILexState.
Public property | Desc | When implemented by a class, gets or sets description of the ILexState.
Public property | Expression | When implemented by a class, represents a collective regular expression pattern for the ILexState.
Public property | Index | When implemented by a class, represents index of the ILexState within the lexical state collection.
Public property | Name | When implemented by a class, gets or sets name of the ILexState.
Public property | Regex | When implemented by a class, represents a regular expression that contains Expression as a pattern.
Public property | Scheme | When implemented by a class, gets or sets ILexScheme that owns this ILexState.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexState object.
Public property | SyntaxBlocks | When implemented by a class, gets or sets a collection of lexical syntax blocks.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexState Methods

ILexState Methods

The ILexState type exposes the following members.

Methods
 | Name | Description
Public method | ResetCaseSensitive | When implemented by a class, resets the CaseSensitive to the default value.
Top
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.ResetCaseSensitive Method

ILexStateResetCaseSensitive Method
When implemented by a class, resets the CaseSensitive to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetCaseSensitive()
Sub ResetCaseSensitive
void ResetCaseSensitive()
abstract ResetCaseSensitive : unit -> unit
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState Properties

ILexState Properties

The ILexState type exposes the following members.

Properties
 | Name | Description
Public property | Blocks | When implemented by a class, represents collection of Syntax Blocks associated with this ILexState.
Public property | CaseSensitive | When implemented by a class, gets or sets a value indicating whether the analyzer should perform case sensitive parsing for this ILexState.
Public property | Desc | When implemented by a class, gets or sets description of the ILexState.
Public property | Expression | When implemented by a class, represents a collective regular expression pattern for the ILexState.
Public property | Index | When implemented by a class, represents index of the ILexState within the lexical state collection.
Public property | Name | When implemented by a class, gets or sets name of the ILexState.
Public property | Regex | When implemented by a class, represents a regular expression that contains Expression as a pattern.
Public property | Scheme | When implemented by a class, gets or sets ILexScheme that owns this ILexState.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexState object.
Public property | SyntaxBlocks | When implemented by a class, gets or sets a collection of lexical syntax blocks.
Top
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.Blocks Property

ILexStateBlocks Property
When implemented by a class, represents collection of Syntax Blocks associated with this ILexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Dictionary<int, ILexSyntaxBlock> Blocks { get; }
ReadOnly Property Blocks As Dictionary(Of Integer, ILexSyntaxBlock)
    Get
property Dictionary<int, ILexSyntaxBlock^>^ Blocks {
    Dictionary<int, ILexSyntaxBlock^>^ get ();
}
abstract Blocks : Dictionary<int, ILexSyntaxBlock> with get

Property Value

Type: DictionaryInt32, ILexSyntaxBlock
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.CaseSensitive Property

ILexStateCaseSensitive Property
When implemented by a class, gets or sets a value indicating whether the analyzer should perform case sensitive parsing for this ILexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CaseSensitive { get; set; }
Property CaseSensitive As Boolean
    Get
    Set
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
abstract CaseSensitive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.Desc Property

ILexStateDesc Property
When implemented by a class, gets or sets description of the ILexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Desc { get; set; }
Property Desc As String
    Get
    Set
property String^ Desc {
    String^ get ();
    void set (String^ value);
}
abstract Desc : string with get, set

Property Value

Type: String
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.Expression Property

ILexStateExpression Property
When implemented by a class, represents a collective regular expression pattern for the ILexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Expression { get; }
ReadOnly Property Expression As String
    Get
property String^ Expression {
    String^ get ();
}
abstract Expression : string with get

Property Value

Type: String
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.Index Property

ILexStateIndex Property
When implemented by a class, represents index of the ILexState within the lexical state collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.Name Property

ILexStateName Property
When implemented by a class, gets or sets name of the ILexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.Regex Property

ILexStateRegex Property
When implemented by a class, represents a regular expression that contains Expression as a pattern.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Regex Regex { get; }
ReadOnly Property Regex As Regex
    Get
property Regex^ Regex {
    Regex^ get ();
}
abstract Regex : Regex with get

Property Value

Type: Regex
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.Scheme Property

ILexStateScheme Property
When implemented by a class, gets or sets ILexScheme that owns this ILexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexScheme Scheme { get; set; }
Property Scheme As ILexScheme
    Get
    Set
property ILexScheme^ Scheme {
    ILexScheme^ get ();
    void set (ILexScheme^ value);
}
abstract Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.SerializationInfo Property

ILexStateSerializationInfo Property
Gets or sets an xml representation of this ILexState object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISerializationInfo SerializationInfo { get; set; }
Property SerializationInfo As ISerializationInfo
    Get
    Set
property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexState.SyntaxBlocks Property

ILexStateSyntaxBlocks Property
When implemented by a class, gets or sets a collection of lexical syntax blocks.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexSyntaxBlocks SyntaxBlocks { get; set; }
Property SyntaxBlocks As ILexSyntaxBlocks
    Get
    Set
property ILexSyntaxBlocks^ SyntaxBlocks {
    ILexSyntaxBlocks^ get ();
    void set (ILexSyntaxBlocks^ value);
}
abstract SyntaxBlocks : ILexSyntaxBlocks with get, set

Property Value

Type: ILexSyntaxBlocks
See Also

Reference

ILexState Interface
Alternet.Syntax.Lexer Namespace


ILexStates Interface

ILexStates Interface
Represents properties and methods to provide an indexed access to individual ILexState objects.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexStates : IList<ILexState>,
    ICollection<ILexState>, IEnumerable<ILexState>, IEnumerable
Public Interface ILexStates
    Inherits IList(Of ILexState), ICollection(Of ILexState),
    IEnumerable(Of ILexState), IEnumerable
public interface class ILexStates : IList<ILexState^>,
    ICollection<ILexState^>, IEnumerable<ILexState^>, IEnumerable
type ILexStates =
    interface
        interface IList<ILexState>
        interface ICollection<ILexState>
        interface IEnumerable<ILexState>
        interface IEnumerable
    end

The ILexStates type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILexState .)
Public method | AddLexState | When implemented by a class, adds a new item to the specified position within the ILexStates collection.
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexStates object.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILexState .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILexState .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILexState .)
Public method | FindLexState | When implemented by a class, finds ILexState by its name.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILexState .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILexState .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILexState .)
Public method | InsertLexState | When implemented by a class, inserts a new item to the specified position within the ILexStates collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILexState .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILexState .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexState | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexState | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexState, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILexState .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILexState .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILexState .)
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexStates Methods

ILexStates Methods

The ILexStates type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILexState .)
Public method | AddLexState | When implemented by a class, adds a new item to the specified position within the ILexStates collection.
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexStates object.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILexState .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILexState .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILexState .)
Public method | FindLexState | When implemented by a class, finds ILexState by its name.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILexState .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILexState .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILexState .)
Public method | InsertLexState | When implemented by a class, inserts a new item to the specified position within the ILexStates collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILexState .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILexState .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexState | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexState | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexState, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ILexStates Interface
Alternet.Syntax.Lexer Namespace


ILexStates.AddLexState Method

ILexStatesAddLexState Method
When implemented by a class, adds a new item to the specified position within the ILexStates collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexState AddLexState()
Function AddLexState As ILexState
ILexState^ AddLexState()
abstract AddLexState : unit -> ILexState

Return Value

Type: ILexState
ILexState that is added.
See Also

Reference

ILexStates Interface
Alternet.Syntax.Lexer Namespace


ILexStates.Assign Method

ILexStatesAssign Method
When implemented by a class, assigns most relevant properties from another ILexStates object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ILexStates source
)
Sub Assign (
    source As ILexStates
)
void Assign(
    ILexStates^ source
)
abstract Assign :
        source : ILexStates -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexStates
Specifies source object.
See Also

Reference

ILexStates Interface
Alternet.Syntax.Lexer Namespace


ILexStates.FindLexState Method

ILexStatesFindLexState Method
When implemented by a class, finds ILexState by its name.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexState FindLexState(
    string name
)
Function FindLexState (
    name As String
) As ILexState
ILexState^ FindLexState(
    String^ name
)
abstract FindLexState :
        name : string -> ILexState

Parameters

name
Type: SystemString
Name of the ILexState.

Return Value

Type: ILexState
ILexState that is found.
See Also

Reference

ILexStates Interface
Alternet.Syntax.Lexer Namespace


ILexStates.InsertLexState Method

ILexStatesInsertLexState Method
When implemented by a class, inserts a new item to the specified position within the ILexStates collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexState InsertLexState(
    int index
)
Function InsertLexState (
    index As Integer
) As ILexState
ILexState^ InsertLexState(
    int index
)
abstract InsertLexState :
        index : int -> ILexState

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ILexState
ILexState that is inserted.
See Also

Reference

ILexStates Interface
Alternet.Syntax.Lexer Namespace


ILexStates Properties

ILexStates Properties

The ILexStates type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILexState .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILexState .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILexState .)
Top
See Also

Reference

ILexStates Interface
Alternet.Syntax.Lexer Namespace


ILexStyle Interface

ILexStyle Interface
Represents properties and methods for individual lexical style with the collection of lexical styles.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexStyle
Public Interface ILexStyle
public interface class ILexStyle
type ILexStyle =  interface end

The ILexStyle type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another ILexStyle object.
Public method | ResetBackColor | When implemented by a class, resets the BackColor to the default value.
Public method | ResetFontStyle | When implemented by a class, resets the FontStyle to the default value.
Public method | ResetForeColor | When implemented by a class, resets the ForeColor to the default value.
Public method | ResetPlainText | When implemented by a class, resets the PlainText to the default value.
Top
Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets a background color of the ILexStyle.
Public property | BackColorEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the BackColor property should be enabled or disabled.
Public property | BoldEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the Bold property should be enabled or disabled.
Public property | Desc | When implemented by a class, gets or sets a description of the ILexStyle.
Public property | FontStyle | When implemented by a class, gets or sets a font style of the ILexStyle.
Public property | ForeColor | When implemented by a class, gets or sets a foreground color of the ILexStyle.
Public property | ForeColorEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the ForeColor property should be enabled or disabled.
Public property | Index | When implemented by a class, represents index of the ILexStyle within the lexical style collection.
Public property | ItalicEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the Italic property should be enabled or disabled.
Public property | Name | When implemented by a class, gets or sets name of the ILexStyle.
Public property | PlainText | When implemented by a class, gets or sets value indicating whether Edit control should use text formatting rules, like checking spelling.
Public property | Scheme | When implemented by a class, gets or sets ILexScheme that owns this ILexStyle.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexStyle object.
Public property | UnderlineEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the Underline property should be enabled or disabled.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexStyle Methods

ILexStyle Methods

The ILexStyle type exposes the following members.

Methods
 | Name | Description
Public method | Assign | When implemented by a class, copies the contents of another ILexStyle object.
Public method | ResetBackColor | When implemented by a class, resets the BackColor to the default value.
Public method | ResetFontStyle | When implemented by a class, resets the FontStyle to the default value.
Public method | ResetForeColor | When implemented by a class, resets the ForeColor to the default value.
Public method | ResetPlainText | When implemented by a class, resets the PlainText to the default value.
Top
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.Assign Method

ILexStyleAssign Method
When implemented by a class, copies the contents of another ILexStyle object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ILexStyle source
)
Sub Assign (
    source As ILexStyle
)
void Assign(
    ILexStyle^ source
)
abstract Assign :
        source : ILexStyle -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexStyle
Specifies ILexStyle to assign.
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.ResetBackColor Method

ILexStyleResetBackColor Method
When implemented by a class, resets the BackColor to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetBackColor()
Sub ResetBackColor
void ResetBackColor()
abstract ResetBackColor : unit -> unit
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.ResetFontStyle Method

ILexStyleResetFontStyle Method
When implemented by a class, resets the FontStyle to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetFontStyle()
Sub ResetFontStyle
void ResetFontStyle()
abstract ResetFontStyle : unit -> unit
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.ResetForeColor Method

ILexStyleResetForeColor Method
When implemented by a class, resets the ForeColor to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetForeColor()
Sub ResetForeColor
void ResetForeColor()
abstract ResetForeColor : unit -> unit
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.ResetPlainText Method

ILexStyleResetPlainText Method
When implemented by a class, resets the PlainText to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ResetPlainText()
Sub ResetPlainText
void ResetPlainText()
abstract ResetPlainText : unit -> unit
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle Properties

ILexStyle Properties

The ILexStyle type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | When implemented by a class, gets or sets a background color of the ILexStyle.
Public property | BackColorEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the BackColor property should be enabled or disabled.
Public property | BoldEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the Bold property should be enabled or disabled.
Public property | Desc | When implemented by a class, gets or sets a description of the ILexStyle.
Public property | FontStyle | When implemented by a class, gets or sets a font style of the ILexStyle.
Public property | ForeColor | When implemented by a class, gets or sets a foreground color of the ILexStyle.
Public property | ForeColorEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the ForeColor property should be enabled or disabled.
Public property | Index | When implemented by a class, represents index of the ILexStyle within the lexical style collection.
Public property | ItalicEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the Italic property should be enabled or disabled.
Public property | Name | When implemented by a class, gets or sets name of the ILexStyle.
Public property | PlainText | When implemented by a class, gets or sets value indicating whether Edit control should use text formatting rules, like checking spelling.
Public property | Scheme | When implemented by a class, gets or sets ILexScheme that owns this ILexStyle.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexStyle object.
Public property | UnderlineEnabled | When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the Underline property should be enabled or disabled.
Top
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.BackColor Property

ILexStyleBackColor Property
When implemented by a class, gets or sets a background color of the ILexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; set; }
Property BackColor As Color
    Get
    Set
property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.BackColorEnabled Property

ILexStyleBackColorEnabled Property
When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the BackColor property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BackColorEnabled { get; set; }
Property BackColorEnabled As Boolean
    Get
    Set
property bool BackColorEnabled {
    bool get ();
    void set (bool value);
}
abstract BackColorEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.BoldEnabled Property

ILexStyleBoldEnabled Property
When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the Bold property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool BoldEnabled { get; set; }
Property BoldEnabled As Boolean
    Get
    Set
property bool BoldEnabled {
    bool get ();
    void set (bool value);
}
abstract BoldEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.Desc Property

ILexStyleDesc Property
When implemented by a class, gets or sets a description of the ILexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Desc { get; set; }
Property Desc As String
    Get
    Set
property String^ Desc {
    String^ get ();
    void set (String^ value);
}
abstract Desc : string with get, set

Property Value

Type: String
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.FontStyle Property

ILexStyleFontStyle Property
When implemented by a class, gets or sets a font style of the ILexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
FontStyle FontStyle { get; set; }
Property FontStyle As FontStyle
    Get
    Set
property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract FontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.ForeColor Property

ILexStyleForeColor Property
When implemented by a class, gets or sets a foreground color of the ILexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; set; }
Property ForeColor As Color
    Get
    Set
property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.ForeColorEnabled Property

ILexStyleForeColorEnabled Property
When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the ForeColor property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ForeColorEnabled { get; set; }
Property ForeColorEnabled As Boolean
    Get
    Set
property bool ForeColorEnabled {
    bool get ();
    void set (bool value);
}
abstract ForeColorEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.Index Property

ILexStyleIndex Property
When implemented by a class, represents index of the ILexStyle within the lexical style collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.ItalicEnabled Property

ILexStyleItalicEnabled Property
When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the Italic property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ItalicEnabled { get; set; }
Property ItalicEnabled As Boolean
    Get
    Set
property bool ItalicEnabled {
    bool get ();
    void set (bool value);
}
abstract ItalicEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.Name Property

ILexStyleName Property
When implemented by a class, gets or sets name of the ILexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.PlainText Property

ILexStylePlainText Property
When implemented by a class, gets or sets value indicating whether Edit control should use text formatting rules, like checking spelling.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool PlainText { get; set; }
Property PlainText As Boolean
    Get
    Set
property bool PlainText {
    bool get ();
    void set (bool value);
}
abstract PlainText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.Scheme Property

ILexStyleScheme Property
When implemented by a class, gets or sets ILexScheme that owns this ILexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexScheme Scheme { get; set; }
Property Scheme As ILexScheme
    Get
    Set
property ILexScheme^ Scheme {
    ILexScheme^ get ();
    void set (ILexScheme^ value);
}
abstract Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.SerializationInfo Property

ILexStyleSerializationInfo Property
Gets or sets an xml representation of this ILexStyle object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISerializationInfo SerializationInfo { get; set; }
Property SerializationInfo As ISerializationInfo
    Get
    Set
property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyle.UnderlineEnabled Property

ILexStyleUnderlineEnabled Property
When implemented by a class, gets or sets a flag that indicates whether the GUI control that corresponds to the Underline property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnderlineEnabled { get; set; }
Property UnderlineEnabled As Boolean
    Get
    Set
property bool UnderlineEnabled {
    bool get ();
    void set (bool value);
}
abstract UnderlineEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ILexStyle Interface
Alternet.Syntax.Lexer Namespace


ILexStyles Interface

ILexStyles Interface
Represents properties and methods to provide an indexed access to individual ILexStyle objects.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexStyles : IList<ILexStyle>,
    ICollection<ILexStyle>, IEnumerable<ILexStyle>, IEnumerable
Public Interface ILexStyles
    Inherits IList(Of ILexStyle), ICollection(Of ILexStyle),
    IEnumerable(Of ILexStyle), IEnumerable
public interface class ILexStyles : IList<ILexStyle^>,
    ICollection<ILexStyle^>, IEnumerable<ILexStyle^>, IEnumerable
type ILexStyles =
    interface
        interface IList<ILexStyle>
        interface ICollection<ILexStyle>
        interface IEnumerable<ILexStyle>
        interface IEnumerable
    end

The ILexStyles type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILexStyle .)
Public method | AddLexStyle | When implemented by a class, adds a new item to the specified position within the ILexStyles collection.
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexStyles object.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILexStyle .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILexStyle .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILexStyle .)
Public method | FindLexStyle | When implemented by a class, finds ILexStyle by its name.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILexStyle .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILexStyle .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILexStyle .)
Public method | InsertLexStyle | When implemented by a class, inserts a new item to the specified position within the ILexStyles collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILexStyle .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILexStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILexStyle .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILexStyle .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILexStyle .)
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexStyles Methods

ILexStyles Methods

The ILexStyles type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILexStyle .)
Public method | AddLexStyle | When implemented by a class, adds a new item to the specified position within the ILexStyles collection.
Public method | Assign | When implemented by a class, assigns most relevant properties from another ILexStyles object.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILexStyle .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILexStyle .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILexStyle .)
Public method | FindLexStyle | When implemented by a class, finds ILexStyle by its name.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILexStyle .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILexStyle .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILexStyle .)
Public method | InsertLexStyle | When implemented by a class, inserts a new item to the specified position within the ILexStyles collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILexStyle .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILexStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ILexStyles Interface
Alternet.Syntax.Lexer Namespace


ILexStyles.AddLexStyle Method

ILexStylesAddLexStyle Method
When implemented by a class, adds a new item to the specified position within the ILexStyles collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStyle AddLexStyle()
Function AddLexStyle As ILexStyle
ILexStyle^ AddLexStyle()
abstract AddLexStyle : unit -> ILexStyle

Return Value

Type: ILexStyle
ILexStyle that is added.
See Also

Reference

ILexStyles Interface
Alternet.Syntax.Lexer Namespace


ILexStyles.Assign Method

ILexStylesAssign Method
When implemented by a class, assigns most relevant properties from another ILexStyles object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Assign(
    ILexStyles source
)
Sub Assign (
    source As ILexStyles
)
void Assign(
    ILexStyles^ source
)
abstract Assign :
        source : ILexStyles -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexStyles
Specifies source object.
See Also

Reference

ILexStyles Interface
Alternet.Syntax.Lexer Namespace


ILexStyles.FindLexStyle Method

ILexStylesFindLexStyle Method
When implemented by a class, finds ILexStyle by its name.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStyle FindLexStyle(
    string name
)
Function FindLexStyle (
    name As String
) As ILexStyle
ILexStyle^ FindLexStyle(
    String^ name
)
abstract FindLexStyle :
        name : string -> ILexStyle

Parameters

name
Type: SystemString
Name of the ILexStyle.

Return Value

Type: ILexStyle
ILexStyle that is found.
See Also

Reference

ILexStyles Interface
Alternet.Syntax.Lexer Namespace


ILexStyles.InsertLexStyle Method

ILexStylesInsertLexStyle Method
When implemented by a class, inserts a new item to the specified position within the ILexStyles collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStyle InsertLexStyle(
    int index
)
Function InsertLexStyle (
    index As Integer
) As ILexStyle
ILexStyle^ InsertLexStyle(
    int index
)
abstract InsertLexStyle :
        index : int -> ILexStyle

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ILexStyle
ILexStyle that is inserted.
See Also

Reference

ILexStyles Interface
Alternet.Syntax.Lexer Namespace


ILexStyles Properties

ILexStyles Properties

The ILexStyles type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILexStyle .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILexStyle .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILexStyle .)
Top
See Also

Reference

ILexStyles Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock Interface

ILexSyntaxBlock Interface
Represents properties and methods for individual syntax block with collection of syntax blocks.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexSyntaxBlock
Public Interface ILexSyntaxBlock
public interface class ILexSyntaxBlock
type ILexSyntaxBlock =  interface end

The ILexSyntaxBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddExpression | When implemented by a class, adds new element to the expression collection.
Public method | FindResword | Locates LexReswordSet containing given resword.
Top
Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, gets or sets a value indicating whether ILexSyntaxBlock is case-sensitive or not.
Public property | Desc | When implemented by a class, gets or sets description of the ILexSyntaxBlock.
Public property | Expression | When implemented by a class, represents a collective regular expression pattern for the ILexSyntaxBlock.Expressions.
Public property | Expressions | When implemented by a class, gets or sets collection of the expressions used by ILexer to parse the text.
Public property | Index | When implemented by a class, represents index of the ILexSyntaxBlock within the lexical syntax block collection.
Public property | LeaveState | When implemented by a class, gets or sets ILexState object that specifies lexical resulting state after lexical analyzer locates text, that matches to the ILexSyntaxBlock.Expression.
Public property | Name | When implemented by a class, gets or sets name of the ILexSyntaxBlock.
Public property | ReswordSets | When implemented by a class, gets or sets collection of the ILexReswordSet object containing Reserved words.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexSyntaxBlock object.
Public property | State | When implemented by a class, gets or sets ILexState owning this ILexSyntaxBlock
Public property | Style | When implemented by a class, gets or sets an ILexStyle object, applicable for text that matches ILexSyntaxBlock expression.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock Methods

ILexSyntaxBlock Methods

The ILexSyntaxBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddExpression | When implemented by a class, adds new element to the expression collection.
Public method | FindResword | Locates LexReswordSet containing given resword.
Top
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.AddExpression Method

ILexSyntaxBlockAddExpression Method
When implemented by a class, adds new element to the expression collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int AddExpression(
    string expression
)
Function AddExpression (
    expression As String
) As Integer
int AddExpression(
    String^ expression
)
abstract AddExpression :
        expression : string -> int

Parameters

expression
Type: SystemString
Regular expression to add.

Return Value

Type: Int32
Index of added element in the expression collection.
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.FindResword Method

ILexSyntaxBlockFindResword Method
Locates LexReswordSet containing given resword.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int FindResword(
    string resword
)
Function FindResword (
    resword As String
) As Integer
int FindResword(
    String^ resword
)
abstract FindResword :
        resword : string -> int

Parameters

resword
Type: SystemString
The resword to search for.

Return Value

Type: Int32
Index of LexReswordSet if resword collection contains specified resword; otherwise - 1.
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock Properties

ILexSyntaxBlock Properties

The ILexSyntaxBlock type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, gets or sets a value indicating whether ILexSyntaxBlock is case-sensitive or not.
Public property | Desc | When implemented by a class, gets or sets description of the ILexSyntaxBlock.
Public property | Expression | When implemented by a class, represents a collective regular expression pattern for the ILexSyntaxBlock.Expressions.
Public property | Expressions | When implemented by a class, gets or sets collection of the expressions used by ILexer to parse the text.
Public property | Index | When implemented by a class, represents index of the ILexSyntaxBlock within the lexical syntax block collection.
Public property | LeaveState | When implemented by a class, gets or sets ILexState object that specifies lexical resulting state after lexical analyzer locates text, that matches to the ILexSyntaxBlock.Expression.
Public property | Name | When implemented by a class, gets or sets name of the ILexSyntaxBlock.
Public property | ReswordSets | When implemented by a class, gets or sets collection of the ILexReswordSet object containing Reserved words.
Public property | SerializationInfo | Gets or sets an xml representation of this ILexSyntaxBlock object.
Public property | State | When implemented by a class, gets or sets ILexState owning this ILexSyntaxBlock
Public property | Style | When implemented by a class, gets or sets an ILexStyle object, applicable for text that matches ILexSyntaxBlock expression.
Top
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.CaseSensitive Property

ILexSyntaxBlockCaseSensitive Property
When implemented by a class, gets or sets a value indicating whether ILexSyntaxBlock is case-sensitive or not.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CaseSensitive { get; }
ReadOnly Property CaseSensitive As Boolean
    Get
property bool CaseSensitive {
    bool get ();
}
abstract CaseSensitive : bool with get

Property Value

Type: Boolean
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.Desc Property

ILexSyntaxBlockDesc Property
When implemented by a class, gets or sets description of the ILexSyntaxBlock.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Desc { get; set; }
Property Desc As String
    Get
    Set
property String^ Desc {
    String^ get ();
    void set (String^ value);
}
abstract Desc : string with get, set

Property Value

Type: String
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.Expression Property

ILexSyntaxBlockExpression Property
When implemented by a class, represents a collective regular expression pattern for the ILexSyntaxBlock.Expressions.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Expression { get; }
ReadOnly Property Expression As String
    Get
property String^ Expression {
    String^ get ();
}
abstract Expression : string with get

Property Value

Type: String
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.Expressions Property

ILexSyntaxBlockExpressions Property
When implemented by a class, gets or sets collection of the expressions used by ILexer to parse the text.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<string> Expressions { get; set; }
Property Expressions As IList(Of String)
    Get
    Set
property IList<String^>^ Expressions {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}
abstract Expressions : IList<string> with get, set

Property Value

Type: IListString
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.Index Property

ILexSyntaxBlockIndex Property
When implemented by a class, represents index of the ILexSyntaxBlock within the lexical syntax block collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.LeaveState Property

ILexSyntaxBlockLeaveState Property
When implemented by a class, gets or sets ILexState object that specifies lexical resulting state after lexical analyzer locates text, that matches to the ILexSyntaxBlock.Expression.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexState LeaveState { get; set; }
Property LeaveState As ILexState
    Get
    Set
property ILexState^ LeaveState {
    ILexState^ get ();
    void set (ILexState^ value);
}
abstract LeaveState : ILexState with get, set

Property Value

Type: ILexState
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.Name Property

ILexSyntaxBlockName Property
When implemented by a class, gets or sets name of the ILexSyntaxBlock.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.ReswordSets Property

ILexSyntaxBlockReswordSets Property
When implemented by a class, gets or sets collection of the ILexReswordSet object containing Reserved words.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexReswordSets ReswordSets { get; set; }
Property ReswordSets As ILexReswordSets
    Get
    Set
property ILexReswordSets^ ReswordSets {
    ILexReswordSets^ get ();
    void set (ILexReswordSets^ value);
}
abstract ReswordSets : ILexReswordSets with get, set

Property Value

Type: ILexReswordSets
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.SerializationInfo Property

ILexSyntaxBlockSerializationInfo Property
Gets or sets an xml representation of this ILexSyntaxBlock object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISerializationInfo SerializationInfo { get; set; }
Property SerializationInfo As ISerializationInfo
    Get
    Set
property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.State Property

ILexSyntaxBlockState Property
When implemented by a class, gets or sets ILexState owning this ILexSyntaxBlock

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexState State { get; set; }
Property State As ILexState
    Get
    Set
property ILexState^ State {
    ILexState^ get ();
    void set (ILexState^ value);
}
abstract State : ILexState with get, set

Property Value

Type: ILexState
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlock.Style Property

ILexSyntaxBlockStyle Property
When implemented by a class, gets or sets an ILexStyle object, applicable for text that matches ILexSyntaxBlock expression.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexStyle Style { get; set; }
Property Style As ILexStyle
    Get
    Set
property ILexStyle^ Style {
    ILexStyle^ get ();
    void set (ILexStyle^ value);
}
abstract Style : ILexStyle with get, set

Property Value

Type: ILexStyle
See Also

Reference

ILexSyntaxBlock Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlocks Interface

ILexSyntaxBlocks Interface
Represents properties and methods to provide an indexed access to individual ILexSyntaxBlock objects.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILexSyntaxBlocks : IList<ILexSyntaxBlock>,
    ICollection<ILexSyntaxBlock>, IEnumerable<ILexSyntaxBlock>, IEnumerable
Public Interface ILexSyntaxBlocks
    Inherits IList(Of ILexSyntaxBlock), ICollection(Of ILexSyntaxBlock),
    IEnumerable(Of ILexSyntaxBlock), IEnumerable
public interface class ILexSyntaxBlocks : IList<ILexSyntaxBlock^>,
    ICollection<ILexSyntaxBlock^>, IEnumerable<ILexSyntaxBlock^>, IEnumerable
type ILexSyntaxBlocks =
    interface
        interface IList<ILexSyntaxBlock>
        interface ICollection<ILexSyntaxBlock>
        interface IEnumerable<ILexSyntaxBlock>
        interface IEnumerable
    end

The ILexSyntaxBlocks type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILexSyntaxBlock .)
Public method | AddLexSyntaxBlock | When implemented by a class, adds a new item to the specified position within the ILexReswordSets collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILexSyntaxBlock .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILexSyntaxBlock .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILexSyntaxBlock .)
Public method | FindSyntaxBlock | When implemented by a class, finds ILexSyntaxBlock by its name.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILexSyntaxBlock .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILexSyntaxBlock .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILexSyntaxBlock .)
Public method | InsertLexSyntaxBlock | When implemented by a class, inserts a new item to the specified position within the ILexSyntaxBlocks collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILexSyntaxBlock .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILexSyntaxBlock .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexSyntaxBlock | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexSyntaxBlock | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexSyntaxBlock, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILexSyntaxBlock .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILexSyntaxBlock .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILexSyntaxBlock .)
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ILexSyntaxBlocks Methods

ILexSyntaxBlocks Methods

The ILexSyntaxBlocks type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionILexSyntaxBlock .)
Public method | AddLexSyntaxBlock | When implemented by a class, adds a new item to the specified position within the ILexReswordSets collection.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionILexSyntaxBlock .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionILexSyntaxBlock .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionILexSyntaxBlock .)
Public method | FindSyntaxBlock | When implemented by a class, finds ILexSyntaxBlock by its name.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableILexSyntaxBlock .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListILexSyntaxBlock .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListILexSyntaxBlock .)
Public method | InsertLexSyntaxBlock | When implemented by a class, inserts a new item to the specified position within the ILexSyntaxBlocks collection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionILexSyntaxBlock .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListILexSyntaxBlock .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexSyntaxBlock | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexSyntaxBlock | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexSyntaxBlock, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

ILexSyntaxBlocks Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlocks.AddLexSyntaxBlock Method

ILexSyntaxBlocksAddLexSyntaxBlock Method
When implemented by a class, adds a new item to the specified position within the ILexReswordSets collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexSyntaxBlock AddLexSyntaxBlock()
Function AddLexSyntaxBlock As ILexSyntaxBlock
ILexSyntaxBlock^ AddLexSyntaxBlock()
abstract AddLexSyntaxBlock : unit -> ILexSyntaxBlock

Return Value

Type: ILexSyntaxBlock
ILexSyntaxBlock that is added.
See Also

Reference

ILexSyntaxBlocks Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlocks.FindSyntaxBlock Method

ILexSyntaxBlocksFindSyntaxBlock Method
When implemented by a class, finds ILexSyntaxBlock by its name.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexSyntaxBlock FindSyntaxBlock(
    string name
)
Function FindSyntaxBlock (
    name As String
) As ILexSyntaxBlock
ILexSyntaxBlock^ FindSyntaxBlock(
    String^ name
)
abstract FindSyntaxBlock :
        name : string -> ILexSyntaxBlock

Parameters

name
Type: SystemString
Specifies name of the ILexSyntaxBlock.

Return Value

Type: ILexSyntaxBlock
ILexSyntaxBlock that is found.
See Also

Reference

ILexSyntaxBlocks Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlocks.InsertLexSyntaxBlock Method

ILexSyntaxBlocksInsertLexSyntaxBlock Method
When implemented by a class, inserts a new item to the specified position within the ILexSyntaxBlocks collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ILexSyntaxBlock InsertLexSyntaxBlock(
    int index
)
Function InsertLexSyntaxBlock (
    index As Integer
) As ILexSyntaxBlock
ILexSyntaxBlock^ InsertLexSyntaxBlock(
    int index
)
abstract InsertLexSyntaxBlock :
        index : int -> ILexSyntaxBlock

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ILexSyntaxBlock
ILexSyntaxBlock that is inserted.
See Also

Reference

ILexSyntaxBlocks Interface
Alternet.Syntax.Lexer Namespace


ILexSyntaxBlocks Properties

ILexSyntaxBlocks Properties

The ILexSyntaxBlocks type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionILexSyntaxBlock .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionILexSyntaxBlock .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListILexSyntaxBlock .)
Top
See Also

Reference

ILexSyntaxBlocks Interface
Alternet.Syntax.Lexer Namespace


Lexer Class

Lexer Class
Represents class that performs lexical analysis of the specified text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Lexer : Component, ILexer,
    INotify, IUpdate
Public Class Lexer
    Inherits Component
    Implements ILexer, INotify, IUpdate
public ref class Lexer : public Component,
    ILexer, INotify, IUpdate
type Lexer =
    class
        inherit Component
        interface ILexer
        interface INotify
        interface IUpdate
    end

The Lexer type exposes the following members.

Constructors
 | Name | Description
Public method | Lexer | Initializes a new instance of the Lexer class with default settings.
Public method | Lexer(IContainer) | Initializes a new instance of the Lexer class with specified container.
Top
Methods
 | Name | Description
Public method | AddNotifier | Adds new handler to respond a notification.
Public method | Assign | Assigns most relevant properties from another ILexer object.
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Notify | Notifies all notifiers about updating object state.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text.
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list.
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text.
Public method | ResetDefaultState | Resets the DefaultState to the default value.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state.
Top
Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultState | Gets or sets default state of the Lexer.
Public property | Scheme | Gets or sets list of rules for lexical analysis.
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | XmlScheme | Gets or sets an xml representation of Scheme property.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line.
Top
Remarks
Lexer class is designed to recognize source code syntax, such as reserved words, comments, numbers, strings and any other syntax structures. Use Scheme property to specify lexical analysis rules.
See Also

Reference

Alternet.Syntax.Lexer Namespace


Lexer Constructor

Lexer Constructor
Overload List
 | Name | Description
Public method | Lexer | Initializes a new instance of the Lexer class with default settings.
Public method | Lexer(IContainer) | Initializes a new instance of the Lexer class with specified container.
Top
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer Constructor

Lexer Constructor
Initializes a new instance of the Lexer class with default settings.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Lexer()
Public Sub New
public:
Lexer()
new : unit -> Lexer
See Also

Reference

Lexer Class
Lexer Overload
Alternet.Syntax.Lexer Namespace


Lexer Constructor (IContainer)

Lexer Constructor (IContainer)
Initializes a new instance of the Lexer class with specified container.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Lexer(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
Lexer(
    IContainer^ container
)
new :
        container : IContainer -> Lexer

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

Lexer Class
Lexer Overload
Alternet.Syntax.Lexer Namespace


Lexer Methods

Lexer Methods

The Lexer type exposes the following members.

Methods
 | Name | Description
Public method | AddNotifier | Adds new handler to respond a notification.
Public method | Assign | Assigns most relevant properties from another ILexer object.
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Notify | Notifies all notifiers about updating object state.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text.
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list.
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text.
Public method | ResetDefaultState | Resets the DefaultState to the default value.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state.
Top
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.AddNotifier Method

LexerAddNotifier Method
Adds new handler to respond a notification.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddNotifier(
    INotifier sender
)
Public Overridable Sub AddNotifier (
    sender As INotifier
)
public:
virtual void AddNotifier(
    INotifier^ sender
)
abstract AddNotifier :
        sender : INotifier -> unit
override AddNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.

Implements

INotifyAddNotifier(INotifier)
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.Assign Method

LexerAssign Method
Assigns most relevant properties from another ILexer object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Assign(
    ILexer source
)
Public Sub Assign (
    source As ILexer
)
public:
virtual void Assign(
    ILexer^ source
) sealed
abstract Assign :
        source : ILexer -> unit
override Assign :
        source : ILexer -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexer
Specifies source object.

Implements

ILexerAssign(ILexer)
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.BeginUpdate Method

LexerBeginUpdate Method
Prevents object state updating until calling EndUpdate method.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.DisableUpdate Method

LexerDisableUpdate Method
Prevents object state updating until calling EnableUpdate method.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DisableUpdate()
Public Overridable Function DisableUpdate As Integer
public:
virtual int DisableUpdate()
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.EnableUpdate Method

LexerEnableUpdate Method
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EnableUpdate()
Public Overridable Function EnableUpdate As Integer
public:
virtual int EnableUpdate()
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.EndUpdate Method

LexerEndUpdate Method
Re-enables object state updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.Notify Method

LexerNotify Method
Notifies all notifiers about updating object state.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Notify(
    EventArgs e
)
Public Overridable Sub Notify (
    e As EventArgs
)
public:
virtual void Notify(
    EventArgs^ e
)
abstract Notify :
        e : EventArgs -> unit
override Notify :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

Implements

INotifyNotify(EventArgs)
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.ParseText Method

LexerParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text.
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text.
Top
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.ParseText Method (Int32, Int32, String, StringItemInfo[])

LexerParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overridable Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
)
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

Lexer Class
ParseText Overload
Alternet.Syntax.Lexer Namespace


Lexer.ParseText Method (Int32, Int32, String, Int32, Int32, Int32)

LexerParseText Method (Int32, Int32, String, Int32, Int32, Int32)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ParseText(
    int state,
    int line,
    string str,
    ref int pos,
    ref int len,
    ref int style
)
Public Overridable Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef pos As Integer,
    ByRef len As Integer,
    ByRef style As Integer
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    int% pos,
    int% len,
    int% style
)
abstract ParseText :
        state : int *
        line : int *
        str : string *
        pos : int byref *
        len : int byref *
        style : int byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        pos : int byref *
        len : int byref *
        style : int byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
pos
Type: SystemInt32
Starting position.
len
Type: SystemInt32
Integer value to receive length of parsed element.
style
Type: SystemInt32
Retrieves style of text being parsed.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, Int32, Int32, Int32)
See Also

Reference

Lexer Class
ParseText Overload
Alternet.Syntax.Lexer Namespace


Lexer.RemoveNotifier Method

LexerRemoveNotifier Method
Exclude specified handler from notification handlers list.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveNotifier(
    INotifier sender
)
Public Overridable Sub RemoveNotifier (
    sender As INotifier
)
public:
virtual void RemoveNotifier(
    INotifier^ sender
)
abstract RemoveNotifier :
        sender : INotifier -> unit
override RemoveNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.

Implements

INotifyRemoveNotifier(INotifier)
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.RemovePlainText Method

LexerRemovePlainText Method
Removes all plain (string constants or comments) parts of text from specified text.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string RemovePlainText(
    string s,
    StringItemInfo[] textData
)
Public Overridable Function RemovePlainText (
    s As String,
    textData As StringItemInfo()
) As String
public:
virtual String^ RemovePlainText(
    String^ s,
    array<StringItemInfo>^ textData
)
abstract RemovePlainText :
        s : string *
        textData : StringItemInfo[] -> string
override RemovePlainText :
        s : string *
        textData : StringItemInfo[] -> string

Parameters

s
Type: SystemString
Text to process.
textData
Type: Alternet.SyntaxStringItemInfo
Color information of given text.

Return Value

Type: String
String without plain parts.

Implements

ILexerRemovePlainText(String, StringItemInfo)
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.ResetDefaultState Method

LexerResetDefaultState Method
Resets the DefaultState to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetDefaultState()
Public Overridable Sub ResetDefaultState
public:
virtual void ResetDefaultState()
abstract ResetDefaultState : unit -> unit
override ResetDefaultState : unit -> unit

Implements

ILexerResetDefaultState
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.Update Method

LexerUpdate Method
When implemented by a class, updates an object state.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer Properties

Lexer Properties

The Lexer type exposes the following members.

Properties
 | Name | Description
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DefaultState | Gets or sets default state of the Lexer.
Public property | Scheme | Gets or sets list of rules for lexical analysis.
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | XmlScheme | Gets or sets an xml representation of Scheme property.
Top
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.DefaultState Property

LexerDefaultState Property
Gets or sets default state of the Lexer.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int DefaultState { get; set; }
Public Overridable Property DefaultState As Integer
    Get
    Set
public:
virtual property int DefaultState {
    int get ();
    void set (int value);
}
abstract DefaultState : int with get, set
override DefaultState : int with get, set

Property Value

Type: Int32

Implements

ILexerDefaultState
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.Scheme Property

LexerScheme Property
Gets or sets list of rules for lexical analysis.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute("Alternet.Syntax.Design.LexSchemeConverter, Alternet.Syntax.Design.v7")]
public virtual ILexScheme Scheme { get; set; }
<TypeConverterAttribute("Alternet.Syntax.Design.LexSchemeConverter, Alternet.Syntax.Design.v7")>
Public Overridable Property Scheme As ILexScheme
    Get
    Set
public:
[TypeConverterAttribute(L"Alternet.Syntax.Design.LexSchemeConverter, Alternet.Syntax.Design.v7")]
virtual property ILexScheme^ Scheme {
    ILexScheme^ get ();
    void set (ILexScheme^ value);
}
[<TypeConverterAttribute("Alternet.Syntax.Design.LexSchemeConverter, Alternet.Syntax.Design.v7")>]
abstract Scheme : ILexScheme with get, set
[<TypeConverterAttribute("Alternet.Syntax.Design.LexSchemeConverter, Alternet.Syntax.Design.v7")>]
override Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme

Implements

ILexerScheme
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.SerializationInfo Property

LexerSerializationInfo Property
Gets or sets an xml representation of this Lexer object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ILexerSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing Editor's content to XML.
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.UpdateCount Property

LexerUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int UpdateCount { get; }
Public Overridable ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get ();
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.XmlScheme Property

LexerXmlScheme Property
Gets or sets an xml representation of Scheme property.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string XmlScheme { get; set; }
Public Overridable Property XmlScheme As String
    Get
    Set
public:
virtual property String^ XmlScheme {
    String^ get ();
    void set (String^ value);
}
abstract XmlScheme : string with get, set
override XmlScheme : string with get, set

Property Value

Type: String
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer Events

Lexer Events

The Lexer type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line.
Top
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


Lexer.Parse Event

LexerParse Event
Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event ParseTextEvent Parse
Public Event Parse As ParseTextEvent
public:
virtual  event ParseTextEvent^ Parse {
    void add (ParseTextEvent^ value);
    void remove (ParseTextEvent^ value);
}
abstract Parse : IEvent<ParseTextEvent,
    ParseTextEventArgs>
override Parse : IEvent<ParseTextEvent,
    ParseTextEventArgs>

Value

Type: Alternet.Syntax.LexerParseTextEvent

Implements

ILexerParse
See Also

Reference

Lexer Class
Alternet.Syntax.Lexer Namespace


LexerProc Delegate

LexerProc Delegate
Represents a method intended to perform lexical analysis.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate int LexerProc()
Public Delegate Function LexerProc As Integer
public delegate int LexerProc()
type LexerProc =
    delegate of unit -> int

Return Value

Type: Int32
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexReswordSet Class

LexReswordSet Class
Represents class to specify keywords for ILexSyntaxBlock.LexReswordSets collection.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.LexerLexReswordSet

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LexReswordSet : ILexReswordSet
Public Class LexReswordSet
    Implements ILexReswordSet
public ref class LexReswordSet : ILexReswordSet
type LexReswordSet =
    class
        interface ILexReswordSet
    end

The LexReswordSet type exposes the following members.

Constructors
 | Name | Description
Public method | LexReswordSet | Initializes a new instance of the LexReswordSet class with default settings.
Top
Methods
 | Name | Description
Public method | AddResword | Adds a new element to the resword collection.
Public method | Clear | Removes all items from Reswords collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindResword | Locates given resword in Reswords collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Block | Gets or sets ILexSyntaxBlock owning this ILexReswordSet.
Public property | CaseSensitive | Gets or sets a value indicating whether ILexReswordSet is case-sensitive or not.
Public property | Index | Represents index of the LexReswordSet within the reswords collection.
Public property | Name | Gets or set name for the LexReswordSet.
Public property | Reswords | Represents a list of reswords for the LexReswordSet.Reswords.
Public property | ReswordStyle | Gets or sets an ILexStyle of resword collection.
Public property | SerializationInfo | Gets or sets an xml representation of this LexReswordSet object.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexReswordSet Constructor

LexReswordSet Constructor
Initializes a new instance of the LexReswordSet class with default settings.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexReswordSet(
    ILexSyntaxBlock block
)
Public Sub New (
    block As ILexSyntaxBlock
)
public:
LexReswordSet(
    ILexSyntaxBlock^ block
)
new :
        block : ILexSyntaxBlock -> LexReswordSet

Parameters

block
Type: Alternet.Syntax.LexerILexSyntaxBlock
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet Methods

LexReswordSet Methods

The LexReswordSet type exposes the following members.

Methods
 | Name | Description
Public method | AddResword | Adds a new element to the resword collection.
Public method | Clear | Removes all items from Reswords collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindResword | Locates given resword in Reswords collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.AddResword Method

LexReswordSetAddResword Method
Adds a new element to the resword collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AddResword(
    string resword
)
Public Overridable Function AddResword (
    resword As String
) As Integer
public:
virtual int AddResword(
    String^ resword
)
abstract AddResword :
        resword : string -> int
override AddResword :
        resword : string -> int

Parameters

resword
Type: SystemString
Resword to add.

Return Value

Type: Int32
Index of added element in the resword collection.

Implements

ILexReswordSetAddResword(String)
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.Clear Method

LexReswordSetClear Method
Removes all items from Reswords collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ILexReswordSetClear
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.FindResword Method

LexReswordSetFindResword Method
Locates given resword in Reswords collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool FindResword(
    string resword
)
Public Overridable Function FindResword (
    resword As String
) As Boolean
public:
virtual bool FindResword(
    String^ resword
)
abstract FindResword :
        resword : string -> bool
override FindResword :
        resword : string -> bool

Parameters

resword
Type: SystemString
Resword to locate.

Return Value

Type: Boolean
True if resword presents in the Reswords collection; otherwise false.

Implements

ILexReswordSetFindResword(String)
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet Properties

LexReswordSet Properties

The LexReswordSet type exposes the following members.

Properties
 | Name | Description
Public property | Block | Gets or sets ILexSyntaxBlock owning this ILexReswordSet.
Public property | CaseSensitive | Gets or sets a value indicating whether ILexReswordSet is case-sensitive or not.
Public property | Index | Represents index of the LexReswordSet within the reswords collection.
Public property | Name | Gets or set name for the LexReswordSet.
Public property | Reswords | Represents a list of reswords for the LexReswordSet.Reswords.
Public property | ReswordStyle | Gets or sets an ILexStyle of resword collection.
Public property | SerializationInfo | Gets or sets an xml representation of this LexReswordSet object.
Top
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.Block Property

LexReswordSetBlock Property
Gets or sets ILexSyntaxBlock owning this ILexReswordSet.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ILexSyntaxBlock Block { get; set; }
Public Property Block As ILexSyntaxBlock
    Get
    Set
public:
virtual property ILexSyntaxBlock^ Block {
    ILexSyntaxBlock^ get () sealed;
    void set (ILexSyntaxBlock^ value) sealed;
}
abstract Block : ILexSyntaxBlock with get, set
override Block : ILexSyntaxBlock with get, set

Property Value

Type: ILexSyntaxBlock

Implements

ILexReswordSetBlock
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.CaseSensitive Property

LexReswordSetCaseSensitive Property
Gets or sets a value indicating whether ILexReswordSet is case-sensitive or not.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CaseSensitive { get; set; }
Public Overridable Property CaseSensitive As Boolean
    Get
    Set
public:
virtual property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
abstract CaseSensitive : bool with get, set
override CaseSensitive : bool with get, set

Property Value

Type: Boolean

Implements

ILexReswordSetCaseSensitive
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.Index Property

LexReswordSetIndex Property
Represents index of the LexReswordSet within the reswords collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Index { get; }
Public Overridable ReadOnly Property Index As Integer
    Get
public:
virtual property int Index {
    int get ();
}
abstract Index : int with get
override Index : int with get

Property Value

Type: Int32

Implements

ILexReswordSetIndex
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.Name Property

LexReswordSetName Property
Gets or set name for the LexReswordSet.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ILexReswordSetName
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.Reswords Property

LexReswordSetReswords Property
Represents a list of reswords for the LexReswordSet.Reswords.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Reswords { get; set; }
Public Property Reswords As IList(Of String)
    Get
    Set
public:
virtual property IList<String^>^ Reswords {
    IList<String^>^ get () sealed;
    void set (IList<String^>^ value) sealed;
}
abstract Reswords : IList<string> with get, set
override Reswords : IList<string> with get, set

Property Value

Type: IListString

Implements

ILexReswordSetReswords
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.ReswordStyle Property

LexReswordSetReswordStyle Property
Gets or sets an ILexStyle of resword collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStyle ReswordStyle { get; set; }
Public Overridable Property ReswordStyle As ILexStyle
    Get
    Set
public:
virtual property ILexStyle^ ReswordStyle {
    ILexStyle^ get ();
    void set (ILexStyle^ value);
}
abstract ReswordStyle : ILexStyle with get, set
override ReswordStyle : ILexStyle with get, set

Property Value

Type: ILexStyle

Implements

ILexReswordSetReswordStyle
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSet.SerializationInfo Property

LexReswordSetSerializationInfo Property
Gets or sets an xml representation of this LexReswordSet object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ILexReswordSetSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing LexScheme's content to XML.
See Also

Reference

LexReswordSet Class
Alternet.Syntax.Lexer Namespace


LexReswordSets Class

LexReswordSets Class
Represents properties and methods to provide an indexed access to individual ILexReswordSet objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListILexReswordSet
Alternet.Syntax.LexerLexReswordSets

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LexReswordSets : List<ILexReswordSet>,
    ILexReswordSets, IList<ILexReswordSet>, ICollection<ILexReswordSet>,
    IEnumerable<ILexReswordSet>, IEnumerable
Public Class LexReswordSets
    Inherits List(Of ILexReswordSet)
    Implements ILexReswordSets, IList(Of ILexReswordSet),
    ICollection(Of ILexReswordSet), IEnumerable(Of ILexReswordSet), IEnumerable
public ref class LexReswordSets : public List<ILexReswordSet^>,
    ILexReswordSets, IList<ILexReswordSet^>, ICollection<ILexReswordSet^>,
    IEnumerable<ILexReswordSet^>, IEnumerable
type LexReswordSets =
    class
        inherit List<ILexReswordSet>
        interface ILexReswordSets
        interface IList<ILexReswordSet>
        interface ICollection<ILexReswordSet>
        interface IEnumerable<ILexReswordSet>
        interface IEnumerable
    end

The LexReswordSets type exposes the following members.

Constructors
 | Name | Description
Public method | LexReswordSets | Initializes a new instance of the LexReswordSets class with specified settings.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILexReswordSet .)
Public method | AddLexReswordSet | Adds a new item to the end of the ILexReswordSets collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILexReswordSet .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILexReswordSet .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILexReswordSet .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexReswordSet .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexReswordSet .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILexReswordSet .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILexReswordSet .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILexReswordSet .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILexReswordSet .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexReswordSet .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexReswordSet .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILexReswordSet .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexReswordSet .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexReswordSet .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexReswordSet .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexReswordSet .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexReswordSet .)
Public method | FindResword | Locates ILexReswordSet containing given resword.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILexReswordSet .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILexReswordSet .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILexReswordSet .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexReswordSet .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexReswordSet .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILexReswordSet .)
Public method | InsertLexReswordSet | Inserts a new item to the specified position within the ILexReswordSets collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILexReswordSet .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexReswordSet .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexReswordSet .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILexReswordSet .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexReswordSet .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILexReswordSet .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILexReswordSet .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILexReswordSet .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILexReswordSet .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILexReswordSet .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILexReswordSet .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILexReswordSet .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILexReswordSet .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILexReswordSet .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILexReswordSet .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILexReswordSet .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexReswordSet | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexReswordSet | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexReswordSet, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILexReswordSet .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListILexReswordSet .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILexReswordSet .)
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexReswordSets Constructor

LexReswordSets Constructor
Initializes a new instance of the LexReswordSets class with specified settings.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexReswordSets(
    ILexSyntaxBlock block
)
Public Sub New (
    block As ILexSyntaxBlock
)
public:
LexReswordSets(
    ILexSyntaxBlock^ block
)
new :
        block : ILexSyntaxBlock -> LexReswordSets

Parameters

block
Type: Alternet.Syntax.LexerILexSyntaxBlock
ILexSyntaxBlock holds this new instance.
See Also

Reference

LexReswordSets Class
Alternet.Syntax.Lexer Namespace


LexReswordSets Methods

LexReswordSets Methods

The LexReswordSets type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILexReswordSet .)
Public method | AddLexReswordSet | Adds a new item to the end of the ILexReswordSets collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILexReswordSet .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILexReswordSet .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILexReswordSet .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexReswordSet .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexReswordSet .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILexReswordSet .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILexReswordSet .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILexReswordSet .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILexReswordSet .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexReswordSet .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexReswordSet .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILexReswordSet .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexReswordSet .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexReswordSet .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexReswordSet .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexReswordSet .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexReswordSet .)
Public method | FindResword | Locates ILexReswordSet containing given resword.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILexReswordSet .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILexReswordSet .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILexReswordSet .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexReswordSet .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexReswordSet .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILexReswordSet .)
Public method | InsertLexReswordSet | Inserts a new item to the specified position within the ILexReswordSets collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILexReswordSet .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexReswordSet .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexReswordSet .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexReswordSet .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILexReswordSet .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexReswordSet .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILexReswordSet .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILexReswordSet .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILexReswordSet .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILexReswordSet .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILexReswordSet .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILexReswordSet .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILexReswordSet .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILexReswordSet .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILexReswordSet .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILexReswordSet .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILexReswordSet .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexReswordSet | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexReswordSet | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexReswordSet, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

LexReswordSets Class
Alternet.Syntax.Lexer Namespace


LexReswordSets.AddLexReswordSet Method

LexReswordSetsAddLexReswordSet Method
Adds a new item to the end of the ILexReswordSets collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexReswordSet AddLexReswordSet()
Public Overridable Function AddLexReswordSet As ILexReswordSet
public:
virtual ILexReswordSet^ AddLexReswordSet()
abstract AddLexReswordSet : unit -> ILexReswordSet
override AddLexReswordSet : unit -> ILexReswordSet

Return Value

Type: ILexReswordSet
ILexReswordSet that is added.

Implements

ILexReswordSetsAddLexReswordSet
See Also

Reference

LexReswordSets Class
Alternet.Syntax.Lexer Namespace


LexReswordSets.FindResword Method

LexReswordSetsFindResword Method
Locates ILexReswordSet containing given resword.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FindResword(
    string resword
)
Public Overridable Function FindResword (
    resword As String
) As Integer
public:
virtual int FindResword(
    String^ resword
)
abstract FindResword :
        resword : string -> int
override FindResword :
        resword : string -> int

Parameters

resword
Type: SystemString
The resword to search for.

Return Value

Type: Int32
Index of ILexReswordSet if resword collection contains specified resword; otherwise - 1.

Implements

ILexReswordSetsFindResword(String)
See Also

Reference

LexReswordSets Class
Alternet.Syntax.Lexer Namespace


LexReswordSets.InsertLexReswordSet Method

LexReswordSetsInsertLexReswordSet Method
Inserts a new item to the specified position within the ILexReswordSets collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexReswordSet InsertLexReswordSet(
    int index
)
Public Overridable Function InsertLexReswordSet (
    index As Integer
) As ILexReswordSet
public:
virtual ILexReswordSet^ InsertLexReswordSet(
    int index
)
abstract InsertLexReswordSet :
        index : int -> ILexReswordSet
override InsertLexReswordSet :
        index : int -> ILexReswordSet

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ILexReswordSet
ILexReswordSet that is inserted.

Implements

ILexReswordSetsInsertLexReswordSet(Int32)
See Also

Reference

LexReswordSets Class
Alternet.Syntax.Lexer Namespace


LexReswordSets Properties

LexReswordSets Properties

The LexReswordSets type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILexReswordSet .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListILexReswordSet .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILexReswordSet .)
Top
See Also

Reference

LexReswordSets Class
Alternet.Syntax.Lexer Namespace


LexScheme Class

LexScheme Class
Represents class contains rules for text lexical analysis.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.LexerLexScheme

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
[TypeConverterAttribute("Alternet.Syntax.Design.LexSchemeConverter, Alternet.Syntax.Design.v7")]
public class LexScheme : ILexScheme, IImport,
    IExport
<SerializableAttribute>
<TypeConverterAttribute("Alternet.Syntax.Design.LexSchemeConverter, Alternet.Syntax.Design.v7")>
Public Class LexScheme
    Implements ILexScheme, IImport, IExport
[SerializableAttribute]
[TypeConverterAttribute(L"Alternet.Syntax.Design.LexSchemeConverter, Alternet.Syntax.Design.v7")]
public ref class LexScheme : ILexScheme,
    IImport, IExport
[<SerializableAttribute>]
[<TypeConverterAttribute("Alternet.Syntax.Design.LexSchemeConverter, Alternet.Syntax.Design.v7")>]
type LexScheme =
    class
        interface ILexScheme
        interface IImport
        interface IExport
    end

The LexScheme type exposes the following members.

Constructors
 | Name | Description
Public method | LexScheme | Initializes a new instance of the LexScheme class with default settings.
Top
Methods
 | Name | Description
Public method | Assign | Assigns most relevant properties from another ILexScheme object.
Public method | Clear | Removes all states and styles from this LexScheme and sets other properties to default values.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Indicates whether LexScheme is empty , that is does not contain any styles, states, author, copyright, and description information.
Public method | IsPlainText | Indicates whether PlainText property of lexical style given by its index is true.
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, Encoding) | Saves scheme content to the specific file with specific encoding.
Public method | SaveStream(Stream) | Saves the scheme content to the specified stream.
Public method | SaveStream(TextWriter) | Saves the scheme content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | When implemented by a class, causes associated ILexer to update its state.
Top
Properties
 | Name | Description
Public property | Author | Gets or sets author of the LexScheme.
Public property | Copyright | Gets or sets copyright of the LexScheme.
Public property | Desc | Gets or sets description of the LexScheme.
Public property | FileExtension | Gets or sets string value indicating associated file extension of the ILexScheme.
Public property | FileType | Gets or sets string value indicating associated file type of the ILexScheme.
Public property | Name | Gets or sets LexScheme name.
Public property | SerializationInfo | Gets or sets an xml representation of this LexScheme object.
Public property | States | Gets or sets collection of lexical states.
Public property | Styles | Gets or sets collection of lexical styles.
Public property | Version | Gets or sets version of the LexScheme.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexScheme Constructor

LexScheme Constructor
Initializes a new instance of the LexScheme class with default settings.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexScheme(
    ILexer owner
)
Public Sub New (
    owner As ILexer
)
public:
LexScheme(
    ILexer^ owner
)
new :
        owner : ILexer -> LexScheme

Parameters

owner
Type: Alternet.Syntax.LexerILexer
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme Methods

LexScheme Methods

The LexScheme type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Assigns most relevant properties from another ILexScheme object.
Public method | Clear | Removes all states and styles from this LexScheme and sets other properties to default values.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Indicates whether LexScheme is empty , that is does not contain any styles, states, author, copyright, and description information.
Public method | IsPlainText | Indicates whether PlainText property of lexical style given by its index is true.
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, Encoding) | Saves scheme content to the specific file with specific encoding.
Public method | SaveStream(Stream) | Saves the scheme content to the specified stream.
Public method | SaveStream(TextWriter) | Saves the scheme content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | When implemented by a class, causes associated ILexer to update its state.
Top
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.Assign Method

LexSchemeAssign Method
Assigns most relevant properties from another ILexScheme object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Assign(
    ILexScheme source
)
Public Sub Assign (
    source As ILexScheme
)
public:
virtual void Assign(
    ILexScheme^ source
) sealed
abstract Assign :
        source : ILexScheme -> unit
override Assign :
        source : ILexScheme -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexScheme
Specifies source object.

Implements

ILexSchemeAssign(ILexScheme)
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.Clear Method

LexSchemeClear Method
Removes all states and styles from this LexScheme and sets other properties to default values.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ILexSchemeClear
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.IsEmpty Method

LexSchemeIsEmpty Method
Indicates whether LexScheme is empty , that is does not contain any styles, states, author, copyright, and description information.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty()
Public Overridable Function IsEmpty As Boolean
public:
virtual bool IsEmpty()
abstract IsEmpty : unit -> bool
override IsEmpty : unit -> bool

Return Value

Type: Boolean

Implements

ILexSchemeIsEmpty
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.IsPlainText Method

LexSchemeIsPlainText Method
Indicates whether PlainText property of lexical style given by its index is true.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsPlainText(
    int style
)
Public Overridable Function IsPlainText (
    style As Integer
) As Boolean
public:
virtual bool IsPlainText(
    int style
)
abstract IsPlainText :
        style : int -> bool
override IsPlainText :
        style : int -> bool

Parameters

style
Type: SystemInt32
Index of lexical style to check-up.

Return Value

Type: Boolean
True if lexical style PlainText property is true; otherwise false.

Implements

ILexSchemeIsPlainText(Int32)
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.LoadFile Method

LexSchemeLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of the specified file.
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding.
Top
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.LoadFile Method (String)

LexSchemeLoadFile Method (String)
Loads the contents of the specified file.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName
)
Public Overridable Function LoadFile (
    fileName As String
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName
)
abstract LoadFile :
        fileName : string -> bool
override LoadFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to load scheme.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String)
See Also

Reference

LexScheme Class
LoadFile Overload
Alternet.Syntax.Lexer Namespace


LexScheme.LoadFile Method (String, Encoding)

LexSchemeLoadFile Method (String, Encoding)
Loads the contents of the specified file with specified encoding.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
)
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load scheme.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

LexScheme Class
LoadFile Overload
Alternet.Syntax.Lexer Namespace


LexScheme.LoadStream Method

LexSchemeLoadStream Method
Overload List
 | Name | Description
Public method | LoadStream(Stream) | Loads the contents of the specified stream.
Public method | LoadStream(TextReader) | Loads the contents of the specified stream.
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream.
Top
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.LoadStream Method (Stream)

LexSchemeLoadStream Method (Stream)
Loads the contents of the specified stream.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream
)
Public Overridable Function LoadStream (
    stream As Stream
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream
)
abstract LoadStream :
        stream : Stream -> bool
override LoadStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read scheme.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream)
See Also

Reference

LexScheme Class
LoadStream Overload
Alternet.Syntax.Lexer Namespace


LexScheme.LoadStream Method (TextReader)

LexSchemeLoadStream Method (TextReader)
Loads the contents of the specified stream.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    TextReader reader
)
Public Overridable Function LoadStream (
    reader As TextReader
) As Boolean
public:
virtual bool LoadStream(
    TextReader^ reader
)
abstract LoadStream :
        reader : TextReader -> bool
override LoadStream :
        reader : TextReader -> bool

Parameters

reader
Type: System.IOTextReader
The TextReader object to read scheme.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(TextReader)
See Also

Reference

LexScheme Class
LoadStream Overload
Alternet.Syntax.Lexer Namespace


LexScheme.LoadStream Method (Stream, Encoding)

LexSchemeLoadStream Method (Stream, Encoding)
Loads the contents of the specified stream.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function LoadStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract LoadStream :
        stream : Stream *
        encoding : Encoding -> bool
override LoadStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to read scheme.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadStream(Stream, Encoding)
See Also

Reference

LexScheme Class
LoadStream Overload
Alternet.Syntax.Lexer Namespace


LexScheme.SaveFile Method

LexSchemeSaveFile Method
Overload List
 | Name | Description
Public method | SaveFile(String) | Saves text content to the specific file.
Public method | SaveFile(String, Encoding) | Saves scheme content to the specific file with specific encoding.
Top
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.SaveFile Method (String)

LexSchemeSaveFile Method (String)
Saves text content to the specific file.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName
)
Public Overridable Function SaveFile (
    fileName As String
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName
)
abstract SaveFile :
        fileName : string -> bool
override SaveFile :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
Name of file to save scheme.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String)
See Also

Reference

LexScheme Class
SaveFile Overload
Alternet.Syntax.Lexer Namespace


LexScheme.SaveFile Method (String, Encoding)

LexSchemeSaveFile Method (String, Encoding)
Saves scheme content to the specific file with specific encoding.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveFile(
    string fileName,
    Encoding encoding
)
Public Overridable Function SaveFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveFile(
    String^ fileName,
    Encoding^ encoding
)
abstract SaveFile :
        fileName : string *
        encoding : Encoding -> bool
override SaveFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to save content.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveFile(String, Encoding)
See Also

Reference

LexScheme Class
SaveFile Overload
Alternet.Syntax.Lexer Namespace


LexScheme.SaveStream Method

LexSchemeSaveStream Method
Overload List
 | Name | Description
Public method | SaveStream(Stream) | Saves the scheme content to the specified stream.
Public method | SaveStream(TextWriter) | Saves the scheme content to the specified stream.
Public method | SaveStream(Stream, Encoding) | Saves the text content to the specified stream.
Top
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.SaveStream Method (Stream)

LexSchemeSaveStream Method (Stream)
Saves the scheme content to the specified stream.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream
)
Public Overridable Function SaveStream (
    stream As Stream
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream
)
abstract SaveStream :
        stream : Stream -> bool
override SaveStream :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream)
See Also

Reference

LexScheme Class
SaveStream Overload
Alternet.Syntax.Lexer Namespace


LexScheme.SaveStream Method (TextWriter)

LexSchemeSaveStream Method (TextWriter)
Saves the scheme content to the specified stream.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    TextWriter writer
)
Public Overridable Function SaveStream (
    writer As TextWriter
) As Boolean
public:
virtual bool SaveStream(
    TextWriter^ writer
)
abstract SaveStream :
        writer : TextWriter -> bool
override SaveStream :
        writer : TextWriter -> bool

Parameters

writer
Type: System.IOTextWriter
The TextWriter object to write scheme to stream.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(TextWriter)
See Also

Reference

LexScheme Class
SaveStream Overload
Alternet.Syntax.Lexer Namespace


LexScheme.SaveStream Method (Stream, Encoding)

LexSchemeSaveStream Method (Stream, Encoding)
Saves the text content to the specified stream.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveStream(
    Stream stream,
    Encoding encoding
)
Public Overridable Function SaveStream (
    stream As Stream,
    encoding As Encoding
) As Boolean
public:
virtual bool SaveStream(
    Stream^ stream,
    Encoding^ encoding
)
abstract SaveStream :
        stream : Stream *
        encoding : Encoding -> bool
override SaveStream :
        stream : Stream *
        encoding : Encoding -> bool

Parameters

stream
Type: System.IOStream
The Stream object to write the text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IExportSaveStream(Stream, Encoding)
See Also

Reference

LexScheme Class
SaveStream Overload
Alternet.Syntax.Lexer Namespace


LexScheme.Update Method

LexSchemeUpdate Method
When implemented by a class, causes associated ILexer to update its state.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Update()
Public Overridable Sub Update
public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit

Implements

ILexSchemeUpdate
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme Properties

LexScheme Properties

The LexScheme type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets or sets author of the LexScheme.
Public property | Copyright | Gets or sets copyright of the LexScheme.
Public property | Desc | Gets or sets description of the LexScheme.
Public property | FileExtension | Gets or sets string value indicating associated file extension of the ILexScheme.
Public property | FileType | Gets or sets string value indicating associated file type of the ILexScheme.
Public property | Name | Gets or sets LexScheme name.
Public property | SerializationInfo | Gets or sets an xml representation of this LexScheme object.
Public property | States | Gets or sets collection of lexical states.
Public property | Styles | Gets or sets collection of lexical styles.
Public property | Version | Gets or sets version of the LexScheme.
Top
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.Author Property

LexSchemeAuthor Property
Gets or sets author of the LexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Author { get; set; }
Public Overridable Property Author As String
    Get
    Set
public:
virtual property String^ Author {
    String^ get ();
    void set (String^ value);
}
abstract Author : string with get, set
override Author : string with get, set

Property Value

Type: String

Implements

ILexSchemeAuthor
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.Copyright Property

LexSchemeCopyright Property
Gets or sets copyright of the LexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Copyright { get; set; }
Public Overridable Property Copyright As String
    Get
    Set
public:
virtual property String^ Copyright {
    String^ get ();
    void set (String^ value);
}
abstract Copyright : string with get, set
override Copyright : string with get, set

Property Value

Type: String

Implements

ILexSchemeCopyright
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.Desc Property

LexSchemeDesc Property
Gets or sets description of the LexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Desc { get; set; }
Public Overridable Property Desc As String
    Get
    Set
public:
virtual property String^ Desc {
    String^ get ();
    void set (String^ value);
}
abstract Desc : string with get, set
override Desc : string with get, set

Property Value

Type: String

Implements

ILexSchemeDesc
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.FileExtension Property

LexSchemeFileExtension Property
Gets or sets string value indicating associated file extension of the ILexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string FileExtension { get; set; }
Public Overridable Property FileExtension As String
    Get
    Set
public:
virtual property String^ FileExtension {
    String^ get ();
    void set (String^ value);
}
abstract FileExtension : string with get, set
override FileExtension : string with get, set

Property Value

Type: String

Implements

ILexSchemeFileExtension
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.FileType Property

LexSchemeFileType Property
Gets or sets string value indicating associated file type of the ILexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string FileType { get; set; }
Public Overridable Property FileType As String
    Get
    Set
public:
virtual property String^ FileType {
    String^ get ();
    void set (String^ value);
}
abstract FileType : string with get, set
override FileType : string with get, set

Property Value

Type: String

Implements

ILexSchemeFileType
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.Name Property

LexSchemeName Property
Gets or sets LexScheme name.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ILexSchemeName
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.SerializationInfo Property

LexSchemeSerializationInfo Property
Gets or sets an xml representation of this LexScheme object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ILexSchemeSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing LexScheme's content to XML.
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.States Property

LexSchemeStates Property
Gets or sets collection of lexical states.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStates States { get; set; }
Public Overridable Property States As ILexStates
    Get
    Set
public:
virtual property ILexStates^ States {
    ILexStates^ get ();
    void set (ILexStates^ value);
}
abstract States : ILexStates with get, set
override States : ILexStates with get, set

Property Value

Type: ILexStates

Implements

ILexSchemeStates
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.Styles Property

LexSchemeStyles Property
Gets or sets collection of lexical styles.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStyles Styles { get; set; }
Public Overridable Property Styles As ILexStyles
    Get
    Set
public:
virtual property ILexStyles^ Styles {
    ILexStyles^ get ();
    void set (ILexStyles^ value);
}
abstract Styles : ILexStyles with get, set
override Styles : ILexStyles with get, set

Property Value

Type: ILexStyles

Implements

ILexSchemeStyles
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexScheme.Version Property

LexSchemeVersion Property
Gets or sets version of the LexScheme.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Version { get; set; }
Public Overridable Property Version As String
    Get
    Set
public:
virtual property String^ Version {
    String^ get ();
    void set (String^ value);
}
abstract Version : string with get, set
override Version : string with get, set

Property Value

Type: String

Implements

ILexSchemeVersion
See Also

Reference

LexScheme Class
Alternet.Syntax.Lexer Namespace


LexState Class

LexState Class
Represents an individual lexical state with collection of lexical states.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.LexerLexState

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LexState : ILexState
Public Class LexState
    Implements ILexState
public ref class LexState : ILexState
type LexState =
    class
        interface ILexState
    end

The LexState type exposes the following members.

Constructors
 | Name | Description
Public method | LexState | Initializes a new instance of the LexState class with default settings.
Public method | LexState(ILexScheme) | Initializes a new instance of the LexState class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetCaseSensitive | Resets the CaseSensitive to the default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Blocks | Represents collection of Syntax Blocks associated with this ILexState.
Public property | CaseSensitive | Gets or sets a value indicating whether the analyzer should perform case sensitive parsing for this LexState.
Public property | Desc | Gets or sets description of the ILexState.
Public property | Expression | Represents a collective regular expression pattern for the LexState.
Public property | Index | Represents index of the LexState within the lexical state collection.
Public property | Name | Gets or sets name of the LexState.
Public property | Regex | Represents a regular expression that contains Expression as a pattern.
Public property | Scheme | Gets or sets ILexScheme that owns this LexState.
Public property | SerializationInfo | Gets or sets an xml representation of this LexState object.
Public property | SyntaxBlocks | Gets or sets a collection of lexical syntax blocks.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexState Constructor

LexState Constructor
Overload List
 | Name | Description
Public method | LexState | Initializes a new instance of the LexState class with default settings.
Public method | LexState(ILexScheme) | Initializes a new instance of the LexState class with specified owner.
Top
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState Constructor

LexState Constructor
Initializes a new instance of the LexState class with default settings.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexState()
Public Sub New
public:
LexState()
new : unit -> LexState
See Also

Reference

LexState Class
LexState Overload
Alternet.Syntax.Lexer Namespace


LexState Constructor (ILexScheme)

LexState Constructor (ILexScheme)
Initializes a new instance of the LexState class with specified owner.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexState(
    ILexScheme scheme
)
Public Sub New (
    scheme As ILexScheme
)
public:
LexState(
    ILexScheme^ scheme
)
new :
        scheme : ILexScheme -> LexState

Parameters

scheme
Type: Alternet.Syntax.LexerILexScheme
ILexScheme that owns this new instance.
See Also

Reference

LexState Class
LexState Overload
Alternet.Syntax.Lexer Namespace


LexState Methods

LexState Methods

The LexState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetCaseSensitive | Resets the CaseSensitive to the default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.ResetCaseSensitive Method

LexStateResetCaseSensitive Method
Resets the CaseSensitive to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetCaseSensitive()
Public Overridable Sub ResetCaseSensitive
public:
virtual void ResetCaseSensitive()
abstract ResetCaseSensitive : unit -> unit
override ResetCaseSensitive : unit -> unit

Implements

ILexStateResetCaseSensitive
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState Properties

LexState Properties

The LexState type exposes the following members.

Properties
 | Name | Description
Public property | Blocks | Represents collection of Syntax Blocks associated with this ILexState.
Public property | CaseSensitive | Gets or sets a value indicating whether the analyzer should perform case sensitive parsing for this LexState.
Public property | Desc | Gets or sets description of the ILexState.
Public property | Expression | Represents a collective regular expression pattern for the LexState.
Public property | Index | Represents index of the LexState within the lexical state collection.
Public property | Name | Gets or sets name of the LexState.
Public property | Regex | Represents a regular expression that contains Expression as a pattern.
Public property | Scheme | Gets or sets ILexScheme that owns this LexState.
Public property | SerializationInfo | Gets or sets an xml representation of this LexState object.
Public property | SyntaxBlocks | Gets or sets a collection of lexical syntax blocks.
Top
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.Blocks Property

LexStateBlocks Property
Represents collection of Syntax Blocks associated with this ILexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Dictionary<int, ILexSyntaxBlock> Blocks { get; }
Public Overridable ReadOnly Property Blocks As Dictionary(Of Integer, ILexSyntaxBlock)
    Get
public:
virtual property Dictionary<int, ILexSyntaxBlock^>^ Blocks {
    Dictionary<int, ILexSyntaxBlock^>^ get ();
}
abstract Blocks : Dictionary<int, ILexSyntaxBlock> with get
override Blocks : Dictionary<int, ILexSyntaxBlock> with get

Property Value

Type: DictionaryInt32, ILexSyntaxBlock

Implements

ILexStateBlocks
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.CaseSensitive Property

LexStateCaseSensitive Property
Gets or sets a value indicating whether the analyzer should perform case sensitive parsing for this LexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CaseSensitive { get; set; }
Public Overridable Property CaseSensitive As Boolean
    Get
    Set
public:
virtual property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
abstract CaseSensitive : bool with get, set
override CaseSensitive : bool with get, set

Property Value

Type: Boolean

Implements

ILexStateCaseSensitive
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.Desc Property

LexStateDesc Property
Gets or sets description of the ILexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Desc { get; set; }
Public Overridable Property Desc As String
    Get
    Set
public:
virtual property String^ Desc {
    String^ get ();
    void set (String^ value);
}
abstract Desc : string with get, set
override Desc : string with get, set

Property Value

Type: String

Implements

ILexStateDesc
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.Expression Property

LexStateExpression Property
Represents a collective regular expression pattern for the LexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Expression { get; }
Public Overridable ReadOnly Property Expression As String
    Get
public:
virtual property String^ Expression {
    String^ get ();
}
abstract Expression : string with get
override Expression : string with get

Property Value

Type: String

Implements

ILexStateExpression
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.Index Property

LexStateIndex Property
Represents index of the LexState within the lexical state collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Index { get; }
Public Overridable ReadOnly Property Index As Integer
    Get
public:
virtual property int Index {
    int get ();
}
abstract Index : int with get
override Index : int with get

Property Value

Type: Int32

Implements

ILexStateIndex
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.Name Property

LexStateName Property
Gets or sets name of the LexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ILexStateName
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.Regex Property

LexStateRegex Property
Represents a regular expression that contains Expression as a pattern.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Regex Regex { get; }
Public Overridable ReadOnly Property Regex As Regex
    Get
public:
virtual property Regex^ Regex {
    Regex^ get ();
}
abstract Regex : Regex with get
override Regex : Regex with get

Property Value

Type: Regex

Implements

ILexStateRegex
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.Scheme Property

LexStateScheme Property
Gets or sets ILexScheme that owns this LexState.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexScheme Scheme { get; set; }
Public Overridable Property Scheme As ILexScheme
    Get
    Set
public:
virtual property ILexScheme^ Scheme {
    ILexScheme^ get ();
    void set (ILexScheme^ value);
}
abstract Scheme : ILexScheme with get, set
override Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme

Implements

ILexStateScheme
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.SerializationInfo Property

LexStateSerializationInfo Property
Gets or sets an xml representation of this LexState object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ILexStateSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing LexScheme's content to XML.
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexState.SyntaxBlocks Property

LexStateSyntaxBlocks Property
Gets or sets a collection of lexical syntax blocks.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexSyntaxBlocks SyntaxBlocks { get; set; }
Public Overridable Property SyntaxBlocks As ILexSyntaxBlocks
    Get
    Set
public:
virtual property ILexSyntaxBlocks^ SyntaxBlocks {
    ILexSyntaxBlocks^ get ();
    void set (ILexSyntaxBlocks^ value);
}
abstract SyntaxBlocks : ILexSyntaxBlocks with get, set
override SyntaxBlocks : ILexSyntaxBlocks with get, set

Property Value

Type: ILexSyntaxBlocks

Implements

ILexStateSyntaxBlocks
See Also

Reference

LexState Class
Alternet.Syntax.Lexer Namespace


LexStates Class

LexStates Class
Provides an indexed access to individual ILexState objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListILexState
Alternet.Syntax.LexerLexStates

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LexStates : List<ILexState>,
    ILexStates, IList<ILexState>, ICollection<ILexState>,
    IEnumerable<ILexState>, IEnumerable
Public Class LexStates
    Inherits List(Of ILexState)
    Implements ILexStates, IList(Of ILexState),
    ICollection(Of ILexState), IEnumerable(Of ILexState), IEnumerable
public ref class LexStates : public List<ILexState^>,
    ILexStates, IList<ILexState^>, ICollection<ILexState^>,
    IEnumerable<ILexState^>, IEnumerable
type LexStates =
    class
        inherit List<ILexState>
        interface ILexStates
        interface IList<ILexState>
        interface ICollection<ILexState>
        interface IEnumerable<ILexState>
        interface IEnumerable
    end

The LexStates type exposes the following members.

Constructors
 | Name | Description
Public method | LexStates | Initializes a new instance of the LexStates with specified owner.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILexState .)
Public method | AddLexState | Creates new ILexState and adds it to LexScheme.LexStates collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILexState .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILexState .)
Public method | Assign | Assigns most relevant properties from another ILexStates object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILexState .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexState .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexState .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILexState .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILexState .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILexState .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILexState .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexState .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexState .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILexState .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexState .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexState .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexState .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexState .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexState .)
Public method | FindLexState | Finds ILexState by its name.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILexState .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILexState .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILexState .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexState .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexState .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILexState .)
Public method | InsertLexState | Inserts a new item to the specified position within the ILexStates collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILexState .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexState .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexState .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILexState .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexState .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILexState .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILexState .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILexState .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILexState .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILexState .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILexState .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILexState .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILexState .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILexState .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILexState .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILexState .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexState | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexState | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexState, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILexState .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListILexState .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILexState .)
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexStates Constructor

LexStates Constructor
Initializes a new instance of the LexStates with specified owner.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexStates(
    ILexScheme owner
)
Public Sub New (
    owner As ILexScheme
)
public:
LexStates(
    ILexScheme^ owner
)
new :
        owner : ILexScheme -> LexStates

Parameters

owner
Type: Alternet.Syntax.LexerILexScheme
Specifies ILexScheme that owns this new instance.
See Also

Reference

LexStates Class
Alternet.Syntax.Lexer Namespace


LexStates Methods

LexStates Methods

The LexStates type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILexState .)
Public method | AddLexState | Creates new ILexState and adds it to LexScheme.LexStates collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILexState .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILexState .)
Public method | Assign | Assigns most relevant properties from another ILexStates object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILexState .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexState .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexState .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILexState .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILexState .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILexState .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILexState .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexState .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexState .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILexState .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexState .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexState .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexState .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexState .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexState .)
Public method | FindLexState | Finds ILexState by its name.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILexState .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILexState .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILexState .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexState .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexState .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILexState .)
Public method | InsertLexState | Inserts a new item to the specified position within the ILexStates collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILexState .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexState .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexState .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexState .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILexState .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexState .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILexState .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILexState .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILexState .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILexState .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILexState .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILexState .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILexState .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILexState .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILexState .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILexState .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILexState .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexState | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexState | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexState, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

LexStates Class
Alternet.Syntax.Lexer Namespace


LexStates.AddLexState Method

LexStatesAddLexState Method
Creates new ILexState and adds it to LexScheme.LexStates collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexState AddLexState()
Public Overridable Function AddLexState As ILexState
public:
virtual ILexState^ AddLexState()
abstract AddLexState : unit -> ILexState
override AddLexState : unit -> ILexState

Return Value

Type: ILexState
ILexState that is added.

Implements

ILexStatesAddLexState
See Also

Reference

LexStates Class
Alternet.Syntax.Lexer Namespace


LexStates.Assign Method

LexStatesAssign Method
Assigns most relevant properties from another ILexStates object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Assign(
    ILexStates source
)
Public Sub Assign (
    source As ILexStates
)
public:
virtual void Assign(
    ILexStates^ source
) sealed
abstract Assign :
        source : ILexStates -> unit
override Assign :
        source : ILexStates -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexStates
Specifies source object.

Implements

ILexStatesAssign(ILexStates)
See Also

Reference

LexStates Class
Alternet.Syntax.Lexer Namespace


LexStates.FindLexState Method

LexStatesFindLexState Method
Finds ILexState by its name.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexState FindLexState(
    string name
)
Public Overridable Function FindLexState (
    name As String
) As ILexState
public:
virtual ILexState^ FindLexState(
    String^ name
)
abstract FindLexState :
        name : string -> ILexState
override FindLexState :
        name : string -> ILexState

Parameters

name
Type: SystemString
Name of the ILexState.

Return Value

Type: ILexState
ILexState that is found.

Implements

ILexStatesFindLexState(String)
See Also

Reference

LexStates Class
Alternet.Syntax.Lexer Namespace


LexStates.InsertLexState Method

LexStatesInsertLexState Method
Inserts a new item to the specified position within the ILexStates collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexState InsertLexState(
    int index
)
Public Overridable Function InsertLexState (
    index As Integer
) As ILexState
public:
virtual ILexState^ InsertLexState(
    int index
)
abstract InsertLexState :
        index : int -> ILexState
override InsertLexState :
        index : int -> ILexState

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ILexState
ILexState that is inserted.

Implements

ILexStatesInsertLexState(Int32)
See Also

Reference

LexStates Class
Alternet.Syntax.Lexer Namespace


LexStates Properties

LexStates Properties

The LexStates type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILexState .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListILexState .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILexState .)
Top
See Also

Reference

LexStates Class
Alternet.Syntax.Lexer Namespace


LexStyle Class

LexStyle Class
Represents an individual lexical style with the collection of lexical styles.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.LexerLexStyle

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LexStyle : ILexStyle
Public Class LexStyle
    Implements ILexStyle
public ref class LexStyle : ILexStyle
type LexStyle =
    class
        interface ILexStyle
    end

The LexStyle type exposes the following members.

Constructors
 | Name | Description
Public method | LexStyle | Initializes a new instance of the LexStyle class with default settings.
Public method | LexStyle(ILexScheme) | Initializes a new instance of the LexStyle class with specified owner.
Top
Methods
 | Name | Description
Public method | Assign | Copies the contents of another ILexStyle object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetBackColor | Resets the BackColor to the default value.
Public method | ResetFontStyle | Resets the FontStyle to the default value.
Public method | ResetForeColor | Resets the ForeColor to the default value.
Public method | ResetPlainText | Resets the PlainText to the default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets a background color of the LexStyle.
Public property | BackColorEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the BackColor property should be enabled or disabled.
Public property | BoldEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the Bold property should be enabled or disabled.
Public property | Desc | Gets or sets a description of the LexStyle.
Public property | FontStyle | Gets or sets a font style of the LexStyle.
Public property | ForeColor | Gets or sets a foreground color of the LexStyle.
Public property | ForeColorEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the ForeColor property should be enabled or disabled.
Public property | Index | Gets or sets index of this LexStyle within the lexical style collection.
Public property | ItalicEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the Italic property should be enabled or disabled.
Public property | Name | Gets or sets name of the LexStyle.
Public property | PlainText | Gets or sets value indicating whether Edit control should use text formatting rules, like checking spelling.
Public property | Scheme | Gets or sets ILexScheme that owns this LexStyle.
Public property | SerializationInfo | Gets or sets an xml representation of this LexStyle object.
Public property | UnderlineEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the Underline property should be enabled or disabled.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexStyle Constructor

LexStyle Constructor
Overload List
 | Name | Description
Public method | LexStyle | Initializes a new instance of the LexStyle class with default settings.
Public method | LexStyle(ILexScheme) | Initializes a new instance of the LexStyle class with specified owner.
Top
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle Constructor

LexStyle Constructor
Initializes a new instance of the LexStyle class with default settings.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexStyle()
Public Sub New
public:
LexStyle()
new : unit -> LexStyle
See Also

Reference

LexStyle Class
LexStyle Overload
Alternet.Syntax.Lexer Namespace


LexStyle Constructor (ILexScheme)

LexStyle Constructor (ILexScheme)
Initializes a new instance of the LexStyle class with specified owner.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexStyle(
    ILexScheme scheme
)
Public Sub New (
    scheme As ILexScheme
)
public:
LexStyle(
    ILexScheme^ scheme
)
new :
        scheme : ILexScheme -> LexStyle

Parameters

scheme
Type: Alternet.Syntax.LexerILexScheme
ILexScheme that contains this new instance.
See Also

Reference

LexStyle Class
LexStyle Overload
Alternet.Syntax.Lexer Namespace


LexStyle Methods

LexStyle Methods

The LexStyle type exposes the following members.

Methods
 | Name | Description
Public method | Assign | Copies the contents of another ILexStyle object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetBackColor | Resets the BackColor to the default value.
Public method | ResetFontStyle | Resets the FontStyle to the default value.
Public method | ResetForeColor | Resets the ForeColor to the default value.
Public method | ResetPlainText | Resets the PlainText to the default value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.Assign Method

LexStyleAssign Method
Copies the contents of another ILexStyle object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Assign(
    ILexStyle source
)
Public Overridable Sub Assign (
    source As ILexStyle
)
public:
virtual void Assign(
    ILexStyle^ source
)
abstract Assign :
        source : ILexStyle -> unit
override Assign :
        source : ILexStyle -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexStyle
Specifies ILexStyle to assign.

Implements

ILexStyleAssign(ILexStyle)
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.ResetBackColor Method

LexStyleResetBackColor Method
Resets the BackColor to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetBackColor()
Public Overridable Sub ResetBackColor
public:
virtual void ResetBackColor()
abstract ResetBackColor : unit -> unit
override ResetBackColor : unit -> unit

Implements

ILexStyleResetBackColor
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.ResetFontStyle Method

LexStyleResetFontStyle Method
Resets the FontStyle to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetFontStyle()
Public Overridable Sub ResetFontStyle
public:
virtual void ResetFontStyle()
abstract ResetFontStyle : unit -> unit
override ResetFontStyle : unit -> unit

Implements

ILexStyleResetFontStyle
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.ResetForeColor Method

LexStyleResetForeColor Method
Resets the ForeColor to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetForeColor()
Public Overridable Sub ResetForeColor
public:
virtual void ResetForeColor()
abstract ResetForeColor : unit -> unit
override ResetForeColor : unit -> unit

Implements

ILexStyleResetForeColor
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.ResetPlainText Method

LexStyleResetPlainText Method
Resets the PlainText to the default value.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetPlainText()
Public Overridable Sub ResetPlainText
public:
virtual void ResetPlainText()
abstract ResetPlainText : unit -> unit
override ResetPlainText : unit -> unit

Implements

ILexStyleResetPlainText
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle Properties

LexStyle Properties

The LexStyle type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets a background color of the LexStyle.
Public property | BackColorEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the BackColor property should be enabled or disabled.
Public property | BoldEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the Bold property should be enabled or disabled.
Public property | Desc | Gets or sets a description of the LexStyle.
Public property | FontStyle | Gets or sets a font style of the LexStyle.
Public property | ForeColor | Gets or sets a foreground color of the LexStyle.
Public property | ForeColorEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the ForeColor property should be enabled or disabled.
Public property | Index | Gets or sets index of this LexStyle within the lexical style collection.
Public property | ItalicEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the Italic property should be enabled or disabled.
Public property | Name | Gets or sets name of the LexStyle.
Public property | PlainText | Gets or sets value indicating whether Edit control should use text formatting rules, like checking spelling.
Public property | Scheme | Gets or sets ILexScheme that owns this LexStyle.
Public property | SerializationInfo | Gets or sets an xml representation of this LexStyle object.
Public property | UnderlineEnabled | Gets or sets a flag that indicates whether the GUI control that corresponds to the Underline property should be enabled or disabled.
Top
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.BackColor Property

LexStyleBackColor Property
Gets or sets a background color of the LexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color BackColor { get; set; }
Public Overridable Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color

Implements

ILexStyleBackColor
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.BackColorEnabled Property

LexStyleBackColorEnabled Property
Gets or sets a flag that indicates whether the GUI control that corresponds to the BackColor property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BackColorEnabled { get; set; }
Public Overridable Property BackColorEnabled As Boolean
    Get
    Set
public:
virtual property bool BackColorEnabled {
    bool get ();
    void set (bool value);
}
abstract BackColorEnabled : bool with get, set
override BackColorEnabled : bool with get, set

Property Value

Type: Boolean

Implements

ILexStyleBackColorEnabled
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.BoldEnabled Property

LexStyleBoldEnabled Property
Gets or sets a flag that indicates whether the GUI control that corresponds to the Bold property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool BoldEnabled { get; set; }
Public Overridable Property BoldEnabled As Boolean
    Get
    Set
public:
virtual property bool BoldEnabled {
    bool get ();
    void set (bool value);
}
abstract BoldEnabled : bool with get, set
override BoldEnabled : bool with get, set

Property Value

Type: Boolean

Implements

ILexStyleBoldEnabled
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.Desc Property

LexStyleDesc Property
Gets or sets a description of the LexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Desc { get; set; }
Public Overridable Property Desc As String
    Get
    Set
public:
virtual property String^ Desc {
    String^ get ();
    void set (String^ value);
}
abstract Desc : string with get, set
override Desc : string with get, set

Property Value

Type: String

Implements

ILexStyleDesc
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.FontStyle Property

LexStyleFontStyle Property
Gets or sets a font style of the LexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FontStyle FontStyle { get; set; }
Public Overridable Property FontStyle As FontStyle
    Get
    Set
public:
virtual property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
abstract FontStyle : FontStyle with get, set
override FontStyle : FontStyle with get, set

Property Value

Type: FontStyle

Implements

ILexStyleFontStyle
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.ForeColor Property

LexStyleForeColor Property
Gets or sets a foreground color of the LexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Color ForeColor { get; set; }
Public Overridable Property ForeColor As Color
    Get
    Set
public:
virtual property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set
override ForeColor : Color with get, set

Property Value

Type: Color

Implements

ILexStyleForeColor
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.ForeColorEnabled Property

LexStyleForeColorEnabled Property
Gets or sets a flag that indicates whether the GUI control that corresponds to the ForeColor property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ForeColorEnabled { get; set; }
Public Overridable Property ForeColorEnabled As Boolean
    Get
    Set
public:
virtual property bool ForeColorEnabled {
    bool get ();
    void set (bool value);
}
abstract ForeColorEnabled : bool with get, set
override ForeColorEnabled : bool with get, set

Property Value

Type: Boolean

Implements

ILexStyleForeColorEnabled
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.Index Property

LexStyleIndex Property
Gets or sets index of this LexStyle within the lexical style collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Index { get; }
Public Overridable ReadOnly Property Index As Integer
    Get
public:
virtual property int Index {
    int get ();
}
abstract Index : int with get
override Index : int with get

Property Value

Type: Int32

Implements

ILexStyleIndex
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.ItalicEnabled Property

LexStyleItalicEnabled Property
Gets or sets a flag that indicates whether the GUI control that corresponds to the Italic property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ItalicEnabled { get; set; }
Public Overridable Property ItalicEnabled As Boolean
    Get
    Set
public:
virtual property bool ItalicEnabled {
    bool get ();
    void set (bool value);
}
abstract ItalicEnabled : bool with get, set
override ItalicEnabled : bool with get, set

Property Value

Type: Boolean

Implements

ILexStyleItalicEnabled
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.Name Property

LexStyleName Property
Gets or sets name of the LexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ILexStyleName
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.PlainText Property

LexStylePlainText Property
Gets or sets value indicating whether Edit control should use text formatting rules, like checking spelling.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool PlainText { get; set; }
Public Overridable Property PlainText As Boolean
    Get
    Set
public:
virtual property bool PlainText {
    bool get ();
    void set (bool value);
}
abstract PlainText : bool with get, set
override PlainText : bool with get, set

Property Value

Type: Boolean

Implements

ILexStylePlainText
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.Scheme Property

LexStyleScheme Property
Gets or sets ILexScheme that owns this LexStyle.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ILexScheme Scheme { get; set; }
Public Property Scheme As ILexScheme
    Get
    Set
public:
virtual property ILexScheme^ Scheme {
    ILexScheme^ get () sealed;
    void set (ILexScheme^ value) sealed;
}
abstract Scheme : ILexScheme with get, set
override Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme

Implements

ILexStyleScheme
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.SerializationInfo Property

LexStyleSerializationInfo Property
Gets or sets an xml representation of this LexStyle object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ILexStyleSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing LexScheme's content to XML.
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyle.UnderlineEnabled Property

LexStyleUnderlineEnabled Property
Gets or sets a flag that indicates whether the GUI control that corresponds to the Underline property should be enabled or disabled.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnderlineEnabled { get; set; }
Public Overridable Property UnderlineEnabled As Boolean
    Get
    Set
public:
virtual property bool UnderlineEnabled {
    bool get ();
    void set (bool value);
}
abstract UnderlineEnabled : bool with get, set
override UnderlineEnabled : bool with get, set

Property Value

Type: Boolean

Implements

ILexStyleUnderlineEnabled
See Also

Reference

LexStyle Class
Alternet.Syntax.Lexer Namespace


LexStyles Class

LexStyles Class
Provides an indexed access to individual ILexStyle objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListILexStyle
Alternet.Syntax.LexerLexStyles

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LexStyles : List<ILexStyle>,
    ILexStyles, IList<ILexStyle>, ICollection<ILexStyle>,
    IEnumerable<ILexStyle>, IEnumerable
Public Class LexStyles
    Inherits List(Of ILexStyle)
    Implements ILexStyles, IList(Of ILexStyle),
    ICollection(Of ILexStyle), IEnumerable(Of ILexStyle), IEnumerable
public ref class LexStyles : public List<ILexStyle^>,
    ILexStyles, IList<ILexStyle^>, ICollection<ILexStyle^>,
    IEnumerable<ILexStyle^>, IEnumerable
type LexStyles =
    class
        inherit List<ILexStyle>
        interface ILexStyles
        interface IList<ILexStyle>
        interface ICollection<ILexStyle>
        interface IEnumerable<ILexStyle>
        interface IEnumerable
    end

The LexStyles type exposes the following members.

Constructors
 | Name | Description
Public method | LexStyles | Initializes a new instance of the LexStyles class with specified owner.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILexStyle .)
Public method | AddLexStyle | Creates new ILexStyle and adds it to LexScheme.LexStyles collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILexStyle .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILexStyle .)
Public method | Assign | Assigns most relevant properties from another ILexStyles object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILexStyle .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexStyle .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexStyle .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILexStyle .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILexStyle .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILexStyle .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILexStyle .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexStyle .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexStyle .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILexStyle .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexStyle .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexStyle .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexStyle .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexStyle .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexStyle .)
Public method | FindLexStyle | Finds ILexStyle by its name.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILexStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILexStyle .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILexStyle .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexStyle .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexStyle .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILexStyle .)
Public method | InsertLexStyle | Inserts a new item to the specified position within the ILexStyles collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILexStyle .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexStyle .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexStyle .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILexStyle .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexStyle .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILexStyle .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILexStyle .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILexStyle .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILexStyle .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILexStyle .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILexStyle .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILexStyle .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILexStyle .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILexStyle .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILexStyle .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILexStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILexStyle .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListILexStyle .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILexStyle .)
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexStyles Constructor

LexStyles Constructor
Initializes a new instance of the LexStyles class with specified owner.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexStyles(
    ILexScheme owner
)
Public Sub New (
    owner As ILexScheme
)
public:
LexStyles(
    ILexScheme^ owner
)
new :
        owner : ILexScheme -> LexStyles

Parameters

owner
Type: Alternet.Syntax.LexerILexScheme
Specifies ILexScheme that owns this new instance.
See Also

Reference

LexStyles Class
Alternet.Syntax.Lexer Namespace


LexStyles Methods

LexStyles Methods

The LexStyles type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILexStyle .)
Public method | AddLexStyle | Creates new ILexStyle and adds it to LexScheme.LexStyles collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILexStyle .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILexStyle .)
Public method | Assign | Assigns most relevant properties from another ILexStyles object.
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILexStyle .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexStyle .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexStyle .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILexStyle .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILexStyle .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILexStyle .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILexStyle .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexStyle .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexStyle .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILexStyle .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexStyle .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexStyle .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexStyle .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexStyle .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexStyle .)
Public method | FindLexStyle | Finds ILexStyle by its name.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILexStyle .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILexStyle .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILexStyle .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexStyle .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexStyle .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILexStyle .)
Public method | InsertLexStyle | Inserts a new item to the specified position within the ILexStyles collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILexStyle .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexStyle .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexStyle .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexStyle .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILexStyle .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexStyle .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILexStyle .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILexStyle .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILexStyle .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILexStyle .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILexStyle .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILexStyle .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILexStyle .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILexStyle .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILexStyle .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILexStyle .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILexStyle .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexStyle | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexStyle | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexStyle, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

LexStyles Class
Alternet.Syntax.Lexer Namespace


LexStyles.AddLexStyle Method

LexStylesAddLexStyle Method
Creates new ILexStyle and adds it to LexScheme.LexStyles collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStyle AddLexStyle()
Public Overridable Function AddLexStyle As ILexStyle
public:
virtual ILexStyle^ AddLexStyle()
abstract AddLexStyle : unit -> ILexStyle
override AddLexStyle : unit -> ILexStyle

Return Value

Type: ILexStyle
ILexStyle that is added.

Implements

ILexStylesAddLexStyle
See Also

Reference

LexStyles Class
Alternet.Syntax.Lexer Namespace


LexStyles.Assign Method

LexStylesAssign Method
Assigns most relevant properties from another ILexStyles object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Assign(
    ILexStyles source
)
Public Sub Assign (
    source As ILexStyles
)
public:
virtual void Assign(
    ILexStyles^ source
) sealed
abstract Assign :
        source : ILexStyles -> unit
override Assign :
        source : ILexStyles -> unit

Parameters

source
Type: Alternet.Syntax.LexerILexStyles
Specifies source object.

Implements

ILexStylesAssign(ILexStyles)
See Also

Reference

LexStyles Class
Alternet.Syntax.Lexer Namespace


LexStyles.FindLexStyle Method

LexStylesFindLexStyle Method
Finds ILexStyle by its name.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStyle FindLexStyle(
    string name
)
Public Overridable Function FindLexStyle (
    name As String
) As ILexStyle
public:
virtual ILexStyle^ FindLexStyle(
    String^ name
)
abstract FindLexStyle :
        name : string -> ILexStyle
override FindLexStyle :
        name : string -> ILexStyle

Parameters

name
Type: SystemString
Name of the ILexStyle.

Return Value

Type: ILexStyle
ILexStyle that is found.

Implements

ILexStylesFindLexStyle(String)
See Also

Reference

LexStyles Class
Alternet.Syntax.Lexer Namespace


LexStyles.InsertLexStyle Method

LexStylesInsertLexStyle Method
Inserts a new item to the specified position within the ILexStyles collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStyle InsertLexStyle(
    int index
)
Public Overridable Function InsertLexStyle (
    index As Integer
) As ILexStyle
public:
virtual ILexStyle^ InsertLexStyle(
    int index
)
abstract InsertLexStyle :
        index : int -> ILexStyle
override InsertLexStyle :
        index : int -> ILexStyle

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ILexStyle
ILexStyle that is inserted.

Implements

ILexStylesInsertLexStyle(Int32)
See Also

Reference

LexStyles Class
Alternet.Syntax.Lexer Namespace


LexStyles Properties

LexStyles Properties

The LexStyles type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILexStyle .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListILexStyle .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILexStyle .)
Top
See Also

Reference

LexStyles Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock Class

LexSyntaxBlock Class
Represents an individual syntax block in the collection of syntax blocks.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.LexerLexSyntaxBlock

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LexSyntaxBlock : ILexSyntaxBlock
Public Class LexSyntaxBlock
    Implements ILexSyntaxBlock
public ref class LexSyntaxBlock : ILexSyntaxBlock
type LexSyntaxBlock =
    class
        interface ILexSyntaxBlock
    end

The LexSyntaxBlock type exposes the following members.

Constructors
 | Name | Description
Public method | LexSyntaxBlock | Initializes a new instance of the LexSyntaxBlock class with default settings.
Public method | LexSyntaxBlock(ILexState) | Initializes a new instance of the LexSyntaxBlock class with specified owner.
Top
Methods
 | Name | Description
Public method | AddExpression | Adds new element to the expression collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindResword | Locates LexReswordSet containing given resword.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Gets or sets a value indicating whether ILexSyntaxBlock is case-sensitive or not.
Public property | Desc | Gets or sets description of the LexSyntaxBlock.
Public property | Expression | Represents a collective regular expression pattern for the LexSyntaxBlock.Expressions.
Public property | Expressions | Represents a list of regular expression patterns for the LexSyntaxBlock.Expressions.
Public property | Index | Represents index of the LexSyntaxBlock within the lexical syntax block collection.
Public property | LeaveState | Gets or sets ILexState object that specifies lexical resulting state after lexical analyzer locates text, that matches to the LexSyntaxBlock.Expression.
Public property | Name | Gets or sets name of the LexSyntaxBlock.
Public property | ReswordSets | Gets or sets collection of the ILexReswordSet object containing Reserved words.
Public property | SerializationInfo | Gets or sets an xml representation of this LexSyntaxBlock object.
Public property | State | Gets or sets ILexState owning this ILexSyntaxBlock
Public property | Style | Gets or sets an ILexStyle object, applicable for text that matches LexSyntaxBlock expression.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexSyntaxBlock Constructor

LexSyntaxBlock Constructor
Overload List
 | Name | Description
Public method | LexSyntaxBlock | Initializes a new instance of the LexSyntaxBlock class with default settings.
Public method | LexSyntaxBlock(ILexState) | Initializes a new instance of the LexSyntaxBlock class with specified owner.
Top
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock Constructor

LexSyntaxBlock Constructor
Initializes a new instance of the LexSyntaxBlock class with default settings.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexSyntaxBlock()
Public Sub New
public:
LexSyntaxBlock()
new : unit -> LexSyntaxBlock
See Also

Reference

LexSyntaxBlock Class
LexSyntaxBlock Overload
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock Constructor (ILexState)

LexSyntaxBlock Constructor (ILexState)
Initializes a new instance of the LexSyntaxBlock class with specified owner.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexSyntaxBlock(
    ILexState state
)
Public Sub New (
    state As ILexState
)
public:
LexSyntaxBlock(
    ILexState^ state
)
new :
        state : ILexState -> LexSyntaxBlock

Parameters

state
Type: Alternet.Syntax.LexerILexState
ILexState that owns this new instance.
See Also

Reference

LexSyntaxBlock Class
LexSyntaxBlock Overload
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock Methods

LexSyntaxBlock Methods

The LexSyntaxBlock type exposes the following members.

Methods
 | Name | Description
Public method | AddExpression | Adds new element to the expression collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindResword | Locates LexReswordSet containing given resword.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.AddExpression Method

LexSyntaxBlockAddExpression Method
Adds new element to the expression collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int AddExpression(
    string expression
)
Public Overridable Function AddExpression (
    expression As String
) As Integer
public:
virtual int AddExpression(
    String^ expression
)
abstract AddExpression :
        expression : string -> int
override AddExpression :
        expression : string -> int

Parameters

expression
Type: SystemString
Regular expression to add.

Return Value

Type: Int32
Index of added element in the expression collection.

Implements

ILexSyntaxBlockAddExpression(String)
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.FindResword Method

LexSyntaxBlockFindResword Method
Locates LexReswordSet containing given resword.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int FindResword(
    string resword
)
Public Overridable Function FindResword (
    resword As String
) As Integer
public:
virtual int FindResword(
    String^ resword
)
abstract FindResword :
        resword : string -> int
override FindResword :
        resword : string -> int

Parameters

resword
Type: SystemString
The resword to search for.

Return Value

Type: Int32
Index of LexReswordSet if resword collection contains specified resword; otherwise - 1.

Implements

ILexSyntaxBlockFindResword(String)
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock Properties

LexSyntaxBlock Properties

The LexSyntaxBlock type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Gets or sets a value indicating whether ILexSyntaxBlock is case-sensitive or not.
Public property | Desc | Gets or sets description of the LexSyntaxBlock.
Public property | Expression | Represents a collective regular expression pattern for the LexSyntaxBlock.Expressions.
Public property | Expressions | Represents a list of regular expression patterns for the LexSyntaxBlock.Expressions.
Public property | Index | Represents index of the LexSyntaxBlock within the lexical syntax block collection.
Public property | LeaveState | Gets or sets ILexState object that specifies lexical resulting state after lexical analyzer locates text, that matches to the LexSyntaxBlock.Expression.
Public property | Name | Gets or sets name of the LexSyntaxBlock.
Public property | ReswordSets | Gets or sets collection of the ILexReswordSet object containing Reserved words.
Public property | SerializationInfo | Gets or sets an xml representation of this LexSyntaxBlock object.
Public property | State | Gets or sets ILexState owning this ILexSyntaxBlock
Public property | Style | Gets or sets an ILexStyle object, applicable for text that matches LexSyntaxBlock expression.
Top
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.CaseSensitive Property

LexSyntaxBlockCaseSensitive Property
Gets or sets a value indicating whether ILexSyntaxBlock is case-sensitive or not.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CaseSensitive { get; set; }
Public Overridable Property CaseSensitive As Boolean
    Get
    Set
public:
virtual property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
abstract CaseSensitive : bool with get, set
override CaseSensitive : bool with get, set

Property Value

Type: Boolean

Implements

ILexSyntaxBlockCaseSensitive
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.Desc Property

LexSyntaxBlockDesc Property
Gets or sets description of the LexSyntaxBlock.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Desc { get; set; }
Public Overridable Property Desc As String
    Get
    Set
public:
virtual property String^ Desc {
    String^ get ();
    void set (String^ value);
}
abstract Desc : string with get, set
override Desc : string with get, set

Property Value

Type: String

Implements

ILexSyntaxBlockDesc
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.Expression Property

LexSyntaxBlockExpression Property
Represents a collective regular expression pattern for the LexSyntaxBlock.Expressions.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Expression { get; }
Public Overridable ReadOnly Property Expression As String
    Get
public:
virtual property String^ Expression {
    String^ get ();
}
abstract Expression : string with get
override Expression : string with get

Property Value

Type: String

Implements

ILexSyntaxBlockExpression
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.Expressions Property

LexSyntaxBlockExpressions Property
Represents a list of regular expression patterns for the LexSyntaxBlock.Expressions.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Expressions { get; set; }
Public Property Expressions As IList(Of String)
    Get
    Set
public:
virtual property IList<String^>^ Expressions {
    IList<String^>^ get () sealed;
    void set (IList<String^>^ value) sealed;
}
abstract Expressions : IList<string> with get, set
override Expressions : IList<string> with get, set

Property Value

Type: IListString

Implements

ILexSyntaxBlockExpressions
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.Index Property

LexSyntaxBlockIndex Property
Represents index of the LexSyntaxBlock within the lexical syntax block collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Index { get; }
Public Overridable ReadOnly Property Index As Integer
    Get
public:
virtual property int Index {
    int get ();
}
abstract Index : int with get
override Index : int with get

Property Value

Type: Int32

Implements

ILexSyntaxBlockIndex
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.LeaveState Property

LexSyntaxBlockLeaveState Property
Gets or sets ILexState object that specifies lexical resulting state after lexical analyzer locates text, that matches to the LexSyntaxBlock.Expression.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexState LeaveState { get; set; }
Public Overridable Property LeaveState As ILexState
    Get
    Set
public:
virtual property ILexState^ LeaveState {
    ILexState^ get ();
    void set (ILexState^ value);
}
abstract LeaveState : ILexState with get, set
override LeaveState : ILexState with get, set

Property Value

Type: ILexState

Implements

ILexSyntaxBlockLeaveState
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.Name Property

LexSyntaxBlockName Property
Gets or sets name of the LexSyntaxBlock.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ILexSyntaxBlockName
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.ReswordSets Property

LexSyntaxBlockReswordSets Property
Gets or sets collection of the ILexReswordSet object containing Reserved words.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexReswordSets ReswordSets { get; set; }
Public Overridable Property ReswordSets As ILexReswordSets
    Get
    Set
public:
virtual property ILexReswordSets^ ReswordSets {
    ILexReswordSets^ get ();
    void set (ILexReswordSets^ value);
}
abstract ReswordSets : ILexReswordSets with get, set
override ReswordSets : ILexReswordSets with get, set

Property Value

Type: ILexReswordSets

Implements

ILexSyntaxBlockReswordSets
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.SerializationInfo Property

LexSyntaxBlockSerializationInfo Property
Gets or sets an xml representation of this LexSyntaxBlock object.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISerializationInfo SerializationInfo { get; set; }
Public Overridable Property SerializationInfo As ISerializationInfo
    Get
    Set
public:
virtual property ISerializationInfo^ SerializationInfo {
    ISerializationInfo^ get ();
    void set (ISerializationInfo^ value);
}
abstract SerializationInfo : ISerializationInfo with get, set
override SerializationInfo : ISerializationInfo with get, set

Property Value

Type: ISerializationInfo

Implements

ILexSyntaxBlockSerializationInfo
Remarks
Normally, you do not need to use this property directly. It's used internally when serializing LexScheme's content to XML.
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.State Property

LexSyntaxBlockState Property
Gets or sets ILexState owning this ILexSyntaxBlock

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ILexState State { get; set; }
Public Property State As ILexState
    Get
    Set
public:
virtual property ILexState^ State {
    ILexState^ get () sealed;
    void set (ILexState^ value) sealed;
}
abstract State : ILexState with get, set
override State : ILexState with get, set

Property Value

Type: ILexState

Implements

ILexSyntaxBlockState
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlock.Style Property

LexSyntaxBlockStyle Property
Gets or sets an ILexStyle object, applicable for text that matches LexSyntaxBlock expression.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexStyle Style { get; set; }
Public Overridable Property Style As ILexStyle
    Get
    Set
public:
virtual property ILexStyle^ Style {
    ILexStyle^ get ();
    void set (ILexStyle^ value);
}
abstract Style : ILexStyle with get, set
override Style : ILexStyle with get, set

Property Value

Type: ILexStyle

Implements

ILexSyntaxBlockStyle
See Also

Reference

LexSyntaxBlock Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlocks Class

LexSyntaxBlocks Class
Provides an indexed access to individual ILexSyntaxBlock objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListILexSyntaxBlock
Alternet.Syntax.LexerLexSyntaxBlocks

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LexSyntaxBlocks : List<ILexSyntaxBlock>,
    ILexSyntaxBlocks, IList<ILexSyntaxBlock>, ICollection<ILexSyntaxBlock>,
    IEnumerable<ILexSyntaxBlock>, IEnumerable
Public Class LexSyntaxBlocks
    Inherits List(Of ILexSyntaxBlock)
    Implements ILexSyntaxBlocks, IList(Of ILexSyntaxBlock),
    ICollection(Of ILexSyntaxBlock), IEnumerable(Of ILexSyntaxBlock), IEnumerable
public ref class LexSyntaxBlocks : public List<ILexSyntaxBlock^>,
    ILexSyntaxBlocks, IList<ILexSyntaxBlock^>, ICollection<ILexSyntaxBlock^>,
    IEnumerable<ILexSyntaxBlock^>, IEnumerable
type LexSyntaxBlocks =
    class
        inherit List<ILexSyntaxBlock>
        interface ILexSyntaxBlocks
        interface IList<ILexSyntaxBlock>
        interface ICollection<ILexSyntaxBlock>
        interface IEnumerable<ILexSyntaxBlock>
        interface IEnumerable
    end

The LexSyntaxBlocks type exposes the following members.

Constructors
 | Name | Description
Public method | LexSyntaxBlocks | Initializes a new instance of the LexSyntaxBlocks class with specifies parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | AddLexSyntaxBlock | Creates new ILexSyntaxBlock and adds it to the LexSyntaxBlocks collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILexSyntaxBlock .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILexSyntaxBlock .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexSyntaxBlock .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexSyntaxBlock .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILexSyntaxBlock .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILexSyntaxBlock .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexSyntaxBlock .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexSyntaxBlock .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILexSyntaxBlock .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexSyntaxBlock .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexSyntaxBlock .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexSyntaxBlock .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | FindSyntaxBlock | Finds ILexSyntaxBlock by its name.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILexSyntaxBlock .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexSyntaxBlock .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexSyntaxBlock .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | InsertLexSyntaxBlock | Inserts a new item to the specified position within the ILexSyntaxBlocks collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexSyntaxBlock .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILexSyntaxBlock .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILexSyntaxBlock .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILexSyntaxBlock .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILexSyntaxBlock .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILexSyntaxBlock .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILexSyntaxBlock .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILexSyntaxBlock .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILexSyntaxBlock .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexSyntaxBlock | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexSyntaxBlock | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexSyntaxBlock, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILexSyntaxBlock .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListILexSyntaxBlock .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILexSyntaxBlock .)
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


LexSyntaxBlocks Constructor

LexSyntaxBlocks Constructor
Initializes a new instance of the LexSyntaxBlocks class with specifies parameters.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LexSyntaxBlocks(
    ILexState state
)
Public Sub New (
    state As ILexState
)
public:
LexSyntaxBlocks(
    ILexState^ state
)
new :
        state : ILexState -> LexSyntaxBlocks

Parameters

state
Type: Alternet.Syntax.LexerILexState
Specifies ILexState to which this new instance belongs.
See Also

Reference

LexSyntaxBlocks Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlocks Methods

LexSyntaxBlocks Methods

The LexSyntaxBlocks type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | AddLexSyntaxBlock | Creates new ILexSyntaxBlock and adds it to the LexSyntaxBlocks collection.
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListILexSyntaxBlock .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListILexSyntaxBlock .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexSyntaxBlock .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListILexSyntaxBlock .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListILexSyntaxBlock .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListILexSyntaxBlock .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexSyntaxBlock .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListILexSyntaxBlock .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListILexSyntaxBlock .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexSyntaxBlock .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexSyntaxBlock .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexSyntaxBlock .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | FindSyntaxBlock | Finds ILexSyntaxBlock by its name.
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListILexSyntaxBlock .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListILexSyntaxBlock .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListILexSyntaxBlock .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | InsertLexSyntaxBlock | Inserts a new item to the specified position within the ILexSyntaxBlocks collection.
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListILexSyntaxBlock .)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListILexSyntaxBlock .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListILexSyntaxBlock .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListILexSyntaxBlock .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListILexSyntaxBlock .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListILexSyntaxBlock .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListILexSyntaxBlock .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListILexSyntaxBlock .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListILexSyntaxBlock .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListILexSyntaxBlock .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListILexSyntaxBlock .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListILexSyntaxBlock .)
Top
Extension Methods
 | Name | Description
Public Extension Method | IndexOfILexSyntaxBlock | Finds the index of the first occurrence of an item in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | IndexOfFirstILexSyntaxBlock | Finds the index of the first item matching an expression in an enumerable. (Defined by EnumerableExtensions.)
Public Extension Method | MaxElementILexSyntaxBlock, TKey | Finds out element with maximum value in the container. (Defined by EnumerableExtensions.)
Top
See Also

Reference

LexSyntaxBlocks Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlocks.AddLexSyntaxBlock Method

LexSyntaxBlocksAddLexSyntaxBlock Method
Creates new ILexSyntaxBlock and adds it to the LexSyntaxBlocks collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexSyntaxBlock AddLexSyntaxBlock()
Public Overridable Function AddLexSyntaxBlock As ILexSyntaxBlock
public:
virtual ILexSyntaxBlock^ AddLexSyntaxBlock()
abstract AddLexSyntaxBlock : unit -> ILexSyntaxBlock
override AddLexSyntaxBlock : unit -> ILexSyntaxBlock

Return Value

Type: ILexSyntaxBlock
ILexSyntaxBlock that is added.

Implements

ILexSyntaxBlocksAddLexSyntaxBlock
See Also

Reference

LexSyntaxBlocks Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlocks.FindSyntaxBlock Method

LexSyntaxBlocksFindSyntaxBlock Method
Finds ILexSyntaxBlock by its name.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexSyntaxBlock FindSyntaxBlock(
    string name
)
Public Overridable Function FindSyntaxBlock (
    name As String
) As ILexSyntaxBlock
public:
virtual ILexSyntaxBlock^ FindSyntaxBlock(
    String^ name
)
abstract FindSyntaxBlock :
        name : string -> ILexSyntaxBlock
override FindSyntaxBlock :
        name : string -> ILexSyntaxBlock

Parameters

name
Type: SystemString
Specifies name of the ILexSyntaxBlock.

Return Value

Type: ILexSyntaxBlock
ILexSyntaxBlock that is found.

Implements

ILexSyntaxBlocksFindSyntaxBlock(String)
See Also

Reference

LexSyntaxBlocks Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlocks.InsertLexSyntaxBlock Method

LexSyntaxBlocksInsertLexSyntaxBlock Method
Inserts a new item to the specified position within the ILexSyntaxBlocks collection.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ILexSyntaxBlock InsertLexSyntaxBlock(
    int index
)
Public Overridable Function InsertLexSyntaxBlock (
    index As Integer
) As ILexSyntaxBlock
public:
virtual ILexSyntaxBlock^ InsertLexSyntaxBlock(
    int index
)
abstract InsertLexSyntaxBlock :
        index : int -> ILexSyntaxBlock
override InsertLexSyntaxBlock :
        index : int -> ILexSyntaxBlock

Parameters

index
Type: SystemInt32
Specifies position to insert.

Return Value

Type: ILexSyntaxBlock
ILexSyntaxBlock that is inserted.

Implements

ILexSyntaxBlocksInsertLexSyntaxBlock(Int32)
See Also

Reference

LexSyntaxBlocks Class
Alternet.Syntax.Lexer Namespace


LexSyntaxBlocks Properties

LexSyntaxBlocks Properties

The LexSyntaxBlocks type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListILexSyntaxBlock .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListILexSyntaxBlock .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListILexSyntaxBlock .)
Top
See Also

Reference

LexSyntaxBlocks Class
Alternet.Syntax.Lexer Namespace


LexToken Enumeration

LexToken Enumeration
Defines types of lexical token that represents result lexical analysis of each element within the text.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LexToken
Public Enumeration LexToken
public enum class LexToken
type LexToken
Members
Member name | Value | Description
Identifier | 0 | Specifies that lexical element represents identifier.
Number | 1 | Specifies that lexical element represents number.
Resword | 2 | Specifies that lexical element represents key word.
Comment | 3 | Specifies that lexical element represents comment.
XmlComment | 4 | Specifies that lexical element represents xml comment.
Symbol | 5 | Specifies that lexical element represents particular symbol.
Whitespace | 6 | Specifies that lexical element represents blank space between other lexical tokens.
String | 7 | Specifies that lexical element represents string literal.
Directive | 8 | Specifies that lexical element represents directive.
Include | 9 | Specifies that lexical element represents include header.
See Also

Reference

Alternet.Syntax.Lexer Namespace


ParseTextEvent Delegate

ParseTextEvent Delegate
Represents a method that will handle the ILexer.Parse event.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public delegate void ParseTextEvent(
    Object sender,
    ParseTextEventArgs e
)
Public Delegate Sub ParseTextEvent (
    sender As Object,
    e As ParseTextEventArgs
)
public delegate void ParseTextEvent(
    Object^ sender,
    ParseTextEventArgs^ e
)
type ParseTextEvent =
    delegate of
        sender : Object *
        e : ParseTextEventArgs -> unit

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Alternet.Syntax.LexerParseTextEventArgs
The ParseTextEventArgs that contains the event data.
See Also

Reference

Alternet.Syntax.Lexer Namespace


ParseTextEventArgs Class

ParseTextEventArgs Class
Provides data for the ILexer.TextParsed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Syntax.LexerParseTextEventArgs

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParseTextEventArgs : EventArgs
Public Class ParseTextEventArgs
    Inherits EventArgs
public ref class ParseTextEventArgs : public EventArgs
type ParseTextEventArgs =
    class
        inherit EventArgs
    end

The ParseTextEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ParseTextEventArgs | Initializes a new instance of the ParseTextEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ColorData | Represents color information for the parsed line.
Public property | String | Represents parsed text line.
Top
See Also

Reference

Alternet.Syntax.Lexer Namespace


ParseTextEventArgs Constructor

ParseTextEventArgs Constructor
Initializes a new instance of the ParseTextEventArgs class

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParseTextEventArgs()
Public Sub New
public:
ParseTextEventArgs()
new : unit -> ParseTextEventArgs
See Also

Reference

ParseTextEventArgs Class
Alternet.Syntax.Lexer Namespace


ParseTextEventArgs Methods

ParseTextEventArgs Methods

The ParseTextEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParseTextEventArgs Class
Alternet.Syntax.Lexer Namespace


ParseTextEventArgs Properties

ParseTextEventArgs Properties

The ParseTextEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ColorData | Represents color information for the parsed line.
Public property | String | Represents parsed text line.
Top
See Also

Reference

ParseTextEventArgs Class
Alternet.Syntax.Lexer Namespace


ParseTextEventArgs.ColorData Property

ParseTextEventArgsColorData Property
Represents color information for the parsed line.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringItemInfo[] ColorData { get; set; }
Public Property ColorData As StringItemInfo()
    Get
    Set
public:
property array<StringItemInfo>^ ColorData {
    array<StringItemInfo>^ get ();
    void set (array<StringItemInfo>^ value);
}
member ColorData : StringItemInfo[] with get, set

Property Value

Type: StringItemInfo
See Also

Reference

ParseTextEventArgs Class
Alternet.Syntax.Lexer Namespace


ParseTextEventArgs.String Property

ParseTextEventArgsString Property
Represents parsed text line.

Namespace: Alternet.Syntax.Lexer
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string String { get; set; }
Public Property String As String
    Get
    Set
public:
property String^ String {
    String^ get ();
    void set (String^ value);
}
member String : string with get, set

Property Value

Type: String
See Also

Reference

ParseTextEventArgs Class
Alternet.Syntax.Lexer Namespace


Alternet.Syntax.Parsers.Advanced Namespace

Alternet.Syntax.Parsers.Advanced Namespace
Classes
 | Class | Description
Public class | CParser | Represents class that and perform syntax and lexical analysis of specified Ansi-C code text.
Public class | CsParser | Represents class that and perform syntax and lexical analysis of specified C# code text.
Public class | CssParser |
Public class | HtmlScriptParser | Represents properties and methods to perform syntax analysis of specified html code text with script code fragments.
Public class | JavaScriptParser | Represents class that and perform syntax and lexical analysis of specified Java Script code text.
Public class | JScriptNETParser | Represents class that and perform syntax and lexical analysis of specified Java Script.NET code text.
Public class | JSONParser |
Public class | JsParser | Represents class that and perform syntax and lexical analysis of specified J# code text.
Public class | MSSQLParser | Represents class that and perform syntax and lexical analysis of specified Microsoft Sql code text.
Public class | NetSyntaxParser | Represents properties and methods to perform syntax analysis of the text intended to use for NET. family of languages.
Public class | SqlParser | Represents class that and perform syntax and lexical analysis of specified Sql code text.
Public class | SyntaxParserConsts | Contains default constants related to lexical and syntax analyzers.
Public class | VBAParser | Represents class that and perform syntax and lexical analysis of specified VBA code text.
Public class | VbParser | Represents class that and perform syntax and lexical analysis of specified Visual Basic.NET code text.
Public class | VbScriptParser | Represents class that and perform syntax and lexical analysis of specified Visual Basic Script code text.
Public class | XmlCommentParser | Represents properties and methods to perform syntax analysis of specified xml code text.
Public class | XmlLiteralParser | Represents properties and methods to perform syntax analysis of specified xml code text.
Public class | XmlParserWithSchema |
Enumerations
 | Enumeration | Description
Public enumeration | CLexerToken | Represents lexical tokens for C parser.
Public enumeration | CsLexerToken | Represents lexical tokens for C# parser.
Public enumeration | CssLexerToken |
Public enumeration | CssNodeType |
Public enumeration | FormatCase | Defines possible reswords formatting states.
Public enumeration | JavaScriptLexerToken | Represents lexical tokens for Java Script parser.
Public enumeration | JsLexerToken | Represents lexical tokens for J# parser.
Public enumeration | MsSqlLexerToken | Represents lexical tokens for MsSql parser.
Public enumeration | MsSqlNodeType | Defines types of syntax nodes used to create a hierarchical tree view that examines code text as a collection of syntax members. Intended to use with Sql language.
Public enumeration | SqlLexerToken | Represents lexical tokens for Sql parser.
Public enumeration | SqlNodeType | Defines types of syntax nodes used to create a hierarchical tree view that examines code text as a collection of syntax members. Intended to use with Sql language.
Public enumeration | VbALexerToken |
Public enumeration | VbLexerToken | Represents lexical tokens for Vb parser.
Public enumeration | VbScriptLexerToken | Represents lexical tokens for VB Script parser.


CLexerToken Enumeration

CLexerToken Enumeration
Represents lexical tokens for C parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CLexerToken
Public Enumeration CLexerToken
public enum class CLexerToken
type CLexerToken
Members
Member name | Value | Description
Auto | 0 |
Break | 1 |
Case | 2 |
Class | 3 |
Char | 4 |
Const | 5 |
Continue | 6 |
Default | 7 |
Do | 8 |
Double | 9 |
Else | 10 |
Enum | 11 |
Extern | 12 |
False | 13 |
Float | 14 |
For | 15 |
Goto | 16 |
If | 17 |
Inline | 18 |
Int | 19 |
Long | 20 |
Null | 21 |
Register | 22 |
Restrict | 23 |
Return | 24 |
Short | 25 |
Signed | 26 |
Sizeof | 27 |
Static | 28 |
Struct | 29 |
Switch | 30 |
True | 31 |
Typedef | 32 |
Union | 33 |
Unsigned | 34 |
Void | 35 |
Volatile | 36 |
While | 37 |
Attribute | 38 |
Bool | 39 |
Complex | 40 |
Imaginary | 41 |
Open_brace | 42 |
Close_brace | 43 |
Open_bracket | 44 |
Close_bracket | 45 |
Open_parens | 46 |
Close_parens | 47 |
Ellipsis | 48 |
Tilda | 49 |
Dot | 50 |
Comma | 51 |
Colon_shift_right | 52 |
Colon | 53 |
LineContinuation | 54 |
DblColon | 55 |
Semicolon | 56 |
Plus | 57 |
Minus | 58 |
Bang | 59 |
Assign | 60 |
Op_evro_assign | 61 |
Evro | 62 |
Op_lt | 63 |
Op_gt | 64 |
Bitwise_and | 65 |
Bitwise_or | 66 |
Sharp | 67 |
DblSharp | 68 |
Star | 69 |
Percent | 70 |
Exponent | 71 |
Div | 72 |
Interr | 73 |
DblInterr | 74 |
Op_percent_shift_right | 75 |
Op_Dbl_persent_colon | 76 |
Op_persent_colon | 77 |
Op_lt_persent | 78 |
Op_lt_colon | 79 |
Op_inc | 80 |
Op_dec | 81 |
Op_shift_left | 82 |
Op_shift_right | 83 |
Op_le | 84 |
Op_ge | 85 |
Op_eq | 86 |
Op_ne | 87 |
Op_and | 88 |
Op_or | 89 |
Op_mult_assign | 90 |
Op_exp_assign | 91 |
Op_div_assign | 92 |
Op_mod_assign | 93 |
Op_add_assign | 94 |
Op_sub_assign | 95 |
Op_shift_left_assign | 96 |
Op_shift_right_assign | 97 |
Op_and_assign | 98 |
Op_xor_assign | 99 |
Op_or_assign | 100 |
Op_ptr | 101 |
Integer_Literal | 102 |
Float_Literal | 103 |
Double_Literal | 104 |
Character_Literal | 105 |
String_Literal | 106 |
Identifier_Literal | 107 |
Comment_Literal | 108 |
XmlComment_Literal | 109 |
XmlInnerComment_Literal | 110 |
Directive_Literal | 111 |
Whitespace_Literal | 112 |
H_Char_Literal | 113 |
Q_Char_Literal | 114 |
Region_Literal | 115 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


CParser Class

CParser Class
Represents class that and perform syntax and lexical analysis of specified Ansi-C code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedCParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CParser : SyntaxParser
Public Class CParser
    Inherits SyntaxParser
public ref class CParser : public SyntaxParser
type CParser =
    class
        inherit SyntaxParser
    end

The CParser type exposes the following members.

Constructors
 | Name | Description
Public method | CParser | Initializes a new instance of the CParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Overrides SyntaxParserFinishParsing.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Overrides SyntaxParserGetAutoFormatNode(Point, Boolean, Point).)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitBoolExtension | Enables usage of bool, true and false as reserved words.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides SyntaxParserIsDeclaration(ISyntaxNode).)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, Int32, Int32, Int32).)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Resets Parser to the start position. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Overrides SyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Overrides SyntaxParserExpressionEvaluator.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


CParser Constructor

CParser Constructor
Initializes a new instance of the CParser class

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CParser()
Public Sub New
public:
CParser()
new : unit -> CParser
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser Methods

CParser Methods

The CParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Overrides SyntaxParserFinishParsing.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Overrides SyntaxParserGetAutoFormatNode(Point, Boolean, Point).)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitBoolExtension | Enables usage of bool, true and false as reserved words.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides SyntaxParserIsDeclaration(ISyntaxNode).)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, Int32, Int32, Int32).)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Resets Parser to the start position. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Overrides SyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.CreateRepository Method

CParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.FinishParsing Method

CParserFinishParsing Method
Commits parsing process.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FinishParsing()
Public Overrides Sub FinishParsing
public:
virtual void FinishParsing() override
abstract FinishParsing : unit -> unit
override FinishParsing : unit -> unit

Implements

ISyntaxParserFinishParsing
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.GetAutoFormatNode Method

CParserGetAutoFormatNode Method
Obtains block node at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISyntaxNode GetAutoFormatNode(
    Point position,
    bool extended,
    out Point startPt
)
Public Overrides Function GetAutoFormatNode (
    position As Point,
    extended As Boolean,
    <OutAttribute> ByRef startPt As Point
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetAutoFormatNode(
    Point position,
    bool extended,
    [OutAttribute] Point% startPt
) override
abstract GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode
override GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode

Parameters

position
Type: System.DrawingPoint
Position to check-up.
extended
Type: SystemBoolean
Specifies that search should be extended outside current scope.
startPt
Type: System.DrawingPoint
Retrieves position of block node.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.

Implements

ISyntaxParserGetAutoFormatNode(Point, Boolean, Point)
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.GetCompletionType Method

CParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.GetCompletionType Method (Char)

CParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

CParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser.GetSingleLineComment Method

CParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.GetSingleLineComment Method

CParserGetSingleLineComment Method
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

CParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser.GetStructureGuideLines Method

CParserGetStructureGuideLines Method
Gets list of guide lines.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetStructureGuideLines(
    IList<IRange> guideLines
)
Public Overrides Function GetStructureGuideLines (
    guideLines As IList(Of IRange)
) As Integer
public:
virtual int GetStructureGuideLines(
    IList<IRange^>^ guideLines
) override
abstract GetStructureGuideLines :
        guideLines : IList<IRange> -> int
override GetStructureGuideLines :
        guideLines : IList<IRange> -> int

Parameters

guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.

Implements

ISyntaxParserGetStructureGuideLines(IListIRange)
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.InitBoolExtension Method

CParserInitBoolExtension Method
Enables usage of bool, true and false as reserved words.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void InitBoolExtension()
Public Overridable Sub InitBoolExtension
public:
virtual void InitBoolExtension()
abstract InitBoolExtension : unit -> unit
override InitBoolExtension : unit -> unit
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.IsDeclaration Method

CParserIsDeclaration Method
Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsDeclaration(
    ISyntaxNode node
)
Public Overrides Function IsDeclaration (
    node As ISyntaxNode
) As Boolean
public:
virtual bool IsDeclaration(
    ISyntaxNode^ node
) override
abstract IsDeclaration :
        node : ISyntaxNode -> bool
override IsDeclaration :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is declaration node; otherwise false.

Implements

ISyntaxParserIsDeclaration(ISyntaxNode)
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.NextToken Method

CParserNextToken Method
Overload List
 | Name | Description
Public method | NextToken | (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.NextToken Method

CParserNextToken Method

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int NextToken()
Public Overrides Function NextToken As Integer
public:
virtual int NextToken() override
abstract NextToken : unit -> int
override NextToken : unit -> int

Return Value

Type: Int32

Implements

IParserNextToken
See Also

Reference

CParser Class
NextToken Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ParseText Method

CParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, Int32, Int32, Int32).)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

CParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

CParser Class
ParseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ParseText Method (Int32, Int32, String, Int32, Int32, Int32)

CParserParseText Method (Int32, Int32, String, Int32, Int32, Int32)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string s,
    ref int pos,
    ref int len,
    ref int token
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    s As String,
    ByRef pos As Integer,
    ByRef len As Integer,
    ByRef token As Integer
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ s,
    int% pos,
    int% len,
    int% token
) override
abstract ParseText :
        state : int *
        line : int *
        s : string *
        pos : int byref *
        len : int byref *
        token : int byref -> int
override ParseText :
        state : int *
        line : int *
        s : string *
        pos : int byref *
        len : int byref *
        token : int byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
s
Type: SystemString
Text to analyze.
pos
Type: SystemInt32
Starting position.
len
Type: SystemInt32
Integer value to receive length of parsed element.
token
Type: SystemInt32
Retrieves style of text being parsed.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, Int32, Int32, Int32)
ILexerParseText(Int32, Int32, String, Int32, Int32, Int32)
See Also

Reference

CParser Class
ParseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser.PositionChanged Method

CParserPositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overrides Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
) override
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxParserPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ReparseBlock Method

CParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ReparseBlock Method (Point)

CParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    Point position
)
Public Overrides Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
) override
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

CParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ReparseText Method

CParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Resets Parser to the start position. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ReparseText Method

CParserReparseText Method
Resets Parser to the start position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

CParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser.Reset Method

CParserReset Method
Overload List
 | Name | Description
Public method | Reset | (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.Reset Method

CParserReset Method

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
IParserReset
See Also

Reference

CParser Class
Reset Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ResetAutoIndentChars Method

CParserResetAutoIndentChars Method
Resets the AutoIndentChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ResetCodeCompletionChars Method

CParserResetCodeCompletionChars Method
Resets the CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ResetCodeCompletionStopChars Method

CParserResetCodeCompletionStopChars Method
Resets the CodeCompletionStopChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionStopChars()
Public Overrides Sub ResetCodeCompletionStopChars
public:
virtual void ResetCodeCompletionStopChars() override
abstract ResetCodeCompletionStopChars : unit -> unit
override ResetCodeCompletionStopChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionStopChars
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ResetOptions Method

CParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ResetSmartFormatChars Method

CParserResetSmartFormatChars Method
Resets the SmartFormatChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetSmartFormatChars()
Public Overrides Sub ResetSmartFormatChars
public:
virtual void ResetSmartFormatChars() override
abstract ResetSmartFormatChars : unit -> unit
override ResetSmartFormatChars : unit -> unit

Implements

ISyntaxParserResetSmartFormatChars
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.RestoreState Method

CParserRestoreState Method
Overload List
 | Name | Description
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.RestoreState Method (Boolean)

CParserRestoreState Method (Boolean)
Restores Parser state and position stored by SaveState method.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void RestoreState(
    bool restore
)
Public Overrides Sub RestoreState (
    restore As Boolean
)
public:
virtual void RestoreState(
    bool restore
) override
abstract RestoreState :
        restore : bool -> unit
override RestoreState :
        restore : bool -> unit

Parameters

restore
Type: SystemBoolean

Implements

IParserRestoreState(Boolean)
See Also

Reference

CParser Class
RestoreState Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser.SaveState Method

CParserSaveState Method
Saves current Parser state and position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void SaveState()
Public Overrides Sub SaveState
public:
virtual void SaveState() override
abstract SaveState : unit -> unit
override SaveState : unit -> unit

Implements

IParserSaveState
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ShouldSerializeAutoIndentChars Method

CParserShouldSerializeAutoIndentChars Method
Indicates whether the AutoIndentChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeAutoIndentChars()
Public Overrides Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars() override
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if AutoIndentChars differs from its default value; otherwise false.
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ShouldSerializeCodeCompletionChars Method

CParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ShouldSerializeCodeCompletionStopChars Method

CParserShouldSerializeCodeCompletionStopChars Method
Indicates whether the CodeCompletionStopChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionStopChars()
Public Overrides Function ShouldSerializeCodeCompletionStopChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionStopChars() override
abstract ShouldSerializeCodeCompletionStopChars : unit -> bool
override ShouldSerializeCodeCompletionStopChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionStopChars differs from its default value; otherwise false.
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ShouldSerializeOptions Method

CParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ShouldSerializeSmartFormatChars Method

CParserShouldSerializeSmartFormatChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeSmartFormatChars()
Public Overrides Function ShouldSerializeSmartFormatChars As Boolean
public:
virtual bool ShouldSerializeSmartFormatChars() override
abstract ShouldSerializeSmartFormatChars : unit -> bool
override ShouldSerializeSmartFormatChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.SmartFormatLine Method

CParserSmartFormatLine Method
Overload List
 | Name | Description
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList, Boolean)

CParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList, Boolean)
Formats line according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations,
    out bool actualPosition
)
Public Overrides Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations,
    [OutAttribute] bool% actualPosition
) override
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int
override SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at given line.

Implements

ISyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean)
See Also

Reference

CParser Class
SmartFormatLine Overload
Alternet.Syntax.Parsers.Advanced Namespace


CParser Properties

CParser Properties

The CParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Overrides SyntaxParserExpressionEvaluator.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.CaseSensitive Property

CParserCaseSensitive Property
Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser.ExpressionEvaluator Property

CParserExpressionEvaluator Property

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IExpressionEvaluator ExpressionEvaluator { get; set; }
Public Overrides Property ExpressionEvaluator As IExpressionEvaluator
    Get
    Set
public:
virtual property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get () override;
    void set (IExpressionEvaluator^ value) override;
}
abstract ExpressionEvaluator : IExpressionEvaluator with get, set
override ExpressionEvaluator : IExpressionEvaluator with get, set

Property Value

Type: IExpressionEvaluator

Implements

ISyntaxParserExpressionEvaluator
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CParser Events

CParser Events

The CParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsLexerToken Enumeration

CsLexerToken Enumeration
Represents lexical tokens for C# parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CsLexerToken
Public Enumeration CsLexerToken
public enum class CsLexerToken
type CsLexerToken
Members
Member name | Value | Description
Unit | 0 |
Abstract | 1 |
As | 2 |
Async | 3 |
Add | 4 |
Assembly | 5 |
Await | 6 |
Base | 7 |
Bool | 8 |
Break | 9 |
Byte | 10 |
Case | 11 |
Catch | 12 |
Char | 13 |
Checked | 14 |
Class | 15 |
Consts | 16 |
Continue | 17 |
Decimal | 18 |
Default | 19 |
Delegate | 20 |
Do | 21 |
Double | 22 |
Dynamic | 23 |
Else | 24 |
Enum | 25 |
Event | 26 |
Explicit | 27 |
Extern | 28 |
False | 29 |
Finally | 30 |
Fixed | 31 |
Float | 32 |
For | 33 |
Foreach | 34 |
Goto | 35 |
If | 36 |
Implicit | 37 |
In | 38 |
Int | 39 |
Interface | 40 |
Internal | 41 |
Is | 42 |
Lock | 43 |
Long | 44 |
Nameof | 45 |
Namespace | 46 |
New | 47 |
Null | 48 |
Object | 49 |
Operator | 50 |
Out | 51 |
Override | 52 |
Params | 53 |
Private | 54 |
Protected | 55 |
Public | 56 |
Readonly | 57 |
Ref | 58 |
Return | 59 |
Remove | 60 |
Sbyte | 61 |
Sealed | 62 |
Short | 63 |
Sizeof | 64 |
Stackalloc | 65 |
Static | 66 |
String | 67 |
Struct | 68 |
Switch | 69 |
This | 70 |
Throw | 71 |
True | 72 |
Try | 73 |
Typeof | 74 |
Uint | 75 |
Ulong | 76 |
Unchecked | 77 |
Unsafe | 78 |
Ushort | 79 |
Using | 80 |
Virtual | 81 |
Void | 82 |
Volatile | 83 |
While | 84 |
ArgList | 85 |
Partial | 86 |
Where | 87 |
Yield | 88 |
Value | 89 |
Alias | 90 |
Global | 91 |
Var | 92 |
Select | 93 |
From | 94 |
Join | 95 |
Group | 96 |
By | 97 |
OrderBy | 98 |
On | 99 |
Equals | 100 |
Into | 101 |
Let | 102 |
Ascending | 103 |
Descending | 104 |
When | 105 |
Get | 106 |
Set | 107 |
Open_brace | 108 |
Close_brace | 109 |
Open_bracket | 110 |
Close_bracket | 111 |
Open_parens | 112 |
Close_parens | 113 |
Dot | 114 |
Comma | 115 |
Colon | 116 |
DblColon | 117 |
Semicolon | 118 |
Tilde | 119 |
Plus | 120 |
Minus | 121 |
Bang | 122 |
Assign | 123 |
Op_lt | 124 |
Op_gt | 125 |
Bitwise_and | 126 |
Bitwise_or | 127 |
Star | 128 |
Percent | 129 |
Div | 130 |
Carret | 131 |
Interr | 132 |
DblInterr | 133 |
Op_inc | 134 |
Op_dec | 135 |
Op_shift_left | 136 |
Op_shift_right | 137 |
Op_le | 138 |
Op_ge | 139 |
Op_eq | 140 |
Op_ne | 141 |
Op_and | 142 |
Op_or | 143 |
Op_mult_assign | 144 |
Op_div_assign | 145 |
Op_mod_assign | 146 |
Op_add_assign | 147 |
Op_sub_assign | 148 |
Op_shift_left_assign | 149 |
Op_shift_right_assign | 150 |
Op_and_assign | 151 |
Op_xor_assign | 152 |
Op_or_assign | 153 |
Op_ptr | 154 |
Lambda | 155 |
XmlComment | 156 |
Integer_Literal | 157 |
Float_Literal | 158 |
Double_Literal | 159 |
Decimal_Literal | 160 |
Character_Literal | 161 |
String_Literal | 162 |
Identifier_Literal | 163 |
Comment_Literal | 164 |
XmlComment_Literal | 165 |
XmlInnerComment_Literal | 166 |
Directive_Literal | 167 |
Whitespace_Literal | 168 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


CsParser Class

CsParser Class
Represents class that and perform syntax and lexical analysis of specified C# code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedNetSyntaxParser
Alternet.Syntax.Parsers.AdvancedCsParser
Alternet.Syntax.Parsers.AdvancedJsParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CsParser : NetSyntaxParser
Public Class CsParser
    Inherits NetSyntaxParser
public ref class CsParser : public NetSyntaxParser
type CsParser =
    class
        inherit NetSyntaxParser
    end

The CsParser type exposes the following members.

Constructors
 | Name | Description
Public method | CsParser | Initializes a new instance of the CsParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from NetSyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides NetSyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from NetSyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from NetSyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NetSyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides NetSyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from NetSyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from NetSyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Overrides NetSyntaxParserGetXmlComment.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NetSyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, Int32, Int32, Int32).)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from NetSyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from NetSyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterObject | Adds specified object for code completion to the repository's object list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from NetSyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides NetSyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | (Overrides NetSyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Overrides NetSyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides NetSyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Overrides NetSyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from NetSyntaxParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from NetSyntaxParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from NetSyntaxParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides NetSyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides NetSyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides NetSyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from NetSyntaxParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from NetSyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterNamespace | Removes specified namespace from the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | UnregisterObject | Removes specified object from the repository's object list. (Inherited from NetSyntaxParser.)
Public method | UnregisterType | Removes specified type from the repository's type list. (Inherited from NetSyntaxParser.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content. (Inherited from NetSyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Inherited from NetSyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


CsParser Constructor

CsParser Constructor
Initializes a new instance of the CsParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsParser()
Public Sub New
public:
CsParser()
new : unit -> CsParser
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser Methods

CsParser Methods

The CsParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from NetSyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides NetSyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from NetSyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from NetSyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NetSyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides NetSyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from NetSyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from NetSyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Overrides NetSyntaxParserGetXmlComment.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NetSyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, Int32, Int32, Int32).)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from NetSyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from NetSyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterObject | Adds specified object for code completion to the repository's object list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from NetSyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides NetSyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | (Overrides NetSyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Overrides NetSyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides NetSyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Overrides NetSyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from NetSyntaxParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from NetSyntaxParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from NetSyntaxParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides NetSyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides NetSyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides NetSyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from NetSyntaxParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from NetSyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterNamespace | Removes specified namespace from the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | UnregisterObject | Removes specified object from the repository's object list. (Inherited from NetSyntaxParser.)
Public method | UnregisterType | Removes specified type from the repository's type list. (Inherited from NetSyntaxParser.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.CreateRepository Method

CsParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.GetCompletionType Method

CsParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides NetSyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.GetCompletionType Method (Char)

CsParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

CsParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.GetSingleLineComment Method

CsParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.GetSingleLineComment Method

CsParserGetSingleLineComment Method
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

CsParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.GetXmlComment Method

CsParserGetXmlComment Method
Gets the string that represents start symbols of xml comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetXmlComment()
Public Overrides Function GetXmlComment As String
public:
virtual String^ GetXmlComment() override
abstract GetXmlComment : unit -> string
override GetXmlComment : unit -> string

Return Value

Type: String
Xml comment string.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.IsCodeCompletionChar Method

CsParserIsCodeCompletionChar Method
Returns boolean value indicating that given character initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Public Overrides Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
public:
virtual bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
) override
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool
override IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
Given character.
style
Type: SystemByte
Specifies text style at cursor.
interval
Type: SystemInt32
Represents the delay, in milliseconds before displaying code completion window.

Return Value

Type: Boolean
True if given character is code completion character; otherwise false.

Implements

ISyntaxParserIsCodeCompletionChar(Char, Byte, Int32)
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ParseText Method

CsParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, Int32, Int32, Int32).)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

CsParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

CsParser Class
ParseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ParseText Method (Int32, Int32, String, Int32, Int32, Int32)

CsParserParseText Method (Int32, Int32, String, Int32, Int32, Int32)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string s,
    ref int pos,
    ref int len,
    ref int token
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    s As String,
    ByRef pos As Integer,
    ByRef len As Integer,
    ByRef token As Integer
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ s,
    int% pos,
    int% len,
    int% token
) override
abstract ParseText :
        state : int *
        line : int *
        s : string *
        pos : int byref *
        len : int byref *
        token : int byref -> int
override ParseText :
        state : int *
        line : int *
        s : string *
        pos : int byref *
        len : int byref *
        token : int byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
s
Type: SystemString
Text to analyze.
pos
Type: SystemInt32
Starting position.
len
Type: SystemInt32
Integer value to receive length of parsed element.
token
Type: SystemInt32
Retrieves style of text being parsed.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, Int32, Int32, Int32)
ILexerParseText(Int32, Int32, String, Int32, Int32, Int32)
See Also

Reference

CsParser Class
ParseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ReparseText Method

CsParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides NetSyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ReparseText Method

CsParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

CsParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.Reset Method

CsParserReset Method
Overload List
 | Name | Description
Public method | Reset | (Overrides NetSyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.Reset Method

CsParserReset Method

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
IParserReset
See Also

Reference

CsParser Class
Reset Overload
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ResetAutoIndentChars Method

CsParserResetAutoIndentChars Method
Resets the AutoIndentChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ResetCodeCompletionChars Method

CsParserResetCodeCompletionChars Method
Resets the CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ResetCodeCompletionStopChars Method

CsParserResetCodeCompletionStopChars Method
Resets the CodeCompletionStopChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionStopChars()
Public Overrides Sub ResetCodeCompletionStopChars
public:
virtual void ResetCodeCompletionStopChars() override
abstract ResetCodeCompletionStopChars : unit -> unit
override ResetCodeCompletionStopChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionStopChars
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ResetSmartFormatChars Method

CsParserResetSmartFormatChars Method
Resets the SmartFormatChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetSmartFormatChars()
Public Overrides Sub ResetSmartFormatChars
public:
virtual void ResetSmartFormatChars() override
abstract ResetSmartFormatChars : unit -> unit
override ResetSmartFormatChars : unit -> unit

Implements

ISyntaxParserResetSmartFormatChars
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ShouldSerializeAutoIndentChars Method

CsParserShouldSerializeAutoIndentChars Method
Indicates whether the AutoIndentChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeAutoIndentChars()
Public Overrides Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars() override
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if AutoIndentChars differs from its default value; otherwise false.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ShouldSerializeCodeCompletionChars Method

CsParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ShouldSerializeCodeCompletionStopChars Method

CsParserShouldSerializeCodeCompletionStopChars Method
Indicates whether the CodeCompletionStopChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionStopChars()
Public Overrides Function ShouldSerializeCodeCompletionStopChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionStopChars() override
abstract ShouldSerializeCodeCompletionStopChars : unit -> bool
override ShouldSerializeCodeCompletionStopChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionStopChars differs from its default value; otherwise false.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser.ShouldSerializeSmartFormatChars Method

CsParserShouldSerializeSmartFormatChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeSmartFormatChars()
Public Overrides Function ShouldSerializeSmartFormatChars As Boolean
public:
virtual bool ShouldSerializeSmartFormatChars() override
abstract ShouldSerializeSmartFormatChars : unit -> bool
override ShouldSerializeSmartFormatChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser Properties

CsParser Properties

The CsParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content. (Inherited from NetSyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Inherited from NetSyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CsParser Events

CsParser Events

The CsParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CssLexerToken Enumeration

CssLexerToken Enumeration

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CssLexerToken
Public Enumeration CssLexerToken
public enum class CssLexerToken
type CssLexerToken
Members
Member name | Value | Description
Open_brace | 17 |
Close_brace | 18 |
Dot | 19 |
Colon | 20 |
Semicolon | 21 |
PropertyName | 22 |
PropertyValue | 23 |
Identifier_Literal | 24 |
Comment_Literal | 25 |
Whitespace_Literal | 26 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


CssNodeType Enumeration

CssNodeType Enumeration

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CssNodeType
Public Enumeration CssNodeType
public enum class CssNodeType
type CssNodeType
Members
Member name | Value | Description
Unit | 253 |
Object | 254 |
Property | 255 |
Value | 256 |
Comment | 257 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


CssParser Class

CssParser Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedCssParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CssParser : SyntaxParser
Public Class CssParser
    Inherits SyntaxParser
public ref class CssParser : public SyntaxParser
type CssParser =
    class
        inherit SyntaxParser
    end

The CssParser type exposes the following members.

Constructors
 | Name | Description
Public method | CssParser | Initializes a new instance of the CssParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from SyntaxParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from SyntaxParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


CssParser Constructor

CssParser Constructor
Initializes a new instance of the CssParser class

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CssParser()
Public Sub New
public:
CssParser()
new : unit -> CssParser
See Also

Reference

CssParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CssParser Methods

CssParser Methods

The CssParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from SyntaxParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from SyntaxParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CssParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CssParser.ReparseText Method

CssParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

CssParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CssParser.ReparseText Method

CssParserReparseText Method

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

CssParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


CssParser Properties

CssParser Properties

The CssParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CssParser Class
Alternet.Syntax.Parsers.Advanced Namespace


CssParser Events

CssParser Events

The CssParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CssParser Class
Alternet.Syntax.Parsers.Advanced Namespace


FormatCase Enumeration

FormatCase Enumeration
Defines possible reswords formatting states.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FormatCase
Public Enumeration FormatCase
public enum class FormatCase
type FormatCase
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Upper | 1 | Reswords should be formatted to the upper-case.
Lower | 2 | Reswords should be formatted to the lower-case.
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser Class

HtmlScriptParser Class
Represents properties and methods to perform syntax analysis of specified html code text with script code fragments.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.SyntaxXmlParser
Alternet.SyntaxHtmlParser
Alternet.Syntax.Parsers.AdvancedHtmlScriptParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class HtmlScriptParser : HtmlParser
<SerializableAttribute>
Public Class HtmlScriptParser
    Inherits HtmlParser
[SerializableAttribute]
public ref class HtmlScriptParser : public HtmlParser
[<SerializableAttribute>]
type HtmlScriptParser =
    class
        inherit HtmlParser
    end

The HtmlScriptParser type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlScriptParser | Initializes a new instance of the HtmlScriptParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs).)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides XmlParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Overrides XmlParserGetMultiLineComment(String, String).)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Overrides SyntaxParserGetMultiLineComment(Point, String, String).)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment(Point).)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, Int32, Int32, Int32).)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from XmlParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to it's default value. (Inherited from HtmlParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides XmlParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides XmlParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from HtmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser Constructor

HtmlScriptParser Constructor
Initializes a new instance of the HtmlScriptParser class

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public HtmlScriptParser()
Public Sub New
public:
HtmlScriptParser()
new : unit -> HtmlScriptParser
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser Methods

HtmlScriptParser Methods

The HtmlScriptParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs).)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides XmlParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Overrides XmlParserGetMultiLineComment(String, String).)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Overrides SyntaxParserGetMultiLineComment(Point, String, String).)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment(Point).)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, Int32, Int32, Int32).)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from XmlParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to it's default value. (Inherited from HtmlParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides XmlParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides XmlParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.CodeCompletion Method

HtmlScriptParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs).)
Top
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.CodeCompletion Method (String, StringItemInfo[], Point, Boolean, CodeCompletionArgs)

HtmlScriptParserCodeCompletion Method (String, StringItemInfo, Point, Boolean, CodeCompletionArgs)

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    bool useThread,
    CodeCompletionArgs e
)
Public Overrides Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    useThread As Boolean,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    bool useThread,
    CodeCompletionArgs^ e
) override
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        useThread : bool *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        useThread : bool *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
textData
Type: Alternet.SyntaxStringItemInfo
position
Type: System.DrawingPoint
useThread
Type: SystemBoolean
e
Type: Alternet.SyntaxCodeCompletionArgs

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs)
See Also

Reference

HtmlScriptParser Class
CodeCompletion Overload
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.GetCompletionType Method

HtmlScriptParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides XmlParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.GetCompletionType Method (Char)

HtmlScriptParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

HtmlScriptParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.GetMultiLineComment Method

HtmlScriptParserGetMultiLineComment Method
Overload List
 | Name | Description
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Overrides XmlParserGetMultiLineComment(String, String).)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Overrides SyntaxParserGetMultiLineComment(Point, String, String).)
Top
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.GetMultiLineComment Method (String, String)

HtmlScriptParserGetMultiLineComment Method (String, String)
Gets the start and symbols multi-line comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool GetMultiLineComment(
    out string start,
    out string end
)
Public Overrides Function GetMultiLineComment (
    <OutAttribute> ByRef start As String,
    <OutAttribute> ByRef end As String
) As Boolean
public:
virtual bool GetMultiLineComment(
    [OutAttribute] String^% start,
    [OutAttribute] String^% end
) override
abstract GetMultiLineComment :
        start : string byref *
        end : string byref -> bool
override GetMultiLineComment :
        start : string byref *
        end : string byref -> bool

Parameters

start
Type: SystemString
Start symbol of multi-line comment.
end
Type: SystemString
End symbol of multi-line comment.

Return Value

Type: Boolean
True if parser supports multi-line comment; otherwise false.

Implements

ISyntaxParserGetMultiLineComment(String, String)
See Also

Reference

HtmlScriptParser Class
GetMultiLineComment Overload
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.GetMultiLineComment Method (Point, String, String)

HtmlScriptParserGetMultiLineComment Method (Point, String, String)
Gets the start and symbols multi-line comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool GetMultiLineComment(
    Point pos,
    out string start,
    out string end
)
Public Overrides Function GetMultiLineComment (
    pos As Point,
    <OutAttribute> ByRef start As String,
    <OutAttribute> ByRef end As String
) As Boolean
public:
virtual bool GetMultiLineComment(
    Point pos,
    [OutAttribute] String^% start,
    [OutAttribute] String^% end
) override
abstract GetMultiLineComment :
        pos : Point *
        start : string byref *
        end : string byref -> bool
override GetMultiLineComment :
        pos : Point *
        start : string byref *
        end : string byref -> bool

Parameters

pos
Type: System.DrawingPoint
Position to check.
start
Type: SystemString
Start symbol of multi-line comment.
end
Type: SystemString
End symbol of multi-line comment.

Return Value

Type: Boolean
True if parser supports multi-line comment; otherwise false.

Implements

ISyntaxParserGetMultiLineComment(Point, String, String)
See Also

Reference

HtmlScriptParser Class
GetMultiLineComment Overload
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.GetSingleLineComment Method

HtmlScriptParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment(Point).)
Top
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.GetSingleLineComment Method (Point)

HtmlScriptParserGetSingleLineComment Method (Point)
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment(
    Point pos
)
Public Overrides Function GetSingleLineComment (
    pos As Point
) As String
public:
virtual String^ GetSingleLineComment(
    Point pos
) override
abstract GetSingleLineComment :
        pos : Point -> string
override GetSingleLineComment :
        pos : Point -> string

Parameters

pos
Type: System.DrawingPoint
Position to check.

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment(Point)
See Also

Reference

HtmlScriptParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.ParseText Method

HtmlScriptParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, Int32, Int32, Int32).)
Top
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.ParseText Method (Int32, Int32, String, Int32, Int32, Int32)

HtmlScriptParserParseText Method (Int32, Int32, String, Int32, Int32, Int32)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string s,
    ref int pos,
    ref int len,
    ref int token
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    s As String,
    ByRef pos As Integer,
    ByRef len As Integer,
    ByRef token As Integer
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ s,
    int% pos,
    int% len,
    int% token
) override
abstract ParseText :
        state : int *
        line : int *
        s : string *
        pos : int byref *
        len : int byref *
        token : int byref -> int
override ParseText :
        state : int *
        line : int *
        s : string *
        pos : int byref *
        len : int byref *
        token : int byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
s
Type: SystemString
Text to analyze.
pos
Type: SystemInt32
Starting position.
len
Type: SystemInt32
Integer value to receive length of parsed element.
token
Type: SystemInt32
Retrieves style of text being parsed.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, Int32, Int32, Int32)
ILexerParseText(Int32, Int32, String, Int32, Int32, Int32)
See Also

Reference

HtmlScriptParser Class
ParseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.ReparseBlock Method

HtmlScriptParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Top
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.ReparseBlock Method (Point)

HtmlScriptParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    Point position
)
Public Overrides Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
) override
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

HtmlScriptParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.ResetOptions Method

HtmlScriptParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser.ShouldSerializeOptions Method

HtmlScriptParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser Properties

HtmlScriptParser Properties

The HtmlScriptParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from HtmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


HtmlScriptParser Events

HtmlScriptParser Events

The HtmlScriptParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

HtmlScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptLexerToken Enumeration

JavaScriptLexerToken Enumeration
Represents lexical tokens for Java Script parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum JavaScriptLexerToken
Public Enumeration JavaScriptLexerToken
public enum class JavaScriptLexerToken
type JavaScriptLexerToken
Members
Member name | Value | Description
Abstract | 0 |
Array | 1 |
Assert | 2 |
Boolean | 3 |
Break | 4 |
Byte | 5 |
Case | 6 |
Catch | 7 |
Char | 8 |
Class | 9 |
Const | 10 |
Continue | 11 |
Debugger | 12 |
Default | 13 |
Delegate | 14 |
Delete | 15 |
Do | 16 |
Double | 17 |
Else | 18 |
Enum | 19 |
Eval | 20 |
Export | 21 |
Extends | 22 |
False | 23 |
Field | 24 |
Final | 25 |
Finally | 26 |
Float | 27 |
For | 28 |
Function | 29 |
Goto | 30 |
If | 31 |
Implements | 32 |
Import | 33 |
In | 34 |
Instanceof | 35 |
Int | 36 |
Interface | 37 |
Long | 38 |
Multicast | 39 |
Native | 40 |
New | 41 |
Null | 42 |
Number | 43 |
Object | 44 |
Package | 45 |
Private | 46 |
Protected | 47 |
Public | 48 |
Return | 49 |
Short | 50 |
Static | 51 |
Strictfp | 52 |
String | 53 |
Super | 54 |
Switch | 55 |
Synchronized | 56 |
This | 57 |
Throw | 58 |
Throws | 59 |
Transient | 60 |
True | 61 |
Try | 62 |
Typeof | 63 |
Using | 64 |
Var | 65 |
Void | 66 |
Volatile | 67 |
While | 68 |
With | 69 |
Internal | 70 |
Infinity | 71 |
Override | 72 |
Hide | 73 |
Expando | 74 |
Get | 75 |
Set | 76 |
Undefined | 77 |
Decimal | 78 |
Sbyte | 79 |
Uint | 80 |
Ulong | 81 |
Ushort | 82 |
Open_brace | 83 |
Close_brace | 84 |
Open_parens | 85 |
Close_parens | 86 |
Open_bracket | 87 |
Close_bracket | 88 |
Dot | 89 |
Comma | 90 |
Colon | 91 |
Semicolon | 92 |
Interr | 93 |
Op_inc | 94 |
Op_add_assign | 95 |
Plus | 96 |
Op_dec | 97 |
Op_sub_assign | 98 |
Minus | 99 |
Op_le | 100 |
Op_lt | 101 |
Op_ge | 102 |
Op_gt | 103 |
Op_op_eq | 104 |
Op_op_ne | 105 |
Op_eq | 106 |
Assign | 107 |
Op_ne | 108 |
Bang | 109 |
Op_and | 110 |
Op_or | 111 |
Op_mult_assign | 112 |
Star | 113 |
Op_div_assign | 114 |
Div | 115 |
Op_mod_assign | 116 |
Percent | 117 |
Lambda | 118 |
Bitwise_or | 119 |
Bitwise_xor | 120 |
Bitwise_and | 121 |
Op_or_assign | 122 |
Op_and_assign | 123 |
Op_xor_assign | 124 |
Op_shift_left | 125 |
Op_shift_right | 126 |
Op_shift_left_assign | 127 |
Op_shift_right_assign | 128 |
Op_unsigned_shift_right | 129 |
Op_unsigned_shift_right_assign | 130 |
Integer_Literal | 131 |
Float_Literal | 132 |
Double_Literal | 133 |
Character_Literal | 134 |
String_Literal | 135 |
RegEx_Literal | 136 |
Identifier_Literal | 137 |
Comment_Literal | 138 |
XmlComment_Literal | 139 |
XmlInnerComment_Literal | 140 |
Directive_Literal | 141 |
Whitespace_Literal | 142 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser Class

JavaScriptParser Class
Represents class that and perform syntax and lexical analysis of specified Java Script code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedJavaScriptParser
Alternet.Syntax.Parsers.AdvancedJScriptNETParser
Alternet.Syntax.Parsers.AdvancedJSONParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaScriptParser : SyntaxParser
Public Class JavaScriptParser
    Inherits SyntaxParser
public ref class JavaScriptParser : public SyntaxParser
type JavaScriptParser =
    class
        inherit SyntaxParser
    end

The JavaScriptParser type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptParser | Initializes a new instance of the JavaScriptParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Overrides SyntaxParserFinishParsing.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Overrides SyntaxParserGetAutoFormatNode(Point, Boolean, Point).)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Overrides SyntaxParserIsDeclaration(ISyntaxNode).)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets JavaScriptSyntaxParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Overrides SyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser Constructor

JavaScriptParser Constructor
Initializes a new instance of the JavaScriptParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaScriptParser()
Public Sub New
public:
JavaScriptParser()
new : unit -> JavaScriptParser
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser Methods

JavaScriptParser Methods

The JavaScriptParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Overrides SyntaxParserFinishParsing.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Overrides SyntaxParserGetAutoFormatNode(Point, Boolean, Point).)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Overrides SyntaxParserIsDeclaration(ISyntaxNode).)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets JavaScriptSyntaxParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Overrides SyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.CodeCompletion Method

JavaScriptParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.CodeCompletion Method (String, StringItemInfo[], Point, CodeCompletionArgs)

JavaScriptParserCodeCompletion Method (String, StringItemInfo, Point, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    CodeCompletionArgs e
)
Public Overrides Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    CodeCompletionArgs^ e
) override
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs)
See Also

Reference

JavaScriptParser Class
CodeCompletion Overload
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.CreateRepository Method

JavaScriptParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.FinishParsing Method

JavaScriptParserFinishParsing Method
Commits parsing process.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FinishParsing()
Public Overrides Sub FinishParsing
public:
virtual void FinishParsing() override
abstract FinishParsing : unit -> unit
override FinishParsing : unit -> unit

Implements

ISyntaxParserFinishParsing
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.GetAutoFormatNode Method

JavaScriptParserGetAutoFormatNode Method
Obtains block node at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISyntaxNode GetAutoFormatNode(
    Point position,
    bool extended,
    out Point startPt
)
Public Overrides Function GetAutoFormatNode (
    position As Point,
    extended As Boolean,
    <OutAttribute> ByRef startPt As Point
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetAutoFormatNode(
    Point position,
    bool extended,
    [OutAttribute] Point% startPt
) override
abstract GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode
override GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode

Parameters

position
Type: System.DrawingPoint
Position to check-up.
extended
Type: SystemBoolean
Specifies that search should be extended outside current scope.
startPt
Type: System.DrawingPoint
Retrieves position of block node.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.

Implements

ISyntaxParserGetAutoFormatNode(Point, Boolean, Point)
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.GetCompletionType Method

JavaScriptParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.GetCompletionType Method (Char)

JavaScriptParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

JavaScriptParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.GetSingleLineComment Method

JavaScriptParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.GetSingleLineComment Method

JavaScriptParserGetSingleLineComment Method
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

JavaScriptParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.GetStructureGuideLines Method

JavaScriptParserGetStructureGuideLines Method
Gets list of guide lines.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetStructureGuideLines(
    IList<IRange> guideLines
)
Public Overrides Function GetStructureGuideLines (
    guideLines As IList(Of IRange)
) As Integer
public:
virtual int GetStructureGuideLines(
    IList<IRange^>^ guideLines
) override
abstract GetStructureGuideLines :
        guideLines : IList<IRange> -> int
override GetStructureGuideLines :
        guideLines : IList<IRange> -> int

Parameters

guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.

Implements

ISyntaxParserGetStructureGuideLines(IListIRange)
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.GetXmlComment Method

JavaScriptParserGetXmlComment Method
Gets the string that represents start symbols of xml comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetXmlComment()
Public Overridable Function GetXmlComment As String
public:
virtual String^ GetXmlComment()
abstract GetXmlComment : unit -> string
override GetXmlComment : unit -> string

Return Value

Type: String
Xml comment string.
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.IsDeclaration Method

JavaScriptParserIsDeclaration Method
Indicates whether specified node represents declaration elements.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsDeclaration(
    ISyntaxNode node
)
Public Overrides Function IsDeclaration (
    node As ISyntaxNode
) As Boolean
public:
virtual bool IsDeclaration(
    ISyntaxNode^ node
) override
abstract IsDeclaration :
        node : ISyntaxNode -> bool
override IsDeclaration :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies node to check-up.

Return Value

Type: Boolean
True if specified node represents declaration element; otherwise false.

Implements

ISyntaxParserIsDeclaration(ISyntaxNode)
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.PositionChanged Method

JavaScriptParserPositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overrides Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
) override
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxParserPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ReparseBlock Method

JavaScriptParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ReparseBlock Method (Point)

JavaScriptParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    Point position
)
Public Overrides Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
) override
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

JavaScriptParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ReparseText Method

JavaScriptParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ReparseText Method

JavaScriptParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

JavaScriptParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.Reset Method

JavaScriptParserReset Method
Overload List
 | Name | Description
Public method | Reset | Resets JavaScriptSyntaxParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.Reset Method

JavaScriptParserReset Method
Resets JavaScriptSyntaxParser to the start position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
IParserReset
See Also

Reference

JavaScriptParser Class
Reset Overload
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ResetAutoIndentChars Method

JavaScriptParserResetAutoIndentChars Method
Resets the AutoIndentChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ResetCodeCompletionChars Method

JavaScriptParserResetCodeCompletionChars Method
Resets the CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ResetCodeCompletionStopChars Method

JavaScriptParserResetCodeCompletionStopChars Method
Resets the CodeCompletionStopChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionStopChars()
Public Overrides Sub ResetCodeCompletionStopChars
public:
virtual void ResetCodeCompletionStopChars() override
abstract ResetCodeCompletionStopChars : unit -> unit
override ResetCodeCompletionStopChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionStopChars
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ResetOptions Method

JavaScriptParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ResetSmartFormatChars Method

JavaScriptParserResetSmartFormatChars Method
Resets the SmartFormatChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetSmartFormatChars()
Public Overrides Sub ResetSmartFormatChars
public:
virtual void ResetSmartFormatChars() override
abstract ResetSmartFormatChars : unit -> unit
override ResetSmartFormatChars : unit -> unit

Implements

ISyntaxParserResetSmartFormatChars
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.RestoreState Method

JavaScriptParserRestoreState Method
Overload List
 | Name | Description
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.RestoreState Method (Boolean)

JavaScriptParserRestoreState Method (Boolean)
Restores Parser state and position stored by SaveState method.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void RestoreState(
    bool restore
)
Public Overrides Sub RestoreState (
    restore As Boolean
)
public:
virtual void RestoreState(
    bool restore
) override
abstract RestoreState :
        restore : bool -> unit
override RestoreState :
        restore : bool -> unit

Parameters

restore
Type: SystemBoolean
Indicates whether Parser should restore it's state to previous position or simply delete information about previously stored state.

Implements

IParserRestoreState(Boolean)
See Also

Reference

JavaScriptParser Class
RestoreState Overload
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.SaveState Method

JavaScriptParserSaveState Method
Saves current Parser state and position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void SaveState()
Public Overrides Sub SaveState
public:
virtual void SaveState() override
abstract SaveState : unit -> unit
override SaveState : unit -> unit

Implements

IParserSaveState
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ShouldSerializeAutoIndentChars Method

JavaScriptParserShouldSerializeAutoIndentChars Method
Indicates whether the AutoIndentChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeAutoIndentChars()
Public Overrides Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars() override
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if AutoIndentChars differs from its default value; otherwise false.
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ShouldSerializeCodeCompletionChars Method

JavaScriptParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ShouldSerializeCodeCompletionStopChars Method

JavaScriptParserShouldSerializeCodeCompletionStopChars Method
Indicates whether the CodeCompletionStopChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionStopChars()
Public Overrides Function ShouldSerializeCodeCompletionStopChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionStopChars() override
abstract ShouldSerializeCodeCompletionStopChars : unit -> bool
override ShouldSerializeCodeCompletionStopChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionStopChars differs from its default value; otherwise false.
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ShouldSerializeOptions Method

JavaScriptParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.ShouldSerializeSmartFormatChars Method

JavaScriptParserShouldSerializeSmartFormatChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeSmartFormatChars()
Public Overrides Function ShouldSerializeSmartFormatChars As Boolean
public:
virtual bool ShouldSerializeSmartFormatChars() override
abstract ShouldSerializeSmartFormatChars : unit -> bool
override ShouldSerializeSmartFormatChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.SmartFormatLine Method

JavaScriptParserSmartFormatLine Method
Overload List
 | Name | Description
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList, Boolean)

JavaScriptParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList, Boolean)
Formats line according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations,
    out bool actualPosition
)
Public Overrides Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations,
    [OutAttribute] bool% actualPosition
) override
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int
override SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at given line.

Implements

ISyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean)
See Also

Reference

JavaScriptParser Class
SmartFormatLine Overload
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser Properties

JavaScriptParser Properties

The JavaScriptParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser.CaseSensitive Property

JavaScriptParserCaseSensitive Property
Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JavaScriptParser Events

JavaScriptParser Events

The JavaScriptParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser Class

JScriptNETParser Class
Represents class that and perform syntax and lexical analysis of specified Java Script.NET code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedJavaScriptParser
Alternet.Syntax.Parsers.AdvancedJScriptNETParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JScriptNETParser : JavaScriptParser
Public Class JScriptNETParser
    Inherits JavaScriptParser
public ref class JScriptNETParser : public JavaScriptParser
type JScriptNETParser =
    class
        inherit JavaScriptParser
    end

The JScriptNETParser type exposes the following members.

Constructors
 | Name | Description
Public method | JScriptNETParser | Initializes a new instance of the JScriptNETParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from JavaScriptParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides JavaScriptParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from JavaScriptParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from JavaScriptParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides JavaScriptParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from JavaScriptParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from JavaScriptParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Inherited from JavaScriptParser.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from JavaScriptParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from JavaScriptParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides JavaScriptParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from JavaScriptParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets JavaScriptSyntaxParser to the start position. (Inherited from JavaScriptParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from JavaScriptParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from JavaScriptParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from JavaScriptParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from JavaScriptParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from JavaScriptParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from JavaScriptParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser Constructor

JScriptNETParser Constructor
Initializes a new instance of the JScriptNETParser class

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JScriptNETParser()
Public Sub New
public:
JScriptNETParser()
new : unit -> JScriptNETParser
See Also

Reference

JScriptNETParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser Methods

JScriptNETParser Methods

The JScriptNETParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from JavaScriptParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides JavaScriptParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from JavaScriptParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from JavaScriptParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides JavaScriptParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from JavaScriptParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from JavaScriptParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Inherited from JavaScriptParser.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from JavaScriptParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from JavaScriptParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides JavaScriptParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from JavaScriptParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets JavaScriptSyntaxParser to the start position. (Inherited from JavaScriptParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from JavaScriptParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from JavaScriptParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from JavaScriptParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from JavaScriptParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from JavaScriptParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

JScriptNETParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser.CreateRepository Method

JScriptNETParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

JScriptNETParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser.GetCompletionType Method

JScriptNETParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides JavaScriptParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

JScriptNETParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser.GetCompletionType Method (Char)

JScriptNETParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

JScriptNETParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser.ReparseBlock Method

JScriptNETParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides JavaScriptParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Top
See Also

Reference

JScriptNETParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser.ReparseBlock Method (Point)

JScriptNETParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    Point position
)
Public Overrides Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
) override
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

JScriptNETParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser Properties

JScriptNETParser Properties

The JScriptNETParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from JavaScriptParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

JScriptNETParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JScriptNETParser Events

JScriptNETParser Events

The JScriptNETParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

JScriptNETParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JsLexerToken Enumeration

JsLexerToken Enumeration
Represents lexical tokens for J# parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum JsLexerToken
Public Enumeration JsLexerToken
public enum class JsLexerToken
type JsLexerToken
Members
Member name | Value | Description
Boolean | 169 |
Assert | 170 |
Extends | 171 |
Final | 172 |
Implements | 173 |
Import | 174 |
Instanceof | 175 |
Native | 176 |
Package | 177 |
Super | 178 |
Synchronized | 179 |
Throws | 180 |
Strictfp | 181 |
Transient | 182 |
Op_unsigned_shift_right_assign | 183 |
Op_unsigned_shift_right | 184 |
Annotation | 185 |
Long_Literal | 186 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


JSONParser Class

JSONParser Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedJavaScriptParser
Alternet.Syntax.Parsers.AdvancedJSONParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JSONParser : JavaScriptParser
Public Class JSONParser
    Inherits JavaScriptParser
public ref class JSONParser : public JavaScriptParser
type JSONParser =
    class
        inherit JavaScriptParser
    end

The JSONParser type exposes the following members.

Constructors
 | Name | Description
Public method | JSONParser | Initializes a new instance of the JSONParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from JavaScriptParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from JavaScriptParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from JavaScriptParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from JavaScriptParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from JavaScriptParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from JavaScriptParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from JavaScriptParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Inherited from JavaScriptParser.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from JavaScriptParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from JavaScriptParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from JavaScriptParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from JavaScriptParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets JavaScriptSyntaxParser to the start position. (Inherited from JavaScriptParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from JavaScriptParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from JavaScriptParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from JavaScriptParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from JavaScriptParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from JavaScriptParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from JavaScriptParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


JSONParser Constructor

JSONParser Constructor
Initializes a new instance of the JSONParser class

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JSONParser()
Public Sub New
public:
JSONParser()
new : unit -> JSONParser
See Also

Reference

JSONParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JSONParser Methods

JSONParser Methods

The JSONParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from JavaScriptParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from JavaScriptParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from JavaScriptParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from JavaScriptParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from JavaScriptParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from JavaScriptParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from JavaScriptParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Inherited from JavaScriptParser.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from JavaScriptParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from JavaScriptParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from JavaScriptParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from JavaScriptParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets JavaScriptSyntaxParser to the start position. (Inherited from JavaScriptParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Inherited from JavaScriptParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from JavaScriptParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from JavaScriptParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from JavaScriptParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from JavaScriptParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from JavaScriptParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from JavaScriptParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from JavaScriptParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

JSONParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JSONParser Properties

JSONParser Properties

The JSONParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from JavaScriptParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

JSONParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JSONParser Events

JSONParser Events

The JSONParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

JSONParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JsParser Class

JsParser Class
Represents class that and perform syntax and lexical analysis of specified J# code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedNetSyntaxParser
Alternet.Syntax.Parsers.AdvancedCsParser
Alternet.Syntax.Parsers.AdvancedJsParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JsParser : CsParser
Public Class JsParser
    Inherits CsParser
public ref class JsParser : public CsParser
type JsParser =
    class
        inherit CsParser
    end

The JsParser type exposes the following members.

Constructors
 | Name | Description
Public method | JsParser | Initializes a new instance of the JsParser with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from NetSyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CsParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from NetSyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from NetSyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NetSyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from CsParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from NetSyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from CsParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from NetSyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Inherited from CsParser.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from CsParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NetSyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from CsParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from CsParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from NetSyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from NetSyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterObject | Adds specified object for code completion to the repository's object list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from NetSyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from CsParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | (Inherited from CsParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Inherited from CsParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Inherited from CsParser.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Inherited from CsParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from NetSyntaxParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from CsParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from NetSyntaxParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from NetSyntaxParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from NetSyntaxParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from CsParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from NetSyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterNamespace | Removes specified namespace from the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | UnregisterObject | Removes specified object from the repository's object list. (Inherited from NetSyntaxParser.)
Public method | UnregisterType | Removes specified type from the repository's type list. (Inherited from NetSyntaxParser.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content. (Inherited from NetSyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Inherited from NetSyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


JsParser Constructor

JsParser Constructor
Initializes a new instance of the JsParser with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JsParser()
Public Sub New
public:
JsParser()
new : unit -> JsParser
See Also

Reference

JsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JsParser Methods

JsParser Methods

The JsParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from NetSyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CsParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from NetSyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from NetSyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NetSyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from CsParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from NetSyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from CsParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from NetSyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Inherited from CsParser.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from CsParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NetSyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from CsParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from CsParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from NetSyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from NetSyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterObject | Adds specified object for code completion to the repository's object list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from NetSyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from CsParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | (Inherited from CsParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets the AutoIndentChars to the default value. (Inherited from CsParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Inherited from CsParser.)
Public method | ResetCodeCompletionStopChars | Resets the CodeCompletionStopChars to the default value. (Inherited from CsParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from NetSyntaxParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Inherited from CsParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from NetSyntaxParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from NetSyntaxParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from CsParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from NetSyntaxParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from CsParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from NetSyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterNamespace | Removes specified namespace from the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | UnregisterObject | Removes specified object from the repository's object list. (Inherited from NetSyntaxParser.)
Public method | UnregisterType | Removes specified type from the repository's type list. (Inherited from NetSyntaxParser.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

JsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JsParser Properties

JsParser Properties

The JsParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content. (Inherited from NetSyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Inherited from NetSyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

JsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


JsParser Events

JsParser Events

The JsParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

JsParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MsSqlLexerToken Enumeration

MsSqlLexerToken Enumeration
Represents lexical tokens for MsSql parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MsSqlLexerToken
Public Enumeration MsSqlLexerToken
public enum class MsSqlLexerToken
type MsSqlLexerToken
Members
Member name | Value | Description
Abort | 0 |
Accept | 1 |
Access | 2 |
Account | 3 |
Action | 4 |
Add | 5 |
All | 6 |
Alter | 7 |
And | 8 |
Any | 9 |
Array | 10 |
As | 11 |
Asc | 12 |
Assert | 13 |
Assign | 14 |
At | 15 |
Audit | 16 |
Authorization | 17 |
Auto | 18 |
Avg | 19 |
Base64 | 20 |
Begin | 21 |
Between | 22 |
Body | 23 |
Browse | 24 |
By | 25 |
Case | 26 |
Cascade | 27 |
Cashe | 28 |
Char_base | 29 |
Check | 30 |
Close | 31 |
Cluster | 32 |
Clusters | 33 |
Colauth | 34 |
Column | 35 |
Columns | 36 |
Comment | 37 |
Commit | 38 |
Compact | 39 |
Compress | 40 |
Compute | 41 |
Concat | 42 |
Connect | 43 |
Connections | 44 |
Constant | 45 |
Constraint | 46 |
Count | 47 |
Crash | 48 |
Create | 49 |
Cross | 50 |
Cube | 51 |
Current | 52 |
Cursor | 53 |
Cycle | 54 |
Data_base | 55 |
Database | 56 |
Dba | 57 |
Debugoff | 58 |
Debugon | 59 |
Declare | 60 |
Default | 61 |
Deferrable | 62 |
Deferred | 63 |
Definition | 64 |
Delay | 65 |
Delete | 66 |
Delta | 67 |
Desc | 68 |
Describe | 69 |
Digits | 70 |
Dispose | 71 |
Distinct | 72 |
Do | 73 |
Drop | 74 |
Elements | 75 |
Else | 76 |
Elsif | 77 |
End | 78 |
Entry | 79 |
Exception | 80 |
Exception_init | 81 |
Exclusive | 82 |
Exec | 83 |
Execute | 84 |
Exists | 85 |
Exit | 86 |
Expand | 87 |
Explicit | 88 |
False | 89 |
Fast | 90 |
Fastfirstrow | 91 |
Fetch | 92 |
File | 93 |
For | 94 |
Force | 95 |
Foreign | 96 |
Form | 97 |
From | 98 |
Full | 99 |
Function | 100 |
Generic | 101 |
Goto | 102 |
Grant | 103 |
Group | 104 |
Groups | 105 |
Hash | 106 |
Having | 107 |
Holdlock | 108 |
Identfied | 109 |
Identified | 110 |
IdentityCol | 111 |
If | 112 |
Immediate | 113 |
In | 114 |
Increment | 115 |
Index | 116 |
Index_Blist | 117 |
Indexes | 118 |
Index_None | 119 |
Indicator | 120 |
Initial | 121 |
Initially | 122 |
Inner | 123 |
Insert | 124 |
Intersect | 125 |
Into | 126 |
Is | 127 |
Isolation | 128 |
Join | 129 |
Keep | 130 |
Keepfixed | 131 |
Key | 132 |
Left | 133 |
Level | 134 |
Like | 135 |
Limit | 136 |
Limited | 137 |
Lock | 138 |
Long | 139 |
Loop | 140 |
Max | 141 |
Maxdop | 142 |
Maxextents | 143 |
Merge | 144 |
Min | 145 |
Minvalue | 146 |
Minus | 147 |
Mod | 148 |
Mode | 149 |
Modify | 150 |
New | 151 |
No | 152 |
Noaudit | 153 |
Nocompress | 154 |
Nolock | 155 |
Not | 156 |
Nowait | 157 |
Null | 158 |
Number | 159 |
Number_base | 160 |
Of | 161 |
Off | 162 |
Offline | 163 |
On | 164 |
Online | 165 |
Open | 166 |
Option | 167 |
Or | 168 |
Order | 169 |
Others | 170 |
Out | 171 |
Outer | 172 |
Package | 173 |
Paglock | 174 |
Partition | 175 |
Password | 176 |
Pctfree | 177 |
Percent | 178 |
Plan | 179 |
Pragma | 180 |
Primary | 181 |
Prior | 182 |
Private | 183 |
Privileges | 184 |
Procedure | 185 |
Public | 186 |
Raise | 187 |
Range | 188 |
Raw | 189 |
Readcommited | 190 |
Readpast | 191 |
Readuncommited | 192 |
Record | 193 |
References | 194 |
Release | 195 |
Rem | 196 |
Rename | 197 |
Repeatableread | 198 |
Replace | 199 |
Resource | 200 |
Return | 201 |
Reverse | 202 |
Revoke | 203 |
Right | 204 |
Robust | 205 |
Rollback | 206 |
Rollup | 207 |
Row | 208 |
RowGuidCol | 209 |
Rowid | 210 |
Rowlabel | 211 |
Rowlock | 212 |
Rownum | 213 |
Rows | 214 |
Rowtype | 215 |
Run | 216 |
Savepoint | 217 |
Schema | 218 |
Select | 219 |
Separate | 220 |
Sequence | 221 |
Serializable | 222 |
Session | 223 |
Set | 224 |
Share | 225 |
Show | 226 |
Shutdown | 227 |
Size | 228 |
Space | 229 |
Sql | 230 |
Sqlcode | 231 |
Sqlerrm | 232 |
Start | 233 |
Statement | 234 |
Status | 235 |
Stddev | 236 |
Stdevp | 237 |
Subtype | 238 |
Successful | 239 |
Sum | 240 |
Synonym | 241 |
Sysdate | 242 |
Tabauth | 243 |
Table | 244 |
Tables | 245 |
Tablock | 246 |
Tablockx | 247 |
Task | 248 |
Terminate | 249 |
Then | 250 |
Ties | 251 |
To | 252 |
Top | 253 |
Transaction | 254 |
Trigger | 255 |
True | 256 |
Type | 257 |
Uid | 258 |
Union | 259 |
Unique | 260 |
Unlock | 261 |
Update | 262 |
Uplock | 263 |
Usage | 264 |
Use | 265 |
User | 266 |
Validate | 267 |
Values | 268 |
Varchar2 | 269 |
Variance | 270 |
View | 271 |
Views | 272 |
When | 273 |
Whenever | 274 |
Where | 275 |
While | 276 |
With | 277 |
Work | 278 |
Xlock | 279 |
Xml | 280 |
Xmldata | 281 |
Xor | 282 |
Bit | 283 |
Real | 284 |
Char | 285 |
Text | 286 |
Date | 287 |
Time | 288 |
Interval | 289 |
Float | 290 |
Bigint | 291 |
Double | 292 |
String | 293 |
Binary | 294 |
Numeric | 295 |
Decimal | 296 |
Boolean | 297 |
Tinyint | 298 |
Integer | 299 |
Varchar | 300 |
Smallint | 301 |
Varbinary | 302 |
Timestamp | 303 |
Longvarchar | 304 |
Java_object | 305 |
Longvarbinary | 306 |
Open_parens | 307 |
Close_parens | 308 |
Div | 309 |
Op_lt | 310 |
Op_gt | 311 |
Op_le | 312 |
Op_ge | 313 |
Op_ne | 314 |
Tilde | 315 |
Bang | 316 |
Uxo | 317 |
Turma | 318 |
Carret | 319 |
Ampersant | 320 |
Bitwise_or | 321 |
Cav | 322 |
Interr | 323 |
Dollar | 324 |
Comma | 325 |
Dot | 326 |
Semicolon | 327 |
Op_Assign | 328 |
Op_Star | 329 |
Op_Div | 330 |
Op_Minus | 331 |
Op_Plus | 332 |
Integer_Literal | 333 |
Float_Literal | 334 |
Double_Literal | 335 |
String_Literal | 336 |
Identifier_Literal | 337 |
Comment_Literal | 338 |
Whitespace_Literal | 339 |
Directive_Literal | 340 |
None | 341 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


MsSqlNodeType Enumeration

MsSqlNodeType Enumeration
Defines types of syntax nodes used to create a hierarchical tree view that examines code text as a collection of syntax members. Intended to use with Sql language.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MsSqlNodeType
Public Enumeration MsSqlNodeType
public enum class MsSqlNodeType
type MsSqlNodeType
Members
Member name | Value | Description
None | 0 |
Unit | 1 |
Create | 2 |
Alter | 3 |
Drop | 4 |
SelectQuery | 5 |
SelectSubQuery | 6 |
QuerySpecification | 7 |
ExecuteProc | 8 |
Insert | 9 |
Update | 10 |
Delete | 11 |
Set | 12 |
Show | 13 |
Top | 14 |
Describe | 15 |
Grant | 16 |
Revoke | 17 |
Commit | 18 |
Compact | 19 |
Roolback | 20 |
Shutdown | 21 |
QueryHint | 22 |
TableHint | 23 |
TableHintIndex | 24 |
SelectItem | 25 |
SearchCondition | 26 |
CreateTable | 27 |
CreateView | 28 |
CreateSchema | 29 |
CreateUser | 30 |
CreateSequence | 31 |
AlterUser | 32 |
AlterTable | 33 |
DropView | 34 |
DropSchema | 35 |
DropUser | 36 |
DropSequence | 37 |
DropTable | 38 |
AddStatement | 39 |
DropStatement | 40 |
AlterStatement | 41 |
PrimaryKeyStatement | 42 |
ForeignKeyStatement | 43 |
CheckStatement | 44 |
UniqueStatement | 45 |
WhereStatement | 46 |
LimitStatement | 47 |
ComputeStatement | 48 |
ForStatement | 49 |
FromStatement | 50 |
HavingStatement | 51 |
OptionStatement | 52 |
OrderbyStatement | 53 |
GroupbyStatement | 54 |
IntoStatement | 55 |
QueryHintStatement | 56 |
DefaultStatement | 57 |
DeleteStatement | 58 |
UpdateStatement | 59 |
ReferenceStatement | 60 |
SetStatement | 61 |
PredicateStatement | 62 |
TableSourceStatement | 63 |
WithStatement | 64 |
IdentifierList | 65 |
ColumnList | 66 |
SelectList | 67 |
PrivilegesList | 68 |
UserList | 69 |
SearchConditionList | 70 |
ArgumentList | 71 |
Expression | 72 |
ExpressionList | 73 |
AdditiveExpression | 74 |
OrExpression | 75 |
AndExpression | 76 |
MultiplicativeExpression | 77 |
LikeExpression | 78 |
InExpression | 79 |
RelationalExpression | 80 |
EqualityExpression | 81 |
PrimaryExpression | 82 |
PrefixedUnaryExpression | 83 |
UnaryExpression | 84 |
InvocationExpression | 85 |
MemberAccessExpression | 86 |
ParenthesizedExpression | 87 |
TableName | 88 |
TableAlias | 89 |
SchemaName | 90 |
VariableName | 91 |
ColumnName | 92 |
ColumnAlias | 93 |
ContraintName | 94 |
Attribute | 95 |
AccountAttribute | 96 |
AliasAttribute | 97 |
PasswordAttribute | 98 |
AutoCommitAttribute | 99 |
IsolationLevelAttribute | 100 |
TypeAttribute | 101 |
PrimaryKeyAttribute | 102 |
DatabaseObjectAttribute | 103 |
TriggerAttribute | 104 |
OldOuterJoinAttribute | 105 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser Class

MSSQLParser Class
Represents class that and perform syntax and lexical analysis of specified Microsoft Sql code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedMSSQLParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MSSQLParser : SyntaxParser
Public Class MSSQLParser
    Inherits SyntaxParser
public ref class MSSQLParser : public SyntaxParser
type MSSQLParser =
    class
        inherit SyntaxParser
    end

The MSSQLParser type exposes the following members.

Constructors
 | Name | Description
Public method | MSSQLParser | Initializes a new instance of the MSSQLParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SqlParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser Constructor

MSSQLParser Constructor
Initializes a new instance of the MSSQLParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public MSSQLParser()
Public Sub New
public:
MSSQLParser()
new : unit -> MSSQLParser
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser Methods

MSSQLParser Methods

The MSSQLParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.CreateRepository Method

MSSQLParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.GetCompletionType Method

MSSQLParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.GetCompletionType Method (Char)

MSSQLParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

MSSQLParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.GetSingleLineComment Method

MSSQLParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.GetSingleLineComment Method

MSSQLParserGetSingleLineComment Method
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

MSSQLParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.ReparseText Method

MSSQLParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.ReparseText Method

MSSQLParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

MSSQLParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.ResetCodeCompletionChars Method

MSSQLParserResetCodeCompletionChars Method
Resets the CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.ResetOptions Method

MSSQLParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.RestoreState Method

MSSQLParserRestoreState Method
Overload List
 | Name | Description
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Top
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.RestoreState Method (Boolean)

MSSQLParserRestoreState Method (Boolean)
Restores Parser state and position stored by SaveState method.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void RestoreState(
    bool restore
)
Public Overrides Sub RestoreState (
    restore As Boolean
)
public:
virtual void RestoreState(
    bool restore
) override
abstract RestoreState :
        restore : bool -> unit
override RestoreState :
        restore : bool -> unit

Parameters

restore
Type: SystemBoolean
Indicates whether Parser should restore it's state to previous position or simply delete information about previously stored state.

Implements

IParserRestoreState(Boolean)
See Also

Reference

MSSQLParser Class
RestoreState Overload
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.SaveState Method

MSSQLParserSaveState Method
Saves current Parser state and position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void SaveState()
Public Overrides Sub SaveState
public:
virtual void SaveState() override
abstract SaveState : unit -> unit
override SaveState : unit -> unit

Implements

IParserSaveState
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.ShouldSerializeCodeCompletionChars Method

MSSQLParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.ShouldSerializeOptions Method

MSSQLParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser Properties

MSSQLParser Properties

The MSSQLParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SqlParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser.CaseSensitive Property

MSSQLParserCaseSensitive Property
Gets or sets a boolean value that indicates whether SqlParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


MSSQLParser Events

MSSQLParser Events

The MSSQLParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

MSSQLParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser Class

NetSyntaxParser Class
Represents properties and methods to perform syntax analysis of the text intended to use for NET. family of languages.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedNetSyntaxParser
Alternet.Syntax.Parsers.AdvancedCsParser
Alternet.Syntax.Parsers.AdvancedVbParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NetSyntaxParser : SyntaxParser
Public Class NetSyntaxParser
    Inherits SyntaxParser
public ref class NetSyntaxParser : public SyntaxParser
type NetSyntaxParser =
    class
        inherit SyntaxParser
    end

The NetSyntaxParser type exposes the following members.

Constructors
 | Name | Description
Public method | NetSyntaxParser | Initializes a new instance of the NetSyntaxParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Initializes a new instance of the ReflectionRepository class with default settings. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Overrides SyntaxParserFinishParsing.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Overrides SyntaxParserGetAutoFormatNode(Point, Boolean, Point).)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Overrides SyntaxParserGetContentDividers(IListInt32).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides SyntaxParserIsDeclaration(ISyntaxNode).)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides SyntaxParserProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain.
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies.
Public method | RegisterNamespace(String) | Adds specified namespace to the repository's namespace list.
Public method | RegisterNamespace(String, String) | Adds specified namespace to the repository's namespace list.
Public method | RegisterObject | Adds specified object for code completion to the repository's object list.
Public method | RegisterType(String, Type) | Adds specified type for code completion to the repository's type list.
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the repository's type list.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets NetSyntaxParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Overrides SyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | UnregisterNamespace | Removes specified namespace from the repository's namespace list.
Public method | UnregisterObject | Removes specified object from the repository's object list.
Public method | UnregisterType | Removes specified type from the repository's type list.
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Overrides SyntaxParserExpressionEvaluator.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser Constructor

NetSyntaxParser Constructor
Initializes a new instance of the NetSyntaxParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetSyntaxParser()
Public Sub New
public:
NetSyntaxParser()
new : unit -> NetSyntaxParser
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser Methods

NetSyntaxParser Methods

The NetSyntaxParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Initializes a new instance of the ReflectionRepository class with default settings. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Overrides SyntaxParserFinishParsing.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Overrides SyntaxParserGetAutoFormatNode(Point, Boolean, Point).)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Overrides SyntaxParserGetContentDividers(IListInt32).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides SyntaxParserIsDeclaration(ISyntaxNode).)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides SyntaxParserProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain.
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies.
Public method | RegisterNamespace(String) | Adds specified namespace to the repository's namespace list.
Public method | RegisterNamespace(String, String) | Adds specified namespace to the repository's namespace list.
Public method | RegisterObject | Adds specified object for code completion to the repository's object list.
Public method | RegisterType(String, Type) | Adds specified type for code completion to the repository's type list.
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the repository's type list.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets NetSyntaxParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Overrides SyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | UnregisterNamespace | Removes specified namespace from the repository's namespace list.
Public method | UnregisterObject | Removes specified object from the repository's object list.
Public method | UnregisterType | Removes specified type from the repository's type list.
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.CodeCompletion Method

NetSyntaxParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.CodeCompletion Method (String, StringItemInfo[], Point, CodeCompletionArgs)

NetSyntaxParserCodeCompletion Method (String, StringItemInfo, Point, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    CodeCompletionArgs e
)
Public Overrides Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    CodeCompletionArgs^ e
) override
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs)
See Also

Reference

NetSyntaxParser Class
CodeCompletion Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.CreateRepository Method

NetSyntaxParserCreateRepository Method
Initializes a new instance of the ReflectionRepository class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that represents this new instance.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.FindReferences Method

NetSyntaxParserFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.FindReferences Method (Point, IRangeList, Boolean)

NetSyntaxParserFindReferences Method (Point, IRangeList, Boolean)
Locates declaration at given position and finds all references to this declaration in the text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int FindReferences(
    Point position,
    IRangeList references,
    bool allDocuments
)
Public Overrides Function FindReferences (
    position As Point,
    references As IRangeList,
    allDocuments As Boolean
) As Integer
public:
virtual int FindReferences(
    Point position,
    IRangeList^ references,
    bool allDocuments
) override
abstract FindReferences :
        position : Point *
        references : IRangeList *
        allDocuments : bool -> int
override FindReferences :
        position : Point *
        references : IRangeList *
        allDocuments : bool -> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
Retrieves references to found declaration.
allDocuments
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found references.

Implements

ISyntaxParserFindReferences(Point, IRangeList, Boolean)
See Also

Reference

NetSyntaxParser Class
FindReferences Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.FinishParsing Method

NetSyntaxParserFinishParsing Method
Commits parsing process.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FinishParsing()
Public Overrides Sub FinishParsing
public:
virtual void FinishParsing() override
abstract FinishParsing : unit -> unit
override FinishParsing : unit -> unit

Implements

ISyntaxParserFinishParsing
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.GetAutoFormatNode Method

NetSyntaxParserGetAutoFormatNode Method
Obtains block node at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISyntaxNode GetAutoFormatNode(
    Point position,
    bool extended,
    out Point startPt
)
Public Overrides Function GetAutoFormatNode (
    position As Point,
    extended As Boolean,
    <OutAttribute> ByRef startPt As Point
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetAutoFormatNode(
    Point position,
    bool extended,
    [OutAttribute] Point% startPt
) override
abstract GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode
override GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode

Parameters

position
Type: System.DrawingPoint
Position to check-up.
extended
Type: SystemBoolean
Specifies that search should be extended outside current scope.
startPt
Type: System.DrawingPoint
Retrieves position of block node.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.

Implements

ISyntaxParserGetAutoFormatNode(Point, Boolean, Point)
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.GetCompletionType Method

NetSyntaxParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.GetCompletionType Method (Char)

NetSyntaxParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

NetSyntaxParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.GetContentDividers Method

NetSyntaxParserGetContentDividers Method
Gets list of content dividers.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetContentDividers(
    IList<int> dividers
)
Public Overrides Function GetContentDividers (
    dividers As IList(Of Integer)
) As Integer
public:
virtual int GetContentDividers(
    IList<int>^ dividers
) override
abstract GetContentDividers :
        dividers : IList<int> -> int
override GetContentDividers :
        dividers : IList<int> -> int

Parameters

dividers
Type: System.Collections.GenericIListInt32

Return Value

Type: Int32

Implements

ISyntaxParserGetContentDividers(IListInt32)
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.GetStructureGuideLines Method

NetSyntaxParserGetStructureGuideLines Method
Gets list of guide lines.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetStructureGuideLines(
    IList<IRange> guideLines
)
Public Overrides Function GetStructureGuideLines (
    guideLines As IList(Of IRange)
) As Integer
public:
virtual int GetStructureGuideLines(
    IList<IRange^>^ guideLines
) override
abstract GetStructureGuideLines :
        guideLines : IList<IRange> -> int
override GetStructureGuideLines :
        guideLines : IList<IRange> -> int

Parameters

guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.

Implements

ISyntaxParserGetStructureGuideLines(IListIRange)
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.GetXmlComment Method

NetSyntaxParserGetXmlComment Method
Gets the string that represents start symbols of xml comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetXmlComment()
Public Overridable Function GetXmlComment As String
public:
virtual String^ GetXmlComment()
abstract GetXmlComment : unit -> string
override GetXmlComment : unit -> string

Return Value

Type: String
Xml comment string.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.IsDeclaration Method

NetSyntaxParserIsDeclaration Method
Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsDeclaration(
    ISyntaxNode node
)
Public Overrides Function IsDeclaration (
    node As ISyntaxNode
) As Boolean
public:
virtual bool IsDeclaration(
    ISyntaxNode^ node
) override
abstract IsDeclaration :
        node : ISyntaxNode -> bool
override IsDeclaration :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is declaration node; otherwise false.

Implements

ISyntaxParserIsDeclaration(ISyntaxNode)
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.PositionChanged Method

NetSyntaxParserPositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overrides Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
) override
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxParserPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ProcessAutoComplete Method

NetSyntaxParserProcessAutoComplete Method
Checks whether end-of-block code needs inserting.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ProcessAutoComplete(
    string text,
    Point position,
    out string code
)
Public Overrides Function ProcessAutoComplete (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessAutoComplete(
    String^ text,
    Point position,
    [OutAttribute] String^% code
) override
abstract ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if autocompletion of end-of-block needed; otherwise false.

Implements

ISyntaxParserProcessAutoComplete(String, Point, String)
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterAllAssemblies Method

NetSyntaxParserRegisterAllAssemblies Method
Registers all assemblies from the current application domain.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterAllAssemblies()
Public Overridable Sub RegisterAllAssemblies
public:
virtual void RegisterAllAssemblies()
abstract RegisterAllAssemblies : unit -> unit
override RegisterAllAssemblies : unit -> unit
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterAssembly Method

NetSyntaxParserRegisterAssembly Method
Overload List
 | Name | Description
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list.
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterAssembly Method (Assembly)

NetSyntaxParserRegisterAssembly Method (Assembly)
Adds specified assembly for code completion to the repository's assembly list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterAssembly(
    Assembly assembly
)
Public Overridable Sub RegisterAssembly (
    assembly As Assembly
)
public:
virtual void RegisterAssembly(
    Assembly^ assembly
)
abstract RegisterAssembly :
        assembly : Assembly -> unit
override RegisterAssembly :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Specifies registered assembly.
See Also

Reference

NetSyntaxParser Class
RegisterAssembly Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterAssembly Method (String)

NetSyntaxParserRegisterAssembly Method (String)
Adds specified assembly for code completion to the repository's assembly list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RegisterAssembly(
    string name
)
Public Overridable Function RegisterAssembly (
    name As String
) As Boolean
public:
virtual bool RegisterAssembly(
    String^ name
)
abstract RegisterAssembly :
        name : string -> bool
override RegisterAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of the assembly.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

NetSyntaxParser Class
RegisterAssembly Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterDefaultAssemblies Method

NetSyntaxParserRegisterDefaultAssemblies Method
Registers some most frequently used assemblies.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterDefaultAssemblies()
Public Overridable Sub RegisterDefaultAssemblies
public:
virtual void RegisterDefaultAssemblies()
abstract RegisterDefaultAssemblies : unit -> unit
override RegisterDefaultAssemblies : unit -> unit
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterNamespace Method

NetSyntaxParserRegisterNamespace Method
Overload List
 | Name | Description
Public method | RegisterNamespace(String) | Adds specified namespace to the repository's namespace list.
Public method | RegisterNamespace(String, String) | Adds specified namespace to the repository's namespace list.
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterNamespace Method (String)

NetSyntaxParserRegisterNamespace Method (String)
Adds specified namespace to the repository's namespace list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterNamespace(
    string nspace
)
Public Overridable Sub RegisterNamespace (
    nspace As String
)
public:
virtual void RegisterNamespace(
    String^ nspace
)
abstract RegisterNamespace :
        nspace : string -> unit
override RegisterNamespace :
        nspace : string -> unit

Parameters

nspace
Type: SystemString
Specifies name of namespace to add.
See Also

Reference

NetSyntaxParser Class
RegisterNamespace Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterNamespace Method (String, String)

NetSyntaxParserRegisterNamespace Method (String, String)
Adds specified namespace to the repository's namespace list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterNamespace(
    string nspace,
    string alias
)
Public Overridable Sub RegisterNamespace (
    nspace As String,
    alias As String
)
public:
virtual void RegisterNamespace(
    String^ nspace,
    String^ alias
)
abstract RegisterNamespace :
        nspace : string *
        alias : string -> unit
override RegisterNamespace :
        nspace : string *
        alias : string -> unit

Parameters

nspace
Type: SystemString
Specifies name of namespace to add.
alias
Type: SystemString
Specifies alias of namespace.
See Also

Reference

NetSyntaxParser Class
RegisterNamespace Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterObject Method

NetSyntaxParserRegisterObject Method
Adds specified object for code completion to the repository's object list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterObject(
    string name,
    Object obj
)
Public Overridable Sub RegisterObject (
    name As String,
    obj As Object
)
public:
virtual void RegisterObject(
    String^ name,
    Object^ obj
)
abstract RegisterObject :
        name : string *
        obj : Object -> unit
override RegisterObject :
        name : string *
        obj : Object -> unit

Parameters

name
Type: SystemString
Specifies name of the object.
obj
Type: SystemObject
Specifies object to register.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterType Method

NetSyntaxParserRegisterType Method
Overload List
 | Name | Description
Public method | RegisterType(String, Type) | Adds specified type for code completion to the repository's type list.
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the repository's type list.
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterType Method (String, Type)

NetSyntaxParserRegisterType Method (String, Type)
Adds specified type for code completion to the repository's type list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterType(
    string name,
    Type type
)
Public Overridable Sub RegisterType (
    name As String,
    type As Type
)
public:
virtual void RegisterType(
    String^ name,
    Type^ type
)
abstract RegisterType :
        name : string *
        type : Type -> unit
override RegisterType :
        name : string *
        type : Type -> unit

Parameters

name
Type: SystemString
Specifies name of the type.
type
Type: SystemType
Specifies type to register.
See Also

Reference

NetSyntaxParser Class
RegisterType Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RegisterType Method (String, Type, Boolean)

NetSyntaxParserRegisterType Method (String, Type, Boolean)
Adds specified type for code completion to the repository's type list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterType(
    string name,
    Type type,
    bool global
)
Public Overridable Sub RegisterType (
    name As String,
    type As Type,
    global As Boolean
)
public:
virtual void RegisterType(
    String^ name,
    Type^ type,
    bool global
)
abstract RegisterType :
        name : string *
        type : Type *
        global : bool -> unit
override RegisterType :
        name : string *
        type : Type *
        global : bool -> unit

Parameters

name
Type: SystemString
Specifies name of the type.
type
Type: SystemType
Specifies type to register.
global
Type: SystemBoolean
Specifies whether the type is global.
See Also

Reference

NetSyntaxParser Class
RegisterType Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ReparseBlock Method

NetSyntaxParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ReparseBlock Method (Point)

NetSyntaxParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    Point position
)
Public Overrides Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
) override
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

NetSyntaxParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ReparseText Method

NetSyntaxParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ReparseText Method

NetSyntaxParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

NetSyntaxParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.Reset Method

NetSyntaxParserReset Method
Overload List
 | Name | Description
Public method | Reset | Resets NetSyntaxParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.Reset Method

NetSyntaxParserReset Method
Resets NetSyntaxParser to the start position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
IParserReset
See Also

Reference

NetSyntaxParser Class
Reset Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ResetAutoIndentChars Method

NetSyntaxParserResetAutoIndentChars Method
Resets AutoIndentChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ResetCodeCompletionChars Method

NetSyntaxParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ResetCodeCompletionStopChars Method

NetSyntaxParserResetCodeCompletionStopChars Method
Resets CodeCompletionStopChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionStopChars()
Public Overrides Sub ResetCodeCompletionStopChars
public:
virtual void ResetCodeCompletionStopChars() override
abstract ResetCodeCompletionStopChars : unit -> unit
override ResetCodeCompletionStopChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionStopChars
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ResetOptions Method

NetSyntaxParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RestoreState Method

NetSyntaxParserRestoreState Method
Overload List
 | Name | Description
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.RestoreState Method (Boolean)

NetSyntaxParserRestoreState Method (Boolean)
Restores Parser state and position stored by SaveState method.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void RestoreState(
    bool restore
)
Public Overrides Sub RestoreState (
    restore As Boolean
)
public:
virtual void RestoreState(
    bool restore
) override
abstract RestoreState :
        restore : bool -> unit
override RestoreState :
        restore : bool -> unit

Parameters

restore
Type: SystemBoolean
Indicates whether Parser should restore it's state to previous position or simply delete information about previously stored state.

Implements

IParserRestoreState(Boolean)
See Also

Reference

NetSyntaxParser Class
RestoreState Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.SaveState Method

NetSyntaxParserSaveState Method
Saves current Parser state and position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void SaveState()
Public Overrides Sub SaveState
public:
virtual void SaveState() override
abstract SaveState : unit -> unit
override SaveState : unit -> unit

Implements

IParserSaveState
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ShouldSerializeAutoIndentChars Method

NetSyntaxParserShouldSerializeAutoIndentChars Method
Indicates whether the AutoIndentChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeAutoIndentChars()
Public Overrides Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars() override
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if AutoIndentChars differs from its default value; otherwise false.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ShouldSerializeCodeCompletionChars Method

NetSyntaxParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ShouldSerializeCodeCompletionStopChars Method

NetSyntaxParserShouldSerializeCodeCompletionStopChars Method
Indicates whether the CodeCompletionStopChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionStopChars()
Public Overrides Function ShouldSerializeCodeCompletionStopChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionStopChars() override
abstract ShouldSerializeCodeCompletionStopChars : unit -> bool
override ShouldSerializeCodeCompletionStopChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionStopChars differs from its default value; otherwise false.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ShouldSerializeOptions Method

NetSyntaxParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.SmartFormatLine Method

NetSyntaxParserSmartFormatLine Method
Overload List
 | Name | Description
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList, Boolean)

NetSyntaxParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList, Boolean)
Formats line according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations,
    out bool actualPosition
)
Public Overrides Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations,
    [OutAttribute] bool% actualPosition
) override
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int
override SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at given line.

Implements

ISyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean)
See Also

Reference

NetSyntaxParser Class
SmartFormatLine Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.UnregisterAssembly Method

NetSyntaxParserUnregisterAssembly Method
Overload List
 | Name | Description
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list.
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.UnregisterAssembly Method (Assembly, Boolean)

NetSyntaxParserUnregisterAssembly Method (Assembly, Boolean)
Removes specified assembly from the repository's assembly list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterAssembly(
    Assembly assembly,
    bool removeReferences
)
Public Overridable Function UnregisterAssembly (
    assembly As Assembly,
    removeReferences As Boolean
) As Boolean
public:
virtual bool UnregisterAssembly(
    Assembly^ assembly,
    bool removeReferences
)
abstract UnregisterAssembly :
        assembly : Assembly *
        removeReferences : bool -> bool
override UnregisterAssembly :
        assembly : Assembly *
        removeReferences : bool -> bool

Parameters

assembly
Type: System.ReflectionAssembly
Specifies assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all types from the specified assembly should be unregistered.

Return Value

Type: Boolean
True if succeed (assembly is present in the assembly list); otherwise false.
See Also

Reference

NetSyntaxParser Class
UnregisterAssembly Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.UnregisterAssembly Method (String, Boolean)

NetSyntaxParserUnregisterAssembly Method (String, Boolean)
Removes specified assembly from the repository's assembly list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterAssembly(
    string name,
    bool removeReferences
)
Public Overridable Function UnregisterAssembly (
    name As String,
    removeReferences As Boolean
) As Boolean
public:
virtual bool UnregisterAssembly(
    String^ name,
    bool removeReferences
)
abstract UnregisterAssembly :
        name : string *
        removeReferences : bool -> bool
override UnregisterAssembly :
        name : string *
        removeReferences : bool -> bool

Parameters

name
Type: SystemString
Specifies name of assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all types from the specified assembly should be unregistered.

Return Value

Type: Boolean
True if succeed (assembly is present in the assembly list); otherwise false.
See Also

Reference

NetSyntaxParser Class
UnregisterAssembly Overload
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.UnregisterNamespace Method

NetSyntaxParserUnregisterNamespace Method
Removes specified namespace from the repository's namespace list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterNamespace(
    string nspace
)
Public Overridable Function UnregisterNamespace (
    nspace As String
) As Boolean
public:
virtual bool UnregisterNamespace(
    String^ nspace
)
abstract UnregisterNamespace :
        nspace : string -> bool
override UnregisterNamespace :
        nspace : string -> bool

Parameters

nspace
Type: SystemString
Specifies name of namespace to remove.

Return Value

Type: Boolean
True if succeed (namespace is present in the namespace list); otherwise false.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.UnregisterObject Method

NetSyntaxParserUnregisterObject Method
Removes specified object from the repository's object list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterObject(
    string name
)
Public Overridable Function UnregisterObject (
    name As String
) As Boolean
public:
virtual bool UnregisterObject(
    String^ name
)
abstract UnregisterObject :
        name : string -> bool
override UnregisterObject :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of object to remove.

Return Value

Type: Boolean
True if succeed (object is present in the object list); otherwise false.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.UnregisterType Method

NetSyntaxParserUnregisterType Method
Removes specified type from the repository's type list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterType(
    string name
)
Public Overridable Function UnregisterType (
    name As String
) As Boolean
public:
virtual bool UnregisterType(
    String^ name
)
abstract UnregisterType :
        name : string -> bool
override UnregisterType :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of type to remove.

Return Value

Type: Boolean
True if succeed (type is present in the type list); otherwise false.
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser Properties

NetSyntaxParser Properties

The NetSyntaxParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Overrides SyntaxParserExpressionEvaluator.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.CaseSensitive Property

NetSyntaxParserCaseSensitive Property
Gets or sets a boolean value that indicates whether NetSyntaxParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser.ExpressionEvaluator Property

NetSyntaxParserExpressionEvaluator Property

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IExpressionEvaluator ExpressionEvaluator { get; set; }
Public Overrides Property ExpressionEvaluator As IExpressionEvaluator
    Get
    Set
public:
virtual property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get () override;
    void set (IExpressionEvaluator^ value) override;
}
abstract ExpressionEvaluator : IExpressionEvaluator with get, set
override ExpressionEvaluator : IExpressionEvaluator with get, set

Property Value

Type: IExpressionEvaluator

Implements

ISyntaxParserExpressionEvaluator
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


NetSyntaxParser Events

NetSyntaxParser Events

The NetSyntaxParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

NetSyntaxParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlLexerToken Enumeration

SqlLexerToken Enumeration
Represents lexical tokens for Sql parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SqlLexerToken
Public Enumeration SqlLexerToken
public enum class SqlLexerToken
type SqlLexerToken
Members
Member name | Value | Description
Abort | 0 |
Accept | 1 |
Access | 2 |
Account | 3 |
Action | 4 |
Add | 5 |
All | 6 |
Alter | 7 |
And | 8 |
Any | 9 |
Array | 10 |
As | 11 |
Asc | 12 |
Assert | 13 |
Assign | 14 |
At | 15 |
Audit | 16 |
Authorization | 17 |
Auto | 18 |
Avg | 19 |
Begin | 20 |
Between | 21 |
Body | 22 |
By | 23 |
Case | 24 |
Cascade | 25 |
Cashe | 26 |
Char_base | 27 |
Check | 28 |
Close | 29 |
Cluster | 30 |
Clusters | 31 |
Colauth | 32 |
Column | 33 |
Columns | 34 |
Comment | 35 |
Commit | 36 |
Compact | 37 |
Compress | 38 |
Connect | 39 |
Connections | 40 |
Constant | 41 |
Constraint | 42 |
Count | 43 |
Crash | 44 |
Create | 45 |
Current | 46 |
Cursor | 47 |
Cycle | 48 |
Data_base | 49 |
Database | 50 |
Dba | 51 |
Debugoff | 52 |
Debugon | 53 |
Declare | 54 |
Default | 55 |
Deferrable | 56 |
Deferred | 57 |
Definition | 58 |
Delay | 59 |
Delete | 60 |
Delta | 61 |
Desc | 62 |
Describe | 63 |
Digits | 64 |
Dispose | 65 |
Distinct | 66 |
Do | 67 |
Drop | 68 |
Else | 69 |
Elsif | 70 |
End | 71 |
Entry | 72 |
Exception | 73 |
Exception_init | 74 |
Exclusive | 75 |
Exists | 76 |
Exit | 77 |
False | 78 |
Fetch | 79 |
File | 80 |
For | 81 |
Foreign | 82 |
Form | 83 |
From | 84 |
Function | 85 |
Generic | 86 |
Goto | 87 |
Grant | 88 |
Group | 89 |
Groups | 90 |
Having | 91 |
Identfied | 92 |
Identified | 93 |
If | 94 |
Immediate | 95 |
In | 96 |
Increment | 97 |
Index | 98 |
Index_Blist | 99 |
Indexes | 100 |
Index_None | 101 |
Indicator | 102 |
Initial | 103 |
Initially | 104 |
Inner | 105 |
Insert | 106 |
Intersect | 107 |
Into | 108 |
Is | 109 |
Isolation | 110 |
Join | 111 |
Key | 112 |
Left | 113 |
Level | 114 |
Like | 115 |
Limit | 116 |
Limited | 117 |
Lock | 118 |
Long | 119 |
Loop | 120 |
Max | 121 |
Maxextents | 122 |
Min | 123 |
Minvalue | 124 |
Minus | 125 |
Mod | 126 |
Mode | 127 |
Modify | 128 |
New | 129 |
No | 130 |
Noaudit | 131 |
Nocompress | 132 |
Not | 133 |
Nowait | 134 |
Null | 135 |
Number | 136 |
Number_base | 137 |
Of | 138 |
Off | 139 |
Offline | 140 |
On | 141 |
Online | 142 |
Open | 143 |
Option | 144 |
Or | 145 |
Order | 146 |
Others | 147 |
Out | 148 |
Outer | 149 |
Package | 150 |
Partition | 151 |
Password | 152 |
Pctfree | 153 |
Pragma | 154 |
Primary | 155 |
Prior | 156 |
Private | 157 |
Privileges | 158 |
Procedure | 159 |
Public | 160 |
Raise | 161 |
Range | 162 |
Raw | 163 |
Record | 164 |
References | 165 |
Release | 166 |
Rem | 167 |
Rename | 168 |
Replace | 169 |
Resource | 170 |
Return | 171 |
Reverse | 172 |
Revoke | 173 |
Right | 174 |
Rollback | 175 |
Row | 176 |
Rowid | 177 |
Rowlabel | 178 |
Rownum | 179 |
Rows | 180 |
Rowtype | 181 |
Run | 182 |
Savepoint | 183 |
Schema | 184 |
Select | 185 |
Separate | 186 |
Sequence | 187 |
Serializable | 188 |
Session | 189 |
Set | 190 |
Share | 191 |
Show | 192 |
Shutdown | 193 |
Size | 194 |
Space | 195 |
Sql | 196 |
Sqlcode | 197 |
Sqlerrm | 198 |
Start | 199 |
Statement | 200 |
Status | 201 |
Stddev | 202 |
Subtype | 203 |
Successful | 204 |
Sum | 205 |
Synonym | 206 |
Sysdate | 207 |
Tabauth | 208 |
Table | 209 |
Tables | 210 |
Task | 211 |
Terminate | 212 |
Then | 213 |
To | 214 |
Transaction | 215 |
Trigger | 216 |
True | 217 |
Type | 218 |
Uid | 219 |
Union | 220 |
Unique | 221 |
Unlock | 222 |
Update | 223 |
Usage | 224 |
Use | 225 |
User | 226 |
Validate | 227 |
Values | 228 |
Varchar2 | 229 |
Variance | 230 |
View | 231 |
Views | 232 |
When | 233 |
Whenever | 234 |
Where | 235 |
While | 236 |
With | 237 |
Work | 238 |
Xor | 239 |
Bit | 240 |
Real | 241 |
Char | 242 |
Text | 243 |
Date | 244 |
DateTime | 245 |
Time | 246 |
Interval | 247 |
Float | 248 |
Bigint | 249 |
Double | 250 |
String | 251 |
Binary | 252 |
Numeric | 253 |
Decimal | 254 |
Boolean | 255 |
Tinyint | 256 |
Integer | 257 |
Varchar | 258 |
Smallint | 259 |
Varbinary | 260 |
Timestamp | 261 |
Longvarchar | 262 |
Java_object | 263 |
Longvarbinary | 264 |
Open_parens | 265 |
Close_parens | 266 |
Div | 267 |
Op_lt | 268 |
Op_gt | 269 |
Op_le | 270 |
Op_ge | 271 |
Op_ne | 272 |
Tilde | 273 |
Bang | 274 |
Uxo | 275 |
Turma | 276 |
Percent | 277 |
Carret | 278 |
Ampersant | 279 |
Bitwise_or | 280 |
Cav | 281 |
Interr | 282 |
Dollar | 283 |
Comma | 284 |
Dot | 285 |
Semicolon | 286 |
Op_Assign | 287 |
Op_Star | 288 |
Op_Div | 289 |
Op_Minus | 290 |
Op_Plus | 291 |
Integer_Literal | 292 |
Float_Literal | 293 |
Double_Literal | 294 |
String_Literal | 295 |
Identifier_Literal | 296 |
Comment_Literal | 297 |
Whitespace_Literal | 298 |
None | 299 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


SqlNodeType Enumeration

SqlNodeType Enumeration
Defines types of syntax nodes used to create a hierarchical tree view that examines code text as a collection of syntax members. Intended to use with Sql language.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SqlNodeType
Public Enumeration SqlNodeType
public enum class SqlNodeType
type SqlNodeType
Members
Member name | Value | Description
None | 0 |
Unit | 1 |
Create | 2 |
Alter | 3 |
Drop | 4 |
Select | 5 |
Insert | 6 |
Update | 7 |
Delete | 8 |
Set | 9 |
Show | 10 |
Describe | 11 |
Grant | 12 |
Revoke | 13 |
Commit | 14 |
Compact | 15 |
Roolback | 16 |
Shutdown | 17 |
CreateTable | 18 |
CreateView | 19 |
CreateSchema | 20 |
CreateUser | 21 |
CreateSequence | 22 |
AlterUser | 23 |
AlterTable | 24 |
DropView | 25 |
DropSchema | 26 |
DropUser | 27 |
DropSequence | 28 |
DropTable | 29 |
AddStatement | 30 |
DropStatement | 31 |
AlterStatement | 32 |
PrimaryKeyStatement | 33 |
ForeignKeyStatement | 34 |
CheckStatement | 35 |
UniqueStatement | 36 |
WhereStatement | 37 |
LimitStatement | 38 |
FromStatement | 39 |
HavingStatement | 40 |
OrderbyStatement | 41 |
GroupbyStatement | 42 |
DefaultStatement | 43 |
DeleteStatement | 44 |
UpdateStatement | 45 |
ReferenceStatement | 46 |
SetStatement | 47 |
IdentifierList | 48 |
ColumnList | 49 |
PrivilegesList | 50 |
UserList | 51 |
ArgumentList | 52 |
Expression | 53 |
AdditiveExpression | 54 |
OrExpression | 55 |
AndExpression | 56 |
MultiplicativeExpression | 57 |
LikeExpression | 58 |
RelationalExpression | 59 |
EqualityExpression | 60 |
PrimaryExpression | 61 |
PrefixedUnaryExpression | 62 |
UnaryExpression | 63 |
InvocationExpression | 64 |
MemberAccessExpression | 65 |
ParenthesizedExpression | 66 |
TableName | 67 |
TableAlias | 68 |
SchemaName | 69 |
VariableName | 70 |
ColumnName | 71 |
ColumnAlias | 72 |
ContraintName | 73 |
Attribute | 74 |
AccountAttribute | 75 |
PasswordAttribute | 76 |
AutoCommitAttribute | 77 |
IsolationLevelAttribute | 78 |
TypeAttribute | 79 |
PrimaryKeyAttribute | 80 |
DatabaseObjectAttribute | 81 |
TriggerAttribute | 82 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


SqlParser Class

SqlParser Class
Represents class that and perform syntax and lexical analysis of specified Sql code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedSqlParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SqlParser : SyntaxParser
Public Class SqlParser
    Inherits SyntaxParser
public ref class SqlParser : public SyntaxParser
type SqlParser =
    class
        inherit SyntaxParser
    end

The SqlParser type exposes the following members.

Constructors
 | Name | Description
Public method | SqlParser | Initializes a new instance of the SqlParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeFormatCase | Indicates whether the FormatCase property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SqlParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | FormatCase |
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


SqlParser Constructor

SqlParser Constructor
Initializes a new instance of the SqlParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SqlParser()
Public Sub New
public:
SqlParser()
new : unit -> SqlParser
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser Methods

SqlParser Methods

The SqlParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeFormatCase | Indicates whether the FormatCase property should be persisted.
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.CreateRepository Method

SqlParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.GetCompletionType Method

SqlParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.GetCompletionType Method (Char)

SqlParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

SqlParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.ReparseBlock Method

SqlParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Top
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.ReparseBlock Method (Point)

SqlParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    Point position
)
Public Overrides Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
) override
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

SqlParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.ReparseText Method

SqlParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.ReparseText Method

SqlParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

SqlParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.ResetCodeCompletionChars Method

SqlParserResetCodeCompletionChars Method
Resets the CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.ResetOptions Method

SqlParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.ShouldSerializeCodeCompletionChars Method

SqlParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.ShouldSerializeFormatCase Method

SqlParserShouldSerializeFormatCase Method
Indicates whether the FormatCase property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeFormatCase()
Public Overridable Function ShouldSerializeFormatCase As Boolean
public:
virtual bool ShouldSerializeFormatCase()
abstract ShouldSerializeFormatCase : unit -> bool
override ShouldSerializeFormatCase : unit -> bool

Return Value

Type: Boolean
True if FormatCase differs from its default value; otherwise false.
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.ShouldSerializeOptions Method

SqlParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.SmartFormatLine Method

SqlParserSmartFormatLine Method
Overload List
 | Name | Description
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Top
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList, Boolean)

SqlParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList, Boolean)
Formats line according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations,
    out bool actualPosition
)
Public Overrides Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations,
    [OutAttribute] bool% actualPosition
) override
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int
override SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at given line.

Implements

ISyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean)
See Also

Reference

SqlParser Class
SmartFormatLine Overload
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser Properties

SqlParser Properties

The SqlParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SqlParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | FormatCase |
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.CaseSensitive Property

SqlParserCaseSensitive Property
Gets or sets a boolean value that indicates whether SqlParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser.FormatCase Property

SqlParserFormatCase Property

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatCase FormatCase { get; set; }
Public Property FormatCase As FormatCase
    Get
    Set
public:
property FormatCase FormatCase {
    FormatCase get ();
    void set (FormatCase value);
}
member FormatCase : FormatCase with get, set

Property Value

Type: FormatCase
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SqlParser Events

SqlParser Events

The SqlParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

SqlParser Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts Class

SyntaxParserConsts Class
Contains default constants related to lexical and syntax analyzers.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.AdvancedSyntaxParserConsts

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxParserConsts
Public Class SyntaxParserConsts
public ref class SyntaxParserConsts
type SyntaxParserConsts =  class end

The SyntaxParserConsts type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxParserConsts | Initializes a new instance of the SyntaxParserConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AbstractModifier |
ArraySpecifier |
BuiltInTypeIndex |
BuitInTypeStyle |
BytesInternalName |
CantFindDeclaration |
CategoryClasses |
CategoryConstants |
CategoryDelegates |
CategoryEnums |
CategoryEvents |
CategoryFields |
CategoryInterfaces |
CategoryKeywords |
CategoryMethods |
CategoryNamespaces |
CategoryProperties |
CategorySnippets |
CategoryStructs |
ClassDataType |
ClassIndex |
ClassSpecifier |
ConstIndex |
Constructor |
DeclarationGuideLines |
DeclarationReference |
DeclarationReferenceList |
DefaultCAutoIndentChars |
DefaultCCodeCompletionChars |
DefaultCCodeCompletionStopChars |
DefaultCsAutoIndentChars |
DefaultCsCodeCompletionChars |
DefaultCsCodeCompletionStopChars |
DefaultCSmartFormatChars |
DefaultCsSmartFormatChars |
DefaultJavaScriptCodeCompletionChars |
DefaultNetAutoIndentChars |
DefaultNetCodeCompletionChars |
DefaultNetCodeCompletionStopChars |
DefaultNetSyntaxOptions |
DefaultPythonSyntaxOptions |
DefaultSqlSyntaxOptions |
DefaultVbCodeCompletionChars |
DefaultVbScriptCodeCompletionChars |
DefaultVbScriptSyntaxOptions |
DefaultVbSmartFormatChars |
DefaultVbSyntaxOptions |
DefaultWinFormsAssemblies |
DefaultWPFAssemblies |
DefineString |
DelegateIndex |
DescriptionTarget |
EditorBrowsable |
EditorBrowsableAttribute |
ElementAccess |
EnumDataType |
EnumIndex |
EnumMemberIndex |
EnumSpecifier |
EventIndex |
ExpressionTag |
ExtendedNetCodeCompletionChars |
ExtensionMethodIndex |
FieldIndex |
FriendModifier |
InterfaceDataType |
InterfaceIndex |
InternalModifier |
LocalMethod |
LocalStyle |
MacroBody |
MethodIndex |
MethodStyle |
NamespaceDataType |
NamespaceIndex |
NamespaceInfo |
NameTag |
NeverAttribute |
NewStatement |
OutlineCommentText |
OutlineImportsText |
OutlineImportText |
OutlineUsingText |
OutParameter |
OverridableModifier |
PartialModifier |
PrivateModifier |
PropertyGetModifier |
PropertyIndex |
PropertySetModifier |
ProtectedModifier |
PtrTypeQualifier |
PublicModifier |
QualifiedDeclartion |
RefParameter |
SharedModifier |
SharedModifierCapitalized |
SnippetIndex |
SnippetStatementIndex |
StatementsGuideLines |
StaticModifier |
StructDataType |
StructIndex |
StructSpecifier |
StructureResWord |
TargetTypeReference |
TypeDataType |
TypeDeclaration |
TypedefStyle |
TypeIndex |
TypeInfo |
TypeReference |
TypeSpecifier |
TypeTag |
UnionSpecifier |
UnknownType |
UnnamedStruct |
UseExtensionMethods |
ValueModifier |
VirtualModifier |
VoidDataType |
XmlCommentStart |
XmlComplexTag |
XmlEndTag |
XmlFormatTag |
XmlIndex |
XmlTag |
XmlVbCommentStart |
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts Constructor

SyntaxParserConsts Constructor
Initializes a new instance of the SyntaxParserConsts class

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxParserConsts()
Public Sub New
public:
SyntaxParserConsts()
new : unit -> SyntaxParserConsts
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts Fields

SyntaxParserConsts Fields

The SyntaxParserConsts type exposes the following members.

Fields
Name | Description
AbstractModifier |
ArraySpecifier |
BuiltInTypeIndex |
BuitInTypeStyle |
BytesInternalName |
CantFindDeclaration |
CategoryClasses |
CategoryConstants |
CategoryDelegates |
CategoryEnums |
CategoryEvents |
CategoryFields |
CategoryInterfaces |
CategoryKeywords |
CategoryMethods |
CategoryNamespaces |
CategoryProperties |
CategorySnippets |
CategoryStructs |
ClassDataType |
ClassIndex |
ClassSpecifier |
ConstIndex |
Constructor |
DeclarationGuideLines |
DeclarationReference |
DeclarationReferenceList |
DefaultCAutoIndentChars |
DefaultCCodeCompletionChars |
DefaultCCodeCompletionStopChars |
DefaultCsAutoIndentChars |
DefaultCsCodeCompletionChars |
DefaultCsCodeCompletionStopChars |
DefaultCSmartFormatChars |
DefaultCsSmartFormatChars |
DefaultJavaScriptCodeCompletionChars |
DefaultNetAutoIndentChars |
DefaultNetCodeCompletionChars |
DefaultNetCodeCompletionStopChars |
DefaultNetSyntaxOptions |
DefaultPythonSyntaxOptions |
DefaultSqlSyntaxOptions |
DefaultVbCodeCompletionChars |
DefaultVbScriptCodeCompletionChars |
DefaultVbScriptSyntaxOptions |
DefaultVbSmartFormatChars |
DefaultVbSyntaxOptions |
DefaultWinFormsAssemblies |
DefaultWPFAssemblies |
DefineString |
DelegateIndex |
DescriptionTarget |
EditorBrowsable |
EditorBrowsableAttribute |
ElementAccess |
EnumDataType |
EnumIndex |
EnumMemberIndex |
EnumSpecifier |
EventIndex |
ExpressionTag |
ExtendedNetCodeCompletionChars |
ExtensionMethodIndex |
FieldIndex |
FriendModifier |
InterfaceDataType |
InterfaceIndex |
InternalModifier |
LocalMethod |
LocalStyle |
MacroBody |
MethodIndex |
MethodStyle |
NamespaceDataType |
NamespaceIndex |
NamespaceInfo |
NameTag |
NeverAttribute |
NewStatement |
OutlineCommentText |
OutlineImportsText |
OutlineImportText |
OutlineUsingText |
OutParameter |
OverridableModifier |
PartialModifier |
PrivateModifier |
PropertyGetModifier |
PropertyIndex |
PropertySetModifier |
ProtectedModifier |
PtrTypeQualifier |
PublicModifier |
QualifiedDeclartion |
RefParameter |
SharedModifier |
SharedModifierCapitalized |
SnippetIndex |
SnippetStatementIndex |
StatementsGuideLines |
StaticModifier |
StructDataType |
StructIndex |
StructSpecifier |
StructureResWord |
TargetTypeReference |
TypeDataType |
TypeDeclaration |
TypedefStyle |
TypeIndex |
TypeInfo |
TypeReference |
TypeSpecifier |
TypeTag |
UnionSpecifier |
UnknownType |
UnnamedStruct |
UseExtensionMethods |
ValueModifier |
VirtualModifier |
VoidDataType |
XmlCommentStart |
XmlComplexTag |
XmlEndTag |
XmlFormatTag |
XmlIndex |
XmlTag |
XmlVbCommentStart |
Top
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.AbstractModifier Field

SyntaxParserConstsAbstractModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string AbstractModifier
Public Const AbstractModifier As String
public:
literal String^ AbstractModifier
static val mutable AbstractModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ArraySpecifier Field

SyntaxParserConstsArraySpecifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ArraySpecifier
Public Const ArraySpecifier As String
public:
literal String^ ArraySpecifier
static val mutable ArraySpecifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.BuiltInTypeIndex Field

SyntaxParserConstsBuiltInTypeIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int BuiltInTypeIndex
Public Const BuiltInTypeIndex As Integer
public:
literal int BuiltInTypeIndex
static val mutable BuiltInTypeIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.BuitInTypeStyle Field

SyntaxParserConstsBuitInTypeStyle Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const byte BuitInTypeStyle
Public Const BuitInTypeStyle As Byte
public:
literal unsigned char BuitInTypeStyle
static val mutable BuitInTypeStyle: byte

Field Value

Type: Byte
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.BytesInternalName Field

SyntaxParserConstsBytesInternalName Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string BytesInternalName
Public Shared BytesInternalName As String
public:
static String^ BytesInternalName
static val mutable BytesInternalName: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CantFindDeclaration Field

SyntaxParserConstsCantFindDeclaration Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string CantFindDeclaration
Public Const CantFindDeclaration As String
public:
literal String^ CantFindDeclaration
static val mutable CantFindDeclaration: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryClasses Field

SyntaxParserConstsCategoryClasses Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryClasses
Public Shared CategoryClasses As String
public:
static String^ CategoryClasses
static val mutable CategoryClasses: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryConstants Field

SyntaxParserConstsCategoryConstants Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryConstants
Public Shared CategoryConstants As String
public:
static String^ CategoryConstants
static val mutable CategoryConstants: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryDelegates Field

SyntaxParserConstsCategoryDelegates Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryDelegates
Public Shared CategoryDelegates As String
public:
static String^ CategoryDelegates
static val mutable CategoryDelegates: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryEnums Field

SyntaxParserConstsCategoryEnums Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryEnums
Public Shared CategoryEnums As String
public:
static String^ CategoryEnums
static val mutable CategoryEnums: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryEvents Field

SyntaxParserConstsCategoryEvents Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryEvents
Public Shared CategoryEvents As String
public:
static String^ CategoryEvents
static val mutable CategoryEvents: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryFields Field

SyntaxParserConstsCategoryFields Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryFields
Public Shared CategoryFields As String
public:
static String^ CategoryFields
static val mutable CategoryFields: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryInterfaces Field

SyntaxParserConstsCategoryInterfaces Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryInterfaces
Public Shared CategoryInterfaces As String
public:
static String^ CategoryInterfaces
static val mutable CategoryInterfaces: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryKeywords Field

SyntaxParserConstsCategoryKeywords Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryKeywords
Public Shared CategoryKeywords As String
public:
static String^ CategoryKeywords
static val mutable CategoryKeywords: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryMethods Field

SyntaxParserConstsCategoryMethods Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryMethods
Public Shared CategoryMethods As String
public:
static String^ CategoryMethods
static val mutable CategoryMethods: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryNamespaces Field

SyntaxParserConstsCategoryNamespaces Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryNamespaces
Public Shared CategoryNamespaces As String
public:
static String^ CategoryNamespaces
static val mutable CategoryNamespaces: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryProperties Field

SyntaxParserConstsCategoryProperties Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryProperties
Public Shared CategoryProperties As String
public:
static String^ CategoryProperties
static val mutable CategoryProperties: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategorySnippets Field

SyntaxParserConstsCategorySnippets Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategorySnippets
Public Shared CategorySnippets As String
public:
static String^ CategorySnippets
static val mutable CategorySnippets: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.CategoryStructs Field

SyntaxParserConstsCategoryStructs Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryStructs
Public Shared CategoryStructs As String
public:
static String^ CategoryStructs
static val mutable CategoryStructs: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ClassDataType Field

SyntaxParserConstsClassDataType Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ClassDataType
Public Shared ClassDataType As String
public:
static String^ ClassDataType
static val mutable ClassDataType: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ClassIndex Field

SyntaxParserConstsClassIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ClassIndex
Public Const ClassIndex As Integer
public:
literal int ClassIndex
static val mutable ClassIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ClassSpecifier Field

SyntaxParserConstsClassSpecifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ClassSpecifier
Public Const ClassSpecifier As String
public:
literal String^ ClassSpecifier
static val mutable ClassSpecifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ConstIndex Field

SyntaxParserConstsConstIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ConstIndex
Public Const ConstIndex As Integer
public:
literal int ConstIndex
static val mutable ConstIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.Constructor Field

SyntaxParserConstsConstructor Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Constructor
Public Const Constructor As String
public:
literal String^ Constructor
static val mutable Constructor: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DeclarationGuideLines Field

SyntaxParserConstsDeclarationGuideLines Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool DeclarationGuideLines
Public Shared DeclarationGuideLines As Boolean
public:
static bool DeclarationGuideLines
static val mutable DeclarationGuideLines: bool

Field Value

Type: Boolean
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DeclarationReference Field

SyntaxParserConstsDeclarationReference Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DeclarationReference
Public Const DeclarationReference As String
public:
literal String^ DeclarationReference
static val mutable DeclarationReference: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DeclarationReferenceList Field

SyntaxParserConstsDeclarationReferenceList Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DeclarationReferenceList
Public Const DeclarationReferenceList As String
public:
literal String^ DeclarationReferenceList
static val mutable DeclarationReferenceList: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultCAutoIndentChars Field

SyntaxParserConstsDefaultCAutoIndentChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCAutoIndentChars
Public Shared DefaultCAutoIndentChars As String
public:
static String^ DefaultCAutoIndentChars
static val mutable DefaultCAutoIndentChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultCCodeCompletionChars Field

SyntaxParserConstsDefaultCCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCCodeCompletionChars
Public Shared DefaultCCodeCompletionChars As String
public:
static String^ DefaultCCodeCompletionChars
static val mutable DefaultCCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultCCodeCompletionStopChars Field

SyntaxParserConstsDefaultCCodeCompletionStopChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCCodeCompletionStopChars
Public Shared DefaultCCodeCompletionStopChars As String
public:
static String^ DefaultCCodeCompletionStopChars
static val mutable DefaultCCodeCompletionStopChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultCsAutoIndentChars Field

SyntaxParserConstsDefaultCsAutoIndentChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCsAutoIndentChars
Public Shared DefaultCsAutoIndentChars As String
public:
static String^ DefaultCsAutoIndentChars
static val mutable DefaultCsAutoIndentChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultCsCodeCompletionChars Field

SyntaxParserConstsDefaultCsCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCsCodeCompletionChars
Public Shared DefaultCsCodeCompletionChars As String
public:
static String^ DefaultCsCodeCompletionChars
static val mutable DefaultCsCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultCsCodeCompletionStopChars Field

SyntaxParserConstsDefaultCsCodeCompletionStopChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCsCodeCompletionStopChars
Public Shared DefaultCsCodeCompletionStopChars As String
public:
static String^ DefaultCsCodeCompletionStopChars
static val mutable DefaultCsCodeCompletionStopChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultCSmartFormatChars Field

SyntaxParserConstsDefaultCSmartFormatChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCSmartFormatChars
Public Shared DefaultCSmartFormatChars As String
public:
static String^ DefaultCSmartFormatChars
static val mutable DefaultCSmartFormatChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultCsSmartFormatChars Field

SyntaxParserConstsDefaultCsSmartFormatChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCsSmartFormatChars
Public Shared DefaultCsSmartFormatChars As String
public:
static String^ DefaultCsSmartFormatChars
static val mutable DefaultCsSmartFormatChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultJavaScriptCodeCompletionChars Field

SyntaxParserConstsDefaultJavaScriptCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultJavaScriptCodeCompletionChars
Public Shared DefaultJavaScriptCodeCompletionChars As String
public:
static String^ DefaultJavaScriptCodeCompletionChars
static val mutable DefaultJavaScriptCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultNetAutoIndentChars Field

SyntaxParserConstsDefaultNetAutoIndentChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultNetAutoIndentChars
Public Shared DefaultNetAutoIndentChars As String
public:
static String^ DefaultNetAutoIndentChars
static val mutable DefaultNetAutoIndentChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultNetCodeCompletionChars Field

SyntaxParserConstsDefaultNetCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultNetCodeCompletionChars
Public Shared DefaultNetCodeCompletionChars As String
public:
static String^ DefaultNetCodeCompletionChars
static val mutable DefaultNetCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultNetCodeCompletionStopChars Field

SyntaxParserConstsDefaultNetCodeCompletionStopChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultNetCodeCompletionStopChars
Public Shared DefaultNetCodeCompletionStopChars As String
public:
static String^ DefaultNetCodeCompletionStopChars
static val mutable DefaultNetCodeCompletionStopChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultNetSyntaxOptions Field

SyntaxParserConstsDefaultNetSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultNetSyntaxOptions
Public Shared DefaultNetSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultNetSyntaxOptions
static val mutable DefaultNetSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultPythonSyntaxOptions Field

SyntaxParserConstsDefaultPythonSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultPythonSyntaxOptions
Public Shared DefaultPythonSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultPythonSyntaxOptions
static val mutable DefaultPythonSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultSqlSyntaxOptions Field

SyntaxParserConstsDefaultSqlSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultSqlSyntaxOptions
Public Shared DefaultSqlSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultSqlSyntaxOptions
static val mutable DefaultSqlSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultVbCodeCompletionChars Field

SyntaxParserConstsDefaultVbCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultVbCodeCompletionChars
Public Shared DefaultVbCodeCompletionChars As String
public:
static String^ DefaultVbCodeCompletionChars
static val mutable DefaultVbCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultVbScriptCodeCompletionChars Field

SyntaxParserConstsDefaultVbScriptCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultVbScriptCodeCompletionChars
Public Shared DefaultVbScriptCodeCompletionChars As String
public:
static String^ DefaultVbScriptCodeCompletionChars
static val mutable DefaultVbScriptCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultVbScriptSyntaxOptions Field

SyntaxParserConstsDefaultVbScriptSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultVbScriptSyntaxOptions
Public Shared DefaultVbScriptSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultVbScriptSyntaxOptions
static val mutable DefaultVbScriptSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultVbSmartFormatChars Field

SyntaxParserConstsDefaultVbSmartFormatChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultVbSmartFormatChars
Public Shared DefaultVbSmartFormatChars As String
public:
static String^ DefaultVbSmartFormatChars
static val mutable DefaultVbSmartFormatChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultVbSyntaxOptions Field

SyntaxParserConstsDefaultVbSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultVbSyntaxOptions
Public Shared DefaultVbSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultVbSyntaxOptions
static val mutable DefaultVbSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultWinFormsAssemblies Field

SyntaxParserConstsDefaultWinFormsAssemblies Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultWinFormsAssemblies
Public Shared DefaultWinFormsAssemblies As String
public:
static String^ DefaultWinFormsAssemblies
static val mutable DefaultWinFormsAssemblies: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefaultWPFAssemblies Field

SyntaxParserConstsDefaultWPFAssemblies Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultWPFAssemblies
Public Shared DefaultWPFAssemblies As String
public:
static String^ DefaultWPFAssemblies
static val mutable DefaultWPFAssemblies: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DefineString Field

SyntaxParserConstsDefineString Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefineString
Public Const DefineString As String
public:
literal String^ DefineString
static val mutable DefineString: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DelegateIndex Field

SyntaxParserConstsDelegateIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DelegateIndex
Public Const DelegateIndex As Integer
public:
literal int DelegateIndex
static val mutable DelegateIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.DescriptionTarget Field

SyntaxParserConstsDescriptionTarget Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DescriptionTarget
Public Const DescriptionTarget As String
public:
literal String^ DescriptionTarget
static val mutable DescriptionTarget: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.EditorBrowsable Field

SyntaxParserConstsEditorBrowsable Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EditorBrowsable
Public Shared EditorBrowsable As String
public:
static String^ EditorBrowsable
static val mutable EditorBrowsable: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.EditorBrowsableAttribute Field

SyntaxParserConstsEditorBrowsableAttribute Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EditorBrowsableAttribute
Public Shared EditorBrowsableAttribute As String
public:
static String^ EditorBrowsableAttribute
static val mutable EditorBrowsableAttribute: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ElementAccess Field

SyntaxParserConstsElementAccess Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ElementAccess
Public Const ElementAccess As String
public:
literal String^ ElementAccess
static val mutable ElementAccess: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.EnumDataType Field

SyntaxParserConstsEnumDataType Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string EnumDataType
Public Shared EnumDataType As String
public:
static String^ EnumDataType
static val mutable EnumDataType: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.EnumIndex Field

SyntaxParserConstsEnumIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int EnumIndex
Public Const EnumIndex As Integer
public:
literal int EnumIndex
static val mutable EnumIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.EnumMemberIndex Field

SyntaxParserConstsEnumMemberIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int EnumMemberIndex
Public Const EnumMemberIndex As Integer
public:
literal int EnumMemberIndex
static val mutable EnumMemberIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.EnumSpecifier Field

SyntaxParserConstsEnumSpecifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string EnumSpecifier
Public Const EnumSpecifier As String
public:
literal String^ EnumSpecifier
static val mutable EnumSpecifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.EventIndex Field

SyntaxParserConstsEventIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int EventIndex
Public Const EventIndex As Integer
public:
literal int EventIndex
static val mutable EventIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ExpressionTag Field

SyntaxParserConstsExpressionTag Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ExpressionTag
Public Shared ExpressionTag As String
public:
static String^ ExpressionTag
static val mutable ExpressionTag: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ExtendedNetCodeCompletionChars Field

SyntaxParserConstsExtendedNetCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ExtendedNetCodeCompletionChars
Public Shared ExtendedNetCodeCompletionChars As String
public:
static String^ ExtendedNetCodeCompletionChars
static val mutable ExtendedNetCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ExtensionMethodIndex Field

SyntaxParserConstsExtensionMethodIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ExtensionMethodIndex
Public Const ExtensionMethodIndex As Integer
public:
literal int ExtensionMethodIndex
static val mutable ExtensionMethodIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.FieldIndex Field

SyntaxParserConstsFieldIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int FieldIndex
Public Const FieldIndex As Integer
public:
literal int FieldIndex
static val mutable FieldIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.FriendModifier Field

SyntaxParserConstsFriendModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string FriendModifier
Public Const FriendModifier As String
public:
literal String^ FriendModifier
static val mutable FriendModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.InterfaceDataType Field

SyntaxParserConstsInterfaceDataType Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string InterfaceDataType
Public Shared InterfaceDataType As String
public:
static String^ InterfaceDataType
static val mutable InterfaceDataType: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.InterfaceIndex Field

SyntaxParserConstsInterfaceIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int InterfaceIndex
Public Const InterfaceIndex As Integer
public:
literal int InterfaceIndex
static val mutable InterfaceIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.InternalModifier Field

SyntaxParserConstsInternalModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string InternalModifier
Public Const InternalModifier As String
public:
literal String^ InternalModifier
static val mutable InternalModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.LocalMethod Field

SyntaxParserConstsLocalMethod Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string LocalMethod
Public Const LocalMethod As String
public:
literal String^ LocalMethod
static val mutable LocalMethod: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.LocalStyle Field

SyntaxParserConstsLocalStyle Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const byte LocalStyle
Public Const LocalStyle As Byte
public:
literal unsigned char LocalStyle
static val mutable LocalStyle: byte

Field Value

Type: Byte
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.MacroBody Field

SyntaxParserConstsMacroBody Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string MacroBody
Public Const MacroBody As String
public:
literal String^ MacroBody
static val mutable MacroBody: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.MethodIndex Field

SyntaxParserConstsMethodIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int MethodIndex
Public Const MethodIndex As Integer
public:
literal int MethodIndex
static val mutable MethodIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.MethodStyle Field

SyntaxParserConstsMethodStyle Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const byte MethodStyle
Public Const MethodStyle As Byte
public:
literal unsigned char MethodStyle
static val mutable MethodStyle: byte

Field Value

Type: Byte
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.NamespaceDataType Field

SyntaxParserConstsNamespaceDataType Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NamespaceDataType
Public Shared NamespaceDataType As String
public:
static String^ NamespaceDataType
static val mutable NamespaceDataType: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.NamespaceIndex Field

SyntaxParserConstsNamespaceIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int NamespaceIndex
Public Const NamespaceIndex As Integer
public:
literal int NamespaceIndex
static val mutable NamespaceIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.NamespaceInfo Field

SyntaxParserConstsNamespaceInfo Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string NamespaceInfo
Public Const NamespaceInfo As String
public:
literal String^ NamespaceInfo
static val mutable NamespaceInfo: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.NameTag Field

SyntaxParserConstsNameTag Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NameTag
Public Shared NameTag As String
public:
static String^ NameTag
static val mutable NameTag: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.NeverAttribute Field

SyntaxParserConstsNeverAttribute Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NeverAttribute
Public Shared NeverAttribute As String
public:
static String^ NeverAttribute
static val mutable NeverAttribute: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.NewStatement Field

SyntaxParserConstsNewStatement Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string NewStatement
Public Shared NewStatement As String
public:
static String^ NewStatement
static val mutable NewStatement: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.OutlineCommentText Field

SyntaxParserConstsOutlineCommentText Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OutlineCommentText
Public Shared OutlineCommentText As String
public:
static String^ OutlineCommentText
static val mutable OutlineCommentText: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.OutlineImportsText Field

SyntaxParserConstsOutlineImportsText Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OutlineImportsText
Public Shared OutlineImportsText As String
public:
static String^ OutlineImportsText
static val mutable OutlineImportsText: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.OutlineImportText Field

SyntaxParserConstsOutlineImportText Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OutlineImportText
Public Shared OutlineImportText As String
public:
static String^ OutlineImportText
static val mutable OutlineImportText: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.OutlineUsingText Field

SyntaxParserConstsOutlineUsingText Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string OutlineUsingText
Public Shared OutlineUsingText As String
public:
static String^ OutlineUsingText
static val mutable OutlineUsingText: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.OutParameter Field

SyntaxParserConstsOutParameter Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string OutParameter
Public Const OutParameter As String
public:
literal String^ OutParameter
static val mutable OutParameter: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.OverridableModifier Field

SyntaxParserConstsOverridableModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string OverridableModifier
Public Const OverridableModifier As String
public:
literal String^ OverridableModifier
static val mutable OverridableModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.PartialModifier Field

SyntaxParserConstsPartialModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string PartialModifier
Public Const PartialModifier As String
public:
literal String^ PartialModifier
static val mutable PartialModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.PrivateModifier Field

SyntaxParserConstsPrivateModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string PrivateModifier
Public Const PrivateModifier As String
public:
literal String^ PrivateModifier
static val mutable PrivateModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.PropertyGetModifier Field

SyntaxParserConstsPropertyGetModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string PropertyGetModifier
Public Const PropertyGetModifier As String
public:
literal String^ PropertyGetModifier
static val mutable PropertyGetModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.PropertyIndex Field

SyntaxParserConstsPropertyIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int PropertyIndex
Public Const PropertyIndex As Integer
public:
literal int PropertyIndex
static val mutable PropertyIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.PropertySetModifier Field

SyntaxParserConstsPropertySetModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string PropertySetModifier
Public Const PropertySetModifier As String
public:
literal String^ PropertySetModifier
static val mutable PropertySetModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ProtectedModifier Field

SyntaxParserConstsProtectedModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ProtectedModifier
Public Const ProtectedModifier As String
public:
literal String^ ProtectedModifier
static val mutable ProtectedModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.PtrTypeQualifier Field

SyntaxParserConstsPtrTypeQualifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string PtrTypeQualifier
Public Const PtrTypeQualifier As String
public:
literal String^ PtrTypeQualifier
static val mutable PtrTypeQualifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.PublicModifier Field

SyntaxParserConstsPublicModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string PublicModifier
Public Const PublicModifier As String
public:
literal String^ PublicModifier
static val mutable PublicModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.QualifiedDeclartion Field

SyntaxParserConstsQualifiedDeclartion Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string QualifiedDeclartion
Public Const QualifiedDeclartion As String
public:
literal String^ QualifiedDeclartion
static val mutable QualifiedDeclartion: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.RefParameter Field

SyntaxParserConstsRefParameter Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string RefParameter
Public Const RefParameter As String
public:
literal String^ RefParameter
static val mutable RefParameter: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.SharedModifier Field

SyntaxParserConstsSharedModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string SharedModifier
Public Const SharedModifier As String
public:
literal String^ SharedModifier
static val mutable SharedModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.SharedModifierCapitalized Field

SyntaxParserConstsSharedModifierCapitalized Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string SharedModifierCapitalized
Public Const SharedModifierCapitalized As String
public:
literal String^ SharedModifierCapitalized
static val mutable SharedModifierCapitalized: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.SnippetIndex Field

SyntaxParserConstsSnippetIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int SnippetIndex
Public Const SnippetIndex As Integer
public:
literal int SnippetIndex
static val mutable SnippetIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.SnippetStatementIndex Field

SyntaxParserConstsSnippetStatementIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int SnippetStatementIndex
Public Const SnippetStatementIndex As Integer
public:
literal int SnippetStatementIndex
static val mutable SnippetStatementIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.StatementsGuideLines Field

SyntaxParserConstsStatementsGuideLines Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool StatementsGuideLines
Public Shared StatementsGuideLines As Boolean
public:
static bool StatementsGuideLines
static val mutable StatementsGuideLines: bool

Field Value

Type: Boolean
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.StaticModifier Field

SyntaxParserConstsStaticModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string StaticModifier
Public Const StaticModifier As String
public:
literal String^ StaticModifier
static val mutable StaticModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.StructDataType Field

SyntaxParserConstsStructDataType Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StructDataType
Public Shared StructDataType As String
public:
static String^ StructDataType
static val mutable StructDataType: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.StructIndex Field

SyntaxParserConstsStructIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int StructIndex
Public Const StructIndex As Integer
public:
literal int StructIndex
static val mutable StructIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.StructSpecifier Field

SyntaxParserConstsStructSpecifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string StructSpecifier
Public Const StructSpecifier As String
public:
literal String^ StructSpecifier
static val mutable StructSpecifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.StructureResWord Field

SyntaxParserConstsStructureResWord Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string StructureResWord
Public Shared StructureResWord As String
public:
static String^ StructureResWord
static val mutable StructureResWord: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.TargetTypeReference Field

SyntaxParserConstsTargetTypeReference Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TargetTypeReference
Public Const TargetTypeReference As String
public:
literal String^ TargetTypeReference
static val mutable TargetTypeReference: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.TypeDataType Field

SyntaxParserConstsTypeDataType Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TypeDataType
Public Shared TypeDataType As String
public:
static String^ TypeDataType
static val mutable TypeDataType: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.TypeDeclaration Field

SyntaxParserConstsTypeDeclaration Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeDeclaration
Public Const TypeDeclaration As String
public:
literal String^ TypeDeclaration
static val mutable TypeDeclaration: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.TypedefStyle Field

SyntaxParserConstsTypedefStyle Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const byte TypedefStyle
Public Const TypedefStyle As Byte
public:
literal unsigned char TypedefStyle
static val mutable TypedefStyle: byte

Field Value

Type: Byte
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.TypeIndex Field

SyntaxParserConstsTypeIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int TypeIndex
Public Const TypeIndex As Integer
public:
literal int TypeIndex
static val mutable TypeIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.TypeInfo Field

SyntaxParserConstsTypeInfo Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeInfo
Public Const TypeInfo As String
public:
literal String^ TypeInfo
static val mutable TypeInfo: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.TypeReference Field

SyntaxParserConstsTypeReference Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeReference
Public Const TypeReference As String
public:
literal String^ TypeReference
static val mutable TypeReference: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.TypeSpecifier Field

SyntaxParserConstsTypeSpecifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeSpecifier
Public Const TypeSpecifier As String
public:
literal String^ TypeSpecifier
static val mutable TypeSpecifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.TypeTag Field

SyntaxParserConstsTypeTag Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TypeTag
Public Shared TypeTag As String
public:
static String^ TypeTag
static val mutable TypeTag: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.UnionSpecifier Field

SyntaxParserConstsUnionSpecifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string UnionSpecifier
Public Const UnionSpecifier As String
public:
literal String^ UnionSpecifier
static val mutable UnionSpecifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.UnknownType Field

SyntaxParserConstsUnknownType Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string UnknownType
Public Shared UnknownType As String
public:
static String^ UnknownType
static val mutable UnknownType: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.UnnamedStruct Field

SyntaxParserConstsUnnamedStruct Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string UnnamedStruct
Public Const UnnamedStruct As String
public:
literal String^ UnnamedStruct
static val mutable UnnamedStruct: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.UseExtensionMethods Field

SyntaxParserConstsUseExtensionMethods Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool UseExtensionMethods
Public Shared UseExtensionMethods As Boolean
public:
static bool UseExtensionMethods
static val mutable UseExtensionMethods: bool

Field Value

Type: Boolean
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.ValueModifier Field

SyntaxParserConstsValueModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ValueModifier
Public Const ValueModifier As String
public:
literal String^ ValueModifier
static val mutable ValueModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.VirtualModifier Field

SyntaxParserConstsVirtualModifier Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VirtualModifier
Public Const VirtualModifier As String
public:
literal String^ VirtualModifier
static val mutable VirtualModifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.VoidDataType Field

SyntaxParserConstsVoidDataType Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VoidDataType
Public Const VoidDataType As String
public:
literal String^ VoidDataType
static val mutable VoidDataType: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.XmlCommentStart Field

SyntaxParserConstsXmlCommentStart Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string XmlCommentStart
Public Const XmlCommentStart As String
public:
literal String^ XmlCommentStart
static val mutable XmlCommentStart: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.XmlComplexTag Field

SyntaxParserConstsXmlComplexTag Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XmlComplexTag
Public Shared XmlComplexTag As String
public:
static String^ XmlComplexTag
static val mutable XmlComplexTag: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.XmlEndTag Field

SyntaxParserConstsXmlEndTag Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XmlEndTag
Public Shared XmlEndTag As String
public:
static String^ XmlEndTag
static val mutable XmlEndTag: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.XmlFormatTag Field

SyntaxParserConstsXmlFormatTag Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XmlFormatTag
Public Shared XmlFormatTag As String
public:
static String^ XmlFormatTag
static val mutable XmlFormatTag: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.XmlIndex Field

SyntaxParserConstsXmlIndex Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int XmlIndex
Public Const XmlIndex As Integer
public:
literal int XmlIndex
static val mutable XmlIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.XmlTag Field

SyntaxParserConstsXmlTag Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XmlTag
Public Shared XmlTag As String
public:
static String^ XmlTag
static val mutable XmlTag: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts.XmlVbCommentStart Field

SyntaxParserConstsXmlVbCommentStart Field

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string XmlVbCommentStart
Public Const XmlVbCommentStart As String
public:
literal String^ XmlVbCommentStart
static val mutable XmlVbCommentStart: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


SyntaxParserConsts Methods

SyntaxParserConsts Methods

The SyntaxParserConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Advanced Namespace


VbALexerToken Enumeration

VbALexerToken Enumeration

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VbALexerToken
Public Enumeration VbALexerToken
public enum class VbALexerToken
type VbALexerToken
Members
Member name | Value | Description
As | 117 |
Byte | 118 |
Boolean | 119 |
Char | 120 |
Date | 121 |
Double | 122 |
Decimal | 123 |
Float | 124 |
Integer | 125 |
Long | 126 |
Object | 127 |
Short | 128 |
Single | 129 |
String | 130 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


VBAParser Class

VBAParser Class
Represents class that and perform syntax and lexical analysis of specified VBA code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedVbScriptParser
Alternet.Syntax.Parsers.AdvancedVBAParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VBAParser : VbScriptParser
Public Class VBAParser
    Inherits VbScriptParser
public ref class VBAParser : public VbScriptParser
type VBAParser =
    class
        inherit VbScriptParser
    end

The VBAParser type exposes the following members.

Constructors
 | Name | Description
Public method | VBAParser | Initializes a new instance of the VBAParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from VbScriptParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from VbScriptParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from VbScriptParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from VbScriptParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from VbScriptParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from VbScriptParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from VbScriptParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from VbScriptParser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from VbScriptParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from VbScriptParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from VbScriptParser.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from VbScriptParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from VbScriptParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from VbScriptParser.)
Public method | ReparseText | Reparses entire text. (Inherited from VbScriptParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from VbScriptParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from VbScriptParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from VbScriptParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from VbScriptParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from VbScriptParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from VbScriptParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from VbScriptParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from VbScriptParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from VbScriptParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from VbScriptParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from VbScriptParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from VbScriptParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from VbScriptParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from VbScriptParser.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from VbScriptParser.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether VbScriptParser should perform case-sensitive analysis of its content. (Inherited from VbScriptParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


VBAParser Constructor

VBAParser Constructor
Initializes a new instance of the VBAParser class

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VBAParser()
Public Sub New
public:
VBAParser()
new : unit -> VBAParser
See Also

Reference

VBAParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VBAParser Methods

VBAParser Methods

The VBAParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from VbScriptParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from VbScriptParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from VbScriptParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from VbScriptParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from VbScriptParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from VbScriptParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from VbScriptParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from VbScriptParser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from VbScriptParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from VbScriptParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from VbScriptParser.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from VbScriptParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from VbScriptParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from VbScriptParser.)
Public method | ReparseText | Reparses entire text. (Inherited from VbScriptParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from VbScriptParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from VbScriptParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from VbScriptParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from VbScriptParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from VbScriptParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from VbScriptParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from VbScriptParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from VbScriptParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from VbScriptParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from VbScriptParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from VbScriptParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from VbScriptParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from VbScriptParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from VbScriptParser.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from VbScriptParser.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

VBAParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VBAParser Properties

VBAParser Properties

The VBAParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether VbScriptParser should perform case-sensitive analysis of its content. (Inherited from VbScriptParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

VBAParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VBAParser Events

VBAParser Events

The VBAParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

VBAParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbLexerToken Enumeration

VbLexerToken Enumeration
Represents lexical tokens for Vb parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VbLexerToken
Public Enumeration VbLexerToken
public enum class VbLexerToken
type VbLexerToken
Members
Member name | Value | Description
AddHandler | 0 |
AddressOf | 1 |
Alias | 2 |
And | 3 |
AndAlso | 4 |
Ansi | 5 |
As | 6 |
Assembly | 7 |
Async | 8 |
Auto | 9 |
Await | 10 |
Boolean | 11 |
ByRef | 12 |
Byte | 13 |
ByVal | 14 |
Call | 15 |
Case | 16 |
Catch | 17 |
CBool | 18 |
CByte | 19 |
CChar | 20 |
CDate | 21 |
CDbl | 22 |
CDec | 23 |
Char | 24 |
CInt | 25 |
Class | 26 |
CLng | 27 |
CObj | 28 |
Const | 29 |
Continue | 30 |
CShort | 31 |
CSng | 32 |
CStr | 33 |
CType | 34 |
Custom | 35 |
Date | 36 |
Decimal | 37 |
Declare | 38 |
Default | 39 |
Delegate | 40 |
Dim | 41 |
DirectCast | 42 |
Do | 43 |
Double | 44 |
Each | 45 |
Else | 46 |
ElseIf | 47 |
End | 48 |
EndIf | 49 |
Enum | 50 |
Erase | 51 |
Error | 52 |
Event | 53 |
Exit | 54 |
False | 55 |
Finally | 56 |
For | 57 |
Friend | 58 |
Function | 59 |
Get | 60 |
GetType | 61 |
GoSub | 62 |
GoTo | 63 |
Handles | 64 |
If | 65 |
Implements | 66 |
Imports | 67 |
In | 68 |
Inherits | 69 |
Integer | 70 |
Interface | 71 |
Is | 72 |
IsNot | 73 |
IsFalse | 74 |
Iterator | 75 |
IsTrue | 76 |
Lib | 77 |
Like | 78 |
Long | 79 |
Loop | 80 |
Me | 81 |
Mid | 82 |
Mod | 83 |
Module | 84 |
MustInherit | 85 |
MustOverride | 86 |
MyBase | 87 |
MyClass | 88 |
NameOf | 89 |
Namespace | 90 |
Narrowing | 91 |
New | 92 |
Next | 93 |
Not | 94 |
Nothing | 95 |
NotInheritable | 96 |
NotOverridable | 97 |
Object | 98 |
Of | 99 |
Operator | 100 |
Option | 101 |
Optional | 102 |
Or | 103 |
OrElse | 104 |
Overloads | 105 |
Overridable | 106 |
Overrides | 107 |
ParamArray | 108 |
Partial | 109 |
Preserve | 110 |
Private | 111 |
Property | 112 |
Protected | 113 |
Public | 114 |
RaiseEvent | 115 |
ReadOnly | 116 |
ReDim | 117 |
Region | 118 |
REM | 119 |
RemoveHandler | 120 |
Resume | 121 |
Return | 122 |
Select | 123 |
Set | 124 |
Shadows | 125 |
Shared | 126 |
Short | 127 |
Single | 128 |
Static | 129 |
Step | 130 |
Stop | 131 |
String | 132 |
Structure | 133 |
Sub | 134 |
SyncLock | 135 |
Then | 136 |
Throw | 137 |
To | 138 |
True | 139 |
Try | 140 |
TryCast | 141 |
TypeOf | 142 |
Unicode | 143 |
Until | 144 |
Using | 145 |
Variant | 146 |
Wend | 147 |
When | 148 |
While | 149 |
Widening | 150 |
With | 151 |
WithEvents | 152 |
WriteOnly | 153 |
Xor | 154 |
Key | 155 |
Let | 156 |
From | 157 |
Join | 158 |
Group | 159 |
Order | 160 |
By | 161 |
Equals | 162 |
Into | 163 |
Ascending | 164 |
Descending | 165 |
Distinct | 166 |
Where | 167 |
Take | 168 |
Skip | 169 |
Explicit | 170 |
Strict | 171 |
Compare | 172 |
Infer | 173 |
On | 174 |
Off | 175 |
Aggregate | 176 |
Open_brace | 177 |
Close_brace | 178 |
Open_parens | 179 |
Close_parens | 180 |
Dot | 181 |
TripleDot | 182 |
Comma | 183 |
Semicolon | 184 |
Colon | 185 |
Pound | 186 |
LineContinuation | 187 |
Plus | 188 |
Minus | 189 |
Bang | 190 |
Assign | 191 |
Op_lt | 192 |
Op_gt | 193 |
Op_integer | 194 |
Op_long | 195 |
Op_decimal | 196 |
Op_single | 197 |
Op_double | 198 |
Op_string | 199 |
Star | 200 |
Div | 201 |
IntDiv | 202 |
Interr | 203 |
Carret | 204 |
Op_shift_left | 205 |
Op_shift_right | 206 |
Op_le | 207 |
Op_ge | 208 |
Op_ne | 209 |
Op_mult_assign | 210 |
Op_div_assign | 211 |
Op_intdiv_assign | 212 |
Op_add_assign | 213 |
Op_sub_assign | 214 |
Op_shift_left_assign | 215 |
Op_shift_right_assign | 216 |
Op_exp_assign | 217 |
String_and_assign | 218 |
Whitespace_Literal | 219 |
Identifier_Literal | 220 |
Integer_Literal | 221 |
Short_Literal | 222 |
Long_Literal | 223 |
Float_Literal | 224 |
Double_Literal | 225 |
Decimal_Literal | 226 |
Date_Literal | 227 |
Character_Literal | 228 |
String_Literal | 229 |
Comment_Literal | 230 |
XmlComment_Literal | 231 |
XmlInnerComment_Literal | 232 |
Directive_Literal | 233 |
None | 234 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


VbParser Class

VbParser Class
Represents class that and perform syntax and lexical analysis of specified Visual Basic.NET code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedNetSyntaxParser
Alternet.Syntax.Parsers.AdvancedVbParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbParser : NetSyntaxParser
Public Class VbParser
    Inherits NetSyntaxParser
public ref class VbParser : public NetSyntaxParser
type VbParser =
    class
        inherit NetSyntaxParser
    end

The VbParser type exposes the following members.

Constructors
 | Name | Description
Public method | VbParser | Initializes a new instance of the VbParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from NetSyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides NetSyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from NetSyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from NetSyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NetSyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides NetSyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from NetSyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from NetSyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Overrides NetSyntaxParserGetXmlComment.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NetSyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from NetSyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides NetSyntaxParserProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterObject | Adds specified object for code completion to the repository's object list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides NetSyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point, String, ISyntaxNode, CodeCompletionType).)
Public method | ReparseText | Reparses entire text. (Inherited from NetSyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets Parser to the start position. (Overrides NetSyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from NetSyntaxParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides NetSyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from NetSyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides NetSyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from NetSyntaxParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from NetSyntaxParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from NetSyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides NetSyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from NetSyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides NetSyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides NetSyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Overrides SyntaxParserSupportsContentDividers.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterNamespace | Removes specified namespace from the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | UnregisterObject | Removes specified object from the repository's object list. (Inherited from NetSyntaxParser.)
Public method | UnregisterType | Removes specified type from the repository's type list. (Inherited from NetSyntaxParser.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether VbParser should perform case-sensitive analysis of its content. (Overrides NetSyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Inherited from NetSyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


VbParser Constructor

VbParser Constructor
Initializes a new instance of the VbParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbParser()
Public Sub New
public:
VbParser()
new : unit -> VbParser
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser Methods

VbParser Methods

The VbParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from NetSyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides NetSyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from NetSyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from NetSyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Inherited from NetSyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides NetSyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from NetSyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from NetSyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Gets the string that represents start symbols of xml comment. (Overrides NetSyntaxParserGetXmlComment.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Inherited from NetSyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from NetSyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides NetSyntaxParserProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAllAssemblies | Registers all assemblies from the current application domain. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | RegisterDefaultAssemblies | Registers some most frequently used assemblies. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterNamespace(String, String) | Adds specified namespace to the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | RegisterObject | Adds specified object for code completion to the repository's object list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RegisterType(String, Type, Boolean) | Adds specified type for code completion to the repository's type list. (Inherited from NetSyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides NetSyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point, String, ISyntaxNode, CodeCompletionType).)
Public method | ReparseText | Reparses entire text. (Inherited from NetSyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets Parser to the start position. (Overrides NetSyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from NetSyntaxParser.)
Public method | ResetCodeCompletionChars | Resets the CodeCompletionChars to the default value. (Overrides NetSyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from NetSyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides NetSyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from NetSyntaxParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from NetSyntaxParser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from NetSyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides NetSyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from NetSyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides NetSyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides NetSyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Overrides SyntaxParserSupportsContentDividers.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list. (Inherited from NetSyntaxParser.)
Public method | UnregisterNamespace | Removes specified namespace from the repository's namespace list. (Inherited from NetSyntaxParser.)
Public method | UnregisterObject | Removes specified object from the repository's object list. (Inherited from NetSyntaxParser.)
Public method | UnregisterType | Removes specified type from the repository's type list. (Inherited from NetSyntaxParser.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.CreateRepository Method

VbParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.GetCompletionType Method

VbParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides NetSyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.GetCompletionType Method (Char)

VbParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

VbParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.GetSingleLineComment Method

VbParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.GetSingleLineComment Method

VbParserGetSingleLineComment Method
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

VbParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.GetXmlComment Method

VbParserGetXmlComment Method
Gets the string that represents start symbols of xml comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetXmlComment()
Public Overrides Function GetXmlComment As String
public:
virtual String^ GetXmlComment() override
abstract GetXmlComment : unit -> string
override GetXmlComment : unit -> string

Return Value

Type: String
Xml comment string.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.IsCodeCompletionChar Method

VbParserIsCodeCompletionChar Method
Returns boolean value indicating that given character initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Public Overrides Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
public:
virtual bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
) override
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool
override IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
Given character.
style
Type: SystemByte
Specifies text style at cursor.
interval
Type: SystemInt32
Represents the delay, in milliseconds before displaying code completion window.

Return Value

Type: Boolean
True if given character is code completion character; otherwise false.

Implements

ISyntaxParserIsCodeCompletionChar(Char, Byte, Int32)
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.NextToken Method

VbParserNextToken Method
Overload List
 | Name | Description
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.NextToken Method

VbParserNextToken Method
Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int NextToken()
Public Overrides Function NextToken As Integer
public:
virtual int NextToken() override
abstract NextToken : unit -> int
override NextToken : unit -> int

Return Value

Type: Int32
Token that corresponds to the next position.

Implements

IParserNextToken
See Also

Reference

VbParser Class
NextToken Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ProcessAutoComplete Method

VbParserProcessAutoComplete Method
Checks whether end-of-block code needs inserting.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ProcessAutoComplete(
    string text,
    Point position,
    out string code
)
Public Overrides Function ProcessAutoComplete (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessAutoComplete(
    String^ text,
    Point position,
    [OutAttribute] String^% code
) override
abstract ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if autocompletion of end-of-block needed; otherwise false.

Implements

ISyntaxParserProcessAutoComplete(String, Point, String)
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ReparseBlock Method

VbParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides NetSyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point, String, ISyntaxNode, CodeCompletionType).)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ReparseBlock Method (Point)

VbParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    Point position
)
Public Overrides Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
) override
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

VbParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ReparseBlock Method (Point, String, ISyntaxNode, CodeCompletionType)

VbParserReparseBlock Method (Point, String, ISyntaxNode, CodeCompletionType)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    ref Point position,
    string text,
    out ISyntaxNode node,
    CodeCompletionType completionType
)
Public Overrides Function ReparseBlock (
    ByRef position As Point,
    text As String,
    <OutAttribute> ByRef node As ISyntaxNode,
    completionType As CodeCompletionType
) As Boolean
public:
virtual bool ReparseBlock(
    Point% position,
    String^ text,
    [OutAttribute] ISyntaxNode^% node,
    CodeCompletionType completionType
) override
abstract ReparseBlock :
        position : Point byref *
        text : string *
        node : ISyntaxNode byref *
        completionType : CodeCompletionType -> bool
override ReparseBlock :
        position : Point byref *
        text : string *
        node : ISyntaxNode byref *
        completionType : CodeCompletionType -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.
text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Returns node corresponding to the block being reparsed.
completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion reason.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point, String, ISyntaxNode, CodeCompletionType)
See Also

Reference

VbParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.Reset Method

VbParserReset Method
Overload List
 | Name | Description
Public method | Reset | Resets Parser to the start position. (Overrides NetSyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.Reset Method

VbParserReset Method
Resets Parser to the start position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
IParserReset
See Also

Reference

VbParser Class
Reset Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ResetCodeCompletionChars Method

VbParserResetCodeCompletionChars Method
Resets the CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ResetOptions Method

VbParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ResetSmartFormatChars Method

VbParserResetSmartFormatChars Method
Resets SmartFormatChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetSmartFormatChars()
Public Overrides Sub ResetSmartFormatChars
public:
virtual void ResetSmartFormatChars() override
abstract ResetSmartFormatChars : unit -> unit
override ResetSmartFormatChars : unit -> unit

Implements

ISyntaxParserResetSmartFormatChars
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ShouldSerializeCodeCompletionChars Method

VbParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ShouldSerializeOptions Method

VbParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.ShouldSerializeSmartFormatChars Method

VbParserShouldSerializeSmartFormatChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeSmartFormatChars()
Public Overrides Function ShouldSerializeSmartFormatChars As Boolean
public:
virtual bool ShouldSerializeSmartFormatChars() override
abstract ShouldSerializeSmartFormatChars : unit -> bool
override ShouldSerializeSmartFormatChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.SmartFormatLine Method

VbParserSmartFormatLine Method
Overload List
 | Name | Description
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides NetSyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList, Boolean)

VbParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList, Boolean)
Formats line according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations,
    out bool actualPosition
)
Public Overrides Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations,
    [OutAttribute] bool% actualPosition
) override
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int
override SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at given line.

Implements

ISyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean)
See Also

Reference

VbParser Class
SmartFormatLine Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.SupportsContentDividers Method

VbParserSupportsContentDividers Method
Indicates whether content dividers are supported.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SupportsContentDividers()
Public Overrides Function SupportsContentDividers As Boolean
public:
virtual bool SupportsContentDividers() override
abstract SupportsContentDividers : unit -> bool
override SupportsContentDividers : unit -> bool

Return Value

Type: Boolean
True if content dividers are supported; otherwise false.

Implements

ISyntaxParserSupportsContentDividers
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser Properties

VbParser Properties

The VbParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether VbParser should perform case-sensitive analysis of its content. (Overrides NetSyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | (Inherited from NetSyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser.CaseSensitive Property

VbParserCaseSensitive Property
Gets or sets a boolean value that indicates whether VbParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbParser Events

VbParser Events

The VbParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptLexerToken Enumeration

VbScriptLexerToken Enumeration
Represents lexical tokens for VB Script parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VbScriptLexerToken
Public Enumeration VbScriptLexerToken
public enum class VbScriptLexerToken
type VbScriptLexerToken
Members
Member name | Value | Description
Empty | 0 |
False | 1 |
Nothing | 2 |
Null | 3 |
True | 4 |
Mod | 5 |
Is | 6 |
Not | 7 |
And | 8 |
Or | 9 |
Xor | 10 |
Eqv | 11 |
Imp | 12 |
Function | 13 |
Sub | 14 |
Dim | 15 |
Const | 16 |
ReDim | 17 |
Call | 18 |
Preserve | 19 |
Public | 20 |
Private | 21 |
Default | 22 |
Class | 23 |
Property | 24 |
New | 25 |
Do | 26 |
Erase | 27 |
Execute | 28 |
ExecuteGlobal | 29 |
Exit | 30 |
For | 31 |
If | 32 |
On | 33 |
Option | 34 |
Randomize | 35 |
Select | 36 |
Set | 37 |
Stop | 38 |
While | 39 |
With | 40 |
Then | 41 |
Else | 42 |
ElseIf | 43 |
Error | 44 |
Resume | 45 |
GoTo | 46 |
Get | 47 |
Let | 48 |
Next | 49 |
Case | 50 |
Wend | 51 |
Loop | 52 |
Until | 53 |
Each | 54 |
In | 55 |
To | 56 |
Step | 57 |
ByVal | 58 |
ByRef | 59 |
End | 60 |
Boolean | 61 |
Byte | 62 |
Char | 63 |
Date | 64 |
Decimal | 65 |
Double | 66 |
Float | 67 |
DateTime | 68 |
Integer | 69 |
Long | 70 |
Object | 71 |
Short | 72 |
Single | 73 |
String | 74 |
CBool | 75 |
CByte | 76 |
CChar | 77 |
CDate | 78 |
CDbl | 79 |
CDec | 80 |
CInt | 81 |
CLng | 82 |
CObj | 83 |
CShort | 84 |
CSng | 85 |
CStr | 86 |
Open_parens | 87 |
Close_parens | 88 |
Dot | 89 |
Comma | 90 |
Colon | 91 |
Plus | 92 |
Minus | 93 |
Op_ne | 94 |
Op_le | 95 |
Op_lt | 96 |
Op_ge | 97 |
Op_gt | 98 |
Assign | 99 |
Op_and | 100 |
Star | 101 |
Div | 102 |
IntDiv | 103 |
Exponent | 104 |
LineContinuation | 105 |
Integer_Literal | 106 |
Float_Literal | 107 |
Double_Literal | 108 |
Date_Literal | 109 |
Character_Literal | 110 |
String_Literal | 111 |
Identifier_Literal | 112 |
Comment_Literal | 113 |
Directive_Literal | 114 |
Whitespace_Literal | 115 |
None | 116 |
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser Class

VbScriptParser Class
Represents class that and perform syntax and lexical analysis of specified Visual Basic Script code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.AdvancedVbScriptParser
Alternet.Syntax.Parsers.AdvancedVBAParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbScriptParser : SyntaxParser
Public Class VbScriptParser
    Inherits SyntaxParser
public ref class VbScriptParser : public SyntaxParser
type VbScriptParser =
    class
        inherit SyntaxParser
    end

The VbScriptParser type exposes the following members.

Constructors
 | Name | Description
Public method | VbScriptParser | Initializes a new instance of the VbParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Overrides SyntaxParserFinishParsing.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Overrides SyntaxParserGetAutoFormatNode(Point, Boolean, Point).)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides SyntaxParserIsDeclaration(ISyntaxNode).)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides SyntaxParserProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point, String, ISyntaxNode, CodeCompletionType).)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Overrides SyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether VbScriptParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser Constructor

VbScriptParser Constructor
Initializes a new instance of the VbParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbScriptParser()
Public Sub New
public:
VbScriptParser()
new : unit -> VbScriptParser
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser Methods

VbScriptParser Methods

The VbScriptParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Overrides SyntaxParserFinishParsing.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Obtains block node at specified position. (Overrides SyntaxParserGetAutoFormatNode(Point, Boolean, Point).)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on). (Overrides SyntaxParserIsDeclaration(ISyntaxNode).)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides SyntaxParserProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point, String, ISyntaxNode, CodeCompletionType).)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Overrides SyntaxParserResetCodeCompletionStopChars.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Overrides ParserSaveState.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionStopChars.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.CreateRepository Method

VbScriptParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.FinishParsing Method

VbScriptParserFinishParsing Method
Commits parsing process.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FinishParsing()
Public Overrides Sub FinishParsing
public:
virtual void FinishParsing() override
abstract FinishParsing : unit -> unit
override FinishParsing : unit -> unit

Implements

ISyntaxParserFinishParsing
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.GetAutoFormatNode Method

VbScriptParserGetAutoFormatNode Method
Obtains block node at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISyntaxNode GetAutoFormatNode(
    Point position,
    bool extended,
    out Point startPt
)
Public Overrides Function GetAutoFormatNode (
    position As Point,
    extended As Boolean,
    <OutAttribute> ByRef startPt As Point
) As ISyntaxNode
public:
virtual ISyntaxNode^ GetAutoFormatNode(
    Point position,
    bool extended,
    [OutAttribute] Point% startPt
) override
abstract GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode
override GetAutoFormatNode :
        position : Point *
        extended : bool *
        startPt : Point byref -> ISyntaxNode

Parameters

position
Type: System.DrawingPoint
Position to check-up.
extended
Type: SystemBoolean
Specifies that search should be extended outside current scope.
startPt
Type: System.DrawingPoint
Retrieves position of block node.

Return Value

Type: ISyntaxNode
ISyntaxNode node representing block statement.

Implements

ISyntaxParserGetAutoFormatNode(Point, Boolean, Point)
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.GetCompletionType Method

VbScriptParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.GetCompletionType Method (Char)

VbScriptParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

VbScriptParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.GetSingleLineComment Method

VbScriptParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.GetSingleLineComment Method

VbScriptParserGetSingleLineComment Method
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

VbScriptParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.GetStructureGuideLines Method

VbScriptParserGetStructureGuideLines Method
Gets list of guide lines.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetStructureGuideLines(
    IList<IRange> guideLines
)
Public Overrides Function GetStructureGuideLines (
    guideLines As IList(Of IRange)
) As Integer
public:
virtual int GetStructureGuideLines(
    IList<IRange^>^ guideLines
) override
abstract GetStructureGuideLines :
        guideLines : IList<IRange> -> int
override GetStructureGuideLines :
        guideLines : IList<IRange> -> int

Parameters

guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.

Implements

ISyntaxParserGetStructureGuideLines(IListIRange)
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.IsDeclaration Method

VbScriptParserIsDeclaration Method
Indicates whether specified node is a declaration node (contains declaration of some syntax structure, such as class, namespace and so on).

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsDeclaration(
    ISyntaxNode node
)
Public Overrides Function IsDeclaration (
    node As ISyntaxNode
) As Boolean
public:
virtual bool IsDeclaration(
    ISyntaxNode^ node
) override
abstract IsDeclaration :
        node : ISyntaxNode -> bool
override IsDeclaration :
        node : ISyntaxNode -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
Specifies ISyntaxNode to check-up.

Return Value

Type: Boolean
True if specified node is declaration node; otherwise false.

Implements

ISyntaxParserIsDeclaration(ISyntaxNode)
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.NextToken Method

VbScriptParserNextToken Method
Overload List
 | Name | Description
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.NextToken Method

VbScriptParserNextToken Method
Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int NextToken()
Public Overrides Function NextToken As Integer
public:
virtual int NextToken() override
abstract NextToken : unit -> int
override NextToken : unit -> int

Return Value

Type: Int32
Token that corresponds to the next position.

Implements

IParserNextToken
See Also

Reference

VbScriptParser Class
NextToken Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.PositionChanged Method

VbScriptParserPositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overrides Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
) override
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxParserPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ProcessAutoComplete Method

VbScriptParserProcessAutoComplete Method
Checks whether end-of-block code needs inserting.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ProcessAutoComplete(
    string text,
    Point position,
    out string code
)
Public Overrides Function ProcessAutoComplete (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessAutoComplete(
    String^ text,
    Point position,
    [OutAttribute] String^% code
) override
abstract ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if autocompletion of end-of-block needed; otherwise false.

Implements

ISyntaxParserProcessAutoComplete(String, Point, String)
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.RegisterAssembly Method

VbScriptParserRegisterAssembly Method
Overload List
 | Name | Description
Public method | RegisterAssembly(Assembly) | Adds specified assembly for code completion to the repository's assembly list.
Public method | RegisterAssembly(String) | Adds specified assembly for code completion to the repository's assembly list.
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.RegisterAssembly Method (Assembly)

VbScriptParserRegisterAssembly Method (Assembly)
Adds specified assembly for code completion to the repository's assembly list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterAssembly(
    Assembly assembly
)
Public Overridable Sub RegisterAssembly (
    assembly As Assembly
)
public:
virtual void RegisterAssembly(
    Assembly^ assembly
)
abstract RegisterAssembly :
        assembly : Assembly -> unit
override RegisterAssembly :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Specifies registered assembly.
See Also

Reference

VbScriptParser Class
RegisterAssembly Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.RegisterAssembly Method (String)

VbScriptParserRegisterAssembly Method (String)
Adds specified assembly for code completion to the repository's assembly list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RegisterAssembly(
    string name
)
Public Overridable Function RegisterAssembly (
    name As String
) As Boolean
public:
virtual bool RegisterAssembly(
    String^ name
)
abstract RegisterAssembly :
        name : string -> bool
override RegisterAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Specifies name of the assembly.

Return Value

Type: Boolean
See Also

Reference

VbScriptParser Class
RegisterAssembly Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ReparseBlock Method

VbScriptParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point, String, ISyntaxNode, CodeCompletionType).)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ReparseBlock Method (Point)

VbScriptParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    Point position
)
Public Overrides Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
) override
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

VbScriptParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ReparseBlock Method (Point, String, ISyntaxNode, CodeCompletionType)

VbScriptParserReparseBlock Method (Point, String, ISyntaxNode, CodeCompletionType)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    ref Point position,
    string text,
    out ISyntaxNode node,
    CodeCompletionType completionType
)
Public Overrides Function ReparseBlock (
    ByRef position As Point,
    text As String,
    <OutAttribute> ByRef node As ISyntaxNode,
    completionType As CodeCompletionType
) As Boolean
public:
virtual bool ReparseBlock(
    Point% position,
    String^ text,
    [OutAttribute] ISyntaxNode^% node,
    CodeCompletionType completionType
) override
abstract ReparseBlock :
        position : Point byref *
        text : string *
        node : ISyntaxNode byref *
        completionType : CodeCompletionType -> bool
override ReparseBlock :
        position : Point byref *
        text : string *
        node : ISyntaxNode byref *
        completionType : CodeCompletionType -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.
text
Type: SystemString
Specifies source text.
node
Type: Alternet.SyntaxISyntaxNode
Returns node corresponding to the block being reparsed.
completionType
Type: Alternet.SyntaxCodeCompletionType
Specifies code completion reason.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point, String, ISyntaxNode, CodeCompletionType)
See Also

Reference

VbScriptParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ReparseText Method

VbScriptParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ReparseText Method

VbScriptParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

VbScriptParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ResetAutoIndentChars Method

VbScriptParserResetAutoIndentChars Method
Resets AutoIndentChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ResetCodeCompletionChars Method

VbScriptParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ResetCodeCompletionStopChars Method

VbScriptParserResetCodeCompletionStopChars Method
Resets CodeCompletionStopChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionStopChars()
Public Overrides Sub ResetCodeCompletionStopChars
public:
virtual void ResetCodeCompletionStopChars() override
abstract ResetCodeCompletionStopChars : unit -> unit
override ResetCodeCompletionStopChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionStopChars
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ResetOptions Method

VbScriptParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ResetSmartFormatChars Method

VbScriptParserResetSmartFormatChars Method
Resets SmartFormatChars to the default value.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetSmartFormatChars()
Public Overrides Sub ResetSmartFormatChars
public:
virtual void ResetSmartFormatChars() override
abstract ResetSmartFormatChars : unit -> unit
override ResetSmartFormatChars : unit -> unit

Implements

ISyntaxParserResetSmartFormatChars
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.RestoreState Method

VbScriptParserRestoreState Method
Overload List
 | Name | Description
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.RestoreState Method (Boolean)

VbScriptParserRestoreState Method (Boolean)
Restores Parser state and position stored by SaveState method.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void RestoreState(
    bool restore
)
Public Overrides Sub RestoreState (
    restore As Boolean
)
public:
virtual void RestoreState(
    bool restore
) override
abstract RestoreState :
        restore : bool -> unit
override RestoreState :
        restore : bool -> unit

Parameters

restore
Type: SystemBoolean
Indicates whether Parser should restore it's state to previous position or simply delete information about previously stored state.

Implements

IParserRestoreState(Boolean)
See Also

Reference

VbScriptParser Class
RestoreState Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.SaveState Method

VbScriptParserSaveState Method
Saves current Parser state and position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void SaveState()
Public Overrides Sub SaveState
public:
virtual void SaveState() override
abstract SaveState : unit -> unit
override SaveState : unit -> unit

Implements

IParserSaveState
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ShouldSerializeAutoIndentChars Method

VbScriptParserShouldSerializeAutoIndentChars Method
Indicates whether the AutoIndentChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeAutoIndentChars()
Public Overrides Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars() override
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if AutoIndentChars differs from its default value; otherwise false.
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ShouldSerializeCodeCompletionChars Method

VbScriptParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ShouldSerializeCodeCompletionStopChars Method

VbScriptParserShouldSerializeCodeCompletionStopChars Method
Indicates whether the CodeCompletionStopChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionStopChars()
Public Overrides Function ShouldSerializeCodeCompletionStopChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionStopChars() override
abstract ShouldSerializeCodeCompletionStopChars : unit -> bool
override ShouldSerializeCodeCompletionStopChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionStopChars differs from its default value; otherwise false.
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ShouldSerializeOptions Method

VbScriptParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.ShouldSerializeSmartFormatChars Method

VbScriptParserShouldSerializeSmartFormatChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeSmartFormatChars()
Public Overrides Function ShouldSerializeSmartFormatChars As Boolean
public:
virtual bool ShouldSerializeSmartFormatChars() override
abstract ShouldSerializeSmartFormatChars : unit -> bool
override ShouldSerializeSmartFormatChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.SmartFormatLine Method

VbScriptParserSmartFormatLine Method
Overload List
 | Name | Description
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Overrides SyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean).)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.SmartFormatLine Method (Int32, String, StringItemInfo[], ITextUndoList, Boolean)

VbScriptParserSmartFormatLine Method (Int32, String, StringItemInfo, ITextUndoList, Boolean)
Formats line according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int SmartFormatLine(
    int index,
    string text,
    StringItemInfo[] textData,
    ITextUndoList operations,
    out bool actualPosition
)
Public Overrides Function SmartFormatLine (
    index As Integer,
    text As String,
    textData As StringItemInfo(),
    operations As ITextUndoList,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int SmartFormatLine(
    int index,
    String^ text,
    array<StringItemInfo>^ textData,
    ITextUndoList^ operations,
    [OutAttribute] bool% actualPosition
) override
abstract SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int
override SmartFormatLine :
        index : int *
        text : string *
        textData : StringItemInfo[] *
        operations : ITextUndoList *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to format.
text
Type: SystemString
Specifies string representation of the line.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at given line.

Implements

ISyntaxParserSmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean)
See Also

Reference

VbScriptParser Class
SmartFormatLine Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.UnregisterAssembly Method

VbScriptParserUnregisterAssembly Method
Overload List
 | Name | Description
Public method | UnregisterAssembly(Assembly, Boolean) | Removes specified assembly from the repository's assembly list.
Public method | UnregisterAssembly(String, Boolean) | Removes specified assembly from the repository's assembly list.
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.UnregisterAssembly Method (Assembly, Boolean)

VbScriptParserUnregisterAssembly Method (Assembly, Boolean)
Removes specified assembly from the repository's assembly list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterAssembly(
    Assembly assembly,
    bool removeReferences
)
Public Overridable Function UnregisterAssembly (
    assembly As Assembly,
    removeReferences As Boolean
) As Boolean
public:
virtual bool UnregisterAssembly(
    Assembly^ assembly,
    bool removeReferences
)
abstract UnregisterAssembly :
        assembly : Assembly *
        removeReferences : bool -> bool
override UnregisterAssembly :
        assembly : Assembly *
        removeReferences : bool -> bool

Parameters

assembly
Type: System.ReflectionAssembly
Specifies assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all types from the specified assembly should be unregistered.

Return Value

Type: Boolean
True if succeed (assembly is present in the assembly list); otherwise false.
See Also

Reference

VbScriptParser Class
UnregisterAssembly Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.UnregisterAssembly Method (String, Boolean)

VbScriptParserUnregisterAssembly Method (String, Boolean)
Removes specified assembly from the repository's assembly list.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterAssembly(
    string name,
    bool removeReferences
)
Public Overridable Function UnregisterAssembly (
    name As String,
    removeReferences As Boolean
) As Boolean
public:
virtual bool UnregisterAssembly(
    String^ name,
    bool removeReferences
)
abstract UnregisterAssembly :
        name : string *
        removeReferences : bool -> bool
override UnregisterAssembly :
        name : string *
        removeReferences : bool -> bool

Parameters

name
Type: SystemString
Specifies name of assembly to remove.
removeReferences
Type: SystemBoolean
Indicates whether all types from the specified assembly should be unregistered.

Return Value

Type: Boolean
True if succeed (assembly is present in the assembly list); otherwise false.
See Also

Reference

VbScriptParser Class
UnregisterAssembly Overload
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser Properties

VbScriptParser Properties

The VbScriptParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether VbScriptParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser.CaseSensitive Property

VbScriptParserCaseSensitive Property
Gets or sets a boolean value that indicates whether VbScriptParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


VbScriptParser Events

VbScriptParser Events

The VbScriptParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbScriptParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlCommentParser Class

XmlCommentParser Class
Represents properties and methods to perform syntax analysis of specified xml code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.SyntaxXmlParser
Alternet.Syntax.Parsers.AdvancedXmlCommentParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCommentParser : XmlParser
Public Class XmlCommentParser
    Inherits XmlParser
public ref class XmlCommentParser : public XmlParser
type XmlCommentParser =
    class
        inherit XmlParser
    end

The XmlCommentParser type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCommentParser | Initializes a new instance of the XmlCommentParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from XmlParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from XmlParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets XmlCommentParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from XmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


XmlCommentParser Constructor

XmlCommentParser Constructor
Initializes a new instance of the XmlCommentParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCommentParser()
Public Sub New
public:
XmlCommentParser()
new : unit -> XmlCommentParser
See Also

Reference

XmlCommentParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlCommentParser Methods

XmlCommentParser Methods

The XmlCommentParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from XmlParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from XmlParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets XmlCommentParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

XmlCommentParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlCommentParser.Reset Method

XmlCommentParserReset Method
Overload List
 | Name | Description
Public method | Reset | Resets XmlCommentParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Top
See Also

Reference

XmlCommentParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlCommentParser.Reset Method

XmlCommentParserReset Method
Resets XmlCommentParser to the start position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
IParserReset
See Also

Reference

XmlCommentParser Class
Reset Overload
Alternet.Syntax.Parsers.Advanced Namespace


XmlCommentParser Properties

XmlCommentParser Properties

The XmlCommentParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from XmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlCommentParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlCommentParser Events

XmlCommentParser Events

The XmlCommentParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlCommentParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser Class

XmlLiteralParser Class
Represents properties and methods to perform syntax analysis of specified xml code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.SyntaxXmlParser
Alternet.Syntax.Parsers.AdvancedXmlLiteralParser

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlLiteralParser : XmlParser
Public Class XmlLiteralParser
    Inherits XmlParser
public ref class XmlLiteralParser : public XmlParser
type XmlLiteralParser =
    class
        inherit XmlParser
    end

The XmlLiteralParser type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLiteralParser | Initializes a new instance of the XmlCommentParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from XmlParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseUnit |
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from XmlParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets XmlCommentParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Overrides ParserReset(Int32, Int32, Int32).)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from XmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser Constructor

XmlLiteralParser Constructor
Initializes a new instance of the XmlCommentParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLiteralParser()
Public Sub New
public:
XmlLiteralParser()
new : unit -> XmlLiteralParser
See Also

Reference

XmlLiteralParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser Methods

XmlLiteralParser Methods

The XmlLiteralParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from XmlParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseUnit |
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from XmlParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets XmlCommentParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Overrides ParserReset(Int32, Int32, Int32).)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

XmlLiteralParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser.ParseText Method

XmlLiteralParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlLiteralParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

XmlLiteralParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

XmlLiteralParser Class
ParseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser.ParseUnit Method

XmlLiteralParserParseUnit Method

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ParseUnit(
    ISyntaxNode node,
    ref Point prevPos
)
Public Overridable Function ParseUnit (
    node As ISyntaxNode,
    ByRef prevPos As Point
) As Boolean
public:
virtual bool ParseUnit(
    ISyntaxNode^ node,
    Point% prevPos
)
abstract ParseUnit :
        node : ISyntaxNode *
        prevPos : Point byref -> bool
override ParseUnit :
        node : ISyntaxNode *
        prevPos : Point byref -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
prevPos
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

XmlLiteralParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser.Reset Method

XmlLiteralParserReset Method
Overload List
 | Name | Description
Public method | Reset | Resets XmlCommentParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Overrides ParserReset(Int32, Int32, Int32).)
Top
See Also

Reference

XmlLiteralParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser.Reset Method

XmlLiteralParserReset Method
Resets XmlCommentParser to the start position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
IParserReset
See Also

Reference

XmlLiteralParser Class
Reset Overload
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser.Reset Method (Int32, Int32, Int32)

XmlLiteralParserReset Method (Int32, Int32, Int32)
Resets Parser to the specified position.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset(
    int line,
    int pos,
    int state
)
Public Overrides Sub Reset (
    line As Integer,
    pos As Integer,
    state As Integer
)
public:
virtual void Reset(
    int line,
    int pos,
    int state
) override
abstract Reset :
        line : int *
        pos : int *
        state : int -> unit
override Reset :
        line : int *
        pos : int *
        state : int -> unit

Parameters

line
Type: SystemInt32
Specifies new line index.
pos
Type: SystemInt32
Specifies new position of character within the line.
state
Type: SystemInt32
Specifies new State.

Implements

IParserReset(Int32, Int32, Int32)
See Also

Reference

XmlLiteralParser Class
Reset Overload
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser Properties

XmlLiteralParser Properties

The XmlLiteralParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from XmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlLiteralParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlLiteralParser Events

XmlLiteralParser Events

The XmlLiteralParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlLiteralParser Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlParserWithSchema Class

XmlParserWithSchema Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.SyntaxXmlParser
Alternet.Syntax.Parsers.AdvancedXmlParserWithSchema

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlParserWithSchema : XmlParser
Public Class XmlParserWithSchema
    Inherits XmlParser
public ref class XmlParserWithSchema : public XmlParser
type XmlParserWithSchema =
    class
        inherit XmlParser
    end

The XmlParserWithSchema type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParserWithSchema | Initializes a new instance of the XmlParserWithSchema class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from XmlParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Overrides SyntaxParserGetSyntaxErrors(IListISyntaxError).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides XmlParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from XmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | SchemaName |
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Advanced Namespace


XmlParserWithSchema Constructor

XmlParserWithSchema Constructor
Initializes a new instance of the XmlParserWithSchema class

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlParserWithSchema()
Public Sub New
public:
XmlParserWithSchema()
new : unit -> XmlParserWithSchema
See Also

Reference

XmlParserWithSchema Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlParserWithSchema Methods

XmlParserWithSchema Methods

The XmlParserWithSchema type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from SyntaxParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from XmlParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Overrides SyntaxParserGetSyntaxErrors(IListISyntaxError).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides XmlParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

XmlParserWithSchema Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlParserWithSchema.GetSyntaxErrors Method

XmlParserWithSchemaGetSyntaxErrors Method
Retrieves all syntax errors found while analyzing the text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetSyntaxErrors(
    IList<ISyntaxError> errors
)
Public Overrides Function GetSyntaxErrors (
    errors As IList(Of ISyntaxError)
) As Integer
public:
virtual int GetSyntaxErrors(
    IList<ISyntaxError^>^ errors
) override
abstract GetSyntaxErrors :
        errors : IList<ISyntaxError> -> int
override GetSyntaxErrors :
        errors : IList<ISyntaxError> -> int

Parameters

errors
Type: System.Collections.GenericIListISyntaxError
Retrieves a collection of syntax error.

Return Value

Type: Int32
Number of syntax errors that are found.

Implements

ISyntaxParserGetSyntaxErrors(IListISyntaxError)
See Also

Reference

XmlParserWithSchema Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlParserWithSchema.ReparseText Method

XmlParserWithSchemaReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides XmlParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParserWithSchema Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlParserWithSchema.ReparseText Method

XmlParserWithSchemaReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

XmlParserWithSchema Class
ReparseText Overload
Alternet.Syntax.Parsers.Advanced Namespace


XmlParserWithSchema Properties

XmlParserWithSchema Properties

The XmlParserWithSchema type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from XmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | SchemaName |
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParserWithSchema Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlParserWithSchema.SchemaName Property

XmlParserWithSchemaSchemaName Property

Namespace: Alternet.Syntax.Parsers.Advanced
Assembly: Alternet.Syntax.Parsers.Advanced.v7 (in Alternet.Syntax.Parsers.Advanced.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SchemaName { get; set; }
Public Property SchemaName As String
    Get
    Set
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}
member SchemaName : string with get, set

Property Value

Type: String
See Also

Reference

XmlParserWithSchema Class
Alternet.Syntax.Parsers.Advanced Namespace


XmlParserWithSchema Events

XmlParserWithSchema Events

The XmlParserWithSchema type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParserWithSchema Class
Alternet.Syntax.Parsers.Advanced Namespace


Alternet.Syntax.Parsers.Lsp Namespace

Alternet.Syntax.Parsers.Lsp Namespace
Classes
 | Class | Description
Public class | CompileCommandsFileManager |
Public class | CProject | Represents a class to manage C/C++ project content.
Public class | CRepository | Represents properties and methods to perform code completion functionality for C/C++ languages.
Public class | LanguageIds |
Public class | LspDocument | Represents a Language Server source code document that provides access to the source text.
Public class | LspListMember | Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe LSP-based language code.
Public class | LspListMembers | Represents data collection related to popup list box controls used to describe LSP-based language code.
Public class | LspParser | Represents base class for LSP parsers. This class is abstract.
Public class | LspRepository | Represents properties and methods to perform code completion functionality for LSP-based languages.
Public class | LspWorkspace |
Public class | LspWorkspaceScope |
Public class | ParserConsts | Contains default constants related to lexical and syntax analyzers.
Public class | ServerDeploymentOptions | Specifies options for the LSP server deployment.
Public class | ServerLocator | Finds location of the language server executable.
Public class | ServerProcess | A ServerProcess is responsible for launching or attaching to a language server, providing access to its input and output streams, and tracking its lifetime.
Public class | StdioServerProcess | A StdioServerProcess is a ServerProcess that launches its server as an external process and communicates with it over STDIN / STDOUT.
Public class | StdioServerProcessEx | A StdioServerProcess is a ServerProcess that launches its server as an external process and communicates with it over STDIN / STDOUT.
Interfaces
 | Interface | Description
Public interface | ICProjectProvider |
Public interface | ILspDocumentProvider |
Enumerations
 | Enumeration | Description
Public enumeration | ServerDeploymentMode | Specifies possible language server deployment modes.


CompileCommandsFileManager Class

CompileCommandsFileManager Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspCompileCommandsFileManager

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CompileCommandsFileManager : IDisposable
Public Class CompileCommandsFileManager
    Implements IDisposable
public ref class CompileCommandsFileManager : IDisposable
type CompileCommandsFileManager =
    class
        interface IDisposable
    end

The CompileCommandsFileManager type exposes the following members.

Constructors
 | Name | Description
Public method | CompileCommandsFileManager | Initializes a new instance of the CompileCommandsFileManager class
Top
Methods
 | Name | Description
Public method | DeleteCompileCommandsDirectory |
Public method | Dispose | Releases all resources used by the CompileCommandsFileManager
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCompileCommandsDirectory |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


CompileCommandsFileManager Constructor

CompileCommandsFileManager Constructor
Initializes a new instance of the CompileCommandsFileManager class

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompileCommandsFileManager(
    ICProjectProvider projectProvider
)
Public Sub New (
    projectProvider As ICProjectProvider
)
public:
CompileCommandsFileManager(
    ICProjectProvider^ projectProvider
)
new :
        projectProvider : ICProjectProvider -> CompileCommandsFileManager

Parameters

projectProvider
Type: Alternet.Syntax.Parsers.LspICProjectProvider
See Also

Reference

CompileCommandsFileManager Class
Alternet.Syntax.Parsers.Lsp Namespace


CompileCommandsFileManager Methods

CompileCommandsFileManager Methods

The CompileCommandsFileManager type exposes the following members.

Methods
 | Name | Description
Public method | DeleteCompileCommandsDirectory |
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCompileCommandsDirectory |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompileCommandsFileManager Class
Alternet.Syntax.Parsers.Lsp Namespace


CompileCommandsFileManager.DeleteCompileCommandsDirectory Method

CompileCommandsFileManagerDeleteCompileCommandsDirectory Method

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteCompileCommandsDirectory()
Public Sub DeleteCompileCommandsDirectory
public:
void DeleteCompileCommandsDirectory()
member DeleteCompileCommandsDirectory : unit -> unit
See Also

Reference

CompileCommandsFileManager Class
Alternet.Syntax.Parsers.Lsp Namespace


CompileCommandsFileManager.Dispose Method

CompileCommandsFileManagerDispose Method
Releases all resources used by the CompileCommandsFileManager

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CompileCommandsFileManager Class
Alternet.Syntax.Parsers.Lsp Namespace


CompileCommandsFileManager.GetCompileCommandsDirectory Method

CompileCommandsFileManagerGetCompileCommandsDirectory Method

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCompileCommandsDirectory()
Public Function GetCompileCommandsDirectory As String
public:
String^ GetCompileCommandsDirectory()
member GetCompileCommandsDirectory : unit -> string

Return Value

Type: String
See Also

Reference

CompileCommandsFileManager Class
Alternet.Syntax.Parsers.Lsp Namespace


CProject Class

CProject Class
Represents a class to manage C/C++ project content.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspCProject

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CProject
Public Class CProject
public ref class CProject
type CProject =  class end

The CProject type exposes the following members.

Constructors
 | Name | Description
Public method | CProject | Initializes a new instance of the CProject class with default settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IncludeDirectories | Represents a list of include files locations.
Public property | SourceFiles | Represents a list of files that belong to the project.
Top
Events
 | Name | Description
Public event | Changed | Occurs when project data changes.
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


CProject Constructor

CProject Constructor
Initializes a new instance of the CProject class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CProject()
Public Sub New
public:
CProject()
new : unit -> CProject
See Also

Reference

CProject Class
Alternet.Syntax.Parsers.Lsp Namespace


CProject Methods

CProject Methods

The CProject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CProject Class
Alternet.Syntax.Parsers.Lsp Namespace


CProject Properties

CProject Properties

The CProject type exposes the following members.

Properties
 | Name | Description
Public property | IncludeDirectories | Represents a list of include files locations.
Public property | SourceFiles | Represents a list of files that belong to the project.
Top
See Also

Reference

CProject Class
Alternet.Syntax.Parsers.Lsp Namespace


CProject.IncludeDirectories Property

CProjectIncludeDirectories Property
Represents a list of include files locations.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> IncludeDirectories { get; }
Public ReadOnly Property IncludeDirectories As IList(Of String)
    Get
public:
property IList<String^>^ IncludeDirectories {
    IList<String^>^ get ();
}
member IncludeDirectories : IList<string> with get

Property Value

Type: IListString
See Also

Reference

CProject Class
Alternet.Syntax.Parsers.Lsp Namespace


CProject.SourceFiles Property

CProjectSourceFiles Property
Represents a list of files that belong to the project.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> SourceFiles { get; }
Public ReadOnly Property SourceFiles As IList(Of String)
    Get
public:
property IList<String^>^ SourceFiles {
    IList<String^>^ get ();
}
member SourceFiles : IList<string> with get

Property Value

Type: IListString
See Also

Reference

CProject Class
Alternet.Syntax.Parsers.Lsp Namespace


CProject Events

CProject Events

The CProject type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when project data changes.
Top
See Also

Reference

CProject Class
Alternet.Syntax.Parsers.Lsp Namespace


CProject.Changed Event

CProjectChanged Event
Occurs when project data changes.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Changed
Public Event Changed As EventHandler
public:
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Changed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

CProject Class
Alternet.Syntax.Parsers.Lsp Namespace


CRepository Class

CRepository Class
Represents properties and methods to perform code completion functionality for C/C++ languages.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.LspLspRepository
Alternet.Syntax.Parsers.LspCRepository

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CRepository : LspRepository
Public Class CRepository
    Inherits LspRepository
public ref class CRepository : public LspRepository
type CRepository =
    class
        inherit LspRepository
    end

The CRepository type exposes the following members.

Constructors
 | Name | Description
Public method | CRepository | Initializes a new instance of the CRepository class with specified parameter.
Top
Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


CRepository Constructor

CRepository Constructor
Initializes a new instance of the CRepository class with specified parameter.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CRepository(
    ILspDocumentProvider documentProvider
)
Public Sub New (
    documentProvider As ILspDocumentProvider
)
public:
CRepository(
    ILspDocumentProvider^ documentProvider
)
new :
        documentProvider : ILspDocumentProvider -> CRepository

Parameters

documentProvider
Type: Alternet.Syntax.Parsers.LspILspDocumentProvider
ILspDocumentProvider associated with this new instance.
See Also

Reference

CRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


CRepository Methods

CRepository Methods

The CRepository type exposes the following members.

Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

CRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


CRepository Properties

CRepository Properties

The CRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

CRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


CRepository Events

CRepository Events

The CRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

CRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


ICProjectProvider Interface

ICProjectProvider Interface

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICProjectProvider
Public Interface ICProjectProvider
public interface class ICProjectProvider
type ICProjectProvider =  interface end

The ICProjectProvider type exposes the following members.

Properties
 | Name | Description
Public property | Project |
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


ICProjectProvider Properties

ICProjectProvider Properties

The ICProjectProvider type exposes the following members.

Properties
 | Name | Description
Public property | Project |
Top
See Also

Reference

ICProjectProvider Interface
Alternet.Syntax.Parsers.Lsp Namespace


ICProjectProvider.Project Property

ICProjectProviderProject Property

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
CProject Project { get; }
ReadOnly Property Project As CProject
    Get
property CProject^ Project {
    CProject^ get ();
}
abstract Project : CProject with get

Property Value

Type: CProject
See Also

Reference

ICProjectProvider Interface
Alternet.Syntax.Parsers.Lsp Namespace


ILspDocumentProvider Interface

ILspDocumentProvider Interface

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ILspDocumentProvider
Public Interface ILspDocumentProvider
public interface class ILspDocumentProvider
type ILspDocumentProvider =  interface end

The ILspDocumentProvider type exposes the following members.

Properties
 | Name | Description
Public property | Document |
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


ILspDocumentProvider Properties

ILspDocumentProvider Properties

The ILspDocumentProvider type exposes the following members.

Properties
 | Name | Description
Public property | Document |
Top
See Also

Reference

ILspDocumentProvider Interface
Alternet.Syntax.Parsers.Lsp Namespace


ILspDocumentProvider.Document Property

ILspDocumentProviderDocument Property

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
LspDocument Document { get; }
ReadOnly Property Document As LspDocument
    Get
property LspDocument^ Document {
    LspDocument^ get ();
}
abstract Document : LspDocument with get

Property Value

Type: LspDocument
See Also

Reference

ILspDocumentProvider Interface
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds Class

LanguageIds Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLanguageIds

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LanguageIds
Public NotInheritable Class LanguageIds
public ref class LanguageIds abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LanguageIds =  class end

The LanguageIds type exposes the following members.

Fields
Name | Description
Abap |
BibTeX |
C |
Clojure |
Coffeescript |
Cpp |
CSharp |
Css |
Dart |
Diff |
Dockerfile |
FSharp |
Git |
Go |
Groovy |
Handlebars |
Html |
Ini |
Java |
JavaScript |
JavaScriptReact |
Json |
LaTeX |
Less |
Lua |
Makefile |
Markdown |
ObjectiveC |
ObjectiveCpp |
Perl |
Perl6 |
Php |
Powershell |
Pug |
Python |
R |
Razor |
Ruby |
Rust |
Scala |
Scss |
ShaderLab |
ShellScriptBash |
Sql |
Swift |
TeX |
TypeScript |
TypeScriptReact |
VisualBasic |
WindowsBat |
Xml |
Xsl |
Yaml |
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds Fields

LanguageIds Fields

The LanguageIds type exposes the following members.

Fields
Name | Description
Abap |
BibTeX |
C |
Clojure |
Coffeescript |
Cpp |
CSharp |
Css |
Dart |
Diff |
Dockerfile |
FSharp |
Git |
Go |
Groovy |
Handlebars |
Html |
Ini |
Java |
JavaScript |
JavaScriptReact |
Json |
LaTeX |
Less |
Lua |
Makefile |
Markdown |
ObjectiveC |
ObjectiveCpp |
Perl |
Perl6 |
Php |
Powershell |
Pug |
Python |
R |
Razor |
Ruby |
Rust |
Scala |
Scss |
ShaderLab |
ShellScriptBash |
Sql |
Swift |
TeX |
TypeScript |
TypeScriptReact |
VisualBasic |
WindowsBat |
Xml |
Xsl |
Yaml |
Top
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Abap Field

LanguageIdsAbap Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Abap
Public Const Abap As String
public:
literal String^ Abap
static val mutable Abap: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.BibTeX Field

LanguageIdsBibTeX Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string BibTeX
Public Const BibTeX As String
public:
literal String^ BibTeX
static val mutable BibTeX: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.C Field

LanguageIdsC Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string C
Public Const C As String
public:
literal String^ C
static val mutable C: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Clojure Field

LanguageIdsClojure Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Clojure
Public Const Clojure As String
public:
literal String^ Clojure
static val mutable Clojure: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Coffeescript Field

LanguageIdsCoffeescript Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Coffeescript
Public Const Coffeescript As String
public:
literal String^ Coffeescript
static val mutable Coffeescript: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Cpp Field

LanguageIdsCpp Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Cpp
Public Const Cpp As String
public:
literal String^ Cpp
static val mutable Cpp: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.CSharp Field

LanguageIdsCSharp Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string CSharp
Public Const CSharp As String
public:
literal String^ CSharp
static val mutable CSharp: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Css Field

LanguageIdsCss Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Css
Public Const Css As String
public:
literal String^ Css
static val mutable Css: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Dart Field

LanguageIdsDart Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Dart
Public Const Dart As String
public:
literal String^ Dart
static val mutable Dart: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Diff Field

LanguageIdsDiff Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Diff
Public Const Diff As String
public:
literal String^ Diff
static val mutable Diff: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Dockerfile Field

LanguageIdsDockerfile Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Dockerfile
Public Const Dockerfile As String
public:
literal String^ Dockerfile
static val mutable Dockerfile: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.FSharp Field

LanguageIdsFSharp Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string FSharp
Public Const FSharp As String
public:
literal String^ FSharp
static val mutable FSharp: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Git Field

LanguageIdsGit Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Git
Public Const Git As String
public:
literal String^ Git
static val mutable Git: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Go Field

LanguageIdsGo Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Go
Public Const Go As String
public:
literal String^ Go
static val mutable Go: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Groovy Field

LanguageIdsGroovy Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Groovy
Public Const Groovy As String
public:
literal String^ Groovy
static val mutable Groovy: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Handlebars Field

LanguageIdsHandlebars Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Handlebars
Public Const Handlebars As String
public:
literal String^ Handlebars
static val mutable Handlebars: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Html Field

LanguageIdsHtml Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Html
Public Const Html As String
public:
literal String^ Html
static val mutable Html: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Ini Field

LanguageIdsIni Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Ini
Public Const Ini As String
public:
literal String^ Ini
static val mutable Ini: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Java Field

LanguageIdsJava Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Java
Public Const Java As String
public:
literal String^ Java
static val mutable Java: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.JavaScript Field

LanguageIdsJavaScript Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string JavaScript
Public Const JavaScript As String
public:
literal String^ JavaScript
static val mutable JavaScript: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.JavaScriptReact Field

LanguageIdsJavaScriptReact Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string JavaScriptReact
Public Const JavaScriptReact As String
public:
literal String^ JavaScriptReact
static val mutable JavaScriptReact: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Json Field

LanguageIdsJson Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Json
Public Const Json As String
public:
literal String^ Json
static val mutable Json: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.LaTeX Field

LanguageIdsLaTeX Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string LaTeX
Public Const LaTeX As String
public:
literal String^ LaTeX
static val mutable LaTeX: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Less Field

LanguageIdsLess Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Less
Public Const Less As String
public:
literal String^ Less
static val mutable Less: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Lua Field

LanguageIdsLua Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Lua
Public Const Lua As String
public:
literal String^ Lua
static val mutable Lua: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Makefile Field

LanguageIdsMakefile Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Makefile
Public Const Makefile As String
public:
literal String^ Makefile
static val mutable Makefile: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Markdown Field

LanguageIdsMarkdown Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Markdown
Public Const Markdown As String
public:
literal String^ Markdown
static val mutable Markdown: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.ObjectiveC Field

LanguageIdsObjectiveC Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ObjectiveC
Public Const ObjectiveC As String
public:
literal String^ ObjectiveC
static val mutable ObjectiveC: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.ObjectiveCpp Field

LanguageIdsObjectiveCpp Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ObjectiveCpp
Public Const ObjectiveCpp As String
public:
literal String^ ObjectiveCpp
static val mutable ObjectiveCpp: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Perl Field

LanguageIdsPerl Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Perl
Public Const Perl As String
public:
literal String^ Perl
static val mutable Perl: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Perl6 Field

LanguageIdsPerl6 Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Perl6
Public Const Perl6 As String
public:
literal String^ Perl6
static val mutable Perl6: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Php Field

LanguageIdsPhp Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Php
Public Const Php As String
public:
literal String^ Php
static val mutable Php: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Powershell Field

LanguageIdsPowershell Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Powershell
Public Const Powershell As String
public:
literal String^ Powershell
static val mutable Powershell: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Pug Field

LanguageIdsPug Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Pug
Public Const Pug As String
public:
literal String^ Pug
static val mutable Pug: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Python Field

LanguageIdsPython Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Python
Public Const Python As String
public:
literal String^ Python
static val mutable Python: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.R Field

LanguageIdsR Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string R
Public Const R As String
public:
literal String^ R
static val mutable R: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Razor Field

LanguageIdsRazor Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Razor
Public Const Razor As String
public:
literal String^ Razor
static val mutable Razor: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Ruby Field

LanguageIdsRuby Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Ruby
Public Const Ruby As String
public:
literal String^ Ruby
static val mutable Ruby: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Rust Field

LanguageIdsRust Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Rust
Public Const Rust As String
public:
literal String^ Rust
static val mutable Rust: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Scala Field

LanguageIdsScala Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Scala
Public Const Scala As String
public:
literal String^ Scala
static val mutable Scala: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Scss Field

LanguageIdsScss Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Scss
Public Const Scss As String
public:
literal String^ Scss
static val mutable Scss: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.ShaderLab Field

LanguageIdsShaderLab Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ShaderLab
Public Const ShaderLab As String
public:
literal String^ ShaderLab
static val mutable ShaderLab: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.ShellScriptBash Field

LanguageIdsShellScriptBash Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ShellScriptBash
Public Const ShellScriptBash As String
public:
literal String^ ShellScriptBash
static val mutable ShellScriptBash: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Sql Field

LanguageIdsSql Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Sql
Public Const Sql As String
public:
literal String^ Sql
static val mutable Sql: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Swift Field

LanguageIdsSwift Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Swift
Public Const Swift As String
public:
literal String^ Swift
static val mutable Swift: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.TeX Field

LanguageIdsTeX Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TeX
Public Const TeX As String
public:
literal String^ TeX
static val mutable TeX: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.TypeScript Field

LanguageIdsTypeScript Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeScript
Public Const TypeScript As String
public:
literal String^ TypeScript
static val mutable TypeScript: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.TypeScriptReact Field

LanguageIdsTypeScriptReact Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeScriptReact
Public Const TypeScriptReact As String
public:
literal String^ TypeScriptReact
static val mutable TypeScriptReact: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.VisualBasic Field

LanguageIdsVisualBasic Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string VisualBasic
Public Const VisualBasic As String
public:
literal String^ VisualBasic
static val mutable VisualBasic: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.WindowsBat Field

LanguageIdsWindowsBat Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string WindowsBat
Public Const WindowsBat As String
public:
literal String^ WindowsBat
static val mutable WindowsBat: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Xml Field

LanguageIdsXml Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Xml
Public Const Xml As String
public:
literal String^ Xml
static val mutable Xml: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Xsl Field

LanguageIdsXsl Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Xsl
Public Const Xsl As String
public:
literal String^ Xsl
static val mutable Xsl: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LanguageIds.Yaml Field

LanguageIdsYaml Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string Yaml
Public Const Yaml As String
public:
literal String^ Yaml
static val mutable Yaml: string

Field Value

Type: String
See Also

Reference

LanguageIds Class
Alternet.Syntax.Parsers.Lsp Namespace


LspDocument Class

LspDocument Class
Represents a Language Server source code document that provides access to the source text.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspDocument

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LspDocument
Public Class LspDocument
public ref class LspDocument
type LspDocument =  class end

The LspDocument type exposes the following members.

Constructors
 | Name | Description
Public method | LspDocument | Initializes a new instance of the LspDocument class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Client | Gets language Client associated with the language server.
Public property | FileName | Gets name of file associated with document.
Public property | Strings | Gets the list of strings containing document text.
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


LspDocument Constructor

LspDocument Constructor
Initializes a new instance of the LspDocument class with specified parameters.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspDocument(
    string fileName,
    LanguageClient client,
    IStringList strings
)
Public Sub New (
    fileName As String,
    client As LanguageClient,
    strings As IStringList
)
public:
LspDocument(
    String^ fileName,
    LanguageClient^ client,
    IStringList^ strings
)
new :
        fileName : string *
        client : LanguageClient *
        strings : IStringList -> LspDocument

Parameters

fileName
Type: SystemString
Name of file associated with this new instance.
client
Type: LanguageClient
LanguageClient associates this new instance with the language server.
strings
Type: Alternet.SyntaxIStringList
List of strings contains some text.
See Also

Reference

LspDocument Class
Alternet.Syntax.Parsers.Lsp Namespace


LspDocument Methods

LspDocument Methods

The LspDocument type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LspDocument Class
Alternet.Syntax.Parsers.Lsp Namespace


LspDocument Properties

LspDocument Properties

The LspDocument type exposes the following members.

Properties
 | Name | Description
Public property | Client | Gets language Client associated with the language server.
Public property | FileName | Gets name of file associated with document.
Public property | Strings | Gets the list of strings containing document text.
Top
See Also

Reference

LspDocument Class
Alternet.Syntax.Parsers.Lsp Namespace


LspDocument.Client Property

LspDocumentClient Property
Gets language Client associated with the language server.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LanguageClient Client { get; }
Public ReadOnly Property Client As LanguageClient
    Get
public:
property LanguageClient^ Client {
    LanguageClient^ get ();
}
member Client : LanguageClient with get

Property Value

Type: LanguageClient
See Also

Reference

LspDocument Class
Alternet.Syntax.Parsers.Lsp Namespace


LspDocument.FileName Property

LspDocumentFileName Property
Gets name of file associated with document.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

LspDocument Class
Alternet.Syntax.Parsers.Lsp Namespace


LspDocument.Strings Property

LspDocumentStrings Property
Gets the list of strings containing document text.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IStringList Strings { get; }
Public ReadOnly Property Strings As IStringList
    Get
public:
property IStringList^ Strings {
    IStringList^ get ();
}
member Strings : IStringList with get

Property Value

Type: IStringList
See Also

Reference

LspDocument Class
Alternet.Syntax.Parsers.Lsp Namespace


LspListMember Class

LspListMember Class
Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe LSP-based language code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.Parsers.LspLspListMember

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LspListMember : ListMember
Public Class LspListMember
    Inherits ListMember
public ref class LspListMember : public ListMember
type LspListMember =
    class
        inherit ListMember
    end

The LspListMember type exposes the following members.

Constructors
 | Name | Description
Public method | LspListMember | Initializes a new instance of the LspListMember class with default settings.
Public method | LspListMember(IListMembers) | Initializes a new instance of the LspListMember class with specified owner. IListMembers owning this instance
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Inherited from ListMember.)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets a CodeCompletionCategory to which this ListMember belongs. (Inherited from ListMember.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Gets or sets a string value that specifies short description of the ListMember. (Inherited from ListMember.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | Selected | Gets or sets a boolean value indicating whether this member is in the selected state.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


LspListMember Constructor

LspListMember Constructor
Overload List
 | Name | Description
Public method | LspListMember | Initializes a new instance of the LspListMember class with default settings.
Public method | LspListMember(IListMembers) | Initializes a new instance of the LspListMember class with specified owner. IListMembers owning this instance
Top
See Also

Reference

LspListMember Class
Alternet.Syntax.Parsers.Lsp Namespace


LspListMember Constructor

LspListMember Constructor
Initializes a new instance of the LspListMember class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspListMember()
Public Sub New
public:
LspListMember()
new : unit -> LspListMember
See Also

Reference

LspListMember Class
LspListMember Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspListMember Constructor (IListMembers)

LspListMember Constructor (IListMembers)
Initializes a new instance of the LspListMember class with specified owner. IListMembers owning this instance

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspListMember(
    IListMembers owner
)
Public Sub New (
    owner As IListMembers
)
public:
LspListMember(
    IListMembers^ owner
)
new :
        owner : IListMembers -> LspListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
See Also

Reference

LspListMember Class
LspListMember Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspListMember Methods

LspListMember Methods

The LspListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Inherited from ListMember.)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LspListMember Class
Alternet.Syntax.Parsers.Lsp Namespace


LspListMember Properties

LspListMember Properties

The LspListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets a CodeCompletionCategory to which this ListMember belongs. (Inherited from ListMember.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Gets or sets a string value that specifies short description of the ListMember. (Inherited from ListMember.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | Selected | Gets or sets a boolean value indicating whether this member is in the selected state.
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

LspListMember Class
Alternet.Syntax.Parsers.Lsp Namespace


LspListMember.Selected Property

LspListMemberSelected Property
Gets or sets a boolean value indicating whether this member is in the selected state.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set
public:
property bool Selected {
    bool get ();
    void set (bool value);
}
member Selected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LspListMember Class
Alternet.Syntax.Parsers.Lsp Namespace


LspListMembers Class

LspListMembers Class
Represents data collection related to popup list box controls used to describe LSP-based language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.Parsers.LspLspListMembers

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LspListMembers : ListMembers
Public Class LspListMembers
    Inherits ListMembers
public ref class LspListMembers : public ListMembers
type LspListMembers =
    class
        inherit ListMembers
    end

The LspListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | LspListMembers | Initializes a new instance of the LspListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Overrides CodeCompletionProviderNeedSort.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


LspListMembers Constructor

LspListMembers Constructor
Initializes a new instance of the LspListMembers class

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspListMembers()
Public Sub New
public:
LspListMembers()
new : unit -> LspListMembers
See Also

Reference

LspListMembers Class
Alternet.Syntax.Parsers.Lsp Namespace


LspListMembers Methods

LspListMembers Methods

The LspListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

LspListMembers Class
Alternet.Syntax.Parsers.Lsp Namespace


LspListMembers Properties

LspListMembers Properties

The LspListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Overrides CodeCompletionProviderNeedSort.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

LspListMembers Class
Alternet.Syntax.Parsers.Lsp Namespace


LspListMembers.NeedSort Property

LspListMembersNeedSort Property
Specifies if provider content needs to be sorted.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool NeedSort { get; }
Public Overrides ReadOnly Property NeedSort As Boolean
    Get
public:
virtual property bool NeedSort {
    bool get () override;
}
abstract NeedSort : bool with get
override NeedSort : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionProviderNeedSort
See Also

Reference

LspListMembers Class
Alternet.Syntax.Parsers.Lsp Namespace


LspListMembers Events

LspListMembers Events

The LspListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

LspListMembers Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser Class

LspParser Class
Represents base class for LSP parsers. This class is abstract.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
More...

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class LspParser : SyntaxParser,
    ILspDocumentProvider
Public MustInherit Class LspParser
    Inherits SyntaxParser
    Implements ILspDocumentProvider
public ref class LspParser abstract : public SyntaxParser,
    ILspDocumentProvider
[<AbstractClassAttribute>]
type LspParser =
    class
        inherit SyntaxParser
        interface ILspDocumentProvider
    end

The LspParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Overrides SyntaxParserOnTextChanged(ITextUndo).)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Overrides SyntaxParserOutline(IListIRange).)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Overrides SyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason).)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from SyntaxParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Overrides SyntaxParserResetParseInterval.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Overrides SyntaxParserShouldSerializeParseInterval.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Overrides SyntaxParserSupportsTextChanges.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser.
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Overrides SyntaxParserFileName.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Overrides ParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope |
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.ClangdCParser
Alternet.Syntax.Parsers.Lsp.JavaJavaParser
Alternet.Syntax.Parsers.Lsp.LuaLuaParser
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellParser
Alternet.Syntax.Parsers.Lsp.PythonPythonParser
Alternet.Syntax.Parsers.Lsp.XmlXmlParser


LspParser Methods

LspParser Methods

The LspParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Overrides SyntaxParserOnTextChanged(ITextUndo).)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Overrides SyntaxParserOutline(IListIRange).)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Overrides SyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason).)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from SyntaxParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Overrides SyntaxParserResetParseInterval.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Overrides SyntaxParserShouldSerializeParseInterval.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Overrides SyntaxParserSupportsTextChanges.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.CodeCompletion Method

LspParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Top
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.CodeCompletion Method (String, StringItemInfo[], Point, CodeCompletionArgs)

LspParserCodeCompletion Method (String, StringItemInfo, Point, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    CodeCompletionArgs e
)
Public Overrides Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    CodeCompletionArgs^ e
) override
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs)
See Also

Reference

LspParser Class
CodeCompletion Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.CreateRepository Method

LspParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.DoCodeCompletionAsync Method

LspParserDoCodeCompletionAsync Method
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task DoCodeCompletionAsync(
    Point position,
    CodeCompletionArgs e,
    CancellationToken cancellationToken,
    bool async
)
Public Function DoCodeCompletionAsync (
    position As Point,
    e As CodeCompletionArgs,
    cancellationToken As CancellationToken,
    async As Boolean
) As Task
public:
Task^ DoCodeCompletionAsync(
    Point position,
    CodeCompletionArgs^ e,
    CancellationToken cancellationToken,
    bool async
)
member DoCodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs *
        cancellationToken : CancellationToken *
        async : bool -> Task

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.
cancellationToken
Type: System.ThreadingCancellationToken
Represents a token handles cancellation operation.
async
Type: SystemBoolean
Specifies whether code completion request can be run asynchronously.

Return Value

Type: Task
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.FindDeclaration Method

LspParserFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Top
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.FindDeclaration Method (Point)

LspParserFindDeclaration Method (Point)
Finds the declaration location at given position.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override SymbolLocation FindDeclaration(
    Point position
)
Public Overrides Function FindDeclaration (
    position As Point
) As SymbolLocation
public:
virtual SymbolLocation^ FindDeclaration(
    Point position
) override
abstract FindDeclaration :
        position : Point -> SymbolLocation
override FindDeclaration :
        position : Point -> SymbolLocation

Parameters

position
Type: System.DrawingPoint
Specifies position to find.

Return Value

Type: SymbolLocation
SymbolLocation represents location of the declaration.

Implements

ISyntaxParserFindDeclaration(Point)
See Also

Reference

LspParser Class
FindDeclaration Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.FindReferences Method

LspParserFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Top
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.FindReferences Method (Point, IRangeList, Boolean)

LspParserFindReferences Method (Point, IRangeList, Boolean)
Locates declaration at given position and finds all references to this declaration in the text.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int FindReferences(
    Point position,
    IRangeList references,
    bool allDocuments
)
Public Overrides Function FindReferences (
    position As Point,
    references As IRangeList,
    allDocuments As Boolean
) As Integer
public:
virtual int FindReferences(
    Point position,
    IRangeList^ references,
    bool allDocuments
) override
abstract FindReferences :
        position : Point *
        references : IRangeList *
        allDocuments : bool -> int
override FindReferences :
        position : Point *
        references : IRangeList *
        allDocuments : bool -> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
Retrieves references to found declaration.
allDocuments
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found references.

Implements

ISyntaxParserFindReferences(Point, IRangeList, Boolean)
See Also

Reference

LspParser Class
FindReferences Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.GetCompletionType Method

LspParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.GetCompletionType Method (Char)

LspParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

LspParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.OnTextChanged Method

LspParserOnTextChanged Method
Responds to incremental change of the text in the editor.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void OnTextChanged(
    ITextUndo operation
)
Public Overrides Sub OnTextChanged (
    operation As ITextUndo
)
public:
virtual void OnTextChanged(
    ITextUndo^ operation
) override
abstract OnTextChanged :
        operation : ITextUndo -> unit
override OnTextChanged :
        operation : ITextUndo -> unit

Parameters

operation
Type: Alternet.SyntaxITextUndo

Implements

ISyntaxParserOnTextChanged(ITextUndo)
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.Outline Method

LspParserOutline Method
Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int Outline(
    IList<IRange> ranges
)
Public Overrides Function Outline (
    ranges As IList(Of IRange)
) As Integer
public:
virtual int Outline(
    IList<IRange^>^ ranges
) override
abstract Outline :
        ranges : IList<IRange> -> int
override Outline :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Retrieves IOutlineRange collection for outlined sections.

Return Value

Type: Int32
Number of outlined sections.

Implements

ISyntaxParserOutline(IListIRange)
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.ParseText Method

LspParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

LspParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

LspParser Class
ParseText Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.Prepare Method

LspParserPrepare Method
Overload List
 | Name | Description
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Overrides SyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason).)
Top
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.Prepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)

LspParserPrepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)
Sets lines to parse.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Prepare(
    string fileName,
    IStringList lines,
    ISyntaxTree syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason.None
)
Public Overrides Sub Prepare (
    fileName As String,
    lines As IStringList,
    syntaxTree As ISyntaxTree,
    useThread As Boolean,
    Optional reason As PrepareReason = PrepareReason.None
)
public:
virtual void Prepare(
    String^ fileName,
    IStringList^ lines,
    ISyntaxTree^ syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason::None
) override
abstract Prepare :
        fileName : string *
        lines : IStringList *
        syntaxTree : ISyntaxTree *
        useThread : bool *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit
override Prepare :
        fileName : string *
        lines : IStringList *
        syntaxTree : ISyntaxTree *
        useThread : bool *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit

Parameters

fileName
Type: SystemString
File to parse
lines
Type: Alternet.SyntaxIStringList
Strings to parse
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies current parser tree.
useThread
Type: SystemBoolean
Specifies whether parser should perform the task in the separate thread
reason (Optional)
Type: Alternet.SyntaxPrepareReason
Reason for this method to be called.

Implements

ISyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason)
See Also

Reference

LspParser Class
Prepare Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.ResetParseInterval Method

LspParserResetParseInterval Method
Resets ParseInterval to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetParseInterval()
Public Overrides Sub ResetParseInterval
public:
virtual void ResetParseInterval() override
abstract ResetParseInterval : unit -> unit
override ResetParseInterval : unit -> unit

Implements

ISyntaxParserResetParseInterval
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.ShouldSerializeParseInterval Method

LspParserShouldSerializeParseInterval Method
Indicates whether the ParseInterval property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeParseInterval()
Public Overrides Function ShouldSerializeParseInterval As Boolean
public:
virtual bool ShouldSerializeParseInterval() override
abstract ShouldSerializeParseInterval : unit -> bool
override ShouldSerializeParseInterval : unit -> bool

Return Value

Type: Boolean
True if ParseInterval differs from its default value; otherwise false.
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.SupportsTextChanges Method

LspParserSupportsTextChanges Method
Indicates whether parser supports incremental text changes.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SupportsTextChanges()
Public Overrides Function SupportsTextChanges As Boolean
public:
virtual bool SupportsTextChanges() override
abstract SupportsTextChanges : unit -> bool
override SupportsTextChanges : unit -> bool

Return Value

Type: Boolean

Implements

ISyntaxParserSupportsTextChanges
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser Properties

LspParser Properties

The LspParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser.
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Overrides SyntaxParserFileName.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Overrides ParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope |
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.Document Property

LspParserDocument Property
Gets a LspDocument associated with this parser.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspDocument Document { get; }
Public ReadOnly Property Document As LspDocument
    Get
public:
virtual property LspDocument^ Document {
    LspDocument^ get () sealed;
}
abstract Document : LspDocument with get
override Document : LspDocument with get

Property Value

Type: LspDocument

Implements

ILspDocumentProviderDocument
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.FileName Property

LspParserFileName Property

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string FileName { get; set; }
Public Overrides Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get () override;
    void set (String^ value) override;
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

ISyntaxParserFileName
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.Repository Property

LspParserRepository Property
Gets a LspRepository that holds methods for code completion purposes.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspRepository Repository { get; }
Public ReadOnly Property Repository As LspRepository
    Get
public:
property LspRepository^ Repository {
    LspRepository^ get ();
}
member Repository : LspRepository with get

Property Value

Type: LspRepository
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.Strings Property

LspParserStrings Property
Gets or sets a list of strings to parse.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IStringList Strings { get; set; }
Public Overrides Property Strings As IStringList
    Get
    Set
public:
virtual property IStringList^ Strings {
    IStringList^ get () override;
    void set (IStringList^ value) override;
}
abstract Strings : IStringList with get, set
override Strings : IStringList with get, set

Property Value

Type: IStringList

Implements

IParserStrings
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.Workspace Property

LspParserWorkspace Property

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspWorkspace Workspace { get; }
Public ReadOnly Property Workspace As LspWorkspace
    Get
public:
property LspWorkspace^ Workspace {
    LspWorkspace^ get ();
}
member Workspace : LspWorkspace with get

Property Value

Type: LspWorkspace
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser.WorkspaceScope Property

LspParserWorkspaceScope Property

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspWorkspaceScope WorkspaceScope { get; set; }
Public Property WorkspaceScope As LspWorkspaceScope
    Get
    Set
public:
property LspWorkspaceScope^ WorkspaceScope {
    LspWorkspaceScope^ get ();
    void set (LspWorkspaceScope^ value);
}
member WorkspaceScope : LspWorkspaceScope with get, set

Property Value

Type: LspWorkspaceScope
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspParser Events

LspParser Events

The LspParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

LspParser Class
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository Class

LspRepository Class
Represents properties and methods to perform code completion functionality for LSP-based languages.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.LspLspRepository
More...

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LspRepository : CodeCompletionRepository,
    ILspDocumentProvider
Public Class LspRepository
    Inherits CodeCompletionRepository
    Implements ILspDocumentProvider
public ref class LspRepository : public CodeCompletionRepository,
    ILspDocumentProvider
type LspRepository =
    class
        inherit CodeCompletionRepository
        interface ILspDocumentProvider
    end

The LspRepository type exposes the following members.

Constructors
 | Name | Description
Public method | LspRepository | Initializes a new instance of the LspRepository class with specified parameters.
Top
Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository.
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.LspLspRepository
Alternet.Syntax.Parsers.LspCRepository
Alternet.Syntax.Parsers.Lsp.JavaJavaRepository
Alternet.Syntax.Parsers.Lsp.LuaLuaRepository
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellRepository
Alternet.Syntax.Parsers.Lsp.PythonPythonRepository
Alternet.Syntax.Parsers.Lsp.XmlXmlRepository


LspRepository Constructor

LspRepository Constructor
Initializes a new instance of the LspRepository class with specified parameters.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspRepository(
    bool caseSensitive,
    ILspDocumentProvider documentProvider,
    ISyntaxTree syntaxTree = null
)
Public Sub New (
    caseSensitive As Boolean,
    documentProvider As ILspDocumentProvider,
    Optional syntaxTree As ISyntaxTree = Nothing
)
public:
LspRepository(
    bool caseSensitive,
    ILspDocumentProvider^ documentProvider,
    ISyntaxTree^ syntaxTree = nullptr
)
new :
        caseSensitive : bool *
        documentProvider : ILspDocumentProvider *
        ?syntaxTree : ISyntaxTree
(* Defaults:
        let _syntaxTree = defaultArg syntaxTree null
*)
-> LspRepository

Parameters

caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
documentProvider
Type: Alternet.Syntax.Parsers.LspILspDocumentProvider
ILspDocumentProvider for this new instance.
syntaxTree (Optional)
Type: Alternet.SyntaxISyntaxTree
ISyntaxTree for this new instance.
See Also

Reference

LspRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository Methods

LspRepository Methods

The LspRepository type exposes the following members.

Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

LspRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository.CodeCompletionAsync Method

LspRepositoryCodeCompletionAsync Method
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task CodeCompletionAsync(
    Point position,
    CodeCompletionArgs e
)
Public Overridable Function CodeCompletionAsync (
    position As Point,
    e As CodeCompletionArgs
) As Task
public:
virtual Task^ CodeCompletionAsync(
    Point position,
    CodeCompletionArgs^ e
)
abstract CodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs -> Task
override CodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs -> Task

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.

Return Value

Type: Task
See Also

Reference

LspRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository.FillMembers Method

LspRepositoryFillMembers Method
Overload List
 | Name | Description
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

LspRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository.FillMembers Method (CompletionItem[], IListMembers, Int32)

LspRepositoryFillMembers Method (CompletionItem, IListMembers, Int32)
Fills list members provider with list of its member, providing available choices for the specified language element.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillMembers(
    CompletionItem[] completionItems,
    IListMembers members,
    out int selectedIndex
)
Public Overridable Sub FillMembers (
    completionItems As CompletionItem(),
    members As IListMembers,
    <OutAttribute> ByRef selectedIndex As Integer
)
public:
virtual void FillMembers(
    array<CompletionItem^>^ completionItems,
    IListMembers^ members,
    [OutAttribute] int% selectedIndex
)
abstract FillMembers :
        completionItems : CompletionItem[] *
        members : IListMembers *
        selectedIndex : int byref -> unit
override FillMembers :
        completionItems : CompletionItem[] *
        members : IListMembers *
        selectedIndex : int byref -> unit

Parameters

completionItems
Type: CompletionItem
Contains list of code completion data.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
selectedIndex
Type: SystemInt32
Receives index of default list member.
See Also

Reference

LspRepository Class
FillMembers Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository Properties

LspRepository Properties

The LspRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository.
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

LspRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository.Document Property

LspRepositoryDocument Property
Represents a LspDocument object associated with this repository.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspDocument Document { get; }
Public ReadOnly Property Document As LspDocument
    Get
public:
virtual property LspDocument^ Document {
    LspDocument^ get () sealed;
}
abstract Document : LspDocument with get
override Document : LspDocument with get

Property Value

Type: LspDocument

Implements

ILspDocumentProviderDocument
See Also

Reference

LspRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository.Images Property

LspRepositoryImages Property
Represents collection of images used for code completion.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; }
Public Overrides ReadOnly Property Images As ImageList
    Get
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
}
abstract Images : ImageList with get
override Images : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImages
See Also

Reference

LspRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository.ImagesHighDpi Property

LspRepositoryImagesHighDpi Property
Represents the ImageList for code completion items for high DPI.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList ImagesHighDpi { get; }
Public Overrides ReadOnly Property ImagesHighDpi As ImageList
    Get
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get () override;
}
abstract ImagesHighDpi : ImageList with get
override ImagesHighDpi : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImagesHighDpi
See Also

Reference

LspRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


LspRepository Events

LspRepository Events

The LspRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

LspRepository Class
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspace Class

LspWorkspace Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
More...

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class LspWorkspace
Public MustInherit Class LspWorkspace
public ref class LspWorkspace abstract
[<AbstractClassAttribute>]
type LspWorkspace =  class end

The LspWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser |
Public method | DisconnectParser |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options.
Public property | ServerProcess |
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.ClangdCWorkspace
Alternet.Syntax.Parsers.Lsp.JavaJavaWorkspace
Alternet.Syntax.Parsers.Lsp.LuaLuaWorkspace
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellWorkspace
Alternet.Syntax.Parsers.Lsp.PythonPythonWorkspace
Alternet.Syntax.Parsers.Lsp.XmlXmlWorkspace


LspWorkspace Methods

LspWorkspace Methods

The LspWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser |
Public method | DisconnectParser |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LspWorkspace Class
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspace.ConnectParser Method

LspWorkspaceConnectParser Method

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ConnectParser(
    LspParser value
)
Public Sub ConnectParser (
    value As LspParser
)
public:
void ConnectParser(
    LspParser^ value
)
member ConnectParser :
        value : LspParser -> unit

Parameters

value
Type: Alternet.Syntax.Parsers.LspLspParser
See Also

Reference

LspWorkspace Class
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspace.DisconnectParser Method

LspWorkspaceDisconnectParser Method

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DisconnectParser(
    LspParser value
)
Public Sub DisconnectParser (
    value As LspParser
)
public:
void DisconnectParser(
    LspParser^ value
)
member DisconnectParser :
        value : LspParser -> unit

Parameters

value
Type: Alternet.Syntax.Parsers.LspLspParser
See Also

Reference

LspWorkspace Class
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspace Properties

LspWorkspace Properties

The LspWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options.
Public property | ServerProcess |
Top
See Also

Reference

LspWorkspace Class
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspace.ServerDeploymentOptions Property

LspWorkspaceServerDeploymentOptions Property
Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerDeploymentOptions ServerDeploymentOptions { get; }
Public ReadOnly Property ServerDeploymentOptions As ServerDeploymentOptions
    Get
public:
property ServerDeploymentOptions^ ServerDeploymentOptions {
    ServerDeploymentOptions^ get ();
}
member ServerDeploymentOptions : ServerDeploymentOptions with get

Property Value

Type: ServerDeploymentOptions
See Also

Reference

LspWorkspace Class
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspace.ServerProcess Property

LspWorkspaceServerProcess Property

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerProcess ServerProcess { get; }
Public ReadOnly Property ServerProcess As ServerProcess
    Get
public:
property ServerProcess^ ServerProcess {
    ServerProcess^ get ();
}
member ServerProcess : ServerProcess with get

Property Value

Type: ServerProcess
See Also

Reference

LspWorkspace Class
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspaceScope Class

LspWorkspaceScope Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspaceScope

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LspWorkspaceScope
Public Class LspWorkspaceScope
public ref class LspWorkspaceScope
type LspWorkspaceScope =  class end

The LspWorkspaceScope type exposes the following members.

Constructors
 | Name | Description
Public method | LspWorkspaceScope | Initializes a new instance of the LspWorkspaceScope class
Public method | LspWorkspaceScope(ActionLspWorkspace) | Initializes a new instance of the LspWorkspaceScope class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspaceScope Constructor

LspWorkspaceScope Constructor
Overload List
 | Name | Description
Public method | LspWorkspaceScope | Initializes a new instance of the LspWorkspaceScope class
Public method | LspWorkspaceScope(ActionLspWorkspace) | Initializes a new instance of the LspWorkspaceScope class
Top
See Also

Reference

LspWorkspaceScope Class
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspaceScope Constructor

LspWorkspaceScope Constructor
Initializes a new instance of the LspWorkspaceScope class

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspWorkspaceScope()
Public Sub New
public:
LspWorkspaceScope()
new : unit -> LspWorkspaceScope
See Also

Reference

LspWorkspaceScope Class
LspWorkspaceScope Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspaceScope Constructor (Action(LspWorkspace))

LspWorkspaceScope Constructor (ActionLspWorkspace)
Initializes a new instance of the LspWorkspaceScope class

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LspWorkspaceScope(
    Action<LspWorkspace> workspaceInitializer
)
Public Sub New (
    workspaceInitializer As Action(Of LspWorkspace)
)
public:
LspWorkspaceScope(
    Action<LspWorkspace^>^ workspaceInitializer
)
new :
        workspaceInitializer : Action<LspWorkspace> -> LspWorkspaceScope

Parameters

workspaceInitializer
Type: SystemActionLspWorkspace
See Also

Reference

LspWorkspaceScope Class
LspWorkspaceScope Overload
Alternet.Syntax.Parsers.Lsp Namespace


LspWorkspaceScope Methods

LspWorkspaceScope Methods

The LspWorkspaceScope type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LspWorkspaceScope Class
Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts Class

ParserConsts Class
Contains default constants related to lexical and syntax analyzers.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspParserConsts

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParserConsts
Public Class ParserConsts
public ref class ParserConsts
type ParserConsts =  class end

The ParserConsts type exposes the following members.

Constructors
 | Name | Description
Public method | ParserConsts | Initializes a new instance of the ParserConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DefaultCodeCompletionDelay |
DefaultLspCodeCompletionChars |
DefaultLspDelimiters |
DefaultLspSyntaxOptions |
DefaultParseInterval |
DefaultSyntaxInterval |
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts Constructor

ParserConsts Constructor
Initializes a new instance of the ParserConsts class

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParserConsts()
Public Sub New
public:
ParserConsts()
new : unit -> ParserConsts
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts Fields

ParserConsts Fields

The ParserConsts type exposes the following members.

Fields
Name | Description
DefaultCodeCompletionDelay |
DefaultLspCodeCompletionChars |
DefaultLspDelimiters |
DefaultLspSyntaxOptions |
DefaultParseInterval |
DefaultSyntaxInterval |
Top
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts.DefaultCodeCompletionDelay Field

ParserConstsDefaultCodeCompletionDelay Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultCodeCompletionDelay
Public Shared DefaultCodeCompletionDelay As Integer
public:
static int DefaultCodeCompletionDelay
static val mutable DefaultCodeCompletionDelay: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts.DefaultLspCodeCompletionChars Field

ParserConstsDefaultLspCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultLspCodeCompletionChars
Public Const DefaultLspCodeCompletionChars As String
public:
literal String^ DefaultLspCodeCompletionChars
static val mutable DefaultLspCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts.DefaultLspDelimiters Field

ParserConstsDefaultLspDelimiters Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DefaultLspDelimiters
Public Const DefaultLspDelimiters As String
public:
literal String^ DefaultLspDelimiters
static val mutable DefaultLspDelimiters: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts.DefaultLspSyntaxOptions Field

ParserConstsDefaultLspSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const SyntaxOptions DefaultLspSyntaxOptions
Public Const DefaultLspSyntaxOptions As SyntaxOptions
public:
literal SyntaxOptions DefaultLspSyntaxOptions
static val mutable DefaultLspSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts.DefaultParseInterval Field

ParserConstsDefaultParseInterval Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultParseInterval
Public Shared DefaultParseInterval As Integer
public:
static int DefaultParseInterval
static val mutable DefaultParseInterval: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts.DefaultSyntaxInterval Field

ParserConstsDefaultSyntaxInterval Field

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultSyntaxInterval
Public Shared DefaultSyntaxInterval As Integer
public:
static int DefaultSyntaxInterval
static val mutable DefaultSyntaxInterval: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Lsp Namespace


ParserConsts Methods

ParserConsts Methods

The ParserConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerDeploymentMode Enumeration

ServerDeploymentMode Enumeration
Specifies possible language server deployment modes.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ServerDeploymentMode
Public Enumeration ServerDeploymentMode
public enum class ServerDeploymentMode
type ServerDeploymentMode
Members
Member name | Value | Description
Embedded | 0 | Copies the embedded server distribution to the user TEMP directory, if needed. Use EmbeddedDeploymentTargetDirectory to override the target directory with an application-defined location.
System | 1 | Tries to locate and use the system server installation, if applicable.
ApplicationDefined | 2 | Use ApplicationDefinedServerDirectory to specify a custom server installation directory.
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


ServerDeploymentOptions Class

ServerDeploymentOptions Class
Specifies options for the LSP server deployment.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerDeploymentOptions

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ServerDeploymentOptions
Public Class ServerDeploymentOptions
public ref class ServerDeploymentOptions
type ServerDeploymentOptions =  class end

The ServerDeploymentOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ServerDeploymentOptions | Initializes an instance of ServerDeploymentOptions class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ApplicationDefinedServerDirectory | Gets or sets a server directory used with ApplicationDefined mode.
Public property | EmbeddedDeploymentTargetDirectory | Gets or sets a bundled embedded server target directory used with Embedded mode.
Public property | Mode | Gets or sets the LSP server deployment mode.
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


ServerDeploymentOptions Constructor

ServerDeploymentOptions Constructor
Initializes an instance of ServerDeploymentOptions class.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerDeploymentOptions(
    Func<bool> isConnectedToServer
)
Public Sub New (
    isConnectedToServer As Func(Of Boolean)
)
public:
ServerDeploymentOptions(
    Func<bool>^ isConnectedToServer
)
new :
        isConnectedToServer : Func<bool> -> ServerDeploymentOptions

Parameters

isConnectedToServer
Type: SystemFuncBoolean
A function indicating whether a connection to LSP server already has been made.
See Also

Reference

ServerDeploymentOptions Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerDeploymentOptions Methods

ServerDeploymentOptions Methods

The ServerDeploymentOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerDeploymentOptions Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerDeploymentOptions Properties

ServerDeploymentOptions Properties

The ServerDeploymentOptions type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationDefinedServerDirectory | Gets or sets a server directory used with ApplicationDefined mode.
Public property | EmbeddedDeploymentTargetDirectory | Gets or sets a bundled embedded server target directory used with Embedded mode.
Public property | Mode | Gets or sets the LSP server deployment mode.
Top
See Also

Reference

ServerDeploymentOptions Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerDeploymentOptions.ApplicationDefinedServerDirectory Property

ServerDeploymentOptionsApplicationDefinedServerDirectory Property
Gets or sets a server directory used with ApplicationDefined mode.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ApplicationDefinedServerDirectory { get; set; }
Public Property ApplicationDefinedServerDirectory As String
    Get
    Set
public:
property String^ ApplicationDefinedServerDirectory {
    String^ get ();
    void set (String^ value);
}
member ApplicationDefinedServerDirectory : string with get, set

Property Value

Type: String
See Also

Reference

ServerDeploymentOptions Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerDeploymentOptions.EmbeddedDeploymentTargetDirectory Property

ServerDeploymentOptionsEmbeddedDeploymentTargetDirectory Property
Gets or sets a bundled embedded server target directory used with Embedded mode.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EmbeddedDeploymentTargetDirectory { get; set; }
Public Property EmbeddedDeploymentTargetDirectory As String
    Get
    Set
public:
property String^ EmbeddedDeploymentTargetDirectory {
    String^ get ();
    void set (String^ value);
}
member EmbeddedDeploymentTargetDirectory : string with get, set

Property Value

Type: String
See Also

Reference

ServerDeploymentOptions Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerDeploymentOptions.Mode Property

ServerDeploymentOptionsMode Property
Gets or sets the LSP server deployment mode.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerDeploymentMode Mode { get; set; }
Public Property Mode As ServerDeploymentMode
    Get
    Set
public:
property ServerDeploymentMode Mode {
    ServerDeploymentMode get ();
    void set (ServerDeploymentMode value);
}
member Mode : ServerDeploymentMode with get, set

Property Value

Type: ServerDeploymentMode
See Also

Reference

ServerDeploymentOptions Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerLocator Class

ServerLocator Class
Finds location of the language server executable.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
More...

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ServerLocator
Public MustInherit Class ServerLocator
public ref class ServerLocator abstract
[<AbstractClassAttribute>]
type ServerLocator =  class end

The ServerLocator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.ClangdClangdServerLocator
Alternet.Syntax.Parsers.Lsp.JavaJavaServerLocator
Alternet.Syntax.Parsers.Lsp.LuaLuaServerLocator
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellServerLocator
Alternet.Syntax.Parsers.Lsp.PythonPythonServerLocator
Alternet.Syntax.Parsers.Lsp.XmlXmlServerLocator


ServerLocator Methods

ServerLocator Methods

The ServerLocator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerLocator Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerLocator.GetServerStartInfo Method

ServerLocatorGetServerStartInfo Method
Gets ProcessStartInfo of the LSP server executable.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ProcessStartInfo GetServerStartInfo(
    ServerDeploymentOptions options
)
Public Overridable Function GetServerStartInfo (
    options As ServerDeploymentOptions
) As ProcessStartInfo
public:
virtual ProcessStartInfo^ GetServerStartInfo(
    ServerDeploymentOptions^ options
)
abstract GetServerStartInfo :
        options : ServerDeploymentOptions -> ProcessStartInfo
override GetServerStartInfo :
        options : ServerDeploymentOptions -> ProcessStartInfo

Parameters

options
Type: Alternet.Syntax.Parsers.LspServerDeploymentOptions
The server deployment options.

Return Value

Type: ProcessStartInfo
A ProcessStartInfo which can be used to start a server process.
See Also

Reference

ServerLocator Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess Class

ServerProcess Class
A ServerProcess is responsible for launching or attaching to a language server, providing access to its input and output streams, and tracking its lifetime.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerProcess
Alternet.Syntax.Parsers.LspStdioServerProcess
Alternet.Syntax.Parsers.LspStdioServerProcessEx

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ServerProcess : IDisposable
Public MustInherit Class ServerProcess
    Implements IDisposable
public ref class ServerProcess abstract : IDisposable
[<AbstractClassAttribute>]
type ServerProcess =
    class
        interface IDisposable
    end

The ServerProcess type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose of resources being used by the launcher.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StartAsync | Start or connect to the server.
Public method | StopAsync | Stop or disconnect from the server.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Exited | Event raised when the server has exited.
Public property | HasExited | A Task that completes when the server has exited.
Public property | HasStarted | A Task that completes when the server has started.
Public property | InputStream | The server's input stream.
Public property | IsRunning | Is the server running?
Public property | OutputStream | The server's output stream.
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess Methods

ServerProcess Methods

The ServerProcess type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose of resources being used by the launcher.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StartAsync | Start or connect to the server.
Public method | StopAsync | Stop or disconnect from the server.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess.Dispose Method

ServerProcessDispose Method
Dispose of resources being used by the launcher.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess.StartAsync Method

ServerProcessStartAsync Method
Start or connect to the server.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Task StartAsync()
Public MustOverride Function StartAsync As Task
public:
virtual Task^ StartAsync() abstract
abstract StartAsync : unit -> Task

Return Value

Type: Task
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess.StopAsync Method

ServerProcessStopAsync Method
Stop or disconnect from the server.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Task StopAsync()
Public MustOverride Function StopAsync As Task
public:
virtual Task^ StopAsync() abstract
abstract StopAsync : unit -> Task

Return Value

Type: Task
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess Properties

ServerProcess Properties

The ServerProcess type exposes the following members.

Properties
 | Name | Description
Public property | Exited | Event raised when the server has exited.
Public property | HasExited | A Task that completes when the server has exited.
Public property | HasStarted | A Task that completes when the server has started.
Public property | InputStream | The server's input stream.
Public property | IsRunning | Is the server running?
Public property | OutputStream | The server's output stream.
Top
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess.Exited Property

ServerProcessExited Property
Event raised when the server has exited.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IObservable<Unit> Exited { get; }
Public ReadOnly Property Exited As IObservable(Of Unit)
    Get
public:
property IObservable<Unit>^ Exited {
    IObservable<Unit>^ get ();
}
member Exited : IObservable<Unit> with get

Property Value

Type: IObservableUnit
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess.HasExited Property

ServerProcessHasExited Property
A Task that completes when the server has exited.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task HasExited { get; }
Public ReadOnly Property HasExited As Task
    Get
public:
property Task^ HasExited {
    Task^ get ();
}
member HasExited : Task with get

Property Value

Type: Task
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess.HasStarted Property

ServerProcessHasStarted Property
A Task that completes when the server has started.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task HasStarted { get; }
Public ReadOnly Property HasStarted As Task
    Get
public:
property Task^ HasStarted {
    Task^ get ();
}
member HasStarted : Task with get

Property Value

Type: Task
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess.InputStream Property

ServerProcessInputStream Property
The server's input stream.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Stream InputStream { get; }
Public MustOverride ReadOnly Property InputStream As Stream
    Get
public:
virtual property Stream^ InputStream {
    Stream^ get () abstract;
}
abstract InputStream : Stream with get

Property Value

Type: Stream
Remarks
The connection will write to the server's input stream, and read from its output stream.
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess.IsRunning Property

ServerProcessIsRunning Property
Is the server running?

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract bool IsRunning { get; }
Public MustOverride ReadOnly Property IsRunning As Boolean
    Get
public:
virtual property bool IsRunning {
    bool get () abstract;
}
abstract IsRunning : bool with get

Property Value

Type: Boolean
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


ServerProcess.OutputStream Property

ServerProcessOutputStream Property
The server's output stream.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Stream OutputStream { get; }
Public MustOverride ReadOnly Property OutputStream As Stream
    Get
public:
virtual property Stream^ OutputStream {
    Stream^ get () abstract;
}
abstract OutputStream : Stream with get

Property Value

Type: Stream
Remarks
The connection will read from the server's output stream, and write to its input stream.
See Also

Reference

ServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcess Class

StdioServerProcess Class
A StdioServerProcess is a ServerProcess that launches its server as an external process and communicates with it over STDIN / STDOUT.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerProcess
Alternet.Syntax.Parsers.LspStdioServerProcess

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StdioServerProcess : ServerProcess
Public Class StdioServerProcess
    Inherits ServerProcess
public ref class StdioServerProcess : public ServerProcess
type StdioServerProcess =
    class
        inherit ServerProcess
    end

The StdioServerProcess type exposes the following members.

Constructors
 | Name | Description
Public method | StdioServerProcess | Create a new StdioServerProcess.
Top
Methods
 | Name | Description
Public method | Dispose | Dispose of resources being used by the launcher. (Inherited from ServerProcess.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StartAsync | Start or connect to the server. (Overrides ServerProcessStartAsync.)
Public method | StopAsync | Stop or disconnect from the server. (Overrides ServerProcessStopAsync.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Exited | Event raised when the server has exited. (Inherited from ServerProcess.)
Public property | HasExited | A Task that completes when the server has exited. (Inherited from ServerProcess.)
Public property | HasStarted | A Task that completes when the server has started. (Inherited from ServerProcess.)
Public property | InputStream | The server's input stream. (Overrides ServerProcessInputStream.)
Public property | IsRunning | Is the server running? (Overrides ServerProcessIsRunning.)
Public property | OutputStream | The server's output stream. (Overrides ServerProcessOutputStream.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcess Constructor

StdioServerProcess Constructor
Create a new StdioServerProcess.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StdioServerProcess(
    ILoggerFactory loggerFactory,
    ProcessStartInfo serverStartInfo
)
Public Sub New (
    loggerFactory As ILoggerFactory,
    serverStartInfo As ProcessStartInfo
)
public:
StdioServerProcess(
    ILoggerFactory^ loggerFactory,
    ProcessStartInfo^ serverStartInfo
)
new :
        loggerFactory : ILoggerFactory *
        serverStartInfo : ProcessStartInfo -> StdioServerProcess

Parameters

loggerFactory
Type: ILoggerFactory
The factory for loggers used by the process and its components.
serverStartInfo
Type: System.DiagnosticsProcessStartInfo
A ProcessStartInfo that describes how to start the server.
See Also

Reference

StdioServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcess Methods

StdioServerProcess Methods

The StdioServerProcess type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose of resources being used by the launcher. (Inherited from ServerProcess.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StartAsync | Start or connect to the server. (Overrides ServerProcessStartAsync.)
Public method | StopAsync | Stop or disconnect from the server. (Overrides ServerProcessStopAsync.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StdioServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcess.StartAsync Method

StdioServerProcessStartAsync Method
Start or connect to the server.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Task StartAsync()
Public Overrides Function StartAsync As Task
public:
virtual Task^ StartAsync() override
abstract StartAsync : unit -> Task
override StartAsync : unit -> Task

Return Value

Type: Task
See Also

Reference

StdioServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcess.StopAsync Method

StdioServerProcessStopAsync Method
Stop or disconnect from the server.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Task StopAsync()
Public Overrides Function StopAsync As Task
public:
virtual Task^ StopAsync() override
abstract StopAsync : unit -> Task
override StopAsync : unit -> Task

Return Value

Type: Task
See Also

Reference

StdioServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcess Properties

StdioServerProcess Properties

The StdioServerProcess type exposes the following members.

Properties
 | Name | Description
Public property | Exited | Event raised when the server has exited. (Inherited from ServerProcess.)
Public property | HasExited | A Task that completes when the server has exited. (Inherited from ServerProcess.)
Public property | HasStarted | A Task that completes when the server has started. (Inherited from ServerProcess.)
Public property | InputStream | The server's input stream. (Overrides ServerProcessInputStream.)
Public property | IsRunning | Is the server running? (Overrides ServerProcessIsRunning.)
Public property | OutputStream | The server's output stream. (Overrides ServerProcessOutputStream.)
Top
See Also

Reference

StdioServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcess.InputStream Property

StdioServerProcessInputStream Property
The server's input stream.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Stream InputStream { get; }
Public Overrides ReadOnly Property InputStream As Stream
    Get
public:
virtual property Stream^ InputStream {
    Stream^ get () override;
}
abstract InputStream : Stream with get
override InputStream : Stream with get

Property Value

Type: Stream
See Also

Reference

StdioServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcess.IsRunning Property

StdioServerProcessIsRunning Property
Is the server running?

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsRunning { get; }
Public Overrides ReadOnly Property IsRunning As Boolean
    Get
public:
virtual property bool IsRunning {
    bool get () override;
}
abstract IsRunning : bool with get
override IsRunning : bool with get

Property Value

Type: Boolean
See Also

Reference

StdioServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcess.OutputStream Property

StdioServerProcessOutputStream Property
The server's output stream.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Stream OutputStream { get; }
Public Overrides ReadOnly Property OutputStream As Stream
    Get
public:
virtual property Stream^ OutputStream {
    Stream^ get () override;
}
abstract OutputStream : Stream with get
override OutputStream : Stream with get

Property Value

Type: Stream
See Also

Reference

StdioServerProcess Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcessEx Class

StdioServerProcessEx Class
A StdioServerProcess is a ServerProcess that launches its server as an external process and communicates with it over STDIN / STDOUT.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerProcess
Alternet.Syntax.Parsers.LspStdioServerProcessEx

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StdioServerProcessEx : ServerProcess
Public Class StdioServerProcessEx
    Inherits ServerProcess
public ref class StdioServerProcessEx : public ServerProcess
type StdioServerProcessEx =
    class
        inherit ServerProcess
    end

The StdioServerProcessEx type exposes the following members.

Constructors
 | Name | Description
Public method | StdioServerProcessEx | Create a new StdioServerProcess.
Top
Methods
 | Name | Description
Public method | Dispose | Dispose of resources being used by the launcher. (Inherited from ServerProcess.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StartAsync | Start or connect to the server. (Overrides ServerProcessStartAsync.)
Public method | StopAsync | Stop or disconnect from the server. (Overrides ServerProcessStopAsync.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Exited | Event raised when the server has exited. (Inherited from ServerProcess.)
Public property | HasExited | A Task that completes when the server has exited. (Inherited from ServerProcess.)
Public property | HasStarted | A Task that completes when the server has started. (Inherited from ServerProcess.)
Public property | InputStream | The server's input stream. (Overrides ServerProcessInputStream.)
Public property | IsRunning | Is the server running? (Overrides ServerProcessIsRunning.)
Public property | OutputStream | The server's output stream. (Overrides ServerProcessOutputStream.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcessEx Constructor

StdioServerProcessEx Constructor
Create a new StdioServerProcess.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public StdioServerProcessEx(
    ILoggerFactory loggerFactory,
    ProcessStartInfo serverStartInfo
)
Public Sub New (
    loggerFactory As ILoggerFactory,
    serverStartInfo As ProcessStartInfo
)
public:
StdioServerProcessEx(
    ILoggerFactory^ loggerFactory,
    ProcessStartInfo^ serverStartInfo
)
new :
        loggerFactory : ILoggerFactory *
        serverStartInfo : ProcessStartInfo -> StdioServerProcessEx

Parameters

loggerFactory
Type: ILoggerFactory
The factory for loggers used by the process and its components.
serverStartInfo
Type: System.DiagnosticsProcessStartInfo
A ProcessStartInfo that describes how to start the server.
See Also

Reference

StdioServerProcessEx Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcessEx Methods

StdioServerProcessEx Methods

The StdioServerProcessEx type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose of resources being used by the launcher. (Inherited from ServerProcess.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StartAsync | Start or connect to the server. (Overrides ServerProcessStartAsync.)
Public method | StopAsync | Stop or disconnect from the server. (Overrides ServerProcessStopAsync.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StdioServerProcessEx Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcessEx.StartAsync Method

StdioServerProcessExStartAsync Method
Start or connect to the server.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Task StartAsync()
Public Overrides Function StartAsync As Task
public:
virtual Task^ StartAsync() override
abstract StartAsync : unit -> Task
override StartAsync : unit -> Task

Return Value

Type: Task
See Also

Reference

StdioServerProcessEx Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcessEx.StopAsync Method

StdioServerProcessExStopAsync Method
Stop or disconnect from the server.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Task StopAsync()
Public Overrides Function StopAsync As Task
public:
virtual Task^ StopAsync() override
abstract StopAsync : unit -> Task
override StopAsync : unit -> Task

Return Value

Type: Task
See Also

Reference

StdioServerProcessEx Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcessEx Properties

StdioServerProcessEx Properties

The StdioServerProcessEx type exposes the following members.

Properties
 | Name | Description
Public property | Exited | Event raised when the server has exited. (Inherited from ServerProcess.)
Public property | HasExited | A Task that completes when the server has exited. (Inherited from ServerProcess.)
Public property | HasStarted | A Task that completes when the server has started. (Inherited from ServerProcess.)
Public property | InputStream | The server's input stream. (Overrides ServerProcessInputStream.)
Public property | IsRunning | Is the server running? (Overrides ServerProcessIsRunning.)
Public property | OutputStream | The server's output stream. (Overrides ServerProcessOutputStream.)
Top
See Also

Reference

StdioServerProcessEx Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcessEx.InputStream Property

StdioServerProcessExInputStream Property
The server's input stream.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Stream InputStream { get; }
Public Overrides ReadOnly Property InputStream As Stream
    Get
public:
virtual property Stream^ InputStream {
    Stream^ get () override;
}
abstract InputStream : Stream with get
override InputStream : Stream with get

Property Value

Type: Stream
See Also

Reference

StdioServerProcessEx Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcessEx.IsRunning Property

StdioServerProcessExIsRunning Property
Is the server running?

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsRunning { get; }
Public Overrides ReadOnly Property IsRunning As Boolean
    Get
public:
virtual property bool IsRunning {
    bool get () override;
}
abstract IsRunning : bool with get
override IsRunning : bool with get

Property Value

Type: Boolean
See Also

Reference

StdioServerProcessEx Class
Alternet.Syntax.Parsers.Lsp Namespace


StdioServerProcessEx.OutputStream Property

StdioServerProcessExOutputStream Property
The server's output stream.

Namespace: Alternet.Syntax.Parsers.Lsp
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Stream OutputStream { get; }
Public Overrides ReadOnly Property OutputStream As Stream
    Get
public:
virtual property Stream^ OutputStream {
    Stream^ get () override;
}
abstract OutputStream : Stream with get
override OutputStream : Stream with get

Property Value

Type: Stream
See Also

Reference

StdioServerProcessEx Class
Alternet.Syntax.Parsers.Lsp Namespace


Alternet.Syntax.Parsers.Lsp.Clangd Namespace

Alternet.Syntax.Parsers.Lsp.Clangd Namespace
Classes
 | Class | Description
Public class | ClangdServerLocator | Finds location of the language server executable.
Public class | CParser | Represents class that and perform syntax and lexical analysis of specified ANSI-C code text.
Public class | CPlusPlusParser | Represents class that and perform syntax and lexical analysis of specified C++ code text.
Public class | CPlusPlusWorkspace |
Public class | CWorkspace |


ClangdServerLocator Class

ClangdServerLocator Class
Finds location of the language server executable.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.ClangdClangdServerLocator
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedClangdServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ClangdServerLocator : ServerLocator
Public Class ClangdServerLocator
    Inherits ServerLocator
public ref class ClangdServerLocator : public ServerLocator
type ClangdServerLocator =
    class
        inherit ServerLocator
    end

The ClangdServerLocator type exposes the following members.

Constructors
 | Name | Description
Public method | ClangdServerLocator | Initializes a new instance of the ClangdServerLocator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd Namespace


ClangdServerLocator Constructor

ClangdServerLocator Constructor
Initializes a new instance of the ClangdServerLocator class

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClangdServerLocator(
    ICProjectProvider projectProvider,
    CompileCommandsFileManager compileCommandsFileManager
)
Public Sub New (
    projectProvider As ICProjectProvider,
    compileCommandsFileManager As CompileCommandsFileManager
)
public:
ClangdServerLocator(
    ICProjectProvider^ projectProvider,
    CompileCommandsFileManager^ compileCommandsFileManager
)
new :
        projectProvider : ICProjectProvider *
        compileCommandsFileManager : CompileCommandsFileManager -> ClangdServerLocator

Parameters

projectProvider
Type: Alternet.Syntax.Parsers.LspICProjectProvider
compileCommandsFileManager
Type: Alternet.Syntax.Parsers.LspCompileCommandsFileManager
See Also

Reference

ClangdServerLocator Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


ClangdServerLocator Methods

ClangdServerLocator Methods

The ClangdServerLocator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClangdServerLocator Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser Class

CParser Class
Represents class that and perform syntax and lexical analysis of specified ANSI-C code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.ClangdCParser
Alternet.Syntax.Parsers.Lsp.ClangdCPlusPlusParser
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedCParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CParser : LspParser
Public Class CParser
    Inherits LspParser
public ref class CParser : public LspParser
type CParser =
    class
        inherit LspParser
    end

The CParser type exposes the following members.

Constructors
 | Name | Description
Public method | CParser | Initializes a new instance of the CParser class with default settings.
Public method | CParser(IContainer) | Initializes a new instance of the CParser class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs).)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Overrides LspParserOutline(IListIRange).)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Fields
Name | Description
DefaultCLangCodeCompletionChars | Represents a default collection of characters that initializes a code completion procedure when typing.
DefaultCLangDelimiters | Represents a default collection of delimiter characters.
DefaultCLangSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Overrides LspParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Overrides SyntaxParserSyntaxTree.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser Constructor

CParser Constructor
Overload List
 | Name | Description
Public method | CParser | Initializes a new instance of the CParser class with default settings.
Public method | CParser(IContainer) | Initializes a new instance of the CParser class with specified container.
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser Constructor

CParser Constructor
Initializes a new instance of the CParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CParser()
Public Sub New
public:
CParser()
new : unit -> CParser
See Also

Reference

CParser Class
CParser Overload
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser Constructor (IContainer)

CParser Constructor (IContainer)
Initializes a new instance of the CParser class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CParser(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
CParser(
    IContainer^ container
)
new :
        container : IContainer -> CParser

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

CParser Class
CParser Overload
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser Fields

CParser Fields

The CParser type exposes the following members.

Fields
Name | Description
DefaultCLangCodeCompletionChars | Represents a default collection of characters that initializes a code completion procedure when typing.
DefaultCLangDelimiters | Represents a default collection of delimiter characters.
DefaultCLangSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.DefaultCLangCodeCompletionChars Field

CParserDefaultCLangCodeCompletionChars Field
Represents a default collection of characters that initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCLangCodeCompletionChars
Public Shared DefaultCLangCodeCompletionChars As String
public:
static String^ DefaultCLangCodeCompletionChars
static val mutable DefaultCLangCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.DefaultCLangDelimiters Field

CParserDefaultCLangDelimiters Field
Represents a default collection of delimiter characters.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCLangDelimiters
Public Shared DefaultCLangDelimiters As String
public:
static String^ DefaultCLangDelimiters
static val mutable DefaultCLangDelimiters: string

Field Value

Type: String
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.DefaultCLangSyntaxOptions Field

CParserDefaultCLangSyntaxOptions Field
Represents default set of flags determining syntax parsing and formatting behavior.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultCLangSyntaxOptions
Public Shared DefaultCLangSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultCLangSyntaxOptions
static val mutable DefaultCLangSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser Methods

CParser Methods

The CParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs).)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Overrides LspParserOutline(IListIRange).)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.CodeCompletion Method

CParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs).)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.CodeCompletion Method (String, StringItemInfo[], Point, Boolean, CodeCompletionArgs)

CParserCodeCompletion Method (String, StringItemInfo, Point, Boolean, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    bool useThread,
    CodeCompletionArgs e
)
Public Overrides Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    useThread As Boolean,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    bool useThread,
    CodeCompletionArgs^ e
) override
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        useThread : bool *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        useThread : bool *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
useThread
Type: SystemBoolean
Specifies whether parser should perform the task in the separate thread.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs)
See Also

Reference

CParser Class
CodeCompletion Overload
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.CreateRepository Method

CParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.IsCodeCompletionChar Method

CParserIsCodeCompletionChar Method
Returns boolean value indicating that given character initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Public Overrides Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
public:
virtual bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
) override
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool
override IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
Given character.
style
Type: SystemByte
Specifies text style at cursor.
interval
Type: SystemInt32
Represents the delay, in milliseconds before displaying code completion window.

Return Value

Type: Boolean
True if given character is code completion character; otherwise false.

Implements

ISyntaxParserIsCodeCompletionChar(Char, Byte, Int32)
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.Outline Method

CParserOutline Method
Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int Outline(
    IList<IRange> ranges
)
Public Overrides Function Outline (
    ranges As IList(Of IRange)
) As Integer
public:
virtual int Outline(
    IList<IRange^>^ ranges
) override
abstract Outline :
        ranges : IList<IRange> -> int
override Outline :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Retrieves IOutlineRange collection for outlined sections.

Return Value

Type: Int32
Number of outlined sections.

Implements

ISyntaxParserOutline(IListIRange)
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.ParseText Method

CParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

CParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

CParser Class
ParseText Overload
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.ReparseText Method

CParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.ReparseText Method

CParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

CParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.ResetCodeCompletionChars Method

CParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.ResetOptions Method

CParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.ShouldSerializeCodeCompletionChars Method

CParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.ShouldSerializeOptions Method

CParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser Properties

CParser Properties

The CParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Overrides LspParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Overrides SyntaxParserSyntaxTree.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.CaseSensitive Property

CParserCaseSensitive Property
Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.Scheme Property

CParserScheme Property
Gets or sets list of rules for lexical analysis.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ILexScheme Scheme { get; set; }
Public Overrides Property Scheme As ILexScheme
    Get
    Set
public:
virtual property ILexScheme^ Scheme {
    ILexScheme^ get () override;
    void set (ILexScheme^ value) override;
}
abstract Scheme : ILexScheme with get, set
override Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme

Implements

ILexerScheme
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.Strings Property

CParserStrings Property
Gets or sets a list of strings to parse.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IStringList Strings { get; set; }
Public Overrides Property Strings As IStringList
    Get
    Set
public:
virtual property IStringList^ Strings {
    IStringList^ get () override;
    void set (IStringList^ value) override;
}
abstract Strings : IStringList with get, set
override Strings : IStringList with get, set

Property Value

Type: IStringList

Implements

IParserStrings
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.SyntaxTree Property

CParserSyntaxTree Property
Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ISyntaxTree SyntaxTree { get; set; }
Public Overrides Property SyntaxTree As ISyntaxTree
    Get
    Set
public:
virtual property ISyntaxTree^ SyntaxTree {
    ISyntaxTree^ get () override;
    void set (ISyntaxTree^ value) override;
}
abstract SyntaxTree : ISyntaxTree with get, set
override SyntaxTree : ISyntaxTree with get, set

Property Value

Type: ISyntaxTree

Implements

ISyntaxParserSyntaxTree
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser.Workspace Property

CParserWorkspace Property

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CWorkspace Workspace { get; }
Public ReadOnly Property Workspace As CWorkspace
    Get
public:
property CWorkspace^ Workspace {
    CWorkspace^ get ();
}
member Workspace : CWorkspace with get

Property Value

Type: CWorkspace
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CParser Events

CParser Events

The CParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusParser Class

CPlusPlusParser Class
Represents class that and perform syntax and lexical analysis of specified C++ code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.ClangdCParser
Alternet.Syntax.Parsers.Lsp.ClangdCPlusPlusParser
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedCPlusPlusParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CPlusPlusParser : CParser
Public Class CPlusPlusParser
    Inherits CParser
public ref class CPlusPlusParser : public CParser
type CPlusPlusParser =
    class
        inherit CParser
    end

The CPlusPlusParser type exposes the following members.

Constructors
 | Name | Description
Public method | CPlusPlusParser | Initializes a new instance of the CPlusPlusParser class with default settings.
Public method | CPlusPlusParser(IContainer) | Initializes a new instance of the CPlusPlusParser class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from CParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from CParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from CParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from CParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from CParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from CParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from CParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from CParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from CParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusParser Constructor

CPlusPlusParser Constructor
Overload List
 | Name | Description
Public method | CPlusPlusParser | Initializes a new instance of the CPlusPlusParser class with default settings.
Public method | CPlusPlusParser(IContainer) | Initializes a new instance of the CPlusPlusParser class with specified container.
Top
See Also

Reference

CPlusPlusParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusParser Constructor

CPlusPlusParser Constructor
Initializes a new instance of the CPlusPlusParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CPlusPlusParser()
Public Sub New
public:
CPlusPlusParser()
new : unit -> CPlusPlusParser
See Also

Reference

CPlusPlusParser Class
CPlusPlusParser Overload
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusParser Constructor (IContainer)

CPlusPlusParser Constructor (IContainer)
Initializes a new instance of the CPlusPlusParser class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CPlusPlusParser(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
CPlusPlusParser(
    IContainer^ container
)
new :
        container : IContainer -> CPlusPlusParser

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

CPlusPlusParser Class
CPlusPlusParser Overload
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusParser Methods

CPlusPlusParser Methods

The CPlusPlusParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from CParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from CParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from CParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from CParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from CParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CPlusPlusParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusParser Properties

CPlusPlusParser Properties

The CPlusPlusParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from CParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from CParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from CParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from CParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CPlusPlusParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusParser.Workspace Property

CPlusPlusParserWorkspace Property

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CPlusPlusWorkspace Workspace { get; }
Public ReadOnly Property Workspace As CPlusPlusWorkspace
    Get
public:
property CPlusPlusWorkspace^ Workspace {
    CPlusPlusWorkspace^ get ();
}
member Workspace : CPlusPlusWorkspace with get

Property Value

Type: CPlusPlusWorkspace
See Also

Reference

CPlusPlusParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusParser Events

CPlusPlusParser Events

The CPlusPlusParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CPlusPlusParser Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusWorkspace Class

CPlusPlusWorkspace Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.ClangdCWorkspace
Alternet.Syntax.Parsers.Lsp.ClangdCPlusPlusWorkspace
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedCPlusPlusWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CPlusPlusWorkspace : CWorkspace
Public Class CPlusPlusWorkspace
    Inherits CWorkspace
public ref class CPlusPlusWorkspace : public CWorkspace
type CPlusPlusWorkspace =
    class
        inherit CWorkspace
    end

The CPlusPlusWorkspace type exposes the following members.

Constructors
 | Name | Description
Public method | CPlusPlusWorkspace | Initializes a new instance of the CPlusPlusWorkspace class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Project | Gets or sets a CProject object for the parser. (Inherited from CWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusWorkspace Constructor

CPlusPlusWorkspace Constructor
Initializes a new instance of the CPlusPlusWorkspace class

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CPlusPlusWorkspace()
Public Sub New
public:
CPlusPlusWorkspace()
new : unit -> CPlusPlusWorkspace
See Also

Reference

CPlusPlusWorkspace Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusWorkspace Methods

CPlusPlusWorkspace Methods

The CPlusPlusWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CPlusPlusWorkspace Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CPlusPlusWorkspace Properties

CPlusPlusWorkspace Properties

The CPlusPlusWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | Project | Gets or sets a CProject object for the parser. (Inherited from CWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

CPlusPlusWorkspace Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CWorkspace Class

CWorkspace Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.ClangdCWorkspace
Alternet.Syntax.Parsers.Lsp.ClangdCPlusPlusWorkspace
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedCWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CWorkspace : LspWorkspace, ICProjectProvider
Public Class CWorkspace
    Inherits LspWorkspace
    Implements ICProjectProvider
public ref class CWorkspace : public LspWorkspace,
    ICProjectProvider
type CWorkspace =
    class
        inherit LspWorkspace
        interface ICProjectProvider
    end

The CWorkspace type exposes the following members.

Constructors
 | Name | Description
Public method | CWorkspace | Initializes a new instance of the CWorkspace class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Project | Gets or sets a CProject object for the parser.
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CWorkspace Constructor

CWorkspace Constructor
Initializes a new instance of the CWorkspace class

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CWorkspace()
Public Sub New
public:
CWorkspace()
new : unit -> CWorkspace
See Also

Reference

CWorkspace Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CWorkspace Methods

CWorkspace Methods

The CWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CWorkspace Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CWorkspace Properties

CWorkspace Properties

The CWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | Project | Gets or sets a CProject object for the parser.
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

CWorkspace Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


CWorkspace.Project Property

CWorkspaceProject Property
Gets or sets a CProject object for the parser.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd
Assembly: Alternet.Syntax.Parsers.Clangd.v7 (in Alternet.Syntax.Parsers.Clangd.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CProject Project { get; set; }
Public Property Project As CProject
    Get
    Set
public:
virtual property CProject^ Project {
    CProject^ get () sealed;
    void set (CProject^ value) sealed;
}
abstract Project : CProject with get, set
override Project : CProject with get, set

Property Value

Type: CProject

Implements

ICProjectProviderProject
See Also

Reference

CWorkspace Class
Alternet.Syntax.Parsers.Lsp.Clangd Namespace


Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace

Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace
Classes
 | Class | Description
Public class | ClangdServerLocatorEmbedded |
Public class | CParserEmbedded | Represents class that and perform syntax and lexical analysis of specified ANSI-C code text.
Public class | CPlusPlusParserEmbedded | Represents class that and perform syntax and lexical analysis of specified C++ code text.
Public class | CPlusPlusWorkspaceEmbedded |
Public class | CWorkspaceEmbedded |


ClangdServerLocatorEmbedded Class

ClangdServerLocatorEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.ClangdClangdServerLocator
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedClangdServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ClangdServerLocatorEmbedded : ClangdServerLocator
Public Class ClangdServerLocatorEmbedded
    Inherits ClangdServerLocator
public ref class ClangdServerLocatorEmbedded : public ClangdServerLocator
type ClangdServerLocatorEmbedded =
    class
        inherit ClangdServerLocator
    end

The ClangdServerLocatorEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | ClangdServerLocatorEmbedded | Initializes a new instance of the ClangdServerLocatorEmbedded class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


ClangdServerLocatorEmbedded Constructor

ClangdServerLocatorEmbedded Constructor
Initializes a new instance of the ClangdServerLocatorEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClangdServerLocatorEmbedded(
    ICProjectProvider projectProvider,
    CompileCommandsFileManager compileCommandsFileManager
)
Public Sub New (
    projectProvider As ICProjectProvider,
    compileCommandsFileManager As CompileCommandsFileManager
)
public:
ClangdServerLocatorEmbedded(
    ICProjectProvider^ projectProvider,
    CompileCommandsFileManager^ compileCommandsFileManager
)
new :
        projectProvider : ICProjectProvider *
        compileCommandsFileManager : CompileCommandsFileManager -> ClangdServerLocatorEmbedded

Parameters

projectProvider
Type: Alternet.Syntax.Parsers.LspICProjectProvider
compileCommandsFileManager
Type: Alternet.Syntax.Parsers.LspCompileCommandsFileManager
See Also

Reference

ClangdServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


ClangdServerLocatorEmbedded Methods

ClangdServerLocatorEmbedded Methods

The ClangdServerLocatorEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClangdServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CParserEmbedded Class

CParserEmbedded Class
Represents class that and perform syntax and lexical analysis of specified ANSI-C code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.ClangdCParser
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedCParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CParserEmbedded : CParser
Public Class CParserEmbedded
    Inherits CParser
public ref class CParserEmbedded : public CParser
type CParserEmbedded =
    class
        inherit CParser
    end

The CParserEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | CParserEmbedded | Initializes a new instance of the CParserEmbedded class with default settings.
Public method | CParserEmbedded(IContainer) | Initializes a new instance of the CParserEmbedded class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from CParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from CParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from CParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from CParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from CParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from CParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from CParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from CParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from CParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from CParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CParserEmbedded Constructor

CParserEmbedded Constructor
Overload List
 | Name | Description
Public method | CParserEmbedded | Initializes a new instance of the CParserEmbedded class with default settings.
Public method | CParserEmbedded(IContainer) | Initializes a new instance of the CParserEmbedded class with specified container.
Top
See Also

Reference

CParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CParserEmbedded Constructor

CParserEmbedded Constructor
Initializes a new instance of the CParserEmbedded class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CParserEmbedded()
Public Sub New
public:
CParserEmbedded()
new : unit -> CParserEmbedded
See Also

Reference

CParserEmbedded Class
CParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CParserEmbedded Constructor (IContainer)

CParserEmbedded Constructor (IContainer)
Initializes a new instance of the CParserEmbedded class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CParserEmbedded(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
CParserEmbedded(
    IContainer^ container
)
new :
        container : IContainer -> CParserEmbedded

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

CParserEmbedded Class
CParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CParserEmbedded Methods

CParserEmbedded Methods

The CParserEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from CParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from CParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from CParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from CParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from CParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CParserEmbedded Properties

CParserEmbedded Properties

The CParserEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from CParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from CParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from CParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from CParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from CParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CParserEmbedded Events

CParserEmbedded Events

The CParserEmbedded type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusParserEmbedded Class

CPlusPlusParserEmbedded Class
Represents class that and perform syntax and lexical analysis of specified C++ code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.ClangdCParser
Alternet.Syntax.Parsers.Lsp.ClangdCPlusPlusParser
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedCPlusPlusParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CPlusPlusParserEmbedded : CPlusPlusParser
Public Class CPlusPlusParserEmbedded
    Inherits CPlusPlusParser
public ref class CPlusPlusParserEmbedded : public CPlusPlusParser
type CPlusPlusParserEmbedded =
    class
        inherit CPlusPlusParser
    end

The CPlusPlusParserEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | CPlusPlusParserEmbedded | Initializes a new instance of the CPlusPlusParserEmbedded class with default settings.
Public method | CPlusPlusParserEmbedded(IContainer) | Initializes a new instance of the CPlusPlusParserEmbedded class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from CParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from CParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from CParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from CParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from CParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from CParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from CParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from CParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from CParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from CPlusPlusParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusParserEmbedded Constructor

CPlusPlusParserEmbedded Constructor
Overload List
 | Name | Description
Public method | CPlusPlusParserEmbedded | Initializes a new instance of the CPlusPlusParserEmbedded class with default settings.
Public method | CPlusPlusParserEmbedded(IContainer) | Initializes a new instance of the CPlusPlusParserEmbedded class with specified container.
Top
See Also

Reference

CPlusPlusParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusParserEmbedded Constructor

CPlusPlusParserEmbedded Constructor
Initializes a new instance of the CPlusPlusParserEmbedded class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CPlusPlusParserEmbedded()
Public Sub New
public:
CPlusPlusParserEmbedded()
new : unit -> CPlusPlusParserEmbedded
See Also

Reference

CPlusPlusParserEmbedded Class
CPlusPlusParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusParserEmbedded Constructor (IContainer)

CPlusPlusParserEmbedded Constructor (IContainer)
Initializes a new instance of the CPlusPlusParserEmbedded class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CPlusPlusParserEmbedded(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
CPlusPlusParserEmbedded(
    IContainer^ container
)
new :
        container : IContainer -> CPlusPlusParserEmbedded

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

CPlusPlusParserEmbedded Class
CPlusPlusParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusParserEmbedded Methods

CPlusPlusParserEmbedded Methods

The CPlusPlusParserEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from CParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from CParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from CParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from CParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from CParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from CParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from CParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from CParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CPlusPlusParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusParserEmbedded.DeployServer Method

CPlusPlusParserEmbeddedDeployServer Method

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DeployServer(
    IProgress<double> progress,
    string targetDirectory = null
)
Public Shared Sub DeployServer (
    progress As IProgress(Of Double),
    Optional targetDirectory As String = Nothing
)
public:
static void DeployServer(
    IProgress<double>^ progress,
    String^ targetDirectory = nullptr
)
static member DeployServer :
        progress : IProgress<float> *
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> unit

Parameters

progress
Type: SystemIProgressDouble
targetDirectory (Optional)
Type: SystemString
See Also

Reference

CPlusPlusParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusParserEmbedded.IsServerDeployed Method

CPlusPlusParserEmbeddedIsServerDeployed Method

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsServerDeployed(
    string targetDirectory = null
)
Public Shared Function IsServerDeployed (
    Optional targetDirectory As String = Nothing
) As Boolean
public:
static bool IsServerDeployed(
    String^ targetDirectory = nullptr
)
static member IsServerDeployed :
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> bool

Parameters

targetDirectory (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

CPlusPlusParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusParserEmbedded Properties

CPlusPlusParserEmbedded Properties

The CPlusPlusParserEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from CParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from CParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from CParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from CParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from CPlusPlusParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CPlusPlusParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusParserEmbedded Events

CPlusPlusParserEmbedded Events

The CPlusPlusParserEmbedded type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CPlusPlusParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusWorkspaceEmbedded Class

CPlusPlusWorkspaceEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.ClangdCWorkspace
Alternet.Syntax.Parsers.Lsp.ClangdCPlusPlusWorkspace
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedCPlusPlusWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CPlusPlusWorkspaceEmbedded : CPlusPlusWorkspace
Public Class CPlusPlusWorkspaceEmbedded
    Inherits CPlusPlusWorkspace
public ref class CPlusPlusWorkspaceEmbedded : public CPlusPlusWorkspace
type CPlusPlusWorkspaceEmbedded =
    class
        inherit CPlusPlusWorkspace
    end

The CPlusPlusWorkspaceEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | CPlusPlusWorkspaceEmbedded | Initializes a new instance of the CPlusPlusWorkspaceEmbedded class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Project | Gets or sets a CProject object for the parser. (Inherited from CWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusWorkspaceEmbedded Constructor

CPlusPlusWorkspaceEmbedded Constructor
Initializes a new instance of the CPlusPlusWorkspaceEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CPlusPlusWorkspaceEmbedded()
Public Sub New
public:
CPlusPlusWorkspaceEmbedded()
new : unit -> CPlusPlusWorkspaceEmbedded
See Also

Reference

CPlusPlusWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusWorkspaceEmbedded Methods

CPlusPlusWorkspaceEmbedded Methods

The CPlusPlusWorkspaceEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CPlusPlusWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CPlusPlusWorkspaceEmbedded Properties

CPlusPlusWorkspaceEmbedded Properties

The CPlusPlusWorkspaceEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | Project | Gets or sets a CProject object for the parser. (Inherited from CWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

CPlusPlusWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CWorkspaceEmbedded Class

CWorkspaceEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.ClangdCWorkspace
Alternet.Syntax.Parsers.Lsp.Clangd.EmbeddedCWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CWorkspaceEmbedded : CWorkspace
Public Class CWorkspaceEmbedded
    Inherits CWorkspace
public ref class CWorkspaceEmbedded : public CWorkspace
type CWorkspaceEmbedded =
    class
        inherit CWorkspace
    end

The CWorkspaceEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | CWorkspaceEmbedded | Initializes a new instance of the CWorkspaceEmbedded class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Project | Gets or sets a CProject object for the parser. (Inherited from CWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CWorkspaceEmbedded Constructor

CWorkspaceEmbedded Constructor
Initializes a new instance of the CWorkspaceEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Clangd.Embedded
Assembly: Alternet.Syntax.Parsers.Clangd.Embedded.v7 (in Alternet.Syntax.Parsers.Clangd.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CWorkspaceEmbedded()
Public Sub New
public:
CWorkspaceEmbedded()
new : unit -> CWorkspaceEmbedded
See Also

Reference

CWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CWorkspaceEmbedded Methods

CWorkspaceEmbedded Methods

The CWorkspaceEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


CWorkspaceEmbedded Properties

CWorkspaceEmbedded Properties

The CWorkspaceEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | Project | Gets or sets a CProject object for the parser. (Inherited from CWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

CWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Clangd.Embedded Namespace


Alternet.Syntax.Parsers.Lsp.Detail Namespace

Alternet.Syntax.Parsers.Lsp.Detail Namespace
Classes
 | Class | Description
Public class | LspPrimitivesHelper |


LspPrimitivesHelper Class

LspPrimitivesHelper Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Lsp.DetailLspPrimitivesHelper

Namespace: Alternet.Syntax.Parsers.Lsp.Detail
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LspPrimitivesHelper
Public NotInheritable Class LspPrimitivesHelper
public ref class LspPrimitivesHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LspPrimitivesHelper =  class end

The LspPrimitivesHelper type exposes the following members.

Methods
Name | Description
LspDiagnosticCodeToString |
LspFoldingRangeToOutlineRange |
LspLocationToFileRange |
LspLocationToSymbolLocation |
LspPositionToPoint |
LspRangeToRange |
LspSeverityToErrorType |
PointToLspPosition |
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Detail Namespace


LspPrimitivesHelper Methods

LspPrimitivesHelper Methods

The LspPrimitivesHelper type exposes the following members.

Methods
Name | Description
LspDiagnosticCodeToString |
LspFoldingRangeToOutlineRange |
LspLocationToFileRange |
LspLocationToSymbolLocation |
LspPositionToPoint |
LspRangeToRange |
LspSeverityToErrorType |
PointToLspPosition |
Top
See Also

Reference

LspPrimitivesHelper Class
Alternet.Syntax.Parsers.Lsp.Detail Namespace


LspPrimitivesHelper.LspDiagnosticCodeToString Method

LspPrimitivesHelperLspDiagnosticCodeToString Method

Namespace: Alternet.Syntax.Parsers.Lsp.Detail
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LspDiagnosticCodeToString(
    DiagnosticCode value
)
Public Shared Function LspDiagnosticCodeToString (
    value As DiagnosticCode
) As String
public:
static String^ LspDiagnosticCodeToString(
    DiagnosticCode value
)
static member LspDiagnosticCodeToString :
        value : DiagnosticCode -> string

Parameters

value
Type: DiagnosticCode

Return Value

Type: String
See Also

Reference

LspPrimitivesHelper Class
Alternet.Syntax.Parsers.Lsp.Detail Namespace


LspPrimitivesHelper.LspFoldingRangeToOutlineRange Method

LspPrimitivesHelperLspFoldingRangeToOutlineRange Method

Namespace: Alternet.Syntax.Parsers.Lsp.Detail
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IOutlineRange LspFoldingRangeToOutlineRange(
    FoldingRange value
)
Public Shared Function LspFoldingRangeToOutlineRange (
    value As FoldingRange
) As IOutlineRange
public:
static IOutlineRange^ LspFoldingRangeToOutlineRange(
    FoldingRange^ value
)
static member LspFoldingRangeToOutlineRange :
        value : FoldingRange -> IOutlineRange

Parameters

value
Type: FoldingRange

Return Value

Type: IOutlineRange
See Also

Reference

LspPrimitivesHelper Class
Alternet.Syntax.Parsers.Lsp.Detail Namespace


LspPrimitivesHelper.LspLocationToFileRange Method

LspPrimitivesHelperLspLocationToFileRange Method

Namespace: Alternet.Syntax.Parsers.Lsp.Detail
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IFileRange LspLocationToFileRange(
    Location value,
    string sourceText = ""
)
Public Shared Function LspLocationToFileRange (
    value As Location,
    Optional sourceText As String = ""
) As IFileRange
public:
static IFileRange^ LspLocationToFileRange(
    Location^ value,
    String^ sourceText = L""
)
static member LspLocationToFileRange :
        value : Location *
        ?sourceText : string
(* Defaults:
        let _sourceText = defaultArg sourceText ""
*)
-> IFileRange

Parameters

value
Type: Location
sourceText (Optional)
Type: SystemString

Return Value

Type: IFileRange
See Also

Reference

LspPrimitivesHelper Class
Alternet.Syntax.Parsers.Lsp.Detail Namespace


LspPrimitivesHelper.LspLocationToSymbolLocation Method

LspPrimitivesHelperLspLocationToSymbolLocation Method

Namespace: Alternet.Syntax.Parsers.Lsp.Detail
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SymbolLocation LspLocationToSymbolLocation(
    LocationOrLocationLink value
)
Public Shared Function LspLocationToSymbolLocation (
    value As LocationOrLocationLink
) As SymbolLocation
public:
static SymbolLocation^ LspLocationToSymbolLocation(
    LocationOrLocationLink^ value
)
static member LspLocationToSymbolLocation :
        value : LocationOrLocationLink -> SymbolLocation

Parameters

value
Type: LocationOrLocationLink

Return Value

Type: SymbolLocation
See Also

Reference

LspPrimitivesHelper Class
Alternet.Syntax.Parsers.Lsp.Detail Namespace


LspPrimitivesHelper.LspPositionToPoint Method

LspPrimitivesHelperLspPositionToPoint Method

Namespace: Alternet.Syntax.Parsers.Lsp.Detail
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point LspPositionToPoint(
    Position value
)
Public Shared Function LspPositionToPoint (
    value As Position
) As Point
public:
static Point LspPositionToPoint(
    Position^ value
)
static member LspPositionToPoint :
        value : Position -> Point

Parameters

value
Type: Position

Return Value

Type: Point
See Also

Reference

LspPrimitivesHelper Class
Alternet.Syntax.Parsers.Lsp.Detail Namespace


LspPrimitivesHelper.LspRangeToRange Method

LspPrimitivesHelperLspRangeToRange Method

Namespace: Alternet.Syntax.Parsers.Lsp.Detail
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IRange LspRangeToRange(
    Range value
)
Public Shared Function LspRangeToRange (
    value As Range
) As IRange
public:
static IRange^ LspRangeToRange(
    Range^ value
)
static member LspRangeToRange :
        value : Range -> IRange

Parameters

value
Type: Range

Return Value

Type: IRange
See Also

Reference

LspPrimitivesHelper Class
Alternet.Syntax.Parsers.Lsp.Detail Namespace


LspPrimitivesHelper.LspSeverityToErrorType Method

LspPrimitivesHelperLspSeverityToErrorType Method

Namespace: Alternet.Syntax.Parsers.Lsp.Detail
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxErrorType LspSeverityToErrorType(
    DiagnosticSeverity severity
)
Public Shared Function LspSeverityToErrorType (
    severity As DiagnosticSeverity
) As SyntaxErrorType
public:
static SyntaxErrorType LspSeverityToErrorType(
    DiagnosticSeverity severity
)
static member LspSeverityToErrorType :
        severity : DiagnosticSeverity -> SyntaxErrorType

Parameters

severity
Type: DiagnosticSeverity

Return Value

Type: SyntaxErrorType
See Also

Reference

LspPrimitivesHelper Class
Alternet.Syntax.Parsers.Lsp.Detail Namespace


LspPrimitivesHelper.PointToLspPosition Method

LspPrimitivesHelperPointToLspPosition Method

Namespace: Alternet.Syntax.Parsers.Lsp.Detail
Assembly: Alternet.Syntax.Parsers.Lsp.v7 (in Alternet.Syntax.Parsers.Lsp.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Position PointToLspPosition(
    Point value
)
Public Shared Function PointToLspPosition (
    value As Point
) As Position
public:
static Position^ PointToLspPosition(
    Point value
)
static member PointToLspPosition :
        value : Point -> Position

Parameters

value
Type: System.DrawingPoint

Return Value

Type: Position
See Also

Reference

LspPrimitivesHelper Class
Alternet.Syntax.Parsers.Lsp.Detail Namespace


Alternet.Syntax.Parsers.Lsp.Java Namespace

Alternet.Syntax.Parsers.Lsp.Java Namespace
Classes
 | Class | Description
Public class | JavaParser | Represents class that and perform syntax and lexical analysis of specified Java code text.
Public class | JavaRepository | Represents properties and methods to perform code completion functionality for Java language.
Public class | JavaServerLocator | Finds location of the language server executable.
Public class | JavaWorkspace |
Enumerations
 | Enumeration | Description
Public enumeration | JavaLexerToken | Represents lexical tokens for J# parser.


JavaLexerToken Enumeration

JavaLexerToken Enumeration
Represents lexical tokens for J# parser.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum JavaLexerToken
Public Enumeration JavaLexerToken
public enum class JavaLexerToken
type JavaLexerToken
Members
Member name | Value | Description
Unit | 0 |
Abstract | 1 |
As | 2 |
Async | 3 |
Add | 4 |
Assembly | 5 |
Await | 6 |
Base | 7 |
Bool | 8 |
Break | 9 |
Byte | 10 |
Case | 11 |
Catch | 12 |
Char | 13 |
Checked | 14 |
Class | 15 |
Consts | 16 |
Continue | 17 |
Decimal | 18 |
Default | 19 |
Delegate | 20 |
Do | 21 |
Double | 22 |
Dynamic | 23 |
Else | 24 |
Enum | 25 |
Event | 26 |
Explicit | 27 |
Extern | 28 |
False | 29 |
Finally | 30 |
Fixed | 31 |
Float | 32 |
For | 33 |
Foreach | 34 |
Goto | 35 |
If | 36 |
Implicit | 37 |
In | 38 |
Int | 39 |
Interface | 40 |
Internal | 41 |
Is | 42 |
Lock | 43 |
Long | 44 |
Nameof | 45 |
Namespace | 46 |
New | 47 |
Null | 48 |
Object | 49 |
Operator | 50 |
Out | 51 |
Override | 52 |
Params | 53 |
Private | 54 |
Protected | 55 |
Public | 56 |
Readonly | 57 |
Ref | 58 |
Return | 59 |
Remove | 60 |
Sbyte | 61 |
Sealed | 62 |
Short | 63 |
Sizeof | 64 |
Stackalloc | 65 |
Static | 66 |
String | 67 |
Struct | 68 |
Switch | 69 |
This | 70 |
Throw | 71 |
True | 72 |
Try | 73 |
Typeof | 74 |
Uint | 75 |
Ulong | 76 |
Unchecked | 77 |
Unsafe | 78 |
Ushort | 79 |
Using | 80 |
Virtual | 81 |
Void | 82 |
Volatile | 83 |
While | 84 |
ArgList | 85 |
Partial | 86 |
Where | 87 |
Yield | 88 |
Value | 89 |
Alias | 90 |
Global | 91 |
Var | 92 |
Select | 93 |
From | 94 |
Join | 95 |
Group | 96 |
By | 97 |
OrderBy | 98 |
On | 99 |
Equals | 100 |
Into | 101 |
Let | 102 |
Ascending | 103 |
Descending | 104 |
When | 105 |
Get | 106 |
Set | 107 |
Open_brace | 108 |
Close_brace | 109 |
Open_bracket | 110 |
Close_bracket | 111 |
Open_parens | 112 |
Close_parens | 113 |
Dot | 114 |
Comma | 115 |
Colon | 116 |
DblColon | 117 |
Semicolon | 118 |
Tilde | 119 |
Plus | 120 |
Minus | 121 |
Bang | 122 |
Assign | 123 |
Op_lt | 124 |
Op_gt | 125 |
Bitwise_and | 126 |
Bitwise_or | 127 |
Star | 128 |
Percent | 129 |
Div | 130 |
Carret | 131 |
Interr | 132 |
DblInterr | 133 |
Op_inc | 134 |
Op_dec | 135 |
Op_shift_left | 136 |
Op_shift_right | 137 |
Op_le | 138 |
Op_ge | 139 |
Op_eq | 140 |
Op_ne | 141 |
Op_and | 142 |
Op_or | 143 |
Op_mult_assign | 144 |
Op_div_assign | 145 |
Op_mod_assign | 146 |
Op_add_assign | 147 |
Op_sub_assign | 148 |
Op_shift_left_assign | 149 |
Op_shift_right_assign | 150 |
Op_and_assign | 151 |
Op_xor_assign | 152 |
Op_or_assign | 153 |
Op_ptr | 154 |
Lambda | 155 |
XmlComment | 156 |
Integer_Literal | 157 |
Float_Literal | 158 |
Double_Literal | 159 |
Decimal_Literal | 160 |
Character_Literal | 161 |
String_Literal | 162 |
Identifier_Literal | 163 |
Comment_Literal | 164 |
XmlComment_Literal | 165 |
XmlInnerComment_Literal | 166 |
Directive_Literal | 167 |
Whitespace_Literal | 168 |
Boolean | 169 |
Assert | 170 |
Extends | 171 |
Final | 172 |
Implements | 173 |
Import | 174 |
Instanceof | 175 |
Native | 176 |
Package | 177 |
Super | 178 |
Synchronized | 179 |
Throws | 180 |
Strictfp | 181 |
Transient | 182 |
Op_unsigned_shift_right_assign | 183 |
Op_unsigned_shift_right | 184 |
Annotation | 185 |
Long_Literal | 186 |
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser Class

JavaParser Class
Represents class that and perform syntax and lexical analysis of specified Java code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.JavaJavaParser
Alternet.Syntax.Parsers.Lsp.Java.EmbeddedJavaParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaParser : LspParser
Public Class JavaParser
    Inherits LspParser
public ref class JavaParser : public LspParser
type JavaParser =
    class
        inherit LspParser
    end

The JavaParser type exposes the following members.

Constructors
 | Name | Description
Public method | JavaParser | Initializes a new instance of the JavaParser class with default settings.
Public method | JavaParser(IContainer) | Initializes a new instance of the JavaParser class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Fields
Name | Description
DefaultJavaCodeCompletionChars | Represents a default collection of characters that initializes a code completion procedure when typing.
DefaultJavaDelimiters | Represents a default collection of delimiter characters.
DefaultJavaSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a JavaRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser Constructor

JavaParser Constructor
Overload List
 | Name | Description
Public method | JavaParser | Initializes a new instance of the JavaParser class with default settings.
Public method | JavaParser(IContainer) | Initializes a new instance of the JavaParser class with specified container.
Top
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser Constructor

JavaParser Constructor
Initializes a new instance of the JavaParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaParser()
Public Sub New
public:
JavaParser()
new : unit -> JavaParser
See Also

Reference

JavaParser Class
JavaParser Overload
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser Constructor (IContainer)

JavaParser Constructor (IContainer)
Initializes a new instance of the JavaParser class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaParser(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
JavaParser(
    IContainer^ container
)
new :
        container : IContainer -> JavaParser

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

JavaParser Class
JavaParser Overload
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser Fields

JavaParser Fields

The JavaParser type exposes the following members.

Fields
Name | Description
DefaultJavaCodeCompletionChars | Represents a default collection of characters that initializes a code completion procedure when typing.
DefaultJavaDelimiters | Represents a default collection of delimiter characters.
DefaultJavaSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.DefaultJavaCodeCompletionChars Field

JavaParserDefaultJavaCodeCompletionChars Field
Represents a default collection of characters that initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultJavaCodeCompletionChars
Public Shared DefaultJavaCodeCompletionChars As String
public:
static String^ DefaultJavaCodeCompletionChars
static val mutable DefaultJavaCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.DefaultJavaDelimiters Field

JavaParserDefaultJavaDelimiters Field
Represents a default collection of delimiter characters.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultJavaDelimiters
Public Shared DefaultJavaDelimiters As String
public:
static String^ DefaultJavaDelimiters
static val mutable DefaultJavaDelimiters: string

Field Value

Type: String
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.DefaultJavaSyntaxOptions Field

JavaParserDefaultJavaSyntaxOptions Field
Represents default set of flags determining syntax parsing and formatting behavior.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultJavaSyntaxOptions
Public Shared DefaultJavaSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultJavaSyntaxOptions
static val mutable DefaultJavaSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser Methods

JavaParser Methods

The JavaParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.CreateRepository Method

JavaParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.IsCodeCompletionChar Method

JavaParserIsCodeCompletionChar Method
Returns boolean value indicating that given character initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Public Overrides Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
public:
virtual bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
) override
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool
override IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
Given character.
style
Type: SystemByte
Specifies text style at cursor.
interval
Type: SystemInt32
Represents the delay, in milliseconds before displaying code completion window.

Return Value

Type: Boolean
True if given character is code completion character; otherwise false.

Implements

ISyntaxParserIsCodeCompletionChar(Char, Byte, Int32)
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.ParseText Method

JavaParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

JavaParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

JavaParser Class
ParseText Overload
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.ResetCodeCompletionChars Method

JavaParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.ResetOptions Method

JavaParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.ShouldSerializeCodeCompletionChars Method

JavaParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.ShouldSerializeOptions Method

JavaParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser Properties

JavaParser Properties

The JavaParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a JavaRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.Repository Property

JavaParserRepository Property
Gets a JavaRepository that holds methods for code completion purposes.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaRepository Repository { get; }
Public ReadOnly Property Repository As JavaRepository
    Get
public:
property JavaRepository^ Repository {
    JavaRepository^ get ();
}
member Repository : JavaRepository with get

Property Value

Type: JavaRepository
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.Scheme Property

JavaParserScheme Property
Gets or sets list of rules for lexical analysis.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ILexScheme Scheme { get; set; }
Public Overrides Property Scheme As ILexScheme
    Get
    Set
public:
virtual property ILexScheme^ Scheme {
    ILexScheme^ get () override;
    void set (ILexScheme^ value) override;
}
abstract Scheme : ILexScheme with get, set
override Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme

Implements

ILexerScheme
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser.Workspace Property

JavaParserWorkspace Property

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaWorkspace Workspace { get; }
Public ReadOnly Property Workspace As JavaWorkspace
    Get
public:
property JavaWorkspace^ Workspace {
    JavaWorkspace^ get ();
}
member Workspace : JavaWorkspace with get

Property Value

Type: JavaWorkspace
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaParser Events

JavaParser Events

The JavaParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaParser Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaRepository Class

JavaRepository Class
Represents properties and methods to perform code completion functionality for Java language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.LspLspRepository
Alternet.Syntax.Parsers.Lsp.JavaJavaRepository

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaRepository : LspRepository
Public Class JavaRepository
    Inherits LspRepository
public ref class JavaRepository : public LspRepository
type JavaRepository =
    class
        inherit LspRepository
    end

The JavaRepository type exposes the following members.

Constructors
 | Name | Description
Public method | JavaRepository | Initializes a new instance of the JavaRepository class with specified parameters.
Top
Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaRepository Constructor

JavaRepository Constructor
Initializes a new instance of the JavaRepository class with specified parameters.

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaRepository(
    ILspDocumentProvider documentProvider,
    ISyntaxTree syntaxTree
)
Public Sub New (
    documentProvider As ILspDocumentProvider,
    syntaxTree As ISyntaxTree
)
public:
JavaRepository(
    ILspDocumentProvider^ documentProvider,
    ISyntaxTree^ syntaxTree
)
new :
        documentProvider : ILspDocumentProvider *
        syntaxTree : ISyntaxTree -> JavaRepository

Parameters

documentProvider
Type: Alternet.Syntax.Parsers.LspILspDocumentProvider
ILspDocumentProvider for this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
ISyntaxTree for this new instance.
See Also

Reference

JavaRepository Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaRepository Methods

JavaRepository Methods

The JavaRepository type exposes the following members.

Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

JavaRepository Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaRepository Properties

JavaRepository Properties

The JavaRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

JavaRepository Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaRepository Events

JavaRepository Events

The JavaRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

JavaRepository Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaServerLocator Class

JavaServerLocator Class
Finds location of the language server executable.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.JavaJavaServerLocator
Alternet.Syntax.Parsers.Lsp.Java.EmbeddedJavaServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaServerLocator : ServerLocator
Public Class JavaServerLocator
    Inherits ServerLocator
public ref class JavaServerLocator : public ServerLocator
type JavaServerLocator =
    class
        inherit ServerLocator
    end

The JavaServerLocator type exposes the following members.

Constructors
 | Name | Description
Public method | JavaServerLocator | Initializes a new instance of the JavaServerLocator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaServerLocator Constructor

JavaServerLocator Constructor
Initializes a new instance of the JavaServerLocator class

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaServerLocator()
Public Sub New
public:
JavaServerLocator()
new : unit -> JavaServerLocator
See Also

Reference

JavaServerLocator Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaServerLocator Methods

JavaServerLocator Methods

The JavaServerLocator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JavaServerLocator Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaWorkspace Class

JavaWorkspace Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.JavaJavaWorkspace
Alternet.Syntax.Parsers.Lsp.Java.EmbeddedJavaWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaWorkspace : LspWorkspace
Public Class JavaWorkspace
    Inherits LspWorkspace
public ref class JavaWorkspace : public LspWorkspace
type JavaWorkspace =
    class
        inherit LspWorkspace
    end

The JavaWorkspace type exposes the following members.

Constructors
 | Name | Description
Public method | JavaWorkspace | Initializes a new instance of the JavaWorkspace class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ProjectDirectory |
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaWorkspace Constructor

JavaWorkspace Constructor
Initializes a new instance of the JavaWorkspace class

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaWorkspace()
Public Sub New
public:
JavaWorkspace()
new : unit -> JavaWorkspace
See Also

Reference

JavaWorkspace Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaWorkspace Methods

JavaWorkspace Methods

The JavaWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JavaWorkspace Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaWorkspace Properties

JavaWorkspace Properties

The JavaWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | ProjectDirectory |
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

JavaWorkspace Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


JavaWorkspace.ProjectDirectory Property

JavaWorkspaceProjectDirectory Property

Namespace: Alternet.Syntax.Parsers.Lsp.Java
Assembly: Alternet.Syntax.Parsers.Java.v7 (in Alternet.Syntax.Parsers.Java.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectDirectory { get; set; }
Public Property ProjectDirectory As String
    Get
    Set
public:
property String^ ProjectDirectory {
    String^ get ();
    void set (String^ value);
}
member ProjectDirectory : string with get, set

Property Value

Type: String
See Also

Reference

JavaWorkspace Class
Alternet.Syntax.Parsers.Lsp.Java Namespace


Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace

Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace
Classes
 | Class | Description
Public class | JavaParserEmbedded | Represents class that and perform syntax and lexical analysis of specified Java code text.
Public class | JavaServerLocatorEmbedded |
Public class | JavaWorkspaceEmbedded |


JavaParserEmbedded Class

JavaParserEmbedded Class
Represents class that and perform syntax and lexical analysis of specified Java code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.JavaJavaParser
Alternet.Syntax.Parsers.Lsp.Java.EmbeddedJavaParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Java.Embedded
Assembly: Alternet.Syntax.Parsers.Java.Embedded.v7 (in Alternet.Syntax.Parsers.Java.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaParserEmbedded : JavaParser
Public Class JavaParserEmbedded
    Inherits JavaParser
public ref class JavaParserEmbedded : public JavaParser
type JavaParserEmbedded =
    class
        inherit JavaParser
    end

The JavaParserEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | JavaParserEmbedded | Initializes a new instance of the JavaParserEmbedded class with default settings.
Public method | JavaParserEmbedded(IContainer) | Initializes a new instance of the JavaParserEmbedded class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from JavaParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from JavaParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from JavaParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from JavaParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from JavaParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from JavaParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from JavaParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a JavaRepository that holds methods for code completion purposes. (Inherited from JavaParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from JavaParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from JavaParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaParserEmbedded Constructor

JavaParserEmbedded Constructor
Overload List
 | Name | Description
Public method | JavaParserEmbedded | Initializes a new instance of the JavaParserEmbedded class with default settings.
Public method | JavaParserEmbedded(IContainer) | Initializes a new instance of the JavaParserEmbedded class with specified container.
Top
See Also

Reference

JavaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaParserEmbedded Constructor

JavaParserEmbedded Constructor
Initializes a new instance of the JavaParserEmbedded class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Java.Embedded
Assembly: Alternet.Syntax.Parsers.Java.Embedded.v7 (in Alternet.Syntax.Parsers.Java.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaParserEmbedded()
Public Sub New
public:
JavaParserEmbedded()
new : unit -> JavaParserEmbedded
See Also

Reference

JavaParserEmbedded Class
JavaParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaParserEmbedded Constructor (IContainer)

JavaParserEmbedded Constructor (IContainer)
Initializes a new instance of the JavaParserEmbedded class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Java.Embedded
Assembly: Alternet.Syntax.Parsers.Java.Embedded.v7 (in Alternet.Syntax.Parsers.Java.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaParserEmbedded(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
JavaParserEmbedded(
    IContainer^ container
)
new :
        container : IContainer -> JavaParserEmbedded

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

JavaParserEmbedded Class
JavaParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaParserEmbedded Methods

JavaParserEmbedded Methods

The JavaParserEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from JavaParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from JavaParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from JavaParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from JavaParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from JavaParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from JavaParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from JavaParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

JavaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaParserEmbedded.DeployServer Method

JavaParserEmbeddedDeployServer Method

Namespace: Alternet.Syntax.Parsers.Lsp.Java.Embedded
Assembly: Alternet.Syntax.Parsers.Java.Embedded.v7 (in Alternet.Syntax.Parsers.Java.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DeployServer(
    IProgress<double> progress,
    string targetDirectory = null
)
Public Shared Sub DeployServer (
    progress As IProgress(Of Double),
    Optional targetDirectory As String = Nothing
)
public:
static void DeployServer(
    IProgress<double>^ progress,
    String^ targetDirectory = nullptr
)
static member DeployServer :
        progress : IProgress<float> *
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> unit

Parameters

progress
Type: SystemIProgressDouble
targetDirectory (Optional)
Type: SystemString
See Also

Reference

JavaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaParserEmbedded.IsServerDeployed Method

JavaParserEmbeddedIsServerDeployed Method

Namespace: Alternet.Syntax.Parsers.Lsp.Java.Embedded
Assembly: Alternet.Syntax.Parsers.Java.Embedded.v7 (in Alternet.Syntax.Parsers.Java.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsServerDeployed(
    string targetDirectory = null
)
Public Shared Function IsServerDeployed (
    Optional targetDirectory As String = Nothing
) As Boolean
public:
static bool IsServerDeployed(
    String^ targetDirectory = nullptr
)
static member IsServerDeployed :
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> bool

Parameters

targetDirectory (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

JavaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaParserEmbedded Properties

JavaParserEmbedded Properties

The JavaParserEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a JavaRepository that holds methods for code completion purposes. (Inherited from JavaParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from JavaParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from JavaParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaParserEmbedded Events

JavaParserEmbedded Events

The JavaParserEmbedded type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaServerLocatorEmbedded Class

JavaServerLocatorEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.JavaJavaServerLocator
Alternet.Syntax.Parsers.Lsp.Java.EmbeddedJavaServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Java.Embedded
Assembly: Alternet.Syntax.Parsers.Java.Embedded.v7 (in Alternet.Syntax.Parsers.Java.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaServerLocatorEmbedded : JavaServerLocator
Public Class JavaServerLocatorEmbedded
    Inherits JavaServerLocator
public ref class JavaServerLocatorEmbedded : public JavaServerLocator
type JavaServerLocatorEmbedded =
    class
        inherit JavaServerLocator
    end

The JavaServerLocatorEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | JavaServerLocatorEmbedded | Initializes a new instance of the JavaServerLocatorEmbedded class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaServerLocatorEmbedded Constructor

JavaServerLocatorEmbedded Constructor
Initializes a new instance of the JavaServerLocatorEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Java.Embedded
Assembly: Alternet.Syntax.Parsers.Java.Embedded.v7 (in Alternet.Syntax.Parsers.Java.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaServerLocatorEmbedded()
Public Sub New
public:
JavaServerLocatorEmbedded()
new : unit -> JavaServerLocatorEmbedded
See Also

Reference

JavaServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaServerLocatorEmbedded Methods

JavaServerLocatorEmbedded Methods

The JavaServerLocatorEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JavaServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaWorkspaceEmbedded Class

JavaWorkspaceEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.JavaJavaWorkspace
Alternet.Syntax.Parsers.Lsp.Java.EmbeddedJavaWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Java.Embedded
Assembly: Alternet.Syntax.Parsers.Java.Embedded.v7 (in Alternet.Syntax.Parsers.Java.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaWorkspaceEmbedded : JavaWorkspace
Public Class JavaWorkspaceEmbedded
    Inherits JavaWorkspace
public ref class JavaWorkspaceEmbedded : public JavaWorkspace
type JavaWorkspaceEmbedded =
    class
        inherit JavaWorkspace
    end

The JavaWorkspaceEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | JavaWorkspaceEmbedded | Initializes a new instance of the JavaWorkspaceEmbedded class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ProjectDirectory | (Inherited from JavaWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaWorkspaceEmbedded Constructor

JavaWorkspaceEmbedded Constructor
Initializes a new instance of the JavaWorkspaceEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Java.Embedded
Assembly: Alternet.Syntax.Parsers.Java.Embedded.v7 (in Alternet.Syntax.Parsers.Java.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaWorkspaceEmbedded()
Public Sub New
public:
JavaWorkspaceEmbedded()
new : unit -> JavaWorkspaceEmbedded
See Also

Reference

JavaWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaWorkspaceEmbedded Methods

JavaWorkspaceEmbedded Methods

The JavaWorkspaceEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JavaWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


JavaWorkspaceEmbedded Properties

JavaWorkspaceEmbedded Properties

The JavaWorkspaceEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | ProjectDirectory | (Inherited from JavaWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

JavaWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Java.Embedded Namespace


Alternet.Syntax.Parsers.Lsp.Lua Namespace

Alternet.Syntax.Parsers.Lsp.Lua Namespace
Classes
 | Class | Description
Public class | LuaParser |
Public class | LuaRepository |
Public class | LuaServerLocator | Finds location of the language server executable.
Public class | LuaWorkspace |
Enumerations
 | Enumeration | Description
Public enumeration | LuaLexerToken | Represents lexical tokens for Lua parser.


LuaLexerToken Enumeration

LuaLexerToken Enumeration
Represents lexical tokens for Lua parser.

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LuaLexerToken
Public Enumeration LuaLexerToken
public enum class LuaLexerToken
type LuaLexerToken
Members
Member name | Value | Description
And | 0 |
Break | 1 |
Do | 2 |
Else | 3 |
ElseIf | 4 |
End | 5 |
False | 6 |
For | 7 |
Function | 8 |
If | 9 |
In | 10 |
Local | 11 |
Nil | 12 |
Not | 13 |
Or | 14 |
Repeat | 15 |
Return | 16 |
Then | 17 |
True | 18 |
Until | 19 |
While | 20 |
Open_brace | 21 |
Close_brace | 22 |
Open_bracket | 23 |
Close_bracket | 24 |
Open_parens | 25 |
Close_parens | 26 |
Ellipsis | 27 |
Dot | 28 |
Comma | 29 |
Colon | 30 |
Semicolon | 31 |
Tilde | 32 |
Plus | 33 |
Minus | 34 |
Assign | 35 |
Op_lt | 36 |
Op_gt | 37 |
Star | 38 |
Percent | 39 |
Div | 40 |
Carret | 41 |
IntDiv | 42 |
Interr | 43 |
LineContinuation | 44 |
Op_le | 45 |
Op_ge | 46 |
Op_eq | 47 |
Op_ne | 48 |
Integer_Literal | 49 |
Float_Literal | 50 |
Double_Literal | 51 |
Character_Literal | 52 |
String_Literal | 53 |
Identifier_Literal | 54 |
Comment_Literal | 55 |
Whitespace_Literal | 56 |
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser Class

LuaParser Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.LuaLuaParser
Alternet.Syntax.Parsers.Lsp.Lua.EmbeddedLuaParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaParser : LspParser
Public Class LuaParser
    Inherits LspParser
public ref class LuaParser : public LspParser
type LuaParser =
    class
        inherit LspParser
    end

The LuaParser type exposes the following members.

Constructors
 | Name | Description
Public method | LuaParser | Initializes a new instance of the LuaParser class
Public method | LuaParser(IContainer) | Initializes a new instance of the LuaParser class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Fields
Name | Description
DefaultLuaSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Overrides LspParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | (Overrides SyntaxParserXmlScheme.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser Constructor

LuaParser Constructor
Overload List
 | Name | Description
Public method | LuaParser | Initializes a new instance of the LuaParser class
Public method | LuaParser(IContainer) | Initializes a new instance of the LuaParser class
Top
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser Constructor

LuaParser Constructor
Initializes a new instance of the LuaParser class

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaParser()
Public Sub New
public:
LuaParser()
new : unit -> LuaParser
See Also

Reference

LuaParser Class
LuaParser Overload
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser Constructor (IContainer)

LuaParser Constructor (IContainer)
Initializes a new instance of the LuaParser class

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaParser(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
LuaParser(
    IContainer^ container
)
new :
        container : IContainer -> LuaParser

Parameters

container
Type: System.ComponentModelIContainer
See Also

Reference

LuaParser Class
LuaParser Overload
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser Fields

LuaParser Fields

The LuaParser type exposes the following members.

Fields
Name | Description
DefaultLuaSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.DefaultLuaSyntaxOptions Field

LuaParserDefaultLuaSyntaxOptions Field
Represents default set of flags determining syntax parsing and formatting behavior.

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultLuaSyntaxOptions
Public Shared DefaultLuaSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultLuaSyntaxOptions
static val mutable DefaultLuaSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser Methods

LuaParser Methods

The LuaParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.CreateRepository Method

LuaParserCreateRepository Method

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.ParseText Method

LuaParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

LuaParserParseText Method (Int32, Int32, String, StringItemInfo)

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
line
Type: SystemInt32
str
Type: SystemString
colorData
Type: Alternet.SyntaxStringItemInfo

Return Value

Type: Int32

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

LuaParser Class
ParseText Overload
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.ResetOptions Method

LuaParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.ShouldSerializeOptions Method

LuaParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser Properties

LuaParser Properties

The LuaParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Overrides LspParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | (Overrides SyntaxParserXmlScheme.)
Top
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.CaseSensitive Property

LuaParserCaseSensitive Property

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.Scheme Property

LuaParserScheme Property

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ILexScheme Scheme { get; set; }
Public Overrides Property Scheme As ILexScheme
    Get
    Set
public:
virtual property ILexScheme^ Scheme {
    ILexScheme^ get () override;
    void set (ILexScheme^ value) override;
}
abstract Scheme : ILexScheme with get, set
override Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme

Implements

ILexerScheme
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.Strings Property

LuaParserStrings Property

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IStringList Strings { get; set; }
Public Overrides Property Strings As IStringList
    Get
    Set
public:
virtual property IStringList^ Strings {
    IStringList^ get () override;
    void set (IStringList^ value) override;
}
abstract Strings : IStringList with get, set
override Strings : IStringList with get, set

Property Value

Type: IStringList

Implements

IParserStrings
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.Workspace Property

LuaParserWorkspace Property

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaWorkspace Workspace { get; }
Public ReadOnly Property Workspace As LuaWorkspace
    Get
public:
property LuaWorkspace^ Workspace {
    LuaWorkspace^ get ();
}
member Workspace : LuaWorkspace with get

Property Value

Type: LuaWorkspace
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser.XmlScheme Property

LuaParserXmlScheme Property

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string XmlScheme { get; set; }
Public Overrides Property XmlScheme As String
    Get
    Set
public:
virtual property String^ XmlScheme {
    String^ get () override;
    void set (String^ value) override;
}
abstract XmlScheme : string with get, set
override XmlScheme : string with get, set

Property Value

Type: String
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaParser Events

LuaParser Events

The LuaParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

LuaParser Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaRepository Class

LuaRepository Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.LspLspRepository
Alternet.Syntax.Parsers.Lsp.LuaLuaRepository

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaRepository : LspRepository
Public Class LuaRepository
    Inherits LspRepository
public ref class LuaRepository : public LspRepository
type LuaRepository =
    class
        inherit LspRepository
    end

The LuaRepository type exposes the following members.

Constructors
 | Name | Description
Public method | LuaRepository | Initializes a new instance of the LuaRepository class
Top
Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaRepository Constructor

LuaRepository Constructor
Initializes a new instance of the LuaRepository class

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaRepository(
    ILspDocumentProvider documentProvider,
    ISyntaxTree syntaxTree
)
Public Sub New (
    documentProvider As ILspDocumentProvider,
    syntaxTree As ISyntaxTree
)
public:
LuaRepository(
    ILspDocumentProvider^ documentProvider,
    ISyntaxTree^ syntaxTree
)
new :
        documentProvider : ILspDocumentProvider *
        syntaxTree : ISyntaxTree -> LuaRepository

Parameters

documentProvider
Type: Alternet.Syntax.Parsers.LspILspDocumentProvider
syntaxTree
Type: Alternet.SyntaxISyntaxTree
See Also

Reference

LuaRepository Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaRepository Methods

LuaRepository Methods

The LuaRepository type exposes the following members.

Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

LuaRepository Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaRepository Properties

LuaRepository Properties

The LuaRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

LuaRepository Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaRepository Events

LuaRepository Events

The LuaRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

LuaRepository Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaServerLocator Class

LuaServerLocator Class
Finds location of the language server executable.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.LuaLuaServerLocator
Alternet.Syntax.Parsers.Lsp.Lua.EmbeddedLuaServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaServerLocator : ServerLocator
Public Class LuaServerLocator
    Inherits ServerLocator
public ref class LuaServerLocator : public ServerLocator
type LuaServerLocator =
    class
        inherit ServerLocator
    end

The LuaServerLocator type exposes the following members.

Constructors
 | Name | Description
Public method | LuaServerLocator | Initializes a new instance of the LuaServerLocator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaServerLocator Constructor

LuaServerLocator Constructor
Initializes a new instance of the LuaServerLocator class

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaServerLocator()
Public Sub New
public:
LuaServerLocator()
new : unit -> LuaServerLocator
See Also

Reference

LuaServerLocator Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaServerLocator Methods

LuaServerLocator Methods

The LuaServerLocator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LuaServerLocator Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaWorkspace Class

LuaWorkspace Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.LuaLuaWorkspace
Alternet.Syntax.Parsers.Lsp.Lua.EmbeddedLuaWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaWorkspace : LspWorkspace
Public Class LuaWorkspace
    Inherits LspWorkspace
public ref class LuaWorkspace : public LspWorkspace
type LuaWorkspace =
    class
        inherit LspWorkspace
    end

The LuaWorkspace type exposes the following members.

Constructors
 | Name | Description
Public method | LuaWorkspace | Initializes a new instance of the LuaWorkspace class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaWorkspace Constructor

LuaWorkspace Constructor
Initializes a new instance of the LuaWorkspace class

Namespace: Alternet.Syntax.Parsers.Lsp.Lua
Assembly: Alternet.Syntax.Parsers.Lua.v7 (in Alternet.Syntax.Parsers.Lua.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaWorkspace()
Public Sub New
public:
LuaWorkspace()
new : unit -> LuaWorkspace
See Also

Reference

LuaWorkspace Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaWorkspace Methods

LuaWorkspace Methods

The LuaWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LuaWorkspace Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


LuaWorkspace Properties

LuaWorkspace Properties

The LuaWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

LuaWorkspace Class
Alternet.Syntax.Parsers.Lsp.Lua Namespace


Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace

Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace
Classes
 | Class | Description
Public class | LuaParserEmbedded |
Public class | LuaServerLocatorEmbedded |
Public class | LuaWorkspaceEmbedded |


LuaParserEmbedded Class

LuaParserEmbedded Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.LuaLuaParser
Alternet.Syntax.Parsers.Lsp.Lua.EmbeddedLuaParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaParserEmbedded : LuaParser
Public Class LuaParserEmbedded
    Inherits LuaParser
public ref class LuaParserEmbedded : public LuaParser
type LuaParserEmbedded =
    class
        inherit LuaParser
    end

The LuaParserEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | LuaParserEmbedded | Initializes a new instance of the LuaParserEmbedded class
Public method | LuaParserEmbedded(IContainer) | Initializes a new instance of the LuaParserEmbedded class
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | (Inherited from LuaParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | (Inherited from LuaParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from LuaParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from LuaParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | (Inherited from LuaParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | (Inherited from LuaParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from LuaParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from LuaParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | (Inherited from LuaParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaParserEmbedded Constructor

LuaParserEmbedded Constructor
Overload List
 | Name | Description
Public method | LuaParserEmbedded | Initializes a new instance of the LuaParserEmbedded class
Public method | LuaParserEmbedded(IContainer) | Initializes a new instance of the LuaParserEmbedded class
Top
See Also

Reference

LuaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaParserEmbedded Constructor

LuaParserEmbedded Constructor
Initializes a new instance of the LuaParserEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaParserEmbedded()
Public Sub New
public:
LuaParserEmbedded()
new : unit -> LuaParserEmbedded
See Also

Reference

LuaParserEmbedded Class
LuaParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaParserEmbedded Constructor (IContainer)

LuaParserEmbedded Constructor (IContainer)
Initializes a new instance of the LuaParserEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaParserEmbedded(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
LuaParserEmbedded(
    IContainer^ container
)
new :
        container : IContainer -> LuaParserEmbedded

Parameters

container
Type: System.ComponentModelIContainer
See Also

Reference

LuaParserEmbedded Class
LuaParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaParserEmbedded Methods

LuaParserEmbedded Methods

The LuaParserEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | (Inherited from LuaParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | (Inherited from LuaParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from LuaParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from LuaParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

LuaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaParserEmbedded.DeployServer Method

LuaParserEmbeddedDeployServer Method

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DeployServer(
    IProgress<double> progress,
    string targetDirectory = null
)
Public Shared Sub DeployServer (
    progress As IProgress(Of Double),
    Optional targetDirectory As String = Nothing
)
public:
static void DeployServer(
    IProgress<double>^ progress,
    String^ targetDirectory = nullptr
)
static member DeployServer :
        progress : IProgress<float> *
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> unit

Parameters

progress
Type: SystemIProgressDouble
targetDirectory (Optional)
Type: SystemString
See Also

Reference

LuaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaParserEmbedded.IsServerDeployed Method

LuaParserEmbeddedIsServerDeployed Method

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsServerDeployed(
    string targetDirectory = null
)
Public Shared Function IsServerDeployed (
    Optional targetDirectory As String = Nothing
) As Boolean
public:
static bool IsServerDeployed(
    String^ targetDirectory = nullptr
)
static member IsServerDeployed :
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> bool

Parameters

targetDirectory (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

LuaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaParserEmbedded Properties

LuaParserEmbedded Properties

The LuaParserEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | (Inherited from LuaParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | (Inherited from LuaParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from LuaParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from LuaParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | (Inherited from LuaParser.)
Top
See Also

Reference

LuaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaParserEmbedded Events

LuaParserEmbedded Events

The LuaParserEmbedded type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

LuaParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaServerLocatorEmbedded Class

LuaServerLocatorEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.LuaLuaServerLocator
Alternet.Syntax.Parsers.Lsp.Lua.EmbeddedLuaServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaServerLocatorEmbedded : LuaServerLocator
Public Class LuaServerLocatorEmbedded
    Inherits LuaServerLocator
public ref class LuaServerLocatorEmbedded : public LuaServerLocator
type LuaServerLocatorEmbedded =
    class
        inherit LuaServerLocator
    end

The LuaServerLocatorEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | LuaServerLocatorEmbedded | Initializes a new instance of the LuaServerLocatorEmbedded class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaServerLocatorEmbedded Constructor

LuaServerLocatorEmbedded Constructor
Initializes a new instance of the LuaServerLocatorEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaServerLocatorEmbedded()
Public Sub New
public:
LuaServerLocatorEmbedded()
new : unit -> LuaServerLocatorEmbedded
See Also

Reference

LuaServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaServerLocatorEmbedded Methods

LuaServerLocatorEmbedded Methods

The LuaServerLocatorEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LuaServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaWorkspaceEmbedded Class

LuaWorkspaceEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.LuaLuaWorkspace
Alternet.Syntax.Parsers.Lsp.Lua.EmbeddedLuaWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaWorkspaceEmbedded : LuaWorkspace
Public Class LuaWorkspaceEmbedded
    Inherits LuaWorkspace
public ref class LuaWorkspaceEmbedded : public LuaWorkspace
type LuaWorkspaceEmbedded =
    class
        inherit LuaWorkspace
    end

The LuaWorkspaceEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | LuaWorkspaceEmbedded | Initializes a new instance of the LuaWorkspaceEmbedded class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
 | DeployServer |
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsServerDeployed |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaWorkspaceEmbedded Constructor

LuaWorkspaceEmbedded Constructor
Initializes a new instance of the LuaWorkspaceEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LuaWorkspaceEmbedded()
Public Sub New
public:
LuaWorkspaceEmbedded()
new : unit -> LuaWorkspaceEmbedded
See Also

Reference

LuaWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaWorkspaceEmbedded Methods

LuaWorkspaceEmbedded Methods

The LuaWorkspaceEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
 | DeployServer |
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsServerDeployed |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LuaWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaWorkspaceEmbedded.DeployServer Method

LuaWorkspaceEmbeddedDeployServer Method

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DeployServer(
    IProgress<double> progress,
    string targetDirectory = null
)
Public Shared Sub DeployServer (
    progress As IProgress(Of Double),
    Optional targetDirectory As String = Nothing
)
public:
static void DeployServer(
    IProgress<double>^ progress,
    String^ targetDirectory = nullptr
)
static member DeployServer :
        progress : IProgress<float> *
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> unit

Parameters

progress
Type: SystemIProgressDouble
targetDirectory (Optional)
Type: SystemString
See Also

Reference

LuaWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaWorkspaceEmbedded.IsServerDeployed Method

LuaWorkspaceEmbeddedIsServerDeployed Method

Namespace: Alternet.Syntax.Parsers.Lsp.Lua.Embedded
Assembly: Alternet.Syntax.Parsers.Lua.Embedded.v7 (in Alternet.Syntax.Parsers.Lua.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsServerDeployed(
    string targetDirectory = null
)
Public Shared Function IsServerDeployed (
    Optional targetDirectory As String = Nothing
) As Boolean
public:
static bool IsServerDeployed(
    String^ targetDirectory = nullptr
)
static member IsServerDeployed :
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> bool

Parameters

targetDirectory (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

LuaWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


LuaWorkspaceEmbedded Properties

LuaWorkspaceEmbedded Properties

The LuaWorkspaceEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

LuaWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Lua.Embedded Namespace


Alternet.Syntax.Parsers.Lsp.PowerShell Namespace

Alternet.Syntax.Parsers.Lsp.PowerShell Namespace
Classes
 | Class | Description
Public class | ExternalVariable | Describes an external variable information to be used in the PowerShellParser.
Public class | LineToken |
Public class | PowerShellParser | Represents class that and perform syntax and lexical analysis of specified PowerShell code text.
Public class | PowerShellRepository | Represents properties and methods to perform code completion functionality for PowerShell language.
Public class | PowerShellServerLocator | Finds location of the language server executable.
Public class | PowerShellTokenizer |
Public class | PowerShellWorkspace |
Public class | TokenList |


ExternalVariable Class

ExternalVariable Class
Describes an external variable information to be used in the PowerShellParser.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Lsp.PowerShellExternalVariable

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalVariable
Public Class ExternalVariable
public ref class ExternalVariable
type ExternalVariable =  class end

The ExternalVariable type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalVariable | Initializes a new instance of the ExternalVariable class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


ExternalVariable Constructor

ExternalVariable Constructor
Initializes a new instance of the ExternalVariable class

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalVariable(
    string name
)
Public Sub New (
    name As String
)
public:
ExternalVariable(
    String^ name
)
new :
        name : string -> ExternalVariable

Parameters

name
Type: SystemString
See Also

Reference

ExternalVariable Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


ExternalVariable Methods

ExternalVariable Methods

The ExternalVariable type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExternalVariable Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


ExternalVariable Properties

ExternalVariable Properties

The ExternalVariable type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

ExternalVariable Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


ExternalVariable.Name Property

ExternalVariableName Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

ExternalVariable Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


LineToken Class

LineToken Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Lsp.PowerShellLineToken

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineToken
Public Class LineToken
public ref class LineToken
type LineToken =  class end

The LineToken type exposes the following members.

Constructors
 | Name | Description
Public method | LineToken | Initializes a new instance of the LineToken class
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Length |
Public property | Line |
Public property | Start |
Public property | Style |
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


LineToken Constructor

LineToken Constructor
Initializes a new instance of the LineToken class

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineToken(
    int line,
    int start,
    int len,
    int style
)
Public Sub New (
    line As Integer,
    start As Integer,
    len As Integer,
    style As Integer
)
public:
LineToken(
    int line,
    int start,
    int len,
    int style
)
new :
        line : int *
        start : int *
        len : int *
        style : int -> LineToken

Parameters

line
Type: SystemInt32
start
Type: SystemInt32
len
Type: SystemInt32
style
Type: SystemInt32
See Also

Reference

LineToken Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


LineToken Methods

LineToken Methods

The LineToken type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineToken Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


LineToken.Clone Method

LineTokenClone Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineToken Clone()
Public Function Clone As LineToken
public:
LineToken^ Clone()
member Clone : unit -> LineToken

Return Value

Type: LineToken
See Also

Reference

LineToken Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


LineToken Properties

LineToken Properties

The LineToken type exposes the following members.

Properties
 | Name | Description
Public property | Length |
Public property | Line |
Public property | Start |
Public property | Style |
Top
See Also

Reference

LineToken Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


LineToken.Length Property

LineTokenLength Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set
public:
property int Length {
    int get ();
    void set (int value);
}
member Length : int with get, set

Property Value

Type: Int32
See Also

Reference

LineToken Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


LineToken.Line Property

LineTokenLine Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

LineToken Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


LineToken.Start Property

LineTokenStart Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

Property Value

Type: Int32
See Also

Reference

LineToken Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


LineToken.Style Property

LineTokenStyle Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Style { get; set; }
Public Property Style As Integer
    Get
    Set
public:
property int Style {
    int get ();
    void set (int value);
}
member Style : int with get, set

Property Value

Type: Int32
See Also

Reference

LineToken Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser Class

PowerShellParser Class
Represents class that and perform syntax and lexical analysis of specified PowerShell code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellParser
Alternet.Syntax.Parsers.Lsp.PowerShell.EmbeddedPowerShellParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PowerShellParser : LspParser
Public Class PowerShellParser
    Inherits LspParser
public ref class PowerShellParser : public LspParser
type PowerShellParser =
    class
        inherit LspParser
    end

The PowerShellParser type exposes the following members.

Constructors
 | Name | Description
Public method | PowerShellParser | Initializes a new instance of the PowerShellParser class with default settings.
Public method | PowerShellParser(IContainer) | Initializes a new instance of the PowerShellParser class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Overrides LspParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Overrides SyntaxParserReparseText(Boolean, Int32, Int32).)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Overrides SyntaxParserStopParsing.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Fields
Name | Description
DefaultPowerShellCodeCompletionChars | Represents a default collection of characters that initializes a code completion procedure when typing.
DefaultPowerShellDelimiters | Represents a default collection of delimiter characters.
DefaultPowerShellSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a PowerShellRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser Constructor

PowerShellParser Constructor
Overload List
 | Name | Description
Public method | PowerShellParser | Initializes a new instance of the PowerShellParser class with default settings.
Public method | PowerShellParser(IContainer) | Initializes a new instance of the PowerShellParser class with specified container.
Top
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser Constructor

PowerShellParser Constructor
Initializes a new instance of the PowerShellParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellParser()
Public Sub New
public:
PowerShellParser()
new : unit -> PowerShellParser
See Also

Reference

PowerShellParser Class
PowerShellParser Overload
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser Constructor (IContainer)

PowerShellParser Constructor (IContainer)
Initializes a new instance of the PowerShellParser class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellParser(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
PowerShellParser(
    IContainer^ container
)
new :
        container : IContainer -> PowerShellParser

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

PowerShellParser Class
PowerShellParser Overload
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser Fields

PowerShellParser Fields

The PowerShellParser type exposes the following members.

Fields
Name | Description
DefaultPowerShellCodeCompletionChars | Represents a default collection of characters that initializes a code completion procedure when typing.
DefaultPowerShellDelimiters | Represents a default collection of delimiter characters.
DefaultPowerShellSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.DefaultPowerShellCodeCompletionChars Field

PowerShellParserDefaultPowerShellCodeCompletionChars Field
Represents a default collection of characters that initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultPowerShellCodeCompletionChars
Public Shared DefaultPowerShellCodeCompletionChars As String
public:
static String^ DefaultPowerShellCodeCompletionChars
static val mutable DefaultPowerShellCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.DefaultPowerShellDelimiters Field

PowerShellParserDefaultPowerShellDelimiters Field
Represents a default collection of delimiter characters.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultPowerShellDelimiters
Public Shared DefaultPowerShellDelimiters As String
public:
static String^ DefaultPowerShellDelimiters
static val mutable DefaultPowerShellDelimiters: string

Field Value

Type: String
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.DefaultPowerShellSyntaxOptions Field

PowerShellParserDefaultPowerShellSyntaxOptions Field
Represents default set of flags determining syntax parsing and formatting behavior.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultPowerShellSyntaxOptions
Public Shared DefaultPowerShellSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultPowerShellSyntaxOptions
static val mutable DefaultPowerShellSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser Methods

PowerShellParser Methods

The PowerShellParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Overrides LspParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Overrides SyntaxParserReparseText(Boolean, Int32, Int32).)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Overrides SyntaxParserStopParsing.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.CreateRepository Method

PowerShellParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.FindDeclaration Method

PowerShellParserFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Overrides LspParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Top
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.FindDeclaration Method (Point)

PowerShellParserFindDeclaration Method (Point)
Finds the declaration location at given position.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override SymbolLocation FindDeclaration(
    Point position
)
Public Overrides Function FindDeclaration (
    position As Point
) As SymbolLocation
public:
virtual SymbolLocation^ FindDeclaration(
    Point position
) override
abstract FindDeclaration :
        position : Point -> SymbolLocation
override FindDeclaration :
        position : Point -> SymbolLocation

Parameters

position
Type: System.DrawingPoint
Specifies position to find.

Return Value

Type: SymbolLocation
SymbolLocation represents location of the declaration.

Implements

ISyntaxParserFindDeclaration(Point)
See Also

Reference

PowerShellParser Class
FindDeclaration Overload
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.IsCodeCompletionChar Method

PowerShellParserIsCodeCompletionChar Method
Returns boolean value indicating that given character initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Public Overrides Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
public:
virtual bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
) override
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool
override IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
Given character.
style
Type: SystemByte
Specifies text style at cursor.
interval
Type: SystemInt32
Represents the delay, in milliseconds before displaying code completion window.

Return Value

Type: Boolean
True if given character is code completion character; otherwise false.

Implements

ISyntaxParserIsCodeCompletionChar(Char, Byte, Int32)
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ParseSyntaxAsync Method

PowerShellParserParseSyntaxAsync Method
Performs asynchronous syntax analysis of specified document.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task ParseSyntaxAsync(
    CancellationToken cancellationToken
)
Public Overridable Function ParseSyntaxAsync (
    cancellationToken As CancellationToken
) As Task
public:
virtual Task^ ParseSyntaxAsync(
    CancellationToken cancellationToken
)
abstract ParseSyntaxAsync :
        cancellationToken : CancellationToken -> Task
override ParseSyntaxAsync :
        cancellationToken : CancellationToken -> Task

Parameters

cancellationToken
Type: System.ThreadingCancellationToken
Represents a token handles cancellation operation.

Return Value

Type: Task
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ParseText Method

PowerShellParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

PowerShellParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

PowerShellParser Class
ParseText Overload
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.PositionChanged Method

PowerShellParserPositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overrides Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
) override
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxParserPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ReparseText Method

PowerShellParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Overrides SyntaxParserReparseText(Boolean, Int32, Int32).)
Top
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ReparseText Method

PowerShellParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

PowerShellParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ReparseText Method (Boolean, Int32, Int32)

PowerShellParserReparseText Method (Boolean, Int32, Int32)
Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText(
    bool useThread,
    int first,
    int last
)
Public Overrides Sub ReparseText (
    useThread As Boolean,
    first As Integer,
    last As Integer
)
public:
virtual void ReparseText(
    bool useThread,
    int first,
    int last
) override
abstract ReparseText :
        useThread : bool *
        first : int *
        last : int -> unit
override ReparseText :
        useThread : bool *
        first : int *
        last : int -> unit

Parameters

useThread
Type: SystemBoolean
first
Type: SystemInt32
last
Type: SystemInt32

Implements

ISyntaxParserReparseText(Boolean, Int32, Int32)
See Also

Reference

PowerShellParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ResetCodeCompletionChars Method

PowerShellParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ResetOptions Method

PowerShellParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ShouldSerializeCodeCompletionChars Method

PowerShellParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.ShouldSerializeOptions Method

PowerShellParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.StopParsing Method

PowerShellParserStopParsing Method
Aborts parsing process.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void StopParsing()
Public Overrides Sub StopParsing
public:
virtual void StopParsing() override
abstract StopParsing : unit -> unit
override StopParsing : unit -> unit

Implements

ISyntaxParserStopParsing
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser Properties

PowerShellParser Properties

The PowerShellParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a PowerShellRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.CaseSensitive Property

PowerShellParserCaseSensitive Property
Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.Repository Property

PowerShellParserRepository Property
Gets a PowerShellRepository that holds methods for code completion purposes.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellRepository Repository { get; }
Public ReadOnly Property Repository As PowerShellRepository
    Get
public:
property PowerShellRepository^ Repository {
    PowerShellRepository^ get ();
}
member Repository : PowerShellRepository with get

Property Value

Type: PowerShellRepository
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser.Workspace Property

PowerShellParserWorkspace Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellWorkspace Workspace { get; }
Public ReadOnly Property Workspace As PowerShellWorkspace
    Get
public:
property PowerShellWorkspace^ Workspace {
    PowerShellWorkspace^ get ();
}
member Workspace : PowerShellWorkspace with get

Property Value

Type: PowerShellWorkspace
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellParser Events

PowerShellParser Events

The PowerShellParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

PowerShellParser Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellRepository Class

PowerShellRepository Class
Represents properties and methods to perform code completion functionality for PowerShell language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.LspLspRepository
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellRepository

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PowerShellRepository : LspRepository
Public Class PowerShellRepository
    Inherits LspRepository
public ref class PowerShellRepository : public LspRepository
type PowerShellRepository =
    class
        inherit LspRepository
    end

The PowerShellRepository type exposes the following members.

Constructors
 | Name | Description
Public method | PowerShellRepository | Initializes a new instance of the PowerShellRepository class with specified parameters.
Top
Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Overrides CodeCompletionRepositoryGetCodeSnippets(String).)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCollapsible | Indicates whether specified statement can be outlined.
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellRepository Constructor

PowerShellRepository Constructor
Initializes a new instance of the PowerShellRepository class with specified parameters.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellRepository(
    ILspDocumentProvider documentProvider,
    ISyntaxTree syntaxTree
)
Public Sub New (
    documentProvider As ILspDocumentProvider,
    syntaxTree As ISyntaxTree
)
public:
PowerShellRepository(
    ILspDocumentProvider^ documentProvider,
    ISyntaxTree^ syntaxTree
)
new :
        documentProvider : ILspDocumentProvider *
        syntaxTree : ISyntaxTree -> PowerShellRepository

Parameters

documentProvider
Type: Alternet.Syntax.Parsers.LspILspDocumentProvider
ILspDocumentProvider for this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
ISyntaxTree for this new instance.
See Also

Reference

PowerShellRepository Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellRepository Methods

PowerShellRepository Methods

The PowerShellRepository type exposes the following members.

Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Overrides CodeCompletionRepositoryGetCodeSnippets(String).)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCollapsible | Indicates whether specified statement can be outlined.
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PowerShellRepository Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellRepository.GetCodeSnippets Method

PowerShellRepositoryGetCodeSnippets Method
Returns code snippets for the given language.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeSnippetsProvider GetCodeSnippets(
    string language
)
Public Overrides Function GetCodeSnippets (
    language As String
) As ICodeSnippetsProvider
public:
virtual ICodeSnippetsProvider^ GetCodeSnippets(
    String^ language
) override
abstract GetCodeSnippets :
        language : string -> ICodeSnippetsProvider
override GetCodeSnippets :
        language : string -> ICodeSnippetsProvider

Parameters

language
Type: SystemString
Represents a language.

Return Value

Type: ICodeSnippetsProvider
ICodeSnippetsProvider instance for a given language.

Implements

ICodeCompletionRepositoryGetCodeSnippets(String)
See Also

Reference

PowerShellRepository Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellRepository.IsCollapsible Method

PowerShellRepositoryIsCollapsible Method
Indicates whether specified statement can be outlined.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsCollapsible(
    StatementAst statement,
    out string outlineText
)
Public Overridable Function IsCollapsible (
    statement As StatementAst,
    <OutAttribute> ByRef outlineText As String
) As Boolean
public:
virtual bool IsCollapsible(
    StatementAst^ statement,
    [OutAttribute] String^% outlineText
)
abstract IsCollapsible :
        statement : StatementAst *
        outlineText : string byref -> bool
override IsCollapsible :
        statement : StatementAst *
        outlineText : string byref -> bool

Parameters

statement
Type: StatementAst
StatementAst to check.
outlineText
Type: SystemString
Output parameter receives text substituting collapsed outline section.

Return Value

Type: Boolean
True if statement can be outlined; otherwise false.
See Also

Reference

PowerShellRepository Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellRepository Properties

PowerShellRepository Properties

The PowerShellRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PowerShellRepository Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellRepository Events

PowerShellRepository Events

The PowerShellRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PowerShellRepository Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellServerLocator Class

PowerShellServerLocator Class
Finds location of the language server executable.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellServerLocator
Alternet.Syntax.Parsers.Lsp.PowerShell.EmbeddedPowerShellServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PowerShellServerLocator : ServerLocator
Public Class PowerShellServerLocator
    Inherits ServerLocator
public ref class PowerShellServerLocator : public ServerLocator
type PowerShellServerLocator =
    class
        inherit ServerLocator
    end

The PowerShellServerLocator type exposes the following members.

Constructors
 | Name | Description
Public method | PowerShellServerLocator | Initializes a new instance of the PowerShellServerLocator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellServerLocator Constructor

PowerShellServerLocator Constructor
Initializes a new instance of the PowerShellServerLocator class

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellServerLocator()
Public Sub New
public:
PowerShellServerLocator()
new : unit -> PowerShellServerLocator
See Also

Reference

PowerShellServerLocator Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellServerLocator Methods

PowerShellServerLocator Methods

The PowerShellServerLocator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PowerShellServerLocator Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer Class

PowerShellTokenizer Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellTokenizer

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PowerShellTokenizer : IUpdate
Public Class PowerShellTokenizer
    Implements IUpdate
public ref class PowerShellTokenizer : IUpdate
type PowerShellTokenizer =
    class
        interface IUpdate
    end

The PowerShellTokenizer type exposes the following members.

Constructors
 | Name | Description
Public method | PowerShellTokenizer | Initializes a new instance of the PowerShellTokenizer class
Top
Methods
 | Name | Description
Public method | BeginUpdate |
Public method | DisableUpdate |
Public method | EnableUpdate |
Public method | EndUpdate |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTokens |
Public method | GetTokensAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ParseText |
Public method | PositionChanged |
Public method | ReparseSyntax |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update |
Top
Properties
 | Name | Description
Public property | Initialized |
Public property | Symbols |
Public property | Tokens |
Public property | UpdateCount |
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer Constructor

PowerShellTokenizer Constructor
Initializes a new instance of the PowerShellTokenizer class

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellTokenizer(
    SyntaxParser parser
)
Public Sub New (
    parser As SyntaxParser
)
public:
PowerShellTokenizer(
    SyntaxParser^ parser
)
new :
        parser : SyntaxParser -> PowerShellTokenizer

Parameters

parser
Type: Alternet.SyntaxSyntaxParser
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer Methods

PowerShellTokenizer Methods

The PowerShellTokenizer type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdate |
Public method | DisableUpdate |
Public method | EnableUpdate |
Public method | EndUpdate |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTokens |
Public method | GetTokensAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ParseText |
Public method | PositionChanged |
Public method | ReparseSyntax |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update |
Top
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.BeginUpdate Method

PowerShellTokenizerBeginUpdate Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BeginUpdate()
Public Function BeginUpdate As Integer
public:
virtual int BeginUpdate() sealed
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateBeginUpdate
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.DisableUpdate Method

PowerShellTokenizerDisableUpdate Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DisableUpdate()
Public Function DisableUpdate As Integer
public:
virtual int DisableUpdate() sealed
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateDisableUpdate
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.EnableUpdate Method

PowerShellTokenizerEnableUpdate Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EnableUpdate()
Public Function EnableUpdate As Integer
public:
virtual int EnableUpdate() sealed
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateEnableUpdate
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.EndUpdate Method

PowerShellTokenizerEndUpdate Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndUpdate()
Public Function EndUpdate As Integer
public:
virtual int EndUpdate() sealed
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32

Implements

IUpdateEndUpdate
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.GetTokens Method

PowerShellTokenizerGetTokens Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual TokenList GetTokens(
    ScriptBlockAst block,
    Token[] parseTokens
)
Public Overridable Function GetTokens (
    block As ScriptBlockAst,
    parseTokens As Token()
) As TokenList
public:
virtual TokenList^ GetTokens(
    ScriptBlockAst^ block,
    array<Token^>^ parseTokens
)
abstract GetTokens :
        block : ScriptBlockAst *
        parseTokens : Token[] -> TokenList
override GetTokens :
        block : ScriptBlockAst *
        parseTokens : Token[] -> TokenList

Parameters

block
Type: ScriptBlockAst
parseTokens
Type: Token

Return Value

Type: TokenList
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.GetTokensAsync Method

PowerShellTokenizerGetTokensAsync Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<TokenList> GetTokensAsync(
    ScriptBlockAst block,
    Token[] parseTokens,
    CancellationToken cancellationToken
)
Public Overridable Function GetTokensAsync (
    block As ScriptBlockAst,
    parseTokens As Token(),
    cancellationToken As CancellationToken
) As Task(Of TokenList)
public:
virtual Task<TokenList^>^ GetTokensAsync(
    ScriptBlockAst^ block,
    array<Token^>^ parseTokens,
    CancellationToken cancellationToken
)
abstract GetTokensAsync :
        block : ScriptBlockAst *
        parseTokens : Token[] *
        cancellationToken : CancellationToken -> Task<TokenList>
override GetTokensAsync :
        block : ScriptBlockAst *
        parseTokens : Token[] *
        cancellationToken : CancellationToken -> Task<TokenList>

Parameters

block
Type: ScriptBlockAst
parseTokens
Type: Token
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: TaskTokenList
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.ParseText Method

PowerShellTokenizerParseText Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ParseText(
    int line,
    ref StringItemInfo[] colorData
)
Public Sub ParseText (
    line As Integer,
    ByRef colorData As StringItemInfo()
)
public:
void ParseText(
    int line,
    array<StringItemInfo>^% colorData
)
member ParseText :
        line : int *
        colorData : StringItemInfo[] byref -> unit

Parameters

line
Type: SystemInt32
colorData
Type: Alternet.SyntaxStringItemInfo
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.PositionChanged Method

PowerShellTokenizerPositionChanged Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    char ch
)
Public Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ch As Char
)
public:
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    wchar_t ch
)
member PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaX
Type: SystemInt32
deltaY
Type: SystemInt32
ch
Type: SystemChar
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.ReparseSyntax Method

PowerShellTokenizerReparseSyntax Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReparseSyntax(
    string text
)
Public Sub ReparseSyntax (
    text As String
)
public:
void ReparseSyntax(
    String^ text
)
member ReparseSyntax :
        text : string -> unit

Parameters

text
Type: SystemString
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.Update Method

PowerShellTokenizerUpdate Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
virtual void Update() sealed
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer Properties

PowerShellTokenizer Properties

The PowerShellTokenizer type exposes the following members.

Properties
 | Name | Description
Public property | Initialized |
Public property | Symbols |
Public property | Tokens |
Public property | UpdateCount |
Top
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.Initialized Property

PowerShellTokenizerInitialized Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Initialized { get; }
Public ReadOnly Property Initialized As Boolean
    Get
public:
property bool Initialized {
    bool get ();
}
member Initialized : bool with get

Property Value

Type: Boolean
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.Symbols Property

PowerShellTokenizerSymbols Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual TokenList Symbols { get; set; }
Public Overridable Property Symbols As TokenList
    Get
    Set
public:
virtual property TokenList^ Symbols {
    TokenList^ get ();
    void set (TokenList^ value);
}
abstract Symbols : TokenList with get, set
override Symbols : TokenList with get, set

Property Value

Type: TokenList
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.Tokens Property

PowerShellTokenizerTokens Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual TokenList Tokens { get; set; }
Public Overridable Property Tokens As TokenList
    Get
    Set
public:
virtual property TokenList^ Tokens {
    TokenList^ get ();
    void set (TokenList^ value);
}
abstract Tokens : TokenList with get, set
override Tokens : TokenList with get, set

Property Value

Type: TokenList
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellTokenizer.UpdateCount Property

PowerShellTokenizerUpdateCount Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UpdateCount { get; }
Public ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get () sealed;
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

PowerShellTokenizer Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace Class

PowerShellWorkspace Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellWorkspace
Alternet.Syntax.Parsers.Lsp.PowerShell.EmbeddedPowerShellWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PowerShellWorkspace : LspWorkspace
Public Class PowerShellWorkspace
    Inherits LspWorkspace
public ref class PowerShellWorkspace : public LspWorkspace
type PowerShellWorkspace =
    class
        inherit LspWorkspace
    end

The PowerShellWorkspace type exposes the following members.

Constructors
 | Name | Description
Public method | PowerShellWorkspace | Initializes a new instance of the PowerShellWorkspace class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RegisterAssemblies | Registers assemblies in the project.
Public method | RegisterAssembly | Registers assembly in the project.
Public method | ResolveAssemblyName | Try to find real assembly name matches the given name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project.
Public method | UnregisterAssembly | Unregisters assembly from the project.
Top
Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths.
Public property | BaseDirectory | Gets or sets a base directory for referenced assemblies search.
Public property | ExternalVariables |
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace Constructor

PowerShellWorkspace Constructor
Initializes a new instance of the PowerShellWorkspace class

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellWorkspace()
Public Sub New
public:
PowerShellWorkspace()
new : unit -> PowerShellWorkspace
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace Methods

PowerShellWorkspace Methods

The PowerShellWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RegisterAssemblies | Registers assemblies in the project.
Public method | RegisterAssembly | Registers assembly in the project.
Public method | ResolveAssemblyName | Try to find real assembly name matches the given name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project.
Public method | UnregisterAssembly | Unregisters assembly from the project.
Top
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace.RegisterAssemblies Method

PowerShellWorkspaceRegisterAssemblies Method
Registers assemblies in the project.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterAssemblies(
    string[] assemblies
)
Public Overridable Sub RegisterAssemblies (
    assemblies As String()
)
public:
virtual void RegisterAssemblies(
    array<String^>^ assemblies
)
abstract RegisterAssemblies :
        assemblies : string[] -> unit
override RegisterAssemblies :
        assemblies : string[] -> unit

Parameters

assemblies
Type: SystemString
Assembly names.
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace.RegisterAssembly Method

PowerShellWorkspaceRegisterAssembly Method
Registers assembly in the project.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterAssembly(
    string name
)
Public Overridable Sub RegisterAssembly (
    name As String
)
public:
virtual void RegisterAssembly(
    String^ name
)
abstract RegisterAssembly :
        name : string -> unit
override RegisterAssembly :
        name : string -> unit

Parameters

name
Type: SystemString
Assembly name.

Return Value

Type:
True if assembly has been registered, otherwise false.
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace.ResolveAssemblyName Method

PowerShellWorkspaceResolveAssemblyName Method
Try to find real assembly name matches the given name.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ResolveAssemblyName(
    string name
)
Public Overridable Function ResolveAssemblyName (
    name As String
) As String
public:
virtual String^ ResolveAssemblyName(
    String^ name
)
abstract ResolveAssemblyName :
        name : string -> string
override ResolveAssemblyName :
        name : string -> string

Parameters

name
Type: SystemString
Short assembly name.

Return Value

Type: String
Full assembly name if succeed; otherwise empty string.
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace.UnregisterAssemblies Method

PowerShellWorkspaceUnregisterAssemblies Method
Unregisters assemblies from the project.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnregisterAssemblies(
    string[] assemblies
)
Public Sub UnregisterAssemblies (
    assemblies As String()
)
public:
void UnregisterAssemblies(
    array<String^>^ assemblies
)
member UnregisterAssemblies :
        assemblies : string[] -> unit

Parameters

assemblies
Type: SystemString
Assembly names.
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace.UnregisterAssembly Method

PowerShellWorkspaceUnregisterAssembly Method
Unregisters assembly from the project.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnregisterAssembly(
    string name
)
Public Sub UnregisterAssembly (
    name As String
)
public:
void UnregisterAssembly(
    String^ name
)
member UnregisterAssembly :
        name : string -> unit

Parameters

name
Type: SystemString
Assembly name.

Return Value

Type:
True if assembly has been unregistered, otherwise false.
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace Properties

PowerShellWorkspace Properties

The PowerShellWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths.
Public property | BaseDirectory | Gets or sets a base directory for referenced assemblies search.
Public property | ExternalVariables |
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace.AssemblySearchPaths Property

PowerShellWorkspaceAssemblySearchPaths Property
Gets or sets a collection of assembly search paths.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string[] AssemblySearchPaths { get; set; }
Public Overridable Property AssemblySearchPaths As String()
    Get
    Set
public:
virtual property array<String^>^ AssemblySearchPaths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract AssemblySearchPaths : string[] with get, set
override AssemblySearchPaths : string[] with get, set

Property Value

Type: String
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace.BaseDirectory Property

PowerShellWorkspaceBaseDirectory Property
Gets or sets a base directory for referenced assemblies search.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BaseDirectory { get; set; }
Public Property BaseDirectory As String
    Get
    Set
public:
property String^ BaseDirectory {
    String^ get ();
    void set (String^ value);
}
member BaseDirectory : string with get, set

Property Value

Type: String
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


PowerShellWorkspace.ExternalVariables Property

PowerShellWorkspaceExternalVariables Property

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyList<ExternalVariable> ExternalVariables { get; set; }
Public Property ExternalVariables As IReadOnlyList(Of ExternalVariable)
    Get
    Set
public:
property IReadOnlyList<ExternalVariable^>^ ExternalVariables {
    IReadOnlyList<ExternalVariable^>^ get ();
    void set (IReadOnlyList<ExternalVariable^>^ value);
}
member ExternalVariables : IReadOnlyList<ExternalVariable> with get, set

Property Value

Type: IReadOnlyListExternalVariable
See Also

Reference

PowerShellWorkspace Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


TokenList Class

TokenList Class
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIListLineToken
Alternet.Syntax.Parsers.Lsp.PowerShellTokenList

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TokenList : List<IList<LineToken>>
Public Class TokenList
    Inherits List(Of IList(Of LineToken))
public ref class TokenList : public List<IList<LineToken^>^>
type TokenList =
    class
        inherit List<IList<LineToken>>
    end

The TokenList type exposes the following members.

Constructors
 | Name | Description
Public method | TokenList | Initializes a new instance of the TokenList class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIListLineToken .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIListLineToken .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIListLineToken .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIListLineToken .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListLineToken .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListLineToken .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIListLineToken .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIListLineToken .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIListLineToken .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIListLineToken .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListLineToken .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListLineToken .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIListLineToken .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListLineToken .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListLineToken .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListLineToken .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListLineToken .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListLineToken .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIListLineToken .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIListLineToken .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIListLineToken .)
Public method | GetTokens |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListLineToken .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListLineToken .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIListLineToken .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIListLineToken .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListLineToken .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListLineToken .)
Public method | PositionChanged |
Public method | PositionChangedX |
Public method | PositionChangedY |
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIListLineToken .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListLineToken .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIListLineToken .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIListLineToken .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIListLineToken .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIListLineToken .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIListLineToken .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIListLineToken .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIListLineToken .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIListLineToken .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIListLineToken .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIListLineToken .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIListLineToken .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIListLineToken .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIListLineToken .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIListLineToken .)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


TokenList Constructor

TokenList Constructor
Initializes a new instance of the TokenList class

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TokenList(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
TokenList(
    int capacity
)
new :
        capacity : int -> TokenList

Parameters

capacity
Type: SystemInt32
See Also

Reference

TokenList Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


TokenList Methods

TokenList Methods

The TokenList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIListLineToken .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIListLineToken .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIListLineToken .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIListLineToken .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListLineToken .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListLineToken .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIListLineToken .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIListLineToken .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIListLineToken .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIListLineToken .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListLineToken .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListLineToken .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIListLineToken .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListLineToken .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListLineToken .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListLineToken .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListLineToken .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListLineToken .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIListLineToken .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIListLineToken .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIListLineToken .)
Public method | GetTokens |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListLineToken .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListLineToken .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIListLineToken .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIListLineToken .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListLineToken .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListLineToken .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListLineToken .)
Public method | PositionChanged |
Public method | PositionChangedX |
Public method | PositionChangedY |
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIListLineToken .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListLineToken .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIListLineToken .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIListLineToken .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIListLineToken .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIListLineToken .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIListLineToken .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIListLineToken .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIListLineToken .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIListLineToken .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIListLineToken .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIListLineToken .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIListLineToken .)
Top
See Also

Reference

TokenList Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


TokenList.GetTokens Method

TokenListGetTokens Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<LineToken> GetTokens(
    int index,
    bool add
)
Public Function GetTokens (
    index As Integer,
    add As Boolean
) As IList(Of LineToken)
public:
IList<LineToken^>^ GetTokens(
    int index,
    bool add
)
member GetTokens :
        index : int *
        add : bool -> IList<LineToken>

Parameters

index
Type: SystemInt32
add
Type: SystemBoolean

Return Value

Type: IListLineToken
See Also

Reference

TokenList Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


TokenList.PositionChanged Method

TokenListPositionChanged Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    char ch
)
Public Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ch As Char
)
public:
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    wchar_t ch
)
member PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaX
Type: SystemInt32
deltaY
Type: SystemInt32
ch
Type: SystemChar
See Also

Reference

TokenList Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


TokenList.PositionChangedX Method

TokenListPositionChangedX Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChangedX(
    int x,
    int y,
    int deltaX,
    char ch
)
Public Sub PositionChangedX (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    ch As Char
)
public:
void PositionChangedX(
    int x,
    int y,
    int deltaX,
    wchar_t ch
)
member PositionChangedX :
        x : int *
        y : int *
        deltaX : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaX
Type: SystemInt32
ch
Type: SystemChar
See Also

Reference

TokenList Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


TokenList.PositionChangedY Method

TokenListPositionChangedY Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell
Assembly: Alternet.Syntax.Parsers.PowerShell.v7 (in Alternet.Syntax.Parsers.PowerShell.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChangedY(
    int x,
    int y,
    int deltaY
)
Public Sub PositionChangedY (
    x As Integer,
    y As Integer,
    deltaY As Integer
)
public:
void PositionChangedY(
    int x,
    int y,
    int deltaY
)
member PositionChangedY :
        x : int *
        y : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaY
Type: SystemInt32
See Also

Reference

TokenList Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


TokenList Properties

TokenList Properties

The TokenList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIListLineToken .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIListLineToken .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIListLineToken .)
Top
See Also

Reference

TokenList Class
Alternet.Syntax.Parsers.Lsp.PowerShell Namespace


Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace

Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace
Classes
 | Class | Description
Public class | PowerShellParserEmbedded | Represents class that and perform syntax and lexical analysis of specified PowerShell code text.
Public class | PowerShellServerLocatorEmbedded |
Public class | PowerShellWorkspaceEmbedded |


PowerShellParserEmbedded Class

PowerShellParserEmbedded Class
Represents class that and perform syntax and lexical analysis of specified PowerShell code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellParser
Alternet.Syntax.Parsers.Lsp.PowerShell.EmbeddedPowerShellParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded
Assembly: Alternet.Syntax.Parsers.PowerShell.Embedded.v7 (in Alternet.Syntax.Parsers.PowerShell.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PowerShellParserEmbedded : PowerShellParser
Public Class PowerShellParserEmbedded
    Inherits PowerShellParser
public ref class PowerShellParserEmbedded : public PowerShellParser
type PowerShellParserEmbedded =
    class
        inherit PowerShellParser
    end

The PowerShellParserEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | PowerShellParserEmbedded | Initializes a new instance of the PowerShellParserEmbedded class with default settings.
Public method | PowerShellParserEmbedded(IContainer) | Initializes a new instance of the PowerShellParserEmbedded class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from PowerShellParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from PowerShellParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from PowerShellParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from PowerShellParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from PowerShellParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from PowerShellParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from PowerShellParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from PowerShellParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from PowerShellParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from PowerShellParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from PowerShellParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from PowerShellParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from PowerShellParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from PowerShellParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a PowerShellRepository that holds methods for code completion purposes. (Inherited from PowerShellParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from PowerShellParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellParserEmbedded Constructor

PowerShellParserEmbedded Constructor
Overload List
 | Name | Description
Public method | PowerShellParserEmbedded | Initializes a new instance of the PowerShellParserEmbedded class with default settings.
Public method | PowerShellParserEmbedded(IContainer) | Initializes a new instance of the PowerShellParserEmbedded class with specified container.
Top
See Also

Reference

PowerShellParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellParserEmbedded Constructor

PowerShellParserEmbedded Constructor
Initializes a new instance of the PowerShellParserEmbedded class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded
Assembly: Alternet.Syntax.Parsers.PowerShell.Embedded.v7 (in Alternet.Syntax.Parsers.PowerShell.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellParserEmbedded()
Public Sub New
public:
PowerShellParserEmbedded()
new : unit -> PowerShellParserEmbedded
See Also

Reference

PowerShellParserEmbedded Class
PowerShellParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellParserEmbedded Constructor (IContainer)

PowerShellParserEmbedded Constructor (IContainer)
Initializes a new instance of the PowerShellParserEmbedded class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded
Assembly: Alternet.Syntax.Parsers.PowerShell.Embedded.v7 (in Alternet.Syntax.Parsers.PowerShell.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellParserEmbedded(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
PowerShellParserEmbedded(
    IContainer^ container
)
new :
        container : IContainer -> PowerShellParserEmbedded

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

PowerShellParserEmbedded Class
PowerShellParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellParserEmbedded Methods

PowerShellParserEmbedded Methods

The PowerShellParserEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from PowerShellParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from PowerShellParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from PowerShellParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from PowerShellParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from PowerShellParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from PowerShellParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from PowerShellParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from PowerShellParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from PowerShellParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from PowerShellParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from PowerShellParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from PowerShellParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from PowerShellParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

PowerShellParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellParserEmbedded.DeployServer Method

PowerShellParserEmbeddedDeployServer Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded
Assembly: Alternet.Syntax.Parsers.PowerShell.Embedded.v7 (in Alternet.Syntax.Parsers.PowerShell.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DeployServer(
    IProgress<double> progress,
    string targetDirectory = null
)
Public Shared Sub DeployServer (
    progress As IProgress(Of Double),
    Optional targetDirectory As String = Nothing
)
public:
static void DeployServer(
    IProgress<double>^ progress,
    String^ targetDirectory = nullptr
)
static member DeployServer :
        progress : IProgress<float> *
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> unit

Parameters

progress
Type: SystemIProgressDouble
targetDirectory (Optional)
Type: SystemString
See Also

Reference

PowerShellParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellParserEmbedded.IsServerDeployed Method

PowerShellParserEmbeddedIsServerDeployed Method

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded
Assembly: Alternet.Syntax.Parsers.PowerShell.Embedded.v7 (in Alternet.Syntax.Parsers.PowerShell.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsServerDeployed(
    string targetDirectory = null
)
Public Shared Function IsServerDeployed (
    Optional targetDirectory As String = Nothing
) As Boolean
public:
static bool IsServerDeployed(
    String^ targetDirectory = nullptr
)
static member IsServerDeployed :
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> bool

Parameters

targetDirectory (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

PowerShellParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellParserEmbedded Properties

PowerShellParserEmbedded Properties

The PowerShellParserEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from PowerShellParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a PowerShellRepository that holds methods for code completion purposes. (Inherited from PowerShellParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from PowerShellParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

PowerShellParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellParserEmbedded Events

PowerShellParserEmbedded Events

The PowerShellParserEmbedded type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

PowerShellParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellServerLocatorEmbedded Class

PowerShellServerLocatorEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellServerLocator
Alternet.Syntax.Parsers.Lsp.PowerShell.EmbeddedPowerShellServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded
Assembly: Alternet.Syntax.Parsers.PowerShell.Embedded.v7 (in Alternet.Syntax.Parsers.PowerShell.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PowerShellServerLocatorEmbedded : PowerShellServerLocator
Public Class PowerShellServerLocatorEmbedded
    Inherits PowerShellServerLocator
public ref class PowerShellServerLocatorEmbedded : public PowerShellServerLocator
type PowerShellServerLocatorEmbedded =
    class
        inherit PowerShellServerLocator
    end

The PowerShellServerLocatorEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | PowerShellServerLocatorEmbedded | Initializes a new instance of the PowerShellServerLocatorEmbedded class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellServerLocatorEmbedded Constructor

PowerShellServerLocatorEmbedded Constructor
Initializes a new instance of the PowerShellServerLocatorEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded
Assembly: Alternet.Syntax.Parsers.PowerShell.Embedded.v7 (in Alternet.Syntax.Parsers.PowerShell.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellServerLocatorEmbedded()
Public Sub New
public:
PowerShellServerLocatorEmbedded()
new : unit -> PowerShellServerLocatorEmbedded
See Also

Reference

PowerShellServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellServerLocatorEmbedded Methods

PowerShellServerLocatorEmbedded Methods

The PowerShellServerLocatorEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PowerShellServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellWorkspaceEmbedded Class

PowerShellWorkspaceEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.PowerShellPowerShellWorkspace
Alternet.Syntax.Parsers.Lsp.PowerShell.EmbeddedPowerShellWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded
Assembly: Alternet.Syntax.Parsers.PowerShell.Embedded.v7 (in Alternet.Syntax.Parsers.PowerShell.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PowerShellWorkspaceEmbedded : PowerShellWorkspace
Public Class PowerShellWorkspaceEmbedded
    Inherits PowerShellWorkspace
public ref class PowerShellWorkspaceEmbedded : public PowerShellWorkspace
type PowerShellWorkspaceEmbedded =
    class
        inherit PowerShellWorkspace
    end

The PowerShellWorkspaceEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | PowerShellWorkspaceEmbedded | Initializes a new instance of the PowerShellWorkspaceEmbedded class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RegisterAssemblies | Registers assemblies in the project. (Inherited from PowerShellWorkspace.)
Public method | RegisterAssembly | Registers assembly in the project. (Inherited from PowerShellWorkspace.)
Public method | ResolveAssemblyName | Try to find real assembly name matches the given name. (Inherited from PowerShellWorkspace.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project. (Inherited from PowerShellWorkspace.)
Public method | UnregisterAssembly | Unregisters assembly from the project. (Inherited from PowerShellWorkspace.)
Top
Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths. (Inherited from PowerShellWorkspace.)
Public property | BaseDirectory | Gets or sets a base directory for referenced assemblies search. (Inherited from PowerShellWorkspace.)
Public property | ExternalVariables | (Inherited from PowerShellWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellWorkspaceEmbedded Constructor

PowerShellWorkspaceEmbedded Constructor
Initializes a new instance of the PowerShellWorkspaceEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded
Assembly: Alternet.Syntax.Parsers.PowerShell.Embedded.v7 (in Alternet.Syntax.Parsers.PowerShell.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PowerShellWorkspaceEmbedded()
Public Sub New
public:
PowerShellWorkspaceEmbedded()
new : unit -> PowerShellWorkspaceEmbedded
See Also

Reference

PowerShellWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellWorkspaceEmbedded Methods

PowerShellWorkspaceEmbedded Methods

The PowerShellWorkspaceEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RegisterAssemblies | Registers assemblies in the project. (Inherited from PowerShellWorkspace.)
Public method | RegisterAssembly | Registers assembly in the project. (Inherited from PowerShellWorkspace.)
Public method | ResolveAssemblyName | Try to find real assembly name matches the given name. (Inherited from PowerShellWorkspace.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project. (Inherited from PowerShellWorkspace.)
Public method | UnregisterAssembly | Unregisters assembly from the project. (Inherited from PowerShellWorkspace.)
Top
See Also

Reference

PowerShellWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


PowerShellWorkspaceEmbedded Properties

PowerShellWorkspaceEmbedded Properties

The PowerShellWorkspaceEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths. (Inherited from PowerShellWorkspace.)
Public property | BaseDirectory | Gets or sets a base directory for referenced assemblies search. (Inherited from PowerShellWorkspace.)
Public property | ExternalVariables | (Inherited from PowerShellWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

PowerShellWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.PowerShell.Embedded Namespace


Alternet.Syntax.Parsers.Lsp.Python Namespace

Alternet.Syntax.Parsers.Lsp.Python Namespace
Classes
 | Class | Description
Public class | PythonParser | Represents class that and perform syntax and lexical analysis of specified Python code text.
Public class | PythonRepository | Represents properties and methods to perform code completion functionality for Python language.
Public class | PythonServerLocator | Finds location of the language server executable.
Public class | PythonWorkspace |
Enumerations
 | Enumeration | Description
Public enumeration | PythonLexerToken | Represents lexical tokens for Python parser.


PythonLexerToken Enumeration

PythonLexerToken Enumeration
Represents lexical tokens for Python parser.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PythonLexerToken
Public Enumeration PythonLexerToken
public enum class PythonLexerToken
type PythonLexerToken
Members
Member name | Value | Description
And | 0 |
As | 1 |
Assert | 2 |
Async | 3 |
Await | 4 |
Break | 5 |
Class | 6 |
Continue | 7 |
Def | 8 |
Del | 9 |
Elif | 10 |
Else | 11 |
Except | 12 |
Exec | 13 |
False | 14 |
Finally | 15 |
For | 16 |
From | 17 |
Global | 18 |
If | 19 |
Import | 20 |
In | 21 |
Is | 22 |
Lambda | 23 |
None | 24 |
Nonlocal | 25 |
Not | 26 |
Or | 27 |
Pass | 28 |
Raise | 29 |
Return | 30 |
True | 31 |
Try | 32 |
While | 33 |
With | 34 |
Yield | 35 |
Open_brace | 36 |
Close_brace | 37 |
Open_bracket | 38 |
Close_bracket | 39 |
Open_parens | 40 |
Close_parens | 41 |
Ellipsis | 42 |
Dot | 43 |
Comma | 44 |
Colon | 45 |
Semicolon | 46 |
Tilde | 47 |
Cav | 48 |
Decorator | 49 |
Plus | 50 |
Minus | 51 |
Bang | 52 |
Assign | 53 |
Op_lt | 54 |
Op_gt | 55 |
Bitwise_and | 56 |
Bitwise_or | 57 |
Star | 58 |
DblStar | 59 |
Percent | 60 |
Div | 61 |
DblDiv | 62 |
Carret | 63 |
Dollar | 64 |
IntDiv | 65 |
Interr | 66 |
LineContinuation | 67 |
Op_shift_left | 68 |
Op_shift_right | 69 |
Op_le | 70 |
Op_ge | 71 |
Op_eq | 72 |
Op_ne | 73 |
Dbl_mult_assign | 74 |
Op_mult_assign | 75 |
Dbl_div_assign | 76 |
Op_div_assign | 77 |
Op_mod_assign | 78 |
Op_add_assign | 79 |
Op_sub_assign | 80 |
Op_shift_left_assign | 81 |
Op_shift_right_assign | 82 |
Op_and_assign | 83 |
Op_xor_assign | 84 |
Op_or_assign | 85 |
Integer_Literal | 86 |
Float_Literal | 87 |
Double_Literal | 88 |
Imag_Literal | 89 |
Character_Literal | 90 |
String_Literal | 91 |
Byte_Literal | 92 |
Identifier_Literal | 93 |
Comment_Literal | 94 |
Whitespace_Literal | 95 |
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser Class

PythonParser Class
Represents class that and perform syntax and lexical analysis of specified Python code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.PythonPythonParser
Alternet.Syntax.Parsers.Lsp.Python.EmbeddedPythonParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonParser : LspParser
Public Class PythonParser
    Inherits LspParser
public ref class PythonParser : public LspParser
type PythonParser =
    class
        inherit LspParser
    end

The PythonParser type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParser | Initializes a new instance of the PythonParser class with default settings.
Public method | PythonParser(IContainer) | Initializes a new instance of the PythonParser class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Fields
Name | Description
CodeStyleWarningCodes |
DefaultPythonSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CodeStyleWarningsEnabled | Gets or sets a boolean value which indicates is code style warnings are enabled.
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Overrides LspParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser Constructor

PythonParser Constructor
Overload List
 | Name | Description
Public method | PythonParser | Initializes a new instance of the PythonParser class with default settings.
Public method | PythonParser(IContainer) | Initializes a new instance of the PythonParser class with specified container.
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser Constructor

PythonParser Constructor
Initializes a new instance of the PythonParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonParser()
Public Sub New
public:
PythonParser()
new : unit -> PythonParser
See Also

Reference

PythonParser Class
PythonParser Overload
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser Constructor (IContainer)

PythonParser Constructor (IContainer)
Initializes a new instance of the PythonParser class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonParser(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
PythonParser(
    IContainer^ container
)
new :
        container : IContainer -> PythonParser

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

PythonParser Class
PythonParser Overload
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser Fields

PythonParser Fields

The PythonParser type exposes the following members.

Fields
Name | Description
CodeStyleWarningCodes |
DefaultPythonSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.CodeStyleWarningCodes Field

PythonParserCodeStyleWarningCodes Field

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static HashSet<string> CodeStyleWarningCodes
Public Shared CodeStyleWarningCodes As HashSet(Of String)
public:
static HashSet<String^>^ CodeStyleWarningCodes
static val mutable CodeStyleWarningCodes: HashSet<string>

Field Value

Type: HashSetString
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.DefaultPythonSyntaxOptions Field

PythonParserDefaultPythonSyntaxOptions Field
Represents default set of flags determining syntax parsing and formatting behavior.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultPythonSyntaxOptions
Public Shared DefaultPythonSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultPythonSyntaxOptions
static val mutable DefaultPythonSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser Methods

PythonParser Methods

The PythonParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.CreateRepository Method

PythonParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.ParseText Method

PythonParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

PythonParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

PythonParser Class
ParseText Overload
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.ResetOptions Method

PythonParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.ShouldSerializeOptions Method

PythonParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser Properties

PythonParser Properties

The PythonParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Overrides SyntaxParserCaseSensitive.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CodeStyleWarningsEnabled | Gets or sets a boolean value which indicates is code style warnings are enabled.
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Overrides LspParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.CaseSensitive Property

PythonParserCaseSensitive Property
Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.CodeStyleWarningsEnabled Property

PythonParserCodeStyleWarningsEnabled Property
Gets or sets a boolean value which indicates is code style warnings are enabled.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CodeStyleWarningsEnabled { get; set; }
Public Property CodeStyleWarningsEnabled As Boolean
    Get
    Set
public:
property bool CodeStyleWarningsEnabled {
    bool get ();
    void set (bool value);
}
member CodeStyleWarningsEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.Scheme Property

PythonParserScheme Property
Gets or sets list of rules for lexical analysis.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ILexScheme Scheme { get; set; }
Public Overrides Property Scheme As ILexScheme
    Get
    Set
public:
virtual property ILexScheme^ Scheme {
    ILexScheme^ get () override;
    void set (ILexScheme^ value) override;
}
abstract Scheme : ILexScheme with get, set
override Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme

Implements

ILexerScheme
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.Strings Property

PythonParserStrings Property
Gets or sets a list of strings to parse.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IStringList Strings { get; set; }
Public Overrides Property Strings As IStringList
    Get
    Set
public:
virtual property IStringList^ Strings {
    IStringList^ get () override;
    void set (IStringList^ value) override;
}
abstract Strings : IStringList with get, set
override Strings : IStringList with get, set

Property Value

Type: IStringList

Implements

IParserStrings
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser.Workspace Property

PythonParserWorkspace Property

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonWorkspace Workspace { get; }
Public ReadOnly Property Workspace As PythonWorkspace
    Get
public:
property PythonWorkspace^ Workspace {
    PythonWorkspace^ get ();
}
member Workspace : PythonWorkspace with get

Property Value

Type: PythonWorkspace
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonParser Events

PythonParser Events

The PythonParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonRepository Class

PythonRepository Class
Represents properties and methods to perform code completion functionality for Python language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.LspLspRepository
Alternet.Syntax.Parsers.Lsp.PythonPythonRepository

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonRepository : LspRepository
Public Class PythonRepository
    Inherits LspRepository
public ref class PythonRepository : public LspRepository
type PythonRepository =
    class
        inherit LspRepository
    end

The PythonRepository type exposes the following members.

Constructors
 | Name | Description
Public method | PythonRepository | Initializes a new instance of the PythonRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonRepository Constructor

PythonRepository Constructor
Initializes a new instance of the PythonRepository class with specified settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonRepository(
    ILspDocumentProvider documentProvider,
    ISyntaxTree syntaxTree
)
Public Sub New (
    documentProvider As ILspDocumentProvider,
    syntaxTree As ISyntaxTree
)
public:
PythonRepository(
    ILspDocumentProvider^ documentProvider,
    ISyntaxTree^ syntaxTree
)
new :
        documentProvider : ILspDocumentProvider *
        syntaxTree : ISyntaxTree -> PythonRepository

Parameters

documentProvider
Type: Alternet.Syntax.Parsers.LspILspDocumentProvider
ILspDocumentProvider associated with this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
ISyntaxTree for this new instance.
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonRepository Methods

PythonRepository Methods

The PythonRepository type exposes the following members.

Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonRepository Properties

PythonRepository Properties

The PythonRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonRepository Events

PythonRepository Events

The PythonRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonServerLocator Class

PythonServerLocator Class
Finds location of the language server executable.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.PythonPythonServerLocator
Alternet.Syntax.Parsers.Lsp.Python.EmbeddedPythonServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonServerLocator : ServerLocator
Public Class PythonServerLocator
    Inherits ServerLocator
public ref class PythonServerLocator : public ServerLocator
type PythonServerLocator =
    class
        inherit ServerLocator
    end

The PythonServerLocator type exposes the following members.

Constructors
 | Name | Description
Public method | PythonServerLocator | Initializes a new instance of the PythonServerLocator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonServerLocator Constructor

PythonServerLocator Constructor
Initializes a new instance of the PythonServerLocator class

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonServerLocator()
Public Sub New
public:
PythonServerLocator()
new : unit -> PythonServerLocator
See Also

Reference

PythonServerLocator Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonServerLocator Methods

PythonServerLocator Methods

The PythonServerLocator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonServerLocator Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonWorkspace Class

PythonWorkspace Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.PythonPythonWorkspace
Alternet.Syntax.Parsers.Lsp.Python.EmbeddedPythonWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonWorkspace : LspWorkspace
Public Class PythonWorkspace
    Inherits LspWorkspace
public ref class PythonWorkspace : public LspWorkspace
type PythonWorkspace =
    class
        inherit LspWorkspace
    end

The PythonWorkspace type exposes the following members.

Constructors
 | Name | Description
Public method | PythonWorkspace | Initializes a new instance of the PythonWorkspace class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CodeStyleChecksEnabled |
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonWorkspace Constructor

PythonWorkspace Constructor
Initializes a new instance of the PythonWorkspace class

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonWorkspace()
Public Sub New
public:
PythonWorkspace()
new : unit -> PythonWorkspace
See Also

Reference

PythonWorkspace Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonWorkspace Methods

PythonWorkspace Methods

The PythonWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonWorkspace Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonWorkspace Properties

PythonWorkspace Properties

The PythonWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | CodeStyleChecksEnabled |
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

PythonWorkspace Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


PythonWorkspace.CodeStyleChecksEnabled Property

PythonWorkspaceCodeStyleChecksEnabled Property

Namespace: Alternet.Syntax.Parsers.Lsp.Python
Assembly: Alternet.Syntax.Parsers.Python.v7 (in Alternet.Syntax.Parsers.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CodeStyleChecksEnabled { get; set; }
Public Property CodeStyleChecksEnabled As Boolean
    Get
    Set
public:
property bool CodeStyleChecksEnabled {
    bool get ();
    void set (bool value);
}
member CodeStyleChecksEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PythonWorkspace Class
Alternet.Syntax.Parsers.Lsp.Python Namespace


Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace

Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace
Classes
 | Class | Description
Public class | PythonParserEmbedded | Represents class that and perform syntax and lexical analysis of specified Python code text.
Public class | PythonServerLocatorEmbedded |
Public class | PythonWorkspaceEmbedded |


PythonParserEmbedded Class

PythonParserEmbedded Class
Represents class that and perform syntax and lexical analysis of specified Python code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.PythonPythonParser
Alternet.Syntax.Parsers.Lsp.Python.EmbeddedPythonParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Python.Embedded
Assembly: Alternet.Syntax.Parsers.Python.Embedded.v7 (in Alternet.Syntax.Parsers.Python.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonParserEmbedded : PythonParser
Public Class PythonParserEmbedded
    Inherits PythonParser
public ref class PythonParserEmbedded : public PythonParser
type PythonParserEmbedded =
    class
        inherit PythonParser
    end

The PythonParserEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParserEmbedded | Initializes a new instance of the PythonParserEmbedded class with default settings.
Public method | PythonParserEmbedded(IContainer) | Initializes a new instance of the PythonParserEmbedded class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from PythonParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from PythonParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from PythonParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from PythonParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from PythonParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CodeStyleWarningsEnabled | Gets or sets a boolean value which indicates is code style warnings are enabled. (Inherited from PythonParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from PythonParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from PythonParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from PythonParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonParserEmbedded Constructor

PythonParserEmbedded Constructor
Overload List
 | Name | Description
Public method | PythonParserEmbedded | Initializes a new instance of the PythonParserEmbedded class with default settings.
Public method | PythonParserEmbedded(IContainer) | Initializes a new instance of the PythonParserEmbedded class with specified container.
Top
See Also

Reference

PythonParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonParserEmbedded Constructor

PythonParserEmbedded Constructor
Initializes a new instance of the PythonParserEmbedded class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Python.Embedded
Assembly: Alternet.Syntax.Parsers.Python.Embedded.v7 (in Alternet.Syntax.Parsers.Python.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonParserEmbedded()
Public Sub New
public:
PythonParserEmbedded()
new : unit -> PythonParserEmbedded
See Also

Reference

PythonParserEmbedded Class
PythonParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonParserEmbedded Constructor (IContainer)

PythonParserEmbedded Constructor (IContainer)
Initializes a new instance of the PythonParserEmbedded class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Python.Embedded
Assembly: Alternet.Syntax.Parsers.Python.Embedded.v7 (in Alternet.Syntax.Parsers.Python.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonParserEmbedded(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
PythonParserEmbedded(
    IContainer^ container
)
new :
        container : IContainer -> PythonParserEmbedded

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

PythonParserEmbedded Class
PythonParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonParserEmbedded Methods

PythonParserEmbedded Methods

The PythonParserEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from PythonParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from PythonParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from PythonParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from PythonParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

PythonParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonParserEmbedded.DeployServer Method

PythonParserEmbeddedDeployServer Method

Namespace: Alternet.Syntax.Parsers.Lsp.Python.Embedded
Assembly: Alternet.Syntax.Parsers.Python.Embedded.v7 (in Alternet.Syntax.Parsers.Python.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DeployServer(
    IProgress<double> progress,
    string targetDirectory = null
)
Public Shared Sub DeployServer (
    progress As IProgress(Of Double),
    Optional targetDirectory As String = Nothing
)
public:
static void DeployServer(
    IProgress<double>^ progress,
    String^ targetDirectory = nullptr
)
static member DeployServer :
        progress : IProgress<float> *
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> unit

Parameters

progress
Type: SystemIProgressDouble
targetDirectory (Optional)
Type: SystemString
See Also

Reference

PythonParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonParserEmbedded.IsServerDeployed Method

PythonParserEmbeddedIsServerDeployed Method

Namespace: Alternet.Syntax.Parsers.Lsp.Python.Embedded
Assembly: Alternet.Syntax.Parsers.Python.Embedded.v7 (in Alternet.Syntax.Parsers.Python.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsServerDeployed(
    string targetDirectory = null
)
Public Shared Function IsServerDeployed (
    Optional targetDirectory As String = Nothing
) As Boolean
public:
static bool IsServerDeployed(
    String^ targetDirectory = nullptr
)
static member IsServerDeployed :
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> bool

Parameters

targetDirectory (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

PythonParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonParserEmbedded Properties

PythonParserEmbedded Properties

The PythonParserEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from PythonParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CodeStyleWarningsEnabled | Gets or sets a boolean value which indicates is code style warnings are enabled. (Inherited from PythonParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a LspRepository that holds methods for code completion purposes. (Inherited from LspParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from PythonParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from PythonParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from PythonParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonParserEmbedded Events

PythonParserEmbedded Events

The PythonParserEmbedded type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonServerLocatorEmbedded Class

PythonServerLocatorEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.PythonPythonServerLocator
Alternet.Syntax.Parsers.Lsp.Python.EmbeddedPythonServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Python.Embedded
Assembly: Alternet.Syntax.Parsers.Python.Embedded.v7 (in Alternet.Syntax.Parsers.Python.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonServerLocatorEmbedded : PythonServerLocator
Public Class PythonServerLocatorEmbedded
    Inherits PythonServerLocator
public ref class PythonServerLocatorEmbedded : public PythonServerLocator
type PythonServerLocatorEmbedded =
    class
        inherit PythonServerLocator
    end

The PythonServerLocatorEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | PythonServerLocatorEmbedded | Initializes a new instance of the PythonServerLocatorEmbedded class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonServerLocatorEmbedded Constructor

PythonServerLocatorEmbedded Constructor
Initializes a new instance of the PythonServerLocatorEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Python.Embedded
Assembly: Alternet.Syntax.Parsers.Python.Embedded.v7 (in Alternet.Syntax.Parsers.Python.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonServerLocatorEmbedded()
Public Sub New
public:
PythonServerLocatorEmbedded()
new : unit -> PythonServerLocatorEmbedded
See Also

Reference

PythonServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonServerLocatorEmbedded Methods

PythonServerLocatorEmbedded Methods

The PythonServerLocatorEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonWorkspaceEmbedded Class

PythonWorkspaceEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.PythonPythonWorkspace
Alternet.Syntax.Parsers.Lsp.Python.EmbeddedPythonWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Python.Embedded
Assembly: Alternet.Syntax.Parsers.Python.Embedded.v7 (in Alternet.Syntax.Parsers.Python.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonWorkspaceEmbedded : PythonWorkspace
Public Class PythonWorkspaceEmbedded
    Inherits PythonWorkspace
public ref class PythonWorkspaceEmbedded : public PythonWorkspace
type PythonWorkspaceEmbedded =
    class
        inherit PythonWorkspace
    end

The PythonWorkspaceEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | PythonWorkspaceEmbedded | Initializes a new instance of the PythonWorkspaceEmbedded class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CodeStyleChecksEnabled | (Inherited from PythonWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonWorkspaceEmbedded Constructor

PythonWorkspaceEmbedded Constructor
Initializes a new instance of the PythonWorkspaceEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Python.Embedded
Assembly: Alternet.Syntax.Parsers.Python.Embedded.v7 (in Alternet.Syntax.Parsers.Python.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonWorkspaceEmbedded()
Public Sub New
public:
PythonWorkspaceEmbedded()
new : unit -> PythonWorkspaceEmbedded
See Also

Reference

PythonWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonWorkspaceEmbedded Methods

PythonWorkspaceEmbedded Methods

The PythonWorkspaceEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


PythonWorkspaceEmbedded Properties

PythonWorkspaceEmbedded Properties

The PythonWorkspaceEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | CodeStyleChecksEnabled | (Inherited from PythonWorkspace.)
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

PythonWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Python.Embedded Namespace


Alternet.Syntax.Parsers.Lsp.Xml Namespace

Alternet.Syntax.Parsers.Lsp.Xml Namespace
Classes
 | Class | Description
Public class | XmlParser | Represents class that and perform syntax and lexical analysis of specified Xml code text.
Public class | XmlRepository | Represents properties and methods to perform code completion functionality for Xml language.
Public class | XmlServerLocator | Finds location of the language server executable.
Public class | XmlWorkspace |
Enumerations
 | Enumeration | Description
Public enumeration | XmlLexerToken | Represents lexical tokens for Xml parser.


XmlLexerToken Enumeration

XmlLexerToken Enumeration
Represents lexical tokens for Xml parser.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum XmlLexerToken
Public Enumeration XmlLexerToken
public enum class XmlLexerToken
type XmlLexerToken
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
WhiteSpace | 1 | Specifies that lexical token corresponds to whitespace symbol.
Body | 2 | Specifies that lexical token corresponds to xml body.
OpenTag | 3 | Specifies that lexical token corresponds to open tag.
CloseTag | 4 | Specifies that lexical token corresponds to close tag.
OpenEndTag | 5 | Specifies that lexical token corresponds to open end tag.
CloseEndTag | 6 | Specifies that lexical token corresponds to close end tag.
Equal | 7 | Specifies that lexical token corresponds to equality symbol.
TagName | 8 | Specifies that lexical token corresponds to name of tag.
ParamName | 9 | Specifies that lexical token corresponds to name of parameter.
ParamValue | 10 | Specifies that lexical token corresponds to parameter value.
Comment | 11 | Specifies that lexical token corresponds to comment tag.
Interr | 12 | Specifies that lexical token corresponds to "?" symbol.
CDATA | 13 | Specifies that lexical token corresponds to CDATA tag.
CDATABody | 14 | Specifies that lexical token corresponds to CDATA body tag.
OpenEmbeddedTag | 15 | Specifies that lexical token corresponds to open embedded tag.
CloseEmbeddedTag | 16 | Specifies that lexical token corresponds to close embedded tag.
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser Class

XmlParser Class
Represents class that and perform syntax and lexical analysis of specified Xml code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.XmlXmlParser
Alternet.Syntax.Parsers.Lsp.Xml.EmbeddedXmlParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlParser : LspParser
Public Class XmlParser
    Inherits LspParser
public ref class XmlParser : public LspParser
type XmlParser =
    class
        inherit LspParser
    end

The XmlParser type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParser | Initializes a new instance of the XmlParser class with default settings.
Public method | XmlParser(IContainer) | Initializes a new instance of the XmlParser class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Fields
Name | Description
DefaultXmlCodeCompletionChars | Represents a default collection of characters that initializes a code completion procedure when typing.
DefaultXmlDelimiters | Represents a default collection of delimiter characters.
DefaultXmlSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a XmlRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser Constructor

XmlParser Constructor
Overload List
 | Name | Description
Public method | XmlParser | Initializes a new instance of the XmlParser class with default settings.
Public method | XmlParser(IContainer) | Initializes a new instance of the XmlParser class with specified container.
Top
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser Constructor

XmlParser Constructor
Initializes a new instance of the XmlParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlParser()
Public Sub New
public:
XmlParser()
new : unit -> XmlParser
See Also

Reference

XmlParser Class
XmlParser Overload
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser Constructor (IContainer)

XmlParser Constructor (IContainer)
Initializes a new instance of the XmlParser class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlParser(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
XmlParser(
    IContainer^ container
)
new :
        container : IContainer -> XmlParser

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

XmlParser Class
XmlParser Overload
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser Fields

XmlParser Fields

The XmlParser type exposes the following members.

Fields
Name | Description
DefaultXmlCodeCompletionChars | Represents a default collection of characters that initializes a code completion procedure when typing.
DefaultXmlDelimiters | Represents a default collection of delimiter characters.
DefaultXmlSyntaxOptions | Represents default set of flags determining syntax parsing and formatting behavior.
Top
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.DefaultXmlCodeCompletionChars Field

XmlParserDefaultXmlCodeCompletionChars Field
Represents a default collection of characters that initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultXmlCodeCompletionChars
Public Shared DefaultXmlCodeCompletionChars As String
public:
static String^ DefaultXmlCodeCompletionChars
static val mutable DefaultXmlCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.DefaultXmlDelimiters Field

XmlParserDefaultXmlDelimiters Field
Represents a default collection of delimiter characters.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultXmlDelimiters
Public Shared DefaultXmlDelimiters As String
public:
static String^ DefaultXmlDelimiters
static val mutable DefaultXmlDelimiters: string

Field Value

Type: String
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.DefaultXmlSyntaxOptions Field

XmlParserDefaultXmlSyntaxOptions Field
Represents default set of flags determining syntax parsing and formatting behavior.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultXmlSyntaxOptions
Public Shared DefaultXmlSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultXmlSyntaxOptions
static val mutable DefaultXmlSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser Methods

XmlParser Methods

The XmlParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides LspParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.CreateRepository Method

XmlParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.IsCodeCompletionChar Method

XmlParserIsCodeCompletionChar Method
Returns boolean value indicating that given character initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Public Overrides Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
public:
virtual bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
) override
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool
override IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
Given character.
style
Type: SystemByte
Specifies text style at cursor.
interval
Type: SystemInt32
Represents the delay, in milliseconds before displaying code completion window.

Return Value

Type: Boolean
True if given character is code completion character; otherwise false.

Implements

ISyntaxParserIsCodeCompletionChar(Char, Byte, Int32)
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.ParseText Method

XmlParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides LspParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

XmlParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

XmlParser Class
ParseText Overload
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.ResetCodeCompletionChars Method

XmlParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.ResetOptions Method

XmlParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.ShouldSerializeCodeCompletionChars Method

XmlParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.ShouldSerializeOptions Method

XmlParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser Properties

XmlParser Properties

The XmlParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a XmlRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Overrides LexerScheme.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace |
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.Repository Property

XmlParserRepository Property
Gets a XmlRepository that holds methods for code completion purposes.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlRepository Repository { get; }
Public ReadOnly Property Repository As XmlRepository
    Get
public:
property XmlRepository^ Repository {
    XmlRepository^ get ();
}
member Repository : XmlRepository with get

Property Value

Type: XmlRepository
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.Scheme Property

XmlParserScheme Property
Gets or sets list of rules for lexical analysis.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ILexScheme Scheme { get; set; }
Public Overrides Property Scheme As ILexScheme
    Get
    Set
public:
virtual property ILexScheme^ Scheme {
    ILexScheme^ get () override;
    void set (ILexScheme^ value) override;
}
abstract Scheme : ILexScheme with get, set
override Scheme : ILexScheme with get, set

Property Value

Type: ILexScheme

Implements

ILexerScheme
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser.Workspace Property

XmlParserWorkspace Property

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlWorkspace Workspace { get; }
Public ReadOnly Property Workspace As XmlWorkspace
    Get
public:
property XmlWorkspace^ Workspace {
    XmlWorkspace^ get ();
}
member Workspace : XmlWorkspace with get

Property Value

Type: XmlWorkspace
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlParser Events

XmlParser Events

The XmlParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParser Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlRepository Class

XmlRepository Class
Represents properties and methods to perform code completion functionality for Xml language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.LspLspRepository
Alternet.Syntax.Parsers.Lsp.XmlXmlRepository

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlRepository : LspRepository
Public Class XmlRepository
    Inherits LspRepository
public ref class XmlRepository : public LspRepository
type XmlRepository =
    class
        inherit LspRepository
    end

The XmlRepository type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRepository | Initializes a new instance of the XmlRepository class with specified parameters.
Top
Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) |
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlRepository Constructor

XmlRepository Constructor
Initializes a new instance of the XmlRepository class with specified parameters.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlRepository(
    ILspDocumentProvider documentProvider,
    ISyntaxTree syntaxTree
)
Public Sub New (
    documentProvider As ILspDocumentProvider,
    syntaxTree As ISyntaxTree
)
public:
XmlRepository(
    ILspDocumentProvider^ documentProvider,
    ISyntaxTree^ syntaxTree
)
new :
        documentProvider : ILspDocumentProvider *
        syntaxTree : ISyntaxTree -> XmlRepository

Parameters

documentProvider
Type: Alternet.Syntax.Parsers.LspILspDocumentProvider
ILspDocumentProvider for this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
ISyntaxTree for this new instance.
See Also

Reference

XmlRepository Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlRepository Methods

XmlRepository Methods

The XmlRepository type exposes the following members.

Methods
 | Name | Description
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) |
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

XmlRepository Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlRepository.FillMembers Method

XmlRepositoryFillMembers Method
Overload List
 | Name | Description
Public method | FillMembers(CompletionItem, IListMembers, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from LspRepository.)
Public method | FillMembers(CompletionItem, IListMembers, Int32) |
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

XmlRepository Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlRepository.FillMembers Method (CompletionItem[], IListMembers, Int32)

XmlRepositoryFillMembers Method (CompletionItem, IListMembers, Int32)

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillMembers(
    CompletionItem[] completionItems,
    IListMembers members,
    out int selectedIndex
)
Public Overridable Sub FillMembers (
    completionItems As CompletionItem(),
    members As IListMembers,
    <OutAttribute> ByRef selectedIndex As Integer
)
public:
virtual void FillMembers(
    array<CompletionItem^>^ completionItems,
    IListMembers^ members,
    [OutAttribute] int% selectedIndex
)
abstract FillMembers :
        completionItems : CompletionItem[] *
        members : IListMembers *
        selectedIndex : int byref -> unit
override FillMembers :
        completionItems : CompletionItem[] *
        members : IListMembers *
        selectedIndex : int byref -> unit

Parameters

completionItems
Type: CompletionItem
members
Type: Alternet.Syntax.CodeCompletionIListMembers
selectedIndex
Type: SystemInt32
See Also

Reference

XmlRepository Class
FillMembers Overload
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlRepository Properties

XmlRepository Properties

The XmlRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a LspDocument object associated with this repository. (Inherited from LspRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from LspRepository.)
Public property | ImagesHighDpi | Represents the ImageList for code completion items for high DPI. (Inherited from LspRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

XmlRepository Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlRepository Events

XmlRepository Events

The XmlRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

XmlRepository Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlServerLocator Class

XmlServerLocator Class
Finds location of the language server executable.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.XmlXmlServerLocator
Alternet.Syntax.Parsers.Lsp.Xml.EmbeddedXmlServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlServerLocator : ServerLocator
Public Class XmlServerLocator
    Inherits ServerLocator
public ref class XmlServerLocator : public ServerLocator
type XmlServerLocator =
    class
        inherit ServerLocator
    end

The XmlServerLocator type exposes the following members.

Constructors
 | Name | Description
Public method | XmlServerLocator | Initializes a new instance of the XmlServerLocator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlServerLocator Constructor

XmlServerLocator Constructor
Initializes a new instance of the XmlServerLocator class

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlServerLocator()
Public Sub New
public:
XmlServerLocator()
new : unit -> XmlServerLocator
See Also

Reference

XmlServerLocator Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlServerLocator Methods

XmlServerLocator Methods

The XmlServerLocator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlServerLocator Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlWorkspace Class

XmlWorkspace Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.XmlXmlWorkspace
Alternet.Syntax.Parsers.Lsp.Xml.EmbeddedXmlWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlWorkspace : LspWorkspace
Public Class XmlWorkspace
    Inherits LspWorkspace
public ref class XmlWorkspace : public LspWorkspace
type XmlWorkspace =
    class
        inherit LspWorkspace
    end

The XmlWorkspace type exposes the following members.

Constructors
 | Name | Description
Public method | XmlWorkspace | Initializes a new instance of the XmlWorkspace class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlWorkspace Constructor

XmlWorkspace Constructor
Initializes a new instance of the XmlWorkspace class

Namespace: Alternet.Syntax.Parsers.Lsp.Xml
Assembly: Alternet.Syntax.Parsers.Xml.v7 (in Alternet.Syntax.Parsers.Xml.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlWorkspace()
Public Sub New
public:
XmlWorkspace()
new : unit -> XmlWorkspace
See Also

Reference

XmlWorkspace Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlWorkspace Methods

XmlWorkspace Methods

The XmlWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlWorkspace Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


XmlWorkspace Properties

XmlWorkspace Properties

The XmlWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

XmlWorkspace Class
Alternet.Syntax.Parsers.Lsp.Xml Namespace


Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace

Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace
Classes
 | Class | Description
Public class | XmlParserEmbedded | Represents class that and perform syntax and lexical analysis of specified Xml code text.
Public class | XmlServerLocatorEmbedded |
Public class | XmlWorkspaceEmbedded |


XmlParserEmbedded Class

XmlParserEmbedded Class
Represents class that and perform syntax and lexical analysis of specified Xml code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.LspLspParser
Alternet.Syntax.Parsers.Lsp.XmlXmlParser
Alternet.Syntax.Parsers.Lsp.Xml.EmbeddedXmlParserEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Xml.Embedded
Assembly: Alternet.Syntax.Parsers.Xml.Embedded.v7 (in Alternet.Syntax.Parsers.Xml.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlParserEmbedded : XmlParser
Public Class XmlParserEmbedded
    Inherits XmlParser
public ref class XmlParserEmbedded : public XmlParser
type XmlParserEmbedded =
    class
        inherit XmlParser
    end

The XmlParserEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParserEmbedded | Initializes a new instance of the XmlParserEmbedded class with default settings.
Public method | XmlParserEmbedded(IContainer) | Initializes a new instance of the XmlParserEmbedded class with specified container.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from XmlParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from XmlParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from XmlParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from XmlParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a XmlRepository that holds methods for code completion purposes. (Inherited from XmlParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from XmlParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from XmlParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlParserEmbedded Constructor

XmlParserEmbedded Constructor
Overload List
 | Name | Description
Public method | XmlParserEmbedded | Initializes a new instance of the XmlParserEmbedded class with default settings.
Public method | XmlParserEmbedded(IContainer) | Initializes a new instance of the XmlParserEmbedded class with specified container.
Top
See Also

Reference

XmlParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlParserEmbedded Constructor

XmlParserEmbedded Constructor
Initializes a new instance of the XmlParserEmbedded class with default settings.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml.Embedded
Assembly: Alternet.Syntax.Parsers.Xml.Embedded.v7 (in Alternet.Syntax.Parsers.Xml.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlParserEmbedded()
Public Sub New
public:
XmlParserEmbedded()
new : unit -> XmlParserEmbedded
See Also

Reference

XmlParserEmbedded Class
XmlParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlParserEmbedded Constructor (IContainer)

XmlParserEmbedded Constructor (IContainer)
Initializes a new instance of the XmlParserEmbedded class with specified container.

Namespace: Alternet.Syntax.Parsers.Lsp.Xml.Embedded
Assembly: Alternet.Syntax.Parsers.Xml.Embedded.v7 (in Alternet.Syntax.Parsers.Xml.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlParserEmbedded(
    IContainer container
)
Public Sub New (
    container As IContainer
)
public:
XmlParserEmbedded(
    IContainer^ container
)
new :
        container : IContainer -> XmlParserEmbedded

Parameters

container
Type: System.ComponentModelIContainer
Specifies IContainer that contains this new instance.
See Also

Reference

XmlParserEmbedded Class
XmlParserEmbedded Overload
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlParserEmbedded Methods

XmlParserEmbedded Methods

The XmlParserEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from XmlParser.)
 | DeployServer |
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletionAsync | Performs code completion for the specified text representing language element. (Inherited from LspParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration location at given position. (Inherited from LspParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from LspParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from LspParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from XmlParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
 | IsServerDeployed |
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from LspParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from LspParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from XmlParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from LspParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from XmlParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from XmlParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from LspParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from XmlParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from LspParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from LspParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

XmlParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlParserEmbedded.DeployServer Method

XmlParserEmbeddedDeployServer Method

Namespace: Alternet.Syntax.Parsers.Lsp.Xml.Embedded
Assembly: Alternet.Syntax.Parsers.Xml.Embedded.v7 (in Alternet.Syntax.Parsers.Xml.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DeployServer(
    IProgress<double> progress,
    string targetDirectory = null
)
Public Shared Sub DeployServer (
    progress As IProgress(Of Double),
    Optional targetDirectory As String = Nothing
)
public:
static void DeployServer(
    IProgress<double>^ progress,
    String^ targetDirectory = nullptr
)
static member DeployServer :
        progress : IProgress<float> *
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> unit

Parameters

progress
Type: SystemIProgressDouble
targetDirectory (Optional)
Type: SystemString
See Also

Reference

XmlParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlParserEmbedded.IsServerDeployed Method

XmlParserEmbeddedIsServerDeployed Method

Namespace: Alternet.Syntax.Parsers.Lsp.Xml.Embedded
Assembly: Alternet.Syntax.Parsers.Xml.Embedded.v7 (in Alternet.Syntax.Parsers.Xml.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsServerDeployed(
    string targetDirectory = null
)
Public Shared Function IsServerDeployed (
    Optional targetDirectory As String = Nothing
) As Boolean
public:
static bool IsServerDeployed(
    String^ targetDirectory = nullptr
)
static member IsServerDeployed :
        ?targetDirectory : string
(* Defaults:
        let _targetDirectory = defaultArg targetDirectory null
*)
-> bool

Parameters

targetDirectory (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

XmlParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlParserEmbedded Properties

XmlParserEmbedded Properties

The XmlParserEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Document | Gets a LspDocument associated with this parser. (Inherited from LspParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from LspParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets a XmlRepository that holds methods for code completion purposes. (Inherited from XmlParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from XmlParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from LspParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | Workspace | (Inherited from XmlParser.)
Public property | WorkspaceScope | (Inherited from LspParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlParserEmbedded Events

XmlParserEmbedded Events

The XmlParserEmbedded type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

XmlParserEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlServerLocatorEmbedded Class

XmlServerLocatorEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspServerLocator
Alternet.Syntax.Parsers.Lsp.XmlXmlServerLocator
Alternet.Syntax.Parsers.Lsp.Xml.EmbeddedXmlServerLocatorEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Xml.Embedded
Assembly: Alternet.Syntax.Parsers.Xml.Embedded.v7 (in Alternet.Syntax.Parsers.Xml.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlServerLocatorEmbedded : XmlServerLocator
Public Class XmlServerLocatorEmbedded
    Inherits XmlServerLocator
public ref class XmlServerLocatorEmbedded : public XmlServerLocator
type XmlServerLocatorEmbedded =
    class
        inherit XmlServerLocator
    end

The XmlServerLocatorEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | XmlServerLocatorEmbedded | Initializes a new instance of the XmlServerLocatorEmbedded class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlServerLocatorEmbedded Constructor

XmlServerLocatorEmbedded Constructor
Initializes a new instance of the XmlServerLocatorEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Xml.Embedded
Assembly: Alternet.Syntax.Parsers.Xml.Embedded.v7 (in Alternet.Syntax.Parsers.Xml.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlServerLocatorEmbedded()
Public Sub New
public:
XmlServerLocatorEmbedded()
new : unit -> XmlServerLocatorEmbedded
See Also

Reference

XmlServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlServerLocatorEmbedded Methods

XmlServerLocatorEmbedded Methods

The XmlServerLocatorEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetServerStartInfo | Gets ProcessStartInfo of the LSP server executable. (Inherited from ServerLocator.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlServerLocatorEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlWorkspaceEmbedded Class

XmlWorkspaceEmbedded Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.LspLspWorkspace
Alternet.Syntax.Parsers.Lsp.XmlXmlWorkspace
Alternet.Syntax.Parsers.Lsp.Xml.EmbeddedXmlWorkspaceEmbedded

Namespace: Alternet.Syntax.Parsers.Lsp.Xml.Embedded
Assembly: Alternet.Syntax.Parsers.Xml.Embedded.v7 (in Alternet.Syntax.Parsers.Xml.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlWorkspaceEmbedded : XmlWorkspace
Public Class XmlWorkspaceEmbedded
    Inherits XmlWorkspace
public ref class XmlWorkspaceEmbedded : public XmlWorkspace
type XmlWorkspaceEmbedded =
    class
        inherit XmlWorkspace
    end

The XmlWorkspaceEmbedded type exposes the following members.

Constructors
 | Name | Description
Public method | XmlWorkspaceEmbedded | Initializes a new instance of the XmlWorkspaceEmbedded class
Top
Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlWorkspaceEmbedded Constructor

XmlWorkspaceEmbedded Constructor
Initializes a new instance of the XmlWorkspaceEmbedded class

Namespace: Alternet.Syntax.Parsers.Lsp.Xml.Embedded
Assembly: Alternet.Syntax.Parsers.Xml.Embedded.v7 (in Alternet.Syntax.Parsers.Xml.Embedded.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlWorkspaceEmbedded()
Public Sub New
public:
XmlWorkspaceEmbedded()
new : unit -> XmlWorkspaceEmbedded
See Also

Reference

XmlWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlWorkspaceEmbedded Methods

XmlWorkspaceEmbedded Methods

The XmlWorkspaceEmbedded type exposes the following members.

Methods
 | Name | Description
Public method | ConnectParser | (Inherited from LspWorkspace.)
Public method | DisconnectParser | (Inherited from LspWorkspace.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


XmlWorkspaceEmbedded Properties

XmlWorkspaceEmbedded Properties

The XmlWorkspaceEmbedded type exposes the following members.

Properties
 | Name | Description
Public property | ServerDeploymentOptions | Gets a ServerDeploymentOptions instance which allows to set LSP server deployment options. (Inherited from LspWorkspace.)
Public property | ServerProcess | (Inherited from LspWorkspace.)
Top
See Also

Reference

XmlWorkspaceEmbedded Class
Alternet.Syntax.Parsers.Lsp.Xml.Embedded Namespace


Alternet.Syntax.Parsers.Python Namespace

Alternet.Syntax.Parsers.Python Namespace
Classes
 | Class | Description
Public class | IronPythonParser |
Public class | PythonParser | Represents class that and perform syntax and lexical analysis of specified Python code text.
Public class | SyntaxParserConsts |
Enumerations
 | Enumeration | Description
Public enumeration | PythonLexerToken | Represents lexical tokens for Python parser.
Public enumeration | PythonNodeType |


IronPythonParser Class

IronPythonParser Class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.PythonPythonParser
Alternet.Syntax.Parsers.PythonIronPythonParser

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonParser : PythonParser
Public Class IronPythonParser
    Inherits PythonParser
public ref class IronPythonParser : public PythonParser
type IronPythonParser =
    class
        inherit PythonParser
    end

The IronPythonParser type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonParser | Initializes a new instance of the IronPythonParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from PythonParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from PythonParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from PythonParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from PythonParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from PythonParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from PythonParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from PythonParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | (Inherited from PythonParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | (Inherited from PythonParser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from PythonParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from PythonParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | (Inherited from PythonParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from PythonParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from PythonParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from PythonParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | (Inherited from PythonParser.)
Public property | Classifier | (Inherited from PythonParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeEnvironment | (Inherited from PythonParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Model | (Inherited from PythonParser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python Namespace


IronPythonParser Constructor

IronPythonParser Constructor
Initializes a new instance of the IronPythonParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonParser()
Public Sub New
public:
IronPythonParser()
new : unit -> IronPythonParser
See Also

Reference

IronPythonParser Class
Alternet.Syntax.Parsers.Python Namespace


IronPythonParser Methods

IronPythonParser Methods

The IronPythonParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from PythonParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Inherited from PythonParser.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from PythonParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from PythonParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from PythonParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from PythonParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from PythonParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | (Inherited from PythonParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | (Inherited from PythonParser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from PythonParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from PythonParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | (Inherited from PythonParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from PythonParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from PythonParser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from PythonParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

IronPythonParser Class
Alternet.Syntax.Parsers.Python Namespace


IronPythonParser Properties

IronPythonParser Properties

The IronPythonParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | (Inherited from PythonParser.)
Public property | Classifier | (Inherited from PythonParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeEnvironment | (Inherited from PythonParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Model | (Inherited from PythonParser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

IronPythonParser Class
Alternet.Syntax.Parsers.Python Namespace


IronPythonParser Events

IronPythonParser Events

The IronPythonParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

IronPythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonLexerToken Enumeration

PythonLexerToken Enumeration
Represents lexical tokens for Python parser.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PythonLexerToken
Public Enumeration PythonLexerToken
public enum class PythonLexerToken
type PythonLexerToken
Members
Member name | Value | Description
And | 0 |
As | 1 |
Assert | 2 |
Async | 3 |
Await | 4 |
Break | 5 |
Class | 6 |
Continue | 7 |
Def | 8 |
Del | 9 |
Elif | 10 |
Else | 11 |
Except | 12 |
Exec | 13 |
False | 14 |
Finally | 15 |
For | 16 |
From | 17 |
Global | 18 |
If | 19 |
Import | 20 |
In | 21 |
Is | 22 |
Lambda | 23 |
None | 24 |
Nonlocal | 25 |
Not | 26 |
Or | 27 |
Pass | 28 |
Raise | 29 |
Return | 30 |
True | 31 |
Try | 32 |
While | 33 |
With | 34 |
Yield | 35 |
Open_brace | 36 |
Close_brace | 37 |
Open_bracket | 38 |
Close_bracket | 39 |
Open_parens | 40 |
Close_parens | 41 |
Ellipsis | 42 |
Dot | 43 |
Comma | 44 |
Colon | 45 |
Semicolon | 46 |
Tilde | 47 |
Cav | 48 |
Decorator | 49 |
Plus | 50 |
Minus | 51 |
Bang | 52 |
Assign | 53 |
Op_lt | 54 |
Op_gt | 55 |
Bitwise_and | 56 |
Bitwise_or | 57 |
Star | 58 |
DblStar | 59 |
Percent | 60 |
Div | 61 |
DblDiv | 62 |
Carret | 63 |
Dollar | 64 |
IntDiv | 65 |
Interr | 66 |
LineContinuation | 67 |
Op_shift_left | 68 |
Op_shift_right | 69 |
Op_le | 70 |
Op_ge | 71 |
Op_eq | 72 |
Op_ne | 73 |
Dbl_mult_assign | 74 |
Op_mult_assign | 75 |
Dbl_div_assign | 76 |
Op_div_assign | 77 |
Op_mod_assign | 78 |
Op_add_assign | 79 |
Op_sub_assign | 80 |
Op_shift_left_assign | 81 |
Op_shift_right_assign | 82 |
Op_and_assign | 83 |
Op_xor_assign | 84 |
Op_or_assign | 85 |
Int | 86 |
Float | 87 |
Double | 88 |
Char | 89 |
String | 90 |
Bool | 91 |
Integer_Literal | 92 |
Float_Literal | 93 |
Double_Literal | 94 |
Imag_Literal | 95 |
Character_Literal | 96 |
String_Literal | 97 |
Byte_Literal | 98 |
Identifier_Literal | 99 |
Method_Literal | 100 |
Type_Literal | 101 |
Comment_Literal | 102 |
Whitespace_Literal | 103 |
See Also

Reference

Alternet.Syntax.Parsers.Python Namespace


PythonNodeType Enumeration

PythonNodeType Enumeration

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PythonNodeType
Public Enumeration PythonNodeType
public enum class PythonNodeType
type PythonNodeType
Members
Member name | Value | Description
None | 0 | Specifies that no flags are in effect.
Unit | 1 | Specifies that syntax node corresponds to entire unit.
UsingList | 2 | Specifies that syntax node corresponds to the list of external namespaces.
Using | 3 | Specifies that syntax node corresponds to external namespace.
UsingAlias | 4 | Specifies that syntax node corresponds to user-defined symbol representing a namespace.
Namespace | 5 | Specifies that syntax node corresponds to namespace.
Class | 6 | Specifies that syntax node corresponds to class.
Struct | 7 | Specifies that syntax node corresponds to structure.
Interface | 8 | Specifies that syntax node corresponds to interface.
Field | 9 | Specifies that syntax node corresponds to field.
LocalVariable | 10 | Specifies that syntax node corresponds to local variable.
Method | 11 | Specifies that syntax node corresponds to method.
Decorator | 12 | Specifies that syntax node corresponds to decorator.
Parameter | 13 | Specifies that syntax node corresponds to parameter.
ParameterList | 14 | Specifies that syntax node corresponds to list of parameters.
LambdaExpression | 15 | Specifies that syntax node corresponds to "lambda" expression.
LambdaParameter | 16 | Specifies that syntax node corresponds to "lambda" parameter.
LambdaParameterList | 17 | Specifies that syntax node corresponds to "lambda" parameter list.
Argument | 18 | Specifies that syntax node corresponds to method argument.
ArgumentList | 19 | Specifies that syntax node corresponds to list of arguments.
VariableInitializer | 20 | Specifies that syntax node corresponds to variable initializer.
Identifier | 21 | Specifies that syntax node corresponds to identifier.
Name | 22 | Specifies that syntax node corresponds to name (identifier).
Type | 23 | Specifies that syntax node corresponds to type.
TypeList | 24 | Specifies that syntax node corresponds to list of types.
TupleMembersList | 25 | Specifies that syntax node corresponds to Tuple member list.
TupleMember | 26 | Specifies that syntax node corresponds to Tuple member.
BaseType | 27 | Specifies that syntax node corresponds to base type.
Modifier | 28 | Specifies that syntax node corresponds to access modifier.
AssignmentStatement | 29 | Specifies that syntax node corresponds to "assignment" statement.
IfStatement | 30 | Specifies that syntax node corresponds to "if" statement.
ElseStatement | 31 | Specifies that syntax node corresponds to "else" statement.
WhileStatement | 32 | Specifies that syntax node corresponds to "while" statement.
ForStatement | 33 | Specifies that syntax node corresponds to "for" statement.
ForConditionStatement | 34 | Specifies that syntax node corresponds to "for" condition statement.
ForInitializerStatement | 35 | Specifies that syntax node corresponds to "for" initializer statement.
AssertStatement | 36 | Specifies that syntax node corresponds to "assert" statement.
BreakStatement | 37 | Specifies that syntax node corresponds to "break" statement.
ContinueStatement | 38 | Specifies that syntax node corresponds to "continue" statement.
ReturnStatement | 39 | Specifies that syntax node corresponds to "return" statement.
TryStatement | 40 | Specifies that syntax node corresponds to "try" statement.
CatchStatement | 41 | Specifies that syntax node corresponds to "catch" statement.
FinallyStatement | 42 | Specifies that syntax node corresponds to "finally" statement.
BlockStatement | 43 | Specifies that syntax node corresponds to "block" statement.
ExpressionStatement | 44 | Specifies that syntax node corresponds to expression statement.
PassStatement | 45 | Specifies that syntax node corresponds to "pass" statement.
DelStatement | 46 | Specifies that syntax node corresponds to "del" statement.
PrintStatement | 47 | Specifies that syntax node corresponds to "print" statement.
YieldStatement | 48 | Specifies that syntax node corresponds to "yield" statement.
RaiseStatement | 49 | Specifies that syntax node corresponds to "raise" statement.
GlobalStatement | 50 | Specifies that syntax node corresponds to "global" statement.
ExecStatement | 51 | Specifies that syntax node corresponds to "exec" statement.
ElseIfStatement | 52 | Specifies that syntax node corresponds to "else if" statement.
WithStatement | 53 | Specifies that syntax node corresponds to "with" statement.
WithStatementMember | 54 | Specifies that syntax node corresponds to with member.
Assignment | 55 | Specifies attribute for assignment expression.
ExpressionList | 56 | Specifies that syntax node corresponds to expression list.
Expression | 57 | Specifies that syntax node corresponds to expression.
KeyDatumList | 58 | Specifies that syntax node corresponds to key datum expression list.
KeyDatum | 59 | Specifies that syntax node corresponds to key datum expression.
ConditionalExpression | 60 | Specifies that syntax node corresponds to "conditional" expression.
AssignmentExpression | 61 | Specifies that syntax node corresponds to "assignment" expression.
ConditionalOrExpression | 62 | Specifies that syntax node corresponds to "conditional or" expression.
ConditionalAndExpression | 63 | Specifies that syntax node corresponds to "conditional and" expression.
InclusiveOrExpression | 64 | Specifies that syntax node corresponds to "inclusive or" expression.
ExclusiveOrExpression | 65 | Specifies that syntax node corresponds to "exclusive or" expression.
AndExpression | 66 | Specifies that syntax node corresponds to "and" expression.
NotExpression | 67 | Specifies that syntax node corresponds to "not" expression.
EqualityExpression | 68 | Specifies that syntax node corresponds to "equality" expression.
RelationalExpression | 69 | Specifies that syntax node corresponds to "relation" expression.
AsIsExpression | 70 | Specifies that syntax node corresponds to "as is" expression.
InExpression | 71 | Specifies that syntax node corresponds to "in" expression.
ShiftExpression | 72 | Specifies that syntax node corresponds to "shift" expression.
AdditiveExpression | 73 | Specifies that syntax node corresponds to "additive" expression.
MultiplicativeExpression | 74 | Specifies that syntax node corresponds to "multiplicative" expression.
PrefixedUnaryExpression | 75 | Specifies that syntax node corresponds to "prefixed unary" expression.
PrimaryExpression | 76 | Specifies that syntax node corresponds to "primary" expression.
AttributeRefExpression | 77 | Specifies that syntax node corresponds to "attribute reference" expression.
SubscriptionExpression | 78 | Specifies that syntax node corresponds to "subscription" expression.
SlicingExpression | 79 | Specifies that syntax node corresponds to "slicing" expression.
SliceList | 80 | Specifies that syntax node corresponds to "slice" expression list.
SliceExpression | 81 | Specifies that syntax node corresponds to "slice" expression.
InvocationExpression | 82 | Specifies that syntax node corresponds to "invocation" expression.
ParenthesizedExpression | 83 | Specifies that syntax node corresponds to "parenthesized" expression.
ListDisplayExpression | 84 | Specifies that syntax node corresponds to "list display" expression.
DictDisplayExpression | 85 | Specifies that syntax node corresponds to "dict display" expression.
SetDisplayExpression | 86 | Specifies that syntax node corresponds to "set display" expression.
StringConversionExpression | 87 | Specifies that syntax node corresponds to "string conversion" expression.
YieldExpression | 88 | Specifies that syntax node corresponds to "yield" expression.
MemberAccessExpression | 89 | Specifies that syntax node corresponds to "member access" expression.
See Also

Reference

Alternet.Syntax.Parsers.Python Namespace


PythonParser Class

PythonParser Class
Represents class that and perform syntax and lexical analysis of specified Python code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.PythonPythonParser
Alternet.Syntax.Parsers.PythonIronPythonParser

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonParser : SyntaxParser
Public Class PythonParser
    Inherits SyntaxParser
public ref class PythonParser : public SyntaxParser
type PythonParser =
    class
        inherit SyntaxParser
    end

The PythonParser type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParser | Initializes a new instance of the PythonParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(String, Point).)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Overrides SyntaxParserFindReferences(Point).)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | (Overrides SyntaxParserCaseSensitive.)
Public property | Classifier |
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeEnvironment |
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Model |
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python Namespace


PythonParser Constructor

PythonParser Constructor
Initializes a new instance of the PythonParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonParser()
Public Sub New
public:
PythonParser()
new : unit -> PythonParser
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser Methods

PythonParser Methods

The PythonParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(String, Point).)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Overrides SyntaxParserFindReferences(Point).)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from SyntaxParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.CodeCompletion Method

PythonParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.CodeCompletion Method (String, StringItemInfo[], Point, CodeCompletionArgs)

PythonParserCodeCompletion Method (String, StringItemInfo, Point, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    CodeCompletionArgs e
)
Public Overrides Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    CodeCompletionArgs^ e
) override
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs)
See Also

Reference

PythonParser Class
CodeCompletion Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.CreateRepository Method

PythonParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.FindDeclaration Method

PythonParserFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(String, Point).)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.FindDeclaration Method (Point)

PythonParserFindDeclaration Method (Point)
Finds the declaration node at given position.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override SymbolLocation FindDeclaration(
    Point position
)
Public Overrides Function FindDeclaration (
    position As Point
) As SymbolLocation
public:
virtual SymbolLocation^ FindDeclaration(
    Point position
) override
abstract FindDeclaration :
        position : Point -> SymbolLocation
override FindDeclaration :
        position : Point -> SymbolLocation

Parameters

position
Type: System.DrawingPoint
Specifies position to find a declaration.

Return Value

Type: SymbolLocation
SymbolLocation object that is found.

Implements

ISyntaxParserFindDeclaration(Point)
See Also

Reference

PythonParser Class
FindDeclaration Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.FindDeclaration Method (String, Point)

PythonParserFindDeclaration Method (String, Point)
Finds the declaration node at given position.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object FindDeclaration(
    string text,
    Point position
)
Public Overrides Function FindDeclaration (
    text As String,
    position As Point
) As Object
public:
virtual Object^ FindDeclaration(
    String^ text,
    Point position
) override
abstract FindDeclaration :
        text : string *
        position : Point -> Object
override FindDeclaration :
        text : string *
        position : Point -> Object

Parameters

text
Type: SystemString
Contains string used to perform search.
position
Type: System.DrawingPoint
Specifies position to find node.

Return Value

Type: Object
ISyntaxNode node representing declaration.

Implements

ISyntaxParserFindDeclaration(String, Point)
See Also

Reference

PythonParser Class
FindDeclaration Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.FindReferences Method

PythonParserFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Overrides SyntaxParserFindReferences(Point).)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.FindReferences Method (Point)

PythonParserFindReferences Method (Point)
Locates and highlights references at given position in the text.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FindReferences(
    Point position
)
Public Overrides Sub FindReferences (
    position As Point
)
public:
virtual void FindReferences(
    Point position
) override
abstract FindReferences :
        position : Point -> unit
override FindReferences :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Implements

ISyntaxParserFindReferences(Point)
See Also

Reference

PythonParser Class
FindReferences Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.FindReferences Method (Point, IRangeList, Boolean)

PythonParserFindReferences Method (Point, IRangeList, Boolean)
Locates declaration at given position and finds all references to this declaration in the text.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int FindReferences(
    Point position,
    IRangeList references,
    bool allDocuments = false
)
Public Overrides Function FindReferences (
    position As Point,
    references As IRangeList,
    Optional allDocuments As Boolean = false
) As Integer
public:
virtual int FindReferences(
    Point position,
    IRangeList^ references,
    bool allDocuments = false
) override
abstract FindReferences :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int
override FindReferences :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
Retrieves references to found declaration.
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found references.

Implements

ISyntaxParserFindReferences(Point, IRangeList, Boolean)
See Also

Reference

PythonParser Class
FindReferences Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.GetCompletionType Method

PythonParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.GetCompletionType Method (Char)

PythonParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

PythonParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.GetSingleLineComment Method

PythonParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.GetSingleLineComment Method

PythonParserGetSingleLineComment Method

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

PythonParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.NextToken Method

PythonParserNextToken Method
Overload List
 | Name | Description
Public method | NextToken | (Overrides ParserNextToken.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.NextToken Method

PythonParserNextToken Method

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int NextToken()
Public Overrides Function NextToken As Integer
public:
virtual int NextToken() override
abstract NextToken : unit -> int
override NextToken : unit -> int

Return Value

Type: Int32

Implements

IParserNextToken
See Also

Reference

PythonParser Class
NextToken Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.PositionChanged Method

PythonParserPositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overrides Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
) override
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxParserPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.ReparseBlock Method

PythonParserReparseBlock Method
Overload List
 | Name | Description
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Overrides SyntaxParserReparseBlock(Point).)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.ReparseBlock Method (Point)

PythonParserReparseBlock Method (Point)
Reparses syntax block at specified position.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ReparseBlock(
    Point position
)
Public Overrides Function ReparseBlock (
    position As Point
) As Boolean
public:
virtual bool ReparseBlock(
    Point position
) override
abstract ReparseBlock :
        position : Point -> bool
override ReparseBlock :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint
Specifies position to find syntax block.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserReparseBlock(Point)
See Also

Reference

PythonParser Class
ReparseBlock Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.ReparseText Method

PythonParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.ReparseText Method

PythonParserReparseText Method

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

PythonParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.ResetOptions Method

PythonParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.RestoreState Method

PythonParserRestoreState Method
Overload List
 | Name | Description
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Overrides ParserRestoreState(Boolean).)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.RestoreState Method (Boolean)

PythonParserRestoreState Method (Boolean)
Restores Parser state and position stored by SaveState method.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void RestoreState(
    bool restore
)
Public Overrides Sub RestoreState (
    restore As Boolean
)
public:
virtual void RestoreState(
    bool restore
) override
abstract RestoreState :
        restore : bool -> unit
override RestoreState :
        restore : bool -> unit

Parameters

restore
Type: SystemBoolean
Indicates whether Parser should restore it's state to previous position or simply delete information about previously stored state.

Implements

IParserRestoreState(Boolean)
See Also

Reference

PythonParser Class
RestoreState Overload
Alternet.Syntax.Parsers.Python Namespace


PythonParser.ShouldSerializeOptions Method

PythonParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser Properties

PythonParser Properties

The PythonParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | (Overrides SyntaxParserCaseSensitive.)
Public property | Classifier |
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeEnvironment |
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Model |
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.CaseSensitive Property

PythonParserCaseSensitive Property

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CaseSensitive { get; }
Public Overrides ReadOnly Property CaseSensitive As Boolean
    Get
public:
virtual property bool CaseSensitive {
    bool get () override;
}
abstract CaseSensitive : bool with get
override CaseSensitive : bool with get

Property Value

Type: Boolean

Implements

ISyntaxParserCaseSensitive
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.Classifier Property

PythonParserClassifier Property

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonClassifier Classifier { get; set; }
Public Property Classifier As IPythonClassifier
    Get
    Set
public:
property IPythonClassifier^ Classifier {
    IPythonClassifier^ get ();
    void set (IPythonClassifier^ value);
}
member Classifier : IPythonClassifier with get, set

Property Value

Type: IPythonClassifier
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.CodeEnvironment Property

PythonParserCodeEnvironment Property

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeEnvironment CodeEnvironment { get; set; }
Public Property CodeEnvironment As ICodeEnvironment
    Get
    Set
public:
property ICodeEnvironment^ CodeEnvironment {
    ICodeEnvironment^ get ();
    void set (ICodeEnvironment^ value);
}
member CodeEnvironment : ICodeEnvironment with get, set

Property Value

Type: ICodeEnvironment
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser.Model Property

PythonParserModel Property

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonSemanticModel Model { get; set; }
Public Property Model As IPythonSemanticModel
    Get
    Set
public:
property IPythonSemanticModel^ Model {
    IPythonSemanticModel^ get ();
    void set (IPythonSemanticModel^ value);
}
member Model : IPythonSemanticModel with get, set

Property Value

Type: IPythonSemanticModel
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


PythonParser Events

PythonParser Events

The PythonParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

PythonParser Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts Class

SyntaxParserConsts Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.PythonSyntaxParserConsts

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SyntaxParserConsts
Public Class SyntaxParserConsts
public ref class SyntaxParserConsts
type SyntaxParserConsts =  class end

The SyntaxParserConsts type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxParserConsts | Initializes a new instance of the SyntaxParserConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
BytesInternalName |
CantFindDeclaration |
CategoryClasses |
CategoryFields |
CategoryLocals |
CategoryMethods |
CategoryNamespaces |
ClassIndex |
ConstIndex |
DefaultByteForeColor |
DefaultMethodForeColor |
DefaultPythonSyntaxOptions |
DefaultTypeForeColor |
DelegateIndex |
DocComment |
EnumIndex |
EventIndex |
FieldIndex |
FileNameSpecifier |
LocalIndex |
MethodIndex |
MethodsInternalName |
NamespaceIndex |
QualifiedDeclartion |
StructIndex |
TypeDeclaration |
TypesInternalName |
TypeSpecifier |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts Constructor

SyntaxParserConsts Constructor
Initializes a new instance of the SyntaxParserConsts class

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SyntaxParserConsts()
Public Sub New
public:
SyntaxParserConsts()
new : unit -> SyntaxParserConsts
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts Fields

SyntaxParserConsts Fields

The SyntaxParserConsts type exposes the following members.

Fields
Name | Description
BytesInternalName |
CantFindDeclaration |
CategoryClasses |
CategoryFields |
CategoryLocals |
CategoryMethods |
CategoryNamespaces |
ClassIndex |
ConstIndex |
DefaultByteForeColor |
DefaultMethodForeColor |
DefaultPythonSyntaxOptions |
DefaultTypeForeColor |
DelegateIndex |
DocComment |
EnumIndex |
EventIndex |
FieldIndex |
FileNameSpecifier |
LocalIndex |
MethodIndex |
MethodsInternalName |
NamespaceIndex |
QualifiedDeclartion |
StructIndex |
TypeDeclaration |
TypesInternalName |
TypeSpecifier |
Top
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.BytesInternalName Field

SyntaxParserConstsBytesInternalName Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string BytesInternalName
Public Shared BytesInternalName As String
public:
static String^ BytesInternalName
static val mutable BytesInternalName: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.CantFindDeclaration Field

SyntaxParserConstsCantFindDeclaration Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string CantFindDeclaration
Public Const CantFindDeclaration As String
public:
literal String^ CantFindDeclaration
static val mutable CantFindDeclaration: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.CategoryClasses Field

SyntaxParserConstsCategoryClasses Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryClasses
Public Shared CategoryClasses As String
public:
static String^ CategoryClasses
static val mutable CategoryClasses: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.CategoryFields Field

SyntaxParserConstsCategoryFields Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryFields
Public Shared CategoryFields As String
public:
static String^ CategoryFields
static val mutable CategoryFields: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.CategoryLocals Field

SyntaxParserConstsCategoryLocals Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryLocals
Public Shared CategoryLocals As String
public:
static String^ CategoryLocals
static val mutable CategoryLocals: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.CategoryMethods Field

SyntaxParserConstsCategoryMethods Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryMethods
Public Shared CategoryMethods As String
public:
static String^ CategoryMethods
static val mutable CategoryMethods: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.CategoryNamespaces Field

SyntaxParserConstsCategoryNamespaces Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryNamespaces
Public Shared CategoryNamespaces As String
public:
static String^ CategoryNamespaces
static val mutable CategoryNamespaces: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.ClassIndex Field

SyntaxParserConstsClassIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ClassIndex
Public Const ClassIndex As Integer
public:
literal int ClassIndex
static val mutable ClassIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.ConstIndex Field

SyntaxParserConstsConstIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ConstIndex
Public Const ConstIndex As Integer
public:
literal int ConstIndex
static val mutable ConstIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.DefaultByteForeColor Field

SyntaxParserConstsDefaultByteForeColor Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultByteForeColor
Public Shared DefaultByteForeColor As Color
public:
static Color DefaultByteForeColor
static val mutable DefaultByteForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.DefaultMethodForeColor Field

SyntaxParserConstsDefaultMethodForeColor Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultMethodForeColor
Public Shared DefaultMethodForeColor As Color
public:
static Color DefaultMethodForeColor
static val mutable DefaultMethodForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.DefaultPythonSyntaxOptions Field

SyntaxParserConstsDefaultPythonSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultPythonSyntaxOptions
Public Shared DefaultPythonSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultPythonSyntaxOptions
static val mutable DefaultPythonSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.DefaultTypeForeColor Field

SyntaxParserConstsDefaultTypeForeColor Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultTypeForeColor
Public Shared DefaultTypeForeColor As Color
public:
static Color DefaultTypeForeColor
static val mutable DefaultTypeForeColor: Color

Field Value

Type: Color
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.DelegateIndex Field

SyntaxParserConstsDelegateIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DelegateIndex
Public Const DelegateIndex As Integer
public:
literal int DelegateIndex
static val mutable DelegateIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.DocComment Field

SyntaxParserConstsDocComment Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string DocComment
Public Const DocComment As String
public:
literal String^ DocComment
static val mutable DocComment: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.EnumIndex Field

SyntaxParserConstsEnumIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int EnumIndex
Public Const EnumIndex As Integer
public:
literal int EnumIndex
static val mutable EnumIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.EventIndex Field

SyntaxParserConstsEventIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int EventIndex
Public Const EventIndex As Integer
public:
literal int EventIndex
static val mutable EventIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.FieldIndex Field

SyntaxParserConstsFieldIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int FieldIndex
Public Const FieldIndex As Integer
public:
literal int FieldIndex
static val mutable FieldIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.FileNameSpecifier Field

SyntaxParserConstsFileNameSpecifier Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string FileNameSpecifier
Public Const FileNameSpecifier As String
public:
literal String^ FileNameSpecifier
static val mutable FileNameSpecifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.LocalIndex Field

SyntaxParserConstsLocalIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int LocalIndex
Public Const LocalIndex As Integer
public:
literal int LocalIndex
static val mutable LocalIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.MethodIndex Field

SyntaxParserConstsMethodIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int MethodIndex
Public Const MethodIndex As Integer
public:
literal int MethodIndex
static val mutable MethodIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.MethodsInternalName Field

SyntaxParserConstsMethodsInternalName Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string MethodsInternalName
Public Shared MethodsInternalName As String
public:
static String^ MethodsInternalName
static val mutable MethodsInternalName: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.NamespaceIndex Field

SyntaxParserConstsNamespaceIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int NamespaceIndex
Public Const NamespaceIndex As Integer
public:
literal int NamespaceIndex
static val mutable NamespaceIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.QualifiedDeclartion Field

SyntaxParserConstsQualifiedDeclartion Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string QualifiedDeclartion
Public Const QualifiedDeclartion As String
public:
literal String^ QualifiedDeclartion
static val mutable QualifiedDeclartion: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.StructIndex Field

SyntaxParserConstsStructIndex Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int StructIndex
Public Const StructIndex As Integer
public:
literal int StructIndex
static val mutable StructIndex: int

Field Value

Type: Int32
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.TypeDeclaration Field

SyntaxParserConstsTypeDeclaration Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeDeclaration
Public Const TypeDeclaration As String
public:
literal String^ TypeDeclaration
static val mutable TypeDeclaration: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.TypesInternalName Field

SyntaxParserConstsTypesInternalName Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string TypesInternalName
Public Shared TypesInternalName As String
public:
static String^ TypesInternalName
static val mutable TypesInternalName: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts.TypeSpecifier Field

SyntaxParserConstsTypeSpecifier Field

Namespace: Alternet.Syntax.Parsers.Python
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeSpecifier
Public Const TypeSpecifier As String
public:
literal String^ TypeSpecifier
static val mutable TypeSpecifier: string

Field Value

Type: String
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


SyntaxParserConsts Methods

SyntaxParserConsts Methods

The SyntaxParserConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SyntaxParserConsts Class
Alternet.Syntax.Parsers.Python Namespace


Alternet.Syntax.Parsers.Python.CodeCompletion Namespace

Alternet.Syntax.Parsers.Python.CodeCompletion Namespace
Classes
 | Class | Description
Public class | IronPythonRepository |
Public class | PythonCodeCompletionService |
Public class | PythonListMember | Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Public class | PythonListMembers | Represents data collection related to popup list box controls used to describe C# language code.
Public class | PythonParameterInfo | Represents Parameter Info data related to popup window and popup hint controls used to describe C# language code.
Public class | PythonRepository |
Public class | PythonSymbolExtensions |
Interfaces
 | Interface | Description
Public interface | IPythonRepository |


IPythonRepository Interface

IPythonRepository Interface

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonRepository : ICodeCompletionRepository,
    IDisposable
Public Interface IPythonRepository
    Inherits ICodeCompletionRepository, IDisposable
public interface class IPythonRepository : ICodeCompletionRepository,
    IDisposable
type IPythonRepository =
    interface
        interface ICodeCompletionRepository
        interface IDisposable
    end

The IPythonRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration(IPythonSemanticModel, ISyntaxNode) |
Public method | FindDeclaration(String, ISyntaxNode, Point) | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindReferences | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(IPythonSymbol) |
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetReferences |
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | ListMembers |
Public method | ParameterInfo |
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository Methods

IPythonRepository Methods

The IPythonRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration(IPythonSemanticModel, ISyntaxNode) |
Public method | FindDeclaration(String, ISyntaxNode, Point) | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindReferences | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(IPythonSymbol) |
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetReferences |
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | ListMembers |
Public method | ParameterInfo |
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IPythonRepository Interface
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository.FindDeclaration Method

IPythonRepositoryFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(IPythonSemanticModel, ISyntaxNode) |
Public method | FindDeclaration(String, ISyntaxNode, Point) | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IPythonRepository Interface
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository.FindDeclaration Method (IPythonSemanticModel, ISyntaxNode)

IPythonRepositoryFindDeclaration Method (IPythonSemanticModel, ISyntaxNode)

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonSymbol FindDeclaration(
    IPythonSemanticModel model,
    ISyntaxNode node
)
Function FindDeclaration (
    model As IPythonSemanticModel,
    node As ISyntaxNode
) As IPythonSymbol
IPythonSymbol^ FindDeclaration(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node
)
abstract FindDeclaration :
        model : IPythonSemanticModel *
        node : ISyntaxNode -> IPythonSymbol

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IPythonSymbol
See Also

Reference

IPythonRepository Interface
FindDeclaration Overload
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository.GetQuickInfo Method

IPythonRepositoryGetQuickInfo Method
Overload List
 | Name | Description
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(IPythonSymbol) |
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IPythonRepository Interface
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository.GetQuickInfo Method (IPythonSymbol)

IPythonRepositoryGetQuickInfo Method (IPythonSymbol)

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IQuickInfo GetQuickInfo(
    IPythonSymbol symbol
)
Function GetQuickInfo (
    symbol As IPythonSymbol
) As IQuickInfo
IQuickInfo^ GetQuickInfo(
    IPythonSymbol^ symbol
)
abstract GetQuickInfo :
        symbol : IPythonSymbol -> IQuickInfo

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: IQuickInfo
See Also

Reference

IPythonRepository Interface
GetQuickInfo Overload
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository.GetReferences Method

IPythonRepositoryGetReferences Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<SymbolReference> GetReferences(
    IPythonSemanticModel model,
    ISyntaxNode node
)
Function GetReferences (
    model As IPythonSemanticModel,
    node As ISyntaxNode
) As IList(Of SymbolReference)
IList<SymbolReference^>^ GetReferences(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node
)
abstract GetReferences :
        model : IPythonSemanticModel *
        node : ISyntaxNode -> IList<SymbolReference>

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IListSymbolReference
See Also

Reference

IPythonRepository Interface
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository.ListMembers Method

IPythonRepositoryListMembers Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IListMembers ListMembers(
    IPythonSemanticModel model,
    ISyntaxNode node,
    Point position
)
Function ListMembers (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    position As Point
) As IListMembers
IListMembers^ ListMembers(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    Point position
)
abstract ListMembers :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        position : Point -> IListMembers

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
position
Type: System.DrawingPoint

Return Value

Type: IListMembers
See Also

Reference

IPythonRepository Interface
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository.ParameterInfo Method

IPythonRepositoryParameterInfo Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IParameterInfo ParameterInfo(
    IPythonSemanticModel model,
    ISyntaxNode node,
    int argumentIndex
)
Function ParameterInfo (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    argumentIndex As Integer
) As IParameterInfo
IParameterInfo^ ParameterInfo(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    int argumentIndex
)
abstract ParameterInfo :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        argumentIndex : int -> IParameterInfo

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
argumentIndex
Type: SystemInt32

Return Value

Type: IParameterInfo
See Also

Reference

IPythonRepository Interface
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository Properties

IPythonRepository Properties

The IPythonRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IPythonRepository Interface
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IPythonRepository Events

IPythonRepository Events

The IPythonRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IPythonRepository Interface
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IronPythonRepository Class

IronPythonRepository Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.Python.CodeCompletionPythonRepository
Alternet.Syntax.Parsers.Python.CodeCompletionIronPythonRepository

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonRepository : PythonRepository
Public Class IronPythonRepository
    Inherits PythonRepository
public ref class IronPythonRepository : public PythonRepository
type IronPythonRepository =
    class
        inherit PythonRepository
    end

The IronPythonRepository type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonRepository | Initializes a new instance of the CsRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(IPythonSemanticModel, ISyntaxNode) | (Inherited from PythonRepository.)
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(IPythonSymbol) | Returns information about the object. (Inherited from PythonRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetReferences | (Inherited from PythonRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ListMembers | (Inherited from PythonRepository.)
Public method | ParameterInfo | (Inherited from PythonRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from PythonRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from PythonRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IronPythonRepository Constructor

IronPythonRepository Constructor
Initializes a new instance of the CsRepository class with specified settings.

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonRepository(
    ISyntaxParser owner,
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    owner As ISyntaxParser,
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
IronPythonRepository(
    ISyntaxParser^ owner,
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        owner : ISyntaxParser *
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> IronPythonRepository

Parameters

owner
Type: Alternet.SyntaxISyntaxParser
caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

IronPythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IronPythonRepository Methods

IronPythonRepository Methods

The IronPythonRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(IPythonSemanticModel, ISyntaxNode) | (Inherited from PythonRepository.)
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(IPythonSymbol) | Returns information about the object. (Inherited from PythonRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetReferences | (Inherited from PythonRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ListMembers | (Inherited from PythonRepository.)
Public method | ParameterInfo | (Inherited from PythonRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

IronPythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IronPythonRepository Properties

IronPythonRepository Properties

The IronPythonRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from PythonRepository.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Inherited from PythonRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

IronPythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


IronPythonRepository Events

IronPythonRepository Events

The IronPythonRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

IronPythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonCodeCompletionService Class

PythonCodeCompletionService Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.CodeCompletionPythonCodeCompletionService

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonCodeCompletionService
Public Class PythonCodeCompletionService
public ref class PythonCodeCompletionService
type PythonCodeCompletionService =  class end

The PythonCodeCompletionService type exposes the following members.

Constructors
 | Name | Description
Public method | PythonCodeCompletionService | Initializes a new instance of the PythonCodeCompletionService class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetContextSymbols |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSignatureSymbols |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonCodeCompletionService Constructor

PythonCodeCompletionService Constructor
Initializes a new instance of the PythonCodeCompletionService class

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonCodeCompletionService()
Public Sub New
public:
PythonCodeCompletionService()
new : unit -> PythonCodeCompletionService
See Also

Reference

PythonCodeCompletionService Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonCodeCompletionService Methods

PythonCodeCompletionService Methods

The PythonCodeCompletionService type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetContextSymbols |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSignatureSymbols |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonCodeCompletionService Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonCodeCompletionService.GetContextSymbols Method

PythonCodeCompletionServiceGetContextSymbols Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<IPythonSymbol> GetContextSymbols(
    IPythonSemanticModel model,
    ISyntaxNode node,
    Point position
)
Public Overridable Function GetContextSymbols (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    position As Point
) As IList(Of IPythonSymbol)
public:
virtual IList<IPythonSymbol^>^ GetContextSymbols(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    Point position
)
abstract GetContextSymbols :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        position : Point -> IList<IPythonSymbol>
override GetContextSymbols :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        position : Point -> IList<IPythonSymbol>

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
position
Type: System.DrawingPoint

Return Value

Type: IListIPythonSymbol
See Also

Reference

PythonCodeCompletionService Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonCodeCompletionService.GetSignatureSymbols Method

PythonCodeCompletionServiceGetSignatureSymbols Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<IPythonSymbol> GetSignatureSymbols(
    IPythonSemanticModel model,
    ISyntaxNode node
)
Public Overridable Function GetSignatureSymbols (
    model As IPythonSemanticModel,
    node As ISyntaxNode
) As IList(Of IPythonSymbol)
public:
virtual IList<IPythonSymbol^>^ GetSignatureSymbols(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node
)
abstract GetSignatureSymbols :
        model : IPythonSemanticModel *
        node : ISyntaxNode -> IList<IPythonSymbol>
override GetSignatureSymbols :
        model : IPythonSemanticModel *
        node : ISyntaxNode -> IList<IPythonSymbol>

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IListIPythonSymbol
See Also

Reference

PythonCodeCompletionService Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMember Class

PythonListMember Class
Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.Parsers.Python.CodeCompletionPythonListMember

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonListMember : ListMember
Public Class PythonListMember
    Inherits ListMember
public ref class PythonListMember : public ListMember
type PythonListMember =
    class
        inherit ListMember
    end

The PythonListMember type exposes the following members.

Constructors
 | Name | Description
Public method | PythonListMember | Initializes a new instance of the PythonListMember class
Public method | PythonListMember(IListMembers) | Initializes a new instance of the PythonListMember class
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Gets or sets a string value that specifies short description of the ListMember. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMember Constructor

PythonListMember Constructor
Overload List
 | Name | Description
Public method | PythonListMember | Initializes a new instance of the PythonListMember class
Public method | PythonListMember(IListMembers) | Initializes a new instance of the PythonListMember class
Top
See Also

Reference

PythonListMember Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMember Constructor

PythonListMember Constructor
Initializes a new instance of the PythonListMember class

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonListMember()
Public Sub New
public:
PythonListMember()
new : unit -> PythonListMember
See Also

Reference

PythonListMember Class
PythonListMember Overload
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMember Constructor (IListMembers)

PythonListMember Constructor (IListMembers)
Initializes a new instance of the PythonListMember class

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonListMember(
    IListMembers owner
)
Public Sub New (
    owner As IListMembers
)
public:
PythonListMember(
    IListMembers^ owner
)
new :
        owner : IListMembers -> PythonListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
See Also

Reference

PythonListMember Class
PythonListMember Overload
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMember Methods

PythonListMember Methods

The PythonListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonListMember Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMember.GetParamText Method

PythonListMemberGetParamText Method
Converts Parameters property to a single string.

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetParamText(
    bool useFormatting
)
Public Overrides Function GetParamText (
    useFormatting As Boolean
) As String
public:
virtual String^ GetParamText(
    bool useFormatting
) override
abstract GetParamText :
        useFormatting : bool -> string
override GetParamText :
        useFormatting : bool -> string

Parameters

useFormatting
Type: SystemBoolean
Specifies whether to use html formatting tags.

Return Value

Type: String
Returns Parameters in the form of comma separated text, framed by parentheses.

Implements

IListMemberGetParamText(Boolean)
See Also

Reference

PythonListMember Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMember Properties

PythonListMember Properties

The PythonListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Gets or sets a string value that specifies short description of the ListMember. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

PythonListMember Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMember.Category Property

PythonListMemberCategory Property

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionCategory Category { get; }
Public Overrides ReadOnly Property Category As CodeCompletionCategory
    Get
public:
virtual property CodeCompletionCategory^ Category {
    CodeCompletionCategory^ get () override;
}
abstract Category : CodeCompletionCategory with get
override Category : CodeCompletionCategory with get

Property Value

Type: CodeCompletionCategory

Implements

ICategorizedListMemberCategory
See Also

Reference

PythonListMember Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMember.Description Property

PythonListMemberDescription Property
Gets or sets a string value that specifies short description of the ListMember.

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

IListMemberDescription
See Also

Reference

PythonListMember Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMembers Class

PythonListMembers Class
Represents data collection related to popup list box controls used to describe C# language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.Parsers.Python.CodeCompletionPythonListMembers

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonListMembers : ListMembers
Public Class PythonListMembers
    Inherits ListMembers
public ref class PythonListMembers : public ListMembers
type PythonListMembers =
    class
        inherit ListMembers
    end

The PythonListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | PythonListMembers | Initializes a new instance of the PythonListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides ListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMembers Constructor

PythonListMembers Constructor
Initializes a new instance of the PythonListMembers class

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonListMembers()
Public Sub New
public:
PythonListMembers()
new : unit -> PythonListMembers
See Also

Reference

PythonListMembers Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMembers Methods

PythonListMembers Methods

The PythonListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the CsListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides ListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

PythonListMembers Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMembers.CreateListMember Method

PythonListMembersCreateListMember Method
Initializes a new instance of the CsListMember class with default settings.

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

PythonListMembers Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMembers.GetColumnText Method

PythonListMembersGetColumnText Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
column
Type: SystemInt32

Return Value

Type: String

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

PythonListMembers Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMembers Properties

PythonListMembers Properties

The PythonListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

PythonListMembers Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonListMembers Events

PythonListMembers Events

The PythonListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

PythonListMembers Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonParameterInfo Class

PythonParameterInfo Class
Represents Parameter Info data related to popup window and popup hint controls used to describe C# language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.CodeCompletionParameterInfo
Alternet.Syntax.Parsers.Python.CodeCompletionPythonParameterInfo

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonParameterInfo : ParameterInfo
Public Class PythonParameterInfo
    Inherits ParameterInfo
public ref class PythonParameterInfo : public ParameterInfo
type PythonParameterInfo =
    class
        inherit ParameterInfo
    end

The PythonParameterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParameterInfo | Initializes a new instance of the PythonParameterInfo class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the PythonListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides ListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonParameterInfo Constructor

PythonParameterInfo Constructor
Initializes a new instance of the PythonParameterInfo class

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonParameterInfo()
Public Sub New
public:
PythonParameterInfo()
new : unit -> PythonParameterInfo
See Also

Reference

PythonParameterInfo Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonParameterInfo Methods

PythonParameterInfo Methods

The PythonParameterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the PythonListMember class with default settings. (Overrides ListMembersCreateListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | (Overrides ListMembersGetColumnText(Int32, Int32).)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

PythonParameterInfo Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonParameterInfo.CreateListMember Method

PythonParameterInfoCreateListMember Method
Initializes a new instance of the PythonListMember class with default settings.

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IListMember CreateListMember()
Public Overrides Function CreateListMember As IListMember
public:
virtual IListMember^ CreateListMember() override
abstract CreateListMember : unit -> IListMember
override CreateListMember : unit -> IListMember

Return Value

Type: IListMember
IListMember that represents this new instance.

Implements

IListMembersCreateListMember
See Also

Reference

PythonParameterInfo Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonParameterInfo.GetColumnText Method

PythonParameterInfoGetColumnText Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetColumnText(
    int index,
    int column
)
Public Overrides Function GetColumnText (
    index As Integer,
    column As Integer
) As String
public:
virtual String^ GetColumnText(
    int index,
    int column
) override
abstract GetColumnText :
        index : int *
        column : int -> string
override GetColumnText :
        index : int *
        column : int -> string

Parameters

index
Type: SystemInt32
column
Type: SystemInt32

Return Value

Type: String

Implements

ICodeCompletionProviderGetColumnText(Int32, Int32)
ICodeCompletionProviderGetColumnText(Int32, Int32)
See Also

Reference

PythonParameterInfo Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonParameterInfo Properties

PythonParameterInfo Properties

The PythonParameterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from ParameterInfo.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

PythonParameterInfo Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonParameterInfo Events

PythonParameterInfo Events

The PythonParameterInfo type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

PythonParameterInfo Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository Class

PythonRepository Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.Python.CodeCompletionPythonRepository
Alternet.Syntax.Parsers.Python.CodeCompletionIronPythonRepository

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonRepository : CodeCompletionRepository,
    IPythonRepository, ICodeCompletionRepository, IDisposable
Public Class PythonRepository
    Inherits CodeCompletionRepository
    Implements IPythonRepository, ICodeCompletionRepository, IDisposable
public ref class PythonRepository : public CodeCompletionRepository,
    IPythonRepository, ICodeCompletionRepository, IDisposable
type PythonRepository =
    class
        inherit CodeCompletionRepository
        interface IPythonRepository
        interface ICodeCompletionRepository
        interface IDisposable
    end

The PythonRepository type exposes the following members.

Constructors
 | Name | Description
Public method | PythonRepository | Initializes a new instance of the CsRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(IPythonSemanticModel, ISyntaxNode) |
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(IPythonSymbol) | Returns information about the object.
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetReferences |
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ListMembers |
Public method | ParameterInfo |
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository Constructor

PythonRepository Constructor
Initializes a new instance of the CsRepository class with specified settings.

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonRepository(
    ISyntaxParser owner,
    bool caseSensitive,
    ISyntaxTree syntaxTree
)
Public Sub New (
    owner As ISyntaxParser,
    caseSensitive As Boolean,
    syntaxTree As ISyntaxTree
)
public:
PythonRepository(
    ISyntaxParser^ owner,
    bool caseSensitive,
    ISyntaxTree^ syntaxTree
)
new :
        owner : ISyntaxParser *
        caseSensitive : bool *
        syntaxTree : ISyntaxTree -> PythonRepository

Parameters

owner
Type: Alternet.SyntaxISyntaxParser
caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository Methods

PythonRepository Methods

The PythonRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(IPythonSemanticModel, ISyntaxNode) |
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(IPythonSymbol) | Returns information about the object.
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetReferences |
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ListMembers |
Public method | ParameterInfo |
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository.FindDeclaration Method

PythonRepositoryFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(IPythonSemanticModel, ISyntaxNode) |
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository.FindDeclaration Method (IPythonSemanticModel, ISyntaxNode)

PythonRepositoryFindDeclaration Method (IPythonSemanticModel, ISyntaxNode)

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPythonSymbol FindDeclaration(
    IPythonSemanticModel model,
    ISyntaxNode node
)
Public Overridable Function FindDeclaration (
    model As IPythonSemanticModel,
    node As ISyntaxNode
) As IPythonSymbol
public:
virtual IPythonSymbol^ FindDeclaration(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node
)
abstract FindDeclaration :
        model : IPythonSemanticModel *
        node : ISyntaxNode -> IPythonSymbol
override FindDeclaration :
        model : IPythonSemanticModel *
        node : ISyntaxNode -> IPythonSymbol

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IPythonSymbol

Implements

IPythonRepositoryFindDeclaration(IPythonSemanticModel, ISyntaxNode)
See Also

Reference

PythonRepository Class
FindDeclaration Overload
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository.GetQuickInfo Method

PythonRepositoryGetQuickInfo Method
Overload List
 | Name | Description
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(IPythonSymbol) | Returns information about the object.
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository.GetQuickInfo Method (IPythonSymbol)

PythonRepositoryGetQuickInfo Method (IPythonSymbol)
Returns information about the object.

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IQuickInfo GetQuickInfo(
    IPythonSymbol symbol
)
Public Overridable Function GetQuickInfo (
    symbol As IPythonSymbol
) As IQuickInfo
public:
virtual IQuickInfo^ GetQuickInfo(
    IPythonSymbol^ symbol
)
abstract GetQuickInfo :
        symbol : IPythonSymbol -> IQuickInfo
override GetQuickInfo :
        symbol : IPythonSymbol -> IQuickInfo

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: IQuickInfo
IQuickInfo instance.

Implements

IPythonRepositoryGetQuickInfo(IPythonSymbol)
See Also

Reference

PythonRepository Class
GetQuickInfo Overload
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository.GetReferences Method

PythonRepositoryGetReferences Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<SymbolReference> GetReferences(
    IPythonSemanticModel model,
    ISyntaxNode node
)
Public Overridable Function GetReferences (
    model As IPythonSemanticModel,
    node As ISyntaxNode
) As IList(Of SymbolReference)
public:
virtual IList<SymbolReference^>^ GetReferences(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node
)
abstract GetReferences :
        model : IPythonSemanticModel *
        node : ISyntaxNode -> IList<SymbolReference>
override GetReferences :
        model : IPythonSemanticModel *
        node : ISyntaxNode -> IList<SymbolReference>

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IListSymbolReference

Implements

IPythonRepositoryGetReferences(IPythonSemanticModel, ISyntaxNode)
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository.ListMembers Method

PythonRepositoryListMembers Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IListMembers ListMembers(
    IPythonSemanticModel model,
    ISyntaxNode node,
    Point position
)
Public Overridable Function ListMembers (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    position As Point
) As IListMembers
public:
virtual IListMembers^ ListMembers(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    Point position
)
abstract ListMembers :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        position : Point -> IListMembers
override ListMembers :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        position : Point -> IListMembers

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
position
Type: System.DrawingPoint

Return Value

Type: IListMembers

Implements

IPythonRepositoryListMembers(IPythonSemanticModel, ISyntaxNode, Point)
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository.ParameterInfo Method

PythonRepositoryParameterInfo Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IParameterInfo ParameterInfo(
    IPythonSemanticModel model,
    ISyntaxNode node,
    int argumentIndex
)
Public Overridable Function ParameterInfo (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    argumentIndex As Integer
) As IParameterInfo
public:
virtual IParameterInfo^ ParameterInfo(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    int argumentIndex
)
abstract ParameterInfo :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        argumentIndex : int -> IParameterInfo
override ParameterInfo :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        argumentIndex : int -> IParameterInfo

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
argumentIndex
Type: SystemInt32

Return Value

Type: IParameterInfo

Implements

IPythonRepositoryParameterInfo(IPythonSemanticModel, ISyntaxNode, Int32)
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository Properties

PythonRepository Properties

The PythonRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository.Images Property

PythonRepositoryImages Property
Represents collection of images used for code completion.

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; }
Public Overrides ReadOnly Property Images As ImageList
    Get
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
}
abstract Images : ImageList with get
override Images : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImages
ICodeCompletionRepositoryImages
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository.ImagesHighDpi Property

PythonRepositoryImagesHighDpi Property
Represents collection of images used for code completion for high DPI.

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList ImagesHighDpi { get; }
Public Overrides ReadOnly Property ImagesHighDpi As ImageList
    Get
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get () override;
}
abstract ImagesHighDpi : ImageList with get
override ImagesHighDpi : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImagesHighDpi
ICodeCompletionRepositoryImagesHighDpi
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonRepository Events

PythonRepository Events

The PythonRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

PythonRepository Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonSymbolExtensions Class

PythonSymbolExtensions Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.CodeCompletionPythonSymbolExtensions

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PythonSymbolExtensions
<ExtensionAttribute>
Public NotInheritable Class PythonSymbolExtensions
[ExtensionAttribute]
public ref class PythonSymbolExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type PythonSymbolExtensions =  class end

The PythonSymbolExtensions type exposes the following members.

Methods
Name | Description
GetDataType |
GetDisplayName(IPythonMethodSymbol, Boolean, Color) |
GetDisplayName(IPythonSymbol, Boolean, Color) |
GetParamText |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonSymbolExtensions Methods

PythonSymbolExtensions Methods

The PythonSymbolExtensions type exposes the following members.

Methods
Name | Description
GetDataType |
GetDisplayName(IPythonMethodSymbol, Boolean, Color) |
GetDisplayName(IPythonSymbol, Boolean, Color) |
GetParamText |
Top
See Also

Reference

PythonSymbolExtensions Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonSymbolExtensions.GetDataType Method

PythonSymbolExtensionsGetDataType Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDataType(
    this IPythonSymbol symbol,
    bool useFormatting,
    Color[] colors
)
<ExtensionAttribute>
Public Shared Function GetDataType (
    symbol As IPythonSymbol,
    useFormatting As Boolean,
    colors As Color()
) As String
public:
[ExtensionAttribute]
static String^ GetDataType(
    IPythonSymbol^ symbol,
    bool useFormatting,
    array<Color>^ colors
)
[<ExtensionAttribute>]
static member GetDataType :
        symbol : IPythonSymbol *
        useFormatting : bool *
        colors : Color[] -> string

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
useFormatting
Type: SystemBoolean
colors
Type: System.DrawingColor

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPythonSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSymbolExtensions Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonSymbolExtensions.GetDisplayName Method

PythonSymbolExtensionsGetDisplayName Method
Overload List
Name | Description
GetDisplayName(IPythonMethodSymbol, Boolean, Color) |
GetDisplayName(IPythonSymbol, Boolean, Color) |
Top
See Also

Reference

PythonSymbolExtensions Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonSymbolExtensions.GetDisplayName Method (IPythonMethodSymbol, Boolean, Color[])

PythonSymbolExtensionsGetDisplayName Method (IPythonMethodSymbol, Boolean, Color)

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDisplayName(
    this IPythonMethodSymbol symbol,
    bool useFormatting,
    Color[] colors
)
<ExtensionAttribute>
Public Shared Function GetDisplayName (
    symbol As IPythonMethodSymbol,
    useFormatting As Boolean,
    colors As Color()
) As String
public:
[ExtensionAttribute]
static String^ GetDisplayName(
    IPythonMethodSymbol^ symbol,
    bool useFormatting,
    array<Color>^ colors
)
[<ExtensionAttribute>]
static member GetDisplayName :
        symbol : IPythonMethodSymbol *
        useFormatting : bool *
        colors : Color[] -> string

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonMethodSymbol
useFormatting
Type: SystemBoolean
colors
Type: System.DrawingColor

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPythonMethodSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSymbolExtensions Class
GetDisplayName Overload
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonSymbolExtensions.GetDisplayName Method (IPythonSymbol, Boolean, Color[])

PythonSymbolExtensionsGetDisplayName Method (IPythonSymbol, Boolean, Color)

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDisplayName(
    this IPythonSymbol symbol,
    bool useFormatting,
    Color[] colors
)
<ExtensionAttribute>
Public Shared Function GetDisplayName (
    symbol As IPythonSymbol,
    useFormatting As Boolean,
    colors As Color()
) As String
public:
[ExtensionAttribute]
static String^ GetDisplayName(
    IPythonSymbol^ symbol,
    bool useFormatting,
    array<Color>^ colors
)
[<ExtensionAttribute>]
static member GetDisplayName :
        symbol : IPythonSymbol *
        useFormatting : bool *
        colors : Color[] -> string

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
useFormatting
Type: SystemBoolean
colors
Type: System.DrawingColor

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPythonSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSymbolExtensions Class
GetDisplayName Overload
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


PythonSymbolExtensions.GetParamText Method

PythonSymbolExtensionsGetParamText Method

Namespace: Alternet.Syntax.Parsers.Python.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetParamText(
    this IPythonParameterSymbol symbol,
    bool useFormatting,
    Color[] colors
)
<ExtensionAttribute>
Public Shared Function GetParamText (
    symbol As IPythonParameterSymbol,
    useFormatting As Boolean,
    colors As Color()
) As String
public:
[ExtensionAttribute]
static String^ GetParamText(
    IPythonParameterSymbol^ symbol,
    bool useFormatting,
    array<Color>^ colors
)
[<ExtensionAttribute>]
static member GetParamText :
        symbol : IPythonParameterSymbol *
        useFormatting : bool *
        colors : Color[] -> string

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonParameterSymbol
useFormatting
Type: SystemBoolean
colors
Type: System.DrawingColor

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPythonParameterSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSymbolExtensions Class
Alternet.Syntax.Parsers.Python.CodeCompletion Namespace


Alternet.Syntax.Parsers.Python.SemanticModel Namespace

Alternet.Syntax.Parsers.Python.SemanticModel Namespace
Classes
 | Class | Description
Public class | DescriptionHelper | Provides methods to get member's description.
Public class | DescriptionHelperDescriptionInfo |
Public class | IronPythonEventSymbol |
Public class | IronPythonFieldSymbol |
Public class | IronPythonMethodSymbol |
Public class | IronPythonModuleContext |
Public class | IronPythonModuleLoader |
Public class | IronPythonModuleSymbol |
Public class | IronPythonPropertySymbol |
Public class | IronPythonSemanticModel |
Public class | IronPythonTypeResolver |
Public class | IronPythonTypeSymbol |
Public class | PythonAliasSymbol |
Public class | PythonBlockContext |
Public class | PythonBlockSymbol |
Public class | PythonBuiltinFunctions |
Public class | PythonClassContext |
Public class | PythonClassifier |
Public class | PythonClassifierLineToken |
Public class | PythonClassifierPythonTokenizer |
Public class | PythonClassifierTokenList |
Public class | PythonClassSymbol |
Public class | PythonContext |
Public class | PythonDictTypeSymbol |
Public class | PythonFieldSymbol |
Public class | PythonFileTypeSymbol |
Public class | PythonForStatementContext |
Public class | PythonImportSymbol |
Public class | PythonLambdaContext |
Public class | PythonListTypeSymbol |
Public class | PythonLocalVariableSymbol |
Public class | PythonMethodContext |
Public class | PythonMethodSymbol |
Public class | PythonModuleContext |
Public class | PythonModuleLoader |
Public class | PythonModuleSymbol |
Public class | PythonObjectTypeSymbol |
Public class | PythonParameterSymbol |
Public class | PythonPrimitiveTypeSymbol |
Public class | PythonSemanticModel |
Public class | PythonSetTypeSymbol |
Public class | PythonStringTypeSymbol |
Public class | PythonStructSymbol |
Public class | PythonSymbol |
Public class | PythonTupleTypeSymbol |
Public class | PythonTypeChecker |
Public class | PythonTypeSymbol |
Public class | SymbolReference |
Public class | SyntaxNodeExtensions |
Interfaces
 | Interface | Description
Public interface | IPythonAliasSymbol |
Public interface | IPythonBlockSymbol |
Public interface | IPythonClassifier |
Public interface | IPythonClassSymbol |
Public interface | IPythonFieldSymbol |
Public interface | IPythonImportSymbol |
Public interface | IPythonLocalVariableSymbol |
Public interface | IPythonMethodSymbol |
Public interface | IPythonModuleSymbol |
Public interface | IPythonParameterSymbol |
Public interface | IPythonSemanticModel |
Public interface | IPythonSymbol |
Public interface | IPythonTypeSymbol |
Enumerations
 | Enumeration | Description
Public enumeration | PythonScope |
Public enumeration | PythonSymbolKind |


DescriptionHelper Class

DescriptionHelper Class
Provides methods to get member's description.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelDescriptionHelper

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DescriptionHelper
Public Class DescriptionHelper
public ref class DescriptionHelper
type DescriptionHelper =  class end

The DescriptionHelper type exposes the following members.

Constructors
 | Name | Description
Public method | DescriptionHelper | Initializes a new instance of the DescriptionHelper class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetDescription(MemberInfo) | Obtains description of the specified MemberInfo.
 | GetDescription(ParameterInfo) | Obtains description of the specified ParameterInfo.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPriority | Obtains priority of the specified MemberInfo.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAssembly(Assembly) | Loads content of the specified assembly.
 | LoadAssembly(Assembly, Stream) | Loads content of the specified assembly.
 | LookupLocalizedXmlDoc |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadAssembly | Removes the specified assembly from the assembly collection.
Top
Properties
Name | Description
CustomXMLDocPath | Gets a custom xml documentation path.
Enabled | Gets or sets a boolean value indicating whether DescriptionHelper should obtain descriptions from assemblies.
SystemAssemblyFolders | Represents directory information where system assembly stored.
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper Constructor

DescriptionHelper Constructor
Initializes a new instance of the DescriptionHelper class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DescriptionHelper()
Public Sub New
public:
DescriptionHelper()
new : unit -> DescriptionHelper
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper Methods

DescriptionHelper Methods

The DescriptionHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetDescription(MemberInfo) | Obtains description of the specified MemberInfo.
 | GetDescription(ParameterInfo) | Obtains description of the specified ParameterInfo.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetPriority | Obtains priority of the specified MemberInfo.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAssembly(Assembly) | Loads content of the specified assembly.
 | LoadAssembly(Assembly, Stream) | Loads content of the specified assembly.
 | LookupLocalizedXmlDoc |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadAssembly | Removes the specified assembly from the assembly collection.
Top
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.GetDescription Method

DescriptionHelperGetDescription Method
Overload List
Name | Description
GetDescription(MemberInfo) | Obtains description of the specified MemberInfo.
GetDescription(ParameterInfo) | Obtains description of the specified ParameterInfo.
Top
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.GetDescription Method (MemberInfo)

DescriptionHelperGetDescription Method (MemberInfo)
Obtains description of the specified MemberInfo.

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDescription(
    MemberInfo info
)
Public Shared Function GetDescription (
    info As MemberInfo
) As String
public:
static String^ GetDescription(
    MemberInfo^ info
)
static member GetDescription :
        info : MemberInfo -> string

Parameters

info
Type: System.ReflectionMemberInfo
MemberInfo to evaluate.

Return Value

Type: String
String that describes specified MemberInfo.
See Also

Reference

DescriptionHelper Class
GetDescription Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.GetDescription Method (ParameterInfo)

DescriptionHelperGetDescription Method (ParameterInfo)
Obtains description of the specified ParameterInfo.

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDescription(
    ParameterInfo pinfo
)
Public Shared Function GetDescription (
    pinfo As ParameterInfo
) As String
public:
static String^ GetDescription(
    ParameterInfo^ pinfo
)
static member GetDescription :
        pinfo : ParameterInfo -> string

Parameters

pinfo
Type: System.ReflectionParameterInfo
ParameterInfo to evaluate.

Return Value

Type: String
String that describes specified ParameterInfo.
See Also

Reference

DescriptionHelper Class
GetDescription Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.GetPriority Method

DescriptionHelperGetPriority Method
Obtains priority of the specified MemberInfo.

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetPriority(
    MemberInfo info
)
Public Shared Function GetPriority (
    info As MemberInfo
) As Integer
public:
static int GetPriority(
    MemberInfo^ info
)
static member GetPriority :
        info : MemberInfo -> int

Parameters

info
Type: System.ReflectionMemberInfo
MemberInfo to evaluate.

Return Value

Type: Int32
Integer value that specifies priority of given MemberInfo.
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.LoadAssembly Method

DescriptionHelperLoadAssembly Method
Overload List
Name | Description
LoadAssembly(Assembly) | Loads content of the specified assembly.
LoadAssembly(Assembly, Stream) | Loads content of the specified assembly.
Top
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.LoadAssembly Method (Assembly)

DescriptionHelperLoadAssembly Method (Assembly)
Loads content of the specified assembly.

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DescriptionHelperDescriptionInfo LoadAssembly(
    Assembly assembly
)
Public Shared Function LoadAssembly (
    assembly As Assembly
) As DescriptionHelperDescriptionInfo
public:
static DescriptionHelperDescriptionInfo^ LoadAssembly(
    Assembly^ assembly
)
static member LoadAssembly :
        assembly : Assembly -> DescriptionHelperDescriptionInfo

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to load.

Return Value

Type: DescriptionHelperDescriptionInfo
True if succeed; otherwise false.
See Also

Reference

DescriptionHelper Class
LoadAssembly Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.LoadAssembly Method (Assembly, Stream)

DescriptionHelperLoadAssembly Method (Assembly, Stream)
Loads content of the specified assembly.

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void LoadAssembly(
    Assembly assembly,
    Stream stream
)
Public Shared Sub LoadAssembly (
    assembly As Assembly,
    stream As Stream
)
public:
static void LoadAssembly(
    Assembly^ assembly,
    Stream^ stream
)
static member LoadAssembly :
        assembly : Assembly *
        stream : Stream -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to load.
stream
Type: System.IOStream
The location of the XML file.

Return Value

Type:
True if succeed; otherwise false.
See Also

Reference

DescriptionHelper Class
LoadAssembly Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.LookupLocalizedXmlDoc Method

DescriptionHelperLookupLocalizedXmlDoc Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string LookupLocalizedXmlDoc(
    string fileName
)
Public Shared Function LookupLocalizedXmlDoc (
    fileName As String
) As String
public:
static String^ LookupLocalizedXmlDoc(
    String^ fileName
)
static member LookupLocalizedXmlDoc :
        fileName : string -> string

Parameters

fileName
Type: SystemString

Return Value

Type: String
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.UnloadAssembly Method

DescriptionHelperUnloadAssembly Method
Removes the specified assembly from the assembly collection.

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnloadAssembly(
    Assembly assembly
)
Public Shared Sub UnloadAssembly (
    assembly As Assembly
)
public:
static void UnloadAssembly(
    Assembly^ assembly
)
static member UnloadAssembly :
        assembly : Assembly -> unit

Parameters

assembly
Type: System.ReflectionAssembly
Assembly to unload.
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper Properties

DescriptionHelper Properties

The DescriptionHelper type exposes the following members.

Properties
Name | Description
CustomXMLDocPath | Gets a custom xml documentation path.
Enabled | Gets or sets a boolean value indicating whether DescriptionHelper should obtain descriptions from assemblies.
SystemAssemblyFolders | Represents directory information where system assembly stored.
Top
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.CustomXMLDocPath Property

DescriptionHelperCustomXMLDocPath Property
Gets a custom xml documentation path.

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CustomXMLDocPath { get; set; }
Public Shared Property CustomXMLDocPath As String
    Get
    Set
public:
static property String^ CustomXMLDocPath {
    String^ get ();
    void set (String^ value);
}
static member CustomXMLDocPath : string with get, set

Property Value

Type: String
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.Enabled Property

DescriptionHelperEnabled Property
Gets or sets a boolean value indicating whether DescriptionHelper should obtain descriptions from assemblies.

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Enabled { get; set; }
Public Shared Property Enabled As Boolean
    Get
    Set
public:
static property bool Enabled {
    bool get ();
    void set (bool value);
}
static member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.SystemAssemblyFolders Property

DescriptionHelperSystemAssemblyFolders Property
Represents directory information where system assembly stored.

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> SystemAssemblyFolders { get; }
Public Shared ReadOnly Property SystemAssemblyFolders As IList(Of String)
    Get
public:
static property IList<String^>^ SystemAssemblyFolders {
    IList<String^>^ get ();
}
static member SystemAssemblyFolders : IList<string> with get

Property Value

Type: IListString
See Also

Reference

DescriptionHelper Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.DescriptionInfo Class

DescriptionHelperDescriptionInfo Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelDescriptionHelperDescriptionInfo

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DescriptionInfo
Public Class DescriptionInfo
public ref class DescriptionInfo
type DescriptionInfo =  class end

The DescriptionHelperDescriptionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DescriptionHelperDescriptionInfo | Initializes a new instance of the DescriptionHelperDescriptionInfo class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Descriptions |
Public property | Priorities |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.DescriptionInfo Constructor

DescriptionHelperDescriptionInfo Constructor
Initializes a new instance of the DescriptionHelperDescriptionInfo class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DescriptionInfo()
Public Sub New
public:
DescriptionInfo()
new : unit -> DescriptionInfo
See Also

Reference

DescriptionHelperDescriptionInfo Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionInfo Methods

DescriptionInfo Methods

The DescriptionHelperDescriptionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DescriptionHelperDescriptionInfo Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionInfo Properties

DescriptionInfo Properties

The DescriptionHelperDescriptionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Descriptions |
Public property | Priorities |
Top
See Also

Reference

DescriptionHelperDescriptionInfo Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.DescriptionInfo.Descriptions Property

DescriptionHelperDescriptionInfoDescriptions Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hashtable Descriptions { get; }
Public ReadOnly Property Descriptions As Hashtable
    Get
public:
property Hashtable^ Descriptions {
    Hashtable^ get ();
}
member Descriptions : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

DescriptionHelperDescriptionInfo Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


DescriptionHelper.DescriptionInfo.Priorities Property

DescriptionHelperDescriptionInfoPriorities Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Hashtable Priorities { get; }
Public ReadOnly Property Priorities As Hashtable
    Get
public:
property Hashtable^ Priorities {
    Hashtable^ get ();
}
member Priorities : Hashtable with get

Property Value

Type: Hashtable
See Also

Reference

DescriptionHelperDescriptionInfo Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonAliasSymbol Interface

IPythonAliasSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonAliasSymbol : IPythonSymbol
Public Interface IPythonAliasSymbol
    Inherits IPythonSymbol
public interface class IPythonAliasSymbol : IPythonSymbol
type IPythonAliasSymbol =
    interface
        interface IPythonSymbol
    end

The IPythonAliasSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | ReferenceSymbol |
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonAliasSymbol Methods

IPythonAliasSymbol Methods

The IPythonAliasSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonAliasSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonAliasSymbol Properties

IPythonAliasSymbol Properties

The IPythonAliasSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | ReferenceSymbol |
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

IPythonAliasSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonAliasSymbol.ReferenceSymbol Property

IPythonAliasSymbolReferenceSymbol Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonSymbol ReferenceSymbol { get; }
ReadOnly Property ReferenceSymbol As IPythonSymbol
    Get
property IPythonSymbol^ ReferenceSymbol {
    IPythonSymbol^ get ();
}
abstract ReferenceSymbol : IPythonSymbol with get

Property Value

Type: IPythonSymbol
See Also

Reference

IPythonAliasSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonBlockSymbol Interface

IPythonBlockSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonBlockSymbol : IPythonSymbol
Public Interface IPythonBlockSymbol
    Inherits IPythonSymbol
public interface class IPythonBlockSymbol : IPythonSymbol
type IPythonBlockSymbol =
    interface
        interface IPythonSymbol
    end

The IPythonBlockSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | BlockMembers |
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonBlockSymbol Methods

IPythonBlockSymbol Methods

The IPythonBlockSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonBlockSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonBlockSymbol Properties

IPythonBlockSymbol Properties

The IPythonBlockSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BlockMembers |
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

IPythonBlockSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonBlockSymbol.BlockMembers Property

IPythonBlockSymbolBlockMembers Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<IPythonSymbol> BlockMembers { get; set; }
Property BlockMembers As IList(Of IPythonSymbol)
    Get
    Set
property IList<IPythonSymbol^>^ BlockMembers {
    IList<IPythonSymbol^>^ get ();
    void set (IList<IPythonSymbol^>^ value);
}
abstract BlockMembers : IList<IPythonSymbol> with get, set

Property Value

Type: IListIPythonSymbol
See Also

Reference

IPythonBlockSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassifier Interface

IPythonClassifier Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonClassifier
Public Interface IPythonClassifier
public interface class IPythonClassifier
type IPythonClassifier =  interface end

The IPythonClassifier type exposes the following members.

Methods
 | Name | Description
Public method | AddSymbol |
Public method | Build |
Public method | ClassifyIdentifier |
Public method | Clear |
Public method | PositionChanged |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassifier Methods

IPythonClassifier Methods

The IPythonClassifier type exposes the following members.

Methods
 | Name | Description
Public method | AddSymbol |
Public method | Build |
Public method | ClassifyIdentifier |
Public method | Clear |
Public method | PositionChanged |
Top
See Also

Reference

IPythonClassifier Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassifier.AddSymbol Method

IPythonClassifierAddSymbol Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddSymbol(
    int x,
    int y,
    int length,
    IPythonSymbol symbol
)
Sub AddSymbol (
    x As Integer,
    y As Integer,
    length As Integer,
    symbol As IPythonSymbol
)
void AddSymbol(
    int x,
    int y,
    int length,
    IPythonSymbol^ symbol
)
abstract AddSymbol :
        x : int *
        y : int *
        length : int *
        symbol : IPythonSymbol -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
length
Type: SystemInt32
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

IPythonClassifier Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassifier.Build Method

IPythonClassifierBuild Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Build(
    ISyntaxNode root,
    IPythonSemanticModel model
)
Sub Build (
    root As ISyntaxNode,
    model As IPythonSemanticModel
)
void Build(
    ISyntaxNode^ root,
    IPythonSemanticModel^ model
)
abstract Build :
        root : ISyntaxNode *
        model : IPythonSemanticModel -> unit

Parameters

root
Type: Alternet.SyntaxISyntaxNode
model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
See Also

Reference

IPythonClassifier Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassifier.ClassifyIdentifier Method

IPythonClassifierClassifyIdentifier Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int ClassifyIdentifier(
    int x,
    int y,
    string identifier
)
Function ClassifyIdentifier (
    x As Integer,
    y As Integer,
    identifier As String
) As Integer
int ClassifyIdentifier(
    int x,
    int y,
    String^ identifier
)
abstract ClassifyIdentifier :
        x : int *
        y : int *
        identifier : string -> int

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
identifier
Type: SystemString

Return Value

Type: Int32
See Also

Reference

IPythonClassifier Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassifier.Clear Method

IPythonClassifierClear Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

IPythonClassifier Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassifier.PositionChanged Method

IPythonClassifierPositionChanged Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    char ch
)
Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ch As Char
)
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    wchar_t ch
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaX
Type: SystemInt32
deltaY
Type: SystemInt32
ch
Type: SystemChar
See Also

Reference

IPythonClassifier Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassSymbol Interface

IPythonClassSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonClassSymbol : IPythonTypeSymbol,
    IPythonSymbol
Public Interface IPythonClassSymbol
    Inherits IPythonTypeSymbol, IPythonSymbol
public interface class IPythonClassSymbol : IPythonTypeSymbol,
    IPythonSymbol
type IPythonClassSymbol =
    interface
        interface IPythonTypeSymbol
        interface IPythonSymbol
    end

The IPythonClassSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField |
Public method | FindMember |
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | BaseType |
Public property | Constructor |
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Members |
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassSymbol Methods

IPythonClassSymbol Methods

The IPythonClassSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField |
Public method | FindMember |
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonClassSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassSymbol.AddField Method

IPythonClassSymbolAddField Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddField(
    string fieldName
)
Sub AddField (
    fieldName As String
)
void AddField(
    String^ fieldName
)
abstract AddField :
        fieldName : string -> unit

Parameters

fieldName
Type: SystemString
See Also

Reference

IPythonClassSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassSymbol.FindMember Method

IPythonClassSymbolFindMember Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonSymbol FindMember(
    string name
)
Function FindMember (
    name As String
) As IPythonSymbol
IPythonSymbol^ FindMember(
    String^ name
)
abstract FindMember :
        name : string -> IPythonSymbol

Parameters

name
Type: SystemString

Return Value

Type: IPythonSymbol
See Also

Reference

IPythonClassSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassSymbol Properties

IPythonClassSymbol Properties

The IPythonClassSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType |
Public property | Constructor |
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Members |
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

IPythonClassSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassSymbol.BaseType Property

IPythonClassSymbolBaseType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonClassSymbol BaseType { get; set; }
Property BaseType As IPythonClassSymbol
    Get
    Set
property IPythonClassSymbol^ BaseType {
    IPythonClassSymbol^ get ();
    void set (IPythonClassSymbol^ value);
}
abstract BaseType : IPythonClassSymbol with get, set

Property Value

Type: IPythonClassSymbol
See Also

Reference

IPythonClassSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassSymbol.Constructor Property

IPythonClassSymbolConstructor Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonSymbol Constructor { get; }
ReadOnly Property Constructor As IPythonSymbol
    Get
property IPythonSymbol^ Constructor {
    IPythonSymbol^ get ();
}
abstract Constructor : IPythonSymbol with get

Property Value

Type: IPythonSymbol
See Also

Reference

IPythonClassSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonClassSymbol.Members Property

IPythonClassSymbolMembers Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<IPythonSymbol> Members { get; }
ReadOnly Property Members As IList(Of IPythonSymbol)
    Get
property IList<IPythonSymbol^>^ Members {
    IList<IPythonSymbol^>^ get ();
}
abstract Members : IList<IPythonSymbol> with get

Property Value

Type: IListIPythonSymbol
See Also

Reference

IPythonClassSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonFieldSymbol Interface

IPythonFieldSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonFieldSymbol : IPythonSymbol
Public Interface IPythonFieldSymbol
    Inherits IPythonSymbol
public interface class IPythonFieldSymbol : IPythonSymbol
type IPythonFieldSymbol =
    interface
        interface IPythonSymbol
    end

The IPythonFieldSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | FieldType |
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonFieldSymbol Methods

IPythonFieldSymbol Methods

The IPythonFieldSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonFieldSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonFieldSymbol Properties

IPythonFieldSymbol Properties

The IPythonFieldSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | FieldType |
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

IPythonFieldSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonFieldSymbol.FieldType Property

IPythonFieldSymbolFieldType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonTypeSymbol FieldType { get; set; }
Property FieldType As IPythonTypeSymbol
    Get
    Set
property IPythonTypeSymbol^ FieldType {
    IPythonTypeSymbol^ get ();
    void set (IPythonTypeSymbol^ value);
}
abstract FieldType : IPythonTypeSymbol with get, set

Property Value

Type: IPythonTypeSymbol
See Also

Reference

IPythonFieldSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonImportSymbol Interface

IPythonImportSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonImportSymbol : IPythonSymbol
Public Interface IPythonImportSymbol
    Inherits IPythonSymbol
public interface class IPythonImportSymbol : IPythonSymbol
type IPythonImportSymbol =
    interface
        interface IPythonSymbol
    end

The IPythonImportSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddDeclaration |
Public method | FindDeclaration |
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | Alias |
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Declarations |
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Module |
Public property | ModuleName |
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonImportSymbol Methods

IPythonImportSymbol Methods

The IPythonImportSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddDeclaration |
Public method | FindDeclaration |
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonImportSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonImportSymbol.AddDeclaration Method

IPythonImportSymbolAddDeclaration Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddDeclaration(
    string declration,
    string alias
)
Sub AddDeclaration (
    declration As String,
    alias As String
)
void AddDeclaration(
    String^ declration,
    String^ alias
)
abstract AddDeclaration :
        declration : string *
        alias : string -> unit

Parameters

declration
Type: SystemString
alias
Type: SystemString
See Also

Reference

IPythonImportSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonImportSymbol.FindDeclaration Method

IPythonImportSymbolFindDeclaration Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonSymbol FindDeclaration(
    string reference
)
Function FindDeclaration (
    reference As String
) As IPythonSymbol
IPythonSymbol^ FindDeclaration(
    String^ reference
)
abstract FindDeclaration :
        reference : string -> IPythonSymbol

Parameters

reference
Type: SystemString

Return Value

Type: IPythonSymbol
See Also

Reference

IPythonImportSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonImportSymbol Properties

IPythonImportSymbol Properties

The IPythonImportSymbol type exposes the following members.

Properties
 | Name | Description
Public property | Alias |
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Declarations |
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Module |
Public property | ModuleName |
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

IPythonImportSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonImportSymbol.Alias Property

IPythonImportSymbolAlias Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Alias { get; set; }
Property Alias As String
    Get
    Set
property String^ Alias {
    String^ get ();
    void set (String^ value);
}
abstract Alias : string with get, set

Property Value

Type: String
See Also

Reference

IPythonImportSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonImportSymbol.Declarations Property

IPythonImportSymbolDeclarations Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDictionary<string, string> Declarations { get; }
ReadOnly Property Declarations As IDictionary(Of String, String)
    Get
property IDictionary<String^, String^>^ Declarations {
    IDictionary<String^, String^>^ get ();
}
abstract Declarations : IDictionary<string, string> with get

Property Value

Type: IDictionaryString, String
See Also

Reference

IPythonImportSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonImportSymbol.Module Property

IPythonImportSymbolModule Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonModuleSymbol Module { get; set; }
Property Module As IPythonModuleSymbol
    Get
    Set
property IPythonModuleSymbol^ Module {
    IPythonModuleSymbol^ get ();
    void set (IPythonModuleSymbol^ value);
}
abstract Module : IPythonModuleSymbol with get, set

Property Value

Type: IPythonModuleSymbol
See Also

Reference

IPythonImportSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonImportSymbol.ModuleName Property

IPythonImportSymbolModuleName Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ModuleName { get; set; }
Property ModuleName As String
    Get
    Set
property String^ ModuleName {
    String^ get ();
    void set (String^ value);
}
abstract ModuleName : string with get, set

Property Value

Type: String
See Also

Reference

IPythonImportSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonLocalVariableSymbol Interface

IPythonLocalVariableSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonLocalVariableSymbol : IPythonSymbol
Public Interface IPythonLocalVariableSymbol
    Inherits IPythonSymbol
public interface class IPythonLocalVariableSymbol : IPythonSymbol
type IPythonLocalVariableSymbol =
    interface
        interface IPythonSymbol
    end

The IPythonLocalVariableSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Public property | VariableType |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonLocalVariableSymbol Methods

IPythonLocalVariableSymbol Methods

The IPythonLocalVariableSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonLocalVariableSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonLocalVariableSymbol Properties

IPythonLocalVariableSymbol Properties

The IPythonLocalVariableSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Public property | VariableType |
Top
See Also

Reference

IPythonLocalVariableSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonLocalVariableSymbol.VariableType Property

IPythonLocalVariableSymbolVariableType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonTypeSymbol VariableType { get; set; }
Property VariableType As IPythonTypeSymbol
    Get
    Set
property IPythonTypeSymbol^ VariableType {
    IPythonTypeSymbol^ get ();
    void set (IPythonTypeSymbol^ value);
}
abstract VariableType : IPythonTypeSymbol with get, set

Property Value

Type: IPythonTypeSymbol
See Also

Reference

IPythonLocalVariableSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonMethodSymbol Interface

IPythonMethodSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonMethodSymbol : IPythonSymbol
Public Interface IPythonMethodSymbol
    Inherits IPythonSymbol
public interface class IPythonMethodSymbol : IPythonSymbol
type IPythonMethodSymbol =
    interface
        interface IPythonSymbol
    end

The IPythonMethodSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName(Boolean, Color) | Overloaded. (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName(Boolean, Color) | Overloaded. (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsConstructor |
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | OpenArgs |
Public property | OptionalParameter |
Public property | Parameters |
Public property | ReturnType |
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonMethodSymbol Methods

IPythonMethodSymbol Methods

The IPythonMethodSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName(Boolean, Color) | Overloaded. (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName(Boolean, Color) | Overloaded. (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonMethodSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonMethodSymbol Properties

IPythonMethodSymbol Properties

The IPythonMethodSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsConstructor |
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | OpenArgs |
Public property | OptionalParameter |
Public property | Parameters |
Public property | ReturnType |
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

IPythonMethodSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonMethodSymbol.IsConstructor Property

IPythonMethodSymbolIsConstructor Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsConstructor { get; }
ReadOnly Property IsConstructor As Boolean
    Get
property bool IsConstructor {
    bool get ();
}
abstract IsConstructor : bool with get

Property Value

Type: Boolean
See Also

Reference

IPythonMethodSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonMethodSymbol.OpenArgs Property

IPythonMethodSymbolOpenArgs Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OpenArgs { get; set; }
Property OpenArgs As Boolean
    Get
    Set
property bool OpenArgs {
    bool get ();
    void set (bool value);
}
abstract OpenArgs : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPythonMethodSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonMethodSymbol.OptionalParameter Property

IPythonMethodSymbolOptionalParameter Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int OptionalParameter { get; set; }
Property OptionalParameter As Integer
    Get
    Set
property int OptionalParameter {
    int get ();
    void set (int value);
}
abstract OptionalParameter : int with get, set

Property Value

Type: Int32
See Also

Reference

IPythonMethodSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonMethodSymbol.Parameters Property

IPythonMethodSymbolParameters Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<IPythonParameterSymbol> Parameters { get; set; }
Property Parameters As IList(Of IPythonParameterSymbol)
    Get
    Set
property IList<IPythonParameterSymbol^>^ Parameters {
    IList<IPythonParameterSymbol^>^ get ();
    void set (IList<IPythonParameterSymbol^>^ value);
}
abstract Parameters : IList<IPythonParameterSymbol> with get, set

Property Value

Type: IListIPythonParameterSymbol
See Also

Reference

IPythonMethodSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonMethodSymbol.ReturnType Property

IPythonMethodSymbolReturnType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonTypeSymbol ReturnType { get; set; }
Property ReturnType As IPythonTypeSymbol
    Get
    Set
property IPythonTypeSymbol^ ReturnType {
    IPythonTypeSymbol^ get ();
    void set (IPythonTypeSymbol^ value);
}
abstract ReturnType : IPythonTypeSymbol with get, set

Property Value

Type: IPythonTypeSymbol
See Also

Reference

IPythonMethodSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol Interface

IPythonModuleSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonModuleSymbol : IPythonClassSymbol,
    IPythonTypeSymbol, IPythonSymbol
Public Interface IPythonModuleSymbol
    Inherits IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
public interface class IPythonModuleSymbol : IPythonClassSymbol,
    IPythonTypeSymbol, IPythonSymbol
type IPythonModuleSymbol =
    interface
        interface IPythonClassSymbol
        interface IPythonTypeSymbol
        interface IPythonSymbol
    end

The IPythonModuleSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from IPythonClassSymbol.)
Public method | AddGlobalVariable |
Public method | FindGlobalVariable |
Public method | FindMember | (Inherited from IPythonClassSymbol.)
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from IPythonClassSymbol.)
Public property | Constructor | (Inherited from IPythonClassSymbol.)
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | FileName |
Public property | GlobalTypes |
Public property | GlobalVariables |
Public property | Imports |
Public property | IsGlobal |
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Members | (Inherited from IPythonClassSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol Methods

IPythonModuleSymbol Methods

The IPythonModuleSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from IPythonClassSymbol.)
Public method | AddGlobalVariable |
Public method | FindGlobalVariable |
Public method | FindMember | (Inherited from IPythonClassSymbol.)
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonModuleSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol.AddGlobalVariable Method

IPythonModuleSymbolAddGlobalVariable Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddGlobalVariable(
    IPythonSymbol symbol
)
Sub AddGlobalVariable (
    symbol As IPythonSymbol
)
void AddGlobalVariable(
    IPythonSymbol^ symbol
)
abstract AddGlobalVariable :
        symbol : IPythonSymbol -> unit

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

IPythonModuleSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol.FindGlobalVariable Method

IPythonModuleSymbolFindGlobalVariable Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonSymbol FindGlobalVariable(
    string name
)
Function FindGlobalVariable (
    name As String
) As IPythonSymbol
IPythonSymbol^ FindGlobalVariable(
    String^ name
)
abstract FindGlobalVariable :
        name : string -> IPythonSymbol

Parameters

name
Type: SystemString

Return Value

Type: IPythonSymbol
See Also

Reference

IPythonModuleSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol Properties

IPythonModuleSymbol Properties

The IPythonModuleSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from IPythonClassSymbol.)
Public property | Constructor | (Inherited from IPythonClassSymbol.)
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | FileName |
Public property | GlobalTypes |
Public property | GlobalVariables |
Public property | Imports |
Public property | IsGlobal |
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Members | (Inherited from IPythonClassSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

IPythonModuleSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol.FileName Property

IPythonModuleSymbolFileName Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

IPythonModuleSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol.GlobalTypes Property

IPythonModuleSymbolGlobalTypes Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<IPythonTypeSymbol> GlobalTypes { get; }
ReadOnly Property GlobalTypes As IList(Of IPythonTypeSymbol)
    Get
property IList<IPythonTypeSymbol^>^ GlobalTypes {
    IList<IPythonTypeSymbol^>^ get ();
}
abstract GlobalTypes : IList<IPythonTypeSymbol> with get

Property Value

Type: IListIPythonTypeSymbol
See Also

Reference

IPythonModuleSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol.GlobalVariables Property

IPythonModuleSymbolGlobalVariables Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IDictionary<string, IPythonSymbol> GlobalVariables { get; }
ReadOnly Property GlobalVariables As IDictionary(Of String, IPythonSymbol)
    Get
property IDictionary<String^, IPythonSymbol^>^ GlobalVariables {
    IDictionary<String^, IPythonSymbol^>^ get ();
}
abstract GlobalVariables : IDictionary<string, IPythonSymbol> with get

Property Value

Type: IDictionaryString, IPythonSymbol
See Also

Reference

IPythonModuleSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol.Imports Property

IPythonModuleSymbolImports Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<IPythonImportSymbol> Imports { get; }
ReadOnly Property Imports As IList(Of IPythonImportSymbol)
    Get
property IList<IPythonImportSymbol^>^ Imports {
    IList<IPythonImportSymbol^>^ get ();
}
abstract Imports : IList<IPythonImportSymbol> with get

Property Value

Type: IListIPythonImportSymbol
See Also

Reference

IPythonModuleSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonModuleSymbol.IsGlobal Property

IPythonModuleSymbolIsGlobal Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsGlobal { get; set; }
Property IsGlobal As Boolean
    Get
    Set
property bool IsGlobal {
    bool get ();
    void set (bool value);
}
abstract IsGlobal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPythonModuleSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonParameterSymbol Interface

IPythonParameterSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonParameterSymbol : IPythonSymbol
Public Interface IPythonParameterSymbol
    Inherits IPythonSymbol
public interface class IPythonParameterSymbol : IPythonSymbol
type IPythonParameterSymbol =
    interface
        interface IPythonSymbol
    end

The IPythonParameterSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetParamText | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsOptional |
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | ParameterType |
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonParameterSymbol Methods

IPythonParameterSymbol Methods

The IPythonParameterSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetParamText | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonParameterSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonParameterSymbol Properties

IPythonParameterSymbol Properties

The IPythonParameterSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsOptional |
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | ParameterType |
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

IPythonParameterSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonParameterSymbol.IsOptional Property

IPythonParameterSymbolIsOptional Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsOptional { get; set; }
Property IsOptional As Boolean
    Get
    Set
property bool IsOptional {
    bool get ();
    void set (bool value);
}
abstract IsOptional : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPythonParameterSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonParameterSymbol.ParameterType Property

IPythonParameterSymbolParameterType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonTypeSymbol ParameterType { get; set; }
Property ParameterType As IPythonTypeSymbol
    Get
    Set
property IPythonTypeSymbol^ ParameterType {
    IPythonTypeSymbol^ get ();
    void set (IPythonTypeSymbol^ value);
}
abstract ParameterType : IPythonTypeSymbol with get, set

Property Value

Type: IPythonTypeSymbol
See Also

Reference

IPythonParameterSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel Interface

IPythonSemanticModel Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonSemanticModel
Public Interface IPythonSemanticModel
public interface class IPythonSemanticModel
type IPythonSemanticModel =  interface end

The IPythonSemanticModel type exposes the following members.

Methods
 | Name | Description
Public method | Build |
Public method | GetReferences |
Public method | GetSymbol |
Public method | GetSymbolType(ISyntaxNode) |
Public method | GetSymbolType(IPythonSymbol, Boolean) |
Public method | GetSymbolType(ISyntaxNode, Boolean) |
Top
Properties
 | Name | Description
Public property | CodeEnvironment |
Public property | IsGlobal |
Public property | ModuleSymbol |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel Methods

IPythonSemanticModel Methods

The IPythonSemanticModel type exposes the following members.

Methods
 | Name | Description
Public method | Build |
Public method | GetReferences |
Public method | GetSymbol |
Public method | GetSymbolType(ISyntaxNode) |
Public method | GetSymbolType(IPythonSymbol, Boolean) |
Public method | GetSymbolType(ISyntaxNode, Boolean) |
Top
See Also

Reference

IPythonSemanticModel Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.Build Method

IPythonSemanticModelBuild Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void Build(
    PythonParser parser
)
Sub Build (
    parser As PythonParser
)
void Build(
    PythonParser^ parser
)
abstract Build :
        parser : PythonParser -> unit

Parameters

parser
Type: Alternet.Syntax.Parsers.PythonPythonParser
See Also

Reference

IPythonSemanticModel Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.GetReferences Method

IPythonSemanticModelGetReferences Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<SymbolReference> GetReferences(
    IPythonSymbol symbol
)
Function GetReferences (
    symbol As IPythonSymbol
) As IList(Of SymbolReference)
IList<SymbolReference^>^ GetReferences(
    IPythonSymbol^ symbol
)
abstract GetReferences :
        symbol : IPythonSymbol -> IList<SymbolReference>

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: IListSymbolReference
See Also

Reference

IPythonSemanticModel Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.GetSymbol Method

IPythonSemanticModelGetSymbol Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonSymbol GetSymbol(
    ISyntaxNode node
)
Function GetSymbol (
    node As ISyntaxNode
) As IPythonSymbol
IPythonSymbol^ GetSymbol(
    ISyntaxNode^ node
)
abstract GetSymbol :
        node : ISyntaxNode -> IPythonSymbol

Parameters

node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IPythonSymbol
See Also

Reference

IPythonSemanticModel Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.GetSymbolType Method

IPythonSemanticModelGetSymbolType Method
Overload List
 | Name | Description
Public method | GetSymbolType(ISyntaxNode) |
Public method | GetSymbolType(IPythonSymbol, Boolean) |
Public method | GetSymbolType(ISyntaxNode, Boolean) |
Top
See Also

Reference

IPythonSemanticModel Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.GetSymbolType Method (ISyntaxNode)

IPythonSemanticModelGetSymbolType Method (ISyntaxNode)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonTypeSymbol GetSymbolType(
    ISyntaxNode node
)
Function GetSymbolType (
    node As ISyntaxNode
) As IPythonTypeSymbol
IPythonTypeSymbol^ GetSymbolType(
    ISyntaxNode^ node
)
abstract GetSymbolType :
        node : ISyntaxNode -> IPythonTypeSymbol

Parameters

node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IPythonTypeSymbol
See Also

Reference

IPythonSemanticModel Interface
GetSymbolType Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.GetSymbolType Method (IPythonSymbol, Boolean)

IPythonSemanticModelGetSymbolType Method (IPythonSymbol, Boolean)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonTypeSymbol GetSymbolType(
    IPythonSymbol symbol,
    out bool isStatic
)
Function GetSymbolType (
    symbol As IPythonSymbol,
    <OutAttribute> ByRef isStatic As Boolean
) As IPythonTypeSymbol
IPythonTypeSymbol^ GetSymbolType(
    IPythonSymbol^ symbol,
    [OutAttribute] bool% isStatic
)
abstract GetSymbolType :
        symbol : IPythonSymbol *
        isStatic : bool byref -> IPythonTypeSymbol

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
isStatic
Type: SystemBoolean

Return Value

Type: IPythonTypeSymbol
See Also

Reference

IPythonSemanticModel Interface
GetSymbolType Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.GetSymbolType Method (ISyntaxNode, Boolean)

IPythonSemanticModelGetSymbolType Method (ISyntaxNode, Boolean)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonTypeSymbol GetSymbolType(
    ISyntaxNode node,
    out bool isStatic
)
Function GetSymbolType (
    node As ISyntaxNode,
    <OutAttribute> ByRef isStatic As Boolean
) As IPythonTypeSymbol
IPythonTypeSymbol^ GetSymbolType(
    ISyntaxNode^ node,
    [OutAttribute] bool% isStatic
)
abstract GetSymbolType :
        node : ISyntaxNode *
        isStatic : bool byref -> IPythonTypeSymbol

Parameters

node
Type: Alternet.SyntaxISyntaxNode
isStatic
Type: SystemBoolean

Return Value

Type: IPythonTypeSymbol
See Also

Reference

IPythonSemanticModel Interface
GetSymbolType Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel Properties

IPythonSemanticModel Properties

The IPythonSemanticModel type exposes the following members.

Properties
 | Name | Description
Public property | CodeEnvironment |
Public property | IsGlobal |
Public property | ModuleSymbol |
Top
See Also

Reference

IPythonSemanticModel Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.CodeEnvironment Property

IPythonSemanticModelCodeEnvironment Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ICodeEnvironment CodeEnvironment { get; set; }
Property CodeEnvironment As ICodeEnvironment
    Get
    Set
property ICodeEnvironment^ CodeEnvironment {
    ICodeEnvironment^ get ();
    void set (ICodeEnvironment^ value);
}
abstract CodeEnvironment : ICodeEnvironment with get, set

Property Value

Type: ICodeEnvironment
See Also

Reference

IPythonSemanticModel Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.IsGlobal Property

IPythonSemanticModelIsGlobal Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsGlobal { get; set; }
Property IsGlobal As Boolean
    Get
    Set
property bool IsGlobal {
    bool get ();
    void set (bool value);
}
abstract IsGlobal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPythonSemanticModel Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSemanticModel.ModuleSymbol Property

IPythonSemanticModelModuleSymbol Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonModuleSymbol ModuleSymbol { get; }
ReadOnly Property ModuleSymbol As IPythonModuleSymbol
    Get
property IPythonModuleSymbol^ ModuleSymbol {
    IPythonModuleSymbol^ get ();
}
abstract ModuleSymbol : IPythonModuleSymbol with get

Property Value

Type: IPythonModuleSymbol
See Also

Reference

IPythonSemanticModel Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol Interface

IPythonSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonSymbol
Public Interface IPythonSymbol
public interface class IPythonSymbol
type IPythonSymbol =  interface end

The IPythonSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType |
Public method | GetDisplayName |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule |
Public property | ContainingSymbol |
Public property | Description |
Public property | IsStatic |
Public property | Location |
Public property | Name |
Public property | Scope |
Public property | SymbolKind |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol Methods

IPythonSymbol Methods

The IPythonSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType |
Public method | GetDisplayName |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.GetDataType Method

IPythonSymbolGetDataType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetDataType()
Function GetDataType As String
String^ GetDataType()
abstract GetDataType : unit -> string

Return Value

Type: String
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.GetDisplayName Method

IPythonSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetDisplayName()
Function GetDisplayName As String
String^ GetDisplayName()
abstract GetDisplayName : unit -> string

Return Value

Type: String
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol Properties

IPythonSymbol Properties

The IPythonSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule |
Public property | ContainingSymbol |
Public property | Description |
Public property | IsStatic |
Public property | Location |
Public property | Name |
Public property | Scope |
Public property | SymbolKind |
Top
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.ContainingModule Property

IPythonSymbolContainingModule Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonModuleSymbol ContainingModule { get; }
ReadOnly Property ContainingModule As IPythonModuleSymbol
    Get
property IPythonModuleSymbol^ ContainingModule {
    IPythonModuleSymbol^ get ();
}
abstract ContainingModule : IPythonModuleSymbol with get

Property Value

Type: IPythonModuleSymbol
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.ContainingSymbol Property

IPythonSymbolContainingSymbol Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IPythonSymbol ContainingSymbol { get; }
ReadOnly Property ContainingSymbol As IPythonSymbol
    Get
property IPythonSymbol^ ContainingSymbol {
    IPythonSymbol^ get ();
}
abstract ContainingSymbol : IPythonSymbol with get

Property Value

Type: IPythonSymbol
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.Description Property

IPythonSymbolDescription Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.IsStatic Property

IPythonSymbolIsStatic Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsStatic { get; }
ReadOnly Property IsStatic As Boolean
    Get
property bool IsStatic {
    bool get ();
}
abstract IsStatic : bool with get

Property Value

Type: Boolean
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.Location Property

IPythonSymbolLocation Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point Location { get; set; }
Property Location As Point
    Get
    Set
property Point Location {
    Point get ();
    void set (Point value);
}
abstract Location : Point with get, set

Property Value

Type: Point
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.Name Property

IPythonSymbolName Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.Scope Property

IPythonSymbolScope Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PythonScope Scope { get; set; }
Property Scope As PythonScope
    Get
    Set
property PythonScope Scope {
    PythonScope get ();
    void set (PythonScope value);
}
abstract Scope : PythonScope with get, set

Property Value

Type: PythonScope
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonSymbol.SymbolKind Property

IPythonSymbolSymbolKind Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
PythonSymbolKind SymbolKind { get; set; }
Property SymbolKind As PythonSymbolKind
    Get
    Set
property PythonSymbolKind SymbolKind {
    PythonSymbolKind get ();
    void set (PythonSymbolKind value);
}
abstract SymbolKind : PythonSymbolKind with get, set

Property Value

Type: PythonSymbolKind
See Also

Reference

IPythonSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonTypeSymbol Interface

IPythonTypeSymbol Interface

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPythonTypeSymbol : IPythonSymbol
Public Interface IPythonTypeSymbol
    Inherits IPythonSymbol
public interface class IPythonTypeSymbol : IPythonSymbol
type IPythonTypeSymbol =
    interface
        interface IPythonSymbol
    end

The IPythonTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonTypeSymbol Methods

IPythonTypeSymbol Methods

The IPythonTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | GetDataType | (Inherited from IPythonSymbol.)
Public method | GetDisplayName | (Inherited from IPythonSymbol.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IPythonTypeSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IPythonTypeSymbol Properties

IPythonTypeSymbol Properties

The IPythonTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from IPythonSymbol.)
Public property | ContainingSymbol | (Inherited from IPythonSymbol.)
Public property | Description | (Inherited from IPythonSymbol.)
Public property | IsStatic | (Inherited from IPythonSymbol.)
Public property | Location | (Inherited from IPythonSymbol.)
Public property | Name | (Inherited from IPythonSymbol.)
Public property | Scope | (Inherited from IPythonSymbol.)
Public property | SymbolKind | (Inherited from IPythonSymbol.)
Top
See Also

Reference

IPythonTypeSymbol Interface
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonEventSymbol Class

IronPythonEventSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonFieldSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonEventSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonEventSymbol : PythonFieldSymbol
Public Class IronPythonEventSymbol
    Inherits PythonFieldSymbol
public ref class IronPythonEventSymbol : public PythonFieldSymbol
type IronPythonEventSymbol =
    class
        inherit PythonFieldSymbol
    end

The IronPythonEventSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonEventSymbol | Initializes a new instance of the IronPythonEventSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonFieldSymbol.)
Public method | GetDisplayName | (Inherited from PythonFieldSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FieldType | (Inherited from PythonFieldSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonEventSymbol Constructor

IronPythonEventSymbol Constructor
Initializes a new instance of the IronPythonEventSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonEventSymbol(
    string name,
    IPythonSymbol containingSymbol,
    EventInfo eventInfo
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol,
    eventInfo As EventInfo
)
public:
IronPythonEventSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol,
    EventInfo^ eventInfo
)
new :
        name : string *
        containingSymbol : IPythonSymbol *
        eventInfo : EventInfo -> IronPythonEventSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
eventInfo
Type: System.ReflectionEventInfo
See Also

Reference

IronPythonEventSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonEventSymbol Methods

IronPythonEventSymbol Methods

The IronPythonEventSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonFieldSymbol.)
Public method | GetDisplayName | (Inherited from PythonFieldSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IronPythonEventSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonEventSymbol Properties

IronPythonEventSymbol Properties

The IronPythonEventSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FieldType | (Inherited from PythonFieldSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

IronPythonEventSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonFieldSymbol Class

IronPythonFieldSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonFieldSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonFieldSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonFieldSymbol : PythonFieldSymbol
Public Class IronPythonFieldSymbol
    Inherits PythonFieldSymbol
public ref class IronPythonFieldSymbol : public PythonFieldSymbol
type IronPythonFieldSymbol =
    class
        inherit PythonFieldSymbol
    end

The IronPythonFieldSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonFieldSymbol | Initializes a new instance of the IronPythonFieldSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonFieldSymbol.)
Public method | GetDisplayName | (Inherited from PythonFieldSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FieldType | (Inherited from PythonFieldSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Overrides PythonSymbolScope.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonFieldSymbol Constructor

IronPythonFieldSymbol Constructor
Initializes a new instance of the IronPythonFieldSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonFieldSymbol(
    string name,
    IPythonSymbol containingSymbol,
    FieldInfo field
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol,
    field As FieldInfo
)
public:
IronPythonFieldSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol,
    FieldInfo^ field
)
new :
        name : string *
        containingSymbol : IPythonSymbol *
        field : FieldInfo -> IronPythonFieldSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
field
Type: System.ReflectionFieldInfo
See Also

Reference

IronPythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonFieldSymbol Methods

IronPythonFieldSymbol Methods

The IronPythonFieldSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonFieldSymbol.)
Public method | GetDisplayName | (Inherited from PythonFieldSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IronPythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonFieldSymbol Properties

IronPythonFieldSymbol Properties

The IronPythonFieldSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FieldType | (Inherited from PythonFieldSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Overrides PythonSymbolScope.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

IronPythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonFieldSymbol.Scope Property

IronPythonFieldSymbolScope Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override PythonScope Scope { get; }
Public Overrides ReadOnly Property Scope As PythonScope
    Get
public:
virtual property PythonScope Scope {
    PythonScope get () override;
}
abstract Scope : PythonScope with get
override Scope : PythonScope with get

Property Value

Type: PythonScope

Implements

IPythonSymbolScope
See Also

Reference

IronPythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonMethodSymbol Class

IronPythonMethodSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonMethodSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonMethodSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonMethodSymbol : PythonMethodSymbol
Public Class IronPythonMethodSymbol
    Inherits PythonMethodSymbol
public ref class IronPythonMethodSymbol : public PythonMethodSymbol
type IronPythonMethodSymbol =
    class
        inherit PythonMethodSymbol
    end

The IronPythonMethodSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonMethodSymbol | Initializes a new instance of the IronPythonMethodSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonMethodSymbol.)
Public method | GetDisplayName | (Inherited from PythonMethodSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsConstructor | (Overrides PythonMethodSymbolIsConstructor.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | OpenArgs | (Inherited from PythonMethodSymbol.)
Public property | OptionalParameter | (Inherited from PythonMethodSymbol.)
Public property | Parameters | (Inherited from PythonMethodSymbol.)
Public property | ReturnType | (Inherited from PythonMethodSymbol.)
Public property | Scope | (Overrides PythonSymbolScope.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonMethodSymbol Constructor

IronPythonMethodSymbol Constructor
Initializes a new instance of the IronPythonMethodSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonMethodSymbol(
    string name,
    IPythonSymbol containingSymbol,
    MethodBase method
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol,
    method As MethodBase
)
public:
IronPythonMethodSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol,
    MethodBase^ method
)
new :
        name : string *
        containingSymbol : IPythonSymbol *
        method : MethodBase -> IronPythonMethodSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
method
Type: System.ReflectionMethodBase
See Also

Reference

IronPythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonMethodSymbol Methods

IronPythonMethodSymbol Methods

The IronPythonMethodSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonMethodSymbol.)
Public method | GetDisplayName | (Inherited from PythonMethodSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IronPythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonMethodSymbol Properties

IronPythonMethodSymbol Properties

The IronPythonMethodSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsConstructor | (Overrides PythonMethodSymbolIsConstructor.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | OpenArgs | (Inherited from PythonMethodSymbol.)
Public property | OptionalParameter | (Inherited from PythonMethodSymbol.)
Public property | Parameters | (Inherited from PythonMethodSymbol.)
Public property | ReturnType | (Inherited from PythonMethodSymbol.)
Public property | Scope | (Overrides PythonSymbolScope.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

IronPythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonMethodSymbol.IsConstructor Property

IronPythonMethodSymbolIsConstructor Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsConstructor { get; }
Public Overrides ReadOnly Property IsConstructor As Boolean
    Get
public:
virtual property bool IsConstructor {
    bool get () override;
}
abstract IsConstructor : bool with get
override IsConstructor : bool with get

Property Value

Type: Boolean

Implements

IPythonMethodSymbolIsConstructor
See Also

Reference

IronPythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonMethodSymbol.Scope Property

IronPythonMethodSymbolScope Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override PythonScope Scope { get; }
Public Overrides ReadOnly Property Scope As PythonScope
    Get
public:
virtual property PythonScope Scope {
    PythonScope get () override;
}
abstract Scope : PythonScope with get
override Scope : PythonScope with get

Property Value

Type: PythonScope

Implements

IPythonSymbolScope
See Also

Reference

IronPythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleContext Class

IronPythonModuleContext Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonModuleContext
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonModuleContext

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonModuleContext : PythonModuleContext
Public Class IronPythonModuleContext
    Inherits PythonModuleContext
public ref class IronPythonModuleContext : public PythonModuleContext
type IronPythonModuleContext =
    class
        inherit PythonModuleContext
    end

The IronPythonModuleContext type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonModuleContext | Initializes a new instance of the IronPythonModuleContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Overrides PythonModuleContextFindDeclaration(ISyntaxNode, Point).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleContext Constructor

IronPythonModuleContext Constructor
Initializes a new instance of the IronPythonModuleContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonModuleContext(
    IPythonSemanticModel model,
    ISyntaxNode node,
    IPythonModuleSymbol moduleSymbol,
    ICodeEnvironment codeEnvironment
)
Public Sub New (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    moduleSymbol As IPythonModuleSymbol,
    codeEnvironment As ICodeEnvironment
)
public:
IronPythonModuleContext(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    IPythonModuleSymbol^ moduleSymbol,
    ICodeEnvironment^ codeEnvironment
)
new :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        moduleSymbol : IPythonModuleSymbol *
        codeEnvironment : ICodeEnvironment -> IronPythonModuleContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
moduleSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonModuleSymbol
codeEnvironment
Type: ICodeEnvironment
See Also

Reference

IronPythonModuleContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleContext Methods

IronPythonModuleContext Methods

The IronPythonModuleContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Overrides PythonModuleContextFindDeclaration(ISyntaxNode, Point).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IronPythonModuleContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleContext.FindDeclaration Method

IronPythonModuleContextFindDeclaration Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IPythonSymbol FindDeclaration(
    ISyntaxNode reference,
    Point position
)
Public Overrides Function FindDeclaration (
    reference As ISyntaxNode,
    position As Point
) As IPythonSymbol
public:
virtual IPythonSymbol^ FindDeclaration(
    ISyntaxNode^ reference,
    Point position
) override
abstract FindDeclaration :
        reference : ISyntaxNode *
        position : Point -> IPythonSymbol
override FindDeclaration :
        reference : ISyntaxNode *
        position : Point -> IPythonSymbol

Parameters

reference
Type: Alternet.SyntaxISyntaxNode
position
Type: System.DrawingPoint

Return Value

Type: IPythonSymbol
See Also

Reference

IronPythonModuleContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleContext Properties

IronPythonModuleContext Properties

The IronPythonModuleContext type exposes the following members.

Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

IronPythonModuleContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleLoader Class

IronPythonModuleLoader Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonModuleLoader

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class IronPythonModuleLoader
Public NotInheritable Class IronPythonModuleLoader
public ref class IronPythonModuleLoader abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IronPythonModuleLoader =  class end

The IronPythonModuleLoader type exposes the following members.

Methods
Name | Description
Clear |
LoadModule |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleLoader Methods

IronPythonModuleLoader Methods

The IronPythonModuleLoader type exposes the following members.

Methods
Name | Description
Clear |
LoadModule |
Top
See Also

Reference

IronPythonModuleLoader Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleLoader.Clear Method

IronPythonModuleLoaderClear Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Clear()
Public Shared Sub Clear
public:
static void Clear()
static member Clear : unit -> unit
See Also

Reference

IronPythonModuleLoader Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleLoader.LoadModule Method

IronPythonModuleLoaderLoadModule Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonModuleSymbol LoadModule(
    ICodeEnvironment codeEnvironment,
    string moduleName
)
Public Shared Function LoadModule (
    codeEnvironment As ICodeEnvironment,
    moduleName As String
) As IPythonModuleSymbol
public:
static IPythonModuleSymbol^ LoadModule(
    ICodeEnvironment^ codeEnvironment,
    String^ moduleName
)
static member LoadModule :
        codeEnvironment : ICodeEnvironment *
        moduleName : string -> IPythonModuleSymbol

Parameters

codeEnvironment
Type: ICodeEnvironment
moduleName
Type: SystemString

Return Value

Type: IPythonModuleSymbol
See Also

Reference

IronPythonModuleLoader Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol Class

IronPythonModuleSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonModuleSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonModuleSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonModuleSymbol : PythonModuleSymbol
Public Class IronPythonModuleSymbol
    Inherits PythonModuleSymbol
public ref class IronPythonModuleSymbol : public PythonModuleSymbol
type IronPythonModuleSymbol =
    class
        inherit PythonModuleSymbol
    end

The IronPythonModuleSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonModuleSymbol(String, String, ICodeEnvironment) | Initializes a new instance of the IronPythonModuleSymbol class
Public method | IronPythonModuleSymbol(String, String, Type, ICodeEnvironment) | Initializes a new instance of the IronPythonModuleSymbol class
Top
Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | AddGlobalVariable | (Inherited from PythonModuleSymbol.)
 | CreateFrom(String, String, ICodeEnvironment) |
 | CreateFrom(String, Type, ICodeEnvironment) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindGlobalVariable | (Inherited from PythonModuleSymbol.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FileName | (Inherited from PythonModuleSymbol.)
Public property | GlobalTypes | (Overrides PythonModuleSymbolGlobalTypes.)
Public property | GlobalVariables | (Inherited from PythonModuleSymbol.)
Public property | Imports | (Inherited from PythonModuleSymbol.)
Public property | IsGlobal | (Inherited from PythonModuleSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol Constructor

IronPythonModuleSymbol Constructor
Overload List
 | Name | Description
Public method | IronPythonModuleSymbol(String, String, ICodeEnvironment) | Initializes a new instance of the IronPythonModuleSymbol class
Public method | IronPythonModuleSymbol(String, String, Type, ICodeEnvironment) | Initializes a new instance of the IronPythonModuleSymbol class
Top
See Also

Reference

IronPythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol Constructor (String, String, ICodeEnvironment)

IronPythonModuleSymbol Constructor (String, String, ICodeEnvironment)
Initializes a new instance of the IronPythonModuleSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonModuleSymbol(
    string fileName,
    string nameSpace,
    ICodeEnvironment codeEnvironment
)
Public Sub New (
    fileName As String,
    nameSpace As String,
    codeEnvironment As ICodeEnvironment
)
public:
IronPythonModuleSymbol(
    String^ fileName,
    String^ nameSpace,
    ICodeEnvironment^ codeEnvironment
)
new :
        fileName : string *
        nameSpace : string *
        codeEnvironment : ICodeEnvironment -> IronPythonModuleSymbol

Parameters

fileName
Type: SystemString
nameSpace
Type: SystemString
codeEnvironment
Type: ICodeEnvironment
See Also

Reference

IronPythonModuleSymbol Class
IronPythonModuleSymbol Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol Constructor (String, String, Type, ICodeEnvironment)

IronPythonModuleSymbol Constructor (String, String, Type, ICodeEnvironment)
Initializes a new instance of the IronPythonModuleSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonModuleSymbol(
    string fileName,
    string name,
    Type module,
    ICodeEnvironment codeEnvironment
)
Public Sub New (
    fileName As String,
    name As String,
    module As Type,
    codeEnvironment As ICodeEnvironment
)
public:
IronPythonModuleSymbol(
    String^ fileName,
    String^ name,
    Type^ module,
    ICodeEnvironment^ codeEnvironment
)
new :
        fileName : string *
        name : string *
        module : Type *
        codeEnvironment : ICodeEnvironment -> IronPythonModuleSymbol

Parameters

fileName
Type: SystemString
name
Type: SystemString
module
Type: SystemType
codeEnvironment
Type: ICodeEnvironment
See Also

Reference

IronPythonModuleSymbol Class
IronPythonModuleSymbol Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol Methods

IronPythonModuleSymbol Methods

The IronPythonModuleSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | AddGlobalVariable | (Inherited from PythonModuleSymbol.)
 | CreateFrom(String, String, ICodeEnvironment) |
 | CreateFrom(String, Type, ICodeEnvironment) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindGlobalVariable | (Inherited from PythonModuleSymbol.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IronPythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol.CreateFrom Method

IronPythonModuleSymbolCreateFrom Method
Overload List
Name | Description
CreateFrom(String, String, ICodeEnvironment) |
CreateFrom(String, Type, ICodeEnvironment) |
Top
See Also

Reference

IronPythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol.CreateFrom Method (String, String, ICodeEnvironment)

IronPythonModuleSymbolCreateFrom Method (String, String, ICodeEnvironment)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonModuleSymbol CreateFrom(
    string fileName,
    string nameSpace,
    ICodeEnvironment codeEnvironment
)
Public Shared Function CreateFrom (
    fileName As String,
    nameSpace As String,
    codeEnvironment As ICodeEnvironment
) As IPythonModuleSymbol
public:
static IPythonModuleSymbol^ CreateFrom(
    String^ fileName,
    String^ nameSpace,
    ICodeEnvironment^ codeEnvironment
)
static member CreateFrom :
        fileName : string *
        nameSpace : string *
        codeEnvironment : ICodeEnvironment -> IPythonModuleSymbol

Parameters

fileName
Type: SystemString
nameSpace
Type: SystemString
codeEnvironment
Type: ICodeEnvironment

Return Value

Type: IPythonModuleSymbol
See Also

Reference

IronPythonModuleSymbol Class
CreateFrom Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol.CreateFrom Method (String, Type, ICodeEnvironment)

IronPythonModuleSymbolCreateFrom Method (String, Type, ICodeEnvironment)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonModuleSymbol CreateFrom(
    string fileName,
    Type type,
    ICodeEnvironment codeEnvironment
)
Public Shared Function CreateFrom (
    fileName As String,
    type As Type,
    codeEnvironment As ICodeEnvironment
) As IPythonModuleSymbol
public:
static IPythonModuleSymbol^ CreateFrom(
    String^ fileName,
    Type^ type,
    ICodeEnvironment^ codeEnvironment
)
static member CreateFrom :
        fileName : string *
        type : Type *
        codeEnvironment : ICodeEnvironment -> IPythonModuleSymbol

Parameters

fileName
Type: SystemString
type
Type: SystemType
codeEnvironment
Type: ICodeEnvironment

Return Value

Type: IPythonModuleSymbol
See Also

Reference

IronPythonModuleSymbol Class
CreateFrom Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol Properties

IronPythonModuleSymbol Properties

The IronPythonModuleSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FileName | (Inherited from PythonModuleSymbol.)
Public property | GlobalTypes | (Overrides PythonModuleSymbolGlobalTypes.)
Public property | GlobalVariables | (Inherited from PythonModuleSymbol.)
Public property | Imports | (Inherited from PythonModuleSymbol.)
Public property | IsGlobal | (Inherited from PythonModuleSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

IronPythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonModuleSymbol.GlobalTypes Property

IronPythonModuleSymbolGlobalTypes Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IList<IPythonTypeSymbol> GlobalTypes { get; }
Public Overrides ReadOnly Property GlobalTypes As IList(Of IPythonTypeSymbol)
    Get
public:
virtual property IList<IPythonTypeSymbol^>^ GlobalTypes {
    IList<IPythonTypeSymbol^>^ get () override;
}
abstract GlobalTypes : IList<IPythonTypeSymbol> with get
override GlobalTypes : IList<IPythonTypeSymbol> with get

Property Value

Type: IListIPythonTypeSymbol

Implements

IPythonModuleSymbolGlobalTypes
See Also

Reference

IronPythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonPropertySymbol Class

IronPythonPropertySymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonFieldSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonPropertySymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonPropertySymbol : PythonFieldSymbol
Public Class IronPythonPropertySymbol
    Inherits PythonFieldSymbol
public ref class IronPythonPropertySymbol : public PythonFieldSymbol
type IronPythonPropertySymbol =
    class
        inherit PythonFieldSymbol
    end

The IronPythonPropertySymbol type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonPropertySymbol | Initializes a new instance of the IronPythonPropertySymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonFieldSymbol.)
Public method | GetDisplayName | (Inherited from PythonFieldSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FieldType | (Inherited from PythonFieldSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Overrides PythonSymbolScope.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonPropertySymbol Constructor

IronPythonPropertySymbol Constructor
Initializes a new instance of the IronPythonPropertySymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonPropertySymbol(
    string name,
    IPythonSymbol containingSymbol,
    PropertyInfo property
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol,
    property As PropertyInfo
)
public:
IronPythonPropertySymbol(
    String^ name,
    IPythonSymbol^ containingSymbol,
    PropertyInfo^ property
)
new :
        name : string *
        containingSymbol : IPythonSymbol *
        property : PropertyInfo -> IronPythonPropertySymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
property
Type: System.ReflectionPropertyInfo
See Also

Reference

IronPythonPropertySymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonPropertySymbol Methods

IronPythonPropertySymbol Methods

The IronPythonPropertySymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonFieldSymbol.)
Public method | GetDisplayName | (Inherited from PythonFieldSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IronPythonPropertySymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonPropertySymbol Properties

IronPythonPropertySymbol Properties

The IronPythonPropertySymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FieldType | (Inherited from PythonFieldSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Overrides PythonSymbolScope.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

IronPythonPropertySymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonPropertySymbol.Scope Property

IronPythonPropertySymbolScope Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override PythonScope Scope { get; }
Public Overrides ReadOnly Property Scope As PythonScope
    Get
public:
virtual property PythonScope Scope {
    PythonScope get () override;
}
abstract Scope : PythonScope with get
override Scope : PythonScope with get

Property Value

Type: PythonScope

Implements

IPythonSymbolScope
See Also

Reference

IronPythonPropertySymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonSemanticModel Class

IronPythonSemanticModel Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSemanticModel
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonSemanticModel

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonSemanticModel : PythonSemanticModel
Public Class IronPythonSemanticModel
    Inherits PythonSemanticModel
public ref class IronPythonSemanticModel : public PythonSemanticModel
type IronPythonSemanticModel =
    class
        inherit PythonSemanticModel
    end

The IronPythonSemanticModel type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonSemanticModel | Initializes a new instance of the IronPythonSemanticModel class
Top
Methods
 | Name | Description
Public method | Build | (Inherited from PythonSemanticModel.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReferences | (Inherited from PythonSemanticModel.)
Public method | GetSymbol | (Inherited from PythonSemanticModel.)
Public method | GetSymbolType(ISyntaxNode) | (Inherited from PythonSemanticModel.)
Public method | GetSymbolType(IPythonSymbol, Boolean) | (Inherited from PythonSemanticModel.)
Public method | GetSymbolType(ISyntaxNode, Boolean) | (Inherited from PythonSemanticModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CodeEnvironment | (Inherited from PythonSemanticModel.)
Public property | IsGlobal | (Inherited from PythonSemanticModel.)
Public property | ModuleSymbol | (Inherited from PythonSemanticModel.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonSemanticModel Constructor

IronPythonSemanticModel Constructor
Initializes a new instance of the IronPythonSemanticModel class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonSemanticModel()
Public Sub New
public:
IronPythonSemanticModel()
new : unit -> IronPythonSemanticModel
See Also

Reference

IronPythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonSemanticModel Methods

IronPythonSemanticModel Methods

The IronPythonSemanticModel type exposes the following members.

Methods
 | Name | Description
Public method | Build | (Inherited from PythonSemanticModel.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReferences | (Inherited from PythonSemanticModel.)
Public method | GetSymbol | (Inherited from PythonSemanticModel.)
Public method | GetSymbolType(ISyntaxNode) | (Inherited from PythonSemanticModel.)
Public method | GetSymbolType(IPythonSymbol, Boolean) | (Inherited from PythonSemanticModel.)
Public method | GetSymbolType(ISyntaxNode, Boolean) | (Inherited from PythonSemanticModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IronPythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonSemanticModel Properties

IronPythonSemanticModel Properties

The IronPythonSemanticModel type exposes the following members.

Properties
 | Name | Description
Public property | CodeEnvironment | (Inherited from PythonSemanticModel.)
Public property | IsGlobal | (Inherited from PythonSemanticModel.)
Public property | ModuleSymbol | (Inherited from PythonSemanticModel.)
Top
See Also

Reference

IronPythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeResolver Class

IronPythonTypeResolver Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonTypeResolver

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class IronPythonTypeResolver
Public NotInheritable Class IronPythonTypeResolver
public ref class IronPythonTypeResolver abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IronPythonTypeResolver =  class end

The IronPythonTypeResolver type exposes the following members.

Methods
Name | Description
FindOrLoadAssembly |
FindType |
GetAssemblies |
GetTypes |
LoadTypes |
Top
Properties
Name | Description
Assemblies |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeResolver Methods

IronPythonTypeResolver Methods

The IronPythonTypeResolver type exposes the following members.

Methods
Name | Description
FindOrLoadAssembly |
FindType |
GetAssemblies |
GetTypes |
LoadTypes |
Top
See Also

Reference

IronPythonTypeResolver Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeResolver.FindOrLoadAssembly Method

IronPythonTypeResolverFindOrLoadAssembly Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Assembly FindOrLoadAssembly(
    string reference
)
Public Shared Function FindOrLoadAssembly (
    reference As String
) As Assembly
public:
static Assembly^ FindOrLoadAssembly(
    String^ reference
)
static member FindOrLoadAssembly :
        reference : string -> Assembly

Parameters

reference
Type: SystemString

Return Value

Type: Assembly
See Also

Reference

IronPythonTypeResolver Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeResolver.FindType Method

IronPythonTypeResolverFindType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Type FindType(
    string name,
    ICodeEnvironment codeEnvironment
)
Public Shared Function FindType (
    name As String,
    codeEnvironment As ICodeEnvironment
) As Type
public:
static Type^ FindType(
    String^ name,
    ICodeEnvironment^ codeEnvironment
)
static member FindType :
        name : string *
        codeEnvironment : ICodeEnvironment -> Type

Parameters

name
Type: SystemString
codeEnvironment
Type: ICodeEnvironment

Return Value

Type: Type
See Also

Reference

IronPythonTypeResolver Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeResolver.GetAssemblies Method

IronPythonTypeResolverGetAssemblies Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] GetAssemblies(
    ICodeEnvironment codeEnvironment
)
Public Shared Function GetAssemblies (
    codeEnvironment As ICodeEnvironment
) As String()
public:
static array<String^>^ GetAssemblies(
    ICodeEnvironment^ codeEnvironment
)
static member GetAssemblies :
        codeEnvironment : ICodeEnvironment -> string[]

Parameters

codeEnvironment
Type: ICodeEnvironment

Return Value

Type: String
See Also

Reference

IronPythonTypeResolver Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeResolver.GetTypes Method

IronPythonTypeResolverGetTypes Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<Type> GetTypes(
    string nameSpace,
    ICodeEnvironment codeEnvironment
)
Public Shared Function GetTypes (
    nameSpace As String,
    codeEnvironment As ICodeEnvironment
) As IList(Of Type)
public:
static IList<Type^>^ GetTypes(
    String^ nameSpace,
    ICodeEnvironment^ codeEnvironment
)
static member GetTypes :
        nameSpace : string *
        codeEnvironment : ICodeEnvironment -> IList<Type>

Parameters

nameSpace
Type: SystemString
codeEnvironment
Type: ICodeEnvironment

Return Value

Type: IListType
See Also

Reference

IronPythonTypeResolver Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeResolver.LoadTypes Method

IronPythonTypeResolverLoadTypes Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDictionary<string, Type> LoadTypes(
    ICodeEnvironment codeEnvironment
)
Public Shared Function LoadTypes (
    codeEnvironment As ICodeEnvironment
) As IDictionary(Of String, Type)
public:
static IDictionary<String^, Type^>^ LoadTypes(
    ICodeEnvironment^ codeEnvironment
)
static member LoadTypes :
        codeEnvironment : ICodeEnvironment -> IDictionary<string, Type>

Parameters

codeEnvironment
Type: ICodeEnvironment

Return Value

Type: IDictionaryString, Type
See Also

Reference

IronPythonTypeResolver Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeResolver Properties

IronPythonTypeResolver Properties

The IronPythonTypeResolver type exposes the following members.

Properties
Name | Description
Assemblies |
Top
See Also

Reference

IronPythonTypeResolver Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeResolver.Assemblies Property

IronPythonTypeResolverAssemblies Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDictionary<string, Assembly> Assemblies { get; }
Public Shared ReadOnly Property Assemblies As IDictionary(Of String, Assembly)
    Get
public:
static property IDictionary<String^, Assembly^>^ Assemblies {
    IDictionary<String^, Assembly^>^ get ();
}
static member Assemblies : IDictionary<string, Assembly> with get

Property Value

Type: IDictionaryString, Assembly
See Also

Reference

IronPythonTypeResolver Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol Class

IronPythonTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IronPythonTypeSymbol : PythonTypeSymbol,
    IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
Public Class IronPythonTypeSymbol
    Inherits PythonTypeSymbol
    Implements IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
public ref class IronPythonTypeSymbol : public PythonTypeSymbol,
    IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
type IronPythonTypeSymbol =
    class
        inherit PythonTypeSymbol
        interface IPythonClassSymbol
        interface IPythonTypeSymbol
        interface IPythonSymbol
    end

The IronPythonTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | IronPythonTypeSymbol | Initializes a new instance of the IronPythonTypeSymbol class
Top
Methods
 | Name | Description
Public method | AddField |
 | CreateFrom |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember |
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | BaseType |
Public property | Constructor |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members |
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Public property | Type |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol Constructor

IronPythonTypeSymbol Constructor
Initializes a new instance of the IronPythonTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IronPythonTypeSymbol(
    string name,
    Type type
)
Public Sub New (
    name As String,
    type As Type
)
public:
IronPythonTypeSymbol(
    String^ name,
    Type^ type
)
new :
        name : string *
        type : Type -> IronPythonTypeSymbol

Parameters

name
Type: SystemString
type
Type: SystemType
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol Methods

IronPythonTypeSymbol Methods

The IronPythonTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField |
 | CreateFrom |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember |
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol.AddField Method

IronPythonTypeSymbolAddField Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddField(
    string fieldName
)
Public Sub AddField (
    fieldName As String
)
public:
virtual void AddField(
    String^ fieldName
) sealed
abstract AddField :
        fieldName : string -> unit
override AddField :
        fieldName : string -> unit

Parameters

fieldName
Type: SystemString

Implements

IPythonClassSymbolAddField(String)
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol.CreateFrom Method

IronPythonTypeSymbolCreateFrom Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol CreateFrom(
    Type type
)
Public Shared Function CreateFrom (
    type As Type
) As IPythonTypeSymbol
public:
static IPythonTypeSymbol^ CreateFrom(
    Type^ type
)
static member CreateFrom :
        type : Type -> IPythonTypeSymbol

Parameters

type
Type: SystemType

Return Value

Type: IPythonTypeSymbol
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol.FindMember Method

IronPythonTypeSymbolFindMember Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonSymbol FindMember(
    string name
)
Public Function FindMember (
    name As String
) As IPythonSymbol
public:
virtual IPythonSymbol^ FindMember(
    String^ name
) sealed
abstract FindMember :
        name : string -> IPythonSymbol
override FindMember :
        name : string -> IPythonSymbol

Parameters

name
Type: SystemString

Return Value

Type: IPythonSymbol

Implements

IPythonClassSymbolFindMember(String)
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol.GetDisplayName Method

IronPythonTypeSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayName()
Public Overrides Function GetDisplayName As String
public:
virtual String^ GetDisplayName() override
abstract GetDisplayName : unit -> string
override GetDisplayName : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDisplayName
IPythonSymbolGetDisplayName
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol Properties

IronPythonTypeSymbol Properties

The IronPythonTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType |
Public property | Constructor |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members |
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Public property | Type |
Top
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol.BaseType Property

IronPythonTypeSymbolBaseType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonClassSymbol BaseType { get; set; }
Public Property BaseType As IPythonClassSymbol
    Get
    Set
public:
virtual property IPythonClassSymbol^ BaseType {
    IPythonClassSymbol^ get () sealed;
    void set (IPythonClassSymbol^ value) sealed;
}
abstract BaseType : IPythonClassSymbol with get, set
override BaseType : IPythonClassSymbol with get, set

Property Value

Type: IPythonClassSymbol

Implements

IPythonClassSymbolBaseType
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol.Constructor Property

IronPythonTypeSymbolConstructor Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonSymbol Constructor { get; }
Public ReadOnly Property Constructor As IPythonSymbol
    Get
public:
virtual property IPythonSymbol^ Constructor {
    IPythonSymbol^ get () sealed;
}
abstract Constructor : IPythonSymbol with get
override Constructor : IPythonSymbol with get

Property Value

Type: IPythonSymbol

Implements

IPythonClassSymbolConstructor
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol.Members Property

IronPythonTypeSymbolMembers Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IPythonSymbol> Members { get; set; }
Public Property Members As IList(Of IPythonSymbol)
    Get
    Set
public:
virtual property IList<IPythonSymbol^>^ Members {
    IList<IPythonSymbol^>^ get () sealed;
    void set (IList<IPythonSymbol^>^ value) sealed;
}
abstract Members : IList<IPythonSymbol> with get, set
override Members : IList<IPythonSymbol> with get, set

Property Value

Type: IListIPythonSymbol

Implements

IPythonClassSymbolMembers
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


IronPythonTypeSymbol.Type Property

IronPythonTypeSymbolType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}
member Type : Type with get

Property Value

Type: Type
See Also

Reference

IronPythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonAliasSymbol Class

PythonAliasSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonAliasSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonAliasSymbol : PythonSymbol,
    IPythonAliasSymbol, IPythonSymbol
Public Class PythonAliasSymbol
    Inherits PythonSymbol
    Implements IPythonAliasSymbol, IPythonSymbol
public ref class PythonAliasSymbol : public PythonSymbol,
    IPythonAliasSymbol, IPythonSymbol
type PythonAliasSymbol =
    class
        inherit PythonSymbol
        interface IPythonAliasSymbol
        interface IPythonSymbol
    end

The PythonAliasSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonAliasSymbol | Initializes a new instance of the PythonAliasSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | ReferenceSymbol |
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonAliasSymbol Constructor

PythonAliasSymbol Constructor
Initializes a new instance of the PythonAliasSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonAliasSymbol(
    string name,
    IPythonSymbol containingSymbol,
    IPythonSymbol referenceSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol,
    referenceSymbol As IPythonSymbol
)
public:
PythonAliasSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol,
    IPythonSymbol^ referenceSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol *
        referenceSymbol : IPythonSymbol -> PythonAliasSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
referenceSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonAliasSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonAliasSymbol Methods

PythonAliasSymbol Methods

The PythonAliasSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonAliasSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonAliasSymbol.GetDataType Method

PythonAliasSymbolGetDataType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDataType()
Public Overrides Function GetDataType As String
public:
virtual String^ GetDataType() override
abstract GetDataType : unit -> string
override GetDataType : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDataType
IPythonSymbolGetDataType
See Also

Reference

PythonAliasSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonAliasSymbol.GetDisplayName Method

PythonAliasSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayName()
Public Overrides Function GetDisplayName As String
public:
virtual String^ GetDisplayName() override
abstract GetDisplayName : unit -> string
override GetDisplayName : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDisplayName
IPythonSymbolGetDisplayName
See Also

Reference

PythonAliasSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonAliasSymbol Properties

PythonAliasSymbol Properties

The PythonAliasSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | ReferenceSymbol |
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonAliasSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonAliasSymbol.ReferenceSymbol Property

PythonAliasSymbolReferenceSymbol Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonSymbol ReferenceSymbol { get; }
Public ReadOnly Property ReferenceSymbol As IPythonSymbol
    Get
public:
virtual property IPythonSymbol^ ReferenceSymbol {
    IPythonSymbol^ get () sealed;
}
abstract ReferenceSymbol : IPythonSymbol with get
override ReferenceSymbol : IPythonSymbol with get

Property Value

Type: IPythonSymbol

Implements

IPythonAliasSymbolReferenceSymbol
See Also

Reference

PythonAliasSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBlockContext Class

PythonBlockContext Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonBlockContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonForStatementContext

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonBlockContext : PythonContext
Public Class PythonBlockContext
    Inherits PythonContext
public ref class PythonBlockContext : public PythonContext
type PythonBlockContext =
    class
        inherit PythonContext
    end

The PythonBlockContext type exposes the following members.

Constructors
 | Name | Description
Public method | PythonBlockContext | Initializes a new instance of the PythonBlockContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBlockContext Constructor

PythonBlockContext Constructor
Initializes a new instance of the PythonBlockContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonBlockContext(
    IPythonSemanticModel model,
    ISyntaxNode node,
    IPythonSymbol containingSymbol
)
Public Sub New (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    containingSymbol As IPythonSymbol
)
public:
PythonBlockContext(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    IPythonSymbol^ containingSymbol
)
new :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        containingSymbol : IPythonSymbol -> PythonBlockContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonBlockContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBlockContext Methods

PythonBlockContext Methods

The PythonBlockContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonBlockContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBlockContext Properties

PythonBlockContext Properties

The PythonBlockContext type exposes the following members.

Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

PythonBlockContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBlockSymbol Class

PythonBlockSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonBlockSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonBlockSymbol : PythonSymbol,
    IPythonBlockSymbol, IPythonSymbol
Public Class PythonBlockSymbol
    Inherits PythonSymbol
    Implements IPythonBlockSymbol, IPythonSymbol
public ref class PythonBlockSymbol : public PythonSymbol,
    IPythonBlockSymbol, IPythonSymbol
type PythonBlockSymbol =
    class
        inherit PythonSymbol
        interface IPythonBlockSymbol
        interface IPythonSymbol
    end

The PythonBlockSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonBlockSymbol | Initializes a new instance of the PythonBlockSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | BlockMembers |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBlockSymbol Constructor

PythonBlockSymbol Constructor
Initializes a new instance of the PythonBlockSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonBlockSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonBlockSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonBlockSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonBlockSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBlockSymbol Methods

PythonBlockSymbol Methods

The PythonBlockSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonBlockSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBlockSymbol Properties

PythonBlockSymbol Properties

The PythonBlockSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BlockMembers |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonBlockSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBlockSymbol.BlockMembers Property

PythonBlockSymbolBlockMembers Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IPythonSymbol> BlockMembers { get; set; }
Public Property BlockMembers As IList(Of IPythonSymbol)
    Get
    Set
public:
virtual property IList<IPythonSymbol^>^ BlockMembers {
    IList<IPythonSymbol^>^ get () sealed;
    void set (IList<IPythonSymbol^>^ value) sealed;
}
abstract BlockMembers : IList<IPythonSymbol> with get, set
override BlockMembers : IList<IPythonSymbol> with get, set

Property Value

Type: IListIPythonSymbol

Implements

IPythonBlockSymbolBlockMembers
See Also

Reference

PythonBlockSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBuiltinFunctions Class

PythonBuiltinFunctions Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonBuiltinFunctions

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PythonBuiltinFunctions
Public NotInheritable Class PythonBuiltinFunctions
public ref class PythonBuiltinFunctions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PythonBuiltinFunctions =  class end

The PythonBuiltinFunctions type exposes the following members.

Methods
Name | Description
CreateBuiltinFunctions |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBuiltinFunctions Methods

PythonBuiltinFunctions Methods

The PythonBuiltinFunctions type exposes the following members.

Methods
Name | Description
CreateBuiltinFunctions |
Top
See Also

Reference

PythonBuiltinFunctions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonBuiltinFunctions.CreateBuiltinFunctions Method

PythonBuiltinFunctionsCreateBuiltinFunctions Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<IPythonSymbol> CreateBuiltinFunctions(
    IPythonSymbol containingSymbol
)
Public Shared Function CreateBuiltinFunctions (
    containingSymbol As IPythonSymbol
) As IList(Of IPythonSymbol)
public:
static IList<IPythonSymbol^>^ CreateBuiltinFunctions(
    IPythonSymbol^ containingSymbol
)
static member CreateBuiltinFunctions :
        containingSymbol : IPythonSymbol -> IList<IPythonSymbol>

Parameters

containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: IListIPythonSymbol
See Also

Reference

PythonBuiltinFunctions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassContext Class

PythonClassContext Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonModuleContext

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonClassContext : PythonContext
Public Class PythonClassContext
    Inherits PythonContext
public ref class PythonClassContext : public PythonContext
type PythonClassContext =
    class
        inherit PythonContext
    end

The PythonClassContext type exposes the following members.

Constructors
 | Name | Description
Public method | PythonClassContext(IPythonSemanticModel, IPythonSymbol) | Initializes a new instance of the PythonClassContext class
Public method | PythonClassContext(IPythonSemanticModel, ISyntaxNode, IPythonSymbol, IPythonSymbol) | Initializes a new instance of the PythonClassContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassContext Constructor

PythonClassContext Constructor
Overload List
 | Name | Description
Public method | PythonClassContext(IPythonSemanticModel, IPythonSymbol) | Initializes a new instance of the PythonClassContext class
Public method | PythonClassContext(IPythonSemanticModel, ISyntaxNode, IPythonSymbol, IPythonSymbol) | Initializes a new instance of the PythonClassContext class
Top
See Also

Reference

PythonClassContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassContext Constructor (IPythonSemanticModel, IPythonSymbol)

PythonClassContext Constructor (IPythonSemanticModel, IPythonSymbol)
Initializes a new instance of the PythonClassContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonClassContext(
    IPythonSemanticModel model,
    IPythonSymbol symbol
)
Public Sub New (
    model As IPythonSemanticModel,
    symbol As IPythonSymbol
)
public:
PythonClassContext(
    IPythonSemanticModel^ model,
    IPythonSymbol^ symbol
)
new :
        model : IPythonSemanticModel *
        symbol : IPythonSymbol -> PythonClassContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonClassContext Class
PythonClassContext Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassContext Constructor (IPythonSemanticModel, ISyntaxNode, IPythonSymbol, IPythonSymbol)

PythonClassContext Constructor (IPythonSemanticModel, ISyntaxNode, IPythonSymbol, IPythonSymbol)
Initializes a new instance of the PythonClassContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonClassContext(
    IPythonSemanticModel model,
    ISyntaxNode node,
    IPythonSymbol symbol,
    IPythonSymbol containingSymbol
)
Public Sub New (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    symbol As IPythonSymbol,
    containingSymbol As IPythonSymbol
)
public:
PythonClassContext(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    IPythonSymbol^ symbol,
    IPythonSymbol^ containingSymbol
)
new :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        symbol : IPythonSymbol *
        containingSymbol : IPythonSymbol -> PythonClassContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonClassContext Class
PythonClassContext Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassContext Methods

PythonClassContext Methods

The PythonClassContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonClassContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassContext Properties

PythonClassContext Properties

The PythonClassContext type exposes the following members.

Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

PythonClassContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier Class

PythonClassifier Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassifier

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonClassifier : IPythonClassifier
Public Class PythonClassifier
    Implements IPythonClassifier
public ref class PythonClassifier : IPythonClassifier
type PythonClassifier =
    class
        interface IPythonClassifier
    end

The PythonClassifier type exposes the following members.

Constructors
 | Name | Description
Public method | PythonClassifier | Initializes a new instance of the PythonClassifier class
Top
Methods
 | Name | Description
Public method | AddSymbol |
Public method | Build |
Public method | ClassifyIdentifier |
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PositionChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
Name | Description
KnownFunctions |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier Constructor

PythonClassifier Constructor
Initializes a new instance of the PythonClassifier class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonClassifier()
Public Sub New
public:
PythonClassifier()
new : unit -> PythonClassifier
See Also

Reference

PythonClassifier Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier Methods

PythonClassifier Methods

The PythonClassifier type exposes the following members.

Methods
 | Name | Description
Public method | AddSymbol |
Public method | Build |
Public method | ClassifyIdentifier |
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PositionChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonClassifier Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.AddSymbol Method

PythonClassifierAddSymbol Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddSymbol(
    int x,
    int y,
    int length,
    IPythonSymbol symbol
)
Public Sub AddSymbol (
    x As Integer,
    y As Integer,
    length As Integer,
    symbol As IPythonSymbol
)
public:
virtual void AddSymbol(
    int x,
    int y,
    int length,
    IPythonSymbol^ symbol
) sealed
abstract AddSymbol :
        x : int *
        y : int *
        length : int *
        symbol : IPythonSymbol -> unit
override AddSymbol :
        x : int *
        y : int *
        length : int *
        symbol : IPythonSymbol -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
length
Type: SystemInt32
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Implements

IPythonClassifierAddSymbol(Int32, Int32, Int32, IPythonSymbol)
See Also

Reference

PythonClassifier Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.Build Method

PythonClassifierBuild Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Build(
    ISyntaxNode root,
    IPythonSemanticModel model
)
Public Sub Build (
    root As ISyntaxNode,
    model As IPythonSemanticModel
)
public:
virtual void Build(
    ISyntaxNode^ root,
    IPythonSemanticModel^ model
) sealed
abstract Build :
        root : ISyntaxNode *
        model : IPythonSemanticModel -> unit
override Build :
        root : ISyntaxNode *
        model : IPythonSemanticModel -> unit

Parameters

root
Type: Alternet.SyntaxISyntaxNode
model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel

Implements

IPythonClassifierBuild(ISyntaxNode, IPythonSemanticModel)
See Also

Reference

PythonClassifier Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.ClassifyIdentifier Method

PythonClassifierClassifyIdentifier Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int ClassifyIdentifier(
    int x,
    int y,
    string identifier
)
Public Overridable Function ClassifyIdentifier (
    x As Integer,
    y As Integer,
    identifier As String
) As Integer
public:
virtual int ClassifyIdentifier(
    int x,
    int y,
    String^ identifier
)
abstract ClassifyIdentifier :
        x : int *
        y : int *
        identifier : string -> int
override ClassifyIdentifier :
        x : int *
        y : int *
        identifier : string -> int

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
identifier
Type: SystemString

Return Value

Type: Int32

Implements

IPythonClassifierClassifyIdentifier(Int32, Int32, String)
See Also

Reference

PythonClassifier Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.Clear Method

PythonClassifierClear Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

IPythonClassifierClear
See Also

Reference

PythonClassifier Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.PositionChanged Method

PythonClassifierPositionChanged Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    char ch
)
Public Overridable Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ch As Char
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    wchar_t ch
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaX
Type: SystemInt32
deltaY
Type: SystemInt32
ch
Type: SystemChar

Implements

IPythonClassifierPositionChanged(Int32, Int32, Int32, Int32, Char)
See Also

Reference

PythonClassifier Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier Properties

PythonClassifier Properties

The PythonClassifier type exposes the following members.

Properties
Name | Description
KnownFunctions |
Top
See Also

Reference

PythonClassifier Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.KnownFunctions Property

PythonClassifierKnownFunctions Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDictionary<string, int> KnownFunctions { get; }
Public Shared ReadOnly Property KnownFunctions As IDictionary(Of String, Integer)
    Get
public:
static property IDictionary<String^, int>^ KnownFunctions {
    IDictionary<String^, int>^ get ();
}
static member KnownFunctions : IDictionary<string, int> with get

Property Value

Type: IDictionaryString, Int32
See Also

Reference

PythonClassifier Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.LineToken Class

PythonClassifierLineToken Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassifierLineToken

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineToken
Public Class LineToken
public ref class LineToken
type LineToken =  class end

The PythonClassifierLineToken type exposes the following members.

Constructors
 | Name | Description
Public method | PythonClassifierLineToken | Initializes a new instance of the PythonClassifierLineToken class
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Length |
Public property | Line |
Public property | Start |
Public property | Style |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.LineToken Constructor

PythonClassifierLineToken Constructor
Initializes a new instance of the PythonClassifierLineToken class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineToken(
    int line,
    int start,
    int len,
    int style
)
Public Sub New (
    line As Integer,
    start As Integer,
    len As Integer,
    style As Integer
)
public:
LineToken(
    int line,
    int start,
    int len,
    int style
)
new :
        line : int *
        start : int *
        len : int *
        style : int -> LineToken

Parameters

line
Type: SystemInt32
start
Type: SystemInt32
len
Type: SystemInt32
style
Type: SystemInt32
See Also

Reference

PythonClassifierLineToken Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


LineToken Methods

LineToken Methods

The PythonClassifierLineToken type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonClassifierLineToken Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.LineToken.Clone Method

PythonClassifierLineTokenClone Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonClassifierLineToken Clone()
Public Function Clone As PythonClassifierLineToken
public:
PythonClassifierLineToken^ Clone()
member Clone : unit -> PythonClassifierLineToken

Return Value

Type: PythonClassifierLineToken
See Also

Reference

PythonClassifierLineToken Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


LineToken Properties

LineToken Properties

The PythonClassifierLineToken type exposes the following members.

Properties
 | Name | Description
Public property | Length |
Public property | Line |
Public property | Start |
Public property | Style |
Top
See Also

Reference

PythonClassifierLineToken Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.LineToken.Length Property

PythonClassifierLineTokenLength Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set
public:
property int Length {
    int get ();
    void set (int value);
}
member Length : int with get, set

Property Value

Type: Int32
See Also

Reference

PythonClassifierLineToken Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.LineToken.Line Property

PythonClassifierLineTokenLine Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

PythonClassifierLineToken Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.LineToken.Start Property

PythonClassifierLineTokenStart Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

Property Value

Type: Int32
See Also

Reference

PythonClassifierLineToken Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.LineToken.Style Property

PythonClassifierLineTokenStyle Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Style { get; set; }
Public Property Style As Integer
    Get
    Set
public:
property int Style {
    int get ();
    void set (int value);
}
member Style : int with get, set

Property Value

Type: Int32
See Also

Reference

PythonClassifierLineToken Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.PythonTokenizer Class

PythonClassifierPythonTokenizer Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassifierPythonTokenizer

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonTokenizer
Public Class PythonTokenizer
public ref class PythonTokenizer
type PythonTokenizer =  class end

The PythonClassifierPythonTokenizer type exposes the following members.

Constructors
 | Name | Description
Public method | PythonClassifierPythonTokenizer | Initializes a new instance of the PythonClassifierPythonTokenizer class
Top
Methods
 | Name | Description
Public method | AddToken |
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetToken |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PositionChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.PythonTokenizer Constructor

PythonClassifierPythonTokenizer Constructor
Initializes a new instance of the PythonClassifierPythonTokenizer class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonTokenizer()
Public Sub New
public:
PythonTokenizer()
new : unit -> PythonTokenizer
See Also

Reference

PythonClassifierPythonTokenizer Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTokenizer Methods

PythonTokenizer Methods

The PythonClassifierPythonTokenizer type exposes the following members.

Methods
 | Name | Description
Public method | AddToken |
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetToken |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PositionChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonClassifierPythonTokenizer Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.PythonTokenizer.AddToken Method

PythonClassifierPythonTokenizerAddToken Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddToken(
    int x,
    int y,
    int length,
    int style
)
Public Overridable Sub AddToken (
    x As Integer,
    y As Integer,
    length As Integer,
    style As Integer
)
public:
virtual void AddToken(
    int x,
    int y,
    int length,
    int style
)
abstract AddToken :
        x : int *
        y : int *
        length : int *
        style : int -> unit
override AddToken :
        x : int *
        y : int *
        length : int *
        style : int -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
length
Type: SystemInt32
style
Type: SystemInt32
See Also

Reference

PythonClassifierPythonTokenizer Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.PythonTokenizer.Clear Method

PythonClassifierPythonTokenizerClear Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

PythonClassifierPythonTokenizer Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.PythonTokenizer.GetToken Method

PythonClassifierPythonTokenizerGetToken Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetToken(
    int x,
    int y,
    out int style
)
Public Function GetToken (
    x As Integer,
    y As Integer,
    <OutAttribute> ByRef style As Integer
) As Boolean
public:
bool GetToken(
    int x,
    int y,
    [OutAttribute] int% style
)
member GetToken :
        x : int *
        y : int *
        style : int byref -> bool

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
style
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

PythonClassifierPythonTokenizer Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.PythonTokenizer.PositionChanged Method

PythonClassifierPythonTokenizerPositionChanged Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    char ch
)
Public Overridable Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ch As Char
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    wchar_t ch
)
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaX
Type: SystemInt32
deltaY
Type: SystemInt32
ch
Type: SystemChar
See Also

Reference

PythonClassifierPythonTokenizer Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.TokenList Class

PythonClassifierTokenList Class
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIListPythonClassifierLineToken
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassifierTokenList

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TokenList : List<IList<PythonClassifierLineToken>>
Public Class TokenList
    Inherits List(Of IList(Of PythonClassifierLineToken))
public ref class TokenList : public List<IList<PythonClassifierLineToken^>^>
type TokenList =
    class
        inherit List<IList<PythonClassifierLineToken>>
    end

The PythonClassifierTokenList type exposes the following members.

Constructors
 | Name | Description
Public method | PythonClassifierTokenList | Initializes a new instance of the PythonClassifierTokenList class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | AddToken |
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIListPythonClassifierLineToken .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIListPythonClassifierLineToken .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIListPythonClassifierLineToken .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListPythonClassifierLineToken .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | GetToken |
Public method | GetTokens |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | PositionChanged |
Public method | PositionChangedX |
Public method | PositionChangedY |
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListPythonClassifierLineToken .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIListPythonClassifierLineToken .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIListPythonClassifierLineToken .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIListPythonClassifierLineToken .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIListPythonClassifierLineToken .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIListPythonClassifierLineToken .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.TokenList Constructor

PythonClassifierTokenList Constructor
Initializes a new instance of the PythonClassifierTokenList class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TokenList(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
TokenList(
    int capacity
)
new :
        capacity : int -> TokenList

Parameters

capacity
Type: SystemInt32
See Also

Reference

PythonClassifierTokenList Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


TokenList Methods

TokenList Methods

The PythonClassifierTokenList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | AddToken |
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIListPythonClassifierLineToken .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIListPythonClassifierLineToken .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIListPythonClassifierLineToken .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListPythonClassifierLineToken .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | GetToken |
Public method | GetTokens |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListPythonClassifierLineToken .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Public method | PositionChanged |
Public method | PositionChangedX |
Public method | PositionChangedY |
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListPythonClassifierLineToken .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIListPythonClassifierLineToken .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIListPythonClassifierLineToken .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIListPythonClassifierLineToken .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIListPythonClassifierLineToken .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIListPythonClassifierLineToken .)
Top
See Also

Reference

PythonClassifierTokenList Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.TokenList.AddToken Method

PythonClassifierTokenListAddToken Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddToken(
    int x,
    int y,
    int length,
    int style
)
Public Sub AddToken (
    x As Integer,
    y As Integer,
    length As Integer,
    style As Integer
)
public:
void AddToken(
    int x,
    int y,
    int length,
    int style
)
member AddToken :
        x : int *
        y : int *
        length : int *
        style : int -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
length
Type: SystemInt32
style
Type: SystemInt32
See Also

Reference

PythonClassifierTokenList Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.TokenList.GetToken Method

PythonClassifierTokenListGetToken Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetToken(
    int x,
    int y,
    out int style
)
Public Function GetToken (
    x As Integer,
    y As Integer,
    <OutAttribute> ByRef style As Integer
) As Boolean
public:
bool GetToken(
    int x,
    int y,
    [OutAttribute] int% style
)
member GetToken :
        x : int *
        y : int *
        style : int byref -> bool

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
style
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

PythonClassifierTokenList Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.TokenList.GetTokens Method

PythonClassifierTokenListGetTokens Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<PythonClassifierLineToken> GetTokens(
    int index,
    bool add
)
Public Function GetTokens (
    index As Integer,
    add As Boolean
) As IList(Of PythonClassifierLineToken)
public:
IList<PythonClassifierLineToken^>^ GetTokens(
    int index,
    bool add
)
member GetTokens :
        index : int *
        add : bool -> IList<PythonClassifierLineToken>

Parameters

index
Type: SystemInt32
add
Type: SystemBoolean

Return Value

Type: IListPythonClassifierLineToken
See Also

Reference

PythonClassifierTokenList Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.TokenList.PositionChanged Method

PythonClassifierTokenListPositionChanged Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    char ch
)
Public Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ch As Char
)
public:
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    wchar_t ch
)
member PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaX
Type: SystemInt32
deltaY
Type: SystemInt32
ch
Type: SystemChar
See Also

Reference

PythonClassifierTokenList Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.TokenList.PositionChangedX Method

PythonClassifierTokenListPositionChangedX Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChangedX(
    int x,
    int y,
    int deltaX,
    char ch
)
Public Sub PositionChangedX (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    ch As Char
)
public:
void PositionChangedX(
    int x,
    int y,
    int deltaX,
    wchar_t ch
)
member PositionChangedX :
        x : int *
        y : int *
        deltaX : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaX
Type: SystemInt32
ch
Type: SystemChar
See Also

Reference

PythonClassifierTokenList Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassifier.TokenList.PositionChangedY Method

PythonClassifierTokenListPositionChangedY Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChangedY(
    int x,
    int y,
    int deltaY
)
Public Sub PositionChangedY (
    x As Integer,
    y As Integer,
    deltaY As Integer
)
public:
void PositionChangedY(
    int x,
    int y,
    int deltaY
)
member PositionChangedY :
        x : int *
        y : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
deltaY
Type: SystemInt32
See Also

Reference

PythonClassifierTokenList Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


TokenList Properties

TokenList Properties

The PythonClassifierTokenList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIListPythonClassifierLineToken .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIListPythonClassifierLineToken .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIListPythonClassifierLineToken .)
Top
See Also

Reference

PythonClassifierTokenList Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassSymbol Class

PythonClassSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
More...

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonClassSymbol : PythonTypeSymbol,
    IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
Public Class PythonClassSymbol
    Inherits PythonTypeSymbol
    Implements IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
public ref class PythonClassSymbol : public PythonTypeSymbol,
    IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
type PythonClassSymbol =
    class
        inherit PythonTypeSymbol
        interface IPythonClassSymbol
        interface IPythonTypeSymbol
        interface IPythonSymbol
    end

The PythonClassSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonClassSymbol | Initializes a new instance of the PythonClassSymbol class
Top
Methods
 | Name | Description
Public method | AddField |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember |
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | BaseType |
Public property | Constructor |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members |
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonDictTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonFileTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonListTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonModuleSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonSetTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonStringTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonStructSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTupleTypeSymbol


PythonClassSymbol Constructor

PythonClassSymbol Constructor
Initializes a new instance of the PythonClassSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonClassSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonClassSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonClassSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonClassSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassSymbol Methods

PythonClassSymbol Methods

The PythonClassSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember |
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonClassSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassSymbol.AddField Method

PythonClassSymbolAddField Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddField(
    string fieldName
)
Public Overridable Sub AddField (
    fieldName As String
)
public:
virtual void AddField(
    String^ fieldName
)
abstract AddField :
        fieldName : string -> unit
override AddField :
        fieldName : string -> unit

Parameters

fieldName
Type: SystemString

Implements

IPythonClassSymbolAddField(String)
See Also

Reference

PythonClassSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassSymbol.FindMember Method

PythonClassSymbolFindMember Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonSymbol FindMember(
    string name
)
Public Function FindMember (
    name As String
) As IPythonSymbol
public:
virtual IPythonSymbol^ FindMember(
    String^ name
) sealed
abstract FindMember :
        name : string -> IPythonSymbol
override FindMember :
        name : string -> IPythonSymbol

Parameters

name
Type: SystemString

Return Value

Type: IPythonSymbol

Implements

IPythonClassSymbolFindMember(String)
See Also

Reference

PythonClassSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassSymbol Properties

PythonClassSymbol Properties

The PythonClassSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType |
Public property | Constructor |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members |
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonClassSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassSymbol.BaseType Property

PythonClassSymbolBaseType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonClassSymbol BaseType { get; set; }
Public Property BaseType As IPythonClassSymbol
    Get
    Set
public:
virtual property IPythonClassSymbol^ BaseType {
    IPythonClassSymbol^ get () sealed;
    void set (IPythonClassSymbol^ value) sealed;
}
abstract BaseType : IPythonClassSymbol with get, set
override BaseType : IPythonClassSymbol with get, set

Property Value

Type: IPythonClassSymbol

Implements

IPythonClassSymbolBaseType
See Also

Reference

PythonClassSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassSymbol.Constructor Property

PythonClassSymbolConstructor Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPythonSymbol Constructor { get; }
Public Overridable ReadOnly Property Constructor As IPythonSymbol
    Get
public:
virtual property IPythonSymbol^ Constructor {
    IPythonSymbol^ get ();
}
abstract Constructor : IPythonSymbol with get
override Constructor : IPythonSymbol with get

Property Value

Type: IPythonSymbol

Implements

IPythonClassSymbolConstructor
See Also

Reference

PythonClassSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonClassSymbol.Members Property

PythonClassSymbolMembers Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IPythonSymbol> Members { get; }
Public ReadOnly Property Members As IList(Of IPythonSymbol)
    Get
public:
virtual property IList<IPythonSymbol^>^ Members {
    IList<IPythonSymbol^>^ get () sealed;
}
abstract Members : IList<IPythonSymbol> with get
override Members : IList<IPythonSymbol> with get

Property Value

Type: IListIPythonSymbol

Implements

IPythonClassSymbolMembers
See Also

Reference

PythonClassSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext Class

PythonContext Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonBlockContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonMethodContext

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonContext
Public Class PythonContext
public ref class PythonContext
type PythonContext =  class end

The PythonContext type exposes the following members.

Constructors
 | Name | Description
Public method | PythonContext(IPythonSemanticModel, IPythonSymbol) | Initializes a new instance of the PythonContext class
Public method | PythonContext(IPythonSemanticModel, ISyntaxNode, IPythonSymbol, IPythonSymbol, Boolean) | Initializes a new instance of the PythonContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition |
Public method | IsValidScope |
Public method | Load |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsLocal |
Public property | IsStatic |
Public property | Node |
Public property | Symbol |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext Constructor

PythonContext Constructor
Overload List
 | Name | Description
Public method | PythonContext(IPythonSemanticModel, IPythonSymbol) | Initializes a new instance of the PythonContext class
Public method | PythonContext(IPythonSemanticModel, ISyntaxNode, IPythonSymbol, IPythonSymbol, Boolean) | Initializes a new instance of the PythonContext class
Top
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext Constructor (IPythonSemanticModel, IPythonSymbol)

PythonContext Constructor (IPythonSemanticModel, IPythonSymbol)
Initializes a new instance of the PythonContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonContext(
    IPythonSemanticModel model,
    IPythonSymbol symbol
)
Public Sub New (
    model As IPythonSemanticModel,
    symbol As IPythonSymbol
)
public:
PythonContext(
    IPythonSemanticModel^ model,
    IPythonSymbol^ symbol
)
new :
        model : IPythonSemanticModel *
        symbol : IPythonSymbol -> PythonContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonContext Class
PythonContext Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext Constructor (IPythonSemanticModel, ISyntaxNode, IPythonSymbol, IPythonSymbol, Boolean)

PythonContext Constructor (IPythonSemanticModel, ISyntaxNode, IPythonSymbol, IPythonSymbol, Boolean)
Initializes a new instance of the PythonContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonContext(
    IPythonSemanticModel model,
    ISyntaxNode node,
    IPythonSymbol symbol,
    IPythonSymbol containingSymbol,
    bool isLocal = false
)
Public Sub New (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    symbol As IPythonSymbol,
    containingSymbol As IPythonSymbol,
    Optional isLocal As Boolean = false
)
public:
PythonContext(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    IPythonSymbol^ symbol,
    IPythonSymbol^ containingSymbol,
    bool isLocal = false
)
new :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        symbol : IPythonSymbol *
        containingSymbol : IPythonSymbol *
        ?isLocal : bool
(* Defaults:
        let _isLocal = defaultArg isLocal false
*)
-> PythonContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
isLocal (Optional)
Type: SystemBoolean
See Also

Reference

PythonContext Class
PythonContext Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext Methods

PythonContext Methods

The PythonContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition |
Public method | IsValidScope |
Public method | Load |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext.FindDeclaration Method

PythonContextFindDeclaration Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPythonSymbol FindDeclaration(
    ISyntaxNode reference,
    Point position
)
Public Overridable Function FindDeclaration (
    reference As ISyntaxNode,
    position As Point
) As IPythonSymbol
public:
virtual IPythonSymbol^ FindDeclaration(
    ISyntaxNode^ reference,
    Point position
)
abstract FindDeclaration :
        reference : ISyntaxNode *
        position : Point -> IPythonSymbol
override FindDeclaration :
        reference : ISyntaxNode *
        position : Point -> IPythonSymbol

Parameters

reference
Type: Alternet.SyntaxISyntaxNode
position
Type: System.DrawingPoint

Return Value

Type: IPythonSymbol
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext.IsValidPosition Method

PythonContextIsValidPosition Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsValidPosition(
    IPythonSymbol symbol,
    Point position
)
Public Overridable Function IsValidPosition (
    symbol As IPythonSymbol,
    position As Point
) As Boolean
public:
virtual bool IsValidPosition(
    IPythonSymbol^ symbol,
    Point position
)
abstract IsValidPosition :
        symbol : IPythonSymbol *
        position : Point -> bool
override IsValidPosition :
        symbol : IPythonSymbol *
        position : Point -> bool

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
position
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext.IsValidScope Method

PythonContextIsValidScope Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsValidScope(
    IPythonSymbol symbol
)
Public Overridable Function IsValidScope (
    symbol As IPythonSymbol
) As Boolean
public:
virtual bool IsValidScope(
    IPythonSymbol^ symbol
)
abstract IsValidScope :
        symbol : IPythonSymbol -> bool
override IsValidScope :
        symbol : IPythonSymbol -> bool

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: Boolean
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext.Load Method

PythonContextLoad Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext Properties

PythonContext Properties

The PythonContext type exposes the following members.

Properties
 | Name | Description
Public property | IsLocal |
Public property | IsStatic |
Public property | Node |
Public property | Symbol |
Top
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext.IsLocal Property

PythonContextIsLocal Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocal { get; set; }
Public Property IsLocal As Boolean
    Get
    Set
public:
property bool IsLocal {
    bool get ();
    void set (bool value);
}
member IsLocal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext.IsStatic Property

PythonContextIsStatic Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; set; }
Public Property IsStatic As Boolean
    Get
    Set
public:
property bool IsStatic {
    bool get ();
    void set (bool value);
}
member IsStatic : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext.Node Property

PythonContextNode Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISyntaxNode Node { get; set; }
Public Property Node As ISyntaxNode
    Get
    Set
public:
property ISyntaxNode^ Node {
    ISyntaxNode^ get ();
    void set (ISyntaxNode^ value);
}
member Node : ISyntaxNode with get, set

Property Value

Type: ISyntaxNode
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonContext.Symbol Property

PythonContextSymbol Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonSymbol Symbol { get; }
Public ReadOnly Property Symbol As IPythonSymbol
    Get
public:
property IPythonSymbol^ Symbol {
    IPythonSymbol^ get ();
}
member Symbol : IPythonSymbol with get

Property Value

Type: IPythonSymbol
See Also

Reference

PythonContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonDictTypeSymbol Class

PythonDictTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonDictTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonDictTypeSymbol : PythonClassSymbol
Public Class PythonDictTypeSymbol
    Inherits PythonClassSymbol
public ref class PythonDictTypeSymbol : public PythonClassSymbol
type PythonDictTypeSymbol =
    class
        inherit PythonClassSymbol
    end

The PythonDictTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonDictTypeSymbol | Initializes a new instance of the PythonDictTypeSymbol class
Top
Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonDictTypeSymbol Constructor

PythonDictTypeSymbol Constructor
Initializes a new instance of the PythonDictTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonDictTypeSymbol(
    string name
)
Public Sub New (
    name As String
)
public:
PythonDictTypeSymbol(
    String^ name
)
new :
        name : string -> PythonDictTypeSymbol

Parameters

name
Type: SystemString
See Also

Reference

PythonDictTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonDictTypeSymbol Methods

PythonDictTypeSymbol Methods

The PythonDictTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonDictTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonDictTypeSymbol Properties

PythonDictTypeSymbol Properties

The PythonDictTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonDictTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFieldSymbol Class

PythonFieldSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonFieldSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonEventSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonFieldSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonPropertySymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonFieldSymbol : PythonSymbol,
    IPythonFieldSymbol, IPythonSymbol
Public Class PythonFieldSymbol
    Inherits PythonSymbol
    Implements IPythonFieldSymbol, IPythonSymbol
public ref class PythonFieldSymbol : public PythonSymbol,
    IPythonFieldSymbol, IPythonSymbol
type PythonFieldSymbol =
    class
        inherit PythonSymbol
        interface IPythonFieldSymbol
        interface IPythonSymbol
    end

The PythonFieldSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonFieldSymbol | Initializes a new instance of the PythonFieldSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FieldType |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFieldSymbol Constructor

PythonFieldSymbol Constructor
Initializes a new instance of the PythonFieldSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonFieldSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonFieldSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonFieldSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFieldSymbol Methods

PythonFieldSymbol Methods

The PythonFieldSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFieldSymbol.GetDataType Method

PythonFieldSymbolGetDataType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDataType()
Public Overrides Function GetDataType As String
public:
virtual String^ GetDataType() override
abstract GetDataType : unit -> string
override GetDataType : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDataType
IPythonSymbolGetDataType
See Also

Reference

PythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFieldSymbol.GetDisplayName Method

PythonFieldSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayName()
Public Overrides Function GetDisplayName As String
public:
virtual String^ GetDisplayName() override
abstract GetDisplayName : unit -> string
override GetDisplayName : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDisplayName
IPythonSymbolGetDisplayName
See Also

Reference

PythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFieldSymbol Properties

PythonFieldSymbol Properties

The PythonFieldSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FieldType |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFieldSymbol.FieldType Property

PythonFieldSymbolFieldType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonTypeSymbol FieldType { get; set; }
Public Property FieldType As IPythonTypeSymbol
    Get
    Set
public:
virtual property IPythonTypeSymbol^ FieldType {
    IPythonTypeSymbol^ get () sealed;
    void set (IPythonTypeSymbol^ value) sealed;
}
abstract FieldType : IPythonTypeSymbol with get, set
override FieldType : IPythonTypeSymbol with get, set

Property Value

Type: IPythonTypeSymbol

Implements

IPythonFieldSymbolFieldType
See Also

Reference

PythonFieldSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFileTypeSymbol Class

PythonFileTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonFileTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonFileTypeSymbol : PythonClassSymbol
Public Class PythonFileTypeSymbol
    Inherits PythonClassSymbol
public ref class PythonFileTypeSymbol : public PythonClassSymbol
type PythonFileTypeSymbol =
    class
        inherit PythonClassSymbol
    end

The PythonFileTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonFileTypeSymbol | Initializes a new instance of the PythonFileTypeSymbol class
Top
Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFileTypeSymbol Constructor

PythonFileTypeSymbol Constructor
Initializes a new instance of the PythonFileTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonFileTypeSymbol(
    string name
)
Public Sub New (
    name As String
)
public:
PythonFileTypeSymbol(
    String^ name
)
new :
        name : string -> PythonFileTypeSymbol

Parameters

name
Type: SystemString
See Also

Reference

PythonFileTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFileTypeSymbol Methods

PythonFileTypeSymbol Methods

The PythonFileTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonFileTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonFileTypeSymbol Properties

PythonFileTypeSymbol Properties

The PythonFileTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonFileTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonForStatementContext Class

PythonForStatementContext Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonBlockContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonForStatementContext

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonForStatementContext : PythonBlockContext
Public Class PythonForStatementContext
    Inherits PythonBlockContext
public ref class PythonForStatementContext : public PythonBlockContext
type PythonForStatementContext =
    class
        inherit PythonBlockContext
    end

The PythonForStatementContext type exposes the following members.

Constructors
 | Name | Description
Public method | PythonForStatementContext | Initializes a new instance of the PythonForStatementContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonForStatementContext Constructor

PythonForStatementContext Constructor
Initializes a new instance of the PythonForStatementContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonForStatementContext(
    IPythonSemanticModel model,
    ISyntaxNode node,
    IPythonSymbol containingSymbol
)
Public Sub New (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    containingSymbol As IPythonSymbol
)
public:
PythonForStatementContext(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    IPythonSymbol^ containingSymbol
)
new :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        containingSymbol : IPythonSymbol -> PythonForStatementContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonForStatementContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonForStatementContext Methods

PythonForStatementContext Methods

The PythonForStatementContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonForStatementContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonForStatementContext Properties

PythonForStatementContext Properties

The PythonForStatementContext type exposes the following members.

Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

PythonForStatementContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol Class

PythonImportSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonImportSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonImportSymbol : PythonSymbol,
    IPythonImportSymbol, IPythonSymbol
Public Class PythonImportSymbol
    Inherits PythonSymbol
    Implements IPythonImportSymbol, IPythonSymbol
public ref class PythonImportSymbol : public PythonSymbol,
    IPythonImportSymbol, IPythonSymbol
type PythonImportSymbol =
    class
        inherit PythonSymbol
        interface IPythonImportSymbol
        interface IPythonSymbol
    end

The PythonImportSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonImportSymbol | Initializes a new instance of the PythonImportSymbol class
Top
Methods
 | Name | Description
Public method | AddDeclaration |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration |
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | Alias |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Declarations |
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Module |
Public property | ModuleName |
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol Constructor

PythonImportSymbol Constructor
Initializes a new instance of the PythonImportSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonImportSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonImportSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonImportSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonImportSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol Methods

PythonImportSymbol Methods

The PythonImportSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddDeclaration |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration |
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonImportSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol.AddDeclaration Method

PythonImportSymbolAddDeclaration Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddDeclaration(
    string declaration,
    string alias
)
Public Overridable Sub AddDeclaration (
    declaration As String,
    alias As String
)
public:
virtual void AddDeclaration(
    String^ declaration,
    String^ alias
)
abstract AddDeclaration :
        declaration : string *
        alias : string -> unit
override AddDeclaration :
        declaration : string *
        alias : string -> unit

Parameters

declaration
Type: SystemString
alias
Type: SystemString

Implements

IPythonImportSymbolAddDeclaration(String, String)
See Also

Reference

PythonImportSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol.FindDeclaration Method

PythonImportSymbolFindDeclaration Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPythonSymbol FindDeclaration(
    string reference
)
Public Overridable Function FindDeclaration (
    reference As String
) As IPythonSymbol
public:
virtual IPythonSymbol^ FindDeclaration(
    String^ reference
)
abstract FindDeclaration :
        reference : string -> IPythonSymbol
override FindDeclaration :
        reference : string -> IPythonSymbol

Parameters

reference
Type: SystemString

Return Value

Type: IPythonSymbol

Implements

IPythonImportSymbolFindDeclaration(String)
See Also

Reference

PythonImportSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol Properties

PythonImportSymbol Properties

The PythonImportSymbol type exposes the following members.

Properties
 | Name | Description
Public property | Alias |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Declarations |
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Module |
Public property | ModuleName |
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonImportSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol.Alias Property

PythonImportSymbolAlias Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set
public:
virtual property String^ Alias {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Alias : string with get, set
override Alias : string with get, set

Property Value

Type: String

Implements

IPythonImportSymbolAlias
See Also

Reference

PythonImportSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol.Declarations Property

PythonImportSymbolDeclarations Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> Declarations { get; }
Public ReadOnly Property Declarations As IDictionary(Of String, String)
    Get
public:
virtual property IDictionary<String^, String^>^ Declarations {
    IDictionary<String^, String^>^ get () sealed;
}
abstract Declarations : IDictionary<string, string> with get
override Declarations : IDictionary<string, string> with get

Property Value

Type: IDictionaryString, String

Implements

IPythonImportSymbolDeclarations
See Also

Reference

PythonImportSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol.Module Property

PythonImportSymbolModule Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonModuleSymbol Module { get; set; }
Public Property Module As IPythonModuleSymbol
    Get
    Set
public:
virtual property IPythonModuleSymbol^ Module {
    IPythonModuleSymbol^ get () sealed;
    void set (IPythonModuleSymbol^ value) sealed;
}
abstract Module : IPythonModuleSymbol with get, set
override Module : IPythonModuleSymbol with get, set

Property Value

Type: IPythonModuleSymbol

Implements

IPythonImportSymbolModule
See Also

Reference

PythonImportSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonImportSymbol.ModuleName Property

PythonImportSymbolModuleName Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ModuleName { get; set; }
Public Property ModuleName As String
    Get
    Set
public:
virtual property String^ ModuleName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ModuleName : string with get, set
override ModuleName : string with get, set

Property Value

Type: String

Implements

IPythonImportSymbolModuleName
See Also

Reference

PythonImportSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLambdaContext Class

PythonLambdaContext Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonMethodContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonLambdaContext

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonLambdaContext : PythonMethodContext
Public Class PythonLambdaContext
    Inherits PythonMethodContext
public ref class PythonLambdaContext : public PythonMethodContext
type PythonLambdaContext =
    class
        inherit PythonMethodContext
    end

The PythonLambdaContext type exposes the following members.

Constructors
 | Name | Description
Public method | PythonLambdaContext | Initializes a new instance of the PythonLambdaContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLambdaContext Constructor

PythonLambdaContext Constructor
Initializes a new instance of the PythonLambdaContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonLambdaContext(
    IPythonSemanticModel model,
    ISyntaxNode node,
    IPythonSymbol containingSymbol
)
Public Sub New (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    containingSymbol As IPythonSymbol
)
public:
PythonLambdaContext(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    IPythonSymbol^ containingSymbol
)
new :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        containingSymbol : IPythonSymbol -> PythonLambdaContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonLambdaContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLambdaContext Methods

PythonLambdaContext Methods

The PythonLambdaContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonLambdaContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLambdaContext Properties

PythonLambdaContext Properties

The PythonLambdaContext type exposes the following members.

Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

PythonLambdaContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonListTypeSymbol Class

PythonListTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonListTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonListTypeSymbol : PythonClassSymbol
Public Class PythonListTypeSymbol
    Inherits PythonClassSymbol
public ref class PythonListTypeSymbol : public PythonClassSymbol
type PythonListTypeSymbol =
    class
        inherit PythonClassSymbol
    end

The PythonListTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonListTypeSymbol | Initializes a new instance of the PythonListTypeSymbol class
Top
Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonListTypeSymbol Constructor

PythonListTypeSymbol Constructor
Initializes a new instance of the PythonListTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonListTypeSymbol(
    string name
)
Public Sub New (
    name As String
)
public:
PythonListTypeSymbol(
    String^ name
)
new :
        name : string -> PythonListTypeSymbol

Parameters

name
Type: SystemString
See Also

Reference

PythonListTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonListTypeSymbol Methods

PythonListTypeSymbol Methods

The PythonListTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonListTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonListTypeSymbol Properties

PythonListTypeSymbol Properties

The PythonListTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonListTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLocalVariableSymbol Class

PythonLocalVariableSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonLocalVariableSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonLocalVariableSymbol : PythonSymbol,
    IPythonLocalVariableSymbol, IPythonSymbol
Public Class PythonLocalVariableSymbol
    Inherits PythonSymbol
    Implements IPythonLocalVariableSymbol, IPythonSymbol
public ref class PythonLocalVariableSymbol : public PythonSymbol,
    IPythonLocalVariableSymbol, IPythonSymbol
type PythonLocalVariableSymbol =
    class
        inherit PythonSymbol
        interface IPythonLocalVariableSymbol
        interface IPythonSymbol
    end

The PythonLocalVariableSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonLocalVariableSymbol | Initializes a new instance of the PythonLocalVariableSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Overrides PythonSymbolScope.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Public property | VariableType |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLocalVariableSymbol Constructor

PythonLocalVariableSymbol Constructor
Initializes a new instance of the PythonLocalVariableSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonLocalVariableSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonLocalVariableSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonLocalVariableSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonLocalVariableSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLocalVariableSymbol Methods

PythonLocalVariableSymbol Methods

The PythonLocalVariableSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonLocalVariableSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLocalVariableSymbol.GetDataType Method

PythonLocalVariableSymbolGetDataType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDataType()
Public Overrides Function GetDataType As String
public:
virtual String^ GetDataType() override
abstract GetDataType : unit -> string
override GetDataType : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDataType
IPythonSymbolGetDataType
See Also

Reference

PythonLocalVariableSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLocalVariableSymbol.GetDisplayName Method

PythonLocalVariableSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayName()
Public Overrides Function GetDisplayName As String
public:
virtual String^ GetDisplayName() override
abstract GetDisplayName : unit -> string
override GetDisplayName : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDisplayName
IPythonSymbolGetDisplayName
See Also

Reference

PythonLocalVariableSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLocalVariableSymbol Properties

PythonLocalVariableSymbol Properties

The PythonLocalVariableSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Overrides PythonSymbolScope.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Public property | VariableType |
Top
See Also

Reference

PythonLocalVariableSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLocalVariableSymbol.Scope Property

PythonLocalVariableSymbolScope Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override PythonScope Scope { get; }
Public Overrides ReadOnly Property Scope As PythonScope
    Get
public:
virtual property PythonScope Scope {
    PythonScope get () override;
}
abstract Scope : PythonScope with get
override Scope : PythonScope with get

Property Value

Type: PythonScope

Implements

IPythonSymbolScope
IPythonSymbolScope
See Also

Reference

PythonLocalVariableSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonLocalVariableSymbol.VariableType Property

PythonLocalVariableSymbolVariableType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonTypeSymbol VariableType { get; set; }
Public Property VariableType As IPythonTypeSymbol
    Get
    Set
public:
virtual property IPythonTypeSymbol^ VariableType {
    IPythonTypeSymbol^ get () sealed;
    void set (IPythonTypeSymbol^ value) sealed;
}
abstract VariableType : IPythonTypeSymbol with get, set
override VariableType : IPythonTypeSymbol with get, set

Property Value

Type: IPythonTypeSymbol

Implements

IPythonLocalVariableSymbolVariableType
See Also

Reference

PythonLocalVariableSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodContext Class

PythonMethodContext Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonMethodContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonLambdaContext

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonMethodContext : PythonContext
Public Class PythonMethodContext
    Inherits PythonContext
public ref class PythonMethodContext : public PythonContext
type PythonMethodContext =
    class
        inherit PythonContext
    end

The PythonMethodContext type exposes the following members.

Constructors
 | Name | Description
Public method | PythonMethodContext | Initializes a new instance of the PythonMethodContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodContext Constructor

PythonMethodContext Constructor
Initializes a new instance of the PythonMethodContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonMethodContext(
    IPythonSemanticModel model,
    ISyntaxNode node,
    IPythonSymbol symbol,
    IPythonSymbol containingSymbol
)
Public Sub New (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    symbol As IPythonSymbol,
    containingSymbol As IPythonSymbol
)
public:
PythonMethodContext(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    IPythonSymbol^ symbol,
    IPythonSymbol^ containingSymbol
)
new :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        symbol : IPythonSymbol *
        containingSymbol : IPythonSymbol -> PythonMethodContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonMethodContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodContext Methods

PythonMethodContext Methods

The PythonMethodContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Inherited from PythonContext.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonMethodContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodContext Properties

PythonMethodContext Properties

The PythonMethodContext type exposes the following members.

Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

PythonMethodContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol Class

PythonMethodSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonMethodSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonMethodSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonMethodSymbol : PythonSymbol,
    IPythonMethodSymbol, IPythonSymbol
Public Class PythonMethodSymbol
    Inherits PythonSymbol
    Implements IPythonMethodSymbol, IPythonSymbol
public ref class PythonMethodSymbol : public PythonSymbol,
    IPythonMethodSymbol, IPythonSymbol
type PythonMethodSymbol =
    class
        inherit PythonSymbol
        interface IPythonMethodSymbol
        interface IPythonSymbol
    end

The PythonMethodSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonMethodSymbol(String, IPythonSymbol) | Initializes a new instance of the PythonMethodSymbol class
Public method | PythonMethodSymbol(String, IPythonSymbol, IPythonTypeSymbol, String, IPythonTypeSymbol, Int32, Boolean) | Initializes a new instance of the PythonMethodSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName(Boolean, Color) | Overloaded. (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName(Boolean, Color) | Overloaded. (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsConstructor |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | OpenArgs |
Public property | OptionalParameter |
Public property | Parameters |
Public property | ReturnType |
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol Constructor

PythonMethodSymbol Constructor
Overload List
 | Name | Description
Public method | PythonMethodSymbol(String, IPythonSymbol) | Initializes a new instance of the PythonMethodSymbol class
Public method | PythonMethodSymbol(String, IPythonSymbol, IPythonTypeSymbol, String, IPythonTypeSymbol, Int32, Boolean) | Initializes a new instance of the PythonMethodSymbol class
Top
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol Constructor (String, IPythonSymbol)

PythonMethodSymbol Constructor (String, IPythonSymbol)
Initializes a new instance of the PythonMethodSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonMethodSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonMethodSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonMethodSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonMethodSymbol Class
PythonMethodSymbol Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol Constructor (String, IPythonSymbol, IPythonTypeSymbol, String[], IPythonTypeSymbol[], Int32, Boolean)

PythonMethodSymbol Constructor (String, IPythonSymbol, IPythonTypeSymbol, String, IPythonTypeSymbol, Int32, Boolean)
Initializes a new instance of the PythonMethodSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonMethodSymbol(
    string name,
    IPythonSymbol containingSymbol,
    IPythonTypeSymbol returnType,
    string[] paramNames = null,
    IPythonTypeSymbol[] paramTypes = null,
    int optionalParameter = -1,
    bool openArgs = false
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol,
    returnType As IPythonTypeSymbol,
    Optional paramNames As String() = Nothing,
    Optional paramTypes As IPythonTypeSymbol() = Nothing,
    Optional optionalParameter As Integer = -1,
    Optional openArgs As Boolean = false
)
public:
PythonMethodSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol,
    IPythonTypeSymbol^ returnType,
    array<String^>^ paramNames = nullptr,
    array<IPythonTypeSymbol^>^ paramTypes = nullptr,
    int optionalParameter = -1,
    bool openArgs = false
)
new :
        name : string *
        containingSymbol : IPythonSymbol *
        returnType : IPythonTypeSymbol *
        ?paramNames : string[] *
        ?paramTypes : IPythonTypeSymbol[] *
        ?optionalParameter : int *
        ?openArgs : bool
(* Defaults:
        let _paramNames = defaultArg paramNames null
        let _paramTypes = defaultArg paramTypes null
        let _optionalParameter = defaultArg optionalParameter -1
        let _openArgs = defaultArg openArgs false
*)
-> PythonMethodSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
returnType
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonTypeSymbol
paramNames (Optional)
Type: SystemString
paramTypes (Optional)
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonTypeSymbol
optionalParameter (Optional)
Type: SystemInt32
openArgs (Optional)
Type: SystemBoolean
See Also

Reference

PythonMethodSymbol Class
PythonMethodSymbol Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol Methods

PythonMethodSymbol Methods

The PythonMethodSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName(Boolean, Color) | Overloaded. (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName(Boolean, Color) | Overloaded. (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol.GetDataType Method

PythonMethodSymbolGetDataType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDataType()
Public Overrides Function GetDataType As String
public:
virtual String^ GetDataType() override
abstract GetDataType : unit -> string
override GetDataType : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDataType
IPythonSymbolGetDataType
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol.GetDisplayName Method

PythonMethodSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayName()
Public Overrides Function GetDisplayName As String
public:
virtual String^ GetDisplayName() override
abstract GetDisplayName : unit -> string
override GetDisplayName : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDisplayName
IPythonSymbolGetDisplayName
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol Properties

PythonMethodSymbol Properties

The PythonMethodSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsConstructor |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | OpenArgs |
Public property | OptionalParameter |
Public property | Parameters |
Public property | ReturnType |
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol.IsConstructor Property

PythonMethodSymbolIsConstructor Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsConstructor { get; }
Public Overridable ReadOnly Property IsConstructor As Boolean
    Get
public:
virtual property bool IsConstructor {
    bool get ();
}
abstract IsConstructor : bool with get
override IsConstructor : bool with get

Property Value

Type: Boolean

Implements

IPythonMethodSymbolIsConstructor
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol.OpenArgs Property

PythonMethodSymbolOpenArgs Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OpenArgs { get; set; }
Public Property OpenArgs As Boolean
    Get
    Set
public:
virtual property bool OpenArgs {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract OpenArgs : bool with get, set
override OpenArgs : bool with get, set

Property Value

Type: Boolean

Implements

IPythonMethodSymbolOpenArgs
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol.OptionalParameter Property

PythonMethodSymbolOptionalParameter Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int OptionalParameter { get; set; }
Public Property OptionalParameter As Integer
    Get
    Set
public:
virtual property int OptionalParameter {
    int get () sealed;
    void set (int value) sealed;
}
abstract OptionalParameter : int with get, set
override OptionalParameter : int with get, set

Property Value

Type: Int32

Implements

IPythonMethodSymbolOptionalParameter
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol.Parameters Property

PythonMethodSymbolParameters Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IPythonParameterSymbol> Parameters { get; set; }
Public Property Parameters As IList(Of IPythonParameterSymbol)
    Get
    Set
public:
virtual property IList<IPythonParameterSymbol^>^ Parameters {
    IList<IPythonParameterSymbol^>^ get () sealed;
    void set (IList<IPythonParameterSymbol^>^ value) sealed;
}
abstract Parameters : IList<IPythonParameterSymbol> with get, set
override Parameters : IList<IPythonParameterSymbol> with get, set

Property Value

Type: IListIPythonParameterSymbol

Implements

IPythonMethodSymbolParameters
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonMethodSymbol.ReturnType Property

PythonMethodSymbolReturnType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonTypeSymbol ReturnType { get; set; }
Public Property ReturnType As IPythonTypeSymbol
    Get
    Set
public:
virtual property IPythonTypeSymbol^ ReturnType {
    IPythonTypeSymbol^ get () sealed;
    void set (IPythonTypeSymbol^ value) sealed;
}
abstract ReturnType : IPythonTypeSymbol with get, set
override ReturnType : IPythonTypeSymbol with get, set

Property Value

Type: IPythonTypeSymbol

Implements

IPythonMethodSymbolReturnType
See Also

Reference

PythonMethodSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleContext Class

PythonModuleContext Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassContext
Alternet.Syntax.Parsers.Python.SemanticModelPythonModuleContext
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonModuleContext

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonModuleContext : PythonClassContext
Public Class PythonModuleContext
    Inherits PythonClassContext
public ref class PythonModuleContext : public PythonClassContext
type PythonModuleContext =
    class
        inherit PythonClassContext
    end

The PythonModuleContext type exposes the following members.

Constructors
 | Name | Description
Public method | PythonModuleContext(IPythonSemanticModel, IPythonSymbol) | Initializes a new instance of the PythonModuleContext class
Public method | PythonModuleContext(IPythonSemanticModel, ISyntaxNode, IPythonModuleSymbol) | Initializes a new instance of the PythonModuleContext class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Overrides PythonContextFindDeclaration(ISyntaxNode, Point).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleContext Constructor

PythonModuleContext Constructor
Overload List
 | Name | Description
Public method | PythonModuleContext(IPythonSemanticModel, IPythonSymbol) | Initializes a new instance of the PythonModuleContext class
Public method | PythonModuleContext(IPythonSemanticModel, ISyntaxNode, IPythonModuleSymbol) | Initializes a new instance of the PythonModuleContext class
Top
See Also

Reference

PythonModuleContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleContext Constructor (IPythonSemanticModel, IPythonSymbol)

PythonModuleContext Constructor (IPythonSemanticModel, IPythonSymbol)
Initializes a new instance of the PythonModuleContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonModuleContext(
    IPythonSemanticModel model,
    IPythonSymbol symbol
)
Public Sub New (
    model As IPythonSemanticModel,
    symbol As IPythonSymbol
)
public:
PythonModuleContext(
    IPythonSemanticModel^ model,
    IPythonSymbol^ symbol
)
new :
        model : IPythonSemanticModel *
        symbol : IPythonSymbol -> PythonModuleContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonModuleContext Class
PythonModuleContext Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleContext Constructor (IPythonSemanticModel, ISyntaxNode, IPythonModuleSymbol)

PythonModuleContext Constructor (IPythonSemanticModel, ISyntaxNode, IPythonModuleSymbol)
Initializes a new instance of the PythonModuleContext class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonModuleContext(
    IPythonSemanticModel model,
    ISyntaxNode node,
    IPythonModuleSymbol symbol
)
Public Sub New (
    model As IPythonSemanticModel,
    node As ISyntaxNode,
    symbol As IPythonModuleSymbol
)
public:
PythonModuleContext(
    IPythonSemanticModel^ model,
    ISyntaxNode^ node,
    IPythonModuleSymbol^ symbol
)
new :
        model : IPythonSemanticModel *
        node : ISyntaxNode *
        symbol : IPythonModuleSymbol -> PythonModuleContext

Parameters

model
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSemanticModel
node
Type: Alternet.SyntaxISyntaxNode
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonModuleSymbol
See Also

Reference

PythonModuleContext Class
PythonModuleContext Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleContext Methods

PythonModuleContext Methods

The PythonModuleContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindDeclaration | (Overrides PythonContextFindDeclaration(ISyntaxNode, Point).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidPosition | (Inherited from PythonContext.)
Public method | IsValidScope | (Inherited from PythonContext.)
Public method | Load | (Inherited from PythonContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonModuleContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleContext.FindDeclaration Method

PythonModuleContextFindDeclaration Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IPythonSymbol FindDeclaration(
    ISyntaxNode reference,
    Point position
)
Public Overrides Function FindDeclaration (
    reference As ISyntaxNode,
    position As Point
) As IPythonSymbol
public:
virtual IPythonSymbol^ FindDeclaration(
    ISyntaxNode^ reference,
    Point position
) override
abstract FindDeclaration :
        reference : ISyntaxNode *
        position : Point -> IPythonSymbol
override FindDeclaration :
        reference : ISyntaxNode *
        position : Point -> IPythonSymbol

Parameters

reference
Type: Alternet.SyntaxISyntaxNode
position
Type: System.DrawingPoint

Return Value

Type: IPythonSymbol
See Also

Reference

PythonModuleContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleContext Properties

PythonModuleContext Properties

The PythonModuleContext type exposes the following members.

Properties
 | Name | Description
Public property | IsLocal | (Inherited from PythonContext.)
Public property | IsStatic | (Inherited from PythonContext.)
Public property | Node | (Inherited from PythonContext.)
Public property | Symbol | (Inherited from PythonContext.)
Top
See Also

Reference

PythonModuleContext Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleLoader Class

PythonModuleLoader Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonModuleLoader

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PythonModuleLoader
Public NotInheritable Class PythonModuleLoader
public ref class PythonModuleLoader abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PythonModuleLoader =  class end

The PythonModuleLoader type exposes the following members.

Methods
Name | Description
Clear |
LoadFile |
LoadModule |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleLoader Methods

PythonModuleLoader Methods

The PythonModuleLoader type exposes the following members.

Methods
Name | Description
Clear |
LoadFile |
LoadModule |
Top
See Also

Reference

PythonModuleLoader Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleLoader.Clear Method

PythonModuleLoaderClear Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Clear()
Public Shared Sub Clear
public:
static void Clear()
static member Clear : unit -> unit
See Also

Reference

PythonModuleLoader Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleLoader.LoadFile Method

PythonModuleLoaderLoadFile Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IStringList LoadFile(
    string fileName
)
Public Shared Function LoadFile (
    fileName As String
) As IStringList
public:
static IStringList^ LoadFile(
    String^ fileName
)
static member LoadFile :
        fileName : string -> IStringList

Parameters

fileName
Type: SystemString

Return Value

Type: IStringList
See Also

Reference

PythonModuleLoader Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleLoader.LoadModule Method

PythonModuleLoaderLoadModule Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonModuleSymbol LoadModule(
    ICodeEnvironment codeEnvironment,
    string moduleName
)
Public Shared Function LoadModule (
    codeEnvironment As ICodeEnvironment,
    moduleName As String
) As IPythonModuleSymbol
public:
static IPythonModuleSymbol^ LoadModule(
    ICodeEnvironment^ codeEnvironment,
    String^ moduleName
)
static member LoadModule :
        codeEnvironment : ICodeEnvironment *
        moduleName : string -> IPythonModuleSymbol

Parameters

codeEnvironment
Type: ICodeEnvironment
moduleName
Type: SystemString

Return Value

Type: IPythonModuleSymbol
See Also

Reference

PythonModuleLoader Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol Class

PythonModuleSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonModuleSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonModuleSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonModuleSymbol : PythonClassSymbol,
    IPythonModuleSymbol, IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
Public Class PythonModuleSymbol
    Inherits PythonClassSymbol
    Implements IPythonModuleSymbol, IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
public ref class PythonModuleSymbol : public PythonClassSymbol,
    IPythonModuleSymbol, IPythonClassSymbol, IPythonTypeSymbol, IPythonSymbol
type PythonModuleSymbol =
    class
        inherit PythonClassSymbol
        interface IPythonModuleSymbol
        interface IPythonClassSymbol
        interface IPythonTypeSymbol
        interface IPythonSymbol
    end

The PythonModuleSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonModuleSymbol | Initializes a new instance of the PythonModuleSymbol class
Top
Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | AddGlobalVariable |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindGlobalVariable |
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FileName |
Public property | GlobalTypes |
Public property | GlobalVariables |
Public property | Imports |
Public property | IsGlobal |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol Constructor

PythonModuleSymbol Constructor
Initializes a new instance of the PythonModuleSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonModuleSymbol(
    string fileName,
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    fileName As String,
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonModuleSymbol(
    String^ fileName,
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        fileName : string *
        name : string *
        containingSymbol : IPythonSymbol -> PythonModuleSymbol

Parameters

fileName
Type: SystemString
name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol Methods

PythonModuleSymbol Methods

The PythonModuleSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | AddGlobalVariable |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindGlobalVariable |
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol.AddGlobalVariable Method

PythonModuleSymbolAddGlobalVariable Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddGlobalVariable(
    IPythonSymbol symbol
)
Public Overridable Sub AddGlobalVariable (
    symbol As IPythonSymbol
)
public:
virtual void AddGlobalVariable(
    IPythonSymbol^ symbol
)
abstract AddGlobalVariable :
        symbol : IPythonSymbol -> unit
override AddGlobalVariable :
        symbol : IPythonSymbol -> unit

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Implements

IPythonModuleSymbolAddGlobalVariable(IPythonSymbol)
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol.FindGlobalVariable Method

PythonModuleSymbolFindGlobalVariable Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPythonSymbol FindGlobalVariable(
    string reference
)
Public Overridable Function FindGlobalVariable (
    reference As String
) As IPythonSymbol
public:
virtual IPythonSymbol^ FindGlobalVariable(
    String^ reference
)
abstract FindGlobalVariable :
        reference : string -> IPythonSymbol
override FindGlobalVariable :
        reference : string -> IPythonSymbol

Parameters

reference
Type: SystemString

Return Value

Type: IPythonSymbol

Implements

IPythonModuleSymbolFindGlobalVariable(String)
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol Properties

PythonModuleSymbol Properties

The PythonModuleSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | FileName |
Public property | GlobalTypes |
Public property | GlobalVariables |
Public property | Imports |
Public property | IsGlobal |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol.FileName Property

PythonModuleSymbolFileName Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

IPythonModuleSymbolFileName
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol.GlobalTypes Property

PythonModuleSymbolGlobalTypes Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<IPythonTypeSymbol> GlobalTypes { get; }
Public Overridable ReadOnly Property GlobalTypes As IList(Of IPythonTypeSymbol)
    Get
public:
virtual property IList<IPythonTypeSymbol^>^ GlobalTypes {
    IList<IPythonTypeSymbol^>^ get ();
}
abstract GlobalTypes : IList<IPythonTypeSymbol> with get
override GlobalTypes : IList<IPythonTypeSymbol> with get

Property Value

Type: IListIPythonTypeSymbol

Implements

IPythonModuleSymbolGlobalTypes
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol.GlobalVariables Property

PythonModuleSymbolGlobalVariables Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IDictionary<string, IPythonSymbol> GlobalVariables { get; }
Public Overridable ReadOnly Property GlobalVariables As IDictionary(Of String, IPythonSymbol)
    Get
public:
virtual property IDictionary<String^, IPythonSymbol^>^ GlobalVariables {
    IDictionary<String^, IPythonSymbol^>^ get ();
}
abstract GlobalVariables : IDictionary<string, IPythonSymbol> with get
override GlobalVariables : IDictionary<string, IPythonSymbol> with get

Property Value

Type: IDictionaryString, IPythonSymbol

Implements

IPythonModuleSymbolGlobalVariables
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol.Imports Property

PythonModuleSymbolImports Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IPythonImportSymbol> Imports { get; }
Public ReadOnly Property Imports As IList(Of IPythonImportSymbol)
    Get
public:
virtual property IList<IPythonImportSymbol^>^ Imports {
    IList<IPythonImportSymbol^>^ get () sealed;
}
abstract Imports : IList<IPythonImportSymbol> with get
override Imports : IList<IPythonImportSymbol> with get

Property Value

Type: IListIPythonImportSymbol

Implements

IPythonModuleSymbolImports
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonModuleSymbol.IsGlobal Property

PythonModuleSymbolIsGlobal Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsGlobal { get; set; }
Public Property IsGlobal As Boolean
    Get
    Set
public:
virtual property bool IsGlobal {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsGlobal : bool with get, set
override IsGlobal : bool with get, set

Property Value

Type: Boolean

Implements

IPythonModuleSymbolIsGlobal
See Also

Reference

PythonModuleSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol Class

PythonObjectTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonObjectTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonObjectTypeSymbol : PythonTypeSymbol
Public Class PythonObjectTypeSymbol
    Inherits PythonTypeSymbol
public ref class PythonObjectTypeSymbol : public PythonTypeSymbol
type PythonObjectTypeSymbol =
    class
        inherit PythonTypeSymbol
    end

The PythonObjectTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonObjectTypeSymbol | Initializes a new instance of the PythonObjectTypeSymbol class
Top
Methods
 | Name | Description
 | ContainsType |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
 | DictType |
 | FileType |
 | FunctionType |
Public property | IsStatic | (Inherited from PythonSymbol.)
 | IterableType |
 | ListType |
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
 | ObjectType |
 | RangeType |
Public property | Scope | (Inherited from PythonSymbol.)
 | SetType |
Public property | SymbolKind | (Inherited from PythonSymbol.)
 | TupleType |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol Constructor

PythonObjectTypeSymbol Constructor
Initializes a new instance of the PythonObjectTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonObjectTypeSymbol(
    string name
)
Public Sub New (
    name As String
)
public:
PythonObjectTypeSymbol(
    String^ name
)
new :
        name : string -> PythonObjectTypeSymbol

Parameters

name
Type: SystemString
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol Methods

PythonObjectTypeSymbol Methods

The PythonObjectTypeSymbol type exposes the following members.

Methods
 | Name | Description
 | ContainsType |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.ContainsType Method

PythonObjectTypeSymbolContainsType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ContainsType(
    IPythonSymbol symbol
)
Public Shared Function ContainsType (
    symbol As IPythonSymbol
) As Boolean
public:
static bool ContainsType(
    IPythonSymbol^ symbol
)
static member ContainsType :
        symbol : IPythonSymbol -> bool

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: Boolean
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.GetDisplayName Method

PythonObjectTypeSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayName()
Public Overrides Function GetDisplayName As String
public:
virtual String^ GetDisplayName() override
abstract GetDisplayName : unit -> string
override GetDisplayName : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDisplayName
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol Properties

PythonObjectTypeSymbol Properties

The PythonObjectTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
 | DictType |
 | FileType |
 | FunctionType |
Public property | IsStatic | (Inherited from PythonSymbol.)
 | IterableType |
 | ListType |
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
 | ObjectType |
 | RangeType |
Public property | Scope | (Inherited from PythonSymbol.)
 | SetType |
Public property | SymbolKind | (Inherited from PythonSymbol.)
 | TupleType |
Top
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.DictType Property

PythonObjectTypeSymbolDictType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol DictType { get; }
Public Shared ReadOnly Property DictType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ DictType {
    IPythonTypeSymbol^ get ();
}
static member DictType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.FileType Property

PythonObjectTypeSymbolFileType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol FileType { get; }
Public Shared ReadOnly Property FileType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ FileType {
    IPythonTypeSymbol^ get ();
}
static member FileType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.FunctionType Property

PythonObjectTypeSymbolFunctionType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol FunctionType { get; }
Public Shared ReadOnly Property FunctionType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ FunctionType {
    IPythonTypeSymbol^ get ();
}
static member FunctionType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.IterableType Property

PythonObjectTypeSymbolIterableType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol IterableType { get; }
Public Shared ReadOnly Property IterableType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ IterableType {
    IPythonTypeSymbol^ get ();
}
static member IterableType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.ListType Property

PythonObjectTypeSymbolListType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol ListType { get; }
Public Shared ReadOnly Property ListType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ ListType {
    IPythonTypeSymbol^ get ();
}
static member ListType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.ObjectType Property

PythonObjectTypeSymbolObjectType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol ObjectType { get; }
Public Shared ReadOnly Property ObjectType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ ObjectType {
    IPythonTypeSymbol^ get ();
}
static member ObjectType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.RangeType Property

PythonObjectTypeSymbolRangeType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol RangeType { get; }
Public Shared ReadOnly Property RangeType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ RangeType {
    IPythonTypeSymbol^ get ();
}
static member RangeType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.SetType Property

PythonObjectTypeSymbolSetType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol SetType { get; }
Public Shared ReadOnly Property SetType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ SetType {
    IPythonTypeSymbol^ get ();
}
static member SetType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonObjectTypeSymbol.TupleType Property

PythonObjectTypeSymbolTupleType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol TupleType { get; }
Public Shared ReadOnly Property TupleType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ TupleType {
    IPythonTypeSymbol^ get ();
}
static member TupleType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonObjectTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonParameterSymbol Class

PythonParameterSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonParameterSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonParameterSymbol : PythonSymbol,
    IPythonParameterSymbol, IPythonSymbol
Public Class PythonParameterSymbol
    Inherits PythonSymbol
    Implements IPythonParameterSymbol, IPythonSymbol
public ref class PythonParameterSymbol : public PythonSymbol,
    IPythonParameterSymbol, IPythonSymbol
type PythonParameterSymbol =
    class
        inherit PythonSymbol
        interface IPythonParameterSymbol
        interface IPythonSymbol
    end

The PythonParameterSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParameterSymbol | Initializes a new instance of the PythonParameterSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetParamText | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsOptional |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | ParameterType |
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonParameterSymbol Constructor

PythonParameterSymbol Constructor
Initializes a new instance of the PythonParameterSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonParameterSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonParameterSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonParameterSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonParameterSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonParameterSymbol Methods

PythonParameterSymbol Methods

The PythonParameterSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Overrides PythonSymbolGetDataType.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetParamText | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonParameterSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonParameterSymbol.GetDataType Method

PythonParameterSymbolGetDataType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDataType()
Public Overrides Function GetDataType As String
public:
virtual String^ GetDataType() override
abstract GetDataType : unit -> string
override GetDataType : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDataType
IPythonSymbolGetDataType
See Also

Reference

PythonParameterSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonParameterSymbol.GetDisplayName Method

PythonParameterSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayName()
Public Overrides Function GetDisplayName As String
public:
virtual String^ GetDisplayName() override
abstract GetDisplayName : unit -> string
override GetDisplayName : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDisplayName
IPythonSymbolGetDisplayName
See Also

Reference

PythonParameterSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonParameterSymbol Properties

PythonParameterSymbol Properties

The PythonParameterSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsOptional |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | ParameterType |
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonParameterSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonParameterSymbol.IsOptional Property

PythonParameterSymbolIsOptional Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOptional { get; set; }
Public Property IsOptional As Boolean
    Get
    Set
public:
virtual property bool IsOptional {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsOptional : bool with get, set
override IsOptional : bool with get, set

Property Value

Type: Boolean

Implements

IPythonParameterSymbolIsOptional
See Also

Reference

PythonParameterSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonParameterSymbol.ParameterType Property

PythonParameterSymbolParameterType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonTypeSymbol ParameterType { get; set; }
Public Property ParameterType As IPythonTypeSymbol
    Get
    Set
public:
virtual property IPythonTypeSymbol^ ParameterType {
    IPythonTypeSymbol^ get () sealed;
    void set (IPythonTypeSymbol^ value) sealed;
}
abstract ParameterType : IPythonTypeSymbol with get, set
override ParameterType : IPythonTypeSymbol with get, set

Property Value

Type: IPythonTypeSymbol

Implements

IPythonParameterSymbolParameterType
See Also

Reference

PythonParameterSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol Class

PythonPrimitiveTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonPrimitiveTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonPrimitiveTypeSymbol : PythonTypeSymbol
Public Class PythonPrimitiveTypeSymbol
    Inherits PythonTypeSymbol
public ref class PythonPrimitiveTypeSymbol : public PythonTypeSymbol
type PythonPrimitiveTypeSymbol =
    class
        inherit PythonTypeSymbol
    end

The PythonPrimitiveTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonPrimitiveTypeSymbol | Initializes a new instance of the PythonPrimitiveTypeSymbol class
Top
Methods
 | Name | Description
 | ContainsType |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
 | BoolType |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
 | FloatType |
 | IntType |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
 | StringType |
Public property | SymbolKind | (Inherited from PythonSymbol.)
 | VoidType |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol Constructor

PythonPrimitiveTypeSymbol Constructor
Initializes a new instance of the PythonPrimitiveTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonPrimitiveTypeSymbol(
    string name
)
Public Sub New (
    name As String
)
public:
PythonPrimitiveTypeSymbol(
    String^ name
)
new :
        name : string -> PythonPrimitiveTypeSymbol

Parameters

name
Type: SystemString
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol Methods

PythonPrimitiveTypeSymbol Methods

The PythonPrimitiveTypeSymbol type exposes the following members.

Methods
 | Name | Description
 | ContainsType |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Overrides PythonSymbolGetDisplayName.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol.ContainsType Method

PythonPrimitiveTypeSymbolContainsType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ContainsType(
    IPythonSymbol symbol
)
Public Shared Function ContainsType (
    symbol As IPythonSymbol
) As Boolean
public:
static bool ContainsType(
    IPythonSymbol^ symbol
)
static member ContainsType :
        symbol : IPythonSymbol -> bool

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: Boolean
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol.GetDisplayName Method

PythonPrimitiveTypeSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayName()
Public Overrides Function GetDisplayName As String
public:
virtual String^ GetDisplayName() override
abstract GetDisplayName : unit -> string
override GetDisplayName : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDisplayName
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol Properties

PythonPrimitiveTypeSymbol Properties

The PythonPrimitiveTypeSymbol type exposes the following members.

Properties
 | Name | Description
 | BoolType |
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
 | FloatType |
 | IntType |
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
 | StringType |
Public property | SymbolKind | (Inherited from PythonSymbol.)
 | VoidType |
Top
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol.BoolType Property

PythonPrimitiveTypeSymbolBoolType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol BoolType { get; }
Public Shared ReadOnly Property BoolType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ BoolType {
    IPythonTypeSymbol^ get ();
}
static member BoolType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol.FloatType Property

PythonPrimitiveTypeSymbolFloatType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol FloatType { get; }
Public Shared ReadOnly Property FloatType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ FloatType {
    IPythonTypeSymbol^ get ();
}
static member FloatType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol.IntType Property

PythonPrimitiveTypeSymbolIntType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol IntType { get; }
Public Shared ReadOnly Property IntType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ IntType {
    IPythonTypeSymbol^ get ();
}
static member IntType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol.StringType Property

PythonPrimitiveTypeSymbolStringType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol StringType { get; }
Public Shared ReadOnly Property StringType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ StringType {
    IPythonTypeSymbol^ get ();
}
static member StringType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonPrimitiveTypeSymbol.VoidType Property

PythonPrimitiveTypeSymbolVoidType Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IPythonTypeSymbol VoidType { get; }
Public Shared ReadOnly Property VoidType As IPythonTypeSymbol
    Get
public:
static property IPythonTypeSymbol^ VoidType {
    IPythonTypeSymbol^ get ();
}
static member VoidType : IPythonTypeSymbol with get

Property Value

Type: IPythonTypeSymbol
See Also

Reference

PythonPrimitiveTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonScope Enumeration

PythonScope Enumeration

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum PythonScope
<FlagsAttribute>
Public Enumeration PythonScope
[FlagsAttribute]
public enum class PythonScope
[<FlagsAttribute>]
type PythonScope
Members
Member name | Value | Description
None | 0 |
Instance | 1 |
Static | 2 |
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel Class

PythonSemanticModel Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSemanticModel
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonSemanticModel

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonSemanticModel : IPythonSemanticModel
Public Class PythonSemanticModel
    Implements IPythonSemanticModel
public ref class PythonSemanticModel : IPythonSemanticModel
type PythonSemanticModel =
    class
        interface IPythonSemanticModel
    end

The PythonSemanticModel type exposes the following members.

Constructors
 | Name | Description
Public method | PythonSemanticModel | Initializes a new instance of the PythonSemanticModel class
Top
Methods
 | Name | Description
Public method | Build |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReferences |
Public method | GetSymbol |
Public method | GetSymbolType(ISyntaxNode) |
Public method | GetSymbolType(IPythonSymbol, Boolean) |
Public method | GetSymbolType(ISyntaxNode, Boolean) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CodeEnvironment |
Public property | IsGlobal |
Public property | ModuleSymbol |
 | SuppressErrors |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel Constructor

PythonSemanticModel Constructor
Initializes a new instance of the PythonSemanticModel class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonSemanticModel()
Public Sub New
public:
PythonSemanticModel()
new : unit -> PythonSemanticModel
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel Methods

PythonSemanticModel Methods

The PythonSemanticModel type exposes the following members.

Methods
 | Name | Description
Public method | Build |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReferences |
Public method | GetSymbol |
Public method | GetSymbolType(ISyntaxNode) |
Public method | GetSymbolType(IPythonSymbol, Boolean) |
Public method | GetSymbolType(ISyntaxNode, Boolean) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.Build Method

PythonSemanticModelBuild Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Build(
    PythonParser parser
)
Public Overridable Sub Build (
    parser As PythonParser
)
public:
virtual void Build(
    PythonParser^ parser
)
abstract Build :
        parser : PythonParser -> unit
override Build :
        parser : PythonParser -> unit

Parameters

parser
Type: Alternet.Syntax.Parsers.PythonPythonParser

Implements

IPythonSemanticModelBuild(PythonParser)
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.GetReferences Method

PythonSemanticModelGetReferences Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<SymbolReference> GetReferences(
    IPythonSymbol symbol
)
Public Overridable Function GetReferences (
    symbol As IPythonSymbol
) As IList(Of SymbolReference)
public:
virtual IList<SymbolReference^>^ GetReferences(
    IPythonSymbol^ symbol
)
abstract GetReferences :
        symbol : IPythonSymbol -> IList<SymbolReference>
override GetReferences :
        symbol : IPythonSymbol -> IList<SymbolReference>

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: IListSymbolReference

Implements

IPythonSemanticModelGetReferences(IPythonSymbol)
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.GetSymbol Method

PythonSemanticModelGetSymbol Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPythonSymbol GetSymbol(
    ISyntaxNode node
)
Public Overridable Function GetSymbol (
    node As ISyntaxNode
) As IPythonSymbol
public:
virtual IPythonSymbol^ GetSymbol(
    ISyntaxNode^ node
)
abstract GetSymbol :
        node : ISyntaxNode -> IPythonSymbol
override GetSymbol :
        node : ISyntaxNode -> IPythonSymbol

Parameters

node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IPythonSymbol

Implements

IPythonSemanticModelGetSymbol(ISyntaxNode)
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.GetSymbolType Method

PythonSemanticModelGetSymbolType Method
Overload List
 | Name | Description
Public method | GetSymbolType(ISyntaxNode) |
Public method | GetSymbolType(IPythonSymbol, Boolean) |
Public method | GetSymbolType(ISyntaxNode, Boolean) |
Top
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.GetSymbolType Method (ISyntaxNode)

PythonSemanticModelGetSymbolType Method (ISyntaxNode)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPythonTypeSymbol GetSymbolType(
    ISyntaxNode node
)
Public Overridable Function GetSymbolType (
    node As ISyntaxNode
) As IPythonTypeSymbol
public:
virtual IPythonTypeSymbol^ GetSymbolType(
    ISyntaxNode^ node
)
abstract GetSymbolType :
        node : ISyntaxNode -> IPythonTypeSymbol
override GetSymbolType :
        node : ISyntaxNode -> IPythonTypeSymbol

Parameters

node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IPythonTypeSymbol

Implements

IPythonSemanticModelGetSymbolType(ISyntaxNode)
See Also

Reference

PythonSemanticModel Class
GetSymbolType Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.GetSymbolType Method (IPythonSymbol, Boolean)

PythonSemanticModelGetSymbolType Method (IPythonSymbol, Boolean)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPythonTypeSymbol GetSymbolType(
    IPythonSymbol symbol,
    out bool isStatic
)
Public Overridable Function GetSymbolType (
    symbol As IPythonSymbol,
    <OutAttribute> ByRef isStatic As Boolean
) As IPythonTypeSymbol
public:
virtual IPythonTypeSymbol^ GetSymbolType(
    IPythonSymbol^ symbol,
    [OutAttribute] bool% isStatic
)
abstract GetSymbolType :
        symbol : IPythonSymbol *
        isStatic : bool byref -> IPythonTypeSymbol
override GetSymbolType :
        symbol : IPythonSymbol *
        isStatic : bool byref -> IPythonTypeSymbol

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
isStatic
Type: SystemBoolean

Return Value

Type: IPythonTypeSymbol

Implements

IPythonSemanticModelGetSymbolType(IPythonSymbol, Boolean)
See Also

Reference

PythonSemanticModel Class
GetSymbolType Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.GetSymbolType Method (ISyntaxNode, Boolean)

PythonSemanticModelGetSymbolType Method (ISyntaxNode, Boolean)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IPythonTypeSymbol GetSymbolType(
    ISyntaxNode node,
    out bool isStatic
)
Public Overridable Function GetSymbolType (
    node As ISyntaxNode,
    <OutAttribute> ByRef isStatic As Boolean
) As IPythonTypeSymbol
public:
virtual IPythonTypeSymbol^ GetSymbolType(
    ISyntaxNode^ node,
    [OutAttribute] bool% isStatic
)
abstract GetSymbolType :
        node : ISyntaxNode *
        isStatic : bool byref -> IPythonTypeSymbol
override GetSymbolType :
        node : ISyntaxNode *
        isStatic : bool byref -> IPythonTypeSymbol

Parameters

node
Type: Alternet.SyntaxISyntaxNode
isStatic
Type: SystemBoolean

Return Value

Type: IPythonTypeSymbol

Implements

IPythonSemanticModelGetSymbolType(ISyntaxNode, Boolean)
See Also

Reference

PythonSemanticModel Class
GetSymbolType Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel Properties

PythonSemanticModel Properties

The PythonSemanticModel type exposes the following members.

Properties
 | Name | Description
Public property | CodeEnvironment |
Public property | IsGlobal |
Public property | ModuleSymbol |
 | SuppressErrors |
Top
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.CodeEnvironment Property

PythonSemanticModelCodeEnvironment Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICodeEnvironment CodeEnvironment { get; set; }
Public Property CodeEnvironment As ICodeEnvironment
    Get
    Set
public:
virtual property ICodeEnvironment^ CodeEnvironment {
    ICodeEnvironment^ get () sealed;
    void set (ICodeEnvironment^ value) sealed;
}
abstract CodeEnvironment : ICodeEnvironment with get, set
override CodeEnvironment : ICodeEnvironment with get, set

Property Value

Type: ICodeEnvironment

Implements

IPythonSemanticModelCodeEnvironment
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.IsGlobal Property

PythonSemanticModelIsGlobal Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsGlobal { get; set; }
Public Property IsGlobal As Boolean
    Get
    Set
public:
virtual property bool IsGlobal {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsGlobal : bool with get, set
override IsGlobal : bool with get, set

Property Value

Type: Boolean

Implements

IPythonSemanticModelIsGlobal
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.ModuleSymbol Property

PythonSemanticModelModuleSymbol Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonModuleSymbol ModuleSymbol { get; }
Public ReadOnly Property ModuleSymbol As IPythonModuleSymbol
    Get
public:
virtual property IPythonModuleSymbol^ ModuleSymbol {
    IPythonModuleSymbol^ get () sealed;
}
abstract ModuleSymbol : IPythonModuleSymbol with get
override ModuleSymbol : IPythonModuleSymbol with get

Property Value

Type: IPythonModuleSymbol

Implements

IPythonSemanticModelModuleSymbol
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSemanticModel.SuppressErrors Property

PythonSemanticModelSuppressErrors Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool SuppressErrors { get; set; }
Public Shared Property SuppressErrors As Boolean
    Get
    Set
public:
static property bool SuppressErrors {
    bool get ();
    void set (bool value);
}
static member SuppressErrors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PythonSemanticModel Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSetTypeSymbol Class

PythonSetTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonSetTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonSetTypeSymbol : PythonClassSymbol
Public Class PythonSetTypeSymbol
    Inherits PythonClassSymbol
public ref class PythonSetTypeSymbol : public PythonClassSymbol
type PythonSetTypeSymbol =
    class
        inherit PythonClassSymbol
    end

The PythonSetTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonSetTypeSymbol | Initializes a new instance of the PythonSetTypeSymbol class
Top
Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSetTypeSymbol Constructor

PythonSetTypeSymbol Constructor
Initializes a new instance of the PythonSetTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonSetTypeSymbol(
    string name
)
Public Sub New (
    name As String
)
public:
PythonSetTypeSymbol(
    String^ name
)
new :
        name : string -> PythonSetTypeSymbol

Parameters

name
Type: SystemString
See Also

Reference

PythonSetTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSetTypeSymbol Methods

PythonSetTypeSymbol Methods

The PythonSetTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonSetTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSetTypeSymbol Properties

PythonSetTypeSymbol Properties

The PythonSetTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonSetTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonStringTypeSymbol Class

PythonStringTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonStringTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonStringTypeSymbol : PythonClassSymbol
Public Class PythonStringTypeSymbol
    Inherits PythonClassSymbol
public ref class PythonStringTypeSymbol : public PythonClassSymbol
type PythonStringTypeSymbol =
    class
        inherit PythonClassSymbol
    end

The PythonStringTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonStringTypeSymbol | Initializes a new instance of the PythonStringTypeSymbol class
Top
Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonStringTypeSymbol Constructor

PythonStringTypeSymbol Constructor
Initializes a new instance of the PythonStringTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonStringTypeSymbol(
    string name
)
Public Sub New (
    name As String
)
public:
PythonStringTypeSymbol(
    String^ name
)
new :
        name : string -> PythonStringTypeSymbol

Parameters

name
Type: SystemString
See Also

Reference

PythonStringTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonStringTypeSymbol Methods

PythonStringTypeSymbol Methods

The PythonStringTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonStringTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonStringTypeSymbol Properties

PythonStringTypeSymbol Properties

The PythonStringTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonStringTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonStructSymbol Class

PythonStructSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonStructSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonStructSymbol : PythonClassSymbol
Public Class PythonStructSymbol
    Inherits PythonClassSymbol
public ref class PythonStructSymbol : public PythonClassSymbol
type PythonStructSymbol =
    class
        inherit PythonClassSymbol
    end

The PythonStructSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonStructSymbol | Initializes a new instance of the PythonStructSymbol class
Top
Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonStructSymbol Constructor

PythonStructSymbol Constructor
Initializes a new instance of the PythonStructSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonStructSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonStructSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonStructSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonStructSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonStructSymbol Methods

PythonStructSymbol Methods

The PythonStructSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonStructSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonStructSymbol Properties

PythonStructSymbol Properties

The PythonStructSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonStructSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol Class

PythonSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
More...

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonSymbol : IPythonSymbol
Public Class PythonSymbol
    Implements IPythonSymbol
public ref class PythonSymbol : IPythonSymbol
type PythonSymbol =
    class
        interface IPythonSymbol
    end

The PythonSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonSymbol | Initializes a new instance of the PythonSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType |
Public method | GetDisplayName |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule |
Public property | ContainingSymbol |
Public property | Description |
Public property | IsStatic |
Public property | Location |
Public property | Name |
Public property | Scope |
Public property | SymbolKind |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonAliasSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonBlockSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonFieldSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonImportSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonLocalVariableSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonMethodSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonParameterSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol


PythonSymbol Constructor

PythonSymbol Constructor
Initializes a new instance of the PythonSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol Methods

PythonSymbol Methods

The PythonSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType |
Public method | GetDisplayName |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.GetDataType Method

PythonSymbolGetDataType Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetDataType()
Public Overridable Function GetDataType As String
public:
virtual String^ GetDataType()
abstract GetDataType : unit -> string
override GetDataType : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDataType
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.GetDisplayName Method

PythonSymbolGetDisplayName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetDisplayName()
Public Overridable Function GetDisplayName As String
public:
virtual String^ GetDisplayName()
abstract GetDisplayName : unit -> string
override GetDisplayName : unit -> string

Return Value

Type: String

Implements

IPythonSymbolGetDisplayName
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol Properties

PythonSymbol Properties

The PythonSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule |
Public property | ContainingSymbol |
Public property | Description |
Public property | IsStatic |
Public property | Location |
Public property | Name |
Public property | Scope |
Public property | SymbolKind |
Top
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.ContainingModule Property

PythonSymbolContainingModule Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonModuleSymbol ContainingModule { get; }
Public ReadOnly Property ContainingModule As IPythonModuleSymbol
    Get
public:
virtual property IPythonModuleSymbol^ ContainingModule {
    IPythonModuleSymbol^ get () sealed;
}
abstract ContainingModule : IPythonModuleSymbol with get
override ContainingModule : IPythonModuleSymbol with get

Property Value

Type: IPythonModuleSymbol

Implements

IPythonSymbolContainingModule
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.ContainingSymbol Property

PythonSymbolContainingSymbol Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPythonSymbol ContainingSymbol { get; }
Public ReadOnly Property ContainingSymbol As IPythonSymbol
    Get
public:
virtual property IPythonSymbol^ ContainingSymbol {
    IPythonSymbol^ get () sealed;
}
abstract ContainingSymbol : IPythonSymbol with get
override ContainingSymbol : IPythonSymbol with get

Property Value

Type: IPythonSymbol

Implements

IPythonSymbolContainingSymbol
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.Description Property

PythonSymbolDescription Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

IPythonSymbolDescription
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.IsStatic Property

PythonSymbolIsStatic Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
virtual property bool IsStatic {
    bool get () sealed;
}
abstract IsStatic : bool with get
override IsStatic : bool with get

Property Value

Type: Boolean

Implements

IPythonSymbolIsStatic
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.Location Property

PythonSymbolLocation Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point Location { get; set; }
Public Property Location As Point
    Get
    Set
public:
virtual property Point Location {
    Point get () sealed;
    void set (Point value) sealed;
}
abstract Location : Point with get, set
override Location : Point with get, set

Property Value

Type: Point

Implements

IPythonSymbolLocation
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.Name Property

PythonSymbolName Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IPythonSymbolName
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.Scope Property

PythonSymbolScope Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PythonScope Scope { get; set; }
Public Overridable Property Scope As PythonScope
    Get
    Set
public:
virtual property PythonScope Scope {
    PythonScope get ();
    void set (PythonScope value);
}
abstract Scope : PythonScope with get, set
override Scope : PythonScope with get, set

Property Value

Type: PythonScope

Implements

IPythonSymbolScope
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbol.SymbolKind Property

PythonSymbolSymbolKind Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonSymbolKind SymbolKind { get; set; }
Public Property SymbolKind As PythonSymbolKind
    Get
    Set
public:
virtual property PythonSymbolKind SymbolKind {
    PythonSymbolKind get () sealed;
    void set (PythonSymbolKind value) sealed;
}
abstract SymbolKind : PythonSymbolKind with get, set
override SymbolKind : PythonSymbolKind with get, set

Property Value

Type: PythonSymbolKind

Implements

IPythonSymbolSymbolKind
See Also

Reference

PythonSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonSymbolKind Enumeration

PythonSymbolKind Enumeration

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PythonSymbolKind
Public Enumeration PythonSymbolKind
public enum class PythonSymbolKind
type PythonSymbolKind
Members
Member name | Value | Description
None | 0 |
Module | 1 |
Include | 2 |
Class | 3 |
Struct | 4 |
LocalVar | 5 |
Method | 6 |
Parameter | 7 |
Field | 8 |
Block | 9 |
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTupleTypeSymbol Class

PythonTupleTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTupleTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonTupleTypeSymbol : PythonClassSymbol
Public Class PythonTupleTypeSymbol
    Inherits PythonClassSymbol
public ref class PythonTupleTypeSymbol : public PythonClassSymbol
type PythonTupleTypeSymbol =
    class
        inherit PythonClassSymbol
    end

The PythonTupleTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTupleTypeSymbol | Initializes a new instance of the PythonTupleTypeSymbol class
Top
Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTupleTypeSymbol Constructor

PythonTupleTypeSymbol Constructor
Initializes a new instance of the PythonTupleTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonTupleTypeSymbol(
    string name
)
Public Sub New (
    name As String
)
public:
PythonTupleTypeSymbol(
    String^ name
)
new :
        name : string -> PythonTupleTypeSymbol

Parameters

name
Type: SystemString
See Also

Reference

PythonTupleTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTupleTypeSymbol Methods

PythonTupleTypeSymbol Methods

The PythonTupleTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddField | (Inherited from PythonClassSymbol.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMember | (Inherited from PythonClassSymbol.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonTupleTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTupleTypeSymbol Properties

PythonTupleTypeSymbol Properties

The PythonTupleTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | BaseType | (Inherited from PythonClassSymbol.)
Public property | Constructor | (Inherited from PythonClassSymbol.)
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Members | (Inherited from PythonClassSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonTupleTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTypeChecker Class

PythonTypeChecker Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeChecker

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonTypeChecker
Public Class PythonTypeChecker
public ref class PythonTypeChecker
type PythonTypeChecker =  class end

The PythonTypeChecker type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTypeChecker | Initializes a new instance of the PythonTypeChecker class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsTypeCompatible |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTypeChecker Constructor

PythonTypeChecker Constructor
Initializes a new instance of the PythonTypeChecker class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonTypeChecker()
Public Sub New
public:
PythonTypeChecker()
new : unit -> PythonTypeChecker
See Also

Reference

PythonTypeChecker Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTypeChecker Methods

PythonTypeChecker Methods

The PythonTypeChecker type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsTypeCompatible |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PythonTypeChecker Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTypeChecker.IsTypeCompatible Method

PythonTypeCheckerIsTypeCompatible Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsTypeCompatible(
    IPythonTypeSymbol type1,
    IPythonTypeSymbol type2
)
Public Shared Function IsTypeCompatible (
    type1 As IPythonTypeSymbol,
    type2 As IPythonTypeSymbol
) As Boolean
public:
static bool IsTypeCompatible(
    IPythonTypeSymbol^ type1,
    IPythonTypeSymbol^ type2
)
static member IsTypeCompatible :
        type1 : IPythonTypeSymbol *
        type2 : IPythonTypeSymbol -> bool

Parameters

type1
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonTypeSymbol
type2
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonTypeSymbol

Return Value

Type: Boolean
See Also

Reference

PythonTypeChecker Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTypeSymbol Class

PythonTypeSymbol Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelPythonSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelIronPythonTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonClassSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonObjectTypeSymbol
Alternet.Syntax.Parsers.Python.SemanticModelPythonPrimitiveTypeSymbol

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PythonTypeSymbol : PythonSymbol,
    IPythonTypeSymbol, IPythonSymbol
Public Class PythonTypeSymbol
    Inherits PythonSymbol
    Implements IPythonTypeSymbol, IPythonSymbol
public ref class PythonTypeSymbol : public PythonSymbol,
    IPythonTypeSymbol, IPythonSymbol
type PythonTypeSymbol =
    class
        inherit PythonSymbol
        interface IPythonTypeSymbol
        interface IPythonSymbol
    end

The PythonTypeSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTypeSymbol | Initializes a new instance of the PythonTypeSymbol class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTypeSymbol Constructor

PythonTypeSymbol Constructor
Initializes a new instance of the PythonTypeSymbol class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public PythonTypeSymbol(
    string name,
    IPythonSymbol containingSymbol
)
Public Sub New (
    name As String,
    containingSymbol As IPythonSymbol
)
public:
PythonTypeSymbol(
    String^ name,
    IPythonSymbol^ containingSymbol
)
new :
        name : string *
        containingSymbol : IPythonSymbol -> PythonTypeSymbol

Parameters

name
Type: SystemString
containingSymbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol
See Also

Reference

PythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTypeSymbol Methods

PythonTypeSymbol Methods

The PythonTypeSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDataType | (Inherited from PythonSymbol.)
Public method | GetDisplayName | (Inherited from PythonSymbol.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSymbolLocation | (Defined by SyntaxNodeExtensions.)
Public Extension Method | GetDataType | (Defined by PythonSymbolExtensions.)
Public Extension Method | GetDisplayName | (Defined by PythonSymbolExtensions.)
Top
See Also

Reference

PythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


PythonTypeSymbol Properties

PythonTypeSymbol Properties

The PythonTypeSymbol type exposes the following members.

Properties
 | Name | Description
Public property | ContainingModule | (Inherited from PythonSymbol.)
Public property | ContainingSymbol | (Inherited from PythonSymbol.)
Public property | Description | (Inherited from PythonSymbol.)
Public property | IsStatic | (Inherited from PythonSymbol.)
Public property | Location | (Inherited from PythonSymbol.)
Public property | Name | (Inherited from PythonSymbol.)
Public property | Scope | (Inherited from PythonSymbol.)
Public property | SymbolKind | (Inherited from PythonSymbol.)
Top
See Also

Reference

PythonTypeSymbol Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SymbolReference Class

SymbolReference Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelSymbolReference

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SymbolReference
Public Class SymbolReference
public ref class SymbolReference
type SymbolReference =  class end

The SymbolReference type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolReference | Initializes a new instance of the SymbolReference class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNameSpan |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Location |
Public property | Node |
Public property | Span |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SymbolReference Constructor

SymbolReference Constructor
Initializes a new instance of the SymbolReference class

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolReference()
Public Sub New
public:
SymbolReference()
new : unit -> SymbolReference
See Also

Reference

SymbolReference Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SymbolReference Methods

SymbolReference Methods

The SymbolReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNameSpan |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SymbolReference Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SymbolReference.GetNameSpan Method

SymbolReferenceGetNameSpan Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRange GetNameSpan()
Public Function GetNameSpan As IRange
public:
IRange^ GetNameSpan()
member GetNameSpan : unit -> IRange

Return Value

Type: IRange
See Also

Reference

SymbolReference Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SymbolReference Properties

SymbolReference Properties

The SymbolReference type exposes the following members.

Properties
 | Name | Description
Public property | Location |
Public property | Node |
Public property | Span |
Top
See Also

Reference

SymbolReference Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SymbolReference.Location Property

SymbolReferenceLocation Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolLocation Location { get; set; }
Public Property Location As SymbolLocation
    Get
    Set
public:
property SymbolLocation^ Location {
    SymbolLocation^ get ();
    void set (SymbolLocation^ value);
}
member Location : SymbolLocation with get, set

Property Value

Type: SymbolLocation
See Also

Reference

SymbolReference Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SymbolReference.Node Property

SymbolReferenceNode Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISyntaxNode Node { get; set; }
Public Property Node As ISyntaxNode
    Get
    Set
public:
property ISyntaxNode^ Node {
    ISyntaxNode^ get ();
    void set (ISyntaxNode^ value);
}
member Node : ISyntaxNode with get, set

Property Value

Type: ISyntaxNode
See Also

Reference

SymbolReference Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SymbolReference.Span Property

SymbolReferenceSpan Property

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRange Span { get; set; }
Public Property Span As IRange
    Get
    Set
public:
property IRange^ Span {
    IRange^ get ();
    void set (IRange^ value);
}
member Span : IRange with get, set

Property Value

Type: IRange
See Also

Reference

SymbolReference Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions Class

SyntaxNodeExtensions Class
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Python.SemanticModelSyntaxNodeExtensions

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SyntaxNodeExtensions
<ExtensionAttribute>
Public NotInheritable Class SyntaxNodeExtensions
[ExtensionAttribute]
public ref class SyntaxNodeExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type SyntaxNodeExtensions =  class end

The SyntaxNodeExtensions type exposes the following members.

Methods
Name | Description
CreateSymbolLocation(IPythonSymbol) |
CreateSymbolLocation(ISyntaxNode, IPythonSymbol) |
GetAttrValue |
GetDescription |
GetFileName |
GetNamePosition |
GetNameRange |
IsValidReference |
Top
See Also

Reference

Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions Methods

SyntaxNodeExtensions Methods

The SyntaxNodeExtensions type exposes the following members.

Methods
Name | Description
CreateSymbolLocation(IPythonSymbol) |
CreateSymbolLocation(ISyntaxNode, IPythonSymbol) |
GetAttrValue |
GetDescription |
GetFileName |
GetNamePosition |
GetNameRange |
IsValidReference |
Top
See Also

Reference

SyntaxNodeExtensions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions.CreateSymbolLocation Method

SyntaxNodeExtensionsCreateSymbolLocation Method
Overload List
Name | Description
CreateSymbolLocation(IPythonSymbol) |
CreateSymbolLocation(ISyntaxNode, IPythonSymbol) |
Top
See Also

Reference

SyntaxNodeExtensions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions.CreateSymbolLocation Method (IPythonSymbol)

SyntaxNodeExtensionsCreateSymbolLocation Method (IPythonSymbol)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SymbolLocation CreateSymbolLocation(
    this IPythonSymbol symbol
)
<ExtensionAttribute>
Public Shared Function CreateSymbolLocation (
    symbol As IPythonSymbol
) As SymbolLocation
public:
[ExtensionAttribute]
static SymbolLocation^ CreateSymbolLocation(
    IPythonSymbol^ symbol
)
[<ExtensionAttribute>]
static member CreateSymbolLocation :
        symbol : IPythonSymbol -> SymbolLocation

Parameters

symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: SymbolLocation

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPythonSymbol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxNodeExtensions Class
CreateSymbolLocation Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions.CreateSymbolLocation Method (ISyntaxNode, IPythonSymbol)

SyntaxNodeExtensionsCreateSymbolLocation Method (ISyntaxNode, IPythonSymbol)

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SymbolLocation CreateSymbolLocation(
    this ISyntaxNode node,
    IPythonSymbol symbol
)
<ExtensionAttribute>
Public Shared Function CreateSymbolLocation (
    node As ISyntaxNode,
    symbol As IPythonSymbol
) As SymbolLocation
public:
[ExtensionAttribute]
static SymbolLocation^ CreateSymbolLocation(
    ISyntaxNode^ node,
    IPythonSymbol^ symbol
)
[<ExtensionAttribute>]
static member CreateSymbolLocation :
        node : ISyntaxNode *
        symbol : IPythonSymbol -> SymbolLocation

Parameters

node
Type: Alternet.SyntaxISyntaxNode
symbol
Type: Alternet.Syntax.Parsers.Python.SemanticModelIPythonSymbol

Return Value

Type: SymbolLocation

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxNodeExtensions Class
CreateSymbolLocation Overload
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions.GetAttrValue Method

SyntaxNodeExtensionsGetAttrValue Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetAttrValue(
    this ISyntaxNode node,
    string attribute
)
<ExtensionAttribute>
Public Shared Function GetAttrValue (
    node As ISyntaxNode,
    attribute As String
) As String
public:
[ExtensionAttribute]
static String^ GetAttrValue(
    ISyntaxNode^ node,
    String^ attribute
)
[<ExtensionAttribute>]
static member GetAttrValue :
        node : ISyntaxNode *
        attribute : string -> string

Parameters

node
Type: Alternet.SyntaxISyntaxNode
attribute
Type: SystemString

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxNodeExtensions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions.GetDescription Method

SyntaxNodeExtensionsGetDescription Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDescription(
    this ISyntaxNode node
)
<ExtensionAttribute>
Public Shared Function GetDescription (
    node As ISyntaxNode
) As String
public:
[ExtensionAttribute]
static String^ GetDescription(
    ISyntaxNode^ node
)
[<ExtensionAttribute>]
static member GetDescription :
        node : ISyntaxNode -> string

Parameters

node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxNodeExtensions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions.GetFileName Method

SyntaxNodeExtensionsGetFileName Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFileName(
    this ISyntaxNode node
)
<ExtensionAttribute>
Public Shared Function GetFileName (
    node As ISyntaxNode
) As String
public:
[ExtensionAttribute]
static String^ GetFileName(
    ISyntaxNode^ node
)
[<ExtensionAttribute>]
static member GetFileName :
        node : ISyntaxNode -> string

Parameters

node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxNodeExtensions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions.GetNamePosition Method

SyntaxNodeExtensionsGetNamePosition Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point GetNamePosition(
    this ISyntaxNode node
)
<ExtensionAttribute>
Public Shared Function GetNamePosition (
    node As ISyntaxNode
) As Point
public:
[ExtensionAttribute]
static Point GetNamePosition(
    ISyntaxNode^ node
)
[<ExtensionAttribute>]
static member GetNamePosition :
        node : ISyntaxNode -> Point

Parameters

node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: Point

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxNodeExtensions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions.GetNameRange Method

SyntaxNodeExtensionsGetNameRange Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IRange GetNameRange(
    this ISyntaxNode node
)
<ExtensionAttribute>
Public Shared Function GetNameRange (
    node As ISyntaxNode
) As IRange
public:
[ExtensionAttribute]
static IRange^ GetNameRange(
    ISyntaxNode^ node
)
[<ExtensionAttribute>]
static member GetNameRange :
        node : ISyntaxNode -> IRange

Parameters

node
Type: Alternet.SyntaxISyntaxNode

Return Value

Type: IRange

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxNodeExtensions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


SyntaxNodeExtensions.IsValidReference Method

SyntaxNodeExtensionsIsValidReference Method

Namespace: Alternet.Syntax.Parsers.Python.SemanticModel
Assembly: Alternet.Syntax.Parsers.Advanced.Python.v7 (in Alternet.Syntax.Parsers.Advanced.Python.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidReference(
    this ISyntaxNode node,
    Point position
)
<ExtensionAttribute>
Public Shared Function IsValidReference (
    node As ISyntaxNode,
    position As Point
) As Boolean
public:
[ExtensionAttribute]
static bool IsValidReference(
    ISyntaxNode^ node,
    Point position
)
[<ExtensionAttribute>]
static member IsValidReference :
        node : ISyntaxNode *
        position : Point -> bool

Parameters

node
Type: Alternet.SyntaxISyntaxNode
position
Type: System.DrawingPoint

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxNodeExtensions Class
Alternet.Syntax.Parsers.Python.SemanticModel Namespace


Alternet.Syntax.Parsers.Roslyn Namespace

Alternet.Syntax.Parsers.Roslyn Namespace
Classes
 | Class | Description
Public class | CsParser | Represents class that and perform syntax and lexical analysis of specified C# code text.
Public class | ParserConsts | Contains default constants related to lexical and syntax analyzers.
Public class | RoslynParser | Represents properties and methods to perform syntax analysis of the text intended to use for Roslyn supported languages.
Public class | VbParser | Represents class that and perform syntax and lexical analysis of specified Visual Basic.NET code text.
Interfaces
 | Interface | Description
Public interface | IRoslynRepository |
Public interface | IRoslynSolution | Represents properties and methods to service source code documents intended to use for Roslyn supported languages.


CsParser Class

CsParser Class
Represents class that and perform syntax and lexical analysis of specified C# code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.RoslynRoslynParser
Alternet.Syntax.Parsers.RoslynCsParser
Alternet.Editor.RoslynCodeEditExtensionsCsScriptParser

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CsParser : RoslynParser
Public Class CsParser
    Inherits RoslynParser
public ref class CsParser : public RoslynParser
type CsParser =
    class
        inherit RoslynParser
    end

The CsParser type exposes the following members.

Constructors
 | Name | Description
Public method | CsParser | Initializes a new instance of the CsParser class with default settings.
Public method | CsParser(IRoslynSolution) | Initializes a new instance of the CsParser class with specified IRoslynSolution.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides RoslynParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from RoslynParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from RoslynParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing. (Inherited from RoslynParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from RoslynParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides RoslynParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from RoslynParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from RoslynParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from RoslynParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from RoslynParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Inherited from RoslynParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from RoslynParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from RoslynParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from RoslynParser.)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from RoslynParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Inherited from RoslynParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from RoslynParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from RoslynParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from RoslynParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from RoslynParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from RoslynParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from RoslynParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from RoslynParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from RoslynParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from RoslynParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from RoslynParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName | (Inherited from RoslynParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from RoslynParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer | (Inherited from RoslynParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from RoslynParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from RoslynParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn Namespace


CsParser Constructor

CsParser Constructor
Overload List
 | Name | Description
Public method | CsParser | Initializes a new instance of the CsParser class with default settings.
Public method | CsParser(IRoslynSolution) | Initializes a new instance of the CsParser class with specified IRoslynSolution.
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser Constructor

CsParser Constructor
Initializes a new instance of the CsParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsParser()
Public Sub New
public:
CsParser()
new : unit -> CsParser
See Also

Reference

CsParser Class
CsParser Overload
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser Constructor (IRoslynSolution)

CsParser Constructor (IRoslynSolution)
Initializes a new instance of the CsParser class with specified IRoslynSolution.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsParser(
    IRoslynSolution roslynSolution
)
Public Sub New (
    roslynSolution As IRoslynSolution
)
public:
CsParser(
    IRoslynSolution^ roslynSolution
)
new :
        roslynSolution : IRoslynSolution -> CsParser

Parameters

roslynSolution
Type: Alternet.Syntax.Parsers.RoslynIRoslynSolution
Specifies IRoslynSolution to this new instance.
See Also

Reference

CsParser Class
CsParser Overload
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser Methods

CsParser Methods

The CsParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides RoslynParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from RoslynParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from RoslynParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing. (Inherited from RoslynParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from RoslynParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides RoslynParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from RoslynParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from RoslynParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from RoslynParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from RoslynParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Inherited from RoslynParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from RoslynParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from RoslynParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from RoslynParser.)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from RoslynParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Inherited from RoslynParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from RoslynParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from RoslynParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from RoslynParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from RoslynParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from RoslynParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from RoslynParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from RoslynParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from RoslynParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from RoslynParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.CreateRepository Method

CsParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.GetCompletionType Method

CsParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides RoslynParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.GetCompletionType Method (Char)

CsParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

CsParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.GetSingleLineComment Method

CsParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.GetSingleLineComment Method

CsParserGetSingleLineComment Method
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

CsParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.ResetAutoIndentChars Method

CsParserResetAutoIndentChars Method
Resets AutoIndentChars to the default value.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.ResetCodeCompletionChars Method

CsParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.ResetSmartFormatChars Method

CsParserResetSmartFormatChars Method
Resets the SmartFormatChars to the default value.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetSmartFormatChars()
Public Overrides Sub ResetSmartFormatChars
public:
virtual void ResetSmartFormatChars() override
abstract ResetSmartFormatChars : unit -> unit
override ResetSmartFormatChars : unit -> unit

Implements

ISyntaxParserResetSmartFormatChars
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.ShouldSerializeAutoIndentChars Method

CsParserShouldSerializeAutoIndentChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeAutoIndentChars()
Public Overrides Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars() override
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.ShouldSerializeCodeCompletionChars Method

CsParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser.ShouldSerializeSmartFormatChars Method

CsParserShouldSerializeSmartFormatChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeSmartFormatChars()
Public Overrides Function ShouldSerializeSmartFormatChars As Boolean
public:
virtual bool ShouldSerializeSmartFormatChars() override
abstract ShouldSerializeSmartFormatChars : unit -> bool
override ShouldSerializeSmartFormatChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser Properties

CsParser Properties

The CsParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from RoslynParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName | (Inherited from RoslynParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from RoslynParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer | (Inherited from RoslynParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from RoslynParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from RoslynParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


CsParser Events

CsParser Events

The CsParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

CsParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository Interface

IRoslynRepository Interface

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRoslynRepository : ICodeCompletionRepository,
    IDisposable, IUpdate
Public Interface IRoslynRepository
    Inherits ICodeCompletionRepository, IDisposable, IUpdate
public interface class IRoslynRepository : ICodeCompletionRepository,
    IDisposable, IUpdate
type IRoslynRepository =
    interface
        interface ICodeCompletionRepository
        interface IDisposable
        interface IUpdate
    end

The IRoslynRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddDocument(String, SourceText) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | AddDocument(String, String) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | AddFileReference | When implemented by a class, adds metadata reference to the project
Public method | AddImageReference | When implemented by a class, adds metadata reference to the project
Public method | AddReference | When implemented by a class, adds metadata reference to the project
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | CloseDocument | When implemented by a class, closes document which was opened in roslyn workspace.
Public method | CodeCompletionAsync | When implemented by a class, performs code completion for the specified text representing language element.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration(String, ISyntaxNode, Point) | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) | When implemented by a class, finds the declaration node at given position.
Public method | FindImplementations | When implemented by a class, finds the symbols that implement an interface or interface member.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | When implemented by a class, locates all references to the symbol in the text.
Public method | GetBreakpointStatementAtPosition | When implemented by a class, gets breakpoint statement range at pecified position.
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetDiagnostics | When implemented by a class, get all the errors within the syntax tree associated with this object.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetModel | When implemented by a class, gets the current semantic model and syntax tree for this document.
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetPosFromPosition | When implemented by a class, converts given position into absolute text coordinate.
Public method | GetPositionFromPos | When implemented by a class, converts given pos into Point coordinate.
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetRangeAt(Point) | When implemented by a class, gets IRange that corresponds to the specified position.
Public method | GetRangeAt(Point, IListIRange) | When implemented by a class, gets IRange that contains given position.
Public method | GetSmartIndent | When implemented by a class, returns indentation string for specified line.
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | GetXmlComment | When implemented by a class, represents beginning of XML comment.
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.
Public method | IsContentDivider | When implemented by a class, gets boolean value indicating whether text content is divided at given node.
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | ProcessAutoComplete | When implemented by a class, checks whether end-of-block code needs inserting.
Public method | ProcessSnippetBody | When implemented by a class, checks whether snippet body code needs inserting.
Public method | RegisterAssemblies | When implemented by a class, registers assemblies in the project.
Public method | RegisterAssembly | When implemented by a class, registers assembly in the project.
Public method | RegisterCodeFiles | When implemented by a class, makes types declared in given source files accessible for code completion.
Public method | RegisterDefaultAssemblies | When implemented by a class, registers default assemblies in the project.
Public method | RegisterDefaultNamespaces | When implemented by a class, registers default namespaces in the project.
Public method | RegisterNamespaces | When implemented by a class, registers global namespaces in the project.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | RemoveDocument | Removes current document from document collection.
Public method | RemoveDocument(DocumentId) | When implemented by a class, removes document from document collection.
Public method | RemoveDocument(String) | When implemented by a class, removes document from document collection.
Public method | ReplaceDocument(DocumentId, SourceText) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | ReplaceDocument(DocumentId, String) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | When implemented by a class, formats block of text according to the parser rules. Position of the textIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabList of changes.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | When implemented by a class, formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList of changes.
Public method | UnregisterAssemblies | When implemented by a class, unregisters assemblies from the project.
Public method | UnregisterAssembly | When implemented by a class, unregisters assembly from the project.
Public method | UnregisterCodeFiles | When implemented by a class, removes types declared in given source files from being accessible code completion.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | Document | When implemented by a class, represents a Microsoft.CodeAnalysis.Document that contains code text.
Public property | DocumentId | When implemented by a class, represents a Microsoft.CodeAnalysis.DocumentId that contains code text.
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | Model | When implemented by a class, gets SemanticModel associated with this Repository.
Public property | ProjectId | When implemented by a class, represents a Microsoft.CodeAnalysis.ProjectId that contains document.
Public property | ProjectName | When implemented by a class, gets or sets Project name containing document
Public property | Solution | When implemented by a class, gets RoslynSolution associated with this Repository.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | Text | When implemented by a class, gets SourceText associated with this Repository.
Public property | Tree | When implemented by a class, gets SyntaxTree associated with this Repository.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options.
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository Methods

IRoslynRepository Methods

The IRoslynRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddDocument(String, SourceText) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | AddDocument(String, String) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | AddFileReference | When implemented by a class, adds metadata reference to the project
Public method | AddImageReference | When implemented by a class, adds metadata reference to the project
Public method | AddReference | When implemented by a class, adds metadata reference to the project
Public method | BeginUpdate | When implemented by a class, prevents object state updating until calling EndUpdate method. (Inherited from IUpdate.)
Public method | CloseDocument | When implemented by a class, closes document which was opened in roslyn workspace.
Public method | CodeCompletionAsync | When implemented by a class, performs code completion for the specified text representing language element.
Public method | DisableUpdate | When implemented by a class, prevents object state updating until calling EnableUpdate method. (Inherited from IUpdate.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from IUpdate.)
Public method | EndUpdate | When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from IUpdate.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration(String, ISyntaxNode, Point) | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) | When implemented by a class, finds the declaration node at given position.
Public method | FindImplementations | When implemented by a class, finds the symbols that implement an interface or interface member.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | When implemented by a class, locates all references to the symbol in the text.
Public method | GetBreakpointStatementAtPosition | When implemented by a class, gets breakpoint statement range at pecified position.
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetDiagnostics | When implemented by a class, get all the errors within the syntax tree associated with this object.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetModel | When implemented by a class, gets the current semantic model and syntax tree for this document.
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetPosFromPosition | When implemented by a class, converts given position into absolute text coordinate.
Public method | GetPositionFromPos | When implemented by a class, converts given pos into Point coordinate.
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetRangeAt(Point) | When implemented by a class, gets IRange that corresponds to the specified position.
Public method | GetRangeAt(Point, IListIRange) | When implemented by a class, gets IRange that contains given position.
Public method | GetSmartIndent | When implemented by a class, returns indentation string for specified line.
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | GetXmlComment | When implemented by a class, represents beginning of XML comment.
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.
Public method | IsContentDivider | When implemented by a class, gets boolean value indicating whether text content is divided at given node.
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | ProcessAutoComplete | When implemented by a class, checks whether end-of-block code needs inserting.
Public method | ProcessSnippetBody | When implemented by a class, checks whether snippet body code needs inserting.
Public method | RegisterAssemblies | When implemented by a class, registers assemblies in the project.
Public method | RegisterAssembly | When implemented by a class, registers assembly in the project.
Public method | RegisterCodeFiles | When implemented by a class, makes types declared in given source files accessible for code completion.
Public method | RegisterDefaultAssemblies | When implemented by a class, registers default assemblies in the project.
Public method | RegisterDefaultNamespaces | When implemented by a class, registers default namespaces in the project.
Public method | RegisterNamespaces | When implemented by a class, registers global namespaces in the project.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | RemoveDocument | Removes current document from document collection.
Public method | RemoveDocument(DocumentId) | When implemented by a class, removes document from document collection.
Public method | RemoveDocument(String) | When implemented by a class, removes document from document collection.
Public method | ReplaceDocument(DocumentId, SourceText) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | ReplaceDocument(DocumentId, String) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | When implemented by a class, formats block of text according to the parser rules. Position of the textIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabList of changes.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | When implemented by a class, formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList of changes.
Public method | UnregisterAssemblies | When implemented by a class, unregisters assemblies from the project.
Public method | UnregisterAssembly | When implemented by a class, unregisters assembly from the project.
Public method | UnregisterCodeFiles | When implemented by a class, removes types declared in given source files from being accessible code completion.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from IUpdate.)
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.AddDocument Method

IRoslynRepositoryAddDocument Method
Overload List
 | Name | Description
Public method | AddDocument(String, SourceText) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | AddDocument(String, String) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.AddDocument Method (String, SourceText)

IRoslynRepositoryAddDocument Method (String, SourceText)
When implemented by a class, adds a new document or replaces existing document with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DocumentId AddDocument(
    string file,
    SourceText text
)
Function AddDocument (
    file As String,
    text As SourceText
) As DocumentId
DocumentId^ AddDocument(
    String^ file,
    SourceText^ text
)
abstract AddDocument :
        file : string *
        text : SourceText -> DocumentId

Parameters

file
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.
text
Type: SourceText
New Microsoft.CodeAnalysis.Document text.

Return Value

Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to be added.
See Also

Reference

IRoslynRepository Interface
AddDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.AddDocument Method (String, String)

IRoslynRepositoryAddDocument Method (String, String)
When implemented by a class, adds a new document or replaces existing document with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DocumentId AddDocument(
    string file,
    string text
)
Function AddDocument (
    file As String,
    text As String
) As DocumentId
DocumentId^ AddDocument(
    String^ file,
    String^ text
)
abstract AddDocument :
        file : string *
        text : string -> DocumentId

Parameters

file
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.
text
Type: SystemString
New Microsoft.CodeAnalysis.Document text.

Return Value

Type: DocumentId
See Also

Reference

IRoslynRepository Interface
AddDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.AddFileReference Method

IRoslynRepositoryAddFileReference Method
When implemented by a class, adds metadata reference to the project

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddFileReference(
    string assemblyLocation
)
Sub AddFileReference (
    assemblyLocation As String
)
void AddFileReference(
    String^ assemblyLocation
)
abstract AddFileReference :
        assemblyLocation : string -> unit

Parameters

assemblyLocation
Type: SystemString
Location of assembly to add.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.AddImageReference Method

IRoslynRepositoryAddImageReference Method
When implemented by a class, adds metadata reference to the project

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddImageReference(
    byte[] assemblyImage
)
Sub AddImageReference (
    assemblyImage As Byte()
)
void AddImageReference(
    array<unsigned char>^ assemblyImage
)
abstract AddImageReference :
        assemblyImage : byte[] -> unit

Parameters

assemblyImage
Type: SystemByte
Assembly image to add.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.AddReference Method

IRoslynRepositoryAddReference Method
When implemented by a class, adds metadata reference to the project

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddReference(
    MetadataReference reference
)
Sub AddReference (
    reference As MetadataReference
)
void AddReference(
    MetadataReference^ reference
)
abstract AddReference :
        reference : MetadataReference -> unit

Parameters

reference
Type: MetadataReference
Reference to add.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.CloseDocument Method

IRoslynRepositoryCloseDocument Method
When implemented by a class, closes document which was opened in roslyn workspace.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CloseDocument()
Function CloseDocument As Boolean
bool CloseDocument()
abstract CloseDocument : unit -> bool

Return Value

Type: Boolean
True if current document was removed; otherwise false
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.CodeCompletionAsync Method

IRoslynRepositoryCodeCompletionAsync Method
When implemented by a class, performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task CodeCompletionAsync(
    Point position,
    CodeCompletionArgs e,
    CancellationToken ct
)
Function CodeCompletionAsync (
    position As Point,
    e As CodeCompletionArgs,
    ct As CancellationToken
) As Task
Task^ CodeCompletionAsync(
    Point position,
    CodeCompletionArgs^ e,
    CancellationToken ct
)
abstract CodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs *
        ct : CancellationToken -> Task

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.
ct
Type: System.ThreadingCancellationToken

Return Value

Type: Task
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.FindDeclaration Method

IRoslynRepositoryFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(String, ISyntaxNode, Point) | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) | When implemented by a class, finds the declaration node at given position.
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.FindDeclaration Method (SemanticModel, Point, Boolean)

IRoslynRepositoryFindDeclaration Method (SemanticModel, Point, Boolean)
When implemented by a class, finds the declaration node at given position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ISymbol FindDeclaration(
    SemanticModel model,
    Point position,
    bool includeCandidates = true
)
Function FindDeclaration (
    model As SemanticModel,
    position As Point,
    Optional includeCandidates As Boolean = true
) As ISymbol
ISymbol^ FindDeclaration(
    SemanticModel^ model,
    Point position,
    bool includeCandidates = true
)
abstract FindDeclaration :
        model : SemanticModel *
        position : Point *
        ?includeCandidates : bool
(* Defaults:
        let _includeCandidates = defaultArg includeCandidates true
*)
-> ISymbol

Parameters

model
Type: SemanticModel
position
Type: System.DrawingPoint
Specifies position to find node.
includeCandidates (Optional)
Type: SystemBoolean
Specifies whether candidate symbols can be considered.

Return Value

Type: ISymbol
Microsoft.CodeAnalysis.ISymbol node representing declaration.
See Also

Reference

IRoslynRepository Interface
FindDeclaration Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.FindImplementations Method

IRoslynRepositoryFindImplementations Method
When implemented by a class, finds the symbols that implement an interface or interface member.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<IEnumerable<ISymbol>> FindImplementations(
    ISymbol symbol,
    CancellationToken cancellationToken
)
Function FindImplementations (
    symbol As ISymbol,
    cancellationToken As CancellationToken
) As Task(Of IEnumerable(Of ISymbol))
Task<IEnumerable<ISymbol^>^>^ FindImplementations(
    ISymbol^ symbol,
    CancellationToken cancellationToken
)
abstract FindImplementations :
        symbol : ISymbol *
        cancellationToken : CancellationToken -> Task<IEnumerable<ISymbol>>

Parameters

symbol
Type: ISymbol
Specifies Microsoft.CodeAnalysis.ISymbol to find implementations.
cancellationToken
Type: System.ThreadingCancellationToken
Cancellation token

Return Value

Type: TaskIEnumerableISymbol
Implementations to symbol.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.FindReferences Method

IRoslynRepositoryFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | When implemented by a class, locates all references to the symbol in the text.
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.FindReferences Method (ISymbol, CancellationToken, Boolean)

IRoslynRepositoryFindReferences Method (ISymbol, CancellationToken, Boolean)
When implemented by a class, locates all references to the symbol in the text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Task<IEnumerable<ReferencedSymbol>> FindReferences(
    ISymbol symbol,
    CancellationToken cancellationToken,
    bool allDocuments = false
)
Function FindReferences (
    symbol As ISymbol,
    cancellationToken As CancellationToken,
    Optional allDocuments As Boolean = false
) As Task(Of IEnumerable(Of ReferencedSymbol))
Task<IEnumerable<ReferencedSymbol^>^>^ FindReferences(
    ISymbol^ symbol,
    CancellationToken cancellationToken,
    bool allDocuments = false
)
abstract FindReferences :
        symbol : ISymbol *
        cancellationToken : CancellationToken *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> Task<IEnumerable<ReferencedSymbol>>

Parameters

symbol
Type: ISymbol
Specifies Microsoft.CodeAnalysis.ISymbol to find references.
cancellationToken
Type: System.ThreadingCancellationToken
Cancellation token
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: TaskIEnumerableReferencedSymbol
References to node.
See Also

Reference

IRoslynRepository Interface
FindReferences Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetBreakpointStatementAtPosition Method

IRoslynRepositoryGetBreakpointStatementAtPosition Method
When implemented by a class, gets breakpoint statement range at pecified position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange GetBreakpointStatementAtPosition(
    Point position
)
Function GetBreakpointStatementAtPosition (
    position As Point
) As IRange
IRange^ GetBreakpointStatementAtPosition(
    Point position
)
abstract GetBreakpointStatementAtPosition :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
The position to check.

Return Value

Type: IRange
IRange of the found breakpoint.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetDiagnostics Method

IRoslynRepositoryGetDiagnostics Method
When implemented by a class, get all the errors within the syntax tree associated with this object.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<Diagnostic> GetDiagnostics()
Function GetDiagnostics As IEnumerable(Of Diagnostic)
IEnumerable<Diagnostic^>^ GetDiagnostics()
abstract GetDiagnostics : unit -> IEnumerable<Diagnostic>

Return Value

Type: IEnumerableDiagnostic
List of Microsoft.CodeAnalysis.Diagnostic errors.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetModel Method

IRoslynRepositoryGetModel Method
When implemented by a class, gets the current semantic model and syntax tree for this document.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool GetModel(
    out SemanticModel model,
    out SyntaxTree tree
)
Function GetModel (
    <OutAttribute> ByRef model As SemanticModel,
    <OutAttribute> ByRef tree As SyntaxTree
) As Boolean
bool GetModel(
    [OutAttribute] SemanticModel^% model,
    [OutAttribute] SyntaxTree^% tree
)
abstract GetModel :
        model : SemanticModel byref *
        tree : SyntaxTree byref -> bool

Parameters

model
Type: SemanticModel
Output parameter receives Microsoft.CodeAnalysis.SemanticModel object.
tree
Type: SyntaxTree
Output parameter receives Microsoft.CodeAnalysis.SyntaxTree object.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetPosFromPosition Method

IRoslynRepositoryGetPosFromPosition Method
When implemented by a class, converts given position into absolute text coordinate.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPosFromPosition(
    SourceText text,
    Point position
)
Function GetPosFromPosition (
    text As SourceText,
    position As Point
) As Integer
int GetPosFromPosition(
    SourceText^ text,
    Point position
)
abstract GetPosFromPosition :
        text : SourceText *
        position : Point -> int

Parameters

text
Type: SourceText
SourceText to process.
position
Type: System.DrawingPoint
Point to convert.

Return Value

Type: Int32
Absolute position.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetPositionFromPos Method

IRoslynRepositoryGetPositionFromPos Method
When implemented by a class, converts given pos into Point coordinate.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point GetPositionFromPos(
    SourceText text,
    int pos
)
Function GetPositionFromPos (
    text As SourceText,
    pos As Integer
) As Point
Point GetPositionFromPos(
    SourceText^ text,
    int pos
)
abstract GetPositionFromPos :
        text : SourceText *
        pos : int -> Point

Parameters

text
Type: SourceText
SourceText to process.
pos
Type: SystemInt32
Absolute position to convert.

Return Value

Type: Point
Point coordinate.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetRangeAt Method

IRoslynRepositoryGetRangeAt Method
Overload List
 | Name | Description
Public method | GetRangeAt(Point) | When implemented by a class, gets IRange that corresponds to the specified position.
Public method | GetRangeAt(Point, IListIRange) | When implemented by a class, gets IRange that contains given position.
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetRangeAt Method (Point)

IRoslynRepositoryGetRangeAt Method (Point)
When implemented by a class, gets IRange that corresponds to the specified position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange GetRangeAt(
    Point position
)
Function GetRangeAt (
    position As Point
) As IRange
IRange^ GetRangeAt(
    Point position
)
abstract GetRangeAt :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.

Return Value

Type: IRange
IRange at specified position.
See Also

Reference

IRoslynRepository Interface
GetRangeAt Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetRangeAt Method (Point, IList(IRange))

IRoslynRepositoryGetRangeAt Method (Point, IListIRange)
When implemented by a class, gets IRange that contains given position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRange GetRangeAt(
    Point position,
    IList<IRange> ranges
)
Function GetRangeAt (
    position As Point,
    ranges As IList(Of IRange)
) As IRange
IRange^ GetRangeAt(
    Point position,
    IList<IRange^>^ ranges
)
abstract GetRangeAt :
        position : Point *
        ranges : IList<IRange> -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.
ranges
Type: System.Collections.GenericIListIRange
List of begin/end blocks at the given position.

Return Value

Type: IRange
IRange at specified position.
See Also

Reference

IRoslynRepository Interface
GetRangeAt Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetSmartIndent Method

IRoslynRepositoryGetSmartIndent Method
When implemented by a class, returns indentation string for specified line.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetSmartIndent(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
Function GetSmartIndent (
    index As Integer,
    autoIndent As Boolean,
    useSpaces As Boolean,
    spacesInTab As Integer
) As String
String^ GetSmartIndent(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
abstract GetSmartIndent :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.

Return Value

Type: String
Indentation text at line specified by index.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.GetXmlComment Method

IRoslynRepositoryGetXmlComment Method
When implemented by a class, represents beginning of XML comment.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetXmlComment()
Function GetXmlComment As String
String^ GetXmlComment()
abstract GetXmlComment : unit -> string

Return Value

Type: String
String determines XML comment start.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.IsCollapsible Method

IRoslynRepositoryIsCollapsible Method
Overload List
 | Name | Description
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.IsCollapsible Method (IEnumerable(SyntaxTrivia), String, TextSpan)

IRoslynRepositoryIsCollapsible Method (IEnumerableSyntaxTrivia, String, TextSpan)
When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCollapsible(
    IEnumerable<SyntaxTrivia> triviaList,
    out string outlineText,
    out TextSpan span
)
Function IsCollapsible (
    triviaList As IEnumerable(Of SyntaxTrivia),
    <OutAttribute> ByRef outlineText As String,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
bool IsCollapsible(
    IEnumerable<SyntaxTrivia>^ triviaList,
    [OutAttribute] String^% outlineText,
    [OutAttribute] TextSpan% span
)
abstract IsCollapsible :
        triviaList : IEnumerable<SyntaxTrivia> *
        outlineText : string byref *
        span : TextSpan byref -> bool

Parameters

triviaList
Type: System.Collections.GenericIEnumerableSyntaxTrivia
Microsoft.CodeAnalysis.SyntaxTriviaList to check.
outlineText
Type: SystemString
Output parameter receives text substituting collapsed outline section.
span
Type: TextSpan
Output parameter receives outline range.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined; otherwise false.
See Also

Reference

IRoslynRepository Interface
IsCollapsible Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.IsCollapsible Method (SyntaxNode, String, TextSpan, Boolean)

IRoslynRepositoryIsCollapsible Method (SyntaxNode, String, TextSpan, Boolean)
When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCollapsible(
    SyntaxNode node,
    out string outlineText,
    out TextSpan span,
    bool checkStatements
)
Function IsCollapsible (
    node As SyntaxNode,
    <OutAttribute> ByRef outlineText As String,
    <OutAttribute> ByRef span As TextSpan,
    checkStatements As Boolean
) As Boolean
bool IsCollapsible(
    SyntaxNode^ node,
    [OutAttribute] String^% outlineText,
    [OutAttribute] TextSpan% span,
    bool checkStatements
)
abstract IsCollapsible :
        node : SyntaxNode *
        outlineText : string byref *
        span : TextSpan byref *
        checkStatements : bool -> bool

Parameters

node
Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode to check.
outlineText
Type: SystemString
Output parameter receives text substituting collapsed outline section.
span
Type: TextSpan
Output parameter receives outline range.
checkStatements
Type: SystemBoolean
Indicates whether statement node also should be processed.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxNode can be outlined; otherwise false.
See Also

Reference

IRoslynRepository Interface
IsCollapsible Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.IsContentDivider Method

IRoslynRepositoryIsContentDivider Method
When implemented by a class, gets boolean value indicating whether text content is divided at given node.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsContentDivider(
    SyntaxNode node,
    out TextSpan span
)
Function IsContentDivider (
    node As SyntaxNode,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
bool IsContentDivider(
    SyntaxNode^ node,
    [OutAttribute] TextSpan% span
)
abstract IsContentDivider :
        node : SyntaxNode *
        span : TextSpan byref -> bool

Parameters

node
Type: SyntaxNode
node check.
span
Type: TextSpan
text span containing node

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.IsStructureGuideNode Method

IRoslynRepositoryIsStructureGuideNode Method
Overload List
 | Name | Description
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.IsStructureGuideNode Method (SyntaxNode, TextSpan)

IRoslynRepositoryIsStructureGuideNode Method (SyntaxNode, TextSpan)
When implemented by a class, indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsStructureGuideNode(
    SyntaxNode node,
    out TextSpan span
)
Function IsStructureGuideNode (
    node As SyntaxNode,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
bool IsStructureGuideNode(
    SyntaxNode^ node,
    [OutAttribute] TextSpan% span
)
abstract IsStructureGuideNode :
        node : SyntaxNode *
        span : TextSpan byref -> bool

Parameters

node
Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode to check.
span
Type: TextSpan
Output parameter receives guide range.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxNode is guide node; otherwise false.
See Also

Reference

IRoslynRepository Interface
IsStructureGuideNode Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.ProcessAutoComplete Method

IRoslynRepositoryProcessAutoComplete Method
When implemented by a class, checks whether end-of-block code needs inserting.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessAutoComplete(
    string text,
    Point position,
    out string code
)
Function ProcessAutoComplete (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
bool ProcessAutoComplete(
    String^ text,
    Point position,
    [OutAttribute] String^% code
)
abstract ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if autocompletion of end-of-block needed; otherwise false.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.ProcessSnippetBody Method

IRoslynRepositoryProcessSnippetBody Method
When implemented by a class, checks whether snippet body code needs inserting.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessSnippetBody(
    string text,
    Point position,
    out string code
)
Function ProcessSnippetBody (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
bool ProcessSnippetBody(
    String^ text,
    Point position,
    [OutAttribute] String^% code
)
abstract ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if snippet body code needed; otherwise false.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RegisterAssemblies Method

IRoslynRepositoryRegisterAssemblies Method
When implemented by a class, registers assemblies in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterAssemblies(
    string[] assemblies
)
Sub RegisterAssemblies (
    assemblies As String()
)
void RegisterAssemblies(
    array<String^>^ assemblies
)
abstract RegisterAssemblies :
        assemblies : string[] -> unit

Parameters

assemblies
Type: SystemString
Assembly names.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RegisterAssembly Method

IRoslynRepositoryRegisterAssembly Method
When implemented by a class, registers assembly in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RegisterAssembly(
    string name
)
Function RegisterAssembly (
    name As String
) As Boolean
bool RegisterAssembly(
    String^ name
)
abstract RegisterAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Assembly name.

Return Value

Type: Boolean
True if assembly has been registered, otherwise false.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RegisterCodeFiles Method

IRoslynRepositoryRegisterCodeFiles Method
When implemented by a class, makes types declared in given source files accessible for code completion.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterCodeFiles(
    string[] files
)
Sub RegisterCodeFiles (
    files As String()
)
void RegisterCodeFiles(
    array<String^>^ files
)
abstract RegisterCodeFiles :
        files : string[] -> unit

Parameters

files
Type: SystemString
files containing source code.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RegisterDefaultAssemblies Method

IRoslynRepositoryRegisterDefaultAssemblies Method
When implemented by a class, registers default assemblies in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms,
    bool keepExisting = false
)
Sub RegisterDefaultAssemblies (
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms,
    Optional keepExisting As Boolean = false
)
void RegisterDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms,
    bool keepExisting = false
)
abstract RegisterDefaultAssemblies :
        ?technology : TechnologyEnvironment *
        ?keepExisting : bool
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
*)
-> unit

Parameters

technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
Specifies technology platform
keepExisting (Optional)
Type: SystemBoolean
Specifies whether existing assemblies should be persisted.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RegisterDefaultNamespaces Method

IRoslynRepositoryRegisterDefaultNamespaces Method
When implemented by a class, registers default namespaces in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterDefaultNamespaces(
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms
)
Sub RegisterDefaultNamespaces (
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms
)
void RegisterDefaultNamespaces(
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms
)
abstract RegisterDefaultNamespaces :
        ?technology : TechnologyEnvironment
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
*)
-> unit

Parameters

technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
Specifies technology platform
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RegisterNamespaces Method

IRoslynRepositoryRegisterNamespaces Method
When implemented by a class, registers global namespaces in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterNamespaces(
    string[] nameSpaces
)
Sub RegisterNamespaces (
    nameSpaces As String()
)
void RegisterNamespaces(
    array<String^>^ nameSpaces
)
abstract RegisterNamespaces :
        nameSpaces : string[] -> unit

Parameters

nameSpaces
Type: SystemString
Global namespaces.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RemoveDocument Method

IRoslynRepositoryRemoveDocument Method
Overload List
 | Name | Description
Public method | RemoveDocument | Removes current document from document collection.
Public method | RemoveDocument(DocumentId) | When implemented by a class, removes document from document collection.
Public method | RemoveDocument(String) | When implemented by a class, removes document from document collection.
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RemoveDocument Method

IRoslynRepositoryRemoveDocument Method
Removes current document from document collection.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RemoveDocument()
Function RemoveDocument As Boolean
bool RemoveDocument()
abstract RemoveDocument : unit -> bool

Return Value

Type: Boolean
True if current document was removed; otherwise false
See Also

Reference

IRoslynRepository Interface
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RemoveDocument Method (DocumentId)

IRoslynRepositoryRemoveDocument Method (DocumentId)
When implemented by a class, removes document from document collection.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RemoveDocument(
    DocumentId documentId
)
Function RemoveDocument (
    documentId As DocumentId
) As Boolean
bool RemoveDocument(
    DocumentId^ documentId
)
abstract RemoveDocument :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId
Id of theMicrosoft.CodeAnalysis.Document.

Return Value

Type: Boolean
True if document was removed; otherwise false
See Also

Reference

IRoslynRepository Interface
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.RemoveDocument Method (String)

IRoslynRepositoryRemoveDocument Method (String)
When implemented by a class, removes document from document collection.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RemoveDocument(
    string file
)
Function RemoveDocument (
    file As String
) As Boolean
bool RemoveDocument(
    String^ file
)
abstract RemoveDocument :
        file : string -> bool

Parameters

file
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.

Return Value

Type: Boolean
True if document was removed; otherwise false
See Also

Reference

IRoslynRepository Interface
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.ReplaceDocument Method

IRoslynRepositoryReplaceDocument Method
Overload List
 | Name | Description
Public method | ReplaceDocument(DocumentId, SourceText) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Public method | ReplaceDocument(DocumentId, String) | When implemented by a class, adds a new document or replaces existing document with specified settings.
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.ReplaceDocument Method (DocumentId, SourceText)

IRoslynRepositoryReplaceDocument Method (DocumentId, SourceText)
When implemented by a class, adds a new document or replaces existing document with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReplaceDocument(
    DocumentId documentId,
    SourceText text
)
Function ReplaceDocument (
    documentId As DocumentId,
    text As SourceText
) As Boolean
bool ReplaceDocument(
    DocumentId^ documentId,
    SourceText^ text
)
abstract ReplaceDocument :
        documentId : DocumentId *
        text : SourceText -> bool

Parameters

documentId
Type: DocumentId
Id of the Microsoft.CodeAnalysis.Document.
text
Type: SourceText
New Microsoft.CodeAnalysis.Document text.

Return Value

Type: Boolean
True if document has been updated; otherwise false.
See Also

Reference

IRoslynRepository Interface
ReplaceDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.ReplaceDocument Method (DocumentId, String)

IRoslynRepositoryReplaceDocument Method (DocumentId, String)
When implemented by a class, adds a new document or replaces existing document with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReplaceDocument(
    DocumentId documentId,
    string text
)
Function ReplaceDocument (
    documentId As DocumentId,
    text As String
) As Boolean
bool ReplaceDocument(
    DocumentId^ documentId,
    String^ text
)
abstract ReplaceDocument :
        documentId : DocumentId *
        text : string -> bool

Parameters

documentId
Type: DocumentId
Id of the Microsoft.CodeAnalysis.Document.
text
Type: SystemString
New Microsoft.CodeAnalysis.Document text.

Return Value

Type: Boolean
True if document has been updated; otherwise false.
See Also

Reference

IRoslynRepository Interface
ReplaceDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.SmartFormat Method

IRoslynRepositorySmartFormat Method
Overload List
 | Name | Description
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | When implemented by a class, formats block of text according to the parser rules. Position of the textIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabList of changes.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | When implemented by a class, formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList of changes.
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.SmartFormat Method (Point, Boolean, Int32, ITextUndoList)

IRoslynRepositorySmartFormat Method (Point, Boolean, Int32, ITextUndoList)
When implemented by a class, formats block of text according to the parser rules. Position of the textIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabList of changes.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SmartFormat(
    ref Point pos,
    bool useSpaces,
    int spacesInTab,
    ITextUndoList operations
)
Function SmartFormat (
    ByRef pos As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    operations As ITextUndoList
) As Boolean
bool SmartFormat(
    Point% pos,
    bool useSpaces,
    int spacesInTab,
    ITextUndoList^ operations
)
abstract SmartFormat :
        pos : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        operations : ITextUndoList -> bool

Parameters

pos
Type: System.DrawingPoint
useSpaces
Type: SystemBoolean
spacesInTab
Type: SystemInt32
operations
Type: Alternet.SyntaxITextUndoList

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IRoslynRepository Interface
SmartFormat Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.SmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)

IRoslynRepositorySmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)
When implemented by a class, formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList of changes.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SmartFormat(
    ref Point start,
    ref Point end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList operations
)
Function SmartFormat (
    ByRef start As Point,
    ByRef end As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    extended As Boolean,
    operations As ITextUndoList
) As Boolean
bool SmartFormat(
    Point% start,
    Point% end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList^ operations
)
abstract SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool

Parameters

start
Type: System.DrawingPoint
end
Type: System.DrawingPoint
useSpaces
Type: SystemBoolean
spacesInTab
Type: SystemInt32
extended
Type: SystemBoolean
operations
Type: Alternet.SyntaxITextUndoList

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IRoslynRepository Interface
SmartFormat Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.UnregisterAssemblies Method

IRoslynRepositoryUnregisterAssemblies Method
When implemented by a class, unregisters assemblies from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnregisterAssemblies(
    string[] assemblies
)
Sub UnregisterAssemblies (
    assemblies As String()
)
void UnregisterAssemblies(
    array<String^>^ assemblies
)
abstract UnregisterAssemblies :
        assemblies : string[] -> unit

Parameters

assemblies
Type: SystemString
Assembly names.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.UnregisterAssembly Method

IRoslynRepositoryUnregisterAssembly Method
When implemented by a class, unregisters assembly from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterAssembly(
    string name
)
Function UnregisterAssembly (
    name As String
) As Boolean
bool UnregisterAssembly(
    String^ name
)
abstract UnregisterAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Assembly name.

Return Value

Type: Boolean
True if assembly has been unregistered, otherwise false.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.UnregisterCodeFiles Method

IRoslynRepositoryUnregisterCodeFiles Method
When implemented by a class, removes types declared in given source files from being accessible code completion.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnregisterCodeFiles(
    string[] files
)
Sub UnregisterCodeFiles (
    files As String()
)
void UnregisterCodeFiles(
    array<String^>^ files
)
abstract UnregisterCodeFiles :
        files : string[] -> unit

Parameters

files
Type: SystemString
files containing source code.
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository Properties

IRoslynRepository Properties

The IRoslynRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | Document | When implemented by a class, represents a Microsoft.CodeAnalysis.Document that contains code text.
Public property | DocumentId | When implemented by a class, represents a Microsoft.CodeAnalysis.DocumentId that contains code text.
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | Model | When implemented by a class, gets SemanticModel associated with this Repository.
Public property | ProjectId | When implemented by a class, represents a Microsoft.CodeAnalysis.ProjectId that contains document.
Public property | ProjectName | When implemented by a class, gets or sets Project name containing document
Public property | Solution | When implemented by a class, gets RoslynSolution associated with this Repository.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | Text | When implemented by a class, gets SourceText associated with this Repository.
Public property | Tree | When implemented by a class, gets SyntaxTree associated with this Repository.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.Document Property

IRoslynRepositoryDocument Property
When implemented by a class, represents a Microsoft.CodeAnalysis.Document that contains code text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Document Document { get; }
ReadOnly Property Document As Document
    Get
property Document^ Document {
    Document^ get ();
}
abstract Document : Document with get

Property Value

Type: Document
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.DocumentId Property

IRoslynRepositoryDocumentId Property
When implemented by a class, represents a Microsoft.CodeAnalysis.DocumentId that contains code text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DocumentId DocumentId { get; set; }
Property DocumentId As DocumentId
    Get
    Set
property DocumentId^ DocumentId {
    DocumentId^ get ();
    void set (DocumentId^ value);
}
abstract DocumentId : DocumentId with get, set

Property Value

Type: DocumentId
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.Model Property

IRoslynRepositoryModel Property
When implemented by a class, gets SemanticModel associated with this Repository.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SemanticModel Model { get; }
ReadOnly Property Model As SemanticModel
    Get
property SemanticModel^ Model {
    SemanticModel^ get ();
}
abstract Model : SemanticModel with get

Property Value

Type: SemanticModel
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.ProjectId Property

IRoslynRepositoryProjectId Property
When implemented by a class, represents a Microsoft.CodeAnalysis.ProjectId that contains document.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ProjectId ProjectId { get; set; }
Property ProjectId As ProjectId
    Get
    Set
property ProjectId^ ProjectId {
    ProjectId^ get ();
    void set (ProjectId^ value);
}
abstract ProjectId : ProjectId with get, set

Property Value

Type: ProjectId
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.ProjectName Property

IRoslynRepositoryProjectName Property
When implemented by a class, gets or sets Project name containing document

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string ProjectName { get; set; }
Property ProjectName As String
    Get
    Set
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}
abstract ProjectName : string with get, set

Property Value

Type: String
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.Solution Property

IRoslynRepositorySolution Property
When implemented by a class, gets RoslynSolution associated with this Repository.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRoslynSolution Solution { get; }
ReadOnly Property Solution As IRoslynSolution
    Get
property IRoslynSolution^ Solution {
    IRoslynSolution^ get ();
}
abstract Solution : IRoslynSolution with get

Property Value

Type: IRoslynSolution
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.Text Property

IRoslynRepositoryText Property
When implemented by a class, gets SourceText associated with this Repository.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SourceText Text { get; }
ReadOnly Property Text As SourceText
    Get
property SourceText^ Text {
    SourceText^ get ();
}
abstract Text : SourceText with get

Property Value

Type: SourceText
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.Tree Property

IRoslynRepositoryTree Property
When implemented by a class, gets SyntaxTree associated with this Repository.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SyntaxTree Tree { get; }
ReadOnly Property Tree As SyntaxTree
    Get
property SyntaxTree^ Tree {
    SyntaxTree^ get ();
}
abstract Tree : SyntaxTree with get

Property Value

Type: SyntaxTree
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository Events

IRoslynRepository Events

The IRoslynRepository type exposes the following members.

Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options.
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynRepository.CustomFormattingOptions Event

IRoslynRepositoryCustomFormattingOptions Event
Occurs when text document is being formatted to provide custom formatting options.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<FormattingOptionsEventArgs> CustomFormattingOptions
Event CustomFormattingOptions As EventHandler(Of FormattingOptionsEventArgs)
 event EventHandler<FormattingOptionsEventArgs^>^ CustomFormattingOptions {
    void add (EventHandler<FormattingOptionsEventArgs^>^ value);
    void remove (EventHandler<FormattingOptionsEventArgs^>^ value);
}
abstract CustomFormattingOptions : IEvent<EventHandler<FormattingOptionsEventArgs>,
    FormattingOptionsEventArgs>

Value

Type: SystemEventHandlerFormattingOptionsEventArgs
See Also

Reference

IRoslynRepository Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution Interface

IRoslynSolution Interface
Represents properties and methods to service source code documents intended to use for Roslyn supported languages.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRoslynSolution : INotify,
    IUpdate
Public Interface IRoslynSolution
    Inherits INotify, IUpdate
public interface class IRoslynSolution : INotify,
    IUpdate
type IRoslynSolution =
    interface
        interface INotify
        interface IUpdate
    end

The IRoslynSolution type exposes the following members.

Methods
Name Description
Public method AddDocument(String, SourceText, ProjectId, Boolean)
Adds a new document to the project.
Public method AddDocument(String, String, ProjectId, Boolean)
When implemented by a class, adds a new document to the project.
Public method AddNotifier
When implemented by a class, adds new handler to respond a notification.
(Inherited from INotify.)
Public method AddProject
When implemented by a class, adds project to the solution
Public method AddReference
When implemented by a class, adds metadata reference to the project
Public method BeginUpdate
When implemented by a class, prevents object state updating until calling EndUpdate method.
(Inherited from IUpdate.)
Public method CloseDocument
When implemented by a class, closes specified document.
Public method CreateDefaultProject
When implemented by a class, Creates default project to this solution.
Public method DisableUpdate
When implemented by a class, prevents object state updating until calling EnableUpdate method.
(Inherited from IUpdate.)
Public method DocumentBelongsToDefaultProject
When implemented by a class, indicates if document belongs to the default project.
Public method EnableUpdate
When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from IUpdate.)
Public method EndUpdate
When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method.
(Inherited from IUpdate.)
Public method FindDocument
When implemented by a class, gets Microsoft.CodeAnalysis.Document matches the given file path.
Public method GetProject(ProjectId)
When implemented by a class, gets or creates Project in the solution.
Public method GetProject(String)
When implemented by a class, gets or creates Project in the solution.
Public method IsDocumentOpen
When implemented by a class, determines if document is already open in the workspace.
Public method Notify
When implemented by a class, notifies all notifiers about updating object state.
(Inherited from INotify.)
Public method OpenDocument
When implemented by a class, opens specified document if needed.
Public method RegisterAssemblies
When implemented by a class, replaces assemblies in the project with new ones.
Public method RegisterAssembly
When implemented by a class, registers assembly in the project.
Public method RegisterCodeFiles
When implemented by a class, makes types declared in given source files accessible for code completion.
Public method RegisterNamespaces
When implemented by a class, registers global namespaces.
Public method RegisterProjectReferences
When implemented by a class, replaces project references with the new ones.
Public method RemoveDocument(DocumentId)
When implemented by a class, removes specified Microsoft.CodeAnalysis.Document from the project.
Public method RemoveDocument(String, ProjectId)
When implemented by a class, removes specified document from the project.
Public method RemoveNotifier
When implemented by a class, exclude specified handler from notification handlers list.
(Inherited from INotify.)
Public method RemoveProject
When implemented by a class, removes project from the solution
Public method ReplaceCodeFile
Updates code completion with changes in source file.
Public method ReplaceDocument(DocumentId, SourceText)
When implemented by a class, updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method ReplaceDocument(DocumentId, String)
When implemented by a class, updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method UnregisterAssemblies
When implemented by a class, unregisters assemblies from the project.
Public method UnregisterAssembly
When implemented by a class, unregisters assembly from the project.
Public method UnregisterCodeFiles
When implemented by a class, removes types declared in given source files from being accessible code completion.
Public method UnregisterProjectReferences
When implemented by a class, unregisters assemblies from the project.
Public method Update
When implemented by a class, updates an object state.
(Inherited from IUpdate.)
Public method WithDefaultAssemblies
When implemented by a class, registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add references to.

Return Value

Type:
IRoslynSolution instance with default assemblies being registered for code completion
Top
Properties
 | Name | Description
Public property | AssemblySearchPaths | When implemented by a class, gets or sets a collection of assembly search paths.
Public property | BaseDirectory | When implemented by a class, gets or sets solution base directory.
Public property | Conditionals | When implemented by a class, gets or sets a collection of conditional symbols
Public property | CustomXMLDocPath | When implemented by a class, gets a custom xml documentation path.
Public property | FrameworkPath | When implemented by a class, gets or sets path to the .NET Framework assemblies
Public property | ProjectId | When implemented by a class, gets a current Microsoft.CodeAnalysis.ProjectId.
Public property | ScriptSearchPaths | When implemented by a class, gets or sets a collection of script source search paths.
Public property | Solution | When implemented by a class, gets a current solution Microsoft.CodeAnalysis.Solution.
Public property | SourceKind | When implemented by a class, gets kind (regular or script) of the source code.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | Workspace | When implemented by a class, gets a current project Microsoft.CodeAnalysis.Workspace.
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution Methods

IRoslynSolution Methods

The IRoslynSolution type exposes the following members.

Methods
Name Description
Public method AddDocument(String, SourceText, ProjectId, Boolean)
Adds a new document to the project.
Public method AddDocument(String, String, ProjectId, Boolean)
When implemented by a class, adds a new document to the project.
Public method AddNotifier
When implemented by a class, adds new handler to respond a notification.
(Inherited from INotify.)
Public method AddProject
When implemented by a class, adds project to the solution
Public method AddReference
When implemented by a class, adds metadata reference to the project
Public method BeginUpdate
When implemented by a class, prevents object state updating until calling EndUpdate method.
(Inherited from IUpdate.)
Public method CloseDocument
When implemented by a class, closes specified document.
Public method CreateDefaultProject
When implemented by a class, Creates default project to this solution.
Public method DisableUpdate
When implemented by a class, prevents object state updating until calling EnableUpdate method.
(Inherited from IUpdate.)
Public method DocumentBelongsToDefaultProject
When implemented by a class, indicates if document belongs to the default project.
Public method EnableUpdate
When implemented by a class, re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from IUpdate.)
Public method EndUpdate
When implemented by a class, re-enables object state updating, that was turn of by calling BeginUpdate method.
(Inherited from IUpdate.)
Public method FindDocument
When implemented by a class, gets Microsoft.CodeAnalysis.Document matches the given file path.
Public method GetProject(ProjectId)
When implemented by a class, gets or creates Project in the solution.
Public method GetProject(String)
When implemented by a class, gets or creates Project in the solution.
Public method IsDocumentOpen
When implemented by a class, determines if document is already open in the workspace.
Public method Notify
When implemented by a class, notifies all notifiers about updating object state.
(Inherited from INotify.)
Public method OpenDocument
When implemented by a class, opens specified document if needed.
Public method RegisterAssemblies
When implemented by a class, replaces assemblies in the project with new ones.
Public method RegisterAssembly
When implemented by a class, registers assembly in the project.
Public method RegisterCodeFiles
When implemented by a class, makes types declared in given source files accessible for code completion.
Public method RegisterNamespaces
When implemented by a class, registers global namespaces.
Public method RegisterProjectReferences
When implemented by a class, replaces project references with the new ones.
Public method RemoveDocument(DocumentId)
When implemented by a class, removes specified Microsoft.CodeAnalysis.Document from the project.
Public method RemoveDocument(String, ProjectId)
When implemented by a class, removes specified document from the project.
Public method RemoveNotifier
When implemented by a class, exclude specified handler from notification handlers list.
(Inherited from INotify.)
Public method RemoveProject
When implemented by a class, removes project from the solution
Public method ReplaceCodeFile
Updates code completion with changes in source file.
Public method ReplaceDocument(DocumentId, SourceText)
When implemented by a class, updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method ReplaceDocument(DocumentId, String)
When implemented by a class, updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method UnregisterAssemblies
When implemented by a class, unregisters assemblies from the project.
Public method UnregisterAssembly
When implemented by a class, unregisters assembly from the project.
Public method UnregisterCodeFiles
When implemented by a class, removes types declared in given source files from being accessible code completion.
Public method UnregisterProjectReferences
When implemented by a class, unregisters assemblies from the project.
Public method Update
When implemented by a class, updates an object state.
(Inherited from IUpdate.)
Public method WithDefaultAssemblies
When implemented by a class, registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add references to.

Return Value

Type:
IRoslynSolution instance with default assemblies being registered for code completion
Top
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.AddDocument Method

IRoslynSolutionAddDocument Method
Overload List
 | Name | Description
Public method | AddDocument(String, SourceText, ProjectId, Boolean) | Adds a new document to the project.
Public method | AddDocument(String, String, ProjectId, Boolean) | When implemented by a class, adds a new document to the project.
Top
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.AddDocument Method (String, SourceText, ProjectId, Boolean)

IRoslynSolutionAddDocument Method (String, SourceText, ProjectId, Boolean)
Adds a new document to the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DocumentId AddDocument(
    string fileName,
    SourceText text,
    ProjectId projectId = null,
    bool open = true
)
Function AddDocument (
    fileName As String,
    text As SourceText,
    Optional projectId As ProjectId = Nothing,
    Optional open As Boolean = true
) As DocumentId
DocumentId^ AddDocument(
    String^ fileName,
    SourceText^ text,
    ProjectId^ projectId = nullptr,
    bool open = true
)
abstract AddDocument :
        fileName : string *
        text : SourceText *
        ?projectId : ProjectId *
        ?open : bool
(* Defaults:
        let _projectId = defaultArg projectId null
        let _open = defaultArg open true
*)
-> DocumentId

Parameters

fileName
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.
text
Type: SourceText
New Microsoft.CodeAnalysis.Document text.
projectId (Optional)
Type: ProjectId
Specifies Project to add document to
open (Optional)
Type: SystemBoolean
Specifies if document needs to be open in the workspace.

Return Value

Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to be added.
See Also

Reference

IRoslynSolution Interface
AddDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.AddDocument Method (String, String, ProjectId, Boolean)

IRoslynSolutionAddDocument Method (String, String, ProjectId, Boolean)
When implemented by a class, adds a new document to the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DocumentId AddDocument(
    string fileName,
    string text,
    ProjectId projectId = null,
    bool open = true
)
Function AddDocument (
    fileName As String,
    text As String,
    Optional projectId As ProjectId = Nothing,
    Optional open As Boolean = true
) As DocumentId
DocumentId^ AddDocument(
    String^ fileName,
    String^ text,
    ProjectId^ projectId = nullptr,
    bool open = true
)
abstract AddDocument :
        fileName : string *
        text : string *
        ?projectId : ProjectId *
        ?open : bool
(* Defaults:
        let _projectId = defaultArg projectId null
        let _open = defaultArg open true
*)
-> DocumentId

Parameters

fileName
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.
text
Type: SystemString
New Microsoft.CodeAnalysis.Document text.
projectId (Optional)
Type: ProjectId
Specifies Project to add document to
open (Optional)
Type: SystemBoolean
Specifies if document needs to be open in the workspace.

Return Value

Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to be added.
See Also

Reference

IRoslynSolution Interface
AddDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.AddProject Method

IRoslynSolutionAddProject Method
When implemented by a class, adds project to the solution

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ProjectId AddProject(
    string projectName,
    string projectPath
)
Function AddProject (
    projectName As String,
    projectPath As String
) As ProjectId
ProjectId^ AddProject(
    String^ projectName,
    String^ projectPath
)
abstract AddProject :
        projectName : string *
        projectPath : string -> ProjectId

Parameters

projectName
Type: SystemString
Project name
projectPath
Type: SystemString
Project path

Return Value

Type: ProjectId
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.AddReference Method

IRoslynSolutionAddReference Method
When implemented by a class, adds metadata reference to the project

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddReference(
    MetadataReference reference,
    ProjectId projectId = null
)
Sub AddReference (
    reference As MetadataReference,
    Optional projectId As ProjectId = Nothing
)
void AddReference(
    MetadataReference^ reference,
    ProjectId^ projectId = nullptr
)
abstract AddReference :
        reference : MetadataReference *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit

Parameters

reference
Type: MetadataReference
Reference to add.
projectId (Optional)
Type: ProjectId
Specifies project to add reference to.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.CloseDocument Method

IRoslynSolutionCloseDocument Method
When implemented by a class, closes specified document.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool CloseDocument(
    DocumentId documentId
)
Function CloseDocument (
    documentId As DocumentId
) As Boolean
bool CloseDocument(
    DocumentId^ documentId
)
abstract CloseDocument :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to close.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.CreateDefaultProject Method

IRoslynSolutionCreateDefaultProject Method
When implemented by a class, Creates default project to this solution.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ProjectId CreateDefaultProject()
Function CreateDefaultProject As ProjectId
ProjectId^ CreateDefaultProject()
abstract CreateDefaultProject : unit -> ProjectId

Return Value

Type: ProjectId
Id of Microsoft.CodeAnalysis.Project of a project that is created.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.DocumentBelongsToDefaultProject Method

IRoslynSolutionDocumentBelongsToDefaultProject Method
When implemented by a class, indicates if document belongs to the default project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool DocumentBelongsToDefaultProject(
    DocumentId documentId
)
Function DocumentBelongsToDefaultProject (
    documentId As DocumentId
) As Boolean
bool DocumentBelongsToDefaultProject(
    DocumentId^ documentId
)
abstract DocumentBelongsToDefaultProject :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId

Return Value

Type: Boolean
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.FindDocument Method

IRoslynSolutionFindDocument Method
When implemented by a class, gets Microsoft.CodeAnalysis.Document matches the given file path.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Document FindDocument(
    string fileName,
    ProjectId projectId = null
)
Function FindDocument (
    fileName As String,
    Optional projectId As ProjectId = Nothing
) As Document
Document^ FindDocument(
    String^ fileName,
    ProjectId^ projectId = nullptr
)
abstract FindDocument :
        fileName : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> Document

Parameters

fileName
Type: SystemString
Document file name.
projectId (Optional)
Type: ProjectId
Specifies Project to search for the document.

Return Value

Type: Document
Found Microsoft.CodeAnalysis.Document object.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.GetProject Method

IRoslynSolutionGetProject Method
Overload List
 | Name | Description
Public method | GetProject(ProjectId) | When implemented by a class, gets or creates Project in the solution.
Public method | GetProject(String) | When implemented by a class, gets or creates Project in the solution.
Top
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.GetProject Method (ProjectId)

IRoslynSolutionGetProject Method (ProjectId)
When implemented by a class, gets or creates Project in the solution.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Project GetProject(
    ProjectId projectId
)
Function GetProject (
    projectId As ProjectId
) As Project
Project^ GetProject(
    ProjectId^ projectId
)
abstract GetProject :
        projectId : ProjectId -> Project

Parameters

projectId
Type: ProjectId
Specifies project ID.

Return Value

Type: Project
Found project.
See Also

Reference

IRoslynSolution Interface
GetProject Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.GetProject Method (String)

IRoslynSolutionGetProject Method (String)
When implemented by a class, gets or creates Project in the solution.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Project GetProject(
    string projectName
)
Function GetProject (
    projectName As String
) As Project
Project^ GetProject(
    String^ projectName
)
abstract GetProject :
        projectName : string -> Project

Parameters

projectName
Type: SystemString
Specifies project name.

Return Value

Type: Project
Found project.
See Also

Reference

IRoslynSolution Interface
GetProject Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.IsDocumentOpen Method

IRoslynSolutionIsDocumentOpen Method
When implemented by a class, determines if document is already open in the workspace.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsDocumentOpen(
    DocumentId documentId
)
Function IsDocumentOpen (
    documentId As DocumentId
) As Boolean
bool IsDocumentOpen(
    DocumentId^ documentId
)
abstract IsDocumentOpen :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to check.

Return Value

Type: Boolean
True if document is already open; False otherwise
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.OpenDocument Method

IRoslynSolutionOpenDocument Method
When implemented by a class, opens specified document if needed.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void OpenDocument(
    DocumentId documentId
)
Sub OpenDocument (
    documentId As DocumentId
)
void OpenDocument(
    DocumentId^ documentId
)
abstract OpenDocument :
        documentId : DocumentId -> unit

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to open.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.RegisterAssemblies Method

IRoslynSolutionRegisterAssemblies Method
When implemented by a class, replaces assemblies in the project with new ones.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RegisterAssemblies(
    string[] references,
    ProjectId projectId = null
)
Function RegisterAssemblies (
    references As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
bool RegisterAssemblies(
    array<String^>^ references,
    ProjectId^ projectId = nullptr
)
abstract RegisterAssemblies :
        references : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

references
Type: SystemString
List of assembly names.
projectId (Optional)
Type: ProjectId
Specifies project to add references to.

Return Value

Type: Boolean
True if succeed otherwise false.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.RegisterAssembly Method

IRoslynSolutionRegisterAssembly Method
When implemented by a class, registers assembly in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RegisterAssembly(
    string name,
    ProjectId projectId = null
)
Function RegisterAssembly (
    name As String,
    Optional projectId As ProjectId = Nothing
) As Boolean
bool RegisterAssembly(
    String^ name,
    ProjectId^ projectId = nullptr
)
abstract RegisterAssembly :
        name : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

name
Type: SystemString
Assembly name.
projectId (Optional)
Type: ProjectId
Specifies project to add reference to.

Return Value

Type: Boolean
True if succeed otherwise false.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.RegisterCodeFiles Method

IRoslynSolutionRegisterCodeFiles Method
When implemented by a class, makes types declared in given source files accessible for code completion.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterCodeFiles(
    string[] files,
    ProjectId projectId = null
)
Sub RegisterCodeFiles (
    files As String(),
    Optional projectId As ProjectId = Nothing
)
void RegisterCodeFiles(
    array<String^>^ files,
    ProjectId^ projectId = nullptr
)
abstract RegisterCodeFiles :
        files : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit

Parameters

files
Type: SystemString
files containing source code.
projectId (Optional)
Type: ProjectId
Specifies project to add files to.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.RegisterNamespaces Method

IRoslynSolutionRegisterNamespaces Method
When implemented by a class, registers global namespaces.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RegisterNamespaces(
    string[] nameSpaces,
    ProjectId projectId = null
)
Function RegisterNamespaces (
    nameSpaces As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
bool RegisterNamespaces(
    array<String^>^ nameSpaces,
    ProjectId^ projectId = nullptr
)
abstract RegisterNamespaces :
        nameSpaces : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

nameSpaces
Type: SystemString
List of global namespaces
projectId (Optional)
Type: ProjectId
Specifies project to add namespaces to.

Return Value

Type: Boolean
True if succeed otherwise false.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.RegisterProjectReferences Method

IRoslynSolutionRegisterProjectReferences Method
When implemented by a class, replaces project references with the new ones.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RegisterProjectReferences(
    string[] projectReferences,
    ProjectId projectId = null
)
Function RegisterProjectReferences (
    projectReferences As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
bool RegisterProjectReferences(
    array<String^>^ projectReferences,
    ProjectId^ projectId = nullptr
)
abstract RegisterProjectReferences :
        projectReferences : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

projectReferences
Type: SystemString
Project references.
projectId (Optional)
Type: ProjectId
Specifies project to add references to.

Return Value

Type: Boolean
True if succeed otherwise false.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.RemoveDocument Method

IRoslynSolutionRemoveDocument Method
Overload List
 | Name | Description
Public method | RemoveDocument(DocumentId) | When implemented by a class, removes specified Microsoft.CodeAnalysis.Document from the project.
Public method | RemoveDocument(String, ProjectId) | When implemented by a class, removes specified document from the project.
Top
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.RemoveDocument Method (DocumentId)

IRoslynSolutionRemoveDocument Method (DocumentId)
When implemented by a class, removes specified Microsoft.CodeAnalysis.Document from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RemoveDocument(
    DocumentId documentId
)
Function RemoveDocument (
    documentId As DocumentId
) As Boolean
bool RemoveDocument(
    DocumentId^ documentId
)
abstract RemoveDocument :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to remove.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IRoslynSolution Interface
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.RemoveDocument Method (String, ProjectId)

IRoslynSolutionRemoveDocument Method (String, ProjectId)
When implemented by a class, removes specified document from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RemoveDocument(
    string fileName,
    ProjectId projectId = null
)
Function RemoveDocument (
    fileName As String,
    Optional projectId As ProjectId = Nothing
) As Boolean
bool RemoveDocument(
    String^ fileName,
    ProjectId^ projectId = nullptr
)
abstract RemoveDocument :
        fileName : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

fileName
Type: SystemString
File path to remove.
projectId (Optional)
Type: ProjectId
Specifies Project to search for the document.

Return Value

Type: Boolean
True if succeed; otherwise false.
See Also

Reference

IRoslynSolution Interface
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.RemoveProject Method

IRoslynSolutionRemoveProject Method
When implemented by a class, removes project from the solution

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool RemoveProject(
    ProjectId projectId
)
Function RemoveProject (
    projectId As ProjectId
) As Boolean
bool RemoveProject(
    ProjectId^ projectId
)
abstract RemoveProject :
        projectId : ProjectId -> bool

Parameters

projectId
Type: ProjectId

Return Value

Type: Boolean
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.ReplaceCodeFile Method

IRoslynSolutionReplaceCodeFile Method
Updates code completion with changes in source file.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReplaceCodeFile(
    string file,
    string text,
    ProjectId projectId = null
)
Sub ReplaceCodeFile (
    file As String,
    text As String,
    Optional projectId As ProjectId = Nothing
)
void ReplaceCodeFile(
    String^ file,
    String^ text,
    ProjectId^ projectId = nullptr
)
abstract ReplaceCodeFile :
        file : string *
        text : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit

Parameters

file
Type: SystemString
File containing source code.
text
Type: SystemString
Source code text.
projectId (Optional)
Type: ProjectId
Specifies project search for the file.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.ReplaceDocument Method

IRoslynSolutionReplaceDocument Method
Overload List
 | Name | Description
Public method | ReplaceDocument(DocumentId, SourceText) | When implemented by a class, updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method | ReplaceDocument(DocumentId, String) | When implemented by a class, updates Microsoft.CodeAnalysis.Document to have the text specified.
Top
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.ReplaceDocument Method (DocumentId, SourceText)

IRoslynSolutionReplaceDocument Method (DocumentId, SourceText)
When implemented by a class, updates Microsoft.CodeAnalysis.Document to have the text specified.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReplaceDocument(
    DocumentId documentId,
    SourceText text
)
Function ReplaceDocument (
    documentId As DocumentId,
    text As SourceText
) As Boolean
bool ReplaceDocument(
    DocumentId^ documentId,
    SourceText^ text
)
abstract ReplaceDocument :
        documentId : DocumentId *
        text : SourceText -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.Document
text
Type: SourceText
New Microsoft.CodeAnalysis.DocumentId text.

Return Value

Type: Boolean
True if document has been replaced, otherwise false.
See Also

Reference

IRoslynSolution Interface
ReplaceDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.ReplaceDocument Method (DocumentId, String)

IRoslynSolutionReplaceDocument Method (DocumentId, String)
When implemented by a class, updates Microsoft.CodeAnalysis.Document to have the text specified.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ReplaceDocument(
    DocumentId documentId,
    string text
)
Function ReplaceDocument (
    documentId As DocumentId,
    text As String
) As Boolean
bool ReplaceDocument(
    DocumentId^ documentId,
    String^ text
)
abstract ReplaceDocument :
        documentId : DocumentId *
        text : string -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.Document
text
Type: SystemString
New Microsoft.CodeAnalysis.Document text.

Return Value

Type: Boolean
True if document has been replaced, otherwise false.
See Also

Reference

IRoslynSolution Interface
ReplaceDocument Overload
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.UnregisterAssemblies Method

IRoslynSolutionUnregisterAssemblies Method
When implemented by a class, unregisters assemblies from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterAssemblies(
    string[] references,
    ProjectId projectId = null
)
Function UnregisterAssemblies (
    references As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
bool UnregisterAssemblies(
    array<String^>^ references,
    ProjectId^ projectId = nullptr
)
abstract UnregisterAssemblies :
        references : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

references
Type: SystemString
List of assembly names.
projectId (Optional)
Type: ProjectId
Specifies project to remove references from.

Return Value

Type: Boolean
True if succeed otherwise false.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.UnregisterAssembly Method

IRoslynSolutionUnregisterAssembly Method
When implemented by a class, unregisters assembly from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterAssembly(
    string name,
    ProjectId projectId = null
)
Function UnregisterAssembly (
    name As String,
    Optional projectId As ProjectId = Nothing
) As Boolean
bool UnregisterAssembly(
    String^ name,
    ProjectId^ projectId = nullptr
)
abstract UnregisterAssembly :
        name : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

name
Type: SystemString
Assembly name.
projectId (Optional)
Type: ProjectId
Specifies project to remove reference from.

Return Value

Type: Boolean
True if assembly has been unregistered, otherwise false.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.UnregisterCodeFiles Method

IRoslynSolutionUnregisterCodeFiles Method
When implemented by a class, removes types declared in given source files from being accessible code completion.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnregisterCodeFiles(
    string[] files,
    ProjectId projectId = null
)
Sub UnregisterCodeFiles (
    files As String(),
    Optional projectId As ProjectId = Nothing
)
void UnregisterCodeFiles(
    array<String^>^ files,
    ProjectId^ projectId = nullptr
)
abstract UnregisterCodeFiles :
        files : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit

Parameters

files
Type: SystemString
files containing source code.
projectId (Optional)
Type: ProjectId
Specifies project to remove files from.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.UnregisterProjectReferences Method

IRoslynSolutionUnregisterProjectReferences Method
When implemented by a class, unregisters assemblies from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool UnregisterProjectReferences(
    string[] projectReferences,
    ProjectId projectId = null
)
Function UnregisterProjectReferences (
    projectReferences As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
bool UnregisterProjectReferences(
    array<String^>^ projectReferences,
    ProjectId^ projectId = nullptr
)
abstract UnregisterProjectReferences :
        projectReferences : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

projectReferences
Type: SystemString
Project references.
projectId (Optional)
Type: ProjectId
Specifies project to remove references from.

Return Value

Type: Boolean
True if succeed otherwise false.
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.WithDefaultAssemblies Method

IRoslynSolutionWithDefaultAssemblies Method
When implemented by a class, registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add references to.

Return Value

Type: IRoslynSolution
IRoslynSolution instance with default assemblies being registered for code completion

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IRoslynSolution WithDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms,
    bool keepExisting = false,
    ProjectId projectId = null,
    TargetFramework targetFramework = null
)
Function WithDefaultAssemblies (
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms,
    Optional keepExisting As Boolean = false,
    Optional projectId As ProjectId = Nothing,
    Optional targetFramework As TargetFramework = Nothing
) As IRoslynSolution
IRoslynSolution^ WithDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms,
    bool keepExisting = false,
    ProjectId^ projectId = nullptr,
    TargetFramework^ targetFramework = nullptr
)
abstract WithDefaultAssemblies :
        ?technology : TechnologyEnvironment *
        ?keepExisting : bool *
        ?projectId : ProjectId *
        ?targetFramework : TargetFramework
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
        let _projectId = defaultArg projectId null
        let _targetFramework = defaultArg targetFramework null
*)
-> IRoslynSolution

Parameters

technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
keepExisting (Optional)
Type: SystemBoolean
projectId (Optional)
Type: ProjectId
targetFramework (Optional)
Type: Alternet.Common.DotNet.ProjectsTargetFramework

Return Value

Type: IRoslynSolution
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution Properties

IRoslynSolution Properties

The IRoslynSolution type exposes the following members.

Properties
 | Name | Description
Public property | AssemblySearchPaths | When implemented by a class, gets or sets a collection of assembly search paths.
Public property | BaseDirectory | When implemented by a class, gets or sets solution base directory.
Public property | Conditionals | When implemented by a class, gets or sets a collection of conditional symbols
Public property | CustomXMLDocPath | When implemented by a class, gets a custom xml documentation path.
Public property | FrameworkPath | When implemented by a class, gets or sets path to the .NET Framework assemblies
Public property | ProjectId | When implemented by a class, gets a current Microsoft.CodeAnalysis.ProjectId.
Public property | ScriptSearchPaths | When implemented by a class, gets or sets a collection of script source search paths.
Public property | Solution | When implemented by a class, gets a current solution Microsoft.CodeAnalysis.Solution.
Public property | SourceKind | When implemented by a class, gets kind (regular or script) of the source code.
Public property | UpdateCount | When implemented by a class, keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from IUpdate.)
Public property | Workspace | When implemented by a class, gets a current project Microsoft.CodeAnalysis.Workspace.
Top
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.AssemblySearchPaths Property

IRoslynSolutionAssemblySearchPaths Property
When implemented by a class, gets or sets a collection of assembly search paths.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] AssemblySearchPaths { get; set; }
Property AssemblySearchPaths As String()
    Get
    Set
property array<String^>^ AssemblySearchPaths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract AssemblySearchPaths : string[] with get, set

Property Value

Type: String
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.BaseDirectory Property

IRoslynSolutionBaseDirectory Property
When implemented by a class, gets or sets solution base directory.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string BaseDirectory { get; set; }
Property BaseDirectory As String
    Get
    Set
property String^ BaseDirectory {
    String^ get ();
    void set (String^ value);
}
abstract BaseDirectory : string with get, set

Property Value

Type: String
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.Conditionals Property

IRoslynSolutionConditionals Property
When implemented by a class, gets or sets a collection of conditional symbols

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] Conditionals { get; set; }
Property Conditionals As String()
    Get
    Set
property array<String^>^ Conditionals {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract Conditionals : string[] with get, set

Property Value

Type: String
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.CustomXMLDocPath Property

IRoslynSolutionCustomXMLDocPath Property
When implemented by a class, gets a custom xml documentation path.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string CustomXMLDocPath { get; set; }
Property CustomXMLDocPath As String
    Get
    Set
property String^ CustomXMLDocPath {
    String^ get ();
    void set (String^ value);
}
abstract CustomXMLDocPath : string with get, set

Property Value

Type: String
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.FrameworkPath Property

IRoslynSolutionFrameworkPath Property
When implemented by a class, gets or sets path to the .NET Framework assemblies

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FrameworkPath { get; set; }
Property FrameworkPath As String
    Get
    Set
property String^ FrameworkPath {
    String^ get ();
    void set (String^ value);
}
abstract FrameworkPath : string with get, set

Property Value

Type: String
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.ProjectId Property

IRoslynSolutionProjectId Property
When implemented by a class, gets a current Microsoft.CodeAnalysis.ProjectId.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ProjectId ProjectId { get; }
ReadOnly Property ProjectId As ProjectId
    Get
property ProjectId^ ProjectId {
    ProjectId^ get ();
}
abstract ProjectId : ProjectId with get

Property Value

Type: ProjectId
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.ScriptSearchPaths Property

IRoslynSolutionScriptSearchPaths Property
When implemented by a class, gets or sets a collection of script source search paths.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string[] ScriptSearchPaths { get; set; }
Property ScriptSearchPaths As String()
    Get
    Set
property array<String^>^ ScriptSearchPaths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract ScriptSearchPaths : string[] with get, set

Property Value

Type: String
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.Solution Property

IRoslynSolutionSolution Property
When implemented by a class, gets a current solution Microsoft.CodeAnalysis.Solution.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Solution Solution { get; }
ReadOnly Property Solution As Solution
    Get
property Solution^ Solution {
    Solution^ get ();
}
abstract Solution : Solution with get

Property Value

Type: Solution
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.SourceKind Property

IRoslynSolutionSourceKind Property
When implemented by a class, gets kind (regular or script) of the source code.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SourceCodeKind SourceKind { get; }
ReadOnly Property SourceKind As SourceCodeKind
    Get
property SourceCodeKind SourceKind {
    SourceCodeKind get ();
}
abstract SourceKind : SourceCodeKind with get

Property Value

Type: SourceCodeKind
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


IRoslynSolution.Workspace Property

IRoslynSolutionWorkspace Property
When implemented by a class, gets a current project Microsoft.CodeAnalysis.Workspace.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Workspace Workspace { get; }
ReadOnly Property Workspace As Workspace
    Get
property Workspace^ Workspace {
    Workspace^ get ();
}
abstract Workspace : Workspace with get

Property Value

Type: Workspace
See Also

Reference

IRoslynSolution Interface
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts Class

ParserConsts Class
Contains default constants related to lexical and syntax analyzers.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.RoslynParserConsts

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParserConsts
Public Class ParserConsts
public ref class ParserConsts
type ParserConsts =  class end

The ParserConsts type exposes the following members.

Constructors
 | Name | Description
Public method | ParserConsts | Initializes a new instance of the ParserConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ClassIndex |
ConstIndex |
ControlKeyword |
ControlKeywordInternalName |
DeclarationGuideLines |
DefaultCodeCompletionDelay |
DefaultControlKeywordForeColor |
DefaultCsAutoIndentChars |
DefaultCsCodeCompletionChars |
DefaultCsSmartFormatChars |
DefaultDelimiters |
DefaultExcludedCodeForeColor |
DefaultMethodForeColor |
DefaultParseInterval |
DefaultSyntaxInterval |
DefaultSyntaxOptions |
DefaultTypeForeColor |
DefaultVbAutoIndentChars |
DefaultVbCodeCompletionChars |
DefaultVbSmartFormatChars |
DefaultVbSyntaxOptions |
DefaultWarningsForeColor |
DefaultWinFormsNamespaces |
DefaultWPFNamespaces |
DefaultXmlParamsForeColor |
DelegateIndex |
EnumIndex |
EnumMemberIndex |
EventIndex |
ExcludedCodeInternalName |
ExtensionMethodName |
FieldIndex |
InterfaceIndex |
KeywordIndex |
LocalIndex |
LookAheadLines |
LookAheadLinesAsync |
MaxDiagnosticCount |
MethodIndex |
MethodInternalName |
MethodName |
NamespaceIndex |
ProcessEmbeddedScriptDocuments |
PropertyIndex |
SnippetIndex |
StatementsGuideLines |
StaticSymbol |
StructIndex |
TypeIndex |
TypeInternalName |
ValueModifier |
WarningsInternalName |
XmlCommentStart |
XmlComplexTag |
XmlEndTag |
XmlParamsInternalName |
XmlTag |
XmlVbCommentStart |
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts Constructor

ParserConsts Constructor
Initializes a new instance of the ParserConsts class

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParserConsts()
Public Sub New
public:
ParserConsts()
new : unit -> ParserConsts
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts Fields

ParserConsts Fields

The ParserConsts type exposes the following members.

Fields
Name | Description
ClassIndex |
ConstIndex |
ControlKeyword |
ControlKeywordInternalName |
DeclarationGuideLines |
DefaultCodeCompletionDelay |
DefaultControlKeywordForeColor |
DefaultCsAutoIndentChars |
DefaultCsCodeCompletionChars |
DefaultCsSmartFormatChars |
DefaultDelimiters |
DefaultExcludedCodeForeColor |
DefaultMethodForeColor |
DefaultParseInterval |
DefaultSyntaxInterval |
DefaultSyntaxOptions |
DefaultTypeForeColor |
DefaultVbAutoIndentChars |
DefaultVbCodeCompletionChars |
DefaultVbSmartFormatChars |
DefaultVbSyntaxOptions |
DefaultWarningsForeColor |
DefaultWinFormsNamespaces |
DefaultWPFNamespaces |
DefaultXmlParamsForeColor |
DelegateIndex |
EnumIndex |
EnumMemberIndex |
EventIndex |
ExcludedCodeInternalName |
ExtensionMethodName |
FieldIndex |
InterfaceIndex |
KeywordIndex |
LocalIndex |
LookAheadLines |
LookAheadLinesAsync |
MaxDiagnosticCount |
MethodIndex |
MethodInternalName |
MethodName |
NamespaceIndex |
ProcessEmbeddedScriptDocuments |
PropertyIndex |
SnippetIndex |
StatementsGuideLines |
StaticSymbol |
StructIndex |
TypeIndex |
TypeInternalName |
ValueModifier |
WarningsInternalName |
XmlCommentStart |
XmlComplexTag |
XmlEndTag |
XmlParamsInternalName |
XmlTag |
XmlVbCommentStart |
Top
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.ClassIndex Field

ParserConstsClassIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ClassIndex
Public Const ClassIndex As Integer
public:
literal int ClassIndex
static val mutable ClassIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.ConstIndex Field

ParserConstsConstIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int ConstIndex
Public Const ConstIndex As Integer
public:
literal int ConstIndex
static val mutable ConstIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.ControlKeyword Field

ParserConstsControlKeyword Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ControlKeyword
Public Const ControlKeyword As String
public:
literal String^ ControlKeyword
static val mutable ControlKeyword: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.ControlKeywordInternalName Field

ParserConstsControlKeywordInternalName Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ControlKeywordInternalName
Public Const ControlKeywordInternalName As String
public:
literal String^ ControlKeywordInternalName
static val mutable ControlKeywordInternalName: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DeclarationGuideLines Field

ParserConstsDeclarationGuideLines Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool DeclarationGuideLines
Public Shared DeclarationGuideLines As Boolean
public:
static bool DeclarationGuideLines
static val mutable DeclarationGuideLines: bool

Field Value

Type: Boolean
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultCodeCompletionDelay Field

ParserConstsDefaultCodeCompletionDelay Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultCodeCompletionDelay
Public Shared DefaultCodeCompletionDelay As Integer
public:
static int DefaultCodeCompletionDelay
static val mutable DefaultCodeCompletionDelay: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultControlKeywordForeColor Field

ParserConstsDefaultControlKeywordForeColor Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultControlKeywordForeColor
Public Shared DefaultControlKeywordForeColor As Color
public:
static Color DefaultControlKeywordForeColor
static val mutable DefaultControlKeywordForeColor: Color

Field Value

Type: Color
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultCsAutoIndentChars Field

ParserConstsDefaultCsAutoIndentChars Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCsAutoIndentChars
Public Shared DefaultCsAutoIndentChars As String
public:
static String^ DefaultCsAutoIndentChars
static val mutable DefaultCsAutoIndentChars: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultCsCodeCompletionChars Field

ParserConstsDefaultCsCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCsCodeCompletionChars
Public Shared DefaultCsCodeCompletionChars As String
public:
static String^ DefaultCsCodeCompletionChars
static val mutable DefaultCsCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultCsSmartFormatChars Field

ParserConstsDefaultCsSmartFormatChars Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCsSmartFormatChars
Public Shared DefaultCsSmartFormatChars As String
public:
static String^ DefaultCsSmartFormatChars
static val mutable DefaultCsSmartFormatChars: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultDelimiters Field

ParserConstsDefaultDelimiters Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultDelimiters
Public Shared DefaultDelimiters As String
public:
static String^ DefaultDelimiters
static val mutable DefaultDelimiters: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultExcludedCodeForeColor Field

ParserConstsDefaultExcludedCodeForeColor Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultExcludedCodeForeColor
Public Shared DefaultExcludedCodeForeColor As Color
public:
static Color DefaultExcludedCodeForeColor
static val mutable DefaultExcludedCodeForeColor: Color

Field Value

Type: Color
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultMethodForeColor Field

ParserConstsDefaultMethodForeColor Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultMethodForeColor
Public Shared DefaultMethodForeColor As Color
public:
static Color DefaultMethodForeColor
static val mutable DefaultMethodForeColor: Color

Field Value

Type: Color
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultParseInterval Field

ParserConstsDefaultParseInterval Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultParseInterval
Public Shared DefaultParseInterval As Integer
public:
static int DefaultParseInterval
static val mutable DefaultParseInterval: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultSyntaxInterval Field

ParserConstsDefaultSyntaxInterval Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultSyntaxInterval
Public Shared DefaultSyntaxInterval As Integer
public:
static int DefaultSyntaxInterval
static val mutable DefaultSyntaxInterval: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultSyntaxOptions Field

ParserConstsDefaultSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultSyntaxOptions
Public Shared DefaultSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultSyntaxOptions
static val mutable DefaultSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultTypeForeColor Field

ParserConstsDefaultTypeForeColor Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultTypeForeColor
Public Shared DefaultTypeForeColor As Color
public:
static Color DefaultTypeForeColor
static val mutable DefaultTypeForeColor: Color

Field Value

Type: Color
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultVbAutoIndentChars Field

ParserConstsDefaultVbAutoIndentChars Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultVbAutoIndentChars
Public Shared DefaultVbAutoIndentChars As String
public:
static String^ DefaultVbAutoIndentChars
static val mutable DefaultVbAutoIndentChars: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultVbCodeCompletionChars Field

ParserConstsDefaultVbCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultVbCodeCompletionChars
Public Shared DefaultVbCodeCompletionChars As String
public:
static String^ DefaultVbCodeCompletionChars
static val mutable DefaultVbCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultVbSmartFormatChars Field

ParserConstsDefaultVbSmartFormatChars Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultVbSmartFormatChars
Public Shared DefaultVbSmartFormatChars As String
public:
static String^ DefaultVbSmartFormatChars
static val mutable DefaultVbSmartFormatChars: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultVbSyntaxOptions Field

ParserConstsDefaultVbSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultVbSyntaxOptions
Public Shared DefaultVbSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultVbSyntaxOptions
static val mutable DefaultVbSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultWarningsForeColor Field

ParserConstsDefaultWarningsForeColor Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultWarningsForeColor
Public Shared DefaultWarningsForeColor As Color
public:
static Color DefaultWarningsForeColor
static val mutable DefaultWarningsForeColor: Color

Field Value

Type: Color
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultWinFormsNamespaces Field

ParserConstsDefaultWinFormsNamespaces Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultWinFormsNamespaces
Public Shared DefaultWinFormsNamespaces As String
public:
static String^ DefaultWinFormsNamespaces
static val mutable DefaultWinFormsNamespaces: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultWPFNamespaces Field

ParserConstsDefaultWPFNamespaces Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultWPFNamespaces
Public Shared DefaultWPFNamespaces As String
public:
static String^ DefaultWPFNamespaces
static val mutable DefaultWPFNamespaces: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DefaultXmlParamsForeColor Field

ParserConstsDefaultXmlParamsForeColor Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultXmlParamsForeColor
Public Shared DefaultXmlParamsForeColor As Color
public:
static Color DefaultXmlParamsForeColor
static val mutable DefaultXmlParamsForeColor: Color

Field Value

Type: Color
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.DelegateIndex Field

ParserConstsDelegateIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int DelegateIndex
Public Const DelegateIndex As Integer
public:
literal int DelegateIndex
static val mutable DelegateIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.EnumIndex Field

ParserConstsEnumIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int EnumIndex
Public Const EnumIndex As Integer
public:
literal int EnumIndex
static val mutable EnumIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.EnumMemberIndex Field

ParserConstsEnumMemberIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int EnumMemberIndex
Public Const EnumMemberIndex As Integer
public:
literal int EnumMemberIndex
static val mutable EnumMemberIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.EventIndex Field

ParserConstsEventIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int EventIndex
Public Const EventIndex As Integer
public:
literal int EventIndex
static val mutable EventIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.ExcludedCodeInternalName Field

ParserConstsExcludedCodeInternalName Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ExcludedCodeInternalName
Public Const ExcludedCodeInternalName As String
public:
literal String^ ExcludedCodeInternalName
static val mutable ExcludedCodeInternalName: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.ExtensionMethodName Field

ParserConstsExtensionMethodName Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ExtensionMethodName
Public Const ExtensionMethodName As String
public:
literal String^ ExtensionMethodName
static val mutable ExtensionMethodName: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.FieldIndex Field

ParserConstsFieldIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int FieldIndex
Public Const FieldIndex As Integer
public:
literal int FieldIndex
static val mutable FieldIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.InterfaceIndex Field

ParserConstsInterfaceIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int InterfaceIndex
Public Const InterfaceIndex As Integer
public:
literal int InterfaceIndex
static val mutable InterfaceIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.KeywordIndex Field

ParserConstsKeywordIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int KeywordIndex
Public Const KeywordIndex As Integer
public:
literal int KeywordIndex
static val mutable KeywordIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.LocalIndex Field

ParserConstsLocalIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int LocalIndex
Public Const LocalIndex As Integer
public:
literal int LocalIndex
static val mutable LocalIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.LookAheadLines Field

ParserConstsLookAheadLines Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int LookAheadLines
Public Shared LookAheadLines As Integer
public:
static int LookAheadLines
static val mutable LookAheadLines: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.LookAheadLinesAsync Field

ParserConstsLookAheadLinesAsync Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int LookAheadLinesAsync
Public Shared LookAheadLinesAsync As Integer
public:
static int LookAheadLinesAsync
static val mutable LookAheadLinesAsync: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.MaxDiagnosticCount Field

ParserConstsMaxDiagnosticCount Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MaxDiagnosticCount
Public Shared MaxDiagnosticCount As Integer
public:
static int MaxDiagnosticCount
static val mutable MaxDiagnosticCount: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.MethodIndex Field

ParserConstsMethodIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int MethodIndex
Public Const MethodIndex As Integer
public:
literal int MethodIndex
static val mutable MethodIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.MethodInternalName Field

ParserConstsMethodInternalName Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string MethodInternalName
Public Const MethodInternalName As String
public:
literal String^ MethodInternalName
static val mutable MethodInternalName: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.MethodName Field

ParserConstsMethodName Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string MethodName
Public Const MethodName As String
public:
literal String^ MethodName
static val mutable MethodName: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.NamespaceIndex Field

ParserConstsNamespaceIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int NamespaceIndex
Public Const NamespaceIndex As Integer
public:
literal int NamespaceIndex
static val mutable NamespaceIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.ProcessEmbeddedScriptDocuments Field

ParserConstsProcessEmbeddedScriptDocuments Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ProcessEmbeddedScriptDocuments
Public Shared ProcessEmbeddedScriptDocuments As Boolean
public:
static bool ProcessEmbeddedScriptDocuments
static val mutable ProcessEmbeddedScriptDocuments: bool

Field Value

Type: Boolean
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.PropertyIndex Field

ParserConstsPropertyIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int PropertyIndex
Public Const PropertyIndex As Integer
public:
literal int PropertyIndex
static val mutable PropertyIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.SnippetIndex Field

ParserConstsSnippetIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int SnippetIndex
Public Const SnippetIndex As Integer
public:
literal int SnippetIndex
static val mutable SnippetIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.StatementsGuideLines Field

ParserConstsStatementsGuideLines Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool StatementsGuideLines
Public Shared StatementsGuideLines As Boolean
public:
static bool StatementsGuideLines
static val mutable StatementsGuideLines: bool

Field Value

Type: Boolean
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.StaticSymbol Field

ParserConstsStaticSymbol Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string StaticSymbol
Public Const StaticSymbol As String
public:
literal String^ StaticSymbol
static val mutable StaticSymbol: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.StructIndex Field

ParserConstsStructIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int StructIndex
Public Const StructIndex As Integer
public:
literal int StructIndex
static val mutable StructIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.TypeIndex Field

ParserConstsTypeIndex Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const int TypeIndex
Public Const TypeIndex As Integer
public:
literal int TypeIndex
static val mutable TypeIndex: int

Field Value

Type: Int32
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.TypeInternalName Field

ParserConstsTypeInternalName Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeInternalName
Public Const TypeInternalName As String
public:
literal String^ TypeInternalName
static val mutable TypeInternalName: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.ValueModifier Field

ParserConstsValueModifier Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string ValueModifier
Public Const ValueModifier As String
public:
literal String^ ValueModifier
static val mutable ValueModifier: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.WarningsInternalName Field

ParserConstsWarningsInternalName Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string WarningsInternalName
Public Const WarningsInternalName As String
public:
literal String^ WarningsInternalName
static val mutable WarningsInternalName: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.XmlCommentStart Field

ParserConstsXmlCommentStart Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string XmlCommentStart
Public Const XmlCommentStart As String
public:
literal String^ XmlCommentStart
static val mutable XmlCommentStart: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.XmlComplexTag Field

ParserConstsXmlComplexTag Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XmlComplexTag
Public Shared XmlComplexTag As String
public:
static String^ XmlComplexTag
static val mutable XmlComplexTag: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.XmlEndTag Field

ParserConstsXmlEndTag Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XmlEndTag
Public Shared XmlEndTag As String
public:
static String^ XmlEndTag
static val mutable XmlEndTag: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.XmlParamsInternalName Field

ParserConstsXmlParamsInternalName Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string XmlParamsInternalName
Public Const XmlParamsInternalName As String
public:
literal String^ XmlParamsInternalName
static val mutable XmlParamsInternalName: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.XmlTag Field

ParserConstsXmlTag Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string XmlTag
Public Shared XmlTag As String
public:
static String^ XmlTag
static val mutable XmlTag: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts.XmlVbCommentStart Field

ParserConstsXmlVbCommentStart Field

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string XmlVbCommentStart
Public Const XmlVbCommentStart As String
public:
literal String^ XmlVbCommentStart
static val mutable XmlVbCommentStart: string

Field Value

Type: String
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


ParserConsts Methods

ParserConsts Methods

The ParserConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParserConsts Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser Class

RoslynParser Class
Represents properties and methods to perform syntax analysis of the text intended to use for Roslyn supported languages.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.RoslynRoslynParser
Alternet.Syntax.Parsers.RoslynCsParser
Alternet.Syntax.Parsers.RoslynVbParser

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoslynParser : SyntaxParser
Public Class RoslynParser
    Inherits SyntaxParser
public ref class RoslynParser : public SyntaxParser
type RoslynParser =
    class
        inherit SyntaxParser
    end

The RoslynParser type exposes the following members.

Constructors
 | Name | Description
Public method | RoslynParser | Initializes a new instance of the RoslynParser class with specified IRoslynSolution.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(String, Point).)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Overrides SyntaxParserFindImplementations(Point, IRangeList, Boolean).)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Overrides SyntaxParserFindReferences(Point).)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing.
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Overrides SyntaxParserGetActiveStatementAt(Point).)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Overrides SyntaxParserGetContentDividers(IListInt32).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Overrides SyntaxParserGetRangeAt(Point).)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Overrides SyntaxParserGetRangeAt(Point, IListIRange).)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Overrides SyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32).)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Overrides SyntaxParserGetSyntaxErrors(IListISyntaxError).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Overrides SyntaxParserLoadFile(String, Encoding).)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Overrides SyntaxParserOnTextChanged(ITextUndo).)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Overrides SyntaxParserOutline(IListIRange).)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document.
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Overrides SyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason).)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides SyntaxParserProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Overrides SyntaxParserProcessSnippetBody(String, Point, String).)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Overrides SyntaxParserReparseText(Boolean).)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Overrides SyntaxParserReparseText(Boolean, Int32, Int32).)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Overrides SyntaxParserResetParseInterval.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Overrides SyntaxParserShouldSerializeParseInterval.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Overrides SyntaxParserSmartFormat(Point, Boolean, Int32, ITextUndoList, String).)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Overrides SyntaxParserSmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList).)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Overrides SyntaxParserStartParsing(String, Int32, Int32).)
Public method | StopParsing | Aborts parsing process. (Overrides SyntaxParserStopParsing.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Overrides SyntaxParserSupportsAsyncParsing.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Overrides SyntaxParserSupportsTextChanges.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Overrides SyntaxParserFileName.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName |
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer |
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Overrides ParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics |
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser Constructor

RoslynParser Constructor
Initializes a new instance of the RoslynParser class with specified IRoslynSolution.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynParser(
    IRoslynSolution roslynSolution
)
Public Sub New (
    roslynSolution As IRoslynSolution
)
public:
RoslynParser(
    IRoslynSolution^ roslynSolution
)
new :
        roslynSolution : IRoslynSolution -> RoslynParser

Parameters

roslynSolution
Type: Alternet.Syntax.Parsers.RoslynIRoslynSolution
Specifies IRoslynSolution to this new instance.
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser Methods

RoslynParser Methods

The RoslynParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element.
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(String, Point).)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Overrides SyntaxParserFindImplementations(Point, IRangeList, Boolean).)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Overrides SyntaxParserFindReferences(Point).)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing.
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Overrides SyntaxParserGetActiveStatementAt(Point).)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Overrides SyntaxParserGetContentDividers(IListInt32).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Overrides SyntaxParserGetRangeAt(Point).)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Overrides SyntaxParserGetRangeAt(Point, IListIRange).)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Overrides SyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32).)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Overrides SyntaxParserGetSyntaxErrors(IListISyntaxError).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Overrides SyntaxParserLoadFile(String, Encoding).)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Overrides SyntaxParserOnTextChanged(ITextUndo).)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Overrides SyntaxParserOutline(IListIRange).)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document.
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Overrides SyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason).)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides SyntaxParserProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Overrides SyntaxParserProcessSnippetBody(String, Point, String).)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Overrides SyntaxParserReparseText(Boolean).)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Overrides SyntaxParserReparseText(Boolean, Int32, Int32).)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Overrides SyntaxParserResetParseInterval.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Overrides SyntaxParserShouldSerializeParseInterval.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Overrides SyntaxParserSmartFormat(Point, Boolean, Int32, ITextUndoList, String).)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Overrides SyntaxParserSmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList).)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Overrides SyntaxParserStartParsing(String, Int32, Int32).)
Public method | StopParsing | Aborts parsing process. (Overrides SyntaxParserStopParsing.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Overrides SyntaxParserSupportsAsyncParsing.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Overrides SyntaxParserSupportsTextChanges.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.CodeCompletion Method

RoslynParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.CodeCompletion Method (String, StringItemInfo[], Point, CodeCompletionArgs)

RoslynParserCodeCompletion Method (String, StringItemInfo, Point, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    CodeCompletionArgs e
)
Public Overrides Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    CodeCompletionArgs^ e
) override
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs)
See Also

Reference

RoslynParser Class
CodeCompletion Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.CreateRepository Method

RoslynParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.DoCodeCompletion Method

RoslynParserDoCodeCompletion Method
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void DoCodeCompletion(
    Point position,
    CodeCompletionArgs e,
    CancellationToken cancellationToken,
    bool async
)
Public Overridable Sub DoCodeCompletion (
    position As Point,
    e As CodeCompletionArgs,
    cancellationToken As CancellationToken,
    async As Boolean
)
public:
virtual void DoCodeCompletion(
    Point position,
    CodeCompletionArgs^ e,
    CancellationToken cancellationToken,
    bool async
)
abstract DoCodeCompletion :
        position : Point *
        e : CodeCompletionArgs *
        cancellationToken : CancellationToken *
        async : bool -> unit
override DoCodeCompletion :
        position : Point *
        e : CodeCompletionArgs *
        cancellationToken : CancellationToken *
        async : bool -> unit

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.
cancellationToken
Type: System.ThreadingCancellationToken
Represents a token handles cancellation operation.
async
Type: SystemBoolean
Specifies whether code completion request can be run asynchronously.
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.FindDeclaration Method

RoslynParserFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(String, Point).)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.FindDeclaration Method (Point)

RoslynParserFindDeclaration Method (Point)
Finds the declaration node at given position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override SymbolLocation FindDeclaration(
    Point position
)
Public Overrides Function FindDeclaration (
    position As Point
) As SymbolLocation
public:
virtual SymbolLocation^ FindDeclaration(
    Point position
) override
abstract FindDeclaration :
        position : Point -> SymbolLocation
override FindDeclaration :
        position : Point -> SymbolLocation

Parameters

position
Type: System.DrawingPoint
Specifies position to find node.

Return Value

Type: SymbolLocation

Implements

ISyntaxParserFindDeclaration(Point)
See Also

Reference

RoslynParser Class
FindDeclaration Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.FindDeclaration Method (String, Point)

RoslynParserFindDeclaration Method (String, Point)
Finds the declaration node at given position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Object FindDeclaration(
    string text,
    Point position
)
Public Overrides Function FindDeclaration (
    text As String,
    position As Point
) As Object
public:
virtual Object^ FindDeclaration(
    String^ text,
    Point position
) override
abstract FindDeclaration :
        text : string *
        position : Point -> Object
override FindDeclaration :
        text : string *
        position : Point -> Object

Parameters

text
Type: SystemString
Contains string used to perform search.
position
Type: System.DrawingPoint
Specifies position to find node.

Return Value

Type: Object
Microsoft.CodeAnalysis.ISymbol node representing declaration.

Implements

ISyntaxParserFindDeclaration(String, Point)
See Also

Reference

RoslynParser Class
FindDeclaration Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.FindImplementations Method

RoslynParserFindImplementations Method
Finds the symbols that implement an interface or interface member.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int FindImplementations(
    Point position,
    IRangeList references,
    bool allDocuments = true
)
Public Overrides Function FindImplementations (
    position As Point,
    references As IRangeList,
    Optional allDocuments As Boolean = true
) As Integer
public:
virtual int FindImplementations(
    Point position,
    IRangeList^ references,
    bool allDocuments = true
) override
abstract FindImplementations :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments true
*)
-> int
override FindImplementations :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments true
*)
-> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
List of found implementations.
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found implementations.

Implements

ISyntaxParserFindImplementations(Point, IRangeList, Boolean)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.FindReferences Method

RoslynParserFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Overrides SyntaxParserFindReferences(Point).)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.FindReferences Method (Point)

RoslynParserFindReferences Method (Point)
Locates and highlights references at given position in the text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FindReferences(
    Point position
)
Public Overrides Sub FindReferences (
    position As Point
)
public:
virtual void FindReferences(
    Point position
) override
abstract FindReferences :
        position : Point -> unit
override FindReferences :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Implements

ISyntaxParserFindReferences(Point)
See Also

Reference

RoslynParser Class
FindReferences Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.FindReferences Method (Point, IRangeList, Boolean)

RoslynParserFindReferences Method (Point, IRangeList, Boolean)
Locates declaration at given position and finds all references to this declaration in the text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int FindReferences(
    Point position,
    IRangeList references,
    bool allDocuments = false
)
Public Overrides Function FindReferences (
    position As Point,
    references As IRangeList,
    Optional allDocuments As Boolean = false
) As Integer
public:
virtual int FindReferences(
    Point position,
    IRangeList^ references,
    bool allDocuments = false
) override
abstract FindReferences :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int
override FindReferences :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
Retrieves references to found declaration.
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found references.

Implements

ISyntaxParserFindReferences(Point, IRangeList, Boolean)
See Also

Reference

RoslynParser Class
FindReferences Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ForceReparseText Method

RoslynParserForceReparseText Method
Force text reparsing.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ForceReparseText(
    bool withSemantic = true
)
Public Sub ForceReparseText (
    Optional withSemantic As Boolean = true
)
public:
void ForceReparseText(
    bool withSemantic = true
)
member ForceReparseText :
        ?withSemantic : bool
(* Defaults:
        let _withSemantic = defaultArg withSemantic true
*)
-> unit

Parameters

withSemantic (Optional)
Type: SystemBoolean
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetActiveStatementAt Method

RoslynParserGetActiveStatementAt Method
Gets IRange that corresponds to the statement at specified position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IRange GetActiveStatementAt(
    Point position
)
Public Overrides Function GetActiveStatementAt (
    position As Point
) As IRange
public:
virtual IRange^ GetActiveStatementAt(
    Point position
) override
abstract GetActiveStatementAt :
        position : Point -> IRange
override GetActiveStatementAt :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.

Return Value

Type: IRange
Statement range at given position

Implements

ISyntaxParserGetActiveStatementAt(Point)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetCompletionType Method

RoslynParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetCompletionType Method (Char)

RoslynParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

RoslynParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetContentDividers Method

RoslynParserGetContentDividers Method
Gets list of content dividers.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetContentDividers(
    IList<int> dividers
)
Public Overrides Function GetContentDividers (
    dividers As IList(Of Integer)
) As Integer
public:
virtual int GetContentDividers(
    IList<int>^ dividers
) override
abstract GetContentDividers :
        dividers : IList<int> -> int
override GetContentDividers :
        dividers : IList<int> -> int

Parameters

dividers
Type: System.Collections.GenericIListInt32

Return Value

Type: Int32

Implements

ISyntaxParserGetContentDividers(IListInt32)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetRangeAt Method

RoslynParserGetRangeAt Method
Overload List
 | Name | Description
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Overrides SyntaxParserGetRangeAt(Point).)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Overrides SyntaxParserGetRangeAt(Point, IListIRange).)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetRangeAt Method (Point)

RoslynParserGetRangeAt Method (Point)
Gets IRange that contains given position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IRange GetRangeAt(
    Point position
)
Public Overrides Function GetRangeAt (
    position As Point
) As IRange
public:
virtual IRange^ GetRangeAt(
    Point position
) override
abstract GetRangeAt :
        position : Point -> IRange
override GetRangeAt :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.

Return Value

Type: IRange
IRange at specified position.

Implements

ISyntaxParserGetRangeAt(Point)
See Also

Reference

RoslynParser Class
GetRangeAt Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetRangeAt Method (Point, IList(IRange))

RoslynParserGetRangeAt Method (Point, IListIRange)
Gets IRange that contains given position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IRange GetRangeAt(
    Point position,
    IList<IRange> ranges
)
Public Overrides Function GetRangeAt (
    position As Point,
    ranges As IList(Of IRange)
) As IRange
public:
virtual IRange^ GetRangeAt(
    Point position,
    IList<IRange^>^ ranges
) override
abstract GetRangeAt :
        position : Point *
        ranges : IList<IRange> -> IRange
override GetRangeAt :
        position : Point *
        ranges : IList<IRange> -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.
ranges
Type: System.Collections.GenericIListIRange

Return Value

Type: IRange
IRange at specified position.

Implements

ISyntaxParserGetRangeAt(Point, IListIRange)
See Also

Reference

RoslynParser Class
GetRangeAt Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetSmartIndentString Method

RoslynParserGetSmartIndentString Method
Returns indentation string for specified line.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
Public Overrides Function GetSmartIndentString (
    index As Integer,
    autoIndent As Boolean,
    useSpaces As Boolean,
    spacesInTab As Integer
) As String
public:
virtual String^ GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
) override
abstract GetSmartIndentString :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string
override GetSmartIndentString :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.

Return Value

Type: String
Indentation text at line specified by index.

Implements

ISyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetStructureGuideLines Method

RoslynParserGetStructureGuideLines Method
Gets list of guide lines.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetStructureGuideLines(
    IList<IRange> guideLines
)
Public Overrides Function GetStructureGuideLines (
    guideLines As IList(Of IRange)
) As Integer
public:
virtual int GetStructureGuideLines(
    IList<IRange^>^ guideLines
) override
abstract GetStructureGuideLines :
        guideLines : IList<IRange> -> int
override GetStructureGuideLines :
        guideLines : IList<IRange> -> int

Parameters

guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.

Implements

ISyntaxParserGetStructureGuideLines(IListIRange)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.GetSyntaxErrors Method

RoslynParserGetSyntaxErrors Method
Retrieves all syntax errors found while analyzing the text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetSyntaxErrors(
    IList<ISyntaxError> errors
)
Public Overrides Function GetSyntaxErrors (
    errors As IList(Of ISyntaxError)
) As Integer
public:
virtual int GetSyntaxErrors(
    IList<ISyntaxError^>^ errors
) override
abstract GetSyntaxErrors :
        errors : IList<ISyntaxError> -> int
override GetSyntaxErrors :
        errors : IList<ISyntaxError> -> int

Parameters

errors
Type: System.Collections.GenericIListISyntaxError
Retrieves a collection of syntax error.

Return Value

Type: Int32
Number of syntax errors that are found.

Implements

ISyntaxParserGetSyntaxErrors(IListISyntaxError)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.IsCodeCompletionChar Method

RoslynParserIsCodeCompletionChar Method

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Public Overrides Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
public:
virtual bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
) override
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool
override IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
style
Type: SystemByte
interval
Type: SystemInt32

Return Value

Type: Boolean

Implements

ISyntaxParserIsCodeCompletionChar(Char, Byte, Int32)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.LoadFile Method

RoslynParserLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Overrides SyntaxParserLoadFile(String, Encoding).)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.LoadFile Method (String, Encoding)

RoslynParserLoadFile Method (String, Encoding)
Loads the contents of the specified file with specified encoding.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Overrides Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
) override
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

RoslynParser Class
LoadFile Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.OnTextChanged Method

RoslynParserOnTextChanged Method
Responds to incremental change of the text in the editor.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void OnTextChanged(
    ITextUndo operation
)
Public Overrides Sub OnTextChanged (
    operation As ITextUndo
)
public:
virtual void OnTextChanged(
    ITextUndo^ operation
) override
abstract OnTextChanged :
        operation : ITextUndo -> unit
override OnTextChanged :
        operation : ITextUndo -> unit

Parameters

operation
Type: Alternet.SyntaxITextUndo

Implements

ISyntaxParserOnTextChanged(ITextUndo)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.Outline Method

RoslynParserOutline Method
Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int Outline(
    IList<IRange> ranges
)
Public Overrides Function Outline (
    ranges As IList(Of IRange)
) As Integer
public:
virtual int Outline(
    IList<IRange^>^ ranges
) override
abstract Outline :
        ranges : IList<IRange> -> int
override Outline :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Retrieves IOutlineRange collection for outlined sections.

Return Value

Type: Int32
Number of outlined sections.

Implements

ISyntaxParserOutline(IListIRange)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ParseSemanticAsync Method

RoslynParserParseSemanticAsync Method
Performs asynchronous semantic analysis of specified document.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task ParseSemanticAsync(
    Document document,
    CancellationToken cancellationToken
)
Public Overridable Function ParseSemanticAsync (
    document As Document,
    cancellationToken As CancellationToken
) As Task
public:
virtual Task^ ParseSemanticAsync(
    Document^ document,
    CancellationToken cancellationToken
)
abstract ParseSemanticAsync :
        document : Document *
        cancellationToken : CancellationToken -> Task
override ParseSemanticAsync :
        document : Document *
        cancellationToken : CancellationToken -> Task

Parameters

document
Type: Document
Document to be analyzed.
cancellationToken
Type: System.ThreadingCancellationToken
Represents a token handles cancellation operation.

Return Value

Type: Task
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ParseSyntaxAsync Method

RoslynParserParseSyntaxAsync Method
Performs asynchronous syntax analysis of specified document.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task ParseSyntaxAsync(
    Document document,
    int first,
    int last,
    CancellationToken cancellationToken
)
Public Overridable Function ParseSyntaxAsync (
    document As Document,
    first As Integer,
    last As Integer,
    cancellationToken As CancellationToken
) As Task
public:
virtual Task^ ParseSyntaxAsync(
    Document^ document,
    int first,
    int last,
    CancellationToken cancellationToken
)
abstract ParseSyntaxAsync :
        document : Document *
        first : int *
        last : int *
        cancellationToken : CancellationToken -> Task
override ParseSyntaxAsync :
        document : Document *
        first : int *
        last : int *
        cancellationToken : CancellationToken -> Task

Parameters

document
Type: Document
Document to be analyzed.
first
Type: SystemInt32
Specifies first changed line in the source text.
last
Type: SystemInt32
Specifies last changed line in the source text.
cancellationToken
Type: System.ThreadingCancellationToken
Represents a token handles cancellation operation.

Return Value

Type: Task
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ParseText Method

RoslynParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

RoslynParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

RoslynParser Class
ParseText Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.PositionChanged Method

RoslynParserPositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overrides Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
) override
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxParserPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.Prepare Method

RoslynParserPrepare Method
Overload List
 | Name | Description
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Overrides SyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason).)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.Prepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)

RoslynParserPrepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Prepare(
    string fileName,
    IStringList lines,
    ISyntaxTree syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason.None
)
Public Overrides Sub Prepare (
    fileName As String,
    lines As IStringList,
    syntaxTree As ISyntaxTree,
    useThread As Boolean,
    Optional reason As PrepareReason = PrepareReason.None
)
public:
virtual void Prepare(
    String^ fileName,
    IStringList^ lines,
    ISyntaxTree^ syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason::None
) override
abstract Prepare :
        fileName : string *
        lines : IStringList *
        syntaxTree : ISyntaxTree *
        useThread : bool *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit
override Prepare :
        fileName : string *
        lines : IStringList *
        syntaxTree : ISyntaxTree *
        useThread : bool *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit

Parameters

fileName
Type: SystemString
lines
Type: Alternet.SyntaxIStringList
syntaxTree
Type: Alternet.SyntaxISyntaxTree
useThread
Type: SystemBoolean
reason (Optional)
Type: Alternet.SyntaxPrepareReason

Implements

ISyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason)
See Also

Reference

RoslynParser Class
Prepare Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ProcessAutoComplete Method

RoslynParserProcessAutoComplete Method
Checks whether end-of-block code needs inserting.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ProcessAutoComplete(
    string text,
    Point position,
    out string code
)
Public Overrides Function ProcessAutoComplete (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessAutoComplete(
    String^ text,
    Point position,
    [OutAttribute] String^% code
) override
abstract ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if autocompletion of end-of-block needed; otherwise false.

Implements

ISyntaxParserProcessAutoComplete(String, Point, String)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ProcessSnippetBody Method

RoslynParserProcessSnippetBody Method
Checks whether snippet body code needs inserting.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ProcessSnippetBody(
    string text,
    Point position,
    out string code
)
Public Overrides Function ProcessSnippetBody (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessSnippetBody(
    String^ text,
    Point position,
    [OutAttribute] String^% code
) override
abstract ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if snippet body code needed; otherwise false.

Implements

ISyntaxParserProcessSnippetBody(String, Point, String)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ReparseText Method

RoslynParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Overrides SyntaxParserReparseText(Boolean).)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Overrides SyntaxParserReparseText(Boolean, Int32, Int32).)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ReparseText Method

RoslynParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

RoslynParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ReparseText Method (Boolean)

RoslynParserReparseText Method (Boolean)
Reparses entire text. Specifies whether parser should perform the task in the separate thread

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText(
    bool useThread
)
Public Overrides Sub ReparseText (
    useThread As Boolean
)
public:
virtual void ReparseText(
    bool useThread
) override
abstract ReparseText :
        useThread : bool -> unit
override ReparseText :
        useThread : bool -> unit

Parameters

useThread
Type: SystemBoolean

Implements

ISyntaxParserReparseText(Boolean)
See Also

Reference

RoslynParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ReparseText Method (Boolean, Int32, Int32)

RoslynParserReparseText Method (Boolean, Int32, Int32)
Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText(
    bool useThread,
    int first,
    int last
)
Public Overrides Sub ReparseText (
    useThread As Boolean,
    first As Integer,
    last As Integer
)
public:
virtual void ReparseText(
    bool useThread,
    int first,
    int last
) override
abstract ReparseText :
        useThread : bool *
        first : int *
        last : int -> unit
override ReparseText :
        useThread : bool *
        first : int *
        last : int -> unit

Parameters

useThread
Type: SystemBoolean
first
Type: SystemInt32
last
Type: SystemInt32

Implements

ISyntaxParserReparseText(Boolean, Int32, Int32)
See Also

Reference

RoslynParser Class
ReparseText Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ResetOptions Method

RoslynParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ResetParseInterval Method

RoslynParserResetParseInterval Method
Resets ParseInterval to the default value.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetParseInterval()
Public Overrides Sub ResetParseInterval
public:
virtual void ResetParseInterval() override
abstract ResetParseInterval : unit -> unit
override ResetParseInterval : unit -> unit

Implements

ISyntaxParserResetParseInterval
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ShouldSerializeOptions Method

RoslynParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ShouldSerializeParseInterval Method

RoslynParserShouldSerializeParseInterval Method
Indicates whether the ParseInterval property should be persisted.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeParseInterval()
Public Overrides Function ShouldSerializeParseInterval As Boolean
public:
virtual bool ShouldSerializeParseInterval() override
abstract ShouldSerializeParseInterval : unit -> bool
override ShouldSerializeParseInterval : unit -> bool

Return Value

Type: Boolean
True if ParseInterval differs from its default value; otherwise false.
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.SmartFormat Method

RoslynParserSmartFormat Method
Overload List
 | Name | Description
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Overrides SyntaxParserSmartFormat(Point, Boolean, Int32, ITextUndoList, String).)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Overrides SyntaxParserSmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList).)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.SmartFormat Method (Point, Boolean, Int32, ITextUndoList, String)

RoslynParserSmartFormat Method (Point, Boolean, Int32, ITextUndoList, String)
Formats block of text according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SmartFormat(
    ref Point pos,
    bool useSpaces,
    int spacesInTab,
    ITextUndoList operations,
    string key
)
Public Overrides Function SmartFormat (
    ByRef pos As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    operations As ITextUndoList,
    key As String
) As Boolean
public:
virtual bool SmartFormat(
    Point% pos,
    bool useSpaces,
    int spacesInTab,
    ITextUndoList^ operations,
    String^ key
) override
abstract SmartFormat :
        pos : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        operations : ITextUndoList *
        key : string -> bool
override SmartFormat :
        pos : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        operations : ITextUndoList *
        key : string -> bool

Parameters

pos
Type: System.DrawingPoint
Position of the text
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab
operations
Type: Alternet.SyntaxITextUndoList
List of the text changes.
key
Type: SystemString
Keystroke being typed.

Return Value

Type: Boolean

Implements

ISyntaxParserSmartFormat(Point, Boolean, Int32, ITextUndoList, String)
See Also

Reference

RoslynParser Class
SmartFormat Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.SmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)

RoslynParserSmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)
Formats block of text according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SmartFormat(
    ref Point start,
    ref Point end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList operations
)
Public Overrides Function SmartFormat (
    ByRef start As Point,
    ByRef end As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    extended As Boolean,
    operations As ITextUndoList
) As Boolean
public:
virtual bool SmartFormat(
    Point% start,
    Point% end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList^ operations
) override
abstract SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool
override SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool

Parameters

start
Type: System.DrawingPoint
Start position of the block
end
Type: System.DrawingPoint
End position of the block
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab
extended
Type: SystemBoolean
Specifies if whole syntax block containing start and end point should be formatted
operations
Type: Alternet.SyntaxITextUndoList
List of the text changes.

Return Value

Type: Boolean

Implements

ISyntaxParserSmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList)
See Also

Reference

RoslynParser Class
SmartFormat Overload
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.StartParsing Method

RoslynParserStartParsing Method
Prepares parser to parse the specified range of the text.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void StartParsing(
    string fileName,
    int first,
    int last
)
Public Overrides Sub StartParsing (
    fileName As String,
    first As Integer,
    last As Integer
)
public:
virtual void StartParsing(
    String^ fileName,
    int first,
    int last
) override
abstract StartParsing :
        fileName : string *
        first : int *
        last : int -> unit
override StartParsing :
        fileName : string *
        first : int *
        last : int -> unit

Parameters

fileName
Type: SystemString
Filename to parse
first
Type: SystemInt32
Specifies first changed line in the source text.
last
Type: SystemInt32
Specifies last changed line in the source text.

Implements

ISyntaxParserStartParsing(String, Int32, Int32)
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.StopParsing Method

RoslynParserStopParsing Method
Aborts parsing process.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void StopParsing()
Public Overrides Sub StopParsing
public:
virtual void StopParsing() override
abstract StopParsing : unit -> unit
override StopParsing : unit -> unit

Implements

ISyntaxParserStopParsing
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.SupportsAsyncParsing Method

RoslynParserSupportsAsyncParsing Method
Indicates whether parser supports async parsing.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SupportsAsyncParsing()
Public Overrides Function SupportsAsyncParsing As Boolean
public:
virtual bool SupportsAsyncParsing() override
abstract SupportsAsyncParsing : unit -> bool
override SupportsAsyncParsing : unit -> bool

Return Value

Type: Boolean

Implements

ISyntaxParserSupportsAsyncParsing
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.SupportsTextChanges Method

RoslynParserSupportsTextChanges Method
Indicates whether parser supports incremental text changes.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SupportsTextChanges()
Public Overrides Function SupportsTextChanges As Boolean
public:
virtual bool SupportsTextChanges() override
abstract SupportsTextChanges : unit -> bool
override SupportsTextChanges : unit -> bool

Return Value

Type: Boolean

Implements

ISyntaxParserSupportsTextChanges
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser Properties

RoslynParser Properties

The RoslynParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Overrides SyntaxParserFileName.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName |
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer |
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Overrides ParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics |
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.FileName Property

RoslynParserFileName Property

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string FileName { get; set; }
Public Overrides Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get () override;
    void set (String^ value) override;
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

ISyntaxParserFileName
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.ProjectName Property

RoslynParserProjectName Property

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectName { get; set; }
Public Property ProjectName As String
    Get
    Set
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}
member ProjectName : string with get, set

Property Value

Type: String
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.Repository Property

RoslynParserRepository Property
Gets an IRoslynRepository that holds methods for code completion purposes.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRoslynRepository Repository { get; }
Public ReadOnly Property Repository As IRoslynRepository
    Get
public:
property IRoslynRepository^ Repository {
    IRoslynRepository^ get ();
}
member Repository : IRoslynRepository with get

Property Value

Type: IRoslynRepository
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.SourceTextContainer Property

RoslynParserSourceTextContainer Property

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynTextContainer SourceTextContainer { get; set; }
Public Property SourceTextContainer As RoslynTextContainer
    Get
    Set
public:
property RoslynTextContainer^ SourceTextContainer {
    RoslynTextContainer^ get ();
    void set (RoslynTextContainer^ value);
}
member SourceTextContainer : RoslynTextContainer with get, set

Property Value

Type: RoslynTextContainer
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.Strings Property

RoslynParserStrings Property

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IStringList Strings { get; set; }
Public Overrides Property Strings As IStringList
    Get
    Set
public:
virtual property IStringList^ Strings {
    IStringList^ get () override;
    void set (IStringList^ value) override;
}
abstract Strings : IStringList with get, set
override Strings : IStringList with get, set

Property Value

Type: IStringList

Implements

IParserStrings
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser.SuppressedDiagnostics Property

RoslynParserSuppressedDiagnostics Property

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] SuppressedDiagnostics { get; set; }
Public Property SuppressedDiagnostics As String()
    Get
    Set
public:
property array<String^>^ SuppressedDiagnostics {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member SuppressedDiagnostics : string[] with get, set

Property Value

Type: String
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


RoslynParser Events

RoslynParser Events

The RoslynParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

RoslynParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser Class

VbParser Class
Represents class that and perform syntax and lexical analysis of specified Visual Basic.NET code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.RoslynRoslynParser
Alternet.Syntax.Parsers.RoslynVbParser
Alternet.Editor.RoslynCodeEditExtensionsVbScriptParser

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbParser : RoslynParser
Public Class VbParser
    Inherits RoslynParser
public ref class VbParser : public RoslynParser
type VbParser =
    class
        inherit RoslynParser
    end

The VbParser type exposes the following members.

Constructors
 | Name | Description
Public method | VbParser | Initializes a new instance of the VbParser class with default settings.
Public method | VbParser(IRoslynSolution) | Initializes a new instance of the VbParser class with specified IRoslynSolution.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides RoslynParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from RoslynParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from RoslynParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing. (Inherited from RoslynParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from RoslynParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides RoslynParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from RoslynParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from RoslynParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from RoslynParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from RoslynParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Inherited from RoslynParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from RoslynParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from RoslynParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from RoslynParser.)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from RoslynParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Inherited from RoslynParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from RoslynParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from RoslynParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from RoslynParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides RoslynParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from RoslynParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides RoslynParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from RoslynParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from RoslynParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from RoslynParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Overrides SyntaxParserSupportsContentDividers.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from RoslynParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from RoslynParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName | (Inherited from RoslynParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from RoslynParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer | (Inherited from RoslynParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from RoslynParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from RoslynParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn Namespace


VbParser Constructor

VbParser Constructor
Overload List
 | Name | Description
Public method | VbParser | Initializes a new instance of the VbParser class with default settings.
Public method | VbParser(IRoslynSolution) | Initializes a new instance of the VbParser class with specified IRoslynSolution.
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser Constructor

VbParser Constructor
Initializes a new instance of the VbParser class with default settings.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbParser()
Public Sub New
public:
VbParser()
new : unit -> VbParser
See Also

Reference

VbParser Class
VbParser Overload
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser Constructor (IRoslynSolution)

VbParser Constructor (IRoslynSolution)
Initializes a new instance of the VbParser class with specified IRoslynSolution.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbParser(
    IRoslynSolution roslynSolution
)
Public Sub New (
    roslynSolution As IRoslynSolution
)
public:
VbParser(
    IRoslynSolution^ roslynSolution
)
new :
        roslynSolution : IRoslynSolution -> VbParser

Parameters

roslynSolution
Type: Alternet.Syntax.Parsers.RoslynIRoslynSolution
Specifies IRoslynSolution to this new instance.
See Also

Reference

VbParser Class
VbParser Overload
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser Methods

VbParser Methods

The VbParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides RoslynParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | Performs code completion for the specified text representing language element. (Inherited from RoslynParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from RoslynParser.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from RoslynParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from RoslynParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | ForceReparseText | Force text reparsing. (Inherited from RoslynParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from RoslynParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides RoslynParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from RoslynParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from RoslynParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from RoslynParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from RoslynParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | (Inherited from RoslynParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from RoslynParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from RoslynParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from RoslynParser.)
Public method | ParseSemanticAsync | Performs asynchronous semantic analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseSyntaxAsync | Performs asynchronous syntax analysis of specified document. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from RoslynParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from RoslynParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | (Inherited from RoslynParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from RoslynParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from RoslynParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from RoslynParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides RoslynParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from RoslynParser.)
Public method | ResetSmartFormatChars | Resets the SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides RoslynParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from RoslynParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from RoslynParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from RoslynParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from RoslynParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Overrides SyntaxParserSupportsContentDividers.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from RoslynParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.CreateRepository Method

VbParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.GetCompletionType Method

VbParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides RoslynParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.GetCompletionType Method (Char)

VbParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

VbParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.GetSingleLineComment Method

VbParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.GetSingleLineComment Method

VbParserGetSingleLineComment Method
Gets the string that represents start symbol of single line comment.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String
Single line comment string.

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

VbParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.ResetAutoIndentChars Method

VbParserResetAutoIndentChars Method
Resets AutoIndentChars to the default value.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.ResetCodeCompletionChars Method

VbParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.ResetOptions Method

VbParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.ResetSmartFormatChars Method

VbParserResetSmartFormatChars Method
Resets the SmartFormatChars to the default value.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetSmartFormatChars()
Public Overrides Sub ResetSmartFormatChars
public:
virtual void ResetSmartFormatChars() override
abstract ResetSmartFormatChars : unit -> unit
override ResetSmartFormatChars : unit -> unit

Implements

ISyntaxParserResetSmartFormatChars
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.ShouldSerializeAutoIndentChars Method

VbParserShouldSerializeAutoIndentChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeAutoIndentChars()
Public Overrides Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars() override
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.ShouldSerializeCodeCompletionChars Method

VbParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.ShouldSerializeOptions Method

VbParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.ShouldSerializeSmartFormatChars Method

VbParserShouldSerializeSmartFormatChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeSmartFormatChars()
Public Overrides Function ShouldSerializeSmartFormatChars As Boolean
public:
virtual bool ShouldSerializeSmartFormatChars() override
abstract ShouldSerializeSmartFormatChars : unit -> bool
override ShouldSerializeSmartFormatChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser.SupportsContentDividers Method

VbParserSupportsContentDividers Method
Indicates whether content dividers are supported.

Namespace: Alternet.Syntax.Parsers.Roslyn
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SupportsContentDividers()
Public Overrides Function SupportsContentDividers As Boolean
public:
virtual bool SupportsContentDividers() override
abstract SupportsContentDividers : unit -> bool
override SupportsContentDividers : unit -> bool

Return Value

Type: Boolean
True if content dividers are supported; otherwise false.

Implements

ISyntaxParserSupportsContentDividers
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser Properties

VbParser Properties

The VbParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | (Inherited from RoslynParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | ProjectName | (Inherited from RoslynParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from RoslynParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | SourceTextContainer | (Inherited from RoslynParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from RoslynParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from RoslynParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


VbParser Events

VbParser Events

The VbParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

VbParser Class
Alternet.Syntax.Parsers.Roslyn Namespace


Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace
Classes
 | Class | Description
Public class | CsRepository | Represents properties and methods to perform code completion functionality intended to use for the C# language.
Public class | CsSolution | Represents properties and methods to service source code documents intended to use for C# language.
Public class | DocumentationComment | A documentation comment derived from either source text or metadata.
Public class | RoslynDocumentationProvider | Provide XML documentation to the compiler for members from metadata.
Public class | RoslynListMembers |
Public class | RoslynRepository | Represents properties and methods to perform code completion functionality intended to use for Roslyn supported languages.
Public class | RoslynSolution | Represents properties and methods to service source code documents intended to use for Roslyn supported languages.
Public class | VbRepository | Represents properties and methods to perform code completion functionality intended to use for the Visual Basic language.
Public class | VbSolution | Represents properties and methods to service source code documents intended to use for Visual Basic language.


CsRepository Class

CsRepository Class
Represents properties and methods to perform code completion functionality intended to use for the C# language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.Roslyn.CodeCompletionRoslynRepository
Alternet.Syntax.Parsers.Roslyn.CodeCompletionCsRepository

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CsRepository : RoslynRepository
Public Class CsRepository
    Inherits RoslynRepository
public ref class CsRepository : public RoslynRepository
type CsRepository =
    class
        inherit RoslynRepository
    end

The CsRepository type exposes the following members.

Constructors
 | Name | Description
Public method | CsRepository | Initializes a new instance of the CsRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | AddDocument(String, SourceText) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | AddDocument(String, String) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | AddFileReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | AddImageReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | AddReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | BeginUpdate | WPrevents object state updating until calling EndUpdate method. (Inherited from RoslynRepository.)
Public method | CloseDocument | Closes document which was opened in roslyn workspace. (Inherited from RoslynRepository.)
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Overrides RoslynRepositoryCodeCompletionAsync(Point, CodeCompletionArgs, CancellationToken).)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from RoslynRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from RoslynRepository.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from RoslynRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionService, Document, CompletionList, IListMembers, Int32) | (Inherited from RoslynRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillParameterInfo | (Inherited from RoslynRepository.)
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) | (Inherited from RoslynRepository.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynRepository.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | Locates all references to the symbol in the text. (Inherited from RoslynRepository.)
Public method | GetBreakpointStatementAtPosition | Gets breakpoint statement range at pecified position. (Inherited from RoslynRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from RoslynRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetDiagnostics | Get all the errors within the syntax tree associated with this object. (Inherited from RoslynRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetModel | Gets the semantic model and syntax tree for this document. (Inherited from RoslynRepository.)
Public method | GetNodeAt(Point) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified position. (Inherited from RoslynRepository.)
Public method | GetNodeAt(Int32) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified line. (Inherited from RoslynRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPosFromPosition | Converts given position into absolute text coordinate. (Inherited from RoslynRepository.)
Public method | GetPositionFromPos | Converts given pos into Point coordinate. (Inherited from RoslynRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynRepository.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynRepository.)
Public method | GetSmartIndent | Returns indentation string for specified line. (Inherited from RoslynRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment. (Overrides RoslynRepositoryGetXmlComment.)
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined. (Overrides RoslynRepositoryIsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan).)
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined. (Overrides RoslynRepositoryIsCollapsible(SyntaxNode, String, TextSpan, Boolean).)
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line. (Inherited from RoslynRepository.)
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node. (Overrides RoslynRepositoryIsStructureGuideNode(SyntaxNode, TextSpan).)
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynRepository.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Overrides RoslynRepositoryProcessSnippetBody(String, Point, String).)
Public method | RegisterAssemblies | Registers assemblies in the project. (Inherited from RoslynRepository.)
Public method | RegisterAssembly | Registers assembly in the project. (Inherited from RoslynRepository.)
Public method | RegisterCodeFiles | Makes types declared in given source files accessible for code completion. (Inherited from RoslynRepository.)
Public method | RegisterDefaultAssemblies | Registers default assemblies in the project. (Inherited from RoslynRepository.)
Public method | RegisterDefaultNamespaces | Registers default namespaces in the project. (Inherited from RoslynRepository.)
Public method | RegisterNamespaces | Registers global namespaces in the project. (Inherited from RoslynRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RemoveDocument | Removes document from document collection. (Inherited from RoslynRepository.)
Public method | RemoveDocument(DocumentId) | Removes current document from document collection. (Inherited from RoslynRepository.)
Public method | RemoveDocument(String) | Removes document from document collection. (Inherited from RoslynRepository.)
Public method | ReplaceDocument(DocumentId, SourceText) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | ReplaceDocument(DocumentId, String) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | SmartCapitalize | Capitalizes block of text. (Inherited from RoslynRepository.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynRepository.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project. (Inherited from RoslynRepository.)
Public method | UnregisterAssembly | Unregisters assembly from the project. (Inherited from RoslynRepository.)
Public method | UnregisterCodeFiles | Removes types declared in given source files from being accessible code completion. (Inherited from RoslynRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | Update | Updates an object state. (Inherited from RoslynRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a Microsoft.CodeAnalysis.Document contains code text. (Inherited from RoslynRepository.)
Public property | DocumentId | Represents a Microsoft.CodeAnalysis.DocumentId contains code text. (Inherited from RoslynRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from RoslynRepository.)
Public property | ImagesHighDpi | (Inherited from RoslynRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Model | Represents a Microsoft.CodeAnalysis.SemanticModel describes code text. (Inherited from RoslynRepository.)
Public property | ProjectId | Represents a Microsoft.CodeAnalysis.ProjectId that contains document. (Inherited from RoslynRepository.)
Public property | ProjectName | gets or sets Project name containing document (Inherited from RoslynRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | Solution | Gets RoslynSolution associated with this Repository. (Inherited from RoslynRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Text | Represents a Microsoft.CodeAnalysis.SourceText describes code text. (Inherited from RoslynRepository.)
Public property | Tree | Represents a Microsoft.CodeAnalysis.SyntaxTree represents parsed code text. (Inherited from RoslynRepository.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from RoslynRepository.)
Top
Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options. (Inherited from RoslynRepository.)
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository Constructor

CsRepository Constructor
Initializes a new instance of the CsRepository class with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsRepository(
    ISyntaxParser owner,
    IRoslynSolution roslynSolution,
    bool caseSensitive
)
Public Sub New (
    owner As ISyntaxParser,
    roslynSolution As IRoslynSolution,
    caseSensitive As Boolean
)
public:
CsRepository(
    ISyntaxParser^ owner,
    IRoslynSolution^ roslynSolution,
    bool caseSensitive
)
new :
        owner : ISyntaxParser *
        roslynSolution : IRoslynSolution *
        caseSensitive : bool -> CsRepository

Parameters

owner
Type: Alternet.SyntaxISyntaxParser
Specifies parser that owns this repository.
roslynSolution
Type: Alternet.Syntax.Parsers.RoslynIRoslynSolution
IRoslynSolution for this new instance.
caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
See Also

Reference

CsRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository Methods

CsRepository Methods

The CsRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddDocument(String, SourceText) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | AddDocument(String, String) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | AddFileReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | AddImageReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | AddReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | BeginUpdate | WPrevents object state updating until calling EndUpdate method. (Inherited from RoslynRepository.)
Public method | CloseDocument | Closes document which was opened in roslyn workspace. (Inherited from RoslynRepository.)
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Overrides RoslynRepositoryCodeCompletionAsync(Point, CodeCompletionArgs, CancellationToken).)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from RoslynRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from RoslynRepository.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from RoslynRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionService, Document, CompletionList, IListMembers, Int32) | (Inherited from RoslynRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillParameterInfo | (Inherited from RoslynRepository.)
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) | (Inherited from RoslynRepository.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynRepository.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | Locates all references to the symbol in the text. (Inherited from RoslynRepository.)
Public method | GetBreakpointStatementAtPosition | Gets breakpoint statement range at pecified position. (Inherited from RoslynRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from RoslynRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetDiagnostics | Get all the errors within the syntax tree associated with this object. (Inherited from RoslynRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetModel | Gets the semantic model and syntax tree for this document. (Inherited from RoslynRepository.)
Public method | GetNodeAt(Point) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified position. (Inherited from RoslynRepository.)
Public method | GetNodeAt(Int32) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified line. (Inherited from RoslynRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPosFromPosition | Converts given position into absolute text coordinate. (Inherited from RoslynRepository.)
Public method | GetPositionFromPos | Converts given pos into Point coordinate. (Inherited from RoslynRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynRepository.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynRepository.)
Public method | GetSmartIndent | Returns indentation string for specified line. (Inherited from RoslynRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment. (Overrides RoslynRepositoryGetXmlComment.)
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined. (Overrides RoslynRepositoryIsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan).)
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined. (Overrides RoslynRepositoryIsCollapsible(SyntaxNode, String, TextSpan, Boolean).)
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line. (Inherited from RoslynRepository.)
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node. (Overrides RoslynRepositoryIsStructureGuideNode(SyntaxNode, TextSpan).)
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from RoslynRepository.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Overrides RoslynRepositoryProcessSnippetBody(String, Point, String).)
Public method | RegisterAssemblies | Registers assemblies in the project. (Inherited from RoslynRepository.)
Public method | RegisterAssembly | Registers assembly in the project. (Inherited from RoslynRepository.)
Public method | RegisterCodeFiles | Makes types declared in given source files accessible for code completion. (Inherited from RoslynRepository.)
Public method | RegisterDefaultAssemblies | Registers default assemblies in the project. (Inherited from RoslynRepository.)
Public method | RegisterDefaultNamespaces | Registers default namespaces in the project. (Inherited from RoslynRepository.)
Public method | RegisterNamespaces | Registers global namespaces in the project. (Inherited from RoslynRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RemoveDocument | Removes document from document collection. (Inherited from RoslynRepository.)
Public method | RemoveDocument(DocumentId) | Removes current document from document collection. (Inherited from RoslynRepository.)
Public method | RemoveDocument(String) | Removes document from document collection. (Inherited from RoslynRepository.)
Public method | ReplaceDocument(DocumentId, SourceText) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | ReplaceDocument(DocumentId, String) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | SmartCapitalize | Capitalizes block of text. (Inherited from RoslynRepository.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynRepository.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project. (Inherited from RoslynRepository.)
Public method | UnregisterAssembly | Unregisters assembly from the project. (Inherited from RoslynRepository.)
Public method | UnregisterCodeFiles | Removes types declared in given source files from being accessible code completion. (Inherited from RoslynRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | Update | Updates an object state. (Inherited from RoslynRepository.)
Top
See Also

Reference

CsRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository.CodeCompletionAsync Method

CsRepositoryCodeCompletionAsync Method
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Task CodeCompletionAsync(
    Point position,
    CodeCompletionArgs e,
    CancellationToken ct
)
Public Overrides Function CodeCompletionAsync (
    position As Point,
    e As CodeCompletionArgs,
    ct As CancellationToken
) As Task
public:
virtual Task^ CodeCompletionAsync(
    Point position,
    CodeCompletionArgs^ e,
    CancellationToken ct
) override
abstract CodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs *
        ct : CancellationToken -> Task
override CodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs *
        ct : CancellationToken -> Task

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.
ct
Type: System.ThreadingCancellationToken

Return Value

Type: Task

Implements

IRoslynRepositoryCodeCompletionAsync(Point, CodeCompletionArgs, CancellationToken)
See Also

Reference

CsRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository.GetXmlComment Method

CsRepositoryGetXmlComment Method
Represents beginning of XML comment.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetXmlComment()
Public Overrides Function GetXmlComment As String
public:
virtual String^ GetXmlComment() override
abstract GetXmlComment : unit -> string
override GetXmlComment : unit -> string

Return Value

Type: String
String determines XML comment start.

Implements

IRoslynRepositoryGetXmlComment
See Also

Reference

CsRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository.IsCollapsible Method

CsRepositoryIsCollapsible Method
Overload List
 | Name | Description
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined. (Overrides RoslynRepositoryIsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan).)
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined. (Overrides RoslynRepositoryIsCollapsible(SyntaxNode, String, TextSpan, Boolean).)
Top
See Also

Reference

CsRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository.IsCollapsible Method (IEnumerable(SyntaxTrivia), String, TextSpan)

CsRepositoryIsCollapsible Method (IEnumerableSyntaxTrivia, String, TextSpan)
Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCollapsible(
    IEnumerable<SyntaxTrivia> triviaList,
    out string outlineText,
    out TextSpan span
)
Public Overrides Function IsCollapsible (
    triviaList As IEnumerable(Of SyntaxTrivia),
    <OutAttribute> ByRef outlineText As String,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
public:
virtual bool IsCollapsible(
    IEnumerable<SyntaxTrivia>^ triviaList,
    [OutAttribute] String^% outlineText,
    [OutAttribute] TextSpan% span
) override
abstract IsCollapsible :
        triviaList : IEnumerable<SyntaxTrivia> *
        outlineText : string byref *
        span : TextSpan byref -> bool
override IsCollapsible :
        triviaList : IEnumerable<SyntaxTrivia> *
        outlineText : string byref *
        span : TextSpan byref -> bool

Parameters

triviaList
Type: System.Collections.GenericIEnumerableSyntaxTrivia
Microsoft.CodeAnalysis.SyntaxTriviaList to check.
outlineText
Type: SystemString
Output parameter receives text substituting collapsed outline section.
span
Type: TextSpan
Output parameter receives outline range.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined; otherwise false.

Implements

IRoslynRepositoryIsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan)
See Also

Reference

CsRepository Class
IsCollapsible Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository.IsCollapsible Method (SyntaxNode, String, TextSpan, Boolean)

CsRepositoryIsCollapsible Method (SyntaxNode, String, TextSpan, Boolean)
Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCollapsible(
    SyntaxNode node,
    out string outlineText,
    out TextSpan span,
    bool checkStatements
)
Public Overrides Function IsCollapsible (
    node As SyntaxNode,
    <OutAttribute> ByRef outlineText As String,
    <OutAttribute> ByRef span As TextSpan,
    checkStatements As Boolean
) As Boolean
public:
virtual bool IsCollapsible(
    SyntaxNode^ node,
    [OutAttribute] String^% outlineText,
    [OutAttribute] TextSpan% span,
    bool checkStatements
) override
abstract IsCollapsible :
        node : SyntaxNode *
        outlineText : string byref *
        span : TextSpan byref *
        checkStatements : bool -> bool
override IsCollapsible :
        node : SyntaxNode *
        outlineText : string byref *
        span : TextSpan byref *
        checkStatements : bool -> bool

Parameters

node
Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode to check.
outlineText
Type: SystemString
Output parameter receives text substituting collapsed outline section.
span
Type: TextSpan
Output parameter receives outline range.
checkStatements
Type: SystemBoolean
Indicates whether statement node also should be processed.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxNode can be outlined; otherwise false.

Implements

IRoslynRepositoryIsCollapsible(SyntaxNode, String, TextSpan, Boolean)
See Also

Reference

CsRepository Class
IsCollapsible Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository.IsStructureGuideNode Method

CsRepositoryIsStructureGuideNode Method
Overload List
 | Name | Description
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node. (Overrides RoslynRepositoryIsStructureGuideNode(SyntaxNode, TextSpan).)
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

CsRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository.IsStructureGuideNode Method (SyntaxNode, TextSpan)

CsRepositoryIsStructureGuideNode Method (SyntaxNode, TextSpan)
Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsStructureGuideNode(
    SyntaxNode node,
    out TextSpan span
)
Public Overrides Function IsStructureGuideNode (
    node As SyntaxNode,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
public:
virtual bool IsStructureGuideNode(
    SyntaxNode^ node,
    [OutAttribute] TextSpan% span
) override
abstract IsStructureGuideNode :
        node : SyntaxNode *
        span : TextSpan byref -> bool
override IsStructureGuideNode :
        node : SyntaxNode *
        span : TextSpan byref -> bool

Parameters

node
Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode to check.
span
Type: TextSpan
Output parameter receives guide range.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxNode is guide node; otherwise false.

Implements

IRoslynRepositoryIsStructureGuideNode(SyntaxNode, TextSpan)
See Also

Reference

CsRepository Class
IsStructureGuideNode Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository.ProcessSnippetBody Method

CsRepositoryProcessSnippetBody Method
Checks whether snippet body code needs inserting.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ProcessSnippetBody(
    string text,
    Point position,
    out string code
)
Public Overrides Function ProcessSnippetBody (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessSnippetBody(
    String^ text,
    Point position,
    [OutAttribute] String^% code
) override
abstract ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if snippet body code needed; otherwise false.

Implements

IRoslynRepositoryProcessSnippetBody(String, Point, String)
See Also

Reference

CsRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository Properties

CsRepository Properties

The CsRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a Microsoft.CodeAnalysis.Document contains code text. (Inherited from RoslynRepository.)
Public property | DocumentId | Represents a Microsoft.CodeAnalysis.DocumentId contains code text. (Inherited from RoslynRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from RoslynRepository.)
Public property | ImagesHighDpi | (Inherited from RoslynRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Model | Represents a Microsoft.CodeAnalysis.SemanticModel describes code text. (Inherited from RoslynRepository.)
Public property | ProjectId | Represents a Microsoft.CodeAnalysis.ProjectId that contains document. (Inherited from RoslynRepository.)
Public property | ProjectName | gets or sets Project name containing document (Inherited from RoslynRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | Solution | Gets RoslynSolution associated with this Repository. (Inherited from RoslynRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Text | Represents a Microsoft.CodeAnalysis.SourceText describes code text. (Inherited from RoslynRepository.)
Public property | Tree | Represents a Microsoft.CodeAnalysis.SyntaxTree represents parsed code text. (Inherited from RoslynRepository.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from RoslynRepository.)
Top
See Also

Reference

CsRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsRepository Events

CsRepository Events

The CsRepository type exposes the following members.

Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options. (Inherited from RoslynRepository.)
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

CsRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsSolution Class

CsSolution Class
Represents properties and methods to service source code documents intended to use for C# language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Roslyn.CodeCompletionRoslynSolution
Alternet.Syntax.Parsers.Roslyn.CodeCompletionCsSolution

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CsSolution : RoslynSolution
Public Class CsSolution
    Inherits RoslynSolution
public ref class CsSolution : public RoslynSolution
type CsSolution =
    class
        inherit RoslynSolution
    end

The CsSolution type exposes the following members.

Constructors
 | Name | Description
Public method | CsSolution | Initializes a new instance of the CsSolution class with default settings.
Top
Methods
Name | Description
Public method AddDocument(String, SourceText, ProjectId, Boolean)
Adds a new document to the project.
(Inherited from RoslynSolution.)
Public method AddDocument(String, String, ProjectId, Boolean)
Adds a new document to the project.
(Inherited from RoslynSolution.)
Public method AddNotifier
Adds new handler to respond a notification.
(Inherited from RoslynSolution.)
Public method AddProject
Creates default project to this solution.
(Overrides RoslynSolutionAddProject(String, String).)
Public method AddReference
Adds metadata reference to the project
(Inherited from RoslynSolution.)
Public method BeginUpdate
Prevents object state updating until calling EndUpdate method.
(Inherited from RoslynSolution.)
Public method CloseDocument
When implemented by a class, closes specified document.
(Inherited from RoslynSolution.)
Public method CreateDefaultProject
Creates default project to this solution.
(Overrides RoslynSolutionCreateDefaultProject.)
Public method DisableUpdate
Prevents object state updating until calling EnableUpdate method.
(Inherited from RoslynSolution.)
Public method | Dispose | (Inherited from RoslynSolution.)
Public method DocumentBelongsToDefaultProject
Indicates if document belongs to the default project.
(Inherited from RoslynSolution.)
Public method EnableUpdate
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from RoslynSolution.)
Public method EndUpdate
Re-enables object state updating, that was turn of by calling BeginUpdate method.
(Inherited from RoslynSolution.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method FindDocument(String, ProjectId)
Gets Microsoft.CodeAnalysis.Document matches the given file path.
(Inherited from RoslynSolution.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetProject(ProjectId)
Gets or creates Project in the solution.
(Inherited from RoslynSolution.)
Public method GetProject(String)
Gets or creates Project in the solution.
(Inherited from RoslynSolution.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsDocumentOpen
Determines if document is already open in the workspace.
(Inherited from RoslynSolution.)
Public method Notify
Notifies all notifiers about updating object state.
(Inherited from RoslynSolution.)
Public method OpenDocument
Opens specified document if needed.
(Inherited from RoslynSolution.)
Public method RegisterAssemblies
Replaces assemblies in the project with new ones.
(Inherited from RoslynSolution.)
Public method RegisterAssembly
Registers assembly in the project.
(Inherited from RoslynSolution.)
Public method RegisterCodeFiles
Makes types declared in given source files accessible for code completion.
(Inherited from RoslynSolution.)
Public method RegisterNamespaces
Registers global namespaces.
(Inherited from RoslynSolution.)
Public method RegisterProjectReferences
When implemented by a class, replaces project references with the new ones.
(Inherited from RoslynSolution.)
Public method RemoveDocument(DocumentId)
Removes specified Microsoft.CodeAnalysis.Document from the project.
(Inherited from RoslynSolution.)
Public method RemoveDocument(String, ProjectId)
Removes specified document from the project.
(Inherited from RoslynSolution.)
Public method RemoveNotifier
Exclude specified handler from notification handlers list.
(Inherited from RoslynSolution.)
Public method RemoveProject
Removes project from the solution
(Inherited from RoslynSolution.)
Public method ReplaceCodeFile
Updates code completion with changes in source file.
(Inherited from RoslynSolution.)
Public method ReplaceDocument(DocumentId, SourceText)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
(Inherited from RoslynSolution.)
Public method ReplaceDocument(DocumentId, String)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
(Inherited from RoslynSolution.)
Public method ResolveAssemblyName
Try to find real assembly name matches the given name.
(Inherited from RoslynSolution.)
Public method | ResolveProjectId | (Inherited from RoslynSolution.)
Public method SetConditionalsForProject
Sets conditional compilation symbols for given project
(Inherited from RoslynSolution.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UnregisterAssemblies
Unregisters assemblies from the project.
(Inherited from RoslynSolution.)
Public method UnregisterAssembly
Unregisters assembly from the project.
(Inherited from RoslynSolution.)
Public method UnregisterCodeFiles
Removes types declared in given source files from being accessible code completion.
(Inherited from RoslynSolution.)
Public method UnregisterProjectReferences
When implemented by a class, unregisters assemblies from the project.
(Inherited from RoslynSolution.)
Public method Update
Updates an object state.
(Inherited from RoslynSolution.)
Public method WithDefaultAssemblies
Registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add reference to.

Return Value

Type:
IRoslynSolution instance with default assemblies being registered for code completion
(Inherited from RoslynSolution.)
Top
Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths. (Inherited from RoslynSolution.)
Public property | BaseDirectory | Gets or sets solution base directory. (Inherited from RoslynSolution.)
Public property | Conditionals | When implemented by a class, gets or sets a collection of conditional symbols (Inherited from RoslynSolution.)
Public property | CustomXMLDocPath | Gets a custom xml documentation path. (Inherited from RoslynSolution.)
 | DefaultScriptSolution | Gets a default script CsSolution object.
 | DefaultSolution | Gets a default CsSolution object.
Public property | FrameworkPath | Gets or sets path to the .NET Framework assemblies (Inherited from RoslynSolution.)
Public property | ProjectId | Gets a current Microsoft.CodeAnalysis.ProjectId. (Inherited from RoslynSolution.)
Public property | ScriptSearchPaths | Gets or sets a collection of script source search paths. (Inherited from RoslynSolution.)
Public property | Solution | Gets a current Microsoft.CodeAnalysis.Project. (Inherited from RoslynSolution.)
Public property | SourceKind | Gets kind (regular or script) of the source code. (Inherited from RoslynSolution.)
Public property | TargetFrameworkVersion | Gets or sets version of the .NET Framework to use with the methods in Framework Location Helper. (Inherited from RoslynSolution.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from RoslynSolution.)
Public property | Workspace | Gets a current project Microsoft.CodeAnalysis.Workspace. (Inherited from RoslynSolution.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsSolution Constructor

CsSolution Constructor
Initializes a new instance of the CsSolution class with default settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public CsSolution(
    SourceCodeKind sourceKind = SourceCodeKind.Regular,
    Type globalType = null
)
Public Sub New (
    Optional sourceKind As SourceCodeKind = SourceCodeKind.Regular,
    Optional globalType As Type = Nothing
)
public:
CsSolution(
    SourceCodeKind sourceKind = SourceCodeKind::Regular,
    Type^ globalType = nullptr
)
new :
        ?sourceKind : SourceCodeKind *
        ?globalType : Type
(* Defaults:
        let _sourceKind = defaultArg sourceKind SourceCodeKind.Regular
        let _globalType = defaultArg globalType null
*)
-> CsSolution

Parameters

sourceKind (Optional)
Type: SourceCodeKind
globalType (Optional)
Type: SystemType
See Also

Reference

CsSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsSolution Methods

CsSolution Methods

The CsSolution type exposes the following members.

Methods
Name | Description
Public method AddDocument(String, SourceText, ProjectId, Boolean)
Adds a new document to the project.
(Inherited from RoslynSolution.)
Public method AddDocument(String, String, ProjectId, Boolean)
Adds a new document to the project.
(Inherited from RoslynSolution.)
Public method AddNotifier
Adds new handler to respond a notification.
(Inherited from RoslynSolution.)
Public method AddProject
Creates default project to this solution.
(Overrides RoslynSolutionAddProject(String, String).)
Public method AddReference
Adds metadata reference to the project
(Inherited from RoslynSolution.)
Public method BeginUpdate
Prevents object state updating until calling EndUpdate method.
(Inherited from RoslynSolution.)
Public method CloseDocument
When implemented by a class, closes specified document.
(Inherited from RoslynSolution.)
Public method CreateDefaultProject
Creates default project to this solution.
(Overrides RoslynSolutionCreateDefaultProject.)
Public method DisableUpdate
Prevents object state updating until calling EnableUpdate method.
(Inherited from RoslynSolution.)
Public method | Dispose | (Inherited from RoslynSolution.)
Public method DocumentBelongsToDefaultProject
Indicates if document belongs to the default project.
(Inherited from RoslynSolution.)
Public method EnableUpdate
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from RoslynSolution.)
Public method EndUpdate
Re-enables object state updating, that was turn of by calling BeginUpdate method.
(Inherited from RoslynSolution.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method FindDocument(String, ProjectId)
Gets Microsoft.CodeAnalysis.Document matches the given file path.
(Inherited from RoslynSolution.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetProject(ProjectId)
Gets or creates Project in the solution.
(Inherited from RoslynSolution.)
Public method GetProject(String)
Gets or creates Project in the solution.
(Inherited from RoslynSolution.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsDocumentOpen
Determines if document is already open in the workspace.
(Inherited from RoslynSolution.)
Public method Notify
Notifies all notifiers about updating object state.
(Inherited from RoslynSolution.)
Public method OpenDocument
Opens specified document if needed.
(Inherited from RoslynSolution.)
Public method RegisterAssemblies
Replaces assemblies in the project with new ones.
(Inherited from RoslynSolution.)
Public method RegisterAssembly
Registers assembly in the project.
(Inherited from RoslynSolution.)
Public method RegisterCodeFiles
Makes types declared in given source files accessible for code completion.
(Inherited from RoslynSolution.)
Public method RegisterNamespaces
Registers global namespaces.
(Inherited from RoslynSolution.)
Public method RegisterProjectReferences
When implemented by a class, replaces project references with the new ones.
(Inherited from RoslynSolution.)
Public method RemoveDocument(DocumentId)
Removes specified Microsoft.CodeAnalysis.Document from the project.
(Inherited from RoslynSolution.)
Public method RemoveDocument(String, ProjectId)
Removes specified document from the project.
(Inherited from RoslynSolution.)
Public method RemoveNotifier
Exclude specified handler from notification handlers list.
(Inherited from RoslynSolution.)
Public method RemoveProject
Removes project from the solution
(Inherited from RoslynSolution.)
Public method ReplaceCodeFile
Updates code completion with changes in source file.
(Inherited from RoslynSolution.)
Public method ReplaceDocument(DocumentId, SourceText)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
(Inherited from RoslynSolution.)
Public method ReplaceDocument(DocumentId, String)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
(Inherited from RoslynSolution.)
Public method ResolveAssemblyName
Try to find real assembly name matches the given name.
(Inherited from RoslynSolution.)
Public method | ResolveProjectId | (Inherited from RoslynSolution.)
Public method SetConditionalsForProject
Sets conditional compilation symbols for given project
(Inherited from RoslynSolution.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UnregisterAssemblies
Unregisters assemblies from the project.
(Inherited from RoslynSolution.)
Public method UnregisterAssembly
Unregisters assembly from the project.
(Inherited from RoslynSolution.)
Public method UnregisterCodeFiles
Removes types declared in given source files from being accessible code completion.
(Inherited from RoslynSolution.)
Public method UnregisterProjectReferences
When implemented by a class, unregisters assemblies from the project.
(Inherited from RoslynSolution.)
Public method Update
Updates an object state.
(Inherited from RoslynSolution.)
Public method WithDefaultAssemblies
Registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add reference to.

Return Value

Type:
IRoslynSolution instance with default assemblies being registered for code completion
(Inherited from RoslynSolution.)
Top
See Also

Reference

CsSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsSolution.AddProject Method

CsSolutionAddProject Method
Creates default project to this solution.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ProjectId AddProject(
    string projectName,
    string projectPath
)
Public Overrides Function AddProject (
    projectName As String,
    projectPath As String
) As ProjectId
public:
virtual ProjectId^ AddProject(
    String^ projectName,
    String^ projectPath
) override
abstract AddProject :
        projectName : string *
        projectPath : string -> ProjectId
override AddProject :
        projectName : string *
        projectPath : string -> ProjectId

Parameters

projectName
Type: SystemString
Name of newly created project.
projectPath
Type: SystemString
Path of newly created project.

Return Value

Type: ProjectId
Microsoft.CodeAnalysis.ProjectId that is created.

Implements

IRoslynSolutionAddProject(String, String)
See Also

Reference

CsSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsSolution.CreateDefaultProject Method

CsSolutionCreateDefaultProject Method
Creates default project to this solution.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ProjectId CreateDefaultProject()
Public Overrides Function CreateDefaultProject As ProjectId
public:
virtual ProjectId^ CreateDefaultProject() override
abstract CreateDefaultProject : unit -> ProjectId
override CreateDefaultProject : unit -> ProjectId

Return Value

Type: ProjectId
Microsoft.CodeAnalysis.ProjectId of a project that is created.

Implements

IRoslynSolutionCreateDefaultProject
See Also

Reference

CsSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsSolution Properties

CsSolution Properties

The CsSolution type exposes the following members.

Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths. (Inherited from RoslynSolution.)
Public property | BaseDirectory | Gets or sets solution base directory. (Inherited from RoslynSolution.)
Public property | Conditionals | When implemented by a class, gets or sets a collection of conditional symbols (Inherited from RoslynSolution.)
Public property | CustomXMLDocPath | Gets a custom xml documentation path. (Inherited from RoslynSolution.)
 | DefaultScriptSolution | Gets a default script CsSolution object.
 | DefaultSolution | Gets a default CsSolution object.
Public property | FrameworkPath | Gets or sets path to the .NET Framework assemblies (Inherited from RoslynSolution.)
Public property | ProjectId | Gets a current Microsoft.CodeAnalysis.ProjectId. (Inherited from RoslynSolution.)
Public property | ScriptSearchPaths | Gets or sets a collection of script source search paths. (Inherited from RoslynSolution.)
Public property | Solution | Gets a current Microsoft.CodeAnalysis.Project. (Inherited from RoslynSolution.)
Public property | SourceKind | Gets kind (regular or script) of the source code. (Inherited from RoslynSolution.)
Public property | TargetFrameworkVersion | Gets or sets version of the .NET Framework to use with the methods in Framework Location Helper. (Inherited from RoslynSolution.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from RoslynSolution.)
Public property | Workspace | Gets a current project Microsoft.CodeAnalysis.Workspace. (Inherited from RoslynSolution.)
Top
See Also

Reference

CsSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsSolution.DefaultScriptSolution Property

CsSolutionDefaultScriptSolution Property
Gets a default script CsSolution object.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CsSolution DefaultScriptSolution { get; }
Public Shared ReadOnly Property DefaultScriptSolution As CsSolution
    Get
public:
static property CsSolution^ DefaultScriptSolution {
    CsSolution^ get ();
}
static member DefaultScriptSolution : CsSolution with get

Property Value

Type: CsSolution
See Also

Reference

CsSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


CsSolution.DefaultSolution Property

CsSolutionDefaultSolution Property
Gets a default CsSolution object.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CsSolution DefaultSolution { get; }
Public Shared ReadOnly Property DefaultSolution As CsSolution
    Get
public:
static property CsSolution^ DefaultSolution {
    CsSolution^ get ();
}
static member DefaultSolution : CsSolution with get

Property Value

Type: CsSolution
See Also

Reference

CsSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment Class

DocumentationComment Class
A documentation comment derived from either source text or metadata.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Roslyn.CodeCompletionDocumentationComment

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DocumentationComment
Public NotInheritable Class DocumentationComment
public ref class DocumentationComment sealed
[<SealedAttribute>]
type DocumentationComment =  class end

The DocumentationComment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromXmlFragment | Parses and constructs a DocumentationComment from the given fragment of XML.
Public method | GetExceptionTexts | Returns the texts for a given exception, or an empty ImmutableArray if no documentation was given for the exception.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParameterText | Returns the text for a given parameter, or null if no documentation was given for the parameter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeParameterText | Returns the text for a given type parameter, or null if no documentation was given for the type parameter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Empty | An empty comment.
Top
Properties
 | Name | Description
Public property | ExampleText | The text in the <example> tag. Null if no tag existed.
Public property | ExceptionTypes | The types of items in <exception> tags.
Public property | FullXmlFragment | The full XML text of this tag.
Public property | HadXmlParseError | True if an error occurred when parsing.
Public property | ParameterNames | The names of items in <param> tags.
Public property | RemarksText | The text in the <remarks> tag. Null if no tag existed.
Public property | ReturnsText | The text in the <returns> tag. Null if no tag existed.
Public property | SummaryText | The text in the <summary> tag. Null if no tag existed.
Public property | TypeParameterNames | The names of items in <typeparam> tags.
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment Fields

DocumentationComment Fields

The DocumentationComment type exposes the following members.

Fields
Name | Description
Empty | An empty comment.
Top
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.Empty Field

DocumentationCommentEmpty Field
An empty comment.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly DocumentationComment Empty
Public Shared ReadOnly Empty As DocumentationComment
public:
static initonly DocumentationComment^ Empty
static val Empty: DocumentationComment

Field Value

Type: DocumentationComment
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment Methods

DocumentationComment Methods

The DocumentationComment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromXmlFragment | Parses and constructs a DocumentationComment from the given fragment of XML.
Public method | GetExceptionTexts | Returns the texts for a given exception, or an empty ImmutableArray if no documentation was given for the exception.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParameterText | Returns the text for a given parameter, or null if no documentation was given for the parameter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeParameterText | Returns the text for a given type parameter, or null if no documentation was given for the type parameter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.FromXmlFragment Method

DocumentationCommentFromXmlFragment Method
Parses and constructs a DocumentationComment from the given fragment of XML.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DocumentationComment FromXmlFragment(
    string xml
)
Public Shared Function FromXmlFragment (
    xml As String
) As DocumentationComment
public:
static DocumentationComment^ FromXmlFragment(
    String^ xml
)
static member FromXmlFragment :
        xml : string -> DocumentationComment

Parameters

xml
Type: SystemString
The fragment of XML to parse.

Return Value

Type: DocumentationComment
A DocumentationComment instance.
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.GetExceptionTexts Method

DocumentationCommentGetExceptionTexts Method
Returns the texts for a given exception, or an empty ImmutableArray if no documentation was given for the exception.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImmutableArray<string> GetExceptionTexts(
    string exceptionName
)
Public Function GetExceptionTexts (
    exceptionName As String
) As ImmutableArray(Of String)
public:
ImmutableArray<String^> GetExceptionTexts(
    String^ exceptionName
)
member GetExceptionTexts :
        exceptionName : string -> ImmutableArray<string>

Parameters

exceptionName
Type: SystemString

Return Value

Type: ImmutableArrayString
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.GetParameterText Method

DocumentationCommentGetParameterText Method
Returns the text for a given parameter, or null if no documentation was given for the parameter.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetParameterText(
    string parameterName
)
Public Function GetParameterText (
    parameterName As String
) As String
public:
String^ GetParameterText(
    String^ parameterName
)
member GetParameterText :
        parameterName : string -> string

Parameters

parameterName
Type: SystemString

Return Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.GetTypeParameterText Method

DocumentationCommentGetTypeParameterText Method
Returns the text for a given type parameter, or null if no documentation was given for the type parameter.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetTypeParameterText(
    string typeParameterName
)
Public Function GetTypeParameterText (
    typeParameterName As String
) As String
public:
String^ GetTypeParameterText(
    String^ typeParameterName
)
member GetTypeParameterText :
        typeParameterName : string -> string

Parameters

typeParameterName
Type: SystemString

Return Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment Properties

DocumentationComment Properties

The DocumentationComment type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | The text in the <example> tag. Null if no tag existed.
Public property | ExceptionTypes | The types of items in <exception> tags.
Public property | FullXmlFragment | The full XML text of this tag.
Public property | HadXmlParseError | True if an error occurred when parsing.
Public property | ParameterNames | The names of items in <param> tags.
Public property | RemarksText | The text in the <remarks> tag. Null if no tag existed.
Public property | ReturnsText | The text in the <returns> tag. Null if no tag existed.
Public property | SummaryText | The text in the <summary> tag. Null if no tag existed.
Public property | TypeParameterNames | The names of items in <typeparam> tags.
Top
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.ExampleText Property

DocumentationCommentExampleText Property
The text in the <example> tag. Null if no tag existed.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get
public:
property String^ ExampleText {
    String^ get ();
}
member ExampleText : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.ExceptionTypes Property

DocumentationCommentExceptionTypes Property
The types of items in <exception> tags.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImmutableArray<string> ExceptionTypes { get; }
Public ReadOnly Property ExceptionTypes As ImmutableArray(Of String)
    Get
public:
property ImmutableArray<String^> ExceptionTypes {
    ImmutableArray<String^> get ();
}
member ExceptionTypes : ImmutableArray<string> with get

Property Value

Type: ImmutableArrayString
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.FullXmlFragment Property

DocumentationCommentFullXmlFragment Property
The full XML text of this tag.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullXmlFragment { get; }
Public ReadOnly Property FullXmlFragment As String
    Get
public:
property String^ FullXmlFragment {
    String^ get ();
}
member FullXmlFragment : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.HadXmlParseError Property

DocumentationCommentHadXmlParseError Property
True if an error occurred when parsing.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HadXmlParseError { get; }
Public ReadOnly Property HadXmlParseError As Boolean
    Get
public:
property bool HadXmlParseError {
    bool get ();
}
member HadXmlParseError : bool with get

Property Value

Type: Boolean
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.ParameterNames Property

DocumentationCommentParameterNames Property
The names of items in <param> tags.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImmutableArray<string> ParameterNames { get; }
Public ReadOnly Property ParameterNames As ImmutableArray(Of String)
    Get
public:
property ImmutableArray<String^> ParameterNames {
    ImmutableArray<String^> get ();
}
member ParameterNames : ImmutableArray<string> with get

Property Value

Type: ImmutableArrayString
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.RemarksText Property

DocumentationCommentRemarksText Property
The text in the <remarks> tag. Null if no tag existed.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RemarksText { get; }
Public ReadOnly Property RemarksText As String
    Get
public:
property String^ RemarksText {
    String^ get ();
}
member RemarksText : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.ReturnsText Property

DocumentationCommentReturnsText Property
The text in the <returns> tag. Null if no tag existed.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReturnsText { get; }
Public ReadOnly Property ReturnsText As String
    Get
public:
property String^ ReturnsText {
    String^ get ();
}
member ReturnsText : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.SummaryText Property

DocumentationCommentSummaryText Property
The text in the <summary> tag. Null if no tag existed.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SummaryText { get; }
Public ReadOnly Property SummaryText As String
    Get
public:
property String^ SummaryText {
    String^ get ();
}
member SummaryText : string with get

Property Value

Type: String
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


DocumentationComment.TypeParameterNames Property

DocumentationCommentTypeParameterNames Property
The names of items in <typeparam> tags.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImmutableArray<string> TypeParameterNames { get; }
Public ReadOnly Property TypeParameterNames As ImmutableArray(Of String)
    Get
public:
property ImmutableArray<String^> TypeParameterNames {
    ImmutableArray<String^> get ();
}
member TypeParameterNames : ImmutableArray<string> with get

Property Value

Type: ImmutableArrayString
See Also

Reference

DocumentationComment Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider Class

RoslynDocumentationProvider Class
Provide XML documentation to the compiler for members from metadata.
Inheritance Hierarchy
SystemObject
DocumentationProvider
Alternet.Syntax.Parsers.Roslyn.CodeCompletionRoslynDocumentationProvider

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoslynDocumentationProvider : DocumentationProvider
Public Class RoslynDocumentationProvider
    Inherits DocumentationProvider
public ref class RoslynDocumentationProvider : public DocumentationProvider
type RoslynDocumentationProvider =
    class
        inherit DocumentationProvider
    end

The RoslynDocumentationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | RoslynDocumentationProvider | Initializes a new instance of the RoslynDocumentationProvider class with specified settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Overrides DocumentationProvider.Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides DocumentationProvider.GetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AssemblyName | Gets an assembly name.
Public property | CustomXMLDocPath | Gets a custom xml documentation path.
Public property | FullPath | Gets a full documentation path.
Public property | SystemPath | Gets a system path.
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider Constructor

RoslynDocumentationProvider Constructor
Initializes a new instance of the RoslynDocumentationProvider class with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynDocumentationProvider(
    string systemPath,
    string fullPath,
    string assemblyName,
    string customXMLDocPath
)
Public Sub New (
    systemPath As String,
    fullPath As String,
    assemblyName As String,
    customXMLDocPath As String
)
public:
RoslynDocumentationProvider(
    String^ systemPath,
    String^ fullPath,
    String^ assemblyName,
    String^ customXMLDocPath
)
new :
        systemPath : string *
        fullPath : string *
        assemblyName : string *
        customXMLDocPath : string -> RoslynDocumentationProvider

Parameters

systemPath
Type: SystemString
Path to the system folder.
fullPath
Type: SystemString
Full documentation path.
assemblyName
Type: SystemString
Assembly name.
customXMLDocPath
Type: SystemString
Custom documentation path name.
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider Methods

RoslynDocumentationProvider Methods

The RoslynDocumentationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Overrides DocumentationProvider.Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides DocumentationProvider.GetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider.Equals Method

RoslynDocumentationProviderEquals Method
Determines whether the specified object is equal to the current object.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider.GetHashCode Method

RoslynDocumentationProviderGetHashCode Method
Serves as a hash function for a particular type.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider Properties

RoslynDocumentationProvider Properties

The RoslynDocumentationProvider type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an assembly name.
Public property | CustomXMLDocPath | Gets a custom xml documentation path.
Public property | FullPath | Gets a full documentation path.
Public property | SystemPath | Gets a system path.
Top
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider.AssemblyName Property

RoslynDocumentationProviderAssemblyName Property
Gets an assembly name.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyName { get; }
Public ReadOnly Property AssemblyName As String
    Get
public:
property String^ AssemblyName {
    String^ get ();
}
member AssemblyName : string with get

Property Value

Type: String
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider.CustomXMLDocPath Property

RoslynDocumentationProviderCustomXMLDocPath Property
Gets a custom xml documentation path.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CustomXMLDocPath { get; }
Public ReadOnly Property CustomXMLDocPath As String
    Get
public:
property String^ CustomXMLDocPath {
    String^ get ();
}
member CustomXMLDocPath : string with get

Property Value

Type: String
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider.FullPath Property

RoslynDocumentationProviderFullPath Property
Gets a full documentation path.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get
public:
property String^ FullPath {
    String^ get ();
}
member FullPath : string with get

Property Value

Type: String
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynDocumentationProvider.SystemPath Property

RoslynDocumentationProviderSystemPath Property
Gets a system path.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemPath { get; }
Public ReadOnly Property SystemPath As String
    Get
public:
property String^ SystemPath {
    String^ get ();
}
member SystemPath : string with get

Property Value

Type: String
See Also

Reference

RoslynDocumentationProvider Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynListMembers Class

RoslynListMembers Class
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.Parsers.Roslyn.CodeCompletionRoslynListMembers

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoslynListMembers : ListMembers
Public Class RoslynListMembers
    Inherits ListMembers
public ref class RoslynListMembers : public ListMembers
type RoslynListMembers =
    class
        inherit ListMembers
    end

The RoslynListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | RoslynListMembers | Initializes a new instance of the RoslynListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | (Overrides CodeCompletionProviderNeedSort.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynListMembers Constructor

RoslynListMembers Constructor
Initializes a new instance of the RoslynListMembers class

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynListMembers()
Public Sub New
public:
RoslynListMembers()
new : unit -> RoslynListMembers
See Also

Reference

RoslynListMembers Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynListMembers Methods

RoslynListMembers Methods

The RoslynListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

RoslynListMembers Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynListMembers Properties

RoslynListMembers Properties

The RoslynListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | (Overrides CodeCompletionProviderNeedSort.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

RoslynListMembers Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynListMembers.NeedSort Property

RoslynListMembersNeedSort Property

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool NeedSort { get; }
Public Overrides ReadOnly Property NeedSort As Boolean
    Get
public:
virtual property bool NeedSort {
    bool get () override;
}
abstract NeedSort : bool with get
override NeedSort : bool with get

Property Value

Type: Boolean

Implements

ICodeCompletionProviderNeedSort
See Also

Reference

RoslynListMembers Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynListMembers Events

RoslynListMembers Events

The RoslynListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

RoslynListMembers Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository Class

RoslynRepository Class
Represents properties and methods to perform code completion functionality intended to use for Roslyn supported languages.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.Roslyn.CodeCompletionRoslynRepository
Alternet.Syntax.Parsers.Roslyn.CodeCompletionCsRepository
Alternet.Syntax.Parsers.Roslyn.CodeCompletionVbRepository

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoslynRepository : CodeCompletionRepository,
    IRoslynRepository, ICodeCompletionRepository, IDisposable, IUpdate
Public Class RoslynRepository
    Inherits CodeCompletionRepository
    Implements IRoslynRepository, ICodeCompletionRepository, IDisposable, IUpdate
public ref class RoslynRepository : public CodeCompletionRepository,
    IRoslynRepository, ICodeCompletionRepository, IDisposable, IUpdate
type RoslynRepository =
    class
        inherit CodeCompletionRepository
        interface IRoslynRepository
        interface ICodeCompletionRepository
        interface IDisposable
        interface IUpdate
    end

The RoslynRepository type exposes the following members.

Constructors
 | Name | Description
Public method | RoslynRepository | Initializes a new instance of the RoslynRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | AddDocument(String, SourceText) | Adds a new document or replaces existing document with specified settings.
Public method | AddDocument(String, String) | Adds a new document or replaces existing document with specified settings.
Public method | AddFileReference | Adds metadata reference to the project
Public method | AddImageReference | Adds metadata reference to the project
Public method | AddReference | Adds metadata reference to the project
Public method | BeginUpdate | WPrevents object state updating until calling EndUpdate method.
Public method | CloseDocument | Closes document which was opened in roslyn workspace.
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionService, Document, CompletionList, IListMembers, Int32) |
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillParameterInfo |
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) |
Public method | FindImplementations | Finds the symbols that implement an interface or interface member.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | Locates all references to the symbol in the text.
Public method | GetBreakpointStatementAtPosition | Gets breakpoint statement range at pecified position.
Public method | GetCodeSnippets | Returns code snippets for the given language. (Overrides CodeCompletionRepositoryGetCodeSnippets(String).)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetDiagnostics | Get all the errors within the syntax tree associated with this object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetModel | Gets the semantic model and syntax tree for this document.
Public method | GetNodeAt(Point) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified position.
Public method | GetNodeAt(Int32) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified line.
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPosFromPosition | Converts given position into absolute text coordinate.
Public method | GetPositionFromPos | Converts given pos into Point coordinate.
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position.
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position.
Public method | GetSmartIndent | Returns indentation string for specified line.
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment.
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line.
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting.
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting.
Public method | RegisterAssemblies | Registers assemblies in the project.
Public method | RegisterAssembly | Registers assembly in the project.
Public method | RegisterCodeFiles | Makes types declared in given source files accessible for code completion.
Public method | RegisterDefaultAssemblies | Registers default assemblies in the project.
Public method | RegisterDefaultNamespaces | Registers default namespaces in the project.
Public method | RegisterNamespaces | Registers global namespaces in the project.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RemoveDocument | Removes document from document collection.
Public method | RemoveDocument(DocumentId) | Removes current document from document collection.
Public method | RemoveDocument(String) | Removes document from document collection.
Public method | ReplaceDocument(DocumentId, SourceText) | Adds a new document or replaces existing document with specified settings.
Public method | ReplaceDocument(DocumentId, String) | Adds a new document or replaces existing document with specified settings.
Public method | SmartCapitalize | Capitalizes block of text.
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | Formats block of text according to the parser rules.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project.
Public method | UnregisterAssembly | Unregisters assembly from the project.
Public method | UnregisterCodeFiles | Removes types declared in given source files from being accessible code completion.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | Update | Updates an object state.
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a Microsoft.CodeAnalysis.Document contains code text.
Public property | DocumentId | Represents a Microsoft.CodeAnalysis.DocumentId contains code text.
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Model | Represents a Microsoft.CodeAnalysis.SemanticModel describes code text.
Public property | ProjectId | Represents a Microsoft.CodeAnalysis.ProjectId that contains document.
Public property | ProjectName | gets or sets Project name containing document
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | Solution | Gets RoslynSolution associated with this Repository.
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Text | Represents a Microsoft.CodeAnalysis.SourceText describes code text.
Public property | Tree | Represents a Microsoft.CodeAnalysis.SyntaxTree represents parsed code text.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options.
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository Constructor

RoslynRepository Constructor
Initializes a new instance of the RoslynRepository class with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynRepository(
    ISyntaxParser owner,
    IRoslynSolution roslynSolution,
    bool caseSensitive
)
Public Sub New (
    owner As ISyntaxParser,
    roslynSolution As IRoslynSolution,
    caseSensitive As Boolean
)
public:
RoslynRepository(
    ISyntaxParser^ owner,
    IRoslynSolution^ roslynSolution,
    bool caseSensitive
)
new :
        owner : ISyntaxParser *
        roslynSolution : IRoslynSolution *
        caseSensitive : bool -> RoslynRepository

Parameters

owner
Type: Alternet.SyntaxISyntaxParser
Specifies parser that owns this repository.
roslynSolution
Type: Alternet.Syntax.Parsers.RoslynIRoslynSolution
IRoslynSolution for this new instance.
caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository Methods

RoslynRepository Methods

The RoslynRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddDocument(String, SourceText) | Adds a new document or replaces existing document with specified settings.
Public method | AddDocument(String, String) | Adds a new document or replaces existing document with specified settings.
Public method | AddFileReference | Adds metadata reference to the project
Public method | AddImageReference | Adds metadata reference to the project
Public method | AddReference | Adds metadata reference to the project
Public method | BeginUpdate | WPrevents object state updating until calling EndUpdate method.
Public method | CloseDocument | Closes document which was opened in roslyn workspace.
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element.
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionService, Document, CompletionList, IListMembers, Int32) |
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillParameterInfo |
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) |
Public method | FindImplementations | Finds the symbols that implement an interface or interface member.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | Locates all references to the symbol in the text.
Public method | GetBreakpointStatementAtPosition | Gets breakpoint statement range at pecified position.
Public method | GetCodeSnippets | Returns code snippets for the given language. (Overrides CodeCompletionRepositoryGetCodeSnippets(String).)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetDiagnostics | Get all the errors within the syntax tree associated with this object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetModel | Gets the semantic model and syntax tree for this document.
Public method | GetNodeAt(Point) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified position.
Public method | GetNodeAt(Int32) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified line.
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPosFromPosition | Converts given position into absolute text coordinate.
Public method | GetPositionFromPos | Converts given pos into Point coordinate.
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position.
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position.
Public method | GetSmartIndent | Returns indentation string for specified line.
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment.
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.
Public method | IsContentDivider | Gets boolean value indicating whether text content is divided at given line.
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting.
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting.
Public method | RegisterAssemblies | Registers assemblies in the project.
Public method | RegisterAssembly | Registers assembly in the project.
Public method | RegisterCodeFiles | Makes types declared in given source files accessible for code completion.
Public method | RegisterDefaultAssemblies | Registers default assemblies in the project.
Public method | RegisterDefaultNamespaces | Registers default namespaces in the project.
Public method | RegisterNamespaces | Registers global namespaces in the project.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RemoveDocument | Removes document from document collection.
Public method | RemoveDocument(DocumentId) | Removes current document from document collection.
Public method | RemoveDocument(String) | Removes document from document collection.
Public method | ReplaceDocument(DocumentId, SourceText) | Adds a new document or replaces existing document with specified settings.
Public method | ReplaceDocument(DocumentId, String) | Adds a new document or replaces existing document with specified settings.
Public method | SmartCapitalize | Capitalizes block of text.
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | Formats block of text according to the parser rules.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project.
Public method | UnregisterAssembly | Unregisters assembly from the project.
Public method | UnregisterCodeFiles | Removes types declared in given source files from being accessible code completion.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | Update | Updates an object state.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.AddDocument Method

RoslynRepositoryAddDocument Method
Overload List
 | Name | Description
Public method | AddDocument(String, SourceText) | Adds a new document or replaces existing document with specified settings.
Public method | AddDocument(String, String) | Adds a new document or replaces existing document with specified settings.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.AddDocument Method (String, SourceText)

RoslynRepositoryAddDocument Method (String, SourceText)
Adds a new document or replaces existing document with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DocumentId AddDocument(
    string fileName,
    SourceText text
)
Public Overridable Function AddDocument (
    fileName As String,
    text As SourceText
) As DocumentId
public:
virtual DocumentId^ AddDocument(
    String^ fileName,
    SourceText^ text
)
abstract AddDocument :
        fileName : string *
        text : SourceText -> DocumentId
override AddDocument :
        fileName : string *
        text : SourceText -> DocumentId

Parameters

fileName
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.
text
Type: SourceText
New Microsoft.CodeAnalysis.Text.SourceText text.

Return Value

Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to be added.

Implements

IRoslynRepositoryAddDocument(String, SourceText)
See Also

Reference

RoslynRepository Class
AddDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.AddDocument Method (String, String)

RoslynRepositoryAddDocument Method (String, String)
Adds a new document or replaces existing document with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DocumentId AddDocument(
    string fileName,
    string text
)
Public Overridable Function AddDocument (
    fileName As String,
    text As String
) As DocumentId
public:
virtual DocumentId^ AddDocument(
    String^ fileName,
    String^ text
)
abstract AddDocument :
        fileName : string *
        text : string -> DocumentId
override AddDocument :
        fileName : string *
        text : string -> DocumentId

Parameters

fileName
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.
text
Type: SystemString
New Microsoft.CodeAnalysis.Document text.

Return Value

Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to be added.

Implements

IRoslynRepositoryAddDocument(String, String)
See Also

Reference

RoslynRepository Class
AddDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.AddFileReference Method

RoslynRepositoryAddFileReference Method
Adds metadata reference to the project

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddFileReference(
    string assemblyLocation
)
Public Overridable Sub AddFileReference (
    assemblyLocation As String
)
public:
virtual void AddFileReference(
    String^ assemblyLocation
)
abstract AddFileReference :
        assemblyLocation : string -> unit
override AddFileReference :
        assemblyLocation : string -> unit

Parameters

assemblyLocation
Type: SystemString
Location of assembly to add.

Implements

IRoslynRepositoryAddFileReference(String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.AddImageReference Method

RoslynRepositoryAddImageReference Method
Adds metadata reference to the project

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddImageReference(
    byte[] assemblyImage
)
Public Overridable Sub AddImageReference (
    assemblyImage As Byte()
)
public:
virtual void AddImageReference(
    array<unsigned char>^ assemblyImage
)
abstract AddImageReference :
        assemblyImage : byte[] -> unit
override AddImageReference :
        assemblyImage : byte[] -> unit

Parameters

assemblyImage
Type: SystemByte
Assembly image to add.

Implements

IRoslynRepositoryAddImageReference(Byte)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.AddReference Method

RoslynRepositoryAddReference Method
Adds metadata reference to the project

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddReference(
    MetadataReference reference
)
Public Overridable Sub AddReference (
    reference As MetadataReference
)
public:
virtual void AddReference(
    MetadataReference^ reference
)
abstract AddReference :
        reference : MetadataReference -> unit
override AddReference :
        reference : MetadataReference -> unit

Parameters

reference
Type: MetadataReference
Reference to add.

Implements

IRoslynRepositoryAddReference(MetadataReference)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.BeginUpdate Method

RoslynRepositoryBeginUpdate Method
WPrevents object state updating until calling EndUpdate method.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.CloseDocument Method

RoslynRepositoryCloseDocument Method
Closes document which was opened in roslyn workspace.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CloseDocument()
Public Function CloseDocument As Boolean
public:
virtual bool CloseDocument() sealed
abstract CloseDocument : unit -> bool
override CloseDocument : unit -> bool

Return Value

Type: Boolean
True if current document was removed; otherwise false

Implements

IRoslynRepositoryCloseDocument
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.CodeCompletionAsync Method

RoslynRepositoryCodeCompletionAsync Method
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task CodeCompletionAsync(
    Point position,
    CodeCompletionArgs e,
    CancellationToken ct
)
Public Overridable Function CodeCompletionAsync (
    position As Point,
    e As CodeCompletionArgs,
    ct As CancellationToken
) As Task
public:
virtual Task^ CodeCompletionAsync(
    Point position,
    CodeCompletionArgs^ e,
    CancellationToken ct
)
abstract CodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs *
        ct : CancellationToken -> Task
override CodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs *
        ct : CancellationToken -> Task

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.
ct
Type: System.ThreadingCancellationToken

Return Value

Type: Task

Implements

IRoslynRepositoryCodeCompletionAsync(Point, CodeCompletionArgs, CancellationToken)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.DisableUpdate Method

RoslynRepositoryDisableUpdate Method
Prevents object state updating until calling EnableUpdate method.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DisableUpdate()
Public Function DisableUpdate As Integer
public:
virtual int DisableUpdate() sealed
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.EnableUpdate Method

RoslynRepositoryEnableUpdate Method
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EnableUpdate()
Public Function EnableUpdate As Integer
public:
virtual int EnableUpdate() sealed
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.EndUpdate Method

RoslynRepositoryEndUpdate Method
Re-enables object state updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.FillMembers Method

RoslynRepositoryFillMembers Method
Overload List
 | Name | Description
Public method | FillMembers(CompletionService, Document, CompletionList, IListMembers, Int32) |
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.FillMembers Method (CompletionService, Document, CompletionList, IListMembers, Int32)

RoslynRepositoryFillMembers Method (CompletionService, Document, CompletionList, IListMembers, Int32)

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FillMembers(
    CompletionService service,
    Document document,
    CompletionList data,
    IListMembers members,
    out int selectedIndex
)
Public Sub FillMembers (
    service As CompletionService,
    document As Document,
    data As CompletionList,
    members As IListMembers,
    <OutAttribute> ByRef selectedIndex As Integer
)
public:
void FillMembers(
    CompletionService^ service,
    Document^ document,
    CompletionList^ data,
    IListMembers^ members,
    [OutAttribute] int% selectedIndex
)
member FillMembers :
        service : CompletionService *
        document : Document *
        data : CompletionList *
        members : IListMembers *
        selectedIndex : int byref -> unit

Parameters

service
Type: CompletionService
document
Type: Document
data
Type: CompletionList
members
Type: Alternet.Syntax.CodeCompletionIListMembers
selectedIndex
Type: SystemInt32
See Also

Reference

RoslynRepository Class
FillMembers Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.FillParameterInfo Method

RoslynRepositoryFillParameterInfo Method

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FillParameterInfo(
    ISignatureHelpItems helpItems,
    IListMembers members
)
Public Sub FillParameterInfo (
    helpItems As ISignatureHelpItems,
    members As IListMembers
)
public:
void FillParameterInfo(
    ISignatureHelpItems^ helpItems,
    IListMembers^ members
)
member FillParameterInfo :
        helpItems : ISignatureHelpItems *
        members : IListMembers -> unit

Parameters

helpItems
Type: ISignatureHelpItems
members
Type: Alternet.Syntax.CodeCompletionIListMembers
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.FindDeclaration Method

RoslynRepositoryFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) |
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.FindDeclaration Method (SemanticModel, Point, Boolean)

RoslynRepositoryFindDeclaration Method (SemanticModel, Point, Boolean)

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ISymbol FindDeclaration(
    SemanticModel model,
    Point position,
    bool includeCandidates = true
)
Public Overridable Function FindDeclaration (
    model As SemanticModel,
    position As Point,
    Optional includeCandidates As Boolean = true
) As ISymbol
public:
virtual ISymbol^ FindDeclaration(
    SemanticModel^ model,
    Point position,
    bool includeCandidates = true
)
abstract FindDeclaration :
        model : SemanticModel *
        position : Point *
        ?includeCandidates : bool
(* Defaults:
        let _includeCandidates = defaultArg includeCandidates true
*)
-> ISymbol
override FindDeclaration :
        model : SemanticModel *
        position : Point *
        ?includeCandidates : bool
(* Defaults:
        let _includeCandidates = defaultArg includeCandidates true
*)
-> ISymbol

Parameters

model
Type: SemanticModel
position
Type: System.DrawingPoint
includeCandidates (Optional)
Type: SystemBoolean

Return Value

Type: ISymbol

Implements

IRoslynRepositoryFindDeclaration(SemanticModel, Point, Boolean)
See Also

Reference

RoslynRepository Class
FindDeclaration Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.FindImplementations Method

RoslynRepositoryFindImplementations Method
Finds the symbols that implement an interface or interface member.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<IEnumerable<ISymbol>> FindImplementations(
    ISymbol symbol,
    CancellationToken cancellationToken
)
Public Overridable Function FindImplementations (
    symbol As ISymbol,
    cancellationToken As CancellationToken
) As Task(Of IEnumerable(Of ISymbol))
public:
virtual Task<IEnumerable<ISymbol^>^>^ FindImplementations(
    ISymbol^ symbol,
    CancellationToken cancellationToken
)
abstract FindImplementations :
        symbol : ISymbol *
        cancellationToken : CancellationToken -> Task<IEnumerable<ISymbol>>
override FindImplementations :
        symbol : ISymbol *
        cancellationToken : CancellationToken -> Task<IEnumerable<ISymbol>>

Parameters

symbol
Type: ISymbol
Specifies Microsoft.CodeAnalysis.ISymbol to find implementations.
cancellationToken
Type: System.ThreadingCancellationToken
Cancellation token

Return Value

Type: TaskIEnumerableISymbol
Implementations to symbol.

Implements

IRoslynRepositoryFindImplementations(ISymbol, CancellationToken)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.FindReferences Method

RoslynRepositoryFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | Locates all references to the symbol in the text.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.FindReferences Method (ISymbol, CancellationToken, Boolean)

RoslynRepositoryFindReferences Method (ISymbol, CancellationToken, Boolean)
Locates all references to the symbol in the text.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task<IEnumerable<ReferencedSymbol>> FindReferences(
    ISymbol symbol,
    CancellationToken cancellationToken,
    bool allDocuments = false
)
Public Overridable Function FindReferences (
    symbol As ISymbol,
    cancellationToken As CancellationToken,
    Optional allDocuments As Boolean = false
) As Task(Of IEnumerable(Of ReferencedSymbol))
public:
virtual Task<IEnumerable<ReferencedSymbol^>^>^ FindReferences(
    ISymbol^ symbol,
    CancellationToken cancellationToken,
    bool allDocuments = false
)
abstract FindReferences :
        symbol : ISymbol *
        cancellationToken : CancellationToken *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> Task<IEnumerable<ReferencedSymbol>>
override FindReferences :
        symbol : ISymbol *
        cancellationToken : CancellationToken *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> Task<IEnumerable<ReferencedSymbol>>

Parameters

symbol
Type: ISymbol
Specifies Microsoft.CodeAnalysis.ISymbol to find references.
cancellationToken
Type: System.ThreadingCancellationToken
Cancellation token
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: TaskIEnumerableReferencedSymbol
References to node.

Implements

IRoslynRepositoryFindReferences(ISymbol, CancellationToken, Boolean)
See Also

Reference

RoslynRepository Class
FindReferences Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetBreakpointStatementAtPosition Method

RoslynRepositoryGetBreakpointStatementAtPosition Method
Gets breakpoint statement range at pecified position.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange GetBreakpointStatementAtPosition(
    Point position
)
Public Overridable Function GetBreakpointStatementAtPosition (
    position As Point
) As IRange
public:
virtual IRange^ GetBreakpointStatementAtPosition(
    Point position
)
abstract GetBreakpointStatementAtPosition :
        position : Point -> IRange
override GetBreakpointStatementAtPosition :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
The position to check.

Return Value

Type: IRange
IRange of the found breakpoint.

Implements

IRoslynRepositoryGetBreakpointStatementAtPosition(Point)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetCodeSnippets Method

RoslynRepositoryGetCodeSnippets Method
Returns code snippets for the given language.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeSnippetsProvider GetCodeSnippets(
    string language
)
Public Overrides Function GetCodeSnippets (
    language As String
) As ICodeSnippetsProvider
public:
virtual ICodeSnippetsProvider^ GetCodeSnippets(
    String^ language
) override
abstract GetCodeSnippets :
        language : string -> ICodeSnippetsProvider
override GetCodeSnippets :
        language : string -> ICodeSnippetsProvider

Parameters

language
Type: SystemString
Represents a language.

Return Value

Type: ICodeSnippetsProvider
ICodeCompletionProvider instance for a given language.

Implements

ICodeCompletionRepositoryGetCodeSnippets(String)
ICodeCompletionRepositoryGetCodeSnippets(String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetDiagnostics Method

RoslynRepositoryGetDiagnostics Method
Get all the errors within the syntax tree associated with this object.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Diagnostic> GetDiagnostics()
Public Function GetDiagnostics As IEnumerable(Of Diagnostic)
public:
virtual IEnumerable<Diagnostic^>^ GetDiagnostics() sealed
abstract GetDiagnostics : unit -> IEnumerable<Diagnostic>
override GetDiagnostics : unit -> IEnumerable<Diagnostic>

Return Value

Type: IEnumerableDiagnostic
List of Microsoft.CodeAnalysis.Diagnostic errors.

Implements

IRoslynRepositoryGetDiagnostics
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetModel Method

RoslynRepositoryGetModel Method
Gets the semantic model and syntax tree for this document.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool GetModel(
    out SemanticModel model,
    out SyntaxTree tree
)
Public Overridable Function GetModel (
    <OutAttribute> ByRef model As SemanticModel,
    <OutAttribute> ByRef tree As SyntaxTree
) As Boolean
public:
virtual bool GetModel(
    [OutAttribute] SemanticModel^% model,
    [OutAttribute] SyntaxTree^% tree
)
abstract GetModel :
        model : SemanticModel byref *
        tree : SyntaxTree byref -> bool
override GetModel :
        model : SemanticModel byref *
        tree : SyntaxTree byref -> bool

Parameters

model
Type: SemanticModel
Output parameter receives Microsoft.CodeAnalysis.SemanticModel object.
tree
Type: SyntaxTree
Output parameter receives Microsoft.CodeAnalysis.SyntaxTree object.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IRoslynRepositoryGetModel(SemanticModel, SyntaxTree)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetNodeAt Method

RoslynRepositoryGetNodeAt Method
Overload List
 | Name | Description
Public method | GetNodeAt(Point) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified position.
Public method | GetNodeAt(Int32) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified line.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetNodeAt Method (Point)

RoslynRepositoryGetNodeAt Method (Point)
Gets Microsoft.CodeAnalysis.SyntaxNode at specified position.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SyntaxNode GetNodeAt(
    Point position
)
Public Overridable Function GetNodeAt (
    position As Point
) As SyntaxNode
public:
virtual SyntaxNode^ GetNodeAt(
    Point position
)
abstract GetNodeAt :
        position : Point -> SyntaxNode
override GetNodeAt :
        position : Point -> SyntaxNode

Parameters

position
Type: System.DrawingPoint
Position to find node.

Return Value

Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode at specified line.
See Also

Reference

RoslynRepository Class
GetNodeAt Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetNodeAt Method (Int32)

RoslynRepositoryGetNodeAt Method (Int32)
Gets Microsoft.CodeAnalysis.SyntaxNode at specified line.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SyntaxNode GetNodeAt(
    int line
)
Public Overridable Function GetNodeAt (
    line As Integer
) As SyntaxNode
public:
virtual SyntaxNode^ GetNodeAt(
    int line
)
abstract GetNodeAt :
        line : int -> SyntaxNode
override GetNodeAt :
        line : int -> SyntaxNode

Parameters

line
Type: SystemInt32
Line to find node.

Return Value

Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode at specified line.
See Also

Reference

RoslynRepository Class
GetNodeAt Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetPosFromPosition Method

RoslynRepositoryGetPosFromPosition Method
Converts given position into absolute text coordinate.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPosFromPosition(
    SourceText text,
    Point position
)
Public Overridable Function GetPosFromPosition (
    text As SourceText,
    position As Point
) As Integer
public:
virtual int GetPosFromPosition(
    SourceText^ text,
    Point position
)
abstract GetPosFromPosition :
        text : SourceText *
        position : Point -> int
override GetPosFromPosition :
        text : SourceText *
        position : Point -> int

Parameters

text
Type: SourceText
SourceText to process.
position
Type: System.DrawingPoint
Point to convert.

Return Value

Type: Int32
Absolute position.

Implements

IRoslynRepositoryGetPosFromPosition(SourceText, Point)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetPositionFromPos Method

RoslynRepositoryGetPositionFromPos Method
Converts given pos into Point coordinate.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point GetPositionFromPos(
    SourceText text,
    int pos
)
Public Overridable Function GetPositionFromPos (
    text As SourceText,
    pos As Integer
) As Point
public:
virtual Point GetPositionFromPos(
    SourceText^ text,
    int pos
)
abstract GetPositionFromPos :
        text : SourceText *
        pos : int -> Point
override GetPositionFromPos :
        text : SourceText *
        pos : int -> Point

Parameters

text
Type: SourceText
SourceText to process.
pos
Type: SystemInt32
Absolute position to convert.

Return Value

Type: Point
Point coordinate.

Implements

IRoslynRepositoryGetPositionFromPos(SourceText, Int32)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetRangeAt Method

RoslynRepositoryGetRangeAt Method
Overload List
 | Name | Description
Public method | GetRangeAt(Point) | Gets IRange that contains given position.
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetRangeAt Method (Point)

RoslynRepositoryGetRangeAt Method (Point)
Gets IRange that contains given position.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange GetRangeAt(
    Point position
)
Public Overridable Function GetRangeAt (
    position As Point
) As IRange
public:
virtual IRange^ GetRangeAt(
    Point position
)
abstract GetRangeAt :
        position : Point -> IRange
override GetRangeAt :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.

Return Value

Type: IRange
IRange at specified position.

Implements

IRoslynRepositoryGetRangeAt(Point)
See Also

Reference

RoslynRepository Class
GetRangeAt Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetRangeAt Method (Point, IList(IRange))

RoslynRepositoryGetRangeAt Method (Point, IListIRange)
Gets IRange that contains given position.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRange GetRangeAt(
    Point position,
    IList<IRange> ranges
)
Public Overridable Function GetRangeAt (
    position As Point,
    ranges As IList(Of IRange)
) As IRange
public:
virtual IRange^ GetRangeAt(
    Point position,
    IList<IRange^>^ ranges
)
abstract GetRangeAt :
        position : Point *
        ranges : IList<IRange> -> IRange
override GetRangeAt :
        position : Point *
        ranges : IList<IRange> -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.
ranges
Type: System.Collections.GenericIListIRange
List of begin/end blocks at the given position.

Return Value

Type: IRange
IRange at specified position.

Implements

IRoslynRepositoryGetRangeAt(Point, IListIRange)
See Also

Reference

RoslynRepository Class
GetRangeAt Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetSmartIndent Method

RoslynRepositoryGetSmartIndent Method
Returns indentation string for specified line.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetSmartIndent(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
Public Overridable Function GetSmartIndent (
    index As Integer,
    autoIndent As Boolean,
    useSpaces As Boolean,
    spacesInTab As Integer
) As String
public:
virtual String^ GetSmartIndent(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
abstract GetSmartIndent :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string
override GetSmartIndent :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.

Return Value

Type: String
Indentation text at line specified by index.

Implements

IRoslynRepositoryGetSmartIndent(Int32, Boolean, Boolean, Int32)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.GetXmlComment Method

RoslynRepositoryGetXmlComment Method
Represents beginning of XML comment.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetXmlComment()
Public Overridable Function GetXmlComment As String
public:
virtual String^ GetXmlComment()
abstract GetXmlComment : unit -> string
override GetXmlComment : unit -> string

Return Value

Type: String
String determines XML comment start.

Implements

IRoslynRepositoryGetXmlComment
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.IsCollapsible Method

RoslynRepositoryIsCollapsible Method
Overload List
 | Name | Description
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.IsCollapsible Method (IEnumerable(SyntaxTrivia), String, TextSpan)

RoslynRepositoryIsCollapsible Method (IEnumerableSyntaxTrivia, String, TextSpan)
Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsCollapsible(
    IEnumerable<SyntaxTrivia> triviaList,
    out string outlineText,
    out TextSpan span
)
Public Overridable Function IsCollapsible (
    triviaList As IEnumerable(Of SyntaxTrivia),
    <OutAttribute> ByRef outlineText As String,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
public:
virtual bool IsCollapsible(
    IEnumerable<SyntaxTrivia>^ triviaList,
    [OutAttribute] String^% outlineText,
    [OutAttribute] TextSpan% span
)
abstract IsCollapsible :
        triviaList : IEnumerable<SyntaxTrivia> *
        outlineText : string byref *
        span : TextSpan byref -> bool
override IsCollapsible :
        triviaList : IEnumerable<SyntaxTrivia> *
        outlineText : string byref *
        span : TextSpan byref -> bool

Parameters

triviaList
Type: System.Collections.GenericIEnumerableSyntaxTrivia
Microsoft.CodeAnalysis.SyntaxTriviaList to check.
outlineText
Type: SystemString
Output parameter receives text substituting collapsed outline section.
span
Type: TextSpan
Output parameter receives outline range.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined; otherwise false.

Implements

IRoslynRepositoryIsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan)
See Also

Reference

RoslynRepository Class
IsCollapsible Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.IsCollapsible Method (SyntaxNode, String, TextSpan, Boolean)

RoslynRepositoryIsCollapsible Method (SyntaxNode, String, TextSpan, Boolean)
Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsCollapsible(
    SyntaxNode node,
    out string outlineText,
    out TextSpan span,
    bool checkStatements
)
Public Overridable Function IsCollapsible (
    node As SyntaxNode,
    <OutAttribute> ByRef outlineText As String,
    <OutAttribute> ByRef span As TextSpan,
    checkStatements As Boolean
) As Boolean
public:
virtual bool IsCollapsible(
    SyntaxNode^ node,
    [OutAttribute] String^% outlineText,
    [OutAttribute] TextSpan% span,
    bool checkStatements
)
abstract IsCollapsible :
        node : SyntaxNode *
        outlineText : string byref *
        span : TextSpan byref *
        checkStatements : bool -> bool
override IsCollapsible :
        node : SyntaxNode *
        outlineText : string byref *
        span : TextSpan byref *
        checkStatements : bool -> bool

Parameters

node
Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode to check.
outlineText
Type: SystemString
Output parameter receives text substituting collapsed outline section.
span
Type: TextSpan
Output parameter receives outline range.
checkStatements
Type: SystemBoolean
Indicates whether statement node also should be processed.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxNode can be outlined; otherwise false.

Implements

IRoslynRepositoryIsCollapsible(SyntaxNode, String, TextSpan, Boolean)
See Also

Reference

RoslynRepository Class
IsCollapsible Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.IsContentDivider Method

RoslynRepositoryIsContentDivider Method
Gets boolean value indicating whether text content is divided at given line.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsContentDivider(
    SyntaxNode node,
    out TextSpan span
)
Public Overridable Function IsContentDivider (
    node As SyntaxNode,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
public:
virtual bool IsContentDivider(
    SyntaxNode^ node,
    [OutAttribute] TextSpan% span
)
abstract IsContentDivider :
        node : SyntaxNode *
        span : TextSpan byref -> bool
override IsContentDivider :
        node : SyntaxNode *
        span : TextSpan byref -> bool

Parameters

node
Type: SyntaxNode
node check.
span
Type: TextSpan
text span containing node

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IRoslynRepositoryIsContentDivider(SyntaxNode, TextSpan)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.IsStructureGuideNode Method

RoslynRepositoryIsStructureGuideNode Method
Overload List
 | Name | Description
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.IsStructureGuideNode Method (SyntaxNode, TextSpan)

RoslynRepositoryIsStructureGuideNode Method (SyntaxNode, TextSpan)
Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsStructureGuideNode(
    SyntaxNode node,
    out TextSpan span
)
Public Overridable Function IsStructureGuideNode (
    node As SyntaxNode,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
public:
virtual bool IsStructureGuideNode(
    SyntaxNode^ node,
    [OutAttribute] TextSpan% span
)
abstract IsStructureGuideNode :
        node : SyntaxNode *
        span : TextSpan byref -> bool
override IsStructureGuideNode :
        node : SyntaxNode *
        span : TextSpan byref -> bool

Parameters

node
Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode to check.
span
Type: TextSpan
Output parameter receives guide range.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxNode is guide node; otherwise false.

Implements

IRoslynRepositoryIsStructureGuideNode(SyntaxNode, TextSpan)
See Also

Reference

RoslynRepository Class
IsStructureGuideNode Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.ProcessAutoComplete Method

RoslynRepositoryProcessAutoComplete Method
Checks whether end-of-block code needs inserting.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ProcessAutoComplete(
    string text,
    Point position,
    out string code
)
Public Overridable Function ProcessAutoComplete (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessAutoComplete(
    String^ text,
    Point position,
    [OutAttribute] String^% code
)
abstract ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if autocompletion of end-of-block needed; otherwise false.

Implements

IRoslynRepositoryProcessAutoComplete(String, Point, String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.ProcessSnippetBody Method

RoslynRepositoryProcessSnippetBody Method
Checks whether snippet body code needs inserting.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ProcessSnippetBody(
    string text,
    Point position,
    out string code
)
Public Overridable Function ProcessSnippetBody (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessSnippetBody(
    String^ text,
    Point position,
    [OutAttribute] String^% code
)
abstract ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessSnippetBody :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if snippet body code needed; otherwise false.

Implements

IRoslynRepositoryProcessSnippetBody(String, Point, String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RegisterAssemblies Method

RoslynRepositoryRegisterAssemblies Method
Registers assemblies in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterAssemblies(
    string[] assemblies
)
Public Overridable Sub RegisterAssemblies (
    assemblies As String()
)
public:
virtual void RegisterAssemblies(
    array<String^>^ assemblies
)
abstract RegisterAssemblies :
        assemblies : string[] -> unit
override RegisterAssemblies :
        assemblies : string[] -> unit

Parameters

assemblies
Type: SystemString
Assembly names.

Implements

IRoslynRepositoryRegisterAssemblies(String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RegisterAssembly Method

RoslynRepositoryRegisterAssembly Method
Registers assembly in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RegisterAssembly(
    string name
)
Public Overridable Function RegisterAssembly (
    name As String
) As Boolean
public:
virtual bool RegisterAssembly(
    String^ name
)
abstract RegisterAssembly :
        name : string -> bool
override RegisterAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Assembly name.

Return Value

Type: Boolean
True if assembly has been registered, otherwise false.

Implements

IRoslynRepositoryRegisterAssembly(String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RegisterCodeFiles Method

RoslynRepositoryRegisterCodeFiles Method
Makes types declared in given source files accessible for code completion.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RegisterCodeFiles(
    string[] files
)
Public Sub RegisterCodeFiles (
    files As String()
)
public:
virtual void RegisterCodeFiles(
    array<String^>^ files
) sealed
abstract RegisterCodeFiles :
        files : string[] -> unit
override RegisterCodeFiles :
        files : string[] -> unit

Parameters

files
Type: SystemString
files containing source code.

Implements

IRoslynRepositoryRegisterCodeFiles(String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RegisterDefaultAssemblies Method

RoslynRepositoryRegisterDefaultAssemblies Method
Registers default assemblies in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms,
    bool keepExisting = false
)
Public Overridable Sub RegisterDefaultAssemblies (
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms,
    Optional keepExisting As Boolean = false
)
public:
virtual void RegisterDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms,
    bool keepExisting = false
)
abstract RegisterDefaultAssemblies :
        ?technology : TechnologyEnvironment *
        ?keepExisting : bool
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
*)
-> unit
override RegisterDefaultAssemblies :
        ?technology : TechnologyEnvironment *
        ?keepExisting : bool
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
*)
-> unit

Parameters

technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
Specifies technology platform
keepExisting (Optional)
Type: SystemBoolean
Specifies whether existing assemblies should be persisted.

Implements

IRoslynRepositoryRegisterDefaultAssemblies(TechnologyEnvironment, Boolean)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RegisterDefaultNamespaces Method

RoslynRepositoryRegisterDefaultNamespaces Method
Registers default namespaces in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterDefaultNamespaces(
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms
)
Public Overridable Sub RegisterDefaultNamespaces (
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms
)
public:
virtual void RegisterDefaultNamespaces(
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms
)
abstract RegisterDefaultNamespaces :
        ?technology : TechnologyEnvironment
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
*)
-> unit
override RegisterDefaultNamespaces :
        ?technology : TechnologyEnvironment
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
*)
-> unit

Parameters

technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
Specifies technology platform

Implements

IRoslynRepositoryRegisterDefaultNamespaces(TechnologyEnvironment)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RegisterNamespaces Method

RoslynRepositoryRegisterNamespaces Method
Registers global namespaces in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterNamespaces(
    string[] nameSpaces
)
Public Overridable Sub RegisterNamespaces (
    nameSpaces As String()
)
public:
virtual void RegisterNamespaces(
    array<String^>^ nameSpaces
)
abstract RegisterNamespaces :
        nameSpaces : string[] -> unit
override RegisterNamespaces :
        nameSpaces : string[] -> unit

Parameters

nameSpaces
Type: SystemString
Global namespaces.

Implements

IRoslynRepositoryRegisterNamespaces(String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RemoveDocument Method

RoslynRepositoryRemoveDocument Method
Overload List
 | Name | Description
Public method | RemoveDocument | Removes document from document collection.
Public method | RemoveDocument(DocumentId) | Removes current document from document collection.
Public method | RemoveDocument(String) | Removes document from document collection.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RemoveDocument Method

RoslynRepositoryRemoveDocument Method
Removes document from document collection.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveDocument()
Public Function RemoveDocument As Boolean
public:
virtual bool RemoveDocument() sealed
abstract RemoveDocument : unit -> bool
override RemoveDocument : unit -> bool

Return Value

Type: Boolean
True if current document was removed; otherwise false

Implements

IRoslynRepositoryRemoveDocument
See Also

Reference

RoslynRepository Class
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RemoveDocument Method (DocumentId)

RoslynRepositoryRemoveDocument Method (DocumentId)
Removes current document from document collection.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveDocument(
    DocumentId documentId
)
Public Function RemoveDocument (
    documentId As DocumentId
) As Boolean
public:
virtual bool RemoveDocument(
    DocumentId^ documentId
) sealed
abstract RemoveDocument :
        documentId : DocumentId -> bool
override RemoveDocument :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId
Id of theMicrosoft.CodeAnalysis.Document.

Return Value

Type: Boolean
True if document was removed; otherwise false

Implements

IRoslynRepositoryRemoveDocument(DocumentId)
See Also

Reference

RoslynRepository Class
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.RemoveDocument Method (String)

RoslynRepositoryRemoveDocument Method (String)
Removes document from document collection.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RemoveDocument(
    string file
)
Public Overridable Function RemoveDocument (
    file As String
) As Boolean
public:
virtual bool RemoveDocument(
    String^ file
)
abstract RemoveDocument :
        file : string -> bool
override RemoveDocument :
        file : string -> bool

Parameters

file
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.

Return Value

Type: Boolean
True if document was removed; otherwise false

Implements

IRoslynRepositoryRemoveDocument(String)
See Also

Reference

RoslynRepository Class
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.ReplaceDocument Method

RoslynRepositoryReplaceDocument Method
Overload List
 | Name | Description
Public method | ReplaceDocument(DocumentId, SourceText) | Adds a new document or replaces existing document with specified settings.
Public method | ReplaceDocument(DocumentId, String) | Adds a new document or replaces existing document with specified settings.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.ReplaceDocument Method (DocumentId, SourceText)

RoslynRepositoryReplaceDocument Method (DocumentId, SourceText)
Adds a new document or replaces existing document with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReplaceDocument(
    DocumentId documentId,
    SourceText text
)
Public Function ReplaceDocument (
    documentId As DocumentId,
    text As SourceText
) As Boolean
public:
virtual bool ReplaceDocument(
    DocumentId^ documentId,
    SourceText^ text
) sealed
abstract ReplaceDocument :
        documentId : DocumentId *
        text : SourceText -> bool
override ReplaceDocument :
        documentId : DocumentId *
        text : SourceText -> bool

Parameters

documentId
Type: DocumentId
Id of the Microsoft.CodeAnalysis.Document.
text
Type: SourceText
New Microsoft.CodeAnalysis.Document text.

Return Value

Type: Boolean
True if document has been updated; otherwise false.

Implements

IRoslynRepositoryReplaceDocument(DocumentId, SourceText)
See Also

Reference

RoslynRepository Class
ReplaceDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.ReplaceDocument Method (DocumentId, String)

RoslynRepositoryReplaceDocument Method (DocumentId, String)
Adds a new document or replaces existing document with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReplaceDocument(
    DocumentId documentId,
    string text
)
Public Function ReplaceDocument (
    documentId As DocumentId,
    text As String
) As Boolean
public:
virtual bool ReplaceDocument(
    DocumentId^ documentId,
    String^ text
) sealed
abstract ReplaceDocument :
        documentId : DocumentId *
        text : string -> bool
override ReplaceDocument :
        documentId : DocumentId *
        text : string -> bool

Parameters

documentId
Type: DocumentId
Id of the Microsoft.CodeAnalysis.Document.
text
Type: SystemString
New Microsoft.CodeAnalysis.Document text.

Return Value

Type: Boolean
True if document has been updated; otherwise false.

Implements

IRoslynRepositoryReplaceDocument(DocumentId, String)
See Also

Reference

RoslynRepository Class
ReplaceDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.SmartCapitalize Method

RoslynRepositorySmartCapitalize Method
Capitalizes block of text.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SmartCapitalize(
    Point start,
    Point end,
    ITextUndoList operations
)
Public Overridable Sub SmartCapitalize (
    start As Point,
    end As Point,
    operations As ITextUndoList
)
public:
virtual void SmartCapitalize(
    Point start,
    Point end,
    ITextUndoList^ operations
)
abstract SmartCapitalize :
        start : Point *
        end : Point *
        operations : ITextUndoList -> unit
override SmartCapitalize :
        start : Point *
        end : Point *
        operations : ITextUndoList -> unit

Parameters

start
Type: System.DrawingPoint
Start position of the block.
end
Type: System.DrawingPoint
End position of the block.
operations
Type: Alternet.SyntaxITextUndoList
List of the text changes.
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.SmartFormat Method

RoslynRepositorySmartFormat Method
Overload List
 | Name | Description
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | Formats block of text according to the parser rules.
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.SmartFormat Method (Point, Boolean, Int32, ITextUndoList)

RoslynRepositorySmartFormat Method (Point, Boolean, Int32, ITextUndoList)
Formats block of text according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SmartFormat(
    ref Point position,
    bool useSpaces,
    int spacesInTab,
    ITextUndoList operations
)
Public Overridable Function SmartFormat (
    ByRef position As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    operations As ITextUndoList
) As Boolean
public:
virtual bool SmartFormat(
    Point% position,
    bool useSpaces,
    int spacesInTab,
    ITextUndoList^ operations
)
abstract SmartFormat :
        position : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        operations : ITextUndoList -> bool
override SmartFormat :
        position : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        operations : ITextUndoList -> bool

Parameters

position
Type: System.DrawingPoint
Position of the text.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.
operations
Type: Alternet.SyntaxITextUndoList
List of the text changes.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IRoslynRepositorySmartFormat(Point, Boolean, Int32, ITextUndoList)
See Also

Reference

RoslynRepository Class
SmartFormat Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.SmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)

RoslynRepositorySmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)
Formats block of text according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SmartFormat(
    ref Point start,
    ref Point end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList operations
)
Public Overridable Function SmartFormat (
    ByRef start As Point,
    ByRef end As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    extended As Boolean,
    operations As ITextUndoList
) As Boolean
public:
virtual bool SmartFormat(
    Point% start,
    Point% end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList^ operations
)
abstract SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool
override SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool

Parameters

start
Type: System.DrawingPoint
Start position of the block
end
Type: System.DrawingPoint
End position of the block
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab
extended
Type: SystemBoolean
Specifies if whole syntax block containing start and end point should be formatted
operations
Type: Alternet.SyntaxITextUndoList
List of changes.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IRoslynRepositorySmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList)
See Also

Reference

RoslynRepository Class
SmartFormat Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.UnregisterAssemblies Method

RoslynRepositoryUnregisterAssemblies Method
Unregisters assemblies from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnregisterAssemblies(
    string[] assemblies
)
Public Sub UnregisterAssemblies (
    assemblies As String()
)
public:
virtual void UnregisterAssemblies(
    array<String^>^ assemblies
) sealed
abstract UnregisterAssemblies :
        assemblies : string[] -> unit
override UnregisterAssemblies :
        assemblies : string[] -> unit

Parameters

assemblies
Type: SystemString
Assembly names.

Implements

IRoslynRepositoryUnregisterAssemblies(String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.UnregisterAssembly Method

RoslynRepositoryUnregisterAssembly Method
Unregisters assembly from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UnregisterAssembly(
    string name
)
Public Function UnregisterAssembly (
    name As String
) As Boolean
public:
virtual bool UnregisterAssembly(
    String^ name
) sealed
abstract UnregisterAssembly :
        name : string -> bool
override UnregisterAssembly :
        name : string -> bool

Parameters

name
Type: SystemString
Assembly name.

Return Value

Type: Boolean
True if assembly has been unregistered, otherwise false.

Implements

IRoslynRepositoryUnregisterAssembly(String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.UnregisterCodeFiles Method

RoslynRepositoryUnregisterCodeFiles Method
Removes types declared in given source files from being accessible code completion.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnregisterCodeFiles(
    string[] files
)
Public Sub UnregisterCodeFiles (
    files As String()
)
public:
virtual void UnregisterCodeFiles(
    array<String^>^ files
) sealed
abstract UnregisterCodeFiles :
        files : string[] -> unit
override UnregisterCodeFiles :
        files : string[] -> unit

Parameters

files
Type: SystemString
files containing source code.

Implements

IRoslynRepositoryUnregisterCodeFiles(String)
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.Update Method

RoslynRepositoryUpdate Method
Updates an object state.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
virtual void Update() sealed
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository Properties

RoslynRepository Properties

The RoslynRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a Microsoft.CodeAnalysis.Document contains code text.
Public property | DocumentId | Represents a Microsoft.CodeAnalysis.DocumentId contains code text.
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Model | Represents a Microsoft.CodeAnalysis.SemanticModel describes code text.
Public property | ProjectId | Represents a Microsoft.CodeAnalysis.ProjectId that contains document.
Public property | ProjectName | gets or sets Project name containing document
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | Solution | Gets RoslynSolution associated with this Repository.
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Text | Represents a Microsoft.CodeAnalysis.SourceText describes code text.
Public property | Tree | Represents a Microsoft.CodeAnalysis.SyntaxTree represents parsed code text.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.Document Property

RoslynRepositoryDocument Property
Represents a Microsoft.CodeAnalysis.Document contains code text.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Document Document { get; }
Public Overridable ReadOnly Property Document As Document
    Get
public:
virtual property Document^ Document {
    Document^ get ();
}
abstract Document : Document with get
override Document : Document with get

Property Value

Type: Document

Implements

IRoslynRepositoryDocument
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.DocumentId Property

RoslynRepositoryDocumentId Property
Represents a Microsoft.CodeAnalysis.DocumentId contains code text.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DocumentId DocumentId { get; set; }
Public Overridable Property DocumentId As DocumentId
    Get
    Set
public:
virtual property DocumentId^ DocumentId {
    DocumentId^ get ();
    void set (DocumentId^ value);
}
abstract DocumentId : DocumentId with get, set
override DocumentId : DocumentId with get, set

Property Value

Type: DocumentId

Implements

IRoslynRepositoryDocumentId
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.Images Property

RoslynRepositoryImages Property
Represents collection of images used for code completion.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; }
Public Overrides ReadOnly Property Images As ImageList
    Get
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
}
abstract Images : ImageList with get
override Images : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImages
ICodeCompletionRepositoryImages
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.ImagesHighDpi Property

RoslynRepositoryImagesHighDpi Property

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList ImagesHighDpi { get; }
Public Overrides ReadOnly Property ImagesHighDpi As ImageList
    Get
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get () override;
}
abstract ImagesHighDpi : ImageList with get
override ImagesHighDpi : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImagesHighDpi
ICodeCompletionRepositoryImagesHighDpi
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.Model Property

RoslynRepositoryModel Property
Represents a Microsoft.CodeAnalysis.SemanticModel describes code text.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SemanticModel Model { get; }
Public Overridable ReadOnly Property Model As SemanticModel
    Get
public:
virtual property SemanticModel^ Model {
    SemanticModel^ get ();
}
abstract Model : SemanticModel with get
override Model : SemanticModel with get

Property Value

Type: SemanticModel

Implements

IRoslynRepositoryModel
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.ProjectId Property

RoslynRepositoryProjectId Property
Represents a Microsoft.CodeAnalysis.ProjectId that contains document.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectId ProjectId { get; set; }
Public Property ProjectId As ProjectId
    Get
    Set
public:
virtual property ProjectId^ ProjectId {
    ProjectId^ get () sealed;
    void set (ProjectId^ value) sealed;
}
abstract ProjectId : ProjectId with get, set
override ProjectId : ProjectId with get, set

Property Value

Type: ProjectId

Implements

IRoslynRepositoryProjectId
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.ProjectName Property

RoslynRepositoryProjectName Property
gets or sets Project name containing document

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectName { get; set; }
Public Property ProjectName As String
    Get
    Set
public:
virtual property String^ ProjectName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ProjectName : string with get, set
override ProjectName : string with get, set

Property Value

Type: String

Implements

IRoslynRepositoryProjectName
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.Solution Property

RoslynRepositorySolution Property
Gets RoslynSolution associated with this Repository.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IRoslynSolution Solution { get; set; }
Public Property Solution As IRoslynSolution
    Get
    Set
public:
virtual property IRoslynSolution^ Solution {
    IRoslynSolution^ get () sealed;
    void set (IRoslynSolution^ value) sealed;
}
abstract Solution : IRoslynSolution with get, set
override Solution : IRoslynSolution with get, set

Property Value

Type: IRoslynSolution

Implements

IRoslynRepositorySolution
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.Text Property

RoslynRepositoryText Property
Represents a Microsoft.CodeAnalysis.SourceText describes code text.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SourceText Text { get; }
Public Overridable ReadOnly Property Text As SourceText
    Get
public:
virtual property SourceText^ Text {
    SourceText^ get ();
}
abstract Text : SourceText with get
override Text : SourceText with get

Property Value

Type: SourceText

Implements

IRoslynRepositoryText
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.Tree Property

RoslynRepositoryTree Property
Represents a Microsoft.CodeAnalysis.SyntaxTree represents parsed code text.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SyntaxTree Tree { get; }
Public Overridable ReadOnly Property Tree As SyntaxTree
    Get
public:
virtual property SyntaxTree^ Tree {
    SyntaxTree^ get ();
}
abstract Tree : SyntaxTree with get
override Tree : SyntaxTree with get

Property Value

Type: SyntaxTree

Implements

IRoslynRepositoryTree
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.UpdateCount Property

RoslynRepositoryUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UpdateCount { get; }
Public ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get () sealed;
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository Events

RoslynRepository Events

The RoslynRepository type exposes the following members.

Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options.
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynRepository.CustomFormattingOptions Event

RoslynRepositoryCustomFormattingOptions Event
Occurs when text document is being formatted to provide custom formatting options.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FormattingOptionsEventArgs> CustomFormattingOptions
Public Event CustomFormattingOptions As EventHandler(Of FormattingOptionsEventArgs)
public:
virtual  event EventHandler<FormattingOptionsEventArgs^>^ CustomFormattingOptions {
    void add (EventHandler<FormattingOptionsEventArgs^>^ value);
    void remove (EventHandler<FormattingOptionsEventArgs^>^ value);
}
abstract CustomFormattingOptions : IEvent<EventHandler<FormattingOptionsEventArgs>,
    FormattingOptionsEventArgs>
override CustomFormattingOptions : IEvent<EventHandler<FormattingOptionsEventArgs>,
    FormattingOptionsEventArgs>

Value

Type: SystemEventHandlerFormattingOptionsEventArgs

Implements

IRoslynRepositoryCustomFormattingOptions
See Also

Reference

RoslynRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution Class

RoslynSolution Class
Represents properties and methods to service source code documents intended to use for Roslyn supported languages.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Roslyn.CodeCompletionRoslynSolution
Alternet.Syntax.Parsers.Roslyn.CodeCompletionCsSolution
Alternet.Syntax.Parsers.Roslyn.CodeCompletionVbSolution

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoslynSolution : IRoslynSolution,
    INotify, IUpdate, IDisposable
Public Class RoslynSolution
    Implements IRoslynSolution, INotify, IUpdate, IDisposable
public ref class RoslynSolution : IRoslynSolution,
    INotify, IUpdate, IDisposable
type RoslynSolution =
    class
        interface IRoslynSolution
        interface INotify
        interface IUpdate
        interface IDisposable
    end

The RoslynSolution type exposes the following members.

Constructors
 | Name | Description
Public method | RoslynSolution | Initializes a new instance of the RoslynSolution class with default settings.
Top
Methods
Name | Description
Public method AddDocument(String, SourceText, ProjectId, Boolean)
Adds a new document to the project.
Public method AddDocument(String, String, ProjectId, Boolean)
Adds a new document to the project.
Public method AddNotifier
Adds new handler to respond a notification.
Public method AddProject
When implemented by a class, adds project to the solution
Public method AddReference
Adds metadata reference to the project
Public method BeginUpdate
Prevents object state updating until calling EndUpdate method.
Public method CloseDocument
When implemented by a class, closes specified document.
Public method CreateDefaultProject
Creates default project to this solution.
Public method DisableUpdate
Prevents object state updating until calling EnableUpdate method.
Public method Dispose
Releases all resources used by the RoslynSolution
Public method DocumentBelongsToDefaultProject
Indicates if document belongs to the default project.
Public method EnableUpdate
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method EndUpdate
Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method FindDocument(String, ProjectId)
Gets Microsoft.CodeAnalysis.Document matches the given file path.
FindDocument(Solution, ProjectId, String)
Gets Microsoft.CodeAnalysis.Document matches the given parameters.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetProject(ProjectId)
Gets or creates Project in the solution.
Public method GetProject(String)
Gets or creates Project in the solution.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsDocumentOpen
Determines if document is already open in the workspace.
Public method Notify
Notifies all notifiers about updating object state.
Public method OpenDocument
Opens specified document if needed.
Public method RegisterAssemblies
Replaces assemblies in the project with new ones.
Public method RegisterAssembly
Registers assembly in the project.
Public method RegisterCodeFiles
Makes types declared in given source files accessible for code completion.
Public method RegisterNamespaces
Registers global namespaces.
Public method RegisterProjectReferences
When implemented by a class, replaces project references with the new ones.
Public method RemoveDocument(DocumentId)
Removes specified Microsoft.CodeAnalysis.Document from the project.
Public method RemoveDocument(String, ProjectId)
Removes specified document from the project.
Public method RemoveNotifier
Exclude specified handler from notification handlers list.
Public method RemoveProject
Removes project from the solution
Public method ReplaceCodeFile
Updates code completion with changes in source file.
Public method ReplaceDocument(DocumentId, SourceText)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method ReplaceDocument(DocumentId, String)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method ResolveAssemblyName
Try to find real assembly name matches the given name.
Public method | ResolveProjectId
Public method SetConditionalsForProject
Sets conditional compilation symbols for given project
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UnregisterAssemblies
Unregisters assemblies from the project.
Public method UnregisterAssembly
Unregisters assembly from the project.
Public method UnregisterCodeFiles
Removes types declared in given source files from being accessible code completion.
Public method UnregisterProjectReferences
When implemented by a class, unregisters assemblies from the project.
Public method Update
Updates an object state.
Public method WithDefaultAssemblies
Registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add reference to.

Return Value

Type:
IRoslynSolution instance with default assemblies being registered for code completion
Top
Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths.
Public property | BaseDirectory | Gets or sets solution base directory.
Public property | Conditionals | When implemented by a class, gets or sets a collection of conditional symbols
Public property | CustomXMLDocPath | Gets a custom xml documentation path.
Public property | FrameworkPath | Gets or sets path to the .NET Framework assemblies
Public property | ProjectId | Gets a current Microsoft.CodeAnalysis.ProjectId.
Public property | ScriptSearchPaths | Gets or sets a collection of script source search paths.
Public property | Solution | Gets a current Microsoft.CodeAnalysis.Project.
Public property | SourceKind | Gets kind (regular or script) of the source code.
Public property | TargetFrameworkVersion | Gets or sets version of the .NET Framework to use with the methods in Framework Location Helper.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | Workspace | Gets a current project Microsoft.CodeAnalysis.Workspace.
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution Constructor

RoslynSolution Constructor
Initializes a new instance of the RoslynSolution class with default settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoslynSolution(
    SourceCodeKind sourceKind = SourceCodeKind.Regular,
    Type scriptGlobalsType = null
)
Public Sub New (
    Optional sourceKind As SourceCodeKind = SourceCodeKind.Regular,
    Optional scriptGlobalsType As Type = Nothing
)
public:
RoslynSolution(
    SourceCodeKind sourceKind = SourceCodeKind::Regular,
    Type^ scriptGlobalsType = nullptr
)
new :
        ?sourceKind : SourceCodeKind *
        ?scriptGlobalsType : Type
(* Defaults:
        let _sourceKind = defaultArg sourceKind SourceCodeKind.Regular
        let _scriptGlobalsType = defaultArg scriptGlobalsType null
*)
-> RoslynSolution

Parameters

sourceKind (Optional)
Type: SourceCodeKind
scriptGlobalsType (Optional)
Type: SystemType
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution Methods

RoslynSolution Methods

The RoslynSolution type exposes the following members.

Methods
Name | Description
Public method AddDocument(String, SourceText, ProjectId, Boolean)
Adds a new document to the project.
Public method AddDocument(String, String, ProjectId, Boolean)
Adds a new document to the project.
Public method AddNotifier
Adds new handler to respond a notification.
Public method AddProject
When implemented by a class, adds project to the solution
Public method AddReference
Adds metadata reference to the project
Public method BeginUpdate
Prevents object state updating until calling EndUpdate method.
Public method CloseDocument
When implemented by a class, closes specified document.
Public method CreateDefaultProject
Creates default project to this solution.
Public method DisableUpdate
Prevents object state updating until calling EnableUpdate method.
Public method | Dispose
Public method DocumentBelongsToDefaultProject
Indicates if document belongs to the default project.
Public method EnableUpdate
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
Public method EndUpdate
Re-enables object state updating, that was turn of by calling BeginUpdate method.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method FindDocument(String, ProjectId)
Gets Microsoft.CodeAnalysis.Document matches the given file path.
FindDocument(Solution, ProjectId, String)
Gets Microsoft.CodeAnalysis.Document matches the given parameters.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetProject(ProjectId)
Gets or creates Project in the solution.
Public method GetProject(String)
Gets or creates Project in the solution.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsDocumentOpen
Determines if document is already open in the workspace.
Public method Notify
Notifies all notifiers about updating object state.
Public method OpenDocument
Opens specified document if needed.
Public method RegisterAssemblies
Replaces assemblies in the project with new ones.
Public method RegisterAssembly
Registers assembly in the project.
Public method RegisterCodeFiles
Makes types declared in given source files accessible for code completion.
Public method RegisterNamespaces
Registers global namespaces.
Public method RegisterProjectReferences
When implemented by a class, replaces project references with the new ones.
Public method RemoveDocument(DocumentId)
Removes specified Microsoft.CodeAnalysis.Document from the project.
Public method RemoveDocument(String, ProjectId)
Removes specified document from the project.
Public method RemoveNotifier
Exclude specified handler from notification handlers list.
Public method RemoveProject
Removes project from the solution
Public method ReplaceCodeFile
Updates code completion with changes in source file.
Public method ReplaceDocument(DocumentId, SourceText)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method ReplaceDocument(DocumentId, String)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method ResolveAssemblyName
Try to find real assembly name matches the given name.
Public method | ResolveProjectId
Public method SetConditionalsForProject
Sets conditional compilation symbols for given project
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UnregisterAssemblies
Unregisters assemblies from the project.
Public method UnregisterAssembly
Unregisters assembly from the project.
Public method UnregisterCodeFiles
Removes types declared in given source files from being accessible code completion.
Public method UnregisterProjectReferences
When implemented by a class, unregisters assemblies from the project.
Public method Update
Updates an object state.
Public method WithDefaultAssemblies
Registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add reference to.

Return Value

Type:
IRoslynSolution instance with default assemblies being registered for code completion
Top
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.AddDocument Method

RoslynSolutionAddDocument Method
Overload List
 | Name | Description
Public method | AddDocument(String, SourceText, ProjectId, Boolean) | Adds a new document to the project.
Public method | AddDocument(String, String, ProjectId, Boolean) | Adds a new document to the project.
Top
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.AddDocument Method (String, SourceText, ProjectId, Boolean)

RoslynSolutionAddDocument Method (String, SourceText, ProjectId, Boolean)
Adds a new document to the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DocumentId AddDocument(
    string fileName,
    SourceText text,
    ProjectId projectId = null,
    bool open = true
)
Public Overridable Function AddDocument (
    fileName As String,
    text As SourceText,
    Optional projectId As ProjectId = Nothing,
    Optional open As Boolean = true
) As DocumentId
public:
virtual DocumentId^ AddDocument(
    String^ fileName,
    SourceText^ text,
    ProjectId^ projectId = nullptr,
    bool open = true
)
abstract AddDocument :
        fileName : string *
        text : SourceText *
        ?projectId : ProjectId *
        ?open : bool
(* Defaults:
        let _projectId = defaultArg projectId null
        let _open = defaultArg open true
*)
-> DocumentId
override AddDocument :
        fileName : string *
        text : SourceText *
        ?projectId : ProjectId *
        ?open : bool
(* Defaults:
        let _projectId = defaultArg projectId null
        let _open = defaultArg open true
*)
-> DocumentId

Parameters

fileName
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.
text
Type: SourceText
New Microsoft.CodeAnalysis.Text.SourceText text.
projectId (Optional)
Type: ProjectId
Specifies Project to add document to
open (Optional)
Type: SystemBoolean
Specifies if document needs to be open in the workspace.

Return Value

Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to be added.

Implements

IRoslynSolutionAddDocument(String, SourceText, ProjectId, Boolean)
See Also

Reference

RoslynSolution Class
AddDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.AddDocument Method (String, String, ProjectId, Boolean)

RoslynSolutionAddDocument Method (String, String, ProjectId, Boolean)
Adds a new document to the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DocumentId AddDocument(
    string fileName,
    string text,
    ProjectId projectId = null,
    bool open = true
)
Public Overridable Function AddDocument (
    fileName As String,
    text As String,
    Optional projectId As ProjectId = Nothing,
    Optional open As Boolean = true
) As DocumentId
public:
virtual DocumentId^ AddDocument(
    String^ fileName,
    String^ text,
    ProjectId^ projectId = nullptr,
    bool open = true
)
abstract AddDocument :
        fileName : string *
        text : string *
        ?projectId : ProjectId *
        ?open : bool
(* Defaults:
        let _projectId = defaultArg projectId null
        let _open = defaultArg open true
*)
-> DocumentId
override AddDocument :
        fileName : string *
        text : string *
        ?projectId : ProjectId *
        ?open : bool
(* Defaults:
        let _projectId = defaultArg projectId null
        let _open = defaultArg open true
*)
-> DocumentId

Parameters

fileName
Type: SystemString
File name of the Microsoft.CodeAnalysis.Document.
text
Type: SystemString
New Microsoft.CodeAnalysis.Document text.
projectId (Optional)
Type: ProjectId
Specifies Project to add document to
open (Optional)
Type: SystemBoolean
Specifies if document needs to be open in the workspace.

Return Value

Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to be added.

Implements

IRoslynSolutionAddDocument(String, String, ProjectId, Boolean)
See Also

Reference

RoslynSolution Class
AddDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.AddNotifier Method

RoslynSolutionAddNotifier Method
Adds new handler to respond a notification.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddNotifier(
    INotifier sender
)
Public Overridable Sub AddNotifier (
    sender As INotifier
)
public:
virtual void AddNotifier(
    INotifier^ sender
)
abstract AddNotifier :
        sender : INotifier -> unit
override AddNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.

Implements

INotifyAddNotifier(INotifier)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.AddProject Method

RoslynSolutionAddProject Method
When implemented by a class, adds project to the solution

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ProjectId AddProject(
    string projectName,
    string projectPath
)
Public Overridable Function AddProject (
    projectName As String,
    projectPath As String
) As ProjectId
public:
virtual ProjectId^ AddProject(
    String^ projectName,
    String^ projectPath
)
abstract AddProject :
        projectName : string *
        projectPath : string -> ProjectId
override AddProject :
        projectName : string *
        projectPath : string -> ProjectId

Parameters

projectName
Type: SystemString
Project name
projectPath
Type: SystemString
Project path

Return Value

Type: ProjectId

Implements

IRoslynSolutionAddProject(String, String)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.AddReference Method

RoslynSolutionAddReference Method
Adds metadata reference to the project

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddReference(
    MetadataReference reference,
    ProjectId projectId = null
)
Public Overridable Sub AddReference (
    reference As MetadataReference,
    Optional projectId As ProjectId = Nothing
)
public:
virtual void AddReference(
    MetadataReference^ reference,
    ProjectId^ projectId = nullptr
)
abstract AddReference :
        reference : MetadataReference *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit
override AddReference :
        reference : MetadataReference *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit

Parameters

reference
Type: MetadataReference
Reference to add.
projectId (Optional)
Type: ProjectId
Specifies project to add reference to.

Implements

IRoslynSolutionAddReference(MetadataReference, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.BeginUpdate Method

RoslynSolutionBeginUpdate Method
Prevents object state updating until calling EndUpdate method.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int BeginUpdate()
Public Overridable Function BeginUpdate As Integer
public:
virtual int BeginUpdate()
abstract BeginUpdate : unit -> int
override BeginUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateBeginUpdate
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.CloseDocument Method

RoslynSolutionCloseDocument Method
When implemented by a class, closes specified document.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CloseDocument(
    DocumentId documentId
)
Public Overridable Function CloseDocument (
    documentId As DocumentId
) As Boolean
public:
virtual bool CloseDocument(
    DocumentId^ documentId
)
abstract CloseDocument :
        documentId : DocumentId -> bool
override CloseDocument :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to close.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IRoslynSolutionCloseDocument(DocumentId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.CreateDefaultProject Method

RoslynSolutionCreateDefaultProject Method
Creates default project to this solution.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ProjectId CreateDefaultProject()
Public Overridable Function CreateDefaultProject As ProjectId
public:
virtual ProjectId^ CreateDefaultProject()
abstract CreateDefaultProject : unit -> ProjectId
override CreateDefaultProject : unit -> ProjectId

Return Value

Type: ProjectId
Id of the Microsoft.CodeAnalysis.Project of a project that is created.

Implements

IRoslynSolutionCreateDefaultProject
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.DisableUpdate Method

RoslynSolutionDisableUpdate Method
Prevents object state updating until calling EnableUpdate method.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DisableUpdate()
Public Function DisableUpdate As Integer
public:
virtual int DisableUpdate() sealed
abstract DisableUpdate : unit -> int
override DisableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateDisableUpdate
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.Dispose Method

RoslynSolutionDispose Method
Releases all resources used by the RoslynSolution

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.DocumentBelongsToDefaultProject Method

RoslynSolutionDocumentBelongsToDefaultProject Method
Indicates if document belongs to the default project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DocumentBelongsToDefaultProject(
    DocumentId documentId
)
Public Function DocumentBelongsToDefaultProject (
    documentId As DocumentId
) As Boolean
public:
virtual bool DocumentBelongsToDefaultProject(
    DocumentId^ documentId
) sealed
abstract DocumentBelongsToDefaultProject :
        documentId : DocumentId -> bool
override DocumentBelongsToDefaultProject :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId

Return Value

Type: Boolean

Implements

IRoslynSolutionDocumentBelongsToDefaultProject(DocumentId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.EnableUpdate Method

RoslynSolutionEnableUpdate Method
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EnableUpdate()
Public Function EnableUpdate As Integer
public:
virtual int EnableUpdate() sealed
abstract EnableUpdate : unit -> int
override EnableUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEnableUpdate
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.EndUpdate Method

RoslynSolutionEndUpdate Method
Re-enables object state updating, that was turn of by calling BeginUpdate method.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int EndUpdate()
Public Overridable Function EndUpdate As Integer
public:
virtual int EndUpdate()
abstract EndUpdate : unit -> int
override EndUpdate : unit -> int

Return Value

Type: Int32
Number of object state updating locks.

Implements

IUpdateEndUpdate
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.FindDocument Method

RoslynSolutionFindDocument Method
Overload List
 | Name | Description
Public method | FindDocument(String, ProjectId) | Gets Microsoft.CodeAnalysis.Document matches the given file path.
 | FindDocument(Solution, ProjectId, String) | Gets Microsoft.CodeAnalysis.Document matches the given parameters.
Top
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.FindDocument Method (String, ProjectId)

RoslynSolutionFindDocument Method (String, ProjectId)
Gets Microsoft.CodeAnalysis.Document matches the given file path.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document FindDocument(
    string fileName,
    ProjectId projectId = null
)
Public Function FindDocument (
    fileName As String,
    Optional projectId As ProjectId = Nothing
) As Document
public:
virtual Document^ FindDocument(
    String^ fileName,
    ProjectId^ projectId = nullptr
) sealed
abstract FindDocument :
        fileName : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> Document
override FindDocument :
        fileName : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> Document

Parameters

fileName
Type: SystemString
File path to find.
projectId (Optional)
Type: ProjectId
Specifies Project to search for the document.

Return Value

Type: Document
Found Microsoft.CodeAnalysis.Document object.

Implements

IRoslynSolutionFindDocument(String, ProjectId)
See Also

Reference

RoslynSolution Class
FindDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.FindDocument Method (Solution, ProjectId, String)

RoslynSolutionFindDocument Method (Solution, ProjectId, String)
Gets Microsoft.CodeAnalysis.Document matches the given parameters.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Document FindDocument(
    Solution solution,
    ProjectId projectId,
    string fileName
)
Public Shared Function FindDocument (
    solution As Solution,
    projectId As ProjectId,
    fileName As String
) As Document
public:
static Document^ FindDocument(
    Solution^ solution,
    ProjectId^ projectId,
    String^ fileName
)
static member FindDocument :
        solution : Solution *
        projectId : ProjectId *
        fileName : string -> Document

Parameters

solution
Type: Solution
Specifies Solution to search for the document.
projectId
Type: ProjectId
Specifies Project to search for the document.
fileName
Type: SystemString
Document file name.

Return Value

Type: Document
Found Microsoft.CodeAnalysis.Document object.
See Also

Reference

RoslynSolution Class
FindDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.GetProject Method

RoslynSolutionGetProject Method
Overload List
 | Name | Description
Public method | GetProject(ProjectId) | Gets or creates Project in the solution.
Public method | GetProject(String) | Gets or creates Project in the solution.
Top
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.GetProject Method (ProjectId)

RoslynSolutionGetProject Method (ProjectId)
Gets or creates Project in the solution.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Project GetProject(
    ProjectId projectId
)
Public Overridable Function GetProject (
    projectId As ProjectId
) As Project
public:
virtual Project^ GetProject(
    ProjectId^ projectId
)
abstract GetProject :
        projectId : ProjectId -> Project
override GetProject :
        projectId : ProjectId -> Project

Parameters

projectId
Type: ProjectId
Specifies project Id.

Return Value

Type: Project
Located or newly created project.

Implements

IRoslynSolutionGetProject(ProjectId)
See Also

Reference

RoslynSolution Class
GetProject Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.GetProject Method (String)

RoslynSolutionGetProject Method (String)
Gets or creates Project in the solution.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Project GetProject(
    string projectName
)
Public Overridable Function GetProject (
    projectName As String
) As Project
public:
virtual Project^ GetProject(
    String^ projectName
)
abstract GetProject :
        projectName : string -> Project
override GetProject :
        projectName : string -> Project

Parameters

projectName
Type: SystemString
Specifies project name.

Return Value

Type: Project
Found project.

Implements

IRoslynSolutionGetProject(String)
See Also

Reference

RoslynSolution Class
GetProject Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.IsDocumentOpen Method

RoslynSolutionIsDocumentOpen Method
Determines if document is already open in the workspace.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDocumentOpen(
    DocumentId documentId
)
Public Function IsDocumentOpen (
    documentId As DocumentId
) As Boolean
public:
virtual bool IsDocumentOpen(
    DocumentId^ documentId
) sealed
abstract IsDocumentOpen :
        documentId : DocumentId -> bool
override IsDocumentOpen :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to check.

Return Value

Type: Boolean
True if document is already open; False otherwise

Implements

IRoslynSolutionIsDocumentOpen(DocumentId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.Notify Method

RoslynSolutionNotify Method
Notifies all notifiers about updating object state.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Notify(
    EventArgs e
)
Public Overridable Sub Notify (
    e As EventArgs
)
public:
virtual void Notify(
    EventArgs^ e
)
abstract Notify :
        e : EventArgs -> unit
override Notify :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs

Implements

INotifyNotify(EventArgs)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.OpenDocument Method

RoslynSolutionOpenDocument Method
Opens specified document if needed.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void OpenDocument(
    DocumentId documentId
)
Public Overridable Sub OpenDocument (
    documentId As DocumentId
)
public:
virtual void OpenDocument(
    DocumentId^ documentId
)
abstract OpenDocument :
        documentId : DocumentId -> unit
override OpenDocument :
        documentId : DocumentId -> unit

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to open.

Implements

IRoslynSolutionOpenDocument(DocumentId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RegisterAssemblies Method

RoslynSolutionRegisterAssemblies Method
Replaces assemblies in the project with new ones.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RegisterAssemblies(
    string[] references,
    ProjectId projectId = null
)
Public Overridable Function RegisterAssemblies (
    references As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
public:
virtual bool RegisterAssemblies(
    array<String^>^ references,
    ProjectId^ projectId = nullptr
)
abstract RegisterAssemblies :
        references : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool
override RegisterAssemblies :
        references : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

references
Type: SystemString
List of assembly name.
projectId (Optional)
Type: ProjectId
Specifies project to add reference to.

Return Value

Type: Boolean
True if succeed otherwise false.

Implements

IRoslynSolutionRegisterAssemblies(String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RegisterAssembly Method

RoslynSolutionRegisterAssembly Method
Registers assembly in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RegisterAssembly(
    string name,
    ProjectId projectId = null
)
Public Overridable Function RegisterAssembly (
    name As String,
    Optional projectId As ProjectId = Nothing
) As Boolean
public:
virtual bool RegisterAssembly(
    String^ name,
    ProjectId^ projectId = nullptr
)
abstract RegisterAssembly :
        name : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool
override RegisterAssembly :
        name : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

name
Type: SystemString
Assembly name.
projectId (Optional)
Type: ProjectId
Specifies project to add reference to.

Return Value

Type: Boolean
True if succeed otherwise false.

Implements

IRoslynSolutionRegisterAssembly(String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RegisterCodeFiles Method

RoslynSolutionRegisterCodeFiles Method
Makes types declared in given source files accessible for code completion.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RegisterCodeFiles(
    string[] files,
    ProjectId projectId = null
)
Public Sub RegisterCodeFiles (
    files As String(),
    Optional projectId As ProjectId = Nothing
)
public:
virtual void RegisterCodeFiles(
    array<String^>^ files,
    ProjectId^ projectId = nullptr
) sealed
abstract RegisterCodeFiles :
        files : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit
override RegisterCodeFiles :
        files : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit

Parameters

files
Type: SystemString
files containing source code.
projectId (Optional)
Type: ProjectId
Specifies project to add files to.

Implements

IRoslynSolutionRegisterCodeFiles(String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RegisterNamespaces Method

RoslynSolutionRegisterNamespaces Method
Registers global namespaces.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RegisterNamespaces(
    string[] nameSpaces,
    ProjectId projectId = null
)
Public Overridable Function RegisterNamespaces (
    nameSpaces As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
public:
virtual bool RegisterNamespaces(
    array<String^>^ nameSpaces,
    ProjectId^ projectId = nullptr
)
abstract RegisterNamespaces :
        nameSpaces : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool
override RegisterNamespaces :
        nameSpaces : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

nameSpaces
Type: SystemString
List of global namespaces
projectId (Optional)
Type: ProjectId
Specifies Project to search for the document.

Return Value

Type: Boolean
True if succeed otherwise false.

Implements

IRoslynSolutionRegisterNamespaces(String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RegisterProjectReferences Method

RoslynSolutionRegisterProjectReferences Method
When implemented by a class, replaces project references with the new ones.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RegisterProjectReferences(
    string[] projectReferences,
    ProjectId projectId = null
)
Public Overridable Function RegisterProjectReferences (
    projectReferences As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
public:
virtual bool RegisterProjectReferences(
    array<String^>^ projectReferences,
    ProjectId^ projectId = nullptr
)
abstract RegisterProjectReferences :
        projectReferences : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool
override RegisterProjectReferences :
        projectReferences : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

projectReferences
Type: SystemString
Project references.
projectId (Optional)
Type: ProjectId
Specifies project to add references to.

Return Value

Type: Boolean
True if succeed otherwise false.

Implements

IRoslynSolutionRegisterProjectReferences(String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RemoveDocument Method

RoslynSolutionRemoveDocument Method
Overload List
 | Name | Description
Public method | RemoveDocument(DocumentId) | Removes specified Microsoft.CodeAnalysis.Document from the project.
Public method | RemoveDocument(String, ProjectId) | Removes specified document from the project.
Top
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RemoveDocument Method (DocumentId)

RoslynSolutionRemoveDocument Method (DocumentId)
Removes specified Microsoft.CodeAnalysis.Document from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RemoveDocument(
    DocumentId documentId
)
Public Overridable Function RemoveDocument (
    documentId As DocumentId
) As Boolean
public:
virtual bool RemoveDocument(
    DocumentId^ documentId
)
abstract RemoveDocument :
        documentId : DocumentId -> bool
override RemoveDocument :
        documentId : DocumentId -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.DocumentId to remove.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IRoslynSolutionRemoveDocument(DocumentId)
See Also

Reference

RoslynSolution Class
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RemoveDocument Method (String, ProjectId)

RoslynSolutionRemoveDocument Method (String, ProjectId)
Removes specified document from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RemoveDocument(
    string fileName,
    ProjectId projectId = null
)
Public Overridable Function RemoveDocument (
    fileName As String,
    Optional projectId As ProjectId = Nothing
) As Boolean
public:
virtual bool RemoveDocument(
    String^ fileName,
    ProjectId^ projectId = nullptr
)
abstract RemoveDocument :
        fileName : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool
override RemoveDocument :
        fileName : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

fileName
Type: SystemString
File path to remove.
projectId (Optional)
Type: ProjectId
Specifies project to search for the document.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IRoslynSolutionRemoveDocument(String, ProjectId)
See Also

Reference

RoslynSolution Class
RemoveDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RemoveNotifier Method

RoslynSolutionRemoveNotifier Method
Exclude specified handler from notification handlers list.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveNotifier(
    INotifier sender
)
Public Overridable Sub RemoveNotifier (
    sender As INotifier
)
public:
virtual void RemoveNotifier(
    INotifier^ sender
)
abstract RemoveNotifier :
        sender : INotifier -> unit
override RemoveNotifier :
        sender : INotifier -> unit

Parameters

sender
Type: Alternet.CommonINotifier
Specifies an object that can respond a notification.

Implements

INotifyRemoveNotifier(INotifier)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.RemoveProject Method

RoslynSolutionRemoveProject Method
Removes project from the solution

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool RemoveProject(
    ProjectId projectId
)
Public Overridable Function RemoveProject (
    projectId As ProjectId
) As Boolean
public:
virtual bool RemoveProject(
    ProjectId^ projectId
)
abstract RemoveProject :
        projectId : ProjectId -> bool
override RemoveProject :
        projectId : ProjectId -> bool

Parameters

projectId
Type: ProjectId

Return Value

Type: Boolean

Implements

IRoslynSolutionRemoveProject(ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.ReplaceCodeFile Method

RoslynSolutionReplaceCodeFile Method
Updates code completion with changes in source file.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReplaceCodeFile(
    string file,
    string text,
    ProjectId projectId
)
Public Sub ReplaceCodeFile (
    file As String,
    text As String,
    projectId As ProjectId
)
public:
virtual void ReplaceCodeFile(
    String^ file,
    String^ text,
    ProjectId^ projectId
) sealed
abstract ReplaceCodeFile :
        file : string *
        text : string *
        projectId : ProjectId -> unit
override ReplaceCodeFile :
        file : string *
        text : string *
        projectId : ProjectId -> unit

Parameters

file
Type: SystemString
File containing source code.
text
Type: SystemString
Source code text.
projectId
Type: ProjectId
Specifies project search for the file.

Implements

IRoslynSolutionReplaceCodeFile(String, String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.ReplaceDocument Method

RoslynSolutionReplaceDocument Method
Overload List
 | Name | Description
Public method | ReplaceDocument(DocumentId, SourceText) | Updates Microsoft.CodeAnalysis.Document to have the text specified.
Public method | ReplaceDocument(DocumentId, String) | Updates Microsoft.CodeAnalysis.Document to have the text specified.
Top
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.ReplaceDocument Method (DocumentId, SourceText)

RoslynSolutionReplaceDocument Method (DocumentId, SourceText)
Updates Microsoft.CodeAnalysis.Document to have the text specified.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReplaceDocument(
    DocumentId documentId,
    SourceText text
)
Public Overridable Function ReplaceDocument (
    documentId As DocumentId,
    text As SourceText
) As Boolean
public:
virtual bool ReplaceDocument(
    DocumentId^ documentId,
    SourceText^ text
)
abstract ReplaceDocument :
        documentId : DocumentId *
        text : SourceText -> bool
override ReplaceDocument :
        documentId : DocumentId *
        text : SourceText -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.DocumentId
text
Type: SourceText
New Microsoft.CodeAnalysis.Document text.

Return Value

Type: Boolean
True if document has been replaced, otherwise false.

Implements

IRoslynSolutionReplaceDocument(DocumentId, SourceText)
See Also

Reference

RoslynSolution Class
ReplaceDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.ReplaceDocument Method (DocumentId, String)

RoslynSolutionReplaceDocument Method (DocumentId, String)
Updates Microsoft.CodeAnalysis.Document to have the text specified.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReplaceDocument(
    DocumentId documentId,
    string text
)
Public Overridable Function ReplaceDocument (
    documentId As DocumentId,
    text As String
) As Boolean
public:
virtual bool ReplaceDocument(
    DocumentId^ documentId,
    String^ text
)
abstract ReplaceDocument :
        documentId : DocumentId *
        text : string -> bool
override ReplaceDocument :
        documentId : DocumentId *
        text : string -> bool

Parameters

documentId
Type: DocumentId
Microsoft.CodeAnalysis.Document
text
Type: SystemString
New Microsoft.CodeAnalysis.DocumentId text.

Return Value

Type: Boolean
True if document has been replaced, otherwise false.

Implements

IRoslynSolutionReplaceDocument(DocumentId, String)
See Also

Reference

RoslynSolution Class
ReplaceDocument Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.ResolveAssemblyName Method

RoslynSolutionResolveAssemblyName Method
Try to find real assembly name matches the given name.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ResolveAssemblyName(
    string name
)
Public Overridable Function ResolveAssemblyName (
    name As String
) As String
public:
virtual String^ ResolveAssemblyName(
    String^ name
)
abstract ResolveAssemblyName :
        name : string -> string
override ResolveAssemblyName :
        name : string -> string

Parameters

name
Type: SystemString
Short assembly name.

Return Value

Type: String
Full assembly name if succeed; otherwise empty string.
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.ResolveProjectId Method

RoslynSolutionResolveProjectId Method

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ProjectId ResolveProjectId(
    string reference
)
Public Overridable Function ResolveProjectId (
    reference As String
) As ProjectId
public:
virtual ProjectId^ ResolveProjectId(
    String^ reference
)
abstract ResolveProjectId :
        reference : string -> ProjectId
override ResolveProjectId :
        reference : string -> ProjectId

Parameters

reference
Type: SystemString

Return Value

Type: ProjectId
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.SetConditionalsForProject Method

RoslynSolutionSetConditionalsForProject Method
Sets conditional compilation symbols for given project

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetConditionalsForProject(
    ProjectId projectId,
    string[] conditionals
)
Public Sub SetConditionalsForProject (
    projectId As ProjectId,
    conditionals As String()
)
public:
void SetConditionalsForProject(
    ProjectId^ projectId,
    array<String^>^ conditionals
)
member SetConditionalsForProject :
        projectId : ProjectId *
        conditionals : string[] -> unit

Parameters

projectId
Type: ProjectId
conditionals
Type: SystemString
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.UnregisterAssemblies Method

RoslynSolutionUnregisterAssemblies Method
Unregisters assemblies from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UnregisterAssemblies(
    string[] references,
    ProjectId projectId = null
)
Public Function UnregisterAssemblies (
    references As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
public:
virtual bool UnregisterAssemblies(
    array<String^>^ references,
    ProjectId^ projectId = nullptr
) sealed
abstract UnregisterAssemblies :
        references : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool
override UnregisterAssemblies :
        references : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

references
Type: SystemString
List of assembly name.
projectId (Optional)
Type: ProjectId
Specifies project to remove reference from.

Return Value

Type: Boolean
True if succeed otherwise false.

Implements

IRoslynSolutionUnregisterAssemblies(String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.UnregisterAssembly Method

RoslynSolutionUnregisterAssembly Method
Unregisters assembly from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UnregisterAssembly(
    string name,
    ProjectId projectId = null
)
Public Function UnregisterAssembly (
    name As String,
    Optional projectId As ProjectId = Nothing
) As Boolean
public:
virtual bool UnregisterAssembly(
    String^ name,
    ProjectId^ projectId = nullptr
) sealed
abstract UnregisterAssembly :
        name : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool
override UnregisterAssembly :
        name : string *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

name
Type: SystemString
Assembly name.
projectId (Optional)
Type: ProjectId
Specifies project to remove reference from.

Return Value

Type: Boolean
True if assembly has been unregistered, otherwise false.

Implements

IRoslynSolutionUnregisterAssembly(String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.UnregisterCodeFiles Method

RoslynSolutionUnregisterCodeFiles Method
Removes types declared in given source files from being accessible code completion.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnregisterCodeFiles(
    string[] files,
    ProjectId projectId = null
)
Public Sub UnregisterCodeFiles (
    files As String(),
    Optional projectId As ProjectId = Nothing
)
public:
virtual void UnregisterCodeFiles(
    array<String^>^ files,
    ProjectId^ projectId = nullptr
) sealed
abstract UnregisterCodeFiles :
        files : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit
override UnregisterCodeFiles :
        files : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> unit

Parameters

files
Type: SystemString
files containing source code.
projectId (Optional)
Type: ProjectId
Specifies project to remove files from.

Implements

IRoslynSolutionUnregisterCodeFiles(String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.UnregisterProjectReferences Method

RoslynSolutionUnregisterProjectReferences Method
When implemented by a class, unregisters assemblies from the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool UnregisterProjectReferences(
    string[] projectReferences,
    ProjectId projectId = null
)
Public Overridable Function UnregisterProjectReferences (
    projectReferences As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
public:
virtual bool UnregisterProjectReferences(
    array<String^>^ projectReferences,
    ProjectId^ projectId = nullptr
)
abstract UnregisterProjectReferences :
        projectReferences : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool
override UnregisterProjectReferences :
        projectReferences : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

projectReferences
Type: SystemString
Project references.
projectId (Optional)
Type: ProjectId
Specifies project to remove references from.

Return Value

Type: Boolean
True if succeed otherwise false.

Implements

IRoslynSolutionUnregisterProjectReferences(String, ProjectId)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.Update Method

RoslynSolutionUpdate Method
Updates an object state.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
virtual void Update() sealed
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.WithDefaultAssemblies Method

RoslynSolutionWithDefaultAssemblies Method
Registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add reference to.

Return Value

Type: IRoslynSolution
IRoslynSolution instance with default assemblies being registered for code completion

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IRoslynSolution WithDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms,
    bool keepExisting = false,
    ProjectId projectId = null,
    TargetFramework targetFramework = null
)
Public Overridable Function WithDefaultAssemblies (
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms,
    Optional keepExisting As Boolean = false,
    Optional projectId As ProjectId = Nothing,
    Optional targetFramework As TargetFramework = Nothing
) As IRoslynSolution
public:
virtual IRoslynSolution^ WithDefaultAssemblies(
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms,
    bool keepExisting = false,
    ProjectId^ projectId = nullptr,
    TargetFramework^ targetFramework = nullptr
)
abstract WithDefaultAssemblies :
        ?technology : TechnologyEnvironment *
        ?keepExisting : bool *
        ?projectId : ProjectId *
        ?targetFramework : TargetFramework
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
        let _projectId = defaultArg projectId null
        let _targetFramework = defaultArg targetFramework null
*)
-> IRoslynSolution
override WithDefaultAssemblies :
        ?technology : TechnologyEnvironment *
        ?keepExisting : bool *
        ?projectId : ProjectId *
        ?targetFramework : TargetFramework
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
        let _keepExisting = defaultArg keepExisting false
        let _projectId = defaultArg projectId null
        let _targetFramework = defaultArg targetFramework null
*)
-> IRoslynSolution

Parameters

technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
keepExisting (Optional)
Type: SystemBoolean
projectId (Optional)
Type: ProjectId
targetFramework (Optional)
Type: Alternet.Common.DotNet.ProjectsTargetFramework

Return Value

Type: IRoslynSolution

Implements

IRoslynSolutionWithDefaultAssemblies(TechnologyEnvironment, Boolean, ProjectId, TargetFramework)
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution Properties

RoslynSolution Properties

The RoslynSolution type exposes the following members.

Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths.
Public property | BaseDirectory | Gets or sets solution base directory.
Public property | Conditionals | When implemented by a class, gets or sets a collection of conditional symbols
Public property | CustomXMLDocPath | Gets a custom xml documentation path.
Public property | FrameworkPath | Gets or sets path to the .NET Framework assemblies
Public property | ProjectId | Gets a current Microsoft.CodeAnalysis.ProjectId.
Public property | ScriptSearchPaths | Gets or sets a collection of script source search paths.
Public property | Solution | Gets a current Microsoft.CodeAnalysis.Project.
Public property | SourceKind | Gets kind (regular or script) of the source code.
Public property | TargetFrameworkVersion | Gets or sets version of the .NET Framework to use with the methods in Framework Location Helper.
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.
Public property | Workspace | Gets a current project Microsoft.CodeAnalysis.Workspace.
Top
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.AssemblySearchPaths Property

RoslynSolutionAssemblySearchPaths Property
Gets or sets a collection of assembly search paths.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string[] AssemblySearchPaths { get; set; }
Public Overridable Property AssemblySearchPaths As String()
    Get
    Set
public:
virtual property array<String^>^ AssemblySearchPaths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract AssemblySearchPaths : string[] with get, set
override AssemblySearchPaths : string[] with get, set

Property Value

Type: String

Implements

IRoslynSolutionAssemblySearchPaths
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.BaseDirectory Property

RoslynSolutionBaseDirectory Property
Gets or sets solution base directory.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BaseDirectory { get; set; }
Public Property BaseDirectory As String
    Get
    Set
public:
virtual property String^ BaseDirectory {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract BaseDirectory : string with get, set
override BaseDirectory : string with get, set

Property Value

Type: String

Implements

IRoslynSolutionBaseDirectory
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.Conditionals Property

RoslynSolutionConditionals Property
When implemented by a class, gets or sets a collection of conditional symbols

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string[] Conditionals { get; set; }
Public Overridable Property Conditionals As String()
    Get
    Set
public:
virtual property array<String^>^ Conditionals {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract Conditionals : string[] with get, set
override Conditionals : string[] with get, set

Property Value

Type: String

Implements

IRoslynSolutionConditionals
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.CustomXMLDocPath Property

RoslynSolutionCustomXMLDocPath Property
Gets a custom xml documentation path.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CustomXMLDocPath { get; set; }
Public Property CustomXMLDocPath As String
    Get
    Set
public:
virtual property String^ CustomXMLDocPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract CustomXMLDocPath : string with get, set
override CustomXMLDocPath : string with get, set

Property Value

Type: String

Implements

IRoslynSolutionCustomXMLDocPath
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.FrameworkPath Property

RoslynSolutionFrameworkPath Property
Gets or sets path to the .NET Framework assemblies

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FrameworkPath { get; set; }
Public Property FrameworkPath As String
    Get
    Set
public:
virtual property String^ FrameworkPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FrameworkPath : string with get, set
override FrameworkPath : string with get, set

Property Value

Type: String

Implements

IRoslynSolutionFrameworkPath
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.ProjectId Property

RoslynSolutionProjectId Property
Gets a current Microsoft.CodeAnalysis.ProjectId.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectId ProjectId { get; }
Public ReadOnly Property ProjectId As ProjectId
    Get
public:
virtual property ProjectId^ ProjectId {
    ProjectId^ get () sealed;
}
abstract ProjectId : ProjectId with get
override ProjectId : ProjectId with get

Property Value

Type: ProjectId

Implements

IRoslynSolutionProjectId
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.ScriptSearchPaths Property

RoslynSolutionScriptSearchPaths Property
Gets or sets a collection of script source search paths.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string[] ScriptSearchPaths { get; set; }
Public Overridable Property ScriptSearchPaths As String()
    Get
    Set
public:
virtual property array<String^>^ ScriptSearchPaths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract ScriptSearchPaths : string[] with get, set
override ScriptSearchPaths : string[] with get, set

Property Value

Type: String

Implements

IRoslynSolutionScriptSearchPaths
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.Solution Property

RoslynSolutionSolution Property
Gets a current Microsoft.CodeAnalysis.Project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Solution Solution { get; }
Public ReadOnly Property Solution As Solution
    Get
public:
virtual property Solution^ Solution {
    Solution^ get () sealed;
}
abstract Solution : Solution with get
override Solution : Solution with get

Property Value

Type: Solution

Implements

IRoslynSolutionSolution
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.SourceKind Property

RoslynSolutionSourceKind Property
Gets kind (regular or script) of the source code.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SourceCodeKind SourceKind { get; }
Public ReadOnly Property SourceKind As SourceCodeKind
    Get
public:
virtual property SourceCodeKind SourceKind {
    SourceCodeKind get () sealed;
}
abstract SourceKind : SourceCodeKind with get
override SourceKind : SourceCodeKind with get

Property Value

Type: SourceCodeKind

Implements

IRoslynSolutionSourceKind
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.TargetFrameworkVersion Property

RoslynSolutionTargetFrameworkVersion Property
Gets or sets version of the .NET Framework to use with the methods in Framework Location Helper.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetNETFrameworkVersion TargetFrameworkVersion { get; set; }
Public Property TargetFrameworkVersion As TargetNETFrameworkVersion
    Get
    Set
public:
property TargetNETFrameworkVersion TargetFrameworkVersion {
    TargetNETFrameworkVersion get ();
    void set (TargetNETFrameworkVersion value);
}
member TargetFrameworkVersion : TargetNETFrameworkVersion with get, set

Property Value

Type: TargetNETFrameworkVersion
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.UpdateCount Property

RoslynSolutionUpdateCount Property
Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UpdateCount { get; }
Public ReadOnly Property UpdateCount As Integer
    Get
public:
virtual property int UpdateCount {
    int get () sealed;
}
abstract UpdateCount : int with get
override UpdateCount : int with get

Property Value

Type: Int32

Implements

IUpdateUpdateCount
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


RoslynSolution.Workspace Property

RoslynSolutionWorkspace Property
Gets a current project Microsoft.CodeAnalysis.Workspace.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Workspace Workspace { get; }
Public ReadOnly Property Workspace As Workspace
    Get
public:
virtual property Workspace^ Workspace {
    Workspace^ get () sealed;
}
abstract Workspace : Workspace with get
override Workspace : Workspace with get

Property Value

Type: Workspace

Implements

IRoslynSolutionWorkspace
See Also

Reference

RoslynSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository Class

VbRepository Class
Represents properties and methods to perform code completion functionality intended to use for the Visual Basic language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.Roslyn.CodeCompletionRoslynRepository
Alternet.Syntax.Parsers.Roslyn.CodeCompletionVbRepository

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbRepository : RoslynRepository
Public Class VbRepository
    Inherits RoslynRepository
public ref class VbRepository : public RoslynRepository
type VbRepository =
    class
        inherit RoslynRepository
    end

The VbRepository type exposes the following members.

Constructors
 | Name | Description
Public method | VbRepository | Initializes a new instance of the VbRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | AddDocument(String, SourceText) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | AddDocument(String, String) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | AddFileReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | AddImageReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | AddReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | BeginUpdate | WPrevents object state updating until calling EndUpdate method. (Inherited from RoslynRepository.)
Public method | CloseDocument | Closes document which was opened in roslyn workspace. (Inherited from RoslynRepository.)
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Overrides RoslynRepositoryCodeCompletionAsync(Point, CodeCompletionArgs, CancellationToken).)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from RoslynRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from RoslynRepository.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from RoslynRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionService, Document, CompletionList, IListMembers, Int32) | (Inherited from RoslynRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillParameterInfo | (Inherited from RoslynRepository.)
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) | (Inherited from RoslynRepository.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynRepository.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | Locates all references to the symbol in the text. (Inherited from RoslynRepository.)
Public method | GetBreakpointStatementAtPosition | Gets breakpoint statement range at pecified position. (Inherited from RoslynRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from RoslynRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetDiagnostics | Get all the errors within the syntax tree associated with this object. (Inherited from RoslynRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetModel | Gets the semantic model and syntax tree for this document. (Inherited from RoslynRepository.)
Public method | GetNodeAt(Point) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified position. (Inherited from RoslynRepository.)
Public method | GetNodeAt(Int32) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified line. (Inherited from RoslynRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPosFromPosition | Converts given position into absolute text coordinate. (Inherited from RoslynRepository.)
Public method | GetPositionFromPos | Converts given pos into Point coordinate. (Inherited from RoslynRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynRepository.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynRepository.)
Public method | GetSmartIndent | Returns indentation string for specified line. (Inherited from RoslynRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment. (Overrides RoslynRepositoryGetXmlComment.)
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined. (Overrides RoslynRepositoryIsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan).)
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined. (Overrides RoslynRepositoryIsCollapsible(SyntaxNode, String, TextSpan, Boolean).)
Public method | IsContentDivider | (Overrides RoslynRepositoryIsContentDivider(SyntaxNode, TextSpan).)
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node. (Overrides RoslynRepositoryIsStructureGuideNode(SyntaxNode, TextSpan).)
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides RoslynRepositoryProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynRepository.)
Public method | RegisterAssemblies | Registers assemblies in the project. (Inherited from RoslynRepository.)
Public method | RegisterAssembly | Registers assembly in the project. (Inherited from RoslynRepository.)
Public method | RegisterCodeFiles | Makes types declared in given source files accessible for code completion. (Inherited from RoslynRepository.)
Public method | RegisterDefaultAssemblies | Registers default assemblies in the project. (Inherited from RoslynRepository.)
Public method | RegisterDefaultNamespaces | Registers default namespaces in the project. (Overrides RoslynRepositoryRegisterDefaultNamespaces(TechnologyEnvironment).)
Public method | RegisterNamespaces | Registers global namespaces in the project. (Inherited from RoslynRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RemoveDocument | Removes document from document collection. (Inherited from RoslynRepository.)
Public method | RemoveDocument(DocumentId) | Removes current document from document collection. (Inherited from RoslynRepository.)
Public method | RemoveDocument(String) | Removes document from document collection. (Inherited from RoslynRepository.)
Public method | ReplaceDocument(DocumentId, SourceText) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | ReplaceDocument(DocumentId, String) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | SmartCapitalize | Capitalizes block of text. (Inherited from RoslynRepository.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynRepository.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Overrides RoslynRepositorySmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project. (Inherited from RoslynRepository.)
Public method | UnregisterAssembly | Unregisters assembly from the project. (Inherited from RoslynRepository.)
Public method | UnregisterCodeFiles | Removes types declared in given source files from being accessible code completion. (Inherited from RoslynRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | Update | Updates an object state. (Inherited from RoslynRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a Microsoft.CodeAnalysis.Document contains code text. (Inherited from RoslynRepository.)
Public property | DocumentId | Represents a Microsoft.CodeAnalysis.DocumentId contains code text. (Inherited from RoslynRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from RoslynRepository.)
Public property | ImagesHighDpi | (Inherited from RoslynRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Model | Represents a Microsoft.CodeAnalysis.SemanticModel describes code text. (Inherited from RoslynRepository.)
Public property | ProjectId | Represents a Microsoft.CodeAnalysis.ProjectId that contains document. (Inherited from RoslynRepository.)
Public property | ProjectName | gets or sets Project name containing document (Inherited from RoslynRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | Solution | Gets RoslynSolution associated with this Repository. (Inherited from RoslynRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Text | Represents a Microsoft.CodeAnalysis.SourceText describes code text. (Inherited from RoslynRepository.)
Public property | Tree | Represents a Microsoft.CodeAnalysis.SyntaxTree represents parsed code text. (Inherited from RoslynRepository.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from RoslynRepository.)
Top
Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options. (Inherited from RoslynRepository.)
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository Constructor

VbRepository Constructor
Initializes a new instance of the VbRepository class with specified settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbRepository(
    ISyntaxParser owner,
    IRoslynSolution roslynSolution,
    bool caseSensitive
)
Public Sub New (
    owner As ISyntaxParser,
    roslynSolution As IRoslynSolution,
    caseSensitive As Boolean
)
public:
VbRepository(
    ISyntaxParser^ owner,
    IRoslynSolution^ roslynSolution,
    bool caseSensitive
)
new :
        owner : ISyntaxParser *
        roslynSolution : IRoslynSolution *
        caseSensitive : bool -> VbRepository

Parameters

owner
Type: Alternet.SyntaxISyntaxParser
Specifies parser that owns this repository.
roslynSolution
Type: Alternet.Syntax.Parsers.RoslynIRoslynSolution
IRoslynSolution for this new instance.
caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository Methods

VbRepository Methods

The VbRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddDocument(String, SourceText) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | AddDocument(String, String) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | AddFileReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | AddImageReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | AddReference | Adds metadata reference to the project (Inherited from RoslynRepository.)
Public method | BeginUpdate | WPrevents object state updating until calling EndUpdate method. (Inherited from RoslynRepository.)
Public method | CloseDocument | Closes document which was opened in roslyn workspace. (Inherited from RoslynRepository.)
Public method | CodeCompletionAsync | Performs code completion for the specified text representing language element. (Overrides RoslynRepositoryCodeCompletionAsync(Point, CodeCompletionArgs, CancellationToken).)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from RoslynRepository.)
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from RoslynRepository.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from RoslynRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(CompletionService, Document, CompletionList, IListMembers, Int32) | (Inherited from RoslynRepository.)
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillParameterInfo | (Inherited from RoslynRepository.)
Public method | FindDeclaration(String, ISyntaxNode, Point) | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration(SemanticModel, Point, Boolean) | (Inherited from RoslynRepository.)
Public method | FindImplementations | Finds the symbols that implement an interface or interface member. (Inherited from RoslynRepository.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | FindReferences(ISymbol, CancellationToken, Boolean) | Locates all references to the symbol in the text. (Inherited from RoslynRepository.)
Public method | GetBreakpointStatementAtPosition | Gets breakpoint statement range at pecified position. (Inherited from RoslynRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from RoslynRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetDiagnostics | Get all the errors within the syntax tree associated with this object. (Inherited from RoslynRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetModel | Gets the semantic model and syntax tree for this document. (Inherited from RoslynRepository.)
Public method | GetNodeAt(Point) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified position. (Inherited from RoslynRepository.)
Public method | GetNodeAt(Int32) | Gets Microsoft.CodeAnalysis.SyntaxNode at specified line. (Inherited from RoslynRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPosFromPosition | Converts given position into absolute text coordinate. (Inherited from RoslynRepository.)
Public method | GetPositionFromPos | Converts given pos into Point coordinate. (Inherited from RoslynRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from RoslynRepository.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from RoslynRepository.)
Public method | GetSmartIndent | Returns indentation string for specified line. (Inherited from RoslynRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment. (Overrides RoslynRepositoryGetXmlComment.)
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined. (Overrides RoslynRepositoryIsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan).)
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined. (Overrides RoslynRepositoryIsCollapsible(SyntaxNode, String, TextSpan, Boolean).)
Public method | IsContentDivider | (Overrides RoslynRepositoryIsContentDivider(SyntaxNode, TextSpan).)
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node. (Overrides RoslynRepositoryIsStructureGuideNode(SyntaxNode, TextSpan).)
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Overrides RoslynRepositoryProcessAutoComplete(String, Point, String).)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from RoslynRepository.)
Public method | RegisterAssemblies | Registers assemblies in the project. (Inherited from RoslynRepository.)
Public method | RegisterAssembly | Registers assembly in the project. (Inherited from RoslynRepository.)
Public method | RegisterCodeFiles | Makes types declared in given source files accessible for code completion. (Inherited from RoslynRepository.)
Public method | RegisterDefaultAssemblies | Registers default assemblies in the project. (Inherited from RoslynRepository.)
Public method | RegisterDefaultNamespaces | Registers default namespaces in the project. (Overrides RoslynRepositoryRegisterDefaultNamespaces(TechnologyEnvironment).)
Public method | RegisterNamespaces | Registers global namespaces in the project. (Inherited from RoslynRepository.)
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RemoveDocument | Removes document from document collection. (Inherited from RoslynRepository.)
Public method | RemoveDocument(DocumentId) | Removes current document from document collection. (Inherited from RoslynRepository.)
Public method | RemoveDocument(String) | Removes document from document collection. (Inherited from RoslynRepository.)
Public method | ReplaceDocument(DocumentId, SourceText) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | ReplaceDocument(DocumentId, String) | Adds a new document or replaces existing document with specified settings. (Inherited from RoslynRepository.)
Public method | SmartCapitalize | Capitalizes block of text. (Inherited from RoslynRepository.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynRepository.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Overrides RoslynRepositorySmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterAssemblies | Unregisters assemblies from the project. (Inherited from RoslynRepository.)
Public method | UnregisterAssembly | Unregisters assembly from the project. (Inherited from RoslynRepository.)
Public method | UnregisterCodeFiles | Removes types declared in given source files from being accessible code completion. (Inherited from RoslynRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Public method | Update | Updates an object state. (Inherited from RoslynRepository.)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.CodeCompletionAsync Method

VbRepositoryCodeCompletionAsync Method
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Task CodeCompletionAsync(
    Point position,
    CodeCompletionArgs e,
    CancellationToken ct
)
Public Overrides Function CodeCompletionAsync (
    position As Point,
    e As CodeCompletionArgs,
    ct As CancellationToken
) As Task
public:
virtual Task^ CodeCompletionAsync(
    Point position,
    CodeCompletionArgs^ e,
    CancellationToken ct
) override
abstract CodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs *
        ct : CancellationToken -> Task
override CodeCompletionAsync :
        position : Point *
        e : CodeCompletionArgs *
        ct : CancellationToken -> Task

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.
ct
Type: System.ThreadingCancellationToken

Return Value

Type: Task

Implements

IRoslynRepositoryCodeCompletionAsync(Point, CodeCompletionArgs, CancellationToken)
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.GetXmlComment Method

VbRepositoryGetXmlComment Method
Represents beginning of XML comment.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetXmlComment()
Public Overrides Function GetXmlComment As String
public:
virtual String^ GetXmlComment() override
abstract GetXmlComment : unit -> string
override GetXmlComment : unit -> string

Return Value

Type: String
String determines XML comment start.

Implements

IRoslynRepositoryGetXmlComment
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.IsCollapsible Method

VbRepositoryIsCollapsible Method
Overload List
 | Name | Description
Public method | IsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined. (Overrides RoslynRepositoryIsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan).)
Public method | IsCollapsible(SyntaxNode, String, TextSpan, Boolean) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined. (Overrides RoslynRepositoryIsCollapsible(SyntaxNode, String, TextSpan, Boolean).)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.IsCollapsible Method (IEnumerable(SyntaxTrivia), String, TextSpan)

VbRepositoryIsCollapsible Method (IEnumerableSyntaxTrivia, String, TextSpan)
Indicates whether specified Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCollapsible(
    IEnumerable<SyntaxTrivia> triviaList,
    out string outlineText,
    out TextSpan span
)
Public Overrides Function IsCollapsible (
    triviaList As IEnumerable(Of SyntaxTrivia),
    <OutAttribute> ByRef outlineText As String,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
public:
virtual bool IsCollapsible(
    IEnumerable<SyntaxTrivia>^ triviaList,
    [OutAttribute] String^% outlineText,
    [OutAttribute] TextSpan% span
) override
abstract IsCollapsible :
        triviaList : IEnumerable<SyntaxTrivia> *
        outlineText : string byref *
        span : TextSpan byref -> bool
override IsCollapsible :
        triviaList : IEnumerable<SyntaxTrivia> *
        outlineText : string byref *
        span : TextSpan byref -> bool

Parameters

triviaList
Type: System.Collections.GenericIEnumerableSyntaxTrivia
Microsoft.CodeAnalysis.SyntaxTriviaList to check.
outlineText
Type: SystemString
Output parameter receives text substituting collapsed outline section.
span
Type: TextSpan
Output parameter receives outline range.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxTrivia list can be outlined; otherwise false.

Implements

IRoslynRepositoryIsCollapsible(IEnumerableSyntaxTrivia, String, TextSpan)
See Also

Reference

VbRepository Class
IsCollapsible Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.IsCollapsible Method (SyntaxNode, String, TextSpan, Boolean)

VbRepositoryIsCollapsible Method (SyntaxNode, String, TextSpan, Boolean)
Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode can be outlined.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCollapsible(
    SyntaxNode node,
    out string outlineText,
    out TextSpan span,
    bool checkStatements
)
Public Overrides Function IsCollapsible (
    node As SyntaxNode,
    <OutAttribute> ByRef outlineText As String,
    <OutAttribute> ByRef span As TextSpan,
    checkStatements As Boolean
) As Boolean
public:
virtual bool IsCollapsible(
    SyntaxNode^ node,
    [OutAttribute] String^% outlineText,
    [OutAttribute] TextSpan% span,
    bool checkStatements
) override
abstract IsCollapsible :
        node : SyntaxNode *
        outlineText : string byref *
        span : TextSpan byref *
        checkStatements : bool -> bool
override IsCollapsible :
        node : SyntaxNode *
        outlineText : string byref *
        span : TextSpan byref *
        checkStatements : bool -> bool

Parameters

node
Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode to check.
outlineText
Type: SystemString
Output parameter receives text substituting collapsed outline section.
span
Type: TextSpan
Output parameter receives outline range.
checkStatements
Type: SystemBoolean
Indicates whether statement node also should be processed.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxNode can be outlined; otherwise false.

Implements

IRoslynRepositoryIsCollapsible(SyntaxNode, String, TextSpan, Boolean)
See Also

Reference

VbRepository Class
IsCollapsible Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.IsContentDivider Method

VbRepositoryIsContentDivider Method

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsContentDivider(
    SyntaxNode node,
    out TextSpan span
)
Public Overrides Function IsContentDivider (
    node As SyntaxNode,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
public:
virtual bool IsContentDivider(
    SyntaxNode^ node,
    [OutAttribute] TextSpan% span
) override
abstract IsContentDivider :
        node : SyntaxNode *
        span : TextSpan byref -> bool
override IsContentDivider :
        node : SyntaxNode *
        span : TextSpan byref -> bool

Parameters

node
Type: SyntaxNode
span
Type: TextSpan

Return Value

Type: Boolean

Implements

IRoslynRepositoryIsContentDivider(SyntaxNode, TextSpan)
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.IsStructureGuideNode Method

VbRepositoryIsStructureGuideNode Method
Overload List
 | Name | Description
Public method | IsStructureGuideNode(SyntaxNode, TextSpan) | Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node. (Overrides RoslynRepositoryIsStructureGuideNode(SyntaxNode, TextSpan).)
Public method | IsStructureGuideNode(ISyntaxNode, IRange) | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.IsStructureGuideNode Method (SyntaxNode, TextSpan)

VbRepositoryIsStructureGuideNode Method (SyntaxNode, TextSpan)
Indicates whether specified Microsoft.CodeAnalysis.SyntaxNode is guide node.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsStructureGuideNode(
    SyntaxNode node,
    out TextSpan span
)
Public Overrides Function IsStructureGuideNode (
    node As SyntaxNode,
    <OutAttribute> ByRef span As TextSpan
) As Boolean
public:
virtual bool IsStructureGuideNode(
    SyntaxNode^ node,
    [OutAttribute] TextSpan% span
) override
abstract IsStructureGuideNode :
        node : SyntaxNode *
        span : TextSpan byref -> bool
override IsStructureGuideNode :
        node : SyntaxNode *
        span : TextSpan byref -> bool

Parameters

node
Type: SyntaxNode
Microsoft.CodeAnalysis.SyntaxNode to check.
span
Type: TextSpan
Output parameter receives guide range.

Return Value

Type: Boolean
True if Microsoft.CodeAnalysis.SyntaxNode is guide node; otherwise false.

Implements

IRoslynRepositoryIsStructureGuideNode(SyntaxNode, TextSpan)
See Also

Reference

VbRepository Class
IsStructureGuideNode Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.ProcessAutoComplete Method

VbRepositoryProcessAutoComplete Method
Checks whether end-of-block code needs inserting.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ProcessAutoComplete(
    string text,
    Point position,
    out string code
)
Public Overrides Function ProcessAutoComplete (
    text As String,
    position As Point,
    <OutAttribute> ByRef code As String
) As Boolean
public:
virtual bool ProcessAutoComplete(
    String^ text,
    Point position,
    [OutAttribute] String^% code
) override
abstract ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool
override ProcessAutoComplete :
        text : string *
        position : Point *
        code : string byref -> bool

Parameters

text
Type: SystemString
Specifies source text.
position
Type: System.DrawingPoint
Specifies current position in text.
code
Type: SystemString
Output parameter to return code fragment to be inserted.

Return Value

Type: Boolean
True if autocompletion of end-of-block needed; otherwise false.

Implements

IRoslynRepositoryProcessAutoComplete(String, Point, String)
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.RegisterDefaultNamespaces Method

VbRepositoryRegisterDefaultNamespaces Method
Registers default namespaces in the project.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void RegisterDefaultNamespaces(
    TechnologyEnvironment technology = TechnologyEnvironment.WindowsForms
)
Public Overrides Sub RegisterDefaultNamespaces (
    Optional technology As TechnologyEnvironment = TechnologyEnvironment.WindowsForms
)
public:
virtual void RegisterDefaultNamespaces(
    TechnologyEnvironment technology = TechnologyEnvironment::WindowsForms
) override
abstract RegisterDefaultNamespaces :
        ?technology : TechnologyEnvironment
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
*)
-> unit
override RegisterDefaultNamespaces :
        ?technology : TechnologyEnvironment
(* Defaults:
        let _technology = defaultArg technology TechnologyEnvironment.WindowsForms
*)
-> unit

Parameters

technology (Optional)
Type: Alternet.CommonTechnologyEnvironment
Specifies technology platform

Implements

IRoslynRepositoryRegisterDefaultNamespaces(TechnologyEnvironment)
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.SmartFormat Method

VbRepositorySmartFormat Method
Overload List
 | Name | Description
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList) | Formats block of text according to the parser rules. (Inherited from RoslynRepository.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. (Overrides RoslynRepositorySmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList).)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository.SmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)

VbRepositorySmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)
Formats block of text according to the parser rules.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SmartFormat(
    ref Point start,
    ref Point end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList operations
)
Public Overrides Function SmartFormat (
    ByRef start As Point,
    ByRef end As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    extended As Boolean,
    operations As ITextUndoList
) As Boolean
public:
virtual bool SmartFormat(
    Point% start,
    Point% end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList^ operations
) override
abstract SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool
override SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool

Parameters

start
Type: System.DrawingPoint
Start position of the block
end
Type: System.DrawingPoint
End position of the block
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab
extended
Type: SystemBoolean
Specifies if whole syntax block containing start and end point should be formatted
operations
Type: Alternet.SyntaxITextUndoList
List of changes.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

IRoslynRepositorySmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList)
See Also

Reference

VbRepository Class
SmartFormat Overload
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository Properties

VbRepository Properties

The VbRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | Document | Represents a Microsoft.CodeAnalysis.Document contains code text. (Inherited from RoslynRepository.)
Public property | DocumentId | Represents a Microsoft.CodeAnalysis.DocumentId contains code text. (Inherited from RoslynRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Inherited from RoslynRepository.)
Public property | ImagesHighDpi | (Inherited from RoslynRepository.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Model | Represents a Microsoft.CodeAnalysis.SemanticModel describes code text. (Inherited from RoslynRepository.)
Public property | ProjectId | Represents a Microsoft.CodeAnalysis.ProjectId that contains document. (Inherited from RoslynRepository.)
Public property | ProjectName | gets or sets Project name containing document (Inherited from RoslynRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | Solution | Gets RoslynSolution associated with this Repository. (Inherited from RoslynRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Public property | Text | Represents a Microsoft.CodeAnalysis.SourceText describes code text. (Inherited from RoslynRepository.)
Public property | Tree | Represents a Microsoft.CodeAnalysis.SyntaxTree represents parsed code text. (Inherited from RoslynRepository.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from RoslynRepository.)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbRepository Events

VbRepository Events

The VbRepository type exposes the following members.

Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options. (Inherited from RoslynRepository.)
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

VbRepository Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbSolution Class

VbSolution Class
Represents properties and methods to service source code documents intended to use for Visual Basic language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.Roslyn.CodeCompletionRoslynSolution
Alternet.Syntax.Parsers.Roslyn.CodeCompletionVbSolution

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VbSolution : RoslynSolution
Public Class VbSolution
    Inherits RoslynSolution
public ref class VbSolution : public RoslynSolution
type VbSolution =
    class
        inherit RoslynSolution
    end

The VbSolution type exposes the following members.

Constructors
 | Name | Description
Public method | VbSolution | Initializes a new instance of the VbSolution class with default settings.
Top
Methods
Name | Description
Public method AddDocument(String, SourceText, ProjectId, Boolean)
Adds a new document to the project.
(Inherited from RoslynSolution.)
Public method AddDocument(String, String, ProjectId, Boolean)
Adds a new document to the project.
(Inherited from RoslynSolution.)
Public method AddNotifier
Adds new handler to respond a notification.
(Inherited from RoslynSolution.)
Public method AddProject
Creates default project to this solution.
(Overrides RoslynSolutionAddProject(String, String).)
Public method AddReference
Adds metadata reference to the project
(Inherited from RoslynSolution.)
Public method BeginUpdate
Prevents object state updating until calling EndUpdate method.
(Inherited from RoslynSolution.)
Public method CloseDocument
When implemented by a class, closes specified document.
(Inherited from RoslynSolution.)
Public method CreateDefaultProject
Creates default project to this solution.
(Overrides RoslynSolutionCreateDefaultProject.)
Public method DisableUpdate
Prevents object state updating until calling EnableUpdate method.
(Inherited from RoslynSolution.)
Public method | Dispose | (Inherited from RoslynSolution.)
Public method DocumentBelongsToDefaultProject
Indicates if document belongs to the default project.
(Inherited from RoslynSolution.)
Public method EnableUpdate
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from RoslynSolution.)
Public method EndUpdate
Re-enables object state updating, that was turn of by calling BeginUpdate method.
(Inherited from RoslynSolution.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method FindDocument(String, ProjectId)
Gets Microsoft.CodeAnalysis.Document matches the given file path.
(Inherited from RoslynSolution.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetProject(ProjectId)
Gets or creates Project in the solution.
(Inherited from RoslynSolution.)
Public method GetProject(String)
Gets or creates Project in the solution.
(Inherited from RoslynSolution.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsDocumentOpen
Determines if document is already open in the workspace.
(Inherited from RoslynSolution.)
Public method Notify
Notifies all notifiers about updating object state.
(Inherited from RoslynSolution.)
Public method OpenDocument
Opens specified document if needed.
(Inherited from RoslynSolution.)
Public method RegisterAssemblies
Replaces assemblies in the project with new ones.
(Inherited from RoslynSolution.)
Public method RegisterAssembly
Registers assembly in the project.
(Inherited from RoslynSolution.)
Public method RegisterCodeFiles
Makes types declared in given source files accessible for code completion.
(Inherited from RoslynSolution.)
Public method RegisterNamespaces
Registers global namespaces.
(Overrides RoslynSolutionRegisterNamespaces(String, ProjectId).)
Public method RegisterProjectReferences
When implemented by a class, replaces project references with the new ones.
(Inherited from RoslynSolution.)
Public method RemoveDocument(DocumentId)
Removes specified Microsoft.CodeAnalysis.Document from the project.
(Inherited from RoslynSolution.)
Public method RemoveDocument(String, ProjectId)
Removes specified document from the project.
(Inherited from RoslynSolution.)
Public method RemoveNotifier
Exclude specified handler from notification handlers list.
(Inherited from RoslynSolution.)
Public method RemoveProject
Removes project from the solution
(Inherited from RoslynSolution.)
Public method ReplaceCodeFile
Updates code completion with changes in source file.
(Inherited from RoslynSolution.)
Public method ReplaceDocument(DocumentId, SourceText)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
(Inherited from RoslynSolution.)
Public method ReplaceDocument(DocumentId, String)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
(Inherited from RoslynSolution.)
Public method ResolveAssemblyName
Try to find real assembly name matches the given name.
(Inherited from RoslynSolution.)
Public method | ResolveProjectId | (Inherited from RoslynSolution.)
Public method SetConditionalsForProject
Sets conditional compilation symbols for given project
(Inherited from RoslynSolution.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UnregisterAssemblies
Unregisters assemblies from the project.
(Inherited from RoslynSolution.)
Public method UnregisterAssembly
Unregisters assembly from the project.
(Inherited from RoslynSolution.)
Public method UnregisterCodeFiles
Removes types declared in given source files from being accessible code completion.
(Inherited from RoslynSolution.)
Public method UnregisterProjectReferences
When implemented by a class, unregisters assemblies from the project.
(Inherited from RoslynSolution.)
Public method Update
Updates an object state.
(Inherited from RoslynSolution.)
Public method WithDefaultAssemblies
Registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add reference to.

Return Value

Type:
IRoslynSolution instance with default assemblies being registered for code completion
(Inherited from RoslynSolution.)
Top
Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths. (Inherited from RoslynSolution.)
Public property | BaseDirectory | Gets or sets solution base directory. (Inherited from RoslynSolution.)
Public property | Conditionals | When implemented by a class, gets or sets a collection of conditional symbols (Inherited from RoslynSolution.)
Public property | CustomXMLDocPath | Gets a custom xml documentation path. (Inherited from RoslynSolution.)
 | DefaultScriptSolution | Gets a default script VbSolution object.
 | DefaultSolution | Gets a default VbSolution object.
Public property | FrameworkPath | Gets or sets path to the .NET Framework assemblies (Inherited from RoslynSolution.)
Public property | ProjectId | Gets a current Microsoft.CodeAnalysis.ProjectId. (Inherited from RoslynSolution.)
Public property | ScriptSearchPaths | Gets or sets a collection of script source search paths. (Inherited from RoslynSolution.)
Public property | Solution | Gets a current Microsoft.CodeAnalysis.Project. (Inherited from RoslynSolution.)
Public property | SourceKind | Gets kind (regular or script) of the source code. (Inherited from RoslynSolution.)
Public property | TargetFrameworkVersion | Gets or sets version of the .NET Framework to use with the methods in Framework Location Helper. (Inherited from RoslynSolution.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from RoslynSolution.)
Public property | Workspace | Gets a current project Microsoft.CodeAnalysis.Workspace. (Inherited from RoslynSolution.)
Top
See Also

Reference

Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbSolution Constructor

VbSolution Constructor
Initializes a new instance of the VbSolution class with default settings.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public VbSolution(
    SourceCodeKind sourceKind = SourceCodeKind.Regular
)
Public Sub New (
    Optional sourceKind As SourceCodeKind = SourceCodeKind.Regular
)
public:
VbSolution(
    SourceCodeKind sourceKind = SourceCodeKind::Regular
)
new :
        ?sourceKind : SourceCodeKind
(* Defaults:
        let _sourceKind = defaultArg sourceKind SourceCodeKind.Regular
*)
-> VbSolution

Parameters

sourceKind (Optional)
Type: SourceCodeKind
See Also

Reference

VbSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbSolution Methods

VbSolution Methods

The VbSolution type exposes the following members.

Methods
Name | Description
Public method AddDocument(String, SourceText, ProjectId, Boolean)
Adds a new document to the project.
(Inherited from RoslynSolution.)
Public method AddDocument(String, String, ProjectId, Boolean)
Adds a new document to the project.
(Inherited from RoslynSolution.)
Public method AddNotifier
Adds new handler to respond a notification.
(Inherited from RoslynSolution.)
Public method AddProject
Creates default project to this solution.
(Overrides RoslynSolutionAddProject(String, String).)
Public method AddReference
Adds metadata reference to the project
(Inherited from RoslynSolution.)
Public method BeginUpdate
Prevents object state updating until calling EndUpdate method.
(Inherited from RoslynSolution.)
Public method CloseDocument
When implemented by a class, closes specified document.
(Inherited from RoslynSolution.)
Public method CreateDefaultProject
Creates default project to this solution.
(Overrides RoslynSolutionCreateDefaultProject.)
Public method DisableUpdate
Prevents object state updating until calling EnableUpdate method.
(Inherited from RoslynSolution.)
Public method | Dispose | (Inherited from RoslynSolution.)
Public method DocumentBelongsToDefaultProject
Indicates if document belongs to the default project.
(Inherited from RoslynSolution.)
Public method EnableUpdate
Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state.
(Inherited from RoslynSolution.)
Public method EndUpdate
Re-enables object state updating, that was turn of by calling BeginUpdate method.
(Inherited from RoslynSolution.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method FindDocument(String, ProjectId)
Gets Microsoft.CodeAnalysis.Document matches the given file path.
(Inherited from RoslynSolution.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetProject(ProjectId)
Gets or creates Project in the solution.
(Inherited from RoslynSolution.)
Public method GetProject(String)
Gets or creates Project in the solution.
(Inherited from RoslynSolution.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IsDocumentOpen
Determines if document is already open in the workspace.
(Inherited from RoslynSolution.)
Public method Notify
Notifies all notifiers about updating object state.
(Inherited from RoslynSolution.)
Public method OpenDocument
Opens specified document if needed.
(Inherited from RoslynSolution.)
Public method RegisterAssemblies
Replaces assemblies in the project with new ones.
(Inherited from RoslynSolution.)
Public method RegisterAssembly
Registers assembly in the project.
(Inherited from RoslynSolution.)
Public method RegisterCodeFiles
Makes types declared in given source files accessible for code completion.
(Inherited from RoslynSolution.)
Public method RegisterNamespaces
Registers global namespaces.
(Overrides RoslynSolutionRegisterNamespaces(String, ProjectId).)
Public method RegisterProjectReferences
When implemented by a class, replaces project references with the new ones.
(Inherited from RoslynSolution.)
Public method RemoveDocument(DocumentId)
Removes specified Microsoft.CodeAnalysis.Document from the project.
(Inherited from RoslynSolution.)
Public method RemoveDocument(String, ProjectId)
Removes specified document from the project.
(Inherited from RoslynSolution.)
Public method RemoveNotifier
Exclude specified handler from notification handlers list.
(Inherited from RoslynSolution.)
Public method RemoveProject
Removes project from the solution
(Inherited from RoslynSolution.)
Public method ReplaceCodeFile
Updates code completion with changes in source file.
(Inherited from RoslynSolution.)
Public method ReplaceDocument(DocumentId, SourceText)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
(Inherited from RoslynSolution.)
Public method ReplaceDocument(DocumentId, String)
Updates Microsoft.CodeAnalysis.Document to have the text specified.
(Inherited from RoslynSolution.)
Public method ResolveAssemblyName
Try to find real assembly name matches the given name.
(Inherited from RoslynSolution.)
Public method | ResolveProjectId | (Inherited from RoslynSolution.)
Public method SetConditionalsForProject
Sets conditional compilation symbols for given project
(Inherited from RoslynSolution.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UnregisterAssemblies
Unregisters assemblies from the project.
(Inherited from RoslynSolution.)
Public method UnregisterAssembly
Unregisters assembly from the project.
(Inherited from RoslynSolution.)
Public method UnregisterCodeFiles
Removes types declared in given source files from being accessible code completion.
(Inherited from RoslynSolution.)
Public method UnregisterProjectReferences
When implemented by a class, unregisters assemblies from the project.
(Inherited from RoslynSolution.)
Public method Update
Updates an object state.
(Inherited from RoslynSolution.)
Public method WithDefaultAssemblies
Registers some most frequently used assemblies. Specifies technology platformSpecifies whether existing assemblies should be persisted.Specifies project to add reference to.

Return Value

Type:
IRoslynSolution instance with default assemblies being registered for code completion
(Inherited from RoslynSolution.)
Top
See Also

Reference

VbSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbSolution.AddProject Method

VbSolutionAddProject Method
Creates default project to this solution.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ProjectId AddProject(
    string projectName,
    string projectPath
)
Public Overrides Function AddProject (
    projectName As String,
    projectPath As String
) As ProjectId
public:
virtual ProjectId^ AddProject(
    String^ projectName,
    String^ projectPath
) override
abstract AddProject :
        projectName : string *
        projectPath : string -> ProjectId
override AddProject :
        projectName : string *
        projectPath : string -> ProjectId

Parameters

projectName
Type: SystemString
Name of newly created project.
projectPath
Type: SystemString
Path of newly created project.

Return Value

Type: ProjectId
Microsoft.CodeAnalysis.ProjectId that is created.

Implements

IRoslynSolutionAddProject(String, String)
See Also

Reference

VbSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbSolution.CreateDefaultProject Method

VbSolutionCreateDefaultProject Method
Creates default project to this solution.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ProjectId CreateDefaultProject()
Public Overrides Function CreateDefaultProject As ProjectId
public:
virtual ProjectId^ CreateDefaultProject() override
abstract CreateDefaultProject : unit -> ProjectId
override CreateDefaultProject : unit -> ProjectId

Return Value

Type: ProjectId
Microsoft.CodeAnalysis.ProjectId of a project that is created.

Implements

IRoslynSolutionCreateDefaultProject
See Also

Reference

VbSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbSolution.RegisterNamespaces Method

VbSolutionRegisterNamespaces Method
Registers global namespaces.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool RegisterNamespaces(
    string[] nameSpaces,
    ProjectId projectId = null
)
Public Overrides Function RegisterNamespaces (
    nameSpaces As String(),
    Optional projectId As ProjectId = Nothing
) As Boolean
public:
virtual bool RegisterNamespaces(
    array<String^>^ nameSpaces,
    ProjectId^ projectId = nullptr
) override
abstract RegisterNamespaces :
        nameSpaces : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool
override RegisterNamespaces :
        nameSpaces : string[] *
        ?projectId : ProjectId
(* Defaults:
        let _projectId = defaultArg projectId null
*)
-> bool

Parameters

nameSpaces
Type: SystemString
List of global namespaces
projectId (Optional)
Type: ProjectId
Specifies Project to search for the document.

Return Value

Type: Boolean
True if succeed otherwise false.

Implements

IRoslynSolutionRegisterNamespaces(String, ProjectId)
See Also

Reference

VbSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbSolution Properties

VbSolution Properties

The VbSolution type exposes the following members.

Properties
 | Name | Description
Public property | AssemblySearchPaths | Gets or sets a collection of assembly search paths. (Inherited from RoslynSolution.)
Public property | BaseDirectory | Gets or sets solution base directory. (Inherited from RoslynSolution.)
Public property | Conditionals | When implemented by a class, gets or sets a collection of conditional symbols (Inherited from RoslynSolution.)
Public property | CustomXMLDocPath | Gets a custom xml documentation path. (Inherited from RoslynSolution.)
 | DefaultScriptSolution | Gets a default script VbSolution object.
 | DefaultSolution | Gets a default VbSolution object.
Public property | FrameworkPath | Gets or sets path to the .NET Framework assemblies (Inherited from RoslynSolution.)
Public property | ProjectId | Gets a current Microsoft.CodeAnalysis.ProjectId. (Inherited from RoslynSolution.)
Public property | ScriptSearchPaths | Gets or sets a collection of script source search paths. (Inherited from RoslynSolution.)
Public property | Solution | Gets a current Microsoft.CodeAnalysis.Project. (Inherited from RoslynSolution.)
Public property | SourceKind | Gets kind (regular or script) of the source code. (Inherited from RoslynSolution.)
Public property | TargetFrameworkVersion | Gets or sets version of the .NET Framework to use with the methods in Framework Location Helper. (Inherited from RoslynSolution.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from RoslynSolution.)
Public property | Workspace | Gets a current project Microsoft.CodeAnalysis.Workspace. (Inherited from RoslynSolution.)
Top
See Also

Reference

VbSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbSolution.DefaultScriptSolution Property

VbSolutionDefaultScriptSolution Property
Gets a default script VbSolution object.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static VbSolution DefaultScriptSolution { get; }
Public Shared ReadOnly Property DefaultScriptSolution As VbSolution
    Get
public:
static property VbSolution^ DefaultScriptSolution {
    VbSolution^ get ();
}
static member DefaultScriptSolution : VbSolution with get

Property Value

Type: VbSolution
See Also

Reference

VbSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


VbSolution.DefaultSolution Property

VbSolutionDefaultSolution Property
Gets a default VbSolution object.

Namespace: Alternet.Syntax.Parsers.Roslyn.CodeCompletion
Assembly: Alternet.Syntax.Parsers.Roslyn.v7 (in Alternet.Syntax.Parsers.Roslyn.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static VbSolution DefaultSolution { get; }
Public Shared ReadOnly Property DefaultSolution As VbSolution
    Get
public:
static property VbSolution^ DefaultSolution {
    VbSolution^ get ();
}
static member DefaultSolution : VbSolution with get

Property Value

Type: VbSolution
See Also

Reference

VbSolution Class
Alternet.Syntax.Parsers.Roslyn.CodeCompletion Namespace


Alternet.Syntax.Parsers.TypeScript Namespace

Alternet.Syntax.Parsers.TypeScript Namespace
Classes
 | Class | Description
Public class | FormattingOptionsEventArgs | Provides data for the ITypeScriptRepository.CustomFormattingOptions event.
Public class | JavaScriptParser | Represents properties and methods to perform syntax analysis of the text intended to use for JavaScript language.
Public class | TypeScriptConsts | Contains default constants related to lexical and syntax analyzers.
Public class | TypeScriptParser | Represents properties and methods to perform syntax analysis of the text intended to use for TypeScript language.
Public class | TypeScriptTokenizer | Represents class that and perform lexical analysis of specified TypeScript code.
Public class | TypeScriptTokenizerLineToken | Represents information about particular line token.
Public class | TypeScriptTokenizerTokenList | Represents a LineToken collection.
Interfaces
 | Interface | Description
Public interface | ITypeScriptRepository | Represents properties and methods to perform code completion functionality for TypeScript code.


FormattingOptionsEventArgs Class

FormattingOptionsEventArgs Class
Provides data for the ITypeScriptRepository.CustomFormattingOptions event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Alternet.Syntax.Parsers.TypeScriptFormattingOptionsEventArgs

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormattingOptionsEventArgs : EventArgs
Public Class FormattingOptionsEventArgs
    Inherits EventArgs
public ref class FormattingOptionsEventArgs : public EventArgs
type FormattingOptionsEventArgs =
    class
        inherit EventArgs
    end

The FormattingOptionsEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FormattingOptionsEventArgs | Initializes a new instance of the FormattingOptionsEventArgs class with specified options.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Options | Gets or sets a rules that define formatting code behavior.
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript Namespace


FormattingOptionsEventArgs Constructor

FormattingOptionsEventArgs Constructor
Initializes a new instance of the FormattingOptionsEventArgs class with specified options.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormattingOptionsEventArgs(
    FormatCodeOptions options
)
Public Sub New (
    options As FormatCodeOptions
)
public:
FormattingOptionsEventArgs(
    FormatCodeOptions^ options
)
new :
        options : FormatCodeOptions -> FormattingOptionsEventArgs

Parameters

options
Type: FormatCodeOptions
Rules that define formatting code behavior.
See Also

Reference

FormattingOptionsEventArgs Class
Alternet.Syntax.Parsers.TypeScript Namespace


FormattingOptionsEventArgs Methods

FormattingOptionsEventArgs Methods

The FormattingOptionsEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FormattingOptionsEventArgs Class
Alternet.Syntax.Parsers.TypeScript Namespace


FormattingOptionsEventArgs Properties

FormattingOptionsEventArgs Properties

The FormattingOptionsEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Options | Gets or sets a rules that define formatting code behavior.
Top
See Also

Reference

FormattingOptionsEventArgs Class
Alternet.Syntax.Parsers.TypeScript Namespace


FormattingOptionsEventArgs.Options Property

FormattingOptionsEventArgsOptions Property
Gets or sets a rules that define formatting code behavior.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatCodeOptions Options { get; set; }
Public Property Options As FormatCodeOptions
    Get
    Set
public:
property FormatCodeOptions^ Options {
    FormatCodeOptions^ get ();
    void set (FormatCodeOptions^ value);
}
member Options : FormatCodeOptions with get, set

Property Value

Type: FormatCodeOptions
See Also

Reference

FormattingOptionsEventArgs Class
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository Interface

ITypeScriptRepository Interface
Represents properties and methods to perform code completion functionality for TypeScript code.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITypeScriptRepository : ICodeCompletionRepository,
    IDisposable
Public Interface ITypeScriptRepository
    Inherits ICodeCompletionRepository, IDisposable
public interface class ITypeScriptRepository : ICodeCompletionRepository,
    IDisposable
type ITypeScriptRepository =
    interface
        interface ICodeCompletionRepository
        interface IDisposable
    end

The ITypeScriptRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillCodeFixes | When implemented by a class, fills codefix provider with list of available code fixes.
Public method | FillCodeRefactors | When implemented by a class, fills codefix provider with list of available code fixes.
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers(IEnumerableCompletionEntry, IListMembers, Point, Int32) | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillParameterInfo | When implemented by a class, fills list members provider with list of its member with parameter info.
Public method | FindDeclaration | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclarations | When implemented by a class, locates all declarations at given position in the text.
Public method | FindReferences(Point) | When implemented by a class, locates all references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | GetApplicableRefactors | When implemented by a class, gets applicable refactors at the given text range.
Public method | GetBreakpointStatementAtPosition | When implemented by a class, gets breakpoint statement range at pecified position.
Public method | GetClassifications | When implemented by a class, gets a list of ClassifiedSpan for the document.
Public method | GetClassifications(Int32, Int32) | When implemented by a class, gets list of classificators for the given document.
Public method | GetCodeFixesAtPosition | When implemented by a class, gets code fix at syntax error position.
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetCompletionsAtPosition | When implemented by a class, gets the completions available at the caret position.
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetDiagnostics | When implemented by a class, gets a list of Diagnostic for the document.
Public method | GetDocCommentTemplateAtPosition | When implemented by a class, gets the documentation comment template available at the caret position.
Public method | GetDocumentText | When implemented by a class, gets text of the specified document.
Public method | GetFormattingEditsAfterKeystroke | When implemented by a class, gets the text changes for the part of document accordingly to the formatting rules.
Public method | GetFormattingEditsForRange | When implemented by a class, gets the text changes for the part of document accordingly to the formatting rules.
Public method | GetIndentationAtPosition | When implemented by a class, gets line indentation at specified position.
Public method | GetLineAndCharacterOfPosition | When implemented by a class, converts given absolute text coordinate into Point position.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetOccurrencesAtPosition | When implemented by a class, locates all occurrences at given position in the text.
Public method | GetOutliningSpans | When implemented by a class, gets a list of OutliningSpan for the document.
Public method | GetPositionOfLineAndCharacter | When implemented by a class, converts given position into absolute text coordinate.
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfoAtPosition(Point) | When implemented by a class, gets the quick info available at the caret position.
Public method | GetQuickInfoAtPosition(Int32) | When implemented by a class, gets the quick info available at the caret position.
Public method | GetReferencesAtPosition | When implemented by a class, locates all references at given position in the text.
Public method | GetSignatureHelpItems | When implemented by a class, gets the signature help items available at the caret position.
Public method | GetSmartFormatSymbol | When implemented by a class, gets smart format node under given position.
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | GetStructureGuideNode | When implemented by a class, gets structure nodes.
Public method | GetSyntaxTree | When implemented by a class, gets the syntax tree for the parsed document.
Public method | GetTextChangesForRefactor | When implemented by a class, gets text changes for the code refactor.
Public method | HasDocument | When implemented by a class, indicates whether TypeScript project has document specified.
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | IsValidBraceCompletionAtPosition | When implemented by a class, determines if close brace code completion is expected.
Public method | QuickInfo | When implemented by a class, gets the quick info available at the caret position.
Public method | RegisterCodeFiles | When implemented by a class, makes types declared in given source files accessible for code completion.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | RemoveDocument | When implemented by a class, removes specified document from the project.
Public method | ReplaceDocument | When implemented by a class, updates source code document to have the text specified.
Public method | UnregisterCodeFiles | When implemented by a class, removes types declared in given source files from being accessible code completion.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | DefaultExtension | When implemented by a class, gets or sets default extension associated with this repository.
Public property | DisplayScaledImages | When implemented by a class, gets ImageList for high DPIs.
Public property | FileName | When implemented by a class, gets or sets file name of the file being parsed.
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | Parser | When implemented by a class, gets a V8Parser that provides syntax analysis for TypeScript document.
Public property | Project | When implemented by a class, gets a ITypeScriptProject that contains document being parsed.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | CustomFormattingOptions | When implemented by a class, occurs while trying to obtains information about formatting options related to the document.
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository Methods

ITypeScriptRepository Methods

The ITypeScriptRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillCodeFixes | When implemented by a class, fills codefix provider with list of available code fixes.
Public method | FillCodeRefactors | When implemented by a class, fills codefix provider with list of available code fixes.
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers(IEnumerableCompletionEntry, IListMembers, Point, Int32) | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillParameterInfo | When implemented by a class, fills list members provider with list of its member with parameter info.
Public method | FindDeclaration | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclarations | When implemented by a class, locates all declarations at given position in the text.
Public method | FindReferences(Point) | When implemented by a class, locates all references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | GetApplicableRefactors | When implemented by a class, gets applicable refactors at the given text range.
Public method | GetBreakpointStatementAtPosition | When implemented by a class, gets breakpoint statement range at pecified position.
Public method | GetClassifications | When implemented by a class, gets a list of ClassifiedSpan for the document.
Public method | GetClassifications(Int32, Int32) | When implemented by a class, gets list of classificators for the given document.
Public method | GetCodeFixesAtPosition | When implemented by a class, gets code fix at syntax error position.
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetCompletionsAtPosition | When implemented by a class, gets the completions available at the caret position.
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetDiagnostics | When implemented by a class, gets a list of Diagnostic for the document.
Public method | GetDocCommentTemplateAtPosition | When implemented by a class, gets the documentation comment template available at the caret position.
Public method | GetDocumentText | When implemented by a class, gets text of the specified document.
Public method | GetFormattingEditsAfterKeystroke | When implemented by a class, gets the text changes for the part of document accordingly to the formatting rules.
Public method | GetFormattingEditsForRange | When implemented by a class, gets the text changes for the part of document accordingly to the formatting rules.
Public method | GetIndentationAtPosition | When implemented by a class, gets line indentation at specified position.
Public method | GetLineAndCharacterOfPosition | When implemented by a class, converts given absolute text coordinate into Point position.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetOccurrencesAtPosition | When implemented by a class, locates all occurrences at given position in the text.
Public method | GetOutliningSpans | When implemented by a class, gets a list of OutliningSpan for the document.
Public method | GetPositionOfLineAndCharacter | When implemented by a class, converts given position into absolute text coordinate.
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfoAtPosition(Point) | When implemented by a class, gets the quick info available at the caret position.
Public method | GetQuickInfoAtPosition(Int32) | When implemented by a class, gets the quick info available at the caret position.
Public method | GetReferencesAtPosition | When implemented by a class, locates all references at given position in the text.
Public method | GetSignatureHelpItems | When implemented by a class, gets the signature help items available at the caret position.
Public method | GetSmartFormatSymbol | When implemented by a class, gets smart format node under given position.
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | GetStructureGuideNode | When implemented by a class, gets structure nodes.
Public method | GetSyntaxTree | When implemented by a class, gets the syntax tree for the parsed document.
Public method | GetTextChangesForRefactor | When implemented by a class, gets text changes for the code refactor.
Public method | HasDocument | When implemented by a class, indicates whether TypeScript project has document specified.
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | IsValidBraceCompletionAtPosition | When implemented by a class, determines if close brace code completion is expected.
Public method | QuickInfo | When implemented by a class, gets the quick info available at the caret position.
Public method | RegisterCodeFiles | When implemented by a class, makes types declared in given source files accessible for code completion.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | RemoveDocument | When implemented by a class, removes specified document from the project.
Public method | ReplaceDocument | When implemented by a class, updates source code document to have the text specified.
Public method | UnregisterCodeFiles | When implemented by a class, removes types declared in given source files from being accessible code completion.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.FillCodeFixes Method

ITypeScriptRepositoryFillCodeFixes Method
When implemented by a class, fills codefix provider with list of available code fixes.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillCodeFixes(
    IEnumerable<ICodeFix> codeFixes,
    ICodeFixItems items
)
Sub FillCodeFixes (
    codeFixes As IEnumerable(Of ICodeFix),
    items As ICodeFixItems
)
void FillCodeFixes(
    IEnumerable<ICodeFix^>^ codeFixes,
    ICodeFixItems^ items
)
abstract FillCodeFixes :
        codeFixes : IEnumerable<ICodeFix> *
        items : ICodeFixItems -> unit

Parameters

codeFixes
Type: System.Collections.GenericIEnumerableICodeFix
Collection of code fixes
items
Type: Alternet.Syntax.CodeCompletionICodeFixItems
Collection of code fix items
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.FillCodeRefactors Method

ITypeScriptRepositoryFillCodeRefactors Method
When implemented by a class, fills codefix provider with list of available code fixes.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillCodeRefactors(
    IEnumerable<ICodeRefactor> codeFixes,
    ICodeRefactorItems items
)
Sub FillCodeRefactors (
    codeFixes As IEnumerable(Of ICodeRefactor),
    items As ICodeRefactorItems
)
void FillCodeRefactors(
    IEnumerable<ICodeRefactor^>^ codeFixes,
    ICodeRefactorItems^ items
)
abstract FillCodeRefactors :
        codeFixes : IEnumerable<ICodeRefactor> *
        items : ICodeRefactorItems -> unit

Parameters

codeFixes
Type: System.Collections.GenericIEnumerableICodeRefactor
Collection of code fixes
items
Type: Alternet.Syntax.CodeCompletionICodeRefactorItems
Collection of code fix items
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.FillMembers Method

ITypeScriptRepositoryFillMembers Method
Overload List
 | Name | Description
Public method | FillMembers(IEnumerableCompletionEntry, IListMembers, Point, Int32) | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.FillMembers Method (IEnumerable(CompletionEntry), IListMembers, Point, Int32)

ITypeScriptRepositoryFillMembers Method (IEnumerableCompletionEntry, IListMembers, Point, Int32)
When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillMembers(
    IEnumerable<CompletionEntry> completions,
    IListMembers members,
    Point position,
    out int selectedIndex
)
Sub FillMembers (
    completions As IEnumerable(Of CompletionEntry),
    members As IListMembers,
    position As Point,
    <OutAttribute> ByRef selectedIndex As Integer
)
void FillMembers(
    IEnumerable<CompletionEntry^>^ completions,
    IListMembers^ members,
    Point position,
    [OutAttribute] int% selectedIndex
)
abstract FillMembers :
        completions : IEnumerable<CompletionEntry> *
        members : IListMembers *
        position : Point *
        selectedIndex : int byref -> unit

Parameters

completions
Type: System.Collections.GenericIEnumerableCompletionEntry
Set of completions that is source of language elements.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
position
Type: System.DrawingPoint
Specifies position of language element in the text.
selectedIndex
Type: SystemInt32
Retrieves index of selected list member
See Also

Reference

ITypeScriptRepository Interface
FillMembers Overload
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.FillParameterInfo Method

ITypeScriptRepositoryFillParameterInfo Method
When implemented by a class, fills list members provider with list of its member with parameter info.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void FillParameterInfo(
    SignatureHelpItems helpItems,
    IListMembers members,
    Point position
)
Sub FillParameterInfo (
    helpItems As SignatureHelpItems,
    members As IListMembers,
    position As Point
)
void FillParameterInfo(
    SignatureHelpItems^ helpItems,
    IListMembers^ members,
    Point position
)
abstract FillParameterInfo :
        helpItems : SignatureHelpItems *
        members : IListMembers *
        position : Point -> unit

Parameters

helpItems
Type: SignatureHelpItems
Source of the parameter information.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
position
Type: System.DrawingPoint
Specifies position of language element in the text.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.FindDeclarations Method

ITypeScriptRepositoryFindDeclarations Method
When implemented by a class, locates all declarations at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<DefinitionInfo> FindDeclarations(
    Point position
)
Function FindDeclarations (
    position As Point
) As IEnumerable(Of DefinitionInfo)
IEnumerable<DefinitionInfo^>^ FindDeclarations(
    Point position
)
abstract FindDeclarations :
        position : Point -> IEnumerable<DefinitionInfo>

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Return Value

Type: IEnumerableDefinitionInfo
List of DefinitionInfo that contains all available declarations.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.FindReferences Method

ITypeScriptRepositoryFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(Point) | When implemented by a class, locates all references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.FindReferences Method (Point)

ITypeScriptRepositoryFindReferences Method (Point)
When implemented by a class, locates all references at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ReferencedSymbol> FindReferences(
    Point position
)
Function FindReferences (
    position As Point
) As IEnumerable(Of ReferencedSymbol)
IEnumerable<ReferencedSymbol^>^ FindReferences(
    Point position
)
abstract FindReferences :
        position : Point -> IEnumerable<ReferencedSymbol>

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Return Value

Type: IEnumerableReferencedSymbol
List of ReferencedSymbol that contains all available references.
See Also

Reference

ITypeScriptRepository Interface
FindReferences Overload
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetApplicableRefactors Method

ITypeScriptRepositoryGetApplicableRefactors Method
When implemented by a class, gets applicable refactors at the given text range.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ApplicableRefactorInfo> GetApplicableRefactors(
    Point startPos,
    Point endPos
)
Function GetApplicableRefactors (
    startPos As Point,
    endPos As Point
) As IEnumerable(Of ApplicableRefactorInfo)
IEnumerable<ApplicableRefactorInfo^>^ GetApplicableRefactors(
    Point startPos,
    Point endPos
)
abstract GetApplicableRefactors :
        startPos : Point *
        endPos : Point -> IEnumerable<ApplicableRefactorInfo>

Parameters

startPos
Type: System.DrawingPoint
Start position within the text.
endPos
Type: System.DrawingPoint
End position within the text.

Return Value

Type: IEnumerableApplicableRefactorInfo
List of applicable refactors or null if there's none.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetBreakpointStatementAtPosition Method

ITypeScriptRepositoryGetBreakpointStatementAtPosition Method
When implemented by a class, gets breakpoint statement range at pecified position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TextSpan GetBreakpointStatementAtPosition(
    Point position
)
Function GetBreakpointStatementAtPosition (
    position As Point
) As TextSpan
TextSpan^ GetBreakpointStatementAtPosition(
    Point position
)
abstract GetBreakpointStatementAtPosition :
        position : Point -> TextSpan

Parameters

position
Type: System.DrawingPoint
The position to check.

Return Value

Type: TextSpan
TextSpan of the found breakpoint.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetClassifications Method

ITypeScriptRepositoryGetClassifications Method
Overload List
 | Name | Description
Public method | GetClassifications | When implemented by a class, gets a list of ClassifiedSpan for the document.
Public method | GetClassifications(Int32, Int32) | When implemented by a class, gets list of classificators for the given document.
Top
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetClassifications Method

ITypeScriptRepositoryGetClassifications Method
When implemented by a class, gets a list of ClassifiedSpan for the document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ClassifiedSpan> GetClassifications()
Function GetClassifications As IEnumerable(Of ClassifiedSpan)
IEnumerable<ClassifiedSpan^>^ GetClassifications()
abstract GetClassifications : unit -> IEnumerable<ClassifiedSpan>

Return Value

Type: IEnumerableClassifiedSpan
List of ClassifiedSpan.
See Also

Reference

ITypeScriptRepository Interface
GetClassifications Overload
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetClassifications Method (Int32, Int32)

ITypeScriptRepositoryGetClassifications Method (Int32, Int32)
When implemented by a class, gets list of classificators for the given document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ClassifiedSpan> GetClassifications(
    int start,
    int length
)
Function GetClassifications (
    start As Integer,
    length As Integer
) As IEnumerable(Of ClassifiedSpan)
IEnumerable<ClassifiedSpan^>^ GetClassifications(
    int start,
    int length
)
abstract GetClassifications :
        start : int *
        length : int -> IEnumerable<ClassifiedSpan>

Parameters

start
Type: SystemInt32
Start position of the text span
length
Type: SystemInt32
Length of the the text span

Return Value

Type: IEnumerableClassifiedSpan
The set of classificators to perform syntax highlighting.
See Also

Reference

ITypeScriptRepository Interface
GetClassifications Overload
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetCodeFixesAtPosition Method

ITypeScriptRepositoryGetCodeFixesAtPosition Method
When implemented by a class, gets code fix at syntax error position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<CodeFixAction> GetCodeFixesAtPosition(
    ISyntaxError error
)
Function GetCodeFixesAtPosition (
    error As ISyntaxError
) As IEnumerable(Of CodeFixAction)
IEnumerable<CodeFixAction^>^ GetCodeFixesAtPosition(
    ISyntaxError^ error
)
abstract GetCodeFixesAtPosition :
        error : ISyntaxError -> IEnumerable<CodeFixAction>

Parameters

error
Type: Alternet.SyntaxISyntaxError
given syntax error

Return Value

Type: IEnumerableCodeFixAction
Collection of applicable code fixes.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetCompletionsAtPosition Method

ITypeScriptRepositoryGetCompletionsAtPosition Method
When implemented by a class, gets the completions available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<CompletionEntry> GetCompletionsAtPosition(
    Point position
)
Function GetCompletionsAtPosition (
    position As Point
) As IEnumerable(Of CompletionEntry)
IEnumerable<CompletionEntry^>^ GetCompletionsAtPosition(
    Point position
)
abstract GetCompletionsAtPosition :
        position : Point -> IEnumerable<CompletionEntry>

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: IEnumerableCompletionEntry
List of CompletionEntry related to the specified position.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetDiagnostics Method

ITypeScriptRepositoryGetDiagnostics Method
When implemented by a class, gets a list of Diagnostic for the document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<Diagnostic> GetDiagnostics()
Function GetDiagnostics As IEnumerable(Of Diagnostic)
IEnumerable<Diagnostic^>^ GetDiagnostics()
abstract GetDiagnostics : unit -> IEnumerable<Diagnostic>

Return Value

Type: IEnumerableDiagnostic
List of Diagnostic.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetDocCommentTemplateAtPosition Method

ITypeScriptRepositoryGetDocCommentTemplateAtPosition Method
When implemented by a class, gets the documentation comment template available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
TextInsertion GetDocCommentTemplateAtPosition(
    Point position
)
Function GetDocCommentTemplateAtPosition (
    position As Point
) As TextInsertion
TextInsertion^ GetDocCommentTemplateAtPosition(
    Point position
)
abstract GetDocCommentTemplateAtPosition :
        position : Point -> TextInsertion

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: TextInsertion
TextInsertion that contains documentation comment template.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetDocumentText Method

ITypeScriptRepositoryGetDocumentText Method
When implemented by a class, gets text of the specified document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetDocumentText(
    string fileName
)
Function GetDocumentText (
    fileName As String
) As String
String^ GetDocumentText(
    String^ fileName
)
abstract GetDocumentText :
        fileName : string -> string

Parameters

fileName
Type: SystemString
File name of the document.

Return Value

Type: String
Source code of a given document.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetFormattingEditsAfterKeystroke Method

ITypeScriptRepositoryGetFormattingEditsAfterKeystroke Method
When implemented by a class, gets the text changes for the part of document accordingly to the formatting rules.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<TextChange> GetFormattingEditsAfterKeystroke(
    int pos,
    string key,
    bool useSpaces,
    int spacesInTab,
    bool applyChanges,
    out string newText
)
Function GetFormattingEditsAfterKeystroke (
    pos As Integer,
    key As String,
    useSpaces As Boolean,
    spacesInTab As Integer,
    applyChanges As Boolean,
    <OutAttribute> ByRef newText As String
) As IEnumerable(Of TextChange)
IEnumerable<TextChange^>^ GetFormattingEditsAfterKeystroke(
    int pos,
    String^ key,
    bool useSpaces,
    int spacesInTab,
    bool applyChanges,
    [OutAttribute] String^% newText
)
abstract GetFormattingEditsAfterKeystroke :
        pos : int *
        key : string *
        useSpaces : bool *
        spacesInTab : int *
        applyChanges : bool *
        newText : string byref -> IEnumerable<TextChange>

Parameters

pos
Type: SystemInt32
Current position within the text.
key
Type: SystemString
Character being typed.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.
applyChanges
Type: SystemBoolean
Forces to apply found changes to the new text.
newText
Type: SystemString
Receives formatted code.

Return Value

Type: IEnumerableTextChange
List of TextChanges representing difference between old and new code.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetFormattingEditsForRange Method

ITypeScriptRepositoryGetFormattingEditsForRange Method
When implemented by a class, gets the text changes for the part of document accordingly to the formatting rules.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<TextChange> GetFormattingEditsForRange(
    int start,
    int end,
    bool useSpaces,
    int spacesInTab,
    bool applyChanges,
    out string newText
)
Function GetFormattingEditsForRange (
    start As Integer,
    end As Integer,
    useSpaces As Boolean,
    spacesInTab As Integer,
    applyChanges As Boolean,
    <OutAttribute> ByRef newText As String
) As IEnumerable(Of TextChange)
IEnumerable<TextChange^>^ GetFormattingEditsForRange(
    int start,
    int end,
    bool useSpaces,
    int spacesInTab,
    bool applyChanges,
    [OutAttribute] String^% newText
)
abstract GetFormattingEditsForRange :
        start : int *
        end : int *
        useSpaces : bool *
        spacesInTab : int *
        applyChanges : bool *
        newText : string byref -> IEnumerable<TextChange>

Parameters

start
Type: SystemInt32
Start position of code being formatted.
end
Type: SystemInt32
End position of code being formatted.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.
applyChanges
Type: SystemBoolean
Forces to apply found changes to the new text.
newText
Type: SystemString
Receives formatted code.

Return Value

Type: IEnumerableTextChange
List of TextChanges representing difference between old and new code.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetIndentationAtPosition Method

ITypeScriptRepositoryGetIndentationAtPosition Method
When implemented by a class, gets line indentation at specified position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetIndentationAtPosition(
    Point position,
    bool useSpaces,
    int spacesInTab
)
Function GetIndentationAtPosition (
    position As Point,
    useSpaces As Boolean,
    spacesInTab As Integer
) As Integer
int GetIndentationAtPosition(
    Point position,
    bool useSpaces,
    int spacesInTab
)
abstract GetIndentationAtPosition :
        position : Point *
        useSpaces : bool *
        spacesInTab : int -> int

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.

Return Value

Type: Int32
Number of indentation characters.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetLineAndCharacterOfPosition Method

ITypeScriptRepositoryGetLineAndCharacterOfPosition Method
When implemented by a class, converts given absolute text coordinate into Point position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Point GetLineAndCharacterOfPosition(
    int position
)
Function GetLineAndCharacterOfPosition (
    position As Integer
) As Point
Point GetLineAndCharacterOfPosition(
    int position
)
abstract GetLineAndCharacterOfPosition :
        position : int -> Point

Parameters

position
Type: SystemInt32
Absolute text coordinate to convert.

Return Value

Type: Point
Point position.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetOccurrencesAtPosition Method

ITypeScriptRepositoryGetOccurrencesAtPosition Method
When implemented by a class, locates all occurrences at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ReferenceEntry> GetOccurrencesAtPosition(
    Point position
)
Function GetOccurrencesAtPosition (
    position As Point
) As IEnumerable(Of ReferenceEntry)
IEnumerable<ReferenceEntry^>^ GetOccurrencesAtPosition(
    Point position
)
abstract GetOccurrencesAtPosition :
        position : Point -> IEnumerable<ReferenceEntry>

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Return Value

Type: IEnumerableReferenceEntry
List of ReferenceEntry that contains all available occurrences.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetOutliningSpans Method

ITypeScriptRepositoryGetOutliningSpans Method
When implemented by a class, gets a list of OutliningSpan for the document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<OutliningSpan> GetOutliningSpans()
Function GetOutliningSpans As IEnumerable(Of OutliningSpan)
IEnumerable<OutliningSpan^>^ GetOutliningSpans()
abstract GetOutliningSpans : unit -> IEnumerable<OutliningSpan>

Return Value

Type: IEnumerableOutliningSpan
List of OutliningSpan.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetPositionOfLineAndCharacter Method

ITypeScriptRepositoryGetPositionOfLineAndCharacter Method
When implemented by a class, converts given position into absolute text coordinate.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
int GetPositionOfLineAndCharacter(
    Point position
)
Function GetPositionOfLineAndCharacter (
    position As Point
) As Integer
int GetPositionOfLineAndCharacter(
    Point position
)
abstract GetPositionOfLineAndCharacter :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Point to convert.

Return Value

Type: Int32
Absolute position.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetQuickInfoAtPosition Method

ITypeScriptRepositoryGetQuickInfoAtPosition Method
Overload List
 | Name | Description
Public method | GetQuickInfoAtPosition(Point) | When implemented by a class, gets the quick info available at the caret position.
Public method | GetQuickInfoAtPosition(Int32) | When implemented by a class, gets the quick info available at the caret position.
Top
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetQuickInfoAtPosition Method (Point)

ITypeScriptRepositoryGetQuickInfoAtPosition Method (Point)
When implemented by a class, gets the quick info available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
QuickInfo GetQuickInfoAtPosition(
    Point position
)
Function GetQuickInfoAtPosition (
    position As Point
) As QuickInfo
QuickInfo^ GetQuickInfoAtPosition(
    Point position
)
abstract GetQuickInfoAtPosition :
        position : Point -> QuickInfo

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: QuickInfo
QuickInfo related to the specified position.
See Also

Reference

ITypeScriptRepository Interface
GetQuickInfoAtPosition Overload
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetQuickInfoAtPosition Method (Int32)

ITypeScriptRepositoryGetQuickInfoAtPosition Method (Int32)
When implemented by a class, gets the quick info available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
QuickInfo GetQuickInfoAtPosition(
    int position
)
Function GetQuickInfoAtPosition (
    position As Integer
) As QuickInfo
QuickInfo^ GetQuickInfoAtPosition(
    int position
)
abstract GetQuickInfoAtPosition :
        position : int -> QuickInfo

Parameters

position
Type: SystemInt32
The position of the caret in absolute cooordinates.

Return Value

Type: QuickInfo
QuickInfo related to the specified position.
See Also

Reference

ITypeScriptRepository Interface
GetQuickInfoAtPosition Overload
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetReferencesAtPosition Method

ITypeScriptRepositoryGetReferencesAtPosition Method
When implemented by a class, locates all references at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ReferenceEntry> GetReferencesAtPosition(
    Point position
)
Function GetReferencesAtPosition (
    position As Point
) As IEnumerable(Of ReferenceEntry)
IEnumerable<ReferenceEntry^>^ GetReferencesAtPosition(
    Point position
)
abstract GetReferencesAtPosition :
        position : Point -> IEnumerable<ReferenceEntry>

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Return Value

Type: IEnumerableReferenceEntry
List of ReferenceEntry that contains all available references.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetSignatureHelpItems Method

ITypeScriptRepositoryGetSignatureHelpItems Method
When implemented by a class, gets the signature help items available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
SignatureHelpItems GetSignatureHelpItems(
    Point position
)
Function GetSignatureHelpItems (
    position As Point
) As SignatureHelpItems
SignatureHelpItems^ GetSignatureHelpItems(
    Point position
)
abstract GetSignatureHelpItems :
        position : Point -> SignatureHelpItems

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: SignatureHelpItems
SignatureHelpItems related to the specified position.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetSmartFormatSymbol Method

ITypeScriptRepositoryGetSmartFormatSymbol Method
When implemented by a class, gets smart format node under given position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
NodeData GetSmartFormatSymbol(
    int pos
)
Function GetSmartFormatSymbol (
    pos As Integer
) As NodeData
NodeData^ GetSmartFormatSymbol(
    int pos
)
abstract GetSmartFormatSymbol :
        pos : int -> NodeData

Parameters

pos
Type: SystemInt32
Current position

Return Value

Type: NodeData
Node that can be formatted or null.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetStructureGuideNode Method

ITypeScriptRepositoryGetStructureGuideNode Method
When implemented by a class, gets structure nodes.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IList<NodeData> GetStructureGuideNode()
Function GetStructureGuideNode As IList(Of NodeData)
IList<NodeData^>^ GetStructureGuideNode()
abstract GetStructureGuideNode : unit -> IList<NodeData>

Return Value

Type: IListNodeData
List of structure nodes.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetSyntaxTree Method

ITypeScriptRepositoryGetSyntaxTree Method
When implemented by a class, gets the syntax tree for the parsed document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
Node GetSyntaxTree()
Function GetSyntaxTree As Node
Node^ GetSyntaxTree()
abstract GetSyntaxTree : unit -> Node

Return Value

Type: Node
Node holds parsed document content.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.GetTextChangesForRefactor Method

ITypeScriptRepositoryGetTextChangesForRefactor Method
When implemented by a class, gets text changes for the code refactor.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
RefactorEditInfo GetTextChangesForRefactor(
    ICodeRefactor codeRefactor
)
Function GetTextChangesForRefactor (
    codeRefactor As ICodeRefactor
) As RefactorEditInfo
RefactorEditInfo^ GetTextChangesForRefactor(
    ICodeRefactor^ codeRefactor
)
abstract GetTextChangesForRefactor :
        codeRefactor : ICodeRefactor -> RefactorEditInfo

Parameters

codeRefactor
Type: Alternet.SyntaxICodeRefactor

Return Value

Type: RefactorEditInfo
Refactor edits or null if there's none.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.HasDocument Method

ITypeScriptRepositoryHasDocument Method
When implemented by a class, indicates whether TypeScript project has document specified.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool HasDocument(
    string fileName
)
Function HasDocument (
    fileName As String
) As Boolean
bool HasDocument(
    String^ fileName
)
abstract HasDocument :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
File name of the document.

Return Value

Type: Boolean
True if project contains given document; otherwise false.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.IsValidBraceCompletionAtPosition Method

ITypeScriptRepositoryIsValidBraceCompletionAtPosition Method
When implemented by a class, determines if close brace code completion is expected.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsValidBraceCompletionAtPosition(
    Point position,
    char openBrace,
    out char closeBrace
)
Function IsValidBraceCompletionAtPosition (
    position As Point,
    openBrace As Char,
    <OutAttribute> ByRef closeBrace As Char
) As Boolean
bool IsValidBraceCompletionAtPosition(
    Point position,
    wchar_t openBrace,
    [OutAttribute] wchar_t% closeBrace
)
abstract IsValidBraceCompletionAtPosition :
        position : Point *
        openBrace : char *
        closeBrace : char byref -> bool

Parameters

position
Type: System.DrawingPoint
The position of the caret.
openBrace
Type: SystemChar
Character specifying open brace.
closeBrace
Type: SystemChar
Character specifying closing brace.

Return Value

Type: Boolean
True if open brace can be completed; otherwise false.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.QuickInfo Method

ITypeScriptRepositoryQuickInfo Method
When implemented by a class, gets the quick info available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
IQuickInfo QuickInfo(
    Point position
)
Function QuickInfo (
    position As Point
) As IQuickInfo
IQuickInfo^ QuickInfo(
    Point position
)
abstract QuickInfo :
        position : Point -> IQuickInfo

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: IQuickInfo
QuickInfo related to the specified position.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.RegisterCodeFiles Method

ITypeScriptRepositoryRegisterCodeFiles Method
When implemented by a class, makes types declared in given source files accessible for code completion.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RegisterCodeFiles(
    string[] files
)
Sub RegisterCodeFiles (
    files As String()
)
void RegisterCodeFiles(
    array<String^>^ files
)
abstract RegisterCodeFiles :
        files : string[] -> unit

Parameters

files
Type: SystemString
Files containing source code.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.RemoveDocument Method

ITypeScriptRepositoryRemoveDocument Method
When implemented by a class, removes specified document from the project.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void RemoveDocument(
    string fileName
)
Sub RemoveDocument (
    fileName As String
)
void RemoveDocument(
    String^ fileName
)
abstract RemoveDocument :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
File name of the document.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.ReplaceDocument Method

ITypeScriptRepositoryReplaceDocument Method
When implemented by a class, updates source code document to have the text specified.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ReplaceDocument(
    string fileName,
    string text
)
Sub ReplaceDocument (
    fileName As String,
    text As String
)
void ReplaceDocument(
    String^ fileName,
    String^ text
)
abstract ReplaceDocument :
        fileName : string *
        text : string -> unit

Parameters

fileName
Type: SystemString
File name of the document.
text
Type: SystemString
New TypeScript text.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.UnregisterCodeFiles Method

ITypeScriptRepositoryUnregisterCodeFiles Method
When implemented by a class, removes types declared in given source files from being accessible code completion.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void UnregisterCodeFiles(
    string[] files
)
Sub UnregisterCodeFiles (
    files As String()
)
void UnregisterCodeFiles(
    array<String^>^ files
)
abstract UnregisterCodeFiles :
        files : string[] -> unit

Parameters

files
Type: SystemString
Files containing source code.
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository Properties

ITypeScriptRepository Properties

The ITypeScriptRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | DefaultExtension | When implemented by a class, gets or sets default extension associated with this repository.
Public property | DisplayScaledImages | When implemented by a class, gets ImageList for high DPIs.
Public property | FileName | When implemented by a class, gets or sets file name of the file being parsed.
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | Parser | When implemented by a class, gets a V8Parser that provides syntax analysis for TypeScript document.
Public property | Project | When implemented by a class, gets a ITypeScriptProject that contains document being parsed.
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.DefaultExtension Property

ITypeScriptRepositoryDefaultExtension Property
When implemented by a class, gets or sets default extension associated with this repository.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string DefaultExtension { get; set; }
Property DefaultExtension As String
    Get
    Set
property String^ DefaultExtension {
    String^ get ();
    void set (String^ value);
}
abstract DefaultExtension : string with get, set

Property Value

Type: String
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.DisplayScaledImages Property

ITypeScriptRepositoryDisplayScaledImages Property
When implemented by a class, gets ImageList for high DPIs.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
DisplayScaledImages DisplayScaledImages { get; }
ReadOnly Property DisplayScaledImages As DisplayScaledImages
    Get
property DisplayScaledImages^ DisplayScaledImages {
    DisplayScaledImages^ get ();
}
abstract DisplayScaledImages : DisplayScaledImages with get

Property Value

Type: DisplayScaledImages
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.FileName Property

ITypeScriptRepositoryFileName Property
When implemented by a class, gets or sets file name of the file being parsed.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.Parser Property

ITypeScriptRepositoryParser Property
When implemented by a class, gets a V8Parser that provides syntax analysis for TypeScript document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
V8Parser Parser { get; }
ReadOnly Property Parser As V8Parser
    Get
property V8Parser^ Parser {
    V8Parser^ get ();
}
abstract Parser : V8Parser with get

Property Value

Type: V8Parser
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.Project Property

ITypeScriptRepositoryProject Property
When implemented by a class, gets a ITypeScriptProject that contains document being parsed.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
ITypeScriptProject Project { get; }
ReadOnly Property Project As ITypeScriptProject
    Get
property ITypeScriptProject^ Project {
    ITypeScriptProject^ get ();
}
abstract Project : ITypeScriptProject with get

Property Value

Type: ITypeScriptProject
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository Events

ITypeScriptRepository Events

The ITypeScriptRepository type exposes the following members.

Events
 | Name | Description
Public event | CustomFormattingOptions | When implemented by a class, occurs while trying to obtains information about formatting options related to the document.
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


ITypeScriptRepository.CustomFormattingOptions Event

ITypeScriptRepositoryCustomFormattingOptions Event
When implemented by a class, occurs while trying to obtains information about formatting options related to the document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
event EventHandler<FormattingOptionsEventArgs> CustomFormattingOptions
Event CustomFormattingOptions As EventHandler(Of FormattingOptionsEventArgs)
 event EventHandler<FormattingOptionsEventArgs^>^ CustomFormattingOptions {
    void add (EventHandler<FormattingOptionsEventArgs^>^ value);
    void remove (EventHandler<FormattingOptionsEventArgs^>^ value);
}
abstract CustomFormattingOptions : IEvent<EventHandler<FormattingOptionsEventArgs>,
    FormattingOptionsEventArgs>

Value

Type: SystemEventHandlerFormattingOptionsEventArgs
See Also

Reference

ITypeScriptRepository Interface
Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser Class

JavaScriptParser Class
Represents properties and methods to perform syntax analysis of the text intended to use for JavaScript language.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.TypeScriptTypeScriptParser
Alternet.Syntax.Parsers.TypeScriptJavaScriptParser

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JavaScriptParser : TypeScriptParser
Public Class JavaScriptParser
    Inherits TypeScriptParser
public ref class JavaScriptParser : public TypeScriptParser
type JavaScriptParser =
    class
        inherit TypeScriptParser
    end

The JavaScriptParser type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptParser | Initializes a new instance of the JavaScriptParser class with default TypeScriptProject.
Public method | JavaScriptParser(ITypeScriptProject) | Initializes a new instance of the JavaScriptParser class with specified ITypeScriptProject.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CanFindDeclaration | (Inherited from TypeScriptParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from TypeScriptParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides TypeScriptParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | (Inherited from TypeScriptParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from TypeScriptParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from TypeScriptParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from TypeScriptParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from TypeScriptParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from TypeScriptParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from TypeScriptParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from TypeScriptParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from TypeScriptParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from TypeScriptParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | (Inherited from TypeScriptParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from TypeScriptParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from TypeScriptParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from TypeScriptParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment. (Inherited from TypeScriptParser.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from TypeScriptParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from TypeScriptParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from TypeScriptParser.)
Public method | ParseSemanticAsync | Performs syntax analysis of specified document. (Inherited from TypeScriptParser.)
Public method | ParseSyntaxAsync | Performs syntax analysis of specified document. (Inherited from TypeScriptParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from TypeScriptParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from TypeScriptParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from TypeScriptParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterDefaultAssemblies | Adds default system assemblies to be used for Code completion. (Inherited from TypeScriptParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from TypeScriptParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from TypeScriptParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from TypeScriptParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from TypeScriptParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from TypeScriptParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from TypeScriptParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from TypeScriptParser.)
Public method | ResetScriptKind | Resets ScriptKind to the default value. (Overrides TypeScriptParserResetScriptKind.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from TypeScriptParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from TypeScriptParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from TypeScriptParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from TypeScriptParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from TypeScriptParser.)
Public method | ShouldSerializeScriptKind | Indicates whether the ScriptKind property should be persisted. (Overrides TypeScriptParserShouldSerializeScriptKind.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from TypeScriptParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from TypeScriptParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from TypeScriptParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from TypeScriptParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from TypeScriptParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | (Inherited from TypeScriptParser.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from TypeScriptParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from TypeScriptParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | ScriptKind | Gets or sets kind of the source code file being parsed. (Inherited from TypeScriptParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from TypeScriptParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from TypeScriptParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | Tokenizer | (Inherited from TypeScriptParser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser Constructor

JavaScriptParser Constructor
Overload List
 | Name | Description
Public method | JavaScriptParser | Initializes a new instance of the JavaScriptParser class with default TypeScriptProject.
Public method | JavaScriptParser(ITypeScriptProject) | Initializes a new instance of the JavaScriptParser class with specified ITypeScriptProject.
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser Constructor

JavaScriptParser Constructor
Initializes a new instance of the JavaScriptParser class with default TypeScriptProject.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaScriptParser()
Public Sub New
public:
JavaScriptParser()
new : unit -> JavaScriptParser
See Also

Reference

JavaScriptParser Class
JavaScriptParser Overload
Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser Constructor (ITypeScriptProject)

JavaScriptParser Constructor (ITypeScriptProject)
Initializes a new instance of the JavaScriptParser class with specified ITypeScriptProject.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public JavaScriptParser(
    ITypeScriptProject project
)
Public Sub New (
    project As ITypeScriptProject
)
public:
JavaScriptParser(
    ITypeScriptProject^ project
)
new :
        project : ITypeScriptProject -> JavaScriptParser

Parameters

project
Type: ITypeScriptProject
Specifies ITypeScriptProject to this new instance.
See Also

Reference

JavaScriptParser Class
JavaScriptParser Overload
Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser Methods

JavaScriptParser Methods

The JavaScriptParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CanFindDeclaration | (Inherited from TypeScriptParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from TypeScriptParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides TypeScriptParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion | (Inherited from TypeScriptParser.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from TypeScriptParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from TypeScriptParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from TypeScriptParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from TypeScriptParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from TypeScriptParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from TypeScriptParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from TypeScriptParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from TypeScriptParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Inherited from TypeScriptParser.)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | (Inherited from TypeScriptParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Inherited from TypeScriptParser.)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from TypeScriptParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from TypeScriptParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment. (Inherited from TypeScriptParser.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from TypeScriptParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from TypeScriptParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from TypeScriptParser.)
Public method | ParseSemanticAsync | Performs syntax analysis of specified document. (Inherited from TypeScriptParser.)
Public method | ParseSyntaxAsync | Performs syntax analysis of specified document. (Inherited from TypeScriptParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from TypeScriptParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from TypeScriptParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from TypeScriptParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterDefaultAssemblies | Adds default system assemblies to be used for Code completion. (Inherited from TypeScriptParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Inherited from TypeScriptParser.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from TypeScriptParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from TypeScriptParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Inherited from TypeScriptParser.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Inherited from TypeScriptParser.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Inherited from TypeScriptParser.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from TypeScriptParser.)
Public method | ResetScriptKind | Resets ScriptKind to the default value. (Overrides TypeScriptParserResetScriptKind.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from TypeScriptParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Inherited from TypeScriptParser.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Inherited from TypeScriptParser.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Inherited from TypeScriptParser.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from TypeScriptParser.)
Public method | ShouldSerializeScriptKind | Indicates whether the ScriptKind property should be persisted. (Overrides TypeScriptParserShouldSerializeScriptKind.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from TypeScriptParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from TypeScriptParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from TypeScriptParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from TypeScriptParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from TypeScriptParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | (Inherited from TypeScriptParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser.CreateRepository Method

JavaScriptParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser.ResetScriptKind Method

JavaScriptParserResetScriptKind Method
Resets ScriptKind to the default value.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetScriptKind()
Public Overrides Sub ResetScriptKind
public:
virtual void ResetScriptKind() override
abstract ResetScriptKind : unit -> unit
override ResetScriptKind : unit -> unit
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser.ShouldSerializeScriptKind Method

JavaScriptParserShouldSerializeScriptKind Method
Indicates whether the ScriptKind property should be persisted.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeScriptKind()
Public Overrides Function ShouldSerializeScriptKind As Boolean
public:
virtual bool ShouldSerializeScriptKind() override
abstract ShouldSerializeScriptKind : unit -> bool
override ShouldSerializeScriptKind : unit -> bool

Return Value

Type: Boolean
True if ScriptKind differs from its default value; otherwise false.
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser Properties

JavaScriptParser Properties

The JavaScriptParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from TypeScriptParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes. (Inherited from TypeScriptParser.)
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | ScriptKind | Gets or sets kind of the source code file being parsed. (Inherited from TypeScriptParser.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Inherited from TypeScriptParser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics | (Inherited from TypeScriptParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | Tokenizer | (Inherited from TypeScriptParser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


JavaScriptParser Events

JavaScriptParser Events

The JavaScriptParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

JavaScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts Class

TypeScriptConsts Class
Contains default constants related to lexical and syntax analyzers.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.TypeScriptTypeScriptConsts

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TypeScriptConsts
Public Class TypeScriptConsts
public ref class TypeScriptConsts
type TypeScriptConsts =  class end

The TypeScriptConsts type exposes the following members.

Constructors
 | Name | Description
Public method | TypeScriptConsts | Initializes a new instance of the TypeScriptConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
CategoryClasses |
CategoryConstants |
CategoryDelegates |
CategoryEnums |
CategoryEvents |
CategoryFields |
CategoryInterfaces |
CategoryKeywords |
CategoryLocalVars |
CategoryMethods |
CategoryNamespaces |
CategoryParameters |
CategoryProperties |
CategorySnippets |
CategoryStructs |
DeclarationGuideLines |
DefaultExtesion |
DefaultMethodForeColor |
DefaultParseInterval |
DefaultTypeForeColor |
DefaultTypeScriptAutoIndentChars |
DefaultTypeScriptCodeCompletionChars |
DefaultTypeScriptSmartFormatChars |
DefaultTypeScriptSyntaxOptions |
DefaultTypeScriptXmlCommentStart |
DefaultWarningsForeColor |
DefaultXmlParamsForeColor |
LookAheadLines |
LookAheadLinesAsync |
MethodInternalName |
StatementsGuideLines |
TypeInternalName |
WarningsInternalName |
XmlParamsInternalName |
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts Constructor

TypeScriptConsts Constructor
Initializes a new instance of the TypeScriptConsts class

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptConsts()
Public Sub New
public:
TypeScriptConsts()
new : unit -> TypeScriptConsts
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts Fields

TypeScriptConsts Fields

The TypeScriptConsts type exposes the following members.

Fields
Name | Description
CategoryClasses |
CategoryConstants |
CategoryDelegates |
CategoryEnums |
CategoryEvents |
CategoryFields |
CategoryInterfaces |
CategoryKeywords |
CategoryLocalVars |
CategoryMethods |
CategoryNamespaces |
CategoryParameters |
CategoryProperties |
CategorySnippets |
CategoryStructs |
DeclarationGuideLines |
DefaultExtesion |
DefaultMethodForeColor |
DefaultParseInterval |
DefaultTypeForeColor |
DefaultTypeScriptAutoIndentChars |
DefaultTypeScriptCodeCompletionChars |
DefaultTypeScriptSmartFormatChars |
DefaultTypeScriptSyntaxOptions |
DefaultTypeScriptXmlCommentStart |
DefaultWarningsForeColor |
DefaultXmlParamsForeColor |
LookAheadLines |
LookAheadLinesAsync |
MethodInternalName |
StatementsGuideLines |
TypeInternalName |
WarningsInternalName |
XmlParamsInternalName |
Top
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryClasses Field

TypeScriptConstsCategoryClasses Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryClasses
Public Shared CategoryClasses As String
public:
static String^ CategoryClasses
static val mutable CategoryClasses: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryConstants Field

TypeScriptConstsCategoryConstants Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryConstants
Public Shared CategoryConstants As String
public:
static String^ CategoryConstants
static val mutable CategoryConstants: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryDelegates Field

TypeScriptConstsCategoryDelegates Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryDelegates
Public Shared CategoryDelegates As String
public:
static String^ CategoryDelegates
static val mutable CategoryDelegates: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryEnums Field

TypeScriptConstsCategoryEnums Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryEnums
Public Shared CategoryEnums As String
public:
static String^ CategoryEnums
static val mutable CategoryEnums: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryEvents Field

TypeScriptConstsCategoryEvents Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryEvents
Public Shared CategoryEvents As String
public:
static String^ CategoryEvents
static val mutable CategoryEvents: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryFields Field

TypeScriptConstsCategoryFields Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryFields
Public Shared CategoryFields As String
public:
static String^ CategoryFields
static val mutable CategoryFields: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryInterfaces Field

TypeScriptConstsCategoryInterfaces Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryInterfaces
Public Shared CategoryInterfaces As String
public:
static String^ CategoryInterfaces
static val mutable CategoryInterfaces: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryKeywords Field

TypeScriptConstsCategoryKeywords Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryKeywords
Public Shared CategoryKeywords As String
public:
static String^ CategoryKeywords
static val mutable CategoryKeywords: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryLocalVars Field

TypeScriptConstsCategoryLocalVars Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryLocalVars
Public Shared CategoryLocalVars As String
public:
static String^ CategoryLocalVars
static val mutable CategoryLocalVars: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryMethods Field

TypeScriptConstsCategoryMethods Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryMethods
Public Shared CategoryMethods As String
public:
static String^ CategoryMethods
static val mutable CategoryMethods: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryNamespaces Field

TypeScriptConstsCategoryNamespaces Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryNamespaces
Public Shared CategoryNamespaces As String
public:
static String^ CategoryNamespaces
static val mutable CategoryNamespaces: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryParameters Field

TypeScriptConstsCategoryParameters Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryParameters
Public Shared CategoryParameters As String
public:
static String^ CategoryParameters
static val mutable CategoryParameters: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryProperties Field

TypeScriptConstsCategoryProperties Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryProperties
Public Shared CategoryProperties As String
public:
static String^ CategoryProperties
static val mutable CategoryProperties: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategorySnippets Field

TypeScriptConstsCategorySnippets Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategorySnippets
Public Shared CategorySnippets As String
public:
static String^ CategorySnippets
static val mutable CategorySnippets: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.CategoryStructs Field

TypeScriptConstsCategoryStructs Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CategoryStructs
Public Shared CategoryStructs As String
public:
static String^ CategoryStructs
static val mutable CategoryStructs: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DeclarationGuideLines Field

TypeScriptConstsDeclarationGuideLines Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool DeclarationGuideLines
Public Shared DeclarationGuideLines As Boolean
public:
static bool DeclarationGuideLines
static val mutable DeclarationGuideLines: bool

Field Value

Type: Boolean
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultExtesion Field

TypeScriptConstsDefaultExtesion Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultExtesion
Public Shared DefaultExtesion As String
public:
static String^ DefaultExtesion
static val mutable DefaultExtesion: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultMethodForeColor Field

TypeScriptConstsDefaultMethodForeColor Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultMethodForeColor
Public Shared DefaultMethodForeColor As Color
public:
static Color DefaultMethodForeColor
static val mutable DefaultMethodForeColor: Color

Field Value

Type: Color
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultParseInterval Field

TypeScriptConstsDefaultParseInterval Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int DefaultParseInterval
Public Shared DefaultParseInterval As Integer
public:
static int DefaultParseInterval
static val mutable DefaultParseInterval: int

Field Value

Type: Int32
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultTypeForeColor Field

TypeScriptConstsDefaultTypeForeColor Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultTypeForeColor
Public Shared DefaultTypeForeColor As Color
public:
static Color DefaultTypeForeColor
static val mutable DefaultTypeForeColor: Color

Field Value

Type: Color
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultTypeScriptAutoIndentChars Field

TypeScriptConstsDefaultTypeScriptAutoIndentChars Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultTypeScriptAutoIndentChars
Public Shared DefaultTypeScriptAutoIndentChars As String
public:
static String^ DefaultTypeScriptAutoIndentChars
static val mutable DefaultTypeScriptAutoIndentChars: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultTypeScriptCodeCompletionChars Field

TypeScriptConstsDefaultTypeScriptCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultTypeScriptCodeCompletionChars
Public Shared DefaultTypeScriptCodeCompletionChars As String
public:
static String^ DefaultTypeScriptCodeCompletionChars
static val mutable DefaultTypeScriptCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultTypeScriptSmartFormatChars Field

TypeScriptConstsDefaultTypeScriptSmartFormatChars Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultTypeScriptSmartFormatChars
Public Shared DefaultTypeScriptSmartFormatChars As String
public:
static String^ DefaultTypeScriptSmartFormatChars
static val mutable DefaultTypeScriptSmartFormatChars: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultTypeScriptSyntaxOptions Field

TypeScriptConstsDefaultTypeScriptSyntaxOptions Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultTypeScriptSyntaxOptions
Public Shared DefaultTypeScriptSyntaxOptions As SyntaxOptions
public:
static SyntaxOptions DefaultTypeScriptSyntaxOptions
static val mutable DefaultTypeScriptSyntaxOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultTypeScriptXmlCommentStart Field

TypeScriptConstsDefaultTypeScriptXmlCommentStart Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultTypeScriptXmlCommentStart
Public Shared DefaultTypeScriptXmlCommentStart As String
public:
static String^ DefaultTypeScriptXmlCommentStart
static val mutable DefaultTypeScriptXmlCommentStart: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultWarningsForeColor Field

TypeScriptConstsDefaultWarningsForeColor Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultWarningsForeColor
Public Shared DefaultWarningsForeColor As Color
public:
static Color DefaultWarningsForeColor
static val mutable DefaultWarningsForeColor: Color

Field Value

Type: Color
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.DefaultXmlParamsForeColor Field

TypeScriptConstsDefaultXmlParamsForeColor Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DefaultXmlParamsForeColor
Public Shared DefaultXmlParamsForeColor As Color
public:
static Color DefaultXmlParamsForeColor
static val mutable DefaultXmlParamsForeColor: Color

Field Value

Type: Color
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.LookAheadLines Field

TypeScriptConstsLookAheadLines Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int LookAheadLines
Public Shared LookAheadLines As Integer
public:
static int LookAheadLines
static val mutable LookAheadLines: int

Field Value

Type: Int32
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.LookAheadLinesAsync Field

TypeScriptConstsLookAheadLinesAsync Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int LookAheadLinesAsync
Public Shared LookAheadLinesAsync As Integer
public:
static int LookAheadLinesAsync
static val mutable LookAheadLinesAsync: int

Field Value

Type: Int32
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.MethodInternalName Field

TypeScriptConstsMethodInternalName Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string MethodInternalName
Public Const MethodInternalName As String
public:
literal String^ MethodInternalName
static val mutable MethodInternalName: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.StatementsGuideLines Field

TypeScriptConstsStatementsGuideLines Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool StatementsGuideLines
Public Shared StatementsGuideLines As Boolean
public:
static bool StatementsGuideLines
static val mutable StatementsGuideLines: bool

Field Value

Type: Boolean
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.TypeInternalName Field

TypeScriptConstsTypeInternalName Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string TypeInternalName
Public Const TypeInternalName As String
public:
literal String^ TypeInternalName
static val mutable TypeInternalName: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.WarningsInternalName Field

TypeScriptConstsWarningsInternalName Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string WarningsInternalName
Public Const WarningsInternalName As String
public:
literal String^ WarningsInternalName
static val mutable WarningsInternalName: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts.XmlParamsInternalName Field

TypeScriptConstsXmlParamsInternalName Field

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public const string XmlParamsInternalName
Public Const XmlParamsInternalName As String
public:
literal String^ XmlParamsInternalName
static val mutable XmlParamsInternalName: string

Field Value

Type: String
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptConsts Methods

TypeScriptConsts Methods

The TypeScriptConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TypeScriptConsts Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser Class

TypeScriptParser Class
Represents properties and methods to perform syntax analysis of the text intended to use for TypeScript language.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.Syntax.Parsers.TypeScriptTypeScriptParser
Alternet.Syntax.Parsers.TypeScriptJavaScriptParser

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TypeScriptParser : SyntaxParser
Public Class TypeScriptParser
    Inherits SyntaxParser
public ref class TypeScriptParser : public SyntaxParser
type TypeScriptParser =
    class
        inherit SyntaxParser
    end

The TypeScriptParser type exposes the following members.

Constructors
 | Name | Description
Public method | TypeScriptParser | Initializes a new instance of the TypeScriptParser class with default TypeScriptProject.
Public method | TypeScriptParser(ITypeScriptProject) | Initializes a new instance of the TypeScriptParser class with specified ITypeScriptProject.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CanFindDeclaration |
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion |
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Overrides SyntaxParserFindCodeFixes(Point, ISyntaxError, Boolean).)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Overrides SyntaxParserFindCodeRefactors(Point, Point, Boolean).)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Overrides SyntaxParserFindReferences(Point).)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Overrides SyntaxParserGetActiveStatementAt(Point).)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Overrides SyntaxParserGetCodeFixes(ISyntaxError, Boolean).)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Overrides SyntaxParserGetCodeRefactors(Point, Point, Boolean).)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Overrides SyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32).)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Overrides SyntaxParserGetSyntaxErrors(IListISyntaxError).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Overrides SyntaxParserLoadFile(String, Encoding).)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Overrides SyntaxParserOutline(IListIRange).)
Public method | ParseSemanticAsync | Performs syntax analysis of specified document.
Public method | ParseSyntaxAsync | Performs syntax analysis of specified document.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Overrides SyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason).)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterDefaultAssemblies | Adds default system assemblies to be used for Code completion.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Overrides SyntaxParserReparseText(Boolean, Int32, Int32).)
Public method | Reset | Resets SyntaxParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Overrides SyntaxParserResetParseInterval.)
Public method | ResetScriptKind | Resets ScriptKind to the default value.
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Overrides SyntaxParserShouldSerializeParseInterval.)
Public method | ShouldSerializeScriptKind | Indicates whether the ScriptKind property should be persisted.
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Overrides SyntaxParserSmartFormat(Point, Boolean, Int32, ITextUndoList, String).)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Overrides SyntaxParserSmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList).)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Overrides SyntaxParserStartParsing(String, Int32, Int32).)
Public method | StopParsing | Aborts parsing process. (Overrides SyntaxParserStopParsing.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | (Overrides LexerUpdate.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Overrides SyntaxParserFileName.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | ScriptKind | Gets or sets kind of the source code file being parsed.
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Overrides ParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics |
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | Tokenizer |
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser Constructor

TypeScriptParser Constructor
Overload List
 | Name | Description
Public method | TypeScriptParser | Initializes a new instance of the TypeScriptParser class with default TypeScriptProject.
Public method | TypeScriptParser(ITypeScriptProject) | Initializes a new instance of the TypeScriptParser class with specified ITypeScriptProject.
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser Constructor

TypeScriptParser Constructor
Initializes a new instance of the TypeScriptParser class with default TypeScriptProject.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptParser()
Public Sub New
public:
TypeScriptParser()
new : unit -> TypeScriptParser
See Also

Reference

TypeScriptParser Class
TypeScriptParser Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser Constructor (ITypeScriptProject)

TypeScriptParser Constructor (ITypeScriptProject)
Initializes a new instance of the TypeScriptParser class with specified ITypeScriptProject.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptParser(
    ITypeScriptProject project
)
Public Sub New (
    project As ITypeScriptProject
)
public:
TypeScriptParser(
    ITypeScriptProject^ project
)
new :
        project : ITypeScriptProject -> TypeScriptParser

Parameters

project
Type: ITypeScriptProject
Specifies ITypeScriptProject to this new instance.
See Also

Reference

TypeScriptParser Class
TypeScriptParser Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser Methods

TypeScriptParser Methods

The TypeScriptParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CanFindDeclaration |
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoCodeCompletion |
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Overrides SyntaxParserFindCodeFixes(Point, ISyntaxError, Boolean).)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Overrides SyntaxParserFindCodeRefactors(Point, Point, Boolean).)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Overrides SyntaxParserFindReferences(Point).)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Overrides SyntaxParserGetActiveStatementAt(Point).)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Overrides SyntaxParserGetCodeFixes(ISyntaxError, Boolean).)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Overrides SyntaxParserGetCodeRefactors(Point, Point, Boolean).)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Overrides SyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32).)
Public method | GetStructureGuideLines | Gets list of guide lines. (Overrides SyntaxParserGetStructureGuideLines(IListIRange).)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Overrides SyntaxParserGetSyntaxErrors(IListISyntaxError).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlComment | Represents beginning of XML comment.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Overrides SyntaxParserIsCodeCompletionChar(Char, Byte, Int32).)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Overrides SyntaxParserLoadFile(String, Encoding).)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Overrides SyntaxParserOutline(IListIRange).)
Public method | ParseSemanticAsync | Performs syntax analysis of specified document.
Public method | ParseSyntaxAsync | Performs syntax analysis of specified document.
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Overrides SyntaxParserPositionChanged(Int32, Int32, Int32, Int32).)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Overrides SyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason).)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RegisterDefaultAssemblies | Adds default system assemblies to be used for Code completion.
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Overrides SyntaxParserReparseText(Boolean, Int32, Int32).)
Public method | Reset | Resets SyntaxParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides SyntaxParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Overrides SyntaxParserResetParseInterval.)
Public method | ResetScriptKind | Resets ScriptKind to the default value.
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Overrides SyntaxParserResetSmartFormatChars.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the AutoIndentChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides SyntaxParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Overrides SyntaxParserShouldSerializeParseInterval.)
Public method | ShouldSerializeScriptKind | Indicates whether the ScriptKind property should be persisted.
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeSmartFormatChars.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Overrides SyntaxParserSmartFormat(Point, Boolean, Int32, ITextUndoList, String).)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Overrides SyntaxParserSmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList).)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Overrides SyntaxParserStartParsing(String, Int32, Int32).)
Public method | StopParsing | Aborts parsing process. (Overrides SyntaxParserStopParsing.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | (Overrides LexerUpdate.)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.CanFindDeclaration Method

TypeScriptParserCanFindDeclaration Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanFindDeclaration(
    Point position
)
Public Overridable Function CanFindDeclaration (
    position As Point
) As Boolean
public:
virtual bool CanFindDeclaration(
    Point position
)
abstract CanFindDeclaration :
        position : Point -> bool
override CanFindDeclaration :
        position : Point -> bool

Parameters

position
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.CodeCompletion Method

TypeScriptParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.CodeCompletion Method (String, StringItemInfo[], Point, CodeCompletionArgs)

TypeScriptParserCodeCompletion Method (String, StringItemInfo, Point, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    CodeCompletionArgs e
)
Public Overrides Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    CodeCompletionArgs^ e
) override
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs)
See Also

Reference

TypeScriptParser Class
CodeCompletion Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.CreateRepository Method

TypeScriptParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.DoCodeCompletion Method

TypeScriptParserDoCodeCompletion Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DoCodeCompletion(
    string text,
    Point position,
    CodeCompletionArgs e,
    CancellationToken cancellationToken,
    bool async
)
Public Sub DoCodeCompletion (
    text As String,
    position As Point,
    e As CodeCompletionArgs,
    cancellationToken As CancellationToken,
    async As Boolean
)
public:
void DoCodeCompletion(
    String^ text,
    Point position,
    CodeCompletionArgs^ e,
    CancellationToken cancellationToken,
    bool async
)
member DoCodeCompletion :
        text : string *
        position : Point *
        e : CodeCompletionArgs *
        cancellationToken : CancellationToken *
        async : bool -> unit

Parameters

text
Type: SystemString
position
Type: System.DrawingPoint
e
Type: Alternet.SyntaxCodeCompletionArgs
cancellationToken
Type: System.ThreadingCancellationToken
async
Type: SystemBoolean
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.FindCodeFixes Method

TypeScriptParserFindCodeFixes Method
Locates and highlights available code refactors for given syntax error.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FindCodeFixes(
    Point position,
    ISyntaxError error,
    bool allDocuments = false
)
Public Overrides Sub FindCodeFixes (
    position As Point,
    error As ISyntaxError,
    Optional allDocuments As Boolean = false
)
public:
virtual void FindCodeFixes(
    Point position,
    ISyntaxError^ error,
    bool allDocuments = false
) override
abstract FindCodeFixes :
        position : Point *
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit
override FindCodeFixes :
        position : Point *
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit

Parameters

position
Type: System.DrawingPoint
Current position within the text.
error
Type: Alternet.SyntaxISyntaxError
Syntax error within the text.
allDocuments (Optional)
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Implements

ISyntaxParserFindCodeFixes(Point, ISyntaxError, Boolean)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.FindCodeRefactors Method

TypeScriptParserFindCodeRefactors Method
Locates and highlights available code refactors at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FindCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments = false
)
Public Overrides Sub FindCodeRefactors (
    startPos As Point,
    endPos As Point,
    Optional allDocuments As Boolean = false
)
public:
virtual void FindCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments = false
) override
abstract FindCodeRefactors :
        startPos : Point *
        endPos : Point *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit
override FindCodeRefactors :
        startPos : Point *
        endPos : Point *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> unit

Parameters

startPos
Type: System.DrawingPoint
Start position within the text.
endPos
Type: System.DrawingPoint
End position within the text.
allDocuments (Optional)
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Implements

ISyntaxParserFindCodeRefactors(Point, Point, Boolean)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.FindDeclaration Method

TypeScriptParserFindDeclaration Method
Overload List
 | Name | Description
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Overrides SyntaxParserFindDeclaration(Point).)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.FindDeclaration Method (Point)

TypeScriptParserFindDeclaration Method (Point)
Finds the declaration node at given position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override SymbolLocation FindDeclaration(
    Point position
)
Public Overrides Function FindDeclaration (
    position As Point
) As SymbolLocation
public:
virtual SymbolLocation^ FindDeclaration(
    Point position
) override
abstract FindDeclaration :
        position : Point -> SymbolLocation
override FindDeclaration :
        position : Point -> SymbolLocation

Parameters

position
Type: System.DrawingPoint
Specifies position to find node.

Return Value

Type: SymbolLocation
SymbolLocation representing declaration location.

Implements

ISyntaxParserFindDeclaration(Point)
See Also

Reference

TypeScriptParser Class
FindDeclaration Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.FindReferences Method

TypeScriptParserFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Overrides SyntaxParserFindReferences(Point).)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Overrides SyntaxParserFindReferences(Point, IRangeList, Boolean).)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.FindReferences Method (Point)

TypeScriptParserFindReferences Method (Point)
Locates and highlights references at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void FindReferences(
    Point position
)
Public Overrides Sub FindReferences (
    position As Point
)
public:
virtual void FindReferences(
    Point position
) override
abstract FindReferences :
        position : Point -> unit
override FindReferences :
        position : Point -> unit

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Implements

ISyntaxParserFindReferences(Point)
See Also

Reference

TypeScriptParser Class
FindReferences Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.FindReferences Method (Point, IRangeList, Boolean)

TypeScriptParserFindReferences Method (Point, IRangeList, Boolean)
Locates declaration at given position and finds all references to this declaration in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int FindReferences(
    Point position,
    IRangeList references,
    bool allDocuments = false
)
Public Overrides Function FindReferences (
    position As Point,
    references As IRangeList,
    Optional allDocuments As Boolean = false
) As Integer
public:
virtual int FindReferences(
    Point position,
    IRangeList^ references,
    bool allDocuments = false
) override
abstract FindReferences :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int
override FindReferences :
        position : Point *
        references : IRangeList *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> int

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.
references
Type: Alternet.CommonIRangeList
Retrieves references to found declaration.
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: Int32
Number of found references.

Implements

ISyntaxParserFindReferences(Point, IRangeList, Boolean)
See Also

Reference

TypeScriptParser Class
FindReferences Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetActiveStatementAt Method

TypeScriptParserGetActiveStatementAt Method
Gets IRange that corresponds to the statement at specified position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IRange GetActiveStatementAt(
    Point position
)
Public Overrides Function GetActiveStatementAt (
    position As Point
) As IRange
public:
virtual IRange^ GetActiveStatementAt(
    Point position
) override
abstract GetActiveStatementAt :
        position : Point -> IRange
override GetActiveStatementAt :
        position : Point -> IRange

Parameters

position
Type: System.DrawingPoint
Position to find range.

Return Value

Type: IRange
Statement range at given position

Implements

ISyntaxParserGetActiveStatementAt(Point)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetCodeFixes Method

TypeScriptParserGetCodeFixes Method
Retrieves all code fixes available for the given syntax error.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IList<ICodeFix> GetCodeFixes(
    ISyntaxError error,
    bool allDocuments = false
)
Public Overrides Function GetCodeFixes (
    error As ISyntaxError,
    Optional allDocuments As Boolean = false
) As IList(Of ICodeFix)
public:
virtual IList<ICodeFix^>^ GetCodeFixes(
    ISyntaxError^ error,
    bool allDocuments = false
) override
abstract GetCodeFixes :
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> IList<ICodeFix>
override GetCodeFixes :
        error : ISyntaxError *
        ?allDocuments : bool
(* Defaults:
        let _allDocuments = defaultArg allDocuments false
*)
-> IList<ICodeFix>

Parameters

error
Type: Alternet.SyntaxISyntaxError
Syntaxe error or warning
allDocuments (Optional)
Type: SystemBoolean
Specifies if search needs to process all documents in the solution

Return Value

Type: IListICodeFix
Collection of available code fixes.

Implements

ISyntaxParserGetCodeFixes(ISyntaxError, Boolean)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetCodeRefactors Method

TypeScriptParserGetCodeRefactors Method
Overload List
 | Name | Description
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Overrides SyntaxParserGetCodeRefactors(Point, Point, Boolean).)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetCodeRefactors Method (Point, Point, Boolean)

TypeScriptParserGetCodeRefactors Method (Point, Point, Boolean)
Retrieves all applicable refactors at given range.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IList<ICodeRefactor> GetCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments
)
Public Overrides Function GetCodeRefactors (
    startPos As Point,
    endPos As Point,
    allDocuments As Boolean
) As IList(Of ICodeRefactor)
public:
virtual IList<ICodeRefactor^>^ GetCodeRefactors(
    Point startPos,
    Point endPos,
    bool allDocuments
) override
abstract GetCodeRefactors :
        startPos : Point *
        endPos : Point *
        allDocuments : bool -> IList<ICodeRefactor>
override GetCodeRefactors :
        startPos : Point *
        endPos : Point *
        allDocuments : bool -> IList<ICodeRefactor>

Parameters

startPos
Type: System.DrawingPoint
Star position within the text.
endPos
Type: System.DrawingPoint
End position within the text..
allDocuments
Type: SystemBoolean
Specifies all documents in the solution needs to be processed.

Return Value

Type: IListICodeRefactor
Collection of available code refactors

Implements

ISyntaxParserGetCodeRefactors(Point, Point, Boolean)
See Also

Reference

TypeScriptParser Class
GetCodeRefactors Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetCompletionType Method

TypeScriptParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides SyntaxParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetCompletionType Method (Char)

TypeScriptParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

TypeScriptParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetSingleLineComment Method

TypeScriptParserGetSingleLineComment Method
Overload List
 | Name | Description
Public method | GetSingleLineComment | (Overrides SyntaxParserGetSingleLineComment.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetSingleLineComment Method

TypeScriptParserGetSingleLineComment Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSingleLineComment()
Public Overrides Function GetSingleLineComment As String
public:
virtual String^ GetSingleLineComment() override
abstract GetSingleLineComment : unit -> string
override GetSingleLineComment : unit -> string

Return Value

Type: String

Implements

ISyntaxParserGetSingleLineComment
See Also

Reference

TypeScriptParser Class
GetSingleLineComment Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetSmartIndentString Method

TypeScriptParserGetSmartIndentString Method
Returns indentation string for specified line.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
Public Overrides Function GetSmartIndentString (
    index As Integer,
    autoIndent As Boolean,
    useSpaces As Boolean,
    spacesInTab As Integer
) As String
public:
virtual String^ GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
) override
abstract GetSmartIndentString :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string
override GetSmartIndentString :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.

Return Value

Type: String
Indentation text at line specified by index.

Implements

ISyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetStructureGuideLines Method

TypeScriptParserGetStructureGuideLines Method
Gets list of guide lines.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetStructureGuideLines(
    IList<IRange> guideLines
)
Public Overrides Function GetStructureGuideLines (
    guideLines As IList(Of IRange)
) As Integer
public:
virtual int GetStructureGuideLines(
    IList<IRange^>^ guideLines
) override
abstract GetStructureGuideLines :
        guideLines : IList<IRange> -> int
override GetStructureGuideLines :
        guideLines : IList<IRange> -> int

Parameters

guideLines
Type: System.Collections.GenericIListIRange
List of guide lines coordinates

Return Value

Type: Int32
Number of guidelines found.

Implements

ISyntaxParserGetStructureGuideLines(IListIRange)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetSyntaxErrors Method

TypeScriptParserGetSyntaxErrors Method
Retrieves all syntax errors found while analyzing the text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetSyntaxErrors(
    IList<ISyntaxError> errors
)
Public Overrides Function GetSyntaxErrors (
    errors As IList(Of ISyntaxError)
) As Integer
public:
virtual int GetSyntaxErrors(
    IList<ISyntaxError^>^ errors
) override
abstract GetSyntaxErrors :
        errors : IList<ISyntaxError> -> int
override GetSyntaxErrors :
        errors : IList<ISyntaxError> -> int

Parameters

errors
Type: System.Collections.GenericIListISyntaxError
Retrieves a collection of syntax error.

Return Value

Type: Int32
Number of syntax errors that are found.

Implements

ISyntaxParserGetSyntaxErrors(IListISyntaxError)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.GetXmlComment Method

TypeScriptParserGetXmlComment Method
Represents beginning of XML comment.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetXmlComment()
Public Overridable Function GetXmlComment As String
public:
virtual String^ GetXmlComment()
abstract GetXmlComment : unit -> string
override GetXmlComment : unit -> string

Return Value

Type: String
String determines XML comment start.
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.IsCodeCompletionChar Method

TypeScriptParserIsCodeCompletionChar Method
Returns boolean value indicating that given character initializes a code completion procedure when typing.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsCodeCompletionChar(
    char ch,
    byte style,
    ref int interval
)
Public Overrides Function IsCodeCompletionChar (
    ch As Char,
    style As Byte,
    ByRef interval As Integer
) As Boolean
public:
virtual bool IsCodeCompletionChar(
    wchar_t ch,
    unsigned char style,
    int% interval
) override
abstract IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool
override IsCodeCompletionChar :
        ch : char *
        style : byte *
        interval : int byref -> bool

Parameters

ch
Type: SystemChar
Given character.
style
Type: SystemByte
Specifies text style at cursor.
interval
Type: SystemInt32
Represents the delay, in milliseconds before displaying code completion window.

Return Value

Type: Boolean
True if given character is code completion character; otherwise false.

Implements

ISyntaxParserIsCodeCompletionChar(Char, Byte, Int32)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.LoadFile Method

TypeScriptParserLoadFile Method
Overload List
 | Name | Description
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Overrides SyntaxParserLoadFile(String, Encoding).)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.LoadFile Method (String, Encoding)

TypeScriptParserLoadFile Method (String, Encoding)
Loads the contents of the specified file with specified encoding.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool LoadFile(
    string fileName,
    Encoding encoding
)
Public Overrides Function LoadFile (
    fileName As String,
    encoding As Encoding
) As Boolean
public:
virtual bool LoadFile(
    String^ fileName,
    Encoding^ encoding
) override
abstract LoadFile :
        fileName : string *
        encoding : Encoding -> bool
override LoadFile :
        fileName : string *
        encoding : Encoding -> bool

Parameters

fileName
Type: SystemString
Name of file to load text.
encoding
Type: System.TextEncoding
Specifies the character encoding to use.

Return Value

Type: Boolean
True is succeed; otherwise false.

Implements

IImportLoadFile(String, Encoding)
See Also

Reference

TypeScriptParser Class
LoadFile Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.Outline Method

TypeScriptParserOutline Method
Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int Outline(
    IList<IRange> ranges
)
Public Overrides Function Outline (
    ranges As IList(Of IRange)
) As Integer
public:
virtual int Outline(
    IList<IRange^>^ ranges
) override
abstract Outline :
        ranges : IList<IRange> -> int
override Outline :
        ranges : IList<IRange> -> int

Parameters

ranges
Type: System.Collections.GenericIListIRange
Retrieves IOutlineRange collection for outlined sections.

Return Value

Type: Int32
Number of outlined sections.

Implements

ISyntaxParserOutline(IListIRange)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ParseSemanticAsync Method

TypeScriptParserParseSemanticAsync Method
Performs syntax analysis of specified document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task ParseSemanticAsync(
    CancellationToken cancellationToken
)
Public Overridable Function ParseSemanticAsync (
    cancellationToken As CancellationToken
) As Task
public:
virtual Task^ ParseSemanticAsync(
    CancellationToken cancellationToken
)
abstract ParseSemanticAsync :
        cancellationToken : CancellationToken -> Task
override ParseSemanticAsync :
        cancellationToken : CancellationToken -> Task

Parameters

cancellationToken
Type: System.ThreadingCancellationToken
Represents a token handles cancellation operation.

Return Value

Type: Task
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ParseSyntaxAsync Method

TypeScriptParserParseSyntaxAsync Method
Performs syntax analysis of specified document.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Task ParseSyntaxAsync(
    int first,
    int last,
    CancellationToken cancellationToken
)
Public Overridable Function ParseSyntaxAsync (
    first As Integer,
    last As Integer,
    cancellationToken As CancellationToken
) As Task
public:
virtual Task^ ParseSyntaxAsync(
    int first,
    int last,
    CancellationToken cancellationToken
)
abstract ParseSyntaxAsync :
        first : int *
        last : int *
        cancellationToken : CancellationToken -> Task
override ParseSyntaxAsync :
        first : int *
        last : int *
        cancellationToken : CancellationToken -> Task

Parameters

first
Type: SystemInt32
last
Type: SystemInt32
cancellationToken
Type: System.ThreadingCancellationToken
Represents a token handles cancellation operation.

Return Value

Type: Task
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ParseText Method

TypeScriptParserParseText Method
Overload List
 | Name | Description
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Overrides SyntaxParserParseText(Int32, Int32, String, StringItemInfo).)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ParseText Method (Int32, Int32, String, StringItemInfo[])

TypeScriptParserParseText Method (Int32, Int32, String, StringItemInfo)
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int ParseText(
    int state,
    int line,
    string str,
    ref StringItemInfo[] colorData
)
Public Overrides Function ParseText (
    state As Integer,
    line As Integer,
    str As String,
    ByRef colorData As StringItemInfo()
) As Integer
public:
virtual int ParseText(
    int state,
    int line,
    String^ str,
    array<StringItemInfo>^% colorData
) override
abstract ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int
override ParseText :
        state : int *
        line : int *
        str : string *
        colorData : StringItemInfo[] byref -> int

Parameters

state
Type: SystemInt32
Specifies start lexical state.
line
Type: SystemInt32
Specifies current line within the text.
str
Type: SystemString
Text to analyze.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text.

Return Value

Type: Int32
Final lexical state.

Implements

ILexerParseText(Int32, Int32, String, StringItemInfo)
ILexerParseText(Int32, Int32, String, StringItemInfo)
See Also

Reference

TypeScriptParser Class
ParseText Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.PositionChanged Method

TypeScriptParserPositionChanged Method
Changes positions of any syntax nodes and its elements located next to the specified position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
)
Public Overrides Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer
)
public:
virtual void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY
) override
abstract PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit
override PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.

Implements

ISyntaxParserPositionChanged(Int32, Int32, Int32, Int32)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.Prepare Method

TypeScriptParserPrepare Method
Overload List
 | Name | Description
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Overrides SyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason).)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.Prepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)

TypeScriptParserPrepare Method (String, IStringList, ISyntaxTree, Boolean, PrepareReason)
Sets lines to parse.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Prepare(
    string fileName,
    IStringList lines,
    ISyntaxTree syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason.None
)
Public Overrides Sub Prepare (
    fileName As String,
    lines As IStringList,
    syntaxTree As ISyntaxTree,
    useThread As Boolean,
    Optional reason As PrepareReason = PrepareReason.None
)
public:
virtual void Prepare(
    String^ fileName,
    IStringList^ lines,
    ISyntaxTree^ syntaxTree,
    bool useThread,
    PrepareReason reason = PrepareReason::None
) override
abstract Prepare :
        fileName : string *
        lines : IStringList *
        syntaxTree : ISyntaxTree *
        useThread : bool *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit
override Prepare :
        fileName : string *
        lines : IStringList *
        syntaxTree : ISyntaxTree *
        useThread : bool *
        ?reason : PrepareReason
(* Defaults:
        let _reason = defaultArg reason PrepareReason.None
*)
-> unit

Parameters

fileName
Type: SystemString
File to parse
lines
Type: Alternet.SyntaxIStringList
Strings to parse
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies current parser tree.
useThread
Type: SystemBoolean
Specifies whether parser should perform the task in the separate thread
reason (Optional)
Type: Alternet.SyntaxPrepareReason
Reason for this method to be called.

Implements

ISyntaxParserPrepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason)
See Also

Reference

TypeScriptParser Class
Prepare Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.RegisterDefaultAssemblies Method

TypeScriptParserRegisterDefaultAssemblies Method
Adds default system assemblies to be used for Code completion.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterDefaultAssemblies(
    TechnologyEnvironment technologyEnvironment
)
Public Overridable Sub RegisterDefaultAssemblies (
    technologyEnvironment As TechnologyEnvironment
)
public:
virtual void RegisterDefaultAssemblies(
    TechnologyEnvironment technologyEnvironment
)
abstract RegisterDefaultAssemblies :
        technologyEnvironment : TechnologyEnvironment -> unit
override RegisterDefaultAssemblies :
        technologyEnvironment : TechnologyEnvironment -> unit

Parameters

technologyEnvironment
Type: Alternet.CommonTechnologyEnvironment
Specifies platform to be used for code completion.
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ReparseText Method

TypeScriptParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides SyntaxParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Inherited from SyntaxParser.)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Overrides SyntaxParserReparseText(Boolean, Int32, Int32).)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ReparseText Method

TypeScriptParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

TypeScriptParser Class
ReparseText Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ReparseText Method (Boolean, Int32, Int32)

TypeScriptParserReparseText Method (Boolean, Int32, Int32)
Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText(
    bool useThread,
    int first,
    int last
)
Public Overrides Sub ReparseText (
    useThread As Boolean,
    first As Integer,
    last As Integer
)
public:
virtual void ReparseText(
    bool useThread,
    int first,
    int last
) override
abstract ReparseText :
        useThread : bool *
        first : int *
        last : int -> unit
override ReparseText :
        useThread : bool *
        first : int *
        last : int -> unit

Parameters

useThread
Type: SystemBoolean
first
Type: SystemInt32
last
Type: SystemInt32

Implements

ISyntaxParserReparseText(Boolean, Int32, Int32)
See Also

Reference

TypeScriptParser Class
ReparseText Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.Reset Method

TypeScriptParserReset Method
Overload List
 | Name | Description
Public method | Reset | Resets SyntaxParser to the start position. (Overrides SyntaxParserReset.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.Reset Method

TypeScriptParserReset Method
Resets SyntaxParser to the start position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IParserReset
IParserReset
See Also

Reference

TypeScriptParser Class
Reset Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ResetAutoIndentChars Method

TypeScriptParserResetAutoIndentChars Method
Resets AutoIndentChars to the default value.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ResetCodeCompletionChars Method

TypeScriptParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ResetOptions Method

TypeScriptParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ResetParseInterval Method

TypeScriptParserResetParseInterval Method
Resets ParseInterval to the default value.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetParseInterval()
Public Overrides Sub ResetParseInterval
public:
virtual void ResetParseInterval() override
abstract ResetParseInterval : unit -> unit
override ResetParseInterval : unit -> unit

Implements

ISyntaxParserResetParseInterval
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ResetScriptKind Method

TypeScriptParserResetScriptKind Method
Resets ScriptKind to the default value.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ResetScriptKind()
Public Overridable Sub ResetScriptKind
public:
virtual void ResetScriptKind()
abstract ResetScriptKind : unit -> unit
override ResetScriptKind : unit -> unit
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ResetSmartFormatChars Method

TypeScriptParserResetSmartFormatChars Method
Resets SmartFormatChars to the default value.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetSmartFormatChars()
Public Overrides Sub ResetSmartFormatChars
public:
virtual void ResetSmartFormatChars() override
abstract ResetSmartFormatChars : unit -> unit
override ResetSmartFormatChars : unit -> unit

Implements

ISyntaxParserResetSmartFormatChars
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ShouldSerializeAutoIndentChars Method

TypeScriptParserShouldSerializeAutoIndentChars Method
Indicates whether the AutoIndentChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeAutoIndentChars()
Public Overrides Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars() override
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if AutoIndentChars differs from its default value; otherwise false.
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ShouldSerializeCodeCompletionChars Method

TypeScriptParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ShouldSerializeOptions Method

TypeScriptParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ShouldSerializeParseInterval Method

TypeScriptParserShouldSerializeParseInterval Method
Indicates whether the ParseInterval property should be persisted.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeParseInterval()
Public Overrides Function ShouldSerializeParseInterval As Boolean
public:
virtual bool ShouldSerializeParseInterval() override
abstract ShouldSerializeParseInterval : unit -> bool
override ShouldSerializeParseInterval : unit -> bool

Return Value

Type: Boolean
True if ParseInterval differs from its default value; otherwise false.
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ShouldSerializeScriptKind Method

TypeScriptParserShouldSerializeScriptKind Method
Indicates whether the ScriptKind property should be persisted.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShouldSerializeScriptKind()
Public Overridable Function ShouldSerializeScriptKind As Boolean
public:
virtual bool ShouldSerializeScriptKind()
abstract ShouldSerializeScriptKind : unit -> bool
override ShouldSerializeScriptKind : unit -> bool

Return Value

Type: Boolean
True if ScriptKind differs from its default value; otherwise false.
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ShouldSerializeSmartFormatChars Method

TypeScriptParserShouldSerializeSmartFormatChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeSmartFormatChars()
Public Overrides Function ShouldSerializeSmartFormatChars As Boolean
public:
virtual bool ShouldSerializeSmartFormatChars() override
abstract ShouldSerializeSmartFormatChars : unit -> bool
override ShouldSerializeSmartFormatChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.SmartFormat Method

TypeScriptParserSmartFormat Method
Overload List
 | Name | Description
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Overrides SyntaxParserSmartFormat(Point, Boolean, Int32, ITextUndoList, String).)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Overrides SyntaxParserSmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList).)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.SmartFormat Method (Point, Boolean, Int32, ITextUndoList, String)

TypeScriptParserSmartFormat Method (Point, Boolean, Int32, ITextUndoList, String)
Formats block of text according to the parser rules.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SmartFormat(
    ref Point position,
    bool useSpace,
    int spacesInTab,
    ITextUndoList operations,
    string key = ""
)
Public Overrides Function SmartFormat (
    ByRef position As Point,
    useSpace As Boolean,
    spacesInTab As Integer,
    operations As ITextUndoList,
    Optional key As String = ""
) As Boolean
public:
virtual bool SmartFormat(
    Point% position,
    bool useSpace,
    int spacesInTab,
    ITextUndoList^ operations,
    String^ key = L""
) override
abstract SmartFormat :
        position : Point byref *
        useSpace : bool *
        spacesInTab : int *
        operations : ITextUndoList *
        ?key : string
(* Defaults:
        let _key = defaultArg key ""
*)
-> bool
override SmartFormat :
        position : Point byref *
        useSpace : bool *
        spacesInTab : int *
        operations : ITextUndoList *
        ?key : string
(* Defaults:
        let _key = defaultArg key ""
*)
-> bool

Parameters

position
Type: System.DrawingPoint
useSpace
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab
operations
Type: Alternet.SyntaxITextUndoList
List containing insertion or deletion of text fragments.
key (Optional)
Type: SystemString
Keystroke being typed.

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserSmartFormat(Point, Boolean, Int32, ITextUndoList, String)
See Also

Reference

TypeScriptParser Class
SmartFormat Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.SmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)

TypeScriptParserSmartFormat Method (Point, Point, Boolean, Int32, Boolean, ITextUndoList)
Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool SmartFormat(
    ref Point start,
    ref Point end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList operations
)
Public Overrides Function SmartFormat (
    ByRef start As Point,
    ByRef end As Point,
    useSpaces As Boolean,
    spacesInTab As Integer,
    extended As Boolean,
    operations As ITextUndoList
) As Boolean
public:
virtual bool SmartFormat(
    Point% start,
    Point% end,
    bool useSpaces,
    int spacesInTab,
    bool extended,
    ITextUndoList^ operations
) override
abstract SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool
override SmartFormat :
        start : Point byref *
        end : Point byref *
        useSpaces : bool *
        spacesInTab : int *
        extended : bool *
        operations : ITextUndoList -> bool

Parameters

start
Type: System.DrawingPoint
end
Type: System.DrawingPoint
useSpaces
Type: SystemBoolean
spacesInTab
Type: SystemInt32
extended
Type: SystemBoolean
operations
Type: Alternet.SyntaxITextUndoList

Return Value

Type: Boolean
True if succeed; otherwise false.

Implements

ISyntaxParserSmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList)
See Also

Reference

TypeScriptParser Class
SmartFormat Overload
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.StartParsing Method

TypeScriptParserStartParsing Method
Prepares parser to parse the specified range of the text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void StartParsing(
    string fileName,
    int first,
    int last
)
Public Overrides Sub StartParsing (
    fileName As String,
    first As Integer,
    last As Integer
)
public:
virtual void StartParsing(
    String^ fileName,
    int first,
    int last
) override
abstract StartParsing :
        fileName : string *
        first : int *
        last : int -> unit
override StartParsing :
        fileName : string *
        first : int *
        last : int -> unit

Parameters

fileName
Type: SystemString
Filename to parse
first
Type: SystemInt32
Specifies first changed line in the source text.
last
Type: SystemInt32
Specifies last changed line in the source text.

Implements

ISyntaxParserStartParsing(String, Int32, Int32)
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.StopParsing Method

TypeScriptParserStopParsing Method
Aborts parsing process.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void StopParsing()
Public Overrides Sub StopParsing
public:
virtual void StopParsing() override
abstract StopParsing : unit -> unit
override StopParsing : unit -> unit

Implements

ISyntaxParserStopParsing
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.Update Method

TypeScriptParserUpdate Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Update()
Public Overrides Sub Update
public:
virtual void Update() override
abstract Update : unit -> unit
override Update : unit -> unit

Implements

IUpdateUpdate
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser Properties

TypeScriptParser Properties

The TypeScriptParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether SyntaxParser should perform case-sensitive analysis of its content. (Inherited from SyntaxParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Overrides SyntaxParserFileName.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | ScriptKind | Gets or sets kind of the source code file being parsed.
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | (Overrides ParserStrings.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SuppressedDiagnostics |
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | Tokenizer |
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.FileName Property

TypeScriptParserFileName Property
Gets or sets file name of the file being parsed.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string FileName { get; set; }
Public Overrides Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get () override;
    void set (String^ value) override;
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

ISyntaxParserFileName
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.Repository Property

TypeScriptParserRepository Property
Gets an IRoslynRepository that holds methods for code completion purposes.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ITypeScriptRepository Repository { get; }
Public ReadOnly Property Repository As ITypeScriptRepository
    Get
public:
property ITypeScriptRepository^ Repository {
    ITypeScriptRepository^ get ();
}
member Repository : ITypeScriptRepository with get

Property Value

Type: ITypeScriptRepository
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.ScriptKind Property

TypeScriptParserScriptKind Property
Gets or sets kind of the source code file being parsed.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptKind ScriptKind { get; set; }
Public Property ScriptKind As ScriptKind
    Get
    Set
public:
property ScriptKind ScriptKind {
    ScriptKind get ();
    void set (ScriptKind value);
}
member ScriptKind : ScriptKind with get, set

Property Value

Type: ScriptKind
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.Strings Property

TypeScriptParserStrings Property

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IStringList Strings { get; set; }
Public Overrides Property Strings As IStringList
    Get
    Set
public:
virtual property IStringList^ Strings {
    IStringList^ get () override;
    void set (IStringList^ value) override;
}
abstract Strings : IStringList with get, set
override Strings : IStringList with get, set

Property Value

Type: IStringList

Implements

IParserStrings
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.SuppressedDiagnostics Property

TypeScriptParserSuppressedDiagnostics Property

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int[] SuppressedDiagnostics { get; set; }
Public Property SuppressedDiagnostics As Integer()
    Get
    Set
public:
property array<int>^ SuppressedDiagnostics {
    array<int>^ get ();
    void set (array<int>^ value);
}
member SuppressedDiagnostics : int[] with get, set

Property Value

Type: Int32
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser.Tokenizer Property

TypeScriptParserTokenizer Property

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptTokenizer Tokenizer { get; }
Public ReadOnly Property Tokenizer As TypeScriptTokenizer
    Get
public:
property TypeScriptTokenizer^ Tokenizer {
    TypeScriptTokenizer^ get ();
}
member Tokenizer : TypeScriptTokenizer with get

Property Value

Type: TypeScriptTokenizer
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptParser Events

TypeScriptParser Events

The TypeScriptParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

TypeScriptParser Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer Class

TypeScriptTokenizer Class
Represents class that and perform lexical analysis of specified TypeScript code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.TypeScriptTypeScriptTokenizer

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TypeScriptTokenizer
Public Class TypeScriptTokenizer
public ref class TypeScriptTokenizer
type TypeScriptTokenizer =  class end

The TypeScriptTokenizer type exposes the following members.

Constructors
 | Name | Description
Public method | TypeScriptTokenizer | Initializes a new instance of the TypeScriptTokenizer class
Top
Methods
 | Name | Description
Public method | AddTokens |
Public method | AlreadyParsed |
Public method | Clear |
Public method | EnsureParsed |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTokens | Performs lexical analysis for given ClassifiedSpan collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse |
Public method | ParseText | Performs lexical analysis of given text.
Public method | PositionChanged | Changes positions of any tokens located next to the specified position.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateTokens |
Top
Properties
 | Name | Description
Public property | Initialized |
Public property | ParsedCount |
Public property | Repository |
Public property | TypeNameToken | Gets or sets token related to the type name.
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer Constructor

TypeScriptTokenizer Constructor
Initializes a new instance of the TypeScriptTokenizer class

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptTokenizer()
Public Sub New
public:
TypeScriptTokenizer()
new : unit -> TypeScriptTokenizer
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer Methods

TypeScriptTokenizer Methods

The TypeScriptTokenizer type exposes the following members.

Methods
 | Name | Description
Public method | AddTokens |
Public method | AlreadyParsed |
Public method | Clear |
Public method | EnsureParsed |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTokens | Performs lexical analysis for given ClassifiedSpan collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Parse |
Public method | ParseText | Performs lexical analysis of given text.
Public method | PositionChanged | Changes positions of any tokens located next to the specified position.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateTokens |
Top
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.AddTokens Method

TypeScriptTokenizerAddTokens Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void AddTokens(
    TypeScriptTokenizerTokenList tokens,
    bool replace
)
Public Overridable Sub AddTokens (
    tokens As TypeScriptTokenizerTokenList,
    replace As Boolean
)
public:
virtual void AddTokens(
    TypeScriptTokenizerTokenList^ tokens,
    bool replace
)
abstract AddTokens :
        tokens : TypeScriptTokenizerTokenList *
        replace : bool -> unit
override AddTokens :
        tokens : TypeScriptTokenizerTokenList *
        replace : bool -> unit

Parameters

tokens
Type: Alternet.Syntax.Parsers.TypeScriptTypeScriptTokenizerTokenList
replace
Type: SystemBoolean
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.AlreadyParsed Method

TypeScriptTokenizerAlreadyParsed Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AlreadyParsed(
    int line
)
Public Function AlreadyParsed (
    line As Integer
) As Boolean
public:
bool AlreadyParsed(
    int line
)
member AlreadyParsed :
        line : int -> bool

Parameters

line
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.Clear Method

TypeScriptTokenizerClear Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.EnsureParsed Method

TypeScriptTokenizerEnsureParsed Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnsureParsed(
    IStringList strings,
    int line
)
Public Sub EnsureParsed (
    strings As IStringList,
    line As Integer
)
public:
void EnsureParsed(
    IStringList^ strings,
    int line
)
member EnsureParsed :
        strings : IStringList *
        line : int -> unit

Parameters

strings
Type: Alternet.SyntaxIStringList
line
Type: SystemInt32
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.GetTokens Method

TypeScriptTokenizerGetTokens Method
Performs lexical analysis for given ClassifiedSpan collection.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual TypeScriptTokenizerTokenList GetTokens(
    IEnumerable<ClassifiedSpan> spans,
    TextResolver textResolver,
    int capacity,
    TextSpan textSpan
)
Public Overridable Function GetTokens (
    spans As IEnumerable(Of ClassifiedSpan),
    textResolver As TextResolver,
    capacity As Integer,
    textSpan As TextSpan
) As TypeScriptTokenizerTokenList
public:
virtual TypeScriptTokenizerTokenList^ GetTokens(
    IEnumerable<ClassifiedSpan^>^ spans,
    TextResolver^ textResolver,
    int capacity,
    TextSpan^ textSpan
)
abstract GetTokens :
        spans : IEnumerable<ClassifiedSpan> *
        textResolver : TextResolver *
        capacity : int *
        textSpan : TextSpan -> TypeScriptTokenizerTokenList
override GetTokens :
        spans : IEnumerable<ClassifiedSpan> *
        textResolver : TextResolver *
        capacity : int *
        textSpan : TextSpan -> TypeScriptTokenizerTokenList

Parameters

spans
Type: System.Collections.GenericIEnumerableClassifiedSpan
Source of syntax information.
textResolver
Type: Alternet.Syntax.Parsers.TypeScript.HelpersTextResolver
TextResolver that provides conversion between Line and Character and absolute coordinates.
capacity
Type: SystemInt32
Tokens capacity.
textSpan
Type: TextSpan
text span that contains classificators

Return Value

Type: TypeScriptTokenizerTokenList
Returns list of tokens as result of lexical analysis.
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.Parse Method

TypeScriptTokenizerParse Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Parse(
    IStringList strings,
    int first,
    int last
)
Public Sub Parse (
    strings As IStringList,
    first As Integer,
    last As Integer
)
public:
void Parse(
    IStringList^ strings,
    int first,
    int last
)
member Parse :
        strings : IStringList *
        first : int *
        last : int -> unit

Parameters

strings
Type: Alternet.SyntaxIStringList
first
Type: SystemInt32
last
Type: SystemInt32
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.ParseText Method

TypeScriptTokenizerParseText Method
Performs lexical analysis of given text.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ParseText(
    int line,
    ref StringItemInfo[] colorData
)
Public Sub ParseText (
    line As Integer,
    ByRef colorData As StringItemInfo()
)
public:
void ParseText(
    int line,
    array<StringItemInfo>^% colorData
)
member ParseText :
        line : int *
        colorData : StringItemInfo[] byref -> unit

Parameters

line
Type: SystemInt32
Specifies current line within the text.
colorData
Type: Alternet.SyntaxStringItemInfo
Receives color data representing lexical information of the given text line.

Return Value

Type:
Final lexical state.
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.PositionChanged Method

TypeScriptTokenizerPositionChanged Method
Changes positions of any tokens located next to the specified position.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    char ch
)
Public Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ch As Char
)
public:
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    wchar_t ch
)
member PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
The X-constituent of the Point value that specifies start position to change.
y
Type: SystemInt32
The Y-constituent of the Point value that specifies start position to change.
deltaX
Type: SystemInt32
Specifies horizontal displacement.
deltaY
Type: SystemInt32
Specifies vertical displacement.
ch
Type: SystemChar
Can be used as punctuation or separator stop char.
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.UpdateTokens Method

TypeScriptTokenizerUpdateTokens Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateTokens(
    ILexScheme scheme
)
Public Overridable Sub UpdateTokens (
    scheme As ILexScheme
)
public:
virtual void UpdateTokens(
    ILexScheme^ scheme
)
abstract UpdateTokens :
        scheme : ILexScheme -> unit
override UpdateTokens :
        scheme : ILexScheme -> unit

Parameters

scheme
Type: Alternet.Syntax.LexerILexScheme
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer Properties

TypeScriptTokenizer Properties

The TypeScriptTokenizer type exposes the following members.

Properties
 | Name | Description
Public property | Initialized |
Public property | ParsedCount |
Public property | Repository |
Public property | TypeNameToken | Gets or sets token related to the type name.
Top
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.Initialized Property

TypeScriptTokenizerInitialized Property

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Initialized { get; }
Public ReadOnly Property Initialized As Boolean
    Get
public:
property bool Initialized {
    bool get ();
}
member Initialized : bool with get

Property Value

Type: Boolean
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.ParsedCount Property

TypeScriptTokenizerParsedCount Property

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ParsedCount { get; }
Public ReadOnly Property ParsedCount As Integer
    Get
public:
property int ParsedCount {
    int get ();
}
member ParsedCount : int with get

Property Value

Type: Int32
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.Repository Property

TypeScriptTokenizerRepository Property

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ITypeScriptRepository Repository { get; set; }
Public Property Repository As ITypeScriptRepository
    Get
    Set
public:
property ITypeScriptRepository^ Repository {
    ITypeScriptRepository^ get ();
    void set (ITypeScriptRepository^ value);
}
member Repository : ITypeScriptRepository with get, set

Property Value

Type: ITypeScriptRepository
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.TypeNameToken Property

TypeScriptTokenizerTypeNameToken Property
Gets or sets token related to the type name.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TypeNameToken { get; set; }
Public Property TypeNameToken As Integer
    Get
    Set
public:
property int TypeNameToken {
    int get ();
    void set (int value);
}
member TypeNameToken : int with get, set

Property Value

Type: Int32
See Also

Reference

TypeScriptTokenizer Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.LineToken Class

TypeScriptTokenizerLineToken Class
Represents information about particular line token.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.TypeScriptTypeScriptTokenizerLineToken

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineToken
Public Class LineToken
public ref class LineToken
type LineToken =  class end

The TypeScriptTokenizerLineToken type exposes the following members.

Constructors
 | Name | Description
Public method | TypeScriptTokenizerLineToken | Initializes a new instance of the LineToken class with specific parameters.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new LineToken that is a copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Length | Gets or sets token length.
Public property | Line | Gets or sets number of line.
Public property | Start | Gets or sets number of start character.
Public property | Style | Gets or sets lexical style.
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.LineToken Constructor

TypeScriptTokenizerLineToken Constructor
Initializes a new instance of the LineToken class with specific parameters.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineToken(
    int line,
    int start,
    int len,
    int style
)
Public Sub New (
    line As Integer,
    start As Integer,
    len As Integer,
    style As Integer
)
public:
LineToken(
    int line,
    int start,
    int len,
    int style
)
new :
        line : int *
        start : int *
        len : int *
        style : int -> LineToken

Parameters

line
Type: SystemInt32
Number of line.
start
Type: SystemInt32
Number of start character.
len
Type: SystemInt32
Token length.
style
Type: SystemInt32
Lexical style.
See Also

Reference

TypeScriptTokenizerLineToken Class
Alternet.Syntax.Parsers.TypeScript Namespace


LineToken Methods

LineToken Methods

The TypeScriptTokenizerLineToken type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new LineToken that is a copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TypeScriptTokenizerLineToken Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.LineToken.Clone Method

TypeScriptTokenizerLineTokenClone Method
Creates a new LineToken that is a copy of the current instance.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptTokenizerLineToken Clone()
Public Function Clone As TypeScriptTokenizerLineToken
public:
TypeScriptTokenizerLineToken^ Clone()
member Clone : unit -> TypeScriptTokenizerLineToken

Return Value

Type: TypeScriptTokenizerLineToken
A new LineToken that is a copy of this instance.
See Also

Reference

TypeScriptTokenizerLineToken Class
Alternet.Syntax.Parsers.TypeScript Namespace


LineToken Properties

LineToken Properties

The TypeScriptTokenizerLineToken type exposes the following members.

Properties
 | Name | Description
Public property | Length | Gets or sets token length.
Public property | Line | Gets or sets number of line.
Public property | Start | Gets or sets number of start character.
Public property | Style | Gets or sets lexical style.
Top
See Also

Reference

TypeScriptTokenizerLineToken Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.LineToken.Length Property

TypeScriptTokenizerLineTokenLength Property
Gets or sets token length.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set
public:
property int Length {
    int get ();
    void set (int value);
}
member Length : int with get, set

Property Value

Type: Int32
See Also

Reference

TypeScriptTokenizerLineToken Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.LineToken.Line Property

TypeScriptTokenizerLineTokenLine Property
Gets or sets number of line.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set
public:
property int Line {
    int get ();
    void set (int value);
}
member Line : int with get, set

Property Value

Type: Int32
See Also

Reference

TypeScriptTokenizerLineToken Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.LineToken.Start Property

TypeScriptTokenizerLineTokenStart Property
Gets or sets number of start character.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

Property Value

Type: Int32
See Also

Reference

TypeScriptTokenizerLineToken Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.LineToken.Style Property

TypeScriptTokenizerLineTokenStyle Property
Gets or sets lexical style.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Style { get; set; }
Public Property Style As Integer
    Get
    Set
public:
property int Style {
    int get ();
    void set (int value);
}
member Style : int with get, set

Property Value

Type: Int32
See Also

Reference

TypeScriptTokenizerLineToken Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.TokenList Class

TypeScriptTokenizerTokenList Class
Represents a LineToken collection.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListIListTypeScriptTokenizerLineToken
Alternet.Syntax.Parsers.TypeScriptTypeScriptTokenizerTokenList

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TokenList : List<IList<TypeScriptTokenizerLineToken>>
Public Class TokenList
    Inherits List(Of IList(Of TypeScriptTokenizerLineToken))
public ref class TokenList : public List<IList<TypeScriptTokenizerLineToken^>^>
type TokenList =
    class
        inherit List<IList<TypeScriptTokenizerLineToken>>
    end

The TypeScriptTokenizerTokenList type exposes the following members.

Constructors
 | Name | Description
Public method | TypeScriptTokenizerTokenList | Initializes a new instance of the TokenList class with specified capacity.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | AddTokens |
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | GetTokens | Gets list of tokens suitable for specified line index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | PositionChanged | Updates specified position by deltaY values for any LineToken in the collection.
Public method | PositionChangedX | Updates specified position by deltaX values for any LineToken in the collection.
Public method | PositionChangedY | Updates specified position by deltaY values for any LineToken in the collection.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.TokenList Constructor

TypeScriptTokenizerTokenList Constructor
Initializes a new instance of the TokenList class with specified capacity.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TokenList(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
TokenList(
    int capacity
)
new :
        capacity : int -> TokenList

Parameters

capacity
Type: SystemInt32
Capacity of the collection.
See Also

Reference

TypeScriptTokenizerTokenList Class
Alternet.Syntax.Parsers.TypeScript Namespace


TokenList Methods

TokenList Methods

The TypeScriptTokenizerTokenList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | AddTokens |
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | GetTokens | Gets list of tokens suitable for specified line index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | PositionChanged | Updates specified position by deltaY values for any LineToken in the collection.
Public method | PositionChangedX | Updates specified position by deltaX values for any LineToken in the collection.
Public method | PositionChangedY | Updates specified position by deltaY values for any LineToken in the collection.
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Top
See Also

Reference

TypeScriptTokenizerTokenList Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.TokenList.AddTokens Method

TypeScriptTokenizerTokenListAddTokens Method

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddTokens(
    IList<TypeScriptTokenizerLineToken> tokens
)
Public Sub AddTokens (
    tokens As IList(Of TypeScriptTokenizerLineToken)
)
public:
void AddTokens(
    IList<TypeScriptTokenizerLineToken^>^ tokens
)
member AddTokens :
        tokens : IList<TypeScriptTokenizerLineToken> -> unit

Parameters

tokens
Type: System.Collections.GenericIListTypeScriptTokenizerLineToken
See Also

Reference

TypeScriptTokenizerTokenList Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.TokenList.GetTokens Method

TypeScriptTokenizerTokenListGetTokens Method
Gets list of tokens suitable for specified line index.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TypeScriptTokenizerLineToken> GetTokens(
    int index,
    bool add
)
Public Function GetTokens (
    index As Integer,
    add As Boolean
) As IList(Of TypeScriptTokenizerLineToken)
public:
IList<TypeScriptTokenizerLineToken^>^ GetTokens(
    int index,
    bool add
)
member GetTokens :
        index : int *
        add : bool -> IList<TypeScriptTokenizerLineToken>

Parameters

index
Type: SystemInt32
Index of line.
add
Type: SystemBoolean
Indicates whether to extend token collection if necessary.

Return Value

Type: IListTypeScriptTokenizerLineToken
List of LineToken at specified line.
See Also

Reference

TypeScriptTokenizerTokenList Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.TokenList.PositionChanged Method

TypeScriptTokenizerTokenListPositionChanged Method
Updates specified position by deltaY values for any LineToken in the collection.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    char ch
)
Public Sub PositionChanged (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    deltaY As Integer,
    ch As Char
)
public:
void PositionChanged(
    int x,
    int y,
    int deltaX,
    int deltaY,
    wchar_t ch
)
member PositionChanged :
        x : int *
        y : int *
        deltaX : int *
        deltaY : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
deltaY
Type: SystemInt32
Vertical displacement.
ch
Type: SystemChar
Stop character.
See Also

Reference

TypeScriptTokenizerTokenList Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.TokenList.PositionChangedX Method

TypeScriptTokenizerTokenListPositionChangedX Method
Updates specified position by deltaX values for any LineToken in the collection.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChangedX(
    int x,
    int y,
    int deltaX,
    char ch
)
Public Sub PositionChangedX (
    x As Integer,
    y As Integer,
    deltaX As Integer,
    ch As Char
)
public:
void PositionChangedX(
    int x,
    int y,
    int deltaX,
    wchar_t ch
)
member PositionChangedX :
        x : int *
        y : int *
        deltaX : int *
        ch : char -> unit

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaX
Type: SystemInt32
Horizontal displacement.
ch
Type: SystemChar
Stop character.
See Also

Reference

TypeScriptTokenizerTokenList Class
Alternet.Syntax.Parsers.TypeScript Namespace


TypeScriptTokenizer.TokenList.PositionChangedY Method

TypeScriptTokenizerTokenListPositionChangedY Method
Updates specified position by deltaY values for any LineToken in the collection.

Namespace: Alternet.Syntax.Parsers.TypeScript
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PositionChangedY(
    int x,
    int y,
    int deltaY
)
Public Sub PositionChangedY (
    x As Integer,
    y As Integer,
    deltaY As Integer
)
public:
void PositionChangedY(
    int x,
    int y,
    int deltaY
)
member PositionChangedY :
        x : int *
        y : int *
        deltaY : int -> unit

Parameters

x
Type: SystemInt32
Index of current character in the text.
y
Type: SystemInt32
Index of current line in the text.
deltaY
Type: SystemInt32
Vertical displacement.
See Also

Reference

TypeScriptTokenizerTokenList Class
Alternet.Syntax.Parsers.TypeScript Namespace


TokenList Properties

TokenList Properties

The TypeScriptTokenizerTokenList type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListIListTypeScriptTokenizerLineToken .)
Top
See Also

Reference

TypeScriptTokenizerTokenList Class
Alternet.Syntax.Parsers.TypeScript Namespace


Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace

Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace
Classes
 | Class | Description
Public class | TypeScriptListMember | Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe TypeScript code.
Public class | TypeScriptRepository | Represents properties and methods to perform code completion functionality intended to use for TpeScript language.


TypeScriptListMember Class

TypeScriptListMember Class
Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe TypeScript code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.Parsers.TypeScript.CodeCompletionTypeScriptListMember

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TypeScriptListMember : ListMember
Public Class TypeScriptListMember
    Inherits ListMember
public ref class TypeScriptListMember : public ListMember
type TypeScriptListMember =
    class
        inherit ListMember
    end

The TypeScriptListMember type exposes the following members.

Constructors
 | Name | Description
Public method | TypeScriptListMember | Initializes a new instance of the TypeScriptListMember class with default settings.
Public method | TypeScriptListMember(IListMembers, String, String, V8Parser, Point, Color) | Initializes a new instance of the TypeScriptListMember class with specified parameters.
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets CodeCompletionCategory to which this member belongs. (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | Selected | Indicates if list member needs to be preselected
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptListMember Constructor

TypeScriptListMember Constructor
Overload List
 | Name | Description
Public method | TypeScriptListMember | Initializes a new instance of the TypeScriptListMember class with default settings.
Public method | TypeScriptListMember(IListMembers, String, String, V8Parser, Point, Color) | Initializes a new instance of the TypeScriptListMember class with specified parameters.
Top
See Also

Reference

TypeScriptListMember Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptListMember Constructor

TypeScriptListMember Constructor
Initializes a new instance of the TypeScriptListMember class with default settings.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptListMember()
Public Sub New
public:
TypeScriptListMember()
new : unit -> TypeScriptListMember
See Also

Reference

TypeScriptListMember Class
TypeScriptListMember Overload
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptListMember Constructor (IListMembers, String, String, V8Parser, Point, Color[])

TypeScriptListMember Constructor (IListMembers, String, String, V8Parser, Point, Color)
Initializes a new instance of the TypeScriptListMember class with specified parameters.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptListMember(
    IListMembers owner,
    string fileName,
    string completionName,
    V8Parser parser,
    Point position,
    Color[] colors = null
)
Public Sub New (
    owner As IListMembers,
    fileName As String,
    completionName As String,
    parser As V8Parser,
    position As Point,
    Optional colors As Color() = Nothing
)
public:
TypeScriptListMember(
    IListMembers^ owner,
    String^ fileName,
    String^ completionName,
    V8Parser^ parser,
    Point position,
    array<Color>^ colors = nullptr
)
new :
        owner : IListMembers *
        fileName : string *
        completionName : string *
        parser : V8Parser *
        position : Point *
        ?colors : Color[]
(* Defaults:
        let _colors = defaultArg colors null
*)
-> TypeScriptListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
IListMembers owning this instance.
fileName
Type: SystemString
File name of the source code file.
completionName
Type: SystemString
Name of the completion entry.
parser
Type: V8Parser
V8Parser that provides syntax analysis.
position
Type: System.DrawingPoint
Specifies position of language element within the text.
colors (Optional)
Type: System.DrawingColor
Array of colors to highlight code completion descriptions.
See Also

Reference

TypeScriptListMember Class
TypeScriptListMember Overload
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptListMember Methods

TypeScriptListMember Methods

The TypeScriptListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Overrides ListMemberGetParamText(Boolean).)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TypeScriptListMember Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptListMember.GetParamText Method

TypeScriptListMemberGetParamText Method
Converts Parameters property to a single string.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetParamText(
    bool useFormatting
)
Public Overrides Function GetParamText (
    useFormatting As Boolean
) As String
public:
virtual String^ GetParamText(
    bool useFormatting
) override
abstract GetParamText :
        useFormatting : bool -> string
override GetParamText :
        useFormatting : bool -> string

Parameters

useFormatting
Type: SystemBoolean
Specifies whether to use HTML formatting tags.

Return Value

Type: String
Returns Parameters in the form of comma separated text.

Implements

IListMemberGetParamText(Boolean)
See Also

Reference

TypeScriptListMember Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptListMember Properties

TypeScriptListMember Properties

The TypeScriptListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets CodeCompletionCategory to which this member belongs. (Overrides ListMemberCategory.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | Selected | Indicates if list member needs to be preselected
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

TypeScriptListMember Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptListMember.Category Property

TypeScriptListMemberCategory Property
Gets or sets CodeCompletionCategory to which this member belongs.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionCategory Category { get; }
Public Overrides ReadOnly Property Category As CodeCompletionCategory
    Get
public:
virtual property CodeCompletionCategory^ Category {
    CodeCompletionCategory^ get () override;
}
abstract Category : CodeCompletionCategory with get
override Category : CodeCompletionCategory with get

Property Value

Type: CodeCompletionCategory

Implements

ICategorizedListMemberCategory
See Also

Reference

TypeScriptListMember Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptListMember.Description Property

TypeScriptListMemberDescription Property
Return member's description.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Return Value

Type: String
String value that describes the member.

Implements

IListMemberDescription
See Also

Reference

TypeScriptListMember Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptListMember.Selected Property

TypeScriptListMemberSelected Property
Indicates if list member needs to be preselected

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set
public:
property bool Selected {
    bool get ();
    void set (bool value);
}
member Selected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TypeScriptListMember Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository Class

TypeScriptRepository Class
Represents properties and methods to perform code completion functionality intended to use for TpeScript language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.TypeScript.CodeCompletionTypeScriptRepository

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TypeScriptRepository : CodeCompletionRepository,
    ITypeScriptRepository, ICodeCompletionRepository, IDisposable
Public Class TypeScriptRepository
    Inherits CodeCompletionRepository
    Implements ITypeScriptRepository, ICodeCompletionRepository, IDisposable
public ref class TypeScriptRepository : public CodeCompletionRepository,
    ITypeScriptRepository, ICodeCompletionRepository, IDisposable
type TypeScriptRepository =
    class
        inherit CodeCompletionRepository
        interface ITypeScriptRepository
        interface ICodeCompletionRepository
        interface IDisposable
    end

The TypeScriptRepository type exposes the following members.

Constructors
 | Name | Description
Public method | TypeScriptRepository | Initializes a new instance of the TypeScriptRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillCodeFixes | When implemented by a class, fills codefix provider with list of available code fixes.
Public method | FillCodeRefactors | When implemented by a class, fills code completion provider with list of available code refactors.
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(IEnumerableCompletionEntry, IListMembers, Point, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillParameterInfo | Fills list members provider with list of its member with parameter info.
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindDeclarations | Locates all declarations at given position in the text.
Public method | FindReferences(Point) | Locates all references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetApplicableRefactors | Gets applicable refactors at the given text range.
Public method | GetBreakpointStatementAtPosition | Gets breakpoint statement range at pecified position.
Public method | GetClassifications | Gets a list of ClassifiedSpan for the document.
Public method | GetClassifications(Int32, Int32) | Gets list of classificators for the given document.
Public method | GetCodeFixesAtPosition | Gets code fix at syntax error position.
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetCompletionsAtPosition | Gets the completions available at the caret position.
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetDiagnostics | Gets a list of Diagnostic for the document.
Public method | GetDocCommentTemplateAtPosition | Gets the documentation comment template available at the caret position.
Public method | GetDocumentText | Gets text of the specified document.
Public method | GetFormattingEditsAfterKeystroke | Gets the text changes for the part of document accordingly to the formatting rules.
Public method | GetFormattingEditsForRange | Gets the text changes for the part of document accordingly to the formatting rules.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentationAtPosition | Gets line indentation at specified position.
Public method | GetLineAndCharacterOfPosition | Converts given absolute text coordinate into Point position.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetOccurrencesAtPosition | Locates all occurrences at given position in the text.
Public method | GetOutliningSpans | Gets a list of OutliningSpan for the document.
Public method | GetPositionOfLineAndCharacter | Converts given position into absolute text coordinate.
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Overrides CodeCompletionRepositoryGetQuickInfo(Object).)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfoAtPosition(Point) | Gets the quick info available at the caret position.
Public method | GetQuickInfoAtPosition(Int32) | Gets the quick info available at the caret position.
Public method | GetReferencesAtPosition | Locates all references at given position in the text.
Public method | GetSignatureHelpItems | Gets the signature help items available at the caret position.
Public method | GetSmartFormatSymbol | Gets smart format node under given position.
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetStructureGuideNode | Gets structure nodes.
Public method | GetSyntaxTree | Gets the syntax tree for the parsed document.
Public method | GetTextChangesForRefactor | Gets text changes for the code refactor.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDocument | Indicates whether TypeScript project has document specified.
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | IsValidBraceCompletionAtPosition | Determines if close brace code completion is expected.
Public method | QuickInfo | Gets the quick info available at the caret position.
Public method | RegisterCodeFiles | Makes types declared in given source files accessible for code completion.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RemoveDocument | Removes specified document from the project.
Public method | ReplaceDocument | Updates source code document to have the text specified.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterCodeFiles | Removes types declared in given source files from being accessible code completion.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | DefaultExtension | Gets or sets a default extension of the code files.
Public property | DisplayScaledImages | Gets ImageList for high DPI.
Public property | FileName | Gets or sets file name of the file being parsed.
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Gets or sets ImageList for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Parser | Gets a V8Parser provides syntax analysis for TypeScript document.
Public property | Project | Gets a ITypeScriptProject that contains document being parsed.
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options.
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository Constructor

TypeScriptRepository Constructor
Initializes a new instance of the TypeScriptRepository class with specified settings.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeScriptRepository(
    ISyntaxParser owner,
    ITypeScriptProject project,
    ScriptKind scriptKind,
    bool caseSensitive
)
Public Sub New (
    owner As ISyntaxParser,
    project As ITypeScriptProject,
    scriptKind As ScriptKind,
    caseSensitive As Boolean
)
public:
TypeScriptRepository(
    ISyntaxParser^ owner,
    ITypeScriptProject^ project,
    ScriptKind scriptKind,
    bool caseSensitive
)
new :
        owner : ISyntaxParser *
        project : ITypeScriptProject *
        scriptKind : ScriptKind *
        caseSensitive : bool -> TypeScriptRepository

Parameters

owner
Type: Alternet.SyntaxISyntaxParser
Specifies parser that owns this repository.
project
Type: ITypeScriptProject
ITypeScriptProject for this new instance.
scriptKind
Type: ScriptKind
Script kind of TypeScript file
caseSensitive
Type: SystemBoolean
Specifies CaseSensitive property of this new instance.
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository Methods

TypeScriptRepository Methods

The TypeScriptRepository type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillCodeFixes | When implemented by a class, fills codefix provider with list of available code fixes.
Public method | FillCodeRefactors | When implemented by a class, fills code completion provider with list of available code refactors.
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers(IEnumerableCompletionEntry, IListMembers, Point, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillParameterInfo | Fills list members provider with list of its member with parameter info.
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindDeclarations | Locates all declarations at given position in the text.
Public method | FindReferences(Point) | Locates all references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetApplicableRefactors | Gets applicable refactors at the given text range.
Public method | GetBreakpointStatementAtPosition | Gets breakpoint statement range at pecified position.
Public method | GetClassifications | Gets a list of ClassifiedSpan for the document.
Public method | GetClassifications(Int32, Int32) | Gets list of classificators for the given document.
Public method | GetCodeFixesAtPosition | Gets code fix at syntax error position.
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetCompletionsAtPosition | Gets the completions available at the caret position.
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetDiagnostics | Gets a list of Diagnostic for the document.
Public method | GetDocCommentTemplateAtPosition | Gets the documentation comment template available at the caret position.
Public method | GetDocumentText | Gets text of the specified document.
Public method | GetFormattingEditsAfterKeystroke | Gets the text changes for the part of document accordingly to the formatting rules.
Public method | GetFormattingEditsForRange | Gets the text changes for the part of document accordingly to the formatting rules.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndentationAtPosition | Gets line indentation at specified position.
Public method | GetLineAndCharacterOfPosition | Converts given absolute text coordinate into Point position.
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetOccurrencesAtPosition | Locates all occurrences at given position in the text.
Public method | GetOutliningSpans | Gets a list of OutliningSpan for the document.
Public method | GetPositionOfLineAndCharacter | Converts given position into absolute text coordinate.
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Overrides CodeCompletionRepositoryGetQuickInfo(Object).)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfoAtPosition(Point) | Gets the quick info available at the caret position.
Public method | GetQuickInfoAtPosition(Int32) | Gets the quick info available at the caret position.
Public method | GetReferencesAtPosition | Locates all references at given position in the text.
Public method | GetSignatureHelpItems | Gets the signature help items available at the caret position.
Public method | GetSmartFormatSymbol | Gets smart format node under given position.
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetStructureGuideNode | Gets structure nodes.
Public method | GetSyntaxTree | Gets the syntax tree for the parsed document.
Public method | GetTextChangesForRefactor | Gets text changes for the code refactor.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDocument | Indicates whether TypeScript project has document specified.
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | IsValidBraceCompletionAtPosition | Determines if close brace code completion is expected.
Public method | QuickInfo | Gets the quick info available at the caret position.
Public method | RegisterCodeFiles | Makes types declared in given source files accessible for code completion.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | RemoveDocument | Removes specified document from the project.
Public method | ReplaceDocument | Updates source code document to have the text specified.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterCodeFiles | Removes types declared in given source files from being accessible code completion.
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.FillCodeFixes Method

TypeScriptRepositoryFillCodeFixes Method
When implemented by a class, fills codefix provider with list of available code fixes.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillCodeFixes(
    IEnumerable<ICodeFix> codeFixes,
    ICodeFixItems items
)
Public Overridable Sub FillCodeFixes (
    codeFixes As IEnumerable(Of ICodeFix),
    items As ICodeFixItems
)
public:
virtual void FillCodeFixes(
    IEnumerable<ICodeFix^>^ codeFixes,
    ICodeFixItems^ items
)
abstract FillCodeFixes :
        codeFixes : IEnumerable<ICodeFix> *
        items : ICodeFixItems -> unit
override FillCodeFixes :
        codeFixes : IEnumerable<ICodeFix> *
        items : ICodeFixItems -> unit

Parameters

codeFixes
Type: System.Collections.GenericIEnumerableICodeFix
Collection of code fixes
items
Type: Alternet.Syntax.CodeCompletionICodeFixItems
Collection of code fix items

Implements

ITypeScriptRepositoryFillCodeFixes(IEnumerableICodeFix, ICodeFixItems)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.FillCodeRefactors Method

TypeScriptRepositoryFillCodeRefactors Method
When implemented by a class, fills code completion provider with list of available code refactors.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillCodeRefactors(
    IEnumerable<ICodeRefactor> codeRefactors,
    ICodeRefactorItems items
)
Public Overridable Sub FillCodeRefactors (
    codeRefactors As IEnumerable(Of ICodeRefactor),
    items As ICodeRefactorItems
)
public:
virtual void FillCodeRefactors(
    IEnumerable<ICodeRefactor^>^ codeRefactors,
    ICodeRefactorItems^ items
)
abstract FillCodeRefactors :
        codeRefactors : IEnumerable<ICodeRefactor> *
        items : ICodeRefactorItems -> unit
override FillCodeRefactors :
        codeRefactors : IEnumerable<ICodeRefactor> *
        items : ICodeRefactorItems -> unit

Parameters

codeRefactors
Type: System.Collections.GenericIEnumerableICodeRefactor
Collection of code refactors
items
Type: Alternet.Syntax.CodeCompletionICodeRefactorItems
Collection of code refactor items

Implements

ITypeScriptRepositoryFillCodeRefactors(IEnumerableICodeRefactor, ICodeRefactorItems)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.FillMembers Method

TypeScriptRepositoryFillMembers Method
Overload List
 | Name | Description
Public method | FillMembers(IEnumerableCompletionEntry, IListMembers, Point, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element.
Public method | FillMembers(ISyntaxNode, Point, IListMembers, Object, String, CodeCompletionScope, Int32) | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.FillMembers Method (IEnumerable(CompletionEntry), IListMembers, Point, Int32)

TypeScriptRepositoryFillMembers Method (IEnumerableCompletionEntry, IListMembers, Point, Int32)
Fills list members provider with list of its member, providing available choices for the specified language element.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillMembers(
    IEnumerable<CompletionEntry> completions,
    IListMembers members,
    Point position,
    out int selectedIndex
)
Public Overridable Sub FillMembers (
    completions As IEnumerable(Of CompletionEntry),
    members As IListMembers,
    position As Point,
    <OutAttribute> ByRef selectedIndex As Integer
)
public:
virtual void FillMembers(
    IEnumerable<CompletionEntry^>^ completions,
    IListMembers^ members,
    Point position,
    [OutAttribute] int% selectedIndex
)
abstract FillMembers :
        completions : IEnumerable<CompletionEntry> *
        members : IListMembers *
        position : Point *
        selectedIndex : int byref -> unit
override FillMembers :
        completions : IEnumerable<CompletionEntry> *
        members : IListMembers *
        position : Point *
        selectedIndex : int byref -> unit

Parameters

completions
Type: System.Collections.GenericIEnumerableCompletionEntry
Set of completions that is source of language elements.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
position
Type: System.DrawingPoint
Specifies position of language element in the text.
selectedIndex
Type: SystemInt32
Retrieves index of selected list member

Implements

ITypeScriptRepositoryFillMembers(IEnumerableCompletionEntry, IListMembers, Point, Int32)
See Also

Reference

TypeScriptRepository Class
FillMembers Overload
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.FillParameterInfo Method

TypeScriptRepositoryFillParameterInfo Method
Fills list members provider with list of its member with parameter info.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FillParameterInfo(
    SignatureHelpItems helpItems,
    IListMembers members,
    Point position
)
Public Overridable Sub FillParameterInfo (
    helpItems As SignatureHelpItems,
    members As IListMembers,
    position As Point
)
public:
virtual void FillParameterInfo(
    SignatureHelpItems^ helpItems,
    IListMembers^ members,
    Point position
)
abstract FillParameterInfo :
        helpItems : SignatureHelpItems *
        members : IListMembers *
        position : Point -> unit
override FillParameterInfo :
        helpItems : SignatureHelpItems *
        members : IListMembers *
        position : Point -> unit

Parameters

helpItems
Type: SignatureHelpItems
Source of the parameter information.
members
Type: Alternet.Syntax.CodeCompletionIListMembers
Specifies provider to fill with available members.
position
Type: System.DrawingPoint
Specifies position of language element in the text.

Implements

ITypeScriptRepositoryFillParameterInfo(SignatureHelpItems, IListMembers, Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.FindDeclarations Method

TypeScriptRepositoryFindDeclarations Method
Locates all declarations at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<DefinitionInfo> FindDeclarations(
    Point position
)
Public Overridable Function FindDeclarations (
    position As Point
) As IEnumerable(Of DefinitionInfo)
public:
virtual IEnumerable<DefinitionInfo^>^ FindDeclarations(
    Point position
)
abstract FindDeclarations :
        position : Point -> IEnumerable<DefinitionInfo>
override FindDeclarations :
        position : Point -> IEnumerable<DefinitionInfo>

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Return Value

Type: IEnumerableDefinitionInfo
List of DefinitionInfo that contains all available declarations.

Implements

ITypeScriptRepositoryFindDeclarations(Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.FindReferences Method

TypeScriptRepositoryFindReferences Method
Overload List
 | Name | Description
Public method | FindReferences(Point) | Locates all references at given position in the text.
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.FindReferences Method (Point)

TypeScriptRepositoryFindReferences Method (Point)
Locates all references at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<ReferencedSymbol> FindReferences(
    Point position
)
Public Overridable Function FindReferences (
    position As Point
) As IEnumerable(Of ReferencedSymbol)
public:
virtual IEnumerable<ReferencedSymbol^>^ FindReferences(
    Point position
)
abstract FindReferences :
        position : Point -> IEnumerable<ReferencedSymbol>
override FindReferences :
        position : Point -> IEnumerable<ReferencedSymbol>

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Return Value

Type: IEnumerableReferencedSymbol
List of ReferencedSymbol that contains all available references.

Implements

ITypeScriptRepositoryFindReferences(Point)
See Also

Reference

TypeScriptRepository Class
FindReferences Overload
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetApplicableRefactors Method

TypeScriptRepositoryGetApplicableRefactors Method
Gets applicable refactors at the given text range.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<ApplicableRefactorInfo> GetApplicableRefactors(
    Point startPos,
    Point endPos
)
Public Overridable Function GetApplicableRefactors (
    startPos As Point,
    endPos As Point
) As IEnumerable(Of ApplicableRefactorInfo)
public:
virtual IEnumerable<ApplicableRefactorInfo^>^ GetApplicableRefactors(
    Point startPos,
    Point endPos
)
abstract GetApplicableRefactors :
        startPos : Point *
        endPos : Point -> IEnumerable<ApplicableRefactorInfo>
override GetApplicableRefactors :
        startPos : Point *
        endPos : Point -> IEnumerable<ApplicableRefactorInfo>

Parameters

startPos
Type: System.DrawingPoint
Start position within the text.
endPos
Type: System.DrawingPoint
End position within the text.

Return Value

Type: IEnumerableApplicableRefactorInfo
List of applicable refactors or null if there's none.

Implements

ITypeScriptRepositoryGetApplicableRefactors(Point, Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetBreakpointStatementAtPosition Method

TypeScriptRepositoryGetBreakpointStatementAtPosition Method
Gets breakpoint statement range at pecified position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual TextSpan GetBreakpointStatementAtPosition(
    Point position
)
Public Overridable Function GetBreakpointStatementAtPosition (
    position As Point
) As TextSpan
public:
virtual TextSpan^ GetBreakpointStatementAtPosition(
    Point position
)
abstract GetBreakpointStatementAtPosition :
        position : Point -> TextSpan
override GetBreakpointStatementAtPosition :
        position : Point -> TextSpan

Parameters

position
Type: System.DrawingPoint
The position to check.

Return Value

Type: TextSpan
TextSpan of the found breakpoint.

Implements

ITypeScriptRepositoryGetBreakpointStatementAtPosition(Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetClassifications Method

TypeScriptRepositoryGetClassifications Method
Overload List
 | Name | Description
Public method | GetClassifications | Gets a list of ClassifiedSpan for the document.
Public method | GetClassifications(Int32, Int32) | Gets list of classificators for the given document.
Top
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetClassifications Method

TypeScriptRepositoryGetClassifications Method
Gets a list of ClassifiedSpan for the document.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<ClassifiedSpan> GetClassifications()
Public Overridable Function GetClassifications As IEnumerable(Of ClassifiedSpan)
public:
virtual IEnumerable<ClassifiedSpan^>^ GetClassifications()
abstract GetClassifications : unit -> IEnumerable<ClassifiedSpan>
override GetClassifications : unit -> IEnumerable<ClassifiedSpan>

Return Value

Type: IEnumerableClassifiedSpan
List of ClassifiedSpan.

Implements

ITypeScriptRepositoryGetClassifications
See Also

Reference

TypeScriptRepository Class
GetClassifications Overload
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetClassifications Method (Int32, Int32)

TypeScriptRepositoryGetClassifications Method (Int32, Int32)
Gets list of classificators for the given document.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ClassifiedSpan> GetClassifications(
    int pos,
    int length
)
Public Function GetClassifications (
    pos As Integer,
    length As Integer
) As IEnumerable(Of ClassifiedSpan)
public:
virtual IEnumerable<ClassifiedSpan^>^ GetClassifications(
    int pos,
    int length
) sealed
abstract GetClassifications :
        pos : int *
        length : int -> IEnumerable<ClassifiedSpan>
override GetClassifications :
        pos : int *
        length : int -> IEnumerable<ClassifiedSpan>

Parameters

pos
Type: SystemInt32
Start position of the text span
length
Type: SystemInt32
Length of the span

Return Value

Type: IEnumerableClassifiedSpan
The set of classificators to perform syntax highlighting.

Implements

ITypeScriptRepositoryGetClassifications(Int32, Int32)
See Also

Reference

TypeScriptRepository Class
GetClassifications Overload
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetCodeFixesAtPosition Method

TypeScriptRepositoryGetCodeFixesAtPosition Method
Gets code fix at syntax error position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<CodeFixAction> GetCodeFixesAtPosition(
    ISyntaxError error
)
Public Overridable Function GetCodeFixesAtPosition (
    error As ISyntaxError
) As IEnumerable(Of CodeFixAction)
public:
virtual IEnumerable<CodeFixAction^>^ GetCodeFixesAtPosition(
    ISyntaxError^ error
)
abstract GetCodeFixesAtPosition :
        error : ISyntaxError -> IEnumerable<CodeFixAction>
override GetCodeFixesAtPosition :
        error : ISyntaxError -> IEnumerable<CodeFixAction>

Parameters

error
Type: Alternet.SyntaxISyntaxError
given syntax error

Return Value

Type: IEnumerableCodeFixAction
Collection of applicable code fixes.

Implements

ITypeScriptRepositoryGetCodeFixesAtPosition(ISyntaxError)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetCompletionsAtPosition Method

TypeScriptRepositoryGetCompletionsAtPosition Method
Gets the completions available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<CompletionEntry> GetCompletionsAtPosition(
    Point position
)
Public Overridable Function GetCompletionsAtPosition (
    position As Point
) As IEnumerable(Of CompletionEntry)
public:
virtual IEnumerable<CompletionEntry^>^ GetCompletionsAtPosition(
    Point position
)
abstract GetCompletionsAtPosition :
        position : Point -> IEnumerable<CompletionEntry>
override GetCompletionsAtPosition :
        position : Point -> IEnumerable<CompletionEntry>

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: IEnumerableCompletionEntry
List of CompletionEntry related to the specified position.

Implements

ITypeScriptRepositoryGetCompletionsAtPosition(Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetDiagnostics Method

TypeScriptRepositoryGetDiagnostics Method
Gets a list of Diagnostic for the document.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<Diagnostic> GetDiagnostics()
Public Overridable Function GetDiagnostics As IEnumerable(Of Diagnostic)
public:
virtual IEnumerable<Diagnostic^>^ GetDiagnostics()
abstract GetDiagnostics : unit -> IEnumerable<Diagnostic>
override GetDiagnostics : unit -> IEnumerable<Diagnostic>

Return Value

Type: IEnumerableDiagnostic
List of Diagnostic.

Implements

ITypeScriptRepositoryGetDiagnostics
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetDocCommentTemplateAtPosition Method

TypeScriptRepositoryGetDocCommentTemplateAtPosition Method
Gets the documentation comment template available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual TextInsertion GetDocCommentTemplateAtPosition(
    Point position
)
Public Overridable Function GetDocCommentTemplateAtPosition (
    position As Point
) As TextInsertion
public:
virtual TextInsertion^ GetDocCommentTemplateAtPosition(
    Point position
)
abstract GetDocCommentTemplateAtPosition :
        position : Point -> TextInsertion
override GetDocCommentTemplateAtPosition :
        position : Point -> TextInsertion

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: TextInsertion
TextInsertion that contains documentation comment template.

Implements

ITypeScriptRepositoryGetDocCommentTemplateAtPosition(Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetDocumentText Method

TypeScriptRepositoryGetDocumentText Method
Gets text of the specified document.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string GetDocumentText(
    string fileName
)
Public Overridable Function GetDocumentText (
    fileName As String
) As String
public:
virtual String^ GetDocumentText(
    String^ fileName
)
abstract GetDocumentText :
        fileName : string -> string
override GetDocumentText :
        fileName : string -> string

Parameters

fileName
Type: SystemString
File name of the document.

Return Value

Type: String
Source code from given document.

Implements

ITypeScriptRepositoryGetDocumentText(String)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetFormattingEditsAfterKeystroke Method

TypeScriptRepositoryGetFormattingEditsAfterKeystroke Method
Gets the text changes for the part of document accordingly to the formatting rules.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<TextChange> GetFormattingEditsAfterKeystroke(
    int pos,
    string key,
    bool useSpaces,
    int spacesInTab,
    bool applyChanges,
    out string newText
)
Public Overridable Function GetFormattingEditsAfterKeystroke (
    pos As Integer,
    key As String,
    useSpaces As Boolean,
    spacesInTab As Integer,
    applyChanges As Boolean,
    <OutAttribute> ByRef newText As String
) As IEnumerable(Of TextChange)
public:
virtual IEnumerable<TextChange^>^ GetFormattingEditsAfterKeystroke(
    int pos,
    String^ key,
    bool useSpaces,
    int spacesInTab,
    bool applyChanges,
    [OutAttribute] String^% newText
)
abstract GetFormattingEditsAfterKeystroke :
        pos : int *
        key : string *
        useSpaces : bool *
        spacesInTab : int *
        applyChanges : bool *
        newText : string byref -> IEnumerable<TextChange>
override GetFormattingEditsAfterKeystroke :
        pos : int *
        key : string *
        useSpaces : bool *
        spacesInTab : int *
        applyChanges : bool *
        newText : string byref -> IEnumerable<TextChange>

Parameters

pos
Type: SystemInt32
Current position within the text.
key
Type: SystemString
Character being typed.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.
applyChanges
Type: SystemBoolean
Forces to apply found changes to the new text.
newText
Type: SystemString
Receives formatted code.

Return Value

Type: IEnumerableTextChange
List of TextChanges representing difference between old and new code.

Implements

ITypeScriptRepositoryGetFormattingEditsAfterKeystroke(Int32, String, Boolean, Int32, Boolean, String)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetFormattingEditsForRange Method

TypeScriptRepositoryGetFormattingEditsForRange Method
Gets the text changes for the part of document accordingly to the formatting rules.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<TextChange> GetFormattingEditsForRange(
    int start,
    int end,
    bool useSpaces,
    int spacesInTab,
    bool applyChanges,
    out string newText
)
Public Overridable Function GetFormattingEditsForRange (
    start As Integer,
    end As Integer,
    useSpaces As Boolean,
    spacesInTab As Integer,
    applyChanges As Boolean,
    <OutAttribute> ByRef newText As String
) As IEnumerable(Of TextChange)
public:
virtual IEnumerable<TextChange^>^ GetFormattingEditsForRange(
    int start,
    int end,
    bool useSpaces,
    int spacesInTab,
    bool applyChanges,
    [OutAttribute] String^% newText
)
abstract GetFormattingEditsForRange :
        start : int *
        end : int *
        useSpaces : bool *
        spacesInTab : int *
        applyChanges : bool *
        newText : string byref -> IEnumerable<TextChange>
override GetFormattingEditsForRange :
        start : int *
        end : int *
        useSpaces : bool *
        spacesInTab : int *
        applyChanges : bool *
        newText : string byref -> IEnumerable<TextChange>

Parameters

start
Type: SystemInt32
Start position of code being formatted.
end
Type: SystemInt32
End position of code being formatted.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.
applyChanges
Type: SystemBoolean
Forces to apply found changes to the new text.
newText
Type: SystemString
Receives formatted code.

Return Value

Type: IEnumerableTextChange
List of TextChange representing a difference between old and new text.

Implements

ITypeScriptRepositoryGetFormattingEditsForRange(Int32, Int32, Boolean, Int32, Boolean, String)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetIndentationAtPosition Method

TypeScriptRepositoryGetIndentationAtPosition Method
Gets line indentation at specified position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetIndentationAtPosition(
    Point position,
    bool useSpaces,
    int spacesInTab
)
Public Overridable Function GetIndentationAtPosition (
    position As Point,
    useSpaces As Boolean,
    spacesInTab As Integer
) As Integer
public:
virtual int GetIndentationAtPosition(
    Point position,
    bool useSpaces,
    int spacesInTab
)
abstract GetIndentationAtPosition :
        position : Point *
        useSpaces : bool *
        spacesInTab : int -> int
override GetIndentationAtPosition :
        position : Point *
        useSpaces : bool *
        spacesInTab : int -> int

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.

Return Value

Type: Int32
Number of indentation characters.

Implements

ITypeScriptRepositoryGetIndentationAtPosition(Point, Boolean, Int32)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetLineAndCharacterOfPosition Method

TypeScriptRepositoryGetLineAndCharacterOfPosition Method
Converts given absolute text coordinate into Point position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Point GetLineAndCharacterOfPosition(
    int position
)
Public Overridable Function GetLineAndCharacterOfPosition (
    position As Integer
) As Point
public:
virtual Point GetLineAndCharacterOfPosition(
    int position
)
abstract GetLineAndCharacterOfPosition :
        position : int -> Point
override GetLineAndCharacterOfPosition :
        position : int -> Point

Parameters

position
Type: SystemInt32
Absolute text coordinate to convert.

Return Value

Type: Point
Point position.

Implements

ITypeScriptRepositoryGetLineAndCharacterOfPosition(Int32)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetOccurrencesAtPosition Method

TypeScriptRepositoryGetOccurrencesAtPosition Method
Locates all occurrences at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<ReferenceEntry> GetOccurrencesAtPosition(
    Point position
)
Public Overridable Function GetOccurrencesAtPosition (
    position As Point
) As IEnumerable(Of ReferenceEntry)
public:
virtual IEnumerable<ReferenceEntry^>^ GetOccurrencesAtPosition(
    Point position
)
abstract GetOccurrencesAtPosition :
        position : Point -> IEnumerable<ReferenceEntry>
override GetOccurrencesAtPosition :
        position : Point -> IEnumerable<ReferenceEntry>

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Return Value

Type: IEnumerableReferenceEntry
List of ReferenceEntry that contains all available occurrences.

Implements

ITypeScriptRepositoryGetOccurrencesAtPosition(Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetOutliningSpans Method

TypeScriptRepositoryGetOutliningSpans Method
Gets a list of OutliningSpan for the document.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<OutliningSpan> GetOutliningSpans()
Public Overridable Function GetOutliningSpans As IEnumerable(Of OutliningSpan)
public:
virtual IEnumerable<OutliningSpan^>^ GetOutliningSpans()
abstract GetOutliningSpans : unit -> IEnumerable<OutliningSpan>
override GetOutliningSpans : unit -> IEnumerable<OutliningSpan>

Return Value

Type: IEnumerableOutliningSpan
List of OutliningSpan.

Implements

ITypeScriptRepositoryGetOutliningSpans
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetPositionOfLineAndCharacter Method

TypeScriptRepositoryGetPositionOfLineAndCharacter Method
Converts given position into absolute text coordinate.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int GetPositionOfLineAndCharacter(
    Point position
)
Public Overridable Function GetPositionOfLineAndCharacter (
    position As Point
) As Integer
public:
virtual int GetPositionOfLineAndCharacter(
    Point position
)
abstract GetPositionOfLineAndCharacter :
        position : Point -> int
override GetPositionOfLineAndCharacter :
        position : Point -> int

Parameters

position
Type: System.DrawingPoint
Point to convert.

Return Value

Type: Int32
Absolute position.

Implements

ITypeScriptRepositoryGetPositionOfLineAndCharacter(Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetQuickInfo Method

TypeScriptRepositoryGetQuickInfo Method
Overload List
 | Name | Description
Public method | GetQuickInfo(Object) | Returns information about the object. (Overrides CodeCompletionRepositoryGetQuickInfo(Object).)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetQuickInfo Method (Object)

TypeScriptRepositoryGetQuickInfo Method (Object)
Returns information about the object.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IQuickInfo GetQuickInfo(
    Object member
)
Public Overrides Function GetQuickInfo (
    member As Object
) As IQuickInfo
public:
virtual IQuickInfo^ GetQuickInfo(
    Object^ member
) override
abstract GetQuickInfo :
        member : Object -> IQuickInfo
override GetQuickInfo :
        member : Object -> IQuickInfo

Parameters

member
Type: SystemObject
Given object.

Return Value

Type: IQuickInfo
IQuickInfo instance.

Implements

ICodeCompletionRepositoryGetQuickInfo(Object)
ICodeCompletionRepositoryGetQuickInfo(Object)
See Also

Reference

TypeScriptRepository Class
GetQuickInfo Overload
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetQuickInfoAtPosition Method

TypeScriptRepositoryGetQuickInfoAtPosition Method
Overload List
 | Name | Description
Public method | GetQuickInfoAtPosition(Point) | Gets the quick info available at the caret position.
Public method | GetQuickInfoAtPosition(Int32) | Gets the quick info available at the caret position.
Top
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetQuickInfoAtPosition Method (Point)

TypeScriptRepositoryGetQuickInfoAtPosition Method (Point)
Gets the quick info available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual QuickInfo GetQuickInfoAtPosition(
    Point position
)
Public Overridable Function GetQuickInfoAtPosition (
    position As Point
) As QuickInfo
public:
virtual QuickInfo^ GetQuickInfoAtPosition(
    Point position
)
abstract GetQuickInfoAtPosition :
        position : Point -> QuickInfo
override GetQuickInfoAtPosition :
        position : Point -> QuickInfo

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: QuickInfo
QuickInfo related to the specified position.

Implements

ITypeScriptRepositoryGetQuickInfoAtPosition(Point)
See Also

Reference

TypeScriptRepository Class
GetQuickInfoAtPosition Overload
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetQuickInfoAtPosition Method (Int32)

TypeScriptRepositoryGetQuickInfoAtPosition Method (Int32)
Gets the quick info available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual QuickInfo GetQuickInfoAtPosition(
    int position
)
Public Overridable Function GetQuickInfoAtPosition (
    position As Integer
) As QuickInfo
public:
virtual QuickInfo^ GetQuickInfoAtPosition(
    int position
)
abstract GetQuickInfoAtPosition :
        position : int -> QuickInfo
override GetQuickInfoAtPosition :
        position : int -> QuickInfo

Parameters

position
Type: SystemInt32
The position of the caret in absolute coordinates

Return Value

Type: QuickInfo
QuickInfo related to the specified position.

Implements

ITypeScriptRepositoryGetQuickInfoAtPosition(Int32)
See Also

Reference

TypeScriptRepository Class
GetQuickInfoAtPosition Overload
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetReferencesAtPosition Method

TypeScriptRepositoryGetReferencesAtPosition Method
Locates all references at given position in the text.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerable<ReferenceEntry> GetReferencesAtPosition(
    Point position
)
Public Overridable Function GetReferencesAtPosition (
    position As Point
) As IEnumerable(Of ReferenceEntry)
public:
virtual IEnumerable<ReferenceEntry^>^ GetReferencesAtPosition(
    Point position
)
abstract GetReferencesAtPosition :
        position : Point -> IEnumerable<ReferenceEntry>
override GetReferencesAtPosition :
        position : Point -> IEnumerable<ReferenceEntry>

Parameters

position
Type: System.DrawingPoint
Specifies position to find declaration.

Return Value

Type: IEnumerableReferenceEntry
List of ReferenceEntry that contains all available references.

Implements

ITypeScriptRepositoryGetReferencesAtPosition(Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetSignatureHelpItems Method

TypeScriptRepositoryGetSignatureHelpItems Method
Gets the signature help items available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SignatureHelpItems GetSignatureHelpItems(
    Point position
)
Public Overridable Function GetSignatureHelpItems (
    position As Point
) As SignatureHelpItems
public:
virtual SignatureHelpItems^ GetSignatureHelpItems(
    Point position
)
abstract GetSignatureHelpItems :
        position : Point -> SignatureHelpItems
override GetSignatureHelpItems :
        position : Point -> SignatureHelpItems

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: SignatureHelpItems
SignatureHelpItems related to the specified position.

Implements

ITypeScriptRepositoryGetSignatureHelpItems(Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetSmartFormatSymbol Method

TypeScriptRepositoryGetSmartFormatSymbol Method
Gets smart format node under given position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual NodeData GetSmartFormatSymbol(
    int pos
)
Public Overridable Function GetSmartFormatSymbol (
    pos As Integer
) As NodeData
public:
virtual NodeData^ GetSmartFormatSymbol(
    int pos
)
abstract GetSmartFormatSymbol :
        pos : int -> NodeData
override GetSmartFormatSymbol :
        pos : int -> NodeData

Parameters

pos
Type: SystemInt32
Current position

Return Value

Type: NodeData
Node that can be formatted or null.

Implements

ITypeScriptRepositoryGetSmartFormatSymbol(Int32)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetStructureGuideNode Method

TypeScriptRepositoryGetStructureGuideNode Method
Gets structure nodes.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IList<NodeData> GetStructureGuideNode()
Public Overridable Function GetStructureGuideNode As IList(Of NodeData)
public:
virtual IList<NodeData^>^ GetStructureGuideNode()
abstract GetStructureGuideNode : unit -> IList<NodeData>
override GetStructureGuideNode : unit -> IList<NodeData>

Return Value

Type: IListNodeData
List of structure nodes.

Implements

ITypeScriptRepositoryGetStructureGuideNode
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetSyntaxTree Method

TypeScriptRepositoryGetSyntaxTree Method
Gets the syntax tree for the parsed document.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Node GetSyntaxTree()
Public Overridable Function GetSyntaxTree As Node
public:
virtual Node^ GetSyntaxTree()
abstract GetSyntaxTree : unit -> Node
override GetSyntaxTree : unit -> Node

Return Value

Type: Node
Node holds parsed document content.

Implements

ITypeScriptRepositoryGetSyntaxTree
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.GetTextChangesForRefactor Method

TypeScriptRepositoryGetTextChangesForRefactor Method
Gets text changes for the code refactor.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual RefactorEditInfo GetTextChangesForRefactor(
    ICodeRefactor codeRefactor
)
Public Overridable Function GetTextChangesForRefactor (
    codeRefactor As ICodeRefactor
) As RefactorEditInfo
public:
virtual RefactorEditInfo^ GetTextChangesForRefactor(
    ICodeRefactor^ codeRefactor
)
abstract GetTextChangesForRefactor :
        codeRefactor : ICodeRefactor -> RefactorEditInfo
override GetTextChangesForRefactor :
        codeRefactor : ICodeRefactor -> RefactorEditInfo

Parameters

codeRefactor
Type: Alternet.SyntaxICodeRefactor

Return Value

Type: RefactorEditInfo
Refactor edits or null if there's none.

Implements

ITypeScriptRepositoryGetTextChangesForRefactor(ICodeRefactor)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.HasDocument Method

TypeScriptRepositoryHasDocument Method
Indicates whether TypeScript project has document specified.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasDocument(
    string fileName
)
Public Overridable Function HasDocument (
    fileName As String
) As Boolean
public:
virtual bool HasDocument(
    String^ fileName
)
abstract HasDocument :
        fileName : string -> bool
override HasDocument :
        fileName : string -> bool

Parameters

fileName
Type: SystemString
File name of the document.

Return Value

Type: Boolean
True if project contains given document; otherwise false.

Implements

ITypeScriptRepositoryHasDocument(String)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.IsValidBraceCompletionAtPosition Method

TypeScriptRepositoryIsValidBraceCompletionAtPosition Method
Determines if close brace code completion is expected.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsValidBraceCompletionAtPosition(
    Point position,
    char openBrace,
    out char closeBrace
)
Public Overridable Function IsValidBraceCompletionAtPosition (
    position As Point,
    openBrace As Char,
    <OutAttribute> ByRef closeBrace As Char
) As Boolean
public:
virtual bool IsValidBraceCompletionAtPosition(
    Point position,
    wchar_t openBrace,
    [OutAttribute] wchar_t% closeBrace
)
abstract IsValidBraceCompletionAtPosition :
        position : Point *
        openBrace : char *
        closeBrace : char byref -> bool
override IsValidBraceCompletionAtPosition :
        position : Point *
        openBrace : char *
        closeBrace : char byref -> bool

Parameters

position
Type: System.DrawingPoint
The position of the caret.
openBrace
Type: SystemChar
Character specifying open brace.
closeBrace
Type: SystemChar
Character specifying closing brace.

Return Value

Type: Boolean
True if open brace can be completed; otherwise false.

Implements

ITypeScriptRepositoryIsValidBraceCompletionAtPosition(Point, Char, Char)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.QuickInfo Method

TypeScriptRepositoryQuickInfo Method
Gets the quick info available at the caret position.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IQuickInfo QuickInfo(
    Point position
)
Public Overridable Function QuickInfo (
    position As Point
) As IQuickInfo
public:
virtual IQuickInfo^ QuickInfo(
    Point position
)
abstract QuickInfo :
        position : Point -> IQuickInfo
override QuickInfo :
        position : Point -> IQuickInfo

Parameters

position
Type: System.DrawingPoint
The position of the caret.

Return Value

Type: IQuickInfo
QuickInfo related to the specified position.

Implements

ITypeScriptRepositoryQuickInfo(Point)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.RegisterCodeFiles Method

TypeScriptRepositoryRegisterCodeFiles Method
Makes types declared in given source files accessible for code completion.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RegisterCodeFiles(
    string[] files
)
Public Overridable Sub RegisterCodeFiles (
    files As String()
)
public:
virtual void RegisterCodeFiles(
    array<String^>^ files
)
abstract RegisterCodeFiles :
        files : string[] -> unit
override RegisterCodeFiles :
        files : string[] -> unit

Parameters

files
Type: SystemString
Files containing source code.

Implements

ITypeScriptRepositoryRegisterCodeFiles(String)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.RemoveDocument Method

TypeScriptRepositoryRemoveDocument Method
Removes specified document from the project.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void RemoveDocument(
    string fileName
)
Public Overridable Sub RemoveDocument (
    fileName As String
)
public:
virtual void RemoveDocument(
    String^ fileName
)
abstract RemoveDocument :
        fileName : string -> unit
override RemoveDocument :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
File name of the document.

Implements

ITypeScriptRepositoryRemoveDocument(String)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.ReplaceDocument Method

TypeScriptRepositoryReplaceDocument Method
Updates source code document to have the text specified.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void ReplaceDocument(
    string fileName,
    string text
)
Public Overridable Sub ReplaceDocument (
    fileName As String,
    text As String
)
public:
virtual void ReplaceDocument(
    String^ fileName,
    String^ text
)
abstract ReplaceDocument :
        fileName : string *
        text : string -> unit
override ReplaceDocument :
        fileName : string *
        text : string -> unit

Parameters

fileName
Type: SystemString
File name of the document.
text
Type: SystemString
New TypeScript text.

Implements

ITypeScriptRepositoryReplaceDocument(String, String)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.UnregisterCodeFiles Method

TypeScriptRepositoryUnregisterCodeFiles Method
Removes types declared in given source files from being accessible code completion.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void UnregisterCodeFiles(
    string[] files
)
Public Overridable Sub UnregisterCodeFiles (
    files As String()
)
public:
virtual void UnregisterCodeFiles(
    array<String^>^ files
)
abstract UnregisterCodeFiles :
        files : string[] -> unit
override UnregisterCodeFiles :
        files : string[] -> unit

Parameters

files
Type: SystemString
Files containing source code.

Implements

ITypeScriptRepositoryUnregisterCodeFiles(String)
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository Properties

TypeScriptRepository Properties

The TypeScriptRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | DefaultExtension | Gets or sets a default extension of the code files.
Public property | DisplayScaledImages | Gets ImageList for high DPI.
Public property | FileName | Gets or sets file name of the file being parsed.
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Represents collection of images used for code completion. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Gets or sets ImageList for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Parser | Gets a V8Parser provides syntax analysis for TypeScript document.
Public property | Project | Gets a ITypeScriptProject that contains document being parsed.
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.DefaultExtension Property

TypeScriptRepositoryDefaultExtension Property
Gets or sets a default extension of the code files.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DefaultExtension { get; set; }
Public Property DefaultExtension As String
    Get
    Set
public:
virtual property String^ DefaultExtension {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DefaultExtension : string with get, set
override DefaultExtension : string with get, set

Property Value

Type: String

Implements

ITypeScriptRepositoryDefaultExtension
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.DisplayScaledImages Property

TypeScriptRepositoryDisplayScaledImages Property
Gets ImageList for high DPI.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplayScaledImages DisplayScaledImages { get; }
Public ReadOnly Property DisplayScaledImages As DisplayScaledImages
    Get
public:
virtual property DisplayScaledImages^ DisplayScaledImages {
    DisplayScaledImages^ get () sealed;
}
abstract DisplayScaledImages : DisplayScaledImages with get
override DisplayScaledImages : DisplayScaledImages with get

Property Value

Type: DisplayScaledImages

Implements

ITypeScriptRepositoryDisplayScaledImages
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.FileName Property

TypeScriptRepositoryFileName Property
Gets or sets file name of the file being parsed.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

ITypeScriptRepositoryFileName
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.Images Property

TypeScriptRepositoryImages Property
Represents collection of images used for code completion.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; }
Public Overrides ReadOnly Property Images As ImageList
    Get
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
}
abstract Images : ImageList with get
override Images : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImages
ICodeCompletionRepositoryImages
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.ImagesHighDpi Property

TypeScriptRepositoryImagesHighDpi Property
Gets or sets ImageList for high DPI.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList ImagesHighDpi { get; }
Public Overrides ReadOnly Property ImagesHighDpi As ImageList
    Get
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get () override;
}
abstract ImagesHighDpi : ImageList with get
override ImagesHighDpi : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImagesHighDpi
ICodeCompletionRepositoryImagesHighDpi
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.Parser Property

TypeScriptRepositoryParser Property
Gets a V8Parser provides syntax analysis for TypeScript document.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public V8Parser Parser { get; }
Public ReadOnly Property Parser As V8Parser
    Get
public:
virtual property V8Parser^ Parser {
    V8Parser^ get () sealed;
}
abstract Parser : V8Parser with get
override Parser : V8Parser with get

Property Value

Type: V8Parser

Implements

ITypeScriptRepositoryParser
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.Project Property

TypeScriptRepositoryProject Property
Gets a ITypeScriptProject that contains document being parsed.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public ITypeScriptProject Project { get; }
Public ReadOnly Property Project As ITypeScriptProject
    Get
public:
virtual property ITypeScriptProject^ Project {
    ITypeScriptProject^ get () sealed;
}
abstract Project : ITypeScriptProject with get
override Project : ITypeScriptProject with get

Property Value

Type: ITypeScriptProject

Implements

ITypeScriptRepositoryProject
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository Events

TypeScriptRepository Events

The TypeScriptRepository type exposes the following members.

Events
 | Name | Description
Public event | CustomFormattingOptions | Occurs when text document is being formatted to provide custom formatting options.
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


TypeScriptRepository.CustomFormattingOptions Event

TypeScriptRepositoryCustomFormattingOptions Event
Occurs when text document is being formatted to provide custom formatting options.

Namespace: Alternet.Syntax.Parsers.TypeScript.CodeCompletion
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FormattingOptionsEventArgs> CustomFormattingOptions
Public Event CustomFormattingOptions As EventHandler(Of FormattingOptionsEventArgs)
public:
virtual  event EventHandler<FormattingOptionsEventArgs^>^ CustomFormattingOptions {
    void add (EventHandler<FormattingOptionsEventArgs^>^ value);
    void remove (EventHandler<FormattingOptionsEventArgs^>^ value);
}
abstract CustomFormattingOptions : IEvent<EventHandler<FormattingOptionsEventArgs>,
    FormattingOptionsEventArgs>
override CustomFormattingOptions : IEvent<EventHandler<FormattingOptionsEventArgs>,
    FormattingOptionsEventArgs>

Value

Type: SystemEventHandlerFormattingOptionsEventArgs

Implements

ITypeScriptRepositoryCustomFormattingOptions
See Also

Reference

TypeScriptRepository Class
Alternet.Syntax.Parsers.TypeScript.CodeCompletion Namespace


Alternet.Syntax.Parsers.TypeScript.Helpers Namespace

Alternet.Syntax.Parsers.TypeScript.Helpers Namespace
Classes
 | Class | Description
Public class | TextResolver | Represents properties and methods to convert absolute position within TypeScript code into Point coordinate.


TextResolver Class

TextResolver Class
Represents properties and methods to convert absolute position within TypeScript code into Point coordinate.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.TypeScript.HelpersTextResolver

Namespace: Alternet.Syntax.Parsers.TypeScript.Helpers
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextResolver
Public Class TextResolver
public ref class TextResolver
type TextResolver =  class end

The TextResolver type exposes the following members.

Constructors
 | Name | Description
Public method | TextResolver(IListString) | Initializes a new instance of the TextResolver class with specified text.
Public method | TextResolver(String) | Initializes a new instance of the TextResolver class with specified text.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLineSpanEnd |
Public method | GetLineSpanStart |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | TextToPoint | Converts given absolute text coordinate into Point position.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Strings | Gets part of code in the form of the list of strings.
Top
See Also

Reference

Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


TextResolver Constructor

TextResolver Constructor
Overload List
 | Name | Description
Public method | TextResolver(IListString) | Initializes a new instance of the TextResolver class with specified text.
Public method | TextResolver(String) | Initializes a new instance of the TextResolver class with specified text.
Top
See Also

Reference

TextResolver Class
Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


TextResolver Constructor (IList(String))

TextResolver Constructor (IListString)
Initializes a new instance of the TextResolver class with specified text.

Namespace: Alternet.Syntax.Parsers.TypeScript.Helpers
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextResolver(
    IList<string> text
)
Public Sub New (
    text As IList(Of String)
)
public:
TextResolver(
    IList<String^>^ text
)
new :
        text : IList<string> -> TextResolver

Parameters

text
Type: System.Collections.GenericIListString
List of strings representing the text.
See Also

Reference

TextResolver Class
TextResolver Overload
Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


TextResolver Constructor (String)

TextResolver Constructor (String)
Initializes a new instance of the TextResolver class with specified text.

Namespace: Alternet.Syntax.Parsers.TypeScript.Helpers
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextResolver(
    string text
)
Public Sub New (
    text As String
)
public:
TextResolver(
    String^ text
)
new :
        text : string -> TextResolver

Parameters

text
Type: SystemString
String representation of the text.
See Also

Reference

TextResolver Class
TextResolver Overload
Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


TextResolver Methods

TextResolver Methods

The TextResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLineSpanEnd |
Public method | GetLineSpanStart |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | TextToPoint | Converts given absolute text coordinate into Point position.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextResolver Class
Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


TextResolver.GetLineSpanEnd Method

TextResolverGetLineSpanEnd Method

Namespace: Alternet.Syntax.Parsers.TypeScript.Helpers
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetLineSpanEnd(
    int line
)
Public Function GetLineSpanEnd (
    line As Integer
) As Integer
public:
int GetLineSpanEnd(
    int line
)
member GetLineSpanEnd :
        line : int -> int

Parameters

line
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

TextResolver Class
Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


TextResolver.GetLineSpanStart Method

TextResolverGetLineSpanStart Method

Namespace: Alternet.Syntax.Parsers.TypeScript.Helpers
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetLineSpanStart(
    int line
)
Public Function GetLineSpanStart (
    line As Integer
) As Integer
public:
int GetLineSpanStart(
    int line
)
member GetLineSpanStart :
        line : int -> int

Parameters

line
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

TextResolver Class
Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


TextResolver.TextToPoint Method

TextResolverTextToPoint Method
Converts given absolute text coordinate into Point position.

Namespace: Alternet.Syntax.Parsers.TypeScript.Helpers
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point TextToPoint(
    int pos
)
Public Function TextToPoint (
    pos As Integer
) As Point
public:
Point TextToPoint(
    int pos
)
member TextToPoint :
        pos : int -> Point

Parameters

pos
Type: SystemInt32
Absolute text coordinate to convert.

Return Value

Type: Point
Point position.
See Also

Reference

TextResolver Class
Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


TextResolver Properties

TextResolver Properties

The TextResolver type exposes the following members.

Properties
 | Name | Description
Public property | Strings | Gets part of code in the form of the list of strings.
Top
See Also

Reference

TextResolver Class
Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


TextResolver.Strings Property

TextResolverStrings Property
Gets part of code in the form of the list of strings.

Namespace: Alternet.Syntax.Parsers.TypeScript.Helpers
Assembly: Alternet.Syntax.Parsers.TypeScript.v7 (in Alternet.Syntax.Parsers.TypeScript.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> Strings { get; }
Public ReadOnly Property Strings As IList(Of String)
    Get
public:
property IList<String^>^ Strings {
    IList<String^>^ get ();
}
member Strings : IList<string> with get

Property Value

Type: IListString
See Also

Reference

TextResolver Class
Alternet.Syntax.Parsers.TypeScript.Helpers Namespace


Alternet.Syntax.Parsers.XAML Namespace

Alternet.Syntax.Parsers.XAML Namespace
Classes
 | Class | Description
Public class | XAMLConsts | Contains default constants related to XAML syntax parser.
Public class | XAMLListMember | Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Public class | XAMLListMembers | Represents data collection related to popup list box controls used to describe XAML language code.
Public class | XAMLParser | Represents class that and perform syntax and lexical analysis of specified XAML code text.
Public class | XAMLRepository | Represents properties and methods to perform code completion functionality intended to use for XAML language.
Interfaces
 | Interface | Description
Public interface | IXAMLRepository | Represents properties and methods to perform code completion functionality for XAML language.


IXAMLRepository Interface

IXAMLRepository Interface
Represents properties and methods to perform code completion functionality for XAML language.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IXAMLRepository : ICodeCompletionRepository,
    IDisposable
Public Interface IXAMLRepository
    Inherits ICodeCompletionRepository, IDisposable
public interface class IXAMLRepository : ICodeCompletionRepository,
    IDisposable
type IXAMLRepository =
    interface
        interface ICodeCompletionRepository
        interface IDisposable
    end

The IXAMLRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddTypeInfoFromType | When implemented by a class, load type definition from .NET type.
Public method | AddTypeInfoFromTypes | When implemented by a class, load type definition from .NET types.
Public method | ClearTypeInfos | When implemented by a class, clears type definitions.
Public method | CodeCompletion | When implemented by a class, performs code completion for the specified text representing language element.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindReferences | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | LoadTypesFromXml | When implemented by a class, loads type definition from XML.
Public method | LoadTypesFromXmlString | When implemented by a class, loads type definition from XML.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.XAML Namespace


IXAMLRepository Methods

IXAMLRepository Methods

The IXAMLRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddTypeInfoFromType | When implemented by a class, load type definition from .NET type.
Public method | AddTypeInfoFromTypes | When implemented by a class, load type definition from .NET types.
Public method | ClearTypeInfos | When implemented by a class, clears type definitions.
Public method | CodeCompletion | When implemented by a class, performs code completion for the specified text representing language element.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FillMember | When implemented by a class, obtains information about individual member of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FillMembers | When implemented by a class, fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from ICodeCompletionRepository.)
Public method | FindDeclaration | When implemented by a class, obtains information about where the language element is declared. (Inherited from ICodeCompletionRepository.)
Public method | FindReferences | When implemented by a class, locates all references to the node in the text. (Inherited from ICodeCompletionRepository.)
Public method | GetCodeSnippets | When implemented by a class, returns code snippets for the given language. (Inherited from ICodeCompletionRepository.)
Public method | GetDescription | When implemented by a class, obtains description of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | When implemented by a class, obtains information about a member of some language element. (Inherited from ICodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | When implemented by a class, obtains information about some language element to perform code completion related operations. (Inherited from ICodeCompletionRepository.)
Public method | GetMethodType | When implemented by a class, obtains information about some method of specified language element. (Inherited from ICodeCompletionRepository.)
Public method | GetNodeType | When implemented by a class, obtains information type of the SyntaxNode (Inherited from ICodeCompletionRepository.)
Public method | GetPriority | When implemented by a class, obtains priority of the given language element. Specifies language element (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(Object) | When implemented by a class, returns information about the object. (Inherited from ICodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | When implemented by a class, returns information about the node. (Inherited from ICodeCompletionRepository.)
Public method | GetSpecialMemberType | When implemented by a class, obtains information about some language element to perform code completion related operations in special cases. (Inherited from ICodeCompletionRepository.)
Public method | IsStructureGuideNode | When implemented by a class, indicates whether specified ISyntaxNode is guide node. (Inherited from ICodeCompletionRepository.)
Public method | LoadTypesFromXml | When implemented by a class, loads type definition from XML.
Public method | LoadTypesFromXmlString | When implemented by a class, loads type definition from XML.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from ICodeCompletionRepository.)
Public method | RegisterSyntaxTree | When implemented by a class, adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from ICodeCompletionRepository.)
Public method | UnregisterSyntaxTree | When implemented by a class, removes specified tree from the list of syntax trees. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IXAMLRepository Interface
Alternet.Syntax.Parsers.XAML Namespace


IXAMLRepository.AddTypeInfoFromType Method

IXAMLRepositoryAddTypeInfoFromType Method
When implemented by a class, load type definition from .NET type.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddTypeInfoFromType(
    Type type
)
Sub AddTypeInfoFromType (
    type As Type
)
void AddTypeInfoFromType(
    Type^ type
)
abstract AddTypeInfoFromType :
        type : Type -> unit

Parameters

type
Type: SystemType
See Also

Reference

IXAMLRepository Interface
Alternet.Syntax.Parsers.XAML Namespace


IXAMLRepository.AddTypeInfoFromTypes Method

IXAMLRepositoryAddTypeInfoFromTypes Method
When implemented by a class, load type definition from .NET types.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void AddTypeInfoFromTypes(
    Type[] types
)
Sub AddTypeInfoFromTypes (
    types As Type()
)
void AddTypeInfoFromTypes(
    array<Type^>^ types
)
abstract AddTypeInfoFromTypes :
        types : Type[] -> unit

Parameters

types
Type: SystemType
Collection of .NET types
See Also

Reference

IXAMLRepository Interface
Alternet.Syntax.Parsers.XAML Namespace


IXAMLRepository.ClearTypeInfos Method

IXAMLRepositoryClearTypeInfos Method
When implemented by a class, clears type definitions.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void ClearTypeInfos()
Sub ClearTypeInfos
void ClearTypeInfos()
abstract ClearTypeInfos : unit -> unit
See Also

Reference

IXAMLRepository Interface
Alternet.Syntax.Parsers.XAML Namespace


IXAMLRepository.CodeCompletion Method

IXAMLRepositoryCodeCompletion Method
When implemented by a class, performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void CodeCompletion(
    Point position,
    CodeCompletionArgs e,
    ISyntaxNode node,
    string text
)
Sub CodeCompletion (
    position As Point,
    e As CodeCompletionArgs,
    node As ISyntaxNode,
    text As String
)
void CodeCompletion(
    Point position,
    CodeCompletionArgs^ e,
    ISyntaxNode^ node,
    String^ text
)
abstract CodeCompletion :
        position : Point *
        e : CodeCompletionArgs *
        node : ISyntaxNode *
        text : string -> unit

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.
node
Type: Alternet.SyntaxISyntaxNode
SyntaxNode for code completion.
text
Type: SystemString
Specifies source text.
See Also

Reference

IXAMLRepository Interface
Alternet.Syntax.Parsers.XAML Namespace


IXAMLRepository.LoadTypesFromXml Method

IXAMLRepositoryLoadTypesFromXml Method
When implemented by a class, loads type definition from XML.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadTypesFromXml(
    string path,
    bool keepExisting = true
)
Sub LoadTypesFromXml (
    path As String,
    Optional keepExisting As Boolean = true
)
void LoadTypesFromXml(
    String^ path,
    bool keepExisting = true
)
abstract LoadTypesFromXml :
        path : string *
        ?keepExisting : bool
(* Defaults:
        let _keepExisting = defaultArg keepExisting true
*)
-> unit

Parameters

path
Type: SystemString
Path to XML file
keepExisting (Optional)
Type: SystemBoolean
Specifies whether to keep existing type definitions.
See Also

Reference

IXAMLRepository Interface
Alternet.Syntax.Parsers.XAML Namespace


IXAMLRepository.LoadTypesFromXmlString Method

IXAMLRepositoryLoadTypesFromXmlString Method
When implemented by a class, loads type definition from XML.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadTypesFromXmlString(
    string xml,
    bool keepExisting = true
)
Sub LoadTypesFromXmlString (
    xml As String,
    Optional keepExisting As Boolean = true
)
void LoadTypesFromXmlString(
    String^ xml,
    bool keepExisting = true
)
abstract LoadTypesFromXmlString :
        xml : string *
        ?keepExisting : bool
(* Defaults:
        let _keepExisting = defaultArg keepExisting true
*)
-> unit

Parameters

xml
Type: SystemString
XML contains data tip.
keepExisting (Optional)
Type: SystemBoolean
Specifies whether to keep existing type definitions.
See Also

Reference

IXAMLRepository Interface
Alternet.Syntax.Parsers.XAML Namespace


IXAMLRepository Properties

IXAMLRepository Properties

The IXAMLRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | When implemented by a class, indicates whether searching for language element's members should be case sensitive. (Inherited from ICodeCompletionRepository.)
Public property | FillBaseMembers | When implemented by a class, indicates whether members of Object class should be present in the member collection. (Inherited from ICodeCompletionRepository.)
Public property | Images | When implemented by a class, gets ImageList attached to this CodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Public property | ImagesHighDpi | When implemented by a class, gets ImageList attached to this CodeCompletionRepository for high DPI. (Inherited from ICodeCompletionRepository.)
Public property | ImagesResourceNameSuffix | When implemented by a class, gets or sets the images resource name suffix. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTree | When implemented by a class, gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from ICodeCompletionRepository.)
Public property | SyntaxTrees | When implemented by a class, gets or sets list of ISyntaxTree objects attached to this ICodeCompletionRepository. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IXAMLRepository Interface
Alternet.Syntax.Parsers.XAML Namespace


IXAMLRepository Events

IXAMLRepository Events

The IXAMLRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | When implemented by a class, occurs while trying to obtain description of some language element. (Inherited from ICodeCompletionRepository.)
Public event | MemberLookup | When implemented by a class, occurs while trying to obtain information about some member of language element. (Inherited from ICodeCompletionRepository.)
Top
See Also

Reference

IXAMLRepository Interface
Alternet.Syntax.Parsers.XAML Namespace


XAMLConsts Class

XAMLConsts Class
Contains default constants related to XAML syntax parser.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.Parsers.XAMLXAMLConsts

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class XAMLConsts
Public NotInheritable Class XAMLConsts
public ref class XAMLConsts abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XAMLConsts =  class end

The XAMLConsts type exposes the following members.

Fields
Name | Description
DefaultCodeCompletionChars |
DefaultDelimibers |
DefaultXAMLAutoIndentChars |
DefaultXAMLOptions |
Top
See Also

Reference

Alternet.Syntax.Parsers.XAML Namespace


XAMLConsts Fields

XAMLConsts Fields

The XAMLConsts type exposes the following members.

Fields
Name | Description
DefaultCodeCompletionChars |
DefaultDelimibers |
DefaultXAMLAutoIndentChars |
DefaultXAMLOptions |
Top
See Also

Reference

XAMLConsts Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLConsts.DefaultCodeCompletionChars Field

XAMLConstsDefaultCodeCompletionChars Field

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultCodeCompletionChars
Public Shared DefaultCodeCompletionChars As String
public:
static String^ DefaultCodeCompletionChars
static val mutable DefaultCodeCompletionChars: string

Field Value

Type: String
See Also

Reference

XAMLConsts Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLConsts.DefaultDelimibers Field

XAMLConstsDefaultDelimibers Field

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultDelimibers
Public Shared DefaultDelimibers As String
public:
static String^ DefaultDelimibers
static val mutable DefaultDelimibers: string

Field Value

Type: String
See Also

Reference

XAMLConsts Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLConsts.DefaultXAMLAutoIndentChars Field

XAMLConstsDefaultXAMLAutoIndentChars Field

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DefaultXAMLAutoIndentChars
Public Shared DefaultXAMLAutoIndentChars As String
public:
static String^ DefaultXAMLAutoIndentChars
static val mutable DefaultXAMLAutoIndentChars: string

Field Value

Type: String
See Also

Reference

XAMLConsts Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLConsts.DefaultXAMLOptions Field

XAMLConstsDefaultXAMLOptions Field

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SyntaxOptions DefaultXAMLOptions
Public Shared DefaultXAMLOptions As SyntaxOptions
public:
static SyntaxOptions DefaultXAMLOptions
static val mutable DefaultXAMLOptions: SyntaxOptions

Field Value

Type: SyntaxOptions
See Also

Reference

XAMLConsts Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMember Class

XAMLListMember Class
Implements properties and methods for a particular list member in the data collection of the code completion popups used to describe C# language code.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionProviderItem
Alternet.Syntax.CodeCompletionListMember
Alternet.Syntax.Parsers.XAMLXAMLListMember

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XAMLListMember : ListMember
Public Class XAMLListMember
    Inherits ListMember
public ref class XAMLListMember : public ListMember
type XAMLListMember =
    class
        inherit ListMember
    end

The XAMLListMember type exposes the following members.

Constructors
 | Name | Description
Public method | XAMLListMember | Initializes a new instance of the CsListMember class with default settings.
Public method | XAMLListMember(IListMembers, Boolean) | Initializes a new instance of the CsListMember class with specified owner. IListMembers owning this instanceBoolean value indicating that member should provide detailed description.
Top
Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Inherited from ListMember.)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets a CodeCompletionCategory to which this ListMember belongs. (Inherited from ListMember.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

Alternet.Syntax.Parsers.XAML Namespace


XAMLListMember Constructor

XAMLListMember Constructor
Overload List
 | Name | Description
Public method | XAMLListMember | Initializes a new instance of the CsListMember class with default settings.
Public method | XAMLListMember(IListMembers, Boolean) | Initializes a new instance of the CsListMember class with specified owner. IListMembers owning this instanceBoolean value indicating that member should provide detailed description.
Top
See Also

Reference

XAMLListMember Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMember Constructor

XAMLListMember Constructor
Initializes a new instance of the CsListMember class with default settings.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XAMLListMember()
Public Sub New
public:
XAMLListMember()
new : unit -> XAMLListMember
See Also

Reference

XAMLListMember Class
XAMLListMember Overload
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMember Constructor (IListMembers, Boolean)

XAMLListMember Constructor (IListMembers, Boolean)
Initializes a new instance of the CsListMember class with specified owner. IListMembers owning this instanceBoolean value indicating that member should provide detailed description.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XAMLListMember(
    IListMembers owner,
    bool fullDescription
)
Public Sub New (
    owner As IListMembers,
    fullDescription As Boolean
)
public:
XAMLListMember(
    IListMembers^ owner,
    bool fullDescription
)
new :
        owner : IListMembers *
        fullDescription : bool -> XAMLListMember

Parameters

owner
Type: Alternet.Syntax.CodeCompletionIListMembers
fullDescription
Type: SystemBoolean
See Also

Reference

XAMLListMember Class
XAMLListMember Overload
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMember Methods

XAMLListMember Methods

The XAMLListMember type exposes the following members.

Methods
 | Name | Description
Public method | AddDescription | Appends text to the member description. (Inherited from ListMember.)
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ListMember.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParamText | Converts Parameters property to a single string. (Inherited from ListMember.)
Public method | GetTemplate | Return member's template. (Inherited from ListMember.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XAMLListMember Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMember Properties

XAMLListMember Properties

The XAMLListMember type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets additional attributes associated with a member. (Inherited from ListMember.)
Public property | Category | Gets or sets a CodeCompletionCategory to which this ListMember belongs. (Inherited from ListMember.)
Public property | CurrentParamIndex | Gets or sets index of current parameter in the parameters collection. (Inherited from ListMember.)
Public property | CustomData | Gets or sets an object that can hold a user defined data attached to the ListMember. (Inherited from ListMember.)
Public property | DataType | Gets or sets a string value that specifies data type of the ListMember. (Inherited from ListMember.)
Public property | Description | Return member's description. (Overrides ListMemberDescription.)
Public property | DisplayText | Gets or sets a string value displayed as a "name" part of ListMember. (Inherited from ListMember.)
Public property | Image | Gets or sets the index of the image for the ListMember. (Inherited from ListMember.)
Public property | ImageIndex | Gets or sets the index of the image displayed for the ListMember. (Inherited from ListMember.)
Public property | InsertText | Gets or sets a string value inserted in the Editor when IListMember is selected. (Inherited from ListMember.)
Public property | MemberType | Gets or sets the integer value representing type of the member. (Inherited from ListMember.)
Public property | Name | Gets or sets a string value that specifies the name of the ListMember. Useful to find necessary item within the ListMember collection. (Inherited from ListMember.)
Public property | Overloads | Gets or sets number of overloading members ListMember in the collection. (Inherited from ListMember.)
Public property | Owner | Gets IListMembers instance owning the ListMember. (Inherited from ListMember.)
Public property | Parameters | Gets or sets a collection of parameters of this ListMember. (Inherited from ListMember.)
Public property | ParamText | Gets or sets a string value that specifies comma separated list of parameters of the ListMember. (Inherited from ListMember.)
Public property | Priority | Gets or sets priority for the ListMember. (Inherited from ListMember.)
Public property | Qualifier | Gets or sets a string value that specifies access modifiers of the ListMember. (Inherited from ListMember.)
Public property | SerializationInfo | When implemented by a class, gets or sets an xml representation of this ICodeCompletionProviderItem object. (Inherited from CodeCompletionProviderItem.)
Top
See Also

Reference

XAMLListMember Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMember.Description Property

XAMLListMemberDescription Property
Return member's description.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Return Value

Type: String
String value that describes the member.

Implements

IListMemberDescription
See Also

Reference

XAMLListMember Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMembers Class

XAMLListMembers Class
Represents data collection related to popup list box controls used to describe XAML language code.
Inheritance Hierarchy
SystemObject
System.Collections.GenericListICodeCompletionProviderItem
Alternet.Syntax.CodeCompletionCodeCompletionProvider
Alternet.Syntax.CodeCompletionListMembers
Alternet.Syntax.Parsers.XAMLXAMLListMembers

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XAMLListMembers : ListMembers
Public Class XAMLListMembers
    Inherits ListMembers
public ref class XAMLListMembers : public ListMembers
type XAMLListMembers =
    class
        inherit ListMembers
    end

The XAMLListMembers type exposes the following members.

Constructors
 | Name | Description
Public method | XAMLListMembers | Initializes a new instance of the XAMLListMembers class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

Alternet.Syntax.Parsers.XAML Namespace


XAMLListMembers Constructor

XAMLListMembers Constructor
Initializes a new instance of the XAMLListMembers class

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XAMLListMembers()
Public Sub New
public:
XAMLListMembers()
new : unit -> XAMLListMembers
See Also

Reference

XAMLListMembers Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMembers Methods

XAMLListMembers Methods

The XAMLListMembers type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AddListMember | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddListMember(IListMember) | Adds a new item to the ListMembers collection. (Inherited from ListMembers.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | AsReadOnly | Returns a read-only IListT wrapper for the current collection. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ListICodeCompletionProviderItem .)
Public method | Clear | Removes all elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ColumnSpace | Indicates whether after specified column SPACE is required. (Inherited from ListMembers.)
Public method | ColumnVisible | Indicates whether specified column is visible. (Inherited from ListMembers.)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ListICodeCompletionProviderItem .)
Public method | CreateListMember | Initializes a new instance of the ListMember class with default settings. (Inherited from ListMembers.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetAvailableCategories | Returns list of all available categories. (Inherited from ListMembers.)
Public method | GetCategory | Gets a category by its index. (Inherited from ListMembers.)
Public method | GetColumnText | Returns text from given list member in the specified column. (Inherited from ListMembers.)
Public method | GetDescription | Returns a content of the column, named 'Description', of the specified item from the collection. (Inherited from ListMembers.)
Public method | GetDisplayText | Returns string representing the display text of the item. (Inherited from ListMembers.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetFullDisplayText | Returns string representing full display text of the item. (Inherited from CodeCompletionProvider.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImage | Returns an image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetImageIndex | Returns index of image that is displayed for item given by Index. (Inherited from ListMembers.)
Public method | GetInsertText | Returns string to be inserted. (Inherited from ListMembers.)
Public method | GetName | Returns string representing name of the item. (Inherited from ListMembers.)
Public method | GetParent | Returns code completion provider owning this ICodeCompletionProvider instance. (Inherited from CodeCompletionProvider.)
Public method | GetPriority | Returns priority of the item. (Inherited from ListMembers.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | GetText | Returns string representing default column. (Inherited from ListMembers.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from ListICodeCompletionProviderItem .)
Public method | IndexOfName | Returns index of the item within collection by it's name. (Inherited from CodeCompletionProvider.)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | InsertListMember | Inserts a new item to the specified position within the ListMembers collection. (Inherited from ListMembers.)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from ListICodeCompletionProviderItem .)
Public method | LoadFile(String) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the given stream into the snippet. (Inherited from CodeCompletionProvider.)
Public method | OnClosePopup | Raises ClosePopup event. (Inherited from CodeCompletionProvider.)
Public method | OnShowPopup | Raises ShowPopup event. (Inherited from CodeCompletionProvider.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | ResetShowHints | Resets the ShowHints to the default value. (Inherited from ListMembers.)
Public method | ResetShowParams | Resets the ShowParams to the default value. (Inherited from ListMembers.)
Public method | ResetShowQualifiers | Resets the ShowQualifiers to the default value. (Inherited from ListMembers.)
Public method | ResetShowResults | Resets the ShowResults to the default value. (Inherited from ListMembers.)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ListICodeCompletionProviderItem .)
Public method | SaveFile(String) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveFile(String, Encoding) | Saves content of the snippet to the specific file. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(TextWriter) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | SaveStream(Stream, Encoding) | Saves content of the snippet to the specified stream. (Inherited from CodeCompletionProvider.)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from ListICodeCompletionProviderItem .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from ListICodeCompletionProviderItem .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from ListICodeCompletionProviderItem .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from ListICodeCompletionProviderItem .)
Top
See Also

Reference

XAMLListMembers Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMembers Properties

XAMLListMembers Properties

The XAMLListMembers type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from ListICodeCompletionProviderItem .)
Public property | ColumnCount | Represents number of the columns. In this class ColumnCount always return 4. (Inherited from ListMembers.)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from ListICodeCompletionProviderItem .)
Public property | Descriptions | Provides an indexed access to the description of each column. (Inherited from CodeCompletionProvider.)
Public property | EditField | Gets or sets a value indicating editable field of the code completion provider. (Inherited from CodeCompletionProvider.)
Public property | EditPath | Gets or sets a value indicating path to the nested code completion provider. (Inherited from CodeCompletionProvider.)
Public property | FocusMode | Specifies mode where pre-selected item in code completion listbox is just focused, but not selected. (Inherited from CodeCompletionProvider.)
Public property | FormatDisplayText | Gets a boolean value indicating that rich text formatting should be applied to display text. (Inherited from CodeCompletionProvider.)
Public property | ImageIndexes | Provides an indexed access to the image index of each column. (Inherited from CodeCompletionProvider.)
Public property | Images | Gets or sets the ImageList for code completion items. (Inherited from CodeCompletionProvider.)
Public property | ImagesHighDpi | Gets or sets the ImageList for code completion items for high DPI. (Inherited from CodeCompletionProvider.)
Public property | InvokeChar | Specifies a character that triggered code completion invocation (Inherited from CodeCompletionProvider.)
Public property | Item | Provides an indexed access to IListMember objects stored in the collection. (Inherited from ListMembers.)
Public property | NameColumnIndex | Gets index of the column containing name. (Inherited from ListMembers.)
Public property | NeedSort | Specifies if provider content needs to be sorted. (Inherited from CodeCompletionProvider.)
Public property | SelIndex | Represents the index specifying the currently selected item of the popup control. (Inherited from CodeCompletionProvider.)
Public property | SerializationInfo | Gets or sets an xml representation of this CodeCompletionProvider object. (Inherited from CodeCompletionProvider.)
Public property | ShowDescriptions | Gets or sets a boolean value that indicates whether provider should display Description part in a form of tooltip near the popup control. (Inherited from CodeCompletionProvider.)
Public property | ShowHints | Gets or sets a value indicating whether popup listbox should display additional information for selected list member. (Inherited from ListMembers.)
Public property | ShowParams | Gets or sets a value indicating whether the "Params" column is visible. (Inherited from ListMembers.)
Public property | ShowQualifiers | Gets or sets a value indicating whether the "Qualifiers" column is visible. (Inherited from ListMembers.)
Public property | ShowResults | Gets or sets a value indicating whether the "Results" column is visible. (Inherited from ListMembers.)
Public property | Strings | Provides an indexed access to the text of default column. (Inherited from CodeCompletionProvider.)
Public property | UseHtmlFormatting | Gets or sets a boolean value indicating whether html formatting tags may appear in the text. (Inherited from CodeCompletionProvider.)
Public property | UseIndent | Gets or sets a value indicating whether the multi-line text should be indented when inserting to the edit control. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

XAMLListMembers Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLListMembers Events

XAMLListMembers Events

The XAMLListMembers type exposes the following members.

Events
 | Name | Description
Public event | ClosePopup | Occurs when popup control is closed. (Inherited from CodeCompletionProvider.)
Public event | ShowPopup | Occurs when popup control is displayed. (Inherited from CodeCompletionProvider.)
Top
See Also

Reference

XAMLListMembers Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser Class

XAMLParser Class
Represents class that and perform syntax and lexical analysis of specified XAML code text.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Alternet.Syntax.LexerLexer
Alternet.SyntaxParser
Alternet.SyntaxSyntaxParser
Alternet.SyntaxXmlParser
Alternet.Syntax.Parsers.XAMLXAMLParser

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XAMLParser : XmlParser
Public Class XAMLParser
    Inherits XmlParser
public ref class XAMLParser : public XmlParser
type XAMLParser =
    class
        inherit XmlParser
    end

The XAMLParser type exposes the following members.

Constructors
 | Name | Description
Public method | XAMLParser | Initializes a new instance of the XAMLParser class with default settings.
Top
Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides XmlParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Overrides SyntaxParserGetSmartIndent(Int32, Boolean, Boolean).)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Overrides SyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32).)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides XmlParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Overrides SyntaxParserReparseText(Boolean).)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides XmlParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides XmlParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from XmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

Alternet.Syntax.Parsers.XAML Namespace


XAMLParser Constructor

XAMLParser Constructor
Initializes a new instance of the XAMLParser class with default settings.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XAMLParser()
Public Sub New
public:
XAMLParser()
new : unit -> XAMLParser
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser Methods

XAMLParser Methods

The XAMLParser type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts parsing process by raising StopParseException exception. (Inherited from SyntaxParser.)
Public method | AddNotifier | Adds new handler to respond a notification. (Inherited from Lexer.)
Public method | Assign | Assigns most relevant properties from another ILexer object. (Inherited from Lexer.)
Public method | BeginUpdate | Prevents object state updating until calling EndUpdate method. (Inherited from Lexer.)
Public method | BlockDeleting | Removes all nodes from the node collection which position in the specified rectangle. (Inherited from SyntaxParser.)
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | CreateRepository | Creates ICodeCompletionRepository to perform code completion functionality for this parser. (Overrides SyntaxParserCreateRepository.)
Public method | DisableUpdate | Prevents object state updating until calling EnableUpdate method. (Inherited from Lexer.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | EnableUpdate | Re-enables object state updating, that was turn of by calling DisableUpdate method. Using DisableUpdate/EnableUpdate to prevent notifying about updating the object state. (Inherited from Lexer.)
Public method | EndUpdate | Re-enables object state updating, that was turn of by calling BeginUpdate method. (Inherited from Lexer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindCodeFixes | Locates and highlights available code refactors for given syntax error. (Inherited from SyntaxParser.)
Public method | FindCodeRefactors | Locates and highlights available code refactors at given position in the text. (Inherited from SyntaxParser.)
Public method | FindDeclaration(Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindDeclaration(String, Point) | Finds the declaration node at given position. (Inherited from SyntaxParser.)
Public method | FindImplementations | Locates all implementations at given position and in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point) | Locates and highlights references at given position in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(ISyntaxNode, ISyntaxNodes) | Locates all references to the node in the text. (Inherited from SyntaxParser.)
Public method | FindReferences(Point, IRangeList, Boolean) | Locates declaration at given position and finds all references to this declaration in the text. (Inherited from SyntaxParser.)
Public method | FinishParsing | Commits parsing process. (Inherited from SyntaxParser.)
Public method | GetActiveStatementAt | Gets IRange that corresponds to the statement at specified position. (Inherited from SyntaxParser.)
Public method | GetAutoFormatNode | Gets syntax block node at specified position. (Inherited from SyntaxParser.)
Public method | GetCodeFixes | Retrieves all code fixes available for the given syntax error. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Boolean) | Retrieves all applicable refactors at given position. (Inherited from SyntaxParser.)
Public method | GetCodeRefactors(Point, Point, Boolean) | Retrieves all applicable refactors at given range. (Inherited from SyntaxParser.)
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides XmlParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Public method | GetContentDividers | Gets list of content dividers. (Inherited from SyntaxParser.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetMultiLineComment(String, String) | Gets the start and symbols multi-line comment. (Inherited from XmlParser.)
Public method | GetMultiLineComment(Point, String, String) | Gets the start and symbols multi-line comment. (Inherited from SyntaxParser.)
Public method | GetNodeAt | Gets ISyntaxNode that corresponds to the specified position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetRangeAt(Point, IListIRange) | Gets IRange that contains given position. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSingleLineComment(Point) | Gets the string that represents start symbol of single line comment. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Overrides SyntaxParserGetSmartIndent(Int32, Boolean, Boolean).)
Public method | GetSmartIndentString | Returns indentation string for specified line. (Overrides SyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32).)
Public method | GetStructureGuideLines | Gets list of guide lines. (Inherited from SyntaxParser.)
Public method | GetSyntaxErrors | Retrieves all syntax errors found while analyzing the text. (Inherited from SyntaxParser.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | IsCodeCompletionChar | Returns boolean value indicating that given character initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public method | IsDeclaration | Indicates whether specified node represents declaration elements. (Inherited from SyntaxParser.)
Public method | LoadFile(String) | Loads the contents of the specified file. (Inherited from SyntaxParser.)
Public method | LoadFile(String, Encoding) | Loads the contents of the specified file with specified encoding. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(TextReader) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | LoadStream(Stream, Encoding) | Loads the contents of the specified stream. (Inherited from SyntaxParser.)
Public method | NextToken | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextToken(String) | Parses text from current position to the next token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | NextValidToken(String) | Parses text from current position to the next valid (non-whitespace, non-comment) token and updates TokenPos, CurrentPos and TokenString properties. (Inherited from Parser.)
Public method | Notify | Notifies all notifiers about updating object state. (Inherited from Lexer.)
Public method | OnTextChanged | Responds to incremental change of the text in the editor. (Inherited from SyntaxParser.)
Public method | OnTextParsed | Raises TextParsed event. (Inherited from SyntaxParser.)
Public method | Outline | Creates outlined sections for parsed text using result of syntax analysis and fills ranges parameter by the collection of the outlined sections. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, StringItemInfo) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | ParseText(Int32, Int32, String, Int32, Int32, Int32) | Performs lexical analysis of given text. (Inherited from SyntaxParser.)
Public method | PeekToken | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekToken(String) | Parses next portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PeekValidToken(String) | Parses to the next valid (non-whitespace, non-comment) portion of the text, remaining current position unchanged. (Inherited from Parser.)
Public method | PositionChanged | Changes positions of any syntax nodes and its elements located next to the specified position. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, PrepareReason) | When implemented by a class, sets lines to parse. (Inherited from SyntaxParser.)
Public method | Prepare(String, IStringList, ISyntaxTree, Boolean, PrepareReason) | Sets lines to parse. (Inherited from SyntaxParser.)
Public method | ProcessAutoComplete | Checks whether end-of-block code needs inserting. (Inherited from SyntaxParser.)
Public method | ProcessSnippetBody | Checks whether snippet body code needs inserting. (Inherited from SyntaxParser.)
Public method | RemoveNotifier | Exclude specified handler from notification handlers list. (Inherited from Lexer.)
Public method | RemovePlainText | Removes all plain (string constants or comments) parts of text from specified text. (Inherited from Lexer.)
Public method | ReparseBlock(Point) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseBlock(Point, String, ISyntaxNode, CodeCompletionType) | Reparses syntax block at specified position. (Inherited from SyntaxParser.)
Public method | ReparseText | Reparses entire text. (Overrides XmlParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Overrides SyntaxParserReparseText(Boolean).)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Public method | Reset | Resets SyntaxParser to the start position. (Inherited from SyntaxParser.)
Public method | Reset(Int32, Int32, Int32) | Resets Parser to the specified position. (Inherited from Parser.)
Public method | ResetAutoIndentChars | Resets AutoIndentChars to the default value. (Overrides SyntaxParserResetAutoIndentChars.)
Public method | ResetCodeCompletionChars | Resets CodeCompletionChars to the default value. (Overrides SyntaxParserResetCodeCompletionChars.)
Public method | ResetCodeCompletionStopChars | Resets CodeCompletionStopChars to the default value. (Inherited from SyntaxParser.)
Public method | ResetDefaultState | Resets the DefaultState to the default value. (Inherited from Lexer.)
Public method | ResetOptions | Resets Options to the default value. (Overrides XmlParserResetOptions.)
Public method | ResetParseInterval | Resets ParseInterval to the default value. (Inherited from SyntaxParser.)
Public method | ResetSmartFormatChars | Resets SmartFormatChars to the default value. (Inherited from SyntaxParser.)
Public method | RestoreState | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreState(Boolean) | Restores Parser state and position stored by SaveState method. (Inherited from Parser.)
Public method | RestoreSyntaxTree | Restores syntax tree, stored by SaveSyntaxTree method. (Inherited from SyntaxParser.)
Public method | SaveState | Saves current Parser state and position. (Inherited from Parser.)
Public method | SaveSyntaxTree | Saves current syntax tree. (Inherited from SyntaxParser.)
Public method | ShouldSerializeAutoIndentChars | Indicates whether the SmartFormatChars property should be persisted. (Overrides SyntaxParserShouldSerializeAutoIndentChars.)
Public method | ShouldSerializeCodeCompletionChars | Indicates whether the CodeCompletionChars property should be persisted. (Overrides SyntaxParserShouldSerializeCodeCompletionChars.)
Public method | ShouldSerializeCodeCompletionStopChars | Indicates whether the CodeCompletionStopChars property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeOptions | Indicates whether the Options property should be persisted. (Overrides XmlParserShouldSerializeOptions.)
Public method | ShouldSerializeParseInterval | Indicates whether the ParseInterval property should be persisted. (Inherited from SyntaxParser.)
Public method | ShouldSerializeSmartFormatChars | Indicates whether the SmartFormatChars property should be persisted. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Boolean, Int32, ITextUndoList, String) | Formats block of text according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormat(Point, Point, Boolean, Int32, Boolean, ITextUndoList) | Formats block of text according to the parser rules. Start position of the blockEnd position of the blockIndicates whether indentation string should contain spaces or tabsSpecifies number of spaces in tabSpecifies if whole syntax block containing start and end point should be formattedList containing insertion or deletion of text fragments. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | SmartFormatLine(Int32, String, StringItemInfo, ITextUndoList, Boolean) | Formats line according to the parser rules. (Inherited from SyntaxParser.)
Public method | StartParsing | Prepares parser to parse the specified range of the text. (Inherited from SyntaxParser.)
Public method | StopParsing | Aborts parsing process. (Inherited from SyntaxParser.)
Public method | SupportsAsyncParsing | Indicates whether parser supports async parsing. (Inherited from SyntaxParser.)
Public method | SupportsCodeCompletionFiltering | When implemented by a class, returns boolean value indicating that information can be filtered for given code completion type. (Inherited from SyntaxParser.)
Public method | SupportsContentDividers | Indicates whether content dividers are supported. (Inherited from SyntaxParser.)
Public method | SupportsTextChanges | Indicates whether parser supports incremental text changes. (Inherited from SyntaxParser.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | When implemented by a class, updates an object state. (Inherited from Lexer.)
Top
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.CodeCompletion Method

XAMLParserCodeCompletion Method
Overload List
 | Name | Description
Public method | CodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Overrides SyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs).)
Public method | CodeCompletion(String, StringItemInfo, Point, Boolean, CodeCompletionArgs) | Performs code completion for the specified text representing language element. (Inherited from SyntaxParser.)
Top
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.CodeCompletion Method (String, StringItemInfo[], Point, CodeCompletionArgs)

XAMLParserCodeCompletion Method (String, StringItemInfo, Point, CodeCompletionArgs)
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void CodeCompletion(
    string text,
    StringItemInfo[] textData,
    Point position,
    CodeCompletionArgs e
)
Public Overrides Sub CodeCompletion (
    text As String,
    textData As StringItemInfo(),
    position As Point,
    e As CodeCompletionArgs
)
public:
virtual void CodeCompletion(
    String^ text,
    array<StringItemInfo>^ textData,
    Point position,
    CodeCompletionArgs^ e
) override
abstract CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit
override CodeCompletion :
        text : string *
        textData : StringItemInfo[] *
        position : Point *
        e : CodeCompletionArgs -> unit

Parameters

text
Type: SystemString
Specifies source text.
textData
Type: Alternet.SyntaxStringItemInfo
Specifies data containing color information for the given string.
position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
Contains data for the code completion.

Implements

ISyntaxParserCodeCompletion(String, StringItemInfo, Point, CodeCompletionArgs)
See Also

Reference

XAMLParser Class
CodeCompletion Overload
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.CreateRepository Method

XAMLParserCreateRepository Method
Creates ICodeCompletionRepository to perform code completion functionality for this parser.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICodeCompletionRepository CreateRepository()
Public Overrides Function CreateRepository As ICodeCompletionRepository
public:
virtual ICodeCompletionRepository^ CreateRepository() override
abstract CreateRepository : unit -> ICodeCompletionRepository
override CreateRepository : unit -> ICodeCompletionRepository

Return Value

Type: ICodeCompletionRepository
ICodeCompletionRepository that is created.
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.GetCompletionType Method

XAMLParserGetCompletionType Method
Overload List
 | Name | Description
Public method | GetCompletionType(Char) | Obtains type of code completion window from specifies char parameter. (Overrides XmlParserGetCompletionType(Char).)
Public method | GetCompletionType(CodeCompletionArgs) | Obtains type of code completion window from specifies CodeCompletionArgs parameter. (Inherited from SyntaxParser.)
Top
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.GetCompletionType Method (Char)

XAMLParserGetCompletionType Method (Char)
Obtains type of code completion window from specifies char parameter.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CodeCompletionType GetCompletionType(
    char ch
)
Public Overrides Function GetCompletionType (
    ch As Char
) As CodeCompletionType
public:
virtual CodeCompletionType GetCompletionType(
    wchar_t ch
) override
abstract GetCompletionType :
        ch : char -> CodeCompletionType
override GetCompletionType :
        ch : char -> CodeCompletionType

Parameters

ch
Type: SystemChar
Contains char being typed.

Return Value

Type: CodeCompletionType
CodeCompletionType data of window to popup.
See Also

Reference

XAMLParser Class
GetCompletionType Overload
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.GetSmartIndent Method

XAMLParserGetSmartIndent Method
Overload List
 | Name | Description
Public method | GetSmartIndent(Int32, Boolean) | Returns indentation level of specified line. (Inherited from SyntaxParser.)
Public method | GetSmartIndent(Int32, Boolean, Boolean) | Returns indentation level of specified line. (Overrides SyntaxParserGetSmartIndent(Int32, Boolean, Boolean).)
Top
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.GetSmartIndent Method (Int32, Boolean, Boolean)

XAMLParserGetSmartIndent Method (Int32, Boolean, Boolean)
Returns indentation level of specified line.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetSmartIndent(
    int index,
    bool autoIndent,
    out bool actualPosition
)
Public Overrides Function GetSmartIndent (
    index As Integer,
    autoIndent As Boolean,
    <OutAttribute> ByRef actualPosition As Boolean
) As Integer
public:
virtual int GetSmartIndent(
    int index,
    bool autoIndent,
    [OutAttribute] bool% actualPosition
) override
abstract GetSmartIndent :
        index : int *
        autoIndent : bool *
        actualPosition : bool byref -> int
override GetSmartIndent :
        index : int *
        autoIndent : bool *
        actualPosition : bool byref -> int

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
actualPosition
Type: SystemBoolean
If true, the indentation position will be returned, otherwise, the level.

Return Value

Type: Int32
Indentation level at line specified by index.

Implements

ISyntaxParserGetSmartIndent(Int32, Boolean, Boolean)
See Also

Reference

XAMLParser Class
GetSmartIndent Overload
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.GetSmartIndentString Method

XAMLParserGetSmartIndentString Method
Returns indentation string for specified line.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
)
Public Overrides Function GetSmartIndentString (
    index As Integer,
    autoIndent As Boolean,
    useSpaces As Boolean,
    spacesInTab As Integer
) As String
public:
virtual String^ GetSmartIndentString(
    int index,
    bool autoIndent,
    bool useSpaces,
    int spacesInTab
) override
abstract GetSmartIndentString :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string
override GetSmartIndentString :
        index : int *
        autoIndent : bool *
        useSpaces : bool *
        spacesInTab : int -> string

Parameters

index
Type: SystemInt32
Specifies index of line to obtain indentation level.
autoIndent
Type: SystemBoolean
Indicates whether indentation level should be calculated automatically, or obtained from the previous line.
useSpaces
Type: SystemBoolean
Indicates whether indentation string should contain spaces or tabs.
spacesInTab
Type: SystemInt32
Specifies number of spaces in tab.

Return Value

Type: String
Indentation text at line specified by index.

Implements

ISyntaxParserGetSmartIndentString(Int32, Boolean, Boolean, Int32)
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.ReparseText Method

XAMLParserReparseText Method
Overload List
 | Name | Description
Public method | ReparseText | Reparses entire text. (Overrides XmlParserReparseText.)
Public method | ReparseText(Boolean) | Reparses entire text. Specifies whether parser should perform the task in the separate thread (Overrides SyntaxParserReparseText(Boolean).)
Public method | ReparseText(Boolean, Int32, Int32) | Reparses entire text. Specifies whether parser should perform the task in the separate threadSpecifies first changed line in the source text.Specifies last changed line in the source text. (Inherited from SyntaxParser.)
Top
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.ReparseText Method

XAMLParserReparseText Method
Reparses entire text.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText()
Public Overrides Sub ReparseText
public:
virtual void ReparseText() override
abstract ReparseText : unit -> unit
override ReparseText : unit -> unit

Implements

ISyntaxParserReparseText
See Also

Reference

XAMLParser Class
ReparseText Overload
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.ReparseText Method (Boolean)

XAMLParserReparseText Method (Boolean)
Reparses entire text. Specifies whether parser should perform the task in the separate thread

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ReparseText(
    bool useThread
)
Public Overrides Sub ReparseText (
    useThread As Boolean
)
public:
virtual void ReparseText(
    bool useThread
) override
abstract ReparseText :
        useThread : bool -> unit
override ReparseText :
        useThread : bool -> unit

Parameters

useThread
Type: SystemBoolean

Implements

ISyntaxParserReparseText(Boolean)
See Also

Reference

XAMLParser Class
ReparseText Overload
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.ResetAutoIndentChars Method

XAMLParserResetAutoIndentChars Method
Resets AutoIndentChars to the default value.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetAutoIndentChars()
Public Overrides Sub ResetAutoIndentChars
public:
virtual void ResetAutoIndentChars() override
abstract ResetAutoIndentChars : unit -> unit
override ResetAutoIndentChars : unit -> unit

Implements

ISyntaxParserResetAutoIndentChars
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.ResetCodeCompletionChars Method

XAMLParserResetCodeCompletionChars Method
Resets CodeCompletionChars to the default value.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetCodeCompletionChars()
Public Overrides Sub ResetCodeCompletionChars
public:
virtual void ResetCodeCompletionChars() override
abstract ResetCodeCompletionChars : unit -> unit
override ResetCodeCompletionChars : unit -> unit

Implements

ISyntaxParserResetCodeCompletionChars
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.ResetOptions Method

XAMLParserResetOptions Method
Resets Options to the default value.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void ResetOptions()
Public Overrides Sub ResetOptions
public:
virtual void ResetOptions() override
abstract ResetOptions : unit -> unit
override ResetOptions : unit -> unit

Implements

ISyntaxParserResetOptions
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.ShouldSerializeAutoIndentChars Method

XAMLParserShouldSerializeAutoIndentChars Method
Indicates whether the SmartFormatChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeAutoIndentChars()
Public Overrides Function ShouldSerializeAutoIndentChars As Boolean
public:
virtual bool ShouldSerializeAutoIndentChars() override
abstract ShouldSerializeAutoIndentChars : unit -> bool
override ShouldSerializeAutoIndentChars : unit -> bool

Return Value

Type: Boolean
True if SmartFormatChars differs from its default value; otherwise false.
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.ShouldSerializeCodeCompletionChars Method

XAMLParserShouldSerializeCodeCompletionChars Method
Indicates whether the CodeCompletionChars property should be persisted.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeCodeCompletionChars()
Public Overrides Function ShouldSerializeCodeCompletionChars As Boolean
public:
virtual bool ShouldSerializeCodeCompletionChars() override
abstract ShouldSerializeCodeCompletionChars : unit -> bool
override ShouldSerializeCodeCompletionChars : unit -> bool

Return Value

Type: Boolean
True if CodeCompletionChars differs from its default value; otherwise false.
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.ShouldSerializeOptions Method

XAMLParserShouldSerializeOptions Method
Indicates whether the Options property should be persisted.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ShouldSerializeOptions()
Public Overrides Function ShouldSerializeOptions As Boolean
public:
virtual bool ShouldSerializeOptions() override
abstract ShouldSerializeOptions : unit -> bool
override ShouldSerializeOptions : unit -> bool

Return Value

Type: Boolean
True if Options differs from its default value; otherwise false.
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser Properties

XAMLParser Properties

The XAMLParser type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Gets or sets boolean variable indicating whether parsing process has been aborted. (Inherited from SyntaxParser.)
Public property | AutoIndentChars | Gets or sets a collection of characters that initializes an indentation procedure when typing. (Inherited from SyntaxParser.)
Public property | CaseSensitive | Gets or sets a boolean value that indicates whether JavaScriptParser should perform case-sensitive analysis of its content. (Inherited from XmlParser.)
Public property | CodeCompletionChars | Gets or sets a collection of characters that initializes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeCompletionStopChars | Gets or sets a collection of characters that finalizes a code completion procedure when typing. (Inherited from SyntaxParser.)
Public property | CodeSnippets | When implemented by a class, returns code snippets for the given parser. (Inherited from SyntaxParser.)
Public property | CompletionRepository | Gets or sets an ICodeCompletionRepository that holds methods for code completion purposes. (Inherited from SyntaxParser.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentPosition | Represents position of current character within the current line. (Inherited from Parser.)
Public property | DefaultState | Gets or sets default state of the Lexer. (Inherited from Lexer.)
Public property | Delimiters | Gets or sets a collection of characters representing delimiters (Inherited from SyntaxParser.)
Public property | Eof | Indicates whether current position is out of the text, signaling that whole text is parsed. (Inherited from Parser.)
Public property | ExpressionEvaluator | Gets or sets an IExpressionEvaluator instance using to evaluate conditional defines. (Inherited from SyntaxParser.)
Public property | FileName | Gets or sets file name of the file being parsed. (Inherited from SyntaxParser.)
Public property | Lines | Gets or sets a list of string to parse represented as string array. (Inherited from Parser.)
Public property | Options | Gets or sets a flags determining syntax parsing and formatting behavior. (Inherited from SyntaxParser.)
Public property | ParseInterval | Specifies delay reparsing should trigger after any change in the editor. (Inherited from SyntaxParser.)
Public property | Repository | Gets an IRoslynRepository that holds methods for code completion purposes.
Public property | Scheme | Gets or sets list of rules for lexical analysis. (Inherited from Lexer.)
Public property | SerializationInfo | Gets or sets an xml representation of this Lexer object. (Inherited from Lexer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmartFormatChars | Gets or sets a collection of characters that initializes a smart formatting procedure when typing. (Inherited from SyntaxParser.)
Public property | State | Represents current Parser state. (Inherited from Parser.)
Public property | Strings | Gets or sets a list of strings to parse. (Inherited from Parser.)
Public property | SupportsThread | Gets boolean value indicating whether parser supports working in thread. (Inherited from SyntaxParser.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements representing abstract syntax tree of the text being parsed. (Inherited from SyntaxParser.)
Public property | Token | Represents token (number of style in the class style collection) related to the current position in the parsed text. (Inherited from Parser.)
Public property | TokenPosition | Represents start position of the current token. (Inherited from Parser.)
Public property | TokenString | Represents text of the current syntax token. (Inherited from Parser.)
Public property | UpdateCount | Keeps track of calls to BeginUpdate and EndUpdate so that they can be nested. (Inherited from Lexer.)
Public property | UseScheme | Gets or sets a boolean value that indicates whether ISyntaxParser should perform lexical analysis based on it's rules rather than using internal method. (Inherited from SyntaxParser.)
Public property | XmlScheme | Gets or sets an xml representation of Scheme property. (Inherited from SyntaxParser.)
Top
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser.Repository Property

XAMLParserRepository Property
Gets an IRoslynRepository that holds methods for code completion purposes.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public IXAMLRepository Repository { get; }
Public ReadOnly Property Repository As IXAMLRepository
    Get
public:
property IXAMLRepository^ Repository {
    IXAMLRepository^ get ();
}
member Repository : IXAMLRepository with get

Property Value

Type: IXAMLRepository
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLParser Events

XAMLParser Events

The XAMLParser type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Parse | Occurs when text line is parsed, allowing to modify colors/styles information about the parsed line. (Inherited from Lexer.)
Public event | TextReparsed | Occurs when SyntaxParser text content is fully parsed. (Inherited from SyntaxParser.)
Top
See Also

Reference

XAMLParser Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository Class

XAMLRepository Class
Represents properties and methods to perform code completion functionality intended to use for XAML language.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.CodeCompletionCodeCompletionRepository
Alternet.Syntax.Parsers.XAMLXAMLRepository

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XAMLRepository : CodeCompletionRepository,
    IXAMLRepository, ICodeCompletionRepository, IDisposable
Public Class XAMLRepository
    Inherits CodeCompletionRepository
    Implements IXAMLRepository, ICodeCompletionRepository, IDisposable
public ref class XAMLRepository : public CodeCompletionRepository,
    IXAMLRepository, ICodeCompletionRepository, IDisposable
type XAMLRepository =
    class
        inherit CodeCompletionRepository
        interface IXAMLRepository
        interface ICodeCompletionRepository
        interface IDisposable
    end

The XAMLRepository type exposes the following members.

Constructors
 | Name | Description
Public method | XAMLRepository | Initializes a new instance of the XAMLRepository class with specified settings.
Top
Methods
 | Name | Description
Public method | AddTypeInfoFromType | Load type definition from .NET type.
Public method | AddTypeInfoFromTypes | Load type definition from .NET types.
Public method | ClearTypeInfos | Clears type definitions.
Public method | CodeCompletion | Performs code completion for the specified text representing language element.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | LoadNameSpaceTypesFromAssemby |
Public method | LoadTypesFromXml | Loads type definition from XML.
Public method | LoadTypesFromXmlString | Loads type definition from XML.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Gets or sets ImageList attached to this XAMLRepository. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository Constructor

XAMLRepository Constructor
Initializes a new instance of the XAMLRepository class with specified settings.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XAMLRepository(
    ISyntaxParser owner,
    ISyntaxTree syntaxTree
)
Public Sub New (
    owner As ISyntaxParser,
    syntaxTree As ISyntaxTree
)
public:
XAMLRepository(
    ISyntaxParser^ owner,
    ISyntaxTree^ syntaxTree
)
new :
        owner : ISyntaxParser *
        syntaxTree : ISyntaxTree -> XAMLRepository

Parameters

owner
Type: Alternet.SyntaxISyntaxParser
Specifies parser that owns this repository.
syntaxTree
Type: Alternet.SyntaxISyntaxTree
Specifies SyntaxTree property of this new instance.
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository Methods

XAMLRepository Methods

The XAMLRepository type exposes the following members.

Methods
 | Name | Description
Public method | AddTypeInfoFromType | Load type definition from .NET type.
Public method | AddTypeInfoFromTypes | Load type definition from .NET types.
Public method | ClearTypeInfos | Clears type definitions.
Public method | CodeCompletion | Performs code completion for the specified text representing language element.
Public method | Dispose | (Inherited from CodeCompletionRepository.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FillMember(IListMembers, Object, String, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMember(IListMembers, Object, String, Int32, CodeCompletionScope) | Obtains information about individual member of specified language element. (Inherited from CodeCompletionRepository.)
Public method | FillMembers | Fills list members provider with list of its member, providing available choices for the specified language element. (Inherited from CodeCompletionRepository.)
Public method | FindDeclaration | Obtains information about where the language element is declared. (Inherited from CodeCompletionRepository.)
Public method | FindReferences | Locates all references to the node in the text. (Inherited from CodeCompletionRepository.)
Public method | GetCodeSnippets | Returns code snippets for the given language. (Inherited from CodeCompletionRepository.)
Public method | GetDescription | Obtains description of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberType(ISyntaxNode, Point, Object, String, CodeCompletionScope) | Obtains information about a member of some language element. (Inherited from CodeCompletionRepository.)
Public method | GetMemberType(String, ISyntaxNode, String, Point, Point, CodeCompletionScope) | Obtains information about some language element to perform code completion related operations. (Inherited from CodeCompletionRepository.)
Public method | GetMethodType | Obtains information about some method of specified language element. (Inherited from CodeCompletionRepository.)
Public method | GetNodeType | Obtains information type of the SyntaxNode (Inherited from CodeCompletionRepository.)
Public method | GetPriority | Obtains priority of the given language element. Specifies language element (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(Object) | Returns information about the object. (Inherited from CodeCompletionRepository.)
Public method | GetQuickInfo(ISyntaxNode) | Returns information about the node. (Inherited from CodeCompletionRepository.)
Public method | GetSpecialMemberType | Obtains information about some language element to perform code completion related operations in special cases. (Inherited from CodeCompletionRepository.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStructureGuideNode | Indicates whether specified ISyntaxNode is guide node. (Inherited from CodeCompletionRepository.)
Public method | LoadNameSpaceTypesFromAssemby |
Public method | LoadTypesFromXml | Loads type definition from XML.
Public method | LoadTypesFromXmlString | Loads type definition from XML.
Public method | RegisterSnippet | When implemented by a class, registers snippet to be displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public method | RegisterSyntaxTree | Adds specified tree to the list of syntax trees for code-completion related purposes. (Inherited from CodeCompletionRepository.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterSnippet | When implemented by a class, removes specified snippet from the list of snippets. (Inherited from CodeCompletionRepository.)
Public method | UnregisterSyntaxTree | Removes specified tree from the list of syntax trees. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository.AddTypeInfoFromType Method

XAMLRepositoryAddTypeInfoFromType Method
Load type definition from .NET type.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddTypeInfoFromType(
    Type type
)
Public Sub AddTypeInfoFromType (
    type As Type
)
public:
virtual void AddTypeInfoFromType(
    Type^ type
) sealed
abstract AddTypeInfoFromType :
        type : Type -> unit
override AddTypeInfoFromType :
        type : Type -> unit

Parameters

type
Type: SystemType

Implements

IXAMLRepositoryAddTypeInfoFromType(Type)
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository.AddTypeInfoFromTypes Method

XAMLRepositoryAddTypeInfoFromTypes Method
Load type definition from .NET types.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddTypeInfoFromTypes(
    Type[] types
)
Public Sub AddTypeInfoFromTypes (
    types As Type()
)
public:
virtual void AddTypeInfoFromTypes(
    array<Type^>^ types
) sealed
abstract AddTypeInfoFromTypes :
        types : Type[] -> unit
override AddTypeInfoFromTypes :
        types : Type[] -> unit

Parameters

types
Type: SystemType
Collection of .NET types

Implements

IXAMLRepositoryAddTypeInfoFromTypes(Type)
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository.ClearTypeInfos Method

XAMLRepositoryClearTypeInfos Method
Clears type definitions.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearTypeInfos()
Public Sub ClearTypeInfos
public:
virtual void ClearTypeInfos() sealed
abstract ClearTypeInfos : unit -> unit
override ClearTypeInfos : unit -> unit

Implements

IXAMLRepositoryClearTypeInfos
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository.CodeCompletion Method

XAMLRepositoryCodeCompletion Method
Performs code completion for the specified text representing language element.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CodeCompletion(
    Point position,
    CodeCompletionArgs e,
    ISyntaxNode node,
    string text
)
Public Sub CodeCompletion (
    position As Point,
    e As CodeCompletionArgs,
    node As ISyntaxNode,
    text As String
)
public:
virtual void CodeCompletion(
    Point position,
    CodeCompletionArgs^ e,
    ISyntaxNode^ node,
    String^ text
) sealed
abstract CodeCompletion :
        position : Point *
        e : CodeCompletionArgs *
        node : ISyntaxNode *
        text : string -> unit
override CodeCompletion :
        position : Point *
        e : CodeCompletionArgs *
        node : ISyntaxNode *
        text : string -> unit

Parameters

position
Type: System.DrawingPoint
Specifies current position in text.
e
Type: Alternet.SyntaxCodeCompletionArgs
A CodeCompletionArgs that contains data for codecompletion.
node
Type: Alternet.SyntaxISyntaxNode
SyntaxNode for codecompletion.
text
Type: SystemString
Specifies source text.

Implements

IXAMLRepositoryCodeCompletion(Point, CodeCompletionArgs, ISyntaxNode, String)
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository.LoadNameSpaceTypesFromAssemby Method

XAMLRepositoryLoadNameSpaceTypesFromAssemby Method

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LoadNameSpaceTypesFromAssemby(
    string fullName
)
Public Sub LoadNameSpaceTypesFromAssemby (
    fullName As String
)
public:
void LoadNameSpaceTypesFromAssemby(
    String^ fullName
)
member LoadNameSpaceTypesFromAssemby :
        fullName : string -> unit

Parameters

fullName
Type: SystemString
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository.LoadTypesFromXml Method

XAMLRepositoryLoadTypesFromXml Method
Loads type definition from XML.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LoadTypesFromXml(
    string path,
    bool keepExisting = true
)
Public Sub LoadTypesFromXml (
    path As String,
    Optional keepExisting As Boolean = true
)
public:
virtual void LoadTypesFromXml(
    String^ path,
    bool keepExisting = true
) sealed
abstract LoadTypesFromXml :
        path : string *
        ?keepExisting : bool
(* Defaults:
        let _keepExisting = defaultArg keepExisting true
*)
-> unit
override LoadTypesFromXml :
        path : string *
        ?keepExisting : bool
(* Defaults:
        let _keepExisting = defaultArg keepExisting true
*)
-> unit

Parameters

path
Type: SystemString
Path to XML file
keepExisting (Optional)
Type: SystemBoolean
Specifies whether to keep existing type definitions.

Implements

IXAMLRepositoryLoadTypesFromXml(String, Boolean)
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository.LoadTypesFromXmlString Method

XAMLRepositoryLoadTypesFromXmlString Method
Loads type definition from XML.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LoadTypesFromXmlString(
    string xml,
    bool keepExisting = true
)
Public Sub LoadTypesFromXmlString (
    xml As String,
    Optional keepExisting As Boolean = true
)
public:
virtual void LoadTypesFromXmlString(
    String^ xml,
    bool keepExisting = true
) sealed
abstract LoadTypesFromXmlString :
        xml : string *
        ?keepExisting : bool
(* Defaults:
        let _keepExisting = defaultArg keepExisting true
*)
-> unit
override LoadTypesFromXmlString :
        xml : string *
        ?keepExisting : bool
(* Defaults:
        let _keepExisting = defaultArg keepExisting true
*)
-> unit

Parameters

xml
Type: SystemString
XML contains data tip.
keepExisting (Optional)
Type: SystemBoolean
Specifies whether to keep existing type definitions.

Implements

IXAMLRepositoryLoadTypesFromXmlString(String, Boolean)
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository Properties

XAMLRepository Properties

The XAMLRepository type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Indicates whether searching for language element's members should be case sensitive. (Inherited from CodeCompletionRepository.)
Public property | FillBaseMembers | Indicates whether members of Object class should be present in the member collection. (Inherited from CodeCompletionRepository.)
Public property | Images | Gets or sets ImageList attached to this XAMLRepository. (Overrides CodeCompletionRepositoryImages.)
Public property | ImagesHighDpi | Represents collection of images used for code completion for high DPI. (Overrides CodeCompletionRepositoryImagesHighDpi.)
Public property | ImagesResourceNameSuffix | (Inherited from CodeCompletionRepository.)
Public property | Snippets | Represents a collection of snippets that are displayed in code completion window. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTree | Gets or sets a hierarchical collection of ISyntaxNode elements. (Inherited from CodeCompletionRepository.)
Public property | SyntaxTrees | Gets or sets list of ISyntaxTree objects attached to this CodeCompletionRepository. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository.Images Property

XAMLRepositoryImages Property
Gets or sets ImageList attached to this XAMLRepository.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList Images { get; }
Public Overrides ReadOnly Property Images As ImageList
    Get
public:
virtual property ImageList^ Images {
    ImageList^ get () override;
}
abstract Images : ImageList with get
override Images : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImages
ICodeCompletionRepositoryImages
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository.ImagesHighDpi Property

XAMLRepositoryImagesHighDpi Property
Represents collection of images used for code completion for high DPI.

Namespace: Alternet.Syntax.Parsers.XAML
Assembly: Alternet.Syntax.Parsers.XAML.v7 (in Alternet.Syntax.Parsers.XAML.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ImageList ImagesHighDpi { get; }
Public Overrides ReadOnly Property ImagesHighDpi As ImageList
    Get
public:
virtual property ImageList^ ImagesHighDpi {
    ImageList^ get () override;
}
abstract ImagesHighDpi : ImageList with get
override ImagesHighDpi : ImageList with get

Property Value

Type: ImageList

Implements

ICodeCompletionRepositoryImagesHighDpi
ICodeCompletionRepositoryImagesHighDpi
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


XAMLRepository Events

XAMLRepository Events

The XAMLRepository type exposes the following members.

Events
 | Name | Description
Public event | DescriptionLookup | Occurs while trying to obtain description of some language element. (Inherited from CodeCompletionRepository.)
Public event | MemberLookup | Occurs while trying to obtain information about some member of language element. (Inherited from CodeCompletionRepository.)
Top
See Also

Reference

XAMLRepository Class
Alternet.Syntax.Parsers.XAML Namespace


Alternet.Syntax.Serialization Namespace

Alternet.Syntax.Serialization Namespace
Classes
 | Class | Description
Public class | XmlCodeSnippetCodeInfo | Contains information about ICodeSnippetCode object's settings.
Public class | XmlCodeSnippetDeclarationInfo | Contains information about ICodeSnippetDeclaration object's settings.
Public class | XmlCodeSnippetHeaderInfo | Contains information about ICodeSnippetHeader object's settings.
Public class | XmlCodeSnippetImportInfo | Contains information about ICodeSnippetImport object's settings.
Public class | XmlCodeSnippetInfo | Contains information about ICodeSnippet object's settings.
Public class | XmlCodeSnippetLiteralInfo | Contains information about ICodeSnippetLiteral object's settings.
Public class | XmlCodeSnippetMemberInfo | Contains information about ICodeSnippetMember object's settings.
Public class | XmlCodeSnippetMembersInfo | Contains information about ICodeSnippetMembers object's settings.
Public class | XmlCodeSnippetObjectInfo | Contains information about ICodeSnippetObject object's settings.
Public class | XmlCodeSnippetReferenceInfo | Contains information about ICodeSnippetReference object's settings.
Public class | XmlCodeSnippetsInfo | Contains information about ICodeSnippets object's settings.
Public class | XmlCodeSnippetTypeInfo | Contains information about ICodeSnippetType object's settings.
Public class | XmlColorInfo | Represents methods to serialize color structure to XML.
Public class | XmlLexerInfo | Contains information about ILexer object's settings.
Public class | XmlLexReswordSetInfo | Contains information about ILexReswordSet object's settings.
Public class | XmlLexSchemeInfo | Contains information about ILexScheme object's settings.
Public class | XmlLexStateInfo | Contains information about ILexState object's settings.
Public class | XmlLexStyleInfo | Contains information about ILexStyle object's settings.
Public class | XmlLexSyntaxBlockInfo | Contains information about ILexSyntaxBlock object's settings.


XmlCodeSnippetCodeInfo Class

XmlCodeSnippetCodeInfo Class
Contains information about ICodeSnippetCode object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetCodeInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetCodeInfo : ISerializationInfo
Public Class XmlCodeSnippetCodeInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetCodeInfo : ISerializationInfo
type XmlCodeSnippetCodeInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetCodeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetCodeInfo | Initializes a new instance of the XmlCodeSnippetCodeInfo class with default settings.
Public method | XmlCodeSnippetCodeInfo(ICodeSnippetCode) | Initializes a new instance of the XmlCodeSnippetCodeInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Code | Stores ICodeSnippetCode.Code property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetCodeInfo Constructor

XmlCodeSnippetCodeInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetCodeInfo | Initializes a new instance of the XmlCodeSnippetCodeInfo class with default settings.
Public method | XmlCodeSnippetCodeInfo(ICodeSnippetCode) | Initializes a new instance of the XmlCodeSnippetCodeInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetCodeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetCodeInfo Constructor

XmlCodeSnippetCodeInfo Constructor
Initializes a new instance of the XmlCodeSnippetCodeInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetCodeInfo()
Public Sub New
public:
XmlCodeSnippetCodeInfo()
new : unit -> XmlCodeSnippetCodeInfo
See Also

Reference

XmlCodeSnippetCodeInfo Class
XmlCodeSnippetCodeInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetCodeInfo Constructor (ICodeSnippetCode)

XmlCodeSnippetCodeInfo Constructor (ICodeSnippetCode)
Initializes a new instance of the XmlCodeSnippetCodeInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetCodeInfo(
    ICodeSnippetCode owner
)
Public Sub New (
    owner As ICodeSnippetCode
)
public:
XmlCodeSnippetCodeInfo(
    ICodeSnippetCode^ owner
)
new :
        owner : ICodeSnippetCode -> XmlCodeSnippetCodeInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetCode
Specifies ICodeSnippetCode object to store settings.
See Also

Reference

XmlCodeSnippetCodeInfo Class
XmlCodeSnippetCodeInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetCodeInfo Methods

XmlCodeSnippetCodeInfo Methods

The XmlCodeSnippetCodeInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetCodeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetCodeInfo.FixupReferences Method

XmlCodeSnippetCodeInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetCodeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetCodeInfo.Load Method

XmlCodeSnippetCodeInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetCodeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetCodeInfo Properties

XmlCodeSnippetCodeInfo Properties

The XmlCodeSnippetCodeInfo type exposes the following members.

Properties
 | Name | Description
Public property | Code | Stores ICodeSnippetCode.Code property.
Top
See Also

Reference

XmlCodeSnippetCodeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetCodeInfo.Code Property

XmlCodeSnippetCodeInfoCode Property
Stores ICodeSnippetCode.Code property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetCodeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo Class

XmlCodeSnippetDeclarationInfo Class
Contains information about ICodeSnippetDeclaration object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetDeclarationInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetDeclarationInfo : ISerializationInfo
Public Class XmlCodeSnippetDeclarationInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetDeclarationInfo : ISerializationInfo
type XmlCodeSnippetDeclarationInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetDeclarationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetDeclarationInfo | Initializes a new instance of the XmlCodeSnippetDeclarationInfo class with default settings.
Public method | XmlCodeSnippetDeclarationInfo(ICodeSnippetDeclaration) | Initializes a new instance of the XmlCodeSnippetDeclarationInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Literals | Stores ICodeSnippetLiteral.Literals property.
Public property | Objects | Stores ICodeSnippetLiteral.Literals property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo Constructor

XmlCodeSnippetDeclarationInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetDeclarationInfo | Initializes a new instance of the XmlCodeSnippetDeclarationInfo class with default settings.
Public method | XmlCodeSnippetDeclarationInfo(ICodeSnippetDeclaration) | Initializes a new instance of the XmlCodeSnippetDeclarationInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetDeclarationInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo Constructor

XmlCodeSnippetDeclarationInfo Constructor
Initializes a new instance of the XmlCodeSnippetDeclarationInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetDeclarationInfo()
Public Sub New
public:
XmlCodeSnippetDeclarationInfo()
new : unit -> XmlCodeSnippetDeclarationInfo
See Also

Reference

XmlCodeSnippetDeclarationInfo Class
XmlCodeSnippetDeclarationInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo Constructor (ICodeSnippetDeclaration)

XmlCodeSnippetDeclarationInfo Constructor (ICodeSnippetDeclaration)
Initializes a new instance of the XmlCodeSnippetDeclarationInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetDeclarationInfo(
    ICodeSnippetDeclaration owner
)
Public Sub New (
    owner As ICodeSnippetDeclaration
)
public:
XmlCodeSnippetDeclarationInfo(
    ICodeSnippetDeclaration^ owner
)
new :
        owner : ICodeSnippetDeclaration -> XmlCodeSnippetDeclarationInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetDeclaration
Specifies ICodeSnippetDeclaration object to store settings.
See Also

Reference

XmlCodeSnippetDeclarationInfo Class
XmlCodeSnippetDeclarationInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo Methods

XmlCodeSnippetDeclarationInfo Methods

The XmlCodeSnippetDeclarationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetDeclarationInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo.FixupReferences Method

XmlCodeSnippetDeclarationInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetDeclarationInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo.Load Method

XmlCodeSnippetDeclarationInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetDeclarationInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo Properties

XmlCodeSnippetDeclarationInfo Properties

The XmlCodeSnippetDeclarationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Literals | Stores ICodeSnippetLiteral.Literals property.
Public property | Objects | Stores ICodeSnippetLiteral.Literals property.
Top
See Also

Reference

XmlCodeSnippetDeclarationInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo.Literals Property

XmlCodeSnippetDeclarationInfoLiterals Property
Stores ICodeSnippetLiteral.Literals property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetLiteralInfo[] Literals { get; set; }
Public Property Literals As XmlCodeSnippetLiteralInfo()
    Get
    Set
public:
property array<XmlCodeSnippetLiteralInfo^>^ Literals {
    array<XmlCodeSnippetLiteralInfo^>^ get ();
    void set (array<XmlCodeSnippetLiteralInfo^>^ value);
}
member Literals : XmlCodeSnippetLiteralInfo[] with get, set

Property Value

Type: XmlCodeSnippetLiteralInfo
See Also

Reference

XmlCodeSnippetDeclarationInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetDeclarationInfo.Objects Property

XmlCodeSnippetDeclarationInfoObjects Property
Stores ICodeSnippetLiteral.Literals property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetObjectInfo[] Objects { get; set; }
Public Property Objects As XmlCodeSnippetObjectInfo()
    Get
    Set
public:
property array<XmlCodeSnippetObjectInfo^>^ Objects {
    array<XmlCodeSnippetObjectInfo^>^ get ();
    void set (array<XmlCodeSnippetObjectInfo^>^ value);
}
member Objects : XmlCodeSnippetObjectInfo[] with get, set

Property Value

Type: XmlCodeSnippetObjectInfo
See Also

Reference

XmlCodeSnippetDeclarationInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo Class

XmlCodeSnippetHeaderInfo Class
Contains information about ICodeSnippetHeader object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetHeaderInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetHeaderInfo : ISerializationInfo
Public Class XmlCodeSnippetHeaderInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetHeaderInfo : ISerializationInfo
type XmlCodeSnippetHeaderInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetHeaderInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetHeaderInfo | Initializes a new instance of the XmlCodeSnippetHeaderInfo class with default settings.
Public method | XmlCodeSnippetHeaderInfo(ICodeSnippetHeader) | Initializes a new instance of the XmlCodeSnippetHeaderInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeSnippetTypes | Indicates whether the SnippetTypes property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Author | Stores ICodeSnippetHeader.Author property.
Public property | Description | Stores ICodeSnippetHeader.Description property.
Public property | Shortcut | Stores ICodeSnippetHeader.Shortcut property.
Public property | SnippetTypes | Stores ICodeSnippetHeader.SnippetTypes property.
Public property | Title | Stores ICodeSnippetHeader.Title property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo Constructor

XmlCodeSnippetHeaderInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetHeaderInfo | Initializes a new instance of the XmlCodeSnippetHeaderInfo class with default settings.
Public method | XmlCodeSnippetHeaderInfo(ICodeSnippetHeader) | Initializes a new instance of the XmlCodeSnippetHeaderInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo Constructor

XmlCodeSnippetHeaderInfo Constructor
Initializes a new instance of the XmlCodeSnippetHeaderInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetHeaderInfo()
Public Sub New
public:
XmlCodeSnippetHeaderInfo()
new : unit -> XmlCodeSnippetHeaderInfo
See Also

Reference

XmlCodeSnippetHeaderInfo Class
XmlCodeSnippetHeaderInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo Constructor (ICodeSnippetHeader)

XmlCodeSnippetHeaderInfo Constructor (ICodeSnippetHeader)
Initializes a new instance of the XmlCodeSnippetHeaderInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetHeaderInfo(
    ICodeSnippetHeader owner
)
Public Sub New (
    owner As ICodeSnippetHeader
)
public:
XmlCodeSnippetHeaderInfo(
    ICodeSnippetHeader^ owner
)
new :
        owner : ICodeSnippetHeader -> XmlCodeSnippetHeaderInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetHeader
Specifies ICodeSnippetHeader object to store settings.
See Also

Reference

XmlCodeSnippetHeaderInfo Class
XmlCodeSnippetHeaderInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo Methods

XmlCodeSnippetHeaderInfo Methods

The XmlCodeSnippetHeaderInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeSnippetTypes | Indicates whether the SnippetTypes property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo.FixupReferences Method

XmlCodeSnippetHeaderInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo.Load Method

XmlCodeSnippetHeaderInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo.ShouldSerializeSnippetTypes Method

XmlCodeSnippetHeaderInfoShouldSerializeSnippetTypes Method
Indicates whether the SnippetTypes property should be persisted.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeSnippetTypes()
Public Function ShouldSerializeSnippetTypes As Boolean
public:
bool ShouldSerializeSnippetTypes()
member ShouldSerializeSnippetTypes : unit -> bool

Return Value

Type: Boolean
True if SnippetTypes differs from its default value; otherwise false.
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo Properties

XmlCodeSnippetHeaderInfo Properties

The XmlCodeSnippetHeaderInfo type exposes the following members.

Properties
 | Name | Description
Public property | Author | Stores ICodeSnippetHeader.Author property.
Public property | Description | Stores ICodeSnippetHeader.Description property.
Public property | Shortcut | Stores ICodeSnippetHeader.Shortcut property.
Public property | SnippetTypes | Stores ICodeSnippetHeader.SnippetTypes property.
Public property | Title | Stores ICodeSnippetHeader.Title property.
Top
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo.Author Property

XmlCodeSnippetHeaderInfoAuthor Property
Stores ICodeSnippetHeader.Author property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}
member Author : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo.Description Property

XmlCodeSnippetHeaderInfoDescription Property
Stores ICodeSnippetHeader.Description property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo.Shortcut Property

XmlCodeSnippetHeaderInfoShortcut Property
Stores ICodeSnippetHeader.Shortcut property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Shortcut { get; set; }
Public Property Shortcut As String
    Get
    Set
public:
property String^ Shortcut {
    String^ get ();
    void set (String^ value);
}
member Shortcut : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo.SnippetTypes Property

XmlCodeSnippetHeaderInfoSnippetTypes Property
Stores ICodeSnippetHeader.SnippetTypes property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetTypeInfo[] SnippetTypes { get; set; }
Public Property SnippetTypes As XmlCodeSnippetTypeInfo()
    Get
    Set
public:
property array<XmlCodeSnippetTypeInfo^>^ SnippetTypes {
    array<XmlCodeSnippetTypeInfo^>^ get ();
    void set (array<XmlCodeSnippetTypeInfo^>^ value);
}
member SnippetTypes : XmlCodeSnippetTypeInfo[] with get, set

Property Value

Type: XmlCodeSnippetTypeInfo
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetHeaderInfo.Title Property

XmlCodeSnippetHeaderInfoTitle Property
Stores ICodeSnippetHeader.Title property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetHeaderInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetImportInfo Class

XmlCodeSnippetImportInfo Class
Contains information about ICodeSnippetImport object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetImportInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetImportInfo : ISerializationInfo
Public Class XmlCodeSnippetImportInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetImportInfo : ISerializationInfo
type XmlCodeSnippetImportInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetImportInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetImportInfo | Initializes a new instance of the XmlCodeSnippetImportInfo class with default settings.
Public method | XmlCodeSnippetImportInfo(ICodeSnippetImport) | Initializes a new instance of the XmlCodeSnippetImportInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Namespace | Stores ICodeSnippetImport.Namespace property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetImportInfo Constructor

XmlCodeSnippetImportInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetImportInfo | Initializes a new instance of the XmlCodeSnippetImportInfo class with default settings.
Public method | XmlCodeSnippetImportInfo(ICodeSnippetImport) | Initializes a new instance of the XmlCodeSnippetImportInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetImportInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetImportInfo Constructor

XmlCodeSnippetImportInfo Constructor
Initializes a new instance of the XmlCodeSnippetImportInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetImportInfo()
Public Sub New
public:
XmlCodeSnippetImportInfo()
new : unit -> XmlCodeSnippetImportInfo
See Also

Reference

XmlCodeSnippetImportInfo Class
XmlCodeSnippetImportInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetImportInfo Constructor (ICodeSnippetImport)

XmlCodeSnippetImportInfo Constructor (ICodeSnippetImport)
Initializes a new instance of the XmlCodeSnippetImportInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetImportInfo(
    ICodeSnippetImport owner
)
Public Sub New (
    owner As ICodeSnippetImport
)
public:
XmlCodeSnippetImportInfo(
    ICodeSnippetImport^ owner
)
new :
        owner : ICodeSnippetImport -> XmlCodeSnippetImportInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetImport
Specifies ICodeSnippetImport object to store settings.
See Also

Reference

XmlCodeSnippetImportInfo Class
XmlCodeSnippetImportInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetImportInfo Methods

XmlCodeSnippetImportInfo Methods

The XmlCodeSnippetImportInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetImportInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetImportInfo.FixupReferences Method

XmlCodeSnippetImportInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetImportInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetImportInfo.Load Method

XmlCodeSnippetImportInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetImportInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetImportInfo Properties

XmlCodeSnippetImportInfo Properties

The XmlCodeSnippetImportInfo type exposes the following members.

Properties
 | Name | Description
Public property | Namespace | Stores ICodeSnippetImport.Namespace property.
Top
See Also

Reference

XmlCodeSnippetImportInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetImportInfo.Namespace Property

XmlCodeSnippetImportInfoNamespace Property
Stores ICodeSnippetImport.Namespace property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Namespace { get; set; }
Public Property Namespace As String
    Get
    Set
public:
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}
member Namespace : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetImportInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo Class

XmlCodeSnippetInfo Class
Contains information about ICodeSnippet object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetInfo : ISerializationInfo
Public Class XmlCodeSnippetInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetInfo : ISerializationInfo
type XmlCodeSnippetInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetInfo | Initializes a new instance of the XmlCodeSnippetInfo class with default settings.
Public method | XmlCodeSnippetInfo(ICodeSnippet) | Initializes a new instance of the XmlCodeSnippetInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Code | Stores ICodeSnippet.Code property.
Public property | Declarations | Stores ICodeSnippet.Declarations property.
Public property | Header | Stores ICodeSnippet.Header property.
Public property | ImageIndex | Stores ICodeSnippet.ImageIndex property.
Public property | Imports | Stores ICodeSnippet.Imports property.
Public property | References | Stores ICodeSnippet.Imports property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo Constructor

XmlCodeSnippetInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetInfo | Initializes a new instance of the XmlCodeSnippetInfo class with default settings.
Public method | XmlCodeSnippetInfo(ICodeSnippet) | Initializes a new instance of the XmlCodeSnippetInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo Constructor

XmlCodeSnippetInfo Constructor
Initializes a new instance of the XmlCodeSnippetInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetInfo()
Public Sub New
public:
XmlCodeSnippetInfo()
new : unit -> XmlCodeSnippetInfo
See Also

Reference

XmlCodeSnippetInfo Class
XmlCodeSnippetInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo Constructor (ICodeSnippet)

XmlCodeSnippetInfo Constructor (ICodeSnippet)
Initializes a new instance of the XmlCodeSnippetInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetInfo(
    ICodeSnippet owner
)
Public Sub New (
    owner As ICodeSnippet
)
public:
XmlCodeSnippetInfo(
    ICodeSnippet^ owner
)
new :
        owner : ICodeSnippet -> XmlCodeSnippetInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippet
Specifies ICodeSnippet object to store settings.
See Also

Reference

XmlCodeSnippetInfo Class
XmlCodeSnippetInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo Methods

XmlCodeSnippetInfo Methods

The XmlCodeSnippetInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo.FixupReferences Method

XmlCodeSnippetInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo.Load Method

XmlCodeSnippetInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo Properties

XmlCodeSnippetInfo Properties

The XmlCodeSnippetInfo type exposes the following members.

Properties
 | Name | Description
Public property | Code | Stores ICodeSnippet.Code property.
Public property | Declarations | Stores ICodeSnippet.Declarations property.
Public property | Header | Stores ICodeSnippet.Header property.
Public property | ImageIndex | Stores ICodeSnippet.ImageIndex property.
Public property | Imports | Stores ICodeSnippet.Imports property.
Public property | References | Stores ICodeSnippet.Imports property.
Top
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo.Code Property

XmlCodeSnippetInfoCode Property
Stores ICodeSnippet.Code property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetCodeInfo Code { get; set; }
Public Property Code As XmlCodeSnippetCodeInfo
    Get
    Set
public:
property XmlCodeSnippetCodeInfo^ Code {
    XmlCodeSnippetCodeInfo^ get ();
    void set (XmlCodeSnippetCodeInfo^ value);
}
member Code : XmlCodeSnippetCodeInfo with get, set

Property Value

Type: XmlCodeSnippetCodeInfo
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo.Declarations Property

XmlCodeSnippetInfoDeclarations Property
Stores ICodeSnippet.Declarations property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetDeclarationInfo[] Declarations { get; set; }
Public Property Declarations As XmlCodeSnippetDeclarationInfo()
    Get
    Set
public:
property array<XmlCodeSnippetDeclarationInfo^>^ Declarations {
    array<XmlCodeSnippetDeclarationInfo^>^ get ();
    void set (array<XmlCodeSnippetDeclarationInfo^>^ value);
}
member Declarations : XmlCodeSnippetDeclarationInfo[] with get, set

Property Value

Type: XmlCodeSnippetDeclarationInfo
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo.Header Property

XmlCodeSnippetInfoHeader Property
Stores ICodeSnippet.Header property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetHeaderInfo Header { get; set; }
Public Property Header As XmlCodeSnippetHeaderInfo
    Get
    Set
public:
property XmlCodeSnippetHeaderInfo^ Header {
    XmlCodeSnippetHeaderInfo^ get ();
    void set (XmlCodeSnippetHeaderInfo^ value);
}
member Header : XmlCodeSnippetHeaderInfo with get, set

Property Value

Type: XmlCodeSnippetHeaderInfo
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo.ImageIndex Property

XmlCodeSnippetInfoImageIndex Property
Stores ICodeSnippet.ImageIndex property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ImageIndex { get; set; }
Public Property ImageIndex As Integer
    Get
    Set
public:
property int ImageIndex {
    int get ();
    void set (int value);
}
member ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo.Imports Property

XmlCodeSnippetInfoImports Property
Stores ICodeSnippet.Imports property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetImportInfo[] Imports { get; set; }
Public Property Imports As XmlCodeSnippetImportInfo()
    Get
    Set
public:
property array<XmlCodeSnippetImportInfo^>^ Imports {
    array<XmlCodeSnippetImportInfo^>^ get ();
    void set (array<XmlCodeSnippetImportInfo^>^ value);
}
member Imports : XmlCodeSnippetImportInfo[] with get, set

Property Value

Type: XmlCodeSnippetImportInfo
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetInfo.References Property

XmlCodeSnippetInfoReferences Property
Stores ICodeSnippet.Imports property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetReferenceInfo[] References { get; set; }
Public Property References As XmlCodeSnippetReferenceInfo()
    Get
    Set
public:
property array<XmlCodeSnippetReferenceInfo^>^ References {
    array<XmlCodeSnippetReferenceInfo^>^ get ();
    void set (array<XmlCodeSnippetReferenceInfo^>^ value);
}
member References : XmlCodeSnippetReferenceInfo[] with get, set

Property Value

Type: XmlCodeSnippetReferenceInfo
See Also

Reference

XmlCodeSnippetInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo Class

XmlCodeSnippetLiteralInfo Class
Contains information about ICodeSnippetLiteral object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetLiteralInfo
Alternet.Syntax.SerializationXmlCodeSnippetObjectInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetLiteralInfo : ISerializationInfo
Public Class XmlCodeSnippetLiteralInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetLiteralInfo : ISerializationInfo
type XmlCodeSnippetLiteralInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetLiteralInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetLiteralInfo | Initializes a new instance of the XmlCodeSnippetLiteralInfo class with default settings.
Public method | XmlCodeSnippetLiteralInfo(ICodeSnippetLiteral) | Initializes a new instance of the XmlCodeSnippetLiteralInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Default | Stores ICodeSnippetLiteral.Default property.
Public property | Editable | Stores ICodeSnippetLiteral.Editable property.
Public property | Function | Stores ICodeSnippetLiteral.Function property.
Public property | ID | Stores ICodeSnippetLiteral.ID property.
Public property | SupportsCode | Stores ICodeSnippetLiteral.SupportsCode property.
Public property | ToolTip | Stores ICodeSnippetLiteral.ToolTip property.
Public property | Type | Stores ICodeSnippetLiteral.Type property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo Constructor

XmlCodeSnippetLiteralInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetLiteralInfo | Initializes a new instance of the XmlCodeSnippetLiteralInfo class with default settings.
Public method | XmlCodeSnippetLiteralInfo(ICodeSnippetLiteral) | Initializes a new instance of the XmlCodeSnippetLiteralInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo Constructor

XmlCodeSnippetLiteralInfo Constructor
Initializes a new instance of the XmlCodeSnippetLiteralInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetLiteralInfo()
Public Sub New
public:
XmlCodeSnippetLiteralInfo()
new : unit -> XmlCodeSnippetLiteralInfo
See Also

Reference

XmlCodeSnippetLiteralInfo Class
XmlCodeSnippetLiteralInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo Constructor (ICodeSnippetLiteral)

XmlCodeSnippetLiteralInfo Constructor (ICodeSnippetLiteral)
Initializes a new instance of the XmlCodeSnippetLiteralInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetLiteralInfo(
    ICodeSnippetLiteral owner
)
Public Sub New (
    owner As ICodeSnippetLiteral
)
public:
XmlCodeSnippetLiteralInfo(
    ICodeSnippetLiteral^ owner
)
new :
        owner : ICodeSnippetLiteral -> XmlCodeSnippetLiteralInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetLiteral
Specifies ICodeSnippetLiteral object to store settings.
See Also

Reference

XmlCodeSnippetLiteralInfo Class
XmlCodeSnippetLiteralInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo Methods

XmlCodeSnippetLiteralInfo Methods

The XmlCodeSnippetLiteralInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo.FixupReferences Method

XmlCodeSnippetLiteralInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo.Load Method

XmlCodeSnippetLiteralInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo Properties

XmlCodeSnippetLiteralInfo Properties

The XmlCodeSnippetLiteralInfo type exposes the following members.

Properties
 | Name | Description
Public property | Default | Stores ICodeSnippetLiteral.Default property.
Public property | Editable | Stores ICodeSnippetLiteral.Editable property.
Public property | Function | Stores ICodeSnippetLiteral.Function property.
Public property | ID | Stores ICodeSnippetLiteral.ID property.
Public property | SupportsCode | Stores ICodeSnippetLiteral.SupportsCode property.
Public property | ToolTip | Stores ICodeSnippetLiteral.ToolTip property.
Public property | Type | Stores ICodeSnippetLiteral.Type property.
Top
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo.Default Property

XmlCodeSnippetLiteralInfoDefault Property
Stores ICodeSnippetLiteral.Default property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Default { get; set; }
Public Property Default As String
    Get
    Set
public:
property String^ Default {
    String^ get ();
    void set (String^ value);
}
member Default : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo.Editable Property

XmlCodeSnippetLiteralInfoEditable Property
Stores ICodeSnippetLiteral.Editable property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
property bool Editable {
    bool get ();
    void set (bool value);
}
member Editable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo.Function Property

XmlCodeSnippetLiteralInfoFunction Property
Stores ICodeSnippetLiteral.Function property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Function { get; set; }
Public Property Function As String
    Get
    Set
public:
property String^ Function {
    String^ get ();
    void set (String^ value);
}
member Function : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo.ID Property

XmlCodeSnippetLiteralInfoID Property
Stores ICodeSnippetLiteral.ID property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo.SupportsCode Property

XmlCodeSnippetLiteralInfoSupportsCode Property
Stores ICodeSnippetLiteral.SupportsCode property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsCode { get; set; }
Public Property SupportsCode As Boolean
    Get
    Set
public:
property bool SupportsCode {
    bool get ();
    void set (bool value);
}
member SupportsCode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo.ToolTip Property

XmlCodeSnippetLiteralInfoToolTip Property
Stores ICodeSnippetLiteral.ToolTip property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
member ToolTip : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetLiteralInfo.Type Property

XmlCodeSnippetLiteralInfoType Property
Stores ICodeSnippetLiteral.Type property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetLiteralInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo Class

XmlCodeSnippetMemberInfo Class
Contains information about ICodeSnippetMember object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetMemberInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetMemberInfo : ISerializationInfo
Public Class XmlCodeSnippetMemberInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetMemberInfo : ISerializationInfo
type XmlCodeSnippetMemberInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetMemberInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetMemberInfo | Initializes a new instance of the XmlCodeSnippetMemberInfo class with default settings.
Public method | XmlCodeSnippetMemberInfo(ICodeSnippetMember) | Initializes a new instance of the XmlCodeSnippetMemberInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ImageIndex | Stores ICodeSnippetMember.ImageIndex property.
Public property | Members | Stores ICodeSnippetMember.Members property.
Public property | Name | Stores ICodeSnippetMember.Name property.
Public property | Path | Stores ICodeSnippetMember.Path property.
Public property | Snippets | Stores ICodeSnippetMember.Snippets property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo Constructor

XmlCodeSnippetMemberInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetMemberInfo | Initializes a new instance of the XmlCodeSnippetMemberInfo class with default settings.
Public method | XmlCodeSnippetMemberInfo(ICodeSnippetMember) | Initializes a new instance of the XmlCodeSnippetMemberInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo Constructor

XmlCodeSnippetMemberInfo Constructor
Initializes a new instance of the XmlCodeSnippetMemberInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetMemberInfo()
Public Sub New
public:
XmlCodeSnippetMemberInfo()
new : unit -> XmlCodeSnippetMemberInfo
See Also

Reference

XmlCodeSnippetMemberInfo Class
XmlCodeSnippetMemberInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo Constructor (ICodeSnippetMember)

XmlCodeSnippetMemberInfo Constructor (ICodeSnippetMember)
Initializes a new instance of the XmlCodeSnippetMemberInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetMemberInfo(
    ICodeSnippetMember owner
)
Public Sub New (
    owner As ICodeSnippetMember
)
public:
XmlCodeSnippetMemberInfo(
    ICodeSnippetMember^ owner
)
new :
        owner : ICodeSnippetMember -> XmlCodeSnippetMemberInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetMember
Specifies ICodeSnippetMember object to store settings.
See Also

Reference

XmlCodeSnippetMemberInfo Class
XmlCodeSnippetMemberInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo Methods

XmlCodeSnippetMemberInfo Methods

The XmlCodeSnippetMemberInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo.FixupReferences Method

XmlCodeSnippetMemberInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo.Load Method

XmlCodeSnippetMemberInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo Properties

XmlCodeSnippetMemberInfo Properties

The XmlCodeSnippetMemberInfo type exposes the following members.

Properties
 | Name | Description
Public property | ImageIndex | Stores ICodeSnippetMember.ImageIndex property.
Public property | Members | Stores ICodeSnippetMember.Members property.
Public property | Name | Stores ICodeSnippetMember.Name property.
Public property | Path | Stores ICodeSnippetMember.Path property.
Public property | Snippets | Stores ICodeSnippetMember.Snippets property.
Top
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo.ImageIndex Property

XmlCodeSnippetMemberInfoImageIndex Property
Stores ICodeSnippetMember.ImageIndex property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ImageIndex { get; set; }
Public Property ImageIndex As Integer
    Get
    Set
public:
property int ImageIndex {
    int get ();
    void set (int value);
}
member ImageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo.Members Property

XmlCodeSnippetMemberInfoMembers Property
Stores ICodeSnippetMember.Members property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetMemberInfo[] Members { get; set; }
Public Property Members As XmlCodeSnippetMemberInfo()
    Get
    Set
public:
property array<XmlCodeSnippetMemberInfo^>^ Members {
    array<XmlCodeSnippetMemberInfo^>^ get ();
    void set (array<XmlCodeSnippetMemberInfo^>^ value);
}
member Members : XmlCodeSnippetMemberInfo[] with get, set

Property Value

Type: XmlCodeSnippetMemberInfo
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo.Name Property

XmlCodeSnippetMemberInfoName Property
Stores ICodeSnippetMember.Name property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo.Path Property

XmlCodeSnippetMemberInfoPath Property
Stores ICodeSnippetMember.Path property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMemberInfo.Snippets Property

XmlCodeSnippetMemberInfoSnippets Property
Stores ICodeSnippetMember.Snippets property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetInfo[] Snippets { get; set; }
Public Property Snippets As XmlCodeSnippetInfo()
    Get
    Set
public:
property array<XmlCodeSnippetInfo^>^ Snippets {
    array<XmlCodeSnippetInfo^>^ get ();
    void set (array<XmlCodeSnippetInfo^>^ value);
}
member Snippets : XmlCodeSnippetInfo[] with get, set

Property Value

Type: XmlCodeSnippetInfo
See Also

Reference

XmlCodeSnippetMemberInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMembersInfo Class

XmlCodeSnippetMembersInfo Class
Contains information about ICodeSnippetMembers object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetMembersInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetMembersInfo : ISerializationInfo
Public Class XmlCodeSnippetMembersInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetMembersInfo : ISerializationInfo
type XmlCodeSnippetMembersInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetMembersInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetMembersInfo | Initializes a new instance of the XmlCodeSnippetMembersInfo class with default settings.
Public method | XmlCodeSnippetMembersInfo(ICodeSnippetMembers) | Initializes a new instance of the XmlCodeSnippetMembersInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Members | Stores ICodeSnippetMembers.Members property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMembersInfo Constructor

XmlCodeSnippetMembersInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetMembersInfo | Initializes a new instance of the XmlCodeSnippetMembersInfo class with default settings.
Public method | XmlCodeSnippetMembersInfo(ICodeSnippetMembers) | Initializes a new instance of the XmlCodeSnippetMembersInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetMembersInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMembersInfo Constructor

XmlCodeSnippetMembersInfo Constructor
Initializes a new instance of the XmlCodeSnippetMembersInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetMembersInfo()
Public Sub New
public:
XmlCodeSnippetMembersInfo()
new : unit -> XmlCodeSnippetMembersInfo
See Also

Reference

XmlCodeSnippetMembersInfo Class
XmlCodeSnippetMembersInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMembersInfo Constructor (ICodeSnippetMembers)

XmlCodeSnippetMembersInfo Constructor (ICodeSnippetMembers)
Initializes a new instance of the XmlCodeSnippetMembersInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetMembersInfo(
    ICodeSnippetMembers owner
)
Public Sub New (
    owner As ICodeSnippetMembers
)
public:
XmlCodeSnippetMembersInfo(
    ICodeSnippetMembers^ owner
)
new :
        owner : ICodeSnippetMembers -> XmlCodeSnippetMembersInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetMembers
Specifies ICodeSnippetMembers object to store settings.
See Also

Reference

XmlCodeSnippetMembersInfo Class
XmlCodeSnippetMembersInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMembersInfo Methods

XmlCodeSnippetMembersInfo Methods

The XmlCodeSnippetMembersInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetMembersInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMembersInfo.FixupReferences Method

XmlCodeSnippetMembersInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetMembersInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMembersInfo.Load Method

XmlCodeSnippetMembersInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetMembersInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMembersInfo Properties

XmlCodeSnippetMembersInfo Properties

The XmlCodeSnippetMembersInfo type exposes the following members.

Properties
 | Name | Description
Public property | Members | Stores ICodeSnippetMembers.Members property.
Top
See Also

Reference

XmlCodeSnippetMembersInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetMembersInfo.Members Property

XmlCodeSnippetMembersInfoMembers Property
Stores ICodeSnippetMembers.Members property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetMemberInfo[] Members { get; set; }
Public Property Members As XmlCodeSnippetMemberInfo()
    Get
    Set
public:
property array<XmlCodeSnippetMemberInfo^>^ Members {
    array<XmlCodeSnippetMemberInfo^>^ get ();
    void set (array<XmlCodeSnippetMemberInfo^>^ value);
}
member Members : XmlCodeSnippetMemberInfo[] with get, set

Property Value

Type: XmlCodeSnippetMemberInfo
See Also

Reference

XmlCodeSnippetMembersInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetObjectInfo Class

XmlCodeSnippetObjectInfo Class
Contains information about ICodeSnippetObject object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetLiteralInfo
Alternet.Syntax.SerializationXmlCodeSnippetObjectInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetObjectInfo : XmlCodeSnippetLiteralInfo
Public Class XmlCodeSnippetObjectInfo
    Inherits XmlCodeSnippetLiteralInfo
public ref class XmlCodeSnippetObjectInfo : public XmlCodeSnippetLiteralInfo
type XmlCodeSnippetObjectInfo =
    class
        inherit XmlCodeSnippetLiteralInfo
    end

The XmlCodeSnippetObjectInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetObjectInfo | Initializes a new instance of the XmlCodeSnippetObjectInfo class with default settings.
Public method | XmlCodeSnippetObjectInfo(ICodeSnippetObject) | Initializes a new instance of the XmlCodeSnippetObjectInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones. (Inherited from XmlCodeSnippetLiteralInfo.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use. (Inherited from XmlCodeSnippetLiteralInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Default | Stores ICodeSnippetLiteral.Default property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | Editable | Stores ICodeSnippetLiteral.Editable property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | Function | Stores ICodeSnippetLiteral.Function property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | ID | Stores ICodeSnippetLiteral.ID property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | SupportsCode | Stores ICodeSnippetLiteral.SupportsCode property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | ToolTip | Stores ICodeSnippetLiteral.ToolTip property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | Type | Stores ICodeSnippetLiteral.Type property. (Inherited from XmlCodeSnippetLiteralInfo.)
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetObjectInfo Constructor

XmlCodeSnippetObjectInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetObjectInfo | Initializes a new instance of the XmlCodeSnippetObjectInfo class with default settings.
Public method | XmlCodeSnippetObjectInfo(ICodeSnippetObject) | Initializes a new instance of the XmlCodeSnippetObjectInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetObjectInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetObjectInfo Constructor

XmlCodeSnippetObjectInfo Constructor
Initializes a new instance of the XmlCodeSnippetObjectInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetObjectInfo()
Public Sub New
public:
XmlCodeSnippetObjectInfo()
new : unit -> XmlCodeSnippetObjectInfo
See Also

Reference

XmlCodeSnippetObjectInfo Class
XmlCodeSnippetObjectInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetObjectInfo Constructor (ICodeSnippetObject)

XmlCodeSnippetObjectInfo Constructor (ICodeSnippetObject)
Initializes a new instance of the XmlCodeSnippetObjectInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetObjectInfo(
    ICodeSnippetObject owner
)
Public Sub New (
    owner As ICodeSnippetObject
)
public:
XmlCodeSnippetObjectInfo(
    ICodeSnippetObject^ owner
)
new :
        owner : ICodeSnippetObject -> XmlCodeSnippetObjectInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetObject
Specifies ICodeSnippetObject object to store settings.
See Also

Reference

XmlCodeSnippetObjectInfo Class
XmlCodeSnippetObjectInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetObjectInfo Methods

XmlCodeSnippetObjectInfo Methods

The XmlCodeSnippetObjectInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones. (Inherited from XmlCodeSnippetLiteralInfo.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use. (Inherited from XmlCodeSnippetLiteralInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetObjectInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetObjectInfo Properties

XmlCodeSnippetObjectInfo Properties

The XmlCodeSnippetObjectInfo type exposes the following members.

Properties
 | Name | Description
Public property | Default | Stores ICodeSnippetLiteral.Default property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | Editable | Stores ICodeSnippetLiteral.Editable property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | Function | Stores ICodeSnippetLiteral.Function property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | ID | Stores ICodeSnippetLiteral.ID property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | SupportsCode | Stores ICodeSnippetLiteral.SupportsCode property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | ToolTip | Stores ICodeSnippetLiteral.ToolTip property. (Inherited from XmlCodeSnippetLiteralInfo.)
Public property | Type | Stores ICodeSnippetLiteral.Type property. (Inherited from XmlCodeSnippetLiteralInfo.)
Top
See Also

Reference

XmlCodeSnippetObjectInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo Class

XmlCodeSnippetReferenceInfo Class
Contains information about ICodeSnippetReference object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetReferenceInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetReferenceInfo : ISerializationInfo
Public Class XmlCodeSnippetReferenceInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetReferenceInfo : ISerializationInfo
type XmlCodeSnippetReferenceInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetReferenceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetReferenceInfo | Initializes a new instance of the XmlCodeSnippetReferenceInfo class with default settings.
Public method | XmlCodeSnippetReferenceInfo(ICodeSnippetReference) | Initializes a new instance of the XmlCodeSnippetReferenceInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Assembly | Stores ICodeSnippetReference.Assembly property.
Public property | Url | Stores ICodeSnippetReference.Url property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo Constructor

XmlCodeSnippetReferenceInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetReferenceInfo | Initializes a new instance of the XmlCodeSnippetReferenceInfo class with default settings.
Public method | XmlCodeSnippetReferenceInfo(ICodeSnippetReference) | Initializes a new instance of the XmlCodeSnippetReferenceInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetReferenceInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo Constructor

XmlCodeSnippetReferenceInfo Constructor
Initializes a new instance of the XmlCodeSnippetReferenceInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetReferenceInfo()
Public Sub New
public:
XmlCodeSnippetReferenceInfo()
new : unit -> XmlCodeSnippetReferenceInfo
See Also

Reference

XmlCodeSnippetReferenceInfo Class
XmlCodeSnippetReferenceInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo Constructor (ICodeSnippetReference)

XmlCodeSnippetReferenceInfo Constructor (ICodeSnippetReference)
Initializes a new instance of the XmlCodeSnippetReferenceInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetReferenceInfo(
    ICodeSnippetReference owner
)
Public Sub New (
    owner As ICodeSnippetReference
)
public:
XmlCodeSnippetReferenceInfo(
    ICodeSnippetReference^ owner
)
new :
        owner : ICodeSnippetReference -> XmlCodeSnippetReferenceInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetReference
Specifies ICodeSnippetReference object to store settings.
See Also

Reference

XmlCodeSnippetReferenceInfo Class
XmlCodeSnippetReferenceInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo Methods

XmlCodeSnippetReferenceInfo Methods

The XmlCodeSnippetReferenceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetReferenceInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo.FixupReferences Method

XmlCodeSnippetReferenceInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetReferenceInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo.Load Method

XmlCodeSnippetReferenceInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetReferenceInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo Properties

XmlCodeSnippetReferenceInfo Properties

The XmlCodeSnippetReferenceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Stores ICodeSnippetReference.Assembly property.
Public property | Url | Stores ICodeSnippetReference.Url property.
Top
See Also

Reference

XmlCodeSnippetReferenceInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo.Assembly Property

XmlCodeSnippetReferenceInfoAssembly Property
Stores ICodeSnippetReference.Assembly property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Assembly { get; set; }
Public Property Assembly As String
    Get
    Set
public:
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}
member Assembly : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetReferenceInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetReferenceInfo.Url Property

XmlCodeSnippetReferenceInfoUrl Property
Stores ICodeSnippetReference.Url property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
member Url : string with get, set

Property Value

Type: String
See Also

Reference

XmlCodeSnippetReferenceInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetsInfo Class

XmlCodeSnippetsInfo Class
Contains information about ICodeSnippets object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetsInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetsInfo : ISerializationInfo
Public Class XmlCodeSnippetsInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetsInfo : ISerializationInfo
type XmlCodeSnippetsInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetsInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetsInfo | Initializes a new instance of the XmlCodeSnippetsInfo class with default settings.
Public method | XmlCodeSnippetsInfo(ICodeSnippets) | Initializes a new instance of the XmlCodeSnippetsInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Snippets | Stores ICodeSnippets indexer.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetsInfo Constructor

XmlCodeSnippetsInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetsInfo | Initializes a new instance of the XmlCodeSnippetsInfo class with default settings.
Public method | XmlCodeSnippetsInfo(ICodeSnippets) | Initializes a new instance of the XmlCodeSnippetsInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetsInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetsInfo Constructor

XmlCodeSnippetsInfo Constructor
Initializes a new instance of the XmlCodeSnippetsInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetsInfo()
Public Sub New
public:
XmlCodeSnippetsInfo()
new : unit -> XmlCodeSnippetsInfo
See Also

Reference

XmlCodeSnippetsInfo Class
XmlCodeSnippetsInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetsInfo Constructor (ICodeSnippets)

XmlCodeSnippetsInfo Constructor (ICodeSnippets)
Initializes a new instance of the XmlCodeSnippetsInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetsInfo(
    ICodeSnippets owner
)
Public Sub New (
    owner As ICodeSnippets
)
public:
XmlCodeSnippetsInfo(
    ICodeSnippets^ owner
)
new :
        owner : ICodeSnippets -> XmlCodeSnippetsInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippets
Specifies ICodeSnippets object to store settings.
See Also

Reference

XmlCodeSnippetsInfo Class
XmlCodeSnippetsInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetsInfo Methods

XmlCodeSnippetsInfo Methods

The XmlCodeSnippetsInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetsInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetsInfo.FixupReferences Method

XmlCodeSnippetsInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetsInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetsInfo.Load Method

XmlCodeSnippetsInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetsInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetsInfo Properties

XmlCodeSnippetsInfo Properties

The XmlCodeSnippetsInfo type exposes the following members.

Properties
 | Name | Description
Public property | Snippets | Stores ICodeSnippets indexer.
Top
See Also

Reference

XmlCodeSnippetsInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetsInfo.Snippets Property

XmlCodeSnippetsInfoSnippets Property
Stores ICodeSnippets indexer.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetInfo[] Snippets { get; set; }
Public Property Snippets As XmlCodeSnippetInfo()
    Get
    Set
public:
property array<XmlCodeSnippetInfo^>^ Snippets {
    array<XmlCodeSnippetInfo^>^ get ();
    void set (array<XmlCodeSnippetInfo^>^ value);
}
member Snippets : XmlCodeSnippetInfo[] with get, set

Property Value

Type: XmlCodeSnippetInfo
See Also

Reference

XmlCodeSnippetsInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetTypeInfo Class

XmlCodeSnippetTypeInfo Class
Contains information about ICodeSnippetType object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlCodeSnippetTypeInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlCodeSnippetTypeInfo : ISerializationInfo
Public Class XmlCodeSnippetTypeInfo
    Implements ISerializationInfo
public ref class XmlCodeSnippetTypeInfo : ISerializationInfo
type XmlCodeSnippetTypeInfo =
    class
        interface ISerializationInfo
    end

The XmlCodeSnippetTypeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeSnippetTypeInfo | Initializes a new instance of the XmlCodeSnippetTypeInfo class with default settings.
Public method | XmlCodeSnippetTypeInfo(ICodeSnippetType) | Initializes a new instance of the XmlCodeSnippetTypeInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SnippetType | Stores ICodeSnippetType.SnippetType property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlCodeSnippetTypeInfo Constructor

XmlCodeSnippetTypeInfo Constructor
Overload List
 | Name | Description
Public method | XmlCodeSnippetTypeInfo | Initializes a new instance of the XmlCodeSnippetTypeInfo class with default settings.
Public method | XmlCodeSnippetTypeInfo(ICodeSnippetType) | Initializes a new instance of the XmlCodeSnippetTypeInfo class with specified owner.
Top
See Also

Reference

XmlCodeSnippetTypeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetTypeInfo Constructor

XmlCodeSnippetTypeInfo Constructor
Initializes a new instance of the XmlCodeSnippetTypeInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetTypeInfo()
Public Sub New
public:
XmlCodeSnippetTypeInfo()
new : unit -> XmlCodeSnippetTypeInfo
See Also

Reference

XmlCodeSnippetTypeInfo Class
XmlCodeSnippetTypeInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetTypeInfo Constructor (ICodeSnippetType)

XmlCodeSnippetTypeInfo Constructor (ICodeSnippetType)
Initializes a new instance of the XmlCodeSnippetTypeInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlCodeSnippetTypeInfo(
    ICodeSnippetType owner
)
Public Sub New (
    owner As ICodeSnippetType
)
public:
XmlCodeSnippetTypeInfo(
    ICodeSnippetType^ owner
)
new :
        owner : ICodeSnippetType -> XmlCodeSnippetTypeInfo

Parameters

owner
Type: Alternet.Syntax.CodeCompletionICodeSnippetType
Specifies ICodeSnippetType object to store settings.
See Also

Reference

XmlCodeSnippetTypeInfo Class
XmlCodeSnippetTypeInfo Overload
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetTypeInfo Methods

XmlCodeSnippetTypeInfo Methods

The XmlCodeSnippetTypeInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlCodeSnippetTypeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetTypeInfo.FixupReferences Method

XmlCodeSnippetTypeInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlCodeSnippetTypeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetTypeInfo.Load Method

XmlCodeSnippetTypeInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlCodeSnippetTypeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetTypeInfo Properties

XmlCodeSnippetTypeInfo Properties

The XmlCodeSnippetTypeInfo type exposes the following members.

Properties
 | Name | Description
Public property | SnippetType | Stores ICodeSnippetType.SnippetType property.
Top
See Also

Reference

XmlCodeSnippetTypeInfo Class
Alternet.Syntax.Serialization Namespace


XmlCodeSnippetTypeInfo.SnippetType Property

XmlCodeSnippetTypeInfoSnippetType Property
Stores ICodeSnippetType.SnippetType property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public SnippetType SnippetType { get; set; }
Public Property SnippetType As SnippetType
    Get
    Set
public:
property SnippetType SnippetType {
    SnippetType get ();
    void set (SnippetType value);
}
member SnippetType : SnippetType with get, set

Property Value

Type: SnippetType
See Also

Reference

XmlCodeSnippetTypeInfo Class
Alternet.Syntax.Serialization Namespace


XmlColorInfo Class

XmlColorInfo Class
Represents methods to serialize color structure to XML.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlColorInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlColorInfo
Public Class XmlColorInfo
public ref class XmlColorInfo
type XmlColorInfo =  class end

The XmlColorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlColorInfo | Initializes a new instance of the XmlColorInfo class
Top
Methods
 | Name | Description
 | DeserializeColor | Deserializes specified string representation of color to Color structure.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | SerializeColor | Serializes specified color.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlColorInfo Constructor

XmlColorInfo Constructor
Initializes a new instance of the XmlColorInfo class

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlColorInfo()
Public Sub New
public:
XmlColorInfo()
new : unit -> XmlColorInfo
See Also

Reference

XmlColorInfo Class
Alternet.Syntax.Serialization Namespace


XmlColorInfo Methods

XmlColorInfo Methods

The XmlColorInfo type exposes the following members.

Methods
 | Name | Description
 | DeserializeColor | Deserializes specified string representation of color to Color structure.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | SerializeColor | Serializes specified color.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlColorInfo Class
Alternet.Syntax.Serialization Namespace


XmlColorInfo.DeserializeColor Method

XmlColorInfoDeserializeColor Method
Deserializes specified string representation of color to Color structure.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color DeserializeColor(
    string color
)
Public Shared Function DeserializeColor (
    color As String
) As Color
public:
static Color DeserializeColor(
    String^ color
)
static member DeserializeColor :
        color : string -> Color

Parameters

color
Type: SystemString
Specifies string to deserialize.

Return Value

Type: Color
Color structure obtained from string representation.
See Also

Reference

XmlColorInfo Class
Alternet.Syntax.Serialization Namespace


XmlColorInfo.SerializeColor Method

XmlColorInfoSerializeColor Method
Serializes specified color.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string SerializeColor(
    Color color
)
Public Shared Function SerializeColor (
    color As Color
) As String
public:
static String^ SerializeColor(
    Color color
)
static member SerializeColor :
        color : Color -> string

Parameters

color
Type: System.DrawingColor
Color to serialize.

Return Value

Type: String
String representation of given color.
See Also

Reference

XmlColorInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexerInfo Class

XmlLexerInfo Class
Contains information about ILexer object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlLexerInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlLexerInfo : ISerializationInfo
Public Class XmlLexerInfo
    Implements ISerializationInfo
public ref class XmlLexerInfo : ISerializationInfo
type XmlLexerInfo =
    class
        interface ISerializationInfo
    end

The XmlLexerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexerInfo | Initializes a new instance of the XmlLexerInfo class with default settings.
Public method | XmlLexerInfo(ILexer) | Initializes a new instance of the XmlLexerInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DefaultState | Stores ILexer.DefaultState property.
Public property | Scheme | Stores ILexer.Scheme property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlLexerInfo Constructor

XmlLexerInfo Constructor
Overload List
 | Name | Description
Public method | XmlLexerInfo | Initializes a new instance of the XmlLexerInfo class with default settings.
Public method | XmlLexerInfo(ILexer) | Initializes a new instance of the XmlLexerInfo class with specified owner.
Top
See Also

Reference

XmlLexerInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexerInfo Constructor

XmlLexerInfo Constructor
Initializes a new instance of the XmlLexerInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexerInfo()
Public Sub New
public:
XmlLexerInfo()
new : unit -> XmlLexerInfo
See Also

Reference

XmlLexerInfo Class
XmlLexerInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexerInfo Constructor (ILexer)

XmlLexerInfo Constructor (ILexer)
Initializes a new instance of the XmlLexerInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexerInfo(
    ILexer owner
)
Public Sub New (
    owner As ILexer
)
public:
XmlLexerInfo(
    ILexer^ owner
)
new :
        owner : ILexer -> XmlLexerInfo

Parameters

owner
Type: Alternet.Syntax.LexerILexer
Specifies ILexer object to store settings.
See Also

Reference

XmlLexerInfo Class
XmlLexerInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexerInfo Methods

XmlLexerInfo Methods

The XmlLexerInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlLexerInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexerInfo.FixupReferences Method

XmlLexerInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlLexerInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexerInfo.Load Method

XmlLexerInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlLexerInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexerInfo Properties

XmlLexerInfo Properties

The XmlLexerInfo type exposes the following members.

Properties
 | Name | Description
Public property | DefaultState | Stores ILexer.DefaultState property.
Public property | Scheme | Stores ILexer.Scheme property.
Top
See Also

Reference

XmlLexerInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexerInfo.DefaultState Property

XmlLexerInfoDefaultState Property
Stores ILexer.DefaultState property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DefaultState { get; set; }
Public Property DefaultState As Integer
    Get
    Set
public:
property int DefaultState {
    int get ();
    void set (int value);
}
member DefaultState : int with get, set

Property Value

Type: Int32
See Also

Reference

XmlLexerInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexerInfo.Scheme Property

XmlLexerInfoScheme Property
Stores ILexer.Scheme property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexSchemeInfo Scheme { get; set; }
Public Property Scheme As XmlLexSchemeInfo
    Get
    Set
public:
property XmlLexSchemeInfo^ Scheme {
    XmlLexSchemeInfo^ get ();
    void set (XmlLexSchemeInfo^ value);
}
member Scheme : XmlLexSchemeInfo with get, set

Property Value

Type: XmlLexSchemeInfo
See Also

Reference

XmlLexerInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo Class

XmlLexReswordSetInfo Class
Contains information about ILexReswordSet object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlLexReswordSetInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlLexReswordSetInfo : ISerializationInfo
Public Class XmlLexReswordSetInfo
    Implements ISerializationInfo
public ref class XmlLexReswordSetInfo : ISerializationInfo
type XmlLexReswordSetInfo =
    class
        interface ISerializationInfo
    end

The XmlLexReswordSetInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexReswordSetInfo | Initializes a new instance of the XmlLexReswordSetInfo class with default settings.
Public method | XmlLexReswordSetInfo(ILexReswordSet) | Initializes a new instance of the XmlLexReswordSetInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeReswords | Indicates whether the Reswords property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Stores ILexReswordSet.Name property.
Public property | Reswords | Stores ILexReswordSet.Reswords property.
Public property | ReswordStyle | Stores ILexReswordSet.ReswordStyle.Index property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo Constructor

XmlLexReswordSetInfo Constructor
Overload List
 | Name | Description
Public method | XmlLexReswordSetInfo | Initializes a new instance of the XmlLexReswordSetInfo class with default settings.
Public method | XmlLexReswordSetInfo(ILexReswordSet) | Initializes a new instance of the XmlLexReswordSetInfo class with specified owner.
Top
See Also

Reference

XmlLexReswordSetInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo Constructor

XmlLexReswordSetInfo Constructor
Initializes a new instance of the XmlLexReswordSetInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexReswordSetInfo()
Public Sub New
public:
XmlLexReswordSetInfo()
new : unit -> XmlLexReswordSetInfo
See Also

Reference

XmlLexReswordSetInfo Class
XmlLexReswordSetInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo Constructor (ILexReswordSet)

XmlLexReswordSetInfo Constructor (ILexReswordSet)
Initializes a new instance of the XmlLexReswordSetInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexReswordSetInfo(
    ILexReswordSet owner
)
Public Sub New (
    owner As ILexReswordSet
)
public:
XmlLexReswordSetInfo(
    ILexReswordSet^ owner
)
new :
        owner : ILexReswordSet -> XmlLexReswordSetInfo

Parameters

owner
Type: Alternet.Syntax.LexerILexReswordSet
Specifies ILexReswordSet object to store settings.
See Also

Reference

XmlLexReswordSetInfo Class
XmlLexReswordSetInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo Methods

XmlLexReswordSetInfo Methods

The XmlLexReswordSetInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeReswords | Indicates whether the Reswords property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlLexReswordSetInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo.FixupReferences Method

XmlLexReswordSetInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlLexReswordSetInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo.Load Method

XmlLexReswordSetInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlLexReswordSetInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo.ShouldSerializeReswords Method

XmlLexReswordSetInfoShouldSerializeReswords Method
Indicates whether the Reswords property should be persisted.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeReswords()
Public Function ShouldSerializeReswords As Boolean
public:
bool ShouldSerializeReswords()
member ShouldSerializeReswords : unit -> bool

Return Value

Type: Boolean
True if Reswords differs from its default value; otherwise false.
See Also

Reference

XmlLexReswordSetInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo Properties

XmlLexReswordSetInfo Properties

The XmlLexReswordSetInfo type exposes the following members.

Properties
 | Name | Description
Public property | Name | Stores ILexReswordSet.Name property.
Public property | Reswords | Stores ILexReswordSet.Reswords property.
Public property | ReswordStyle | Stores ILexReswordSet.ReswordStyle.Index property.
Top
See Also

Reference

XmlLexReswordSetInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo.Name Property

XmlLexReswordSetInfoName Property
Stores ILexReswordSet.Name property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexReswordSetInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo.Reswords Property

XmlLexReswordSetInfoReswords Property
Stores ILexReswordSet.Reswords property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string[] Reswords { get; set; }
Public Overridable Property Reswords As String()
    Get
    Set
public:
virtual property array<String^>^ Reswords {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
abstract Reswords : string[] with get, set
override Reswords : string[] with get, set

Property Value

Type: String
See Also

Reference

XmlLexReswordSetInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexReswordSetInfo.ReswordStyle Property

XmlLexReswordSetInfoReswordStyle Property
Stores ILexReswordSet.ReswordStyle.Index property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReswordStyle { get; set; }
Public Property ReswordStyle As Integer
    Get
    Set
public:
property int ReswordStyle {
    int get ();
    void set (int value);
}
member ReswordStyle : int with get, set

Property Value

Type: Int32
See Also

Reference

XmlLexReswordSetInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo Class

XmlLexSchemeInfo Class
Contains information about ILexScheme object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlLexSchemeInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlLexSchemeInfo : ISerializationInfo
Public Class XmlLexSchemeInfo
    Implements ISerializationInfo
public ref class XmlLexSchemeInfo : ISerializationInfo
type XmlLexSchemeInfo =
    class
        interface ISerializationInfo
    end

The XmlLexSchemeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexSchemeInfo | Initializes a new instance of the XmlLexSchemeInfo class with default settings.
Public method | XmlLexSchemeInfo(ILexScheme) | Initializes a new instance of the XmlLexSchemeInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeStates | Indicates whether the States property should be persisted.
Public method | ShouldSerializeStyles | Indicates whether the Styles property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Author | Stores ILexScheme.Author property.
Public property | Copyright | Stores ILexScheme.Copyright property.
Public property | Desc | Stores ILexScheme.Desc property.
Public property | FileExtension | Stores ILexScheme.FileExtension property.
Public property | FileType | Stores ILexScheme.FileType property.
Public property | Name | Stores ILexScheme.Name property.
Public property | States | Stores ILexScheme.States property.
Public property | Styles | Stores ILexScheme.Styles property.
Public property | Version | Stores ILexScheme.Version property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo Constructor

XmlLexSchemeInfo Constructor
Overload List
 | Name | Description
Public method | XmlLexSchemeInfo | Initializes a new instance of the XmlLexSchemeInfo class with default settings.
Public method | XmlLexSchemeInfo(ILexScheme) | Initializes a new instance of the XmlLexSchemeInfo class with specified owner.
Top
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo Constructor

XmlLexSchemeInfo Constructor
Initializes a new instance of the XmlLexSchemeInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexSchemeInfo()
Public Sub New
public:
XmlLexSchemeInfo()
new : unit -> XmlLexSchemeInfo
See Also

Reference

XmlLexSchemeInfo Class
XmlLexSchemeInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo Constructor (ILexScheme)

XmlLexSchemeInfo Constructor (ILexScheme)
Initializes a new instance of the XmlLexSchemeInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexSchemeInfo(
    ILexScheme owner
)
Public Sub New (
    owner As ILexScheme
)
public:
XmlLexSchemeInfo(
    ILexScheme^ owner
)
new :
        owner : ILexScheme -> XmlLexSchemeInfo

Parameters

owner
Type: Alternet.Syntax.LexerILexScheme
Specifies ILexScheme object to store settings.
See Also

Reference

XmlLexSchemeInfo Class
XmlLexSchemeInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo Methods

XmlLexSchemeInfo Methods

The XmlLexSchemeInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeStates | Indicates whether the States property should be persisted.
Public method | ShouldSerializeStyles | Indicates whether the Styles property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.FixupReferences Method

XmlLexSchemeInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.Load Method

XmlLexSchemeInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.ShouldSerializeStates Method

XmlLexSchemeInfoShouldSerializeStates Method
Indicates whether the States property should be persisted.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeStates()
Public Function ShouldSerializeStates As Boolean
public:
bool ShouldSerializeStates()
member ShouldSerializeStates : unit -> bool

Return Value

Type: Boolean
True if States differs from its default value; otherwise false.
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.ShouldSerializeStyles Method

XmlLexSchemeInfoShouldSerializeStyles Method
Indicates whether the Styles property should be persisted.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeStyles()
Public Function ShouldSerializeStyles As Boolean
public:
bool ShouldSerializeStyles()
member ShouldSerializeStyles : unit -> bool

Return Value

Type: Boolean
True if Styles differs from its default value; otherwise false.
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo Properties

XmlLexSchemeInfo Properties

The XmlLexSchemeInfo type exposes the following members.

Properties
 | Name | Description
Public property | Author | Stores ILexScheme.Author property.
Public property | Copyright | Stores ILexScheme.Copyright property.
Public property | Desc | Stores ILexScheme.Desc property.
Public property | FileExtension | Stores ILexScheme.FileExtension property.
Public property | FileType | Stores ILexScheme.FileType property.
Public property | Name | Stores ILexScheme.Name property.
Public property | States | Stores ILexScheme.States property.
Public property | Styles | Stores ILexScheme.Styles property.
Public property | Version | Stores ILexScheme.Version property.
Top
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.Author Property

XmlLexSchemeInfoAuthor Property
Stores ILexScheme.Author property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}
member Author : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.Copyright Property

XmlLexSchemeInfoCopyright Property
Stores ILexScheme.Copyright property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Copyright { get; set; }
Public Property Copyright As String
    Get
    Set
public:
property String^ Copyright {
    String^ get ();
    void set (String^ value);
}
member Copyright : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.Desc Property

XmlLexSchemeInfoDesc Property
Stores ILexScheme.Desc property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Desc { get; set; }
Public Property Desc As String
    Get
    Set
public:
property String^ Desc {
    String^ get ();
    void set (String^ value);
}
member Desc : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.FileExtension Property

XmlLexSchemeInfoFileExtension Property
Stores ILexScheme.FileExtension property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileExtension { get; set; }
Public Property FileExtension As String
    Get
    Set
public:
property String^ FileExtension {
    String^ get ();
    void set (String^ value);
}
member FileExtension : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.FileType Property

XmlLexSchemeInfoFileType Property
Stores ILexScheme.FileType property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileType { get; set; }
Public Property FileType As String
    Get
    Set
public:
property String^ FileType {
    String^ get ();
    void set (String^ value);
}
member FileType : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.Name Property

XmlLexSchemeInfoName Property
Stores ILexScheme.Name property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.States Property

XmlLexSchemeInfoStates Property
Stores ILexScheme.States property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexStateInfo[] States { get; set; }
Public Property States As XmlLexStateInfo()
    Get
    Set
public:
property array<XmlLexStateInfo^>^ States {
    array<XmlLexStateInfo^>^ get ();
    void set (array<XmlLexStateInfo^>^ value);
}
member States : XmlLexStateInfo[] with get, set

Property Value

Type: XmlLexStateInfo
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.Styles Property

XmlLexSchemeInfoStyles Property
Stores ILexScheme.Styles property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexStyleInfo[] Styles { get; set; }
Public Property Styles As XmlLexStyleInfo()
    Get
    Set
public:
property array<XmlLexStyleInfo^>^ Styles {
    array<XmlLexStyleInfo^>^ get ();
    void set (array<XmlLexStyleInfo^>^ value);
}
member Styles : XmlLexStyleInfo[] with get, set

Property Value

Type: XmlLexStyleInfo
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSchemeInfo.Version Property

XmlLexSchemeInfoVersion Property
Stores ILexScheme.Version property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexSchemeInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo Class

XmlLexStateInfo Class
Contains information about ILexState object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlLexStateInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlLexStateInfo : ISerializationInfo
Public Class XmlLexStateInfo
    Implements ISerializationInfo
public ref class XmlLexStateInfo : ISerializationInfo
type XmlLexStateInfo =
    class
        interface ISerializationInfo
    end

The XmlLexStateInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexStateInfo | Initializes a new instance of the XmlLexStateInfo class with default settings.
Public method | XmlLexStateInfo(ILexState) | Initializes a new instance of the XmlLexStateInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeSyntaxBlocks | Indicates whether the SyntaxBlocks property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CaseSensitive | Stores ILexState.CaseSensitive property.
Public property | Desc | Stores ILexState.Desc property.
Public property | Name | Stores ILexState.Name property.
Public property | SyntaxBlocks | Stores ILexState.SyntaxBlocks property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlLexStateInfo Constructor

XmlLexStateInfo Constructor
Overload List
 | Name | Description
Public method | XmlLexStateInfo | Initializes a new instance of the XmlLexStateInfo class with default settings.
Public method | XmlLexStateInfo(ILexState) | Initializes a new instance of the XmlLexStateInfo class with specified owner.
Top
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo Constructor

XmlLexStateInfo Constructor
Initializes a new instance of the XmlLexStateInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexStateInfo()
Public Sub New
public:
XmlLexStateInfo()
new : unit -> XmlLexStateInfo
See Also

Reference

XmlLexStateInfo Class
XmlLexStateInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo Constructor (ILexState)

XmlLexStateInfo Constructor (ILexState)
Initializes a new instance of the XmlLexStateInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexStateInfo(
    ILexState owner
)
Public Sub New (
    owner As ILexState
)
public:
XmlLexStateInfo(
    ILexState^ owner
)
new :
        owner : ILexState -> XmlLexStateInfo

Parameters

owner
Type: Alternet.Syntax.LexerILexState
Specifies ILexState object to store settings.
See Also

Reference

XmlLexStateInfo Class
XmlLexStateInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo Methods

XmlLexStateInfo Methods

The XmlLexStateInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeSyntaxBlocks | Indicates whether the SyntaxBlocks property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo.FixupReferences Method

XmlLexStateInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo.Load Method

XmlLexStateInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo.ShouldSerializeSyntaxBlocks Method

XmlLexStateInfoShouldSerializeSyntaxBlocks Method
Indicates whether the SyntaxBlocks property should be persisted.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeSyntaxBlocks()
Public Function ShouldSerializeSyntaxBlocks As Boolean
public:
bool ShouldSerializeSyntaxBlocks()
member ShouldSerializeSyntaxBlocks : unit -> bool

Return Value

Type: Boolean
True if SyntaxBlocks differs from its default value; otherwise false.
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo Properties

XmlLexStateInfo Properties

The XmlLexStateInfo type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Stores ILexState.CaseSensitive property.
Public property | Desc | Stores ILexState.Desc property.
Public property | Name | Stores ILexState.Name property.
Public property | SyntaxBlocks | Stores ILexState.SyntaxBlocks property.
Top
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo.CaseSensitive Property

XmlLexStateInfoCaseSensitive Property
Stores ILexState.CaseSensitive property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
    Get
    Set
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
member CaseSensitive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo.Desc Property

XmlLexStateInfoDesc Property
Stores ILexState.Desc property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Desc { get; set; }
Public Property Desc As String
    Get
    Set
public:
property String^ Desc {
    String^ get ();
    void set (String^ value);
}
member Desc : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo.Name Property

XmlLexStateInfoName Property
Stores ILexState.Name property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStateInfo.SyntaxBlocks Property

XmlLexStateInfoSyntaxBlocks Property
Stores ILexState.SyntaxBlocks property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexSyntaxBlockInfo[] SyntaxBlocks { get; set; }
Public Property SyntaxBlocks As XmlLexSyntaxBlockInfo()
    Get
    Set
public:
property array<XmlLexSyntaxBlockInfo^>^ SyntaxBlocks {
    array<XmlLexSyntaxBlockInfo^>^ get ();
    void set (array<XmlLexSyntaxBlockInfo^>^ value);
}
member SyntaxBlocks : XmlLexSyntaxBlockInfo[] with get, set

Property Value

Type: XmlLexSyntaxBlockInfo
See Also

Reference

XmlLexStateInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo Class

XmlLexStyleInfo Class
Contains information about ILexStyle object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlLexStyleInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlLexStyleInfo : ISerializationInfo
Public Class XmlLexStyleInfo
    Implements ISerializationInfo
public ref class XmlLexStyleInfo : ISerializationInfo
type XmlLexStyleInfo =
    class
        interface ISerializationInfo
    end

The XmlLexStyleInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexStyleInfo | Initializes a new instance of the XmlLexStyleInfo class with default settings.
Public method | XmlLexStyleInfo(ILexStyle) | Initializes a new instance of the XmlLexStyleInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BackColor | Stores ILexStyle.BackColor property.
Public property | BackColorEnabled | Stores ILexStyle.BackColorEnabled property.
Public property | BoldEnabled | Stores ILexStyle.BoldEnabled property.
Public property | Desc | Stores ILexStyle.Desc property.
Public property | FontStyle | Stores ILexStyle.FontStyle property.
Public property | ForeColor | Stores ILexStyle.ForeColor property.
Public property | ForeColorEnabled | Stores ILexStyle.ForeColorEnabled property.
Public property | ItalicEnabled | Stores ILexStyle.ItalicEnabled property.
Public property | Name | Stores ILexStyle.Name property.
Public property | PlainText | Stores ILexStyle.PlainText property.
Public property | UnderlineEnabled | Stores ILexStyle.UnderlineEnabled property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo Constructor

XmlLexStyleInfo Constructor
Overload List
 | Name | Description
Public method | XmlLexStyleInfo | Initializes a new instance of the XmlLexStyleInfo class with default settings.
Public method | XmlLexStyleInfo(ILexStyle) | Initializes a new instance of the XmlLexStyleInfo class with specified owner.
Top
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo Constructor

XmlLexStyleInfo Constructor
Initializes a new instance of the XmlLexStyleInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexStyleInfo()
Public Sub New
public:
XmlLexStyleInfo()
new : unit -> XmlLexStyleInfo
See Also

Reference

XmlLexStyleInfo Class
XmlLexStyleInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo Constructor (ILexStyle)

XmlLexStyleInfo Constructor (ILexStyle)
Initializes a new instance of the XmlLexStyleInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexStyleInfo(
    ILexStyle owner
)
Public Sub New (
    owner As ILexStyle
)
public:
XmlLexStyleInfo(
    ILexStyle^ owner
)
new :
        owner : ILexStyle -> XmlLexStyleInfo

Parameters

owner
Type: Alternet.Syntax.LexerILexStyle
Specifies ILexStyle object to store settings.
See Also

Reference

XmlLexStyleInfo Class
XmlLexStyleInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo Methods

XmlLexStyleInfo Methods

The XmlLexStyleInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.FixupReferences Method

XmlLexStyleInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.Load Method

XmlLexStyleInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo Properties

XmlLexStyleInfo Properties

The XmlLexStyleInfo type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Stores ILexStyle.BackColor property.
Public property | BackColorEnabled | Stores ILexStyle.BackColorEnabled property.
Public property | BoldEnabled | Stores ILexStyle.BoldEnabled property.
Public property | Desc | Stores ILexStyle.Desc property.
Public property | FontStyle | Stores ILexStyle.FontStyle property.
Public property | ForeColor | Stores ILexStyle.ForeColor property.
Public property | ForeColorEnabled | Stores ILexStyle.ForeColorEnabled property.
Public property | ItalicEnabled | Stores ILexStyle.ItalicEnabled property.
Public property | Name | Stores ILexStyle.Name property.
Public property | PlainText | Stores ILexStyle.PlainText property.
Public property | UnderlineEnabled | Stores ILexStyle.UnderlineEnabled property.
Top
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.BackColor Property

XmlLexStyleInfoBackColor Property
Stores ILexStyle.BackColor property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BackColor { get; set; }
Public Property BackColor As String
    Get
    Set
public:
property String^ BackColor {
    String^ get ();
    void set (String^ value);
}
member BackColor : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.BackColorEnabled Property

XmlLexStyleInfoBackColorEnabled Property
Stores ILexStyle.BackColorEnabled property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BackColorEnabled { get; set; }
Public Property BackColorEnabled As Boolean
    Get
    Set
public:
property bool BackColorEnabled {
    bool get ();
    void set (bool value);
}
member BackColorEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.BoldEnabled Property

XmlLexStyleInfoBoldEnabled Property
Stores ILexStyle.BoldEnabled property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BoldEnabled { get; set; }
Public Property BoldEnabled As Boolean
    Get
    Set
public:
property bool BoldEnabled {
    bool get ();
    void set (bool value);
}
member BoldEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.Desc Property

XmlLexStyleInfoDesc Property
Stores ILexStyle.Desc property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Desc { get; set; }
Public Property Desc As String
    Get
    Set
public:
property String^ Desc {
    String^ get ();
    void set (String^ value);
}
member Desc : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.FontStyle Property

XmlLexStyleInfoFontStyle Property
Stores ILexStyle.FontStyle property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public FontStyle FontStyle { get; set; }
Public Property FontStyle As FontStyle
    Get
    Set
public:
property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
member FontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.ForeColor Property

XmlLexStyleInfoForeColor Property
Stores ILexStyle.ForeColor property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ForeColor { get; set; }
Public Property ForeColor As String
    Get
    Set
public:
property String^ ForeColor {
    String^ get ();
    void set (String^ value);
}
member ForeColor : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.ForeColorEnabled Property

XmlLexStyleInfoForeColorEnabled Property
Stores ILexStyle.ForeColorEnabled property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ForeColorEnabled { get; set; }
Public Property ForeColorEnabled As Boolean
    Get
    Set
public:
property bool ForeColorEnabled {
    bool get ();
    void set (bool value);
}
member ForeColorEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.ItalicEnabled Property

XmlLexStyleInfoItalicEnabled Property
Stores ILexStyle.ItalicEnabled property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ItalicEnabled { get; set; }
Public Property ItalicEnabled As Boolean
    Get
    Set
public:
property bool ItalicEnabled {
    bool get ();
    void set (bool value);
}
member ItalicEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.Name Property

XmlLexStyleInfoName Property
Stores ILexStyle.Name property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.PlainText Property

XmlLexStyleInfoPlainText Property
Stores ILexStyle.PlainText property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PlainText { get; set; }
Public Property PlainText As Boolean
    Get
    Set
public:
property bool PlainText {
    bool get ();
    void set (bool value);
}
member PlainText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexStyleInfo.UnderlineEnabled Property

XmlLexStyleInfoUnderlineEnabled Property
Stores ILexStyle.UnderlineEnabled property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UnderlineEnabled { get; set; }
Public Property UnderlineEnabled As Boolean
    Get
    Set
public:
property bool UnderlineEnabled {
    bool get ();
    void set (bool value);
}
member UnderlineEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XmlLexStyleInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo Class

XmlLexSyntaxBlockInfo Class
Contains information about ILexSyntaxBlock object's settings.
Inheritance Hierarchy
SystemObject
Alternet.Syntax.SerializationXmlLexSyntaxBlockInfo

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XmlLexSyntaxBlockInfo : ISerializationInfo
Public Class XmlLexSyntaxBlockInfo
    Implements ISerializationInfo
public ref class XmlLexSyntaxBlockInfo : ISerializationInfo
type XmlLexSyntaxBlockInfo =
    class
        interface ISerializationInfo
    end

The XmlLexSyntaxBlockInfo type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexSyntaxBlockInfo | Initializes a new instance of the XmlLexSyntaxBlockInfo class with default settings.
Public method | XmlLexSyntaxBlockInfo(ILexSyntaxBlock) | Initializes a new instance of the XmlLexSyntaxBlockInfo class with specified owner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeExpressions | Indicates whether the Expressions property should be persisted.
Public method | ShouldSerializeReswordSets | Indicates whether the ReswordSets property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Desc | Stores ILexSyntaxBlock.Desc property.
Public property | Expressions | Stores ILexSyntaxBlock.Expressions property.
Public property | LeaveState | Stores ILexSyntaxBlock.LeaveState property.
Public property | LexStyle | Stores ILexSyntaxBlock.LexStyle property.
Public property | Name | Stores ILexSyntaxBlock.Name property.
Public property | ReswordSets | Stores ILexSyntaxBlock.ReswordSets property.
Top
See Also

Reference

Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo Constructor

XmlLexSyntaxBlockInfo Constructor
Overload List
 | Name | Description
Public method | XmlLexSyntaxBlockInfo | Initializes a new instance of the XmlLexSyntaxBlockInfo class with default settings.
Public method | XmlLexSyntaxBlockInfo(ILexSyntaxBlock) | Initializes a new instance of the XmlLexSyntaxBlockInfo class with specified owner.
Top
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo Constructor

XmlLexSyntaxBlockInfo Constructor
Initializes a new instance of the XmlLexSyntaxBlockInfo class with default settings.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexSyntaxBlockInfo()
Public Sub New
public:
XmlLexSyntaxBlockInfo()
new : unit -> XmlLexSyntaxBlockInfo
See Also

Reference

XmlLexSyntaxBlockInfo Class
XmlLexSyntaxBlockInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo Constructor (ILexSyntaxBlock)

XmlLexSyntaxBlockInfo Constructor (ILexSyntaxBlock)
Initializes a new instance of the XmlLexSyntaxBlockInfo class with specified owner.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexSyntaxBlockInfo(
    ILexSyntaxBlock owner
)
Public Sub New (
    owner As ILexSyntaxBlock
)
public:
XmlLexSyntaxBlockInfo(
    ILexSyntaxBlock^ owner
)
new :
        owner : ILexSyntaxBlock -> XmlLexSyntaxBlockInfo

Parameters

owner
Type: Alternet.Syntax.LexerILexSyntaxBlock
Specifies ILexSyntaxBlock object to store settings.
See Also

Reference

XmlLexSyntaxBlockInfo Class
XmlLexSyntaxBlockInfo Overload
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo Methods

XmlLexSyntaxBlockInfo Methods

The XmlLexSyntaxBlockInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FixupReferences | Updates properties of external object with stored ones.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Reads property values from external object. Reserved for internal use.
Public method | ShouldSerializeExpressions | Indicates whether the Expressions property should be persisted.
Public method | ShouldSerializeReswordSets | Indicates whether the ReswordSets property should be persisted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.FixupReferences Method

XmlLexSyntaxBlockInfoFixupReferences Method
Updates properties of external object with stored ones.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void FixupReferences(
    Object owner
)
Public Overridable Sub FixupReferences (
    owner As Object
)
public:
virtual void FixupReferences(
    Object^ owner
)
abstract FixupReferences :
        owner : Object -> unit
override FixupReferences :
        owner : Object -> unit

Parameters

owner
Type: SystemObject
Specifies external object.

Implements

ISerializationInfoFixupReferences(Object)
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.Load Method

XmlLexSyntaxBlockInfoLoad Method
Reads property values from external object. Reserved for internal use.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()
abstract Load : unit -> unit
override Load : unit -> unit

Implements

ISerializationInfoLoad
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.ShouldSerializeExpressions Method

XmlLexSyntaxBlockInfoShouldSerializeExpressions Method
Indicates whether the Expressions property should be persisted.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeExpressions()
Public Function ShouldSerializeExpressions As Boolean
public:
bool ShouldSerializeExpressions()
member ShouldSerializeExpressions : unit -> bool

Return Value

Type: Boolean
True if Expressions differs from its default value; otherwise false.
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.ShouldSerializeReswordSets Method

XmlLexSyntaxBlockInfoShouldSerializeReswordSets Method
Indicates whether the ReswordSets property should be persisted.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSerializeReswordSets()
Public Function ShouldSerializeReswordSets As Boolean
public:
bool ShouldSerializeReswordSets()
member ShouldSerializeReswordSets : unit -> bool

Return Value

Type: Boolean
True if ReswordSets differs from its default value; otherwise false.
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo Properties

XmlLexSyntaxBlockInfo Properties

The XmlLexSyntaxBlockInfo type exposes the following members.

Properties
 | Name | Description
Public property | Desc | Stores ILexSyntaxBlock.Desc property.
Public property | Expressions | Stores ILexSyntaxBlock.Expressions property.
Public property | LeaveState | Stores ILexSyntaxBlock.LeaveState property.
Public property | LexStyle | Stores ILexSyntaxBlock.LexStyle property.
Public property | Name | Stores ILexSyntaxBlock.Name property.
Public property | ReswordSets | Stores ILexSyntaxBlock.ReswordSets property.
Top
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.Desc Property

XmlLexSyntaxBlockInfoDesc Property
Stores ILexSyntaxBlock.Desc property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Desc { get; set; }
Public Property Desc As String
    Get
    Set
public:
property String^ Desc {
    String^ get ();
    void set (String^ value);
}
member Desc : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.Expressions Property

XmlLexSyntaxBlockInfoExpressions Property
Stores ILexSyntaxBlock.Expressions property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Expressions { get; set; }
Public Property Expressions As String()
    Get
    Set
public:
property array<String^>^ Expressions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Expressions : string[] with get, set

Property Value

Type: String
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.LeaveState Property

XmlLexSyntaxBlockInfoLeaveState Property
Stores ILexSyntaxBlock.LeaveState property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LeaveState { get; set; }
Public Property LeaveState As Integer
    Get
    Set
public:
property int LeaveState {
    int get ();
    void set (int value);
}
member LeaveState : int with get, set

Property Value

Type: Int32
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.LexStyle Property

XmlLexSyntaxBlockInfoLexStyle Property
Stores ILexSyntaxBlock.LexStyle property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LexStyle { get; set; }
Public Property LexStyle As Integer
    Get
    Set
public:
property int LexStyle {
    int get ();
    void set (int value);
}
member LexStyle : int with get, set

Property Value

Type: Int32
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.Name Property

XmlLexSyntaxBlockInfoName Property
Stores ILexSyntaxBlock.Name property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace


XmlLexSyntaxBlockInfo.ReswordSets Property

XmlLexSyntaxBlockInfoReswordSets Property
Stores ILexSyntaxBlock.ReswordSets property.

Namespace: Alternet.Syntax.Serialization
Assemblies: Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Alternet.Syntax.v7 (in Alternet.Syntax.v7.dll) Version: 7.1 (Release build 7.1.0.0)
Syntax
C#
VB
C++
F#
Copy
public XmlLexReswordSetInfo[] ReswordSets { get; set; }
Public Property ReswordSets As XmlLexReswordSetInfo()
    Get
    Set
public:
property array<XmlLexReswordSetInfo^>^ ReswordSets {
    array<XmlLexReswordSetInfo^>^ get ();
    void set (array<XmlLexReswordSetInfo^>^ value);
}
member ReswordSets : XmlLexReswordSetInfo[] with get, set

Property Value

Type: XmlLexReswordSetInfo
See Also

Reference

XmlLexSyntaxBlockInfo Class
Alternet.Syntax.Serialization Namespace